About BEMCLI Cmdlets

Backup Exec Management Command Line Interface Help
About BEMCLI Cmdlets
トピック
    about_BEMCLI_Cmdlets

短い説明
    Provides information about the Backup Exec Management Command Line
    Interface

LONG DESCRIPTION
    このトピックでは、Backup Exec 管理コマンドラインインターフェース（BEMCLI）を使うための必要条件と、
    BEMCLI、BEMCLI コマンド、BEMCLI コマンドの説明をロードする方法に関する情報を提供します。また、
    Windows PowerShell の詳細情報へのリンクも示します。

Backup Exec 管理コマンドラインインターフェースについて
    Backup Exec 管理コマンドラインインターフェース（BEMCLI）を使うと、Backup Exec
    の最も便利な機能の一部を簡単に自動化できます。BEMCLI モジュールには、
    Backup Exec のほとんどの機能とユーティリティを、Windows PowerShell
    コンソールで実行するコマンドが含まれています。

    BEMCLI は、BEMCLI がインストールされた Backup Exec サーバーで実行します。
    リモートコンピュータから BEMCLI を実行するには、PowerShell のリモート機能を使います。
    詳しくは、Get-Help about_remote の情報を参照してください。

Backup Exec 管理コマンドラインインターフェースの必要条件
    BEMCLI を実行するための必要条件:

    - Windows PowerShell V2

    - .NET 3.5

    - PowerShell の実行ポリシーの値が、Restricted
      よりも低い制限になっている必要があります（AllSigned など）。
      詳しくは、Get-Help Set-ExecutionPolicy の情報を参照してください。

Backup Exec 管理コマンドラインインターフェースの使用
    Backup Exec 管理コマンドラインインターフェース（BEMCLI）は、Backup Exec
    と一緒にインストールされます。BEMCLI を開くには、次のいずれかの操作を行います。

    - Backup Exec がインストールされているコンピュータでのタスクバーで、［スタート］>
      ［すべてのプログラム］>［Veritas Backup Exec］>［Backup Exec
      管理コマンドラインインターフェース］の順にクリックします。

    - Backup Exec がインストールされているコンピュータで PowerShell を起動し、
      次に Import-Module BEMCLI と入力します。

よく使われる Backup Exec コマンドライン操作

  アラート監視

    すべてのアクティブな情報アラートを消去するには、次のように入力します:
    [Get-BEAlert -Severity Information | Clear-BEAlert -Response Ok]

    すべてのアクティブエラーアラートの数を表示するには、次のように入力します:
    [@(Get-BEAlert -Severity Error).Count]

    指定したサーバーに対するアラートのリストを表示するには、次のように入力します:
    [Get-BEAgentServer <FQDN サーバー名> | Get-BEAlert]

  ジョブ監視

    既存のジョブを開始して完了を待機するには、次のように入力します:
    [Start-BEJob <ジョブ名> | Wait-BEJob]

    ジョブの最終実行のジョブログを表示するには、次のように入力します:
    Get-BEJob <job name> | Get-BEJobHistory | Select-Object -Last 1 | Get-BEJob
    Log

    指定したサーバーのジョブ履歴を表示するには、次のように入力します:
    Get-BEAgentServer <FQDN server name> | Get-BEJobHistory

  デバイス管理

    ディスクベースのストレージデバイスプールを作成するには、次のように入力します:
    New-BEStoragePool -Name <desired storage pool name> -StoragePoolType Disk

    指定したボリュームに新しいディスクベースのストレージを作成するには、次のように入力します:
    New-BEDiskStorageDevice -Name <disk storage name> -DriveLetter <drive lette
    r:>

    ストレージデバイスプールにディスクベースのストレージを追加するには、次のように入力します:
    Get-BEStoragePool -Name <storage pool name> | Add-BEMemberToDiskStoragePool
     -DiskStorageDevice <disk storage name>

  バックアップ

    サーバー全体の 1 回限りのバックアップジョブを作成して完了を待機するには、次のように入力します:
    Get-BEAgentServer <FQDN server name> | Submit-BEOnetimeBackupJob | Wait-BEJ
    ob

    サーバー上の特定のディレクトリの 1 回限りのバックアップジョブを作成するには、次のように入力します:
    Get-BEAgentServer <FQDN server name> | Submit-BEOnetimeBackupJob -FileSyste
    mSelection <drive letter:>\<directory name>\*

    指定したボリュームを除く、サーバー全体の 1 回限りのバックアップジョブを作成するには、次のように入力します:
    $exclude = New-BEFileSystemSelection <drive letter:>\* -Recurse -Exclude
    Get-BEAgentServer <FQDN server name> | Submit-BEOnetimeBackupJob -FileSyste
    mSelection $exclude

    サーバーのシステム状態についての 1 回限りのバックアップジョブを作成するには、次のように入力します:
    Get-BEAgentServer <FQDN server name> | Submit-BEOnetimeBackupJob -SystemSta
    teSelection Include

  リストア

    サーバーの最新バックアップから特定のファイルをリストアしてジョブの完了を待機するには、次のように入力します:
    Get-BEAgentServer <FQDN server name> | Submit-BEFileSystemRestoreJob <drive
     letter:>\<directory name>\<filename> | Wait-BEJob

    特定時点の最新バックアップから特定のファイルをリストアするには、次のように入力します:
    Get-BEAgentServer <FQDN server name> | Submit-BEFileSystemRestoreJob <drive
     letter:>\<directory name>\<filename> -PointInTime "<date>"

    ジョブの最後の実行から特定のファイルを復元するには、次のように入力します:
    Get-BEJob <job name> | Get-BEJobHistory | Select-Object -First 1 | Submit-B
    EFileSystemRestoreJob <drive letter:>\<directory name>\<filename>

関連項目
    Windows PowerShell の導入ガイド:
        http://msdn.microsoft.com/en-us/library/aa973757(v=vs.85).aspx
    Windows Powershell V2 ダウンロード::
        http://support.microsoft.com/kb/968929
    Set-ExecutionPolicy
    Import-Module
    about_remote
    Get-BEAlert
    Clear-BEAlert
    Get-BEAgentServer
    New-BEStoragePool
    New-BEDiskStorageDevice
    Add-BEMemberToDiskStoragePool
    Start-BEJob
    Wait-BEJob
    Get-BEJobHistory
    Get-BEJobLog
    Submit-BEOnetimeBackupJob
    Submit-BEFileSystemRestoreJob

キーワード
    about_BackupExec


Add-BEAgentServerToAgentServerGroup Help

Add-BEAgentServerToAgentServerGroup Cmdlet
Synopsis

エージェントサーバーグループにエージェントサーバーを追加します。

Syntax
Add-BEAgentServerToAgentServerGroup -InputObject <BEAgentServerGroup[]> [-AgentServer] <BEAgentServer[]> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

エージェントサーバーグループにエージェントサーバーを追加します。

エージェントサーバーは 1 つ以上のサーバーグループに属することができます。

Parameters

-AgentServer <BEAgentServer[]>

エージェントサーバーグループに追加する AgentServer を指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEAgentServerGroup[]>

1 つ以上のエージェントサーバーグループオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEAgentServerGroup

Backup Exec エージェントサーバーグループオブジェクトを Add-BEAgentServerToAgentServerGroup にパイプ処理できます。

Return Value
BackupExec.Managment.CLI.BEAgentServer

Add-BEAgentServerToAgentServerGroup は追加されたエージェントサーバーを表すオブジェクトを返します。

Example

C:\PS> New-BEAgentServerGroup "Windows"
C:\PS> Get-BEAgentServer "Win*" | Add-BEAgentServerToAgentServerGroup "Windows"

これらのコマンドは「Windows」というグループを作成し、パターン「Win*」に一致するすべてのエージェントサーバーを「Windows」エージェントサーバーグループに追加します。

Related Links


Add-BEBackupExecServerToCloudStorageDevice Help

Add-BEBackupExecServerToCloudStorageDevice Cmdlet
Synopsis

Backup Exec サーバーにクラウドストレージデバイスを追加します。

Syntax
Add-BEBackupExecServerToCloudStorageDevice [-BackupExecServer] <BEBackupExecServer[]> [-CloudStorageDevice] <BECloudStorageDevice> [-Force <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec サーバーにクラウドストレージデバイスを追加します。

Parameters

-CloudStorageDevice <BECloudStorageDevice>

Backup Exec サーバーに追加するクラウドストレージデバイスを指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer[]>

クラウドストレージデバイスを追加する Backup Exec サーバーを 1 つ以上指定します。

Required | true
Position | 1
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Force <SwitchParameter>

Add-BEBackupExecServerToCloudStorageDevice がこの Backup Exec サーバーをこのデバイスに追加することは、サーバーにこのデバイスの推奨環境がない場合でも、可能であることを確認します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトを Add-BEBackupExecServerToCloudStorageDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BECloudStorageDevice

Add-BEBackupExecServerToCloudStorageDevice はクラウドストレージデバイスを表すオブジェクトを返します。

Example

C:\PS> $Device = Get-BECloudStorageDevice -Name "Cloud"
C:\PS> Get-BEBackupExecServer -Name "My-MMS" | Add-BEBackupExecServerToCloudStorageDevice -CloudStorageDevice $Device

このコマンドは「Cloud」という名前のクラウドストレージデバイスを Backup Exec サーバー「My-MMS」に追加します。

Related Links


Add-BEBackupExecServerToDeduplicationDiskStorageDevice Help

Add-BEBackupExecServerToDeduplicationDiskStorageDevice Cmdlet
Synopsis

Backup Exec サーバーに重複排除ディスクストレージデバイスを追加します。

Syntax
Add-BEBackupExecServerToDeduplicationDiskStorageDevice [-BackupExecServer] <BEBackupExecServer[]> [-DeduplicationDiskStorageDevice] <BEDeduplicationDiskStorageDevice> [-Force <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec サーバーに重複排除ディスクストレージデバイスを追加します。

Parameters

-DeduplicationDiskStorageDevice <BEDeduplicationDiskStorageDevice>

Backup Exec サーバーに追加する重複排除ディスクストレージデバイスを指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer[]>

重複排除用ディスクストレージを追加する Backup Exec サーバーを 1 つ以上指定します。Get-BEBackupExecServer を参照してください。

Required | true
Position | 1
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Force <SwitchParameter>

Add-BEBackupExecServerToDeduplicationDiskStorageDevice がこの Backup Exec サーバーをこのデバイスに追加することが、サーバーにこのデバイスの推奨環境がない場合でも続行可能であることを確認します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトを Add-BEBackupExecServerToDeduplicationDiskStorageDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEDeduplicationDiskStorageDevice

Add-BEBackupExecServerToDeduplicationDiskStorageDevice は重複排除用ディスクストレージを表すオブジェクトを返します。

Example

C:\PS> $Device = Get-BEDeduplicationDiskStorageDevice -Name "DedupeDevice"
C:\PS>
Get-BEBackupExecServer -Name "My-MMS" | Add-BEBackupExecServerToDeduplicationDiskStorageDevice -DeduplicationDiskStorageDevice $Device

このコマンドは「DedupeDevice」という名前の重複排除用ディスクストレージデバイスを Backup Exec サーバー「My-MMS」に追加します。

Related Links


Add-BEBackupExecServerToDiskStorageDevice Help

Add-BEBackupExecServerToDiskStorageDevice Cmdlet
Synopsis

Backup Exec サーバーにディスクベースのストレージデバイスを追加します。

Syntax
Add-BEBackupExecServerToDiskStorageDevice [-BackupExecServer] <BEBackupExecServer[]> [-DiskStorageDevice] <BEDiskStorageDevice> [[-StoragePath] <String>] [-Force <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec サーバーにディスクベースのストレージデバイスを追加します。

Parameters

-DiskStorageDevice <BEDiskStorageDevice>

Backup Exec サーバーに追加するディスクベースのストレージデバイスを指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-StoragePath <String>

ストレージボリュームのパスを指定します。 デバイスがすでに正常に共有されている場合、これは必要ありません。

Required | false
Position | 2
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer[]>

ディスクベースのストレージデバイスを追加する Backup Exec サーバーを 1 つ以上指定します。

Required | true
Position | 1
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Force <SwitchParameter>

Add-BEBackupExecServerToDiskStorageDevice がこの Backup Exec サーバーをこのデバイスに追加することは、サーバーにこのデバイスの推奨環境がない場合でも、可能であることを確認します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトを Add-BEBackupExecServerToDiskStorageDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEDiskStorageDevice

Add-BEBackupExecServerToDiskStorageDevice はディスクベースのストレージデバイスを表すオブジェクトを返します。

Examples

Example 1

C:\PS> $Device = Get-BEDiskStorageDevice -Name "DiskDevice"
C:\PS> Get-BEBackupExecServer -Name "My-MMS" | Add-BEBackupExecServerToDiskStorageDevice -DiskStorageDevice $Device -StoragePath '\\My-CAS\BEData'

このコマンドは共有されていない、「DiskDevice」という名前のディスクベースのストレージデバイスを Backup Exec サーバー「My-MMS」に追加します。

Example 2
C:\PS> $Device = Get-BEDiskStorageDevice -Name "DiskDevice"
C:\PS> Get-BEBackupExecServer -Name "My-MMS" | Add-BEBackupExecServerToDiskStorageDevice -DiskStorageDevice $Device

このコマンドは共有されていない、「DiskDevice」という名前のディスクベースのストレージデバイスを Backup Exec サーバー「My-MMS」に追加します。

Related Links


Add-BEBackupExecServerToLegacyBackupToDiskFolderDevice Help

Add-BEBackupExecServerToLegacyBackupToDiskFolderDevice Cmdlet
Synopsis

Backup Exec サーバーにレガシーのディスクへのバックアップフォルダを追加します。

Syntax
Add-BEBackupExecServerToLegacyBackupToDiskFolderDevice [-BackupExecServer] <BEBackupExecServer[]> [-LegacyBackupToDiskFolderDevice] <BELegacyBackupToDiskFolderDevice> [[-StoragePath] <String>] [-Force <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec サーバーにレガシーのディスクへのバックアップフォルダを追加します。

Parameters

-LegacyBackupToDiskFolderDevice <BELegacyBackupToDiskFolderDevice>

Backup Exec サーバーに追加するレガシーのディスクへのバックアップフォルダを指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-StoragePath <String>

ストレージボリュームのパスを指定します。 デバイスがすでに正常に共有されている場合、これは必要ありません。

Required | false
Position | 2
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer[]>

レガシーのディスクへのバックアップフォルダを追加する Backup Exec サーバーを 1 つ以上指定します。

Required | true
Position | 1
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Force <SwitchParameter>

Add-BEBackupExecServerToLegacyBackupToDiskFolderDevice がこの Backup Exec サーバーをこのデバイスに追加することは、サーバーにこのデバイスの推奨環境がない場合でも、可能であることを確認します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトを Add-BEBackupExecServerToLegacyBackupToDiskFolderDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BELegacyBackupToDiskFolderDevice

Add-BEBackupExecServerToLegacyBackupToDiskFolderDevice はレガシーのディスクへのバックアップフォルダを表すオブジェクトを返します。

Examples

Example 1

C:\PS> $Device = Get-BELegacyBackupToDiskFolderDevice -Name "Legacy"
C:\PS> Get-BEBackupExecServer -Name "My-MMS" | Add-BEBackupExecServerToLegacyBackupToDiskFolderDevice -LegacyBackupToDiskFolderDevice $Device -StoragePath '\\My-CAS\B2D'

このコマンドは共有されていない、「Legacy」という名前のレガシーのディスクへのバックアップフォルダを Backup Exec サーバー「My-MMS」に追加します。

Example 2
C:\PS> $Device = Get-BELegacyBackupToDiskFolderDevice -Name "Legacy"
C:\PS> Get-BEBackupExecServer -Name "My-MMS" | Add-BEBackupExecServerToLegacyBackupToDiskFolderDevice -LegacyBackupToDiskFolderDevice $Device

このコマンドは共有されていない、「Legacy」という名前のレガシーのディスクへのバックアップフォルダを Backup Exec サーバー「My-MMS」に追加します。

Related Links


Add-BEBackupExecServerToNdmpServer Help

Add-BEBackupExecServerToNdmpServer Cmdlet
Synopsis

Backup Exec サーバーに NDMP サーバーを追加します。

Syntax
Add-BEBackupExecServerToNdmpServer [-BackupExecServer] <BEBackupExecServer[]> [-NdmpServer] <BENdmpServer> [-Force <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec サーバーに NDMP サーバーを追加します。

Parameters

-NdmpServer <BENdmpServer>

Backup Exec に追加する NDMP サーバーデバイスを指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer[]>

NDMP サーバーデバイスを追加する Backup Exec サーバーを 1 つ以上指定します。

Required | true
Position | 1
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Force <SwitchParameter>

Add-BEBackupExecServerToNdmpServer がこの Backup Exec サーバーをこのデバイスに追加することは、サーバーにこのデバイスの推奨環境がない場合でも、可能であることを確認します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトを Add-BEBackupExecServerToNdmpServer にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BENdmpServer

Add-BEBackupExecServerToNdmpServer は NDMP サーバーデバイスを表すオブジェクトを返します。

Example

C:\PS> $Device = Get-BENdmpServer -Name "NDMP"
C:\PS> Get-BEBackupExecServer -Name "My-MMS" | Add-BEBackupExecServerToNdmpServer -NdmpServer $Device

このコマンドは「NDMP」という名前の NDMP サーバーを Backup Exec サーバー「My-MMS」に追加します。

Related Links


Add-BEBackupExecServerToOpenStorageDevice Help

Add-BEBackupExecServerToOpenStorageDevice Cmdlet
Synopsis

OpenStorage デバイスを Backup Exec サーバーに追加します。

Syntax
Add-BEBackupExecServerToOpenStorageDevice [-BackupExecServer] <BEBackupExecServer[]> [-OpenStorageDevice] <BEOpenStorageDevice> [-Force <SwitchParameter>] [<CommonParameters>]
Description

OpenStorage デバイスを Backup Exec サーバーに追加します。

Parameters

-OpenStorageDevice <BEOpenStorageDevice>

Backup Exec サーバーに追加する OpenStorage デバイスを指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer[]>

OpenStorage デバイスを追加する Backup Exec サーバーを 1 つ以上指定します。

Required | true
Position | 1
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Force <SwitchParameter>

Add-BEBackupExecServerToOpenStorageDevice がこの Backup Exec サーバーをこのデバイスに追加することは、サーバーにこのデバイスの推奨環境がない場合でも、可能であることを確認します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトを Add-BEBackupExecServerToOpenStorageDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEOpenStorageDevice

Add-BEBackupExecServerToOpenStorageDevice は OpenStorage デバイスを表すオブジェクトを返します。

Example

C:\PS> $Device = Get-BEOpenStorageDevice -Name "PureDisk"
C:\PS> Get-BEBackupExecServer -Name "My-MMS" | Add-BEBackupExecServerToOpenStorageDevice -OpenStorageDevice $Device

このコマンドは「PureDisk」という名前の OpenStorage デバイスを Backup Exec サーバー「My-MMS」に追加します。

Related Links


Add-BEBackupExecServerToRemoteMediaAgentForLinux Help

Add-BEBackupExecServerToRemoteMediaAgentForLinux Cmdlet
Synopsis

Remote Media Agent for Linux を Backup Exec サーバーに追加します。

Syntax
Add-BEBackupExecServerToRemoteMediaAgentForLinux [-BackupExecServer] <BEBackupExecServer[]> [-RemoteMediaAgentForLinux] <BERemoteMediaAgentForLinux> [-Force <SwitchParameter>] [<CommonParameters>]
Description

Remote Media Agent for Linux を Backup Exec サーバーに追加します。

Parameters

-RemoteMediaAgentForLinux <BERemoteMediaAgentForLinux>

Backup Exec に追加する Remote Media Agent for Linux を指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer[]>

Remote Media Agent for Linux を追加する Backup Exec サーバーを 1 つ以上指定します。

Required | true
Position | 1
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Force <SwitchParameter>

Add-BEBackupExecServerToRemoteMediaAgentForLinux がこの Backup Exec サーバーをこのデバイスに追加することは、サーバーにこのデバイスの推奨環境がない場合でも、可能であることを確認します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトを Add-BEBackupExecServerToRemoteMediaAgentForLinux にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BERemoteMediaAgentForLinux

Add-BEBackupExecServerToRemoteMediaAgentForLinux は Remote Media Agent for Linux を表すオブジェクトを返します。

Example

C:\PS> $Device = Get-BERemoteMediaAgentForLinux -Name "RMAL"
C:\PS> Get-BEBackupExecServer -Name "My-MMS" | Add-BEBackupExecServerToRemoteMediaAgentForLinux -RemoteMediaAgentForLinux $Device

このコマンドは「RMAL」という名前の Remote Media Agent for Linux を Backup Exec サーバー「My-MMS」に追加します。

Related Links


Add-BEBackupExecServerToVirtualDiskDevice Help

Add-BEBackupExecServerToVirtualDiskDevice Cmdlet
Synopsis

Backup Exec サーバーに仮想ディスクデバイスを追加します。

Syntax
Add-BEBackupExecServerToVirtualDiskDevice [-BackupExecServer] <BEBackupExecServer[]> [-VirtualDiskDevice] <BEVirtualDiskDevice> [[-StoragePath] <String>] [-Force <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec サーバーに仮想ディスクデバイスを追加します。

Parameters

-VirtualDiskDevice <BEVirtualDiskDevice>

Backup Exec サーバーに追加する仮想ディスクを指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-StoragePath <String>

ストレージボリュームのパスを指定します。 デバイスがすでに正常に共有されている場合、これは必要ありません。

Required | false
Position | 2
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer[]>

仮想ディスクデバイスを追加する Backup Exec サーバーを 1 つ以上指定します。

Required | true
Position | 1
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Force <SwitchParameter>

Add-BEBackupExecServerToVirtualDiskDevice がこの Backup Exec サーバーをこのデバイスに追加することは、サーバーにこのデバイスの推奨環境がない場合でも、可能であることを確認します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトを Add-BEBackupExecServerToVirtualDiskDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEVirtualDiskDevice

Add-BEBackupExecServerToVirtualDiskDevice は仮想ディスクデバイスを表すオブジェクトを返します。

Examples

Example 1

C:\PS> $Device = Get-BEVirtualDiskDevice -Name "Virtual"
C:\PS> Get-BEBackupExecServer -Name "My-MMS" | Add-BEBackupExecServerToVirtualDiskDevice -VirtualDiskDevice $Device -StoragePath '\\My-CAS\Virtual'

このコマンドは共有されていない、「Virtual」という名前の仮想ディスクデバイスを Backup Exec サーバー「My-MMS」に追加します。

Example 2
C:\PS> $Device = Get-BEVirtualDiskDevice -Name "Virtual"
C:\PS>
Get-BEBackupExecServer -Name "My-MMS" | Add-BEBackupExecServerToVirtualDiskDevice -VirtualDiskDevice $Device

このコマンドは共有されていない、「Virtual」という名前の仮想ディスクデバイスを Backup Exec サーバー「My-MMS」に追加します。

Related Links


Add-BEBackupSelection Help

Add-BEBackupSelection Cmdlet
Synopsis

エージェントサーバーの順序付けられた選択項目のリストをバックアップジョブに追加します。

Syntax
Add-BEBackupSelection -BackupDefinition <BEBackupDefinition> [-AgentServer] <BEAgentServer> [-Selection] <BESelection[]> [<CommonParameters>]

Add-BEBackupSelection -OneTimeBackupJob <BEOneTimeBackupJob> [-AgentServer] <BEAgentServer> [-Selection] <BESelection[]> [<CommonParameters>]

Add-BEBackupSelection -AgentServerBackupSelectionList <BEAgentServerBackupSelectionList> [-Selection] <BESelection[]> [<CommonParameters>]

Add-BEBackupSelection [-AgentServer] <BEAgentServer> [-Selection] <BESelection[]> [<CommonParameters>]

Add-BEBackupSelection [-AgentServer] <BEAgentServer> [-Selection] <BESelection[]> [<CommonParameters>]
Description

エージェントサーバーの順序付けられた選択項目のリストをバックアップジョブに追加します。複数のエージェントサーバー上で選択を行うには、この cmdlet を各 AgentServer に対して 1 回使用して必要な選択項目を含めます。Backup Exec には順序付けの制約がありますが、選択項目を指定する順序は、リソースがバックアップされる順序です。

Parameters

-BackupDefinition <BEBackupDefinition>

選択を追加するバックアップ定義の名前を指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-OneTimeBackupJob <BEOneTimeBackupJob>

選択を追加する BEOneTimeBackupJob を指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-AgentServerBackupSelectionList <BEAgentServerBackupSelectionList>

選択を追加する BEAgentServerBackupSelectionList を指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-AgentServer <BEAgentServer>

選択を追加する AgentServer を指定します。

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-Selection <BESelection[]>

AgentServer に対して追加する 1 つ以上の BESelection オブジェクトを指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupDefinition

選択を追加する BEBackupDefinition です。

Return Value
BackupExec.Management.CLI.BEBackupDefinition

BackupExec.Management.CLI.BEBackupDefinition

Examples

Example 1

C:\PS> Get-BEAgentServer -local | New-BEBackupDefinition BackupToDisk | Add-BEBackupSelection -Selection (New-BEFileSystemSelection C:\Users -PathIsDirectory) | Save-BEBackupDefinition

このコマンドはローカルメディアサーバーの C:\Users ディレクトリに対するディスクへのバックアップの BEBackupDefinition を作成します。

Example 2
C:\PS> $selection = New-BEBackupSelection -AgentServer (Get-BEAgentServer -local) -Selection (New-BEFileSystemSelection C:\Users -PathIsDirectory)
C:\PS> $selection | Add-BEBackupSelection -Selection (New-BEFileSystemSelection D:\* -PathIsDirectory)
C:\PS> Get-BEBackupDefinition "My Local System Backup" | Set-BEBackupDefinition -Selections $selection | Save-BEBackupDefinition

これらのコマンドは「My Local System Backup」という名前の BEBackupDefinition の選択項目を、ローカルメディアサーバーの C:\Users ディレクトリと D: ドライブを含めるように変更します。

Related Links

Get-BEAgentServer
New-BEBackupDefinition
New-BEFileSystemSelection
Save-BEBackupDefinition
New-BEBackupSelection
Get-BEBackupDefinition
Set-BEBackupDefinition


Add-BEConvertToVirtualStageBackupTask Help

Add-BEConvertToVirtualStageBackupTask Cmdlet
Synopsis

仮想ステージを Backup Exec のバックアップ定義に追加します。

Syntax
Add-BEConvertToVirtualStageBackupTask -BackupDefinition <BEBackupDefinition> -TargetEnvironment <BEConvertToVirtualTargetEnvironment> -SimultaneouslyWithBackup <SwitchParameter> [-VirtualMachineCpuCount <UInt32>] [-VirtualMachinePhysicalRamMB <UInt32>] [-IncludeJobLogWithEmailNotification <Boolean>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-OverwriteExistingVirtualMachine <Boolean>] [-VirtualMachineName <String>] [<CommonParameters>]

Add-BEConvertToVirtualStageBackupTask -BackupDefinition <BEBackupDefinition> -ImmediatelyAfterFullBackup <String> -TargetEnvironment <BEConvertToVirtualTargetEnvironment> [-VirtualMachineCpuCount <UInt32>] [-VirtualMachinePhysicalRamMB <UInt32>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-SubmitOnHold <Boolean>] [-IncludeJobLogWithEmailNotification <Boolean>] [-Name <String>] [-OverwriteExistingVirtualMachine <Boolean>] [-VirtualMachineName <String>] [<CommonParameters>]

Add-BEConvertToVirtualStageBackupTask -BackupDefinition <BEBackupDefinition> [-SourceBackup] {AllBackups | MostRecentFullBackup} -Schedule <BESchedule> -TargetEnvironment <BEConvertToVirtualTargetEnvironment> [-VirtualMachineCpuCount <UInt32>] [-VirtualMachinePhysicalRamMB <UInt32>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-SubmitOnHold <Boolean>] [-IncludeJobLogWithEmailNotification <Boolean>] [-OverwriteExistingVirtualMachine <Boolean>] [-Name <String>] [-VirtualMachineName <String>] [<CommonParameters>]
Description

仮想ステージを Backup Exec のバックアップ定義に追加します。

新しいバックアップ定義に仮想ステージを追加するか、バックアップ定義を編集できます。

仮想ステージを新しいバックアップ定義に追加するには、Add-BEConvertToVirtualStageBackupTask と New-BEBackupDefinition を使用します。

バックアップ定義を編集して仮想ステージへの変換を追加するには、Add-BEConvertToVirtualStageBackupTask と Get-BEBackupDefinition を使用します。

バックアップ定義を作成または編集する場合、そのバックアップ定義を Save-BEBackupDefinition に渡して変更をコミットする必要があります。

Parameters

-BackupDefinition <BEBackupDefinition>

変更するバックアップ定義を指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String>

仮想ステージへの変換名を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SimultaneouslyWithBackup <SwitchParameter>

仮想マシンへの同時変換を伴うバックアップジョブを作成します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ImmediatelyAfterFullBackup <String>

バックアップジョブを作成し、バックアップの直後に仮想マシンへの変換を実行します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SourceBackup

仮想マシンに変換するバックアップ定義内のバックアップソースを指定します。

The valid values are:
AllBackups
MostRecentFullBackup

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-Schedule <BESchedule>

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TargetEnvironment <BEConvertToVirtualTargetEnvironment>

仮想マシンを作成する仮想環境を指定します。New-BEConvertToVirtualTargetEnvironment を参照してください。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineName <String>

作成する仮想マシンの名前を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OverwriteExistingVirtualMachine <Boolean>

仮想マシンがすでに存在する場合、同じ名前を持つ既存の仮想マシンを上書きします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachinePhysicalRamMB <UInt32>

仮想マシンの RAM を MB 単位で指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineCpuCount <UInt32>

仮想マシンの CPU 数を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NotificationRecipientList <BENotificationRecipientObject[]>

ジョブが完了したときに通知を受け取る受信者を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IncludeJobLogWithEmailNotification <Boolean>

電子メールにジョブログを添付します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SubmitOnHold <Boolean>

ジョブを保留状態でサブミットします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupDefinition

Backup Exec バックアップ定義オブジェクトを、パイプを使用して Add-BEConvertToVirtualStageBackupTask に渡すことができます。

Return Value
BackupExec.Management.CLI.BEBackupDefinition

修正されたバックアップ定義を示します。

Examples

Example 1

C:\PS> $targetEnvironment = New-BEConvertToVirtualTargetEnvironment -HyperVServerName hypervserver01 -HyperVDestinationPath c:\vms -LogonAccount "System Logon Account" -ToolsIsoPath c:\hypervtools.iso
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition BackupToDisk | Add-BEConvertToVirtualStageBackupTask -SimultaneouslyWithBackup -TargetEnvironment $targetEnvironment | Save-BEBackupDefinition

これらのコマンドは、バックアップジョブと同時に Hyper-V サーバー上で仮想マシンを作成する仮想ステージへの変換を持つバックアップ定義を作成します。

Example 2
C:\PS> $targetEnvironment = New-BEConvertToVirtualTargetEnvironment -VMwareVCenterServerName vcenterserver01 -VMwareHostName hostserver01 -VMwareDataStoreName datastore01 -LogonAccount "System Logon Account" -ToolsIsoPath c:\vmwaretools.iso
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition BackupToDisk | Add-BEConvertToVirtualStageBackupTask -SourceBackup AllBackups -Schedule (New-BESchedule -Weekdays -StartingAt 10PM) -TargetEnvironment $targetEnvironment | Save-BEBackupDefinition

これらのコマンドは、平日毎日午後 10 時にバックアップジョブから VMware vCenter の仮想マシンを作成する仮想ステージへの変換を持つバックアップ定義を作成します。

Related Links


Add-BEDeviceToStorageDevicePool Help

Add-BEDeviceToStorageDevicePool Cmdlet
Synopsis

Backup Exec のストレージデバイスプールにデバイスを追加します。

Syntax
Add-BEDeviceToStorageDevicePool -DiskStorageDevicePool <BEDiskStorageDevicePool> [-DiskStorageDevice] <BEDiskStorageDevice[]> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Add-BEDeviceToStorageDevicePool -TapeStorageDevicePool <BETapeStorageDevicePool> [-TapeDriveDevice] <BETapeDriveDevice[]> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Add-BEDeviceToStorageDevicePool -DiskStorageDevicePool <BEDiskStorageDevicePool> [-VirtualDiskDevice] <BEVirtualDiskDevice[]> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Add-BEDeviceToStorageDevicePool -DiskCartridgeStorageDevicePool <BEDiskCartridgeStorageDevicePool> [-DiskCartridgeDevice] <BEDiskCartridgeDevice[]> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のストレージデバイスプールにデバイスを追加します。

Parameters

-TapeStorageDevicePool <BETapeStorageDevicePool>

デバイスを追加するテープストレージデバイスプールを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-DiskStorageDevicePool <BEDiskStorageDevicePool>

デバイスを追加するディスクストレージデバイスプールを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-DiskCartridgeStorageDevicePool <BEDiskCartridgeStorageDevicePool>

デバイスを追加するディスクカートリッジストレージデバイスプールを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-DiskCartridgeDevice <BEDiskCartridgeDevice[]>

ストレージデバイスプールに追加する Backup Exec ディスクカートリッジデバイスを指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskStorageDevice <BEDiskStorageDevice[]>

ストレージデバイスプールに追加する Backup Exec ディスクストレージデバイスを指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualDiskDevice <BEVirtualDiskDevice[]>

ストレージデバイスプールに追加する Backup Exec 仮想ディスクデバイスを指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeDriveDevice <BETapeDriveDevice[]>

ストレージデバイスプールに追加する Backup Exec テープドライブデバイスを指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BETapeStorageDevicePool

Backup Exec テープストレージデバイスプールオブジェクトを Add-BEDeviceToStorageDevicePool にパイプ処理することができます。

BackupExec.Management.CLI.BEDiskStorageDevicePool

Backup Exec ディスクストレージデバイスプールオブジェクトを Add-BEDeviceToStorageDevicePool にパイプ処理することができます。

BackupExec.Management.CLI.BEDiskCartridgeStorageDevicePool

Backup Exec ディスクカートリッジストレージデバイスプールオブジェクトを Add-BEDeviceToStorageDevicePool にパイプ処理することができます。

Return Value
BackupExec.Management.CLI.BEStorageDevicePool

Add-BEDeviceFromStorageDevicePool は Backup Exec ストレージデバイスプールオブジェクトを返します。

Example

C:\PS> Get-BEStorageDevicePool "StorageDevicePool 0001" | Add-BEDeviceToStorageDevicePool "Device 0001"

これらのコマンドは「StorageDevicePool 0001」という名前のストレージデバイスプールに「Device 0001」という名前のデバイスを追加します。

Related Link

Get-BEStorageDevicePool


Add-BEDifferentialBackupTask Help

Add-BEDifferentialBackupTask Cmdlet
Synopsis

差分バックアップを Backup Exec のバックアップ定義に追加します。

Syntax
Add-BEDifferentialBackupTask -BackupDefinition <BEBackupDefinition> [[-Name] <String>] [-SqlDiskCopyPath <String>] [-SqlCreateDiskCopy <Boolean>] [-SqlUseChecksumOnBackup <Boolean>] [-SqlUseSoftwareCompression <Boolean>] [-OracleSkipBackedUpArchivedLogFile <Boolean>] [-OracleDeleteBackedUpArchivedLogFile <Boolean>] [-SharePointUseGrt <Boolean>] [-EncryptionKey <BEEncryptionKey>] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-VerifyAsPartOfJob <Boolean>] [-ExchangeUseGrt <Boolean>] [-SqlPostConsistencyCheck {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-SqlContinueIfConsistencyCheckUnsuccessful <Boolean>] [-SqlPreConsistencyCheckMethod {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-OraclePerformBackupOffline <Boolean>] [-EnterpriseVaultBackupType {Full | Incremental | Differential | FullCopy}] [-VMwareBackupType {Full | Incremental | Differential}] [-OracleBackupType {Full | Incremental | Differential}] [-NdmpBackupType {Level0 | Level1 | Level2 | Level3 | Level4 | Level5 | Level6 | Level7 | Level8 | Level9}] [-OpenEnterpriseServerBackupType {Full}] [-FileSystemBackupType {Full | Incremental | Differential | FullCopy}] [-ExcludeSelectionList <BEFileSystemSelection[]>] [-DeleteSelectedFilesAfterSuccessfulBackup {Never | FilesOnly | FilesAndFolders}] [-ExchangeBackupType {Full | FullCopy | Incremental | Differential}] [-SharePointBackupType {Full | FullCopy | Incremental | Differential | DifferentialBlockLevel | Log}] [-SqlBackupType {Full | FullCopy | Automatic | Log | LogNoTruncate | Incremental | Differential | DifferentialBlockLevel | DatabaseSnapshot}] [-SqlIncrementalBackupMethod {Full | FullCopy | Automatic | Log | LogNoTruncate | Incremental | Differential | DifferentialBlockLevel | DatabaseSnapshot}] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-TapeStorageRetensionMediaBeforeBackup <Boolean>] [-TapeStorageEnableDirectCopyToTape <Boolean>] [-TapeStorageEnableWriteOnceReadManyMedia <Boolean>] [-DiskStorageKeepForHours <Int32>] [-Schedule <BESchedule>] [-BackupSetDescription <String>] [-SubmitOnHold <Boolean>] [-Storage <BEStorage>] [-JobName <String>] [-TapeStorageMediaSet <BEMediaSet>] [-TapeStorageEjectMediaAfterComplete <Boolean>] [-TapeStorageExportMediaToVault <BEMediaVault>] [-TapeStorageExportMedia <Boolean>] [-KeepJobQueuedFor <TimeSpan>] [-RunJobOnlyIfPreCommandIsSuccessful <Boolean>] [-PrePostCommandSuccessfulIfReturnsZero <Boolean>] [-PostCommand <String>] [-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>] [-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>] [-RunPostCommandAfterVerification <Boolean>] [-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>] [-IncludeJobLogWithEmailNotification <Boolean>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-TapeStorageCompressionMethod {None | SoftwareIfNoHardware | HardwareOnly | SoftwareOnly}] [-EnableDirectAccessIfAvailable <Boolean>] [-PreCommand <String>] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [-Force <SwitchParameter>] [<CommonParameters>]

Add-BEDifferentialBackupTask -BackupJobDefault <BEBackupJobDefaults> [[-Name] <String>] [-SqlDiskCopyPath <String>] [-SqlCreateDiskCopy <Boolean>] [-SqlUseChecksumOnBackup <Boolean>] [-OracleDeleteBackedUpArchivedLogFile <Boolean>] [-SharePointUseGrt <Boolean>] [-SqlUseSoftwareCompression <Boolean>] [-SqlPostConsistencyCheck {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-EncryptionKey <BEEncryptionKey>] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-VerifyAsPartOfJob <Boolean>] [-SqlContinueIfConsistencyCheckUnsuccessful <Boolean>] [-SqlPreConsistencyCheckMethod {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-ExchangeUseGrt <Boolean>] [-OracleSkipBackedUpArchivedLogFile <Boolean>] [-NdmpBackupType {Level0 | Level1 | Level2 | Level3 | Level4 | Level5 | Level6 | Level7 | Level8 | Level9}] [-EnterpriseVaultBackupType {Full | Incremental | Differential | FullCopy}] [-VMwareBackupType {Full | Incremental | Differential}] [-OpenEnterpriseServerBackupType {Full}] [-OracleBackupType {Full | Incremental | Differential}] [-ExchangeBackupType {Full | FullCopy | Incremental | Differential}] [-FileSystemBackupType {Full | Incremental | Differential | FullCopy}] [-OraclePerformBackupOffline <Boolean>] [-SharePointBackupType {Full | FullCopy | Incremental | Differential | DifferentialBlockLevel | Log}] [-SqlBackupType {Full | FullCopy | Automatic | Log | LogNoTruncate | Incremental | Differential | DifferentialBlockLevel | DatabaseSnapshot}] [-SqlIncrementalBackupMethod {Full | FullCopy | Automatic | Log | LogNoTruncate | Incremental | Differential | DifferentialBlockLevel | DatabaseSnapshot}] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-SubmitOnHold <Boolean>] [-DiskStorageKeepForHours <Int32>] [-TapeStorageRetensionMediaBeforeBackup <Boolean>] [-KeepJobQueuedFor <TimeSpan>] [-Schedule <BESchedule>] [-BackupSetDescription <String>] [-TapeStorageEnableDirectCopyToTape <Boolean>] [-TapeStorageExportMedia <Boolean>] [-TapeStorageMediaSet <BEMediaSet>] [-Storage <BEStorage>] [-TapeStorageEnableWriteOnceReadManyMedia <Boolean>] [-TapeStorageEjectMediaAfterComplete <Boolean>] [-TapeStorageExportMediaToVault <BEMediaVault>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>] [-RunJobOnlyIfPreCommandIsSuccessful <Boolean>] [-PrePostCommandSuccessfulIfReturnsZero <Boolean>] [-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>] [-RunPostCommandAfterVerification <Boolean>] [-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>] [-PostCommand <String>] [-TapeStorageCompressionMethod {None | SoftwareIfNoHardware | HardwareOnly | SoftwareOnly}] [-IncludeJobLogWithEmailNotification <Boolean>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-EnableDirectAccessIfAvailable <Boolean>] [-PreCommand <String>] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

差分バックアップを Backup Exec のバックアップ定義に追加します。

新しいバックアップ定義に差分バックアップを追加するか、バックアップ定義を編集できます。 差分バックアップをバックアップジョブのデフォルトに追加することもできます。

差分バックアップを新規のバックアップ定義に追加するには、Add-BEDifferentialBackupTask と New-BEBackupDefinition を使用します。

バックアップ定義を編集するには、Add-BEDifferentialBackupTask と Get-BEBackupDefinition を使用します。

差分バックアップをバックアップジョブのデフォルトに追加するには、Add-BEDifferentialBackupTask と Get-BEBackupJobDefault を使用します。

バックアップ定義を作成または編集する場合は、そのバックアップ定義を Save-BEBackupDefinition に渡して変更をコミットする必要があります。

バックアップジョブのデフォルトを編集する場合、そのバックアップジョブのデフォルトを Save-BEBackupJobDefault に渡して変更をコミットする必要があります。

Parameters

-BackupDefinition <BEBackupDefinition>

変更するバックアップ定義を指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupJobDefault <BEBackupJobDefaults>

変更するバックアップジョブのデフォルトを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-JobName <String>

このタスクを表すジョブの名前を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Storage <BEStorage>

バックアップジョブに使用するストレージデバイスを指定します。 Get-BEStorage を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaSet <BEMediaSet>

メディアと関連付けるメディアセットを指定します。メディアはメディアセットの設定に基づいて上書きから保護されます。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。 Get-BEMediaSet を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMedia <Boolean>

ジョブの完了後にデバイスからメディアをエクスポートします。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMediaToVault <BEMediaVault>

ジョブの完了後にメディアを指定したボルトに論理的に移動します。Storage パラメータはテープベースのストレージデバイスに設定し、TapeStorageExportMedia は $true に設定する必要があります。Get-BEMediaVault を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEjectMediaAfterComplete <Boolean>

ジョブの完了後にストレージデバイスからメディアを取り出します。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableWriteOnceReadManyMedia <Boolean>

バックアップジョブに WORM (Write Once Read Many) メディアの使用を指定します。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableDirectCopyToTape <Boolean>

物理テープデバイスに仮想テープライブラリから直接データをコピーできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageRetensionMediaBeforeBackup <Boolean>

データを書き込む前にメディアのリテンションを行います。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskStorageKeepForHours <Int32>

メディアへの上書きを禁止し、このメディア上にデータを保存する時間を指定します。 Storage パラメータがディスクベースのストレージデバイスに設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SubmitOnHold <Boolean>

ジョブを保留状態でサブミットします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupSetDescription <String>

バックアップしたデータとその格納場所についての説明です。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Schedule <BESchedule>

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

予定開始時刻の経過後に、ジョブが未処理であると Backup Exec が判断し、そのジョブのスケジュール再設定が可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

予定開始時刻後にジョブの実行が続行されている場合、そのジョブのキャンセルが可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NotificationRecipientList <BENotificationRecipientObject[]>

ジョブが完了したときに通知を受け取る受信者を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IncludeJobLogWithEmailNotification <Boolean>

電子メールにジョブログを添付します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageCompressionMethod

使用するソフトウェアデータ圧縮またはハードウェアデータ圧縮の種類を指定します。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
None
SoftwareIfNoHardware
HardwareOnly
SoftwareOnly

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaAppendMethod

ジョブの開始時にメディアに上書きまたは追記します。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
Append
AppendOnly
Overwrite

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableDirectAccessIfAvailable <Boolean>

Agent for Windows から Storage パラメータで指定したデバイスにバックアップデータを直接送信できるようにします (デバイスがこの操作をサポートしている場合)。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreCommand <String>

バックアップジョブの前に実行するコマンドを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PostCommand <String>

バックアップジョブの後に実行するコマンドを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PrePostCommandSuccessfulIfReturnsZero <Boolean>

Backup Exec によってプリコマンドまたはポストコマンドの戻りコードを確認し、コマンドが正しく完了したかどうかを調べることができます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunJobOnlyIfPreCommandIsSuccessful <Boolean>

プリコマンドが正しく実行された場合にのみバックアップジョブを実行します。プリコマンドの実行に失敗した場合は、ジョブは実行されません。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>

プリコマンドが正しく実行された場合にのみポストコマンドを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>

ジョブが正しく実行されなかった場合でもポストコマンドを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandAfterVerification <Boolean>

バックアップジョブの検証を選択した場合、検証が完了した後にポストコマンドを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>

完了しなかったプリコマンドまたはポストコマンドをキャンセルするのに待つ時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunCommandLocation

プリコマンドとポストコマンドが実行される場所を指定します。

The valid values are:
OnEachAgentServer
OnBackupExecServer

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VerifyAsPartOfJob <Boolean>

バックアップジョブの完了時に自動的に検証操作を実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionType

バックアップジョブに使用する暗号化の種類を指定します。

The valid values are:
None
Software
Hardware
SoftwareIfNoHardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionKey <BEEncryptionKey>

使用する暗号化キーを指定します。 EncryptionType が None 以外の値に設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeUseGrt <Boolean>

インフォメーションストアのバックアップジョブから個々の項目をリストアできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlPreConsistencyCheckMethod

バックアップジョブを実行する前に行う一貫性チェックの種類を指定します。

The valid values are:
None
Physical
FullExcludingIndexes
FullIncludingIndexes

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlContinueIfConsistencyCheckUnsuccessful <Boolean>

一貫性チェックに失敗した場合でもバックアップジョブを続行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlPostConsistencyCheck

バックアップジョブを実行した後に行う一貫性チェックの種類を指定します。

The valid values are:
None
Physical
FullExcludingIndexes
FullIncludingIndexes

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlUseChecksumOnBackup <Boolean>

SQL 2005 以降の場合、バックアップする SQL データベースのデータにチェックサムを追加します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlCreateDiskCopy <Boolean>

バックアップする SQL データベースのコピーをディスク上に作成します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlDiskCopyPath <String>

バックアップする SQL データベースのディスク上に作成されるコピーのパスを指定します。CreateDiskCopy が $true に設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlUseSoftwareCompression <Boolean>

SQL 2008以降の場合、使用する圧縮設定を指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointUseGrt <Boolean>

データベースバックアップからの個々のドキュメント、イメージ、サイト、サブサイト、リスト、リストの項目のリストアを有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleDeleteBackedUpArchivedLogFile <Boolean>

バックアップ後にアーカイブログファイルを自動的に削除できます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleSkipBackedUpArchivedLogFile <Boolean>

以前にバックアップしたアーカイブログファイルを Backup Exec がスキップできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OraclePerformBackupOffline <Boolean>

バックアップジョブを開始する前に Backup Exec がデータベースをオフラインにすることを可能にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DeleteSelectedFilesAfterSuccessfulBackup

選択したデータをバックアップし、メディアの検証を行った後、ボリュームからデータを削除します。この操作でファイルを削除してデータを回復するにはリストアを実行する必要があるため、このオプションを有効にした場合は Force パラメータを指定する必要があります。

The valid values are:
Never
FilesOnly
FilesAndFolders

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExcludeSelectionList <BEFileSystemSelection[]>

バックアップジョブを実行するときの除外対象を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemBackupType

ファイルシステムを選択した場合に、どの種類のバックアップジョブを作成するかを指定します。

The valid values are:
Full
Incremental
Differential
FullCopy

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeBackupType

Microsoft Exchange を選択した場合に、どの種類のバックアップジョブを作成するかを指定します。

The valid values are:
Full
FullCopy
Incremental
Differential

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlIncrementalBackupMethod

Microsoft SQL 選択に対する増分バックアップ方式を指定します。

The valid values are:
Full
FullCopy
Automatic
Log
LogNoTruncate
Incremental
Differential
DifferentialBlockLevel
DatabaseSnapshot

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlBackupType

Microsoft SQL を選択した場合に、どの種類のバックアップジョブを作成するかを指定します。

The valid values are:
Full
FullCopy
Automatic
Log
LogNoTruncate
Incremental
Differential
DifferentialBlockLevel
DatabaseSnapshot

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointBackupType

Microsoft SharePoint を選択した場合に、どの種類のバックアップジョブを作成するかを指定します。

The valid values are:
Full
FullCopy
Incremental
Differential
DifferentialBlockLevel
Log

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleBackupType

Oracle を選択した場合に、どの種類のバックアップジョブを作成するかを指定します。

The valid values are:
Full
Incremental
Differential

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VMwareBackupType

VMware を選択した場合に、どの種類のバックアップジョブを作成するかを指定します。

The valid values are:
Full
Incremental
Differential

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnterpriseVaultBackupType

Enterprise Vault を選択した場合に、どの種類のバックアップジョブを作成するかを指定します。

The valid values are:
Full
Incremental
Differential
FullCopy

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NdmpBackupType

バックアップ NDMP サーバーに対して使用するバックアップレベルを指定します。

The valid values are:
Level0
Level1
Level2
Level3
Level4
Level5
Level6
Level7
Level8
Level9

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OpenEnterpriseServerBackupType

Open Enterprise Server を選択した場合に、どの種類のバックアップジョブを作成するかを指定します。

The valid values are:
Full

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

差分バックアップジョブの名前を指定します。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-Force <SwitchParameter>

DeleteSelectedFilesAfterSuccessfulBackup パラメータによってデータが失われ、使用を続ける必要があることを確認します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupDefinition

パイプを使用して Backup Exec バックアップ定義オブジェクトを Add-BEDifferentialBackupTask に渡すことができます。

BackupExec.Management.CLI.BEBackupJobDefaults

パイプを使用して Backup Exec バックアップジョブのデフォルトオブジェクトを Add-BEDifferentialBackupTask に渡すことができます。

Return Values
BackupExec.Management.CLI.BEBackupDefinition

修正されたバックアップ定義を示します。

BackupExec.Management.CLI.BEBackupJobDefaults

修正されたバックアップジョブのデフォルトを示します。

Examples

Example 1

C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition -BackupJobDefault BackupToDisk | Remove-BEBackupTask * | Add-BEDifferentialBackupTask | Save-BEBackupDefinition

これらのコマンドでは、ローカルコンピュータについて、初期完全バックアップと差分バックアップを行うバックアップ定義を新しく作成します。

Example 2
C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Add-BEDifferentialBackupTask | Save-BEBackupDefinition

これらのコマンドでは、差分バックアップを「Backup Definition 01」という名前のバックアップ定義に追加します。

Example 3
C:\PS> Get-BEBackupJobDefault BackupToDisk | Add-BEDifferentialBackupTask | Save-BEBackupJobDefault

これらのコマンドでは、差分バックアップをディスクへのバックアップジョブのデフォルトに追加します。

Related Links

New-BEBackupDefinition
Get-BEBackupDefinition
Get-BEBackupJobDefault
Save-BEBackupDefinition
Save-BEBackupJobDefault
Get-BEStorage
Get-BEMediaSet
Get-BEMediaVault
New-BESchedule
Get-BEAgentServer
Remove-BEBackupTask


Add-BEDuplicateStageBackupTask Help

Add-BEDuplicateStageBackupTask Cmdlet
Synopsis

複製ステージを Backup Exec のバックアップ定義に追加します。

Syntax
Add-BEDuplicateStageBackupTask -BackupDefinition <BEBackupDefinition> [[-Name] <String>] -ImmediatelyAfterBackup <String> [-IncludeJobLogWithEmailNotification <Boolean>] [-VerifyAsPartOfJob <Boolean>] [-TapeStorageEnabledHardwareCompression <Boolean>] [-KeepJobQueuedFor <TimeSpan>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-DoNotAddDefaultVerifyTask <SwitchParameter>] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-EncryptionKey <BEEncryptionKey>] [-TapeStorageExportMedia <Boolean>] [-TapeStorageExportMediaToVault <BEMediaVault>] [-TapeStorageEjectMediaAfterComplete <Boolean>] [-Storage <BEStorage>] [-TapeStorageMediaSet <BEMediaSet>] [-DiskStorageKeepForHours <Int32>] [-SubmitOnHold <Boolean>] [-BackupSetDescription <String>] [-TapeStorageEnableDirectCopyToTape <Boolean>] [-TapeStorageEnableWriteOnceReadManyMedia <Boolean>] [-TapeStorageRetensionMediaBeforeBackup <Boolean>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Add-BEDuplicateStageBackupTask -BackupDefinition <BEBackupDefinition> [[-Name] <String>] [-SourceBackup] {AllBackups | MostRecentFullBackup | SpecificSourceBackups} [[-SpecificSourceBackup] <String[]>] -Schedule <BESchedule> [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-IncludeJobLogWithEmailNotification <Boolean>] [-BackupSetDescription <String>] [-KeepJobQueuedFor <TimeSpan>] [-VerifyAsPartOfJob <Boolean>] [-EncryptionKey <BEEncryptionKey>] [-DoNotAddDefaultVerifyTask <SwitchParameter>] [-TapeStorageEnabledHardwareCompression <Boolean>] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-Storage <BEStorage>] [-TapeStorageMediaSet <BEMediaSet>] [-TapeStorageExportMedia <Boolean>] [-SubmitOnHold <Boolean>] [-JobName <String>] [-TapeStorageEnableDirectCopyToTape <Boolean>] [-TapeStorageRetensionMediaBeforeBackup <Boolean>] [-DiskStorageKeepForHours <Int32>] [-TapeStorageExportMediaToVault <BEMediaVault>] [-TapeStorageEjectMediaAfterComplete <Boolean>] [-TapeStorageEnableWriteOnceReadManyMedia <Boolean>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Add-BEDuplicateStageBackupTask -BackupDefinition <BEBackupDefinition> [[-Name] <String>] -SourceDuplicate <String> -Schedule <BESchedule> [-NotificationRecipientList <BENotificationRecipientObject[]>] [-IncludeJobLogWithEmailNotification <Boolean>] [-VerifyAsPartOfJob <Boolean>] [-BackupSetDescription <String>] [-KeepJobQueuedFor <TimeSpan>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-TapeStorageEnabledHardwareCompression <Boolean>] [-DoNotAddDefaultVerifyTask <SwitchParameter>] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-EncryptionKey <BEEncryptionKey>] [-Storage <BEStorage>] [-TapeStorageMediaSet <BEMediaSet>] [-TapeStorageExportMedia <Boolean>] [-JobName <String>] [-TapeStorageExportMediaToVault <BEMediaVault>] [-TapeStorageRetensionMediaBeforeBackup <Boolean>] [-DiskStorageKeepForHours <Int32>] [-SubmitOnHold <Boolean>] [-TapeStorageEnableWriteOnceReadManyMedia <Boolean>] [-TapeStorageEjectMediaAfterComplete <Boolean>] [-TapeStorageEnableDirectCopyToTape <Boolean>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Add-BEDuplicateStageBackupTask -BackupDefinition <BEBackupDefinition> [[-Name] <String>] -ImmediatelyAfterDuplicate <String> [-IncludeJobLogWithEmailNotification <Boolean>] [-VerifyAsPartOfJob <Boolean>] [-TapeStorageEnabledHardwareCompression <Boolean>] [-KeepJobQueuedFor <TimeSpan>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-DoNotAddDefaultVerifyTask <SwitchParameter>] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-EncryptionKey <BEEncryptionKey>] [-TapeStorageExportMedia <Boolean>] [-TapeStorageExportMediaToVault <BEMediaVault>] [-TapeStorageEjectMediaAfterComplete <Boolean>] [-Storage <BEStorage>] [-TapeStorageMediaSet <BEMediaSet>] [-DiskStorageKeepForHours <Int32>] [-SubmitOnHold <Boolean>] [-BackupSetDescription <String>] [-TapeStorageEnableDirectCopyToTape <Boolean>] [-TapeStorageEnableWriteOnceReadManyMedia <Boolean>] [-TapeStorageRetensionMediaBeforeBackup <Boolean>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Add-BEDuplicateStageBackupTask -SyntheticBackupDefinition <BESyntheticBackupDefinition> [[-Name] <String>] [-SourceBackup] {AllBackups | MostRecentFullBackup | SpecificSourceBackups} [[-SpecificSourceBackup] <String[]>] -Schedule <BESchedule> [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-IncludeJobLogWithEmailNotification <Boolean>] [-BackupSetDescription <String>] [-KeepJobQueuedFor <TimeSpan>] [-VerifyAsPartOfJob <Boolean>] [-EncryptionKey <BEEncryptionKey>] [-DoNotAddDefaultVerifyTask <SwitchParameter>] [-TapeStorageEnabledHardwareCompression <Boolean>] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-Storage <BEStorage>] [-TapeStorageMediaSet <BEMediaSet>] [-TapeStorageExportMedia <Boolean>] [-SubmitOnHold <Boolean>] [-JobName <String>] [-TapeStorageEnableDirectCopyToTape <Boolean>] [-TapeStorageRetensionMediaBeforeBackup <Boolean>] [-DiskStorageKeepForHours <Int32>] [-TapeStorageExportMediaToVault <BEMediaVault>] [-TapeStorageEjectMediaAfterComplete <Boolean>] [-TapeStorageEnableWriteOnceReadManyMedia <Boolean>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Add-BEDuplicateStageBackupTask -SyntheticBackupDefinition <BESyntheticBackupDefinition> [[-Name] <String>] -ImmediatelyAfterBackup <String> [-IncludeJobLogWithEmailNotification <Boolean>] [-VerifyAsPartOfJob <Boolean>] [-TapeStorageEnabledHardwareCompression <Boolean>] [-KeepJobQueuedFor <TimeSpan>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-DoNotAddDefaultVerifyTask <SwitchParameter>] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-EncryptionKey <BEEncryptionKey>] [-TapeStorageExportMedia <Boolean>] [-TapeStorageExportMediaToVault <BEMediaVault>] [-TapeStorageEjectMediaAfterComplete <Boolean>] [-Storage <BEStorage>] [-TapeStorageMediaSet <BEMediaSet>] [-DiskStorageKeepForHours <Int32>] [-SubmitOnHold <Boolean>] [-BackupSetDescription <String>] [-TapeStorageEnableDirectCopyToTape <Boolean>] [-TapeStorageEnableWriteOnceReadManyMedia <Boolean>] [-TapeStorageRetensionMediaBeforeBackup <Boolean>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Add-BEDuplicateStageBackupTask -SyntheticBackupDefinition <BESyntheticBackupDefinition> [[-Name] <String>] -SourceDuplicate <String> -Schedule <BESchedule> [-NotificationRecipientList <BENotificationRecipientObject[]>] [-IncludeJobLogWithEmailNotification <Boolean>] [-VerifyAsPartOfJob <Boolean>] [-BackupSetDescription <String>] [-KeepJobQueuedFor <TimeSpan>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-TapeStorageEnabledHardwareCompression <Boolean>] [-DoNotAddDefaultVerifyTask <SwitchParameter>] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-EncryptionKey <BEEncryptionKey>] [-Storage <BEStorage>] [-TapeStorageMediaSet <BEMediaSet>] [-TapeStorageExportMedia <Boolean>] [-JobName <String>] [-TapeStorageExportMediaToVault <BEMediaVault>] [-TapeStorageRetensionMediaBeforeBackup <Boolean>] [-DiskStorageKeepForHours <Int32>] [-SubmitOnHold <Boolean>] [-TapeStorageEnableWriteOnceReadManyMedia <Boolean>] [-TapeStorageEjectMediaAfterComplete <Boolean>] [-TapeStorageEnableDirectCopyToTape <Boolean>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Add-BEDuplicateStageBackupTask -SyntheticBackupDefinition <BESyntheticBackupDefinition> [[-Name] <String>] -ImmediatelyAfterDuplicate <String> [-IncludeJobLogWithEmailNotification <Boolean>] [-VerifyAsPartOfJob <Boolean>] [-TapeStorageEnabledHardwareCompression <Boolean>] [-KeepJobQueuedFor <TimeSpan>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-DoNotAddDefaultVerifyTask <SwitchParameter>] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-EncryptionKey <BEEncryptionKey>] [-TapeStorageExportMedia <Boolean>] [-TapeStorageExportMediaToVault <BEMediaVault>] [-TapeStorageEjectMediaAfterComplete <Boolean>] [-Storage <BEStorage>] [-TapeStorageMediaSet <BEMediaSet>] [-DiskStorageKeepForHours <Int32>] [-SubmitOnHold <Boolean>] [-BackupSetDescription <String>] [-TapeStorageEnableDirectCopyToTape <Boolean>] [-TapeStorageEnableWriteOnceReadManyMedia <Boolean>] [-TapeStorageRetensionMediaBeforeBackup <Boolean>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

複製ステージを Backup Exec のバックアップ定義に追加します。

新しいバックアップ定義に複製ステージを追加するか、バックアップ定義を編集できます。

複製ステージを新しいバックアップ定義に追加するには、Add-BEDuplicateStageBackupTask と New-BEBackupDefinition を使用します。

バックアップ定義を編集して複製ステージを追加するには、Add-BEDuplicateStageBackupTask と Get-BEBackupDefinition を使用します。

バックアップ定義を作成または編集するときは、バックアップ定義を Save-BEBackupDefinition に渡し、変更内容をコミットする必要があります。

Parameters

-BackupDefinition <BEBackupDefinition>

変更するバックアップ定義を指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-SyntheticBackupDefinition <BESyntheticBackupDefinition>

変更する合成バックアップ定義を指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-SourceBackup

複製するバックアップ定義内部のバックアップソースを指定します。

The valid values are:
AllBackups
MostRecentFullBackup
SpecificSourceBackups

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-SpecificSourceBackup <String[]>

バックアップ定義で複製するための 1 つまたは複数のバックアップジョブを名前 (文字列) を使用して指定します。複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。Source パラメータは SpecificBackups に指定する必要があります。

Required | false
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-ImmediatelyAfterBackup <String>

バックアップ定義で複製するバックアップジョブの名前を指定します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ImmediatelyAfterDuplicate <String>

バックアップ定義で複製する複製バックアップジョブの名前を指定します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SourceDuplicate <String>

バックアップ定義の、複製する複製バックアップジョブの名前を指定します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-JobName <String>

このタスクを表すジョブの名前を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Schedule <BESchedule>

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Storage <BEStorage>

バックアップジョブに使用するストレージデバイスを指定します。 Get-BEStorage を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaSet <BEMediaSet>

メディアと関連付けるメディアセットを指定します。メディアはメディアセットの設定に基づいて上書きから保護されます。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。 Get-BEMediaSet を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMedia <Boolean>

ジョブの完了後にデバイスからメディアをエクスポートします。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMediaToVault <BEMediaVault>

ジョブの完了後にメディアを指定したボルトに論理的に移動します。Storage パラメータはテープベースのストレージデバイスに設定し、TapeStorageExportMedia は $true に設定する必要があります。Get-BEMediaVault を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEjectMediaAfterComplete <Boolean>

ジョブの完了後にストレージデバイスからメディアを取り出します。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableWriteOnceReadManyMedia <Boolean>

バックアップジョブに WORM (Write Once Read Many) メディアの使用を指定します。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableDirectCopyToTape <Boolean>

物理テープデバイスに仮想テープライブラリから直接データをコピーできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageRetensionMediaBeforeBackup <Boolean>

データを書き込む前にメディアのリテンションを行います。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskStorageKeepForHours <Int32>

メディアへの上書きを禁止し、このメディア上にデータを保存する時間を指定します。 Storage パラメータがディスクベースのストレージデバイスに設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SubmitOnHold <Boolean>

ジョブを保留状態でサブミットします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupSetDescription <String>

バックアップしたデータとその格納場所についての説明です。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

予定開始時刻の経過後に、ジョブが未処理であると Backup Exec が判断し、そのジョブのスケジュール再設定が可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

予定開始時刻後にジョブの実行が続行されている場合、そのジョブのキャンセルが可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NotificationRecipientList <BENotificationRecipientObject[]>

ジョブが完了したときに通知を受け取る受信者を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IncludeJobLogWithEmailNotification <Boolean>

電子メールにジョブログを添付します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VerifyAsPartOfJob <Boolean>

バックアップジョブの完了時に自動的に検証操作を実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnabledHardwareCompression <Boolean>

ハードウェア圧縮を有効にするかどうかを指定します。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaAppendMethod

ジョブの開始時にメディアに上書きまたは追記します。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
Append
AppendOnly
Overwrite

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionType

バックアップジョブに使用する暗号化の種類を指定します。

The valid values are:
None
Software
Hardware
SoftwareIfNoHardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionKey <BEEncryptionKey>

使用する暗号化キーを指定します。 EncryptionType が None 以外の値に設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DoNotAddDefaultVerifyTask <SwitchParameter>

デフォルトの検証タスクが複製ステージに関連付けられている場合、検証タスクが複製ステージとともに追加されないようにします。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

複製ステージの名前を指定します。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupDefinition

パイプを使用して Backup Exec バックアップ定義オブジェクトを Add-BEDuplicateStageBackupTask に渡すことができます。

BackupExec.Management.CLI.BEBackupJobDefaults

パイプを使用して Backup Exec バックアップジョブのデフォルトオブジェクトを Add-BEDuplicateStageBackupTask に渡すことができます。

Return Values
BackupExec.Management.CLI.BEBackupDefinition

修正されたバックアップ定義を示します。

BackupExec.Management.CLI.BEBackupJobDefaults

修正されたバックアップジョブのデフォルトを示します。

Examples

Example 1

C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition BackupToDisk | Add-BEDuplicateStageBackupTask -SourceBackup AllBackups -Schedule (New-BESchedule -Weekdays -StartingAt 10PM) | Save-BEBackupDefinition

これらのコマンドでは、すべてのバックアップジョブからのデータを平日毎日午後 10 時に複製する複製ステージがあるバックアップ定義を作成します。

Example 2
C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Add-BEDuplicateStageBackupTask -SourceBackup SpecificSourceBackups -SpecificSourceBackup Full -Schedule (New-BESchedule -Weekdays -StartingAt 10PM) | Save-BEBackupDefinition

これらのコマンドでは、「Full」という名前のバックアップジョブからのデータを平日毎日午後 10 時に複製する「Backup Definition 01」というバックアップ定義に複製ステージを追加します。

Example 3
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition BackupToDisk | Add-BEDuplicateStageBackupTask -ImmediatelyAfterBackup Full | Save-BEBackupDefinition

これらのコマンドでは、バックアップジョブの完了後、「Full」という名前のバックアップジョブからのデータを複製する複製ステージがあるバックアップ定義を作成します。

Example 4
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition BackupToDiskThenDuplicateToTape | Add-BEDuplicateStageBackupTask -SourceDuplicate Duplicate -Schedule (New-BESchedule -Weekdays -StartingAt 10PM) | Save-BEBackupDefinition

これらのコマンドでは、「Duplicate」という名前の複製ステージからのデータを平日毎日午後 10 時に複製する複製ステージがあるバックアップ定義を作成します。

Example 5
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition BackupToDiskThenDuplicateToTape | Add-BEDuplicateStageBackupTask -ImmediatelyAfterDuplicate Duplicate | Save-BEBackupDefinition

これらのコマンドでは、複製ジョブの完了後、「Duplicate」という名前の複製ステージからのデータを複製する複製ステージがあるバックアップ定義が作成されます。

Related Links


Add-BEFullBackupTask Help

Add-BEFullBackupTask Cmdlet
Synopsis

完全バックアップを Backup Exec のバックアップ定義に追加します。

Syntax
Add-BEFullBackupTask -BackupDefinition <BEBackupDefinition> [[-Name] <String>] [-SqlDiskCopyPath <String>] [-SqlCreateDiskCopy <Boolean>] [-SqlUseChecksumOnBackup <Boolean>] [-SqlUseSoftwareCompression <Boolean>] [-OracleSkipBackedUpArchivedLogFile <Boolean>] [-OracleDeleteBackedUpArchivedLogFile <Boolean>] [-SharePointUseGrt <Boolean>] [-EncryptionKey <BEEncryptionKey>] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-VerifyAsPartOfJob <Boolean>] [-ExchangeUseGrt <Boolean>] [-SqlPostConsistencyCheck {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-SqlContinueIfConsistencyCheckUnsuccessful <Boolean>] [-SqlPreConsistencyCheckMethod {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-OraclePerformBackupOffline <Boolean>] [-EnterpriseVaultBackupType {Full | Incremental | Differential | FullCopy}] [-VMwareBackupType {Full | Incremental | Differential}] [-OracleBackupType {Full | Incremental | Differential}] [-NdmpBackupType {Level0 | Level1 | Level2 | Level3 | Level4 | Level5 | Level6 | Level7 | Level8 | Level9}] [-OpenEnterpriseServerBackupType {Full}] [-FileSystemBackupType {Full | Incremental | Differential | FullCopy}] [-ExcludeSelectionList <BEFileSystemSelection[]>] [-DeleteSelectedFilesAfterSuccessfulBackup {Never | FilesOnly | FilesAndFolders}] [-ExchangeBackupType {Full | FullCopy | Incremental | Differential}] [-SharePointBackupType {Full | FullCopy | Incremental | Differential | DifferentialBlockLevel | Log}] [-SqlBackupType {Full | FullCopy | Automatic | Log | LogNoTruncate | Incremental | Differential | DifferentialBlockLevel | DatabaseSnapshot}] [-SqlIncrementalBackupMethod {Full | FullCopy | Automatic | Log | LogNoTruncate | Incremental | Differential | DifferentialBlockLevel | DatabaseSnapshot}] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-TapeStorageRetensionMediaBeforeBackup <Boolean>] [-TapeStorageEnableDirectCopyToTape <Boolean>] [-TapeStorageEnableWriteOnceReadManyMedia <Boolean>] [-DiskStorageKeepForHours <Int32>] [-Schedule <BESchedule>] [-BackupSetDescription <String>] [-SubmitOnHold <Boolean>] [-Storage <BEStorage>] [-JobName <String>] [-TapeStorageMediaSet <BEMediaSet>] [-TapeStorageEjectMediaAfterComplete <Boolean>] [-TapeStorageExportMediaToVault <BEMediaVault>] [-TapeStorageExportMedia <Boolean>] [-KeepJobQueuedFor <TimeSpan>] [-RunJobOnlyIfPreCommandIsSuccessful <Boolean>] [-PrePostCommandSuccessfulIfReturnsZero <Boolean>] [-PostCommand <String>] [-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>] [-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>] [-RunPostCommandAfterVerification <Boolean>] [-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>] [-IncludeJobLogWithEmailNotification <Boolean>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-TapeStorageCompressionMethod {None | SoftwareIfNoHardware | HardwareOnly | SoftwareOnly}] [-EnableDirectAccessIfAvailable <Boolean>] [-PreCommand <String>] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [-Force <SwitchParameter>] [<CommonParameters>]

Add-BEFullBackupTask -BackupJobDefault <BEBackupJobDefaults> [[-Name] <String>] [-SqlDiskCopyPath <String>] [-SqlCreateDiskCopy <Boolean>] [-SqlUseChecksumOnBackup <Boolean>] [-OracleDeleteBackedUpArchivedLogFile <Boolean>] [-SharePointUseGrt <Boolean>] [-SqlUseSoftwareCompression <Boolean>] [-SqlPostConsistencyCheck {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-EncryptionKey <BEEncryptionKey>] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-VerifyAsPartOfJob <Boolean>] [-SqlContinueIfConsistencyCheckUnsuccessful <Boolean>] [-SqlPreConsistencyCheckMethod {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-ExchangeUseGrt <Boolean>] [-OracleSkipBackedUpArchivedLogFile <Boolean>] [-NdmpBackupType {Level0 | Level1 | Level2 | Level3 | Level4 | Level5 | Level6 | Level7 | Level8 | Level9}] [-EnterpriseVaultBackupType {Full | Incremental | Differential | FullCopy}] [-VMwareBackupType {Full | Incremental | Differential}] [-OpenEnterpriseServerBackupType {Full}] [-OracleBackupType {Full | Incremental | Differential}] [-ExchangeBackupType {Full | FullCopy | Incremental | Differential}] [-FileSystemBackupType {Full | Incremental | Differential | FullCopy}] [-OraclePerformBackupOffline <Boolean>] [-SharePointBackupType {Full | FullCopy | Incremental | Differential | DifferentialBlockLevel | Log}] [-SqlBackupType {Full | FullCopy | Automatic | Log | LogNoTruncate | Incremental | Differential | DifferentialBlockLevel | DatabaseSnapshot}] [-SqlIncrementalBackupMethod {Full | FullCopy | Automatic | Log | LogNoTruncate | Incremental | Differential | DifferentialBlockLevel | DatabaseSnapshot}] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-SubmitOnHold <Boolean>] [-DiskStorageKeepForHours <Int32>] [-TapeStorageRetensionMediaBeforeBackup <Boolean>] [-KeepJobQueuedFor <TimeSpan>] [-Schedule <BESchedule>] [-BackupSetDescription <String>] [-TapeStorageEnableDirectCopyToTape <Boolean>] [-TapeStorageExportMedia <Boolean>] [-TapeStorageMediaSet <BEMediaSet>] [-Storage <BEStorage>] [-TapeStorageEnableWriteOnceReadManyMedia <Boolean>] [-TapeStorageEjectMediaAfterComplete <Boolean>] [-TapeStorageExportMediaToVault <BEMediaVault>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>] [-RunJobOnlyIfPreCommandIsSuccessful <Boolean>] [-PrePostCommandSuccessfulIfReturnsZero <Boolean>] [-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>] [-RunPostCommandAfterVerification <Boolean>] [-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>] [-PostCommand <String>] [-TapeStorageCompressionMethod {None | SoftwareIfNoHardware | HardwareOnly | SoftwareOnly}] [-IncludeJobLogWithEmailNotification <Boolean>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-EnableDirectAccessIfAvailable <Boolean>] [-PreCommand <String>] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

完全バックアップを Backup Exec のバックアップ定義に追加します。

新しいバックアップ定義に完全バックアップを追加するか、バックアップ定義を編集できます。 完全バックアップをバックアップジョブのデフォルトに追加することもできます。

完全バックアップを新しいバックアップ定義に追加するには、Add-BEFullBackupTask と New-BEBackupDefinition を使用します。

バックアップ定義を編集して完全バックアップを追加するには、Add-BEFullBackupTask と Get-BEBackupDefinition を使用します。

完全バックアップをバックアップジョブのデフォルトに追加するには、Add-BEFullBackupTask と Get-BEBackupJobDefault を使用します。

バックアップ定義を作成または編集するときは、バックアップ定義を Save-BEBackupDefinition に渡し、変更内容をコミットする必要があります。

バックアップジョブのデフォルトを編集するときは、バックアップジョブのデフォルトを Save-BEBackupJobDefault に渡し、変更内容をコミットする必要があります。

Parameters

-BackupDefinition <BEBackupDefinition>

変更するバックアップ定義を指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupJobDefault <BEBackupJobDefaults>

変更するバックアップジョブのデフォルトを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-JobName <String>

このタスクを表すジョブの名前を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Storage <BEStorage>

バックアップジョブに使用するストレージデバイスを指定します。 Get-BEStorage を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaSet <BEMediaSet>

メディアと関連付けるメディアセットを指定します。メディアはメディアセットの設定に基づいて上書きから保護されます。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。 Get-BEMediaSet を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMedia <Boolean>

ジョブの完了後にデバイスからメディアをエクスポートします。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMediaToVault <BEMediaVault>

ジョブの完了後にメディアを指定したボルトに論理的に移動します。Storage パラメータはテープベースのストレージデバイスに設定し、TapeStorageExportMedia は $true に設定する必要があります。Get-BEMediaVault を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEjectMediaAfterComplete <Boolean>

ジョブの完了後にストレージデバイスからメディアを取り出します。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableWriteOnceReadManyMedia <Boolean>

バックアップジョブに WORM (Write Once Read Many) メディアの使用を指定します。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableDirectCopyToTape <Boolean>

物理テープデバイスに仮想テープライブラリから直接データをコピーできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageRetensionMediaBeforeBackup <Boolean>

データを書き込む前にメディアのリテンションを行います。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskStorageKeepForHours <Int32>

メディアへの上書きを禁止し、このメディア上にデータを保存する時間を指定します。 Storage パラメータがディスクベースのストレージデバイスに設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SubmitOnHold <Boolean>

ジョブを保留状態でサブミットします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupSetDescription <String>

バックアップしたデータとその格納場所についての説明です。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Schedule <BESchedule>

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

予定開始時刻の経過後に、ジョブが未処理であると Backup Exec が判断し、そのジョブのスケジュール再設定が可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

予定開始時刻後にジョブの実行が続行されている場合、そのジョブのキャンセルが可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NotificationRecipientList <BENotificationRecipientObject[]>

ジョブが完了したときに通知を受け取る受信者を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IncludeJobLogWithEmailNotification <Boolean>

電子メールにジョブログを添付します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageCompressionMethod

使用するソフトウェアデータ圧縮またはハードウェアデータ圧縮の種類を指定します。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
None
SoftwareIfNoHardware
HardwareOnly
SoftwareOnly

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaAppendMethod

ジョブの開始時にメディアに上書きまたは追記します。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
Append
AppendOnly
Overwrite

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableDirectAccessIfAvailable <Boolean>

Agent for Windows から Storage パラメータで指定したデバイスにバックアップデータを直接送信できるようにします (デバイスがこの操作をサポートしている場合)。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreCommand <String>

バックアップジョブの前に実行するコマンドを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PostCommand <String>

バックアップジョブの後に実行するコマンドを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PrePostCommandSuccessfulIfReturnsZero <Boolean>

Backup Exec によってプリコマンドまたはポストコマンドの戻りコードを確認し、コマンドが正しく完了したかどうかを調べることができます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunJobOnlyIfPreCommandIsSuccessful <Boolean>

プリコマンドが正しく実行された場合にのみバックアップジョブを実行します。プリコマンドの実行に失敗した場合は、ジョブは実行されません。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>

プリコマンドが正しく実行された場合にのみポストコマンドを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>

ジョブが正しく実行されなかった場合でもポストコマンドを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandAfterVerification <Boolean>

バックアップジョブの検証を選択した場合、検証が完了した後にポストコマンドを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>

完了しなかったプリコマンドまたはポストコマンドをキャンセルするのに待つ時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunCommandLocation

プリコマンドとポストコマンドが実行される場所を指定します。

The valid values are:
OnEachAgentServer
OnBackupExecServer

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VerifyAsPartOfJob <Boolean>

バックアップジョブの完了時に自動的に検証操作を実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionType

バックアップジョブに使用する暗号化の種類を指定します。

The valid values are:
None
Software
Hardware
SoftwareIfNoHardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionKey <BEEncryptionKey>

使用する暗号化キーを指定します。 EncryptionType が None 以外の値に設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeUseGrt <Boolean>

インフォメーションストアのバックアップジョブから個々の項目をリストアできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlPreConsistencyCheckMethod

バックアップジョブを実行する前に行う一貫性チェックの種類を指定します。

The valid values are:
None
Physical
FullExcludingIndexes
FullIncludingIndexes

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlContinueIfConsistencyCheckUnsuccessful <Boolean>

一貫性チェックに失敗した場合でもバックアップジョブを続行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlPostConsistencyCheck

バックアップジョブを実行した後に行う一貫性チェックの種類を指定します。

The valid values are:
None
Physical
FullExcludingIndexes
FullIncludingIndexes

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlUseChecksumOnBackup <Boolean>

SQL 2005 以降の場合、バックアップする SQL データベースのデータにチェックサムを追加します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlCreateDiskCopy <Boolean>

バックアップする SQL データベースのコピーをディスク上に作成します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlDiskCopyPath <String>

バックアップする SQL データベースのディスク上に作成されるコピーのパスを指定します。CreateDiskCopy が $true に設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlUseSoftwareCompression <Boolean>

SQL 2008以降の場合、使用する圧縮設定を指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointUseGrt <Boolean>

データベースバックアップからの個々のドキュメント、イメージ、サイト、サブサイト、リスト、リストの項目のリストアを有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleDeleteBackedUpArchivedLogFile <Boolean>

バックアップ後にアーカイブログファイルを自動的に削除できます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleSkipBackedUpArchivedLogFile <Boolean>

以前にバックアップしたアーカイブログファイルを Backup Exec がスキップできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OraclePerformBackupOffline <Boolean>

バックアップジョブを開始する前に Backup Exec がデータベースをオフラインにすることを可能にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DeleteSelectedFilesAfterSuccessfulBackup

選択したデータをバックアップし、メディアの検証を行った後、ボリュームからデータを削除します。この操作でファイルを削除してデータを回復するにはリストアを実行する必要があるため、このオプションを有効にした場合は Force パラメータを指定する必要があります。

The valid values are:
Never
FilesOnly
FilesAndFolders

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExcludeSelectionList <BEFileSystemSelection[]>

バックアップジョブを実行するときの除外対象を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemBackupType

ファイルシステムを選択した場合に、どの種類のバックアップジョブを作成するかを指定します。

The valid values are:
Full
Incremental
Differential
FullCopy

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeBackupType

Microsoft Exchange を選択した場合に、どの種類のバックアップジョブを作成するかを指定します。

The valid values are:
Full
FullCopy
Incremental
Differential

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlIncrementalBackupMethod

Microsoft SQL 選択に対する増分バックアップ方式を指定します。

The valid values are:
Full
FullCopy
Automatic
Log
LogNoTruncate
Incremental
Differential
DifferentialBlockLevel
DatabaseSnapshot

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlBackupType

Microsoft SQL を選択した場合に、どの種類のバックアップジョブを作成するかを指定します。

The valid values are:
Full
FullCopy
Automatic
Log
LogNoTruncate
Incremental
Differential
DifferentialBlockLevel
DatabaseSnapshot

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointBackupType

Microsoft SharePoint を選択した場合に、どの種類のバックアップジョブを作成するかを指定します。

The valid values are:
Full
FullCopy
Incremental
Differential
DifferentialBlockLevel
Log

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleBackupType

Oracle を選択した場合に、どの種類のバックアップジョブを作成するかを指定します。

The valid values are:
Full
Incremental
Differential

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VMwareBackupType

VMware を選択した場合に、どの種類のバックアップジョブを作成するかを指定します。

The valid values are:
Full
Incremental
Differential

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnterpriseVaultBackupType

Enterprise Vault を選択した場合に、どの種類のバックアップジョブを作成するかを指定します。

The valid values are:
Full
Incremental
Differential
FullCopy

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NdmpBackupType

バックアップ NDMP サーバーに対して使用するバックアップレベルを指定します。

The valid values are:
Level0
Level1
Level2
Level3
Level4
Level5
Level6
Level7
Level8
Level9

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OpenEnterpriseServerBackupType

Open Enterprise Server を選択した場合に、どの種類のバックアップジョブを作成するかを指定します。

The valid values are:
Full

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

完全バックアップジョブの名前を指定します。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-Force <SwitchParameter>

DeleteSelectedFilesAfterSuccessfulBackup パラメータによってデータが失われ、使用を続ける必要があることを確認します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupDefinition

パイプを使用して Backup Exec バックアップ定義オブジェクトを Add-BEFullBackupTask に渡すことができます。

BackupExec.Management.CLI.BEBackupJobDefaults

パイプを使用して Backup Exec バックアップジョブのデフォルトオブジェクトを Add-BEFullBackupTask に渡すことができます。

Return Values
BackupExec.Management.CLI.BEBackupDefinition

修正されたバックアップ定義を示します。

BackupExec.Management.CLI.BEBackupJobDefaults

修正されたバックアップジョブのデフォルトを示します。

Examples

Example 1

C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition -BackupJobDefault BackupToDisk | Remove-BEBackupTask * | Add-BEFullBackupTask | Save-BEBackupDefinition

これらのコマンドでは、ローカルコンピュータについて、初期完全バックアップと追加の完全バックアップを行うバックアップ定義を新しく作成します。

Example 2
C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Add-BEFullBackupTask | Save-BEBackupDefinition

これらのコマンドでは、完全バックアップを「Backup Definition 01」という名前のバックアップ定義に追加します。

Example 3
C:\PS> Get-BEBackupJobDefault BackupToDisk | Add-BEFullBackupTask | Save-BEBackupJobDefault

これらのコマンドはフルバックアップをディスクへのバックアップジョブのデフォルトに追加します。

Related Links

New-BEBackupDefinition
Get-BEBackupDefinition
Get-BEBackupJobDefault
Save-BEBackupDefinition
Save-BEBackupJobDefault
Get-BEStorage
Get-BEMediaSet
Get-BEMediaVault
New-BESchedule
Get-BEAgentServer
Remove-BEBackupTask


Add-BEGlobalExcludeSelection Help

Add-BEGlobalExcludeSelection Cmdlet
Synopsis

ファイルシステムの選択項目オブジェクトをグローバル除外項目のリストに追加します。

Syntax
Add-BEGlobalExcludeSelection [-FileSystemSelection] <BEFileSystemSelection[]> [<CommonParameters>]
Description

ファイルシステムの選択項目オブジェクトをグローバル除外項目のリストに追加します。

Parameters

-FileSystemSelection <BEFileSystemSelection[]>

1 つ以上のファイルシステムの選択項目をグローバルに除外される選択項目のリストに追加します。 除外するファイルまたはディレクトリを指定するには、1 つまたは複数のパスを、カンマを使用して値を区切って指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEFileSystemSelection

BEFileSystemSelection オブジェクトを Add-BEGlobalExcludeSelection にパイプ処理できます。

Return Value
None

このコマンドレットは出力を生成しません。

Example

C:\PS> Add-BEGlobalExcludeSelection -FileSystemSelection (New-BEFileSystemSelection -Path "C:\Windows\*")

このコマンドは C:\Windows ディレクトリをグローバル除外リストに追加します。

Related Link

New-BEFileSystemSelection


Add-BEIncrementalBackupTask Help

Add-BEIncrementalBackupTask Cmdlet
Synopsis

増分バックアップを Backup Exec のバックアップ定義に追加します。

Syntax
Add-BEIncrementalBackupTask -BackupDefinition <BEBackupDefinition> [[-Name] <String>] [-SqlDiskCopyPath <String>] [-SqlCreateDiskCopy <Boolean>] [-SqlUseChecksumOnBackup <Boolean>] [-SqlUseSoftwareCompression <Boolean>] [-OracleSkipBackedUpArchivedLogFile <Boolean>] [-OracleDeleteBackedUpArchivedLogFile <Boolean>] [-SharePointUseGrt <Boolean>] [-EncryptionKey <BEEncryptionKey>] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-VerifyAsPartOfJob <Boolean>] [-ExchangeUseGrt <Boolean>] [-SqlPostConsistencyCheck {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-SqlContinueIfConsistencyCheckUnsuccessful <Boolean>] [-SqlPreConsistencyCheckMethod {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-OraclePerformBackupOffline <Boolean>] [-EnterpriseVaultBackupType {Full | Incremental | Differential | FullCopy}] [-VMwareBackupType {Full | Incremental | Differential}] [-OracleBackupType {Full | Incremental | Differential}] [-NdmpBackupType {Level0 | Level1 | Level2 | Level3 | Level4 | Level5 | Level6 | Level7 | Level8 | Level9}] [-OpenEnterpriseServerBackupType {Full}] [-FileSystemBackupType {Full | Incremental | Differential | FullCopy}] [-ExcludeSelectionList <BEFileSystemSelection[]>] [-DeleteSelectedFilesAfterSuccessfulBackup {Never | FilesOnly | FilesAndFolders}] [-ExchangeBackupType {Full | FullCopy | Incremental | Differential}] [-SharePointBackupType {Full | FullCopy | Incremental | Differential | DifferentialBlockLevel | Log}] [-SqlBackupType {Full | FullCopy | Automatic | Log | LogNoTruncate | Incremental | Differential | DifferentialBlockLevel | DatabaseSnapshot}] [-SqlIncrementalBackupMethod {Full | FullCopy | Automatic | Log | LogNoTruncate | Incremental | Differential | DifferentialBlockLevel | DatabaseSnapshot}] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-TapeStorageRetensionMediaBeforeBackup <Boolean>] [-TapeStorageEnableDirectCopyToTape <Boolean>] [-TapeStorageEnableWriteOnceReadManyMedia <Boolean>] [-DiskStorageKeepForHours <Int32>] [-Schedule <BESchedule>] [-BackupSetDescription <String>] [-SubmitOnHold <Boolean>] [-Storage <BEStorage>] [-JobName <String>] [-TapeStorageMediaSet <BEMediaSet>] [-TapeStorageEjectMediaAfterComplete <Boolean>] [-TapeStorageExportMediaToVault <BEMediaVault>] [-TapeStorageExportMedia <Boolean>] [-KeepJobQueuedFor <TimeSpan>] [-RunJobOnlyIfPreCommandIsSuccessful <Boolean>] [-PrePostCommandSuccessfulIfReturnsZero <Boolean>] [-PostCommand <String>] [-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>] [-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>] [-RunPostCommandAfterVerification <Boolean>] [-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>] [-IncludeJobLogWithEmailNotification <Boolean>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-TapeStorageCompressionMethod {None | SoftwareIfNoHardware | HardwareOnly | SoftwareOnly}] [-EnableDirectAccessIfAvailable <Boolean>] [-PreCommand <String>] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [-Force <SwitchParameter>] [<CommonParameters>]

Add-BEIncrementalBackupTask -BackupJobDefault <BEBackupJobDefaults> [[-Name] <String>] [-SqlDiskCopyPath <String>] [-SqlCreateDiskCopy <Boolean>] [-SqlUseChecksumOnBackup <Boolean>] [-OracleDeleteBackedUpArchivedLogFile <Boolean>] [-SharePointUseGrt <Boolean>] [-SqlUseSoftwareCompression <Boolean>] [-SqlPostConsistencyCheck {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-EncryptionKey <BEEncryptionKey>] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-VerifyAsPartOfJob <Boolean>] [-SqlContinueIfConsistencyCheckUnsuccessful <Boolean>] [-SqlPreConsistencyCheckMethod {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-ExchangeUseGrt <Boolean>] [-OracleSkipBackedUpArchivedLogFile <Boolean>] [-NdmpBackupType {Level0 | Level1 | Level2 | Level3 | Level4 | Level5 | Level6 | Level7 | Level8 | Level9}] [-EnterpriseVaultBackupType {Full | Incremental | Differential | FullCopy}] [-VMwareBackupType {Full | Incremental | Differential}] [-OpenEnterpriseServerBackupType {Full}] [-OracleBackupType {Full | Incremental | Differential}] [-ExchangeBackupType {Full | FullCopy | Incremental | Differential}] [-FileSystemBackupType {Full | Incremental | Differential | FullCopy}] [-OraclePerformBackupOffline <Boolean>] [-SharePointBackupType {Full | FullCopy | Incremental | Differential | DifferentialBlockLevel | Log}] [-SqlBackupType {Full | FullCopy | Automatic | Log | LogNoTruncate | Incremental | Differential | DifferentialBlockLevel | DatabaseSnapshot}] [-SqlIncrementalBackupMethod {Full | FullCopy | Automatic | Log | LogNoTruncate | Incremental | Differential | DifferentialBlockLevel | DatabaseSnapshot}] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-SubmitOnHold <Boolean>] [-DiskStorageKeepForHours <Int32>] [-TapeStorageRetensionMediaBeforeBackup <Boolean>] [-KeepJobQueuedFor <TimeSpan>] [-Schedule <BESchedule>] [-BackupSetDescription <String>] [-TapeStorageEnableDirectCopyToTape <Boolean>] [-TapeStorageExportMedia <Boolean>] [-TapeStorageMediaSet <BEMediaSet>] [-Storage <BEStorage>] [-TapeStorageEnableWriteOnceReadManyMedia <Boolean>] [-TapeStorageEjectMediaAfterComplete <Boolean>] [-TapeStorageExportMediaToVault <BEMediaVault>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>] [-RunJobOnlyIfPreCommandIsSuccessful <Boolean>] [-PrePostCommandSuccessfulIfReturnsZero <Boolean>] [-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>] [-RunPostCommandAfterVerification <Boolean>] [-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>] [-PostCommand <String>] [-TapeStorageCompressionMethod {None | SoftwareIfNoHardware | HardwareOnly | SoftwareOnly}] [-IncludeJobLogWithEmailNotification <Boolean>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-EnableDirectAccessIfAvailable <Boolean>] [-PreCommand <String>] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

増分バックアップを Backup Exec のバックアップ定義に追加します。

新しいバックアップ定義に増分バックアップを追加するか、バックアップ定義を編集できます。 増分バックアップをバックアップジョブのデフォルトに追加することもできます。

増分バックアップを新しいバックアップ定義に追加するには、Add-BEIncrementalBackupTask と New-BEBackupDefinition を使用します。

バックアップ定義を編集して増分バックアップを追加するには、Add-BEIncrementalBackupTask と Get-BEBackupDefinition を使用します。

増分バックアップをバックアップジョブのデフォルトに追加するには、Add-BEIncrementalBackupTask と Get-BEBackupJobDefault を使用します。

バックアップ定義を作成または編集するときは、バックアップ定義を Save-BEBackupDefinition に渡し、変更内容をコミットする必要があります。

バックアップジョブのデフォルトを編集するときは、ジョブのデフォルトを Save-BEBackupJobDefault に渡し、変更内容をコミットする必要があります。

Parameters

-BackupDefinition <BEBackupDefinition>

変更するバックアップ定義を指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupJobDefault <BEBackupJobDefaults>

変更するバックアップジョブのデフォルトを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-JobName <String>

このタスクを表すジョブの名前を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Storage <BEStorage>

バックアップジョブに使用するストレージデバイスを指定します。 Get-BEStorage を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaSet <BEMediaSet>

メディアと関連付けるメディアセットを指定します。メディアはメディアセットの設定に基づいて上書きから保護されます。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。 Get-BEMediaSet を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMedia <Boolean>

ジョブの完了後にデバイスからメディアをエクスポートします。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMediaToVault <BEMediaVault>

ジョブの完了後にメディアを指定したボルトに論理的に移動します。Storage パラメータはテープベースのストレージデバイスに設定し、TapeStorageExportMedia は $true に設定する必要があります。Get-BEMediaVault を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEjectMediaAfterComplete <Boolean>

ジョブの完了後にストレージデバイスからメディアを取り出します。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableWriteOnceReadManyMedia <Boolean>

バックアップジョブに WORM (Write Once Read Many) メディアの使用を指定します。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableDirectCopyToTape <Boolean>

物理テープデバイスに仮想テープライブラリから直接データをコピーできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageRetensionMediaBeforeBackup <Boolean>

データを書き込む前にメディアのリテンションを行います。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskStorageKeepForHours <Int32>

メディアへの上書きを禁止し、このメディア上にデータを保存する時間を指定します。 Storage パラメータがディスクベースのストレージデバイスに設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SubmitOnHold <Boolean>

ジョブを保留状態でサブミットします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupSetDescription <String>

バックアップしたデータとその格納場所についての説明です。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Schedule <BESchedule>

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

予定開始時刻の経過後に、ジョブが未処理であると Backup Exec が判断し、そのジョブのスケジュール再設定が可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

予定開始時刻後にジョブの実行が続行されている場合、そのジョブのキャンセルが可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NotificationRecipientList <BENotificationRecipientObject[]>

ジョブが完了したときに通知を受け取る受信者を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IncludeJobLogWithEmailNotification <Boolean>

電子メールにジョブログを添付します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageCompressionMethod

使用するソフトウェアデータ圧縮またはハードウェアデータ圧縮の種類を指定します。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
None
SoftwareIfNoHardware
HardwareOnly
SoftwareOnly

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaAppendMethod

ジョブの開始時にメディアに上書きまたは追記します。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
Append
AppendOnly
Overwrite

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableDirectAccessIfAvailable <Boolean>

Agent for Windows から Storage パラメータで指定したデバイスにバックアップデータを直接送信できるようにします (デバイスがこの操作をサポートしている場合)。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreCommand <String>

バックアップジョブの前に実行するコマンドを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PostCommand <String>

バックアップジョブの後に実行するコマンドを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PrePostCommandSuccessfulIfReturnsZero <Boolean>

Backup Exec によってプリコマンドまたはポストコマンドの戻りコードを確認し、コマンドが正しく完了したかどうかを調べることができます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunJobOnlyIfPreCommandIsSuccessful <Boolean>

プリコマンドが正しく実行された場合にのみバックアップジョブを実行します。プリコマンドの実行に失敗した場合は、ジョブは実行されません。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>

プリコマンドが正しく実行された場合にのみポストコマンドを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>

ジョブが正しく実行されなかった場合でもポストコマンドを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandAfterVerification <Boolean>

バックアップジョブの検証を選択した場合、検証が完了した後にポストコマンドを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>

完了しなかったプリコマンドまたはポストコマンドをキャンセルするのに待つ時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunCommandLocation

プリコマンドとポストコマンドが実行される場所を指定します。

The valid values are:
OnEachAgentServer
OnBackupExecServer

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VerifyAsPartOfJob <Boolean>

バックアップジョブの完了時に自動的に検証操作を実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionType

バックアップジョブに使用する暗号化の種類を指定します。

The valid values are:
None
Software
Hardware
SoftwareIfNoHardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionKey <BEEncryptionKey>

使用する暗号化キーを指定します。 EncryptionType が None 以外の値に設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeUseGrt <Boolean>

インフォメーションストアのバックアップジョブから個々の項目をリストアできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlPreConsistencyCheckMethod

バックアップジョブを実行する前に行う一貫性チェックの種類を指定します。

The valid values are:
None
Physical
FullExcludingIndexes
FullIncludingIndexes

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlContinueIfConsistencyCheckUnsuccessful <Boolean>

一貫性チェックに失敗した場合でもバックアップジョブを続行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlPostConsistencyCheck

バックアップジョブを実行した後に行う一貫性チェックの種類を指定します。

The valid values are:
None
Physical
FullExcludingIndexes
FullIncludingIndexes

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlUseChecksumOnBackup <Boolean>

SQL 2005 以降の場合、バックアップする SQL データベースのデータにチェックサムを追加します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlCreateDiskCopy <Boolean>

バックアップする SQL データベースのコピーをディスク上に作成します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlDiskCopyPath <String>

バックアップする SQL データベースのディスク上に作成されるコピーのパスを指定します。CreateDiskCopy が $true に設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlUseSoftwareCompression <Boolean>

SQL 2008以降の場合、使用する圧縮設定を指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointUseGrt <Boolean>

データベースバックアップからの個々のドキュメント、イメージ、サイト、サブサイト、リスト、リストの項目のリストアを有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleDeleteBackedUpArchivedLogFile <Boolean>

バックアップ後にアーカイブログファイルを自動的に削除できます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleSkipBackedUpArchivedLogFile <Boolean>

以前にバックアップしたアーカイブログファイルを Backup Exec がスキップできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OraclePerformBackupOffline <Boolean>

バックアップジョブを開始する前に Backup Exec がデータベースをオフラインにすることを可能にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DeleteSelectedFilesAfterSuccessfulBackup

選択したデータをバックアップし、メディアの検証を行った後、ボリュームからデータを削除します。この操作でファイルを削除してデータを回復するにはリストアを実行する必要があるため、このオプションを有効にした場合は Force パラメータを指定する必要があります。

The valid values are:
Never
FilesOnly
FilesAndFolders

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExcludeSelectionList <BEFileSystemSelection[]>

バックアップジョブを実行するときの除外対象を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemBackupType

ファイルシステムを選択した場合に、どの種類のバックアップジョブを作成するかを指定します。

The valid values are:
Full
Incremental
Differential
FullCopy

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeBackupType

Microsoft Exchange を選択した場合に、どの種類のバックアップジョブを作成するかを指定します。

The valid values are:
Full
FullCopy
Incremental
Differential

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlIncrementalBackupMethod

Microsoft SQL 選択に対する増分バックアップ方式を指定します。

The valid values are:
Full
FullCopy
Automatic
Log
LogNoTruncate
Incremental
Differential
DifferentialBlockLevel
DatabaseSnapshot

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlBackupType

Microsoft SQL を選択した場合に、どの種類のバックアップジョブを作成するかを指定します。

The valid values are:
Full
FullCopy
Automatic
Log
LogNoTruncate
Incremental
Differential
DifferentialBlockLevel
DatabaseSnapshot

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointBackupType

Microsoft SharePoint の選択項目を作成するバックアップジョブの種類を指定します。

The valid values are:
Full
FullCopy
Incremental
Differential
DifferentialBlockLevel
Log

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleBackupType

Oracle を選択した場合に、どの種類のバックアップジョブを作成するかを指定します。

The valid values are:
Full
Incremental
Differential

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VMwareBackupType

VMware を選択した場合に、どの種類のバックアップジョブを作成するかを指定します。

The valid values are:
Full
Incremental
Differential

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnterpriseVaultBackupType

Enterprise Vault を選択した場合に、どの種類のバックアップジョブを作成するかを指定します。

The valid values are:
Full
Incremental
Differential
FullCopy

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NdmpBackupType

バックアップ NDMP サーバーに対して使用するバックアップレベルを指定します。

The valid values are:
Level0
Level1
Level2
Level3
Level4
Level5
Level6
Level7
Level8
Level9

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OpenEnterpriseServerBackupType

Open Enterprise Server を選択した場合に、どの種類のバックアップジョブを作成するかを指定します。

The valid values are:
Full

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

増分バックアップジョブの名前を指定します。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-Force <SwitchParameter>

DeleteSelectedFilesAfterSuccessfulBackup パラメータによってデータが失われ、使用を続ける必要があることを確認します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupDefinition

パイプを使用して Backup Exec バックアップ定義オブジェクトを Add-BEIncrementalBackupTask に渡すことができます。

BackupExec.Management.CLI.BEBackupJobDefaults

パイプを使用して Backup Exec バックアップジョブのデフォルトオブジェクトを Add-BEIncrementalBackupTask に渡すことができます。

Return Values
BackupExec.Management.CLI.BEBackupDefinition

修正されたバックアップ定義を示します。

BackupExec.Management.CLI.BEBackupJobDefaults

修正されたバックアップジョブのデフォルトを示します。

Examples

Example 1

C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition -BackupJobDefault BackupToDisk | Remove-BEBackupTask * | Add-BEIncrementalBackupTask | Save-BEBackupDefinition

これらのコマンドでは、ローカルコンピュータについて、初期完全バックアップと増分バックアップを行うバックアップ定義を新しく作成します。

Example 2
C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Add-BEIncrementalBackupTask | Save-BEBackupDefinition

これらのコマンドでは、増分バックアップを「Backup Definition 01」という名前のバックアップ定義に追加します。

Example 3
C:\PS> Get-BEBackupJobDefault BackupToDisk | Add-BEIncrementalBackupTask | Save-BEBackupJobDefault

これらのコマンドでは、増分バックアップをディスクへのバックアップジョブのデフォルトに追加します。

Related Links

New-BEBackupDefinition
Get-BEBackupDefinition
Get-BEBackupJobDefault
Save-BEBackupDefinition
Save-BEBackupJobDefault
Get-BEStorage
Get-BEMediaSet
Get-BEMediaVault
New-BESchedule
Get-BEAgentServer
Remove-BEBackupTask


Add-BELinuxAgentServer Help

Add-BELinuxAgentServer Cmdlet
Synopsis

Backup Exec の新しい Linux エージェントサーバーを作成します。

Syntax
Add-BELinuxAgentServer [-Name] <String> [-LogonAccount] <BELogonAccount> [-ExcludeFromScheduledCredentialTest <Boolean>] [-Description <String>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [-Force <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec の新しい Linux エージェントサーバーを作成します。

次のコマンドは、Add-BELinuxAgentServer のエイリアスです。
Add-BEFileAgentServer
Add-BEMacintoshAgentServer
Add-BENdmpAgentServer

Parameters

-LogonAccount <BELogonAccount>

名前を変更するログオンアカウントオブジェクトを指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

Linux エージェントの説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExcludeFromScheduledCredentialTest <Boolean>

スケジュール済みクレデンシャルテストからエージェントサーバーを除外します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

Linux エージェントの名前を指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | true

-Force <SwitchParameter>

自動的に Linux エージェントとの信頼関係を構築します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

作成する Backup Exec Linux エージェントサーバーオブジェクトの名前を含む文字列を Add-BELinuxAgentServer にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BELinuxAgentServer

Add-BELinuxAgentServer は、作成された Linux エージェントサーバーを返します。

Examples

Example 1

C:\PS> $LogonAccount = Get-BELogonAccount -Name Linux
C:\PS> Add-BELinuxAgentServer -Name "MyServer.mycompany.com" -Description "Linux Server" -LogonAccount $Logon

これらのコマンドは Linux エージェントを名前を使用して追加します。

Example 2
C:\PS> $LogonAccount = Get-BELogonAccount -Name Linux
C:\PS> '10.67.101.92' | Add-BELinuxAgentServer -LogonAccount $Logon -Description "Linux Server"

これらのコマンドは Linux エージェントを名前を使用して追加します。

Example 3
C:\PS> $LogonAccount = Get-BELogonAccount -Name File
C:\PS> Add-BEFileAgentServer -Name "\\MyServer.mycompany.com\Share" -Description "File Server" -LogonAccount $Logon

Add-BEFileAgentServer は Add-BELinuxAgentServer のエイリアスです。 これらのコマンドはファイルエージェントを名前を使用して追加します。

Example 4
C:\PS> $LogonAccount = Get-BELogonAccount -Name File
C:\PS> '\\10.67.101.92\Share' | Add-BEFileAgentServer -LogonAccount $Logon -Description "File Server"

Add-BEFileAgentServer は Add-BELinuxAgentServer のエイリアスです。 これらのコマンドはファイルエージェントを名前を使用して追加します。

Example 5
C:\PS> $LogonAccount = Get-BELogonAccount -Name Ndmp
C:\PS> Add-BENdmpAgentServer -Name "MyServer.mycompany.com" -Description "Ndmp Server" -LogonAccount $Logon

Add-BENdmpAgentServer は Add-BELinuxAgentServer のエイリアスです。これらのコマンドは NDMP エージェントを名前を使用して追加します。

Example 6
C:\PS> $LogonAccount = Get-BELogonAccount -Name Ndmp
C:\PS> '10.67.101.92' | Add-BENdmpAgentServer -LogonAccount $Logon -Description "Ndmp Server"

Add-BENdmpAgentServer は Add-BELinuxAgentServer のエイリアスです。これらのコマンドは NDMP エージェントを名前を使用して追加します。

Related Link

Get-BELogonAccount


Add-BENdmpServer Help

Add-BENdmpServer Cmdlet
Synopsis

Backup Exec の NDMP サーバーを追加します。

Syntax
Add-BENdmpServer [-Name] <String> [-LogonAccount] <BELogonAccount> [-BackupExecServer] <BEBackupExecServer> [-Port <Int32>] [-Disabled <Boolean>] [-UseICMPPingOption <Boolean>] [-Description <String>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [-Force <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec の NDMP サーバーを追加します。

NDMP サーバーは、Network Data Management Protocol を使用して Network-Attached Storage NDMP サーバーをバックアップおよびリストアします。

Parameters

-BackupExecServer <BEBackupExecServer>

Central Admin Server Option (CASO) 環境で NDMP サーバーを作成する Backup Exec サーバーを指定します。

Required | true
Position | 2
Accepts pipeline input | false
Accepts wildcard characters | false

-LogonAccount <BELogonAccount>

NDMP サーバーで使用するログオンアカウントオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BELogonAccount を参照してください。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

NDMP サーバーの説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UseICMPPingOption <Boolean>

Internet Control Message Protocol による NDMP サーバーの検索を可能にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Port <Int32>

NDMP サーバーに接続するために使用するポートを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Disabled <Boolean>

NDMP サーバーを無効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

NDMP サーバーの名前を指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | true

-Force <SwitchParameter>

自動的に NDMP サーバーとの信頼関係を構築します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

作成する Backup Exec NDMP サーバーオブジェクトの名前を含む文字列を Add-BENdmpServer にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BENdmpServer

Add-BENdmpServer は、作成された NDMP サーバーを返します。

Examples

Example 1

C:\PS> $LogonAccount = Get-BELogonAccount -Name Linux
C:\PS> $BackupExecServer = Get-BEBackupExecServer -Name CASO
C:\PS> Add-BENDMPServer -Name "MyServer.mycompany.com" -Description "NDMP server" -LogonAccount $Logon -BackupExecServer $BackupExecServer

これらのコマンドは NDMP サーバーを名前を使用して追加します。

Example 2
C:\PS> $LogonAccount = Get-BELogonAccount -Name Linux
C:\PS> $BackupExecServer = Get-BEBackupExecServer -Name CASO
C:\PS> '10.67.101.92' | Add-BENDMPServer -LogonAccount $Logon -Description "NDMP server" -BackupExecServer $BackupExecServer

これらのコマンドは NDMP サーバーを名前を使用して追加します。

Related Links


Add-BERemoteMediaAgentForLinux Help

Add-BERemoteMediaAgentForLinux Cmdlet
Synopsis

Linux サーバーを Backup Exec の Remote Media Agent for Linux として追加します。

Syntax
Add-BERemoteMediaAgentForLinux [-Name] <String> [-LogonAccount] <BELogonAccount> [-BackupExecServer] <BEBackupExecServer> [-Port <Int32>] [-Disabled <Boolean>] [-UseICMPPingOption <Boolean>] [-Description <String>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [-Force <SwitchParameter>] [<CommonParameters>]
Description

Linux サーバーを Backup Exec Remote Media Agent for Linux (RMAL) として追加します。

RMAL は、サポート対象のエージェントがインストールされたリモートコンピュータへのデータ接続を確立します。

Remote Media Agent for Linux は Central Admin Server Option (CASO) 環境へのみ追加できます。

Parameters

-BackupExecServer <BEBackupExecServer>

Central Admin Server Option (CASO) 環境でデバイスを作成する Backup Exec サーバーを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEBackupExecServer を参照してください。

Required | true
Position | 2
Accepts pipeline input | false
Accepts wildcard characters | false

-LogonAccount <BELogonAccount>

Remote Media Agent for Linux で使用するログオンアカウントオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BELogonAccount を参照してください。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

Remote Media Agent for Linux の説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UseICMPPingOption <Boolean>

Internet Control Message Protocol による Remote Media Agent for Linux の検索を可能にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Port <Int32>

Remote Media Agent for Linux に接続するために使用するポートを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Disabled <Boolean>

Remote Media Agent for Linux を無効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

Remote Media Agent for Linux の名前を指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | true

-Force <SwitchParameter>

自動的に Remote Media Agent for Linux との信頼関係を構築します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

作成する Backup Exec Remote Media Agent for Linux オブジェクトの名前を含む文字列を Add-BERemoteMediaAgentForLinux にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BERemoteMediaAgentForLinux

Add-BERemoteMediaAgentForLinux は、作成された Remote Media Agent for Linux を返します。

Examples

Example 1

C:\PS> $LogonAccount = Get-BELogonAccount -Name Linux
C:\PS> $BackupExecServer = Get-BEBackupExecServer -Local
C:\PS> Add-BERemoteMediaAgentForLinux -LogonAccount $LogonAccount -Description "a Remote Media Agent for Linux" -Name 10.67.101.92 -BackupExecServer $BackupExecServer

これらのコマンドは「Linux」ログオンアカウントを使用して、ローカルの Backup Exec サーバー上で Linux サーバーを新しい Remote Media Agent for Linux として追加します。

Example 2
C:\PS> $LogonAccount = Get-BELogonAccount -Name Linux
C:\PS> $BackupExecServer = Get-BEBackupExecServer -Local
C:\PS> "MyServer.mycompany.com" | Add-BERemoteMediaAgentForLinux -LogonAccount $LogonAccount -BackupExecServer $BackupExecServer

これらのコマンドは「Linux」ログオンアカウントを使用して、ローカルの Backup Exec サーバー上で Linux サーバーを新しい Remote Media Agent for Linux として追加します。

Related Links


Add-BEScheduleDatesToExclude Help

Add-BEScheduleDatesToExclude Cmdlet
Synopsis

BESchedule の DatesToExclude と指定された日数を組み合わせます。

Syntax
Add-BEScheduleDatesToExclude -Schedule <BESchedule> [-DatesToExclude] <DateTime[]> [<CommonParameters>]
Description

BESchedule の DatesToExclude と指定された日数を組み合わせます。 重複した日付は無視されました。

Parameters

-Schedule <BESchedule>

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-DatesToExclude <DateTime[]>

繰り返し実行するスケジュールをスキップする日付を指定します。

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BESchedule

指定したスケジュールを表すオブジェクト。

Return Value
BackupExec.Management.CLI.BESchedule

指定したスケジュールを表すオブジェクト。

Examples

Example 1

C:\PS> $s = New-BESchedule -Daily -StartingAt 9pm -DatesToExclude 1/1/2013, 1/1/2014
C:\PS> $s | Add-BEScheduleDatesToExclude 1/1/2015, 1/1/2016, 1/1/2017

これらのコマンドは、毎日午後 9 時に実行され、2013 から 2017 年の 1 月 1 日を除外するようにジョブをスケジュールします。

Example 2
C:\PS> $bd = Get-BEBackupDefinition "Payroll"
C:\PS> $s = $bd.InitialFullBackup.Schedule
C:\PS> $s | Add-BEScheduleDatesToExclude 12/12/2015, 12/12/2016, 12/12/2017
C:\PS> $bd | Set-BEFullBackupTask -Name $bd.InitialFullBackup.Name -Schedule $s | Save-BEBackupDefinition

これらのコマンドは、「Payroll」という名前のバックアップ定義で初期フルバックアップのスケジュールを修正し、2015 から 2017 年の 12 月 12 日を除外します。

Related Links


Add-BEScheduleDatesToInclude Help

Add-BEScheduleDatesToInclude Cmdlet
Synopsis

BESchedule の DatesToInclude と指定された日数を組み合わせます。

Syntax
Add-BEScheduleDatesToInclude -Schedule <BESchedule> [-DatesToInclude] <DateTime[]> [<CommonParameters>]
Description

BESchedule の DatesToInclude と指定された日数を組み合わせます。 重複した日付は無視されました。

Parameters

-Schedule <BESchedule>

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-DatesToInclude <DateTime[]>

繰り返しスケジュールが追加する日付を指定します。

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BESchedule

指定したスケジュールを表すオブジェクト。

Return Value
BackupExec.Management.CLI.BESchedule

指定したスケジュールを表すオブジェクト。

Examples

Example 1

C:\PS> $s = New-BESchedule -Daily -StartingAt 9pm -DatesToInclude 1/1/2013, 1/1/2014
C:\PS> $s | Add-BEScheduleDatesToInclude 1/1/2015, 1/1/2016, 1/1/2017

これらのコマンドは、毎日朝 9:00 に実行されるスケジュールを作成します。これには 2013 年から 2017 年までの 1 月 1 日も含まれます。

Example 2
C:\PS> $bd = Get-BEBackupDefinition "Payroll"
C:\PS> $s = $bd.InitialFullBackup.Schedule
C:\PS> $s | Add-BEScheduleDatesToInclude 12/12/2015, 12/12/2016, 12/12/2017
C:\PS> $bd | Set-BEFullBackupTask -Name $bd.InitialFullBackup.Name -Schedule $s | Save-BEBackupDefinition

これらのコマンドは、「Payroll」という名前のバックアップ定義に 2015 から 2017 年の 12 月 12 日を含む初期フルバックアップを作成します。

Related Links


Add-BEServerToBackupExecServerPool Help

Add-BEServerToBackupExecServerPool Cmdlet
Synopsis

Backup Exec サーバープールに管理対象 Backup Exec サーバーを追加します。

Syntax
Add-BEServerToBackupExecServerPool -InputObject <BEBackupExecServerPool[]> [-BackupExecServer] <BEBackupExecServer[]> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec サーバープールに管理対象 Backup Exec サーバーを追加します。

Parameters

-BackupExecServer <BEBackupExecServer[]>

プールに追加する管理対象 Backup Exec サーバー。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEBackupExecServerPool[]>

1 つ以上の Backup Exec サーバープールオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupExecServerPool

Backup Exec サーバープールオブジェクトを Add-BEServerToBackupExecServerPool にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEBackupExecServerPool

Add-BEServerToBackupExecServerPool は、Backup Exec サーバープールオブジェクトを返します。

Example

C:\PS> Get-BEBackupExecServerPool "Server Pool 0001" | Add-BEServerToBackupExecServerPool -BackupExecServer "MyManagedServer"

これらのコマンドは、「MyManagedServer」という名前の管理対象 Backup Exec サーバーを「Server Pool 0001」という名前のサーバープールに追加します。

Related Link

Get-BEBackupExecServerPool


Add-BESharePointFarmAgentServer Help

Add-BESharePointFarmAgentServer Cmdlet
Synopsis

SharePoint ファームを Backup Exec に追加します。

Syntax
Add-BESharePointFarmAgentServer [-Name] <String> [-LogonAccount] <BELogonAccount> -WebServerName <String> [-ExcludeFromScheduledCredentialTest <Boolean>] [-Description <String>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [-Force <SwitchParameter>] [<CommonParameters>]
Description

SharePoint ファームを Backup Exec に追加します。

Parameters

-WebServerName <String>

SharePoint ファームの Web サーバーの名前を指定します

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LogonAccount <BELogonAccount>

SharePoint ファームのサーバーへのアクセスに使用する Backup Exec ログオンアカウントを指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

SharePoint ファームの説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExcludeFromScheduledCredentialTest <Boolean>

スケジュール済みクレデンシャルテストからエージェントサーバーを除外します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

SharePoint ファームの名前を指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | true

-Force <SwitchParameter>

Add-BESharePointFarmAgentServer で SharePoint ファームのすべてのサーバーと信頼を確立できることを確認します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

追加する SharePoint ファームオブジェクトの名前を含む文字列を Add-BESharePointFarmAgentServer にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BESharePointFarmAgentServer

Add-BESharePointFarmAgentServer は、追加された SharePoint ファームエージェントサーバーを返します。

Example

C:\PS> Add-BESharePointFarmAgentServer -Name Farm01 -WebServerName webserver01 -LogonAccount "System Logon Account"

このコマンドは、「webserver01」という名前の Web サーバーがメンバーである SharePoint ファームを追加します。


Add-BETapeDriveDeviceToRoboticLibraryPartition Help

Add-BETapeDriveDeviceToRoboticLibraryPartition Cmdlet
Synopsis

Backup Exec のロボットライブラリパーティションにテープドライブデバイスを追加します。

Syntax
Add-BETapeDriveDeviceToRoboticLibraryPartition -InputObject <BERoboticLibraryPartition[]> [-TapeDriveDevice] <BETapeDriveDevice[]> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のロボットライブラリパーティションにテープドライブデバイスを追加します。

ロボットライブラリパーティションに関連付けられたロボットライブラリデバイスにテープドライブデバイスが接続されている必要があります。

ロボットライブラリパーティションを作成するには、-SlotsPerPartition と -BERoboticLibraryDevice を使用します。

Parameters

-TapeDriveDevice <BETapeDriveDevice[]>

ロボットライブラリパーティションに追加するテープデバイスです。 Get-BETapeDriveDevice を参照してください。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BERoboticLibraryPartition[]>

1 つ以上のロボットライブラリパーティションオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BERoboticLibraryPartition

Backup Exec のロボットライブラリパーティションオブジェクトを Add-BETapeDriveDeviceToRoboticLibraryPartition にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BERoboticLibraryPartition

Add-BETapeDriveDeviceToRoboticLibraryPartition は Backup Exec ロボットライブラリパーティションオブジェクトを出力します。

Example

C:\PS> Get-BERoboticLibraryDevice "Robotic library 0001" | Get-BERoboticLibraryPartition -FirstSlotNumber 1 | Add-BETapeDriveDeviceToRoboticLibraryPartition "Tape drive 0001"

これらのコマンドは「Robotic library 0001」という名前のロボットライブラリデバイスのスロット 1 で開始するロボットライブラリパーティションに「Tape drive 0001」という名前のテープドライブデバイスを追加します。

Related Links


Add-BEVerifyBackupTask Help

Add-BEVerifyBackupTask Cmdlet
Synopsis

検証タスクを Backup Exec のバックアップ定義に追加します。

Syntax
Add-BEVerifyBackupTask -BackupDefinition <BEBackupDefinition> [[-Name] <String>] -ImmediatelyAfterBackup <String> [-IncludeJobLogWithEmailNotification <Boolean>] [-VerifyDataOnClient <Boolean>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Add-BEVerifyBackupTask -BackupDefinition <BEBackupDefinition> [[-Name] <String>] -Schedule <BESchedule> -SourceBackup <String[]> [-IncludeJobLogWithEmailNotification <Boolean>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-VerifyDataOnClient <Boolean>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Add-BEVerifyBackupTask -BackupJobDefault <BEBackupJobDefaults> [[-Name] <String>] -ImmediatelyAfterBackup <String> [-IncludeJobLogWithEmailNotification <Boolean>] [-VerifyDataOnClient <Boolean>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Add-BEVerifyBackupTask -BackupJobDefault <BEBackupJobDefaults> [[-Name] <String>] -Schedule <BESchedule> -SourceBackup <String[]> [-IncludeJobLogWithEmailNotification <Boolean>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-VerifyDataOnClient <Boolean>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Add-BEVerifyBackupTask -SyntheticBackupDefinition <BESyntheticBackupDefinition> [[-Name] <String>] -ImmediatelyAfterBackup <String> [-IncludeJobLogWithEmailNotification <Boolean>] [-VerifyDataOnClient <Boolean>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Add-BEVerifyBackupTask -SyntheticBackupDefinition <BESyntheticBackupDefinition> [[-Name] <String>] -Schedule <BESchedule> -SourceBackup <String[]> [-IncludeJobLogWithEmailNotification <Boolean>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-VerifyDataOnClient <Boolean>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Add-BEVerifyBackupTask -SyntheticBackupJobDefault <BESyntheticBackupJobDefaults> [[-Name] <String>] -ImmediatelyAfterBackup <String> [-IncludeJobLogWithEmailNotification <Boolean>] [-VerifyDataOnClient <Boolean>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Add-BEVerifyBackupTask -SyntheticBackupJobDefault <BESyntheticBackupJobDefaults> [[-Name] <String>] -Schedule <BESchedule> -SourceBackup <String[]> [-IncludeJobLogWithEmailNotification <Boolean>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-VerifyDataOnClient <Boolean>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

検証タスクを Backup Exec のバックアップ定義に追加します。

検証タスクを新しいバックアップ定義に追加するか、既存のバックアップ定義を編集できます。 また、検証タスクをバックアップジョブのデフォルトに追加することもできます。

検証タスクを新しいバックアップ定義に追加するには、Add-BEVerifyBackupTask と New-BEBackupDefinition を使用します。

バックアップ定義を編集して検証タスクを追加するには、Add-BEVerifyBackupTask と Get-BEBackupDefinition を使用します。

検証タスクをバックアップジョブのデフォルトに追加するには、Add-BEVerifyBackupTask と Get-BEBackupJobDefault を使用します。

バックアップ定義を作成または編集する場合、そのバックアップ定義を Save-BEBackupDefinition に渡して変更をコミットする必要があります。

バックアップジョブのデフォルトを編集する場合、そのバックアップジョブのデフォルトを Save-BEBackupJobDefault に渡して変更をコミットする必要があります。

Parameters

-BackupDefinition <BEBackupDefinition>

変更するバックアップ定義を指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupJobDefault <BEBackupJobDefaults>

変更するバックアップジョブのデフォルトを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-SyntheticBackupDefinition <BESyntheticBackupDefinition>

変更する合成バックアップ定義を指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-SyntheticBackupJobDefault <BESyntheticBackupJobDefaults>

変更する合成バックアップジョブのデフォルトを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-SourceBackup <String[]>

1 つまたは複数のバックアップをバックアップ定義で指定して、スケジュールの設定単位で検証します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ImmediatelyAfterBackup <String>

バックアップ定義で検証するバックアップジョブの名前を指定します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Schedule <BESchedule>

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VerifyDataOnClient <Boolean>

Backup Exec エージェントがサポートしている場合には、検証操作をリモートで実行できます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NotificationRecipientList <BENotificationRecipientObject[]>

ジョブが完了したときに通知を受け取る受信者を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IncludeJobLogWithEmailNotification <Boolean>

電子メールにジョブログを添付します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

検証タスクの名前を指定します。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupDefinition

Backup Exec バックアップ定義オブジェクトを Add-BEVerifyBackupTask にパイプ処理できます。

BackupExec.Management.CLI.BEBackupJobDefaults

Backup Exec バックアップジョブのデフォルトオブジェクトを Add-BEVerifyBackupTask にパイプ処理できます。

Return Values
BackupExec.Management.CLI.BEBackupDefinition

修正されたバックアップ定義を示します。

BackupExec.Management.CLI.BEBackupJobDefaults

修正されたバックアップジョブのデフォルトを示します。

Examples

Example 1

C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition BackupToDisk | Add-BEVerifyBackupTask -SourceBackup Full,Incremental -Schedule (New-BESchedule -Weekdays -StartingAt 10PM) | Save-BEBackupDefinition

これらのコマンドは、平日の毎日午後 10 時に「Full」および「Incremental」という名前のバックアップジョブからのデータを検証するバックアップ定義を作成します。

Example 2
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition BackupToDisk | Add-BEVerifyBackupTask -ImmediatelyAfterBackup Full | Save-BEBackupDefinition

これらのコマンドでは、バックアップジョブの完了後、「Full」という名前のバックアップジョブからのデータを検証する検証タスクがあるバックアップ定義を作成します。

Related Links


Add-BEVMwareAgentServer Help

Add-BEVMwareAgentServer Cmdlet
Synopsis

VMware サーバーを Backup Exec に追加します。

Syntax
Add-BEVMwareAgentServer [-Name] <String> [-LogonAccount] <BELogonAccount> [-ExcludeFromScheduledCredentialTest <Boolean>] [-Description <String>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

VMware サーバーを Backup Exec に追加します。

Parameters

-LogonAccount <BELogonAccount>

VMware サーバーへのアクセスに使用する Backup Exec ログオンアカウントを指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

VMware サーバーの説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExcludeFromScheduledCredentialTest <Boolean>

スケジュール済みクレデンシャルテストからエージェントサーバーを除外します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

VMware サーバーの名前を指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | true

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

作成する Backup Exec VMware エージェントサーバーオブジェクトの名前を含む文字列を Add-BEVMwareAgentServer にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEVMwareAgentServer

Add-BEVMwareAgentServer は、作成された VMware エージェントサーバーを返します。

Example

C:\PS> Add-BEVMwareAgentServer -Name "VCenterHost" -LogonAccount "VMware Logon Account"

このコマンドは、「VMware Logon Account」という名前の Backup Exec のログオンアカウントに格納されたクレデンシャルを使用して、「VCenterHost」という名前の VMware VCenter を追加します。


Clear-BEAlert Help

Clear-BEAlert Cmdlet
Synopsis

アクティブな Backup Exec アラートをクリアします。

Syntax
Clear-BEAlert -InputObject <BEAlert[]> [-Response] {None | Ok | Cancel | Abort | Retry | Ignore | Yes | No | Try | Continue} [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

アクティブな Backup Exec アラートをクリアします。

Get-BEAlert を使用して、アクティブな Backup Exec アラートを取得します。

Parameters

-Response

アラートへの応答を指定します。

The valid values are:
None
Ok
Cancel
Abort
Retry
Ignore
Yes
No
Try
Continue

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEAlert[]>

1 つまたは複数のアラートオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEAlert

Backup Exec アラートオブジェクトを、パイプを使用して Clear-BEAlert に渡すことができます。

Return Value
BackupExec.Management.CLI.BEAlert

Clear-BEAlert は、クリアした Backup Exec アラートを表すオブジェクトを返します。

Example

C:\PS> Get-BEAlert -Severity Information | Clear-BEAlert -Response Ok

これらのコマンドは、すべてのアクティブな Backup Exec 情報アラートをクリアします。

Related Link

Get-BEAlert


Export-BEBackupDefinition Help

Export-BEBackupDefinition Cmdlet
Synopsis

バックアップ定義のジョブ設定を PowerShell スクリプトにエクスポートします。

Syntax
Export-BEBackupDefinition [-BackupDefinition] <BEBackupDefinition> [<CommonParameters>]
Description

バックアップ定義のジョブ設定を PowerShell スクリプトにエクスポートします。

Export-BEBackupDefinition が生成するスクリプトは、以前のリリースの Backup Exec におけるジョブポリシーと同義です。

このスクリプトを使って、追加のエージェントサーバーの新規バックアップジョブを作成し、元のバックアップ定義に含まれていた同じジョブ設定を使用して選択項目をバックアップできます。

スクリプトは自己完結であるため、他の Backup Exec サーバーでも実行可能です。

生成されたスクリプトを実行するには、AllSigned よりも制限の少ない値に PowerShell の実行ポリシーを設定する必要があります。 詳しくは、Get-Help Set-ExectuionPolicy を参照してください。

Parameters

-BackupDefinition <BEBackupDefinition>

エクスポートするバックアップ定義。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupDefinition

バックアップ定義オブジェクトを Get-BEBackupDefinition にパイプ処理できます。

Return Value
System.String

Export-BEBackupDefinition は、バックアップ定義のジョブ設定を再作成することができる PowerShell スクリプトを返します。

Example

C:\PS> Get-BEBackupDefinition "Backup 01" | Export-BEBackupDefinition >ExportedBackup01.ps1
C:\PS> Get-BEAgentServer "myserver.mycompany.com" | .\ExportedBackup01.ps1 -FileSystemSelection C:\Users\* | Save-BEBackupDefinition

これらのコマンドは、「Backup 01」という名前のバックアップ定義のジョブ設定を「ExportedBackup01.ps1」という名前の PowerShell スクリプトファイルにエクスポートします。 このスクリプトファイルは、「Backup 01」という名前のバックアップ定義にあった同じジョブ設定を使用して「myserver.mycompany.com」という名前のサーバーの C:\Users ディレクトリをバックアップするときに使用されます。

スクリプトファイルは自己完結であるため、別の Backup Exec サーバーにコピーしたり、そのサーバーから実行したりできます。

Related Links


Export-BEItemsBlocked Help

Export-BEItemsBlocked Cmdlet
Synopsis

ブロックされた項目に関する情報を指定された場所で CSV にエクスポートします。

Syntax
Export-BEItemsBlocked [-CsvFilePath] <String> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

ブロックされた項目に関する情報を指定された場所で CSV にエクスポートします。
エクスポートした CSV には、ブロックされた項目のサーバー名とフルパスが含まれます。
エクスポートした CSV ファイルには、複数のサーバーからの項目に関する情報を含めることができます。
CSV の名前の形式は BE-BLockedFiles-TimeStamp.csv です。
Export-BEItemsBlocked コマンドを実行して、インポートしたブロックされた項目のバックアップを定期的に作成することをお勧めします。

Parameters

-CsvFilePath <String>

エクスポートした CSV ファイルを作成する場所を指定します。指定した場所はローカルドライブに存在する必要があります。

Required | true
Position | 1
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

このコマンドレットは入力を受け入れません。

Return Value
None

コマンドが成功した場合、Export-BEItemsBlocked は何も返しません。コマンドが失敗した場合は、例外を返します。

Example

C:\PS> Export-BEItemsBlocked -CsvFilePath C:\csvFiles

ブロックされた項目に関する情報を CSV にエクスポートします。CSV には「ServerName」と「FullPath」の列ヘッダーがあり、ブロックされた項目のサーバー名とフルパスが含まれます。エクスポートした CSV ファイルは「C:\csvFiles」に保存されます。


Get-BEActiveJobDetail Help

Get-BEActiveJobDetail Cmdlet
Synopsis

Backup Exec で実行中のジョブの詳細を取得します。

Syntax
Get-BEActiveJobDetail [[-Name] <String[]>] [<CommonParameters>]

Get-BEActiveJobDetail -Job <BEJob[]> [[-Name] <String[]>] [<CommonParameters>]

Get-BEActiveJobDetail [-Id] <Guid[]> [<CommonParameters>]

Get-BEActiveJobDetail -InputObject <BEActiveJobDetail[]> [<CommonParameters>]
Description

Backup Exec で実行中のジョブの詳細を取得します。

パラメータを指定しない場合、Get-BEActiveJobDetail は Backup Exec で実行中のすべてのジョブの詳細を取得します。 実行中のジョブの詳細名または実行中のジョブの詳細 ID (Guid) を使用して実行中のジョブの詳細を指定することも、パイプラインを介して Backup Exec で実行中のジョブの状態オブジェクトを Get-BEActiveJobDetail に渡すこともできます。

Parameters

-Job <BEJob[]>

1 つ以上のジョブオブジェクトを指定して、実行中のジョブの詳細をフィルタ処理します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEJob を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

1 つ以上の実行中のジョブの詳細をその名前 (ワイルドカードを使用可能) で指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

実行中のジョブの詳細 ID (Guid) を使用して、1 つ以上の実行中のジョブの詳細を指定します。 複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEActiveJobDetail[]>

1 つ以上の実行中のジョブの詳細オブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEJob

Backup Exec ジョブオブジェクトをパイプ処理して、Get-BEActiveJobDetail によって返される実行中のジョブの詳細をフィルタ処理できます。

System.Guid

Backup Exec で実行中のジョブの詳細オブジェクトの ID を含む System.Guid を Get-BEActiveJobDetail にパイプ処理できます。

BackupExec.Management.CLI.BEActiveJobDetail

Backup Exec で実行中のジョブの詳細オブジェクトを Get-BEActiveJobDetail にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEActiveJobDetail

Get-BEActiveJobDetail は、Backup Exec で実行中のジョブの詳細を表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEActiveJobDetail

このコマンドは、Backup Exec で実行中のすべてのジョブの詳細オブジェクトを取得します。

Example 2
C:\PS> Get-BEJob "Backup Job 0001" | Get-BEActiveJobDetail

これらのコマンドは、「Backup Job 0001」という名前のジョブの実行中のジョブの詳細を取得します。

Related Link

Get-BEJob


Get-BEAgentServer Help

Get-BEAgentServer Cmdlet
Synopsis

Backup Exec のエージェントサーバーを取得します。

Syntax
Get-BEAgentServer [[-Name] <String[]>] [-BackupStatus {Unknown | BackupSucceeded | BackupSucceededWithExceptions | NeverBackedUp | FirstBackupScheduled | BackupCanceled | BackupFailed}] [-Force <SwitchParameter>] [<CommonParameters>]

Get-BEAgentServer [-Local <SwitchParameter>] [-Force <SwitchParameter>] [<CommonParameters>]

Get-BEAgentServer [-AgentServerGroup <BEAgentServerGroup>] [-Force <SwitchParameter>] [<CommonParameters>]

Get-BEAgentServer -LogonAccount <BELogonAccount[]> [[-Name] <String[]>] [-BackupStatus {Unknown | BackupSucceeded | BackupSucceededWithExceptions | NeverBackedUp | FirstBackupScheduled | BackupCanceled | BackupFailed}] [-Force <SwitchParameter>] [<CommonParameters>]

Get-BEAgentServer [-Id] <Guid[]> [-Force <SwitchParameter>] [<CommonParameters>]

Get-BEAgentServer -InputObject <BEAgentServer[]> [-Force <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のエージェントサーバーを取得します。

エージェントサーバーオブジェクトは、バックアップまたはリストア可能でログオンアカウントに関連付けられるサーバーを表します。

パラメータが指定されていない場合、Get-BEAgentServer は破棄されていないすべての Backup Exec エージェントサーバーを取得します。また、エージェントサーバー名またはエージェントサーバー ID (Guid) を使用してエージェントサーバーを指定することも、パイプラインを通じて Backup Exec エージェントサーバーオブジェクトを Get-BEAgentServer に渡すこともできます。

ローカルコンピュータを表すエージェントサーバーオブジェクトを取得するには、-Local パラメータを指定します。

Parameters

-Local <SwitchParameter>

ローカルコンピュータのエージェントサーバーオブジェクトを取得します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AgentServerGroup <BEAgentServerGroup>

エージェントサーバーをフィルタするエージェントサーバーグループを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEAgentServerGroup を参照してください。

Required | false
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-LogonAccount <BELogonAccount[]>

1 つ以上のログオンアカウントオブジェクトを指定して、エージェントサーバーをフィルタ処理します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BELogonAccount を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

1 つ以上のエージェントサーバーをエージェントサーバー名で (ワイルドカードを使用可能) 指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-BackupStatus

1 つ以上のバックアップ状態オブジェクトを指定して、エージェントサーバーをフィルタ処理します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEBackupStatus を参照してください。

The valid values are:
Unknown
BackupSucceeded
BackupSucceededWithExceptions
NeverBackedUp
FirstBackupScheduled
BackupCanceled
BackupFailed

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Id <Guid[]>

エージェントサーバー ID (Guid) を使用して、1 つ以上のエージェントサーバーを指定します。 複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEAgentServer[]>

1 つ以上のエージェントサーバーオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Force <SwitchParameter>

破棄されたエージェントサーバーを含むエージェントサーバーオブジェクトを取得します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BELogonAccount

Backup Exec ログオンアカウントオブジェクトをパイプ処理して、Get-BEAgentServer によって返されるエージェントサーバーをフィルタ処理できます。

System.Guid

Backup Exec エージェントサーバーオブジェクトの ID を含む System.Guid を Get-BEAgentServer にパイプ処理できます。

BackupExec.Management.CLI.BEAgentServerGroup

Backup Exec エージェントサーバーグループオブジェクトを Get-BEAgentServer にパイプ処理できます。

BackupExec.Management.CLI.BEAgentServer

Backup Exec エージェントサーバーオブジェクトを Get-BEAgentServer にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEAgentServer

Get-BEAgentServer は、Backup Exec エージェントサーバーを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEAgentServer

このコマンドは、すべてのエージェントサーバーを取得します。

Example 2
C:\PS> Get-BEAgentServer -Force

このコマンドは、破棄されたエージェントサーバーを含むすべてのエージェントサーバーを取得します。

Example 3
C:\PS> Get-BEAgentServer -Name "myserver.mycompany.com"

このコマンドは「myserver.mycompany.com」という名前のエージェントサーバーを取得します。

Example 4
C:\PS> Get-BEAgentServer -Name "*.mycompany.com"

このコマンドは、ワイルドカード「*.mycompany.com」と一致するすべてのエージェントサーバーを取得します。

Example 5
C:\PS> Get-BEAgentServer -Local

このコマンドは、ローカルコンピュータのエージェントサーバーを取得します。

Example 6
C:\PS> Get-BEAgentServer -Local | Set-BEAgentServerBackupSource

これらのコマンドは、ローカルコンピュータのバックアップソースを取得します。

Example 7
C:\PS> Get-BEAgentServer -Local | Set-BEAgentServer -LogonAccount "System Logon Account"

これらのコマンドは、ローカルコンピュータを表すエージェントサーバーのログオンアカウントを設定します。

Example 8
C:\PS> Get-BEAgentServer -Local | Test-BELogonAccount

これらのコマンドは、ローカルコンピュータを表すエージェントサーバーのログオンアカウントをテストします。

Example 9
C:\PS> Get-BEAgentServer -Local | Submit-BEOnetimeBackup

これらのコマンドは、ローカルコンピュータ全体をバックアップするワンタイムバックアップをサブミットします。

Example 10
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition BackupToDisk | Save-BEBackupDefinition

これらのコマンドは、ローカルコンピュータ全体をバックアップするバックアップ定義をサブミットします。

Example 11
C:\PS> Get-BEAgentServerGroup "Accounting" | Get-BEAgentServer | New-BEBackupDefinition BackupToDisk | Save-BEBackupDefinition

これらのコマンドは、「Accounting」エージェントサーバーグループのすべてのサーバーをバックアップするバックアップ定義をサブミットします。

Related Links

Get-BELogonAccount
Get-BEAgentServerGroup
Set-BEAgentServerBackupSource
Set-BEAgentServer
Test-BELogonAccount
New-BEBackupDefinition
Save-BEBackupDefinition


Get-BEAgentServerBackupSource Help

Get-BEAgentServerBackupSource Cmdlet
Synopsis

Backup Exec のエージェントサーバーのバックアップソースを取得します。

Syntax
Get-BEAgentServerBackupSource -AgentServer <BEAgentServer> [[-Name] <String[]>] [<CommonParameters>]

Get-BEAgentServerBackupSource -InputObject <BEAgentServerBackupSource[]> [-Children <SwitchParameter>] [<CommonParameters>]

Get-BEAgentServerBackupSource [-Id] <Guid[]> [<CommonParameters>]
Description

Backup Exec のエージェントサーバーのバックアップソースを取得します。

エージェントサーバーのバックアップソースは、バックアップ可能で、ログオンアカウントに関連付けることができるエージェントサーバーのリソースを表します。

エージェントサーバーに関連付けられた、トップレベルのエージェントサーバーのバックアップソースを取得するには、Get-BEAgentServerBackupSource にエージェントサーバーオブジェクトが必要です。 Get-BEAgentServer を参照してください。

追加パラメータを指定しない場合、Get-BEAgentServerBackupSource はすべての Backup Exec エージェントサーバーのバックアップソースを取得します。 また、エージェントサーバーのバックアップソース名、またはエージェントサーバーのバックアップソース ID (Guid) を使用してエージェントサーバーのバックアップソースを指定するか、パイプラインを通じて Backup Exec エージェントサーバーのバックアップオブジェクトを Get-BEAgentServerBackupSource に渡すこともできます。

Parameters

-AgentServer <BEAgentServer>

エージェントサーバーのバックアップソースを取得するエージェントサーバーを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Children <SwitchParameter>

-InputObject パラメータで指定されたエージェントサーバーのバックアップソースオブジェクトに関連付けられた子エージェントサーバーのバックアップソースを取得します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEAgentServerBackupSource[]>

1 つ以上のエージェントサーバーのバックアップソースオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

エージェントサーバーのバックアップソース名 (ワイルドカードを使用可能) を使用して、1 つ以上のエージェントサーバーのバックアップソースを指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

エージェントサーバーのバックアップソース ID (Guid) を使用して、1 つ以上のエージェントサーバーのバックアップソースを指定します。 複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEAgentServer

Backup Exec エージェントサーバーオブジェクトを Get-BEAgentServerBackupSource にパイプ処理できます。

BackupExec.Management.CLI.BEAgentServerBackupSource

Backup Exec エージェントサーバーのバックアップソースオブジェクトを Get-BEAgentServerBackupSource にパイプ処理できます。

System.Guid

Backup Exec エージェントサーバーのバックアップソースオブジェクトの ID を含む System.Guid を Get-BEAgentServerBackupSource にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEAgentServerBackupSource

Get-BEAgentServerBackupSource は、Backup Exec エージェントサーバーのバックアップソースを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEAgentServer -Local | Get-BEAgentServerBackupSource

これらのコマンドは、ローカルコンピュータに関連付けられたトップレベルのエージェントサーバーのバックアップソースを取得します。

Example 2
C:\PS> Get-BEAgentServer -Local | Get-BEAgentServerBackupSource "Microsoft SQL Server Instances" | Get-BEAgentServerBackupSource -Children

これらのコマンドは、ローカルコンピュータに関連付けられた Microsoft SQL インスタンスのバックアップソースを取得します。

Example 3
C:\PS> Get-BEAgentServer -Local | Get-BEAgentServerBackupSource C: | Set-BEAgentServerBackupSource -LogonAccount "System Logon Account"

これらのコマンドは、ローカルコンピュータの C: ボリュームに関連付けられたログオンアカウントを設定します。

Example 4
C:\PS> Get-BEAgentServer -Local | Get-BEAgentServerBackupSource C: | Test-BELogonAccount

これらのコマンドは、ローカルコンピュータの C: ボリュームに関連付けられたログオンアカウントをテストします。

Related Links


Get-BEAgentServerGroup Help

Get-BEAgentServerGroup Cmdlet
Synopsis

Backup Exec エージェントサーバーグループを取得します。

Syntax
Get-BEAgentServerGroup [[-Name] <String[]>] [<CommonParameters>]

Get-BEAgentServerGroup [-Retired <SwitchParameter>] [<CommonParameters>]

Get-BEAgentServerGroup [-Id] <Guid[]> [<CommonParameters>]

Get-BEAgentServerGroup -InputObject <BEAgentServerGroup[]> [<CommonParameters>]
Description

Backup Exec エージェントサーバーグループを取得します。

パラメーターなしで、Get-BEAgentServerGroup はすべての Backup Exec エージェントサーバーグループを取得します。また、エージェントサーバーのグループ名やエージェントサーバーのグループ ID (Guid) を使用して特定のエージェントサーバーグループを指定したり、パイプラインを通じて Backup Exec エージェントサーバーのグループオブジェクトを Get-BEAgentServerGroup に渡したりすることもできます。

Parameters

-Retired <SwitchParameter>

破棄サーバーを含むエージェントサーバーグループオブジェクトを取得します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String[]>

1 つ以上のエージェントサーバーグループをエージェントサーバーのグループ名 (ワイルドカードを使用可能) で指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

エージェントサーバーのグループ ID (Guid) を使用して、1 つ以上のエージェントサーバーグループを指定します。 複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEAgentServerGroup[]>

1 つ以上のエージェントサーバーグループオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
System.Guid

Backup Exec エージェントサーバーオブジェクトの ID を含む System.Guid を Get-BEAgentServerGroup にパイプ処理できます。

BackupExec.Management.CLI.BEAgentServerGroup

Backup Exec エージェントサーバーグループオブジェクトを Get-BEAgentServerGroup にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEAgentServerGroup

Get-BEAgentServerGroup は、Backup Exec エージェントサーバーグループを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEAgentServerGroup

このコマンドは、すべてのエージェントサーバーグループを取得します。

Example 2
C:\PS> Get-BEAgentServer -local | Get-BEAgentServerGroup

これらのコマンドはローカル Backup Exec サーバーを含んでいるエージェントサーバーグループをすべて取得します。

Example 3
C:\PS> Get-BEAgentServer "Win*" | Get-BEAgentServerGroup

これらのコマンドは名前に「Win*」が含まれているエージェントサーバーを含んでいるすべてのエージェントサーバーグループを取得します。

Example 4
C:\PS> Get-BEAgentServerGroup -Retired | Get-BEAgentServer

これらのコマンドは破棄されたエージェントサーバーグループ内のエージェントサーバーをすべて取得します。

Related Link

Get-BEAgentServer


Get-BEAlert Help

Get-BEAlert Cmdlet
Synopsis

アクティブな Backup Exec アラートを取得します。

Syntax
Get-BEAlert [[-Name] <String[]>] [-Category {None | JobWarning | JobSuccess | JobFailure | JobCancellation | CatalogError | SoftwareUpdateInformation | SoftwareUpdateWarning | SoftwareUpdateError | InstallInformation | InstallWarning | GeneralInformation | DatabaseMaintenanceInformation | DatabaseMaintenanceFailure | BackupExecRetrieveUrlUpdateInformation | BackupExecRetrieveUrlUpdateFailure | IdrCopyFailed | IdrFullBackupSuccess | BackupJobContainsNoData | JobCompletedWithExceptions | JobStart | ServiceStart | ServiceStop | DeviceError | DeviceWarning | DeviceInformation | DeviceIntervention | MediaError | MediaWarning | MediaInformation | MediaIntervention | MediaInsert | MediaOverwrite | MediaRemove | LibraryInsert | TapeAlertInformation | TapeAlertWarning | TapeAlertError | IdrFullBackupSuccessWarning | LicenseAndMaintenanceWarning}] [-Severity {None | Information | Question | Warning | Error}] [<CommonParameters>]

Get-BEAlert -Storage <BEStorage[]> [[-Name] <String[]>] [-Category {None | JobWarning | JobSuccess | JobFailure | JobCancellation | CatalogError | SoftwareUpdateInformation | SoftwareUpdateWarning | SoftwareUpdateError | InstallInformation | InstallWarning | GeneralInformation | DatabaseMaintenanceInformation | DatabaseMaintenanceFailure | BackupExecRetrieveUrlUpdateInformation | BackupExecRetrieveUrlUpdateFailure | IdrCopyFailed | IdrFullBackupSuccess | BackupJobContainsNoData | JobCompletedWithExceptions | JobStart | ServiceStart | ServiceStop | DeviceError | DeviceWarning | DeviceInformation | DeviceIntervention | MediaError | MediaWarning | MediaInformation | MediaIntervention | MediaInsert | MediaOverwrite | MediaRemove | LibraryInsert | TapeAlertInformation | TapeAlertWarning | TapeAlertError | IdrFullBackupSuccessWarning | LicenseAndMaintenanceWarning}] [-Severity {None | Information | Question | Warning | Error}] [<CommonParameters>]

Get-BEAlert -Job <BEJob[]> [[-Name] <String[]>] [-Category {None | JobWarning | JobSuccess | JobFailure | JobCancellation | CatalogError | SoftwareUpdateInformation | SoftwareUpdateWarning | SoftwareUpdateError | InstallInformation | InstallWarning | GeneralInformation | DatabaseMaintenanceInformation | DatabaseMaintenanceFailure | BackupExecRetrieveUrlUpdateInformation | BackupExecRetrieveUrlUpdateFailure | IdrCopyFailed | IdrFullBackupSuccess | BackupJobContainsNoData | JobCompletedWithExceptions | JobStart | ServiceStart | ServiceStop | DeviceError | DeviceWarning | DeviceInformation | DeviceIntervention | MediaError | MediaWarning | MediaInformation | MediaIntervention | MediaInsert | MediaOverwrite | MediaRemove | LibraryInsert | TapeAlertInformation | TapeAlertWarning | TapeAlertError | IdrFullBackupSuccessWarning | LicenseAndMaintenanceWarning}] [-Severity {None | Information | Question | Warning | Error}] [<CommonParameters>]

Get-BEAlert -AgentServer <BEAgentServer[]> [[-Name] <String[]>] [-Category {None | JobWarning | JobSuccess | JobFailure | JobCancellation | CatalogError | SoftwareUpdateInformation | SoftwareUpdateWarning | SoftwareUpdateError | InstallInformation | InstallWarning | GeneralInformation | DatabaseMaintenanceInformation | DatabaseMaintenanceFailure | BackupExecRetrieveUrlUpdateInformation | BackupExecRetrieveUrlUpdateFailure | IdrCopyFailed | IdrFullBackupSuccess | BackupJobContainsNoData | JobCompletedWithExceptions | JobStart | ServiceStart | ServiceStop | DeviceError | DeviceWarning | DeviceInformation | DeviceIntervention | MediaError | MediaWarning | MediaInformation | MediaIntervention | MediaInsert | MediaOverwrite | MediaRemove | LibraryInsert | TapeAlertInformation | TapeAlertWarning | TapeAlertError | IdrFullBackupSuccessWarning | LicenseAndMaintenanceWarning}] [-Severity {None | Information | Question | Warning | Error}] [<CommonParameters>]

Get-BEAlert [-Id] <Guid[]> [<CommonParameters>]

Get-BEAlert -InputObject <BEAlert[]> [<CommonParameters>]
Description

アクティブな Backup Exec アラートを取得します。パラメータを指定しない場合、Get-BEAlert はすべてのアクティブな Backup Exec アラートを取得します。アラート名またはアラート ID (Guid) を使用してアラートを指定したり、パイプラインを通じて Backup Exec アラートオブジェクトを Get-BEAlert に渡したりすることもできます。

Parameters

-Storage <BEStorage[]>

アラートをフィルタ処理するための 1 つまたは複数のストレージオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEStorage を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Job <BEJob[]>

アラートをフィルタ処理するための 1 つまたは複数のジョブオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEJob を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-AgentServer <BEAgentServer[]>

アラートをフィルタ処理するための 1 つまたは複数のエージェントサーバーオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEAgentServer を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

1 つまたは複数のアラートをアラート名で指定します。ワイルドカードを使用できます。複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Severity

アラートをフィルタ処理するための 1 つまたは複数の重大度の値を指定します。複数の値を指定する場合は、カンマを使用して値を区切ります。

The valid values are:
None
Information
Question
Warning
Error

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Category

アラートをフィルタ処理するための 1 つまたは複数のカテゴリの値を指定します。複数の値を指定する場合は、カンマを使用して値を区切ります。

The valid values are:
None
JobWarning
JobSuccess
JobFailure
JobCancellation
CatalogError
SoftwareUpdateInformation
SoftwareUpdateWarning
SoftwareUpdateError
InstallInformation
InstallWarning
GeneralInformation
DatabaseMaintenanceInformation
DatabaseMaintenanceFailure
BackupExecRetrieveUrlUpdateInformation
BackupExecRetrieveUrlUpdateFailure
IdrCopyFailed
IdrFullBackupSuccess
BackupJobContainsNoData
JobCompletedWithExceptions
JobStart
ServiceStart
ServiceStop
DeviceError
DeviceWarning
DeviceInformation
DeviceIntervention
MediaError
MediaWarning
MediaInformation
MediaIntervention
MediaInsert
MediaOverwrite
MediaRemove
LibraryInsert
TapeAlertInformation
TapeAlertWarning
TapeAlertError
IdrFullBackupSuccessWarning
LicenseAndMaintenanceWarning

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Id <Guid[]>

1 つまたは複数のアラートをアラート ID (GUID) で指定します。複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEAlert[]>

1 つまたは複数のアラートオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEStorage

パイプを使用して Backup Exec ストレージオブジェクトを渡し、Get-BEAlert で返されるアラートをフィルタ処理できます。

BackupExec.Management.CLI.BEJob

パイプを使用して Backup Exec ジョブオブジェクトを渡し、Get-BEAlert で返されるアラートをフィルタ処理できます。

BackupExec.Management.CLI.BEAgentServer

パイプを使用して Backup Exec エージェントサーバーオブジェクトを渡し、Get-BEAlert で返されるアラートをフィルタ処理できます。

System.Guid

Backup Exec アラートオブジェクトの ID を含む System.Guid を、パイプを使用して Get-BEAlert に渡すことができます。

BackupExec.Management.CLI.BEAlert

パイプを使用して Backup Exec アラートオブジェクトを Get-BEAlert に渡すことができます。

Return Value
BackupExec.Management.CLI.BEAlert

Get-BEAlert は Backup Exec アラートを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEAlert

このコマンドでは、すべての Backup Exec アクティブアラートを取得します。

Example 2
C:\PS> @(Get-BEAlert -Severity Error).Count

このコマンドでは、アクティブなエラーアラートの数を取得します。

Example 3
C:\PS> Get-BEAlert -Severity Information | Clear-BEAlert -Response Ok

これらのコマンドでは、すべてのアクティブな情報アラートをクリアします。

Example 4
C:\PS> Get-BEAgentServer myserver.mycompany.com | Get-BEAlert

これらのコマンドでは、「myserver.mycompany.com」という名前のコンピュータに関するすべてのアクティブアラートを取得します。

Example 5
C:\PS> Get-BEDiskStorageDevice "Disk storage 0001" | Get-BEAlert

これらのコマンドでは、「Disk storage 0001」という名前のディスクストレージデバイスに関するすべてのアクティブアラートを取得します。

Example 6
C:\PS> Get-BEJob "Backup of myserver.mycompany.com" | Get-BEAlert

これらのコマンドでは、「Backup of myserver.mycompany.com」という名前のジョブに関するすべてのアクティブアラートを取得します。

Related Links


Get-BEAlertCategory Help

Get-BEAlertCategory Cmdlet
Synopsis

Backup Exec のアラートカテゴリを取得します。

Syntax
Get-BEAlertCategory [[-Name] <String[]>] [<CommonParameters>]

Get-BEAlertCategory [-Id] <Guid[]> [<CommonParameters>]

Get-BEAlertCategory -InputObject <BEAlertCategory[]> [<CommonParameters>]
Description

Backup Exec のアラートカテゴリを取得します。

パラメータを指定しない場合、Get-BEAlertCategory はすべての Backup Exec アラートカテゴリを取得します。 アラートカテゴリ名またはアラートカテゴリ ID (Guid) を使用してアラートカテゴリを指定することも、パイプラインを通じて Backup Exec アラートカテゴリオブジェクトを Get-BEAlertCategory に渡すこともできます。

Parameters

-Name <String[]>

アラートカテゴリ名 (ワイルドカードを使用可能) を使用して、1 つ以上のアラートカテゴリを指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

アラートカテゴリ ID (Guid) を使用して、1 つ以上のアラートカテゴリを指定します。 複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEAlertCategory[]>

1 つ以上のアラートカテゴリオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
System.Guid

Backup Exec アラートカテゴリオブジェクトの ID を含む System.Guid を Get-BEAlertCategory にパイプ処理できます。

BackupExec.Management.CLI.BEAlertCategory

Backup Exec アラートカテゴリオブジェクトを Get-BEAlertCategory にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEAlertCategory

Get-BEAlertCategory devuelve objetos que representan a las categorías de alerta de Backup Exec.

Examples

Example 1

C:\PS> Get-BEAlertCategory

このコマンドは、すべてのアラートカテゴリを取得します。

Example 2
C:\PS> Get-BEAlertCategory -Name "Job Completed with Exceptions"

このコマンドは「Job Completed with Exceptions」という名前のアラートカテゴリを取得します。

Example 3
C:\PS> Get-BEAlertCategory -Name "Job*"

このコマンドは、ワイルドカード「Job*」と一致するすべてのアラートカテゴリを取得します。

Example 4
C:\PS> Get-BEAlertCategory -Name "Job Start" | Set-BEAlertCategory -Enabled $true

このコマンドは「Job Start」という名前のアラートカテゴリを有効にします。

Related Link

Set-BEAlertCategory


Get-BEAlertHistory Help

Get-BEAlertHistory Cmdlet
Synopsis

Backup Exec アラートのリストを取得します。

Syntax
Get-BEAlertHistory [[-Name] <String[]>] [-Category {None | JobWarning | JobSuccess | JobFailure | JobCancellation | CatalogError | SoftwareUpdateInformation | SoftwareUpdateWarning | SoftwareUpdateError | InstallInformation | InstallWarning | GeneralInformation | DatabaseMaintenanceInformation | DatabaseMaintenanceFailure | BackupExecRetrieveUrlUpdateInformation | BackupExecRetrieveUrlUpdateFailure | IdrCopyFailed | IdrFullBackupSuccess | BackupJobContainsNoData | JobCompletedWithExceptions | JobStart | ServiceStart | ServiceStop | DeviceError | DeviceWarning | DeviceInformation | DeviceIntervention | MediaError | MediaWarning | MediaInformation | MediaIntervention | MediaInsert | MediaOverwrite | MediaRemove | LibraryInsert | TapeAlertInformation | TapeAlertWarning | TapeAlertError | IdrFullBackupSuccessWarning | LicenseAndMaintenanceWarning}] [-Severity {None | Information | Question | Warning | Error}] [<CommonParameters>]

Get-BEAlertHistory -Storage <BEStorage[]> [[-Name] <String[]>] [-Category {None | JobWarning | JobSuccess | JobFailure | JobCancellation | CatalogError | SoftwareUpdateInformation | SoftwareUpdateWarning | SoftwareUpdateError | InstallInformation | InstallWarning | GeneralInformation | DatabaseMaintenanceInformation | DatabaseMaintenanceFailure | BackupExecRetrieveUrlUpdateInformation | BackupExecRetrieveUrlUpdateFailure | IdrCopyFailed | IdrFullBackupSuccess | BackupJobContainsNoData | JobCompletedWithExceptions | JobStart | ServiceStart | ServiceStop | DeviceError | DeviceWarning | DeviceInformation | DeviceIntervention | MediaError | MediaWarning | MediaInformation | MediaIntervention | MediaInsert | MediaOverwrite | MediaRemove | LibraryInsert | TapeAlertInformation | TapeAlertWarning | TapeAlertError | IdrFullBackupSuccessWarning | LicenseAndMaintenanceWarning}] [-Severity {None | Information | Question | Warning | Error}] [<CommonParameters>]

Get-BEAlertHistory -Job <BEJob[]> [[-Name] <String[]>] [-Category {None | JobWarning | JobSuccess | JobFailure | JobCancellation | CatalogError | SoftwareUpdateInformation | SoftwareUpdateWarning | SoftwareUpdateError | InstallInformation | InstallWarning | GeneralInformation | DatabaseMaintenanceInformation | DatabaseMaintenanceFailure | BackupExecRetrieveUrlUpdateInformation | BackupExecRetrieveUrlUpdateFailure | IdrCopyFailed | IdrFullBackupSuccess | BackupJobContainsNoData | JobCompletedWithExceptions | JobStart | ServiceStart | ServiceStop | DeviceError | DeviceWarning | DeviceInformation | DeviceIntervention | MediaError | MediaWarning | MediaInformation | MediaIntervention | MediaInsert | MediaOverwrite | MediaRemove | LibraryInsert | TapeAlertInformation | TapeAlertWarning | TapeAlertError | IdrFullBackupSuccessWarning | LicenseAndMaintenanceWarning}] [-Severity {None | Information | Question | Warning | Error}] [<CommonParameters>]

Get-BEAlertHistory -AgentServer <BEAgentServer[]> [[-Name] <String[]>] [-Category {None | JobWarning | JobSuccess | JobFailure | JobCancellation | CatalogError | SoftwareUpdateInformation | SoftwareUpdateWarning | SoftwareUpdateError | InstallInformation | InstallWarning | GeneralInformation | DatabaseMaintenanceInformation | DatabaseMaintenanceFailure | BackupExecRetrieveUrlUpdateInformation | BackupExecRetrieveUrlUpdateFailure | IdrCopyFailed | IdrFullBackupSuccess | BackupJobContainsNoData | JobCompletedWithExceptions | JobStart | ServiceStart | ServiceStop | DeviceError | DeviceWarning | DeviceInformation | DeviceIntervention | MediaError | MediaWarning | MediaInformation | MediaIntervention | MediaInsert | MediaOverwrite | MediaRemove | LibraryInsert | TapeAlertInformation | TapeAlertWarning | TapeAlertError | IdrFullBackupSuccessWarning | LicenseAndMaintenanceWarning}] [-Severity {None | Information | Question | Warning | Error}] [<CommonParameters>]

Get-BEAlertHistory [-Id] <Guid[]> [<CommonParameters>]

Get-BEAlertHistory -InputObject <BEAlertHistory[]> [<CommonParameters>]
Description

サーバー上で発生した Backup Exec アラートのリストを取得します。

パラメータを指定しない場合、Get-BEAlertHistory はサーバー上で発生したすべての Backup Exec アラートを取得します。 アラート履歴の名前またはアラート履歴 ID (Guid) を使用してアラートを指定したり、パイプラインを通じて Backup Exec アラート履歴オブジェクトを Get-BEAlertHistory に渡したりすることもできます。

Parameters

-Storage <BEStorage[]>

アラートをフィルタ処理するための 1 つまたは複数のストレージオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEStorage を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Job <BEJob[]>

アラートをフィルタ処理するための 1 つまたは複数のジョブオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEJob を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-AgentServer <BEAgentServer[]>

アラートをフィルタ処理するための 1 つまたは複数のエージェントサーバーオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEAgentServer を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

1 つまたは複数のアラートをアラート名で指定します。ワイルドカードを使用できます。複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Severity

アラートをフィルタ処理するための 1 つまたは複数の重大度の値を指定します。複数の値を指定する場合は、カンマを使用して値を区切ります。

The valid values are:
None
Information
Question
Warning
Error

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Category

アラートをフィルタ処理するための 1 つまたは複数のカテゴリの値を指定します。複数の値を指定する場合は、カンマを使用して値を区切ります。

The valid values are:
None
JobWarning
JobSuccess
JobFailure
JobCancellation
CatalogError
SoftwareUpdateInformation
SoftwareUpdateWarning
SoftwareUpdateError
InstallInformation
InstallWarning
GeneralInformation
DatabaseMaintenanceInformation
DatabaseMaintenanceFailure
BackupExecRetrieveUrlUpdateInformation
BackupExecRetrieveUrlUpdateFailure
IdrCopyFailed
IdrFullBackupSuccess
BackupJobContainsNoData
JobCompletedWithExceptions
JobStart
ServiceStart
ServiceStop
DeviceError
DeviceWarning
DeviceInformation
DeviceIntervention
MediaError
MediaWarning
MediaInformation
MediaIntervention
MediaInsert
MediaOverwrite
MediaRemove
LibraryInsert
TapeAlertInformation
TapeAlertWarning
TapeAlertError
IdrFullBackupSuccessWarning
LicenseAndMaintenanceWarning

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Id <Guid[]>

1 つまたは複数のアラートをアラート ID (GUID) で指定します。複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEAlertHistory[]>

1 つまたは複数のアラートオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEStorage

パイプを使用して Backup Exec ストレージオブジェクトを渡し、Get-BEAlertHistory で返されるアラートをフィルタ処理できます。

BackupExec.Management.CLI.BEJob

パイプを使用して Backup Exec ジョブオブジェクトを渡し、Get-BEAlertHistory で返されるアラートをフィルタ処理できます。

BackupExec.Management.CLI.BEAgentServer

パイプを使用して Backup Exec エージェントサーバーオブジェクトを渡し、Get-BEAlertHistory で返されるアラートをフィルタ処理できます。

System.Guid

Backup Exec アラートオブジェクトの ID を含む System.Guid を、パイプを使用して Get-BEAlertHistory に渡すことができます。

BackupExec.Management.CLI.BEAlertHistory

パイプを使用して Backup Exec アラートオブジェクトを Get-BEAlertHistory に渡すことができます。

Return Value
BackupExec.Management.CLI.BEAlertHistory

Get-BEAlertHistory は Backup Exec アラートを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEAlertHistory

このコマンドは Backup Execのアラートをすべて取得します。

Example 2
C:\PS> @(Get-BEAlertHistory -Severity Error).Count

このコマンドはエラーのアラートの数を取得します。

Example 3
C:\PS> Get-BEAgentServer myserver.mycompany.com | Get-BEAlertHistory

これらのコマンドは「myserver.mycompany.com」という名前のコンピュータに関するすべてのアラートを取得します。

Example 4
C:\PS> Get-BEDiskStorageDevice "Disk storage 0001" | Get-BEAlertHistory

これらのコマンドは「Disk storage 0001」という名前のディスクストレージデバイスに関するすべてのアクティブアラートを取得します。

Example 5
C:\PS> Get-BEJob "Backup of myserver.mycompany.com" | Get-BEAlertHistory

これらのコマンドは「Backup of myserver.mycompany.com」という名前のジョブに関するすべてのアラートを取得します。

Related Links


Get-BEAuthorizedOracleServer Help

Get-BEAuthorizedOracleServer Cmdlet
Synopsis

Oracle DBA 認定リストにサーバーを返します。

Syntax
Get-BEAuthorizedOracleServer [[-Name] <String[]>] [<CommonParameters>]

Get-BEAuthorizedOracleServer [-ServerName <String>] [<CommonParameters>]
Description

Oracle DBA 認定リストにサーバーを返します。

Parameters

-ServerName <String>

Oracle サーバーの名前を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String[]>

この設定の名前を指定します。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

このコマンドレットは入力を受け入れません。

Return Value
BackupExec.Management.CLI.BEAuthorizedOracleServer

Get-BEAuthorizedOracleServer は、Oracle サーバーの名前を返します。

Examples

Example 1

C:\PS> Get-BEAuthorizedOracleServer -ServerName myoracleserver.oracle.com

このコマンドは、Backup Exec サーバーの Oracle サーバーと認証クレデンシャルのリストから myoracleserver.oracle.com のサーバーの詳細を返します。

Example 2
C:\PS> Get-BEAuthorizedOracleServer

このコマンドは、Backup Exec サーバーの Oracle サーバーと認証クレデンシャルのリストにあるすべてのサーバーを返します。


Get-BEBackupDefinition Help

Get-BEBackupDefinition Cmdlet
Synopsis

Backup Exec のバックアップ定義を取得します。

Syntax
Get-BEBackupDefinition [[-Name] <String[]>] [<CommonParameters>]

Get-BEBackupDefinition -AgentServer <BEAgentServer[]> [<CommonParameters>]

Get-BEBackupDefinition [-Id] <Guid[]> [<CommonParameters>]

Get-BEBackupDefinition -InputObject <BEBackupDefinition[]> [<CommonParameters>]
Description

Backup Exec のバックアップ定義を取得します。

パラメータを指定しない場合、Get-BEBackupDefinition はすべての Backup Exec バックアップ定義を取得します。 バックアップ名またはバックアップ定義 ID (GUID) でバックアップ定義を指定するか、パイプライン経由でバックアップ定義オブジェクトを Get-BEBackupDefinition に渡すこともできます。

Get-BEBackupDefinition を次のコマンドと一緒に使用して、バックアップ定義のタスクを変更できます:Set-BEBackupDefinition、Add-BEIncrementalBackupTask、Add-BEDifferentialBackupTask、Add-BEDuplicateStageBackupTask、Add-BEConvertToVirtualStageBackupTask、Add-BEVerifyBackupTask、Set-BEIncrementalBackupTask、Set-BEDifferentialBackupTask、Set-BEDuplicateStageBackupTask、Set-BEVerifyBackupTask、Remove-BEBackupTask。

バックアップ定義を作成または編集する場合、そのバックアップ定義を Save-BEBackupDefinition に渡して変更をコミットする必要があります。

Parameters

-AgentServer <BEAgentServer[]>

バックアップ定義をフィルタ処理するための 1 つまたは複数のエージェントサーバーオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEAgentServer を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

1 つまたは複数のバックアップ定義をバックアップ定義名で指定します。ワイルドカードを使用できます。複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

1 つまたは複数のバックアップ定義をバックアップ定義 ID (GUID) で指定します。複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEBackupDefinition[]>

1 つまたは複数のバックアップ定義オブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEAgentServer

パイプを使用して Backup Exec エージェントサーバーオブジェクトを渡し、Get-BEBackupDefinition で返されるバックアップ定義をフィルタ処理できます。

System.Guid

バックアップ定義オブジェクトの ID を含む System.Guid を、パイプを使用して Get-BEBackupDefinition に渡すことができます。

BackupExec.Management.CLI.BEBackupDefinition

パイプを使用してバックアップ定義オブジェクトを Get-BEBackupDefinition に渡すことができます。

Return Value
BackupExec.Management.CLI.BEBackupDefinition

Get-BEBackupDefinition は Backup Exec バックアップ定義を表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEBackupDefinition

このコマンドでは、すべてのバックアップ定義を取得します。

Example 2
C:\PS> Get-BEBackupDefinition -Name "Backup Definition 01"

このコマンドでは、「Backup Definition 01」という名前のバックアップ定義を取得します。

Example 3
C:\PS> Get-BEBackupDefinition -Name "Backup*"

このコマンドでは、ワイルドカード「Backup*」に一致するすべてのバックアップ定義を取得します。

Example 4
C:\PS> Get-BEAgentServer -Local | Get-BEBackupDefinition

これらのコマンドでは、ローカルコンピュータのすべてのバックアップ定義を取得します。

Example 5
C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Set-BEBackupDefinition -FileSystemSelection D:\* | Save-BEBackupDefinition

これらのコマンドでは、「Backup Definition 01」という名前のバックアップ定義のバックアップ選択項目に D:\* を追加します。

Example 6
C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Add-BEDifferentialBackupTask | Save-BEBackupDefinition

これらのコマンドでは、差分バックアップを「Backup Definition 01」という名前のバックアップ定義に追加します。

Related Links

Set-BEBackupDefinition
Add-BEIncrementalBackupTask
Add-BEDifferentialBackupTask
Add-BEDuplicateStageBackupTask
Add-BEConvertToVirtualStageBackupTask
Add-BEVerifyBackupTask
Set-BEIncrementalBackupTask
Set-BEDifferentialBackupTask
Set-BEDuplicateStageBackupTask
Set-BEVerifyBackupTask
Remove-BEBackupTask
Save-BEBackupDefinition
Get-BEAgentServer


Get-BEBackupExecServer Help

Get-BEBackupExecServer Cmdlet
Synopsis

Backup Exec のサーバーを取得します。

Syntax
Get-BEBackupExecServer [[-Name] <String[]>] [<CommonParameters>]

Get-BEBackupExecServer [-Local <SwitchParameter>] [<CommonParameters>]

Get-BEBackupExecServer -ServerInformation <BEServerInformation[]> [[-Name] <String[]>] [<CommonParameters>]

Get-BEBackupExecServer [-Id] <Guid[]> [<CommonParameters>]

Get-BEBackupExecServer -InputObject <BEBackupExecServer[]> [<CommonParameters>]
Description

Backup Exec のサーバーを取得します。

集中管理サーバーではない Backup Exec サーバー上で Get-BEBackupExecServer を実行すると、ローカル Backup Exec サーバーが返されます。

パラメータを指定しない場合、Get-BEBackupExecServer は CASO 環境内のすべての管理対象 Backup Exec サーバーを取得します。 Backup Exec サーバー名または Backup Exec サーバー ID (Guid) を使用して管理対象 Backup Exec サーバーを指定することも、パイプラインを通じて Backup Exec サーバーオブジェクトを Get-BEBackupExecServer に渡すこともできます。

Parameters

-Local <SwitchParameter>

ローカルコンピュータの Backup Exec サーバーオブジェクトを取得します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ServerInformation <BEServerInformation[]>

フィルタ処理する 1 つ以上の Backup Exec サーバー情報オブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEServerInformation を確認します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

サーバー名 (ワイルドカードを使用可能) を使用して、1 つ以上の Backup Exec サーバーを指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

サーバー ID (Guid) を使用して、1 つ以上の Backup Exec サーバーを指定します。 複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEBackupExecServer[]>

1 つ以上の Backup Exec サーバーオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
System.Guid

Backup Exec サーバーオブジェクトの ID を含む System.Guid を Get-BEBackupExecServer にパイプ処理できます。

BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトを Get-BEBackupExecServer にパイプ処理できます。

BackupExec.Management.CLI.BEServerInformation

Get-BEBackupExecServer によって返される Backup Exec サーバーをフィルタ処理する方法として Backup Exec サーバー情報オブジェクトをパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEBackupExecServer

Get-BEBackupExecServer は、Backup Exec サーバーを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEBackupExecServer

このコマンドはすべての Backup Exec サーバーを取得します。

Example 2
C:\PS> Get-BEBackupExecServer -Name "MyManagedServer"

このコマンドは「MyManagedServer」という名前の Backup Exec サーバーを取得します。

Example 3
C:\PS> Get-BEBackupExecServer -Name "*Managed*"

このコマンドはワイルドカード「*Managed*」と一致するすべての Backup Exec サーバーを取得します。

Example 4
C:\PS> Get-BEBackupExecServer -Local

このコマンドはローカル Backup Exec サーバーを取得します。

Example 5
C:\PS> Get-BEBackupExecServer -Local | Get-BEStorage

このコマンドはローカル Backup Exec サーバーにアクセスできるすべてのバックアップストレージを取得します。

Related Links


Get-BEBackupExecServerPool Help

Get-BEBackupExecServerPool Cmdlet
Synopsis

Backup Exec サーバープールを取得します。

Syntax
Get-BEBackupExecServerPool [[-Name] <String[]>] [<CommonParameters>]

Get-BEBackupExecServerPool [-Id] <Guid[]> [<CommonParameters>]

Get-BEBackupExecServerPool -InputObject <BEBackupExecServerPool[]> [<CommonParameters>]
Description

Backup Exec サーバープールを取得します。

パラメータを指定しない場合、Get-BEBackupExecServerPool はすべての Backup Exec サーバープールを取得します。 サーバープール名またはサーバープール ID (Guid) を使用して Backup Exec サーバープールを指定することも、パイプラインを通じて Backup Exec サーバープールオブジェクトを Get-BEBackupExecServerPool に渡すこともできます。

Parameters

-Name <String[]>

サーバープール名 (ワイルドカードを使用可能) を使用して、1 つ以上の Backup Exec サーバープールを指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

サーバープール ID (Guid) を使用して、1 つ以上の Backup Exec サーバープールを指定します。 複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEBackupExecServerPool[]>

1 つ以上の Backup Exec サーバープールオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
System.Guid

Backup Exec サーバープールオブジェクトの ID を含む System.Guid を Get-BEBackupExecServerPool にパイプ処理できます。

BackupExec.Management.CLI.BEBackupExecServerPool

Backup Exec サーバープールオブジェクトを Get-BEBackupExecServerPool にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEBackupExecServerPool

Get-BEBackupExecServerPool は、Backup Exec サーバープールを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEBackupExecServerPool

このコマンドは、すべての Backup Exec サーバープールを返します。

Example 2
C:\PS> Get-BEBackupExecServerPool -Name "Server Pool 0001"

このコマンドは「Server Pool 0001」という名前の Backup Exec サーバープールを返します。


Get-BEBackupExecSetting Help

Get-BEBackupExecSetting Cmdlet
Synopsis

グローバル Backup Exec 設定を取得します。

Syntax
Get-BEBackupExecSetting [<CommonParameters>]
Description

グローバル Backup Exec 設定を取得します。

設定を変更するには、Set-BEBackupExecSetting を使用します。

Parameters

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

このコマンドレットは入力を受け入れません。

Return Value
BackupExec.Management.CLI.BEBackupExecSettings

Get-BEBackupExecSetting は、グローバル Backup Exec 設定を表すオブジェクトを返します。

Example

C:\PS> Get-BEBackupExecSetting

このコマンドは、グローバル Backup Exec 設定を取得します。

Related Link

Set-BEBackupExecSetting


Get-BEBackupJobDefault Help

Get-BEBackupJobDefault Cmdlet
Synopsis

Backup Exec ジョブのデフォルトを取得します。

Syntax
Get-BEBackupJobDefault [-BackupJobDefaultType] {BackupToDisk | BackupToDiskCartridge | BackupToDeduplication | BackupToTape | BackupToCloud} [<CommonParameters>]
Description

Backup Exec ジョブのデフォルトを取得します。

Get-BEBackupJobDefault を次のコマンドと一緒に使用して、バックアップジョブのデフォルトのタスクを変更できます:Set-BEBackupJobDefault、Add-BEIncrementalBackupTask、Add-BEDifferentialBackupTask、Add-BEVerifyBackupTask、Set-BEIncrementalBackupTask、Set-BEDifferentialBackupTask、Set-BEVerifyBackupTask、Remove-BEBackupTask。

バックアップジョブのデフォルトを編集する場合、バックアップジョブのデフォルトを Save-BEBackupJobDefault に渡して変更をコミットする必要があります。

Parameters

-BackupJobDefaultType

編集するバックアップジョブのデフォルトの種類を指定します。

The valid values are:
BackupToDisk
BackupToDiskCartridge
BackupToDeduplication
BackupToTape
BackupToCloud

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

このコマンドレットは入力を受け入れません。

Return Value
BackupExec.Management.CLI.BEBackupJobDefaults

Get-BEBackupJobDefault は、Backup Exec ジョブのデフォルトを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEBackupJobDefault BackupToDisk

このコマンドは、ディスクへのバックアップジョブのデフォルトを取得します。

Example 2
C:\PS> Get-BEBackupJobDefault BackupToTape | Add-BEDifferentalBackupTask | Save-BEBackupJobDefault

これらのコマンドは、差分バックアップをテープへのバックアップジョブのデフォルトに追加します。

Related Links

Set-BEBackupJobDefault
Add-BEIncrementalBackupTask
Add-BEDifferentialBackupTask
Add-BEVerifyBackupTask
Set-BEIncrementalBackupTask
Set-BEDifferentialBackupTask
Set-BEVerifyBackupTask
Remove-BEBackupTask
Save-BEBackupJobDefault


Get-BEBarcodeRule Help

Get-BEBarcodeRule Cmdlet
Synopsis

Backup Exec のバーコードルールを取得します。

Syntax
Get-BEBarcodeRule [[-Name] <String[]>] [-BarcodePrefix <String[]>] [-BarcodeSuffix <String[]>] [-Vendor <String[]>] [<CommonParameters>]

Get-BEBarcodeRule -MediaType <BEMediaType[]> [[-Name] <String[]>] [-BarcodePrefix <String[]>] [-BarcodeSuffix <String[]>] [-Vendor <String[]>] [<CommonParameters>]

Get-BEBarcodeRule [-Id] <Guid[]> [<CommonParameters>]

Get-BEBarcodeRule -InputObject <BEBarcodeRule[]> [<CommonParameters>]
Description

Backup Exec のバーコードルールを取得します。

パラメータを指定しない場合、Get-BEBarcodeRule はすべての Backup Exec バーコードルールを取得します。 バーコードルール名またはバーコードルール ID (Guid) を使用してバーコードルールを指定することも、パイプラインを通じて Backup Exec バーコードルールオブジェクトを Get-BEBarcodeRule に渡すこともできます。

Parameters

-MediaType <BEMediaType[]>

1 つ以上のメディアタイプオブジェクトを指定して、バーコードルールをフィルタ処理します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEMediaType を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

バーコードルール名 (ワイルドカードを使用可能) を使用して、1 つ以上のバーコードルールを指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Vendor <String[]>

1 つ以上の製造元の値を指定して、バーコードルールをフィルタ処理します。 複数の値を指定する場合は、カンマを使用して値を区切ります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BarcodePrefix <String[]>

1 つ以上のバーコード接頭辞値を指定して、バーコードルールをフィルタ処理します。 複数の値を指定する場合は、カンマを使用して値を区切ります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BarcodeSuffix <String[]>

1 つ以上のバーコード接尾辞値を指定して、バーコードルールをフィルタ処理します。 複数の値を指定する場合は、カンマを使用して値を区切ります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Id <Guid[]>

バーコードルール ID (Guid) を使用して、1 つ以上のバーコードルールを指定します。 複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEBarcodeRule[]>

1 つ以上のバーコードルールオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEMediaType

Backup Exec メディアタイプオブジェクトをパイプ処理して、Get-BEBarcodeRule によって返されるバーコードルールをフィルタ処理できます。

System.Guid

Backup Exec バーコードルールオブジェクトの ID を含む System.Guid を Get-BEBarcodeRule にパイプ処理できます。

BackupExec.Management.CLI.BEBarcodeRule

Backup Exec バーコードルールオブジェクトを Get-BEBarcodeRule にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEBarcodeRule

Get-BEBarcodeRule は、Backup Exec バーコードルールを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEBarcodeRule

このコマンドはすべてのバーコードルールを取得します。

Example 2
C:\PS> Get-BEBarcodeRule -BarcodePrefix CLN

このコマンドは「CLN」という名前のバーコード接頭辞を持つすべてのバーコードルールを取得します。

Example 3
C:\PS> Get-BEMediaType LTO-100 | Get-BEBarcodeRule

これらのコマンドは LTO-100 メディアタイプに関連付けられたバーコードルールを取得します。

Related Link

Get-BEMediaType


Get-BECentralAdministrationBackupExecServer Help

Get-BECentralAdministrationBackupExecServer Cmdlet
Synopsis

Backup Exec 集中管理サーバーを取得します。

Syntax
Get-BECentralAdministrationBackupExecServer [[-Name] <String[]>] [-IsPrivateCloudServer <Boolean>] [<CommonParameters>]

Get-BECentralAdministrationBackupExecServer -ServerInformation <BEServerInformation[]> [[-Name] <String[]>] [-IsPrivateCloudServer <Boolean>] [<CommonParameters>]

Get-BECentralAdministrationBackupExecServer [-Id] <Guid[]> [<CommonParameters>]

Get-BECentralAdministrationBackupExecServer -InputObject <BECentralAdministrationBackupExecServer[]> [<CommonParameters>]
Description

Backup Exec 集中管理サーバーを取得します。

パラメータを指定しない場合、Get-BECentralAdministrationBackupExecServer はすべての Backup Exec 集中管理サーバーを取得します。 サーバー名またはサーバー ID (Guid) を使用して集中管理サーバーを指定したり、パイプラインを通じてサーバーを Get-BECentralAdministrationBackupExecServer に渡すこともできます。

Parameters

-ServerInformation <BEServerInformation[]>

集中管理サーバーをフィルタ処理するための 1 つ以上のサーバーの値を指定します。複数の値を指定する場合は、カンマを使用して値を区切ります。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

1 つ以上の集中管理サーバーをサーバー名で (ワイルドカードを使用可能) 指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-IsPrivateCloudServer <Boolean>

プライベートクラウドサーバーである、またはそうでない集中 exec サーバーをフィルタ処理するか指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Id <Guid[]>

1 つ以上の集中管理サーバーをサーバー ID (Guid) で指定します。 複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BECentralAdministrationBackupExecServer[]>

1 つ以上の集中管理サーバーオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEServerInformation

Backup Exec サーバー情報オブジェクトを Get-BECentralAdministrationBackupExecServer にパイプ処理できます。

System.Guid

集中管理サーバーオブジェクトの ID を含む System.Guid を Get-BECentralAdministrationBackupExecServer にパイプ処理できます。

BackupExec.Management.CLI.BECentralAdministrationBackupExecServer

Backup Exec 集中管理サーバーオブジェクトを Get-BECentralAdministrationBackupExecServer にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BECentralAdministrationBackupExecServer

Get-BECentralAdministrationBackupExecServer は、Backup Exec 集中管理サーバーを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BECentralAdministrationBackupExecServer

このコマンドは Backup Exec 内のすべての集中管理サーバーを取得します。

Example 2
C:\PS> Get-BECentralAdministrationBackupExecServer -Name "MyCas"

このコマンドは「MyCas」という名前の集中管理サーバーを取得します。


Get-BECleanUtilityJob Help

Get-BECleanUtilityJob Cmdlet
Synopsis

Backup Exec のクリーニングジョブを取得します。

Syntax
Get-BECleanUtilityJob [[-Name] <String[]>] [-Status {Unknown | Canceled | Completed | SucceededWithExceptions | OnHold | Error | Missed | Recovered | Resumed | Succeeded | ThresholdAbort | Dispatched | DispatchFailed | InvalidSchedule | InvalidTimeWindow | NotInTimeWindow | Queued | Disabled | Active | Ready | Scheduled | Superseded | ToBeScheduled | Linked | RuleBlocked}] [-IsActive <Boolean>] [<CommonParameters>]

Get-BECleanUtilityJob -Storage <BEStorage[]> [[-Name] <String[]>] [-Status {Unknown | Canceled | Completed | SucceededWithExceptions | OnHold | Error | Missed | Recovered | Resumed | Succeeded | ThresholdAbort | Dispatched | DispatchFailed | InvalidSchedule | InvalidTimeWindow | NotInTimeWindow | Queued | Disabled | Active | Ready | Scheduled | Superseded | ToBeScheduled | Linked | RuleBlocked}] [-IsActive <Boolean>] [<CommonParameters>]

Get-BECleanUtilityJob [-Id] <Guid[]> [<CommonParameters>]

Get-BECleanUtilityJob -InputObject <BECleanUtilityJob[]> [<CommonParameters>]
Description

Backup Exec のクリーニングジョブを取得します。

パラメータを指定しない場合、Get-BECleanUtilityJob はすべての Backup Exec クリーニングジョブを取得します。 ジョブ名またはジョブ ID (Guid) を使用して特定のクリーニングジョブを指定することも、パイプラインを通じて Backup Exec ジョブオブジェクトを Get-BECleanUtilityJob に渡すこともできます。

Parameters

-Storage <BEStorage[]>

クリーニングジョブをフィルタ処理するための 1 つ以上のストレージオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEStorage を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

ジョブ名 (ワイルドカードを使用可能) を使用して、1 つ以上のクリーニングジョブを指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-IsActive <Boolean>

1 つ以上のアクティブな値を指定して、ジョブをフィルタ処理します。複数の値を指定する場合は、カンマを使用して値を区切ります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Status

1 つ以上の状態値を指定して、ジョブをフィルタ処理します。 複数の値を指定する場合は、カンマを使用して値を区切ります。

The valid values are:
Unknown
Canceled
Completed
SucceededWithExceptions
OnHold
Error
Missed
Recovered
Resumed
Succeeded
ThresholdAbort
Dispatched
DispatchFailed
InvalidSchedule
InvalidTimeWindow
NotInTimeWindow
Queued
Disabled
Active
Ready
Scheduled
Superseded
ToBeScheduled
Linked
RuleBlocked

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Id <Guid[]>

ジョブ ID (Guid) を使用して、1 つ以上のクリーニングジョブを指定します。複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BECleanUtilityJob[]>

1 つ以上のジョブオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEStorage

Backup Exec ストレージオブジェクトを Get-BECleanUtilityJob にパイプ処理できます。

BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトを Get-BECleanUtilityJob にパイプ処理できます。

System.Guid

Backup Exec クリーニングジョブオブジェクトの ID を含む System.Guid を Get-BECleanUtilityJob にパイプ処理できます。

BackupExec.Management.CLI.BECleanUtilityJob

Backup Exec クリーニングジョブオブジェクトを Get-BECleanUtilityJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BECleanUtilityJob

Get-BECleanUtilityJob は、Backup Exec クリーニングジョブを表すオブジェクトを返します。

Example

C:\PS> Get-BECleanUtilityJob -Name "CleanUtilityJob"

このコマンドは「CleanUtilityJob」という名前のクリーニングジョブを取得します。

Related Links


Get-BECloudInstance Help

Get-BECloudInstance Cmdlet
Synopsis

Backup Exec で設定されているすべてのクラウドインスタンスを取得します。

Syntax
Get-BECloudInstance [[-Name] <String[]>] [<CommonParameters>]

Get-BECloudInstance [-Id] <Guid[]> [<CommonParameters>]

Get-BECloudInstance -InputObject <BECloudInstance[]> [<CommonParameters>]
Description

Backup Exec クラウドインスタンスを取得します。

パラメータを指定しない場合、Get-BECloudInstance は Backup Exec で設定されているすべてのクラウドインスタンスを取得します。インスタンス名でクラウドインスタンスを指定したり、パイプラインを使用してクラウドインスタンスオブジェクトを Get-BECloudInstance に渡すこともできます。

Parameters

-Name <String[]>

クラウドインスタンス名 (ワイルドカードを使用可能) を使用して、1 つ以上のクラウドインスタンスを指定します。複数の名前を指定する場合は、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

クラウドインスタンス ID (Guid) を使用して、1 つ以上のクラウドインスタンスを指定します。複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BECloudInstance[]>

1 つ以上のクラウドインスタンスオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
System.Guid

Backup Exec クラウドインスタンスオブジェクトの ID を含む System.Guid を Get-BECloudInstance にパイプ処理できます。

BackupExec.Management.CLI.BECloudInstance

Backup Exec クラウドインスタンスオブジェクトを Get-BELogonAccount にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BECloudInstance

Get-BECloudInstance は、Backup Exec クラウドインスタンスを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BECloudInstance

このコマンドはすべてのクラウドインスタンスを取得します。

Example 2
C:\PS> Get-BECloudInstance -Name "CloudInstance0001"

このコマンドは「CloudInstance0001」という名前のクラウドインスタンスを取得します。

Example 3
C:\PS> Get-BECloudInstance -Name "*CloudInstance*"

このコマンドはワイルドカード「*CloudInstance*」に一致するすべてのクラウドインスタンスを取得します。

Related Link

Get-BELogonAccount


Get-BECloudRegion Help

Get-BECloudRegion Cmdlet
Synopsis

Backup Exec の既存のクラウドインスタンスで設定されているすべてのクラウドリージョンを取得します。

Syntax
Get-BECloudRegion [[-Name] <String[]>] [-InstanceName <String[]>] [<CommonParameters>]

Get-BECloudRegion [-Id] <Guid[]> [<CommonParameters>]

Get-BECloudRegion -InputObject <BECloudRegion[]> [<CommonParameters>]
Description

Backup Exec クラウドリージョンを取得します。

パラメータがない場合、Get-BECloudRegion は Backup Exec の既存のクラウドインスタンスで設定されているすべてのクラウドリージョンを取得します。リージョン名を使用してクラウドリージョンを指定するか、パイプラインでクラウドリージョンオブジェクトを Get-BECloudRegion に渡すこともできます。

Parameters

-InstanceName <String[]>

クラウドインスタンス名を使用して、1 つ以上のクラウドリージョンを指定します。複数の名前を指定する場合は、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String[]>

クラウドリージョン名 (ワイルドカードを使用可能) を使用して、1 つ以上のクラウドリージョンを指定します。複数の名前を指定する場合は、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

クラウドリージョン ID (GUID) を使用して、1 つ以上のクラウドリージョンを指定します。複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BECloudRegion[]>

1 つ以上のクラウドリージョンオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.Guid

Backup Exec クラウドリージョンオブジェクトの ID を含む System.Guid を Get-BECloudRegion にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BECloudRegion

Get-BECloudRegion は、Backup Exec クラウドリージョンを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BECloudRegion

このコマンドはすべてのクラウドリージョンを取得します。

Example 2
C:\PS> Get-BECloudRegion -Name "ap australia"

このコマンドは「ap australia」という名前のクラウドリージョンを取得します。

Example 3
C:\PS> Get-BECloudRegion -Name "*ap*"

このコマンドはワイルドカード「*ap*」に一致するすべてのクラウドリージョンを取得します。

Example 4
C:\PS> Get-BECloudRegion -InstanceName "ibminst"

このコマンドは ibminst インスタンスのすべてのクラウドリージョンを取得します。


Get-BECloudStorageDevice Help

Get-BECloudStorageDevice Cmdlet
Synopsis

Backup Exec クラウドストレージのデバイスを取得します。

Syntax
Get-BECloudStorageDevice [[-Name] <String[]>] [<CommonParameters>]

Get-BECloudStorageDevice -BackupExecServer <BEBackupExecServer[]> [[-Name] <String[]>] [<CommonParameters>]

Get-BECloudStorageDevice -LogonAccount <BELogonAccount[]> [[-Name] <String[]>] [<CommonParameters>]

Get-BECloudStorageDevice [-Id] <Guid[]> [<CommonParameters>]

Get-BECloudStorageDevice -InputObject <BECloudStorageDevice[]> [<CommonParameters>]
Description

Backup Exec クラウドストレージのデバイスを取得します。

Get-BECloudStorageDevice は、パラメータなしの場合、Backup Exec クラウドストレージのデバイスをすべて取得します。 また、クラウドストレージデバイス名またはクラウドストレージデバイス ID（GUID）によって特定のクラウドストレージデバイスを指定するか、パイプラインによって Backup Exec クラウドストレージデバイスオブジェクトを Get-BECloudStorageDevice に渡すこともできます。

Parameters

-BackupExecServer <BEBackupExecServer[]>

クラウドストレージデバイスをフィルタ処理する Backup Exec サーバーオブジェクトを 1 つ以上指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEBackupExecServer を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-LogonAccount <BELogonAccount[]>

クラウドストレージデバイスをフィルタ処理するログオンアカウントオブジェクトを 1 つ以上指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BELogonAccount を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

クラウドストレージデバイス名（ワイルドカードを使用可能）を使用して、クラウドストレージデバイスを 1 つ以上指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

クラウドストレージデバイス ID（GUID）によってクラウドストレージデバイスを 1 つ以上指定します。 複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BECloudStorageDevice[]>

クラウドストレージデバイスオブジェクトを 1 つ以上指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトをパイプ処理して、Get-BECloudStorageDevice によって返されるクラウドストレージデバイスをフィルタ処理できます。

BackupExec.Management.CLI.BELogonAccount

Get-BECloudStorageDevice によって返されるクラウドストレージデバイスをフィルタ処理する方法として、Backup Exec ログオンアカウントオブジェクトをパイプ処理できます。

System.Guid

Backup Exec クラウドストレージデバイスオブジェクトの ID を含む System.Guid を Get-BECloudStorageDevice にパイプ処理できます。

BackupExec.Management.CLI.BECloudStorageDevice

Backup Exec クラウドストレージデバイスオブジェクトを Get-BECloudStorageDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BECloudStorageDevice

Get-BECloudStorageDevice は Backup Exec クラウドストレージデバイスを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BECloudStorageDevice

このコマンドはすべてのクラウドストレージデバイスを取得します。

Example 2
C:\PS> Get-BECloudStorageDevice -Name "Device 01"

このコマンドは「Device 01」という名前のクラウドストレージデバイスを取得します。

Example 3
C:\PS> Get-BECloudStorageDevice -Name "Device*"

このコマンドはワイルドカード「Device*」と一致するすべてのクラウドストレージデバイスを取得します。

Example 4
C:\PS> Get-BEBackupExecServer -Local | Get-BECloudStorageDevice

このコマンドはローカル Backup Exec サーバーに接続されているすべてのクラウドストレージデバイスを取得します。

Related Links


Get-BECloudStorageServerType Help

Get-BECloudStorageServerType Cmdlet
Synopsis

Backup Exec サーバーにインストールされている登録済みのクラウドストレージサーバーの種類を取得します。

Syntax
Get-BECloudStorageServerType [-BackupExecServer <BEBackupExecServer>] [<CommonParameters>]
Description

Backup Exec サーバーにインストールされている登録済みのクラウドストレージサーバーの種類を取得します。

Get-BECloudStorageServerType によって返される値は、New-BECloudStorageDevice コマンドの ServerType パラメータの値として使用できます。

Parameters

-BackupExecServer <BEBackupExecServer>

クラウドストレージサーバーの種類の取得元となる Backup Exec サーバーを指定します。

Required | false
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトを Get-BECloudStorageServerType にパイプ処理できます。

Return Value
System.String

登録済みのクラウドストレージサーバーの種類。

Example

C:\PS> Get-BECloudStorageServerType

このコマンドはローカル Backup Exec サーバーで登録済みのすべてのクラウドストレージサーバーの種類を取得します。

Related Link

New-BECloudStorageDevice


Get-BEConvertToVirtualJob Help

Get-BEConvertToVirtualJob Cmdlet
Synopsis

Backup Exec の仮想への変換ジョブを取得します。

Syntax
Get-BEConvertToVirtualJob [[-Name] <String[]>] [<CommonParameters>]

Get-BEConvertToVirtualJob -AgentServer <BEAgentServer[]> [<CommonParameters>]

Get-BEConvertToVirtualJob [-Id] <Guid[]> [<CommonParameters>]

Get-BEConvertToVirtualJob -InputObject <BEConvertToVirtualJob[]> [<CommonParameters>]
Description

Backup Exec の仮想への変換ジョブを取得します。

パラメータを指定しない場合、Get-BEConvertToVirtualJob は Backup Exec の仮想への変換ジョブをすべて取得します。 ジョブ名またはジョブ ID (Guid) を使用して仮想への変換ジョブを指定したり、パイプラインを通じて Backup Exec の仮想への変換ジョブオブジェクトを Get-BEConvertToVirtualJob に渡したりすることもできます。

Parameters

-AgentServer <BEAgentServer[]>

1 つ以上のエージェントサーバーオブジェクトを指定して、仮想への変換ジョブをフィルタ処理します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEAgentServer を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

ジョブ名 (ワイルドカードを使用可能) を使用して、1 つ以上の仮想への変換ジョブを指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

ジョブ ID (Guid) を使用して、1 つ以上の仮想への変換ジョブを指定します。 複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEConvertToVirtualJob[]>

1 つ以上の仮想への変換ジョブオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEAgentServer

Get-BEConvertToVirtualJob によって返される仮想への変換ジョブをフィルタ処理する方法として、Backup Exec エージェントサーバーオブジェクトをパイプ処理できます。

System.Guid

Backup Exec 仮想への変換ジョブオブジェクトの ID を含む System.Guid を Get-BEConvertToVirtualJob にパイプ処理できます。

BackupExec.Management.CLI.BEConvertToVirtualJob

Backup Exec 仮想への変換ジョブオブジェクトを Get-BEConvertToVirtualJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEConvertToVirtualJob

Get-BEConvertToVirtualJob は、Backup Exec の仮想への変換ジョブを表すオブジェクトを返します。

Example

C:\PS> Get-BEConvertToVirtualJob -Name "Convert To Virtual Job 0001"

このコマンドはジョブ「Convert To Virtual Job 0001」を取得します。

Related Link

Get-BEAgentServer


Get-BEDeduplicationDiskStorageDevice Help

Get-BEDeduplicationDiskStorageDevice Cmdlet
Synopsis

Backup Exec の重複排除用ディスクストレージデバイスを取得します。

Syntax
Get-BEDeduplicationDiskStorageDevice [[-Name] <String[]>] [<CommonParameters>]

Get-BEDeduplicationDiskStorageDevice -BackupExecServer <BEBackupExecServer[]> [[-Name] <String[]>] [<CommonParameters>]

Get-BEDeduplicationDiskStorageDevice -LogonAccount <BELogonAccount[]> [[-Name] <String[]>] [<CommonParameters>]

Get-BEDeduplicationDiskStorageDevice [-Id] <Guid[]> [<CommonParameters>]

Get-BEDeduplicationDiskStorageDevice -InputObject <BEDeduplicationDiskStorageDevice[]> [<CommonParameters>]
Description

Backup Exec の重複排除用ディスクストレージデバイスを取得します。

パラメータを指定しない場合、Get-BEDeduplicationDiskStorageDevice はすべての Backup Exec 重複排除用ディスクストレージデバイスを取得します。 重複排除用ディスクストレージデバイス名、または重複排除用ディスクストレージデバイス ID (Guid) を使用して重複排除用ディスクストレージデバイスを指定することも、パイプラインを通じて、Backup Exec 重複排除用ディスクストレージデバイスオブジェクトを Get-BEDeduplicationDiskStorageDevice に渡すこともできます。

Parameters

-BackupExecServer <BEBackupExecServer[]>

1 つ以上の Backup Exec サーバーオブジェクトを指定して、重複排除用ディスクストレージデバイスをフィルタ処理します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEBackupExecServer を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-LogonAccount <BELogonAccount[]>

1 つ以上のログオンアカウントオブジェクトを指定して、重複排除用ディスクストレージデバイスをフィルタ処理します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BELogonAccount を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

重複排除用ディスクストレージデバイス名 (ワイルドカードを使用可能) を使用して、1 つ以上の重複排除用ディスクストレージデバイスを指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

重複排除用ディスクストレージデバイス ID (Guid) を使用して、1 つ以上の重複排除用ディスクストレージデバイスを指定します。 複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEDeduplicationDiskStorageDevice[]>

1 つ以上の重複排除用ディスクストレージデバイスオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトをパイプ処理して、Get-BEDeduplicationDiskStorageDevice によって返される重複排除用ディスクストレージデバイスをフィルタ処理します。

BackupExec.Management.CLI.BELogonAccount

Backup Exec ログオンアカウントオブジェクトをパイプ処理して、Get-BEDeduplicationDiskStorageDevice によって返される重複排除用ディスクストレージデバイスをフィルタ処理します。

BackupExec.Management.CLI.BEStorageArrayDevice

Backup Exec ストレージアレイデバイスオブジェクトをパイプ処理して、Get-BEDeduplicationDiskStorageDevice によって返される重複排除用ディスクストレージデバイスをフィルタ処理します。

System.Guid

Backup Exec 重複排除用ディスクストレージデバイスオブジェクトの ID を含む System.Guid を Get-BEDeduplicationDiskStorageDevice にパイプ処理できます。

BackupExec.Management.CLI.BEDeduplicationDiskStorageDevice

Backup Exec 重複排除用ディスクストレージデバイスオブジェクトを Get-BEDeduplicationDiskStorageDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEDeduplicationDiskStorageDevice

Get-BEDeduplicationDiskStorageDevice は、Backup Exec 重複排除用ディスクストレージデバイスを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEDeduplicationDiskStorageDevice

このコマンドはすべての重複排除用ディスクストレージデバイスを取得します。

Example 2
C:\PS> Get-BEDeduplicationDiskStorageDevice -Name "Device 01"

このコマンドは「Device 01」という名前の重複排除用ディスクストレージデバイスを取得します。

Example 3
C:\PS> Get-BEDeduplicationDiskStorageDevice -Name "Device*"

このコマンドはワイルドカード「Device*」と一致するすべての重複排除用ディスクストレージデバイスを取得します。

Example 4
C:\PS> Get-BEBackupExecServer -Local | Get-BEDeduplicationDiskStorageDevice

このコマンドは、ローカル Backup Exec サーバーに接続されているすべての重複排除用ディスクストレージデバイスを取得します。

Related Links


Get-BEDiskCartridgeDevice Help

Get-BEDiskCartridgeDevice Cmdlet
Synopsis

Backup Exec のディスクカートリッジデバイスを取得します。

Syntax
Get-BEDiskCartridgeDevice [[-Name] <String[]>] [-Unconfigured <SwitchParameter>] [<CommonParameters>]

Get-BEDiskCartridgeDevice -BackupExecServer <BEBackupExecServer[]> [[-Name] <String[]>] [-Unconfigured <SwitchParameter>] [<CommonParameters>]

Get-BEDiskCartridgeDevice -Media <BEMedia[]> [[-Name] <String[]>] [-Unconfigured <SwitchParameter>] [<CommonParameters>]

Get-BEDiskCartridgeDevice [-Id] <Guid[]> [-Unconfigured <SwitchParameter>] [<CommonParameters>]

Get-BEDiskCartridgeDevice -InputObject <BEDiskCartridgeDevice[]> [-Unconfigured <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のディスクカートリッジデバイスを取得します。

パラメータを指定しない場合、Get-BEDiskCartridgeDevice はすべての Backup Exec ディスクカートリッジデバイスを取得します。 ディスクカートリッジデバイス名、またはディスクカートリッジデバイス ID (Guid) を使用してディスクカートリッジデバイスを指定することも、パイプラインを通じて Backup Exec ディスクカートリッジデバイスオブジェクトを Get-BEDiskCartridgeDevice に渡すこともできます。

デフォルトで、Get-BEDiskCartridgeDevice は未設定のディスクカートリッジデバイスを返しません。 未設定のディスクカートリッジデバイスを取得するには、-Unconfigured パラメータを指定します。

Parameters

-Unconfigured <SwitchParameter>

未設定のディスクカートリッジデバイスを返します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer[]>

1 つ以上の Backup Exec サーバーオブジェクトを指定して、ディスクカートリッジデバイスをフィルタ処理します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEBackupExecServer を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Media <BEMedia[]>

1 つ以上の Backup Exec メディアオブジェクトを指定して、ディスクカートリッジデバイスをフィルタ処理します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEMedia を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

ディスクカートリッジデバイス名 (ワイルドカードを使用可能) を使用して、1 つ以上のディスクカートリッジデバイスを指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

ディスクカートリッジデバイス ID (Guid) を使用して、1 つ以上のディスクカートリッジデバイスを指定します。 複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEDiskCartridgeDevice[]>

1 つ以上のディスクカートリッジデバイスオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトをパイプ処理して、Get-BEDiskCartridgeDevice によって返されるディスクカートリッジデバイスをフィルタ処理します。

BackupExec.Management.CLI.BEMedia

Backup Exec メディアオブジェクトをパイプ処理して、Get-BEDiskCartridgeDevice によって返されるディスクカートリッジデバイスをフィルタ処理します。

System.Guid

Backup Exec ディスクカートリッジデバイスオブジェクトの ID を含む System.Guid を Get-BEDiskCartridgeDevice にパイプ処理できます。

BackupExec.Management.CLI.BEDiskCartridgeDevice

Backup Exec ディスクカートリッジデバイスオブジェクトを Get-BEDiskCartridgeDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEDiskCartridgeDevice

Get-BEDiskCartridgeDevice は、Backup Exec ディスクカートリッジデバイスを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEDiskCartridgeDevice

このコマンドはすべてのディスクカートリッジデバイスを取得します。

Example 2
C:\PS> Get-BEDiskCartridgeDevice -Name "Device 01"

このコマンドは「Device 01」という名前のディスクカートリッジデバイスを取得します。

Example 3
C:\PS> Get-BEDiskCartridgeDevice -Name "Device*"

このコマンドはワイルドカード「Device*」と一致するすべてのディスクカートリッジデバイスを取得します。

Example 4
C:\PS> Get-BEBackupExecServer -Local | Get-BEDiskCartridgeDevice

このコマンドは、ローカル Backup Exec サーバーに接続されているすべてのディスクカートリッジデバイスを取得します。

Related Links


Get-BEDiskStorageDevice Help

Get-BEDiskStorageDevice Cmdlet
Synopsis

Backup Exec のディスクストレージデバイスを取得します。

Syntax
Get-BEDiskStorageDevice [[-Name] <String[]>] [-DriveLetter <String[]>] [-Unconfigured <SwitchParameter>] [<CommonParameters>]

Get-BEDiskStorageDevice -BackupExecServer <BEBackupExecServer[]> [[-Name] <String[]>] [-DriveLetter <String[]>] [-Unconfigured <SwitchParameter>] [<CommonParameters>]

Get-BEDiskStorageDevice [-Id] <Guid[]> [-Unconfigured <SwitchParameter>] [<CommonParameters>]

Get-BEDiskStorageDevice -InputObject <BEDiskStorageDevice[]> [-Unconfigured <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のディスクストレージデバイスを取得します。

パラメータを指定しない場合、Get-BEDiskStorageDevice はすべての Backup Exec ディスクストレージデバイスを取得します。 ディスクストレージデバイス名またはディスクストレージデバイス ID (Guid) を使用してディスクストレージデバイスを指定することも、パイプラインを通じて Backup Exec ディスクストレージデバイスオブジェクトを Get-BEDiskStorageDevice に渡すこともできます。

デフォルトで、Get-BEDiskStorageDevice は未設定のディスクストレージデバイスを返しません。 未設定のディスクストレージデバイスを取得するには、-Unconfigured パラメータを指定します。

Parameters

-Unconfigured <SwitchParameter>

未設定のディスクストレージデバイスを返します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer[]>

1 つ以上の Backup Exec サーバーオブジェクトを指定して、ディスクストレージデバイスをフィルタ処理します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEBackupExecServer を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

ディスクストレージデバイス名 (ワイルドカードを使用可能) を使用して、1 つ以上のディスクストレージデバイスを指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-DriveLetter <String[]>

1 つ以上のドライブ文字値を指定して、ディスクストレージデバイスをフィルタ処理します。 複数の値を指定する場合は、カンマを使用して値を区切ります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Id <Guid[]>

ディスクストレージデバイス ID (Guid) を使用して、1 つ以上のディスクストレージデバイスを指定します。 複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEDiskStorageDevice[]>

1 つ以上のディスクストレージデバイスオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトをパイプ処理して、Get-BEDiskStorageDevice によって返されるディスクストレージデバイスをフィルタ処理します。

System.Guid

Backup Exec ディスクストレージデバイスオブジェクトの ID を含む System.Guid を Get-BEDiskStorageDevice にパイプ処理できます。

BackupExec.Management.CLI.BEDiskStorageDevice

Backup Exec ディスクストレージデバイスオブジェクトを Get-BEDiskStorageDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEDiskStorageDevice

Get-BEDiskStorageDevice は、Backup Exec ディスクストレージデバイスを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEDiskStorageDevice

このコマンドはすべてのディスクストレージデバイスを取得します。

Example 2
C:\PS> Get-BEDiskStorageDevice -Name "Device 01"

このコマンドは「Device 01」という名前のディスクストレージデバイスを取得します。

Example 3
C:\PS> Get-BEDiskStorageDevice -Name "Device*"

このコマンドはワイルドカード「Device*」と一致するすべてのディスクストレージデバイスを取得します。

Example 4
C:\PS> Get-BEBackupExecServer -Local | Get-BEDiskStorageDevice

このコマンドは、ローカル Backup Exec サーバーに接続されているすべてのディスクストレージデバイスを取得します。

Related Link

Get-BEBackupExecServer


Get-BEEditionInformation Help

Get-BEEditionInformation Cmdlet
Synopsis

Backup Exec エディション情報を取得します。

Syntax
Get-BEEditionInformation [<CommonParameters>]
Description

Backup Exec エディション情報を取得します。

Backup Exec エディション情報では Backup Exec サーバーの種類と評価期間の詳細が表示されます。

個別の機能ライセンスの詳細情報を表示するには、Get-BELicenseInformation を使用します。

Parameters

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

このコマンドレットは入力を受け入れません。

Return Value
BackupExec.Management.CLI.BEEditionInformation

Get-BEEditionInformation は Backup Exec エディション情報を表すオブジェクトを返します。

Example

C:\PS> Get-BEEditionInformation

このコマンドは Backup Exec エディション情報を取得します。

Related Link

Get-BELicenseInformation


Get-BEEjectUtilityJob Help

Get-BEEjectUtilityJob Cmdlet
Synopsis

Backup Exec メディアの取り出しジョブを取得します。

Syntax
Get-BEEjectUtilityJob [[-Name] <String[]>] [-Status {Unknown | Canceled | Completed | SucceededWithExceptions | OnHold | Error | Missed | Recovered | Resumed | Succeeded | ThresholdAbort | Dispatched | DispatchFailed | InvalidSchedule | InvalidTimeWindow | NotInTimeWindow | Queued | Disabled | Active | Ready | Scheduled | Superseded | ToBeScheduled | Linked | RuleBlocked}] [-IsActive <Boolean>] [<CommonParameters>]

Get-BEEjectUtilityJob -Storage <BEStorage[]> [[-Name] <String[]>] [-Status {Unknown | Canceled | Completed | SucceededWithExceptions | OnHold | Error | Missed | Recovered | Resumed | Succeeded | ThresholdAbort | Dispatched | DispatchFailed | InvalidSchedule | InvalidTimeWindow | NotInTimeWindow | Queued | Disabled | Active | Ready | Scheduled | Superseded | ToBeScheduled | Linked | RuleBlocked}] [-IsActive <Boolean>] [<CommonParameters>]

Get-BEEjectUtilityJob [-Id] <Guid[]> [<CommonParameters>]

Get-BEEjectUtilityJob -InputObject <BEEjectUtilityJob[]> [<CommonParameters>]
Description

Backup Exec メディアの取り出しジョブを取得します。

パラメータを指定しない場合、Get-BEEjectUtilityJob はすべての Backup Exec のメディアの取り出しジョブを取得します。 ジョブ名またはジョブ ID (Guid) を使用して特定のメディアの取り出しジョブを指定することも、パイプラインを通じて Backup Exec ジョブオブジェクトを Get-BEEjectUtilityJob に渡すこともできます。

Parameters

-Storage <BEStorage[]>

メディアの取り出しジョブをフィルタ処理するための 1 つ以上のストレージオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEStorage を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

ジョブ名 (ワイルドカードを使用可能) を使用して、1 つ以上のメディアの取り出しジョブを指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-IsActive <Boolean>

1 つ以上のアクティブな値を指定して、ジョブをフィルタ処理します。複数の値を指定する場合は、カンマを使用して値を区切ります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Status

1 つ以上の状態値を指定して、ジョブをフィルタ処理します。 複数の値を指定する場合は、カンマを使用して値を区切ります。

The valid values are:
Unknown
Canceled
Completed
SucceededWithExceptions
OnHold
Error
Missed
Recovered
Resumed
Succeeded
ThresholdAbort
Dispatched
DispatchFailed
InvalidSchedule
InvalidTimeWindow
NotInTimeWindow
Queued
Disabled
Active
Ready
Scheduled
Superseded
ToBeScheduled
Linked
RuleBlocked

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Id <Guid[]>

ジョブ ID (Guid) を使用して、1 つ以上のメディアの取り出しジョブを指定します。 複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEEjectUtilityJob[]>

1 つ以上のジョブオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEStorage

Backup Exec ストレージオブジェクトを Get-BEEjectUtilityJob にパイプ処理できます。

BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトを Get-BEEjectUtilityJob にパイプ処理できます。

System.Guid

Backup Exec メディアの取り出しジョブオブジェクトの ID を含む System.Guid を Get-BEEjectUtilityJob にパイプ処理できます。

BackupExec.Management.CLI.BEEjectUtilityJob

Backup Exec メディアの取り出しジョブオブジェクトを Get-BEEjectUtilityJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEEjectUtilityJob

Get-BEEjectUtilityJob は、Backup Exec メディアの取り出しジョブを表すオブジェクトを返します。

Example

C:\PS> Get-BEEjectUtilityJob -Name "EjectUtilityJob"

このコマンドは「EjectUtilityJob」という名前のメディアの取り出しジョブを取得します。

Related Links


Get-BEEncryptionKey Help

Get-BEEncryptionKey Cmdlet
Synopsis

Backup Exec の暗号化キーを取得します。.

Syntax
Get-BEEncryptionKey [[-Name] <String[]>] [<CommonParameters>]

Get-BEEncryptionKey [-Id] <Guid[]> [<CommonParameters>]

Get-BEEncryptionKey -InputObject <BEEncryptionKey[]> [<CommonParameters>]
Description

Backup Exec の暗号化キーを取得します。

パラメータを指定しない場合、Get-BEEncryptionKey はすべての Backup Exec 暗号化キーを取得します。 暗号化キー名、または暗号化キー ID (Guid) を使用して暗号化キーを指定することも、パイプラインを通じて Backup Exec 暗号化キーオブジェクトを Get-BEEncryptionKey に渡すこともできます。

Parameters

-Name <String[]>

暗号化キー名 (ワイルドカードを使用可能) を使用して、1 つ以上の暗号化キーを指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

暗号化キー ID (Guid) を使用して、1 つ以上の暗号化キーを指定します。 複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEEncryptionKey[]>

1 つ以上の暗号化キーオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
System.Guid

Backup Exec 暗号化キーオブジェクトの ID を含む System.Guid を Get-BEEncryptionKey にパイプ処理できます。

BackupExec.Management.CLI.BEEncryptionKey

Backup Exec 暗号化キーオブジェクトを Get-BEEncryptionKey にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEEncryptionKey

Get-BEEncryptionKey は、Backup Exec 暗号化キーを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEEncryptionKey

このコマンドはすべての暗号化キーを取得します。

Example 2
C:\PS> Get-BEEncryptionKey -Name "Encryption Key 01"

このコマンドは「Encryption Key 01」という名前の暗号化キーを取得します。

Example 3
C:\PS> Get-BEEncryptionKey -Name "Encryption Key*"

このコマンドはワイルドカード「Encryption Key*」と一致するすべての暗号化キーを取得します。


Get-BEEraseUtilityJob Help

Get-BEEraseUtilityJob Cmdlet
Synopsis

Backup Exec 消去操作ジョブを取得します。

Syntax
Get-BEEraseUtilityJob [[-Name] <String[]>] [-Status {Unknown | Canceled | Completed | SucceededWithExceptions | OnHold | Error | Missed | Recovered | Resumed | Succeeded | ThresholdAbort | Dispatched | DispatchFailed | InvalidSchedule | InvalidTimeWindow | NotInTimeWindow | Queued | Disabled | Active | Ready | Scheduled | Superseded | ToBeScheduled | Linked | RuleBlocked}] [-IsActive <Boolean>] [<CommonParameters>]

Get-BEEraseUtilityJob -Storage <BEStorage[]> [[-Name] <String[]>] [-Status {Unknown | Canceled | Completed | SucceededWithExceptions | OnHold | Error | Missed | Recovered | Resumed | Succeeded | ThresholdAbort | Dispatched | DispatchFailed | InvalidSchedule | InvalidTimeWindow | NotInTimeWindow | Queued | Disabled | Active | Ready | Scheduled | Superseded | ToBeScheduled | Linked | RuleBlocked}] [-IsActive <Boolean>] [<CommonParameters>]

Get-BEEraseUtilityJob [-Id] <Guid[]> [<CommonParameters>]

Get-BEEraseUtilityJob -InputObject <BEEraseUtilityJob[]> [<CommonParameters>]
Description

Backup Exec 消去操作ジョブを取得します。

パラメータを指定しない場合、Get-BEEraseUtilityJob はすべての Backup Exec 消去操作ジョブを取得します。 ジョブ名またはジョブ ID (Guid) を使用して特定の消去操作ジョブを指定することも、パイプラインを通じてジョブオブジェクトを Get-BEEraseUtilityJob に渡すこともできます。

Parameters

-Storage <BEStorage[]>

消去操作ジョブをフィルタ処理するための 1 つ以上のストレージオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEStorage を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

ジョブ名 (ワイルドカードを使用可能) を使用して、1 つ以上の消去操作ジョブを指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-IsActive <Boolean>

1 つ以上のアクティブな値を指定して、ジョブをフィルタ処理します。複数の値を指定する場合は、カンマを使用して値を区切ります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Status

1 つ以上の状態値を指定して、ジョブをフィルタ処理します。 複数の値を指定する場合は、カンマを使用して値を区切ります。

The valid values are:
Unknown
Canceled
Completed
SucceededWithExceptions
OnHold
Error
Missed
Recovered
Resumed
Succeeded
ThresholdAbort
Dispatched
DispatchFailed
InvalidSchedule
InvalidTimeWindow
NotInTimeWindow
Queued
Disabled
Active
Ready
Scheduled
Superseded
ToBeScheduled
Linked
RuleBlocked

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Id <Guid[]>

ジョブ ID (Guid) を使用して、1 つ以上の消去操作ジョブを指定します。複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEEraseUtilityJob[]>

1 つ以上の消去操作ジョブオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEStorage

Backup Exec ストレージオブジェクトを Get-BEEraseUtilityJob にパイプ処理できます。

BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトを Get-BEEraseUtilityJob にパイプ処理できます。

System.Guid

Backup Exec 消去操作ジョブオブジェクトの ID を含む System.Guid を Get-BEEraseUtilityJob にパイプ処理できます。

BackupExec.Management.CLI.BEEraseUtilityJob

Backup Exec 消去操作ジョブを Get-BEEraseUtilityJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEEraseUtilityJob

Get-BEEraseUtilityJob は Backup Exec 消去操作ジョブを表すオブジェクトを返します。

Example

C:\PS> Get-BEEraseUtilityJob -Name "EraseUtilityJob"

このコマンドは「EraseUtilityJob」という名前の消去操作ジョブを取得します。

Related Links


Get-BEErrorHandlingRule Help

Get-BEErrorHandlingRule Cmdlet
Synopsis

Backup Exec のエラー処理ルールを取得します。

Syntax
Get-BEErrorHandlingRule [[-Name] <String[]>] [<CommonParameters>]

Get-BEErrorHandlingRule [-Id] <Guid[]> [<CommonParameters>]

Get-BEErrorHandlingRule -InputObject <BEErrorHandlingRule[]> [<CommonParameters>]
Description

Backup Exec のエラー処理ルールを取得します。

パラメータを指定しない場合、Get-BEErrorHandlingRule はすべての Backup Exec エラー処理ルールを取得します。 エラー処理ルール名またはエラー処理ルール ID (Guid) を使用してエラー処理ルールを指定することも、パイプラインを通じて Backup Exec エラー処理ルールオブジェクトを Get-BEErrorHandlingRule に渡すこともできます。

Parameters

-Name <String[]>

エラー処理ルール名 (ワイルドカードを使用可能) を使用して、1 つ以上のエラー処理ルールを指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

エラー処理ルール ID (Guid) を使用して、1 つ以上のエラー処理ルールを指定します。 複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEErrorHandlingRule[]>

1 つ以上のエラー処理ルールオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
System.Guid

Backup Exec エラー処理ルールオブジェクトの ID を含む System.Guid を Get-BEErrorHandlingRule にパイプ処理できます。

BackupExec.Management.CLI.BEErrorHandlingRule

Backup Exec エラー処理ルールオブジェクトを Get-BEErrorHandlingRule にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEErrorHandlingRule

Get-BEErrorHandlingRule は、Backup Exec エラー処理ルールを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEErrorHandlingRule

このコマンドはすべてのエラー処理ルールを取得します。

Example 2
C:\PS> Get-BEErrorHandlingRule -Name "Job Cancellation"

このコマンドは「Job Cancellation」という名前のエラー処理ルールを取得します。

Example 3
C:\PS> Get-BEErrorHandlingRule -Name "*Job*"

このコマンドはワイルドカード「*Job*」と一致するすべてのエラー処理ルールを取得します。


Get-BEErrorMessage Help

Get-BEErrorMessage Cmdlet
Synopsis

エラーコードを記述するオブジェクトを取得します。

Syntax
Get-BEErrorMessage [-All <SwitchParameter>] [-LocaleId <String>] [<CommonParameters>]

Get-BEErrorMessage [-ErrorCode] <Int32> [-LocaleId <String>] [<CommonParameters>]
Description

エラーコードを記述するオブジェクトを取得します。

Parameters

-ErrorCode <Int32>

メッセージ情報が返されるエラーコードを指定します。エラーコードが存在しない場合、エラーが返されます。

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-All <SwitchParameter>

指定すると、すべてのエラーメッセージオブジェクトを返します。エラーメッセージオブジェクトはエラーコード、カテゴリ、メッセージを表示します。 cmdlet に渡されるパラメータがない場合、これはデフォルトになります。

Required | false
Position | Named
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-LocaleId <String>

メッセージ情報の結果を表示するロケールを指定します。指定されない場合、現在の BEMCLI コンソールの言語が使用されます。 可能な値は DE (ドイツ語)、EN (英語)、ES (スペイン語)、FR (フランス語)、IT (イタリア語)、JP (日本語)、KO (韓国語)、PT (ポルトガル語)、RU (ロシア語)、ZH-CHS (中国語簡体字)、および ZH-CHT (中国語繁体字) です。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.Int32

Int32 オブジェクトを Get-BEErrorMessage にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEErrorMessage

Get-BEError は BEErrorMessage オブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEErrorMessage

このコマンドは、すべての BEErrorMessage オブジェクトを取得します。

Example 2
C:\PS> Get-BEErrorMessage -All

このコマンドは、すべての BEErrorMessage オブジェクトを取得します。-All は必須ではなくデフォルトパラメータセットではないため、-All を指定する必要はありません。

Example 3
C:\PS> Get-BEErrorMessage 0xE00004321

このコマンドは、エラーコード 0xE00004321 に対応するすべての BEErrorMessage オブジェクトを取得します。

Example 4
C:\PS> Get-BEErrorMessage 0xE00004321 -LocaleId FR

このコマンドは、フランス語 (FR) ロケールのエラーコード 0xE00004321 に対応するすべての BEErrorMessage オブジェクトを取得します。

Example 5
C:\PS> Get-BEErrorMessage -LocaleId EN

このコマンドは、英語 (EN) ロケールのすべての BEErrorMessage オブジェクトを取得します。

Example 6
C:\PS> Get-BEErrorMessage -LocaleId ES

このコマンドは、スペイン語 (ES) ロケールのすべての BEErrorMessage オブジェクトを取得します。

Example 7
C:\PS> Get-BEErrorMessage -LocaleId DU

このコマンドは、ドイツ語 (DE) ロケールのすべての BEErrorMessage オブジェクトを取得します。

Example 8
C:\PS> Get-BEErrorMessage -LocaleId FR

このコマンドは、フランス語 (FR) ロケールのすべての BEErrorMessage オブジェクトを取得します。

Example 9
C:\PS> Get-BEErrorMessage -LocaleId IT

このコマンドは、イタリア語 (IT) ロケールのすべての BEErrorMessage オブジェクトを取得します。

Example 10
C:\PS> Get-BEErrorMessage -LocaleId PT

このコマンドは、ポルトガル語 (PT) ロケールのすべての BEErrorMessage オブジェクトを取得します。

Example 11
C:\PS> Get-BEErrorMessage -LocaleId RU

このコマンドは、ロシア語 (RU) ロケールのすべての BEErrorMessage オブジェクトを取得します。

Example 12
C:\PS> Get-BEErrorMessage -LocaleId KO

このコマンドは、韓国語 (KO) ロケールのすべての BEErrorMessage オブジェクトを取得します。

Example 13
C:\PS> Get-BEErrorMessage -LocaleId JP

このコマンドは、日本語 (JP) ロケールのすべての BEErrorMessage オブジェクトを取得します。

Example 14
C:\PS> Get-BEErrorMessage -LocaleId ZH-CHT

このコマンドは、中国語繁体字 (ZH-CHT) ロケールのすべての BEErrorMessage オブジェクトを取得します。

Example 15
C:\PS> Get-BEErrorMessage -LocaleId ZH-CHS

このコマンドは、中国語簡体字 (ZH-CHS) ロケールのすべての BEErrorMessage オブジェクトを取得します。


Get-BEExportExpiredUtilityJob Help

Get-BEExportExpiredUtilityJob Cmdlet
Synopsis

Backup Exec 期限切れメディアのエクスポートジョブを取得します。

Syntax
Get-BEExportExpiredUtilityJob [[-Name] <String[]>] [-Status {Unknown | Canceled | Completed | SucceededWithExceptions | OnHold | Error | Missed | Recovered | Resumed | Succeeded | ThresholdAbort | Dispatched | DispatchFailed | InvalidSchedule | InvalidTimeWindow | NotInTimeWindow | Queued | Disabled | Active | Ready | Scheduled | Superseded | ToBeScheduled | Linked | RuleBlocked}] [-IsActive <Boolean>] [<CommonParameters>]

Get-BEExportExpiredUtilityJob -Storage <BEStorage[]> [[-Name] <String[]>] [-Status {Unknown | Canceled | Completed | SucceededWithExceptions | OnHold | Error | Missed | Recovered | Resumed | Succeeded | ThresholdAbort | Dispatched | DispatchFailed | InvalidSchedule | InvalidTimeWindow | NotInTimeWindow | Queued | Disabled | Active | Ready | Scheduled | Superseded | ToBeScheduled | Linked | RuleBlocked}] [-IsActive <Boolean>] [<CommonParameters>]

Get-BEExportExpiredUtilityJob [-Id] <Guid[]> [<CommonParameters>]

Get-BEExportExpiredUtilityJob -InputObject <BEExportExpiredUtilityJob[]> [<CommonParameters>]
Description

Backup Exec 期限切れメディアのエクスポートジョブを取得します。

パラメータを指定しない場合、Get-BEExportExpiredUtilityJob はすべての Backup Exec 期限切れメディアのエクスポートジョブを取得します。 ジョブ名またはジョブ ID (Guid) を使用して特定の期限切れメディアのエクスポートジョブを指定することも、パイプラインを通じてジョブオブジェクトを Get-BEExportExpiredUtilityJob に渡すこともできます。

Parameters

-Storage <BEStorage[]>

期限切れメディアのエクスポートジョブをフィルタ処理するための 1 つまたは複数のストレージオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEStorage を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

ジョブ名 (ワイルドカードを使用可能) を使用して、1 つ以上の期限切れメディアをエクスポートするジョブを指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-IsActive <Boolean>

1 つ以上のアクティブな値を指定して、ジョブをフィルタ処理します。複数の値を指定する場合は、カンマを使用して値を区切ります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Status

1 つ以上の状態値を指定して、ジョブをフィルタ処理します。 複数の値を指定する場合は、カンマを使用して値を区切ります。

The valid values are:
Unknown
Canceled
Completed
SucceededWithExceptions
OnHold
Error
Missed
Recovered
Resumed
Succeeded
ThresholdAbort
Dispatched
DispatchFailed
InvalidSchedule
InvalidTimeWindow
NotInTimeWindow
Queued
Disabled
Active
Ready
Scheduled
Superseded
ToBeScheduled
Linked
RuleBlocked

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Id <Guid[]>

ジョブ ID (Guid) を使用して、1 つ以上の期限切れメディアをエクスポートするジョブを指定します。 複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEExportExpiredUtilityJob[]>

1 つ以上の期限切れメディアのエクスポートジョブのオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEStorage

Backup Exec ストレージオブジェクトを Get-BEExportExpiredUtilityJob にパイプ処理できます。

BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトを Get-BEExportExpiredUtilityJob にパイプ処理できます。

System.Guid

Backup Exec 期限切れメディアのエクスポートジョブオブジェクトの ID を含む System.Guid を Get-BEExportExpiredUtilityJob にパイプ処理できます。

BackupExec.Management.CLI.BEExportExpiredUtilityJob

Backup Exec 期限切れユーティリティのエクスポートジョブオブジェクトを Get-BEExportExpiredUtilityJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEExportExpiredUtilityJob

Get-BEExportExpiredUtilityJob は、Backup Exec の期限切れメディアのエクスポートジョブを表すオブジェクトを返します。

Example

C:\PS> Get-BEExportExpiredUtilityJob -Name "ExportExpiredUtilityJob"

このコマンドは「ExportExpiredUtilityJob」という名前の期限切れメディアをエクスポートするジョブを取得します。

Related Links


Get-BEExportUtilityJob Help

Get-BEExportUtilityJob Cmdlet
Synopsis

Backup Exec メディアのエクスポートジョブを取得します。

Syntax
Get-BEExportUtilityJob [[-Name] <String[]>] [-Status {Unknown | Canceled | Completed | SucceededWithExceptions | OnHold | Error | Missed | Recovered | Resumed | Succeeded | ThresholdAbort | Dispatched | DispatchFailed | InvalidSchedule | InvalidTimeWindow | NotInTimeWindow | Queued | Disabled | Active | Ready | Scheduled | Superseded | ToBeScheduled | Linked | RuleBlocked}] [-IsActive <Boolean>] [<CommonParameters>]

Get-BEExportUtilityJob -Storage <BEStorage[]> [[-Name] <String[]>] [-Status {Unknown | Canceled | Completed | SucceededWithExceptions | OnHold | Error | Missed | Recovered | Resumed | Succeeded | ThresholdAbort | Dispatched | DispatchFailed | InvalidSchedule | InvalidTimeWindow | NotInTimeWindow | Queued | Disabled | Active | Ready | Scheduled | Superseded | ToBeScheduled | Linked | RuleBlocked}] [-IsActive <Boolean>] [<CommonParameters>]

Get-BEExportUtilityJob [-Id] <Guid[]> [<CommonParameters>]

Get-BEExportUtilityJob -InputObject <BEExportUtilityJob[]> [<CommonParameters>]
Description

Backup Exec メディアのエクスポートジョブを取得します。

パラメータを指定しない場合、Get-BEExportUtilityJob はすべての Backup Exec メディアのエクスポートジョブを取得します。 ジョブ名またはジョブ ID (Guid) を使用して特定の期限切れメディアのエクスポートジョブを指定することも、パイプラインを通じてジョブオブジェクトを Get-BEExportUtilityJob に渡すこともできます。

Parameters

-Storage <BEStorage[]>

メディアのエクスポートジョブをフィルタ処理するための 1 つ以上のストレージオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEStorage を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

ジョブ名 (ワイルドカードを使用可能) を使用して、1 つ以上のメディアをエクスポートするジョブを指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-IsActive <Boolean>

1 つ以上のアクティブな値を指定して、ジョブをフィルタ処理します。複数の値を指定する場合は、カンマを使用して値を区切ります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Status

1 つ以上の状態値を指定して、ジョブをフィルタ処理します。 複数の値を指定する場合は、カンマを使用して値を区切ります。

The valid values are:
Unknown
Canceled
Completed
SucceededWithExceptions
OnHold
Error
Missed
Recovered
Resumed
Succeeded
ThresholdAbort
Dispatched
DispatchFailed
InvalidSchedule
InvalidTimeWindow
NotInTimeWindow
Queued
Disabled
Active
Ready
Scheduled
Superseded
ToBeScheduled
Linked
RuleBlocked

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Id <Guid[]>

ジョブ ID (Guid) を使用して、1 つ以上の期限切れメディアをエクスポートするジョブを指定します。 複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEExportUtilityJob[]>

1 つ以上のメディアのエクスポートジョブオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEStorage

Backup Exec ストレージオブジェクトを Get-BEExportUtilityJob にパイプ処理できます。

BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトを Get-BEExportUtilityJob にパイプ処理できます。

System.Guid

Backup Exec メディアのエクスポートジョブオブジェクトの ID を含む System.Guid を Get-BEExportUtilityJob にパイプ処理できます。

BackupExec.Management.CLI.BEExportUtilityJob

Backup Exec メディアのエクスポートジョブオブジェクトを Get-BEExportUtilityJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEExportUtilityJob

Get-BEExportUtilityJob は、Backup Exec メディアのエクスポートジョブを表すオブジェクトを返します。

Example

C:\PS> Get-BEExportUtilityJob -Name "ExportUtilityJob"

このコマンドは「ExportUtilityJob」という名前のメディアのエクスポートジョブを取得します。

Related Links


Get-BEGlobalExcludeSelection Help

Get-BEGlobalExcludeSelection Cmdlet
Synopsis

すべての選択項目からグローバルに除外されるファイルシステムの選択項目を取得します。

Syntax
Get-BEGlobalExcludeSelection [<CommonParameters>]
Description

Backup Exec サーバーのすべての選択項目からグローバルに除外されるファイルシステムの選択項目を取得します。

Parameters

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

このコマンドレットは入力を受け入れません。

Return Value
BackupExec.Management.CLI.BEFileSystemSelection

Get-BEBackupDefinition は Backup Exec バックアップ定義を表すオブジェクトを返します。

Example

C:\PS> Get-BEGlobalExcludeSelection

このコマンドは選択項目のグローバル除外リストに追加する選択項目のリストを取得します。

Related Link

Get-BEBackupDefinition


Get-BEImportUtilityJob Help

Get-BEImportUtilityJob Cmdlet
Synopsis

Backup Exec のメディアのインポートジョブを取得します。

Syntax
Get-BEImportUtilityJob [[-Name] <String[]>] [-Status {Unknown | Canceled | Completed | SucceededWithExceptions | OnHold | Error | Missed | Recovered | Resumed | Succeeded | ThresholdAbort | Dispatched | DispatchFailed | InvalidSchedule | InvalidTimeWindow | NotInTimeWindow | Queued | Disabled | Active | Ready | Scheduled | Superseded | ToBeScheduled | Linked | RuleBlocked}] [-IsActive <Boolean>] [<CommonParameters>]

Get-BEImportUtilityJob -Storage <BEStorage[]> [[-Name] <String[]>] [-Status {Unknown | Canceled | Completed | SucceededWithExceptions | OnHold | Error | Missed | Recovered | Resumed | Succeeded | ThresholdAbort | Dispatched | DispatchFailed | InvalidSchedule | InvalidTimeWindow | NotInTimeWindow | Queued | Disabled | Active | Ready | Scheduled | Superseded | ToBeScheduled | Linked | RuleBlocked}] [-IsActive <Boolean>] [<CommonParameters>]

Get-BEImportUtilityJob [-Id] <Guid[]> [<CommonParameters>]

Get-BEImportUtilityJob -InputObject <BEImportUtilityJob[]> [<CommonParameters>]
Description

Backup Exec メディアのインポートジョブを取得します。

パラメータを指定しない場合、Get-BEImportUtilityJob はすべての Backup Exec メディアのインポートジョブを取得します。 ジョブ名またはジョブ ID (Guid) を使用して特定のメディアのインポートジョブを指定したり、パイプラインを通じてジョブオブジェクトを Get-BEImportUtilityJob に渡すこともできます。

Parameters

-Storage <BEStorage[]>

メディアのインポートジョブをフィルタ処理するための 1 つ以上のストレージオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEStorage を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

ジョブ名 (ワイルドカードを使用可能) を使用して、1 つ以上のメディアのインポートジョブを指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-IsActive <Boolean>

1 つ以上のアクティブな値を指定して、ジョブをフィルタ処理します。複数の値を指定する場合は、カンマを使用して値を区切ります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Status

1 つ以上の状態値を指定して、ジョブをフィルタ処理します。 複数の値を指定する場合は、カンマを使用して値を区切ります。

The valid values are:
Unknown
Canceled
Completed
SucceededWithExceptions
OnHold
Error
Missed
Recovered
Resumed
Succeeded
ThresholdAbort
Dispatched
DispatchFailed
InvalidSchedule
InvalidTimeWindow
NotInTimeWindow
Queued
Disabled
Active
Ready
Scheduled
Superseded
ToBeScheduled
Linked
RuleBlocked

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Id <Guid[]>

ジョブ ID (Guid) を使用して、1 つ以上の期限切れメディアのインポートジョブを指定します。 複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEImportUtilityJob[]>

1 つ以上のメディアのインポートジョブオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEStorage

>Backup Exec ストレージオブジェクトを Get-BEImportUtilityJob にパイプ処理できます。.

BackupExec.Management.CLI.BEBackupExecServer

>Backup Exec サーバーオブジェクトを Get-BEImportUtilityJob にパイプ処理できます。

System.Guid

Backup Exec メディアのインポートジョブオブジェクトの ID を含む System.Guid を Get-BEImportUtilityJob にパイプ処理できます。

BackupExec.Management.CLI.BEImportUtilityJob

Backup Exec メディアのインポートジョブオブジェクトを Get-BEImportUtilityJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEImportUtilityJob

Get-BEImportUtilityJob は、Backup Exec メディアのインポートジョブを表すオブジェクトを返します。

Example

C:\PS> Get-BEImportUtilityJob -Name "ImportUtilityJob"

このコマンドは「ImportUtilityJob」という名前のメディアのインポートジョブを取得します。

Related Links


Get-BEInstalledUpdate Help

Get-BEInstalledUpdate Cmdlet
Synopsis

Backup Exec サーバーにインストールされた保守パックの詳細を取得します。.

Syntax
Get-BEInstalledUpdate [[-Name] <String[]>] [<CommonParameters>]

Get-BEInstalledUpdate [-Id] <Guid[]> [<CommonParameters>]

Get-BEInstalledUpdate -InputObject <BEInstalledUpdate[]> [<CommonParameters>]
Description

Backup Exec サーバーにインストールされている保守パックの更新番号と更新の種類を取得します。

Parameters

-Name <String[]>

更新の番号を使用して 1 つ以上のバックアップの更新を指定します。複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

1 つ以上の更新 ID (Guid) 指定します。 複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEInstalledUpdate[]>

1 つ以上のインストールされた更新オブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.Guid

インストールされた更新オブジェクトの ID を含む System.Guid を Get-BEInstalledUpdate にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEInstalledUpdate

Get-BEInstalledUpdate は Backup Exec サーバーでインストールされた更新を表すオブジェクトを返します。

Example

C:\PS> Get-BEInstalledUpdate

このコマンドは Backup Exec サーバーにインストールされた更新の詳細 (ServicePack または Hotfix) を取得します。.


Get-BEInventoryUtilityJob Help

Get-BEInventoryUtilityJob Cmdlet
Synopsis

Backup Exec インベントリ操作ジョブを取得します。

Syntax
Get-BEInventoryUtilityJob [[-Name] <String[]>] [-Status {Unknown | Canceled | Completed | SucceededWithExceptions | OnHold | Error | Missed | Recovered | Resumed | Succeeded | ThresholdAbort | Dispatched | DispatchFailed | InvalidSchedule | InvalidTimeWindow | NotInTimeWindow | Queued | Disabled | Active | Ready | Scheduled | Superseded | ToBeScheduled | Linked | RuleBlocked}] [-IsActive <Boolean>] [<CommonParameters>]

Get-BEInventoryUtilityJob -Storage <BEStorage[]> [[-Name] <String[]>] [-Status {Unknown | Canceled | Completed | SucceededWithExceptions | OnHold | Error | Missed | Recovered | Resumed | Succeeded | ThresholdAbort | Dispatched | DispatchFailed | InvalidSchedule | InvalidTimeWindow | NotInTimeWindow | Queued | Disabled | Active | Ready | Scheduled | Superseded | ToBeScheduled | Linked | RuleBlocked}] [-IsActive <Boolean>] [<CommonParameters>]

Get-BEInventoryUtilityJob [-Id] <Guid[]> [<CommonParameters>]

Get-BEInventoryUtilityJob -InputObject <BEInventoryUtilityJob[]> [<CommonParameters>]
Description

Backup Exec インベントリ操作ジョブを取得します。

パラメータを指定しない場合、Get-BEInventoryUtilityJob はすべての Backup Exec インベントリ操作ジョブを取得します。 ジョブ名またはジョブ ID (Guid) を使用して特定のインベントリ操作ジョブを指定することも、パイプラインを通じてジョブオブジェクトを Get-BEInventoryUtilityJob に渡すこともできます。

Parameters

-Storage <BEStorage[]>

インベントリ操作ジョブをフィルタ処理するための 1 つ以上のストレージオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEStorage を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

ジョブ名 (ワイルドカードを使用可能) を使用して、1 つ以上のインベントリ操作ジョブを指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-IsActive <Boolean>

1 つ以上のアクティブな値を指定して、ジョブをフィルタ処理します。複数の値を指定する場合は、カンマを使用して値を区切ります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Status

1 つ以上の状態値を指定して、ジョブをフィルタ処理します。 複数の値を指定する場合は、カンマを使用して値を区切ります。

The valid values are:
Unknown
Canceled
Completed
SucceededWithExceptions
OnHold
Error
Missed
Recovered
Resumed
Succeeded
ThresholdAbort
Dispatched
DispatchFailed
InvalidSchedule
InvalidTimeWindow
NotInTimeWindow
Queued
Disabled
Active
Ready
Scheduled
Superseded
ToBeScheduled
Linked
RuleBlocked

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Id <Guid[]>

ジョブ ID (Guid) を使用して、1 つ以上のインベントリ操作ジョブを指定します。複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEInventoryUtilityJob[]>

1 つ以上のインベントリ操作ジョブオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEStorage

Backup Exec ストレージオブジェクトを Get-BEInventoryUtilityJob にパイプ処理できます。

BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトを Get-BEInventoryUtilityJob にパイプ処理できます。

System.Guid

Backup Exec インベントリ操作ジョブオブジェクトの ID を含む System.Guid を Get-BEInventoryUtilityJob にパイプ処理できます。

BackupExec.Management.CLI.BEInventoryUtilityJob

Backup Exec インベントリ操作ジョブオブジェクトを Get-BEInventoryUtilityJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEInventoryUtilityJob

Get-BEInventoryUtilityJob は Backup Exec インベントリ操作ジョブを表すオブジェクトを返します。

Example

C:\PS> Get-BEInventoryUtilityJob -Name "InventoryUtilityJob"

このコマンドは「InventoryUtilityJob」という名前のインベントリ操作ジョブを取得します。

Related Links


Get-BEJob Help

Get-BEJob Cmdlet
Synopsis

Backup Exec のジョブを取得します。

Syntax
Get-BEJob [[-Name] <String[]>] [-Status {Unknown | Canceled | Completed | SucceededWithExceptions | OnHold | Error | Missed | Recovered | Resumed | Succeeded | ThresholdAbort | Dispatched | DispatchFailed | InvalidSchedule | InvalidTimeWindow | NotInTimeWindow | Queued | Disabled | Active | Ready | Scheduled | Superseded | ToBeScheduled | Linked | RuleBlocked}] [-JobType {Unknown | Backup | Restore | Verify | Catalog | Utility | Report | Duplicate | TestRun | ResourceDiscovery | CopyJob | Install | ConvertToVirtual | RecoverVM | RemoveVM | ValidateVM}] [-TaskType {None | OnetimeBackup | Full | IndependentFull | CustomBackup | Duplicate | ConvertToVirtual | ConvertBackupToVirtual | Verify | DelayedCatalog | ExportMediaToVault | TestRun | VirtualToVirtualReplication | Incremental | SyntheticFull | Differential | ConsolidateFull}] [-IsActive <Boolean>] [-TaskName <String[]>] [<CommonParameters>]

Get-BEJob -Storage <BEStorage[]> [[-Name] <String[]>] [-Status {Unknown | Canceled | Completed | SucceededWithExceptions | OnHold | Error | Missed | Recovered | Resumed | Succeeded | ThresholdAbort | Dispatched | DispatchFailed | InvalidSchedule | InvalidTimeWindow | NotInTimeWindow | Queued | Disabled | Active | Ready | Scheduled | Superseded | ToBeScheduled | Linked | RuleBlocked}] [-JobType {Unknown | Backup | Restore | Verify | Catalog | Utility | Report | Duplicate | TestRun | ResourceDiscovery | CopyJob | Install | ConvertToVirtual | RecoverVM | RemoveVM | ValidateVM}] [-TaskType {None | OnetimeBackup | Full | IndependentFull | CustomBackup | Duplicate | ConvertToVirtual | ConvertBackupToVirtual | Verify | DelayedCatalog | ExportMediaToVault | TestRun | VirtualToVirtualReplication | Incremental | SyntheticFull | Differential | ConsolidateFull}] [-IsActive <Boolean>] [-TaskName <String[]>] [<CommonParameters>]

Get-BEJob -MediaSet <BEMediaSet[]> [[-Name] <String[]>] [-Status {Unknown | Canceled | Completed | SucceededWithExceptions | OnHold | Error | Missed | Recovered | Resumed | Succeeded | ThresholdAbort | Dispatched | DispatchFailed | InvalidSchedule | InvalidTimeWindow | NotInTimeWindow | Queued | Disabled | Active | Ready | Scheduled | Superseded | ToBeScheduled | Linked | RuleBlocked}] [-JobType {Unknown | Backup | Restore | Verify | Catalog | Utility | Report | Duplicate | TestRun | ResourceDiscovery | CopyJob | Install | ConvertToVirtual | RecoverVM | RemoveVM | ValidateVM}] [-TaskType {None | OnetimeBackup | Full | IndependentFull | CustomBackup | Duplicate | ConvertToVirtual | ConvertBackupToVirtual | Verify | DelayedCatalog | ExportMediaToVault | TestRun | VirtualToVirtualReplication | Incremental | SyntheticFull | Differential | ConsolidateFull}] [-IsActive <Boolean>] [-TaskName <String[]>] [<CommonParameters>]

Get-BEJob -MediaVault <BEMediaVault[]> [[-Name] <String[]>] [-Status {Unknown | Canceled | Completed | SucceededWithExceptions | OnHold | Error | Missed | Recovered | Resumed | Succeeded | ThresholdAbort | Dispatched | DispatchFailed | InvalidSchedule | InvalidTimeWindow | NotInTimeWindow | Queued | Disabled | Active | Ready | Scheduled | Superseded | ToBeScheduled | Linked | RuleBlocked}] [-JobType {Unknown | Backup | Restore | Verify | Catalog | Utility | Report | Duplicate | TestRun | ResourceDiscovery | CopyJob | Install | ConvertToVirtual | RecoverVM | RemoveVM | ValidateVM}] [-TaskType {None | OnetimeBackup | Full | IndependentFull | CustomBackup | Duplicate | ConvertToVirtual | ConvertBackupToVirtual | Verify | DelayedCatalog | ExportMediaToVault | TestRun | VirtualToVirtualReplication | Incremental | SyntheticFull | Differential | ConsolidateFull}] [-IsActive <Boolean>] [-TaskName <String[]>] [<CommonParameters>]

Get-BEJob -BackupDefinition <BEBackupDefinition[]> [[-Name] <String[]>] [-Status {Unknown | Canceled | Completed | SucceededWithExceptions | OnHold | Error | Missed | Recovered | Resumed | Succeeded | ThresholdAbort | Dispatched | DispatchFailed | InvalidSchedule | InvalidTimeWindow | NotInTimeWindow | Queued | Disabled | Active | Ready | Scheduled | Superseded | ToBeScheduled | Linked | RuleBlocked}] [-JobType {Unknown | Backup | Restore | Verify | Catalog | Utility | Report | Duplicate | TestRun | ResourceDiscovery | CopyJob | Install | ConvertToVirtual | RecoverVM | RemoveVM | ValidateVM}] [-TaskType {None | OnetimeBackup | Full | IndependentFull | CustomBackup | Duplicate | ConvertToVirtual | ConvertBackupToVirtual | Verify | DelayedCatalog | ExportMediaToVault | TestRun | VirtualToVirtualReplication | Incremental | SyntheticFull | Differential | ConsolidateFull}] [-IsActive <Boolean>] [-TaskName <String[]>] [<CommonParameters>]

Get-BEJob -SyntheticBackupDefinition <BESyntheticBackupDefinition[]> [[-Name] <String[]>] [-Status {Unknown | Canceled | Completed | SucceededWithExceptions | OnHold | Error | Missed | Recovered | Resumed | Succeeded | ThresholdAbort | Dispatched | DispatchFailed | InvalidSchedule | InvalidTimeWindow | NotInTimeWindow | Queued | Disabled | Active | Ready | Scheduled | Superseded | ToBeScheduled | Linked | RuleBlocked}] [-JobType {Unknown | Backup | Restore | Verify | Catalog | Utility | Report | Duplicate | TestRun | ResourceDiscovery | CopyJob | Install | ConvertToVirtual | RecoverVM | RemoveVM | ValidateVM}] [-TaskType {None | OnetimeBackup | Full | IndependentFull | CustomBackup | Duplicate | ConvertToVirtual | ConvertBackupToVirtual | Verify | DelayedCatalog | ExportMediaToVault | TestRun | VirtualToVirtualReplication | Incremental | SyntheticFull | Differential | ConsolidateFull}] [-IsActive <Boolean>] [-TaskName <String[]>] [<CommonParameters>]

Get-BEJob -OneTimeBackupJob <BEOneTimeBackupJob[]> [[-Name] <String[]>] [-Status {Unknown | Canceled | Completed | SucceededWithExceptions | OnHold | Error | Missed | Recovered | Resumed | Succeeded | ThresholdAbort | Dispatched | DispatchFailed | InvalidSchedule | InvalidTimeWindow | NotInTimeWindow | Queued | Disabled | Active | Ready | Scheduled | Superseded | ToBeScheduled | Linked | RuleBlocked}] [-JobType {Unknown | Backup | Restore | Verify | Catalog | Utility | Report | Duplicate | TestRun | ResourceDiscovery | CopyJob | Install | ConvertToVirtual | RecoverVM | RemoveVM | ValidateVM}] [-TaskType {None | OnetimeBackup | Full | IndependentFull | CustomBackup | Duplicate | ConvertToVirtual | ConvertBackupToVirtual | Verify | DelayedCatalog | ExportMediaToVault | TestRun | VirtualToVirtualReplication | Incremental | SyntheticFull | Differential | ConsolidateFull}] [-IsActive <Boolean>] [-TaskName <String[]>] [<CommonParameters>]

Get-BEJob -BackupExecServer <BEBackupExecServer[]> [[-Name] <String[]>] [-Status {Unknown | Canceled | Completed | SucceededWithExceptions | OnHold | Error | Missed | Recovered | Resumed | Succeeded | ThresholdAbort | Dispatched | DispatchFailed | InvalidSchedule | InvalidTimeWindow | NotInTimeWindow | Queued | Disabled | Active | Ready | Scheduled | Superseded | ToBeScheduled | Linked | RuleBlocked}] [-JobType {Unknown | Backup | Restore | Verify | Catalog | Utility | Report | Duplicate | TestRun | ResourceDiscovery | CopyJob | Install | ConvertToVirtual | RecoverVM | RemoveVM | ValidateVM}] [-TaskType {None | OnetimeBackup | Full | IndependentFull | CustomBackup | Duplicate | ConvertToVirtual | ConvertBackupToVirtual | Verify | DelayedCatalog | ExportMediaToVault | TestRun | VirtualToVirtualReplication | Incremental | SyntheticFull | Differential | ConsolidateFull}] [-IsActive <Boolean>] [-TaskName <String[]>] [<CommonParameters>]

Get-BEJob -AgentServer <BEAgentServer[]> [[-Name] <String[]>] [-Status {Unknown | Canceled | Completed | SucceededWithExceptions | OnHold | Error | Missed | Recovered | Resumed | Succeeded | ThresholdAbort | Dispatched | DispatchFailed | InvalidSchedule | InvalidTimeWindow | NotInTimeWindow | Queued | Disabled | Active | Ready | Scheduled | Superseded | ToBeScheduled | Linked | RuleBlocked}] [-JobType {Unknown | Backup | Restore | Verify | Catalog | Utility | Report | Duplicate | TestRun | ResourceDiscovery | CopyJob | Install | ConvertToVirtual | RecoverVM | RemoveVM | ValidateVM}] [-TaskType {None | OnetimeBackup | Full | IndependentFull | CustomBackup | Duplicate | ConvertToVirtual | ConvertBackupToVirtual | Verify | DelayedCatalog | ExportMediaToVault | TestRun | VirtualToVirtualReplication | Incremental | SyntheticFull | Differential | ConsolidateFull}] [-IsActive <Boolean>] [-TaskName <String[]>] [<CommonParameters>]

Get-BEJob [-Id] <Guid[]> [<CommonParameters>]

Get-BEJob -InputObject <BEJob[]> [<CommonParameters>]
Description

Backup Exec のジョブを取得します。

パラメータを指定しない場合、Get-BEJob はすべての Backup Exec ジョブを取得します。 ジョブ名またはジョブ ID (Guid) を使用してジョブを指定することも、パイプラインを通じて Backup Exec ジョブオブジェクトを Get-BEJob に渡すこともできます。

Parameters

-Storage <BEStorage[]>

バックアップジョブに使用するストレージデバイスを指定します。 Get-BEStorage を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-MediaSet <BEMediaSet[]>

1 つ以上のメディアセットオブジェクトを指定して、ジョブをフィルタ処理します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEMediaSet を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-MediaVault <BEMediaVault[]>

1 つ以上のメディアボルトオブジェクトを指定して、ジョブをフィルタ処理します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEMediaVault を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupDefinition <BEBackupDefinition[]>

1 つ以上のバックアップ定義オブジェクトを指定して、ジョブをフィルタ処理します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEBackupDefinition を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-SyntheticBackupDefinition <BESyntheticBackupDefinition[]>

1 つ以上の合成バックアップ定義オブジェクトを指定して、ジョブをフィルタ処理します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BESyntheticBackupDefinition 参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-OneTimeBackupJob <BEOneTimeBackupJob[]>

1 つ以上のワンタイムバックアップジョブオブジェクトを指定して、ジョブをフィルタ処理します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEOneTimeBackupJob を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer[]>

1 つ以上の Backup Exec サーバーオブジェクトを指定して、ジョブをフィルタ処理します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEBackupExecServer を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-AgentServer <BEAgentServer[]>

1 つ以上のエージェントサーバーオブジェクトを指定して、ジョブをフィルタ処理します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEAgentServer を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

ジョブ名 (ワイルドカードを使用可能) を使用して、1 つ以上のジョブを指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-TaskName <String[]>

1 つ以上のタスク名値を指定して、ジョブをフィルタ処理します。 複数の値を指定する場合は、カンマを使用して値を区切ります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IsActive <Boolean>

1 つ以上のアクティブな値を指定して、ジョブをフィルタ処理します。複数の値を指定する場合は、カンマを使用して値を区切ります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Status

1 つ以上の状態値を指定して、ジョブをフィルタ処理します。 複数の値を指定する場合は、カンマを使用して値を区切ります。

The valid values are:
Unknown
Canceled
Completed
SucceededWithExceptions
OnHold
Error
Missed
Recovered
Resumed
Succeeded
ThresholdAbort
Dispatched
DispatchFailed
InvalidSchedule
InvalidTimeWindow
NotInTimeWindow
Queued
Disabled
Active
Ready
Scheduled
Superseded
ToBeScheduled
Linked
RuleBlocked

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-JobType

1 つ以上のジョブタイプオブジェクトを指定して、ジョブをフィルタ処理します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEJobType を参照してください。

The valid values are:
Unknown
Backup
Restore
Verify
Catalog
Utility
Report
Duplicate
TestRun
ResourceDiscovery
CopyJob
Install
ConvertToVirtual
RecoverVM
RemoveVM
ValidateVM

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TaskType

1 つ以上のタスクタイプオブジェクトを指定して、ジョブをフィルタ処理します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BETaskType を参照してください。

The valid values are:
None
OnetimeBackup
Full
IndependentFull
CustomBackup
Duplicate
ConvertToVirtual
ConvertBackupToVirtual
Verify
DelayedCatalog
ExportMediaToVault
TestRun
VirtualToVirtualReplication
Incremental
SyntheticFull
Differential
ConsolidateFull

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Id <Guid[]>

ジョブ ID (Guid) を使用して、1 つ以上のジョブを指定します。 複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEJob[]>

1 つ以上のジョブオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEStorage

Backup Exec ストレージオブジェクトをパイプ処理して、Get-BEJob によって返されるジョブをフィルタ処理できます。

BackupExec.Management.CLI.BEMediaSet

Backup Exec メディアセットオブジェクトをパイプ処理して、Get-BEJob によって返されるジョブをフィルタ処理できます。

BackupExec.Management.CLI.BEMediaVault

Backup Exec メディアボルトオブジェクトをパイプ処理して、Get-BEJob によって返されるジョブをフィルタ処理できます。

BackupExec.Management.CLI.BEBackupDefinition

Backup Exec バックアップ定義オブジェクトをパイプ処理して、Get-BEJob によって返されるジョブをフィルタ処理できます。

BackupExec.Management.CLI.BEAgentServer

Backup Exec エージェントサーバーオブジェクトをパイプ処理して、Get-BEJob によって返されるジョブをフィルタ処理できます。

System.Guid

Backup Exec ジョブオブジェクトの ID を含む System.Guid を Get-BEJob にパイプ処理できます。

BackupExec.Management.CLI.BEJob

Backup Exec ジョブオブジェクトを Get-BEJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEJob

Get-BEJob は、Backup Exec ジョブを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEJob

このコマンドはすべての Backup Exec ジョブを取得します。

Example 2
C:\PS> Get-BEJob -Name "Job 01"

このコマンドは「Job 01」という名前の Backup Exec ジョブを取得します。

Example 3
C:\PS> Get-BEJob -Name "Job*"

このコマンドはワイルドカード「Job*」と一致するすべての Backup Exec ジョブを取得します。

Example 4
C:\PS> Get-BEJob -Name "Job 01" | Wait-BEJob

これらのコマンドは「Job 01」という名前の Backup Exec ジョブが完了するまで待機します。

Example 5
C:\PS> Get-BEJob -Name "Job 01" | Suspend-BEJob

これらのコマンドは「Job 01」という名前の Backup Exec ジョブを保留します。

Example 6
C:\PS> Get-BEJob -Name "Job 01" | Resume-BEJob

これらのコマンドは「Job 01」という名前の Backup Exec ジョブを再開します。

Example 7
C:\PS> Get-BEJob -Name "Job 01" | Stop-BEJob

これらのコマンドは「Job 01」という名前の Backup Exec ジョブをキャンセルします。

Related Links

Get-BEStorage
Get-BEMediaSet
Get-BEMediaVault
Get-BEBackupDefinition
Get-BESyntheticBackupDefinition
Get-BEOneTimeBackupJob
Get-BEAgentServer
Get-BEBackupExecServer
Wait-BEJob
Suspend-BEJob
Resume-BEJob
Stop-BEJob


Get-BEJobHistory Help

Get-BEJobHistory Cmdlet
Synopsis

Backup Exec のジョブ履歴を取得します。

Syntax
Get-BEJobHistory [[-Name] <String[]>] [-JobStatus {Unknown | Canceled | Completed | SucceededWithExceptions | OnHold | Error | Missed | Recovered | Resumed | Succeeded | ThresholdAbort | Dispatched | DispatchFailed | InvalidSchedule | InvalidTimeWindow | NotInTimeWindow | Queued | Disabled | Active | Ready | Scheduled | Superseded | ToBeScheduled | Linked | RuleBlocked}] [-JobType {Unknown | Backup | Restore | Verify | Catalog | Utility | Report | Duplicate | TestRun | ResourceDiscovery | CopyJob | Install | ConvertToVirtual | RecoverVM | RemoveVM | ValidateVM}] [-FromLastJobRun <SwitchParameter>] [-FromStartTime <DateTime>] [-ToStartTime <DateTime>] [<CommonParameters>]

Get-BEJobHistory -Job <BEJob[]> [[-Name] <String[]>] [-JobStatus {Unknown | Canceled | Completed | SucceededWithExceptions | OnHold | Error | Missed | Recovered | Resumed | Succeeded | ThresholdAbort | Dispatched | DispatchFailed | InvalidSchedule | InvalidTimeWindow | NotInTimeWindow | Queued | Disabled | Active | Ready | Scheduled | Superseded | ToBeScheduled | Linked | RuleBlocked}] [-JobType {Unknown | Backup | Restore | Verify | Catalog | Utility | Report | Duplicate | TestRun | ResourceDiscovery | CopyJob | Install | ConvertToVirtual | RecoverVM | RemoveVM | ValidateVM}] [-FromLastJobRun <SwitchParameter>] [-FromStartTime <DateTime>] [-ToStartTime <DateTime>] [<CommonParameters>]

Get-BEJobHistory -Storage <BEStorage[]> [[-Name] <String[]>] [-JobStatus {Unknown | Canceled | Completed | SucceededWithExceptions | OnHold | Error | Missed | Recovered | Resumed | Succeeded | ThresholdAbort | Dispatched | DispatchFailed | InvalidSchedule | InvalidTimeWindow | NotInTimeWindow | Queued | Disabled | Active | Ready | Scheduled | Superseded | ToBeScheduled | Linked | RuleBlocked}] [-JobType {Unknown | Backup | Restore | Verify | Catalog | Utility | Report | Duplicate | TestRun | ResourceDiscovery | CopyJob | Install | ConvertToVirtual | RecoverVM | RemoveVM | ValidateVM}] [-FromLastJobRun <SwitchParameter>] [-FromStartTime <DateTime>] [-ToStartTime <DateTime>] [<CommonParameters>]

Get-BEJobHistory -AgentServer <BEAgentServer[]> [[-Name] <String[]>] [-JobStatus {Unknown | Canceled | Completed | SucceededWithExceptions | OnHold | Error | Missed | Recovered | Resumed | Succeeded | ThresholdAbort | Dispatched | DispatchFailed | InvalidSchedule | InvalidTimeWindow | NotInTimeWindow | Queued | Disabled | Active | Ready | Scheduled | Superseded | ToBeScheduled | Linked | RuleBlocked}] [-JobType {Unknown | Backup | Restore | Verify | Catalog | Utility | Report | Duplicate | TestRun | ResourceDiscovery | CopyJob | Install | ConvertToVirtual | RecoverVM | RemoveVM | ValidateVM}] [-FromLastJobRun <SwitchParameter>] [-FromStartTime <DateTime>] [-ToStartTime <DateTime>] [<CommonParameters>]

Get-BEJobHistory [-Id] <Guid[]> [-FromLastJobRun <SwitchParameter>] [-ToStartTime <DateTime>] [-FromStartTime <DateTime>] [<CommonParameters>]

Get-BEJobHistory -InputObject <BEJobHistory[]> [-FromLastJobRun <SwitchParameter>] [-ToStartTime <DateTime>] [-FromStartTime <DateTime>] [<CommonParameters>]
Description

Backup Exec のジョブ履歴を取得します。

パラメータを指定しない場合、Get-BEJobHistory はすべての Backup Exec ジョブ履歴を取得します。 ジョブ履歴名またはジョブ履歴 ID (Guid) を使用してジョブ履歴を指定することも、パイプラインを通じて Backup Exec ジョブ履歴オブジェクトを Get-BEJobHistory に渡すこともできます。

Parameters

-FromStartTime <DateTime>

DateTime オブジェクトを指定して、開始時刻が指定した DateTime より後のジョブ履歴をフィルタ処理します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ToStartTime <DateTime>

DateTime オブジェクトを指定して、開始時刻が指定した DateTime より前のジョブ履歴をフィルタ処理します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FromLastJobRun <SwitchParameter>

ジョブの最近の実行からジョブ履歴を返します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Job <BEJob[]>

1 つ以上のジョブオブジェクトを指定して、ジョブ履歴をフィルタ処理します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEJob を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Storage <BEStorage[]>

1 つ以上のストレージオブジェクトを指定して、ジョブ履歴をフィルタ処理します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEStorage を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-AgentServer <BEAgentServer[]>

1 つ以上のエージェントサーバーオブジェクトを指定して、ジョブ履歴をフィルタ処理します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEAgentServer を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

ジョブ履歴名 (ワイルドカードを使用可能) を使用して、1 つ以上のジョブ履歴を指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-JobStatus

1 つ以上のジョブステータスオブジェクトを指定して、ジョブ履歴をフィルタ処理します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEJobStatus を参照してください。

The valid values are:
Unknown
Canceled
Completed
SucceededWithExceptions
OnHold
Error
Missed
Recovered
Resumed
Succeeded
ThresholdAbort
Dispatched
DispatchFailed
InvalidSchedule
InvalidTimeWindow
NotInTimeWindow
Queued
Disabled
Active
Ready
Scheduled
Superseded
ToBeScheduled
Linked
RuleBlocked

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-JobType

1 つ以上のジョブタイプオブジェクトを指定して、ジョブ履歴をフィルタ処理します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEJobType を参照してください。

The valid values are:
Unknown
Backup
Restore
Verify
Catalog
Utility
Report
Duplicate
TestRun
ResourceDiscovery
CopyJob
Install
ConvertToVirtual
RecoverVM
RemoveVM
ValidateVM

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Id <Guid[]>

ジョブ履歴 ID (Guid) を使用して、1 つ以上のジョブ履歴を指定します。 複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEJobHistory[]>

1 つ以上のジョブ履歴オブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEJob

Backup Exec ジョブオブジェクトをパイプ処理して、Get-BEJobHistory によって返されるジョブ履歴をフィルタ処理できます。

BackupExec.Management.CLI.BEAgentServer

Backup Exec エージェントサーバーオブジェクトをパイプ処理して、Get-BEJobHistory によって返されるジョブ履歴をフィルタ処理できます。

System.Guid

Backup Exec ジョブ履歴オブジェクトの ID を含む System.Guid を Get-BEJobHistory にパイプ処理できます。

BackupExec.Management.CLI.BEJobHistory

Backup Exec ジョブ履歴オブジェクトを Get-BEJobHistory にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEJobHistory

Get-BEJobHistory は Backup Exec ジョブ履歴を表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEJobHistory

このコマンドはすべての Backup Exec ジョブ履歴を取得します。

Example 2
C:\PS> Get-BEJob "Job 01" | Get-BEJobHistory

これらのコマンドは「Job 01」という名前の Backup Exec ジョブの Backup Exec ジョブ履歴をすべて取得します。

Example 3
C:\PS> Get-BEAgentServer -Local | Get-BEJobHistory

これらのコマンドはローカル コンピュータの Backup Exec ジョブ履歴をすべて取得します。

Related Links


Get-BEJobLog Help

Get-BEJobLog Cmdlet
Synopsis

Backup Exec のジョブ履歴のジョブログを取得します。

Syntax
Get-BEJobLog [-Path] <String> [[-OutputStyle] {Text | Html}] [<CommonParameters>]

Get-BEJobLog -JobHistory <BEJobHistory> [[-OutputStyle] {Text | Html}] [<CommonParameters>]
Description

Backup Exec のジョブ履歴のジョブログを取得します。

Parameters

-JobHistory <BEJobHistory>

ジョブログを取得するジョブ履歴を指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Path <String>

ジョブ履歴 XML ファイルのパスを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-OutputStyle

目的のジョブログの形式を指定します。

The valid values are:
Text
Html

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEJobHistory

Backup Exec ジョブ履歴オブジェクトを Get-BEJobLog にパイプ処理できます。

Return Value
System.String

Get-BEJobLog はジョブログの内容を表す文字列を返します。

Example

C:\PS> Get-BEJob "Job 01" | Get-BEJobHistory -FromLastJobRun | Get-BEJobLog

これらのコマンドは「Job 01」という名前の Backup Exec ジョブの最後のジョブログを取得します。

Related Links


Get-BELegacyBackupToDiskFolderDevice Help

Get-BELegacyBackupToDiskFolderDevice Cmdlet
Synopsis

Backup Exec のレガシーのディスクへのバックアップフォルダを取得します。

Syntax
Get-BELegacyBackupToDiskFolderDevice [[-Name] <String[]>] [<CommonParameters>]

Get-BELegacyBackupToDiskFolderDevice -BackupExecServer <BEBackupExecServer[]> [[-Name] <String[]>] [<CommonParameters>]

Get-BELegacyBackupToDiskFolderDevice [-Id] <Guid[]> [<CommonParameters>]

Get-BELegacyBackupToDiskFolderDevice -InputObject <BELegacyBackupToDiskFolderDevice[]> [<CommonParameters>]
Description

Backup Exec のレガシーのディスクへのバックアップフォルダを取得します。

パラメータを指定しない場合、Get-BELegacyBackupToDiskFolderDevice はレガシーのディスクへのバックアップフォルダをすべて取得します。 フォルダ名またはフォルダ ID (Guid) を使用して特定のレガシーのディスクへのバックアップフォルダを指定することも、パイプラインを通じてフォルダオブジェクトを Get-BELegacyBackupToDiskFolderDevice に渡すこともできます。

Parameters

-BackupExecServer <BEBackupExecServer[]>

1 つ以上の Backup Exec サーバーオブジェクトを指定して、レガシーのディスクへのバックアップフォルダをフィルタ処理します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEBackupExecServer を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

ディスクへのバックアップフォルダデバイス名 (ワイルドカードを使用可能) を使用して、1 つ以上のレガシーのディスクへのバックアップフォルダデバイスを指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

1 つ以上のレガシーのディスクへのバックアップフォルダデバイス ID (Guid) を指定します。 複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BELegacyBackupToDiskFolderDevice[]>

1 つ以上のレガシーのディスクへのバックアップフォルダデバイスオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトをパイプ処理して、Get-BELegacyBackupToDiskFolderDevice によって返されるレガシーのディスクへのバックアップフォルダデバイスをフィルタ処理できます。

System.Guid

Backup Exec のレガシーのディスクへのバックアップフォルダデバイスオブジェクトの ID を含む System.Guid を Get-BELegacyBackupToDiskFolderDevice にパイプ処理できます。

BackupExec.Management.CLI.BELegacyBackupToDiskFolderDevice

Backup Exec のレガシーのディスクへのバックアップフォルダデバイスオブジェクトを Get-BELegacyBackupToDiskFolderDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BELegacyBackupToDiskFolderDevice

Get-BELegacyBackupToDiskFolderDevice は Backup Exec のレガシーのディスクへのバックアップフォルダデバイスを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BELegacyBackupToDiskFolderDevice

このコマンドはレガシーのディスクへのバックアップフォルダデバイスをすべて取得します。

Example 2
C:\PS> Get-BELegacyBackupToDiskFolderDevice -Name "Device 01"

このコマンドは「Device 01」という名前のレガシーのディスクへのバックアップフォルダデバイスを取得します。

Example 3
C:\PS> Get-BELegacyBackupToDiskFolderDevice -Name "Device*"

このコマンドはワイルドカード「Device*」に一致するレガシーのディスクへのバックアップフォルダデバイスをすべて取得します。

Example 4
C:\PS> Get-BEBackupExecServer -Local | Get-BELegacyBackupToDiskFolderDevice

このコマンドはローカル Backup Exec サーバーに接続されているレガシーのディスクへのバックアップフォルダデバイスをすべて取得します。

Related Link

Get-BEBackupExecServer


Get-BELicenseInformation Help

Get-BELicenseInformation Cmdlet
Synopsis

Backup Exec ライセンスを取得します。

Syntax
Get-BELicenseInformation [-BackupExecServer <BEBackupExecServer>] [[-Name] <String[]>] [<CommonParameters>]
Description

Backup Exec ライセンスを取得します。

パラメータを指定しない場合、Get-BELicenseInformation はすべての Backup Exec ライセンスを取得します。 ライセンス名またはライセンス ID (Guid) を使用してライセンスを指定することも、パイプラインを通じて Backup Exec ライセンスオブジェクトを Get-BELicenseInformation に渡すこともできます。

Backup Exec エディションの詳細を確認するには、Get-BEEditionInformation を使用します。

Parameters

-BackupExecServer <BEBackupExecServer>

1 つ以上の Backup Exec サーバーオブジェクトを指定して、ライセンスをフィルタ処理します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEBackupExecServer を参照してください。

Required | false
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

ライセンス名 (ワイルドカードを使用可能) を使用して、1 つ以上のライセンスを指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupExecServer

Backup Exec ジョブオブジェクトをパイプ処理して、Get-BELicenseInformation によって返されるライセンスをフィルタ処理できます。

Return Value
BackupExec.Management.CLI.BELicenseInformation

Get-BELicenseInformation は Backup Exec ライセンスを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BELicenseInformation

このコマンドはすべてのライセンスオブジェクトを取得します。

Example 2
C:\PS> Get-BELicenseInformation -Name "Agent for Windows"

このコマンドは「Agent for Windows」という名前のライセンスオブジェクトを取得します。

Example 3
C:\PS> Get-BELicenseInformation -Name "*agent*"

このコマンドはワイルドカード「*agent*」に一致するライセンスオブジェクトをすべて取得します。

Related Links


Get-BELogonAccount Help

Get-BELogonAccount Cmdlet
Synopsis

Backup Exec ログオンアカウントを取得します。

Syntax
Get-BELogonAccount [[-Name] <String[]>] [<CommonParameters>]

Get-BELogonAccount [-Id] <Guid[]> [<CommonParameters>]

Get-BELogonAccount -InputObject <BELogonAccount[]> [<CommonParameters>]
Description

Backup Exec ログオンアカウントを取得します。

パラメータを指定しない場合、Get-BELogonAccount はすべての Backup Exec ログオンアカウントを取得します。 アカウント名またはアカウント ID (Guid) を使用してログオンアカウントを指定することも、パイプラインを通じてログオンアカウントオブジェクトを Get-BELogonAccount に渡すこともできます。

Parameters

-Name <String[]>

ログオンアカウント名 (ワイルドカードを使用可能) を使用して、1 つ以上のログオンアカウントを指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

ログオンアカウント ID (Guid) を使用して、1 つ以上のログオンアカウントを指定します。 複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BELogonAccount[]>

1 つ以上のログオンアカウントオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
System.Guid

Backup Exec ログオンアカウントオブジェクトの ID を含む System.Guid を Get-BELogonAccount にパイプ処理できます。

BackupExec.Management.CLI.BELogonAccount

Backup Exec ログオンアカウントオブジェクトを Get-BELogonAccount にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BELogonAccount

Get-BELogonAccount は Backup Exec ログオンアカウントを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BELogonAccount

このコマンドはすべてのログオンアカウントを取得します。

Example 2
C:\PS> Get-BELogonAccount -Name "System Logon Account"

このコマンドは「System Logon Account」という名前のログオンアカウントを取得します。

Example 3
C:\PS> Get-BELogonAccount -Name "*system*"

このコマンドはワイルドカード「*system*」に一致するログオンアカウントをすべて取得します。


Get-BEManagedBackupExecServer Help

Get-BEManagedBackupExecServer Cmdlet
Synopsis

管理対象 Backup Exec サーバーを取得します。

Syntax
Get-BEManagedBackupExecServer [[-Name] <String[]>] [-SendJobHistory {JobCompletion | NeverSend | Scheduled}] [-KeepCatalogsOn {Centralized | Distributed | Replicated}] [-IsPrivateCloudServer <Boolean>] [-SendJobLogDetail {JobCompletion | NeverSend | Scheduled}] [-ConnectionSetting {Custom | Normal | Slow}] [<CommonParameters>]

Get-BEManagedBackupExecServer -ServerInformation <BEServerInformation[]> [[-Name] <String[]>] [-SendJobHistory {JobCompletion | NeverSend | Scheduled}] [-KeepCatalogsOn {Centralized | Distributed | Replicated}] [-IsPrivateCloudServer <Boolean>] [-SendJobLogDetail {JobCompletion | NeverSend | Scheduled}] [-ConnectionSetting {Custom | Normal | Slow}] [<CommonParameters>]

Get-BEManagedBackupExecServer [-Id] <Guid[]> [<CommonParameters>]

Get-BEManagedBackupExecServer -InputObject <BEManagedBackupExecServer[]> [<CommonParameters>]
Description

管理対象 Backup Exec サーバーを取得します。

パラメータを指定しない場合、Get-BEManagedBackupExecServer はすべての管理対象 Backup Exec サーバーを取得します。 サーバー名またはサーバー ID (Guid) を使用して特定の管理対象 Backup Exec サーバーを指定することも、パイプラインを通じて Backup Exec サーバーオブジェクトを Get-BEManagedBackupExecServer に渡すこともできます。

Parameters

-ServerInformation <BEServerInformation[]>

1 つ以上のサーバー情報の値を指定して、管理対象 Backup Exec サーバーをフィルタ処理します。複数の値を指定する場合は、カンマを使用して値を区切ります。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

サーバー名 (ワイルドカードを使用可能) を使用して、1 つ以上の管理対象 Backup Exec サーバーを指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-ConnectionSetting

1 つ以上の接続設定オプションを指定して、管理対象 Backup Exec サーバーをフィルタ処理します。複数の値を指定する場合は、カンマを使用して値を区切ります。

The valid values are:
Custom
Normal
Slow

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SendJobLogDetail

1 つ以上のジョブログ詳細オプションを指定して、管理対象 Backup Exec サーバーをフィルタ処理します。複数の値を指定する場合は、カンマを使用して値を区切ります。

The valid values are:
JobCompletion
NeverSend
Scheduled

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SendJobHistory

1 つ以上のジョブ履歴オプションを指定して、管理対象 Backup Exec サーバーをフィルタ処理します。複数の値を指定する場合は、カンマを使用して値を区切ります。

The valid values are:
JobCompletion
NeverSend
Scheduled

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepCatalogsOn

1 つ以上のカタログオプションを指定して、管理対象 Backup Exec サーバーをフィルタ処理します。複数の値を指定する場合は、カンマを使用して値を区切ります。

The valid values are:
Centralized
Distributed
Replicated

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IsPrivateCloudServer <Boolean>

プライベートクラウドサーバーである管理対象 Backup Exec サーバーをフィルタ処理します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Id <Guid[]>

サーバー ID (Guid) を使用して、1 つ以上の管理対象 Backup Exec サーバーを指定します。 複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEManagedBackupExecServer[]>

1 つ以上の管理対象 Backup Exec サーバーオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEServerInformation

Backup Exec サーバー情報オブジェクトを Get-BEManagedBackupExecServer にパイプ処理できます。

System.Guid

管理対象 Backup Exec サーバーオブジェクトの ID を含む System.Guid を Get-BEManagedBackupExecServer にパイプ処理できます。

BackupExec.Management.CLI.BEManagedBackupExecServer

管理対象 Backup Exec サーバーオブジェクトを Get-BEManagedBackupExecServer にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEManagedBackupExecServer

Get-BEManagedBackupExecServer は、管理対象 Backup Exec サーバーを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEManagedBackupExecServer

このコマンドはすべての管理対象 Backup Exec サーバーを取得します。

Example 2
C:\PS> Get-BEManagedBackupExecServer -Name "MyMms"

このコマンドは「MyMMs」という名前の管理対象 Backup Exec サーバーを取得します。


Get-BEMedia Help

Get-BEMedia Cmdlet
Synopsis

Backup Exec のメディアを取得します。

Syntax
Get-BEMedia [[-Name] <String[]>] [-MediaType {AllMedia | DiskCartridge | TapeCartridge}] [<CommonParameters>]

Get-BEMedia -MediaSet <BEMediaSet[]> [[-Name] <String[]>] [-MediaType {AllMedia | DiskCartridge | TapeCartridge}] [<CommonParameters>]

Get-BEMedia -MediaVault <BEMediaVault[]> [[-Name] <String[]>] [-MediaType {AllMedia | DiskCartridge | TapeCartridge}] [<CommonParameters>]

Get-BEMedia [-Id] <Guid[]> [-MediaType {AllMedia | DiskCartridge | TapeCartridge}] [<CommonParameters>]

Get-BEMedia -InputObject <BEMedia[]> [-MediaType {AllMedia | DiskCartridge | TapeCartridge}] [<CommonParameters>]
Description

Backup Exec のメディアを取得します。

パラメータを指定しない場合、Get-BEMedia はすべての Backup Exec メディアを取得します。 また、メディア名またはメディア ID (Guid) を使用してメディアを指定することも、パイプラインを通じて Backup Exec メディアオブジェクトを Get-BEMedia に渡すこともできます。

Parameters

-MediaType

メディアのタイプを指定します。

The valid values are:
AllMedia
DiskCartridge
TapeCartridge

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MediaSet <BEMediaSet[]>

1 つ以上のメディアセットオブジェクトを指定して、メディアをフィルタ処理します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEMediaSet を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-MediaVault <BEMediaVault[]>

1 つ以上のメディアボルトオブジェクトを指定して、メディアをフィルタ処理します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEMediaVault を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

メディア名 (ワイルドカードを使用可能) を使用して、1 つ以上のメディアを指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

メディア ID (Guid) を使用して、1 つ以上のメディアを指定します。 複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEMedia[]>

1 つ以上のメディアオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEMediaSet

Backup Exec メディアセットオブジェクトをパイプ処理して、Get-BEMedia によって返されるメディアをフィルタ処理できます。

BackupExec.Management.CLI.BEMediaVault

Backup Exec メディアボルトオブジェクトをパイプ処理して、Get-BEMedia によって返されるメディアをフィルタ処理できます。

System.Guid

Backup Exec メディアオブジェクトの ID を含む System.Guid を Get-BEMedia にパイプ処理できます。

BackupExec.Management.CLI.BEMedia

Backup Exec メディアオブジェクトを Get-BEMedia にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEMedia

Get-BEMedia は Backup Exec メディアを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEMedia

このコマンドはすべてのメディアを取得します。

Example 2
C:\PS> Get-BEMedia -Name "Media 01"

このコマンドは「Media 01」という名前のメディアを取得します。

Example 3
C:\PS> Get-BEMedia -MediaType TapeCartridge

このコマンドはすべてのテープカートリッジメディアを取得します。

Example 4
C:\PS> Get-BEMedia -Name "*media*"

このコマンドはワイルドカード「*media*」に一致するメディアをすべて取得します。

Example 5
C:\PS> Get-BEMediaSet -Name "MediaSet 01" | Get-BEMedia

これらのコマンドは「MediaSet 01」という名前のメディアセットに関連付けられているすべてのメディアを取得します。

Example 6
C:\PS> Get-BEMediaVault -Name "MediaVault 01" | Get-BEMedia

これらのコマンドは「MediaVault 01」という名前のメディアボルトに関連付けられているすべてのメディアを取得します。

Related Links


Get-BEMediaSet Help

Get-BEMediaSet Cmdlet
Synopsis

Backup Exec のメディアセットを取得します。

Syntax
Get-BEMediaSet [[-Name] <String[]>] [<CommonParameters>]

Get-BEMediaSet -MediaVault <BEMediaVault[]> [[-Name] <String[]>] [<CommonParameters>]

Get-BEMediaSet [-Id] <Guid[]> [<CommonParameters>]

Get-BEMediaSet -InputObject <BEMediaSet[]> [<CommonParameters>]
Description

Backup Exec のメディアセットを取得します。

パラメータを指定しない場合、Get-BEMediaSet はすべての Backup Exec メディアセットを取得します。 また、メディアセット名またはメディアセット ID (Guid) を使用してメディアセットを指定することも、パイプラインを通じて Backup Exec メディアセットオブジェクトを Get-BEMediaSet に渡すこともできます。

Parameters

-MediaVault <BEMediaVault[]>

1 つ以上のメディアボルトオブジェクトを指定して、メディアセットをフィルタ処理します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEMediaVault を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

メディアセット名 (ワイルドカードを使用可能) を使用して、1 つ以上のメディアセットを指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

メディアセット ID (Guid) を使用して、1 つ以上のメディアセットを指定します。 複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEMediaSet[]>

1 つ以上のメディアセットオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEMediaVault

Backup Exec メディアボルトオブジェクトをパイプ処理して、Get-BEMediaSet によって返されるメディアセットをフィルタ処理できます。

System.Guid

Backup Exec メディアセットオブジェクトの ID を含む System.Guid を Get-BEMediaSet にパイプ処理できます。

BackupExec.Management.CLI.BEMediaSet

Backup Exec メディアセットオブジェクトを Get-BEMediaSet にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEMediaSet

Get-BEMediaSet は Backup Exec メディアセットを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEMediaSet

このコマンドはすべてのメディアセットを取得します。

Example 2
C:\PS> Get-BEMediaSet -Name "MediaSet 01"

このコマンドは「MediaSet 01」という名前のメディアセットを取得します。

Example 3
C:\PS> Get-BEMediaSet -Name "*mediaset*"

このコマンドはワイルドカード「*mediaset*」に一致するメディアセットをすべて取得します。

Related Link

Get-BEMediaVault


Get-BEMediaType Help

Get-BEMediaType Cmdlet
Synopsis

Backup Exec のメディアタイプを取得します。

Syntax
Get-BEMediaType [[-Name] <String[]>] [<CommonParameters>]

Get-BEMediaType -TapeDriveDevice <BETapeDriveDevice> [-WritableMediaType <SwitchParameter>] [-ReadableMediaType <SwitchParameter>] [<CommonParameters>]

Get-BEMediaType [-Id] <Guid[]> [<CommonParameters>]

Get-BEMediaType -InputObject <BEMediaType[]> [<CommonParameters>]
Description

Backup Exec のメディアタイプを取得します。

パラメータを指定しない場合、Get-BEMediaType はすべての Backup Exec メディアタイプを取得します。 また、メディアタイプ名またはメディアタイプ ID (Guid) を使用してメディアタイプを指定することも、パイプラインを通じて Backup Exec メディアタイプオブジェクトを Get-BEMediaType に渡すこともできます。

バーコードルールを設定するために、テープドライブデバイスがサポートするメディアタイプを返す -TapeDriveDevice パラメータを指定できます。 また、-ReadableMediaType パラメータおよび -WritableMediaType パラメータを指定して、テープドライブデバイスが読み書きするように設定されているメディアタイプを取得することもできます。 詳細については、New-BEBarcodeRule および Set-BETapeDriveDevice を参照してください。

Parameters

-TapeDriveDevice <BETapeDriveDevice>

サポートされているメディアタイプを取得するテープドライブデバイスオブジェクトを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-ReadableMediaType <SwitchParameter>

テープドライブデバイスによる読み込みが設定されているメディアタイプを返します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WritableMediaType <SwitchParameter>

テープドライブデバイスによる書き込みが設定されているメディアタイプを返します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String[]>

メディアタイプ名 (ワイルドカードを使用可能) を使用して、1 つ以上のメディアタイプを指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

メディアタイプ ID (Guid) を使用して、1 つ以上のメディアタイプを指定します。 複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEMediaType[]>

1 つ以上のメディアタイプオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BETapeDriveDevice

Backup Exec テープドライブデバイスオブジェクトを Get-BEMediaType にパイプ処理できます。

System.Guid

Backup Exec メディアタイプオブジェクトの ID を含む System.Guid を Get-BEMediaType にパイプ処理できます。

BackupExec.Management.CLI.BEMediaType

Backup Exec メディアタイプオブジェクトを Get-BEMediaType にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEMediaType

Get-BEMediaType は Backup Exec メディアタイプを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEMediaType

このコマンドはすべてのメディアタイプを取得します。

Example 2
C:\PS> Get-BEMediaType -Name "LTO"

このコマンドは「LTO」という名前のメディアタイプを取得します。

Example 3
C:\PS> Get-BEMediaType -Name "*LTO*"

このコマンドはワイルドカード「*LTO*」に一致するメディアタイプをすべて取得します。

Related Links


Get-BEMediaVault Help

Get-BEMediaVault Cmdlet
Synopsis

Backup Exec のメディアボルトを取得します。

Syntax
Get-BEMediaVault [[-Name] <String[]>] [<CommonParameters>]

Get-BEMediaVault [-Id] <Guid[]> [<CommonParameters>]

Get-BEMediaVault -InputObject <BEMediaVault[]> [<CommonParameters>]
Description

Backup Exec のメディアボルトを取得します。

パラメータを指定しない場合、Get-BEMediaVault はすべての Backup Exec メディアボルトを取得します。 また、メディアボルト名またはメディアボルト ID (Guid) を使用してメディアボルトを指定することも、パイプラインを通じて Backup Exec メディアボルトオブジェクトを Get-BEMediaVault に渡すこともできます。

Parameters

-Name <String[]>

メディアボルト名 (ワイルドカードを使用可能) を使用して、1 つ以上のメディアボルトを指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

メディアボルト ID (Guid) を使用して、1 つ以上のメディアボルトを指定します。 複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEMediaVault[]>

1 つ以上のメディアボルトオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
System.Guid

Backup Exec メディアボルトオブジェクトの ID を含む System.Guid を Get-BEMediaVault にパイプ処理できます。

BackupExec.Management.CLI.BEMediaVault

Backup Exec メディアボルトオブジェクトを Get-BEMediaVault にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEMediaVault

Get-BEMediaVault は Backup Exec メディアボルトを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEMediaVault

このコマンドはすべてのメディアボルトを取得します。

Example 2
C:\PS> Get-BEMediaVault -Name "MediaVault 01"

このコマンドは「MediaVault 01」という名前のメディアボルトを取得します。

Example 3
C:\PS> Get-BEMediaVault -Name "*mediavault*"

このコマンドはワイルドカード「*mediavault*」に一致するメディアボルトをすべて取得します。


Get-BENdmpServer Help

Get-BENdmpServer Cmdlet
Synopsis

Backup Exec NDMP サーバーを取得します。

Syntax
Get-BENdmpServer [[-Name] <String[]>] [<CommonParameters>]

Get-BENdmpServer -LogonAccount <BELogonAccount[]> [[-Name] <String[]>] [<CommonParameters>]

Get-BENdmpServer [-Id] <Guid[]> [<CommonParameters>]

Get-BENdmpServer -InputObject <BENdmpServer[]> [<CommonParameters>]
Description

Backup Exec NDMP サーバーを取得します。

パラメータを指定しない場合、Get-BENdmpServer はすべての Backup Exec NDMP サーバーを取得します。サーバー名またはサーバー ID (Guid) を使用して特定の NDMP サーバーを指定することも、パイプラインを通じて Backup Exec NDMP サーバーオブジェクトを Get-BENdmpServer に渡すこともできます。

Parameters

-LogonAccount <BELogonAccount[]>

1 つ以上のログオンアカウントオブジェクトを指定して、NDMP サーバーをフィルタ処理します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BELogonAccount を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

サーバー名 (ワイルドカードを使用可能) を使用して、1 つ以上の NDMP サーバーを指定します。複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

サーバー ID (Guid) を使用して、1 つ以上の NDMP サーバーを指定します。複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BENdmpServer[]>

1 つ以上の NDMP サーバーオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BELogonAccount

Backup Exec ログオンアカウントオブジェクトをパイプ処理することで、Get-BENdmpServer によって返される NDMP サーバーをフィルタ処理できます。

System.Guid

Backup Exec NDMP サーバーオブジェクトの ID を含む System.Guid を Get-BENdmpServer にパイプ処理できます。

BackupExec.Management.CLI.BENdmpServer

Backup Exec NDMP サーバーオブジェクトを Get-BENdmpServer にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BENdmpServer

Get-BENdmpServer は、Backup Exec NDMP サーバーを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BENDMPServer -Name '10.67.101.92'

このコマンドは NDMP サーバーを名前を使用して取得します。

Example 2
C:\PS> $LogonAccount = Get-BELogonAccount -Name Linux
C:\PS> $LogonAccount | Get-BENDMPServer

このコマンドはログオンアカウント「Linux」を使用してすべての NDMP サーバーを取得します。

Related Link

Get-BELogonAccount


Get-BENetworkInterface Help

Get-BENetworkInterface Cmdlet
Synopsis

ローカル Backup Exec サーバーのネットワークインターフェースを取得します。

Syntax
Get-BENetworkInterface [[-Name] <String[]>] [<CommonParameters>]

Get-BENetworkInterface [-Id] <Guid[]> [<CommonParameters>]

Get-BENetworkInterface -InputObject <BENetworkInterface[]> [<CommonParameters>]
Description

ローカル Backup Exec サーバーのネットワークインターフェースを取得します。

パラメータを指定しない場合、Get-BENetworkInterface はすべての Backup Exec ネットワークインターフェースを取得します。ネットワークインターフェース名またはネットワークインターフェース ID (Guid) を使用して特定のネットワークインターフェースを指定することも、パイプラインを通じて Backup Exec ネットワークインターフェースオブジェクトを Get-BENetworkInterface に渡すこともできます。

Get-BENetworkInterface から返されたオブジェクトは、Get-BEBackupDefiniton、Set-BEBackupDefinition、Set-BEbackupJobDefault、および Submit-BEOnetimeBackupJob コマンドの NetworkInterface パラメータを設定するために使用されます。

Parameters

-Name <String[]>

ネットワークインターフェース名（ワイルドカードを使用可能）を使用して、1 つ以上のネットワークインターフェースを指定します。複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

ネットワークインターフェースID（Guid）を使用して、1 つ以上のネットワークインターフェースを指定します。複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BENetworkInterface[]>

1 つ以上のネットワークインターフェースオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
System.Guid

Backup Exec ネットワークインターフェースオブジェクトの ID を含む System.Guid を、パイプを使用して Get-BENetworkInterface に渡すことができます。

BackupExec.Management.CLI.BENetworkInterface

Backup Exec ネットワークインターフェースオブジェクトを、パイプを使用して Get-BENetworkInterface に渡すことができます。

Return Value
BackupExec.Management.CLI.BENetworkInterface

Get-BENetworkInterface は、Backup Exec ネットワークインターフェースを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BENetworkInterface

このコマンドは、ローカル Backup Exec サーバーに接続されているすべてのネットワークインターフェースを取得します。

Example 2
C:\PS> Get-BENetworkInterface -Name "Local Area Connection"

このコマンドは、「Local Area Connection」という名前のネットワークインターフェースを取得します。

Example 3
C:\PS> $networkInterface = Get-BENetworkInterface -Name "Local Area Connection"
C:\PS> Get-BEAgentServer server01 | Submit-BEOnetimeBackupJob -NetworkInterface $networInterface

これらのコマンドは、「Local Area Connection」という名前のネットワークインターフェースを使用して、「server01」という名前のサーバーのワンタイムバックアップジョブをサブミットします。

Related Links


Get-BENotificationConfiguration Help

Get-BENotificationConfiguration Cmdlet
Synopsis

通知構成設定を取得します。

Syntax
Get-BENotificationConfiguration [<CommonParameters>]
Description

テキストおよびメール通知の送信に使用される通知構成設定を取得します。

Parameters

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

このコマンドレットは入力を受け入れません。

Return Value
BackupExec.Management.CLI.BENotificationConfiguration

Get-BENotificationConfiguration は、通知構成設定を表すオブジェクトを返します。

Example

C:\PS> Get-BENotificationConfiguration

このコマンドは現在の通知構成設定を取得します。


Get-BENotificationRecipient Help

Get-BENotificationRecipient Cmdlet
Synopsis

アラートの通知受信者を取得します。

Syntax
Get-BENotificationRecipient [[-Name] <String[]>] [<CommonParameters>]

Get-BENotificationRecipient [-Id] <Guid[]> [<CommonParameters>]

Get-BENotificationRecipient -InputObject <BENotificationRecipient[]> [<CommonParameters>]
Description

アラートの通知受信者を取得します。

Parameters

-Name <String[]>

通知受信者の名前を指定します。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

受信者 ID (Guid) を使用して、1 つ以上の通知受信者を指定します。複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BENotificationRecipient[]>

1 つ以上の受信者オブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BENotificationRecipient

このコマンドレットはパイプラインを通して BENotificationRecipient のオブジェクトを受け入れます。

Return Value
BackupExec.Management.CLI.BENotificationRecipient

Get-BENotificationRecipient は、アラートを送信するための通知受信者を表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BENotificationRecipient

このコマンドはすべての通知受信者を取得します。

Example 2
C:\PS> Get-BENotificationRecipient -Name "John"

このコマンドは指定された名前により通知受信者を取得します。


Get-BENotificationRecipientGroup Help

Get-BENotificationRecipientGroup Cmdlet
Synopsis

アラート通知を送信するように設定されたグループを取得します。

Syntax
Get-BENotificationRecipientGroup [[-Name] <String[]>] [<CommonParameters>]

Get-BENotificationRecipientGroup [-Id] <Guid[]> [<CommonParameters>]

Get-BENotificationRecipientGroup -InputObject <BENotificationRecipientGroup[]> [<CommonParameters>]
Description

アラート通知を送信するように設定されたグループを取得します。

Parameters

-Name <String[]>

受信者グループの名前を指定します。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

受信者グループ ID (Guid) を使用して、1 つ以上の受信者グループを指定します。複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BENotificationRecipientGroup[]>

1 つ以上の受信者オブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BENotificationRecipientGroup

このコマンドレットはパイプラインを通して BENotificationRecipientGroup のオブジェクトを受け入れます。

Return Value
BackupExec.Management.CLI.BENotificationRecipientGroup

Get-BENotificationRecipientGroup は、アラートを送信するための通知受信者のグループを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BENotificationRecipientGroup

このコマンドはアラート通知用に設定されたすべてのグループを取得します。

Example 2
C:\PS> Get-BENotificationRecipientGroup -Name "exampleName"

このコマンドはアラート通知用に設定されたグループを指定された名前により取得します。


Get-BENotificationRecipientObject Help

Get-BENotificationRecipientObject Cmdlet
Synopsis

アラートの通知受信者を取得します。

Syntax
Get-BENotificationRecipientObject [[-Name] <String[]>] [<CommonParameters>]

Get-BENotificationRecipientObject [-Id] <Guid[]> [<CommonParameters>]

Get-BENotificationRecipientObject -InputObject <BENotificationRecipientObject[]> [<CommonParameters>]
Description

アラートの通知受信者を取得します。

Parameters

-Name <String[]>

通知受信者または受信者グループの名前を指定します。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

ID (Guid) を使用して、1 つ以上の通知受信者または受信者グループを指定します。複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BENotificationRecipientObject[]>

1 つ以上の受信者オブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BENotificationRecipient

このコマンドレットはパイプラインを通して BENotificationRecipient のオブジェクトを受け入れます。

BackupExec.Management.CLI.BENotificationRecipientGroup

このコマンドレットはパイプラインを通して BENotificationRecipientGroup のオブジェクトを受け入れます。

Return Values
BackupExec.Management.CLI.BENotificationRecipient

Get-BENotificationRecipient は、アラートを送信するための通知受信者を表すオブジェクトを返します。

BackupExec.Management.CLI.BENotificationRecipientGroup

Get-BENotificationRecipientGroup は、アラートを送信するための通知受信者のグループを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BENotificationRecipientObject

このコマンドはすべての通知受信者または通知受信者グループを取得します。

Example 2
C:\PS> Get-BENotificationRecipientObject -Name "John"

このコマンドは指定された名前により通知受信者または通知受信者グループを取得します。

Related Links


Get-BEOneTimeBackupJob Help

Get-BEOneTimeBackupJob Cmdlet
Synopsis

すべてのワンタイムバックアップジョブを取得します。

Syntax
Get-BEOneTimeBackupJob [[-Name] <String[]>] [<CommonParameters>]

Get-BEOneTimeBackupJob -AgentServer <BEAgentServer[]> [<CommonParameters>]

Get-BEOneTimeBackupJob [-Id] <Guid[]> [<CommonParameters>]

Get-BEOneTimeBackupJob -InputObject <BEOneTimeBackupJob[]> [<CommonParameters>]
Description

すべてのワンタイムバックアップジョブを取得します。

パラメータを指定しない場合、Get-BEOneTimeBackupJob はすべての Backup Exec ワンタイムバックアップジョブを取得します。ジョブ名またはバックアップジョブ ID (Guid) を使用して特定のワンタイムバックアップジョブを指定することも、パイプラインを通じて Backup Exec ワンタイムバックアップジョブオブジェクトを Get-BEOneTimeBackupJob に渡すこともできます。

Parameters

-AgentServer <BEAgentServer[]>

1 つ以上のエージェントサーバーオブジェクトを指定して、ワンタイムバックアップジョブをフィルタ処理します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEAgentServer を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

ジョブ名 (ワイルドカードを使用可能) を使用して、1 つ以上のワンタイムバックアップジョブを指定します。複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

ジョブ ID (Guid) を使用して、1 つ以上のワンタイムバックアップジョブを指定します。 複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEOneTimeBackupJob[]>

1 つ以上の 1 回限りのバックアップオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEAgentServer

Backup Exec エージェントサーバーオブジェクトをパイプ処理することで、Get-BEOneTimeBackupJob によって返されるワンタイムバックアップジョブをフィルタ処理できます。

System.Guid

Backup Exec ワンタイムバックアップジョブオブジェクトの ID を含む System.Guid を Get-BEOneTimeBackupJob にパイプ処理できます。

BackupExec.Management.CLI.BEOneTimeBackupJob

Backup Exec ワンタイムバックアップジョブオブジェクトを Get-BEOneTimeBackupJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEOneTimeBackupJob

Get-BEOneTimeBackupJob は、Backup Exec ワンタイムバックアップジョブを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEOneTimeBackupJob

このコマンドはすべてのワンタイムバックアップジョブを取得します。

Example 2
C:\PS> Get-BEOneTimeBackupJob -Name "Backup 01"

これらのコマンドは「Backup 01」という名前のワンタイムバックアップジョブを取得します。

Example 3
C:\PS> Get-BEOneTimeBackupJob -Name "Backup*"

このコマンドはワイルドカード「Backup*」に一致するすべてのワンタイムバックアップジョブを取得します。

Example 4
C:\PS> Get-BEAgentServer -Local | Get-BEOneTimeBackupJob

これらのコマンドは、ローカルコンピュータのすべてのワンタイムバックアップジョブを取得します。

Example 5
C:\PS> Get-BEOneTimeBackupJob "Backup 01" | Set-BEOneTimeBackupJob -FileSystemSelection D:\*

これらのコマンドは、「Backup 01」という名前のワンタイムバックアップジョブのバックアップ選択項目に D:\* を追加します。

Related Links


Get-BEOpenStorageDevice Help

Get-BEOpenStorageDevice Cmdlet
Synopsis

Backup Exec OpenStorage デバイスを取得します。

Syntax
Get-BEOpenStorageDevice [[-Name] <String[]>] [<CommonParameters>]

Get-BEOpenStorageDevice -BackupExecServer <BEBackupExecServer[]> [[-Name] <String[]>] [<CommonParameters>]

Get-BEOpenStorageDevice -LogonAccount <BELogonAccount[]> [[-Name] <String[]>] [<CommonParameters>]

Get-BEOpenStorageDevice [-Id] <Guid[]> [<CommonParameters>]

Get-BEOpenStorageDevice -InputObject <BEOpenStorageDevice[]> [<CommonParameters>]
Description

Backup Exec OpenStorage デバイスを取得します。

Get-BEOpenStorageDevice は、パラメータなしの場合、Backup Exec OpenStorage デバイスをすべて取得します。 OpenStorage デバイス名または OpenStorage デバイス ID（GUID）を基準に特定の OpenStorage デバイスを指定したり、パイプラインを介して Backup Exec OpenStorage デバイスオブジェクトを Get-BEOpenStorageDevice に渡したりできます。

Parameters

-BackupExecServer <BEBackupExecServer[]>

1 つ以上の Backup Exec サーバーオブジェクトを指定して、OpenStorage デバイスをフィルタ処理します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEBackupExecServer を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-LogonAccount <BELogonAccount[]>

1 つ以上のログオンアカウントオブジェクトを指定して、OpenStorage デバイスをフィルタ処理します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BELogonAccount を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

OpenStorage デバイス名（ワイルドカードを使用可能）を使用して、1 つ以上の OpenStorage デバイスを指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

OpenStorage デバイス ID（GUID）を使用して 1 つ以上の OpenStorage デバイスを指定します。 複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEOpenStorageDevice[]>

1 つ以上の OpenStorage デバイスオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトをパイプ処理して、Get-BEOpenStorageDevice によって返される OpenStorage デバイスをフィルタ処理できます。

BackupExec.Management.CLI.BELogonAccount

Get-BEOpenStorageDevice によって返される OpenStorage デバイスをフィルタ処理する方法として、Backup Exec ログオンアカウントオブジェクトをパイプ処理できます。

System.Guid

Backup Exec OpenStorage デバイスオブジェクトの ID を含む System.Guid を Get-BEOpenStorageDevice にパイプ処理できます。

BackupExec.Management.CLI.BEOpenStorageDevice

Backup Exec OpenStorage デバイスオブジェクトを Get-BEOpenStorageDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEOpenStorageDevice

Get-BEOpenStorageDevice は Backup Exec OpenStorage デバイスを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEOpenStorageDevice

このコマンドはすべての OpenStorage デバイスを取得します。

Example 2
C:\PS> Get-BEOpenStorageDevice -Name "Device 01"

このコマンドは「Device 01」という名前の OpenStorage デバイスを取得します。

Example 3
C:\PS> Get-BEOpenStorageDevice -Name "Device*"

このコマンドはワイルドカード「Device*」に一致する OpenStorage デバイスをすべて取得します。

Example 4
C:\PS> Get-BEBackupExecServer -Local | Get-BEOpenStorageDevice

このコマンドはローカル Backup Exec サーバーに接続されている OpenStorage デバイスをすべて取得します。

Related Links


Get-BEOpenStorageLogicalStorageUnit Help

Get-BEOpenStorageLogicalStorageUnit Cmdlet
Synopsis

OpenStorage サーバーの論理ストレージユニットを取得します。

Syntax
Get-BEOpenStorageLogicalStorageUnit [-BackupExecServer <BEBackupExecServer>] -LogonAccount <BELogonAccount> -ServerType <String> -HostServer <String> [<CommonParameters>]
Description

OpenStorage サーバーの論理ストレージユニットを取得します。

Get-BEOpenStorageLogicalStorageUnit によって返される値は、New-BEOpenStorageDevice コマンドと New-BECloudStorageDevice コマンドの ServerType パラメータの値として使用できます。

Parameters

-HostServer <String>

OpenStorage サーバーの完全修飾名を指定します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ServerType <String>

OpenStorage サーバーの種類を指定します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LogonAccount <BELogonAccount>

OpenStorage サーバーの Backup Exec ログオンアカウントを指定します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

OpenStorage サーバータイプを登録する Backup Exec サーバーを指定します。

Required | false
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトを Get-BEOpenStorageLogicalStorageUnit にパイプ処理できます。

Return Value
System.String

OpenStorage サーバーの論理ストレージユニット。

Examples

Example 1

C:\PS> Get-BEOpenStorageLogicalStorageUnit -HostServer "amazon:amazon.com" -ServerType "S3" -LogonAccount "amazoncred"

このコマンドは、ログオンアカウント「amazoncred」を使用して、「amazon:amazon.com」というホストサーバーから Amazon 標準ストレージティアタイプの論理ストレージユニットを取得します。

Example 2
C:\PS> Get-BEOpenStorageLogicalStorageUnit -HostServer "amazon:amazon-ia.com" -ServerType "S3" -LogonAccount "amazoniacred"

このコマンドは、ログオンアカウント「amazoniacred」を使用して、「amazon:amazon-ia.com」というホストサーバーから Amazon の低頻度アクセスストレージティアタイプの論理ストレージユニットを取得します。

Related Links


Get-BEOpenStorageServerType Help

Get-BEOpenStorageServerType Cmdlet
Synopsis

Backup Exec サーバーにインストールされている登録済みの OpenStorage サーバーの種類を取得します。

Syntax
Get-BEOpenStorageServerType [-BackupExecServer <BEBackupExecServer>] [<CommonParameters>]
Description

Backup Exec サーバーにインストールされている登録済みの OpenStorage サーバーの種類を取得します。

Get-BEOpenStorageServerType によって返される値は、New-BEOpenStorageDevice コマンドの ServerType パラメータの値として使用できます。

Parameters

-BackupExecServer <BEBackupExecServer>

OpenStorage サーバーの種類の取得元となる Backup Exec サーバーを指定します。

Required | false
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトを Get-BEOpenStorageServerType にパイプ処理できます。

Return Value
System.String

登録済みの OpenStorage サーバーの種類。

Example

C:\PS> Get-BEOpenStorageServerType

このコマンドはローカル Backup Exec サーバーで登録済みのすべての OpenStorage サーバーの種類を取得します。

Related Link

New-BEOpenStorageDevice


Get-BEPreferredServerGroup Help

Get-BEPreferredServerGroup Cmdlet
Synopsis

Backup Exec 優先サーバー設定を取得します。

Syntax
Get-BEPreferredServerGroup [[-Name] <String[]>] [<CommonParameters>]

Get-BEPreferredServerGroup [-Id] <Guid[]> [<CommonParameters>]

Get-BEPreferredServerGroup -InputObject <BEPreferredServerGroup[]> [<CommonParameters>]
Description

Backup Exec 優先サーバー設定を取得します。 パラメータを指定しない場合、Get-BEPreferredServerGroup はすべての Backup Exec 優先サーバー設定を取得します。優先サーバーグループ名または優先サーバーグループ ID (Guid) を使用して特定の優先サーバーグループを指定することも、パイプラインを通じて Backup Exec 優先サーバーグループオブジェクトを Get-BEPreferredServerGroup に渡すこともできます。

Parameters

-Name <String[]>

優先サーバーグループ名 (ワイルドカードを使用可能) を使用して、1 つ以上の優先サーバー設定を指定します。複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

優先サーバーグループ ID (Guid) を使用して、1 つ以上の優先サーバー設定を指定します。複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEPreferredServerGroup[]>

1 つ以上の優先サーバーグループオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
System.Guid

Backup Exec 優先サーバーグループオブジェクトの ID を含む System.Guid を Get-BEPreferredServerGroup にパイプ処理できます。

BackupExec.Management.CLI.BEPreferredServerGroup

Backup Exec 優先サーバーグループオブジェクトを Get-BEPreferredServerGroup にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEPreferredServerGroup

Get-BEPreferredServerGroup は、Backup Exec 優先サーバー設定を表すオブジェクトを返します。

Example

C:\PS> Get-BEPreferredServerGroup "ExchangeDag1"

このコマンドは「ExchangeDag1」という名前の Backup Exec 優先サーバー設定を取得します。


Get-BERemoteMediaAgentForLinux Help

Get-BERemoteMediaAgentForLinux Cmdlet
Synopsis

Backup Exec Remote Media Agent for Linux サーバーを取得します。

Syntax
Get-BERemoteMediaAgentForLinux [[-Name] <String[]>] [<CommonParameters>]

Get-BERemoteMediaAgentForLinux -LogonAccount <BELogonAccount[]> [[-Name] <String[]>] [<CommonParameters>]

Get-BERemoteMediaAgentForLinux [-Id] <Guid[]> [<CommonParameters>]

Get-BERemoteMediaAgentForLinux -InputObject <BERemoteMediaAgentForLinux[]> [<CommonParameters>]
Description

Backup Exec Remote Media Agent for Linux サーバーを取得します。

パラメータを指定しない場合、 Get-BERemoteMediaAgentForLinux はすべての Backup Exec Remote Media Agent for Linux サーバーを取得します。Linux サーバー名または Linux サーバー ID (Guid) を使用して特定の Remote Media Agent for Linux サーバーを指定することも、パイプラインを通じて Backup Exec Remote Media Agent for Linux サーバーオブジェクトを Get-BERemoteMediaAgentForLinux に渡すこともできます。

Parameters

-LogonAccount <BELogonAccount[]>

1 つ以上のログオンアカウントオブジェクトを指定して、Remote Media Agent for Linux をフィルタ処理します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BELogonAccount を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

サーバー名 (ワイルドカードを使用可能) を使用して、1 つ以上の Remote Media Agent for Linux サーバーを指定します。複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

サーバー ID (Guid) を使用して、1 つ以上の Remote Media Agent for Linux サーバーを指定します。複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BERemoteMediaAgentForLinux[]>

1 つ以上の Remote Media Agent for Linux サーバーオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BELogonAccount

Backup Exec ログオンアカウントオブジェクトをパイプ処理することで、Get-BERemoteMediaAgentForLinux によって返される Remote Media Agent for Linux サーバーをフィルタ処理できます。

System.Guid

Backup Exec Remote Media Agent for Linux サーバーオブジェクトの ID を含む System.Guid を Get-BERemoteMediaAgentForLinux にパイプ処理できます。

BackupExec.Management.CLI.BERemoteMediaAgentForLinux

Backup Exec Remote Media Agent for Linux サーバーオブジェクトを Get-BERemoteMediaAgentForLinux にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BERemoteMediaAgentForLinux

Get-BERemoteMediaAgentForLinux は、Backup Exec Remote Media Agent for Linux を表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BERemoteMediaAgentForLinux -Name '10.67.101.92'

このコマンドは Remote Media Agent for Linux サーバーを名前を使用して取得します。

Example 2
C:\PS> $LogonAccount = Get-BELogonAccount -Name Linux
C:\PS> $LogonAccount | Get-BERemoteMediaAgentForLinux

このコマンドはログオンアカウント「Linux」を使用してすべての Remote Media Agent for Linux サーバーを取得します。

Related Link

Get-BELogonAccount


Get-BEReport Help

Get-BEReport Cmdlet
Synopsis

Backup Exec のレポートを取得します。

Syntax
Get-BEReport [[-Name] <String[]>] [-Category {Alerts | Configuration | Jobs | Media | Devices | Custom}] [<CommonParameters>]

Get-BEReport [-Id] <Guid[]> [<CommonParameters>]

Get-BEReport -InputObject <BEReport[]> [<CommonParameters>]
Description

Backup Exec のレポートを取得します。

パラメータを指定しない場合、Get-BEReport はすべての Backup Exec のレポートを取得します。レポート名またはレポート ID（Guid）を使用して特定のレポートを指定することも、パイプラインを通じて Backup Exec レポートオブジェクトを Get-BEReport に渡すこともできます。

レポートは、Get-BEReport の結果を Invoke-BEReport に渡すことで実行されます

Parameters

-Category

1 つ以上のカテゴリ値を指定して、レポートをフィルタ処理します。複数の値を指定する場合は、カンマを使用して値を区切ります。

The valid values are:
Alerts
Configuration
Jobs
Media
Devices
Custom

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String[]>

レポート名（ワイルドカードを使用可能）を使用して、1 つ以上のレポートを指定します。複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

レポートID（Guid）を使用して、1 つ以上のレポートを指定します。複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEReport[]>

1 つ以上のレポートオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
System.Guid

Backup Exec レポートオブジェクトの ID を含む System.Guid を、パイプを使用して Get-BEReport に渡すことができます。

BackupExec.Management.CLI.BEReport

Backup Exec レポートオブジェクトを、パイプを使用して Get-BEReport に渡すことができます。

Return Value
BackupExec.Management.CLI.BEReport

Get-BEReport は、Backup Exec レポートを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEReport

このコマンドは、すべての Backup Exec レポートオブジェクトを取得します。

Example 2
C:\PS> Get-BEReport -Name "Audit Log"

このコマンドは、「Audit Log」という名前の Backup Exec レポートオブジェクトを取得します。

Example 3
C:\PS> Get-BEReport -Name "Media*"

このコマンドは、ワイルドカード「Media*」に一致するすべての Backup Exec レポートオブジェクトを取得します。

Example 4
C:\PS> Get-BEReport "Audit Log" | Invoke-BEReport -Path .\AuditLog.html | Invoke-Item

これらのコマンドは、「Audit Log」という名前のレポートを実行し、デフォルトの Web ブラウザでレポートを表示します。

Related Link

Invoke-BEReport


Get-BERoboticLibraryDevice Help

Get-BERoboticLibraryDevice Cmdlet
Synopsis

Backup Exec のロボットライブラリデバイスを取得します。

Syntax
Get-BERoboticLibraryDevice [[-Name] <String[]>] [<CommonParameters>]

Get-BERoboticLibraryDevice -BackupExecServer <BEBackupExecServer[]> [[-Name] <String[]>] [<CommonParameters>]

Get-BERoboticLibraryDevice [-Id] <Guid[]> [<CommonParameters>]

Get-BERoboticLibraryDevice -InputObject <BERoboticLibraryDevice[]> [<CommonParameters>]
Description

Backup Exec のロボットライブラリデバイスを取得します。

パラメータを指定しない場合、Get-BERoboticLibraryDevice はすべての Backup Exec ロボットライブラリデバイスを取得します。 また、ロボットライブラリデバイス名またはロボットライブラリデバイス ID (Guid) を使用してロボットライブラリデバイスを指定することも、パイプラインを通じて Backup Exec ロボットライブラリデバイスオブジェクトを Get-BERoboticLibraryDevice に渡すこともできます。

Parameters

-BackupExecServer <BEBackupExecServer[]>

1 つ以上の Backup Exec サーバーオブジェクトを指定して、ロボットライブラリデバイスをフィルタ処理します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEBackupExecServer を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

ロボットライブラリデバイス名 (ワイルドカードを使用可能) を使用して、1 つ以上のロボットライブラリデバイスを指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

ロボットライブラリデバイス ID (Guid) を使用して、1 つ以上のロボットライブラリデバイスを指定します。 複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BERoboticLibraryDevice[]>

1 つ以上のロボットライブラリデバイスオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトをパイプ処理して、Get-BERoboticLibraryDevice によって返されるロボットライブラリデバイスをフィルタ処理できます。

System.Guid

Backup Exec ロボットライブラリデバイスオブジェクトの ID を含む System.Guid を Get-BERoboticLibraryDevice にパイプ処理できます。

BackupExec.Management.CLI.BERoboticLibraryDevice

Backup Exec ロボットライブラリデバイスオブジェクトを Get-BERoboticLibraryDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BERoboticLibraryDevice

Get-BERoboticLibraryDevice は Backup Exec ロボットライブラリデバイスを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BERoboticLibraryDevice

このコマンドはすべてのロボットライブラリデバイスを取得します。

Example 2
C:\PS> Get-BERoboticLibraryDevice -Name "Device 01"

このコマンドは「Device 01」という名前のロボットライブラリデバイスを取得します。

Example 3
C:\PS> Get-BERoboticLibraryDevice -Name "Device*"

このコマンドはワイルドカード「Device*」に一致するロボットライブラリデバイスをすべて取得します。

Example 4
C:\PS> Get-BEBackupExecServer -Local | Get-BERoboticLibraryDevice

このコマンドはローカル Backup Exec サーバーに接続されているロボットライブラリデバイスをすべて取得します。

Related Link

Get-BEBackupExecServer


Get-BERoboticLibraryPartition Help

Get-BERoboticLibraryPartition Cmdlet
Synopsis

Backup Exec ロボットライブラリパーティションを取得します。

Syntax
Get-BERoboticLibraryPartition -RoboticLibraryDevice <BERoboticLibraryDevice[]> [[-Name] <String[]>] [-LastSlotNumber <Int32[]>] [-FirstSlotNumber <Int32[]>] [<CommonParameters>]

Get-BERoboticLibraryPartition [-Id] <Guid[]> [<CommonParameters>]

Get-BERoboticLibraryPartition -InputObject <BERoboticLibraryPartition[]> [<CommonParameters>]
Description

Backup Exec ロボットライブラリパーティションを取得します。

Parameters

-RoboticLibraryDevice <BERoboticLibraryDevice[]>

1 つ以上のロボットライブラリデバイス値を指定して、ロボットライブラリパーティションをフィルタ処理します。複数の値を指定する場合は、カンマを使用して値を区切ります。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-FirstSlotNumber <Int32[]>

1 つ以上の最初のスロット番号値を指定して、ロボットライブラリパーティションをフィルタ処理します。複数の値を指定する場合は、カンマを使用して値を区切ります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LastSlotNumber <Int32[]>

1 つ以上の最後のスロット番号値を指定して、ロボットライブラリパーティションをフィルタ処理します。複数の値を指定する場合は、カンマを使用して値を区切ります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String[]>

ロボットライブラリパーティション名（ワイルドカードを使用可能）を使用して、1 つ以上のロボットライブラリパーティションを指定します。複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

ロボットライブラリパーティション ID（Guid）を使用して、1 つ以上のロボットライブラリパーティションを指定します。複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BERoboticLibraryPartition[]>

1 つ以上のロボットライブラリパーティションオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BERoboticLibraryDevice

Backup Exec ロボットライブラリオブジェクトを、パイプを使用して Get-BERoboticLibraryPartition に渡すことができます。

System.Guid

Backup Exec ロボットライブラリパーティションオブジェクトの ID を含む System.Guid を、パイプを使用して Get-BERoboticLibraryPartition に渡すことができます。

BackupExec.Management.CLI.BERoboticLibraryPartition

Backup Exec ロボットライブラリパーティションオブジェクトを、パイプを使用して Get-BERoboticLibraryPartition に渡すことができます。

Return Value
BackupExec.Management.CLI.BERoboticLibraryPartition

Get-BERoboticLibraryPartition は、Backup Exec ロボットライブラリパーティションを表すオブジェクトを返します。

Example

C:\PS> Get-BERoboticLibraryDevice "Device 01" | Get-BERoboticLibraryPartition

これらのコマンドは、「Device 01」という名前のロボットライブラリデバイスのパーティションを取得します。

Related Link

Get-BERoboticLibraryDevice


Get-BERoboticLibrarySlot Help

Get-BERoboticLibrarySlot Cmdlet
Synopsis

Backup Exec ロボットライブラリスロットを取得します。

Syntax
Get-BERoboticLibrarySlot -RoboticLibraryDevice <BERoboticLibraryDevice[]> [[-Name] <String[]>] [-Barcode <String[]>] [-IsCleaningSlot <Boolean>] [-SlotNumber <Int32[]>] [<CommonParameters>]

Get-BERoboticLibrarySlot -Media <BEMedia[]> [[-Name] <String[]>] [-Barcode <String[]>] [-IsCleaningSlot <Boolean>] [-SlotNumber <Int32[]>] [<CommonParameters>]

Get-BERoboticLibrarySlot -RoboticLibraryPartition <BERoboticLibraryPartition[]> [[-Name] <String[]>] [-Barcode <String[]>] [-IsCleaningSlot <Boolean>] [-SlotNumber <Int32[]>] [<CommonParameters>]

Get-BERoboticLibrarySlot [-Id] <Guid[]> [<CommonParameters>]

Get-BERoboticLibrarySlot -InputObject <BERoboticLibrarySlot[]> [<CommonParameters>]
Description

Backup Exec ロボットライブラリスロットを取得します。

Parameters

-RoboticLibraryDevice <BERoboticLibraryDevice[]>

1 つ以上のロボットライブラリデバイス値を指定して、ロボットライブラリスロットをフィルタ処理します。複数の値を指定する場合は、カンマを使用して値を区切ります。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Media <BEMedia[]>

1 つ以上のメディアオブジェクトを指定して、ロボットライブラリスロットをフィルタ処理します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEMedia を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibraryPartition <BERoboticLibraryPartition[]>

1 つ以上のロボットライブラリパーティションオブジェクトを指定して、ロボットライブラリスロットをフィルタ処理します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BERoboticLibraryPartition を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

ロボットライブラリスロット名（ワイルドカードを使用可能）を使用して、1 つ以上のロボットライブラリスロットを指定します。複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-SlotNumber <Int32[]>

1 つ以上のスロット番号値を指定して、ロボットライブラリスロットをフィルタ処理します。複数の値を指定する場合は、カンマを使用して値を区切ります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Barcode <String[]>

1 つ以上のバーコード値を指定して、ロボットライブラリスロットをフィルタ処理します。複数の値を指定する場合は、カンマを使用して値を区切ります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IsCleaningSlot <Boolean>

1 つ以上のクリーニングスロット値を指定して、ロボットライブラリスロットをフィルタ処理します。複数の値を指定する場合は、カンマを使用して値を区切ります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Id <Guid[]>

ロボットライブラリスロット ID（Guid）を使用して、1 つ以上のロボットライブラリスロットを指定します。複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BERoboticLibrarySlot[]>

1 つ以上のロボットライブラリスロットオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BERoboticLibraryDevice

Backup Exec ロボットライブラリオブジェクトを、パイプを使用して Get-BERoboticLibrarySlot に渡すことができます。

BackupExec.Management.CLI.BEMedia

Backup Exec メディアオブジェクトは、Get-BERoboticLibrarySlot によって返されるロボットライブラリスロットをフィルタ処理するための手段としてパイプ処理できます。

BackupExec.Management.CLI.BERoboticLibraryPartition

Backup Exec ロボットライブラリパーティションオブジェクトは、Get-BERoboticLibrarySlot によって返されるロボットライブラリスロットをフィルタ処理するための手段としてパイプ処理できます。

System.Guid

Backup Exec ロボットライブラリスロットオブジェクトの ID を含む System.Guid を、パイプを使用して Get-BERoboticLibrarySlot に渡すことができます。

BackupExec.Management.CLI.BERoboticLibrarySlot

Backup Exec ロボットライブラリスロットオブジェクトを、パイプを使用して Get-BERoboticLibrarySlot に渡すことができます。

Return Value
BackupExec.Management.CLI.BERoboticLibrarySlot

Get-BERoboticLibrarySlot は、Backup Exec ロボットライブラリスロットを表すオブジェクトを返します。

Example

C:\PS> Get-BERoboticLibraryDevice "Device 01" | Get-BERoboticLibrarySlot

これらのコマンドは、「Device 01」という名前のロボットライブラリデバイスのスロットを取得します。

Related Links


Get-BEScanUtilityJob Help

Get-BEScanUtilityJob Cmdlet
Synopsis

Backup Exec スキャン操作ジョブを取得します。

Syntax
Get-BEScanUtilityJob [[-Name] <String[]>] [-Status {Unknown | Canceled | Completed | SucceededWithExceptions | OnHold | Error | Missed | Recovered | Resumed | Succeeded | ThresholdAbort | Dispatched | DispatchFailed | InvalidSchedule | InvalidTimeWindow | NotInTimeWindow | Queued | Disabled | Active | Ready | Scheduled | Superseded | ToBeScheduled | Linked | RuleBlocked}] [-IsActive <Boolean>] [<CommonParameters>]

Get-BEScanUtilityJob -Storage <BEStorage[]> [[-Name] <String[]>] [-Status {Unknown | Canceled | Completed | SucceededWithExceptions | OnHold | Error | Missed | Recovered | Resumed | Succeeded | ThresholdAbort | Dispatched | DispatchFailed | InvalidSchedule | InvalidTimeWindow | NotInTimeWindow | Queued | Disabled | Active | Ready | Scheduled | Superseded | ToBeScheduled | Linked | RuleBlocked}] [-IsActive <Boolean>] [<CommonParameters>]

Get-BEScanUtilityJob [-Id] <Guid[]> [<CommonParameters>]

Get-BEScanUtilityJob -InputObject <BEScanUtilityJob[]> [<CommonParameters>]
Description

Backup Exec のスキャン操作ジョブを取得します。

パラメータを指定しない場合、Get-BEScanUtilityJob はすべての Backup Exec スキャン操作ジョブを取得します。 ジョブ名またはジョブ ID (Guid) を使用して特定のスキャン操作ジョブを指定することも、パイプラインを通じてジョブオブジェクトを Get-BEScanUtilityJob に渡すこともできます。

Parameters

-Storage <BEStorage[]>

1 つまたは複数のストレージオブジェクトを指定して、スキャン操作ジョブをフィルタ処理します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEStorage を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

ジョブ名を使用して、1 つ以上のスキャン操作ジョブを指定します (ワイルドカードを使用可能)。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-IsActive <Boolean>

1 つ以上のアクティブな値を指定して、ジョブをフィルタ処理します。複数の値を指定する場合は、カンマを使用して値を区切ります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Status

1 つ以上の状態値を指定して、ジョブをフィルタ処理します。 複数の値を指定する場合は、カンマを使用して値を区切ります。

The valid values are:
Unknown
Canceled
Completed
SucceededWithExceptions
OnHold
Error
Missed
Recovered
Resumed
Succeeded
ThresholdAbort
Dispatched
DispatchFailed
InvalidSchedule
InvalidTimeWindow
NotInTimeWindow
Queued
Disabled
Active
Ready
Scheduled
Superseded
ToBeScheduled
Linked
RuleBlocked

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Id <Guid[]>

ジョブ ID (Guid) を使用して、1 つ以上のスキャン操作ジョブを指定します。複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEScanUtilityJob[]>

1 つ以上のスキャン操作ジョブオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEStorage

Backup Exec ストレージオブジェクトを Get-BEScanUtilityJob にパイプ処理できます。

BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトを Get-BEScanUtilityJob にパイプ処理できます。

System.Guid

Backup Exec スキャン操作ジョブオブジェクトの ID を含む System.Guid を Get-BEScanUtilityJob にパイプ処理できます。

BackupExec.Management.CLI.BEScanUtilityJob

Backup Exec スキャン操作ジョブオブジェクトを Get-BEScanUtilityJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEScanUtilityJob

Get-BEScanUtilityJob は、Backup Exec スキャン操作ジョブを表すオブジェクトを返します。

Example

C:\PS> Get-BEScanUtilityJob -Name "ScanUtilityJob"

このコマンドは「ScanUtilityJob」という名前のスキャン操作ジョブを取得します。

Related Links


Get-BEServerInformation Help

Get-BEServerInformation Cmdlet
Synopsis

Backup Exec サーバー情報を取得します。

Syntax
Get-BEServerInformation [[-Name] <String[]>] [<CommonParameters>]

Get-BEServerInformation -BackupExecServer <BEBackupExecServer[]> [[-Name] <String[]>] [<CommonParameters>]

Get-BEServerInformation [-Id] <Guid[]> [<CommonParameters>]

Get-BEServerInformation -InputObject <BEServerInformation[]> [<CommonParameters>]
Description

Backup Exec サーバー情報を取得します。

パラメータを指定しない場合、Get-BEServerInformation はすべての Backup Exec サーバー情報を取得します。 サーバー名またはサーバー ID (Guid) を使用して特定のサーバーを指定することも、パイプラインを通じてサーバーオブジェクトを Get-BEServerInformation に渡すこともできます。

Parameters

-BackupExecServer <BEBackupExecServer[]>

1 つ以上の Backup Exec サーバーを指定して、サーバー情報をフィルタ処理します。 複数の値を指定する場合は、カンマを使用して値を区切ります。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

サーバー名 (ワイルドカードを使用可能) を使用して、1 つ以上のサーバーを指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

サーバー ID (Guid) を使用して、1 つ以上のサーバーを指定します。 複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEServerInformation[]>

1 つ以上のサーバーオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
System.Guid

Backup Exec サーバー情報オブジェクトの ID を含む System.Guid を Get-BEServerInformation にパイプ処理できます。

BackupExec.Management.CLI.BEServerInformation

Backup Exec サーバー情報オブジェクトを Get-BEServerInformation にパイプ処理できます。

BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトを Get-BEServerInformation にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEServerInformation

Get-BEServerInformation は Backup Exec サーバー情報を表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEServerInformation

このコマンドは Backup Exec のすべてのサーバーのサーバー情報を取得します。

Example 2
C:\PS> $BackupExecServer = Get-BEBackupExecServer -Name "MyCas"
C:\PS> Get-BeServerInformation -BackupExecServer $BackupExecServer

このコマンドは「MyCas」という名前のサーバーのサーバー情報を取得します。

Related Link

Get-BEBackupExecServer


Get-BEService Help

Get-BEService Cmdlet
Synopsis

Backup Exec サービスを取得します。

Syntax
Get-BEService [[-Name] <String[]>] [-All <SwitchParameter>] [-ServiceType {Core | Deduplication}] [-ComputerName <String[]>] [<CommonParameters>]

Get-BEService -DisplayName <String[]> [-ServiceType {Core | Deduplication}] [-All <SwitchParameter>] [-ComputerName <String[]>] [<CommonParameters>]
Description

Backup Exec サービスを取得します。

デフォルトでは、Get-BEService は中心的な Backup Exec サービスを取り込みます。 -ServiceType パラメータを使用して他の Backup Exec サービスタイプを指定できます。

Backup Exec サービスを起動、停止、再起動するには、Start-BEService、Stop-BEService、Restart-BEService を参照してください。

Parameters

-ComputerName <String[]>

指定したコンピュータで実行されているサービスを取得します。デフォルトはローカルコンピュータです。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String[]>

サービスの名前を指定します。 ワイルドカードを使用できます。

Required | false
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | true

-DisplayName <String[]>

サービスの表示名を指定します。 ワイルドカードを使用できます。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ServiceType

Backup Exec サービスのタイプを指定します。

The valid values are:
Core
Deduplication

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-All <SwitchParameter>

Backup Exec のすべてのサービスを再起動します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

Get-BEService にサービス名をパイプ処理できます。

Return Value
System.ServiceProcess.ServiceController

Get-BEService はコンピュータの Backup Exec サービスを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEService

すべての中心的な Backup Exec サービスを取得します。

Example 2
C:\PS> Get-BEService "BackupExecRPCService"

「BackupExecRPCService」というサービス名の Backup Exec サービスを取得します。

Example 3
C:\PS> Get-BEService -DisplayName "Backup Exec Server"

「Backup Exec Server」という表示名の Backup Exec サービスを取得します。

Example 4
C:\PS> Get-BEService -ServiceType Deduplication

すべての Backup Exec 重複排除用サービスを取得します。 Backup Exec Deduplication Option がインストールされていない場合、Get-BEService はエラーを返します。

Related Links


Get-BEStandaloneBackupExecServer Help

Get-BEStandaloneBackupExecServer Cmdlet
Synopsis

スタンドアロン Backup Exec サービスを取得します。

Syntax
Get-BEStandaloneBackupExecServer [[-Name] <String[]>] [-IsPrivateCloudServer <Boolean>] [<CommonParameters>]

Get-BEStandaloneBackupExecServer -ServerInformation <BEServerInformation[]> [[-Name] <String[]>] [-IsPrivateCloudServer <Boolean>] [<CommonParameters>]

Get-BEStandaloneBackupExecServer [-Id] <Guid[]> [<CommonParameters>]

Get-BEStandaloneBackupExecServer -InputObject <BEStandaloneBackupExecServer[]> [<CommonParameters>]
Description

スタンドアロン Backup Exec サービスを取得します。

パラメータを指定しない場合、Get-BEStandaloneBackupExecServer はすべてのスタンドアロン Backup Exec サーバーを取得します。 サーバー名またはサーバー ID (Guid) を使用して特定のスタンドアロン Backup Exec サーバーを指定することも、パイプラインを通じてサーバーオブジェクトを Get-BEStandaloneBackupExecServer に渡すこともできます。

Parameters

-ServerInformation <BEServerInformation[]>

スタンドアロン Backup Exec サーバーのフィルタ処理を行うために、1 つ以上のサーバー情報の値を指定します。 複数の値を指定する場合は、カンマを使用して値を区切ります。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

サーバー名 (ワイルドカードを使用可能) を使用して、1 つ以上のスタンドアロン Backup Exec サーバーを指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-IsPrivateCloudServer <Boolean>

スタンドアロンの Backup Exec サーバーがプライベートクラウドサーバーであるかどうかを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Id <Guid[]>

サーバー ID (Guid) を使用して、1 つ以上のスタンドアロン Backup Exec サーバーを指定します。 複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEStandaloneBackupExecServer[]>

1 つ以上のサーバーオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEServerInformation

Backup Exec サーバー情報オブジェクトを Get-BEStandaloneBackupExecServer にパイプ処理できます。

System.Guid

Backup Exec スタンドアロン Backup Exec サーバーオブジェクトの ID を含む System.Guid を Get-BEStandaloneBackupExecServer にパイプ処理できます。

BackupExec.Management.CLI.BEStandaloneBackupExecServer

Backup Exec スタンドアロン Backup Exec サーバーオブジェクトを Get-BEStandaloneBackupExecServer にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEStandaloneBackupExecServer

Get-BEStandaloneBackupExecServer は、Backup Exec スタンドアロン Backup Exec サーバーを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEStandaloneBackupExecServer

すべてのスタンドアロン Backup Exec サーバーを取得します。

Example 2
C:\PS> Get-BEStandaloneBackupExecServer -Name "MyServer"

このコマンドは「MyServer」という名前のスタンドアロン Backup Exec サーバーを取得します。


Get-BEStorage Help

Get-BEStorage Cmdlet
Synopsis

Backup Exec のストレージを取得します。

Syntax
Get-BEStorage [[-Name] <String[]>] [<CommonParameters>]

Get-BEStorage -BackupExecServer <BEBackupExecServer[]> [[-Name] <String[]>] [<CommonParameters>]

Get-BEStorage [-Id] <Guid[]> [<CommonParameters>]

Get-BEStorage -InputObject <BEStorage[]> [<CommonParameters>]
Description

Backup Exec のストレージを取得します。

パラメータを指定しない場合、Get-BEStorage はすべての Backup Exec ストレージを取得します。 また、ストレージ名またはストレージ ID (Guid) を使用してストレージを指定することも、パイプラインを通じて Backup Exec ストレージオブジェクトを Get-BEStorage に渡すこともできます。

Parameters

-BackupExecServer <BEBackupExecServer[]>

1 つ以上の Backup Exec サーバーオブジェクトを指定して、ストレージをフィルタ処理します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEBackupExecServer を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

ストレージ名 (ワイルドカードを使用可能) を使用して、1 つ以上のストレージを指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

ストレージ ID (Guid) を使用して 1 つ以上のストレージを指定します。 複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEStorage[]>

1 つ以上のストレージオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトをパイプ処理して、Get-BEStorage によって返されるストレージをフィルタ処理できます。

System.Guid

Backup Exec ストレージオブジェクトの ID を含む System.Guid を Get-BEStorage にパイプ処理できます。

BackupExec.Management.CLI.BEStorage

Backup Exec ストレージオブジェクトを Get-BEStorage にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEStorage

Get-BEStorage は Backup Exec ストレージを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEStorage

このコマンドはすべての Backup Exec ストレージオブジェクトを取得します。

Example 2
C:\PS> Get-BEStorage -Name "Device 01"

このコマンドは「Device 01」という名前の Backup Exec ストレージオブジェクトを取得します。

Example 3
C:\PS> Get-BEStorage -Name "Device*"

このコマンドはワイルドカード「Device*」に一致する Backup Exec ストレージオブジェクトをすべて取得します。

Example 4
C:\PS> Get-BEBackupExecServer -Local | Get-BEStorage

このコマンドはローカル Backup Exec サーバーに接続された Backup Exec ストレージオブジェクトをすべて取得します。

Related Link

Get-BEBackupExecServer


Get-BEStorageArrayConfigurationVirtualDiskCount Help

Get-BEStorageArrayConfigurationVirtualDiskCount Cmdlet
Synopsis

物理ディスクのセットで構成されたストレージアレイに設定可能な仮想ディスクの最小数と最大数を取得します。

Syntax
Get-BEStorageArrayConfigurationVirtualDiskCount -StorageArrayPhysicalDisk <BEStorageArrayPhysicalDisk[]> -StorageArrayDevice <BEStorageArrayDevice> -BackupExecServer <BEBackupExecServer> [<CommonParameters>]
Description

物理ディスクのセットで構成されたストレージアレイに設定可能な仮想ディスクの最小数と最大数を取得します。

Parameters

-StorageArrayPhysicalDisk <BEStorageArrayPhysicalDisk[]>

ストレージアレイの構成に使用するストレージアレイの物理ディスクを指定します。Get-BEStorageArrayPhysicalDisk を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

ストレージを設定する Backup Exec サーバーを指定します。Get-BEBackupExecServer を参照してください。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-StorageArrayDevice <BEStorageArrayDevice>

仮想ディスクを作成するストレージアレイを指定します。Get-BEStorageArrayDevice を参照してください。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEStorageArrayPhysicalDisk

ストレージアレイ物理ディスクオブジェクトをパイプ処理して、Get-BEStorageArrayPhysicalDisk によって返されるストレージアレイを更新することができます。

Return Value
BackupExec.Management.CLI.BEStorageArrayConfigurationVirtualDiskCount

ストレージアレイに作成可能な仮想ディスクの最小数と最大数を指定するオブジェクトを返します。

Example

C:\PS> $BackupExecServer | Get-BackupExecServer -Local
C:\PS> $StorageArray = Get-BEStorageArrayDevice -Name "MyStorageArray"
C:\PS> Get-BEStorageArrayPhysicalDisk -StorageArrayDevice $StorageArray -IsConfigured $False | Get-BEStorageArrayConfigurationVirtualDiskCount -BackupExecServer $BackupExecServer -StorageArray $StorageArray

これらのコマンドは「MyStorageArray」という名前のストレージアレイに設定可能な仮想ディスクの最小数と最大数を取得します。

Related Links


Get-BEStorageArrayConfigurationVirtualDiskMaxGigabyteSize Help

Get-BEStorageArrayConfigurationVirtualDiskMaxGigabyteSize Cmdlet
Synopsis

ストレージアレイに設定可能な仮想ディスクの最大サイズをギガバイト単位で取得します。

Syntax
Get-BEStorageArrayConfigurationVirtualDiskMaxGigabyteSize -StorageArrayDevice <BEStorageArrayDevice[]> -BackupExecServer <BEBackupExecServer> [<CommonParameters>]
Description

ストレージアレイに設定可能な仮想ディスクの最大サイズをギガバイト単位で取得します。

Parameters

-StorageArrayDevice <BEStorageArrayDevice[]>

ディスクサイズを取得するストレージアレイを指定します。Get-BEStorageArrayDevice を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

ストレージを設定する Backup Exec サーバーを指定します。Get-BEBackupExecServer を参照してください。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEStorageArrayDevice

ストレージアレイオブジェクトをパイプ処理して、Get-BEStorageArrayDevice によって返される設定可能な最大値をギガバイト単位で取得できます。

Return Value
System.UInt32

ストレージアレイデバイスを設定するときに使用可能な最大容量をギガバイト単位で返します。

Example

C:\PS> $BackupExecServer = Get-BackupExecServer -Local
C:\PS> "MyStorageArray" | Get-BEStorageArrayDevice | Get-BEStorageArrayConfigurationVirtualDiskMaxGigabyteSize -BackupExecServer $BackupExecServer

これらのコマンドは「MyStorageArray」という名前のストレージアレイに設定可能な仮想ディスクの最大サイズをギガバイト単位で取得します。

Related Links


Get-BEStorageArrayDevice Help

Get-BEStorageArrayDevice Cmdlet
Synopsis

Backup Exec のストレージアレイデバイスを取得します。

Syntax
Get-BEStorageArrayDevice [[-Name] <String[]>] [<CommonParameters>]

Get-BEStorageArrayDevice -BackupExecServer <BEBackupExecServer[]> [[-Name] <String[]>] [<CommonParameters>]

Get-BEStorageArrayDevice [-Id] <Guid[]> [<CommonParameters>]

Get-BEStorageArrayDevice -InputObject <BEStorageArrayDevice[]> [<CommonParameters>]
Description

Backup Exec のストレージアレイデバイスを取得します。

パラメータを指定しない場合、Get-BEStorageArrayDevice はすべての Backup Exec ストレージアレイデバイスを取得します。 また、ストレージアレイデバイス名またはストレージアレイデバイス ID (Guid) を使用してストレージアレイデバイスを指定することも、パイプラインを通じて Backup Exec ストレージアレイデバイスオブジェクトを Get-BEStorageArrayDevice に渡すこともできます。

Parameters

-BackupExecServer <BEBackupExecServer[]>

1 つ以上の Backup Exec サーバーオブジェクトを指定して、ストレージアレイデバイスをフィルタ処理します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEBackupExecServer を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

ストレージアレイデバイス名 (ワイルドカードを使用可能) を使用して、1 つ以上のストレージアレイデバイスを指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

ストレージアレイデバイス ID (Guid) を使用して、1 つ以上のストレージアレイデバイスを指定します。 複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEStorageArrayDevice[]>

1 つ以上のストレージアレイデバイスオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトをパイプ処理して、Get-BEStorageArrayDevice によって返されるストレージアレイデバイスをフィルタ処理できます。

System.Guid

Backup Exec ストレージアレイデバイスオブジェクトの ID を含む System.Guid を Get-BEStorageArrayDevice にパイプ処理できます。

BackupExec.Management.CLI.BEStorageArrayDevice

Backup Exec ストレージアレイデバイスオブジェクトを Get-BEStorageArrayDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEStorageArrayDevice

Get-BEStorageArrayDevice は Backup Exec ストレージアレイデバイスを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEStorageArrayDevice

このコマンドはすべてのストレージアレイデバイスを取得します。

Example 2
C:\PS> Get-BEStorageArrayDevice -Name "Device 01"

このコマンドは「Device 01」という名前のストレージアレイデバイスを取得します。

Example 3
C:\PS> Get-BEStorageArrayDevice -Name "Device*"

このコマンドはワイルドカード「Device*」に一致するストレージアレイデバイスをすべて取得します。

Example 4
C:\PS> Get-BEBackupExecServer -Local | Get-BEStorageArrayDevice

このコマンドはローカル Backup Exec サーバーに接続されているストレージアレイデバイスをすべて取得します。

Related Link

Get-BEBackupExecServer


Get-BEStorageArrayPhysicalDisk Help

Get-BEStorageArrayPhysicalDisk Cmdlet
Synopsis

ストレージアレイの物理ディスクを取得します。

Syntax
Get-BEStorageArrayPhysicalDisk -StorageArrayDevice <BEStorageArrayDevice[]> [[-Name] <String[]>] [-IsConfigured <Boolean>] [-Slot <UInt32[]>] [-Enclosure <UInt32[]>] [<CommonParameters>]

Get-BEStorageArrayPhysicalDisk [-Id] <Guid[]> [<CommonParameters>]

Get-BEStorageArrayPhysicalDisk -InputObject <BEStorageArrayPhysicalDisk[]> [<CommonParameters>]
Description

ストレージアレイの物理ディスクを取得します。

Get-BEStorageArrayPhysicalDisk から返されるオブジェクトを使って、Submit-BEStorageArrayDeviceConfigurationJob コマンドの DiskGroupPhysicalDisk パラメータ、AddHotSparePhysicalDisk パラメータ、RemoveHotSparePhysicalDisk パラメータを設定できます。

Parameters

-StorageArrayDevice <BEStorageArrayDevice[]>

1 つ以上のストレージアレイ値を指定して、ストレージアレイの物理ディスクをフィルタ処理します。複数の値を指定する場合は、カンマを使用して値を区切ります。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Enclosure <UInt32[]>

1 つ以上のエンクロージャ値を指定して、ストレージアレイの物理ディスクをフィルタ処理します。複数の値を指定する場合は、カンマを使用して値を区切ります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Slot <UInt32[]>

1 つ以上のスロット値を指定して、ストレージアレイの物理ディスクをフィルタ処理します。複数の値を指定する場合は、カンマを使用して値を区切ります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IsConfigured <Boolean>

1 つ以上の設定値を指定して、ストレージアレイの物理ディスクをフィルタ処理します。複数の値を指定する場合は、カンマを使用して値を区切ります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String[]>

ストレージアレイの物理ディスク名（ワイルドカードを使用可能）を使用して、1 つ以上のストレージアレイの物理ディスクを指定します。複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

ストレージアレイの物理ディスクID（Guid）を使用して、1 つ以上のストレージアレイの物理ディスクを指定します。複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEStorageArrayPhysicalDisk[]>

1 つ以上のストレージアレイ物理ディスクオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEStorageArrayDevice

Backup Exec ストレージアレイオブジェクトを、パイプを使用して Get-BEStorageArrayPhysicalDisk に渡すことができます。

System.Guid

Backup Exec ストレージアレイ物理ディスクオブジェクトの ID を含む System.Guid を、パイプを使用して Get-BEStorageArrayPhysicalDisk に渡すことができます。

BackupExec.Management.CLI.BEStorageArrayPhysicalDisk

Backup Exec ストレージアレイ物理ディスクオブジェクトを、パイプを使用して Get-BEStorageArrayPhysicalDisk に渡すことができます。

Return Value
BackupExec.Management.CLI.BEStorageArrayPhysicalDisk

Get-BEStorageArrayPhysicalDisk は、Backup Exec ストレージアレイ物理ディスクを表すオブジェクトを返します。

Examples

Example 1

C:\PS> $physicalDisks = Get-BEStorageArrayDevice -Name "Device 0001" | Get-BEStorageArrayPhysicalDisk -IsConfigured $false
C:\PS> Get-BEStorageArrayDevice -Name "Device 0001" | Submit-BEStorageArrayDeviceConfigurationJob -ConfigureHotSparesOnly -AddHotSparePhysicalDisk $physicalDisks

これらのコマンドは、「Device 0001」という名前のストレージアレイで未設定物理ディスクをすべてホットスペアとして設定します。

Example 2
C:\PS> $physicalDisks = Get-BEStorageArrayDevice -Name "Device 0001" | Get-BEStorageArrayPhysicalDisk -IsConfigured $false
C:\PS> Get-BEStorageArrayDevice -Name "Device 0001" | Submit-BEStorageArrayDeviceConfigurationJob -DiskGroupPhysicalDisk $physicalDisks

これらのコマンドは、「Device 0001」という名前のストレージアレイで未設定物理ディスクをすべてホットスペアとして設定します。

Related Links


Get-BEStorageDevice Help

Get-BEStorageDevice Cmdlet
Synopsis

Backup Exec のストレージデバイスを取得します。

Syntax
Get-BEStorageDevice [[-Name] <String[]>] [<CommonParameters>]

Get-BEStorageDevice -BackupExecServer <BEBackupExecServer[]> [[-Name] <String[]>] [<CommonParameters>]

Get-BEStorageDevice [-Id] <Guid[]> [<CommonParameters>]

Get-BEStorageDevice -InputObject <BEStorageDevice[]> [<CommonParameters>]
Description

Backup Exec のストレージデバイスを取得します。

パラメータを指定しない場合、Get-BEStorageDevice はすべての Backup Exec ストレージデバイスを取得します。 また、ストレージデバイス名またはストレージデバイス ID (Guid) を使用してストレージデバイスを指定することも、パイプラインを通じて Backup Exec ストレージデバイスオブジェクトを Get-BEStorageDevice に渡すこともできます。

Parameters

-BackupExecServer <BEBackupExecServer[]>

1 つ以上の Backup Exec サーバーオブジェクトを指定して、ストレージデバイスをフィルタ処理します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEBackupExecServer を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

ストレージデバイス名 (ワイルドカードを使用可能) を使用して、1 つ以上のストレージデバイスを指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

ストレージデバイス ID (Guid) を使用して、1 つ以上のストレージデバイスを指定します。 複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEStorageDevice[]>

1 つ以上のストレージデバイスオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトをパイプ処理して、Get-BEStorageDevice によって返されるストレージデバイスをフィルタ処理できます。

System.Guid

Backup Exec ストレージデバイスオブジェクトの ID を含む System.Guid を Get-BEStorageDevice にパイプ処理できます。

BackupExec.Management.CLI.BEStorageDevice

Backup Exec ストレージデバイスオブジェクトを Get-BEStorageDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEStorageDevice

Get-BEStorageDevice は Backup Exec ストレージデバイスを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEStorageDevice

このコマンドはすべてのストレージデバイスを取得します。

Example 2
C:\PS> Get-BEStorageDevice -Name "Device 01"

このコマンドは「Device 01」という名前のストレージデバイスを取得します。

Example 3
C:\PS> Get-BEStorageDevice -Name "Device*"

このコマンドはワイルドカード「Device*」に一致するストレージデバイスをすべて取得します。

Example 4
C:\PS> Get-BEBackupExecServer -Local | Get-BEStorageDevice

このコマンドはローカル Backup Exec サーバーに接続されているストレージデバイスをすべて取得します。

Related Link

Get-BEBackupExecServer


Get-BEStorageDevicePool Help

Get-BEStorageDevicePool Cmdlet
Synopsis

Backup Exec のストレージデバイスプールを取得します。

Syntax
Get-BEStorageDevicePool [[-Name] <String[]>] [<CommonParameters>]

Get-BEStorageDevicePool [-Id] <Guid[]> [<CommonParameters>]

Get-BEStorageDevicePool -InputObject <BEStorageDevicePool[]> [<CommonParameters>]
Description

Backup Exec のストレージデバイスプールを取得します。

パラメータを指定しない場合、Get-BEStorageDevicePool はすべての Backup Exec ストレージデバイスプールを取得します。 また、ストレージデバイスプール名またはストレージデバイスプール ID (Guid) を使用してストレージデバイスプールを指定することも、パイプラインを通じて Backup Exec ストレージデバイスプールオブジェクトを Get-BEStorageDevicePool に渡すこともできます。

Parameters

-Name <String[]>

ストレージデバイスプール名 (ワイルドカードを使用可能) を使用して、1 つ以上のストレージデバイスプールを指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

ストレージデバイスプール ID (Guid) を使用して、1 つ以上のストレージデバイスプールを指定します。 複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEStorageDevicePool[]>

1 つ以上のストレージデバイスプールオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
System.Guid

Backup Exec ストレージデバイスプールオブジェクトの ID を含む System.Guid を Get-BEStorageDevicePool にパイプ処理できます。

BackupExec.Management.CLI.BEStorageDevicePool

Backup Exec ストレージデバイスプールオブジェクトを Get-BEStorageDevicePool にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEStorageDevicePool

Get-BEStorageDevicePool は Backup Exec ストレージデバイスプールを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEStorageDevicePool

このコマンドはすべてのストレージデバイスプールを取得します。

Example 2
C:\PS> Get-BEStorageDevicePool -Name "Any disk storage"

このコマンドは「Any disk storage」という名前のストレージデバイスプールを取得します。

Example 3
C:\PS> Get-BEStorageDevicePool -Name "*pool*"

このコマンドはワイルドカード「*pool*」に一致するストレージデバイスプールをすべて取得します。


Get-BESyntheticBackupDefinition Help

Get-BESyntheticBackupDefinition Cmdlet
Synopsis

Backup Exec の合成バックアップ定義を取得します。

Syntax
Get-BESyntheticBackupDefinition [[-Name] <String[]>] [<CommonParameters>]

Get-BESyntheticBackupDefinition -AgentServer <BEAgentServer[]> [<CommonParameters>]

Get-BESyntheticBackupDefinition [-Id] <Guid[]> [<CommonParameters>]

Get-BESyntheticBackupDefinition -InputObject <BESyntheticBackupDefinition[]> [<CommonParameters>]
Description

Backup Exec の合成バックアップ定義を取得します。

パラメータを指定しない場合、Get-BESyntheticBackupDefinition はすべての Backup Exec の合成バックアップ定義を取得します。 定義名または定義 ID (Guid) を使用して特定の合成バックアップ定義を指定することも、パイプラインを通じて合成バックアップ定義オブジェクトを Get-BESyntheticBackupDefinition に渡すこともできます。

Parameters

-AgentServer <BEAgentServer[]>

合成バックアップ定義をフィルタ処理するためにの 1 つ以上のエージェントサーバーオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEAgentServer を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

1 つまたは複数の合成バックアップ定義を合成バックアップ定義名で指定します (ワイルドカードを使用可能)。複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

1 つ以上の合成バックアップ定義を合成バックアップ定義 ID (Guid) で指定します。複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BESyntheticBackupDefinition[]>

1 つ以上の合成バックアップ定義オブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEAgentServer

Backup Exec エージェントサーバーオブジェクトをパイプ処理して、Get-BESyntheticBackupDefinition によって返される合成バックアップ定義をフィルタ処理するための手段とすることができます。

System.Guid

Backup Exec 合成バックアップ定義オブジェクトの ID を含む System.Guid を、Get-BESyntheticBackupDefinition にパイプ処理できます。

BackupExec.Management.CLI.BESyntheticBackupDefinition

Backup Exec 合成バックアップ定義オブジェクトを Get-BESyntheticBackupDefinition にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BESyntheticBackupDefinition

Get-BESyntheticBackupDefinition は Backup Exec の合成バックアップ定義を表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BESyntheticBackupDefinition

このコマンドは、すべての合成バックアップ定義を取得します。

Example 2
C:\PS> Get-BESyntheticBackupDefinition -Name "Synthetic Backup Definition 01"

このコマンドは、「Synthetic Backup Definition 01」という名前の合成バックアップ定義を取得します。

Example 3
C:\PS> Get-BESyntheticBackupDefinition -Name "Synthetic*"

このコマンドは、ワイルドカード「Synthetic*」に一致するすべての合成バックアップ定義を取得します。

Example 4
C:\PS> Get-BEAgentServer -Local | Get-BESyntheticBackupDefinition

これらのコマンドは、ローカルコンピュータのすべての合成バックアップ定義を取得します。

Example 5
C:\PS> Get-BESyntheticBackupDefinition "Synthetic Backup Definition 01" | Set-BESyntheticBackupDefinition -FileSystemSelection D:\* | Save-BESyntheticBackupDefinition

これらのコマンドは、「Synthetic Backup Definition 01」という名前の合成バックアップ定義用のバックアップ選択項目に「D:\*」を追加します。

Related Links


Get-BESyntheticBackupJobDefault Help

Get-BESyntheticBackupJobDefault Cmdlet
Synopsis

Backup Exec の合成バックアップジョブのデフォルトを取得します。

Syntax
Get-BESyntheticBackupJobDefault [<CommonParameters>]
Description

Backup Exec の合成バックアップジョブのデフォルトを取得します。

Get-BESyntheticBackupJobDefault を次のコマンドと一緒に使用して、合成バックアップジョブのデフォルトのタスクを変更できます: Set-BESyntheticBackupJobDefault、Set-BESyntheticInitialFullTask、Set-BESyntheticIncrementalTask、Set-BESyntheticFullTask、Add-BEVerifyBackupTask、および Set-BEVerifyBackupTask。

合成バックアップジョブのデフォルトを編集した場合、変更をコミットするには合成バックアップジョブのデフォルトを Save-BESyntheticBackupJobDefault に渡す必要があります。

Parameters

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

このコマンドレットは入力を受け入れません。

Return Value
BackupExec.Management.CLI.BESyntheticBackupJobDefaults

Get-BESyntheticBackupJobDefault は、Backup Exec の合成バックアップジョブのデフォルトを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BESyntheticBackupJobDefault

このコマンドは、合成バックアップジョブのデフォルトを取得します。

Example 2
C:\PS> Get-BESyntheticBackupJobDefault | Set-BESyntheticIncrementalTask -Storage "BackupToDisk" | Save-BESyntheticBackupJobDefault

これらのコマンドは、合成バックアップジョブのデフォルトの増分バックアップタスクで使用されるストレージを変更します。

Related Links


Get-BETapeDriveDevice Help

Get-BETapeDriveDevice Cmdlet
Synopsis

Backup Exec のテープストレージを取得します。

Syntax
Get-BETapeDriveDevice [[-Name] <String[]>] [<CommonParameters>]

Get-BETapeDriveDevice -BackupExecServer <BEBackupExecServer[]> [[-Name] <String[]>] [<CommonParameters>]

Get-BETapeDriveDevice -Media <BEMedia[]> [[-Name] <String[]>] [<CommonParameters>]

Get-BETapeDriveDevice -RoboticLibraryDevice <BERoboticLibraryDevice[]> [[-Name] <String[]>] [<CommonParameters>]

Get-BETapeDriveDevice [-Id] <Guid[]> [<CommonParameters>]

Get-BETapeDriveDevice -InputObject <BETapeDriveDevice[]> [<CommonParameters>]
Description

Backup Exec のテープストレージを取得します。

パラメータを指定しない場合、Get-BETapeDriveDevice はすべての Backup Exec テープストレージを取得します。 また、テープデバイス名またはテープデバイス ID (Guid) を使用してテープデバイスを指定することも、パイプラインを通じて Backup Exec テープデバイスオブジェクトを Get-BETapeDriveDevice に渡すこともできます。

Parameters

-BackupExecServer <BEBackupExecServer[]>

1 つ以上の Backup Exec サーバーオブジェクトを指定して、テープストレージをフィルタ処理します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEBackupExecServer を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Media <BEMedia[]>

1 つ以上の Backup Exec メディアオブジェクトを指定して、テープストレージをフィルタ処理します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEMedia を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibraryDevice <BERoboticLibraryDevice[]>

1 つ以上のロボットライブラリデバイスオブジェクトを指定して、テープストレージをフィルタ処理します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BERoboticLibraryDevice を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

テープドライブデバイス名 (ワイルドカードを使用可能) を使用して、1 つ以上のテープドライブデバイスを指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

テープドライブデバイス ID (Guid) を使用して、1 つ以上のテープドライブデバイスを指定します。 複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BETapeDriveDevice[]>

1 つ以上のテープドライブデバイスオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトをパイプ処理して、Get-BETapeDriveDevice によって返されるテープドライブデバイスをフィルタ処理できます。

BackupExec.Management.CLI.BEMedia

Backup Exec メディアオブジェクトをパイプ処理して、Get-BETapeDriveDevice によって返されるテープドライブデバイスをフィルタ処理できます。

BackupExec.Management.CLI.BERoboticLibraryDevice

Backup Exec ロボットライブラリデバイスオブジェクトをパイプ処理して、Get-BETapeDriveDevice によって返されるテープドライブデバイスをフィルタ処理できます。

System.Guid

Backup Exec テープドライブデバイスオブジェクトの ID を含む System.Guid を Get-BETapeDriveDevice にパイプ処理できます。

BackupExec.Management.CLI.BETapeDriveDevice

Backup Exec テープドライブデバイスオブジェクトを Get-BETapeDriveDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BETapeDriveDevice

Get-BETapeDriveDevice は Backup Exec テープドライブデバイスを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BETapeDriveDevice

このコマンドはすべてのテープドライブデバイスを取得します。

Example 2
C:\PS> Get-BETapeDriveDevice -Name "Device 01"

このコマンドは「Device 01」という名前のテープドライブデバイスを取得します。

Example 3
C:\PS> Get-BETapeDriveDevice -Name "Device*"

このコマンドはワイルドカード「Device*」に一致するテープドライブデバイスをすべて取得します。

Example 4
C:\PS> Get-BEBackupExecServer -Local | Get-BETapeDriveDevice

このコマンドはローカル Backup Exec サーバーに接続されているテープドライブデバイスをすべて取得します。

Related Links


Get-BEUnlockUtilityJob Help

Get-BEUnlockUtilityJob Cmdlet
Synopsis

ロボットライブラリのフロントポータルをロック解除する Backup Exec のジョブを取得します。

Syntax
Get-BEUnlockUtilityJob [[-Name] <String[]>] [-Status {Unknown | Canceled | Completed | SucceededWithExceptions | OnHold | Error | Missed | Recovered | Resumed | Succeeded | ThresholdAbort | Dispatched | DispatchFailed | InvalidSchedule | InvalidTimeWindow | NotInTimeWindow | Queued | Disabled | Active | Ready | Scheduled | Superseded | ToBeScheduled | Linked | RuleBlocked}] [-IsActive <Boolean>] [<CommonParameters>]

Get-BEUnlockUtilityJob -Storage <BEStorage[]> [[-Name] <String[]>] [-Status {Unknown | Canceled | Completed | SucceededWithExceptions | OnHold | Error | Missed | Recovered | Resumed | Succeeded | ThresholdAbort | Dispatched | DispatchFailed | InvalidSchedule | InvalidTimeWindow | NotInTimeWindow | Queued | Disabled | Active | Ready | Scheduled | Superseded | ToBeScheduled | Linked | RuleBlocked}] [-IsActive <Boolean>] [<CommonParameters>]

Get-BEUnlockUtilityJob [-Id] <Guid[]> [<CommonParameters>]

Get-BEUnlockUtilityJob -InputObject <BEUnlockUtilityJob[]> [<CommonParameters>]
Description

ロボットライブラリのフロントポータルをロック解除する Backup Exec のジョブを取得します。

パラメータを指定しない場合、Get-BEUnlockUtilityJob はロボットライブラリのフロントポータルをロック解除する Backup Exec のすべてのジョブを取得します。 ジョブ名またはジョブ ID (Guid) を使用して特定のロック解除ジョブを指定することも、パイプラインを通じて Backup Exec ジョブオブジェクトを Get-BEUnlockUtilityJob に渡すこともできます。

Parameters

-Storage <BEStorage[]>

ロック解除ジョブをフィルタ処理するために 1 つ以上のストレージオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEStorage を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

ジョブ名 (ワイルドカードを使用可能) を使用して、1 つ以上のロック解除ジョブを指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-IsActive <Boolean>

1 つ以上のアクティブな値を指定して、ジョブをフィルタ処理します。複数の値を指定する場合は、カンマを使用して値を区切ります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Status

1 つ以上の状態値を指定して、ジョブをフィルタ処理します。 複数の値を指定する場合は、カンマを使用して値を区切ります。

The valid values are:
Unknown
Canceled
Completed
SucceededWithExceptions
OnHold
Error
Missed
Recovered
Resumed
Succeeded
ThresholdAbort
Dispatched
DispatchFailed
InvalidSchedule
InvalidTimeWindow
NotInTimeWindow
Queued
Disabled
Active
Ready
Scheduled
Superseded
ToBeScheduled
Linked
RuleBlocked

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Id <Guid[]>

ジョブ ID (Guid) を使用して、1 つ以上のロック解除ジョブを指定します。 複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEUnlockUtilityJob[]>

1 つ以上のロック解除ジョブオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEStorage

Backup Exec ストレージオブジェクトを Get-BEUnlockUtilityJob にパイプ処理できます。

BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトを Get-BEUnlockUtilityJob にパイプ処理できます。

System.Guid

Backup Exec ロック解除ジョブオブジェクトの ID を含む System.Guid を Get-BEUnlockUtilityJob にパイプ処理できます。

BackupExec.Management.CLI.BEUnlockUtilityJob

Backup Exec ロック解除ジョブを Get-BEUnlockUtilityJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEUnlockUtilityJob

Get-BEUnlockUtilityJob は、ロボットライブラリのフロントポータルをロック解除する Backup Exec のジョブを表すオブジェクトを返します。

Example

C:\PS> Get-BEUnlockUtilityJob -Name "UnlockUtilityJob"

このコマンドは「UnlockUtilityJob」という名前のロック解除ジョブを取得します。

Related Links


Get-BEVirtualDiskDevice Help

Get-BEVirtualDiskDevice Cmdlet
Synopsis

Backup Exec の仮想ディスクデバイスを取得します。

Syntax
Get-BEVirtualDiskDevice [[-Name] <String[]>] [-Unconfigured <SwitchParameter>] [<CommonParameters>]

Get-BEVirtualDiskDevice -BackupExecServer <BEBackupExecServer[]> [[-Name] <String[]>] [-Unconfigured <SwitchParameter>] [<CommonParameters>]

Get-BEVirtualDiskDevice -StorageArrayDevice <BEStorageArrayDevice[]> [[-Name] <String[]>] [-Unconfigured <SwitchParameter>] [<CommonParameters>]

Get-BEVirtualDiskDevice [-Id] <Guid[]> [-Unconfigured <SwitchParameter>] [<CommonParameters>]

Get-BEVirtualDiskDevice -InputObject <BEVirtualDiskDevice[]> [-Unconfigured <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec の仮想ディスクデバイスを取得します。

パラメータを指定しない場合、Get-BEVirtualDiskDevice はすべての Backup Exec 仮想ディスクデバイスを取得します。 また、仮想ディスクデバイス名または仮想ディスクデバイス ID (Guid) を使用して仮想ディスクデバイスを指定することも、パイプラインを通じて Backup Exec 仮想ディスクデバイスオブジェクトを Get-BEVirtualDiskDevice に渡すこともできます。

デフォルトでは、Get-BEVirtualDiskDevice は未設定の仮想ディスクデバイスを返しません。 未設定の仮想ディスクデバイスを取得するには、-Unconfigured パラメータを指定します。

Parameters

-Unconfigured <SwitchParameter>

未設定の仮想ディスクデバイスを返します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer[]>

1 つ以上の Backup Exec サーバーオブジェクトを指定して、仮想マシンをフィルタ処理します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEBackupExecServer を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-StorageArrayDevice <BEStorageArrayDevice[]>

1 つ以上のストレージアレイオブジェクトを指定して、仮想マシンをフィルタ処理します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEStorageArrayDevice を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

仮想ディスクデバイス名 (ワイルドカードを使用可能) を使用して、1 つ以上の仮想ディスクデバイスを指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

仮想ディスクデバイス ID (Guid) を使用して、1 つ以上の仮想ディスクデバイスを指定します。 複数の ID を指定する場合は、カンマを使用してそれぞれの ID を区切ります。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEVirtualDiskDevice[]>

1 つ以上の仮想ディスクデバイスオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトをパイプ処理して、Get-BEVirtualDiskDevice によって返される仮想ディスクデバイスをフィルタ処理できます。

BackupExec.Management.CLI.BEStorageArrayDevice

Backup Exec ストレージアレイオブジェクトをパイプ処理して、Get-BEVirtualDiskDevice によって返される仮想マシンをフィルタ処理できます。

System.Guid

Backup Exec 仮想ディスクデバイスオブジェクトの ID を含む System.Guid を Get-BEVirtualDiskDevice にパイプ処理できます。

BackupExec.Management.CLI.BEVirtualDiskDevice

Backup Exec 仮想ディスクデバイスオブジェクトを Get-BEVirtualDiskDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEVirtualDiskDevice

Get-BEVirtualDiskDevice は Backup Exec 仮想ディスクデバイスを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEVirtualDiskDevice

このコマンドはすべての仮想ディスクデバイスを取得します。

Example 2
C:\PS> Get-BEVirtualDiskDevice -Name "Device 01"

このコマンドは「Device 01」という名前の仮想ディスクデバイスを取得します。

Example 3
C:\PS> Get-BEVirtualDiskDevice -Name "Device*"

このコマンドはワイルドカード「Device*」に一致する仮想ディスクデバイスをすべて取得します。

Example 4
C:\PS> Get-BEBackupExecServer -Local | Get-BEVirtualDiskDevice

このコマンドはローカル Backup Exec サーバーに接続されている仮想ディスクデバイスをすべて取得します。

Related Links


Get-BEVMwareAgentServerVM Help

Get-BEVMwareAgentServerVM Cmdlet
Synopsis

Backup Exec Agent for Windows の VMWare 仮想マシンを取得します。

Syntax
Get-BEVMwareAgentServerVM -AgentServer <BEAgentServer[]> [-VMwareSelection <BEVMwareSelection>] [-Path <String>] [<CommonParameters>]
Description

Backup Exec Agent for Windows の VMWare 仮想マシンを取得します。

パラメータを指定しない場合、Get-BEVMwareAgentServerVM はすべての Backup Exec Agent for Windows の VMWare 仮想マシンを取得します。仮想マシン名または仮想マシン ID (Guid) を使用して特定の Agent for Windows を指定することも、パイプラインを通じて Backup Exec の仮想マシンオブジェクトを Get-BEVMwareAgentServerVM に渡すこともできます。

Parameters

-AgentServer <BEAgentServer[]>

仮想マシンをフィルタ処理するために 1 つ以上のエージェントサーバーの値を指定します。複数の値を指定する場合は、カンマを使用して値を区切ります。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Path <String>

VMware 仮想リソース名を指定します。使用可能なすべての VMware 仮想リソースを指定するには「*」と指定します。Backup Exec の VMware リソース名は大文字と小文字を区別しません。Backup Exec のユーザーインターフェースに表示されるものと同じ名前を使用し、パスの区切りには \ を使用してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VMwareSelection <BEVMwareSelection>

BEVMwareSelection を指定して VMWare 仮想マシンをフィルタ処理します。 New-BEVMwareSelection を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEAgentServer

Agent for Windows 仮想マシンを取得するために、Backup Exec エージェントサーバーを Get-BEVMwareAgentServerV にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEVMwareAgentServerVM

Get-BEVMwareAgentServerVM は Backup Exec Agent for Windows 仮想マシンを表すオブジェクトを返します。

Examples

Example 1

C:\PS> $AgentServer = Get-BEAgentServer -Name "My-VMWare-Server.MyDomain.com"
C:\PS> $VMWareSelection = New-BEVMWareSelection -Path 'My-VMWare-Server\Production_Servers\'
C:\PS> $AgentServer | Get-BEVMwareAgentServerVM -VMWareSelection $VMWareSelection

これらのコマンドは「My-VMWare-Server」というエージェントサーバーにあるすべての仮想マシンを取得します。

Example 2
C:\PS> $AgentServer = Get-BEAgentServer -Name "My-VMWare-Server.MyDomain.com"
C:\PS> $AgentServer | Get-BEVMwareAgentServerVM -Path 'My-VMWare-Server\Production_Servers\'

これらのコマンドは「My-VMWare-Server」というエージェントサーバーにあるすべての仮想マシンを取得します。

Example 3
C:\PS> $AgentServer | Get-BEVMwareAgentServerVM

これらのコマンドは「My-VMWare-Server」という名前のエージェントサーバーにあるすべての仮想マシンを取得します。

Related Links


Grant-BETrust Help

Grant-BETrust Cmdlet
Synopsis

ローカル Backup Exec サーバーと Backup Exec エージェントを実行しているリモートコンピュータ間の信頼を確立します。

Syntax
Grant-BETrust -AgentServer <BEAgentServer[]> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Grant-BETrust [-ComputerName] <String[]> [-LogonAccount] <BELogonAccount> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

ローカル Backup Exec サーバーと Agent for Windows を実行しているリモートコンピュータ間の信頼を確立します。

Parameters

-AgentServer <BEAgentServer[]>

信頼を確立する 1 つ以上のエージェントサーバーオブジェクトを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-ComputerName <String[]>

信頼を確立する 1 つ以上のコンピュータ名を指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-LogonAccount <BELogonAccount>

リモートコンピュータにログオンするために使用する Backup Exec ログオンアカウントを指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEAgentServer

Backup Exec エージェントサーバーオブジェクトを、パイプを使用して Grant-BETrust に渡すことができます。

System.String

文字列を、パイプを使用して Grant-BETrust に渡すことができます。

Return Values
BackupExec.Management.CLI.BEAgentServer

信頼されている Backup Exec エージェントサーバーオブジェクト。

System.String

信頼されているコンピュータ名。

Examples

Example 1

C:\PS> "server01","server02","server03" | Grant-BETrust -LogonAccount "System Logon Account"

このコマンドは、「server01」、「server02」、「server03」という名前のサーバーとの信頼を確立します。

Example 2
C:\PS> type servers.txt | Grant-BETrust -LogonAccount "System Logon Account"

このコマンドは、テキストファイル内でサーバーの名前との信頼を確立します。


Import-BEItemsToBlock Help

Import-BEItemsToBlock Cmdlet
Synopsis

ブロックされた項目に関する情報を入力ファイルからインポートします。

Syntax
Import-BEItemsToBlock [-CsvFilePath] <String> [-ColumnNameForServerName] <String> [-ColumnNameForBlockedItemPath] <String> [-LogFilePath <String>] [-ResetIfCorrupted <SwitchParameter>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

ブロックされた項目に関する情報を入力ファイルからインポートします。ブロックされた項目をインポートすると Backup Exec で表示されず、リストアできなくなります。ブロックされた項目は保護されるサーバーのいずれかに所属できます。入力 CSV ファイルは複数のサーバーからの項目に関する情報を含むことができます。
ファイルシステムには、NDMP サーバー以外のボリュームまたは共有 (Windows と Linux のファイルサーバー) からブロックされたファイルをインポートできます。
Export-BEItemsBlocked コマンドを実行して、インポートしたブロックされた項目のバックアップを定期的に作成することをお勧めします。

Parameters

-CsvFilePath <String>

CSV ファイル名を含む、CSV ファイルのフルパスを指定します。CSV ファイルはローカルドライブに存在する必要があります。CSV ファイルには、ブロックする項目に関する情報 (サーバー名とフルパス) が含まれている必要があります。CSV ファイルの先頭の行では列名が指定されている必要があります。

Required | true
Position | 1
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-ColumnNameForServerName <String>

ブロックされた項目のサーバー名の情報を含む CSV ファイルの列名を指定します。CSV に存在するサーバー名は、FQDN または Backup Exec の［サーバー］タブで表示される名前である必要があります。ブロックされた項目にその他のサーバー名が指定されている場合、インポートコマンドはその項目を拒否します。

Required | true
Position | 2
Accepts pipeline input | false
Accepts wildcard characters | false

-ColumnNameForBlockedItemPath <String>

ブロックされた項目のフルパスを含む CSV ファイルの列名を指定します。この列では「*」に関連するワイルドカードを使用して、フォルダ内の一連の項目を指定できます。たとえば、H:\Folder1\*.txt または H:\* などです。* はこの列で使用できるエントリです。

Required | true
Position | 3
Accepts pipeline input | false
Accepts wildcard characters | false

-ResetIfCorrupted <SwitchParameter>

リセットモードで Import-BEItemsToBlock コマンドを実行するかどうかを指定します。このコマンドは、破損した内部リストのみリセットします。内部リストはリソースに所属し、ブロックされた項目を含みます。このオプションは、システムログオンアカウントユーザーの所有者にのみ適用できます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LogFilePath <String>

ログファイルが作成される場所を指定します。指定した場所はローカルドライブに存在する必要があります。実行したインポートコマンドに関する情報について詳しくは、ログファイルを参照することをお勧めします。コマンドが成功した場合、ログファイルは生成されません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

このコマンドレットは入力を受け入れません。

Return Value
None

Import-BEItemsToBlock コマンドが成功した場合、出力は生成されません。コマンドが失敗した場合は、適切な例外を返します。不正確な情報が指定された項目は、その操作でインポートされません。これらに関する情報は出力に表示されます。ログファイルには、インポートされなかったブロックされた項目に関する詳細が含まれます。

Examples

Example 1

C:\PS> Import-BEItemsToBlock -CsvFilePath "C:\a.csv" -ColumnNameForServerName "ServerName" -ColumnNameForBlockedItemPath "BlockedFilePath"

ブロックされた項目のサーバー名とフルパスをそれぞれ列ヘッダー「ServerName」と「BlockedFilePath」の列に含む CSV ファイル「C:\a.csv」からブロックされた項目をインポートします。

Example 2
C:\PS> Import-BEItemsToBlock -CsvFilePath "C:\a.csv" -ColumnNameForServerName "ServerName" -ColumnNameForBlockedItemPath "BlockedFilePath" -LogFilePath "C:\log"

ブロックされた項目のサーバー名とフルパスをそれぞれ列ヘッダー「ServerName」と「BlockedFilePath」の列に含む CSV ファイル「C:\a.csv」からブロックされた項目をインポートします。コマンドが警告を返す場合、「C:\log」にログファイルが作成されます。

Related Link

Export-BEItemsBlocked


Import-BELegacyBackupToDiskFolderDevice Help

Import-BELegacyBackupToDiskFolderDevice Cmdlet
Synopsis

Backup Exec のレガシーのディスクへのバックアップフォルダデバイスをインポートします。

Syntax
Import-BELegacyBackupToDiskFolderDevice [-Name] <String> [-Path] <String> [-BufferedReadsEnabled <Boolean>] [-BufferedReadsAutoDetectEnabled <Boolean>] [-BackupExecServer <BEBackupExecServer>] [-Description <String>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のレガシーのディスクへのバックアップフォルダデバイスをインポートします。 Backup Exec に既存のディスクへのバックアップフォルダをインポートし、そこからデータをリストアする必要があります。

Parameters

-BackupExecServer <BEBackupExecServer>

CASO 環境でデバイスを作成する Backup Exec サーバーを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Path <String>

レガシーのディスクへのバックアップフォルダのパスを指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

レガシーのディスクへのバックアップフォルダデバイスの説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BufferedReadsAutoDetectEnabled <Boolean>

読み取りバッファと書き込みバッファに適した設定を自動的に検出するかどうかを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BufferedReadsEnabled <Boolean>

大きなデータブロックの読み取りを有効にします。 このオプションでパフォーマンスが向上する可能性があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

新しいレガシーのディスクへのバックアップフォルダデバイスの名前を指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | true

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

作成する Backup Exec のレガシーのディスクへのバックアップフォルダデバイスオブジェクトの名前を含む文字列を Import-BELegacyBackupToDiskFolderDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BELegacyBackupToDiskFolderDevice

Import-BELegacyBackupToDiskFolderDevice は作成されたレガシーのディスクへのバックアップフォルダデバイスを返します。

Example

C:\PS> Import-BELegacyBackupToDiskFolderDevice -Name "Device 0001" -Path E:\b2d

これらのコマンドは「Device 0001」という名前の新しいレガシーのディスクへのバックアップフォルダとして「E:\b2d」のコンテンツをインポートします。


Initialize-BEUnconfiguredDiskCartridgeDevice Help

Initialize-BEUnconfiguredDiskCartridgeDevice Cmdlet
Synopsis

未設定のディスクカートリッジデバイスを Backup Exec で使用できるように設定します。

Syntax
Initialize-BEUnconfiguredDiskCartridgeDevice -InputObject <BEDiskCartridgeDevice[]> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

未設定のディスクカートリッジデバイスを Backup Exec で使用できるように設定します。

このコマンドを Get-BEDiskCartridgeDevice と -Unconfigured とともに使用して、未設定のディスクカートリッジデバイスを取得します。

ドライブ文字が割り当てられていない未設定のローカルディスクストレージデバイスを設定するためにこのコマンドを使用できます。 ドライブ文字が割り当てられているローカルディスクストレージデバイスを設定するには、New-BEDiskCartridgeDevice を使用します。

Parameters

-InputObject <BEDiskCartridgeDevice[]>

1 つ以上のディスクカートリッジデバイスオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEDiskCartridgeDevice

Backup Exec のディスクカートリッジデバイスオブジェクトを Initialize-BEUnconfiguredDiskCartridgeDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEDiskCartridgeDevice

Initialize-BEUnconfiguredDiskCartridgeDevice は BEDiskCartridgeDevice オブジェクトを出力します。

Example

C:\PS> Get-BEDiskCartridgeDevice -Unconfigured | Select-Object -First 1 | Initialize-BEUnconfiguredDiskCartridgeDevice

これらのコマンドは Get-BEDiskCartridgeDevice から返された最初の未設定のディスクカートリッジデバイスを設定します。

Related Links


Initialize-BEUnconfiguredDiskStorageDevice Help

Initialize-BEUnconfiguredDiskStorageDevice Cmdlet
Synopsis

未設定のディスクストレージデバイスを Backup Exec で使用できるように設定します。

Syntax
Initialize-BEUnconfiguredDiskStorageDevice -InputObject <BEDiskStorageDevice[]> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

未設定のディスクストレージデバイスを Backup Exec で使用できるように設定します。

このコマンドを Get-BEDiskStorageDevice と -Unconfigured スイッチとともに使用して、未設定のディスクストレージデバイスを設定します。

ドライブ文字が割り当てられていない未設定のローカルディスクストレージデバイスを設定するためにこのコマンドを使用できます。 ドライブ文字が割り当てられているローカルディスクストレージデバイスを設定するには、New-BEDiskStorageDevice を使用します。

Parameters

-InputObject <BEDiskStorageDevice[]>

1 つ以上のディスクストレージデバイスオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEDiskStorageDevice

Backup Exec のディスクストレージデバイスオブジェクトを Initialize-BEUnconfiguredDiskStorageDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEDiskStorageDevice

Initialize-BEUnconfiguredBEDiskStorageDevice は Backup Exec のディスクストレージデバイスオブジェクトを出力します。

Example

C:\PS> Get-BEDiskStorageDevice -Unconfigured | Select-Object -First 1 | Initialize-BEUnconfiguredDiskStorageDevice

これらのコマンドは Get-BEDiskStorageDevice から返された最初の未設定のディスクストレージデバイスを設定します。

Related Links


Initialize-BEUnconfiguredVirtualDiskDevice Help

Initialize-BEUnconfiguredVirtualDiskDevice Cmdlet
Synopsis

未設定の仮想ディスクデバイスを Backup Exec で使用できるように設定します。

Syntax
Initialize-BEUnconfiguredVirtualDiskDevice -InputObject <BEVirtualDiskDevice[]> [-MakeDeduplicationDiskStorageDevice <SwitchParameter>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

未設定の仮想ディスクデバイスを Backup Exec で使用できるように設定します。

このコマンドを Get-BEVirtualDiskDevice と -Unconfigured とともに使用して、設定する未設定の仮想ディスクデバイスを取得できます。

Parameters

-MakeDeduplicationDiskStorageDevice <SwitchParameter>

重複排除用ディスクストレージデバイスを作成する場合に指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEVirtualDiskDevice[]>

1 つ以上の仮想ディスクデバイスオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEVirtualDiskDevice

Backup Exec の仮想ディスクデバイスオブジェクトを Initialize-BEUnconfiguredVirtualDiskDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEVirtualDiskDevice

Initialize-BEUnconfiguredVirtualDiskDevice は Backup Exec の仮想ディスクデバイスオブジェクトを出力します。

Example

C:\PS> Get-BEVirtualDiskDevice -Unconfigured | Select-Object -First 1 | Initialize-BEUnconfiguredVirtualDiskDevice

これらのコマンドは Get-BEVirtualDiskDevice から返された最初の未設定の仮想ディスクデバイスを設定します。

Related Link

Get-BEVirtualDiskDevice


Install-BEWindowsAgentServer Help

Install-BEWindowsAgentServer Cmdlet
Synopsis

リモートコンピュータに Backup Exec Agent for Windows をインストールします。

Syntax
Install-BEWindowsAgentServer [-Name] <String[]> [-LogonAccount] <BELogonAccount> [-RestartAutomaticallyIfNecessary <SwitchParameter>] [-UpgradeAutomatically <SwitchParameter>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [-Force <SwitchParameter>] [<CommonParameters>]

Install-BEWindowsAgentServer [-VMwareAgentServerVM] <BEVMwareAgentServerVM[]> [-LogonAccount] <BELogonAccount> [-RestartAutomaticallyIfNecessary <SwitchParameter>] [-UpgradeAutomatically <SwitchParameter>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [-Force <SwitchParameter>] [<CommonParameters>]
Description

リモートコンピュータに Backup Exec Agent for Windows をインストールします。

Parameters

-LogonAccount <BELogonAccount>

リモートコンピュータに接続するために使用するログオンアカウントオブジェクトを指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-UpgradeAutomatically <SwitchParameter>

バックアップサーバーにインストールされた更新と一致させるために、自動的に更新をインストールします。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String[]>

Agent for Windows をインストールするリモートコンピュータの名前を指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | true

-VMwareAgentServerVM <BEVMwareAgentServerVM[]>

Agent for Windows をインストールする VMware 仮想マシンを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RestartAutomaticallyIfNecessary <SwitchParameter>

再起動が必要な場合は、コンピュータを自動的に再起動します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Force <SwitchParameter>

リモートコンピュータに Backup Exec サーバーとの信頼関係を確立することを強制します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
System.String

インストールするコンピュータの名前を含む文字列を Install-BEWindowsAgentServer にパイプ処理できます。

BackupExec.Management.CLI.BEVMwareAgentServerVM

更新する Backup Exec VMware 仮想マシンを Install-BEWindowsAgentServer にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEJob

Install-BEWindowsAgentServer は Backup Exec のインストールジョブを表すオブジェクトを返します。

Examples

Example 1

C:\PS> $AgentServers = @("Raws-01.MyDomain.com","Raws-02.MyDomain.com","Raws-03.MyDomain.com","Raws-04.MyDomain.com","Raws-05.MyDomain.com")
C:\PS> $BELogon = Get-BELogonAccount "MyLogonAccount"
C:\PS> $AgentServers | Install-BEWindowsAgentServer -LogonAccount $BELogon -RestartAutomaticallyIfNecessary -UpgradeAutomatically -Force | Wait-BEJob

これらのコマンドは Agent for Windows を指定されたサーバーにインストールし、更新を適用し、インストール後に再起動が必要な場合はリモートコンピュータを再起動します。

Example 2
C:\PS> $LogonAccount = Get-BElogonAccount -Name "TargetVMLogOn"
C:\PS> $AgentServer = Get-BEAgentServer -Name "My-VMWare-Server.MyDomain.com"
C:\PS> $VMAgentServerVM = $AgentServer | Get-BEVMwareAgentServerVM -Path 'My-VMWare-Server\Production_Servers\TargetVM'
C:\PS> $VMAgentServerVM | Install-BEWindowsAgentServer -LogonAccount $LogonAccount -Confirm:$False | Wait-BEJob

これらのコマンドは「TargetVM」という名前の VMware 仮想マシンに Agent for Windows をインストールします。

Related Links


Invoke-BEReport Help

Invoke-BEReport Cmdlet
Synopsis

Backup Exec レポートを実行します。

Syntax
Invoke-BEReport -Report <BEReport> [-Path] <String> [[-Format] {Html | Pdf | Csv | Xml | Xls}] [-MediaSet <BEMediaSet[]>] [-AuditLogCategory {Alert | AuditLog | DeviceAndMedia | EncryptionKey | ErrorHandlingRules | Job | LogonAccount | ServerConfiguration}] [-AgentServer <BEAgentServer[]>] [-JobStatus {Canceled | SucceededWithExceptions | Error | Missed | Succeeded}] [-MediaVault <BEMediaVault[]>] [-DaysBefore <Int32>] [-BackupExecServer <BEBackupExecServer[]>] [-DaysAfter <Int32>] [-MaximumEventCount <Int32>] [-WithinHour <Int32>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec レポートを実行します。

レポートは、Get-BEReport の結果を Invoke-BEReport に渡すことで実行されます。

レポートに適用されるフィルタパラメータを取得するには、Get-BEReport によって返されるオブジェクトの ValidFilters プロパティを使用します。

Parameters

-Report <BEReport>

実行するレポートを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Path <String>

レポート出力が書きこまれるファイルのパスを指定します。

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-Format

レポート出力形式を指定します。

The valid values are:
Html
Pdf
Csv
Xml
Xls

Required | false
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-DaysBefore <Int32>

本日より何日前のデータから、レポートに表示するデータにフィルタを適用するかを日数で指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DaysAfter <Int32>

本日より何日後のデータから、レポートに表示するデータにフィルタを適用するかを日数で指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WithinHour <Int32>

現時点より何時間前または何時間後から、レポートに表示するデータにフィルタを適用するかを時間数で指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MaximumEventCount <Int32>

レポートに含めるイベント数を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer[]>

Backup Exec サーバーに基づいてレポートをフィルタ処理します。Get-BEBackupExecServer を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AgentServer <BEAgentServer[]>

特定のバックアップサーバーに基づいてレポートをフィルタ処理します。Get-BEAgentServer を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AuditLogCategory

監査ログカテゴリに基づいてレポートをフィルタ処理します。

The valid values are:
Alert
AuditLog
DeviceAndMedia
EncryptionKey
ErrorHandlingRules
Job
LogonAccount
ServerConfiguration

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MediaSet <BEMediaSet[]>

メディアセットに基づいてレポートをフィルタ処理します。Get-BEMediaSet を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MediaVault <BEMediaVault[]>

メディアボルトに基づいてレポートをフィルタ処理します。Get-BEMediaVault を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-JobStatus

1 つ以上のジョブステータス値に基づいてレポートをフィルタ処理します。次のジョブステータス値がサポートされています。キャンセル、エラー、未処理、成功、および SucceededWithExceptions。

The valid values are:
Canceled
SucceededWithExceptions
Error
Missed
Succeeded

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEReport

Backup Exec レポートオブジェクトを、パイプを使用して Invoke-BEReport に渡すことができます。

Return Value
System.IO.FileInfo

Invoke-BEReport は、レポート結果が書き込まれるファイルオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEReport "Audit Log" | Invoke-BEReport -Path .\AuditLog.html | Invoke-Item

これらのコマンドは、「Audit Log」という名前のレポートを実行し、デフォルトの Web ブラウザでレポートを表示します。

Example 2
C:\PS> Get-BEReport "Jobs Summary" | Invoke-BEReport -Path .\JobsSummary.html -JobStatus Error, SucceededWithExceptions | Invoke-Item

これらのコマンドは「Jobs Summary」という名前のレポートを実行し、Error または SucceededWithExceptions ジョブステータスのジョブを含めるようにフィルタ処理され、デフォルトの Web ブラウザにレポートを表示します。

Related Links


Move-BEMediaToMediaSet Help

Move-BEMediaToMediaSet Cmdlet
Synopsis

Backup Exec のメディアセットにメディアを移動します。

Syntax
Move-BEMediaToMediaSet -InputObject <BEMedia[]> -MediaSet <BEMediaSet> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のメディアセットにメディアを移動します。

Parameters

-MediaSet <BEMediaSet>

メディアを移動する Backup Exec メディアセットを指定します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEMedia[]>

1 つ以上のメディアオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEMedia

Backup Exec メディアオブジェクトを Move-BEMediaToMediaSet にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEMedia

Move-BEMediaToMediaSet は移動されたメディアを返します。

Example

C:\PS> Get-BEMedia "Media0001" | Move-BEMediaToMediaSet -MediaSet "MediaSet0001"

「Media0001」という名前のメディアを「MediaSet0001」という名前のメディアセットに移動します。

Related Link

Get-BEMedia


Move-BEMediaToMediaVault Help

Move-BEMediaToMediaVault Cmdlet
Synopsis

Backup Exec のメディアボルトにメディアを移動します。

Syntax
Move-BEMediaToMediaVault -InputObject <BEMedia[]> -MediaVault <BEMediaVault> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のメディアボルトにメディアを移動します。

Parameters

-MediaVault <BEMediaVault>

メディアを移動する Backup Exec メディアボルトを指定します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEMedia[]>

1 つ以上のメディアオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEMedia

Backup Exec メディアオブジェクトを Move-BEMediaToMediaVault にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEMedia

Move-BEMediaToMediaVault は移動されたメディアを返します。

Example

C:\PS> Get-BEMedia "Media0001" | Move-BEMediaToMediaVault -MediaVault "MediaVault0001"

「Media0001」という名前のメディアを「MediaVault0001」という名前のメディアボルトに移動します。

Related Link

Get-BEMedia


New-BEActiveDirectoryApplicationModeSelection Help

New-BEActiveDirectoryApplicationModeSelection Cmdlet
Synopsis

Active Directory Application Mode の選択で、選択オブジェクトを作成します。

Syntax
New-BEActiveDirectoryApplicationModeSelection [[-InstanceName] <String>] [-Exclude <SwitchParameter>] [<CommonParameters>]
Description

Active Directory Application Mode の選択で、選択オブジェクトを作成します。

Parameters

-InstanceName <String>

選択するインスタンスを指定します。すべてのインスタンスを指定するには「*」と入力します。

Required | false
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Exclude <SwitchParameter>

-InstanceName パラメータで指定したユーティリティパーティション選択項目を除外します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

文字列オブジェクトを New-BEActiveDirectoryApplicationModeSelection にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEActiveDirectoryApplicationModeSelection

New-BEActiveDirectoryApplicationModeSelection は BEActiveDirectoryApplicationModeSelection オブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEAgentServer -Local | Submit-BEOnetimeBackupJob -BEActiveDirectoryApplicationModeSelection InstanceName *

このコマンドによってワンタイムバックアップジョブがサブミットされ、Active Directory Application Mode のすべてのインスタンスが Backup Exec サーバー上にバックアップされます。

Example 2
C:\PS> Get-BEAgentServer -Local | Submit-BEOnetimeBackupJob -BEActiveDirectoryApplicationModeSelection -InstanceName "instance1"

このコマンドによってワンタイムバックアップジョブがサブミットされ、「instance1」という名前のActive Directory Application Mode インスタンスが Backup Exec サーバー上にバックアップされます。

Example 3
C:\PS> Get-BEAgentServer -Local | Submit-BEOnetimeBackupJob -BEActiveDirectoryApplicationModeSelection (New-BEActiveDirectoryApplicationModeSelection -InstanceName "instance1" -Exclude)

このコマンドによってワンタイムバックアップジョブがサブミットされ、「instance1」という名前のインスタンスを除くすべてのActive Directory Application Mode インスタンスがバックアップされます。

Related Links


New-BEAgentServerGroup Help

New-BEAgentServerGroup Cmdlet
Synopsis

Backup Exec に新規エージェントサーバーグループを作成します。

Syntax
New-BEAgentServerGroup [-Name] <String> [-Description <String>] [-AgentServerList <BEAgentServer[]>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec に新規エージェントサーバーグループを作成します。

Parameters

-Description <String>

エージェントサーバーグループの説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AgentServerList <BEAgentServer[]>

グループに追加するエージェントサーバーを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

新規エージェントサーバーグループの名前を指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

作成する Backup Exec エージェントサーバーグループオブジェクトの名前を含む文字列を New-BEAgentServerGroup にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEAgentServerGroup

New-BEAgentServerGroup は、作成されたエージェントサーバーグループを返します。

Examples

Example 1

C:\PS> New-BEAgentServerGroup -Name "Windows"

このコマンドは「Windows」という名前のエージェントサーバーグループを作成します。

Example 2
C:\PS> $servers = Get-BEAgentServer "Win*"
C:\PS> New-BEAgentServerGroup -Name "Windows" -AgentServerList $servers

これらのコマンドは名前に「Win*」が含まれているエージェントサーバーをすべて含んだ、「Windows」という名前のエージェントサーバーグループを作成します。

Related Link

Get-BEAgentServer


New-BEAgentServerSelection Help

New-BEAgentServerSelection Cmdlet
Synopsis

エージェントサーバー全体を選択します。

Syntax
New-BEAgentServerSelection [-Exclude <SwitchParameter>] [-EnableSimplifiedDisasterRecovery <Boolean>] [<CommonParameters>]
Description

エージェントサーバー全体を選択します。

Parameters

-EnableSimplifiedDisasterRecovery <Boolean>

簡易ディザスタリカバリを有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Exclude <SwitchParameter>

エージェントサーバーの選択を除外します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

このコマンドレットは入力を受け入れません。

Return Value
BackupExec.Management.CLI.BEAgentServerSelection

BackupExec.Management.CLI.BEAgentServerSelection

Example

C:\PS> New-BEBackupDefinition BackupToDisk | Add-BEBackupSelection -AgentServer (Get-BEAgentServer -local) -Selection (New-BEAgentServerSelection -EnableSimplifiedDisasterRecovery) | Save-BEBackupDefinition

これらのコマンドはバックアップ定義を作成し、簡易ディザスタリカバリが有効になったローカルサーバーの選択内容を追加して、それを保存します。

Related Links


New-BEAuthorizedOracleServer Help

New-BEAuthorizedOracleServer Cmdlet
Synopsis

Oracle DBA 認定リストにサーバーを追加します。

Syntax
New-BEAuthorizedOracleServer [-ServerName] <String> -ServerLogonAccount <BELogonAccount> [<CommonParameters>]
Description

Backup Exec サーバーの Oracle サーバーと認証クレデンシャルのリストに、Oracle 完全修飾ドメイン名およびログオンアカウント名を追加します。

Parameters

-ServerName <String>

Oracle サーバーの名前を指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-ServerLogonAccount <BELogonAccount>

Oracle サーバーに対する権限のあるログオンアカウントの名前を指定します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

このコマンドレットは入力を受け入れません。

Return Value
BackupExec.Management.CLI.BEAuthorizedOracleServer

New-BEAuthorizedOracleServer は、作成されたオブジェクトを返します。

Example

C:\PS> New-BEAuthorizedOracleServer -ServerName myoracleserver.oracle.com -ServerLogonAccount orclLogonAccount

このコマンドは、Backup Exec サーバーの Oracle サーバーと認証クレデンシャルのリストに myoracleserver.oracle.com サーバーを追加します。


New-BEBackupDefinition Help

New-BEBackupDefinition Cmdlet
Synopsis

新しいバックアップ定義を Backup Exec に作成します。

Syntax
New-BEBackupDefinition [-BackupJobDefault] {BackupToDisk | BackupToDiskThenDuplicateToDisk | BackupToDiskThenDuplicateToTape | BackupToDiskCartridge | BackupToDiskCartridgeThenDuplicateToDiskCartridge | BackupToDiskCartridgeThenDuplicateToTape | BackupToDeduplicationDevice | BackupToDeduplicationDeviceThenDuplicateToDeduplicationDevice | BackupToDeduplicationDeviceThenDuplicateToTape | BackupToTape | BackupToCloud} [-LinuxMacFollowRemoteMountPoint <Boolean>] [-LinuxMacLockRemoteFile <Boolean>] [-LinuxMacPreserveChangeTime <Boolean>] [-LinuxMacFollowLocalMountPoint <Boolean>] [-ActiveDirectoryUseGrt <Boolean>] [-OracleMaximumNumberOfDevicesToUseForResources <UInt32>] [-ActiveDirectoryPreConsistencyCheck <Boolean>] [-ActiveDirectoryContinueIfConsistencyCheckIsUnsuccessful <Boolean>] [-SharePointContinueIfConsistencyCheckIsUnsuccessful <Boolean>] [-ExchangePreConsistencyCheck <Boolean>] [-ExchangeContinueIfConsistencyCheckIsUnsuccessful <Boolean>] [-FileSystemBackupOpenFile {Never | IfClosedWithinSpecifiedTime | WithALock | WithoutALock}] [-FileSystemBackupOpenFileIfClosedWithinSeconds <UInt32>] [-SharePointReleaseLockOnFarmTopology <Boolean>] [-SharePointPreConsistencyCheck <Boolean>] [-ExchangeHighAvailability {FromPassiveCopyIfAvailableOtherwiseActiveCopy | FromPassiveCopyOnly | FromActiveCopyOnly | FromPassiveCopyIfAvailableOtherwiseActiveCopyUsePreferredServers}] [-ExchangePreferredServerGroup <BEPreferredServerGroup>] [-NdmpEMCBackupType {Dump | VBB}] [-NdmpEMCBackupWithIntegratedCheckpoints <Boolean>] [-VMwareTransportModePriority {SAN | NBD | NBDSSL | Hotadd}] [-VMwareVSpherePort <UInt32>] [-NdmpNetAppEnableFileHistory <Boolean>] [-SharePointUseGrt <Boolean>] [-NdmpEMCEnableFileHistory <Boolean>] [-NdmpNetAppBackupAccessControlLists <Boolean>] [-HyperVExcludeVirtualMachinesNeedingSavedState <Boolean>] [-VirtualMachineEnableIRForAll <Boolean>] [-VirtualMachineUseGrtForFileSystem <Boolean>] [-OracleMinimumNumberOfDevicesRequiredForJob <UInt32>] [-VirtualMachineBackupPoweredOffVirtualMachine <Boolean>] [-VirtualMachineUseGrtForSql <Boolean>] [-VirtualMachineUseGrtForSharePoint <Boolean>] [-VirtualMachineUseGrtForActiveDirectory <Boolean>] [-VirtualMachineUseGrtForExchange <Boolean>] [-ExchangeUseGrt <Boolean>] [-TestRunCheckMediaAvailable <Boolean>] [-TestRunJobSizeCalculationMethod {UsePreviousJobHistories | PerformPreScan}] [-TestRunCheckLogonAccount <Boolean>] [-TestRunCheckStorageSpace <Boolean>] [-NetworkProtocol {AnyAvailable | IPv4 | IPv6}] [-NetworkSubnet <BENetworkInterfaceSubnet>] [-TestRunPlaceScheduledBackupJobOnHoldIfUnsuccessful <Boolean>] [-NetworkInterface <BENetworkInterface>] [-TestRunSchedule <BESchedule>] [-Description <String>] [-WithInitialFullBackupOnly <SwitchParameter>] [-FileSystemBackupRemoteStorage <Boolean>] [-Name <String>] [-RestrictToBackupExecServersInPool <BEBackupExecServerPool>] [-EnableTestRun <Boolean>] [-Priority {Normal | Lowest | Low | High | Highest}] [-RestrictToBackupExecServer <BEBackupExecServer>] [-DelayedCatalogStartAt <DateTime>] [-DelayedCatalogDaysOfWeek {Sunday | Monday | Tuesday | Wednesday | Thursday | Friday | Saturday}] [-ProcessOffhostLogicalVolumesSequentially <Boolean>] [-DelayedCatalogScheduleType {NoDelayedCatalog | ImmediatelyAfterBackup | Scheduled}] [-FileSystemFollowJunctionPoint <Boolean>] [-FileSystemFollowSymbolicLink <Boolean>] [-FileSystemBackupMethod {UseModifiedTime | UseArchiveBit | UseCatalog}] [-FileSystemEnableNtfsSingleInstanceBackup <Boolean>] [-FailIfNoOffhostBackup <Boolean>] [-UseSnapshotTechnology <Boolean>] [-SnapshotTechnology {Automatic | MicrosoftVolumeShadowCopyService}] [-AllowAnyNetworkForAgentAccess <Boolean>] [-EnableCheckpointRestart <Boolean>] [-UseOffhostBackup <Boolean>] [-OffhostBackupSnapshotProvider {Automatic | Software | Hardware}] [-SnapshotProvider {Automatic | System | Software | Hardware}] [-ProcessLogicalVolumesSequentially <Boolean>] [<CommonParameters>]

New-BEBackupDefinition -AgentServer <BEAgentServer> [-BackupJobDefault] {BackupToDisk | BackupToDiskThenDuplicateToDisk | BackupToDiskThenDuplicateToTape | BackupToDiskCartridge | BackupToDiskCartridgeThenDuplicateToDiskCartridge | BackupToDiskCartridgeThenDuplicateToTape | BackupToDeduplicationDevice | BackupToDeduplicationDeviceThenDuplicateToDeduplicationDevice | BackupToDeduplicationDeviceThenDuplicateToTape | BackupToTape | BackupToCloud} [-FileSystemBackupOpenFile {Never | IfClosedWithinSpecifiedTime | WithALock | WithoutALock}] [-FileSystemBackupOpenFileIfClosedWithinSeconds <UInt32>] [-ExchangePreConsistencyCheck <Boolean>] [-FileSystemFollowJunctionPoint <Boolean>] [-FileSystemFollowSymbolicLink <Boolean>] [-FileSystemBackupRemoteStorage <Boolean>] [-SharePointReleaseLockOnFarmTopology <Boolean>] [-SharePointPreConsistencyCheck <Boolean>] [-SharePointContinueIfConsistencyCheckIsUnsuccessful <Boolean>] [-ExchangeContinueIfConsistencyCheckIsUnsuccessful <Boolean>] [-ExchangeHighAvailability {FromPassiveCopyIfAvailableOtherwiseActiveCopy | FromPassiveCopyOnly | FromActiveCopyOnly | FromPassiveCopyIfAvailableOtherwiseActiveCopyUsePreferredServers}] [-ExchangePreferredServerGroup <BEPreferredServerGroup>] [-FileSystemEnableNtfsSingleInstanceBackup <Boolean>] [-ProcessLogicalVolumesSequentially <Boolean>] [-UseOffhostBackup <Boolean>] [-OffhostBackupSnapshotProvider {Automatic | Software | Hardware}] [-ExchangeUseGrt <Boolean>] [-SnapshotTechnology {Automatic | MicrosoftVolumeShadowCopyService}] [-SnapshotProvider {Automatic | System | Software | Hardware}] [-DelayedCatalogStartAt <DateTime>] [-DelayedCatalogDaysOfWeek {Sunday | Monday | Tuesday | Wednesday | Thursday | Friday | Saturday}] [-FileSystemBackupMethod {UseModifiedTime | UseArchiveBit | UseCatalog}] [-FailIfNoOffhostBackup <Boolean>] [-ProcessOffhostLogicalVolumesSequentially <Boolean>] [-DelayedCatalogScheduleType {NoDelayedCatalog | ImmediatelyAfterBackup | Scheduled}] [-HyperVExcludeVirtualMachinesNeedingSavedState <Boolean>] [-VMwareTransportModePriority {SAN | NBD | NBDSSL | Hotadd}] [-VMwareVSpherePort <UInt32>] [-VirtualMachineUseGrtForExchange <Boolean>] [-VirtualMachineUseGrtForSql <Boolean>] [-VirtualMachineUseGrtForSharePoint <Boolean>] [-NdmpNetAppBackupAccessControlLists <Boolean>] [-NdmpNetAppEnableFileHistory <Boolean>] [-SharePointUseGrt <Boolean>] [-NdmpEMCBackupType {Dump | VBB}] [-NdmpEMCBackupWithIntegratedCheckpoints <Boolean>] [-NdmpEMCEnableFileHistory <Boolean>] [-VirtualMachineUseGrtForActiveDirectory <Boolean>] [-LinuxMacLockRemoteFile <Boolean>] [-ActiveDirectoryPreConsistencyCheck <Boolean>] [-ActiveDirectoryContinueIfConsistencyCheckIsUnsuccessful <Boolean>] [-LinuxMacPreserveChangeTime <Boolean>] [-LinuxMacFollowLocalMountPoint <Boolean>] [-LinuxMacFollowRemoteMountPoint <Boolean>] [-VirtualMachineBackupPoweredOffVirtualMachine <Boolean>] [-VirtualMachineEnableIRForAll <Boolean>] [-VirtualMachineUseGrtForFileSystem <Boolean>] [-ActiveDirectoryUseGrt <Boolean>] [-OracleMaximumNumberOfDevicesToUseForResources <UInt32>] [-OracleMinimumNumberOfDevicesRequiredForJob <UInt32>] [-SharePointSingleSignOnDatabaseSelection {Include | Exclude}] [-SharePointWebApplicationSelection <BESharePointWebApplicationSelection[]>] [-SharePointServiceApplicationSelection <BESharePointServiceApplicationSelection[]>] [-SharePointCentralAdministrationWebApplicationSelection {Include | Exclude}] [-SharePointInfoPathServicesSelection {Include | Exclude}] [-SharePointHelpSearchSelection {Include | Exclude}] [-SharePointSharedServiceProviderSelection <BESharePointSharedServiceProviderSelection[]>] [-SharePointPortalSiteSelection <BESharePointPortalSiteSelection[]>] [-SharePointServiceSiteSelection <BESharePointServiceSiteSelection[]>] [-SharePointServiceApplicationProxySelection <BESharePointServiceApplicationProxySelection[]>] [-SharePointSharedServiceApplicationSelection <BESharePointSharedServiceApplicationSelection[]>] [-SharePointSharedServiceApplicationProxySelection <BESharePointSharedServiceApplicationProxySelection[]>] [-SharePointGlobalSettingsSelection {Include | Exclude}] [-Description <String>] [-WithInitialFullBackupOnly <SwitchParameter>] [-SystemStateSelection {Include | Exclude}] [-UseSnapshotTechnology <Boolean>] [-EnableSimplifiedDisasterRecovery <Boolean>] [-Name <String>] [-SqlDatabaseSelection <BESqlDatabaseSelection[]>] [-SharePointAllResourcesSelection {Include | Exclude}] [-SharePointConfigurationDatabaseSelection {Include | Exclude}] [-FileSystemSelection <BEFileSystemSelection[]>] [-ExchangeStorageGroupDatabaseSelection <BEExchangeStorageGroupDatabaseSelection[]>] [-ExchangeDatabaseSelection <BEExchangeDatabaseSelection[]>] [-TestRunCheckStorageSpace <Boolean>] [-TestRunCheckMediaAvailable <Boolean>] [-TestRunJobSizeCalculationMethod {UsePreviousJobHistories | PerformPreScan}] [-EnableTestRun <Boolean>] [-TestRunSchedule <BESchedule>] [-TestRunCheckLogonAccount <Boolean>] [-NetworkSubnet <BENetworkInterfaceSubnet>] [-AllowAnyNetworkForAgentAccess <Boolean>] [-EnableCheckpointRestart <Boolean>] [-TestRunPlaceScheduledBackupJobOnHoldIfUnsuccessful <Boolean>] [-NetworkInterface <BENetworkInterface>] [-NetworkProtocol {AnyAvailable | IPv4 | IPv6}] [-RestrictToBackupExecServersInPool <BEBackupExecServerPool>] [-VMwareSelection <BEVMwareSelection[]>] [-UtilityPartitionSelection <BEUtilityPartitionSelection[]>] [-EnterpriseVaultDirectorySelection <BEEnterpriseVaultDirectorySelection[]>] [-LinuxMacSelection <BELinuxMacSelection[]>] [-OracleSelection <BEOracleSelection[]>] [-HyperVSelection <BEHyperVSelection[]>] [-OpenEnterpriseServerSelection <BEOpenEnterpriseServerSelection[]>] [-Priority {Normal | Lowest | Low | High | Highest}] [-RestrictToBackupExecServer <BEBackupExecServer>] [-EnterpriseVaultComplianceAcceleratorSelection <BEEnterpriseVaultComplianceAcceleratorSelection[]>] [-EnterpriseVaultDiscoveryAcceleratorSelection <BEEnterpriseVaultDiscoveryAcceleratorSelection[]>] [-ActiveDirectoryApplicationModeSelection <BEActiveDirectoryApplicationModeSelection[]>] [<CommonParameters>]

New-BEBackupDefinition -SelectionList <BEAgentServerBackupSelectionList[]> [-BackupJobDefault] {BackupToDisk | BackupToDiskThenDuplicateToDisk | BackupToDiskThenDuplicateToTape | BackupToDiskCartridge | BackupToDiskCartridgeThenDuplicateToDiskCartridge | BackupToDiskCartridgeThenDuplicateToTape | BackupToDeduplicationDevice | BackupToDeduplicationDeviceThenDuplicateToDeduplicationDevice | BackupToDeduplicationDeviceThenDuplicateToTape | BackupToTape | BackupToCloud} [-LinuxMacFollowRemoteMountPoint <Boolean>] [-LinuxMacLockRemoteFile <Boolean>] [-LinuxMacPreserveChangeTime <Boolean>] [-LinuxMacFollowLocalMountPoint <Boolean>] [-ActiveDirectoryUseGrt <Boolean>] [-OracleMaximumNumberOfDevicesToUseForResources <UInt32>] [-ActiveDirectoryPreConsistencyCheck <Boolean>] [-ActiveDirectoryContinueIfConsistencyCheckIsUnsuccessful <Boolean>] [-SharePointContinueIfConsistencyCheckIsUnsuccessful <Boolean>] [-ExchangePreConsistencyCheck <Boolean>] [-ExchangeContinueIfConsistencyCheckIsUnsuccessful <Boolean>] [-FileSystemBackupOpenFile {Never | IfClosedWithinSpecifiedTime | WithALock | WithoutALock}] [-FileSystemBackupOpenFileIfClosedWithinSeconds <UInt32>] [-SharePointReleaseLockOnFarmTopology <Boolean>] [-SharePointPreConsistencyCheck <Boolean>] [-ExchangeHighAvailability {FromPassiveCopyIfAvailableOtherwiseActiveCopy | FromPassiveCopyOnly | FromActiveCopyOnly | FromPassiveCopyIfAvailableOtherwiseActiveCopyUsePreferredServers}] [-ExchangePreferredServerGroup <BEPreferredServerGroup>] [-NdmpEMCBackupType {Dump | VBB}] [-NdmpEMCBackupWithIntegratedCheckpoints <Boolean>] [-VMwareTransportModePriority {SAN | NBD | NBDSSL | Hotadd}] [-VMwareVSpherePort <UInt32>] [-NdmpNetAppEnableFileHistory <Boolean>] [-SharePointUseGrt <Boolean>] [-NdmpEMCEnableFileHistory <Boolean>] [-NdmpNetAppBackupAccessControlLists <Boolean>] [-HyperVExcludeVirtualMachinesNeedingSavedState <Boolean>] [-VirtualMachineEnableIRForAll <Boolean>] [-VirtualMachineUseGrtForFileSystem <Boolean>] [-OracleMinimumNumberOfDevicesRequiredForJob <UInt32>] [-VirtualMachineBackupPoweredOffVirtualMachine <Boolean>] [-VirtualMachineUseGrtForSql <Boolean>] [-VirtualMachineUseGrtForSharePoint <Boolean>] [-VirtualMachineUseGrtForActiveDirectory <Boolean>] [-VirtualMachineUseGrtForExchange <Boolean>] [-ExchangeUseGrt <Boolean>] [-TestRunCheckMediaAvailable <Boolean>] [-TestRunJobSizeCalculationMethod {UsePreviousJobHistories | PerformPreScan}] [-TestRunCheckLogonAccount <Boolean>] [-TestRunCheckStorageSpace <Boolean>] [-NetworkProtocol {AnyAvailable | IPv4 | IPv6}] [-NetworkSubnet <BENetworkInterfaceSubnet>] [-TestRunPlaceScheduledBackupJobOnHoldIfUnsuccessful <Boolean>] [-NetworkInterface <BENetworkInterface>] [-TestRunSchedule <BESchedule>] [-Description <String>] [-WithInitialFullBackupOnly <SwitchParameter>] [-FileSystemBackupRemoteStorage <Boolean>] [-Name <String>] [-RestrictToBackupExecServersInPool <BEBackupExecServerPool>] [-EnableTestRun <Boolean>] [-Priority {Normal | Lowest | Low | High | Highest}] [-RestrictToBackupExecServer <BEBackupExecServer>] [-DelayedCatalogStartAt <DateTime>] [-DelayedCatalogDaysOfWeek {Sunday | Monday | Tuesday | Wednesday | Thursday | Friday | Saturday}] [-ProcessOffhostLogicalVolumesSequentially <Boolean>] [-DelayedCatalogScheduleType {NoDelayedCatalog | ImmediatelyAfterBackup | Scheduled}] [-FileSystemFollowJunctionPoint <Boolean>] [-FileSystemFollowSymbolicLink <Boolean>] [-FileSystemBackupMethod {UseModifiedTime | UseArchiveBit | UseCatalog}] [-FileSystemEnableNtfsSingleInstanceBackup <Boolean>] [-FailIfNoOffhostBackup <Boolean>] [-UseSnapshotTechnology <Boolean>] [-SnapshotTechnology {Automatic | MicrosoftVolumeShadowCopyService}] [-AllowAnyNetworkForAgentAccess <Boolean>] [-EnableCheckpointRestart <Boolean>] [-UseOffhostBackup <Boolean>] [-OffhostBackupSnapshotProvider {Automatic | Software | Hardware}] [-SnapshotProvider {Automatic | System | Software | Hardware}] [-ProcessLogicalVolumesSequentially <Boolean>] [<CommonParameters>]
Description

新しいバックアップ定義を Backup Exec に作成します。

BackupJobDefault パラメータの値によって、バックアップ定義で使用するデフォルトのジョブオプションが決定されます。

New-BEBackupDefinition に渡されるパラメータは、バックアップ定義のすべてのタスクに対するオプションです。

New-BEBackupDefinition に渡される選択パラメータがない場合、エージェントサーバー全体がバックアップされます。

New-BEBackupDefinition を次のコマンドと一緒に使用して、バックアップ定義のタスクを変更できます:Set-BEBackupDefinition、Add-BEIncrementalBackupTask、Add-BEDifferentialBackupTask、Add-BEDuplicateStageBackupTask、Add-BEConvertToVirtualStageBackupTask、Add-BEVerifyBackupTask、Set-BEIncrementalBackupTask、Set-BEDifferentialBackupTask、Set-BEDuplicateStageBackupTask、Set-BEVerifyBackupTask、Remove-BEBackupTask。

バックアップ定義を作成または編集する場合、そのバックアップ定義を Save-BEBackupDefinition に渡して変更をコミットする必要があります。

Parameters

-BackupJobDefault

バックアップ定義に使用するデフォルトのジョブオプションを指定します。

The valid values are:
BackupToDisk
BackupToDiskThenDuplicateToDisk
BackupToDiskThenDuplicateToTape
BackupToDiskCartridge
BackupToDiskCartridgeThenDuplicateToDiskCartridge
BackupToDiskCartridgeThenDuplicateToTape
BackupToDeduplicationDevice
BackupToDeduplicationDeviceThenDuplicateToDeduplicationDevice
BackupToDeduplicationDeviceThenDuplicateToTape
BackupToTape
BackupToCloud

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-AgentServer <BEAgentServer>

バックアップするエージェントサーバーオブジェクトを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-EnableSimplifiedDisasterRecovery <Boolean>

簡易システムリカバリを有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SelectionList <BEAgentServerBackupSelectionList[]>

バックアップする選択項目のリストを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String>

新しいバックアップ定義の名前を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

新しいバックアップ定義の説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WithInitialFullBackupOnly <SwitchParameter>

初回の完全バックアップでバックアップ定義を作成します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SystemStateSelection

システム状態をバックアップ定義に含める、またはバックアップ定義から除外します。

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemSelection <BEFileSystemSelection[]>

1 つ以上のファイルシステムの選択項目をバックアップ定義に含める、またはバックアップ定義から除外します。含めるファイルまたはディレクトリを指定するには、1 つまたは複数のパスを、カンマを使用して値を区切って指定します。除外するファイルまたはディレクトリを指定するには、-Exclude パラメータと一緒に New-BEFileSystemSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeStorageGroupDatabaseSelection <BEExchangeStorageGroupDatabaseSelection[]>

1 つ以上の Exchange 2003 ストレージのグループまたはデータベースをバックアップ定義に含める、またはバックアップ定義から除外します。含めるストレージグループを指定するには、1 つまたは複数のストレージグループ名を、カンマを使用して値を区切って指定します。「*」を指定するとすべてのストレージグループが含まれます。除外するストレージグループを指定したり、含めるまたは除外するデータベースを個別に指定するには、-Exclude パラメータと一緒に New-BEExchangeStorageGroupDatabaseSelection の出力を使用します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeDatabaseSelection <BEExchangeDatabaseSelection[]>

1 つ以上の Exchange 2007 以降のデータベースをバックアップ定義に含める、またはバックアップ定義から除外します。含めるデータベースを指定するには、1 つまたは複数のデータベース名を、カンマを使用して値を区切って指定します。「*」を指定するとすべてのデータベースが含まれます。除外するデータベースを指定するには、-Exclude パラメータと一緒に New-BEExchangeDatabaseSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlDatabaseSelection <BESqlDatabaseSelection[]>

1 つ以上の SQL インスタンスまたは SQL データベースをバックアップ定義に含める、またはバックアップ定義から除外します。含める SQL インスタンスを指定するには、1 つまたは複数の SQL インスタンス名を、カンマを使用して値を区切って指定します。「*」を指定するとすべての SQL インスタンスが含まれます。除外する SQL インスタンスを指定したり、含めるまたは除外するデータベースを個別に指定するには、-Exclude パラメータと一緒に New-BESqlDatabaseSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointAllResourcesSelection

Windows コンピュータをバックアップするときに、すべての SharePoint リソースをカテゴリ別にバックアップ定義に含める、またはバックアップ定義から除外します。

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointConfigurationDatabaseSelection

SharePoint 設定データベースをバックアップ定義に含める、またはバックアップ定義から除外します。

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointGlobalSettingsSelection

SharePoint のグローバル設定データベースをバックアップ定義に含める、またはバックアップ定義から除外します。

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointCentralAdministrationWebApplicationSelection

SharePoint Central Administration Web アプリケーションをバックアップ定義に含める、またはバックアップ定義から除外します。

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointInfoPathServicesSelection

SharePoint InfoPath サービスをバックアップ定義に含める、またはバックアップ定義から除外します。

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointHelpSearchSelection

SharePoint ヘルプ検索をバックアップ定義に含める、またはバックアップ定義から除外します。

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointSingleSignOnDatabaseSelection

SharePoint シングルサインオンデータベースをバックアップ定義に含める、またはバックアップ定義から除外します。

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointWebApplicationSelection <BESharePointWebApplicationSelection[]>

1 つ以上の SharePoint Web アプリケーションをバックアップ定義に含める、またはバックアップ定義から除外します。含める Web アプリケーションを指定するには、1 つまたは複数の Web アプリケーション名を、カンマを使用して値を区切って指定します。「*」を指定すると、すべての Web アプリケーションが含まれます。 除外する Web アプリケーションを指定するには、-Exclude パラメータと一緒に New-BESharePointWebApplicationSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointServiceApplicationSelection <BESharePointServiceApplicationSelection[]>

1 つ以上の SharePoint サービスアプリケーションをバックアップ定義に含める、またはバックアップ定義から除外します。 含めるサービスアプリケーションを指定するには、1 つまたは複数のサービスアプリケーション名を、カンマを使用して値を区切って指定します。「*」を指定すると、すべてのサービスアプリケーションが含まれます。 除外するサービスアプリケーションを指定するには、-Exclude パラメータと一緒に New-BESharePointServiceApplicationSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointServiceApplicationProxySelection <BESharePointServiceApplicationProxySelection[]>

1 つ以上の SharePoint サービスアプリケーションプロキシをバックアップ定義に含める、またはバックアップ定義から除外します。含めるサービスアプリケーションプロキシを指定するには、1 つまたは複数のサービスアプリケーションプロキシ名を、カンマを使用して値を区切って指定します。「*」を指定すると、すべてのサービスアプリケーションプロキシが含まれます。除外するサービスアプリケーションプロキシを指定するには、-Exclude パラメータと一緒に New-BESharePointServiceApplicationProxySelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointSharedServiceApplicationSelection <BESharePointSharedServiceApplicationSelection[]>

1 つ以上の SharePoint 共有サービスアプリケーションをバックアップ定義に含める、またはバックアップ定義から除外します。含める共有サービスアプリケーションを指定するには、1 つまたは複数の共有サービスアプリケーション名を、カンマを使用して値を区切って指定します。「*」を指定すると、すべての共有サービスアプリケーションが含まれます。除外する共有サービスアプリケーションを指定するには、-Exclude パラメータと一緒に New-BESharePointSharedServiceApplicationSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointSharedServiceApplicationProxySelection <BESharePointSharedServiceApplicationProxySelection[]>

1 つ以上の SharePoint 共有サービスアプリケーションプロキシをバックアップ定義に含める、またはバックアップ定義から除外します。 含める共有サービスアプリケーションプロキシを指定するには、1 つまたは複数の共有サービスアプリケーションプロキシ名を、カンマを使用して値を区切って指定します。「*」を指定すると、すべての共有サービスアプリケーションプロキシが含まれます。除外する共有サービスアプリケーションプロキシを指定するには、-Exclude パラメータと一緒に New-BESharePointSharedServiceApplicationProxySelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointSharedServiceProviderSelection <BESharePointSharedServiceProviderSelection[]>

1 つ以上の SharePoint 共有サービスプロバイダをバックアップ定義に含める、またはバックアップ定義から除外します。含める共有サービスプロバイダを指定するには、1 つまたは複数の共有サービスプロバイダ名を、カンマを使用して値を区切って指定します。除外する共有サービスプロバイダを指定するには、-Exclude パラメータと一緒に New-BESharePointSharedServiceProviderSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointPortalSiteSelection <BESharePointPortalSiteSelection[]>

1 つ以上の SharePoint ポータルサイトをバックアップ定義に含める、またはバックアップ定義から除外します。含めるポータルサイトを指定するには、1 つまたは複数のポータルサイト名を、カンマを使用して値を区切って指定します。除外するポータルサイトを指定するには、-Exclude パラメータと一緒に New-BESharePointPortalSiteSelection の出力を使い、1 つ以上の除外するポータルサイトをこのパラメータに渡します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointServiceSiteSelection <BESharePointServiceSiteSelection[]>

1 つ以上の SharePoint サービスサイトをバックアップ定義に含める、またはバックアップ定義から除外します。 含めるサービスサイトを指定するには、1 つまたは複数のサービスサイト名を、カンマを使用して値を区切って指定します。除外するサービスサイトを指定するには、-Exclude パラメータと一緒に New-BESharePointServiceSiteSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LinuxMacSelection <BELinuxMacSelection[]>

1 つ以上の Linux サーバーまたは Macintosh システムをバックアップ定義に含める、またはバックアップ定義から除外します。 含めるファイルまたはディレクトリを指定するには、1 つまたは複数のパスを、カンマを使用して値を区切って指定します。除外するファイルまたはディレクトリを指定するには、-Exclude パラメータと一緒に New-BELinuxMacSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleSelection <BEOracleSelection[]>

1 つ以上の Oracle の選択項目をバックアップ定義に含める、またはバックアップ定義から除外します。含めるデータベースまたは表スペースを指定するには、1 つまたは複数のパスを、カンマを使用して値を区切って指定します。除外するデータベースまたは表スペースを指定するには、-Exclude パラメータと一緒に New-BEOracleSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-HyperVSelection <BEHyperVSelection[]>

1 つ以上の Hyper-V 仮想マシンをバックアップ定義に含める、またはバックアップ定義から除外します。含める仮想マシンを指定するには、1 つまたは複数の仮想マシン名を、カンマを使用して値を区切って指定します (「*」を指定するとすべての Hyper-V 仮想マシンが含められます)。除外する仮想マシンを指定するには、New-BEHyperVSelection の出力とともに -Exclude パラメータを使用して、最初にすべての仮想マシンを含め、次に除外する対象を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VMwareSelection <BEVMwareSelection[]>

1 つ以上の VMware サーバーをバックアップ定義に含める、またはバックアップ定義から除外します。含める VMware サーバーを指定するには、1 つまたは複数の VMware サーバー名を、カンマを使用して値を区切って指定します。 除外する VMware サーバーを指定するには、New-BEVMwareSelection の出力とともに -Exclude パラメータを使用します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UtilityPartitionSelection <BEUtilityPartitionSelection[]>

1 つ以上のユーティリティパーティションをバックアップ定義に含める、またはバックアップ定義から除外します。含めるユーティリティパーティションを指定するには、1 つまたは複数のパスを、カンマを使用して値を区切って指定します。除外するユーティリティパーティションを指定するには、-Exclude パラメータと一緒に New-BEUtilityPartitionSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnterpriseVaultDirectorySelection <BEEnterpriseVaultDirectorySelection[]>

1 つ以上の Enterprise Vault Directory リソースをバックアップ定義に含める、またはバックアップ定義から除外します。 含める Enterprise Vault Directory リソースを指定するには、1 つまたは複数のリソース名を、カンマを使用して値を区切って指定します。除外するリソースを指定するには、New-BEEnterpriseVaultDirectorySelection の出力とともに -Exclude パラメータを使用します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnterpriseVaultComplianceAcceleratorSelection <BEEnterpriseVaultComplianceAcceleratorSelection[]>

1 つ以上の Enterprise Vault Compliance の Accelerator データベースをバックアップ定義に含める、またはバックアップ定義から除外します。含める Enterprise Vault Compliance の Accelerator データベースを指定するには、1 つまたは複数のデータベース名を、カンマを使用して値を区切って指定します。除外するデータベースを指定するには、New-BEEnterpriseVaultComplianceAcceleratorSelection の出力とともに -Exclude パラメータを使用します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnterpriseVaultDiscoveryAcceleratorSelection <BEEnterpriseVaultDiscoveryAcceleratorSelection[]>

1 つ以上の Enterprise Vault Discovery の Accelerator データベースをバックアップ定義に含める、またはバックアップ定義から除外します。 含める Enterprise Vault Discovery の Accelerator データベースを指定するには、1 つまたは複数のデータベース名を、カンマを使用して値を区切って指定します。除外するデータベースを指定するには、New-BEEnterpriseVaultDiscoveryAcceleratorSelection の出力とともに -Exclude パラメータを使用します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ActiveDirectoryApplicationModeSelection <BEActiveDirectoryApplicationModeSelection[]>

1 つ以上の Active Directory Application Mode インスタンスをバックアップ定義に含める、またはバックアップ定義から除外します。含めるインスタンスを指定するには、1 つまたは複数のパスを、カンマを使用して値を区切って指定します。除外するインスタンスを指定するには、-Exclude パラメータと一緒に New-BEActiveDirectoryLightweightDirectoryServiceSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OpenEnterpriseServerSelection <BEOpenEnterpriseServerSelection[]>

1 つ以上の OES コンポーネントをバックアップ定義に含める、またはバックアップ定義から除外します。含めるファイルまたはディレクトリを指定するには、1 つまたは複数のパスを、カンマを使用して値を区切って指定します。除外するファイルまたはディレクトリを指定するには、-Exclude パラメータと一緒に New-BEOpenEnterpriseServerSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Priority

ジョブを実行する順序を指定します。2 つのジョブが同時に実行されるようにスケジュールされている場合、ユーザーが設定する優先度でどちらが先に実行されるかが決まります。

The valid values are:
Normal
Lowest
Low
High
Highest

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RestrictToBackupExecServer <BEBackupExecServer>

CASO 環境でジョブをディスパッチ可能な Backup Exec サーバーを指定します。RestrictToBackupExecServersInPool が指定されている場合は指定できません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RestrictToBackupExecServersInPool <BEBackupExecServerPool>

CASO 環境でジョブをディスパッチ可能な Backup Exec サーバーのセットを指定します。RestrictToBackupExecServer が指定されている場合は指定できません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableTestRun <Boolean>

テスト実行の処理を有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunSchedule <BESchedule>

テスト実行ジョブの実行日時と実行頻度のスケジュール設定を可能にします。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunCheckLogonAccount <Boolean>

バックアップする Backup Exec ログオンアカウントがデータにアクセス可能であることを確認します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunCheckStorageSpace <Boolean>

メディア上にジョブの完了に必要な容量があるかどうかをチェックします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunCheckMediaAvailable <Boolean>

メディアがオンラインになっていて上書き可能かどうかをチェックします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunJobSizeCalculationMethod

メディアにスケジュール済みバックアップジョブの実行に必要な容量があるかどうかを計算する方法を指定します。

The valid values are:
UsePreviousJobHistories
PerformPreScan

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunPlaceScheduledBackupJobOnHoldIfUnsuccessful <Boolean>

テスト実行中に Backup Exec で障害が検出された場合、スケジュール済みジョブを保留にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NetworkInterface <BENetworkInterface>

バックアップネットワークとして使用するネットワークに対して Backup Exec サーバーを接続する、ネットワークインターフェースカードの名前を指定します。Get-BENetworkInterface を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NetworkProtocol

リモートコンピュータをバックアップするために使うプロトコルを指定します。

The valid values are:
AnyAvailable
IPv4
IPv6

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NetworkSubnet <BENetworkInterfaceSubnet>

Get-BENetworkInterface によって返されたネットワークインターフェースのサブネットの 1 つを使用して、リモートコンピュータをバックアップするために使うサブネットを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AllowAnyNetworkForAgentAccess <Boolean>

バックアップまたはリストアのために選択したリモートコンピュータが、指定したバックアップネットワークの一部でない場合に、リモートコンピュータからのデータが任意の利用可能なネットワークを介してバックアップまたはリストアされるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableCheckpointRestart <Boolean>

ジョブが中断された時点からバックアップジョブを続行可能にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UseSnapshotTechnology <Boolean>

スナップショットテクノロジの利用を有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SnapshotTechnology

スナップショットテクノロジを有効にしたときに使用する、スナップショットテクノロジを指定します。UseSnapshotTechnology は $true に設定する必要があります。

The valid values are:
Automatic
MicrosoftVolumeShadowCopyService

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SnapshotProvider

スナップショットテクノロジを有効にしたときに使用するスナップショットプロバイダとして、Microsoft ボリュームシャドウコピーサービスを指定します。UseSnapshotTechnology を $true に設定し、SnapshotTechnology を MicrosoftVolumeShadowCopyService に設定する必要があります。

The valid values are:
Automatic
System
Software
Hardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ProcessLogicalVolumesSequentially <Boolean>

1 つのジョブで複数のボリュームをバックアップすることを有効にします。このとき、一度に 1 つの論理ボリュームのスナップショットのみが作成されます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UseOffhostBackup <Boolean>

オフホストバックアップを有効にします。有効な場合は、すべての必要条件が満たされると、すべてのボリュームのオフホストバックアップが実行されます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OffhostBackupSnapshotProvider

使用するオフホストバックアップのスナップショットプロバイダを指定します。UseOffhostBackup は $true に設定する必要があります。

The valid values are:
Automatic
Software
Hardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FailIfNoOffhostBackup <Boolean>

選択したボリュームのいずれかがオフホストバックアップをサポートしない場合、またはスナップショットやボリュームのインポートでエラーが発生した場合、バックアップジョブを終了します。 UseOffhostBackup は $true に設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ProcessOffhostLogicalVolumesSequentially <Boolean>

1 つのジョブで複数のボリュームをバックアップすることを可能にします。このとき、オフホストバックアップに対して一度に 1 つの論理ボリュームのスナップショットのみが作成されます。UseOffhostBackup は $true に設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DelayedCatalogScheduleType

実行する延期したカタログ操作の代替日または時間を指定します。

The valid values are:
NoDelayedCatalog
ImmediatelyAfterBackup
Scheduled

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DelayedCatalogStartAt <DateTime>

遅延カタログジョブを実行する時刻を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DelayedCatalogDaysOfWeek

遅延カタログジョブを実行する曜日を指定します。

The valid values are:
Sunday
Monday
Tuesday
Wednesday
Thursday
Friday
Saturday

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemBackupMethod

ファイルとフォルダのバックアップに使用するバックアップ方式を指定します。

The valid values are:
UseModifiedTime
UseArchiveBit
UseCatalog

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemEnableNtfsSingleInstanceBackup <Boolean>

Backup Exec で同一ファイルに対して NTFS ボリュームをチェックできるようにします。ファイルのコピーが複数見つかった場合は、そのファイルの 1 つのインスタンスのみが Backup Exec によってバックアップされます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemFollowJunctionPoint <Boolean>

接合点の情報とリンク先のファイルおよびディレクトリをバックアップします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemFollowSymbolicLink <Boolean>

シンボリックリンクの情報とリンク先のファイルとディレクトリの情報をバックアップします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemBackupRemoteStorage <Boolean>

プライマリストレージからセカンダリストレージに移動したデータをバックアップします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemBackupOpenFile

スナップショットテクノロジが使用されていない場合に Backup Exec がバックアップジョブでオープンファイルを処理する方法を指定します。

The valid values are:
Never
IfClosedWithinSpecifiedTime
WithALock
WithoutALock

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemBackupOpenFileIfClosedWithinSeconds <UInt32>

オープンファイルをスキップしてバックアップジョブを続行する前に Backup Exec が待機する秒数を指定します。BackupOpenFile が IfClosedWithinSpecifiedTime に設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangePreConsistencyCheck <Boolean>

バックアップジョブを実行する前に一貫性チェックを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeContinueIfConsistencyCheckIsUnsuccessful <Boolean>

一貫性チェックに失敗した場合でもバックアップジョブを続行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeHighAvailability

Exchange 2007 以降のバックアップソースを指定します。

The valid values are:
FromPassiveCopyIfAvailableOtherwiseActiveCopy
FromPassiveCopyOnly
FromActiveCopyOnly
FromPassiveCopyIfAvailableOtherwiseActiveCopyUsePreferredServers

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangePreferredServerGroup <BEPreferredServerGroup>

Microsoft Exchange 2010 データベース可用性グループをバックアップするために使用する優先サーバーの設定の名前を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointReleaseLockOnFarmTopology <Boolean>

バックアップジョブを実行する前に SharePoint ファームトポロジーのロックを解除します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointPreConsistencyCheck <Boolean>

Microsoft SharePoint で使用する Microsoft SQL データベースをバックアップする前に、インデックスを含む完全な一貫性チェックを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointContinueIfConsistencyCheckIsUnsuccessful <Boolean>

一貫性チェックに失敗した場合でもバックアップジョブを続行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LinuxMacPreserveChangeTime <Boolean>

バックアップジョブの実行時に Agent for Windows でオブジェクトの属性が変更されないようにします。オブジェクトはファイルまたはディレクトリです。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LinuxMacFollowLocalMountPoint <Boolean>

データのバックアップ時に Backup Exec でローカルマウントポイントをたどることができます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LinuxMacFollowRemoteMountPoint <Boolean>

データのバックアップ時に Backup Exec でリモートマウントポイントをたどることができます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LinuxMacLockRemoteFile <Boolean>

ネットワークファイルシステム (NFS) を介して接続されたリモートコンピュータのファイルに Agent for Windows で排他的にアクセスできます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ActiveDirectoryPreConsistencyCheck <Boolean>

スナップショットにデータ破損がないかを確認します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ActiveDirectoryContinueIfConsistencyCheckIsUnsuccessful <Boolean>

一貫性チェックが失敗してもバックアップジョブの続行を可能にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ActiveDirectoryUseGrt <Boolean>

Active Directory の完全バックアップから個々の項目をリストアできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleMaximumNumberOfDevicesToUseForResources <UInt32>

バックアップジョブで使用できる最大デバイス数を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleMinimumNumberOfDevicesRequiredForJob <UInt32>

ジョブで使用できる最小デバイス数を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineBackupPoweredOffVirtualMachine <Boolean>

オフになった仮想マシンを Backup Exec でバックアップできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineEnableIRForAll <Boolean>

GRT の対象外を含むすべての仮想マシンでインスタントリカバリを有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForFileSystem <Boolean>

完全バックアップジョブから個々のファイルとフォルダをリストアできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForActiveDirectory <Boolean>

Backup Exec で仮想マシン上の個々の Active Directory オブジェクトをリストアするのに必要な情報を収集できるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForExchange <Boolean>

Backup Exec で仮想マシン上の個々の Exchange データベースおよびメールボックス項目をリストアするのに必要な情報を収集できるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForSql <Boolean>

Backup Exec で仮想マシン上の個々の SQL データベース項目をリストアするのに必要な情報を収集できるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForSharePoint <Boolean>

Backup Exec で仮想マシン上の SharePoint データをリストアするのに必要な情報を収集できるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-HyperVExcludeVirtualMachinesNeedingSavedState <Boolean>

オンラインバックアップをサポートしない、バックアップの開始時に実行状態であるすべてのオフライン仮想マシンを除外します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VMwareTransportModePriority

Backup Exec で使用する 1 つ以上の VMware 転送モードを優先度順に指定します。

The valid values are:
SAN
NBD
NBDSSL
Hotadd

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VMwareVSpherePort <UInt32>

Backup Exec で使用する VMware vSphere ポートを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NdmpEMCBackupType

EMC NDMP サーバーのバックアップタイプを指定します。

The valid values are:
Dump
VBB

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NdmpEMCBackupWithIntegratedCheckpoints <Boolean>

Backup Exec で EMC SnapSure 機能を使用するバックアップセットを作成するように設定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NdmpEMCEnableFileHistory <Boolean>

ファイルの履歴データの生成を可能にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NdmpNetAppBackupAccessControlLists <Boolean>

NetApp アクセス制御リストをバックアップします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NdmpNetAppEnableFileHistory <Boolean>

ファイルの履歴データの生成を可能にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointUseGrt <Boolean>

廃止: これはタスクレベルに設定するべきもので、BackupDefinition レベルに設定するものではありません。データベースバックアップからの個々のドキュメント、イメージ、サイト、サブサイト、リスト、リストの項目のリストアを有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeUseGrt <Boolean>

廃止: これはタスクレベルに設定する必要があるもので、BackupDefinition レベルに設定するものではありません。インフォメーションストアのバックアップジョブから個々の項目をリストアできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEAgentServer

パイプを使用して Backup Exec エージェントサーバーオブジェクトを New-BEBackupDefinition に渡すことができます。

Return Value
BackupExec.Management.CLI.BEBackupDefinition

New-BEBackupDefinition は、作成されたバックアップ定義を返します。

Examples

Example 1

C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition -BackupJobDefault BackupToDisk | Save-BEBackupDefinition

これらのコマンドでは、BackupToDisk のデフォルトを使用してローカルコンピュータ全体をバックアップするバックアップ定義を新しく作成します。

Example 2
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition -BackupJobDefault BackupToDisk -FileSystemSelection C:\Windows\*,D:\* -SystemStateSelection Include | Save-BEBackupDefinition

これらのコマンドでは、C:\Windows ディレクトリ、D: ドライブ、ローカルコンピュータのシステム状態をバックアップするバックアップ定義を新しく作成します。

Example 3
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition -BackupJobDefault BackupToDisk | Remove-BEBackupTask * | Add-BEDifferentialBackupTask | Save-BEBackupDefinition

これらのコマンドでは、初期完全バックアップと差分バックアップでローカルコンピュータをバックアップするバックアップ定義を新しく作成します。

Related Links

Set-BEBackupDefinition
Add-BEIncrementalBackupTask
Add-BEDifferentialBackupTask
Add-BEDuplicateStageBackupTask
Add-BEConvertToVirtualStageBackupTask
Add-BEVerifyBackupTask
Set-BEIncrementalBackupTask
Set-BEDifferentialBackupTask
Set-BEDuplicateStageBackupTask
Set-BEVerifyBackupTask
Remove-BEBackupTask
Save-BEBackupDefinition
New-BEFileSystemSelection
New-BEUtilityPartitionSelection
New-BELinuxMacSelection
New-BEOpenEnterpriseServerSelection
New-BEOracleSelection
New-BEExchangeStorageGroupDatabaseSelection
New-BEExchangeDatabaseSelection
New-BESqlDatabaseSelection
New-BESharePointWebApplicationSelection
New-BESharePointServiceApplicationSelection
New-BESharePointServiceApplicationProxySelection
New-BESharePointSharedServiceApplicationSelection
New-BESharePointSharedServiceApplicationProxySelection
New-BESharePointSharedServiceProviderSelection
New-BESharePointPortalSiteSelection
New-BESharePointServiceSiteSelection
Get-BENetworkInterface
New-BEHyperVSelection
New-BEVMwareSelection
New-BEEnterpriseVaultDirectorySelection
New-BEEnterpriseVaultComplianceAcceleratorSelection
New-BEEnterpriseVaultDiscoveryAcceleratorSelection
Get-BEAgentServer


New-BEBackupExecServerPool Help

New-BEBackupExecServerPool Cmdlet
Synopsis

新しい Backup Exec サーバープールを作成します。

Syntax
New-BEBackupExecServerPool [-Name] <String> [-Description <String>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

新しい Backup Exec サーバープールを作成します。

Parameters

-Description <String>

Backup Exec サーバープールの説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

新しい Backup Exec サーバープールの名前を指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

作成する Backup Exec サーバープールオブジェクトの名前を含む文字列を New-BEBackupExecServerPool にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEBackupExecServerPool

New-BEBackupExecServerPool は、作成された Backup Exec サーバープールを返します。

Example

C:\PS> New-BEBackupExecServerPool -Name "Server Pool 0001".

このコマンドは、「Server Pool 0001」という名前の Backup Exec サーバープールを作成します。


New-BEBackupSelection Help

New-BEBackupSelection Cmdlet
Synopsis

バックアップジョブに含められる、エージェントサーバーファイルの選択項目の順序付けされたリストを作成します。

Syntax
New-BEBackupSelection -AgentServer <BEAgentServer> [-Selection] <BESelection[]> [<CommonParameters>]
Description

バックアップジョブに含められる、エージェントサーバーファイルの選択項目の順序付けされたリストを作成します。複数のエージェントサーバー上でファイルの選択を行うには、この cmdlet を、各エージェントサーバーに対して、含めるファイルの選択項目を持つエージェントサーバーにつき 1 回使用します。Backup Exec にはいくつかの順序付けの制約がありますが、多くの場合、選択項目を指定する順序が、それらがバックアップされる順序になります。

Parameters

-AgentServer <BEAgentServer>

ファイルの選択を追加するエージェントサーバーを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Selection <BESelection[]>

エージェントサーバーに対して追加する 1 つ以上のファイル選択オブジェクトを指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEAgentServer

ファイルの選択を行う Backup Exec エージェントサーバーです。

Return Value
BackupExec.Management.CLI.BEAgentServerBackupSelectionList

BackupExec.Management.CLI.BEAgentServerBackupSelectionList

Example

C:\PS> $selections = Get-BEAgentServer -local | New-BEBackupSelection -Selection (New-BEFileSystemSelection C:\Users -PathIsDirectory)
C:\PS> Submit-BEOneTimeBackupJob -SelectionList $selections

このコマンドは Backup Exec サーバーの C:\Users ディレクトリに対するワンタイムバックアップを作成します。

Related Links


New-BEBarcodeRule Help

New-BEBarcodeRule Cmdlet
Synopsis

新しいバーコードルールを Backup Exec 内に作成します。

Syntax
New-BEBarcodeRule -MediaType <BEMediaType> [-BarcodeSuffix <String>] [-Vendor <String>] [-BarcodePrefix <String>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

新しいバーコードルールを Backup Exec 内に作成します。

Parameters

-MediaType <BEMediaType>

バーコードルールに含めるメディアの種類を指定します。Get-BEMediaTypeを参照してください

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Vendor <String>

ロボットライブラリの製造元の名前を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BarcodePrefix <String>

メディアの種類を表すバーコードの前に配置されるコードを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BarcodeSuffix <String>

メディアタイプを表すバーコードの後に続けるコードを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEMediaType

Backup Exec メディアタイプオブジェクトを New-BEBarcodeRule にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEBarcodeRule

New-BEBarcodeRule は作成されたバーコードルールを返します。

Example

C:\PS> New-BEBarcodeRule -MediaType LTO-100 -BarcodeSuffix L1

このコマンドは、「L1」というバーコードサフィックスを付けて「LTO-100」という名前のメディアタイプのバーコードルールを作成します。


New-BECloudInstance Help

New-BECloudInstance Cmdlet
Synopsis

Backup Exec で新しいクラウドインスタンスを作成して設定します。

Syntax
New-BECloudInstance [-Name] <String> [-Provider] <String> [-ServiceHost] <String> [-SslMode] {Disabled | AuthenticationOnly | Full} [-HttpsPort <Int32>] [-Endpoint <String>] [-HttpPort <Int32>] [-UrlStyle {Unknown | Virtual | Path}] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec で新しいクラウドインスタンスを作成して設定します。

Parameters

-Provider <String>

クラウドインスタンスのプロバイダを指定します。プライベートクラウドのプロバイダ名のみを指定できます。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-ServiceHost <String>

クラウドインスタンスのサービスホストを指定します。クラウドインスタンスのサービスホストは一意である必要があります。

Required | true
Position | 2
Accepts pipeline input | false
Accepts wildcard characters | false

-SslMode

クラウドインスタンスとの通信に Backup Exec が使用する SSL モードを指定します。Disabled - SSL を使用しないでください。AuthenticationOnly - 認証のみに SSL を使用します。Full - 認証とデータ転送に SSL を使用します。

The valid values are:
Disabled
AuthenticationOnly
Full

Required | true
Position | 3
Accepts pipeline input | false
Accepts wildcard characters | false

-UrlStyle

クラウドインスタンスの URL 形式を指定します。Unknown - Backup Exec にデフォルトの URL 形式の設定を許可します。Virtual - バケット名は URL のドメイン名に含まれます。Path - 地域固有のエンドポイントを使用する場合を除き、バケット名は URL のドメイン名に含まれません。

The valid values are:
Unknown
Virtual
Path

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-HttpPort <Int32>

クラウドインスタンスの http ポートを指定します。デフォルトポートは 80 です。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-HttpsPort <Int32>

クラウドインスタンスの https ポートを指定します。デフォルトポートは 443 です。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Endpoint <String>

クラウドインスタンスのエンドポイントを作成します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

新しいクラウドインスタンスの名前を指定します。クラウドインスタンス名には、文字、数字、ダッシュ (ハイフン) を使用できます。ダッシュ (ハイフン) で始めることはできません。

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

このコマンドレットは入力を受け入れません。

Return Value
BackupExec.Management.CLI.BECloudInstance

New-BECloudInstance は、作成したクラウドインスタンスを返します。

Examples

Example 1

C:\PS> New-BECloudInstance -Name "CloudInstance0001" -Provider "cloudian" -ServiceHost "s3.cloudian.com" -SslMode "Disabled" -HttpPort 80 -HttpsPort 443

これらのコマンドは、指定した値を使用して Backup Exec で新しいクラウドインスタンスを設定します。

Example 2
C:\PS> New-BECloudInstance -Name "CloudInstance0002" -Provider "cloudian" -ServiceHost "s3.cloudian1.com" -SslMode "AuthenticationOnly" -UrlStyle "Path"

これらのコマンドは、指定した値を使用して Backup Exec で新しいクラウドインスタンスを設定します。

Example 3
C:\PS> New-BECloudInstance -Name "CloudInstance0003" -Provider "compatible-with-s3-v4" -ServiceHost "s3.cloudian1.com" -SslMode "Disabled" -UrlStyle "Path"

この例で、コマンドは指定された値を使用した V4 認証で、Generic S3 と互換性がある新しいクラウドインスタンスを Backup Exec に構成します。


New-BECloudRegion Help

New-BECloudRegion Cmdlet
Synopsis

Backup Exec の既存のクラウドインスタンスに新しいクラウドリージョンを作成して設定します。

Syntax
New-BECloudRegion [-Name] <String> [-IsDefaultRegion] <Boolean> [-InstanceName] <String> [-Identifier] <String> [-ServiceHost] <String> [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec の既存のクラウドインスタンスに新しいクラウドリージョンを作成して設定します。このコマンドは、指定した値を使用して Backup Exec で新しいクラウドリージョンを設定します。

Parameters

-IsDefaultRegion <Boolean>

クラウドインスタンスに使用するデフォルトリージョンを指定します。

The valid values are:
$true
$false

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-InstanceName <String>

クラウドリージョンのインスタンスを指定します。

Required | true
Position | 2
Accepts pipeline input | false
Accepts wildcard characters | false

-Identifier <String>

クラウドリージョンの識別子を指定します。

Required | true
Position | 3
Accepts pipeline input | false
Accepts wildcard characters | false

-ServiceHost <String>

クラウドリージョンのサービスホストを指定します。

Required | true
Position | 4
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

新しいクラウドリージョンの名前を指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

このコマンドレットは入力を受け入れません。

Return Value
BackupExec.Management.CLI.BECloudRegion

New-BECloudRegion は、作成したクラウドリージョンを返します。

Example

C:\PS> New-BECloudRegion -InstanceName ibminst -IsDefaultRegion $true -Name "AP Australia" -Identifier au-syd-standard -ServiceHost s3.au-syd.cloud-object-storage.appdomain.cloud

これらのコマンドは、指定した値を使用して Backup Exec で新しいクラウドリージョンを設定します。


New-BECloudStorageDevice Help

New-BECloudStorageDevice Cmdlet
Synopsis

Backup Exec で新しいクラウドストレージデバイスを作成します。

Syntax
New-BECloudStorageDevice [-Name] <String> [-HostServer] <String> [-ServerType] <String> [-LogicalStorageUnit] <String> [-LogonAccount] <BELogonAccount> [-DataStreamSizeBytes <Int32>] [-SplitDataStreamBytes <Int64>] [-AllowedConcurrentOperations <Int32>] [-IsStreamHandlerSupportEnabled <Boolean>] [-DiskSpaceReserveBytes <Int64>] [-BackupExecServer <BEBackupExecServer>] [-Description <String>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [-Force <SwitchParameter>] [<CommonParameters>]
Description

新規クラウドストレージデバイスを Backup Exec に作成します。

ServerType パラメータに渡す、登録されたサーバータイプのリストを取得するには、Get-BECloudStorageServerType をコールします。

LogicalStorageUnit パラメータに渡す論理ストレージユニットのリストを取得するには、Get-BEOpenStorageLogicalStorageUnit をコールします。

Parameters

-BackupExecServer <BEBackupExecServer>

CASO 環境でデバイスを作成する Backup Exec サーバーを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-HostServer <String>

デバイスがあるサーバーの完全修飾名を指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-ServerType <String>

クラウドストレージデバイスの種類を指定します。

Required | true
Position | 2
Accepts pipeline input | false
Accepts wildcard characters | false

-LogicalStorageUnit <String>

クラウドストレージデバイスの論理ストレージユニットを指定します。

Required | true
Position | 3
Accepts pipeline input | false
Accepts wildcard characters | false

-LogonAccount <BELogonAccount>

新しいクラウドストレージデバイスの Backup Exec ログオンアカウントを指定します。 このログオンアカウントにシステムログオンアカウントは使用できません。

Required | true
Position | 4
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

クラウドストレージデバイスの説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AllowedConcurrentOperations <Int32>

このデバイスで許可される最大許容並列書き込み処理を設定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SplitDataStreamBytes <Int64>

Backup Exec が新しいイメージにスパンするサイズを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DataStreamSizeBytes <Int32>

Backup Exec が行う単一書き込み操作のサイズを示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IsStreamHandlerSupportEnabled <Boolean>

ストリームハンドラを使用するかどうかを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskSpaceReserveBytes <Int64>

Backup Exec 以外のアプリケーション用に空けてあるディスク領域を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

新しいクラウドストレージデバイスの名前を指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Force <SwitchParameter>

Backup Exec サーバーにクラウドストレージデバイスを強制的に信頼させます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

作成する Backup Exec クラウドストレージデバイスオブジェクトの名前を含む文字列を New-BECloudStorageDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BECloudStorageDevice

New-BECloudStorageDevice は作成されたクラウドストレージデバイスを返します。

Examples

Example 1

C:\PS> New-BECloudStorageDevice -Name "amazon-cloud" -BackupExecServer 2k12auto -HostServer "amazon:amazon.com" -ServerType "S3" -LogicalStorageUnit "test-bucket" -LogonAccount "amazon"

このコマンドは、ログオンアカウント「amazon」を使用して、「amazon:amazon.com」という Amazon ホストサーバーで「test-bucket」という論理ストレージタイプを使用するメディアサーバー 2k12auto に「amazon-cloud」という Amazon 標準ストレージティアタイプのクラウドストレージデバイスを作成します。

Example 2
C:\PS> New-BECloudStorageDevice -Name "amazonIA-cloud" -BackupExecServer 2k12auto -HostServer "amazon:amazon-ia.com" -ServerType "S3" -LogicalStorageUnit "test-bucket-ia" -LogonAccount "amazoniacreds"

このコマンドは、ログオンアカウント「amazoniacreds」を使用して、「amazon:amazon-ia.com」という Amazon ホストサーバーで「test-bucket-ia」という論理ストレージタイプを使用するメディアサーバー 2k12auto に「amazonIA-cloud」という Amazon の低頻度アクセスストレージティアタイプのクラウドストレージデバイスを作成します。

Related Links


New-BEConvertToVirtualTargetEnvironment Help

New-BEConvertToVirtualTargetEnvironment Cmdlet
Synopsis

仮想への変換ジョブのターゲット環境を定義します。

Syntax
New-BEConvertToVirtualTargetEnvironment -LogonAccount <BELogonAccount> -HyperVServerName <String> -HyperVDestinationPath <String> [-ToolsIsoPath <String>] [<CommonParameters>]

New-BEConvertToVirtualTargetEnvironment -LogonAccount <BELogonAccount> -ToolsIsoPath <String> -VMwareVCenterServerName <String> -VMwareHostName <String> -VMwareDataStoreName <String> [-VMwareResourcePoolName <String>] [-VMwareVirtualMachineFolder <String>] [<CommonParameters>]

New-BEConvertToVirtualTargetEnvironment -LogonAccount <BELogonAccount> -ToolsIsoPath <String> -VMwareEsxServerName <String> -VMwareDataStoreName <String> [-VMwareResourcePoolName <String>] [<CommonParameters>]
Description

仮想への変換ジョブのターゲット環境を定義します。

New-BEConvertToVirtualTargetEnvironment の出力は、Submit-BEConvertBackupToVirtualJob コマンドと Add-BEConvertToVirtualStageBackupTask コマンドの TargetEnvironment パラメータとして使用されます。

Parameters

-VMwareVCenterServerName <String>

仮想マシンが作成される VMware vCenter サーバーの名前を指定します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VMwareHostName <String>

仮想マシンが作成される VMware vCenter 内のホストの名前を指定します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VMwareEsxServerName <String>

仮想マシンが作成される VMware ESX サーバーの名前を指定します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VMwareDataStoreName <String>

仮想マシンが作成される VMware ホストのデータストアの名前を指定します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VMwareVirtualMachineFolder <String>

仮想マシンが作成される VMware vCenter 内の仮想マシンフォルダのフォルダバスを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VMwareResourcePoolName <String>

VMware リソースプールの名前を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-HyperVServerName <String>

Microsoft Hyper-V サーバーの名前を指定します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-HyperVDestinationPath <String>

Microsoft Hyper-V 仮想マシンが作成されるディレクトリを指定します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LogonAccount <BELogonAccount>

ターゲット仮想環境にログインするために使用する Backup Exec ログオンアカウントを指定します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ToolsIsoPath <String>

VMware Tools または Hyper-V Integration Components の ISO イメージの絶対パスを指定します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

このコマンドレットは入力を受け入れません。

Return Value
BackupExec.Management.CLI.BEConvertToVirtualTargetEnvironment

指定した仮想環境への変換を表すオブジェクト。

Examples

Example 1

C:\PS> $targetEnvironment = New-BEConvertToVirtualTargetEnvironment -HyperVServerName hypervserver01 -HyperVDestinationPath c:\vms -LogonAccount "System Logon Account" -ToolsIsoPath c:\hypervtools.iso
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition BackupToDisk | Add-BEConvertToVirtualStageBackupTask -SimultaneouslyWithBackup -TargetEnvironment $targetEnvironment | Save-BEBackupDefinition

これらのコマンドは、バックアップジョブと同時に Hyper-V サーバー上で仮想マシンを作成する仮想ステージへの変換を持つバックアップ定義を作成します。

Example 2
C:\PS> $targetEnvironment = New-BEConvertToVirtualTargetEnvironment -VMwareVCenterServerName vcenterserver01 -VMwareHostName hostserver01 -VMwareDataStoreName datastore01 -LogonAccount "System Logon Account" -ToolsIsoPath c:\vmwaretools.iso
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition BackupToDisk | Add-BEConvertToVirtualStageBackupTask -SourceBackup AllBackups -Schedule (New-BESchedule -Weekdays -StartingAt 10PM) -TargetEnvironment $targetEnvironment | Save-BEBackupDefinition

これらのコマンドは、平日の毎日午後 10 時にバックアップジョブのいずれかから VMware vCenter 内に仮想マシンを作成する、仮想ステージへの変換を含むバックアップ定義を作成します。

Related Links

Submit-BEConvertBackupToVirtualJob
Add-BEConvertToVirtualStageBackupTask
Get-BEAgentServer
New-BEBackupDefinition
Save-BEBackupDefinition
New-BESchedule


New-BEDeduplicationDiskStorageDevice Help

New-BEDeduplicationDiskStorageDevice Cmdlet
Synopsis

Backup Exec の新しい重複排除用ディスクストレージデバイスを作成します。

Syntax
New-BEDeduplicationDiskStorageDevice [-Name] <String> [-StoragePath] <String> [-LogonAccount] <BELogonAccount> [-LogLevel {Minimal | Low | Normal | High | Full}] [-ClientSideDeduplicationEnabled <Boolean>] [-DataStreamSizeBytes <Int32>] [-LogRetentionDays <Int32>] [-EnableEncryption <Boolean>] [-BackupExecServer <BEBackupExecServer>] [-Description <String>] [-AllowedConcurrentOperations <Int32>] [-DiskSpaceReservePercent <Int64>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [-Force <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec の新しい重複排除用ディスクストレージデバイスを作成します。

Parameters

-BackupExecServer <BEBackupExecServer>

CASO 環境でデバイスを作成する Backup Exec サーバーを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-StoragePath <String>

ストレージボリュームのパスを指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-LogonAccount <BELogonAccount>

新しい重複排除用ストレージデバイスの Backup Exec ログオンアカウントを指定します。 このログオンアカウントにシステムログオンアカウントは使用できません。

Required | true
Position | 2
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

重複排除用ディスクストレージデバイスの説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskSpaceReservePercent <Int64>

Backup Exec 以外のアプリケーション用に予約するディスク領域の割合を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AllowedConcurrentOperations <Int32>

このデバイスで許容される最大許容同時並行処理数を設定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DataStreamSizeBytes <Int32>

Backup Exec が行う単一書き込み操作のサイズを示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ClientSideDeduplicationEnabled <Boolean>

クライアント側の重複排除をこの OpenStorage デバイスで有効にするかどうかを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LogLevel

このデバイスの診断ログに含めたい情報の種類を示します。

The valid values are:
Minimal
Low
Normal
High
Full

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LogRetentionDays <Int32>

ログファイルを保持する日数を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableEncryption <Boolean>

このデバイスに格納されたデータの暗号化を有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

新しい重複排除用ディスクストレージデバイスの名前を指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Force <SwitchParameter>

指定した Backup Exec サーバーがメモリの最小必要条件を満たしていない場合でも、重複排除用ディスクストレージデバイスの作成を強制します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

作成する Backup Exec の重複排除用ディスクストレージデバイスオブジェクトの名前を含む文字列を New-BEDeduplicationDiskStorageDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEDeduplicationDiskStorageDevice

New-BEDeduplicationDiskStorageDevice は作成された重複排除用ディスクストレージデバイスを返します。

Example

C:\PS> New-BEDeduplicationDiskStorageDevice -Name "Device 0001" -StoragePath "E:\pdde" -LogonAccount "Logon Account 0001"

このコマンドはパス「E:\pdde」とログオンアカウント「Logon Account 0001」を使用する「Device 0001」という名前の重複排除用デバイスを作成します。


New-BEDiskCartridgeDevice Help

New-BEDiskCartridgeDevice Cmdlet
Synopsis

Backup Exec の新しいディスクカートリッジデバイスを作成します。

Syntax
New-BEDiskCartridgeDevice [-Name] <String> [-DriveLetter] <String> [-LowDiskSpaceInformationThresholdPercent <Int32>] [-BufferSizeBytes <Int32>] [-LowDiskSpaceWarningThresholdPercent <Int32>] [-BufferedReadsWritesAutoDetectEnabled <Boolean>] [-LowDiskSpaceCriticalThresholdPercent <Int32>] [-Description <String>] [-BackupExecServer <BEBackupExecServer>] [-BlockSizeBytes <Int32>] [-MaximumFileSizeBytes <Int64>] [-BlockAndBufferSizeAutoDetectEnabled <Boolean>] [-PreallocationIncrementBytes <Int64>] [-PreallocationEnabled <Boolean>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec の新しいディスクカートリッジデバイスを作成します。

Parameters

-DriveLetter <String>

新規ディスクカートリッジデバイスのシステムドライブ文字を指定します。

Required | true
Position | 1
Accepts pipeline input | true (ByPropertyName)
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

CASO 環境でデバイスを作成する Backup Exec サーバーを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

ディスクカートリッジデバイスの説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MaximumFileSizeBytes <Int64>

ディスクストレージの最大ファイルサイズを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreallocationEnabled <Boolean>

増分するディスク容量の事前割り当てを有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreallocationIncrementBytes <Int64>

ファイルサイズを増やすために使用するディスク容量を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BlockAndBufferSizeAutoDetectEnabled <Boolean>

ディスクストレージのブロックサイズとバッファサイズに適した設定を自動的に検出するかどうかを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BlockSizeBytes <Int32>

新しいメディアに書き込まれるデータのブロックサイズをバイトで指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BufferSizeBytes <Int32>

読み取りまたは書き込み要求でディスクカートリッジに送信されるデータ量を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LowDiskSpaceInformationThresholdPercent <Int32>

初回のディスク容量低下アラートの 1 番目のしきい値制限を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LowDiskSpaceWarningThresholdPercent <Int32>

2 回目のディスク容量低下アラートの 2 番目のしきい値制限を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LowDiskSpaceCriticalThresholdPercent <Int32>

初回のディスク容量低下アラートに関する 3 番目と最後のしきい値の制限を指定します。ディスク空き領域を増やすように促されています。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BufferedReadsWritesAutoDetectEnabled <Boolean>

このディスクの設定を自動的に検出しないように指定し、読み取りバッファと書き込みバッファの使用を有効にします。 読み取りバッファと書き込みバッファとは、大きなデータブロックの読み取りと書き込みです。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

新しいディスクカートリッジデバイスの名前を指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

作成する Backup Exec ディスクカートリッジデバイスオブジェクトの名前を含む文字列を New-BEDiskCartridgeDevice にパイプ処理することができます。

Return Value
BackupExec.Management.CLI.BEDiskCartridgeDevice

New-BEDiskCartridgeDevice は作成されたディスクカートリッジデバイスを返します。

Example

C:\PS> New-BEDiskCartridgeDevice -Name "Device 0001" -DriveLetter E:

このコマンドはローカル Backup Exec サーバーのドライブ E に「Device 0001」という名前の新しいディスクカートリッジデバイスを作成します。


New-BEDiskStorageDevice Help

New-BEDiskStorageDevice Cmdlet
Synopsis

Backup Exec の新しいディスクストレージデバイスを作成します。

Syntax
New-BEDiskStorageDevice [-Name] <String> [-DriveLetter] <String> [-DiskSpaceReserveBytes <Int64>] [-VirtualWriteProtectionEnabled <Boolean>] [-BlockSizeBytes <Int32>] [-BufferSizeBytes <Int32>] [-BufferedReadsWritesAutoDetectEnabled <Boolean>] [-BlockAndBufferSizeAutoDetectEnabled <Boolean>] [-AllowedConcurrentWriteOperations <UInt32>] [-Description <String>] [-LowDiskSpaceInformationThresholdPercent <Int32>] [-PreallocationIncrementBytes <Int64>] [-BackupExecServer <BEBackupExecServer>] [-MaximumFileSizeBytes <Int64>] [-PreallocationEnabled <Boolean>] [-LowDiskSpaceWarningThresholdPercent <Int32>] [-LowDiskSpaceCriticalThresholdPercent <Int32>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

New-BEDiskStorageDevice [-Name] <String> [-UncPath] <String> [-DiskSpaceReserveBytes <Int64>] [-VirtualWriteProtectionEnabled <Boolean>] [-BlockSizeBytes <Int32>] [-BufferSizeBytes <Int32>] [-BufferedReadsWritesAutoDetectEnabled <Boolean>] [-BlockAndBufferSizeAutoDetectEnabled <Boolean>] [-AllowedConcurrentWriteOperations <UInt32>] [-Description <String>] [-LowDiskSpaceInformationThresholdPercent <Int32>] [-PreallocationIncrementBytes <Int64>] [-BackupExecServer <BEBackupExecServer>] [-MaximumFileSizeBytes <Int64>] [-PreallocationEnabled <Boolean>] [-LowDiskSpaceWarningThresholdPercent <Int32>] [-LowDiskSpaceCriticalThresholdPercent <Int32>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec の新しいディスクストレージデバイスを作成します。

Parameters

-DriveLetter <String>

新規ディスクデバイスのシステムドライブ文字を指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-UncPath <String>

新しいディスクデバイスの UNC パスを指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

CASO 環境でデバイスを作成する Backup Exec サーバーを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

ディスクストレージデバイスの説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LowDiskSpaceInformationThresholdPercent <Int32>

初回のディスク容量低下アラートに関する最初のしきい値の制限を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LowDiskSpaceWarningThresholdPercent <Int32>

2 回目のディスク容量低下アラートに関する 2 番目のしきい値制限を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LowDiskSpaceCriticalThresholdPercent <Int32>

初回のディスク容量低下アラートに関する 3 番目かつ最後のしきい値制限を指定します。すぐにディスク容量を増やすように要求されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MaximumFileSizeBytes <Int64>

ディスクストレージの最大ファイルサイズを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreallocationEnabled <Boolean>

事前割り当てを有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreallocationIncrementBytes <Int64>

ファイルサイズを増やすための容量を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BlockSizeBytes <Int32>

ディスクストレージデバイスに書き込まれるデータのブロックサイズをバイトで指定します。次の値が有効です: 1KB、4KB、8KB、16KB、32KB、64KB、128KB、256KB、512KB、および 1MB。BlockSizeBytes は BufferSizeBytes 以下である必要があります。BlockAndBufferSizeAutoDetectEnabled は BlockSizeBytes.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BufferSizeBytes <Int32>

読み取りまたは書き込み要求でディスクストレージデバイスに送信されるデータ量を指定します。次の値が有効です: 64KB、128KB、256KB、512KB および 1MB。BufferSizeBytes は BlockSizeBytes 以上である必要があります。BlockAndBufferSizeAutoDetectEnabled は BufferSizeBytes を無効にするために false である必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskSpaceReserveBytes <Int64>

Backup Exec 以外のアプリケーション用に空けてあるディスク領域を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualWriteProtectionEnabled <Boolean>

仮想書き込み保護を有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BlockAndBufferSizeAutoDetectEnabled <Boolean>

ディスクストレージのブロックサイズとバッファサイズに適した設定を自動的に検出するかどうかを指定します。これにより現在のセットのサイズが上書きされる場合があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AllowedConcurrentWriteOperations <UInt32>

ディスクへの書き込みの同時並行処理を許可します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BufferedReadsWritesAutoDetectEnabled <Boolean>

このディスクの設定を自動的に検出しないように指定し、読み取りバッファと書き込みバッファの使用を有効にします。 読み取りバッファと書き込みバッファとは、大きなデータブロックの読み取りと書き込みです。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

新しいディスクストレージデバイスの名前を指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

作成する Backup Exec ディスクストレージデバイスオブジェクトの名前を含む文字列を New-BEDiskStorageDevice にパイプ処理することができます。

Return Value
BackupExec.Management.CLI.BEDiskStorageDevice

New-BEDiskStorageDevice は作成されたディスクストレージデバイスを返します。

Example

C:\PS> New-BEDiskStorageDevice -Name "Device 0001" -DriveLetter E:

このコマンドはローカル Backup Exec サーバーのドライブ E に「Device 0001」という名前の新しいディスクストレージデバイスを作成します。


New-BEEncryptionKey Help

New-BEEncryptionKey Cmdlet
Synopsis

Backup Exec の新しい暗号化キーを作成します。

Syntax
New-BEEncryptionKey [-Name] <String> [-Passphrase] <SecureString> [-Salt <String>] [-EncryptionKeyType {Restricted | Common}] [-EncryptionType {Aes128Bit | Aes256BitSha2 | Aes256BitPbkdf2}] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec の新しい暗号化キーを作成します。

Parameters

-Passphrase <SecureString>

キーのパスフレーズを指定します。 128 ビット AES 暗号化の場合は、パスフレーズを 8 文字以上に設定する必要があります。 256 ビット AES 暗号化の場合は、パスフレーズを 16 文字以上に設定する必要があります。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionType

使用する暗号化アルゴリズムの種類を指定します。

The valid values are:
Aes128Bit
Aes256BitSha2
Aes256BitPbkdf2

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionKeyType

キーが共用か所有者専用かを指定します。 所有者専用キーでは、キーの所有者のみが暗号化されたデータをリストアできます。

The valid values are:
Restricted
Common

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Salt <String>

Salt を指定して暗号化キーを作成します。このスイッチは、Aes256PBKDF2 暗号化形式のみに適用できます。このオプションは、Backup Exec アラートで指定された Salt を使用して既存のキーをもう一度作成する場合にのみ使用してください。カタログまたはリストア操作中に Backup Exec がキーを見つけられない場合にのみ、Salt が必要になります。Salt の文字長は 48 文字で、16 進数値 (0 〜 9 および A 〜 F) のみを含める必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

新しい暗号化キーの名前を指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

作成する Backup Exec 暗号化キーオブジェクトの名前を含む文字列を New-BEEncryptionKey にパイプ処理することができます。

Return Value
BackupExec.Management.CLI.BEEncryptionKey

New-BEEncryptionKey は作成された暗号化キーを返します。

Examples

Example 1

C:\PS> $passphrase = ConvertTo-SecureString "P@ssW0rD!" -AsPlainText -Force
C:\PS> New-BEEncryptionKey -Name "Encryption Key 0001" -Passphrase $passphrase -EncryptionType Aes128Bit

これらのコマンドは安全な文字列を作成し、「Encryption Key 0001」という名前の暗号化キーを作成するためのパスフレーズとしてこの文字列を使用します。

Example 2
C:\PS> $passphrase = ConvertTo-SecureString "SampleBeP@ssW0rD!" -AsPlainText -Force
C:\PS> New-BEEncryptionKey -Name "Encryption Key 0001" -Passphrase $passphrase -EncryptionType Aes256BitPbkdf2 -Salt "3002197D13547052CFAA8025206221F516E3A57784B9304C"

これらのコマンドは安全な文字列を作成します。この文字列をパスフレーズとして使用し、Backup Exec で入力した Salt 「3002197D13547052CFAA8025206221F516E3A57784B9304C」を使用して「Encryption Key 0001」という名前の暗号化キーを作成します。


New-BEEnterpriseVaultComplianceAcceleratorSelection Help

New-BEEnterpriseVaultComplianceAcceleratorSelection Cmdlet
Synopsis

Enterprise Vault Compliance Accelerator の選択オブジェクトを作成します。

Syntax
New-BEEnterpriseVaultComplianceAcceleratorSelection [[-All] <String>] [-Exclude <SwitchParameter>] [<CommonParameters>]

New-BEEnterpriseVaultComplianceAcceleratorSelection [-Exclude <SwitchParameter>] [-CustomerDB <String>] [-ConfigurationDB <SwitchParameter>] [<CommonParameters>]
Description

Enterprise Vault Compliance Accelerator の選択オブジェクトを作成します。 これには構成データベースとカスタマデータベースが含まれます。

Parameters

-All <String>

すべての Enterprise Vault Compliance Accelerator データベースを含みます。このパラメータに有効な値は「*」のみです。

Required | false
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-ConfigurationDB <SwitchParameter>

構成データベースを含めます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CustomerDB <String>

選択するカスタマデータベースを指定します。すべてのサイトを指定するには「*」と入力します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Exclude <SwitchParameter>

BEEnterpriseVaultComplianceAcceleratorSelection パラメータの選択オブジェクトを除外します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

文字列オブジェクトを New-BEEnterpriseVaultComplianceAcceleratorSelection にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEEnterpriseVaultComplianceAcceleratorSelection

New-BEEnterpriseVaultComplianceAcceleratorSelection は BEEnterpriseVaultComplianceAcceleratorSelection オブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEAgentServer -Name "Compliance Accelerator on EVServer" | Submit-BEOnetimeBackupJob -EnterpriseVaultComplianceAcceleratorSelection *

このコマンドは、Enterprise Vault Compliance Accelerator のすべてのコンポーネントをバックアップするワンタイムバックアップジョブをサブミットします。

Example 2
C:\PS> Get-BEAgentServer -Name "Compliance Accelerator on EVServer" | Submit-BEOnetimeBackupJob -EnterpriseVaultComplianceAcceleratorSelection (New-BEEnterpriseVaultComplianceAcceleratorSelection -ConfigurationDB)

このコマンドは、Enterprise Vault Compliance Accelerator の構成データベースをバックアップするワンタイムバックアップジョブをサブミットします。

Example 3
C:\PS> Get-BEAgentServer -Name "Compliance Accelerator on EVServer" | Submit-BEOnetimeBackupJob -EnterpriseVaultComplianceAcceleratorSelection (New-BEEnterpriseVaultComplianceAcceleratorSelection -CustomerDB "CMCData")

このコマンドは、「CMCData」という名前の Enterprise Vault Compliance Accelerator のカスタマデータベースをバックアップするワンタイムバックアップジョブをサブミットします。

Example 4
C:\PS> Get-BEAgentServer -Name "Compliance Accelerator on EVServer" | Submit-BEOnetimeBackupJob -EnterpriseVaultComplianceAcceleratorSelection *, (New-BEEnterpriseVaultComplianceAcceleratorSelection -CustomerDB "CMCData")

このコマンドは、「CMCData」という名前の Enterprise Vault Compliance Accelerator のカスタマデータベースを除くすべてのコンポーネントをバックアップするワンタイムバックアップジョブをサブミットします。

Related Links


New-BEEnterpriseVaultDirectorySelection Help

New-BEEnterpriseVaultDirectorySelection Cmdlet
Synopsis

Enterprise Vault ディレクトリの選択オブジェクトを作成します。

Syntax
New-BEEnterpriseVaultDirectorySelection [[-All] <String>] [-Exclude <SwitchParameter>] [-VaultStore <String>] [-VaultStoreGroup <String>] [-Site <String>] [<CommonParameters>]

New-BEEnterpriseVaultDirectorySelection -DirectoryDB <SwitchParameter> [-Exclude <SwitchParameter>] [<CommonParameters>]

New-BEEnterpriseVaultDirectorySelection -AuditDB <SwitchParameter> [-Exclude <SwitchParameter>] [<CommonParameters>]

New-BEEnterpriseVaultDirectorySelection -MonitoringDB <SwitchParameter> [-Exclude <SwitchParameter>] [<CommonParameters>]

New-BEEnterpriseVaultDirectorySelection -FSAReportingDB <SwitchParameter> [-Exclude <SwitchParameter>] [<CommonParameters>]

New-BEEnterpriseVaultDirectorySelection -PartitionState {None | Open | Closed | Ready | All} -Site <String> -VaultStoreGroup <String> -VaultStore <String> [-PartitionName <String>] [-Exclude <SwitchParameter>] [<CommonParameters>]

New-BEEnterpriseVaultDirectorySelection -FingerPrintDB <SwitchParameter> -Site <String> -VaultStoreGroup <String> [-Exclude <SwitchParameter>] [<CommonParameters>]

New-BEEnterpriseVaultDirectorySelection -IndexLocation <String> -Site <String> [-Exclude <SwitchParameter>] [<CommonParameters>]

New-BEEnterpriseVaultDirectorySelection -VaultStoreDB <SwitchParameter> -VaultStore <String> -Site <String> -VaultStoreGroup <String> [-Exclude <SwitchParameter>] [<CommonParameters>]
Description

Enterprise Vault ディレクトリの選択オブジェクトを作成します。 選択オブジェクトにはディレクトリデータベース、監査データベース、監視データベース、
FSA レポートデータベース,、Enterprise Vault サイト、ボルトストアグループ、ボルトストア、パーティション、ボルトストアデータベース、フィンガープリントデータベースおよびインデックスの場所が含まれる可能性があります。

Parameters

-All <String>

すべての Enterprise Vault のコンポーネントを含めます。このパラメータに有効な値は「*」のみです。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-DirectoryDB <SwitchParameter>

ディレクトリデータベースを含めます。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AuditDB <SwitchParameter>

監査データベースを含めます。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MonitoringDB <SwitchParameter>

監視データベースを含めます。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FSAReportingDB <SwitchParameter>

FSAReporting データベースを含めます。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Site <String>

選択する Enterprise Vault サイトを指定します。

Required | false
Position | Named
Accepts pipeline input | true (ByPropertyName)
Accepts wildcard characters | false

-VaultStoreGroup <String>

選択する Enterprise Vault のボルトストアグループを指定します。

Required | false
Position | Named
Accepts pipeline input | true (ByPropertyName)
Accepts wildcard characters | false

-VaultStore <String>

選択する Enterprise Vault のボルトストアを指定します。

Required | false
Position | Named
Accepts pipeline input | true (ByPropertyName)
Accepts wildcard characters | false

-PartitionState

バックアップするパーティション状態を指定します。値にはすべて、オープン、準備完了、クローズが含まれます。

The valid values are:
None
Open
Closed
Ready
All

Required | true
Position | Named
Accepts pipeline input | true (ByPropertyName)
Accepts wildcard characters | false

-PartitionName <String>

選択するパーティション名を指定します。

Required | false
Position | Named
Accepts pipeline input | true (ByPropertyName)
Accepts wildcard characters | false

-FingerPrintDB <SwitchParameter>

選択したボルトストアグループ内のフィンガープリントデータベースが含まれます。

Required | true
Position | Named
Accepts pipeline input | true (ByPropertyName)
Accepts wildcard characters | false

-VaultStoreDB <SwitchParameter>

選択したボルトストア内のボルトストアデータベースが含まれます。

Required | true
Position | Named
Accepts pipeline input | true (ByPropertyName)
Accepts wildcard characters | false

-IndexLocation <String>

選択するインデックスの場所を指定します。すべてのインデックスの場所を指定するには「*」と入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByPropertyName)
Accepts wildcard characters | false

-Exclude <SwitchParameter>

BEEnterpriseVaultDirectorySelection パラメータの選択オブジェクトを除外します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

文字列オブジェクトを New-BEEnterpriseVaultDirectorySelection にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEEnterpriseVaultDirectorySelection

New-BEEnterpriseVaultDirectorySelection は BEEnterpriseVaultDirectorySelection オブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEAgentServer -Name "Directory on EVServer" | Submit-BEOnetimeBackupJob -EnterpriseVaultDirectorySelection *

このコマンドは、Enterprise Vault ディレクトリサーバーのすべてのコンポーネントをバックアップするワンタイムバックアップジョブをサブミットします。

Example 2
C:\PS> Get-BEAgentServer -Name "Directory on EVServer" | Submit-BEOnetimeBackupJob -EnterpriseVaultDirectorySelection (New-BEEnterpriseVaultDirectorySelection -DirectoryDB)

このコマンドは、Enterprise Vault ディレクトリサーバーのディレクトリデータベースをバックアップするワンタイムバックアップジョブをサブミットします。

Example 3
C:\PS> Get-BEAgentServer -Name "Directory on EVServer" | Submit-BEOnetimeBackupJob -EnterpriseVaultDirectorySelection (New-BEEnterpriseVaultDirectorySelection -AuditDB)

このコマンドは、Enterprise Vault ディレクトリサーバーの監査データベースをバックアップするワンタイムバックアップジョブをサブミットします。

Example 4
C:\PS> Get-BEAgentServer -Name "Directory on EVServer" | Submit-BEOnetimeBackupJob -EnterpriseVaultDirectorySelection (New-BEEnterpriseVaultDirectorySelection -Site "EVSite1")

このコマンドは、「EVSite1」という名前の Enterprise Vault ディレクトリサーバーのサイトをバックアップするワンタイムバックアップジョブをサブミットします。

Example 5
C:\PS> Get-BEAgentServer -Name "Directory on EVServer" | Submit-BEOnetimeBackupJob -EnterpriseVaultDirectorySelection (New-BEEnterpriseVaultDirectorySelection -Site "SiteA" -VaultStoreGroup "Group1" -VaultStore "Store1")

このコマンドは、「Site1」という名前のサイトで「Group1」という名前のボルトストアグループ内にある「Store1」という名前の Enterprise Vault ディレクトリサーバーのボルトストアをバックアップするワンタイムバックアップジョブをサブミットします。

Example 6
C:\PS> Get-BEAgentServer -Name "Directory on EVServer" | Submit-BEOnetimeBackupJob -EnterpriseVaultDirectorySelection (New-BEEnterpriseVaultDirectorySelection -Site "SiteA" -VaultStoreGroup "Group1" -VaultStore "Store1" -PartitionState Closed)

このコマンドは、「Site1」という名前のサイトで「Group1」という名前のボルトストアグループ内にある「Store1」という名前のボルトストアの Enterprise Vault ディレクトリサーバーのクローズパーティションをすべてバックアップするワンタイムバックアップジョブをサブミットします。

Example 7
C:\PS> Get-BEAgentServer -Name "Directory on EVServer" | Submit-BEOnetimeBackupJob -EnterpriseVaultDirectorySelection (New-BEEnterpriseVaultDirectorySelection -Site "SiteA" -VaultStoreGroup "Group1" -VaultStore "Store1" -PartitionState Closed -PartitionName "ClsdPtn")

このコマンドは、「Site1」という名前のサイトで「Group1」という名前のボルトストアグループ内にある「Store1」という名前のボルトストアの、「ClsdPtn」という名前の Enterprise Vault ディレクトリサーバーのクローズパーティションをバックアップするワンタイムバックアップジョブをサブミットします。

Example 8
C:\PS> Get-BEAgentServer -Name "Directory on EVServer" | Submit-BEOnetimeBackupJob -EnterpriseVaultDirectorySelection (New-BEEnterpriseVaultDirectorySelection -Site "SiteA" -IndexLocation "Index4")

このコマンドは、「Site1」という名前のサイトで「Index4」という名前の Enterprise Vault ディレクトリサーバーのインデックスの場所をバックアップするワンタイムバックアップジョブをサブミットします。

Example 9
C:\PS> Get-BEAgentServer -Name "Directory on EVServer" | Submit-BEOnetimeBackupJob -EnterpriseVaultDirectorySelection *, (New-BEEnterpriseVaultDirectorySelection -Site "EVSIte1" -Exclude)

このコマンドは、「EVSite1」という名前のサイトを除く、Enterprise Vault ディレクトリサーバーのすべてのコンポーネントをバックアップするワンタイムバックアップジョブをサブミットします。

Related Links


New-BEEnterpriseVaultDiscoveryAcceleratorSelection Help

New-BEEnterpriseVaultDiscoveryAcceleratorSelection Cmdlet
Synopsis

Enterprise Vault Discovery Accelerator の選択オブジェクトを作成します。

Syntax
New-BEEnterpriseVaultDiscoveryAcceleratorSelection [[-All] <String>] [-Exclude <SwitchParameter>] [<CommonParameters>]

New-BEEnterpriseVaultDiscoveryAcceleratorSelection [-CustodianDB <String>] [-Exclude <SwitchParameter>] [-ConfigurationDB <SwitchParameter>] [-CustomerDB <String>] [<CommonParameters>]
Description

Enterprise Vault Discovery Accelerator の選択オブジェクトを作成します。 これには構成データベースとカスタマデータベースが含まれます。

Parameters

-All <String>

すべての Enterprise Vault Discovery Accelerator データベースを含めます。このパラメータに有効な値は「*」のみです。

Required | false
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-ConfigurationDB <SwitchParameter>

構成データベースを含めます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CustomerDB <String>

選択するカスタマデータベースを指定します。すべてのカスタマデータベースを指定するには「*」と入力します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CustodianDB <String>

選択するカストディアンデータベースを指定します。すべてのカストディアンデータベースを指定するには「*」と入力します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Exclude <SwitchParameter>

BEEnterpriseVaultDiscoveryAcceleratorSelection パラメータの選択オブジェクトを除外します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

文字列オブジェクトを New-BEEnterpriseVaultDiscoveryAcceleratorSelection にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEEnterpriseVaultDiscoveryAcceleratorSelection

New-BEEnterpriseVaultDiscoveryAcceleratorSelection は BEEnterpriseVaultDiscoveryAcceleratorSelection オブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEAgentServer -Name "Discovery Accelerator on EVServer" | Submit-BEOnetimeBackupJob -EnterpriseVaultDiscoveryAcceleratorSelection *

このコマンドは、Enterprise Vault Discovery Accelerator のすべてのコンポーネントをバックアップするワンタイムバックアップジョブをサブミットします。

Example 2
C:\PS> Get-BEAgentServer -Name "Discovery Accelerator on EVServer" | Submit-BEOnetimeBackupJob -EnterpriseVaultDiscoveryAcceleratorSelection (New-BEEnterpriseVaultDiscoveryAcceleratorSelection -ConfigurationDB)

このコマンドは、Enterprise Vault Discovery Accelerator の構成データベースをバックアップするワンタイムバックアップジョブをサブミットします。

Example 3
C:\PS> Get-BEAgentServer -Name "Discovery Accelerator on EVServer" | Submit-BEOnetimeBackupJob -EnterpriseVaultDiscoveryAcceleratorSelection (New-BEEnterpriseVaultDiscoveryAcceleratorSelection -CustodianDB "CMCData")

このコマンドは、「CMCData」という名前の Enterprise Vault Discovery Accelerator のカストディアンデータベースをバックアップするワンタイムバックアップジョブをサブミットします。

Example 4
C:\PS> Get-BEAgentServer -Name "Discovery Accelerator on EVServer" | Submit-BEOnetimeBackupJob -EnterpriseVaultDiscoveryAcceleratorSelection *, (New-BEEnterpriseVaultDiscoveryAcceleratorSelection -CustomerDB "CMCData")

このコマンドは、「CMCData」という名前の Enterprise Vault Discovery Accelerator のカスタマデータベースを除くすべてのコンポーネントをバックアップするワンタイムバックアップジョブをサブミットします。

Related Links


New-BEExchangeDatabaseSelection Help

New-BEExchangeDatabaseSelection Cmdlet
Synopsis

Exchange 2010 データベースのバックアップ選択項目オブジェクトを作成します。

Syntax
New-BEExchangeDatabaseSelection [[-DatabaseName] <String>] [-Exclude <SwitchParameter>] [<CommonParameters>]
Description

Exchange 2010 データベースのバックアップ選択項目オブジェクトを作成します。

Parameters

-DatabaseName <String>

データベースの名前を指定します。 使用可能なすべてのデータベースを指定するには「*」と入力します。

Required | false
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Exclude <SwitchParameter>

-DatabaseName パラメータで指定したデータベース選択項目を除外します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

文字列オブジェクトを New-BEExchangeDatabaseSelection にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEExchangeDatabaseSelection

New-BEExchangeDatabaseSelection は BEExchangeDatabaseSelection オブジェクトを返します。

Examples

Example 1

C:\PS> $x = New-BEExchangeDatabaseSelection -DatabaseName "Database1"
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition -BackupJobDefault BackupToDisk -ExchangeDatabaseSelection $x | Save-BEBackupDefinition

これらのコマンドは「BackupToDisk」ジョブデフォルト設定を使用してローカルコンピュータに「Database1」という名前の Exchange データベースをバックアップするバックアップ定義を作成します。

Example 2
C:\PS> $x = "Database1" | New-BEExchangeDatabaseSelection
C:\PS> Get-BEAgentServer -Local | Submit-BEOnetimeBackupJob -ExchangeDatabaseSelection $x

これらのコマンドはローカルコンピュータに「Database1」という名前の Exchange データベースをバックアップするワンタイムバックアップジョブをサブミットします。

Related Links


New-BEExchangeStorageGroupDatabaseSelection Help

New-BEExchangeStorageGroupDatabaseSelection Cmdlet
Synopsis

Microsoft Exchange 2003 または 2007 データベースのバックアップ選択項目オブジェクトを作成します。

Syntax
New-BEExchangeStorageGroupDatabaseSelection [[-StorageGroupName] <String>] [[-DatabaseName] <String>] [-Exclude <SwitchParameter>] [<CommonParameters>]
Description

Microsoft Exchange 2003 または 2007 データベースのバックアップ選択項目オブジェクトを作成します。

Parameters

-StorageGroupName <String>

ストレージグループの名前を指定します。 使用可能なすべてのストレージグループを指定するには「*」と入力します。

Required | false
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-DatabaseName <String>

データベースの名前を指定します。 使用可能なすべてのデータベースを指定するには「*」と入力します。

Required | false
Position | 1
Accepts pipeline input | true (ByPropertyName)
Accepts wildcard characters | false

-Exclude <SwitchParameter>

-StorageGroupName パラメータや -DatabaseName パラメータで指定したストレージグループまたはデータベース選択項目を除外します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

文字列オブジェクトを New-BEExchangeStorageGroupDatabaseSelection にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEExchangeStorageGroupDatabaseSelection

New-BEExchangeStorageGroupDatabaseSelection は BEExchangeStorageGroupDatabaseSelection オブジェクトを返します。

Examples

Example 1

C:\PS> $x = New-BEExchangeStorageGroupDatabaseSelection -StorageGroupName "StorageGroup1" -DatabaseName "Database1"
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition -BackupJobDefault BackupToDisk -ExchangeStorageGroupDatabaseSelection $x | Save-BEBackupDefinition

これらのコマンドは「BackupToDisk」ジョブのデフォルト設定を使用して、ローカルコンピュータの「StorageGroup1」という名前のストレージグループに「Database1」という名前の Exchange データベースをバックアップするバックアップ定義を作成します。

Example 2
C:\PS> $x = "StorageGroup1" | New-BEExchangeStorageGroupDatabaseSelection -Database "Database1"
C:\PS> Get-BEAgentServer -Local | Submit-BEOnetimeBackupJob -ExchangeStorageGroupDatabaseSelection $x

これらのコマンドはローカルコンピュータの「StorageGroup1」という名前のストレージグループに「Database1」という名前の Exchange データベースをバックアップするワンタイムバックアップジョブをサブミットします。

Related Links


New-BEFileSystemSelection Help

New-BEFileSystemSelection Cmdlet
Synopsis

NTFS ファイルシステム選択項目のバックアップ選択項目オブジェクトを作成します。

Syntax
New-BEFileSystemSelection [-Path] <String> [-IncludeOnlyModifiedFiles <SwitchParameter>] [-IncludeOnlyReadOnlyFiles <SwitchParameter>] [-NumberOfDaysFilesNotAccessed <Int32>] [-PathIsDirectory <SwitchParameter>] [-Recurse <SwitchParameter>] [-Exclude <SwitchParameter>] [<CommonParameters>]

New-BEFileSystemSelection [-Path] <String> -FromDate <DateTime> [-IncludeOnlyReadOnlyFiles <SwitchParameter>] [-NumberOfDaysFilesNotAccessed <Int32>] [-ToDate <DateTime>] [-Recurse <SwitchParameter>] [-PathIsDirectory <SwitchParameter>] [-IncludeOnlyModifiedFiles <SwitchParameter>] [-Exclude <SwitchParameter>] [<CommonParameters>]
Description

NTFS ファイルシステム選択項目のバックアップ選択項目オブジェクトを作成します。

Parameters

-Path <String>

選択するファイルシステムのフォルダまたはファイルのパスを指定します (ワイルドカードを使用可能)。

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-PathIsDirectory <SwitchParameter>

Path パラメータの値がファイルではなくディレクトリであることを指定します。

Required | false
Position | Named
Accepts pipeline input | true (ByPropertyName)
Accepts wildcard characters | false

-Recurse <SwitchParameter>

すべてのサブフォルダを選択するように指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Exclude <SwitchParameter>

-Path パラメータで指定したファイルシステム選択項目を除外します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IncludeOnlyModifiedFiles <SwitchParameter>

最後のバックアップジョブ以降に修正されたファイルのみを選択するように指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IncludeOnlyReadOnlyFiles <SwitchParameter>

読み取り専用ファイルを選択するように指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FromDate <DateTime>

DateTime オブジェクトを指定して、タイムスタンプが指定した DateTime より後のファイルをフィルタ処理します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ToDate <DateTime>

DateTime オブジェクトを指定して、タイムスタンプが指定した DateTime より前のファイルをフィルタ処理します。FromDate パラメータが指定されていて ToDate パラメータが指定されていない場合、ToDate パラメータは自動的に当日の午後 11:59:59 に設定されます。FromDate パラメータは ToDate パラメータより前に設定される必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NumberOfDaysFilesNotAccessed <Int32>

日数を指定して、アクセスしたことのないファイルをフィルタ処理します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

文字列オブジェクトを New-BEFileSystemSelection にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEFileSystemSelection

New-BEFileSystemSelection は BEFileSystemSelection オブジェクトを返します。

Examples

Example 1

C:\PS> $x = New-BEFileSystemSelection -Path "C:\*" -Recurse
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition -BackupJobDefault BackupToDisk -FileSystemSelection $x | Save-BEBackupDefinition

これらのコマンドは「BackupToDisk」ジョブデフォルト設定を使用してローカルコンピュータの C: ボリュームをバックアップするバックアップ定義を作成します。

Example 2
C:\PS> $x = "C:\Windows\*" | New-BEFileSystemSelection -Recurse -Exclude
C:\PS> Get-BEAgentServer -Local | Submit-BEOnetimeBackupJob -FileSystemSelection $x

これらのコマンドは C:\Windows ディレクトリを除いてローカルコンピュータのすべてのデータをバックアップするワンタイムバックアップをサブミットします。

Related Links


New-BEHyperVSelection Help

New-BEHyperVSelection Cmdlet
Synopsis

Microsoft Hyper-V 仮想マシンのバックアップ選択項目オブジェクトを作成します。

Syntax
New-BEHyperVSelection [-VirtualMachineName] <String> [-Exclude <SwitchParameter>] [<CommonParameters>]

New-BEHyperVSelection [-VirtualMachineName] <String> [-Exclude <SwitchParameter>] [<CommonParameters>]

New-BEHyperVSelection -IncludeInitialStore <SwitchParameter> [<CommonParameters>]
Description

Microsoft Hyper-V 仮想マシンのバックアップ選択項目オブジェクトを作成します。

Parameters

-VirtualMachineName <String>

Microsoft Hyper-V 仮想マシン名を指定します。使用可能なすべての Hyper-V 仮想マシンを指定するには「*」と入力します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-IncludeInitialStore <SwitchParameter>

Hyper-V 初期ストアを含めます。

Required | true
Position | Named
Accepts pipeline input | true (ByPropertyName)
Accepts wildcard characters | false

-Exclude <SwitchParameter>

-Path パラメータで指定した Hyper-V 仮想マシンを除外します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

このコマンドレットは入力を受け入れません。

Return Value
BackupExec.Management.CLI.BEHyperVSelection

New-BEHyperVSelection は BEHyperVSelection オブジェクトを返します。

Examples

Example 1

C:\PS> $x = New-BEHyperVSelection *
C:\PS> Get-BEAgentServer "HyperVHost" | New-BEBackupDefinition -BackupJobDefault BackupToDisk -HyperVSelection $x | Save-BEBackupDefinition

これらのコマンドは「BackupToDisk」ジョブのデフォルト設定を使用して、「HyperVHost」という名前の Windows サーバー上のすべての仮想マシンをバックアップするバックアップ定義を作成します。

Example 2
C:\PS> $x = New-BEHyperVSelection VM01
C:\PS> Get-BEAgentServer "HyperVHost" | New-BEBackupDefinition -BackupJobDefault BackupToDisk -HyperVSelection $x | Save-BEBackupDefinition

これらのコマンドは「BackupToDisk」ジョブのデフォルト設定を使用して、「HyperVHost」という名前の Windows サーバー上の「VM01」という名前の仮想マシンをバックアップするバックアップ定義を作成します。

Example 3
C:\PS> $x = (New-BEHyperVSelection *),(NEW-BEHyperVSelection VM01 -Exclude)
C:\PS> Get-BEAgentServer "HyperVHost" | New-BEBackupDefinition -BackupJobDefault BackupToDisk -HyperVSelection $x | Save-BEBackupDefinition

これらのコマンドは「BackupToDisk」ジョブのデフォルト設定を使用して、「HyperVHost」という名前の Windows サーバー上の「VM01」という名前の仮想マシンを除くすべての仮想マシンをバックアップするバックアップ定義を作成します。

Related Links


New-BELinuxMacSelection Help

New-BELinuxMacSelection Cmdlet
Synopsis

Linux サーバーと Macintosh システムのバックアップ選択項目オブジェクトを作成します。

Syntax
New-BELinuxMacSelection [-Path] <String> [-IncludeOnlyModifiedFiles <SwitchParameter>] [-IncludeOnlyReadOnlyFiles <SwitchParameter>] [-NumberOfDaysFilesNotAccessed <Int32>] [-PathIsDirectory <SwitchParameter>] [-Recurse <SwitchParameter>] [-Exclude <SwitchParameter>] [<CommonParameters>]

New-BELinuxMacSelection [-Path] <String> -FromDate <DateTime> [-IncludeOnlyReadOnlyFiles <SwitchParameter>] [-NumberOfDaysFilesNotAccessed <Int32>] [-ToDate <DateTime>] [-Recurse <SwitchParameter>] [-PathIsDirectory <SwitchParameter>] [-IncludeOnlyModifiedFiles <SwitchParameter>] [-Exclude <SwitchParameter>] [<CommonParameters>]
Description

Linux サーバーと Macintosh システムのバックアップ選択項目オブジェクトを作成します。

Parameters

-Path <String>

選択するファイルシステムのフォルダまたはファイルのパスを指定します (ワイルドカードを使用可能)。

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-PathIsDirectory <SwitchParameter>

Path パラメータの値がファイルではなくディレクトリであることを指定します。

Required | false
Position | Named
Accepts pipeline input | true (ByPropertyName)
Accepts wildcard characters | false

-Recurse <SwitchParameter>

すべてのサブフォルダを選択するように指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Exclude <SwitchParameter>

-Path パラメータで指定したファイルシステム選択項目を除外します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IncludeOnlyModifiedFiles <SwitchParameter>

最後のバックアップジョブ以降に修正されたファイルのみを選択するように指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IncludeOnlyReadOnlyFiles <SwitchParameter>

読み取り専用ファイルを選択するように指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FromDate <DateTime>

DateTime オブジェクトを指定して、タイムスタンプが指定した DateTime より後のファイルをフィルタ処理します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ToDate <DateTime>

DateTime オブジェクトを指定して、タイムスタンプが指定した DateTime より前のファイルをフィルタ処理します。FromDate パラメータが指定されていて ToDate パラメータが指定されていない場合、ToDate パラメータは自動的に当日の午後 11:59:59 に設定されます。FromDate パラメータは ToDate パラメータより前に設定される必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NumberOfDaysFilesNotAccessed <Int32>

日数を指定して、アクセスしたことのないファイルをフィルタ処理します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

文字列オブジェクトを New-BELinuxMacSelection にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BELinuxMacSelection

New-BELinuxMacSelection は、BELinuxMacSelection オブジェクトを返します。

Examples

Example 1

C:\PS> $x = New-BELinuxMacSelection -Path "/opt/*" -Recurse
C:\PS> Get-BEAgentServer -Name LinuxMacMachine | New-BEBackupDefinition -BackupJobDefault BackupToDisk -LinuxMacSelection $x | Save-BEBackupDefinition

これらのコマンドは「BackupToDisk」ジョブデフォルト設定を使用して LinuxMacMachine コンピュータの /opt ディレクトリをバックアップするバックアップ定義を作成します。

Example 2
C:\PS> $x = "/opt/lib/*" | New-BELinuxMacSelection -Recurse -Exclude
C:\PS> Get-BEAgentServer -Name LinuxMacMachine | Submit-BEOnetimeBackupJob -LinuxMacSelection $x

これらのコマンドは /opt/lib ディレクトリを除いて LinuxMacMachine コンピュータのすべてのデータをバックアップするワンタイムバックアップジョブをサブミットします。

Related Links


New-BELogonAccount Help

New-BELogonAccount Cmdlet
Synopsis

新しい Backup Exec ログオンアカウントを作成します。

Syntax
New-BELogonAccount [[-Name] <String>] -Credential <PSCredential> [-Description <String>] [-AccountType {Restricted | Common}] [-UserDefault <SwitchParameter>] [-SystemLogonAccount <SwitchParameter>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

New-BELogonAccount [[-Name] <String>] -UserName <String> -Password <SecureString> [-Description <String>] [-AccountType {Restricted | Common}] [-UserDefault <SwitchParameter>] [-SystemLogonAccount <SwitchParameter>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

新しい Backup Exec ログオンアカウントを作成します。

Parameters

-Name <String>

新しいログオンアカウントの名前を指定します。

Required | false
Position | 0
Accepts pipeline input | true (ByPropertyName)
Accepts wildcard characters | false

-Credential <PSCredential>

ログオンアカウントのクレデンシャルを指定します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UserName <String>

ログオンアカウントのユーザー名を指定します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Password <SecureString>

ログオンアカウントのパスワードを指定します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SystemLogonAccount <SwitchParameter>

システムログオンアカウントを作成します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UserDefault <SwitchParameter>

アカウントがデフォルトのログインアカウントであることを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

ログオンアカウントの説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AccountType

これが共有アカウントであるか、所有者専用アカウントであるかを指定します。

The valid values are:
Restricted
Common

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

このコマンドレットは入力を受け入れません。

Return Value
BackupExec.Management.CLI.BELogonAccount

New-BELogonAccount は、作成されたログオンアカウントを返します。

Examples

Example 1

C:\PS> $credential = Get-Credential
C:\PS> New-BELogonAccount -Credential $credential

これらのコマンドは、Get-Credential から受け取ったクレデンシャルを使用して、新しい Backup Exec ログオンアカウントを作成します。

Example 2
C:\PS> $password = ConvertTo-SecureString "P@ssW0rD!" -AsPlainText -Force
C:\PS> New-BELogonAccount -UserName "mydomain\myuser" -Password $password

これらのコマンドは、ユーザー名とパスワードを指定することによって新しい Backup Exec ログオンアカウントを作成します。


New-BEMediaSet Help

New-BEMediaSet Cmdlet
Synopsis

Backup Exec に新しいメディアセットを作成します。

Syntax
New-BEMediaSet [-Name] <String> [-ReturnFromVaultPeriodHours <Int32>] [-MoveToVaultPeriodHours <Int32>] [-OverwriteProtectionPeriodHours <Int32>] [-Description <String>] [-MediaVault <BEMediaVault>] [-AppendPeriodHours <Int32>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec に新しいメディアセットを作成します。

Parameters

-Description <String>

メディアセットの説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OverwriteProtectionPeriodHours <Int32>

データが上書きされるまで、特定のメディアにそのデータが保持される期間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AppendPeriodHours <Int32>

メディアにデータを追加できる期間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MediaVault <BEMediaVault>

このメディアセットに関連付けられているメディアを送信する Backup Exec メディアボルトを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MoveToVaultPeriodHours <Int32>

メディアをこのボルトに移動可能であるとレポートされるまでの時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ReturnFromVaultPeriodHours <Int32>

メディアをこのボルトから返すことが可能であると報告されるまでの時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

新しいメディアセットの名前を指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

作成する Backup Exec メディアセットオブジェクトの名前を含む文字列を New-BEMediaSet にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEMediaSet

New-BEMediaSet は、作成されたメディアセットを返します。

Example

C:\PS> New-BEMediaSet -Name "Media Set 0001"

このコマンドは「Media Set 0001」という名前の新しいメディアセットを作成します。


New-BEMediaVault Help

New-BEMediaVault Cmdlet
Synopsis

Backup Exec に新しいメディアボルトを作成します。

Syntax
New-BEMediaVault [-Name] <String> [-Description <String>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec に新しいメディアボルトを作成します。

Parameters

-Description <String>

メディアボルトの説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

新しいメディアボルトの名前を指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

作成する Backup Exec メディアボルトオブジェクトの名前を含む文字列を New-BEMediaVault にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEMediaVault

New-BEMediaVault は、作成されたメディアボルトを返します。

Example

C:\PS> New-BEMediaVault -Name "Media Vault 0001"

このコマンドは「Media Vault 0001」という名前の新しいメディアボルトを作成します。


New-BENdmpEMCServerSelection Help

New-BENdmpEMCServerSelection Cmdlet
Synopsis

EMC NDMP サーバーのバックアップ選択項目オブジェクトを作成します。

Syntax
New-BENdmpEMCServerSelection [-Volume] <String> [[-Exclude] <SwitchParameter>] [[-Recurse] <SwitchParameter>] [-Path] <String> [<CommonParameters>]

New-BENdmpEMCServerSelection [-Volume] <String> [-FilePatternToExclude] <String> [<CommonParameters>]
Description

EMC NDMP サーバーのバックアップ選択項目オブジェクトを作成します。

Parameters

-Path <String>

バックアップするデータのディレクトリパスです。

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-Volume <String>

バックアップする EMC NDMP サーバーのボリュームを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Recurse <SwitchParameter>

すべてのサブフォルダを選択するように指定します。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-Exclude <SwitchParameter>

-Path パラメータで指定した EMC NDMP サーバー選択項目を除外します。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-FilePatternToExclude <String>

バックアップジョブから除外するファイル名 (ワイルドカードを使用可能) のパターン。

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

このコマンドレットは入力を受け入れません。

Return Value
BackupExec.Management.CLI.BENdmpEMCServerSelection

New-BENdmpEMCServerSelection は、BENdmpEMCServerSelection オブジェクトを返します。

Examples

Example 1

C:\PS> $x = New-BENdmpEMCServerSelection -Volume "vol1" -Path "/testfolder" -Recurse:$true
C:\PS> Get-BEAgentServer "EMCServer" | New-BEBackupDefinition -BackupJobDefault BackupToDisk | Add-BEBackupSelection $x | Save-BEBackupDefinition

これらのコマンドは「BackupToDisk」ジョブデフォルト設定を使用して「/testfolder」パスおよび EMC NDMP サーバーのボリューム「vol1」にあるすべてのサブフォルダをバックアップするバックアップ定義を作成します。

Example 2
C:\PS> $x = New-BENdmpEMCServerSelection -Volume "vol1" -FilePatternToExclude "*.tmp"
C:\PS> Get-BEAgentServer "EMCServer" | New-BEBackupDefinition -BackupJobDefault BackupToDisk | Add-BEBackupSelection $x | Save-BEBackupDefinition

これらのコマンドは「BackupToDisk」ジョブデフォルト設定を使用して EMC NDMP サーバーのパターン「*.tmp」、ボリューム「vol1」のすべてのファイルを除外するバックアップ定義を作成します。

Related Links


New-BENdmpNetAppServerSelection Help

New-BENdmpNetAppServerSelection Cmdlet
Synopsis

NetApp NDMP サーバーのバックアップ選択項目オブジェクトを作成します。

Syntax
New-BENdmpNetAppServerSelection [-Volume] <String> [[-Recurse] <SwitchParameter>] [-Path] <String> [<CommonParameters>]

New-BENdmpNetAppServerSelection [-Volume] <String> [-FilePatternToExclude] <String> [<CommonParameters>]
Description

NetApp NDMP サーバーのバックアップ選択項目オブジェクトを作成します。

Parameters

-Path <String>

バックアップするデータのディレクトリパスです。

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-Volume <String>

バックアップする NetApp NDMP サーバーのボリュームを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Recurse <SwitchParameter>

すべてのサブフォルダを選択するように指定します。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-FilePatternToExclude <String>

バックアップから除外するファイル名 (ワイルドカードを使用可能) のパターン。

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

このコマンドレットは入力を受け入れません。

Return Value
BackupExec.Management.CLI.BENdmpNetAppServerSelection

New-BENdmpNetAppServerSelection は、BENdmpNetAppServerSelection オブジェクトを返します。

Examples

Example 1

C:\PS> $x = New-BENdmpNetAppServerSelection -Volume "/vol/vol1" -Path "/testfolder" -Recurse:$true
C:\PS> Get-BEAgentServer "NetAppServer" | New-BEBackupDefinition -BackupJobDefault BackupToDisk | Add-BEBackupSelection $x | Save-BEBackupDefinition

これらのコマンドは「BackupToDisk」ジョブデフォルト設定を使用して「/testfolder」パスおよび NetApp NDMP サーバーのボリューム「vol/vol1」にあるすべてのサブフォルダをバックアップするバックアップ定義を作成します。

Example 2
C:\PS> $x = New-BENdmpNetAppServerSelection -Volume "/vol/vol1" -FilePatternToExclude "*.tmp"
C:\PS> Get-BEAgentServer "NetAppServer" | New-BEBackupDefinition -BackupJobDefault BackupToDisk | Add-BEBackupSelection $x | Save-BEBackupDefinition

これらのコマンドは「BackupToDisk」ジョブデフォルト設定を使用して NetApp NDMP サーバーのパターン「*.tmp」、ボリューム「vol1」のすべてのファイルを除外するバックアップ定義を作成します。

Related Links


New-BENotificationRecipient Help

New-BENotificationRecipient Cmdlet
Synopsis

アラートの新しい通知受信者を作成します。

Syntax
New-BENotificationRecipient [-Name] <String> [-MaxTextNotifications <Int32>] [-TextServiceProviderAddress <String>] [-LimitTextNotification <Boolean>] [-MaxTextNotificationsTimeWindowInMinutes <Int32>] [-RecipientsCellPhoneNumber <String>] [-LimitEmailNotification <Boolean>] [-RecipientsEmailAddress <String>] [-NotifyByEmailEnabled <Boolean>] [-NotifyByTextEnabled <Boolean>] [-MaxEmailNotificationsTimeWindowInMinutes <Int32>] [-MaxEmailNotifications <Int32>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

アラートの新しい通知受信者を作成します。

Parameters

-NotifyByEmailEnabled <Boolean>

電子メールによる通知を有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RecipientsEmailAddress <String>

アラート通知を送信する通知受信者の電子メールアドレスを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LimitEmailNotification <Boolean>

通知電子メールの受信者への送信を制限します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MaxEmailNotifications <Int32>

受信者へ送信する通知電子メールの最大数を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MaxEmailNotificationsTimeWindowInMinutes <Int32>

最大の通知電子メールを送信することができる期間の長さを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NotifyByTextEnabled <Boolean>

テキストによる通知を有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RecipientsCellPhoneNumber <String>

テキスト通知を送信する通知受信者の携帯電話番号を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LimitTextNotification <Boolean>

テキスト通知の受信者への送信を制限します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TextServiceProviderAddress <String>

テキストサービスプロバイダのアドレスを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MaxTextNotifications <Int32>

受信者へ送信するテキスト通知の最大数を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MaxTextNotificationsTimeWindowInMinutes <Int32>

最大の通知テキストを送信することができる期間の長さを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

通知受信者の名前を指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

このコマンドレットは入力を受け入れません。

Return Value
BackupExec.Management.CLI.BENotificationRecipient

New-BENotificationRecipient は、アラート送信用の通知受信者を表すオブジェクトを返します。

Examples

Example 1

C:\PS> New-BENotificationRecipient -Name "John" -NotifyByEmailEnabled $true -RecipientsEmailAddress "john@example.com" -LimitEmailNotification $true -MaxEmailNotifications 10 -MaxEmailNotificationsTimeWindowInMinutes 60

これらのコマンドは新しい通知受信者を作成して、電子メール通知送信用の電子メール設定を行います。

Example 2
C:\PS> New-BENotificationRecipient -Name "John" -NotifyByTextEnabled $true -RecipientsCellPhoneNumber 9867453627 -TextServiceProviderAddress "text.example.com" -LimitTextNotification $true -MaxTextNotifications 10 -MaxTextNotificationsTimeWindowInMinutes 60

これらのコマンドは新しい通知受信者を作成して、テキスト通知送信用のテキストメッセージ設定を行います。


New-BENotificationRecipientGroup Help

New-BENotificationRecipientGroup Cmdlet
Synopsis

アラート通知を行うアラート用の新しいグループを作成します。

Syntax
New-BENotificationRecipientGroup [-Name] <String> [-NotificationRecipientList] <BENotificationRecipient[]> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

アラート通知を行うアラート用の新しいグループを作成します。

Parameters

-NotificationRecipientList <BENotificationRecipient[]>

グループに追加できる受信者を指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

グループの名前を指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

このコマンドレットは入力を受け入れません。

Return Value
BackupExec.Management.CLI.BENotificationRecipientGroup

New-BENotificationRecipientGroup は、アラート送信用のグループを表すオブジェクトを返します。

Example

C:\PS>
$Recipients = Get-BENotificationRecipient
New-BENotificationRecipientGroup -Name "AdminGroup" -NotificationRecipientList $Recipients

これらのコマンドは新しいグループを作成して、指定した通知受信者をグループに追加します。

Related Link

Get-BENotificationRecipient


New-BEOpenEnterpriseServerSelection Help

New-BEOpenEnterpriseServerSelection Cmdlet
Synopsis

Novell Open Enterprise Server (OES) のバックアップ選択項目オブジェクトを作成します。

Syntax
New-BEOpenEnterpriseServerSelection [-Component] {None | iFolder | eDirectory | GroupWise} -Object <String> -Service <String> [-Path <String>] [-PathIsDirectory <SwitchParameter>] [-Exclude <SwitchParameter>] [<CommonParameters>]
Description

Novell Open Enterprise Server (OES) のバックアップ選択項目オブジェクトを作成します。

Parameters

-Component

バックアップするコンポーネントまたはターゲットサービスエージェントを指定します。値には Novell iFolder、Novell eDirectory、および Novell GroupWise が含まれます。

The valid values are:
None
iFolder
eDirectory
GroupWise

Required | true
Position | 0
Accepts pipeline input | true (ByPropertyName)
Accepts wildcard characters | false

-Service <String>

選択するターゲットサービスエージェントを指定します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Object <String>

選択する指定サーバー内のオブジェクトを指定します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Path <String>

選択するフォルダまたはファイルのパス (ワイルドカードを使用可能) を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PathIsDirectory <SwitchParameter>

Path パラメータの値がファイルではなくディレクトリであることを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Exclude <SwitchParameter>

Open Enterprise Server 選択項目を除外します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

このコマンドレットは入力を受け入れません。

Return Value
BackupExec.Management.CLI.BEOpenEnterpriseServerSelection

New-BEOpenEnterpriseServerSelection は、BEOpenEnterpriseServerSelection オブジェクトを返します。

Examples

Example 1

C:\PS> $x = New-BEOpenEnterpriseServerSelection -Component "iFolder" -Service "linux-ouyn" -Object "[ROOT]" -Path "admin/opt"
C:\PS> Get-BEAgentServer -Name OESMachine | New-BEBackupDefinition -BackupJobDefault BackupToDisk -OpenEnterpriseServerSelection $x | Save-BEBackupDefinition

これらのコマンドは「BackupToDisk」ジョブデフォルト設定を使用して OESMachine コンピュータに Novell iFolder コンポーネントの admin/opt ディレクトリをバックアップするバックアップ定義を作成します。

Example 2
C:\PS> $x = New-BEOpenEnterpriseServerSelection -Component "GroupWise" -Service "linux-ouyn" -Object "1[DOM]dom111" -Path "ofmsg/guardbak/newguard.fbk"
C:\PS> Get-BEAgentServer -Name OESMachine | New-BEBackupDefinition -BackupJobDefault BackupToDisk -OpenEnterpriseServerSelection $x | Save-BEBackupDefinition

これらのコマンドは「BackupToDisk」ジョブデフォルト設定を使用して OESMachine コンピュータに Novell GroupWise コンポーネントの ofmsg/guardbak/newguard.fbk ファイルをバックアップするバックアップ定義を作成します。

Related Links


New-BEOpenStorageDevice Help

New-BEOpenStorageDevice Cmdlet
Synopsis

Backup Exec で新しい OpenStorage デバイスを作成します。

Syntax
New-BEOpenStorageDevice [-Name] <String> [-HostServer] <String> [-ServerType] <String> [-LogicalStorageUnit] <String> [-LogonAccount] <BELogonAccount> [-IsStreamHandlerSupportEnabled <Boolean>] [-DataStreamSizeBytes <Int32>] [-SplitDataStreamBytes <Int64>] [-ClientSideDeduplicationEnabled <Boolean>] [-DiskSpaceReserveBytes <Int64>] [-AllowedConcurrentOperations <Int32>] [-BackupExecServer <BEBackupExecServer>] [-Description <String>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [-Force <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec の新しい OpenStorage デバイスを作成します。

ServerType パラメータに渡す登録済みサーバータイプのリストを確認するには、Get-BEOpenStorageServerType をコールします。

LogicalStorageUnit パラメータに渡す論理ストレージユニットのリストを確認するには、Get-BEOpenStorageLogicalStorageUnit をコールします。

Parameters

-BackupExecServer <BEBackupExecServer>

CASO 環境でデバイスを作成する Backup Exec サーバーを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-HostServer <String>

デバイスがあるサーバーの完全修飾名を指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-ServerType <String>

OpenStorage デバイスの種類を指定します。

Required | true
Position | 2
Accepts pipeline input | false
Accepts wildcard characters | false

-LogicalStorageUnit <String>

OpenStorage デバイスの論理ストレージユニットを指定します。

Required | true
Position | 3
Accepts pipeline input | false
Accepts wildcard characters | false

-LogonAccount <BELogonAccount>

新しい OpenStorage デバイスの Backup Exec ログオンアカウントを指定します。 このログオンアカウントにシステムログオンアカウントは使用できません。

Required | true
Position | 4
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

OpenStorage デバイスの説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AllowedConcurrentOperations <Int32>

このデバイスで許可される最大許容並列書き込み処理を設定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SplitDataStreamBytes <Int64>

Backup Exec が新しいイメージにスパンするサイズを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DataStreamSizeBytes <Int32>

Backup Exec が行う単一書き込み操作のサイズを示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IsStreamHandlerSupportEnabled <Boolean>

ストリームハンドラを使用するかどうかを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ClientSideDeduplicationEnabled <Boolean>

クライアント側の重複排除をこの OpenStorage デバイスで有効にするかどうかを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskSpaceReserveBytes <Int64>

Backup Exec 以外のアプリケーション用に空けてあるディスク領域を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

新しい OpenStorage デバイスの名前を指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Force <SwitchParameter>

Backup Exec サーバーに OpenStorage デバイスを強制的に信頼させます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

作成する Backup Exec OpenStorage デバイスオブジェクトの名前を含む文字列を New-BEOpenStorageDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEOpenStorageDevice

New-BEOpenStorageDevice は、作成された OpenStorage デバイスを返します。

Example

C:\PS> New-BEOpenStorageDevice -Name "Device 0001" -HostServer "server01" -ServerType "Quantum" -LogicalStorageUnit "lsu1" -LogonAccount "Logon Account 0001"

このコマンドは、ログオンアカウントが「Logon Account 0001」の「server01」という名前の Quantum ホストサーバーで、「lsu1」という名前の論理ストレージタイプを使用する「Device 0001」という名前の OpenStorage デバイスを作成します。

Related Links


New-BEOracleSelection Help

New-BEOracleSelection Cmdlet
Synopsis

Oracle のバックアップ選択項目オブジェクトを作成します。

Syntax
New-BEOracleSelection [-Database] <String> [-Exclude <SwitchParameter>] [<CommonParameters>]

New-BEOracleSelection [-Database] <String> -TableSpace <String> [-FileName <String>] [-Exclude <SwitchParameter>] [<CommonParameters>]

New-BEOracleSelection [-Database] <String> [-Exclude <SwitchParameter>] [-ArchivedLogs <SwitchParameter>] [<CommonParameters>]
Description

Oracle のバックアップ選択項目オブジェクトを作成します。

Parameters

-Database <String>

選択するデータベースを指定します。すべてのデータベースを指定するには「*」と入力します。

Required | true
Position | 0
Accepts pipeline input | true (ByPropertyName)
Accepts wildcard characters | false

-TableSpace <String>

データベースで選択する表スペースファイルを指定します。すべての表スペースを指定するには「*」と入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByPropertyName)
Accepts wildcard characters | false

-FileName <String>

表スペースで選択する表スペースファイルを指定します。すべてのファイルを指定するには「*」と入力します。

Required | false
Position | Named
Accepts pipeline input | true (ByPropertyName)
Accepts wildcard characters | false

-ArchivedLogs <SwitchParameter>

アーカイブログファイルをバックアップすることを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Exclude <SwitchParameter>

-Database パラメータで指定した Oracle 選択項目を除外します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

文字列オブジェクトを New-BEOracleSelection にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEOracleSelection

New-BEOracleSelection は、BEOracleSelection オブジェクトを返します。

Examples

Example 1

C:\PS> $x = New-BEOracleSelection -Database MyOrcl
C:\PS> Get-BEAgentServer -Name OracleMachine | New-BEBackupDefinition -BackupJobDefault BackupToDisk -OracleSelection $x | Save-BEBackupDefinition

これらのコマンドは「BackupToDisk」ジョブデフォルト設定を使用して OracleMachine コンピュータに MyOrcl データベースをバックアップするバックアップ定義を作成します。

Example 2
C:\PS> $x = New-BEOracleSelection -Database MyOrcl -Tablespace USERS
C:\PS> Get-BEAgentServer -Name OracleMachine | Submit-BEOnetimeBackupJob -OracleSelection $x

これらのコマンドは OracleMachine コンピュータに MyOrcl データベースの USERS 表スペースをバックアップするワンタイムバックアップジョブをサブミットします。

Example 3
C:\PS> $x = New-BEOracleSelection -Database MyOrcl -Tablespace USERS -FileName "C:\APP\ADMINISTRATOR\ORADATA\ORCL\USERS01.DBF"
C:\PS> Get-BEAgentServer -Name OracleMachine | Submit-BEOnetimeBackupJob -OracleSelection $x

これらのコマンドは OracleMachine コンピュータに MyOrcl データベースの USERS 表スペースの USERS01.DBF ファイルをバックアップするワンタイムバックアップジョブをサブミットします。

Example 4
C:\PS> $x = New-BEOracleSelection -Database MyOrcl -Exclude
C:\PS> Get-BEAgentServer -Name OracleMachine | New-BEBackupDefinition -BackupJobDefault BackupToDisk -OracleSelection *, $x | Save-BEBackupDefinition

これらのコマンドは「BackupToDisk」ジョブデフォルト設定を使用して OracleMachine コンピュータに「MyOrcl」という名前のデータベースを除くすべてのデータベースをバックアップするバックアップ定義を作成します。

Related Links


New-BEPreferredServerGroup Help

New-BEPreferredServerGroup Cmdlet
Synopsis

Backup Exec の新しい優先サーバー設定を作成します。

Syntax
New-BEPreferredServerGroup [-Name] <String> [-ServerList] <String[]> [-IsDefault <Boolean>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec の新しい優先サーバー設定を作成します。 優先サーバー設定は、Exchange Database Availability Groups (DAGs) のバックアップに使用するサーバーを指定します。

Parameters

-ServerList <String[]>

Backup Exec がデータベースのバックアップに使用できる Microsoft Exchange サーバー。Backup Exec は、このリストに追加されたサーバーの順序に基づいてサーバーを使用します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-IsDefault <Boolean>

優先サーバーグループがデフォルトのサーバーグループであることを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

新しい優先サーバー設定の名前を指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

作成する Backup Exec 優先サーバー設定オブジェクトの名前を含む文字列を New-BEPreferredServerGroup にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEPreferredServerGroup

New-BEPreferredServerGroup は、作成された優先サーバー設定を返します。

Example

C:\PS> New-BEPreferredServerGroup -Name "ServerGroup 1" -ServerList @("Server1", "Server2")

このコマンドは ServerGroup 1 という名前の新しい BEPreferredServerGroup を作成してから、Server 1 および Server 2 を使用して Exchange Database Availability Group (DAG) をバックアップします。


New-BESchedule Help

New-BESchedule Cmdlet
Synopsis

新しい Backup Exec スケジュールを作成します。

Syntax
New-BESchedule [-WeeklyEvery] {Sunday | Monday | Tuesday | Wednesday | Thursday | Friday | Saturday} -StartingAt <DateTime> [-DatesToInclude <DateTime[]>] [-DatesToExclude <DateTime[]>] [-Every <Int32>] [<CommonParameters>]

New-BESchedule [-RunNow] <SwitchParameter> [<CommonParameters>]

New-BESchedule [-RunOnce] <SwitchParameter> -StartingAt <DateTime> [<CommonParameters>]

New-BESchedule [-Unscheduled] <SwitchParameter> [<CommonParameters>]

New-BESchedule [-Minutely] <SwitchParameter> -StartingAt <DateTime> [-DatesToInclude <DateTime[]>] [-DatesToExclude <DateTime[]>] [-Every <Int32>] [<CommonParameters>]

New-BESchedule [-MinutelyWithTimeWindow] <SwitchParameter> -EndingAt <DateTime> -StartingAt <DateTime> [-DatesToInclude <DateTime[]>] [-DatesToExclude <DateTime[]>] [-WeeklyEvery {Sunday | Monday | Tuesday | Wednesday | Thursday | Friday | Saturday}] [-Every <Int32>] [<CommonParameters>]

New-BESchedule [-Hourly] <SwitchParameter> -StartingAt <DateTime> [-DatesToInclude <DateTime[]>] [-DatesToExclude <DateTime[]>] [-Every <Int32>] [<CommonParameters>]

New-BESchedule [-HourlyWithTimeWindow] <SwitchParameter> -EndingAt <DateTime> -StartingAt <DateTime> [-DatesToInclude <DateTime[]>] [-DatesToExclude <DateTime[]>] [-WeeklyEvery {Sunday | Monday | Tuesday | Wednesday | Thursday | Friday | Saturday}] [-Every <Int32>] [<CommonParameters>]

New-BESchedule [-Daily] <SwitchParameter> -StartingAt <DateTime> [-DatesToInclude <DateTime[]>] [-DatesToExclude <DateTime[]>] [-Every <Int32>] [<CommonParameters>]

New-BESchedule [-Weekdays] <SwitchParameter> -StartingAt <DateTime> [-DatesToExclude <DateTime[]>] [-DatesToInclude <DateTime[]>] [<CommonParameters>]

New-BESchedule [-MonthlyOnDayNumber] <Int32> -StartingAt <DateTime> [-DatesToInclude <DateTime[]>] [-DatesToExclude <DateTime[]>] [-Every <Int32>] [<CommonParameters>]

New-BESchedule [-MonthlyOnMultipleDayNumber] <Int32[]> -StartingAt <DateTime> [-DatesToExclude <DateTime[]>] [-DatesToInclude <DateTime[]>] [<CommonParameters>]

New-BESchedule [-MonthlyEvery] {First | Second | Third | Fourth | Last} [-Day] {Sunday | Monday | Tuesday | Wednesday | Thursday | Friday | Saturday | Weekday | WeekendDay | Day} -StartingAt <DateTime> [-DatesToExclude <DateTime[]>] [-DatesToInclude <DateTime[]>] [-Every <Int32>] [<CommonParameters>]

New-BESchedule -StartingAt <DateTime> [-MonthlyEveryLastWeek {Sunday | Monday | Tuesday | Wednesday | Thursday | Friday | Saturday}] [-MonthlyEveryFourthWeek {Sunday | Monday | Tuesday | Wednesday | Thursday | Friday | Saturday}] [-DatesToInclude <DateTime[]>] [-DatesToExclude <DateTime[]>] [-MonthlyEveryWeek {Sunday | Monday | Tuesday | Wednesday | Thursday | Friday | Saturday}] [-MonthlyEveryQualifiedDay {FirstSunday | SecondSunday | ThirdSunday | FourthSunday | LastSunday | FirstMonday | SecondMonday | ThirdMonday | FourthMonday | LastMonday | FirstTuesday | SecondTuesday | ThirdTuesday | FourthTuesday | LastTuesday | FirstWednesday | SecondWednesday | ThirdWednesday | FourthWednesday | LastWednesday | FirstThursday | SecondThursday | ThirdThursday | FourthThursday | LastThursday | FirstFriday | SecondFriday | ThirdFriday | FourthFriday | LastFriday | FirstSaturday | SecondSaturday | ThirdSaturday | FourthSaturday | LastSaturday}] [-MonthlyEveryFirstWeek {Sunday | Monday | Tuesday | Wednesday | Thursday | Friday | Saturday}] [-MonthlyEveryThirdWeek {Sunday | Monday | Tuesday | Wednesday | Thursday | Friday | Saturday}] [-MonthlyEverySecondWeek {Sunday | Monday | Tuesday | Wednesday | Thursday | Friday | Saturday}] [<CommonParameters>]

New-BESchedule [-YearlyOnMonthDayNumber] <Int32> [-Month] {January | February | March | April | May | June | July | August | September | October | November | December} -StartingAt <DateTime> [-DatesToExclude <DateTime[]>] [-DatesToInclude <DateTime[]>] [-Every <Int32>] [<CommonParameters>]

New-BESchedule [-YearlyEvery] {First | Second | Third | Fourth | Last} [-Day] {Sunday | Monday | Tuesday | Wednesday | Thursday | Friday | Saturday | Weekday | WeekendDay | Day} [-Month] {January | February | March | April | May | June | July | August | September | October | November | December} -StartingAt <DateTime> [-DatesToInclude <DateTime[]>] [-DatesToExclude <DateTime[]>] [-Every <Int32>] [<CommonParameters>]
Description

新しい Backup Exec スケジュールを作成します。

New-BESchedule の出力は、次のコマンドの Schedule パラメータとして使用されます。
Add-BEConvertToVirtualStageBackupTask
Add-BEDifferentialBackupTask
Add-BEDuplicateStageBackupTask
Add-BEFullBackupTask
Add-BEIncrementalBackupTask
Set-BEDifferentialBackupTask
Set-BEDuplicateStageBackupTask
Set-BEFullBackupTask
Set-BEIncrementalBackupTask
Submit-BECleanJob
Submit-BEEjectMediaJob
Submit-BEExportExpiredMediaJob
Submit-BEExportMediaJob
Submit-BEImportMediaJob
Submit-BEInventoryJob

Parameters

-RunNow <SwitchParameter>

ジョブを今すぐ実行します。

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-RunOnce <SwitchParameter>

繰り返しスケジュールなしでジョブを今すぐ実行します。

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-Unscheduled <SwitchParameter>

スケジュールに基づくジョブは実行しないでください。 Start-BEJob を使用してジョブを手動で実行します。

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-Minutely <SwitchParameter>

分単位で繰り返しパターンをスケジュールします。

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-MinutelyWithTimeWindow <SwitchParameter>

分単位で設定され、各発生日における開始と終了時刻を伴う繰り返しパターンをスケジュールします。

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-Hourly <SwitchParameter>

時単位で繰り返しパターンをスケジュールします。

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-HourlyWithTimeWindow <SwitchParameter>

時単位で設定され、各発生日における開始と終了時刻を伴う繰り返しパターンをスケジュールします。

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-Daily <SwitchParameter>

日単位で繰り返しパターンをスケジュールします。

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-Weekdays <SwitchParameter>

平日単位で繰り返しパターンをスケジュールします。

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-WeeklyEvery

週の指定日単位で繰り返しパターンをスケジュールします。このパラメータは、HourlyWithTimeWindow または MinutelyWithTimeWindow の繰り返しパターンを使用するスケジュールと共に使用してください。

The valid values are:
Sunday
Monday
Tuesday
Wednesday
Thursday
Friday
Saturday

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-MonthlyOnDayNumber <Int32>

特定の日単位で繰り返しパターンをスケジュールします。

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-MonthlyOnMultipleDayNumber <Int32[]>

各月の 1 日以上の指定日単位で繰り返しパターンをスケジュールします。

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-MonthlyEvery

特定の日単位で繰り返しパターンをスケジュールします。

The valid values are:
First
Second
Third
Fourth
Last

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-MonthlyEveryQualifiedDay

月の指定日単位で繰り返しパターンをスケジュールします。

The valid values are:
FirstSunday
SecondSunday
ThirdSunday
FourthSunday
LastSunday
FirstMonday
SecondMonday
ThirdMonday
FourthMonday
LastMonday
FirstTuesday
SecondTuesday
ThirdTuesday
FourthTuesday
LastTuesday
FirstWednesday
SecondWednesday
ThirdWednesday
FourthWednesday
LastWednesday
FirstThursday
SecondThursday
ThirdThursday
FourthThursday
LastThursday
FirstFriday
SecondFriday
ThirdFriday
FourthFriday
LastFriday
FirstSaturday
SecondSaturday
ThirdSaturday
FourthSaturday
LastSaturday

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MonthlyEveryWeek

月のすべての週の指定日単位で繰り返しパターンをスケジュールします。

The valid values are:
Sunday
Monday
Tuesday
Wednesday
Thursday
Friday
Saturday

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MonthlyEveryFirstWeek

月の第 1 週の指定日単位で繰り返しパターンをスケジュールします。

The valid values are:
Sunday
Monday
Tuesday
Wednesday
Thursday
Friday
Saturday

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MonthlyEverySecondWeek

月の第 2 週の指定日単位で繰り返しパターンをスケジュールします。

The valid values are:
Sunday
Monday
Tuesday
Wednesday
Thursday
Friday
Saturday

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MonthlyEveryThirdWeek

月の第 3 週の指定日単位で繰り返しパターンをスケジュールします。

The valid values are:
Sunday
Monday
Tuesday
Wednesday
Thursday
Friday
Saturday

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MonthlyEveryFourthWeek

月の第 4 週の指定日単位で繰り返しパターンをスケジュールします。

The valid values are:
Sunday
Monday
Tuesday
Wednesday
Thursday
Friday
Saturday

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MonthlyEveryLastWeek

月の最終週の指定日単位で繰り返しパターンをスケジュールします。

The valid values are:
Sunday
Monday
Tuesday
Wednesday
Thursday
Friday
Saturday

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-YearlyOnMonthDayNumber <Int32>

特定の日単位で毎年の繰り返しパターンをスケジュールします。

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-YearlyEvery

特定の複数日単位で毎年の繰り返しパターンをスケジュールします。

The valid values are:
First
Second
Third
Fourth
Last

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-Month

月を指定します。

The valid values are:
January
February
March
April
May
June
July
August
September
October
November
December

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-Day

日を指定します。

The valid values are:
Sunday
Monday
Tuesday
Wednesday
Thursday
Friday
Saturday
Weekday
WeekendDay
Day

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-Every <Int32>

スケジュールの繰り返し頻度を指定します。 デフォルト値は 1 です。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-StartingAt <DateTime>

スケジュールの開始日時を指定します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EndingAt <DateTime>

スケジュールの停止時刻を指定します。このパラメータは、HourlyWithTimeWindow または MinutelyWithTimeWindow の繰り返しパターンを使用するスケジュールと共に使用してください。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DatesToExclude <DateTime[]>

繰り返し実行するスケジュールをスキップする日付を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DatesToInclude <DateTime[]>

他の設定の影響を受けることなく含められる日付を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

このコマンドレットは入力を受け入れません。

Return Value
BackupExec.Management.CLI.BESchedule

指定したスケジュールを表すオブジェクト。

Examples

Example 1

C:\PS> New-BESchedule -RunNow

このコマンドはすぐに開始してジョブを 1 回だけ実行するスケジュールを作成します。

Example 2
C:\PS> New-BESchedule -RunOnce -StartingAt 10PM

このコマンドは本日の午後 10 時に開始してジョブを 1 回だけ実行するスケジュールを作成します。

Example 3
C:\PS> New-BESchedule -Minutely -Every 5 -StartingAt 10PM

このコマンドは本日の午後 10 時に開始してジョブを 5 分間隔で実行するスケジュールを作成します。

Example 4
C:\PS> New-BESchedule -MinutelyWithTimeWindow -Every 5 -StartingAt 9AM -EndingAt 6PM

このコマンドは午前 9 時から午後 6 時の間にジョブを 5 分間隔で実行するスケジュールを作成します。

Example 5
C:\PS> New-BESchedule -MinutelyWithTimeWindow -Every 15 -WeeklyEvery Monday,Wednesday,Friday -StartingAt 9AM -EndingAt 6PM

このコマンドは、毎月曜日、毎水曜日、毎金曜日に、午前 9 時から午後 6 時の間で 15 分ごとにジョブを実行するスケジュールを作成します。

Example 6
C:\PS> New-BESchedule -Hourly -StartingAt 10PM

このコマンドは本日の午後 10 時に開始してジョブを 1 時間間隔で実行するスケジュールを作成します。

Example 7
C:\PS> New-BESchedule -HourlyWithTimeWindow -StartingAt 9AM -EndingAt 6PM

このコマンドは午前 9 時から午後 6 時の間でジョブを 1 時間おきに実行するスケジュールを作成します。

Example 8
C:\PS> New-BESchedule -HourlyWithTimeWindow -WeeklyEvery Monday,Wednesday,Friday -StartingAt 9AM -EndingAt 6PM

このコマンドは、毎月曜日、毎水曜日、毎金曜日に、午前 9 時から午後 6 時の間で 1 時間おきにジョブを実行するスケジュールを作成します。

Example 9
C:\PS> New-BESchedule -Daily -StartingAt 10PM

このコマンドは本日の午後 10 時に開始してジョブを毎日実行するスケジュールを作成します。

Example 10
C:\PS> New-BESchedule -Daily -StartingAt 10PM -DatesToExclude 12/25/2012, 12/25/2013, 12/25/2014, 12/25/2015

このコマンドは本日の午後 10 時に開始し、2012 年 12 月 25 日、2013 年 12 月 25 日、2014 年 12 月 25 日、2015 年 12 月 25 日を除いて毎日ジョブを実行するスケジュールを作成します。

Example 11
C:\PS> New-BESchedule -Weekdays -StartingAt 10PM

このコマンドは本日の午後 10 時に開始してジョブを平日の毎日実行するスケジュールを作成します。

Example 12
C:\PS> New-BESchedule -WeeklyEvery Monday,Wednesday,Friday -StartingAt 10PM

このコマンドは、本日の午後 10 時に開始してジョブを毎月曜日、毎水曜日、毎金曜日に実行するスケジュールを作成します。

Example 13
C:\PS> New-BESchedule -MonthlyOnDayNumber 10 -StartingAt "1/1/2012 10PM"

このコマンドは、2012 年 1 月 1 日から有効で、毎月 10 日の午後 10 時にジョブを実行するスケジュールを作成します。

Example 14
C:\PS> New-BESchedule -MonthlyEvery Last Friday -StartingAt "1/1/2012 10PM"

このコマンドは、2012 年 1 月 1 日から有効で、毎月最後の金曜日の午後 10 時にジョブを実行するスケジュールを作成します。

Example 15
C:\PS> New-BESchedule -MonthlyEveryQualifiedDay SecondFriday, LastFriday -StartingAt "1/1/2012 10PM"

このコマンドは、2012 年 1 月 1 日から有効で、月の第 2 週および最終週の金曜日の午後 10 時にジョブを実行するスケジュールを作成します。

Example 16
C:\PS> New-BESchedule -MonthlyEveryWeek Monday, Wednesday, Friday -StartingAt "1/1/2012 10PM"

このコマンドは、2012 年 1 月 1 日から有効で、月の毎月曜日、毎水曜日、毎金曜日の午後 10 時にジョブを実行するスケジュールを作成します。

Example 17
C:\PS> New-BESchedule -MonthlyEverySecondWeek Friday -MonthlyEveryLastWeek Friday -StartingAt "1/1/2012 10PM"

このコマンドは、2012 年 1 月 1 日から有効で、月の第 2 週および最終週の金曜日の午後 10 時にジョブを実行するスケジュールを作成します。

Example 18
C:\PS> New-BESchedule -YearlyOnMonthDayNumber 1 January -StartingAt "1/1/2012 10PM"

このコマンドは、2012 年 1 月 1 日から有効で、毎年 1 月 10 日の午後 10 時にジョブを実行するスケジュールを作成します。

Example 19
C:\PS> New-BESchedule -YearlyEvery First Monday March -StartingAt "1/1/2012 10PM"

このコマンドは、2012 年 1 月 1 日から有効で、毎年 3 月の第 1 月曜日の午後 10 時にジョブを実行するスケジュールを作成します。

Related Links

Add-BEConvertToVirtualStageBackupTask
Add-BEDifferentialBackupTask
Add-BEDuplicateStageBackupTask
Add-BEFullBackupTask
Add-BEIncrementalBackupTask
Set-BEDifferentialBackupTask
Set-BEDuplicateStageBackupTask
Set-BEFullBackupTask
Set-BEIncrementalBackupTask
Submit-BECleanJob
Submit-BEEjectMediaJob
Submit-BEExportExpiredMediaJob
Submit-BEExportMediaJob
Submit-BEImportMediaJob
Submit-BEInventoryJob
Start-BEJob


New-BESharePointAllResourcesSelection Help

New-BESharePointAllResourcesSelection Cmdlet
Synopsis

Windows コンピュータまたは SharePoint ファームに見つかったすべての SharePoint リソースのバックアップ選択項目オブジェクトを作成します。

Syntax
New-BESharePointAllResourcesSelection [-Exclude <SwitchParameter>] [<CommonParameters>]
Description

Windows コンピュータまたは SharePoint ファームに見つかったすべての SharePoint リソースのバックアップ選択項目オブジェクトを作成します。

Parameters

-Exclude <SwitchParameter>

エクスクルード選択のための選択項目オブジェクトを作成します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

このコマンドレットは入力を受け入れません。

Return Value
BackupExec.Management.CLI.BESharePointAllResourcesSelection

Windows コンピュータまたは SharePoint ファームに見つかったすべての SharePoint リソースのバックアップ選択項目オブジェクトです。

Example

C:\PS> $x = New-BESharePointAllResourcesSelection
C:\PS> Get-BEAgentServer "SharePointServer" | New-BEBackupDefinition -BackupJobDefault BackupToDisk | Add-BEBackupSelection $x | Save-BEBackupDefinition

これらのコマンドは「BackupToDisk」ジョブのデフォルト設定を使用して、「SharePointServer」という名前の Windows サーバー用のすべての SharePoint リソースを含むバックアップ定義を作成します。

Related Links


New-BESharePointCentralAdministrationWebApplicationSelection Help

New-BESharePointCentralAdministrationWebApplicationSelection Cmdlet
Synopsis

SharePoint 集中管理 Web アプリケーションのバックアップ選択項目オブジェクトを作成します。

Syntax
New-BESharePointCentralAdministrationWebApplicationSelection [-Exclude <SwitchParameter>] [<CommonParameters>]
Description

SharePoint 集中管理 Web アプリケーションのバックアップ選択項目オブジェクトを作成します。

Parameters

-Exclude <SwitchParameter>

エクスクルード選択のための選択項目オブジェクトを作成します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

このコマンドレットは入力を受け入れません。

Return Value
BackupExec.Management.CLI.BESharePointCentralAdministrationWebApplicationSelection

SharePoint 集中管理 Web アプリケーションのバックアップ選択項目オブジェクトです。

Example

C:\PS> $x = New-BESharePointConfigurationDatabaseSelection
C:\PS> Get-BEAgentServer "SharePointServer" | New-BEBackupDefinition -BackupJobDefault BackupToDisk | Add-BEBackupSelection $x | Save-BEBackupDefinition

これらのコマンドは「BackupToDisk」ジョブのデフォルト設定を使用して、「SharePointServer」という名前の Windows サーバーに見つかった SharePoint サーバー用の SharePoint 集中管理 Web アプリケーションを含むバックアップ定義を作成します。

Related Links


New-BESharePointConfigurationDatabaseSelection Help

New-BESharePointConfigurationDatabaseSelection Cmdlet
Synopsis

SharePoint 構成データベースのバックアップ選択項目オブジェクトを作成します。

Syntax
New-BESharePointConfigurationDatabaseSelection [-Exclude <SwitchParameter>] [<CommonParameters>]
Description

SharePoint 構成データベースのバックアップ選択項目オブジェクトを作成します。

Parameters

-Exclude <SwitchParameter>

エクスクルード選択のための選択項目オブジェクトを作成します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

このコマンドレットは入力を受け入れません。

Return Value
BackupExec.Management.CLI.BESharePointConfigurationDatabaseSelection

SharePoint 構成データベースのバックアップ選択項目オブジェクトです。

Example

C:\PS> $x = New-BESharePointConfigurationDatabaseSelection
C:\PS> Get-BEAgentServer "SharePointServer" | New-BEBackupDefinition -BackupJobDefault BackupToDisk | Add-BEBackupSelection $x | Save-BEBackupDefinition

これらのコマンドは「BackupToDisk」ジョブのデフォルト設定を使用して、「SharePointServer」という名前の Windows サーバーに見つかった SharePoint サーバー用の SharePoint 構成データベースを含むバックアップ定義を作成します。

Related Links


New-BESharePointGlobalSettingsSelection Help

New-BESharePointGlobalSettingsSelection Cmdlet
Synopsis

SharePoint グローバル設定データベースのバックアップ選択項目オブジェクトを作成します。

Syntax
New-BESharePointGlobalSettingsSelection [-Exclude <SwitchParameter>] [<CommonParameters>]
Description

SharePoint グローバル設定データベースのバックアップ選択項目オブジェクトを作成します。

Parameters

-Exclude <SwitchParameter>

エクスクルード選択のための選択項目オブジェクトを作成します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

このコマンドレットは入力を受け入れません。

Return Value
BackupExec.Management.CLI.BESharePointGlobalSettingsSelection

SharePoint グローバル設定データベースのバックアップ選択項目オブジェクトです。

Example

C:\PS> $x = New-BESharePointHelpSearchSelection
C:\PS> Get-BEAgentServer "SharePointServer" | New-BEBackupDefinition -BackupJobDefault BackupToDisk | Add-BEBackupSelection $x | Save-BEBackupDefinition

これらのコマンドは「BackupToDisk」ジョブのデフォルト設定を使用して、「SharePointServer」という名前の Windows サーバーに見つかった SharePoint サーバー用の SharePoint グローバル設定データベースを含むバックアップ定義を作成します。

Related Links


New-BESharePointHelpSearchSelection Help

New-BESharePointHelpSearchSelection Cmdlet
Synopsis

SharePoint ヘルプ検索のバックアップ選択項目オブジェクトを作成します。

Syntax
New-BESharePointHelpSearchSelection [-Exclude <SwitchParameter>] [<CommonParameters>]
Description

SharePoint ヘルプ検索のバックアップ選択項目オブジェクトを作成します。

Parameters

-Exclude <SwitchParameter>

エクスクルード選択のための選択項目オブジェクトを作成します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

このコマンドレットは入力を受け入れません。

Return Value
BackupExec.Management.CLI.BESharePointHelpSearchSelection

SharePoint ヘルプ検索のバックアップ選択項目オブジェクトです。

Example

C:\PS> $x = New-BESharePointHelpSearchSelection
C:\PS> Get-BEAgentServer "SharePointServer" | New-BEBackupDefinition -BackupJobDefault BackupToDisk | Add-BEBackupSelection $x | Save-BEBackupDefinition

これらのコマンドは「BackupToDisk」ジョブのデフォルト設定を使用して、「SharePointServer」という名前の Windows サーバーに見つかった SharePoint サーバー用の SharePoint ヘルプ検索を含むバックアップ定義を作成します。

Related Links


New-BESharePointInfoPathServicesSelection Help

New-BESharePointInfoPathServicesSelection Cmdlet
Synopsis

SharePoint Info Path Services のバックアップ選択項目オブジェクトを作成します。

Syntax
New-BESharePointInfoPathServicesSelection [-Exclude <SwitchParameter>] [<CommonParameters>]
Description

SharePoint Info Path Services のバックアップ選択項目オブジェクトを作成します。

Parameters

-Exclude <SwitchParameter>

エクスクルード選択のための選択項目オブジェクトを作成します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

このコマンドレットは入力を受け入れません。

Return Value
BackupExec.Management.CLI.BESharePointInfoPathServicesSelection

A

Example

C:\PS> $x = New-BESharePointInfoPathServicesSelection
C:\PS> Get-BEAgentServer "SharePointServer" | New-BEBackupDefinition -BackupJobDefault BackupToDisk | Add-BEBackupSelection $x | Save-BEBackupDefinition

これらのコマンドは「BackupToDisk」ジョブのデフォルト設定を使用して、「SharePointServer」という名前の Windows サーバーに見つかった SharePoint サーバー用の SharePoint 情報パスサービスを含むバックアップ定義を作成します。

Related Links


New-BESharePointPortalSiteSelection Help

New-BESharePointPortalSiteSelection Cmdlet
Synopsis

Microsoft SharePoint 2003 ポータルサイトのバックアップ選択項目オブジェクトを作成します。

Syntax
New-BESharePointPortalSiteSelection [-PortalSite] <String> [-Exclude <SwitchParameter>] [<CommonParameters>]
Description

Microsoft SharePoint 2003 ポータルサイトのバックアップ選択項目オブジェクトを作成します。

Parameters

-PortalSite <String>

ポータルサイトの名前を指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Exclude <SwitchParameter>

-PortalSite パラメータで指定したポータルサイト選択項目を除外します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

文字列オブジェクトを New-BESharePointPortalSiteSelection にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BESharePointPortalSiteSelection

New-BESharePointPortalSiteSelection は BESharePointPortalSiteSelection オブジェクトを返します。

Examples

Example 1

C:\PS> $x = New-BESharePointPortalSiteSelection -PortalSite "MyPortalSite"
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition -BackupJobDefault BackupToDisk -SharePointPortalSiteSelection $x | Save-BEBackupDefinition

これらのコマンドは「BackupToDisk」ジョブデフォルト設定を使用してローカルコンピュータに「MyPortalSite」という名前のポータルサイトをバックアップするバックアップ定義を作成します。

Example 2
C:\PS> $x = "MyPortalSite" | New-BESharePointPortalSiteSelection
C:\PS> Get-BEAgentServer -Local | Submit-BEOnetimeBackupJob -SharePointPortalSiteSelection $x

これらのコマンドはローカルコンピュータに「MyPortalSite」という名前のポータルサイトをバックアップするワンタイムバックアップジョブをサブミットします。

Related Links


New-BESharePointServiceApplicationProxySelection Help

New-BESharePointServiceApplicationProxySelection Cmdlet
Synopsis

Microsoft SharePoint 2007 および 2010 のサービスアプリケーションプロキシのバックアップ選択項目オブジェクトを作成します。

Syntax
New-BESharePointServiceApplicationProxySelection [-ProxyName] <String> [-Exclude <SwitchParameter>] [<CommonParameters>]
Description

Microsoft SharePoint 2007 および 2010 のサービスアプリケーションプロキシのバックアップ選択項目オブジェクトを作成します。

Parameters

-ProxyName <String>

サービスアプリケーションプロキシの名前を指定します。 使用可能なすべてのサービスアプリケーションプロキシを指定するには「*」と入力します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Exclude <SwitchParameter>

-ProxyName パラメータで指定したサービスアプリケーションプロキシを除外します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

文字列オブジェクトを New-BESharePointServiceApplicationProxySelection にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BESharePointServiceApplicationProxySelection

New-BESharePointServiceApplicationProxySelection は BESharePointServiceApplicationProxySelection オブジェクトを返します。

Examples

Example 1

C:\PS> $x = New-BESharePointServiceApplicationProxySelection -ProxyName "ServiceProxy"
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition -BackupJobDefault BackupToDisk -SharePointServiceApplicationProxySelection $x | Save-BEBackupDefinition

これらのコマンドは「BackupToDisk」ジョブデフォルト設定を使用してローカルコンピュータの「ServiceProxy」という名前のサービスアプリケーションプロキシをバックアップするバックアップ定義を作成します。

Example 2
C:\PS> $x = "ServiceProxy"|New-BESharePointPortalSiteSelection
C:\PS> Get-BEAgentServer -Local | Submit-BEOnetimeBackupJob -SharePointServiceApplicationProxySelection $x

これらのコマンドはローカルコンピュータに「ServiceProxy」という名前のサービスアプリケーションプロキシをバックアップするワンタイムバックアップジョブをサブミットします。

Related Links


New-BESharePointServiceApplicationSelection Help

New-BESharePointServiceApplicationSelection Cmdlet
Synopsis

Microsoft SharePoint 2007 および 2010 のサービスアプリケーションのバックアップ選択項目オブジェクトを作成します。

Syntax
New-BESharePointServiceApplicationSelection [[-ApplicationName] <String>] [-Exclude <SwitchParameter>] [<CommonParameters>]
Description

Microsoft SharePoint 2007 および 2010 のサービスアプリケーションのバックアップ選択項目オブジェクトを作成します。

Parameters

-ApplicationName <String>

サービスアプリケーションの名前を指定します。 使用可能なすべてのサービスアプリケーションを指定するには「*」と入力します。

Required | false
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Exclude <SwitchParameter>

-ApplicationName パラメータで指定したアプリケーション選択項目を除外します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

文字列オブジェクトを New-BESharePointServiceApplicationSelection にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BESharePointServiceApplicationSelection

New-BESharePointServiceApplicationSelection は BESharePointServiceApplicationSelection オブジェクトを返します。

Examples

Example 1

C:\PS> $x = New-BESharePointServiceApplicationSelection -ApplicationName "SharePointApp1"
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition -BackupJobDefault BackupToDisk -SharePointServiceApplicationSelection $x | Save-BEBackupDefinition

これらのコマンドは「BackupToDisk」ジョブデフォルト設定を使用してローカルコンピュータの「SharePointApp1」という名前のサービスアプリケーションをバックアップするバックアップ定義を作成します。

Example 2
C:\PS> $x = "SharePointApp1"|New-BESharePointServiceApplicationSelection
C:\PS> Get-BEAgentServer -Local | Submit-BEOnetimeBackupJob -SharePointServiceApplicationSelection $x

これらのコマンドはローカルコンピュータに「SharePointApp1」という名前のサービスアプリケーションをバックアップするワンタイムバックアップジョブをサブミットします。

Related Links


New-BESharePointServiceSiteSelection Help

New-BESharePointServiceSiteSelection Cmdlet
Synopsis

Microsoft SharePoint 2003 サービスサイトのバックアップ選択項目オブジェクトを作成します。

Syntax
New-BESharePointServiceSiteSelection [-ServiceSite] <String> [-Exclude <SwitchParameter>] [<CommonParameters>]
Description

Microsoft SharePoint 2003 サービスサイトのバックアップ選択項目オブジェクトを作成します。

Parameters

-ServiceSite <String>

サービスサイトの名前を指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Exclude <SwitchParameter>

-ServiceSite パラメータで指定したサービスサイト選択項目を除外します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

文字列オブジェクトを New-BESharePointServiceSiteSelection にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BESharePointServiceSiteSelection

New-BESharePointServiceSiteSelection は BESharePointServiceSiteSelection オブジェクトを返します。

Examples

Example 1

C:\PS> $x = New-BESharePointServiceSiteSelection -ServiceSite "Site1"
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition -BackupJobDefault BackupToDisk -BESharePointServiceSiteSelection $x | Save-BEBackupDefinition

これらのコマンドは「BackupToDisk」ジョブデフォルト設定を使用してローカルコンピュータの「Site1」という名前のサービスサイトをバックアップするバックアップ定義を作成します。

Example 2
C:\PS> $x = "Site1" | New-BESharePointServiceSiteSelection
C:\PS> Get-BEAgentServer -Local | Submit-BEOnetimeBackupJob -BESharePointServiceSiteSelection $x

これらのコマンドはローカルコンピュータに「Site1」という名前のサービスサイトをバックアップするワンタイムバックアップジョブをサブミットします。

Related Links


New-BESharePointSharedServiceApplicationProxySelection Help

New-BESharePointSharedServiceApplicationProxySelection Cmdlet
Synopsis

Microsoft SharePoint 2007 および 2010 の共有サービスアプリケーションプロキシのバックアップ選択項目オブジェクトを作成します。

Syntax
New-BESharePointSharedServiceApplicationProxySelection [[-ProxyName] <String>] [-Exclude <SwitchParameter>] [<CommonParameters>]
Description

Microsoft SharePoint 2007 および 2010 の共有サービスアプリケーションプロキシのバックアップ選択項目オブジェクトを作成します。

Parameters

-ProxyName <String>

共有サービスアプリケーションプロキシの名前を指定します。 使用可能なすべての共有サービスアプリケーションプロキシを指定するには「*」と入力します。

Required | false
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Exclude <SwitchParameter>

-ProxyName パラメータで指定した共有サービスアプリケーションプロキシを除外します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

文字列オブジェクトを New-BESharePointSharedServiceApplicationProxySelection にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BESharePointSharedServiceApplicationProxySelection

New-BESharePointSharedServiceApplicationProxySelection は BESharePointSharedServiceApplicationProxySelection オブジェクトを返します。

Examples

Example 1

C:\PS> $x = New-BESharePointSharedServiceApplicationProxySelection -ProxyName "ServiceProxy"
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition -BackupJobDefault BackupToDisk -SharePointSharedServiceApplicationProxySelection $x | Save-BEBackupDefinition

これらのコマンドは「BackupToDisk」ジョブのデフォルト設定を使用して、ローカルコンピュータの「ServiceProxy」という名前の共有サービスアプリケーションプロキシをバックアップするバックアップ定義を作成します。

Example 2
C:\PS> $x = "ServiceProxy" | New-BESharePointSharedServiceApplicationProxySelection
C:\PS> Get-BEAgentServer -Local | Submit-BEOnetimeBackupJob -SharePointSharedServiceApplicationProxySelection $x

これらのコマンドはローカルコンピュータの「Database1」という名前の共有サービスアプリケーションプロキシをバックアップするワンタイムバックアップジョブをサブミットします。

Related Links


New-BESharePointSharedServiceApplicationSelection Help

New-BESharePointSharedServiceApplicationSelection Cmdlet
Synopsis

Microsoft SharePoint 2007 と 2010 の共有サービスアプリケーションのバックアップ選択項目オブジェクトを作成します。

Syntax
New-BESharePointSharedServiceApplicationSelection [[-ApplicationName] <String>] [-Exclude <SwitchParameter>] [<CommonParameters>]
Description

Microsoft SharePoint 2007 と 2010 の共有サービスアプリケーションのバックアップ選択項目オブジェクトを作成します。

Parameters

-ApplicationName <String>

共有サービスアプリケーションの名前を指定します。 すべての使用可能な共有サービスアプリケーションを指定するには「*」と入力します。

Required | false
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Exclude <SwitchParameter>

-ApplicationName パラメータで指定された共有サービスの選択項目を除外します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

文字列オブジェクトを New-BESharePointSharedServiceApplicationSelection にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BESharePointSharedServiceApplicationSelection

New-BESharePointSharedServiceApplicationSelection は BESharePointSharedServiceApplicationSelection オブジェクトを返します。

Examples

Example 1

C:\PS> $x = New-BESharePointSharedServiceApplicationSelection -ApplicationName "SharePointApp1"
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition -BackupJobDefault BackupToDisk -SharePointSharedServiceApplicationSelection $x | Save-BEBackupDefinition

これらのコマンドは「BackupToDisk」ジョブのデフォルト設定を使用して、ローカルコンピュータの「SharePointApp1」という名前の共有サービスアプリケーションをバックアップするバックアップ定義を作成します。

Example 2
C:\PS> $x = "SharePointApp1" | New-BESharePointSharedServiceApplicationSelection
C:\PS> Get-BEAgentServer -Local | Submit-BEOnetimeBackupJob -SharePointSharedServiceApplicationSelection $x

これらのコマンドはローカルコンピュータの「SharePointApp1」という名前の共有サービスアプリケーションをバックアップするワンタイムバックアップジョブをサブミットします。

Related Links


New-BESharePointSharedServiceProviderSelection Help

New-BESharePointSharedServiceProviderSelection Cmdlet
Synopsis

Microsoft SharePoint 2007 と 2010 の共有サービスプロバイダのバックアップ選択項目オブジェクトを作成します。

Syntax
New-BESharePointSharedServiceProviderSelection [-ServiceProviderName] <String> [-Exclude <SwitchParameter>] [<CommonParameters>]
Description

Microsoft SharePoint 2007 と 2010 の共有サービスプロバイダのバックアップ選択項目オブジェクトを作成します。

Parameters

-ServiceProviderName <String>

共有サービスプロバイダの名前を指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Exclude <SwitchParameter>

-ServiceProviderName パラメータで指定されたサービスプロバイダを除外します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

文字列オブジェクトを New-BESharePointSharedServiceProviderSelection にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BESharePointSharedServiceProviderSelection

New-BESharePointSharedServiceProviderSelection は BESharePointSharedServiceProviderSelection オブジェクトを返します。

Examples

Example 1

C:\PS> $x = New-BESharePointSharedServiceProviderSelection -ServiceProviderName "SharePointProv1"
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition -BackupJobDefault BackupToDisk -SharePointSharedServiceProviderSelection $x | Save-BEBackupDefinition

これらのコマンドは「BackupToDisk」ジョブのデフォルト設定を使用して、ローカルコンピュータの「SharePointProv1」という名前のサービスプロバイダをバックアップするバックアップ定義を作成します。

Example 2
C:\PS> $x = "SharePointProv1" | New-BESharePointSharedServiceProviderSelection
C:\PS> Get-BEAgentServer -Local | Submit-BEOnetimeBackupJob -SharePointSharedServiceProviderSelection $x

これらのコマンドはローカルコンピュータの「SharePointProv1」という名前のサービスプロバイダをバックアップするワンタイムバックアップジョブをサブミットします。

Related Links


New-BESharePointSingleSignOnDatabaseSelection Help

New-BESharePointSingleSignOnDatabaseSelection Cmdlet
Synopsis

SharePoint シングルサインオンデータベースのバックアップ選択項目オブジェクトを作成します。

Syntax
New-BESharePointSingleSignOnDatabaseSelection [-Exclude <SwitchParameter>] [<CommonParameters>]
Description

SharePoint シングルサインオンデータベースのバックアップ選択項目オブジェクトを作成します。

Parameters

-Exclude <SwitchParameter>

エクスクルード選択のための選択項目オブジェクトを作成します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

このコマンドレットは入力を受け入れません。

Return Value
BackupExec.Management.CLI.BESharePointSingleSignOnDatabaseSelection

SharePoint シングルサインオンデータベースのバックアップ選択項目オブジェクトです。

Example

C:\PS> $x = New-BESharePointSingleSignOnDatabaseSelection
C:\PS> Get-BEAgentServer "SharePointServer" | New-BEBackupDefinition -BackupJobDefault BackupToDisk | Add-BEBackupSelection $x | Save-BEBackupDefinition

これらのコマンドは「BackupToDisk」ジョブのデフォルト設定を使用して、「SharePointServer」という名前の Windows サーバーに見つかった SharePoint サーバー用の SharePoint シングルサインオンデータベースを含むバックアップ定義を作成します。

Related Links


New-BESharePointWebApplicationSelection Help

New-BESharePointWebApplicationSelection Cmdlet
Synopsis

Microsoft SharePoint 2007 と 2010 の Web アプリケーションのバックアップ選択項目オブジェクトを作成します。

Syntax
New-BESharePointWebApplicationSelection [[-WebApplicationName] <String>] [[-DatabaseName] <String>] [-Exclude <SwitchParameter>] [<CommonParameters>]
Description

Microsoft SharePoint 2007 と 2010 の Web アプリケーションのバックアップ選択項目オブジェクトを作成します。

Parameters

-WebApplicationName <String>

Web アプリケーションの名前を指定します。 すべての使用可能な Web アプリケーションを指定するには「*」と入力します。

Required | false
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-DatabaseName <String>

Web アプリケーションのデータベース名を指定します。 すべての使用可能な Web アプリケーションデータベースを指定するには「*」と指定します。このパラメータが空または「*」に設定されていない場合、WebApplicationName パラメータを「*」にすることはできません。

Required | false
Position | 1
Accepts pipeline input | true (ByPropertyName)
Accepts wildcard characters | false

-Exclude <SwitchParameter>

-WebApplicationName パラメータで指定された Web アプリケーションの選択項目を除外します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

文字列オブジェクトを New-BESharePointWebApplicationSelection にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BESharePointWebApplicationSelection

New-BESharePointWebApplicationSelection は BESharePointWebApplicationSelection オブジェクトを返します。

Examples

Example 1

C:\PS> $x = New-BESharePointWebApplicationSelection -WebApplicationName "WEB_APP1"
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition -BackupJobDefault BackupToDisk -SharePointWebApplicationSelection $x | Save-BEBackupDefinition

これらのコマンドは「BackupToDisk」ジョブのデフォルト設定を使用して、ローカルコンピュータの「WEB_APP1」という名前の Web アプリケーションをバックアップするバックアップ定義を作成します。

Example 2
C:\PS> $x = "WEB_APP1" | New-BESharePointWebApplicationSelection
C:\PS> Get-BEAgentServer -Local | Submit-BEOnetimeBackupJob -SharePointWebApplicationSelection $x

これらのコマンドはローカルコンピュータの「WEB_APP1」という名前の Web アプリケーションをバックアップするワンタイムバックアップジョブをサブミットします。

Example 3
C:\PS> $x = "WEB_APP1" | New-BESharePointWebApplicationSelection -DatabaseName WebAppDB
C:\PS> Get-BEAgentServer -Local | Submit-BEOnetimeBackupJob -SharePointWebApplicationSelection $x

これらのコマンドはローカルコンピュータの「WEB_APP1」という名前の Web アプリケーションで使用される「WebAppDB」という名前のデータベースをバックアップするワンタイムバックアップジョブをサブミットします。

Related Links


New-BESqlDatabaseSelection Help

New-BESqlDatabaseSelection Cmdlet
Synopsis

Microsoft SQL データベースのバックアップ選択項目オブジェクトを作成します。

Syntax
New-BESqlDatabaseSelection [[-InstanceName] <String>] [-Exclude <SwitchParameter>] [<CommonParameters>]

New-BESqlDatabaseSelection [-InstanceName] <String> [[-DatabaseName] <String>] [-Exclude <SwitchParameter>] [<CommonParameters>]
Description

Microsoft SQL データベースのバックアップ選択項目オブジェクトを作成します。

Parameters

-InstanceName <String>

SQL インスタンス名を指定します。 すべての使用可能なSQL インスタンスを指定するには「*」と入力します。

Required | true
Position | 0
Accepts pipeline input | true (ByPropertyName)
Accepts wildcard characters | false

-DatabaseName <String>

SQL データベース名を指定します。 すべての使用可能な SQL データベースを指定するには「*」と入力します。

Required | false
Position | 1
Accepts pipeline input | true (ByPropertyName)
Accepts wildcard characters | false

-Exclude <SwitchParameter>

-InstanceName パラメータと -DatabaseName パラメータで指定された SQL インスタンス/データベースの選択項目を除外します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

このコマンドレットは入力を受け入れません。

Return Value
BackupExec.Management.CLI.BESqlDatabaseSelection

New-BESqlDatabaseSelection は BESqlDatabaseSelection オブジェクトを返します。

Examples

Example 1

C:\PS> $x = New-BESqlDatabaseSelection -InstanceName "Instance1" -DatabaseName "DB1"
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition -BackupJobDefault BackupToDisk -SqlDatabaseSelection $x | Save-BEBackupDefinition

これらのコマンドは「BackupToDisk」ジョブのデフォルト設定を使用して、ローカルコンピュータの「Instance1」という名前の SQL インスタンスに含まれる「DB1」という名前の SQL データベースをバックアップするバックアップ定義を作成します。

Example 2
C:\PS> $x = New-BESqlDatabaseSelection -InstanceName "Instance1" -DatabaseName "DB1"
C:\PS> Get-BEAgentServer -Local | Submit-BEOnetimeBackupJob -SqlDatabaseSelection $x

これらのコマンドは「BackupToDisk」ジョブのデフォルト設定を使用して、ローカルコンピュータの「Instance1」という名前の SQL インスタンスに含まれる「DB1」という名前の SQL データベースをバックアップするバックアップ定義を作成します。

Related Links


New-BEStorageDevicePool Help

New-BEStorageDevicePool Cmdlet
Synopsis

Backup Exec に新しいストレージデバイスプールを作成します。

Syntax
New-BEStorageDevicePool [-Name] <String> [-StoragePoolType] {Disk | Tape | DiskCartridge} [-SelectionMethod {Default | LeastFreeSpaceFirst | MostFreeSpaceFirst}] [-Description <String>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec に新しいストレージデバイスプールを作成します。

Parameters

-StoragePoolType

デバイスプールの種類を指定します。

The valid values are:
Disk
Tape
DiskCartridge

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

ストレージデバイスプールの説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SelectionMethod

プールに対してバックアップジョブを実行する場合のストレージプール内でのデバイスの選択方法を指定します。バックアップジョブをストレージデバイスプールにサブミットする場合、デフォルトでは、そのジョブはプール内で利用可能なストレージデバイスに自動的に送信されます。

The valid values are:
Default
LeastFreeSpaceFirst
MostFreeSpaceFirst

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

新しいストレージデバイスプールの名前を指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

作成する Backup Exec ストレージデバイスプールオブジェクトの名前を含む文字列を New-BEStorageDevicePool にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEStorageDevicePool

New-BEStorageDevicePool は、作成されたストレージデバイスプールを返します。

Example

C:\PS> New-BEStorageDevicePool -Name "Storage Pool 0001".

このコマンドは「Storage Pool 0001」という名前のストレージプールを作成します。


New-BESyntheticBackupDefinition Help

New-BESyntheticBackupDefinition Cmdlet
Synopsis

新しい合成バックアップ定義を Backup Exec に作成します。

Syntax
New-BESyntheticBackupDefinition -AgentServer <BEAgentServer> [-AllowAnyNetworkForAgentAccess <Boolean>] [-EnableCheckpointRestart <Boolean>] [-UseSnapshotTechnology <Boolean>] [-NetworkInterface <BENetworkInterface>] [-NetworkProtocol {AnyAvailable | IPv4 | IPv6}] [-NetworkSubnet <BENetworkInterfaceSubnet>] [-SnapshotTechnology {Automatic | MicrosoftVolumeShadowCopyService}] [-OffhostBackupSnapshotProvider {Automatic | Software | Hardware}] [-FailIfNoOffhostBackup <Boolean>] [-ProcessOffhostLogicalVolumesSequentially <Boolean>] [-SnapshotProvider {Automatic | System | Software | Hardware}] [-ProcessLogicalVolumesSequentially <Boolean>] [-UseOffhostBackup <Boolean>] [-Priority {Normal | Lowest | Low | High | Highest}] [-RestrictToBackupExecServer <BEBackupExecServer>] [-RestrictToBackupExecServersInPool <BEBackupExecServerPool>] [-Name <String>] [-Description <String>] [-FileSystemSelection <BEFileSystemSelection[]>] [-EnableTestRun <Boolean>] [-TestRunCheckMediaAvailable <Boolean>] [-TestRunJobSizeCalculationMethod {UsePreviousJobHistories | PerformPreScan}] [-TestRunPlaceScheduledBackupJobOnHoldIfUnsuccessful <Boolean>] [-TestRunSchedule <BESchedule>] [-TestRunCheckLogonAccount <Boolean>] [-TestRunCheckStorageSpace <Boolean>] [<CommonParameters>]
Description

新しい合成バックアップ定義を Backup Exec に作成します。

New-BESyntheticBackupDefinition に渡されたパラメータは、合成バックアップ定義のすべてのタスクのためのオプションです。

合成バックアップ定義では、ファイルとフォルダのバックアップのみを行えます。 バックアップするファイルとフォルダを指定するには、FileSystemSelection パラメータを使用します。

合成バックアップ定義のタスクを変更するには、New-BESyntheticBackupDefinition を次のコマンドとともに使用します: Set-BESyntheticBackupDefinition、Set-BESyntheticInitialFullTask、Set-BESyntheticIncrementalTask、Set-BESyntheticFullTask、Add-BEVerifyBackupTask、および Set-BEVerifyBackupTask。

合成バックアップ定義を作成または編集した場合、変更をコミットするには合成バックアップ定義を Save-BESyntheticBackupDefinition に渡す必要があります。

Parameters

-AgentServer <BEAgentServer>

バックアップするエージェントサーバーオブジェクトを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String>

新しい合成バックアップ定義の名前を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

新しい合成バックアップ定義の説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemSelection <BEFileSystemSelection[]>

1 つ以上のファイルシステムの選択項目をバックアップ戦略に含める、またはバックアップ戦略から除外します。含めるファイルまたはディレクトリを指定するには、1 つまたは複数のパスを、カンマを使用して値を区切って指定します。除外するファイルまたはディレクトリを指定するには、-Exclude パラメータと一緒に New-BEFileSystemSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Priority

ジョブを実行する順序を指定します。2 つのジョブが同時に実行されるようにスケジュールされている場合、ユーザーが設定する優先度でどちらが先に実行されるかが決まります。

The valid values are:
Normal
Lowest
Low
High
Highest

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RestrictToBackupExecServer <BEBackupExecServer>

CASO 環境でジョブをディスパッチ可能な Backup Exec サーバーを指定します。RestrictToBackupExecServersInPool が指定されている場合は指定できません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RestrictToBackupExecServersInPool <BEBackupExecServerPool>

CASO 環境でジョブをディスパッチ可能な Backup Exec サーバーのセットを指定します。RestrictToBackupExecServer が指定されている場合は指定できません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableTestRun <Boolean>

テスト実行の処理を有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunSchedule <BESchedule>

テスト実行ジョブの実行日時と実行頻度のスケジュール設定を可能にします。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunCheckLogonAccount <Boolean>

バックアップする Backup Exec ログオンアカウントがデータにアクセス可能であることを確認します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunCheckStorageSpace <Boolean>

メディア上にジョブの完了に必要な容量があるかどうかをチェックします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunCheckMediaAvailable <Boolean>

メディアがオンラインになっていて上書き可能かどうかをチェックします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunJobSizeCalculationMethod

スケジュール済みバックアップジョブを実行するために使用可能なメディアの容量を計算する方法を指定します。

The valid values are:
UsePreviousJobHistories
PerformPreScan

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunPlaceScheduledBackupJobOnHoldIfUnsuccessful <Boolean>

テスト実行中に Backup Exec で障害が検出された場合、スケジュール済みジョブを保留にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NetworkInterface <BENetworkInterface>

バックアップネットワークとして使用するネットワークに対して Backup Exec サーバーを接続する、ネットワークインターフェースカードの名前を指定します。Get-BENetworkInterface を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NetworkProtocol

リモートコンピュータをバックアップするために使うプロトコルを指定します。

The valid values are:
AnyAvailable
IPv4
IPv6

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NetworkSubnet <BENetworkInterfaceSubnet>

Get-BENetworkInterface によって返されたネットワークインターフェースのサブネットの 1 つを使用して、リモートコンピュータをバックアップするために使うサブネットを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AllowAnyNetworkForAgentAccess <Boolean>

バックアップまたはリストアのために選択したリモートコンピュータが、指定したバックアップネットワークの一部でない場合に、リモートコンピュータからのデータが任意の利用可能なネットワークを介してバックアップまたはリストアされるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableCheckpointRestart <Boolean>

ジョブが中断された時点からバックアップジョブを続行可能にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UseSnapshotTechnology <Boolean>

スナップショットテクノロジを有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SnapshotTechnology

スナップショットテクノロジを有効にしたときに使用する、スナップショットテクノロジを指定します。UseSnapshotTechnology は $true に設定する必要があります。

The valid values are:
Automatic
MicrosoftVolumeShadowCopyService

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SnapshotProvider

スナップショットテクノロジを有効にしたときに使用するスナップショットプロバイダとして、Microsoft ボリュームシャドウコピーサービスを指定します。UseSnapshotTechnology を $true に設定し、SnapshotTechnology を MicrosoftVolumeShadowCopyService に設定する必要があります。

The valid values are:
Automatic
System
Software
Hardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ProcessLogicalVolumesSequentially <Boolean>

1 つのジョブで複数のボリュームをバックアップすることを有効にします。このとき、一度に 1 つの論理ボリュームのスナップショットのみが作成されます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UseOffhostBackup <Boolean>

オフホストバックアップを有効にします。有効な場合は、すべての必要条件が満たされると、すべてのボリュームのオフホストバックアップが実行されます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OffhostBackupSnapshotProvider

使用するオフホストバックアップのスナップショットプロバイダを指定します。UseOffhostBackup は $true に設定する必要があります。

The valid values are:
Automatic
Software
Hardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FailIfNoOffhostBackup <Boolean>

選択したボリュームのいずれかがオフホストバックアップをサポートしない場合、またはスナップショットやボリュームのインポートでエラーが発生した場合、バックアップジョブを終了します。 UseOffhostBackup は $true に設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ProcessOffhostLogicalVolumesSequentially <Boolean>

1 つのジョブで複数のボリュームをバックアップすることを可能にします。このとき、オフホストバックアップに対して一度に 1 つの論理ボリュームのスナップショットのみが作成されます。UseOffhostBackup は $true に設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

このコマンドレットは入力を受け入れません。

Return Value
BackupExec.Management.CLI.BESyntheticBackupDefinition

New-BESyntheticBackupDefinition は、作成された合成バックアップ定義を返します。

Example

C:\PS> Get-BEAgentServer -Local | New-BESyntheticBackupDefinition -FileSystemSelection C:\Windows\*,D:\* | Save-BESyntheticBackupDefinition

これらのコマンドは、ローカルコンピュータの C:\Windows ディレクトリと D: ドライブをバックアップする新しい合成バックアップ定義を作成します。

Related Links

Set-BESyntheticBackupDefinition
Add-BEVerifyBackupTask
Set-BEVerifyBackupTask
Save-BESyntheticBackupDefinition
New-BEFileSystemSelection
Get-BENetworkInterface
Get-BEAgentServer


New-BESystemStateSelection Help

New-BESystemStateSelection Cmdlet
Synopsis

システム状態のバックアップ選択項目オブジェクトを作成します。

Syntax
New-BESystemStateSelection [-Exclude <SwitchParameter>] [<CommonParameters>]
Description

システム状態のバックアップ選択項目オブジェクトを作成します。

Parameters

-Exclude <SwitchParameter>

BESystemStateSelection の選択項目オブジェクトを除外します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

このコマンドレットは入力を受け入れません。

Return Value
BackupExec.Management.CLI.BESystemStateSelection

New-BESystemStateSelection は BESystemStateSelection オブジェクトを返します。

Example

C:\PS> New-BEBackupDefinition -BackupJobDefault BackupToTape | Set-BEFullBackupTask * | Add-BEBackupSelection -AgentServer (Get-BEAgentServer -Local) -Selection (New-BESystemStateSelection) | Save-BEBackupDefinition

このコマンドは、ローカルコンピュータのシステム状態をバックアップするバックアップ定義を作成します。

Related Links


New-BEUtilityPartitionSelection Help

New-BEUtilityPartitionSelection Cmdlet
Synopsis

ユーティリティパーティション選択項目のバックアップ選択項目オブジェクトを作成します。

Syntax
New-BEUtilityPartitionSelection [[-Partition] <String>] [-Exclude <SwitchParameter>] [<CommonParameters>]
Description

ユーティリティパーティション選択項目のバックアップ選択項目オブジェクトを作成します。

Parameters

-Partition <String>

選択するパーティションを指定します。すべてのパーティションを指定するには「*」と指定します。

Required | false
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Exclude <SwitchParameter>

-Partition パラメータで指定したユーティリティパーティションの選択項目を除外します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

文字列オブジェクトを New-BEUtilityPartitionSelection にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEUtilityPartitionSelection

New-BEUtilityPartitionSelection は BEUtilityPartitionSelection オブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEAgentServer -Local | Submit-BEOnetimeBackupJob -BEUtilityPartitionSelection *

このコマンドは、サーバーで使用可能なすべてのユーティリティパーティションをバックアップする 1 回のみのバックアップジョブをサブミットします。

Example 2
C:\PS> Get-BEAgentServer -Local | Submit-BEOnetimeBackupJob -BEUtilityPartitionSelection -Partition "Utility Partition on Disk 1"

このコマンドは、Backup Exec サーバーにある「Utility Partition on Disk 1」という名前のユーティリティパーティションをバックアップする 1 回のみのバックアップジョブをサブミットします。

Example 3
C:\PS> Get-BEAgentServer -Local | Submit-BEOnetimeBackupJob -BEUtilityPartitionSelection (New-BEUtilityPartitionSelection -Partition "Utility Partition on Disk 1" -Exclude)

このコマンドは、「Utility Partition on Disk 1」という名前のユーティリティパーティション以外のすべてのユーティリティパーティションをバックアップする 1 回のみのバックアップジョブをサブミットします。

Related Links


New-BEVMwareSelection Help

New-BEVMwareSelection Cmdlet
Synopsis

VMware リソースのバックアップ選択項目オブジェクトを作成します。

Syntax
New-BEVMwareSelection [[-Path] <String>] [-Exclude <SwitchParameter>] [<CommonParameters>]
Description

VMware リソースのバックアップ選択項目オブジェクトを作成します。

Parameters

-Path <String>

VMware のリソース名を指定します。使用可能なすべての VMware リソースを指定するには「*」と指定します。Backup Exec の VMware リソース名は大文字と小文字を区別しません。Backup Exec のユーザーインターフェースに表示されるものと同じ名前を使用し、パスの区切りには \ を使用してください。

Required | false
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Exclude <SwitchParameter>

-Path パラメータで指定した VMware リソース選択項目を除外します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

このコマンドレットは入力を受け入れません。

Return Value
BackupExec.Management.CLI.BEVMwareSelection

New-BEVMwareSelection は BEVMwareSelection オブジェクトを返します。

Examples

Example 1

C:\PS> $x = New-BEVMwareSelection "MyDC\VMFolder\VirtualMachine01"
C:\PS> Get-BEAgentServer "VMwareVCenterName" | New-BEBackupDefinition -BackupJobDefault BackupToDisk -VMwareSelection $x | Save-BEBackupDefinition

これらのコマンドは、「VMwareVCenterName」という名前の VMware VCenter における、「MyDC」という名前の VMware DataCenter 内にある、「VMFolder」という VMware フォルダ内の、「VirtualMachine01」という名前の VMware 仮想マシンをバックアップするバックアップ定義を作成し、「BackupToDisk」というジョブデフォルトを使用します。

Example 2
C:\PS> $x = New-BEVMwareSelection "VirtualMachine02"
C:\PS> Get-BEAgentServer "ESX Server" | New-BEBackupDefinition -BackupJobDefault BackupToDisk -VMwareSelection $x | Save-BEBackupDefinition

これらのコマンドは、「ESX Serve」という名前の VMware ESX サーバー用の「VirtualMachine02」という名前の VMware 仮想マシンをバックアップするバックアップ定義を作成し、「BackupToDisk」というジョブデフォルトを使用します。

Example 3
C:\PS> $x = New-BEVMwareSelection "VirtualMachine02" -Exclude
C:\PS> Get-BEAgentServer "ESX Server" | New-BEBackupDefinition -BackupJobDefault BackupToDisk -VMwareSelection *, $x | Save-BEBackupDefinition

これらのコマンドは、「ESX Serve」という名前の VMware ESX サーバー用の「VirtualMachine02」という名前の VMware 仮想マシン以外のすべての VMware 仮想マシンをバックアップするバックアップ定義を作成し、「BackupToDisk」というジョブデフォルトを使用します。

Related Links


Register-BEEvent Help

Register-BEEvent Cmdlet
Synopsis

受信者に Backup Exec でのイベントを通知します。

Syntax
Register-BEEvent [-Event] {AlertChanged | ActiveJobChanged | JobCompleted} [[-SourceIdentifier] <String>] [[-Action] <ScriptBlock>] [-MaxTriggerCount <Int32>] [-SupportEvent <SwitchParameter>] [-Forward <SwitchParameter>] [-MessageData <PSObject>] [<CommonParameters>]
Description

受信者に Backup Exec でのイベントを通知します。

イベントが起きると、セッションのイベントキューに追加されます。 イベントキュー内のイベントを取得するには、Get-Event コマンドレットを使用します。

イベントの通知を受信すると、イベント予約者がセッションに追加されます。 セッションのイベント予約者を取得するには、Get-EventSubscriber コマンドレットを使用します。 通知をキャンセルするには、セッションからイベント予約者を削除する Unregister-Event コマンドレットを使用します。

Parameters

-Event

通知を受信するイベントを指定します。

The valid values are:
AlertChanged
ActiveJobChanged
JobCompleted

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-SourceIdentifier <String>

通知用に選択する名前を指定します。 選択する名前は、現在のセッションで固有の名前にする必要があります。 デフォルト値は Windows PowerShell が割り当てる GUID です。

Required | false
Position | 100
Accepts pipeline input | false
Accepts wildcard characters | false

-Action <ScriptBlock>

イベントを処理するコマンドを指定します。

Action に含まれるコマンドは、イベントをイベントキューに送信するときではなく、イベントが起きた時に実行されます。 かっこ（{}）でコマンドを囲んでスクリプトブロックを作成します。 Action パラメータの値には、イベントに関する情報を Action スクリプトブロックに提供する $Event、$EventSubscriber、$Sender、$SourceEventArgs、$SourceArgs automatic の各自動変数を含めることができます。 詳しくは、about_Automatic_Variables を参照してください。

処理を指定すると、Register-BEEvent はその処理を表すイベントジョブオブジェクトを返します。 イベントジョブは Job コマンドレットを使用して管理できます。

Required | false
Position | 101
Accepts pipeline input | false
Accepts wildcard characters | false

-MessageData <PSObject>

このイベントに関連付ける追加データを指定します。このパラメータの値は、この通知に関連付けられるすべてのイベントの MessageData プロパティに含められます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SupportEvent <SwitchParameter>

イベント通知を非表示にします。 このパラメータは、現在の通知がより複雑なイベント登録機構の一部になっているときに使用し、個別に検出されることのないようにしてください。

SupportEvent パラメータを指定して作成された通知を表示またはキャンセルするには、Get-EventSubscriber および Unregister-Event コマンドレットの Force パラメータを使用します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Forward <SwitchParameter>

この通知のイベントをリモートセッションに送信します。 このパラメータは、リモートコンピュータまたはリモートセッションでイベントを登録するときに使用します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MaxTriggerCount <Int32>

登録されたイベントが通知をトリガできる回数の最大値を指定します。このパラメータは PowerShell バージョン 3 以降で機能します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

このコマンドレットは入力を受け入れません。

Return Value
System.Management.Automation.PSEventJob

Action パラメータを使用すると、Register-EngineEvent は System.Management.Automation.PSEventJob オブジェクトを返します。 それ以外の場合は出力を何も生成しません。

Examples

Example 1

C:\PS> Register-BEEvent -Event JobCompleted

このコマンドはBackup Exec ジョブの完了時に生成されるイベントを予約します。

Example 2
C:\PS> $voice = New-Object -ComObject sapi.spvoice
C:\PS> Register-BEEvent -Event AlertChanged -Action { $voice.Speak($EventArgs.Alert.Message, 1) }

このコマンドは、Backup Exec アラートが追加されるときに生成されるイベントを予約し、Windows Speech API を使用してアラートメッセージを読み上げます。


Remove-BEAgentServerFromAgentServerGroup Help

Remove-BEAgentServerFromAgentServerGroup Cmdlet
Synopsis

エージェントサーバーグループからエージェントサーバーを削除します

Syntax
Remove-BEAgentServerFromAgentServerGroup -InputObject <BEAgentServerGroup[]> [-AgentServer] <BEAgentServer[]> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

エージェントサーバーグループからエージェントサーバーを削除します。

エージェントサーバーは複数のエージェントサーバーグループ内に存在するこ場合があります。

Parameters

-AgentServer <BEAgentServer[]>

エージェントサーバーグループから削除する AgentServer を指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEAgentServerGroup[]>

1 つ以上のエージェントサーバーグループオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEAgentServerGroup

Backup Exec エージェントサーバーグループオブジェクトを Remove-BEAgentServerFromAgentServerGroup にパイプ処理できます。

Return Value
BackupExec.Managment.CLI.BEAgentServer

Remove-BEAgentServerToAgentServerGroup は削除されたエージェントサーバーを表すオブジェクトを返します。

Example

C:\PS> Get-BEAgentServer "Linux*" | Remove-BEAgentServerToAgentServerGroup "Windows"

これらのコマンドは名前に「Linux*」を含んでいるすべてのエージェントサーバーを「Windows」という名前のエージェントサーバーグループから削除します。

Related Link

Get-BEAgentServer


Remove-BEAgentServerGroup Help

Remove-BEAgentServerGroup Cmdlet
Synopsis

Backup Exec からエージェントサーバーグループを削除します。

Syntax
Remove-BEAgentServerGroup -InputObject <BEAgentServerGroup[]> [-PassThru <SwitchParameter>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec からエージェントサーバーグループを削除します。 エージェントサーバーグループを削除すると、エージェントサーバーは残りますが削除されたエージェントサーバーグループとの関連付けはなくなります。

Parameters

-PassThru <SwitchParameter>

削除したオブジェクトをパイプラインに渡します。デフォルトでは、このコマンドレットは出力を生成しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEAgentServerGroup[]>

1 つ以上のエージェントサーバーグループオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEAgentServerGroup

Backup Exec エージェントサーバーグループオブジェクトを Remove-BEAgentServerGroup にパイプ処理できます。

Return Value
None or BackupExec.Management.CLI.BEAgentServerGroup

PassThru パラメータを使用すると、Remove-BEAgentServerGroup は削除されたエージェントサーバーグループを表すオブジェクトを返します。 それ以外の場合、このコマンドレットは出力を生成しません。

Examples

Example 1

C:\PS> Get-BEAgentServerGroup "Accounting" | Remove-BEAgentServerGroup

これらのコマンドは「Accounting」という名前のエージェントサーバーグループを削除します。

Example 2
C:\PS> Remove-BEAgentServerGroup -Name "Accounting"

このコマンドは「Accounting」という名前のエージェントサーバーグループを削除します。

Related Link

Get-BEAgentServerGroup


Remove-BEAlertHistory Help

Remove-BEAlertHistory Cmdlet
Synopsis

アラート履歴から Backup Exec のアラートを削除します。

Syntax
Remove-BEAlertHistory -InputObject <BEAlertHistory[]> [-PassThru <SwitchParameter>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

アラート履歴から Backup Exec のアラートを削除します。

Parameters

-PassThru <SwitchParameter>

削除したオブジェクトをパイプラインに渡します。デフォルトでは、このコマンドレットは出力を生成しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEAlertHistory[]>

1 つまたは複数のアラートオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEAlert

パイプを使用して Backup Exec アラート履歴オブジェクトを Remove-BEAlertHistory に渡すことができます。

Return Value
BackupExec.Management.CLI.BEAlert

PassThru パラメータを使用すると、Remove-BEAlertHistory は削除されたバーコードルールを表すオブジェクトを返します。 それ以外の場合、このコマンドレットは出力を生成しません。

Example

C:\PS> Get-BEAlertHistory | Remove-BEAlertHistory

これらのコマンドは、アラート履歴から Backup Exec のすべてのアラートをクリアします。

Related Link

Get-BEAlertHistory


Remove-BEBackupDefinition Help

Remove-BEBackupDefinition Cmdlet
Synopsis

Backup Exec からバックアップ定義を削除します。

Syntax
Remove-BEBackupDefinition -InputObject <BEBackupDefinition[]> [-PassThru <SwitchParameter>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec からバックアップ定義を削除します。 バックアップ定義を削除すると、そのバックアップ定義に関連付けられているジョブも削除されます。

Parameters

-PassThru <SwitchParameter>

削除したオブジェクトをパイプラインに渡します。デフォルトでは、このコマンドレットは出力を生成しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEBackupDefinition[]>

1 つまたは複数のバックアップ定義オブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupDefinition

パイプを使用して Backup Exec バックアップ定義オブジェクトを Remove-BEBackupDefinition に渡すことができます。

Return Value
BackupExec.Management.CLI.BEBackupDefinition

PassThru パラメータを使用すると、Remove-BEBackupDefinition は、削除されたバックアップ定義を表すオブジェクトを返します。それ以外の場合、このコマンドレットは出力を生成しません。

Examples

Example 1

C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Remove-BEBackupDefinition

これらのコマンドでは、「Backup Definition 01」という名前のバックアップ定義を削除します。

Example 2
C:\PS> Get-BEBackupDefinition | Remove-BEBackupDefinition

これらのコマンドでは、すべてのバックアップ定義を削除します。

Related Link

Get-BEBackupDefinition


Remove-BEBackupExecServerFromCloudStorageDevice Help

Remove-BEBackupExecServerFromCloudStorageDevice Cmdlet
Synopsis

Backup Exec からクラウドストレージデバイスを削除します。

Syntax
Remove-BEBackupExecServerFromCloudStorageDevice [-BackupExecServer] <BEBackupExecServer[]> [-CloudStorageDevice] <BECloudStorageDevice> [-Force <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec からクラウドストレージデバイスを削除します。

Parameters

-CloudStorageDevice <BECloudStorageDevice>

削除するクラウドストレージデバイスを指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer[]>

クラウドストレージデバイスを削除する Backup Exec サーバーを 1 つ以上指定します。

Required | true
Position | 1
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Force <SwitchParameter>

Remove-BEBackupExecServerFromCloudStorageDevice がこのデバイスの Backup Exec サーバーを削除可能であることを確認します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトを Remove-BEBackupExecServerFromCloudStorageDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BECloudStorageDevice

Remove-BEBackupExecServerFromCloudStorageDevice は削除するクラウドストレージデバイスを表すオブジェクトを返します。

Example

C:\PS> $Device = Get-BECloudStorageDevice -Name "Cloud"
C:\PS> Get-BEBackupExecServer -Name "My-MMS" | Remove-BEBackupExecServerFromCloudStorageDevice -CloudStorageDevice $Device

このコマンドは「Cloud」という名前のクラウドストレージデバイスを Backup Exec サーバー「My-MMS」から削除します。

Related Links


Remove-BEBackupExecServerFromDeduplicationDiskStorageDevice Help

Remove-BEBackupExecServerFromDeduplicationDiskStorageDevice Cmdlet
Synopsis

Backup Exec から重複排除用ディスクストレージデバイスを削除します。

Syntax
Remove-BEBackupExecServerFromDeduplicationDiskStorageDevice [-BackupExecServer] <BEBackupExecServer[]> [-DeduplicationDiskStorageDevice] <BEDeduplicationDiskStorageDevice> [-Force <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec から重複排除用ディスクストレージデバイスを削除します。

Parameters

-DeduplicationDiskStorageDevice <BEDeduplicationDiskStorageDevice>

削除する重複排除用ディスクストレージデバイスを指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer[]>

重複排除用ディスクストレージデバイスを削除する 1 つ以上の Backup Exec サーバーを指定します。

Required | true
Position | 1
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Force <SwitchParameter>

Remove-BEBackupExecServerFromDeduplicationDiskStorageDevice がこのデバイスの Backup Exec サーバーを削除可能であることを確認します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトを Remove-BEBackupExecServerFromDeduplicationDiskStorageDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEDeduplicationDiskStorageDevice

Remove-BEBackupExecServerFromDeduplicationDiskStorageDevice は削除する重複排除用ディスクストレージデバイスを表すオブジェクトを返します。

Example

C:\PS> $Device = Get-BEDeduplicationDiskStorageDevice -Name "DedupeDevice"
C:\PS> Get-BEBackupExecServer -Name "My-MMS" | Remove-BEBackupExecServerFromDeduplicationDiskStorageDevice -DeduplicationDiskStorageDevice $Device

このコマンドは「DedupeDevice」という名前の重複排除用ディスクストレージデバイスを Backup Exec サーバー「My-MMS」から削除します。

Related Links


Remove-BEBackupExecServerFromDiskStorageDevice Help

Remove-BEBackupExecServerFromDiskStorageDevice Cmdlet
Synopsis

Backup Exec からディスクベースのストレージデバイスを削除します。

Syntax
Remove-BEBackupExecServerFromDiskStorageDevice [-BackupExecServer] <BEBackupExecServer[]> [-DiskStorageDevice] <BEDiskStorageDevice> [-Force <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec からディスクベースのストレージデバイスを削除します。

Parameters

-DiskStorageDevice <BEDiskStorageDevice>

削除するディスクベースのストレージデバイスを指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer[]>

ディスクベースのストレージデバイスを削除する Backup Exec サーバーを 1 つ以上指定します。

Required | true
Position | 1
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Force <SwitchParameter>

Remove-BEBackupExecServerFromDiskStorageDevice がこのデバイスの Backup Exec サーバーを削除可能であることを確認します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトを Remove-BEBackupExecServerFromDiskStorageDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEDiskStorageDevice

Remove-BEBackupExecServerFromDiskStorageDevice は削除するディスクベースのストレージデバイスを表すオブジェクトを返します。

Example

C:\PS> $Device = Get-BEDiskStorageDevice -Name "DiskDevice"
C:\PS> Get-BEBackupExecServer -Name "My-MMS" | Remove-BEBackupExecServerFromDiskStorageDevice -DiskStorageDevice $Device

このコマンドは「DiskDevice」という名前のディスクベースのストレージデバイスを Backup Exec サーバー「My-MMS」から削除します。

Related Links


Remove-BEBackupExecServerFromLegacyBackupToDiskFolderDevice Help

Remove-BEBackupExecServerFromLegacyBackupToDiskFolderDevice Cmdlet
Synopsis

Backup Exec からレガシーのディスクへのバックアップフォルダを削除します。

Syntax
Remove-BEBackupExecServerFromLegacyBackupToDiskFolderDevice [-BackupExecServer] <BEBackupExecServer[]> [-LegacyBackupToDiskFolderDevice] <BELegacyBackupToDiskFolderDevice> [-Force <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec からレガシーのディスクへのバックアップフォルダを削除します。

Parameters

-LegacyBackupToDiskFolderDevice <BELegacyBackupToDiskFolderDevice>

削除するレガシーのディスクへのバックアップフォルダを指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer[]>

レガシーのディスクへのバックアップフォルダを削除する Backup Exec サーバーを 1 つ以上指定します。

Required | true
Position | 1
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Force <SwitchParameter>

Remove-BEBackupExecServerFromLegacyBackupToDiskFolderDevice がこのデバイスの Backup Exec サーバーを削除可能であることを確認します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトを Remove-BEBackupExecServerFromLegacyBackupToDiskFolderDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BELegacyBackupToDiskFolderDevice

Remove-BEBackupExecServerFromLegacyBackupToDiskFolderDevice は削除するレガシーのディスクへのバックアップフォルダデバイスを表すオブジェクトを返します。

Example

C:\PS> $Device = Get-BELegacyBackupToDiskFolderDevice -Name "Legacy"
C:\PS> Get-BEBackupExecServer -Name "My-MMS" | Remove-BEBackupExecServerFromLegacyBackupToDiskFolderDevice -LegacyBackupToDiskFolderDevice $Device

このコマンドは「Legacy」という名前のレガシーのディスクへのバックアップフォルダを Backup Exec サーバー「My-MMS」から削除します。

Related Links


Remove-BEBackupExecServerFromNdmpServer Help

Remove-BEBackupExecServerFromNdmpServer Cmdlet
Synopsis

Backup Exec から NDMP サーバーデバイスを削除します。

Syntax
Remove-BEBackupExecServerFromNdmpServer [-BackupExecServer] <BEBackupExecServer[]> [-NdmpServer] <BENdmpServer> [-Force <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec から NDMP サーバーデバイスを削除します。

Parameters

-NdmpServer <BENdmpServer>

削除する NDMP サーバー デバイスを指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer[]>

NDMP サーバーデバイスを削除する Backup Exec サーバーを 1 つ以上指定します。

Required | true
Position | 1
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Force <SwitchParameter>

Remove-BEBackupExecServerFromNdmpServer がこのデバイスの Backup Exec サーバーを削除可能であることを確認します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトを Remove-BEBackupExecServerFromNdmpServer にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BENdmpServer

Remove-BEBackupExecServerFromNdmpServer は削除する NDMP サーバーデバイスを表すオブジェクトを返します。
.

Example

C:\PS> $Device = Get-BENdmpServer -Name "NDMP"
C:\PS>
Get-BEBackupExecServer -Name "My-MMS" | Remove-BEBackupExecServerFromNdmpServer -NdmpServer $Device

このコマンドは「NDMP」という名前の NDMP サーバーデバイスを Backup Exec サーバー「My-MMS」から削除します。

Related Links


Remove-BEBackupExecServerFromOpenStorageDevice Help

Remove-BEBackupExecServerFromOpenStorageDevice Cmdlet
Synopsis

OpenStorage デバイスを Backup Exec から削除します。

Syntax
Remove-BEBackupExecServerFromOpenStorageDevice [-BackupExecServer] <BEBackupExecServer[]> [-OpenStorageDevice] <BEOpenStorageDevice> [-Force <SwitchParameter>] [<CommonParameters>]
Description

OpenStorage デバイスを Backup Exec から削除します。

Parameters

-OpenStorageDevice <BEOpenStorageDevice>

削除する OpenStorage デバイスを指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer[]>

OpenStorage デバイスを削除する Backup Exec サーバーを 1 つ以上指定します。

Required | true
Position | 1
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Force <SwitchParameter>

Remove-BEBackupExecServerFromOpenStorageDevice がこのデバイスの Backup Exec サーバーを削除可能であることを確認します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトを Remove-BEBackupExecServerFromOpenStorageDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEOpenStorageDevice

Remove-BEBackupExecServerFromOpenStorageDevice は削除する OpenStorage デバイスを表すオブジェクトを返します。

Example

C:\PS> $Device = Get-BEOpenStorageDevice -Name "PureDisk"
C:\PS> Get-BEBackupExecServer -Name "My-MMS" | Remove-BEBackupExecServerFromOpenStorageDevice -OpenStorageDevice $Device

このコマンドは「PureDisk」という名前の OpenStorage を Backup Exec サーバー「My-MMS」から削除します。

Related Links


Remove-BEBackupExecServerFromRemoteMediaAgentForLinux Help

Remove-BEBackupExecServerFromRemoteMediaAgentForLinux Cmdlet
Synopsis

Remote Media Agent for Linux を Backup Exec サーバーから削除します。

Syntax
Remove-BEBackupExecServerFromRemoteMediaAgentForLinux [-BackupExecServer] <BEBackupExecServer[]> [-RemoteMediaAgentForLinux] <BERemoteMediaAgentForLinux> [-Force <SwitchParameter>] [<CommonParameters>]
Description

Remote Media Agent for Linux を Backup Exec サーバーから削除します。

Parameters

-RemoteMediaAgentForLinux <BERemoteMediaAgentForLinux>

削除する Remote Media Agent for Linux を指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer[]>

Remote Media Agent for Linux を削除する Backup Exec サーバーを 1 つ以上指定します。

Required | true
Position | 1
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Force <SwitchParameter>

Remove-BEBackupExecServerFromRemoteMediaAgentForLinux がこのデバイスの Backup Exec サーバーを削除可能であることを確認します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトを Remove-BEBackupExecServerFromRemoteMediaAgentForLinux にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BERemoteMediaAgentForLinux

Remove-BEBackupExecServerFromRemoteMediaAgentForLinux は削除する Remote Media Agent for Linux を表すオブジェクトを返します。

Example

C:\PS> $Device = Get-BERemoteMediaAgentForLinux -Name "RMAL"
C:\PS> Get-BEBackupExecServer -Name "My-MMS" | Remove-BEBackupExecServerFromRemoteMediaAgentForLinux -RemoteMediaAgentForLinux $Device

このコマンドは「RMAL」という名前の Remote Media Agent for Linux を Backup Exec サーバー「My-MMS」から削除します。

Related Links


Remove-BEBackupExecServerFromVirtualDiskDevice Help

Remove-BEBackupExecServerFromVirtualDiskDevice Cmdlet
Synopsis

Backup Exec から仮想ディスクデバイスを削除します。

Syntax
Remove-BEBackupExecServerFromVirtualDiskDevice [-BackupExecServer] <BEBackupExecServer[]> [-VirtualDiskDevice] <BEVirtualDiskDevice> [-Force <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec から仮想ディスクデバイスを削除します。

Parameters

-VirtualDiskDevice <BEVirtualDiskDevice>

削除する仮想ディスクデバイスを指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer[]>

仮想ディスクデバイスを削除する Backup Exec サーバーを 1 つ以上指定します。

Required | true
Position | 1
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Force <SwitchParameter>

Remove-BEBackupExecServerFromVirtualDiskDevice がこのデバイスの Backup Exec サーバーを削除可能であることを確認します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトを Remove-BEBackupExecServerFromVirtualDiskDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEVirtualDiskDevice

Remove-BEBackupExecServerFromVirtualDiskDevice は削除する仮想ディスクデバイスを表すオブジェクトを返します。

Example

C:\PS> $Device = Get-BEVirtualDiskDevice -Name "Virtual"
C:\PS>
Get-BEBackupExecServer -Name "My-MMS" | Remove-BEBackupExecServerFromVirtualDiskDevice -VirtualDiskDevice $Device

このコマンドは「Virtual」という名前の仮想ディスクデバイスを Backup Exec サーバー「My-MMS」から削除します。

Related Links


Remove-BEBackupExecServerPool Help

Remove-BEBackupExecServerPool Cmdlet
Synopsis

Backup Exec サーバープールを削除します。

Syntax
Remove-BEBackupExecServerPool -InputObject <BEBackupExecServerPool[]> [-PassThru <SwitchParameter>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec サーバープールを削除します。

Parameters

-PassThru <SwitchParameter>

削除したオブジェクトをパイプラインに渡します。デフォルトでは、このコマンドレットは出力を生成しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEBackupExecServerPool[]>

1 つ以上の Backup Exec サーバープールオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupExecServerPool

Backup Exec サーバープールオブジェクトを Remove-BEBackupExecServerPool にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEBackupExecServerPool

PassThru パラメータを指定した場合、Remove-BEBackupExecServerPool は削除された Backup Exec サーバープールを表すオブジェクトを返します。 それ以外の場合、このコマンドレットは出力を生成しません。

Example

C:\PS> Get-BEBackupExecServerPool -Name "Server Pool 0001" | Remove-BEBackupExecServerPool

これらのコマンドは「Server Pool 0001」という名前の Backup Exec サーバープールを削除します。

Related Link

Get-BEBackupExecServerPool


Remove-BEBackupTask Help

Remove-BEBackupTask Cmdlet
Synopsis

Backup Exec のバックアップ定義または合成バックアップ定義からバックアップタスクを削除します。

Syntax
Remove-BEBackupTask -BackupDefinition <BEBackupDefinition> [-Name] <String[]> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Remove-BEBackupTask -BackupDefinition <BEBackupDefinition> -SimultaneousConvertToVirtualStage <SwitchParameter> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Remove-BEBackupTask -SyntheticBackupDefinition <BESyntheticBackupDefinition> [-Name] <String[]> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Remove-BEBackupTask -BackupJobDefault <BEBackupJobDefaults> [-Name] <String[]> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Remove-BEBackupTask -SyntheticBackupJobDefault <BESyntheticBackupJobDefaults> [-Name] <String[]> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のバックアップ定義または合成バックアップ定義からバックアップタスクを削除します。

バックアップ定義から初期フルバックアップを削除することはできません。 合成バックアップ定義からバックアップを削除することはできません。

新しいバックアップ定義からバックアップタスクを削除するには、Remove-BEBackupTask と New-BEBackupDefinition を使用します。

既存のバックアップ定義からバックアップタスクを削除するには、Remove-BEBackupTask と Get-BEBackupDefinition を使用します。

バックアップジョブのデフォルトからバックアップタスクを削除するには、Remove-BEBackupTask と Get-BEBackupJobDefault を使用します。

バックアップ定義を作成または編集する場合、そのバックアップ定義を Save-BEBackupDefinition に渡して変更をコミットする必要があります。

バックアップジョブのデフォルトを編集する場合、そのバックアップジョブのデフォルトを Save-BEBackupJobDefault に渡して変更をコミットする必要があります。

新規合成バックアップ定義からバックアップタスクを削除するには、Remove-BEBackupTask と New-BESyntheticBackupDefinition を使用します。

既存の合成バックアップ定義からバックアップタスクを削除するには、Remove-BEBackupTask と Get-BESyntheticBackupDefinition を使用します。

合成バックアップジョブのデフォルトからバックアップタスクを削除するには、Remove-BEBackupTask と Get-BESyntheticBackupJobDefault を使用します。

合成バックアップ定義を作成または編集する場合、その合成バックアップ定義を Save-BESyntheticBackupDefinition に渡して変更をコミットする必要があります。

合成バックアップジョブのデフォルトを編集する場合、その合成バックアップジョブのデフォルトを Save-BESyntheticBackupJobDefault に渡して変更をコミットする必要があります。

Parameters

-BackupDefinition <BEBackupDefinition>

変更するバックアップ定義を指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-SyntheticBackupDefinition <BESyntheticBackupDefinition>

変更する合成バックアップ定義を指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-SimultaneousConvertToVirtualStage <SwitchParameter>

バックアップ定義から仮想ステージへの同時変換を削除します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupJobDefault <BEBackupJobDefaults>

変更するバックアップジョブのデフォルトを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-SyntheticBackupJobDefault <BESyntheticBackupJobDefaults>

変更する合成バックアップジョブのデフォルトを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

バックアップ定義から削除する 1 つまたは複数のバックアップタスクを、バックアップタスク名で指定します。ワイルドカードを使用できます。複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupDefinition

パイプを使用して Backup Exec バックアップ定義オブジェクトを Remove-BEBackupTask に渡すことができます。

BackupExec.Management.CLI.BEBackupJobDefaults

パイプを使用して Backup Exec バックアップジョブのデフォルトオブジェクトを Remove-BEBackupTask に渡すことができます。

BackupExec.Management.CLI.BESyntheticBackupDefinition

パイプを使用して Backup Exec 合成バックアップ定義オブジェクトを Remove-BEBackupTask に渡すことができます。

BackupExec.Management.CLI.BESyntheticBackupJobDefaults

パイプを使用して Backup Exec 合成バックアップジョブのデフォルトオブジェクトを Remove-BEBackupTask に渡すことができます。

Return Values
BackupExec.Management.CLI.BEBackupDefinition

修正されたバックアップ定義を示します。

BackupExec.Management.CLI.BEBackupJobDefaults

修正されたバックアップジョブのデフォルトを示します。

BackupExec.Management.CLI.BESyntheticBackupDefinition

修正された合成バックアップ定義です。

BackupExec.Management.CLI.BESyntheticBackupJobDefaults

修正された合成バックアップジョブのデフォルトです。

Examples

Example 1

C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition -BackupJobDefault BackupToDisk | Remove-BEBackupTask "Incremental" | Save-BEBackupDefinition

これらのコマンドでは、ローカルコンピュータについて、デフォルトの増分バックアップを削除するバックアップ定義を新しく作成します。

Example 2
C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Remove-BEBackupTask * | Save-BEBackupDefinition

これらのコマンドでは、初期完全バックアップを除くすべてのバックアップタスクを、「Backup Definition 01」という名前のバックアップ定義から削除します。

Example 3
C:\PS> Get-BEBackupJobDefault BackupToDisk | Remove-BEBackupTask * | Save-BEBackupJobDefault

これらのコマンドでは、初期完全バックアップを除くすべてのバックアップタスクを、ディスクへのバックアップジョブのデフォルトから削除します。

Example 4
C:\PS> Get-BESyntheticBackupDefinition "Synthetic Backup Definition 01" | Remove-BEBackupTask Duplicate* | Save-BESyntheticBackupDefinition

これらのコマンドは、名前に「Duplicate*」を含むすべてのタスクを「Synthetic Backup Definition 01」という名前の合成バックアップ定義から削除します。

Example 5
C:\PS> Get-BESyntheticBackupJobDefault | Remove-BEBackupTask Verify* | Save-BESyntheticBackupJobDefault

これらのコマンドは、合成バックアップジョブのデフォルトから、名前が「Verify*」で始まるタスクをすべて削除します。

Related Links

New-BEBackupDefinition
Get-BEBackupDefinition
Get-BEBackupJobDefault
Save-BEBackupDefinition
Save-BEBackupJobDefault
New-BESyntheticBackupDefinition
Get-BESyntheticBackupDefinition
Get-BESyntheticBackupJobDefault
Save-BESyntheticBackupDefinition
Save-BESyntheticBackupJobDefault
Get-BEAgentServer


Remove-BEBarcodeRule Help

Remove-BEBarcodeRule Cmdlet
Synopsis

Backup Exec のバーコードルールを削除します。

Syntax
Remove-BEBarcodeRule -InputObject <BEBarcodeRule[]> [-PassThru <SwitchParameter>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のバーコードルールを削除します。

Parameters

-PassThru <SwitchParameter>

削除したオブジェクトをパイプラインに渡します。デフォルトでは、このコマンドレットは出力を生成しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEBarcodeRule[]>

1 つ以上のバーコードルールオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBarcodeRule

Backup Exec のバーコードルールオブジェクトを Remove-BEBarcodeRule にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEBarcodeRule

PassThru パラメータを使用した場合、Remove-BEBarcodeRule は削除されたバーコードルールを表すオブジェクトを返します。 それ以外の場合、このコマンドレットは出力を生成しません。

Example

C:\PS> Get-BEBarcodeRule -BarcodePrefix CLN | Remove-BEBarcodeRule

これらのコマンドはバーコードの接頭辞が「CLN」のすべてのバーコードルールを削除します。

Related Link

Get-BEBarcodeRule


Remove-BECloudInstance Help

Remove-BECloudInstance Cmdlet
Synopsis

Backup Exec で設定されているクラウドインスタンスを削除します。

Syntax
Remove-BECloudInstance -InputObject <BECloudInstance[]> [-PassThru <SwitchParameter>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec で設定されているクラウドインスタンスを削除します。プライベートクラウドストレージデバイスがクラウドインスタンスに接続されている場合は、クラウドインスタンスを削除できません。

Parameters

-PassThru <SwitchParameter>

削除したオブジェクトをパイプラインに渡します。デフォルトでは、このコマンドレットは出力を生成しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BECloudInstance[]>

1 つ以上のクラウドインスタンスオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BECloudInstance

Backup Exec クラウドインスタンスオブジェクトを Remove-BECloudInstance にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BECloudInstance

PassThru パラメータを使用した場合、Remove-BECloudInstance は削除されたクラウドインスタンスを表すオブジェクトを返します。それ以外の場合、このコマンドレットは出力を生成しません。

Example

C:\PS> Get-BECloudInstance "CloudInstance0001" | Remove-BECloudInstance

これらのコマンドは「CloudInstance0001」という名前のクラウドインスタンスを削除します。

Related Link

Get-BECloudInstance


Remove-BECloudRegion Help

Remove-BECloudRegion Cmdlet
Synopsis

Backup Exec で設定されているクラウドリージョンを削除します。

Syntax
Remove-BECloudRegion -InputObject <BECloudRegion[]> [-PassThru <SwitchParameter>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec で設定されているクラウドリージョンを削除します。クラウドリージョンがデフォルトとして設定されている場合は削除できません。

Parameters

-PassThru <SwitchParameter>

削除したオブジェクトをパイプラインに渡します。デフォルトでは、このコマンドレットは出力を生成しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BECloudRegion[]>

1 つ以上のクラウドリージョンオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BECloudRegion

Backup Exec クラウドリージョンオブジェクトを Remove-BECloudRegion にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BECloudRegion

PassThru パラメータを使用した場合、Remove-BECloudRegion は削除されたクラウドリージョンを表すオブジェクトを返します。それ以外の場合、このコマンドレットは出力を生成しません。

Examples

Example 1

C:\PS> Get-BECloudRegion -Name "ap australia" | Remove-BECloudRegion

これらのコマンドは、「ap australia」という名前のクラウドリージョンを Backup Exec から削除します。

Example 2
C:\PS> Get-BECloudRegion -Name "ap australia" -InstanceName "ibminst" | Remove-BECloudRegion

これらのコマンドは、インスタンス ibminst に関連付けられている「ap australia」という名前のクラウドリージョンを Backup Exec から削除します。

Related Link

Get-BECloudRegion


Remove-BECloudStorageDevice Help

Remove-BECloudStorageDevice Cmdlet
Synopsis

Backup Exec からクラウドストレージデバイスを削除します。

Syntax
Remove-BECloudStorageDevice -InputObject <BECloudStorageDevice[]> [-RemoveBackupSets <SwitchParameter>] [-PassThru <SwitchParameter>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec からクラウドストレージデバイスを削除します。

Parameters

-RemoveBackupSets <SwitchParameter>

デバイスが正常に削除された後で、そのデバイスに関連付けられたすべてのバックアップセットを削除します。このパラメータは Backup Exec のカタログエントリのみを削除します。バックアップセットの内容は削除しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PassThru <SwitchParameter>

削除したオブジェクトをパイプラインに渡します。デフォルトでは、このコマンドレットは出力を生成しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BECloudStorageDevice[]>

クラウドストレージデバイスオブジェクトを 1 つ以上指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BECloudStorageDevice

Backup Exec クラウドストレージデバイスオブジェクトを Remove-BECloudStorageDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BECloudStorageDevice

PassThru パラメータを使用した場合、Remove-BECloudStorageDevice は削除されたクラウドストレージデバイスを表すオブジェクトを返します。 それ以外の場合、このコマンドレットは出力を生成しません。

Example

C:\PS> Get-BECloudStorageDevice "Device 0001" | Remove-BECloudStorageDevice

これらのコマンドは「Device 0001」という名前のクラウドストレージデバイスを削除します。

Related Link

Get-BECloudStorageDevice


Remove-BEConvertToVirtualJob Help

Remove-BEConvertToVirtualJob Cmdlet
Synopsis

Backup Exec から仮想への変換ジョブを削除します。

Syntax
Remove-BEConvertToVirtualJob -InputObject <BEConvertToVirtualJob[]> [-PassThru <SwitchParameter>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec から仮想への変換ジョブを削除します。

Parameters

-PassThru <SwitchParameter>

削除したオブジェクトをパイプラインに渡します。デフォルトでは、このコマンドレットは出力を生成しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEConvertToVirtualJob[]>

1 つ以上の仮想への変換ジョブオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEConvertToVirtualJob

Backup Exec 仮想への変換ジョブオブジェクトを Remove-BEConvertToVirtualJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEConvertToVirtualJob

PassThru パラメータを使用した場合、Remove-BEConvertToVirtualJob は削除された仮想への変換ジョブを表すオブジェクトを返します。 それ以外の場合、このコマンドレットは出力を生成しません。

Example

C:\PS> Get-BEConvertToVirtualJob -Name "Convert To Virtual Job 0001" | Remove-BEConvertToVirtualJob

これらのコマンドは「Convert To Virtual Job 0001」という名前の仮想への変換ジョブをシステムから削除します。

Related Link

Get-BEConvertToVirtualJob


Remove-BEDeduplicationDiskStorageDevice Help

Remove-BEDeduplicationDiskStorageDevice Cmdlet
Synopsis

Backup Exec から重複排除用ディスクストレージデバイスを削除します。

Syntax
Remove-BEDeduplicationDiskStorageDevice -InputObject <BEDeduplicationDiskStorageDevice[]> [-RemoveBackupSets <SwitchParameter>] [-PassThru <SwitchParameter>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec から重複排除用ディスクストレージデバイスを削除します。

Parameters

-RemoveBackupSets <SwitchParameter>

デバイスが正常に削除された後で、そのデバイスに関連付けられたすべてのバックアップセットを削除します。このパラメータは Backup Exec のカタログエントリのみを削除します。バックアップセットの内容は削除しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PassThru <SwitchParameter>

削除したオブジェクトをパイプラインに渡します。デフォルトでは、このコマンドレットは出力を生成しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEDeduplicationDiskStorageDevice[]>

1 つ以上の重複排除用ディスクストレージデバイスオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEDeduplicationDiskStorageDevice

Backup Exec の重複排除用ディスクストレージデバイスオブジェクトを Remove-BEDeduplicationDiskStorageDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEDeduplicationDiskStorageDevice

PassThru パラメータを使用した場合、Remove-BEDeduplicationDiskStorageDevice は削除された重複排除用ディスクストレージデバイスを表すオブジェクトを返します。 それ以外の場合、このコマンドレットは出力を生成しません。

Example

C:\PS> Get-BEDeduplicationDiskStorageDevice "Device 0001" | Remove-BEDeduplicationDiskStorageDevice

これらのコマンドは「Device 0001」という名前の重複排除用ディスクストレージデバイスを削除します。

Related Link

Get-BEDeduplicationDiskStorageDevice


Remove-BEDeviceFromStorageDevicePool Help

Remove-BEDeviceFromStorageDevicePool Cmdlet
Synopsis

Backup Exec のストレージデバイスプールからデバイスを削除します。

Syntax
Remove-BEDeviceFromStorageDevicePool -DiskStorageDevicePool <BEDiskStorageDevicePool> [-DiskStorageDevice] <BEDiskStorageDevice[]> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Remove-BEDeviceFromStorageDevicePool -TapeStorageDevicePool <BETapeStorageDevicePool> [-TapeDriveDevice] <BETapeDriveDevice[]> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Remove-BEDeviceFromStorageDevicePool -DiskStorageDevicePool <BEDiskStorageDevicePool> [-VirtualDiskDevice] <BEVirtualDiskDevice[]> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Remove-BEDeviceFromStorageDevicePool -DiskCartridgeStorageDevicePool <BEDiskCartridgeStorageDevicePool> [-DiskCartridgeDevice] <BEDiskCartridgeDevice[]> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のストレージデバイスプールからデバイスを削除します。

Parameters

-TapeStorageDevicePool <BETapeStorageDevicePool>

デバイスを削除するテープストレージデバイスプールを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-DiskStorageDevicePool <BEDiskStorageDevicePool>

デバイスを削除するディスクストレージデバイスプールを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-DiskCartridgeStorageDevicePool <BEDiskCartridgeStorageDevicePool>

デバイスを削除するディスクカートリッジストレージデバイスプールを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-DiskCartridgeDevice <BEDiskCartridgeDevice[]>

ストレージデバイスプールから削除する Backup Exec ディスクカートリッジデバイスを指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskStorageDevice <BEDiskStorageDevice[]>

ストレージデバイスプールから削除する Backup Exec ディスクストレージデバイスを指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualDiskDevice <BEVirtualDiskDevice[]>

ストレージデバイスプールから削除する Backup Exec 仮想ディスクデバイスを指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeDriveDevice <BETapeDriveDevice[]>

ストレージデバイスプールから削除する Backup Exec テープドライブデバイスを指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BETapeStorageDevicePool

Backup Exec テープストレージデバイスプールオブジェクトを Remove-BEDeviceFromStorageDevicePool にパイプ処理することができます。

BackupExec.Management.CLI.BEDiskStorageDevicePool

Backup Exec ディスクストレージデバイスプールオブジェクトを Remove-BEDeviceFromStorageDevicePool にパイプ処理することができます。

BackupExec.Management.CLI.BEDiskCartridgeStorageDevicePool

Backup Exec ディスクカートリッジストレージデバイスプールオブジェクトを Remove-BEDeviceFromStorageDevicePool にパイプ処理することができます。

Return Value
BackupExec.Management.CLI.BEStorageDevicePool

Remove-BEDeviceFromStorageDevicePool は Backup Exec ストレージデバイスプールオブジェクトを返します。

Example

C:\PS> Get-BEStorageDevicePool "StorageDevicePool 0001" | Remove-BEDeviceFromStorageDevicePool "Device 0001"

これらのコマンドは「StorageDevicePool 0001」という名前のストレージデバイスプールから「Device 0001」という名前のデバイスを削除します。

Related Link

Get-BEStorageDevicePool


Remove-BEDiskCartridgeDevice Help

Remove-BEDiskCartridgeDevice Cmdlet
Synopsis

Backup Exec からディスクカートリッジデバイスを削除します。

Syntax
Remove-BEDiskCartridgeDevice -InputObject <BEDiskCartridgeDevice[]> [-PassThru <SwitchParameter>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec からディスクカートリッジデバイスを削除します。

Parameters

-PassThru <SwitchParameter>

削除したオブジェクトをパイプラインに渡します。デフォルトでは、このコマンドレットは出力を生成しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEDiskCartridgeDevice[]>

1 つ以上のディスクカートリッジデバイスオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEDiskCartridgeDevice

Backup Exec のディスクカートリッジデバイスオブジェクトを Remove-BEDiskCartridgeDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEDiskCartridgeDevice

PassThru パラメータを使用した場合、Remove-BEDiskCartridgeDevice は削除されたディスクカートリッジデバイスを表すオブジェクトを返します。 それ以外の場合、このコマンドレットは出力を生成しません。

Example

C:\PS> Get-BEDiskCartridgeDevice "Device 0001" | Remove-BEDiskCartridgeDevice

これらのコマンドは「Device 0001」という名前のディスクカートリッジデバイスを削除します。

Related Link

Get-BEDiskCartridgeDevice


Remove-BEDiskStorageDevice Help

Remove-BEDiskStorageDevice Cmdlet
Synopsis

Backup Exec からディスクストレージデバイスを削除します。

Syntax
Remove-BEDiskStorageDevice -InputObject <BEDiskStorageDevice[]> [-RemoveBackupSets <SwitchParameter>] [-PassThru <SwitchParameter>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec からディスクストレージデバイスを削除します。

Parameters

-RemoveBackupSets <SwitchParameter>

デバイスが正常に削除された後で、そのデバイスに関連付けられたすべてのバックアップセットを削除します。このパラメータは Backup Exec のカタログエントリのみを削除します。バックアップセットの内容は削除しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PassThru <SwitchParameter>

削除したオブジェクトをパイプラインに渡します。デフォルトでは、このコマンドレットは出力を生成しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEDiskStorageDevice[]>

1 つ以上のディスクストレージデバイスオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEDiskStorageDevice

Backup Exec のディスクストレージデバイスオブジェクトを Remove-BEDiskStorageDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEDiskStorageDevice

PassThru パラメータを使用した場合、Remove-BEDiskStorageDevice は削除されたディスクストレージデバイスを表すオブジェクトを返します。 それ以外の場合、このコマンドレットは出力を生成しません。

Example

C:\PS> Get-BEDiskStorageDevice "Device 0001" | Remove-BEDiskStorageDevice

これらのコマンドは「Device 0001」という名前のディスクストレージデバイスを削除します。

Related Link

Get-BEDiskStorageDevice


Remove-BEEncryptionKey Help

Remove-BEEncryptionKey Cmdlet
Synopsis

Backup Exec から暗号化キーを削除します。

Syntax
Remove-BEEncryptionKey -InputObject <BEEncryptionKey[]> [-PassThru <SwitchParameter>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec から暗号化キーを削除します。

バックアップジョブで使用中の暗号化キーは削除する前に置換する必要があります。 Switch-BEEncryptionKey を参照してください。

Parameters

-PassThru <SwitchParameter>

削除したオブジェクトをパイプラインに渡します。デフォルトでは、このコマンドレットは出力を生成しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEEncryptionKey[]>

1 つ以上の暗号化キーオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEEncryptionKey

Backup Exec の暗号化キーオブジェクトを Remove-BEEncryptionKey にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEEncryptionKey

PassThru パラメータを使用した場合、Remove-BEEncryptionKey は削除された暗号化キーを表すオブジェクトを返します。 それ以外の場合、このコマンドレットは出力を生成しません。

Example

C:\PS> Get-BEEncryptionKey "EncryptionKey 0001" | Switch-BEEncryptionKey -ReplacementEncryptionKey "EncryptionKey 0002" | Remove-BEEncryptionKey

これらのコマンドは「EncryptionKey 0001」という名前の暗号化キーを削除する前に、「EncryptionKey 0001」を使用するジョブで暗号化キーを「EncryptionKey 0002」という名前の別の暗号化キーに置換します。

Related Links


Remove-BEGlobalExcludeSelection Help

Remove-BEGlobalExcludeSelection Cmdlet
Synopsis

ファイルシステムの選択項目オブジェクトをグローバル除外項目のリストから削除します。

Syntax
Remove-BEGlobalExcludeSelection [-FileSystemSelection] <BEFileSystemSelection> [<CommonParameters>]
Description

ファイルシステムの選択項目オブジェクトをグローバル除外項目のリストから削除します。

Parameters

-FileSystemSelection <BEFileSystemSelection>

ファイルシステムの選択項目をグローバル除外の選択項目のリストから削除します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEFileSystemSelection

BEFileSystemSelection オブジェクトを Remove-BEGlobalExcludeSelection にパイプ処理できます。

Return Value
None

このコマンドレットは出力を生成しません。

Examples

Example 1

C:\PS> Remove-BEGlobalExcludeSelection -FileSystemSelection (New-BEFileSystemSelection -Path "C:\Windows\*")

このコマンドは C:\Windows ディレクトリをグローバル除外リストから削除します。

Example 2
C:\PS> $x = Get-BEGlobalExcludeSelection | Where-Object { $_.Path -like "C:\temp\*" }
C:\PS> Remove-BEGlobalExcludeSelection $x

このコマンドは C:\temp ディレクトリをグローバル除外リストから削除します。

Related Links


Remove-BEJob Help

Remove-BEJob Cmdlet
Synopsis

Backup Exec ジョブを削除します。

Syntax
Remove-BEJob -InputObject <BEJob[]> [-PassThru <SwitchParameter>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec ジョブを削除します。

バックアップ定義に関連付けられたジョブを削除するには、バックアップ定義を削除する必要があります。 Remove-BEBackupDefinition を参照してください。

Parameters

-PassThru <SwitchParameter>

削除したオブジェクトをパイプラインに渡します。デフォルトでは、このコマンドレットは出力を生成しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEJob[]>

1 つ以上のジョブオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEJob

Backup Exec のジョブオブジェクトを Remove-BEJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEJob

PassThru パラメータを使用した場合、Remove-BEJob は削除されたジョブを表すオブジェクトを返します。 それ以外の場合、このコマンドレットは出力を生成しません。

Example

C:\PS> Get-BEJob "Job 0001" | Remove-BEJob

これらのコマンドは「Job 0001」という名前のジョブを削除します。

Related Links


Remove-BEJobHistory Help

Remove-BEJobHistory Cmdlet
Synopsis

Backup Exec からジョブ履歴を削除します。

Syntax
Remove-BEJobHistory -InputObject <BEJobHistory[]> [-PassThru <SwitchParameter>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec からジョブ履歴を削除します。

Parameters

-PassThru <SwitchParameter>

削除したオブジェクトをパイプラインに渡します。デフォルトでは、このコマンドレットは出力を生成しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEJobHistory[]>

1 つ以上のジョブ履歴オブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEJobHistory

Backup Exec のジョブ履歴オブジェクトを Remove-BEJobHistory にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEJobHistory

PassThru パラメータを使用した場合、Remove-BEJobHistory は削除されたジョブ履歴を表すオブジェクトを返します。 それ以外の場合、このコマンドレットは出力を生成しません。

Example

C:\PS> Get-BEJob "Job 0001" | Get-BEJobHistory | Remove-BEJobHistory

これらのコマンドは「Job 0001」という名前のジョブに関連付けられたすべてのジョブ履歴を削除します。

Related Links


Remove-BELegacyBackupToDiskFolderDevice Help

Remove-BELegacyBackupToDiskFolderDevice Cmdlet
Synopsis

Backup Exec からレガシーのディスクへのバックアップフォルダデバイスを削除します。

Syntax
Remove-BELegacyBackupToDiskFolderDevice -InputObject <BELegacyBackupToDiskFolderDevice[]> [-RemoveBackupSets <SwitchParameter>] [-PassThru <SwitchParameter>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec からレガシーのディスクへのバックアップフォルダデバイスを削除します。

Parameters

-RemoveBackupSets <SwitchParameter>

デバイスが正常に削除された後で、そのデバイスに関連付けられたすべてのバックアップセットを削除します。このパラメータは Backup Exec のカタログエントリのみを削除します。バックアップセットの内容は削除しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PassThru <SwitchParameter>

削除したオブジェクトをパイプラインに渡します。デフォルトでは、このコマンドレットは出力を生成しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BELegacyBackupToDiskFolderDevice[]>

1 つ以上のレガシーのディスクへのバックアップフォルダデバイスオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BELegacyBackupToDiskFolderDevice

レガシーのディスクへのバックアップフォルダデバイスオブジェクトを Remove-BELegacyBackupToDiskFolderDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BELegacyBackupToDiskFolderDevice

PassThru パラメータを使用した場合、Remove-BELegacyBackupToDiskFolderDevice は削除されたレガシーのディスクへのバックアップフォルダデバイスを表すオブジェクトを返します。 それ以外の場合、このコマンドレットは出力を生成しません。

Example

C:\PS> Get-BELegacyBackupToDiskFolderDevice "Device 0001" | Remove-BELegacyBackupToDiskFolderDevice

これらのコマンドは「Device 0001」という名前のレガシーのディスクへのバックアップフォルダデバイスを削除します。

Related Link

Get-BELegacyBackupToDiskFolderDevice


Remove-BELogonAccount Help

Remove-BELogonAccount Cmdlet
Synopsis

Backup Exec のログオンアカウントを削除します。

Syntax
Remove-BELogonAccount -InputObject <BELogonAccount[]> [-PassThru <SwitchParameter>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のログオンアカウントを削除します。

システムログオンアカウントとユーザーデフォルトログオンアカウントは削除できません。

Parameters

-PassThru <SwitchParameter>

削除したオブジェクトをパイプラインに渡します。デフォルトでは、このコマンドレットは出力を生成しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BELogonAccount[]>

1 つ以上のログオンアカウントオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BELogonAccount

Backup Exec のログオンアカウントオブジェクトを Remove-BELogonAccount にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BELogonAccount

PassThru パラメータを使用した場合、Remove-BELogonAccount は削除されたログオンアカウントを表すオブジェクトを返します。 それ以外の場合、このコマンドレットは出力を生成しません。

Example

C:\PS> Get-BELogonAccount "LogonAccount 0001" | Remove-BELogonAccount

これらのコマンドは「LogonAccount 0001」という名前のログオンアカウントを削除します。

Related Link

Get-BELogonAccount


Remove-BEMedia Help

Remove-BEMedia Cmdlet
Synopsis

Backup Exec からメディアを削除します。

Syntax
Remove-BEMedia -InputObject <BEMedia[]> [-PassThru <SwitchParameter>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [-Force <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec からメディアを削除します。

破棄メディアセットに関連付けられたメディアのみを削除できます。 破棄メディアに含まれないメディアを削除するには、-Force パラメータを使用します。

Parameters

-PassThru <SwitchParameter>

削除したオブジェクトをパイプラインに渡します。デフォルトでは、このコマンドレットは出力を生成しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEMedia[]>

1 つ以上のメディアオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Force <SwitchParameter>

メディアが破棄メディアに含まれない場合でも強制的に削除します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEMedia

Backup Exec のメディアオブジェクトを Remove-BEMedia にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEMedia

PassThru パラメータを使用した場合、Remove-BEMedia は削除されたメディアを表すオブジェクトを返します。 それ以外の場合、このコマンドレットは出力を生成しません。

Example

C:\PS> Get-BEMedia "Media 0001" | Remove-BEMedia

これらのコマンドは「Media 0001」という名前のメディアオブジェクトを削除します。

Related Link

Get-BEMedia


Remove-BEMediaSet Help

Remove-BEMediaSet Cmdlet
Synopsis

Backup Exec からメディアセットを削除します。

Syntax
Remove-BEMediaSet -InputObject <BEMediaSet[]> [-PassThru <SwitchParameter>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec からメディアセットを削除します。

システム定義のメディアセットは削除できません。

Parameters

-PassThru <SwitchParameter>

削除したオブジェクトをパイプラインに渡します。デフォルトでは、このコマンドレットは出力を生成しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEMediaSet[]>

1 つ以上のメディアセットオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEMediaSet

Backup Exec のメディアセットオブジェクトを Remove-BEMediaSet にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEMediaSet

PassThru パラメータを使用した場合、Remove-BEMediaSet は削除されたメディアセットを表すオブジェクトを返します。 それ以外の場合、このコマンドレットは出力を生成しません。

Example

C:\PS> Get-BEMediaSet "MediaSet 0001" | Remove-BEMediaSet

これらのコマンドは「MediaSet 0001」という名前のメディアセットを削除します。

Related Link

Get-BEMediaSet


Remove-BEMediaVault Help

Remove-BEMediaVault Cmdlet
Synopsis

Backup Exec からメディアボルトを削除します。

Syntax
Remove-BEMediaVault -InputObject <BEMediaVault[]> [-PassThru <SwitchParameter>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec からメディアボルトを削除します。

システム定義のメディアボルトは削除できません。

Parameters

-PassThru <SwitchParameter>

削除したオブジェクトをパイプラインに渡します。デフォルトでは、このコマンドレットは出力を生成しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEMediaVault[]>

1 つ以上のメディアボルトオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEMediaVault

Backup Exec メディアボルトオブジェクトを Remove-BEMediaVault にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEMediaVault

PassThru パラメータを使用した場合、Remove-BEMediaVault は削除されたメディアボルトを表すオブジェクトを返します。 それ以外の場合、このコマンドレットは出力を生成しません。

Example

C:\PS> Get-BEMediaVault "MediaVault 0001" | Remove-BEMediaVault

これらのコマンドは「MediaVault 0001」という名前のメディアボルトを削除します。

Related Link

Get-BEMediaVault


Remove-BENdmpServer Help

Remove-BENdmpServer Cmdlet
Synopsis

Backup Exec から NDMP サーバーを削除します。

Syntax
Remove-BENdmpServer -InputObject <BENdmpServer[]> [-PassThru <SwitchParameter>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec から NDMP サーバーを削除します。

Parameters

-PassThru <SwitchParameter>

削除したオブジェクトをパイプラインに渡します。デフォルトでは、このコマンドレットは出力を生成しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BENdmpServer[]>

1 つ以上の NDMP サーバーオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BENdmpServer

Backup Exec NDMP サーバーオブジェクトを Remove-BENdmpServer にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BENdmpServer

PassThru パラメータを使用した場合、Remove-BENdmpServer は削除された NDMP サーバーを表すオブジェクトを返します。それ以外の場合、このコマンドレットは出力を生成しません。

Example

C:\PS> $NDMPServer = Get-BENDMPServer -Name "MyServer.mycompany.com"
C:\PS> $NDMPServer | Set-BENDMPServer -Disabled $true
C:\PS> $NDMPServer | Remove-BENDMPServer

これらのコマンドは「MyServer.mycompany.com」という名前の NDMP サーバーを取得および無効にした後、それを Backup Exec から削除します。

Related Links


Remove-BENotificationRecipient Help

Remove-BENotificationRecipient Cmdlet
Synopsis

受信者をアラート通知の受信から削除します。

Syntax
Remove-BENotificationRecipient -InputObject <BENotificationRecipient[]> [-PassThru <SwitchParameter>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

受信者をアラート通知の受信から削除します。

Parameters

-PassThru <SwitchParameter>

削除したオブジェクトをパイプラインに渡します。デフォルトでは、このコマンドレットは出力を生成しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BENotificationRecipient[]>

1 つ以上の通知受信者オブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BENotificationRecipient

通知受信者オブジェクトを Remove-BENotificationRecipient にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BENotificationRecipient

PassThru パラメータを使用した場合、Remove-BENotificationRecipient は削除された通知受信者を表すオブジェクトを返します。それ以外の場合、このコマンドレットは出力を生成しません。

Examples

Example 1

C:\PS> Get-BENotificationRecipient -Name "john" | Remove-BENotificationRecipient

これらのコマンドは、「john」という名前の通知受信者を削除します。

Example 2
C:\PS> Get-BENotificationRecipient | Remove-BENotificationRecipient

これらのコマンドは、アラート通知を受け取るすべての通知受信者を削除します。

Related Link

Get-BENotificationRecipient


Remove-BENotificationRecipientGroup Help

Remove-BENotificationRecipientGroup Cmdlet
Synopsis

アラート通知用に設定されたグループを削除します。

Syntax
Remove-BENotificationRecipientGroup -InputObject <BENotificationRecipientGroup[]> [-PassThru <SwitchParameter>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

アラート通知用に設定されたグループを削除します。

Parameters

-PassThru <SwitchParameter>

削除したオブジェクトをパイプラインに渡します。デフォルトでは、このコマンドレットは出力を生成しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BENotificationRecipientGroup[]>

1 つ以上の通知受信者グループオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BENotificationRecipientGroup

通知受信者グループオブジェクトを Remove-BENotificationRecipientGroup にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BENotificationRecipientGroup

PassThru パラメータを使用した場合、Remove-BENotificationRecipientGroup は削除された通知受信者グループを表すオブジェクトを返します。それ以外の場合、このコマンドレットは出力を生成しません。

Examples

Example 1

C:\PS> Get-BENotificationRecipientGroup -Name "exampleName" | Remove-BENotificationRecipientGroup

これらのコマンドは「exampleName」という名前の通知受信者グループを削除します。

Example 2
C:\PS> Get-BENotificationRecipientGroup | Remove-BENotificationRecipientGroup

これらのコマンドはアラート通知用に設定されたすべてのグループを削除します。

Related Link

Get-BENotificationRecipientGroup


Remove-BENotificationRecipientObject Help

Remove-BENotificationRecipientObject Cmdlet
Synopsis

受信者または受信グループをアラート通知の受信から削除します。

Syntax
Remove-BENotificationRecipientObject ; CommonParameters=True; WorkflowCommonParameters=False; parameter=System.Object[]}, @{name=

Remove-BENotificationRecipientObject ; CommonParameters=True; WorkflowCommonParameters=False; parameter=System.Object[]}}
Description

受信者または受信グループをアラート通知の受信から削除します。

Parameters

-NotificationRecipient <BENotificationRecipient>

1 つ以上の通知受信者オブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NotificationRecipientGroup <BENotificationRecipientGroup>

1 つ以上の通知受信者グループオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-PassThru <SwitchParameter>

削除したオブジェクトをパイプラインに渡します。デフォルトでは、このコマンドレットは出力を生成しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BENotificationRecipient

通知受信者オブジェクトを Remove-BENotificationRecipientObject にパイプ処理できます。

BackupExec.Management.CLI.BENotificationRecipientGroup

通知受信者ｸﾞﾙｰﾌﾟオブジェクトを Remove-BENotificationRecipientObject にパイプ処理できます。

Return Values
BackupExec.Management.CLI.BENotificationRecipient

PassThru パラメータを使用した場合、Remove-BENotificationRecipientObject は削除された通知受信者を表すオブジェクトを返します。それ以外の場合、このコマンドレットは出力を生成しません。

BackupExec.Management.CLI.BENotificationRecipientGroup

PassThru パラメータを使用した場合、Remove-BENotificationRecipientObject は削除された通知受信者グループを表すオブジェクトを返します。それ以外の場合、このコマンドレットは出力を生成しません。

Examples

Example 1

C:\PS> Get-BENotificationRecipientObject -Name "john" | Remove-BENotificationRecipientObject

これらのコマンドは、「john」という名前の通知受信者を削除します。

Example 2
C:\PS> Get-BENotificationRecipientObject -Name "administrators" | Remove-BENotificationRecipientObject

これらのコマンドは、「administrators」という名前の通知受信者グループを削除します。

Example 3
C:\PS> Get-BENotificationRecipientObject | Remove-BENotificationRecipientObject

これらのコマンドはアラート通知を受信するすべての受信者および受信者グループを削除します。

Example 4
C:\PS> Get-BENotificationRecipient -Name "john" | Remove-BENotificationRecipientObject

これらのコマンドは、「john」という名前の通知受信者を削除します。

Example 5
C:\PS> Get-BENotificationRecipient | Remove-BENotificationRecipientObject

これらのコマンドは、アラート通知を受け取るすべての通知受信者を削除します。

Example 6
C:\PS> Get-BENotificationRecipientGroup -Name "administrators" | Remove-BENotificationRecipientObject

これらのコマンドは、「administrators」という名前の通知受信者グループを削除します。

Example 7
C:\PS> Get-BENotificationRecipientGroup | Remove-BENotificationRecipientObject

これらのコマンドはアラート通知を受信するすべての受信者グループを削除します。

Related Links


Remove-BEOneTimeBackupJob Help

Remove-BEOneTimeBackupJob Cmdlet
Synopsis

Backup Exec からワンタイムバックアップジョブを削除します。

Syntax
Remove-BEOneTimeBackupJob -InputObject <BEOneTimeBackupJob[]> [-PassThru <SwitchParameter>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec からワンタイムバックアップジョブを削除します。

Parameters

-PassThru <SwitchParameter>

削除したオブジェクトをパイプラインに渡します。デフォルトでは、このコマンドレットは出力を生成しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEOneTimeBackupJob[]>

1 つ以上の 1 回限りのバックアップオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEOneTimeBackupJob

Backup Exec ワンタイムバックアップジョブオブジェクトを Remove-BEOneTimeBackupJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEOneTimeBackupJob

PassThru パラメータを使用した場合、Remove-BEOneTimeBackupJob は削除されたワンタイムバックアップジョブを表すオブジェクトを返します。 それ以外の場合、このコマンドレットは出力を生成しません。

Examples

Example 1

C:\PS> Get-BEOneTimeBackupJob "Backup 01" | Remove-BEOneTimeBackupJob

これらのコマンドは「Backup 01」という名前のワンタイムバックアップジョブを削除します。

Example 2
C:\PS> Get-BEOneTimeBackupJob | Remove-BEOneTimeBackupJob

これらのコマンドはすべてのワンタイムバックアップジョブを削除します。

Related Link

Get-BEOneTimeBackupJob


Remove-BEOpenStorageDevice Help

Remove-BEOpenStorageDevice Cmdlet
Synopsis

Backup Exec から OpenStorage デバイスを削除します。

Syntax
Remove-BEOpenStorageDevice -InputObject <BEOpenStorageDevice[]> [-RemoveBackupSets <SwitchParameter>] [-PassThru <SwitchParameter>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec から OpenStorage デバイスを削除します。

Parameters

-RemoveBackupSets <SwitchParameter>

デバイスが正常に削除された後で、そのデバイスに関連付けられたすべてのバックアップセットを削除します。このパラメータは Backup Exec のカタログエントリのみを削除します。バックアップセットの内容は削除しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PassThru <SwitchParameter>

削除したオブジェクトをパイプラインに渡します。デフォルトでは、このコマンドレットは出力を生成しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEOpenStorageDevice[]>

1 つ以上の OpenStorage デバイスオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEOpenStorageDevice

Backup Exec OpenStorage デバイスオブジェクトを Remove-BEOpenStorageDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEOpenStorageDevice

PassThru パラメータを使用した場合、Remove-BEOpenStorageDevice は削除された OpenStorage デバイスを表すオブジェクトを返します。 それ以外の場合、このコマンドレットは出力を生成しません。

Example

C:\PS> Get-BEOpenStorageDevice "Device 0001" | Remove-BEOpenStorageDevice

これらのコマンドは「Device 0001」という名前の OpenStorage デバイスを削除します。

Related Link

Get-BEOpenStorageDevice


Remove-BEPreferredServerGroup Help

Remove-BEPreferredServerGroup Cmdlet
Synopsis

Backup Exec から優先サーバーの設定を削除します。

Syntax
Remove-BEPreferredServerGroup -InputObject <BEPreferredServerGroup[]> [-PassThru <SwitchParameter>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec から優先サーバーの設定を削除します。

Parameters

-PassThru <SwitchParameter>

削除したオブジェクトをパイプラインに渡します。デフォルトでは、このコマンドレットは出力を生成しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEPreferredServerGroup[]>

1 つ以上の優先サーバー設定オブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEPreferredServerGroup

Backup Exec 優先サーバーグループオブジェクトを Remove-BEPreferredServerGroup にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEPreferredServerGroup

PassThru パラメータを使用した場合、Remove-BEPreferredServerGroup は削除された優先サーバーグループを表すオブジェクトを返します。それ以外の場合、このコマンドレットは出力を生成しません。

Example

C:\PS> Get-BEPreferredServerGroup "ServerGroup 1" | Remove-BEPreferredServerGroup

このコマンドは「ServerGroup 1」という名前の BEPreferredServerGroup を削除します。

Related Link

Get-BEPreferredServerGroup


Remove-BERemoteMediaAgentForLinux Help

Remove-BERemoteMediaAgentForLinux Cmdlet
Synopsis

Backup Exec から Remote Media Agent for Linux サーバーを削除します。

Syntax
Remove-BERemoteMediaAgentForLinux -InputObject <BERemoteMediaAgentForLinux[]> [-PassThru <SwitchParameter>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec から Remote Media Agent for Linux サーバーを削除します。

Parameters

-PassThru <SwitchParameter>

削除したオブジェクトをパイプラインに渡します。デフォルトでは、このコマンドレットは出力を生成しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BERemoteMediaAgentForLinux[]>

1 つ以上の Remote Media Agent for Linux オブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BERemoteMediaAgentForLinux

Backup Exec Remote Media Agent for Linux オブジェクトを Remove-BERemoteMediaAgentForLinux にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BERemoteMediaAgentForLinux

PassThru パラメータを使用した場合、Remove-BERemoteMediaAgentForLinux は削除された Remote Media Agent for Linux を表すオブジェクトを返します。それ以外の場合、このコマンドレットは出力を生成しません。

Example

C:\PS> $RMALServer = Get-BERemoteMediaAgentForLinux -Name "MyServer.mycompany.com"
C:\PS> $RMALServer | Set-BERemoteMediaAgentForLinux -Disabled $true
C:\PS> $RMALServer | Remove-BERemoteMediaAgentForLinux

これらのコマンドは「MyServer.mycompany.com」という名前の Remote Media Agent for Linux サーバーを取得および無効にした後、それを Backup Exec から削除します。

Related Links


Remove-BERoboticLibraryDevice Help

Remove-BERoboticLibraryDevice Cmdlet
Synopsis

Backup Exec からロボットライブラリデバイスを削除します。

Syntax
Remove-BERoboticLibraryDevice -InputObject <BERoboticLibraryDevice[]> [-PassThru <SwitchParameter>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec からロボットライブラリデバイスを削除します。

Parameters

-PassThru <SwitchParameter>

削除したオブジェクトをパイプラインに渡します。デフォルトでは、このコマンドレットは出力を生成しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BERoboticLibraryDevice[]>

1 つ以上のロボットライブラリデバイスオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BERoboticLibraryDevice

Backup Exec ロボットライブラリデバイスオブジェクトを Remove-BERoboticLibraryDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BERoboticLibraryDevice

PassThru パラメータを使用した場合、Remove-BERoboticLibraryDevice は削除されたロボットライブラリデバイスを表すオブジェクトを返します。 それ以外の場合、このコマンドレットは出力を生成しません。

Example

C:\PS> Get-BERoboticLibraryDevice "Device 0001" | Remove-BERoboticLibraryDevice

これらのコマンドは「Device 0001」という名前のロボットライブラリデバイスを削除します。

Related Link

Get-BERoboticLibraryDevice


Remove-BEScheduleDatesToExclude Help

Remove-BEScheduleDatesToExclude Cmdlet
Synopsis

BESchedule の DatesToExclude から指定された日付リストを削除します。

Syntax
Remove-BEScheduleDatesToExclude -Schedule <BESchedule> [-DatesToExclude] <DateTime[]> [<CommonParameters>]

Remove-BEScheduleDatesToExclude -Schedule <BESchedule> -All <SwitchParameter> [<CommonParameters>]
Description

BESchedule の DatesToExclude から指定された日付リストを削除します。重複する日数、および現在 BESchedule の DatesToExclude の範囲にない日数は無視されます。

Parameters

-Schedule <BESchedule>

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-DatesToExclude <DateTime[]>

-Schedule パラメータの DatesToExclude から削除する日付を指定します。

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-All <SwitchParameter>

スケジュールからすべての DatesToExclude を削除します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BESchedule

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Return Value
BackupExec.Management.CLI.BESchedule

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Examples

Example 1

C:\PS> $s = New-BESchedule -Daily -StartingAt 9pm -DatesToExclude 1/1/2013, 1/1/2014, 1/1/2015, 1/1/2016, 1/1/2017
C:\PS> $s | Remove-BEScheduleDatesToExclude 1/1/2015

これらのコマンドは、毎日午後 9 時に実行され、2013、2014、2016、および 2017 年の 1 月 1 日を除外し、BESchedule の DatesToExclude から 2015 年 1 月 1 日を削除するようにジョブをスケジュールします。

Example 2
C:\PS> $s = New-BESchedule -Daily -StartingAt 9pm -DatesToExclude 1/1/2013, 1/1/2014, 1/1/2015, 1/1/2016, 1/1/2017
C:\PS> $s | Remove-BEScheduleDatesToExclude -All

これらのコマンドは、毎日午後 9 時に実行され、2013、2014、2016、および 2017 年の 1 月 1 日を除外し、BESchedule の DatesToExclude から 2015 年 1 月 1 日を削除するようにジョブをスケジュールします。

Example 3
C:\PS> $bd = Get-BEBackupDefinition "Payroll"
C:\PS> $s = $bd.InitialFullBackup.Schedule
C:\PS> $s | Remove-BEScheduleDatesToExclude 12/12/2015, 12/12/2016, 12/12/2017
C:\PS> $bd | Set-BEFullBackupTask -Name $bd.InitialFullBackup.Name -Schedule $s | Save-BEBackupDefinition

これらのコマンドは、「Payroll」という名前のバックアップ定義で初期フルバックアップのスケジュールを修正し、2015 から 2017 年の 12 月 12 日が除外されないようにます。

Related Links


Remove-BEScheduleDatesToInclude Help

Remove-BEScheduleDatesToInclude Cmdlet
Synopsis

BESchedule の DatesToInclude から指定された日付リストを削除します。

Syntax
Remove-BEScheduleDatesToInclude -Schedule <BESchedule> [-DatesToInclude] <DateTime[]> [<CommonParameters>]

Remove-BEScheduleDatesToInclude -Schedule <BESchedule> -All <SwitchParameter> [<CommonParameters>]
Description

BESchedule の DatesToInclude から指定された日付リストを削除します。重複する日数、および現在 BESchedule の DatesToInclude の範囲にない日数は無視されます。

Parameters

-Schedule <BESchedule>

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-DatesToInclude <DateTime[]>

-Schedule パラメータの DatesToInclude から削除する日付を指定します。

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-All <SwitchParameter>

スケジュールからすべての DatesToInclude を削除します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BESchedule

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Return Value
BackupExec.Management.CLI.BESchedule

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Examples

Example 1

C:\PS> $s = New-BESchedule -Daily -StartingAt 9pm -DatesToInclude 1/1/2013, 1/1/2014, 1/1/2015, 1/1/2016, 1/1/2017
C:\PS> $s | Remove-BEScheduleDatesToInclude 1/1/2015

これらのコマンドは、毎日午後 9 時に実行され、2013、2014、2016、および 2017 年の 1 月 1 日を含むスケジュールを作成します。2015 年 1 月 1 日は BESchedule の DatesToInclude から削除されました。

Example 2
C:\PS> $s = New-BESchedule -Daily -StartingAt 9pm -DatesToInclude 1/1/2013, 1/1/2014, 1/1/2015, 1/1/2016, 1/1/2017
C:\PS> $s | Remove-BEScheduleDatesToInclude -All

これらのコマンドは、毎日午後 9 時に実行され、2013、2014、2016、および 2017 年の 1 月 1 日を含むスケジュールを作成します。2015 年 1 月 1 日は BESchedule の DatesToInclude から削除されました。

Example 3
C:\PS> $bd = Get-BEBackupDefinition "Payroll"
C:\PS> $s = $bd.InitialFullBackup.Schedule
C:\PS> $s | Remove-BEScheduleDatesToInclude 12/12/2015, 12/12/2016, 12/12/2017
C:\PS> $bd | Set-BEFullBackupTask -Name $bd.InitialFullBackup.Name -Schedule $s | Save-BEBackupDefinition

これらのコマンドは、「Payroll」という名前のバックアップ定義で初期フルバックアップをスケジュールし、2015 から 2017 年の 12 月 12 日が含まれないように日付を修正します。

Related Links


Remove-BEServerFromBackupExecServerPool Help

Remove-BEServerFromBackupExecServerPool Cmdlet
Synopsis

Backup Exec サーバープールから管理対象 Backup Exec サーバーを削除します。

Syntax
Remove-BEServerFromBackupExecServerPool -InputObject <BEBackupExecServerPool[]> [-BackupExecServer] <BEBackupExecServer[]> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec サーバープールから管理対象 Backup Exec サーバーを削除します。

Parameters

-BackupExecServer <BEBackupExecServer[]>

プールから削除する管理対象 Backup Exec サーバーを指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEBackupExecServerPool[]>

1 つ以上の Backup Exec サーバープールオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupExecServerPool

Backup Exec サーバープールオブジェクトを Remove-BEServerFromBackupExecServerPool にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEBackupExecServerPool

Remove-BEServerFromBackupExecServerPool は、Backup Exec サーバープールオブジェクトを返します。

Example

C:\PS> Get-BEBackupExecServerPool "Server Pool 0001" | Remove-BEServerFromBackupExecServerPool -BackupExecServer "MyManagedServer"

これらのコマンドは、「MyManagedServer」という名前の管理対象 Backup Exec サーバーを「Server Pool 0001」という名前のサーバープールから削除します。

Related Link

Get-BEBackupExecServerPool


Remove-BEStorageArrayDevice Help

Remove-BEStorageArrayDevice Cmdlet
Synopsis

Backup Exec からストレージアレイデバイスを削除します。

Syntax
Remove-BEStorageArrayDevice -InputObject <BEStorageArrayDevice[]> [-PassThru <SwitchParameter>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec からストレージアレイデバイスを削除します。

Parameters

-PassThru <SwitchParameter>

削除したオブジェクトをパイプラインに渡します。デフォルトでは、このコマンドレットは出力を生成しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEStorageArrayDevice[]>

1 つ以上のストレージアレイデバイスオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEStorageArrayDevice

Backup Exec ストレージアレイデバイスオブジェクトを Remove-BEStorageArrayDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEStorageArrayDevice

PassThru パラメータを使用した場合、Remove-BEStorageArrayDevice は削除されたストレージアレイデバイスを表すオブジェクトを返します。 それ以外の場合、このコマンドレットは出力を生成しません。

Example

C:\PS> Get-BEStorageArrayDevice "Device 0001" | Remove-BEStorageArrayDevice

これらのコマンドは「Device 0001」という名前のストレージアレイデバイスを削除します。

Related Link

Get-BEStorageArrayDevice


Remove-BEStorageDevicePool Help

Remove-BEStorageDevicePool Cmdlet
Synopsis

Backup Exec からストレージデバイスプールを削除します。

Syntax
Remove-BEStorageDevicePool -InputObject <BEStorageDevicePool[]> [-PassThru <SwitchParameter>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec からストレージデバイスプールを削除します。

システム定義のストレージデバイスプールは削除できません。

Parameters

-PassThru <SwitchParameter>

削除したオブジェクトをパイプラインに渡します。デフォルトでは、このコマンドレットは出力を生成しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEStorageDevicePool[]>

1 つ以上のストレージデバイスプールオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEStorageDevicePool

Backup Exec ストレージデバイスプールオブジェクトを Remove-BEStorageDevicePool にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEStorageDevicePool

PassThru パラメータを使用した場合、Remove-BEStorageDevicePool は削除されたストレージデバイスプールを表すオブジェクトを返します。 それ以外の場合、このコマンドレットは出力を生成しません。

Example

C:\PS> Get-BEStorageDevicePool "StorageDevicePool 0001" | Remove-BEStorageDevicePool

これらのコマンドは「StorageDevicePool 0001」という名前のストレージデバイスプールを削除します。

Related Link

Get-BEStorageDevicePool


Remove-BESyntheticBackupDefinition Help

Remove-BESyntheticBackupDefinition Cmdlet
Synopsis

Backup Exec から合成バックアップ定義を削除します。

Syntax
Remove-BESyntheticBackupDefinition -InputObject <BESyntheticBackupDefinition[]> [-PassThru <SwitchParameter>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec から合成バックアップ定義を削除します。 合成バックアップ定義を削除すると、その合成バックアップ定義に関連付けられているジョブも削除されます。

Parameters

-PassThru <SwitchParameter>

削除したオブジェクトをパイプラインに渡します。デフォルトでは、このコマンドレットは出力を生成しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BESyntheticBackupDefinition[]>

1 つ以上の合成バックアップ定義オブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BESyntheticBackupDefinition

Backup Exec 合成バックアップ定義オブジェクトを Remove-BESyntheticBackupDefinition にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BESyntheticBackupDefinition

PassThru パラメータを使用すると、Remove-BESyntheticBackupDefinition は、削除された合成バックアップ定義を表すオブジェクトを返します。それ以外の場合、このコマンドレットは出力を生成しません。

Examples

Example 1

C:\PS> Get-BESyntheticBackupDefinition "Synthetic Backup Definition 01" | Remove-BESyntheticBackupDefinition

これらのコマンドは「Synthetic Backup Definition 01」という名前の合成バックアップ定義を削除します。

Example 2
C:\PS> Get-BESyntheticBackupDefinition | Remove-BESyntheticBackupDefinition

これらのコマンドはすべての合成バックアップ定義を削除します。

Related Link

Get-BESyntheticBackupDefinition


Remove-BETapeDriveDevice Help

Remove-BETapeDriveDevice Cmdlet
Synopsis

Backup Exec からテープドライブデバイスを削除します。

Syntax
Remove-BETapeDriveDevice -InputObject <BETapeDriveDevice[]> [-PassThru <SwitchParameter>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec からテープドライブデバイスを削除します。

Parameters

-PassThru <SwitchParameter>

削除したオブジェクトをパイプラインに渡します。デフォルトでは、このコマンドレットは出力を生成しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BETapeDriveDevice[]>

1 つ以上のテープドライブデバイスオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BETapeDriveDevice

Backup Exec テープドライブデバイスオブジェクトを Remove-BETapeDriveDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BETapeDriveDevice

PassThru パラメータを使用した場合、Remove-BETapeDriveDevice は削除されたテープドライブデバイスを表すオブジェクトを返します。 それ以外の場合、このコマンドレットは出力を生成しません。

Example

C:\PS> Get-BETapeDriveDevice "Device 0001" | Remove-BETapeDriveDevice

これらのコマンドは「Device 0001」という名前のテープドライブデバイスを削除します。

Related Link

Get-BETapeDriveDevice


Remove-BETapeDriveDeviceFromRoboticLibraryPartition Help

Remove-BETapeDriveDeviceFromRoboticLibraryPartition Cmdlet
Synopsis

テープドライブデバイスを Backup Exec のロボットライブラリパーティションから削除します。

Syntax
Remove-BETapeDriveDeviceFromRoboticLibraryPartition -InputObject <BERoboticLibraryPartition[]> [-TapeDriveDevice] <BETapeDriveDevice[]> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

テープドライブデバイスを Backup Exec のロボットライブラリパーティションから削除します。

Parameters

-TapeDriveDevice <BETapeDriveDevice[]>

ロボットライブラリパーティションから削除するテープドライブオブジェクト。 Get-BETapeDriveDevice を参照してください。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BERoboticLibraryPartition[]>

1 つ以上のロボットライブラリパーティションオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BERoboticLibraryPartition

Backup Exec ロボットライブラリパーティションオブジェクトを Remove-BETapeDriveDeviceFromRoboticLibraryPartition にパイプ処理することができます。

Return Value
BackupExec.Management.CLI.BERoboticLibraryPartition

Remove-BETapeDriveDeviceFromRoboticLibraryPartition は Backup Exec ロボットライブラリパーティションオブジェクトを出力します。

Example

C:\PS> Get-BERoboticLibraryDevice "Robotic library 0001" | Get-BERoboticLibraryPartition -FirstSlotNumber 1 | Remove-BETapeDriveDeviceFromRoboticLibraryPartition "Tape drive 0001"

これらのコマンドは「Tape drive 0001」という名前のテープドライブデバイスを「Robotic library 0001」という名前のロボットライブラリデバイスのスロット 1 で開始するロボットライブラリパーティションから削除します。

Related Links


Remove-BEVirtualDiskDevice Help

Remove-BEVirtualDiskDevice Cmdlet
Synopsis

Backup Exec から仮想ディスクデバイスを削除します。

Syntax
Remove-BEVirtualDiskDevice -InputObject <BEVirtualDiskDevice[]> [-RemoveBackupSets <SwitchParameter>] [-PassThru <SwitchParameter>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec から仮想ディスクデバイスを削除します。

Parameters

-RemoveBackupSets <SwitchParameter>

デバイスが正常に削除された後で、そのデバイスに関連付けられたすべてのバックアップセットを削除します。このパラメータは Backup Exec のカタログエントリのみを削除します。バックアップセットの内容は削除しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PassThru <SwitchParameter>

削除したオブジェクトをパイプラインに渡します。デフォルトでは、このコマンドレットは出力を生成しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEVirtualDiskDevice[]>

1 つ以上の仮想ディスクデバイスオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEVirtualDiskDevice

Backup Exec 仮想ディスクデバイスオブジェクトを Remove-BEVirtualDiskDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEVirtualDiskDevice

PassThru パラメータを使用した場合、Remove-BEVirtualDiskDevice は削除された仮想ディスクデバイスを表すオブジェクトを返します。 それ以外の場合、このコマンドレットは出力を生成しません。

Example

C:\PS> Get-BEVirtualDiskDevice "Device 0001" | Remove-BEVirtualDiskDevice

これらのコマンドは、「Device 0001」という名前の仮想ディスクデバイスを削除します。

Related Link

Get-BEVirtualDiskDevice


Rename-BEAgentServerGroup Help

Rename-BEAgentServerGroup Cmdlet
Synopsis

Backup Exec の新規エージェントサーバーグループの名前を変更します。

Syntax
Rename-BEAgentServerGroup [-InputObject] <BEAgentServerGroup> [-NewName] <String> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec の新規エージェントサーバーグループの名前を変更します。

Parameters

-InputObject <BEAgentServerGroup>

名前を変更するエージェントサーバーグループオブジェクトを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

エージェントサーバーグループオブジェクトに割り当てる新しい名前です。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEAgentServerGroup

Backup Exec エージェントサーバーグループオブジェクトを Rename-BEAgentServerGroup にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEAgentServerGroup

Rename-BEAgentServerGroup は名前が変更されたエージェントサーバーグループを表すオブジェクトを返します。

Example

C:\PS> Get-BEAgentServerGroup "Group 1" | Rename-BEAgentServerGroup -NewName "Accounting"

これらのコマンドは「Group 1」という名前のエージェントサーバーグループを「Accounting」という名前に変更します。

Related Link

Get-BEAgentServerGroup


Rename-BEBackupDefinition Help

Rename-BEBackupDefinition Cmdlet
Synopsis

Backup Exec のバックアップ定義の名前を変更します。

Syntax
Rename-BEBackupDefinition [-InputObject] <BEBackupDefinition> [-NewName] <String> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のバックアップ定義の名前を変更します。

Parameters

-InputObject <BEBackupDefinition>

名前を変更するバックアップ定義オブジェクトを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

バックアップ定義オブジェクトに割り当てる新しい名前を示します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupDefinition

パイプを使用して Backup Exec バックアップ定義オブジェクトを Rename-BEBackupDefinition に渡すことができます。

Return Value
BackupExec.Management.CLI.BEBackupDefinition

Rename-BEBackupDefinition は、名前が変更されたバックアップ定義を表すオブジェクトを返します。

Example

C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Rename-BEBackupDefinition -NewName "Backup Definition 02"

これらのコマンドでは、「Backup Definition 01」という名前のバックアップ定義の名前を「Backup Definition 02」に変更します。

Related Link

Get-BEBackupDefinition


Rename-BEBackupTask Help

Rename-BEBackupTask Cmdlet
Synopsis

Backup Exec のバックアップ定義に含まれるバックアップタスクの名前を変更します。

Syntax
Rename-BEBackupTask -BackupDefinition <BEBackupDefinition> [-Name] <String> [-NewName] <String> [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Rename-BEBackupTask -BackupJobDefault <BEBackupJobDefaults> [-Name] <String> [-NewName] <String> [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Rename-BEBackupTask -SyntheticBackupDefinition <BESyntheticBackupDefinition> [-Name] <String> [-NewName] <String> [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Rename-BEBackupTask -SyntheticBackupJobDefault <BESyntheticBackupJobDefaults> [-Name] <String> [-NewName] <String> [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のバックアップ定義に含まれるバックアップタスクの名前を変更します。

新しいバックアップ定義のバックアップタスクの名前を変更するには、Rename-BEBackupTask と New-BEBackupDefinition を使用します。

既存のバックアップ定義のバックアップタスクの名前を変更するには、Rename-BEBackupTask と Get-BEBackupDefinition を使用します。

バックアップ定義を作成または編集する場合、そのバックアップ定義を Save-BEBackupDefinition に渡して変更をコミットする必要があります。

バックアップジョブのデフォルトにあるバックアップタスクの名前を変更するには、Rename-BEBackupTask と Get-BEBackupJobDefault を使用します。

バックアップジョブのデフォルトを編集する場合、そのバックアップジョブのデフォルトを Save-BEBackupJobDefault に渡して変更をコミットする必要があります。

新規合成バックアップ定義のバックアップタスクの名前を変更するには、Rename-BEBackupTask と New-BESyntheticBackupDefinition を使用します。

既存の合成バックアップ定義のバックアップタスクの名前を変更するには、Rename-BEBackupTask と Get-BESyntheticBackupDefinition を使用します。

合成バックアップ定義を作成または編集する場合、そのバックアップ定義を Save-BESyntheticBackupDefinition に渡して変更をコミットする必要があります。

合成バックアップジョブのデフォルトにある合成バックアップタスクの名前を変更するには、Rename-BEBackupTask と Get-BESyntheticBackupJobDefault を使用します。

合成バックアップジョブのデフォルトを編集する場合、その合成バックアップジョブのデフォルトを Save-BESyntheticBackupJobDefault に渡して変更をコミットする必要があります。

Parameters

-BackupDefinition <BEBackupDefinition>

変更するバックアップ定義を指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupJobDefault <BEBackupJobDefaults>

変更するバックアップジョブのデフォルトを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-SyntheticBackupDefinition <BESyntheticBackupDefinition>

変更する合成バックアップ定義を指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-SyntheticBackupJobDefault <BESyntheticBackupJobDefaults>

変更する合成バックアップジョブのデフォルトを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String>

バックアップ定義で名前を変更するバックアップタスクの名前を指定します。

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-NewName <String>

バックアップタスクの新しい名前を示します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupDefinition

パイプを使用して Backup Exec バックアップ定義オブジェクトを Rename-BEBackupTask に渡すことができます。

BackupExec.Management.CLI.BEBackupJobDefaults

パイプを使用して Backup Exec バックアップジョブのデフォルトオブジェクトを Rename-BEBackupTask に渡すことができます。

BackupExec.Management.CLI.BESyntheticBackupDefinition

パイプを使用して Backup Exec 合成バックアップ定義オブジェクトを Rename-BEBackupTask に渡すことができます。

BackupExec.Management.CLI.BESyntheticBackupJobDefaults

パイプを使用して Backup Exec 合成バックアップジョブのデフォルトオブジェクトを Rename-BEBackupTask に渡すことができます。

Return Values
BackupExec.Management.CLI.BEBackupDefinition

修正されたバックアップ定義を示します。

BackupExec.Management.CLI.BEBackupJobDefaults

修正されたバックアップジョブのデフォルトを示します。

BackupExec.Management.CLI.BESyntheticBackupDefinition

修正された合成バックアップ定義を示します。

BackupExec.Management.CLI.BESyntheticBackupJobDefaults

修正された合成バックアップジョブのデフォルトを示します。

Examples

Example 1

C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Rename-BEBackupTask -Name "Full" -NewName "Full 1" | Save-BEBackupDefinition

これらのコマンドでは、「Backup Definition 01」という名前のバックアップ定義に含まれる「Full」というバックアップの名前を「Full 1」に変更します。

Example 2
C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Rename-BEBackupTask -Name "Duplicate" -NewName "Duplicate 1" | Save-BEBackupDefinition

これらのコマンドでは、「Backup Definition 01」という名前のバックアップ定義に含まれる「Duplicate」という複製ステージの名前を「Duplicate 1」に変更します。

Example 3
C:\PS> Get-BEBackupJobDefault BackupToDisk | Rename-BEBackupTask -Name "Full" -NewName "Full 1" | Save-BEBackupJobDefault

これらのコマンドでは、ディスクへのバックアップジョブのデフォルトに含まれる「Full」というバックアップの名前を「Full 1」に変更します。

Example 4
C:\PS> Get-BESyntheticBackupDefinition "Synthetic Backup Definition 01" | Rename-BEBackupTask -Name "Full" -NewName "Full 1" | Save-BESyntheticBackupDefinition

これらのコマンドでは、「Synthetic Backup Definition 01」という名前の合成バックアップ定義に含まれる「Full」という合成バックアップの名前を「Full 1」に変更します。

Example 5
C:\PS> Get-BESyntheticBackupDefinition "Synthetic Backup Definition 01" | Rename-BEBackupTask -Name "Duplicate" -NewName "Duplicate 1" | Save-BESyntheticBackupDefinition

これらのコマンドでは、「Synthetic Backup Definition 01」という名前の合成バックアップ定義に含まれる「Duplicate」という複製ステージの名前を「Duplicate 1」に変更します。

Example 6
C:\PS> Get-BESyntheticBackupJobDefault | Rename-BEBackupTask -Name "Full" -NewName "Full 1" | Save-BESyntheticBackupJobDefault

これらのコマンドでは、合成バックアップジョブのデフォルトに含まれる「Full」という合成バックアップの名前を「Full 1」に変更します。

Related Links

New-BEBackupDefinition
Get-BEBackupDefinition
Save-BEBackupDefinition
Get-BEBackupJobDefault
Save-BEBackupJobDefault
New-BESyntheticBackupDefinition
Get-BESyntheticBackupDefinition
Save-BESyntheticBackupDefinition
Get-BESyntheticBackupJobDefault
Save-BESyntheticBackupJobDefault


Rename-BECleanUtilityJob Help

Rename-BECleanUtilityJob Cmdlet
Synopsis

Backup Exec のクリーニングジョブの名前を変更します。

Syntax
Rename-BECleanUtilityJob [-InputObject] <BECleanUtilityJob> [-NewName] <String> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のクリーニングジョブの名前を変更します。

Parameters

-InputObject <BECleanUtilityJob>

名前を変更するクリーニングジョブオブジェクトを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

クリーニングジョブオブジェクトに割り当てる新しい名前を指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BECleanUtilityJob

Backup Exec クリーニングジョブオブジェクトを Rename-BECleanUtilityJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BECleanUtilityJob

Rename-BECleanUtilityJob は名前が変更されたクリーニングジョブを表すオブジェクトを返します。

Example

C:\PS> Get-BECleanUtilityJob -name "MyCleanUtilityJob" | Rename-BECleanUtilityJob -NewName "MyNewNamedCleanUtilityJob"

このコマンドは「MyCleanUtilityJob」という名前のクリーニングジョブを「MyNewNamedCleanUtilityJob」という名前に変更します。

Related Link

Get-BECleanUtilityJob


Rename-BECloudStorageDevice Help

Rename-BECloudStorageDevice Cmdlet
Synopsis

Backup Exec のクラウドストレージデバイスの名前を変更します。

Syntax
Rename-BECloudStorageDevice [-InputObject] <BECloudStorageDevice> [-NewName] <String> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のクラウドストレージデバイスの名前を変更します。

Parameters

-InputObject <BECloudStorageDevice>

名前を変更するクラウドストレージデバイスオブジェクトを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

クラウドストレージデバイスオブジェクトに割り当てる新しい名前を指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BECloudStorageDevice

Backup Exec クラウドストレージデバイスオブジェクトを Rename-BECloudStorageDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BECloudStorageDevice

Rename-BECloudStorageDevice は名前が変更されたクラウドストレージデバイスを表すオブジェクトを返します。

Example

C:\PS> Get-BECloudStorageDevice "Device 0001" | Rename-BECloudStorageDevice -NewName "Device 0002"

これらのコマンドは「Device 0001」というクラウドストレージデバイスの名前を「Device 0002」に変更します。

Related Link

Get-BECloudStorageDevice


Rename-BEConvertToVirtualJob Help

Rename-BEConvertToVirtualJob Cmdlet
Synopsis

Backup Exec での仮想への変換ジョブの名前を変更します。

Syntax
Rename-BEConvertToVirtualJob [-InputObject] <BEConvertToVirtualJob> [-NewName] <String> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec での仮想への変換ジョブの名前を変更します。

Parameters

-InputObject <BEConvertToVirtualJob>

名前を変更する仮想への変換ジョブを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

仮想への変換ジョブに割り当てる新しい名前を指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEConvertToVirtualJob

Backup Exec 仮想への変換ジョブオブジェクトを Rename-BEConvertToVirtualJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEConvertToVirtualJob

Rename-BEConvertToVirtualJob は名前が変更された仮想への変換ジョブを表すオブジェクトを返します。

Example

C:\PS> Get-BEConvertToVirtualJob -Name "Convert To Virtual Job 0001" | Rename-BEConvertToVirtualJob -NewName "Convert Job 1"

これらのコマンドは「Convert To Virtual Job 0001」という名前の仮想への変換ジョブを「Convert Job 1」という名前に変更します。

Related Link

Get-BEConvertToVirtualJob


Rename-BEDeduplicationDiskStorageDevice Help

Rename-BEDeduplicationDiskStorageDevice Cmdlet
Synopsis

Backup Exec の重複排除用ディスクストレージデバイスの名前を変更します。

Syntax
Rename-BEDeduplicationDiskStorageDevice [-InputObject] <BEDeduplicationDiskStorageDevice> [-NewName] <String> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec の重複排除用ディスクストレージデバイスの名前を変更します。

Parameters

-InputObject <BEDeduplicationDiskStorageDevice>

名前を変更する重複排除用ディスクストレージデバイスオブジェクトを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

重複排除用ディスクストレージデバイスオブジェクトに割り当てる新しい名前を指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEDeduplicationDiskStorageDevice

Backup Exec の重複排除用ディスクストレージデバイスオブジェクトを Rename-BEDeduplicationDiskStorageDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEDeduplicationDiskStorageDevice

Rename-BEDeduplicationDiskStorageDevice は名前が変更された重複排除用ディスクストレージデバイスを表すオブジェクトを返します。

Example

C:\PS> Get-BEDeduplicationDiskStorageDevice "Device 0001" | Rename-BEDeduplicationDiskStorageDevice -NewName "Device 0002"

これらのコマンドは「Device 0001」という重複排除用ディスクストレージデバイスの名前を「Device 0002」に変更します。

Related Link

Get-BEDeduplicationDiskStorageDevice


Rename-BEDiskCartridgeDevice Help

Rename-BEDiskCartridgeDevice Cmdlet
Synopsis

Backup Exec のディスクカートリッジデバイスの名前を変更します。

Syntax
Rename-BEDiskCartridgeDevice [-InputObject] <BEDiskCartridgeDevice> [-NewName] <String> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のディスクカートリッジデバイスの名前を変更します。

Parameters

-InputObject <BEDiskCartridgeDevice>

名前を変更するディスクカートリッジデバイスオブジェクトを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

ディスクカートリッジデバイスオブジェクトに割り当てる新しい名前を指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEDiskCartridgeDevice

Backup Exec のディスクカートリッジデバイスオブジェクトを Rename-BEDiskCartridgeDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEDiskCartridgeDevice

Rename-BEDiskCartridgeDevice は名前が変更されたディスクカートリッジデバイスを表すオブジェクトを返します。

Example

C:\PS> Get-BEDiskCartridgeDevice "Device 0001" | Rename-BEDiskCartridgeDevice -NewName "Device 0002"

これらのコマンドは「Device 0001」というディスクカートリッジデバイスの名前を「Device 0002」に変更します。

Related Link

Get-BEDiskCartridgeDevice


Rename-BEDiskStorageDevice Help

Rename-BEDiskStorageDevice Cmdlet
Synopsis

Backup Exec のディスクストレージデバイスの名前を変更します。

Syntax
Rename-BEDiskStorageDevice [-InputObject] <BEDiskStorageDevice> [-NewName] <String> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のディスクストレージデバイスの名前を変更します。

Parameters

-InputObject <BEDiskStorageDevice>

名前を変更するディスクストレージデバイスオブジェクトを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

ディスクストレージデバイスオブジェクトに割り当てる新しい名前を指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEDiskStorageDevice

Backup Exec のディスクストレージデバイスオブジェクトを Rename-BEDiskStorageDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEDiskStorageDevice

Rename-BEDiskStorageDevice は名前が変更されたディスクストレージデバイスを表すオブジェクトを返します。

Example

C:\PS> Get-BEDiskStorageDevice "Device 0001" | Rename-BEDiskStorageDevice -NewName "Device 0002"

これらのコマンドは「Device 0001」というディスクストレージデバイスの名前を「Device 0002」に変更します。

Related Link

Get-BEDiskStorageDevice


Rename-BEEjectUtilityJob Help

Rename-BEEjectUtilityJob Cmdlet
Synopsis

Backup Exec メディアの取り出しジョブの名前を変更します。

Syntax
Rename-BEEjectUtilityJob [-InputObject] <BEEjectUtilityJob> [-NewName] <String> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec メディアの取り出しジョブの名前を変更します。

Parameters

-InputObject <BEEjectUtilityJob>

名前を変更するメディアの取り出しジョブオブジェクトを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

メディアの取り出しジョブオブジェクトに割り当てる新しい名前を指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEEjectUtilityJob

Backup Exec メディアの取り出しジョブオブジェクトを Rename-BEEjectUtilityJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEEjectUtilityJob

Rename-BECleanUtilityJob は名前が変更されたメディアの取り出しジョブを表すオブジェクトを返します。

Example

C:\PS> Get-BEEjectUtilityJob -name "MyEjectUtilityJob" | Rename-BEEjectUtilityJob -NewName "MyNewNamedEjectUtilityJob"

このコマンドは「MyEjectUtilityJob」という名前のメディアの取り出しジョブを「MyNewNamedEjectUtilityJob」という名前に変更します。

Related Links


Rename-BEEraseUtilityJob Help

Rename-BEEraseUtilityJob Cmdlet
Synopsis

Backup Exec 消去操作ジョブの名前を変更します。

Syntax
Rename-BEEraseUtilityJob [-InputObject] <BEEraseUtilityJob> [-NewName] <String> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec 消去操作ジョブの名前を変更します。

Parameters

-InputObject <BEEraseUtilityJob>

名前を変更する消去操作ジョブオブジェクトを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

消去操作ジョブオブジェクトに割り当てる新しい名前を指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEEraseUtilityJob

Backup Exec 消去操作ジョブを Rename-BEEraseUtilityJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEEraseUtilityJob

Rename-BEEraseUtilityJob は名前が変更された消去操作ジョブを表すオブジェクトを返します。

Example

C:\PS> Get-BEEraseUtilityJob -name "MyEraseUtilityJob" | Rename-BEEraseUtilityJob -NewName "MyNewNamedEraseUtilityJob"

このコマンドは「MyEraseUtilityJob」という名前の消去操作ジョブの名前を「MyEraseUtilityJob」に変更します。

Related Link

Get-BEEraseUtilityJob


Rename-BEExportExpiredUtilityJob Help

Rename-BEExportExpiredUtilityJob Cmdlet
Synopsis

Backup Exec での期限切れメディアのエクスポートジョブの名前を変更します。

Syntax
Rename-BEExportExpiredUtilityJob [-InputObject] <BEExportExpiredUtilityJob> [-NewName] <String> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec での期限切れメディアのエクスポートジョブの名前を変更します。

Parameters

-InputObject <BEExportExpiredUtilityJob>

名前を変更する期限切れメディアのエクスポートジョブオブジェクトを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

期限切れメディアのエクスポートジョブオブジェクトに割り当てる新しい名前を指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEExportExpiredUtilityJob

Backup Exec 期限切れメディアのエクスポートジョブオブジェクトを Rename-BEExportExpiredUtilityJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEExportExpiredUtilityJob

Rename-BEExportExpiredUtilityJob は名前が変更された期限切れメディアのエクスポートジョブを表すオブジェクトを返します。

Example

C:\PS> Get-BEExportExpiredUtilityJob -name "MyExportExpiredUtilityJob" | Rename-BEExportExpiredUtilityJob -NewName "MyNewNamedExportExpiredUtilityJob"

このコマンドは「MyExportExpiredUtilityJob」という名前の期限切れメディアのエクスポートジョブを「MyExportExpiredUtilityJob」という名前に変更します。

Related Link

Get-BEExportExpiredUtilityJob


Rename-BEExportUtilityJob Help

Rename-BEExportUtilityJob Cmdlet
Synopsis

Backup Exec でのメディアをエクスポートするジョブの名前を変更します。

Syntax
Rename-BEExportUtilityJob [-InputObject] <BEExportUtilityJob> [-NewName] <String> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec でのメディアをエクスポートするジョブの名前を変更します。

Parameters

-InputObject <BEExportUtilityJob>

名前を変更するメディアのエクスポートジョブオブジェクトを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

メディアのエクスポートジョブオブジェクトに割り当てる新しい名前を指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEExportUtilityJob

Backup Exec メディアのエクスポートジョブオブジェクトを Rename-BEExportUtilityJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEExportUtilityJob

Rename-BEExportUtilityJob は名前が変更されたメディアのエクスポートジョブを表すオブジェクトを返します。

Example

C:\PS> Get-BEExportExpiredUtilityJob -name "MyExportUtilityJob" | Rename-BEExportExpiredUtilityJob -NewName "MyNewNamedExportUtilityJob"

このコマンドは「MyExportUtilityJob」という名前のメディアのエクスポートジョブを「MyExportUtilityJob」という名前に変更します。

Related Links


Rename-BEImportUtilityJob Help

Rename-BEImportUtilityJob Cmdlet
Synopsis

Backup Exec でのメディアのインポートジョブの名前を変更します。

Syntax
Rename-BEImportUtilityJob [-InputObject] <BEImportUtilityJob> [-NewName] <String> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec でのメディアのインポートジョブの名前を変更します。

Parameters

-InputObject <BEImportUtilityJob>

名前を変更するメディアのインポートジョブオブジェクトを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

メディアのインポートジョブオブジェクトに割り当てる新しい名前を指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEImportUtilityJob

Backup Exec メディアのインポートジョブオブジェクトを Rename-BEImportUtilityJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEImportUtilityJob

Rename-BEImportUtilityJob は名前が変更されたメディアのインポートジョブを表すオブジェクトを返します。

Example

C:\PS> Get-BEImportUtilityJob -name "MyImportUtilityJob" | Rename-BEImportUtilityJob -NewName "MyNewNamedImportUtilityJob"

このコマンドは「MyImportUtilityJob」という名前のメディアのインポートジョブを「MyNewNamedImportUtilityJob」という名前に変更します。

Related Link

Get-BEImportUtilityJob


Rename-BEInventoryUtilityJob Help

Rename-BEInventoryUtilityJob Cmdlet
Synopsis

Backup Exec のインベントリ操作ジョブの名前を変更します。

Syntax
Rename-BEInventoryUtilityJob [-InputObject] <BEInventoryUtilityJob> [-NewName] <String> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のインベントリ操作ジョブの名前を変更します。

Parameters

-InputObject <BEInventoryUtilityJob>

名前を変更するインベントリ操作ジョブオブジェクトを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

インベントリ操作ジョブオブジェクトに割り当てる新しい名前を指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEInventoryUtilityJob

Backup Exec インベントリ操作ジョブオブジェクトを Rename-BEInventoryUtilityJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEInventoryUtilityJob

Rename-BEInventoryUtilityJob は名前が変更されたインベントリ操作ジョブを表すオブジェクトを返します。

Example

C:\PS> Get-BEInventoryUtilityJob -name "MyInventoryUtilityJob" | Rename-BEInventoryUtilityJob -NewName "MyNewNamedInventoryUtilityJob"

このコマンドは「MyInventoryUtilityJob」という名前のインベントリ操作ジョブを「MyNewNamedInventoryUtilityJob」という名前に変更します。

Related Link

Get-BEInventoryUtilityJob


Rename-BELegacyBackupToDiskFolderDevice Help

Rename-BELegacyBackupToDiskFolderDevice Cmdlet
Synopsis

Backup Exec のレガシーのディスクへのバックアップフォルダデバイスの名前を変更します。

Syntax
Rename-BELegacyBackupToDiskFolderDevice [-InputObject] <BELegacyBackupToDiskFolderDevice> [-NewName] <String> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のレガシーのディスクへのバックアップフォルダデバイスの名前を変更します。

Parameters

-InputObject <BELegacyBackupToDiskFolderDevice>

名前を変更するレガシーのディスクへのバックアップフォルダデバイスオブジェクトを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

レガシーのディスクへのバックアップフォルダデバイスオブジェクトに割り当てる新しい名前を指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BELegacyBackupToDiskFolderDevice

Backup Exec のレガシーのディスクへのバックアップフォルダデバイスオブジェクトを Rename-BELegacyBackupToDiskFolderDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BELegacyBackupToDiskFolderDevice

Rename-BELegacyBackupToDiskFolderDevice は名前が変更されたレガシーのディスクへのバックアップフォルダデバイスを表すオブジェクトを返します。

Example

C:\PS> Get-BELegacyBackupToDiskFolderDevice "Device 0001" | Rename-BELegacyBackupToDiskFolderDevice -NewName "Device 0002"

これらのコマンドは「Device 0001」というレガシーのディスクへのバックアップフォルダデバイスの名前を「Device 0002」に変更します。

Related Link

Get-BELegacyBackupToDiskFolderDevice


Rename-BELogonAccount Help

Rename-BELogonAccount Cmdlet
Synopsis

Backup Exec ログオンアカウントの名前を変更します。

Syntax
Rename-BELogonAccount [-InputObject] <BELogonAccount> [-NewName] <String> [[-CurrentPassword] <SecureString>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec ログオンアカウントの名前を変更します。

システムログオンアカウントの名前は変更できません。

Parameters

-CurrentPassword <SecureString>

ログオンアカウントの現在のアカウントパスワードを指定します。 異なるユーザーによって作成された所有者専用ログオンアカウントの名前を変更する場合にこのパラメータが必要です。

Required | false
Position | 2
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BELogonAccount>

名前を変更するログオンアカウントオブジェクトを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

ログオンアカウントオブジェクトに割り当てる新しい名前を指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BELogonAccount

Backup Exec のログオンアカウントオブジェクトを Rename-BELogonAccount にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BELogonAccount

Rename-BELogonAccount returns は名前が変更されたログオンアカウントを表すオブジェクトを返します。

Example

C:\PS> Get-BELogonAccount "LogonAccount 0001" | Rename-BELogonAccount -NewName "LogonAccount 0002"

これらのコマンドは「LogonAccount 0001」というログオンアカウントの名前を「LogonAccount 0002」に変更します。

Related Link

Get-BELogonAccount


Rename-BEMedia Help

Rename-BEMedia Cmdlet
Synopsis

Backup Exec のメディアの名前を変更します。

Syntax
Rename-BEMedia [-InputObject] <BEMedia> [-NewName] <String> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のメディアの名前を変更します。

Parameters

-InputObject <BEMedia>

名前を変更するメディアオブジェクトを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

メディアオブジェクトに割り当てる新しい名前を指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEMedia

Backup Exec のメディアオブジェクトを Rename-BEMedia にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEMedia

Rename-BEMedia returns は名前が変更されたメディアを表すオブジェクトを返します。

Example

C:\PS> Get-BEMedia "Media 0001" | Rename-BEMedia -NewName "Media 0002"

これらのコマンドは「Media 0001」というメディアオブジェクトの名前を「Media 0002」に変更します。

Related Link

Get-BEMedia


Rename-BEMediaSet Help

Rename-BEMediaSet Cmdlet
Synopsis

Backup Exec のメディアセットの名前を変更します。

Syntax
Rename-BEMediaSet [-InputObject] <BEMediaSet> [-NewName] <String> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のメディアセットの名前を変更します。

システム定義のメディアセットの名前は変更できません。

Parameters

-InputObject <BEMediaSet>

名前を変更するメディアセットオブジェクトを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

メディアセットオブジェクトに割り当てる新しい名前を指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEMediaSet

Backup Exec のメディアセットオブジェクトを Rename-BEMediaSet にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEMediaSet

Rename-BEMediaSet は、名前が変更されたメディアセットを表すオブジェクトを返します。

Example

C:\PS> Get-BEMediaSet "MediaSet 0001" | Rename-BEMediaSet -NewName "MediaSet 0002"

これらのコマンドは「MediaSet 0001」というメディアセットの名前を「MediaSet 0002」に変更します。

Related Link

Get-BEMediaSet


Rename-BEMediaVault Help

Rename-BEMediaVault Cmdlet
Synopsis

Backup Exec のメディアボルトの名前を変更します。

Syntax
Rename-BEMediaVault [-InputObject] <BEMediaVault> [-NewName] <String> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のメディアボルトの名前を変更します。

システム定義のメディアボルトの名前は変更できません。

Parameters

-InputObject <BEMediaVault>

名前を変更するメディアボルトオブジェクトを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

メディアボルトオブジェクトに割り当てる新しい名前を指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEMediaVault

Backup Exec のメディアボルトオブジェクトを Rename-BEMediaVault にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEMediaVault

Rename-BEMediaVault は名前が変更されたメディアボルトを表すオブジェクトを返します。

Example

C:\PS> Get-BEMediaVault "MediaVault 0001" | Rename-BEMediaVault -NewName "MediaVault 0002"

これらのコマンドは「MediaVault 0001」というメディアボルトの名前を「MediaVault 0002」に変更します。

Related Link

Get-BEMediaVault


Rename-BENotificationRecipient Help

Rename-BENotificationRecipient Cmdlet
Synopsis

アラートを受信する通知受信者の名前を変更します。

Syntax
Rename-BENotificationRecipient [-InputObject] <BENotificationRecipient> [-NewName] <String> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

アラートを受信する通知受信者の名前を変更します。

Parameters

-InputObject <BENotificationRecipient>

名前を変更する通知受信者を指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

通知受信者に割り当てる新しい名前を指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BENotificationRecipient

受信者オブジェクトを Rename-BENotificationRecipient にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BENotificationRecipient

Rename-BENotificationRecipient は、名前が変更された通知受信者を表すオブジェクトを返します。

Example

C:\PS> Get-BENotificationRecipient "John" | Rename-BENotificationRecipient -NewName "Jim"

これらのコマンドは通知受信者の名前を「John」から「Jim」に変更します。

Related Link

Get-BENotificationRecipient


Rename-BENotificationRecipientGroup Help

Rename-BENotificationRecipientGroup Cmdlet
Synopsis

アラート通知用に設定されたグループの名前を変更します。

Syntax
Rename-BENotificationRecipientGroup [-InputObject] <BENotificationRecipientGroup> [-NewName] <String> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

アラート通知用に設定されたグループの名前を変更します。

Parameters

-InputObject <BENotificationRecipientGroup>

名前を変更するグループを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

グループに割り当てる新しい名前を指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BENotificationRecipientGroup

通知受信者グループオブジェクトを Rename-BENotificationRecipientGroup にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BENotificationRecipientGroup

Rename-BENotificationRecipientGroup は、名前が変更されたグループを表すオブジェクトを返します。

Example

C:\PS> Get-BENotificationRecipientGroup "exampleName" | Rename-BENotificationRecipientGroup -NewName "NewGroupName"

これらのコマンドはグループの名前を「exampleName」から「NewGroupName」に変更します。

Related Link

Get-BENotificationRecipientGroup


Rename-BEOneTimeBackupJob Help

Rename-BEOneTimeBackupJob Cmdlet
Synopsis

Backup Exec のワンタイムバックアップジョブの名前を変更します。

Syntax
Rename-BEOneTimeBackupJob [-InputObject] <BEOneTimeBackupJob> [-NewName] <String> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のワンタイムバックアップジョブの名前を変更します。

Parameters

-InputObject <BEOneTimeBackupJob>

名前を変更するワンタイムバックアップジョブオブジェクトを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

ワンタイムバックアップジョブオブジェクトに割り当てる新しい名前を指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEOneTimeBackupJob

Backup Exec ワンタイムバックアップジョブオブジェクトを Rename-BEOneTimeBackupJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEOneTimeBackupJob

Rename-BEOneTimeBackupJob は、名前が変更されたワンタイムバックアップジョブを表すオブジェクトを返します。

Example

C:\PS> Get-BEOneTimeBackupJob "Backup 01" | Rename-BEOneTimeBackupJob -NewName "Backup 02"

これらのコマンドはワンタイムバックアップジョブの名前を「Backup 01」から「Backup 02」に変更します。

Related Link

Get-BEOneTimeBackupJob


Rename-BEOpenStorageDevice Help

Rename-BEOpenStorageDevice Cmdlet
Synopsis

Backup Exec の OpenStorage デバイスの名前を変更します。

Syntax
Rename-BEOpenStorageDevice [-InputObject] <BEOpenStorageDevice> [-NewName] <String> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec の OpenStorage デバイスの名前を変更します。

Parameters

-InputObject <BEOpenStorageDevice>

名前を変更する OpenStorage デバイスオブジェクトを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

OpenStorage デバイスオブジェクトを割り当てる新しい名前を指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEOpenStorageDevice

Backup Exec OpenStorage デバイスオブジェクトを Rename-BEOpenStorageDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEOpenStorageDevice

Rename-BEOpenStorageDevice は名前が変更された OpenStorage デバイスを表すオブジェクトを返します。

Example

C:\PS> Get-BEOpenStorageDevice "Device 0001" | Rename-BEOpenStorageDevice -NewName "Device 0002"

これらのコマンドは「Device 0001」という OpenStorage の名前を「Device 0002」に変更します。

Related Link

Get-BEOpenStorageDevice


Rename-BEPreferredServerGroup Help

Rename-BEPreferredServerGroup Cmdlet
Synopsis

優先サーバー設定の名前を変更します。

Syntax
Rename-BEPreferredServerGroup [-InputObject] <BEPreferredServerGroup> [-NewName] <String> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

優先サーバー設定の名前を変更します。

Parameters

-InputObject <BEPreferredServerGroup>

名前を変更する優先サーバー設定オブジェクトを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

優先サーバー設定オブジェクトに割り当てる新しい名前。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEPreferredServerGroup

Backup Exec 優先サーバー設定オブジェクトを Rename-BEPreferredServerGroup にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEPreferredServerGroup

Rename-BEPreferredServerGroup は、名前が変更された優先サーバーグループを表すオブジェクトを返します。

Example

C:\PS> Get-BEPreferredServerGroup "ServerGroup 1" | Rename-BEPreferredServerGroup -NewName "ServerGroup 2"

このコマンドは「ServerGroup 1」という名前を「ServerGroup 2」に変更します。

Related Link

Get-BEPreferredServerGroup


Rename-BERoboticLibraryDevice Help

Rename-BERoboticLibraryDevice Cmdlet
Synopsis

Backup Exec のロボットライブラリデバイスの名前を変更します。

Syntax
Rename-BERoboticLibraryDevice [-InputObject] <BERoboticLibraryDevice> [-NewName] <String> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のロボットライブラリデバイスの名前を変更します。

Parameters

-InputObject <BERoboticLibraryDevice>

名前を変更するロボットライブラリデバイスオブジェクトを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

ロボットライブラリデバイスオブジェクトに割り当てる新しい名前を指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BERoboticLibraryDevice

Backup Exec のロボットライブラリデバイスオブジェクトを Rename-BERoboticLibraryDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BERoboticLibraryDevice

Rename-BERoboticLibraryDevice は名前が変更されたロボットライブラリデバイスを表すオブジェクトを返します。

Example

C:\PS> Get-BERoboticLibraryDevice "Device 0001" | Rename-BERoboticLibraryDevice -NewName "Device 0002"

これらのコマンドは「Device 0001」というロボットライブラリデバイスの名前を「Device 0002」に変更します。

Related Link

Get-BERoboticLibraryDevice


Rename-BEScanUtilityJob Help

Rename-BEScanUtilityJob Cmdlet
Synopsis

Backup Exec のスキャン操作ジョブの名前を変更します。

Syntax
Rename-BEScanUtilityJob [-InputObject] <BEScanUtilityJob> [-NewName] <String> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のスキャン操作ジョブの名前を変更します。

Parameters

-InputObject <BEScanUtilityJob>

名前を変更するスキャン操作ジョブオブジェクトを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

スキャン操作ジョブオブジェクトに割り当てる新しい名前を指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEScanUtilityJob

Backup Exec スキャン操作ジョブオブジェクトを Rename-BEScanUtilityJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEScanUtilityJob

Rename-BEScanUtilityJob は、名前が変更されたスキャン操作ジョブを表すオブジェクトを返します。

Example

C:\PS> Get-BEScanUtilityJob -name "MyScanUtilityJob" | Rename-BEScanUtilityJob -NewName "MyNewNamedScanUtilityJob"

このコマンドは「MyScanUtilityJob」という名前のスキャン操作ジョブの名前を「MyNewNamedScanUtilityJob」に変更します。

Related Link

Get-BEScanUtilityJob


Rename-BEStorageArrayDevice Help

Rename-BEStorageArrayDevice Cmdlet
Synopsis

Backup Exec のストレージアレイデバイスの名前を変更します。

Syntax
Rename-BEStorageArrayDevice [-InputObject] <BEStorageArrayDevice> [-NewName] <String> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のストレージアレイデバイスの名前を変更します。

Parameters

-InputObject <BEStorageArrayDevice>

名前を変更するストレージアレイデバイスオブジェクトを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

ストレージアレイデバイスオブジェクトに割り当てる新しい名前を指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEStorageArrayDevice

Backup Exec のストレージアレイデバイスオブジェクトを Rename-BEStorageArrayDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEStorageArrayDevice

Rename-BEStorageArrayDevice は名前が変更されたストレージアレイデバイスを表すオブジェクトを返します。

Example

C:\PS> Get-BEStorageArrayDevice "Device 0001" | Rename-BEStorageArrayDevice -NewName "Device 0002"

これらのコマンドは「Device 0001」というストレージアレイデバイスの名前を「Device 0002」に変更します。

Related Link

Get-BEStorageArrayDevice


Rename-BEStorageDevicePool Help

Rename-BEStorageDevicePool Cmdlet
Synopsis

Backup Exec のストレージデバイスプールの名前を変更します。

Syntax
Rename-BEStorageDevicePool [-InputObject] <BEStorageDevicePool> [-NewName] <String> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のストレージデバイスプールの名前を変更します。

システム定義のストレージデバイスプールの名前は変更できません。

Parameters

-InputObject <BEStorageDevicePool>

名前を変更するストレージデバイスプールオブジェクトを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

ストレージデバイスプールオブジェクトに割り当てる新しい名前を指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEStorageDevicePool

Backup Exec のストレージデバイスプールオブジェクトを Rename-BEStorageDevicePool にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEStorageDevicePool

Rename-BEStorageDevicePool は名前が変更されたストレージデバイスプールを表すオブジェクトを返します。

Example

C:\PS> Get-BEStorageDevicePool "StorageDevicePool 0001" | Rename-BEStorageDevicePool -NewName "StorageDevicePool 0002"

これらのコマンドは「StorageDevicePool 0001」というストレージデバイスプールの名前を「StorageDevicePool 0002」に変更します。

Related Link

Get-BEStorageDevicePool


Rename-BESyntheticBackupDefinition Help

Rename-BESyntheticBackupDefinition Cmdlet
Synopsis

Backup Exec の合成バックアップ定義の名前を変更します。

Syntax
Rename-BESyntheticBackupDefinition [-InputObject] <BESyntheticBackupDefinition> [-NewName] <String> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec の合成バックアップ定義の名前を変更します。

Parameters

-InputObject <BESyntheticBackupDefinition>

名前を変更する合成バックアップ定義オブジェクトを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

合成バックアップ定義オブジェクトに割り当てる新しい名前を示します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BESyntheticBackupDefinition

Backup Exec 合成バックアップ定義オブジェクトを Remove-BESyntheticBackupDefinition にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BESyntheticBackupDefinition

Rename-BESyntheticBackupDefinition は、名前が変更された合成バックアップ定義を表すオブジェクトを返します。

Example

C:\PS> Get-BESyntheticBackupDefinition "Synthetic Backup Definition 01" | Rename-BESyntheticBackupDefinition -NewName "Synthetic Backup Definition 02"

これらのコマンドは「Synthetic Backup Definition 01」という名前の合成バックアップ定義の名前を「Synthetic Backup Definition 02」に変更します。

Related Links


Rename-BETapeDriveDevice Help

Rename-BETapeDriveDevice Cmdlet
Synopsis

Backup Exec のテープドライブデバイスの名前を変更します。

Syntax
Rename-BETapeDriveDevice [-InputObject] <BETapeDriveDevice> [-NewName] <String> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のテープドライブデバイスの名前を変更します。

Parameters

-InputObject <BETapeDriveDevice>

名前を変更するテープドライブデバイスオブジェクトを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

テープドライブデバイスオブジェクトに割り当てる新しい名前を指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BETapeDriveDevice

Backup Exec のテープドライブデバイスオブジェクトを Rename-BETapeDriveDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BETapeDriveDevice

Rename-BETapeDriveDevice は名前が変更されたテープドライブデバイスを表すオブジェクトを返します。

Example

C:\PS> Get-BETapeDriveDevice "Device 0001" | Rename-BETapeDriveDevice -NewName "Device 0002"

これらのコマンドは「Device 0001」というテープドライブデバイスの名前を「Device 0002」に変更します。

Related Link

Get-BETapeDriveDevice


Rename-BEUnlockUtilityJob Help

Rename-BEUnlockUtilityJob Cmdlet
Synopsis

ロボットライブラリのフロントポータルをロック解除する Backup Exec のジョブの名前を変更します。

Syntax
Rename-BEUnlockUtilityJob [-InputObject] <BEUnlockUtilityJob> [-NewName] <String> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

ロボットライブラリのフロントポータルをロック解除する Backup Exec のジョブの名前を変更します。

Parameters

-InputObject <BEUnlockUtilityJob>

名前を変更するロック解除ジョブオブジェクトを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

ロック解除オブジェクトに割り当てる新しい名前を指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEUnlockUtilityJob

Backup Exec ロック解除ジョブを Rename-BEUnlockUtilityJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEUnlockUtilityJob

Rename-BEUnlockUtilityJob は名前が変更されたロボットライブラリのフロントポータルをロック解除するジョブを表すオブジェクトを返します。

Example

C:\PS> Get-BEUnlockUtilityJob -name "MyUnlockUtilityJob" | Rename-BEUnlockUtilityJob -NewName "MyNewNamedUnlockUtilityJob"

このコマンドは「MyScanUnlockUtilityJob」というロック解除ジョブの名前を「MyNewNamedUnlockUtilityJob」に変更します。

Related Link

Get-BEUnlockUtilityJob


Rename-BEVirtualDiskDevice Help

Rename-BEVirtualDiskDevice Cmdlet
Synopsis

Backup Exec の仮想ディスクデバイスの名前を変更します。

Syntax
Rename-BEVirtualDiskDevice [-InputObject] <BEVirtualDiskDevice> [-NewName] <String> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec の仮想ディスクデバイスの名前を変更します。

Parameters

-InputObject <BEVirtualDiskDevice>

名前を変更する仮想ディスクデバイスオブジェクトを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

仮想ディスクデバイスオブジェクトに割り当てる新しい名前を指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEVirtualDiskDevice

Backup Exec の仮想ディスクデバイスオブジェクトを Rename-BEVirtualDiskDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEVirtualDiskDevice

Rename-BEVirtualDiskDevice は名前が変更された仮想ディスクデバイスを表すオブジェクトを返します。

Example

C:\PS> Get-BEVirtualDiskDevice "Device 0001" | Rename-BEVirtualDiskDevice -NewName "Device 0002"

これらのコマンドは「Device 0001」という仮想ディスクデバイスの名前を「Device 0002」に変更します。

Related Link

Get-BEVirtualDiskDevice


Reset-BETapeDriveCleaningStatistic Help

Reset-BETapeDriveCleaningStatistic Cmdlet
Synopsis

リモートサーバー上のテープドライブのクリーニング情報をリセットします。

Syntax
Reset-BETapeDriveCleaningStatistic -InputObject <BETapeDriveDevice[]> [<CommonParameters>]
Description

リモートサーバー上のテープドライブのクリーニング情報をリセットします。

Parameters

-InputObject <BETapeDriveDevice[]>

1 つ以上のテープドライブオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BETapeDriveDevice

Backup Exec テープドライブオブジェクトを Reset-BETapeDriveCleaningStatistic にパイプ処理することができます。

Return Value
BackupExec.Management.CLI.BETapeDriveDevice

Reset-BETapeDriveCleaningStatistic はクリーニング情報がリセットされたテープドライブを表すオブジェクトを返します。

Example

C:\PS> $TapeDrive = Get-BETapeDriveDevice -Name "Tape drive 0001"
C:\PS> $TapeDrive | Reset-BETapeDriveCleaningStatistic

このコマンドはパイプ処理された Backup Exec のテープドライブデバイスのクリーニング情報をリセットします。

Related Link

Get-BETapeDriveDevice


Restart-BEService Help

Restart-BEService Cmdlet
Synopsis

1 つ以上の Backup Exec サービスを再起動します。

Syntax
Restart-BEService [[-Name] <String[]>] [-All <SwitchParameter>] [-TimeoutSeconds <Int32>] [-PassThru <SwitchParameter>] [-ServiceType {Core | Deduplication}] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Restart-BEService -DisplayName <String[]> [-All <SwitchParameter>] [-ServiceType {Core | Deduplication}] [-TimeoutSeconds <Int32>] [-PassThru <SwitchParameter>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

1 つ以上の Backup Exec サービスを再起動します。

Restart-BEService にパラメータを渡さない場合、すべてのコア Backup Exec サービスが再起動されます。

Parameters

-TimeoutSeconds <Int32>

各 Backup Exec サービスの再起動の時間の長さを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PassThru <SwitchParameter>

サービスを表すオブジェクトを返します。 デフォルトでは、このコマンドレットは出力を生成しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String[]>

再起動する Backup Exec サービスの名前を指定します。

Required | false
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | true

-DisplayName <String[]>

再起動する Backup Exec サービスの共通名を指定します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ServiceType

再起動する Backup Exec サービスの種類を指定します。

The valid values are:
Core
Deduplication

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-All <SwitchParameter>

Backup Exec のすべてのサービスを再起動します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

Backup Exec サービスの名前を Restart-BEService にパイプ処理できます。

Return Value
System.ServiceProcess.ServiceController

PassThru パラメータを指定した場合、Restart-BEService はサービスを表す System.ServiceProcess.ServiceController オブジェクトを生成します。 それ以外の場合、このコマンドレットは出力を生成しません。

Examples

Example 1

C:\PS> Restart-BEService

このコマンドは、すべての Backup Exec コアサービスを再起動します。

Example 2
C:\PS> Restart-BEService -ServiceType Deduplication

このコマンドは、すべての Backup Exec 重複排除用サービスを再起動します。


Resume-BEJob Help

Resume-BEJob Cmdlet
Synopsis

Backup Exec のジョブの保留を解除します。

Syntax
Resume-BEJob -InputObject <BEJob[]> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のジョブの保留を解除します。

保留中のジョブを再開するには Resume-BEJob を使用します (Suspend-BEJob を参照)。

Parameters

-InputObject <BEJob[]>

1 つ以上のジョブオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEJob

Backup Exec ジョブオブジェクトを Resume-BEJob にパイプ処理することができます。

Return Value
BackupExec.Management.CLI.BEJob

Resume-BEJob は Backup Exec ジョブオブジェクトを返します。

Example

C:\PS> Get-BEJob "Job 0001" | Resume-BEJob

これらのコマンドは「Job 0001」という名前のジョブの保留を解除します。

Related Links


Resume-BEJobQueue Help

Resume-BEJobQueue Cmdlet
Synopsis

Backup Exec のサーバーのジョブキューの保留を解除します。

Syntax
Resume-BEJobQueue [-BackupExecServer <BEBackupExecServer>] [<CommonParameters>]
Description

Backup Exec のサーバーのジョブキューの保留を解除します。

保留中のサーバーのジョブキューを再開するには Resume-BEJobQueue を使用します (Suspend-BEJobQueue を参照)。

-BackupExecServer パラメータを指定しない場合、Resume-BEJobQueue はローカル Backup Exec サーバーのジョブキューの保留を解除します。

Parameters

-BackupExecServer <BEBackupExecServer>

CASO 環境でジョブキューの保留を解除する Backup Exec サーバーを指定します。

Required | false
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトを Resume-BEJobQueue にパイプ処理することができます。

Return Value
BackupExec.Management.CLI.BEBackupExecServer

Resume-BEJobQueue は Backup Exec サーバーオブジェクトを返します。

Examples

Example 1

C:\PS> Resume-BEJobQueue

このコマンドはローカル Backup Exec サーバーのジョブキューの保留を解除します。

Example 2
C:\PS> Get-BEBackupExecServer "ManagedServer0001" | Resume-BEJobQueue

これらのコマンドは「ManagedServer0001」という名前の Backup Exec サーバーのジョブキューの保留を解除します。

Related Links


Save-BEBackupDefinition Help

Save-BEBackupDefinition Cmdlet
Synopsis

新しい、または修正されたバックアップ定義を Backup Exec に保存します。

Syntax
Save-BEBackupDefinition [-BackupDefinition] <BEBackupDefinition> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [-Force <SwitchParameter>] [<CommonParameters>]
Description

新しい、または修正されたバックアップ定義を Backup Exec に保存します。

新しいバックアップ定義を作成した場合 (New-BEBackupDefinition を参照) や、バックアップ定義を編集した場合 (Get-BEBackupDefinition を参照) は、バックアップ定義を Save-BEBackupDefinition に渡して変更内容をコミットする必要があります。

Parameters

-BackupDefinition <BEBackupDefinition>

保存するバックアップ定義を指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Force <SwitchParameter>

Save-BEBackupDefinition がダイレクトアクセスの使用時に続行可能で、エージェントサーバーがデフォルトのポート 10000 以外を使用していることを確認します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupDefinition

パイプを使用して Backup Exec バックアップ定義オブジェクトを Save-BEBackupDefinition に渡すことができます。

Return Value
BackupExec.Management.CLI.BEBackupDefinition

Save-BEBackupDefinition は、保存されたバックアップ定義を返します。

Examples

Example 1

C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition -BackupJobDefault BackupToDisk | Save-BEBackupDefinition

これらのコマンドでは、BackupToDisk のデフォルトを使用してローカルコンピュータ全体をバックアップするバックアップ定義を新しく作成します。

Example 2
C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Add-BEDifferentialBackupTask | Save-BEBackupDefinition

これらのコマンドでは、差分バックアップを「Backup Definition 01」という名前のバックアップ定義に追加します。

Related Links


Save-BEBackupJobDefault Help

Save-BEBackupJobDefault Cmdlet
Synopsis

変更された Backup Exec ジョブのデフォルトを保存します。

Syntax
Save-BEBackupJobDefault [-BackupJobDefault] <BEBackupJobDefaults> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

変更された Backup Exec ジョブのデフォルトを保存します。

バックアップジョブのデフォルトを編集する場合（Get-BEBackupJobDefault を参照）、バックアップジョブのデフォルトを Save-BEBackupJobDefault に渡して変更をコミットする必要があります。

Parameters

-BackupJobDefault <BEBackupJobDefaults>

保存するバックアップジョブのデフォルトを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupJobDefaults

Backup Exec バックアップジョブのデフォルトオブジェクトを、パイプを使用して Save-BEBackupJobDefault に渡すことができます。

Return Value
BackupExec.Management.CLI.BEBackupJobDefaults

Save-BEBackupJobDefault は、保存されたバックアップジョブのデフォルトを返します。

Examples

Example 1

C:\PS> Get-BEBackupJobDefault BackupToTape | Set-BEBackupJobDefault -FileSystemBackupMethod UseModifiedTime | Save-BEBackupJobDefault

これらのコマンドは、テープファイルシステムバックアップ方式に対するデフォルトのバックアップを「UseModifiedTime」に設定します。

Example 2
C:\PS> Get-BEBackupJobDefault BackupToTape | Add-BEDifferentalBackupTask | Save-BEBackupJobDefault

これらのコマンドは、差分バックアップをテープへのバックアップジョブのデフォルトに追加します。

Related Links


Save-BESyntheticBackupDefinition Help

Save-BESyntheticBackupDefinition Cmdlet
Synopsis

新しい、または修正された合成バックアップ定義を Backup Exec に保存します。

Syntax
Save-BESyntheticBackupDefinition [-SyntheticBackupDefinition] <BESyntheticBackupDefinition> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [-Force <SwitchParameter>] [<CommonParameters>]
Description

新しい、または修正された合成バックアップ定義を Backup Exec に保存します。

新しい合成バックアップ定義を作成した場合 (New-BESyntheticBackupDefinition を参照) や、合成バックアップ定義を編集した場合 (Get-BESyntheticBackupDefinitio を参照) は、合成バックアップ定義を Save-BESyntheticBackupDefinition に渡して変更内容をコミットする必要があります。

Parameters

-SyntheticBackupDefinition <BESyntheticBackupDefinition>

保存する合成バックアップ定義を指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Force <SwitchParameter>

ダイレクトアクセスを使用し、エージェントサーバーがデフォルトのポート 10000 以外のポートを使用する場合に、Save-BESyntheticBackupDefinitio が続行可能かを確認します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BESyntheticBackupDefinition

Backup Exec 合成バックアップ定義オブジェクトを Save-BESyntheticBackupDefinition にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BESyntheticBackupDefinition

Save-BESyntheticBackupDefinition は、保存された合成バックアップ定義を返します。

Example

C:\PS> Get-BESyntheticBackupDefinition "Synthetic Backup Definition 01" | Set-BESyntheticBackupDefinition -FileSystemSelection D:\* | Save-BESyntheticBackupDefinition

これらのコマンドは、「Synthetic Backup Definition 01」という名前の合成バックアップ定義用のバックアップ選択項目に「D:\*」を追加します。

Related Links


Save-BESyntheticBackupJobDefault Help

Save-BESyntheticBackupJobDefault Cmdlet
Synopsis

変更された Backup Exec の合成バックアップジョブのデフォルトを保存します。

Syntax
Save-BESyntheticBackupJobDefault [-SyntheticBackupDefault] <BESyntheticBackupJobDefaults> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

変更された Backup Exec の合成バックアップジョブのデフォルトを保存します。

合成バックアップジョブのデフォルトを編集した場合 (Get-BESyntheticBackupJobDefault を参照)、変更をコミットするには合成バックアップジョブのデフォルトを Save-BESyntheticBackupJobDefault に渡す必要があります。

Parameters

-SyntheticBackupDefault <BESyntheticBackupJobDefaults>

保存する合成バックアップジョブのデフォルトを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BESyntheticBackupJobDefaults

Backup Exec の合成バックアップジョブのデフォルトオブジェクトを Save-BESyntheticBackupJobDefault にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BESyntheticBackupJobDefaults

Save-BESyntheticBackupJobDefault は、保存された合成バックアップジョブのデフォルトを返します。

Example

C:\PS> Get-BESyntheticBackupJobDefault | Set-BESyntheticBackupJobDefault -Priority High | Save-BESyntheticBackupJobDefault

これらのコマンドは、デフォルトの合成バックアップの優先度を「高」に設定します。

Related Links


Search-BECatalog Help

Search-BECatalog Cmdlet
Synopsis

Backup Exec カタログでファイルとフォルダを検索します。

Syntax
Search-BECatalog [-AgentServer <BEAgentServer[]>] [-Path] <String> [-FromLastWriteTime <DateTime>] [-Recurse <SwitchParameter>] [-ToLastWriteTime <DateTime>] [-ToLength <UInt64>] [-FromLength <UInt64>] [-PathIsDirectory <SwitchParameter>] [-ToCreationTime <DateTime>] [-FromBackupTime <DateTime>] [-FromCreationTime <DateTime>] [-ToBackupTime <DateTime>] [<CommonParameters>]
Description

Backup Exec カタログでファイルとフォルダを検索します。

Parameters

-AgentServer <BEAgentServer[]>

検索結果をフィルタ処理するエージェントサーバーオブジェクトを 1 つ以上指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEAgentServer を参照してください。

Required | false
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Path <String>

検索するファイルシステムのフォルダまたはファイルのパスを指定します（ワイルドカード使用可）

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-PathIsDirectory <SwitchParameter>

Path パラメータの値がファイルではなくディレクトリであることを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FromBackupTime <DateTime>

検索結果をフィルタ処理して、指定した時刻以後にバックアップされた項目に絞り込みます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ToBackupTime <DateTime>

検索結果をフィルタ処理して、指定した時刻以前にバックアップされた項目に絞り込みます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FromCreationTime <DateTime>

検索結果をフィルタ処理して、指定した時刻以後に作成された項目に絞り込みます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ToCreationTime <DateTime>

検索結果をフィルタ処理して、指定した時刻以前に作成された項目に絞り込みます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FromLastWriteTime <DateTime>

検索結果をフィルタ処理して、指定した時刻以後に変更された項目に絞り込みます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ToLastWriteTime <DateTime>

検索結果をフィルタ処理して、指定した時刻以前に変更された項目に絞り込みます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FromLength <UInt64>

検索結果をフィルタ処理して、指定したファイルサイズ（バイト）より大きい項目に絞り込みます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ToLength <UInt64>

検索結果をフィルタ処理して、指定したファイルサイズ（バイト）より小さい項目に絞り込みます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Recurse <SwitchParameter>

サブフォルダを検索するように指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEAgentServer

Backup Exec エージェントサーバーオブジェクトをパイプ処理して、Search-BECatalog によって返される検索結果をフィルタ処理できます。

Return Value
BackupExec.Management.CLI.BEFileSystemCatalogSearchResult

Search-BECatalog は、Backup Exec カタログの検索結果を表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEAgentServer server01 | Search-BECatalog *.txt

これらのコマンドは、「server01」という名前のサーバーでバックアップされたテキストファイルすべてを検索します。

Example 2
C:\PS> Get-BEAgentServer server01 | Search-BECatalog C:\Windows\*.dll -Recurse

これらのコマンドは、「server01」という名前のサーバーでバックアップされた、C:\Windows ディレクトリの DLL ファイルすべてとそのサブディレクトリのすべてを検索します。

Example 3
C:\PS> Get-BEAgentServer server01 | Search-BECatalog C:\Users -PathIsDirectory

これらのコマンドは、「server01」という名前のサーバーでバックアップされた C:\Users ディレクトリのバックアップすべてを検索します。

Related Link

Get-BEAgentServer


Set-BEAgentServer Help

Set-BEAgentServer Cmdlet
Synopsis

Backup Exec エージェントサーバーのプロパティを設定します。

Syntax
Set-BEAgentServer -InputObject <BEAgentServer[]> [-ExcludeFromScheduledCredentialTest <Boolean>] [-LogonAccount <BELogonAccount>] [-Description <String>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec エージェントサーバーのプロパティを設定します。

Parameters

-LogonAccount <BELogonAccount>

エージェントサーバーを参照するときに使う Backup Exec ログオンアカウントを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

エージェントサーバーの説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExcludeFromScheduledCredentialTest <Boolean>

スケジュール済みクレデンシャルテストからエージェントサーバーを除外します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEAgentServer[]>

1 つ以上のエージェントサーバーオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEAgentServer

Backup Exec エージェントサーバーオブジェクトを Set-BEAgentServer にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEAgentServer

Set-BEAgentServer は、変更された Backup Exec エージェントサーバーを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEAgentServer server01 | Set-BEAgentServer -LogonAccount "System Logon Account"

これらのコマンドは、「server01」という名前のサーバーのログオンアカウントをシステムログオンアカウントに設定します。

Example 2
C:\PS> Get-BEAgentServer server01 | Set-BEAgentServer -ExcludeFromScheduledCredentialTest:$true

これらのコマンドは、次のサーバーでスケジュール済みクレデンシャルテストを無効にします。 「server01」。

Related Link

Get-BEAgentServer


Set-BEAgentServerBackupSource Help

Set-BEAgentServerBackupSource Cmdlet
Synopsis

Backup Exec エージェントサーバーのバックアップソースのプロパティを設定します。

Syntax
Set-BEAgentServerBackupSource -InputObject <BEAgentServerBackupSource[]> [-LogonAccount <BELogonAccount>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec エージェントサーバーのバックアップソースのプロパティを設定します。

Parameters

-LogonAccount <BELogonAccount>

エージェントサーバーのバックアップソースを参照するときに使用する Backup Exec ログオンアカウントを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEAgentServerBackupSource[]>

1 つ以上のエージェントサーバーのバックアップソースオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEAgentServerBackupSource

Backup Exec エージェントサーバーのバックアップソースオブジェクトを Set-BEAgentServerBackupSource にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEAgentServerBackupSource

Set-BEAgentServerBackupSource は、変更された Backup Exec エージェントサーバーのバックアップソースを表すオブジェクトを返します。

Example

C:\PS> Get-BEAgentServer server01 | Get-BEAgentServerBackupSource C: | Set-BEAgentServerBackupSource -LogonAccount "System Logon Account"

これらのコマンドは、「server01」という名前のサーバーの C: ボリュームのログオンアカウントをシステムログオンアカウントに設定します。

Related Links


Set-BEAgentServerGroup Help

Set-BEAgentServerGroup Cmdlet
Synopsis

Backup Exec エージェントサーバーグループのプロパティを設定します。

Syntax
Set-BEAgentServerGroup -InputObject <BEAgentServerGroup[]> [-Description <String>] [-AgentServerList <BEAgentServer[]>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec エージェントサーバーグループのプロパティを設定します。

Parameters

-Description <String>

エージェントサーバーグループの説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AgentServerList <BEAgentServer[]>

グループに割り当てるエージェントサーバーを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEAgentServerGroup[]>

1 つ以上のエージェントサーバーグループオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEAgentServerGroup

Backup Exec エージェントサーバーグループオブジェクトを Set-BEAgentServerGroup にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEAgentServerGroup

Set-BEAgentServerGroup は、変更された Backup Exec エージェントサーバーグループを表すオブジェクトを返します。

Example

C:\PS> Get-BEAgentServerGroup "Windows" | Set-BEAgentServerGroup -Description "Windows servers"

これらのコマンドは「Windows」という名前のエージェントサーバーグループの説明を「Windows サーバー」に設定します。

Related Link

Get-BEAgentServerGroup


Set-BEAlertCategory Help

Set-BEAlertCategory Cmdlet
Synopsis

Backup Exec アラートカテゴリのプロパティを設定します。

Syntax
Set-BEAlertCategory -InputObject <BEAlertCategory[]> [-AutoClearAlertResponse {Cancel | Yes | No}] [-AutoClearAlertAfterMinutes <Int32>] [-NotificationRecipientList <BENotificationRecipient[]>] [-AutoClearAlertEnabled <Boolean>] [-Enabled <Boolean>] [-RecipientNotificationEnabled <Boolean>] [-IncludeJobLog <Boolean>] [-EventLogRecordingEnabled <Boolean>] [-SnmpNotificationEnabled <Boolean>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec アラートカテゴリのプロパティを設定します。

Parameters

-RecipientNotificationEnabled <Boolean>

廃止: これは使用されなくなっているため削除されています。アラートが発生したときの受信者通知を有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Enabled <Boolean>

アラートを有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IncludeJobLog <Boolean>

通知と一緒にジョブログのコピーが含まれます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SnmpNotificationEnabled <Boolean>

アラートの SNMP 通知を有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EventLogRecordingEnabled <Boolean>

Windows のイベントビューアにアラートを表示します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AutoClearAlertEnabled <Boolean>

自動的にアラートをクリアします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AutoClearAlertAfterMinutes <Int32>

アラートをクリアする前にアクティブな状態を保持する分数を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AutoClearAlertResponse

アラートをクリアするときに、Backup Exec で自動的に送信する応答を指定します。

The valid values are:
Cancel
Yes
No

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NotificationRecipientList <BENotificationRecipient[]>

このカテゴリのアラートが発生するときに通知を受ける受信者を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEAlertCategory[]>

1 つ以上のアラートカテゴリオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEAlertCategory

Backup Exec アラートカテゴリオブジェクトを、パイプを使用して Set-BEAlertCategory に渡すことができます。

Return Value
BackupExec.Management.CLI.BEAlertCategory

Set-BEAlertCategory は、変更された Backup Exec アラートカテゴリを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEAlertCategory "Media Overwrite" | Set-BEAlertCategory -AutoClearAlertEnabled $true -AutoClearAlertAfterMinutes 5 -AutoClearAlertResponse No

これらのコマンドは、「No」の応答の 5 分後に「メディア上書き」アラートを自動的にクリアするように設定します。

Example 2
C:\PS> $NotificationRecipient = Get-BENotificationRecipient -Name "Backup Administrator"
C:\PS> Get-BEAlertCategory "Media Overwrite" | Set-BEAlertCategory -NotificationRecipientList $NotificationRecipient

これらのコマンドは、すべての「メディアの上書き」アラートを BENotificationRecipient 「Backup Administrator」に通知を送信するように設定します。

Related Links


Set-BEBackupDefinition Help

Set-BEBackupDefinition Cmdlet
Synopsis

Backup Exec のバックアップ定義のプロパティを設定します。

Syntax
Set-BEBackupDefinition [-BackupDefinition] <BEBackupDefinition> [-ActiveDirectoryPreConsistencyCheck <Boolean>] [-ActiveDirectoryContinueIfConsistencyCheckIsUnsuccessful <Boolean>] [-LinuxMacFollowRemoteMountPoint <Boolean>] [-LinuxMacLockRemoteFile <Boolean>] [-OracleMinimumNumberOfDevicesRequiredForJob <UInt32>] [-VirtualMachineBackupPoweredOffVirtualMachine <Boolean>] [-ActiveDirectoryUseGrt <Boolean>] [-OracleMaximumNumberOfDevicesToUseForResources <UInt32>] [-LinuxMacFollowLocalMountPoint <Boolean>] [-ExchangeHighAvailability {FromPassiveCopyIfAvailableOtherwiseActiveCopy | FromPassiveCopyOnly | FromActiveCopyOnly | FromPassiveCopyIfAvailableOtherwiseActiveCopyUsePreferredServers}] [-ExchangePreferredServerGroup <BEPreferredServerGroup>] [-ExchangePreConsistencyCheck <Boolean>] [-ExchangeContinueIfConsistencyCheckIsUnsuccessful <Boolean>] [-SharePointContinueIfConsistencyCheckIsUnsuccessful <Boolean>] [-LinuxMacPreserveChangeTime <Boolean>] [-SharePointReleaseLockOnFarmTopology <Boolean>] [-SharePointPreConsistencyCheck <Boolean>] [-VirtualMachineEnableIRForAll <Boolean>] [-NdmpNetAppBackupAccessControlLists <Boolean>] [-NdmpNetAppEnableFileHistory <Boolean>] [-NdmpEMCBackupWithIntegratedCheckpoints <Boolean>] [-NdmpEMCEnableFileHistory <Boolean>] [-SharePointUseGrt <Boolean>] [-ExchangeUseGrt <Boolean>] [-NdmpEMCBackupType {Dump | VBB}] [-VirtualMachineUseGrtForExchange <Boolean>] [-VirtualMachineUseGrtForSql <Boolean>] [-VirtualMachineUseGrtForFileSystem <Boolean>] [-VirtualMachineUseGrtForActiveDirectory <Boolean>] [-VMwareTransportModePriority {SAN | NBD | NBDSSL | Hotadd}] [-VMwareVSpherePort <UInt32>] [-VirtualMachineUseGrtForSharePoint <Boolean>] [-HyperVExcludeVirtualMachinesNeedingSavedState <Boolean>] [-TestRunPlaceScheduledBackupJobOnHoldIfUnsuccessful <Boolean>] [-NetworkInterface <BENetworkInterface>] [-TestRunCheckMediaAvailable <Boolean>] [-TestRunJobSizeCalculationMethod {UsePreviousJobHistories | PerformPreScan}] [-AllowAnyNetworkForAgentAccess <Boolean>] [-EnableCheckpointRestart <Boolean>] [-NetworkProtocol {AnyAvailable | IPv4 | IPv6}] [-NetworkSubnet <BENetworkInterfaceSubnet>] [-TestRunCheckStorageSpace <Boolean>] [-Priority {Normal | Lowest | Low | High | Highest}] [-RestrictToBackupExecServer <BEBackupExecServer>] [-ClearExistingSelection <SwitchParameter>] [-Description <String>] [-TestRunSchedule <BESchedule>] [-TestRunCheckLogonAccount <Boolean>] [-RestrictToBackupExecServersInPool <BEBackupExecServerPool>] [-EnableTestRun <Boolean>] [-UseSnapshotTechnology <Boolean>] [-FileSystemEnableNtfsSingleInstanceBackup <Boolean>] [-FileSystemFollowJunctionPoint <Boolean>] [-DelayedCatalogDaysOfWeek {Sunday | Monday | Tuesday | Wednesday | Thursday | Friday | Saturday}] [-FileSystemBackupMethod {UseModifiedTime | UseArchiveBit | UseCatalog}] [-FileSystemBackupOpenFile {Never | IfClosedWithinSpecifiedTime | WithALock | WithoutALock}] [-FileSystemBackupOpenFileIfClosedWithinSeconds <UInt32>] [-FileSystemFollowSymbolicLink <Boolean>] [-FileSystemBackupRemoteStorage <Boolean>] [-DelayedCatalogStartAt <DateTime>] [-ProcessLogicalVolumesSequentially <Boolean>] [-UseOffhostBackup <Boolean>] [-SnapshotTechnology {Automatic | MicrosoftVolumeShadowCopyService}] [-SnapshotProvider {Automatic | System | Software | Hardware}] [-ProcessOffhostLogicalVolumesSequentially <Boolean>] [-DelayedCatalogScheduleType {NoDelayedCatalog | ImmediatelyAfterBackup | Scheduled}] [-OffhostBackupSnapshotProvider {Automatic | Software | Hardware}] [-FailIfNoOffhostBackup <Boolean>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Set-BEBackupDefinition [-BackupDefinition] <BEBackupDefinition> -SelectionList <BEAgentServerBackupSelectionList[]> [-ActiveDirectoryPreConsistencyCheck <Boolean>] [-ActiveDirectoryContinueIfConsistencyCheckIsUnsuccessful <Boolean>] [-LinuxMacFollowRemoteMountPoint <Boolean>] [-LinuxMacLockRemoteFile <Boolean>] [-OracleMinimumNumberOfDevicesRequiredForJob <UInt32>] [-VirtualMachineBackupPoweredOffVirtualMachine <Boolean>] [-ActiveDirectoryUseGrt <Boolean>] [-OracleMaximumNumberOfDevicesToUseForResources <UInt32>] [-LinuxMacFollowLocalMountPoint <Boolean>] [-ExchangeHighAvailability {FromPassiveCopyIfAvailableOtherwiseActiveCopy | FromPassiveCopyOnly | FromActiveCopyOnly | FromPassiveCopyIfAvailableOtherwiseActiveCopyUsePreferredServers}] [-ExchangePreferredServerGroup <BEPreferredServerGroup>] [-ExchangePreConsistencyCheck <Boolean>] [-ExchangeContinueIfConsistencyCheckIsUnsuccessful <Boolean>] [-SharePointContinueIfConsistencyCheckIsUnsuccessful <Boolean>] [-LinuxMacPreserveChangeTime <Boolean>] [-SharePointReleaseLockOnFarmTopology <Boolean>] [-SharePointPreConsistencyCheck <Boolean>] [-VirtualMachineEnableIRForAll <Boolean>] [-NdmpNetAppBackupAccessControlLists <Boolean>] [-NdmpNetAppEnableFileHistory <Boolean>] [-NdmpEMCBackupWithIntegratedCheckpoints <Boolean>] [-NdmpEMCEnableFileHistory <Boolean>] [-SharePointUseGrt <Boolean>] [-ExchangeUseGrt <Boolean>] [-NdmpEMCBackupType {Dump | VBB}] [-VirtualMachineUseGrtForExchange <Boolean>] [-VirtualMachineUseGrtForSql <Boolean>] [-VirtualMachineUseGrtForFileSystem <Boolean>] [-VirtualMachineUseGrtForActiveDirectory <Boolean>] [-VMwareTransportModePriority {SAN | NBD | NBDSSL | Hotadd}] [-VMwareVSpherePort <UInt32>] [-VirtualMachineUseGrtForSharePoint <Boolean>] [-HyperVExcludeVirtualMachinesNeedingSavedState <Boolean>] [-FileSystemBackupOpenFileIfClosedWithinSeconds <UInt32>] [-TestRunJobSizeCalculationMethod {UsePreviousJobHistories | PerformPreScan}] [-TestRunPlaceScheduledBackupJobOnHoldIfUnsuccessful <Boolean>] [-TestRunCheckStorageSpace <Boolean>] [-TestRunCheckMediaAvailable <Boolean>] [-NetworkSubnet <BENetworkInterfaceSubnet>] [-AllowAnyNetworkForAgentAccess <Boolean>] [-NetworkInterface <BENetworkInterface>] [-NetworkProtocol {AnyAvailable | IPv4 | IPv6}] [-TestRunCheckLogonAccount <Boolean>] [-Description <String>] [-Priority {Normal | Lowest | Low | High | Highest}] [-ClearExistingSelection <SwitchParameter>] [-EnableTestRun <Boolean>] [-TestRunSchedule <BESchedule>] [-RestrictToBackupExecServer <BEBackupExecServer>] [-RestrictToBackupExecServersInPool <BEBackupExecServerPool>] [-EnableCheckpointRestart <Boolean>] [-FileSystemBackupMethod {UseModifiedTime | UseArchiveBit | UseCatalog}] [-FileSystemEnableNtfsSingleInstanceBackup <Boolean>] [-DelayedCatalogStartAt <DateTime>] [-DelayedCatalogDaysOfWeek {Sunday | Monday | Tuesday | Wednesday | Thursday | Friday | Saturday}] [-FileSystemBackupRemoteStorage <Boolean>] [-FileSystemBackupOpenFile {Never | IfClosedWithinSpecifiedTime | WithALock | WithoutALock}] [-FileSystemFollowJunctionPoint <Boolean>] [-FileSystemFollowSymbolicLink <Boolean>] [-DelayedCatalogScheduleType {NoDelayedCatalog | ImmediatelyAfterBackup | Scheduled}] [-SnapshotProvider {Automatic | System | Software | Hardware}] [-ProcessLogicalVolumesSequentially <Boolean>] [-UseSnapshotTechnology <Boolean>] [-SnapshotTechnology {Automatic | MicrosoftVolumeShadowCopyService}] [-FailIfNoOffhostBackup <Boolean>] [-ProcessOffhostLogicalVolumesSequentially <Boolean>] [-UseOffhostBackup <Boolean>] [-OffhostBackupSnapshotProvider {Automatic | Software | Hardware}] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Set-BEBackupDefinition [-BackupDefinition] <BEBackupDefinition> [-ExchangePreConsistencyCheck <Boolean>] [-ExchangeContinueIfConsistencyCheckIsUnsuccessful <Boolean>] [-ExchangeHighAvailability {FromPassiveCopyIfAvailableOtherwiseActiveCopy | FromPassiveCopyOnly | FromActiveCopyOnly | FromPassiveCopyIfAvailableOtherwiseActiveCopyUsePreferredServers}] [-FileSystemBackupRemoteStorage <Boolean>] [-FileSystemBackupOpenFile {Never | IfClosedWithinSpecifiedTime | WithALock | WithoutALock}] [-FileSystemBackupOpenFileIfClosedWithinSeconds <UInt32>] [-SharePointContinueIfConsistencyCheckIsUnsuccessful <Boolean>] [-LinuxMacPreserveChangeTime <Boolean>] [-LinuxMacFollowLocalMountPoint <Boolean>] [-ExchangePreferredServerGroup <BEPreferredServerGroup>] [-SharePointReleaseLockOnFarmTopology <Boolean>] [-SharePointPreConsistencyCheck <Boolean>] [-FileSystemFollowSymbolicLink <Boolean>] [-OffhostBackupSnapshotProvider {Automatic | Software | Hardware}] [-FailIfNoOffhostBackup <Boolean>] [-ProcessOffhostLogicalVolumesSequentially <Boolean>] [-SnapshotProvider {Automatic | System | Software | Hardware}] [-ProcessLogicalVolumesSequentially <Boolean>] [-UseOffhostBackup <Boolean>] [-FileSystemBackupMethod {UseModifiedTime | UseArchiveBit | UseCatalog}] [-FileSystemEnableNtfsSingleInstanceBackup <Boolean>] [-FileSystemFollowJunctionPoint <Boolean>] [-DelayedCatalogScheduleType {NoDelayedCatalog | ImmediatelyAfterBackup | Scheduled}] [-DelayedCatalogStartAt <DateTime>] [-DelayedCatalogDaysOfWeek {Sunday | Monday | Tuesday | Wednesday | Thursday | Friday | Saturday}] [-LinuxMacFollowRemoteMountPoint <Boolean>] [-NdmpEMCBackupType {Dump | VBB}] [-NdmpEMCBackupWithIntegratedCheckpoints <Boolean>] [-NdmpEMCEnableFileHistory <Boolean>] [-HyperVExcludeVirtualMachinesNeedingSavedState <Boolean>] [-VMwareTransportModePriority {SAN | NBD | NBDSSL | Hotadd}] [-VMwareVSpherePort <UInt32>] [-ExchangeUseGrt <Boolean>] [-NdmpNetAppBackupAccessControlLists <Boolean>] [-NdmpNetAppEnableFileHistory <Boolean>] [-SharePointUseGrt <Boolean>] [-VirtualMachineUseGrtForSharePoint <Boolean>] [-ActiveDirectoryUseGrt <Boolean>] [-OracleMaximumNumberOfDevicesToUseForResources <UInt32>] [-OracleMinimumNumberOfDevicesRequiredForJob <UInt32>] [-LinuxMacLockRemoteFile <Boolean>] [-ActiveDirectoryPreConsistencyCheck <Boolean>] [-ActiveDirectoryContinueIfConsistencyCheckIsUnsuccessful <Boolean>] [-VirtualMachineUseGrtForActiveDirectory <Boolean>] [-VirtualMachineUseGrtForExchange <Boolean>] [-VirtualMachineUseGrtForSql <Boolean>] [-VirtualMachineBackupPoweredOffVirtualMachine <Boolean>] [-VirtualMachineEnableIRForAll <Boolean>] [-VirtualMachineUseGrtForFileSystem <Boolean>] [-SharePointWebApplicationSelection <BESharePointWebApplicationSelection[]>] [-SharePointServiceApplicationSelection <BESharePointServiceApplicationSelection[]>] [-SharePointServiceApplicationProxySelection <BESharePointServiceApplicationProxySelection[]>] [-SharePointInfoPathServicesSelection {Include | Exclude}] [-SharePointHelpSearchSelection {Include | Exclude}] [-SharePointSingleSignOnDatabaseSelection {Include | Exclude}] [-SharePointPortalSiteSelection <BESharePointPortalSiteSelection[]>] [-SharePointServiceSiteSelection <BESharePointServiceSiteSelection[]>] [-LinuxMacSelection <BELinuxMacSelection[]>] [-SharePointSharedServiceApplicationSelection <BESharePointSharedServiceApplicationSelection[]>] [-SharePointSharedServiceApplicationProxySelection <BESharePointSharedServiceApplicationProxySelection[]>] [-SharePointSharedServiceProviderSelection <BESharePointSharedServiceProviderSelection[]>] [-SharePointCentralAdministrationWebApplicationSelection {Include | Exclude}] [-Description <String>] [-SystemStateSelection {Include | Exclude}] [-FileSystemSelection <BEFileSystemSelection[]>] [-EnableSimplifiedDisasterRecovery <Boolean>] [-SelectEntireAgentServer <SwitchParameter>] [-ClearExistingSelection <SwitchParameter>] [-SharePointAllResourcesSelection {Include | Exclude}] [-SharePointConfigurationDatabaseSelection {Include | Exclude}] [-SharePointGlobalSettingsSelection {Include | Exclude}] [-ExchangeStorageGroupDatabaseSelection <BEExchangeStorageGroupDatabaseSelection[]>] [-ExchangeDatabaseSelection <BEExchangeDatabaseSelection[]>] [-SqlDatabaseSelection <BESqlDatabaseSelection[]>] [-OracleSelection <BEOracleSelection[]>] [-TestRunJobSizeCalculationMethod {UsePreviousJobHistories | PerformPreScan}] [-TestRunPlaceScheduledBackupJobOnHoldIfUnsuccessful <Boolean>] [-NetworkInterface <BENetworkInterface>] [-TestRunCheckLogonAccount <Boolean>] [-TestRunCheckStorageSpace <Boolean>] [-TestRunCheckMediaAvailable <Boolean>] [-EnableCheckpointRestart <Boolean>] [-UseSnapshotTechnology <Boolean>] [-SnapshotTechnology {Automatic | MicrosoftVolumeShadowCopyService}] [-NetworkProtocol {AnyAvailable | IPv4 | IPv6}] [-NetworkSubnet <BENetworkInterfaceSubnet>] [-AllowAnyNetworkForAgentAccess <Boolean>] [-TestRunSchedule <BESchedule>] [-EnterpriseVaultDirectorySelection <BEEnterpriseVaultDirectorySelection[]>] [-EnterpriseVaultComplianceAcceleratorSelection <BEEnterpriseVaultComplianceAcceleratorSelection[]>] [-EnterpriseVaultDiscoveryAcceleratorSelection <BEEnterpriseVaultDiscoveryAcceleratorSelection[]>] [-HyperVSelection <BEHyperVSelection[]>] [-VMwareSelection <BEVMwareSelection[]>] [-UtilityPartitionSelection <BEUtilityPartitionSelection[]>] [-RestrictToBackupExecServer <BEBackupExecServer>] [-RestrictToBackupExecServersInPool <BEBackupExecServerPool>] [-EnableTestRun <Boolean>] [-ActiveDirectoryApplicationModeSelection <BEActiveDirectoryApplicationModeSelection[]>] [-OpenEnterpriseServerSelection <BEOpenEnterpriseServerSelection[]>] [-Priority {Normal | Lowest | Low | High | Highest}] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のバックアップ定義のプロパティを設定します。

Set-BEBackupDefinition に渡されるパラメータは、バックアップ定義のすべてのタスクに対するオプションです。

Set-BEBackupDefinition に渡される選択パラメータの値は、編集するバックアップ定義の現在の選択に追加されます。 既存の選択をクリアするには、ClearExistingSelection を使用します。

Set-BEBackupDefinition を次のコマンドと一緒に使用して、バックアップ定義のタスクを変更できます:Add-BEIncrementalBackupTask、Add-BEDifferentialBackupTask、Add-BEDuplicateStageBackupTask、Add-BEConvertToVirtualStageBackupTask、Add-BEVerifyBackupTask、Set-BEIncrementalBackupTask、Set-BEDifferentialBackupTask、Set-BEDuplicateStageBackupTask、Set-BEVerifyBackupTask、and Remove-BEBackupTask。

バックアップ定義を作成または編集する場合、そのバックアップ定義を Save-BEBackupDefinition に渡して変更をコミットする必要があります。

Parameters

-BackupDefinition <BEBackupDefinition>

編集するバックアップ定義を指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-SelectionList <BEAgentServerBackupSelectionList[]>

バックアップする選択項目のリストを指定します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableSimplifiedDisasterRecovery <Boolean>

簡易システムリカバリを有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SelectEntireAgentServer <SwitchParameter>

バックアップするエージェントサーバー全体を選択します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ClearExistingSelection <SwitchParameter>

既存のバックアップの選択をクリアします。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

バックアップ定義の説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SystemStateSelection

システム状態をバックアップ定義に含める、またはバックアップ定義から除外します。

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemSelection <BEFileSystemSelection[]>

1 つ以上のファイルシステムの選択項目をバックアップ定義に含める、またはバックアップ定義から除外します。含めるファイルまたはディレクトリを指定するには、1 つまたは複数のパスを、カンマを使用して値を区切って指定します。除外するファイルまたはディレクトリを指定するには、-Exclude パラメータと一緒に New-BEFileSystemSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeStorageGroupDatabaseSelection <BEExchangeStorageGroupDatabaseSelection[]>

1 つ以上の Exchange 2003 ストレージのグループまたはデータベースをバックアップ定義に含める、またはバックアップ定義から除外します。含めるストレージグループを指定するには、1 つまたは複数のストレージグループ名を、カンマを使用して値を区切って指定します。「*」を指定するとすべてのストレージグループが含まれます。除外するストレージグループを指定したり、含めるまたは除外するデータベースを個別に指定するには、-Exclude パラメータと一緒に New-BEExchangeStorageGroupDatabaseSelection の出力を使用します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeDatabaseSelection <BEExchangeDatabaseSelection[]>

1 つ以上の Exchange 2007 以降のデータベースをバックアップ定義に含める、またはバックアップ定義から除外します。含めるデータベースを指定するには、1 つまたは複数のデータベース名を、カンマを使用して値を区切って指定します。「*」を指定するとすべてのデータベースが含まれます。除外するデータベースを指定するには、-Exclude パラメータと一緒に New-BEExchangeDatabaseSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlDatabaseSelection <BESqlDatabaseSelection[]>

1 つ以上の SQL インスタンスまたは SQL データベースをバックアップ定義に含める、またはバックアップ定義から除外します。含める SQL インスタンスを指定するには、1 つまたは複数の SQL インスタンス名を、カンマを使用して値を区切って指定します。「*」を指定するとすべての SQL インスタンスが含まれます。除外する SQL インスタンスを指定したり、含めるまたは除外するデータベースを個別に指定するには、-Exclude パラメータと一緒に New-BESqlDatabaseSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointAllResourcesSelection

Windows コンピュータをバックアップするときに、すべての SharePoint リソースをカテゴリ別にバックアップ定義に含める、またはバックアップ定義から除外します。

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointConfigurationDatabaseSelection

SharePoint 設定データベースをバックアップ定義に含める、またはバックアップ定義から除外します。

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointGlobalSettingsSelection

SharePoint のグローバル設定データベースをバックアップ定義に含める、またはバックアップ定義から除外します。

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointCentralAdministrationWebApplicationSelection

SharePoint Central Administration Web アプリケーションをバックアップ定義に含める、またはバックアップ定義から除外します。

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointInfoPathServicesSelection

SharePoint InfoPath サービスをバックアップ定義に含める、またはバックアップ定義から除外します。

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointHelpSearchSelection

SharePoint ヘルプ検索をバックアップ定義に含める、またはバックアップ定義から除外します。

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointSingleSignOnDatabaseSelection

SharePoint シングルサインオンデータベースをバックアップ定義に含める、またはバックアップ定義から除外します。

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointWebApplicationSelection <BESharePointWebApplicationSelection[]>

1 つ以上の SharePoint Web アプリケーションをバックアップ定義に含める、またはバックアップ定義から除外します。含める Web アプリケーションを指定するには、1 つまたは複数の Web アプリケーション名を、カンマを使用して値を区切って指定します。「*」を指定すると、すべての Web アプリケーションが含まれます。 除外する Web アプリケーションを指定するには、-Exclude パラメータと一緒に New-BESharePointWebApplicationSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointServiceApplicationSelection <BESharePointServiceApplicationSelection[]>

1 つ以上の SharePoint サービスアプリケーションをバックアップ定義に含める、またはバックアップ定義から除外します。 含めるサービスアプリケーションを指定するには、1 つまたは複数のサービスアプリケーション名を、カンマを使用して値を区切って指定します。「*」を指定すると、すべてのサービスアプリケーションが含まれます。 除外するサービスアプリケーションを指定するには、-Exclude パラメータと一緒に New-BESharePointServiceApplicationSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointServiceApplicationProxySelection <BESharePointServiceApplicationProxySelection[]>

1 つ以上の SharePoint サービスアプリケーションプロキシをバックアップ定義に含める、またはバックアップ定義から除外します。含めるサービスアプリケーションプロキシを指定するには、1 つまたは複数のサービスアプリケーションプロキシ名を、カンマを使用して値を区切って指定します。「*」を指定すると、すべてのサービスアプリケーションプロキシが含まれます。除外するサービスアプリケーションプロキシを指定するには、-Exclude パラメータと一緒に New-BESharePointServiceApplicationProxySelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointSharedServiceApplicationSelection <BESharePointSharedServiceApplicationSelection[]>

1 つ以上の SharePoint 共有サービスアプリケーションをバックアップ定義に含める、またはバックアップ定義から除外します。含める共有サービスアプリケーションを指定するには、1 つまたは複数の共有サービスアプリケーション名を、カンマを使用して値を区切って指定します。「*」を指定すると、すべての共有サービスアプリケーションが含まれます。除外する共有サービスアプリケーションを指定するには、-Exclude パラメータと一緒に New-BESharePointSharedServiceApplicationSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointSharedServiceApplicationProxySelection <BESharePointSharedServiceApplicationProxySelection[]>

1 つ以上の SharePoint 共有サービスアプリケーションプロキシをバックアップ定義に含める、またはバックアップ定義から除外します。 含める共有サービスアプリケーションプロキシを指定するには、1 つまたは複数の共有サービスアプリケーションプロキシ名を、カンマを使用して値を区切って指定します。「*」を指定すると、すべての共有サービスアプリケーションプロキシが含まれます。除外する共有サービスアプリケーションプロキシを指定するには、-Exclude パラメータと一緒に New-BESharePointSharedServiceApplicationProxySelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointSharedServiceProviderSelection <BESharePointSharedServiceProviderSelection[]>

1 つ以上の SharePoint 共有サービスプロバイダをバックアップ定義に含める、またはバックアップ定義から除外します。含める共有サービスプロバイダを指定するには、1 つまたは複数の共有サービスプロバイダ名を、カンマを使用して値を区切って指定します。除外する共有サービスプロバイダを指定するには、-Exclude パラメータと一緒に New-BESharePointSharedServiceProviderSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointPortalSiteSelection <BESharePointPortalSiteSelection[]>

1 つ以上の SharePoint ポータルサイトをバックアップ定義に含める、またはバックアップ定義から除外します。含めるポータルサイトを指定するには、1 つまたは複数のポータルサイト名を、カンマを使用して値を区切って指定します。除外するポータルサイトを指定するには、-Exclude パラメータと一緒に New-BESharePointPortalSiteSelection の出力を使い、1 つ以上の除外するポータルサイトをこのパラメータに渡します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointServiceSiteSelection <BESharePointServiceSiteSelection[]>

1 つ以上の SharePoint サービスサイトをバックアップ定義に含める、またはバックアップ定義から除外します。 含めるサービスサイトを指定するには、1 つまたは複数のサービスサイト名を、カンマを使用して値を区切って指定します。除外するサービスサイトを指定するには、-Exclude パラメータと一緒に New-BESharePointServiceSiteSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LinuxMacSelection <BELinuxMacSelection[]>

1 つ以上の Linux サーバーまたは Macintosh システムをバックアップ定義に含める、またはバックアップ定義から除外します。 含めるファイルまたはディレクトリを指定するには、1 つまたは複数のパスを、カンマを使用して値を区切って指定します。除外するファイルまたはディレクトリを指定するには、-Exclude パラメータと一緒に New-BELinuxMacSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleSelection <BEOracleSelection[]>

1 つ以上の Oracle の選択項目をバックアップ定義に含める、またはバックアップ定義から除外します。含めるデータベースまたは表スペースを指定するには、1 つまたは複数のパスを、カンマを使用して値を区切って指定します。除外するデータベースまたは表スペースを指定するには、-Exclude パラメータと一緒に New-BEOracleSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-HyperVSelection <BEHyperVSelection[]>

1 つ以上の Hyper-V 仮想マシンをバックアップ定義に含める、またはバックアップ定義から除外します。含める仮想マシンを指定するには、1 つまたは複数の仮想マシン名を、カンマを使用して値を区切って指定します (「*」を指定するとすべての Hyper-V 仮想マシンが含められます)。除外する仮想マシンを指定するには、New-BEHyperVSelection の出力とともに -Exclude パラメータを使用して、最初にすべての仮想マシンを含め、次に除外する対象を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VMwareSelection <BEVMwareSelection[]>

1 つ以上の VMware サーバーをバックアップ定義に含める、またはバックアップ定義から除外します。含める VMware サーバーを指定するには、1 つまたは複数の VMware サーバー名を、カンマを使用して値を区切って指定します。 除外する VMware サーバーを指定するには、New-BEVMwareSelection の出力とともに -Exclude パラメータを使用します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UtilityPartitionSelection <BEUtilityPartitionSelection[]>

1 つ以上のユーティリティパーティションをバックアップ定義に含める、またはバックアップ定義から除外します。含めるユーティリティパーティションを指定するには、1 つまたは複数のパスを、カンマを使用して値を区切って指定します。除外するユーティリティパーティションを指定するには、-Exclude パラメータと一緒に New-BEUtilityPartitionSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnterpriseVaultDirectorySelection <BEEnterpriseVaultDirectorySelection[]>

1 つ以上の Enterprise Vault Directory リソースをバックアップ定義に含める、またはバックアップ定義から除外します。 含める Enterprise Vault Directory リソースを指定するには、1 つまたは複数のリソース名を、カンマを使用して値を区切って指定します。除外するリソースを指定するには、New-BEEnterpriseVaultDirectorySelection の出力とともに -Exclude パラメータを使用します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnterpriseVaultComplianceAcceleratorSelection <BEEnterpriseVaultComplianceAcceleratorSelection[]>

1 つ以上の Enterprise Vault Compliance の Accelerator データベースをバックアップ定義に含める、またはバックアップ定義から除外します。含める Enterprise Vault Compliance の Accelerator データベースを指定するには、1 つまたは複数のデータベース名を、カンマを使用して値を区切って指定します。除外するデータベースを指定するには、New-BEEnterpriseVaultComplianceAcceleratorSelection の出力とともに -Exclude パラメータを使用します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnterpriseVaultDiscoveryAcceleratorSelection <BEEnterpriseVaultDiscoveryAcceleratorSelection[]>

1 つ以上の Enterprise Vault Discovery の Accelerator データベースをバックアップ定義に含める、またはバックアップ定義から除外します。 含める Enterprise Vault Discovery の Accelerator データベースを指定するには、1 つまたは複数のデータベース名を、カンマを使用して値を区切って指定します。除外するデータベースを指定するには、New-BEEnterpriseVaultDiscoveryAcceleratorSelection の出力とともに -Exclude パラメータを使用します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ActiveDirectoryApplicationModeSelection <BEActiveDirectoryApplicationModeSelection[]>

1 つ以上の Active Directory Application Mode インスタンスをバックアップ定義に含める、またはバックアップ定義から除外します。含めるインスタンスを指定するには、1 つまたは複数のパスを、カンマを使用して値を区切って指定します。除外するインスタンスを指定するには、-Exclude パラメータと一緒に New-BEActiveDirectoryLightweightDirectoryServiceSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OpenEnterpriseServerSelection <BEOpenEnterpriseServerSelection[]>

1 つ以上の OES コンポーネントをバックアップ定義に含める、またはバックアップ定義から除外します。含めるファイルまたはディレクトリを指定するには、1 つまたは複数のパスを、カンマを使用して値を区切って指定します。除外するファイルまたはディレクトリを指定するには、-Exclude パラメータと一緒に New-BEOpenEnterpriseServerSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Priority

ジョブを実行する順序を指定します。2 つのジョブが同時に実行されるようにスケジュールされている場合、ユーザーが設定する優先度でどちらが先に実行されるかが決まります。

The valid values are:
Normal
Lowest
Low
High
Highest

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RestrictToBackupExecServer <BEBackupExecServer>

CASO 環境でジョブをディスパッチ可能な Backup Exec サーバーを指定します。RestrictToBackupExecServersInPool が指定されている場合は指定できません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RestrictToBackupExecServersInPool <BEBackupExecServerPool>

CASO 環境でジョブをディスパッチ可能な Backup Exec サーバーのセットを指定します。RestrictToBackupExecServer が指定されている場合は指定できません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableTestRun <Boolean>

テスト実行の処理を有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunSchedule <BESchedule>

テスト実行ジョブの実行日時と実行頻度のスケジュール設定を可能にします。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunCheckLogonAccount <Boolean>

バックアップする Backup Exec ログオンアカウントがデータにアクセス可能であることを確認します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunCheckStorageSpace <Boolean>

メディア上にジョブの完了に必要な容量があるかどうかをチェックします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunCheckMediaAvailable <Boolean>

メディアがオンラインになっていて上書き可能かどうかをチェックします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunJobSizeCalculationMethod

メディアにスケジュール済みバックアップジョブの実行に必要な容量があるかどうかを計算する方法を指定します。

The valid values are:
UsePreviousJobHistories
PerformPreScan

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunPlaceScheduledBackupJobOnHoldIfUnsuccessful <Boolean>

テスト実行中に Backup Exec で障害が検出された場合、スケジュール済みジョブを保留にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NetworkInterface <BENetworkInterface>

バックアップネットワークとして使用するネットワークに対して Backup Exec サーバーを接続する、ネットワークインターフェースカードの名前を指定します。Get-BENetworkInterface を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NetworkProtocol

リモートコンピュータをバックアップするために使うプロトコルを指定します。

The valid values are:
AnyAvailable
IPv4
IPv6

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NetworkSubnet <BENetworkInterfaceSubnet>

Get-BENetworkInterface によって返されたネットワークインターフェースのサブネットの 1 つを使用して、リモートコンピュータをバックアップするために使うサブネットを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AllowAnyNetworkForAgentAccess <Boolean>

バックアップまたはリストアのために選択したリモートコンピュータが、指定したバックアップネットワークの一部でない場合に、リモートコンピュータからのデータが任意の利用可能なネットワークを介してバックアップまたはリストアされるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableCheckpointRestart <Boolean>

ジョブが中断された時点からバックアップジョブを続行可能にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UseSnapshotTechnology <Boolean>

スナップショットテクノロジの利用を有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SnapshotTechnology

スナップショットテクノロジを有効にしたときに使用する、スナップショットテクノロジを指定します。UseSnapshotTechnology は $true に設定する必要があります。

The valid values are:
Automatic
MicrosoftVolumeShadowCopyService

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SnapshotProvider

スナップショットテクノロジを有効にしたときに使用するスナップショットプロバイダとして、Microsoft ボリュームシャドウコピーサービスを指定します。UseSnapshotTechnology を $true に設定し、SnapshotTechnology を MicrosoftVolumeShadowCopyService に設定する必要があります。

The valid values are:
Automatic
System
Software
Hardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ProcessLogicalVolumesSequentially <Boolean>

1 つのジョブで複数のボリュームをバックアップすることを有効にします。このとき、一度に 1 つの論理ボリュームのスナップショットのみが作成されます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UseOffhostBackup <Boolean>

オフホストバックアップを有効にします。有効な場合は、すべての必要条件が満たされると、すべてのボリュームのオフホストバックアップが実行されます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OffhostBackupSnapshotProvider

使用するオフホストバックアップのスナップショットプロバイダを指定します。UseOffhostBackup は $true に設定する必要があります。

The valid values are:
Automatic
Software
Hardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FailIfNoOffhostBackup <Boolean>

選択したボリュームのいずれかがオフホストバックアップをサポートしない場合、またはスナップショットやボリュームのインポートでエラーが発生した場合、バックアップジョブを終了します。 UseOffhostBackup は $true に設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ProcessOffhostLogicalVolumesSequentially <Boolean>

1 つのジョブで複数のボリュームをバックアップすることを可能にします。このとき、オフホストバックアップに対して一度に 1 つの論理ボリュームのスナップショットのみが作成されます。UseOffhostBackup は $true に設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DelayedCatalogScheduleType

実行する延期したカタログ操作の代替日または時間を指定します。

The valid values are:
NoDelayedCatalog
ImmediatelyAfterBackup
Scheduled

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DelayedCatalogStartAt <DateTime>

遅延カタログジョブを実行する時刻を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DelayedCatalogDaysOfWeek

遅延カタログジョブを実行する曜日を指定します。

The valid values are:
Sunday
Monday
Tuesday
Wednesday
Thursday
Friday
Saturday

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemBackupMethod

ファイルとフォルダのバックアップに使用するバックアップ方式を指定します。

The valid values are:
UseModifiedTime
UseArchiveBit
UseCatalog

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemEnableNtfsSingleInstanceBackup <Boolean>

Backup Exec で同一ファイルに対して NTFS ボリュームをチェックできるようにします。ファイルのコピーが複数見つかった場合は、そのファイルの 1 つのインスタンスのみが Backup Exec によってバックアップされます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemFollowJunctionPoint <Boolean>

接合点の情報とリンク先のファイルおよびディレクトリをバックアップします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemFollowSymbolicLink <Boolean>

シンボリックリンクの情報とリンク先のファイルとディレクトリの情報をバックアップします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemBackupRemoteStorage <Boolean>

プライマリストレージからセカンダリストレージに移動したデータをバックアップします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemBackupOpenFile

スナップショットテクノロジが使用されていない場合に Backup Exec がバックアップジョブでオープンファイルを処理する方法を指定します。

The valid values are:
Never
IfClosedWithinSpecifiedTime
WithALock
WithoutALock

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemBackupOpenFileIfClosedWithinSeconds <UInt32>

オープンファイルをスキップしてバックアップジョブを続行する前に Backup Exec が待機する秒数を指定します。BackupOpenFile が IfClosedWithinSpecifiedTime に設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangePreConsistencyCheck <Boolean>

バックアップジョブを実行する前に一貫性チェックを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeContinueIfConsistencyCheckIsUnsuccessful <Boolean>

一貫性チェックに失敗した場合でもバックアップジョブを続行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeHighAvailability

Exchange 2007 以降のバックアップソースを指定します。

The valid values are:
FromPassiveCopyIfAvailableOtherwiseActiveCopy
FromPassiveCopyOnly
FromActiveCopyOnly
FromPassiveCopyIfAvailableOtherwiseActiveCopyUsePreferredServers

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangePreferredServerGroup <BEPreferredServerGroup>

Microsoft Exchange 2010 データベース可用性グループをバックアップするために使用する優先サーバーの設定の名前を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointReleaseLockOnFarmTopology <Boolean>

バックアップジョブを実行する前に SharePoint ファームトポロジーのロックを解除します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointPreConsistencyCheck <Boolean>

Microsoft SharePoint で使用する Microsoft SQL データベースをバックアップする前に、インデックスを含む完全な一貫性チェックを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointContinueIfConsistencyCheckIsUnsuccessful <Boolean>

一貫性チェックに失敗した場合でもバックアップジョブを続行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LinuxMacPreserveChangeTime <Boolean>

バックアップジョブの実行時に Agent for Windows でオブジェクトの属性が変更されないようにします。オブジェクトはファイルまたはディレクトリです。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LinuxMacFollowLocalMountPoint <Boolean>

データのバックアップ時に Backup Exec でローカルマウントポイントをたどることができます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LinuxMacFollowRemoteMountPoint <Boolean>

データのバックアップ時に Backup Exec でリモートマウントポイントをたどることができます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LinuxMacLockRemoteFile <Boolean>

ネットワークファイルシステム (NFS) を介して接続されたリモートコンピュータのファイルに Agent for Windows で排他的にアクセスできます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ActiveDirectoryPreConsistencyCheck <Boolean>

スナップショットにデータ破損がないかを確認します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ActiveDirectoryContinueIfConsistencyCheckIsUnsuccessful <Boolean>

一貫性チェックが失敗してもバックアップジョブの続行を可能にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ActiveDirectoryUseGrt <Boolean>

Active Directory の完全バックアップから個々の項目をリストアできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleMaximumNumberOfDevicesToUseForResources <UInt32>

バックアップジョブで使用できる最大デバイス数を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleMinimumNumberOfDevicesRequiredForJob <UInt32>

ジョブで使用できる最小デバイス数を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineBackupPoweredOffVirtualMachine <Boolean>

オフになった仮想マシンを Backup Exec でバックアップできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineEnableIRForAll <Boolean>

GRT の対象外を含むすべての仮想マシンでインスタントリカバリを有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForFileSystem <Boolean>

完全バックアップジョブから個々のファイルとフォルダをリストアできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForActiveDirectory <Boolean>

Backup Exec で仮想マシン上の個々の Active Directory オブジェクトをリストアするのに必要な情報を収集できるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForExchange <Boolean>

Backup Exec で仮想マシン上の個々の Exchange データベースおよびメールボックス項目をリストアするのに必要な情報を収集できるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForSql <Boolean>

Backup Exec で仮想マシン上の個々の SQL データベース項目をリストアするのに必要な情報を収集できるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForSharePoint <Boolean>

Backup Exec で仮想マシン上の SharePoint データをリストアするのに必要な情報を収集できるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-HyperVExcludeVirtualMachinesNeedingSavedState <Boolean>

オンラインバックアップをサポートしない、バックアップの開始時に実行状態であるすべてのオフライン仮想マシンを除外します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VMwareTransportModePriority

Backup Exec で使用する 1 つ以上の VMware 転送モードを優先度順に指定します。

The valid values are:
SAN
NBD
NBDSSL
Hotadd

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VMwareVSpherePort <UInt32>

Backup Exec で使用する VMware vSphere ポートを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NdmpEMCBackupType

EMC NDMP サーバーのバックアップタイプを指定します。

The valid values are:
Dump
VBB

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NdmpEMCBackupWithIntegratedCheckpoints <Boolean>

Backup Exec で EMC SnapSure 機能を使用するバックアップセットを作成するように設定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NdmpEMCEnableFileHistory <Boolean>

ファイルの履歴データの生成を可能にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NdmpNetAppBackupAccessControlLists <Boolean>

NetApp アクセス制御リストをバックアップします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NdmpNetAppEnableFileHistory <Boolean>

ファイルの履歴データの生成を可能にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointUseGrt <Boolean>

廃止: これはタスクレベルに設定する必要があるもので、BackupDefinition レベルに設定するものではありません。データベースバックアップからの個々のドキュメント、イメージ、サイト、サブサイト、リスト、リストの項目のリストアを有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeUseGrt <Boolean>

インフォメーションストアのバックアップジョブから個々の項目をリストアできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupDefinition

パイプを使用して Backup Exec バックアップ定義オブジェクトを Set-BEBackupDefinition に渡すことができます。

Return Value
BackupExec.Management.CLI.BEBackupDefinition

修正されたバックアップ定義を示します。

Examples

Example 1

C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Set-BEBackupDefinition -FileSystemSelection D:\* | Save-BEBackupDefinition

これらのコマンドでは、「Backup Definition 01」という名前のバックアップ定義での現在の選択項目に、D:\* をバックアップ選択項目として追加します。

Example 2
C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Set-BEBackupDefinition -ClearExistingSelection -FileSystemSelection D:\* | Save-BEBackupDefinition

これらのコマンドでは、「Backup Definition 01」という名前のバックアップ定義に含まれる唯一のバックアップ選択項目として D:\* を設定します。

Related Links

Add-BEIncrementalBackupTask
Add-BEDifferentialBackupTask
Add-BEDuplicateStageBackupTask
Add-BEConvertToVirtualStageBackupTask
Add-BEVerifyBackupTask
Set-BEIncrementalBackupTask
Set-BEDifferentialBackupTask
Set-BEDuplicateStageBackupTask
Set-BEVerifyBackupTask
Remove-BEBackupTask
Save-BEBackupDefinition
New-BEFileSystemSelection
New-BEUtilityPartitionSelection
New-BELinuxMacSelection
New-BEOpenEnterpriseServerSelection
New-BEOracleSelection
New-BEExchangeStorageGroupDatabaseSelection
New-BEExchangeDatabaseSelection
New-BESqlDatabaseSelection
New-BESharePointWebApplicationSelection
New-BESharePointServiceApplicationSelection
New-BESharePointServiceApplicationProxySelection
New-BESharePointSharedServiceApplicationSelection
New-BESharePointSharedServiceApplicationProxySelection
New-BESharePointSharedServiceProviderSelection
New-BESharePointPortalSiteSelection
New-BESharePointServiceSiteSelection
Get-BENetworkInterface
New-BEHyperVSelection
New-BEVMwareSelection
New-BEEnterpriseVaultDirectorySelection
New-BEEnterpriseVaultComplianceAcceleratorSelection
New-BEEnterpriseVaultDiscoveryAcceleratorSelection
Get-BEBackupDefinition


Set-BEBackupExecServerPool Help

Set-BEBackupExecServerPool Cmdlet
Synopsis

Backup Exec サーバープールのプロパティを設定します。

Syntax
Set-BEBackupExecServerPool -InputObject <BEBackupExecServerPool[]> [-Description <String>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec サーバープールのプロパティを設定します。

Parameters

-Description <String>

Backup Exec サーバープールの説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEBackupExecServerPool[]>

1 つ以上の Backup Exec サーバープールオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupExecServerPool

Backup Exec サーバープールオブジェクトを Set-BEBackupExecServerPool にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEBackupExecServerPool

Set-BEBackupExecServerPool は、変更された Backup Exec サーバープールを表すオブジェクトを返します。

Example

C:\PS> Get-BEBackupExecServerPool -Name "Server Pool 0001" | Set-BEBackupExecServerPool -Description "Test Pool"

これらのコマンドは、「Server Pool 0001」という名前の Backup Exec サーバープールの説明を「Test Pool」に変更します。

Related Link

Get-BEBackupExecServerPool


Set-BEBackupExecSetting Help

Set-BEBackupExecSetting Cmdlet
Synopsis

グローバル Backup Exec 設定を変更します。

Syntax
Set-BEBackupExecSetting [-EnableRemoteAgentTcpDynamicPortRange <Boolean>] [-RemoteAgentTcpDynamicPortRangeLowerBound <UInt16>] [-NetworkSubnet <BENetworkInterfaceSubnet>] [-EnableSelectionOfUserShare <Boolean>] [-DisasterRecoveryDataPath <String>] [-DisasterRecoveryAlternateDataPath <String>] [-RemoteAgentTcpDynamicPortRangeUpperBound <UInt16>] [-UseFipsSoftwareEncryption <Boolean>] [-NetworkProtocol {AnyAvailable | IPv4 | IPv6}] [-ReportFooterIncludeTime <Boolean>] [-EnableDiscoverDataToBackup <Boolean>] [-ReportBannerColor <Color>] [-ReportFooterText <String>] [-AllowAnyNetworkForAgentAccess <Boolean>] [-NetworkInterface <BENetworkInterface>] [-DiscoverDataToBackupSchedule <BESchedule>] [-DiscoverDataToBackupCancel {After1Hour | After2Hours | After4Hours | After6Hours | After12Hours | After18Hours | After24Hours}] [-EnableTestAgentServerCredentialSchedule <Boolean>] [-TestAgentServerCredentialDayInterval <UInt32>] [-MultipleServerBackupMode {CreateOneBackup | CreateSeparateBackupPerServer}] [-PromptForMultipleServerBackupMode <Boolean>] [-TestAgentServerCredentialStartTime <DateTime>] [-TestAgentServerCredentialAtAgentServerLevelOnly <Boolean>] [-LimitDiskCartridgesToReadOnlyIfNotInsertedForDays <Int32>] [-PromptBeforeOverwritingMedia <Boolean>] [-MediaOverwriteOption {OverwriteScratchBeforeRecyclable | OverwriteRecyclableBeforeScratchMedia}] [-InventoryRoboticLibrariesOnBackupExecServiceStart <Boolean>] [-MediaOverwriteProtectionLevel {None | Full | Partial}] [-EnableBackupExecToMarkDiskCartridgesReadOnly <Boolean>] [-AllowBackupExecToReportAnonymousUsageInformation <Boolean>] [-EnableBackupExecToMarkDiskStorageReadOnly <Boolean>] [-LimitDiskStorageToReadOnlyIfDetachedForDays <Int32>] [-JobLogFilePrefix <String>] [-JobLogEmailAttachmentFormat {Text | Html}] [-JobStalledRecoveredSeconds <UInt32>] [-JobLogInformationLevel {Summary | SummaryAndDirectories | SummaryDirectoriesAndFiles | SummaryDirectoriesAndFileDetails}] [-TruncateCatalogAfterDays <UInt32>] [-CatalogPath <String>] [-RequestMediaInSequenceForCatalogOperation <Boolean>] [-UseStorageBasedCatalog <Boolean>] [-JobStalledThresholdSeconds <UInt32>] [-GrtRestoreTemporaryStagingPath <String>] [-DefaultSchedule <BESchedule>] [-GrtBackupTemporaryStagingPath <String>] [-EnableProgressIndicatorForBackupJob <Boolean>] [-SendMaintenanceReminderAlertOn <DateTime>] [-DefaultKeepJobQueuedFor <TimeSpan>] [-DefaultCancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-DatabaseMaintenanceKeepAuditLogsForDays <UInt32>] [-ReportFormat {Html | Pdf}] [-DatabaseMaintenanceKeepAlertHistoryForDays <UInt32>] [-DatabaseMaintenanceKeepReportsForDays <UInt32>] [-ReportUseCompanyLogoImageFile <Boolean>] [-ReportCompanyLogoImageFilePath <String>] [-ReportMaxRowsToInclude <UInt32>] [-ReportShowRow {All | Distinct}] [-DatabaseMaintenanceKeepJobLogsForDays <UInt32>] [-DatabaseMaintenancePerformDatabaseConsistencyCheck <Boolean>] [-DatabaseMaintenanceSaveDatabaseContent <Boolean>] [-EnableDatabaseMaintenance <Boolean>] [-DatabaseMaintenancePerformEverydayAt <DateTime>] [-DatabaseMaintenanceKeepJobHistoryForMediaWithOverwriteProtection <Boolean>] [-DatabaseMaintenanceKeepJobHistoryForDays <UInt32>] [-DatabaseMaintenanceOptimizeSize <Boolean>] [-DatabaseMaintenanceDeleteAgedData <Boolean>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [-Force <SwitchParameter>] [<CommonParameters>]
Description

グローバル Backup Exec 設定を変更します。

Set-BEBackupExecSetting を使用して、グローバル Backup Exec 設定を取得します。

Parameters

-GrtBackupTemporaryStagingPath <String>

GRT 対応バックアップジョブの間に Backup Exec が一時的なデータをステージングできる場所を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-GrtRestoreTemporaryStagingPath <String>

GRT リストアジョブの間に Backup Exec が一時的なデータをステージングできる場所を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DefaultSchedule <BESchedule>

デフォルトのジョブスケジュールを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DefaultKeepJobQueuedFor <TimeSpan>

スケジュール設定された開始時間から最大何時間経過したらジョブが無効とみなされ、再スケジュールされるかを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DefaultCancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

スケジュール設定された開始時間から何時間実行中の状態が続いたらジョブをキャンセルするかを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableProgressIndicatorForBackupJob <Boolean>

バックアップジョブの実行中に完了した処理のパーセンテージとインジケータを表示します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SendMaintenanceReminderAlertOn <DateTime>

インストールされている Backup Exec 機能の保守契約の更新の事前通知を受信する日付を選択できます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-JobStalledThresholdSeconds <UInt32>

Backup Exec が応答しないジョブの状態を［停止］に変更する前に、待機する時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-JobStalledRecoveredSeconds <UInt32>

Backup Exec が停止したジョブに失敗し、それらをリカバリする前に、待機する時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-JobLogInformationLevel

完了したジョブのログにどの程度詳しく情報を記録するかを指定します。

The valid values are:
Summary
SummaryAndDirectories
SummaryDirectoriesAndFiles
SummaryDirectoriesAndFileDetails

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-JobLogFilePrefix <String>

処理されるジョブログに追加する接頭辞を指定します。デフォルトの接頭辞は、BEX です。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-JobLogEmailAttachmentFormat

ジョブログを電子メール通知に添付する場合に使用する形式を指定します。

The valid values are:
Text
Html

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RequestMediaInSequenceForCatalogOperation <Boolean>

テープファミリーで最も小さい既知のテープ番号から、テープドライブとディスクカートリッジ内部のメディアのカタログ登録を開始します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UseStorageBasedCatalog <Boolean>

Backup Exec がストレージデバイスからカタログ情報を読み取るようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TruncateCatalogAfterDays <UInt32>

指定した時間の経過後に、ヘッダー情報のみを残して、ファイルやディレクトリのすべての詳細情報を削除します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CatalogPath <String>

カタログを探すパスを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableDatabaseMaintenance <Boolean>

データベースの保守プロセスを有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DatabaseMaintenancePerformEverydayAt <DateTime>

データベースの保守を実行する時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DatabaseMaintenancePerformDatabaseConsistencyCheck <Boolean>

データベースのデータの論理的または物理的な一貫性を調べます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DatabaseMaintenanceSaveDatabaseContent <Boolean>

データベースバックアップファイル（BEDB.bak）をバックアップできるように Backup Exec のデータディレクトリにデータベースに含まれているデータを配置します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DatabaseMaintenanceOptimizeSize <Boolean>

断片化したページを構成しなおして、物理データベースの量を実際に使用されているサイズから 10 % 以上減少させます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DatabaseMaintenanceDeleteAgedData <Boolean>

指定日数の経過後に、期限の切れたジョブの概略、ジョブログ、アラート履歴またはレポートを Backup Exec データベースから削除します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DatabaseMaintenanceKeepJobHistoryForMediaWithOverwriteProtection <Boolean>

上書き禁止ポリシーが現在割り当てられているメディアのすべてのジョブ履歴データを保持します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DatabaseMaintenanceKeepJobHistoryForDays <UInt32>

データベースにジョブ履歴を保持する日数を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DatabaseMaintenanceKeepJobLogsForDays <UInt32>

データベースにジョブログを保持する日数を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DatabaseMaintenanceKeepAlertHistoryForDays <UInt32>

データベースにアラート履歴を保持する日数を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DatabaseMaintenanceKeepReportsForDays <UInt32>

データベースにレポートを保持する日数を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DatabaseMaintenanceKeepAuditLogsForDays <UInt32>

データベースに監査ログを保持する日数を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ReportFormat

レポートの形式を指定します。

The valid values are:
Html
Pdf

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ReportMaxRowsToInclude <UInt32>

レポートに表示する最大行数を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ReportShowRow

レポートに表示する行を指定します。

The valid values are:
All
Distinct

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ReportUseCompanyLogoImageFile <Boolean>

すべてのカスタムレポートのヘッダーに、カスタマイズしたイメージファイルを使用します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ReportCompanyLogoImageFilePath <String>

すべてのカスタムレポートに使用するロゴへのパスを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ReportBannerColor <Color>

レポートのバナーの色を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ReportFooterText <String>

カスタムレポートのフッターに表示するテキストを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ReportFooterIncludeTime <Boolean>

カスタムレポートのフッターにレポートの実行時刻を含めます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableDiscoverDataToBackup <Boolean>

バックアップするデータを検出する Backup Exec のタスクを有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiscoverDataToBackupSchedule <BESchedule>

バックアップするデータの検出タスクを実行するスケジュールを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiscoverDataToBackupCancel

データ検出タスクの時間数を指定します。この時間内に終了しないとデータ検出タスクはキャンセルされます。

The valid values are:
After1Hour
After2Hours
After4Hours
After6Hours
After12Hours
After18Hours
After24Hours

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AllowAnyNetworkForAgentAccess <Boolean>

バックアップまたはリストアのために選択したリモートコンピュータが、指定したバックアップネットワークの一部でない場合に、リモートコンピュータからのデータが任意の利用可能なネットワークを介してバックアップまたはリストアされるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NetworkInterface <BENetworkInterface>

バックアップネットワークとして使用するネットワークに対して Backup Exec サーバーを接続する、ネットワークインターフェースカードの名前を指定します。Get-BENetworkInterface を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NetworkProtocol

リモートコンピュータをバックアップするために使うプロトコルを指定します。

The valid values are:
AnyAvailable
IPv4
IPv6

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NetworkSubnet <BENetworkInterfaceSubnet>

Get-BENetworkInterface によって返されたネットワークインターフェースのサブネットの 1 つを使用して、リモートコンピュータをバックアップするために使うサブネットを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableSelectionOfUserShare <Boolean>

ジョブにユーザー定義共有を含めることができます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableRemoteAgentTcpDynamicPortRange <Boolean>

Remote Agent で通信用のポートの範囲を使用できるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RemoteAgentTcpDynamicPortRangeLowerBound <UInt16>

Remote Agent が通信に使用する下限ポート。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RemoteAgentTcpDynamicPortRangeUpperBound <UInt16>

Remote Agent が通信に使用する上限ポート。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UseFipsSoftwareEncryption <Boolean>

FIPS 140-2 標準に準拠するソフトウェア暗号化を有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DisasterRecoveryDataPath <String>

バックアップするコンピュータのディザスタリカバリ情報を格納するために使用するパスを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DisasterRecoveryAlternateDataPath <String>

バックアップするコンピュータのディザスタリカバリ情報のコピーを格納するために使用する代替パスを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InventoryRoboticLibrariesOnBackupExecServiceStart <Boolean>

Backup Exec サービスの起動時に、ロボットライブラリ内部のすべてのスロットのインベントリを Backup Exec で実行できるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MediaOverwriteProtectionLevel

Backup Exec がメディアを上書きできる場合を指定します。

The valid values are:
None
Full
Partial

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PromptBeforeOverwritingMedia <Boolean>

Backup Exec がメディアを上書きする前に、メッセージが表示されます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MediaOverwriteOption

最初に上書きするメディアの種類を指定します。

The valid values are:
OverwriteScratchBeforeRecyclable
OverwriteRecyclableBeforeScratchMedia

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableBackupExecToMarkDiskStorageReadOnly <Boolean>

Backup Exec がディスクストレージデバイスを読み取り専用にマークするのを無効化します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LimitDiskStorageToReadOnlyIfDetachedForDays <Int32>

Backup Exec が読み取り専用の操作に限定される前に、ディスクベースのストレージが Backup Exec サーバーから切断される必要がある日数を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableBackupExecToMarkDiskCartridgesReadOnly <Boolean>

Backup Exec がディスクカートリッジを読み取り専用にマークするのを無効化します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AllowBackupExecToReportAnonymousUsageInformation <Boolean>

Backup Exec の最適化に役立てるよう、Backup Exec に匿名使用情報の報告を許可します。個人識別情報はベリタス社に送信されません

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LimitDiskCartridgesToReadOnlyIfNotInsertedForDays <Int32>

Backup Exec がカートリッジを読み取り専用にマークするまでのディスクカートリッジが挿入されていない日数を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MultipleServerBackupMode

複数のサーバーにわたる選択項目を持つ新規バックアップジョブが、すべての選択項目を含んだ単一のバックアップジョブとして作成されているのか、特定サーバー上の別個のバックアップジョブとして作成されているのかを指定します。

The valid values are:
CreateOneBackup
CreateSeparateBackupPerServer

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PromptForMultipleServerBackupMode <Boolean>

複数のサーバーにわたる選択項目を持つ新規バックアップジョブが作成されるときに、Backup Exec が MultipleServerBackupMode のメッセージを表示することを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableTestAgentServerCredentialSchedule <Boolean>

エージェントサーバーのスケジュール済みクレデンシャルテストを有効化します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestAgentServerCredentialDayInterval <UInt32>

スケジュール済みクレデンシャルテストの間隔として必要な経過日数を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestAgentServerCredentialStartTime <DateTime>

スケジュール済みクレデンシャルテストを実行する時刻を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestAgentServerCredentialAtAgentServerLevelOnly <Boolean>

クレデンシャルがエージェントサーバーへのログインのみについてテストされるかどうか、またはエージェントサーバー上にあるすべてのバックアップソースについてテストされるかを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Force <SwitchParameter>

Backup Exec にディスクストレージまたはディスクカートリッジを強制的に読み取り専用とマークさせるようにして、カタログパスを変更可能にします。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

このコマンドレットは入力を受け入れません。

Return Value
BackupExec.Management.CLI.BEBackupExecSettings

Get-BEBackupExecSetting は、グローバル Backup Exec 設定を表すオブジェクトを返します。

Examples

Example 1

C:\PS> Set-BEBackupExecSetting -JobLogInformationLevel SummaryDirectoriesAndFileDetails

このコマンドはグローバル設定を更新して、概略情報、処理されたサブディレクトリ、すべてのファイル名とその属性のリストをジョブログに記載します。

Example 2
C:\PS> Set-BEBackupExecSetting -EnableTestAgentServerCredentialSchedule:$true -TestAgentServerCredentialDayInterval 1 -TestAgentServerCredentialStartTime 1:00pm -TestAgentServerCredentialAtAgentServerLevelOnly:$false

このコマンドはグローバル設定を更新して、毎日午後 1 時にエージェントサーバー上のクレデンシャル (すべてのエージェントサーバーのバックアップソースのクレデンシャル) をテストします。

Related Links


Set-BEBackupJobDefault Help

Set-BEBackupJobDefault Cmdlet
Synopsis

Backup Exec のジョブのデフォルトのプロパティを設定します。

Syntax
Set-BEBackupJobDefault [-BackupJobDefault] <BEBackupJobDefaults> [-OracleMinimumNumberOfDevicesRequiredForJob <UInt32>] [-OracleMaximumNumberOfDevicesToUseForResources <UInt32>] [-ActiveDirectoryUseGrt <Boolean>] [-VirtualMachineBackupPoweredOffVirtualMachine <Boolean>] [-VirtualMachineUseGrtForActiveDirectory <Boolean>] [-VirtualMachineUseGrtForFileSystem <Boolean>] [-VirtualMachineEnableIRForAll <Boolean>] [-ActiveDirectoryContinueIfConsistencyCheckIsUnsuccessful <Boolean>] [-LinuxMacPreserveChangeTime <Boolean>] [-SharePointContinueIfConsistencyCheckIsUnsuccessful <Boolean>] [-SharePointPreConsistencyCheck <Boolean>] [-LinuxMacFollowLocalMountPoint <Boolean>] [-ActiveDirectoryPreConsistencyCheck <Boolean>] [-LinuxMacLockRemoteFile <Boolean>] [-LinuxMacFollowRemoteMountPoint <Boolean>] [-NdmpNetAppEnableFileHistory <Boolean>] [-NdmpNetAppBackupAccessControlLists <Boolean>] [-NdmpEMCEnableFileHistory <Boolean>] [-RestrictToBackupExecServer <BEBackupExecServer>] [-RestrictToBackupExecServersInPool <BEBackupExecServerPool>] [-NdmpEMCBackupWithIntegratedCheckpoints <Boolean>] [-VirtualMachineUseGrtForSharePoint <Boolean>] [-VirtualMachineUseGrtForSql <Boolean>] [-VirtualMachineUseGrtForExchange <Boolean>] [-HyperVExcludeVirtualMachinesNeedingSavedState <Boolean>] [-NdmpEMCBackupType {Dump | VBB}] [-VMwareVSpherePort <UInt32>] [-VMwareTransportModePriority {SAN | NBD | NBDSSL | Hotadd}] [-SharePointReleaseLockOnFarmTopology <Boolean>] [-SnapshotProvider {Automatic | System | Software | Hardware}] [-SnapshotTechnology {Automatic | MicrosoftVolumeShadowCopyService}] [-UseSnapshotTechnology <Boolean>] [-ProcessLogicalVolumesSequentially <Boolean>] [-FailIfNoOffhostBackup <Boolean>] [-OffhostBackupSnapshotProvider {Automatic | Software | Hardware}] [-UseOffhostBackup <Boolean>] [-EnableCheckpointRestart <Boolean>] [-TestRunCheckLogonAccount <Boolean>] [-TestRunSchedule <BESchedule>] [-EnableTestRun <Boolean>] [-TestRunCheckStorageSpace <Boolean>] [-TestRunPlaceScheduledBackupJobOnHoldIfUnsuccessful <Boolean>] [-TestRunJobSizeCalculationMethod {UsePreviousJobHistories | PerformPreScan}] [-TestRunCheckMediaAvailable <Boolean>] [-FileSystemBackupOpenFileIfClosedWithinSeconds <UInt32>] [-FileSystemBackupOpenFile {Never | IfClosedWithinSpecifiedTime | WithALock | WithoutALock}] [-FileSystemBackupRemoteStorage <Boolean>] [-ExchangePreConsistencyCheck <Boolean>] [-ExchangePreferredServerGroup <BEPreferredServerGroup>] [-ExchangeHighAvailability {FromPassiveCopyIfAvailableOtherwiseActiveCopy | FromPassiveCopyOnly | FromActiveCopyOnly | FromPassiveCopyIfAvailableOtherwiseActiveCopyUsePreferredServers}] [-ExchangeContinueIfConsistencyCheckIsUnsuccessful <Boolean>] [-FileSystemFollowSymbolicLink <Boolean>] [-DelayedCatalogStartAt <DateTime>] [-DelayedCatalogScheduleType {NoDelayedCatalog | ImmediatelyAfterBackup | Scheduled}] [-ProcessOffhostLogicalVolumesSequentially <Boolean>] [-DelayedCatalogDaysOfWeek {Sunday | Monday | Tuesday | Wednesday | Thursday | Friday | Saturday}] [-FileSystemFollowJunctionPoint <Boolean>] [-FileSystemEnableNtfsSingleInstanceBackup <Boolean>] [-FileSystemBackupMethod {UseModifiedTime | UseArchiveBit | UseCatalog}] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のジョブのデフォルトのプロパティを設定します。

Set-BEBackupJobDefault に渡されるパラメータは、バックアップジョブのデフォルトのすべてのタスクに対するオプションです。

Set-BEBackupJobDefault を次のコマンドと一緒に使用して、バックアップジョブのデフォルトのタスクを変更できます:Get-BEBackupJobDefault、Add-BEIncrementalBackupTask、Add-BEDifferentialBackupTask、Add-BEVerifyBackupTask、Set-BEIncrementalBackupTask、Set-BEDifferentialBackupTask、Set-BEVerifyBackupTask、Remove-BEBackupTask。

バックアップジョブのデフォルトを編集する場合、バックアップジョブのデフォルトを Save-BEBackupJobDefault に渡して変更をコミットする必要があります。

Parameters

-EnableTestRun <Boolean>

テスト実行の処理を有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunSchedule <BESchedule>

テスト実行ジョブの実行日時と実行頻度のスケジュール設定を可能にします。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunCheckLogonAccount <Boolean>

バックアップする Backup Exec ログオンアカウントがデータにアクセス可能であることを確認します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunCheckStorageSpace <Boolean>

メディア上にジョブの完了に必要な容量があるかどうかをチェックします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunCheckMediaAvailable <Boolean>

メディアがオンラインになっていて上書き可能かどうかをチェックします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunJobSizeCalculationMethod

メディアにスケジュール済みバックアップジョブの実行に必要な容量があるかどうかを計算する方法を指定します。

The valid values are:
UsePreviousJobHistories
PerformPreScan

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunPlaceScheduledBackupJobOnHoldIfUnsuccessful <Boolean>

テスト実行中に Backup Exec で障害が検出された場合、スケジュール済みジョブを保留にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableCheckpointRestart <Boolean>

ジョブが中断された時点からバックアップジョブを続行可能にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UseSnapshotTechnology <Boolean>

スナップショットテクノロジの利用を有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SnapshotTechnology

スナップショットテクノロジを有効にしたときに使用する、スナップショットテクノロジを指定します。UseSnapshotTechnology は $true に設定する必要があります。

The valid values are:
Automatic
MicrosoftVolumeShadowCopyService

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SnapshotProvider

スナップショットテクノロジを有効にしたときに使用するスナップショットプロバイダとして、Microsoft ボリュームシャドウコピーサービスを指定します。UseSnapshotTechnology を $true に設定し、SnapshotTechnology を MicrosoftVolumeShadowCopyService に設定する必要があります。

The valid values are:
Automatic
System
Software
Hardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ProcessLogicalVolumesSequentially <Boolean>

1 つのジョブで複数のボリュームをバックアップすることを有効にします。このとき、一度に 1 つの論理ボリュームのスナップショットのみが作成されます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UseOffhostBackup <Boolean>

オフホストバックアップを有効にします。有効な場合は、すべての必要条件が満たされると、すべてのボリュームのオフホストバックアップが実行されます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OffhostBackupSnapshotProvider

使用するオフホストバックアップのスナップショットプロバイダを指定します。UseOffhostBackup は $true に設定する必要があります。

The valid values are:
Automatic
Software
Hardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FailIfNoOffhostBackup <Boolean>

選択したボリュームのいずれかがオフホストバックアップをサポートしない場合、またはスナップショットやボリュームのインポートでエラーが発生した場合、バックアップジョブを終了します。 UseOffhostBackup は $true に設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ProcessOffhostLogicalVolumesSequentially <Boolean>

1 つのジョブで複数のボリュームをバックアップすることを可能にします。このとき、オフホストバックアップに対して一度に 1 つの論理ボリュームのスナップショットのみが作成されます。UseOffhostBackup は $true に設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DelayedCatalogScheduleType

実行する延期したカタログ操作の代替日または時間を指定します。

The valid values are:
NoDelayedCatalog
ImmediatelyAfterBackup
Scheduled

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DelayedCatalogStartAt <DateTime>

遅延カタログジョブを実行する時刻を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DelayedCatalogDaysOfWeek

遅延カタログジョブを実行する曜日を指定します。

The valid values are:
Sunday
Monday
Tuesday
Wednesday
Thursday
Friday
Saturday

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemBackupMethod

ファイルとフォルダのバックアップに使用するバックアップ方式を指定します。

The valid values are:
UseModifiedTime
UseArchiveBit
UseCatalog

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemEnableNtfsSingleInstanceBackup <Boolean>

Backup Exec で同一ファイルに対して NTFS ボリュームをチェックできるようにします。ファイルのコピーが複数見つかった場合は、そのファイルの 1 つのインスタンスのみが Backup Exec によってバックアップされます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemFollowJunctionPoint <Boolean>

接合点の情報とリンク先のファイルおよびディレクトリをバックアップします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemFollowSymbolicLink <Boolean>

シンボリックリンクの情報とリンク先のファイルとディレクトリの情報をバックアップします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemBackupRemoteStorage <Boolean>

プライマリストレージからセカンダリストレージに移動したデータをバックアップします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemBackupOpenFile

スナップショットテクノロジが使用されていない場合に Backup Exec がバックアップジョブでオープンファイルを処理する方法を指定します。

The valid values are:
Never
IfClosedWithinSpecifiedTime
WithALock
WithoutALock

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemBackupOpenFileIfClosedWithinSeconds <UInt32>

オープンファイルをスキップしてバックアップジョブを続行する前に Backup Exec が待機する秒数を指定します。BackupOpenFile が IfClosedWithinSpecifiedTime に設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangePreConsistencyCheck <Boolean>

バックアップジョブを実行する前に一貫性チェックを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeContinueIfConsistencyCheckIsUnsuccessful <Boolean>

一貫性チェックに失敗した場合でもバックアップジョブを続行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeHighAvailability

Exchange 2007 以降のバックアップソースを指定します。

The valid values are:
FromPassiveCopyIfAvailableOtherwiseActiveCopy
FromPassiveCopyOnly
FromActiveCopyOnly
FromPassiveCopyIfAvailableOtherwiseActiveCopyUsePreferredServers

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangePreferredServerGroup <BEPreferredServerGroup>

Microsoft Exchange 2010 データベース可用性グループをバックアップするために使用する優先サーバーの設定の名前を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointReleaseLockOnFarmTopology <Boolean>

バックアップジョブを実行する前に SharePoint ファームトポロジーのロックを解除します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointPreConsistencyCheck <Boolean>

Microsoft SharePoint で使用する Microsoft SQL データベースをバックアップする前に、インデックスを含む完全な一貫性チェックを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointContinueIfConsistencyCheckIsUnsuccessful <Boolean>

一貫性チェックに失敗した場合でもバックアップジョブを続行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LinuxMacPreserveChangeTime <Boolean>

バックアップジョブの実行時に Agent for Windows でオブジェクトの属性が変更されないようにします。オブジェクトはファイルまたはディレクトリです。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LinuxMacFollowLocalMountPoint <Boolean>

データのバックアップ時に Backup Exec でローカルマウントポイントをたどることができます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LinuxMacFollowRemoteMountPoint <Boolean>

データのバックアップ時に Backup Exec でリモートマウントポイントをたどることができます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LinuxMacLockRemoteFile <Boolean>

ネットワークファイルシステム (NFS) を介して接続されたリモートコンピュータのファイルに Agent for Windows で排他的にアクセスできます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ActiveDirectoryPreConsistencyCheck <Boolean>

スナップショットにデータ破損がないかを確認します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ActiveDirectoryContinueIfConsistencyCheckIsUnsuccessful <Boolean>

一貫性チェックが失敗してもバックアップジョブの続行を可能にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ActiveDirectoryUseGrt <Boolean>

Active Directory の完全バックアップから個々の項目をリストアできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleMaximumNumberOfDevicesToUseForResources <UInt32>

バックアップジョブで使用できる最大デバイス数を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleMinimumNumberOfDevicesRequiredForJob <UInt32>

ジョブで使用できる最小デバイス数を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineBackupPoweredOffVirtualMachine <Boolean>

オフになった仮想マシンを Backup Exec でバックアップできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineEnableIRForAll <Boolean>

GRT の対象外を含むすべての仮想マシンでインスタントリカバリを有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForFileSystem <Boolean>

完全バックアップジョブから個々のファイルとフォルダをリストアできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForActiveDirectory <Boolean>

Backup Exec で仮想マシン上の個々の Active Directory オブジェクトをリストアするのに必要な情報を収集できるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForExchange <Boolean>

Backup Exec で仮想マシン上の個々の Exchange データベースおよびメールボックス項目をリストアするのに必要な情報を収集できるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForSql <Boolean>

Backup Exec で仮想マシン上の個々の SQL データベース項目をリストアするのに必要な情報を収集できるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForSharePoint <Boolean>

Backup Exec で仮想マシン上の SharePoint データをリストアするのに必要な情報を収集できるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-HyperVExcludeVirtualMachinesNeedingSavedState <Boolean>

オンラインバックアップをサポートしない、バックアップの開始時に実行状態であるすべてのオフライン仮想マシンを除外します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VMwareTransportModePriority

Backup Exec で使用する 1 つ以上の VMware 転送モードを優先度順に指定します。

The valid values are:
SAN
NBD
NBDSSL
Hotadd

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VMwareVSpherePort <UInt32>

Backup Exec で使用する VMware vSphere ポートを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NdmpEMCBackupType

EMC NDMP サーバーのバックアップタイプを指定します。

The valid values are:
Dump
VBB

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NdmpEMCBackupWithIntegratedCheckpoints <Boolean>

Backup Exec で EMC SnapSure 機能を使用するバックアップセットを作成するように設定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NdmpEMCEnableFileHistory <Boolean>

ファイルの履歴データの生成を可能にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NdmpNetAppBackupAccessControlLists <Boolean>

NetApp アクセス制御リストをバックアップします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NdmpNetAppEnableFileHistory <Boolean>

ファイルの履歴データの生成を可能にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupJobDefault <BEBackupJobDefaults>

変更するバックアップジョブのデフォルトを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RestrictToBackupExecServer <BEBackupExecServer>

CASO 環境でジョブをディスパッチ可能な Backup Exec サーバーを指定します。RestrictToBackupExecServersInPool が指定されている場合は指定できません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RestrictToBackupExecServersInPool <BEBackupExecServerPool>

CASO 環境でジョブをディスパッチ可能な Backup Exec サーバーのセットを指定します。RestrictToBackupExecServer が指定されている場合は指定できません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupJobDefaults

Backup Exec バックアップジョブのデフォルトオブジェクトを、パイプを使用して Set-BEBackupJobDefault に渡すことができます。

Return Value
BackupExec.Management.CLI.BEBackupJobDefaults

Set-BEBackupJobDefault は、変更されたバックアップジョブのデフォルトを返します。

Examples

Example 1

C:\PS> Get-BEBackupJobDefault BackupToTape | Set-BEBackupJobDefault -FileSystemBackupMethod UseModifiedTime | Save-BEBackupJobDefault

これらのコマンドは、テープファイルシステムバックアップ方式に対するデフォルトのバックアップを「UseModifiedTime」に設定します。

Example 2
C:\PS> Get-BEBackupJobDefault BackupToTape | Add-BEDifferentalBackupTask | Save-BEBackupJobDefault

これらのコマンドは、差分バックアップをテープへのバックアップジョブのデフォルトに追加します。

Related Links

Get-BEBackupJobDefault
Add-BEIncrementalBackupTask
Add-BEDifferentialBackupTask
Add-BEVerifyBackupTask
Set-BEIncrementalBackupTask
Set-BEDifferentialBackupTask
Set-BEVerifyBackupTask
Remove-BEBackupTask
Save-BEBackupJobDefault


Set-BEBackupSelectionListOrder Help

Set-BEBackupSelectionListOrder Cmdlet
Synopsis

既存のバックアップ定義内またはワンタイムバックアップジョブで選択項目を並べ替えます。

Syntax
Set-BEBackupSelectionListOrder [-InputObject] <Object> [[-AgentServerNameOrder] <String[]>] [-MakeLast <SwitchParameter>] [-AgentServerBackupSourceNameOrder <String[]>] [<CommonParameters>]
Description

既存のバックアップ定義内またはワンタイムバックアップジョブで選択項目を並べ替えます。

バックアップの選択項目は、単一のバックアップジョブで、複数のエージェントサーバーにわたることが可能です。ただし、ジョブの実行中に、エージェントサーバーは選択項目リスト内で指定された順序でバックアップされます。
AgentServerNameOrder パラメータを使用して、バックアップジョブでエージェントサーバーがバックアップされる順序のリストを表示できます。

また、BEAgentServerBackupSelection オブジェクトの選択項目プロパティには、それぞれバックアップジョブに含めるデータと除外するデータを指定している BESelection オブジェクトのリストが含まれています。
AgentServerBackupSourceNameOrder パラメータを使用して、各エージェントサーバーの選択項目がバックアップされる順序を指定できます。

Parameters

-InputObject <Object>

BEAgentServerSelection オブジェクトのアレイが含まれている「SelectionList」という名前のプロパティを含んだオブジェクトを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-AgentServerNameOrder <String[]>

順序を変更するエージェントサーバー名の順序付けられたリストを指定します。

Required | false
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-AgentServerBackupSourceNameOrder <String[]>

順序を変更するエージェントサーバーのバックアップソース名の順序付けられたリストを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MakeLast <SwitchParameter>

ソートされる項目が選択の順序の最後に置かれることを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupDefinition

バックアップ定義オブジェクトを Sort-BEBackupSelectionList にパイプ処理できます。

BackupExec.Management.CLI.BEOneTimeBackupJob

ワンタイムバックアップジョブオブジェクトを Sort-BEBackupSelectionList にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEAgentServerSelection

BackupExec.Management.CLI.BEAgentServerSelection

Examples

Example 1

C:\PS> Get-BEOneTimeBackupJob | Set-BEBackupSelectionListOrder -AgentServerNameOrder *.mycompany.com

これらのコマンドは、名前に「*.mycompany.com」を含むサーバーが最初にバックアップされるように、すべてのワンタイムバックアップジョブの選択項目を並べ替えます。

Example 2
C:\PS> Get-BEBackupDefinition | Set-BEBackupSelectionListOrder -AgentServerBackupSourceNameOrder *SQL*,C:

これらのコマンドは、AgentServerBackupSource を伴う選択したすべてのエージェントサーバーにおけるバックアップソースの選択で、AgentServerBackupSource 名に「*SQL*」を含むものが最初にバックアップされ、次に「C:」を含むもの、次に指定された残りの順序でバックアップされるように、すべてのバックアップ定義の選択項目を並べ替えます。

Example 3
C:\PS> Get-BEBackupDefinition | Set-BEBackupSelectionListOrder -AgentServerNameOrder *.mycompany.com -AgentServerBackupSourceNameOrder *SQL*,C:

これらのコマンドは、名前に「*.mycompany.com」を含むサーバーが最初にバックアップされるように、すべてのバックアップ定義の選択項目を並べ替えます。 これにより、AgentServerBackupSource 名に「*SQL*」を含むものが最初にバックアップされ、次に「C:」を含むもの、その次に指定した残りの順序でバックアップされるように、一致するサーバー内のバックアップソースの選択項目が並べ替えられます。

Example 4
C:\PS> Get-BEOneTimeBackupJob | Set-BEBackupSelectionListOrder -AgentServerNameOrder *.mycompany.com -AgentServerBackupSourceNameOrder *SQL*,C:

これらのコマンドは、名前に「*.mycompany.com」を含むサーバーが最初にバックアップされるように、すべてのワンタイムバックアップジョブの選択項目を並べ替えます。 これにより、AgentServerBackupSource 名でバックアップソースの選択項目が並べ替えられ、その中の「*SQL*」を含むものが最初にバックアップされ、次に「C:」を含むもの、その次に指定した残りの順序でバックアップされます。

Related Links


Set-BEBackupTask Help

Set-BEBackupTask Cmdlet
Synopsis

Backup Exec のバックアップ定義のバックアップを修正します。

Syntax
Set-BEBackupTask -BackupDefinition <BEBackupDefinition> [-Name] <String[]> [-SqlDiskCopyPath <String>] [-SqlCreateDiskCopy <Boolean>] [-SqlUseChecksumOnBackup <Boolean>] [-SqlUseSoftwareCompression <Boolean>] [-OracleSkipBackedUpArchivedLogFile <Boolean>] [-OracleDeleteBackedUpArchivedLogFile <Boolean>] [-SharePointUseGrt <Boolean>] [-EncryptionKey <BEEncryptionKey>] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-VerifyAsPartOfJob <Boolean>] [-ExchangeUseGrt <Boolean>] [-SqlPostConsistencyCheck {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-SqlContinueIfConsistencyCheckUnsuccessful <Boolean>] [-SqlPreConsistencyCheckMethod {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-OraclePerformBackupOffline <Boolean>] [-EnterpriseVaultBackupType {Full | Incremental | Differential | FullCopy}] [-VMwareBackupType {Full | Incremental | Differential}] [-OracleBackupType {Full | Incremental | Differential}] [-NdmpBackupType {Level0 | Level1 | Level2 | Level3 | Level4 | Level5 | Level6 | Level7 | Level8 | Level9}] [-OpenEnterpriseServerBackupType {Full}] [-FileSystemBackupType {Full | Incremental | Differential | FullCopy}] [-ExcludeSelectionList <BEFileSystemSelection[]>] [-DeleteSelectedFilesAfterSuccessfulBackup {Never | FilesOnly | FilesAndFolders}] [-ExchangeBackupType {Full | FullCopy | Incremental | Differential}] [-SharePointBackupType {Full | FullCopy | Incremental | Differential | DifferentialBlockLevel | Log}] [-SqlBackupType {Full | FullCopy | Automatic | Log | LogNoTruncate | Incremental | Differential | DifferentialBlockLevel | DatabaseSnapshot}] [-SqlIncrementalBackupMethod {Full | FullCopy | Automatic | Log | LogNoTruncate | Incremental | Differential | DifferentialBlockLevel | DatabaseSnapshot}] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-TapeStorageRetensionMediaBeforeBackup <Boolean>] [-TapeStorageEnableDirectCopyToTape <Boolean>] [-TapeStorageEnableWriteOnceReadManyMedia <Boolean>] [-DiskStorageKeepForHours <Int32>] [-Schedule <BESchedule>] [-BackupSetDescription <String>] [-SubmitOnHold <Boolean>] [-Storage <BEStorage>] [-JobName <String>] [-TapeStorageMediaSet <BEMediaSet>] [-TapeStorageEjectMediaAfterComplete <Boolean>] [-TapeStorageExportMediaToVault <BEMediaVault>] [-TapeStorageExportMedia <Boolean>] [-KeepJobQueuedFor <TimeSpan>] [-RunJobOnlyIfPreCommandIsSuccessful <Boolean>] [-PrePostCommandSuccessfulIfReturnsZero <Boolean>] [-PostCommand <String>] [-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>] [-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>] [-RunPostCommandAfterVerification <Boolean>] [-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>] [-IncludeJobLogWithEmailNotification <Boolean>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-TapeStorageCompressionMethod {None | SoftwareIfNoHardware | HardwareOnly | SoftwareOnly}] [-EnableDirectAccessIfAvailable <Boolean>] [-PreCommand <String>] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [-Force <SwitchParameter>] [<CommonParameters>]

Set-BEBackupTask -BackupJobDefault <BEBackupJobDefaults> [-Name] <String[]> [-SqlDiskCopyPath <String>] [-SqlCreateDiskCopy <Boolean>] [-SqlUseChecksumOnBackup <Boolean>] [-OracleDeleteBackedUpArchivedLogFile <Boolean>] [-SharePointUseGrt <Boolean>] [-SqlUseSoftwareCompression <Boolean>] [-SqlPostConsistencyCheck {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-EncryptionKey <BEEncryptionKey>] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-VerifyAsPartOfJob <Boolean>] [-SqlContinueIfConsistencyCheckUnsuccessful <Boolean>] [-SqlPreConsistencyCheckMethod {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-ExchangeUseGrt <Boolean>] [-OracleSkipBackedUpArchivedLogFile <Boolean>] [-NdmpBackupType {Level0 | Level1 | Level2 | Level3 | Level4 | Level5 | Level6 | Level7 | Level8 | Level9}] [-EnterpriseVaultBackupType {Full | Incremental | Differential | FullCopy}] [-VMwareBackupType {Full | Incremental | Differential}] [-OpenEnterpriseServerBackupType {Full}] [-OracleBackupType {Full | Incremental | Differential}] [-ExchangeBackupType {Full | FullCopy | Incremental | Differential}] [-FileSystemBackupType {Full | Incremental | Differential | FullCopy}] [-OraclePerformBackupOffline <Boolean>] [-SharePointBackupType {Full | FullCopy | Incremental | Differential | DifferentialBlockLevel | Log}] [-SqlBackupType {Full | FullCopy | Automatic | Log | LogNoTruncate | Incremental | Differential | DifferentialBlockLevel | DatabaseSnapshot}] [-SqlIncrementalBackupMethod {Full | FullCopy | Automatic | Log | LogNoTruncate | Incremental | Differential | DifferentialBlockLevel | DatabaseSnapshot}] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-SubmitOnHold <Boolean>] [-DiskStorageKeepForHours <Int32>] [-TapeStorageRetensionMediaBeforeBackup <Boolean>] [-KeepJobQueuedFor <TimeSpan>] [-Schedule <BESchedule>] [-BackupSetDescription <String>] [-TapeStorageEnableDirectCopyToTape <Boolean>] [-TapeStorageExportMedia <Boolean>] [-TapeStorageMediaSet <BEMediaSet>] [-Storage <BEStorage>] [-TapeStorageEnableWriteOnceReadManyMedia <Boolean>] [-TapeStorageEjectMediaAfterComplete <Boolean>] [-TapeStorageExportMediaToVault <BEMediaVault>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>] [-RunJobOnlyIfPreCommandIsSuccessful <Boolean>] [-PrePostCommandSuccessfulIfReturnsZero <Boolean>] [-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>] [-RunPostCommandAfterVerification <Boolean>] [-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>] [-PostCommand <String>] [-TapeStorageCompressionMethod {None | SoftwareIfNoHardware | HardwareOnly | SoftwareOnly}] [-IncludeJobLogWithEmailNotification <Boolean>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-EnableDirectAccessIfAvailable <Boolean>] [-PreCommand <String>] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のバックアップ定義の完全バックアップを修正します。

新しいバックアップ定義のバックアップを修正またはバックアップ定義を編集できます。
バックアップジョブのデフォルトでバックアップを修正することもできます。

新しいバックアップ定義のバックアップを修正するには、Set-BEBackupTask と New-BEBackupDefinition を使用します。

既存のバックアップ定義のバックアップを修正するには、Set-BEBackupTask と Get-BEBackupDefinition を使用します。

バックアップジョブのデフォルトでバックアップを修正するには、Set-BEBackupTask と Get-BEBackupJobDefault を使用します。

バックアップ定義を作成または編集する場合、そのバックアップ定義を Save-BEBackupDefinition に渡して変更をコミットする必要があります。

バックアップジョブのデフォルトを編集する場合、そのバックアップジョブのデフォルトを Save-BEBackupJobDefault に渡して変更をコミットする必要があります。

Parameters

-BackupDefinition <BEBackupDefinition>

変更するバックアップ定義を指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupJobDefault <BEBackupJobDefaults>

変更するバックアップジョブのデフォルトを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-JobName <String>

このタスクを表すジョブの名前を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Storage <BEStorage>

バックアップジョブに使用するストレージデバイスを指定します。 Get-BEStorage を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaSet <BEMediaSet>

メディアと関連付けるメディアセットを指定します。メディアはメディアセットの設定に基づいて上書きから保護されます。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。 Get-BEMediaSet を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMedia <Boolean>

ジョブの完了後にデバイスからメディアをエクスポートします。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMediaToVault <BEMediaVault>

ジョブの完了後にメディアを指定したボルトに論理的に移動します。Storage パラメータはテープベースのストレージデバイスに設定し、TapeStorageExportMedia は $true に設定する必要があります。Get-BEMediaVault を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEjectMediaAfterComplete <Boolean>

ジョブの完了後にストレージデバイスからメディアを取り出します。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableWriteOnceReadManyMedia <Boolean>

このバックアップジョブに WORM (Write Once Read Many) メディアの使用を指定します。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableDirectCopyToTape <Boolean>

物理テープデバイスに仮想テープライブラリから直接データをコピーできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageRetensionMediaBeforeBackup <Boolean>

データを書き込む前にメディアのリテンションを行います。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskStorageKeepForHours <Int32>

メディアへの上書きを禁止し、このメディア上にデータを保存する時間を指定します。 Storage パラメータがディスクベースのストレージデバイスに設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SubmitOnHold <Boolean>

ジョブを保留状態でサブミットします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupSetDescription <String>

バックアップしたデータとその格納場所についての説明です。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Schedule <BESchedule>

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

予定開始時刻の経過後に、ジョブが未処理であると Backup Exec が判断し、そのジョブのスケジュール再設定が可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

予定開始時刻後にジョブの実行が続行されている場合、そのジョブのキャンセルが可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NotificationRecipientList <BENotificationRecipientObject[]>

ジョブが完了したときに通知を受け取る受信者を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IncludeJobLogWithEmailNotification <Boolean>

電子メールにジョブログを添付します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageCompressionMethod

ハードウェアまたはソフトウェアで実行するデータ圧縮の種類を指定します。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
None
SoftwareIfNoHardware
HardwareOnly
SoftwareOnly

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaAppendMethod

ジョブの開始時にメディアに上書きするか、追記するかを指定します。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
Append
AppendOnly
Overwrite

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableDirectAccessIfAvailable <Boolean>

Agent for Windows から Storage パラメータで指定したデバイスにバックアップデータを直接送信できるようにします (デバイスがこの操作をサポートしている場合)。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreCommand <String>

バックアップジョブの前に実行するコマンドを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PostCommand <String>

バックアップジョブの後に実行するコマンドを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PrePostCommandSuccessfulIfReturnsZero <Boolean>

Backup Exec によってプリコマンドまたはポストコマンドの戻りコードを確認し、コマンドが正しく完了したかどうかを調べることができます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunJobOnlyIfPreCommandIsSuccessful <Boolean>

プリコマンドが正しく実行された場合にのみバックアップジョブを実行します。プリコマンドの実行に失敗した場合は、ジョブは実行されません。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>

プリコマンドが正しく実行された場合にのみポストコマンドを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>

ジョブの実行に成功したかどうかに関係なくポストコマンドを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandAfterVerification <Boolean>

バックアップジョブの検証を選択した場合、検証が完了した後にポストコマンドを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>

完了しなかったプリコマンドまたはポストコマンドをキャンセルするのに待つ時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunCommandLocation

プリコマンドとポストコマンドが実行される場所を指定します。

The valid values are:
OnEachAgentServer
OnBackupExecServer

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VerifyAsPartOfJob <Boolean>

バックアップジョブの完了時に自動的に検証操作を実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionType

バックアップジョブに使用する暗号化の種類を指定します。

The valid values are:
None
Software
Hardware
SoftwareIfNoHardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionKey <BEEncryptionKey>

使用する暗号化キーを指定します。 EncryptionType が None 以外の値に設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeUseGrt <Boolean>

インフォメーションストアのバックアップジョブから個々の項目をリストアできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlPreConsistencyCheckMethod

バックアップジョブを実行する前に行う一貫性チェックの種類を指定します。

The valid values are:
None
Physical
FullExcludingIndexes
FullIncludingIndexes

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlContinueIfConsistencyCheckUnsuccessful <Boolean>

一貫性チェックに失敗した場合でもバックアップジョブを続行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlPostConsistencyCheck

バックアップジョブを実行した後に行う一貫性チェックの種類を指定します。

The valid values are:
None
Physical
FullExcludingIndexes
FullIncludingIndexes

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlUseChecksumOnBackup <Boolean>

SQL 2005 以降の場合、バックアップする SQL データベースのデータにチェックサムを追加します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlCreateDiskCopy <Boolean>

バックアップする SQL データベースのコピーをディスク上に作成します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlDiskCopyPath <String>

バックアップする SQL データベースのディスク上に作成されるコピーのパスを指定します。CreateDiskCopy が $true に設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlUseSoftwareCompression <Boolean>

SQL 2008以降の場合、使用する圧縮設定を指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointUseGrt <Boolean>

データベースバックアップからの個々のドキュメント、イメージ、サイト、サブサイト、リスト、リストの項目のリストアを有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleDeleteBackedUpArchivedLogFile <Boolean>

バックアップ後にアーカイブログファイルを自動的に削除できます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleSkipBackedUpArchivedLogFile <Boolean>

以前にバックアップしたアーカイブログファイルを Backup Exec がスキップできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OraclePerformBackupOffline <Boolean>

バックアップジョブを開始する前に Backup Exec がデータベースをオフラインにすることを可能にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DeleteSelectedFilesAfterSuccessfulBackup

選択したデータをバックアップし、メディアの検証を行った後、ボリュームからデータを削除します。この操作でファイルを削除してデータを回復するにはリストアを実行する必要があるため、このオプションを有効にした場合は Force パラメータを指定する必要があります。

The valid values are:
Never
FilesOnly
FilesAndFolders

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExcludeSelectionList <BEFileSystemSelection[]>

バックアップジョブを実行するときの除外対象を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemBackupType

ファイルシステムを選択した場合に、どの種類のバックアップジョブを作成するかを指定します。

The valid values are:
Full
Incremental
Differential
FullCopy

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeBackupType

Microsoft Exchange を選択した場合に、どの種類のバックアップジョブを作成するかを指定します。

The valid values are:
Full
FullCopy
Incremental
Differential

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlIncrementalBackupMethod

Microsoft SQL 選択に対する増分バックアップ方式を指定します。

The valid values are:
Full
FullCopy
Automatic
Log
LogNoTruncate
Incremental
Differential
DifferentialBlockLevel
DatabaseSnapshot

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlBackupType

Microsoft SQL 選択を作成するバックアップジョブの種類を指定します。

The valid values are:
Full
FullCopy
Automatic
Log
LogNoTruncate
Incremental
Differential
DifferentialBlockLevel
DatabaseSnapshot

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointBackupType

Microsoft SharePoint を選択した場合に、どの種類のバックアップジョブを作成するかを指定します。

The valid values are:
Full
FullCopy
Incremental
Differential
DifferentialBlockLevel
Log

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleBackupType

Oracle を選択した場合に、どの種類のバックアップジョブを作成するかを指定します。

The valid values are:
Full
Incremental
Differential

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VMwareBackupType

VMware を選択した場合に、どの種類のバックアップジョブを作成するかを指定します。

The valid values are:
Full
Incremental
Differential

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnterpriseVaultBackupType

Enterprise Vault を選択した場合に、どの種類のバックアップジョブを作成するかを指定します。

The valid values are:
Full
Incremental
Differential
FullCopy

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NdmpBackupType

バックアップ NDMP サーバーに対して使用するバックアップレベルを指定します。

The valid values are:
Level0
Level1
Level2
Level3
Level4
Level5
Level6
Level7
Level8
Level9

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OpenEnterpriseServerBackupType

Open Enterprise Server を選択した場合に、どの種類のバックアップジョブを作成するかを指定します。

The valid values are:
Full

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String[]>

バックアップジョブの名前を指定します。

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Force <SwitchParameter>

DeleteSelectedFilesAfterSuccessfulBackup パラメータによってデータが失われ、使用を続ける必要があることを確認します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupDefinition

Backup Exec バックアップ定義オブジェクトを Set-BEBackupTask にパイプ処理できます。

BackupExec.Management.CLI.BEBackupJobDefaults

Backup Exec のバックアップジョブのデフォルトオブジェクトを Set-BEBackupTask にパイプ処理できます。

Return Values
BackupExec.Management.CLI.BEBackupDefinition

修正されたバックアップ定義を示します。

BackupExec.Management.CLI.BEBackupJobDefaults

修正されたバックアップジョブのデフォルトを示します。

Examples

Example 1

C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Set-BEBackupTask -Name "Differential 2" -Storage "Any disk storage" | Save-BEBackupDefinition

これらのコマンドは「Backup Definition 01」という名前のバックアップ定義に含まれる「Differential 2」という名前のバックアップのストレージを「Any disk storage」プールに設定します。

Example 2
C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Set-BEBackupTask -Name * -Storage "Any disk storage" | Save-BEBackupDefinition

これらのコマンドは「Backup Definition 01」という名前のバックアップ定義に含まれるすべてのバックアップのストレージを「Any disk storage」プールに設定します。

Example 3
C:\PS> Get-BEBackupJobDefault BackupToDisk | Set-BEBackupTask -Name * -Storage "Any disk storage" | Save-BEBackupJobDefault

これらのコマンドはディスクへのバックアップジョブのデフォルトに含まれるすべてのバックアップのストレージを「Any disk storage」プールに設定します。

Related Links

New-BEBackupDefinition
Get-BEBackupDefinition
Get-BEBackupJobDefault
Save-BEBackupDefinition
Save-BEBackupJobDefault
Get-BEStorage
Get-BEMediaSet
Get-BEMediaVault
New-BESchedule


Set-BECentralAdministrationBackupExecServer Help

Set-BECentralAdministrationBackupExecServer Cmdlet
Synopsis

集中管理サーバーのプロパティを設定します。

Syntax
Set-BECentralAdministrationBackupExecServer -InputObject <BECentralAdministrationBackupExecServer[]> [-Description <String>] [-IsPrivateCloudServer <Boolean>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

集中管理サーバーのプロパティを設定します。

Parameters

-Description <String>

集中管理サーバーの説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IsPrivateCloudServer <Boolean>

集中管理サーバーがプライベートクラウドサーバーであることを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BECentralAdministrationBackupExecServer[]>

1 つ以上の集中管理サーバーオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BECentralAdministrationBackupExecServer

Backup Exec 集中管理サーバーオブジェクトを Set-BECentralAdministrationBackupExecServer にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BECentralAdministrationBackupExecServer

Set-BECentralAdministrationBackupExecServer は、変更された Backup Exec 集中管理サーバーを表すオブジェクトを返します。

Example

C:\PS> $BackupExecServer = Get-BECentralAdministrationBackupExecServer -Name "MyCas"
C:\PS> $BackupExecServer | Set-BECentralAdministrationBackupExecServer -Description "This is my Central Administration Server"

このコマンドは「MyCas」という名前の集中管理サーバーの説明を設定します。

Related Link

Get-BECentralAdministrationBackupExecServer


Set-BECleanUtilityJob Help

Set-BECleanUtilityJob Cmdlet
Synopsis

Backup Exec クリーニングジョブのプロパティを設定します。

Syntax
Set-BECleanUtilityJob -InputObject <BECleanUtilityJob[]> [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-Schedule <BESchedule>] [-KeepJobQueuedFor <TimeSpan>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec クリーニングジョブのプロパティを設定します。

Parameters

-Schedule <BESchedule>

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

予定開始時刻の経過後に、ジョブが未処理であると Backup Exec が判断し、そのジョブのスケジュール再設定が可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

予定開始時刻後にジョブの実行が続行されている場合、そのジョブのキャンセルが可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BECleanUtilityJob[]>

1 つ以上のクリーニングジョブオブジェクトを指定します。 . オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BECleanUtilityJob

Backup Exec クリーニングジョブオブジェクトを Set-BECleanUtilityJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BECleanUtilityJob

Set-BECleanUtilityJob は、変更された Backup Exec クリーニングジョブを表すオブジェクトを返します。

Example

C:\PS> $Schedule = New-BESchedule -RunNow
C:\PS> Get-BECleanUtilityJob -Name "CleanJob" | Set-BECleanUtilityJob -Schedule $Schedule

これらのコマンドはクリーニングジョブ「CleanJob」のスケジュールを今すぐ実行するよう設定します。

Related Links


Set-BECloudInstance Help

Set-BECloudInstance Cmdlet
Synopsis

Backup Exec クラウドインスタンスのプロパティを設定します。

Syntax
Set-BECloudInstance -InputObject <BECloudInstance[]> [-Endpoint <String>] [-HttpsPort <Int32>] [-SslMode {Disabled | AuthenticationOnly | Full}] [-ServiceHost <String>] [-HttpPort <Int32>] [-UrlStyle {Unknown | Virtual | Path}] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec クラウドインスタンスのプロパティを設定します。

既存のクラウドインスタンスのプロバイダを除くすべての設定を修正できます。

Parameters

-ServiceHost <String>

クラウドインスタンスのサービスホストを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SslMode

クラウドインスタンスとの通信に Backup Exec が使用する SSL モードを指定します。

The valid values are:
Disabled
AuthenticationOnly
Full

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UrlStyle

クラウドインスタンスの URL 形式を指定します。

The valid values are:
Unknown
Virtual
Path

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-HttpPort <Int32>

クラウドインスタンスの http ポートを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-HttpsPort <Int32>

クラウドインスタンスの https ポートを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Endpoint <String>

クラウドインスタンスのエンドポイントを作成します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BECloudInstance[]>

1 つ以上のクラウドインスタンスオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BECloudInstance

Backup Exec クラウドインスタンスオブジェクトを Set-BECloudInstance にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BECloudInstance

Set-BECloudInstance は、変更されたクラウドインスタンスを表すオブジェクトを返します。

Example

C:\PS> Get-BECloudInstance "CloudInstance0001" | Set-BECloudInstance -ServiceHost "s3.cloudian1.com"

これらのコマンドは、「CloudInstance0001」という名前のクラウドインスタンスのサービスホストプロパティを「s3.cloudian1.com」に変更します。

Related Link

Get-BECloudInstance


Set-BECloudRegion Help

Set-BECloudRegion Cmdlet
Synopsis

Backup Exec のクラウドリージョンのプロパティを設定します。

Syntax
Set-BECloudRegion -InputObject <BECloudRegion[]> [-IsDefaultRegion <Boolean>] [-ServiceHost <String>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のクラウドリージョンのプロパティを設定します。

既存のクラウドリージョンの IsDefaultRegion と ServiceHost を変更できます。

Parameters

-IsDefaultRegion <Boolean>

クラウドインスタンスに使用するデフォルトリージョンを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ServiceHost <String>

クラウドリージョンのサービスホストを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BECloudRegion[]>

1 つ以上のクラウドリージョンオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BECloudRegion

Backup Exec クラウドリージョンオブジェクトを Set-BECloudRegion にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BECloudRegion

Set-BECloudRegion は、変更されたクラウドリージョンを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BECloudRegion -Name "ap australia" | Set-BECloudRegion -ServiceHost "s3.au-syd.cloud-object-storage.appdomain.cloud"

これらのコマンドは、「ap australia」という名前のクラウドリージョンのサービスホストプロパティを「s3.au-syd.cloud-object-storage.appdomain.cloud」に変更します。

Example 2
C:\PS> Get-BECloudRegion -Name "ap australia" -InstanceName "ibminst" | Set-BECloudRegion -IsDefaultRegion $true

これらのコマンドは、クラウドインスタンス「ibminst」に関連付けられている「ap australia」という名前のクラウドリージョンのデフォルトリージョンのプロパティを true に変更します。

Related Link

Get-BECloudRegion


Set-BECloudStorageDevice Help

Set-BECloudStorageDevice Cmdlet
Synopsis

Backup Exec クラウドストレージデバイスのプロパティを設定します。

Syntax
Set-BECloudStorageDevice -InputObject <BECloudStorageDevice[]> [-DiskSpaceReserveBytes <Int64>] [-IsStreamHandlerSupportEnabled <Boolean>] [-DataStreamSizeBytes <Int32>] [-PreferredBackupServer <BEBackupExecServer>] [-Disabled <Boolean>] [-Description <String>] [-LogonAccount <BELogonAccount>] [-SplitDataStreamBytes <Int64>] [-AllowedConcurrentOperations <Int32>] [-Paused <Boolean>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec クラウドストレージデバイスのプロパティを設定します。

Parameters

-LogonAccount <BELogonAccount>

新しいクラウドストレージデバイスの Backup Exec ログオンアカウントを指定します。 このログオンアカウントにシステムログオンアカウントは使用できません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

クラウドストレージデバイスの説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Disabled <Boolean>

クラウドストレージデバイスを無効にするかどうかを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Paused <Boolean>

クラウドストレージデバイスを一時停止するかどうかを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AllowedConcurrentOperations <Int32>

このデバイスで許可される最大許容並列書き込み処理を設定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SplitDataStreamBytes <Int64>

Backup Exec が新しいイメージにスパンするサイズを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DataStreamSizeBytes <Int32>

Backup Exec が行う単一書き込み操作のサイズを示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IsStreamHandlerSupportEnabled <Boolean>

ストリームハンドラを使用するかどうかを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskSpaceReserveBytes <Int64>

Backup Exec 以外のアプリケーション用に空けてあるディスク領域を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreferredBackupServer <BEBackupExecServer>

Central Admin Server Option 環境内のサーバー間でクラウドストレージデバイスが共有されているるときにバックアップ操作を実行するサーバーを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BECloudStorageDevice[]>

クラウドストレージデバイスオブジェクトを 1 つ以上指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BECloudStorageDevice

Backup Exec クラウドストレージデバイスオブジェクトを Set-BECloudStorageDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BECloudStorageDevice

Set-BECloudStorageDevice は、変更された Backup Exec クラウドストレージデバイスを表すオブジェクトを返します。

Example

C:\PS> Get-BECloudStorageDevice "Device 0001" | Set-BECloudStorageDevice -Paused $true

これらのコマンドは「Device 0001」という名前のクラウドストレージデバイスを一時停止します。

Related Link

Get-BECloudStorageDevice


Set-BEConvertToVirtualJob Help

Set-BEConvertToVirtualJob Cmdlet
Synopsis

仮想への変換ジョブのプロパティを設定します。

Syntax
Set-BEConvertToVirtualJob -InputObject <BEConvertToVirtualJob[]> [-NotificationRecipientList <BENotificationRecipientObject[]>] [-StartDate <DateTime>] [-VirtualMachineCpuCount <UInt32>] [-IncludeJobLogWithEmailNotification <Boolean>] [-TargetEnvironment <BEConvertToVirtualTargetEnvironment>] [-SubmitOnHold <Boolean>] [-ExcludeSelectionList <BEAgentServerBackupSelectionList>] [-VirtualMachinePhysicalRamMB <UInt32>] [-OverwriteExistingVirtualMachine <Boolean>] [-VirtualMachineName <String>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

仮想への変換ジョブのプロパティを設定します。

Parameters

-ExcludeSelectionList <BEAgentServerBackupSelectionList>

仮想への変換ジョブを実行するときの除外対象を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SubmitOnHold <Boolean>

ジョブを保留状態でサブミットします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TargetEnvironment <BEConvertToVirtualTargetEnvironment>

仮想への変換ジョブのターゲット環境を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineName <String>

作成される仮想マシンの名前を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OverwriteExistingVirtualMachine <Boolean>

同じ名前のものが存在する場合は、その仮想マシンを上書きします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachinePhysicalRamMB <UInt32>

宛先の仮想マシンの RAM を MB 単位で指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineCpuCount <UInt32>

宛先の仮想マシンの CPU 数を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-StartDate <DateTime>

実行するジョブの日付と時刻を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NotificationRecipientList <BENotificationRecipientObject[]>

ジョブが完了したときに通知を受け取る受信者を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IncludeJobLogWithEmailNotification <Boolean>

電子メールにジョブログを添付します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEConvertToVirtualJob[]>

更新する仮想への変換ジョブを指定します

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEConvertToVirtualJob

更新される BEConvertToVirtualJob です。

Return Value
BackupExec.Management.CLI.BEConvertToVirtualJob

更新された BEConvertToVirtualJob です。

Example

C:\PS> Get-BEConvertToVirtualJob -Name "Convert To Virtual Job 0001" | Set-BEConvertToVirtualJob -VirtualMachineName "NewMachineName"

これらのコマンドは「Convert To Virtual Job 0001」という名前の仮想への変換ジョブのプロパティを「NewMachineName」に変換します。

Related Link

Get-BEConvertToVirtualJob


Set-BEDeduplicationDiskStorageDevice Help

Set-BEDeduplicationDiskStorageDevice Cmdlet
Synopsis

Backup Exec の重複排除用ディスクストレージデバイスのプロパティを設定します。

Syntax
Set-BEDeduplicationDiskStorageDevice -InputObject <BEDeduplicationDiskStorageDevice[]> [-LogRetentionDays <Int32>] [-LogLevel {Minimal | Low | Normal | High | Full}] [-ClientSideDeduplicationEnabled <Boolean>] [-EnableEncryption <Boolean>] [-DataStreamSizeBytes <Int32>] [-Disabled <Boolean>] [-Description <String>] [-LogonAccount <BELogonAccount>] [-AllowedConcurrentOperations <Int32>] [-DiskSpaceReservePercent <Int64>] [-Paused <Boolean>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec の重複排除用ディスクストレージデバイスのプロパティを設定します。

Parameters

-LogonAccount <BELogonAccount>

この重複排除用ストレージデバイスに関連付けられた Backup Exec ログオンアカウントを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

重複排除用ディスクストレージデバイスの説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Disabled <Boolean>

重複排除用ディスクストレージデバイスを無効にするかどうかを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Paused <Boolean>

重複排除用ディスクストレージデバイスを一時停止するかどうかを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskSpaceReservePercent <Int64>

Backup Exec 以外のアプリケーション用に予約するディスク領域の割合を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AllowedConcurrentOperations <Int32>

このデバイスで許容される最大許容同時並行処理数を設定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DataStreamSizeBytes <Int32>

Backup Exec が行う単一書き込み操作のサイズを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ClientSideDeduplicationEnabled <Boolean>

このデバイスのクライアント側の重複排除を有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LogLevel

このデバイスの診断ログに含めたい情報の種類を示します。

The valid values are:
Minimal
Low
Normal
High
Full

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LogRetentionDays <Int32>

ログファイルを保持する日数を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableEncryption <Boolean>

このデバイスに格納されたデータの暗号化を有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEDeduplicationDiskStorageDevice[]>

1 つ以上の重複排除用ディスクストレージデバイスオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEDeduplicationDiskStorageDevice

Backup Exec 重複排除用ディスクストレージデバイスオブジェクトを Set-BEDeduplicationDiskStorageDevice にパイプ処理することができます。

Return Value
BackupExec.Management.CLI.BEDeduplicationDiskStorageDevice

Set-BEDeduplicationDiskStorageDevice は変更された重複排除用ディスクストレージデバイスを表すオブジェクトを返します。

Example

C:\PS> Get-BEDeduplicationDiskStorageDevice "Device 0001" | Set-BEDeduplicationDiskStorageDevice -Paused $true

これらのコマンドは「Device 0001」という名前の重複排除用ディスクストレージデバイスを一時停止します。

Related Link

Get-BEDeduplicationDiskStorageDevice


Set-BEDifferentialBackupTask Help

Set-BEDifferentialBackupTask Cmdlet
Synopsis

Backup Exec のバックアップ定義に含まれる差分バックアップを修正します。

Syntax
Set-BEDifferentialBackupTask -BackupDefinition <BEBackupDefinition> [-Name] <String[]> [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-VerifyAsPartOfJob <Boolean>] [-EncryptionKey <BEEncryptionKey>] [-SqlPreConsistencyCheckMethod {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-ExchangeUseGrt <Boolean>] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>] [-RunJobOnlyIfPreCommandIsSuccessful <Boolean>] [-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>] [-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>] [-RunPostCommandAfterVerification <Boolean>] [-SqlContinueIfConsistencyCheckUnsuccessful <Boolean>] [-OracleSkipBackedUpArchivedLogFile <Boolean>] [-OracleDeleteBackedUpArchivedLogFile <Boolean>] [-OraclePerformBackupOffline <Boolean>] [-SharePointUseGrt <Boolean>] [-SqlUseChecksumOnBackup <Boolean>] [-SqlPostConsistencyCheck {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-SqlCreateDiskCopy <Boolean>] [-SqlUseSoftwareCompression <Boolean>] [-SqlDiskCopyPath <String>] [-TapeStorageEnableDirectCopyToTape <Boolean>] [-TapeStorageEnableWriteOnceReadManyMedia <Boolean>] [-TapeStorageRetensionMediaBeforeBackup <Boolean>] [-SubmitOnHold <Boolean>] [-DiskStorageKeepForHours <Int32>] [-TapeStorageEjectMediaAfterComplete <Boolean>] [-Storage <BEStorage>] [-JobName <String>] [-TapeStorageMediaSet <BEMediaSet>] [-TapeStorageExportMediaToVault <BEMediaVault>] [-TapeStorageExportMedia <Boolean>] [-BackupSetDescription <String>] [-EnableDirectAccessIfAvailable <Boolean>] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-PreCommand <String>] [-PrePostCommandSuccessfulIfReturnsZero <Boolean>] [-PostCommand <String>] [-TapeStorageCompressionMethod {None | SoftwareIfNoHardware | HardwareOnly | SoftwareOnly}] [-KeepJobQueuedFor <TimeSpan>] [-Schedule <BESchedule>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-IncludeJobLogWithEmailNotification <Boolean>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Set-BEDifferentialBackupTask -BackupJobDefault <BEBackupJobDefaults> [-Name] <String[]> [-EncryptionKey <BEEncryptionKey>] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-ExchangeUseGrt <Boolean>] [-SqlContinueIfConsistencyCheckUnsuccessful <Boolean>] [-SqlPreConsistencyCheckMethod {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-VerifyAsPartOfJob <Boolean>] [-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>] [-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>] [-RunPostCommandAfterVerification <Boolean>] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>] [-OracleSkipBackedUpArchivedLogFile <Boolean>] [-OracleDeleteBackedUpArchivedLogFile <Boolean>] [-OraclePerformBackupOffline <Boolean>] [-SharePointUseGrt <Boolean>] [-SqlUseChecksumOnBackup <Boolean>] [-SqlPostConsistencyCheck {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-SqlCreateDiskCopy <Boolean>] [-SqlUseSoftwareCompression <Boolean>] [-SqlDiskCopyPath <String>] [-RunJobOnlyIfPreCommandIsSuccessful <Boolean>] [-TapeStorageRetensionMediaBeforeBackup <Boolean>] [-TapeStorageEnableDirectCopyToTape <Boolean>] [-DiskStorageKeepForHours <Int32>] [-BackupSetDescription <String>] [-SubmitOnHold <Boolean>] [-TapeStorageEnableWriteOnceReadManyMedia <Boolean>] [-TapeStorageMediaSet <BEMediaSet>] [-Storage <BEStorage>] [-TapeStorageExportMedia <Boolean>] [-TapeStorageEjectMediaAfterComplete <Boolean>] [-TapeStorageExportMediaToVault <BEMediaVault>] [-EnableDirectAccessIfAvailable <Boolean>] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-PreCommand <String>] [-PrePostCommandSuccessfulIfReturnsZero <Boolean>] [-PostCommand <String>] [-TapeStorageCompressionMethod {None | SoftwareIfNoHardware | HardwareOnly | SoftwareOnly}] [-KeepJobQueuedFor <TimeSpan>] [-Schedule <BESchedule>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-IncludeJobLogWithEmailNotification <Boolean>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

この cmdlet は利用できなくなりました。 代わりに Set-BEBackupTask を使用します。

Backup Exec のバックアップ定義の差分バックアップを修正します。

新しいバックアップ定義または既存のバックアップ定義の差分バックアップを修正できます。 バックアップジョブのデフォルトに含まれる差分バックアップを修正することもできます。

新しいバックアップ定義に含まれる差分バックアップを修正するには、Set-BEDifferentialBackupTask と New-BEBackupDefinition を使用します。

既存のバックアップ定義に含まれる差分バックアップを修正するには、Set-BEDifferentialBackupTask と Get-BEBackupDefinition を使用します。

バックアップジョブのデフォルトに含まれる差分バックアップを修正するには、Set-BEDifferentialBackupTask と Get-BEBackupJobDefault を使用します。

バックアップ定義を作成または編集するときは、バックアップ定義を Save-BEBackupDefinition に渡し、変更内容をコミットする必要があります。

バックアップジョブのデフォルトを編集するときは、ジョブのデフォルトを Save-BEBackupJobDefault に渡し、変更内容をコミットする必要があります。

Parameters

-BackupDefinition <BEBackupDefinition>

変更するバックアップ定義を指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupJobDefault <BEBackupJobDefaults>

変更するバックアップジョブのデフォルトを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-JobName <String>

このタスクを表すジョブの名前を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Storage <BEStorage>

バックアップジョブに使用するストレージデバイスを指定します。 Get-BEStorage を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaSet <BEMediaSet>

メディアと関連付けるメディアセットを指定します。メディアはメディアセットの設定に基づいて上書きから保護されます。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。 Get-BEMediaSet を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMedia <Boolean>

ジョブの完了後にデバイスからメディアをエクスポートします。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMediaToVault <BEMediaVault>

ジョブの完了後にメディアを指定したボルトに論理的に移動します。Storage パラメータはテープベースのストレージデバイスに設定し、TapeStorageExportMedia は $true に設定する必要があります。Get-BEMediaVault を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEjectMediaAfterComplete <Boolean>

ジョブの完了後にストレージデバイスからメディアを取り出します。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableWriteOnceReadManyMedia <Boolean>

バックアップジョブに WORM (Write Once Read Many) メディアの使用を指定します。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableDirectCopyToTape <Boolean>

物理テープデバイスに仮想テープライブラリから直接データをコピーできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageRetensionMediaBeforeBackup <Boolean>

データを書き込む前にメディアのリテンションを行います。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskStorageKeepForHours <Int32>

メディアへの上書きを禁止し、このメディア上にデータを保存する時間を指定します。 Storage パラメータがディスクベースのストレージデバイスに設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SubmitOnHold <Boolean>

ジョブを保留状態でサブミットします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupSetDescription <String>

バックアップしたデータとその格納場所についての説明です。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Schedule <BESchedule>

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

予定開始時刻の経過後に、ジョブが未処理であると Backup Exec が判断し、そのジョブのスケジュール再設定が可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

予定開始時刻後にジョブの実行が続行されている場合、そのジョブのキャンセルが可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NotificationRecipientList <BENotificationRecipientObject[]>

ジョブが完了したときに通知を受け取る受信者を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IncludeJobLogWithEmailNotification <Boolean>

電子メールにジョブログを添付します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageCompressionMethod

使用するソフトウェアデータ圧縮またはハードウェアデータ圧縮の種類を指定します。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
None
SoftwareIfNoHardware
HardwareOnly
SoftwareOnly

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaAppendMethod

ジョブの開始時にメディアに上書きまたは追記します。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
Append
AppendOnly
Overwrite

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableDirectAccessIfAvailable <Boolean>

Agent for Windows から Storage パラメータで指定したデバイスにバックアップデータを直接送信できるようにします (デバイスがこの操作をサポートしている場合)。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreCommand <String>

バックアップジョブの前に実行するコマンドを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PostCommand <String>

バックアップジョブの後に実行するコマンドを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PrePostCommandSuccessfulIfReturnsZero <Boolean>

Backup Exec によってプリコマンドまたはポストコマンドの戻りコードを確認し、コマンドが正しく完了したかどうかを調べることができます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunJobOnlyIfPreCommandIsSuccessful <Boolean>

プリコマンドが正しく実行された場合にのみバックアップジョブを実行します。プリコマンドの実行に失敗した場合は、ジョブは実行されません。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>

プリコマンドが正しく実行された場合にのみポストコマンドを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>

ジョブが正しく実行されなかった場合でもポストコマンドを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandAfterVerification <Boolean>

バックアップジョブの検証を選択した場合、検証が完了した後にポストコマンドを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>

完了しなかったプリコマンドまたはポストコマンドをキャンセルするのに待つ時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunCommandLocation

プリコマンドとポストコマンドが実行される場所を指定します。

The valid values are:
OnEachAgentServer
OnBackupExecServer

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VerifyAsPartOfJob <Boolean>

バックアップジョブの完了時に自動的に検証操作を実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionType

バックアップジョブに使用する暗号化の種類を指定します。

The valid values are:
None
Software
Hardware
SoftwareIfNoHardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionKey <BEEncryptionKey>

使用する暗号化キーを指定します。 EncryptionType が None 以外の値に設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeUseGrt <Boolean>

インフォメーションストアのバックアップジョブから個々の項目をリストアできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlPreConsistencyCheckMethod

バックアップジョブを実行する前に行う一貫性チェックの種類を指定します。

The valid values are:
None
Physical
FullExcludingIndexes
FullIncludingIndexes

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlContinueIfConsistencyCheckUnsuccessful <Boolean>

一貫性チェックに失敗した場合でもバックアップジョブを続行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlPostConsistencyCheck

バックアップジョブを実行した後に行う一貫性チェックの種類を指定します。

The valid values are:
None
Physical
FullExcludingIndexes
FullIncludingIndexes

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlUseChecksumOnBackup <Boolean>

SQL 2005 以降の場合、バックアップする SQL データベースのデータにチェックサムを追加します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlCreateDiskCopy <Boolean>

バックアップする SQL データベースのコピーをディスク上に作成します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlDiskCopyPath <String>

バックアップする SQL データベースのディスク上に作成されるコピーのパスを指定します。CreateDiskCopy が $true に設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlUseSoftwareCompression <Boolean>

SQL 2008以降の場合、使用する圧縮設定を指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointUseGrt <Boolean>

データベースバックアップからの個々のドキュメント、イメージ、サイト、サブサイト、リスト、リストの項目のリストアを有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleDeleteBackedUpArchivedLogFile <Boolean>

バックアップ後にアーカイブログファイルを自動的に削除できます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleSkipBackedUpArchivedLogFile <Boolean>

以前にバックアップしたアーカイブログファイルを Backup Exec がスキップできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OraclePerformBackupOffline <Boolean>

バックアップジョブを開始する前に Backup Exec がデータベースをオフラインにすることを可能にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String[]>

修正する 1 つ以上の差分バックアップジョブの名前 (ワイルドカードを使用可能) を指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupDefinition

Backup Exec のバックアップ定義オブジェクトを Set-BEDifferentialBackupTask にパイプ処理できます。

BackupExec.Management.CLI.BEBackupJobDefaults

Backup Exec のバックアップジョブのデフォルトオブジェクトを Set-BEDifferentialBackupTask にパイプ処理できます。

Return Values
BackupExec.Management.CLI.BEBackupDefinition

修正されたバックアップ定義を示します。

BackupExec.Management.CLI.BEBackupJobDefaults

修正されたバックアップジョブのデフォルトを示します。

Examples

Example 1

C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Set-BEDifferentialBackupTask -Name "Differential 2" -Storage "Any disk storage" | Save-BEBackupDefinition

これらのコマンドは「Backup Definition 01」という名前のバックアップ定義に含まれる「Differential 2」という名前の差分パックアップのストレージを「Any disk storage」プールに設定します。

Example 2
C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Set-BEDifferentialBackupTask -Name * -Storage "Any disk storage" | Save-BEBackupDefinition

これらのコマンドは「Backup Definition 01」という名前のバックアップ定義に含まれるすべての差分パックアップのストレージを「Any disk storage」プールに設定します。

Example 3
C:\PS> Get-BEBackupJobDefault BackupToDisk | Set-BEDifferentialBackupTask -Name * -Storage "Any disk storage" | Save-BEBackupJobDefault

これらのコマンドはディスクへのバックアップジョブのデフォルトに含まれるすべての差分パックアップのストレージを「Any disk storage」プールに設定します。

Related Links

Set-BEBackupTask
New-BEBackupDefinition
Get-BEBackupDefinition
Get-BEBackupJobDefault
Save-BEBackupDefinition
Save-BEBackupJobDefault
Get-BEStorage
Get-BEMediaSet
Get-BEMediaVault
New-BESchedule


Set-BEDiskCartridgeDevice Help

Set-BEDiskCartridgeDevice Cmdlet
Synopsis

Backup Exec のディスクカートリッジデバイスのプロパティを設定します。

Syntax
Set-BEDiskCartridgeDevice -InputObject <BEDiskCartridgeDevice[]> [[-BackupExecServer] <BEBackupExecServer>] [-LowDiskSpaceInformationThresholdPercent <Int32>] [-BufferSizeBytes <Int32>] [-BlockSizeBytes <Int32>] [-LowDiskSpaceWarningThresholdPercent <Int32>] [-BufferedReadsWritesAutoDetectEnabled <Boolean>] [-LowDiskSpaceCriticalThresholdPercent <Int32>] [-Disabled <Boolean>] [-Description <String>] [-BlockAndBufferSizeAutoDetectEnabled <Boolean>] [-Paused <Boolean>] [-PreallocationIncrementBytes <Int64>] [-PreallocationEnabled <Boolean>] [-MaximumFileSizeBytes <Int64>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のディスクカートリッジデバイスのプロパティを設定します。

Parameters

-BackupExecServer <BEBackupExecServer>

CASO 環境でデバイスを接続する Backup Exec サーバーを指定します。

Required | false
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

ディスクカートリッジデバイスの説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Disabled <Boolean>

ディスクカートリッジデバイスを無効にするかどうかを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Paused <Boolean>

ディスクカートリッジデバイスを一時停止するかどうかを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MaximumFileSizeBytes <Int64>

ディスクストレージの最大ファイルサイズを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreallocationEnabled <Boolean>

事前割り当てを有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreallocationIncrementBytes <Int64>

ファイルサイズを増やすための容量を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BlockAndBufferSizeAutoDetectEnabled <Boolean>

ディスクストレージのブロックサイズとバッファサイズに適した設定を自動的に検出するかどうかを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BlockSizeBytes <Int32>

新しいメディアに書き込まれるデータのブロックサイズをバイトで指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BufferSizeBytes <Int32>

読み取りまたは書き込み要求でディスクカートリッジに送信されるデータ量を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LowDiskSpaceInformationThresholdPercent <Int32>

初回のディスク容量低下アラートの 1 番目のしきい値制限を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LowDiskSpaceWarningThresholdPercent <Int32>

2 回目のディスク容量低下アラートの 2 番目のしきい値制限を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LowDiskSpaceCriticalThresholdPercent <Int32>

初回のディスク容量低下アラートに関する 3 番目と最後のしきい値の制限を指定します。ディスク空き領域を増やすように促されています。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BufferedReadsWritesAutoDetectEnabled <Boolean>

このディスクの設定を自動的に検出しないように指定し、読み取りバッファと書き込みバッファの使用を有効にします。 読み取りバッファと書き込みバッファとは、大きなデータブロックの読み取りと書き込みです。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEDiskCartridgeDevice[]>

1 つ以上のディスクカートリッジデバイスオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEDiskCartridgeDevice

Backup Exec ディスクカートリッジデバイスオブジェクトを Set-BEDiskCartridgeDevice にパイプ処理することができます。

Return Value
BackupExec.Management.CLI.BEDiskCartridgeDevice

Set-BEDiskCartridgeDevice は変更されたディスクカートリッジデバイスを表すオブジェクトを返します。

Example

C:\PS> Get-BEDiskCartridgeDevice "Device 0001" | Set-BEDiskCartridgeDevice -Paused $true

これらのコマンドは「Device 0001」という名前のディスクカートリッジデバイスを一時停止します。

Related Link

Get-BEDiskCartridgeDevice


Set-BEDiskStorageDevice Help

Set-BEDiskStorageDevice Cmdlet
Synopsis

Backup Exec のディスクストレージデバイスのプロパティを設定します。

Syntax
Set-BEDiskStorageDevice -InputObject <BEDiskStorageDevice[]> [[-BackupExecServer] <BEBackupExecServer>] [-BufferSizeBytes <Int32>] [-DiskSpaceReserveBytes <Int64>] [-BlockSizeBytes <Int32>] [-VirtualWriteProtectionEnabled <Boolean>] [-BufferedReadsWritesAutoDetectEnabled <Boolean>] [-BlockAndBufferSizeAutoDetectEnabled <Boolean>] [-AllowedConcurrentWriteOperations <UInt32>] [-Disabled <Boolean>] [-Paused <Boolean>] [-PreallocationIncrementBytes <Int64>] [-Description <String>] [-LowDiskSpaceInformationThresholdPercent <Int32>] [-MaximumFileSizeBytes <Int64>] [-PreallocationEnabled <Boolean>] [-LowDiskSpaceWarningThresholdPercent <Int32>] [-LowDiskSpaceCriticalThresholdPercent <Int32>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のディスクストレージデバイスのプロパティを設定します。

Parameters

-BackupExecServer <BEBackupExecServer>

CASO 環境でデバイスを接続する Backup Exec サーバーを指定します。

Required | false
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

ディスクストレージデバイスの説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Disabled <Boolean>

ディスクストレージデバイスを無効にするかどうかを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Paused <Boolean>

ディスクストレージデバイスを一時停止するかどうかを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LowDiskSpaceInformationThresholdPercent <Int32>

初回のディスク容量低下アラートに関する最初のしきい値の制限を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LowDiskSpaceWarningThresholdPercent <Int32>

2 回目のディスク容量低下アラートに関する 2 番目のしきい値制限を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LowDiskSpaceCriticalThresholdPercent <Int32>

初回のディスク容量低下アラートに関する 3 番目かつ最後のしきい値制限を指定します。すぐにディスク容量を増やすように要求されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MaximumFileSizeBytes <Int64>

ディスクストレージの最大ファイルサイズを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreallocationEnabled <Boolean>

事前割り当てを有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreallocationIncrementBytes <Int64>

ファイルサイズを増やすための容量を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BlockSizeBytes <Int32>

新しいメディアに書き込まれるデータのブロックサイズをバイトで指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BufferSizeBytes <Int32>

読み取りまたは書き込み要求でディスクカートリッジに送信されるデータ量を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskSpaceReserveBytes <Int64>

Backup Exec 以外のアプリケーション用に空けてあるディスク領域を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualWriteProtectionEnabled <Boolean>

仮想書き込み保護を有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BlockAndBufferSizeAutoDetectEnabled <Boolean>

ディスクストレージのブロックサイズとバッファサイズに適した設定を自動的に検出するかどうかを指定します。これにより現在のセットのサイズが上書きされる場合があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AllowedConcurrentWriteOperations <UInt32>

ディスクへの書き込みの同時並行処理を許可します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BufferedReadsWritesAutoDetectEnabled <Boolean>

Backup Exec が自動的にこのディスクの設定を検出しないように指定し、このディスクストレージで読み取りバッファと書き込みバッファの使用を許可するように設定します。読み取りバッファと書き込みバッファとは、大きなデータブロックの読み取りと書き込みです。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEDiskStorageDevice[]>

1 つ以上のディスクストレージデバイスオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEDiskStorageDevice

Backup Exec ディスクストレージデバイスオブジェクトを Set-BEDiskStorageDevice にパイプ処理することができます。

Return Value
BackupExec.Management.CLI.BEDiskStorageDevice

Set-BEDiskStorageDevice は変更されたディスクストレージデバイスを表すオブジェクトを返します。

Example

C:\PS> Get-BEDiskStorageDevice "Device 0001" | Set-BEDiskStorageDevice -Paused $true

これらのコマンドは「Device 0001」という名前のディスクストレージデバイスを一時停止します。

Related Link

Get-BEDiskStorageDevice


Set-BEDuplicateStageBackupTask Help

Set-BEDuplicateStageBackupTask Cmdlet
Synopsis

Backup Exec のバックアップ定義の複製ステージを修正します。

Syntax
Set-BEDuplicateStageBackupTask [-Name] <String[]> [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-IncludeJobLogWithEmailNotification <Boolean>] [-KeepJobQueuedFor <TimeSpan>] [-DiskStorageKeepForHours <Int32>] [-SubmitOnHold <Boolean>] [-BackupSetDescription <String>] [-EncryptionKey <BEEncryptionKey>] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-VerifyAsPartOfJob <Boolean>] [-TapeStorageEnabledHardwareCompression <Boolean>] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-TapeStorageRetensionMediaBeforeBackup <Boolean>] [-SourceDuplicate <String>] [-JobName <String>] [-Schedule <BESchedule>] [-ImmediatelyAfterDuplicate <String>] [-SourceBackup {AllBackups | MostRecentFullBackup | SpecificSourceBackups}] [-SpecificSourceBackup <String[]>] [-ImmediatelyAfterBackup <String>] [-TapeStorageEjectMediaAfterComplete <Boolean>] [-TapeStorageEnableWriteOnceReadManyMedia <Boolean>] [-TapeStorageEnableDirectCopyToTape <Boolean>] [-TapeStorageExportMediaToVault <BEMediaVault>] [-TapeStorageMediaSet <BEMediaSet>] [-Storage <BEStorage>] [-TapeStorageExportMedia <Boolean>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Set-BEDuplicateStageBackupTask -BackupDefinition <BEBackupDefinition> [-Name] <String[]> [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-IncludeJobLogWithEmailNotification <Boolean>] [-KeepJobQueuedFor <TimeSpan>] [-DiskStorageKeepForHours <Int32>] [-SubmitOnHold <Boolean>] [-BackupSetDescription <String>] [-EncryptionKey <BEEncryptionKey>] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-VerifyAsPartOfJob <Boolean>] [-TapeStorageEnabledHardwareCompression <Boolean>] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-TapeStorageRetensionMediaBeforeBackup <Boolean>] [-SourceDuplicate <String>] [-JobName <String>] [-Schedule <BESchedule>] [-ImmediatelyAfterDuplicate <String>] [-SourceBackup {AllBackups | MostRecentFullBackup | SpecificSourceBackups}] [-SpecificSourceBackup <String[]>] [-ImmediatelyAfterBackup <String>] [-TapeStorageEjectMediaAfterComplete <Boolean>] [-TapeStorageEnableWriteOnceReadManyMedia <Boolean>] [-TapeStorageEnableDirectCopyToTape <Boolean>] [-TapeStorageExportMediaToVault <BEMediaVault>] [-TapeStorageMediaSet <BEMediaSet>] [-Storage <BEStorage>] [-TapeStorageExportMedia <Boolean>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Set-BEDuplicateStageBackupTask -SyntheticBackupDefinition <BESyntheticBackupDefinition> [-Name] <String[]> [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-IncludeJobLogWithEmailNotification <Boolean>] [-KeepJobQueuedFor <TimeSpan>] [-DiskStorageKeepForHours <Int32>] [-SubmitOnHold <Boolean>] [-BackupSetDescription <String>] [-EncryptionKey <BEEncryptionKey>] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-VerifyAsPartOfJob <Boolean>] [-TapeStorageEnabledHardwareCompression <Boolean>] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-TapeStorageRetensionMediaBeforeBackup <Boolean>] [-SourceDuplicate <String>] [-JobName <String>] [-Schedule <BESchedule>] [-ImmediatelyAfterDuplicate <String>] [-SourceBackup {AllBackups | MostRecentFullBackup | SpecificSourceBackups}] [-SpecificSourceBackup <String[]>] [-ImmediatelyAfterBackup <String>] [-TapeStorageEjectMediaAfterComplete <Boolean>] [-TapeStorageEnableWriteOnceReadManyMedia <Boolean>] [-TapeStorageEnableDirectCopyToTape <Boolean>] [-TapeStorageExportMediaToVault <BEMediaVault>] [-TapeStorageMediaSet <BEMediaSet>] [-Storage <BEStorage>] [-TapeStorageExportMedia <Boolean>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のバックアップ定義の複製ステージを修正します。

新しいバックアップ定義または既存のバックアップ定義の複製ステージを修正できます。

新しいバックアップ定義の複製ステージを修正するには、Set-BEDuplicateStageBackupTask と New-BEBackupDefinition を使用します。

既存のバックアップ定義の複製ステージを修正するには、Set-BEDuplicateStageBackupTask と Get-BEBackupDefinition を使用します。

バックアップ定義を作成または編集する場合、そのバックアップ定義を Save-BEBackupDefinition に渡して変更をコミットする必要があります。

Parameters

-BackupDefinition <BEBackupDefinition>

変更するバックアップ定義を指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-SyntheticBackupDefinition <BESyntheticBackupDefinition>

変更する合成バックアップ定義を指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-SourceBackup

複製するバックアップ定義のソースバックアップを指定します。

The valid values are:
AllBackups
MostRecentFullBackup
SpecificSourceBackups

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SpecificSourceBackup <String[]>

バックアップ定義で複製するための 1 つまたは複数のバックアップジョブを名前 (文字列) を使用して指定します。複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。Source パラメータは SpecificBackups に指定する必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ImmediatelyAfterBackup <String>

バックアップ定義で複製するバックアップジョブの名前を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ImmediatelyAfterDuplicate <String>

バックアップ定義で複製する複製バックアップジョブの名前を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SourceDuplicate <String>

バックアップ定義の、複製する複製バックアップジョブの名前を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-JobName <String>

このタスクを表すジョブの名前を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Schedule <BESchedule>

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Storage <BEStorage>

バックアップジョブに使用するストレージデバイスを指定します。 Get-BEStorage を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaSet <BEMediaSet>

メディアと関連付けるメディアセットを指定します。メディアはメディアセットの設定に基づいて上書きから保護されます。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。 Get-BEMediaSet を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMedia <Boolean>

ジョブの完了後にデバイスからメディアをエクスポートします。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMediaToVault <BEMediaVault>

ジョブの完了後にメディアを指定したボルトに論理的に移動します。Storage パラメータはテープベースのストレージデバイスに設定し、TapeStorageExportMedia は $true に設定する必要があります。Get-BEMediaVault を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEjectMediaAfterComplete <Boolean>

ジョブの完了後にストレージデバイスからメディアを取り出します。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableWriteOnceReadManyMedia <Boolean>

バックアップジョブに WORM (Write Once Read Many) メディアの使用を指定します。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableDirectCopyToTape <Boolean>

物理テープデバイスに仮想テープライブラリから直接データをコピーできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageRetensionMediaBeforeBackup <Boolean>

データを書き込む前にメディアのリテンションを行います。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskStorageKeepForHours <Int32>

メディアへの上書きを禁止し、このメディア上にデータを保存する時間を指定します。 Storage パラメータがディスクベースのストレージデバイスに設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SubmitOnHold <Boolean>

ジョブを保留状態でサブミットします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupSetDescription <String>

バックアップしたデータとその格納場所についての説明です。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

予定開始時刻の経過後に、ジョブが未処理であると Backup Exec が判断し、そのジョブのスケジュール再設定が可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

予定開始時刻後にジョブの実行が続行されている場合、そのジョブのキャンセルが可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NotificationRecipientList <BENotificationRecipientObject[]>

ジョブが完了したときに通知を受け取る受信者を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IncludeJobLogWithEmailNotification <Boolean>

電子メールにジョブログを添付します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VerifyAsPartOfJob <Boolean>

バックアップジョブの完了時に自動的に検証操作を実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnabledHardwareCompression <Boolean>

ハードウェア圧縮を有効にします。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaAppendMethod

ジョブの開始時にメディアに上書きまたは追記します。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
Append
AppendOnly
Overwrite

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionType

バックアップジョブに使用する暗号化の種類を指定します。

The valid values are:
None
Software
Hardware
SoftwareIfNoHardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionKey <BEEncryptionKey>

使用する暗号化キーを指定します。 EncryptionType が None 以外の値に設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String[]>

修正する 1 つ以上の複製ステージの名前 (ワイルドカードを使用可能) を指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupDefinition

Backup Exec のバックアップ定義オブジェクトを Set-BEDuplicateStageBackupTask にパイプ処理できます。

Return Values
BackupExec.Management.CLI.BEBackupDefinition

修正されたバックアップ定義を示します。

BackupExec.Management.CLI.BEBackupJobDefaults

修正されたバックアップジョブのデフォルトを示します。

Examples

Example 1

C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Set-BEDuplicateStageBackupTask -Name "Duplicate 2" -Storage "Any disk storage" | Save-BEBackupDefinition

これらのコマンドは「Backup Definition 01」という名前のバックアップ定義に含まれる「Duplicate 2」という名前の複製ステージのストレージを「Any disk storage」プールに設定します。

Example 2
C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Set-BEDuplicateStageBackupTask -Name * -Storage "Any disk storage" | Save-BEBackupDefinition

これらのコマンドは「Backup Definition 01」という名前のバックアップ定義に含まれるすべての複製ステージのストレージを「Any disk storage」プールに設定します。

Related Links


Set-BEEjectUtilityJob Help

Set-BEEjectUtilityJob Cmdlet
Synopsis

Backup Exec メディアの取り出しジョブのプロパティを設定します。

Syntax
Set-BEEjectUtilityJob -InputObject <BEEjectUtilityJob[]> [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-Schedule <BESchedule>] [-KeepJobQueuedFor <TimeSpan>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec メディアの取り出しジョブのプロパティを設定します。

Parameters

-Schedule <BESchedule>

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

予定開始時刻の経過後に、ジョブが未処理であると Backup Exec が判断し、そのジョブのスケジュール再設定が可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

予定開始時刻後にジョブの実行が続行されている場合、そのジョブのキャンセルが可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEEjectUtilityJob[]>

1 つ以上のメディアの取り出しジョブオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEEjectUtilityJob

Backup Exec メディアの取り出しジョブオブジェクトを Set-BEEjectUtilityJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEEjectUtilityJob

Set-BEEjectUtilityJob は変更された Backup Exec メディアの取り出しジョブを表すオブジェクトを返します。

Example

C:\PS> $Schedule = New-BESchedule -RunNow
C:\PS> Get-BEEjectUtilityJob -Name "EjectJob" | Set-BEEjectUtilityJob -Schedule $Schedule

これらのコマンドは「EjectJob」という名前のメディアの取り出しジョブのスケジュールを今すぐ実行するように設定します。

Related Links


Set-BEEraseUtilityJob Help

Set-BEEraseUtilityJob Cmdlet
Synopsis

Backup Exec 消去操作ジョブのプロパティを設定します。

Syntax
Set-BEEraseUtilityJob -InputObject <BEEraseUtilityJob[]> [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-Schedule <BESchedule>] [-KeepJobQueuedFor <TimeSpan>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec 消去操作ジョブのプロパティを設定します。

Parameters

-Schedule <BESchedule>

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

予定開始時刻の経過後に、ジョブが未処理であると Backup Exec が判断し、そのジョブのスケジュール再設定が可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

予定開始時刻後にジョブの実行が続行されている場合、そのジョブのキャンセルが可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEEraseUtilityJob[]>

1 つ以上の消去操作ジョブオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEEraseUtilityJob

Backup Exec 消去操作ジョブを Set-BEEraseUtilityJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEEraseUtilityJob

Set-BEEraseUtilityJob は変更された Backup Exec 消去操作ジョブを表すオブジェクトを返します。

Example

C:\PS> $Schedule = New-BESchedule -RunNow
C:\PS> Get-BEEraseUtilityJob -Name "EraseUtilityJob" | Set-BEEraseUtilityJob -Schedule $Schedule

これらのコマンドは「EraseUtilityJob」という完全消去操作ジョブのスケジュールを今すぐ実行するように設定します。

Related Links


Set-BEErrorHandlingRule Help

Set-BEErrorHandlingRule Cmdlet
Synopsis

Backup Exec エラー処理方法のプロパティを設定します。

Syntax
Set-BEErrorHandlingRule -InputObject <BEErrorHandlingRule[]> [-Note <String>] [-RetryIntervalMinutes <Int32>] [-Enabled <Boolean>] [-RetryJobEnabled <Boolean>] [-MaximumRetries <Int32>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec エラー処理方法のプロパティを設定します。

Parameters

-Enabled <Boolean>

エラー処理方法を有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RetryJobEnabled <Boolean>

Backup Exec がジョブを再試行することを許可します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MaximumRetries <Int32>

ジョブを再試行する回数を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RetryIntervalMinutes <Int32>

ジョブを再試行する間隔を分単位で指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Note <String>

このエラー処理方法についてのその他の情報を表示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEErrorHandlingRule[]>

1 つ以上のエラー処理ルールオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEErrorHandlingRule

Backup Exec エラー処理ルールオブジェクトを Set-BEErrorHandlingRule にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEErrorHandlingRule

Set-BEErrorHandlingRule は、変更された Backup Exec エラー処理方法を表すオブジェクトを返します。

Example

C:\PS> Get-BEErrorHandlingRule "Job Cancellation" | Set-BEErrorHandlingRule -Enabled $true

これらのコマンドは「ジョブのキャンセル」という名前のエラー処理方法を有効にします。

Related Link

Get-BEErrorHandlingRule


Set-BEExportExpiredUtilityJob Help

Set-BEExportExpiredUtilityJob Cmdlet
Synopsis

Backup Exec の期限切れメディアのエクスポートジョブのプロパティを設定します。

Syntax
Set-BEExportExpiredUtilityJob -InputObject <BEExportExpiredUtilityJob[]> [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-Schedule <BESchedule>] [-KeepJobQueuedFor <TimeSpan>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec の期限切れメディアのエクスポートジョブのプロパティを設定します。

Parameters

-Schedule <BESchedule>

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

予定開始時刻の経過後に、ジョブが未処理であると Backup Exec が判断し、そのジョブのスケジュール再設定が可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

予定開始時刻後にジョブの実行が続行されている場合、そのジョブのキャンセルが可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEExportExpiredUtilityJob[]>

1 つ以上の期限切れメディアのエクスポートジョブのオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEExportExpiredUtilityJob

Backup Exec 期限切れメディアのエクスポートジョブオブジェクトを Set-BEExportExpiredUtilityJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEExportExpiredUtilityJob

Set-BEExportExpiredUtilityJob は、Backup Exec の期限切れメディアのエクスポートジョブを表すオブジェクトを返します。

Example

C:\PS> $Schedule = New-BESchedule -RunNow
C:\PS> Get-BEExportExpiredUtilityJob -Name "ExportExpiredJob" | Set-BEExportExpiredUtilityJob -Schedule $Schedule

これらのコマンドは「ExportExpiredJob」という名前の期限切れメディアのエクスポートジョブのスケジュールを今すぐ実行するように設定します。

Related Links


Set-BEExportUtilityJob Help

Set-BEExportUtilityJob Cmdlet
Synopsis

Backup Exec メディアのエクスポートジョブのプロパティを設定します。

Syntax
Set-BEExportUtilityJob -InputObject <BEExportUtilityJob[]> [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-Schedule <BESchedule>] [-KeepJobQueuedFor <TimeSpan>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec メディアのエクスポートジョブのプロパティを設定します。

Parameters

-Schedule <BESchedule>

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

予定開始時刻の経過後に、ジョブが未処理であると Backup Exec が判断し、そのジョブのスケジュール再設定が可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

予定開始時刻後にジョブの実行が続行されている場合、そのジョブのキャンセルが可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEExportUtilityJob[]>

1 つ以上のメディアのエクスポートジョブオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEExportUtilityJob

Backup Exec メディアのエクスポートジョブオブジェクトを Set-BEExportUtilityJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEExportUtilityJob

Set-BEExportUtilityJob は、変更された Backup Exec メディアのエクスポートジョブを表すオブジェクトを返します。

Example

C:\PS> $Schedule = New-BESchedule -RunNow
C:\PS> Get-BEExportUtilityJob -Name "ExportJob" | Set-BEExportUtilityJob -Schedule $Schedule

これらのコマンドは「ExportJob」という名前のメディアのエクスポートジョブのスケジュールを今すぐ実行するように設定します。

Related Links


Set-BEFullBackupTask Help

Set-BEFullBackupTask Cmdlet
Synopsis

Backup Exec のバックアップ定義の完全バックアップを修正します。

Syntax
Set-BEFullBackupTask -BackupDefinition <BEBackupDefinition> [-Name] <String[]> [-SqlPreConsistencyCheckMethod {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-ExchangeUseGrt <Boolean>] [-EncryptionKey <BEEncryptionKey>] [-SqlUseChecksumOnBackup <Boolean>] [-SqlPostConsistencyCheck {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-SqlContinueIfConsistencyCheckUnsuccessful <Boolean>] [-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>] [-RunPostCommandAfterVerification <Boolean>] [-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-VerifyAsPartOfJob <Boolean>] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-SqlCreateDiskCopy <Boolean>] [-SqlBackupType {Full | FullCopy}] [-ExchangeBackupType {Full | FullCopy}] [-DeleteSelectedFilesAfterSuccessfulBackup {Never | FilesOnly | FilesAndFolders}] [-SharePointBackupType {Full | FullCopy}] [-SharePointUseGrt <Boolean>] [-SqlUseSoftwareCompression <Boolean>] [-SqlDiskCopyPath <String>] [-OraclePerformBackupOffline <Boolean>] [-OracleSkipBackedUpArchivedLogFile <Boolean>] [-OracleDeleteBackedUpArchivedLogFile <Boolean>] [-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>] [-TapeStorageEnableDirectCopyToTape <Boolean>] [-TapeStorageEnableWriteOnceReadManyMedia <Boolean>] [-TapeStorageEjectMediaAfterComplete <Boolean>] [-SubmitOnHold <Boolean>] [-DiskStorageKeepForHours <Int32>] [-TapeStorageRetensionMediaBeforeBackup <Boolean>] [-Storage <BEStorage>] [-JobName <String>] [-TapeStorageExportMediaToVault <BEMediaVault>] [-TapeStorageExportMedia <Boolean>] [-TapeStorageMediaSet <BEMediaSet>] [-BackupSetDescription <String>] [-PreCommand <String>] [-EnableDirectAccessIfAvailable <Boolean>] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-RunJobOnlyIfPreCommandIsSuccessful <Boolean>] [-PrePostCommandSuccessfulIfReturnsZero <Boolean>] [-PostCommand <String>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-KeepJobQueuedFor <TimeSpan>] [-Schedule <BESchedule>] [-IncludeJobLogWithEmailNotification <Boolean>] [-TapeStorageCompressionMethod {None | SoftwareIfNoHardware | HardwareOnly | SoftwareOnly}] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [-Force <SwitchParameter>] [<CommonParameters>]

Set-BEFullBackupTask -BackupJobDefault <BEBackupJobDefaults> [-Name] <String[]> [-SqlPreConsistencyCheckMethod {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-ExchangeUseGrt <Boolean>] [-EncryptionKey <BEEncryptionKey>] [-SqlUseChecksumOnBackup <Boolean>] [-SqlPostConsistencyCheck {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-SqlContinueIfConsistencyCheckUnsuccessful <Boolean>] [-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>] [-RunPostCommandAfterVerification <Boolean>] [-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-VerifyAsPartOfJob <Boolean>] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-SqlBackupType {Full | FullCopy}] [-ExchangeBackupType {Full | FullCopy}] [-OraclePerformBackupOffline <Boolean>] [-SharePointBackupType {Full | FullCopy}] [-SqlUseSoftwareCompression <Boolean>] [-SqlDiskCopyPath <String>] [-SqlCreateDiskCopy <Boolean>] [-OracleSkipBackedUpArchivedLogFile <Boolean>] [-OracleDeleteBackedUpArchivedLogFile <Boolean>] [-SharePointUseGrt <Boolean>] [-DiskStorageKeepForHours <Int32>] [-TapeStorageRetensionMediaBeforeBackup <Boolean>] [-TapeStorageEnableDirectCopyToTape <Boolean>] [-Schedule <BESchedule>] [-BackupSetDescription <String>] [-SubmitOnHold <Boolean>] [-TapeStorageExportMedia <Boolean>] [-TapeStorageMediaSet <BEMediaSet>] [-Storage <BEStorage>] [-TapeStorageEnableWriteOnceReadManyMedia <Boolean>] [-TapeStorageEjectMediaAfterComplete <Boolean>] [-TapeStorageExportMediaToVault <BEMediaVault>] [-PostCommand <String>] [-PreCommand <String>] [-EnableDirectAccessIfAvailable <Boolean>] [-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>] [-RunJobOnlyIfPreCommandIsSuccessful <Boolean>] [-PrePostCommandSuccessfulIfReturnsZero <Boolean>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-KeepJobQueuedFor <TimeSpan>] [-TapeStorageCompressionMethod {None | SoftwareIfNoHardware | HardwareOnly | SoftwareOnly}] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-IncludeJobLogWithEmailNotification <Boolean>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のバックアップ定義の完全バックアップを修正します。

新しいバックアップ定義または既存のバックアップ定義の完全バックアップを修正できます。 バックアップジョブのデフォルトの完全バックアップを修正することもできます。

新しいバックアップ定義の完全バックアップを修正するには、Set-BEFullBackupTask と New-BEBackupDefinition を使用します。

既存のバックアップ定義の完全バックアップを修正するには、Set-BEFullBackupTask と Get-BEBackupDefinition を使用します。

バックアップジョブのデフォルトの完全バックアップを修正するには、Set-BEFullBackupTask と Get-BEBackupJobDefault を使用します。

バックアップ定義を作成または編集する場合、そのバックアップ定義を Save-BEBackupDefinition に渡して変更をコミットする必要があります。

バックアップジョブのデフォルトを編集する場合、そのバックアップジョブのデフォルトを Save-BEBackupJobDefault に渡して変更をコミットする必要があります。

Parameters

-BackupDefinition <BEBackupDefinition>

変更するバックアップ定義を指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupJobDefault <BEBackupJobDefaults>

変更するバックアップジョブのデフォルトを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-JobName <String>

このタスクを表すジョブの名前を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Storage <BEStorage>

バックアップジョブに使用するストレージデバイスを指定します。 Get-BEStorage を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaSet <BEMediaSet>

メディアと関連付けるメディアセットを指定します。メディアはメディアセットの設定に基づいて上書きから保護されます。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。 Get-BEMediaSet を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMedia <Boolean>

ジョブの完了後にデバイスからメディアをエクスポートします。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMediaToVault <BEMediaVault>

ジョブの完了後にメディアを指定したボルトに論理的に移動します。Storage パラメータはテープベースのストレージデバイスに設定し、TapeStorageExportMedia は $true に設定する必要があります。Get-BEMediaVault を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEjectMediaAfterComplete <Boolean>

ジョブの完了後にストレージデバイスからメディアを取り出します。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableWriteOnceReadManyMedia <Boolean>

バックアップジョブに WORM (Write Once Read Many) メディアの使用を指定します。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableDirectCopyToTape <Boolean>

物理テープデバイスに仮想テープライブラリから直接データをコピーできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageRetensionMediaBeforeBackup <Boolean>

データを書き込む前にメディアのリテンションを行います。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskStorageKeepForHours <Int32>

メディアへの上書きを禁止し、このメディア上にデータを保存する時間を指定します。 Storage パラメータがディスクベースのストレージデバイスに設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SubmitOnHold <Boolean>

ジョブを保留状態でサブミットします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupSetDescription <String>

バックアップしたデータとその格納場所についての説明です。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Schedule <BESchedule>

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

予定開始時刻の経過後に、ジョブが未処理であると Backup Exec が判断し、そのジョブのスケジュール再設定が可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

予定開始時刻後にジョブの実行が続行されている場合、そのジョブのキャンセルが可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NotificationRecipientList <BENotificationRecipientObject[]>

ジョブが完了したときに通知を受け取る受信者を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IncludeJobLogWithEmailNotification <Boolean>

電子メールにジョブログを添付します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageCompressionMethod

使用するソフトウェアデータ圧縮またはハードウェアデータ圧縮の種類を指定します。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
None
SoftwareIfNoHardware
HardwareOnly
SoftwareOnly

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaAppendMethod

ジョブの開始時にメディアに上書きまたは追記します。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
Append
AppendOnly
Overwrite

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableDirectAccessIfAvailable <Boolean>

Agent for Windows から Storage パラメータで指定したデバイスにバックアップデータを直接送信できるようにします (デバイスがこの操作をサポートしている場合)。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreCommand <String>

バックアップジョブの前に実行するコマンドを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PostCommand <String>

バックアップジョブの後に実行するコマンドを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PrePostCommandSuccessfulIfReturnsZero <Boolean>

Backup Exec によってプリコマンドまたはポストコマンドの戻りコードを確認し、コマンドが正しく完了したかどうかを調べることができます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunJobOnlyIfPreCommandIsSuccessful <Boolean>

プリコマンドが正しく実行された場合にのみバックアップジョブを実行します。プリコマンドの実行に失敗した場合は、ジョブは実行されません。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>

プリコマンドが正しく実行された場合にのみポストコマンドを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>

ジョブが正しく実行されなかった場合でもポストコマンドを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandAfterVerification <Boolean>

バックアップジョブの検証を選択した場合、検証が完了した後にポストコマンドを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>

完了しなかったプリコマンドまたはポストコマンドをキャンセルするのに待つ時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunCommandLocation

プリコマンドとポストコマンドが実行される場所を指定します。

The valid values are:
OnEachAgentServer
OnBackupExecServer

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VerifyAsPartOfJob <Boolean>

バックアップジョブの完了時に自動的に検証操作を実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionType

バックアップジョブに使用する暗号化の種類を指定します。

The valid values are:
None
Software
Hardware
SoftwareIfNoHardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionKey <BEEncryptionKey>

使用する暗号化キーを指定します。 EncryptionType が None 以外の値に設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeUseGrt <Boolean>

インフォメーションストアのバックアップジョブから個々の項目をリストアできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlPreConsistencyCheckMethod

バックアップジョブを実行する前に行う一貫性チェックの種類を指定します。

The valid values are:
None
Physical
FullExcludingIndexes
FullIncludingIndexes

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlContinueIfConsistencyCheckUnsuccessful <Boolean>

一貫性チェックに失敗した場合でもバックアップジョブを続行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlPostConsistencyCheck

バックアップジョブを実行した後に行う一貫性チェックの種類を指定します。

The valid values are:
None
Physical
FullExcludingIndexes
FullIncludingIndexes

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlUseChecksumOnBackup <Boolean>

SQL 2005 以降の場合、バックアップする SQL データベースのデータにチェックサムを追加します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlCreateDiskCopy <Boolean>

バックアップする SQL データベースのコピーをディスク上に作成します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlDiskCopyPath <String>

バックアップする SQL データベースのディスク上に作成されるコピーのパスを指定します。CreateDiskCopy が $true に設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlUseSoftwareCompression <Boolean>

SQL 2008以降の場合、使用する圧縮設定を指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointUseGrt <Boolean>

データベースバックアップからの個々のドキュメント、イメージ、サイト、サブサイト、リスト、リストの項目のリストアを有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleDeleteBackedUpArchivedLogFile <Boolean>

バックアップ後にアーカイブログファイルを自動的に削除できます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleSkipBackedUpArchivedLogFile <Boolean>

以前にバックアップしたアーカイブログファイルを Backup Exec がスキップできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OraclePerformBackupOffline <Boolean>

バックアップジョブを開始する前に Backup Exec がデータベースをオフラインにすることを可能にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DeleteSelectedFilesAfterSuccessfulBackup

選択したデータをバックアップし、メディアの検証を行った後、ボリュームからデータを削除します。この操作でファイルを削除してデータを回復するにはリストアを実行する必要があるため、このオプションを有効にした場合は Force パラメータを指定する必要があります。

The valid values are:
Never
FilesOnly
FilesAndFolders

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeBackupType

Microsoft Exchange の選択項目のためにジョブが作成するバックアップの種類を指定します。

The valid values are:
Full
FullCopy

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlBackupType

Microsoft Exchange Server の選択項目のために作成するバックアップジョブの種類を指定します。

The valid values are:
Full
FullCopy

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointBackupType

Microsoft SharePoint を選択した場合に、どの種類のバックアップジョブを作成するかを指定します。

The valid values are:
Full
FullCopy

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String[]>

修正する 1 つ以上の完全バックアップジョブの名前 (ワイルドカードを使用可能) を指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Force <SwitchParameter>

DeleteSelectedFilesAfterSuccessfulBackup パラメータによってデータが失われ、使用を続ける必要があることを確認します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupDefinition

Backup Exec のバックアップ定義オブジェクトを Set-BEFullBackupTask にパイプ処理できます。

BackupExec.Management.CLI.BEBackupJobDefaults

Backup Exec のバックアップジョブのデフォルトオブジェクトを Set-BEFullBackupTask にパイプ処理できます。

Return Values
BackupExec.Management.CLI.BEBackupDefinition

修正されたバックアップ定義を示します。

BackupExec.Management.CLI.BEBackupJobDefaults

修正されたバックアップジョブのデフォルトを示します。

Examples

Example 1

C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Set-BEFullBackupTask -Name "Full 2" -Storage "Any disk storage" | Save-BEBackupDefinition

これらのコマンドは「Backup Definition 01」という名前のバックアップ定義に含まれる「Full 2」という名前の完全パックアップのストレージを「Any disk storage」プールに設定します。

Example 2
C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Set-BEFullBackupTask -Name * -Storage "Any disk storage" | Save-BEBackupDefinition

これらのコマンドは「Backup Definition 01」という名前のバックアップ定義に含まれるすべての完全パックアップのストレージを「Any disk storage」プールに設定します。

Example 3
C:\PS> Get-BEBackupJobDefault BackupToDisk | Set-BEFullBackupTask -Name * -Storage "Any disk storage" | Save-BEBackupJobDefault

これらのコマンドはディスクへのバックアップジョブのデフォルトに含まれるすべての完全パックアップのストレージを「Any disk storage」プールに設定します。

Related Links

New-BEBackupDefinition
Get-BEBackupDefinition
Get-BEBackupJobDefault
Save-BEBackupDefinition
Save-BEBackupJobDefault
Get-BEStorage
Get-BEMediaSet
Get-BEMediaVault
New-BESchedule


Set-BEImportUtilityJob Help

Set-BEImportUtilityJob Cmdlet
Synopsis

Backup Exec メディアのインポートジョブのプロパティを設定します。

Syntax
Set-BEImportUtilityJob -InputObject <BEImportUtilityJob[]> [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-Schedule <BESchedule>] [-KeepJobQueuedFor <TimeSpan>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec メディアのインポートジョブのプロパティを設定します。

Parameters

-Schedule <BESchedule>

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

予定開始時刻の経過後に、ジョブが未処理であると Backup Exec が判断し、そのジョブのスケジュール再設定が可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

予定開始時刻後にジョブの実行が続行されている場合、そのジョブのキャンセルが可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEImportUtilityJob[]>

1 つ以上のメディアのインポートジョブオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEImportUtilityJob

Backup Exec メディアのインポートジョブオブジェクトを Set-BEImportUtilityJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEImportUtilityJob

Set-BEImportUtilityJob は、変更された Backup Exec メディアのインポートジョブを表すオブジェクトを返します。

Example

C:\PS> $Schedule = New-BESchedule -RunNow
C:\PS> Get-BEImportUtilityJob -Name "ImportJob" | Set-BEImportUtilityJob -Schedule $Schedule

これらのコマンドは「ImportJob」という名前のメディアのインポートジョブのスケジュールを今すぐ実行するように設定します。

Related Links


Set-BEIncrementalBackupTask Help

Set-BEIncrementalBackupTask Cmdlet
Synopsis

Backup Exec のバックアップ定義の増分バックアップを修正します。

Syntax
Set-BEIncrementalBackupTask -BackupDefinition <BEBackupDefinition> [-Name] <String[]> [-ExchangeUseGrt <Boolean>] [-EncryptionKey <BEEncryptionKey>] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-SqlPostConsistencyCheck {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-SqlContinueIfConsistencyCheckUnsuccessful <Boolean>] [-SqlPreConsistencyCheckMethod {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-RunPostCommandAfterVerification <Boolean>] [-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>] [-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>] [-VerifyAsPartOfJob <Boolean>] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>] [-SqlIncrementalBackupMethod {Full | FullCopy | Automatic | Log | LogNoTruncate | Incremental | Differential | DifferentialBlockLevel | DatabaseSnapshot}] [-OraclePerformBackupOffline <Boolean>] [-OracleSkipBackedUpArchivedLogFile <Boolean>] [-NdmpBackupMethod <Int32>] [-SqlDiskCopyPath <String>] [-SqlCreateDiskCopy <Boolean>] [-SqlUseChecksumOnBackup <Boolean>] [-OracleDeleteBackedUpArchivedLogFile <Boolean>] [-SharePointUseGrt <Boolean>] [-SqlUseSoftwareCompression <Boolean>] [-TapeStorageRetensionMediaBeforeBackup <Boolean>] [-TapeStorageEnableDirectCopyToTape <Boolean>] [-TapeStorageEnableWriteOnceReadManyMedia <Boolean>] [-BackupSetDescription <String>] [-SubmitOnHold <Boolean>] [-DiskStorageKeepForHours <Int32>] [-TapeStorageMediaSet <BEMediaSet>] [-Storage <BEStorage>] [-JobName <String>] [-TapeStorageEjectMediaAfterComplete <Boolean>] [-TapeStorageExportMediaToVault <BEMediaVault>] [-TapeStorageExportMedia <Boolean>] [-PreCommand <String>] [-EnableDirectAccessIfAvailable <Boolean>] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-RunJobOnlyIfPreCommandIsSuccessful <Boolean>] [-PrePostCommandSuccessfulIfReturnsZero <Boolean>] [-PostCommand <String>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-KeepJobQueuedFor <TimeSpan>] [-Schedule <BESchedule>] [-IncludeJobLogWithEmailNotification <Boolean>] [-TapeStorageCompressionMethod {None | SoftwareIfNoHardware | HardwareOnly | SoftwareOnly}] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Set-BEIncrementalBackupTask -BackupJobDefault <BEBackupJobDefaults> [-Name] <String[]> [-ExchangeUseGrt <Boolean>] [-EncryptionKey <BEEncryptionKey>] [-SqlPreConsistencyCheckMethod {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-SqlPostConsistencyCheck {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-SqlContinueIfConsistencyCheckUnsuccessful <Boolean>] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-RunPostCommandAfterVerification <Boolean>] [-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>] [-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>] [-VerifyAsPartOfJob <Boolean>] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-SqlUseChecksumOnBackup <Boolean>] [-SqlIncrementalBackupMethod {Full | FullCopy | Automatic | Log | LogNoTruncate | Incremental | Differential | DifferentialBlockLevel | DatabaseSnapshot}] [-OraclePerformBackupOffline <Boolean>] [-NdmpBackupMethod <Int32>] [-OracleSkipBackedUpArchivedLogFile <Boolean>] [-SqlDiskCopyPath <String>] [-SqlCreateDiskCopy <Boolean>] [-SqlUseSoftwareCompression <Boolean>] [-OracleDeleteBackedUpArchivedLogFile <Boolean>] [-SharePointUseGrt <Boolean>] [-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>] [-TapeStorageRetensionMediaBeforeBackup <Boolean>] [-TapeStorageEnableDirectCopyToTape <Boolean>] [-DiskStorageKeepForHours <Int32>] [-BackupSetDescription <String>] [-SubmitOnHold <Boolean>] [-TapeStorageEnableWriteOnceReadManyMedia <Boolean>] [-TapeStorageMediaSet <BEMediaSet>] [-Storage <BEStorage>] [-TapeStorageExportMedia <Boolean>] [-TapeStorageEjectMediaAfterComplete <Boolean>] [-TapeStorageExportMediaToVault <BEMediaVault>] [-Schedule <BESchedule>] [-PreCommand <String>] [-EnableDirectAccessIfAvailable <Boolean>] [-PostCommand <String>] [-RunJobOnlyIfPreCommandIsSuccessful <Boolean>] [-PrePostCommandSuccessfulIfReturnsZero <Boolean>] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-KeepJobQueuedFor <TimeSpan>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-TapeStorageCompressionMethod {None | SoftwareIfNoHardware | HardwareOnly | SoftwareOnly}] [-IncludeJobLogWithEmailNotification <Boolean>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

この cmdlet は利用できなくなりました。代わりに Set-BEBackupTask を使用します。

Backup Exec のバックアップ定義にある既存の増分バックアップを修正します。

新しいバックアップ定義または既存のバックアップ定義の増分バックアップを修正できます。 バックアップジョブのデフォルトの増分バックアップを修正することもできます。

新しいバックアップ定義の増分バックアップを修正するには、Set-BEIncrementalBackupTask と New-BEBackupDefinition を使用します。

既存のバックアップ定義の増分バックアップを修正するには、Set-BEIncrementalBackupTask と Get-BEBackupDefinition を使用します。

バックアップジョブのデフォルトの増分バックアップを修正するには、Set-BEIncrementalBackupTask と Get-BEBackupJobDefault を使用します。

バックアップ定義を作成または編集する場合、そのバックアップ定義を Save-BEBackupDefinition に渡して変更をコミットする必要があります。

バックアップジョブのデフォルトを編集する場合、そのバックアップジョブのデフォルトを Save-BEBackupJobDefault に渡して変更をコミットする必要があります。

Parameters

-BackupDefinition <BEBackupDefinition>

変更するバックアップ定義を指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupJobDefault <BEBackupJobDefaults>

変更するバックアップジョブのデフォルトを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-JobName <String>

このタスクを表すジョブの名前を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Storage <BEStorage>

バックアップジョブに使用するストレージデバイスを指定します。 Get-BEStorage を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaSet <BEMediaSet>

メディアと関連付けるメディアセットを指定します。メディアはメディアセットの設定に基づいて上書きから保護されます。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。 Get-BEMediaSet を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMedia <Boolean>

ジョブの完了後にデバイスからメディアをエクスポートします。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMediaToVault <BEMediaVault>

ジョブの完了後にメディアを指定したボルトに論理的に移動します。Storage パラメータはテープベースのストレージデバイスに設定し、TapeStorageExportMedia は $true に設定する必要があります。Get-BEMediaVault を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEjectMediaAfterComplete <Boolean>

ジョブの完了後にストレージデバイスからメディアを取り出します。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableWriteOnceReadManyMedia <Boolean>

バックアップジョブに WORM (Write Once Read Many) メディアの使用を指定します。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableDirectCopyToTape <Boolean>

物理テープデバイスに仮想テープライブラリから直接データをコピーできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageRetensionMediaBeforeBackup <Boolean>

データを書き込む前にメディアのリテンションを行います。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskStorageKeepForHours <Int32>

メディアへの上書きを禁止し、このメディア上にデータを保存する時間を指定します。 Storage パラメータがディスクベースのストレージデバイスに設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SubmitOnHold <Boolean>

ジョブを保留状態でサブミットします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupSetDescription <String>

バックアップしたデータとその格納場所についての説明です。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Schedule <BESchedule>

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

予定開始時刻の経過後に、ジョブが未処理であると Backup Exec が判断し、そのジョブのスケジュール再設定が可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

予定開始時刻後にジョブの実行が続行されている場合、そのジョブのキャンセルが可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NotificationRecipientList <BENotificationRecipientObject[]>

ジョブが完了したときに通知を受け取る受信者を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IncludeJobLogWithEmailNotification <Boolean>

電子メールにジョブログを添付します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageCompressionMethod

使用するソフトウェアデータ圧縮またはハードウェアデータ圧縮の種類を指定します。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
None
SoftwareIfNoHardware
HardwareOnly
SoftwareOnly

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaAppendMethod

ジョブの開始時にメディアに上書きまたは追記します。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
Append
AppendOnly
Overwrite

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableDirectAccessIfAvailable <Boolean>

Agent for Windows から Storage パラメータで指定したデバイスにバックアップデータを直接送信できるようにします (デバイスがこの操作をサポートしている場合)。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreCommand <String>

バックアップジョブの前に実行するコマンドを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PostCommand <String>

バックアップジョブの後に実行するコマンドを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PrePostCommandSuccessfulIfReturnsZero <Boolean>

Backup Exec によってプリコマンドまたはポストコマンドの戻りコードを確認し、コマンドが正しく完了したかどうかを調べることができます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunJobOnlyIfPreCommandIsSuccessful <Boolean>

プリコマンドが正しく実行された場合にのみバックアップジョブを実行します。プリコマンドの実行に失敗した場合は、ジョブは実行されません。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>

プリコマンドが正しく実行された場合にのみポストコマンドを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>

ジョブが正しく実行されなかった場合でもポストコマンドを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandAfterVerification <Boolean>

バックアップジョブの検証を選択した場合、検証が完了した後にポストコマンドを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>

完了しなかったプリコマンドまたはポストコマンドをキャンセルするのに待つ時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunCommandLocation

プリコマンドとポストコマンドが実行される場所を指定します。

The valid values are:
OnEachAgentServer
OnBackupExecServer

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VerifyAsPartOfJob <Boolean>

バックアップジョブの完了時に自動的に検証操作を実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionType

バックアップジョブに使用する暗号化の種類を指定します。

The valid values are:
None
Software
Hardware
SoftwareIfNoHardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionKey <BEEncryptionKey>

使用する暗号化キーを指定します。 EncryptionType が None 以外の値に設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeUseGrt <Boolean>

インフォメーションストアのバックアップジョブから個々の項目をリストアできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlPreConsistencyCheckMethod

バックアップジョブを実行する前に行う一貫性チェックの種類を指定します。

The valid values are:
None
Physical
FullExcludingIndexes
FullIncludingIndexes

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlContinueIfConsistencyCheckUnsuccessful <Boolean>

一貫性チェックに失敗した場合でもバックアップジョブを続行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlPostConsistencyCheck

バックアップジョブを実行した後に行う一貫性チェックの種類を指定します。

The valid values are:
None
Physical
FullExcludingIndexes
FullIncludingIndexes

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlUseChecksumOnBackup <Boolean>

SQL 2005 以降の場合、バックアップする SQL データベースのデータにチェックサムを追加します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlCreateDiskCopy <Boolean>

バックアップする SQL データベースのコピーをディスク上に作成します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlDiskCopyPath <String>

バックアップする SQL データベースのディスク上に作成されるコピーのパスを指定します。CreateDiskCopy が $true に設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlUseSoftwareCompression <Boolean>

SQL 2008以降の場合、使用する圧縮設定を指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointUseGrt <Boolean>

データベースバックアップからの個々のドキュメント、イメージ、サイト、サブサイト、リスト、リストの項目のリストアを有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleDeleteBackedUpArchivedLogFile <Boolean>

バックアップ後にアーカイブログファイルを自動的に削除できます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleSkipBackedUpArchivedLogFile <Boolean>

以前にバックアップしたアーカイブログファイルを Backup Exec がスキップできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OraclePerformBackupOffline <Boolean>

バックアップジョブを開始する前に Backup Exec がデータベースをオフラインにすることを可能にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlIncrementalBackupMethod

バックアップジョブの SQL 増分バックアップを指定します。

The valid values are:
Full
FullCopy
Automatic
Log
LogNoTruncate
Incremental
Differential
DifferentialBlockLevel
DatabaseSnapshot

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NdmpBackupMethod <Int32>

NDMP ジョブのバックアップ方式を指定します。1 から 9 の範囲の値を入力します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String[]>

修正する 1 つ以上の増分バックアップジョブの名前 (ワイルドカードを使用可能) を指定します。 複数の名前を指定する場合、カンマを使用してそれぞれの名前を区切ります。

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupDefinition

Backup Exec のバックアップ定義オブジェクトを Set-BEIncrementalBackupTask にパイプ処理できます。

BackupExec.Management.CLI.BEBackupJobDefaults

Backup Exec のバックアップジョブのデフォルトオブジェクトを Set-BEIncrementalBackupTask にパイプ処理できます。

Return Values
BackupExec.Management.CLI.BEBackupDefinition

修正されたバックアップ定義を示します。

BackupExec.Management.CLI.BEBackupJobDefaults

修正されたバックアップジョブのデフォルトを示します。

Examples

Example 1

C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Set-BEIncrementalBackupTask -Name "Incremental 2" -Storage "Any disk storage" | Save-BEBackupDefinition

これらのコマンドは「Backup Definition 01」という名前のバックアップ定義に含まれる「Incremental 2」という名前の増分パックアップのストレージを「Any disk storage」プールに設定します。

Example 2
C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Set-BEIncrementalBackupTask -Name * -Storage "Any disk storage" | Save-BEBackupDefinition

これらのコマンドは「Backup Definition 01」という名前のバックアップ定義に含まれるすべての増分パックアップのストレージを「Any disk storage」プールに設定します。

Example 3
C:\PS> Get-BEBackupJobDefault BackupToDisk | Set-BEIncrementalBackupTask -Name * -Storage "Any disk storage" | Save-BEBackupJobDefault

これらのコマンドはディスクへのバックアップジョブのデフォルトに含まれるすべての増分パックアップのストレージを「Any disk storage」プールに設定します。

Related Links

Set-BEBackupTask
New-BEBackupDefinition
Get-BEBackupDefinition
Get-BEBackupJobDefault
Save-BEBackupDefinition
Save-BEBackupJobDefault
Get-BEStorage
Get-BEMediaSet
Get-BEMediaVault
New-BESchedule


Set-BEInitialFullBackupTask Help

Set-BEInitialFullBackupTask Cmdlet
Synopsis

Backup Exec のバックアップ定義で初回の完全バックアップを修正します。

Syntax
Set-BEInitialFullBackupTask -BackupDefinition <BEBackupDefinition> [-SqlPreConsistencyCheckMethod {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-ExchangeUseGrt <Boolean>] [-EncryptionKey <BEEncryptionKey>] [-SqlUseChecksumOnBackup <Boolean>] [-SqlPostConsistencyCheck {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-SqlContinueIfConsistencyCheckUnsuccessful <Boolean>] [-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>] [-RunPostCommandAfterVerification <Boolean>] [-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-VerifyAsPartOfJob <Boolean>] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-SqlCreateDiskCopy <Boolean>] [-SqlBackupType {Full | FullCopy}] [-ExchangeBackupType {Full | FullCopy}] [-DeleteSelectedFilesAfterSuccessfulBackup {Never | FilesOnly | FilesAndFolders}] [-SharePointBackupType {Full | FullCopy}] [-SharePointUseGrt <Boolean>] [-SqlUseSoftwareCompression <Boolean>] [-SqlDiskCopyPath <String>] [-OraclePerformBackupOffline <Boolean>] [-OracleSkipBackedUpArchivedLogFile <Boolean>] [-OracleDeleteBackedUpArchivedLogFile <Boolean>] [-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>] [-TapeStorageEnableDirectCopyToTape <Boolean>] [-TapeStorageEnableWriteOnceReadManyMedia <Boolean>] [-TapeStorageEjectMediaAfterComplete <Boolean>] [-SubmitOnHold <Boolean>] [-DiskStorageKeepForHours <Int32>] [-TapeStorageRetensionMediaBeforeBackup <Boolean>] [-Storage <BEStorage>] [-JobName <String>] [-TapeStorageExportMediaToVault <BEMediaVault>] [-TapeStorageExportMedia <Boolean>] [-TapeStorageMediaSet <BEMediaSet>] [-BackupSetDescription <String>] [-PreCommand <String>] [-EnableDirectAccessIfAvailable <Boolean>] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-RunJobOnlyIfPreCommandIsSuccessful <Boolean>] [-PrePostCommandSuccessfulIfReturnsZero <Boolean>] [-PostCommand <String>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-KeepJobQueuedFor <TimeSpan>] [-Schedule <BESchedule>] [-TapeStorageCompressionMethod {None | SoftwareIfNoHardware | HardwareOnly | SoftwareOnly}] [-IncludeJobLogWithEmailNotification <Boolean>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [-Force <SwitchParameter>] [<CommonParameters>]

Set-BEInitialFullBackupTask -BackupJobDefault <BEBackupJobDefaults> [-SqlPreConsistencyCheckMethod {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-ExchangeUseGrt <Boolean>] [-EncryptionKey <BEEncryptionKey>] [-SqlUseChecksumOnBackup <Boolean>] [-SqlPostConsistencyCheck {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-SqlContinueIfConsistencyCheckUnsuccessful <Boolean>] [-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>] [-RunPostCommandAfterVerification <Boolean>] [-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-VerifyAsPartOfJob <Boolean>] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-SqlBackupType {Full | FullCopy}] [-ExchangeBackupType {Full | FullCopy}] [-OraclePerformBackupOffline <Boolean>] [-SharePointBackupType {Full | FullCopy}] [-SqlUseSoftwareCompression <Boolean>] [-SqlDiskCopyPath <String>] [-SqlCreateDiskCopy <Boolean>] [-OracleSkipBackedUpArchivedLogFile <Boolean>] [-OracleDeleteBackedUpArchivedLogFile <Boolean>] [-SharePointUseGrt <Boolean>] [-DiskStorageKeepForHours <Int32>] [-TapeStorageRetensionMediaBeforeBackup <Boolean>] [-TapeStorageEnableDirectCopyToTape <Boolean>] [-Schedule <BESchedule>] [-BackupSetDescription <String>] [-SubmitOnHold <Boolean>] [-TapeStorageExportMedia <Boolean>] [-TapeStorageMediaSet <BEMediaSet>] [-Storage <BEStorage>] [-TapeStorageEnableWriteOnceReadManyMedia <Boolean>] [-TapeStorageEjectMediaAfterComplete <Boolean>] [-TapeStorageExportMediaToVault <BEMediaVault>] [-PostCommand <String>] [-PreCommand <String>] [-EnableDirectAccessIfAvailable <Boolean>] [-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>] [-RunJobOnlyIfPreCommandIsSuccessful <Boolean>] [-PrePostCommandSuccessfulIfReturnsZero <Boolean>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-KeepJobQueuedFor <TimeSpan>] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-TapeStorageCompressionMethod {None | SoftwareIfNoHardware | HardwareOnly | SoftwareOnly}] [-IncludeJobLogWithEmailNotification <Boolean>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のバックアップ定義で初回の完全バックアップを修正します。

新しいバックアップ定義または既存のバックアップ定義で初回の完全バックアップを修正できます。 バックアップジョブのデフォルトの完全バックアップを修正することもできます。

新しいバックアップ定義で初回の完全バックアップを修正するには、Set-BEInitialFullBackupTask と New-BEBackupDefinition を使用します。

既存のバックアップ定義で初回の完全バックアップを修正するには、Set-BEInitialFullBackupTask と Get-BEBackupDefinition を使用します。

バックアップジョブのデフォルトで初回の完全バックアップを修正するには、Set-BEInitialFullBackupTask と Get-BEBackupJobDefault を使用します。

バックアップ定義を作成または編集する場合、そのバックアップ定義を Save-BEBackupDefinition に渡して変更をコミットする必要があります。

バックアップジョブのデフォルトを編集する場合、そのバックアップジョブのデフォルトを Save-BEBackupJobDefault に渡して変更をコミットする必要があります。

Parameters

-BackupDefinition <BEBackupDefinition>

変更するバックアップ定義を指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupJobDefault <BEBackupJobDefaults>

変更するバックアップジョブのデフォルトを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-JobName <String>

このタスクを表すジョブの名前を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Storage <BEStorage>

バックアップジョブに使用するストレージデバイスを指定します。 Get-BEStorage を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaSet <BEMediaSet>

メディアと関連付けるメディアセットを指定します。メディアはメディアセットの設定に基づいて上書きから保護されます。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。 Get-BEMediaSet を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMedia <Boolean>

ジョブの完了後にデバイスからメディアをエクスポートします。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMediaToVault <BEMediaVault>

ジョブの完了後にメディアを指定したボルトに論理的に移動します。Storage パラメータはテープベースのストレージデバイスに設定し、TapeStorageExportMedia は $true に設定する必要があります。Get-BEMediaVault を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEjectMediaAfterComplete <Boolean>

ジョブの完了後にストレージデバイスからメディアを取り出します。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableWriteOnceReadManyMedia <Boolean>

このバックアップジョブに WORM (Write Once Read Many) メディアの使用を指定します。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableDirectCopyToTape <Boolean>

物理テープデバイスに仮想テープライブラリから直接データをコピーできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageRetensionMediaBeforeBackup <Boolean>

データを書き込む前にメディアのリテンションを行います。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskStorageKeepForHours <Int32>

メディアへの上書きを禁止し、このメディア上にデータを保存する時間を指定します。 Storage パラメータがディスクベースのストレージデバイスに設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SubmitOnHold <Boolean>

ジョブを保留状態でサブミットします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupSetDescription <String>

バックアップしたデータとその格納場所についての説明です。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Schedule <BESchedule>

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

予定開始時刻の経過後に、ジョブが未処理であると Backup Exec が判断し、そのジョブのスケジュール再設定が可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

予定開始時刻後にジョブの実行が続行されている場合、そのジョブのキャンセルが可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NotificationRecipientList <BENotificationRecipientObject[]>

ジョブが完了したときに通知を受け取る受信者を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IncludeJobLogWithEmailNotification <Boolean>

電子メールにジョブログを添付します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageCompressionMethod

ハードウェアまたはソフトウェアで実行するデータ圧縮の種類を指定します。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
None
SoftwareIfNoHardware
HardwareOnly
SoftwareOnly

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaAppendMethod

ジョブの開始時にメディアに上書きするか、追記するかを指定します。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
Append
AppendOnly
Overwrite

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableDirectAccessIfAvailable <Boolean>

Agent for Windows から Storage パラメータで指定したデバイスにバックアップデータを直接送信できるようにします (デバイスがこの操作をサポートしている場合)。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreCommand <String>

バックアップジョブの前に実行するコマンドを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PostCommand <String>

バックアップジョブの後に実行するコマンドを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PrePostCommandSuccessfulIfReturnsZero <Boolean>

Backup Exec によってプリコマンドまたはポストコマンドの戻りコードを確認し、コマンドが正しく完了したかどうかを調べることができます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunJobOnlyIfPreCommandIsSuccessful <Boolean>

プリコマンドが正しく実行された場合にのみバックアップジョブを実行します。プリコマンドの実行に失敗した場合は、ジョブは実行されません。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>

プリコマンドが正しく実行された場合にのみポストコマンドを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>

ジョブの実行に成功したかどうかに関係なくポストコマンドを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandAfterVerification <Boolean>

バックアップジョブの検証を選択した場合、検証が完了した後にポストコマンドを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>

完了しなかったプリコマンドまたはポストコマンドをキャンセルするのに待つ時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunCommandLocation

プリコマンドとポストコマンドが実行される場所を指定します。

The valid values are:
OnEachAgentServer
OnBackupExecServer

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VerifyAsPartOfJob <Boolean>

バックアップジョブの完了時に自動的に検証操作を実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionType

バックアップジョブに使用する暗号化の種類を指定します。

The valid values are:
None
Software
Hardware
SoftwareIfNoHardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionKey <BEEncryptionKey>

使用する暗号化キーを指定します。 EncryptionType が None 以外の値に設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeUseGrt <Boolean>

インフォメーションストアのバックアップジョブから個々の項目をリストアできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlPreConsistencyCheckMethod

バックアップジョブを実行する前に行う一貫性チェックの種類を指定します。

The valid values are:
None
Physical
FullExcludingIndexes
FullIncludingIndexes

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlContinueIfConsistencyCheckUnsuccessful <Boolean>

一貫性チェックに失敗した場合でもバックアップジョブを続行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlPostConsistencyCheck

バックアップジョブを実行した後に行う一貫性チェックの種類を指定します。

The valid values are:
None
Physical
FullExcludingIndexes
FullIncludingIndexes

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlUseChecksumOnBackup <Boolean>

SQL 2005 以降の場合、バックアップする SQL データベースのデータにチェックサムを追加します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlCreateDiskCopy <Boolean>

バックアップする SQL データベースのコピーをディスク上に作成します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlDiskCopyPath <String>

バックアップする SQL データベースのディスク上に作成されるコピーのパスを指定します。CreateDiskCopy が $true に設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlUseSoftwareCompression <Boolean>

SQL 2008以降の場合、使用する圧縮設定を指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointUseGrt <Boolean>

データベースバックアップからの個々のドキュメント、イメージ、サイト、サブサイト、リスト、リストの項目のリストアを有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleDeleteBackedUpArchivedLogFile <Boolean>

バックアップ後にアーカイブログファイルを自動的に削除できます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleSkipBackedUpArchivedLogFile <Boolean>

以前にバックアップしたアーカイブログファイルを Backup Exec がスキップできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OraclePerformBackupOffline <Boolean>

バックアップジョブを開始する前に Backup Exec がデータベースをオフラインにすることを可能にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DeleteSelectedFilesAfterSuccessfulBackup

選択したデータをバックアップし、メディアの検証を行った後、ボリュームからデータを削除します。この操作でファイルを削除してデータを回復するにはリストアを実行する必要があるため、このオプションを有効にした場合は Force パラメータを指定する必要があります。

The valid values are:
Never
FilesOnly
FilesAndFolders

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeBackupType

Microsoft Exchange を選択した場合に、どの種類のバックアップジョブを作成するかを指定します。

The valid values are:
Full
FullCopy

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlBackupType

Microsoft SQL を選択した場合に、どの種類のバックアップジョブを作成するかを指定します。

The valid values are:
Full
FullCopy

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointBackupType

Microsoft SharePoint を選択した場合に、どの種類のバックアップジョブを作成するかを指定します。

The valid values are:
Full
FullCopy

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Force <SwitchParameter>

DeleteSelectedFilesAfterSuccessfulBackup パラメータによってデータが失われ、使用を続ける必要があることを確認します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupDefinition

Backup Exec のバックアップ定義オブジェクトを Set-BEFullBackupTask にパイプ処理できます。

BackupExec.Management.CLI.BEBackupJobDefaults

Backup Exec のバックアップジョブのデフォルトオブジェクトを Set-BEFullBackupTask にパイプ処理できます。

Return Values
BackupExec.Management.CLI.BEBackupDefinition

修正されたバックアップ定義を示します。

BackupExec.Management.CLI.BEBackupJobDefaults

修正されたバックアップジョブのデフォルトを示します。

Examples

Example 1

C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Set-BEInitialFullBackupTask -Storage "Any disk storage" | Save-BEBackupDefinition

これらのコマンドは「Backup Definition 01」という名前のバックアップ定義に含まれる初回の完全バックアップのストレージを「Any disk storage」プールに設定します。

Example 2
C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Set-BEInitialFullBackupTask -Storage "Any disk storage" | Save-BEBackupDefinition

これらのコマンドは「Backup Definition 01」という名前のバックアップ定義に含まれる初回の完全バックアップのストレージを「Any disk storage」プールに設定します。

Example 3
C:\PS> Get-BEBackupJobDefault BackupToDisk | Set-BEInitialFullBackupTask -Storage "Any disk storage" | Save-BEBackupJobDefault

これらのコマンドはディスクへのバックアップジョブのデフォルトに含まれる完全バックアップのストレージを「Any disk storage」プールに設定します。

Related Links

New-BEBackupDefinition
Get-BEBackupDefinition
Get-BEBackupJobDefault
Save-BEBackupDefinition
Save-BEBackupJobDefault
Get-BEStorage
Get-BEMediaSet
Get-BEMediaVault
New-BESchedule
Set-BEFullBackupTask


Set-BEInventoryUtilityJob Help

Set-BEInventoryUtilityJob Cmdlet
Synopsis

Backup Exec インベントリ操作ジョブのプロパティを設定します。

Syntax
Set-BEInventoryUtilityJob -InputObject <BEInventoryUtilityJob[]> [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-Schedule <BESchedule>] [-KeepJobQueuedFor <TimeSpan>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec インベントリ操作ジョブのプロパティを設定します。

Parameters

-Schedule <BESchedule>

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

予定開始時刻の経過後に、ジョブが未処理であると Backup Exec が判断し、そのジョブのスケジュール再設定が可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

予定開始時刻後にジョブの実行が続行されている場合、そのジョブのキャンセルが可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEInventoryUtilityJob[]>

1 つ以上のインベントリ操作ジョブオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEInventoryUtilityJob

Backup Exec インベントリ操作ジョブオブジェクトを Set-BEInventoryUtilityJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEInventoryUtilityJob

Set-BEInventoryUtilityJob は変更された Backup Exec インベントリ操作ジョブを表すオブジェクトを返します。

Example

C:\PS> $Schedule = New-BESchedule -RunNow
C:\PS> Get-BEInventoryUtilityJob -Name "InventoryJob" | Set-BEInventoryUtilityJob -Schedule $Schedule

これらのコマンドは「InventoryJob」という名前のインベントリ操作ジョブのスケジュールを今すぐ実行するように設定します。

Related Links


Set-BELegacyBackupToDiskFolderDevice Help

Set-BELegacyBackupToDiskFolderDevice Cmdlet
Synopsis

Backup Exec のレガシーのディスクへのバックアップフォルダデバイスのプロパティを設定します。

Syntax
Set-BELegacyBackupToDiskFolderDevice -InputObject <BELegacyBackupToDiskFolderDevice[]> [[-BackupExecServer] <BEBackupExecServer>] [-BufferedReadsAutoDetectEnabled <Boolean>] [-BufferedReadsEnabled <Boolean>] [-Paused <Boolean>] [-Description <String>] [-Disabled <Boolean>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のレガシーのディスクへのバックアップフォルダデバイスのプロパティを設定します。

Parameters

-BackupExecServer <BEBackupExecServer>

CASO 環境でデバイスを接続する Backup Exec サーバーを指定します。

Required | false
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

レガシーのディスクへのバックアップフォルダデバイスの説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Disabled <Boolean>

レガシーのディスクへのバックアップフォルダデバイスを無効にするかどうかを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Paused <Boolean>

レガシーのディスクへのバックアップフォルダデバイスを一時停止するかどうかを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BufferedReadsAutoDetectEnabled <Boolean>

読み取りバッファと書き込みバッファに適した設定を自動的に検出するかどうかを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BufferedReadsEnabled <Boolean>

大きなデータブロックの読み取りを許可します。このオプションによりパフォーマンスが向上する可能性があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BELegacyBackupToDiskFolderDevice[]>

1 つ以上のレガシーのディスクへのバックアップフォルダデバイスオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BELegacyBackupToDiskFolderDevice

Backup Exec のレガシーのディスクへのバックアップフォルダデバイスオブジェクトを Set-BELegacyBackupToDiskFolderDevice にパイプ処理することができます。

Return Value
BackupExec.Management.CLI.BELegacyBackupToDiskFolderDevice

Set-BELegacyBackupToDiskFolderDevice は変更されたレガシーのディスクへのバックアップフォルダデバイスを表すオブジェクトを返します。

Example

C:\PS> Get-BELegacyBackupToDiskFolderDevice "Device 0001" | Set-BELegacyBackupToDiskFolderDevice -Paused $true

これらのコマンドは「Device 0001」という名前のレガシーのディスクへのバックアップフォルダデバイスを一時停止します。

Related Link

Get-BELegacyBackupToDiskFolderDevice


Set-BELogonAccount Help

Set-BELogonAccount Cmdlet
Synopsis

Backup Exec ログオンアカウントのプロパティを設定します。

Syntax
Set-BELogonAccount -InputObject <BELogonAccount[]> [-AccountType {Restricted | Common}] [-Description <String>] [-UserName <String>] [-CurrentPassword <SecureString>] [-UserDefault <SwitchParameter>] [-NewPassword <SecureString>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Set-BELogonAccount -InputObject <BELogonAccount[]> -Credential <PSCredential> [-AccountType {Restricted | Common}] [-Description <String>] [-CurrentPassword <SecureString>] [-UserDefault <SwitchParameter>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec ログオンアカウントのプロパティを設定します。

ログオンアカウントが制限されたアカウントで、アカウントの所有者でない場合、-CurrentPassword パラメータを使用してログオンアカウントを変更する必要があります。

Parameters

-InputObject <BELogonAccount[]>

1 つ以上のログオンアカウントオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-CurrentPassword <SecureString>

このアカウントに割り当てられている現在のパスワードを指定します。 このパスワードの指定は、ログオンアカウントの所有者ではないユーザーとしてログインしている場合に、そのログオンアカウントが所有者専用であるときに必要です。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Credential <PSCredential>

ログオンアカウントのクレデンシャルを指定します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UserName <String>

ログオンアカウントのユーザー名を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NewPassword <SecureString>

ログオンアカウントの新しいパスワードを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UserDefault <SwitchParameter>

アカウントがデフォルトのログインアカウントであることを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

ログオンアカウントの説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AccountType

これが共有アカウントであるか、所有者専用アカウントであるかを指定します。

The valid values are:
Restricted
Common

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BELogonAccount

Backup Exec ログオンアカウントオブジェクトを Set-BELogonAccount にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BELogonAccount

Set-BELogonAccount は、変更されたログオンアカウントを表すオブジェクトを返します。

Example

C:\PS> Get-BELogonAccount "LogonAccount 0001" | Set-BELogonAccount -AccountType Common

これらのコマンドは、「LogonAccount 0001」という名前のログオンアカウントを共有ログオンアカウントに変更します。

Related Link

Get-BELogonAccount


Set-BEManagedBackupExecServer Help

Set-BEManagedBackupExecServer Cmdlet
Synopsis

管理対象 Backup Exec サーバーのプロパティを設定します。

Syntax
Set-BEManagedBackupExecServer -InputObject <BEManagedBackupExecServer[]> [-SendJobHistory {JobCompletion | NeverSend | Scheduled}] [-SendJobHistoryIfJobFailed <Boolean>] [-SendJobLogIfJobFailed <Boolean>] [-SendJobLogOn <DateTime>] [-SendJobHistoryOn <DateTime>] [-KeepCatalogsOn {Centralized | Distributed | Replicated}] [-IsPrivateCloudServer <Boolean>] [-MonitorJobsCreatedOnThisServer <Boolean>] [-DisplayUnsyncedTimeAlert <Boolean>] [-Description <String>] [-ConnectionSetting {Custom | Normal | Slow}] [-AlertAfterMaxUnsyncedSeconds <Int32>] [-SendActiveJobStatusUpdateSeconds <Int32>] [-SendJobLogDetail {JobCompletion | NeverSend | Scheduled}] [-MaximumAllowedStalledCommunicationSeconds <Int32>] [-MaximumAllowedNoCommunicationSeconds <Int32>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

管理対象 Backup Exec サーバーのプロパティを設定します。

Parameters

-Description <String>

管理対象 Backup Exec サーバーの説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ConnectionSetting

集中管理サーバーおよび管理対象 Backup Exec サーバー間の接続速度を指定します。デフォルト値は「標準」です。

The valid values are:
Custom
Normal
Slow

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MonitorJobsCreatedOnThisServer <Boolean>

委任されたジョブ、およびローカルの管理対象 Backup Exec サーバーで作成されるジョブを表示できます。デフォルト値は「false」です。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DisplayUnsyncedTimeAlert <Boolean>

管理対象 Backup Exec サーバー上の時刻と集中管理サーバー上の時刻に差がある場合に、作成およびアラートを表示します。デフォルト値は「true」です。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AlertAfterMaxUnsyncedSeconds <Int32>

管理対象 Backup Exec サーバー上の時刻と集中管理サーバー上の時刻の差となり Backup Exec がアラートを送信するまでの秒数を指定します。デフォルト値は「1」です。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MaximumAllowedStalledCommunicationSeconds <Int32>

管理対象 Backup Exec サーバーが停止状態になってからサーバーがステータスを変更するまでの時間を指定します。このパラメータは、「カスタム」接続設定とともに使用してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MaximumAllowedNoCommunicationSeconds <Int32>

管理対象 Backup Exec サーバーに通信が発生せず、集中管理サーバーが管理対象 Backup Exec サーバー上で実行中のジョブを失敗としてマークするまでの時間を指定します。このパラメータは、「カスタム」接続設定とともに使用してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SendActiveJobStatusUpdateSeconds <Int32>

管理対象 Backup Exec サーバーがジョブステータス更新を集中管理サーバーに送信する時間を指定します。このパラメータは、「カスタム」接続設定とともに使用してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SendJobLogDetail

ジョブログの詳細を集中管理サーバーに送信します。

The valid values are:
JobCompletion
NeverSend
Scheduled

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SendJobLogIfJobFailed <Boolean>

ジョブが失敗した場合にジョブログの詳細を集中管理サーバーに送信するかどうかを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SendJobLogOn <DateTime>

ジョブログを集中管理サーバーに送信する時刻を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SendJobHistory

管理対象 Backup Exec サーバーのジョブ履歴を集中管理サーバーに送信するかどうかを指定します。

The valid values are:
JobCompletion
NeverSend
Scheduled

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SendJobHistoryIfJobFailed <Boolean>

ジョブが失敗した場合にジョブ履歴を集中管理サーバーに送信するかどうかを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SendJobHistoryOn <DateTime>

管理対象 Backup Exec サーバーのジョブ履歴を集中管理サーバーに送信する時刻を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepCatalogsOn

カタログを保持する場所を指定します。デフォルト値は集中管理サーバーに対応する「集中」です。

The valid values are:
Centralized
Distributed
Replicated

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IsPrivateCloudServer <Boolean>

管理対象 Backup Exec サーバーがプライベートクラウドサーバーであるかどうかを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEManagedBackupExecServer[]>

1 つ以上の管理対象 Backup Exec サーバーオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEManagedBackupExecServer

管理対象 Backup Exec サーバーオブジェクトを Set-BEManagedBackupExecServer にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEManagedBackupExecServer

Set-BEManagedBackupExecServer は、変更された管理対象 Backup Exec サーバーを表すオブジェクトを返します。

Example

C:\PS> $BackupExecServer = Get-BEManagedBackupExecServer -Name "MyMMs"
C:\PS> $BackupExecServer | Set-BEManagedBackupExecServer -Description "This is my Managed Media Server"

このコマンドは「MyMms」という名前の管理対象 Backup Exec サーバーの説明を設定します。

Related Link

Get-BEManagedBackupExecServer


Set-BEMedia Help

Set-BEMedia Cmdlet
Synopsis

Backup Exec のメディアのプロパティを設定します。

Syntax
Set-BEMedia -InputObject <BEMedia[]> [-MaximumCleaningCount <Int32>] [-Description <String>] [-PreserveDescription <Boolean>] [-VirtualWriteProtectionEnabled <Boolean>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のメディアのプロパティを設定します。

Parameters

-Description <String>

メディアの説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreserveDescription <Boolean>

メディアが消去または上書きされる場合に、その説明を保持します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualWriteProtectionEnabled <Boolean>

仮想書き込み保護を有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MaximumCleaningCount <Int32>

クリーニングメディアを使用できる回数を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEMedia[]>

1 つ以上のメディアオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEMedia

Backup Exec メディアオブジェクトを Set-BEMedia にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEMedia

Set-BEMedia は、変更されたメディアを表すオブジェクトを返します。

Example

C:\PS> Get-BEMedia "Media 0001" | Set-BEMedia -Description "Test Media"

これらのコマンドは、「Media 0001」という名前のメディアに「Test Media」という説明を追加します。

Related Link

Get-BEMedia


Set-BEMediaSet Help

Set-BEMediaSet Cmdlet
Synopsis

Backup Exec のメディアセットのプロパティを設定します。

Syntax
Set-BEMediaSet -InputObject <BEMediaSet[]> [-ReturnFromVaultPeriodHours <Int32>] [-MoveToVaultPeriodHours <Int32>] [-OverwriteProtectionPeriodHours <Int32>] [-Description <String>] [-MediaVault <BEMediaVault>] [-AppendPeriodHours <Int32>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のメディアセットのプロパティを設定します。

Parameters

-Description <String>

メディアセットの説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OverwriteProtectionPeriodHours <Int32>

データが上書きされるまで、特定のメディアにそのデータが保持される期間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AppendPeriodHours <Int32>

メディアにデータを追加できる期間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MediaVault <BEMediaVault>

このメディアセットに関連付けられているメディアを送信する Backup Exec メディアボルトを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MoveToVaultPeriodHours <Int32>

メディアをこのボルトに移動可能であるとレポートされるまでの時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ReturnFromVaultPeriodHours <Int32>

メディアをこのボルトから返すことが可能であると報告されるまでの時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEMediaSet[]>

1 つ以上のメディアセットオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEMediaSet

Backup Exec メディアセットオブジェクトを Set-BEMediaSet にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEMediaSet

Set-BEMediaSet は、変更されたメディアセットを表すオブジェクトを返します。

Example

C:\PS> Get-BEMediaSet "Media Set 0001" | Set-BEMediaSet -Description "Test Media Set"

これらのコマンドは、「Media Set 0001」という名前のメディアセットに「Test Media Set」という説明を追加します。

Related Link

Get-BEMediaSet


Set-BEMediaType Help

Set-BEMediaType Cmdlet
Synopsis

Backup Exec メディアタイプのプロパティを設定します。

Syntax
Set-BEMediaType -InputObject <BEMediaType[]> [-MediaLabelDigits <UInt32>] [-MediaLabelPrefix <String>] [-MediaLabelNextValue <UInt32>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec メディアタイプのプロパティを設定します。

Parameters

-MediaLabelPrefix <String>

メディアタイプのメディアラベルプレフィックスを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MediaLabelNextValue <UInt32>

この Backup Exec のインストールでメディアを初めて使用するときに、そのメディアタイプと一致する次のメディアのラベルに含める次の番号を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MediaLabelDigits <UInt32>

そのメディアタイプのメディアラベルにおける数値部の最小サイズを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEMediaType[]>

1 つ以上のメディアタイプオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEMediaType

Backup Exec メディアタイプオブジェクトを Set-BEMediaType にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEMediaType

Set-BEMediaType は、変更された Backup Exec メディアタイプを表すオブジェクトを返します。

Example

C:\PS> Get-BEMediaType LTO | Set-BEMediaType -MediaLabelPrefix WORM

これらのコマンドは、LTO メディアタイプのメディアラベルプレフィクスを「WORM」に変更します。

Related Link

Get-BEMediaType


Set-BEMediaVault Help

Set-BEMediaVault Cmdlet
Synopsis

Backup Exec のメディアボルトにプロパティを設定します。

Syntax
Set-BEMediaVault -InputObject <BEMediaVault[]> [-Description <String>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のメディアボルトにプロパティを設定します。

Parameters

-Description <String>

メディアボルトの説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEMediaVault[]>

1 つ以上のメディアボルトオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEMediaVault

Backup Exec メディアボルトオブジェクトを Set-BEMediaVault にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEMediaVault

Set-BEMediaVault は、変更されたメディアボルトを表すオブジェクトを返します。

Example

C:\PS> Get-BEMediaVault "Media Vault 0001" | Set-BEMediaVault -Description "Test Media Vault"

これらのコマンドは、「Media Vault 0001」という名前のメディアボルトの説明を「Test Media Vault」に設定します。

Related Link

Get-BEMediaVault


Set-BENdmpServer Help

Set-BENdmpServer Cmdlet
Synopsis

Backup Exec NDMP サーバーのプロパティを設定します。

Syntax
Set-BENdmpServer -InputObject <BENdmpServer[]> [-Disabled <Boolean>] [-Port <Int32>] [-LogonAccount <BELogonAccount>] [-Description <String>] [-UseICMPPingOption <Boolean>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec NDMP サーバーのプロパティを設定します。

Parameters

-LogonAccount <BELogonAccount>

NDMP サーバーで使用するログオンアカウントオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BELogonAccount を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

NDMP サーバーの説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UseICMPPingOption <Boolean>

Internet Control Message Protocol で NDMP サーバーを検索するように設定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Port <Int32>

NDMP サーバーに接続するために使用するポートを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Disabled <Boolean>

NDMP サーバーを無効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BENdmpServer[]>

1 つ以上の NDMP サーバーオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BENdmpServer

Backup Exec NDMP サーバーオブジェクトを Set-BENdmpServer にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BENdmpServer

Set-BENdmpServer は、変更された Backup Exec NDMP サーバーを表すオブジェクトを返します。

Example

C:\PS> Get-BENDMPServer -Name "MyServer.mycompany.com" | Set-BENDMPServer -Port 10001

このコマンドは「MyServer.mycompany.com」という名前の NDMP サーバーのポートを 10001 に設定します。

Related Links


Set-BENotificationConfiguration Help

Set-BENotificationConfiguration Cmdlet
Synopsis

アラート用の通知を設定します。

Syntax
Set-BENotificationConfiguration -SmtpPort <Int32> -SmtpServer <String> -SenderEmailAddress <String> -SenderName <String> [-LogOnName <String>] [-EmailAuthenticationEnabled <Boolean>] [-TextServiceProviderAddress <String>] [-Password <String>] [<CommonParameters>]
Description

アラート用の電子メールおよびテキスト通知を設定します。

Parameters

-SmtpServer <String>

メール通知を送信する SMTP メールサーバーの名前を指定します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SmtpPort <Int32>

メールサーバーで使用される SMTP ポート番号を指定します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SenderName <String>

通知の送信者として表示される送信者の名前を指定します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SenderEmailAddress <String>

通知の送信元となる送信者の電子メールアドレスを指定します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EmailAuthenticationEnabled <Boolean>

Backup Exec でアラート通知用に送信される電子メールを認証するように設定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LogOnName <String>

送信者の電子メールアカウントのユーザー名を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Password <String>

送信者の電子メールアカウントのパスワードを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TextServiceProviderAddress <String>

送信者のテキストメッセージングサービスプロバイダの名前を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

このコマンドレットは入力を受け入れません。

Return Value
BackupExec.Management.CLI.BENotificationConfiguration

Set-BENotificationConfiguration は、通知構成設定を表すオブジェクトを返します。

Example

C:\PS> Set-BENotificationConfiguration -SmtpServer "smtp.be.com" -SmtpPort 455 -SenderName "BeAdmin" -SenderEmailAddress"BeAdmin@be.com"

このコマンドは通知設定の 4 つの必須パラメータを設定します。


Set-BENotificationRecipient Help

Set-BENotificationRecipient Cmdlet
Synopsis

アラートの通知受信者を修正します。

Syntax
Set-BENotificationRecipient -InputObject <BENotificationRecipient[]> [-MaxTextNotifications <Int32>] [-TextServiceProviderAddress <String>] [-LimitTextNotification <Boolean>] [-MaxTextNotificationsTimeWindowInMinutes <Int32>] [-RecipientsCellPhoneNumber <String>] [-LimitEmailNotification <Boolean>] [-RecipientsEmailAddress <String>] [-NotifyByEmailEnabled <Boolean>] [-NotifyByTextEnabled <Boolean>] [-MaxEmailNotificationsTimeWindowInMinutes <Int32>] [-MaxEmailNotifications <Int32>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

アラートの通知受信者を修正します。

Parameters

-NotifyByEmailEnabled <Boolean>

電子メールによる通知を有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RecipientsEmailAddress <String>

アラート通知を送信する通知受信者の電子メールアドレスを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LimitEmailNotification <Boolean>

通知電子メールの受信者への送信を制限します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MaxEmailNotifications <Int32>

受信者へ送信する通知電子メールの最大数を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MaxEmailNotificationsTimeWindowInMinutes <Int32>

最大の通知電子メールを送信することができる期間の長さを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NotifyByTextEnabled <Boolean>

テキストによる通知を有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RecipientsCellPhoneNumber <String>

テキスト通知を送信する通知受信者の携帯電話番号を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LimitTextNotification <Boolean>

テキスト通知の受信者への送信を制限します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TextServiceProviderAddress <String>

テキストサービスプロバイダのアドレスを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MaxTextNotifications <Int32>

受信者へ送信するテキスト通知の最大数を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MaxTextNotificationsTimeWindowInMinutes <Int32>

最大の通知テキストを送信することができる期間の長さを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BENotificationRecipient[]>

修正する通知受信者を指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BENotificationRecipient

このコマンドレットはパイプラインを通して BENotificationRecipient のオブジェクトを受け入れます。

Return Value
BackupExec.Management.CLI.BENotificationRecipient

New-BENotificationRecipient は、アラート通知を送信する通知受信者を表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BENotificationRecipient | Set-BENotificationRecipient -LimitEmailNotification $true -MaxEmailNotifications 10 -MaxEmailNotificationsTimeWindowInMinutes 60

これらのコマンドはすべての通知受信者を修正して、電子メール通知送信用の電子メール設定を行います。

Example 2
C:\PS> Get-BENotificationRecipient -Name "John" | Set-BENotificationRecipient -NotifyByTextEnabled $true -RecipientsCellPhoneNumber 9867453627 -TextServiceProviderAddress "text.example.com" -LimitTextNotification $true -MaxTextNotifications 10 -MaxTextNotificationsTimeWindowInMinutes 60

これらのコマンドは指定された名前で通知受信者を修正して、テキスト通知送信用のテキストメッセージ設定を行います。

Related Links


Set-BENotificationRecipientGroup Help

Set-BENotificationRecipientGroup Cmdlet
Synopsis

アラート通知が設定された通知受信者グループを修正します。

Syntax
Set-BENotificationRecipientGroup -InputObject <BENotificationRecipientGroup[]> [-NotificationRecipientList <BENotificationRecipient[]>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

アラート通知が設定された通知受信者グループを修正します。

Parameters

-NotificationRecipientList <BENotificationRecipient[]>

通知受信者グループに割り当てる受信者を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BENotificationRecipientGroup[]>

修正する通知受信者グループを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BENotificationRecipientGroup

このコマンドレットはパイプラインを通して BENotificationRecipientGroup のオブジェクトを受け入れます。

Return Value
BackupExec.Management.CLI.BENotificationRecipientGroup

Set-BENotificationRecipientGroup は、アラート送信用の通知受信者グループを表すオブジェクトを返します。

Example

C:\PS>
$Recipients = Get-BENotificationRecipient
Get-BENotificationRecipientGroup -Name "exampleGroup" | Set-BENotificationRecipientGroup -NotificationRecipientList $Recipients

これらのコマンドは「exampleGroup」という名前のグループを修正して、指定した受信者をグループに追加します。

Related Links


Set-BEOneTimeBackupJob Help

Set-BEOneTimeBackupJob Cmdlet
Synopsis

ワンタイムバックアップジョブのプロパティを設定します。

Syntax
Set-BEOneTimeBackupJob [-InputObject] <BEOneTimeBackupJob[]> [-TapeStorageEjectMediaAfterComplete <Boolean>] [-TapeStorageExportMediaToVault <BEMediaVault>] [-TapeStorageEnableDirectCopyToTape <Boolean>] [-TapeStorageEnableWriteOnceReadManyMedia <Boolean>] [-Storage <BEStorage>] [-NdmpNetAppEnableFileHistory <Boolean>] [-TapeStorageExportMedia <Boolean>] [-TapeStorageMediaSet <BEMediaSet>] [-TapeStorageRetensionMediaBeforeBackup <Boolean>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-TapeStorageCompressionMethod {None | SoftwareIfNoHardware | HardwareOnly | SoftwareOnly}] [-IncludeJobLogWithEmailNotification <Boolean>] [-SubmitOnHold <Boolean>] [-DiskStorageKeepForHours <Int32>] [-KeepJobQueuedFor <TimeSpan>] [-BackupSetDescription <String>] [-NdmpNetAppBackupAccessControlLists <Boolean>] [-VirtualMachineEnableIRForAll <Boolean>] [-VirtualMachineBackupPoweredOffVirtualMachine <Boolean>] [-VirtualMachineUseGrtForActiveDirectory <Boolean>] [-VirtualMachineUseGrtForFileSystem <Boolean>] [-ActiveDirectoryUseGrt <Boolean>] [-ActiveDirectoryContinueIfConsistencyCheckIsUnsuccessful <Boolean>] [-OracleMinimumNumberOfDevicesRequiredForJob <UInt32>] [-OracleMaximumNumberOfDevicesToUseForResources <UInt32>] [-VirtualMachineUseGrtForExchange <Boolean>] [-NdmpEMCBackupType {Dump | VBB}] [-VMwareVSpherePort <UInt32>] [-NdmpEMCEnableFileHistory <Boolean>] [-NdmpEMCBackupWithIntegratedCheckpoints <Boolean>] [-VirtualMachineUseGrtForSharePoint <Boolean>] [-VirtualMachineUseGrtForSql <Boolean>] [-VMwareTransportModePriority {SAN | NBD | NBDSSL | Hotadd}] [-HyperVExcludeVirtualMachinesNeedingSavedState <Boolean>] [-SqlCreateDiskCopy <Boolean>] [-SqlUseChecksumOnBackup <Boolean>] [-SqlUseSoftwareCompression <Boolean>] [-SqlDiskCopyPath <String>] [-SqlPreConsistencyCheckMethod {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-ExchangeUseGrt <Boolean>] [-SqlPostConsistencyCheck {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-SqlContinueIfConsistencyCheckUnsuccessful <Boolean>] [-SharePointUseGrt <Boolean>] [-SqlAdvancedLogBackupOption {None | NoRecover | Standby}] [-SqlBackupMethod {FullCopy | DatabaseSnapshot | LogNoTruncate | Log | Full}] [-OracleSkipBackedUpArchivedLogFile <Boolean>] [-OracleDeleteBackedUpArchivedLogFile <Boolean>] [-DeleteSelectedFilesAfterSuccessfulBackup {Never | FilesOnly | FilesAndFolders}] [-OraclePerformBackupOffline <Boolean>] [-EncryptionKey <BEEncryptionKey>] [-PrePostCommandSuccessfulIfReturnsZero <Boolean>] [-PostCommand <String>] [-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>] [-RunJobOnlyIfPreCommandIsSuccessful <Boolean>] [-EnableDirectAccessIfAvailable <Boolean>] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-PreCommand <String>] [-StartDate <DateTime>] [-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>] [-VerifyJobNotificationRecipientList <BENotificationRecipientObject[]>] [-EnableDirectAccessForVerifyJobIfAvailable <Boolean>] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-VerifyJobIncludeJobLogWithEmailNotification <Boolean>] [-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>] [-RunPostCommandAfterVerification <Boolean>] [-Verify {None | AsPartOfJob | AsSeparateJobImmediatelyAfter}] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-LinuxMacSelection <BELinuxMacSelection[]>] [-SharePointServiceSiteSelection <BESharePointServiceSiteSelection[]>] [-HyperVSelection <BEHyperVSelection[]>] [-OracleSelection <BEOracleSelection[]>] [-SharePointSharedServiceApplicationProxySelection <BESharePointSharedServiceApplicationProxySelection[]>] [-SharePointSharedServiceApplicationSelection <BESharePointSharedServiceApplicationSelection[]>] [-SharePointPortalSiteSelection <BESharePointPortalSiteSelection[]>] [-SharePointSharedServiceProviderSelection <BESharePointSharedServiceProviderSelection[]>] [-VMwareSelection <BEVMwareSelection[]>] [-OpenEnterpriseServerSelection <BEOpenEnterpriseServerSelection[]>] [-ActiveDirectoryApplicationModeSelection <BEActiveDirectoryApplicationModeSelection[]>] [-RestrictToBackupExecServer <BEBackupExecServer>] [-Priority {Normal | Lowest | Low | High | Highest}] [-EnterpriseVaultDirectorySelection <BEEnterpriseVaultDirectorySelection[]>] [-UtilityPartitionSelection <BEUtilityPartitionSelection[]>] [-EnterpriseVaultDiscoveryAcceleratorSelection <BEEnterpriseVaultDiscoveryAcceleratorSelection[]>] [-EnterpriseVaultComplianceAcceleratorSelection <BEEnterpriseVaultComplianceAcceleratorSelection[]>] [-SharePointServiceApplicationProxySelection <BESharePointServiceApplicationProxySelection[]>] [-ExchangeStorageGroupDatabaseSelection <BEExchangeStorageGroupDatabaseSelection[]>] [-FileSystemSelection <BEFileSystemSelection[]>] [-SqlDatabaseSelection <BESqlDatabaseSelection[]>] [-ExchangeDatabaseSelection <BEExchangeDatabaseSelection[]>] [-EnableSimplifiedDisasterRecovery <Boolean>] [-ClearExistingSelection <SwitchParameter>] [-SystemStateSelection {Include | Exclude}] [-Description <String>] [-SharePointAllResourcesSelection {Include | Exclude}] [-SharePointSingleSignOnDatabaseSelection {Include | Exclude}] [-SharePointHelpSearchSelection {Include | Exclude}] [-SharePointServiceApplicationSelection <BESharePointServiceApplicationSelection[]>] [-SharePointWebApplicationSelection <BESharePointWebApplicationSelection[]>] [-SharePointGlobalSettingsSelection {Include | Exclude}] [-SharePointConfigurationDatabaseSelection {Include | Exclude}] [-SharePointInfoPathServicesSelection {Include | Exclude}] [-SharePointCentralAdministrationWebApplicationSelection {Include | Exclude}] [-ExchangePreConsistencyCheck <Boolean>] [-FileSystemBackupOpenFileIfClosedWithinSeconds <UInt32>] [-ExchangeHighAvailability {FromPassiveCopyIfAvailableOtherwiseActiveCopy | FromPassiveCopyOnly | FromActiveCopyOnly | FromPassiveCopyIfAvailableOtherwiseActiveCopyUsePreferredServers}] [-ExchangeContinueIfConsistencyCheckIsUnsuccessful <Boolean>] [-FileSystemFollowSymbolicLink <Boolean>] [-FileSystemFollowJunctionPoint <Boolean>] [-FileSystemBackupOpenFile {Never | IfClosedWithinSpecifiedTime | WithALock | WithoutALock}] [-FileSystemBackupRemoteStorage <Boolean>] [-ExchangePreferredServerGroup <BEPreferredServerGroup>] [-LinuxMacFollowRemoteMountPoint <Boolean>] [-LinuxMacFollowLocalMountPoint <Boolean>] [-ActiveDirectoryPreConsistencyCheck <Boolean>] [-LinuxMacLockRemoteFile <Boolean>] [-SharePointPreConsistencyCheck <Boolean>] [-SharePointReleaseLockOnFarmTopology <Boolean>] [-LinuxMacPreserveChangeTime <Boolean>] [-SharePointContinueIfConsistencyCheckIsUnsuccessful <Boolean>] [-FileSystemEnableNtfsSingleInstanceBackup <Boolean>] [-EnableCheckpointRestart <Boolean>] [-AllowAnyNetworkForAgentAccess <Boolean>] [-SnapshotTechnology {Automatic | MicrosoftVolumeShadowCopyService}] [-UseSnapshotTechnology <Boolean>] [-NetworkInterface <BENetworkInterface>] [-RestrictToBackupExecServersInPool <BEBackupExecServerPool>] [-NetworkSubnet <BENetworkInterfaceSubnet>] [-NetworkProtocol {AnyAvailable | IPv4 | IPv6}] [-SnapshotProvider {Automatic | System | Software | Hardware}] [-DelayedCatalogScheduleType {NoDelayedCatalog | ImmediatelyAfterBackup | Scheduled}] [-ProcessOffhostLogicalVolumesSequentially <Boolean>] [-DelayedCatalogDaysOfWeek {Sunday | Monday | Tuesday | Wednesday | Thursday | Friday | Saturday}] [-DelayedCatalogStartAt <DateTime>] [-UseOffhostBackup <Boolean>] [-ProcessLogicalVolumesSequentially <Boolean>] [-FailIfNoOffhostBackup <Boolean>] [-OffhostBackupSnapshotProvider {Automatic | Software | Hardware}] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Set-BEOneTimeBackupJob [-InputObject] <BEOneTimeBackupJob[]> -SelectionList <BEAgentServerBackupSelectionList[]> [-IncludeJobLogWithEmailNotification <Boolean>] [-TapeStorageCompressionMethod {None | SoftwareIfNoHardware | HardwareOnly | SoftwareOnly}] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-KeepJobQueuedFor <TimeSpan>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-EnableDirectAccessIfAvailable <Boolean>] [-PrePostCommandSuccessfulIfReturnsZero <Boolean>] [-RunJobOnlyIfPreCommandIsSuccessful <Boolean>] [-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>] [-StartDate <DateTime>] [-PreCommand <String>] [-PostCommand <String>] [-BackupSetDescription <String>] [-Storage <BEStorage>] [-TapeStorageMediaSet <BEMediaSet>] [-TapeStorageExportMedia <Boolean>] [-NdmpEMCEnableFileHistory <Boolean>] [-NdmpNetAppBackupAccessControlLists <Boolean>] [-NdmpNetAppEnableFileHistory <Boolean>] [-TapeStorageExportMediaToVault <BEMediaVault>] [-TapeStorageRetensionMediaBeforeBackup <Boolean>] [-DiskStorageKeepForHours <Int32>] [-SubmitOnHold <Boolean>] [-TapeStorageEjectMediaAfterComplete <Boolean>] [-TapeStorageEnableWriteOnceReadManyMedia <Boolean>] [-TapeStorageEnableDirectCopyToTape <Boolean>] [-SqlUseSoftwareCompression <Boolean>] [-SharePointUseGrt <Boolean>] [-OracleDeleteBackedUpArchivedLogFile <Boolean>] [-SqlUseChecksumOnBackup <Boolean>] [-SqlCreateDiskCopy <Boolean>] [-SqlDiskCopyPath <String>] [-OracleSkipBackedUpArchivedLogFile <Boolean>] [-SqlAdvancedLogBackupOption {None | NoRecover | Standby}] [-OraclePerformBackupOffline <Boolean>] [-DeleteSelectedFilesAfterSuccessfulBackup {Never | FilesOnly | FilesAndFolders}] [-SqlBackupMethod {FullCopy | DatabaseSnapshot | LogNoTruncate | Log | Full}] [-SqlPostConsistencyCheck {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-Verify {None | AsPartOfJob | AsSeparateJobImmediatelyAfter}] [-EnableDirectAccessForVerifyJobIfAvailable <Boolean>] [-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>] [-RunPostCommandAfterVerification <Boolean>] [-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>] [-VerifyJobNotificationRecipientList <BENotificationRecipientObject[]>] [-ExchangeUseGrt <Boolean>] [-SqlPreConsistencyCheckMethod {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-SqlContinueIfConsistencyCheckUnsuccessful <Boolean>] [-VerifyJobIncludeJobLogWithEmailNotification <Boolean>] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-EncryptionKey <BEEncryptionKey>] [-NdmpEMCBackupWithIntegratedCheckpoints <Boolean>] [-ProcessOffhostLogicalVolumesSequentially <Boolean>] [-DelayedCatalogScheduleType {NoDelayedCatalog | ImmediatelyAfterBackup | Scheduled}] [-DelayedCatalogStartAt <DateTime>] [-UseOffhostBackup <Boolean>] [-OffhostBackupSnapshotProvider {Automatic | Software | Hardware}] [-FailIfNoOffhostBackup <Boolean>] [-DelayedCatalogDaysOfWeek {Sunday | Monday | Tuesday | Wednesday | Thursday | Friday | Saturday}] [-FileSystemBackupRemoteStorage <Boolean>] [-FileSystemBackupOpenFile {Never | IfClosedWithinSpecifiedTime | WithALock | WithoutALock}] [-FileSystemBackupOpenFileIfClosedWithinSeconds <UInt32>] [-FileSystemEnableNtfsSingleInstanceBackup <Boolean>] [-FileSystemFollowJunctionPoint <Boolean>] [-FileSystemFollowSymbolicLink <Boolean>] [-ProcessLogicalVolumesSequentially <Boolean>] [-RestrictToBackupExecServer <BEBackupExecServer>] [-RestrictToBackupExecServersInPool <BEBackupExecServerPool>] [-NetworkInterface <BENetworkInterface>] [-Description <String>] [-Priority {Normal | Lowest | Low | High | Highest}] [-NetworkProtocol {AnyAvailable | IPv4 | IPv6}] [-UseSnapshotTechnology <Boolean>] [-SnapshotTechnology {Automatic | MicrosoftVolumeShadowCopyService}] [-SnapshotProvider {Automatic | System | Software | Hardware}] [-NetworkSubnet <BENetworkInterfaceSubnet>] [-AllowAnyNetworkForAgentAccess <Boolean>] [-EnableCheckpointRestart <Boolean>] [-VirtualMachineEnableIRForAll <Boolean>] [-VirtualMachineUseGrtForFileSystem <Boolean>] [-VirtualMachineUseGrtForActiveDirectory <Boolean>] [-OracleMaximumNumberOfDevicesToUseForResources <UInt32>] [-OracleMinimumNumberOfDevicesRequiredForJob <UInt32>] [-VirtualMachineBackupPoweredOffVirtualMachine <Boolean>] [-VirtualMachineUseGrtForExchange <Boolean>] [-VMwareTransportModePriority {SAN | NBD | NBDSSL | Hotadd}] [-VMwareVSpherePort <UInt32>] [-NdmpEMCBackupType {Dump | VBB}] [-VirtualMachineUseGrtForSql <Boolean>] [-VirtualMachineUseGrtForSharePoint <Boolean>] [-HyperVExcludeVirtualMachinesNeedingSavedState <Boolean>] [-ActiveDirectoryUseGrt <Boolean>] [-ExchangePreferredServerGroup <BEPreferredServerGroup>] [-SharePointReleaseLockOnFarmTopology <Boolean>] [-SharePointPreConsistencyCheck <Boolean>] [-ExchangePreConsistencyCheck <Boolean>] [-ExchangeContinueIfConsistencyCheckIsUnsuccessful <Boolean>] [-ExchangeHighAvailability {FromPassiveCopyIfAvailableOtherwiseActiveCopy | FromPassiveCopyOnly | FromActiveCopyOnly | FromPassiveCopyIfAvailableOtherwiseActiveCopyUsePreferredServers}] [-SharePointContinueIfConsistencyCheckIsUnsuccessful <Boolean>] [-LinuxMacLockRemoteFile <Boolean>] [-ActiveDirectoryPreConsistencyCheck <Boolean>] [-ActiveDirectoryContinueIfConsistencyCheckIsUnsuccessful <Boolean>] [-LinuxMacPreserveChangeTime <Boolean>] [-LinuxMacFollowLocalMountPoint <Boolean>] [-LinuxMacFollowRemoteMountPoint <Boolean>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

ワンタイムバックアップジョブのプロパティを設定します。

Parameters

-InputObject <BEOneTimeBackupJob[]>

1 つ以上の 1 回限りのバックアップオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | 1
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-ClearExistingSelection <SwitchParameter>

既存のバックアップの選択をクリアします。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SelectionList <BEAgentServerBackupSelectionList[]>

バックアップする選択項目のリストを指定します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableSimplifiedDisasterRecovery <Boolean>

簡易システムリカバリを有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

バックアップジョブの説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SystemStateSelection

システム状態をバックアップ定義に含める、またはバックアップ定義から除外します。

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemSelection <BEFileSystemSelection[]>

1 つ以上のファイルシステムの選択項目をバックアップ定義に含める、またはバックアップ定義から除外します。含めるファイルまたはディレクトリを指定するには、1 つまたは複数のパスを、カンマを使用して値を区切って指定します。除外するファイルまたはディレクトリを指定するには、-Exclude パラメータと一緒に New-BEFileSystemSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeStorageGroupDatabaseSelection <BEExchangeStorageGroupDatabaseSelection[]>

1 つ以上の Exchange 2003 ストレージのグループまたはデータベースをバックアップ定義に含める、またはバックアップ定義から除外します。含めるストレージグループを指定するには、1 つまたは複数のストレージグループ名を、カンマを使用して値を区切って指定します。「*」を指定するとすべてのストレージグループが含まれます。除外するストレージグループを指定したり、含めるまたは除外するデータベースを個別に指定するには、-Exclude パラメータと一緒に New-BEExchangeStorageGroupDatabaseSelection の出力を使用します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeDatabaseSelection <BEExchangeDatabaseSelection[]>

1 つ以上の Exchange 2007 以降のデータベースをバックアップ定義に含める、またはバックアップ定義から除外します。含めるデータベースを指定するには、1 つまたは複数のデータベース名を、カンマを使用して値を区切って指定します。「*」を指定するとすべてのデータベースが含まれます。除外するデータベースを指定するには、-Exclude パラメータと一緒に New-BEExchangeDatabaseSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlDatabaseSelection <BESqlDatabaseSelection[]>

1 つ以上の SQL インスタンスまたは SQL データベースをバックアップ定義に含める、またはバックアップ定義から除外します。含める SQL インスタンスを指定するには、1 つまたは複数の SQL インスタンス名を、カンマを使用して値を区切って指定します。「*」を指定するとすべての SQL インスタンスが含まれます。除外する SQL インスタンスを指定したり、含めるまたは除外するデータベースを個別に指定するには、-Exclude パラメータと一緒に New-BESqlDatabaseSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointAllResourcesSelection

Windows コンピュータをバックアップするときに、すべての SharePoint リソースをカテゴリ別にバックアップ定義に含める、またはバックアップ定義から除外します。

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointConfigurationDatabaseSelection

SharePoint 設定データベースをバックアップ定義に含める、またはバックアップ定義から除外します。

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointGlobalSettingsSelection

SharePoint のグローバル設定データベースをバックアップ定義に含める、またはバックアップ定義から除外します。

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointCentralAdministrationWebApplicationSelection

SharePoint Central Administration Web アプリケーションをバックアップ定義に含める、またはバックアップ定義から除外します。

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointInfoPathServicesSelection

SharePoint InfoPath サービスをバックアップ定義に含める、またはバックアップ定義から除外します。

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointHelpSearchSelection

SharePoint ヘルプ検索をバックアップ定義に含める、またはバックアップ定義から除外します。

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointSingleSignOnDatabaseSelection

SharePoint シングルサインオンデータベースをバックアップ定義に含める、またはバックアップ定義から除外します。

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointWebApplicationSelection <BESharePointWebApplicationSelection[]>

1 つ以上の SharePoint Web アプリケーションをバックアップ定義に含める、またはバックアップ定義から除外します。含める Web アプリケーションを指定するには、1 つまたは複数の Web アプリケーション名を、カンマを使用して値を区切って指定します。「*」を指定すると、すべての Web アプリケーションが含まれます。 除外する Web アプリケーションを指定するには、-Exclude パラメータと一緒に New-BESharePointWebApplicationSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointServiceApplicationSelection <BESharePointServiceApplicationSelection[]>

1 つ以上の SharePoint サービスアプリケーションをバックアップ定義に含める、またはバックアップ定義から除外します。 含めるサービスアプリケーションを指定するには、1 つまたは複数のサービスアプリケーション名を、カンマを使用して値を区切って指定します。「*」を指定すると、すべてのサービスアプリケーションが含まれます。 除外するサービスアプリケーションを指定するには、-Exclude パラメータと一緒に New-BESharePointServiceApplicationSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointServiceApplicationProxySelection <BESharePointServiceApplicationProxySelection[]>

1 つ以上の SharePoint サービスアプリケーションプロキシをバックアップ定義に含める、またはバックアップ定義から除外します。含めるサービスアプリケーションプロキシを指定するには、1 つまたは複数のサービスアプリケーションプロキシ名を、カンマを使用して値を区切って指定します。「*」を指定すると、すべてのサービスアプリケーションプロキシが含まれます。除外するサービスアプリケーションプロキシを指定するには、-Exclude パラメータと一緒に New-BESharePointServiceApplicationProxySelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointSharedServiceApplicationSelection <BESharePointSharedServiceApplicationSelection[]>

1 つ以上の SharePoint 共有サービスアプリケーションをバックアップ定義に含める、またはバックアップ定義から除外します。含める共有サービスアプリケーションを指定するには、1 つまたは複数の共有サービスアプリケーション名を、カンマを使用して値を区切って指定します。「*」を指定すると、すべての共有サービスアプリケーションが含まれます。除外する共有サービスアプリケーションを指定するには、-Exclude パラメータと一緒に New-BESharePointSharedServiceApplicationSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointSharedServiceApplicationProxySelection <BESharePointSharedServiceApplicationProxySelection[]>

1 つ以上の SharePoint 共有サービスアプリケーションプロキシをバックアップ定義に含める、またはバックアップ定義から除外します。 含める共有サービスアプリケーションプロキシを指定するには、1 つまたは複数の共有サービスアプリケーションプロキシ名を、カンマを使用して値を区切って指定します。「*」を指定すると、すべての共有サービスアプリケーションプロキシが含まれます。除外する共有サービスアプリケーションプロキシを指定するには、-Exclude パラメータと一緒に New-BESharePointSharedServiceApplicationProxySelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointSharedServiceProviderSelection <BESharePointSharedServiceProviderSelection[]>

1 つ以上の SharePoint 共有サービスプロバイダをバックアップ定義に含める、またはバックアップ定義から除外します。含める共有サービスプロバイダを指定するには、1 つまたは複数の共有サービスプロバイダ名を、カンマを使用して値を区切って指定します。除外する共有サービスプロバイダを指定するには、-Exclude パラメータと一緒に New-BESharePointSharedServiceProviderSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointPortalSiteSelection <BESharePointPortalSiteSelection[]>

1 つ以上の SharePoint ポータルサイトをバックアップ定義に含める、またはバックアップ定義から除外します。含めるポータルサイトを指定するには、1 つまたは複数のポータルサイト名を、カンマを使用して値を区切って指定します。除外するポータルサイトを指定するには、-Exclude パラメータと一緒に New-BESharePointPortalSiteSelection の出力を使い、1 つ以上の除外するポータルサイトをこのパラメータに渡します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointServiceSiteSelection <BESharePointServiceSiteSelection[]>

1 つ以上の SharePoint サービスサイトをバックアップ定義に含める、またはバックアップ定義から除外します。 含めるサービスサイトを指定するには、1 つまたは複数のサービスサイト名を、カンマを使用して値を区切って指定します。除外するサービスサイトを指定するには、-Exclude パラメータと一緒に New-BESharePointServiceSiteSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LinuxMacSelection <BELinuxMacSelection[]>

1 つ以上の Linux サーバーまたは Macintosh システムをバックアップ定義に含める、またはバックアップ定義から除外します。 含めるファイルまたはディレクトリを指定するには、1 つまたは複数のパスを、カンマを使用して値を区切って指定します。除外するファイルまたはディレクトリを指定するには、-Exclude パラメータと一緒に New-BELinuxMacSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleSelection <BEOracleSelection[]>

1 つ以上の Oracle の選択項目をバックアップ定義に含める、またはバックアップ定義から除外します。含めるデータベースまたは表スペースを指定するには、1 つまたは複数のパスを、カンマを使用して値を区切って指定します。除外するデータベースまたは表スペースを指定するには、-Exclude パラメータと一緒に New-BEOracleSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-HyperVSelection <BEHyperVSelection[]>

1 つ以上の Hyper-V 仮想マシンをバックアップ定義に含める、またはバックアップ定義から除外します。含める仮想マシンを指定するには、1 つまたは複数の仮想マシン名を、カンマを使用して値を区切って指定します (「*」を指定するとすべての Hyper-V 仮想マシンが含められます)。除外する仮想マシンを指定するには、New-BEHyperVSelection の出力とともに -Exclude パラメータを使用して、最初にすべての仮想マシンを含め、次に除外する対象を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VMwareSelection <BEVMwareSelection[]>

1 つ以上の VMware サーバーをバックアップ定義に含める、またはバックアップ定義から除外します。含める VMware サーバーを指定するには、1 つまたは複数の VMware サーバー名を、カンマを使用して値を区切って指定します。 除外する VMware サーバーを指定するには、New-BEVMwareSelection の出力とともに -Exclude パラメータを使用します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UtilityPartitionSelection <BEUtilityPartitionSelection[]>

1 つ以上のユーティリティパーティションをバックアップ定義に含める、またはバックアップ定義から除外します。含めるユーティリティパーティションを指定するには、1 つまたは複数のパスを、カンマを使用して値を区切って指定します。除外するユーティリティパーティションを指定するには、-Exclude パラメータと一緒に New-BEUtilityPartitionSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnterpriseVaultDirectorySelection <BEEnterpriseVaultDirectorySelection[]>

1 つ以上の Enterprise Vault Directory リソースをバックアップ定義に含める、またはバックアップ定義から除外します。 含める Enterprise Vault Directory リソースを指定するには、1 つまたは複数のリソース名を、カンマを使用して値を区切って指定します。除外するリソースを指定するには、New-BEEnterpriseVaultDirectorySelection の出力とともに -Exclude パラメータを使用します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnterpriseVaultComplianceAcceleratorSelection <BEEnterpriseVaultComplianceAcceleratorSelection[]>

1 つ以上の Enterprise Vault Compliance の Accelerator データベースをバックアップ定義に含める、またはバックアップ定義から除外します。含める Enterprise Vault Compliance の Accelerator データベースを指定するには、1 つまたは複数のデータベース名を、カンマを使用して値を区切って指定します。除外するデータベースを指定するには、New-BEEnterpriseVaultComplianceAcceleratorSelection の出力とともに -Exclude パラメータを使用します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnterpriseVaultDiscoveryAcceleratorSelection <BEEnterpriseVaultDiscoveryAcceleratorSelection[]>

1 つ以上の Enterprise Vault Discovery の Accelerator データベースをバックアップ定義に含める、またはバックアップ定義から除外します。 含める Enterprise Vault Discovery の Accelerator データベースを指定するには、1 つまたは複数のデータベース名を、カンマを使用して値を区切って指定します。除外するデータベースを指定するには、New-BEEnterpriseVaultDiscoveryAcceleratorSelection の出力とともに -Exclude パラメータを使用します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ActiveDirectoryApplicationModeSelection <BEActiveDirectoryApplicationModeSelection[]>

1 つ以上の Active Directory Application Mode インスタンスをバックアップ定義に含める、またはバックアップ定義から除外します。含めるインスタンスを指定するには、1 つまたは複数のパスを、カンマを使用して値を区切って指定します。除外するインスタンスを指定するには、-Exclude パラメータと一緒に New-BEActiveDirectoryLightweightDirectoryServiceSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OpenEnterpriseServerSelection <BEOpenEnterpriseServerSelection[]>

1 つ以上の OES コンポーネントをバックアップ定義に含める、またはバックアップ定義から除外します。含めるファイルまたはディレクトリを指定するには、1 つまたは複数のパスを、カンマを使用して値を区切って指定します。除外するファイルまたはディレクトリを指定するには、-Exclude パラメータと一緒に New-BEOpenEnterpriseServerSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Priority

ジョブを実行する順序を指定します。2 つのジョブが同時に実行されるようにスケジュールされている場合、ユーザーが設定する優先度でどちらが先に実行されるかが決まります。

The valid values are:
Normal
Lowest
Low
High
Highest

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RestrictToBackupExecServer <BEBackupExecServer>

CASO 環境でジョブをディスパッチ可能な Backup Exec サーバーを指定します。RestrictToBackupExecServersInPool が指定されている場合は指定できません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RestrictToBackupExecServersInPool <BEBackupExecServerPool>

CASO 環境でジョブをディスパッチ可能な Backup Exec サーバーのセットを指定します。RestrictToBackupExecServer が指定されている場合は指定できません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NetworkInterface <BENetworkInterface>

バックアップネットワークとして使用するネットワークに対して Backup Exec サーバーを接続する、ネットワークインターフェースカードの名前を指定します。Get-BENetworkInterface を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NetworkProtocol

リモートコンピュータをバックアップするために使うプロトコルを指定します。

The valid values are:
AnyAvailable
IPv4
IPv6

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NetworkSubnet <BENetworkInterfaceSubnet>

Get-BENetworkInterface によって返されたネットワークインターフェースのサブネットの 1 つを使用して、リモートコンピュータをバックアップするために使うサブネットを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AllowAnyNetworkForAgentAccess <Boolean>

バックアップまたはリストアのために選択したリモートコンピュータが、指定したバックアップネットワークの一部でない場合に、リモートコンピュータからのデータが任意の利用可能なネットワークを介してバックアップまたはリストアされるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableCheckpointRestart <Boolean>

ジョブが中断された時点からバックアップジョブを続行可能にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UseSnapshotTechnology <Boolean>

スナップショットテクノロジの利用を有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SnapshotTechnology

スナップショットテクノロジを有効にしたときに使用する、スナップショットテクノロジを指定します。UseSnapshotTechnology は $true に設定する必要があります。

The valid values are:
Automatic
MicrosoftVolumeShadowCopyService

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SnapshotProvider

スナップショットテクノロジを有効にしたときに使用するスナップショットプロバイダとして、Microsoft ボリュームシャドウコピーサービスを指定します。UseSnapshotTechnology を $true に設定し、SnapshotTechnology を MicrosoftVolumeShadowCopyService に設定する必要があります。

The valid values are:
Automatic
System
Software
Hardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ProcessLogicalVolumesSequentially <Boolean>

1 つのジョブで複数のボリュームをバックアップすることを有効にします。このとき、一度に 1 つの論理ボリュームのスナップショットのみが作成されます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UseOffhostBackup <Boolean>

オフホストバックアップを有効にします。有効な場合は、すべての必要条件が満たされると、すべてのボリュームのオフホストバックアップが実行されます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OffhostBackupSnapshotProvider

使用するオフホストバックアップのスナップショットプロバイダを指定します。UseOffhostBackup は $true に設定する必要があります。

The valid values are:
Automatic
Software
Hardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FailIfNoOffhostBackup <Boolean>

選択したボリュームのいずれかがオフホストバックアップをサポートしない場合、またはスナップショットやボリュームのインポートでエラーが発生した場合、バックアップジョブを終了します。 UseOffhostBackup は $true に設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ProcessOffhostLogicalVolumesSequentially <Boolean>

1 つのジョブで複数のボリュームをバックアップすることを可能にします。このとき、オフホストバックアップに対して一度に 1 つの論理ボリュームのスナップショットのみが作成されます。UseOffhostBackup は $true に設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DelayedCatalogScheduleType

実行する延期したカタログ操作の代替日または時間を指定します。

The valid values are:
NoDelayedCatalog
ImmediatelyAfterBackup
Scheduled

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DelayedCatalogStartAt <DateTime>

遅延カタログジョブを実行する時刻を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DelayedCatalogDaysOfWeek

遅延カタログジョブを実行する曜日を指定します。

The valid values are:
Sunday
Monday
Tuesday
Wednesday
Thursday
Friday
Saturday

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemEnableNtfsSingleInstanceBackup <Boolean>

Backup Exec で同一ファイルに対して NTFS ボリュームをチェックできるようにします。ファイルのコピーが複数見つかった場合は、そのファイルの 1 つのインスタンスのみが Backup Exec によってバックアップされます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemFollowJunctionPoint <Boolean>

接合点の情報とリンク先のファイルおよびディレクトリをバックアップします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemFollowSymbolicLink <Boolean>

シンボリックリンクの情報とリンク先のファイルとディレクトリの情報をバックアップします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemBackupRemoteStorage <Boolean>

プライマリストレージからセカンダリストレージに移動したデータをバックアップします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemBackupOpenFile

スナップショットテクノロジが使用されていない場合に Backup Exec がバックアップジョブでオープンファイルを処理する方法を指定します。

The valid values are:
Never
IfClosedWithinSpecifiedTime
WithALock
WithoutALock

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemBackupOpenFileIfClosedWithinSeconds <UInt32>

オープンファイルをスキップしてバックアップジョブを続行する前に Backup Exec が待機する秒数を指定します。BackupOpenFile が IfClosedWithinSpecifiedTime に設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangePreConsistencyCheck <Boolean>

バックアップジョブを実行する前に一貫性チェックを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeContinueIfConsistencyCheckIsUnsuccessful <Boolean>

一貫性チェックに失敗した場合でもバックアップジョブを続行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeHighAvailability

Exchange 2007 以降のバックアップソースを指定します。

The valid values are:
FromPassiveCopyIfAvailableOtherwiseActiveCopy
FromPassiveCopyOnly
FromActiveCopyOnly
FromPassiveCopyIfAvailableOtherwiseActiveCopyUsePreferredServers

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangePreferredServerGroup <BEPreferredServerGroup>

Exchange 2010 Database Availability Group (DAG) のバックアップに使用する優先サーバーグループを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointReleaseLockOnFarmTopology <Boolean>

バックアップジョブを実行する前に SharePoint ファームトポロジーのロックを解除します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointPreConsistencyCheck <Boolean>

Microsoft SharePoint で使用する Microsoft SQL データベースをバックアップする前に、インデックスを含む完全な一貫性チェックを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointContinueIfConsistencyCheckIsUnsuccessful <Boolean>

一貫性チェックに失敗した場合でもバックアップジョブを続行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LinuxMacPreserveChangeTime <Boolean>

バックアップジョブの実行時に Agent for Windows でオブジェクトの属性が変更されないようにします。オブジェクトはファイルまたはディレクトリです。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LinuxMacFollowLocalMountPoint <Boolean>

データのバックアップ時に Backup Exec でローカルマウントポイントをたどることができます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LinuxMacFollowRemoteMountPoint <Boolean>

データのバックアップ時に Backup Exec でリモートマウントポイントをたどることができます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LinuxMacLockRemoteFile <Boolean>

ネットワークファイルシステム (NFS) を介して接続されたリモートコンピュータのファイルに Agent for Windows で排他的にアクセスできます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ActiveDirectoryPreConsistencyCheck <Boolean>

スナップショットにデータ破損がないかを確認します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ActiveDirectoryContinueIfConsistencyCheckIsUnsuccessful <Boolean>

一貫性チェックが失敗してもバックアップジョブの続行を可能にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ActiveDirectoryUseGrt <Boolean>

Active Directory の完全バックアップから個々の項目をリストアできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleMaximumNumberOfDevicesToUseForResources <UInt32>

バックアップジョブで使用できる最大デバイス数を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleMinimumNumberOfDevicesRequiredForJob <UInt32>

ジョブで使用できる最小デバイス数を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineBackupPoweredOffVirtualMachine <Boolean>

オフになった仮想マシンを Backup Exec でバックアップできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineEnableIRForAll <Boolean>

GRT の対象外を含むすべての仮想マシンでインスタントリカバリを有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForFileSystem <Boolean>

完全バックアップジョブから個々のファイルとフォルダをリストアできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForActiveDirectory <Boolean>

Backup Exec で仮想マシン上の個々の Active Directory オブジェクトをリストアするのに必要な情報を収集できるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForExchange <Boolean>

Backup Exec で仮想マシン上の個々の Exchange データベースおよびメールボックス項目をリストアするのに必要な情報を収集できるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForSql <Boolean>

Backup Exec で仮想マシン上の個々の SQL データベース項目をリストアするのに必要な情報を収集できるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForSharePoint <Boolean>

Backup Exec で仮想マシン上の SharePoint データをリストアするのに必要な情報を収集できるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-HyperVExcludeVirtualMachinesNeedingSavedState <Boolean>

オンラインバックアップをサポートしない、バックアップの開始時に実行状態であるすべてのオフライン仮想マシンを除外します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VMwareTransportModePriority

Backup Exec で使用する 1 つ以上の VMware 転送モードを優先度順に指定します。

The valid values are:
SAN
NBD
NBDSSL
Hotadd

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VMwareVSpherePort <UInt32>

Backup Exec で使用する VMware vSphere ポートを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NdmpEMCBackupType

EMC NDMP サーバーのバックアップタイプを指定します。

The valid values are:
Dump
VBB

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NdmpEMCBackupWithIntegratedCheckpoints <Boolean>

Backup Exec で EMC SnapSure 機能を使用するように設定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NdmpEMCEnableFileHistory <Boolean>

EMC NDMP サーバーに関するファイルの履歴データの生成を可能にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NdmpNetAppBackupAccessControlLists <Boolean>

NetApp アクセス制御リストをバックアップします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NdmpNetAppEnableFileHistory <Boolean>

NetApp NDMP サーバーに関するファイルの履歴データの生成を可能にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Storage <BEStorage>

バックアップジョブに使用するストレージデバイスを指定します。 Get-BEStorage を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaSet <BEMediaSet>

メディアと関連付けるメディアセットを指定します。メディアはメディアセットの設定に基づいて上書きから保護されます。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。 Get-BEMediaSet を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMedia <Boolean>

ジョブの完了後にデバイスからメディアをエクスポートします。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMediaToVault <BEMediaVault>

ジョブの完了後にメディアを指定したボルトに論理的に移動します。Storage パラメータはテープベースのストレージデバイスに設定し、TapeStorageExportMedia は $true に設定する必要があります。Get-BEMediaVault を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEjectMediaAfterComplete <Boolean>

ジョブの完了後にストレージデバイスからメディアを取り出します。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableWriteOnceReadManyMedia <Boolean>

バックアップジョブに WORM (Write Once Read Many) メディアの使用を指定します。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableDirectCopyToTape <Boolean>

物理テープデバイスに仮想テープライブラリから直接データをコピーできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageRetensionMediaBeforeBackup <Boolean>

データを書き込む前にメディアのリテンションを行います。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskStorageKeepForHours <Int32>

メディアへの上書きを禁止し、このメディア上にデータを保存する時間を指定します。 Storage パラメータがディスクベースのストレージデバイスに設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SubmitOnHold <Boolean>

ジョブを保留状態でサブミットします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupSetDescription <String>

バックアップしたデータとその格納場所についての説明です。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

予定開始時刻の経過後に、ジョブが未処理であると Backup Exec が判断し、そのジョブのスケジュール再設定が可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

予定開始時刻後にジョブの実行が続行されている場合、そのジョブのキャンセルが可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NotificationRecipientList <BENotificationRecipientObject[]>

ジョブが完了したときに通知を受け取る受信者を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IncludeJobLogWithEmailNotification <Boolean>

電子メールにジョブログを添付します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageCompressionMethod

使用するソフトウェアデータ圧縮またはハードウェアデータ圧縮の種類を指定します。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
None
SoftwareIfNoHardware
HardwareOnly
SoftwareOnly

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaAppendMethod

ジョブの開始時にメディアに上書きまたは追記します。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
Append
AppendOnly
Overwrite

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableDirectAccessIfAvailable <Boolean>

Agent for Windows から Storage パラメータで指定したデバイスにバックアップデータを直接送信できるようにします (デバイスがこの操作をサポートしている場合)。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-StartDate <DateTime>

ジョブを開始する日時を指定します。 このパラメータを指定しない場合、ジョブはすぐに開始されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreCommand <String>

バックアップジョブの前に実行するコマンドを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PostCommand <String>

バックアップジョブの後に実行するコマンドを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PrePostCommandSuccessfulIfReturnsZero <Boolean>

Backup Exec によってプリコマンドまたはポストコマンドの戻りコードを確認し、コマンドが正しく完了したかどうかを調べることができます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunJobOnlyIfPreCommandIsSuccessful <Boolean>

プリコマンドが正しく実行された場合にのみバックアップジョブを実行します。プリコマンドの実行に失敗した場合は、ジョブは実行されません。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>

プリコマンドが正しく実行された場合にのみポストコマンドを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>

ジョブが正しく実行されなかった場合でもポストコマンドを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandAfterVerification <Boolean>

バックアップジョブの検証を選択した場合、検証が完了した後にポストコマンドを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>

完了しなかったプリコマンドまたはポストコマンドをキャンセルするのに待つ時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunCommandLocation

プリコマンドとポストコマンドが実行される場所を指定します。

The valid values are:
OnEachAgentServer
OnBackupExecServer

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Verify

バックアップジョブの完了時に自動的に検証操作を実行します。

The valid values are:
None
AsPartOfJob
AsSeparateJobImmediatelyAfter

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableDirectAccessForVerifyJobIfAvailable <Boolean>

Agent for Windows でデータを検証するかどうかを指定します (Storage パラメータで指定したデバイスがこの操作をサポートしている場合)。 Verify パラメータが AsSeparateJobImmediatelyAfter に設定されている必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VerifyJobNotificationRecipientList <BENotificationRecipientObject[]>

検証ジョブが完了したときに通知を受け取る受信者を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VerifyJobIncludeJobLogWithEmailNotification <Boolean>

電子メールに検証ジョブログを添付します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionType

バックアップジョブに使用する暗号化の種類を指定します。

The valid values are:
None
Software
Hardware
SoftwareIfNoHardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionKey <BEEncryptionKey>

使用する暗号化キーを指定します。 EncryptionType が None 以外の値に設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeUseGrt <Boolean>

インフォメーションストアのバックアップジョブから個々の項目をリストアできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlPreConsistencyCheckMethod

バックアップジョブを実行する前に行う一貫性チェックの種類を指定します。

The valid values are:
None
Physical
FullExcludingIndexes
FullIncludingIndexes

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlContinueIfConsistencyCheckUnsuccessful <Boolean>

一貫性チェックに失敗した場合でもバックアップジョブを続行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlPostConsistencyCheck

バックアップジョブを実行した後に行う一貫性チェックの種類を指定します。

The valid values are:
None
Physical
FullExcludingIndexes
FullIncludingIndexes

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlUseChecksumOnBackup <Boolean>

SQL 2005 以降の場合、バックアップする SQL データベースのデータにチェックサムを追加します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlCreateDiskCopy <Boolean>

バックアップする SQL データベースのコピーをディスク上に作成します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlDiskCopyPath <String>

バックアップする SQL データベースのディスク上に作成されるコピーのパスを指定します。CreateDiskCopy が $true に設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlUseSoftwareCompression <Boolean>

SQL 2008以降の場合、使用する圧縮設定を指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointUseGrt <Boolean>

データベースバックアップからの個々のドキュメント、イメージ、サイト、サブサイト、リスト、リストの項目のリストアを有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleDeleteBackedUpArchivedLogFile <Boolean>

バックアップ後にアーカイブログファイルを自動的に削除できます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleSkipBackedUpArchivedLogFile <Boolean>

以前にバックアップしたアーカイブログファイルを Backup Exec がスキップできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OraclePerformBackupOffline <Boolean>

バックアップジョブを開始する前に Backup Exec がデータベースをオフラインにすることを可能にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DeleteSelectedFilesAfterSuccessfulBackup

選択したデータをバックアップし、メディアの検証を行った後、ボリュームからデータを削除します。この操作でファイルを削除してデータを回復するにはリストアを実行する必要があるため、このオプションを有効にした場合は Force パラメータを指定する必要があります。

The valid values are:
Never
FilesOnly
FilesAndFolders

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlBackupMethod

このバックアップジョブに使用する SQL バックアップ方式を指定します。

The valid values are:
FullCopy
DatabaseSnapshot
LogNoTruncate
Log
Full

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlAdvancedLogBackupOption

このバックアップジョブに使用する高度なログバックアップオプションを指定します。

The valid values are:
None
NoRecover
Standby

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEOneTimeBackupJob

Backup Exec ワンタイムバックアップジョブオブジェクトを Set-BEOneTimeBackupJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEOneTimeBackupJob

Set-BEOneTimeBackupJob は、変更された Backup Exec ワンタイムバックアップジョブを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEOneTimeBackupJob "Backup 01" | Set-BEOneTimeBackupJob -FileSystemSelection D:\*

これらのコマンドは、「Backup 01」という名前のワンタイムバックアップジョブでの現在の選択項目に、D:\* をバックアップ選択項目として追加します。

Example 2
C:\PS> Get-BEOneTimeBackupJob "Backup 01" | Set-BEOneTimeBackupJob -ClearExistingSelection -FileSystemSelection D:\*

これらのコマンドは「Backup 01」という名前のワンタイムバックアップジョブにおける唯一のバックアップ選択項目として D:\* を設定します。

Related Links

New-BEFileSystemSelection
New-BEUtilityPartitionSelection
New-BELinuxMacSelection
New-BEOpenEnterpriseServerSelection
New-BEOracleSelection
New-BEExchangeStorageGroupDatabaseSelection
New-BEExchangeDatabaseSelection
New-BESqlDatabaseSelection
New-BESharePointWebApplicationSelection
New-BESharePointServiceApplicationSelection
New-BESharePointServiceApplicationProxySelection
New-BESharePointSharedServiceApplicationSelection
New-BESharePointSharedServiceApplicationProxySelection
New-BESharePointSharedServiceProviderSelection
New-BESharePointPortalSiteSelection
New-BESharePointServiceSiteSelection
Get-BENetworkInterface
New-BEHyperVSelection
New-BEVMwareSelection
Get-BEStorage
Get-BEMediaSet
Get-BEMediaVault
New-BEEnterpriseVaultDirectorySelection
New-BEEnterpriseVaultComplianceAcceleratorSelection
New-BEEnterpriseVaultDiscoveryAcceleratorSelection
Get-BEOneTimeBackupJob


Set-BEOpenStorageDevice Help

Set-BEOpenStorageDevice Cmdlet
Synopsis

Backup Exec OpenStorage デバイスのプロパティを設定します。

Syntax
Set-BEOpenStorageDevice -InputObject <BEOpenStorageDevice[]> [-ClientSideDeduplicationEnabled <Boolean>] [-IsStreamHandlerSupportEnabled <Boolean>] [-DataStreamSizeBytes <Int32>] [-DiskSpaceReserveBytes <Int64>] [-SplitDataStreamBytes <Int64>] [-Description <String>] [-LogonAccount <BELogonAccount>] [-PreferredBackupServer <BEBackupExecServer>] [-AllowedConcurrentOperations <Int32>] [-Paused <Boolean>] [-Disabled <Boolean>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec OpenStorage デバイスのプロパティを設定します。

Parameters

-PreferredBackupServer <BEBackupExecServer>

Central Admin Server Option 環境で OpenStorage デバイスがサーバー間で共有される場合にバックアップ操作を実行するサーバーを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LogonAccount <BELogonAccount>

新しい OpenStorage デバイスの Backup Exec ログオンアカウントを指定します。 このログオンアカウントにシステムログオンアカウントは使用できません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

OpenStorage デバイスの説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Disabled <Boolean>

OpenStorage デバイスを無効にするかどうかを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Paused <Boolean>

OpenStorage デバイスを一時停止するかどうかを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AllowedConcurrentOperations <Int32>

このデバイスで許可される最大許容並列書き込み処理を設定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SplitDataStreamBytes <Int64>

Backup Exec が新しいイメージにスパンするサイズを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DataStreamSizeBytes <Int32>

Backup Exec が行う単一書き込み操作のサイズを示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IsStreamHandlerSupportEnabled <Boolean>

ストリームハンドラを使用するかどうかを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ClientSideDeduplicationEnabled <Boolean>

クライアント側の重複排除をこの OpenStorage デバイスで有効にするかどうかを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskSpaceReserveBytes <Int64>

Backup Exec 以外のアプリケーション用に空けてあるディスク領域を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEOpenStorageDevice[]>

1 つ以上の OpenStorage デバイスオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEOpenStorageDevice

Backup Exec OpenStorage デバイスオブジェクトを Set-BEOpenStorageDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEOpenStorageDevice

Set-BEOpenStorageDevice は変更された Backup Exec OpenStorage デバイスを表すオブジェクトを返します。

Example

C:\PS> Get-BEOpenStorageDevice "Device 0001" | Set-BEOpenStorageDevice -Paused $true

これらのコマンドは「Device 0001」という名前の OpenStorage デバイスを一時停止します。

Related Link

Get-BEOpenStorageDevice


Set-BEPreferredServerGroup Help

Set-BEPreferredServerGroup Cmdlet
Synopsis

Backup Exec の優先サーバー設定のプロパティを設定します。

Syntax
Set-BEPreferredServerGroup -InputObject <BEPreferredServerGroup[]> [-ServerList <String[]>] [-IsDefault <Boolean>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec の優先サーバー設定のプロパティを設定します。

Parameters

-ServerList <String[]>

Backup Exec がデータベースのバックアップに使用できる Microsoft Exchange サーバー。Backup Exec は、このリストに追加されたサーバーの順序に基づいてサーバーを使用します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IsDefault <Boolean>

優先サーバーグループがデフォルトのサーバーグループであることを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEPreferredServerGroup[]>

1 つ以上の優先サーバー設定オブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEPreferredServerGroup

Backup Exec 優先サーバーグループ設定を Set-BEPreferredServerGroup にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEPreferredServerGroup

Set-BEPreferredServerGroup は、変更された Backup Exec 優先サーバー設定を表すオブジェクトを返します。

Example

C:\PS> Get-BEPreferredServerGroup "ServerGroup1" | Set-BEPreferredServerGroup -ServerList @("Server3", "Server4")

このコマンドは ServerGroup1 のサーバーリストを Server3 および Server4 に設定します。

Related Link

Get-BEPreferredServerGroup


Set-BERemoteMediaAgentForLinux Help

Set-BERemoteMediaAgentForLinux Cmdlet
Synopsis

Remote Media Agent for Linux のプロパティを設定します。

Syntax
Set-BERemoteMediaAgentForLinux -InputObject <BERemoteMediaAgentForLinux[]> [-Disabled <Boolean>] [-Port <Int32>] [-LogonAccount <BELogonAccount>] [-Description <String>] [-UseICMPPingOption <Boolean>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec Remote Media Agent for Linux のプロパティを設定します。

Parameters

-LogonAccount <BELogonAccount>

Remote Media Agent for Linux で使用するログオンアカウントオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BELogonAccount を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

Remote Media Agent for Linux の説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UseICMPPingOption <Boolean>

Internet Control Message Protocol で Remote Media Agent for Linux を検索するように設定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Port <Int32>

Remote Media Agent for Linux に接続するために使用するポートを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Disabled <Boolean>

Remote Media Agent for Linux を無効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BERemoteMediaAgentForLinux[]>

1 つ以上の Remote Media Agent for Linux サーバーオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BERemoteMediaAgentForLinux

Backup Exec Remote Media Agent for Linux サーバーオブジェクトを Set-BERemoteMediaAgentForLinux にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BERemoteMediaAgentForLinux

Set-BERemoteMediaAgentForLinux は、変更された Backup Exec Remote Media Agent for Linux を表すオブジェクトを返します。

Example

C:\PS> Get-BERemoteMediaAgentForLinux -Name "MyServer.mycompany.com" | Set-BERemoteMediaAgentForLinux -Port 10001

このコマンドは「MyServer.mycompany.com」という名前の Remote Media Agent for Linux サーバーのポートを 10001 に設定します。

Related Links


Set-BERoboticLibraryDevice Help

Set-BERoboticLibraryDevice Cmdlet
Synopsis

Backup Exec のロボットライブラリデバイスのプロパティを設定します。

Syntax
Set-BERoboticLibraryDevice -InputObject <BERoboticLibraryDevice[]> [-SlotsNumbersAreZeroBased <Boolean>] [-BarcodeRulesEnabled <Boolean>] [-StartupInitializationEnabled <Boolean>] [-Description <String>] [-SlotsPerPartition <Int32[]>] [-Paused <Boolean>] [-Disabled <Boolean>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のロボットライブラリデバイスのプロパティを設定します。

Parameters

-SlotsPerPartition <Int32[]>

パーティション 1 つあたりのスロット数を指定します。 ロボットライブラリデバイスで指定したスロットの総数を超えることはできません。 結果として作成されるロボットライブラリパーティションを取得するには、Get-BERobiticLibraryPartition を使用します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

ロボットライブラリデバイスの説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Disabled <Boolean>

ロボットライブラリデバイスを無効にするかどうかを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Paused <Boolean>

ロボットライブラリデバイスを一時停止するかどうかを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-StartupInitializationEnabled <Boolean>

Backup Exec サービス起動時にロボットライブラリの初期化を有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BarcodeRulesEnabled <Boolean>

バーコードルールを有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SlotsNumbersAreZeroBased <Boolean>

スロット数が 0 から開始するか、1 から開始するかを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BERoboticLibraryDevice[]>

1 つ以上のロボットライブラリデバイスオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BERoboticLibraryDevice

Backup Exec ロボットライブラリデバイスオブジェクトを Set-BERoboticLibraryDevice にパイプ処理することができます。

Return Value
BackupExec.Management.CLI.BERoboticLibraryDevice

Set-BERoboticLibraryDevice は変更されたロボットライブラリデバイスを表すオブジェクトを返します。

Example

C:\PS> Get-BERoboticLibraryDevice "Device 0001" | Set-BERoboticLibraryDevice -Paused $true

これらのコマンドは「Device 0001」という名前のロボットライブラリデバイスを一時停止します。

Related Link

Get-BERoboticLibraryDevice


Set-BERoboticLibrarySlot Help

Set-BERoboticLibrarySlot Cmdlet
Synopsis

Backup Exec ロボットライブラリスロットのプロパティを設定します。

Syntax
Set-BERoboticLibrarySlot -InputObject <BERoboticLibrarySlot[]> [-IsCleaningSlot <Boolean>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec ロボットライブラリスロットのプロパティを設定します。

Parameters

-IsCleaningSlot <Boolean>

スロットをクリーニングスロットとして指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BERoboticLibrarySlot[]>

1 つ以上のロボットライブラリスロットオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BERoboticLibrarySlot

Backup Exec ロボットライブラリスロットオブジェクトを、パイプを使用して Set-BERoboticLibrarySlot に渡すことができます。

Return Value
BackupExec.Management.CLI.BERoboticLibrarySlot

Set-BERoboticLibrarySlot は、変更された Backup Exec ロボットライブラリスロットを表すオブジェクトを返します。

Example

C:\PS> Get-BERoboticLibraryDevice "Device 01" | Get-BERoboticLibrarySlot -SlotNumber 1 | Set-BERoboticLibrarySlot -IsCleaningSlot $true

これらのコマンドは、「Device 01」という名前のロボットライブラリデバイスの第一スロットをクリーニングスロットとして指定します。

Related Links


Set-BEScanUtilityJob Help

Set-BEScanUtilityJob Cmdlet
Synopsis

Backup Exec スキャン操作ジョブのプロパティを設定します。

Syntax
Set-BEScanUtilityJob -InputObject <BEScanUtilityJob[]> [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-Schedule <BESchedule>] [-KeepJobQueuedFor <TimeSpan>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec スキャン操作ジョブのプロパティを設定します。

Parameters

-Schedule <BESchedule>

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

予定開始時刻の経過後に、ジョブが未処理であると Backup Exec が判断し、そのジョブのスケジュール再設定が可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

予定開始時刻後にジョブの実行が続行されている場合、そのジョブのキャンセルが可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEScanUtilityJob[]>

1 つ以上のスキャン操作ジョブオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEScanUtilityJob

Backup Exec スキャン操作ジョブオブジェクトを Set-BEScanUtilityJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEScanUtilityJob

Set-BEScanUtilityJob は、変更された Backup Exec スキャン操作ジョブを表すオブジェクトを返します。

Example

C:\PS> $Schedule = New-BESchedule -RunNow
C:\PS> Get-BEScanUtilityJob -Name "ScanJob" | Set-BEScanUtilityJob -Schedule $Schedule

これらのコマンドは「ScanJob」という名前のスキャン操作ジョブのスケジュールを今すぐ実行するように設定します。

Related Links


Set-BEScheduleDatesToExclude Help

Set-BEScheduleDatesToExclude Cmdlet
Synopsis

Set-BEScheduleDatesToExclude は BESchedule 内の除外される日付のリストを置き換えます。

Syntax
Set-BEScheduleDatesToExclude -Schedule <BESchedule> [-DatesToExclude] <DateTime[]> [<CommonParameters>]
Description

Set-BEScheduleDatesToExclude は BESchedule 内の除外される日付のリストを置き換えます。

Parameters

-Schedule <BESchedule>

ジョブを実行する時刻と頻度を指定します。New-BESchedule を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-DatesToExclude <DateTime[]>

スケジュールでスキップする日付のリストを指定します。

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BESchedule

ジョブを実行する時刻と頻度を指定します。

System.DateTime

DateTime オブジェクトです (.NET framework 内で定義)。 このコマンドレットでは、日付のみが使用されます。時刻が深夜に設定されています。

Return Value
BackupExec.Management.CLI.BESchedule

ジョブを実行する時刻と頻度を指定します。

Examples

Example 1

C:\PS> $s = New-BESchedule -Daily -StartingAt 9pm
C:\PS> $s | Set-BEScheduleDatesToExclude 1/1/2013, 1/1/2014, 1/1/2015, 1/1/2016, 1/1/2017

これらのコマンドは、毎日午後 9 時に実行され、2013 から 2017 年の 1 月 1 日を除外するようにジョブをスケジュールします。

Example 2
C:\PS> $bd = Get-BEBackupDefinition "Payroll"
C:\PS> $s = $bd.InitialFullBackup.Schedule
C:\PS> $s | Set-BEScheduleDatesToExclude 1/1/2013, 1/1/2014, 1/1/2015, 1/1/2016, 1/1/2017
C:\PS> $bd | Set-BEFullBackupTask -Name $bd.InitialFullBackup.Name -Schedule $s | Save-BEBackupDefinition

これらのコマンドは、「Payroll」という名前のバックアップ定義で初期フルバックアップのスケジュールを修正し、2013 から 2017 年の 1 月 1 日を除外します。

Related Links


Set-BEScheduleDatesToInclude Help

Set-BEScheduleDatesToInclude Cmdlet
Synopsis

Set-BEScheduleDatesToInclude は BESchedule 内の含まれる日付のリストを置き換えます。

Syntax
Set-BEScheduleDatesToInclude -Schedule <BESchedule> [-DatesToInclude] <DateTime[]> [<CommonParameters>]
Description

Set-BEScheduleDatesToInclude は BESchedule 内の含まれる日付のリストを置き換えます。

Parameters

-Schedule <BESchedule>

ジョブを実行する時刻と頻度を指定します。New-BESchedule を参照してください。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-DatesToInclude <DateTime[]>

スケジュールに追加する日付のリストを指定します。

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BESchedule

ジョブを実行する時刻と頻度を指定します。

System.DateTime

DateTime オブジェクトです (.NET framework 内で定義)。 このコマンドレットでは、日付のみが使用されます。時刻が深夜に設定されています。

Return Value
BackupExec.Management.CLI.BESchedule

ジョブを実行する時刻と頻度を指定します。

Examples

Example 1

C:\PS> $s = New-BESchedule -Daily -StartingAt 9pm
C:\PS> $s | Set-BEScheduleDatesToInclude 1/1/2013, 1/1/2014, 1/1/2015, 1/1/2016, 1/1/2017

これらのコマンドは、毎日朝 9:00 に実行されるスケジュールを作成します。これには 2013 年から 2017 年までの 1 月 1 日も含まれます。

Example 2
C:\PS> $bd = Get-BEBackupDefinition "Payroll"
C:\PS> $s = $bd.InitialFullBackup.Schedule
C:\PS> $s | Set-BEScheduleDatesToInclude 1/1/2013, 1/1/2014, 1/1/2015, 1/1/2016, 1/1/2017
C:\PS> $bd | Set-BEFullBackupTask -Name $bd.InitialFullBackup.Name -Schedule $s | Save-BEBackupDefinition

これらのコマンドは、「Payroll」という名前のバックアップ定義で初期フルバックアップをスケジュールし、2013 から 2017 年の 1 月 1 日を含めるよう日付を修正します。

Related Links


Set-BEStandaloneBackupExecServer Help

Set-BEStandaloneBackupExecServer Cmdlet
Synopsis

スタンドアロン Backup Exec サーバーのプロパティを設定します。

Syntax
Set-BEStandaloneBackupExecServer -InputObject <BEStandaloneBackupExecServer[]> [-Description <String>] [-IsPrivateCloudServer <Boolean>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

スタンドアロン Backup Exec サーバーのプロパティを設定します。

Parameters

-Description <String>

スタンドアロン Backup Exec サーバーの説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IsPrivateCloudServer <Boolean>

スタンドアロンの Backup Exec サーバーがプライベートクラウドサーバーであるかどうかを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEStandaloneBackupExecServer[]>

1 つ以上のスタンドアロン Backup Exec サーバーオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEStandaloneBackupExecServer

スタンドアロン Backup Exec サーバーオブジェクトを Set-BEStandaloneBackupExecServer にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEStandaloneBackupExecServer

Set-BEStandaloneBackupExecServer は変更された Backup Exec スタンドアロンサーバーを表すオブジェクトを返します。

Example

C:\PS> $BackupExecServer = Get-BEStandaloneBackupExecServer -Name "MyStandalone"
C:\PS> $BackupExecServer | Set-BEStandaloneBackupExecServer -Description "This is my Standalone Server"

これらのコマンドは「MyStandalone」という名前のスタンドアロン Backup Exec サーバーの説明を提供します。

Related Link

Get-BEStandaloneBackupExecServer


Set-BEStorageArrayDevice Help

Set-BEStorageArrayDevice Cmdlet
Synopsis

Backup Exec のストレージアレイのプロパティを設定します。

Syntax
Set-BEStorageArrayDevice -InputObject <BEStorageArrayDevice[]> [-Paused <Boolean>] [-Description <String>] [-Disabled <Boolean>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のストレージアレイのプロパティを設定します。

Parameters

-Description <String>

ストレージアレイの説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Disabled <Boolean>

ストレージアレイデバイスを無効にするかどうかを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Paused <Boolean>

ストレージアレイデバイスを一時停止するかどうかを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEStorageArrayDevice[]>

1 つ以上のストレージアレイを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEStorageArrayDevice

Backup Exec ストレージアレイオブジェクトを Set-BEStorageArrayDevice にパイプ処理することができます。

Return Value
BackupExec.Management.CLI.BEStorageArrayDevice

Set-BEStorageArrayDevice は変更されたストレージアレイを表すオブジェクトを返します。

Example

C:\PS> Get-BEStorageArrayDevice "Device 0001" | Set-BEStorageArrayDevice -Paused $true

これらのコマンドは「Device 0001」という名前のストレージアレイを一時停止します。

Related Link

Get-BEStorageArrayDevice


Set-BEStorageDevice Help

Set-BEStorageDevice Cmdlet
Synopsis

Backup Exec のストレージデバイスのプロパティを設定します。

Syntax
Set-BEStorageDevice -InputObject <BEStorageDevice[]> [-Paused <Boolean>] [-Description <String>] [-Disabled <Boolean>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のストレージデバイスのプロパティを設定します。

Parameters

-Description <String>

ストレージデバイスの説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Disabled <Boolean>

ストレージデバイスを無効にするかどうかを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Paused <Boolean>

ストレージデバイスを一時停止するかどうかを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEStorageDevice[]>

1 つ以上のストレージデバイスオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEStorageDevice

Backup Exec ストレージデバイスオブジェクトを Set-BEStorageDevice にパイプ処理することができます。

Return Value
BackupExec.Management.CLI.BEStorageDevice

Set-BEStorageDevice は変更されたストレージデバイスを表すオブジェクトを返します。

Example

C:\PS> Get-BEStorageDevice "Device 0001" | Set-BEStorageDevice -Paused $true

これらのコマンドは「Device 0001」という名前のストレージデバイスを一時停止します。

Related Link

Get-BEStorageDevice


Set-BEStorageDevicePool Help

Set-BEStorageDevicePool Cmdlet
Synopsis

Backup Exec のストレージデバイスプールにプロパティを設定します。

Syntax
Set-BEStorageDevicePool -InputObject <BEStorageDevicePool[]> [-Description <String>] [-SelectionMethod {Default | LeastFreeSpaceFirst | MostFreeSpaceFirst}] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のストレージデバイスプールにプロパティを設定します。

Parameters

-Description <String>

ストレージデバイスプールの説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SelectionMethod

プールに対してバックアップジョブを実行する場合のストレージプール内でのデバイスの選択方法を指定します。バックアップジョブをストレージデバイスプールにサブミットする場合、デフォルトでは、そのジョブはプール内で利用可能なストレージデバイスに自動的に送信されます。

The valid values are:
Default
LeastFreeSpaceFirst
MostFreeSpaceFirst

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEStorageDevicePool[]>

1 つ以上のストレージデバイスプールオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEStorageDevicePool

Backup Exec ストレージデバイスプールオブジェクトを Set-BEStorageDevicePool にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEStorageDevicePool

Set-BEStorageDevicePool は、変更されたストレージデバイスプールを表すオブジェクトを返します。

Example

C:\PS> Get-BEStorageDevicePool -Name "Storage Pool 0001" | Set-BEStorageDevicePool -Description "Test Pool"

これらのコマンドは、「Storage Pool 0001」という名前のストレージプールの説明を「Test Pool」に変更します。

Related Link

Get-BEStorageDevicePool


Set-BESyntheticBackupDefinition Help

Set-BESyntheticBackupDefinition Cmdlet
Synopsis

Backup Exec の合成バックアップ定義のプロパティを設定します。

Syntax
Set-BESyntheticBackupDefinition [-SyntheticBackupDefinition] <BESyntheticBackupDefinition> [-UseSnapshotTechnology <Boolean>] [-SnapshotTechnology {Automatic | MicrosoftVolumeShadowCopyService}] [-SnapshotProvider {Automatic | System | Software | Hardware}] [-EnableCheckpointRestart <Boolean>] [-NetworkProtocol {AnyAvailable | IPv4 | IPv6}] [-NetworkSubnet <BENetworkInterfaceSubnet>] [-AllowAnyNetworkForAgentAccess <Boolean>] [-ProcessOffhostLogicalVolumesSequentially <Boolean>] [-FailIfNoOffhostBackup <Boolean>] [-ProcessLogicalVolumesSequentially <Boolean>] [-UseOffhostBackup <Boolean>] [-OffhostBackupSnapshotProvider {Automatic | Software | Hardware}] [-RestrictToBackupExecServer <BEBackupExecServer>] [-RestrictToBackupExecServersInPool <BEBackupExecServerPool>] [-EnableTestRun <Boolean>] [-Priority {Normal | Lowest | Low | High | Highest}] [-ClearExistingSelection <SwitchParameter>] [-Description <String>] [-FileSystemSelection <BEFileSystemSelection[]>] [-TestRunJobSizeCalculationMethod {UsePreviousJobHistories | PerformPreScan}] [-TestRunPlaceScheduledBackupJobOnHoldIfUnsuccessful <Boolean>] [-NetworkInterface <BENetworkInterface>] [-TestRunCheckMediaAvailable <Boolean>] [-TestRunSchedule <BESchedule>] [-TestRunCheckLogonAccount <Boolean>] [-TestRunCheckStorageSpace <Boolean>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec の合成バックアップ定義のプロパティを設定します。

Set-BEBackupDefinition に渡されるパラメータは、合成バックアップ定義のすべてのタスクに対するオプションです。

Set-BEBackupDefinition に渡される選択パラメータの値は、編集する合成バックアップ定義の現在の選択に追加されます。 既存の選択をクリアするには、ClearExistingSelection を使用します。

Set-BESyntheticBackupDefinition を次のコマンドと一緒に使用して、合成バックアップ定義のタスクを変更できます:Set-BESyntheticBackupDefinition、Set-BESyntheticInitialFullTask、Set-BESyntheticIncrementalTask、Set-BESyntheticFullTask、Add-BEVerifyBackupTask、および Set-BEVerifyBackupTask。

合成バックアップ定義を作成または編集した場合、変更をコミットするには合成バックアップ定義を Save-BESyntheticBackupDefinition に渡す必要があります。

Parameters

-SyntheticBackupDefinition <BESyntheticBackupDefinition>

編集するバックアップ定義を指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-ClearExistingSelection <SwitchParameter>

既存のバックアップの選択をクリアします。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

合成バックアップ定義の説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemSelection <BEFileSystemSelection[]>

1 つ以上のファイルシステムの選択項目をバックアップ戦略に含める、またはバックアップ戦略から除外します。含めるファイルまたはディレクトリを指定するには、1 つまたは複数のパスを、カンマを使用して値を区切って指定します。除外するファイルまたはディレクトリを指定するには、-Exclude パラメータと一緒に New-BEFileSystemSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Priority

ジョブを実行する順序を指定します。2 つのジョブが同時に実行されるようにスケジュールされている場合、ユーザーが設定する優先度でどちらが先に実行されるかが決まります。

The valid values are:
Normal
Lowest
Low
High
Highest

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RestrictToBackupExecServer <BEBackupExecServer>

CASO 環境でジョブをディスパッチ可能な Backup Exec サーバーを指定します。RestrictToBackupExecServersInPool が指定されている場合は指定できません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RestrictToBackupExecServersInPool <BEBackupExecServerPool>

CASO 環境でジョブをディスパッチ可能な Backup Exec サーバーのセットを指定します。RestrictToBackupExecServer が指定されている場合は指定できません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableTestRun <Boolean>

テスト実行の処理を有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunSchedule <BESchedule>

テスト実行ジョブの実行日時と実行頻度のスケジュール設定を可能にします。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunCheckLogonAccount <Boolean>

バックアップする Backup Exec ログオンアカウントがデータにアクセス可能であることを確認します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunCheckStorageSpace <Boolean>

メディア上にジョブの完了に必要な容量があるかどうかをチェックします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunCheckMediaAvailable <Boolean>

メディアがオンラインになっていて上書き可能かどうかをチェックします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunJobSizeCalculationMethod

スケジュール済みバックアップジョブを実行するために使用可能なメディアの容量を計算する方法を指定します。

The valid values are:
UsePreviousJobHistories
PerformPreScan

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunPlaceScheduledBackupJobOnHoldIfUnsuccessful <Boolean>

テスト実行中に Backup Exec で障害が検出された場合、スケジュール済みジョブを保留にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NetworkInterface <BENetworkInterface>

バックアップネットワークとして使用するネットワークに対して Backup Exec サーバーを接続する、ネットワークインターフェースカードの名前を指定します。Get-BENetworkInterface を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NetworkProtocol

リモートコンピュータをバックアップするために使うプロトコルを指定します。

The valid values are:
AnyAvailable
IPv4
IPv6

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NetworkSubnet <BENetworkInterfaceSubnet>

Get-BENetworkInterface によって返されたネットワークインターフェースのサブネットの 1 つを使用して、リモートコンピュータをバックアップするために使うサブネットを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AllowAnyNetworkForAgentAccess <Boolean>

バックアップまたはリストアのために選択したリモートコンピュータが、指定したバックアップネットワークの一部でない場合に、リモートコンピュータからのデータが任意の利用可能なネットワークを介してバックアップまたはリストアされるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableCheckpointRestart <Boolean>

ジョブが中断された時点からバックアップジョブを続行可能にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UseSnapshotTechnology <Boolean>

スナップショットテクノロジを有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SnapshotTechnology

スナップショットテクノロジを有効にしたときに使用する、スナップショットテクノロジを指定します。UseSnapshotTechnology は $true に設定する必要があります。

The valid values are:
Automatic
MicrosoftVolumeShadowCopyService

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SnapshotProvider

スナップショットテクノロジを有効にしたときに使用するスナップショットプロバイダとして、Microsoft ボリュームシャドウコピーサービスを指定します。UseSnapshotTechnology を $true に設定し、SnapshotTechnology を MicrosoftVolumeShadowCopyService に設定する必要があります。

The valid values are:
Automatic
System
Software
Hardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ProcessLogicalVolumesSequentially <Boolean>

1 つのジョブで複数のボリュームをバックアップすることを有効にします。このとき、一度に 1 つの論理ボリュームのスナップショットのみが作成されます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UseOffhostBackup <Boolean>

オフホストバックアップを有効にします。有効な場合は、すべての必要条件が満たされると、すべてのボリュームのオフホストバックアップが実行されます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OffhostBackupSnapshotProvider

使用するオフホストバックアップのスナップショットプロバイダを指定します。UseOffhostBackup は $true に設定する必要があります。

The valid values are:
Automatic
Software
Hardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FailIfNoOffhostBackup <Boolean>

選択したボリュームのいずれかがオフホストバックアップをサポートしない場合、またはスナップショットやボリュームのインポートでエラーが発生した場合、バックアップジョブを終了します。 UseOffhostBackup は $true に設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ProcessOffhostLogicalVolumesSequentially <Boolean>

1 つのジョブで複数のボリュームをバックアップすることを可能にします。このとき、オフホストバックアップに対して一度に 1 つの論理ボリュームのスナップショットのみが作成されます。UseOffhostBackup は $true に設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BESyntheticBackupDefinition

Backup Exec 合成バックアップ定義オブジェクトを Set-BESyntheticBackupDefinition にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BESyntheticBackupDefinition

Set-BESyntheticBackupDefinition は、作成された合成バックアップ定義を返します。

Examples

Example 1

C:\PS> Get-BESyntheticBackupDefinition "Synthetic Backup Definition 01" | Set-BESyntheticBackupDefinition -FileSystemSelection D:\* | Save-BESyntheticBackupDefinition

これらのコマンドは「Synthetic Backup Definition 01」という名前の合成バックアップ定義の現在の選択項目に、D:\* をバックアップ選択項目として追加します。

Example 2
C:\PS> Get-BESyntheticBackupDefinition "Synthetic Backup Definition 01" | Set-BESyntheticBackupDefinition -ClearExistingSelection -FileSystemSelection D:\* | Save-BESyntheticBackupDefinition

これらのコマンドは、「Synthetic Backup Definition 01」という名前の合成バックアップ定義のバックアップ選択項目のみに「D:\*」を設定します。

Related Links

Set-BEBackupDefinition
Add-BEVerifyBackupTask
Set-BEVerifyBackupTask
Save-BESyntheticBackupDefinition
New-BEFileSystemSelection
Get-BENetworkInterface
Get-BESyntheticBackupDefinition


Set-BESyntheticBackupJobDefault Help

Set-BESyntheticBackupJobDefault Cmdlet
Synopsis

Backup Exec の合成ジョブのデフォルトのプロパティを設定します。

Syntax
Set-BESyntheticBackupJobDefault [-SyntheticBackupDefault] <BESyntheticBackupJobDefaults> [-ProcessLogicalVolumesSequentially <Boolean>] [-UseOffhostBackup <Boolean>] [-SnapshotProvider {Automatic | System | Software | Hardware}] [-UseSnapshotTechnology <Boolean>] [-SnapshotTechnology {Automatic | MicrosoftVolumeShadowCopyService}] [-ProcessOffhostLogicalVolumesSequentially <Boolean>] [-OffhostBackupSnapshotProvider {Automatic | Software | Hardware}] [-FailIfNoOffhostBackup <Boolean>] [-TestRunSchedule <BESchedule>] [-TestRunCheckLogonAccount <Boolean>] [-EnableTestRun <Boolean>] [-RestrictToBackupExecServer <BEBackupExecServer>] [-RestrictToBackupExecServersInPool <BEBackupExecServerPool>] [-TestRunPlaceScheduledBackupJobOnHoldIfUnsuccessful <Boolean>] [-EnableCheckpointRestart <Boolean>] [-TestRunJobSizeCalculationMethod {UsePreviousJobHistories | PerformPreScan}] [-TestRunCheckStorageSpace <Boolean>] [-TestRunCheckMediaAvailable <Boolean>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec の合成バックアップジョブのデフォルトのプロパティを設定します。

Set-BESyntheticBackupJobDefault に渡されるパラメータは、合成バックアップジョブのデフォルトのすべてのタスクに対するオプションです。

Set-BESyntheticBackupJobDefault を次のコマンドと一緒に使用して、合成バックアップジョブのデフォルトのタスクを変更できます: Set-BESyntheticBackupJobDefault、Set-BESyntheticInitialFullTask、Set-BESyntheticIncrementalTask、Set-BESyntheticFullTask、Add-BEVerifyBackupTask、および Set-BEVerifyBackupTask。

合成バックアップジョブのデフォルトを編集した場合、変更をコミットするには合成バックアップジョブのデフォルトを Save-BESyntheticBackupJobDefault に渡す必要があります。

Parameters

-SyntheticBackupDefault <BESyntheticBackupJobDefaults>

保存する合成バックアップジョブのデフォルトを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RestrictToBackupExecServer <BEBackupExecServer>

CASO 環境でジョブをディスパッチ可能な Backup Exec サーバーを指定します。RestrictToBackupExecServersInPool が指定されている場合は指定できません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RestrictToBackupExecServersInPool <BEBackupExecServerPool>

CASO 環境でジョブをディスパッチ可能な Backup Exec サーバーのセットを指定します。RestrictToBackupExecServer が指定されている場合は指定できません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableTestRun <Boolean>

テスト実行の処理を有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunSchedule <BESchedule>

テスト実行ジョブを実行する時刻と頻度をスケジュールできます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunCheckLogonAccount <Boolean>

バックアップする Backup Exec ログオンアカウントがデータにアクセス可能であることを確認します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunCheckStorageSpace <Boolean>

メディア上にジョブの完了に必要な容量があるかどうかをチェックします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunCheckMediaAvailable <Boolean>

メディアがオンラインになっていて上書き可能かどうかをチェックします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunJobSizeCalculationMethod

スケジュール済みバックアップジョブを実行するために使用可能なメディアの容量を計算する方法を指定します。

The valid values are:
UsePreviousJobHistories
PerformPreScan

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunPlaceScheduledBackupJobOnHoldIfUnsuccessful <Boolean>

テスト実行中に Backup Exec で障害が検出された場合、スケジュール済みジョブを保留にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableCheckpointRestart <Boolean>

ジョブが中断された時点からバックアップジョブを続行可能にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UseSnapshotTechnology <Boolean>

スナップショットテクノロジを有効にします

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SnapshotTechnology

スナップショットテクノロジを有効にしたときに使用する、スナップショットテクノロジを指定します。UseSnapshotTechnology は $true に設定する必要があります。

The valid values are:
Automatic
MicrosoftVolumeShadowCopyService

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SnapshotProvider

スナップショットテクノロジを有効にしたときに使用するスナップショットプロバイダとして、Microsoft ボリュームシャドウコピーサービスを指定します。UseSnapshotTechnology を $true に設定し、SnapshotTechnology を MicrosoftVolumeShadowCopyService に設定する必要があります。

The valid values are:
Automatic
System
Software
Hardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ProcessLogicalVolumesSequentially <Boolean>

1 つのジョブで複数のボリュームをバックアップすることを有効にします。このとき、一度に 1 つの論理ボリュームのスナップショットのみが作成されます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UseOffhostBackup <Boolean>

オフホストバックアップを有効にします。有効な場合は、すべての必要条件が満たされると、すべてのボリュームのオフホストバックアップが実行されます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OffhostBackupSnapshotProvider

使用するオフホストバックアップのスナップショットプロバイダを指定します。UseOffhostBackup は $true に設定する必要があります。

The valid values are:
Automatic
Software
Hardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FailIfNoOffhostBackup <Boolean>

選択したボリュームのいずれかがオフホストバックアップをサポートしない場合、またはスナップショットやボリュームのインポートでエラーが発生した場合、バックアップジョブを終了します。 UseOffhostBackup は $true に設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ProcessOffhostLogicalVolumesSequentially <Boolean>

1 つのジョブで複数のボリュームをバックアップすることを可能にします。このとき、オフホストバックアップに対して一度に 1 つの論理ボリュームのスナップショットのみが作成されます。UseOffhostBackup は $true に設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BESyntheticBackupJobDefaults

Backup Exec の合成バックアップジョブのデフォルトオブジェクトを Set-BESyntheticBackupJobDefault にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BESyntheticBackupJobDefaults

Save-BESyntheticBackupJobDefaults は、修正された合成バックアップジョブのデフォルトを返します。

Example

C:\PS> Get-BESyntheticBackupJobDefault | Set-BESyntheticBackupJobDefault -Priority High | Save-BESyntheticBackupJobDefault

これらのコマンドは、デフォルトの合成バックアップジョブの優先度を「高」に設定します。

Related Links


Set-BESyntheticFullBackupTask Help

Set-BESyntheticFullBackupTask Cmdlet
Synopsis

Backup Exec の合成バックアップ定義の合成完全バックアップを修正します。

Syntax
Set-BESyntheticFullBackupTask -SyntheticBackupDefinition <BESyntheticBackupDefinition> [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-KeepJobQueuedFor <TimeSpan>] [-BackupSetDescription <String>] [-Schedule <BESchedule>] [-IncludeJobLogWithEmailNotification <Boolean>] [-VerifyAsPartOfJob <Boolean>] [-TapeStorageCompressionMethod {None | SoftwareIfNoHardware | HardwareOnly | SoftwareOnly}] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-TapeStorageExportMedia <Boolean>] [-TapeStorageExportMediaToVault <BEMediaVault>] [-TapeStorageMediaSet <BEMediaSet>] [-JobName <String>] [-Storage <BEStorage>] [-TapeStorageEjectMediaAfterComplete <Boolean>] [-DiskStorageKeepForHours <Int32>] [-SubmitOnHold <Boolean>] [-TapeStorageRetensionMediaBeforeBackup <Boolean>] [-TapeStorageEnableWriteOnceReadManyMedia <Boolean>] [-TapeStorageEnableDirectCopyToTape <Boolean>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Set-BESyntheticFullBackupTask -SyntheticBackupJobDefault <BESyntheticBackupJobDefaults> [-NotificationRecipientList <BENotificationRecipientObject[]>] [-IncludeJobLogWithEmailNotification <Boolean>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-Schedule <BESchedule>] [-KeepJobQueuedFor <TimeSpan>] [-VerifyAsPartOfJob <Boolean>] [-TapeStorageCompressionMethod {None | SoftwareIfNoHardware | HardwareOnly | SoftwareOnly}] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-BackupSetDescription <String>] [-TapeStorageExportMediaToVault <BEMediaVault>] [-TapeStorageEjectMediaAfterComplete <Boolean>] [-TapeStorageExportMedia <Boolean>] [-Storage <BEStorage>] [-TapeStorageMediaSet <BEMediaSet>] [-DiskStorageKeepForHours <Int32>] [-SubmitOnHold <Boolean>] [-TapeStorageRetensionMediaBeforeBackup <Boolean>] [-TapeStorageEnableWriteOnceReadManyMedia <Boolean>] [-TapeStorageEnableDirectCopyToTape <Boolean>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec の合成バックアップ定義の完全バックアップを修正します。

新しい合成バックアップ定義の合成完全バックアップを修正するか、合成バックアップ定義を編集できます。 合成バックアップジョブのデフォルトの合成完全バックアップを修正することもできます。

新しい合成バックアップ定義の合成完全バックアップを修正するには、Set-BESyntheticFullBackupTask と New-BESyntheticBackupDefinition を使用します。

既存のバックアップ定義の合成完全バックアップを修正するには、Set-BESyntheticFullBackupTask と Get-BESyntheticBackupDefinitionを使用します。

バックアップジョブのデフォルトの合成完全バックアップを修正するには、Set-BESyntheticFullBackupTask と Get-BESyntheticBackupJobDefault を使用します。

合成バックアップ定義を作成または編集する場合、その合成バックアップ定義を Save-BESyntheticBackupDefinition に渡して変更をコミットする必要があります。

合成バックアップジョブのデフォルトを編集する場合、その合成バックアップジョブのデフォルトを Save-BESyntheticBackupJobDefault に渡して変更をコミットする必要があります。

Parameters

-SyntheticBackupDefinition <BESyntheticBackupDefinition>

編集するバックアップ定義を指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-SyntheticBackupJobDefault <BESyntheticBackupJobDefaults>

保存する合成バックアップジョブのデフォルトを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-JobName <String>

このタスクを表すジョブの名前を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Storage <BEStorage>

アラートをフィルタ処理するための 1 つまたは複数のストレージオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEStorage を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaSet <BEMediaSet>

メディアと関連付けるメディアセットを指定します。メディアはメディアセットの設定に基づいて上書きから保護されます。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。 Get-BEMediaSet を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMedia <Boolean>

ジョブの完了後にデバイスからメディアをエクスポートします。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMediaToVault <BEMediaVault>

ジョブの完了後にメディアを指定したボルトに論理的に移動します。Storage パラメータはテープベースのストレージデバイスに設定し、TapeStorageExportMedia は $true に設定する必要があります。Get-BEMediaVault を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEjectMediaAfterComplete <Boolean>

ジョブの完了後にストレージデバイスからメディアを取り出します。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableWriteOnceReadManyMedia <Boolean>

バックアップジョブに WORM (Write Once Read Many) メディアの使用を指定します。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableDirectCopyToTape <Boolean>

物理テープデバイスに仮想テープライブラリから直接データをコピーできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageRetensionMediaBeforeBackup <Boolean>

データを書き込む前にメディアのリテンションを行います。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskStorageKeepForHours <Int32>

メディアへの上書きを禁止し、このメディア上にデータを保存する時間を指定します。 Storage パラメータがディスクベースのストレージデバイスに設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SubmitOnHold <Boolean>

ジョブを保留状態でサブミットします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupSetDescription <String>

バックアップしたデータとその格納場所についての説明です。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Schedule <BESchedule>

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

予定開始時刻の経過後に、ジョブが未処理であると Backup Exec が判断し、そのジョブのスケジュール再設定が可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

予定開始時刻後にジョブの実行が続行されている場合、そのジョブのキャンセルが可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NotificationRecipientList <BENotificationRecipientObject[]>

ジョブが完了したときに通知を受け取る受信者を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IncludeJobLogWithEmailNotification <Boolean>

電子メールにジョブログを添付します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageCompressionMethod

使用するソフトウェアデータ圧縮またはハードウェアデータ圧縮の種類を指定します。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
None
SoftwareIfNoHardware
HardwareOnly
SoftwareOnly

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaAppendMethod

ジョブの開始時にメディアに上書きまたは追記します。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
Append
AppendOnly
Overwrite

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VerifyAsPartOfJob <Boolean>

バックアップジョブの完了時に自動的に検証操作を実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BESyntheticBackupDefinition

Backup Exec の合成バックアップジョブのデフォルトオブジェクトを Set-BESyntheticFullBackupTask にパイプ処理できます。

BackupExec.Management.CLI.BESyntheticBackupJobDefaults

Backup Exec の合成バックアップジョブのデフォルトオブジェクトを Set-BESyntheticFullBackupTask にパイプ処理できます。

Return Values
BackupExec.Management.CLI.BESyntheticBackupDefinition

Set-BESyntheticFullBackupTask は Backup Exec の合成バックアップ定義を表すオブジェクトを返します。

BackupExec.Management.CLI.BESyntheticBackupJobDefaults

修正された合成バックアップジョブのデフォルトを示します。

Examples

Example 1

C:\PS> Get-BESyntheticBackupDefinition "Backup Definition 01" | Set-BESyntheticFullBackupTask -Name "Synthetic Full" -Storage "Any disk storage" | Save-BESyntheticBackupDefinition

これらのコマンドは「Backup Definition 01」という名前の合成バックアップ定義に含まれる「Full 2」という名前の完全バックアップのストレージを「Any disk storage」プールに設定します。

Example 2
C:\PS> Get-BESyntheticBackupDefinition "Backup Definition 01" | Set-BESyntheticFullBackupTask -Name * -Storage "Any disk storage" | Save-BESyntheticBackupDefinition

これらのコマンドは「Backup Definition 01」という名前の合成バックアップ定義に含まれるすべての合成完全バックアップのストレージを「Any disk storage」プールに設定します。

Example 3
C:\PS> Get-BESyntheticBackupJobDefault | Set-BESyntheticFullBackupTask -Name * -Storage "Any disk storage" | Save-BESyntheticBackupJobDefault

これらのコマンドは合成バックアップジョブのデフォルトに含まれるすべての合成完全バックアップのストレージを「Any disk storage」プールに設定します。

Related Links

New-BESyntheticBackupDefinition
Get-BESyntheticBackupJobDefault
Save-BESyntheticBackupDefinition
Save-BESyntheticBackupJobDefault
Get-BEStorage
Get-BEMediaSet
Get-BEMediaVault
New-BESchedule
Get-BESyntheticBackupDefinition


Set-BESyntheticIncrementalBackupTask Help

Set-BESyntheticIncrementalBackupTask Cmdlet
Synopsis

Backup Exec の合成バックアップ定義の合成増分バックアップを修正します。

Syntax
Set-BESyntheticIncrementalBackupTask -SyntheticBackupDefinition <BESyntheticBackupDefinition> [-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>] [-RunPostCommandAfterVerification <Boolean>] [-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>] [-PrePostCommandSuccessfulIfReturnsZero <Boolean>] [-RunJobOnlyIfPreCommandIsSuccessful <Boolean>] [-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>] [-EncryptionKey <BEEncryptionKey>] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-VerifyAsPartOfJob <Boolean>] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-PostCommand <String>] [-SubmitOnHold <Boolean>] [-BackupSetDescription <String>] [-Schedule <BESchedule>] [-JobName <String>] [-Storage <BEStorage>] [-DiskStorageKeepForHours <Int32>] [-IncludeJobLogWithEmailNotification <Boolean>] [-EnableDirectAccessIfAvailable <Boolean>] [-PreCommand <String>] [-KeepJobQueuedFor <TimeSpan>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Set-BESyntheticIncrementalBackupTask -SyntheticBackupJobDefault <BESyntheticBackupJobDefaults> [-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>] [-RunPostCommandAfterVerification <Boolean>] [-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>] [-PrePostCommandSuccessfulIfReturnsZero <Boolean>] [-RunJobOnlyIfPreCommandIsSuccessful <Boolean>] [-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>] [-EncryptionKey <BEEncryptionKey>] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-VerifyAsPartOfJob <Boolean>] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-BackupSetDescription <String>] [-Schedule <BESchedule>] [-KeepJobQueuedFor <TimeSpan>] [-Storage <BEStorage>] [-DiskStorageKeepForHours <Int32>] [-SubmitOnHold <Boolean>] [-EnableDirectAccessIfAvailable <Boolean>] [-PreCommand <String>] [-PostCommand <String>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-IncludeJobLogWithEmailNotification <Boolean>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec の合成バックアップ定義の合成増分バックアップを修正します。

新しい合成バックアップ定義の合成増分バックアップを修正するか、合成バックアップ定義を編集できます。 合成バックアップジョブのデフォルトの合成増分バックアップを修正することもできます。

新しい合成バックアップ定義の合成増分バックアップを修正するには、Set-BESyntheticIncrementalBackupTask と New-BESyntheticBackupDefinition を使用します。

既存のバックアップ定義の合成増分バックアップを修正するには、Set-BESyntheticIncrementalBackupTask と Get-BESyntheticBackupDefinitionを使用します。

バックアップジョブのデフォルトの合成増分バックアップを修正するには、Set-BESyntheticIncrementalBackupTask と Get-BESyntheticBackupJobDefault を使用します。

合成バックアップ定義を作成または編集する場合、その合成バックアップ定義を Save-BESyntheticBackupDefinition に渡して変更をコミットする必要があります。

合成バックアップジョブのデフォルトを編集する場合、その合成バックアップジョブのデフォルトを Save-BESyntheticBackupJobDefault に渡して変更をコミットする必要があります。

Parameters

-SyntheticBackupDefinition <BESyntheticBackupDefinition>

編集するバックアップ定義を指定します

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-SyntheticBackupJobDefault <BESyntheticBackupJobDefaults>

保存する合成バックアップジョブのデフォルトを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-JobName <String>

このタスクを表すジョブの名前を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Storage <BEStorage>

アラートをフィルタ処理するための 1 つまたは複数のストレージオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEStorage を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskStorageKeepForHours <Int32>

メディアへの上書きを禁止し、このメディア上にデータを保存する時間を指定します。 Storage パラメータがディスクベースのストレージデバイスに設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SubmitOnHold <Boolean>

ジョブを保留状態でサブミットします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupSetDescription <String>

バックアップしたデータとその格納場所についての説明です。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Schedule <BESchedule>

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

予定開始時刻の経過後に、ジョブが未処理であると Backup Exec が判断し、そのジョブのスケジュール再設定が可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

予定開始時刻後にジョブの実行が続行されている場合、そのジョブのキャンセルが可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NotificationRecipientList <BENotificationRecipientObject[]>

ジョブが完了したときに通知を受け取る受信者を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IncludeJobLogWithEmailNotification <Boolean>

電子メールにジョブログを添付します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableDirectAccessIfAvailable <Boolean>

Agent for Windows から Storage パラメータで指定したデバイスにバックアップデータを直接送信できるようにします (デバイスがこの操作をサポートしている場合)。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreCommand <String>

バックアップジョブの前に実行するコマンドを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PostCommand <String>

バックアップジョブの後に実行するコマンドを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PrePostCommandSuccessfulIfReturnsZero <Boolean>

Backup Exec によってプリコマンドまたはポストコマンドの戻りコードを確認し、コマンドが正しく完了したかどうかを調べることができます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunJobOnlyIfPreCommandIsSuccessful <Boolean>

プリコマンドが正しく実行された場合にのみバックアップジョブを実行します。プリコマンドの実行に失敗した場合は、ジョブは実行されません。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>

プリコマンドが正しく実行された場合にのみポストコマンドを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>

ジョブが正しく実行されなかった場合でもポストコマンドを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandAfterVerification <Boolean>

バックアップジョブの検証を選択した場合、検証が完了した後にポストコマンドを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>

完了しなかったプリコマンドまたはポストコマンドをキャンセルするのに待つ時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunCommandLocation

プリコマンドとポストコマンドが実行される場所を指定します。

The valid values are:
OnEachAgentServer
OnBackupExecServer

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VerifyAsPartOfJob <Boolean>

バックアップジョブの完了時に自動的に検証操作を実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionType

バックアップジョブに使用する暗号化の種類を指定します。

The valid values are:
None
Software
Hardware
SoftwareIfNoHardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionKey <BEEncryptionKey>

使用する暗号化キーを指定します。 EncryptionType が None 以外の値に設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BESyntheticBackupDefinition

Backup Exec の合成バックアップジョブのデフォルトオブジェクトを Set-BESyntheticIncrementalBackupTask にパイプ処理できます。

BackupExec.Management.CLI.BESyntheticBackupJobDefaults

Backup Exec の合成バックアップジョブのデフォルトオブジェクトを Set-BESyntheticIncrementalBackupTask にパイプ処理できます。

Return Values
BackupExec.Management.CLI.BESyntheticBackupDefinition

Set-BESyntheticIncrementalBackupTask は Backup Exec の合成バックアップ定義を表すオブジェクトを返します。

BackupExec.Management.CLI.BESyntheticBackupJobDefaults

修正された合成バックアップジョブのデフォルトを示します。

Examples

Example 1

C:\PS> Get-BESyntheticBackupDefinition "Backup Definition 01" | Set-BESyntheticIncrementalBackupTask -Name "Incremental" -Storage "Any disk storage" | Save-BESyntheticBackupDefinition

これらのコマンドは「Backup Definition 01」という名前の合成バックアップ定義に含まれる「Full 2」という名前の増分バックアップのストレージを「Any disk storage」プールに設定します。

Example 2
C:\PS> Get-BESyntheticBackupDefinition "Backup Definition 01" | Set-BESyntheticIncrementalBackupTask -Name * -Storage "Any disk storage" | Save-BESyntheticBackupDefinition

これらのコマンドは「Backup Definition 01」という名前の合成バックアップ定義に含まれるすべての増分バックアップのストレージを「Any disk storage」プールに設定します。

Example 3
C:\PS> Get-BESyntheticBackupJobDefault | Set-BESyntheticIncrementalBackupTask -Name * -Storage "Any disk storage" | Save-BESyntheticBackupJobDefault

これらのコマンドは合成バックアップジョブのデフォルトに含まれるすべての増分バックアップのストレージを「Any disk storage」プールに設定します。

Related Links

New-BESyntheticBackupDefinition
Get-BESyntheticBackupJobDefault
Save-BESyntheticBackupDefinition
Save-BESyntheticBackupJobDefault
Get-BEStorage
Get-BEMediaSet
Get-BEMediaVault
New-BESchedule
Get-BESyntheticBackupDefinition


Set-BESyntheticInitialFullBackupTask Help

Set-BESyntheticInitialFullBackupTask Cmdlet
Synopsis

Backup Exec の合成バックアップ定義の初回の合成完全バックアップを修正します。

Syntax
Set-BESyntheticInitialFullBackupTask -SyntheticBackupDefinition <BESyntheticBackupDefinition> [-PrePostCommandSuccessfulIfReturnsZero <Boolean>] [-PostCommand <String>] [-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>] [-RunJobOnlyIfPreCommandIsSuccessful <Boolean>] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-TapeStorageCompressionMethod {None | SoftwareIfNoHardware | HardwareOnly | SoftwareOnly}] [-PreCommand <String>] [-EnableDirectAccessIfAvailable <Boolean>] [-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>] [-EncryptionKey <BEEncryptionKey>] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>] [-RunPostCommandAfterVerification <Boolean>] [-VerifyAsPartOfJob <Boolean>] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-TapeStorageEjectMediaAfterComplete <Boolean>] [-TapeStorageExportMediaToVault <BEMediaVault>] [-TapeStorageEnableDirectCopyToTape <Boolean>] [-TapeStorageEnableWriteOnceReadManyMedia <Boolean>] [-Storage <BEStorage>] [-JobName <String>] [-TapeStorageExportMedia <Boolean>] [-TapeStorageMediaSet <BEMediaSet>] [-TapeStorageRetensionMediaBeforeBackup <Boolean>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-KeepJobQueuedFor <TimeSpan>] [-IncludeJobLogWithEmailNotification <Boolean>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-SubmitOnHold <Boolean>] [-DiskStorageKeepForHours <Int32>] [-Schedule <BESchedule>] [-BackupSetDescription <String>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Set-BESyntheticInitialFullBackupTask -SyntheticBackupJobDefault <BESyntheticBackupJobDefaults> [-RunJobOnlyIfPreCommandIsSuccessful <Boolean>] [-PrePostCommandSuccessfulIfReturnsZero <Boolean>] [-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>] [-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>] [-EnableDirectAccessIfAvailable <Boolean>] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-PostCommand <String>] [-PreCommand <String>] [-EncryptionKey <BEEncryptionKey>] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>] [-RunPostCommandAfterVerification <Boolean>] [-VerifyAsPartOfJob <Boolean>] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-TapeStorageCompressionMethod {None | SoftwareIfNoHardware | HardwareOnly | SoftwareOnly}] [-TapeStorageEnableWriteOnceReadManyMedia <Boolean>] [-TapeStorageEjectMediaAfterComplete <Boolean>] [-TapeStorageRetensionMediaBeforeBackup <Boolean>] [-TapeStorageEnableDirectCopyToTape <Boolean>] [-TapeStorageMediaSet <BEMediaSet>] [-Storage <BEStorage>] [-TapeStorageExportMediaToVault <BEMediaVault>] [-TapeStorageExportMedia <Boolean>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-KeepJobQueuedFor <TimeSpan>] [-IncludeJobLogWithEmailNotification <Boolean>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-SubmitOnHold <Boolean>] [-DiskStorageKeepForHours <Int32>] [-Schedule <BESchedule>] [-BackupSetDescription <String>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec の合成バックアップ定義の初回の完全バックアップを修正します。

新しい合成バックアップ定義の初回の完全バックアップを修正するか、合成バックアップ定義を編集できます。合成バックアップジョブのデフォルトの初回の完全バックアップを修正することもできます。

新しい合成バックアップ定義の初回の完全バックアップを修正するには、Set-BESyntheticInitialFullBackupTask と New-BESyntheticBackupDefinition を使用します。

既存のバックアップ定義の初回の完全バックアップを修正するには、Set-BESyntheticInitialFullBackupTask と Get-BESyntheticBackupDefinitionを使用します。

バックアップジョブのデフォルトの初回の完全バックアップを修正するには、Set-BESyntheticInitialFullBackupTask と Get-BESyntheticBackupJobDefault を使用します。

合成バックアップ定義を作成または編集する場合、その合成バックアップ定義を Save-BESyntheticBackupDefinition に渡して変更をコミットする必要があります。

合成バックアップジョブのデフォルトを編集する場合、その合成バックアップジョブのデフォルトを Save-BESyntheticBackupJobDefault に渡して変更をコミットする必要があります。

Parameters

-SyntheticBackupDefinition <BESyntheticBackupDefinition>

編集するバックアップ定義を指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-SyntheticBackupJobDefault <BESyntheticBackupJobDefaults>

保存する合成バックアップジョブのデフォルトを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-JobName <String>

このタスクを表すジョブの名前を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Storage <BEStorage>

アラートをフィルタ処理するための 1 つまたは複数のストレージオブジェクトを指定します。オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。Get-BEStorage を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaSet <BEMediaSet>

メディアと関連付けるメディアセットを指定します。メディアはメディアセットの設定に基づいて上書きから保護されます。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。 Get-BEMediaSet を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMedia <Boolean>

ジョブの完了後にデバイスからメディアをエクスポートします。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMediaToVault <BEMediaVault>

ジョブの完了後にメディアを指定したボルトに論理的に移動します。Storage パラメータはテープベースのストレージデバイスに設定し、TapeStorageExportMedia は $true に設定する必要があります。Get-BEMediaVault を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEjectMediaAfterComplete <Boolean>

ジョブの完了後にストレージデバイスからメディアを取り出します。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableWriteOnceReadManyMedia <Boolean>

バックアップジョブに WORM (Write Once Read Many) メディアの使用を指定します。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableDirectCopyToTape <Boolean>

物理テープデバイスに仮想テープライブラリから直接データをコピーできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageRetensionMediaBeforeBackup <Boolean>

データを書き込む前にメディアのリテンションを行います。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskStorageKeepForHours <Int32>

メディアへの上書きを禁止し、このメディア上にデータを保存する時間を指定します。 Storage パラメータがディスクベースのストレージデバイスに設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SubmitOnHold <Boolean>

ジョブを保留状態でサブミットします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupSetDescription <String>

バックアップしたデータとその格納場所についての説明です。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Schedule <BESchedule>

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

予定開始時刻の経過後に、ジョブが未処理であると Backup Exec が判断し、そのジョブのスケジュール再設定が可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

予定開始時刻後にジョブの実行が続行されている場合、そのジョブのキャンセルが可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NotificationRecipientList <BENotificationRecipientObject[]>

ジョブが完了したときに通知を受け取る受信者を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IncludeJobLogWithEmailNotification <Boolean>

電子メールにジョブログを添付します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageCompressionMethod

使用するソフトウェアデータ圧縮またはハードウェアデータ圧縮の種類を指定します。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
None
SoftwareIfNoHardware
HardwareOnly
SoftwareOnly

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaAppendMethod

ジョブの開始時にメディアに上書きまたは追記します。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
Append
AppendOnly
Overwrite

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableDirectAccessIfAvailable <Boolean>

Agent for Windows から Storage パラメータで指定したデバイスにバックアップデータを直接送信できるようにします (デバイスがこの操作をサポートしている場合)。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreCommand <String>

バックアップジョブの前に実行するコマンドを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PostCommand <String>

バックアップジョブの後に実行するコマンドを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PrePostCommandSuccessfulIfReturnsZero <Boolean>

Backup Exec によってプリコマンドまたはポストコマンドの戻りコードを確認し、コマンドが正しく完了したかどうかを調べることができます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunJobOnlyIfPreCommandIsSuccessful <Boolean>

プリコマンドが正しく実行された場合にのみバックアップジョブを実行します。プリコマンドの実行に失敗した場合は、ジョブは実行されません。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>

プリコマンドが正しく実行された場合にのみポストコマンドを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>

ジョブが正しく実行されなかった場合でもポストコマンドを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandAfterVerification <Boolean>

バックアップジョブの検証を選択した場合、検証が完了した後にポストコマンドを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>

完了しなかったプリコマンドまたはポストコマンドをキャンセルするのに待つ時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunCommandLocation

プリコマンドとポストコマンドが実行される場所を指定します。

The valid values are:
OnEachAgentServer
OnBackupExecServer

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VerifyAsPartOfJob <Boolean>

バックアップジョブの完了時に自動的に検証操作を実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionType

バックアップジョブに使用する暗号化の種類を指定します。

The valid values are:
None
Software
Hardware
SoftwareIfNoHardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionKey <BEEncryptionKey>

使用する暗号化キーを指定します。 EncryptionType が None 以外の値に設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BESyntheticBackupDefinition

Backup Exec の合成バックアップジョブのデフォルトオブジェクトを Set-BESyntheticInitialFullBackupTask にパイプ処理できます。

BackupExec.Management.CLI.BESyntheticBackupJobDefaults

Backup Exec の合成バックアップジョブのデフォルトオブジェクトを Set-BESyntheticInitialFullBackupTask にパイプ処理できます。

Return Values
BackupExec.Management.CLI.BESyntheticBackupDefinition

Set-BESyntheticInitialFullBackupTask は Backup Exec の合成バックアップ定義を表すオブジェクトを返します。

BackupExec.Management.CLI.BESyntheticBackupJobDefaults

合成バックアップジョブのデフォルトが修正されました。

Examples

Example 1

C:\PS> Get-BESyntheticBackupDefinition "Backup Definition 01" | Set-BESyntheticInitialFullBackupTask -Storage "Any disk storage" | Save-BESyntheticBackupDefinition

これらのコマンドは「Backup Definition 01」という名前の合成バックアップ定義に含まれる初回の完全バックアップのストレージを「Any disk storage」プールに設定します。

Example 2
C:\PS> Get-BESyntheticBackupDefinition "Backup Definition 01" | Set-BESyntheticInitialFullBackupTask -Name * -Storage "Any disk storage" | Save-BESyntheticBackupDefinition

これらのコマンドは「Backup Definition 01」という名前の合成バックアップ定義に含まれる初回の完全バックアップのストレージを「Any disk storage」プールに設定します。

Example 3
C:\PS> Get-BESyntheticBackupJobDefault | Set-BESyntheticIncrementalBackupTask -Name * -Storage "Any disk storage" | Save-BESyntheticBackupJobDefault

これらのコマンドは合成バックアップジョブのデフォルトに含まれる初回の完全バックアップのストレージを「Any disk storage」プールに設定します。

Related Links

New-BESyntheticBackupDefinition
Get-BESyntheticBackupJobDefault
Save-BESyntheticBackupDefinition
Save-BESyntheticBackupJobDefault
Get-BEStorage
Get-BEMediaSet
Get-BEMediaVault
New-BESchedule
Get-BESyntheticBackupDefinition
Set-BESyntheticIncrementalBackupTask


Set-BETapeDriveDevice Help

Set-BETapeDriveDevice Cmdlet
Synopsis

Backup Exec のテープドライブデバイスのプロパティを設定します。

Syntax
Set-BETapeDriveDevice -InputObject <BETapeDriveDevice[]> [-ReadSingleBlockModeEnabled <Boolean>] [-WriteSingleBlockModeEnabled <Boolean>] [-BufferCount <Int32>] [-HighWaterCount <Int32>] [-ReadScsiPassThruModeEnabled <Boolean>] [-WriteScsiPassThruModeEnabled <Boolean>] [-Description <String>] [-Disabled <Boolean>] [-ReadableMediaType <BEMediaType[]>] [-WritableMediaType <BEMediaType[]>] [-BlockSizeBytes <Int32>] [-BufferSizeBytes <Int32>] [-Paused <Boolean>] [-CompressionEnabled <Boolean>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のテープドライブデバイスのプロパティを設定します。

Parameters

-ReadableMediaType <BEMediaType[]>

読み取り可能なメディアの種類を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WritableMediaType <BEMediaType[]>

書き込み可能なメディアの種類を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

テープドライブデバイスの説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Disabled <Boolean>

テープドライブデバイスを無効にするかどうかを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Paused <Boolean>

テープドライブデバイスを一時停止するかどうかを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CompressionEnabled <Boolean>

このデバイスで圧縮を有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BlockSizeBytes <Int32>

新しいメディアに書き込まれるデータのブロックサイズをバイトで指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BufferSizeBytes <Int32>

読み取りまたは書き込み要求でディスクカートリッジに送信されるデータ量を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BufferCount <Int32>

このテープデバイスに割り当てるバッファ数を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-HighWaterCount <Int32>

テープドライブへのデータの送信開始時や、その後テープドライブにアンダーランが発生した場合に満たす必要のあるバッファ数を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ReadSingleBlockModeEnabled <Boolean>

このテープドライブが、バッファブロックのサイズに関係なく、一度に 1 ブロックのデータのみを読み取るかどうかを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WriteSingleBlockModeEnabled <Boolean>

このテープドライブで一度に 1 ブロックのデータのみを書き込むかどうかを指定します。 このパラメータを使用すると、データ書き込みエラー処理を細かく制御することができます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ReadScsiPassThruModeEnabled <Boolean>

このテープドライブで Microsoft 社のテープデバイス API を使用せずにデータを読み取るかどうかを指定します。 このパラメータを使用すると、データはテープドライブを通じて直接渡されるため、デバイスエラーが発生した場合に、より詳細な情報を入手することができます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WriteScsiPassThruModeEnabled <Boolean>

このテープドライブで Microsoft 社のテープデバイス API を使用せずにデータを書き込むかどうかを指定します。 このパラメータを使用すると、データはデバイスドライバを通じて直接渡されるため、デバイスエラーが発生した場合に、より詳細な情報を入手することができます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BETapeDriveDevice[]>

1 つ以上のテープドライブデバイスオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BETapeDriveDevice

Backup Exec テープドライブデバイスオブジェクトを Set-BETapeDriveDevice にパイプ処理することができます。

Return Value
BackupExec.Management.CLI.BETapeDriveDevice

Set-BETapeDriveDevice は変更されたテープドライブデバイスを表すオブジェクトを返します。

Example

C:\PS> Get-BETapeDriveDevice "Device 0001" | Set-BETapeDriveDevice -Paused $true

これらのコマンドは「Device 0001」という名前のテープドライブデバイスを一時停止します。

Related Link

Get-BETapeDriveDevice


Set-BETapeDriveToDefaultSetting Help

Set-BETapeDriveToDefaultSetting Cmdlet
Synopsis

リモートサーバー上のテープドライブの優先構成設定をデフォルト設定に戻します。

Syntax
Set-BETapeDriveToDefaultSetting -InputObject <BETapeDriveDevice[]> [<CommonParameters>]
Description

リモートサーバー上のテープドライブの優先構成設定をデフォルト設定に戻します。

Parameters

-InputObject <BETapeDriveDevice[]>

1 つ以上のテープドライブオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BETapeDriveDevice

Backup Exec テープドライブオブジェクトを Set-BETapeDriveToDefaultSetting にパイプ処理することができます。

Return Value
BackupExec.Management.CLI.BETapeDriveDevice

Set-BETapeDriveToDefaultSetting はデフォルト設定にリセットされたテープドライブを表すオブジェクトを返します。

Example

C:\PS> $TapeDrive = Get-BETapeDriveDevice -Name "Tape drive 0001"
C:\PS> $TapeDrive | Reset-BETapeDriveToDefaultSetting

このコマンドはパイプ処理された Backup Exec のテープドライブデバイスをそのデフォルト設定にリセットします。

Related Link

Get-BETapeDriveDevice


Set-BETraceSource Help

Set-BETraceSource Cmdlet
Synopsis

BEMCLI コンポーネントのトレースを設定、開始、停止します。

Syntax
Set-BETraceSource [[-FilePath] <String>] [[-Level] {Off | Critical | Error | Warning | Information | Verbose | ActivityTracing | All}] [-Debugger <SwitchParameter>] [-PSHost <SwitchParameter>] [-ListenerOptions {None | LogicalOperationStack | DateTime | Timestamp | ProcessId | ThreadId | Callstack}] [-Force <SwitchParameter>] [<CommonParameters>]

Set-BETraceSource [-RemoveFilePath <String>] [-RemoveDebugger <SwitchParameter>] [-RemovePSHost <SwitchParameter>] [<CommonParameters>]
Description

BEMCLI コンポーネントのトレースを設定、開始、停止します。

Parameters

-Level

トレースするイベントの種類を指定します。

The valid values are:
Off
Critical
Error
Warning
Information
Verbose
ActivityTracing
All

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-ListenerOptions

出力の各トレースメッセージのプレフィックスにオプションデータを追加します。 複数のオプションを指定するには、"ProcessID,ThreadID" などのように、各オプションをスペースを入れずにカンマで区切り、二重引用符で囲みます。

The valid values are:
None
LogicalOperationStack
DateTime
Timestamp
ProcessId
ThreadId
Callstack

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FilePath <String>

指定されたファイルにトレース出力を送信します。 このパラメータでは、ファイルトレースリスナーも選択します。 このパラメータを使用してトレースを開始する場合は、RemoveFilePath パラメータを使用してトレースを停止してください。

Required | false
Position | 1
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-PSHost <SwitchParameter>

Windows PowerShell ホストにトレース出力を送信します。 このパラメータでは、PSHost トレースリスナーも選択します。 このパラメータを使用してトレースを開始する場合は、RemovePSHost パラメータを使用してトレースを停止してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Debugger <SwitchParameter>

デバッガにトレース出力を送信します。 出力は、ユーザーモードまたはカーネルモードのデバッガすべて、または Microsoft Visual Studio で表示できます。 このパラメータでは、デフォルトのトレースリスナーも選択します。 このパラメータを使用してトレースを開始する場合は、RemoveDebugger パラメータを使用してトレースを停止してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RemovePSHost <SwitchParameter>

PSHost トレースリスナーを削除することによってトレースを停止します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RemoveDebugger <SwitchParameter>

デバッガトレースリスナーを削除することによってトレースを停止します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RemoveFilePath <String>

指定したファイルに関連付けられたファイルトレースリスナーを削除することによってトレースを停止します。 トレース出力ファイルのパスとファイル名を入力します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Force <SwitchParameter>

コマンドレットに読み取り専用ファイルの上書きを許可します。 FilePath パラメータと一緒に使用します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

文字列を Set-BETraceSource にパイプ処理してファイルトレースリスナーを有効にすることができます。

Return Value
None

このコマンドレットは出力を生成しません。

Examples

Example 1

C:\PS> Set-BETraceSource -Level Information -PSHost

このコマンドは、情報レベルのイベントの BEMCLI トレースを開始し、Windows PowerShell ホストに記録します。

Example 2
C:\PS> Set-BETraceSource -RemovePSHost

このコマンドは Windows PowerShell ホストへの BEMCLI イベントのトレースを停止します。


Set-BEUnlockUtilityJob Help

Set-BEUnlockUtilityJob Cmdlet
Synopsis

ロボットライブラリのフロントポータルをロック解除する Backup Exec のジョブのプロパティを設定します。

Syntax
Set-BEUnlockUtilityJob -InputObject <BEUnlockUtilityJob[]> [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-Schedule <BESchedule>] [-KeepJobQueuedFor <TimeSpan>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

ロボットライブラリのフロントポータルをロック解除する Backup Exec のジョブのプロパティを設定します。

Parameters

-Schedule <BESchedule>

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

予定開始時刻の経過後に、ジョブが未処理であると Backup Exec が判断し、そのジョブのスケジュール再設定が可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

予定開始時刻後にジョブの実行が続行されている場合、そのジョブのキャンセルが可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEUnlockUtilityJob[]>

1 つ以上のロック解除ジョブオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEUnlockUtilityJob

Backup Exec ロック解除ジョブを Set-BEUnlockUtilityJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEUnlockUtilityJob

Set-BEUnlockUtilityJob は、ロボットライブラリのフロントポータルをロック解除する、変更された Backup Exec のジョブを表すオブジェクトを返します。

Example

C:\PS> $Schedule = New-BESchedule -RunNow
C:\PS> Get-BEUnlockUtilityJob -Name "UnlockJob" | Set-BEUnlockUtilityJob -Schedule $Schedule

これらのコマンドは、今から実行する「UnlockJob」という名前のロック解除ジョブのスケジュールを設定します。

Related Links


Set-BEUserDefaultLogonAccount Help

Set-BEUserDefaultLogonAccount Cmdlet
Synopsis

現在のユーザーに Backup Exec のデフォルトログオンアカウントを設定します。

Syntax
Set-BEUserDefaultLogonAccount -LogonAccount <BELogonAccount> [[-CurrentPassword] <SecureString>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

現在のユーザーに Backup Exec のデフォルトログオンアカウントを設定します。

Parameters

-LogonAccount <BELogonAccount>

Backup Exec ログオンアカウントを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-CurrentPassword <SecureString>

このアカウントに割り当てられている現在のパスワードを指定します。 このパスワードの指定は、ログオンアカウントの所有者ではないユーザーとしてログインしている場合に、そのログオンアカウントが所有者専用であるときに必要です。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BELogonAccount

Backup Exec ログオンアカウントオブジェクトを Set-BEUserDefaultLogonAccount にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BELogonAccount

Set-BEUserDefaultLogonAccount は、変更されたログオンアカウントを表すオブジェクトを返します。

Example

C:\PS> Get-BELogonAccount "LogonAccount 0001" | Set-BEUserDefaultLogonAccount

これらのコマンドは、「LogonAccount 0001」という名前のログオンアカウントを現在のユーザーのデフォルトログオンアカウントに設定します。

Related Link

Get-BELogonAccount


Set-BEVerifyBackupTask Help

Set-BEVerifyBackupTask Cmdlet
Synopsis

Backup Exec でのバックアップ定義の検証タスクを修正します。

Syntax
Set-BEVerifyBackupTask -BackupDefinition <BEBackupDefinition> [-Name] <String[]> [-IncludeJobLogWithEmailNotification <Boolean>] [-VerifyDataOnClient <Boolean>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Set-BEVerifyBackupTask -BackupDefinition <BEBackupDefinition> [-Name] <String[]> -ImmediatelyAfterBackup <String> [-IncludeJobLogWithEmailNotification <Boolean>] [-VerifyDataOnClient <Boolean>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Set-BEVerifyBackupTask -BackupDefinition <BEBackupDefinition> [-Name] <String[]> -Schedule <BESchedule> -SourceBackup <String[]> [-IncludeJobLogWithEmailNotification <Boolean>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-VerifyDataOnClient <Boolean>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Set-BEVerifyBackupTask -BackupJobDefault <BEBackupJobDefaults> [-Name] <String[]> [-IncludeJobLogWithEmailNotification <Boolean>] [-VerifyDataOnClient <Boolean>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Set-BEVerifyBackupTask -BackupJobDefault <BEBackupJobDefaults> [-Name] <String[]> -ImmediatelyAfterBackup <String> [-IncludeJobLogWithEmailNotification <Boolean>] [-VerifyDataOnClient <Boolean>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Set-BEVerifyBackupTask -BackupJobDefault <BEBackupJobDefaults> [-Name] <String[]> -Schedule <BESchedule> -SourceBackup <String[]> [-IncludeJobLogWithEmailNotification <Boolean>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-VerifyDataOnClient <Boolean>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Set-BEVerifyBackupTask -SyntheticBackupDefinition <BESyntheticBackupDefinition> [-Name] <String[]> [-IncludeJobLogWithEmailNotification <Boolean>] [-VerifyDataOnClient <Boolean>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Set-BEVerifyBackupTask -SyntheticBackupDefinition <BESyntheticBackupDefinition> [-Name] <String[]> -ImmediatelyAfterBackup <String> [-IncludeJobLogWithEmailNotification <Boolean>] [-VerifyDataOnClient <Boolean>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Set-BEVerifyBackupTask -SyntheticBackupDefinition <BESyntheticBackupDefinition> [-Name] <String[]> -Schedule <BESchedule> -SourceBackup <String[]> [-IncludeJobLogWithEmailNotification <Boolean>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-VerifyDataOnClient <Boolean>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Set-BEVerifyBackupTask -SyntheticBackupJobDefault <BESyntheticBackupJobDefaults> [-Name] <String[]> [-IncludeJobLogWithEmailNotification <Boolean>] [-VerifyDataOnClient <Boolean>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Set-BEVerifyBackupTask -SyntheticBackupJobDefault <BESyntheticBackupJobDefaults> [-Name] <String[]> -ImmediatelyAfterBackup <String> [-IncludeJobLogWithEmailNotification <Boolean>] [-VerifyDataOnClient <Boolean>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Set-BEVerifyBackupTask -SyntheticBackupJobDefault <BESyntheticBackupJobDefaults> [-Name] <String[]> -Schedule <BESchedule> -SourceBackup <String[]> [-IncludeJobLogWithEmailNotification <Boolean>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-VerifyDataOnClient <Boolean>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec でのバックアップ定義の検証タスクを修正します。

新しいバックアップ定義でタスクを検証するか、既存のバックアップ定義を編集できます。 また、バックアップジョブのデフォルトで検証タスクを修正することもできます。

新しいバックアップ定義の検証タスクを修正するには、Set-BEVerifyBackupTask と New-BEBackupDefinition を使用します。

既存のバックアップ定義の検証タスクを修正するには、Set-BEVerifyBackupTask と New-BEBackupDefinition を使用します。

バックアップジョブのデフォルトで検証タスクを修正するには、Set-BEVerifyBackupTask と Get-BEBackupJobDefault を使用します。

バックアップ定義を作成または編集する場合、そのバックアップ定義を Save-BEBackupDefinition に渡して変更をコミットする必要があります。

バックアップジョブのデフォルトを編集する場合、そのバックアップジョブのデフォルトを Save-BEBackupJobDefault に渡して変更をコミットする必要があります。

Parameters

-BackupDefinition <BEBackupDefinition>

変更するバックアップ定義を指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupJobDefault <BEBackupJobDefaults>

変更するバックアップジョブのデフォルトを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-SyntheticBackupDefinition <BESyntheticBackupDefinition>

変更する合成バックアップ定義を指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-SyntheticBackupJobDefault <BESyntheticBackupJobDefaults>

変更する合成バックアップジョブのデフォルトを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-SourceBackup <String[]>

1 つまたは複数のバックアップをバックアップ定義で指定して、スケジュールの設定単位で検証します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ImmediatelyAfterBackup <String>

バックアップ定義で検証するバックアップジョブの名前を指定します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Schedule <BESchedule>

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VerifyDataOnClient <Boolean>

Backup Exec エージェントがサポートしている場合には、検証操作をリモートで実行できます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NotificationRecipientList <BENotificationRecipientObject[]>

ジョブが完了したときに通知を受け取る受信者を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IncludeJobLogWithEmailNotification <Boolean>

電子メールにジョブログを添付します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String[]>

検証タスクの名前を指定します。

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupDefinition

Backup Exec のバックアップ定義オブジェクトを Set-BEVerifyBackupTask にパイプ処理できます。

BackupExec.Management.CLI.BEBackupJobDefaults

Backup Exec のバックアップジョブのデフォルトオブジェクトを Set-BEVerifyBackupTask にパイプ処理できます。

Return Values
BackupExec.Management.CLI.BEBackupDefinition

修正されたバックアップ定義を示します。

BackupExec.Management.CLI.BEBackupJobDefaults

修正されたバックアップジョブのデフォルトを示します。

Examples

Example 1

C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Set-BEVerifyBackupTask -Name "Verify 2" -VerifyDataOnClient $true | Save-BEBackupDefinition

これらのコマンドは、「Backup Definition 01」という名前のバックアップ定義にある「Verify 2」という名前の検証タスクの VerifyDataOnClient 設定を True に設定します。

Example 2
C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Set-BEVerifyBackupTask -Name * -VerifyDataOnClient $true | Save-BEBackupDefinition

これらのコマンドは、「Backup Definition 01」という名前のバックアップ定義にあるすべての検証タスクの VerifyDataOnClient 設定を True に設定します。

Related Links


Set-BEVirtualDiskDevice Help

Set-BEVirtualDiskDevice Cmdlet
Synopsis

Backup Exec の仮想ディスクデバイスのプロパティを設定します。

Syntax
Set-BEVirtualDiskDevice -InputObject <BEVirtualDiskDevice[]> [[-BackupExecServer] <BEBackupExecServer>] [-BufferSizeBytes <Int32>] [-DiskSpaceReserveBytes <Int64>] [-PreallocationIncrementBytes <Int64>] [-BlockSizeBytes <Int32>] [-BufferedReadsWritesAutoDetectEnabled <Boolean>] [-VirtualWriteProtectionEnabled <Boolean>] [-AllowedConcurrentWriteOperations <UInt32>] [-Disabled <Boolean>] [-Paused <Boolean>] [-PreallocationEnabled <Boolean>] [-Description <String>] [-LowDiskSpaceCriticalThresholdPercent <Int32>] [-MaximumFileSizeBytes <Int64>] [-LowDiskSpaceInformationThresholdPercent <Int32>] [-LowDiskSpaceWarningThresholdPercent <Int32>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec の仮想ディスクデバイスのプロパティを設定します。

Parameters

-BackupExecServer <BEBackupExecServer>

CASO 環境でデバイスを接続する Backup Exec サーバーを指定します。

Required | false
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

仮想ディスクデバイスの説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Disabled <Boolean>

仮想ディスクデバイスを無効にするかどうかを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Paused <Boolean>

仮想ディスクデバイスを一時停止するかどうかを指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LowDiskSpaceInformationThresholdPercent <Int32>

初回のディスク容量低下アラートに関する最初のしきい値の制限を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LowDiskSpaceWarningThresholdPercent <Int32>

2 回目のディスク容量低下アラートに関する 2 番目のしきい値制限を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LowDiskSpaceCriticalThresholdPercent <Int32>

初回のディスク容量低下アラートに関する 3 番目かつ最後のしきい値制限を指定します。すぐにディスク容量を増やすように要求されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MaximumFileSizeBytes <Int64>

ディスクストレージの最大ファイルサイズを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreallocationEnabled <Boolean>

事前割り当てを有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreallocationIncrementBytes <Int64>

ファイルサイズを増やすための容量を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BlockSizeBytes <Int32>

新しいメディアに書き込まれるデータのブロックサイズをバイトで指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BufferSizeBytes <Int32>

読み取りまたは書き込み要求でディスクカートリッジに送信されるデータ量を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskSpaceReserveBytes <Int64>

Backup Exec 以外のアプリケーション用に空けてあるディスク領域を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualWriteProtectionEnabled <Boolean>

仮想書き込み保護を有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AllowedConcurrentWriteOperations <UInt32>

ディスクへの書き込みの同時並行処理を許可します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BufferedReadsWritesAutoDetectEnabled <Boolean>

Backup Exec が自動的にこのディスクの設定を検出しないように指定し、このディスクストレージで読み取りバッファと書き込みバッファの使用を許可するように設定します。読み取りバッファと書き込みバッファとは、大きなデータブロックの読み取りと書き込みです。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEVirtualDiskDevice[]>

1 つ以上の仮想ディスクデバイスオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEVirtualDiskDevice

Backup Exec 仮想ディスクデバイスオブジェクトを Set-BEVirtualDiskDevice にパイプ処理することができます。

Return Value
BackupExec.Management.CLI.BEVirtualDiskDevice

Set-BEVirtualDiskDevice は変更された仮想ディスクデバイスを表すオブジェクトを返します。

Example

C:\PS> Get-BEVirtualDiskDevice "Device 0001" | Set-BEVirtualDiskDevice -Paused $true

これらのコマンドは「Device 0001」という名前の仮想ディスクデバイスを一時停止します。

Related Link

Get-BEVirtualDiskDevice


Show-BEHelp Help

Show-BEHelp Cmdlet
Synopsis

BEMCLI ヘルプマニュアルを起動します。

Syntax
Show-BEHelp [<CommonParameters>]
Description

BEMCLI ヘルプマニュアルを起動します。

Parameters

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

このコマンドレットは入力を受け入れません。

Return Value
None

このコマンドレットは出力を生成しません

Example

C:\PS> Show-BEHelp

このコマンドは BEMCLI ヘルプマニュアルを起動します。


Start-BEJob Help

Start-BEJob Cmdlet
Synopsis

Backup Exec ジョブを開始します。

Syntax
Start-BEJob -InputObject <BEJob[]> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [-Force <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec ジョブを開始します。

Start-BEJob は保留中や完了済みのジョブを含めて任意の Backup Exec ジョブを開始できます。

Parameters

-InputObject <BEJob[]>

1 つ以上のジョブオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Force <SwitchParameter>

Start-BEJob が選択項目に破棄されたサーバーのみを含んでいるジョブを開始できることを確認します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEJob

Backup Exec ジョブオブジェクトを Start-BEJob にパイプ処理することができます。

Return Value
BackupExec.Management.CLI.BEJob

Start-BEJob は Backup Exec ジョブオブジェクトを返します。

Example

C:\PS> Get-BEJob -Name "Job 0001" | Start-BEJob

これらのコマンドは「Job 0001」という名前の Backup Exec ジョブを開始します。

Related Link

Get-BEJob


Start-BEService Help

Start-BEService Cmdlet
Synopsis

1 つ以上の Backup Exec サービスを起動します。

Syntax
Start-BEService [[-Name] <String[]>] [-All <SwitchParameter>] [-TimeoutSeconds <Int32>] [-PassThru <SwitchParameter>] [-ServiceType {Core | Deduplication}] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Start-BEService -DisplayName <String[]> [-All <SwitchParameter>] [-ServiceType {Core | Deduplication}] [-TimeoutSeconds <Int32>] [-PassThru <SwitchParameter>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

1 つ以上の Backup Exec サービスを起動します。

Start-BEService にパラメータを渡さない場合、すべてのコア Backup Exec サービスが起動されます。

Parameters

-TimeoutSeconds <Int32>

各 Backup Exec サービスの起動の時間の長さを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PassThru <SwitchParameter>

サービスを表すオブジェクトを返します。 デフォルトでは、このコマンドレットは出力を生成しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String[]>

起動する Backup Exec サービスの名前を指定します。

Required | false
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | true

-DisplayName <String[]>

再起動する Backup Exec サービスの共通名を指定します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ServiceType

起動する Backup Exec サービスの種類を指定します。

The valid values are:
Core
Deduplication

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-All <SwitchParameter>

Backup Exec のすべてのサービスを起動します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

Backup Exec サービスの名前を Start-BEService にパイプ処理できます。

Return Value
System.ServiceProcess.ServiceController

PassThru パラメータを指定した場合、Start-BEService はサービスを表す System.ServiceProcess.ServiceController オブジェクトを生成します。 それ以外の場合、このコマンドレットは出力を生成しません。

Examples

Example 1

C:\PS> Start-BEService

このコマンドは、すべての Backup Exec コアサービスを起動します。

Example 2
C:\PS> Start-BEService -ServiceType Deduplication

このコマンドは、すべての Backup Exec 重複排除用サービスを起動します。


Stop-BEJob Help

Stop-BEJob Cmdlet
Synopsis

アクティブな Backup Exec ジョブをキャンセルします。

Syntax
Stop-BEJob -InputObject <BEJob[]> [-TimeoutSeconds <Int32>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

実行中のアクティブな Backup Exec ジョブをキャンセルします。

Stop-BEJob はキャンセルしたジョブに関連付けられているジョブ履歴を返します。

-TimeoutSeconds パラメータを指定しない場合、Stop-BEJob は指定したジョブがキャンセル状態になるのを無期限に待機します。

-TimeoutSeconds パラメータを指定し、ジョブがキャンセル状態になる前に指定した時間が経過した場合、ジョブが実行中であってもこのコマンドは戻ります。 エラーメッセージは表示されません。

Parameters

-TimeoutSeconds <Int32>

各ジョブについて待機する最大時間を秒単位で決定します。 ジョブがキャンセル状態になる前にこの時間が経過した場合、ジョブが実行中であってもこのコマンドは戻ります。 エラーメッセージは表示されません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEJob[]>

1 つ以上のジョブオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEJob

Backup Exec ジョブオブジェクトを Stop-BEJob にパイプ処理することができます。

Return Value
BackupExec.Management.CLI.BEJobHistory

-TimeoutSeconds の時間が経過していない場合、Stop-BEJob は Backup Exec ジョブ履歴オブジェクトを返します。この時間が経過した場合は何も返しません。

Example

C:\PS> Get-BEJob "Job 0001" | Stop-BEJob

これらのコマンドは「Job 0001」という名前のジョブをキャンセルします。

Related Link

Get-BEJob


Stop-BEService Help

Stop-BEService Cmdlet
Synopsis

1 つ以上の Backup Exec サービスを停止します。

Syntax
Stop-BEService [[-Name] <String[]>] [-All <SwitchParameter>] [-TimeoutSeconds <Int32>] [-PassThru <SwitchParameter>] [-ServiceType {Core | Deduplication}] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Stop-BEService -DisplayName <String[]> [-All <SwitchParameter>] [-ServiceType {Core | Deduplication}] [-TimeoutSeconds <Int32>] [-PassThru <SwitchParameter>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

1 つ以上の Backup Exec サービスを停止します。

Stop-BEService にパラメータを渡さない場合、すべてのコア Backup Exec サービスが停止されます。

Parameters

-TimeoutSeconds <Int32>

各 Backup Exec サービスの停止の時間の長さを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PassThru <SwitchParameter>

サービスを表すオブジェクトを返します。 デフォルトでは、このコマンドレットは出力を生成しません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String[]>

停止する Backup Exec サービスの名前を指定します。

Required | false
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | true

-DisplayName <String[]>

再起動する Backup Exec サービスの共通名を指定します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ServiceType

停止する Backup Exec サービスを指定します。

The valid values are:
Core
Deduplication

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-All <SwitchParameter>

Backup Exec のすべてのサービスを停止します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

Backup Exec サービスの名前を Stop-BEService にパイプ処理できます。

Return Value
System.ServiceProcess.ServiceController

PassThru パラメータを指定した場合、Stop-BEService はサービスを表す System.ServiceProcess.ServiceController オブジェクトを生成します。 それ以外の場合、このコマンドレットは出力を生成しません。

Examples

Example 1

C:\PS> Stop-BEService

このコマンドは、すべての Backup Exec コアサービスを停止します。

Example 2
C:\PS> Stop-BEService -ServiceType Deduplication

このコマンドは、すべての Backup Exec 重複排除用サービスを停止します。


Submit-BECatalogMediaJob Help

Submit-BECatalogMediaJob Cmdlet
Synopsis

Backup Exec のメディアでバックアップセットのカタログ登録を実行するジョブをサブミットします。

Syntax
Submit-BECatalogMediaJob -DiskCartridgeDevice <BEDiskCartridgeDevice> [[-Name] <String>] [-MediaPassword <SecureString>] [-BackupExecServer <BEBackupExecServer>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Submit-BECatalogMediaJob -TapeDriveDevice <BETapeDriveDevice> [[-Name] <String>] [-MediaPassword <SecureString>] [-BackupExecServer <BEBackupExecServer>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Submit-BECatalogMediaJob -RoboticLibrarySlot <BERoboticLibrarySlot> [[-Name] <String>] [-MediaPassword <SecureString>] [-BackupExecServer <BEBackupExecServer>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Submit-BECatalogMediaJob -DiskStorageDevice <BEDiskStorageDevice> [[-Name] <String>] [-MediaPassword <SecureString>] [-BackupExecServer <BEBackupExecServer>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Submit-BECatalogMediaJob -LegacyBackupToDiskFolderDevice <BELegacyBackupToDiskFolderDevice> [[-Name] <String>] [-MediaPassword <SecureString>] [-BackupExecServer <BEBackupExecServer>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Submit-BECatalogMediaJob -DeduplicationDiskStorageDevice <BEDeduplicationDiskStorageDevice> [[-Name] <String>] [-MediaPassword <SecureString>] [-BackupExecServer <BEBackupExecServer>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Submit-BECatalogMediaJob -OpenStorageDevice <BEOpenStorageDevice> [[-Name] <String>] [-MediaPassword <SecureString>] [-BackupExecServer <BEBackupExecServer>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Submit-BECatalogMediaJob -Media <BEMedia> [[-Name] <String>] [-MediaPassword <SecureString>] [-BackupExecServer <BEBackupExecServer>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のメディアでバックアップセットのカタログ登録を実行するジョブをサブミットします。

ストレージデバイスを指定した場合、カタログ登録するメディアがストレージデバイス内にある必要があります。 メディアを指定した場合、Backup Exec が適切なデバイスを特定してカタログジョブを実行します。

Parameters

-Name <String>

作成するジョブの名前を指定します。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskCartridgeDevice <BEDiskCartridgeDevice>

カタログ登録するディスクカートリッジデバイスを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-TapeDriveDevice <BETapeDriveDevice>

カタログ登録するテープドライブデバイスを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibrarySlot <BERoboticLibrarySlot>

カタログ登録するロボットライブラリスロットを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-DiskStorageDevice <BEDiskStorageDevice>

カタログ登録するディスクストレージデバイスを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-LegacyBackupToDiskFolderDevice <BELegacyBackupToDiskFolderDevice>

カタログ登録する、レガシーのディスクへのバックアップフォルダを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-DeduplicationDiskStorageDevice <BEDeduplicationDiskStorageDevice>

カタログ登録する重複排除用ディスクストレージデバイスを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-OpenStorageDevice <BEOpenStorageDevice>

カタログ登録する OpenStorage デバイスを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Media <BEMedia>

カタログ登録するメディアを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

CASO 環境でジョブを処理する Backup Exec サーバーを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MediaPassword <SecureString>

メディアがパスワードで保護される場合のメディアのパスワードを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEDiskCartridgeDevice

Backup Exec のディスクカートリッジデバイスオブジェクトを Submit-BECatalogMediaJob にパイプ処理できます。

BackupExec.Management.CLI.BEDiskStorageDevice

Backup Exec ディスクストレージデバイスオブジェクトを Submit-BECatalogMediaJob にパイプ処理できます。

BackupExec.Management.CLI.BELegacyBackupToDiskFolderDevice

Backup Exec のレガシーのディスクへのバックアップフォルダオブジェクトを Submit-BECatalogMediaJob にパイプ処理できます。

BackupExec.Management.CLI.BEDeduplicationDiskStorageDevice

Backup Exec 重複排除用ディスクデバイスオブジェクトを Submit-BECatalogMediaJob にパイプ処理できます。

BackupExec.Management.CLI.BEOpenStorageDevice

Backup Exec OpenStorage デバイスオブジェクトを Submit-BECatalogMediaJob にパイプ処理できます。

BackupExec.Management.CLI.BETapeDriveDevice

Backup Exec のテープドライブデバイスオブジェクトを Submit-BECatalogMediaJob にパイプ処理できます。

BackupExec.Management.CLI.BERoboticLibrarySlot

Backup Exec のロボットライブラリスロットオブジェクトを Submit-BECatalogMediaJob にパイプ処理できます。

BackupExec.Management.CLI.BEMedia

Backup Exec のメディアオブジェクトを Submit-BECatalogMediaJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEJob

Submit-BECatalogMediaJob はサブミットされたジョブを返します。

Example

C:\PS> Get-BETapeDriveDevice "Device 0001" | Submit-BECatalogMediaJob

これらのコマンドは「Device 0001」という名前のテープドライブデバイス内のメディアをカタログ登録するカタログジョブをサブミットします。

Related Link

Get-BETapeDriveDevice


Submit-BECleanJob Help

Submit-BECleanJob Cmdlet
Synopsis

Backup Exec のテープドライブクリーニングジョブをサブミットします。

Syntax
Submit-BECleanJob -TapeDriveDevice <BETapeDriveDevice> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-Schedule <BESchedule>] [-KeepJobQueuedFor <TimeSpan>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のテープドライブクリーニングジョブをサブミットします。

Parameters

-Name <String>

作成するジョブの名前を指定します。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeDriveDevice <BETapeDriveDevice>

クリーニングテープを含むドライブを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Schedule <BESchedule>

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

予定開始時刻の経過後に、ジョブが未処理であると Backup Exec が判断し、そのジョブのスケジュール再設定が可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

予定開始時刻後にジョブの実行が続行されている場合、そのジョブのキャンセルが可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

CASO 環境でジョブを処理する Backup Exec サーバーを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BETapeDriveDevice

Backup Exec のテープドライブデバイスオブジェクトを Submit-BECleanJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEJob

Submit-BECleanJob はサブミットされたジョブを返します。

Examples

Example 1

C:\PS> Get-BETapeDriveDevice "Device 0001" | Submit-BECleanJob

これらのコマンドは「Device 0001」という名前のテープドライブデバイスをクリーニングするクリーニングジョブをサブミットします。

Example 2
C:\PS> Get-BETapeDriveDevice "Device 0001" | Submit-BECleanJob -Schedule (New-BESchedule -Daily -StartingAt 10pm)

これらのコマンドは毎日午後 10 時に「Device 0001」という名前のテープドライブデバイスをクリーニングするクリーニングジョブをサブミットします。

Related Links


Submit-BEConvertBackupToVirtualJob Help

Submit-BEConvertBackupToVirtualJob Cmdlet
Synopsis

Backup Exec での仮想への変換ジョブをサブミットします。

Syntax
Submit-BEConvertBackupToVirtualJob -AgentServer <BEAgentServer> -TargetEnvironment <BEConvertToVirtualTargetEnvironment> [-AutomaticallyDeleteJob {Never | IfSuccessful | WhenComplete}] [-SubmitOnHold <Boolean>] [-StartDate <DateTime>] [-Priority {Normal | Lowest | Low | High | Highest}] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-IncludeJobLogWithEmailNotification <Boolean>] [-ExcludeNonSystemData <SwitchParameter>] [-NotBefore <DateTime>] [-Name <String>] [-PointInTime <DateTime>] [-VirtualMachinePhysicalRamMB <UInt32>] [-VirtualMachineCpuCount <UInt32>] [-VirtualMachineName <String>] [-OverwriteExistingVirtualMachine <Boolean>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Submit-BEConvertBackupToVirtualJob -JobHistory <BEJobHistory> -TargetEnvironment <BEConvertToVirtualTargetEnvironment> [-SubmitOnHold <Boolean>] [-AutomaticallyDeleteJob {Never | IfSuccessful | WhenComplete}] [-Priority {Normal | Lowest | Low | High | Highest}] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-IncludeJobLogWithEmailNotification <Boolean>] [-StartDate <DateTime>] [-VirtualMachineName <String>] [-Name <String>] [-OverwriteExistingVirtualMachine <Boolean>] [-ExcludeNonSystemData <SwitchParameter>] [-VirtualMachineCpuCount <UInt32>] [-VirtualMachinePhysicalRamMB <UInt32>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec での仮想への変換ジョブをサブミットします。

Backup Exec ジョブ履歴オブジェクトを仮想への変換操作のバックアップセットの特定時点として指定できます。

また、特定時点の範囲を指定して仮想への変換操作のバックアップセットの特定時点を決定することもできます。

Parameters

-Name <String>

ジョブの名前を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AgentServer <BEAgentServer>

データをバックアップしたサーバーを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-PointInTime <DateTime>

仮想への変換操作で使用するバックアップセットでの特定時点を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NotBefore <DateTime>

仮想への変換操作で使用するバックアップセットでの特定開始時点を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-JobHistory <BEJobHistory>

仮想への変換操作で使用するバックアップセットを参照するジョブ履歴オブジェクトを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-TargetEnvironment <BEConvertToVirtualTargetEnvironment>

仮想マシンが作成されるターゲット仮想環境を指定します。 New-BEConvertToVirtualTargetEnvironment を参照してください。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineName <String>

作成する仮想マシンの名前を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OverwriteExistingVirtualMachine <Boolean>

同じ名前の既存の仮想マシンがある場合は、その仮想マシンを上書きます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachinePhysicalRamMB <UInt32>

仮想マシンに割り当てる RAM 容量（MB）を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineCpuCount <UInt32>

仮想マシンに割り当てる CPU の数を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExcludeNonSystemData <SwitchParameter>

仮想への変換操作からユーザーデータを除外します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-StartDate <DateTime>

ジョブを開始する日時を指定します。 このパラメータを指定しない場合、ジョブはすぐに開始されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Priority

ジョブを実行する順序を指定します。2 つのジョブが同時に実行されるようにスケジュールされている場合、ユーザーが設定する優先度でどちらが先に実行されるかが決まります。

The valid values are:
Normal
Lowest
Low
High
Highest

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AutomaticallyDeleteJob

ジョブが完了したら自動的にジョブを削除します。

The valid values are:
Never
IfSuccessful
WhenComplete

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SubmitOnHold <Boolean>

ジョブを保留状態でサブミットします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NotificationRecipientList <BENotificationRecipientObject[]>

ジョブが完了したときに通知を受け取る受信者を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IncludeJobLogWithEmailNotification <Boolean>

電子メールにジョブログを添付します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEAgentServer

Backup Exec エージェントサーバーオブジェクトを Submit-BEConvertBackupToVirtualJob にパイプ処理することができます。

BackupExec.Management.CLI.BEJobHistory

Backup Exec ジョブ履歴オブジェクトを Submit-BEConvertBackupToVirtualJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEJob

Submit-BEConvertBackupToVirtualJob は Backup Exec ジョブオブジェクトを返します。

Examples

Example 1

C:\PS> $targetEnvironment = New-BEConvertToVirtualTargetEnvironment -HyperVServerName hypervserver01 -HyperVDestinationPath c:\vms -LogonAccount "System Logon Account" -ToolsIsoPath c:\hypervtools.iso
C:\PS> Get-BEJob "Job 0001" | Get-BEJobHistory -FromLastJobRun | Submit-BEConvertBackupToVirtualJob -TargetEnvironment $targetEnvironment

これらのコマンドは、「Job 0001」という名前の最新の実行ジョブから得られるデータを使用して Hyper-V サーバーに仮想マシンを作成します。

Example 2
C:\PS> $targetEnvironment = New-BEConvertToVirtualTargetEnvironment -VMwareVCenterServerName vcenterserver01 -VMwareHostName hostserver01 -VMwareDataStoreName datastore01 -LogonAccount "System Logon Account" -ToolsIsoPath c:\vmwaretools.iso
C:\PS> Get-BEAgentServer myserver.mycompany.com | Submit-BEConvertBackupToVirtualJob -TargetEnvironment $targetEnvironment

これらのコマンドは、「myserver.mycompany.com」という名前のサーバーの最新のバックアップから得られるデータを使用して、VMware vCenter 内に仮想マシンを作成します。

Related Links


Submit-BEConvertToVirtualJob Help

Submit-BEConvertToVirtualJob Cmdlet
Synopsis

Backup Exec での仮想への変換ジョブをサブミットします。

Syntax
Submit-BEConvertToVirtualJob -AgentServer <BEAgentServer> [-NotificationRecipientList <BENotificationRecipientObject[]>] [-StartDate <DateTime>] [-VirtualMachineCpuCount <UInt32>] [-IncludeJobLogWithEmailNotification <Boolean>] [-VirtualMachinePhysicalRamMB <UInt32>] [-SubmitOnHold <Boolean>] [-ExcludeSelectionList <BEAgentServerBackupSelectionList>] [-Name <String>] [-OverwriteExistingVirtualMachine <Boolean>] [-VirtualMachineName <String>] [-TargetEnvironment <BEConvertToVirtualTargetEnvironment>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec での仮想への変換ジョブをサブミットします。

Parameters

-Name <String>

仮想への変換ジョブの名前を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AgentServer <BEAgentServer>

仮想サーバーに変換するエージェントサーバーを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-ExcludeSelectionList <BEAgentServerBackupSelectionList>

仮想への変換ジョブを実行するときの除外対象を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SubmitOnHold <Boolean>

ジョブを保留状態でサブミットします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TargetEnvironment <BEConvertToVirtualTargetEnvironment>

仮想への変換ジョブのターゲット環境を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineName <String>

作成する仮想マシンの名前を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OverwriteExistingVirtualMachine <Boolean>

同じ名前のものが存在する場合は、その仮想マシンを上書きします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachinePhysicalRamMB <UInt32>

宛先の仮想マシンの RAM を MB 単位で指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineCpuCount <UInt32>

宛先の仮想マシンの CPU 数を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-StartDate <DateTime>

実行するジョブの日付と時刻を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NotificationRecipientList <BENotificationRecipientObject[]>

ジョブが完了したときに通知を受け取る受信者を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IncludeJobLogWithEmailNotification <Boolean>

電子メールにジョブログを添付します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEAgentServer

仮想サーバーに変換されるエージェントサーバーです。

Return Value
BackupExec.Management.CLI.BEConvertToVirtualJob

作成された BEConvertToVirtualJob です。

Example

C:\PS> $logonAccount = Get-BELogonAccount "My Logon Account"
C:\PS> $targetEnvironment = New-BEConvertToVirtualTargetEnvironment -VMwareVCenterServerName MyVCenter -VMwareHostName MyEsxHost -VMwareDataStoreName "Storage1" -LogonAccount $logonAccount -ToolsIsoPath "c:\vmwaretools.iso"
C:\PS> $startDate = New-Object System.DateTime(2012,12,31)
C:\PS> Submit-BEConvertToVirtualJob -AgentServer (Get-BEAgentServer -Local) -TargetEnvironment $targetEnvironment -VirtualMachineName "TestServer" -OverwriteExistingVirtualMachine $false -VirtualMachinePhysicalRamMB 1024 -VirtualMachineCpuCount 4 -StartDate $startDate

これらのコマンドは、12/31/2012 に実行される仮想への変換ジョブを作成し、1GB の RAM と 4 個のプロセッサを搭載したローカルサーバーの仮想マシンを作成します。

Related Links


Submit-BEEjectMediaJob Help

Submit-BEEjectMediaJob Cmdlet
Synopsis

Backup Exec のディスクカートリッジまたはテープドライブデバイスにあるメディアを取り出すジョブをサブミットします。

Syntax
Submit-BEEjectMediaJob -DiskCartridgeDevice <BEDiskCartridgeDevice> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-Schedule <BESchedule>] [-KeepJobQueuedFor <TimeSpan>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Submit-BEEjectMediaJob -TapeDriveDevice <BETapeDriveDevice> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-Schedule <BESchedule>] [-KeepJobQueuedFor <TimeSpan>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のディスクカートリッジまたはテープドライブデバイスにあるメディアを取り出すジョブをサブミットします。

ソフトウェアによるメディアの取り出しをサポートしていないデバイスもあります。 このようなドライブでは、メディアがテープの場合は、テープの巻き戻しが完了すると手動でのテープの取り出しを求めるメッセージが表示されます。

Parameters

-Name <String>

作成するジョブの名前を指定します。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskCartridgeDevice <BEDiskCartridgeDevice>

取り出すディスクカートリッジメディアを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-TapeDriveDevice <BETapeDriveDevice>

取り出すテープメディアを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Schedule <BESchedule>

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

予定開始時刻の経過後に、ジョブが未処理であると Backup Exec が判断し、そのジョブのスケジュール再設定が可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

予定開始時刻後にジョブの実行が続行されている場合、そのジョブのキャンセルが可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

CASO 環境でジョブを処理する Backup Exec サーバーを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEDiskCartridgeDevice

Backup Exec のディスクカートリッジデバイスオブジェクトを Submit-BEEjectMediaJob にパイプ処理できます。

BackupExec.Management.CLI.BETapeDriveDevice

Backup Exec のテープドライブデバイスオブジェクトを Submit-BEEjectMediaJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEJob

Submit-BEEjectMediaJob はサブミットされたジョブを返します。

Example

C:\PS> Get-BETapeDriveDevice "Device 0001" | Submit-BEEjectMediaJob

これらのコマンドは「Device 0001」という名前のテープドライブデバイス内のメディアを取り出す取り出しジョブをサブミットします。

Related Links


Submit-BEEraseMediaJob Help

Submit-BEEraseMediaJob Cmdlet
Synopsis

Backup Exec のメディアデータの消去ジョブをサブミットします。

Syntax
Submit-BEEraseMediaJob -TapeDriveDevice <BETapeDriveDevice> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-LongErase <SwitchParameter>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-Schedule <BESchedule>] [-KeepJobQueuedFor <TimeSpan>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Submit-BEEraseMediaJob -RoboticLibraryPartition <BERoboticLibraryPartition> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-LongErase <SwitchParameter>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-Schedule <BESchedule>] [-KeepJobQueuedFor <TimeSpan>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Submit-BEEraseMediaJob -RoboticLibrarySlot <BERoboticLibrarySlot[]> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-LongErase <SwitchParameter>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-Schedule <BESchedule>] [-KeepJobQueuedFor <TimeSpan>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のメディアデータの消去ジョブをサブミットします。

デフォルトでは、Submit-BEEraseMediaJob はクイック消去を実行します。 -LongErase パラメータを指定することで完全消去を実行できます。

完全消去をサポートしていないデバイスではクイック消去のみが実行されます。

Parameters

-Name <String>

作成するジョブの名前を指定します。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeDriveDevice <BETapeDriveDevice>

メディアデータの消去ジョブを実行するテープドライブを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibraryPartition <BERoboticLibraryPartition>

メディアデータの消去ジョブを実行するロボットライブラリパーティションを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibrarySlot <BERoboticLibrarySlot[]>

メディアデータの消去ジョブを実行するロボットライブラリスロットを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Schedule <BESchedule>

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

予定開始時刻の経過後に、ジョブが未処理であると Backup Exec が判断し、そのジョブのスケジュール再設定が可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

予定開始時刻後にジョブの実行が続行されている場合、そのジョブのキャンセルが可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

CASO 環境でジョブを処理する Backup Exec サーバーを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LongErase <SwitchParameter>

メディアデータのクイック消去ではなく、完全消去を実行します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BETapeDriveDevice

Backup Exec のテープドライブデバイスオブジェクトを Submit-BEEraseMediaJob にパイプ処理できます。

BackupExec.Management.CLI.BERoboticLibraryPartition

Backup Exec のロボットライブラリパーティションオブジェクトを Submit-BEEraseMediaJob にパイプ処理できます。

BackupExec.Management.CLI.BERoboticLibrarySlot

Backup Exec のロボットライブラリスロットオブジェクトを Submit-BEEraseMediaJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEJob

Submit-BEEraseMediaJob はサブミットされたジョブを返します。

Example

C:\PS> Get-BETapeDriveDevice "Device 0001" | Submit-BEEraseMediaJob

これらのコマンドは「Device 0001」という名前のテープドライブデバイス内のメディアからデータを消去する消去ジョブをサブミットします。

Related Links


Submit-BEExportExpiredMediaJob Help

Submit-BEExportExpiredMediaJob Cmdlet
Synopsis

Backup Exec のロボットライブラリデバイスから期限切れメディアをエクスポートするジョブをサブミットします。

Syntax
Submit-BEExportExpiredMediaJob -RoboticLibraryDevice <BERoboticLibraryDevice> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-Schedule <BESchedule>] [-KeepJobQueuedFor <TimeSpan>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Submit-BEExportExpiredMediaJob -RoboticLibraryPartition <BERoboticLibraryPartition> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-Schedule <BESchedule>] [-KeepJobQueuedFor <TimeSpan>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Submit-BEExportExpiredMediaJob -RoboticLibrarySlot <BERoboticLibrarySlot[]> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-Schedule <BESchedule>] [-KeepJobQueuedFor <TimeSpan>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のロボットライブラリデバイスから期限切れメディアをエクスポートするジョブをサブミットします。

書き込みができないメディアは取り出されます。 Submit-BEExportExpiredMediaJob を使用すると、ロボットライブラリ内のメディアの処理を自動化できます。

Parameters

-Name <String>

作成するジョブの名前を指定します。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-RoboticLibraryDevice <BERoboticLibraryDevice>

エクスポートするメディアを含むロボットライブラリデバイスを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibraryPartition <BERoboticLibraryPartition>

エクスポートするメディアを含むロボットライブラリパーティションを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibrarySlot <BERoboticLibrarySlot[]>

エクスポートするメディアを含むロボットライブラリスロットを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Schedule <BESchedule>

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

予定開始時刻の経過後に、ジョブが未処理であると Backup Exec が判断し、そのジョブのスケジュール再設定が可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

予定開始時刻後にジョブの実行が続行されている場合、そのジョブのキャンセルが可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

CASO 環境でジョブを処理する Backup Exec サーバーを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BERoboticLibraryDevice

Backup Exec のロボットライブラリデバイスオブジェクトを Submit-BEExportExpiredMediaJob にパイプ処理できます。

BackupExec.Management.CLI.BERoboticLibraryPartition

Backup Exec のロボットライブラリパーティションオブジェクトを Submit-BEExportExpiredMediaJob にパイプ処理できます。

BackupExec.Management.CLI.BERoboticLibrarySlot

Backup Exec のロボットライブラリスロットオブジェクトを Submit-BEExportExpiredMediaJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEJob

Submit-BEExportExpiredMediaJob はサブミットされたジョブを返します。

Examples

Example 1

C:\PS> Get-BERoboticLibraryDevice "Device 0001" | Submit-BEExportExpiredMediaJob

これらのコマンドは「Device 0001」という名前のロボットライブラリから期限切れメディアをエクスポートする期限切れメディアのエクスポートジョブをサブミットします。

Example 2
C:\PS> Get-BERoboticLibraryDevice "Device 0001" | Submit-BEExportExpiredMediaJob -Schedule (New-BESchedule -Daily -StartingAt 10pm)

これらのコマンドは毎日午後 10 時に「Device 0001」という名前のロボットライブラリから期限切れメディアをエクスポートする期限切れメディアのエクスポートジョブをサブミットします。

Related Links


Submit-BEExportMediaJob Help

Submit-BEExportMediaJob Cmdlet
Synopsis

Backup Exec のロボットライブラリデバイスからメディアをエクスポートするジョブをサブミットします。

Syntax
Submit-BEExportMediaJob -RoboticLibraryDevice <BERoboticLibraryDevice> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-ImportAfterExport <SwitchParameter>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-Schedule <BESchedule>] [-KeepJobQueuedFor <TimeSpan>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Submit-BEExportMediaJob -RoboticLibraryPartition <BERoboticLibraryPartition> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-ImportAfterExport <SwitchParameter>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-Schedule <BESchedule>] [-KeepJobQueuedFor <TimeSpan>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Submit-BEExportMediaJob -RoboticLibrarySlot <BERoboticLibrarySlot[]> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-ImportAfterExport <SwitchParameter>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-Schedule <BESchedule>] [-KeepJobQueuedFor <TimeSpan>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のロボットライブラリデバイスからメディアをエクスポートするジョブをサブミットします。

複数のライブラリパーティションまたは個々のロボットライブラリスロットを指定できます。

Parameters

-Name <String>

作成するジョブの名前を指定します。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-RoboticLibraryDevice <BERoboticLibraryDevice>

エクスポートするメディアを含むロボットライブラリデバイスを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibraryPartition <BERoboticLibraryPartition>

エクスポートするメディアを含むロボットライブラリパーティションを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibrarySlot <BERoboticLibrarySlot[]>

エクスポートするメディアを含むロボットライブラリスロットを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Schedule <BESchedule>

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

予定開始時刻の経過後に、ジョブが未処理であると Backup Exec が判断し、そのジョブのスケジュール再設定が可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

予定開始時刻後にジョブの実行が続行されている場合、そのジョブのキャンセルが可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

CASO 環境でジョブを処理する Backup Exec サーバーを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ImportAfterExport <SwitchParameter>

エクスポートジョブの完了後にメディアをインポートします。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BERoboticLibraryDevice

Backup Exec のロボットライブラリデバイスオブジェクトを Submit-BEExportMediaJob にパイプ処理できます。

BackupExec.Management.CLI.BERoboticLibraryPartition

Backup Exec のロボットライブラリパーティションオブジェクトを Submit-BEExportMediaJob にパイプ処理できます。

BackupExec.Management.CLI.BERoboticLibrarySlot

Backup Exec のロボットライブラリスロットオブジェクトを Submit-BEExportMediaJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEJob

Submit-BEExportMediaJob はサブミットされたジョブを返します。

Examples

Example 1

C:\PS> Get-BERoboticLibraryDevice "Device 0001" | Submit-BEExportMediaJob

これらのコマンドは「Device 0001」という名前のロボットライブラリからメディアをエクスポートするメディアのエクスポートジョブをサブミットします。

Example 2
C:\PS> Get-BERoboticLibraryDevice "Device 0001" | Submit-BEExportMediaJob -Schedule (New-BESchedule -Daily -StartingAt 10pm)

これらのコマンドは毎日午後 10 時に「Device 0001」という名前のロボットライブラリからメディアをエクスポートするメディアのエクスポートジョブをサブミットします。

Related Links


Submit-BEFileSystemRestoreJob Help

Submit-BEFileSystemRestoreJob Cmdlet
Synopsis

Backup Exec のファイルシステムリストアジョブをサブミットします。

Syntax
Submit-BEFileSystemRestoreJob -AgentServer <BEAgentServer> [-FileSystemSelection] <BEFileSystemSelection[]> [-PostCommand <String>] [-PrePostCommandSuccessfulIfReturnsZero <Boolean>] [-RunJobOnlyIfPreCommandIsSuccessful <Boolean>] [-PreCommand <String>] [-Priority {Normal | Lowest | Low | High | Highest}] [-AutomaticallyDeleteJob {Never | IfSuccessful | WhenComplete}] [-SubmitOnHold <Boolean>] [-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-IncludeJobLogWithEmailNotification <Boolean>] [-Storage <BEStorage>] [-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>] [-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-RedirectToVirtualDiskFileName <String>] [-RestoreCorruptFile <Boolean>] [-RestoreDirectoryStructure <Boolean>] [-RedirectToVirtualDisk {None | VHD}] [-StartDate <DateTime>] [-RedirectToPath <String>] [-RedirectToPathLogonAccount <BELogonAccount>] [-OverwriteExistingFile {IfExistingIsOlder | No | Yes}] [-Name <String>] [-PointInTime <DateTime>] [-NotBefore <DateTime>] [-RestoreJunctionPoint <Boolean>] [-RestoreSecurityInformation {FilesAndNtfsPermissions | NtfsPermissionsOnly | FilesOnly}] [-RestoreRemovableStorageData <Boolean>] [-RestoreDiskQuotaData <Boolean>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Submit-BEFileSystemRestoreJob -JobHistory <BEJobHistory> [-FileSystemSelection] <BEFileSystemSelection[]> [-PostCommand <String>] [-PrePostCommandSuccessfulIfReturnsZero <Boolean>] [-RunJobOnlyIfPreCommandIsSuccessful <Boolean>] [-PreCommand <String>] [-AutomaticallyDeleteJob {Never | IfSuccessful | WhenComplete}] [-SubmitOnHold <Boolean>] [-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-IncludeJobLogWithEmailNotification <Boolean>] [-Storage <BEStorage>] [-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>] [-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-RedirectToVirtualDiskFileName <String>] [-RestoreCorruptFile <Boolean>] [-RestoreDirectoryStructure <Boolean>] [-RedirectToVirtualDisk {None | VHD}] [-Priority {Normal | Lowest | Low | High | Highest}] [-RedirectToPath <String>] [-RedirectToPathLogonAccount <BELogonAccount>] [-OverwriteExistingFile {IfExistingIsOlder | No | Yes}] [-Name <String>] [-AgentServer <BEAgentServer>] [-StartDate <DateTime>] [-RestoreJunctionPoint <Boolean>] [-RestoreSecurityInformation {FilesAndNtfsPermissions | NtfsPermissionsOnly | FilesOnly}] [-RestoreRemovableStorageData <Boolean>] [-RestoreDiskQuotaData <Boolean>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のファイルシステムリストアジョブをサブミットします。

Backup Exec ジョブ履歴オブジェクトをリストアの特定時点のバックアップセットとして指定できます。

また、特定時点の範囲を指定してリストアのバックアップセットの特定時点を決定することもできます。

Parameters

-FileSystemSelection <BEFileSystemSelection[]>

1 つ以上のファイルシステムの選択項目をバックアップ定義に含める、またはバックアップ定義から除外します。含めるファイルまたはディレクトリを指定するには、1 つまたは複数のパスを、カンマを使用して値を区切って指定します。除外するファイルまたはディレクトリを指定するには、-Exclude パラメータと一緒に New-BEFileSystemSelection の出力を使います。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-RedirectToPath <String>

リストア先変更ジョブについてリストアするパスを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RedirectToPathLogonAccount <BELogonAccount>

リストア先変更ジョブについて Backup Exec ログオンアカウントを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RedirectToVirtualDisk

リストアジョブのリストア先を仮想ディスクに変更します。RedirectToPath を指定する必要があります。

The valid values are:
None
VHD

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RedirectToVirtualDiskFileName <String>

リストアジョブのリストア先を変更する仮想ディスクの名前を指定します。指定しない場合、リストアジョブの各バックアップセットについて VHD が作成されます。RedirectToVirtualDisk パラメータは VHD に設定する必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RestoreCorruptFile <Boolean>

破損ファイルをリストアします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RestoreDirectoryStructure <Boolean>

ファイルシステムのディレクトリ構造をリストアします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OverwriteExistingFile

リストア中に既存のファイルをすべて上書きします。

The valid values are:
IfExistingIsOlder
No
Yes

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RestoreSecurityInformation

セキュリティ情報をリストアします。

The valid values are:
FilesAndNtfsPermissions
NtfsPermissionsOnly
FilesOnly

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RestoreRemovableStorageData <Boolean>

リムーバブル記憶域データをリストアします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RestoreDiskQuotaData <Boolean>

ディスククォータ設定をリストアします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RestoreJunctionPoint <Boolean>

接合点をリストアします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

リストアジョブの名前を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AgentServer <BEAgentServer>

データをバックアップしたサーバーを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-PointInTime <DateTime>

バックアップセットでどの時点までリストアするかを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NotBefore <DateTime>

バックアップセットでリストアを開始する時点を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-JobHistory <BEJobHistory>

バックアップセットを参照しているジョブ履歴オブジェクトを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-StartDate <DateTime>

ジョブを開始する日時を指定します。 このパラメータを指定しない場合、ジョブはすぐに開始されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Priority

ジョブを実行する順序を指定します。2 つのジョブが同時に実行されるようにスケジュールされている場合、ユーザーが設定する優先度でどちらが先に実行されるかが決まります。

The valid values are:
Normal
Lowest
Low
High
Highest

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AutomaticallyDeleteJob

ジョブが完了したら自動的にジョブを削除します。

The valid values are:
Never
IfSuccessful
WhenComplete

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SubmitOnHold <Boolean>

ジョブを保留状態でサブミットします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreCommand <String>

バックアップジョブの前に実行するコマンドを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PostCommand <String>

バックアップジョブの後に実行するコマンドを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PrePostCommandSuccessfulIfReturnsZero <Boolean>

Backup Exec によってプリコマンドまたはポストコマンドの戻りコードを確認し、コマンドが正しく完了したかどうかを調べることができます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunJobOnlyIfPreCommandIsSuccessful <Boolean>

プリコマンドが正しく実行された場合にのみバックアップジョブを実行します。プリコマンドの実行に失敗した場合は、ジョブは実行されません。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>

プリコマンドが正しく実行された場合にのみポストコマンドを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>

ジョブが正しく実行されなかった場合でもポストコマンドを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>

完了しなかったプリコマンドまたはポストコマンドをキャンセルするのに待つ時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunCommandLocation

プリコマンドとポストコマンドが実行される場所を指定します。

The valid values are:
OnEachAgentServer
OnBackupExecServer

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Storage <BEStorage>

リストアジョブに使用するストレージデバイスを指定します。 Get-BEStorage を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NotificationRecipientList <BENotificationRecipientObject[]>

ジョブが完了したときに通知を受け取る受信者を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IncludeJobLogWithEmailNotification <Boolean>

電子メールにジョブログを添付します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEAgentServer

Backup Exec エージェントサーバーオブジェクトを Submit-BEFileSystemRestoreJob にパイプ処理することができます。

BackupExec.Management.CLI.BEJobHistory

Backup Exec ジョブ履歴オブジェクトを Submit-BEFileSystemRestoreJob にパイプ処理することができます。

Return Value
BackupExec.Management.CLI.BEJob

Submit-BEFileSystemRestoreJob は Backup Exec ジョブオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEJob "Job 0001" | Get-BEJobHistory -FromLastJobRun | Submit-BEFileSystemRestoreJob -FileSystemSelection C:\BackedUpData\*.*

これらのコマンドは「Job 0001」という名前のジョブの最新の実行から C:\BackedUpData という名前のディレクトリをリストアします。

Example 2
C:\PS> Get-BEAgentServer myserver.mycompany.com | Submit-BEFileSystemRestoreJob -FileSystemSelection C:\BackedUpData\*.*

これらのコマンドは「myserver.mycompany.com」という名前のサーバーの最新のバックアップから C:\BackedUpData という名前のディレクトリをリストアします。

Related Links


Submit-BEFormatMediaJob Help

Submit-BEFormatMediaJob Cmdlet
Synopsis

Backup Exec のストレージデバイス内のメディアをフォーマットするジョブをサブミットします。

Syntax
Submit-BEFormatMediaJob -TapeDriveDevice <BETapeDriveDevice> [[-Name] <String>] [-FormatWorm <SwitchParameter>] [-BackupExecServer <BEBackupExecServer>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Submit-BEFormatMediaJob -RoboticLibraryPartition <BERoboticLibraryPartition> [[-Name] <String>] [-FormatWorm <SwitchParameter>] [-BackupExecServer <BEBackupExecServer>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Submit-BEFormatMediaJob -RoboticLibrarySlot <BERoboticLibrarySlot[]> [[-Name] <String>] [-FormatWorm <SwitchParameter>] [-BackupExecServer <BEBackupExecServer>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のストレージデバイス内のメディアをフォーマットするジョブをサブミットします。

ストレージデバイスにフォーマットするメディアが存在する必要があります。

フォーマットを実行すると、メディアからデータが消去されます。 メディア上のデータはすべて失われます。

Parameters

-Name <String>

作成するジョブの名前を指定します。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeDriveDevice <BETapeDriveDevice>

フォーマットするテープドライブを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibraryPartition <BERoboticLibraryPartition>

フォーマットするロボットライブラリパーティションを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibrarySlot <BERoboticLibrarySlot[]>

フォーマットするロボットライブラリスロットを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

CASO 環境でジョブを処理する Backup Exec サーバーを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FormatWorm <SwitchParameter>

WORM (Write Once Read Many) パラメータを有効にします。 WORM でフォーマットされたドライブは再フォーマットできません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BETapeDriveDevice

Backup Exec のテープドライブデバイスオブジェクトを Submit-BEFormatMediaJob にパイプ処理できます。

BackupExec.Management.CLI.BERoboticLibraryPartition

Backup Exec のロボットライブラリパーティションオブジェクトを Submit-BEFormatMediaJob にパイプ処理できます。

BackupExec.Management.CLI.BERoboticLibrarySlot

Backup Exec のロボットライブラリスロットオブジェクトを Submit-BEFormatMediaJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEJob

Submit-BEFormatMediaJob はサブミットされたジョブを返します。

Example

C:\PS> Get-BETapeDriveDevice "Device 0001" | Submit-BEFormatMediaJob

これらのコマンドは「Device 0001」という名前のテープドライブデバイス内のメディアをフォーマットするジョブをサブミットします。

Related Link

Get-BETapeDriveDevice


Submit-BEImportMediaJob Help

Submit-BEImportMediaJob Cmdlet
Synopsis

ロボットライブラリにメディアを挿入した後、Backup Exec データベースが更新されるジョブをサブミットします。

Syntax
Submit-BEImportMediaJob -RoboticLibraryDevice <BERoboticLibraryDevice> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-InventoryAfterImport <SwitchParameter>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-Schedule <BESchedule>] [-KeepJobQueuedFor <TimeSpan>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Submit-BEImportMediaJob -RoboticLibraryPartition <BERoboticLibraryPartition> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-InventoryAfterImport <SwitchParameter>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-Schedule <BESchedule>] [-KeepJobQueuedFor <TimeSpan>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Submit-BEImportMediaJob -RoboticLibrarySlot <BERoboticLibrarySlot[]> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-InventoryAfterImport <SwitchParameter>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-Schedule <BESchedule>] [-KeepJobQueuedFor <TimeSpan>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

ロボットライブラリにメディアを挿入した後、Backup Exec データベースが更新されるジョブをサブミットします。

Parameters

-Name <String>

作成するジョブの名前を指定します。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-RoboticLibraryDevice <BERoboticLibraryDevice>

インポートするメディアを含むロボットライブラリデバイスを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibraryPartition <BERoboticLibraryPartition>

インポートするメディアを含むロボットライブラリパーティションを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibrarySlot <BERoboticLibrarySlot[]>

インポートするメディアを含むロボットライブラリスロットを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Schedule <BESchedule>

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

予定開始時刻の経過後に、ジョブが未処理であると Backup Exec が判断し、そのジョブのスケジュール再設定が可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

予定開始時刻後にジョブの実行が続行されている場合、そのジョブのキャンセルが可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

CASO 環境でジョブを処理する Backup Exec サーバーを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InventoryAfterImport <SwitchParameter>

Backup Exec がインベントリジョブを作成できるようにします。 インベントリジョブはインポートジョブの完了後に自動的に実行され、メディアについての情報で Backup Exec データベースを更新します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BERoboticLibraryDevice

Backup Exec のロボットライブラリデバイスオブジェクトを Submit-BEImportMediaJob にパイプ処理できます。

BackupExec.Management.CLI.BERoboticLibraryPartition

Backup Exec のロボットライブラリパーティションオブジェクトを Submit-BEImportMediaJob にパイプ処理できます。

BackupExec.Management.CLI.BERoboticLibrarySlot

Backup Exec のロボットライブラリスロットオブジェクトを Submit-BEImportMediaJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEJob

Submit-BEImportMediaJob はサブミットされたジョブを返します。

Examples

Example 1

C:\PS> Get-BERoboticLibraryDevice "Device 0001" | Submit-BEImportMediaJob

これらのコマンドは「Device 0001」という名前のロボットライブラリからメディアをインポートするメディアのインポートジョブをサブミットします。

Example 2
C:\PS> Get-BERoboticLibraryDevice "Device 0001" | Submit-BEImportMediaJob -Schedule (New-BESchedule -Daily -StartingAt 10pm)

これらのコマンドは毎日午後 10 時に「Device 0001」という名前のロボットライブラリからメディアをインポートするメディアのインポートジョブをサブミットします。

Related Links


Submit-BEInitializeJob Help

Submit-BEInitializeJob Cmdlet
Synopsis

Backup Exec のロボットライブラリデバイスを初期化するジョブをサブミットします。

Syntax
Submit-BEInitializeJob -RoboticLibraryDevice <BERoboticLibraryDevice> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のロボットライブラリデバイスを初期化するジョブをサブミットします。

起動時にロボットライブラリスロットにメディアが存在する場合は、Backup Exec はそのメディアを元のスロットに戻そうとします。

Parameters

-Name <String>

作成するジョブの名前を指定します。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-RoboticLibraryDevice <BERoboticLibraryDevice>

初期化するロボットライブラリデバイスを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

CASO 環境でジョブを処理する Backup Exec サーバーを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BERoboticLibraryDevice

Backup Exec のロボットライブラリデバイスオブジェクトを Submit-BEInitializeJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEJob

Submit-BEInitializeJob はサブミットされたジョブを返します。

Example

C:\PS> Get-BERoboticLibraryDevice "Device 0001" | Submit-BEInitializeJob

これらのコマンドは「Device 0001」という名前のロボットライブラリを初期化するジョブをサブミットします。

Related Link

Get-BERoboticLibraryDevice


Submit-BEInventoryAndCatalogMediaJob Help

Submit-BEInventoryAndCatalogMediaJob Cmdlet
Synopsis

Backup Exec のストレージデバイス内のメディアをインベントリ処理してカタログ登録するジョブをサブミットします。

Syntax
Submit-BEInventoryAndCatalogMediaJob -DiskCartridgeDevice <BEDiskCartridgeDevice> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Submit-BEInventoryAndCatalogMediaJob -TapeDriveDevice <BETapeDriveDevice> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Submit-BEInventoryAndCatalogMediaJob -RoboticLibraryDevice <BERoboticLibraryDevice> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Submit-BEInventoryAndCatalogMediaJob -RoboticLibraryPartition <BERoboticLibraryPartition> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Submit-BEInventoryAndCatalogMediaJob -RoboticLibrarySlot <BERoboticLibrarySlot[]> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Submit-BEInventoryAndCatalogMediaJob -DiskStorageDevice <BEDiskStorageDevice> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Submit-BEInventoryAndCatalogMediaJob -LegacyBackupToDiskFolderDevice <BELegacyBackupToDiskFolderDevice> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Submit-BEInventoryAndCatalogMediaJob -DeduplicationDiskStorageDevice <BEDeduplicationDiskStorageDevice> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Submit-BEInventoryAndCatalogMediaJob -VirtualDiskDevice <BEVirtualDiskDevice> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Submit-BEInventoryAndCatalogMediaJob -OpenStorageDevice <BEOpenStorageDevice> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Submit-BEInventoryAndCatalogMediaJob -CloudStorageDevice <BECloudStorageDevice> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のストレージデバイス内のメディアをインベントリ処理してカタログ登録するジョブをサブミットします。

Parameters

-Name <String>

作成するジョブの名前を指定します。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskCartridgeDevice <BEDiskCartridgeDevice>

インベントリ処理してカタログ登録するディスクカートリッジデバイスを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-TapeDriveDevice <BETapeDriveDevice>

インベントリ処理してカタログ登録するテープドライブデバイスを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibraryDevice <BERoboticLibraryDevice>

インベントリ処理してカタログ登録するロボットライブラリデバイスを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibraryPartition <BERoboticLibraryPartition>

インベントリ処理してカタログ登録するロボットライブラリパーティションを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibrarySlot <BERoboticLibrarySlot[]>

インベントリ処理してカタログ登録するロボットライブラリスロットを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-DiskStorageDevice <BEDiskStorageDevice>

インベントリ処理してカタログ登録するディスクデバイスを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-LegacyBackupToDiskFolderDevice <BELegacyBackupToDiskFolderDevice>

インベントリ処理してカタログ登録するディスクへのバックアップデバイスを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-DeduplicationDiskStorageDevice <BEDeduplicationDiskStorageDevice>

インベントリ処理してカタログ登録する重複排除用ディスクストレージデバイスを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-VirtualDiskDevice <BEVirtualDiskDevice>

インベントリ処理してカタログ登録する仮想ディスクデバイスを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-OpenStorageDevice <BEOpenStorageDevice>

インベントリ処理してカタログ登録するオープンストレージデバイスを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-CloudStorageDevice <BECloudStorageDevice>

インベントリ処理してカタログ登録するクラウドストレージデバイスを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

CASO 環境でジョブを処理する Backup Exec サーバーを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEDiskCartridgeDevice

Backup Exec のディスクカートリッジデバイスオブジェクトを Submit-BEInventoryAndCatalogMediaJob にパイプ処理できます。

BackupExec.Management.CLI.BETapeDriveDevice

Backup Exec のテープドライブデバイスオブジェクトを Submit-BEInventoryAndCatalogMediaJob にパイプ処理できます。

BackupExec.Management.CLI.BERoboticLibraryDevice

Backup Exec のロボットライブラリデバイスオブジェクトを Submit-BEInventoryAndCatalogMediaJob にパイプ処理できます。

BackupExec.Management.CLI.BERoboticLibraryPartition

Backup Exec のロボットライブラリパーティションオブジェクトを Submit-BEInventoryAndCatalogMediaJob にパイプ処理できます。

BackupExec.Management.CLI.BERoboticLibrarySlot

Backup Exec のロボットライブラリスロットオブジェクトを Submit-BEInventoryAndCatalogMediaJob にパイプ処理できます。

BackupExec.Management.CLI.BEDiskStorageDevice

Backup Exec のディスクストレージデバイスオブジェクトを Submit-BEInventoryAndCatalogMediaJob にパイプ処理できます。

BackupExec.Management.CLI.BELegacyBackupToDiskFolderDevice

Backup Exec のレガシーのディスクへのバックアップフォルダデバイスオブジェクトを Submit-BEInventoryAndCatalogMediaJob にパイプ処理できます。

BackupExec.Management.CLI.BEDeduplicationDiskStorageDevice

Backup Exec の重複排除用ディスクストレージデバイスオブジェクトを Submit-BEInventoryAndCatalogMediaJob にパイプ処理できます。

BackupExec.Management.CLI.BEVirtualDiskDevice

Backup Exec の仮想ディスクデバイスオブジェクトを Submit-BEInventoryAndCatalogMediaJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEJob

Submit-BEInventoryAndCatalogMediaJob はサブミットされたジョブを返します。

Example

C:\PS> Get-BETapeDriveDevice "Device 0001" | Submit-BEInventoryAndCatalogMediaJob

これらのコマンドは「Device 0001」という名前のテープドライブデバイス内のメディアをインベントリ処理してカタログ登録するジョブをサブミットします。

Related Link

Get-BETapeDriveDevice


Submit-BEInventoryJob Help

Submit-BEInventoryJob Cmdlet
Synopsis

Backup Exec のストレージデバイス内のメディアをインベントリ処理するジョブをサブミットします。

Syntax
Submit-BEInventoryJob -DiskCartridgeDevice <BEDiskCartridgeDevice> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-Schedule <BESchedule>] [-KeepJobQueuedFor <TimeSpan>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Submit-BEInventoryJob -TapeDriveDevice <BETapeDriveDevice> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-Schedule <BESchedule>] [-KeepJobQueuedFor <TimeSpan>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Submit-BEInventoryJob -RoboticLibraryDevice <BERoboticLibraryDevice> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-Schedule <BESchedule>] [-KeepJobQueuedFor <TimeSpan>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Submit-BEInventoryJob -RoboticLibraryPartition <BERoboticLibraryPartition> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-Schedule <BESchedule>] [-KeepJobQueuedFor <TimeSpan>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Submit-BEInventoryJob -RoboticLibrarySlot <BERoboticLibrarySlot[]> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-Schedule <BESchedule>] [-KeepJobQueuedFor <TimeSpan>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Submit-BEInventoryJob -DiskStorageDevice <BEDiskStorageDevice> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-Schedule <BESchedule>] [-KeepJobQueuedFor <TimeSpan>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Submit-BEInventoryJob -LegacyBackupToDiskFolderDevice <BELegacyBackupToDiskFolderDevice> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-Schedule <BESchedule>] [-KeepJobQueuedFor <TimeSpan>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Submit-BEInventoryJob -DeduplicationDiskStorageDevice <BEDeduplicationDiskStorageDevice> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-Schedule <BESchedule>] [-KeepJobQueuedFor <TimeSpan>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Submit-BEInventoryJob -VirtualDiskDevice <BEVirtualDiskDevice> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-Schedule <BESchedule>] [-KeepJobQueuedFor <TimeSpan>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Submit-BEInventoryJob -OpenStorageDevice <BEOpenStorageDevice> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-Schedule <BESchedule>] [-KeepJobQueuedFor <TimeSpan>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Submit-BEInventoryJob -CloudStorageDevice <BECloudStorageDevice> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-Schedule <BESchedule>] [-KeepJobQueuedFor <TimeSpan>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のストレージデバイス内のメディアをインベントリ処理するジョブをサブミットします。

インベントリジョブは現在のメディア情報で Backup Exec を更新します。

Parameters

-Name <String>

作成するジョブの名前を指定します。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskCartridgeDevice <BEDiskCartridgeDevice>

インベントリ処理するディスクカートリッジデバイスを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-TapeDriveDevice <BETapeDriveDevice>

インベントリ処理するテープドライブデバイスを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibraryDevice <BERoboticLibraryDevice>

インベントリ処理するロボットライブラリデバイスを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibraryPartition <BERoboticLibraryPartition>

インベントリ処理するロボットライブラリパーティションを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibrarySlot <BERoboticLibrarySlot[]>

インベントリ処理するロボットライブラリスロットを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-DiskStorageDevice <BEDiskStorageDevice>

インベントリ処理するディスクデバイスを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-LegacyBackupToDiskFolderDevice <BELegacyBackupToDiskFolderDevice>

インベントリ処理するディスクへのバックアップデバイスを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-DeduplicationDiskStorageDevice <BEDeduplicationDiskStorageDevice>

インベントリ処理する重複排除用ディスクストレージデバイスを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-VirtualDiskDevice <BEVirtualDiskDevice>

インベントリ処理する仮想ディスクデバイスを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-OpenStorageDevice <BEOpenStorageDevice>

インベントリ処理するオープンストレージデバイスを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-CloudStorageDevice <BECloudStorageDevice>

インベントリ処理するクラウドストレージデバイスを指定します。.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Schedule <BESchedule>

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

予定開始時刻の経過後に、ジョブが未処理であると Backup Exec が判断し、そのジョブのスケジュール再設定が可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

予定開始時刻後にジョブの実行が続行されている場合、そのジョブのキャンセルが可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

CASO 環境でジョブを処理する Backup Exec サーバーを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEDiskCartridgeDevice

Backup Exec のディスクカートリッジデバイスオブジェクトを Submit-BEInventoryJob にパイプ処理できます。

BackupExec.Management.CLI.BETapeDriveDevice

Backup Exec のテープドライブデバイスオブジェクトを Submit-BEInventoryJob にパイプ処理できます。

BackupExec.Management.CLI.BERoboticLibraryDevice

Backup Exec のロボットライブラリデバイスオブジェクトを Submit-BEInventoryJob にパイプ処理できます。

BackupExec.Management.CLI.BERoboticLibraryPartition

Backup Exec のロボットライブラリパーティションオブジェクトを Submit-BEInventoryJob にパイプ処理できます。

BackupExec.Management.CLI.BERoboticLibrarySlot

Backup Exec のロボットライブラリスロットオブジェクトを Submit-BEInventoryJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEJob

Submit-BEInventoryJob はサブミットされたジョブを返します。

Examples

Example 1

C:\PS> Get-BERoboticLibraryDevice "Device 0001" | Submit-BEInventoryJob

これらのコマンドは「Device 0001」という名前のロボットライブラリ内のメディアをインベントリ処理するジョブをサブミットします。

Example 2
C:\PS> Get-BERoboticLibraryDevice "Device 0001" | Submit-BEInventoryJob -Schedule (New-BESchedule -Daily -StartingAt 10pm)

これらのコマンドは毎日午後 10 時に「Device 0001」という名前のロボットライブラリ内のメディアをインベントリ処理するジョブをサブミットします。

Related Links


Submit-BELabelMediaJob Help

Submit-BELabelMediaJob Cmdlet
Synopsis

Backup Exec のストレージデバイス内のメディアに新しいメディアラベルを書き込むジョブをサブミットします。

Syntax
Submit-BELabelMediaJob -TapeDriveDevice <BETapeDriveDevice> [[-Name] <String>] -Label <String> [-BackupExecServer <BEBackupExecServer>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Submit-BELabelMediaJob -RoboticLibrarySlot <BERoboticLibrarySlot> [[-Name] <String>] -Label <String> [-BackupExecServer <BEBackupExecServer>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のストレージデバイス内のメディアに新しいメディアラベルを書き込むジョブをサブミットします。

Parameters

-Name <String>

作成するジョブの名前を指定します。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeDriveDevice <BETapeDriveDevice>

ラベルを書き込むテープドライブを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibrarySlot <BERoboticLibrarySlot>

ラベルを書き込むロボットライブラリスロットを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

CASO 環境でジョブを処理する Backup Exec サーバーを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Label <String>

メディアについて説明します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BETapeDriveDevice

Backup Exec のテープドライブデバイスオブジェクトを Submit-BELabelMediaJob にパイプ処理できます。

BackupExec.Management.CLI.BERoboticLibrarySlot

Backup Exec のロボットライブラリスロットオブジェクトを Submit-BELabelMediaJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEJob

Submit-BELabelMediaJob はサブミットされたジョブを返します。

Example

C:\PS> Get-BETapeDriveDevice "Device 0001" | Submit-BELabelMediaJob

これらのコマンドは「Device 0001」という名前のテープドライブデバイス内のメディアに新しいラベルを書き込むジョブをサブミットします。

Related Link

Get-BETapeDriveDevice


Submit-BELinuxMacRestoreJob Help

Submit-BELinuxMacRestoreJob Cmdlet
Synopsis

Backup Exec で Linux または Mac ファイルシステムのリストアジョブをサブミットします。

Syntax
Submit-BELinuxMacRestoreJob -AgentServer <BEAgentServer> [-LinuxMacSelection] <BELinuxMacSelection[]> [-PrePostCommandSuccessfulIfReturnsZero <Boolean>] [-RunJobOnlyIfPreCommandIsSuccessful <Boolean>] [-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>] [-SubmitOnHold <Boolean>] [-PreCommand <String>] [-PostCommand <String>] [-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-IncludeJobLogWithEmailNotification <Boolean>] [-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-Storage <BEStorage>] [-OverwriteExistingFile {IfExistingIsOlder | No | Yes}] [-RestoreDirectoryStructure <Boolean>] [-RedirectToPathLogonAccount <BELogonAccount>] [-AutomaticallyDeleteJob {Never | IfSuccessful | WhenComplete}] [-RedirectToPath <String>] [-RestoreCorruptFile <Boolean>] [-RedirectToVirtualDisk {None | VHD}] [-NotBefore <DateTime>] [-StartDate <DateTime>] [-Priority {Normal | Lowest | Low | High | Highest}] [-RedirectToVirtualDiskFileName <String>] [-Name <String>] [-PointInTime <DateTime>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Submit-BELinuxMacRestoreJob -JobHistory <BEJobHistory> [-LinuxMacSelection] <BELinuxMacSelection[]> [-PrePostCommandSuccessfulIfReturnsZero <Boolean>] [-RunJobOnlyIfPreCommandIsSuccessful <Boolean>] [-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>] [-PreCommand <String>] [-PostCommand <String>] [-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-IncludeJobLogWithEmailNotification <Boolean>] [-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-Storage <BEStorage>] [-OverwriteExistingFile {IfExistingIsOlder | No | Yes}] [-RestoreDirectoryStructure <Boolean>] [-RedirectToPathLogonAccount <BELogonAccount>] [-SubmitOnHold <Boolean>] [-RedirectToPath <String>] [-RestoreCorruptFile <Boolean>] [-RedirectToVirtualDisk {None | VHD}] [-StartDate <DateTime>] [-Priority {Normal | Lowest | Low | High | Highest}] [-AutomaticallyDeleteJob {Never | IfSuccessful | WhenComplete}] [-RedirectToVirtualDiskFileName <String>] [-Name <String>] [-AgentServer <BEAgentServer>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec で Linux または Mac ファイルシステムのリストアジョブをサブミットします。

Backup Exec ジョブ履歴オブジェクトをリストアに使用するバックアップセットの特定時点として指定できます。

特定時点の範囲を指定して、リストアに使用するバックアップセットの特定時点を決定することもできます。

Parameters

-LinuxMacSelection <BELinuxMacSelection[]>

1 つ以上のファイルシステムの選択項目をバックアップ定義に含める、またはバックアップ定義から除外します。含めるファイルまたはディレクトリを指定するには、1 つまたは複数のパスを、カンマを使用して値を区切って指定します。除外するファイルまたはディレクトリを指定するには、-Exclude パラメータと一緒に New-BELinuxMacSelection の出力を使います。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-RedirectToPath <String>

リストア先変更ジョブについてリストアするパスを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RestoreCorruptFile <Boolean>

破損ファイルをリストアします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OverwriteExistingFile

リストア中に既存のファイルをすべて上書きします。

The valid values are:
IfExistingIsOlder
No
Yes

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RestoreDirectoryStructure <Boolean>

ファイルシステムのディレクトリ構造をリストアします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RedirectToPathLogonAccount <BELogonAccount>

リストア先変更ジョブについて Backup Exec ログオンアカウントを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RedirectToVirtualDisk

リストアジョブのリストア先を仮想ディスクに変更します。RedirectToPath を指定する必要があります。

The valid values are:
None
VHD

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RedirectToVirtualDiskFileName <String>

リストアジョブのリストア先を変更する仮想ディスクの名前を指定します。指定しない場合、リストアジョブの各バックアップセットについて VHD が作成されます。RedirectToVirtualDisk パラメータは VHD に設定する必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

リストアジョブの名前を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AgentServer <BEAgentServer>

データをバックアップしたサーバーを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-PointInTime <DateTime>

バックアップセットでどの時点までリストアするかを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NotBefore <DateTime>

バックアップセットでリストアを開始する時点を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-JobHistory <BEJobHistory>

バックアップセットを参照しているジョブ履歴オブジェクトを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-StartDate <DateTime>

ジョブを開始する日時を指定します。 このパラメータを指定しない場合、ジョブはすぐに開始されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Priority

ジョブを実行する順序を指定します。2 つのジョブが同時に実行されるようにスケジュールされている場合、ユーザーが設定する優先度でどちらが先に実行されるかが決まります。

The valid values are:
Normal
Lowest
Low
High
Highest

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AutomaticallyDeleteJob

ジョブが完了したら自動的にジョブを削除します。

The valid values are:
Never
IfSuccessful
WhenComplete

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SubmitOnHold <Boolean>

ジョブを保留状態でサブミットします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreCommand <String>

バックアップジョブの前に実行するコマンドを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PostCommand <String>

バックアップジョブの後に実行するコマンドを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PrePostCommandSuccessfulIfReturnsZero <Boolean>

Backup Exec によってプリコマンドまたはポストコマンドの戻りコードを確認し、コマンドが正しく完了したかどうかを調べることができます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunJobOnlyIfPreCommandIsSuccessful <Boolean>

プリコマンドが正しく実行された場合にのみバックアップジョブを実行します。プリコマンドの実行に失敗した場合は、ジョブは実行されません。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>

プリコマンドが正しく実行された場合にのみポストコマンドを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>

ジョブが正しく実行されなかった場合でもポストコマンドを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>

完了しなかったプリコマンドまたはポストコマンドをキャンセルするのに待つ時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunCommandLocation

プリコマンドとポストコマンドが実行される場所を指定します。

The valid values are:
OnEachAgentServer
OnBackupExecServer

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Storage <BEStorage>

リストアジョブに使用するストレージデバイスを指定します。 Get-BEStorage を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NotificationRecipientList <BENotificationRecipientObject[]>

ジョブが完了したときに通知を受け取る受信者を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IncludeJobLogWithEmailNotification <Boolean>

電子メールにジョブログを添付します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEAgentServer

Backup Exec エージェントサーバーオブジェクトを Submit-BELinuxMacRestoreJob にパイプ処理することができます。

BackupExec.Management.CLI.BEJobHistory

Backup Exec ジョブ履歴オブジェクトを Submit-BELinuxMacRestoreJob にパイプ処理することができます。

Return Value
BackupExec.Management.CLI.BEJob

Submit-BELinuxMacRestoreJob は Backup Exec ジョブオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEJob "Job 0001" | Get-BEJobHistory -FromLastJobRun | Submit-BELinuxMacRestoreJob -LinuxMacSelection /root/BackupUpData/*.*

これらのコマンドは、「Job 0001」というジョブの最新のバックアップセットから /root/BackupUpData というディレクトリをリストアします。

Example 2
C:\PS> Get-BEAgentServer myserver.mycompany.com | Submit-BELinuxMacRestoreJob -LinuxMacSelection /root/BackupUpData/*.*

これらのコマンドは、「myserver.mycompany.com」というサーバーの最新のバックアップセットから /root/BackupUpData というディレクトリをリストアします。

Related Links


Submit-BELockJob Help

Submit-BELockJob Cmdlet
Synopsis

Backup Exec のロボットライブラリの前面パネルをロックするジョブをサブミットします。

Syntax
Submit-BELockJob -RoboticLibraryDevice <BERoboticLibraryDevice> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のロボットライブラリの前面パネルをロックするジョブをサブミットします。

Parameters

-Name <String>

作成するジョブの名前を指定します。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-RoboticLibraryDevice <BERoboticLibraryDevice>

ロックするロボットライブラリを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

CASO 環境でジョブを処理する Backup Exec サーバーを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BERoboticLibraryDevice

Backup Exec のロボットライブラリデバイスオブジェクトを Submit-BELockJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEJob

Submit-BELockJob はサブミットされたジョブを返します。

Example

C:\PS> Get-BERoboticLibraryDevice "Device 0001" | Submit-BELockJob

これらのコマンドは「Device 0001」という名前のロボットライブラリの前面パネルをロックするジョブをサブミットします。

Related Link

Get-BERoboticLibraryDevice


Submit-BEOnetimeBackupJob Help

Submit-BEOnetimeBackupJob Cmdlet
Synopsis

Backup Exec のワンタイムバックアップジョブをサブミットします。

Syntax
Submit-BEOnetimeBackupJob -AgentServer <BEAgentServer> [-TapeStorageEjectMediaAfterComplete <Boolean>] [-TapeStorageExportMediaToVault <BEMediaVault>] [-TapeStorageEnableDirectCopyToTape <Boolean>] [-TapeStorageEnableWriteOnceReadManyMedia <Boolean>] [-Storage <BEStorage>] [-NdmpNetAppEnableFileHistory <Boolean>] [-TapeStorageExportMedia <Boolean>] [-TapeStorageMediaSet <BEMediaSet>] [-TapeStorageRetensionMediaBeforeBackup <Boolean>] [-NotificationRecipientList <BENotificationRecipientObject[]>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-TapeStorageCompressionMethod {None | SoftwareIfNoHardware | HardwareOnly | SoftwareOnly}] [-IncludeJobLogWithEmailNotification <Boolean>] [-SubmitOnHold <Boolean>] [-DiskStorageKeepForHours <Int32>] [-KeepJobQueuedFor <TimeSpan>] [-BackupSetDescription <String>] [-NdmpNetAppBackupAccessControlLists <Boolean>] [-VirtualMachineEnableIRForAll <Boolean>] [-VirtualMachineBackupPoweredOffVirtualMachine <Boolean>] [-VirtualMachineUseGrtForActiveDirectory <Boolean>] [-VirtualMachineUseGrtForFileSystem <Boolean>] [-ActiveDirectoryUseGrt <Boolean>] [-ActiveDirectoryContinueIfConsistencyCheckIsUnsuccessful <Boolean>] [-OracleMinimumNumberOfDevicesRequiredForJob <UInt32>] [-OracleMaximumNumberOfDevicesToUseForResources <UInt32>] [-VirtualMachineUseGrtForExchange <Boolean>] [-NdmpEMCBackupType {Dump | VBB}] [-VMwareVSpherePort <UInt32>] [-NdmpEMCEnableFileHistory <Boolean>] [-NdmpEMCBackupWithIntegratedCheckpoints <Boolean>] [-VirtualMachineUseGrtForSharePoint <Boolean>] [-VirtualMachineUseGrtForSql <Boolean>] [-VMwareTransportModePriority {SAN | NBD | NBDSSL | Hotadd}] [-HyperVExcludeVirtualMachinesNeedingSavedState <Boolean>] [-SqlCreateDiskCopy <Boolean>] [-SqlUseChecksumOnBackup <Boolean>] [-SqlUseSoftwareCompression <Boolean>] [-SqlDiskCopyPath <String>] [-SqlPreConsistencyCheckMethod {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-ExchangeUseGrt <Boolean>] [-SqlPostConsistencyCheck {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-SqlContinueIfConsistencyCheckUnsuccessful <Boolean>] [-SharePointUseGrt <Boolean>] [-SqlAdvancedLogBackupOption {None | NoRecover | Standby}] [-SqlBackupMethod {FullCopy | DatabaseSnapshot | LogNoTruncate | Log | Full}] [-OracleSkipBackedUpArchivedLogFile <Boolean>] [-OracleDeleteBackedUpArchivedLogFile <Boolean>] [-DeleteSelectedFilesAfterSuccessfulBackup {Never | FilesOnly | FilesAndFolders}] [-OraclePerformBackupOffline <Boolean>] [-EncryptionKey <BEEncryptionKey>] [-PrePostCommandSuccessfulIfReturnsZero <Boolean>] [-PostCommand <String>] [-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>] [-RunJobOnlyIfPreCommandIsSuccessful <Boolean>] [-EnableDirectAccessIfAvailable <Boolean>] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-PreCommand <String>] [-StartDate <DateTime>] [-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>] [-VerifyJobNotificationRecipientList <BENotificationRecipientObject[]>] [-EnableDirectAccessForVerifyJobIfAvailable <Boolean>] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-VerifyJobIncludeJobLogWithEmailNotification <Boolean>] [-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>] [-RunPostCommandAfterVerification <Boolean>] [-Verify {None | AsPartOfJob | AsSeparateJobImmediatelyAfter}] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-ActiveDirectoryPreConsistencyCheck <Boolean>] [-SharePointServiceSiteSelection <BESharePointServiceSiteSelection[]>] [-SharePointPortalSiteSelection <BESharePointPortalSiteSelection[]>] [-OracleSelection <BEOracleSelection[]>] [-LinuxMacSelection <BELinuxMacSelection[]>] [-SharePointSharedServiceApplicationSelection <BESharePointSharedServiceApplicationSelection[]>] [-SharePointServiceApplicationProxySelection <BESharePointServiceApplicationProxySelection[]>] [-SharePointSharedServiceProviderSelection <BESharePointSharedServiceProviderSelection[]>] [-SharePointSharedServiceApplicationProxySelection <BESharePointSharedServiceApplicationProxySelection[]>] [-HyperVSelection <BEHyperVSelection[]>] [-ActiveDirectoryApplicationModeSelection <BEActiveDirectoryApplicationModeSelection[]>] [-EnterpriseVaultDiscoveryAcceleratorSelection <BEEnterpriseVaultDiscoveryAcceleratorSelection[]>] [-Priority {Normal | Lowest | Low | High | Highest}] [-OpenEnterpriseServerSelection <BEOpenEnterpriseServerSelection[]>] [-UtilityPartitionSelection <BEUtilityPartitionSelection[]>] [-VMwareSelection <BEVMwareSelection[]>] [-EnterpriseVaultComplianceAcceleratorSelection <BEEnterpriseVaultComplianceAcceleratorSelection[]>] [-EnterpriseVaultDirectorySelection <BEEnterpriseVaultDirectorySelection[]>] [-SharePointServiceApplicationSelection <BESharePointServiceApplicationSelection[]>] [-FileSystemSelection <BEFileSystemSelection[]>] [-SystemStateSelection {Include | Exclude}] [-ExchangeDatabaseSelection <BEExchangeDatabaseSelection[]>] [-ExchangeStorageGroupDatabaseSelection <BEExchangeStorageGroupDatabaseSelection[]>] [-Name <String>] [-EnableSimplifiedDisasterRecovery <Boolean>] [-Description <String>] [-SqlDatabaseSelection <BESqlDatabaseSelection[]>] [-SharePointHelpSearchSelection {Include | Exclude}] [-SharePointInfoPathServicesSelection {Include | Exclude}] [-SharePointWebApplicationSelection <BESharePointWebApplicationSelection[]>] [-SharePointSingleSignOnDatabaseSelection {Include | Exclude}] [-SharePointConfigurationDatabaseSelection {Include | Exclude}] [-SharePointAllResourcesSelection {Include | Exclude}] [-SharePointCentralAdministrationWebApplicationSelection {Include | Exclude}] [-SharePointGlobalSettingsSelection {Include | Exclude}] [-FileSystemBackupOpenFileIfClosedWithinSeconds <UInt32>] [-FileSystemBackupOpenFile {Never | IfClosedWithinSpecifiedTime | WithALock | WithoutALock}] [-ExchangeContinueIfConsistencyCheckIsUnsuccessful <Boolean>] [-ExchangePreConsistencyCheck <Boolean>] [-FileSystemFollowJunctionPoint <Boolean>] [-FileSystemEnableNtfsSingleInstanceBackup <Boolean>] [-FileSystemBackupRemoteStorage <Boolean>] [-FileSystemFollowSymbolicLink <Boolean>] [-ExchangeHighAvailability {FromPassiveCopyIfAvailableOtherwiseActiveCopy | FromPassiveCopyOnly | FromActiveCopyOnly | FromPassiveCopyIfAvailableOtherwiseActiveCopyUsePreferredServers}] [-LinuxMacFollowLocalMountPoint <Boolean>] [-LinuxMacPreserveChangeTime <Boolean>] [-LinuxMacLockRemoteFile <Boolean>] [-LinuxMacFollowRemoteMountPoint <Boolean>] [-SharePointReleaseLockOnFarmTopology <Boolean>] [-ExchangePreferredServerGroup <BEPreferredServerGroup>] [-SharePointContinueIfConsistencyCheckIsUnsuccessful <Boolean>] [-SharePointPreConsistencyCheck <Boolean>] [-DelayedCatalogDaysOfWeek {Sunday | Monday | Tuesday | Wednesday | Thursday | Friday | Saturday}] [-AllowAnyNetworkForAgentAccess <Boolean>] [-NetworkSubnet <BENetworkInterfaceSubnet>] [-UseSnapshotTechnology <Boolean>] [-EnableCheckpointRestart <Boolean>] [-RestrictToBackupExecServersInPool <BEBackupExecServerPool>] [-RestrictToBackupExecServer <BEBackupExecServer>] [-NetworkProtocol {AnyAvailable | IPv4 | IPv6}] [-NetworkInterface <BENetworkInterface>] [-SnapshotTechnology {Automatic | MicrosoftVolumeShadowCopyService}] [-ProcessOffhostLogicalVolumesSequentially <Boolean>] [-FailIfNoOffhostBackup <Boolean>] [-DelayedCatalogStartAt <DateTime>] [-DelayedCatalogScheduleType {NoDelayedCatalog | ImmediatelyAfterBackup | Scheduled}] [-ProcessLogicalVolumesSequentially <Boolean>] [-SnapshotProvider {Automatic | System | Software | Hardware}] [-OffhostBackupSnapshotProvider {Automatic | Software | Hardware}] [-UseOffhostBackup <Boolean>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [-Force <SwitchParameter>] [<CommonParameters>]

Submit-BEOnetimeBackupJob -SelectionList <BEAgentServerBackupSelectionList[]> [-NotificationRecipientList <BENotificationRecipientObject[]>] [-IncludeJobLogWithEmailNotification <Boolean>] [-TapeStorageCompressionMethod {None | SoftwareIfNoHardware | HardwareOnly | SoftwareOnly}] [-BackupSetDescription <String>] [-KeepJobQueuedFor <TimeSpan>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-PostCommand <String>] [-PrePostCommandSuccessfulIfReturnsZero <Boolean>] [-RunJobOnlyIfPreCommandIsSuccessful <Boolean>] [-EnableDirectAccessIfAvailable <Boolean>] [-StartDate <DateTime>] [-PreCommand <String>] [-SubmitOnHold <Boolean>] [-NdmpNetAppEnableFileHistory <Boolean>] [-Storage <BEStorage>] [-TapeStorageMediaSet <BEMediaSet>] [-NdmpEMCBackupWithIntegratedCheckpoints <Boolean>] [-NdmpEMCEnableFileHistory <Boolean>] [-NdmpNetAppBackupAccessControlLists <Boolean>] [-TapeStorageExportMedia <Boolean>] [-TapeStorageEnableDirectCopyToTape <Boolean>] [-TapeStorageRetensionMediaBeforeBackup <Boolean>] [-DiskStorageKeepForHours <Int32>] [-TapeStorageExportMediaToVault <BEMediaVault>] [-TapeStorageEjectMediaAfterComplete <Boolean>] [-TapeStorageEnableWriteOnceReadManyMedia <Boolean>] [-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>] [-SqlUseSoftwareCompression <Boolean>] [-SharePointUseGrt <Boolean>] [-OracleDeleteBackedUpArchivedLogFile <Boolean>] [-SqlUseChecksumOnBackup <Boolean>] [-SqlCreateDiskCopy <Boolean>] [-SqlDiskCopyPath <String>] [-OracleSkipBackedUpArchivedLogFile <Boolean>] [-SqlAdvancedLogBackupOption {None | NoRecover | Standby}] [-OraclePerformBackupOffline <Boolean>] [-DeleteSelectedFilesAfterSuccessfulBackup {Never | FilesOnly | FilesAndFolders}] [-SqlBackupMethod {FullCopy | DatabaseSnapshot | LogNoTruncate | Log | Full}] [-SqlPostConsistencyCheck {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-Verify {None | AsPartOfJob | AsSeparateJobImmediatelyAfter}] [-EnableDirectAccessForVerifyJobIfAvailable <Boolean>] [-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>] [-RunPostCommandAfterVerification <Boolean>] [-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>] [-VerifyJobNotificationRecipientList <BENotificationRecipientObject[]>] [-ExchangeUseGrt <Boolean>] [-SqlPreConsistencyCheckMethod {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-SqlContinueIfConsistencyCheckUnsuccessful <Boolean>] [-VerifyJobIncludeJobLogWithEmailNotification <Boolean>] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-EncryptionKey <BEEncryptionKey>] [-FailIfNoOffhostBackup <Boolean>] [-ProcessOffhostLogicalVolumesSequentially <Boolean>] [-DelayedCatalogScheduleType {NoDelayedCatalog | ImmediatelyAfterBackup | Scheduled}] [-ProcessLogicalVolumesSequentially <Boolean>] [-UseOffhostBackup <Boolean>] [-OffhostBackupSnapshotProvider {Automatic | Software | Hardware}] [-DelayedCatalogStartAt <DateTime>] [-FileSystemFollowSymbolicLink <Boolean>] [-FileSystemBackupRemoteStorage <Boolean>] [-FileSystemBackupOpenFile {Never | IfClosedWithinSpecifiedTime | WithALock | WithoutALock}] [-DelayedCatalogDaysOfWeek {Sunday | Monday | Tuesday | Wednesday | Thursday | Friday | Saturday}] [-FileSystemEnableNtfsSingleInstanceBackup <Boolean>] [-FileSystemFollowJunctionPoint <Boolean>] [-SnapshotProvider {Automatic | System | Software | Hardware}] [-Priority {Normal | Lowest | Low | High | Highest}] [-RestrictToBackupExecServer <BEBackupExecServer>] [-RestrictToBackupExecServersInPool <BEBackupExecServerPool>] [-Name <String>] [-Description <String>] [-NetworkInterface <BENetworkInterface>] [-EnableCheckpointRestart <Boolean>] [-UseSnapshotTechnology <Boolean>] [-SnapshotTechnology {Automatic | MicrosoftVolumeShadowCopyService}] [-NetworkProtocol {AnyAvailable | IPv4 | IPv6}] [-NetworkSubnet <BENetworkInterfaceSubnet>] [-AllowAnyNetworkForAgentAccess <Boolean>] [-FileSystemBackupOpenFileIfClosedWithinSeconds <UInt32>] [-VirtualMachineEnableIRForAll <Boolean>] [-VirtualMachineUseGrtForFileSystem <Boolean>] [-VirtualMachineUseGrtForActiveDirectory <Boolean>] [-OracleMaximumNumberOfDevicesToUseForResources <UInt32>] [-OracleMinimumNumberOfDevicesRequiredForJob <UInt32>] [-VirtualMachineBackupPoweredOffVirtualMachine <Boolean>] [-VirtualMachineUseGrtForExchange <Boolean>] [-VMwareTransportModePriority {SAN | NBD | NBDSSL | Hotadd}] [-VMwareVSpherePort <UInt32>] [-NdmpEMCBackupType {Dump | VBB}] [-VirtualMachineUseGrtForSql <Boolean>] [-VirtualMachineUseGrtForSharePoint <Boolean>] [-HyperVExcludeVirtualMachinesNeedingSavedState <Boolean>] [-ActiveDirectoryUseGrt <Boolean>] [-ExchangePreferredServerGroup <BEPreferredServerGroup>] [-SharePointReleaseLockOnFarmTopology <Boolean>] [-SharePointPreConsistencyCheck <Boolean>] [-ExchangePreConsistencyCheck <Boolean>] [-ExchangeContinueIfConsistencyCheckIsUnsuccessful <Boolean>] [-ExchangeHighAvailability {FromPassiveCopyIfAvailableOtherwiseActiveCopy | FromPassiveCopyOnly | FromActiveCopyOnly | FromPassiveCopyIfAvailableOtherwiseActiveCopyUsePreferredServers}] [-SharePointContinueIfConsistencyCheckIsUnsuccessful <Boolean>] [-LinuxMacLockRemoteFile <Boolean>] [-ActiveDirectoryPreConsistencyCheck <Boolean>] [-ActiveDirectoryContinueIfConsistencyCheckIsUnsuccessful <Boolean>] [-LinuxMacPreserveChangeTime <Boolean>] [-LinuxMacFollowLocalMountPoint <Boolean>] [-LinuxMacFollowRemoteMountPoint <Boolean>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [-Force <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のワンタイムバックアップジョブをサブミットします。

選択パラメータが Submit-BEOnetimeBackupJob に渡されていない場合、プロンプトの表示後にエージェントサーバ全体がバックアップに選択されます。 このメッセージを表示しないようにするには、-Force パラメータを指定します。

スケジュール済みバックアップジョブを作成するには、New-BEBackupDefinition を使用します。

Parameters

-AgentServer <BEAgentServer>

バックアップするエージェントサーバーを表すオブジェクトを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-EnableSimplifiedDisasterRecovery <Boolean>

簡易システムリカバリを有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SelectionList <BEAgentServerBackupSelectionList[]>

バックアップする選択項目のリストを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String>

バックアップジョブの名前を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

バックアップジョブの説明を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SystemStateSelection

システム状態をバックアップ定義に含める、またはバックアップ定義から除外します。

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemSelection <BEFileSystemSelection[]>

1 つ以上のファイルシステムの選択項目をバックアップ定義に含める、またはバックアップ定義から除外します。含めるファイルまたはディレクトリを指定するには、1 つまたは複数のパスを、カンマを使用して値を区切って指定します。除外するファイルまたはディレクトリを指定するには、-Exclude パラメータと一緒に New-BEFileSystemSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeStorageGroupDatabaseSelection <BEExchangeStorageGroupDatabaseSelection[]>

1 つ以上の Exchange 2003 ストレージのグループまたはデータベースをバックアップ定義に含める、またはバックアップ定義から除外します。含めるストレージグループを指定するには、1 つまたは複数のストレージグループ名を、カンマを使用して値を区切って指定します。「*」を指定するとすべてのストレージグループが含まれます。除外するストレージグループを指定したり、含めるまたは除外するデータベースを個別に指定するには、-Exclude パラメータと一緒に New-BEExchangeStorageGroupDatabaseSelection の出力を使用します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeDatabaseSelection <BEExchangeDatabaseSelection[]>

1 つ以上の Exchange 2007 以降のデータベースをバックアップ定義に含める、またはバックアップ定義から除外します。含めるデータベースを指定するには、1 つまたは複数のデータベース名を、カンマを使用して値を区切って指定します。「*」を指定するとすべてのデータベースが含まれます。除外するデータベースを指定するには、-Exclude パラメータと一緒に New-BEExchangeDatabaseSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlDatabaseSelection <BESqlDatabaseSelection[]>

1 つ以上の SQL インスタンスまたは SQL データベースをバックアップ定義に含める、またはバックアップ定義から除外します。含める SQL インスタンスを指定するには、1 つまたは複数の SQL インスタンス名を、カンマを使用して値を区切って指定します。「*」を指定するとすべての SQL インスタンスが含まれます。除外する SQL インスタンスを指定したり、含めるまたは除外するデータベースを個別に指定するには、-Exclude パラメータと一緒に New-BESqlDatabaseSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointAllResourcesSelection

Windows コンピュータをバックアップするときに、すべての SharePoint リソースをカテゴリ別にバックアップ定義に含める、またはバックアップ定義から除外します。

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointConfigurationDatabaseSelection

SharePoint 設定データベースをバックアップ定義に含める、またはバックアップ定義から除外します。

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointGlobalSettingsSelection

SharePoint のグローバル設定データベースをバックアップ定義に含める、またはバックアップ定義から除外します。

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointCentralAdministrationWebApplicationSelection

SharePoint Central Administration Web アプリケーションをバックアップ定義に含める、またはバックアップ定義から除外します。

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointInfoPathServicesSelection

SharePoint InfoPath サービスをバックアップ定義に含める、またはバックアップ定義から除外します。

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointHelpSearchSelection

SharePoint ヘルプ検索をバックアップ定義に含める、またはバックアップ定義から除外します。

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointSingleSignOnDatabaseSelection

SharePoint シングルサインオンデータベースをバックアップ定義に含める、またはバックアップ定義から除外します。

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointWebApplicationSelection <BESharePointWebApplicationSelection[]>

1 つ以上の SharePoint Web アプリケーションをバックアップ定義に含める、またはバックアップ定義から除外します。含める Web アプリケーションを指定するには、1 つまたは複数の Web アプリケーション名を、カンマを使用して値を区切って指定します。「*」を指定すると、すべての Web アプリケーションが含まれます。 除外する Web アプリケーションを指定するには、-Exclude パラメータと一緒に New-BESharePointWebApplicationSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointServiceApplicationSelection <BESharePointServiceApplicationSelection[]>

1 つ以上の SharePoint サービスアプリケーションをバックアップ定義に含める、またはバックアップ定義から除外します。 含めるサービスアプリケーションを指定するには、1 つまたは複数のサービスアプリケーション名を、カンマを使用して値を区切って指定します。「*」を指定すると、すべてのサービスアプリケーションが含まれます。 除外するサービスアプリケーションを指定するには、-Exclude パラメータと一緒に New-BESharePointServiceApplicationSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointServiceApplicationProxySelection <BESharePointServiceApplicationProxySelection[]>

1 つ以上の SharePoint サービスアプリケーションプロキシをバックアップ定義に含める、またはバックアップ定義から除外します。含めるサービスアプリケーションプロキシを指定するには、1 つまたは複数のサービスアプリケーションプロキシ名を、カンマを使用して値を区切って指定します。「*」を指定すると、すべてのサービスアプリケーションプロキシが含まれます。除外するサービスアプリケーションプロキシを指定するには、-Exclude パラメータと一緒に New-BESharePointServiceApplicationProxySelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointSharedServiceApplicationSelection <BESharePointSharedServiceApplicationSelection[]>

1 つ以上の SharePoint 共有サービスアプリケーションをバックアップ定義に含める、またはバックアップ定義から除外します。含める共有サービスアプリケーションを指定するには、1 つまたは複数の共有サービスアプリケーション名を、カンマを使用して値を区切って指定します。「*」を指定すると、すべての共有サービスアプリケーションが含まれます。除外する共有サービスアプリケーションを指定するには、-Exclude パラメータと一緒に New-BESharePointSharedServiceApplicationSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointSharedServiceApplicationProxySelection <BESharePointSharedServiceApplicationProxySelection[]>

1 つ以上の SharePoint 共有サービスアプリケーションプロキシをバックアップ定義に含める、またはバックアップ定義から除外します。 含める共有サービスアプリケーションプロキシを指定するには、1 つまたは複数の共有サービスアプリケーションプロキシ名を、カンマを使用して値を区切って指定します。「*」を指定すると、すべての共有サービスアプリケーションプロキシが含まれます。除外する共有サービスアプリケーションプロキシを指定するには、-Exclude パラメータと一緒に New-BESharePointSharedServiceApplicationProxySelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointSharedServiceProviderSelection <BESharePointSharedServiceProviderSelection[]>

1 つ以上の SharePoint 共有サービスプロバイダをバックアップ定義に含める、またはバックアップ定義から除外します。含める共有サービスプロバイダを指定するには、1 つまたは複数の共有サービスプロバイダ名を、カンマを使用して値を区切って指定します。除外する共有サービスプロバイダを指定するには、-Exclude パラメータと一緒に New-BESharePointSharedServiceProviderSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointPortalSiteSelection <BESharePointPortalSiteSelection[]>

1 つ以上の SharePoint ポータルサイトをバックアップ定義に含める、またはバックアップ定義から除外します。含めるポータルサイトを指定するには、1 つまたは複数のポータルサイト名を、カンマを使用して値を区切って指定します。除外するポータルサイトを指定するには、-Exclude パラメータと一緒に New-BESharePointPortalSiteSelection の出力を使い、1 つ以上の除外するポータルサイトをこのパラメータに渡します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointServiceSiteSelection <BESharePointServiceSiteSelection[]>

1 つ以上の SharePoint サービスサイトをバックアップ定義に含める、またはバックアップ定義から除外します。 含めるサービスサイトを指定するには、1 つまたは複数のサービスサイト名を、カンマを使用して値を区切って指定します。除外するサービスサイトを指定するには、-Exclude パラメータと一緒に New-BESharePointServiceSiteSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LinuxMacSelection <BELinuxMacSelection[]>

1 つ以上の Linux サーバーまたは Macintosh システムをバックアップ定義に含める、またはバックアップ定義から除外します。 含めるファイルまたはディレクトリを指定するには、1 つまたは複数のパスを、カンマを使用して値を区切って指定します。除外するファイルまたはディレクトリを指定するには、-Exclude パラメータと一緒に New-BELinuxMacSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleSelection <BEOracleSelection[]>

1 つ以上の Oracle の選択項目をバックアップ定義に含める、またはバックアップ定義から除外します。含めるデータベースまたは表スペースを指定するには、1 つまたは複数のパスを、カンマを使用して値を区切って指定します。除外するデータベースまたは表スペースを指定するには、-Exclude パラメータと一緒に New-BEOracleSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-HyperVSelection <BEHyperVSelection[]>

1 つ以上の Hyper-V 仮想マシンをバックアップ定義に含める、またはバックアップ定義から除外します。含める仮想マシンを指定するには、1 つまたは複数の仮想マシン名を、カンマを使用して値を区切って指定します (「*」を指定するとすべての Hyper-V 仮想マシンが含められます)。除外する仮想マシンを指定するには、New-BEHyperVSelection の出力とともに -Exclude パラメータを使用して、最初にすべての仮想マシンを含め、次に除外する対象を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VMwareSelection <BEVMwareSelection[]>

1 つ以上の VMware サーバーをバックアップ定義に含める、またはバックアップ定義から除外します。含める VMware サーバーを指定するには、1 つまたは複数の VMware サーバー名を、カンマを使用して値を区切って指定します。 除外する VMware サーバーを指定するには、New-BEVMwareSelection の出力とともに -Exclude パラメータを使用します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UtilityPartitionSelection <BEUtilityPartitionSelection[]>

1 つ以上のユーティリティパーティションをバックアップ定義に含める、またはバックアップ定義から除外します。含めるユーティリティパーティションを指定するには、1 つまたは複数のパスを、カンマを使用して値を区切って指定します。除外するユーティリティパーティションを指定するには、-Exclude パラメータと一緒に New-BEUtilityPartitionSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnterpriseVaultDirectorySelection <BEEnterpriseVaultDirectorySelection[]>

1 つ以上の Enterprise Vault Directory リソースをバックアップ定義に含める、またはバックアップ定義から除外します。 含める Enterprise Vault Directory リソースを指定するには、1 つまたは複数のリソース名を、カンマを使用して値を区切って指定します。除外するリソースを指定するには、New-BEEnterpriseVaultDirectorySelection の出力とともに -Exclude パラメータを使用します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnterpriseVaultComplianceAcceleratorSelection <BEEnterpriseVaultComplianceAcceleratorSelection[]>

1 つ以上の Enterprise Vault Compliance の Accelerator データベースをバックアップ定義に含める、またはバックアップ定義から除外します。含める Enterprise Vault Compliance の Accelerator データベースを指定するには、1 つまたは複数のデータベース名を、カンマを使用して値を区切って指定します。除外するデータベースを指定するには、New-BEEnterpriseVaultComplianceAcceleratorSelection の出力とともに -Exclude パラメータを使用します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnterpriseVaultDiscoveryAcceleratorSelection <BEEnterpriseVaultDiscoveryAcceleratorSelection[]>

1 つ以上の Enterprise Vault Discovery の Accelerator データベースをバックアップ定義に含める、またはバックアップ定義から除外します。 含める Enterprise Vault Discovery の Accelerator データベースを指定するには、1 つまたは複数のデータベース名を、カンマを使用して値を区切って指定します。除外するデータベースを指定するには、New-BEEnterpriseVaultDiscoveryAcceleratorSelection の出力とともに -Exclude パラメータを使用します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ActiveDirectoryApplicationModeSelection <BEActiveDirectoryApplicationModeSelection[]>

1 つ以上の Active Directory Application Mode インスタンスをバックアップ定義に含める、またはバックアップ定義から除外します。含めるインスタンスを指定するには、1 つまたは複数のパスを、カンマを使用して値を区切って指定します。除外するインスタンスを指定するには、-Exclude パラメータと一緒に New-BEActiveDirectoryLightweightDirectoryServiceSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OpenEnterpriseServerSelection <BEOpenEnterpriseServerSelection[]>

1 つ以上の OES コンポーネントをバックアップ定義に含める、またはバックアップ定義から除外します。含めるファイルまたはディレクトリを指定するには、1 つまたは複数のパスを、カンマを使用して値を区切って指定します。除外するファイルまたはディレクトリを指定するには、-Exclude パラメータと一緒に New-BEOpenEnterpriseServerSelection の出力を使います。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Priority

ジョブを実行する順序を指定します。2 つのジョブが同時に実行されるようにスケジュールされている場合、ユーザーが設定する優先度でどちらが先に実行されるかが決まります。

The valid values are:
Normal
Lowest
Low
High
Highest

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RestrictToBackupExecServer <BEBackupExecServer>

CASO 環境でジョブをディスパッチ可能な Backup Exec サーバーを指定します。RestrictToBackupExecServersInPool が指定されている場合は指定できません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RestrictToBackupExecServersInPool <BEBackupExecServerPool>

CASO 環境でジョブをディスパッチ可能な Backup Exec サーバーのセットを指定します。RestrictToBackupExecServer が指定されている場合は指定できません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NetworkInterface <BENetworkInterface>

バックアップネットワークとして使用するネットワークに対して Backup Exec サーバーを接続する、ネットワークインターフェースカードの名前を指定します。Get-BENetworkInterface を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NetworkProtocol

リモートコンピュータをバックアップするために使うプロトコルを指定します。

The valid values are:
AnyAvailable
IPv4
IPv6

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NetworkSubnet <BENetworkInterfaceSubnet>

Get-BENetworkInterface によって返されたネットワークインターフェースのサブネットの 1 つを使用して、リモートコンピュータをバックアップするために使うサブネットを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AllowAnyNetworkForAgentAccess <Boolean>

バックアップまたはリストアのために選択したリモートコンピュータが、指定したバックアップネットワークの一部でない場合に、リモートコンピュータからのデータが任意の利用可能なネットワークを介してバックアップまたはリストアされるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableCheckpointRestart <Boolean>

ジョブが中断された時点からバックアップジョブを続行可能にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UseSnapshotTechnology <Boolean>

スナップショットテクノロジの利用を有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SnapshotTechnology

スナップショットテクノロジを有効にしたときに使用する、スナップショットテクノロジを指定します。UseSnapshotTechnology は $true に設定する必要があります。

The valid values are:
Automatic
MicrosoftVolumeShadowCopyService

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SnapshotProvider

スナップショットテクノロジを有効にしたときに使用するスナップショットプロバイダとして、Microsoft ボリュームシャドウコピーサービスを指定します。UseSnapshotTechnology を $true に設定し、SnapshotTechnology を MicrosoftVolumeShadowCopyService に設定する必要があります。

The valid values are:
Automatic
System
Software
Hardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ProcessLogicalVolumesSequentially <Boolean>

1 つのジョブで複数のボリュームをバックアップすることを有効にします。このとき、一度に 1 つの論理ボリュームのスナップショットのみが作成されます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UseOffhostBackup <Boolean>

オフホストバックアップを有効にします。有効な場合は、すべての必要条件が満たされると、すべてのボリュームのオフホストバックアップが実行されます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OffhostBackupSnapshotProvider

使用するオフホストバックアップのスナップショットプロバイダを指定します。UseOffhostBackup は $true に設定する必要があります。

The valid values are:
Automatic
Software
Hardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FailIfNoOffhostBackup <Boolean>

選択したボリュームのいずれかがオフホストバックアップをサポートしない場合、またはスナップショットやボリュームのインポートでエラーが発生した場合、バックアップジョブを終了します。 UseOffhostBackup は $true に設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ProcessOffhostLogicalVolumesSequentially <Boolean>

1 つのジョブで複数のボリュームをバックアップすることを可能にします。このとき、オフホストバックアップに対して一度に 1 つの論理ボリュームのスナップショットのみが作成されます。UseOffhostBackup は $true に設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DelayedCatalogScheduleType

実行する延期したカタログ操作の代替日または時間を指定します。

The valid values are:
NoDelayedCatalog
ImmediatelyAfterBackup
Scheduled

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DelayedCatalogStartAt <DateTime>

遅延カタログジョブを実行する時刻を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DelayedCatalogDaysOfWeek

遅延カタログジョブを実行する曜日を指定します。

The valid values are:
Sunday
Monday
Tuesday
Wednesday
Thursday
Friday
Saturday

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemEnableNtfsSingleInstanceBackup <Boolean>

Backup Exec で同一ファイルに対して NTFS ボリュームをチェックできるようにします。ファイルのコピーが複数見つかった場合は、そのファイルの 1 つのインスタンスのみが Backup Exec によってバックアップされます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemFollowJunctionPoint <Boolean>

接合点の情報とリンク先のファイルおよびディレクトリをバックアップします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemFollowSymbolicLink <Boolean>

シンボリックリンクの情報とリンク先のファイルとディレクトリの情報をバックアップします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemBackupRemoteStorage <Boolean>

プライマリストレージからセカンダリストレージに移動したデータをバックアップします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemBackupOpenFile

スナップショットテクノロジが使用されていない場合に Backup Exec がバックアップジョブでオープンファイルを処理する方法を指定します。

The valid values are:
Never
IfClosedWithinSpecifiedTime
WithALock
WithoutALock

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemBackupOpenFileIfClosedWithinSeconds <UInt32>

オープンファイルをスキップしてバックアップジョブを続行する前に Backup Exec が待機する秒数を指定します。BackupOpenFile が IfClosedWithinSpecifiedTime に設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangePreConsistencyCheck <Boolean>

バックアップジョブを実行する前に一貫性チェックを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeContinueIfConsistencyCheckIsUnsuccessful <Boolean>

一貫性チェックに失敗した場合でもバックアップジョブを続行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeHighAvailability

Exchange 2007 以降のバックアップソースを指定します。

The valid values are:
FromPassiveCopyIfAvailableOtherwiseActiveCopy
FromPassiveCopyOnly
FromActiveCopyOnly
FromPassiveCopyIfAvailableOtherwiseActiveCopyUsePreferredServers

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangePreferredServerGroup <BEPreferredServerGroup>

Microsoft Exchange 2010 データベース可用性グループをバックアップするために使用する優先サーバーの設定の名前を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointReleaseLockOnFarmTopology <Boolean>

バックアップジョブを実行する前に SharePoint ファームトポロジーのロックを解除します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointPreConsistencyCheck <Boolean>

Microsoft SharePoint で使用する Microsoft SQL データベースをバックアップする前に、インデックスを含む完全な一貫性チェックを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointContinueIfConsistencyCheckIsUnsuccessful <Boolean>

一貫性チェックに失敗した場合でもバックアップジョブを続行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LinuxMacPreserveChangeTime <Boolean>

バックアップジョブの実行時に Agent for Windows でオブジェクトの属性が変更されないようにします。オブジェクトはファイルまたはディレクトリです。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LinuxMacFollowLocalMountPoint <Boolean>

データのバックアップ時に Backup Exec でローカルマウントポイントをたどることができます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LinuxMacFollowRemoteMountPoint <Boolean>

データのバックアップ時に Backup Exec でリモートマウントポイントをたどることができます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LinuxMacLockRemoteFile <Boolean>

ネットワークファイルシステム (NFS) を介して接続されたリモートコンピュータのファイルに Agent for Windows で排他的にアクセスできます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ActiveDirectoryPreConsistencyCheck <Boolean>

スナップショットにデータ破損がないかを確認します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ActiveDirectoryContinueIfConsistencyCheckIsUnsuccessful <Boolean>

一貫性チェックが失敗してもバックアップジョブの続行を可能にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ActiveDirectoryUseGrt <Boolean>

Active Directory の完全バックアップから個々の項目をリストアできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleMaximumNumberOfDevicesToUseForResources <UInt32>

バックアップジョブで使用できる最大デバイス数を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleMinimumNumberOfDevicesRequiredForJob <UInt32>

ジョブで使用できる最小デバイス数を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineBackupPoweredOffVirtualMachine <Boolean>

オフになった仮想マシンを Backup Exec でバックアップできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineEnableIRForAll <Boolean>

GRT の対象外を含むすべての仮想マシンでインスタントリカバリを有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForFileSystem <Boolean>

完全バックアップジョブから個々のファイルとフォルダをリストアできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForActiveDirectory <Boolean>

Backup Exec で仮想マシン上の個々の Active Directory オブジェクトをリストアするのに必要な情報を収集できるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForExchange <Boolean>

Backup Exec で仮想マシン上の個々の Exchange データベースおよびメールボックス項目をリストアするのに必要な情報を収集できるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForSql <Boolean>

Backup Exec で仮想マシン上の個々の SQL データベース項目をリストアするのに必要な情報を収集できるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForSharePoint <Boolean>

Backup Exec で仮想マシン上の SharePoint データをリストアするのに必要な情報を収集できるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-HyperVExcludeVirtualMachinesNeedingSavedState <Boolean>

オンラインバックアップをサポートしない、バックアップの開始時に実行状態であるすべてのオフライン仮想マシンを除外します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VMwareTransportModePriority

Backup Exec で使用する 1 つ以上の VMware 転送モードを優先度順に指定します。

The valid values are:
SAN
NBD
NBDSSL
Hotadd

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VMwareVSpherePort <UInt32>

Backup Exec で使用する VMware vSphere ポートを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NdmpEMCBackupType

EMC NDMP サーバーのバックアップタイプを指定します。

The valid values are:
Dump
VBB

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NdmpEMCBackupWithIntegratedCheckpoints <Boolean>

Backup Exec で EMC SnapSure 機能を使用するバックアップセットを作成するように設定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NdmpEMCEnableFileHistory <Boolean>

ファイルの履歴データの生成を可能にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NdmpNetAppBackupAccessControlLists <Boolean>

NetApp アクセス制御リストをバックアップします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NdmpNetAppEnableFileHistory <Boolean>

ファイルの履歴データの生成を可能にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Storage <BEStorage>

バックアップジョブに使用するストレージデバイスを指定します。 Get-BEStorage を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaSet <BEMediaSet>

メディアと関連付けるメディアセットを指定します。メディアはメディアセットの設定に基づいて上書きから保護されます。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。 Get-BEMediaSet を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMedia <Boolean>

ジョブの完了後にデバイスからメディアをエクスポートします。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMediaToVault <BEMediaVault>

ジョブの完了後にメディアを指定したボルトに論理的に移動します。Storage パラメータはテープベースのストレージデバイスに設定し、TapeStorageExportMedia は $true に設定する必要があります。Get-BEMediaVault を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEjectMediaAfterComplete <Boolean>

ジョブの完了後にストレージデバイスからメディアを取り出します。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableWriteOnceReadManyMedia <Boolean>

バックアップジョブに WORM (Write Once Read Many) メディアの使用を指定します。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableDirectCopyToTape <Boolean>

物理テープデバイスに仮想テープライブラリから直接データをコピーできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageRetensionMediaBeforeBackup <Boolean>

データを書き込む前にメディアのリテンションを行います。 Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskStorageKeepForHours <Int32>

メディアへの上書きを禁止し、このメディア上にデータを保存する時間を指定します。 Storage パラメータがディスクベースのストレージデバイスに設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SubmitOnHold <Boolean>

ジョブを保留状態でサブミットします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupSetDescription <String>

バックアップしたデータとその格納場所についての説明です。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

予定開始時刻の経過後に、ジョブが未処理であると Backup Exec が判断し、そのジョブのスケジュール再設定が可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

予定開始時刻後にジョブの実行が続行されている場合、そのジョブのキャンセルが可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NotificationRecipientList <BENotificationRecipientObject[]>

ジョブが完了したときに通知を受け取る受信者を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IncludeJobLogWithEmailNotification <Boolean>

電子メールにジョブログを添付します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageCompressionMethod

使用するソフトウェアデータ圧縮またはハードウェアデータ圧縮の種類を指定します。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
None
SoftwareIfNoHardware
HardwareOnly
SoftwareOnly

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaAppendMethod

ジョブの開始時にメディアに上書きまたは追記します。Storage パラメータは、テープベースのストレージデバイスに設定する必要があります。

The valid values are:
Append
AppendOnly
Overwrite

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableDirectAccessIfAvailable <Boolean>

Agent for Windows から Storage パラメータで指定したデバイスにバックアップデータを直接送信できるようにします (デバイスがこの操作をサポートしている場合)。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-StartDate <DateTime>

ジョブを開始する日時を指定します。 このパラメータを指定しない場合、ジョブはすぐに開始されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreCommand <String>

バックアップジョブの前に実行するコマンドを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PostCommand <String>

バックアップジョブの後に実行するコマンドを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PrePostCommandSuccessfulIfReturnsZero <Boolean>

Backup Exec によってプリコマンドまたはポストコマンドの戻りコードを確認し、コマンドが正しく完了したかどうかを調べることができます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunJobOnlyIfPreCommandIsSuccessful <Boolean>

プリコマンドが正しく実行された場合にのみバックアップジョブを実行します。プリコマンドの実行に失敗した場合は、ジョブは実行されません。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>

プリコマンドが正しく実行された場合にのみポストコマンドを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>

ジョブが正しく実行されなかった場合でもポストコマンドを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandAfterVerification <Boolean>

バックアップジョブの検証を選択した場合、検証が完了した後にポストコマンドを実行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>

完了しなかったプリコマンドまたはポストコマンドをキャンセルするのに待つ時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunCommandLocation

プリコマンドとポストコマンドが実行される場所を指定します。

The valid values are:
OnEachAgentServer
OnBackupExecServer

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Verify

バックアップジョブの完了時に自動的に検証操作を実行します。

The valid values are:
None
AsPartOfJob
AsSeparateJobImmediatelyAfter

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableDirectAccessForVerifyJobIfAvailable <Boolean>

Agent for Windows でデータを検証するかどうかを指定します (Storage パラメータで指定したデバイスがこの操作をサポートしている場合)。 Verify パラメータが AsSeparateJobImmediatelyAfter に設定されている必要があります。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VerifyJobNotificationRecipientList <BENotificationRecipientObject[]>

検証ジョブが完了したときに通知を受け取る受信者を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VerifyJobIncludeJobLogWithEmailNotification <Boolean>

電子メールに検証ジョブログを添付します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionType

バックアップジョブに使用する暗号化の種類を指定します。

The valid values are:
None
Software
Hardware
SoftwareIfNoHardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionKey <BEEncryptionKey>

使用する暗号化キーを指定します。 EncryptionType が None 以外の値に設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeUseGrt <Boolean>

インフォメーションストアのバックアップジョブから個々の項目をリストアできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlPreConsistencyCheckMethod

バックアップジョブを実行する前に行う一貫性チェックの種類を指定します。

The valid values are:
None
Physical
FullExcludingIndexes
FullIncludingIndexes

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlContinueIfConsistencyCheckUnsuccessful <Boolean>

一貫性チェックに失敗した場合でもバックアップジョブを続行します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlPostConsistencyCheck

バックアップジョブを実行した後に行う一貫性チェックの種類を指定します。

The valid values are:
None
Physical
FullExcludingIndexes
FullIncludingIndexes

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlUseChecksumOnBackup <Boolean>

SQL 2005 以降の場合、バックアップする SQL データベースのデータにチェックサムを追加します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlCreateDiskCopy <Boolean>

バックアップする SQL データベースのコピーをディスク上に作成します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlDiskCopyPath <String>

バックアップする SQL データベースのディスク上に作成されるコピーのパスを指定します。CreateDiskCopy が $true に設定されている必要があります。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlUseSoftwareCompression <Boolean>

SQL 2008以降の場合、使用する圧縮設定を指定します。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointUseGrt <Boolean>

データベースバックアップからの個々のドキュメント、イメージ、サイト、サブサイト、リスト、リストの項目のリストアを有効にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleDeleteBackedUpArchivedLogFile <Boolean>

バックアップ後にアーカイブログファイルを自動的に削除できます。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleSkipBackedUpArchivedLogFile <Boolean>

以前にバックアップしたアーカイブログファイルを Backup Exec がスキップできるようにします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OraclePerformBackupOffline <Boolean>

バックアップジョブを開始する前に Backup Exec がデータベースをオフラインにすることを可能にします。

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DeleteSelectedFilesAfterSuccessfulBackup

選択したデータをバックアップし、メディアの検証を行った後、ボリュームからデータを削除します。この操作でファイルを削除してデータを回復するにはリストアを実行する必要があるため、このオプションを有効にした場合は Force パラメータを指定する必要があります。

The valid values are:
Never
FilesOnly
FilesAndFolders

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlBackupMethod

このバックアップジョブに使用する SQL バックアップ方式を指定します。

The valid values are:
FullCopy
DatabaseSnapshot
LogNoTruncate
Log
Full

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlAdvancedLogBackupOption

このバックアップジョブに使用する高度なログバックアップオプションを指定します。

The valid values are:
None
NoRecover
Standby

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Force <SwitchParameter>

DeleteSelectedFilesAfterSuccessfulBackup パラメータによってデータが失われ、使用を続ける必要があることを確認します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEAgentServer

Backup Exec のエージェントサーバーオブジェクトを Submit-BEOnetimeBackupJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEJob

Submit-BEOnetimeBackupJob はサブミットされたジョブを返します。

Examples

Example 1

C:\PS> Get-BEAgentServer -Local | Submit-BEOneTimeBackupJob -Force | Wait-BEJob

これらのコマンドはローカルコンピュータ上のすべてのデータをバックアップするワンタイムバックアップをサブミットして、ジョブが完了するまで待機します。

Example 2
C:\PS> Get-BEAgentServer -Local | Submit-BEOneTimeBackupJob -SystemStateSelection Include -FileSystemSelection C:\*,D:\*

これらのコマンドはローカルコンピュータのシステム状態と C: ドライブと D: ドライブ上のデータをバックアップするワンタイムバックアップをサブミットします。

Related Links

New-BEBackupDefinition
New-BEFileSystemSelection
New-BEUtilityPartitionSelection
New-BELinuxMacSelection
New-BEOpenEnterpriseServerSelection
New-BEOracleSelection
New-BEExchangeStorageGroupDatabaseSelection
New-BEExchangeDatabaseSelection
New-BESqlDatabaseSelection
New-BESharePointWebApplicationSelection
New-BESharePointServiceApplicationSelection
New-BESharePointServiceApplicationProxySelection
New-BESharePointSharedServiceApplicationSelection
New-BESharePointSharedServiceApplicationProxySelection
New-BESharePointSharedServiceProviderSelection
New-BESharePointPortalSiteSelection
New-BESharePointServiceSiteSelection
Get-BENetworkInterface
New-BEHyperVSelection
New-BEVMwareSelection
Get-BEStorage
Get-BEMediaSet
Get-BEMediaVault
New-BEEnterpriseVaultDirectorySelection
New-BEEnterpriseVaultComplianceAcceleratorSelection
New-BEEnterpriseVaultDiscoveryAcceleratorSelection
Get-BEAgentServer
Wait-BEJob


Submit-BERetensionMediaJob Help

Submit-BERetensionMediaJob Cmdlet
Synopsis

Backup Exec のストレージデバイス内のメディアをリテンションするジョブをサブミットします。

Syntax
Submit-BERetensionMediaJob -TapeDriveDevice <BETapeDriveDevice> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Submit-BERetensionMediaJob -RoboticLibraryDevice <BERoboticLibraryDevice> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Submit-BERetensionMediaJob -RoboticLibraryPartition <BERoboticLibraryPartition> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Submit-BERetensionMediaJob -RoboticLibrarySlot <BERoboticLibrarySlot[]> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のストレージデバイス内のメディアをリテンションするジョブをサブミットします。

リテンションを使用してテープドライブ内のテープを始めから終わりまで高速で巻き取りなおし、テープが均一にヘッドを滑らかに通過するようにします。

Parameters

-Name <String>

作成するジョブの名前を指定します。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeDriveDevice <BETapeDriveDevice>

リテンションするテープドライブデバイスを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibraryDevice <BERoboticLibraryDevice>

リテンションするロボットライブラリデバイスを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibraryPartition <BERoboticLibraryPartition>

リテンションするロボットライブラリパーティションを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibrarySlot <BERoboticLibrarySlot[]>

リテンションするロボットライブラリスロットを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

CASO 環境でジョブを処理する Backup Exec サーバーを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BETapeDriveDevice

Backup Exec のテープドライブデバイスオブジェクトを Submit-BERetensionMediaJob にパイプ処理できます。

BackupExec.Management.CLI.BERoboticLibraryDevice

Backup Exec のロボットライブラリデバイスオブジェクトを Submit-BERetensionMediaJob にパイプ処理できます。

BackupExec.Management.CLI.BERoboticLibraryPartition

Backup Exec のロボットライブラリパーティションオブジェクトを Submit-BERetensionMediaJob にパイプ処理できます。

BackupExec.Management.CLI.BERoboticLibrarySlot

Backup Exec のロボットライブラリスロットオブジェクトを Submit-BERetensionMediaJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEJob

Submit-BERetensionMediaJob はサブミットされたジョブを返します。

Example

C:\PS> Get-BETapeDriveDevice "Device 0001" | Submit-BERetensionMediaJob

これらのコマンドは「Device 0001」という名前のテープドライブデバイス内のメディアをリテンションするジョブをサブミットします。

Related Link

Get-BETapeDriveDevice


Submit-BEScanJob Help

Submit-BEScanJob Cmdlet
Synopsis

Backup Exec のロボットライブラリデバイスのスロット情報を更新するジョブをサブミットします。

Syntax
Submit-BEScanJob -RoboticLibraryDevice <BERoboticLibraryDevice> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-Schedule <BESchedule>] [-KeepJobQueuedFor <TimeSpan>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Submit-BEScanJob -RoboticLibraryPartition <BERoboticLibraryPartition> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-Schedule <BESchedule>] [-KeepJobQueuedFor <TimeSpan>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Submit-BEScanJob -RoboticLibrarySlot <BERoboticLibrarySlot[]> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-Schedule <BESchedule>] [-KeepJobQueuedFor <TimeSpan>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のロボットライブラリデバイスのスロット情報を更新するジョブをサブミットします。

このユーティリティジョブはマガジンを変更する場合やマガジンに新しいメディアを挿入する場合に役立ちます。

Parameters

-Name <String>

作成するジョブの名前を指定します。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-RoboticLibraryDevice <BERoboticLibraryDevice>

スキャンするロボットライブラリデバイスを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibraryPartition <BERoboticLibraryPartition>

スキャンするロボットライブラリパーティションを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibrarySlot <BERoboticLibrarySlot[]>

スキャンするロボットライブラリスロットを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Schedule <BESchedule>

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

予定開始時刻の経過後に、ジョブが未処理であると Backup Exec が判断し、そのジョブのスケジュール再設定が可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

予定開始時刻後にジョブの実行が続行されている場合、そのジョブのキャンセルが可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

CASO 環境でジョブを処理する Backup Exec サーバーを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BERoboticLibraryDevice

Backup Exec のロボットライブラリデバイスオブジェクトを Submit-BEScanJob にパイプ処理できます。

BackupExec.Management.CLI.BERoboticLibraryPartition

Backup Exec のロボットライブラリパーティションオブジェクトを Submit-BEScanJob にパイプ処理できます。

BackupExec.Management.CLI.BERoboticLibrarySlot

Backup Exec のロボットライブラリスロットオブジェクトを Submit-BEScanJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEJob

Submit-BEScanJob はサブミットされたジョブを返します。

Example

C:\PS> Get-BERoboticLibraryDevice "Device 0001" | Submit-BEScanJob

これらのコマンドは「Device 0001」という名前のロボットライブラリ内のメディアをスキャンするジョブをサブミットします。

Related Links


Submit-BEStorageArrayDeviceConfigurationJob Help

Submit-BEStorageArrayDeviceConfigurationJob Cmdlet
Synopsis

Backup Exec のストレージアレイデバイスを設定します。

Syntax
Submit-BEStorageArrayDeviceConfigurationJob -StorageArrayDevice <BEStorageArrayDevice> -VirtualDiskSizeGigabyte <UInt32> [-MakeDeduplicationDiskStorageDevice <SwitchParameter>] [-BackupExecServer <BEBackupExecServer>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]

Submit-BEStorageArrayDeviceConfigurationJob -StorageArrayDevice <BEStorageArrayDevice> -DiskGroupPhysicalDisk <BEStorageArrayPhysicalDisk[]> [-MakeDeduplicationDiskStorageDevice <SwitchParameter>] [-RemoveHotSparePhysicalDisk <BEStorageArrayPhysicalDisk[]>] [-BackupExecServer <BEBackupExecServer>] [-AddHotSparePhysicalDisk <BEStorageArrayPhysicalDisk[]>] [-VirtualDiskCount <Int32>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Submit-BEStorageArrayDeviceConfigurationJob -StorageArrayDevice <BEStorageArrayDevice> -ConfigureHotSparesOnly <SwitchParameter> [-RemoveHotSparePhysicalDisk <BEStorageArrayPhysicalDisk[]>] [-BackupExecServer <BEBackupExecServer>] [-AddHotSparePhysicalDisk <BEStorageArrayPhysicalDisk[]>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のストレージアレイデバイスを設定します。

Parameters

-StorageArrayDevice <BEStorageArrayDevice>

設定するストレージアレイデバイスを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

CASO 環境でジョブを処理する Backup Exec サーバーを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualDiskSizeGigabyte <UInt32>

仮想ディスクのサイズを指定します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskGroupPhysicalDisk <BEStorageArrayPhysicalDisk[]>

ディスクグループに属する物理ディスクを指定します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualDiskCount <Int32>

ストレージアレイにある物理ディスクから作成する仮想ディスクの数を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ConfigureHotSparesOnly <SwitchParameter>

ホットスペア物理ディスクのみを設定します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AddHotSparePhysicalDisk <BEStorageArrayPhysicalDisk[]>

ホットスペアとして追加する 1 つ以上の物理ディスクを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RemoveHotSparePhysicalDisk <BEStorageArrayPhysicalDisk[]>

ホットスペアとして削除する 1 つ以上の物理ディスクを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MakeDeduplicationDiskStorageDevice <SwitchParameter>

重複排除用ディスクストレージデバイスにします。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEStorageArrayDevice

Backup Exec ストレージアレイデバイスオブジェクトを Submit-BEStorageArrayDeviceConfigurationJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEJob

Submit-BEStorageArrayDeviceConfigurationJob は Backup Exec ジョブオブジェクトを出力します。

Examples

Example 1

C:\PS> Get-BEStorageArrayDevice -Name "Device 0001" | Submit-BEStorageArrayDeviceConfigurationJob -VirtualDiskSizeGigabyte 10

これらのコマンドは「Device 0001」という名前のストレージアレイデバイスで指定したサイズの仮想ディスクを設定します。 ストレージアレイはディスクストレージグループに属する物理ディスクを選択します。

Example 2
C:\PS> $physicalDisks = Get-BEStorageArrayDevice -Name "Device 0001" | Get-BEStorageArrayPhysicalDisk -IsConfigured $false
C:\PS> Get-BEStorageArrayDevice -Name "Device 0001" | Submit-BEStorageArrayDeviceConfigurationJob -ConfigureHotSparesOnly -AddHotSparePhysicalDisk $physicalDisks

これらのコマンドは「Device 0001」という名前のストレージアレイデバイスで未設定物理ディスクをすべてホットスペアとして設定します。

Example 3
C:\PS> $physicalDisks = Get-BEStorageArrayDevice -Name "Device 0001" | Get-BEStorageArrayPhysicalDisk -IsConfigured $false
C:\PS> Get-BEStorageArrayDevice -Name "Device 0001" | Submit-BEStorageArrayDeviceConfigurationJob -DiskGroupPhysicalDisk $physicalDisks

これらのコマンドは「Device 0001」という名前のストレージアレイデバイスで未設定物理ディスクをすべてホットスペアとして設定します。

Related Links


Submit-BEUnlockJob Help

Submit-BEUnlockJob Cmdlet
Synopsis

Backup Exec のロボットライブラリの前面パネルをロック解除するジョブをサブミットします。

Syntax
Submit-BEUnlockJob -RoboticLibraryDevice <BERoboticLibraryDevice> [[-Name] <String>] [-BackupExecServer <BEBackupExecServer>] [-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>] [-Schedule <BESchedule>] [-KeepJobQueuedFor <TimeSpan>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のロボットライブラリの前面パネルをロック解除するジョブをサブミットします。

Parameters

-Name <String>

作成するジョブの名前を指定します。

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-RoboticLibraryDevice <BERoboticLibraryDevice>

ロック解除するロボットライブラリデバイスを指定します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Schedule <BESchedule>

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

予定開始時刻の経過後に、ジョブが未処理であると Backup Exec が判断し、そのジョブのスケジュール再設定が可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

予定開始時刻後にジョブの実行が続行されている場合、そのジョブのキャンセルが可能となるまでの最大経過時間を指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

CASO 環境でジョブを処理する Backup Exec サーバーを指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BERoboticLibraryDevice

Backup Exec のロボットライブラリデバイスオブジェクトを Submit-BEUnlockJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEJob

Submit-BEUnlockJob はサブミットされたジョブを返します。

Example

C:\PS> Get-BERoboticLibraryDevice "Device 0001" | Submit-BEUnlockJob

これらのコマンドは「Device 0001」という名前のロボットライブラリの前面パネルをロック解除するジョブをサブミットします。

Related Links


Suspend-BEJob Help

Suspend-BEJob Cmdlet
Synopsis

Backup Exec のジョブを保留にします。

Syntax
Suspend-BEJob -InputObject <BEJob[]> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のジョブを保留にします。

保留中のジョブを再開するには Resume-BEJob を使用します。

Parameters

-InputObject <BEJob[]>

1 つ以上のジョブオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEJob

Backup Exec ジョブオブジェクトを Suspend-BEJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEJob

Suspend-BEJob は Backup Exec ジョブオブジェクトを返します。

Example

C:\PS> Get-BEJob "Job 0001" | Suspend-BEJob

これらのコマンドは「Job 0001」という名前のジョブを保留にします。

Related Links


Suspend-BEJobQueue Help

Suspend-BEJobQueue Cmdlet
Synopsis

Backup Exec のサーバーのジョブキューを保留にします。

Syntax
Suspend-BEJobQueue [-BackupExecServer <BEBackupExecServer>] [<CommonParameters>]
Description

Backup Exec のサーバーのジョブキューを保留にします。

保留中のサーバーのジョブキューを再開するには Resume-BEJobQueue を使用します。

-BackupExecServer パラメータを指定しない場合、Suspend-BEJobQueue はローカル Backup Exec サーバーのジョブキューを保留にします。

Parameters

-BackupExecServer <BEBackupExecServer>

CASO 環境でジョブキューを保留にする Backup Exec サーバーを指定します。

Required | false
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトを Suspend-BEJobQueue にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEBackupExecServer

Suspend-BEJobQueue は Backup Exec サーバーオブジェクトを返します。

Examples

Example 1

C:\PS> Suspend-BEJobQueue

このコマンドはローカル Backup Exec サーバーのジョブキューを保留にします。

Example 2
C:\PS> Get-BEBackupExecServer "ManagedServer0001" | Suspend-BEJobQueue

これらのコマンドは「ManagedServer0001」という名前の Backup Exec サーバーのジョブキューを保留にします。

Related Links


Switch-BEEncryptionKey Help

Switch-BEEncryptionKey Cmdlet
Synopsis

Backup Exec のすべてのバックアップジョブで 1 つの暗号化キーを別の暗号化キーと置換します。

Syntax
Switch-BEEncryptionKey -InputObject <BEEncryptionKey[]> -ReplacementEncryptionKey <BEEncryptionKey> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Switch-BEEncryptionKey -InputObject <BEEncryptionKey[]> -ReplaceWithNone <SwitchParameter> [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のすべてのバックアップジョブで 1 つの暗号化キーを別の暗号化キーと置換します。

1 つの暗号化キーを 1 つ以上のジョブで使用している場合、Remove-BEEncryptionKey コマンドで暗号化キーを削除する前に Switch-BEEncryptionKey を使用する必要があります。

Parameters

-InputObject <BEEncryptionKey[]>

1 つ以上の暗号化キーオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-ReplacementEncryptionKey <BEEncryptionKey>

置換用に使用する暗号化キーを指定します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ReplaceWithNone <SwitchParameter>

置換用の暗号化キーを使用しないことを指定します。

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEEncryptionKey

Backup Exec 暗号化キーオブジェクトを Switch-BEEncryptionKey にパイプ処理することができます。

Return Value
BackupExec.Management.CLI.BEEncryptionKey

Switch-BEEncryptionKey は Backup Exec 暗号化キーオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEEncryptionKey "Encryption Key 0001" | Replace-BEEncryptionKey -ReplacementEncryptionKey "Encryption Key 0002"

これらのコマンドは、「Encryption Key 0001」という名前の暗号化キーを使用中のすべてのジョブで暗号化キーを「Encryption Key 0002」という名前の暗号化キーに置換します。

Example 2
C:\PS> Get-BEEncryptionKey "Encryption Key 0001" | Replace-BEEncryptionKey -ReplaceWithNone

これらのコマンドは「Encryption Key 0001」という名前の暗号化キーを使用中のすべてのジョブからその暗号化キーを削除します。

Related Links


Test-BEBackupExecServerOnCloudStorageDevice Help

Test-BEBackupExecServerOnCloudStorageDevice Cmdlet
Synopsis

Backup Exec がクラウドストレージデバイスにアクセスするために使用するクレデンシャルをテストします。

Syntax
Test-BEBackupExecServerOnCloudStorageDevice [-BackupExecServer] <BEBackupExecServer> [-CloudStorageDevice] <BECloudStorageDevice> [<CommonParameters>]
Description

Backup Exec がクラウドストレージデバイスにアクセスするために使用するクレデンシャルをテストします。

Parameters

-CloudStorageDevice <BECloudStorageDevice>

テストするクラウドストレージデバイスを指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

クラウドストレージデバイスにアクセスする Backup Exec サーバーを指定します。

Required | true
Position | 1
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトを Test-BEBackupExecServerOnCloudStorageDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEDeviceValidationResult

Test-BEBackupExecServerOnCloudStorageDevice は Backup Exec サーバーとクラウドストレージデバイスとの間の通信をテストするオブジェクトを返します。

Example

C:\PS> $Device = Get-BECloudStorageDevice -Name "Cloud Device"
C:\PS> Get-BEBackupExecServer | Test-BEBackupExecServerOnCloudStorageDevice -CloudStorageDevice $Device

このコマンドは Backup Exec サーバーがクラウドストレージデバイスにアクセスするために使用するクレデンシャルをテストします。

Related Links


Test-BEBackupExecServerOnDeduplicationDiskStorageDevice Help

Test-BEBackupExecServerOnDeduplicationDiskStorageDevice Cmdlet
Synopsis

Backup Exec が重複排除用ディスクストレージデバイスにアクセスするために使用するクレデンシャルをテストします。

Syntax
Test-BEBackupExecServerOnDeduplicationDiskStorageDevice [-BackupExecServer] <BEBackupExecServer> [-DeduplicationDiskStorageDevice] <BEDeduplicationDiskStorageDevice> [<CommonParameters>]
Description

Backup Exec が重複排除用ディスクストレージデバイスにアクセスするために使用するクレデンシャルをテストします。

Parameters

-DeduplicationDiskStorageDevice <BEDeduplicationDiskStorageDevice>

テストする重複排除用ディスクストレージデバイスを指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

重複排除用ディスクストレージデバイスにアクセスする Backup Exec サーバーを指定します。

Required | true
Position | 1
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトを Test-BEBackupExecServerOnDeduplicationDiskStorageDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEDeviceValidationResult

Test-BEBackupExecServerOnCloudStorageDevice は Backup Exec サーバーと重複排除ディスクストレージデバイスとの間の通信をテストするオブジェクトを返します。

Example

C:\PS> $Device = Get-BEDeduplicationDiskStorageDevice -Name "Deduplication Device"
C:\PS> Get-BEBackupExecServer | Test-BEBackupExecServerOnDeduplicationDiskStorageDevice -DeduplicationDiskStorageDevice $Device

このコマンドは Backup Exec サーバーが重複排除ディスクストレージデバイスにアクセスするために使用するクレデンシャルをテストします。

Related Links


Test-BEBackupExecServerOnNdmpServer Help

Test-BEBackupExecServerOnNdmpServer Cmdlet
Synopsis

Backup Exec が NDMP サーバーにアクセスするために使用するクレデンシャルをテストします。

Syntax
Test-BEBackupExecServerOnNdmpServer [-BackupExecServer] <BEBackupExecServer> [-NdmpServer] <BENdmpServer> [<CommonParameters>]
Description

Backup Exec が NDMP サーバーにアクセスするために使用するクレデンシャルをテストします。

Parameters

-NdmpServer <BENdmpServer>

テストする NDMP サーバーを指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

NDMP サーバーにアクセスする Backup Exec サーバーを指定します

Required | true
Position | 1
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトを Test-BEBackupExecServerOnNdmpServer にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEDeviceValidationResult

Test-BEBackupExecServerOnNdmpServer は Backup Exec サーバーと NDMP サーバーとの間の通信をテストするオブジェクトを返します。

Example

C:\PS> $Device = Get-BENdmpServer -Name "NDMP Server"
C:\PS> Get-BEBackupExecServer | Test-BEBackupExecServerOnNdmpServer -NdmpServer $Device

このコマンドは Backup Exec サーバーが NDMP サーバーにアクセスするために使用するクレデンシャルをテストします。

Related Links


Test-BEBackupExecServerOnOpenStorageDevice Help

Test-BEBackupExecServerOnOpenStorageDevice Cmdlet
Synopsis

Backup Exec が OpenStorage デバイスにアクセスするために使用するクレデンシャルをテストします。

Syntax
Test-BEBackupExecServerOnOpenStorageDevice [-BackupExecServer] <BEBackupExecServer> [-OpenStorageDevice] <BEOpenStorageDevice> [<CommonParameters>]
Description

Backup Exec が OpenStorage デバイスにアクセスするために使用するクレデンシャルをテストします。

Parameters

-OpenStorageDevice <BEOpenStorageDevice>

テストする OpenStorage デバイスを指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

OpenStorage デバイスにアクセスする Backup Exec サーバーを指定します。

Required | true
Position | 1
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトを Test-BEBackupExecServerOnOpenStorageDevice にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEDeviceValidationResult

Test-BEBackupExecServerOnOpenStorageDevice は Backup Exec サーバーと OpenStorage デバイスとの間の通信をテストするオブジェクトを返します。

Example

C:\PS> $Device = Get-BEOpenStorageDevice -Name "Open Storage Device"
C:\PS> Get-BEBackupExecServer | Test-BEBackupExecServerOnOpenStorageDevice -OpenStorageDevice $Device

このコマンドは Backup Exec サーバーが OpenStorage デバイスにアクセスするために使用するクレデンシャルをテストします。

Related Links


Test-BEBackupExecServerOnRemoteMediaAgentForLinux Help

Test-BEBackupExecServerOnRemoteMediaAgentForLinux Cmdlet
Synopsis

Backup Exec が Remote Media Agent For Linux にアクセスするために使用するクレデンシャルをテストします。

Syntax
Test-BEBackupExecServerOnRemoteMediaAgentForLinux [-BackupExecServer] <BEBackupExecServer> [-RemoteMediaAgentForLinux] <BERemoteMediaAgentForLinux> [<CommonParameters>]
Description

Backup Exec が Remote Media Agent For Linux にアクセスするために使用するクレデンシャルをテストします。

Parameters

-RemoteMediaAgentForLinux <BERemoteMediaAgentForLinux>

テストする Remote Media Agent For Linux を指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

Remote Media Agent for Linux にアクセスする Backup Exec サーバーを指定します。

Required | true
Position | 1
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupExecServer

Backup Exec サーバーオブジェクトを Test-BEBackupExecServerOnRemoteMediaAgentForLinux にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEDeviceValidationResult

Test-BEBackupExecServerOnRemoteMediaAgentForLinux は Backup Exec サーバーと Remote Media Agent for Linux との間の通信をテストするオブジェクトを返します。

Example

C:\PS> $Device = Get-BERemoteMediaAgentForLinux -Name "Remote Media Agent For Linux"
C:\PS> Get-BEBackupExecServer | Test-BEBackupExecServerOnRemoteMediaAgentForLinux -RemoteMediaAgentForLinux $Device

このコマンドは Backup Exec が Remote Media Agent For Linux にアクセスするために使用するクレデンシャルをテストします。

Related Links


Test-BELogonAccount Help

Test-BELogonAccount Cmdlet
Synopsis

エージェントサーバーまたはバックアップソースに割り当てられた Backup Exec ログオンアカウントをテストします。

Syntax
Test-BELogonAccount [-AgentServer] <BEAgentServer> [<CommonParameters>]

Test-BELogonAccount [-AgentServer] <BEAgentServer> [-LogonAccount] <BELogonAccount> [<CommonParameters>]

Test-BELogonAccount [-AgentServerBackupSource] <BEAgentServerBackupSource> [<CommonParameters>]

Test-BELogonAccount [-StorageDevice] <BEStorageDevice> [-LogonAccount] <BELogonAccount> [<CommonParameters>]
Description

エージェントサーバーまたはバックアップソースに割り当てられた Backup Exec ログオンアカウントをテストします。

Parameters

-AgentServer <BEAgentServer>

ログオンアカウントをテストするエージェントサーバーを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-AgentServerBackupSource <BEAgentServerBackupSource>

ログオンアカウントをテストするバックアップソースを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-StorageDevice <BEStorageDevice>

ストレージデバイスを指定して、指定したログオンアカウントでテストを実行します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-LogonAccount <BELogonAccount>

テストを実行するログオンアカウントを指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEAgentServer

Backup Exec エージェントサーバーオブジェクトを Test-BELogonAccount にパイプ処理できます。

BackupExec.Management.CLI.BEAgentServerBackupSource

Backup Exec エージェントサーバーのバックアップソースを Test-BELogonAccount にパイプ処理できます。

BackupExec.Management.CLI.BEStorageDevice

Backup Exec ストレージデバイスを Test-BELogonAccount にパイプ処理できます。

Return Values
BackupExec.Management.CLI.BEAgentServer

Test-BELogonAccount は、Backup Exec エージェントサーバーオブジェクトを返します。

BackupExec.Management.CLI.BEAgentServerBackupSource

Test-BELogonAccount は Backup Exec エージェントサーバーのバックアップソースオブジェクトを返します。

BackupExec.Management.CLI.BEStorageDevice

Test-BELogonAccount は、Backup Exec ストレージデバイスを表すオブジェクトを返します。

Examples

Example 1

C:\PS> Get-BEAgentServer myserver.mycompany.com | Test-BELogonAccount

これらのコマンドは、「myserver.mycompany.com」という名前のエージェントサーバーのログオンアカウントをテストします。

Example 2
C:\PS> Get-BEAgentServer myserver.mycompany.com | Get-BEAgentServerBackupSource C: | Test-BELogonAccount

これらのコマンドは、「myserver.mycompany.com」という名前のエージェントサーバーの C: ボリュームのログオンアカウントをテストします。

Example 3
C:\PS> Get-BEAgentServer myserver.mycompany.com | Test-BELogonAccount myserver_logon

これらのコマンドは「myserver.mycompany.com」という名前のエージェントサーバーのログオンアカウント「myserver_logon」をテストします。

Example 4
C:\PS> Get-BEStorageDevice Dedupe | Test-BELogonAccount -LogonAccount Dedupe

これらのコマンドは「Dedupe」という名前のストレージデバイスのログオンアカウント「Dedupe」をテストします。

Related Links


Update-BEWindowsAgentServer Help

Update-BEWindowsAgentServer Cmdlet
Synopsis

リモートコンピュータの Backup Exec Agent for Windows を更新します。

Syntax
Update-BEWindowsAgentServer [-InputObject] <BEAgentServer[]> [[-RunOn] <DateTime>] [[-Schedule] <BESchedule>] [-RestartAutomaticallyIfNecessary <SwitchParameter>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Update-BEWindowsAgentServer [-Name] <String[]> [[-RunOn] <DateTime>] [[-Schedule] <BESchedule>] [-RestartAutomaticallyIfNecessary <SwitchParameter>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]

Update-BEWindowsAgentServer [-VMwareAgentServerVM] <BEVMwareAgentServerVM[]> [[-RunOn] <DateTime>] [[-Schedule] <BESchedule>] [-RestartAutomaticallyIfNecessary <SwitchParameter>] [-Confirm <SwitchParameter>] [-WhatIf <SwitchParameter>] [<CommonParameters>]
Description

リモートコンピュータの Backup Exec Agent for Windows を更新します。

Parameters

-InputObject <BEAgentServer[]>

更新する Backup Exec Agent for Windows を指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-RunOn <DateTime>

実行するジョブの日付と時刻を指定します。

Required | false
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-Schedule <BESchedule>

ジョブを実行する時刻と頻度を指定します。 New-BESchedule を参照してください。

Required | false
Position | 2
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String[]>

更新する Agent for Windows の名前を指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | true

-VMwareAgentServerVM <BEVMwareAgentServerVM[]>

Agent for Windows を更新する VMware 仮想マシンを指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RestartAutomaticallyIfNecessary <SwitchParameter>

再起動が必要な場合は、コンピュータを自動的に再起動します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
System.String

更新するコンピュータの名前を含む文字列を Update-BEWindowsAgentServer にパイプ処理できます。

BackupExec.Management.CLI.BEAgentServer

>Backup Exec エージェントサーバーの更新を Update-BEWindowsAgentServer にパイプ処理できます。

BackupExec.Management.CLI.BEVMwareAgentServerVM

更新する Backup Exec VMware 仮想マシンを Update-BEWindowsAgentServer にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEJob

Update-BEWindowsAgentServer は Backup Exec の更新ジョブを表すオブジェクトを返します。

Examples

Example 1

C:\PS> $AgentServer = Get-BEAgentServer -Name "Raws-01.MyDomain.com"
C:\PS> $AgentServer | Update-BEWindowsAgentServer | Wait-BEJob

このコマンドは「Raws-01.MyDomain.com」という名前の Agent for Windows リモートコンピュータを更新します。

Example 2
C:\PS> $AgentServer = Get-BEAgentServer -Name "My-VMWare-Server.MyDomain.com"
C:\PS> $VMAgentServerVM = $AgentServer | Get-BEVMwareAgentServerVM -Path 'My-VMWare-Server\Production_Servers\TargetVM'
C:\PS> $VMAgentServerVM | Update-BEWindowsAgentServer | Wait-BEJob

このコマンドは「TargetVM」という名前の VMware 仮想マシンを更新します。

Related Links


Use-BERestrictedLogonAccount Help

Use-BERestrictedLogonAccount Cmdlet
Synopsis

現在のユーザーに、別のユーザーが所有する所有者専用ログオンアカウントの使用を許可します。

Syntax
Use-BERestrictedLogonAccount [-LogonAccount] <BELogonAccount> [-CurrentPassword] <SecureString> [<CommonParameters>]
Description

現在のユーザーに、別のユーザーが所有する所有者専用ログオンアカウントの使用を許可します。

Parameters

-LogonAccount <BELogonAccount>

使用する所有者専用ログオンアカウントの名前を指定します。

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-CurrentPassword <SecureString>

所有者専用ログオンアカウントのパスワードを指定します。

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BELogonAccount

Backup Exec ログオンアカウントオブジェクトを Use-BERestrictedLogonAccount にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BELogonAccount

ユーザーが現在アクセス権限を持っているログオンアカウント。

Example

C:\PS> $password = Read-Host -AsSecureString
C:\PS> Get-BELogonAccount "Logon Account 01" | Use-BERestrictedLogonAccount -CurrentPassword $password

これらのコマンドは、現在のユーザーに、「Logon Account 01」という名前の所有者専用ログオンアカウントへのアクセス権限を付与します。

Related Link

Get-BELogonAccount


Wait-BEJob Help

Wait-BEJob Cmdlet
Synopsis

Backup Exec のジョブが完了するのを待機します。

Syntax
Wait-BEJob -InputObject <BEJob[]> [-Any <SwitchParameter>] [-TimeoutSeconds <Int32>] [-WhatIf <SwitchParameter>] [-Confirm <SwitchParameter>] [<CommonParameters>]
Description

Backup Exec のジョブが完了するのを待機します。

Wait-BEJob は、完了したジョブに関連付けられているジョブ履歴を返します。

-TimeoutSeconds パラメータを指定しない場合、Wait-BEJob は指定したジョブが完了するのを無期限に待機します。接続が中断された場合、Wait-BEJob は終了します。適切なジョブステータスを取得するには、Get-BEJob コマンドレットを数分おきに実行することをお勧めします。

-TimeoutSeconds パラメータを指定し、ジョブが完了する前に設定した時間が経過した場合、ジョブが実行中であってもこのコマンドは戻ります。 エラーメッセージは表示されません。

Parameters

-Any <SwitchParameter>

複数のジョブが完了するのを待機している場合、いずれかのジョブが完了した後で Wait-BEJob が戻るように指定します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TimeoutSeconds <Int32>

各ジョブについて待機する最大時間を秒単位で決定します。 ジョブが完了する前にこの時間が経過した場合、ジョブが実行中であってもこのコマンドは戻ります。 エラーメッセージは表示されません。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEJob[]>

1 つ以上のジョブオブジェクトを指定します。 オブジェクトを含む変数を入力するか、オブジェクトを取得するコマンドまたは式を入力します。

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

コマンドを実際に実行する前に、そのコマンドで実行される内容を示します。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

コマンドの実行前に確認を求めるメッセージが表示されます。

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEJob

Backup Exec ジョブオブジェクトを Wait-BEJob にパイプ処理できます。

Return Value
BackupExec.Management.CLI.BEJobHistory

Wait-BEJob は、-TimeoutSeconds 時間が経過していない場合、Backup Exec ジョブ履歴オブジェクトを返します。この時間が経過した場合は何も返しせん。

Examples

Example 1

C:\PS> Get-BEJob "Job 0001" | Wait-BEJob

これらのコマンドは「Job 0001」という名前のジョブが完了するのを待機します。

Example 2
C:\PS> Get-BEAgentServer myserver.mycompany.com | Submit-BEOnetimeBackupJob | Wait-BEJob

これらのコマンドは、「myserver.mycompany.com」という名前のサーバーをバックアップするワンタイムバックアップをサブミットして、ジョブが完了するまで待機します。

Related Links