EUR 帳票出力 機能解説 EUR Server編

  • 目次

  • 索引

  • 前へ

  • 1 / 218

  • 次へ

EUR 帳票出力 機能解説 EUR Server編

3021-7-006-40

目次ダイジェスト

  • 前書き

  • 変更内容

  • はじめに

  • 第1編　EUR Serverの概要

    • 1.　EUR Serverとは

  • 第2編　EUR Serverを使用した帳票出力

    • 2.　帳票出力の概要

    • 3.　出力先を選んで出力する

    • 4.　ファイル形式を選んで出力する

    • 5.　スプールデータを出力するには

    • 6.　仕分け・分割・統合して出力する

    • 7.　帳票を配送印刷する

    • 8.　監視フォルダに格納したデータファイルを自動的に出力する

    • 9.　BSP-RMで生成されたデータファイルを出力する

    • 10.　個人番号管理サービスと連携して個人番号を含む帳票を出力する

  • 第3編　帳票の出力内容の設定

    • 11.　レイアウトやデータを設定する

    • 12.　属性情報を設定する

  • 第4編　帳票の管理

    • 13.　スプールデータを管理するには

    • 14.　監査ログを出力する

  • 付録

  • 索引

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 1 / 218

  • 次へ

  • 商品名称に関する表示

  • マニュアル発行元

All Rights Reserved. Copyright (C) 2014, 2017, Hitachi, Ltd.

All Rights Reserved. Copyright (C) 2014, 2017, Hitachi Solutions, Ltd.


前書き : EUR 帳票出力 機能解説 EUR Server編

  • 3 / 218

  • 次へ

  • 表紙

  • 前書き

前書き

■ 対象製品

●適用OS：Windows 7 x86，Windows 7 x64※1，Windows 8.1 x86※2，Windows 8.1 x64※1※2，Windows 10 x86※2，Windows 10 x64※1※2

  • P-2CD2-56A4 EUR Designer 10-40

  • P-2CD2-5DA4 EUR Developer※3 10-40

  • P-2CD2-53A4 EUR Viewer 10-40

●適用OS：Windows Server 2008，Windows Server 2012

  • P-29D2-59A4 EUR Server Standard※4 10-40

  • P-29D2-5EA4 EUR Server Enterprise※4 10-40

  • P-29D2-5CA4 EUR Server - Cipher option 10-30

●適用OS：HP-UX 11i V3(IPF)

  • P-1JD2-59A1 EUR Server Standard 10-10

  • P-1JD2-5EA1 EUR Server Enterprise 10-10

  • P-1JD2-5CA1 EUR Server - Cipher option 10-00

●適用OS：AIX V6.1，AIX V7.1，AIX V7.2

  • P-1MD2-59A1 EUR Server Standard 10-10

  • P-1MD2-5EA1 EUR Server Enterprise 10-10

  • P-1MD2-5CA1 EUR Server - Cipher option 10-00

●適用OS：Linux 6，Linux 7

  • P-82D2-59A1 EUR Server Standard 10-10

  • P-82D2-5EA1 EUR Server Enterprise 10-10

  • P-82D2-5CA1 EUR Server - Cipher option 10-00

注※1

    WOW64（Windows On Windows 64）環境だけで使用できます。

注※2

    Modern UIには対応していません。

注※3

    次に示す製品を同梱しています。

    ・P-2463-2354　　DABroker

注※4

    次に示す製品を同梱しています。

    ・P-2963-2354　　DABroker(64)

これらの製品は，ISO9001およびTickITの認証を受けた品質マネジメントシステムで開発されました。

■ 輸出時の注意

本製品を輸出される場合には、外国為替及び外国貿易法の規制並びに米国輸出管理規則など外国の輸出関連法規をご確認の上、必要な手続きをお取りください。

なお、不明な場合は、弊社担当営業にお問い合わせください。

■ 商標類

HITACHI，DABroker，DBPARTNER，EUR，Groupmax，HiRDB，JP1，SEWB，TPBroker，uCosminexusは，株式会社 日立製作所の商標または登録商標です。

ActiveXは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

IBM，AIXは，世界の多くの国で登録されたInternational Business Machines Corporationの商標です。

Internet Explorerは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

Itaniumは，アメリカ合衆国および / またはその他の国におけるIntel Corporationの商標です。

Linuxは，Linus Torvalds氏の日本およびその他の国における登録商標または商標です。

MicrosoftおよびMS-DOSは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

MicrosoftおよびSQL Serverは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

MicrosoftおよびVisual Basicは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

MicrosoftおよびVisual C++は，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

Microsoft .NET は，お客様，情報，システムおよびデバイスを繋ぐソフトウェアです。

Microsoft OfficeおよびExcelは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

Microsoft Office Wordは，米国Microsoft Corporation の商品名称です。

ODBCは，米国Microsoft Corporationが提唱するデータベースアクセス機構です。

OLEは，米国Microsoft Corporationが開発したソフトウェア名称です。

OracleとJavaは，Oracle Corporation 及びその子会社，関連会社の米国及びその他の国における登録商標です。

PostScriptは，米国でのAdobe Systems, Inc.の商標です。

Red Hatは，米国およびその他の国でRed Hat, Inc.の登録商標もしくは商標です。

RSAおよびBSAFEは，米国EMC コーポレーションの米国およびその他の国における商標または登録商標です。

UNIXは，The Open Groupの米国ならびに他の国における登録商標です。

Windowsは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

Windows Serverは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

本製品は，米国EMC コーポレーションのRSA BSAFE(R)ソフトウェアを搭載しています。

This product includes software developed by the Apache Software Foundation (http://www.apache.org/).

This product includes software developed by Ben Laurie for use in the Apache-SSL HTTP server project.

Portions of this software were developed at the National Center for Supercomputing Applications (NCSA) at the University of Illinois at Urbana-Champaign.

This product includes software developed by the University of California, Berkeley and its contributors.

This software contains code derived from the RSA Data Security Inc. MD5 Message-Digest Algorithm, including various modifications by Spyglass Inc., Carnegie Mellon University, and Bell Communications Research, Inc (Bellcore).

Regular expression support is provided by the PCRE library package, which is open source software, written by Philip Hazel, and copyright by the University of Cambridge, England. The original software is available from ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/

This product includes software developed by Ralf S. Engelschall <rse@engelschall.com> for use in the mod_ssl project (http://www.modssl.org/).

This product includes software developed by IAIK of Graz University of Technology.

This product includes software developed by Daisuke Okajima and Kohsuke Kawaguchi (http://relaxngcc.sf.net/).

This product includes software developed by the Java Apache Project for use in the Apache JServ servlet engine project (http://java.apache.org/).

This product includes software developed by Andy Clark.

その他記載の会社名，製品名は，それぞれの会社の商標もしくは登録商標です。

■ マイクロソフト製品のスクリーンショットの使用について

マイクロソフトの許可を得て使用しています。

■ マイクロソフト製品の表記について

このマニュアルでは，マイクロソフト製品の名称を次のように表記しています。

表記 |  |  | 製品名称
.NET |  |  | Microsoft(R) .NET
ActiveX |  |  | ActiveX(R)
Excel |  |  | Microsoft(R) Office Excel 2007 Microsoft(R) Office Excel 2010 Microsoft(R) Office Excel 2013
Internet Explorer |  |  | Windows(R) Internet Explorer(R)
SQL Server |  |  | Microsoft(R) SQL Server 2008 Microsoft(R) SQL Server 2008 R2 Microsoft(R) SQL Server 2012
VBScript |  |  | Microsoft(R) Visual Basic(R) Scripting Edition
Visual Basic |  |  | Microsoft(R) Visual Basic(R)
Visual C++ |  |  | Microsoft(R) Visual C++(R)
Windows | Windows 7 | Windows 7 x86 | Microsoft(R) Windows(R) 7 Professional(32ビット版) Microsoft(R) Windows(R) 7 Enterprise(32ビット版) Microsoft(R) Windows(R) 7 Ultimate(32ビット版)
 |  | Windows 7 x64 | Microsoft(R) Windows(R) 7 Professional(64ビット版) Microsoft(R) Windows(R) 7 Enterprise(64ビット版) Microsoft(R) Windows(R) 7 Ultimate(64ビット版)
 | Windows 8 | Windows 8 x86 | Windows(R) 8 Pro(32ビット版) Windows(R) 8 Enterprise(32ビット版)
 |  | Windows 8 x64 | Windows(R) 8 Pro(64ビット版) Windows(R) 8 Enterprise(64ビット版)
 | Windows 8.1 | Windows 8.1 x86 | Windows(R) 8.1 Pro(32ビット版) Windows(R) 8.1 Enterprise(32ビット版)
 |  | Windows 8.1 x64 | Windows(R) 8.1 Pro(64ビット版) Windows(R) 8.1 Enterprise(64ビット版)
 | Windows 10 | Windows 10 x86 | Windows(R) 10 Pro(32ビット版) Windows(R) 10 Enterprise(32ビット版)
 |  | Windows 10 x64 | Windows(R) 10 Pro(64ビット版) Windows(R) 10 Enterprise(64ビット版)
 | Windows Server 2008 |  | Microsoft(R) Windows Server(R) 2008 R2 Standard Microsoft(R) Windows Server(R) 2008 R2 Enterprise Microsoft(R) Windows Server(R) 2008 R2 Datacenter
 | Windows Server 2012 |  | Microsoft(R) Windows Server(R) 2012 Standard Microsoft(R) Windows Server(R) 2012 Datacenter Microsoft(R) Windows Server(R) 2012 R2 Standard Microsoft(R) Windows Server(R) 2012 R2 Datacenter
Word |  |  | Microsoft(R) Office Word 2007 Microsoft(R) Office Word 2010 Microsoft(R) Office Word 2013

■ 発行

2017年3月　3021-7-006-40

■ 著作権

All Rights Reserved. Copyright (C) 2014, 2017, Hitachi, Ltd.

All Rights Reserved. Copyright (C) 2014, 2017, Hitachi Solutions, Ltd.

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 3 / 218


変更内容 : EUR 帳票出力 機能解説 EUR Server編

  • 4 / 218

  • 表紙

  • 変更内容

変更内容

変更内容（3021-7-006-40）

EUR Designer　10-40

EUR Developer　10-40

EUR Viewer　10-40

EUR Server Standard　10-40

EUR Server Enterprise　10-40

追加・変更内容

変更個所

EUR Server Standard，EUR Server Enterpriseの適用OSに次のOSを追加しました。

  • AIX V7.2

  • Linux 7

－

EUR Server - Adapterの起動部品で，分割ページ数を指定してPDF形式ファイルを分割出力する機能を追加しました。

1.1.2，4.1，4.1.1，4.1.2，5.3.5(2)，6.2，6.2.1，6.2.2

単一様式帳票，または帳票セットの複数指定の帳票の出力で，常に用紙の表面に出力する対象の帳票ファイルを指定する機能を追加しました。

2.3.1，2.5，2.7.1，11.6，付録A

EUR 帳票作成機能の文字アイテムで下線を描画する機能を追加しました。

4.3.6(1)，付録B.1(2)，付録B.1(2)(d)

Excel形式ファイルを出力するときの注意事項に，UNIX／Linux環境の場合の注意事項を追加しました。

4.3.6(4)

EUR Designer，EUR Developer，EUR Viewerの適用OSからWindows 8を除外しました。

5.4.3(3)(a)，13.1.10(1)

PDF仕分け出力の注意事項を追加しました。

6.1.5

統合出力したスプールデータを印刷する場合に使用する起動部品の説明を追加しました。

6.3.2(3)(b)

個人番号管理サービス連携機能の事前準備の説明を変更，追加しました。

10.1.1

帳票GUIの前提プログラムからInternet Explorer 8を除外しました。

13.1.10(4)
（凡例）

－：該当なし

単なる誤字・脱字などはお断りなく訂正しました。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 4 / 218


はじめに : EUR 帳票出力 機能解説 EUR Server編

  • 5 / 218

  • 表紙

  • はじめに

はじめに

このマニュアルは，EUR 帳票作成機能で設計した帳票を，次に示すプログラムプロダクトを使用して帳票出力する方法について説明したものです。

  • EUR Server Standard

  • EUR Server Enterprise

  • EUR Server - Cipher option

〈はじめにの構成〉

  • 対象読者

  • このマニュアルの文法で使用する記号

  • このマニュアルのGUIの説明で使用する記号

■ 対象読者

このマニュアルは，EUR サーバ帳票出力機能を使って帳票を出力する方を対象としています。なお，次の内容を理解されていることを前提としています。

  • 使用するOSに関する基本的な知識

ページの先頭へ

■ このマニュアルの文法で使用する記号

このマニュアルで使用する記号について，次に示します。

記　号

意　　味

｜

横に並べられた複数の項目に対する項目間の区切りを示し，「または」を意味します。

（例）A｜B

「A，またはBを指定する」ことを示します。

｛　｝

この記号で囲まれている複数の項目のうちから一つを選択することを示します。項目が横に並べられ，記号｜で区切られている場合は，そのうちの一つを選択します。

（例）｛A｜B｜C｝

「A，B，またはCのどれかを指定する」ことを示します。

〔　〕

この記号で囲まれている項目は省略してもよいことを示します。複数の項目が横に並べて記述されている場合には，すべてを省略するか，記号｛　｝と同じくどれか一つを選択します。

（例）〔A〕

「何も指定しない」か「Aと指定する」ことを示します。

（例）〔B｜C〕

「何も指定しない」か「B，またはCのどちらかを指定する」ことを示します。

…

記述が省略されていることを示します。この記号の直前に示された項目を繰り返し複数個指定できます。

（例）〔A〔,…〕〕

「Aのあとに，Aを複数個指定できる」ことを示します。

＿

括弧で囲まれた複数項目のうち1項目に対し使用され，括弧内のすべてを省略したときシステムが採る標準値を示します。

（例）〔A｜B｜C〕

「A，B，Cのどれも指定しなかった場合，システムはCが指定されたときと同じ処理をする」ことを示します。

ページの先頭へ

■ このマニュアルのGUIの説明で使用する記号

このマニュアルでは，次に示す記号を使用してGUIを説明しています。

記　号

意　　味

＜　＞

文字キーを表します。

＜　＞＋＜　＞

＋の前のキーを押したまま，後ろのキーを押すことを表します。

［　］

メニュー項目，ダイアログ名，ダイアログのボタンを表します。

［　］－［　］

メニュー項目を連続して選択することを表します。

（例）［ファイル］－［開く］

［ファイル］メニューから［開く］メニューを選択することを表します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 5 / 218


1. EUR Serverとは : EUR 帳票出力 機能解説 EUR Server編

  • 6 / 218

  • 表紙

  • 1.　EUR Serverとは

1.　EUR Serverとは

この章では，EUR Serverの特長や製品構成などのEUR Serverの概要について説明します。

〈この章の構成〉

  • 1.1　EUR Serverの特長

  • 1.2　製品構成

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 6 / 218


1.1 EUR Serverの特長 : EUR 帳票出力 機能解説 EUR Server編

  • 7 / 218

  • 表紙

  • 1.　EUR Serverとは

  • 1.1　EUR Serverの特長

1.1　EUR Serverの特長

EUR Serverは，EUR 帳票作成機能で設計した帳票ファイルと，帳票出力に必要なデータファイルから，帳票を出力するための製品です。ここでは，EUR Serverの特長について説明します。

〈この節の構成〉

  • 1.1.1　柔軟な帳票出力環境を構築できます

  • 1.1.2　さまざまなファイル形式で出力できます

  • 1.1.3　きめ細かな出力設定が簡単にできます

  • 1.1.4　英語環境用のインタフェースを提供しています

  • 1.1.5　業務プログラムと連携できます

  • 1.1.6　データファイルを監視して自動的に帳票出力できます

  • 1.1.7　帳票管理システム「BSP-RM」と連携できます

  • 1.1.8　個人番号管理サービスと連携できます

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 7 / 218


1.1.1 柔軟な帳票出力環境を構築できます : EUR 帳票出力 機能解説 EUR Server編

  • 8 / 218

  • 表紙

  • 1.　EUR Serverとは

  • 1.1　EUR Serverの特長

  • 1.1.1　柔軟な帳票出力環境を構築できます

1.1.1　柔軟な帳票出力環境を構築できます

帳票の出力方法や出力先に合わせてEUR Serverの各コンポーネントを配置することで，帳票システムの目的に応じた柔軟な帳票出力環境を構築できます。

帳票の出力方法には，バッチによる自動出力，Webブラウザを使用したオンライン出力，出力指示とは別に任意のタイミングで印刷する非同期印刷などがあります。また，帳票の出力先は，利用目的に応じて任意に選択できます。帳票サーバのプリンタに直接出力するだけでなく，分散拠点に配置されたサーバ（スプールサーバ）やクライアントPCに帳票を配信して出力できます。

■参考

帳票システムの負荷分散のために，業務システムが稼働するサーバと帳票サーバを分離したり，帳票サーバを複数台構成にしたりすることもできます。帳票システムの負荷分散については，マニュアル「EUR システム設計ガイド」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 8 / 218


1.1.2 さまざまなファイル形式で出力できます : EUR 帳票出力 機能解説 EUR Server編

  • 9 / 218

  • 表紙

  • 1.　EUR Serverとは

  • 1.1　EUR Serverの特長

  • 1.1.2　さまざまなファイル形式で出力できます

1.1.2　さまざまなファイル形式で出力できます

EUR Serverでは，さまざまなファイル形式で帳票を出力できます。EUR Serverで出力できるファイル形式を次に示します。

  • EPF形式

    スプールサーバやクライアントPCに帳票を配信したり，Webブラウザを使用してクライアントPCで帳票を出力したりするときのファイル形式です。

    使用できる出力方法を次に示します。

    • 帳票をスプールサーバのプリンタに出力する（参照先：3.1.2）

    • 帳票をクライアントPCのプリンタに出力する（参照先：3.2）

    • 帳票をクライアントPCでプレビューする（参照先：3.3）

    • 帳票のスプールデータを出力する（参照先：5章）

    • 帳票を蓄積仕分け出力する（参照先：6.1.3）

    • 帳票を蓄積分割出力する（参照先：6.2.3）

    • 複数の帳票を統合して出力する（参照先：6.3）

  • EUR形式

    分散拠点に配置されているEUR Serverと連携して帳票を出力したり，クライアントPCのEUR Viewerを使用して帳票を出力したりするときのファイル形式です。

    使用できる出力方法を次に示します。

    • 分散拠点のEUR Serverと連携して帳票を出力する（参照先：3.1.3）

    • EUR形式ファイルの帳票を出力する（参照先：4.2）

  • PDF形式

    Adobe Readerを使用して，クライアントPCで帳票を表示，および出力するときのファイル形式です。

    使用できる出力方法を次に示します。

    • PDF形式ファイルの帳票を出力する（参照先：4.1）

    • 帳票のスプールデータを出力する（参照先：5章）

    • 帳票をPDF仕分け出力する（参照先：6.1.1）

    • 帳票をPDF暗号化仕分け出力する（参照先：6.1.2）

    • 帳票をPDF分割出力する（参照先：6.2.1）

    • 帳票をPDF暗号化分割出力する（参照先：6.2.2）

  • Excel形式

    Excelを使用して，クライアントPCで帳票を表示，および出力するときのファイル形式です。二次加工をすることもできます。

    使用できる出力方法を次に示します。

    • Excel形式ファイルの帳票を出力する（参照先：4.3）

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 9 / 218


1.1.3 きめ細かな出力設定が簡単にできます : EUR 帳票出力 機能解説 EUR Server編

  • 10 / 218

  • 表紙

  • 1.　EUR Serverとは

  • 1.1　EUR Serverの特長

  • 1.1.3　きめ細かな出力設定が簡単にできます

1.1.3　きめ細かな出力設定が簡単にできます

EUR Serverでは，帳票の出力内容や出力時の動作を入力ファイルや設定ファイル，インタフェースの指定値などで制御しています。出力内容に合わせて，指定するファイルを追加，変更したり，指定する値の組み合わせをあらかじめEUR Serverに定義したりしておくことで，きめ細かな出力設定が簡単にできます。

例えば，帳票を出力するサーバや，帳票を出力するプリンタとトレイの組み合わせ（プリンタクラス）は，次の図に示すように画面で定義できます。

図1‒1　帳票の出力先を画面で定義する例

[図データ]

なお，帳票出力で使用するファイルには，大きく分けて次の5種類があります。詳細については「付録A　帳票出力で使用するファイルの種類」を参照してください。

  • 印刷定義ファイル

  • ユーザデータファイル

  • 構成定義ファイル

  • 環境設定ファイル

  • そのほかのファイル

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 10 / 218


1.1.4 英語環境用のインタフェースを提供しています : EUR 帳票出力 機能解説 EUR Server編

  • 11 / 218

  • 表紙

  • 1.　EUR Serverとは

  • 1.1　EUR Serverの特長

  • 1.1.4　英語環境用のインタフェースを提供しています

1.1.4　英語環境用のインタフェースを提供しています

EUR Serverでは，日本語だけでなく，英語環境用のインタフェースを提供しています。ユーザがEUR Serverを使用する環境（ロケール）によって，インタフェースが自動で切り替わるため，企業の海外拠点など，主に英語を使用する環境でEUR Serverを利用する場合に便利です。

英語環境への対応状況を，コンポーネントごとに次の表に示します。

表1‒1 英語環境への対応状況
コンポーネント | GUI | メッセージ
EUR Server Service | ○ | ○
EUR Server - Adapter | － | ○
EUR Server - Spool Service（帳票管理GUI以外） | ○ | ○
EUR Server - Spool Service（帳票管理GUI） | × | ×
EUR Server - Spool Service Adapter | － | ○
EUR Client Service | ○ | ○
EUR Web Plug-In | ○ | ○
BSP-RM連携コマンド（eursmprコマンド） | － | ○
ファイル監視サービス | － | ○
（凡例）

○：英語環境に対応しています。

×：英語環境に対応していません。

－：GUIはありません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 11 / 218


1.1.5 業務プログラムと連携できます : EUR 帳票出力 機能解説 EUR Server編

  • 12 / 218

  • 表紙

  • 1.　EUR Serverとは

  • 1.1　EUR Serverの特長

  • 1.1.5　業務プログラムと連携できます

1.1.5　業務プログラムと連携できます

EUR Serverと業務プログラムとを連携させることで，ユーザの開発環境に合わせた帳票出力ができます。

業務プログラムと連携して帳票の出力や操作をするために，EUR Serverでは次に示すインタフェースを提供しています。

  • ActiveX起動部品，SS-ActiveX起動部品

    IISサーバのVBScript，Visual Basic，Visual Basic .NET，ASP.NETなどのプログラムからEUR Serverを起動して，帳票の出力や操作をする場合に使用します。

  • Java起動部品，SS-Java起動部品

    JSPやJavaサーブレットからEUR Serverを起動して，帳票の出力や操作をする場合に使用します。アプリケーションと同期を取って出力処理を実行できます。

  • COBOL起動部品

    COBOLプログラムからEUR Serverを起動して，帳票の出力をする場合に使用します。

  • コマンド起動部品（eurpmcコマンド），SS-コマンド起動部品（eurpmlscコマンド）

    サーバ側で動作する業務プログラムからEUR Serverを起動して，帳票の出力や操作をする場合に使用します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 12 / 218


1.1.6 データファイルを監視して自動的に帳票出力できます : EUR 帳票出力 機能解説 EUR Server編

  • 13 / 218

  • 表紙

  • 1.　EUR Serverとは

  • 1.1　EUR Serverの特長

  • 1.1.6　データファイルを監視して自動的に帳票出力できます

1.1.6　データファイルを監視して自動的に帳票出力できます

ファイル監視サービスを使用することにより，業務プログラムから出力されたデータファイルを特定のフォルダに格納するだけで，自動的にEUR Serverで帳票出力できます。

運用形態に応じて，業務プログラムが出力したデータファイルそのものを監視する事前定義型と，データファイルに帳票出力のための制御情報を付加したファイルを監視する上位主導型のどちらかの方式を選択できます。

事前定義型の方式では，新たにプログラムを開発することなく自動的に帳票出力できます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 13 / 218


1.1.7 帳票管理システム「BSP-RM」と連携できます : EUR 帳票出力 機能解説 EUR Server編

  • 14 / 218

  • 表紙

  • 1.　EUR Serverとは

  • 1.1　EUR Serverの特長

  • 1.1.7　帳票管理システム「BSP-RM」と連携できます

1.1.7　帳票管理システム「BSP-RM」と連携できます

帳票管理システム「BSP-RM」と連携し，BSP-RM連携コマンド（eursmprコマンド）を使用して，「BSP-RM」で管理しているデータファイルをEURのサーバ環境で帳票の印刷やファイル出力ができます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 14 / 218


1.1.8 個人番号管理サービスと連携できます : EUR 帳票出力 機能解説 EUR Server編

  • 15 / 218

  • 表紙

  • 1.　EUR Serverとは

  • 1.1　EUR Serverの特長

  • 1.1.8　個人番号管理サービスと連携できます

1.1.8　個人番号管理サービスと連携できます

Windows環境で帳票出力する場合，マイナンバー対応の個人番号管理サービス※と連携し，個人番号管理サービスから取得した個人番号を帳票に出力できます。

次に示す個人番号管理サービスと連携できます。

  • マイナンバーセキュア管理システム

  • 匿名バンク

注※

機密性の高いマイナンバー対応の個人番号を，暗号化したデータベースで保存管理し，業務アプリケーションなどから安全に参照するためのサービスです。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 15 / 218


1.2 製品構成 : EUR 帳票出力 機能解説 EUR Server編

  • 16 / 218

  • 表紙

  • 1.　EUR Serverとは

  • 1.2　製品構成

1.2　製品構成

EUR Serverは，次の表に示すように二つのエディションを提供しています。帳票システムの構成や利用したいEURの機能に応じて，導入するEUR Serverを選択してください。

表1‒2　EUR Serverの種類と位置づけ

製品名

位置づけ

使用できる出力機能

EUR Server Enterprise

EUR Serverの帳票出力機能をすべて利用できます。

次のような場合に適しています。

  • 出力する帳票の枚数が多く，印刷データの生成に時間が掛かる場合

  • 帳票名で出力先を振り分けたい場合

  • 印刷処理の負荷分散を実施したい場合

  • 帳票の印刷履歴を管理したい場合

  • 帳票の出力処理が複数の業務システムにわたるなどで，印刷データの一時保管が必要な場合

  • オンライン処理で素早いレスポンスが求められる場合

  • プリンタ出力

  • EPF形式ファイル出力

  • PDF形式ファイル出力

  • EUR形式ファイル出力

  • Excel形式ファイル出力

  • スプールデータ出力（印刷データの蓄積）

EUR Server Standard

次のような場合に適しています。

  • クライアントPCに帳票を配信して出力する場合

  • PDF形式，EUR形式，Excel形式の帳票を出力する場合

  • サーバで生成した帳票を，クライアントPCのWebブラウザから出力，表示する場合

  • プリンタ出力

  • EPF形式ファイル出力

  • PDF形式ファイル出力

  • EUR形式ファイル出力

  • Excel形式ファイル出力
〈この節の構成〉

  • 1.2.1　EUR Serverを構成するコンポーネント

  • 1.2.2　ほかのEUR製品との関連

  • 1.2.3　連携製品

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 16 / 218


1.2.1 EUR Serverを構成するコンポーネント : EUR 帳票出力 機能解説 EUR Server編

  • 17 / 218

  • 表紙

  • 1.　EUR Serverとは

  • 1.2　製品構成

  • 1.2.1　EUR Serverを構成するコンポーネント

1.2.1　EUR Serverを構成するコンポーネント

EUR Serverを構成するコンポーネントとその役割を，次の表に示します。

なお，サーバで動作するコンポーネントのバージョンは同じバージョンで運用してください。

また，クライアントで動作するコンポーネントが古いバージョンの場合は，古いバージョンの機能範囲で動作します。

表1‒3 EUR Serverを構成するコンポーネントと役割
環境 | コンポーネント | 役割 |  | エディションごとの利用可否
 |  |  |  | ENT | STD
サーバ | EUR Print Service | 帳票の印刷データを生成します。 |  | ○ | ○
 | EUR Server Service | 生成された印刷データの出力指示，およびEUR Serverの全体的な管理を行います。 |  | ○ | ○
 | EUR Server - Adapter | 業務プログラムからEUR Server Serviceを操作するための起動部品を提供します。 |  | ○ | ○
 |  | BSP-RM連携コマンド（eursmprコマンド） | BSP-RMが管理するデータファイルをEURサーバ環境で帳票の印刷やファイル出力を行うコマンドを提供します。このコマンドはBSP-RMから呼び出して実行します。
 |  | ファイル監視サービス | 帳票出力に使用するファイルを監視フォルダに格納すると，自動的に帳票の印刷やファイル出力を行うファイル監視サービスを提供します。
 | EUR Server - Spool Service | 帳票の印刷データ（EPF形式ファイル）をサーバに蓄積します。また，蓄積されている印刷データの操作，および管理を行います。 |  | ○ | ×
 |  | 帳票管理GUIサービス | 蓄積されている帳票の印刷データの操作および管理を行う帳票管理GUIサービスを提供します。
 |  | 配送サービス | 蓄積した帳票の配送印刷を行う配送サービスを提供します。
 | EUR Server - Spool Service Adapter | 業務プログラムからEUR Server - Spool Serviceを操作するための起動部品を提供します。 |  | ○ | ×
クライアント | EUR Client Service | クライアントPCに配信された帳票の出力指示を行います。 |  | ○ | ○
 | EUR Web Plug-In | サーバに格納されている帳票をWebブラウザからダウンロードして印刷します。また，ダウンロードした帳票をWebブラウザに埋め込んで表示します。 |  | ○ | ○
（凡例）

ENT：EUR Server Enterprise

STD：EUR Server Standard

○：利用できます。

×：利用できません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 17 / 218


1.2.2 ほかのEUR製品との関連 : EUR 帳票出力 機能解説 EUR Server編

  • 18 / 218

  • 表紙

  • 1.　EUR Serverとは

  • 1.2　製品構成

  • 1.2.2　ほかのEUR製品との関連

1.2.2　ほかのEUR製品との関連

EUR ServerとほかのEUR製品との関連を，次の図に示します。

図1‒2　EUR ServerとほかのEUR製品との関連

[図データ]

開発環境のEUR Designer，またはEUR Developerで作成した帳票ファイル（*.fms）を基に，出力環境のEUR Serverで帳票を出力します。

出力環境にEUR Server - Cipher optionをインストールすると，EUR Server - Cipher optionの暗号化ツールを使用して次のことができます。

  • 暗号化PDF形式ファイルを出力できます。

  • 個人番号管理サービス連携機能で使用する場合，個人番号接続情報ファイルを暗号化できます。

また，EUR ServerでEUR形式ファイルを出力した場合，出力したEUR形式ファイルをEUR ViewerがインストールされているクライアントPCに転送して出力することもできます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 18 / 218


1.2.3 連携製品 : EUR 帳票出力 機能解説 EUR Server編

  • 19 / 218

  • 表紙

  • 1.　EUR Serverとは

  • 1.2　製品構成

  • 1.2.3　連携製品

1.2.3　連携製品

EUR Serverに同梱されている連携製品を次に示します。

DABroker

データベースからデータを読み込んで帳票を出力するときに使用します。セットアップ方法などの詳細については，マニュアル「EUR データベース連携ガイド」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 19 / 218


2. 帳票出力の概要 : EUR 帳票出力 機能解説 EUR Server編

  • 20 / 218

  • 表紙

  • 2.　帳票出力の概要

2.　帳票出力の概要

この章では，帳票出力の流れや，必要なファイルと出力内容との関係など，EUR Serverを使用した帳票出力の概要について説明します。

〈この章の構成〉

  • 2.1　帳票出力の流れ

  • 2.2　帳票の出力に必要なファイルと出力内容との関係

  • 2.3　帳票セットとは

  • 2.4　帳票IDとは

  • 2.5　帳票様式の種類

  • 2.6　出力できるファイル形式とページ数／シート数の上限

  • 2.7　出力した総ページ数の取得

  • 2.8　ファイル出力とメモリ出力

  • 2.9　帳票の出力で使用するプリンタ

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 20 / 218


2.1 帳票出力の流れ : EUR 帳票出力 機能解説 EUR Server編

  • 21 / 218

  • 表紙

  • 2.　帳票出力の概要

  • 2.1　帳票出力の流れ

2.1　帳票出力の流れ

EUR Serverを使用した帳票出力の流れを，次の図に示します。

図2‒1　帳票を出力する流れ

[図データ]

  1. 印刷データの生成

    出力要求時に指定した入力データから，帳票の印刷データが生成されます。

    生成できる印刷データの種類については，「付録A　帳票出力で使用するファイルの種類」を参照してください。

  2. 出力

    生成された印刷データは，帳票サーバ，スプールサーバ（Windows環境の場合），またはクライアントPCのプリンタに出力できます。また，EPF形式などのデータとして出力したり，クライアントPCでプレビューしたりすることもできます。なお，印刷データは出力後に削除されます。

生成された印刷データ（EPF形式ファイル）をすぐに出力しないでサーバに蓄積（スプール）しておくと，任意のタイミングで印刷できます。印刷データ（EPF形式ファイル）をサーバに蓄積し，任意のタイミングで印刷する方法を蓄積印刷といいます。

帳票を蓄積印刷する流れを，次の図に示します。

図2‒2　帳票を蓄積印刷する流れ

[図データ]

  1. 印刷データの生成

    蓄積要求時に指定した入力データから，帳票の印刷データが生成されます。

  2. 印刷データの蓄積

    生成された印刷データには，属性情報が付けられてサーバに蓄積されます。印刷データに属性情報が付けられたものをスプールデータといいます。

  3. 蓄積された印刷データの出力

    蓄積された印刷データに対して印刷要求を送ると，スプールサーバ（Windows環境の場合），またはクライアントPCのプリンタに出力できます。また，EPF形式のデータとして出力したり，クライアントPCでプレビューしたりすることもできます。なお，蓄積された印刷データは，蓄積期限が切れるまでスプールサーバから削除されません。そのため，一度出力した印刷データを再出力することもできます。

蓄積印刷は，出力する帳票の枚数が多くて印刷データの生成に時間が掛かる場合や，印刷データの一時保管が必要な場合に利用すると便利です。蓄積印刷の詳細については，「5.　スプールデータを出力するには」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 21 / 218


2.2 帳票の出力に必要なファイルと出力内容との関係 : EUR 帳票出力 機能解説 EUR Server編

  • 22 / 218

  • 表紙

  • 2.　帳票出力の概要

  • 2.2　帳票の出力に必要なファイルと出力内容との関係

2.2　帳票の出力に必要なファイルと出力内容との関係

帳票の出力に必要なファイルと帳票の出力内容との関係を，次の図に示します。

図2‒3　帳票の出力に必要なファイルと帳票の出力内容との関係

[図データ]

各入力ファイルに定義されている帳票のレイアウトやデータなどを読み込んで，帳票を出力します。データファイルの代わりに，データベースに登録されているデータを読み込んで帳票を出力することもできます。詳細については，マニュアル「EUR データベース連携ガイド」を参照してください。

入力ファイルと指定するファイルの概要を，次に示します。各ファイルの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

  • 帳票ファイル

    EUR Serverが扱える帳票ファイルは，フォームシートファイル形式（*.fms）です。帳票ファイルの作成方法については，マニュアル「EUR 帳票作成 操作ガイド」を参照してください。

  • データファイル

    EUR Serverで扱えるデータファイルは，CSV形式（*.csv），DAT形式（*.dat），およびFIX形式（*.fix）です。

    データファイルのフィールドの区切り方法やフィールド定義などは，EUR 帳票作成機能で帳票を設計するときに指定します。EUR Serverで帳票を出力するときには，帳票設計で使用したデータファイルを使用します。なお，帳票設計で使用するデータファイルには，次の2種類があります。詳細については，マニュアル「EUR 帳票作成 操作ガイド」を参照してください。

    • マッピングデータファイル

    • ユーザ定義データファイル

    また，マッピングデータファイルの内容（マッピングデータ）に帳票の出力方法や出力先などの情報を付加した制御情報付データファイルがあります。制御情報付データファイルの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

  • 画像ファイル

    EUR Serverで扱える画像ファイルの形式は次のとおりです。

    • Windows BITMAP

    • JPEG

    • GIF（GIF GIF87a，GIF GIF89a）

    • TIFF（TIFF 6.0）

    • PNG

■注意

  • 使用するデータファイルが固定のときは，データファイル名の指定を省略できます。この場合，EUR 帳票作成機能で帳票を設計したときに使用したデータファイル名を参照して帳票出力します。データファイル名は，帳票を設計したときの名称で帳票ファイル中に保存されています。データファイルの指定を省略して帳票を出力する場合は，帳票を設計したときに使用したデータファイル名でデータを作成してください。

  • 点線を出力する場合，指定した線幅が細いと印刷結果が実線に見えることがあります。想定どおりに印刷されるか，事前にテストしてから運用を開始してください。

  • 固定画像を含む帳票を出力する場合，帳票内に埋め込まれた固定画像を参照するか，外部データとして配置した画像ファイルを参照するかは，EUR Print Serviceの環境変数（EURPS_LOCATION_FIXIMAGE）の設定に依存します。EUR Print Serviceの環境変数（EURPS_LOCATION_FIXIMAGE）については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 22 / 218


2.3 帳票セットとは : EUR 帳票出力 機能解説 EUR Server編

  • 23 / 218

  • 表紙

  • 2.　帳票出力の概要

  • 2.3　帳票セットとは

2.3　帳票セットとは

対になる帳票ファイル名とデータファイル名の組み合わせを帳票セットといいます。

データベースからデータを取得して帳票を出力する場合は，データファイルの代わりに可変記号値定義ファイルを指定して帳票セットとします。また，しおり付きPDF形式ファイルを出力する場合は，しおり定義ファイルも帳票セットに含めます。PDF形式ファイルの出力については，「4.1　PDF形式ファイルを出力するには」を参照してください。

〈この節の構成〉

  • 2.3.1　帳票セットを複数指定した場合の動作

  • 2.3.2　帳票セット指定ファイルの利用

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 23 / 218


2.3.1 帳票セットを複数指定した場合の動作 : EUR 帳票出力 機能解説 EUR Server編

  • 24 / 218

  • 表紙

  • 2.　帳票出力の概要

  • 2.3　帳票セットとは

  • 2.3.1　帳票セットを複数指定した場合の動作

2.3.1　帳票セットを複数指定した場合の動作

帳票セットを複数指定すると，複数の帳票を一括で出力できます。複数の帳票を一括で出力することを，複数帳票の一括出力といいます。

帳票セットを複数指定した場合，次のように出力されます。

  • 出力順

    指定した帳票ファイルの順に帳票を出力します。

  • 用紙の向きとサイズ

    それぞれ用紙の向きやサイズが異なっていても，定義されている帳票の情報に合わせて出力します。

  • ページ番号

    連続したページ番号を付けることはできません。

    例えば，帳票Aと帳票Bを出力する場合，帳票Aのページ番号がnで終わっても，帳票Bのページ番号はn＋1からページ番号を付けることはできません。帳票Bのページ番号も，1から始まります。

  • 両面印刷で常に表面に出力するページの指定

    新規用紙出力定義ファイルで，帳票セットの各帳票ファイルの1ページ目を，常に用紙の表面に出力する対象ページに指定できます。両面印刷する場合，指定した対象ページが常に用紙の表面になるように空白ページが挿入されます。

    両面印刷で常に表面に出力するページを指定する方法については，「11.6 両面印刷で常に用紙の表面に出力する対象の帳票ファイルを指定するには」を参照してください。

■注意

複数の帳票セットだけを指定したとき，EUR形式ファイルはプレビューできません。指定できる拡張子は「.eup」です。ただし，複数の帳票セットに加えて，複数様式情報定義ファイルを指定している場合は，EUR形式ファイルをプレビューできます。拡張子は「.euv」および「.eup」が指定できます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 24 / 218


2.3.2 帳票セット指定ファイルの利用 : EUR 帳票出力 機能解説 EUR Server編

  • 25 / 218

  • 表紙

  • 2.　帳票出力の概要

  • 2.3　帳票セットとは

  • 2.3.2　帳票セット指定ファイルの利用

2.3.2　帳票セット指定ファイルの利用

EUR Serverでは，起動部品に複数の帳票ファイルを指定して帳票セットとすることもできますが，指定できる帳票セットの個数に上限はなくても，起動部品の引数に指定する文字数に制限があります。帳票セットの個数やファイルに指定できる文字数の上限に関係なく指定したい場合は，帳票セットを帳票セット指定ファイルに指定してください。

帳票セット指定ファイルは，次のように複数の帳票ファイルを統合する順番と帳票に読み込むデータファイルを指定しておくファイルです。指定内容の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 25 / 218


2.4 帳票IDとは : EUR 帳票出力 機能解説 EUR Server編

  • 26 / 218

  • 表紙

  • 2.　帳票出力の概要

  • 2.4　帳票IDとは

2.4　帳票IDとは

帳票IDは，起動部品を使用した帳票の出力で，帳票出力定義ファイルを使用する場合に指定します。帳票IDには，帳票出力時に使用する帳票出力定義ファイルのファイル名を指定できます。

〈この節の構成〉

  • 2.4.1　帳票出力定義ファイルの利用

  • 2.4.2　帳票IDの指定で使用する起動部品

  • 2.4.3　帳票IDの指定例

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 26 / 218


2.4.1 帳票出力定義ファイルの利用 : EUR 帳票出力 機能解説 EUR Server編

  • 27 / 218

  • 表紙

  • 2.　帳票出力の概要

  • 2.4　帳票IDとは

  • 2.4.1　帳票出力定義ファイルの利用

2.4.1　帳票出力定義ファイルの利用

帳票出力定義ファイルは，起動部品で帳票IDを使用して帳票を出力する場合に，帳票ファイル名を含む起動部品のプロパティ情報やメソッドの引数情報で指定する項目を定義するファイルです。

帳票IDを使用することで，帳票出力時の入力情報を，帳票ID，マッピングデータファイル，印刷方法，および印刷方法ごとに指定する必須項目だけに減らすことができます。

帳票出力定義ファイルでは，起動部品の設定項目のうち，次の項目を設定できます。

  • 帳票ファイルのファイル名とパス

  • 複数様式情報定義ファイルのファイル名とパス

  • 文書情報設定ファイルのファイル名とパス

  • EUR Print Serviceの環境設定ファイル（EURPS_ENV）のファイル名とパス

また，個人番号管理サービス連携機能を使用する場合は，次の項目の設定が必須です。

  • 個人番号フィールド情報ファイルのファイル名とパス※

注※

  • 帳票出力定義ファイルだけで設定できる項目です。

  • EUR Server Standard，またはEUR Server Enterpriseを使用している場合だけ指定できる項目です。EUR Developerを使用している場合は指定できません（指定するとエラー（KEEY337-E）になります）。

帳票出力定義ファイルの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

図2‒4　帳票出力時の起動部品の入力情報と帳票出力定義（帳票IDを使用する場合）

[図データ]

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 27 / 218


2.4.2 帳票IDの指定で使用する起動部品 : EUR 帳票出力 機能解説 EUR Server編

  • 28 / 218

  • 表紙

  • 2.　帳票出力の概要

  • 2.4　帳票IDとは

  • 2.4.2　帳票IDの指定で使用する起動部品

2.4.2　帳票IDの指定で使用する起動部品

次に示す印刷またはファイル出力を実行する場合に，起動部品で帳票IDを指定できます。

  • スプールサーバでの印刷

  • クライアントPCでの印刷※1

  • スプールデータ出力（印刷データの蓄積）

  • 帳票サーバでの直接印刷

  • EPF形式ファイル出力またはEPF形式データ出力※2

  • EUR形式ファイル出力またはEUR形式データ出力

  • PDF形式ファイル出力またはPDF形式データ出力

  • Excel形式ファイル出力またはExcel形式データ出力

注※1

クライアントPCでの配布印刷では，帳票IDを使用できません。指定しても無効になります。

注※2

複数のEPF形式ファイルの統合出力および統合データ出力では，帳票IDを使用できません。指定しても無効になります。

帳票IDを指定する起動部品のプロパティ，メソッド，パラメタ，およびオプションの指定値を次に示します。

  • ActiveX起動部品：ReportIDプロパティ

  • Java起動部品：setReportIDメソッド

  • COBOL起動部品：REPORTIDパラメタ

  • コマンド起動部品（eurpmcコマンド）：/ridオプション

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 28 / 218


2.4.3 帳票IDの指定例 : EUR 帳票出力 機能解説 EUR Server編

  • 29 / 218

  • 表紙

  • 2.　帳票出力の概要

  • 2.4　帳票IDとは

  • 2.4.3　帳票IDの指定例

2.4.3　帳票IDの指定例

コマンド起動部品（eurpmcコマンド）を使用したPDF形式ファイル出力について，帳票ファイル名（/rfオプション）を直接指定する場合と，帳票ID（/ridオプション）で帳票出力定義ファイル名を指定する場合で，それぞれ同じ入力情報を指定するときのコマンド起動部品の指定例を次に示します。

■入力情報

帳票ファイル名：帳票1.fms，帳票2.fms

マッピングデータファイル名：マップ1.csv，マップ2.csv

マッピングデータファイルのパス：c:\temp\map

複数様式情報定義ファイル名：複数様式.txt

複数様式情報定義ファイルのパス：デフォルト

文書情報設定ファイル名：文書情報.txt

文書情報設定ファイルのパス：デフォルト

EUR Print Serviceの環境設定ファイル（EURPS_ENV）名：c:\temp\環境設定\EURPS_ENV※

EUR Print Serviceの環境設定ファイル（EURPS_ENV）のパス：デフォルト

注※

この例では，EUR Print Serviceの環境設定ファイル（EURPS_ENV）名にフルパスを指定しているため，EUR Server Serviceの環境設定ファイル（EURPM.ini）で，OPTIONセクションのPATHMODEキーに1（フルパスモード）を指定しておく必要があります。

■コマンド起動部品の指定例

  • 帳票ファイル名を直接指定する場合

eurpmc.exe /m pdf /rf 帳票1.fms,帳票2.fms /mapp c:\temp\map /map マップ1.csv,マップ2.csv /mfd 複数様式.txt /df 文書情報.txt /psenvf c:\temp\環境設定\EURPS_ENV

  • 帳票IDを指定する場合

eurpmc.exe /m pdf /rid reportid_1 /mapp c:\temp\map /map マップ1.csv,マップ2.csv

帳票出力定義ファイル名：reportid_1

#reportid_1
#帳票ファイル名
ReportFileName:帳票1.fms
ReportFileName:帳票2.fms

#複数様式情報定義ファイル名
MultiFormInfoDefFileName:複数様式.txt

#文書情報設定ファイル名
DocInfoFileName:文書情報.txt

#EUR Print Serviceの環境設定ファイル(EURPS_ENV)名
PSEnvFileName:c:\temp\環境設定\EURPS_ENV

帳票出力定義ファイルのパス：デフォルト※

注※

デフォルトの格納先は「インストール先フォルダ\Server\reportidフォルダ」です。帳票出力定義ファイルの格納先は，EUR Server Serviceの環境設定ファイル（EURPM.ini）のPATHセクションのREPORTIDキーで変更できます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 29 / 218


2.5 帳票様式の種類 : EUR 帳票出力 機能解説 EUR Server編

  • 30 / 218

  • 表紙

  • 2.　帳票出力の概要

  • 2.5　帳票様式の種類

2.5　帳票様式の種類

次に示す3種類の帳票様式があります。

単一様式

帳票セットを一つだけ指定して，単一の様式で出力する帳票様式です。

帳票セットの複数指定

帳票セットを二つ以上指定して，一様式ごとに出力（複数帳票の一括出力）する帳票様式です。

複数様式

帳票セットを二つ以上指定して，複数の異なる様式を一つの帳票として出力する帳票様式です。

帳票様式を決定するまでの流れを，次の図に示します。

図2‒5　帳票様式を決定するまでの流れ

[図データ]

（凡例）

[図データ] ：帳票様式に応じて，コマンドまたは業務プログラムで設定する機能を示します。

複数様式帳票を出力する方法については，「11.1　複数様式で帳票を出力するには」を参照してください。

また，帳票様式に応じて，両面印刷で常に表面に出力する対象の帳票ファイルを指定する方法については，「11.6 両面印刷で常に用紙の表面に出力する対象の帳票ファイルを指定するには」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 30 / 218


2.6 出力できるファイル形式とページ数／シート数の上限 : EUR 帳票出力 機能解説 EUR Server編

  • 31 / 218

  • 表紙

  • 2.　帳票出力の概要

  • 2.6　出力できるファイル形式とページ数／シート数の上限

2.6　出力できるファイル形式とページ数／シート数の上限

EUR Serverで出力できるファイル形式とページ数／シート数の上限を，次の表に示します。

表2‒1　EUR Serverで出力できるファイル形式とページ数／シート数の上限

項番

ファイル形式

拡張子

出力できるページ数／シート数の上限

説明

1

EPF形式

*.epf，*.epp

999,999ページ

EUR独自のファイル形式です。

データを圧縮しているので，サイズが小さく，ネットワークの負荷を軽減できます。

EUR Client Serviceをヘルパ起動で実行するときは，ファイルの出力時に指定した拡張子によって，実行時の動作が決まります。

  • *.epp

    プリンタに出力します。

  • *.epf

    プレビューします。

2

PDF形式

*.pdf

999,999ページ

Adobe Readerで表示できるファイル形式です。

EURがインストールされていないPCや，異なるOSのPCとの間でもやり取りできます。

3

EUR形式

*.eup

32,767ページ

EUR独自のファイル形式です。

PDF形式ファイルやEPF形式ファイルよりもサイズが小さく，ネットワーク負荷を軽減できます。

また，精度が高いバーコードの印刷や，プリンタごとの印刷補正ができます。

EUR Viewerをヘルパ起動で実行するときは，ファイルの出力時に指定した拡張子によって，実行時の動作が決まります。

  • *.eup

    プリンタに出力します。

  • *.euv

    プレビューします。

4

*.euv

65,534ページ

5

Excel形式

*.xlsx

100シート※

Excelで表示・編集できるファイル形式です。

Excelを使用して帳票の内容を編集したり，コメントやグラフを挿入したりするなどの二次加工ができます。
注※

ページ単位でシートを分けない設定の場合，縦繰り返しのExcelのシート上での行数の上限は1シートあたり10,000です。

重要

  • EPF形式ファイルを作成する際に一時ファイルを作成します。一時ファイルのサイズが2GB以上となる場合，エラーとなり，EPF形式ファイルは作成できません。

  • PDF形式ファイルのサイズが2GB以上のファイルはエラーとなり，作成できません。

  • EUR形式ファイルを作成する際に一時ファイルを作成します。一時ファイルのサイズが4GB以上となる場合，エラーとなり，EUR形式ファイルは作成できません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 31 / 218


2.7 出力した総ページ数の取得 : EUR 帳票出力 機能解説 EUR Server編

  • 32 / 218

  • 表紙

  • 2.　帳票出力の概要

  • 2.7　出力した総ページ数の取得

2.7　出力した総ページ数の取得

起動部品を使用して，印刷またはファイル出力を実行した帳票の総ページ数を取得することができます。

〈この節の構成〉

  • 2.7.1　出力した総ページ数の取得で使用する起動部品

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 32 / 218


2.7.1 出力した総ページ数の取得で使用する起動部品 : EUR 帳票出力 機能解説 EUR Server編

  • 33 / 218

  • 表紙

  • 2.　帳票出力の概要

  • 2.7　出力した総ページ数の取得

  • 2.7.1　出力した総ページ数の取得で使用する起動部品

2.7.1　出力した総ページ数の取得で使用する起動部品

次に示す印刷またはファイル出力を実行する場合に，起動部品で出力した帳票の総ページ数※1を取得できます。

  • スプールサーバでの印刷※2

  • クライアントPCでの印刷※3

  • スプールデータ出力（印刷データの蓄積）

  • 帳票サーバでの直接印刷

  • EPF形式ファイル出力※4

  • PDF形式ファイル出力

  • Excel形式ファイル出力※5

注※1

次に示す空白ページは総ページ数に含みません。

  • 単一様式帳票，または帳票セットを複数指定した帳票の場合，新規用紙出力定義ファイルの指定によって挿入された空白ページ

  • 複数様式帳票の場合，複数様式情報定義ファイルのprintnewpaper=ONの指定によって挿入された空白ページ

ただし，EUR Print Serviceの環境設定ファイル（EURPS_ENV）の環境変数EURPS_PRINTNEWPAPER_INCLUDE_OUTPUTPAGECOUNTキーで「YES」を指定している場合は，上記の空白ページを総ページ数に含めます。

注※2

印刷モードがEPF形式ファイル印刷モードの場合だけ，出力した帳票の総ページ数を取得できます。

注※3

クライアントPCでの配布印刷では，出力した帳票の総ページ数を取得できません。出力した帳票の総ページ数の情報が必要な場合は，クライアントPCに配布する個々の印刷データ（EPF形式ファイル）を出力するときに帳票の総ページ数を取得し，合計ページ数は計算して求める運用としてください。

注※4

複数のEPF形式ファイルの統合出力では，出力した帳票の総ページ数を取得できません。出力した帳票の総ページ数の情報が必要な場合は，個々のEPF形式ファイルを出力するときに帳票の総ページ数を取得し，合計ページ数は計算して求める運用としてください。

注※5

出力した帳票の総シート数（最大100シート）を取得できます。

出力した帳票の総ページ数を取得する起動部品のプロパティ，メソッド，パラメタ，およびオプションの指定値を次に示します。

  • ActiveX起動部品：OutputPageCountOptプロパティおよびGetOutputPageCountメソッド

  • Java起動部品：setOutputPageCountOptメソッドおよびgetOutputPageCountメソッド

  • COBOL起動部品：OUTPUTPAGECOUNTOPTパラメタおよび戻り値OUTPUTPAGECOUNT

  • コマンド起動部品（eurpmcコマンド）：/opcオプション

なお，COBOL起動部品を使用する場合は，出力した帳票の総ページ数を最大999,999,998ページまで取得できます。出力した帳票の総ページ数が999,999,998ページを超える場合は，取得する総ページ数が999,999,999ページとなります。COBOL起動部品以外の起動部品を使用する場合は，最大2,147,483,646ページまで取得できます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 33 / 218


2.8 ファイル出力とメモリ出力 : EUR 帳票出力 機能解説 EUR Server編

  • 34 / 218

  • 表紙

  • 2.　帳票出力の概要

  • 2.8　ファイル出力とメモリ出力

2.8　ファイル出力とメモリ出力

帳票をEPF形式やPDF形式などのデータとして出力するには，任意のフォルダにファイルで出力する方法（ファイル出力）と，サーバのメモリ上にデータとして出力する方法（メモリ出力）の2種類があります。

通常はファイル出力を使用しますが，次のような場合はメモリ出力を使用します。

  • セキュリティ上，サーバやクライアントPCに一時ファイルを作成したくない場合

  • 帳票の印刷データをデータベースにバイナリデータとして登録する場合

帳票をメモリに出力する場合は，Java起動部品を使用してください。ActiveX起動部品，COBOL起動部品，およびコマンド起動部品には，帳票をメモリに出力する機能はありません。

〈この節の構成〉

  • 2.8.1　出力で使用する起動部品

  • 2.8.2　ファイル出力とメモリ出力のコーディング例

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 34 / 218


2.8.1 出力で使用する起動部品 : EUR 帳票出力 機能解説 EUR Server編

  • 35 / 218

  • 表紙

  • 2.　帳票出力の概要

  • 2.8　ファイル出力とメモリ出力

  • 2.8.1　出力で使用する起動部品

2.8.1　出力で使用する起動部品

帳票をデータ出力するときに使用する起動部品について説明します。

〈この項の構成〉

  • (1)　ファイル出力で使用する起動部品

  • (2)　メモリ出力で使用する起動部品

(1)　ファイル出力で使用する起動部品

ファイル出力で使用する起動部品のメソッド，関数，およびオプションの指定値を次に示します。

  • EPF形式ファイルの場合

    ActiveX起動部品：OutputEPFReportメソッド

    Java起動部品：outputEPFReportメソッド

    COBOL起動部品：OutputEPFReport関数

    コマンド起動部品（eurpmcコマンド）：/mオプションにepfを指定

  • PDF形式ファイルの場合

    ActiveX起動部品：OutputPDFReportメソッド

    Java起動部品：outputPDFReportメソッド

    COBOL起動部品：OutputPDFReport関数

    コマンド起動部品（eurpmcコマンド）：/mオプションにpdfを指定

  • EUR形式ファイルの場合

    ActiveX起動部品：OutputEURReportメソッド

    Java起動部品：outputEURReportメソッド

    COBOL起動部品：OutputEURReport関数

    コマンド起動部品（eurpmcコマンド）：/mオプションにeurを指定

  • Excel形式ファイルの場合

    ActiveX起動部品：OutputXLSXReportメソッド

    Java起動部品：outputXLSXReportメソッド

    COBOL起動部品：OutputXLSXReport関数

    コマンド起動部品（eurpmcコマンド）：/mオプションにxlsxを指定

ページの先頭へ

(2)　メモリ出力で使用する起動部品

メモリ出力で使用するJava起動部品のメソッドを次に示します。

  • EPF形式データの場合

    getEPFReportメソッド

  • PDF形式データの場合

    getPDFReportメソッド

  • EUR形式データの場合

    getEURReportメソッド

  • Excel形式データの場合

    getXLSXReportメソッド

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 35 / 218


2.8.2 ファイル出力とメモリ出力のコーディング例 : EUR 帳票出力 機能解説 EUR Server編

  • 36 / 218

  • 表紙

  • 2.　帳票出力の概要

  • 2.8　ファイル出力とメモリ出力

  • 2.8.2　ファイル出力とメモリ出力のコーディング例

2.8.2　ファイル出力とメモリ出力のコーディング例

〈この項の構成〉

  • (1)　ファイル出力の場合のコーディング例

  • (2)　メモリ出力の場合のコーディング例

(1)　ファイル出力の場合のコーディング例

次に示すパラメタを指定して，EPF形式データをファイル出力します。出力ファイルは，EUR Server - Adapter稼働マシンに出力されます。

■入力ファイル（印刷定義ファイル）：EUR Server Service稼働マシンに配置

帳票ファイル名：sample1.fms

■入力ファイル（ユーザデータファイル）：EUR Server - Adapter稼働マシンに配置

マッピングデータファイルのパス：c:\Temp

マッピングデータファイル名：data1.csv

■出力ファイル

出力EPF形式ファイルのパス：c:\Inetpub\wwwroot\EPF

出力EPF形式ファイル名：sample1_EPF.epf

■そのほか

印刷範囲：1～10ページ

コーディング例を次に示します。

<%@ page import="java.io.*" %>
<%@ page import="java.util.*" %>
<%@ page import="JP.co.Hitachi.soft.EURPM.*" %>
<%@ page contentType="text/html; charset=Shift_JIS" %>
<jsp:useBean id="adapter" class="JP.co.Hitachi.soft.EURPM.EURPMAdapterForJava" scope="session" />

               ・
               ・
               ・
<%
  try {
      String hostName = request.getServerName();

      adapter.setReportFileName("sample1.fms");      // 帳票名設定
      adapter.setDataFilePath("c:\\Temp");
                                // マッピングデータファイルのパス設定
      adapter.setDataFileName("data1.csv");
                                // マッピングデータファイル名設定
      adapter.setPrintStartPage(1);             // 印刷開始ページ設定
      adapter.setPrintEndPage(10);              // 印刷終了ページ設定
      adapter.setEPFFilePath("c:\\Inetpub\\wwwroot\\EPF");
                                        // EPF形式ファイル出力パス設定
      adapter.setEPFFileName("sample1_EPF.epf");
                                        // EPF形式ファイル名設定
      adapter.outputEPFReport();        // EPF形式ファイル出力要求

  }
// エラー処理
  catch (JP.co.Hitachi.soft.EURPM.EURPMException e) {
      out.println("<P>エラー発生<br>");
      out.println("<table BORDER CELLSPACING=2 CELLPADDING=4 >");
      out.println("<tr><th>メソッド</th><th>取得結果</th></tr>");
      out.println("<tr><td>エラーコード</td>");
      out.println("<td>" + e.getErrorCode() + "</td></tr>");
      out.println("<tr><td>メッセージ</td>");
      out.println("<td>" + e.getMessage() + "</td></tr>");
      out.println("<tr><td>エラーレベル</td>");
      out.println("<td>" + e.getErrorLevel() + "</td></tr>");
      out.println("<tr><td>メッセージID</td>");
      out.println("<td>" + e.getKey() + "</td></tr>");
      out.println("</table>");
  }
%>

ページの先頭へ

(2)　メモリ出力の場合のコーディング例

次に示すパラメタを指定して，EPF形式データをメモリ出力します。

■入力ファイル（印刷定義ファイル）：EUR Server Service稼働マシンに配置

帳票ファイル名1：都道府県.fms

帳票ファイル名2：名簿（ローマ字）.fms

帳票ファイル名3：アルファベット一覧.fms

■入力ファイル（ユーザデータファイル）

帳票ファイル名1のマッピングデータ："東京,神奈川,千葉,埼玉"

帳票ファイル名2のマッピングデータ："TARO,NAHAKO,JIRO,YOKO,SABURO,NAOMI"

帳票ファイル名3のマッピングデータ："A,B,C,D,E,F,G,H"

コーディング例を次に示します。

import JP.co.Hitachi.soft.EURPM.*;

    try {
      EURPMAdapterForJava obj=new EURPMAdapterForJava();
      String target = request.getRemoteAddr();
      frmFileNames = (String[])(3);
      Array.set(frmFileNames, 0, “都道府県.fms”);
      Array.set(frmFileNames, 1, “名簿（ローマ字）.fms”);
      Array.set(frmFileNames, 2, “アルファベット一覧.fms”);
      obj.setMultiReportFileName(frmFileNames);
                         //帳票ファイル名の指定

      StringBuffer[] mapFileDatas = new StringBuffer[3];
      StringBuffer mapFileData;
      mapFileData = new StringBuffer();
      mapFileData.insert(0, "東京,神奈川,千葉,埼玉");
      Array.set(mapFileDatas, 0, mapFileData);
      mapFileData = new StringBuffer();
      mapFileData.insert(1, "TARO,NAHAKO,JIRO,YOKO,SABURO,NAOMI ");
      Array.set(mapFileDatas, 1, mapFileData);
      mapFileData = new StringBuffer();
      mapFileData.insert(2, "A,B,C,D,E,F,G,H");
      Array.set(mapFileDatas, 2, mapFileData);
      obj.setDataFileData(mapFileDatas);
                         //マッピングデータの指定

      ByteBuffer outputFileData = adp.getEPFReport();
                         //EPF形式データの取得
    }
    catch (JP.co.Hitachi.soft.EURPM.EURPMException ce) {
                                    //エラー処理
      int errid;
      errid=ce.getErrorCode();
                     //エラーコードをerridに取り出す
      if (errid==441) {
                     //KEEY441-Wの場合のエラー処理
      } else if (errid==301) {
                     //KEEY301-Eの場合のエラー処理
      } else if (errid==302) {
                     //KEEY302-Eの場合のエラー処理
      } else if (errid==   {
                     //以下，そのほかのエラー処理を繰り返す
              :
      }
    }

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 36 / 218


2.9 帳票の出力で使用するプリンタ : EUR 帳票出力 機能解説 EUR Server編

  • 37 / 218

  • 表紙

  • 2.　帳票出力の概要

  • 2.9　帳票の出力で使用するプリンタ

2.9　帳票の出力で使用するプリンタ

帳票の出力で使用するプリンタは次のとおりです。

  • Windows環境の場合

    Windowsプリンタに標準対応しています。

  • UNIX／Linux環境の場合

    LIPSIII，PostScript，およびESC/Pに標準対応しています。

なお，印刷で使用するプリンタの情報や印刷位置補正情報などの，印刷に関する各種設定にはプリンタ定義ファイルを使用します。指定内容の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

■注意

  • EUR 帳票作成機能で設計した帳票が「ユーザ定義」の用紙サイズに設定されている場合，出力するプリンタの用紙サイズも，同じ「ユーザ定義」のサイズで登録しておく必要があります。「ユーザ定義」の用紙サイズに設定した単位に合わせて設定してください。用紙サイズの設定方法については，使用しているプリンタ，またはプリンタドライバの仕様を確認してください。

  • 帳票をPostScript対応プリンタで出力する場合，用紙サイズの設定を，帳票の先頭ページおよび用紙サイズが切り替わったページだけに行うか，各ページに行うかは，EUR Print Serviceの環境変数（EURPS_PS2_PR1）の設定に依存します。EUR Print Serviceの環境変数（EURPS_PS2_PR1）については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

〈この節の構成〉

  • 2.9.1　プリンタクラスの利用

  • 2.9.2　UNIX／Linux環境でのプリンタ定義

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 37 / 218


2.9.1 プリンタクラスの利用 : EUR 帳票出力 機能解説 EUR Server編

  • 38 / 218

  • 表紙

  • 2.　帳票出力の概要

  • 2.9　帳票の出力で使用するプリンタ

  • 2.9.1　プリンタクラスの利用

2.9.1　プリンタクラスの利用

帳票を出力するプリンタとトレイの組み合わせのことをプリンタクラスといいます。プリンタクラスを設定すると，プリンタに任意の名前を付けられるため，プリンタを簡単に管理できます。また，帳票の出力時にプリンタクラス名を指定することで，プリンタとトレイを一度に指定できます。

プリンタクラスの設定方法については，マニュアル「EUR システム構築ガイド」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 38 / 218


2.9.2 UNIX／Linux環境でのプリンタ定義 : EUR 帳票出力 機能解説 EUR Server編

  • 39 / 218

  • 表紙

  • 2.　帳票出力の概要

  • 2.9　帳票の出力で使用するプリンタ

  • 2.9.2　UNIX／Linux環境でのプリンタ定義

2.9.2　UNIX／Linux環境でのプリンタ定義

UNIX／Linux環境のEUR Serverで出力するときは，プリンタ定義ファイルを指定しただけでは印刷できません。EUR Serverをインストールしたあと，稼働するOSでプリンタ定義をする必要があります。

プリンタ定義ファイルの指定内容の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

〈この項の構成〉

  • (1)　定義手順

  • (2)　プリンタ定義ファイルの指定例

(1)　定義手順

  1. OSでのプリンタ定義

    OSでのプリンタ定義は，スーパーユーザでログインしたあと，次に示す手順で行います。

    AIX環境の場合

    # /usr/sbin/lpshut　　（プリンタのスケジューラが動作している場合）

    # /usr/sbin/lpadmin　（プリンタ定義　※）

    # /usr/lib/lp/lpsched　（プリンタのスケジューラを起動）

    HP-UX環境の場合

    # /usr/sbin/lpshut　　（プリンタのスケジューラが動作している場合）

    # /usr/sbin/lpadmin　（プリンタ定義　※）

    # /usr/lib/lpsched　　（プリンタのスケジューラを起動）

    Linux環境の場合

    Linux環境の場合は，printconf-gui，またはprintconf-tuiツールを使用します。printconf-gui，またはprintconf-tuiツールについては，Linuxのドキュメントを参照してください。

  2. プリンタ定義ファイルの指定

    1.で定義したプリンタ名を，プリンタ定義ファイルのキーワードCommandに指定します。

  3. 印刷の実行

    2.で指定したプリンタ名を指定します。

注※

プリンタ定義は，ローカルプリンタとリモートプリンタで定義が次のように異なります。

  • AIX環境の場合

    ローカルプリンタのとき

    lpadminコマンドを使用して，ローカルプリンタをプリンタスプールシステムに追加します。例えば，プリンタ名Printer1とする場合は，次のように定義します。スペシャルファイルとして，/dev/lp0を使用しています。

    # /usr/sbin/lpadmin -pPrinter1 -v/dev/lp0 -onobanner

    # /usr/sbin/accept Printer1

    # /usr/bin/enable Printer1

    リモートプリンタのとき

    lpadminコマンドを使用して，リモートプリンタをプリンタスプールシステムに追加します。例えば，ホスト名HOST1に接続されているプリンタ（プリンタ名＝RemotePR）をプリンタ名Printer1とする場合は，次のように定義します。ただし，ネットワークの構成などによって指定方法が異なる場合があります。プリンタを定義する場合は，あらかじめAIXのマニュアルを確認してください。

    # /usr/sbin/lpsystem HOST1

    # /usr/sbin/lpadmin -pPrinter1 -sHOST1!RemotePR

    # /usr/sbin/accept Printer1

    # /usr/bin/enable Printer1

  • HP-UX環境の場合

    ローカルプリンタのとき

    lpadminコマンドを使用して，ローカルプリンタをプリンタスプールシステムに追加します。例えば，プリンタ名Printer1とする場合は，次のように定義します。スペシャルファイルとして，/dev/lp0を使用しています。

    # /usr/sbin/lpadmin -pPrinter1 -v/dev/lp0 -mLIPS3

    リモートプリンタのとき

    lpadminコマンドを使用して，リモートプリンタをプリンタスプールシステムに追加します。例えば，ホスト名HOST1に接続されているプリンタ（プリンタ名＝LBPA4）をプリンタ名Printer1とする場合は，次のように定義します。

    # /usr/sbin/lpadmin -pPrinter1 -v/dev/null -ocmrcmodel -osmrsmodel -ormHOST1 -orpLBPA4 -mrmodel

  • Linux環境の場合

    ローカルプリンタのとき

    プリンタタイプをLOCALに設定して，ドライバは直接プリンタキューを指定してください。

    リモートプリンタのとき

    プリンタタイプをLPDに設定して，ドライバは直接プリンタキューを指定してください。

ページの先頭へ

(2)　プリンタ定義ファイルの指定例

次の3台のプリンタを使用した，プリンタ定義ファイルの指定例を次に示します。

■LIPSPR1の定義内容

LIPSIII対応プリンタ，解像度300dpi，ハードマージン上下左右5mm，2段カセット，LPプリンタ名は，Printer1で登録されているプリンタ，自動給紙，モノクロ印刷，CODE39バーコードの細エレメント，太エレメント，キャラクタ間ギャップの幅の比を1対2.5対1に変更し，黒バーの太さを0.04mm補正，QRコードのセルサイズに5ドットを指定し，QRコードのセルサイズに30(1/100mm)を指定

■PSPR2の定義内容

PostScript対応プリンタ，解像度600dpi，ハードマージン上下左右5mm，両面印刷，用紙の長辺にとじ代を設定，3段カセット，LPプリンタ名は，Printer2で登録されているプリンタ，自動給紙，両面カラー印刷，ＭＳ 明朝をHeiseiMin-W3-90ms-RKSJ-Hに置き換え，ＭＳ ゴシックをHeiseiKakugo-W3-90ms-RKSJ-Hに置き換え，CODE39バーコードの細エレメント，太エレメント，キャラクタ間ギャップの幅の比を1対2対1に変更，QRコードのセルサイズに10ドットを指定し，QRコードのセルサイズに50(1/100mm)を指定

■ESCPPR3の定義内容

ESC/P対応プリンタ，解像度180dpi，1段カセット，LPプリンタ名は，Printer3で登録されているプリンタ，自動給紙，モノクロ印刷，CODE39バーコードの細エレメント，太エレメント，キャラクタ間ギャップの幅の比を1対3対1に変更し，黒バーの太さを0.05mm補正，QRコードのセルサイズに9ドットを指定し，QRコードのセルサイズに100(1/100mm)を指定

■プリンタ定義ファイルの指定例

  • HP-UX環境の場合

    [LIPSPR1]
  PDLType=LIPS3
  XDpi=300
  YDpi=300
  Margin=5:5:5:5
  Duplex=FALSE
  Cassettes=2
  DefaultCassette=Auto
  Color=FALSE
  Command=/usr/bin/lp -c -oraw -onb -dPrinter1
  CODE39PARAM=2,1:2.5:1,0.04
  QRCellSizeD=5
  QRCellSizeM=30

[PSPR2]
  PDLType=PS2
  XDpi=600
  YDpi=600
  Margin=5:5:5:5
  Duplex=TRUE
  DuplexBinding=Long
  Cassettes=3
  DefaultCassette=Auto
  Color=TRUE
  Command=/usr/bin/lp -c -oraw -onb -dPrinter2
  Font=MS明朝:HeiseiMin-W3-90ms-RKSJ-H,MSゴシック:HeiseiKakugo-W3-90ms-RKSJ-H
  CODE39PARAM=2,1:2:1
  QRCellSizeD=10
  QRCellSizeM=50

[ESCPPR3]
  PDLType=ESCP
  XDpi=180
  YDpi=180
  Duplex=FALSE
  Cassettes=1
  DefaultCassette=Auto
  Color=FALSE
  Command=/usr/bin/lp -c -oraw -onb -dPrinter3
  CODE39PARAM=2,1:3:1,0.05
  QRCellSizeD=9
  QRCellSizeM=100

  • AIX，およびLinux環境の場合

    [LIPSPR1]
  PDLType=LIPS3
  XDpi=300
  YDpi=300
  Margin=5:5:5:5
  Duplex=FALSE
  Cassettes=2
  DefaultCassette=Auto
  Color=FALSE
  Command=/usr/bin/lp -c -onobanner -dPrinter1
  CODE39PARAM=2,1:2.5:1,0.04
  QRCellSizeD=5
  QRCellSizeM=30

[PSPR2]
  PDLType=PS2
  XDpi=600
  YDpi=600
  Margin=5:5:5:5
  Duplex=TRUE
  DuplexBinding=Long
  Cassettes=3
  DefaultCassette=Auto
  Color=TRUE
  Command=/usr/bin/lp -c -onobanner -dPrinter2
  Font=MS明朝:HeiseiMin-W3-90ms-RKSJ-H,MSゴシック:HeiseiKakugo-W3-90ms-RKSJ-H
  CODE39PARAM=2,1:2:1
  QRCellSizeD=6
  QRCellSizeM=50

[ESCPPR3]
  PDLType=ESCP
  XDpi=180
  YDpi=180
  Duplex=FALSE
  Cassettes=1
  DefaultCassette=Auto
  Color=FALSE
  Command=/usr/bin/lp -c -onobanner -dPrinter3
  CODE39PARAM=2,1:3:1,0.05
  QRCellSizeD=9
  QRCellSizeM=100

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 39 / 218


3. 出力先を選んで出力する : EUR 帳票出力 機能解説 EUR Server編

  • 40 / 218

  • 表紙

  • 3.　出力先を選んで出力する

3.　出力先を選んで出力する

この章では，出力先を選んで帳票を出力する方法について説明します。

〈この章の構成〉

  • 3.1　サーバのプリンタに出力するには

  • 3.2　クライアントPCのプリンタに出力するには

  • 3.3　クライアントPCでプレビューするには

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 40 / 218


3.1 サーバのプリンタに出力するには : EUR 帳票出力 機能解説 EUR Server編

  • 41 / 218

  • 表紙

  • 3.　出力先を選んで出力する

  • 3.1　サーバのプリンタに出力するには

3.1　サーバのプリンタに出力するには

ここでは，EUR サーバ帳票出力機能で出力した帳票を，帳票サーバまたはスプールサーバのプリンタに出力する方法について説明します。

なお，スプールサーバのプリンタに出力できるのは，スプールサーバがWindows環境の場合だけです。スプールサーバがUNIX／Linux環境の場合は，スプールサーバのプリンタへの出力はできません。

〈この節の構成〉

  • 3.1.1　帳票サーバのプリンタに出力する

  • 3.1.2　スプールサーバのプリンタに出力する

  • 3.1.3　スプールサーバのプリンタに出力する（EUR Server連携）

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 41 / 218


3.1.1 帳票サーバのプリンタに出力する : EUR 帳票出力 機能解説 EUR Server編

  • 42 / 218

  • 表紙

  • 3.　出力先を選んで出力する

  • 3.1　サーバのプリンタに出力するには

  • 3.1.1　帳票サーバのプリンタに出力する

3.1.1　帳票サーバのプリンタに出力する

帳票サーバに登録されているプリンタに帳票を出力できます。

〈この項の構成〉

  • (1)　出力の流れ

  • (2)　起動部品の設定

  • (3)　出力結果

  • (4)　注意事項

(1)　出力の流れ

帳票サーバに登録されているプリンタに帳票を出力する流れを，次の図に示します。

図3‒1　帳票サーバのプリンタに出力する流れ

[図データ]

  1. 出力要求

    帳票の出力要求が業務プログラムに送られます。

  2. 転送

    EUR Server - Adapterは，ユーザデータファイルを帳票サーバのEUR Server Serviceに転送します。

  3. 出力

    帳票サーバに登録されているプリンタに帳票が出力されます。

ページの先頭へ

(2)　起動部品の設定

帳票出力で使用する起動部品のメソッド，関数，およびオプションの指定値を次に示します。

  • ActiveX起動部品：PrintPMReportメソッド

  • Java起動部品：printReportメソッド

  • COBOL起動部品：PrintReport関数またはPrintReport2関数

  • コマンド起動部品（eurpmcコマンド）：/mオプションにprintを指定

また，出力時に設定する起動部品のプロパティ，メソッド，パラメタ，およびオプションの指定値を次に示します。

  1. 印刷方法の設定

    帳票を印刷する方法を設定します。

    印刷方法の設定

    起動部品の設定項目

    設定する値

    印刷方法

    ActiveX起動部品：PrintModeプロパティ

    Java起動部品：setPrintModeメソッド

    COBOL起動部品：PRINTMODEパラメタ

    4（帳票サーバで直接印刷する）

    コマンド起動部品：/pmオプション

    pm（帳票サーバで直接印刷する）

  2. プリンタの設定

    プリンタの指定方法を設定します。プリンタの指定方法は，プリンタクラス名とプリンタ名の2種類から選択できます。

    帳票サーバのプリンタの設定

    起動部品の設定項目

    設定する値

    プリンタの指定方法

    ActiveX起動部品：PrinterSelectModeプロパティ

    Java起動部品：setPrinterSelectModeメソッド

    COBOL起動部品：PRINTERSELECTMODEパラメタ

    0（プリンタクラス名で指定する）

    1（プリンタ名で指定する）

    コマンド起動部品：/smオプション

    class（プリンタクラス名で指定する）

    printer（プリンタ名で指定する）

    プリンタクラス名

    ActiveX起動部品：PrinterClassNameプロパティ

    Java起動部品：setPrinterClassNameメソッド

    COBOL起動部品：PRINTERCLASSNAMEパラメタ

    コマンド起動部品：/prcオプション

    プリンタクラス名（80バイト以内の文字列）

    プリンタ名

    OS上のプリンタ名

    ActiveX起動部品：ServerPrinterNameプロパティ

    Java起動部品：setServerPrinterNameメソッド

    COBOL起動部品：SERVERPRINTERNAMEパラメタ

    コマンド起動部品：/lspオプション

    プリンタ名（80バイト以内の文字列）

    OS上のプリンタのトレイ名

    ActiveX起動部品：ServerTrayNameプロパティ

    Java起動部品：setServerTrayNameメソッド

    COBOL起動部品：SERVERTRAYNAMEパラメタ

    コマンド起動部品：/lstオプション

    トレイ名（80バイト以内の文字列）

  3. 帳票ファイルの設定

    印刷する帳票ファイル名を設定します。

    帳票ファイルの設定

    起動部品の設定項目

    設定する値

    帳票ファイルの名前

    ActiveX起動部品：ReportFileNameプロパティ

    Java起動部品：setReportFileNameメソッド

    COBOL起動部品：REPORTNAMEパラメタ

    コマンド起動部品：/rfオプション

    帳票ファイル名（255バイト以内の文字列）

  4. マッピングデータファイルの設定

    マッピングデータファイル名を設定します。

    ユーザデータファイルの設定

    起動部品の設定項目

    設定する値

    マッピングデータファイルの名前

    ActiveX起動部品：DataFileNameプロパティ

    Java起動部品：setDataFileNameメソッド

    COBOL起動部品：MAPPINGDATAパラメタ

    コマンド起動部品：/mapオプション

    マッピングデータファイル名（255バイト以内の文字列）

  5. ユーザデータファイルおよび印刷定義ファイルの設定

    必要に応じて，ユーザデータファイル（ユーザ定義データファイルなど），および印刷定義ファイル（複数様式情報定義ファイル，文書情報設定ファイル，置き換え表管理情報ファイルなど）を設定します。

■参考

3.の帳票ファイルの設定は，帳票ファイル名を直接指定する以外に，次のどちらかを指定することもできます。

  • 帳票セット指定ファイル

    帳票ファイル名やマッピングデータファイル名を，帳票セットとして帳票セット指定ファイルにまとめて指定することができます。出力時には次に示すプロパティ，メソッド，パラメタ，またはオプションで帳票セット指定ファイル名を指定してください。

    ・ActiveX起動部品：MultiReportSetFileNameプロパティ

    ・Java起動部品：setMultiReportSetFileNameメソッド

    ・COBOL起動部品：REPORTSETFILEパラメタ

    ・コマンド起動部品：/mrsオプション

  • 帳票ID

    帳票ファイル名を含む帳票出力で使用する項目を，帳票出力定義として帳票出力定義ファイルに指定することができます。帳票IDには，帳票出力時に使用する帳票出力定義ファイル名を指定します。出力時には次に示すプロパティ，メソッド，パラメタ，またはオプションで帳票出力定義ファイル名を指定してください。

    ・ActiveX起動部品：ReportIDプロパティ

    ・Java起動部品：setReportIDメソッド

    ・COBOL起動部品：REPORTIDパラメタ

    ・コマンド起動部品：/ridオプション

ページの先頭へ

(3)　出力結果

  • プリンタクラス名を指定していた場合

    指定したプリンタクラス名に対応するプリンタとトレイで出力されます。プリンタクラス名が設定されていない場合は，帳票サーバのデフォルトのプリンタに出力されます。プリンタクラス名が設定されていない，かつ，デフォルトのプリンタも設定されていない場合は，エラーとなります。

    また，帳票サーバプリンタクラス定義ファイル（PMPrinterClass.conf）内に，同じプリンタクラス名が複数存在する場合は，最初に記述されているプリンタクラス名が有効になります。

  • プリンタ名とトレイ名を指定していた場合

    指定したプリンタとトレイで出力されます。指定したプリンタとトレイが帳票サーバにない場合は，エラーとなります。

ページの先頭へ

(4)　注意事項

  • Windows環境でネットワークプリンタに印刷する場合は，EUR Server Serviceのログオンアカウントを，ネットワークプリンタに印刷できる適切なアクセス権を持つアカウントに変更してください。

  • Microsoft XPS Document Writerのように，ファイルの出力先を指定するダイアログを表示するなど，ユーザの操作を必要とする応答が発生するプリンタドライバは使用しないでください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 42 / 218


3.1.2 スプールサーバのプリンタに出力する : EUR 帳票出力 機能解説 EUR Server編

  • 43 / 218

  • 表紙

  • 3.　出力先を選んで出力する

  • 3.1　サーバのプリンタに出力するには

  • 3.1.2　スプールサーバのプリンタに出力する

3.1.2　スプールサーバのプリンタに出力する

スプールサーバに登録されているプリンタに帳票を出力できます。

なお，スプールサーバのプリンタに出力できるのは，スプールサーバがWindows環境の場合だけです。スプールサーバがUNIX／Linux環境の場合は，スプールサーバのプリンタへの出力はできません。

〈この項の構成〉

  • (1)　出力の流れ

  • (2)　出力先の設定

  • (3)　起動部品の設定

  • (4)　出力結果

  • (5)　コーディング例

  • (6)　注意事項

(1)　出力の流れ

スプールサーバに登録されているプリンタに帳票を出力する流れを，次の図に示します。

図3‒2　スプールサーバのプリンタに出力する流れ

[図データ]

  1. 出力要求

    帳票の出力要求が業務プログラムに送られます。

  2. 転送

    EUR Server - Adapterは，ユーザデータファイルを帳票サーバのEUR Server Serviceに転送します。

  3. 印刷データ生成

    転送されたユーザデータファイルとあらかじめ帳票サーバに配置しておいた印刷定義ファイルから，印刷データ（EPF形式ファイル）が生成されます。

  4. 印刷データ転送

    EUR Server Serviceは，生成された印刷データ（EPF形式ファイル）をスプールサーバに転送します。

  5. 出力

    スプールサーバに登録されているプリンタに帳票が出力されます。転送された印刷データは，帳票の出力後に削除されます。

■参考

帳票の印刷データ（EPF形式ファイル）をスプールサーバに蓄積してから，任意のタイミングで出力することもできます。帳票の印刷データをスプールサーバに蓄積する方法については，「5.2.2　印刷データを蓄積する手順」を参照してください。また，蓄積した印刷データを出力する方法については，「5.4　蓄積した印刷データを出力する」を参照してください。

ページの先頭へ

(2)　出力先の設定

  • スプールサーバの設定

    出力先のスプールサーバは，IPアドレスまたはIPアドレスに名前を付けた出力先名（出力先定義）のどちらかで指定します。

    • IPアドレスで指定する場合

      帳票出力時に起動部品でIPアドレスを指定します。

    • 出力先名で指定する場合

      スプールサーバのIPアドレスに名前を付けて，出力先名として帳票サーバに登録します。帳票出力時に起動部品で出力先名を指定すると，指定したスプールサーバに帳票が出力されます。

  • スプールサーバのプリンタの設定

    スプールサーバのプリンタは，プリンタ名とトレイ名の直接指定，スプールサーバのプリンタとトレイを組み合わせたプリンタクラス，または帳票振り分け定義のどれかで指定します。

    • プリンタ名とトレイ名の直接指定で指定する場合

      帳票出力時に起動部品でプリンタ名とトレイ名を指定します。

    • プリンタクラスで指定する場合

      スプールサーバのプリンタとトレイを組み合わせたものを，プリンタクラスとしてスプールサーバに登録します。帳票出力時に起動部品でプリンタクラス名を指定すると，指定したプリンタのトレイに帳票が出力されます。

    • 帳票振り分け定義で指定する場合

      帳票名を分類するグループ（振り分けグループ），帳票名，およびプリンタクラスの組み合わせを，帳票振り分け定義としてスプールサーバに登録します。帳票出力時に起動部品で振り分けグループを指定すると，帳票名ごとに自動的にプリンタが設定されます。セパレータ出力などのトレイ振り分けもできます。

ページの先頭へ

(3)　起動部品の設定

帳票出力で使用する起動部品のメソッド，関数，およびオプションの指定値を次に示します。

  • ActiveX起動部品：PrintPMReportメソッド

  • Java起動部品：printReportメソッド

  • COBOL起動部品：PrintReport関数またはPrintReport2関数

  • コマンド起動部品（eurpmcコマンド）：/mオプションにprintを指定

また，出力時に設定する起動部品のプロパティ，メソッド，パラメタ，およびオプションの指定値を次に示します。

  1. 印刷方法の設定

    帳票を印刷する方法を設定します。

    印刷方法の設定

    起動部品の設定項目

    設定する値

    印刷方法

    ActiveX起動部品：PrintModeプロパティ

    Java起動部品：setPrintModeメソッド

    COBOL起動部品：PRINTMODEパラメタ

    3（スプールサーバで印刷する）

    コマンド起動部品：/pmオプション

    sv（スプールサーバで印刷する）

    出力するファイル形式

    ActiveX起動部品：PrintKindプロパティ

    Java起動部品：setPrintKindメソッド

    COBOL起動部品：PRINTKINDパラメタ

    0（EPF形式ファイルを出力する）

    コマンド起動部品：/pkオプション

    epf（EPF形式ファイルを出力する）

  2. スプールサーバの設定

    スプールサーバの指定方法を設定します。スプールサーバの指定方法は，出力先名とIPアドレスの2種類から選択できます。

    スプールサーバの設定

    起動部品の設定項目

    設定する値

    サーバの指定方法

    ActiveX起動部品：ServerSelectModeプロパティ

    Java起動部品：setServerSelectModeメソッド

    COBOL起動部品：SERVERSELECTMODEパラメタ

    0（出力先名で指定する）

    1（IPアドレスで指定する）

    コマンド起動部品：/srmオプション

    dest（出力先名で指定する）

    sv（IPアドレスで指定する）

    出力先名

    ActiveX起動部品：DestinationNameプロパティ

    Java起動部品：setDestinationNameメソッド

    COBOL起動部品：DESTNAMEパラメタ

    コマンド起動部品：/destオプション

    出力先名（80バイト以内の文字列）

    IPアドレス

    ActiveX起動部品：ServerAddressプロパティ

    Java起動部品：setServerAddressメソッド

    COBOL起動部品：SERVERADDRパラメタ

    コマンド起動部品：svrオプション

    255.255.255.255形式

  3. プリンタの設定

    スプールサーバのプリンタの指定方法を設定します。スプールサーバのプリンタの指定方法は，プリンタクラス名，プリンタ名，および帳票振り分け定義の3種類から選択できます。

    スプールサーバのプリンタの設定

    起動部品の設定項目

    設定する値

    プリンタの指定方法

    ActiveX起動部品：PrinterSelectModeプロパティ

    Java起動部品：setPrinterSelectModeメソッド

    COBOL起動部品：PRINTERSELECTMODEパラメタ

    0（プリンタクラス名で指定する）

    1（プリンタ名で指定する）

    2（帳票振り分け定義で指定する）

    コマンド起動部品：/smオプション

    class（プリンタクラス名で指定する）

    printer（プリンタ名で指定する）

    group（帳票振り分け定義で指定する）

    プリンタクラス名

    ActiveX起動部品：PrinterClassNameプロパティ

    Java起動部品：setPrinterClassNameメソッド

    COBOL起動部品：PRINTERCLASSNAMEパラメタ

    コマンド起動部品：/prcオプション

    プリンタクラス名（80バイト以内の文字列）

    プリンタ名

    OS上のプリンタ名

    ActiveX起動部品：ServerPrinterNameプロパティ

    Java起動部品：setServerPrinterNameメソッド

    COBOL起動部品：SERVERPRINTERNAMEパラメタ

    コマンド起動部品：/lspオプション

    プリンタ名（80バイト以内の文字列）

    OS上のプリンタのトレイ名

    ActiveX起動部品：ServerTrayNameプロパティ

    Java起動部品：setServerTrayNameメソッド

    COBOL起動部品：SERVERTRAYNAMEパラメタ

    コマンド起動部品：/lstオプション

    トレイ名（80バイト以内の文字列）

    帳票振り分け定義

    ActiveX起動部品：GroupNameプロパティ

    Java起動部品：setGroupNameメソッド

    COBOL起動部品：GROUPNAMEパラメタ

    コマンド起動部品：/groupオプション

    帳票振り分け定義（80バイト以内の文字列）

  4. 帳票ファイルの設定

    印刷する帳票ファイル名を設定します。

    帳票ファイルの設定

    起動部品の設定項目

    設定する値

    帳票ファイルの名前

    ActiveX起動部品：ReportFileNameプロパティ

    Java起動部品：setReportFileNameメソッド

    COBOL起動部品：REPORTNAMEパラメタ

    コマンド起動部品：/rfオプション

    帳票ファイル名（255バイト以内の文字列）

  5. マッピングデータファイルの設定

    マッピングデータファイル名を設定します。

    ユーザデータファイルの設定

    起動部品の設定項目

    設定する値

    マッピングデータファイルの名前

    ActiveX起動部品：DataFileNameプロパティ

    Java起動部品：setDataFileNameメソッド

    COBOL起動部品：MAPPINGDATAパラメタ

    コマンド起動部品：/mapオプション

    マッピングデータファイル名（255バイト以内の文字列）

  6. ユーザデータファイル，印刷定義ファイル，および印刷付加情報の設定

    必要に応じて，ユーザデータファイル（ユーザ定義データファイルなど），印刷定義ファイル（複数様式情報定義ファイル，文書情報設定ファイル，置き換え表管理情報ファイルなど）および印刷付加情報（印刷開始ページ，印刷部数，ページ番号など）を設定します。

■参考

4.の帳票ファイルの設定は，帳票ファイル名を直接指定する以外に，次のどちらかを指定することもできます。

  • 帳票セット指定ファイル

    帳票ファイル名やマッピングデータファイル名を，帳票セットとして帳票セット指定ファイルにまとめて指定することができます。出力時には次に示すプロパティ，メソッド，パラメタ，またはオプションで帳票セット指定ファイル名を指定してください。

    ・ActiveX起動部品：MultiReportSetFileNameプロパティ

    ・Java起動部品：setMultiReportSetFileNameメソッド

    ・COBOL起動部品：REPORTSETFILEパラメタ

    ・コマンド起動部品：/mrsオプション

  • 帳票ID

    帳票ファイル名を含む帳票出力で使用する項目を，帳票出力定義として帳票出力定義ファイルに指定することができます。帳票IDには，帳票出力時に使用する帳票出力定義ファイル名を指定します。出力時には次に示すプロパティ，メソッド，パラメタ，またはオプションで帳票出力定義ファイル名を指定してください。

    ・ActiveX起動部品：ReportIDプロパティ

    ・Java起動部品：setReportIDメソッド

    ・COBOL起動部品：REPORTIDパラメタ

    ・コマンド起動部品：/ridオプション

ページの先頭へ

(4)　出力結果

  • 拠点プリンタクラスを指定していた場合

    指定した拠点プリンタクラスに対応するプリンタとトレイで出力されます。

    指定した拠点プリンタクラス名が拠点プリンタクラスに設定されていない場合は，拠点プリンタクラスに設定したデフォルトの拠点プリンタクラスのプリンタに出力されます。拠点プリンタクラスに設定したプリンタとトレイがスプールサーバに登録されていない場合は，エラーとなります。拠点プリンタクラスの設定およびスプールサーバに登録されたプリンタの設定を見直してください。

  • プリンタとトレイを指定していた場合

    指定したプリンタとトレイで出力されます。

    指定したプリンタとトレイがスプールサーバに登録されていない場合は，エラーとなります。

  • 帳票振り分け定義を指定していた場合

    指定した帳票名と帳票振り分け定義に対応するプリンタとトレイで出力されます。帳票が印刷されるプリンタを設定別に次に示します。

    • 振り分けグループ名を指定したとき

      指定された振り分けグループに対応する拠点プリンタクラスで印刷されます。

    • 振り分けグループ名が指定されていないとき

      デフォルトの振り分けグループに対応する拠点プリンタクラスで印刷されます。

    • 指定された帳票が帳票振り分け定義にないとき

      振り分けグループのデフォルト帳票に設定した拠点プリンタクラスで印刷されます。デフォルトの振り分けグループにも，デフォルト帳票を定義できます。

    • 指定された帳票が帳票振り分け定義になく，デフォルト帳票が設定されていないとき

      デフォルトの拠点プリンタクラスで印刷されます。

ページの先頭へ

(5)　コーディング例

次に示すパラメタを指定して，スプールサーバのプリンタに出力します。

■入力ファイル（印刷定義ファイル）：EUR Server Service稼働マシンに配置

帳票ファイル名：sample1.fms

■入力ファイル（ユーザデータファイル）：EUR Server - Adapter稼働マシンに配置

マッピングデータファイルのパス：c:\Temp

マッピングデータファイル名：data1.csv

コーディング例を次に示します。

(a)　ActiveX起動部品の場合

<HTML>
<HEAD>
<TITLE>Sample Script of ASP page for EUR Print Manager</TITLE>
</HEAD>
<BODY>
<%
  Server.ScriptTimeOut=100     …スクリプトのタイムアウト時間を
                                 100秒に設定
  On Error Resume Next         …エラーハンドリングを行う
  dim target                   …変数宣言
  Set EURPM=Server.CreateObject("EURPM.Exec")
                        …プログラムID「EURPM.Exec」を指定して，
                          ActiveX起動部品のインスタンス作成
  EURPM.ClientAddress=target              …クライアントIPアドレスの指定
  EURPM.ReportFileName="sample1.fms"      …帳票ファイルの指定
  EURPM.DataFilePath="c:\Temp"            …マッピングデータファイルの
                                            パスの指定
  EURPM.DataFileName="data1.csv"          …マッピングデータの指定
  If Err.Number <> 0 Then
    Response.Write("印刷実行前に
                    エラーが発生しています"& Err.Number &"<BR>")
  Else
    EURPM.PrintPMReport()                 …印刷指示
    If Err.Number = 0 Then                …PrintPMReportメソッドは
                                            正常終了かどうかの判定
      「正常終了時の処理」
    Else
      errid= Err.Number           …エラーコードをerridに取り出す
      If errid=-441 Then          …KEEY441-Wの場合のエラー処理
        Elseif errid=-301 Then    …KEEY301-Eの場合のエラー処理
        Elseif errid=-302 Then    …KEEY302-Eの場合のエラー処理
        Elseif errid=
              :                   …そのほかのエラー処理を繰り返す
      End If
    End If
  End If
%>
</BODY>
</HTML>

(b)　Java起動部品の場合

import JP.co.Hitachi.soft.EURPM.*;

  :
    try {
      EURPMAdapterForJava obj=new EURPMAdapterForJava();
      String target = request.getRemoteAddr();
      obj.setReportFileName("sample1.fms");
                         //帳票ファイル名の指定
      obj.setDataFilePath("c:\\Temp");
                         //マッピングデータファイルのパスの指定
      obj.setDataFileName("data1.csv");
                         //マッピングデータファイル名の指定
      obj.printReport();    //帳票の出力指示
    }
    catch (JP.co.Hitachi.soft.EURPM.EURPMException ce) {
                                    //エラー処理
      int errid;
      errid=ce.getErrorCode();
                     //エラーコードをerridに取り出す
      if (errid==441) {
                     //KEEY441-Wの場合のエラー処理
      } else if (errid==301) {
                     //KEEY301-Eの場合のエラー処理
      } else if (errid==302) {
                     //KEEY302-Eの場合のエラー処理
      } else if (errid==xxx) {
                     //以下，そのほかのエラー処理を繰り返す
              :
      }
    }

ページの先頭へ

(6)　注意事項

  • ネットワークプリンタに印刷する場合は，EUR Server - Spool Serviceのログオンアカウントを，ネットワークプリンタに印刷できる適切なアクセス権を持つアカウントに変更してください。

  • Microsoft XPS Document Writerのように，ファイルの出力先を指定するダイアログを表示するなど，ユーザの操作を必要とする応答が発生するプリンタドライバは使用しないでください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 43 / 218


3.1.3 スプールサーバのプリンタに出力する（EUR Server連携） : EUR 帳票出力 機能解説 EUR Server編

  • 44 / 218

  • 表紙

  • 3.　出力先を選んで出力する

  • 3.1　サーバのプリンタに出力するには

  • 3.1.3　スプールサーバのプリンタに出力する（EUR Server連携）

3.1.3　スプールサーバのプリンタに出力する（EUR Server連携）

スプールサーバに配置したEUR Serverと連携することで，スプールサーバのプリンタでEUR形式ファイルの帳票を出力できます。

EUR形式ファイルの帳票を出力するには，帳票サーバにEUR Server Standard，またはEUR Server Enterpriseが必要です。スプールサーバに配置するEUR Serverは，どのエディションでもかまいません。

また，スプールサーバのプリンタに出力できるのは，スプールサーバがWindows環境の場合だけです。スプールサーバがUNIX／Linux環境の場合は，スプールサーバのプリンタへの出力はできません。

〈この項の構成〉

  • (1)　出力の流れ

  • (2)　出力先の設定

  • (3)　起動部品の設定

  • (4)　注意事項

(1)　出力の流れ

スプールサーバのEUR Serverと連携して帳票を出力する流れを，次の図に示します。

図3‒3　スプールサーバのEUR Serverと連携して出力する流れ

[図データ]

  1. 出力要求

    帳票の出力要求が業務プログラムに送られます。

  2. 転送

    EUR Server - Adapterは，ユーザデータファイルを帳票サーバのEUR Server Serviceに転送します。

  3. 印刷データ生成

    転送されたユーザデータファイルとあらかじめ帳票サーバに配置しておいた印刷定義ファイルから，印刷データ（EUR形式ファイル）が生成されます。

  4. 印刷データ転送

    EUR Server Serviceは，生成された印刷データ（EUR形式ファイル）をスプールサーバに転送します。

  5. 出力

    スプールサーバに登録されているプリンタに帳票が出力されます。

ページの先頭へ

(2)　出力先の設定

  • スプールサーバの設定

    出力先のスプールサーバは，IPアドレスまたはIPアドレスに名前を付けた出力先名（出力先定義）のどちらかで指定します。

    • IPアドレスで指定する場合

      帳票出力時に起動部品でIPアドレスを指定します。

    • 出力先名で指定する場合

      スプールサーバのIPアドレスに名前を付けて，出力先名として帳票サーバに登録します。帳票出力時に起動部品で出力先名を指定すると，指定したスプールサーバに帳票が出力されます。

  • スプールサーバのプリンタの設定

    スプールサーバのプリンタは，プリンタ名とトレイ名の直接指定，またはスプールサーバのプリンタとトレイを組み合わせたプリンタクラスのどちらかで指定します。

    • プリンタ名とトレイ名の直接指定で指定する場合

      帳票出力時に起動部品でプリンタ名とトレイ名を指定します。

    • プリンタクラスで指定する場合

      スプールサーバのプリンタとトレイを組み合わせたものを，プリンタクラスとしてスプールサーバに登録します。帳票出力時に起動部品でプリンタクラス名を指定すると，指定したプリンタのトレイに帳票が出力されます。

ページの先頭へ

(3)　起動部品の設定

帳票出力で使用する起動部品のメソッド，関数，およびオプションの指定値を次に示します。

  • ActiveX起動部品：PrintPMReportメソッド

  • Java起動部品：printReportメソッド

  • COBOL起動部品：PrintReport関数またはPrintReport2関数

  • コマンド起動部品（eurpmcコマンド）：/mオプションにprintを指定

また，出力時に設定する起動部品のプロパティ，メソッド，パラメタ，およびオプションの指定値を次に示します。

  1. 印刷方法の設定

    帳票を印刷する方法を設定します。出力するファイル形式をEUR形式に設定すると，EUR Serverと連携して出力できます。

    印刷方法の設定

    起動部品の設定項目

    設定する値

    印刷方法

    ActiveX起動部品：PrintModeプロパティ

    Java起動部品：setPrintModeメソッド

    COBOL起動部品：PRINTMODEパラメタ

    3（スプールサーバで印刷する）

    コマンド起動部品：/pmオプション

    sv（スプールサーバで印刷する）

    出力するファイル形式

    ActiveX起動部品：PrintKindプロパティ

    Java起動部品：setPrintKindメソッド

    COBOL起動部品：PRINTKINDパラメタ

    1（EUR形式ファイルを出力する）

    コマンド起動部品：/pkオプション

    eur（EUR形式ファイルを出力する）

  2. スプールサーバの設定

    スプールサーバの指定方法を設定します。スプールサーバの指定方法は，出力先名とIPアドレスの2種類から選択できます。

    スプールサーバの設定

    起動部品の設定項目

    設定する値

    サーバの指定方法

    ActiveX起動部品：ServerSelectModeプロパティ

    Java起動部品：setServerSelectModeメソッド

    COBOL起動部品：SERVERSELECTMODEパラメタ

    0（出力先名で指定する）

    1（IPアドレスで指定する）

    コマンド起動部品：/srmオプション

    dest（出力先名で指定する）

    sv（IPアドレスで指定する）

    出力先名

    ActiveX起動部品：DestinationNameプロパティ

    Java起動部品：setDestinationNameメソッド

    COBOL起動部品：DESTNAMEパラメタ

    コマンド起動部品：/destオプション

    出力先名（80バイト以内の文字列）

    IPアドレス

    ActiveX起動部品：ServerAddressプロパティ

    Java起動部品：setServerAddressメソッド

    COBOL起動部品：SERVERADDRパラメタ

    コマンド起動部品：/svrオプション

    255.255.255.255形式

  3. プリンタの設定

    スプールサーバのプリンタの指定方法を設定します。スプールサーバのプリンタの指定方法は，プリンタクラス名とプリンタ名の2種類から選択できます。

    スプールサーバのプリンタの設定

    起動部品の設定項目

    設定する値

    プリンタの指定方法

    ActiveX起動部品：PrinterSelectModeプロパティ

    Java起動部品：setPrinterSelectModeメソッド

    COBOL起動部品：PRINTERSELECTMODEパラメタ

    0（プリンタクラス名で指定する）

    1（プリンタ名で指定する）

    コマンド起動部品：/smオプション

    class（プリンタクラス名で指定する）

    printer（プリンタ名で指定する）

    プリンタクラス名

    ActiveX起動部品：PrinterClassNameプロパティ

    Java起動部品：setPrinterClassNameメソッド

    COBOL起動部品：PRINTERCLASSNAMEパラメタ

    コマンド起動部品：/prcオプション

    プリンタクラス名（80バイト以内の文字列）

    プリンタ名

    OS上のプリンタ名

    ActiveX起動部品：ServerPrinterNameプロパティ

    Java起動部品：setServerPrinterNameメソッド

    COBOL起動部品：SERVERPRINTERNAMEパラメタ

    コマンド起動部品：/lspオプション

    プリンタ名（80バイト以内の文字列）

    OS上のプリンタのトレイ名

    ActiveX起動部品：ServerTrayNameプロパティ

    Java起動部品：setServerTrayNameメソッド

    COBOL起動部品：SERVERTRAYNAMEパラメタ

    コマンド起動部品：/lstオプション

    トレイ名（80バイト以内の文字列）

  4. 帳票ファイルの設定

    印刷する帳票ファイル名を設定します。

    帳票ファイルの設定

    起動部品の設定項目

    設定する値

    帳票ファイルの名前

    ActiveX起動部品：ReportFileNameプロパティ

    Java起動部品：setReportFileNameメソッド

    COBOL起動部品：REPORTNAMEパラメタ

    コマンド起動部品：/rfオプション

    帳票ファイル名（255バイト以内の文字列）

  5. マッピングデータファイルの設定

    マッピングデータファイル名を設定します。

    ユーザデータファイルの設定

    起動部品の設定項目

    設定する値

    マッピングデータファイルの名前

    ActiveX起動部品：DataFileNameプロパティ

    Java起動部品：setDataFileNameメソッド

    COBOL起動部品：MAPPINGDATAパラメタ

    コマンド起動部品：/mapオプション

    マッピングデータファイル名（255バイト以内の文字列）

  6. ユーザデータファイル，印刷定義ファイル，および印刷付加情報の設定

    必要に応じて，ユーザデータファイル（ユーザ定義データファイルなど），印刷定義ファイル（複数様式情報定義ファイル，文書情報設定ファイル，置き換え表管理情報ファイルなど）および印刷付加情報（印刷開始ページ，印刷部数，ページ番号など）を設定します。

■参考

4.の帳票ファイルの設定は，帳票ファイル名を直接指定する以外に，次のどちらかを指定することもできます。

  • 帳票セット指定ファイル

    帳票ファイル名やマッピングデータファイル名を，帳票セットとして帳票セット指定ファイルにまとめて指定することができます。出力時には次に示すプロパティ，メソッド，パラメタ，またはオプションで帳票セット指定ファイル名を指定してください。

    ・ActiveX起動部品：MultiReportSetFileNameプロパティ

    ・Java起動部品：setMultiReportSetFileNameメソッド

    ・COBOL起動部品：REPORTSETFILEパラメタ

    ・コマンド起動部品：/mrsオプション

  • 帳票ID

    帳票ファイル名を含む帳票出力で使用する項目を，帳票出力定義として帳票出力定義ファイルに指定することができます。帳票IDには，帳票出力時に使用する帳票出力定義ファイル名を指定します。出力時には次に示すプロパティ，メソッド，パラメタ，またはオプションで帳票出力定義ファイル名を指定してください。

    ・ActiveX起動部品：ReportIDプロパティ

    ・Java起動部品：setReportIDメソッド

    ・COBOL起動部品：REPORTIDパラメタ

    ・コマンド起動部品：/ridオプション

ページの先頭へ

(4)　注意事項

  • ネットワークプリンタに印刷する場合は，EUR Server - Spool Serviceのログオンアカウントを，ネットワークプリンタに印刷できる適切なアクセス権を持つアカウントに変更してください。

  • Microsoft XPS Document Writerのように，ファイルの出力先を指定するダイアログを表示するなど，ユーザの操作を必要とする応答が発生するプリンタドライバは使用しないでください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 44 / 218


3.2 クライアントPCのプリンタに出力するには : EUR 帳票出力 機能解説 EUR Server編

  • 45 / 218

  • 表紙

  • 3.　出力先を選んで出力する

  • 3.2　クライアントPCのプリンタに出力するには

3.2　クライアントPCのプリンタに出力するには

ここでは，EUR サーバ帳票出力機能で出力した帳票を，クライアントPCのプリンタに出力する方法について説明します。

帳票をクライアントPCのプリンタに出力するには，次の表に示す方法があります。

表3‒1 クライアントPCのプリンタへの出力方法
出力方法 | 運用 | 参照先
自動で出力する | クライアントPCに帳票を転送して出力する。 | 3.2.1
 | 同一の帳票を複数のクライアントPCに配布して出力する（配布印刷）。 | 3.2.2
ダイアログでプリンタを設定して出力する | クライアントPCに帳票を転送して出力する。 | 3.2.3
 | 同一の帳票を複数のクライアントPCに配布して出力する（配布印刷）。 | 3.2.4
Webブラウザを使用して出力する | EUR Web Plug-Inを使用して出力する（ActiveXクライアント印刷）。 | 3.2.5
 | EUR Client Serviceをヘルパ起動して出力する（ヘルパクライアント印刷）。 | 3.2.6
コマンドを実行して出力する | クライアントでコマンドを実行して出力する。 | 3.2.7
■参考

帳票の印刷データ（EPF形式ファイル）をスプールサーバに蓄積してから，任意のタイミングで出力することもできます。帳票の印刷データをスプールサーバに蓄積する方法については，「5.2.2　印刷データを蓄積する手順」を参照してください。また，蓄積した印刷データを出力する方法については，「5.4　蓄積した印刷データを出力する」を参照してください。

〈この節の構成〉

  • 3.2.1　自動で出力する

  • 3.2.2　自動で出力する（配布印刷）

  • 3.2.3　ダイアログでプリンタを設定して出力する

  • 3.2.4　ダイアログでプリンタを設定して出力する（配布印刷）

  • 3.2.5　EUR Web Plug-Inを使用して出力する

  • 3.2.6　EUR Client Serviceをヘルパ起動して出力する

  • 3.2.7　コマンドを実行して出力する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 45 / 218


3.2.1 自動で出力する : EUR 帳票出力 機能解説 EUR Server編

  • 46 / 218

  • 表紙

  • 3.　出力先を選んで出力する

  • 3.2　クライアントPCのプリンタに出力するには

  • 3.2.1　自動で出力する

3.2.1　自動で出力する

帳票サーバから帳票の印刷データ（EPF形式ファイル）がクライアントPCに転送されると，EUR Client Serviceが起動して帳票を自動で出力できます（自動印刷）。印刷実行時に印刷中ダイアログを表示させないように設定することもできます（全自動印刷）。

自動印刷，および全自動印刷では，あらかじめ設定したプリンタに帳票が自動で出力されるため，データ受信時にクライアントPCを操作する必要はありません。

〈この項の構成〉

  • (1)　出力の流れ

  • (2)　出力先の設定

  • (3)　起動部品の設定

  • (4)　出力結果

  • (5)　注意事項

(1)　出力の流れ

帳票をクライアントPCに転送して出力する流れを，次の図に示します。

図3‒4　帳票をクライアントPCに転送して出力する流れ（自動印刷）

[図データ]

  1. 出力要求

    帳票の出力要求が業務プログラムに送られます。

  2. 転送

    アプリケーションサーバのEUR Server - Adapterは，ユーザデータファイルを帳票サーバのEUR Server Serviceに転送します。

  3. 印刷データ生成

    転送されたユーザデータファイルとあらかじめ帳票サーバに配置しておいた印刷定義ファイルから，印刷データ（EPF形式ファイル）が生成されます。

  4. 印刷データ転送

    EUR Server Serviceは，生成された印刷データ（EPF形式ファイル）をクライアントPCに転送します。

  5. 出力

    印刷データ（EPF形式ファイル）を受信すると，EUR Client Serviceが起動して，指定したプリンタに自動で出力されます。

ページの先頭へ

(2)　出力先の設定

プリンタ名とトレイ名の直接指定，またはクライアントPCのプリンタクラスのどちらかで出力先を指定します。

  • プリンタ名とトレイ名の直接指定で指定する場合

    帳票出力時に起動部品でプリンタ名とトレイ名を指定します。

  • プリンタクラスで指定する場合

    クライアントPCのプリンタとトレイを組み合わせたものを，プリンタクラスとしてクライアントPCに登録します。帳票出力時に起動部品でプリンタクラス名を指定すると，指定したプリンタのトレイに帳票が出力されます。

どちらの場合も，起動部品の指定内容は印刷データ（EPF形式ファイル）の属性情報として保持されます。クライアントPCで印刷データを受信したとき，印刷データが保持している属性情報によって自動でプリンタが選択されます。

■参考

クライアントPCのプリンタクラスは各クライアントPCで設定しますが，設定内容をクライアントプリンタクラス定義ファイルに保存して，ひな型として各クライアントPCに配布することもできます。配布したファイルを使えば，各クライアントPCでプリンタクラスを設定する手間が省けます。

クライアントプリンタクラス定義ファイルの作成方法や格納先については，マニュアル「EUR システム構築ガイド」を参照してください。

ページの先頭へ

(3)　起動部品の設定

帳票出力で使用する起動部品のメソッド，関数，およびオプションの指定値を次に示します。

  • ActiveX起動部品：PrintPMReportメソッド

  • Java起動部品：printReportメソッド

  • COBOL起動部品：PrintReport関数またはPrintReport2関数

  • コマンド起動部品（eurpmcコマンド）：/mオプションにprintを指定

また，出力時に設定する起動部品のプロパティ，メソッド，パラメタ，およびオプションの指定値を次に示します。

  1. 印刷方法の設定

    帳票を印刷する方法を設定します。

    印刷方法の設定

    起動部品の設定項目

    設定する値

    印刷方法

    ActiveX起動部品：PrintModeプロパティ

    Java起動部品：setPrintModeメソッド

    COBOL起動部品：PRINTMODEパラメタ

    1（クライアントPCで印刷する）

    コマンド起動部品：/pmオプション

    cl（クライアントPCで印刷する）

  2. クライアントPCの設定

    クライアントPCのIPアドレスを指定します。

    クライアントPCの設定

    起動部品の設定項目

    設定する値

    IPアドレス

    ActiveX起動部品：ClientAddressプロパティ

    Java起動部品：setClientAddressメソッド

    COBOL起動部品：CLIENTADDRパラメタ

    コマンド起動部品：/clientオプション

    255.255.255.255形式

  3. ダイアログの設定

    クライアントPCで帳票を受信したときにダイアログを表示するかどうかを設定します。

    ダイアログの設定

    起動部品の設定項目

    設定する値

    ダイアログを表示するかどうか

    ActiveX起動部品：DispPrintDlgプロパティ

    Java起動部品：setDispPrintDlgメソッド

    COBOL起動部品：DISPPRINTDLGパラメタ

    1（自動印刷）

    3（全自動印刷）※

    コマンド起動部品：/dialogオプション

    auto（自動印刷）

    fullauto（全自動印刷）※

    注※　印刷実行時に印刷中のダイアログが表示されません。

  4. クライアントPCのプリンタの設定

    クライアントPCのプリンタを設定します。クライアントPCのプリンタの設定方法は，プリンタクラス名とプリンタ名の2種類から選択できます。

    クライアントPCのプリンタ

    起動部品の設定項目

    設定する値

    プリンタクラス名

    ActiveX起動部品：PrinterClassNameプロパティ

    Java起動部品：setPrinterClassNameメソッド

    COBOL起動部品：PRINTERCLASSNAMEパラメタ

    コマンド起動部品：/prcオプション

    プリンタクラス名（80バイト以内の文字列）

    プリンタ名

    OS上のプリンタ名

    ActiveX起動部品：ClientPrinterNameプロパティ

    Java起動部品：setClientPrinterNameメソッド

    COBOL起動部品：CLIENTPRINTERNAMEパラメタ

    コマンド起動部品：/pオプション

    プリンタ名（80バイト以内の文字列）

    OS上のプリンタのトレイ名

    ActiveX起動部品：ClientTrayNameプロパティ

    Java起動部品：setClientTrayNameメソッド

    COBOL起動部品：CLIENTTRAYNAMEパラメタ

    コマンド起動部品：/tオプション

    トレイ名（80バイト以内の文字列）

  5. 帳票ファイルの設定

    印刷する帳票ファイル名を設定します。

    帳票ファイルの設定

    起動部品の設定項目

    設定する値

    帳票ファイルの名前

    ActiveX起動部品：ReportFileNameプロパティ

    Java起動部品：setReportFileNameメソッド

    COBOL起動部品：REPORTNAMEパラメタ

    コマンド起動部品：/rfオプション

    帳票ファイル名（255バイト以内の文字列）

  6. マッピングデータファイルの設定

    マッピングデータファイル名を設定します。

    ユーザデータファイルの設定

    起動部品の設定項目

    設定する値

    マッピングデータファイルの名前

    ActiveX起動部品：DataFileNameプロパティ

    Java起動部品：setDataFileNameメソッド

    COBOL起動部品：MAPPINGDATAパラメタ

    コマンド起動部品：/mapオプション

    マッピングデータファイル名（255バイト以内の文字列）

  7. ユーザデータファイル，印刷定義ファイル，および印刷付加情報の設定

    必要に応じて，ユーザデータファイル（ユーザ定義データファイルなど），印刷定義ファイル（複数様式情報定義ファイル，文書情報設定ファイル，置き換え表管理情報ファイルなど）および印刷付加情報（印刷開始ページ，印刷部数，ページ番号など）を設定します。

■参考

5.の帳票ファイルの設定は，帳票ファイル名を直接指定する以外に，次のどちらかを指定することもできます。

  • 帳票セット指定ファイル

    帳票ファイル名やマッピングデータファイル名を，帳票セットとして帳票セット指定ファイルにまとめて指定することができます。出力時には次に示すプロパティ，メソッド，パラメタ，またはオプションで帳票セット指定ファイル名を指定してください。

    ・ActiveX起動部品：MultiReportSetFileNameプロパティ

    ・Java起動部品：setMultiReportSetFileNameメソッド

    ・COBOL起動部品：REPORTSETFILEパラメタ

    ・コマンド起動部品：/mrsオプション

  • 帳票ID

    帳票ファイル名を含む帳票出力で使用する項目を，帳票出力定義として帳票出力定義ファイルに指定することができます。帳票IDには，帳票出力時に使用する帳票出力定義ファイル名を指定します。出力時には次に示すプロパティ，メソッド，パラメタ，またはオプションで帳票出力定義ファイル名を指定してください。

    ・ActiveX起動部品：ReportIDプロパティ

    ・Java起動部品：setReportIDメソッド

    ・COBOL起動部品：REPORTIDパラメタ

    ・コマンド起動部品：/ridオプション

ページの先頭へ

(4)　出力結果

  • クライアントプリンタクラスを指定していた場合

    指定したクライアントプリンタクラスに対応するプリンタとトレイで出力されます。

    指定したクライアントプリンタクラス名がクライアントプリンタクラスに設定されていない場合は，クライアントプリンタクラスに設定したデフォルトのクライアントプリンタクラスのプリンタに出力されます。

    デフォルトのクライアントプリンタクラスの設定がない場合は，クライアントPCの通常使うプリンタに出力されます。クライアントプリンタクラスに指定されたプリンタがクライアントPCに登録されていない場合は，エラーとなります。

  • プリンタとトレイを指定していた場合

    指定されたプリンタとトレイで出力されます。

    プリンタとトレイの指定がなく，クライアントプリンタクラス名が指定されている場合は，上記に示した「クライアントプリンタクラスを指定していた場合」の運用になります。

    指定されたプリンタがクライアントPCに登録されていない場合は，エラーとなります。

なお，どちらの場合も，指定したトレイ名がクライアントPCに登録されていない場合は，デフォルトのトレイで出力されます。

ページの先頭へ

(5)　注意事項

帳票を連続して出力すると，メモリ不足のエラーになることがあります。クライアントPCでメモリ不足のエラーが発生した場合は，時間を置いて再度出力するか，EUR Client Serviceを再起動してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 46 / 218


3.2.2 自動で出力する（配布印刷） : EUR 帳票出力 機能解説 EUR Server編

  • 47 / 218

  • 表紙

  • 3.　出力先を選んで出力する

  • 3.2　クライアントPCのプリンタに出力するには

  • 3.2.2　自動で出力する（配布印刷）

3.2.2　自動で出力する（配布印刷）

同一の帳票を複数のクライアントに配布して出力する方法を，配布印刷といいます。帳票サーバから帳票の印刷データ（EPF形式ファイル）がクライアントPCに配布されると，EUR Client Serviceが起動して帳票を自動で出力できます（自動印刷）。印刷実行時に印刷中ダイアログを表示させないように設定することもできます（全自動印刷）。

自動印刷では，あらかじめ設定したプリンタに帳票が自動で出力されるため，データ受信時にクライアントPCを操作する必要はありません。

〈この項の構成〉

  • (1)　出力の流れ

  • (2)　起動部品の設定

  • (3)　出力結果

  • (4)　注意事項

  • (5)　コーディング例

(1)　出力の流れ

帳票を複数のクライアントPCに配布して出力する流れを，次の図に示します。

図3‒5　帳票を複数のクライアントPCに配布して出力する流れ（自動印刷）

[図データ]

印刷データの生成
1.　出力要求

帳票の出力要求が業務プログラムに送られます。

2.　転送

EUR Server - Adapterは，ユーザデータファイルを帳票サーバのEUR Server Serviceに転送します。

3.　印刷データ生成

転送されたユーザデータファイルとあらかじめ帳票サーバに配置しておいた印刷定義ファイルから，印刷データ（EPF形式ファイル）が生成されます。

なお，手順1.～手順3.で生成された印刷データが複数ある場合，一つの印刷データに統合することもできます。印刷データの統合方法については，「6.3.1　複数のEPF形式ファイルを統合出力する」を参照してください。

配布印刷

手順3.で生成した印刷データを，手順4.～手順5.を繰り返すことで複数のクライアントPCに配布します。

4.　印刷データ転送（EUR Server - AdapterからEUR Server Serviceへ）

EUR Server - Adapterは，生成された印刷データ（EPF形式ファイル）をEUR Server Serviceに転送します。

5.　印刷データ転送（EUR Server ServiceからクライアントPCへ）

EUR Server Serviceは，転送された印刷データ（EPF形式ファイル）をクライアントPCに転送します。

6.　出力

印刷データ（EPF形式ファイル）を受信すると，EUR Client Serviceが起動して，指定したプリンタに自動で出力されます。

ページの先頭へ

(2)　起動部品の設定

(a)　印刷データの生成に関する設定

印刷データの生成で使用する起動部品のメソッド，関数，およびオプションの指定値を次に示します。

  • ActiveX起動部品：OutputEPFReportメソッド

  • Java起動部品：outputEPFReportメソッド

  • COBOL起動部品：OutputEPFReport関数

  • コマンド起動部品（eurpmcコマンド）：/mオプションにepfを指定

また，生成時に設定する起動部品のプロパティ，メソッド，パラメタ，およびオプションの指定値を次に示します。

  1. 帳票ファイルの設定

    印刷する帳票ファイル名を設定します。

    帳票ファイルの設定

    起動部品の設定項目

    設定する値

    帳票ファイルの名前

    ActiveX起動部品：ReportFileNameプロパティ

    Java起動部品：setReportFileNameメソッド

    COBOL起動部品：REPORTNAMEパラメタ

    コマンド起動部品：/rfオプション

    帳票ファイル名（255バイト以内の文字列）

  2. EPF形式ファイルの設定

    EPF形式ファイル名を設定します。

    EPF形式ファイルの設定

    起動部品の設定項目

    設定する値

    EPF形式ファイル名

    ActiveX起動部品：EPFFileNameプロパティ

    Java起動部品：setEPFFileNameメソッド

    COBOL起動部品：EPFFILENAMEパラメタ

    コマンド起動部品：/epfnオプション

    EPF形式ファイル名（255バイト以内の文字列）

  3. マッピングデータファイルの設定

    マッピングデータファイル名を設定します。

    ユーザデータファイルの設定

    起動部品の設定項目

    設定する値

    マッピングデータファイルの名前

    ActiveX起動部品：DataFileNameプロパティ

    Java起動部品：setDataFileNameメソッド

    COBOL起動部品：MAPPINGDATAパラメタ

    コマンド起動部品：/mapオプション

    マッピングデータファイル名（255バイト以内の文字列）

  4. ユーザデータファイル，印刷定義ファイル，および印刷付加情報の設定

    必要に応じて，ユーザデータファイル（ユーザ定義データファイルなど），印刷定義ファイル（複数様式情報定義ファイル，文書情報設定ファイル，置き換え表管理情報ファイルなど）および印刷付加情報（印刷開始ページ，印刷部数，ページ番号など）を設定します。

  5. プリンタクラス名の設定

    同じ帳票が送られてきたときに，前回印刷時に指定したプリンタ名とトレイ名をデフォルト表示するためには，帳票のプリンタクラス名で前回印刷時の情報を記憶させます。

    クライアントPCのプリンタ

    起動部品の設定項目

    設定する値

    プリンタクラス名

    ActiveX起動部品：PrinterClassNameプロパティ

    Java起動部品：setPrinterClassNameメソッド

    COBOL起動部品：PRINTERCLASSNAMEパラメタ

    コマンド起動部品：/prcオプション

    プリンタクラス名（80バイト以内の文字列）
■参考

1.の帳票ファイルの設定は，帳票ファイル名を直接指定する以外に，帳票セット指定ファイルを指定することもできます。

  • 帳票セット指定ファイル

    帳票ファイル名やマッピングデータファイル名を，帳票セットとして帳票セット指定ファイルにまとめて指定することができます。出力時には次に示すプロパティ，メソッド，パラメタ，またはオプションで帳票セット指定ファイル名を指定してください。

    ・ActiveX起動部品：MultiReportSetFileNameプロパティ

    ・Java起動部品：setMultiReportSetFileNameメソッド

    ・COBOL起動部品：REPORTSETFILEパラメタ

    ・コマンド起動部品：/mrsオプション

(b)　配布印刷に関する設定

配布印刷で使用する起動部品のメソッド，関数，およびオプションの指定値を次に示します。

  • ActiveX起動部品：PrintPMReportメソッド

  • Java起動部品：printReportメソッド

  • COBOL起動部品：PrintReport関数またはPrintReport2関数

  • コマンド起動部品：/m print

また，印刷時に設定する起動部品のプロパティ，メソッド，パラメタ，およびオプションの指定値を次に示します。

  1. 配布するEPF形式ファイルの設定

    配布するEPF形式ファイル名を設定します。

    配布するEPF形式ファイル名には，「(a)　印刷データの生成に関する設定」の手順2.で生成したEPF形式ファイル名を設定します。

    EPF形式ファイルの設定

    起動部品の設定項目

    設定する値

    EPF形式ファイル名

    ActiveX起動部品：EPFFileNameプロパティ

    Java起動部品：setEPFFileNameメソッド

    COBOL起動部品：EPFFILENAMEパラメタ

    コマンド起動部品：/epfnオプション

    EPF形式ファイル名（255バイト以内の文字列）

  2. 印刷方法の設定

    帳票を印刷する方法を設定します。

    印刷方法の設定

    起動部品の設定項目

    設定する値

    印刷方法

    ActiveX起動部品：PrintModeプロパティ

    Java起動部品：setPrintModeメソッド

    COBOL起動部品：PRINTMODEパラメタ

    5（クライアントPCに配布印刷する）

    コマンド起動部品：/pmオプション

    clds（クライアントPCに配布印刷する）

  3. クライアントPCの設定

    クライアントPCのIPアドレスを指定します。

    クライアントPCの設定

    起動部品の設定項目

    設定する値

    IPアドレス

    ActiveX起動部品：ClientAddressプロパティ

    Java起動部品：setClientAddressメソッド

    COBOL起動部品：CLIENTADDRパラメタ

    コマンド起動部品：/clientオプション

    255.255.255.255形式

  4. ダイアログの設定

    クライアントPCで帳票を受信したときにダイアログを表示するかどうかを設定します。

    ダイアログの設定

    起動部品の設定項目

    設定する値

    ダイアログを表示するかどうか

    ActiveX起動部品：DispPrintDlgプロパティ

    Java起動部品：setDispPrintDlgメソッド

    COBOL起動部品：DISPPRINTDLGパラメタ

    1（自動印刷）

    3（全自動印刷）※

    コマンド起動部品：/dialogオプション

    auto（自動印刷）

    fullauto（全自動印刷）※

    注※　印刷実行時に印刷中のダイアログが表示されません。

  5. クライアントPCのプリンタの設定

    クライアントPCのプリンタを設定します。

    クライアントPCのプリンタ

    起動部品の設定項目

    設定する値

    プリンタ名

    OS上のプリンタ名

    ActiveX起動部品：ClientPrinterNameプロパティ

    Java起動部品：setClientPrinterNameメソッド

    COBOL起動部品：CLIENTPRINTERNAMEパラメタ

    コマンド起動部品：/pオプション

    プリンタ名（80バイト以内の文字列）

    OS上のプリンタのトレイ名

    ActiveX起動部品：ClientTrayNameプロパティ

    Java起動部品：setClientTrayNameメソッド

    COBOL起動部品：CLIENTTRAYNAMEパラメタ

    コマンド起動部品：/tオプション

    トレイ名（80バイト以内の文字列）

ページの先頭へ

(3)　出力結果

「3.2.1(4)　出力結果」を参照してください。

ページの先頭へ

(4)　注意事項

帳票を連続して出力すると，メモリ不足のエラーになることがあります。クライアントPCでメモリ不足のエラーが発生した場合は，時間を置いて再度出力するか，EUR Client Serviceを再起動してください。

ページの先頭へ

(5)　コーディング例

次に示すパラメタを指定して，クライアントPCへの配布印刷をします。

■入力ファイル（EPF形式データ）：EUR Server - Adapter稼働マシンに配置

EPF形式ファイル名：sample1_EPF.epf

EPF形式ファイルパス：c:\Temp

■そのほかの設定

印刷方式：5

クライアントPCのIPアドレス：127.0.0.1

コーディング例を次に示します。

(a)　Java起動部品の場合

import JP.co.Hitachi.soft.EURPM.*;

    try {
      EURPMAdapterForJava obj=new EURPMAdapterForJava();

      String target = request.getRemoteAddr();

      obj.setEPFFileName("sample1_EPF.epf");
                          //EPF形式ファイル名の指定
      obj.setEPFFilePath("c:\\Temp");
                          //EPF形式ファイルパスの指定
      obj.setPrintMode(5);
                          //印刷方式の指定
      obj.setClientAddress("127.0.0.1");
                          //クライアントPCのIPアドレスの指定
      obj.printReport();
                          //帳票の出力指示
    }
    catch (JP.co.Hitachi.soft.EURPM.EURPMException ce) {
                                    //エラー処理
      int errid;
      errid=ce.getErrorCode();
                     //エラーコードをerridに取り出す
      if (errid==301) {
                     //KEEY301-Eの場合のエラー処理
      } else if (errid==   {
                     //以下，そのほかのエラー処理を繰り返す
              :
      }
    }

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 47 / 218


3.2.3 ダイアログでプリンタを設定して出力する : EUR 帳票出力 機能解説 EUR Server編

  • 48 / 218

  • 表紙

  • 3.　出力先を選んで出力する

  • 3.2　クライアントPCのプリンタに出力するには

  • 3.2.3　ダイアログでプリンタを設定して出力する

3.2.3　ダイアログでプリンタを設定して出力する

帳票サーバから帳票の印刷データ（EPF形式ファイル）がクライアントPCに転送されると，EUR Client Serviceが起動して出力先を設定するダイアログが表示されます（対話型印刷）。ダイアログでプリンタとトレイを設定して帳票を出力します。

〈この項の構成〉

  • (1)　出力の流れ

  • (2)　起動部品の設定

  • (3)　出力で使用するダイアログ

  • (4)　注意事項

(1)　出力の流れ

帳票をクライアントPCに転送して出力する流れを，次の図に示します。

図3‒6　帳票をクライアントPCに転送して出力する流れ（対話型印刷）

[図データ]

  1. 出力要求

    帳票の出力要求が業務プログラムに送られます。

  2. 転送

    アプリケーションサーバのEUR Server - Adapterは，ユーザデータファイルを帳票サーバのEUR Server Serviceに転送します。

  3. 印刷データ生成

    転送されたユーザデータファイルとあらかじめ帳票サーバに配置しておいた印刷定義ファイルから，印刷データ（EPF形式ファイル）が生成されます。

  4. 印刷データ転送

    EUR Server Serviceは，生成された印刷データ（EPF形式ファイル）をクライアントPCに転送します。

  5. ［印刷先指定］ダイアログの表示

    印刷データ（EPF形式ファイル）を受信すると，EUR Client Serviceが起動して，出力先を設定するダイアログが表示されます。

  6. プリンタの選択

    ［プリンタ］リストボックスで，クライアントPCのプリンタを選択します。

  7. トレイの選択

    ［トレイ］リストボックスで，出力で使用するトレイを選択します。

  8. ［OK］ボタンのクリック

    指定したプリンタのトレイで帳票が出力されます。

ページの先頭へ

(2)　起動部品の設定

帳票出力で使用する起動部品のメソッド，関数，およびオプションの指定値を次に示します。

  • ActiveX起動部品：PrintPMReportメソッド

  • Java起動部品：printReportメソッド

  • COBOL起動部品：PrintReport関数またはPrintReport2関数

  • コマンド起動部品（eurpmcコマンド）：/mオプションにprintを指定

また，出力時に設定する起動部品のプロパティ，メソッド，パラメタ，およびオプションの指定値を次に示します。

  1. 印刷方法の設定

    帳票を印刷する方法を設定します。

    印刷方法の設定

    起動部品の設定項目

    設定する値

    印刷方法

    ActiveX起動部品：PrintModeプロパティ

    Java起動部品：setPrintModeメソッド

    COBOL起動部品：PRINTMODEパラメタ

    1（クライアントPCで印刷する）

    コマンド起動部品：/pmオプション

    cl（クライアントPCで印刷する）

  2. クライアントPCの設定

    クライアントPCのIPアドレスを指定します。

    クライアントPCの設定

    起動部品の設定項目

    設定する値

    IPアドレス

    ActiveX起動部品：ClientAddressプロパティ

    Java起動部品：setClientAddressメソッド

    COBOL起動部品：CLIENTADDRパラメタ

    コマンド起動部品：/clientオプション

    255.255.255.255形式

  3. ダイアログの設定

    クライアントPCで帳票を受信したときにダイアログを表示するかどうかを設定します。

    ダイアログの設定

    起動部品の設定項目

    設定する値

    ダイアログを表示するかどうか

    ActiveX起動部品：DispPrintDlgプロパティ

    Java起動部品：setDispPrintDlgメソッド

    COBOL起動部品：DISPPRINTDLGパラメタ

    0（対話型印刷）

    コマンド起動部品：/dialogオプション

    dialog（対話型印刷）

  4. プリンタクラス名の設定

    同じ帳票が送られてきたときに，前回印刷時に指定したプリンタ名とトレイ名をデフォルト表示するためには，帳票のプリンタクラス名で前回印刷時の情報を記憶させます。

    プリンタクラス名の設定

    起動部品の設定項目

    設定する値

    プリンタクラス名

    ActiveX起動部品：PrinterClassNameプロパティ

    Java起動部品：setPrinterClassNameメソッド

    COBOL起動部品：PRINTERCLASSNAMEパラメタ

    コマンド起動部品：/prcオプション

    プリンタクラス名（80バイト以内の文字列）

  5. 帳票ファイルの設定

    印刷する帳票ファイル名を設定します。

    帳票ファイルの設定

    起動部品の設定項目

    設定する値

    帳票ファイルの名前

    ActiveX起動部品：ReportFileNameプロパティ

    Java起動部品：setReportFileNameメソッド

    COBOL起動部品：REPORTNAMEパラメタ

    コマンド起動部品：/rfオプション

    帳票ファイル名（255バイト以内の文字列）

  6. マッピングデータファイルの設定

    マッピングデータファイル名を設定します。

    ユーザデータファイルの設定

    起動部品の設定項目

    設定する値

    マッピングデータファイルの名前

    ActiveX起動部品：DataFileNameプロパティ

    Java起動部品：setDataFileNameメソッド

    COBOL起動部品：MAPPINGDATAパラメタ

    コマンド起動部品：/mapオプション

    マッピングデータファイル名（255バイト以内の文字列）

  7. ユーザデータファイル，印刷定義ファイル，および印刷付加情報の設定

    必要に応じて，ユーザデータファイル（ユーザ定義データファイルなど），印刷定義ファイル（複数様式情報定義ファイル，文書情報設定ファイル，置き換え表管理情報ファイルなど）および印刷付加情報（印刷開始ページ，印刷部数，ページ番号など）を設定します。

■参考

5.の帳票ファイルの設定は，帳票ファイル名を直接指定する以外に，次のどちらかを指定することもできます。

  • 帳票セット指定ファイル

    帳票ファイル名やマッピングデータファイル名を，帳票セットとして帳票セット指定ファイルにまとめて指定することができます。出力時には次に示すプロパティ，メソッド，パラメタ，またはオプションで帳票セット指定ファイル名を指定してください。

    ・ActiveX起動部品：MultiReportSetFileNameプロパティ

    ・Java起動部品：setMultiReportSetFileNameメソッド

    ・COBOL起動部品：REPORTSETFILEパラメタ

    ・コマンド起動部品：/mrsオプション

  • 帳票ID

    帳票ファイル名を含む帳票出力で使用する項目を，帳票出力定義として帳票出力定義ファイルに指定することができます。帳票IDには，帳票出力時に使用する帳票出力定義ファイル名を指定します。出力時には次に示すプロパティ，メソッド，パラメタ，またはオプションで帳票出力定義ファイル名を指定してください。

    ・ActiveX起動部品：ReportIDプロパティ

    ・Java起動部品：setReportIDメソッド

    ・COBOL起動部品：REPORTIDパラメタ

    ・コマンド起動部品：/ridオプション

ページの先頭へ

(3)　出力で使用するダイアログ

(a)　［印刷先指定］ダイアログ

EUR Client Serviceが印刷データ（EPF形式ファイル）を受信すると，［印刷先指定］ダイアログが表示されます。［印刷先指定］ダイアログでは，出力で使用するプリンタやトレイを選択します。

［帳票ジョブ名］

クライアントプリンタクラス名を表示します。クライアントプリンタクラスが指定されていない場合は，帳票名を表示します。

［プリンタ］リストボックス

クライアントPCに登録されたプリンタ名を表示します。

［プリンタ］リストボックスに初期表示されるプリンタ名は，EUR Client Serviceの環境設定ファイルのSELECTDISPLAYPRINTERキーの指定で変更できます。

［プリンタ］リストボックスは，プリンタの種類と状態を次に示すアイコンで示します。

  • [図データ] ：OS上の通常使うプリンタ

  • [図データ] ：OS上の通常使うプリンタ以外のOSに登録されているプリンタ

［トレイ］リストボックス

プリンタ名を選択すると，OS上に登録されたプリンタ名のトレイ名を表示します。トレイを指定しなかった場合は，デフォルトのトレイに印刷されます。

印刷したことがある帳票ジョブを受信した場合で，［プリンタ］リストボックスに初期表示されるプリンタ名が，前回の受信時に設定したプリンタ名のときは，前回の受信時に設定したトレイ名が表示されます。

それ以外の場合は，トレイ名は表示されません。

［プレビュー］ボタン

印刷する帳票のプレビューウィンドウを表示します。

［+］ボタン

［印刷先指定］ダイアログが拡張されて，［印刷オプション］を設定できます。

［－］ボタン

［印刷オプション］の設定が非表示になります。

［ページ指定］

印刷開始ページと印刷終了ページを指定します。

  • 印刷開始ページ

    初期表示は1（ページ）です。入力できる値は，1～999,999です。帳票の最終ページを超える値を指定した場合は，最終ページだけ印刷されます。

  • 印刷終了ページ

    初期表示は，帳票の最終ページです。入力できる値は，1～999,999です。帳票の最終ページを超える値を指定した場合は，最終ページまで印刷されます。

(b)　プレビューウィンドウ

［印刷先指定］ダイアログの［プレビュー］ボタンをクリックすると，プレビューウィンドウが表示されます。プレビューウィンドウでは，帳票の印刷イメージを確認できます。

表3‒2 プレビューウィンドウのメニュー（対話型印刷）
メニュー |  | 機能 | ボタン
ファイル(F) | プロパティ(P) | ［プロパティ］ダイアログが表示されます。［プロパティ］ダイアログについては，「3.3.1(3)(b) ［プロパティ］ダイアログ」を参照してください。 | [図データ]
 | 終了(X) | プレビューウィンドウが終了します。 | －
編集(E) | 検索(F) | ［検索］ダイアログが表示されます。［検索］ダイアログについては，「3.3.1(3)(c) ［検索］ダイアログ」を参照してください。 | [図データ]
 | 次を検索(N) | ［検索］ダイアログで前回実行した検索の内容に従って，次の検索を実行します。一度も検索を実行していない場合は，［検索］ダイアログが表示されます。 | －
表示(V) | ツールバー(T) | チェックを入れると，ツールバーが表示されます。 | －
 | ステータスバー(S) | チェックを入れると，ステータスバーが表示されます。 | －
 | 先頭ページ(O) | 先頭ページに移動します。 | [図データ]
 | 前ページ(B) | 前ページに移動します。 | [図データ]
 | 次ページ(N) | 次ページに移動します。 | [図データ]
 | 最終ページ(L) | 最終ページに移動します。 | [図データ]
 | 指定ページへジャンプ(J) | ［指定ページへジャンプ］ダイアログが表示されます。指定したページに移動します。［指定ページへジャンプ］ダイアログについては，「3.3.1(3)(d) ［指定ページへジャンプ］ダイアログ」を参照してください。 | [図データ]
 | 拡大(U) | 表示された帳票を拡大します。10%ずつ拡大します。 | [図データ]
 | 縮小(D) | 表示された帳票を縮小します。10%ずつ縮小します。 | [図データ]
 | 拡大率の指定(P) | ［拡大率の指定］ダイアログが表示されます。指定した拡大率で帳票が表示されます。［拡大率の指定］ダイアログについては，「3.3.1(3)(e) ［拡大率の指定］ダイアログ」を参照してください。 | [図データ]
ヘルプ(H) | ヘルプ(E) | 常に不活性です。 | [図データ]
 | バージョン情報(A) | ［バージョン情報］ダイアログが表示されます。 | －

ページの先頭へ

(4)　注意事項

帳票を連続して出力すると，メモリ不足のエラーになることがあります。クライアントPCでメモリ不足のエラーが発生した場合は，時間を置いて再度出力するか，EUR Client Serviceを再起動してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 48 / 218


3.2.4 ダイアログでプリンタを設定して出力する（配布印刷） : EUR 帳票出力 機能解説 EUR Server編

  • 49 / 218

  • 表紙

  • 3.　出力先を選んで出力する

  • 3.2　クライアントPCのプリンタに出力するには

  • 3.2.4　ダイアログでプリンタを設定して出力する（配布印刷）

3.2.4　ダイアログでプリンタを設定して出力する（配布印刷）

同一の帳票を複数のクライアントに配布して出力する方法を，配布印刷といいます。帳票サーバから帳票の印刷データ（EPF形式ファイル）がクライアントPCに配布されると，EUR Client Serviceが起動して出力先を設定するダイアログが表示されます（対話型印刷）。ダイアログでプリンタとトレイを設定して帳票を出力します。

〈この項の構成〉

  • (1)　出力の流れ

  • (2)　起動部品の設定

  • (3)　出力で使用するダイアログ

  • (4)　注意事項

(1)　出力の流れ

帳票を複数のクライアントPCに配布して出力する流れを，次の図に示します。

図3‒7　帳票を複数のクライアントPCに配布して出力する流れ（対話型印刷）

[図データ]

印刷データの生成
1.　出力要求

帳票の出力要求が業務プログラムに送られます。

2.　転送

EUR Server - Adapterは，ユーザデータファイルを帳票サーバのEUR Server Serviceに転送します。

3.　印刷データ生成

転送されたユーザデータファイルとあらかじめ帳票サーバに配置しておいた印刷定義ファイルから，印刷データ（EPF形式ファイル）が生成されます。

なお，手順1.～手順3.で生成された印刷データが複数ある場合，一つの印刷データに統合することもできます。印刷データの統合方法については，「6.3.1　複数のEPF形式ファイルを統合出力する」を参照してください。

配布印刷

手順3.で生成した印刷データを，手順4.～手順5.を繰り返すことで複数のクライアントPCに配布します。

4.　印刷データ転送（EUR Server - AdapterからEUR Server Serviceへ）

EUR Server - Adapterは，生成された印刷データ（EPF形式ファイル）をEUR Server Serviceに転送します。

5.　印刷データ転送（EUR Server ServiceからクライアントPCへ）

EUR Server Serviceは，転送された印刷データ（EPF形式ファイル）をクライアントPCに転送します。

6.　［印刷先指定］ダイアログの表示

印刷データ（EPF形式ファイル）を受信すると，EUR Client Serviceが起動して，出力先を設定するダイアログが表示されます。

7.　プリンタの選択

［プリンタ］リストボックスで，クライアントPCのプリンタを選択します。

8.　トレイの選択

［トレイ］リストボックスで，出力で使用するトレイを選択します。

9.　［OK］ボタンのクリック

指定したプリンタのトレイで帳票が出力されます。

ページの先頭へ

(2)　起動部品の設定

(a)　印刷データの生成に関する設定

印刷データの生成で使用する起動部品のメソッド，関数，およびオプションの指定値を次に示します。

  • ActiveX起動部品：OutputEPFReportメソッド

  • Java起動部品：outputEPFReportメソッド

  • COBOL起動部品：OutputEPFReport関数

  • コマンド起動部品（eurpmcコマンド）：/mオプションにepfを指定

また，生成時に設定する起動部品のプロパティ，メソッド，パラメタ，およびオプションの指定値を次に示します。

  1. 帳票ファイルの設定

    印刷する帳票ファイル名を設定します。

    帳票ファイルの設定

    起動部品の設定項目

    設定する値

    帳票ファイルの名前

    ActiveX起動部品：ReportFileNameプロパティ

    Java起動部品：setReportFileNameメソッド

    COBOL起動部品：REPORTNAMEパラメタ

    コマンド起動部品：/rfオプション

    帳票ファイル名（255バイト以内の文字列）

  2. EPF形式ファイルの設定

    EPF形式ファイル名を設定します。

    EPF形式ファイルの設定

    起動部品の設定項目

    設定する値

    EPF形式ファイル名

    ActiveX起動部品：EPFFileNameプロパティ

    Java起動部品：setEPFFileNameメソッド

    COBOL起動部品：EPFFILENAMEパラメタ

    コマンド起動部品：/epfnオプション

    EPF形式ファイル名（255バイト以内の文字列）

  3. マッピングデータファイルの設定

    マッピングデータファイル名を設定します。

    ユーザデータファイルの設定

    起動部品の設定項目

    設定する値

    マッピングデータファイルの名前

    ActiveX起動部品：DataFileNameプロパティ

    Java起動部品：setDataFileNameメソッド

    COBOL起動部品：MAPPINGDATAパラメタ

    コマンド起動部品：/mapオプション

    マッピングデータファイル名（255バイト以内の文字列）

  4. ユーザデータファイル，印刷定義ファイル，および印刷付加情報の設定

    必要に応じて，ユーザデータファイル（ユーザ定義データファイルなど），印刷定義ファイル（複数様式情報定義ファイル，文書情報設定ファイル，置き換え表管理情報ファイルなど）および印刷付加情報（印刷開始ページ，印刷部数，ページ番号など）を設定します。

  5. プリンタクラス名の設定

    同じ帳票が送られてきたときに，前回印刷時に指定したプリンタ名とトレイ名をデフォルト表示するためには，帳票のプリンタクラス名で前回印刷時の情報を記憶させます。

    クライアントPCのプリンタ

    起動部品の設定項目

    設定する値

    プリンタクラス名

    ActiveX起動部品：PrinterClassNameプロパティ

    Java起動部品：setPrinterClassNameメソッド

    COBOL起動部品：PRINTERCLASSNAMEパラメタ

    コマンド起動部品：/prcオプション

    プリンタクラス名（80バイト以内の文字列）
■参考

帳票ファイル名やマッピングデータファイル名を起動部品で直接指定するのではなく，帳票セットとして帳票セット指定ファイルにまとめて指定することもできます。この場合，出力時には次に示すプロパティ，メソッド，パラメタ，またはオプションで帳票セット指定ファイル名を指定してください。

  • ActiveX起動部品：MultiReportSetFileNameプロパティ

  • Java起動部品：setMultiReportSetFileNameメソッド

  • COBOL起動部品：REPORTSETFILEパラメタ

  • コマンド起動部品：/mrsオプション

(b)　配布印刷に関する設定

配布印刷で使用する起動部品のメソッド，関数，およびオプションの指定値を次に示します。

  • ActiveX起動部品：PrintPMReportメソッド

  • Java起動部品：printReportメソッド

  • COBOL起動部品：PrintReport関数またはPrintReport2関数

  • コマンド起動部品（eurpmcコマンド）：/mオプションにprintを指定

また，印刷時に設定する起動部品のプロパティ，メソッド，パラメタ，およびオプションの指定値を次に示します。

  1. 配布するEPF形式ファイルの設定

    配布するEPF形式ファイル名を設定します。

    配布するEPF形式ファイル名には，「(a)　印刷データの生成に関する設定」の手順2.で生成したEPF形式ファイル名を設定します。

    EPF形式ファイルの設定

    起動部品の設定項目

    設定する値

    EPF形式ファイル名

    ActiveX起動部品：EPFFileNameプロパティ

    Java起動部品：setEPFFileNameメソッド

    COBOL起動部品：EPFFILENAMEパラメタ

    コマンド起動部品：/epfnオプション

    EPF形式ファイル名（255バイト以内の文字列）

  2. 印刷方法の設定

    帳票を印刷する方法を設定します。

    印刷方法の設定

    起動部品の設定項目

    設定する値

    印刷方法

    ActiveX起動部品：PrintModeプロパティ

    Java起動部品：setPrintModeメソッド

    COBOL起動部品：PRINTMODEパラメタ

    5（クライアントPCに配布印刷する）

    コマンド起動部品：/pmオプション

    clds（クライアントPCに配布印刷する）

  3. クライアントPCの設定

    クライアントPCのIPアドレスを指定します。

    クライアントPCの設定

    起動部品の設定項目

    設定する値

    IPアドレス

    ActiveX起動部品：ClientAddressプロパティ

    Java起動部品：setClientAddressメソッド

    COBOL起動部品：CLIENTADDRパラメタ

    コマンド起動部品：/clientオプション

    255.255.255.255形式

  4. ダイアログの設定

    クライアントPCで帳票を受信したときに印刷ダイアログを表示するかどうかを設定します。

    ダイアログの設定

    起動部品の設定項目

    設定する値

    ダイアログを表示するかどうか

    ActiveX起動部品：DispPrintDlgプロパティ

    Java起動部品：setDispPrintDlgメソッド

    COBOL起動部品：DISPPRINTDLGパラメタ

    0（対話型印刷）

    コマンド起動部品：/dialogオプション

    dialog（対話型印刷）

ページの先頭へ

(3)　出力で使用するダイアログ

「3.2.3(3)　出力で使用するダイアログ」を参照してください。

ページの先頭へ

(4)　注意事項

帳票を連続して出力すると，メモリ不足のエラーになることがあります。クライアントPCでメモリ不足のエラーが発生した場合は，時間を置いて再度出力するか，EUR Client Serviceを再起動してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 49 / 218


3.2.5 EUR Web Plug-Inを使用して出力する : EUR 帳票出力 機能解説 EUR Server編

  • 50 / 218

  • 表紙

  • 3.　出力先を選んで出力する

  • 3.2　クライアントPCのプリンタに出力するには

  • 3.2.5　EUR Web Plug-Inを使用して出力する

3.2.5　EUR Web Plug-Inを使用して出力する

EUR Web Plug-Inを使用してWebブラウザから帳票を出力する方法を，ActiveXクライアント印刷といいます。クライアントPCのWebブラウザから，Webサーバにアクセスして印刷データ（EPF形式ファイル）をダウンロードすると，クライアントPCのEUR Web Plug-Inによって帳票が出力されます。

〈この項の構成〉

  • (1)　出力の流れ

  • (2)　Webページの設定

  • (3)　起動部品の設定

  • (4)　出力結果

  • (5)　出力で使用するダイアログ

  • (6)　注意事項

  • (7)　コーディング例

(1)　出力の流れ

EUR Web Plug-Inを使用して帳票を出力する流れを，次の図に示します。

図3‒8　EUR Web Plug-Inを使用して帳票を出力する流れ（ActiveXクライアント印刷）

[図データ]

  1. 出力要求

    帳票の出力要求が業務プログラムに送られます。

  2. 転送

    アプリケーションサーバのEUR Server - Adapterは，ユーザデータファイルを帳票サーバのEUR Server Serviceに転送します。

  3. 印刷データ生成

    転送されたユーザデータファイルとあらかじめ帳票サーバに配置しておいた印刷定義ファイルから，印刷データ（EPF形式ファイル）が生成されます。

    なお，手順1.～手順3.で生成された印刷データが複数ある場合，一つの印刷データに統合することもできます。印刷データの統合方法については，「6.3.1　複数のEPF形式ファイルを統合出力する」を参照してください。

  4. 印刷データ転送

    EUR Server Serviceは，生成された印刷データ（EPF形式ファイル）をアプリケーションサーバに転送します。

  5. ダウンロード

    クライアントPCのWebブラウザから，Webサーバにアクセスして印刷データ（EPF形式ファイル）をダウンロードします。

    Webサーバとアプリケーションサーバが別マシンであったり，ネットワークを共有していたりする場合は，業務プログラム側でアプリケーションサーバの印刷データ（EPF形式ファイル）をWebサーバに転送しておいてください。

  6. 出力

    印刷データ（EPF形式ファイル）のダウンロードが完了すると，EUR Web Plug-Inによって帳票が出力されます。

ページの先頭へ

(2)　Webページの設定

帳票をダウンロードするWebページに，ダウンロードで使用するEUR Web Plug-Inのパラメタを<object>タグを使用して記述します。<object>タグの記述内容は，EUR Web Plug-Inのインストール方法によって異なります。<object>タグの記述内容については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

  • 出力するファイルの設定

    出力するファイルをダウンロードするURLは，EUR Web Plug-InのEPFFileURLパラメタで指定します。

  • プリンタの指定方法の設定

    プリンタの指定方法には，次の3種類の方法があります。

    • 印刷するプリンタとトレイを指定する

    • 通常使うプリンタを指定する

    • ダイアログでプリンタを選択する

    ダイアログでプリンタを選択する場合は，表示するダイアログと初期表示するプリンタ名の表示モードを指定できます。

    プリンタの指定方法と関係する部品の設定項目を，次に示します。指定方法のどれか一つを設定してください。

    プリンタの指定方法

    EUR Web Plug-Inの設定項目

    指定する値

    印刷するプリンタとトレイを指定する※1

    OS上のプリンタ名

    PrinterNameパラメタ

    プリンタ名（80バイト以内の文字列）

    OS上のプリンタのトレイ名

    TrayNameパラメタ

    トレイ名（80バイト以内の文字列）

    通常使うプリンタを指定する※2

    NoSetPrinterDlgパラメタ

    YES（通常使うプリンタを指定する）

    NO（通常使うプリンタを指定しない）

    ダイアログでプリンタを選択する

    表示するダイアログ

    DefaultPrintDlgパラメタ

    YES（OSの印刷ダイアログを表示する）

    NO（EUR Web Plug-Inの［印刷先指定］ダイアログ※3を表示する）

    初期表示するプリンタ名の表示モード

    SelectDisplayPrinterパラメタ，SelectDisplayPrinterプロパティ

    0（標準モード）

    1（通常使うプリンタ初期表示モード）
    注※1

    存在するプリンタとトレイを指定した場合，通常使うプリンタの指定，およびダイアログでのプリンタ選択の指定は無視されます。

    注※2

    通常使うプリンタを指定した場合の注意事項を次に示します。

    ・ダイアログでのプリンタ選択の指定は無視されます。

    ・通常使うプリンタのプリンタ名，またはプリンタドライバ名が，EUR Web Plug-InのExclusionPrinterNameプロパティ，またはExclusionPrinterDriverプロパティに指定されている場合はエラーになります。

    ・通常使うプリンタのプリンタ名，またはプリンタドライバ名が，EUR Web Plug-InのPermissionPrinterNameプロパティ，またはPermissionPrinterDriverプロパティに指定されていない場合はエラーになります。

    注※3

    ・EUR Web Plug-InのPermissionPrinterNameプロパティ，またはPermissionPrinterDriverプロパティで，EUR Web Plug-Inの［印刷先指定］ダイアログのプリンタ一覧に表示できるプリンタを指定できます。

    ・EUR Web Plug-InのExclusionPrinterNameプロパティ，またはExclusionPrinterDriverプロパティで，EUR Web Plug-Inの［印刷先指定］ダイアログのプリンタ一覧で非表示にするプリンタを指定できます。

EUR Web Plug-InのExclusionPrinterNameプロパティ，ExclusionPrinterDriverプロパティ，PermissionPrinterNameプロパティ，およびPermissionPrinterDriverプロパティの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

(3)　起動部品の設定

帳票出力で使用する起動部品のメソッド，関数，およびオプションの指定値を次に示します。

  • ActiveX起動部品：OutputEPFReportメソッド

  • Java起動部品：outputEPFReportメソッド

  • COBOL起動部品：OutputEPFReport関数

  • コマンド起動部品（eurpmcコマンド）：/mオプションにepfを指定

また，出力時に設定する起動部品のプロパティ，メソッド，パラメタ，およびオプションの指定値を次に示します。

  1. 帳票ファイルの設定

    印刷する帳票ファイル名を設定します。

    帳票ファイルの設定

    起動部品の設定項目

    設定する値

    帳票ファイルの名前

    ActiveX起動部品：ReportFileNameプロパティ

    Java起動部品：setReportFileNameメソッド

    COBOL起動部品：REPORTNAMEパラメタ

    コマンド起動部品：/rfオプション

    帳票ファイル名（255バイト以内の文字列）

  2. EPF形式ファイルの設定

    EPF形式ファイル名を設定します。

    EPF形式ファイルの設定

    起動部品の設定項目

    設定する値

    EPF形式ファイル名

    ActiveX起動部品：EPFFileNameプロパティ

    Java起動部品：setEPFFileNameメソッド

    COBOL起動部品：EPFFILENAMEパラメタ

    コマンド起動部品：/epfnオプション

    EPF形式ファイル名（255バイト以内の文字列）

  3. マッピングデータファイルの設定

    マッピングデータファイル名を設定します。

    ユーザデータファイルの設定

    起動部品の設定項目

    設定する値

    マッピングデータファイルの名前

    ActiveX起動部品：DataFileNameプロパティ

    Java起動部品：setDataFileNameメソッド

    COBOL起動部品：MAPPINGDATAパラメタ

    コマンド起動部品：/mapオプション

    マッピングデータファイル名（255バイト以内の文字列）

  4. ユーザデータファイル，印刷定義ファイル，および印刷付加情報の設定

    必要に応じて，ユーザデータファイル（ユーザ定義データファイルなど），印刷定義ファイル（複数様式情報定義ファイル，文書情報設定ファイル，置き換え表管理情報ファイルなど）および印刷付加情報（印刷開始ページ，印刷部数，ページ番号など）を設定します。

■参考

帳票ファイル名やマッピングデータファイル名を起動部品で直接指定するのではなく，帳票セットとして帳票セット指定ファイルにまとめて指定することもできます。この場合，出力時には次に示すプロパティ，メソッド，パラメタ，またはオプションで帳票セット指定ファイル名を指定してください。

  • ActiveX起動部品：MultiReportSetFileNameプロパティ

  • Java起動部品：setMultiReportSetFileNameメソッド

  • COBOL起動部品：REPORTSETFILEパラメタ

  • コマンド起動部品：/mrsオプション

ページの先頭へ

(4)　出力結果

次の表に示すように，出力時のEUR Web Plug-Inのパラメタの指定内容によって，出力結果が異なります。

表3‒3　出力時のEUR Web Plug-Inのパラメタの指定内容と出力結果

出力時のEUR Web Plug-Inのパラメタの指定内容

出力結果

プリンタ（PrinterNameパラメタ）

トレイ（TrayNameパラメタ）

プリンタ選択ダイアログの表示（NoSetPrinterDlgパラメタ）

プリンタ選択ダイアログの種類

（DefaultPrintDlgパラメタ）

プリンタ選択ダイアログに初期表示するプリンタ名の表示モード（SelectDisplayPrinterパラメタ，SelectDisplayPrinterプロパティ）

○

○

－

－

－

指定されたプリンタとトレイで自動出力されます。

×

－

－

－

指定したプリンタと指定したプリンタの標準のトレイで自動出力されます。

×

－

YES（通常使うプリンタを指定する）

－

－

クライアントPCの「通常使うプリンタ」で自動出力されます。※1

NO（通常使うプリンタを指定しない）

YES（OSの印刷ダイアログを表示する）

0（標準モード）

OSの印刷ダイアログが表示されます。

次に示すプリンタ名が初期表示されます。

初めて印刷する帳票ジョブを受信した場合

通常使うプリンタのプリンタ名が表示されます。

印刷したことがある帳票ジョブを受信した場合

前回の受信時に設定したプリンタ名が表示されます。※2

1（通常使うプリンタ初期表示モード）

OSの印刷ダイアログが表示されます。

次に示すプリンタ名が初期表示されます。

初めて印刷する帳票ジョブを受信した場合

通常使うプリンタのプリンタ名が表示されます。

印刷したことがある帳票ジョブを受信した場合

通常使うプリンタのプリンタ名が表示されます。

NO（EUR Web Plug-Inの［印刷先指定］ダイアログを表示する）

0（標準モード）

［印刷先指定］ダイアログが表示されます。

次に示すプリンタ名が初期表示されます。

初めて印刷する帳票ジョブを受信した場合

プリンタ名は表示されません。※3

印刷したことがある帳票ジョブを受信した場合

前回の受信時に設定したプリンタ名が表示されます。※4

1（通常使うプリンタ初期表示モード）

［印刷先指定］ダイアログが表示されます。

次に示すプリンタ名が初期表示されます。※5

初めて印刷する帳票ジョブを受信した場合

通常使うプリンタのプリンタ名が表示されます。

印刷したことがある帳票ジョブを受信した場合

通常使うプリンタのプリンタ名が表示されます。
（凡例）

○：存在するプリンタ名，またはトレイ名をパラメタに指定している場合。

×：パラメタに指定したプリンタ名，またはトレイ名が存在しない場合。または，プリンタ名，およびトレイ名を指定していない場合。

－：パラメタの指定は無視されます。

注※1

  • 通常使うプリンタのプリンタ名，またはプリンタドライバ名が，EUR Web Plug-InのExclusionPrinterNameプロパティ，またはExclusionPrinterDriverプロパティに指定されている場合はエラーになります。

  • 通常使うプリンタのプリンタ名，またはプリンタドライバ名が，EUR Web Plug-InのPermissionPrinterNameプロパティ，またはPermissionPrinterDriverプロパティに指定されていない場合はエラーになります。

注※2

前回の受信時に設定したプリンタ名のプリンタが存在しない場合，通常使うプリンタのプリンタ名が表示されます。

注※3

ExclusionPrinterNameプロパティ，またはExclusionPrinterDriverプロパティが指定されている場合，次のどちらかの条件を満たすときは，通常使うプリンタのプリンタ名が表示されます。

  • ExclusionPrinterNameプロパティ，またはExclusionPrinterDriverプロパティの指定が有効，かつ指定値に通常使うプリンタのプリンタ名が指定されていないとき

  • PermissionPrinterNameプロパティ，またはPermissionPrinterDriverプロパティの指定が有効，かつ指定値に通常使うプリンタのプリンタ名が指定されているとき

注※4

前回の受信時に設定したプリンタ名が存在しない場合，またはプロパティ（ExclusionPrinterNameプロパティ，ExclusionPrinterDriverプロパティ，PermissionPrinterNameプロパティ，またはPermissionPrinterDriverプロパティ）の指定によってプリンタ名が表示できない場合は，次に示すプリンタ名が表示されます。

  • 注※3の条件を満たすときは，通常使うプリンタのプリンタ名が表示されます。

  • 注※5の条件を満たすときは，プリンタ名は表示されません。

  • ExclusionPrinterNameプロパティ，またはExclusionPrinterDriverプロパティが指定されていないときは，プリンタ名は表示されません。

注※5

次のどちらかの条件を満たす場合，プリンタ名は表示されません。

  • ExclusionPrinterNameプロパティ，またはExclusionPrinterDriverプロパティの指定が有効，かつ指定値に通常使うプリンタのプリンタ名が指定されているとき

  • PermissionPrinterNameプロパティ，またはPermissionPrinterDriverプロパティの指定が有効，かつ指定値に通常使うプリンタのプリンタ名が指定されていないとき

ページの先頭へ

(5)　出力で使用するダイアログ

(a)　［印刷先指定］ダイアログ

［印刷先指定］ダイアログの［OK］ボタンをクリックすると，指定したプリンタのトレイで帳票が出力されます。指定したプリンタとトレイがクライアントPCにない場合は，エラーとなります。

［帳票ジョブ名］

クライアントプリンタクラス名を表示します。クライアントプリンタクラスが指定されていない場合は，帳票名を表示します。

［プリンタ］リストボックス

クライアントPCに登録されたプリンタ名を表示します。

初期表示されるプリンタ名については，「3.2.5(4)　出力結果」を参照してください。

［プリンタ］リストボックスは，プリンタの種類と状態を次に示すアイコンで示します。

  • [図データ] ：OS上の通常使うプリンタ

  • [図データ] ：OS上の通常使うプリンタ以外のOSに登録されているプリンタ

［トレイ］リストボックス

プリンタ名を選択すると，OS上に登録されたプリンタ名のトレイ名を表示します。トレイを指定しなかった場合は，デフォルトのトレイで印刷されます。

印刷したことがある帳票ジョブを受信した場合で，［プリンタ］リストボックスに初期表示されるプリンタ名が，前回の受信時に設定したプリンタ名のときは，前回の受信時に設定したトレイ名が表示されます。

それ以外の場合は，トレイ名は表示されません。

［+］ボタン

［印刷先指定］ダイアログが拡張されて，［印刷オプション］を設定できます。

［－］ボタン

［印刷オプション］の設定が非表示になります。

［ページ指定］

印刷開始ページと印刷終了ページを指定します。

  • 印刷開始ページ

    初期表示は1（ページ）です。入力できる値は，1～999,999です。帳票の最終ページを超える値を指定した場合は，最終ページだけ印刷されます。

  • 印刷終了ページ

    初期表示は，帳票の最終ページです。入力できる値は，1～999,999です。帳票の最終ページを超える値を指定した場合は，最終ページまで印刷されます。

ページの先頭へ

(6)　注意事項

  • 32ビット版のInternet Explorerを使用してください。64ビット版のInternet Explorerでは，帳票の出力はできません。

  • 帳票のプレビューと印刷を同時に実行する場合は，帳票をダウンロードするWebページに，EUR Web Plug-Inのプレビュー用の<object>タグと印刷用の<object>タグを記述してください。

ページの先頭へ

(7)　コーディング例

クライアントPCにユーザ単位インストール用とマシン単位インストール用のどちらかのEUR Web Plug-Inダウンロードパッケージを配置して，最新のEUR Web Plug-Inを自動でインストールして帳票を出力します。

■EUR Web Plug-Inダウンロードパッケージ：EUR Server - Adapter稼働マシンに配置

http://xxx.xxx.xxx.xxx/cab/EURPMPrintAX.cab

■出力ファイル：EUR Server - Adapter稼働マシンに配置

出力EPF形式ファイル名：http://xxx.xxx.xxx/File/EPF/sample.epf

■処理内容

クライアントPCに最新のEUR Web Plug-Inがインストールされていない場合，ユーザ単位インストール用またはマシン単位インストール用のどちらかのEUR Web Plug-InダウンロードパッケージとEUR Web Plug-In情報ファイルを配置したクライアントPCに，最新のEUR Web Plug-Inが自動でインストールされます。

コーディング例を次に示します。

(a)　ActiveX起動部品の場合

<%@ LANGUAGE="VBScript" %>
<HTML>
<HEAD>
<META http-equiv="Content-Type"
 content="text/html;charset=Shift_JIS">
<TITLE>
EUR-CLP-AX ASP Sample
</TITLE>
<%
    'Webサーバの処理
    Dim objEURPM
    'EURPMオブジェクト生成
    Set objEURPM=Server.CreateObject("EURPM.Exec")
    Dim strVersion
    'EUR-CLP-AXのバージョン取得
    strVersion = objEURPM.GetPrintAXVersion()
    Dim strClassID
    'EUR-CLP-AXのクラスID取得
    strClassID = objEURPM.GetPrintAXClassID()
%>
</HEAD>
<BODY>
<Script LANGUAGE="vbScript">
<!--
    'EUR Web Plug-Inダウンロードパッケージの格納場所の設定
    Dim CabPath
    CabPath = "http://xxx.xxx.xxx.xxx/cab/EURPMPrintAX.cab"

    'OBJECTタグの生成
    document.Write("<object")
    'Webサーバで取得したクラスIDを指定
    document.Write(" classid=clsid:<%=strClassID%>")
    'CAB形式ファイルのパスおよびWebサーバで取得したバージョンを指定
    document.Write(" codebase=" & CabPath & "#version=<%=strVersion%>")
    document.Write(" ID=EURPMPRINTAX")
    document.Write(" type=application/x-oleobject>")
    document.Write("<BR>")
    document.Write("<param name=EPFFileURL value=http://xxx.xxx.xxx/File/EPF/sample.epf>")
    document.Write("<BR>")
    document.Write("<param name=LogLevel value=16>")
    document.Write("<BR>")
    document.Write("</object>")
    document.Write("<BR>")
-->
</Script>
</BODY>
</HTML>

(b)　Java起動部品の場合

<%@ page import="JP.co.Hitachi.soft.EURPM.*" %>
<%@ page contentType="text/html; charset=Shift_JIS" %>
<jsp:useBean id="adapter" class="JP.co.Hitachi.soft.EURPM.EURPMAdapterForJava" scope="session" />
<HTML>
<HEAD>
<TITLE>
EUR-CLP-AX JSP Sample
</TITLE>
<%
    //EUR-CLP-AXのバージョン取得
    String strVersion = adapter.getPrintAXVersion();
    //EUR-CLP-AXのクラスID取得
    String strClassID = adapter.getPrintAXClassID();
%>
</HEAD>
<BODY>
<Script LANGUAGE="javascript">
<!--
    //EUR Web Plug-Inダウンロードパッケージの格納場所の設定
    var CABPath; // CAB形式ファイルの格納場所
    CabPath = "http://xxx.xxx.xxx.xxx/cab/EURPMPrintAX.cab";

    //OBJECTタグの記述
    document.write("<object");
    //Webサーバで取得したクラスIDを指定
    document.write(" classid=clsid:<%=strClassID%>");
    //CAB形式ファイルのパスおよびWebサーバで取得したバージョンを指定
    document.write(" codebase=" + CabPath + "#version=<%=strVersion%>");
    document.write(" ID=EURPMPRINTAX");
    document.write(" type=application/x-oleobject>");
    document.write("<BR>");
    document.write("<param name=EPFFileURL value=http://xxx.xxx.xxx/File/EPF/sample.epf>");
    document.write("<BR>");
    document.write("<param name=LogLevel value=16>");
    document.write("<BR>");
    document.write("</object>");
    document.write("<BR>");
-->
</Script>
</BODY>
</HTML>

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 50 / 218


3.2.6 EUR Client Serviceをヘルパ起動して出力する : EUR 帳票出力 機能解説 EUR Server編

  • 51 / 218

  • 表紙

  • 3.　出力先を選んで出力する

  • 3.2　クライアントPCのプリンタに出力するには

  • 3.2.6　EUR Client Serviceをヘルパ起動して出力する

3.2.6　EUR Client Serviceをヘルパ起動して出力する

EUR Client Serviceをヘルパ起動してWebブラウザから帳票を出力する方法を，ヘルパクライアント印刷といいます。クライアントPCのWebブラウザから，Webサーバにアクセスして印刷データ（EPF形式ファイル）をダウンロードすると，クライアントPCのEUR Client Serviceが起動して，帳票が出力されます。

〈この項の構成〉

  • (1)　出力の流れ

  • (2)　出力先の設定

  • (3)　起動部品の設定

(1)　出力の流れ

EUR Client Serviceをヘルパ起動して帳票を出力する流れを，次の図に示します。

図3‒9　EUR Client Serviceをヘルパ起動して帳票を出力する流れ（ヘルパクライアント印刷）

[図データ]

  1. 出力要求

    帳票の出力要求が業務プログラムに送られます。

  2. 転送

    アプリケーションサーバのEUR Server - Adapterは，ユーザデータファイルを帳票サーバのEUR Server Serviceに転送します。

  3. 印刷データ生成

    転送されたユーザデータファイルとあらかじめ帳票サーバに配置しておいた印刷定義ファイルから，印刷データ（EPF形式ファイル）が生成されます。EPF形式ファイルの拡張子には「*.epp」を指定します。

    複数の帳票セットを一つのEPF形式ファイルに出力した場合も，複数様式で指定した場合も，クライアントPCで出力できます。

    なお，手順1.～手順3.で生成された印刷データが複数ある場合，一つの印刷データに統合することもできます。印刷データの統合方法については，「6.3.1　複数のEPF形式ファイルを統合出力する」を参照してください。

  4. 印刷データ転送

    EUR Server Serviceは，生成された印刷データ（EPF形式ファイル）をアプリケーションサーバに転送します。

  5. ダウンロード

    クライアントPCのWebブラウザから，Webサーバにアクセスして印刷データ（EPF形式ファイル）をダウンロードします。

    Webサーバとアプリケーションサーバが別マシンであったり，ネットワークを共有していたりする場合は，業務プログラム側でアプリケーションサーバの印刷データ（EPF形式ファイル）をWebサーバに転送しておいてください。なお，HTTPヘッダに指定するEPF形式ファイルのMIMEタイプには「application/vnd.hitachi.eurpm-print」と指定してください。

  6. ヘルパ起動

    クライアントPCにインストールされたEUR Client Serviceが起動されます。

  7. 出力

    クライアントプリンタクラスに対応するプリンタに自動印刷されます。クライアントプリンタクラスが指定されていない場合は，通常使うプリンタに自動印刷されます。正しく印刷されない場合は，プリンタの設定を確認してください。

    なお，MIMEタイプが「application/vnd.hitachi.eurpm-print」であっても，ファイルの拡張子が*.epfの場合は，帳票がプレビューされます。

手順4.の代わりに，EPF形式ファイルをメール送信する運用もできます。この場合，メール受信者は，添付されたEPF形式ファイルをローカルディスクに保存し，ダブルクリックすることで出力できます。

ページの先頭へ

(2)　出力先の設定

クライアントPCのプリンタクラスで出力先を指定します。

クライアントPCのプリンタとトレイを組み合わせたものを，プリンタクラスとしてクライアントPCに登録します。帳票出力時に起動部品でプリンタクラス名を指定すると，指定したプリンタのトレイに帳票が出力されます。

起動部品で指定したプリンタクラス名は，印刷データ（EPF形式ファイル）の属性情報として保持されます。クライアントPCで印刷データを受信したとき，印刷データが保持している属性情報によって自動でプリンタが選択されます。

■参考

クライアントPCのプリンタクラスは各クライアントPCで設定しますが，設定内容をクライアントプリンタクラス定義ファイルに保存して，ひな型として各クライアントPCに配布することもできます。配布したファイルを使えば，各クライアントPCでプリンタクラスを設定する手間が省けます。

クライアントプリンタクラス定義ファイルの作成方法や格納先については，マニュアル「EUR システム構築ガイド」を参照してください。

ページの先頭へ

(3)　起動部品の設定

帳票出力で使用する起動部品のメソッド，関数，およびオプションの指定値を次に示します。

  • ActiveX起動部品：OutputEPFReportメソッド

  • Java起動部品：outputEPFReportメソッド

  • COBOL起動部品：OutputEPFReport関数

  • コマンド起動部品（eurpmcコマンド）：/mオプションにepfを指定

また，出力時に設定する起動部品のプロパティ，メソッド，パラメタ，およびオプションの指定値を次に示します。

  1. クライアントPCのプリンタの設定

    クライアントPCのプリンタをプリンタクラス名で設定します。

    クライアントPCのプリンタ

    起動部品の設定項目

    設定する値

    プリンタクラス名

    ActiveX起動部品：PrinterClassNameプロパティ

    Java起動部品：setPrinterClassNameメソッド

    COBOL起動部品：PRINTERCLASSNAMEパラメタ

    コマンド起動部品：/prcオプション

    プリンタクラス名（80バイト以内の文字列）

  2. 帳票ファイルの設定

    印刷する帳票ファイル名を設定します。

    帳票ファイルの設定

    起動部品の設定項目

    設定する値

    帳票ファイルの名前

    ActiveX起動部品：ReportFileNameプロパティ

    Java起動部品：setReportFileNameメソッド

    COBOL起動部品：REPORTNAMEパラメタ

    コマンド起動部品：/rfオプション

    帳票ファイル名（255バイト以内の文字列）

  3. EPF形式ファイルの設定

    EPF形式ファイル名を設定します。

    EPF形式ファイルの設定

    起動部品の設定項目

    設定する値

    EPF形式ファイル名

    ActiveX起動部品：EPFFileNameプロパティ

    Java起動部品：setEPFFileNameメソッド

    COBOL起動部品：EPFFILENAMEパラメタ

    コマンド起動部品：/epfnオプション

    EPF形式ファイル名（255バイト以内の文字列）

  4. マッピングデータファイルの設定

    マッピングデータファイル名を設定します。

    ユーザデータファイルの設定

    起動部品の設定項目

    設定する値

    マッピングデータファイルの名前

    ActiveX起動部品：DataFileNameプロパティ

    Java起動部品：setDataFileNameメソッド

    COBOL起動部品：MAPPINGDATAパラメタ

    コマンド起動部品：/mapオプション

    マッピングデータファイル名（255バイト以内の文字列）

  5. ユーザデータファイル，印刷定義ファイル，および印刷付加情報の設定

    必要に応じて，ユーザデータファイル（ユーザ定義データファイルなど），印刷定義ファイル（複数様式情報定義ファイル，文書情報設定ファイル，置き換え表管理情報ファイルなど）および印刷付加情報（印刷開始ページ，印刷部数，ページ番号など）を設定します。

■参考

帳票ファイル名やマッピングデータファイル名を起動部品で直接指定するのではなく，帳票セットとして帳票セット指定ファイルにまとめて指定することもできます。この場合，出力時には次に示すプロパティ，メソッド，パラメタ，またはオプションで帳票セット指定ファイル名を指定してください。

  • ActiveX起動部品：MultiReportSetFileNameプロパティ

  • Java起動部品：setMultiReportSetFileNameメソッド

  • COBOL起動部品：REPORTSETFILEパラメタ

  • コマンド起動部品：/mrsオプション

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 51 / 218


3.2.7 コマンドを実行して出力する : EUR 帳票出力 機能解説 EUR Server編

  • 52 / 218

  • 表紙

  • 3.　出力先を選んで出力する

  • 3.2　クライアントPCのプリンタに出力するには

  • 3.2.7　コマンドを実行して出力する

3.2.7　コマンドを実行して出力する

クライアントPCでeurpmcepfviewerコマンドを実行すると，クライアントPCのEUR Client Serviceが起動して，帳票が出力されます。

eurpmcepfviewerコマンドの構文については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

〈この項の構成〉

  • (1)　出力の流れ

  • (2)　起動部品の設定

  • (3)　出力結果

  • (4)　注意事項

  • (5)　コーディング例

(1)　出力の流れ

コマンドを実行して帳票を出力する流れを，次の図に示します。

図3‒10　コマンドを実行して帳票を出力する流れ

[図データ]

  1. 出力要求

    帳票の出力要求が業務プログラムに送られます。

  2. 転送

    アプリケーションサーバのEUR Server - Adapterは，ユーザデータファイルを帳票サーバのEUR Server Serviceに転送します。

  3. 印刷データ生成

    転送されたユーザデータファイルとあらかじめ帳票サーバに配置しておいた印刷定義ファイルから，印刷データ（EPF形式ファイル）が生成されます。

    なお，手順1.～手順3.で生成された印刷データが複数ある場合，一つの印刷データに統合することもできます。印刷データの統合方法については，「6.3.1　複数のEPF形式ファイルを統合出力する」を参照してください。

  4. 印刷データ転送

    EUR Server Serviceは，生成された印刷データ（EPF形式ファイル）をアプリケーションサーバに転送します。

  5. ダウンロード

    クライアントPCの業務プログラムから，Webサーバにアクセスして印刷データ（EPF形式ファイル）をダウンロードします。

    Webサーバとアプリケーションサーバが別マシンであったり，ネットワークを共有していたりする場合は，業務プログラム側でアプリケーションサーバの印刷データ（EPF形式ファイル）をWebサーバに転送しておいてください。

  6. 出力

    クライアントPCの業務プログラムから，/rオプションを指定してeurpmcepfviewerコマンドを実行すると，帳票が自動で印刷されます。なお，ファイルの拡張子が*.epfであっても，eurpmcepfviewerコマンドの実行時に，/rオプションを指定した場合は，帳票が自動印刷されます。

■参考

手順3.で生成された印刷データを直接クライアントPCに転送してeurpmcepfviewerコマンドを実行しても，帳票を出力できます。

ページの先頭へ

(2)　起動部品の設定

帳票出力で使用する起動部品のメソッド，関数，およびオプションの指定値を次に示します。

  • ActiveX起動部品：OutputEPFReportメソッド

  • Java起動部品：outputEPFReportメソッド

  • COBOL起動部品：OutputEPFReport関数

  • コマンド起動部品（eurpmcコマンド）：/mオプションにepfを指定

また，出力時に設定する起動部品のプロパティ，メソッド，パラメタ，およびオプションの指定値を次に示します。

  1. 帳票ファイルの設定

    印刷する帳票ファイル名を設定します。

    帳票ファイルの設定

    起動部品の設定項目

    設定する値

    帳票ファイルの名前

    ActiveX起動部品：ReportFileNameプロパティ

    Java起動部品：setReportFileNameメソッド

    COBOL起動部品：REPORTNAMEパラメタ

    コマンド起動部品：/rfオプション

    帳票ファイル名（255バイト以内の文字列）

  2. EPF形式ファイルの設定

    EPF形式ファイル名を設定します。

    EPF形式ファイルの設定

    起動部品の設定項目

    設定する値

    EPF形式ファイル名

    ActiveX起動部品：EPFFileNameプロパティ

    Java起動部品：setEPFFileNameメソッド

    COBOL起動部品：EPFFILENAMEパラメタ

    コマンド起動部品：/epfnオプション

    EPF形式ファイル名（255バイト以内の文字列）

  3. マッピングデータファイルの設定

    マッピングデータファイル名を設定します。

    ユーザデータファイルの設定

    起動部品の設定項目

    設定する値

    マッピングデータファイルの名前

    ActiveX起動部品：DataFileNameプロパティ

    Java起動部品：setDataFileNameメソッド

    COBOL起動部品：MAPPINGDATAパラメタ

    コマンド起動部品：/mapオプション

    マッピングデータファイル名（255バイト以内の文字列）

  4. ユーザデータファイル，印刷定義ファイル，および印刷付加情報の設定

    必要に応じて，ユーザデータファイル（ユーザ定義データファイルなど），印刷定義ファイル（複数様式情報定義ファイル，文書情報設定ファイル，置き換え表管理情報ファイルなど）および印刷付加情報（印刷開始ページ，印刷部数，ページ番号など）を設定します。

■参考

帳票ファイル名やマッピングデータファイル名を起動部品で直接指定するのではなく，帳票セットとして帳票セット指定ファイルにまとめて指定することもできます。この場合，出力時には次に示すプロパティ，メソッド，パラメタ，またはオプションで帳票セット指定ファイル名を指定してください。

  • ActiveX起動部品：MultiReportSetFileNameプロパティ

  • Java起動部品：setMultiReportSetFileNameメソッド

  • COBOL起動部品：REPORTSETFILEパラメタ

  • コマンド起動部品：/mrsオプション

ページの先頭へ

(3)　出力結果

eurpmcepfviewerコマンドの実行時に指定するオプションによって異なります。

優先順位は次のとおりです。

  1. プリンタ名の指定（/prオプションで指定）

  2. プリンタクラス名の指定（/prcオプションで指定）

  3. EPF形式ファイルのプリンタクラス名情報

  4. OSのデフォルトのプリンタ

帳票の印刷先に関するオプションの指定（1.および2.）を省略した場合は，帳票に設定されているクライアントプリンタクラス（3.）に対応するプリンタに出力されます。帳票にクライアントプリンタクラスが設定されていない場合（4.）は，OSのデフォルトのプリンタに出力されます。

なお，プリンタ名（1.）またはプリンタクラス名（2.）の指定によって決定したプリンタが存在しない場合はエラーになります。

ページの先頭へ

(4)　注意事項

帳票を連続して出力すると，メモリ不足のエラーになることがあります。クライアントPCでメモリ不足のエラーが発生した場合は，時間を置いて再度出力するか，EUR Client Serviceを再起動してください。

ページの先頭へ

(5)　コーディング例

■プリンタクラス名を指定して帳票を全自動印刷する場合
"C:\Program Files\Hitachi\EUR\Client\Program\EURPMCEPFViewer.exe" /r /nomessage /prc AClass C:\temp\EPFFile.epf

プリンタクラス名：AClass

EPF形式ファイル名：EPFFile.epf

ファイルのある場所：C:\temp

プリンタクラス「AClass」で定義されているプリンタとトレイで，帳票が出力されます。

■プリンタ名とトレイ名を指定して帳票を自動印刷する場合
"C:\Program Files\Hitachi\EUR\Client\Program\EURPMCEPFViewer.exe" /r /pr "Port C4300" /tr 自動 C:\temp\EPFFile.epf

プリンタ名：Port C4300

トレイ名：自動

EPF形式ファイル名：EPFFile.epf

ファイルのある場所：C:\temp

プリンタ名が「Port C4300」のプリンタとトレイ名が「自動」の給紙トレイで，帳票が出力されます。

■帳票のプリンタクラス名情報を使用して自動印刷する場合
"C:\Program Files\Hitachi\EUR\Client\Program\EURPMCEPFViewer.exe" /r "C:\temp folder\EPFFile.epf"

EPF形式ファイル名：EPFFile.epf

ファイルのある場所：C:\temp folder

EPF形式ファイル「EPFFile.epf」の属性情報に設定されているクライアントプリンタクラス情報を基に，帳票が出力されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 52 / 218


3.3 クライアントPCでプレビューするには : EUR 帳票出力 機能解説 EUR Server編

  • 53 / 218

  • 表紙

  • 3.　出力先を選んで出力する

  • 3.3　クライアントPCでプレビューするには

3.3　クライアントPCでプレビューするには

ここでは，EUR サーバ帳票出力機能で出力した帳票を，クライアントPCでプレビューする方法について説明します。

帳票をクライアントPCでプレビューするには，次の表に示す方法があります。運用に応じて，適切な方法を選択してください。

表3‒4 クライアントPCでのプレビュー方法
出力方法 | 運用 | 参照先
プレビューウィンドウを表示する | クライアントPCに帳票を転送してプレビューする。 | 3.3.1
 | 同一の帳票を複数のクライアントに配布してプレビューする。 | 3.3.2
Webブラウザを使用してプレビューする | EUR Web Plug-Inを使用してプレビューする。 | 3.3.3
 | EUR Client Serviceをヘルパ起動してプレビューする。 | 3.3.4
コマンドを実行してプレビューする | クライアントでコマンドを実行してプレビューする。 | 3.3.5
■参考

帳票の印刷データ（EPF形式ファイル）をスプールサーバに蓄積してから，任意のタイミングでプレビューすることもできます。帳票の印刷データをスプールサーバに蓄積する方法については，「5.2.2　印刷データを蓄積する手順」を参照してください。また，蓄積した印刷データをプレビューする方法については，「5.4　蓄積した印刷データを出力する」を参照してください。

〈この節の構成〉

  • 3.3.1　転送された帳票をプレビューする

  • 3.3.2　配布された帳票をプレビューする

  • 3.3.3　EUR Web Plug-Inを使用してプレビューする

  • 3.3.4　EUR Client Serviceをヘルパ起動してプレビューする

  • 3.3.5　コマンドを実行してプレビューする

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 53 / 218


3.3.1 転送された帳票をプレビューする : EUR 帳票出力 機能解説 EUR Server編

  • 54 / 218

  • 表紙

  • 3.　出力先を選んで出力する

  • 3.3　クライアントPCでプレビューするには

  • 3.3.1　転送された帳票をプレビューする

3.3.1　転送された帳票をプレビューする

帳票サーバから帳票の印刷データ（EPF形式ファイル）がクライアントPCに転送されると，EUR Client Serviceが起動して帳票をプレビューできます。

〈この項の構成〉

  • (1)　プレビューの流れ

  • (2)　起動部品の設定

  • (3)　プレビューで使用するウィンドウ

  • (4)　［検索］ダイアログでIVSの漢字文字を入力した場合の動作

(1)　プレビューの流れ

ダイアログでプリンタを設定して帳票を出力する場合と同じです。詳細については，「3.2.3　ダイアログでプリンタを設定して出力する」を参照してください。印刷データ（EPF形式ファイル）がクライアントPCに転送されると，［印刷先指定］ダイアログの代わりにプレビューウィンドウが表示されます。

ページの先頭へ

(2)　起動部品の設定

帳票出力で使用する起動部品のメソッド，関数，およびオプションの指定値を次に示します。

  • ActiveX起動部品：PrintPMReportメソッド

  • Java起動部品：printReportメソッド

  • COBOL起動部品：PrintReport関数またはPrintReport2関数

  • コマンド起動部品（eurpmcコマンド）：/mオプションにprintを指定

また，出力時に設定する起動部品のプロパティ，メソッド，パラメタ，およびオプションの指定値を次に示します。

  1. 印刷方法の設定

    帳票を印刷する方法を設定します。

    印刷方法の設定

    起動部品の設定項目

    設定する値

    印刷方法

    ActiveX起動部品：PrintModeプロパティ

    Java起動部品：setPrintModeメソッド

    COBOL起動部品：PRINTMODEパラメタ

    1（クライアントPCで印刷する）

    コマンド起動部品：/pmオプション

    cl（クライアントPCで印刷する）

  2. クライアントPCの設定

    クライアントPCのIPアドレスを指定します。

    クライアントPCの設定

    起動部品の設定項目

    設定する値

    IPアドレス

    ActiveX起動部品：ClientAddressプロパティ

    Java起動部品：setClientAddressメソッド

    COBOL起動部品：CLIENTADDRパラメタ

    コマンド起動部品：/clientオプション

    255.255.255.255形式

  3. ダイアログの設定

    クライアントPCで帳票を受信したときに印刷ダイアログを表示するかどうかを設定します。

    ダイアログの設定

    起動部品の設定項目

    設定する値

    ダイアログを表示するかどうか

    ActiveX起動部品：DispPrintDlgプロパティ

    Java起動部品：setDispPrintDlgメソッド

    COBOL起動部品：DISPPRINTDLGパラメタ

    2（対話型印刷プレビュー表示）

    4（対話型印刷プレビュー表示限定）※

    コマンド起動部品：/dialogオプション

    preview（対話型印刷プレビュー表示）

    pvonly（対話型印刷プレビュー表示限定）※

    注※　印刷ダイアログを表示しないため，印刷を実行できません。

  4. プリンタクラス名の設定

    同じ帳票が送られてきたときに，前回印刷時に指定したプリンタ名とトレイ名をデフォルト表示するためには，帳票のプリンタクラス名で前回印刷時の情報を記憶させます。

    プリンタクラス名の設定

    起動部品の設定項目

    設定する値

    プリンタクラス名

    ActiveX起動部品：PrinterClassNameプロパティ

    Java起動部品：setPrinterClassNameメソッド

    COBOL起動部品：PRINTERCLASSNAMEパラメタ

    コマンド起動部品：/prcオプション

    プリンタクラス名（80バイト以内の文字列）

  5. 帳票ファイルの設定

    印刷する帳票ファイル名を設定します。

    帳票ファイルの設定

    起動部品の設定項目

    設定する値

    帳票ファイルの名前

    ActiveX起動部品：ReportFileNameプロパティ

    Java起動部品：setReportFileNameメソッド

    COBOL起動部品：REPORTNAMEパラメタ

    コマンド起動部品：/rfオプション

    帳票ファイル名（255バイト以内の文字列）

  6. マッピングデータファイルの設定

    マッピングデータファイル名を設定します。

    ユーザデータファイルの設定

    起動部品の設定項目

    設定する値

    マッピングデータファイルの名前

    ActiveX起動部品：DataFileNameプロパティ

    Java起動部品：setDataFileNameメソッド

    COBOL起動部品：MAPPINGDATAパラメタ

    コマンド起動部品：/mapオプション

    マッピングデータファイル名（255バイト以内の文字列）

  7. ユーザデータファイル，印刷定義ファイル，および印刷付加情報の設定

    必要に応じて，ユーザデータファイル（ユーザ定義データファイルなど），印刷定義ファイル（複数様式情報定義ファイル，文書情報設定ファイル，置き換え表管理情報ファイルなど）および印刷付加情報（印刷開始ページ，印刷部数，ページ番号など）を設定します。

■参考

帳票ファイル名やマッピングデータファイル名を起動部品で直接指定するのではなく，帳票セットとして帳票セット指定ファイルにまとめて指定することもできます。この場合，出力時には次に示すプロパティ，メソッド，パラメタ，またはオプションで帳票セット指定ファイル名を指定してください。

  • ActiveX起動部品：MultiReportSetFileNameプロパティ

  • Java起動部品：setMultiReportSetFileNameメソッド

  • COBOL起動部品：REPORTSETFILEパラメタ

  • コマンド起動部品：/mrsオプション

ページの先頭へ

(3)　プレビューで使用するウィンドウ

(a)　プレビューウィンドウ

プレビューウィンドウでは，帳票の印刷イメージを確認できます。

表3‒5 プレビューウィンドウのメニュー（対話型印刷プレビュー表示）
メニュー |  | 機能 | ボタン
ファイル(F) | 印刷(R) | ［印刷先指定］ダイアログが表示されます。 | [図データ]
 | プロパティ(P) | ［プロパティ］ダイアログが表示されます。 | [図データ]
 | 終了(X) | プレビューウィンドウが終了します。 | －
編集(E) | 検索(F) | ［検索］ダイアログが表示されます。 | [図データ]
 | 次を検索(N) | ［検索］ダイアログで前回実行した検索の内容に従って，次の検索を実行します。一度も検索を実行していない場合は，［検索］ダイアログが表示されます。 | －
表示(V) | ツールバー(T) | チェックを入れると，ツールバーが表示されます。 | －
 | ステータスバー(S) | チェックを入れると，ステータスバーが表示されます。 | －
 | 先頭ページ(O) | 先頭ページに移動します。 | [図データ]
 | 前ページ(B) | 前ページに移動します。 | [図データ]
 | 次ページ(N) | 次ページに移動します。 | [図データ]
 | 最終ページ(L) | 最終ページに移動します。 | [図データ]
 | 指定ページへジャンプ(J) | ［指定ページへジャンプ］ダイアログが表示されます。指定したページに移動します。 | [図データ]
 | 拡大(U) | 表示された帳票を拡大します。10%ずつ拡大します。 | [図データ]
 | 縮小(D) | 表示された帳票を縮小します。10%ずつ縮小します。 | [図データ]
 | 拡大率の指定(P) | ［拡大率の指定］ダイアログが表示されます。指定した拡大率で帳票が表示されます。 | [図データ]
ヘルプ(H) | ヘルプ(E) | 常に不活性です。 | [図データ]
 | バージョン情報(A) | ［バージョン情報］ダイアログが表示されます。 | －

なお，印刷ダイアログを表示しない設定にした場合，プレビューウィンドウのメニュー，およびツールバーのボタンに［印刷(R)］は表示されません。

(b)　［プロパティ］ダイアログ

印刷データ（EPF形式ファイル）のプロパティが表示されます。

［EURPSバージョン］

印刷データを作成したEUR Print Serviceのバージョンが表示されます。

［EPF Reportバージョン］

印刷データを作成したプログラムのバージョンが表示されます。

［プリンタクラス名］

印刷データのクライアントプリンタクラス名が表示されます。設定されていない場合は，表示されません。

［スプールタイトル］

印刷データのスプールのタイトルが表示されます。設定されていない場合は，表示されません。

［印刷部数］

印刷データの印刷部数が表示されます。

［部数の単位］

印刷データの部数の単位が表示されます。［部単位］または［ページ単位］のどちらかが表示されます。

［向き］

印刷データの印刷の向きが表示されます。［縦］または［横］のどちらかが表示されます。設定されていない場合は，表示されません。

［総ページ数］

印刷データの総ページ数が表示されます。

［横dpi］

印刷データの横dpiが表示されます。

［縦dpi］

印刷データの縦dpiが表示されます。

［先頭ページ帳票ファイル名］

帳票ファイル名を表示します。複数の帳票が指定されている場合は，先頭ページの帳票ファイル名を表示します。

［蓄積ジョブID］

スプールデータの印刷，またはスプールデータからファイル取得したEPF形式ファイルを印刷する場合に蓄積時のジョブIDを表示します。蓄積印刷ではない場合は何も表示しません。

［印刷日時書式］

プリンタでの印刷実行時に帳票に出力される，日時情報の文字列が表示されます。設定されていない場合は，表示されません。

なお，文字列中の書式指定コード（「%」で始まる文字列）は，出力時の日時に合わせて変換されます。書式指定コードの詳細については，「11.4.1　日時情報に出力できる文字列」を参照してください。

［印刷日時出力位置］

プリンタでの印刷実行時に帳票に出力される，日時情報の文字列の出力位置が表示されます。設定されていない場合は，表示されません。

［印刷日時フォント名］

プリンタでの印刷実行時に帳票に出力される，日時情報の文字のフォント名が表示されます。設定されていない場合は，表示されません。

［印刷日時フォントサイズ］

プリンタでの印刷実行時に帳票に出力される，日時情報の文字の大きさが表示されます。単位はポイントです。設定されていない場合は，表示されません。

［印刷日時フォント色(RGB)］

プリンタでの印刷実行時に帳票に出力される，日時情報の文字の色がRGB値で表示されます。設定されていない場合は，表示されません。

(c)　［検索］ダイアログ

プレビュー領域内をアイテム単位に文字列で検索できます。また，IVS（基底文字＋異体字セレクタ）で表現される漢字文字の異体字も検索できます。［検索］ダイアログでIVSの漢字文字を入力した場合の動作については，「3.3.1 (4)　［検索］ダイアログでIVSの漢字文字を入力した場合の動作」を参照してください。

［検索する文字列］テキストボックス

検索する文字列を指定します。最大127文字まで入力できます。

2回目以降の検索では，前回検索を実行したときの文字列が表示されます。

［大文字と小文字を区別する］チェックボックス

検索するときに英字の大文字と小文字を区別するかどうかを指定します。英字の大文字と小文字を区別する場合はチェックボックスをオンにします。デフォルトはオンです。

2回目以降の検索では，前回検索を実行したときの状態で表示されます。

［検索する方向］グループボックス

検索する方向を選択します。下方向に検索する場合は［下へ］ラジオボタンを，上方向に検索する場合は［上へ］ラジオボタンを選択します。デフォルトは［下へ］ラジオボタンが選択状態で表示されます。

2回目以降の検索では，前回検索を実行したときの選択状態で表示されます。

［次を検索］ボタン

入力された検索条件に従って，プレビュー領域の文字列検索を実行します。

検索する文字列が見つかった場合，見つかった文字列が反転表示されます。

(d)　［指定ページへジャンプ］ダイアログ

ページ番号を入力すると，指定したページに移動できます。

［現在表示ページ］

プレビュー領域に表示されたページのページ番号が表示されます。形式は，「ページ番号/総ページ数」です。

［ページ番号の入力］テキストボックス

表示したいページ番号を1から総ページ数の範囲で入力します。半角数字で入力してください。

［ジャンプ］ボタン

指定したページをプレビュー領域に表示します。

1から総ページ数の範囲以外の値を指定した場合はエラーとなります。

(e)　［拡大率の指定］ダイアログ

指定した倍率で，プレビュー領域が表示されます。

［現在の拡大率］

プレビュー領域に表示された倍率を表示します。

［拡大率］グループボックス

［25%］ラジオボタン：帳票を25%の倍率で表示します。

［75%］ラジオボタン：帳票を75%の倍率で表示します。

［100%］ラジオボタン：帳票を100%の倍率で表示します。

［150%］ラジオボタン：帳票を150%の倍率で表示します。

［200%］ラジオボタン：帳票を200%の倍率で表示します。

［任意］ラジオボタン：任意の拡大率を指定します。

拡大率指定テキストボックス

任意の倍率を入力します。［任意］ラジオボタンを選択すると，入力できます。25～200の半角数字を指定してください。25～200の範囲以外の値を指定した場合はエラーとなります。

ページの先頭へ

(4)　［検索］ダイアログでIVSの漢字文字を入力した場合の動作

［検索］ダイアログで，プレビュー領域に表示されているIVS（基底文字+異体字セレクタ）で表現される漢字文字を入力して検索できます。IVSの詳細については，マニュアル「EUR システム設計ガイド」を参照してください。

［検索］ダイアログで，IVSの漢字文字を入力した検索は，次のようになります。

基底文字+異体字セレクタで表現される漢字文字を入力した場合，基底文字+異体字セレクタの文字コードが検索条件値となります。ただし，［検索］ダイアログ上では異体字セレクタは無視され，基底文字単体（異体字セレクタなし）の漢字文字が表示されます。

IVSの漢字文字の文字列（検索文字列）を検索条件値に入力して検索を実行すると，［検索］ダイアログ上に表示されている文字列ではなく，検索条件値の文字コードで，帳票の印刷データ（EPF形式ファイル）内の文字列情報を検索します。なお，検索文字列の最終文字が「基底文字（異体字セレクタなし）」の場合と，「基底文字+異体字セレクタ」の場合とで，検索でヒットする文字列が次のように変わります。

■検索文字列の最終文字が「基底文字（異体字セレクタなし）」の場合

EPF形式ファイル内の文字列情報を検索して，検索文字列の先頭文字から最終文字の「基底文字」までの文字コードが一致する文字列が，検索でヒットします。

この場合，検索文字列の最終文字に「異体字セレクタ」が付加されている文字列も，検索でヒットします。

■検索文字列の最終文字が「基底文字+異体字セレクタ」の場合

EPF形式ファイル内の文字列情報を検索して，検索文字列の先頭文字から最終文字の「異体字セレクタ」までの文字コードと一致する文字列が，検索でヒットします。

この場合，検索文字列の最終文字に「異体字セレクタ」が付加されていない文字列，および異なる「異体字セレクタ」が付加されている文字列は，検索でヒットしません。

［検索］ダイアログで，IVSの漢字文字の検索文字列を入力して検索を実行した場合の，EPF形式ファイル内に含まれる文字列の検索結果の例を次に示します。

表3‒6 IVSの漢字文字の検索結果の例
検索文字列 | EPF形式ファイル内に含まれる文字列
 | ＡＢＣ | ＡＢ’Ｃ | ＡＢＣ’ | ＡＢ’Ｃ’
ＡＢＣ | ヒットする | ヒットしない | ヒットする | ヒットしない
ＡＢ’Ｃ | ヒットしない | ヒットする | ヒットしない | ヒットする
ＡＢＣ’ | ヒットしない | ヒットしない | ヒットする | ヒットしない
ＡＢ’Ｃ’ | ヒットしない | ヒットしない | ヒットしない | ヒットする
（凡例）

Ａ，Ｂ，Ｃ：基底文字だけ（異体字セレクタなし）の漢字文字を表します。

Ｂ’：基底文字「Ｂ」に異体字セレクタが付加された漢字文字を表します。

Ｃ’：基底文字「Ｃ」に異体字セレクタが付加された漢字文字を表します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 54 / 218


3.3.2 配布された帳票をプレビューする : EUR 帳票出力 機能解説 EUR Server編

  • 55 / 218

  • 表紙

  • 3.　出力先を選んで出力する

  • 3.3　クライアントPCでプレビューするには

  • 3.3.2　配布された帳票をプレビューする

3.3.2　配布された帳票をプレビューする

同一の帳票を複数のクライアントに配布して出力する方法を，配布印刷といいます。帳票サーバから帳票の印刷データ（EPF形式ファイル）がクライアントPCに配布されると，EUR Client Serviceが起動して帳票をプレビューできます。

〈この項の構成〉

  • (1)　プレビューの流れ

  • (2)　起動部品の設定

  • (3)　プレビューで使用するウィンドウ

(1)　プレビューの流れ

ダイアログでプリンタを設定して配布された帳票を出力する場合と同じです。詳細については，「3.2.4　ダイアログでプリンタを設定して出力する（配布印刷）」を参照してください。印刷データ（EPF形式ファイル）がクライアントPCに転送されると，［印刷先指定］ダイアログの代わりにプレビューウィンドウが表示されます。

ページの先頭へ

(2)　起動部品の設定

(a)　印刷データの生成に関する設定

印刷データの生成で使用する起動部品のメソッド，関数，およびオプションの指定値を次に示します。

  • ActiveX起動部品：OutputEPFReportメソッド

  • Java起動部品：outputEPFReportメソッド

  • COBOL起動部品：OutputEPFReport関数

  • コマンド起動部品（eurpmcコマンド）：/mオプションにepfを指定

また，生成時に設定する起動部品のプロパティ，メソッド，パラメタ，およびオプションの指定値を次に示します。

  1. 帳票ファイルの設定

    印刷する帳票ファイル名を設定します。

    帳票ファイルの設定

    起動部品の設定項目

    設定する値

    帳票ファイルの名前

    ActiveX起動部品：ReportFileNameプロパティ

    Java起動部品：setReportFileNameメソッド

    COBOL起動部品：REPORTNAMEパラメタ

    コマンド起動部品：/rfオプション

    帳票ファイル名（255バイト以内の文字列）

  2. EPF形式ファイルの設定

    EPF形式ファイル名を設定します。

    EPF形式ファイルの設定

    起動部品の設定項目

    設定する値

    EPF形式ファイル名

    ActiveX起動部品：EPFFileNameプロパティ

    Java起動部品：setEPFFileNameメソッド

    COBOL起動部品：EPFFILENAMEパラメタ

    コマンド起動部品：/epfnオプション

    EPF形式ファイル名（255バイト以内の文字列）

  3. マッピングデータファイルの設定

    マッピングデータファイル名を設定します。

    ユーザデータファイルの設定

    起動部品の設定項目

    設定する値

    マッピングデータファイルの名前

    ActiveX起動部品：DataFileNameプロパティ

    Java起動部品：setDataFileNameメソッド

    COBOL起動部品：MAPPINGDATAパラメタ

    コマンド起動部品：/mapオプション

    マッピングデータファイル名（255バイト以内の文字列）

  4. ユーザデータファイル，印刷定義ファイル，および印刷付加情報の設定

    必要に応じて，ユーザデータファイル（ユーザ定義データファイルなど），印刷定義ファイル（複数様式情報定義ファイル，文書情報設定ファイル，置き換え表管理情報ファイルなど）および印刷付加情報（印刷開始ページ，印刷部数，ページ番号など）を設定します。

  5. プリンタクラス名の設定

    同じ帳票が送られてきたときに，前回印刷時に指定したプリンタ名とトレイ名をデフォルト表示するためには，帳票のプリンタクラス名で前回印刷時の情報を記憶させます。

    クライアントPCのプリンタ

    起動部品の設定項目

    設定する値

    プリンタクラス名

    ActiveX起動部品：PrinterClassNameプロパティ

    Java起動部品：setPrinterClassNameメソッド

    COBOL起動部品：PRINTERCLASSNAMEパラメタ

    コマンド起動部品：/prcオプション

    プリンタクラス名（80バイト以内の文字列）
■参考

帳票ファイル名やマッピングデータファイル名を起動部品で直接指定するのではなく，帳票セットとして帳票セット指定ファイルにまとめて指定することもできます。この場合，出力時には次に示すプロパティ，メソッド，パラメタ，またはオプションで帳票セット指定ファイル名を指定してください。

  • ActiveX起動部品：MultiReportSetFileNameプロパティ

  • Java起動部品：setMultiReportSetFileNameメソッド

  • COBOL起動部品：REPORTSETFILEパラメタ

  • コマンド起動部品：/mrsオプション

(b)　配布印刷に関する設定

配布印刷で使用する起動部品のメソッド，関数，およびオプションの指定値を次に示します。

  • ActiveX起動部品：PrintPMReportメソッド

  • Java起動部品：printReportメソッド

  • COBOL起動部品：PrintReport関数またはPrintReport2関数

  • コマンド起動部品（eurpmcコマンド）：/mオプションにprintを指定

また，印刷時に設定する起動部品のプロパティ，メソッド，パラメタ，およびオプションの指定値を次に示します。

  1. 配布するEPF形式ファイルの設定

    配布するEPF形式ファイル名を設定します。

    配布するEPF形式ファイル名には，「(a)　印刷データの生成に関する設定」の手順2.で生成したEPF形式ファイル名を設定します。

    EPF形式ファイルの設定

    起動部品の設定項目

    設定する値

    EPF形式ファイル名

    ActiveX起動部品：EPFFileNameプロパティ

    Java起動部品：setEPFFileNameメソッド

    COBOL起動部品：EPFFILENAMEパラメタ

    コマンド起動部品：/epfnオプション

    EPF形式ファイル名（255バイト以内の文字列）

  2. 印刷方法の設定

    帳票を印刷する方法を設定します。

    印刷方法の設定

    起動部品の設定項目

    設定する値

    印刷方法

    ActiveX起動部品：PrintModeプロパティ

    Java起動部品：setPrintModeメソッド

    COBOL起動部品：PRINTMODEパラメタ

    5（クライアントPCに配布印刷する）

    コマンド起動部品：/pmオプション

    clds（クライアントPCに配布印刷する）

  3. クライアントPCの設定

    クライアントPCのIPアドレスを指定します。

    クライアントPCの設定

    起動部品の設定項目

    設定する値

    IPアドレス

    ActiveX起動部品：ClientAddressプロパティ

    Java起動部品：setClientAddressメソッド

    COBOL起動部品：CLIENTADDRパラメタ

    コマンド起動部品：/clientオプション

    255.255.255.255形式

  4. ダイアログの設定

    クライアントPCで帳票を受信したときに印刷ダイアログを表示するかどうかを設定します。

    ダイアログの設定

    起動部品の設定項目

    設定する値

    ダイアログを表示するかどうか

    ActiveX起動部品：DispPrintDlgプロパティ

    Java起動部品：setDispPrintDlgメソッド

    COBOL起動部品：DISPPRINTDLGパラメタ

    2（対話型印刷プレビュー表示）

    4（対話型印刷プレビュー表示限定）※

    コマンド起動部品：/dialogオプション

    preview（対話型印刷プレビュー表示）

    pvonly（対話型印刷プレビュー表示限定）※

    注※　印刷ダイアログを表示しないため，印刷を実行できません。

ページの先頭へ

(3)　プレビューで使用するウィンドウ

「3.3.1(3)　プレビューで使用するウィンドウ」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 55 / 218


3.3.3 EUR Web Plug-Inを使用してプレビューする : EUR 帳票出力 機能解説 EUR Server編

  • 56 / 218

  • 表紙

  • 3.　出力先を選んで出力する

  • 3.3　クライアントPCでプレビューするには

  • 3.3.3　EUR Web Plug-Inを使用してプレビューする

3.3.3　EUR Web Plug-Inを使用してプレビューする

クライアントPCのWebブラウザから，Webサーバにアクセスして印刷データ（EPF形式ファイル）をダウンロードすると，クライアントPCのEUR Web Plug-Inによって帳票をプレビューできます。帳票はWebブラウザ上に埋め込まれて表示されます。

〈この項の構成〉

  • (1)　プレビューの流れ

  • (2)　Webページの設定

  • (3)　起動部品の設定

  • (4)　注意事項

  • (5)　コーディング例

(1)　プレビューの流れ

EUR Web Plug-Inを使用して，帳票をWebブラウザからダウンロードして出力する場合と同じです。詳細については，「3.2.5　EUR Web Plug-Inを使用して出力する」を参照してください。

印刷データ（EPF形式ファイル）のダウンロードが完了すると，EUR Web Plug-Inによって帳票がプレビューされます。

帳票のプレビュー後に帳票を出力する場合は，EUR Web Plug-InのPrintEPFメソッドを呼び出して実行します。

ページの先頭へ

(2)　Webページの設定

「3.2.5(2)　Webページの設定」を参照してください。

ページの先頭へ

(3)　起動部品の設定

「3.2.5(3)　起動部品の設定」を参照してください。

ページの先頭へ

(4)　注意事項

  • 32ビット版のInternet Explorerを使用してください。64ビット版のInternet Explorerでは，帳票をプレビューできません。

  • Internet Explorerで帳票をプレビューしているときに，Internet Explorerのメニューバーの［表示］－［拡大］からページの拡大または縮小を実行すると，帳票の表示が不正になります。Internet Explorerのウィンドウを最小化して元のサイズに戻すと，帳票を正しく表示できます。

  • 帳票のプレビューと印刷を同時に実行する場合は，帳票をダウンロードするWebページに，EUR Web Plug-Inのプレビュー用の<object>タグと印刷用の<object>タグを記述してください。

ページの先頭へ

(5)　コーディング例

クライアントPCにユーザ単位インストール用とマシン単位インストール用のどちらかのEUR Web Plug-Inダウンロードパッケージを配置して，最新のEUR Web Plug-Inを自動でインストールして帳票をプレビューします。

■EUR Web Plug-Inダウンロードパッケージ：EUR Server - Adapter稼働マシンに配置

http://xxx.xxx.xxx.xxx/cab/EURPMPreViewAX.cab

■出力ファイル：EUR Server - Adapter稼働マシンに配置

出力EPF形式ファイル名：http://xxx.xxx.xxx/File/EPF/sample.epf

■処理内容

クライアントPCに最新のEUR Web Plug-Inがインストールされていない場合，ユーザ単位インストール用またはマシン単位インストール用のどちらかのEUR Web Plug-InダウンロードパッケージとEUR Web Plug-In情報ファイルを配置したクライアントPCに，最新のEUR Web Plug-Inが自動でインストールされます。

コーディング例を次に示します。

(a)　ActiveX起動部品の場合

<%@ LANGUAGE="VBScript" %>
<HTML>
<HEAD>
<META http-equiv="Content-Type"
 content="text/html;charset=Shift_JIS">
<TITLE>
EUR-CLP-PVX ASP Sample
</TITLE>
<%
'Webサーバの処理
    Dim objEURPM
    'EURPMオブジェクトの生成
    Set objEURPM=Server.CreateObject("EURPM.Exec")
    Dim strVersion
    'EUR-CLP-PVXのバージョン取得
    strVersion = objEURPM.GetPreviewAXVersion()
    Dim strClassID
    'EUR-CLP-PVXのクラスID取得
    strClassID = objEURPM.GetPreviewAXClassID()
%>
</HEAD>
<BODY>
<Script LANGUAGE="vbScript">
<!--
    'EUR Web Plug-Inダウンロードパッケージの格納場所の設定
    Dim CabPath
    CabPath = " http://xxx.xxx.xxx.xxx/cab/EURPMPreViewAX.cab"

    'OBJECTタグの記述
    document.Write("<object")
    'Webサーバで取得したクラスIDを指定
    document.Write(" classid=clsid:<%=strClassID%>")
    'CAB形式ファイルのパスおよびWebサーバで取得したバージョンを指定
    document.Write(" codebase=" & CabPath & "#version=<%=strVersion%>")
    document.Write(" ID=EURPMPREVIEWAX")
    document.Write(" width=500")
    document.Write(" height=500")
    document.Write(" type=application/x-oleobject>")
    document.Write("<BR>")
    document.Write("<param name=EPFFileURL value=http://xxx.xxx.xxx/File/EPF/sample.epf>")
    document.Write("<BR>")
    document.Write("<param name=LogLevel value=16>")
    document.Write("<BR>")
    document.Write("</object>")
    document.Write("<BR>")
-->
</Script>
</BODY>
</HTML>

(b)　Java起動部品の場合

<%@ page import="JP.co.Hitachi.soft.EURPM.*" %>
<%@ page contentType="text/html; charset=Shift_JIS" %>
<jsp:useBean id="adapter" class="JP.co.Hitachi.soft.EURPM.EURPMAdapterForJava" scope="session" />
<HTML>
<HEAD>
<TITLE>
EUR-CLP-AX JSP Sample
</TITLE>
<%
    //EUR-CLP-PVXのバージョン取得
    String strVersion = adapter. getPreviewAXVersion();
    //EUR-CLP-PVXのクラスID取得
    String strClassID = adapter. getPreviewAXClassID();
%>
</HEAD>
<BODY>
<Script LANGUAGE="javascript">
<!--
    //EUR Web Plug-Inダウンロードパッケージの格納場所の設定
    var CABPath; // CAB形式ファイルの格納場所
    CabPath = "http://xxx.xxx.xxx.xxx/cab/EURPMPreViewAX.cab";

    //OBJECTタグの記述
    document.write("<object");
    //Webサーバで取得したクラスIDを指定
    document.write(" classid=clsid:<%=strClassID%>");
    //CAB形式ファイルのパスおよびWebサーバで取得したバージョンを指定
    document.write(" codebase=" + CabPath + "#version=<%=strVersion%>");
    document.write(" ID=EURPMPREVIEWAX");
    document.write(" width=500");
    document.write(" height=500");
    document.write(" type=application/x-oleobject>");
    document.write("<BR>");
    document.write("<param name=EPFFileURL value=http://xxx.xxx.xxx/File/EPF/sample.epf>");
    document.write("<BR>");
    document.write("<param name=LogLevel value=16>");
    document.write("<BR>");
    document.write("</object>");
    document.write("<BR>");
-->
</Script>
</BODY>
</HTML>

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 56 / 218


3.3.4 EUR Client Serviceをヘルパ起動してプレビューする : EUR 帳票出力 機能解説 EUR Server編

  • 57 / 218

  • 表紙

  • 3.　出力先を選んで出力する

  • 3.3　クライアントPCでプレビューするには

  • 3.3.4　EUR Client Serviceをヘルパ起動してプレビューする

3.3.4　EUR Client Serviceをヘルパ起動してプレビューする

クライアントPCのWebブラウザから，Webサーバにアクセスして印刷データ（EPF形式ファイル）をダウンロードすると，クライアントPCのEUR Client Serviceが起動して，帳票がプレビューされます。

〈この項の構成〉

  • (1)　プレビューの流れ

  • (2)　起動部品の設定

  • (3)　プレビューで使用するウィンドウ

(1)　プレビューの流れ

EUR Client Serviceをヘルパ起動してWebブラウザから帳票を出力する場合と同じです。詳細については，「3.2.6　EUR Client Serviceをヘルパ起動して出力する」を参照してください。

なお，HTTPヘッダに指定するEPF形式ファイルのMIMEタイプには「application/vnd.hitachi.eurpm-view」と指定してください。MIMEタイプが「application/vnd.hitachi.eurpm-view」であっても，ファイルの拡張子が*.eppの場合は，帳票が自動印刷されます。

ページの先頭へ

(2)　起動部品の設定

「3.2.6(3)　起動部品の設定」を参照してください。

ページの先頭へ

(3)　プレビューで使用するウィンドウ

(a)　プレビューウィンドウ

プレビューウィンドウでは，帳票の印刷イメージを確認できます。

表3‒7 プレビューウィンドウのメニュー（ヘルパクライアント印刷）
メニュー |  | 機能 | ボタン
ファイル(F) | 開く(O) | ［ファイルを開く］ダイアログが表示されます。 | [図データ]
 | 印刷(R) | ［印刷先指定］ダイアログが表示されます。 | [図データ]
 | プロパティ(P) | ［プロパティ］ダイアログが表示されます。 | [図データ]
 | 終了(X) | プレビューウィンドウが終了します。 | －
編集(E) | 検索(F) | ［検索］ダイアログが表示されます。 | [図データ]
 | 次を検索(N) | ［検索］ダイアログで前回実行した検索の内容に従って，次の検索を実行します。一度も検索を実行していない場合は，［検索］ダイアログが表示されます。 | －
表示(V) | ツールバー(T) | チェックを入れると，ツールバーが表示されます。 | －
 | ステータスバー(S) | チェックを入れると，ステータスバーが表示されます。 | －
 | 先頭ページ(O) | 先頭ページに移動します。 | [図データ]
 | 前ページ(B) | 前ページに移動します。 | [図データ]
 | 次ページ(N) | 次ページに移動します。 | [図データ]
 | 最終ページ(L) | 最終ページに移動します。 | [図データ]
 | 指定ページへジャンプ(J) | ［指定ページへジャンプ］ダイアログが表示されます。指定したページに移動します。 | [図データ]
 | 拡大(U) | 表示された帳票を拡大します。10%ずつ拡大します。 | [図データ]
 | 縮小(D) | 表示された帳票を縮小します。10%ずつ縮小します。 | [図データ]
 | 拡大率の指定(P) | ［拡大率の指定］ダイアログが表示されます。指定した拡大率で帳票が表示されます。 | [図データ]
ヘルプ(H) | ヘルプ(E) | 常に不活性です。 | [図データ]
 | バージョン情報(A) | ［バージョン情報］ダイアログが表示されます。 | －

(b)　［印刷先指定］ダイアログ

プレビューウィンドウの［ファイル］メニューの［印刷］をクリックすると，［印刷先指定］ダイアログが表示されます。

［印刷先指定］ダイアログの［OK］ボタンをクリックすると，指定したプリンタのトレイで帳票が印刷されます。指定したプリンタとトレイがクライアントPCにない場合は，エラーとなります。

［帳票ジョブ名］

クライアントプリンタクラス名を表示します。クライアントプリンタクラスが指定されていない場合は，帳票名を表示します。

［プリンタ］リストボックス

クライアントPCに登録されたプリンタ名を表示します。

［プリンタ］リストボックスに初期表示されるプリンタ名は，EUR Client Serviceの環境設定ファイルのSELECTDISPLAYPRINTERキーの指定で変更できます。

［プリンタ］リストボックスは，プリンタの種類と状態を次に示すアイコンで示します。

  • [図データ] ：OS上の通常使うプリンタ

  • [図データ] ：OS上の通常使うプリンタ以外のOSに登録されているプリンタ

［トレイ］リストボックス

プリンタ名を選択すると，OS上に登録されたプリンタ名のトレイ名を表示します。トレイを指定しなかった場合は，デフォルトのトレイで印刷されます。

印刷したことがある帳票ジョブを受信した場合で，［プリンタ］リストボックスに初期表示されるプリンタ名が，前回の受信時に設定したプリンタ名のときは，前回の受信時に設定したトレイ名が表示されます。

それ以外の場合は，トレイ名は表示されません。

［+］ボタン

［印刷先指定］ダイアログが拡張されて，［印刷オプション］を設定できます。

［－］ボタン

［印刷オプション］の設定が非表示になります。

［ページ指定］

印刷開始ページと印刷終了ページを指定します。

  • 印刷開始ページ

    初期表示は1（ページ）です。入力できる値は，1～999,999です。帳票の最終ページを超える値を指定した場合は，最終ページだけ印刷されます。

  • 印刷終了ページ

    初期表示は，帳票の最終ページです。入力できる値は，1～999,999です。帳票の最終ページを超える値を指定した場合は，最終ページまで印刷されます。

(c)　［検索］ダイアログ

プレビュー領域内をアイテム単位に文字列で検索できます。

［検索する文字列］テキストボックス

検索する文字列を指定します。最大127文字まで入力できます。

2回目以降の検索では，前回検索を実行したときの文字列が表示されます。

［大文字と小文字を区別する］チェックボックス

検索するときに英字の大文字と小文字を区別するかどうかを指定します。英字の大文字と小文字を区別する場合はチェックボックスをオンにします。デフォルトはオンです。2回目以降の検索では，前回検索を実行したときの状態で表示されます。

［検索する方向］グループボックス

検索する方向を指定します。下方向に検索する場合は［下へ］ラジオボタンを，上方向に検索する場合は［上へ］ラジオボタンを選択します。デフォルトは［下へ］ラジオボタンが選択状態で表示されます。2回目以降の検索では，前回検索を実行したときの選択状態で表示されます。

［次を検索］ボタン

入力された検索条件に従って，プレビュー領域の文字列検索を実行します。

検索する文字列が見つかった場合，見つかった文字列が反転表示されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 57 / 218


3.3.5 コマンドを実行してプレビューする : EUR 帳票出力 機能解説 EUR Server編

  • 58 / 218

  • 表紙

  • 3.　出力先を選んで出力する

  • 3.3　クライアントPCでプレビューするには

  • 3.3.5　コマンドを実行してプレビューする

3.3.5　コマンドを実行してプレビューする

クライアントPCでeurpmcepfviewerコマンドを実行すると，クライアントPCのEUR Client Serviceが起動して，帳票がプレビューされます。

eurpmcepfviewerコマンドの構文については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

〈この項の構成〉

  • (1)　プレビューの流れ

  • (2)　起動部品の設定

  • (3)　プレビューで使用するウィンドウ

  • (4)　コーディング例

(1)　プレビューの流れ

コマンドを実行して出力する場合と同じです。詳細については，「3.2.7　コマンドを実行して出力する」を参照してください。

eurpmcepfviewerコマンドを実行するときは，/rオプションの指定を省略してください。なお，ファイルの拡張子が*.eppであっても，eurpmcepfviewerコマンドの実行時に，/rオプションの指定を省略した場合は，帳票がプレビューされます。

ページの先頭へ

(2)　起動部品の設定

「3.2.7(2)　起動部品の設定」を参照してください。

ページの先頭へ

(3)　プレビューで使用するウィンドウ

「3.3.4(3)　プレビューで使用するウィンドウ」を参照してください。

ページの先頭へ

(4)　コーディング例

■帳票をプレビュー表示する場合
"C:\Program Files\Hitachi\EUR\Client\Program\EURPMCEPFViewer.exe" C:\temp\EPFFile.epf

EPF形式ファイル名：EPFFile.epf

ファイルのある場所：C:\temp

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 58 / 218


4. ファイル形式を選んで出力する : EUR 帳票出力 機能解説 EUR Server編

  • 59 / 218

  • 表紙

  • 4.　ファイル形式を選んで出力する

4.　ファイル形式を選んで出力する

この章では，帳票の出力方法をファイル形式ごとに説明します。

〈この章の構成〉

  • 4.1　PDF形式ファイルを出力するには

  • 4.2　EUR形式ファイルを出力するには

  • 4.3　Excel形式ファイルを出力するには

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 59 / 218


4.1 PDF形式ファイルを出力するには : EUR 帳票出力 機能解説 EUR Server編

  • 60 / 218

  • 表紙

  • 4.　ファイル形式を選んで出力する

  • 4.1　PDF形式ファイルを出力するには

4.1　PDF形式ファイルを出力するには

ここでは，PDF形式ファイルの帳票を出力する方法について説明します。PDF形式ファイルを出力するには，EUR Server Standard，またはEUR Server Enterpriseが必要です。

PDF形式ファイルには，次の表に示すようにさまざまな設定ができます。運用に応じて，必要な設定をしてください。

表4‒1 PDF形式ファイルの設定内容
設定内容 | 説明 | 参照先
仕分け | 指定したキーワードでPDF形式ファイルを仕分けして出力します（仕分け出力）。 | 6.1
分割 | 指定したページ数でPDF形式ファイルを分割して出力します（分割出力）。 | 6.2
暗号化※ | PDF形式ファイルを暗号化するセキュリティ属性を設定して出力します（暗号化出力）。 | 4.1.2
しおりの付加 | PDF形式ファイルにしおりを付けて出力します。 | 4.1.3
フォントの埋め込み | PDF形式ファイルにフォントを埋め込んで出力します。 | 4.1.4
解像度の指定 | PDF形式ファイルの出力時の解像度を指定して出力します。 | 4.1.5
JavaScriptプログラムの埋め込み | PDF形式ファイルにJavaScriptプログラムを埋め込んで出力します。 | 4.1.6
Adobe ReaderのGUIの制御情報 | PDF形式ファイルを開いたときのAdobe ReaderのGUIの制御情報（ビューアプレファレンス）を設定して出力します。 | 4.1.7
注※

PDF形式ファイルを暗号化出力するには，EUR Server Standard，またはEUR Server Enterpriseに加えて，EUR Server - Cipher optionが帳票サーバに必要です。

〈この節の構成〉

  • 4.1.1　出力の流れ

  • 4.1.2　暗号化して出力する

  • 4.1.3　しおりを付けて出力する

  • 4.1.4　フォントを埋め込んで出力する

  • 4.1.5　解像度を指定して出力する

  • 4.1.6　JavaScriptプログラムを埋め込んで出力する

  • 4.1.7　Adobe ReaderのGUIの制御情報を設定して出力する

  • 4.1.8　コーディング例

  • 4.1.9　注意事項

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 60 / 218


4.1.1 出力の流れ : EUR 帳票出力 機能解説 EUR Server編

  • 61 / 218

  • 表紙

  • 4.　ファイル形式を選んで出力する

  • 4.1　PDF形式ファイルを出力するには

  • 4.1.1　出力の流れ

4.1.1　出力の流れ

PDF形式ファイルを出力する流れを次の図に示します。

図4‒1　PDF形式ファイルを出力する流れ

[図データ]

  1. 出力要求

    帳票の出力要求が業務プログラムに送られます。

  2. 転送

    EUR Server - Adapterは，ユーザデータファイルを帳票サーバのEUR Server Serviceに転送します。

  3. 印刷データ生成

    転送されたユーザデータファイルとあらかじめ帳票サーバに配置しておいた印刷定義ファイルから，印刷データ（PDF形式ファイル）が生成されます。

    なお，暗号化PDF形式ファイルを生成する場合は，EUR Server - Cipher optionが必要です。

  4. 印刷データ転送

    PDF形式ファイルをEUR Server - Adapter稼働マシンに出力する設定にしている場合，EUR Server Serviceは，生成された印刷データ（PDF形式ファイル）をアプリケーションサーバに転送します。生成された印刷データ（PDF形式ファイル）を他システムで利用する場合など，PDF形式ファイルをEUR Server Service稼働マシンに出力する設定にしている場合は転送しません。

  5. 出力，プレビュー

    PDF形式ファイルをEUR Server - Adapter稼働マシンに出力する設定にしている場合，クライアントPCのAdobe Readerを使用して帳票をプリンタに出力したり，プレビューしたりできます。この場合，印刷データ（PDF形式ファイル）をアプリケーションサーバからダウンロードする必要があります。

■注意

PDF形式ファイルを仕分けまたは分割して出力する場合，PDF形式ファイルはEUR Server Service稼働マシンに出力されます。出力先のフォルダは，EUR Print Serviceの環境変数（EURPS_OUTPUTPATH）の設定に依存します。EUR Print Serviceの環境変数（EURPS_OUTPUTPATH）については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

〈この項の構成〉

  • (1)　起動部品の設定

(1)　起動部品の設定

PDF形式ファイルの出力で使用する起動部品のメソッド，関数，およびオプションの指定値を次に示します。

  • ActiveX起動部品：OutputPDFReportメソッド

  • Java起動部品：outputPDFReportメソッド

  • COBOL起動部品：OutputPDFReport関数

  • コマンド起動部品（eurpmcコマンド）：/mオプションにpdfを指定

また，出力時に設定する起動部品のプロパティ，メソッド，パラメタ，およびオプションの指定値を次に示します。

  1. 帳票ファイルの設定

    印刷する帳票ファイル名を設定します。

    帳票ファイルの設定

    起動部品の設定項目

    設定する値

    帳票ファイルの名前

    ActiveX起動部品：ReportFileNameプロパティ

    Java起動部品：setReportFileNameメソッド

    COBOL起動部品：REPORTNAMEパラメタ

    コマンド起動部品：/rfオプション

    帳票ファイル名（255バイト以内の文字列）

  2. PDF形式ファイルの設定

    PDF形式ファイル名および出力先のサーバを設定します。

    PDF形式ファイルの設定

    起動部品の設定項目

    設定する値

    PDF形式ファイル名

    ActiveX起動部品：PDFFileNameプロパティ

    Java起動部品：setPDFFileNameメソッド

    COBOL起動部品：PDFFILENAMEパラメタ

    コマンド起動部品：/pdfnオプション

    PDF形式ファイル名（255バイト以内の文字列）

    ファイルの出力先

    ActiveX起動部品：FileOutputDestinationプロパティ

    Java起動部品：setFileOutputDestinationメソッド

    COBOL起動部品：FILEOUTPUTDESTINATIONパラメタ

    0（EUR Server - Adapter稼働マシンに出力する）

    1（EUR Server Service稼働マシンに出力する）

    コマンド起動部品：/foutdestオプション

    adp（EUR Server - Adapter稼働マシンに出力する）

    pm（EUR Server Service稼働マシンに出力する）

  3. マッピングデータファイルの設定

    マッピングデータファイル名を設定します。

    ユーザデータファイルの設定

    起動部品の設定項目

    設定する値

    マッピングデータファイルの名前

    ActiveX起動部品：DataFileNameプロパティ

    Java起動部品：setDataFileNameメソッド

    COBOL起動部品：MAPPINGDATAパラメタ

    コマンド起動部品：/mapオプション

    マッピングデータファイル名（255バイト以内の文字列）

  4. ユーザデータファイル，印刷定義ファイル，および印刷付加情報の設定

    必要に応じて，ユーザデータファイル（ユーザ定義データファイルなど），印刷定義ファイル（複数様式情報定義ファイル，文書情報設定ファイル，置き換え表管理情報ファイルなど）および印刷付加情報（印刷開始ページ，ページ番号など）を設定します。

■参考

1.の帳票ファイルの設定は，起動部品で帳票ファイル名を直接指定する以外に，次のどちらかで指定することもできます。

  • 帳票セット指定ファイル

    帳票ファイル名やマッピングデータファイル名を，帳票セットとして帳票セット指定ファイルにまとめて指定することができます。出力時には次に示すプロパティ，メソッド，パラメタ，またはオプションで帳票セット指定ファイル名を指定してください。

    ・ActiveX起動部品：MultiReportSetFileNameプロパティ

    ・Java起動部品：setMultiReportSetFileNameメソッド

    ・COBOL起動部品：REPORTSETFILEパラメタ

    ・コマンド起動部品：/mrsオプション

  • 帳票ID

    帳票ファイル名を含む帳票出力で使用する項目を，帳票出力定義として帳票出力定義ファイルに指定することができます。帳票IDには，帳票出力時に使用する帳票出力定義ファイル名を指定します。出力時には次に示すプロパティ，メソッド，パラメタ，またはオプションで帳票出力定義ファイル名を指定してください。

    ・ActiveX起動部品：ReportIDプロパティ

    ・Java起動部品：setReportIDメソッド

    ・COBOL起動部品：REPORTIDパラメタ

    ・コマンド起動部品：/ridオプション

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 61 / 218


4.1.2 暗号化して出力する : EUR 帳票出力 機能解説 EUR Server編

  • 62 / 218

  • 表紙

  • 4.　ファイル形式を選んで出力する

  • 4.1　PDF形式ファイルを出力するには

  • 4.1.2　暗号化して出力する

4.1.2　暗号化して出力する

PDF形式ファイルを暗号化するセキュリティ属性を設定して出力できます（暗号化出力）。暗号化することで，PDF形式ファイルの改ざん，および給与明細などの情報の漏えいを防げます。

また，仕分け出力と組み合わせることで，PDF形式ファイルの暗号化仕分け出力，分割出力と組み合わせることで，PDF形式ファイルの暗号化分割出力ができます。

暗号化仕分け出力の詳細については，「6.1.2　PDF暗号化仕分け出力する」，暗号化分割出力の詳細については，「6.2.2　PDF暗号化分割出力する」を参照してください。

PDF形式ファイルを暗号化出力するには，EUR Server Standard，またはEUR Server Enterpriseに加えて，EUR Server - Cipher optionが帳票サーバに必要です。

〈この項の構成〉

  • (1)　使用するファイル

  • (2)　暗号化出力したPDF形式ファイルの動作

  • (3)　パスワードの暗号化

  • (4)　注意事項

(1)　使用するファイル

PDF形式ファイルを暗号化出力するには，帳票出力時に暗号化設定ファイルの指定が必要です。暗号化設定ファイルには，PDF形式ファイルを暗号化するセキュリティ属性を指定します。暗号化設定ファイルで指定できる項目を次に示します。

  • ユーザパスワード（PDF形式ファイルを閲覧するためのパスワード）

  • オーナパスワード（セキュリティ属性を変更するパスワード）

  • 印刷

  • 文書の変更

  • 内容のコピー，または抽出

  • 注釈とフォームフィールドの作成

なお，ユーザパスワードとオーナパスワードには，暗号化したパスワードも指定できます。パスワードの暗号化については，「(3)　パスワードの暗号化」を参照してください。

■PDF形式ファイルを暗号化出力する場合の指定例

出力先ファイル「OUTPUT.pdf」に，次の設定をするときの指定例です。

  • PDF形式ファイルを閲覧するとき，パスワードの入力を求めます。

  • PDF形式ファイルの印刷を禁止します。

暗号化設定ファイル（cipher.txt）の定義内容
OwnerPassword=OWNER
DisablePrint=Yes
UserPassword=HITACHI
マッピングデータファイル（shikyuu.csv）の内容
所属,氏名,支給額
勤労課,日立太郎,250000
勤労課,日立花子,200000

「OUTPUT.pdf」には，「勤労課　日立太郎　250,000円」と「勤労課　日立花子　200,000円」が出力されます。

「OUTPUT.pdf」を開こうとすると，パスワードの入力を求められます。

「OUTPUT.pdf」を開くと，［文書のセキュリティ］ダイアログには次のように表示されます。

ユーザパスワード：はい

マスタパスワード：はい

印刷　　　　　　：許可しない

なお，お使いのAdobe Readerのバージョンによっては，表示内容が異なる場合があります。

暗号化設定ファイルの指定内容の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

(2)　暗号化出力したPDF形式ファイルの動作

暗号化出力したPDF形式ファイルを開いたときの動作を，次の表に示します。

表4‒2　暗号化出力したPDF形式ファイルを開いたときの動作

項番

PDF仕分け定義ファイル

暗号化設定ファイル

動作

ユーザパスワード

オーナパスワード

ユーザパスワード

1

－

○

－

パスワードの入力を求められません。

自由にファイルを開けますが，暗号化設定ファイルに設定されているセキュリティ属性は有効です。

2

○

－

－

パスワードの入力を求められます。

ユーザパスワードが通知されている閲覧者だけファイルを開けます。また，暗号化設定ファイルに設定されているセキュリティ属性も有効です。

3

－

－

○

4

○

○

－

パスワードの入力を求められます。入力するパスワードは，オーナパスワードとユーザパスワードのどちらでもかまいません。ただし，どちらのパスワードを入力するかによって，セキュリティ属性は次のように異なります。

  • オーナパスワードを入力したとき

    暗号化設定ファイルに設定されているセキュリティ属性は，すべて解除した状態で表示されます。

  • ユーザパスワードを入力したとき

    暗号化設定ファイルに設定されているセキュリティ属性は有効です。

5

－

○

○
（凡例）

○：指定あり。

－：指定なし。

■PDF形式ファイルを暗号化仕分け出力する場合の注意

  • ユーザパスワードは，PDF仕分け定義ファイルのuserpasswordで指定します。暗号化設定ファイルのキーワードUserPasswordの指定はいりません。指定されていても無視されます。

  • パスワードは，暗号化設定ファイルのキーワードOwnerPassword，またはPDF仕分け定義ファイルのuserpasswordのどちらかを指定してください。どちらも指定していない場合は，エラー（KEEU033-E）になります。

  • 暗号化設定ファイルで指定するOwnerPasswordと，PDF仕分け定義ファイルで指定するuserpasswordは，異なるパスワードを指定してください。同じパスワードが指定されている場合は，エラー（KEEU034-E）になります。

ページの先頭へ

(3)　パスワードの暗号化

セキュリティを強化するために，暗号化設定ファイル，およびPDF仕分け定義ファイルに指定するユーザパスワードとオーナパスワードを暗号化できます。

パスワードの暗号化は，PDFパスワード暗号化ツール（eurecpdfコマンド）で行います。PDFパスワード暗号化ツールは，EUR Server - Cipher optionに同梱されています。

(a)　ファイル名

PDFパスワード暗号化ツールのファイル名と格納先を次に示します。

  • Windows環境の場合

    ファイル名：eurecpdf.exe

    格納先：EUR Server - Cipher optionのインストール先フォルダ\Cipher\x64

  • UNIX／Linux環境の場合

    ファイル名：eurecpdf

    格納先：/opt/eur/print/bin

(b)　コマンドの構文

PDFパスワード暗号化ツールのコマンドの構文を次に示します。なお，オプションのセパレータは「/」で示しています。UNIX／Linux環境の場合の場合は，「/」を「-」に置き換えてお読みください。

eurecpdf
     /t 暗号化対象ファイル種別
     /if 暗号化対象ファイルパス
     /of 出力先ファイルパス
     /es 暗号化鍵

  • /tオプション

    暗号化するファイルの種別を指定します。指定できるファイル種別を次に示します。

        cr：暗号化設定ファイル

        pd：PDF仕分け定義ファイル

    大文字と小文字の区別はしません。「cr」，「pd」以外の文字を指定すると，エラーになります。

  • /ifオプション

    パスワードを暗号化する暗号化設定ファイル名，またはPDF仕分け定義ファイル名のフルパスを，259文字以内で指定します。

  • /ofオプション

    パスワードを暗号化したデータを出力するファイルのフルパスを，259文字以内で指定します。

  • /esオプション

    暗号化したパスワードから元のパスワードを読み出すための，暗号化鍵を指定します。パスワード暗号化鍵に指定できる文字は，次のとおりです。

    • 半角数字

      0～9

    • 半角英字

      A～Z，a～z

    指定できるパスワード暗号化鍵の長さは，Shift JISコードで32バイトまでです。32バイトを超えた場合は，エラー（KEEU806-E）になります。また，パスワード暗号化鍵に指定できない文字を指定した場合も，エラー（KEEU806-E）になります。

(c)　出力されるファイル

PDFパスワード暗号化ツールのコマンドを実行すると，暗号化設定ファイルまたはPDF仕分け定義ファイルの中のパスワードだけが暗号化され，指定したファイルに出力されます。暗号化前のファイルへの上書きはできません。

ページの先頭へ

(4)　注意事項

  • PDF形式ファイルの暗号化出力は，日本語ロケールでだけ正しく動作します。PDF形式ファイルを暗号化出力するときは，ロケールを日本語環境に設定してください。

  • PDF形式ファイルのセキュリティ属性を変更する場合は，暗号化設定ファイルから行ってください。Adobe AcrobatでPDF形式ファイルを開き，オーナパスワードを入力することで文書のセキュリティを変更できますが，この場合EURでは動作を保証しません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 62 / 218


4.1.3 しおりを付けて出力する : EUR 帳票出力 機能解説 EUR Server編

  • 63 / 218

  • 表紙

  • 4.　ファイル形式を選んで出力する

  • 4.1　PDF形式ファイルを出力するには

  • 4.1.3　しおりを付けて出力する

4.1.3　しおりを付けて出力する

PDF形式ファイルにしおりを付けて出力できます。

しおりとは，見たいページに移動するために付加する印です。PDF形式ファイルにしおりを付加しておくと，Adobe Readerで表示したときに，次のような利点があります。

  • PDF形式ファイルの構成がわかりやすい

  • PDF形式ファイルを閲覧しやすい（しおりを選択することで，目的の場所に直接ジャンプできる）

〈この項の構成〉

  • (1)　しおりに出力できるもの

  • (2)　使用するファイル

  • (3)　注意事項

(1)　しおりに出力できるもの

しおりに出力できるものを次に示します。

  • PDF文書情報のタイトル

    「PDF形式ファイルを示すしおり」になります。

  • 帳票名

    「PDF形式ファイルを構成するサブ文書（帳票）を示すしおり」になります。

  • キー項目

    「（帳票に出力する）データのまとまりを表す項目のしおり」になります。「データのまとまり」とは，特定のフィールドでの同一データのことです。対象となるデータは，マッピングデータです。

PDF形式ファイルの構成としおりの対応を，次の図に示します。

図4‒2　PDF形式ファイルの構成としおりの対応

[図データ]

「PDF形式ファイルを示すしおり」をトップレベルのしおりとしますが，「PDF形式ファイルを示すしおり」がない場合は，「PDF形式ファイルを構成するサブ文書（帳票）を示すしおり」をトップレベルのしおりとします。

「（帳票に出力する）データのまとまりを表す項目のしおり」は，しおり定義ファイル中に指定した順に出力されます。階層は，5階層までです。

なお，「PDF形式ファイルを構成するサブ文書（帳票）を示すしおり」と「（帳票に出力する）データのまとまりを表す項目のしおり」を総称して，「サブ文書の情報を示すしおり」と呼びます。

ページの先頭へ

(2)　使用するファイル

「PDF形式ファイルを示すしおり」を付ける場合は，文書しおり定義ファイルに情報を設定します。「サブ文書の情報を示すしおり」を付ける場合は，しおり定義ファイルに情報を設定します。各ファイルの指定内容の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

(a)　文書しおり定義ファイル

文書しおり定義ファイルには，「PDF形式ファイルを示すしおり」となる文字列とPDF形式ファイルのページの表示方法を指定します。

文書しおり定義ファイルに「PDF形式ファイルを示すしおり」の情報が指定されていると，PDF形式ファイルを開いた場合，次のように表示されます。

(b)　しおり定義ファイル

しおり定義ファイルには，「PDF形式ファイルを構成するサブ文書（帳票）を示すしおり」と「（帳票に出力する）データのまとまりを表す項目のしおり」の文字列とPDF形式ファイルのページの表示方法を指定します。

しおり定義ファイルに「サブ文書の情報を示すしおり」の情報が指定されていると，PDF形式ファイルを開いた場合，次のように表示されます。

■PDF形式ファイルにしおりを付ける場合の指定例
文書しおり定義ファイルの定義内容
TITLE="ペット情報"
SCALE=fit
BOOKMARK=open
しおり定義ファイルの定義内容
NAME="ペット"
BREAKFLD="科目",fit

次に示すように表示されます。フィールド名「科目」のデータのまとまりを示す項目「イヌ」，「ウサギ」，または「ハムスター」をクリックすると，直接ページを開けます。

しおり定義ファイルの指定内容と，しおりの文字列との関係を次の図に示します。

ページの先頭へ

(3)　注意事項

EUR 帳票作成機能で設計した帳票に出力ページ機能が設定されている場合でも，しおり付きPDF形式ファイルを出力することはできます。ただし，出力ページと連動させたり，最終ページのしおりをしおりパレットに出力させたりすることはできません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 63 / 218


4.1.4 フォントを埋め込んで出力する : EUR 帳票出力 機能解説 EUR Server編

  • 64 / 218

  • 表紙

  • 4.　ファイル形式を選んで出力する

  • 4.1　PDF形式ファイルを出力するには

  • 4.1.4　フォントを埋め込んで出力する

4.1.4　フォントを埋め込んで出力する

PDF形式ファイルにフォントを埋め込んで出力できます。フォントを埋め込むことで，PDF形式ファイルを出力するマシンにインストールされていないフォントも出力できるようになります。

PDF形式ファイルにフォントを埋め込んで出力するには，プリンタ定義ファイルに埋め込むフォントの書体名と対応するフォントファイル名を指定します。プリンタ定義ファイルの指定内容の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

■フォントを埋め込むときの注意

埋め込みが許可されていないフォントを埋め込むことはできません。埋め込みに使用するフォントは，次の点を確認してから使用してください。

  • フォントファイルの属性に埋め込みが許可されているか

  • フォントの埋め込みについてライセンス許諾があるか

  • フォントを埋め込んだPDFファイルを配布する場合，フォントの再配布についてライセンス許諾があるか

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 64 / 218


4.1.5 解像度を指定して出力する : EUR 帳票出力 機能解説 EUR Server編

  • 65 / 218

  • 表紙

  • 4.　ファイル形式を選んで出力する

  • 4.1　PDF形式ファイルを出力するには

  • 4.1.5　解像度を指定して出力する

4.1.5　解像度を指定して出力する

PDF形式ファイルの出力時の解像度を指定して出力できます。バーコードのあるPDF形式ファイルを出力する場合，使用するプリンタの解像度を指定することで，プリンタの解像度に合わせたバーコードを印刷できます。

PDF形式ファイルの出力時の解像度は，プリンタ定義ファイルに指定します。プリンタ定義ファイルの指定内容の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 65 / 218


4.1.6 JavaScriptプログラムを埋め込んで出力する : EUR 帳票出力 機能解説 EUR Server編

  • 66 / 218

  • 表紙

  • 4.　ファイル形式を選んで出力する

  • 4.1　PDF形式ファイルを出力するには

  • 4.1.6　JavaScriptプログラムを埋め込んで出力する

4.1.6　JavaScriptプログラムを埋め込んで出力する

PDF形式ファイルにJavaScriptプログラムを埋め込んで出力できます。PDF形式ファイルにJavaScriptプログラムを埋め込むことで，Adobe Readerの「ページを開く」などのメニューを操作したときにエラーを出力したり，メールを送信したりするなどの機能を実行できます。

〈この項の構成〉

  • (1)　使用するファイル

(1)　使用するファイル

PDF形式ファイルにJavaScriptプログラムを埋め込むには，Acrobat JavaScriptファイルおよびAcrobat JavaScript定義ファイルが必要です。

(a)　Acrobat JavaScriptファイル

Acrobat JavaScriptファイルには，PDF形式ファイルに埋め込むJavaScriptプログラムを指定します。指定内容の詳細については，Adobeのマニュアルを参照してください。

(b)　Acrobat JavaScript定義ファイル

Acrobat JavaScript定義ファイルには，PDFファイルに埋め込むAcrobat JavaScriptファイル名を指定します。Acrobat JavaScript定義ファイルは，CSV形式で作成します。Acrobat JavaScript定義ファイルの指定内容の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 66 / 218


4.1.7 Adobe ReaderのGUIの制御情報を設定して出力する : EUR 帳票出力 機能解説 EUR Server編

  • 67 / 218

  • 表紙

  • 4.　ファイル形式を選んで出力する

  • 4.1　PDF形式ファイルを出力するには

  • 4.1.7　Adobe ReaderのGUIの制御情報を設定して出力する

4.1.7　Adobe ReaderのGUIの制御情報を設定して出力する

PDF形式ファイルを開いたときのAdobe ReaderのGUIの制御情報（ビューアプレファレンス）を，PDF形式ファイルに設定して出力できます。

〈この項の構成〉

  • (1)　使用するファイル

(1)　使用するファイル

PDF形式ファイルにAdobe ReaderのGUIの制御情報を設定して出力するには，帳票出力時にビューアプレファレンス定義ファイルの指定が必要です。ビューアプレファレンス定義ファイルには，出力したPDF形式ファイルを開いた時に実行するビューアプレファレンスを指定します。ビューアプレファレンス定義ファイルは，CSV形式で作成します。ビューアプレファレンス定義ファイルの指定内容の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 67 / 218


4.1.8 コーディング例 : EUR 帳票出力 機能解説 EUR Server編

  • 68 / 218

  • 表紙

  • 4.　ファイル形式を選んで出力する

  • 4.1　PDF形式ファイルを出力するには

  • 4.1.8　コーディング例

4.1.8　コーディング例

次に示すパラメタを指定して，PDF形式ファイルを出力します。出力ファイルは，EUR Server - Adapter稼働マシンに出力されます。

■入力ファイル（印刷定義ファイル）：EUR Server Service稼働マシンに配置

帳票ファイル名：sample1.fms

■入力ファイル（ユーザデータファイル）：EUR Server - Adapter稼働マシンに配置

マッピングデータファイルのパス：c:\Temp

マッピングデータファイル名：data1.csv

■出力ファイル

出力PDF形式ファイルのパス：c:\Temp

出力PDF形式ファイル名：pdf1.pdf

コーディング例を次に示します。

〈この項の構成〉

  • (1)　ActiveX起動部品の場合

(1)　ActiveX起動部品の場合

<HTML>
<HEAD>
<TITLE>Sample Script of ASP page for EUR Print Manager</TITLE>
</HEAD>
<BODY>
<%
  Server.ScriptTimeOut=100     …スクリプトのタイムアウト時間を
                                 100秒に設定
  On Error Resume Next         …エラーハンドリングを行う
  dim target                   …変数宣言
  Set EURPM=Server.CreateObject("EURPM.Exec")
                        …プログラムID「EURPM.Exec」を指定して，
                          ActiveX起動部品のインスタンス作成
  EURPM.ReportFileName="sample1.fms"       …帳票ファイルの指定
  EURPM.DataFilePath="c:\Temp"             …マッピングデータファイルの
                                             パスの指定
  EURPM.DataFileName="data1.csv"           …マッピングデータの指定
  EURPM.PDFFilePath="c:\Temp"              …PDF形式ファイルパスの指定
  EURPM.PDFFileName="pdf1.pdf"             …PDF形式ファイル名の指定
  If Err.Number <> 0 Then
    Response.Write("印刷実行前に
                    エラーが発生しています"& Err.Number &"<BR>")
  Else
    EURPM.OutputPDFReport()               …PDF形式ファイル出力指示
    If Err.Number = 0 Then                …OutputPDFReportメソッドは
                                            正常終了かどうかの判定
      「正常終了時の処理」
    Else
      errid= Err.Number           …エラーコードをerridに取り出す
      If errid=-nnn Then          …KEEYnnn-Eの場合のエラー処理
        Elseif errid=-nnn Then    …KEEYnnn-Eの場合のエラー処理
        Elseif errid=-nnn Then    …KEEYnnn-Eの場合のエラー処理
        Elseif errid=
              :                   …そのほかのエラー処理を繰り返す
      End If
    End If
  End If
%>
</BODY>
</HTML>

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 68 / 218


4.1.9 注意事項 : EUR 帳票出力 機能解説 EUR Server編

  • 69 / 218

  • 表紙

  • 4.　ファイル形式を選んで出力する

  • 4.1　PDF形式ファイルを出力するには

  • 4.1.9　注意事項

4.1.9　注意事項

PDF形式ファイルを出力するときの注意事項について説明します。

〈この項の構成〉

  • (1)　PDF形式ファイルの出力で使用できるフォントについての注意

  • (2)　図形（網掛け）が設定されている帳票を出力するときの注意

  • (3)　バーコードのある帳票を出力するときの注意

  • (4)　光学式文字読み取り装置（OCR）で帳票を読み取るときの注意

  • (5)　PDF形式ファイルを出力するときの空白についての注意

(1)　PDF形式ファイルの出力で使用できるフォントについての注意

PDF形式ファイルの出力で使用できるフォントについては，マニュアル「EUR システム設計ガイド」を参照してください。

ページの先頭へ

(2)　図形（網掛け）が設定されている帳票を出力するときの注意

EUR 帳票作成機能で設計した帳票に，図形（網掛け）が設定されていると，PDF形式ファイルに出力したとき，網掛けの表示が乱れたり，印刷に時間が掛かったりすることがあります。図形（網掛け）が設定されている帳票をPDF形式ファイルに出力する場合は，EUR 帳票作成機能で，網パターンを「塗りつぶし」に変更してから出力してください。

ページの先頭へ

(3)　バーコードのある帳票を出力するときの注意

PDF形式ファイルをAdobe Readerなどで印刷した場合，バーコードの読み取りについては，動作を保証しません。

PDF形式ファイルを印刷するときは次のことに注意してください。

  • 印刷する場合は，拡大／縮小を指定しないでください。

    出力するプリンタの解像度でPDFファイルを作成して印刷し，読み取り確認をしてください。出力するプリンタの解像度でPDFファイルを作成するには，プリンタ定義ファイルのキーワードYDPIに，出力するプリンタの解像度を指定してください。

    プリンタ定義ファイルの指定内容の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

(4)　光学式文字読み取り装置（OCR）で帳票を読み取るときの注意

EUR サーバ帳票出力機能で出力した帳票を，光学式文字読み取り装置で読み取るときは，次のことに注意してください。

  • 帳票を出力する場合は，300dpi以上のレーザープリンタを使用してください。

  • 印刷ダイアログなどで，用紙サイズに合わせた縮小，または拡大の指定はしないでください。

  • ご使用になる光学式読み取り装置で，出力した帳票が読み取れるかどうかを確認してください。EUR 帳票作成機能で設計した帳票にOCRフォントが使用されている場合も，十分な確認を行ってください。

  • PDF形式ファイルを出力する場合は，プリンタ定義ファイルのキーワードYDPIに，出力するプリンタの解像度を指定してください。

    プリンタ定義ファイルの指定内容の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

(5)　PDF形式ファイルを出力するときの空白についての注意

  • PDF形式ファイルに半角空白および全角空白は出力されません。

    ただし，次に示す帳票の場合は，PDF形式ファイルに半角空白または全角空白が出力されます。

    • 均等に配置したアイテムがある場合

    • 桁数またはCPIを指定したアイテムがある場合，かつEUR Print Serviceの環境設定ファイル（EURPS_ENV）の環境変数EURPS_SKIP_OUTPUTSPACEキーで「NO」を設定した場合

    • ページ番号を余白に出力した場合

    • EUR Print Serviceの環境設定ファイル（EURPS_ENV）の環境変数EURPS_ENABLE_OUTPUTSPACEキーに「ON」を指定した場合

  • PDF形式ファイルをAdobe Readerで表示して文字列のコピーや検索を行う場合，PDF形式ファイルに半角空白が出力されていなくても，文字配置によって空白と認識されることがあります。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 69 / 218


4.2 EUR形式ファイルを出力するには : EUR 帳票出力 機能解説 EUR Server編

  • 70 / 218

  • 表紙

  • 4.　ファイル形式を選んで出力する

  • 4.2　EUR形式ファイルを出力するには

4.2　EUR形式ファイルを出力するには

ここでは，EUR形式ファイルの帳票を出力する方法について説明します。EUR形式ファイルを出力するには，EUR Server Standard，またはEUR Server Enterpriseが必要です。

EUR形式ファイルは，EURの独自形式の印刷データファイルです。帳票定義ファイルとデータファイル（マッピングデータファイル，ユーザ定義データファイル，および画像ファイル）を一つのパッケージにしたファイルで，PDF形式ファイルよりもサイズが小さく，ネットワーク負荷を軽減できます。1ファイルにまとめているので，Webシステムなどで帳票を利用するときに便利です。

〈この節の構成〉

  • 4.2.1　出力の流れ

  • 4.2.2　コーディング例

  • 4.2.3　注意事項

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 70 / 218


4.2.1 出力の流れ : EUR 帳票出力 機能解説 EUR Server編

  • 71 / 218

  • 表紙

  • 4.　ファイル形式を選んで出力する

  • 4.2　EUR形式ファイルを出力するには

  • 4.2.1　出力の流れ

4.2.1　出力の流れ

EUR形式ファイルを出力する流れを，次の図に示します。

図4‒3　EUR形式ファイルを出力する流れ

[図データ]

  1. 出力要求

    帳票の出力要求が業務プログラムに送られます。

  2. 転送

    EUR Server - Adapterは，ユーザデータファイルを帳票サーバのEUR Server Serviceに転送します。

  3. 印刷データ生成

    転送されたユーザデータファイルとあらかじめ帳票サーバに配置しておいた印刷定義ファイルから，印刷データ（EUR形式ファイル）が生成されます。

  4. 印刷データ転送

    EUR Server Serviceは，生成された印刷データ（EUR形式ファイル）をアプリケーションサーバに転送します。

  5. 出力，プレビュー

    クライアントPCのEUR Viewerを使用して，帳票をプリンタに出力したり，プレビューしたりできます。この場合，印刷データ（EUR形式ファイル）をアプリケーションサーバからダウンロードする必要があります。

    帳票を出力するには，EUR Viewerのメニューから［ファイル］－［印刷］を選択します。

〈この項の構成〉

  • (1)　起動部品の設定

(1)　起動部品の設定

EUR形式ファイルの出力で使用する起動部品のメソッド，関数，およびオプションの指定値を次に示します。

  • ActiveX起動部品：OutputEURReportメソッド

  • Java起動部品：outputEURReportメソッド

  • COBOL起動部品：OutputEURReport関数

  • コマンド起動部品（eurpmcコマンド）：/mオプションにeurを指定

また，出力時に設定する起動部品のプロパティ，メソッド，パラメタ，およびオプションの指定値を次に示します。

  1. 帳票ファイルの設定

    印刷する帳票ファイル名を設定します。

    帳票ファイルの設定

    起動部品の設定項目

    設定する値

    帳票ファイルの名前

    ActiveX起動部品：ReportFileNameプロパティ

    Java起動部品：setReportFileNameメソッド

    COBOL起動部品：REPORTNAMEパラメタ

    コマンド起動部品：/rfオプション

    帳票ファイル名（255バイト以内の文字列）

  2. EUR形式ファイルの設定

    EUR形式ファイル名を設定します。

    EUR形式ファイルの設定

    起動部品の設定項目

    設定する値

    EUR形式ファイル名

    ActiveX起動部品：EURFileNameプロパティ

    Java起動部品：setEURFileNameメソッド

    COBOL起動部品：EURFILENAMEパラメタ

    コマンド起動部品：/eurnオプション

    EUR形式ファイル名（255バイト以内の文字列）

  3. マッピングデータファイルの設定

    マッピングデータファイル名を設定します。

    ユーザデータファイルの設定

    起動部品の設定項目

    設定する値

    マッピングデータファイルの名前

    ActiveX起動部品：DataFileNameプロパティ

    Java起動部品：setDataFileNameメソッド

    COBOL起動部品：MAPPINGDATAパラメタ

    コマンド起動部品：/mapオプション

    マッピングデータファイル名（255バイト以内の文字列）

  4. ユーザデータファイルおよび印刷定義ファイルの設定

    必要に応じて，ユーザデータファイル（ユーザ定義データファイルなど），印刷定義ファイル（複数様式情報定義ファイル，文書情報設定ファイル，置き換え表管理情報ファイルなど）を設定します。

■参考

1.の帳票ファイルの設定は，起動部品で帳票ファイル名を直接指定する以外に，次のどちらかで指定することもできます。

  • 帳票セット指定ファイル

    帳票ファイル名やマッピングデータファイル名を，帳票セットとして帳票セット指定ファイルにまとめて指定することができます。出力時には次に示すプロパティ，メソッド，パラメタ，またはオプションで帳票セット指定ファイル名を指定してください。

    ・ActiveX起動部品：MultiReportSetFileNameプロパティ

    ・Java起動部品：setMultiReportSetFileNameメソッド

    ・COBOL起動部品：REPORTSETFILEパラメタ

    ・コマンド起動部品：/mrsオプション

  • 帳票ID

    帳票ファイル名を含む帳票出力で使用する項目を，帳票出力定義として帳票出力定義ファイルに指定することができます。帳票IDには，帳票出力時に使用する帳票出力定義ファイル名を指定します。出力時には次に示すプロパティ，メソッド，パラメタ，またはオプションで帳票出力定義ファイル名を指定してください。

    ・ActiveX起動部品：ReportIDプロパティ

    ・Java起動部品：setReportIDメソッド

    ・COBOL起動部品：REPORTIDパラメタ

    ・コマンド起動部品：/ridオプション

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 71 / 218


4.2.2 コーディング例 : EUR 帳票出力 機能解説 EUR Server編

  • 72 / 218

  • 表紙

  • 4.　ファイル形式を選んで出力する

  • 4.2　EUR形式ファイルを出力するには

  • 4.2.2　コーディング例

4.2.2　コーディング例

次に示すパラメタを指定して，EUR形式ファイルを出力します。出力ファイルは，EUR Server - Adapter稼働マシンに出力されます。

■入力ファイル（印刷定義ファイル）：EUR Server Service稼働マシンに配置

帳票ファイル名：sample1.fms

■入力ファイル（ユーザデータファイル）：EUR Server - Adapter稼働マシンに配置

マッピングデータファイルのパス：c:\Temp

マッピングデータファイル名：data1.csv

■出力ファイル

出力EUR形式ファイルのパス：c:\Temp

出力EUR形式ファイル名：eup1.eup

コーディング例を次に示します。

〈この項の構成〉

  • (1)　ActiveX起動部品の場合

(1)　ActiveX起動部品の場合

<HTML>
<HEAD>
<TITLE>Sample Script of ASP page for EUR Print Manager</TITLE>
</HEAD>
<BODY>
<%
  Server.ScriptTimeOut=100     …スクリプトのタイムアウト時間を
                                 100秒に設定
  On Error Resume Next         …エラーハンドリングを行う
  dim target                   …変数宣言
  Set EURPM=Server.CreateObject("EURPM.Exec")
                        …プログラムID「EURPM.Exec」を指定して，
                          ActiveX起動部品のインスタンス作成
  EURPM.ReportFileName="sample1.fms"       …帳票ファイルの指定
  EURPM.DataFilePath="c:\Temp"             …マッピングデータファイルの
                                             パスの指定
  EURPM.DataFileName="data1.csv"           …マッピングデータの指定
  EURPM.EURFilePath="c:\Temp"              …EUR形式ファイルパスの指定
  EURPM.EURFileName="eup1.eup"             …EUR形式ファイル名の指定
  If Err.Number <> 0 Then
    Response.Write("印刷実行前に
                    エラーが発生しています"& Err.Number &"<BR>")
  Else
    EURPM.OutputEURReport()                …EUR形式ファイル出力指示
    If Err.Number = 0 Then                 …OutputEURReportメソッドは
                                             正常終了かどうかの判定
      「正常終了時の処理」
    Else
      errid= Err.Number           …エラーコードをerridに取り出す
      If errid=-nnn Then          …KEEYnnn-Eの場合のエラー処理
        Elseif errid=-nnn Then    …KEEYnnn-Eの場合のエラー処理
        Elseif errid=-nnn Then    …KEEYnnn-Eの場合のエラー処理
        Elseif errid=
              :                   …そのほかのエラー処理を繰り返す
      End If
    End If
  End If
%>
</BODY>
</HTML>

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 72 / 218


4.2.3 注意事項 : EUR 帳票出力 機能解説 EUR Server編

  • 73 / 218

  • 表紙

  • 4.　ファイル形式を選んで出力する

  • 4.2　EUR形式ファイルを出力するには

  • 4.2.3　注意事項

4.2.3　注意事項

EUR形式ファイルを出力するときの注意事項について説明します。

〈この項の構成〉

  • (1)　ログファイル（eurps.logファイル）に出力されるページ数についての注意

  • (2)　画像のある帳票を出力するときの注意

  • (3)　実行ロケールと入力ファイルのエンコードについての注意

  • (4)　光学式読み取り装置で帳票を読み取るときの注意

(1)　ログファイル（eurps.logファイル）に出力されるページ数についての注意

メッセージレベルがInformationのとき，ログファイルに出力されるページ数は，常に0です。

ページの先頭へ

(2)　画像のある帳票を出力するときの注意

  • データファイルに指定する画像ファイルは，ファイル名で指定してください。画像ファイルのパスは，環境変数EURPS_IMAGEPATHに指定してください。

  • 帳票に不正な画像データがあった場合，エラー（KEEU700-E）が出力されますが処理は実行されます。EUR形式ファイルには，正常な画像データだけが出力されます。

    画像データを使用したEUR形式ファイルを出力するときは，プレビュー，または印刷をして，画像データが正しく出力されているかを確認してください。

ページの先頭へ

(3)　実行ロケールと入力ファイルのエンコードについての注意

次の場合，EUR形式ファイルには入力データが途中までしか格納されません。

  • Shift JISロケールで，Shift JISのファイルを入力ファイルに指定した場合

    Shift JIS範囲外の文字コードはEOFと判定されるので，それ以降のデータは読み込まれません。

  • EUCロケールで，EUCのファイルを入力ファイルに指定した場合

    EUC範囲外の文字コードはEOFと判定されるので，それ以降のデータは読み込まれません。

そのため，出力されたEUR形式ファイルをEUR Viewer帳票出力機能で開いても，正しく表示できません。

ページの先頭へ

(4)　光学式読み取り装置で帳票を読み取るときの注意

EUR サーバ帳票出力機能で出力した帳票を，光学式文字読み取り装置（OCR），バーコードの読み取り装置などの光学式読み取り装置で読み取るときは，次のことに注意してください。

  • 帳票を出力する場合は，300dpi以上のレーザープリンタを使用してください。

  • 印刷ダイアログなどで，用紙サイズに合わせた縮小，または拡大の指定はしないでください。

  • ご使用になる光学式読み取り装置で，出力した帳票が読み取れるかどうかを確認してください。EUR 帳票作成機能で設計した帳票にOCRフォントが使用されている場合も，十分な確認を行ってください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 73 / 218


4.3 Excel形式ファイルを出力するには : EUR 帳票出力 機能解説 EUR Server編

  • 74 / 218

  • 表紙

  • 4.　ファイル形式を選んで出力する

  • 4.3　Excel形式ファイルを出力するには

4.3　Excel形式ファイルを出力するには

ここでは，Excel形式ファイルの帳票を出力する方法について説明します。Excel形式ファイルを出力するには，EUR Server Standard，またはEUR Server Enterpriseが必要です。

Excel形式ファイルで帳票を出力すると，帳票の内容を編集したり，コメントやグラフを挿入したりするなど，Excelを使って帳票を二次加工できます。

Excel形式ファイルへの出力例を次の図に示します。

図4‒4　Excel形式ファイルへの出力例

[図データ]

（説明）

  • Excel形式ファイルのセルの高さおよび幅は，どちらも16ピクセルになります。Excel形式ファイルへ出力される情報については，「付録B　Excel形式ファイルへ出力される情報」を参照してください。

  • ページ単位でExcelのシートを分けて出力するか（デフォルト），ページ単位でExcelのシートを分けないで出力する（キーブレイクによる改ページごとにシートを分け，縦方向の繰り返しを1シート内で出力する）かのどちらかを，環境変数EURPS_EXCEL_REPEAT_MODEで設定できます。詳細については，「4.3.3(2)(a)　ページ単位でシートを分けるかどうかの設定」を参照してください。

  • 帳票ファイル上の文字や線などのアイテムは，Excelのセル区切りに合わせて配置されます。アイテムの座標値は，EUR 帳票作成機能で設計した帳票の座標に最も近いセル区切りの位置に補正されます。Excel形式ファイル上でのアイテムの座標は，セルA1の左上のセル区切りを原点とします。

  • 補正の結果，EUR 帳票作成機能で設計した帳票をExcel形式ファイルへ出力すると，アイテムの配置が異なる場合があります。アイテムの出力規則については，「4.3.2(1)　文字アイテムの出力規則」，「4.3.2(2)　線アイテムの出力規則」，および「4.3.2(3)　図形アイテムの出力規則」を参照してください。

    なお，Excel形式ファイルに出力されなかったアイテムについては，メッセージ（KEEU320-W）を出力し，出力されなかったアイテムの情報をEPS-XLSXログに出力します。EPS-XLSXログに出力される項目の詳細については，マニュアル「EUR システム設計ガイド」を参照してください。

また，Excel形式ファイルへ出力した場合，次のような注意事項があります。

  • EUR 帳票作成機能で表示した場合と比べて帳票の見た目が異なる

  • 出力できない帳票がある

  • 使用できない機能がある

詳細については，「4.3.6　注意事項」を参照してください。

〈この節の構成〉

  • 4.3.1　出力の流れ

  • 4.3.2　アイテムの出力規則

  • 4.3.3　出力されるExcel形式ファイルの形式

  • 4.3.4　必要なロケール

  • 4.3.5　コーディング例

  • 4.3.6　注意事項

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 74 / 218


4.3.1 出力の流れ : EUR 帳票出力 機能解説 EUR Server編

  • 75 / 218

  • 表紙

  • 4.　ファイル形式を選んで出力する

  • 4.3　Excel形式ファイルを出力するには

  • 4.3.1　出力の流れ

4.3.1　出力の流れ

Excel形式ファイルを出力する流れを次の図に示します。

図4‒5　Excel形式ファイルを出力する流れ

[図データ]

  1. 出力要求

    帳票の出力要求が業務プログラムに送られます。

  2. 転送

    EUR Server - Adapterは，ユーザデータファイルを帳票サーバのEUR Server Serviceに転送します。

  3. 印刷データ生成

    転送されたユーザデータファイルとあらかじめ帳票サーバに配置しておいた印刷定義ファイルから，印刷データ（Excel形式ファイル）が生成されます。

  4. 印刷データ転送

    EUR Server Serviceは，生成された印刷データ（Excel形式ファイル）をアプリケーションサーバに転送します。

  5. 出力，プレビュー

    クライアントPCのExcelを使用して，帳票をプリンタに出力したり，プレビューしたりできます。

    なお，クライアントPCのプリンタで帳票を出力するには，あらかじめアプリケーションサーバから印刷データ（Excel形式ファイル）をダウンロードする必要があります。

〈この項の構成〉

  • (1)　起動部品の設定

(1)　起動部品の設定

Excel形式ファイルの出力で使用する起動部品のメソッド，関数，およびオプションの指定値を次に示します。

  • ActiveX起動部品：OutputXLSXReportメソッド

  • Java起動部品：outputXLSXReportメソッド

  • COBOL起動部品：OutputXLSXReport関数

  • コマンド起動部品（eurpmcコマンド）：/mオプションにxlsxを指定

また，出力時に設定する起動部品のプロパティ，メソッド，パラメタ，およびオプションの指定値を次に示します。

  1. 帳票ファイルの設定

    印刷する帳票ファイル名を設定します。

    帳票ファイルの設定

    起動部品の設定項目

    設定する値

    帳票ファイルの名前

    ActiveX起動部品：ReportFileNameプロパティ

    Java起動部品：setReportFileNameメソッド

    COBOL起動部品：REPORTNAMEパラメタ

    コマンド起動部品：/rfオプション

    帳票ファイル名（255バイト以内の文字列）

  2. Excel形式ファイルの設定

    Excel形式ファイル名を設定します。

    Excel形式ファイルの設定

    起動部品の設定項目

    設定する値

    Excel形式ファイル名

    ActiveX起動部品：XLSXFileNameプロパティ

    Java起動部品：setXLSXFileNameメソッド

    COBOL起動部品：XLSXFILENAMEパラメタ

    コマンド起動部品：/xlfnオプション

    Excel形式ファイル名（255バイト以内の文字列）

  3. マッピングデータファイルの設定

    マッピングデータファイル名を設定します。

    ユーザデータファイルの設定

    起動部品の設定項目

    設定する値

    マッピングデータファイルの名前

    ActiveX起動部品：DataFileNameプロパティ

    Java起動部品：setDataFileNameメソッド

    COBOL起動部品：MAPPINGDATAパラメタ

    コマンド起動部品：/mapオプション

    マッピングデータファイル名（255バイト以内の文字列）

  4. ユーザデータファイル，印刷定義ファイル，および印刷付加情報の設定

    必要に応じて，ユーザデータファイル（ユーザ定義データファイルなど），印刷定義ファイル（置き換え表管理情報ファイルなど）および印刷付加情報（印刷開始ページなど）を設定します。

■参考

1.の帳票ファイルの設定は，起動部品で帳票ファイル名を直接指定する以外に，次のどちらかで指定することもできます。

  • 帳票セット指定ファイル

    帳票ファイル名やマッピングデータファイル名を，帳票セットとして帳票セット指定ファイルにまとめて指定することができます。出力時には次に示すプロパティ，メソッド，パラメタ，またはオプションで帳票セット指定ファイル名を指定してください。

    ・ActiveX起動部品：MultiReportSetFileNameプロパティ

    ・Java起動部品：setMultiReportSetFileNameメソッド

    ・COBOL起動部品：REPORTSETFILEパラメタ

    ・コマンド起動部品：/mrsオプション

  • 帳票ID

    帳票ファイル名を含む帳票出力で使用する項目を，帳票出力定義として帳票出力定義ファイルに指定することができます。帳票IDには，帳票出力時に使用する帳票出力定義ファイル名を指定します。出力時には次に示すプロパティ，メソッド，パラメタ，またはオプションで帳票出力定義ファイル名を指定してください。

    ・ActiveX起動部品：ReportIDプロパティ

    ・Java起動部品：setReportIDメソッド

    ・COBOL起動部品：REPORTIDパラメタ

    ・コマンド起動部品：/ridオプション

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 75 / 218


4.3.2 アイテムの出力規則 : EUR 帳票出力 機能解説 EUR Server編

  • 76 / 218

  • 表紙

  • 4.　ファイル形式を選んで出力する

  • 4.3　Excel形式ファイルを出力するには

  • 4.3.2　アイテムの出力規則

4.3.2　アイテムの出力規則

ここでは，Excel形式ファイルへ出力した場合のアイテムの出力規則について説明します。

〈この項の構成〉

  • (1)　文字アイテムの出力規則

  • (2)　線アイテムの出力規則

  • (3)　図形アイテムの出力規則

(1)　文字アイテムの出力規則

Excel形式ファイルへ出力した場合，文字アイテムの出力は次の規則に従います。

  • フィールドの種別とアイテムの種類の変換規則

  • セルへの配置規則

  • セルの結合規則

  • 重なっている文字アイテムの出力規則

それぞれの規則について説明します。

(a)　フィールドの種別とアイテムの種類の変換規則

Excel形式ファイルに出力する場合，EUR 帳票作成機能で定義したフィールドの種別およびアイテムの種類とExcelでの書式の表示形式が異なることがあります。

EUR 帳票作成機能で定義した内容とExcelでの書式の表示形式の対応を次の表に示します。

表4‒3 EUR 帳票作成機能で定義した内容とExcelでの書式の表示形式の対応
EUR 帳票作成機能で定義した内容 |  | Excelでの書式の表示形式
文字アイテムのフィールドの種別 | 文字列 | 文字列
 | 数値 | 数値
 | 日付 | 文字列
 | 和暦 | 文字列
 | バーコード | －
アイテムの種類 | 印刷日付・印刷時刻・ページ番号 | 文字列
（凡例）

－：出力しません。

なお，帳票設計時，文字アイテムの枠の大きさまたは改行コードによって，文字アイテムが複数行にわたる場合があります。この場合，Excel形式ファイルに出力すると文字アイテムは1行で出力されます。

文字列がExcelのセルからはみ出した場合，隣のセルにアイテムが配置されていないときは，すべての文字列が表示されます。ほかのアイテムが配置されているときは，はみ出した文字列は表示されません。

また，数値がExcelのセルからはみ出した場合は，枠内に「#」が表示されます。

Excelでの書式の表示形式は，Excelの［セルの書式設定］ダイアログの［表示形式］タブで確認できます。［セルの書式設定］ダイアログは，Excelのセルを右クリックして表示されるメニューから，［セルの書式設定］を選択して表示します。

(b)　セルへの配置規則

EUR 帳票作成機能で定義した文字アイテムの四隅の座標は，それぞれいちばん近いセル区切りの座標に合わせて出力されます。文字アイテムの高さおよび幅は，アイテムの四隅が，どのセル区切りに合わせて出力されるかによって決まります。

（例1）

文字アイテムの左上，左下，右上，右下が，それぞれA1の左上，左下，右上，右下のセル区切りに合わせて出力されます。この文字アイテムは文字のフォントサイズおよびアイテム枠の大きさが小さく，Excelのセル一つ分に収まるため，文字アイテムはA1だけに配置されます。

なお，文字アイテムの四隅の座標値がちょうどセルの中心に位置する場合は，座標値の小さい方のセル区切り位置に合わせて出力されます。

（例2）

次の図は文字アイテムの左端がセルの中心に位置しています。この場合，文字アイテムの左上はA1の左上のセル区切りに，文字アイテムの左下はA1の左下のセル区切りに合わせて出力されます。文字アイテムの右上，右下はそれぞれB1の右上，右下のセル区切りに合わせて出力されます。この文字アイテムは文字のフォントサイズおよびアイテム枠の大きさが大きく，A1とB1の二つのセルにわたるため，セルが結合されます。その結果，文字アイテムはA1とB1の結合セルに配置されます。

セルの結合の詳細については，「(c)　セルの結合規則」を参照してください。

（例3）

次の図は文字アイテムの上端がセルの中心に位置しています。この場合，文字アイテムの左上はA1の左上のセル区切りに，文字アイテムの右上はB1の右上のセル区切りに合わせて出力されます。文字アイテムの左下，右下はそれぞれA1の左下，B1の右下のセル区切りに合わせて出力されます。その結果，文字アイテムはA1とB1の結合セルに配置されます。

また，文字アイテムが小さく，四隅のうちどれかの角が同じ場所に出力される場合，文字アイテムは出力されません。

（例4）

文字アイテムの四隅の座標すべてがセルの左上のセル区切りに合わせて出力されるため，文字アイテムは出力されません。

(c)　セルの結合規則

文字アイテムの四隅の位置をそれぞれいちばん近いセル区切りに合わせた場合，アイテムが複数のセルにわたるときは，セルが結合されます。

（例1）

文字アイテムの左上，左下，右上，右下がそれぞれA1の左上，A1の左下，B1の右上，B1の右下のセル区切りに合わせて出力されます。その結果，文字アイテムはA1とB1の二つのセルにわたるため，セルが結合されます。

（例2）

文字アイテムの左上，左下，右上，右下がそれぞれA1の左上，A2の左下，B1の右上，B2の右下のセル区切りに合わせて出力されます。その結果，文字アイテムはA1，A2，B1およびB2の四つのセルにわたるため，セルが結合されます。

(d)　重なっている文字アイテムの出力規則

EUR 帳票作成機能で帳票を設計したときに重なっている文字アイテムは，すべて出力されません。

（例）

次の図で文字アイテム「あい」と「かきくけ」は重なっているため，どちらも出力されません。

ほかのアイテムと重なっていないように見える文字アイテムが出力されない場合

帳票設計時にほかのアイテムと重なっていないように見える文字アイテムが，Excel形式ファイルに出力されないことがあります。これは，文字アイテムが空データ（値のないデータ）の配置された繰り返し領域と重なっているためです。空データはアイテム枠もなく，帳票に表示されません。

空データは繰り返しを設定したときに帳票に配置されます。

次に示す図のように，空データが配置された繰り返し領域に別の文字アイテムが重なって配置されることがあります。

「aaa」，「bbb」，および「ccc」は繰り返し設定されたマッピングデータアイテム，「xyz」は任意の文字アイテムを示します。

この場合，文字アイテム「xyz」はExcel形式ファイルに出力されません。

ただし，集計行のアイテムと空データの配置された繰り返し領域が重なっている場合，集計行のアイテムはExcel形式ファイルに出力されます。

空データは，繰り返し個数や下限／右限の指定の有無に関係なく配置されることがあります。空データが配置される場合を次に示します。

マッピングデータの個数が帳票ファイルの貼付域の限界に満たない場合

繰り返し個数を指定しない場合，マッピングデータが帳票ファイルの貼付域の限界に満たない個数でも，繰り返し領域は貼付域の限界まで設定されます。

このため，データがない領域には空データが配置されます。

また，データに欠損値（空白）が含まれていて，帳票には表示されなくても，繰り返し領域として設定されます。

マッピングデータの個数が繰り返し個数や繰り返しの下限／右限に満たない場合

繰り返し個数を指定した場合，マッピングデータの個数が指定した個数より少なくても，繰り返し領域は指定した個数分設定されます。

また，繰り返しの下限／右限を設定した場合は，マッピングデータが設定した繰り返しの下限／右限に満たない個数でも，繰り返し領域は設定された位置まで設定されます。

このため，データがない領域には空データが配置されます。

空データが配置された例を次に示します。

ページの先頭へ

(2)　線アイテムの出力規則

Excel形式ファイルへ出力した場合，線アイテムの出力は次の規則に従います。

  • 線種および線の傾きの出力規則

  • 線幅の変換規則

  • セルへの配置規則

  • 複数の線アイテムの同一セルへの配置規則

  • 結合セルに重なる線アイテムの配置規則

それぞれの規則について説明します。

(a)　線種および線の傾きの出力規則

Excel形式ファイルには，実線，点線，破線，一点鎖線，二点鎖線，点線（丸），点線（角）が出力できます。ただし，点線，点線（丸），および点線（角）はすべて同じ線種に変換されます。出力結果の詳細については，「付録B.1(3)　線」を参照してください。

水平線または垂直線だけがExcel形式ファイルに出力できます。斜線は出力できません。

(b)　線幅の変換規則

Excelのセル罫線は，線幅を数値で指定できません。

実線は，EUR 帳票作成機能で定義した線幅によって3種類の線幅を持つ実線のどれかに変換されます。

  • 0.1～1.4ポイントの実線

    Excelのセル罫線の中でいちばん細い実線に変換されます。

  • 1.5～2.4ポイントの実線

    Excelのセル罫線の中で2番目に細い実線に変換されます。

  • 2.5～10.0ポイントの実線

    Excelのセル罫線の中でいちばん太い実線に変換されます。

実線以外の線種は，すべてExcelでサポートされる線種のセル罫線として出力されます。実線以外のExcelの線種はそれぞれ1種類の線幅しか持たないため，EURで線幅を指定してもすべて同じ線幅で出力されます。

出力結果の詳細については，「付録B.1(3)　線」を参照してください。

(c)　セルへの配置規則

EUR 帳票作成機能で定義した線アイテムはExcel形式ファイルのセル罫線として出力されます。線アイテムの位置および長さは，アイテムの始点と終点がExcelのセル区切りのどこに出力されるかによって決まります。

線アイテムの始点と終点は，帳票ファイルでの座標値にいちばん近いセル区切りに合わせて出力されます。

その結果，線アイテムの長さが帳票設計時と異なる場合があります。線アイテムの長さは，始点が配置されたセル区切りから終点が配置されたセル区切りまでの長さになります。

（例1）

線アイテムの始点の座標はA1の左上のセル区切りに，終点の座標はA1の左下のセル区切りに合わせて出力されます。その結果，線アイテムはA1の左罫線として配置され，長さはExcelのセル一つ分になります。

（例2）

線アイテムの始点の座標はA1の左上のセル区切りに，終点の座標はB1の右上のセル区切りに合わせて出力されます。その結果，線アイテムはA1とB1の上罫線として配置され，長さはExcelのセル二つ分になります。

なお，線アイテムの始点または終点の座標値がちょうどセルの中心に位置する場合は，座標値の小さい方のセル区切りに合わせて出力されます。

（例3）

次の図は線アイテムの始点がセルの中心に位置しています。この場合，線アイテムの始点の座標はA1の左上のセル区切りに，終点の座標はA2の左下のセル区切りに合わせて出力されます。その結果，線アイテムはA1とA2の左罫線として配置され，長さはExcelのセル二つ分になります。

なお，線アイテムの始点と終点が同じ座標に配置される場合，線アイテムは出力されません。

（例4）

線アイテムの始点と終点の座標は，どちらも左上のセル区切りに合わせて出力されます。線アイテムの始点と終点の座標が重なってしまうため，この線アイテムは出力されません。

(d)　複数の線アイテムの同一セルへの配置規則

Excel形式ファイル出力時に，線アイテムの出力位置が補正された結果，複数の線アイテムが同じセルの同じ位置に配置されることがあります。しかし，セル罫線には1種類の情報しか設定できないため，同じセル罫線には，線アイテムを一つだけ出力します。

線アイテム同士が同じセル罫線に配置された場合，線の開始位置座標が最も左上にある（原点に近い）線アイテムが出力されます。開始位置座標が原点から同じ距離にある場合は，座標値が最も左にある線アイテムを出力します。

線アイテムの一部だけがほかの線アイテムと重なって配置される場合，線アイテムの重なっていない部分は優先順位と関係なく出力されます。

(e)　結合セルに重なる線アイテムの配置規則

文字アイテムの大きさによって，セルが結合される場合があります。線アイテムの出力位置を補正した結果，出力位置が結合セルの内部となった場合は，線アイテムの結合セルと重なる部分は出力されません。結合セルと重ならない部分は別々のセル罫線として出力されます。

結合セルと線アイテムが重なった場合の出力結果を次の図に示します。

図4‒6　結合セルと線アイテムが重なった場合の出力結果

[図データ]

ページの先頭へ

(3)　図形アイテムの出力規則

Excel形式ファイルへ出力した場合，図形アイテムの出力は次の規則に従います。

  • 図形アイテムの種類別の出力規則

  • 網掛けアイテムの出力規則

  • 複数の網掛けアイテムの同一セルへの配置規則

  • 結合セルの塗りつぶしパターンの出力規則

それぞれの規則について説明します。

(a)　図形アイテムの種類別の出力規則

EUR 帳票作成機能で定義できる図形アイテムは，網掛けアイテム，角丸四角アイテム，円／楕円アイテム，および多角形アイテムの4種類です。

図形アイテムの種類別のExcel形式ファイルへの出力結果を次の表に示します。

表4‒4 図形アイテムの種類別のExcel形式ファイルへの出力結果
図形アイテムの種類 | 出力結果
網掛けアイテム | ○
角丸四角アイテム | ○※
円／楕円アイテム | ×
多角形アイテム | ×
（凡例）

○：出力できます。

×：出力できません。

注※

角丸め情報は出力されません。網掛けアイテムと同様に出力されます。

角丸四角アイテムは網掛けアイテムと同じ出力規則に従います。

(b)　網掛けアイテムの出力規則

網掛けアイテムはExcel形式ファイルのセル区切りに合わせて出力されます。

網掛けアイテムの四隅の座標は，それぞれいちばん近いセル区切りの座標に合わせて出力されます。四隅の座標値がちょうどセルの中心に位置する場合は，座標値の小さい方のセル区切り位置に合わせて出力されます。

網掛けアイテムの領域が複数のセルにわたっても，セルは結合されません。

EUR 帳票作成機能で設定した網掛けのパターンは，Excelのセルの塗りつぶしパターンとして出力されます。EURでの網掛けパターンとExcelのセルの塗りつぶしパターンの対応については，「付録B.1(4)(a)　出力結果の詳細」を参照してください。

枠線については，線アイテムと同様にExcel形式ファイルのセル罫線として出力されます。線アイテムの出力方法については，「(2)　線アイテムの出力規則」を参照してください。

(c)　複数の網掛けアイテムの同一セルへの配置規則

Excel形式ファイル出力時に，網掛けアイテムの出力位置が補正された結果，同じセルに複数のアイテムが配置される場合があります。この場合，EURでの帳票設計時に最前面に表示されるアイテムの枠線および網掛けパターンが出力され，背面に表示されるアイテムの枠線および網掛けパターンは出力されません。

同じセルに配置された網掛けアイテムのうち，最前面に表示されるアイテム以外の枠線および網掛けパターンは，重なっていない部分だけが出力されます。

また，網掛けアイテムの網掛けパターンは，Excel形式ファイル出力時に1種類の塗りつぶしパターンに変換されます。また，帳票設計時に塗りつぶしを選択した場合は，Excel形式ファイル出力時に塗りつぶしの色が「色なし」になります。

EURでの網掛けパターンとExcelのセルの塗りつぶしパターンの対応については，「付録B.1(4)(a)　出力結果の詳細」を参照してください。

図4‒7　同じセルに二つの網掛けアイテムが配置された場合の例

[図データ]

最前面に表示される網掛けアイテムの網掛けのパターンが透明（塗りつぶしなし）の場合，帳票設計時，アイテムが重なる部分には背面に表示される網掛けアイテムの枠線や網掛けパターンが表示されます。しかし，Excel形式ファイルに出力すると，アイテムの重なっている部分には最前面に表示されるアイテムの枠線が出力され，背面に表示される網掛けアイテムの枠線や網掛けパターンは表示されません。

網掛けアイテムの網掛けのパターンが透明（塗りつぶしなし）の場合，Excelでの塗りつぶしパターンは「塗りつぶしなし」になります。

図4‒8　最前面に表示されるアイテムの網掛けのパターンが透明（塗りつぶしなし）の場合

[図データ]

(d)　結合セルの塗りつぶしパターンの出力規則

Excel形式ファイル出力時に，網掛けアイテムの出力位置が補正された結果，文字アイテムが出力された結合セルに，網掛けアイテムが出力される場合があります。この場合，結合セルの塗りつぶしパターンは，網掛けアイテムが出力されるセルの位置によって，次のように出力されます。

結合セル中の最も左上のセルと重なっている場合

結合されたセルの塗りつぶしパターンは，出力する網掛けアイテムの塗りつぶしパターンとなります。

結合セル中の最も左上のセルと重なっていない場合

結合されたセルの塗りつぶしパターンは変換されません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 76 / 218


4.3.3 出力されるExcel形式ファイルの形式 : EUR 帳票出力 機能解説 EUR Server編

  • 77 / 218

  • 表紙

  • 4.　ファイル形式を選んで出力する

  • 4.3　Excel形式ファイルを出力するには

  • 4.3.3　出力されるExcel形式ファイルの形式

4.3.3　出力されるExcel形式ファイルの形式

〈この項の構成〉

  • (1)　ファイル名・シート名

  • (2)　ページとシート

(1)　ファイル名・シート名

出力するExcel形式ファイルのファイル名は，次に示す起動部品で指定します。

  • ActiveX起動部品：XLSXFileNameプロパティ

  • Java起動部品：setXLSXFileNameメソッド

  • COBOL起動部品：OutputXLSXReport関数（XLSXFILENAMEパラメタ）

  • コマンド起動部品（eurpmcコマンド）：/xlfnオプション

出力するExcel形式ファイルのシート名は，「sheet+Excel形式ファイル内でのシート番号」となります。

例：2ページの帳票を出力した場合

  • 出力された帳票の1シート目

    シート名：「sheet1」

  • 出力された帳票の2シート目

    シート名：「sheet2」

ページの先頭へ

(2)　ページとシート

(a)　ページ単位でシートを分けるかどうかの設定

Excel形式ファイルに出力するときのシートの分け方を環境変数EURPS_EXCEL_REPEAT_MODEで設定できます。

  • ページ単位でシートを分ける設定の場合（デフォルト）

    ページごとにExcelのシートを分けて出力します。

  • ページ単位でシートを分けない設定の場合

    キーブレイクによる改ページごとにExcelのシートを分けて出力します。縦方向の繰り返しを1シート内で出力できます。

    なお，次に示す機能はシート単位に処理されます。

    • ページ番号

    • 出力ページ

    • ページ集計

    • 集計ページ

    • 印刷開始ページ

    • 印刷終了ページ

    • ログに出力されるページ数

ページ単位でシートを分ける場合とページ単位でシートを分けない場合の出力例を次の図に示します。

環境変数EURPS_EXCEL_REPEAT_MODEの設定値については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

(b)　ページが指定されたアイテムの出力

アイテムの出力ページが指定されていた場合，そのアイテムは指定したページに該当するシートだけに出力されます。

(c)　出力シート数の制限

出力するシート数の上限は100です。出力しようとするシート数が100を超えた場合，先頭（最初のシートまたは印刷開始ページで指定されたシート）から100シートだけを出力し，メッセージ（KEEU321-W）を出力して終了します。

また，ページ単位でシートを分けない設定の場合，縦繰り返しのExcelのシート上での行数の上限は1シートあたり10,000です。行数が10,000を超えるときは，10,000行までを出力し，メッセージ（KEEU322-W）を出力して終了します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 77 / 218


4.3.4 必要なロケール : EUR 帳票出力 機能解説 EUR Server編

  • 78 / 218

  • 表紙

  • 4.　ファイル形式を選んで出力する

  • 4.3　Excel形式ファイルを出力するには

  • 4.3.4　必要なロケール

4.3.4　必要なロケール

帳票サーバがUNIX／Linux環境の場合，Excel形式ファイルを出力するには次の表に示すロケールをインストールしてください。

必要なロケールがインストールされていない場合は，エラー（KEEU124-E）になります。

表4‒5 UNIX／Linux環境でExcel形式ファイルを出力する場合に必要なロケール
実行環境 |  | 必要なロケール
OS | 言語
AIX | 英語 | EN_US.UTF-8
 | 中国語 | ZH_CN.UTF-8
 | 日本語 | JA_JP.UTF-8
HP-UX（IPF） | 英語 | en_US.utf8
 | 中国語 | zh_CN.utf8
 | 日本語 | ja_JP.utf8
Linux | 英語 | en_US.utf8
 | 中国語 | zh_CN.utf8
 | 日本語 | ja_JP.utf8

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 78 / 218


4.3.5 コーディング例 : EUR 帳票出力 機能解説 EUR Server編

  • 79 / 218

  • 表紙

  • 4.　ファイル形式を選んで出力する

  • 4.3　Excel形式ファイルを出力するには

  • 4.3.5　コーディング例

4.3.5　コーディング例

次に示すパラメタを指定して，Excel形式ファイルを出力します。出力ファイルは，EUR Server - Adapter稼働マシンに出力されます。

■入力ファイル（印刷定義ファイル）：EUR Server Service稼働マシンに配置

帳票ファイル名：sample1.fms

■入力ファイル（ユーザデータファイル）：EUR Server - Adapter稼働マシンに配置

マッピングデータファイルのパス：c:\Temp

マッピングデータファイル名：data1.csv

■出力ファイル

出力Excel形式ファイルのパス：c:\Inetpub\wwwroot\XLSX

出力Excel形式ファイル名：sample1_EPF.xlsx

■そのほか

印刷範囲：1～10ページ

コーディング例を次に示します。

〈この項の構成〉

  • (1)　Java起動部品の場合

(1)　Java起動部品の場合

<%@ page import="java.io.*" %>
<%@ page import="java.util.*" %>
<%@ page import="JP.co.Hitachi.soft.EURPM.*" %>
<%@ page contentType="text/html; charset=Shift_JIS" %>
<jsp:useBean id="adapter" class="JP.co.Hitachi.soft.EURPM.EURPMAdapterForJava" scope="session" />

               ・
               ・
               ・
<%
  try {
      String hostName = request.getServerName();

      adapter.setReportFileName("sample1.fms");     // 帳票名設定
      adapter.setDataFilePath("c:\\Temp");
                                   // マッピングデータファイルのパス設定
      adapter.setDataFileName("data1.csv");
                                   // マッピングデータファイル名設定
      adapter.setPrintStartPage(1);                 // 印刷開始ページ設定
      adapter.setPrintEndPage(10);                  // 印刷終了ページ設定
      adapter.setXLSXFilePath("c:\\Inetpub\\wwwroot\\XLSX");
                                   //Excel形式ファイル出力パス設定
      adapter.setXLSXFileName("sample1_EPF.xlsx");
                                   //Excel形式ファイル名設定
      adapter.outputXLSXReport();
                                   //Excel形式ファイル出力要求

  }
// エラー処理
  catch (JP.co.Hitachi.soft.EURPM.EURPMException e) {
      out.println("<P>エラー発生<br>");
      out.println("<table BORDER CELLSPACING=2 CELLPADDING=4 >");
      out.println("<tr><th>メソッド</th><th>取得結果</th></tr>");
      out.println("<tr><td>エラーコード</td>");
      out.println("<td>" + e.getErrorCode() + "</td></tr>");
      out.println("<tr><td>メッセージ</td>");
      out.println("<td>" + e.getMessage() + "</td></tr>");
      out.println("<tr><td>エラーレベル</td>");
      out.println("<td>" + e.getErrorLevel() + "</td></tr>");
      out.println("<tr><td>メッセージID</td>");
      out.println("<td>" + e.getKey() + "</td></tr>");
      out.println("</table>");
  }
%>

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 79 / 218


4.3.6 注意事項 : EUR 帳票出力 機能解説 EUR Server編

  • 80 / 218

  • 表紙

  • 4.　ファイル形式を選んで出力する

  • 4.3　Excel形式ファイルを出力するには

  • 4.3.6　注意事項

4.3.6　注意事項

Excel形式ファイルを出力するときの注意事項について説明します。

帳票設計時の注意事項については，マニュアル「EUR 帳票作成 操作ガイド」を参照してください。なお，Excel形式ファイルに出力する場合，セルの幅，高さは16ピクセルとなります。繰り返しを定義した帳票を出力するときは，グリッドのサイズに16ピクセル以上を設定することをお勧めします。

〈この項の構成〉

  • (1)　帳票の見た目についての注意

  • (2)　Excel形式ファイルに出力できる帳票についての注意

  • (3)　Excel形式ファイル出力で使用できない機能についての注意

  • (4)　UNIX／Linux環境の場合の注意

(1)　帳票の見た目についての注意

EUR 帳票作成機能で設計した帳票をExcel形式ファイルへ出力すると，EUR 帳票作成機能で表示した場合と，見た目が異なる場合があります。

帳票の見た目の変換についての注意事項を次に示します。

  • アイテムはExcelのセル（サイズ固定）に合わせて出力されるため，EUR 帳票作成機能で表示した場合と見た目が異なることがあります。

  • 線アイテムは，水平線または垂直線だけがExcel形式ファイルに出力できます。斜線は出力できません。

  • 線アイテムの線種および線幅はすべてExcelでサポートされる線種のセル罫線として出力されるため，EUR 帳票作成機能で定義した線種および線幅と異なる場合があります。

  • 帳票設計時に，線アイテム同士が近くに配置されている場合や線アイテムと文字アイテムと重なっている場合，Excel形式ファイルに出力したとき，アイテムが同じ位置に配置され，線アイテムが一部消えることがあります。

  • 角丸四角アイテムをExcel形式ファイルに出力する場合，角丸め情報が出力されないで網掛けアイテムとなります。

  • 図形アイテムは，網掛けアイテム，角丸四角アイテムだけがExcel形式ファイルに出力できます。円／楕円アイテム，多角形アイテムは出力できません。

  • 帳票設計時に，複数の網掛けアイテム，角丸四角アイテムが重なって配置されている場合，または網掛けアイテムおよび角丸四角アイテムと，文字アイテムが重なって配置されている場合，Excel形式ファイルに出力すると，EUR 帳票作成機能で表示したときと見た目が異なることがあります。

  • 帳票設計時の用紙サイズがA3，A4，A5，レター，リーガル以外の場合，「A4」として出力されます。

  • 用紙の余白サイズは上下左右とも「10mm」として出力されます。

  • 用紙サイズや用紙の余白サイズについて，Excel画面上での単位の表記はWindowsの設定によって異なることがあります。

    単位の表記は次の手順で設定します。

    1. スタートメニューの［設定］－［コントロールパネル］－［地域と言語のオプション］を選択します。

      ［地域と言語のオプション］ダイアログが表示されます。

    2. ［地域オプション］タブの［カスタマイズ］ボタンをクリックします。

      ［地域のオプションのカスタマイズ］ダイアログが表示されます。

    3. ［単位］リストボックスで単位の表記を選択します。

  • 出力される文字アイテムのフォントは，ロケールごとに固定となります（日本語：MS 明朝，中国語：NSimSun，その他：Courier New）。

  • 画像アイテムおよびバーコードアイテムは出力されません。

  • 網掛けアイテム，および角丸四角アイテムの網掛けパターンは，Excel形式ファイルに出力した場合，すべてExcelのセルの塗りつぶしパターン「6.25% 灰色」として出力されます。

  • 帳票設計時，文字アイテムの枠の大きさまたは改行コードによって，文字アイテムが複数行にわたる場合があります。この場合，Excel形式ファイルに出力すると，文字アイテムは1行で出力されます。文字列がアイテム枠からはみ出した場合，はみ出した文字列は表示されません。また，数値がアイテム枠からはみ出した場合は，枠内に「#」が表示されます。

  • Excel形式ファイルに出力する場合，セルの幅，高さは16ピクセルになります。

    Excelを利用するクライアント環境で，フォントの設定が初期状態から変更されている場合，出力するExcel形式ファイルのセルの横幅が16ピクセルとならないで，帳票の見た目が異なることがあります。

  • 帳票設計時に小数点以下桁数を指定しないでExcel形式ファイルに小数値を出力した場合，小数点以下が表示されないで整数値として表示されます。数式バーでは小数点以下の数値も表示されます。

    小数をExcel形式ファイルに出力したい場合，［小数点以下桁数］テキストボックスで小数点以下の桁数を指定してください。桁数を指定しないと，Excel出力時に小数点以下の桁数はデフォルトの「0」が設定されます。

  • 次の条件がすべて重なった場合，EUR 帳票作成機能で定義した文字アイテムが，隣接する文字アイテムの位置に表示されることがあります。

    • 隣接する文字アイテムの枠線が重なっている。

    • 文字の配置を左寄せ，右寄せ，上寄せ，下寄せ，または均等に設定している。

    • 隣接する文字アイテムが欠損値である。

  • 次の条件がすべて重なった場合，罫線が結合したセルの文字アイテムに隠れてしまって表示されないことがあります。

    • ［まとめ表示］ダイアログの［罫線もまとめる］チェックボックスをオフにしている。

    • 文字の配置を中央揃え，または均等配置に設定している。

  • 環境変数EURPS_EXCEL_REPEAT_MODEがページ単位でシートを分ける設定（デフォルト）の場合，帳票の縦方向の繰り返し間隔をLPIで指定しているときは，アイテムを配置する位置は，LPIをミリメートルに換算した値を元に計算されて出力されます。LPIとミリメートル間の換算では誤差が生じるため，EUR帳票作成機能で表示した場合と見た目が異なることがあります。

  • 環境変数EURPS_EXCEL_REPEAT_MODEがページ単位でシートを分けない設定の場合，帳票の縦方向の繰り返し間隔を6LPI（約4.23mm）の倍数に切り上げます。このため，EUR帳票作成機能で表示した場合と見た目が異なることがあります。繰り返し間隔の詳細については，「付録B.1(6)　繰り返し」を参照してください。

  • 数値項目を出力する場合，整数部と小数部を合わせた桁数が15桁を超えるときは丸められた値が出力されます。

  • Excelの下線には，下線，二重下線，会計タイプの下線（会計），二重下線（会計）の4種類があります。

    ［アイテムのプロパティ］ダイアログの［フォント］タブで，文字修飾の下線の設定をして，Excel形式ファイルを出力した場合，下線で出力されます。EURの帳票作成機能では，文字の外側に下線を引くため，「g」のような文字の場合，帳票設計時は文字と下線が重なりませんが，Excel形式ファイルに出力すると，セルの属性として下線を出力するため，文字と下線が重なって出力され，EUR帳票作成機能で表示した場合と見た目が異なります。

  • 指数表示する場合は，0より大きく1より小さい数値データを使用できません。

ページの先頭へ

(2)　Excel形式ファイルに出力できる帳票についての注意

  • Excel形式ファイルに出力できる帳票は単一様式の帳票だけです。複数様式の帳票，および帳票セット指定ファイルで，複数の帳票を一括出力した帳票は出力できません。

  • Excel形式ファイルに出力するシート数が100を超える場合，出力するシート数が100以内となるように印刷開始ページや印刷終了ページを指定して，複数回に分けて帳票を出力する必要があります。

  • 環境変数EURPS_EXCEL_REPEAT_MODEがページ単位でシートを分けない設定の場合，Excel形式ファイルに出力する行数が1シートあたり10,000行を超えるときは，10,000行までが出力されます。それ以降のシートは出力されません。

  • 環境変数EURPS_EXCEL_REPEAT_MODEがページ単位でシートを分けない設定の場合，次のどれかに該当する帳票は出力できません。

    • 繰り返し種別に縦方向以外が設定されている

    • 繰り返し個数に任意の値が設定されている

    • 集計行に位置固定が設定されている（繰り返し下限位置が設定されている）

    • マッピングデータファイルが指定されていない

    • レコード数が0件のマッピングデータファイルが指定されている

ページの先頭へ

(3)　Excel形式ファイル出力で使用できない機能についての注意

Excel形式ファイル出力で使用できない機能を次の表に示します。

表4‒6 Excel形式ファイル出力で使用できない機能
機能
様式 | 複数様式※1
帳票セットを指定した出力 | 帳票セット※1
帳票セット指定ファイルを使用した出力 | 複数帳票の一括出力※1
入力データ | フィールド種別 | 画像
 |  | バーコード
 |  | 特殊編集レベル※2
印刷 | 帳票の出力 帳票の出力タイプ指定※1
 | 出力先プリンタ名指定※1
 | 印刷の向き指定※1
 | 印刷部数指定
 | 部数が複数の場合の印刷単位指定
 | 給紙トレイコード指定※1
 | 様式ごとの給紙トレイコード指定※1
貼り付け域外のページ番号印刷
V8互換機能を使用した出力ページ数取得 | 出力した帳票のページ数 | 出力ページ情報ファイル（V8互換機能）※1
注※1

エラー（KEEU002-E）を出力します。

注※2

エラー（KEEU083-E）を出力します。

ページの先頭へ

(4)　UNIX／Linux環境の場合の注意

UNIX／Linux環境でExcel形式ファイルを出力する場合の注意事項を次に示します。

  • 環境変数LOGNAMEが設定されていない場合，エラー（KEEU124-E）になります。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 80 / 218


5. スプールデータを出力するには : EUR 帳票出力 機能解説 EUR Server編

  • 81 / 218

  • 表紙

  • 5.　スプールデータを出力するには

5.　スプールデータを出力するには

この章では，帳票のスプールデータを出力する方法について説明します。帳票のスプールデータを出力するには，EUR Server Enterpriseが必要です。

〈この章の構成〉

  • 5.1　スプールデータとは

  • 5.2　帳票の印刷データを蓄積する

  • 5.3　帳票の印刷データを取得する

  • 5.4　蓄積した印刷データを出力する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 81 / 218


5.1 スプールデータとは : EUR 帳票出力 機能解説 EUR Server編

  • 82 / 218

  • 表紙

  • 5.　スプールデータを出力するには

  • 5.1　スプールデータとは

5.1　スプールデータとは

スプールデータとは，帳票の印刷データをスプールサーバに蓄積するときのファイル形式です。次の図に示すように，帳票の印刷データ（EPF形式ファイル）に属性情報が設定されています。

図5‒1　スプールデータの構成要素

[図データ]

スプールデータに設定できる属性情報の詳細については，「12.1.4　スプールデータに出力する場合」を参照してください。

〈この節の構成〉

  • 5.1.1　スプールデータの格納先

  • 5.1.2　スプールデータの管理

  • 5.1.3　スプールデータのアクセス制限

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 82 / 218


5.1.1 スプールデータの格納先 : EUR 帳票出力 機能解説 EUR Server編

  • 83 / 218

  • 表紙

  • 5.　スプールデータを出力するには

  • 5.1　スプールデータとは

  • 5.1.1　スプールデータの格納先

5.1.1　スプールデータの格納先

スプールデータの格納先は，EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）のESFキーで設定できます。デフォルトの格納先は，次に示すとおりです。

  • Windows環境

    インストール先フォルダ\Spool\ESF

  • UNIX／Linux環境

    /var/opt/eur/spool/ESF

スプールデータはいったん保存されると，蓄積期限日数が経過するまで削除されません。スプールデータを格納するフォルダに必要なディスク容量は，蓄積する帳票のページ数，1日に蓄積されるスプールデータの数，蓄積の期限などによって変わります。印刷データを蓄積する前に，蓄積に掛かるデータ量を算出して，スプールデータを格納するフォルダに十分なディスク容量を確保してください。

スプールデータを格納するフォルダに必要なディスク容量の算出方法については，マニュアル「EUR システム設計ガイド」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 83 / 218


5.1.2 スプールデータの管理 : EUR 帳票出力 機能解説 EUR Server編

  • 84 / 218

  • 表紙

  • 5.　スプールデータを出力するには

  • 5.1　スプールデータとは

  • 5.1.2　スプールデータの管理

5.1.2　スプールデータの管理

帳票管理GUI，または業務プログラムを使用してスプールデータを管理できます。管理方法の詳細については，「13.　スプールデータを管理するには」を参照してください。

  • スプールデータの一覧取得

    スプールサーバの蓄積フォルダ内にあるスプールデータの一覧を取得できます。

    また，検索条件を指定して，該当するファイルの一覧を取得することもできます。指定された条件をすべて満たすファイルの一覧を取得します（AND検索）。

  • スプールデータの属性値取得

    指定されたジョブIDに該当するスプールデータの属性値を取得できます。

  • スプールデータの属性値変更

    指定されたジョブIDに該当するスプールデータの属性値を変更できます。

  • スプールデータからの印刷データの取得

    指定されたジョブIDに該当するスプールデータに格納されている印刷データ（EPF形式ファイル）を任意のフォルダに取得できます。蓄積するときに印刷データの取得可否の属性を設定することで，印刷データの取得を許可するかどうかを制御できます。

    また，印刷データをPDF形式ファイルで取得することもできます。

  • スプールデータの削除

    指定されたジョブIDに該当するスプールデータを削除できます。

  • 蓄積期限が切れたスプールデータの一括削除

    スプールサーバの蓄積フォルダ内にある，蓄積期限が切れたスプールデータを検索して，一括削除できます。

    蓄積期限が切れたスプールデータは，次に示すタイミングで自動的に削除することもできます。

    • EUR Server - Spool Serviceのサービスが起動されたとき

    • EUR Server - Spool Serviceが稼働するマシンの日付が変わったあと，EUR Server - Spool Serviceに対して最初の要求があったとき（日付変更の契機にローカルタイムと協定世界時（UTC）のどちらを使用するかを，EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）のOPTIONセクションのSTANDARDTIMEキーで設定できます）

    蓄積期限が切れたスプールデータを自動で削除するかどうかは，EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）のOPTIONセクションのESFAUTODELキーで設定できます。ESFAUTODELキーの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

  • スプールデータの印刷回数

    スプールデータの印刷回数の上限値を設定することができます。

    スプールデータの印刷回数は，スプールデータに対して次に示す操作が成功したタイミングでカウントされます。

    • スプールデータを蓄積後に続けて，スプールサーバまたはクライアントPCのプリンタで印刷したとき

    • スプールデータをスプールサーバまたはクライアントPCのプリンタで印刷したとき

    • 配送印刷を実行して，クライアントPCのプリンタで印刷したとき

注意

スプールデータの一覧を取得するときは，取得する情報量に応じた処理時間が掛かります。一度に一覧に取得するスプールデータの件数は，10,000件までとすることを推奨します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 84 / 218


5.1.3 スプールデータのアクセス制限 : EUR 帳票出力 機能解説 EUR Server編

  • 85 / 218

  • 表紙

  • 5.　スプールデータを出力するには

  • 5.1　スプールデータとは

  • 5.1.3　スプールデータのアクセス制限

5.1.3　スプールデータのアクセス制限

スプールデータに設定した属性情報と，ユーザ定義とを組み合わせることで，帳票管理GUIでスプールデータを操作するユーザを制限できます。アクセス制限の詳細については，「12.2.1　帳票にアクセスできるユーザを制限する」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 85 / 218


5.2 帳票の印刷データを蓄積する : EUR 帳票出力 機能解説 EUR Server編

  • 86 / 218

  • 表紙

  • 5.　スプールデータを出力するには

  • 5.2　帳票の印刷データを蓄積する

5.2　帳票の印刷データを蓄積する

ここでは，帳票の印刷データをサーバに蓄積する方法について説明します。

〈この節の構成〉

  • 5.2.1　蓄積の流れ

  • 5.2.2　印刷データを蓄積する手順

  • 5.2.3　コーディング例

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 86 / 218


5.2.1 蓄積の流れ : EUR 帳票出力 機能解説 EUR Server編

  • 87 / 218

  • 表紙

  • 5.　スプールデータを出力するには

  • 5.2　帳票の印刷データを蓄積する

  • 5.2.1　蓄積の流れ

5.2.1　蓄積の流れ

帳票の印刷データを蓄積する流れを次の図に示します。

図5‒2　帳票の印刷データを蓄積する流れ

[図データ]

  1. 出力要求

    帳票の出力要求が業務プログラムに送られます。

  2. 転送

    EUR Server - Adapterは，ユーザデータファイルを帳票サーバのEUR Server Serviceに転送します。

  3. 印刷データ生成

    転送されたユーザデータファイルとあらかじめ帳票サーバに配置しておいた印刷定義ファイルから，印刷データ（EPF形式ファイル）が生成されます。

  4. 印刷データ転送

    EUR Server Serviceは，生成された印刷データ（EPF形式ファイル）をスプールサーバのEUR Server - Spool Serviceに転送します。

  5. 蓄積

    EUR Server - Spool Serviceが印刷データ（EPF形式ファイル）を受信すると，スプールサーバ内に印刷データが蓄積されます。このとき，属性情報が付けられてスプールデータとなります。

なお，EUR Server ServiceとEUR Server - Spool Serviceを同じサーバに配置することで，印刷データの生成から蓄積までを一つのサーバに集約することもできます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 87 / 218


5.2.2 印刷データを蓄積する手順 : EUR 帳票出力 機能解説 EUR Server編

  • 88 / 218

  • 表紙

  • 5.　スプールデータを出力するには

  • 5.2　帳票の印刷データを蓄積する

  • 5.2.2　印刷データを蓄積する手順

5.2.2　印刷データを蓄積する手順

印刷データをスプールデータとして蓄積する手順について説明します。

■注意

OutputEPFReportメソッドで出力したEPF形式ファイルは，蓄積印刷には使用できません。蓄積印刷を実行する場合は，次の手順で帳票を蓄積してください。

〈この項の構成〉

  • (1)　蓄積した帳票をスプールサーバで出力する場合

  • (2)　蓄積した帳票をクライアントPCで出力する場合

(1)　蓄積した帳票をスプールサーバで出力する場合

蓄積した帳票をスプールサーバで出力するために設定する起動部品のメソッド，関数，およびオプションの指定値を次に示します。

蓄積する帳票ファイル，マッピングデータファイル，ユーザデータファイル，印刷定義ファイル，および印刷付加情報の設定は，帳票サーバのプリンタに出力する場合と同じです。詳細については，「3.1.1　帳票サーバのプリンタに出力する」の「(2)起動部品の設定」を参照してください。

なお，スプールサーバがUNIX／Linux環境の場合は，スプールサーバでの印刷はできません。

  • ActiveX起動部品：PrintPMReportメソッド

  • Java起動部品：printReportメソッド

  • COBOL起動部品：PrintReport関数またはPrintReport2関数

  • コマンド起動部品（eurpmcコマンド）：/mオプションにprintを指定

また，蓄積時に設定する起動部品のプロパティ，メソッド，パラメタ，およびオプションの指定値を次に示します。

  1. 印刷方法の設定

    帳票を印刷する方法を設定します。

    印刷方法の設定

    起動部品の設定項目

    設定する値

    印刷方法

    ActiveX起動部品：PrintModeプロパティ

    Java起動部品：setPrintModeメソッド

    COBOL起動部品：PRINTMODEパラメタ

    2（蓄積する）

    コマンド起動部品：/pmオプション

    spl（蓄積する）

  2. 蓄積先のスプールサーバの設定

    蓄積先となるスプールサーバの指定方法を設定します。蓄積先のスプールサーバの指定方法は，出力先名とIPアドレスの2種類から選択できます。

    蓄積先のスプールサーバの設定

    起動部品の設定項目

    設定する値

    蓄積先のスプールサーバの指定方法

    ActiveX起動部品：ServerSelectModeプロパティ

    Java起動部品：setServerSelectModeメソッド

    COBOL起動部品：SERVERSELECTMODEパラメタ

    0（出力先名で指定する）

    1（IPアドレスで指定する）

    コマンド起動部品：/srmオプション

    dest（出力先名で指定する）

    sv（IPアドレスで指定する）

    蓄積先のスプールサーバ

    出力先名

    ActiveX起動部品：DestinationNameプロパティ

    Java起動部品：setDestinationNameメソッド

    COBOL起動部品：DESTNAMEパラメタ

    コマンド起動部品：/destオプション

    出力先名（80バイト以内の文字列）

    IPアドレス

    ActiveX起動部品：ServerAddressプロパティ

    Java起動部品：setServerAddressメソッド

    COBOL起動部品：SERVERADDRパラメタ

    コマンド起動部品：/svrオプション

    255.255.255.255形式

  3. 実行できる印刷方法の設定

    帳票を印刷する方法のうち，どの印刷方法を選択できるのか設定します。

    実行できる印刷方法の設定

    起動部品の設定項目

    設定する値

    実行できる印刷方法

    ActiveX起動部品：ExecutablePrintModeプロパティ

    Java起動部品：setExecutablePrintModeメソッド

    COBOL起動部品：EXECUTABLEPRINTMODEパラメタ

    0（スプールサーバで印刷できる）

    1（スプールサーバ，およびクライアントPCで印刷できる）

    コマンド起動部品：/expオプション

    sv（スプールサーバで印刷できる）

    svcl（スプールサーバ，およびクライアントPCで印刷できる）

  4. 分割/仕分けの設定

    印刷データの蓄積時に，分割または仕分けするかどうかを設定します。

    分割/仕分けの設定

    起動部品の設定項目

    設定する値

    分割/仕分けの実行

    ActiveX起動部品：SplitModeプロパティ

    Java起動部品：setSplitModeメソッド

    COBOL起動部品：SPLITMODEパラメタ

    0（EUR Server Serviceの環境設定ファイルの設定に従う）

    1（分割/仕分けしない）

    2（仕分けする）

    3（分割する）

    コマンド起動部品：/splitオプション

    default（EUR Server Serviceの環境設定ファイルの設定に従う）

    no（分割/仕分けしない）

    key（仕分けする）

    page（分割する）

  5. スプールデータの設定

    スプールデータの情報を設定します。

    蓄積時に帳票を分割または仕分けする場合は，起動部品の指定内容よりも印刷先定義ファイルの設定内容が優先されます。印刷先定義ファイルの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

    また，スプールデータにアクセスできるユーザを制限する場合は，「ジョブ検索キーの分類」と「ジョブ検索キーの値」に，ユーザ名を定義するための分類名と対応する値を必ず設定してください。スプールデータにアクセスできるユーザの制限については，「12.2.1　帳票にアクセスできるユーザを制限する」を参照してください。

    スプールデータの設定

    起動部品の設定項目

    設定する値

    スプールデータに格納する印刷データのファイル名

    ActiveX起動部品：SpoolFileNameプロパティ

    Java起動部品：setSpoolFileNameメソッド

    COBOL起動部品：SPOOLFILENAMEパラメタ

    コマンド起動部品：/sfオプション

    スプールデータに格納する印刷データのファイル名（255バイト以内の文字列）

    ジョブ検索キーの分類

    ActiveX起動部品：JobKeyCategoryプロパティ

    Java起動部品：setJobKeyCategoryメソッド

    COBOL起動部品：JOBKEYCATEGORYパラメタ

    コマンド起動部品：/fcオプション

    ジョブ検索キーの分類名（80バイト以内の文字列）

    ジョブ検索キーの値

    ActiveX起動部品：JobKeyDataプロパティ

    Java起動部品：setJobKeyDataメソッド

    COBOL起動部品：JOBKEYDATAパラメタ

    コマンド起動部品：/fdオプション

    ジョブ検索キーの値（80バイト以内の文字列）

    蓄積期限日

    ActiveX起動部品：SpoolLimitプロパティ

    Java起動部品：setSpoolLimitメソッド

    COBOL起動部品：SPOOLLIMITパラメタ

    コマンド起動部品：/lmオプション
    日付で指定する場合

    YYYYMMDD形式

    日数で指定する場合

    +XXX形式

    印刷回数の上限値

    ActiveX起動部品：MaxPrintCountプロパティ

    Java起動部品：setMaxPrintCountメソッド

    COBOL起動部品：MAXPRINTCOUNTパラメタ

    コマンド起動部品：/xpオプション

    1～65,536（指定した回数印刷できる）

    -1（無限に印刷できる）

    0（印刷を禁止する）

    印刷データを取得できるかどうか

    ActiveX起動部品：EnableGetプロパティ

    Java起動部品：setEnableGetメソッド

    COBOL起動部品：ENABLEGETパラメタ

    True（取得できる）

    False（取得できない）

    コマンド起動部品：/gオプション

    get（取得できる）

    noget（取得できない）

    蓄積後に続けて印刷するかどうか

    ActiveX起動部品：PrintHoldModeプロパティ

    Java起動部品：setPrintHoldModeメソッド

    COBOL起動部品：PRINTHOLDMODEパラメタ

    0（蓄積後に続けて印刷しない）

    1（蓄積後に続けてスプールサーバで印刷する）

    コマンド起動部品：/prhオプション

    hold（蓄積後に続けて印刷しない）

    sv（蓄積後に続けてスプールサーバで印刷する）

  6. プリンタの設定

    スプールサーバのプリンタの指定方法を設定します。スプールサーバのプリンタの指定方法は，プリンタクラス名，プリンタ名，および帳票振り分け定義の3種類から選択できます。

    スプールサーバのプリンタの設定

    起動部品の設定項目

    設定する値

    プリンタの指定方法

    ActiveX起動部品：PrinterSelectModeプロパティ

    Java起動部品：setPrinterSelectModeメソッド

    COBOL起動部品：PRINTERSELECTMODEパラメタ

    0（プリンタクラス名で指定する）

    1（プリンタ名で指定する）

    2（帳票振り分け定義で指定する）

    コマンド起動部品：/smオプション

    class（プリンタクラス名で指定する）

    printer（プリンタ名で指定する）

    group（帳票振り分け定義で指定する）

    プリンタクラス名

    ActiveX起動部品：PrinterClassNameプロパティ

    Java起動部品：setPrinterClassNameメソッド

    COBOL起動部品：PRINTERCLASSNAMEパラメタ

    コマンド起動部品：/prcオプション

    プリンタクラス名（80バイト以内の文字列）

    プリンタ名

    OS上のプリンタ名

    ActiveX起動部品：ServerPrinterNameプロパティ

    Java起動部品：setServerPrinterNameメソッド

    COBOL起動部品：SERVERPRINTERNAMEパラメタ

    コマンド起動部品：/lspオプション

    プリンタ名（80バイト以内の文字列）

    OS上のプリンタのトレイ名

    ActiveX起動部品：ServerTrayNameプロパティ

    Java起動部品：setServerTrayNameメソッド

    COBOL起動部品：SERVERTRAYNAMEパラメタ

    コマンド起動部品：/lstオプション

    トレイ名（80バイト以内の文字列）

    帳票振り分け定義

    ActiveX起動部品：GroupNameプロパティ

    Java起動部品：setGroupNameメソッド

    COBOL起動部品：GROUPNAMEパラメタ

    コマンド起動部品：/groupオプション

    帳票振り分け定義（80バイト以内の文字列）
■参考

  • 実行できる印刷方法の設定，およびプリンタの設定は，サーバに帳票を蓄積したあとでも変更できます。印刷方法の設定，およびプリンタの設定を変更する方法については「13.　スプールデータを管理するには」を参照してください。

  • 帳票の蓄積後にスプールデータのジョブIDを取得することで，蓄積に続けてスプールデータを操作することもできます。ジョブIDを取得するための起動部品を次に示します。

    ActiveX起動部品

    GetJobIDメソッド，またはGetJobIDListメソッド

    Java起動部品

    getJobIDメソッド，またはgetJobIDListメソッド

    COBOL起動部品

    PrintReport関数の場合は，戻り値JOBIDで取得できます。また，PrintReport2関数の場合は，戻り値JOBID，または戻り値JOBIDSで取得できます。

    コマンド起動部品

    eurpmcコマンドの出力結果でスプールデータのジョブIDを確認できます。詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

(2)　蓄積した帳票をクライアントPCで出力する場合

蓄積した帳票をクライアントPCで出力するために設定する起動部品のメソッド，関数，およびオプションの指定値を次に示します。

蓄積する帳票ファイル，マッピングデータファイル，ユーザデータファイル，印刷定義ファイル，および印刷付加情報の設定は，クライアントPCのプリンタに自動で出力する場合と同じです。詳細については，「3.2.1　自動で出力する」の「(3)起動部品の設定」を参照してください。

  • ActiveX起動部品：PrintPMReportメソッド

  • Java起動部品：printReportメソッド

  • COBOL起動部品：PrintReport関数またはPrintReport2関数

  • コマンド起動部品（eurpmcコマンド）：/mオプションにprintを指定

また，蓄積時に設定する起動部品のプロパティ，メソッド，パラメタ，およびオプションの指定値を次に示します。なお，次に示す場合は，手順3，手順6，および手順7の設定は不要です。

  • 複数のクライアントPCに帳票を配布して出力する

  • クライアントPCのWebブラウザから出力する

  1. 印刷方法の設定

    帳票を印刷する方法を設定します。

    印刷方法の設定

    起動部品の設定項目

    設定する値

    印刷方法

    ActiveX起動部品：PrintModeプロパティ

    Java起動部品：setPrintModeメソッド

    COBOL起動部品：PRINTMODEパラメタ

    2（蓄積する）

    コマンド起動部品：/pmオプション

    spl（蓄積する）

  2. 蓄積先のスプールサーバの設定

    蓄積先となるスプールサーバの指定方法を設定します。蓄積先のスプールサーバの指定方法は，出力先名とIPアドレスの2種類から選択できます。

    蓄積先のスプールサーバの設定

    起動部品の設定項目

    設定する値

    蓄積先のスプールサーバの指定方法

    ActiveX起動部品：ServerSelectModeプロパティ

    Java起動部品：setServerSelectModeメソッド

    COBOL起動部品：SERVERSELECTMODEパラメタ

    0（出力先名で指定する）

    1（IPアドレスで指定する）

    コマンド起動部品：/srmオプション

    dest（出力先名で指定する）

    sv（IPアドレスで指定する）

    蓄積先のスプールサーバ

    出力先名

    ActiveX起動部品：DestinationNameプロパティ

    Java起動部品：setDestinationNameメソッド

    COBOL起動部品：DESTNAMEパラメタ

    コマンド起動部品：/destオプション

    出力先名（80バイト以内の文字列）

    IPアドレス

    ActiveX起動部品：ServerAddressプロパティ

    Java起動部品：setServerAddressメソッド

    COBOL起動部品：SERVERADDRパラメタ

    コマンド起動部品：/svrオプション

    255.255.255.255形式

  3. 実行できる印刷方法の設定

    帳票を印刷する方法のうち，どの印刷方法を選択できるのか設定します。

    実行できる印刷方法の設定

    起動部品の設定項目

    設定する値

    実行できる印刷方法

    ActiveX起動部品：ExecutablePrintModeプロパティ

    Java起動部品：setExecutablePrintModeメソッド

    COBOL起動部品：EXECUTABLEPRINTMODEパラメタ

    1（スプールサーバ，およびクライアントPCで印刷できる）

    2（クライアントPCで印刷できる）

    コマンド起動部品：/expオプション

    svcl（スプールサーバ，およびクライアントPCで印刷できる）

    cl（クライアントPCで印刷できる）

  4. 分割/仕分けの設定

    印刷データの蓄積時に，分割または仕分けするかどうかを設定します。

    分割/仕分けの設定

    起動部品の設定項目

    設定する値

    分割/仕分けの実行

    ActiveX起動部品：SplitModeプロパティ

    Java起動部品：setSplitModeメソッド

    COBOL起動部品：SPLITMODEパラメタ

    0（EUR Server Serviceの環境設定ファイルの設定に従う）

    1（分割/仕分けしない）

    2（仕分けする）

    3（分割する）

    コマンド起動部品：/splitオプション

    default（EUR Server Serviceの環境設定ファイルの設定に従う）

    no（分割/仕分けしない）

    key（仕分けする）

    page（分割する）

  5. スプールデータの設定

    スプールデータの情報を設定します。

    蓄積時に帳票を分割または仕分けする場合は，起動部品の指定内容よりも印刷先定義ファイルの設定内容が優先されます。印刷先定義ファイルの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

    また，スプールデータにアクセスできるユーザを制限する場合は，「ジョブ検索キーの分類」と「ジョブ検索キーの値」に，ユーザ名を定義するための分類名と対応する値を必ず設定してください。スプールデータにアクセスできるユーザの制限については，「12.2.1　帳票にアクセスできるユーザを制限する」を参照してください。

    スプールデータの設定

    起動部品の設定項目

    設定する値

    スプールデータに格納する印刷データのファイル名

    ActiveX起動部品：SpoolFileNameプロパティ

    Java起動部品：setSpoolFileNameメソッド

    COBOL起動部品：SPOOLFILENAMEパラメタ

    コマンド起動部品：/sfオプション

    スプールデータに格納する印刷データのファイル名（255バイト以内の文字列）

    ジョブ検索キーの分類

    ActiveX起動部品：JobKeyCategoryプロパティ

    Java起動部品：setJobKeyCategoryメソッド

    COBOL起動部品：JOBKEYCATEGORYパラメタ

    コマンド起動部品：/fcオプション

    ジョブ検索キーの分類名（80バイト以内の文字列）

    ジョブ検索キーの値

    ActiveX起動部品：JobKeyDataプロパティ

    Java起動部品：setJobKeyDataメソッド

    COBOL起動部品：JOBKEYDATAパラメタ

    コマンド起動部品：/fdオプション

    ジョブ検索キーの値（80バイト以内の文字列）

    蓄積期限日

    ActiveX起動部品：SpoolLimitプロパティ

    Java起動部品：setSpoolLimitメソッド

    COBOL起動部品：SPOOLLIMITパラメタ

    コマンド起動部品：/lmオプション
    日付で指定する場合

    YYYYMMDD形式

    日数で指定する場合

    +XXX形式

    印刷回数の上限値

    ActiveX起動部品：MaxPrintCountプロパティ

    Java起動部品：setMaxPrintCountメソッド

    COBOL起動部品：MAXPRINTCOUNTパラメタ

    コマンド起動部品：/xpオプション

    1～65,536（指定した回数印刷できる）

    -1（無限に印刷できる）

    0（印刷を禁止する）

    印刷データを取得できるかどうか

    ActiveX起動部品：EnableGetプロパティ

    Java起動部品：setEnableGetメソッド

    COBOL起動部品：ENABLEGETパラメタ

    True（取得できる）

    False（取得できない）

    コマンド起動部品：/gオプション

    get（取得できる）

    noget（取得できない）

    蓄積後に続けて印刷するかどうか

    ActiveX起動部品：PrintHoldModeプロパティ

    Java起動部品：setPrintHoldModeメソッド

    COBOL起動部品：PRINTHOLDMODEパラメタ

    0（蓄積後に続けて印刷しない）

    2（蓄積後に続けてクライアントPCで印刷する）

    コマンド起動部品：/prhオプション

    hold（蓄積後に続けて印刷しない）

    cl（蓄積後に続けてクライアントPCで印刷する）

  6. クライアントPCの設定

    クライアントPCのIPアドレスを指定します。

    クライアントPCの設定

    起動部品の設定項目

    設定する値

    IPアドレス

    ActiveX起動部品：ClientAddressプロパティ

    Java起動部品：setClientAddressメソッド

    COBOL起動部品：CLIENTADDRパラメタ

    コマンド起動部品：/clientオプション

    255.255.255.255形式

  7. ダイアログの設定

    クライアントPCで帳票を受信したときにダイアログを表示するかどうかを設定します。

    ダイアログの設定

    起動部品の設定項目

    設定する値

    ダイアログを表示するかどうか

    ActiveX起動部品：DispPrintDlgプロパティ

    Java起動部品：setDispPrintDlgメソッド

    COBOL起動部品：DISPPRINTDLGパラメタ

    0（対話型印刷）

    1（自動印刷）

    2（対話型印刷プレビュー表示）

    3（全自動印刷）※1

    4（対話型印刷プレビュー表示限定）※2

    コマンド起動部品：/dialogオプション

    dialog（対話型印刷）

    auto（自動印刷）

    preview（対話型印刷プレビュー表示）

    fullauto（全自動印刷）※1

    pvonly（対話型印刷プレビュー表示限定）※2

    注※1　印刷実行時に印刷中のダイアログが表示されません。

    注※2　印刷ダイアログを表示しないため，印刷を実行できません。

  8. クライアントPCのプリンタの設定

    クライアントPCのプリンタを設定します。クライアントPCのプリンタの設定方法は，プリンタクラス名とプリンタ名の2種類から選択できます。

    クライアントPCのプリンタの設定

    起動部品の設定項目

    設定する値

    プリンタクラス名

    ActiveX起動部品：PrinterClassNameプロパティ

    Java起動部品：setPrinterClassNameメソッド

    COBOL起動部品：PRINTERCLASSNAMEパラメタ

    コマンド起動部品：/prcオプション

    プリンタクラス名（80バイト以内の文字列）

    プリンタ名

    OS上のプリンタ名

    ActiveX起動部品：ClientPrinterNameプロパティ

    Java起動部品：setClientPrinterNameメソッド

    COBOL起動部品：CLIENTPRINTERNAMEパラメタ

    コマンド起動部品：/pオプション

    プリンタ名（80バイト以内の文字列）

    OS上のプリンタのトレイ名

    ActiveX起動部品：ClientTrayNameプロパティ

    Java起動部品：setClientTrayNameメソッド

    COBOL起動部品：CLIENTTRAYNAMEパラメタ

    コマンド起動部品：/tオプション

    トレイ名（80バイト以内の文字列）
■参考

  • 実行できる印刷方法の設定，クライアントPCのIPアドレスの設定，ダイアログの設定，およびプリンタの設定は，サーバに帳票を蓄積したあとでも変更できます。印刷方法の設定，およびプリンタの設定を変更する方法については「13.　スプールデータを管理するには」を参照してください。

  • 帳票の蓄積後にスプールデータのジョブIDを取得することで，蓄積に続けてスプールデータを操作することもできます。ジョブIDを取得するための起動部品を次に示します。

    ActiveX起動部品

    GetJobIDメソッド，またはGetJobIDListメソッド

    Java起動部品

    getJobIDメソッド，またはgetJobIDListメソッド

    COBOL起動部品

    PrintReport関数の場合は，戻り値JOBIDで取得できます。また，PrintReport2関数の場合は，戻り値JOBID，または戻り値JOBIDSで取得できます。

    コマンド起動部品

    eurpmcコマンドの出力結果でスプールデータのジョブIDを確認できます。詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 88 / 218


5.2.3 コーディング例 : EUR 帳票出力 機能解説 EUR Server編

  • 89 / 218

  • 表紙

  • 5.　スプールデータを出力するには

  • 5.2　帳票の印刷データを蓄積する

  • 5.2.3　コーディング例

5.2.3　コーディング例

次に示すパラメタを指定して，サーバに印刷データを蓄積します。

■入力ファイル（印刷定義ファイル）：EUR Server Service稼働マシンに配置

帳票ファイル名：sample1.fms

■入力ファイル（ユーザデータファイル）：EUR Server - Adapter稼働マシンに配置

マッピングデータファイルのパス：c:\Temp

マッピングデータファイル名：data1.csv

コーディング例を次に示します。

〈この項の構成〉

  • (1)　ActiveX起動部品の場合

(1)　ActiveX起動部品の場合

<HTML>
<HEAD>
<TITLE>Sample Script of ASP page for EUR Print Manager</TITLE>
</HEAD>
<BODY>
<%
  Server.ScriptTimeOut=100     …スクリプトのタイムアウト時間を
                                 100秒に設定
  On Error Resume Next         …エラーハンドリングを行う
  dim jobid                    …変数宣言
  Set EURPM=Server.CreateObject("EURPM.Exec")
                        …プログラムID「EURPM.Exec」を指定して，
                          ActiveXオブジェクトのインスタンス作成
  EURPM.ReportFileName="sample1.fms"       …帳票ファイルの指定
  EURPM.DataFilePath="c:\Temp"             …マッピングデータパスの指定
  EURPM.DataFileName="data1.csv"           …マッピングデータの指定
  EURPM.PrintMode=2                        …印刷方式を「蓄積」に設定
  If Err.Number <> 0 Then
    Response.Write("蓄積実行前に
                    エラーが発生しています"& Err.Number &"<BR>")
  Else
    EURPM.PrintPMReport()               …蓄積指示
    If Err.Number = 0 Then              …PrintPMReportメソッドは
                                          正常終了かどうかの判定
      jobid = EURPM.GetJobID();         …スプールデータのジョブIDを取得
      「正常終了時の処理」
    Else
      errid= Err.Number           …エラーコードをerridに取り出す
      If errid=-441 Then          …KEEY441-Wの場合のエラー処理
        Elseif errid=-301 Then    …KEEY301-Eの場合のエラー処理
        Elseif errid=-302 Then    …KEEY302-Eの場合のエラー処理
        Elseif errid=
              :                   …以下，そのほかのエラー処理を繰り返す
      End If
    End If
  End If
%>
</BODY>
</HTML>

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 89 / 218


5.3 帳票の印刷データを取得する : EUR 帳票出力 機能解説 EUR Server編

  • 90 / 218

  • 表紙

  • 5.　スプールデータを出力するには

  • 5.3　帳票の印刷データを取得する

5.3　帳票の印刷データを取得する

ここでは，スプールデータから印刷データ（EPF形式ファイル）を取得する方法について説明します。取得した印刷データは，クライアントPCのWebブラウザからダウンロードして出力したり，クライアントPCに配布して出力したりできます。

スプールデータから印刷データ（EPF形式ファイル）を取得するには，任意のフォルダにファイルで取得する方法（ファイル取得）と，サーバのメモリ上にデータとして取得する方法（メモリ取得）の2種類があります。

また，印刷データをPDF形式ファイルで取得することもできます。

通常はファイル取得を使用しますが，次のような場合はメモリ取得を使用します。

  • セキュリティ上，サーバやクライアントPCに一時ファイルを作成したくない場合

  • 帳票の印刷データをデータベースにバイナリデータとして登録する場合

印刷データをメモリに取得する場合は，SS-Java起動部品を使用してください。SS-ActiveX起動部品およびSS-コマンド起動部品には，印刷データをメモリに取得する機能はありません。

それぞれの取得方法について説明します。

〈この節の構成〉

  • 5.3.1　印刷データをファイル取得する

  • 5.3.2　印刷データをメモリ取得する

  • 5.3.3　コーディング例

  • 5.3.4　帳票管理GUIを使用して印刷データをPDF形式ファイルで取得する

  • 5.3.5　取得するPDF形式ファイルのプロパティ情報と注意事項

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 90 / 218


5.3.1 印刷データをファイル取得する : EUR 帳票出力 機能解説 EUR Server編

  • 91 / 218

  • 表紙

  • 5.　スプールデータを出力するには

  • 5.3　帳票の印刷データを取得する

  • 5.3.1　印刷データをファイル取得する

5.3.1　印刷データをファイル取得する

スプールデータの印刷データをEPF形式またはPDF形式のファイル形式で任意のフォルダに取得できます。

印刷データをEPF形式ファイルで取得する場合は，複数のスプールデータから印刷データを取り出して，一つの印刷データに統合して取得することもできます。統合して取得する場合の条件や，統合したデータの属性情報については，「6.3.2　複数のスプールデータを統合出力する」を参照してください。

なお，印刷データをファイル形式で取得するときのファイルの拡張子は次のようになります。

  • 起動部品で出力ファイル名を設定している場合

    出力ファイル名に設定した値

  • 起動部品で出力ファイル名を設定していない場合

    EPF形式で取得する場合

    指定したスプールデータに格納されているファイル名

    PDF形式で取得する場合

    指定したスプールデータに格納されているファイル名※

    注※　拡張子が「.epf」の場合は「.pdf」に置き換えられます。

〈この項の構成〉

  • (1)　取得の流れ

  • (2)　実行メソッド

  • (3)　設定項目

(1)　取得の流れ

スプールデータの印刷データをファイルで取得する流れを，次の図に示します。

図5‒3　スプールデータの印刷データをファイルで取得する流れ

[図データ]

●EPF形式で取得する場合

  1. 取得要求

    ユーザが，印刷データをEPF形式で取得する要求を業務プログラムに送ります。

  2. 印刷データ取得

    業務プログラムが，スプールサーバ内のスプールデータから印刷データをEPF形式で取得します。

    このとき，複数のスプールデータのデータを統合して，一つの印刷データとして取得することもできます。

  3. 印刷データ転送

    EUR Server - Spool Serviceは，取得したEPF形式の印刷データをアプリケーションサーバに転送します。

  4. 取得

    EPF形式の印刷データを取得します。

●PDF形式で取得する場合

  1. 取得要求

    ユーザが，印刷データをPDF形式で取得する要求を業務プログラムに送ります。

  2. 印刷データ取得

    業務プログラムが，スプールサーバ内のスプールデータから印刷データをEPF形式で取得します。

  3. 変換

    印刷データをEPF形式からPDF形式に変換します。

  4. 印刷データ転送

    EUR Server - Spool Serviceは，取得したPDF形式の印刷データをアプリケーションサーバに転送します。

  5. 取得

    PDF形式の印刷データを取得します。

ページの先頭へ

(2)　実行メソッド

スプールデータから印刷データを任意のフォルダに取得するメソッドを次の表に示します。

表5‒1 スプールデータから印刷データを任意のフォルダに取得するメソッド
起動部品 | メソッド
SS-ActiveX起動部品 | GetSpoolFile
SS-Java起動部品 | getSpoolFile
SS-コマンド起動部品（eurpmlscコマンド） | /mオプションにgetを指定

ページの先頭へ

(3)　設定項目

スプールデータから印刷データを任意のフォルダに取得するときに設定する項目を，次の表に示します。

表5‒2 スプールデータから印刷データを任意のフォルダに取得するときに設定する項目
印刷データのファイル取得に関する設定 | 起動部品の設定項目 | 設定する値
出力ファイル名 | SS-ActiveX起動部品：OutputFileNameプロパティ SS-Java起動部品：setOutputFileNameメソッド SS-コマンド起動部品：/ofnオプション | 出力ファイル名（255バイト以内の文字列）
印刷データを取得するフォルダ | SS-ActiveX起動部品：OutputFilePathプロパティ SS-Java起動部品：setOutputFilePathメソッド SS-コマンド起動部品：/oオプション | 取得するフォルダのパス（255バイト以内の文字列）
用紙の向き※ | SS-ActiveX起動部品：PaperOrientationプロパティ SS-Java起動部品：setPaperOrientationメソッド | 0（帳票の定義情報に合わせる） 1（縦） 2（横）
 | SS-コマンド起動部品：/poオプション | none（帳票の定義情報に合わせる） portrait（縦） landscape（横）
印刷部数※ | SS-ActiveX起動部品：PrintCopiesプロパティ SS-Java起動部品：setPrintCopiesメソッドSS-コマンド起動部品：/cオプション | 印刷部数（1～99）
プリンタクラス名 | SS-ActiveX起動部品：PrinterClassNameプロパティ SS-Java起動部品：setPrinterClassNameメソッド SS-コマンド起動部品：/prcオプション | プリンタクラス名 （80バイト以内の文字列）
スプールデータのジョブID | SS-ActiveX起動部品：SearchJobIDプロパティ SS-Java起動部品：setSearchJobIDメソッド，またはsetSearchJobIDMultiメソッド SS-コマンド起動部品：/idオプション | ジョブID（36バイト以内の文字列）
蓄積先のスプールサーバのIPアドレス | SS-ActiveX起動部品：ServerAddressプロパティ SS-Java起動部品：setServerAddressメソッド SS-コマンド起動部品：/svrオプション | 255.255.255.255形式
印刷部数の単位 | SS-ActiveX起動部品：SortPrintプロパティ SS-Java起動部品：setSortPrintメソッド | 0（部単位） 1（ページ単位）
 | SS-コマンド起動部品：/numオプション | sort（部単位） stack（ページ単位）
スプールタイトル | SS-ActiveX起動部品：SpoolTitleプロパティ SS-Java起動部品：setSpoolTitleメソッド SS-コマンド起動部品：/sptlオプション | スプールタイトル （255バイト以内の文字列）
取得ファイル形式 | SS-ActiveX起動部品：OutputFileKindプロパティ SS-Java起動部品：setOutputFileKindメソッド | 0（EPF形式） 1（PDF形式）
 | SS-コマンド起動部品：/ofkオプション | epf（EPF形式） pdf（PDF形式）
注※

取得ファイル形式がEPF形式，かつ複数のジョブIDを指定して統合出力する場合に，設定が有効となります。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 91 / 218


5.3.2 印刷データをメモリ取得する : EUR 帳票出力 機能解説 EUR Server編

  • 92 / 218

  • 表紙

  • 5.　スプールデータを出力するには

  • 5.3　帳票の印刷データを取得する

  • 5.3.2　印刷データをメモリ取得する

5.3.2　印刷データをメモリ取得する

スプールデータの印刷データをEPF形式またはPDF形式のファイル形式でメモリに取得できます。

印刷データをEPF形式ファイルで取得する場合は，複数のスプールデータから印刷データを取り出して，一つの印刷データに統合して取得することもできます。統合して取得する場合の条件や，統合したデータの属性情報については，「6.3.2　複数のスプールデータを統合出力する」を参照してください。

〈この項の構成〉

  • (1)　取得の流れ

  • (2)　実行メソッド

  • (3)　設定項目

(1)　取得の流れ

スプールデータの印刷データをファイルで取得する場合と同じです。

印刷データをファイルで取得する流れについては，「5.3.1　印刷データをファイル取得する」を参照してください。

ページの先頭へ

(2)　実行メソッド

スプールデータから印刷データをメモリに取得するメソッドを次の表に示します。

表5‒3 スプールデータから印刷データをメモリに取得するメソッド
起動部品 | メソッド
SS-Java起動部品 | memgetSpoolFile

ページの先頭へ

(3)　設定項目

スプールデータから印刷データをメモリに取得するときに設定する項目を，次の表に示します。

表5‒4 スプールデータから印刷データをメモリに取得するときに設定する項目
印刷データのメモリ取得に関する設定 | 起動部品の設定項目 | 設定する値
用紙の向き※ | SS-Java起動部品：setPaperOrientationメソッド | 0（帳票の定義情報に合わせる） 1（縦） 2（横）
印刷部数※ | SS-Java起動部品：setPrintCopiesメソッド | 印刷部数（1～99）
プリンタクラス名 | SS-Java起動部品：setPrinterClassNameメソッド | プリンタクラス名 （80バイト以内の文字列）
スプールデータのジョブID | SS-Java起動部品：setSearchJobIDメソッド，またはsetSearchJobIDMultiメソッド | ジョブID（36バイト以内の文字列）
蓄積先のスプールサーバのIPアドレス | SS-Java起動部品：setServerAddressメソッド | 255.255.255.255形式
印刷部数の単位 | SS-Java起動部品：setSortPrintメソッド | 0（部単位） 1（ページ単位）
スプールタイトル | SS-Java起動部品：setSpoolTitleメソッド | スプールタイトル （255バイト以内の文字列）
取得ファイル形式 | SS-Java起動部品：setOutputFileKindメソッド | 0（EPF形式） 1（PDF形式）
注※

取得ファイル形式がEPF形式，かつ複数のジョブIDを指定して統合出力する場合に，設定が有効となります。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 92 / 218


5.3.3 コーディング例 : EUR 帳票出力 機能解説 EUR Server編

  • 93 / 218

  • 表紙

  • 5.　スプールデータを出力するには

  • 5.3　帳票の印刷データを取得する

  • 5.3.3　コーディング例

5.3.3　コーディング例

次に示すパラメタを指定して，スプールデータから印刷データをメモリ取得し，クライアントに配布して出力します。

■入力ファイル（EPF形式データ）：スプールデータからメモリ取得

EPF形式ファイルデータ：bbEPFdata

■プロパティ（アプリケーションサーバ）：EUR Server - Adapter稼働マシンで設定

印刷方式：5

クライアントPCのIPアドレス：127.0.0.1

■プロパティ（アプリケーションサーバ）：EUR Server - Spool Service Adapter稼働マシンに配置

ジョブID検索値：EUR200805220056259780000001000000016

コーディング例を次に示します。

〈この項の構成〉

  • (1)　Java起動部品の場合

(1)　Java起動部品の場合

import JP.co.Hitachi.soft.EURPM.*;
import JP.co.Hitachi.soft.EURPMLS.*;

    try {
      EURPMAdapterForJava   pmadp   = new EURPMAdapterForJava();
      EURPMLSAdapterForJava rsadp   = new EURPMLSAdapterForJava();

      String target = request.getRemoteAddr();

      rsadp.setSearchJobID("EUR200805220056259780000001000000016");
                               //ジョブID検索値の指定
      ByteBuffer bbEPFdata = rsadp.memgetSpoolFile();
                               //EPF形式ファイルデータの取得

    pmadp.setEPFFileData(bbEPFdata);
                               //EPF形式ファイルのメモリ入力の指定
      pmadp.setPrintMode(5);
                               //印刷方式の指定
      pmadp.setClientAddress("127.0.0.1");
                               //クライアントIPアドレスの指定
      pmadp.printReport();
                               //帳票の出力指示
    }
    catch (JP.co.Hitachi.soft.EURPM.EURPMException ce) {
                                    //エラー処理
      int errid;
      errid=ce.getErrorCode();
                     //エラーコードをerridに取り出す
      if (errid==301) {
                     //KEEY301-Eの場合のエラー処理
      } else if (errid==   {
                     //以下，そのほかのエラー処理を繰り返す
              :
      }
    catch (JP.co.Hitachi.soft.EURPMLS.EURPMLSException ce) {
                                    //エラー処理
      int errid;
      errid=ce.getErrorCode();
                     //エラーコードをerridに取り出す
      if (errid==531) {
                     //KEEY531-Eの場合のエラー処理
      } else if (errid==   {
                     //以下，そのほかのエラー処理を繰り返す
              :
      }
    }

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 93 / 218


5.3.4 帳票管理GUIを使用して印刷データをPDF形式ファイルで取得する : EUR 帳票出力 機能解説 EUR Server編

  • 94 / 218

  • 表紙

  • 5.　スプールデータを出力するには

  • 5.3　帳票の印刷データを取得する

  • 5.3.4　帳票管理GUIを使用して印刷データをPDF形式ファイルで取得する

5.3.4　帳票管理GUIを使用して印刷データをPDF形式ファイルで取得する

Webブラウザ上で帳票管理GUIから帳票の印刷データをPDF形式ファイルで取得できます。

〈この項の構成〉

  • (1)　ファイル取得の流れ

  • (2)　注意事項

(1)　ファイル取得の流れ

  1. スプールデータの一覧取得

    スプールサーバ内のスプールデータを一覧で取得します。取得方法については，「13.1.4　スプールデータの一覧取得」を参照してください。

  2. スプールデータの選択

    PDF形式ファイルで取得するスプールデータを一つだけ選択します。

  3. PDF形式ファイルの取得

    ［ジョブ］－［PDF取得］を選択するか，または［PDF取得］ボタンをクリックすると，OSのファイルの保存ダイアログが表示されます。

    ［保存］ボタンをクリックすると，PDF形式ファイルを取得できます。

    PDF取得の処理中は，進捗状況を示すダイアログが表示されます。

ページの先頭へ

(2)　注意事項

帳票管理GUIを使用して印刷データをPDF形式ファイルで取得するときにInternet Explorerの保護モードが有効になっていると，Adobe Flash Playerの仕様により，次に示す問題が発生する場合があります。

  • PDF取得の処理中にエラーが発生した場合，ファイルの保存ダイアログで指定したフォルダに0バイトのファイルが残ることがあります。0バイトのファイルが残っていると，再度同じ保存先とファイル名を指定してもPDF形式ファイルは取得できません。0バイトのファイルが残っている場合は，すべてのブラウザを終了し，手動で削除してください。

  • PDF取得の実行時に，アクセスできないファイルに対して上書き保存を実行すると，PDF形式ファイルが取得できないことがあるため，ファイルを上書き保存する場合は，書き込みアクセス権のあるファイル，かつアクセスできるファイルを選択してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 94 / 218


5.3.5 取得するPDF形式ファイルのプロパティ情報と注意事項 : EUR 帳票出力 機能解説 EUR Server編

  • 95 / 218

  • 表紙

  • 5.　スプールデータを出力するには

  • 5.3　帳票の印刷データを取得する

  • 5.3.5　取得するPDF形式ファイルのプロパティ情報と注意事項

5.3.5　取得するPDF形式ファイルのプロパティ情報と注意事項

〈この項の構成〉

  • (1)　プロパティ情報

  • (2)　注意事項

(1)　プロパティ情報

スプールデータの印刷データから生成するPDF形式ファイルに設定されるプロパティ情報の内容を，次の表に示します。

表5‒5　PDF形式ファイルのプロパティ情報

項目

設定内容

タイトル

タイトルの文字列が次の優先順位で設定されます。

  1. 起動部品で指定したスプールタイトルの指定値

    ・ActiveX起動部品：SpoolTitleプロパティ

    ・Java起動部品：setSpoolTitleメソッド

    ・COBOL起動部品：SPOOLTITLEパラメタ

    ・コマンド起動部品（eurpmcコマンド）：/sptlオプション

  2. 文書情報設定ファイルのTITLEキーの指定値

  3. 帳票ファイル名

作成者

何も設定されません。

サブタイトル

キーワード

作成日

PDF形式ファイルの作成日時が自動で設定されます。

更新日

何も設定されません。

アプリケーション

PDF変換

PDF形式ファイルを生成したコンポーネント名が「EUR Server - Spool Service VVRR」形式の文字列で設定されます。VVRRは，バージョン，リビジョン番号です。

PDFのバージョン

環境変数EURPS_OUTPUTPDF_VERのデフォルト値が設定されます。

ページの先頭へ

(2)　注意事項

スプールデータの印刷データから生成するPDF形式ファイルの注意事項を次に示します。

  • PDF形式ファイル出力で使用できる機能のうち，次の機能は使用できません。

    • 仕分け

    • 分割

    • 暗号化

    • しおりの付加

    • フォントの埋め込み

    • 解像度の指定

    • 印刷位置補正情報の指定

    • JavaScriptプログラムの埋め込み

    • Adobe ReaderのGUIの制御情報の設定

    • 外字ファイルの指定

  • 環境設定ファイル（EURPS_ENV）の環境変数のうち，PDF形式ファイル出力で使用する環境変数は，デフォルト値が適用されます。

    PDF形式ファイル出力で使用する環境変数の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

  • EUR帳票作成機能で表示した場合と異なることがあります。

  • バーコードを使用している場合の注意事項を次に示します。

    • バーコード画像の解像度は，蓄積時に指定されたEPF形式ファイルの解像度に従います。

    • プリンタ定義ファイルのPDF形式ファイルを印刷するときの解像度情報で，QRコードまたはカスタマバーコードの描画データを最小化する指定がされている場合は，小さな画像を作成して拡大表示されます。

  • スプールデータの属性値として参照できるファイルサイズは，EPF形式ファイルのファイルサイズとなります。

  • フォントの出力方法には「フォントの書体名称を出力」が適用されます。PDF形式ファイルで使用するフォントが印刷・表示環境にインストールされている必要があります。

  • 外字を使用している場合の注意事項を次に示します。

    • Windows環境の場合

      スプールサーバのEUR Server - Spool Serviceが稼働しているOSの標準の外字が画像として埋め込まれて出力されます。

    • AIX環境の場合

      外字が空白に置き換えられて出力されます。

    • HP-UX環境の場合

      OSの標準の外字が画像として埋め込まれて出力されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 95 / 218


5.4 蓄積した印刷データを出力する : EUR 帳票出力 機能解説 EUR Server編

  • 96 / 218

  • 表紙

  • 5.　スプールデータを出力するには

  • 5.4　蓄積した印刷データを出力する

5.4　蓄積した印刷データを出力する

ここでは，サーバに蓄積した帳票（スプールデータ）から，印刷データ（EPF形式ファイル）を取り出して出力する方法について説明します。なお，蓄積した印刷データの出力には，帳票管理GUIも利用できます。帳票管理GUIの機能や表示方法については，「13.1　GUIで管理する」を参照してください。

蓄積した印刷データを出力する場合の出力方法を次の表に示します。運用に応じて，適切な方法を選択してください。

表5‒6 蓄積した印刷データを出力する場合の出力方法
印刷データの出力先 | 出力方法 | 運用 | 参照先
スプールサーバ | 自動で出力する | スプールサーバのプリンタに出力する。 | 5.4.1
 | Webブラウザから出力を指示する | 帳票管理GUIを使用して出力する。 | 5.4.3
クライアントPC | 自動で出力する | クライアントごとに異なる帳票を出力する。 | 5.4.2(1)
 |  | 同一の帳票を複数のクライアントに配布して出力する（配布印刷）。 | 5.4.2(3)
 | ダイアログでプリンタを設定して出力する | クライアントごとに異なる帳票を出力する。 | 5.4.2(2)
 |  | 同一の帳票を複数のクライアントに配布して出力する（配布印刷）。 | 5.4.2(3)
 | Webブラウザから出力する | EUR Web Plug-Inを使用して出力する（ActiveXクライアント印刷）。 | 5.4.2(4)
 |  | EUR Client Serviceをヘルパ起動して出力する（ヘルパクライアント印刷）。 | 5.4.2(5)
 |  | 帳票管理GUIを使用して出力する。 | 5.4.3
 | コマンドを実行して出力する | クライアントでコマンドを実行して出力する。 | 5.4.2(6)
〈この節の構成〉

  • 5.4.1　スプールサーバで出力する

  • 5.4.2　クライアントPCで出力する

  • 5.4.3　帳票管理GUIを使用して出力する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 96 / 218


5.4.1 スプールサーバで出力する : EUR 帳票出力 機能解説 EUR Server編

  • 97 / 218

  • 表紙

  • 5.　スプールデータを出力するには

  • 5.4　蓄積した印刷データを出力する

  • 5.4.1　スプールサーバで出力する

5.4.1　スプールサーバで出力する

蓄積した印刷データを，スプールサーバのプリンタに出力できます。

スプールサーバのプリンタに出力するには，スプールサーバにWindows版のEUR Server - Spool Serviceが必要です。スプールサーバがUNIX／Linux環境の場合は，スプールサーバのプリンタへの出力はできません。

〈この項の構成〉

  • (1)　出力の流れ

  • (2)　起動部品の設定

  • (3)　注意事項

(1)　出力の流れ

スプールサーバに登録されているプリンタに帳票を出力する流れを，次の図に示します。

図5‒4　スプールサーバのプリンタに出力する流れ

[図データ]

  1. 出力要求

    ユーザが，出力要求を業務プログラムに送ります。

  2. 印刷データ呼び出し

    業務プログラムが，スプールサーバ内のスプールデータから印刷データ（EPF形式ファイル）を呼び出します。

    このとき，複数のスプールデータのデータを統合して，一つの印刷データとして呼び出すこともできます。スプールデータの統合については，「6.3.2　複数のスプールデータを統合出力する」を参照してください。

  3. 出力

    スプールサーバに登録されているプリンタに帳票が出力されます。

ページの先頭へ

(2)　起動部品の設定

帳票出力で使用する起動部品のメソッドおよびオプションの指定値を次に示します。

  • SS-ActiveX起動部品：PrintSpoolReportメソッド

  • SS-Java起動部品：printSpoolReportメソッド

  • SS-コマンド起動部品（eurpmlscコマンド）：/mオプションにprintを指定

また，出力時に設定する起動部品のプロパティ，メソッド，およびオプションの指定値を次に示します。

  1. スプールデータを格納しているサーバの設定

    スプールデータを格納しているサーバのIPアドレスを設定します。

    サーバの設定

    起動部品の設定項目

    設定する値

    スプールデータを格納しているサーバのIPアドレス

    SS-ActiveX起動部品：ServerAddressプロパティ

    SS-Java起動部品：setServerAddressメソッド

    SS-コマンド起動部品：/svrオプション

    255.255.255.255形式

  2. ジョブIDの設定

    スプールデータのジョブIDを設定します。

    ジョブIDの設定

    起動部品の設定項目

    設定する値

    スプールデータのジョブID

    SS-ActiveX起動部品：SearchJobIDプロパティ

    SS-Java起動部品：setSearchJobIDメソッド，またはsetSearchJobIDMultiメソッド

    SS-コマンド起動部品：/idオプション

    ジョブID（36バイト以内の文字列）

  3. プリンタの設定

    必要に応じて，出力時に使用するスプールサーバのプリンタやトレイを設定します。設定しないときは，スプールデータの属性値に従って出力先を決定します。

    スプールサーバのプリンタの指定方法は，プリンタクラス名，プリンタ名，および帳票振り分け定義の3種類から選択できます。

    スプールサーバのプリンタの設定

    起動部品の設定項目

    設定する値

    プリンタの指定方法

    SS-ActiveX起動部品：PrinterSelectModeプロパティ

    SS-Java起動部品：setPrinterSelectModeメソッド

    0（プリンタクラス名で指定する）

    1（プリンタ名で指定する）

    2（帳票振り分け定義で指定する）

    SS-コマンド起動部品：/smオプション

    class（プリンタクラス名で指定する）

    printer（プリンタ名で指定する）

    group（帳票振り分け定義で指定する）

    プリンタクラス名

    SS-ActiveX起動部品：PrinterClassNameプロパティ

    SS-Java起動部品：setPrinterClassNameメソッド

    SS-コマンド起動部品：/prcオプション

    プリンタクラス名（80バイト以内の文字列）

    プリンタ名

    OS上のプリンタ名

    SS-ActiveX起動部品：ServerPrinterNameプロパティ

    SS-Java起動部品：setServerPrinterNameメソッド

    SS-コマンド起動部品：/lspオプション

    プリンタ名（80バイト以内の文字列）

    OS上のプリンタのトレイ名

    SS-ActiveX起動部品：ServerTrayNameプロパティ

    SS-Java起動部品：setServerTrayNameメソッド

    SS-コマンド起動部品：/lstオプション

    トレイ名（80バイト以内の文字列）

    帳票振り分け定義

    SS-ActiveX起動部品：GroupNameプロパティ

    SS-Java起動部品：setGroupNameメソッド

    SS-コマンド起動部品：/groupオプション

    帳票振り分け定義（80バイト以内の文字列）

  4. 印刷付加情報の設定

    必要に応じて，印刷付加情報（印刷開始ページ，印刷部数，用紙の向きなど）を設定します。

ページの先頭へ

(3)　注意事項

ネットワークプリンタに印刷する場合は，EUR Server - Spool Serviceのログオンアカウントを，ネットワークプリンタに印刷できる適切なアクセス権を持つアカウントに変更してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 97 / 218


5.4.2 クライアントPCで出力する : EUR 帳票出力 機能解説 EUR Server編

  • 98 / 218

  • 表紙

  • 5.　スプールデータを出力するには

  • 5.4　蓄積した印刷データを出力する

  • 5.4.2　クライアントPCで出力する

5.4.2　クライアントPCで出力する

蓄積した印刷データを，クライアントPCのプリンタに出力したり，プレビューしたりできます。

〈この項の構成〉

  • (1)　自動で出力する

  • (2)　ダイアログでプリンタを設定して出力する

  • (3)　複数のクライアントに配布して出力する

  • (4)　Webブラウザから出力する（ActiveXクライアント印刷）

  • (5)　Webブラウザから出力する（ヘルパクライアント印刷）

  • (6)　コマンドを実行して出力する

  • (7)　起動部品の設定

(1)　自動で出力する

帳票をクライアントPCに転送して出力する流れを，次の図に示します。

図5‒5　帳票をクライアントPCに転送して出力する流れ（自動印刷）

[図データ]

  1. 出力要求

    ユーザが，出力要求を業務プログラムに送ります。

  2. 印刷データ呼び出し

    業務プログラムが，スプールサーバ内のスプールデータから印刷データ（EPF形式ファイル）を呼び出します。

    このとき，複数のスプールデータのデータを統合して，一つの印刷データとして呼び出すこともできます。スプールデータの統合については，「6.3.2　複数のスプールデータを統合出力する」を参照してください。

  3. 印刷データ転送

    EUR Server - Spool Serviceは，生成された印刷データ（EPF形式ファイル）をクライアントPCに転送します。

  4. 出力

    印刷データ（EPF形式ファイル）を受信すると，EUR Client Serviceが起動して，指定したプリンタに自動で出力されます。

ページの先頭へ

(2)　ダイアログでプリンタを設定して出力する

帳票をクライアントPCに転送して出力する流れを，次の図に示します。

図5‒6　帳票をクライアントPCに転送して出力する流れ（対話型印刷）

[図データ]

  1. 出力要求

    ユーザが，出力要求を業務プログラムに送ります。

  2. 印刷データ呼び出し

    業務プログラムが，スプールサーバ内のスプールデータから印刷データ（EPF形式ファイル）を呼び出します。

    このとき，複数のスプールデータのデータを統合して，一つの印刷データとして呼び出すこともできます。スプールデータの統合については，「6.3.2　複数のスプールデータを統合出力する」を参照してください。

  3. 印刷データ転送

    EUR Server - Spool Serviceは，生成された印刷データ（EPF形式ファイル）をクライアントPCに転送します。

  4. ［印刷先指定］ダイアログの表示

    印刷データ（EPF形式ファイル）を受信すると，EUR Client Serviceが起動して，出力先を設定するダイアログが表示されます。

  5. プリンタの選択

    ［プリンタ］リストボックスで，クライアントPCのプリンタを選択します。

    出力したことがある印刷データ（EPF形式ファイル）を受信した場合は，前回の受信時に設定したプリンタ名が表示されます。初めて出力する印刷データ（EPF形式ファイル）を受信した場合は，プリンタ名は表示されません。

  6. トレイの選択

    ［トレイ］リストボックスで，出力で使用するトレイを選択します。

    出力したことがある印刷データ（EPF形式ファイル）を受信した場合は，前回の受信時に設定したトレイ名が表示されます。初めて出力する印刷データ（EPF形式ファイル）を受信した場合は，トレイ名は表示されません。

  7. ［OK］ボタンのクリック

    指定したプリンタのトレイで帳票が出力されます。

ページの先頭へ

(3)　複数のクライアントに配布して出力する

クライアントPCのプリンタに配布印刷する流れを，次の図に示します。

図5‒7　クライアントPCのプリンタに配布印刷する流れ

[図データ]

印刷データの取得
1.　出力要求

ユーザが，出力要求を業務プログラムに送ります。

2.　印刷データ取得

業務プログラムが，スプールサーバ内のスプールデータから印刷データ（EPF形式ファイル）を取得します。

このとき，複数のスプールデータのデータを統合して，一つの印刷データとして取得することもできます。スプールデータの統合については，「6.3.2　複数のスプールデータを統合出力する」を参照してください。

配布印刷

手順2.で取得した印刷データを次の手順を繰り返すことで，複数のクライアントPCに配布します。

3.　印刷データ転送

EUR Server - Adapterは，取得した印刷データ（EPF形式ファイル）を，帳票サーバ内のEUR Server Serviceを経由して複数のクライアントPCに転送します。

4.　出力・プレビュー

配布先のクライアントPCのプリンタから帳票を出力したり，プレビューしたりできます。

ページの先頭へ

(4)　Webブラウザから出力する（ActiveXクライアント印刷）

クライアントPCのプリンタにActiveXクライアント印刷する流れを，次の図に示します。

図5‒8　クライアントPCのプリンタにActiveXクライアント印刷する流れ

[図データ]

  1. 出力要求

    ユーザが，出力要求を業務プログラムに送ります。

  2. 印刷データ取得

    業務プログラムが，スプールサーバ内のスプールデータから印刷データ（EPF形式ファイル）を取得します。

    このとき，複数のスプールデータのデータを統合して，一つの印刷データとして取得することもできます。スプールデータの統合については，「6.3.2　複数のスプールデータを統合出力する」を参照してください。

  3. 印刷データ転送

    EUR Server - Spool Serviceは，取得した印刷データ（EPF形式ファイル）をアプリケーションサーバに転送します。

  4. ダウンロード

    クライアントPCのWebブラウザから，Webサーバにアクセスして印刷データ（EPF形式ファイル）をダウンロードします。

    Webサーバとアプリケーションサーバが別マシンであったり，ネットワークを共有していたりする場合は，業務プログラム側でアプリケーションサーバの印刷データ（EPF形式ファイル）をWebサーバに転送しておいてください。

  5. 出力・プレビュー

    印刷データ（EPF形式ファイル）のダウンロードが完了すると，EUR Web Plug-Inによって，クライアントPCのプリンタから帳票を出力したり，プレビューしたりできます。

■注意

  • 32ビット版のInternet Explorerを使用してください。64ビット版のInternet Explorerでは，帳票の出力はできません。

ページの先頭へ

(5)　Webブラウザから出力する（ヘルパクライアント印刷）

クライアントPCのプリンタにヘルパクライアント印刷する流れを，次の図に示します。

図5‒9　クライアントPCのプリンタにヘルパクライアント印刷する流れ

[図データ]

  1. 出力要求

    ユーザが，出力要求を業務プログラムに送ります。

  2. 印刷データ取得

    業務プログラムが，スプールサーバ内のスプールデータから印刷データ（EPF形式ファイル）を取得します。

    このとき，複数のスプールデータのデータを統合して，一つの印刷データとして取得することもできます。スプールデータの統合については，「6.3.2　複数のスプールデータを統合出力する」を参照してください。

  3. 印刷データ転送

    EUR Server - Spool Serviceは，取得した印刷データ（EPF形式ファイル）をアプリケーションサーバに転送します。

  4. ダウンロード

    クライアントPCのWebブラウザから，Webサーバにアクセスして印刷データ（EPF形式ファイル）をダウンロードします。

    Webサーバとアプリケーションサーバが別マシンであったり，ネットワークを共有していたりする場合は，業務プログラム側でアプリケーションサーバの印刷データ（EPF形式ファイル）をWebサーバに転送しておいてください。

    なお，HTTPヘッダに指定するEPF形式ファイルのMIMEタイプには，次のとおり指定してください。

    • 帳票をプリンタに出力する場合

      「application/vnd.hitachi.eurpm-print」を指定します。

    • 帳票をプレビューする場合

      「application/vnd.hitachi.eurpm-view」を指定します。

  5. ヘルパ起動

    クライアントPCにインストールされたEUR Client Serviceを起動します。

  6. 出力・プレビュー

    クライアントPCのプリンタから帳票を出力したり，プレビューしたりできます。

手順4.の代わりに，EPF形式ファイルをメール送信する運用もできます。この場合，メール受信者は，添付されたEPF形式ファイルをローカルディスクに保存し，ダブルクリックすることで出力できます。

ページの先頭へ

(6)　コマンドを実行して出力する

コマンドを実行してクライアントPCのプリンタに出力する流れを，次の図に示します。

図5‒10　コマンドを実行してクライアントPCのプリンタに出力する流れ

[図データ]

  1. 出力要求

    ユーザが，出力要求を業務プログラムに送ります。

  2. 印刷データ取得

    業務プログラムが，スプールサーバ内のスプールデータから印刷データ（EPF形式ファイル）を取得します。

    このとき，複数のスプールデータのデータを統合して，一つの印刷データとして取得することもできます。スプールデータの統合については，「6.3.2　複数のスプールデータを統合出力する」を参照してください。

  3. 印刷データ転送

    EUR Server - Spool Serviceは，取得した印刷データ（EPF形式ファイル）をアプリケーションサーバに転送します。

  4. ダウンロード

    クライアントPCの業務プログラムから，Webサーバにアクセスして印刷データ（EPF形式ファイル）をダウンロードします。

    Webサーバとアプリケーションサーバが別マシンであったり，ネットワークを共有していたりする場合は，業務プログラム側でアプリケーションサーバの印刷データ（EPF形式ファイル）をWebサーバに転送しておいてください。

  5. 出力・プレビュー

    コマンドを実行して，クライアントPCのプリンタから帳票を出力したり，プレビューしたりできます。

■参考

手順2.で取得した印刷データを直接クライアントPCに転送してeurpmcepfviewerコマンドを実行しても，帳票を出力できます。

ページの先頭へ

(7)　起動部品の設定

(a)　帳票を自動印刷または対話型印刷する場合

帳票出力で使用する起動部品のメソッドおよびオプションの指定値を次に示します。

  • SS-ActiveX起動部品：PrintSpoolReportメソッド

  • SS-Java起動部品：printSpoolReportメソッド

  • SS-コマンド起動部品（eurpmlscコマンド）：/mオプションにprintを指定

また，出力時に設定する起動部品のプロパティ，メソッド，およびオプションの指定値を次に示します。

  1. スプールデータを格納しているサーバの設定

    スプールデータを格納しているサーバのIPアドレスを設定します。

    サーバの設定

    起動部品の設定項目

    設定する値

    スプールデータを格納しているサーバのIPアドレス

    SS-ActiveX起動部品：ServerAddressプロパティ

    SS-Java起動部品：setServerAddressメソッド

    SS-コマンド起動部品：/svrオプション

    255.255.255.255形式

  2. ジョブIDの設定

    スプールデータのジョブIDを設定します。

    ジョブIDの設定

    起動部品の設定項目

    設定する値

    スプールデータのジョブID

    SS-ActiveX起動部品：SearchJobIDプロパティ

    SS-Java起動部品：setSearchJobIDメソッド，またはsetSearchJobIDMultiメソッド

    SS-コマンド起動部品：/idオプション

    ジョブID（36バイト以内の文字列）

  3. クライアントPCの設定

    クライアントPCのIPアドレスを指定します。

    クライアントPCの設定

    起動部品の設定項目

    設定する値

    IPアドレス

    SS-ActiveX起動部品：ClientAddressプロパティ

    SS-Java起動部品：setClientAddressメソッド

    SS-コマンド起動部品：/clientオプション

    255.255.255.255形式

  4. ダイアログの設定

    クライアントPCで帳票を受信したときにダイアログを表示するかどうかを設定します。

    ダイアログの設定

    起動部品の設定項目

    設定する値

    ダイアログを表示するかどうか

    SS-ActiveX起動部品：DispPrintDlgプロパティ

    SS-Java起動部品：setDispPrintDlgメソッド

    0（対話型印刷）

    1（自動印刷）

    2（対話型印刷プレビュー表示）

    3（全自動印刷）※1

    4（対話型印刷プレビュー表示限定）※2

    SS-コマンド起動部品：/dialogオプション

    dialog（対話型印刷）

    auto（自動印刷）

    preview（対話型印刷プレビュー表示）

    fullauto（全自動印刷）※1

    pvonly（対話型印刷プレビュー表示限定）※2

    注※1　印刷実行時に印刷中のダイアログが表示されません。

    注※2　印刷ダイアログを表示しないため，印刷を実行できません。

  5. クライアントPCのプリンタの設定

    必要に応じて，出力時に使用するクライアントPCのプリンタやトレイを設定します。設定しないときは，スプールデータの属性値に従って出力先を決定します。

    クライアントPCのプリンタの設定方法は，プリンタクラス名とプリンタ名の2種類の指定方法を選択できます。

    クライアントPCのプリンタの設定

    起動部品の設定項目

    設定する値

    プリンタクラス名

    SS-ActiveX起動部品：PrinterClassNameプロパティ

    SS-Java起動部品：setPrinterClassNameメソッド

    SS-コマンド起動部品：/prcオプション

    プリンタクラス名（80バイト以内の文字列）

    プリンタ名

    OS上のプリンタ名

    SS-ActiveX起動部品：ClientPrinterNameプロパティ

    SS-Java起動部品：setClientPrinterNameメソッド

    SS-コマンド起動部品：/pオプション

    プリンタ名（80バイト以内の文字列）

    OS上のプリンタのトレイ名

    SS-ActiveX起動部品：ClientTrayNameプロパティ

    SS-Java起動部品：setClientTrayNameメソッド

    SS-コマンド起動部品：/tオプション

    トレイ名（80バイト以内の文字列）

  6. 印刷付加情報の設定

    必要に応じて，印刷付加情報（印刷部数，用紙の向きなど）を設定します。

(b)　帳票を配布印刷，ActiveXクライアント印刷，ヘルパクライアント印刷，またはコマンド実行で印刷する場合

帳票を配布印刷，ActiveXクライアント印刷，ヘルパクライアント印刷，またはコマンド実行で印刷するには，スプールデータから印刷データ（EPF形式ファイル）を取得する必要があります。スプールデータから印刷データを取得するときの起動部品の設定については，「5.3　帳票の印刷データを取得する」を参照してください。

取得した印刷データは，次の方法で印刷します。

  • 配布印刷する場合

    取得した印刷データをクライアントPCに配布して印刷します。

    クライアントPCに配布印刷するときの起動部品の設定については，「3.2.2(2)(b)　配布印刷に関する設定」（自動印刷するとき）または「3.2.4(2)(b)　配布印刷に関する設定」（対話型印刷するとき）を参照してください。

  • ActiveXクライアント印刷またはヘルパクライアント印刷する場合

    取得した印刷データをWebサーバに転送しておき，クライアントPCのWebブラウザから印刷データをダウンロードして印刷します。

  • コマンド実行で印刷する場合

    取得した印刷データをWebサーバに転送しておきます。クライアントPCのWebブラウザから印刷データをダウンロードしたあと，eurpmcepfviewerコマンドを実行して印刷します。また，取得した印刷データを直接クライアントPCに転送してeurpmcepfviewerコマンドを実行しても，帳票を印刷できます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 98 / 218


5.4.3 帳票管理GUIを使用して出力する : EUR 帳票出力 機能解説 EUR Server編

  • 99 / 218

  • 表紙

  • 5.　スプールデータを出力するには

  • 5.4　蓄積した印刷データを出力する

  • 5.4.3　帳票管理GUIを使用して出力する

5.4.3　帳票管理GUIを使用して出力する

Webブラウザ上で帳票管理GUIから出力先を選んで帳票を出力できます。スプールサーバのプリンタ，またはクライアントPCのプリンタに出力できます。

なお，帳票管理GUIはイントラネット内でご使用ください。

〈この項の構成〉

  • (1)　出力の流れ

  • (2)　出力で使用する画面

  • (3)　注意事項

(1)　出力の流れ

  1. スプールデータの一覧取得

    スプールサーバ内のスプールデータを一覧で取得します。取得方法については，「13.1.4　スプールデータの一覧取得」を参照してください。

  2. 出力するスプールデータの選択

    出力するスプールデータを一つ以上選択します。

  3. ［印刷］画面の表示

    ［ジョブ］－［印刷］を選択するか，または［印刷］ボタンをクリックすると，［印刷］画面が表示されます。

    なお，手順2.でスプールデータを選択して［プレビュー］画面を表示したあとに，［印刷］画面を表示することもできます。

  4. 印刷方式および印刷オプションの指定

    ［印刷］画面で印刷方式および印刷オプションを指定します。

    印刷範囲は，スプールデータに格納されている印刷データのページ数，またはスプールデータのジョブ番号を指定して選択できます。

  5. ［OK］ボタンのクリック

    ［印刷］画面の［OK］ボタンをクリックして，印刷を実行します。

    なお，［このマシンで印刷］ラジオボタンを選択している場合は，［OK］ボタンをクリックしたあと，OSの印刷ダイアログが表示されます。

    印刷するプリンタのプリンタ名などを指定して，印刷を実行してください。

  6. 再印刷

    プリンタのエラーなどで印刷を中断した場合，［印刷］画面で再印刷するページ範囲を指定して，印刷を実行します。

    ページ番号を印刷していない帳票の場合など，再印刷するページ範囲を特定できないときは，印刷済みの帳票から印刷を中断した個所を特定するキーワードを確認したあと，［プレビュー］画面の［検索］ダイアログで該当するページを検索して，再印刷するページ番号をステータスバーで確認します。

ページの先頭へ

(2)　出力で使用する画面

(a)　［印刷］画面

［印刷方式］グループボックス
［このマシンで印刷］ラジオボタン

帳票管理GUIを操作しているマシンに接続されているプリンタで印刷します。

  • ［一つの帳票として印刷する］チェックボックス

    印刷方法を指定します。チェックを入れると，複数のスプールデータから印刷データを取り出し，不定の順序で一つにまとめて印刷できます。

    スプールデータを複数選択し，かつ［このマシンで印刷］ラジオボタンを選択している場合にチェックできます。

［蓄積情報で印刷］ラジオボタン

スプールデータに設定されている実行可能印刷方式の情報に従って印刷します。実行可能印刷方式が［蓄積拠点サーバ印刷／蓄積クライアント印刷］の場合は，［優先する情報］の指定に従って印刷されます。

［優先する情報］グループボックス

蓄積拠点サーバ印刷または蓄積クライアント印刷を指定します。［蓄積情報で印刷］ラジオボタンを選択すると，入力できます。

  • ［蓄積拠点サーバ印刷］ラジオボタン

    スプールデータの実行可能印刷方式が［蓄積拠点サーバ印刷／蓄積クライアント印刷］の場合に，スプールデータの印刷情報を優先して蓄積拠点サーバ印刷を実行します。

  • ［蓄積クライアント印刷］ラジオボタン

    スプールデータの実行可能印刷方式が［蓄積拠点サーバ印刷／蓄積クライアント印刷］の場合に，スプールデータの印刷情報を優先して蓄積クライアント印刷を実行します。

［印刷オプション］グループボックス

●スプールデータを一つだけ選択している場合

［全ページ印刷］ラジオボタン

全ページを印刷します。

［蓄積拠点サーバ印刷時のみ有効］グループボックス

［ページ指定］ラジオボタン

印刷開始ページと印刷終了ページを指定して印刷します。スプールサーバに出力する場合だけ指定が有効になります。

［ページ指定］ラジオボタンの右にあるテキストボックスに，ページ番号を半角数字で入力してください。印刷開始ページに指定した値が，印刷終了ページに指定した値よりも大きい場合はエラーとなります。

［現在のページを印刷］ラジオボタン

プレビュー領域に表示しているページを印刷します。［プレビュー］画面の［印刷］ボタンから［印刷］画面を開いた場合だけ指定できます。なお，スプールサーバに出力する場合だけ指定が有効になります。

●複数のスプールデータを選択している場合

［全ジョブ印刷］ラジオボタン

選択したスプールデータに格納されている印刷データを全ページ印刷します。

［ジョブ指定］ラジオボタン

選択したスプールデータの中から，ジョブ番号を指定して印刷します。［プレビュー］画面の［印刷］ボタンから［印刷］画面を開いた場合だけ指定できます。

［ジョブ指定］ラジオボタンの右にあるテキストボックスに，ジョブ番号を半角数字で入力してください。印刷を開始するジョブ番号に指定した値が，印刷を終了するジョブ番号に指定した値よりも大きい場合はエラーとなります。

［現在のジョブを印刷］ラジオボタン

プレビュー領域に表示している帳票を印刷します。［プレビュー］画面の［印刷］ボタンから［印刷］画面を開いた場合だけ指定できます。

  • ［全ページ］ラジオボタン

    プレビュー領域に表示している帳票のすべてのページを印刷します。

［蓄積拠点サーバ印刷時のみ有効］グループボックス

  • ［ページ指定］ラジオボタン

    プレビュー領域に表示している帳票の印刷開始ページと印刷終了ページを指定して印刷します。複数の帳票を選択している場合は，選択した帳票の総ページ数で指定します。なお，スプールサーバに出力する場合だけ指定が有効になります。

    ［ページ指定］ラジオボタンの右にあるテキストボックスに，ページ番号を半角数字で入力してください。印刷開始ページに指定した値が，印刷終了ページに指定した値よりも大きい場合はエラーとなります。

［OK］ボタン

指定した印刷方式および印刷オプションで帳票を印刷します。

印刷オプションの設定に範囲以外の値を指定した場合はエラーとなります。

［キャンセル］ボタン

［印刷］画面を閉じて，元の画面に戻ります。

(b)　［プレビュー］画面

ツールバー
［先頭］ボタン

先頭ページに移動します。

［前］ボタン

前ページに移動します。

［次］ボタン

次ページに移動します。

［最終］ボタン

最終ページに移動します。

［ページ指定］ボタン

［指定ページジャンプ］ダイアログが表示されます。指定したページに移動します。［指定ページジャンプ］ダイアログについては，「(c)　［指定ページジャンプ］ダイアログ」を参照してください。

［印刷］ボタン

［印刷］画面が表示されます。［印刷］画面で印刷の設定ができます。印刷については，「(a)　［印刷］画面」を参照してください。

［拡大率］ボタン

［拡大率の指定］ダイアログが表示されます。指定した拡大率で帳票を表示できます。デフォルトの拡大率は，75%です。［拡大率の指定］ダイアログについては，「(d)　［拡大率の指定］ダイアログ」を参照してください。

［検索］ボタン

［検索］ダイアログが表示されます。［検索］ダイアログについては，「(e)　［検索］ダイアログ」を参照してください。

［次検索］ボタン

［検索］ダイアログで前回実行した検索の内容に従って，次の検索を実行します。一度も検索を実行していない場合は，［検索］ダイアログが表示されます。

［閉じる］ボタン

［プレビュー］画面を閉じます。

セクション領域

スプールデータのジョブIDが選択した順に一覧で表示されます。プレビュー領域に表示しているスプールデータのジョブIDが反転表示されます。

プレビュー領域

帳票の内容をプレビュー表示します。

ステータスバー

帳票のページ番号が表示されます。形式は，「ページ番号/総ページ数」です。

(c)　［指定ページジャンプ］ダイアログ

［現在表示ページ］

プレビュー領域に表示されたページのページ番号が表示されます。形式は，「ページ番号/総ページ数」です。

［ページ番号の入力］テキストボックス

表示したいページ番号を1から総ページ数の範囲で入力します。半角数字で入力してください。

［ジャンプ］ボタン

指定したページをプレビュー領域に表示します。

1から総ページ数の範囲以外の値を指定した場合はエラーとなります。

［キャンセル］ボタン

表示ページを変更しないで，［指定ページジャンプ］ダイアログを閉じます。

(d)　［拡大率の指定］ダイアログ

［現在の拡大率］

プレビュー領域に表示された倍率を表示します。

［拡大率］グループボックス

［25%］ラジオボタン：帳票を25%の倍率で表示します。

［75%］ラジオボタン：帳票を75%の倍率で表示します。

［100%］ラジオボタン：帳票を100%の倍率で表示します。

［150%］ラジオボタン：帳票を150%の倍率で表示します。

［200%］ラジオボタン：帳票を200%の倍率で表示します。

［任意］ラジオボタン：任意の拡大率を指定します。

拡大率指定テキストボックス

任意の倍率を入力します。［任意］ラジオボタンを選択すると，入力できます。25～200の半角数字を指定してください。25～200の範囲以外の値を指定した場合はエラーとなります。

［OK］ボタン

指定した拡大率で帳票をプレビュー領域に表示します。

25%から200%の範囲以外の値を指定した場合はエラーとなります。

［キャンセル］ボタン

拡大率を変更しないで，［拡大率の指定］ダイアログを閉じます。

(e)　［検索］ダイアログ

［検索する文字列］テキストボックス

検索する文字列を指定します。最大127文字まで入力できます。

2回目以降の検索では，前回検索を実行したときの文字列が表示されます。

［大文字と小文字を区別する］チェックボックス

検索するときに英字の大文字と小文字を区別するかどうかを指定します。英字の大文字と小文字を区別する場合はチェックボックスをオンにします。デフォルトはオンです。

2回目以降の検索では，前回検索を実行したときの状態で表示されます。

［検索する方向］グループボックス

検索する方向を選択します。下方向に検索する場合は［下へ］ラジオボタンを，上方向に検索する場合は［上へ］ラジオボタンを選択します。デフォルトは［下へ］ラジオボタンが選択状態で表示されます。

2回目以降の検索では，前回検索を実行したときの選択状態で表示されます。

［次を検索］ボタン

入力された検索条件に従って，プレビュー領域の文字列検索を実行します。

検索する文字列が見つかった場合，見つかった文字列が反転表示されます。

［キャンセル］ボタン

検索を実行しないで，［検索］ダイアログを閉じます。

ページの先頭へ

(3)　注意事項

(a)　ディスプレイに表示される文字の大きさについての注意

ディスプレイに表示される文字の大きさを変更しないでください。Windows 7，Windows 8.1，およびWindows 10の場合は，「小-100%（規定）」が規定の大きさです。規定以外の大きさで帳票をプレビュー表示すると，帳票の表示が不正になります。

ディスプレイに表示される文字の大きさは，［コントロールパネル］から，［デスクトップのカスタマイズ］－［ディスプレイ］を選択すると確認できます。

(b)　スプールデータの一覧をソート表示する場合の注意

取得したスプールデータの一覧をソート表示する場合，一覧に表示されているスプールデータの件数が5,000件程度になるようにしてください。一覧に表示されているスプールデータの件数が多い（約10,000件以上）と，正しくソートできないことがあります。

一覧に表示されているスプールデータの件数が5,000件を超えている場合，検索条件を設定するなどして，表示されるスプールデータを絞り込んでください。検索条件の設定方法については，「13.1.9　スプールデータの検索」を参照してください。

(c)　EUR Web Plug-Inを使用する場合の注意

  • 32ビット版のInternet Explorerを使用してください。64ビット版のInternet Explorerでは，帳票の印刷やプレビュー表示はできません。

  • 帳票管理GUIで次の操作を行うと，EUR Web Plug-Inの実行を許可するかどうかを確認するダイアログが表示されます。

    • プレビュー表示

    • ［印刷］画面から［このマシンで印刷］を選択して印刷を実行

    ダイアログが表示されたら実行を許可してください。ただし，ダイアログの応答後には画面が初期表示に戻ります。

    なお，帳票管理GUIを使用する前に，Internet Explorerのアドオンの管理機能でEUR Web Plug-Inの実行を許可しておくこともできます。

  • メニューバーの［表示］－［拡大］で「100%」を指定して使用してください。また，帳票のプレビュー表示中に倍率を変更しないでください。倍率に100%以外を指定した状態で帳票をプレビュー表示すると，帳票の表示が不正になります。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 99 / 218


6. 仕分け・分割・統合して出力する : EUR 帳票出力 機能解説 EUR Server編

  • 100 / 218

  • 表紙

  • 6.　仕分け・分割・統合して出力する

6.　仕分け・分割・統合して出力する

この章では，帳票を仕分け，分割，または統合して出力する方法について説明します。

〈この章の構成〉

  • 6.1　仕分けして出力するには

  • 6.2　分割して出力するには

  • 6.3　統合して出力するには

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 100 / 218


6.1 仕分けして出力するには : EUR 帳票出力 機能解説 EUR Server編

  • 101 / 218

  • 表紙

  • 6.　仕分け・分割・統合して出力する

  • 6.1　仕分けして出力するには

6.1　仕分けして出力するには

ここでは，入力データ中のキーとなるフィールドの値ごとに帳票を仕分けして出力する方法（仕分け出力）について説明します。

帳票を仕分けして出力するには，次の表に示す方法があります。

表6‒1 仕分け出力の出力方法
出力方法 | 説明 | 参照先
PDF仕分け出力 | 仕分けした帳票をPDF形式ファイルで出力します。 | 6.1.1
PDF暗号化仕分け出力 | 仕分けした帳票を暗号化PDF形式ファイルで出力します。 | 6.1.2
蓄積仕分け出力 | 仕分けした帳票の印刷データ（EPF形式ファイル）を，スプールサーバに蓄積します。 | 6.1.3
〈この節の構成〉

  • 6.1.1　PDF仕分け出力する

  • 6.1.2　PDF暗号化仕分け出力する

  • 6.1.3　蓄積仕分け出力する

  • 6.1.4　コーディング例

  • 6.1.5　注意事項

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 101 / 218


6.1.1 PDF仕分け出力する : EUR 帳票出力 機能解説 EUR Server編

  • 102 / 218

  • 表紙

  • 6.　仕分け・分割・統合して出力する

  • 6.1　仕分けして出力するには

  • 6.1.1　PDF仕分け出力する

6.1.1　PDF仕分け出力する

ここでは，帳票をPDF仕分け出力する方法について説明します。帳票をPDF仕分け出力するには，EUR Server Standard，またはEUR Server Enterpriseが必要です。

〈この項の構成〉

  • (1)　出力の流れ

  • (2)　出力で使用するファイル

(1)　出力の流れ

帳票をPDF仕分け出力する流れを次の図に示します。

図6‒1　帳票をPDF仕分け出力する流れ

[図データ]

  1. 出力要求

    帳票の出力要求が業務プログラムに送られます。

  2. 転送

    EUR Server - Adapterは，ユーザデータファイルを帳票サーバのEUR Server Serviceに転送します。

  3. 印刷データ生成

    転送されたユーザデータファイルと，あらかじめ帳票サーバに配置しておいた印刷定義ファイルなどの定義ファイルから，印刷データ（PDF形式ファイル）が生成されます。

    この図では，"総務"と"経理"というキーワードによって帳票が仕分けされ，印刷データが生成されます。

  4. 印刷データ転送

    業務アプリケーションの機能を使って，印刷データ（PDF形式ファイル）をEUR Server Service稼働マシンからEUR Server - Adapter稼働マシンに転送します。

  5. 出力

    アプリケーションサーバからクライアントPCに印刷データ（PDF形式ファイル）をダウンロードすることで，クライアントPCのAdobe Readerを使用して帳票をプリンタに出力したり，プレビューしたりできます。

ページの先頭へ

(2)　出力で使用するファイル

PDF仕分け出力で使用するファイルの概要について説明します。各ファイルの指定内容の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

(a)　PDF仕分け定義ファイル

PDF形式ファイルを仕分けするときのキーワードや出力先ファイル名などを指定します。

■PDF形式ファイルを仕分け出力する場合の指定例

帳票のキーフィールド名「F1」のデータである「A」と「B」をキーワードに指定して，PDF形式ファイルを仕分け出力するときの指定例です。

PDF仕分け定義ファイル（shiwake.csv）の定義内容
KEYFIELD,1,F1
DATA,Alunch.pdf,A
DATA,Blunch.pdf,B
マッピングデータファイル（menu.csv）の内容
F1,F2,F3
A,Fish,タイ
A,Fish,サケ
A,Fish,マグロ
B,Meat,牛肉
B,Meat,豚肉

「Alunch.pdf」には，「Fish　タイ」「Fish　サケ」「Fish　マグロ」が表示されます。また，「Blunch.pdf」には，「Meat　牛肉」「Meat　豚肉」が表示されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 102 / 218


6.1.2 PDF暗号化仕分け出力する : EUR 帳票出力 機能解説 EUR Server編

  • 103 / 218

  • 表紙

  • 6.　仕分け・分割・統合して出力する

  • 6.1　仕分けして出力するには

  • 6.1.2　PDF暗号化仕分け出力する

6.1.2　PDF暗号化仕分け出力する

ここでは，帳票をPDF暗号化仕分け出力する方法について説明します。帳票をPDF暗号化仕分け出力するには，EUR Server Standard，またはEUR Server Enterpriseに加えて，EUR Server - Cipher optionが必要です。

〈この項の構成〉

  • (1)　出力の流れ

  • (2)　出力で使用するファイル

(1)　出力の流れ

帳票をPDF暗号化仕分け出力する流れを次の図に示します。

図6‒2　帳票をPDF暗号化仕分け出力する流れ

[図データ]

  1. 出力要求

    帳票の出力要求が業務プログラムに送られます。

  2. 転送

    EUR Server - Adapterは，ユーザデータファイルを帳票サーバのEUR Server Serviceに転送します。

  3. 印刷データ生成

    転送されたユーザデータファイルと，あらかじめ帳票サーバに配置しておいた印刷定義ファイルなどの定義ファイルから，印刷データ（暗号化PDF形式ファイル）が生成されます。

    この図では，"既存顧客"と"見込み顧客"というキーワードによって帳票が仕分けされ，印刷データが生成されます。

  4. 印刷データ転送

    業務アプリケーションの機能を使って，印刷データ（暗号化PDF形式ファイル）をEUR Server Service稼働マシンからEUR Server - Adapter稼働マシンに転送します。

  5. 出力

    アプリケーションサーバからクライアントPCに印刷データ（暗号化PDF形式ファイル）をダウンロードすることで，クライアントPCのAdobe Readerを使用して帳票をプリンタに出力したり，プレビューしたりできます。

ページの先頭へ

(2)　出力で使用するファイル

PDF暗号化仕分け出力で使用するファイルの概要について説明します。各ファイルの指定内容の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。また，暗号化出力したPDF形式ファイルを開いたときの動作については，「4.1.2(2)　暗号化出力したPDF形式ファイルの動作」を参照してください。

(a)　PDF仕分け定義ファイル

PDF形式ファイルを仕分けするときのキーワードや出力先ファイル名などを指定します。また，仕分けしたPDF形式ファイルを閲覧するためのパスワード（ユーザパスワード）を指定します。暗号化したパスワードも指定できます。パスワードの暗号化については，「4.1.2(3)　パスワードの暗号化」を参照してください。

(b)　暗号化設定ファイル

PDF形式ファイルを暗号化するセキュリティ属性を指定します。暗号化設定ファイルに指定する項目を次に示します。

  • ユーザパスワード（PDF形式ファイルを閲覧するためのパスワード）

  • オーナパスワード（セキュリティ属性を変更するパスワード）

  • 印刷

  • 文書の変更

  • 内容のコピー，または抽出

  • 注釈とフォームフィールドの作成

なお，ユーザパスワードとオーナパスワードには，暗号化したパスワードも指定できます。パスワードの暗号化については，「4.1.2(3)　パスワードの暗号化」を参照してください。

■PDF形式ファイルを暗号化仕分け出力する場合の指定例

仕分けしたファイルに，次の設定をするときの指定例です。

  • PDF形式ファイルを閲覧するとき，パスワードの入力を求めます。

  • PDF形式ファイルの印刷を禁止します。

暗号化設定ファイル（cipher.txt）の定義内容
OwnerPassword=OWNER
DisablePrint=Yes
PDF仕分け定義ファイル（shiwake.csv）の定義内容
KEYFIELD,1,氏名番号
DATA,00000001.pdf,00000001,TARO
DATA,00000002.pdf,00000002,HANAKO
マッピングデータファイル（shikyuu.csv）の内容
所属,氏名番号,氏名,支給額
勤労課,00000001,日立太郎,250000
勤労課,00000002,日立花子,200000

「00000001.pdf」には「勤労課　日立太郎　250,000円」が出力され，「00000002.pdf」には「勤労課　日立花子　200,000円」が出力されます。

どちらも，ファイルを開こうとすると，パスワードの入力を求められます。

また，ファイルを開くと，［文書のセキュリティ］ダイアログには次のように表示されます。

ユーザパスワード：はい

オーナパスワード：はい

印刷　　　　　　：許可しない

なお，お使いのAdobe Readerのバージョンによっては，表示内容が異なる場合があります。

暗号化設定ファイルの指定内容の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 103 / 218


6.1.3 蓄積仕分け出力する : EUR 帳票出力 機能解説 EUR Server編

  • 104 / 218

  • 表紙

  • 6.　仕分け・分割・統合して出力する

  • 6.1　仕分けして出力するには

  • 6.1.3　蓄積仕分け出力する

6.1.3　蓄積仕分け出力する

ここでは，帳票を蓄積仕分け出力する方法について説明します。蓄積仕分け出力することで，印刷データごとに別々の出力先を設定できるため，記載内容によって帳票の出力先を変更したい場合に便利です。なお，帳票を蓄積仕分け出力するには，EUR Server Enterpriseが必要です。

〈この項の構成〉

  • (1)　出力の流れ

  • (2)　出力で使用するファイル

  • (3)　起動部品の設定

(1)　出力の流れ

帳票を蓄積仕分け出力する流れを次の図に示します。

図6‒3　帳票を蓄積仕分け出力する流れ

[図データ]

  1. 出力要求

    帳票の出力要求が業務プログラムに送られます。

  2. 転送

    EUR Server - Adapterは，ユーザデータファイルを帳票サーバのEUR Server Serviceに転送します。

  3. 印刷データ生成

    転送されたユーザデータファイルと，あらかじめ帳票サーバに配置しておいた印刷定義ファイル，印刷先定義ファイルなどの定義ファイルから，印刷データ（EPF形式ファイル）が生成されます。

    この図では，"本社"と"支店"というキーワードによって帳票が仕分けされ，印刷データが生成されます。

  4. 印刷データ転送

    印刷データは，キーワードごとに決められた印刷先に自動で転送されます。

    この図では，キーワード"本社"に該当する印刷データは，東京本社のスプールサーバに転送されます。また，キーワード"支店"に該当する印刷データは，新宿支店のスプールサーバに転送されます。

  5. 蓄積

    EUR Server - Spool Serviceが印刷データ（EPF形式ファイル）を受信すると，スプールサーバ内に印刷データが蓄積されます。このとき，属性情報が付けられてスプールデータとなります。スプールデータは，手順3.で生成された印刷データの数だけ生成されます。

  6. 出力

    スプールデータの属性情報に従って，スプールサーバのプリンタ，またはクライアントPCのプリンタで出力されます。

■注意

スプールサーバのプリンタに出力できるのは，スプールサーバがWindows環境の場合だけです。スプールサーバがUNIX／Linux環境の場合は，スプールサーバのプリンタへの出力はできません。

ページの先頭へ

(2)　出力で使用するファイル

蓄積仕分け出力で使用するファイルの概要について説明します。各ファイルの指定内容の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

(a)　仕分け定義ファイル

仕分け定義ファイルには，帳票を仕分けするときのキーワードやキーワードに対応する印刷先などを指定します。

■作成した仕分け定義ファイルの指定方法

  • 印刷ジョブごとに指定する場合

    仕分け定義ファイルは，アプリケーションサーバ（EUR Server - Adapter稼働マシン）の任意のディレクトリに格納します。

    次に示す起動部品に，仕分け定義ファイル名と仕分け定義ファイルを格納したディレクトリのパスを指定します。

    ActiveX起動部品

      SplitFileNameプロパティ，およびSplitFilePathプロパティ

    Java起動部品

      setSplitFileNameメソッド，およびsetSplitFilePathメソッド

    COBOL起動部品

      SPLITFILENAMEパラメタ，およびSPLITFILEPATHパラメタ

    コマンド起動部品（eurpmcコマンド）

      /splitfオプション，および/splitfpオプション

  • EUR Server Serviceのサービスごとに指定する場合

    仕分け定義ファイルは，環境設定ファイル（EURPM.ini）のPATHセクションのSPLITキーで指定したディレクトリに格納します。

    仕分け定義ファイルのファイル名を，環境設定ファイル（EURPM.ini）のFILEセクションのSPLITキーに指定します。

(b)　印刷先定義ファイル

印刷先定義ファイル（PrintDest.conf）には，帳票の蓄積先やスプールデータの格納ファイル名などの蓄積時に指定する情報を，印刷先として指定します。印刷先を定義しておくことで，蓄積先や格納ファイル名などの情報を印刷データごとに個別に指定できます。印刷データに埋め込むスプールタイトルを指定することもできます。

ページの先頭へ

(3)　起動部品の設定

帳票を蓄積仕分け出力するために設定する起動部品のメソッド，関数，およびオプションの指定値を次に示します。

  • ActiveX起動部品：PrintPMReportメソッド

  • Java起動部品：printReportメソッド

  • COBOL起動部品：PrintReport関数またはPrintReport2関数

  • コマンド起動部品（eurpmcコマンド）：/mオプションにprintを指定

また，蓄積時に設定する起動部品のプロパティ，メソッド，パラメタ，およびオプションの指定値を次に示します。

分割/仕分けの設定 | 起動部品の設定項目 | 設定する値
分割/仕分けの実行 | ActiveX起動部品：SplitModeプロパティ Java起動部品：setSplitModeメソッド COBOL起動部品：SPLITMODEパラメタ | 0（EUR Server Serviceの環境設定ファイルの設定に従う） 2（仕分けする）
 | コマンド起動部品：/splitオプション | default（EUR Server Serviceの環境設定ファイルの設定に従う） key（仕分けする）

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 104 / 218


6.1.4 コーディング例 : EUR 帳票出力 機能解説 EUR Server編

  • 105 / 218

  • 表紙

  • 6.　仕分け・分割・統合して出力する

  • 6.1　仕分けして出力するには

  • 6.1.4　コーディング例

6.1.4　コーディング例

次に示すパラメタを指定して，仕分けした印刷データをスプールサーバに蓄積します。

■入力ファイル（印刷定義ファイル）：EUR Server Service稼働マシンに配置

帳票ファイル名：Report1.fms

■入力ファイル（ユーザデータファイル）：EUR Server - Adapter稼働マシンに配置

マッピングデータファイルのパス：c:\Temp

マッピングデータファイル名：Report1_1000P.csv

仕分け定義ファイルのパス：c:\Temp

仕分け定義ファイル名：PMDistribute.txt

コーディング例を次に示します。

〈この項の構成〉

  • (1)　コマンド起動部品（eurpmcコマンド）を使用する場合

  • (2)　ActiveX起動部品を使用する場合

  • (3)　Java起動部品を使用する場合

  • (4)　COBOL起動部品を使用する場合

(1)　コマンド起動部品（eurpmcコマンド）を使用する場合

EURPMC.exe /m print /mapp "c:\Temp" /splitf "PMDistribute.txt" /splitfp "c:\Temp" /pm spl /split key /alljob /rf Report1.fms /map Report1_1000P.csv

ページの先頭へ

(2)　ActiveX起動部品を使用する場合

<HTML>
<HEAD>
<TITLE>Sample Script of ASP page for EUR Print Manager</TITLE>
</HEAD>
<BODY>
<%
    Server.ScriptTimeOut=100
    On Error Resume Next
    // 変数定義
    dim jobidlist
    dim cnt
    // EURPMオブジェクト生成
    set EURPM = Server.CreateObject("EURPM.Exec")
    // 帳票ファイルの指定
    EURPM.ReportFileName = "Report1.fms"
    // マッピングデータファイルの指定
    EURPM.DataFileName   = "Report1_1000P.csv"
    EURPM.DataFilePath   = "c:\Temp"
    // 仕分け定義ファイルの指定
    EURPM.SplitFileName  = "PMDistribute.txt"
    EURPM.SplitFilePath  = "c:\Temp"
    // そのほかのパラメタの指定
    EURPM.SplitMode = 2
    EURPM.PrintMode = 2
    // 蓄積実行指示
    EURPM.PrintPMReport()

    If Err.Number = 0 Then
        // 複数JobIDの取得
        jobidlist = EURPM.GetJobIDList()
        // 取得したJobIDの表示
        For cnt = 0 To UBound(jobidlist, 1)
            Response.Write(jobidlist(cnt))
            Response.Write("<BR>")
        Next

    Else
       // エラー処理
        errid= Err.Number
        If errid=-301 Then
        End If
    End If
%>
</BODY>
</HTML>

ページの先頭へ

(3)　Java起動部品を使用する場合

import java.util.ArrayList;
import JP.co.Hitachi.soft.EURPM.*;

public class SAMPLE {
    public static void main(String[] args) {
        // 変数定義
        int iCnt = 0;
        EURPMAdapterForJava obj = null;
        ArrayList alJobID = null;

        try {
            // オブジェクト生成
            obj = new EURPMAdapterForJava();

            // 帳票ファイルの指定
            obj.setReportFileName("Report1.fms");
            // マッピングデータファイルの指定
            obj.setDataFileName("Report1_1000P.csv");
            obj.setDataFilePath("c:\\Temp");
            // 仕分け定義ファイルの指定
            obj.setSplitFileName("PMDistribute.txt");
            obj.setSplitFilePath("c:\\Temp");
            // そのほかのパラメタの指定
            obj.setSplitMode(2);
            obj.setPrintMode(2);

            //蓄積実行指示
            obj.printReport();

            // 複数ジョブIDの取得
            alJobID = new ArrayList();
            alJobID = obj.getJobIDList();
            for(iCnt = 0; iCnt < alJobID.size(); iCnt++){
                System.out.println(alJobID.get(iCnt));
            }

        } catch (EURPMException ce) {
            // エラー処理
            int errid;
            errid = ce.getErrorCode();
            if (errid==301) {
            }
        }
    }
}

ページの先頭へ

(4)　COBOL起動部品を使用する場合

     IDENTIFICATION DIVISION.
      PROGRAM-ID.
      EURPMADCTEST.
      ENVIRONMENT DIVISION.
      INPUT-OUTPUT SECTION.
      FILE-CONTROL.
          SELECT INP-FL ASSIGN DATAFILENAME
              ORGANIZATION LINE SEQUENTIAL.
      CONFIGURATION SECTION.
      SPECIAL-NAMES.
          CDECL IS CDECL.
      EXTERNAL-PROGRAM SECTION.
      CALL-CONVENTION.
          'PrintReport2' IS CDECL
      DATA DIVISION.

      FILE SECTION.
      FD INP-FL.
      01 INP-REC                PIC X(512).

      WORKING-STORAGE SECTION.
      01 EURPMPARAM1.
          COPY 'EURPMPARAM1.cbl'.

      01 EURPMPARAMJOBID.
          COPY 'EURPMPARAMJOBID.cbl'.

     *変数定義
      01 RTNCODE                PIC S9(9) BINARY.
      01 IX1                    PIC S9(9) BINARY.
      01 REPNAME                PIC X(256) VALUE SPACE.
      01 MAPNAME                PIC X(256) VALUE SPACE.
      01 MAPPATH                PIC X(256) VALUE SPACE.
      01 SPLITNAME              PIC X(256) VALUE SPACE.
      01 SPLITPATH              PIC X(256) VALUE SPACE.
      01 SPMODE                 PIC S9(9) BINARY.
      01 PRTMODE                PIC S9(9) BINARY.

      PROCEDURE DIVISION.
      MAIN SECTION.
      MAIN-START.
          MOVE ZERO                TO RTNCODE
          MOVE ZERO                TO IX1
     *    帳票ファイルの指定
          MOVE 'Report1.fms'       TO REPNAME
     *    マッピングデータファイルの指定
          MOVE 'Report1_1000P.csv' TO MAPNAME
          MOVE 'C:\Temp'           TO MAPPATH
     *    仕分け定義ファイルの指定
          MOVE 'PMDistribute.txt'  TO SPLITNAME
          MOVE 'C:\Temp'           TO SPLITPATH
     *    そのほかのパラメタの指定
          MOVE  2                  TO SPMODE
          MOVE  2                  TO PRTMODE

          MOVE REPNAME             TO REPORTNAME OF EURPMPARAM1
          MOVE MAPNAME             TO MAPPINGDATA OF EURPMPARAM1
          MOVE MAPPATH             TO MAPPINGDATAPATH OF EURPMPARAM1
          MOVE SPLITNAME           TO SPLITFILENAME OF EURPMPARAM1
          MOVE SPLITPATH           TO SPLITFILEPATH OF EURPMPARAM1
          MOVE SPMODE              TO SPLITMODE OF EURPMPARAM1
          MOVE PRTMODE             TO PRINTMODE OF EURPMPARAM1

     *    蓄積実行指示
          CALL 'PrintReport2' USING BY REFERENCE EURPMPARAM1
                              EURPMPARAMJOBID
                              RETURNING RTNCODE
     *    複数ジョブIDの表示
          PERFORM  VARYING IX1
                   FROM 1
                   BY 1
                   UNTIL IX1 > JOBIDNUM OF EURPMPARAMJOBID
            DISPLAY JOBID OF EURPMPARAMJOBID(IX1)
          END-PERFORM
          STOP RUN.

      MAIN-END.
          EXIT.

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 105 / 218


6.1.5 注意事項 : EUR 帳票出力 機能解説 EUR Server編

  • 106 / 218

  • 表紙

  • 6.　仕分け・分割・統合して出力する

  • 6.1　仕分けして出力するには

  • 6.1.5　注意事項

6.1.5　注意事項

  • 帳票の仕分けキーフィールドの指定は，ページごとにキーフィールドのデータと仕分け情報を比較して，仕分けされます。次のような帳票の場合は，仕分けをするときに注意してください。

    • 1ページ中に仕分けキーフィールドのデータが，複数繰り返して表示されている帳票の場合

      仕分け印刷は，ページ単位に仕分けをします。そのため，1ページに複数の情報があっても，分別して配布することはできません。フィールドのデータごとに分別して配布したい場合は，仕分けをする前に改ページをして，1ページに一つだけ仕分けキーフィールドのデータが表示されるように設計してください。

      1ページ中に仕分けキーフィールドのデータが複数繰り返して表示されている場合は，そのページの最初のデータが仕分けの判定対象になります。

      例えば，1ページに東京と横浜のデータが繰り返して表示されていると，東京には横浜のデータも一緒に配布されますが，横浜には配布されません。

    • 集計ページのある帳票の場合

      集計ページは，前ページの最後のデータを仕分けの判定対象にします。

      例えば，前ページが横浜のデータであれば，集計ページも横浜に配布されます。

      キー集計と総集計の集計ページがある場合，前ページが横浜のデータであれば，総集計の集計ページは横浜だけに配布されます。総集計のデータを配布先すべてに出力する場合は，総集計アイテムをすべてのキー集計の集計ページに貼り付けてください。

  • PDF仕分け出力するときに，出力先のPDF形式ファイルがすでに存在する場合は上書きしないでエラー（KEEU032-E）になります。PDF仕分け出力では，出力先やファイル名に注意してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 106 / 218


6.2 分割して出力するには : EUR 帳票出力 機能解説 EUR Server編

  • 107 / 218

  • 表紙

  • 6.　仕分け・分割・統合して出力する

  • 6.2　分割して出力するには

6.2　分割して出力するには

ここでは，帳票を指定したページ数で分割して出力する方法（分割出力）について説明します。

帳票を分割して出力するには，次の表に示す方法があります。

表6‒2 分割出力の出力方法
出力方法 | 説明 | 参照先
PDF分割出力 | 帳票を指定したページ数で分割してPDF形式ファイルで出力します。 | 6.2.1
PDF暗号化分割出力 | 帳票を指定したページ数で分割して暗号化PDF形式ファイルで出力します。 | 6.2.2
蓄積分割出力 | 帳票の印刷データ（EPF形式ファイル）を，指定したページ数で分割してスプールサーバに蓄積します。 | 6.2.3
〈この節の構成〉

  • 6.2.1　PDF分割出力する

  • 6.2.2　PDF暗号化分割出力する

  • 6.2.3　蓄積分割出力する

  • 6.2.4　コーディング例

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 107 / 218


6.2.1 PDF分割出力する : EUR 帳票出力 機能解説 EUR Server編

  • 108 / 218

  • 表紙

  • 6.　仕分け・分割・統合して出力する

  • 6.2　分割して出力するには

  • 6.2.1　PDF分割出力する

6.2.1　PDF分割出力する

ここでは，帳票を指定したページ数で分割してPDF形式ファイルに出力する方法（PDF分割出力）について説明します。PDF分割出力することで，プリンタの用紙カセットの給紙枚数など，ユーザの扱いやすい単位で印刷データを分割して，プリンタやPDF形式ファイルに出力できます。また，出力するPDF形式ファイルのサイズが上限の2GBを超える場合，上限を超えないページ数でPDF分割出力することで出力できるようになります。

なお，帳票をPDF分割出力するには，EUR Server Standard，またはEUR Server Enterpriseが必要です。

〈この項の構成〉

  • (1)　出力の流れ

  • (2)　起動部品の設定

  • (3)　分割結果ファイル

(1)　出力の流れ

帳票をPDF分割出力する流れを次の図に示します。

図6‒4　帳票をPDF分割出力する流れ

[図データ]

  1. 出力要求

    帳票の出力要求が業務プログラムに送られます。

  2. 転送

    EUR Server - Adapterは，ユーザデータファイルを帳票サーバのEUR Server Serviceに転送します。

  3. 印刷データ生成

    転送されたユーザデータファイルと，あらかじめ帳票サーバに配置しておいた印刷定義ファイルから，印刷データ（PDF形式ファイル）が生成されます。

    また，印刷データは，EUR Server - Adapterの起動部品で指定した分割ページ数で分割されて生成されます。

  4. 印刷データ転送

    業務アプリケーションの機能を使って，印刷データ（PDF形式ファイル）をEUR Server Service稼働マシンからEUR Server - Adapter稼働マシンに転送します。

    EUR Server - Adapterの起動部品で分割結果ファイルの設定をしている場合は，PDF形式ファイルを分割した情報が分割結果ファイルに出力されます。

  5. 出力

    アプリケーションサーバからクライアントPCに印刷データ（PDF形式ファイル）をダウンロードすることで，クライアントPCのAdobe Readerを使用してプリンタに出力したり，プレビューしたりできます。

■注意

PDF形式ファイルを分割して出力する場合，PDF形式ファイルはEUR Server Service稼働マシンに出力されます。出力先のフォルダは，EUR Print Serviceの環境変数（EURPS_OUTPUTPATH）の設定に依存します。EUR Print Serviceの環境変数（EURPS_OUTPUTPATH）については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

(2)　起動部品の設定

PDF形式ファイルの出力で使用する起動部品のメソッド，関数，およびオプションの指定値を次に示します。

  • ActiveX起動部品：OutputPDFReportメソッド

  • Java起動部品：outputPDFReportメソッド

  • COBOL起動部品：OutputPDFReport関数

  • コマンド起動部品（eurpmcコマンド）：/mオプションにpdfを指定

また，PDF分割出力の設定をする起動部品のプロパティ，メソッド，パラメタ，およびオプションの指定値を次に示します。

PDF分割出力の設定 | 起動部品の設定項目 | 設定する値
分割ページ数（必須） | ActiveX起動部品：SplitPageNumberプロパティ Java起動部品：setSplitPageNumberメソッド COBOL起動部品：SPLITPAGENUMBERパラメタ コマンド起動部品：/spnオプション | 1～999,999の数値※1
分割ファイル名（必須）※2 | ActiveX起動部品：OutputSplitFileNameプロパティ Java起動部品：setOutputSplitFileNameメソッド COBOL起動部品：OUTPUTSPLITFILENAMEパラメタ コマンド起動部品：/osfnオプション | 200バイト以内の文字列※3
分割結果ファイル名（任意） | ActiveX起動部品：SplitResultFileNameプロパティ Java起動部品：setSplitResultFileNameメソッド COBOL起動部品：SPLITRESULTFILENAMEパラメタ コマンド起動部品：/srfnオプション | 255バイト以内の文字列
分割結果ファイルのパス（任意） | ActiveX起動部品：SplitResultFilePathプロパティ Java起動部品：SplitResultFilePathプロパティ COBOL起動部品：SPLITRESULTFILEPATHパラメタ コマンド起動部品：/srfpオプション | 255バイト以内の文字列
注※1

COBOL起動部品で分割ページ数を設定しないときは「0」を指定します。

注※2

分割ファイルの出力先のフォルダは，環境設定ファイル（EURPS_ENV）の環境変数EURPS_OUTPUTPATHキーで指定します。出力先のフォルダは，EUR Server Service稼働マシンのパスとなるため，EUR Server - Adapter稼働マシンのパスで取得したい場合は，共有フォルダを使用するなどの運用としてください。

注※3

分割ファイル名の書式を次に示します。

  • ファイル名だけを拡張子（.pdf）を含めて指定します。

  • ファイル名には必ず「%Nd」の文字列を含めて指定してください。Nには通番の桁数（1～9）を指定します。「%Nd」を指定すると，Nに指定された桁数で前0を付加した通し番号が自動的に設定されます。

  • ファイル名に「%」を使用したい場合は「%%」と指定します。

ページの先頭へ

(3)　分割結果ファイル

EUR Server - Adapterの起動部品で分割結果ファイルの設定をしている場合，PDF形式ファイルを分割した情報が，分割結果ファイルに出力されます。分割結果ファイルのファイル形式はテキストファイルです。

なお，分割結果ファイルのエンコーディングは「UTF-16（BOMあり）」です。

(a)　出力形式

分割結果ファイルの出力形式を次に示します。

分割数▼
分割したPDF形式ファイルの出力先のパス▼
分割したPDF形式ファイルのファイル名▼
〔分割したPDF形式ファイルのファイル名▼〕
  ：
（凡例）

▼：Windows環境の場合，改行コード（0x0d+0x0a）を示します。UNIX／Linux環境の場合，改行コード（0x0a）を示します。

(b)　出力項目

分割結果ファイルの出力される項目を次の表に示します。

表6‒3 分割結果ファイルの出力項目
出力項目 | 内容
分割数 | PDF形式ファイルの分割数が出力されます。
分割したPDF形式ファイルの出力先のパス | 分割したPDF形式ファイルの出力先のパスが出力されます。
分割したPDF形式ファイルのファイル名 | 分割したPDF形式ファイルのファイル名が，分割数分出力されます。

(c)　出力例

PDF形式ファイルの出力で出力ページ数が5ページとなる帳票で，分割ページ数に2を指定したときのPDF分割出力の出力例を次に示します。

■PDF分割出力の指定例

  • 分割ページ数：2

  • 分割ファイル名：split_pdf_%3d.pdf

■分割結果ファイルの出力例

3
C:\EUR\
split_pdf_001.pdf
split_pdf_002.pdf
split_pdf_003.pdf

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 108 / 218


6.2.2 PDF暗号化分割出力する : EUR 帳票出力 機能解説 EUR Server編

  • 109 / 218

  • 表紙

  • 6.　仕分け・分割・統合して出力する

  • 6.2　分割して出力するには

  • 6.2.2　PDF暗号化分割出力する

6.2.2　PDF暗号化分割出力する

ここでは，帳票を指定したページ数で分割して暗号化PDF形式ファイルで出力する方法（PDF暗号化分割出力）について説明します。

なお，帳票をPDF暗号化分割出力するには，EUR Server Standard，またはEUR Server Enterpriseが必要です。

〈この項の構成〉

  • (1)　出力の流れ

  • (2)　出力で使用するファイル

  • (3)　起動部品の設定

  • (4)　分割結果ファイル

(1)　出力の流れ

帳票をPDF暗号化分割出力する流れを次の図に示します。

図6‒5　帳票をPDF暗号化分割出力する流れ

[図データ]

  1. 出力要求

    帳票の出力要求が業務プログラムに送られます。

  2. 転送

    EUR Server - Adapterは，ユーザデータファイルを帳票サーバのEUR Server Serviceに転送します。

  3. 印刷データ生成

    転送されたユーザデータファイルと，あらかじめ帳票サーバに配置しておいた印刷定義ファイルから，印刷データ（暗号化PDF形式ファイル）が生成されます。

    また，印刷データは，EUR Server Adapterの起動部品で指定した分割ページ数で分割されて生成されます。

    なお，暗号化PDF形式ファイルを生成する場合は，EUR Server - Cipher optionが必要です。

  4. 印刷データ転送

    業務アプリケーションの機能を使って，印刷データ（暗号化PDF形式ファイル）をEUR Server Service稼働マシンからEUR Server - Adapter稼働マシンに転送します。

    EUR Server - Adapterの起動部品で分割結果ファイルの設定をしている場合は，暗号化PDF形式ファイルを分割した情報が分割結果ファイルに出力されます。

  5. 出力

    アプリケーションサーバからクライアントPCに印刷データ（暗号化PDF形式ファイル）をダウンロードすることで，クライアントPCのAdobe Readerを使用してプリンタに出力したり，プレビューしたりできます。

■注意

暗号化PDF形式ファイルを分割して出力する場合，暗号化PDF形式ファイルはEUR Server Service稼働マシンに出力されます。出力先のフォルダは，EUR Print Serviceの環境変数（EURPS_OUTPUTPATH）の設定に依存します。EUR Print Serviceの環境変数（EURPS_OUTPUTPATH）については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

(2)　出力で使用するファイル

PDF暗号化分割出力で使用するファイルの概要について説明します。各ファイルの指定内容の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

(a)　暗号化設定ファイル

PDF形式ファイルを暗号化するセキュリティ属性を指定します。暗号化設定ファイルに指定する項目を次に示します。

  • ユーザパスワード（PDF形式ファイルを閲覧するためのパスワード）

  • オーナパスワード（セキュリティ属性を変更するパスワード）

  • 印刷

  • 文書の変更

  • 内容のコピー，または抽出

  • 注釈とフォームフィールドの作成

なお，ユーザパスワードとオーナパスワードには，暗号化したパスワードも指定できます。パスワードの暗号化については，「4.1.2(3)　パスワードの暗号化」を参照してください。

■PDF形式ファイルを暗号化分割出力する場合の指定例

分割したファイルに，次の設定をするときの指定例です。

  • PDF形式ファイルを閲覧するとき，パスワードの入力を求めます。

  • PDF形式ファイルの印刷を禁止します。

暗号化設定ファイル（cipher.txt）の定義内容
OwnerPassword=OWNER
DisablePrint=Yes

PDF暗号化分割出力で分割出力したファイルを開こうとすると，パスワードの入力を求められます。

また，ファイルを開くと，［文書のセキュリティ］ダイアログには次のように表示されます。

ユーザパスワード：はい

オーナパスワード：はい

印刷　　　　　　：許可しない

なお，お使いのAdobe Readerのバージョンによっては，表示内容が異なる場合があります。

暗号化設定ファイルの指定内容の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

(3)　起動部品の設定

PDF暗号化分割出力で使用する起動部品の設定は，PDF分割出力で使用する起動部品の設定と同じです。PDF分割出力で使用する起動部品の設定については，「6.2.1(2)　起動部品の設定」を参照してください。

ページの先頭へ

(4)　分割結果ファイル

分割結果ファイルについては，「6.2.1(3)　分割結果ファイル」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 109 / 218


6.2.3 蓄積分割出力する : EUR 帳票出力 機能解説 EUR Server編

  • 110 / 218

  • 表紙

  • 6.　仕分け・分割・統合して出力する

  • 6.2　分割して出力するには

  • 6.2.3　蓄積分割出力する

6.2.3　蓄積分割出力する

ここでは，帳票を指定したページ数で蓄積分割出力する方法について説明します。蓄積分割出力することで，プリンタの用紙カセットの給紙枚数など，ユーザの扱いやすい単位で印刷データを操作できます。ページ数の多い帳票や印刷データ量の大きい帳票を印刷したいときに便利です。また，分割後の帳票（EPF形式の印刷データ）は，スプールデータとして出力されます。スプールデータには，それぞれ異なる印刷先を設定できます。

なお，帳票を蓄積分割出力するには，EUR Server Enterpriseが必要です。

〈この項の構成〉

  • (1)　出力の流れ

  • (2)　出力で使用するファイル

  • (3)　起動部品の設定

(1)　出力の流れ

帳票を指定したページ数で蓄積分割出力する流れを次の図に示します。

図6‒6　帳票を蓄積分割出力する流れ

[図データ]

  1. 出力要求

    帳票の出力要求が業務プログラムに送られます。

  2. 転送

    EUR Server - Adapterは，ユーザデータファイルを帳票サーバのEUR Server Serviceに転送します。

  3. 印刷データ生成

    転送されたユーザデータファイルと，あらかじめ帳票サーバに配置しておいた印刷定義ファイル，印刷先定義ファイルなどの定義ファイルから，印刷データ（EPF形式ファイル）が生成されます。

    なお，印刷データは，分割定義ファイルで設定したページ数で分割されて生成されます。

  4. 印刷データ転送

    EUR Server Serviceは，生成された印刷データ（EPF形式ファイル）をスプールサーバのEUR Server - Spool Serviceに転送します。

  5. 蓄積

    EUR Server - Spool Serviceが印刷データ（EPF形式ファイル）を受信すると，スプールサーバ内に印刷データが蓄積されます。このとき，属性情報が付けられてスプールデータとなります。スプールデータは，手順3.で生成された印刷データの数だけ生成されます。

  6. 出力

    スプールデータの属性情報に従って，スプールサーバのプリンタ，またはクライアントPCのプリンタで出力されます。

■注意

スプールサーバのプリンタに出力するには，スプールサーバにWindows版のEUR Server - Spool Serviceが必要です。スプールサーバがUNIX／Linux環境の場合は，スプールサーバのプリンタへの出力はできません。

ページの先頭へ

(2)　出力で使用するファイル

蓄積分割出力で使用するファイルを次に示します。

(a)　分割定義ファイル

分割定義ファイルには，帳票を分割するときのページ数や分割後の印刷データの印刷先などを指定します。

■印刷先が複数ある場合の印刷データの配布方法

印刷先が複数ある場合の印刷データの配布方法には，次の2種類があります。

  • ページ方式

    各印刷先で帳票のページ番号が連続するように，印刷データを配布する方法です。ページ方式で配布するときは，分割定義ファイルのDISTRIBUTEMETHODキーに「PAGE」を指定してください。

    ページ方式で配布するときの配布イメージを次の図に示します。

  • 順次方式

    分割された順に印刷データを配布する方法です。順次方式で配布するときは，分割定義ファイルのDISTRIBUTEMETHODキーに「ORDER」を指定してください。

    順次方式で配布するときの配布イメージを次の図に示します。

■作成した分割定義ファイルの指定方法

  • 印刷ジョブごとに指定する場合

    分割定義ファイルは，アプリケーションサーバ（EUR Server - Adapter稼働マシン）の任意のディレクトリに格納します。

    次に示す起動部品に，分割定義ファイル名と分割定義ファイルを格納したディレクトリのパスを指定します。

    ActiveX起動部品

      SplitFileNameプロパティ，およびSplitFilePathプロパティ

    Java起動部品

      setSplitFileNameメソッド，およびsetSplitFilePathメソッド

    COBOL起動部品

      SPLITFILENAMEパラメタ，およびSPLITFILEPATHパラメタ

    コマンド起動部品（eurpmcコマンド）

      /splitfオプション，および/splitfpオプション

  • EUR Server Serviceのサービスごとに指定する場合

    分割定義ファイルは，環境設定ファイル（EURPM.ini）のPATHセクションのSPLITキーで指定したディレクトリに格納します。

    分割定義ファイルのファイル名を，環境設定ファイル（EURPM.ini）のFILEセクションのSPLITキーに指定します。

(b)　印刷先定義ファイル

帳票を蓄積仕分け出力する場合と同じです。詳細については，「6.1.3(2)(b)　印刷先定義ファイル」を参照してください。

ページの先頭へ

(3)　起動部品の設定

帳票を蓄積分割出力するために設定する起動部品のメソッド，関数，およびオプションの指定値を次に示します。

  • ActiveX起動部品：PrintPMReportメソッド

  • Java起動部品：printReportメソッド

  • COBOL起動部品：PrintReport関数またはPrintReport2関数

  • コマンド起動部品（eurpmcコマンド）：/mオプションにprintを指定

また，蓄積時に設定する起動部品のプロパティ，メソッド，パラメタ，およびオプションの指定値を次に示します。

分割/仕分けの設定 | 起動部品の設定項目 | 設定する値
分割/仕分けの実行 | ActiveX起動部品：SplitModeプロパティ Java起動部品：setSplitModeメソッド COBOL起動部品：SPLITMODEパラメタ | 0（EUR Server Serviceの環境設定ファイルの設定に従う） 3（分割する）
 | コマンド起動部品：/splitオプション | default（EUR Server Serviceの環境設定ファイルの設定に従う） page（分割する）

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 110 / 218


6.2.4 コーディング例 : EUR 帳票出力 機能解説 EUR Server編

  • 111 / 218

  • 表紙

  • 6.　仕分け・分割・統合して出力する

  • 6.2　分割して出力するには

  • 6.2.4　コーディング例

6.2.4　コーディング例

次に示すパラメタを指定して，分割した印刷データをスプールサーバに蓄積します。

■入力ファイル（印刷定義ファイル）：EUR Server Service稼働マシンに配置

帳票ファイル名：Report1.fms

■入力ファイル（ユーザデータファイル）：EUR Server - Adapter稼働マシンに配置

マッピングデータファイルのパス：c:\Temp

マッピングデータファイル名：Report1_1000P.csv

分割定義ファイルのパス：c:\Temp

分割定義ファイル名：PMPageSplit.txt

コーディング例を次に示します。

〈この項の構成〉

  • (1)　コマンド起動部品（eurpmcコマンド）を使用する場合

  • (2)　ActiveX起動部品を使用する場合

  • (3)　Java起動部品を使用する場合

  • (4)　COBOL起動部品を使用する場合

(1)　コマンド起動部品（eurpmcコマンド）を使用する場合

EURPMC.exe /m print /mapp "c:\Temp" /splitf "PMPageSplit.txt" /splitfp "c:\Temp" /pm spl /split page /alljob /rf Report1.fms /map Report1_1000P.csv

ページの先頭へ

(2)　ActiveX起動部品を使用する場合

<HTML>
<HEAD>
<TITLE>Sample Script of ASP page for EUR Print Manager</TITLE>
</HEAD>
<BODY>
<%
    Server.ScriptTimeOut=100
    On Error Resume Next
    // 変数定義
    dim jobidlist
    dim cnt
    // EURPMオブジェクト生成
    set EURPM = Server.CreateObject("EURPM.Exec")
    // 帳票ファイルの指定
    EURPM.ReportFileName = "Report1.fms"
    // マッピングデータファイルの指定
    EURPM.DataFileName   = "Report1_1000P.csv"
    EURPM.DataFilePath   = "c:\Temp"
    // 分割定義ファイルの指定
    EURPM.SplitFileName  = "PMPageSplit.txt"
    EURPM.SplitFilePath  = "c:\Temp"
    // そのほかのパラメタの指定
    EURPM.SplitMode = 3
    EURPM.PrintMode = 2
    // 蓄積実行指示
    EURPM.PrintPMReport()

    If Err.Number = 0 Then
        // 複数JobIDの取得
        jobidlist = EURPM.GetJobIDList()
        // 取得したJobIDの表示
        For cnt = 0 To UBound(jobidlist, 1)
            Response.Write(jobidlist(cnt))
            Response.Write("<BR>")
        Next

    Else
       // エラー処理
        errid= Err.Number
        If errid=-301 Then
        End If
    End If
%>
</BODY>
</HTML>

ページの先頭へ

(3)　Java起動部品を使用する場合

import java.util.ArrayList;
import JP.co.Hitachi.soft.EURPM.*;

public class SAMPLE {
    public static void main(String[] args) {
        // 変数定義
        int iCnt = 0;
        EURPMAdapterForJava obj = null;
        ArrayList alJobID = null;

        try {
            // オブジェクト生成
            obj = new EURPMAdapterForJava();

            // 帳票ファイルの指定
            obj.setReportFileName("Report1.fms");
            // マッピングデータファイルの指定
            obj.setDataFileName("Report1_1000P.csv");
            obj.setDataFilePath("c:\\Temp");
            // 分割定義ファイルの指定
            obj.setSplitFileName("PMPageSplit.txt");
            obj.setSplitFilePath("c:\\Temp");
            // そのほかのパラメタの指定
            obj.setSplitMode(3);
            obj.setPrintMode(2);

            //蓄積実行指示
            obj.printReport();

            // 複数ジョブIDの取得
            alJobID = new ArrayList();
            alJobID = obj.getJobIDList();
            for(iCnt = 0; iCnt < alJobID.size(); iCnt++){
                System.out.println(alJobID.get(iCnt));
            }

        } catch (EURPMException ce) {
            // エラー処理
            int errid;
            errid = ce.getErrorCode();
            if (errid==301) {
            }
        }
    }
}

ページの先頭へ

(4)　COBOL起動部品を使用する場合

      IDENTIFICATION DIVISION.
      PROGRAM-ID.
      EURPMADCTEST.
      ENVIRONMENT DIVISION.
      INPUT-OUTPUT SECTION.
      FILE-CONTROL.
          SELECT INP-FL ASSIGN DATAFILENAME
              ORGANIZATION LINE SEQUENTIAL.
      CONFIGURATION SECTION.
      SPECIAL-NAMES.
          CDECL IS CDECL.
      EXTERNAL-PROGRAM SECTION.
      CALL-CONVENTION.
          'PrintReport2' IS CDECL
      DATA DIVISION.

      FILE SECTION.
      FD INP-FL.
      01 INP-REC                PIC X(512).

      WORKING-STORAGE SECTION.
      01 EURPMPARAM1.
          COPY 'EURPMPARAM1.cbl'.

      01 EURPMPARAMJOBID.
          COPY 'EURPMPARAMJOBID.cbl'.

     *変数定義
      01 RTNCODE                PIC S9(9) BINARY.
      01 IX1                    PIC S9(9) BINARY.
      01 REPNAME                PIC X(256) VALUE SPACE.
      01 MAPNAME                PIC X(256) VALUE SPACE.
      01 MAPPATH                PIC X(256) VALUE SPACE.
      01 SPLITNAME              PIC X(256) VALUE SPACE.
      01 SPLITPATH              PIC X(256) VALUE SPACE.
      01 SPMODE                 PIC S9(9) BINARY.
      01 PRTMODE                PIC S9(9) BINARY.

      PROCEDURE DIVISION.
      MAIN SECTION.
      MAIN-START.
          MOVE ZERO                TO RTNCODE
          MOVE ZERO                TO IX1
     *    帳票ファイルの指定
          MOVE 'Report1.fms'        TO REPNAME
     *    マッピングデータファイルの指定
          MOVE 'Report1_1000P.csv'  TO MAPNAME
          MOVE 'C:\Temp'            TO MAPPATH
     *    分割定義ファイルの指定
          MOVE PMPageSplit.txt'     TO SPLITNAME
          MOVE 'C:\Temp'            TO SPLITPATH
     *    そのほかのパラメタの指定
          MOVE  3                  TO SPMODE
          MOVE  2                  TO PRTMODE

          MOVE REPNAME             TO REPORTNAME OF EURPMPARAM1
          MOVE MAPNAME             TO MAPPINGDATA OF EURPMPARAM1
          MOVE MAPPATH             TO MAPPINGDATAPATH OF EURPMPARAM1
          MOVE SPLITNAME           TO SPLITFILENAME OF EURPMPARAM1
          MOVE SPLITPATH           TO SPLITFILEPATH OF EURPMPARAM1
          MOVE SPMODE              TO SPLITMODE OF EURPMPARAM1
          MOVE PRTMODE             TO PRINTMODE OF EURPMPARAM1

     *    蓄積実行指示
          CALL 'PrintReport2' USING BY REFERENCE EURPMPARAM1
                              EURPMPARAMJOBID
                              RETURNING RTNCODE
     *    複数ジョブIDの表示
          PERFORM  VARYING IX1
                   FROM 1
                   BY 1
                   UNTIL IX1 > JOBIDNUM OF EURPMPARAMJOBID
            DISPLAY JOBID OF EURPMPARAMJOBID(IX1)
          END-PERFORM
          STOP RUN.

      MAIN-END.
          EXIT.

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 111 / 218


6.3 統合して出力するには : EUR 帳票出力 機能解説 EUR Server編

  • 112 / 218

  • 表紙

  • 6.　仕分け・分割・統合して出力する

  • 6.3　統合して出力するには

6.3　統合して出力するには

ここでは，複数の帳票を統合して出力する方法（統合出力）について説明します。複数の帳票を一つに統合して出力することで，ほかのユーザが出力した帳票と混在してしまうのを防げます。また，複数の帳票を同じ出力先に出力したい場合に，出力先のプリンタやトレイを何度も指定したり確認したりする手間を省けます。

帳票を統合して出力するには，次の表に示す方法があります。

表6‒4 統合出力の出力方法
出力方法 | 説明 | 参照先
EPF形式ファイルの統合出力 | 複数のEPF形式ファイルを一つのEPF形式ファイルに統合して出力します。 | 6.3.1
スプールデータの統合出力 | 複数のスプールデータの印刷データ（EPF形式ファイル）を一つのEPF形式ファイルに統合して出力します。 | 6.3.2
■注意

多数の帳票を統合すると，出力処理に時間が掛かります。

〈この節の構成〉

  • 6.3.1　複数のEPF形式ファイルを統合出力する

  • 6.3.2　複数のスプールデータを統合出力する

  • 6.3.3　コーディング例

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 112 / 218


6.3.1 複数のEPF形式ファイルを統合出力する : EUR 帳票出力 機能解説 EUR Server編

  • 113 / 218

  • 表紙

  • 6.　仕分け・分割・統合して出力する

  • 6.3　統合して出力するには

  • 6.3.1　複数のEPF形式ファイルを統合出力する

6.3.1　複数のEPF形式ファイルを統合出力する

ここでは，複数のEPF形式ファイルを統合出力する方法について説明します。

〈この項の構成〉

  • (1)　出力条件

  • (2)　出力の流れ

  • (3)　起動部品の設定

  • (4)　統合後の属性情報

(1)　出力条件

複数のEPF形式ファイルを統合して出力するには，次の条件をすべて満たす必要があります。

  • 統合対象のEPF形式ファイルの数が，2～10,000ファイルであること。

  • 統合対象のEPF形式ファイルの合計ページ数が，999,999ページ以下であること。

  • 統合対象のEPF形式ファイルを，印刷用のデータ形式に変換したときのファイルサイズの合計が，2GB以下であること。

  • 統合対象のEPF形式ファイルが，EUR Server - Adapterの稼働するマシンにすべて存在していること。

  • 統合対象のすべてのEPF形式ファイルにアクセスできること。

  • 統合対象のすべてのEPF形式ファイルで，印刷データの解像度（DPI値）が同じであること。

ページの先頭へ

(2)　出力の流れ

複数のEPF形式ファイルを統合出力する流れを次の図に示します。

図6‒7　複数のEPF形式ファイルを統合出力する流れ

[図データ]

  1. 出力要求

    帳票の出力要求が業務プログラムに送られます。

  2. 転送

    EUR Server - Adapterは，統合対象のEPF形式ファイルを帳票サーバのEUR Server Serviceに転送します。

  3. ファイル統合

    EUR Server Serviceは，転送されたEPF形式ファイルを統合し，印刷データ（EPF形式ファイル）を生成します。

  4. 印刷データ転送

    EUR Server Serviceは，生成された印刷データ（EPF形式ファイル）をEUR Server - Adapterに転送します。

    転送された印刷データは，クライアントPCに配布したり，Webブラウザからダウンロードしたりすることで，クライアントPCのプリンタに出力したり，クライアントPCでプレビューしたりできます。

ページの先頭へ

(3)　起動部品の設定

複数のEPF形式ファイルの統合出力で使用する起動部品のメソッド，関数，およびオプションの指定値を次に示します。

  • ActiveX起動部品：OutputMergeEPFReportメソッド

  • Java起動部品：outputMergeEPFReportメソッド

  • COBOL起動部品：OutputMergeEPFReport関数

  • コマンド起動部品（eurpmcコマンド）：/mオプションにmergeを指定

また，出力時に設定する起動部品のプロパティ，メソッド，パラメタ，およびオプションの指定値を次に示します。

  1. 統合対象EPF形式ファイルの設定

    統合対象EPF形式ファイル名を設定します。

    統合対象EPF形式ファイルの設定

    起動部品の設定項目

    設定する値

    統合対象EPF形式ファイル名

    ActiveX起動部品：MergeEPFFileNameプロパティ

    Java起動部品：setMergeEPFFileNameメソッド

    COBOL起動部品：MERGEEPFFILENAMEパラメタ

    コマンド起動部品：/mepfnオプション

    統合対象EPF形式ファイル名（255バイト以内の文字列）

  2. 出力EPF形式ファイルの設定

    出力EPF形式ファイル名を設定します。

    出力EPF形式ファイルの設定

    起動部品の設定項目

    設定する値

    出力EPF形式ファイル名

    ActiveX起動部品：EPFFileNameプロパティ

    Java起動部品：setEPFFileNameメソッド

    COBOL起動部品：EPFFILENAMEパラメタ

    コマンド起動部品：/epfnオプション

    出力EPF形式ファイル名（255バイト以内の文字列）

  3. 印刷付加情報の設定

    必要に応じて，印刷付加情報（印刷部数，用紙の向き，プリンタクラス名など）を設定します。

ページの先頭へ

(4)　統合後の属性情報

統合後のEPF形式ファイルの属性情報を次の表に示します。

表6‒5 統合後のEPF形式ファイルの属性情報（EPF形式ファイルの統合）
EPF形式ファイルの属性 | 統合時の指定可否 | 統合後に設定される値
 |  | 統合時に指定あり | 統合時に指定なし
印刷部数 | ○ | 指定値 | 1
印刷部数の単位 | ○ | 指定値 | 0（部単位）
用紙の向き | ○ | 指定値 | 未指定（統合するEPF形式ファイルのページごとの属性で出力）
スプールタイトル | ○ | 指定値 | 未指定（印刷時は最初に指定するEPF形式ファイルの帳票ファイル名を出力）
プリンタクラス名 | ○ | 指定値 | 未指定
EUR Print Serviceのバージョン | × | － | 統合するEPF形式ファイルの最新バージョン
印刷データを作成したプログラムのバージョン | × | － | 統合するEPF形式ファイルの最新バージョン
ジョブID | × | － | 最初に指定するEPF形式ファイルの属性値
総ページ数 | × | － | 統合するEPF形式ファイルのページ数の総和
印刷日時書式 | × | － | 最初に指定するEPF形式ファイルの属性値
印刷日時フォント名 | × | － | 最初に指定するEPF形式ファイルの属性値
印刷日時フォントサイズ | × | － | 最初に指定するEPF形式ファイルの属性値
印刷日時出力位置 | × | － | 最初に指定するEPF形式ファイルの属性値
印刷日時フォント色 | × | － | 最初に指定するEPF形式ファイルの属性値
（凡例）

○：指定できます。

×：指定できません。

－：該当しません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 113 / 218


6.3.2 複数のスプールデータを統合出力する : EUR 帳票出力 機能解説 EUR Server編

  • 114 / 218

  • 表紙

  • 6.　仕分け・分割・統合して出力する

  • 6.3　統合して出力するには

  • 6.3.2　複数のスプールデータを統合出力する

6.3.2　複数のスプールデータを統合出力する

ここでは，複数のスプールデータを統合出力する方法について説明します。なお，複数のスプールデータを統合出力するには，EUR Server Enterpriseが必要です。

〈この項の構成〉

  • (1)　出力条件

  • (2)　出力の流れ

  • (3)　起動部品の設定

  • (4)　統合後の属性情報

(1)　出力条件

複数のスプールデータの印刷データを統合して，EPF形式ファイルとして出力するには，次の条件をすべて満たす必要があります。

  • 統合対象のスプールデータの数が，2～10,000個であること。

  • 統合対象のスプールデータに格納されている印刷データの合計ページ数が，999,999ページ以下であること。

  • 統合対象のスプールデータに格納されている印刷データのファイルサイズの合計が2GB以下であること。

  • 統合対象のすべてのスプールデータに格納されている印刷データの解像度（DPI値）がすべて同じであること。

  • 統合対象のスプールデータが，すべて存在していること。

  • 統合対象のすべてのスプールデータにアクセスできること。

  • 統合対象のスプールデータの取得可否が，すべて「取得可能」に設定されていること。

ページの先頭へ

(2)　出力の流れ

複数のスプールデータを統合出力する流れを次の図に示します。

図6‒8　複数のスプールデータを統合出力する流れ

[図データ]

  1. 出力要求

    帳票の出力要求が業務プログラムに送られます。

  2. 統合対象スプールデータの指示

    EUR Server - Spool Service Adapterは，統合対象のスプールデータのジョブIDをスプールサーバのEUR Server - Spool Serviceに指示します。

  3. ファイル統合

    EUR Server - Spool Serviceは，指示されたジョブIDに該当するスプールデータから，印刷データ（EPF形式ファイル）を取得して統合します。

  4. 出力

    統合された印刷データは，スプールサーバのプリンタに出力できます。

    また，統合した印刷データをアプリケーションサーバの任意のフォルダやメモリに出力し，クライアントPCに配布したり，Webブラウザからダウンロードしたりすることで，クライアントPCのプリンタに出力したり，クライアントPCでプレビューしたりできます。

■注意

スプールサーバのプリンタに出力するには，スプールサーバにWindows版のEUR Server - Spool Serviceが必要です。スプールサーバがUNIX／Linux環境の場合は，スプールサーバのプリンタへの出力はできません。

ページの先頭へ

(3)　起動部品の設定

(a)　統合出力したスプールデータをファイル取得する場合

複数のスプールデータの統合出力（ファイル取得）で使用する起動部品のメソッドおよびオプションの指定値を次に示します。

  • SS-ActiveX起動部品：GetSpoolFileメソッド

  • SS-Java起動部品：getSpoolFileメソッド

  • SS-コマンド起動部品（eurpmlscコマンド）：/mオプションにgetを指定

また，出力時に設定する起動部品のプロパティ，メソッド，およびオプションの指定値を次に示します。

  1. 統合対象スプールデータの設定

    統合対象のスプールデータを設定します。

    統合対象スプールデータの設定

    起動部品の設定項目

    設定する値

    スプールデータのジョブID

    SS-ActiveX起動部品：SearchJobIDプロパティ

    SS-Java起動部品：setSearchJobIDメソッド，またはsetSearchJobIDMultiメソッド

    SS-コマンド起動部品：/idオプション

    ジョブID（36バイト以内の文字列）

    蓄積先のスプールサーバのIPアドレス

    SS-ActiveX起動部品：ServerAddressプロパティ

    SS-Java起動部品：setServerAddressメソッド

    SS-コマンド起動部品：/svrオプション

    255.255.255.255形式

  2. 出力EPF形式ファイルの設定

    統合した印刷データをアプリケーションサーバの任意のフォルダに出力する場合，出力EPF形式ファイル名を設定します。

    出力EPF形式ファイルの設定

    起動部品の設定項目

    設定する値

    出力ファイル名

    SS-ActiveX起動部品：OutputFileNameプロパティ

    SS-Java起動部品：setOutputFileNameメソッド

    SS-コマンド起動部品：/ofnオプション

    出力ファイル名（255バイト以内の文字列）

    EPF形式ファイルを取得するフォルダ

    SS-ActiveX起動部品：OutputFilePathプロパティ

    SS-Java起動部品：setOutputFilePathメソッド

    SS-コマンド起動部品：/oオプション

    取得するフォルダのパス（255バイト以内の文字列）

  3. 印刷付加情報の設定

    必要に応じて，印刷付加情報（印刷部数，用紙の向き，プリンタクラス名など）を設定します。

(b)　統合出力したスプールデータを印刷する場合

複数のスプールデータの統合出力（印刷）で使用する起動部品のメソッドおよびオプションの指定値を次に示します。

  • SS-ActiveX起動部品：PrintSpoolReportメソッド

  • SS-Java起動部品：printSpoolReportメソッド

  • SS-コマンド起動部品（eurpmlscコマンド）：/mオプションにprintを指定

また，出力時に設定する起動部品のプロパティ，メソッド，およびオプションの指定値を次に示します。

  1. 統合対象スプールデータの設定

    統合対象のスプールデータを設定します。

    統合対象スプールデータの設定

    起動部品の設定項目

    設定する値

    スプールデータのジョブID

    SS-ActiveX起動部品：SearchJobIDプロパティ

    SS-Java起動部品：setSearchJobIDメソッド，またはsetSearchJobIDMultiメソッド

    SS-コマンド起動部品：/idオプション

    ジョブID（36バイト以内の文字列）※

    蓄積先のスプールサーバのIPアドレス

    SS-ActiveX起動部品：ServerAddressプロパティ

    SS-Java起動部品：setServerAddressメソッド

    SS-コマンド起動部品：/svrオプション

    255.255.255.255形式
    注※

    統合対象のスプールデータのジョブID（複数）を指定します。ジョブIDを指定した順にスプールデータを統合して印刷します。

  2. 印刷方式の設定

    スプールデータの印刷方法を設定します。

    印刷設定

    起動部品の設定項目

    設定する値

    印刷方法

    SS-ActiveX起動部品：PrintModeプロパティ

    SS-Java起動部品：setPrintModeメソッド

    0（蓄積スプールサーバ印刷）

    SS-コマンド起動部品：/pm

    sv（スプールサーバで印刷する）

  3. 印刷付加情報の設定

    必要に応じて，印刷付加情報（印刷部数，用紙の向き，プリンタクラス名など）を設定します。

ページの先頭へ

(4)　統合後の属性情報

統合後のEPF形式ファイルの属性情報を次の表に示します。

表6‒6 統合後のEPF形式ファイルの属性情報（スプールデータの統合）
EPF形式ファイルの属性 | 統合時の指定可否 | 統合後のEPF形式ファイルに設定される値
 |  | 統合時に指定あり | 統合時に指定なし
 |  |  | スプールデータを一つだけ選択 | スプールデータを複数選択
印刷部数 | ○ | 指定値 | スプールデータの印刷データの属性値 | 1
印刷部数の単位 | ○ | 指定値 | スプールデータの印刷データの属性値 | 0（部単位）
用紙の向き | ○ | 指定値 | スプールデータの印刷データの属性値 | 未指定（印刷データを蓄積したときのページごとの属性で出力）
スプールタイトル | ○ | 指定値 | スプールデータの印刷データの属性値 | 未指定（印刷時は最初に指定するスプールデータに格納された印刷データの帳票ファイル名を出力）
プリンタクラス名 | ○ | 指定値 | スプールデータの印刷データの属性値 | 未指定
EUR Print Serviceのバージョン | × | － | スプールデータの印刷データの属性値 | 統合するスプールデータの印刷データの最新バージョン
印刷データを作成したプログラムのバージョン | × | － | スプールデータの印刷データの属性値 | 統合するスプールデータの印刷データの最新バージョン
ジョブID | × | － | スプールデータの属性値 | 最初に指定するスプールデータの属性値
総ページ数 | × | － | スプールデータの印刷データの属性値 | 統合するスプールデータの印刷データのページ数の総和
印刷日時書式 | × | － | スプールデータの印刷データの属性値 | 最初に指定するスプールデータの印刷データの属性値
印刷日時フォント名 | × | － | スプールデータの印刷データの属性値 | 最初に指定するスプールデータの印刷データの属性値
印刷日時フォントサイズ | × | － | スプールデータの印刷データの属性値 | 最初に指定するスプールデータの印刷データの属性値
印刷日時出力位置 | × | － | スプールデータの印刷データの属性値 | 最初に指定するスプールデータの印刷データの属性値
印刷日時フォント色 | × | － | スプールデータの印刷データの属性値 | 最初に指定するスプールデータの印刷データの属性値
（凡例）

○：指定できます。

×：指定できません。

－：該当しません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 114 / 218


6.3.3 コーディング例 : EUR 帳票出力 機能解説 EUR Server編

  • 115 / 218

  • 表紙

  • 6.　仕分け・分割・統合して出力する

  • 6.3　統合して出力するには

  • 6.3.3　コーディング例

6.3.3　コーディング例

次に示すパラメタを指定して，アプリケーションサーバにある複数のEPF形式ファイルを統合します。

■入力ファイル：EUR Server - Adapter稼働マシンに配置

統合対象のEPF形式ファイル名：Add_1.epf，Add_2.epf

統合対象のEPF形式ファイルのパス：c:\Input\EPF

■出力ファイル

出力EPF形式ファイルのパス：c:\Output\EPF

出力EPF形式ファイル名：sample1.epf

■そのほか

印刷部数：3部

プリンタクラス：SampleTest

コーディング例を次に示します。

〈この項の構成〉

  • (1)　Java起動部品を使用する場合

(1)　Java起動部品を使用する場合

<%@ page import="java.io.*" %>
<%@ page import="java.util.*" %>
<%@ page import="JP.co.Hitachi.soft.EURPM.*" %>
<%@ page contentType="text/html; charset=Shift_JIS" %>
<jsp:useBean id="adapter" class="JP.co.Hitachi.soft.EURPM.EURPMAdapterForJava" scope="session" />
               ・
               ・
<%
  try {
      String hostName = request.getServerName();

      mergeFileNames = (String[])(2);
      Array.set(mergeFileNames, 0, "Add_1.epf");
      Array.set(mergeFileNames, 1, "Add_2.epf");
      adapter.setMergeEPFFileName(mergeFileNames);
                      //統合対象EPF形式ファイル名設定

      adapter.setMergeEPFFilePath("c:\\Input\\EPF");
                     //統合対象EPF形式ファイルパス設定
                     //統合対象のEPF形式ファイルは次の2ファイルになる
                     //c:\Input\EPF\Add_1.epf
                     //c:\Input\EPF\Add_2.epf

      adapter.setPrintCopies(3);
                     // 印刷部数設定
      adapter.setPrinterClassName("SampleTest”);
                     // プリンタクラス名設定

      adapter.setEPFFilePath("c:\\Output\\EPF") ;
                     // EPF形式ファイル出力パス設定
      adapter.setEPFFileName("sample1.epf");
                     // EPF形式ファイル名設定
                     //出力ファイルは次のファイルになる
                     //c:\Output\EPF\sample1.epf

      adapter.outputMergeEPFReport();
                     //複数EPF形式ファイル統合出力要求
  }
// エラー処理
  catch (JP.co.Hitachi.soft.EURPM.EURPMException e) {
      out.println("<P>エラー発生<br>");
      out.println("<table BORDER CELLSPACING=2 CELLPADDING=4 >");
      out.println("<tr><th>メソッド</th><th>取得結果</th></tr>");
      out.println("<tr><td>エラーコード</td>");
      out.println("<td>" + e.getErrorCode() + "</td></tr>");
      out.println("<tr><td>メッセージ</td>");
      out.println("<td>" + e.getMessage() + "</td></tr>");
      out.println("<tr><td>エラーレベル</td>");
      out.println("<td>" + e.getErrorLevel() + "</td></tr>");
      out.println("<tr><td>メッセージID</td>");
      out.println("<td>" + e.getKey() + "</td></tr>");
      out.println("</table>");
  }
%>

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 115 / 218


7. 帳票を配送印刷する : EUR 帳票出力 機能解説 EUR Server編

  • 116 / 218

  • 表紙

  • 7.　帳票を配送印刷する

7.　帳票を配送印刷する

この章では，クライアントPCから帳票を問い合わせて印刷する配送印刷について説明します。

〈この章の構成〉

  • 7.1　配送印刷とは

  • 7.2　配送印刷の流れ

  • 7.3　配送印刷の実行例

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 116 / 218


7.1 配送印刷とは : EUR 帳票出力 機能解説 EUR Server編

  • 117 / 218

  • 表紙

  • 7.　帳票を配送印刷する

  • 7.1　配送印刷とは

7.1　配送印刷とは

EURでは，ログインしたユーザの印刷できる帳票を一定間隔でポーリング（問い合わせ）し，そのユーザに宛てた帳票が届いていた場合に自動で印刷できます。この機能を配送印刷といいます。

配送印刷を使用することで，次のような運用ができます。

  • 課やプロジェクトなど特定のグループに属しているユーザに宛てた帳票を印刷する

  • 特定のマシンやプリンタで出力できるユーザを制限して印刷する

EURでは，帳票の配送先（宛先）と帳票を出力するユーザとの関連づけを，宛先情報として管理します。宛先定義ファイルで，「宛先」と「宛先に登録したいユーザ名」を宛先情報として登録します。出力された帳票は宛先ごとに私書箱で管理され，ポーリングしてきたユーザと宛先情報が合致したときに，帳票をクライアントPCに配送して印刷します。

配送印刷をするためには，目的の帳票を蓄積しておく必要があります。蓄積するときに宛先情報を付加して蓄積します。

配送印刷のイメージを次の図に示します。

図7‒1　帳票の配送印刷イメージ

[図データ]

なお，「自分宛ての帳票を印刷する」設定もできます。この設定をすれば，ユーザ個人宛ての帳票を印刷したい場合にも，ユーザ全員分の宛先を登録する必要はありません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 117 / 218


7.2 配送印刷の流れ : EUR 帳票出力 機能解説 EUR Server編

  • 118 / 218

  • 表紙

  • 7.　帳票を配送印刷する

  • 7.2　配送印刷の流れ

7.2　配送印刷の流れ

蓄積した帳票を配送印刷する流れを次の図に示します。

なお，帳票の印刷データの蓄積までの流れについては「5.2.1　蓄積の流れ」を参照してください。

図7‒2　配送印刷の流れ

[図データ]

  1. ログイン

    EUR Client Serviceから，配送サービスにログインします。

  2. ポーリング

    ログイン直後に，配送サービスにポーリングを行います。その後は，EUR Server - Spool Serviceで定義された間隔で定期的にポーリングを行います。

  3. 印刷データ取得

    宛先情報を基に，スプールサーバに格納された帳票の印刷データ（EPF形式ファイル）を取得します。

  4. 印刷データ転送

    取得された印刷データ（EPF形式ファイル）をクライアントPCに転送します。

  5. 印刷

    クライアントプリンタクラス定義に従って自動で印刷します。

〈この節の構成〉

  • 7.2.1　配送印刷をする前に準備しておくこと

  • 7.2.2　帳票を私書箱に登録する

  • 7.2.3　帳票を配送印刷する手順

  • 7.2.4　配送印刷した帳票の状態などを確認する

  • 7.2.5　帳票を再印刷する

  • 7.2.6　コーディング例

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 118 / 218


7.2.1 配送印刷をする前に準備しておくこと : EUR 帳票出力 機能解説 EUR Server編

  • 119 / 218

  • 表紙

  • 7.　帳票を配送印刷する

  • 7.2　配送印刷の流れ

  • 7.2.1　配送印刷をする前に準備しておくこと

7.2.1　配送印刷をする前に準備しておくこと

配送印刷をする前に，次のことを準備しておいてください。

〈この項の構成〉

  • (1)　認証方式を決める

  • (2)　宛先の情報を定義する

  • (3)　製品をインストールしてサービスを登録する

  • (4)　配送サービスのURLを設定する

  • (5)　クライアントプリンタクラスを定義する

(1)　認証方式を決める

配送印刷では，ユーザのログイン情報を使用してポーリングします。EURではLDAPサーバと連携した認証方式とユーザ定義を使用した認証方式のどちらかを選べます。

LDAPサーバと連携した認証方式，またはユーザ定義を使用した認証方式のそれぞれの場合に検討しておく内容については，マニュアル「EUR システム設計ガイド」を参照してください。なお，LDAPサーバと連携した認証方式はWindows環境だけで使用できます。

ページの先頭へ

(2)　宛先の情報を定義する

各ユーザが取得する宛先の情報として，宛先キーの分類，宛先キーの値およびユーザ名を宛先定義ファイルに定義します。

宛先定義ファイルの定義例を次に示します。

所属,設計1課,ユーザA,ユーザC
所属,設計1課,ユーザB,ユーザD
フロア3F,チームA,ユーザC
プリンタ,Hitachi XXX1234,ユーザD
扶養家族,あり,ユーザB

この場合，ユーザによって次の宛先の帳票を印刷できます。

ユーザA

  • 「所属」，「設計1課」の帳票を印刷できます。

ユーザB

  • 「所属」，「設計1課」の帳票を印刷できます。

  • 「扶養家族」，「あり」の帳票を印刷できます。

ユーザC

  • 「所属」，「設計1課」の帳票を印刷できます。

  • 「フロア3F」，「チームA」の帳票を印刷できます。

ユーザD

  • 「所属」，「設計1課」の帳票を印刷できます。

  • 「プリンタ」，「Hitachi XXX1234」の帳票を印刷できます。

宛先定義ファイルに記載できる内容の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

(3)　製品をインストールしてサービスを登録する

配送印刷を実行する環境にEUR製品をインストールして，配送サービスを登録します。

(a)　インストール

配送サービスを実行するマシンに，EUR Server - Spool Service Adapterをインストールします。

また，使用するJava起動部品の環境設定を行ってください。

(b)　配送サービスの登録

配送サービスをアプリケーションサーバのサービスに登録します。

配送サービスのプログラムは，次の場所に格納されています。

インストール先フォルダ\Component\SpoolServer\eurssdeli.ear

ページの先頭へ

(4)　配送サービスのURLを設定する

EUR Client Serviceで接続する配送サービスのURLを決めて，EUR Client Serviceの環境設定ファイル（EURPMCL.ini）に設定しておきます。

なお，EUR Application Serviceを使用して配送印刷する場合は，ポート番号に23100を指定する必要があります。

ページの先頭へ

(5)　クライアントプリンタクラスを定義する

クライアントPCで，プリンタとトレイを組み合わせたクライアントプリンタクラスを定義します。デフォルトのクライアントプリンタクラスを定義すれば，EUR Client Serviceで帳票を印刷するときのデフォルトのプリンタをあらかじめ指定しておくことができます。

クライアントプリンタクラスの定義は，EUR ClientがインストールされたクライアントPCの［EUR Client 構成定義］ダイアログで行います。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 119 / 218


7.2.2 帳票を私書箱に登録する : EUR 帳票出力 機能解説 EUR Server編

  • 120 / 218

  • 表紙

  • 7.　帳票を配送印刷する

  • 7.2　配送印刷の流れ

  • 7.2.2　帳票を私書箱に登録する

7.2.2　帳票を私書箱に登録する

配送印刷する帳票を私書箱に登録するために，「5.2.2(2)　蓄積した帳票をクライアントPCで出力する場合」に示した内容に加えて，蓄積時に次の内容を設定します。

蓄積ファイルの設定内容 | 起動部品の設定項目 | 設定する値
宛先キーの分類 | ActiveX起動部品：ReportAddressKeyCategoryプロパティ Java起動部品：setReportAddressKeyCategoryメソッド COBOL起動部品：REPORTADDRKEYCATEGORYパラメタ コマンド起動部品（eurpmcコマンド）：/racオプション | 宛先キーの分類名（80バイト以内の文字列）
宛先キーの値 | ActiveX起動部品：ReportAddressKeyDataプロパティ Java起動部品：setReportAddressKeyDataメソッド COBOL起動部品：REPORTADDRKEYDATAパラメタ コマンド起動部品（eurpmcコマンド）：/radオプション | 宛先キーの値（80バイト以内の文字列）

なお，自分宛ての帳票（ログインしたユーザ個人が取得できる帳票）として蓄積する場合は，宛先キー分類プロパティにEUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）のPERSONALCATEGORYキーの値を指定し，宛先キー値プロパティにユーザIDを指定してください。

これらの設定によって，帳票の蓄積時に私書箱フォルダに登録されます。

メモ

配送帳票の宛先情報の保持期限も，EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）で設定できます。保持期限が切れた宛先情報は，次のタイミングで状態が変更されます（状態が「印刷済み」または「エラー」の場合は自動で削除されます）。

  • EUR Server - Spool Serviceのサービス起動時

  • EUR Server - Spool Serviceが稼働するマシンの日付が変わって，最初にEUR Server - Spool Serviceへの要求が来たとき（日付変更の契機にローカルタイムと協定世界時（UTC）のどちらを使用するかを，EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）のOPTIONセクションのSTANDARDTIMEキーで指定できます）

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 120 / 218


7.2.3 帳票を配送印刷する手順 : EUR 帳票出力 機能解説 EUR Server編

  • 121 / 218

  • 表紙

  • 7.　帳票を配送印刷する

  • 7.2　配送印刷の流れ

  • 7.2.3　帳票を配送印刷する手順

7.2.3　帳票を配送印刷する手順

クライアントPCからEUR Client Serviceを起動すると，ログインダイアログが表示されます。2回目以降のログインの場合は，前回のログインユーザ名が表示されています。

ユーザ名とパスワードを入力してログインします。

ユーザ名とパスワードには，80バイト以内の文字列が入力できます。ただし，制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」は入力できません。また，パスワードには全角文字は指定できません。

ログインすると，タスクトレイのアイコンが [図データ] に変わり，EUR Client ServiceからEUR Server - Spool Serviceへのポーリングが行われます。印刷する帳票が私書箱にある場合は，印刷データ（EPF形式ファイル）がポーリング元のクライアントPCに転送されて印刷されます。配送印刷中は， [図データ] のアイコンが繰り返し表示されます。

また，配送印刷中にエラーが発生した場合は [図データ] が点滅して表示されます。点滅したアイコンをクリックすると，エラーダイアログが表示されます。

メモ

  • EUR Client Serviceは，クライアントPCにEUR Clientをインストールすると，スタートメニューのスタートアップに登録※され，Windowsにログインしたときに自動起動してタスクトレイに常駐します。EUR Client Serviceが停止している状態でEUR Client Serviceを起動する場合は，EUR製品のプログラムメニューから，［Client］－［Client Service］を選択すると，EUR Client Serviceが起動されます。

    注※　EUR ClientのサイレントインストールでEUR Web Plug-Inだけをインストールした場合は登録されません。

  • EUR Client Serviceを停止する場合は，タスクトレイのアイコンを右クリックして表示されるメニューから，「終了」を選択すると，EUR Client Serviceが停止されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 121 / 218


7.2.4 配送印刷した帳票の状態などを確認する : EUR 帳票出力 機能解説 EUR Server編

  • 122 / 218

  • 表紙

  • 7.　帳票を配送印刷する

  • 7.2　配送印刷の流れ

  • 7.2.4　配送印刷した帳票の状態などを確認する

7.2.4　配送印刷した帳票の状態などを確認する

タスクトレイのアイコンを右クリックして表示されるメニューから，［帳票一覧］を選択すると，［帳票一覧］ダイアログが表示されます。

［帳票一覧］ダイアログでは，次の内容を確認できます。

表7‒1　［帳票一覧］ダイアログで確認できる内容

［帳票一覧］ダイアログの項目

説明

宛先

自分が登録されている宛先をドロップダウンリストで選択します。選択した宛先の帳票が，［帳票一覧］グループボックスに表示されます。

帳票一覧

処理実行時刻

配送印刷帳票の処理実行時刻をYYYY/MM/DD hh:mm:ss形式で表示します。

帳票名

配送印刷した帳票の帳票名を表示します。

印刷状態

配送印刷した帳票の状態を表示します。

  • 印刷待ち

    帳票が配送印刷待ちであることを示します。

  • 印刷中

    帳票が配送印刷中であることを示します。

  • 印刷済

    配送印刷が成功したことを示します。

  • エラー

    配送印刷中に次のどちらかの理由でエラーとなったことを示します。

    ・プリンタ出力中にエラーが発生した

    ・帳票の保持期限を超えている※

印刷者

帳票を印刷したユーザ名を表示します。

出力プリンタクラス

帳票を出力したときのプリンタクラス名を表示します。

ジョブID

配送印刷した帳票のジョブIDを表示します。
注※

帳票の保持期限はEUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）で設定します。詳細についてはマニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

メモ

配送印刷中にエラーが発生した場合に表示されるエラーダイアログの［帳票一覧］ボタンをクリックしても，［帳票一覧］ダイアログを表示できます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 122 / 218


7.2.5 帳票を再印刷する : EUR 帳票出力 機能解説 EUR Server編

  • 123 / 218

  • 表紙

  • 7.　帳票を配送印刷する

  • 7.2　配送印刷の流れ

  • 7.2.5　帳票を再印刷する

7.2.5　帳票を再印刷する

印刷に失敗した場合，［帳票一覧］ダイアログでジョブIDを調べて，システム管理者に再印刷を依頼します。システム管理者は帳票管理GUIにログインして，連絡されたジョブIDや宛先で帳票を検索して再印刷を実行します。

再印刷の詳細については，「13.1　GUIで管理する」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 123 / 218


7.2.6 コーディング例 : EUR 帳票出力 機能解説 EUR Server編

  • 124 / 218

  • 表紙

  • 7.　帳票を配送印刷する

  • 7.2　配送印刷の流れ

  • 7.2.6　コーディング例

7.2.6　コーディング例

次に示すパラメタを指定して，帳票を配送印刷します。

■入力ファイル（印刷定義ファイル）：EUR Server Service稼働マシンに配置

帳票ファイル名：Report1.fms

■入力ファイル（ユーザデータファイル）：EUR Server - Adapter稼働マシンに配置

マッピングデータファイルのパス：C:\temp

■プロパティ（アプリケーションサーバ）：EUR Server - Adapter稼働マシンで設定

印刷方式：2

宛先キー分類：testRAKC

宛先キー値：testRAKD

コーディング例を次に示します。

〈この項の構成〉

  • (1)　コマンド起動部品（eurpmcコマンド）を使用する場合

  • (2)　ActiveX起動部品を使用する場合

  • (3)　Java起動部品を使用する場合

  • (4)　COBOL起動部品を使用する場合

(1)　コマンド起動部品（eurpmcコマンド）を使用する場合

EURPMC.exe /m print /pm spl /rf Report1.fms /map C:\temp\Report1.csv /rac testRAKC /rad testRAKD

ページの先頭へ

(2)　ActiveX起動部品を使用する場合

<HTML>
<HEAD>
<TITLE>Sample Script of ASP page for EUR Print Manager</TITLE>
</HEAD>
<BODY>
<%
  Server.ScriptTimeOut = 100    'スクリプトのタイムアウト時間を100秒に設定
  On Error Resume Next          'エラーハンドリングを行う
  dim jobid                     '変数宣言
  Set EURPM = Server.CreateObject("EURPM.Exec")  'ActiveXオブジェクトのインスタンス作成
  EURPM.ReportFileName = "Report1.fms"           '帳票ファイルの指定
  EURPM.DataFilePath = "C:\temp"                 'マッピングデータパスの指定
  EURPM.DataFileName = "Report1.csv"             'マッピングデータの指定
  EURPM.ReportAddressKeyCategory = "testRAKC"    '宛先キー分類の指定
  EURPM.ReportAddressKeyData = "testRAKD"        '宛先キー値の指定
  EURPM.PrintMode = 2                            '印刷方式を「蓄積」に設定
  If Err.Number <> 0 Then
    Response.Write("蓄積実行前にエラーが発生しています"& Err.Number &"<BR>")
  Else
    EURPM.PrintPMReport()               '蓄積指示
    If Err.Number = 0 Then              'PrintPMReportメソッドは正常終了かどうかの判定
    jobid = EURPM.GetJobID()            '蓄積ファイルのジョブIDを取得
    Else
      errid = Err.Number            'エラーコードをerridに取り出す
      If errid = -441 Then          'KEEY441-Wの場合のエラー処理
      Elseif errid = -301 Then      'KEEY301-Eの場合のエラー処理
      Elseif errid = -302 Then      'KEEY302-Eの場合のエラー処理
      Elseif errid = -201 Then      'KEEY201-Eの場合のエラー処理
        '…以下そのほかのエラー処理を書く
      End If
    End If
  End If
%>
</BODY>
</HTML>

ページの先頭へ

(3)　Java起動部品を使用する場合

import JP.co.Hitachi.soft.EURPM.*;

public class SAMPLE {
    public static void main(String[] args) {
        // 変数定義
        int iCnt = 0;
        EURPMAdapterForJava obj = null;
        String strJobID = null;

        try {
            // オブジェクト生成
            obj = new EURPMAdapterForJava();

            // 帳票ファイルの指定
            obj.setReportFileName("Report1.fms");
            // マッピングデータファイルの指定
            obj.setDataFilePath("C:\\temp\\");
            obj.setDataFileName("Report1.csv");
            //宛先キー分類の指定
            obj.setReportAddressKeyCategory("testRAKC");
            //宛先キー値の指定
            obj.setReportAddressKeyData("testRAKD");
            // その他パラメタの指定
            obj.setPrintMode(2);

            //蓄積実行指示
            obj.printReport();

            // ジョブIDの取得
            strJobID = obj.getJobID();
            System.out.println(strJobID);

        } catch (EURPMException ce) {
            // エラー処理
            int errid;
            errid = ce.getErrorCode();
            if (errid==301) {
            }
        }
    }
}

ページの先頭へ

(4)　COBOL起動部品を使用する場合

       IDENTIFICATION DIVISION.
       PROGRAM-ID.
       EURPMADCTEST.
       ENVIRONMENT DIVISION.
       INPUT-OUTPUT SECTION.
       FILE-CONTROL.
           SELECT INP-FL ASSIGN DATAFILENAME
               ORGANIZATION LINE SEQUENTIAL.
       CONFIGURATION SECTION.
       SPECIAL-NAMES.
           CDECL IS CDECL.
       DATA DIVISION.

       FILE SECTION.
       FD INP-FL.
       01 INP-REC                PIC X(512).

       WORKING-STORAGE SECTION.
       01 EURPMPARAM1.
           COPY 'EURPMPARAM1.cbl'.

      *変数定義
       01 RTNCODE                PIC S9(9) BINARY.
       01 REPNAME                PIC X(256) VALUE SPACE.
       01 MAPNAME                PIC X(256) VALUE SPACE.
       01 MAPPATH                PIC X(256) VALUE SPACE.
       01 PRTMODE                PIC S9(9) BINARY.
       01 RAKC                   PIC X(80) VALUE SPACE.
       01 RAKD                   PIC X(80) VALUE SPACE.

       PROCEDURE DIVISION.
       MAIN SECTION.
       MAIN-START.
           MOVE ZERO             TO RTNCODE
      *    帳票ファイルの指定
           MOVE 'Report1.fms'    TO REPNAME
      *    マッピングデータファイルの指定
           MOVE 'Report1.csv'    TO MAPNAME
           MOVE 'C:\temp\'       TO MAPPATH
      *    宛先キー分類の指定
           MOVE 'TESTRAKC'       TO RAKC
      *    宛先キー値の指定
           MOVE 'TESTRAKD'       TO RAKD
      *    その他パラメタの指定
           MOVE  2               TO PRTMODE

           MOVE REPNAME          TO REPORTNAME OF EURPMPARAM1
           MOVE MAPNAME          TO MAPPINGDATA OF EURPMPARAM1
           MOVE MAPPATH          TO MAPPINGDATAPATH OF EURPMPARAM1
           MOVE PRTMODE          TO PRINTMODE OF EURPMPARAM1
           MOVE RAKC             TO REPORTADDRKEYCATEGORY OF EURPMPARAM1
           MOVE RAKD             TO REPORTADDRKEYDATA OF EURPMPARAM1

      *    蓄積実行指示
           CALL 'PrintReport'  USING BY REFERENCE EURPMPARAM1
                               RETURNING RTNCODE
      *    ジョブIDの表示
           DISPLAY '[JOBID=' JOBID OF EURPMPARAM1 ']'
       .
       MAIN-END.
           EXIT.

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 124 / 218


7.3 配送印刷の実行例 : EUR 帳票出力 機能解説 EUR Server編

  • 125 / 218

  • 表紙

  • 7.　帳票を配送印刷する

  • 7.3　配送印刷の実行例

7.3　配送印刷の実行例

開発環境にインストールしたEUR Developerを使用して，自分宛て帳票を印刷するための手順を説明します。

〈この節の構成〉

  • 7.3.1　配送印刷するユーザを登録する

  • 7.3.2　自分宛て帳票の取得を設定する

  • 7.3.3　配送サービスのURLを設定する

  • 7.3.4　配送サービスにログインする

  • 7.3.5　配送印刷を実行する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 125 / 218


7.3.1 配送印刷するユーザを登録する : EUR 帳票出力 機能解説 EUR Server編

  • 126 / 218

  • 表紙

  • 7.　帳票を配送印刷する

  • 7.3　配送印刷の実行例

  • 7.3.1　配送印刷するユーザを登録する

7.3.1　配送印刷するユーザを登録する

配送印刷するユーザをスプールサーバのEUR Server - Spool Serviceに登録します。

  1. EUR製品のプログラムメニューから，［Server］－［Spool Service 構成定義］を選択します。

    ［EUR Spool Service 構成定義］ダイアログが表示されます。

  2. ［EUR Spool Service 構成定義］ダイアログの［ユーザ定義］タブを表示します。

  3. ［追加］ボタンをクリックします。

    ［ユーザ定義の追加］ダイアログが表示されます。

  4. ユーザ名を設定します。

    ここでは，ユーザ名「euruser」を設定します。そのほかの設定はデフォルト状態のままでかまいませんが，必要に応じて入力してください。

  5. ［OK］ボタンをクリックします。

    ユーザ定義が［EUR Spool Service 構成定義］ダイアログに追加されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 126 / 218


7.3.2 自分宛て帳票の取得を設定する : EUR 帳票出力 機能解説 EUR Server編

  • 127 / 218

  • 表紙

  • 7.　帳票を配送印刷する

  • 7.3　配送印刷の実行例

  • 7.3.2　自分宛て帳票の取得を設定する

7.3.2　自分宛て帳票の取得を設定する

EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）で，ユーザが自分宛て帳票を取得できるように設定します。

EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）は，インストール先フォルダ\Spool下に格納されています。メモ帳などのテキスト編集エディタで編集します。

OPTIONセクションのPERSONALCATEGORYキーを次のとおり設定してください。

PERSONALCATEGORY=personal

環境設定ファイルを保存したあと，EUR Server - Spool Serviceのサービス「EUR Spool Service」を再起動してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 127 / 218


7.3.3 配送サービスのURLを設定する : EUR 帳票出力 機能解説 EUR Server編

  • 128 / 218

  • 表紙

  • 7.　帳票を配送印刷する

  • 7.3　配送印刷の実行例

  • 7.3.3　配送サービスのURLを設定する

7.3.3　配送サービスのURLを設定する

EUR Client Serviceの環境設定ファイル（EURPMCL.ini）で，EUR Client Serviceを起動したときに接続する配送サービスのURLを設定します。

EUR Client Serviceの環境設定ファイル（EURPMCL.ini）は，インストール先フォルダ\Client下に格納されています。テキスト編集エディタで編集します。

PATHセクションのDELISERVICEキーを次のとおり設定してください。

DELISERVICE=http://127.0.0.1:23100/eurssdeli

環境設定ファイルを保存したあと，タスクトレイのアイコンから［終了］をクリックしてEUR Client Serviceを終了します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 128 / 218


7.3.4 配送サービスにログインする : EUR 帳票出力 機能解説 EUR Server編

  • 129 / 218

  • 表紙

  • 7.　帳票を配送印刷する

  • 7.3　配送印刷の実行例

  • 7.3.4　配送サービスにログインする

7.3.4　配送サービスにログインする

EUR製品のプログラムメニューから，［Client］－［Client Service］を選択すると，EUR Client Serviceのログイン画面が表示されます。

ユーザ名「euruser」を入力して［OK］ボタンをクリックします。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 129 / 218


7.3.5 配送印刷を実行する : EUR 帳票出力 機能解説 EUR Server編

  • 130 / 218

  • 表紙

  • 7.　帳票を配送印刷する

  • 7.3　配送印刷の実行例

  • 7.3.5　配送印刷を実行する

7.3.5　配送印刷を実行する

eurpmcコマンドを使用して，配送印刷を実行します。この例では「通常使うプリンタ」に印刷されます。

次のとおりコマンドを実行してください。

"C:\Program Files\Hitachi\EUR\Adapter\Program\eurpmc.exe" /m print /rf report1.fms /map "C:\Program Files\Hitachi\EUR\Sample\REPORTS\report1.csv" /pm spl /rac personal /rad euruser

コマンドを実行すると，EURのバージョンとジョブIDが出力されます。出力例を次に示します。

0910
JobID
E00201205280409295520000001000000006

タスクトレイのアイコンから［帳票一覧］をクリックして帳票が出力されたことを確認します。

印刷状態が「印刷済」になれば配送印刷は終了です。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 130 / 218


8. 監視フォルダに格納したデータファイルを自動的に出力する : EUR 帳票出力 機能解説 EUR Server編

  • 131 / 218

  • 表紙

  • 8.　監視フォルダに格納したデータファイルを自動的に出力する

8.　監視フォルダに格納したデータファイルを自動的に出力する

この章では，業務プログラムが所定のフォルダに出力したデータファイルをEURで帳票出力する方法について説明します。

〈この章の構成〉

  • 8.1　帳票自動出力機能とは

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 131 / 218


8.1 帳票自動出力機能とは : EUR 帳票出力 機能解説 EUR Server編

  • 132 / 218

  • 表紙

  • 8.　監視フォルダに格納したデータファイルを自動的に出力する

  • 8.1　帳票自動出力機能とは

8.1　帳票自動出力機能とは

業務プログラムから出力されたデータファイルを監視フォルダに格納するだけで，自動的にEUR Serverで帳票出力できます。この機能を帳票自動出力機能といいます。なお，帳票自動出力機能を使用できるのは，EUR Server - AdapterがWindows環境の場合だけです。EUR Server - AdapterがUNIX／Linux環境の場合は，帳票自動出力機能を使用できません。

帳票自動出力機能を使用することで，次のような運用ができます。

  • 業務プログラムに応じてバッチからの計画実行

  • オンライン操作からの対話実行

帳票自動出力機能の運用形態には，次の二つがあります。

事前定義型

業務プログラムが出力するマッピングデータファイルを監視する方式です。

帳票の出力先や出力方法はあらかじめ起動パラメタファイルに定義しておきます。また，着信を監視するマッピングデータファイルとそのファイルに対応させる起動パラメタファイルの情報を監視定義ファイルに定義します。

マッピングデータファイルを加工する必要がないため，新たにプログラムを開発することなく帳票自動出力機能を使用できる方式です。

上位主導型

マッピングデータに帳票出力のための制御情報を付加した制御情報付データファイルを監視する方式です。

マッピングデータに帳票の出力先や出力方法などの制御情報を付加した形式の制御情報付データファイルを作成するためのプログラムを準備する必要があります。

マッピングデータの内容に応じて動的に帳票の出力先や出力方法を指定するなど，きめこまかく帳票出力を行うようなシステムに使用できる方式です。

なお，次の機能は，帳票自動出力機能では使用できません。

  • データベースからデータを読み込んだ帳票出力

  • 事前定義型の場合，複数の帳票セットを指定した帳票出力

  • 上位主導型の場合，複数の帳票セットに同じマッピングデータファイルを指定した複数様式での帳票出力

〈この節の構成〉

  • 8.1.1　帳票自動出力の流れ

  • 8.1.2　着信したファイルの処理順序

  • 8.1.3　監視管理フォルダ

  • 8.1.4　出力で使用するファイル

  • 8.1.5　ファイル監視サービスの登録

  • 8.1.6　障害が発生した場合のジョブの再投入

  • 8.1.7　制限事項

  • 8.1.8　注意事項

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 132 / 218


8.1.1 帳票自動出力の流れ : EUR 帳票出力 機能解説 EUR Server編

  • 133 / 218

  • 表紙

  • 8.　監視フォルダに格納したデータファイルを自動的に出力する

  • 8.1　帳票自動出力機能とは

  • 8.1.1　帳票自動出力の流れ

8.1.1　帳票自動出力の流れ

監視フォルダに格納されたデータファイルを自動で帳票出力する流れを，次の図に示します。

〈この項の構成〉

  • (1)　事前定義型

  • (2)　上位主導型

(1)　事前定義型

事前定義型の場合の帳票自動出力の流れを，次の図に示します。

図8‒1　事前定義型の場合の帳票自動出力の流れ

[図データ]

  1. 事前定義

    事前に監視定義ファイルと起動パラメタファイルを作成します。

  2. 読み込み

    ファイル監視サービスは，監視定義ファイルから照合パターン，起動パラメタファイルから帳票出力のための制御情報（eurpmcコマンドのオプション）を読み込みます。

  3. 格納

    業務プログラムが監視フォルダにマッピングデータファイルを格納します。

  4. 監視

    ファイル監視サービスは，監視フォルダにマッピングデータファイルが格納されているかを一定間隔でチェックします。

  5. 取得

    ファイル監視サービスは，監視定義ファイルの照合パターンと一致するマッピングデータファイルからマッピングデータを取得します。照合パターンと一致しないマッピングデータファイルは完了フォルダに移動し，エラー情報をシステムログおよびログファイルに出力します。

  6. 転送

    ファイル監視サービスは，eurpmcコマンドを呼び出してマッピングデータを帳票サーバのEUR Server Serviceに転送します。呼び出しが正常終了した場合は，マッピングデータファイルを削除します。

  7. 出力

    EUR Server Serviceは，帳票サーバに登録されているプリンタに帳票を出力したり，ファイル形式を選んで出力したりします。

ページの先頭へ

(2)　上位主導型

上位主導型の場合の帳票自動出力の流れを，次の図に示します。

図8‒2　上位主導型の場合の帳票自動出力の流れ

[図データ]

  1. 格納

    業務プログラムが監視フォルダに制御情報付データファイルを格納します。

  2. 監視

    ファイル監視サービスは，監視フォルダに制御情報付データファイルが格納されているかを一定間隔でチェックします。

  3. 取得

    ファイル監視サービスは，検知した制御情報付データファイルからマッピングデータと帳票出力のための制御情報（eurpmcコマンドのオプション）を取得します。

  4. 転送

    ファイル監視サービスは，eurpmcコマンドを呼び出してマッピングデータを帳票サーバのEUR Server Serviceに転送します。呼び出しが正常終了した場合は，制御情報付データファイルを削除します。

  5. 出力

    EUR Server Serviceは，帳票サーバに登録されているプリンタに帳票を出力したり，ファイル形式を選んで出力したりします。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 133 / 218


8.1.2 着信したファイルの処理順序 : EUR 帳票出力 機能解説 EUR Server編

  • 134 / 218

  • 表紙

  • 8.　監視フォルダに格納したデータファイルを自動的に出力する

  • 8.1　帳票自動出力機能とは

  • 8.1.2　着信したファイルの処理順序

8.1.2　着信したファイルの処理順序

ファイル監視サービスが複数のファイルの着信を検知した場合，作成日時の古いファイルから順番に処理します。

決まった順番で帳票を出力したい場合は，監視フォルダにマッピングデータファイル，または制御情報付データファイルを一つずつ順番に作成し，ファイル監視サービスの環境設定ファイル（eurfm.ini）のTHREADセクションのGENERALキーに1を設定してください。この場合，ファイル監視サービスがファイルの着信を検知するタイミングごとに1ファイルずつ処理されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 134 / 218


8.1.3 監視管理フォルダ : EUR 帳票出力 機能解説 EUR Server編

  • 135 / 218

  • 表紙

  • 8.　監視フォルダに格納したデータファイルを自動的に出力する

  • 8.1　帳票自動出力機能とは

  • 8.1.3　監視管理フォルダ

8.1.3　監視管理フォルダ

ここでは，ファイル監視サービスが扱うマッピングデータファイルまたは制御情報付データファイルを管理する監視管理フォルダについて説明します。

監視管理フォルダは，次の3つのサブフォルダで構成されます。

  • 監視フォルダ

    ファイル監視サービスが定期的にファイルの着信を監視するフォルダです。

  • 照合フォルダ

    ファイル監視サービスがファイルを解析・照合する際に使用するフォルダです。

  • 完了フォルダ

    照合パターンに一致しないファイルや，印刷や出力に失敗したファイルが格納されるフォルダです。印刷やファイル出力に失敗した時の一時ファイルも格納されます。

監視管理フォルダの作成先は，デフォルトでは「EUR Serverのインストール先ディレクトリ\FileMonitor\fmc」です。

監視フォルダの作成先は，ファイル監視サービスの環境設定ファイルで変更できます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 135 / 218


8.1.4 出力で使用するファイル : EUR 帳票出力 機能解説 EUR Server編

  • 136 / 218

  • 表紙

  • 8.　監視フォルダに格納したデータファイルを自動的に出力する

  • 8.1　帳票自動出力機能とは

  • 8.1.4　出力で使用するファイル

8.1.4　出力で使用するファイル

ここでは，帳票自動出力機能を使用して出力するときに使用するファイルの概要について説明します。各ファイルの指定内容の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

〈この項の構成〉

  • (1)　監視定義ファイル

  • (2)　起動パラメタファイル

  • (3)　制御情報付データファイル

(1)　監視定義ファイル

監視定義ファイルは，運用形態が事前定義型の場合に必要です。

監視定義ファイルには，着信したマッピングデータファイルと起動パラメタファイルを紐付けるための情報を指定します。

ページの先頭へ

(2)　起動パラメタファイル

起動パラメタファイルは，運用形態が事前定義型の場合に必要です。

起動パラメタファイルには，eurpmcコマンドのオプションを指定します。

ページの先頭へ

(3)　制御情報付データファイル

制御情報付データファイルは，運用形態が上位主導型の場合に監視対象となるファイルです。制御情報付データファイルには，eurpmcコマンドのオプション，帳票ファイル名，ユーザ定義データファイル名，しおり定義ファイル名，およびマッピングデータを指定します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 136 / 218


8.1.5 ファイル監視サービスの登録 : EUR 帳票出力 機能解説 EUR Server編

  • 137 / 218

  • 表紙

  • 8.　監視フォルダに格納したデータファイルを自動的に出力する

  • 8.1　帳票自動出力機能とは

  • 8.1.5　ファイル監視サービスの登録

8.1.5　ファイル監視サービスの登録

〈この項の構成〉

  • (1)　サービスの登録

(1)　サービスの登録

ファイル監視サービスは，EUR Server，EUR Server - Adapter，またはEUR Developerをインストールすると，自動的にサービス登録されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 137 / 218


8.1.6 障害が発生した場合のジョブの再投入 : EUR 帳票出力 機能解説 EUR Server編

  • 138 / 218

  • 表紙

  • 8.　監視フォルダに格納したデータファイルを自動的に出力する

  • 8.1　帳票自動出力機能とは

  • 8.1.6　障害が発生した場合のジョブの再投入

8.1.6　障害が発生した場合のジョブの再投入

帳票自動出力機能でエラーを検知すると，エラー情報をシステムログおよびログファイルに出力します。エラーになったマッピングデータファイルまたは制御情報付データファイルは，完了フォルダ（デフォルトはEUR Serverのインストール先フォルダ\FileMonitor\fmc\data）に登録されます。完了フォルダは，ファイル監視サービス起動時に自動的に作成されます。

エラー原因を取り除き，完了フォルダに格納されている障害が発生したマッピングデータファイルまたは制御情報付データファイルを監視フォルダに再度投入します。

帳票自動出力機能が投入されたファイルを再度処理します。

メモ

エラーで完了フォルダに格納されたマッピングデータファイルまたは制御情報付データファイルの保持期限は，ファイル監視サービスの環境設定ファイル（eurfm.ini）で設定できます。保持期限が切れたマッピングデータファイルまたは制御情報付データファイルは，次のタイミングで自動的に削除されます。

  • ファイル監視サービスの起動時

  • 日付が変わって，最初にファイル監視が実行されたとき（日付変更の契機にローカルタイムと協定世界時（UTC）のどちらを使用するかを，ファイル監視サービスの環境設定ファイル（eurfm.ini）のOPTIONセクションのSTANDARDTIMEキーで指定できます）

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 138 / 218


8.1.7 制限事項 : EUR 帳票出力 機能解説 EUR Server編

  • 139 / 218

  • 表紙

  • 8.　監視フォルダに格納したデータファイルを自動的に出力する

  • 8.1　帳票自動出力機能とは

  • 8.1.7　制限事項

8.1.7　制限事項

〈この項の構成〉

  • (1)　使用できないEURの機能

  • (2)　指定できないフォルダおよびファイルの種類

  • (3)　監視フォルダへのファイル書き込み方法

(1)　使用できないEURの機能

帳票自動出力機能を使用する場合に使用できない機能を次に示します。

  • データベースからデータを読み込んだ帳票出力

  • 事前定義型の場合，複数の帳票セットを指定した帳票出力

  • 上位主導型の場合に，複数の帳票セットに同じマッピングデータファイルを指定する複数様式での帳票出力

ページの先頭へ

(2)　指定できないフォルダおよびファイルの種類

  • ディスクがマウントされたり，アンマウントされたりする環境にあるフォルダは監視フォルダに指定しないでください。このようなフォルダを監視管理フォルダに指定した場合，監視処理が正常に動作しなくなったり，意図しないタイミングでファイルの着信を検知してしまったりすることがあります。

  • 監視管理フォルダを指定する場合，ネットワークドライブおよびUNC（Universal Naming Convention）で参照できるフォルダを指定しても動作の保証はできません。これは，サービスからアクセスできなかったり，ネットワーク切断など不安定な状態になったりするおそれがあること，また，着信したファイルが他システムで使用中かどうかの判断ができないためです。他システムのファイルを監視する場合は，他システムにファイル監視サービスを配置して，ローカルのファイルとして監視してください。

  • 監視管理フォルダおよびその配下のフォルダおよびファイルがシンボリックリンクの場合は，監視できません。

ページの先頭へ

(3)　監視フォルダへのファイル書き込み方法

  • ファイル監視サービスは，監視フォルダにファイルが存在していることを確認した場合，監視対象のファイルにほかのプロセスがアクセスしていないかチェックします（クローズチェック）。ほかのプロセスが監視対象のファイルにアクセスしていた場合は，着信を検知しません。次回の監視間隔に繰り越して監視し，そこでほかのプロセスのアクセスがなければ着信を検知します。

  • 頻繁にファイルのオープン・クローズを行い，データを追加書きするようなファイルについては，ファイル監視サービスで正しく監視できません。ファイル監視サービスの監視するタイミングとファイルのクローズが重なると，ファイルの書き込みが完了したと見なして着信を検知した処理を行います。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 139 / 218


8.1.8 注意事項 : EUR 帳票出力 機能解説 EUR Server編

  • 140 / 218

  • 表紙

  • 8.　監視フォルダに格納したデータファイルを自動的に出力する

  • 8.1　帳票自動出力機能とは

  • 8.1.8　注意事項

8.1.8　注意事項

〈この項の構成〉

  • (1)　多量のファイルが出力されたときの注意

  • (2)　大量ページのファイルを出力するときの注意

  • (3)　監視管理フォルダ変更時の注意

  • (4)　マッピングデータファイルの注意

(1)　多量のファイルが出力されたときの注意

監視フォルダに多量のマッピングデータファイル，または制御情報付データファイルが出力された場合，実行されず待ち状態になることがあります。待ち状態のファイルをキャンセルする場合は，監視フォルダのファイルを別のフォルダに移動すると帳票出力をキャンセルできます。なお，移動したファイルを監視フォルダに戻すと，出力処理が実行されます。

ページの先頭へ

(2)　大量ページのファイルを出力するときの注意

監視フォルダに大量ページのマッピングデータファイル，または制御情報付データファイルが出力された場合，ジョブが長時間実行状態になってタイムアウトになることがあります。あらかじめ，EUR Server - Adapterの環境設定ファイル（EURPMADP.ini）のTIMEOUTセクションのタイムアウト時間を変更しておくことをお勧めします。

ページの先頭へ

(3)　監視管理フォルダ変更時の注意

監視管理フォルダを変更する場合で，変更前の監視フォルダ，および照合フォルダにファイルが格納されているときは，ファイル監視サービスが起動する前に，変更後の監視フォルダに移動させておいてください。移動しない場合は，変更前の監視フォルダ，および照合フォルダに格納されているファイルは処理されません。

ページの先頭へ

(4)　マッピングデータファイルの注意

ファイル監視サービスは，ファイルの着信を検知すると，着信したファイルがマッピングデータファイルなのか，制御情報付データファイルなのかを判定します。着信したファイルの先頭行が次の形式の場合は，制御情報付データファイルと判定します。

オプションの開始行

△<!eur_option start>△▼

（凡例）

△：0個以上のタブ，半角空白，または全角空白を示します。

▼：改行（0x0a，または0x0d+0x0a）を示します。

そのため，マッピングデータファイルで，上記の形式を使用したい場合は，マッピングデータの上記の文字列を「"」で囲んで指定してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 140 / 218


9. BSP-RMで生成されたデータファイルを出力する : EUR 帳票出力 機能解説 EUR Server編

  • 141 / 218

  • 表紙

  • 9.　BSP-RMで生成されたデータファイルを出力する

9.　BSP-RMで生成されたデータファイルを出力する

この章では，帳票管理システムBSP-RMで作成，管理しているデータファイルをEURで帳票出力する方法について説明します。

〈この章の構成〉

  • 9.1　BSP-RM連携機能とは

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 141 / 218


9.1 BSP-RM連携機能とは : EUR 帳票出力 機能解説 EUR Server編

  • 142 / 218

  • 表紙

  • 9.　BSP-RMで生成されたデータファイルを出力する

  • 9.1　BSP-RM連携機能とは

9.1　BSP-RM連携機能とは

BSP-RMと連携することで，BSP-RMで生成されたデータファイルをEUR Serverで帳票出力できます。この機能をBSP-RM連携機能といいます。

〈この節の構成〉

  • 9.1.1　出力の流れ

  • 9.1.2　出力で使用するファイル

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 142 / 218


9.1.1 出力の流れ : EUR 帳票出力 機能解説 EUR Server編

  • 143 / 218

  • 表紙

  • 9.　BSP-RMで生成されたデータファイルを出力する

  • 9.1　BSP-RM連携機能とは

  • 9.1.1　出力の流れ

9.1.1　出力の流れ

BSP-RMで生成されたデータファイルを帳票出力する流れを，次の図に示します。

  1. 事前定義

    事前に起動パラメタファイルを作成します。

  2. 出力要求

    帳票の出力要求が業務プログラムに送られます。

  3. データファイル出力

    BSP-RMが制御情報付データファイルを出力します。

  4. 呼び出し

    BSP-RMがBSP-RM連携コマンド（eursmprコマンド）を起動します。

  5. 取得

    BSP-RM連携コマンド（eursmprコマンド）は，制御情報付データファイルから帳票ファイル名，ユーザ定義データファイル名，およびマッピングデータ，起動パラメタファイルから帳票出力のための制御情報（eurpmcコマンドのオプション）を取得します。

  6. 転送

    BSP-RM連携コマンド（eursmprコマンド）は，eurpmcコマンドを呼び出してマッピングデータを帳票サーバのEUR Server Serviceに転送します。

  7. 出力

    EUR Server Serviceは，帳票サーバに登録されているプリンタに帳票を出力したり，ファイル形式を選んで出力したりします。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 143 / 218


9.1.2 出力で使用するファイル : EUR 帳票出力 機能解説 EUR Server編

  • 144 / 218

  • 表紙

  • 9.　BSP-RMで生成されたデータファイルを出力する

  • 9.1　BSP-RM連携機能とは

  • 9.1.2　出力で使用するファイル

9.1.2　出力で使用するファイル

BSP-RM連携機能で使用するファイルの概要について説明します。各ファイルの指定内容の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

〈この項の構成〉

  • (1)　起動パラメタファイル

  • (2)　制御情報付データファイル

(1)　起動パラメタファイル

起動パラメタファイルには，eurpmcコマンドのオプションを指定します。

ページの先頭へ

(2)　制御情報付データファイル

制御情報付データファイルは，BSP-RMから出力してください。制御情報付データファイルには，帳票ファイル名，ユーザ定義データファイル名，およびマッピングデータを指定します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 144 / 218


10. 個人番号管理サービスと連携して個人番号を含む帳票を出力する : EUR 帳票出力 機能解説 EUR Server編

  • 145 / 218

  • 表紙

  • 10.　個人番号管理サービスと連携して個人番号を含む帳票を出力する

10.　個人番号管理サービスと連携して個人番号を含む帳票を出力する

この章では，マイナンバー対応の個人番号管理サービスと連携して，個人番号を含む法定調書などの帳票を出力する方法について説明します。

〈この章の構成〉

  • 10.1　個人番号管理サービス連携機能とは

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 145 / 218


10.1 個人番号管理サービス連携機能とは : EUR 帳票出力 機能解説 EUR Server編

  • 146 / 218

  • 表紙

  • 10.　個人番号管理サービスと連携して個人番号を含む帳票を出力する

  • 10.1　個人番号管理サービス連携機能とは

10.1　個人番号管理サービス連携機能とは

機密性の高いマイナンバー対応の個人番号を，暗号化したデータベースで保存・管理し，業務アプリケーションなどから安全に参照できる個人番号管理サービスと連携できます。

マイナンバー対応の個人番号管理サービスと連携することで，Windows環境のEUR Serverでの帳票出力時に，個人番号管理サービスから個人番号を取得して帳票に出力することができます。この機能を個人番号管理サービス連携機能といいます。

Windows環境のEUR Serverと連携できる個人番号管理サービスを次に示します。

  • マイナンバーセキュア管理システム

  • 匿名バンク

個人番号を含む法定調書（源泉徴収票など）を出力する場合に，個人番号管理サービスの暗号化したデータベースから個人番号を取得して出力できるため，情報漏えいのリスクがなく，セキュアに帳票出力できます。

〈この節の構成〉

  • 10.1.1　事前準備

  • 10.1.2　構築の流れ

  • 10.1.3　出力の流れ

  • 10.1.4　出力で使用するファイル

  • 10.1.5　個人番号接続情報ファイルを暗号化する

  • 10.1.6　起動部品の設定

  • 10.1.7　注意事項

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 146 / 218


10.1.1 事前準備 : EUR 帳票出力 機能解説 EUR Server編

  • 147 / 218

  • 表紙

  • 10.　個人番号管理サービスと連携して個人番号を含む帳票を出力する

  • 10.1　個人番号管理サービス連携機能とは

  • 10.1.1　事前準備

10.1.1　事前準備

個人番号管理サービス連携機能を使用する前に，事前に準備しておくことを次に示します。

  • 個人番号管理サービスのURLの入手

    EUR Serverから個人番号管理サービスに接続するURLの情報を，契約した個人番号管理サービスから入手しておく必要があります。

  • 連携プロファイルの作成

    個人番号管理サービスから提供される機能を使用して連携プロファイルを作成し，帳票サーバに配置しておく必要があります。

  • 個人番号管理サービスへの個人番号の登録

    社員の個人番号および個人番号を取得するためのキー情報のデータを，個人番号管理サービスのデータベースに登録しておく必要があります。登録するデータを次に示します。

    • 個人番号のデータ

    • 会社を識別するためのデータ（番号またはコード）

    • 社員を識別するためのデータ（番号またはコード）

    • 家族の続柄を識別するためのデータ（番号またはコード）

    個人番号管理サービスへのデータの登録方法の詳細については，連携先のサービスの窓口などにお問い合わせください。

  • 個人番号管理サービスのSSL証明書のルート証明書の入手

    EUR Serverと個人番号管理サービスとの通信プロトコルには，SSL/TLSを使用するため，個人番号管理サービスのSSL証明書がEUR Server側で信頼された証明書と認識される必要があります。また，信頼された証明書と認識するために，必要に応じて，ルート証明書を入手して，証明書をインポートしておく必要があります。

  • プロキシサーバの接続情報の入手

    帳票サーバからプロキシサーバを経由して個人番号管理サービスに接続する構成の場合は，プロキシサーバのIPアドレスまたはホスト名と，ポート番号を入手しておく必要があります。また，プロキシの認証機能を使用する場合は，認証に使用するIDとパスワードを入手しておく必要があります。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 147 / 218


10.1.2 構築の流れ : EUR 帳票出力 機能解説 EUR Server編

  • 148 / 218

  • 表紙

  • 10.　個人番号管理サービスと連携して個人番号を含む帳票を出力する

  • 10.1　個人番号管理サービス連携機能とは

  • 10.1.2　構築の流れ

10.1.2　構築の流れ

個人番号管理サービス連携機能を使用する場合の構築の流れを，次に示します。

  1. 必要なプログラムのインストール

    個人番号管理サービスと連携する場合に必要なプログラムを，帳票サーバにインストールします。

    個人番号管理サービスと連携する場合に必要なプログラムについては，マニュアル「EUR システム設計ガイド」を参照してください。

  2. 帳票出力で使用するファイルの準備

    個人番号管理サービス連携機能を使用する場合に準備するファイルを次に示します。

    ■帳票設計で使用するファイル

    ・帳票ファイル

    ・マッピングデータファイル

    ■帳票の出力環境を設定するファイル

    ・個人番号接続情報ファイル

    ・環境設定ファイル（EURPS_ENV）

    ・連携プロファイル

    ・個人番号管理サービスのSSLサーバ証明書

    ■帳票の出力内容を設定するファイル

    ・個人番号フィールド情報ファイル

    ・帳票出力定義ファイル

  3. 業務アプリケーションでの帳票出力

    EUR Server - Adapterの起動部品を使用し，次に示す項目を指定して帳票出力することで，業務アプリケーションから個人番号を含む帳票を出力することができます。

    • 帳票ID

    • 個人番号を取得するためのキー情報を含むマッピングデータ

    • ファイル暗号化鍵（個人番号接続情報ファイルを暗号化した場合）

    個人番号管理サービス連携機能で使用するEUR Server - Adapterの起動部品については，「10.1.6　起動部品の設定」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 148 / 218


10.1.3 出力の流れ : EUR 帳票出力 機能解説 EUR Server編

  • 149 / 218

  • 表紙

  • 10.　個人番号管理サービスと連携して個人番号を含む帳票を出力する

  • 10.1　個人番号管理サービス連携機能とは

  • 10.1.3　出力の流れ

10.1.3　出力の流れ

個人番号管理サービス連携機能を使用して帳票を出力する流れを，次の図に示します。

なお，個人番号接続情報ファイルを暗号化する場合は，オプション製品のEUR Server - Cipher optionに同梱されているファイル暗号化ツールで，事前に暗号化しておく必要があります。

図10‒1　個人番号管理サービス連携機能を使用して帳票を出力する流れ

[図データ]

  1. 出力要求

    帳票の出力要求が業務プログラムに送られます。

  2. 転送

    EUR Server - Adapterは，次のデータを帳票サーバのEUR Server Serviceに転送します。

    • 帳票ID

    • 個人番号を取得するためのキー情報を含むマッピングデータ

    • ファイル暗号化鍵※

    注※

    個人番号接続情報ファイルを暗号化した場合だけ，暗号化したときのファイル暗号化鍵を指定します。

  3. 個人番号フィールド情報ファイル名の取得

    EUR Server Serviceは，帳票IDで指定される帳票出力定義ファイルから，個人番号フィールド情報ファイル名を取得し，EUR Print Serviceに転送します。

  4. 個人番号管理サービスとの連携に必要なデータの取得

    EUR Print Serviceは，次のファイルのデータを取得します。

    • 個人番号フィールド情報ファイル

    • 連携プロファイル

    • 個人番号接続情報ファイル※

    注※

    暗号化されている場合は，ファイル暗号化鍵で復号化してデータを取得します。

  5. 個人番号管理サービスへの接続と通信

    EUR Print Serviceは，個人番号管理サービスのクライアント用のライブラリを呼び出して，個人番号管理サービスと接続します。個人番号管理サービスとの通信で送受信するデータは，暗号化されます。

  6. 個人番号データの取得要求

    個人番号を取得するためのキー情報のデータで，個人番号管理サービスのデータベースを照合し，個人番号のデータを取得します。

  7. 印刷データ生成

    EUR Print Serviceは，業務プログラムから転送されたマッピングデータとあらかじめ帳票サーバに配置しておいた印刷定義ファイルから，印刷データが生成されます。

  8. 印刷データ転送

    EUR Server Serviceは，生成された印刷データをクライアントPCに転送します。

  9. 出力

    印刷データを受信すると，クライアントPCで帳票を出力できます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 149 / 218


10.1.4 出力で使用するファイル : EUR 帳票出力 機能解説 EUR Server編

  • 150 / 218

  • 表紙

  • 10.　個人番号管理サービスと連携して個人番号を含む帳票を出力する

  • 10.1　個人番号管理サービス連携機能とは

  • 10.1.4　出力で使用するファイル

10.1.4　出力で使用するファイル

ここでは，個人番号管理サービス連携機能で使用するファイルの概要について説明します。各ファイルの指定内容の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

〈この項の構成〉

  • (1)　帳票の出力環境を設定するファイル

  • (2)　帳票の出力内容を設定するファイル

  • (3)　連携プロファイル

  • (4)　個人番号管理サービスのSSL証明書のルート証明書

(1)　帳票の出力環境を設定するファイル

(a)　個人番号接続情報ファイル

個人番号接続情報ファイルには，個人番号管理サービスと接続するために必要な情報を指定します。

個人番号接続情報ファイルに指定する項目を次に示します。

  • 接続先の個人番号管理サービスのURL

  • 個人番号管理サービスとの通信タイムアウト監視時間

  • 個人番号管理サービスに登録されている会社を識別するデータ（番号またはコード）

また，個人番号接続情報ファイルは暗号化することもできます。個人番号接続情報ファイルの暗号化については，「10.1.5　個人番号接続情報ファイルを暗号化する」を参照してください。

(b)　環境設定ファイル（EURPS_ENV）

EUR Print Serviceの環境設定ファイル（EURPS_ENV）に指定する項目を次に示します。

  • 環境変数EURPS_MMS_CONNECT_INFO_FILE

    個人番号接続情報ファイルのファイル名およびパスを指定します。

  • 環境変数EURPS_MMS_FILEPATH

    個人番号接続情報ファイルおよび個人番号フィールド情報ファイルのデフォルトの読み込みフォルダを指定します。

  • 環境変数EURPS_MMS_LOGDETAIL

    個人番号管理サービス連携機能の実行ログを出力するeurmmsログに詳細な情報を出力するかどうかを指定します。

  • 環境変数EURPS_MMS_NOTMATCH_ERROR

    個人番号を取得するためのキー情報のデータに対して個人番号を取得できなかったときに，エラーとするかどうかを指定します。

  • 環境変数EURPS_MMS_LIBRARY_PATH

    個人番号管理サービスから提供されるクライアント用のライブラリのパスを指定します。

  • 環境変数EURPS_MMS_PROFILE_PATH

    個人番号管理サービスから提供される機能で作成した連携プロファイルのパスを指定します。

  • 環境変数EURPS_LOGFILEPATH

    eurmmsログの出力先フォルダを指定します。

  • 環境変数EURPS_LOGSIZE

    eurmmsログのファイルサイズを指定します。

  • 環境変数EURPS_LOGFILELEVEL

    eurmmsログへのメッセージ出力レベルを指定します。

ページの先頭へ

(2)　帳票の出力内容を設定するファイル

(a)　個人番号フィールド情報ファイル

個人番号フィールド情報ファイルは，個人番号管理サービスから個人番号を取得するためのキー情報となるマッピングデータのフィールド名を定義するファイルです。個人番号フィールド情報ファイルには，次に示す項目を指定します。

  • 個人番号管理サービスに登録されている次のデータに対応するマッピングデータのフィールド名

    • 社員を識別するデータ（番号またはコード）

    • 家族の続柄を識別するデータ（番号またはコード）

  • 個人番号管理サービスから取得した個人番号のデータを設定するマッピングデータのフィールド名

(b)　帳票出力定義ファイル

個人番号管理サービス連携機能を使用する場合は，帳票IDを使用して帳票を出力する必要があります。

帳票IDに指定する帳票出力定義ファイルには，通常の入力情報に加えて，次に示す項目を指定します。

  • 個人番号フィールド情報ファイル名

  • 個人番号フィールド情報ファイルのパス

ページの先頭へ

(3)　連携プロファイル

連携プロファイルは，個人番号管理サービスから提供される機能を使用して作成するファイルです。

ページの先頭へ

(4)　個人番号管理サービスのSSL証明書のルート証明書

必要に応じて，帳票サーバにインポートしておく必要があるファイルです。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 150 / 218


10.1.5 個人番号接続情報ファイルを暗号化する : EUR 帳票出力 機能解説 EUR Server編

  • 151 / 218

  • 表紙

  • 10.　個人番号管理サービスと連携して個人番号を含む帳票を出力する

  • 10.1　個人番号管理サービス連携機能とは

  • 10.1.5　個人番号接続情報ファイルを暗号化する

10.1.5　個人番号接続情報ファイルを暗号化する

個人番号管理サービス連携機能で使用する個人番号接続情報ファイルは，暗号化できます。暗号化することで，セキュリティを高めることができます。

個人番号接続情報ファイルを暗号化した場合は，帳票出力時に暗号化したときのファイル暗号化鍵を指定する必要があります。

なお，個人番号接続情報ファイルを暗号化するには，EUR Server StandardまたはEUR Server Enterpriseに加えて，EUR Server - Cipher optionが帳票サーバに必要です。

〈この項の構成〉

  • (1)　ファイルの暗号化

  • (2)　注意事項

(1)　ファイルの暗号化

個人番号接続情報ファイルの暗号化は，ファイル暗号化ツール（eurecfileコマンド）で行います。ファイル暗号化ツールは，EUR Server - Cipher optionに同梱されています。

(a)　ファイル名

ファイル暗号化ツールのファイル名と格納先を次に示します。

  • ファイル名：eurecfile.exe

  • 格納先：EUR Server - Cipher optionのインストール先フォルダ\Cipher\x64

(b)　コマンドの構文

ファイル暗号化ツールのコマンドの構文を次に示します。

eurecfile
     /if 暗号化対象ファイルパス
     /of 出力先ファイルパス
     /es 暗号化鍵

  • /ifオプション

    暗号化するファイル名のフルパスを指定します。

  • /ofオプション

    暗号化したファイルを出力するファイルのフルパスを指定します。

  • /esオプション

    暗号化したファイルから元のファイルを読み出すための，暗号化鍵を指定します。ファイル暗号化鍵に指定できる文字は，次のとおりです。

    • 半角数字

      0～9

    • 半角英字

      A～Z，a～z

    • 半角記号

    指定できるファイル暗号化鍵の長さは，8～32バイトです。

(c)　出力されるファイル

ファイル暗号化ツールのコマンドを実行すると，暗号化されたファイルが，指定した出力先ファイルパスに出力されます。暗号化前のファイルの更新や削除は行いません。

(d)　終了コード

ファイル暗号化ツール（eurecfileコマンド）を実行すると，終了コードが返されます。終了コード一覧を次に示します。

表10‒1 ファイル暗号化ツール（eurecfileコマンド）の終了コード
終了コード | 意味
0 | コマンドが正常に終了しました。
8 | コマンドの実行中に，システムエラーが発生しました。
12 | コマンドの実行中に，データエラーが発生しました。
16 | コマンドラインの指定に誤りがあります。
32 | 上記以外のエラーが発生しました。

ページの先頭へ

(2)　注意事項

  • 個人番号接続情報ファイルの暗号化出力は，日本語ロケールでだけ正しく動作します。個人番号接続情報ファイルを暗号化出力するときは，ロケールを日本語環境に設定してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 151 / 218


10.1.6 起動部品の設定 : EUR 帳票出力 機能解説 EUR Server編

  • 152 / 218

  • 表紙

  • 10.　個人番号管理サービスと連携して個人番号を含む帳票を出力する

  • 10.1　個人番号管理サービス連携機能とは

  • 10.1.6　起動部品の設定

10.1.6　起動部品の設定

個人番号管理サービス連携機能を使用する場合は，帳票IDを使用して帳票を出力する必要があります。帳票IDの指定で使用する起動部品については，「2.4.2　帳票IDの指定で使用する起動部品」を参照してください。

また，個人番号接続情報ファイルを暗号化した場合は，帳票出力時にファイル暗号化鍵を指定する必要があります（指定しないとエラーになります）。帳票出力時にファイル暗号化鍵を設定する起動部品のプロパティ，メソッド，パラメタ，およびオプションの指定値を次に示します。

  • ActiveX起動部品：EncryptionFileKeyプロパティ

  • Java起動部品：setEncryptionFileKeyメソッド

  • COBOL起動部品：ENCRYPTIONFILEKEYパラメタ

  • コマンド起動部品：/encfilekeyオプション

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 152 / 218


10.1.7 注意事項 : EUR 帳票出力 機能解説 EUR Server編

  • 153 / 218

  • 表紙

  • 10.　個人番号管理サービスと連携して個人番号を含む帳票を出力する

  • 10.1　個人番号管理サービス連携機能とは

  • 10.1.7　注意事項

10.1.7　注意事項

〈この項の構成〉

  • (1)　システム構築上の注意事項

  • (2)　運用上の注意事項

(1)　システム構築上の注意事項

個人番号管理サービス連携機能を使用して帳票出力する場合，個人番号の情報漏えいに注意する必要がある項目と対処について，次の表に示します。

表10‒2　個人番号の情報漏えいに注意する必要がある項目と対処

項番

個人番号の情報漏えいに注意する必要がある項目

個人番号の情報漏えいに注意する必要がある契機

個人番号の情報漏えいの可能性があるケース

対処

1

EURでファイル出力したファイル，または蓄積したスプールデータ

ファイル出力を実行したとき

ファイル出力したファイルや蓄積したスプールデータに個人番号の情報が含まれているとき

セキュリティの観点から，帳票データが残る機能（ファイル出力や蓄積）の使用は推奨しません。帳票データが残る機能を使用する場合は，個人番号が含まれる帳票データの取り扱いに十分注意してください。

2

帳票サーバの一時フォルダ内の一時ファイル

帳票サーバ，スプールサーバ，またはクライアントの一時フォルダに一時ファイルを出力したとき

帳票出力時に作成される一時ファイルに個人番号が含まれているとき

環境設定がデフォルトの場合，発生するエラーによっては，一時ファイルが残る場合があります。このため，環境設定ファイル（EURPM.ini，EURPMLS.ini，およびEURPMCL.ini）で，一時ファイルを常に削除する設定にしておくことを推奨します。推奨する設定値を次に示します。

■環境設定ファイル（EURPM.ini，EURPMLS.ini，およびEURPMCL.ini）の[OPTION]セクション

  • TEMPFILEDELキー：0（一時ファイルを常に削除）

  • RMDIRRETRYCOUNTキー：20（一時フォルダの削除に失敗した場合のリトライ回数の最大値）

  • RMDIRINTERVALTIMEキー：1000（一時フォルダの削除に失敗した場合にリトライするまでの待機時間（単位：ミリ秒）の最大値）

また，一時ファイルは，環境設定ファイルで設定する帳票サーバ，スプールサーバ，およびクライアントの作業フォルダに作成されるため，OSのアクセス権の設定などで，不特定多数のユーザに参照されないようにすることを推奨します。

3

EUR Web Plug-Inを使用するマシンの一時フォルダ内の一時ファイル

EUR Web Plug-Inで印刷またはプレビューを実行したとき

印刷時またはプレビュー時に作成される一時ファイルに個人番号が含まれているとき

環境設定がデフォルトの場合，発生するエラーによっては，一時ファイルが残る場合があります。このため，EUR Web Plug-InのEPFTempDataModeパラメタに1（一時ファイルとして保存しない）を設定しておくことを推奨します。

また，EPFTempDataModeパラメタに0（一時ファイルとして保存する）を設定，またはEPFTempDataModeパラメタを省略する場合は，TempFileDelパラメタに0（一時ファイルを常に削除）を設定しておくことを推奨します。

なお，帳票管理GUIの印刷またはプレビューで使用するEUR Web Plug-Inについては，EPFTempDataModeパラメタとTempFileDelパラメタの設定がデフォルトのまま変更できないため，帳票管理GUIでは，個人番号を含むスプールデータは蓄積しないでください。

4

eurpsログ（eurps.log）に出力したデータ

個人番号管理サービス連携機能を使用する帳票ファイルの，個人番号を出力するアイテムの桁数が12桁より小さいとき，またはフィールドのデータ種別が適切でないとき

帳票への個人番号の出力で， KEEU301-WまたはKEEU302-Wのエラーが発生し，個人番号がログファイルに出力されたとき

出力するアイテムの桁数（12桁固定）やフィールドのデータ種別が適切かどうかを事前に十分確認してください。

5

トレースファイルに出力したデータ

環境変数EURPS_TRACEと環境変数EURPS_TRACE_DRAWAPIの両方にYESを指定しているとき

環境変数EURPS_TRACE_DRAWAPIにYESを指定し，描画系APIの引数（個人番号も引数として出力されます）がトレースファイルに出力されたとき

環境変数EURPS_TRACEにNO（トレースファイルを出力しない）を設定するか，環境変数EURPS_TRACE_DRAWAPIにNO（描画系APIのトレースファイルを出力しない）を設定するかのどちらかで対処してください。

6

出力した帳票

個人番号フィールド情報ファイルに定義したフィールド名が帳票ファイルに定義されていないとき

不完全な帳票を出力し，適切に処分されなかったとき

個人番号フィールド情報ファイルで定義したフィールド名は，個人番号を含める帳票ファイルすべてに定義してください。

また，フィールド名を定義していない帳票ファイルを出力する場合，警告が発生しますが，問題がないことを事前に確認してから出力してください。

一部のキー情報に対応する個人番号が個人番号管理サービスに登録されていないとき

すべてのキー情報のデータに対応する個人番号が登録済みかどうかを確認してください。または，環境変数EURPS_MMS_

NOTMATCH_ERRORにON（キー情報に対応する個人番号が取得できなかったときにエラーとして帳票出力を中止する）を設定してください。

ページの先頭へ

(2)　運用上の注意事項

  • 個人番号を含む帳票を印刷した場合，情報漏えいを防ぐため，プリンタなどに放置しないようにしてください。

  • EURには帳票出力の際の認証機能はないため，個人番号を含む帳票を出力できるユーザを限定する運用としてください。

  • エンドユーザが帳票を出力する場合，ファイル暗号化鍵を入力するような運用はしないでください。ファイル暗号化鍵を誤って入力するたびに，帳票サーバでエラーが発生します。

  • 個人番号接続情報ファイルには，システム管理者だけが参照できるような適切なアクセス権を設定してください。

  • 個人番号管理サービス連携機能を使用して帳票出力する場合，個人番号管理サービスから個人番号を取得するときに暗号化処理および通信処理を行うため，通常の帳票出力よりも時間がかかります。実際にかかる時間については，事前に評価を行うことを推奨します。

  • 個人番号管理サービスに同時にアクセスできるアカウントは1つだけのため，個人番号管理サービス連携機能を使用した帳票出力は，同一の帳票サーバ上で複数同時に実行しても並列に処理されません。

  • 個人番号管理サービスは，同一アカウントによる複数ログインを禁止しているため，帳票サーバを複数台構成で運用する場合は，サーバごとに異なるアカウントの連携プロファイルを準備してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 153 / 218


11. レイアウトやデータを設定する : EUR 帳票出力 機能解説 EUR Server編

  • 154 / 218

  • 表紙

  • 11.　レイアウトやデータを設定する

11.　レイアウトやデータを設定する

この章では，帳票のレイアウトやデータなどを設定して帳票を出力する方法について説明します。

〈この章の構成〉

  • 11.1　複数様式で帳票を出力するには

  • 11.2　データベースからデータを読み込んで出力するには

  • 11.3　アイテムのデータを置き換えて出力するには

  • 11.4　印刷日時を帳票に出力するには

  • 11.5　テスト印刷用の文字列を出力するには

  • 11.6　両面印刷で常に用紙の表面に出力する対象の帳票ファイルを指定するには

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 154 / 218


11.1 複数様式で帳票を出力するには : EUR 帳票出力 機能解説 EUR Server編

  • 155 / 218

  • 表紙

  • 11.　レイアウトやデータを設定する

  • 11.1　複数様式で帳票を出力するには

11.1　複数様式で帳票を出力するには

複数の異なる様式（帳票）を一つの帳票として出力できます。これを，「複数様式で帳票を出力する」といいます。ここでは，複数様式で帳票を出力する方法について説明します。

〈この節の構成〉

  • 11.1.1　複数様式で出力できる帳票

  • 11.1.2　出力の流れ

  • 11.1.3　出力で使用するファイル

  • 11.1.4　複数の帳票セットを指定した一括出力との違い

  • 11.1.5　複数様式での帳票出力例

  • 11.1.6　コーディング例

  • 11.1.7　注意事項

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 155 / 218


11.1.1 複数様式で出力できる帳票 : EUR 帳票出力 機能解説 EUR Server編

  • 156 / 218

  • 表紙

  • 11.　レイアウトやデータを設定する

  • 11.1　複数様式で帳票を出力するには

  • 11.1.1　複数様式で出力できる帳票

11.1.1　複数様式で出力できる帳票

複数様式では，次のような帳票が出力できます。

  • 表紙・次紙構成の帳票

    表紙と次紙の2様式を一組にして出力できます。使用するデータファイルは一つです。

    出力例を次に示します。

  • 複数の様式・出力用データを組み合わせた帳票

    表紙・次紙構成の帳票のようなn様式の帳票と，別のn様式の帳票を合わせて一組に出力することもできます。n様式ごとにデータファイルを準備するので，複数のデータファイルを使用できます。

    出力例を次に示します。

  • 伝票（連票）形式の帳票

    伝票のようなn様式を一組の連票形式にして出力できます。使用するデータファイルは一つです。

    出力例を次に示します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 156 / 218


11.1.2 出力の流れ : EUR 帳票出力 機能解説 EUR Server編

  • 157 / 218

  • 表紙

  • 11.　レイアウトやデータを設定する

  • 11.1　複数様式で帳票を出力するには

  • 11.1.2　出力の流れ

11.1.2　出力の流れ

複数様式で帳票を出力する流れを，次の図に示します。

図11‒1　 複数様式で帳票を出力する流れ

[図データ]

  1. 出力要求

    帳票の出力要求が業務プログラムに送られます。

  2. 転送

    EUR Server - Adapterは，ユーザデータファイルを帳票サーバに転送します。

  3. 印刷データ生成

    転送されたユーザデータファイルと，あらかじめ帳票サーバに配置しておいた印刷定義ファイルなどの定義ファイルから，印刷データを生成します。

    印刷データのデータ形式は，EPF形式，PDF形式，およびEUR形式のどれかを出力時に指定します。なお，Excel形式のデータは出力できません。

  4. 出力

    複数様式で帳票が出力されます。

■注意

  • 複数様式で出力するときの帳票は，一組にする帳票すべてに同じキーフィールドで改ページするように設計しておいてください。

  • 帳票ヘッダのある帳票は，複数様式では出力できません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 157 / 218


11.1.3 出力で使用するファイル : EUR 帳票出力 機能解説 EUR Server編

  • 158 / 218

  • 表紙

  • 11.　レイアウトやデータを設定する

  • 11.1　複数様式で帳票を出力するには

  • 11.1.3　出力で使用するファイル

11.1.3　出力で使用するファイル

ここでは，複数様式で帳票を出力するときに使用するファイルの概要について説明します。各ファイルの指定内容の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

〈この項の構成〉

  • (1)　帳票セット指定ファイル

  • (2)　複数様式情報定義ファイル

(1)　帳票セット指定ファイル

帳票セット指定ファイルには，複数の帳票ファイルを統合する順番と帳票に読み込むデータファイルを指定します。

帳票セット指定ファイルの利用方法については，「2.3.2　帳票セット指定ファイルの利用」を参照してください。

ページの先頭へ

(2)　複数様式情報定義ファイル

複数様式情報定義ファイルには，様式（帳票フォーマット）や読み込むデータを切り替える条件と，切り替え時の動作を指定します。

なお，同じデータで出力する様式のまとまりを様式グループといいます。様式グループの中にも様式グループを定義できます。これをサブ様式グループといいます。サブ様式グループを定義すると，様式グループのデータを細かく切り分けて，それぞれ異なるフォーマットの帳票に出力できます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 158 / 218


11.1.4 複数の帳票セットを指定した一括出力との違い : EUR 帳票出力 機能解説 EUR Server編

  • 159 / 218

  • 表紙

  • 11.　レイアウトやデータを設定する

  • 11.1　複数様式で帳票を出力するには

  • 11.1.4　複数の帳票セットを指定した一括出力との違い

11.1.4　複数の帳票セットを指定した一括出力との違い

複数様式で帳票を出力した場合，複数の帳票セットを指定した一括出力ではできなかった方法で，帳票を出力できます。

複数の帳票セットを指定した一括出力との違いを次に示します。

〈この項の構成〉

  • (1)　データ単位の帳票出力

  • (2)　複数の様式で連続したページ番号の付加

(1)　データ単位の帳票出力

複数の帳票セットを指定した一括出力は，指定された帳票ファイルの順に出力されますが，複数様式での帳票出力は，データファイルのフィールドをキーブレイク対象に指定しておくことで，データ単位で帳票を出力できます。

図11‒2　 データ単位で出力した帳票例

[図データ]

ページの先頭へ

(2)　複数の様式で連続したページ番号の付加

複数の帳票セットを指定した一括出力は，帳票ファイルごとにページ番号を付けていましたが，複数様式での帳票出力は，複数の様式で連続したページ番号が付けられます。

図11‒3　 連続したページ番号の帳票例

[図データ]

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 159 / 218


11.1.5 複数様式での帳票出力例 : EUR 帳票出力 機能解説 EUR Server編

  • 160 / 218

  • 表紙

  • 11.　レイアウトやデータを設定する

  • 11.1　複数様式で帳票を出力するには

  • 11.1.5　複数様式での帳票出力例

11.1.5　複数様式での帳票出力例

EUR 帳票作成機能で提供されているサンプル帳票を基に，複数様式での帳票出力例を示します。また，サブ様式グループを指定した場合の指定例についても示します。

〈この項の構成〉

  • (1)　サンプル帳票「請求書」の場合

  • (2)　サンプル帳票「従業員勤務歴カード」の場合

  • (3)　サンプル帳票「保険申込書」の場合

  • (4)　サブ様式グループを指定した場合

(1)　サンプル帳票「請求書」の場合

「請求書」は，「表紙次紙形式の帳票＿表紙」と「表紙次紙形式の帳票＿次紙」の2様式を請求先ごとに一組にして出力します。

サンプル帳票「請求書」を出力したときの一組の帳票例を次の図に示します。

図11‒4　サンプル帳票「請求書.fms」の出力例（1ページ目）

[図データ]

図11‒5　サンプル帳票「請求書.fms」の出力例（2ページ目）

[図データ]

「表紙次紙形式の帳票＿表紙」は必ず出力します。「表紙次紙形式の帳票＿表紙」に納まらなかったデータがあるときは，「表紙次紙形式の帳票＿次紙」を出力します。「表紙次紙形式の帳票＿次紙」は，請求先のデータが同じ間出力されます。請求先のデータが変わった時点で改ページし，「表紙次紙形式の帳票＿表紙」に戻ります。

ページ番号は，2様式を通して請求先ごとのページ番号（n/m形式）を出力します。請求先のデータが変わった時点で，「表紙次紙形式の帳票＿表紙」は「1/m」に初期化されます。

(a)　サンプル帳票「請求書」を出力する手順

サンプル帳票「請求書」を出力する手順を次に示します。

  1. 帳票設計

    EUR 帳票作成機能を使って，帳票を設計します。

    帳票ファイルは，「表紙次紙形式の帳票＿表紙」と「表紙次紙形式の帳票＿次紙」の2様式を作成して，フォームシートファイル（*.fms）で保存します。

    二つの帳票は，請求先を区別するために「請求書番号」フィールドをキーにして改ページするように設定します。

    改ページの設定では，キーとなるフィールドのデータが変わった時点で，ページ番号を開始番号に初期化するか，またはキーとなるフィールドのデータが変わっても，通し番号でページ番号を印刷するかを設定できますが，この設定はどちらでもかまいません。ページ番号を初期化するかどうかは，複数様式情報定義ファイルのページ番号リセット属性（resetpagenumber）の設定が優先されます。

  2. データファイルの準備

    「表紙次紙形式の帳票＿表紙（複数様式帳票例１）.csv」を「表紙次紙形式の帳票＿表紙」と「表紙次紙形式の帳票＿次紙」で共有します。

  3. 帳票セット指定ファイルの作成

    サンプル帳票セット指定ファイル（formset01（複数様式帳票例１）.txt）の内容を次に示します。

    表紙次紙形式の帳票＿表紙（複数様式帳票例１）.fms,表紙次紙形式の帳票＿表紙（複数様式帳票例１）.csv

    表紙次紙形式の帳票＿次紙（複数様式帳票例１）.fms,表紙次紙形式の帳票＿表紙（複数様式帳票例１）.csv

  4. 複数様式情報定義ファイルの作成

    様式グループが一つなので，様式グループ遷移条件（grouptransfercondition）は省略します。

    「表紙次紙形式の帳票＿表紙」は必ず出力します。「表紙次紙形式の帳票＿次紙」は，「表紙次紙形式の帳票＿表紙」に納まらなかったデータがあるときに出力します。様式間遷移条件（formtransfercondition）で，フィールド「請求書番号」がキーブレイクしたら「表紙次紙形式の帳票＿表紙」に戻るように指定します。

    サンプル複数様式情報定義ファイル（formdef01（複数様式帳票例１）.txt）の内容を次に示します。

    group 1 {
 formtransfercondition {
   keybreaktopform=ON        …フィールド「請求書番号」が
                               キーブレイクしたら，
                               先頭の様式（表紙）に戻ります
   fieldname="請求書番号"
 }
 formfilename "表紙次紙形式の帳票＿表紙（複数様式帳票例１）.fms" {
   transfercondition=NPNF    …表紙を1ページ出力すると次紙に移ります
   printnewpaper=OFF  ※
   resetpagenumber=ON        …次紙から表紙に戻ったとき，
                               ページ番号を初期化します
 }
 formfilename "表紙次紙形式の帳票＿次紙（複数様式帳票例１）.fms" {
   transfercondition=KBNF    …キーブレイクしたら，
                               表紙に戻るようにします
   printnewpaper=OFF
   resetpagenumber=OFF       …表紙からの続きのページ番号を出力します
 }
}
    注※

    両面印刷する場合，「表紙次紙形式の帳票＿表紙」を表面に印刷したいときは，次のように指定してください。「表紙次紙形式の帳票＿次紙」に出力するデータがない場合は，裏面を白紙にします。

    printnewpaper = ON

    サンプル帳票「請求書」を両面印刷したときの，出力例を次の図に示します。

    図11‒6　 サンプル帳票「請求書.fms」を両面出力したときの出力例

    [図データ]

  5. 帳票ファイル，および複数様式情報定義ファイルの転送

    帳票ファイル，および複数様式情報定義ファイルを帳票サーバに転送します。

  6. データファイル，および帳票セット指定ファイルの転送

    データファイル，および帳票セット指定ファイルをアプリケーションサーバに転送します。

  7. 出力

    業務プログラムから帳票サーバのEUR Server Serviceを起動して，帳票を出力します。

    ■補足説明

    複数様式で出力する「表紙次紙形式の帳票」は，「表紙」と「次紙」の異なる二つの様式を一組の帳票として出力できます。

    帳票ヘッダ領域のある「表紙のある帳票」は，「表紙ページ」と「次紙ページ」で一つの様式の帳票です。そのため，表紙ページの繰り返し領域に貼り付けたデータの続きを次紙ページに出力できますが，次紙ページのページ上端やページ下端にアイテムを作成したり，貼り付けたりすることはできません。

    なお，帳票ヘッダ領域のある帳票ファイルを，複数様式で出力しようとするとエラー（KEEU048-E）となります。

ページの先頭へ

(2)　サンプル帳票「従業員勤務歴カード」の場合

「従業員勤務歴カード」は，「従業員勤務歴カード［I］」と「従業員勤務歴カード［I］（続き）」の2様式と，「従業員勤務歴カード［II］」の1様式を合わせて一組にして出力します。

サンプル帳票「従業員勤務歴カード」を出力したときの一組の帳票例を次に示します。

サンプル帳票「従業員勤務歴カード」は，従業員番号ごとに一組の帳票を出力します。

「従業員勤務歴カード［I］」は必ず出力します。「従業員勤務歴カード［I］」に納まらなかったデータがあるときは「従業員勤務歴カード［I］（続き）」を出力します。「従業員勤務歴カード［I］（続き）」を出力し終えたら，「従業員勤務歴カード［II］」の様式に移り，同じ従業員番号のデータを出力します。従業員番号のデータが変わったら「従業員勤務歴カード［I］」に戻ります。

ページ番号は，3様式を通して従業員番号ごとのページ番号（n/m形式）を出力します。従業員番号のデータが変わった時点で，「従業員勤務歴カード［I］」は「1/m」に初期化されます。

(a)　サンプル帳票「従業員勤務歴カード」を出力する手順

サンプル帳票「従業員勤務歴カード」を出力する手順を次に示します。

  1. 帳票設計

    EUR 帳票作成機能を使って，帳票を設計します。

    帳票ファイルは，「従業員勤務歴カード［I］」，「従業員勤務歴カード［I］（続き）」，および「従業員勤務歴カード［II］」の3様式を作成して，フォームシートファイル（*.fms）で保存します。

    • 従業員勤務歴１（複数様式帳票例２）.fms

    • 従業員勤務歴１－次紙（複数様式帳票例２）.fms

    • 従業員勤務歴２（複数様式帳票例２）.fms

    三つの帳票は，フィールド「従業員番号」をキーにして改ページするように設定します。

    改ページの設定では，キーとなるフィールドのデータが変わった時点で，ページ番号を開始番号に初期化するか，またはキーとなるフィールドのデータが変わっても，通し番号でページ番号を印刷するかを設定できますが，この設定はどちらでもかまいません。ページ番号を初期化するかどうかは，複数様式情報定義ファイルのページ番号リセット属性（resetpagenumber）の設定が優先されます。

  2. データファイルの準備

    n様式とn様式を組み合わせて一組の帳票に出力するには，n様式ごとのデータファイルを準備します。

    「従業員勤務歴１（複数様式帳票例２）.csv」は，「従業員勤務歴カード［I］」と「従業員勤務歴カード［I］（続き）」で共有します。

    「従業員勤務歴２（複数様式帳票例２）.csv」は，「従業員勤務歴カード［II］」で使用します。

  3. 帳票セット指定ファイルの作成

    サンプル帳票セット指定ファイル（formset02（複数様式帳票例２）.txt）の内容を次に示します。

    従業員勤務歴１（複数様式帳票例２）.fms,従業員勤務歴１（複数様式帳票例２）.csv

    従業員勤務歴１－次紙（複数様式帳票例２）.fms,従業員勤務歴１（複数様式帳票例２）.csv

    従業員勤務歴２（複数様式帳票例２）.fms,従業員勤務歴２（複数様式帳票例２）.csv

  4. 複数様式情報定義ファイルの作成

    「従業員勤務歴カード［I］」と「従業員勤務歴カード［I］（続き）」の2様式で一つの様式グループ，「従業員勤務歴カード［II］」の1様式で一つの様式グループにします。

    「従業員勤務歴カード［I］」と「従業員勤務歴カード［I］（続き）」の様式グループと，「従業員勤務歴カード［II］」の様式グループを順に出力するので，様式間遷移条件（formtransfercondition）の指定は省略します。

    様式グループ間は，フィールド「従業員番号」がキーブレイクしたら，様式グループに指定されている様式（帳票）が出力されるように，様式グループ遷移条件（grouptransfercondition）に「transfercondition=KBNF」を指定します。

    この指定によって，次のように帳票が出力されます。

    サンプル複数様式情報定義ファイル（formdef02（複数様式帳票例２）.txt）の内容を次に示します。

    group 1 {           …「従業員勤務歴カード［I］」と，
                      「従業員勤務歴カード［I］（続き）」の
                      様式グループです
 grouptransfercondition {
    transfercondition=KBNF      …二つの様式は，
                                  フィールド「従業員番号」が
                                  キーブレイクしたら，
                                  様式を切り替えます
    fieldname="従業員番号"
 }
 formfilename "従業員勤務歴１（複数様式帳票例２）.fms" {
   transfercondition=NPNF
                         …従業員勤務歴１が出力されると
                           次紙に移ります
                           次紙を出力しないで済む場合は
                           group 2の従業員勤務歴２に移ります
   printnewpaper=OFF  ※
   resetpagenumber=ON        …従業員勤務歴１を出力するときは，
                               ページ番号を初期化します
 }
 formfilename "従業員勤務歴１－次紙（複数様式帳票例２）.fms" {
   transfercondition=KBNF      …フィールド「従業員番号」が
                                 キーブレイクしたら，
                                 従業員勤務歴２に移ります
   printnewpaper=OFF
   resetpagenumber=OFF       …従業員勤務歴１からの
                               続きのページ番号を出力します
 }
}
group 2 {                   …「従業員勤務歴カード［II］」の
                              様式グループです
 grouptransfercondition {
    transfercondition=KBNF   …フィールド「従業員番号」が
                               キーブレイクしたら，group 1の
                               従業員勤務歴１に戻ります
    fieldname="従業員番号"
 }
 formfilename "従業員勤務歴２（複数様式帳票例２）.fms" {
   transfercondition=KBNF
   printnewpaper=OFF
   resetpagenumber=OFF     …従業員勤務歴１，または次紙からの
                             続きのページ番号を出力します
 }
}
    注※

    両面印刷する場合，「従業員勤務歴カード［I］」を表面に印刷したいときは，次のように指定してください。

    printnewpaper = ON

    サンプル帳票「従業員勤務歴カード」を両面印刷したときの，出力例を次の図に示します。

    図11‒7　 両面印刷の出力例

    [図データ]

  5. 帳票ファイル，および複数様式情報定義ファイルの転送

    帳票ファイル，および複数様式情報定義ファイルを帳票サーバに転送します。

  6. データファイル，および帳票セット指定ファイルの転送

    データファイル，および帳票セット指定ファイルをアプリケーションサーバに転送します。

  7. 出力

    業務プログラムから帳票サーバのEUR Server Serviceを起動して，帳票を出力します。

ページの先頭へ

(3)　サンプル帳票「保険申込書」の場合

「保険申込書」は，「保険申込書」，「保険申込書＿代理店控」，および「保険申込書＿契約者控」の3様式を一組の連票形式にして出力します。

サンプル帳票「保険申込書」を出力したときの一組の帳票例を次に示します。

サンプル帳票「保険申込書」は，契約者ごとに一組の帳票を出力します。「保険申込書」，「保険申込書＿代理店控」，「保険申込書＿契約者控」の順に一組の帳票を出力したあと，次の契約者の帳票を出力します。

ページ番号は，3様式を通して契約者ごとのページ番号（n/m形式）を出力します。契約者のデータが変わった時点で，「保険申込書」は「1/3」に初期化されます。

(a)　サンプル帳票「保険申込書」を出力する手順

サンプル帳票「保険申込書」を出力する手順を次に示します。

  1. 帳票設計

    EUR 帳票作成機能を使って，帳票を設計します。

    帳票ファイルは，「保険申込書」，「保険申込書＿代理店控」，および「保険申込書＿契約者控」の3様式を作成して，フォームシートファイル（*.fms）で保存します。

    • 保険申込書（複数様式帳票例３）.fms

    • 保険申込書＿代理店控（複数様式帳票例３）.fms

    • 保険申込書＿契約者控（複数様式帳票例３）.fms

    三つの帳票は，フィールド「契約者管理ID」をキーにして改ページするように設定します。

    改ページの設定では，キーとなるフィールドのデータが変わった時点で，ページ番号を開始番号に初期化するか，またはキーとなるフィールドのデータが変わっても，通し番号でページ番号を印刷するかを設定できますが，この設定はどちらでもかまいません。ページ番号を初期化するかどうかは，複数様式情報定義ファイルのページ番号リセット属性（resetpagenumber）の設定が優先されます。

  2. データファイルの準備

    「保険申込書（複数様式帳票例３）.csv」を，「保険申込書」，「保険申込書＿代理店控」，および「保険申込書＿契約者控」で共有します。

    1レコードが1契約者のデータになっています。

  3. 帳票セット指定ファイルの作成

    サンプル帳票セット指定ファイル（formset03（複数様式帳票例３）.txt）の内容を次に示します。

    保険申込書（複数様式帳票例３）.fms,保険申込書（複数様式帳票例３）.csv

    保険申込書＿代理店控（複数様式帳票例３）.fms,保険申込書（複数様式帳票例３）.csv

    保険申込書＿契約者控（複数様式帳票例３）.fms,保険申込書（複数様式帳票例３）.csv

  4. 複数様式情報定義ファイルの作成

    「保険申込書」は，「保険申込書」，「保険申込書＿代理店控」，および「保険申込書＿契約者控」の3様式を一組の連票形式にして出力します。

    データファイルは一つですが，様式ごとにレコードのデータを読み込むので，様式グループは三つになります。

    様式グループは三つですが，3様式を必ず出力するので，様式グループ遷移条件（grouptransfercondition）の指定は省略します。

    1様式グループ1様式であることと，フィールド「契約者管理ID」がキーブレイクしたら次の様式グループに移るように指定するので，様式間遷移条件（formtransfercondition）の指定は省略します。

    サンプル複数様式情報定義ファイル（formdef03（複数様式帳票例３）.txt）の内容を次に示します。

    group 1 {
 formfilename "保険申込書（複数様式帳票例３）.fms" {
   transfercondition=KBNF     …キーブレイクしたら，
                                group 2の代理店控に移ります
   printnewpaper=OFF
   resetpagenumber=ON        …保険申込書を出力するときは，
                               ページ番号を初期化します
 }
}
group 2 {
 formfilename "保険申込書＿代理店控（複数様式帳票例３）.fms" {
   transfercondition=KBNF    …キーブレイクしたら，
                               group 3の契約者控に移ります
   printnewpaper=OFF
   resetpagenumber=OFF     …前の様式からの続きのページ番号を
                             出力します
 }
}
group 3 {
 formfilename "保険申込書＿契約者控（複数様式帳票例３）.fms" {
   transfercondition=KBNF   …キーブレイクしたら，
                              group 1の保険申込書に戻ります
   printnewpaper=OFF
   resetpagenumber=OFF     …前の様式からの続きのページ番号を
                             出力します
 }
}

  5. 帳票ファイル，および複数様式情報定義ファイルの転送

    帳票ファイル，および複数様式情報定義ファイルを帳票サーバに転送します。

  6. データファイル，および帳票セット指定ファイルの転送

    データファイル，および帳票セット指定ファイルをアプリケーションサーバに転送します。

  7. 出力

    業務プログラムから帳票サーバのEUR Server Serviceを起動して，帳票を出力します。

ページの先頭へ

(4)　サブ様式グループを指定した場合

サブ様式グループを指定した複数様式の帳票の出力時に指定する，複数様式情報定義ファイルの指定例を示します。

group 1 {             …「sample1」の様式グループです
   grouptransfercondition {
       transfercondition=KBNF     …フィールド「A」がキーブレイクしたら，
                                    様式を切り替えます
       fieldname="A"
   }
   formfilename "sample1.fms" {
       transfercondition=NPNF        …sample1が出力されると
                                       subgroup 1のsample2に移ります
       printnewpaper=OFF
       resetpagenumber=ON     …sample1の出力時は，
                                ページ番号を初期化します
   }
}
group 2 {             …「sample2」と「sample3」の
                        様式グループです
   grouptransfercondition {
       transfercondition=KBNF     …フィールド「A」がキーブレイクしたら，
                                    group 1のsample1に戻ります。
       fieldname="A"
   }
   subgroup 1 {       …「sample2」の
                        サブ様式グループです
       grouptransfercondition {
           transfercondition=KBNF    …フィールド「B」がキーブレイクしたら，
                                       様式を切り替えます
           fieldname="B"
       }
       formfilename "sample2.fms" {
           transfercondition=NPNF     …sample2が出力されると
                                        subgroup 2のsample3に移ります
           printnewpaper=OFF
           resetpagenumber=ON     …sample2の出力時は，
                                    ページ番号を初期化します
       }
   }
   subgroup 2 {       …「sample3」の
                        サブ様式グループです
       grouptransfercondition {
           transfercondition=KBNF     …フィールド「B」が
                                        キーブレイクしたら，group 1の
                                        sample1に戻ります
           fieldname="B"
       }
       formfilename "sample3.fms" {
           transfercondition=NPNF
           printnewpaper=OFF
           resetpagenumber=ON     …sample3の出力時は，
                                    ページ番号を初期化します
       }
   }
}

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 160 / 218


11.1.6 コーディング例 : EUR 帳票出力 機能解説 EUR Server編

  • 161 / 218

  • 表紙

  • 11.　レイアウトやデータを設定する

  • 11.1　複数様式で帳票を出力するには

  • 11.1.6　コーディング例

11.1.6　コーディング例

次に示すパラメタを指定して，スプールサーバで印刷します。

■入力ファイル（印刷定義ファイル）：EUR Server Service稼働マシンに配置

複数様式情報定義ファイル名：MULTIFORMINFO1.txt

■入力ファイル（ユーザデータファイル）：EUR Server - Adapter稼働マシンに配置

帳票セット指定ファイル名：REPORTSET1.txt ※

■そのほかのパラメタ

印刷ページ範囲：すべて

注※

帳票セット指定ファイルで指定する帳票ファイルは，EUR Server Service稼働マシンに配置しておきます。また，帳票セット指定ファイルで指定するユーザデータファイルは，EUR Server - Adapterがインストールされたマシンに配置しておきます。

コーディング例を次に示します。

〈この項の構成〉

  • (1)　COBOL起動部品の場合

(1)　COBOL起動部品の場合

       IDENTIFICATION DIVISION.
       PROGRAM-ID.
       COBOLSAMPLE.
       ENVIRONMENT DIVISION.
       CONFIGURATION SECTION.
       SPECIAL-NAMES.
           CDECL IS CDECL.
       EXTERNAL-PROGRAM SECTION.
       CALL-CONVENTION.
           'PrintReport' IS CDECL.
       DATA DIVISION.
       WORKING-STORAGE SECTION.
       01 EURPMPARAM.
       COPY 'EURPMPARAM1.cbl'
       01 RTNCODE                PIC S9(9) BINARY.

       PROCEDURE DIVISION.
       PROC1 SECTION.
           MOVE SPACE TO PRINTERNAME.
           MOVE SPACE TO TRAYNAME.
           MOVE ZERO TO PRINTSTARTPAGE.
           MOVE ZERO TO PRINTENDPAGE.
           MOVE 'REPORTSET1.txt' TO REPORTSETFILE.
           MOVE 'MULTIFORMINFO1.txt' TO MULTIFORMINFO.
           MOVE SPACE TO REPORTNAME.
           MOVE SPACE TO MAPPINGDATA.
           MOVE SPACE TO USERDEFDATA.

           CALL 'PrintReport' USING BY REFERENCE EURPMPARAM
                              RETURNING RTNCODE.

           EXIT PROGRAM.

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 161 / 218


11.1.7 注意事項 : EUR 帳票出力 機能解説 EUR Server編

  • 162 / 218

  • 表紙

  • 11.　レイアウトやデータを設定する

  • 11.1　複数様式で帳票を出力するには

  • 11.1.7　注意事項

11.1.7　注意事項

  • 複数様式を使用する場合，一度に多数の帳票ファイル，マッピングデータファイル，ユーザ定義データファイルを指定すると，エラー（KEEU005-EまたはKEEU006-E）が発生します。この場合，一度に使用する帳票ファイル，マッピングデータファイル，およびユーザ定義データファイルの数を減らすか，複数回に分けて実行してください。

  • 複数様式定義ファイルでtraycode（給紙トレイ番号）キーワードを使用する場合は，次のどちらかの方法で帳票を出力してください。スプールサーバのプリンタでEPF形式ファイルの帳票を出力する場合は，traycodeキーワードは無視されます。

    • 帳票サーバのプリンタに出力する（参照先：3.1.1）

    • スプールサーバのプリンタでEUR形式ファイルの帳票を出力する（参照先：3.1.3）

    なお，複数様式定義ファイルでtraycodeキーワードを定義した場合，EUR Server Serviceから指定するトレイ名，およびプリンタクラスで定義されたトレイ名は無効になります。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 162 / 218


11.2 データベースからデータを読み込んで出力するには : EUR 帳票出力 機能解説 EUR Server編

  • 163 / 218

  • 表紙

  • 11.　レイアウトやデータを設定する

  • 11.2　データベースからデータを読み込んで出力するには

11.2　データベースからデータを読み込んで出力するには

データベースからデータを読み込んで帳票を出力できます。EUR サーバ帳票出力機能からアクセスできるデータベースと，英語，中国語ロケールでの使用可否を次の表に示します。

表11‒1 アクセスできるデータベースと，英語，中国語ロケールでの使用可否
データベース | 英語，中国語ロケールでの使用可否
HiRDB | ×
Oracle | ○
SQL Server | ×
（凡例）

○：使用できます。

×：使用できません。

なお，すべての帳票セットのマッピングデータおよびユーザ定義データの入力元として指定できるデータベースは，一つだけです。

システム管理者は，DABrokerを使用して，データベースに接続するためのデータソースや，データベースに初めて接続する前に，接続に必要な環境を設定します。データベースの接続設定については，マニュアル「EUR データベース連携ガイド」を参照してください。

〈この節の構成〉

  • 11.2.1　出力の流れ

  • 11.2.2　出力で使用するファイル

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 163 / 218


11.2.1 出力の流れ : EUR 帳票出力 機能解説 EUR Server編

  • 164 / 218

  • 表紙

  • 11.　レイアウトやデータを設定する

  • 11.2　データベースからデータを読み込んで出力するには

  • 11.2.1　出力の流れ

11.2.1　出力の流れ

データベースからデータを読み込んで帳票を出力する流れを，次の図に示します。

図11‒8　 データベースからデータを読み込んで出力する流れ

[図データ]

  1. 出力要求

    帳票の出力要求が業務プログラムに送られます。

  2. 転送

    EUR Server - Adapterは，ユーザデータファイルを帳票サーバに転送します。

  3. 入力データ取得

    データベースに接続して帳票の入力データを取得します。

    データベースからデータを取得するには，次に示す両方のファイルの指定が必要です。

    • 接続情報ファイル

    • 可変記号値定義ファイル

  4. 印刷データ生成

    データベースから取得した帳票の入力データと，あらかじめ帳票サーバに配置しておいた印刷定義ファイルなどの定義ファイルから，印刷データを生成します。

    印刷データのデータ形式は，EPF形式，PDF形式，EUR形式，およびExcel形式のどれかを出力時に指定します。

  5. 出力

    帳票が出力されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 164 / 218


11.2.2 出力で使用するファイル : EUR 帳票出力 機能解説 EUR Server編

  • 165 / 218

  • 表紙

  • 11.　レイアウトやデータを設定する

  • 11.2　データベースからデータを読み込んで出力するには

  • 11.2.2　出力で使用するファイル

11.2.2　出力で使用するファイル

ここでは，データベースからデータを読み込んで帳票を出力するときに使用するファイルの概要について説明します。各ファイルの指定内容の詳細については，マニュアル「EUR データベース連携ガイド」を参照してください。

〈この項の構成〉

  • (1)　接続情報ファイル

  • (2)　可変記号値定義ファイル

(1)　接続情報ファイル

接続情報ファイルには，データベースと接続するために必要な情報を指定します。

接続情報ファイルは，一つの接続先について一つ作成します。EUR サーバ帳票出力機能の実行時には，接続情報ファイルを一つだけ指定できます。

接続情報ファイルに指定する項目を次に示します。

  • DABrokerのホスト名またはIPアドレス

  • データベースの種別（HiRDB，Oracle，またはSQLServer）

  • 送受信領域サイズ

  • 応答監視時間

  • データベースホスト名

  • データベース識別子

  • ユーザID

  • パスワード（暗号化したパスワードも指定可能）

  • 排他オプション

ページの先頭へ

(2)　可変記号値定義ファイル

可変記号値定義ファイルには，データベースからデータを検索し，条件に合ったデータを抽出するときに必要な，検索条件の可変記号とその値（可変記号値）を指定します。可変記号は，条件式の条件値だけを変更する場合に使います。

帳票を設計したときに設定された可変記号に，可変記号値を定義することで，条件に合った抽出データで帳票を出力できます。接続情報ファイルと組み合わせて使用します。

可変記号値定義ファイルは，一つの帳票ファイルに対して，マッピングデータ用とユーザ定義データ用にそれぞれ一つずつ作成できます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 165 / 218


11.3 アイテムのデータを置き換えて出力するには : EUR 帳票出力 機能解説 EUR Server編

  • 166 / 218

  • 表紙

  • 11.　レイアウトやデータを設定する

  • 11.3　アイテムのデータを置き換えて出力するには

11.3　アイテムのデータを置き換えて出力するには

帳票の文字列アイテムまたは数値アイテムのデータを，指定したデータに置き換えて出力できます。空データへの置き換えもできます。

〈この節の構成〉

  • 11.3.1　出力で使用するファイル

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 166 / 218


11.3.1 出力で使用するファイル : EUR 帳票出力 機能解説 EUR Server編

  • 167 / 218

  • 表紙

  • 11.　レイアウトやデータを設定する

  • 11.3　アイテムのデータを置き換えて出力するには

  • 11.3.1　出力で使用するファイル

11.3.1　出力で使用するファイル

ここでは，アイテムのデータを置き換えて帳票を出力するときに使用するファイルの概要について説明します。各ファイルの指定内容の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

〈この項の構成〉

  • (1)　置き換え表管理情報ファイル

  • (2)　置き換え表ファイル

(1)　置き換え表管理情報ファイル

置き換え表管理情報ファイルには，帳票を設計したときに設定された置き換え表名と，置き換え表ファイルの対応を指定します。置き換え表管理情報ファイルは，CSV形式で作成します。

ページの先頭へ

(2)　置き換え表ファイル

置き換え表ファイルには，アイテムのデータを置き換えて出力する場合に，1フィールドごとの置き換え対象のデータと，置き換えて出力するデータを指定します。置き換え表ファイルは，CSV形式で作成します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 167 / 218


11.4 印刷日時を帳票に出力するには : EUR 帳票出力 機能解説 EUR Server編

  • 168 / 218

  • 表紙

  • 11.　レイアウトやデータを設定する

  • 11.4　印刷日時を帳票に出力するには

11.4　印刷日時を帳票に出力するには

プリンタでの印刷実行時の日時情報を帳票に出力できます。

プリンタでの印刷実行時の日時情報は，印刷領域に出力されます。印刷領域とは，印刷用紙からプリンタのハードマージンを除いた領域のことです。印刷領域と日時情報の出力位置との関係を，次の図に示します。

図11‒9　印刷領域と日時情報の出力位置との関係

[図データ]

なお，日時情報は帳票出力時にEPF形式の印刷データを生成する場合に出力できます。PDF形式，EUR形式，またはExcel形式の印刷データを生成する場合は出力できません。

〈この節の構成〉

  • 11.4.1　日時情報に出力できる文字列

  • 11.4.2　出力で使用するファイル

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 168 / 218


11.4.1 日時情報に出力できる文字列 : EUR 帳票出力 機能解説 EUR Server編

  • 169 / 218

  • 表紙

  • 11.　レイアウトやデータを設定する

  • 11.4　印刷日時を帳票に出力するには

  • 11.4.1　日時情報に出力できる文字列

11.4.1　日時情報に出力できる文字列

日時情報には，259文字までの文字列を出力できます。印刷時の日時に合わせて変換が必要な文字列は，次の表に示すように書式指定コードで指定します。

表11‒2　書式指定コード

項番

書式指定コード

説明

変換後の値の例

備考

1

%a

曜日（省略形）
日本語環境

日

英語環境

Sun

－

2

%A

曜日
日本語環境

日曜日

英語環境

Sunday

－

3

%b

月（省略形）
日本語環境

1

英語環境

Jan

－

4

%B

月
日本語環境

1月

英語環境

January

－

5

%c

日付と時刻
日本語環境

2010/08/24 10:48:30

英語環境

08/24/10 10:48:30

「%x %X」を指定した場合と同じです。

6

%#c

日付※1と時刻

日本語環境

2010年8月24日 10:48:30

英語環境

Tuesday, August 24, 2010 10:48:30

「%#x %X」を指定した場合と同じです。

7

%d

日

01

－

8

%#d

日※2

1

－

9

%H

時間（24時間表記）

01

－

10

%#H

時間（24時間表記）※2

1

－

11

%I

時間（12時間表記）

01

－

12

%#I

時間（12時間表記）※2

1

－

13

%m

月（10進数）

01

－

14

%#m

月（10進数）※2

1

－

15

%M

分（10進数）

01

－

16

%#M

分（10進数）※2

1

－

17

%p

午前または午後
日本語環境

午前

英語環境

AM

－

18

%S

秒（10進数）

01

－

19

%#S

秒（10進数）※2

1

－

20

%x

日付
日本語環境

2010/08/24

英語環境

08/24/10
日本語環境

「%y/%m/%d」を指定した場合と同じです。

英語環境

「%m/%d/%y」を指定した場合と同じです。

21

%#x

日付※1
日本語環境

2010年8月24日

英語環境

Tuesday, August 24, 2010
日本語環境

「%Y年%B%#d日」を指定した場合と同じです。

英語環境

「%A, %B %d, %Y」を指定した場合と同じです。

22

%X

時刻

10:48:30

「%H:%M:%S」を指定した場合と同じです。

23

%y

西暦（下2桁）

05

－

24

%#y

西暦（下2桁）※2

5

－

25

%Y

西暦（4桁）

0794

－

26

%#Y

西暦（4桁）※2

794

－

27

%%

パーセント記号

%

－
注※1

英語環境の場合は，曜日の情報を含みます。

注※2

値が規定の桁数に満たない場合，頭に「0」を付けません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 169 / 218


11.4.2 出力で使用するファイル : EUR 帳票出力 機能解説 EUR Server編

  • 170 / 218

  • 表紙

  • 11.　レイアウトやデータを設定する

  • 11.4　印刷日時を帳票に出力するには

  • 11.4.2　出力で使用するファイル

11.4.2　出力で使用するファイル

ここでは，プリンタでの印刷実行時の日時情報を帳票に出力するときに使用するファイルの概要について説明します。各ファイルの指定内容の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

〈この項の構成〉

  • (1)　印刷日時出力定義ファイル

(1)　印刷日時出力定義ファイル

印刷日時出力定義ファイルには，プリンタでの印刷実行時の日時情報を帳票に出力するために必要な情報を指定します。

日時情報として出力する文字列について，次の内容を指定できます。

  • 文字列の内容

  • 文字のフォント名

  • 文字の大きさ

  • 文字列の出力位置

  • 文字の色

■作成した印刷日時出力定義ファイルの指定方法

作成した印刷日時出力定義ファイルは，EUR Server Serviceが稼働するマシンに配置してください。また，印刷実行時にファイルの格納先を指定してください。ファイルの格納先の指定方法は，印刷ジョブごとに指定するか，EUR Server Serviceのサービスごとに指定するかによって次のとおり異なります。

  • 印刷ジョブごとに指定する場合

    使用する起動部品で印刷日時出力定義ファイル名およびパスを指定します。

  • EUR Server Serviceのサービスごとに指定する場合

    EUR Server Serviceの環境設定ファイル（EURPM.ini）で，印刷日時出力定義ファイルを格納したフォルダを指定します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 170 / 218


11.5 テスト印刷用の文字列を出力するには : EUR 帳票出力 機能解説 EUR Server編

  • 171 / 218

  • 表紙

  • 11.　レイアウトやデータを設定する

  • 11.5　テスト印刷用の文字列を出力するには

11.5　テスト印刷用の文字列を出力するには

テスト印刷用の文字列を帳票に出力できます。テスト印刷用の文字列を帳票に出力することで，テスト印刷で出力した帳票の不正使用を防げます。

テスト印刷用の文字列を出力した帳票のイメージを次の図に示します。

図11‒10　テスト印刷用の文字列を出力した帳票のイメージ

[図データ]

線アイテムと文字アイテムはテスト印刷用の文字列よりも上に出力されるため，テスト印刷用の文字列に隠れることはありません。図形と画像はテスト印刷用の文字列に隠れます。これは，異なる種別のアイテムの重なりの順序に決まりがあり，テスト印刷用の文字列は図形アイテムと線アイテムの中間に出力されるためです。アイテムの重なりの詳細については，マニュアル「EUR 帳票作成 操作ガイド」を参照してください。

なお，テスト印刷用の文字列は，帳票をプリンタ出力する場合や，帳票出力時にEPF形式，PDF形式，またはEUR形式の印刷データを生成する場合に出力できます。Excel形式の印刷データを生成する場合は出力できません。

■参考

帳票を設計しているクライアント環境でサーバからの帳票出力テストを実施したい場合は，EUR DeveloperのEUR サーバ帳票出力機能を使用してください。

〈この節の構成〉

  • 11.5.1　出力で使用するファイル

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 171 / 218


11.5.1 出力で使用するファイル : EUR 帳票出力 機能解説 EUR Server編

  • 172 / 218

  • 表紙

  • 11.　レイアウトやデータを設定する

  • 11.5　テスト印刷用の文字列を出力するには

  • 11.5.1　出力で使用するファイル

11.5.1　出力で使用するファイル

ここでは，テスト印刷用の文字列を帳票に出力するときに使用するファイルの概要について説明します。各ファイルの指定内容の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

〈この項の構成〉

  • (1)　テスト印刷設定ファイル

(1)　テスト印刷設定ファイル

テスト印刷設定ファイルには，テスト印刷用の文字列を帳票に出力するための情報を指定します。

テスト印刷用の文字列について，次の内容を指定できます。

  • 文字列の内容

  • 文字のフォント名

  • 文字の大きさ

  • 文字列の出力位置

  • 文字の色

  • 日付／時刻の書式

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 172 / 218


11.6 両面印刷で常に用紙の表面に出力する対象の帳票ファイルを指定するには : EUR 帳票出力 機能解説 EUR Server編

  • 173 / 218

  • 表紙

  • 11.　レイアウトやデータを設定する

  • 11.6　両面印刷で常に用紙の表面に出力する対象の帳票ファイルを指定するには

11.6　両面印刷で常に用紙の表面に出力する対象の帳票ファイルを指定するには

帳票様式に応じて，両面印刷で常に用紙の表面（奇数ページ）に出力する対象の帳票ファイルを指定できます。ここでは，常に表面に出力する対象の帳票ファイルを指定する方法について説明します。

●単一様式帳票，または帳票セットを複数指定した帳票の場合

新規用紙出力定義ファイルで，帳票ファイルごとに常に用紙の表面に出力する対象の帳票ファイルを指定できます。

両面印刷する場合，指定した対象の帳票ファイルが常に用紙の表面になるように空白ページが挿入されます。常に表面に出力するページには，次の2種類があります。

  • 帳票の先頭ページ※

  • 帳票セットを複数指定した帳票の各帳票ファイルの1ページ目

注※

先頭ページは，帳票作成機能の［レポートのプロパティ］ダイアログの［レポートの構成］タブにある［先頭・最終ページの範囲］グループボックスで定義した範囲によって，次のように異なります。

  • 定義した範囲が「キーブレイクによる改ページで区切られた範囲」の場合

    すべてのデータが出力された最初のページ，およびキーブレイクによって改ページされたページ

  • 定義した範囲が「ページ番号の初期化の指定で区切られた範囲」の場合

    すべてのデータが出力された最初のページ，およびページ番号が初期化されたページ

新規用紙出力定義ファイルの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

●複数様式帳票の場合

複数様式情報定義ファイルのキーワードprintnewpaperで，様式ごとに様式の1ページ目を常に用紙の表面に出力するかどうかを指定できます。

両面印刷する場合，キーワードprintnewpaperに「ON」を指定した様式の1ページ目が常に用紙の表面になるように空白ページが挿入されます。

複数様式情報定義ファイルの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 173 / 218


12. 属性情報を設定する : EUR 帳票出力 機能解説 EUR Server編

  • 174 / 218

  • 表紙

  • 12.　属性情報を設定する

12.　属性情報を設定する

この章では，帳票の属性情報の設定について説明します。

〈この章の構成〉

  • 12.1　属性情報の種類と設定方法

  • 12.2　属性情報の利用例

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 174 / 218


12.1 属性情報の種類と設定方法 : EUR 帳票出力 機能解説 EUR Server編

  • 175 / 218

  • 表紙

  • 12.　属性情報を設定する

  • 12.1　属性情報の種類と設定方法

12.1　属性情報の種類と設定方法

ここでは，帳票を出力するときに設定できる，属性情報の種類と設定方法について説明します。

〈この節の構成〉

  • 12.1.1　プリンタに出力する場合

  • 12.1.2　PDF形式ファイルに出力する場合

  • 12.1.3　EUR形式ファイルに出力する場合

  • 12.1.4　スプールデータに出力する場合

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 175 / 218


12.1.1 プリンタに出力する場合 : EUR 帳票出力 機能解説 EUR Server編

  • 176 / 218

  • 表紙

  • 12.　属性情報を設定する

  • 12.1　属性情報の種類と設定方法

  • 12.1.1　プリンタに出力する場合

12.1.1　プリンタに出力する場合

帳票をプリンタに出力する場合，属性情報として「出力先に表示する帳票名」を設定できます。設定した帳票名はプリンタスプールのジョブ名として，プリンタの印刷待ち状態を確認する一覧ウィンドウの「ドキュメント名」や，通信／ジョブ状態を示す確認画面などに表示されます。ただし，帳票名に表示される文字列は，259文字までです。

属性情報の「出力先に表示する帳票名」に設定される値の優先順位は次のとおりです。

指定内容の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

  1. 印刷先定義ファイルのSpoolTitleキーの指定値（蓄積仕分け出力または分割出力の場合）

  2. 起動部品で指定したスプールタイトルの指定値

    • ActiveX起動部品：SpoolTitleプロパティ

    • Java起動部品：setSpoolTitleメソッド

    • COBOL起動部品：SPOOLTITLEパラメタ

    • コマンド起動部品（eurpmcコマンド）：/sptlオプション

  3. 文書情報設定ファイルのTITLEキーの指定値

  4. 「HITACHI Report - 帳票ファイル名」※

注※

表示される文字列は，Shift JISコードでのバイト数で31バイトまでです。帳票ファイル名が長くて31バイトを超える場合は，31バイトまでを表示します。31バイト目が2バイト文字の場合は，30バイトまでの文字列を表示します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 176 / 218


12.1.2 PDF形式ファイルに出力する場合 : EUR 帳票出力 機能解説 EUR Server編

  • 177 / 218

  • 表紙

  • 12.　属性情報を設定する

  • 12.1　属性情報の種類と設定方法

  • 12.1.2　PDF形式ファイルに出力する場合

12.1.2　PDF形式ファイルに出力する場合

PDF形式ファイルに出力する場合，属性情報として「PDF文書情報」を設定できます。設定内容を次の表に示します。なお，一部の項目については，文書情報設定ファイルで指定します。指定内容の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

表12‒1 PDF文書情報の設定内容
項目 | 設定内容 | 設定方法 | 説明
タイトル | タイトルの文字列 | 文書情報設定ファイルのTITLEキーで設定します。 | 文書情報設定ファイルを指定しない場合や，キーワードの指定を省略した場合は，PDF文書情報は空表示になります。
サブタイトル | サブタイトルの文字列 | 文書情報設定ファイルのSUBTITLEキーで設定します。
作成者 | ファイルの作成者 | 文書情報設定ファイルのAUTHORキーで設定します。
キーワード | キーワード | 文書情報設定ファイルのKEYWORDキーで設定します。
作成（Creator） | Windows EUR（形名） VV-RR | 自動で設定されます。 | 帳票を作成したEURの製品・バージョン番号が設定されます。VV-RRは，バージョン，リビジョン番号です。
PDF変換（Producer） | EUR Print Service VVRR | 自動で設定されます。 | PDF形式ファイルを出力した製品名が設定されます。VVRRは，バージョン，リビジョン番号です。
作成日時 | PDF形式ファイルの作成日時 | 自動で設定されます。 | －

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 177 / 218


12.1.3 EUR形式ファイルに出力する場合 : EUR 帳票出力 機能解説 EUR Server編

  • 178 / 218

  • 表紙

  • 12.　属性情報を設定する

  • 12.1　属性情報の種類と設定方法

  • 12.1.3　EUR形式ファイルに出力する場合

12.1.3　EUR形式ファイルに出力する場合

EUR形式ファイルに出力する場合，属性情報として「出力先に表示する帳票名」を設定できます。設定した帳票名は，プリンタの印刷待ち状態を確認する一覧ウィンドウの「ドキュメント名」や，プレビューウィンドウに表示されます。

属性情報の「出力先に表示する帳票名」に設定される値の優先順位は次のとおりです。

指定内容の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

  1. 起動部品で指定したスプールタイトルの指定値

    • ActiveX起動部品：SpoolTitleプロパティ

    • Java起動部品：setSpoolTitleメソッド

    • COBOL起動部品：SPOOLTITLEパラメタ

    • コマンド起動部品（eurpmcコマンド）：/sptlオプション

  2. 文書情報設定ファイルのTITLEキーの指定値

  3. 次に示す表示形式

    • 単一様式帳票の場合

      「HITACHI Report - EUR形式ファイル名（拡張子なし）」

    • 帳票セットを複数指定した帳票，または複数様式帳票の場合

      「EUR形式ファイル名（拡張子なし）」

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 178 / 218


12.1.4 スプールデータに出力する場合 : EUR 帳票出力 機能解説 EUR Server編

  • 179 / 218

  • 表紙

  • 12.　属性情報を設定する

  • 12.1　属性情報の種類と設定方法

  • 12.1.4　スプールデータに出力する場合

12.1.4　スプールデータに出力する場合

スプールデータの属性情報は，帳票の蓄積時に起動部品または印刷先定義ファイルで設定します。ただし，印刷先定義ファイルで属性情報を設定できるのは，帳票を分割または仕分けして蓄積する場合だけです。

スプールデータに設定できる属性情報を次の表に示します。

表12‒2 スプールデータに設定できる属性情報
項番 | 属性情報 | 起動部品 | 印刷先定義ファイル
1 | スプールデータに格納された印刷データのファイル名 | ○ | ○
2 | 蓄積期限日 | ○ | ×
3 | スプールデータに格納された印刷データの取得可否 | ○ | ○
4 | 印刷上限回数 | ○ | ○
5 | 実行できる印刷方式 | ○ | ○
6 | プリンタクラス名 | ○ | ○
7 | プリンタ名 | ○ | ○
8 | トレイ名 | ○ | ○
9 | プリンタ指定方法 （スプールサーバに出力する場合） | ○ | ○
10 | 帳票振り分け定義の振り分けグループ名 （スプールサーバに出力する場合） | ○ | ○
11 | ダイアログ表示モード （クライアントPCに出力する場合） | ○ | ○
12 | クライアントPCのIPアドレス （クライアントPCに出力する場合） | ○ | ○
13 | ジョブ検索キー（検索用のキー情報）の分類 | ○ | ○
14 | ジョブ検索キー（検索用のキー情報）の値 | ○ | ○
15 | スプールタイトル | ○ | ○
（凡例）

○：設定できます。

×：設定できません。

なお，起動部品と印刷先定義ファイルでは，印刷先定義ファイルの設定が優先されます。印刷先定義ファイルについては，「6.1.3(2)(b)　印刷先定義ファイル」を参照してください。

また，スプールデータに設定した属性情報を取得したり，変更したりすることもできます。詳細については「13.　スプールデータを管理するには」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 179 / 218


12.2 属性情報の利用例 : EUR 帳票出力 機能解説 EUR Server編

  • 180 / 218

  • 表紙

  • 12.　属性情報を設定する

  • 12.2　属性情報の利用例

12.2　属性情報の利用例

ここでは，帳票を蓄積するときに設定した属性情報の利用例について説明します。

〈この節の構成〉

  • 12.2.1　帳票にアクセスできるユーザを制限する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 180 / 218


12.2.1 帳票にアクセスできるユーザを制限する : EUR 帳票出力 機能解説 EUR Server編

  • 181 / 218

  • 表紙

  • 12.　属性情報を設定する

  • 12.2　属性情報の利用例

  • 12.2.1　帳票にアクセスできるユーザを制限する

12.2.1　帳票にアクセスできるユーザを制限する

スプールデータに設定した属性情報（ジョブ検索キーの分類と値）と，ユーザ定義とを組み合わせることで，帳票管理GUIでスプールデータを操作するユーザを制限できます。

ユーザ定義には，スプールデータを操作するユーザごとに，アクセスできるスプールデータの条件を定義します。

帳票管理GUIでスプールデータを操作するユーザを制限する場合，ユーザ定義には次の情報を定義します。

  • ユーザ認証情報

    ユーザ名と確認キーを定義します。

  • スプールデータに対するアクセス制限情報

    アクセス制限情報には，次の4種類があります。

    • アクセス制限方式

    • アクセスを許可するスプールデータの属性情報

    • ユーザ名が一致するスプールデータのアクセス可否

    • アクセスを許可する分類名がジョブ検索キーに設定されていないスプールデータのアクセス可否

なお，ユーザ定義のユーザ認証情報を使用する代わりに，LDAPサーバと連携してスプールデータを操作するユーザを制限することもできます。LDAPサーバと連携する場合の設定内容については，マニュアル「EUR システム設計ガイド」を参照してください。

〈この項の構成〉

  • (1)　定義する情報とアクセス制限との関係

  • (2)　アクセス制限の例

  • (3)　アクセス制限を実施するには

(1)　定義する情報とアクセス制限との関係

スプールデータに設定した属性情報（ジョブ検索キーの分類と値）が，ユーザ定義の定義内容と一致すると，条件に一致するスプールデータにアクセスできます。

存在しないユーザ名を指定した場合，または指定したユーザ名と確認キーがユーザ定義の内容と一致しなかった場合は，デフォルトユーザとしてスプールデータにアクセスします。デフォルトユーザとは，アクセス制限の対象としないスプールデータにアクセスするための最低限の権限を持つユーザのことです。

ページの先頭へ

(2)　アクセス制限の例

スプールデータの属性情報を使用したアクセス制限の例を次に示します。

  • スプールデータの属性情報

    帳票管理GUIで管理しているスプールデータの属性情報を，次の表に示します。

    表12‒3　スプールデータの属性情報の設定内容

    ファイル名

    ジョブ検索キー

    分類1

    値1

    分類2

    値2

    ファイルA

    ユーザ名

    管理者

    －

    －

    ファイルB

    ユーザ名

    管理者

    公開先

    部内

    ファイルC

    ユーザ名

    管理者

    公開先

    社内

    ファイルD

    ユーザ名

    リーダー

    －

    －

    ファイルE

    ユーザ名

    リーダー

    公開先

    部内

    ファイルF

    ユーザ名

    リーダー

    公開先

    社内

    ファイルG

    －

    －

    －

    －
    （凡例）

    －：属性情報がありません。

  • ユーザ定義

    ユーザ定義を次の表に示すように定義します。

    表12‒4　ユーザ定義の定義内容

    ユーザ認証情報

    アクセス制限方式

    アクセスを許可する属性情報※

    ユーザ名が一致するスプールデータの場合

    アクセスを許可する分類名がジョブ検索キーに設定されていない場合

    ユーザ認証に使用する分類名

    ユーザ名

    分類名

    キー値

    ユーザ名

    管理者

    分類

    公開先

    部内

    社内

    ○

    ×

    ユーザ名

    リーダー

    分類

    公開先

    社内

    △

    ○
    （凡例）

    ○：アクセスできるようにします。

    △：ユーザ名が一致するかどうかに関係なく，指定したアクセス制限方式で，対象になるスプールデータにアクセスできるようにします。

    ×：アクセスできないようにします。

    注※

    分類名はスプールデータのジョブ検索キーの分類に，キー値はジョブ検索キーの値に，それぞれ対応します。

(a)　ファイルのアクセス可否

  • ユーザ名が「管理者」のユーザ

    次のどちらかの条件を満たすスプールデータにアクセスできます。

    • ユーザ名が一致するスプールデータ

    • 「公開先」の値が「部内」と「社内」のスプールデータ

    そのため，「ファイルA」，「ファイルB」，「ファイルC」，「ファイルE」，および「ファイルF」にアクセスできます。

  • ユーザ名が「リーダー」のユーザ

    次のどちらかの条件を満たすスプールデータにアクセスできます。

    • 「公開先」の値が「社内」のスプールデータ（ユーザ名が一致するかどうかは関係ありません）

    • 「公開先」がジョブ検索キーに設定されていないスプールデータ

    そのため，「ファイルA」，「ファイルC」，「ファイルD」，「ファイルF」，および「ファイルG」にアクセスできます。

ページの先頭へ

(3)　アクセス制限を実施するには

ユーザ認証情報，およびスプールデータに対するアクセス制限情報は，スプールデータの属性情報を基に定義します。利用できる属性情報がない場合は，属性情報を新たに追加します。また，新規にスプールデータを作成する場合は，印刷データの蓄積時に，スプールデータの管理方法に合わせて必要な属性情報を設定します。

スプールデータの属性情報を追加する方法については，「13.　スプールデータを管理するには」を参照してください。印刷データの蓄積方法については，「5.2　帳票の印刷データを蓄積する」を参照してください。

また，ユーザ定義の定義方法については，マニュアル「EUR システム構築ガイド」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 181 / 218


13. スプールデータを管理するには : EUR 帳票出力 機能解説 EUR Server編

  • 182 / 218

  • 表紙

  • 13.　スプールデータを管理するには

13.　スプールデータを管理するには

この章では，スプールデータの管理について説明します。スプールデータの管理方法には，帳票管理GUIを使用する方法と，業務プログラムを使用する方法の2種類があります。なお，スプールデータを管理するには，EUR Server Enterpriseが必要です。

〈この章の構成〉

  • 13.1　GUIで管理する

  • 13.2　業務プログラムで管理する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 182 / 218


13.1 GUIで管理する : EUR 帳票出力 機能解説 EUR Server編

  • 183 / 218

  • 表紙

  • 13.　スプールデータを管理するには

  • 13.1　GUIで管理する

13.1　GUIで管理する

帳票管理GUIとは，スプールデータを管理するためにEUR Server Enterpriseが提供しているサービスプログラムです。アプリケーションサーバ上で動作します。

なお，帳票管理GUIはイントラネット内でご使用ください。

帳票管理GUIを使用するための準備については，マニュアル「EUR システム構築ガイド」を参照してください。

  • 帳票管理GUIの機能

    帳票管理GUIの機能を次に示します。

    スプールサーバのサーバ情報の取得

    スプールサーバのサーバ情報を取得できます。

    操作方法については，「13.1.3　スプールサーバのサーバ情報の取得」を参照してください。

    スプールデータの一覧取得

    スプールデータの情報をスプールサーバごとに一覧で取得できます。すべてのスプールデータの一覧を取得することもできますし，指定した検索条件に当てはまるスプールデータだけを一覧で取得することもできます。

    さらに，目的に合わせてスプールデータの表示順序や一覧の表示方法を変更できます。

    操作方法については，「13.1.4　スプールデータの一覧取得」を参照してください。

    スプールデータの属性値の参照・変更

    スプールデータの属性値を参照したり，変更したりできます。

    操作方法については，「13.1.5　スプールデータの属性値の参照」および「13.1.6　スプールデータの属性値の変更」を参照してください。

    スプールデータの検索

    印刷データのファイル名や作成日時などの条件を指定して，スプールサーバのスプールデータを検索できます。

    操作方法については，「13.1.9　スプールデータの検索」を参照してください。

    スプールデータの削除

    不要なスプールデータを削除できます。選択したスプールデータを一つずつ削除することもできますし，複数のスプールデータをまとめて削除することもできます。

    また，蓄積期限が切れたスプールデータを一括して削除することもできます。一括削除は，ユーザのアクセス制限に関係なく実行できます。

    操作方法については，「13.1.7　スプールデータの削除」および「13.1.8　期限が切れたスプールデータの一括削除」を参照してください。

    スプールデータのアクセス制限

    スプールデータを操作するユーザごとに，アクセスできるスプールデータの条件を定義することで，操作できるスプールデータを制限できます。

    操作方法については，「13.1.2　ユーザの設定」を参照してください。

    アクセス制限の詳細については，「12.2.1　帳票にアクセスできるユーザを制限する」を参照してください。

    スプールデータからの印刷・プレビュー

    選択したスプールデータを，設定されている印刷方式に従ってスプールサーバやクライアントPCで印刷できます。

    操作方法については，「5.4.3　帳票管理GUIを使用して出力する」を参照してください。

    スプールデータからのPDF形式ファイル取得

    選択したスプールデータをPDF形式ファイルで取得できます。

    操作方法については，「5.3.4　帳票管理GUIを使用して印刷データをPDF形式ファイルで取得する」を参照してください。

  • 帳票管理GUIの表示方法

    帳票管理GUIの表示方法について説明します。

    1. クライアントPCのブラウザからURL「http://＜帳票管理GUIサービスIPアドレス＞/＜サービス名＞/」にアクセスします。

      ［ユーザの設定］画面が表示されます。

      （例）

      次に示す条件の場合，URLは「http://192.168.15.50/eurpmrsgui/」になります。

      ＜帳票管理GUIサービスIPアドレス＞：192.168.15.50

      ＜サービス名＞：eurpmrsgui

      なお，＜サービス名＞には，Web/APサーバの環境設定で登録した帳票管理GUIサービスの名称を指定してください。

    2. ユーザ名および確認キーをテキストボックスに入力します。

      帳票管理GUIが起動し，メイン画面が表示されます。

      ユーザ名，および確認キーを入力しなかった場合は，デフォルトユーザとして操作できます。入力項目の詳細については，「13.1.2(1)　［ユーザの設定］画面」を参照してください。また，デフォルトユーザについては，「12.2.1　帳票にアクセスできるユーザを制限する」を参照してください。

    帳票管理GUIを終了するときは，帳票管理GUIのメニューバーから［ファイル］－［終了］を選択します。

    なお，ユーザの認証情報（ユーザ名と確認キー）を業務プログラムと帳票管理GUIとで共有する仕組みにすることで，［ユーザの設定］画面の表示を省略できます。詳細については，マニュアル「EUR システム設計ガイド」を参照してください。

メモ

EURをインストールしたマシンで帳票管理GUIを使用するときは，スタートメニュー－［EUR Server］または［EUR Developer］－［Server］－［帳票管理］を選択する方法でもアクセスできます。

〈この節の構成〉

  • 13.1.1　画面構成

  • 13.1.2　ユーザの設定

  • 13.1.3　スプールサーバのサーバ情報の取得

  • 13.1.4　スプールデータの一覧取得

  • 13.1.5　スプールデータの属性値の参照

  • 13.1.6　スプールデータの属性値の変更

  • 13.1.7　スプールデータの削除

  • 13.1.8　期限が切れたスプールデータの一括削除

  • 13.1.9　スプールデータの検索

  • 13.1.10　GUIで管理するときの注意

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 183 / 218


13.1.1 画面構成 : EUR 帳票出力 機能解説 EUR Server編

  • 184 / 218

  • 表紙

  • 13.　スプールデータを管理するには

  • 13.1　GUIで管理する

  • 13.1.1　画面構成

13.1.1　画面構成

帳票管理GUIの画面構成について説明します。

〈この項の構成〉

  • (1)　メイン画面

  • (2)　メニュー領域

  • (3)　ツリー領域

  • (4)　リストビュー領域

  • (5)　状態表示領域

(1)　メイン画面

帳票管理GUIのメイン画面を次の図に示します。

図13‒1　帳票管理GUIのメイン画面

[図データ]

  • メニュー領域

    帳票管理GUIを操作するメニューバーおよびツールバーが表示されます。

  • ツリー領域

    スプールサーバの出力先名の一覧，およびスプールデータの検索条件の一覧が表示されます。

  • リストビュー領域

    ツリー領域で選択したスプールサーバのサーバ情報，およびスプールデータの一覧取得の結果が表示されます。

  • 状態表示領域

    スプールデータの一覧を取得する場合の進捗状況が表示されます。

ページの先頭へ

(2)　メニュー領域

メニュー領域を次の図に示します。

図13‒2　メニュー領域（帳票管理GUI）

[図データ]

表13‒1 帳票管理GUIのメニュー
メニュー （メニューバー） |  | 機能 | ボタン （ツールバー）
ファイル | 終了 | 帳票管理GUIを終了します。 | －
ジョブ | プレビュー | 選択したスプールデータに格納された印刷データを［プレビュー］画面に表示します。 プレビュー表示については，「5.4.3 帳票管理GUIを使用して出力する」を参照してください。 | [図データ]
 | 印刷 | 選択したスプールデータに格納された印刷データを印刷します。 印刷については，「5.4.3 帳票管理GUIを使用して出力する」を参照してください。 | [図データ]
 | PDF取得※ | 選択したスプールデータをPDF形式ファイルで取得します。 PDF形式ファイルの取得については，「5.3.4 帳票管理GUIを使用して印刷データをPDF形式ファイルで取得する」を参照してください。 | [図データ]
 | 属性参照 | 選択したスプールデータの属性を表示します。 属性の参照については，「13.1.5 スプールデータの属性値の参照」を参照してください。 | [図データ]
 | 属性変更 | 選択したスプールデータの属性を変更します。 属性の変更については，「13.1.6 スプールデータの属性値の変更」を参照してください。 | [図データ]
 | 削除 | 選択したスプールデータを削除します。 削除については，「13.1.7 スプールデータの削除」を参照してください。 | [図データ]
実行 | 蓄積期限が切れた蓄積ファイルの一括削除 | 選択したスプールサーバにある蓄積期限が切れたスプールデータを削除します。 一括削除については，「13.1.8 期限が切れたスプールデータの一括削除」を参照してください。 | －
設定 | ユーザの設定 | スプールデータを操作するユーザを設定します。 ユーザの設定については，「13.1.2 ユーザの設定」を参照してください。 | －
 | 検索条件設定 | スプールデータの検索条件を設定します。 検索条件の設定については，「13.1.9 スプールデータの検索」を参照してください。 | －
ヘルプ | バージョン情報 | 帳票管理GUIのバージョン情報を表示します。 | －
（凡例）

－：該当するボタンはありません。

注※

スプールデータをPDF形式ファイルで取得する機能を使用する場合は，帳票管理GUIの環境設定ファイル（EURPMRSGUI.ini）のENABLEGETPDFキーに「1」（PDF形式ファイルの取得を許可する）を指定しておく必要があります。

ページの先頭へ

(3)　ツリー領域

ツリー領域を次の図に示します。

図13‒3　ツリー領域（帳票管理GUI）

[図データ]

スプールサーバ一覧

［EUR Server Service 構成定義］ダイアログ，または出力先定義ファイル（Destination.conf）で設定したスプールサーバの出力先名が，定義順で表示されます。

デフォルトの出力先については，「"デフォルト"」と表示されます。

スプールサーバの出力先名をクリックすることで，スプールサーバのサーバ情報をリストビュー領域に表示できます。また， [図データ] アイコンまたは [図データ] アイコンをクリックすることで，検索条件名の表示と非表示の切り替えができます。

[図データ] アイコン

検索条件名が非表示の状態です。

[図データ] アイコン

検索条件名が表示されている状態です。

検索条件名

  • ［一覧］

    ［一覧］をクリックすることで，選択しているスプールサーバのスプールデータの一覧をリストビュー領域に表示できます。一覧を更新するときは，再度クリックします。

  • ［任意条件］

    ［任意条件］をダブルクリックすることで，ツリー領域に検索条件表示が表示され，スプールデータの検索条件を設定できます。

    また，［任意条件］をクリックすることで，設定した条件に該当するスプールデータをリストビュー領域に表示できます（検索条件表示で［保存して検索実行］ボタンをクリックしたときと同じ動作になります）。一覧を更新するときは，再度クリックします。

    なお，検索条件を設定していない状態で［任意条件］をクリックした場合は，［一覧］をクリックした場合と同様に，選択しているスプールサーバのスプールデータの一覧をリストビュー領域に表示します。

検索条件表示

スプールデータの検索条件を設定できます。［任意条件］をダブルクリックすると表示されます。検索条件の設定については，「13.1.9　スプールデータの検索」を参照してください。

ページの先頭へ

(4)　リストビュー領域

リストビュー領域は，操作によって表示される内容が次のように変わります。

  • サーバ情報表示

    ツリー領域でスプールサーバの出力先名をクリックした場合に表示されます。

  • 一覧表示

    ツリー領域で検索条件名をクリックした場合に表示されます。

(a)　サーバ情報表示

サーバ情報表示を次の図に示します。

図13‒4　サーバ情報表示

[図データ]

［サーバ情報］

ツリー領域で選択したスプールサーバのサーバ情報が表示されます。

［出力先名］

スプールサーバの出力先名が表示されます。

［説明］

出力先の説明が表示されます。

(b)　一覧表示

一覧表示の構成を次に示します。

  • ［一覧］タブ

    ツリー領域で選択したスプールサーバのスプールデータの一覧が，ジョブIDの昇順で表示されます（デフォルト）。一覧の各項目名をクリックすると，昇順または降順にソートして表示されます。ただし，一覧取得中はソートできません。

    図13‒5　［一覧］タブ

    [図データ]

    ［ファイル名］

    スプールデータに格納された印刷データのファイル名が表示されます。

    ［ページ数］

    ページ数が表示されます。

    ［作成日時］

    作成日時が表示されます。

    ［印刷結果］

    最新の印刷結果が表示されます。

    ［印刷日時］

    最新の印刷日時が表示されます。

    ［宛先キー分類］

    宛先キーの分類が表示されます。

    ［宛先キー値］

    宛先キーのキー値が表示されます。

    ［プリンタクラス名］

    プリンタクラス名が表示されます。

    ［検索キー分類n（n：1～10）］

    ジョブ検索キーの分類が表示されます。

    ［検索キー値n（n：1～10）］

    ジョブ検索キーのキー値が表示されます。

    ［印刷実行回数］

    印刷実行回数が表示されます。

    ［ジョブID］

    ジョブIDが表示されます。

  • ［印刷状態確認］タブ

    ツリー領域で選択したスプールサーバのスプールデータの一覧が，未印刷か印刷済みかで分かれて表示されます。一覧の各項目については，［一覧］タブの説明を参照してください。

    図13‒6　［印刷状態確認］タブ

    [図データ]

    ［未印刷一覧］

    ツリー領域で選択したスプールサーバのスプールデータの情報のうち，未印刷のスプールデータが一覧で表示されます。

    ［印刷済み一覧］

    ツリー領域で選択したスプールサーバのスプールデータの情報のうち，印刷済みのスプールデータが一覧で表示されます。

ページの先頭へ

(5)　状態表示領域

状態表示領域を次の図に示します。

図13‒7　状態表示領域

[図データ]

［キャンセル］ボタン

一覧の取得を途中でキャンセルします。

一覧の取得をキャンセルすると，「一覧情報の取得を中断しました。」と表示されます。なお，キャンセルを実行する前にすでに取得した情報がある場合は，リストビュー領域に一覧で表示されます。

状態表示

スプールデータの一覧を取得する場合の進捗状況が「＜取得済みスプールデータ数＞／＜全スプールデータ数＞」の形式で表示されます。

一覧の取得が終了すると，「全ての一覧情報を取得しました。」と表示されます。なお，一覧の取得中は［キャンセル］ボタンをクリックする以外の操作はできません。

［ユーザ：ユーザ名］

帳票管理GUIを操作しているユーザ名が表示されます。

デフォルトユーザの場合は，「”デフォルト”」と表示されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 184 / 218


13.1.2 ユーザの設定 : EUR 帳票出力 機能解説 EUR Server編

  • 185 / 218

  • 表紙

  • 13.　スプールデータを管理するには

  • 13.1　GUIで管理する

  • 13.1.2　ユーザの設定

13.1.2　ユーザの設定

ユーザ名および確認キーを入力することで，スプールデータを操作するユーザを設定できます。また，操作するユーザを任意のタイミングで切り替えることもできます。

  1. ［ユーザの設定］画面の表示

    帳票管理GUIにアクセスすると，自動的に［ユーザの設定］画面が表示されます。ユーザを切り替える場合は，［設定］－［ユーザの設定］を選択して，［ユーザの設定］画面を表示します。

  2. ユーザ名および確認キーの入力

    スプールデータを操作するユーザのユーザ名，および確認キーをテキストボックスに入力します。

    デフォルトユーザとして操作する場合は，何も入力しません。

  3. ［OK］ボタンのクリック

    ［OK］ボタンをクリックすると，入力したユーザ名のユーザが操作者として設定されます。このとき，ツリービュー領域およびリストビュー領域はデフォルトの状態で表示されます。

    ユーザ名または確認キーが入力できる文字数を超えている場合はメッセージが表示され，［ユーザの設定］画面に戻ります。［ユーザの設定］画面でユーザ名または確認キーを修正してください。

    また，［キャンセル］ボタンをクリックすると，入力したユーザ名と確認キーの内容をクリアしてメイン画面に戻ります。

〈この項の構成〉

  • (1)　［ユーザの設定］画面

(1)　［ユーザの設定］画面

［ユーザ名］テキストボックス

スプールデータを操作するユーザのユーザ名を入力します。80バイトまで入力できます。ただし，制御コード（0x00～0x1F，0x7F～0x9F），「"」，「#」，「&」，「+」，「\」，および「,」を入力した場合は正しく動作しません。半角空白だけを入力した場合はエラーとなります。入力しなかった場合は，デフォルトユーザとして動作します。

［確認キー］テキストボックス

確認キーを入力します。半角文字で80バイトまで入力できます。ただし，制御コード（0x00～0x1F，0x7F～0x9F），「"」，「#」，「&」，「+」，「\」，および「,」を入力した場合は正しく動作しません。入力した値は「*」で表示されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 185 / 218


13.1.3 スプールサーバのサーバ情報の取得 : EUR 帳票出力 機能解説 EUR Server編

  • 186 / 218

  • 表紙

  • 13.　スプールデータを管理するには

  • 13.1　GUIで管理する

  • 13.1.3　スプールサーバのサーバ情報の取得

13.1.3　スプールサーバのサーバ情報の取得

スプールデータが格納されているスプールサーバのサーバ情報を表示できます。

  1. スプールサーバの選択

    ツリー領域に表示されているスプールサーバ一覧から，サーバ情報を表示したいスプールサーバの出力先名をクリックします。

  2. スプールサーバのサーバ情報の表示

    選択したスプールサーバのサーバ情報がリストビュー領域に表示されます。

    詳細については，「13.1.1(4)(a)　サーバ情報表示」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 186 / 218


13.1.4 スプールデータの一覧取得 : EUR 帳票出力 機能解説 EUR Server編

  • 187 / 218

  • 表紙

  • 13.　スプールデータを管理するには

  • 13.1　GUIで管理する

  • 13.1.4　スプールデータの一覧取得

13.1.4　スプールデータの一覧取得

スプールサーバおよびスプールデータの情報を取得し，表示できます。

なお，一覧を取得する場合，取得する情報量に応じた処理時間が掛かります。一度に一覧を取得するスプールデータの件数は，10,000件程度までとすることを推奨します。

  1. スプールデータの取得方法の選択

    ツリー領域に表示されているスプールサーバの [図データ] アイコンをクリックして検索条件名を表示します。

    • すべてのスプールデータの情報を取得する場合

      検索条件名の［一覧］をクリックします。

    • 検索条件を設定してスプールデータの情報を取得する場合

      検索条件名の［任意条件］をダブルクリックして検索条件表示を表示します。

      検索条件の設定については，「13.1.9　スプールデータの検索」を参照してください。検索条件を設定したら，［任意条件］をクリックします。

    スプールデータ数が多い場合は自動的に情報を分割して取得します。この場合，状態表示領域に進捗状況が表示されます。詳細については，「13.1.1(5)　状態表示領域」を参照してください。

  2. 一覧の参照

    リストビュー領域に取得したスプールデータの一覧が表示されます。

    取得したスプールデータの一覧を未印刷か印刷済みかで分けて参照したい場合は，［印刷状態確認］タブをクリックしてください。また，一覧の項目名をクリックすることで，昇順または降順にソートして表示できます。

    詳細については，「13.1.1(4)(b)　一覧表示」を参照してください。

  3. 一覧の更新

    ツリー領域の［一覧］または［任意条件］をクリックすることで，一覧を最新の状態に更新できます。

    すべてのスプールデータの情報を取得している場合は［一覧］を，検索条件を設定してスプールデータの情報を取得している場合は［任意条件］をクリックしてください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 187 / 218


13.1.5 スプールデータの属性値の参照 : EUR 帳票出力 機能解説 EUR Server編

  • 188 / 218

  • 表紙

  • 13.　スプールデータを管理するには

  • 13.1　GUIで管理する

  • 13.1.5　スプールデータの属性値の参照

13.1.5　スプールデータの属性値の参照

スプールデータの属性値を表示し，参照できます。

  1. スプールデータの一覧取得

    詳細については，「13.1.4　スプールデータの一覧取得」を参照してください。

  2. スプールデータの選択

    取得した一覧から，属性値を参照するスプールデータを一つ選択します。

  3. 属性参照表示の表示

    ［ジョブ］－［属性参照］を選択するか，または［属性参照］ボタンをクリックします。

  4. 属性値の参照

    リストビュー領域に属性参照表示が表示され，属性値を参照できます。

    なお，属性参照表示を表示した状態で一覧からほかのスプールデータを選択した場合や，属性参照表示の［OK］ボタンをクリックした場合は，属性参照表示が閉じます。

〈この項の構成〉

  • (1)　属性参照表示

(1)　属性参照表示

参照できる属性値は次の表のとおりです。

表13‒2 参照できる属性値
タブ | 項目 |  | 説明
ファイル属性 | 格納ファイル名 |  | スプールデータに格納された印刷データの名称
 | 格納ファイルページ数 |  | スプールデータに格納された印刷データのページ数
 | サイズ |  | スプールデータに格納された印刷データのサイズ（単位：バイト）
 | 作成日時 |  | スプールデータの作成日時
 | ジョブID |  | スプールデータのジョブID
 | 蓄積ファイルのフォーマットバージョン |  | スプールデータのフォーマットバージョン
ジョブ属性 | 蓄積期限 |  | スプールデータの蓄積期限日
 | 実行回数/上限回数 | 印刷 | スプールデータに格納された印刷データの印刷実行回数/印刷上限回数
 | 出力先情報 | プリンタ指定方法 | スプールサーバでの印刷時のプリンタ指定方法
 |  | プリンタクラス名 | スプールサーバでの印刷時のプリンタクラス名
 |  | 拠点プリンタ名 | スプールサーバでの印刷時のOS上のプリンタ名
 |  | 拠点トレイ名 | スプールサーバでの印刷時のOS上のトレイ名
 |  | クライアントプリンタ名 | クライアントPCでの印刷時のOS上のプリンタ名
 |  | クライアントトレイ名 | クライアントPCでの印刷時のOS上のトレイ名
 |  | 帳票振り分けグループ名 | スプールデータの振り分けグループ名
 | 宛先情報 | 宛先キー分類 | スプールデータの宛先の分類名
 |  | 宛先キー値 | スプールデータの宛先のキー値
 | 印刷方式 | 実行可能印刷方式 | 実行できる印刷方式
 | その他 | ダイアログ表示モード | クライアントPCでの印刷時のダイアログ表示モード
 |  | クライアントIPアドレス | クライアントPCでの印刷時の出力先のクライアントIPアドレス
 |  | 取得可否 | スプールデータに格納された印刷データの取得可否
検索属性 | 分類 |  | スプールデータのジョブ検索キーの分類
 | 値 |  | スプールデータのジョブ検索キーの値
状態属性 | 印刷結果 |  | 最新の印刷結果
 | 印刷日時 |  | 最新の印刷日時
履歴 | 種別 |  | スプールデータを操作した内容
 | 操作日時 |  | スプールデータを操作した日時
 | 操作対象 |  | 属性変更を実行した属性名
 | 変更前情報 |  | 属性変更前の属性値
 | 変更後情報 |  | 属性変更後の属性値
 | 印刷実行結果 |  | 印刷の実行結果

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 188 / 218


13.1.6 スプールデータの属性値の変更 : EUR 帳票出力 機能解説 EUR Server編

  • 189 / 218

  • 表紙

  • 13.　スプールデータを管理するには

  • 13.1　GUIで管理する

  • 13.1.6　スプールデータの属性値の変更

13.1.6　スプールデータの属性値の変更

スプールデータの属性値を変更できます。

  1. スプールデータの一覧取得

    詳細については，「13.1.4　スプールデータの一覧取得」を参照してください。

  2. スプールデータの選択

    取得した一覧から，属性値を変更するスプールデータを一つ選択します。

  3. 属性変更表示の表示

    ［ジョブ］－［属性変更］を選択するか，または［属性変更］ボタンをクリックします。

  4. 属性値の変更

    リストビュー領域に属性変更表示が表示され，属性値を変更できます。変更できる属性値については，「(1)　属性変更表示」を参照してください。

  5. ［OK］ボタンのクリック

    属性変更表示の［OK］ボタンをクリックすると，指定した属性値が変更されます。

    ただし，次の場合はメッセージが表示され，属性変更表示に戻ります。

    • 属性値に入力できない文字があった場合

    • 属性値が入力できる文字数を超えている場合

    • ［検索属性］タブの［検索キー］の［分類］が未入力で［値］が入力済みの場合

    なお，属性変更表示を表示している場合，一覧でほかのスプールデータは選択できません。［キャンセル］ボタンをクリックした場合は，属性値は変更されないで属性変更表示が閉じます。

〈この項の構成〉

  • (1)　属性変更表示

(1)　属性変更表示

属性変更表示で変更できる属性値について説明します。

(a)　［ジョブ属性］タブ

［蓄積期限］テキストボックス

スプールデータの蓄積期限を指定します。

蓄積期限は，属性値の変更を実施する日～2038/01/18の範囲で入力します。年月日はテキストボックスに直接入力するか，カレンダーの日付をクリックして指定します。 [図データ] アイコンをクリックするとカレンダーが表示されます。カレンダーについては，「(c)　カレンダー」を参照してください。

［実行回数/上限回数］グループボックス
［印刷］

印刷回数の上限を指定します。

  • ［上限指定］ラジオボタン

    印刷回数の上限を設定する場合に指定します。

    印刷回数の上限は，1～65,536の範囲で指定できます。［上限指定］ラジオボタンの左にあるテキストボックスに，半角数字で入力してください。

  • ［上限なし］ラジオボタン

    印刷回数の上限を設定しない場合に指定します。

［出力先情報］グループボックス
［プリンタ指定方法］プルダウンメニュー

プリンタ指定方法を指定します。プルダウンメニューから次のどれかを選択します。

  • プリンタクラス名指定

  • OS上のプリンタ名指定

  • 帳票名による自動振り分け

［プリンタクラス名］テキストボックス

スプールサーバでの印刷時のプリンタクラス名を入力します。80バイトまで入力できます。ただし，制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」は入力できません。先頭と末尾の半角空白は登録時に削除されます。半角空白だけを入力した場合はエラーとなります。

［拠点プリンタ名］テキストボックス

スプールサーバのプリンタ名を入力します。80バイトまで入力できます。ただし，制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」は入力できません。先頭と末尾の半角空白は登録時に削除されます。半角空白だけを入力した場合はエラーとなります。

［拠点トレイ名］テキストボックス

スプールサーバのプリンタのトレイ名を入力します。80バイトまで入力できます。ただし，制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」は入力できません。先頭と末尾の半角空白は登録時に削除されます。半角空白だけを入力した場合はエラーとなります。

［クライアントプリンタ名］テキストボックス

クライアントのプリンタ名を入力します。80バイトまで入力できます。ただし，制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」は入力できません。先頭と末尾の半角空白は登録時に削除されます。半角空白だけを入力した場合はエラーとなります。

［クライアントトレイ名］テキストボックス

クライアントのプリンタのトレイ名を入力します。80バイトまで入力できます。ただし，制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」は入力できません。先頭と末尾の半角空白は登録時に削除されます。半角空白だけを入力した場合はエラーとなります。

［帳票振り分けグループ名］テキストボックス

スプールデータの振り分けグループ名を入力します。80バイトまで入力できます。ただし，制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」は入力できません。先頭と末尾の半角空白は登録時に削除されます。半角空白だけを入力した場合はエラーとなります。

［印刷方式］グループボックス
［実行可能印刷方式］プルダウンメニュー

実行可能印刷方式を指定します。プルダウンメニューから次のどれかを選択します。

  • 蓄積拠点サーバ印刷

  • 蓄積拠点サーバ印刷／蓄積クライアント印刷

  • 蓄積クライアント印刷

［ダイアログ表示モード］プルダウンメニュー

クライアントPCでの印刷時のダイアログ表示モードを指定します。プルダウンメニューから次のどれかを選択します。

  • 対話型印刷

  • 自動印刷

  • 対話型印刷プレビュー表示

  • 全自動印刷

  • 対話型印刷プレビュー表示限定

［クライアントIPアドレス］テキストボックス

クライアントPCでの印刷時の出力先のクライアントIPアドレスを指定します。入力形式は「xxx.xxx.xxx.xxx」です。

［取得可否］チェックボックス

スプールデータの取得可否を指定します。チェックを入れるとスプールデータが取得可能となります。

(b)　［検索属性］タブ

［検索キー］

ジョブ検索キーの分類と値を指定します。分類と値のペアは，分類だけ入力し，値を省略できます。ただし，値を入力した検索キーの分類は省略できません。

［分類］テキストボックス

ジョブ検索キーの分類を入力します。80バイトまで入力できます。ただし，制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」は入力できません。先頭と末尾の半角空白は登録時に削除されます。半角空白だけを入力した場合はエラーとなります。

［値］テキストボックス

ジョブ検索キーの値を入力します。80バイトまで入力できます。ただし，制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」は入力できません。先頭と末尾の半角空白は登録時に削除されます。半角空白だけを入力した場合はエラーとなります。

(c)　カレンダー

カレンダーを次の図に示します。

図13‒8　カレンダー

[図データ]

デフォルトでは，設定されている蓄積期限日が反転表示されます。

[図データ] アイコン

前の月を表示します。

[図データ] アイコン

次の月を表示します。

[図データ] アイコン

次の年を表示します。

[図データ] アイコン

前の年を表示します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 189 / 218


13.1.7 スプールデータの削除 : EUR 帳票出力 機能解説 EUR Server編

  • 190 / 218

  • 表紙

  • 13.　スプールデータを管理するには

  • 13.1　GUIで管理する

  • 13.1.7　スプールデータの削除

13.1.7　スプールデータの削除

選択したスプールデータを削除できます。

  1. スプールデータの一覧取得

    詳細については，「13.1.4　スプールデータの一覧取得」を参照してください。

  2. スプールデータの選択

    取得した一覧から，削除するスプールデータを一つ以上選択します。

  3. ［削除］画面の表示

    ［ジョブ］－［削除］を選択するか，または［削除］ボタンをクリックします。［削除］画面が表示されます。

  4. ［OK］ボタンのクリック

    ［OK］ボタンをクリックすると，選択したスプールデータが削除されます。

    ［キャンセル］ボタンをクリックした場合は，スプールデータは削除されないで，［削除］画面が閉じます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 190 / 218


13.1.8 期限が切れたスプールデータの一括削除 : EUR 帳票出力 機能解説 EUR Server編

  • 191 / 218

  • 表紙

  • 13.　スプールデータを管理するには

  • 13.1　GUIで管理する

  • 13.1.8　期限が切れたスプールデータの一括削除

13.1.8　期限が切れたスプールデータの一括削除

蓄積期限が切れたスプールデータを一括で削除できます。

  1. スプールサーバの選択

    ツリー領域のスプールサーバ一覧から，スプールサーバの出力先名を一つ選択します。

  2. ［一括削除］画面の表示

    ［実行］－［蓄積期限が切れた蓄積ファイルの一括削除］を選択します。［蓄積期限が切れた蓄積ファイルの一括削除］は，ツリー領域でスプールサーバを選択している場合にだけ選択できます。［一括削除］画面が表示されます。

  3. ［OK］ボタンのクリック

    ［OK］ボタンをクリックすると，選択したスプールサーバにある蓄積期限が切れたスプールデータの一括削除が実行されます。

    ［キャンセル］ボタンをクリックした場合は，スプールデータは削除されないで［一括削除］画面が閉じます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 191 / 218


13.1.9 スプールデータの検索 : EUR 帳票出力 機能解説 EUR Server編

  • 192 / 218

  • 表紙

  • 13.　スプールデータを管理するには

  • 13.1　GUIで管理する

  • 13.1.9　スプールデータの検索

13.1.9　スプールデータの検索

条件を設定してスプールデータを検索できます。

  1. 検索条件表示の表示

    次のどちらかの方法でツリー領域に検索条件表示を表示します。

    • ツリー領域で選択したいスプールサーバの出力先名をクリックしたあと，［設定］－［検索条件設定］を選択する。

    • ツリー領域で選択したいスプールサーバの [図データ] アイコンをクリックしたあと，［任意条件］をダブルクリックする。

  2. 検索条件の指定

    検索条件を指定します。検索条件に指定できる項目は，「(1)　検索条件表示」を参照してください。なお，複数の条件を指定した場合は，AND検索となります。

    検索条件の項目を選択して［クリア］ボタンをクリックすると，選択している項目の検索条件がクリアされます。また，［全クリア］ボタンをクリックすると，すべての項目の検索条件がクリアされます。

  3. ［保存して検索実行］ボタンのクリック

    ［保存して検索実行］ボタンをクリックすると，指定した検索条件に該当するスプールデータがリストビュー領域に一覧で表示されます。すぐに検索を実行しないときは，［保存］ボタンをクリックすると，指定した条件を保存できます。

    ただし，次の場合はメッセージが表示されます。

    • 検索条件の値に入力できない文字があった場合

    • 検索条件の値が入力できる文字数を超えている場合

    • 検索条件の値が入力できる数値の範囲を超えている場合

    なお，指定した検索条件で一覧を更新する場合は，［任意条件］をクリックします。

■注意

検索条件表示の表示中に，ツリー領域で，スプールサーバの出力先名，［一覧］，または［任意条件］を選択すると，検索条件表示は閉じます。

〈この項の構成〉

  • (1)　検索条件表示

(1)　検索条件表示

検索条件として指定できる項目を次の表に示します。

表13‒3 スプールデータの検索条件
項目 | 指定方法
 | 最小値※1 | 最大値※1 | 直接指定※1, ※2
ジョブID | × | × | ○
格納ファイル名 | × | × | ○
格納ファイルページ数 | ○ | ○ | ○
作成日時 | ○ | ○ | ○
印刷結果 | × | × | ○
プリンタクラス名 | × | × | ○
印刷実行回数 | ○ | ○ | ○
印刷日時 | ○ | ○ | ○
ジョブ検索キー分類n（n：1～10） | × | × | ○
ジョブ検索キー値n（n：1～10） | × | × | ○
宛先キー分類 | × | × | ○
宛先キー値 | × | × | ○
（凡例）

○：指定できます。

×：指定できません。

注※1

最小値または最大値と直接指定を同時に指定した場合は，直接指定が有効となります。このとき，最小値または最大値の指定は無視されます。

注※2

文字列または数値を指定します。

各項目について説明します。

［ジョブID］

ジョブIDで検索する場合に指定します。直接指定に文字列で入力します。

［格納ファイル名］

スプールデータに格納された印刷データのファイル名で検索する場合に指定します。直接指定に文字列で入力します。

［格納ファイルページ数］

スプールデータに格納された印刷データのページ数で検索する場合に指定します。1～999,999の数値で入力します。

［作成日時］

スプールデータの作成日時で検索する場合に指定します。作成日時を指定すると検索範囲を絞り込めるため，一覧表示が速くなります。指定可能な範囲は，1970/01/01 09:00:00～2038/01/18 23:59:59（UTCの場合，1970/01/01 00:00:00～2038/01/18 14:59:59）です。入力形式は「YYYYMMDDhhmmss」です。「YYYYMMDDhhmmss」形式の内容を次に示します。

  • YYYY：年（西暦）を4桁で示します。

  • MM：月（01～12）を2桁で示します。01～09は，ゼロ埋めします。

  • DD：日（01～31）を2桁で示します。01～09は，ゼロ埋めします。

  • hh：時（00～23）を2桁で示します。00～09は，ゼロ埋めします。

  • mm：分（00～59）を2桁で示します。00～09は，ゼロ埋めします。

  • ss：秒（00～59）を2桁で示します。00～09は，ゼロ埋めします。

［印刷結果］

スプールデータの印刷結果で検索する場合に指定します。直接指定のプルダウンメニューから次のどれかを選択します。

  • 未印刷

  • 印刷済み

  • 印刷エラー

［プリンタクラス名］

スプールデータのプリンタクラス名で検索する場合に指定します。直接指定に文字列で入力します。

［印刷実行回数］

スプールデータの印刷実行回数で検索する場合に指定します。数値で入力できます。

［印刷日時］

スプールデータの印刷日時で検索する場合に指定します。30バイトまで入力できます。指定可能な範囲は，1970/01/01 09:00:00～2038/01/18 23:59:59（UTCの場合，1970/01/01 00:00:00～2038/01/18 14:59:59）です。入力形式は「YYYYMMDDhhmmss」です。「YYYYMMDDhhmmss」形式の内容を次に示します。

  • YYYY：年（西暦）を4桁で示します。

  • MM：月（01～12）を2桁で示します。01～09は，ゼロ埋めします。

  • DD：日（01～31）を2桁で示します。01～09は，ゼロ埋めします。

  • hh：時（00～23）を2桁で示します。00～09は，ゼロ埋めします。

  • mm：分（00～59）を2桁で示します。00～09は，ゼロ埋めします。

  • ss：秒（00～59）を2桁で示します。00～09は，ゼロ埋めします。

［宛先キー分類］

スプールデータの宛先の分類名で検索する場合に指定します。

直接指定に80バイト以内の文字列で入力します。ただし，制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」は入力できません。先頭と末尾の半角空白は登録時に削除されます。半角空白だけを入力した場合は未入力とみなされます。

［宛先キー値］

スプールデータの宛先のキー値で検索する場合に指定します。

直接指定に80バイト以内の文字列で入力します。ただし，制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」は入力できません。先頭と末尾の半角空白は登録時に削除されます。半角空白だけを入力した場合は未入力とみなされます。

［ジョブ検索キー分類n（n：1～10）］

スプールデータのジョブ検索キーの分類で検索する場合に指定します。直接指定に文字列で入力します。

［ジョブ検索キー値n（n：1～10）］

スプールデータのジョブ検索キーのキー値で検索する場合に指定します。直接指定に文字列で入力します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 192 / 218


13.1.10 GUIで管理するときの注意 : EUR 帳票出力 機能解説 EUR Server編

  • 193 / 218

  • 表紙

  • 13.　スプールデータを管理するには

  • 13.1　GUIで管理する

  • 13.1.10　GUIで管理するときの注意

13.1.10　GUIで管理するときの注意

〈この項の構成〉

  • (1)　ディスプレイに表示される文字の大きさについての注意

  • (2)　スプールデータの一覧をソート表示する場合の注意

  • (3)　EUR Web Plug-Inを使用する場合の注意

  • (4)　応答に時間が掛かる操作のタイムアウト

(1)　ディスプレイに表示される文字の大きさについての注意

ディスプレイに表示される文字の大きさを変更しないでください。Windows 7，Windows 8.1，およびWindows 10の場合は，「小-100%（規定）」が規定の大きさです。規定以外の大きさで帳票をプレビュー表示すると，帳票の表示が不正になります。

ディスプレイに表示される文字の大きさは，［コントロールパネル］から，［デスクトップのカスタマイズ］－［ディスプレイ］を選択すると確認できます。

ページの先頭へ

(2)　スプールデータの一覧をソート表示する場合の注意

取得したスプールデータの一覧をソート表示する場合，一覧に表示されているスプールデータの件数が5,000件程度になるようにしてください。一覧に表示されているスプールデータの件数が多い（約10,000件以上）と，正しくソートできないことがあります。

一覧に表示されているスプールデータの件数が5,000件を超えている場合，検索条件を設定するなどして，表示されるスプールデータを絞り込んでください。検索条件の設定方法については，「13.1.9　スプールデータの検索」を参照してください。

ページの先頭へ

(3)　EUR Web Plug-Inを使用する場合の注意

  • 32ビット版のInternet Explorerを使用してください。64ビット版のInternet Explorerでは，帳票の印刷やプレビュー表示はできません。

  • 帳票管理GUIで次の操作を行うと，EUR Web Plug-Inの実行を許可するかどうかを確認するダイアログが表示されます。

    • プレビュー表示

    • ［印刷］画面から［このマシンで印刷］を選択して印刷を実行

    ダイアログが表示されたら実行を許可してください。ただし，ダイアログの応答後には画面が初期表示に戻ります。

    なお，帳票管理GUIを使用する前に，Internet Explorerのアドオンの管理機能でEUR Web Plug-Inの実行を許可しておくこともできます。

  • メニューバーの［表示］－［拡大］で「100%」を指定して使用してください。また，帳票のプレビュー表示中に倍率を変更しないでください。倍率に100%以外を指定した状態で帳票をプレビュー表示すると，帳票の表示が不正になります。

ページの先頭へ

(4)　応答に時間が掛かる操作のタイムアウト

●Internet ExplorerやWebサーバなどのタイムアウト指定

帳票管理GUIを使用して時間が掛かる操作を行った場合，Internet ExplorerやWebサーバなどでタイムアウトが発生する可能性があるため，事前にタイムアウトの指定を確認しておく必要があります。

タイムアウト値の参考値を次に示します。

  • Internet Explorer 9の場合：60分（デフォルト）

  • EUR Server Enterpriseが同梱するEUR HTTP Serverの場合：60分（変更不可）

EUR HTTP Server以外のWebサーバを使用している場合のタイムアウト値については，使用しているWebサーバのマニュアルを参照してください。

●帳票管理GUIの操作のタイムアウト指定

帳票管理GUIの操作について，EUR Server - Spool Service Adapterの環境設定ファイル（EURPMLSADP.ini）でタイムアウトを指定できます。タイムアウトを指定できる操作，およびタイムアウトを指定する環境設定ファイルのキーを次に示します。

  • 印刷：TIMEOUTセクションのPRINTキー

  • PDF取得：TIMEOUTセクションのGETFILEキー

EUR Server - Spool Service Adapterの環境設定ファイルの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

●帳票管理GUIの操作（印刷またはPDF取得）がInternet ExplorerやWebサーバなどで設定したタイムアウト値を超えても完了しない場合の注意事項

  • タイムアウトが発生した際，エラーダイアログを表示して操作が失敗しますが，EURのログファイル（EURPMLSADP.logやEURPMLS.log）にエラー情報が出力されないことがあります。

    タイムアウトが発生した際にログファイルにエラー情報を出力するためには，EUR Server - Spool Service Adapterの環境設定ファイル（EURPMLSADP.ini）のタイムアウトの指定（TIMEOUTセクションのPRINTキーおよびGETFILEキー）で，次の点に注意してください。

    ・0（タイムアウト監視しない）を指定しないでください。

    ・Internet ExplorerやWebサーバなどで設定しているタイムアウト値を超えない値を指定してください。

    上記を満たさない場合，タイムアウトが発生した際にEURのログファイルにエラー情報が出力されないことがあります。

    EUR Server - Spool Service Adapterの環境設定ファイルの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

  • タイムアウトが発生しても，EURでは指定された操作が完了するまで処理を継続し，マシンのリソース（CPUやメモリなど）を使い続けます。

    なお，PDF取得でタイムアウトが発生したときは，処理が完了してもPDF形式ファイルは生成されません。

  • EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）でPDF取得の並列処理数（THREADセクションのCONVERTキー）に小さい値を指定して運用している場合，ほかのPDF取得の処理待ちが発生する可能性があります。

    EUR Server - Spool Serviceの環境設定ファイルの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 193 / 218


13.2 業務プログラムで管理する : EUR 帳票出力 機能解説 EUR Server編

  • 194 / 218

  • 表紙

  • 13.　スプールデータを管理するには

  • 13.2　業務プログラムで管理する

13.2　業務プログラムで管理する

スプールデータに対して，属性値を変更するなどの操作ができます。

スプールデータにアクセスできるユーザが制限されている場合は，スプールデータを操作できないことがあります。スプールデータのアクセス制限については，「12.2.1　帳票にアクセスできるユーザを制限する」を参照してください。

〈この節の構成〉

  • 13.2.1　スプールデータの一覧取得

  • 13.2.2　スプールデータの属性値の取得

  • 13.2.3　スプールデータの属性値の変更

  • 13.2.4　スプールデータの削除

  • 13.2.5　期限が切れたスプールデータの一括削除

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 194 / 218


13.2.1 スプールデータの一覧取得 : EUR 帳票出力 機能解説 EUR Server編

  • 195 / 218

  • 表紙

  • 13.　スプールデータを管理するには

  • 13.2　業務プログラムで管理する

  • 13.2.1　スプールデータの一覧取得

13.2.1　スプールデータの一覧取得

蓄積フォルダに格納されているスプールデータの一覧を取得できます。「(3)　設定項目」に示す項目を設定することで，条件に当てはまるファイルを検索して取得します。

なお，一覧を取得する際は，取得する情報量に応じた処理時間が掛かります。一度に一覧に取得するスプールデータの件数は，10,000件程度までとすることを推奨します。

〈この項の構成〉

  • (1)　取得できる情報

  • (2)　実行メソッド

  • (3)　設定項目

(1)　取得できる情報

スプールデータごとに取得できる情報を次に示します。

  • 蓄積フォルダからの相対パス

  • スプールデータに格納された印刷データのファイル名

  • スプールデータに格納された印刷データのページ数

  • 作成日時

  • 印刷結果 ※

  • プリンタクラス名

注※

メソッドを発行した時点で，最後に印刷を実行したときの結果です。蓄積拠点サーバ印刷の場合は「印刷データをスプールへ出力した結果」を示し，蓄積クライアント印刷の場合は「印刷データをクライアントPCへ配信した結果」を示します。

ページの先頭へ

(2)　実行メソッド

スプールデータの一覧取得を実行するメソッドを次の表に示します。

表13‒4 スプールデータの一覧取得を実行するメソッド
起動部品 | メソッド
SS-ActiveX起動部品 | GetSpoolFileOutline
SS-Java起動部品 | getSpoolFileOutline
SS-コマンド起動部品（eurpmlscコマンド） | /mオプションにgetoutlineを指定

ページの先頭へ

(3)　設定項目

スプールデータの一覧を取得するときに設定する項目を，次の表に示します。

表13‒5 スプールデータの一覧を取得するときに設定する項目
スプールデータの検索条件の設定 |  | 起動部品の設定項目 | 設定する値
スプールサーバのIPアドレス |  | SS-ActiveX起動部品：ServerAddressプロパティ SS-Java起動部品：setServerAddressメソッド SS-コマンド起動部品：/svrオプション | 255.255.255.255形式
検索条件 | ジョブID | SS-ActiveX起動部品：SearchJobIDプロパティ SS-Java起動部品：setSearchJobIDメソッド，またはsetSearchJobIDMultiメソッド SS-コマンド起動部品：/idオプション | ジョブID（36バイト以内の文字列）
 | スプールデータに格納された印刷データのファイル名 | SS-ActiveX起動部品：SearchSpoolFileNameプロパティ SS-Java起動部品：setSearchSpoolFileNameメソッド SS-コマンド起動部品：/incオプション | 格納ファイル名（255バイト以内の文字列）
 | プリンタクラス名 | SS-ActiveX起動部品：SearchPrinterClassNameプロパティ SS-Java起動部品：setSearchPrinterClassNameメソッド SS-コマンド起動部品：/pcオプション | プリンタクラス名（80バイト以内の文字列）
 | ファイル作成日時の範囲（開始） | SS-ActiveX起動部品：SearchCreateTimeStartプロパティ SS-Java起動部品：setSearchCreateTimeStartメソッド SS-コマンド起動部品：/tsオプション | YYYYMMDDhhmmss形式
 | ファイル作成日時の範囲（終了） | SS-ActiveX起動部品：SearchCreateTimeEndプロパティ SS-Java起動部品：setSearchCreateTimeEndメソッド SS-コマンド起動部品：/teオプション | YYYYMMDDhhmmss形式
 | ジョブ検索キー※の分類 | SS-ActiveX起動部品：SearchJobKeyCategoryプロパティ SS-Java起動部品：setSearchJobKeyCategoryメソッド SS-コマンド起動部品：/fcオプション | ジョブ検索キーの分類（80バイト以内の文字列）
 | ジョブ検索キー※ | SS-ActiveX起動部品：SearchJobKeyDataプロパティ SS-Java起動部品：setSearchJobKeyDataメソッド SS-コマンド起動部品：/fdオプション | ジョブ検索キー（80バイト以内の文字列）
 | スプールデータのジョブID | SS-ActiveX起動部品：SearchJobIDプロパティ SS-Java起動部品：setSearchJobIDメソッド，またはsetSearchJobIDMultiメソッド SS-コマンド起動部品：/idオプション | ジョブID（36バイト以内の文字列）
 | 宛先キーの分類 | SS-ActiveX起動部品：SearchReportAddressKeyCategoryプロパティ SS-Java起動部品：setSearchReportAddressKeyCategoryメソッド SS-コマンド起動部品：/racオプション | 宛先キーの分類（80バイト以内の文字列）
 | 宛先キーの値 | SS-ActiveX起動部品：SearchReportAddressKeyDataプロパティ SS-Java起動部品：setSearchReportAddressKeyDataメソッド SS-コマンド起動部品：/radオプション | 宛先キーの値（80バイト以内の文字列）
注※

ジョブ検索キーは，スプールデータに対してユーザが任意で設定できる検索項目です。蓄積するときに，検索キーの分類と値をペアにして，10個まで指定できます。設定されたジョブ検索キーをスプールデータの一覧取得時に指定することで，対象のスプールデータを検索します。検索時は，分類と値が共に一致するスプールデータを検索します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 195 / 218


13.2.2 スプールデータの属性値の取得 : EUR 帳票出力 機能解説 EUR Server編

  • 196 / 218

  • 表紙

  • 13.　スプールデータを管理するには

  • 13.2　業務プログラムで管理する

  • 13.2.2　スプールデータの属性値の取得

13.2.2　スプールデータの属性値の取得

スプールデータの属性値を取得できます。

〈この項の構成〉

  • (1)　取得できる情報

  • (2)　実行メソッド

  • (3)　設定項目

  • (4)　履歴情報

(1)　取得できる情報

取得できる情報を次に示します。

  • スプールデータが格納されているフォルダからの相対パス

  • スプールデータに格納された印刷データのファイル名

  • スプールデータに格納された印刷データのサイズ（単位：バイト） ※1

  • スプールデータに格納された印刷データのページ数

  • 作成日時

  • 蓄積期限日

  • スプールデータに格納された印刷データの取得可否

  • 印刷日時 ※2

  • 蓄積を指示したマシンのIPアドレス

  • スプールデータのフォーマットのバージョン情報

  • 印刷実行回数

  • 印刷上限回数

  • 実行できる印刷方式

  • スプールサーバでの印刷時のプリンタ指定方法

  • スプールサーバ，またはクライアントPCでの印刷時のプリンタクラス名

  • スプールサーバでの印刷時のOS上のプリンタ名

  • スプールサーバでの印刷時のOS上のトレイ名

  • スプールサーバでの印刷時の帳票振り分け定義名

  • クライアントPCでの印刷時のダイアログ表示モード

  • クライアントPCでの印刷時のクライアントPCのIPアドレス

  • クライアントPCでの印刷時のOS上のプリンタ名

  • クライアントPCでの印刷時のOS上のトレイ名

  • ジョブ検索キーの分類

  • ジョブ検索キーの値

  • 最後に実行した印刷の結果

  • 履歴情報 ※3

注※1

スプールデータに格納された印刷データ（EPF形式ファイル）を取得した場合，蓄積実行時および操作時の情報の一部をEPF形式ファイルに反映するため，属性値として取得したサイズと実際のファイルサイズとは異なります。

注※2

印刷結果に関係なく最後に印刷を実行した日時を示します。

注※3

スプールデータに対して操作したときの履歴情報です。「スプールデータの印刷」，「スプールデータの取得」，および「スプールデータの属性値の変更」を行ったとき，属性値に追加されます。取得される履歴情報を次に示します。

  • 操作種別（スプールサーバ印刷／クライアント印刷／ActiveXクライアント印刷／取得／変更／配送印刷／PDF形式ファイル取得）

  • 操作日時

  • 操作を指示したマシン（EUR Server - Spool Service Adapterが動作するマシン）のIPアドレス

  • 「属性値の変更」操作時の操作対象の属性名

  • 「属性値の変更」操作時の変更前の属性値

  • 「属性値の変更」操作時の変更後の属性値

  • 印刷実行結果

なお，操作種別の「ActiveXクライアント印刷」は，属性値の変更で印刷結果を「1：印刷済み」または「2：印刷エラー」に変更した場合に設定されます。印刷結果を「0：未印刷」に変更した場合は，操作種別は「変更」となります。

ページの先頭へ

(2)　実行メソッド

スプールデータの属性値の取得を実行するメソッドを次の表に示します。

表13‒6 スプールデータの属性値の取得を実行するメソッド
起動部品 | メソッド
SS-ActiveX起動部品 | GetSpoolFileAttribute
SS-Java起動部品 | getSpoolFileAttribute
SS-コマンド起動部品（eurpmlscコマンド） | /mオプションにgetattrを指定

ページの先頭へ

(3)　設定項目

スプールデータの属性値を取得するときに設定する項目を，次の表に示します。

表13‒7 スプールデータの属性値を取得するときに設定する項目
スプールデータの属性値の取得に関する設定 | 起動部品の設定項目 | 設定する値
IPアドレス | SS-ActiveX起動部品：ServerAddressプロパティ SS-Java起動部品：setServerAddressメソッド SS-コマンド起動部品：/svrオプション | 255.255.255.255形式
スプールデータのジョブID | SS-ActiveX起動部品：SearchJobIDプロパティ SS-Java起動部品：setSearchJobIDメソッド SS-コマンド起動部品：/idオプション | ジョブID（36バイト以内の文字列）

ページの先頭へ

(4)　履歴情報

属性値を変更した場合に，履歴情報に表示される属性名と変更履歴の表示名の対応を次の表に示します。

表13‒8 属性名と変更履歴の表示名の対応
属性名 | 変更履歴の表示名
蓄積期限日 | 蓄積期限日
取得可否情報 | 取得可否
印刷上限回数 | 印刷上限回数
実行できる印刷方式 | 実行可能印刷方式
スプールサーバでの印刷時のプリンタ指定方法 | プリンタ指定方法
スプールサーバ，またはクライアントPCでの印刷時のプリンタクラス名 | プリンタクラス名
スプールサーバでの印刷時のOS上のプリンタ名 | 拠点プリンタ名
スプールサーバでの印刷時のOS上のトレイ名 | 拠点トレイ名
スプールサーバでの印刷時の帳票振り分け定義名 | 帳票振り分けグループ名
クライアントPCでの印刷時のダイアログ表示モード | ダイアログ表示モード
クライアントPCでの印刷時のクライアントPCのIPアドレス | クライアントマシンIPアドレス
クライアントPCでの印刷時のOS上のプリンタ名 | クライアントプリンタ名
クライアントPCでの印刷時のOS上のトレイ名 | クライアントトレイ名
ジョブ検索キーの値 | ジョブ検索キー

属性値を変更した場合に，属性名とActiveX起動部品の場合の属性値，および変更前または変更後に表示される履歴情報を次の表に示します。

表13‒9 属性値と履歴情報（変更前または変更後）の対応
属性名 | 属性値（ActiveX起動部品の場合） | 履歴情報（変更前または変更後）
取得可否情報 | TRUE | 取得可能
 | FALSE | 取得不可
実行できる印刷方式 | 0 | 蓄積拠点サーバ印刷
 | 1 | 蓄積拠点サーバ印刷および蓄積クライアント印刷
 | 2 | 蓄積クライアント印刷
スプールサーバでの印刷時のプリンタ指定方法 | 0 | プリンタクラス名指定
 | 1 | OS上のプリンタ名指定
 | 2 | 帳票名による自動振り分け
クライアントPCでの印刷時のダイアログ表示モード | 0 | 対話型印刷モード
 | 1 | 自動印刷モード
 | 2 | 対話型印刷プレビューモード
 | 3 | 全自動印刷モード
 | 4 | 対話型印刷プレビュー表示限定モード

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 196 / 218


13.2.3 スプールデータの属性値の変更 : EUR 帳票出力 機能解説 EUR Server編

  • 197 / 218

  • 表紙

  • 13.　スプールデータを管理するには

  • 13.2　業務プログラムで管理する

  • 13.2.3　スプールデータの属性値の変更

13.2.3　スプールデータの属性値の変更

指定したスプールデータの属性値を変更できます。

〈この項の構成〉

  • (1)　変更できる情報

  • (2)　実行メソッド

  • (3)　設定項目

(1)　変更できる情報

変更できる情報を次に示します。

  • 蓄積期限日

  • スプールデータに格納された印刷データの取得可否

  • 印刷上限回数

  • 実行できる印刷方式

  • スプールサーバでの印刷時のプリンタ指定方法

  • スプールサーバ，またはクライアントPCでの印刷時のプリンタクラス名

  • スプールサーバでの印刷時のOS上のプリンタ名

  • スプールサーバでの印刷時のOS上のトレイ名

  • スプールサーバでの印刷時の帳票振り分け定義名

  • クライアントPCでの印刷時のクライアントPCのIPアドレス

  • クライアントPCでの印刷時のダイアログ表示モード

  • クライアントPCでの印刷時のOS上のプリンタ名

  • クライアントPCでの印刷時のOS上のトレイ名

  • ジョブ検索キーの分類

  • ジョブ検索キーの値

ページの先頭へ

(2)　実行メソッド

スプールデータの属性値の変更を実行するメソッドを次の表に示します。

表13‒10 スプールデータの属性値の変更を実行するメソッド
起動部品 | メソッド
SS-ActiveX起動部品 | SetSpoolFileAttribute
SS-Java起動部品 | setSpoolFileAttribute
SS-コマンド起動部品（eurpmlscコマンド） | /mオプションにsetattrを指定

ページの先頭へ

(3)　設定項目

スプールデータの属性値を変更するときに設定する項目を，次の表に示します。

表13‒11 スプールデータの属性値を変更するときに設定する項目
スプールデータの属性値の変更に関する設定 | 起動部品の設定項目 | 設定する値
IPアドレス | SS-ActiveX起動部品：ServerAddressプロパティ SS-Java起動部品：setServerAddressメソッド SS-コマンド起動部品：/svrオプション | 255.255.255.255形式
スプールデータのジョブID | SS-ActiveX起動部品：SearchJobIDプロパティ SS-Java起動部品：setSearchJobIDメソッド SS-コマンド起動部品：/idオプション | ジョブID（36バイト以内の文字列）
蓄積期限日 | SS-ActiveX起動部品：SpoolLimitプロパティ SS-Java起動部品：setSpoolLimitメソッド SS-コマンド起動部品：/lmオプション | YYYYMMDD形式
取得可否 | SS-ActiveX起動部品：EnableGetプロパティ SS-Java起動部品：setEnableGetメソッド | True（取得できる） False（取得できない）
 | SS-コマンド起動部品：/gオプション | get（取得できる） noget（取得できない）
印刷上限回数 | SS-ActiveX起動部品：MaxPrintCountプロパティ SS-Java起動部品：setMaxPrintCountメソッド SS-コマンド起動部品：/xpオプション | 1～65,536（指定した回数印刷できる） -1（無限に印刷できる） 0（印刷を禁止する）
実行できる印刷方式 | SS-ActiveX起動部品：ExecutablePrintModeプロパティ SS-Java起動部品：setExecutablePrintModeメソッド | 0（スプールサーバで印刷できる） 1（スプールサーバ，およびクライアントPCで印刷できる） 2（クライアントPCで印刷できる）
 | SS-コマンド起動部品：/expオプション | sv（スプールサーバで印刷できる） svcl（スプールサーバ，およびクライアントPCで印刷できる） cl（クライアントPCで印刷できる）
スプールサーバのプリンタの指定方法 | SS-ActiveX起動部品：PrinterSelectModeプロパティ SS-Java起動部品：setPrinterSelectModeメソッド | 0（プリンタクラス名で指定する） 1（プリンタ名で指定する） 2（帳票振り分け定義で指定する）
 | SS-コマンド起動部品：/smオプション | class（プリンタクラス名で指定する） printer（プリンタ名で指定する） group（帳票振り分け定義で指定する）
スプールサーバ，およびクライアントPCのプリンタクラス名 | SS-ActiveX起動部品：PrinterClassNameプロパティ SS-Java起動部品：setPrinterClassNameメソッド SS-コマンド起動部品：/prcオプション | プリンタクラス名（80バイト以内の文字列）
スプールサーバのプリンタ名を設定する | SS-ActiveX起動部品：ServerPrinterNameプロパティ SS-Java起動部品：setServerPrinterNameメソッド SS-コマンド起動部品：/lspオプション | プリンタ名（80バイト以内の文字列）
スプールサーバのプリンタのトレイ名 | SS-ActiveX起動部品：ServerTrayNameプロパティ SS-Java起動部品：setServerTrayNameメソッド SS-コマンド起動部品：/lstオプション | トレイ名（80バイト以内の文字列）
スプールサーバの帳票振り分け定義名 | SS-ActiveX起動部品：GroupNameプロパティ SS-Java起動部品：setGroupNameメソッド SS-コマンド起動部品：/groupオプション | 帳票振り分け定義（80バイト以内の文字列）
ダイアログを表示するかどうか | SS-ActiveX起動部品：DispPrintDlgプロパティ SS-Java起動部品：setDispPrintDlgメソッド | 0（対話型印刷） 1（自動印刷） 2（対話型印刷プレビュー表示） 3（全自動印刷）※1 4（対話型印刷プレビュー表示限定）※2
 | SS-コマンド起動部品：/dialogオプション | dialog（対話型印刷） auto（自動印刷） preview（対話型印刷プレビュー表示） fullauto（全自動印刷）※1 pvonly（対話型印刷プレビュー表示限定）※2
クライアントPCのIPアドレス | SS-ActiveX起動部品：ClientAddressプロパティ SS-Java起動部品：setClientAddressメソッド SS-コマンド起動部品：/clientオプション | 255.255.255.255形式
クライアントPCのプリンタ名 | SS-ActiveX起動部品：ClientPrinterNameプロパティ SS-Java起動部品：setClientPrinterNameメソッド SS-コマンド起動部品：/pオプション | プリンタ名（80バイト以内の文字列）
クライアントPCのトレイ名 | SS-ActiveX起動部品：ClientTrayNameプロパティ SS-Java起動部品：setClientTrayNameメソッド SS-コマンド起動部品：/tオプション | トレイ名（80バイト以内の文字列）
ジョブ検索キーの分類 | SS-ActiveX起動部品：JobKeyCategoryプロパティ SS-Java起動部品：setJobKeyCategoryメソッド SS-コマンド起動部品：/caオプション | ジョブ検索キーの分類（80バイト以内の文字列）
ジョブ検索キー | SS-ActiveX起動部品：JobKeyDataプロパティ SS-Java起動部品：setJobKeyDataメソッド SS-コマンド起動部品：/daオプション | ジョブ検索キー（80バイト以内の文字列）
注※1

印刷実行時に印刷中のダイアログが表示されません。

注※2

印刷は実行できません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 197 / 218


13.2.4 スプールデータの削除 : EUR 帳票出力 機能解説 EUR Server編

  • 198 / 218

  • 表紙

  • 13.　スプールデータを管理するには

  • 13.2　業務プログラムで管理する

  • 13.2.4　スプールデータの削除

13.2.4　スプールデータの削除

指定したスプールデータを削除できます。

〈この項の構成〉

  • (1)　実行メソッド

  • (2)　設定項目

(1)　実行メソッド

スプールデータの削除を実行するメソッドを次の表に示します。

表13‒12 スプールデータの削除を実行するメソッド
起動部品 | メソッド
SS-ActiveX起動部品 | DeleteSpoolFile
SS-Java起動部品 | deleteSpoolFile
SS-コマンド起動部品（eurpmlscコマンド） | /mオプションにdelを指定

ページの先頭へ

(2)　設定項目

スプールデータを削除するときに設定する項目を，次の表に示します。

表13‒13 スプールデータを削除するときに設定する項目
スプールデータの削除に関する設定 | 起動部品の設定項目 | 設定する値
スプールサーバのIPアドレス | SS-ActiveX起動部品：ServerAddressプロパティ SS-Java起動部品：setServerAddressメソッド SS-コマンド起動部品：/svrオプション | 255.255.255.255形式
スプールデータのジョブID | SS-ActiveX起動部品：SearchJobIDプロパティ SS-Java起動部品：setSearchJobIDメソッド，またはsetSearchJobIDMultiメソッド SS-コマンド起動部品：/idオプション | ジョブID（36バイト以内の文字列）
削除方法 | SS-ActiveX起動部品：DeleteKindプロパティ SS-Java起動部品：setDeleteKindメソッド | 0（指定したスプールデータだけを削除）
 | SS-コマンド起動部品：/dkオプション | direct（指定したスプールデータだけを削除）

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 198 / 218


13.2.5 期限が切れたスプールデータの一括削除 : EUR 帳票出力 機能解説 EUR Server編

  • 199 / 218

  • 表紙

  • 13.　スプールデータを管理するには

  • 13.2　業務プログラムで管理する

  • 13.2.5　期限が切れたスプールデータの一括削除

13.2.5　期限が切れたスプールデータの一括削除

蓄積期限が切れたスプールデータを一括して削除できます。

〈この項の構成〉

  • (1)　実行メソッド

  • (2)　設定項目

(1)　実行メソッド

蓄積期限が切れたスプールデータの一括削除を実行するメソッドを次の表に示します。

表13‒14 蓄積期限が切れたスプールデータの一括削除を実行するメソッド
起動部品 | メソッド
SS-ActiveX起動部品 | DeleteSpoolFile
SS-Java起動部品 | deleteSpoolFile
SS-コマンド起動部品（eurpmlscコマンド） | /mオプションにdelを指定

ページの先頭へ

(2)　設定項目

蓄積期限が切れたスプールデータを一括削除するときに設定する項目を，次の表に示します。

表13‒15 蓄積期限が切れたスプールデータを一括削除するときに設定する項目
スプールデータの一括削除に関する設定 | 起動部品の設定項目 | 設定する値
スプールサーバのIPアドレス | SS-ActiveX起動部品：ServerAddressプロパティ SS-Java起動部品：setServerAddressメソッド SS-コマンド起動部品：/svrオプション | 255.255.255.255形式
削除方法 | SS-ActiveX起動部品：DeleteKindプロパティ SS-Java起動部品：setDeleteKindメソッド | 1（蓄積期限が切れたスプールデータの一括削除）
 | SS-コマンド起動部品：/dkオプション | expire（蓄積期限が切れたスプールデータの一括削除）

蓄積期限が切れたスプールデータは，次に示すタイミングで自動的に削除することもできます。

  • EUR Server - Spool Serviceのサービスが起動されたとき

  • EUR Server - Spool Serviceが稼働するマシンの日付が変わったあと，EUR Server - Spool Serviceに対して最初の要求があったとき（日付変更の契機にローカルタイムと協定世界時（UTC）のどちらを使用するかを，EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）のOPTIONセクションのSTANDARDTIMEキーで設定できます）

蓄積期限が切れたスプールデータを自動で削除するかどうかは，EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）のOPTIONセクションのESFAUTODELキーで設定できます。ESFAUTODELキーの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 199 / 218


14. 監査ログを出力する : EUR 帳票出力 機能解説 EUR Server編

  • 200 / 218

  • 表紙

  • 14.　監査ログを出力する

14.　監査ログを出力する

この章では，EURの監査ログについて説明します。

〈この章の構成〉

  • 14.1　監査ログとは

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 200 / 218


14.1 監査ログとは : EUR 帳票出力 機能解説 EUR Server編

  • 201 / 218

  • 表紙

  • 14.　監査ログを出力する

  • 14.1　監査ログとは

14.1　監査ログとは

EURでは，スプールデータを操作したときの情報を監査ログとして出力できます。

監査ログを出力するかどうかは，EUR - Spool Serviceの環境設定ファイルで設定します。

監査ログの運用方法には，次の二つの方法があります。

  • 監査証跡管理システムと連携する

    JP1/Audit Management - Managerを導入して構築する監査証跡管理システムと連携することで，監査ログを自動的に収集して一元管理する運用方法です。

    監査証跡管理システムと連携する場合，EUR Server - Spool Serviceの稼働中に監査ログファイルを参照できます。

  • 監査ログを業務プログラムで管理する

    監査ログの管理や運用に独自の規定があるなど，監査証跡管理システムを適用できない場合に，監査ログを業務プログラムで収集して管理する運用方法です。

    監査ログを業務プログラムで管理する場合は，EUR Server - Spool Serviceが出力中の監査ログファイルのバックアップファイルを監査用に参照します。

監査ログの出力には，次の二つの機能があります。

  • 監査ログ出力

    監査ログを監査ログファイルに出力する機能です。

    監査ログファイルは世代管理されます。世代の切り替えが発生すると，バックアップファイルを作成し，監査ログの出力先が新しい監査ログファイルに切り替わります。

  • 監査ログ切り替え

    任意のタイミングで監査ログファイルの世代の切り替えを行う機能です。

    業務プログラムで監査ログを管理して運用する場合は，コマンドまたはメソッドで監査ログ切り替えを実行して作成したバックアップファイルを監査用に参照します。

〈この節の構成〉

  • 14.1.1　監査ログ出力の流れ

  • 14.1.2　監査ログ参照の流れ

  • 14.1.3　注意事項

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 201 / 218


14.1.1 監査ログ出力の流れ : EUR 帳票出力 機能解説 EUR Server編

  • 202 / 218

  • 表紙

  • 14.　監査ログを出力する

  • 14.1　監査ログとは

  • 14.1.1　監査ログ出力の流れ

14.1.1　監査ログ出力の流れ

スプールデータを操作するときの監査ログ出力の流れを，次の図に示します。

図14‒1　監査ログ出力の流れ

[図データ]

  1. 操作要求

    スプールデータの操作要求が，業務プログラムに送られます。

  2. スプールデータの操作指示

    EUR Server - Spool Service Adapterは，スプールデータのジョブIDをEUR Server - Spool Serviceに指示します。

  3. 操作実行

    EUR Server - Spool Serviceは，指示されたジョブIDに該当するスプールデータの操作を実行します。

  4. 操作結果

    EUR Server - Spool Serviceは，指示されたジョブIDに該当するスプールデータの操作の実行結果を取得します。

  5. ログ出力

    スプールデータの操作を実行したときの情報を，監査ログとして監査ログファイルに出力します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 202 / 218


14.1.2 監査ログ参照の流れ : EUR 帳票出力 機能解説 EUR Server編

  • 203 / 218

  • 表紙

  • 14.　監査ログを出力する

  • 14.1　監査ログとは

  • 14.1.2　監査ログ参照の流れ

14.1.2　監査ログ参照の流れ

〈この項の構成〉

  • (1)　監査証跡管理システムと連携する場合

  • (2)　監査ログを業務プログラムで管理する場合

(1)　監査証跡管理システムと連携する場合

監査証跡管理システムと連携する場合の監査ログ参照の流れを，次の図に示します。

図14‒2　監査ログ切り替えの流れ（監査証跡管理システムと連携する場合）

[図データ]

  1. 収集（スプールサーバ）

    スプールサーバ（監査ログ収集対象サーバ）で出力する監査ログが，監査証跡管理システムに収集されます。

  2. 格納（イベントデータベース）

    収集された監査ログが，JP1/Baseの監査ログ専用のイベントデータベースに格納されます。

  3. 収集（監査ログ管理サーバ）

    監査ログ収集対象サーバで蓄積された監査ログが，監査ログ管理サーバに収集されます。

  4. 格納（監査ログ管理データベース）

    収集された監査ログが，監査ログ管理サーバの監査ログ管理データベースに格納されます。

  5. 参照

    監査者は，監査ログを参照します。

ページの先頭へ

(2)　監査ログを業務プログラムで管理する場合

監査ログを業務プログラムで管理する場合の監査ログ参照の流れを，次の図に示します。

図14‒3　監査ログ参照の流れ（監査ログを業務プログラムで管理する場合）

[図データ]

  1. 監査ログ切り替え要求

    監査ログ切り替え要求が，業務プログラムに送られます。

  2. 監査ログ切り替え指示

    EUR Server - Spool Service Adapterは，監査ログ切り替えをEUR Server - Spool Serviceに指示します。

  3. ログ切り替え

    EUR Server - Spool Serviceは，監査ログ切り替えを実行します。

  4. バックアップ作成

    監査ログファイルのバックアップが作成されます。監査ログの出力先が新しい監査ログファイルに切り替えられます。

  5. 参照

    監査者は，監査ログファイルのバックアップを参照します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 203 / 218


14.1.3 注意事項 : EUR 帳票出力 機能解説 EUR Server編

  • 204 / 218

  • 表紙

  • 14.　監査ログを出力する

  • 14.1　監査ログとは

  • 14.1.3　注意事項

14.1.3　注意事項

監査ログを使用するときの注意事項を次に示します。

〈この項の構成〉

  • (1)　監査証跡管理システムと連携するときの注意

  • (2)　ユーザ管理ファイルによる認証を使用するときの注意

  • (3)　監査ログファイルの参照・移動についての注意

  • (4)　監査ログファイルのバックアップファイル作成時の注意

  • (5)　バックアップファイル保持数の設定変更時の注意

  • (6)　監査ログファイルのバックアップ作成時刻についての注意

(1)　監査証跡管理システムと連携するときの注意

  • 監査証跡管理システムと連携する場合は，EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）のSPOOLLOGMODEキーに「0」（監査証跡管理システム連携モード）を指定してください。

    SPOOLLOGMODEキーに「1」（詳細情報モード）を指定すると，EUR Server - Spool Serviceが出力した監査ログは，監査証跡管理システムでフォーマット不正などを検知して正しく扱うことができません。

  • Linux環境で監査証跡管理システムを構築する場合は，EUR Server - Spool ServiceのロケールにUTF-8を設定してください。EUR Server - Spool ServiceのロケールにUTF-8以外を設定すると，監査証跡管理システムが監査ログを正しく扱えません。

ページの先頭へ

(2)　ユーザ管理ファイルによる認証を使用するときの注意

スプールデータを操作するユーザ認証方式に「ユーザ管理ファイルによる認証」を使用する場合，デフォルトユーザが，すべてのスプールデータにアクセスできないように設定する運用を推奨します。

デフォルトユーザがスプールデータにアクセスできる設定の場合，正規のユーザが誤ったユーザ名でスプールデータを操作しているのか，悪意のあるユーザが不正なアクセスを試みているのかの判断が困難になります。

スプールデータを操作するユーザ認証方式に「LDAP認証」を使用する場合は，デフォルトユーザにスプールデータの操作が許可されないため，上記の設定は不要です。

ページの先頭へ

(3)　監査ログファイルの参照・移動についての注意

監査ログファイル「eur_spool_audit.log」を，EUR Server - Spool Serviceの稼働中に参照または移動すると，監査ログファイルの出力結果が不正になる場合があります。

なお，監査ログファイルのバックアップファイル「eur_spool_audit_n.log」（nは整数値）は，EUR Server - Spool Serviceの稼働中に参照または移動しても問題ありません。

ページの先頭へ

(4)　監査ログファイルのバックアップファイル作成時の注意

監査ログファイルのバックアップファイル作成時に，監査ログファイルの出力先に監査ログファイル名と同じ名称のファイルを作成すると，エラーになる場合があります。

ページの先頭へ

(5)　バックアップファイル保持数の設定変更時の注意

監査ログファイルのバックアップファイル「eur_spool_audit_n.log」（nは整数値（世代番号））が作成されている状態で，EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）に指定するバックアップファイル保持数の設定値を，すでに作成されているバックアップファイルの数よりも少ない値に変更した場合，変更後の設定値の範囲を超える世代のバックアップファイルは削除されずにそのまま残ります。

例えば，バックアップファイル保持数の設定値を「4」から「2」に変更した場合，バックアップファイルの世代管理が発生したときに，三つ目と四つ目のバックアップファイルは削除されません。ただし，バックアップファイル保持数の設定値を「2」から「4」に再度変更した場合は，世代管理が発生したときに，四つ目のバックアップファイルが削除されます。

ページの先頭へ

(6)　監査ログファイルのバックアップ作成時刻についての注意

EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）のSPOOLLOGDATEキーで監査ログファイルのバックアップ作成時刻を指定した場合，監査ログファイルのバックアップファイルは，バックアップ作成時刻を経過したあと，EUR Server - Spool Serviceがスプールデータの操作を実行したタイミングで作成されます（バックアップ作成時刻を経過しただけではバックアップファイルは作成されません）。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 204 / 218


付録 : EUR 帳票出力 機能解説 EUR Server編

  • 205 / 218

  • 表紙

  • 付録

付録

〈この付録の構成〉

  • 付録A　帳票出力で使用するファイルの種類

  • 付録B　Excel形式ファイルへ出力される情報

  • 付録C　このマニュアルの参考情報

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 205 / 218


付録A 帳票出力で使用するファイルの種類 : EUR 帳票出力 機能解説 EUR Server編

  • 206 / 218

  • 表紙

  • 付録

  • 付録A　帳票出力で使用するファイルの種類

付録A　帳票出力で使用するファイルの種類

帳票出力で使用するファイルの種類を次の表に示します。

表A‒1　帳票出力で使用するファイルの種類

ファイルの種類

ファイル形式（拡張子）

印刷データファイル

EPF形式ファイル

EPF形式ファイル（*.epf，*.epp）

EUR形式ファイル

EUR形式ファイル（*.eup，*.euv）

PDF形式ファイル

PDF形式ファイル（*.pdf）

Excel形式ファイル

Excel形式ファイル（*.xlsx）

印刷定義ファイル

帳票ファイル

フォームシートファイル（*.fms）

画像ファイル

  • Windows BITMAP（*.bmp）

  • JPEG（*.jpg，*.jpe，*.jpeg）

  • GIF GIF87a（*.gif）

  • GIF GIF89a（*.gif）

  • TIFF 6.0（*.tif，*.tiff）

  • PNG（*.png）

複数様式情報定義ファイル

テキストファイル（任意）

文書情報設定ファイル

接続情報ファイル

新規用紙出力定義ファイル

置き換え表管理情報ファイル

CSV形式ファイル（*.csv）

置き換え表ファイル

Acrobat JavaScript定義ファイル

Acrobat JavaScriptファイル

ビューアプレファレンス定義ファイル

ユーザデータファイル

マッピングデータファイル

データファイル（*.csv，*.dat，*.fix），またはテキストファイル（任意）

ユーザ定義データファイル

可変記号値定義ファイル

しおり定義ファイル

テキストファイル（任意）

文書しおり定義ファイル

暗号化設定ファイル

帳票セット指定ファイル

分割定義ファイル

仕分け定義ファイル

PDF仕分け定義ファイル

CSV形式ファイル（*.csv）

スプールデータ

なし

構成定義ファイル

出力先定義ファイル

CONFファイル（*.conf）

帳票サーバプリンタクラス定義ファイル

印刷先定義ファイル

拠点プリンタクラス定義ファイル

帳票振り分け定義ファイル

ユーザ管理ファイル

クライアントプリンタクラス定義ファイル

宛先定義ファイル

監視定義ファイル

環境設定ファイル

EUR Print Serviceの環境設定ファイル

テキストファイル（拡張子なし）

EUR Server Serviceの環境設定ファイル

テキストファイル（*.ini※）

EUR Server - Adapterの環境設定ファイル

EUR Server - Spool Serviceの環境設定ファイル

EUR Server - Spool Service Adapterの環境設定ファイル

上記以外の環境設定ファイル

テキストファイル（*.ini）

起動管理定義ファイル

CONFファイル（*.conf）

プリンタ定義ファイル（printerinf）

テキストファイル（拡張子なし）

テスト印刷設定ファイル

テキストファイル（任意）

印刷日時出力定義ファイル

制御情報付データファイル

起動パラメタファイル

帳票出力定義ファイル

EURフォントファイル

EDFファイル（*.edf）

EUR Web Plug-In情報ファイル

INFファイル（*.inf）

出力ページ情報ファイル（V8互換機能）

CSV形式ファイル（*.csv）
注※

環境設定ファイルの格納先またはファイル名をデフォルトから変更する場合は，拡張子は任意です。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 206 / 218


付録B Excel形式ファイルへ出力される情報 : EUR 帳票出力 機能解説 EUR Server編

  • 207 / 218

  • 表紙

  • 付録

  • 付録B　Excel形式ファイルへ出力される情報

付録B　Excel形式ファイルへ出力される情報

ここでは，Excel形式ファイルへ出力される情報について説明します。

〈この節の構成〉

  • 付録B.1　Excel形式ファイルへ出力される帳票定義情報

  • 付録B.2　Excel形式ファイルへ出力されるそのほかの情報

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 207 / 218


付録B.1 Excel形式ファイルへ出力される帳票定義情報 : EUR 帳票出力 機能解説 EUR Server編

  • 208 / 218

  • 表紙

  • 付録

  • 付録B　Excel形式ファイルへ出力される情報

  • 付録B.1　Excel形式ファイルへ出力される帳票定義情報

付録B.1　Excel形式ファイルへ出力される帳票定義情報

ここでは，Excel形式ファイルへ出力される帳票定義情報について説明します。

〈この項の構成〉

  • (1)　用紙

  • (2)　文字

  • (3)　線

  • (4)　図形

  • (5)　集計アイテム

  • (6)　繰り返し

  • (7)　ブレイク

  • (8)　帳票ヘッダ

  • (9)　集計行

(1)　用紙

情報の種類 | 帳票ファイルに定義された内容 |  | 出力結果
用紙サイズ | A3 |  | ○
 | A4
 | A5
 | レター
 | リーガル
 | B4 |  | A4
 | B5
 | ハガキ
 | 10×14インチシート
 | 11×17インチシート
 | 15×11インチシート
 | 12×8.5インチシート
 | ユーザ定義 | 幅（1/10mm単位）
 |  | 長さ（1/10mm単位）
印刷の向き | 縦 |  | ○
 | 横
用紙の余白サイズ（上余白，下余白，右余白，左余白） | 数値（0mm以上） |  | 1 cm※
（凡例）

○：定義内容のとおりに反映されます。

注※

Excel画面上での単位の表記は，Windowsの設定によって異なることがあります。単位の表記の詳細については，「4.3.6　注意事項」を参照してください。

用紙の情報の出力結果は，Excel画面の次に示す個所で確認できます。

情報の種類 | Excel画面の表示個所
用紙サイズ | ［ページレイアウト］－［サイズ］
印刷の向き | ［ページレイアウト］－［印刷の向き］
用紙の余白サイズ | ［ページレイアウト］－［余白］

ページの先頭へ

(2)　文字

  • 固定文字列

    機能

    出力結果

    参照先

    配置

    横位置／縦位置

    ○

    付録B.1(2)(a)

    フォント

    フォント名

    ＭＳ 明朝

    ○

    付録B.1(2)(d)

    ＭＳ 明朝以外

    △

    スタイル

    標準

    ○

    太字

    斜体

    太字斜体

    サイズ

    3～256pt

    色

    フルカラー

    フォント縦横比補正を行う

    ×

    下線

    ○

    文字配置

    バージョン2以前の文字配置を行う

    ×

    付録B.1(2)(d)

    文字の方向

    上向き左から右

    ○

    上向き上から下

    左向き下から上

    右向き上から下

    左向き左から右

    △

    文字間隔

    -10.0～100.0pt

    ×

    行間隔

    -10.0～100.0pt

    ワードラップを行う

    △

    付録B.1(2)(c)

    禁則処理を行う

    ×

    CPI指定

    出力ページ

    △

    付録B.1(2)(a)

    条件付きアイテム表示／非表示切り替え
    （凡例）

    ○：出力されます。

    △：加工して出力されます。

    ×：出力されません。

  • マッピングデータ文字列

    機能

    出力結果

    参照先

    表示形式

    前付加文字列

    △

    付録B.1(2)(c)の表B-2

    後付加文字列

    任意書式指定

    配置※

    ○

    付録B.1(2)(a)

    フォント※

    △

    付録B.1(2)(d)

    文字配置※

    アイテムの桁数指定

    △

    付録B.1(2)(c)の表B-5

    縮小して全体を表示

    △

    付録B.1(2)(c)

    ワードラップを行う

    禁則処理を行う

    ×

    置き換え表

    △

    付録B.1(2)(a)

    出力ページ

    条件付きアイテム表示／非表示切り替え

    CPI指定

    ×

    付録B.1(2)(c)
    （凡例）

    ○：出力されます。

    △：加工して出力されます。

    ×：出力されません。

    注※

    下位項目は「固定文字列」と同じになります。

  • マッピングデータ，数値，数値（集計対象外）

    機能

    出力結果

    参照先

    表示形式

    前付加文字列

    ○

    付録B.1(2)(c)の表B-3

    後付加文字列

    ゼロ埋め桁数

    負符号文字

    小数点文字

    コンマ表示

    指数表示

    小数点以下桁揃え

    小数点以下桁数

    配置※

    ○

    付録B.1(2)(a)

    フォント※

    △

    付録B.1(2)(d)

    文字配置※

    0のとき0表示／表示しない／ハイフン表示

    ○

    付録B.1(2)(c)の表B-3

    空データのとき表示しない／ハイフン表示

    △

    アイテムの桁数指定

    △

    付録B.1(2)(c)の表B-5

    縮小して全体を表示

    △

    付録B.1(2)(c)

    置き換え表

    △

    付録B.1(2)(a)

    ワードラップを行う

    △

    付録B.1(2)(c)

    禁則処理を行う

    ×

    出力ページ

    △

    付録B.1(2)(a)

    条件付きアイテム表示／非表示切り替え

    CPI指定

    ×

    付録B.1(2)(c)
    （凡例）

    ○：出力されます。

    △：加工して出力されます。

    ×：出力されません。

    注※

    下位項目は「固定文字列」と同じになります。

  • マッピングデータ，日付時刻

    機能

    出力結果

    参照先

    表示形式

    レポートファイル形式

    和暦／西暦

    △

    付録B.1(2)(c)の表B-4

    配置※

    ○

    付録B.1(2)(a)

    フォント※

    △

    付録B.1(2)(d)

    文字配置※

    縮小して全体を表示

    △

    付録B.1(2)(c)

    ワードラップを行う

    禁則処理を行う

    ×

    出力ページ

    △

    付録B.1(2)(a)

    条件付きアイテム表示／非表示切り替え

    CPI指定

    ×

    付録B.1(2)(c)
    （凡例）

    ○：出力されます。

    △：加工して出力されます。

    ×：出力されません。

    注※

    下位項目は「固定文字列」と同じになります。

  • マッピングデータ，日次／月次／年次

    機能

    出力結果

    参照先

    表示形式

    レポートファイル形式

    和暦／西暦

    △

    付録B.1(2)(c)の表B-4

    フォームシートファイル形式

    配置※

    ○

    付録B.1(2)(a)

    フォント※

    △

    付録B.1(2)(d)

    文字配置※

    縮小して全体を表示

    △

    付録B.1(2)(c)

    ワードラップを行う

    禁則処理を行う

    ×

    出力ページ

    △

    付録B.1(2)(a)

    条件付きアイテム表示／非表示切り替え

    CPI指定

    ×

    付録B.1(2)(c)
    （凡例）

    ○：出力されます。

    △：加工して出力されます。

    ×：出力されません。

    注※

    下位項目は「固定文字列」と同じになります。

  • マッピングデータ，和暦（日次）／和暦（月次）／和暦（年次）

    機能

    出力結果

    参照先

    表示形式

    レポートファイル形式

    和暦

    △

    付録B.1(2)(c)の表B-4

    フォームシートファイル形式

    配置※

    ○

    付録B.1(2)(a)

    フォント※

    △

    付録B.1(2)(d)

    文字配置※

    縮小して全体を表示

    △

    付録B.1(2)(c)

    ワードラップを行う

    禁則処理を行う

    ×

    出力ページ

    △

    付録B.1(2)(a)

    条件付きアイテム表示／非表示切り替え

    CPI指定

    ×

    付録B.1(2)(c)
    （凡例）

    ○：出力されます。

    △：加工して出力されます。

    ×：出力されません。

    注※

    下位項目は「固定文字列」と同じになります。

  • 印刷日付・印刷時刻

    機能

    出力結果

    参照先

    表示形式

    西暦／和暦

    △

    付録B.1(2)(b)の表B-1

    配置※

    ○

    付録B.1(2)(a)

    フォント※

    △

    付録B.1(2)(d)

    文字配置※

    ワードラップを行う

    △

    付録B.1(2)(c)

    禁則処理を行う

    ×

    出力ページ

    △

    付録B.1(2)(a)

    条件付きアイテム表示／非表示切り替え
    （凡例）

    ○：出力されます。

    △：加工して出力されます。

    ×：出力されません。

    注※

    下位項目は「固定文字列」と同じになります。

  • ページ番号

    機能

    出力結果

    参照先

    表示形式

    最大ページ桁数

    任意／1／2／3／4／5

    △

    付録B.1(2)(b)の表B-1

    バージョン2形式

    ページ番号

    ページ数

    バージョン3形式

    初期化あり

    ページ番号

    ページ数

    初期化なし

    ページ番号

    ページ数

    配置※

    ○

    付録B.1(2)(a)

    フォント※

    △

    付録B.1(2)(d)

    文字配置※

    ワードラップを行う

    △

    付録B.1(2)(c)

    禁則処理を行う

    ×

    出力ページ

    △

    付録B.1(2)(a)

    条件付きアイテム表示／非表示切り替え
    （凡例）

    ○：出力されます。

    △：加工して出力されます。

    ×：出力されません。

    注※

    下位項目は「固定文字列」と同じになります。

(a)　出力結果の詳細（アイテムの表示に関するもの）

説明 | 設定値 | 出力結果
繰り返し種別 | 非繰り返し，見出し，繰り返し | △
水平方向の文字揃え※1 | 左揃え， 中央揃え， 右揃え， 均等配置 | 左詰め（インデント）， 中央揃え， 右詰め（インデント）， 均等割り付け（インデント）
垂直方向の文字揃え※1 | 上揃え， 中揃え， 下揃え， 均等配置 | 上詰め， 中央揃え， 下詰め， 均等割り付け
まとめ表示の優先順位 | 階層あり／階層なし | セルを結合します。
まとめ表示※2 | まとめ表示をする／しない | セルを結合します。
 | 罫線をまとめる／まとめない | △
表示・印刷ページ | ［全てのページに出力する］ラジオボタン，［先頭のページだけに出力する］ラジオボタン，または［最終ページだけに出力する］ラジオボタンの指定 | △
表示条件 | ［アイテムの表示条件］ダイアログの設定値
置き換え表※3 | ［置き換え表］タブの設定値
（凡例）

△：帳票設計時に表示されているとおりに出力されます。

注※1

縦／横方向の配置の出力結果は，Excel画面の次に示す表示で確認できます。

情報の種類

Excel画面の表示

縦／横方向の配置

［ホーム］－［配置］

上段：図B-1の1

縦方向配置設定で，左から順に上揃え，中央揃え，下揃えとなります。

下段：図B-1の2

横方向配置設定で，左から順に左揃え，中央揃え，右揃えとなります。
図B‒1　Excel画面の表示

[図データ]

均等割り付けに関しては，［セルの書式設定］－［配置］タブの縦／横位置のプルダウンリストから選択します。

注※2

罫線をまとめた場合の，まとめ表示の表示結果を次の図に示します。

図B‒2　まとめ表示の表示結果（罫線をまとめた場合）

[図データ]

まとめ表示でのセルの結合は，まとめ表示されたキーの繰り返しの先頭位置から終了位置までの領域を結合します。

まとめ表示されたキーの出力位置は，結合されたセルの領域内に，キーが持っている縦／横方向の文字揃え位置（左寄せなど）で出力します。

また，まとめ表示を設定したセルに対し，罫線をまとめるかどうかも設定できます。罫線をまとめない場合の，まとめ表示の表示結果を次の図に示します。

図B‒3　まとめ表示の表示結果（罫線をまとめない場合）

[図データ]

まとめ表示のセルに対して罫線をまとめる設定をしないと，次の例のように，罫線が結合セルの文字アイテムに隠れて表示されない場合があります。この場合，ログにメッセージが出力されます。

注※3

置き換え表で置き換えられた値はすべて文字列として出力します。

(b)　出力結果の詳細（アイテム種別によるもの）

印刷日付・印刷時刻アイテム，ページ番号アイテム

表B‒1 印刷日付・印刷時刻アイテム，ページ番号アイテムの出力結果
説明 | 設定値 | 出力結果
印刷日付・印刷時刻アイテム，ページ番号アイテムの表示フォーマット | ［定義］テキストボックスの指定値 | 文字列として出力します。
印刷日付・印刷時刻アイテム，ページ番号アイテムの種別 | 日付アイテム 時刻アイテム ページ番号アイテム | 文字列として出力します。 印刷日付・印刷時刻は，Excel形式ファイル出力時の日時を出力します。
ページ番号アイテムの表示形式 | ［バージョン2形式］ラジオボタンまたは［バージョン3形式］ラジオボタンの指定 | ×
ページ番号アイテムのときのページ番号桁数 | ［最大ページ桁数］リストボックスの指定値
（凡例）

×：定義内容は反映されません。

(c)　出力結果の詳細（データ装飾）

文字列データ

前付加文字列，後付加文字列，任意書式指定に関しては，文字列の書式として設定するのではなく，これらの書式を一つの文字列として出力します。

表B‒2　文字列データの出力結果

説明

設定値

出力結果

前付加文字列

［前付加文字］テキストボックスの指定値

△

後付加文字列

［後付加文字］テキストボックスの指定値

任意書式指定

［任意書式指定］テキストボックスの指定値
（凡例）

△：帳票設計時に表示されているとおりに出力されます。

数値データ

表B‒3　数値データの出力結果

説明

設定値

出力結果

前付加文字列

［前付加文字］テキストボックスの指定値

前付加文字列として出力します。

後付加文字列

［後付加文字］テキストボックスの指定値

後付加文字列として出力します。

コンマ表示

［コンマ表示］チェックボックスのON／OFF

ONの場合，桁区切り属性として出力します。

小数点以下桁数

［小数点以下桁数］テキストボックスの指定値

指定の桁数を書式に設定します。※1

小数点文字

［小数点文字］テキストボックスの指定値

"."（ピリオド）に統一します。

四捨五入

四捨五入，

切り捨て，

切り上げ

帳票設計時に表示されているとおりに出力します。

ゼロ埋め桁数

［ゼロ埋め桁数］テキストボックスの指定値

書式情報に出力します。

指数表示

［指数表示］チェックボックスのON／OFF

ONの場合，書式情報に出力します。※2

負符号文字

［負符号文字］テキストボックスのON／OFF

書式情報に出力します。

0を表示，非表示，"-"表示

［値が0の場合］グループボックスの指定値

書式情報に出力します。ただし，「0を表示しない」の場合は何も表示しません。

欠損値を非表示，"-"表示

［値が空データの場合］グループボックスの指定値
「表示しない」の場合

何も表示しません。

「"-"」表示の場合

文字"-"を出力します。
注※1

帳票設計時に小数点以下桁数を指定しないでExcel形式ファイルに小数値を出力した場合，小数点以下が表示されないで整数値として表示されます。数式バーでは小数点以下の数値も表示されます。

小数をExcel形式ファイルに出力したい場合，［小数点以下桁数］テキストボックスで小数点以下の桁数を指定してください。桁数を指定しないと，Excel出力時に小数点以下の桁数はデフォルトの「0」が設定されます。

注※2

帳票設計時に指数表示を設定している場合，［小数点以下桁数］テキストボックスで小数点以下の桁数を指定してください。桁数を指定しないと，Excel出力時に小数点以下の桁数はデフォルトの「0」が設定されます。

指数表示する場合は，0より大きく1より小さい数値データを使用できません。

日付・時刻データ

日付・時刻アイテムは文字列として出力します。

表B‒4　日付・時刻データの出力結果

説明

設定値

出力結果

日付フォーマット

［定義］テキストボックス での指定値

△

日付の表示形式

日次，月次，年次，日付・時刻

日次（和暦），月次（和暦），年次（和暦）

元号年1年を元年と表示するかどうか

［元号年1年を元年と表示する］チェックボックスのON／OFF
（凡例）

△：帳票設計時に表示されているとおりに出力されます。

機能ごとの出力結果
桁数の指定

桁数指定が指定されていれば，指定された桁数で出力します。この場合，文字数が桁数を上回っているとエラー（KEEU050-E）となります。

表B‒5　桁数の指定の出力結果

説明

設定値

出力結果

アイテム枠内に入力できる桁数の指定

［桁数を指定］チェックボックスのON／OFF

OFFの場合は何もしません。

ONの場合，指定された桁数で出力します。

アイテムの桁数

1以上の整数値
縮小して全体を表示

「縮小して全体を表示」が設定されていた場合，EURでは設定したポイント数より小さい状態で表示されます。Excel形式ファイルに出力する文字列は，小さくなったポイント数で帳票設計時に表示されているとおりに出力します。Excelでも「縮小して全体を表示する」という項目はありますが，この項目は設定しません。

ワードラップを行う

ワードラップは，Excel形式ファイルに属性としては出力されません。Excel上で文字列の折り返しがある場合，自動的に折り返されますが，EUR サーバ帳票出力機能を使ってExcel形式ファイルに出力する場合，文字列は1行として出力されます。

文字の折り返しに関する注意事項については，「4.3.6　注意事項」を参照してください。

禁則処理を行う

禁則処理は，Excel形式ファイルに属性としては出力されません。

CPI指定

CPIで指定した内容は，Excel形式ファイルに属性としては出力されません。

(d)　出力結果の詳細（フォント，文字方向に関するもの）

説明

設定値

出力結果

フォントの高さ（単位：1pt）※

3～256

ポイント数として出力します。

フォントの太さ※

［スタイル］コンボボックスの設定
「標準」を設定した場合：

太字を設定しません。

「太字」を設定した場合：

太字を設定します。

フォントの傾き※

［スタイル］コンボボックスの設定
「標準」を設定した場合：

斜体を設定しません。

「斜体」を設定した場合：

斜体を設定します。

書体名※

［フォント名］コンボボックスの設定
日本語ロケール：

"MS　明朝"

中国語ロケール：

"NSimSun"

上記以外のロケール：

"Courier New"

フォントの色※

［色］リストボックスの設定

RGB値をフォントの色として出力します。

文字描画方法※

［文字の方向］グループボックスの設定

上向き左から右

Excelのデフォルト

上向き上から下

縦書き

左向き下から上

左へ90度回転

右向き上から下

右へ90度回転

左向き左から右

Excelのデフォルト

バージョン2以前の文字配置を行うかどうか

［バージョン2以前の文字配置を行う］チェックボックスのON／OFF

×

文字幅間隔（単位：1pt）

ポイント数

文字行間隔（単位：1pt）

文字幅間隔指定

標準，狭く，広く

文字行間隔指定

文字の縦横比を2:1に補正するかどうか

［フォント縦横比補正を行う］チェックボックスのON／OFF

下線※

［下線］チェックボックスのON／OFF
チェックボックスがONの場合：

下線を設定します。

チェックボックスがOFFの場合：

下線を設定しません。
（凡例）

×：定義内容は反映されません。

注※

フォント属性の出力結果は，Excel画面の次に示す個所で確認できます。

情報の種類

Excel画面の表示個所

フォントの高さ

［書式設定］ツールバー

フォントの太さ

フォントの傾き

［書式］－［セル］の「配置」

書体名

［書式設定］ツールバー

フォントの色

文字描画方法

下線

なお，EURでの「上向き，上から下」とExcelでの「縦書き」では，見え方が異なります。EURでの「上向き，上から下」では半角英字，半角数字は右向き，それ以外の文字は上向きで表示されますが，Excelでの「縦書き」ではすべて上向きで表示されます。EURでの「上向き，上から下」とExcelでの「縦書き」の見え方の違いを次に示します。

ページの先頭へ

(3)　線

機能 |  |  |  | 出力結果 | 参照先
水平線 垂直線 | 線 | 線種 | 実線 | ○ | 付録B.1(3)(a)の表B-6
 |  |  | 破線
 |  |  | 点線
 |  |  | 一点鎖線
 |  |  | 二点鎖線
 |  |  | 点線（丸）
 |  |  | 点線（角）
 |  | 線幅 | 細線／中線／太線／極太線 | △
 |  |  | 任意サイズ 0.1～10pt
 |  | 線色 | フルカラー | ○
 |  | 繰り返し |  | △
 | 出力ページ |  |  | △
斜線 |  |  |  | ×
（凡例）

○：出力されます。

△：加工して出力されます。

×：出力されません。

(a)　出力結果の詳細

EURでの線アイテムは，Excelでのセル罫線として出力されます。セル罫線は線幅という概念がなく，線種と線幅を合わせて一つのパターンとなります。そのため，線種は表B-7の対応表に従って出力し，線幅は線種によって一意に決定されます。

表B‒6 線アイテムの出力結果
情報の種類 |  | 設定値 | 出力結果
座標 | 線種 | 実線 破線 点線 一点鎖線 二点鎖線 | 表B-7参照
 |  | 破線 点線 一点鎖線 二点鎖線 点線（丸） 点線（角）
 | 線幅 | 細線 中線 太線 極太線
 | 任意線幅 | 1pt単位，0.1～10.0ポイント
 | 線色 | 線の色 | RGB値を線色として出力します。
 | 線の繰り返し | 非繰り返し，見出し，繰り返し | △
 | 線の表示・印刷ページ | ［全てのページに出力する］ラジオボタン，［先頭のページだけに出力する］ラジオボタン，または［最終ページだけに出力する］ラジオボタンの指定
 | アイテムの配置 | ［繰り返し領域の左上を基準］または，［貼付域の左上を基準］の設定
（凡例）

△：帳票設計時に表示されているとおりに出力されます。

線種と線色の出力結果は，Excel画面の次に示す個所で確認できます。

情報の種類 | Excel画面の表示個所
線種 | ［罫線］－［線のスタイル］
線色 | ［罫線］－［線の色］

EURの線種とExcel形式ファイルでの線種の対応を次の表に示します。

表B‒7 EURの線種とExcel形式ファイルでの線種との対応
EUR |  | Excel
線種 | 線幅 | 線種
実線 [図データ] | 1（細線） | 図B-4の5
 | 2（中線）
 | 3（太線） | 図B-4の6
 | 4（極太線）
 | 任意サイズ：0.1pt～1.4pt | 図B-4の5
 | 任意サイズ：1.5pt～2.4pt | 図B-4の6
 | 任意サイズ：2.5pt～10.0pt | 図B-4の7
破線 [図データ] |  | 図B-4の4
点線 [図データ] |  | 図B-4の1※
一点鎖線 [図データ] |  | 図B-4の3
二点鎖線 [図データ] |  | 図B-4の2
点線（丸） [図データ] |  | 図B-4の1※
点線（角） [図データ]
注※

点線・点線（丸）・点線（角）は，Excelの枠線の属性としては区別がないため，すべて同じ線種で出力されます。

図B‒4　Excel形式ファイルでの線種

[図データ]

ページの先頭へ

(4)　図形

機能 |  |  | 出力結果 | 参照先
網掛け | パターン | 14種類 | △ | 付録B.1(4)(a)の表B-9
 | 繰り返し
 | 枠線表示 | 枠線種 | ○
 |  | 枠線幅 | △※2
 |  | 枠線色 | ○※2
 | 背景色 | フルカラー | ○
 | 前景色
角丸四角 | 角丸め |  | △
 | パターン※1 繰り返し 枠線※1 色※1
円／楕円※1 |  |  | ×
多角形※1
出力ページ |  |  | △
条件付きアイテム表示／非表示切り替え
（凡例）

○：出力されます。

△：加工して出力されます。

×：出力されません。

注※1

下位項目は「網掛け」欄と同じになります。

注※2

出力結果は線アイテムと同じになります。

(a)　出力結果の詳細

網掛けアイテムの場合，次に示す表の対応づけに従ってセルの塗りつぶしパターンを決定します。この場合，背景色は「色なし」で，パターンの色は「自動」で統一します。

表B‒8 EURでの網掛けパターンとExcelのセルの塗りつぶしパターンの対応
EUR | Excel
薄い網掛け | 6.25% 灰色（図B-5の2）
やや濃い網掛け
やや薄い網掛け
濃い網掛け
濃い左上り点線
濃い右上り点線
左上り点線
右上り点線
透明（塗りつぶしなし） | 塗りつぶしなし
塗りつぶし | 塗りつぶし（図B-5の1）
横縞 | 6.25% 灰色（図B-5の2）
縦縞
濃い横縞
濃い縦縞
図B‒5　Excelのセルの塗りつぶしパターン

[図データ]

表B‒9 図形アイテムの出力結果
説明 | 設定値 | 出力結果
網掛けのパターン | 薄い網掛け やや濃い網掛け やや薄い網掛け 濃い網掛け 濃い左上り点線 濃い右上り点線 左上り点線 右上り点線 透明（塗りつぶしなし） 塗りつぶし 横縞 縦縞 濃い横縞 濃い縦縞 | 網掛けアイテムの場合，表B-8を参照してください。
図形の繰り返し | 非繰り返し，見出し，繰り返し | △
表示・印刷ページ | ［全てのページに出力する］ラジオボタン，［先頭のページだけに出力する］ラジオボタン，または［最終ページだけに出力する］ラジオボタンの指定
表示条件 | ［アイテムの表示条件］ダイアログの設定値
背景色※1 | ［背景色］リストボックスの指定値 | 背景色としてRGB値を出力します。
前景色※1 | ［前景色］リストボックスの指定値 | パターンの色としてRGB値に変換して出力します。
枠線※1 | ［枠線表示］チェックボックスのON／OFF | ON：枠線を表示します。 OFF：枠線を表示しません。
枠線種※1 | 実線 破線 点線 一点鎖線 二点鎖線 点線（丸） 点線（角） | 網掛けアイテムの場合はセル属性になるので，「付録B.1(3)(a) 出力結果の詳細」を参照してください。
枠線幅※1 | 1（細線），2（中線），3（太線），4（極太線） | 網掛けアイテムの場合はセル属性になるので，「付録B.1(3)(a) 出力結果の詳細」を参照してください。
枠線色 | ［枠線色］リストボックスの指定値 | セル罫線としてRGB値を出力します。
丸め半径X※2 | ［丸め］テキストボックスの指定値 | ×
丸め半径Y※2 | ［丸め］テキストボックスの指定値
枠影有無 | ［影付き］チェックボックスのON／OFF
丸める角 | ［左上］，［左下］，［右上］，［右下］チェックボックスのON／OFF
（凡例）

△：帳票設計時に表示されているとおりに出力されます。

×：定義内容は反映されません。

注※1

セルの色設定，図形の線，図形の枠線の出力結果は，Excel画面の次に示す個所で確認できます。

情報の種類

Excel画面の表示個所

セルの背景色・パターンの色・パターンの種類

［書式］－［セル］

  • 「背景色」：「背景色」に対応

  • 「パターンの色」：「前景色」に対応

  • 「パターンの種類」：

    XML属性値では表B-8に示すとおりに対応づけられています。ただし，網掛けはExcel形式ファイルでの出力先とならない属性です。

図形の枠線種・線幅

［図形の書式設定］－［線のスタイル］－［幅］

［図形の書式設定］－［線のスタイル］－［線の先端］

線種の設定（実線／点線）は次の順に並んでいます。

  • 実線

  • 点線（丸）

  • 点線（角）

  • 破線

  • 一点鎖線

  • 長破線

  • 長一点鎖線

  • 長二点鎖線

点線（丸）は，枠線の先端を設定する必要があります。

図形の枠線の先端設定

［図形の書式設定］－［線のスタイル］－［線の先端］

デフォルトは「四角」です。設定を「丸」へ変更すると，枠線種の点線（丸）になります。
注※2

丸め半径Xおよび丸め半径Yは，角丸四角アイテムの場合の属性値です。Excel形式ファイル出力では，角丸四角アイテムは網掛けアイテムとするため，これらの属性は出力されません。

ページの先頭へ

(5)　集計アイテム

機能 |  | 出力結果 | 参照先
種別 | キー集計 | △ | 付録B.1(5)(a)
 | ヘッダ集計
 | 総集計
集計種別 | 合計／平均／最大／最小／件数 | △ | 付録B.1(5)(a)
配置※ |  | ○ | 付録B.1(2)(a)
フォント※ |  | △ | 付録B.1(2)(d)
文字配置※
ワードラップを行う |  | △ | 付録B.1(2)(c)
禁則処理を行う |  | ×
出力ページ |  | △ | 付録B.1(2)(a)
条件付きアイテム表示／非表示切り替え
（凡例）

○：出力されます。

△：加工して出力されます。

×：出力されません。

注※

下位項目は「付録B.1(2)　文字」の固定文字列と同じになります。

(a)　出力結果の詳細

EURの集計アイテムおよびExcelのセルは，最大有効桁数が15桁です。そのため，集計関数を適用した結果，値が正しく表示できないことがあります。

説明 | 設定値 | 出力結果
集計アイテム | 合計 平均 最大 最小 件数 | 集計結果を数値として出力します。

ページの先頭へ

(6)　繰り返し

  • 環境変数EURPS_EXCEL_REPEAT_MODEがページ単位でシートを分ける設定の場合

    繰り返しは，帳票設計時に表示されているとおりに出力されます。

  • 環境変数EURPS_EXCEL_REPEAT_MODEがページ単位でシートを分けない設定の場合

    縦方向の繰り返しは，Excelの1シート内に出力されます。

(a)　出力結果の詳細

縦繰り返し間隔

  • 環境変数EURPS_EXCEL_REPEAT_MODEがページ単位でシートを分ける設定の場合

    帳票の縦方向の繰り返し間隔をLPIで指定しているときは，アイテムを配置する位置は，LPIをミリメートルに換算した値を元に計算されて出力されます。

  • 環境変数EURPS_EXCEL_REPEAT_MODEがページ単位でシートを分けない設定の場合

    帳票の縦方向の繰り返し間隔を6LPI（約4.23mm）の倍数に切り上げます（6LPIがExcelのシート上での1行になります）。縦繰り返し間隔の調整の例を次の表に示します。

    帳票の縦繰り返し間隔

    調整後の縦繰り返し間隔

    シートでの縦繰り返し間隔

    4mm

    6LPI×1行ごと

    1行

    6mm

    6LPI×2行ごと

    2行

    9mm

    6LPI×3行ごと

    3行

    3LPI×1行ごと

    6LPI×2行ごと

    2行

    なお，帳票設計時のアイテム枠の配置によって，Excel形式ファイル出力時のアイテム枠の高さと縦繰り返し間隔の行数が異なる場合があります。Excel形式ファイル出力時に，アイテム枠の高さと縦繰り返し間隔の行数が変わるときと変わらないときの出力例を次の図に示します。

    また，縦繰り返しのExcelのシート上での行数の上限は1シートあたり10,000です。調整後の縦繰り返し間隔とシートでの縦繰り返し個数の上限の例を次の表に示します。

    調整後の縦繰り返し間隔

    シートでの縦繰り返し個数の上限

    6LPI×1行ごと

    10,000個

    6LPI×2行ごと

    5,000個

    6LPI×3行ごと

    3,333個
まとめ表示に関するもの

まとめ表示の表示結果については，「付録B.1(2)(a)　出力結果の詳細（アイテムの表示に関するもの）」を参照してください。

説明

設定値

出力結果

集計行を分断して表示するかどうか

［集計行で分断しない］のON／OFF

帳票設計時に表示されているとおりに出力されます。

ページの先頭へ

(7)　ブレイク

帳票設計時にデータ中の特定のフィールドをキーとしてブレイクを設定すると，キーとなるデータの値が変化した時点で改ブロックまたは改ページされます。改ブロックまたは改ページされた帳票は，帳票設計時に表示されているとおりにExcel形式ファイルに出力されます。

ページの先頭へ

(8)　帳票ヘッダ

機能 |  | 出力結果 | 参照先
ヘッダ領域 | あり／なし | △ | 付録B.1(8)(a)
ヘッダアイテム
アイテムの配置規準 | 貼り付け域／繰り返し領域
（凡例）

△：加工して出力されます。

(a)　出力結果の詳細

EURでの帳票ヘッダ領域に相当するExcelの機能はありません。見た目は，帳票設計時に表示されているとおりに出力します。

説明 | 設定値 | 出力結果
帳票ヘッダ領域幅 | 帳票ヘッダ領域の設定 | △
帳票ヘッダ領域の表示・非表示 | ON／OFF
アイテムの配置 | ［繰り返し領域の左上を基準］または，［貼付域の左上を基準］の設定
（凡例）

△：帳票設計時に表示されているとおりに出力されます。

ページの先頭へ

(9)　集計行

集計行は，帳票設計時に表示されているとおりに出力されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 208 / 218


付録B.2 Excel形式ファイルへ出力されるそのほかの情報 : EUR 帳票出力 機能解説 EUR Server編

  • 209 / 218

  • 表紙

  • 付録

  • 付録B　Excel形式ファイルへ出力される情報

  • 付録B.2　Excel形式ファイルへ出力されるそのほかの情報

付録B.2　Excel形式ファイルへ出力されるそのほかの情報

ここでは，Excel形式ファイルに出力される情報のうち，帳票定義情報以外の情報について説明します。

〈この項の構成〉

  • (1)　ファイル作成日時

  • (2)　フォームシートバージョン，EUR Serverバージョン

(1)　ファイル作成日時

Excel形式ファイル出力実行時の日付・時刻を，Excel形式ファイル作成日時としてファイルに埋め込みます。ファイル作成日時は，Excel画面の［ドキュメントのプロパティ］－［詳細情報］タブの「作成日時」に出力されます。

ページの先頭へ

(2)　フォームシートバージョン，EUR Serverバージョン

Excel形式ファイル出力時に，フォームシートバージョンおよびライブラリ（Windows環境の場合はLibXLS.dll，UNIX／Linux環境の場合はlibxls.so）のバージョンをExcel画面の［ドキュメントのプロパティ］の「コメント」欄に出力します。

出力形式
Formsheet Vxx.x
PRODUCTCODE VV-RR-SS

xx.x：フォームシートのバージョン番号

PRODUCTCODE：EUR Server Standardの形名

VV-RR-SS：ライブラリのバージョン番号（VV），リビジョン番号（RR），限定番号（SS）

出力例
Formsheet V13.0
P-29D2-5994 09-00

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 209 / 218


付録C このマニュアルの参考情報 : EUR 帳票出力 機能解説 EUR Server編

  • 210 / 218

  • 表紙

  • 付録

  • 付録C　このマニュアルの参考情報

付録C　このマニュアルの参考情報

このマニュアルを読むに当たっての参考情報を示します。

〈この節の構成〉

  • 付録C.1　関連マニュアル

  • 付録C.2　EUR バージョン10での製品体系の変更

  • 付録C.3　EUR バージョン10でのマニュアル体系の変更

  • 付録C.4　このマニュアルでの表記

  • 付録C.5　このマニュアルで使用する略語

  • 付録C.6　KB（キロバイト）などの単位表記について

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 210 / 218


付録C.1 関連マニュアル : EUR 帳票出力 機能解説 EUR Server編

  • 211 / 218

  • 表紙

  • 付録

  • 付録C　このマニュアルの参考情報

  • 付録C.1　関連マニュアル

付録C.1　関連マニュアル

関連マニュアルを次に示します。必要に応じてお読みください。

〈この項の構成〉

  • (1)　EURのマニュアル

  • (2)　関連ソフトウェアのマニュアル

  • (3)　このマニュアルでのマニュアル名表記

(1)　EURのマニュアル

EURの関連マニュアルを次に示します。

  • はじめての帳票作成（3020-7-532）※

    EUR 帳票作成機能をまだ使用したことのない人向けに，簡単な帳票を作成する方法について説明しています。

  • EUR システム設計ガイド（3021-7-001）

    EURを使用した帳票システムの計画・設計時に検討が必要な内容について説明しています。

  • EUR システム構築ガイド（3021-7-002）

    EURを使用した帳票システムを構築する手順について説明しています。

  • EUR 帳票作成 操作ガイド（3021-7-003）

    EUR 帳票作成機能を使用して帳票を作成する方法について説明しています。

  • EUR 帳票作成 画面リファレンス（3021-7-004）

    EUR 帳票作成機能で表示されるダイアログの内容について説明しています。

  • uCosminexus EUR 帳票設計（EUR Form帳票）（3020-7-534）※

    EUR Form帳票作成機能を使用してEUR Form帳票を作成する方法について説明しています。

  • EUR 帳票出力 EUR Designer/EUR Viewer編（3021-7-005）

    EUR DesignerまたはEUR Viewerを使用して，クライアント環境で帳票を出力する方法について説明しています。

  • uCosminexus EUR クライアント帳票出力（3020-7-535）※

    EUR クライアント帳票出力機能のV8互換機能を使用して，クライアント環境で帳票を出力する方法について説明しています。

  • EUR 帳票出力 リファレンス EUR Server編（3021-7-007）

    EUR サーバ帳票出力機能を使って帳票を出力するときに使用するAPIや入力ファイルの設定方法について説明しています。

  • uCosminexus EUR サーバ帳票出力（3020-7-536）※

    EUR ServerのV8互換機能を使用して，サーバ環境で帳票を出力する方法について説明しています。

  • EUR データベース連携ガイド（3021-7-008）

    データベースから抽出したデータを使って帳票を作成および出力する方法，およびEUR 帳票作成機能のデータベースアクセス定義ウィンドウを使用する方法について説明しています。また，データベースの操作時に出力されるメッセージについても説明しています。

  • EUR メッセージ（3021-7-009）

    EURを使用しているときに出力されるメッセージについて説明しています。

  • EUR 用語集（3021-7-010）

    EURシリーズマニュアル内で使用する用語について説明しています。なお，この用語集は日立ソフトウェアマニュアル公開サイト，または製品同梱のヘルプ（Windows版）だけで参照できます。

注※

バージョン8のマニュアルを提供しています。バージョン10の製品に置き換えて参照してください。

ページの先頭へ

(2)　関連ソフトウェアのマニュアル

関連ソフトウェアのマニュアルを次に示します。

  • TPBroker ユーザーズガイド（3000-3-660）

  • TPBroker Developer's Kit - Extension for C++ プログラマーズガイド（3000-3-680）

  • TPBroker Object Transaction Monitor ユーザーズガイド（3000-3-689）

  • COBOL2002　使用の手引　手引編（3000-3-D42）

  • COBOL2002　使用の手引　操作編（3000-3-D43）

  • COBOL2002　操作ガイド（3020-3-D47）

  • COBOL2002　ユーザーズガイド（Web公開限定）（3020-3-D48）

  • SEWB+/REPOSITORY 辞書設計ガイド（3020-3-698）

  • SEWB+/REPOSITORY 辞書設計ガイド（3020-3-N82）

  • DBPARTNER2 Client　操作ガイド（3020-6-027）

  • DABroker（3020-6-031）

  • HiRDB Version 8 UAP開発ガイド（3020-6-356）

  • HiRDB Version 8 メッセージ（3020-6-358）

  • HiRDB Version 9 UAP開発ガイド（3020-6-456）

  • HiRDB Version 9 メッセージ（3020-6-458）

  • JP1 Version 10 JP1/Audit Management - Manager 構築・運用ガイド（3021-3-165）

ページの先頭へ

(3)　このマニュアルでのマニュアル名表記

このマニュアルでは，マニュアル名について，次のように表記しています。

マニュアル名 | 表記
uCosminexus EUR 帳票設計（EUR Form帳票） | EUR 帳票設計（EUR Form帳票）
uCosminexus EUR クライアント帳票出力 | EUR クライアント帳票出力
uCosminexus EUR サーバ帳票出力 | EUR サーバ帳票出力
HiRDB Version 8 UAP開発ガイド HiRDB Version 9 UAP開発ガイド | HiRDB UAP開発ガイド
HiRDB Version 8 メッセージ HiRDB Version 9 メッセージ | HiRDB メッセージ
JP1 Version 10 JP1/Audit Management - Manager 構築・運用ガイド | JP1/Audit Management - Manager 構築・運用ガイド

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 211 / 218


付録C.2 EUR バージョン10での製品体系の変更 : EUR 帳票出力 機能解説 EUR Server編

  • 212 / 218

  • 表紙

  • 付録

  • 付録C　このマニュアルの参考情報

  • 付録C.2　EUR バージョン10での製品体系の変更

付録C.2　EUR バージョン10での製品体系の変更

  • 製品名称を変更しました。

  • uCosminexus EUR Server Print Editionを廃止しました。

EUR バージョン10での製品体系の変更について，次の図に示します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 212 / 218


付録C.3 EUR バージョン10でのマニュアル体系の変更 : EUR 帳票出力 機能解説 EUR Server編

  • 213 / 218

  • 表紙

  • 付録

  • 付録C　このマニュアルの参考情報

  • 付録C.3　EUR バージョン10でのマニュアル体系の変更

付録C.3　EUR バージョン10でのマニュアル体系の変更

  • マニュアル名を変更しました。

EUR バージョン10でのマニュアル体系の変更について，次の表に示します。

EUR バージョン9 | EUR バージョン10
uCosminexus EUR システム設計ガイド | EUR システム設計ガイド
uCosminexus EUR システム構築ガイド | EUR システム構築ガイド
uCosminexus EUR 帳票作成 操作ガイド | EUR 帳票作成 操作ガイド
uCosminexus EUR 帳票作成 画面リファレンス | EUR 帳票作成 画面リファレンス
uCosminexus EUR 帳票出力 機能解説 EUR Server編 | EUR 帳票出力 機能解説 EUR Server編
uCosminexus EUR 帳票出力 リファレンス EUR Server編 | EUR 帳票出力 リファレンス EUR Server編
uCosminexus EUR 帳票出力 EUR Designer/EUR Viewer編 | EUR 帳票出力 EUR Designer/EUR Viewer編
uCosminexus EUR データベース連携ガイド | EUR データベース連携ガイド
uCosminexus EUR メッセージ | EUR メッセージ
uCosminexus EUR 用語集 | EUR 用語集

EUR ServerのV8互換機能を使用する場合は，バージョン8対応のマニュアル「EUR サーバ帳票出力」を参照してください。Windows環境では，インストール先フォルダ\Print\1041\Help\eurps.chmに統合ヘルプが格納されています。

クライアント帳票出力機能のV8互換機能を使用する場合は，バージョン8対応のマニュアル「EUR クライアント帳票出力」を参照してください。Windows環境では，次のフォルダにヘルプが格納されています。

  • EUR Designerの場合

    EUR Designerのインストール先フォルダ\Designer\1041\Help\euroutp.chm

  • EUR Viewerの場合

    EUR Viewerのインストール先フォルダ\1041\Help\euroutp.chm

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 213 / 218


付録C.4 このマニュアルでの表記 : EUR 帳票出力 機能解説 EUR Server編

  • 214 / 218

  • 表紙

  • 付録

  • 付録C　このマニュアルの参考情報

  • 付録C.4　このマニュアルでの表記

付録C.4　このマニュアルでの表記

このマニュアルでは，EURの各製品について，次のように表記しています。

表記 |  | 製品名称
EUR Designer |  | EUR Designer
EUR Developer |  | EUR Developer
EUR Viewer |  | EUR Viewer
EUR Server | EUR Server Enterprise | EUR Server Enterprise
 | EUR Server Standard | EUR Server Standard
EUR Server - Cipher option |  | EUR Server - Cipher option
EUR Server Print Edition |  | uCosminexus EUR Server Print Edition
EUR Print Manager - Client |  | uCosminexus EUR Print Manager - Client
EUR Print Manager - Report Server |  | uCosminexus EUR Print Manager - Report Server
EUR Print Service |  | uCosminexus EUR Print Service
EUR Print Service Enterprise |  | uCosminexus EUR Print Service Enterprise
EUR Form | EUR Form Service | uCosminexus EUR Form Service
EUR Form Service - Data Store option |  | uCosminexus EUR Form Service - Data Store option

EUR以外の製品名称などについては，次のように表記しています。

表記 |  | 製品名称
BSP-RM |  | BSP-RM(R)
COBOL |  | COBOL2002
DABroker |  | DABroker 03-17以降 DABroker 03-21以降 DABroker(64) 03-20以降 DABroker(64) 03-21以降
HiRDB |  | HiRDB/Run Time Version 8 08-00 以降 HiRDB/Developer's Kit Version 8 08-00 以降 HiRDB/Run Time Version 8(64) 08-00 以降 HiRDB/Developer's Kit Version 8(64) 08-00 以降 HiRDB/Run Time Version 9 09-00以降 HiRDB/Developer's Kit Version 9 09-00以降 HiRDB/Developer's Suite Version 9 09-00以降 HiRDB/Run Time Version 9(64) 09-00以降 HiRDB/Developer's Kit Version 9(64) 09-00以降 HiRDB Server Version 9 09-00以降 HiRDB Server with Additional Function Version 9 09-00以降
IPF |  | Itanium(R) Processor Family
Linux | Linux 6 | Red Hat Enterprise Linux(R) Server 6 (64-bit x86_64)
 | Linux 7 | Red Hat Enterprise Linux(R) Server 7 (64-bit x86_64)
ODBC Driver |  | EURODBC Driver
 |  | DBPARTNER ODBC Driver 01-11以降
Oracle | Oracle 10g | Oracle 10g 10.1.0 Oracle 10g 10.2.0
 | Oracle 11g | Oracle Database 11g 11.1.0 Oracle Database 11g R2 11.2.0
SEWB+ |  | Software Engineering Workbench+
Hitachi Application Server |  | Hitachi Application Server uCosminexus Application Server uCosminexus Application Server Enterprise uCosminexus Application Server Standard
UNIX | AIX | AIX V6.1 AIX V7.1 AIX V7.2
 | HP-UX | HP-UX 11i V3(IPF)

このほか，このマニュアルでは，次に示す表記を使用しています。

  • EURの各製品を区別する必要がない場合は，総称してEURと表記します。

  • EUR Designer，EUR Developerの帳票作成機能を「EUR 帳票作成機能」と表記します。

  • EUR DeveloperのEUR Form帳票作成機能を「EUR 帳票作成機能（EUR Form帳票）」と表記します。

  • EUR Designer，EUR Developer，EUR Viewerのクライアント環境での帳票出力機能を「EUR クライアント帳票出力機能」と表記します。

  • EUR Developer，EUR Server Enterprise，EUR Server Standardのサーバ環境での帳票出力機能を「EUR サーバ帳票出力機能」と表記します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 214 / 218


付録C.5 このマニュアルで使用する略語 : EUR 帳票出力 機能解説 EUR Server編

  • 215 / 218

  • 表紙

  • 付録

  • 付録C　このマニュアルの参考情報

  • 付録C.5　このマニュアルで使用する略語

付録C.5　このマニュアルで使用する略語

このマニュアルで使用する英略語を次に示します。

英略語 | 英字での表記
API | Application Programming Interface
ASP | Active Server Pages
BOM | Byte Order Mark
COBOL | COmmon Business Oriented Language
CPI | Characters Per Inch
CSV | Comma Separated Value
DLL | Dynamic Linking Library
DPI | Dot Per Inch
EAN | European Article Number
EJB | Enterprise JavaBeans
EMF | Enhanced Metafile
EOF | End Of File
EUR | End-User Reporting
GIF | Graphics Interchange Format
GUI | Graphical User Interface
HTTP | Hyper Text Transfer Protocol
ID | IDentifier
IPF | Itanium(R) Processor Family
ISO | International Organization for Standardization
IVS | Ideographic Variation Sequence/Selector
JAN | Japanese Article Number
JDK | Java Development Kit
JIS | Japanese Industrial Standards
JPEG | Joint Photographic Experts Group
JSP | Java Server Pages
LAN | Local Area Network
LDAP | Lightweight Directory Access Protocol
LIPS | LBP Image Processing System
LPI | Lines Per Inch
MFC | Microsoft Foundation Class
MIME | Multipurpose Internet Mail Extension
MSI | Microsoft Windows Installer
MUI | Multi User Interface
OCR | Optical Character Reader
OCX | OLE Custom Control (OLE Control eXtension)
ODBC | Open Database Connectivity
OLE | Object Linking and Embedding
PCF | Portable Compiled Format
PDF | Portable Document Format
PDL | Page Description Language
PNG | Portable Network Graphics
RPM | RPM Package Manager
SSL | Secure Sockets Layer
TIFF | Tagged Image File Format
TLS | Transport Layer Security
UAP | User Application Program
UPC | Universal Product Code
UTC | Coordinated Universal Time
WAN | Wide Area Network
XML | eXtensible Mark-up Language

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 215 / 218


付録C.6 KB（キロバイト）などの単位表記について : EUR 帳票出力 機能解説 EUR Server編

  • 216 / 218

  • 表紙

  • 付録

  • 付録C　このマニュアルの参考情報

  • 付録C.6　KB（キロバイト）などの単位表記について

付録C.6　KB（キロバイト）などの単位表記について

1KB（キロバイト），1MB（メガバイト），1GB（ギガバイト），1TB（テラバイト）はそれぞれ1,024バイト，1,0242バイト，1,0243バイト，1,0244バイトです。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 216 / 218


索引 : EUR 帳票出力 機能解説 EUR Server編

  • 217 / 218

  • 表紙

  • 索引

索引

  • 記号

  • A B C D E G J M P S

  • あ行 か行 さ行 た行 な行 は行 ま行 や行 ら行

記号

  • ［検索］ダイアログでIVSの漢字文字を入力した場合の動作

ページの先頭へ

A

  • Acrobat JavaScript定義ファイル

  • Acrobat JavaScriptファイル

  • ActiveX起動部品

  • ActiveXクライアント印刷

  • Adobe ReaderのGUIの制御情報を設定して出力する〔PDF形式ファイルの出力〕

ページの先頭へ

B

  • BSP-RMで生成された帳票を出力する

  • BSP-RM連携機能

  • BSP-RM連携コマンド

  • BSP-RM連携コマンド〔役割〕

ページの先頭へ

C

  • COBOL起動部品

ページの先頭へ

D

  • DABroker〔役割〕

ページの先頭へ

E

  • EPF形式〔概要〕

  • EUR Client Service〔役割〕

  • EUR Designer〔役割〕

  • EUR Developer〔役割〕

  • eurecfile.exe

  • eurecpdf

  • eurecpdf.exe

  • eurecpdfコマンド

  • eurpmcepfviewerコマンド〔印刷〕

  • eurpmcepfviewerコマンド〔プレビュー〕

  • eurpmcコマンド

  • eurpmlscコマンド

  • EUR Print Service〔役割〕

  • EUR Server Enterprise〔位置づけ〕

  • EUR Server Service〔役割〕

  • EUR Server Standard〔位置づけ〕

  • EUR Serverの種類

  • EUR Serverの特長

  • EUR Serverを構成するコンポーネント

  • EUR Server - Adapter〔役割〕

  • EUR Server - Cipher option〔役割〕

  • EUR Server - Spool Service Adapter〔役割〕

  • EUR Server - Spool Service〔役割〕

  • eursmprコマンド

  • EUR Web Plug-In〔役割〕

  • EUR形式〔概要〕

  • EUR形式ファイルを出力する

  • Excel形式〔概要〕

  • Excel形式ファイルへ出力される情報

  • Excel形式ファイルを出力する

ページの先頭へ

G

  • GUIで管理する〔スプールデータ〕

ページの先頭へ

J

  • JavaScriptプログラムを埋め込んで出力する〔PDF形式ファイルの出力〕

  • Java起動部品

ページの先頭へ

M

  • MIMEタイプ〔印刷〕

  • MIMEタイプ〔プレビュー〕

ページの先頭へ

P

  • PDF暗号化仕分け出力

  • PDF暗号化分割出力

  • PDF形式〔概要〕

  • PDF形式ファイルの設定内容

  • PDF形式ファイルを示すしおり

  • PDF形式ファイルを出力する

  • PDF仕分け出力

  • PDFパスワード暗号化ツール

  • PDFパスワード暗号化ツール〔PDF形式ファイル出力〕

  • PDF分割出力

  • PDF文書情報

ページの先頭へ

S

  • SS-ActiveX起動部品

  • SS-Java起動部品

  • SS-コマンド起動部品

ページの先頭へ

あ行

あ

  • アイテムの出力規則〔Excel形式ファイルの出力〕

  • アイテムのデータを置き換えて出力する

  • アクセス制限の例〔スプールデータ〕

  • 暗号化して出力する〔PDF形式ファイルの出力〕

  • 暗号化出力

  • 暗号化設定ファイル

い

  • ［印刷先指定］ダイアログ

  • 印刷先定義ファイル

  • 印刷定義ファイル

  • 印刷データを蓄積する手順

  • 印刷日時出力定義ファイル

  • 印刷日時を帳票に出力する

  • 印刷領域

え

  • 英語環境用のインタフェースを提供しています〔特長〕

  • エディションごとの利用可否

お

  • 置き換え表管理情報ファイル

  • 置き換え表ファイル

ページの先頭へ

か行

か

  • 解像度を指定して出力する〔PDF形式ファイルの出力〕

  • ［拡大率の指定］ダイアログ

  • 格納先〔スプールデータ〕

  • 画像ファイル

  • 可変記号値

  • 可変記号値定義ファイル

  • 画面構成〔帳票管理GUI〕

  • 環境設定ファイル

  • 監査ログ

  • 監査ログ切り替え

  • 監査ログ出力

  • 監査ログの運用方法

  • 監査ログを出力する

  • 監視定義ファイル

き

  • 期限が切れたスプールデータの一括削除〔業務プログラム〕

  • 期限が切れたスプールデータの一括削除〔帳票管理GUI〕

  • 起動パラメタファイル, [2]

  • 機能〔帳票管理GUI〕

  • きめ細かな出力設定が簡単にできます〔特長〕

  • 業務プログラムで管理する〔スプールデータ〕

  • 業務プログラムと連携できます〔特長〕

く

  • クライアントPCでプレビューする

  • クライアントPCでプレビューする〔蓄積印刷〕

  • クライアントPCのプリンタに出力する

  • クライアントPCのプリンタに出力する〔蓄積印刷〕

け

  • ［検索］ダイアログ

こ

  • 構成定義ファイル

  • 構成要素〔スプールデータ〕

  • コーディング例〔配送印刷〕

  • 個人番号管理サービスと連携して個人番号を含む帳票を出力する

  • 個人番号管理サービスと連携できます〔特長〕

  • 個人番号管理サービス連携機能

  • 個人番号接続情報ファイル

  • 個人番号接続情報ファイルを暗号化する

  • 個人番号フィールド情報ファイル

  • コマンド起動部品

ページの先頭へ

さ行

さ

  • サーバのプリンタに出力する

  • サーバのプリンタに出力する〔蓄積印刷〕

  • 再印刷する〔配送印刷〕

  • サブ文書の情報を示すしおり

  • サブ様式グループ

  • さまざまなファイル形式で出力できます〔特長〕

し

  • しおり

  • しおり定義ファイル

  • しおりを付けて出力する〔PDF形式ファイルの出力〕

  • 私書箱に登録する〔配送印刷〕

  • 事前定義型〔帳票自動出力機能〕

  • 実行例〔配送印刷〕

  • ［指定ページへジャンプ］ダイアログ

  • 指定例〔帳票ID〕

  • 指定例〔プリンタ定義ファイル〕

  • 自動印刷

  • 柔軟な帳票出力環境を構築できます〔特長〕

  • 出力されるExcel形式ファイルの形式

  • 出力した総ページ数の取得

  • 出力した総ページ数の取得で使用する起動部品

  • 出力できるファイル形式

  • 出力ページ数／シート数の上限

  • 出力例〔複数様式〕

  • 準備しておくこと〔配送印刷〕

  • 上位主導型〔帳票自動出力機能〕

  • 書式指定コード

  • 仕分けして出力する

  • 仕分け出力

  • 仕分け定義ファイル

す

  • 図形アイテムの出力規則〔Excel形式ファイル出力〕

  • スプールサーバ

  • スプールサーバのサーバ情報の取得〔帳票管理GUI〕

  • スプールデータ

  • スプールデータの一覧取得〔業務プログラム〕

  • スプールデータの一覧取得〔帳票管理GUI〕

  • スプールデータの検索〔帳票管理GUI〕

  • スプールデータの削除〔業務プログラム〕

  • スプールデータの削除〔帳票管理GUI〕

  • スプールデータの属性値の参照〔帳票管理GUI〕

  • スプールデータの属性値の取得〔業務プログラム〕

  • スプールデータの属性値の変更〔業務プログラム〕

  • スプールデータの属性値の変更〔帳票管理GUI〕

  • スプールデータを管理する

せ

  • 制御情報付データファイル, [2]

  • 製品構成

  • 接続情報ファイル

  • 線アイテムの出力規則〔Excel形式ファイル出力〕

  • 全自動印刷

そ

  • 属性情報〔EUR形式ファイル出力〕

  • 属性情報〔PDF形式ファイル出力〕

  • 属性情報〔スプールデータ〕

  • 属性情報の種類と設定方法

  • 属性情報の利用例

  • 属性情報〔プリンタ出力〕

ページの先頭へ

た行

た

  • 単一様式

ち

  • 蓄積印刷

  • 蓄積した印刷データを出力する

  • 蓄積仕分け出力

  • 蓄積分割出力

  • 注意事項〔EUR形式ファイル出力〕

  • 注意事項〔Excel形式ファイル出力〕

  • 注意事項〔PDF形式ファイル出力〕

  • 帳票ID

  • 帳票IDの指定で使用する起動部品

  • 帳票管理GUI

    • ［印刷］画面

    • ［拡大率の指定］ダイアログ

    • ［検索］ダイアログ

    • ［指定ページジャンプ］ダイアログ

    • 状態表示領域

    • ツリー領域

    • ［プレビュー］画面

    • メイン画面

    • メニュー領域

    • ［ユーザの設定］画面

    • リストビュー領域

  • 帳票管理GUIサービス〔役割〕

  • 帳票管理GUIを使用して出力する

  • 帳票管理システム「BSP-RM」と連携できます〔特長〕

  • 帳票自動出力機能

  • 帳票出力定義ファイル

  • 帳票出力で使用するファイルの種類

  • 帳票出力の流れ

  • 帳票セット

  • 帳票セット指定ファイル

  • 帳票セットの複数指定

  • 帳票セットを複数指定した場合の動作

  • 帳票にアクセスできるユーザを制限する

  • 帳票の印刷データを取得する

  • 帳票の印刷データを蓄積する

  • 帳票の出力で使用するプリンタ

  • 帳票の出力に必要なファイルと出力内容との関係

  • 帳票ファイル

  • 帳票様式の種類

て

  • データ単位の帳票出力〔複数様式〕

  • データファイル

  • データファイルを監視して自動的に帳票出力できます〔特長〕

  • データベースからデータを読み込んで出力する

  • テスト印刷設定ファイル

  • テスト印刷用の文字列を出力する

  • デフォルトユーザ

と

  • 統合後の属性情報〔EPF形式ファイル〕

  • 統合後の属性情報〔スプールデータ〕

  • 統合出力

  • 統合出力〔EPF形式ファイル〕

  • 統合出力〔スプールデータ〕

ページの先頭へ

な行

に

  • 日時情報に出力できる文字列

ページの先頭へ

は行

は

  • 配送印刷

  • 配送印刷した帳票の状態などを確認する

  • 配送印刷する

  • 配送印刷する手順

  • 配送印刷の流れ

  • 配送サービス〔役割〕

  • 配布印刷〔自動印刷〕

  • 配布印刷〔対話型印刷〕

  • 配布印刷〔プレビュー〕

ひ

  • ビューアプレファレンス定義ファイル

  • 表示方法〔帳票管理GUI〕

ふ

  • ファイル監視サービス

  • ファイル監視サービスの登録

  • ファイル監視サービス〔役割〕

  • ファイル出力

  • ファイル出力で使用する起動部品

  • ファイル取得

  • フォントを埋め込んで出力する〔PDF形式ファイルの出力〕

  • 複数帳票の一括出力

  • 複数の帳票セットを指定した一括出力との違い

  • 複数様式

  • 複数様式情報定義ファイル

  • 複数様式で出力できる帳票

  • 複数様式で帳票を出力する

  • プリンタクラス

  • プリンタ定義〔UNIX／Linux環境〕

  • プリンタ定義ファイルでのプリンタ定義〔AIX環境の場合〕

  • プリンタ定義ファイルでのプリンタ定義〔HP-UX環境の場合〕

  • プリンタ定義ファイルでのプリンタ定義〔Linux環境の場合〕

  • プリンタに出力する〔クライアントPC〕

  • プリンタに出力する〔スプールサーバ〕

  • プリンタに出力する〔スプールサーバ（EUR Server連携）〕

  • プリンタに出力する〔帳票サーバ〕

  • プレビューウィンドウ〔対話型印刷〕

  • プレビューウィンドウ〔ヘルパクライアント印刷〕

  • プレビューする〔クライアントPC〕

  • ［プロパティ］ダイアログ

  • 分割出力

  • 分割定義ファイル

  • 文書しおり定義ファイル

  • 文書情報設定ファイル〔PDF形式ファイル出力〕

へ

  • ヘルパクライアント印刷

ほ

  • ほかのEUR製品との関連

ページの先頭へ

ま行

め

  • メモリ出力

  • メモリ出力で使用する起動部品

  • メモリ取得

も

  • 文字アイテムの出力規則〔Excel形式ファイル出力〕

ページの先頭へ

や行

ゆ

  • ユーザ定義

  • ユーザデータファイル

  • ユーザの設定〔帳票管理GUI〕

よ

  • 様式グループ

ページの先頭へ

ら行

り

  • 両面印刷で常に用紙の表面に出力する対象の帳票ファイルを指定する

れ

  • 連携製品

  • 連携プロファイル

  • 連続したページ番号の付加〔複数様式〕

ろ

  • ロケール

  • ロケール〔Excel形式ファイルの出力〕

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 217 / 218


マニュアル発行元 : EUR 帳票出力 機能解説 EUR Server編

  • 218 / 218

  • 表紙

  • マニュアル発行元

マニュアル発行元

株式会社 日立製作所

〒100‒8280　東京都千代田区丸の内一丁目6番6号

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 218 / 218


目次 : EUR 帳票出力 機能解説 EUR Server編

  • 2 / 218

  • 表紙

  • 目次

目次

  • 前書き

  • 変更内容

  • はじめに

  • 第1編　EUR Serverの概要

    • 1.　EUR Serverとは

      • 1.1　EUR Serverの特長

        • 1.1.1　柔軟な帳票出力環境を構築できます

        • 1.1.2　さまざまなファイル形式で出力できます

        • 1.1.3　きめ細かな出力設定が簡単にできます

        • 1.1.4　英語環境用のインタフェースを提供しています

        • 1.1.5　業務プログラムと連携できます

        • 1.1.6　データファイルを監視して自動的に帳票出力できます

        • 1.1.7　帳票管理システム「BSP-RM」と連携できます

        • 1.1.8　個人番号管理サービスと連携できます

      • 1.2　製品構成

        • 1.2.1　EUR Serverを構成するコンポーネント

        • 1.2.2　ほかのEUR製品との関連

        • 1.2.3　連携製品

  • 第2編　EUR Serverを使用した帳票出力

    • 2.　帳票出力の概要

      • 2.1　帳票出力の流れ

      • 2.2　帳票の出力に必要なファイルと出力内容との関係

      • 2.3　帳票セットとは

        • 2.3.1　帳票セットを複数指定した場合の動作

        • 2.3.2　帳票セット指定ファイルの利用

      • 2.4　帳票IDとは

        • 2.4.1　帳票出力定義ファイルの利用

        • 2.4.2　帳票IDの指定で使用する起動部品

        • 2.4.3　帳票IDの指定例

      • 2.5　帳票様式の種類

      • 2.6　出力できるファイル形式とページ数／シート数の上限

      • 2.7　出力した総ページ数の取得

        • 2.7.1　出力した総ページ数の取得で使用する起動部品

      • 2.8　ファイル出力とメモリ出力

        • 2.8.1　出力で使用する起動部品

        • 2.8.2　ファイル出力とメモリ出力のコーディング例

      • 2.9　帳票の出力で使用するプリンタ

        • 2.9.1　プリンタクラスの利用

        • 2.9.2　UNIX／Linux環境でのプリンタ定義

    • 3.　出力先を選んで出力する

      • 3.1　サーバのプリンタに出力するには

        • 3.1.1　帳票サーバのプリンタに出力する

        • 3.1.2　スプールサーバのプリンタに出力する

        • 3.1.3　スプールサーバのプリンタに出力する（EUR Server連携）

      • 3.2　クライアントPCのプリンタに出力するには

        • 3.2.1　自動で出力する

        • 3.2.2　自動で出力する（配布印刷）

        • 3.2.3　ダイアログでプリンタを設定して出力する

        • 3.2.4　ダイアログでプリンタを設定して出力する（配布印刷）

        • 3.2.5　EUR Web Plug-Inを使用して出力する

        • 3.2.6　EUR Client Serviceをヘルパ起動して出力する

        • 3.2.7　コマンドを実行して出力する

      • 3.3　クライアントPCでプレビューするには

        • 3.3.1　転送された帳票をプレビューする

        • 3.3.2　配布された帳票をプレビューする

        • 3.3.3　EUR Web Plug-Inを使用してプレビューする

        • 3.3.4　EUR Client Serviceをヘルパ起動してプレビューする

        • 3.3.5　コマンドを実行してプレビューする

    • 4.　ファイル形式を選んで出力する

      • 4.1　PDF形式ファイルを出力するには

        • 4.1.1　出力の流れ

        • 4.1.2　暗号化して出力する

        • 4.1.3　しおりを付けて出力する

        • 4.1.4　フォントを埋め込んで出力する

        • 4.1.5　解像度を指定して出力する

        • 4.1.6　JavaScriptプログラムを埋め込んで出力する

        • 4.1.7　Adobe ReaderのGUIの制御情報を設定して出力する

        • 4.1.8　コーディング例

        • 4.1.9　注意事項

      • 4.2　EUR形式ファイルを出力するには

        • 4.2.1　出力の流れ

        • 4.2.2　コーディング例

        • 4.2.3　注意事項

      • 4.3　Excel形式ファイルを出力するには

        • 4.3.1　出力の流れ

        • 4.3.2　アイテムの出力規則

        • 4.3.3　出力されるExcel形式ファイルの形式

        • 4.3.4　必要なロケール

        • 4.3.5　コーディング例

        • 4.3.6　注意事項

    • 5.　スプールデータを出力するには

      • 5.1　スプールデータとは

        • 5.1.1　スプールデータの格納先

        • 5.1.2　スプールデータの管理

        • 5.1.3　スプールデータのアクセス制限

      • 5.2　帳票の印刷データを蓄積する

        • 5.2.1　蓄積の流れ

        • 5.2.2　印刷データを蓄積する手順

        • 5.2.3　コーディング例

      • 5.3　帳票の印刷データを取得する

        • 5.3.1　印刷データをファイル取得する

        • 5.3.2　印刷データをメモリ取得する

        • 5.3.3　コーディング例

        • 5.3.4　帳票管理GUIを使用して印刷データをPDF形式ファイルで取得する

        • 5.3.5　取得するPDF形式ファイルのプロパティ情報と注意事項

      • 5.4　蓄積した印刷データを出力する

        • 5.4.1　スプールサーバで出力する

        • 5.4.2　クライアントPCで出力する

        • 5.4.3　帳票管理GUIを使用して出力する

    • 6.　仕分け・分割・統合して出力する

      • 6.1　仕分けして出力するには

        • 6.1.1　PDF仕分け出力する

        • 6.1.2　PDF暗号化仕分け出力する

        • 6.1.3　蓄積仕分け出力する

        • 6.1.4　コーディング例

        • 6.1.5　注意事項

      • 6.2　分割して出力するには

        • 6.2.1　PDF分割出力する

        • 6.2.2　PDF暗号化分割出力する

        • 6.2.3　蓄積分割出力する

        • 6.2.4　コーディング例

      • 6.3　統合して出力するには

        • 6.3.1　複数のEPF形式ファイルを統合出力する

        • 6.3.2　複数のスプールデータを統合出力する

        • 6.3.3　コーディング例

    • 7.　帳票を配送印刷する

      • 7.1　配送印刷とは

      • 7.2　配送印刷の流れ

        • 7.2.1　配送印刷をする前に準備しておくこと

        • 7.2.2　帳票を私書箱に登録する

        • 7.2.3　帳票を配送印刷する手順

        • 7.2.4　配送印刷した帳票の状態などを確認する

        • 7.2.5　帳票を再印刷する

        • 7.2.6　コーディング例

      • 7.3　配送印刷の実行例

        • 7.3.1　配送印刷するユーザを登録する

        • 7.3.2　自分宛て帳票の取得を設定する

        • 7.3.3　配送サービスのURLを設定する

        • 7.3.4　配送サービスにログインする

        • 7.3.5　配送印刷を実行する

    • 8.　監視フォルダに格納したデータファイルを自動的に出力する

      • 8.1　帳票自動出力機能とは

        • 8.1.1　帳票自動出力の流れ

        • 8.1.2　着信したファイルの処理順序

        • 8.1.3　監視管理フォルダ

        • 8.1.4　出力で使用するファイル

        • 8.1.5　ファイル監視サービスの登録

        • 8.1.6　障害が発生した場合のジョブの再投入

        • 8.1.7　制限事項

        • 8.1.8　注意事項

    • 9.　BSP-RMで生成されたデータファイルを出力する

      • 9.1　BSP-RM連携機能とは

        • 9.1.1　出力の流れ

        • 9.1.2　出力で使用するファイル

    • 10.　個人番号管理サービスと連携して個人番号を含む帳票を出力する

      • 10.1　個人番号管理サービス連携機能とは

        • 10.1.1　事前準備

        • 10.1.2　構築の流れ

        • 10.1.3　出力の流れ

        • 10.1.4　出力で使用するファイル

        • 10.1.5　個人番号接続情報ファイルを暗号化する

        • 10.1.6　起動部品の設定

        • 10.1.7　注意事項

  • 第3編　帳票の出力内容の設定

    • 11.　レイアウトやデータを設定する

      • 11.1　複数様式で帳票を出力するには

        • 11.1.1　複数様式で出力できる帳票

        • 11.1.2　出力の流れ

        • 11.1.3　出力で使用するファイル

        • 11.1.4　複数の帳票セットを指定した一括出力との違い

        • 11.1.5　複数様式での帳票出力例

        • 11.1.6　コーディング例

        • 11.1.7　注意事項

      • 11.2　データベースからデータを読み込んで出力するには

        • 11.2.1　出力の流れ

        • 11.2.2　出力で使用するファイル

      • 11.3　アイテムのデータを置き換えて出力するには

        • 11.3.1　出力で使用するファイル

      • 11.4　印刷日時を帳票に出力するには

        • 11.4.1　日時情報に出力できる文字列

        • 11.4.2　出力で使用するファイル

      • 11.5　テスト印刷用の文字列を出力するには

        • 11.5.1　出力で使用するファイル

      • 11.6　両面印刷で常に用紙の表面に出力する対象の帳票ファイルを指定するには

    • 12.　属性情報を設定する

      • 12.1　属性情報の種類と設定方法

        • 12.1.1　プリンタに出力する場合

        • 12.1.2　PDF形式ファイルに出力する場合

        • 12.1.3　EUR形式ファイルに出力する場合

        • 12.1.4　スプールデータに出力する場合

      • 12.2　属性情報の利用例

        • 12.2.1　帳票にアクセスできるユーザを制限する

  • 第4編　帳票の管理

    • 13.　スプールデータを管理するには

      • 13.1　GUIで管理する

        • 13.1.1　画面構成

        • 13.1.2　ユーザの設定

        • 13.1.3　スプールサーバのサーバ情報の取得

        • 13.1.4　スプールデータの一覧取得

        • 13.1.5　スプールデータの属性値の参照

        • 13.1.6　スプールデータの属性値の変更

        • 13.1.7　スプールデータの削除

        • 13.1.8　期限が切れたスプールデータの一括削除

        • 13.1.9　スプールデータの検索

        • 13.1.10　GUIで管理するときの注意

      • 13.2　業務プログラムで管理する

        • 13.2.1　スプールデータの一覧取得

        • 13.2.2　スプールデータの属性値の取得

        • 13.2.3　スプールデータの属性値の変更

        • 13.2.4　スプールデータの削除

        • 13.2.5　期限が切れたスプールデータの一括削除

    • 14.　監査ログを出力する

      • 14.1　監査ログとは

        • 14.1.1　監査ログ出力の流れ

        • 14.1.2　監査ログ参照の流れ

        • 14.1.3　注意事項

  • 付録

    • 付録A　帳票出力で使用するファイルの種類

    • 付録B　Excel形式ファイルへ出力される情報

      • 付録B.1　Excel形式ファイルへ出力される帳票定義情報

      • 付録B.2　Excel形式ファイルへ出力されるそのほかの情報

    • 付録C　このマニュアルの参考情報

      • 付録C.1　関連マニュアル

      • 付録C.2　EUR バージョン10での製品体系の変更

      • 付録C.3　EUR バージョン10でのマニュアル体系の変更

      • 付録C.4　このマニュアルでの表記

      • 付録C.5　このマニュアルで使用する略語

      • 付録C.6　KB（キロバイト）などの単位表記について

  • 索引

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 2 / 218