EUR 帳票作成 画面リファレンス

  • 目次

  • 索引

  • 前へ

  • 1 / 139

  • 次へ

EUR 帳票作成 画面リファレンス

3021-7-004-10

目次ダイジェスト

  • 前書き

  • 変更内容

  • はじめに

  • 1.　データウィンドウのダイアログ

  • 2.　帳票ウィンドウのダイアログ

  • 3.　実行ファイルまたはスタートメニューから表示するダイアログ

  • 付録

  • 索引

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 1 / 139

  • 次へ

  • 商品名称に関する表示

  • マニュアル発行元

All Rights Reserved. Copyright (C) 2014, 2017, Hitachi, Ltd.

All Rights Reserved. Copyright (C) 2014, 2017, Hitachi Solutions, Ltd.


前書き : EUR 帳票作成 画面リファレンス

  • 3 / 139

  • 次へ

  • 表紙

  • 前書き

前書き

■ 対象製品

●適用OS：Windows 7 x86，Windows 7 x64※1，Windows 8.1 x86※2，Windows 8.1 x64※1※2，Windows 10 x86※2，Windows 10 x64※1※2

  • P-2CD2-56A4 EUR Designer 10-40

  • P-2CD2-5DA4 EUR Developer※3 10-40

  • P-2CD2-53A4 EUR Viewer 10-40

●適用OS：Windows Server 2008，Windows Server 2012

  • P-29D2-59A4 EUR Server Standard※4 10-40

  • P-29D2-5EA4 EUR Server Enterprise※4 10-40

  • P-29D2-5CA4 EUR Server - Cipher option 10-30

●適用OS：HP-UX 11i V3(IPF)

  • P-1JD2-59A1 EUR Server Standard 10-10

  • P-1JD2-5EA1 EUR Server Enterprise 10-10

  • P-1JD2-5CA1 EUR Server - Cipher option 10-00

●適用OS：AIX V6.1，AIX V7.1，AIX V7.2

  • P-1MD2-59A1 EUR Server Standard 10-10

  • P-1MD2-5EA1 EUR Server Enterprise 10-10

  • P-1MD2-5CA1 EUR Server - Cipher option 10-00

●適用OS：Linux 6，Linux 7

  • P-82D2-59A1 EUR Server Standard 10-10

  • P-82D2-5EA1 EUR Server Enterprise 10-10

  • P-82D2-5CA1 EUR Server - Cipher option 10-00

注※1

    WOW64（Windows On Windows 64）環境だけで使用できます。

注※2

    Modern UIには対応していません。

注※3

    次に示す製品を同梱しています。

    ・P-2463-2354　　DABroker

注※4

    次に示す製品を同梱しています。

    ・P-2963-2354　　DABroker(64)

これらの製品は，ISO9001およびTickITの認証を受けた品質マネジメントシステムで開発されました。

■ 輸出時の注意

本製品を輸出される場合には、外国為替及び外国貿易法の規制並びに米国輸出管理規則など外国の輸出関連法規をご確認の上、必要な手続きをお取りください。

なお、不明な場合は、弊社担当営業にお問い合わせください。

■ 商標類

HITACHI，DABroker，DBPARTNER，EUR，Groupmax，HiRDB，JP1，SEWB，TPBroker，uCosminexusは，株式会社 日立製作所の商標または登録商標です。

ActiveXは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

IBM，AIXは，世界の多くの国で登録されたInternational Business Machines Corporationの商標です。

Internet Explorerは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

Itaniumは，アメリカ合衆国および / またはその他の国におけるIntel Corporationの商標です。

Linuxは，Linus Torvalds氏の日本およびその他の国における登録商標または商標です。

MicrosoftおよびMS-DOSは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

MicrosoftおよびSQL Serverは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

MicrosoftおよびVisual Basicは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

MicrosoftおよびVisual C++は，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

Microsoft .NET は，お客様，情報，システムおよびデバイスを繋ぐソフトウェアです。

Microsoft OfficeおよびExcelは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

Microsoft Office Wordは，米国Microsoft Corporation の商品名称です。

ODBCは，米国Microsoft Corporationが提唱するデータベースアクセス機構です。

OLEは，米国Microsoft Corporationが開発したソフトウェア名称です。

OracleとJavaは，Oracle Corporation 及びその子会社，関連会社の米国及びその他の国における登録商標です。

PostScriptは，米国でのAdobe Systems, Inc.の商標です。

Red Hatは，米国およびその他の国でRed Hat, Inc.の登録商標もしくは商標です。

RSAおよびBSAFEは，米国EMC コーポレーションの米国およびその他の国における商標または登録商標です。

UNIXは，The Open Groupの米国ならびに他の国における登録商標です。

Windowsは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

Windows Serverは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

本製品は，米国EMC コーポレーションのRSA BSAFE(R)ソフトウェアを搭載しています。

This product includes software developed by the Apache Software Foundation (http://www.apache.org/).

This product includes software developed by Ben Laurie for use in the Apache-SSL HTTP server project.

Portions of this software were developed at the National Center for Supercomputing Applications (NCSA) at the University of Illinois at Urbana-Champaign.

This product includes software developed by the University of California, Berkeley and its contributors.

This software contains code derived from the RSA Data Security Inc. MD5 Message-Digest Algorithm, including various modifications by Spyglass Inc., Carnegie Mellon University, and Bell Communications Research, Inc (Bellcore).

Regular expression support is provided by the PCRE library package, which is open source software, written by Philip Hazel, and copyright by the University of Cambridge, England. The original software is available from ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/

This product includes software developed by Ralf S. Engelschall <rse@engelschall.com> for use in the mod_ssl project (http://www.modssl.org/).

This product includes software developed by IAIK of Graz University of Technology.

This product includes software developed by Daisuke Okajima and Kohsuke Kawaguchi (http://relaxngcc.sf.net/).

This product includes software developed by the Java Apache Project for use in the Apache JServ servlet engine project (http://java.apache.org/).

This product includes software developed by Andy Clark.

その他記載の会社名，製品名は，それぞれの会社の商標もしくは登録商標です。

■ マイクロソフト製品の表記について

このマニュアルでは，マイクロソフト製品の名称を次のように表記しています。

表記 |  |  | 製品名称
.NET |  |  | Microsoft(R) .NET
ActiveX |  |  | ActiveX(R)
Excel |  |  | Microsoft(R) Office Excel 2007 Microsoft(R) Office Excel 2010 Microsoft(R) Office Excel 2013
Internet Explorer |  |  | Windows(R) Internet Explorer(R)
SQL Server |  |  | Microsoft(R) SQL Server 2008 Microsoft(R) SQL Server 2008 R2 Microsoft(R) SQL Server 2012
VBScript |  |  | Microsoft(R) Visual Basic(R) Scripting Edition
Visual Basic |  |  | Microsoft(R) Visual Basic(R)
Visual C++ |  |  | Microsoft(R) Visual C++(R)
Windows | Windows 7 | Windows 7 x86 | Microsoft(R) Windows(R) 7 Professional(32ビット版) Microsoft(R) Windows(R) 7 Enterprise(32ビット版) Microsoft(R) Windows(R) 7 Ultimate(32ビット版)
 |  | Windows 7 x64 | Microsoft(R) Windows(R) 7 Professional(64ビット版) Microsoft(R) Windows(R) 7 Enterprise(64ビット版) Microsoft(R) Windows(R) 7 Ultimate(64ビット版)
 | Windows 8 | Windows 8 x86 | Windows(R) 8 Pro(32ビット版) Windows(R) 8 Enterprise(32ビット版)
 |  | Windows 8 x64 | Windows(R) 8 Pro(64ビット版) Windows(R) 8 Enterprise(64ビット版)
 | Windows 8.1 | Windows 8.1 x86 | Windows(R) 8.1 Pro(32ビット版) Windows(R) 8.1 Enterprise(32ビット版)
 |  | Windows 8.1 x64 | Windows(R) 8.1 Pro(64ビット版) Windows(R) 8.1 Enterprise(64ビット版)
 | Windows 10 | Windows 10 x86 | Windows(R) 10 Pro(32ビット版) Windows(R) 10 Enterprise(32ビット版)
 |  | Windows 10 x64 | Windows(R) 10 Pro(64ビット版) Windows(R) 10 Enterprise(64ビット版)
 | Windows Server 2008 |  | Microsoft(R) Windows Server(R) 2008 R2 Standard Microsoft(R) Windows Server(R) 2008 R2 Enterprise Microsoft(R) Windows Server(R) 2008 R2 Datacenter
 | Windows Server 2012 |  | Microsoft(R) Windows Server(R) 2012 Standard Microsoft(R) Windows Server(R) 2012 Datacenter Microsoft(R) Windows Server(R) 2012 R2 Standard Microsoft(R) Windows Server(R) 2012 R2 Datacenter
Word |  |  | Microsoft(R) Office Word 2007 Microsoft(R) Office Word 2010 Microsoft(R) Office Word 2013

■ 発行

2017年3月　3021-7-004-10

■ 著作権

All Rights Reserved. Copyright (C) 2014, 2017, Hitachi, Ltd.

All Rights Reserved. Copyright (C) 2014, 2017, Hitachi Solutions, Ltd.

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 3 / 139


変更内容 : EUR 帳票作成 画面リファレンス

  • 4 / 139

  • 表紙

  • 変更内容

変更内容

変更内容（3021-7-004-10）

EUR Designer　10-40

EUR Developer　10-40

EUR Viewer　10-40

EUR Server Standard　10-40

EUR Server Enterprise　10-40

EUR Server - Cipher option　10-30

追加・変更内容

変更個所

EUR Designer，EUR Developer，EUR Viewerの適用OSにWindows 10を追加し，Windows 8を除外しました。

－

EUR Server Standard，EUR Server Enterpriseの適用OSに次のOSを追加しました。

  • AIX V7.2

  • Linux 7

－

文字アイテムで下線を描画する機能を追加しました。

2.4.7(1)，2.4.7(2)

［文字配置］タブの次の設定項目について，選択できない条件の説明を削除または変更しました。

  • ［縮小して全体を表示］チェックボックス

  • ［ワードラップを行う］チェックボックス

2.4.13(1)

［ファイル］タブの次の設定項目について，デフォルトのフォルダの説明を変更しました。

  • 下敷きファイル

  • 置き換え表管理情報ファイル

2.17.8(1)

［ログを出力するファイル］テキストボックスについて，デフォルトのフォルダの説明を変更しました。

3.1.1
（凡例）

－：該当なし

単なる誤字・脱字などはお断りなく訂正しました。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 4 / 139


はじめに : EUR 帳票作成 画面リファレンス

  • 5 / 139

  • 表紙

  • はじめに

はじめに

このマニュアルは，次のEUR製品を使用して，Windows(R)環境で帳票を設計する際に表示されるダイアログについて説明したものです。

  • EUR Designer

  • EUR Developer

〈はじめにの構成〉

  • 対象読者

  • このマニュアルの文法で使用する記号

  • このマニュアルのGUIの説明で使用する記号

■ 対象読者

このマニュアルは，EUR 帳票作成機能を使って帳票を作成する方を対象としています。なお，次の内容を理解されていることを前提としています。

  • Windowsの基本操作

ページの先頭へ

■ このマニュアルの文法で使用する記号

このマニュアルで使用する記号について，次に示します。

記　号

意　　味

｜

横に並べられた複数の項目に対する項目間の区切りを示し，「または」を意味します。

（例）A｜B

「A，またはBを指定する」ことを示します。

｛　｝

この記号で囲まれている複数の項目のうちから一つを選択することを示します。項目が横に並べられ，記号｜で区切られている場合は，そのうちの一つを選択します。

（例）｛A｜B｜C｝

「A，B，またはCのどれかを指定する」ことを示します。

〔　〕

この記号で囲まれている項目は省略してもよいことを示します。複数の項目が横に並べて記述されている場合には，すべてを省略するか，記号｛　｝と同じくどれか一つを選択します。

（例）〔A〕

「何も指定しない」か「Aと指定する」ことを示します。

（例）〔B｜C〕

「何も指定しない」か「B，またはCのどちらかを指定する」ことを示します。

…

記述が省略されていることを示します。この記号の直前に示された項目を繰り返し複数個指定できます。

（例）〔A〔,…〕〕

「Aのあとに，Aを複数個指定できる」ことを示します。

＿

括弧で囲まれた複数項目のうち1項目に対し使用され，括弧内のすべてを省略したときシステムが採る標準値を示します。

（例）〔A｜B｜C〕

「A，B，Cのどれも指定しなかった場合，システムはCが指定されたときと同じ処理をする」ことを示します。

ページの先頭へ

■ このマニュアルのGUIの説明で使用する記号

このマニュアルでは，次に示す記号を使用してGUIを説明しています。

記　号

意　　味

＜　＞

文字キーを表します。

＜　＞＋＜　＞

＋の前のキーを押したまま，後ろのキーを押すことを表します。

［　］

メニュー項目，ダイアログ名，ダイアログのボタンを表します。

［　］－［　］

メニュー項目を連続して選択することを表します。

（例）［ファイル］－［開く］

［ファイル］メニューから［開く］メニューを選択することを表します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 5 / 139


1. データウィンドウのダイアログ : EUR 帳票作成 画面リファレンス

  • 6 / 139

  • 表紙

  • 1.　データウィンドウのダイアログ

1.　データウィンドウのダイアログ

この章では，データウィンドウ（マッピングデータウィンドウおよびユーザ定義データウィンドウ）で表示するダイアログについて説明します。

〈この章の構成〉

  • 1.1　［フィールド定義］ダイアログ

  • 1.2　［フィールド定義情報自動作成］ダイアログ

  • 1.3　［フィールド定義情報変更］ダイアログ

  • 1.4　［フィールド表示幅設定］ダイアログ

  • 1.5　［基準レコード幅変更］ダイアログ

  • 1.6　［データのプロパティ］ダイアログ

  • 1.7　［データソースの選択］ダイアログ

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 6 / 139


1.1 ［フィールド定義］ダイアログ : EUR 帳票作成 画面リファレンス

  • 7 / 139

  • 表紙

  • 1.　データウィンドウのダイアログ

  • 1.1　［フィールド定義］ダイアログ

1.1　［フィールド定義］ダイアログ

データのフィールド情報を参照，および変更するダイアログです。SEWB+連携の場合は，フィールド情報の参照とサンプルデータの変更ができます。

なお，［フィールド定義］ダイアログで指定した情報は，読み込み専用のため，データベースやCSV形式ファイルには反映されません。

表示領域は，マウスホイールでスクロールできます。

〈この節の構成〉

  • 1.1.1　［フィールド定義］ダイアログで設定できる項目

  • 1.1.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 7 / 139


1.1.1 ［フィールド定義］ダイアログで設定できる項目 : EUR 帳票作成 画面リファレンス

  • 8 / 139

  • 表紙

  • 1.　データウィンドウのダイアログ

  • 1.1　［フィールド定義］ダイアログ

  • 1.1.1　［フィールド定義］ダイアログで設定できる項目

1.1.1　［フィールド定義］ダイアログで設定できる項目

［フィールド定義］ダイアログで設定できる項目を次に示します。

［フィールド名称］

帳票に貼り付けるデータのフィールド名称を設定します。設定するフィールド名称は，重複してはいけません。

マッピングデータのフィールド名は，510文字までです。ユーザ定義データのフィールド名は，499文字までです。

フィールド名は，セルに直接入力して変更するか，または［フィールド定義情報変更］ダイアログで変更します。［フィールド定義情報変更］ダイアログは，フィールド名称の左側にある番号を選択したあと，［変更］ボタンをクリックするか，またはフィールド名称の左側にある番号をダブルクリックすると表示されます。

［種別］

データの種別を設定します。設定できる種別は，表1-1を参照してください。

「数値（集計対象外）」は，例えば，従業員番号や製品番号など，集計したくない数値データに指定しておくと，帳票に貼り付けても集計はされません。

種別は，種別のセルをクリックしてデータ種別一覧から変更するか，または［フィールド定義情報変更］ダイアログで変更します。

［データ］，［サンプルデータ］

［データ］または［サンプルデータ］は，読み込むデータによって表示が異なります。

まだデータが設定されていない場合にフィールドを定義すると，サンプルデータが仮表示されます。サンプルデータは，データと同様にフィールド定義ができます。そのため，データがなくても，サンプルデータを使用して，帳票を設計できます。サンプルデータのデフォルトは，次のとおりです。

表1‒1　データの種別とサンプルデータのデフォルト値

データ種別※1

サンプルデータのデフォルト値

文字列

ABC

文字列（KEIS専用）※2

あいうえお

数値

123

数値（集計対象外）

123456

日付（日付・時刻）

1996/03/31 12:42:07

日付（日次）

19960331

日付（月次）

199603

日付（年次）

1996

和暦（日次）

4080331

和暦（月次）

40803

和暦（年次）

408

画像

sample.bmp

バーコード

4901234567894

特殊編集レベル

1
注※1

データ形式については，マニュアル「EUR システム設計ガイド」を参照してください。

注※2

「文字列（KEIS専用）」は，［フィールド定義］ダイアログで文字列フィールドを選択したあと，［フィールド定義情報変更］ダイアログで種別詳細を「KEIS専用」に変更することで設定できます。

なお，読み込んだデータが実データの場合，またはSEWB+/REPOSITORYで定義した最上位結合項目から読み込んだ実データが表示されている場合は，データのセルは不活性となり，編集はできません。

［自動作成］ボタン

［フィールド定義情報自動作成］ダイアログが表示されます。ダイアログの説明は，「1.2　［フィールド定義情報自動作成］ダイアログ」を参照してください。

［フィールド定義情報自動作成］ダイアログは，データファイル，データベース，およびディクショナリファイルに含まれる全フィールドの定義情報を自動作成できます。ただし，現在のフィールド定義情報は，破棄されるので注意が必要です。

データのフィールド情報を変更した場合は，［自動作成］ボタンをクリックして，データとフィールド定義の同期を取ってください。

［フィールド定義］ダイアログにSEWB+/REPOSITORYで定義した最上位結合項目から読み込んだデータが表示されている場合は，［自動生成］ボタンは使用できません。

［挿入］ボタン

［フィールド定義］ダイアログにフィールド情報を追加します。追加する位置にポインタを設定したあと，［挿入］ボタンをクリックします。

［フィールド定義］ダイアログにSEWB+/REPOSITORYで定義した最上位結合項目から読み込んだデータが表示されている場合は，［挿入］ボタンは使用できません。

［変更］ボタン

［フィールド定義情報変更］ダイアログが表示されます。

［フィールド定義情報変更］ダイアログは，フィールド名称の左側にある番号を選択したあと，［変更］ボタンをクリックするか，またはフィールド名称の左側にある番号をダブルクリックすると表示されます。

ダイアログの説明は，「1.3　［フィールド定義情報変更］ダイアログ」を参照してください。

［フィールド定義］ダイアログにSEWB+/REPOSITORYで定義した最上位結合項目から読み込んだデータが表示されている場合は，［変更］ボタンは使用できません。

［削除］ボタン

フィールドを削除します。フィールドを削除するには，削除するフィールドを選択したあと，［削除］ボタンをクリックするか，または＜Delete＞キーを押します。

［フィールド定義］ダイアログにSEWB+/REPOSITORYで定義した最上位結合項目から読み込んだデータが表示されている場合は，［削除］ボタンは使用できません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 8 / 139


1.1.2 画面図 : EUR 帳票作成 画面リファレンス

  • 9 / 139

  • 表紙

  • 1.　データウィンドウのダイアログ

  • 1.1　［フィールド定義］ダイアログ

  • 1.1.2　画面図

1.1.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 9 / 139


1.2 ［フィールド定義情報自動作成］ダイアログ : EUR 帳票作成 画面リファレンス

  • 10 / 139

  • 表紙

  • 1.　データウィンドウのダイアログ

  • 1.2　［フィールド定義情報自動作成］ダイアログ

1.2　［フィールド定義情報自動作成］ダイアログ

フィールド定義情報を自動作成するための，基になるデータを選択するダイアログです。

〈この節の構成〉

  • 1.2.1　［フィールド定義情報自動作成］ダイアログで設定できる項目

  • 1.2.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 10 / 139


1.2.1 ［フィールド定義情報自動作成］ダイアログで設定できる項目 : EUR 帳票作成 画面リファレンス

  • 11 / 139

  • 表紙

  • 1.　データウィンドウのダイアログ

  • 1.2　［フィールド定義情報自動作成］ダイアログ

  • 1.2.1　［フィールド定義情報自動作成］ダイアログで設定できる項目

1.2.1　［フィールド定義情報自動作成］ダイアログで設定できる項目

［フィールド定義情報自動作成］ダイアログで設定できる項目を次に示します。

［レポート内の保存されている情報から作成］ラジオボタン

レポートファイル内の保存されている情報を基にフィールド定義情報を自動作成します。レポートファイル内に保存されている情報がない場合は，このラジオボタンは選択できません。

［データファイルから作成］ラジオボタン

データファイルを基にフィールド定義情報を自動作成します。データファイルの1行目をフィールドにしていない場合は，フィールド名称をA，B，C・・・と仮定します。

CSV形式およびDAT形式のデータファイルからフィールド定義情報を自動作成する場合，1行目のデータが「" "」で囲まれているかどうかで，データの属性を判断しています。データの属性は，次に示す基準で判断されます。

  • " "で囲まれたデータ　　　：文字列データ

  • " "で囲まれていないデータ：数値の場合は数値データ，数値以外の場合は文字列データ

1行目のデータをフィールド名として扱う場合は，2行目のデータが「" "」で囲まれているかどうかで，データの属性を判断します。このため，" "で囲まれていない文字列がデータウィンドウに正しく表示されない場合があります。このようなときは，フィールド定義で属性を設定し直すことで，正しく表示されます。

FIX形式の場合は，データの属性が，数値の場合は数値データ，数値以外の場合は文字列データとして判断されます。

なお，データファイルが指定されていない場合，このラジオボタンは選択できません。

［データベースアクセス定義から作成］ラジオボタン

データベースアクセス定義を基に，フィールド定義情報を自動作成します。データベースアクセス定義は，［データ］メニューの［データベースアクセス定義］で定義します。

元データがデータベースアクセス定義から作成する場合，次に示す規則に従ってフィールド定義情報を自動作成します。

なお，データベースアクセス定義が指定されていない場合は，このラジオボタンは選択できません。

表1‒2　データ型の遷移一覧

データベースごとのデータ型

データベースアクセス定義でのデータ型（列属性）

自動生成された時のデータ種別

HiRDB

CHARACTER(n)

CHAR

文字列

VARCHAR(n)

VARCHAR

NCHAR(n)，NATIONAL CHARACTER(n)

NCHAR

NVARCHAR(n)

NVARCHAR

MCHAR(n)

MCHAR

MVARCHAR(n)

MVARCHAR

DATE

DATE

文字列 ※1

TIME

TIME

LARGE DECIMAL(m,n)

DECIMAL

数値

FLOAT，DOUBLE PRECISION

FLOAT

INTEGER

INTEGER

SMALLFLT，REAL

REAL

SMALLINT

SMALLINT

Oracle

CHAR(n)

CHAR

文字列

VARCHAR2(n)

VARCHAR

LONG

LONG VARCHAR

DATE

TIMESTAMP

文字列 ※1

RAW

VARBINARY

文字列 ※2

FLOAT

FLOAT

数値

NUMBER(p,s) ※3

NUMERIC

SQL Server

char

CHAR

文字列

varchar

VARCHAR

text

LONG VARCHAR

nchar

UCHAR ※4

nvarchar

UVARCHAR ※4

ntext

LONG UVARCHAR ※4

datetime，smalldatetime

TIMESTAMP

文字列 ※1

binary，timestamp

BINARY

文字列 ※2

varbinary

VARBINARY

bit

BIT

数値

decimal，money，smallmoney

DECIMAL

float

DOUBLE

int

INTEGER

numeric

NUMERIC

real

REAL

smallint

SMALLINT

tinyint

TINYINT
注※1

EURは，定義されているデータをそのまま表示します。

注※2

EURは，定義されている16進文字列をそのまま表示します。

注※3

Oracleのデータ型「NUMBER（精度・位取りなし）」（浮動小数点数）を［条件設定］ダイアログで表示すると，「列属性：NUMERIC（38,0）」となり，「38桁小数部なしの固定小数点数」と見なされます。そのため，EUR 帳票作成機能では，列の条件値や可変記号の初期値に，小数点付きのデータは指定できません。ただし，EUR サーバ帳票出力機能で帳票を出力する場合は，この型を浮動小数点数として扱うので，可変値に小数点付きの値を指定したり，データベースからデータを取得したりできます。

注※4

Unicodeデータを抽出する場合だけ使用できます。

［ディクショナリファイルから作成］ラジオボタン

［ディクショナリファイル］のテキストボックスで指定されたディクショナリファイルを基に，フィールド定義情報を自動作成します。ディクショナリファイルには，フィールド区切り情報（区切り文字／区切り位置）が含まれていますが，ここでは，フィールド定義で設定できる情報だけを使用します。ただし，英語ロケール，中国語ロケールの場合は，使用できません。

［ディクショナリファイル］テキストボックス

フィールド定義情報を自動作成するための，基になるディクショナリファイルを設定します。ディクショナリファイル名，およびファイルの場所がわからない場合は，［参照］ボタンをクリックしてください。［ディクショナリファイルの指定］ダイアログが表示されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 11 / 139


1.2.2 画面図 : EUR 帳票作成 画面リファレンス

  • 12 / 139

  • 表紙

  • 1.　データウィンドウのダイアログ

  • 1.2　［フィールド定義情報自動作成］ダイアログ

  • 1.2.2　画面図

1.2.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 12 / 139


1.3 ［フィールド定義情報変更］ダイアログ : EUR 帳票作成 画面リファレンス

  • 13 / 139

  • 表紙

  • 1.　データウィンドウのダイアログ

  • 1.3　［フィールド定義情報変更］ダイアログ

1.3　［フィールド定義情報変更］ダイアログ

フィールド定義情報を変更するダイアログです。

〈この節の構成〉

  • 1.3.1　［フィールド定義情報変更］ダイアログで設定できる項目

  • 1.3.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 13 / 139


1.3.1 ［フィールド定義情報変更］ダイアログで設定できる項目 : EUR 帳票作成 画面リファレンス

  • 14 / 139

  • 表紙

  • 1.　データウィンドウのダイアログ

  • 1.3　［フィールド定義情報変更］ダイアログ

  • 1.3.1　［フィールド定義情報変更］ダイアログで設定できる項目

1.3.1　［フィールド定義情報変更］ダイアログで設定できる項目

［フィールド定義情報変更］ダイアログで設定できる項目を次に示します。

［フィールド名称］テキストボックス

変更するフィールド名称を設定します。［フィールド定義］ダイアログで複数のフィールド情報が選択されている場合は，表示されません。

マッピングデータのフィールド名は，510桁までです。ユーザ定義データのフィールド名は，499桁までです。

［種別］リストボックス

変更する種別を設定します。リストボックスの右端にある矢印をクリックすると，選択できる種別の一覧が表示されます。

種別の詳細については，「1.1.1　［フィールド定義］ダイアログで設定できる項目」を参照してください。

［種別詳細］リストボックス

文字列フィールドの種別詳細を設定します。［種別詳細］のリストボックスは，［フィールド定義］ダイアログで選択したフィールドの種別が，［文字列］の時に設定できます。デフォルトは，「設定しない」です。

［KEIS専用］を選択すると，［サンプルデータ］下に注意書きが表示されます。

文字列フィールドの種別詳細を［KEIS専用］にすると，メインフレーム版 EUR Print Serviceで扱えるKEIS2バイトの文字列が設定できます。ただし，英語ロケール，中国語ロケールの場合は，［KEIS専用］は使用できません。

［サンプルデータ］

変更する種別を設定すると，その種別のサンプルデータが表示されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 14 / 139


1.3.2 画面図 : EUR 帳票作成 画面リファレンス

  • 15 / 139

  • 表紙

  • 1.　データウィンドウのダイアログ

  • 1.3　［フィールド定義情報変更］ダイアログ

  • 1.3.2　画面図

1.3.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 15 / 139


1.4 ［フィールド表示幅設定］ダイアログ : EUR 帳票作成 画面リファレンス

  • 16 / 139

  • 表紙

  • 1.　データウィンドウのダイアログ

  • 1.4　［フィールド表示幅設定］ダイアログ

1.4　［フィールド表示幅設定］ダイアログ

フィールドの表示幅を変更するダイアログです。

〈この節の構成〉

  • 1.4.1　［フィールド表示幅設定］ダイアログで設定できる項目

  • 1.4.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 16 / 139


1.4.1 ［フィールド表示幅設定］ダイアログで設定できる項目 : EUR 帳票作成 画面リファレンス

  • 17 / 139

  • 表紙

  • 1.　データウィンドウのダイアログ

  • 1.4　［フィールド表示幅設定］ダイアログ

  • 1.4.1　［フィールド表示幅設定］ダイアログで設定できる項目

1.4.1　［フィールド表示幅設定］ダイアログで設定できる項目

［フィールド表示幅設定］ダイアログで設定できる項目を次に示します。

［フィールド幅］スピンボックス

変更するフィールドの表示幅を設定します。テキストボックスに直接入力するか，またはアップダウンコントロールをクリックして設定します。設定できる値は，1～99です。複数のフィールドを選択した場合，フィールドの表示幅がすべて同じであるときはその幅値が，フィールドの表示幅が異なるときは「20」が表示されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 17 / 139


1.4.2 画面図 : EUR 帳票作成 画面リファレンス

  • 18 / 139

  • 表紙

  • 1.　データウィンドウのダイアログ

  • 1.4　［フィールド表示幅設定］ダイアログ

  • 1.4.2　画面図

1.4.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 18 / 139


1.5 ［基準レコード幅変更］ダイアログ : EUR 帳票作成 画面リファレンス

  • 19 / 139

  • 表紙

  • 1.　データウィンドウのダイアログ

  • 1.5　［基準レコード幅変更］ダイアログ

1.5　［基準レコード幅変更］ダイアログ

基準レコード幅を変更するためのダイアログです。

〈この節の構成〉

  • 1.5.1　［基準レコード幅変更］ダイアログで設定できる項目

  • 1.5.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 19 / 139


1.5.1 ［基準レコード幅変更］ダイアログで設定できる項目 : EUR 帳票作成 画面リファレンス

  • 20 / 139

  • 表紙

  • 1.　データウィンドウのダイアログ

  • 1.5　［基準レコード幅変更］ダイアログ

  • 1.5.1　［基準レコード幅変更］ダイアログで設定できる項目

1.5.1　［基準レコード幅変更］ダイアログで設定できる項目

［基準レコード幅変更］ダイアログで設定できる項目を次に示します。

［基準レコード幅］スピンボックス

基準レコード幅を設定します。テキストボックスに直接入力するか，またはアップダウンコントロールをクリックして設定します。設定できる値は，1～32,767です。デフォルトは，1が表示されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 20 / 139


1.5.2 画面図 : EUR 帳票作成 画面リファレンス

  • 21 / 139

  • 表紙

  • 1.　データウィンドウのダイアログ

  • 1.5　［基準レコード幅変更］ダイアログ

  • 1.5.2　画面図

1.5.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 21 / 139


1.6 ［データのプロパティ］ダイアログ : EUR 帳票作成 画面リファレンス

  • 22 / 139

  • 表紙

  • 1.　データウィンドウのダイアログ

  • 1.6　［データのプロパティ］ダイアログ

1.6　［データのプロパティ］ダイアログ

データのプロパティを設定するダイアログです。［データのプロパティ］ダイアログは，次に示すタブが表示されます。

  • ［データ情報］タブ

  • ［区切り情報］タブ

〈この節の構成〉

  • 1.6.1　［データ情報］タブ

  • 1.6.2　［区切り情報］（コンマ）タブ

  • 1.6.3　［区切り情報］（位置）タブ

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 22 / 139


1.6.1 ［データ情報］タブ : EUR 帳票作成 画面リファレンス

  • 23 / 139

  • 表紙

  • 1.　データウィンドウのダイアログ

  • 1.6　［データのプロパティ］ダイアログ

  • 1.6.1　［データ情報］タブ

1.6.1　［データ情報］タブ

データウィンドウから貼り付けたデータの情報を設定します。

〈この項の構成〉

  • (1)　［データ情報］タブで設定できる項目

  • (2)　画面図

(1)　［データ情報］タブで設定できる項目

［データ情報］タブで設定できる項目を次に示します。

［データ種別］

選択したデータがマッピングデータなのか，ユーザ定義データなのかが表示されます。表示されているデータ種別は変更できません。

［データ］グループボックス

読み込むデータを変更します。

［使用データ］リストボックス

読み込むデータを変更する場合，どのデータに変更するかを設定します。リストボックスには，現在使用できるデータの一覧が表示されます。デフォルトは，「データファイルのデータ」です。データウィンドウにデータが表示されていない場合は，「サンプルのデータ」です。

  1. サンプルのデータ

    使用するデータを，サンプルとして仮定されたデータに変更します。この項目を選択した場合，［サンプル］のグループボックスで属性を設定します。

  2. データファイルのデータ

    使用するデータを，データファイルのデータに変更します。この項目を選択すると，［データ］のグループボックスの中に［データファイル名称］テキストボックスと［空レコードを無視する］チェックボックスが表示されます。

［データファイル名称］テキストボックス

変更するデータファイル名を設定します。［...］ボタンをクリックすると，データファイルの一覧が表示されます。

［...］ボタン

変更するデータファイルの一覧が表示されます。

［空レコードを無視する］チェックボックス

入力するデータ中に空レコードがある場合，空レコードを無視してデータウィンドウに読み込むかどうかを設定します。デフォルトは，「オフ（空レコードをデータとして読み込む）」です。

なお，バージョン02-00-/Bで設計した帳票は，空レコードを無視するかどうかの設定に関係なく，入力するデータ中に空レコードがあっても，空レコードを無視してデータウィンドウに読み込みます。

［文字コード（0x00）だけのレコードを無視する］チェックボックス

入力するデータ中に文字コード（0x00）だけのレコードがある場合，そのレコードを無視してデータウィンドウに読み込むかどうかを設定します。デフォルトは，「オフ（文字コード（0x00）だけのレコードもデータとして読み込む）」です。文字コード（0x00）だけのレコードの例を，次に示します。

なお，旧バージョンで設計した帳票ファイルを読み込んだ時，［文字コード（0x00）だけのレコードを無視する］のチェックボックスは，次のように設定されます。そのため，旧バージョンで設計した帳票ファイルを読み込んで帳票を出力しても，同じ動作が保証されます。

表1‒3　バージョン別［文字コード（0x00）だけのレコードを無視する］チェックボックス状態一覧

EURのバージョン

［文字コード（0x00）だけのレコードを無視する］チェックボックスの状態

UNIX版 EUR旧製品

オフ

Windows版 EUR V1

オフ

Windows版 EUR V2

オン

Windows版 EUR V3

オフ

Windows版 EUR V4

オフ

Windows版 EUR V5

オフ

Windows版 EUR V7

オフ

Windows版 EUR V8

オフ
データベースのデータ

使用するデータを，データベースのデータに変更します。ただし，データベースアクセス定義が指定されている場合に選択できます。

レポート内のデータ

使用するデータを，帳票に保存されているデータに変更します。ただし，レポートファイル内にデータが保存されているときに選択できます。

［フィールド定義］グループボックス

フィールド定義情報の定義方法を設定します。

［定義方法］リストボックス

フィールド定義情報の定義方法を変更する場合，どのデータに変更するかを設定します。リストボックスには，現在使用できるデータの一覧が表示されます。デフォルトは，「標準」です。ただし，英語ロケール，中国語ロケールの場合は，［ディクショナリファイルを使用］は選択できません。

  1. 標準

    ［フィールド定義］ダイアログで変更します。

  2. ディクショナリファイルを使用

    ディクショナリファイルを基に，フィールド定義情報を変更します。この項目を変更すると，［フィールド定義］のグループボックスの中に［ディクショナリファイル名称］テキストボックスが表示されます。

［ディクショナリファイル名称］テキストボックス

変更するディクショナリファイル名を設定します。［...］ボタンをクリックすると，ディクショナリファイルの一覧が表示されます。

［...］ボタン

変更するディクショナリファイルの一覧が表示されます。

最上位結合項目を使用

最上位結合項目を基に，フィールド定義情報を変更します。この項目を選択すると，［フィールド定義］グループボックスの中に，［最上位結合項目名］が表示されます。

［最上位結合項目名］

最上位結合項目名が表示されます。

［サンプル］グループボックス

［使用データ］リストボックスで，［サンプルデータ］を選択した時，サンプルデータの属性を設定できます。

［データ数］スピンボックス

サンプルデータの数を，1～1,000の整数で設定します。テキストボックスに直接入力するか，またはアップダウンコントロールをクリックして設定します。デフォルトとして，「100」が表示されています。

［特殊編集レベルの編集］チェックボックス

特殊編集レベルフィールドがある場合，データを0～99の間で繰り返すかどうかを設定します。デフォルトは，「オフ（繰り返さない）」です。この項目を設定すると，サンプルデータで特殊編集レベルを対象とした集計行の編集が容易になります。

［改ブロック／ページの編集］チェックボックス

文字フィールドのすべてのデータを10レコード単位で切り替えるかどうかを設定します。デフォルトは，「オフ（切り替えない）」です。この項目を設定すると，サンプルデータで改ブロックや改ページの編集が容易になります。

［基準レコード］グループボックス

マッピングデータのデータ情報を変更するときに設定できます。

［位置］スピンボックス

変更する基準レコードの位置を設定します。テキストボックスに直接入力するか，またはアップダウンコントロールをクリックして設定します。デフォルトとして「1」が表示されています。

［幅］スピンボックス

変更する基準レコードの幅を設定します。テキストボックスに直接入力するか，またはアップダウンコントロールをクリックして設定します。デフォルトとして「1」が表示されています。

ページの先頭へ

(2)　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 23 / 139


1.6.2 ［区切り情報］（コンマ）タブ : EUR 帳票作成 画面リファレンス

  • 24 / 139

  • 表紙

  • 1.　データウィンドウのダイアログ

  • 1.6　［データのプロパティ］ダイアログ

  • 1.6.2　［区切り情報］（コンマ）タブ

1.6.2　［区切り情報］（コンマ）タブ

データファイルからデータを読み込む場合の，データファイルの区切り方法（コンマやスペース等区切り文字でデータを区切る）を設定します。

〈この項の構成〉

  • (1)　［区切り情報］（コンマ）タブで設定できる項目

  • (2)　画面図

(1)　［区切り情報］（コンマ）タブで設定できる項目

［区切り情報］（コンマ）タブで設定できる項目を次に示します。

［データファイル区切り方法］リストボックス

データファイルの区切り方法を設定します。区切り方法には，「コンマやスペース等区切り文字でデータを区切る」のほかに「指定した区切り位置でデータを区切る」があります。

［区切り文字］グループボックス

データファイルを区切る文字を指定します。デフォルトは，「コンマ」です。

［コンマ］ラジオボタン

区切り文字にコンマ「，」を使用します。

［タブ］ラジオボタン

区切り文字にタブを使用します。

［スペース］ラジオボタン

区切り文字に空白を使用します。

［指定］ラジオボタン

区切り文字を任意の文字で設定できます。ただし，CSV形式およびDAT形式のデータファイルの場合は，「"」は区切り文字として設定できません。FIX形式のデータファイルの場合は，データ間の区切りをデータの開始位置によって決めるため，区切り文字は使用しません。したがって，「，」を設定すると，データとして扱われます。

［1行目のデータをフィールド名として扱う］チェックボックス

1行目のデータを，フィールド名として扱うかどうかを設定します。デフォルトは，「オフ（扱わない）」です。

ページの先頭へ

(2)　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 24 / 139


1.6.3 ［区切り情報］（位置）タブ : EUR 帳票作成 画面リファレンス

  • 25 / 139

  • 表紙

  • 1.　データウィンドウのダイアログ

  • 1.6　［データのプロパティ］ダイアログ

  • 1.6.3　［区切り情報］（位置）タブ

1.6.3　［区切り情報］（位置）タブ

データファイルからデータを読み込む場合の，データファイルの区切り方法（指定した区切り位置でデータを区切る）を設定します。

〈この項の構成〉

  • (1)　［区切り情報］（位置）タブで設定できる項目

  • (2)　画面図

(1)　［区切り情報］（位置）タブで設定できる項目

［区切り情報］（位置）タブで設定できる項目を次に示します。

［データファイル区切り方法］リストボックス

データファイルの区切り方法を設定します。区切り方法には，「指定した区切り位置でデータを区切る」のほかに「コンマやスペース等区切り文字でデータを区切る」があります。

［区切り位置］グループボックス

データファイルの区切り位置を指定します。指定されているデータファイルのデータが表示されます。表示は，50レコードまでです。実際のデータが50レコード以上あっても，50レコードしか表示されません。

区切り位置の直接指定

表示されたデータファイルをマウスで操作して，区切り位置を直接指定できます。区切り位置を指定すると，表示されたデータファイルの下にカラム数が表示されます。

  • 区切り位置を設定する場合

    区切り位置をクリックします。

  • 区切り位置を移動する場合

    区切り位置を示す矢印［↑］をドラッグします。

  • 区切り位置を削除する場合

    区切り位置を示す矢印［↑］をダブルクリックします。

［区切り位置の自動設定］ボタン

自動的に区切り位置を設定します。データファイルが指定されている場合に指定できます。

［全区切り位置のクリア］ボタン

指定したデータファイルを表示したときの区切り位置を，すべて解除します。

［選択されている矢印以降の区切り位置を，同時に移動する］チェックボックス

区切り位置に指定されている矢印を選択して左右に移動させる場合，選択した矢印より右側に指定されているすべての矢印も同時に移動するかどうかを設定します。デフォルトは，「オン（移動する）」です。

［1行目のデータをフィールド名とする］チェックボックス

1行目のデータを，フィールド名として扱うかどうかを設定します。デフォルトは，「オフ（扱わない）」です。

ページの先頭へ

(2)　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 25 / 139


1.7 ［データソースの選択］ダイアログ : EUR 帳票作成 画面リファレンス

  • 26 / 139

  • 表紙

  • 1.　データウィンドウのダイアログ

  • 1.7　［データソースの選択］ダイアログ

1.7　［データソースの選択］ダイアログ

データベースと連携する場合，接続先のデータベースを設定，または変更するダイアログです。

〈この節の構成〉

  • 1.7.1　［データソースの選択］ダイアログで設定できる項目

  • 1.7.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 26 / 139


1.7.1 ［データソースの選択］ダイアログで設定できる項目 : EUR 帳票作成 画面リファレンス

  • 27 / 139

  • 表紙

  • 1.　データウィンドウのダイアログ

  • 1.7　［データソースの選択］ダイアログ

  • 1.7.1　［データソースの選択］ダイアログで設定できる項目

1.7.1　［データソースの選択］ダイアログで設定できる項目

［データソースの選択］ダイアログで設定できる項目を次に示します。

［データソース名］リストボックス

接続するデータソースを選択します。リストに表示されるデータソース名は，EURで使用できるODBC Driverで設定されたデータソース名です。

［ユーザID］テキストボックス

データソースに接続するユーザIDを指定します。

［パスワード］テキストボックス

データソースに接続するパスワードを指定します。文字列を入力すると，「*」に置き換えて表示されます。

［OK］ボタン

［OK］ボタンは，「接続先データソース」と「ユーザID」が設定されると活性になります。

［OK］ボタンをクリックすると，データベースアクセス定義が起動されて，データベースアクセス定義ウィンドウが表示されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 27 / 139


1.7.2 画面図 : EUR 帳票作成 画面リファレンス

  • 28 / 139

  • 表紙

  • 1.　データウィンドウのダイアログ

  • 1.7　［データソースの選択］ダイアログ

  • 1.7.2　画面図

1.7.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 28 / 139


2. 帳票ウィンドウのダイアログ : EUR 帳票作成 画面リファレンス

  • 29 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

2.　帳票ウィンドウのダイアログ

この章では，帳票ウィンドウで表示するダイアログについて説明します。

〈この章の構成〉

  • 2.1　［レポートのプロパティ］ダイアログ

  • 2.2　［下敷きの設定］ダイアログ

  • 2.3　［用紙の設定］ダイアログ

  • 2.4　［アイテムのプロパティ］ダイアログ

  • 2.5　［アイテムの表示条件］ダイアログ

  • 2.6　［部品アイテムのプロパティ］ダイアログ

  • 2.7　［ツールバー］ダイアログ

  • 2.8　［ズーム］ダイアログ

  • 2.9　［ページ番号］ダイアログ

  • 2.10　［印刷日付］ダイアログ

  • 2.11　［印刷時刻］ダイアログ

  • 2.12　［繰り返し個数指定］ダイアログ

  • 2.13　［まとめ表示］ダイアログ

  • 2.14　［改ブロック／改ページ一覧］ダイアログ

  • 2.15　［繰り返し設定］ダイアログ

  • 2.16　［集計アイテム］ダイアログ

  • 2.17　［オプション］ダイアログ

  • 2.18　部品パレットウィンドウ

  • 2.19　［部品の登録］ダイアログ

  • 2.20　［部品の名称］ダイアログ

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 29 / 139


2.1 ［レポートのプロパティ］ダイアログ : EUR 帳票作成 画面リファレンス

  • 30 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.1　［レポートのプロパティ］ダイアログ

2.1　［レポートのプロパティ］ダイアログ

レポートのプロパティを設定します。［レポートのプロパティ］ダイアログは，次に示すタブが表示されます。

  • ［レポートの構成］タブ

  • ［置き換え表］タブ

  • ［禁則文字］タブ

〈この節の構成〉

  • 2.1.1　［レポートの構成］タブ

  • 2.1.2　［置き換え表］タブ

  • 2.1.3　［禁則文字］タブ

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 30 / 139


2.1.1 ［レポートの構成］タブ : EUR 帳票作成 画面リファレンス

  • 31 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.1　［レポートのプロパティ］ダイアログ

  • 2.1.1　［レポートの構成］タブ

2.1.1　［レポートの構成］タブ

帳票のグリッド，ページ番号など，帳票の属性を設定するタブです。設定した内容は，現在開いている帳票に適用され，帳票の属性としてファイルに保存されます。また，次回設定を変えるまで，前回指定した値が設定されています。

〈この項の構成〉

  • (1)　［レポートの構成］タブで設定できる項目

  • (2)　画面図

(1)　［レポートの構成］タブで設定できる項目

［レポートの構成］タブで設定できる項目を次に示します。

［グリッド］グループボックス

グリッドの間隔，原点を設定します。［幅］，［高さ］，および［原点］は，［オプション］ダイアログの［表示］タブで設定されている「使用する単位」で表示されます。テキストボックスには，「使用する単位」と異なる単位で値を指定することもできます。例えば，［オプション］ダイアログの［表示］タブで「使用する単位」に「ミリメートル（mm）」が設定されている場合，［高さ］のテキストボックスに「1in」を入力して［適用］または［OK］ボタンをクリックすると，「25.4mm」の高さで表示されます。

［幅］グループボックス

グリッドの横の間隔を設定します。

  • ［間隔］ラジオボタン

    グリッドの横の間隔をmmで指定します。値はテキストボックスに入力します。指定できる値は，1（mm）～200（mm）です。

  • ［CPI］ラジオボタン

    グリッドの横の間隔をCPIで指定します。値はテキストボックスに入力します。指定できる値は，0.13（CPI）～24（CPI）です。

［高さ］グループボックス

グリッドの縦の間隔を設定します。

  • ［間隔］ラジオボタン

    グリッドの縦の間隔をmmで指定します。値はテキストボックスに入力します。指定できる値は，1（mm）～200（mm）です。

  • ［LPI］ラジオボタン

    グリッドの縦の間隔をLPIで指定します。値はテキストボックスに入力します。指定できる値は，0.13（LPI）～24（LPI）です。

［原点］テキストボックス

グリッドの原点を設定します。原点は，余白（マージン）を除いた左上を基準とします。指定できる値は，0（mm）～200（mm）です。

［アイテムをグリッド補正する］チェックボックス

グリッドに合わせて，アイテムのラバーバンドをきれいに配置できます。デフォルトは，「オン（補正する）」です。補正しない場合は，グリッドの表示に関係なくラバーバンドを配置できるので，微妙に配置するときに便利です。

［データキャラクタのフォント］リストボックス

バーコードCODE128以外で使用する，データキャラクタのフォントを選択します。設定できるフォントは，縦書きフォントを除くすべてです。

デフォルトは，「ＭＳ P明朝」です。英語ロケール，中国語ロケールのデフォルトは，「MS PMincho」です。

フォントを設定する場合，実行する環境によっては，帳票が正しく印刷されなかったり，表示されなかったりする場合があります。詳細は，マニュアル「EUR 帳票作成 操作ガイド」を参照してください。

バーコードCODE128のデータキャラクタに使用するフォントは，［アイテムのプロパティ］ダイアログの［データキャラクタ］タブで設定します。

［ページ番号］グループボックス

帳票に表示，または印刷するページ番号のページ数開始番号，または改ページごとにページ番号を初期化するかどうかを設定します。

［開始番号］テキストボックス

ページ番号のページ数開始番号を設定します。設定できる値は，1～32,767です。初めは，「1」が設定されています。

［改ページの設定に従う］チェックボックス

改ページごとにページ番号を開始番号から印刷するかどうかを選択します。選択すると，帳票内に「改ページ（初期化あり）」の指定がある場合，ページ番号を開始番号に初期化します。［形式］のテキストボックスで「＄」または「$」を設定している場合，最終ページ番号は，次に改ページするまでのページ数が設定されます。選択しない場合は，帳票内の改ページ初期化の設定に関係なく，ページ番号は初期化しません。初めは，「オン（改ページの設定に従って，ページ番号を初期化する）」が設定されています。

なお，［改ページの設定に従う］のチェックボックスの指定は，［アイテムのプロパティ］ダイアログの［表示形式］（ページ番号）タブで，［バージョン2形式］ラジオボタンが指定された時に有効になります。

［貼付域外の印刷］グループボックス

貼付域外（余白）にページ番号を付けて印刷するかどうかを，ラジオボタンの［する］，［しない］で設定します。貼付域外へのページ番号は，［用紙の設定］ダイアログの［余白］で設定した領域に印刷されます。貼付域外にページ番号を出力する場合は，プリンタのハードマージンに掛からないように，用紙の余白は余裕を持って設定してください。

貼付域外にページ番号を付けるのは，UNIX版 EUR旧製品，およびEUR サーバ帳票出力機能の帳票と共用する場合だけです。ページ番号をアイテムとして貼付域に付けて印刷する場合は，マニュアル「EUR 帳票作成 操作ガイド」を参照してください。

初めは，「（貼付域外に印刷）しない」が設定されています。ラジオボタンの「する」を選択した場合は，［形式］テキストボックスと［位置］リストボックスにページ番号の表示形式と表示位置が設定できます。

なお，貼付域外にページ番号を設定しても帳票（帳票ファイル）には表示されません。印刷プレビューで，設定したページ番号と位置を確認してください。

［形式］テキストボックス

ページ番号の表示形式を，任意に設定します。ページ番号を「*」，最終ページ番号を「$」で示して表示形式を指定します。ほかの文字は，固定文字として扱います。「*」と「$」を全角文字で設定すると，全角文字のページ番号で表示できます。初めは，「－＊－」が設定されています。

（例）

指定した形式

表示結果

*

ページ番号は半角文字。

1

－＊－

ページ番号は全角文字。

ページ番号の前後に固定文字「－」を付加。

－１－

－＊／＄－

ページ番号，最終ページ番号は全角文字。

ページ番号の前後に固定文字「－」を付加。

n/m形式で出力するため，ページ番号と最終ページ番号の間に「／」を指定。

－１／５－

（＊）

ページ番号は全角文字。

ページ番号の前後に固定文字「（」「）」を付加。

（１）
［位置］リストボックス

ページ番号の印刷位置を選択します。選択できる印刷位置を次に示します。初めは，「中央下」が設定されています。

［先頭・最終ページの範囲］グループボックス

アイテムの出力ページを設定する場合の，先頭ページおよび最終ページの定義をラジオボタンで変更できます。

［キーブレイクによる改ページで区切られた範囲］を選択した場合は，キーブレイクによって改ページされたページが先頭ページに，キーブレイクによって改ページされたページの一つ前のページが最終ページになります。

［ページ番号の初期化の指定で区切られた範囲］を選択した場合は，ページ番号が初期化されたページが先頭ページに，ページ番号が初期化されたページの一つ前のページが最終ページになります。

帳票の新規作成時は，［ページ番号の初期化の指定で区切られた範囲］が選択されています。ただし，バージョン08-20以前のEURで設計した帳票を開いた場合は，［キーブレイクによる改ページで区切られた範囲］が選択されています。

ページの先頭へ

(2)　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 31 / 139


2.1.2 ［置き換え表］タブ : EUR 帳票作成 画面リファレンス

  • 32 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.1　［レポートのプロパティ］ダイアログ

  • 2.1.2　［置き換え表］タブ

2.1.2　［置き換え表］タブ

置き換え表管理情報ファイルを設定します。

置き換え表管理情報ファイルを読み込んだあと，置き換え表管理情報ファイルまたは置き換え表ファイルを変更した場合は，置き換え表管理情報ファイルをもう一度読み込んでください。置き換え表管理情報ファイルの読み込みをしないと，変更したファイルの内容が正しく反映されません。

重要

置き換え表管理情報ファイルで指定した置き換え表ファイルがEURで設定されたフォルダにない場合，エラーメッセージが表示されます。置き換え表ファイルの格納場所を設定し直すには，ファイルオプションで格納場所を指定してください。ファイルオプションについては「2.17.8　［ファイル］タブ」を参照してください。

〈この項の構成〉

  • (1)　［置き換え表］タブで設定できる項目

  • (2)　画面図

(1)　［置き換え表］タブで設定できる項目

［置き換え表］タブで設定できる項目を次に示します。

［置き換え表管理情報ファイル名称］テキストボックス

置き換え表管理情報ファイル名を指定します。置き換え表管理情報ファイルをすでに設定している場合は，前回設定したファイル名がフルパスで表示されます。

置き換え表管理情報ファイル名，またはファイルの場所がわからない場合は，［...］ボタンをクリックしてください。［置き換え表管理情報ファイルの指定］ダイアログから置き換え表管理情報ファイル名を指定します。

ページの先頭へ

(2)　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 32 / 139


2.1.3 ［禁則文字］タブ : EUR 帳票作成 画面リファレンス

  • 33 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.1　［レポートのプロパティ］ダイアログ

  • 2.1.3　［禁則文字］タブ

2.1.3　［禁則文字］タブ

禁則処理に指定する禁則文字を変更するタブです。

〈この項の構成〉

  • (1)　［禁則文字］タブで設定できる項目

  • (2)　画面図

(1)　［禁則文字］タブで設定できる項目

［禁則文字］タブで設定できる項目を次に示します。

［禁則文字言語］コンボボックス

禁則文字の言語を設定します。「日本語」，「中国語」，「英語」および「カスタム」のうちどれかを選択します。デフォルトは，EURを実行したロケールによって異なります。ロケールごとのデフォルトの言語を次に示します。

  • 英語ロケールの場合：英語

  • 中国語ロケールの場合：中国語

  • 日本語ロケールの場合：日本語

［禁則文字］グループボックス

禁則文字を指定します。

［行頭禁則文字］テキストボックス

行頭の禁則文字を指定します。

  • 禁則文字の言語が「カスタム」以外の場合

    禁則文字の言語の指定に対応した行頭禁則文字の標準値が，保護された状態でテキストボックスに表示されます。

  • 禁則文字の言語が「カスタム」の場合

    行頭禁則文字が，テキストボックスに入力および変更できる状態で表示されます。指定できる行頭禁則文字は510文字までです。

［行末禁則文字］テキストボックス

行末の禁則文字を指定します。

  • 禁則文字の言語が「カスタム」以外の場合

    禁則文字の言語の指定に対応した行末禁則文字の標準値が，保護された状態でテキストボックスに表示されます。

  • 禁則文字の言語が「カスタム」の場合

    行末禁則文字が，テキストボックスに入力および変更できる状態で表示されます。指定できる行末禁則文字は510文字までです。

メモ

［禁則文字言語］コンボボックスの言語を変更した場合の動作を次に示します。

  • 禁則文字の言語を「カスタム」以外から「カスタム」に変更したとき

    ［行頭禁則文字］テキストボックス，および［行末禁則文字］テキストボックスが，変更前の禁則文字の言語に対応した禁則文字の標準値を表示したまま保護された状態から入力できる状態に変わります。

  • 禁則文字言語を「カスタム」から「カスタム」以外に変更したとき

    ［行頭禁則文字］テキストボックス，および［行末禁則文字］テキストボックスが，入力できる状態から保護された状態に変わり，［行頭禁則文字］テキストボックスで選択した言語の禁則文字の標準値が表示されます。

ページの先頭へ

(2)　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 33 / 139


2.2 ［下敷きの設定］ダイアログ : EUR 帳票作成 画面リファレンス

  • 34 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.2　［下敷きの設定］ダイアログ

2.2　［下敷きの設定］ダイアログ

下敷きに指定する画像ファイルを設定したり，変更したりするダイアログです。

〈この節の構成〉

  • 2.2.1　［下敷きの設定］ダイアログで設定できる項目

  • 2.2.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 34 / 139


2.2.1 ［下敷きの設定］ダイアログで設定できる項目 : EUR 帳票作成 画面リファレンス

  • 35 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.2　［下敷きの設定］ダイアログ

  • 2.2.1　［下敷きの設定］ダイアログで設定できる項目

2.2.1　［下敷きの設定］ダイアログで設定できる項目

［下敷きの設定］ダイアログで設定できる項目を次に示します。

［表示位置］と［画像サイズ］は，［オプション］ダイアログの［表示］タブで設定されている「使用する単位」で表示されます。テキストボックスには，「使用する単位」と異なる単位で値を指定することもできます。異なる単位で値を指定する場合は，単位も入力してください。例えば，「使用する単位」に「ミリメートル（mm）」が設定されている場合，［表示位置］のテキストボックスにそれぞれ「1in」を入力して［OK］ボタンをクリックすると，「25.4mm」の位置から表示されます。

［ファイル名］テキストボックス

下敷きに指定する画像ファイル名を指定します。画像ファイルは，EURで使用できる画像ファイルの形式すべてを指定できます。EURで使用できる画像ファイルの形式については，マニュアル「EUR 帳票作成 操作ガイド」を参照してください。

［ファイル名］のテキストボックスにファイル名だけを指定した場合は，［オプション］ダイアログの［ファイル］タブに表示されるパスから読み込まれます。

指定する下敷きの画像ファイル名，およびファイルの場所がわからない場合は，［参照］ボタンをクリックしてください。［ファイルを開く］ダイアログから指定する画像ファイル名を指定してください。

［表示位置］グループボックス

下敷きを表示する位置を，用紙の左上端からの値で指定します。指定できる単位は，1/100ミリメートル（mm），1/100インチ（in），またはピクセル（px）です。

下敷きを表示する位置は，画像ファイルの作成手順で控えておいた帳票原稿の端からの位置合わせの目印の位置を，用紙の左上隅からオフセットとして指定します。指定できる範囲は，次のとおりです。

（-1）×用紙の幅 ≦ 指定値 ≦ 用紙の幅

（-1）×用紙の高さ ≦ 指定値 ≦ 用紙の高さ

［用紙の左端から］テキストボックス

用紙の左端からの座標値を指定します。デフォルトは，「0」です。

［用紙の上端から］テキストボックス

用紙の上端からの座標値を指定します。デフォルトは，「0」です。

［画像サイズ］グループボックス

画像ファイルが持つサイズ情報に従って下敷きを表示するか，または指定されたサイズ情報に従って下敷きを表示するかを設定します。

下敷きには，EURで使用できるすべての画像ファイルを使用できますが，次に示すように，画像ファイルの形式によって，サイズ情報を持つものと持たないものがあります。

表2‒1　画像ファイルのサイズ情報

画像ファイルの形式

サイズ情報の有無

Windows BITMAP

Windows 3.x形式

△

OS2形式

×

TIFF

○

JPEG

△

GIF

×

PNG

×
（凡例）

○：サイズ情報を持っています。

△：サイズ情報を持っている形式と持っていない形式があります。

×：サイズ情報は持っていません。

  • サイズ情報を持つ画像ファイルの場合

    指定した画像ファイルをスキャナで読み込んだ時，または作成したときに指定したサイズと同じ条件の画像を下敷きとして使用できます。

    使用する画像ファイルの［幅］と［高さ］を指定して，下敷きの画像ファイルを表示する位置を［表示位置］で調整してください。

  • サイズ情報を持たない画像ファイルの場合

    ［表示位置］の［用紙の左端から］と［用紙の上端から］に「0」を指定して，設計する帳票の用紙サイズと同じ値を［画像サイズ］の［幅］と［高さ］に指定すると，位置がずれることなく下敷きに使用できます。ただし，下敷きに使用する画像ファイルが，指定した用紙サイズや縦横比と異なる場合は，元の画像ファイルの表示と異なることがあります。

    指定した画像ファイルがサイズ情報を持っていない場合は，［画像サイズ］を指定しないで［OK］ボタンをクリックすると，サイズの指定を要求するメッセージが表示されます。［サイズを指定する］のチェックボックスをオンにして，［幅］と［高さ］を指定してください。

［サイズを指定する］チェックボックス

画像ファイルが持つサイズ情報を基に下敷きを表示するかどうかを設定します。デフォルトは，「オフ（画像ファイルのサイズ情報に従って，下敷きを表示する）」です。

チェックボックスがオフの場合

  • 画像ファイルにサイズ情報が格納されている場合，画像ファイルが持つサイズ情報を基に下敷きが表示されます。そのため，プレプリント用紙と同じ内容，同じサイズの画像を下敷きとして使用できます。

  • 画像ファイルにサイズ情報が格納されていない場合，サイズ指定の要求メッセージが表示されます。［サイズを指定する］のチェックボックスをオンにして，［幅］と［高さ］を指定してください。

チェックボックスがオンの場合

［サイズを指定する］のチェックボックスをオンにすると，［幅］と［高さ］を指定できます。

［幅］テキストボックス

画像ファイルの幅を指定します。デフォルトは，EURの用紙サイズ（A4縦の幅，210mm）です。

［高さ］テキストボックス

画像ファイルの高さを指定します。デフォルトは，EURの用紙サイズ（A4縦の高さ，297mm）です。

画像ファイルと同じ大きさで下敷きを表示したい場合は，画像ファイルを作成したときのサイズで指定してください。

なお，ここで指定した［幅］と［高さ］サイズは，画像ファイルのデータを下敷きとして表示するためのものなので，本来の画像ファイルのサイズを変更するものではありません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 35 / 139


2.2.2 画面図 : EUR 帳票作成 画面リファレンス

  • 36 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.2　［下敷きの設定］ダイアログ

  • 2.2.2　画面図

2.2.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 36 / 139


2.3 ［用紙の設定］ダイアログ : EUR 帳票作成 画面リファレンス

  • 37 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.3　［用紙の設定］ダイアログ

2.3　［用紙の設定］ダイアログ

帳票の用紙サイズや余白を設定したり，変更したりするダイアログです。

〈この節の構成〉

  • 2.3.1　［用紙の設定］ダイアログで設定できる項目

  • 2.3.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 37 / 139


2.3.1 ［用紙の設定］ダイアログで設定できる項目 : EUR 帳票作成 画面リファレンス

  • 38 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.3　［用紙の設定］ダイアログ

  • 2.3.1　［用紙の設定］ダイアログで設定できる項目

2.3.1　［用紙の設定］ダイアログで設定できる項目

［用紙の設定］ダイアログで設定できる項目を次に示します。

用紙サイズの［幅］，［長さ］，および［余白］の値は，［オプション］ダイアログの［表示］タブで設定されている「使用する単位」で表示されます。テキストボックスには，「使用する単位」と異なる単位で値を指定することもできます。異なる単位で値を指定する場合は，単位も入力してください。例えば，「使用する単位」が「ミリメートル（mm）」で設定されている場合，［余白］のテキストボックスにそれぞれ「1in」を入力して［更新］または［OK］ボタンをクリックすると，余白は「25.4mm」になります。

［用紙サイズ］リストボックス

用紙のサイズを設定します。［用紙サイズ］のリストボックスには，デフォルトとして「A4」か，ユーザが最後に設定した用紙サイズが表示されています。

設定できる用紙とそのサイズを次に示します。

表2‒2　［用紙サイズ］リストボックスで設定できる用紙とそのサイズ

用紙

サイズ

A3

297×420 mm

A4

210×297 mm

A5

148×210 mm

レター

8.5×11 in

リーガル

8.5×14 in

B4

257×364 mm

B5

182×257 mm

ハガキ

100×148 mm

10×11インチシート

10×11 in

11×17インチシート

11×17 in

15×11インチシート

15×11 in

12×8.5インチシート

12×8.5 in

ユーザ定義

－
（凡例）

－：該当する項目はありません。

独自の用紙サイズを設定する場合は，［ユーザ定義］を選択したあと，［幅］と［長さ］のテキストボックスに値を直接入力してください。また，［用紙サイズ］のリストボックスで用紙を設定したあと，出力するプリンタの用紙サイズに合わせて，幅と長さを変更することもできます。［幅］と［長さ］のテキストボックスに表示されているサイズを，直接入力して変更してください。そのとき，［用紙サイズ］のリストボックスの表示は「ユーザ定義」に変わります。

なお，「ユーザ定義」を設定した帳票を印刷する場合は，設計した帳票と同じ印刷結果を得るため，プリンタのプロパティでも同じ用紙サイズを設定してください。このとき，［用紙の設定］で設定した用紙サイズの単位を合わせて設定すると便利です。

［幅］テキストボックス

［用紙サイズ］で指定した用紙の幅が表示されます。デフォルトは，210（mm）です。幅のサイズを変更する場合は，35（mm）≦ 幅 ≦ 431.8（mm）の値で指定してください。

［長さ］テキストボックス

［用紙サイズ］で指定した用紙の長さが表示されます。デフォルトは，297（mm）です。長さのサイズを変更する場合は，35（mm）≦ 長さ ≦ 431.8（mm）の値で指定してください。

［幅］と［長さ］のサイズを直接入力する場合は，［余白］のサイズに注意してください。

［余白］グループボックス

用紙の余白（マージン）を設定します。［余白］のテキストボックスには，デフォルトとして上下左右ともに「10（mm）」か，ユーザが最後に設定したサイズが表示されています。

設定できる余白のサイズを，次に示します。

  • 上下左右の各余白 ≧ 0（mm）

    出力先プリンタのハードマージン以上の値を指定してください。

  • 上下の余白の合計 ≦ 用紙の縦の長さ－25（mm）

    上下の余白の合計が小さくなる場合は，そのテキストボックスが反転表示されます。

  • 左右の余白の合計 ≦ 用紙の横の長さ－25（mm）

    左右の余白の合計が小さくなる場合は，そのテキストボックスが反転表示されます。

［印刷の向き］グループボックス

印刷する用紙の向きを，次に示す二つの中から選択します。［印刷の向き］は，デフォルトとして「縦」のラジオボタンか，ユーザが最後に設定した方向のラジオボタンが選択されています。

［縦］ラジオボタン

用紙を縦向きに使用します。

［横］ラジオボタン

用紙を横向きに使用します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 38 / 139


2.3.2 画面図 : EUR 帳票作成 画面リファレンス

  • 39 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.3　［用紙の設定］ダイアログ

  • 2.3.2　画面図

2.3.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 39 / 139


2.4 ［アイテムのプロパティ］ダイアログ : EUR 帳票作成 画面リファレンス

  • 40 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.4　［アイテムのプロパティ］ダイアログ

2.4　［アイテムのプロパティ］ダイアログ

アイテムのプロパティを設定するダイアログです。［アイテムのプロパティ］ダイアログは，次に示すタブが表示されます。

  • ［データ］タブ

  • ［表示形式］タブ

    ［表示形式］タブは，選択したアイテムによって表示が異なります。

  • ［配置］タブ

  • ［フォント］タブ

  • ［線］タブ

  • ［図形］タブ

  • ［画像］タブ

  • ［バーコード］タブ

  • ［データキャラクタ］タブ

  • ［文字配置］タブ

  • ［位置・サイズ］タブ

  • ［出力ページ］タブ

  • ［置き換え表］タブ

〈この節の構成〉

  • 2.4.1　［データ］タブ

  • 2.4.2　［表示形式］（集計内容）タブ

  • 2.4.3　［表示形式］（文字列・数値データ）タブ

  • 2.4.4　［表示形式］（日付・時刻データ）タブ

  • 2.4.5　［表示形式］（ページ番号）タブ

  • 2.4.6　［配置］タブ

  • 2.4.7　［フォント］タブ

  • 2.4.8　［線］タブ

  • 2.4.9　［図形］タブ

  • 2.4.10　［画像］タブ

  • 2.4.11　［バーコード］タブ

  • 2.4.12　［データキャラクタ］タブ

  • 2.4.13　［文字配置］タブ

  • 2.4.14　［位置・サイズ］タブ

  • 2.4.15　［出力ページ］タブ

  • 2.4.16　［置き換え表］タブ

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 40 / 139


2.4.1 ［データ］タブ : EUR 帳票作成 画面リファレンス

  • 41 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.4　［アイテムのプロパティ］ダイアログ

  • 2.4.1　［データ］タブ

2.4.1　［データ］タブ

マッピングアイテムのプロパティを設定します。マッピングアイテムには，画像アイテムとバーコードアイテムも含まれます。［データ］タブは，複数アイテムおよび置き換えを指定したアイテムを選択しているときは表示されません。

〈この項の構成〉

  • (1)　［データ］タブで設定できる項目

  • (2)　画面図

(1)　［データ］タブで設定できる項目

［データ］タブで設定できる項目を次に示します。

［項目の見出し名］リストボックス

データウィンドウで定義したフィールド名が［項目の見出し名］リストボックスに一覧表示されます。対象となるアイテムを選択したあと，そのアイテムにリンクするフィールド名を変更できます。デフォルトは，データウィンドウからデータを貼り付けた時に決まります。

ページの先頭へ

(2)　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 41 / 139


2.4.2 ［表示形式］（集計内容）タブ : EUR 帳票作成 画面リファレンス

  • 42 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.4　［アイテムのプロパティ］ダイアログ

  • 2.4.2　［表示形式］（集計内容）タブ

2.4.2　［表示形式］（集計内容）タブ

集計アイテムの集計内容の表示形式を変更します。［分類］リストボックスには，「集計」と「数値データ」が表示されます。集計アイテムの集計内容の表示形式を変更する場合は，「集計」を選択します。［表示形式］（集計内容）タブは，置き換えを指定したアイテムを選択している時は表示されません。

〈この項の構成〉

  • (1)　［表示形式］（集計内容）タブで設定できる項目

  • (2)　画面図

(1)　［表示形式］（集計内容）タブで設定できる項目

［表示形式］（集計内容）タブで設定できる項目を次に示します。

［集計内容］グループボックス

変更する集計を，次に示す五つの中から選択します。［集計内容］には，デフォルトとして「合計」のラジオボタンか，ユーザが最後に設定した集計のラジオボタンが選択されています。

［合計］ラジオボタン

合計を求めます。

［平均］ラジオボタン

平均値を求めます。

［最大］ラジオボタン

最大値を求めます。

［最小］ラジオボタン

最小値を求めます。

［件数］ラジオボタン

件数を求めます。

ページの先頭へ

(2)　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 42 / 139


2.4.3 ［表示形式］（文字列・数値データ）タブ : EUR 帳票作成 画面リファレンス

  • 43 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.4　［アイテムのプロパティ］ダイアログ

  • 2.4.3　［表示形式］（文字列・数値データ）タブ

2.4.3　［表示形式］（文字列・数値データ）タブ

文字列データと数値データの表示形式を変更します。［分類］リストボックスには，選択したアイテムの属性が表示されます。属性の異なる複数のアイテムを選択した場合は，複数の属性が表示されますので，変更したい属性を選択します。［表示形式］（文字列・数値データ）タブは，置き換えを指定したアイテムを選択している場合は項目が不活性となります。

選択したアイテムと［分類］リストボックスに表示されるデータ属性は次のとおりです。

表2‒3 選択したアイテムと［分類］に表示されるデータ属性
選択したアイテム | ［分類］に表示されるデータ属性
文字アイテム | 文字データ
集計アイテム | 集計，数値データ
数値アイテム | 数値データ

文字アイテムを選択した場合は，［前付加文字］，［後付加文字］テキストボックス，［書式種別］コンボボックス，［書式オプション］グループボックス，および［書式記号］テキストボックス以外の項目は設定できません。また，数値アイテムを選択した場合は，任意書式は設定できません。

数値データの属性を変更する場合の注意事項

  • 集計アイテムを選択した場合，［分類］リストボックスには，「集計」と「数値データ」が表示されます。集計アイテムの数値データの表示形式を変更したい場合は，「数値データ」を選択してください。

  • 集計結果の有効桁数は，小数点以下桁揃えの指定に関係なく15桁までです。集計結果が，有効桁数の15桁を超える場合は，集計する数値の整数部の桁数によって，集計行に表示される数値の小数部の内容が異なるなど，正しく印刷されません。

  • 属性の変更によって，桁数が大きくなりアイテム枠の表示領域を超える場合は，「***…*」のように表示されます。アイテム枠をリサイズしてください。

任意書式を設定する場合の注意事項

  • 書式は入力文字がある場合に適用されます。

  • ［前付加文字］，［後付加文字］テキストボックスとあわせて設定している場合は，任意書式へ変換したあとに設定した文字が付加されます。

  • 書式を正しく設定していない状態で，タブ移動または［OK］ボタンをクリックした場合は，設定した文字列が選択状態となり，タブ移動およびダイアログを閉じることはできません。

  • 書式が正しく指定されていない帳票で，［アイテムのプロパティ］ダイアログの［表示形式］タブを表示した時，書式種別は「指定なし」になります。

  • 書式が正しく指定されていない帳票を出力した場合は，［前付加文字］，［後付加文字］テキストボックスで設定した文字だけ出力されます。

〈この項の構成〉

  • (1)　［表示形式］（文字列・数値データ）タブで設定できる項目

  • (2)　画面図

(1)　［表示形式］（文字列・数値データ）タブで設定できる項目

［表示形式］（文字列・数値データ）タブで設定できる項目を次に示します。

［前付加文字］，［後付加文字］テキストボックス

データの前後に付ける文字を設定します。デフォルトは，空白です。［前付加文字］または［後付加文字］のテキストボックスに入力した前付加文字，または後付加文字は，リストボックスに登録されます。任意書式とあわせて設定している場合は，任意書式へ変換したあとに設定した文字を付けます。

［書式種別］コンボボックス

文字列データに，任意書式の種別を設定します。「文字書式」，「数値書式」および「指定なし」のうちどれかを選択します。デフォルトは「指定なし」です。

「文字書式」および「数値書式」を選択した場合の，文字列データに対する書式の適用方向を次に示します。

  • 「文字書式」を選択した場合

    文字列の左から書式に変換されます。ただし，［書式オプション］グループボックスの［適用方向］コンボボックスで，「右から適用」を選択した場合は，文字列の右から書式に変換されます。

  • 「数値書式」を選択した場合

    ［適用方向］コンボボックスで，「指定なし」または「右から適用」を選択した場合は，数値書式の整数部は文字列の整数部が右から書式に変換され，小数部は文字列の小数部が左から書式に変換されます。［適用方向］コンボボックスで「左から適用」を選択した場合は，文字列の左から書式に変換されます。

［書式オプション］グループボックス

文字列データに，任意書式の書式オプションを設定します。

［データ長］コンボボックス

データと，設定した書式の長さが異なる場合の対処を選択します。

デフォルトは「指定なし」です。［書式種別］コンボボックスで，「指定なし」を選択した場合は，選択できません。

［データ長］コンボボックスで選択できる項目を次に示します。

  • 「指定なし」

    データと，設定した書式の長さが異なる場合の対処を指定しません。

    「指定なし」を選択した場合の，データと変換書式の長さの関係と，対応する動作を次に示します。

    表2‒4　データと変換書式の長さの関係と対応する動作

    データと変換書式の長さの関係

    動作

    文字書式

    数値書式

    データ > 変換書式

    指定した書式に従って書式変換されます。超過分の文字列は表示されません。

    入力文字の右から書式変換されます。超過分の文字列は表示されません。

    データ = 変換書式

    すべて書式変換して表示されます。

    すべて書式変換して表示されます。

    データ < 変換書式

    すべて書式変換して表示されます。固定文字列は出力され，未適用の書式には書式記号に対応した空白が出力されます。

    すべて書式変換して表示されます。固定文字列は出力され，未適用の書式には書式記号に対応した文字が出力されます。

  • 「データ長＞書式の場合，"?"を表示」

    適用するデータが書式より長い場合，変換後の文字数分の「?」を出力します。ただし，書式記号が”N”の場合は「？」を出力します。数値書式の場合は，整数部と小数部を分けてデータ長をチェックします。

    また，数値書式の場合，入力データの長さは符号を含めた長さでチェックしますが，数値書式で次の条件のどちらかを満たすときは，入力データの長さに符号を含めません。

    ・［符号が入らない場合，","を削除］チェックボックスをオンにしているとき

    ・書式記号に「-」を定義していて，入力データの符号が「+」のとき

  • 「データ長＜書式の場合，"?"を表示」

    適用するデータが書式より短い場合，変換後の文字数分の「?」を出力します。ただし，書式記号が”N”の場合は「？」を出力します。数値書式の場合は，整数部と小数部を分けてデータ長をチェックします。

    また，数値書式の場合，入力データの長さは符号を含めた長さでチェックしますが，数値書式で次の条件のどちらかを満たすときは，入力データの長さに符号を含めません。

    ・［符号が入らない場合，","を削除］チェックボックスをオンにしているとき

    ・書式記号に「-」を定義していて，入力データの符号が「+」のとき

  • 「データ長≠書式の場合，"?"を表示」

    適用するデータが書式より長い，または短い場合は，変換後の文字数分の「?」を出力します。ただし，書式記号が”N”の場合は「？」を出力します。数値書式の場合は，整数部と小数部を分けてデータ長をチェックします。

    また，数値書式の場合，入力データの長さは符号を含めた長さでチェックしますが，数値書式で次の条件のどちらかを満たすときは，入力データの長さに符号を含めません。

    ・［符号が入らない場合，","を削除］チェックボックスをオンにしているとき

    ・書式記号に「-」を定義していて，入力データの符号が「+」のとき

［適用方向］コンボボックス

データに対する，書式の適用方向を選択します。デフォルトは「指定なし」です。［書式種別］コンボボックスで「指定なし」を選択している場合は選択できません。また，［書式種別］コンボボックスで「数値書式」を選択している場合で，書式に小数点またはコンマがあるとき，「左から適用」は選択できません。

［適用方向］コンボボックスで選択できる項目を次に示します。

  • 「指定なし」

    データに対する，書式の適用方向を指定しません。

  • 「左から適用」

    左の文字から書式を適用します。

  • 「右から適用」

    右の文字から書式を適用します。

［空白削除］コンボボックス

任意書式を適用後，固定文字列を挿入する前に<空白文字>を削除する方法を選択します。<空白文字>は，#x20，#x09，#x0a，#x0dまたは全角空白を示します。デフォルトは「指定なし」です。［書式種別］コンボボックスで「指定なし」を選択している場合は選択できません。

［空白削除］コンボボックスで選択できる項目を次に示します。

  • 「指定なし」

    書式適用後，固定文字列を挿入する前に<空白文字>を削除しません。

  • 「左の空白を削除」

    書式適用後，固定文字列を挿入する前に左の<空白文字>を削除します。

  • 「右の空白を削除」

    書式適用後，固定文字列を挿入する前に右の<空白文字>を削除します。

  • 「左右の空白を削除」

    書式適用後，固定文字列を挿入する前に左右の<空白文字>を削除します。

［ゼロ削除］コンボボックス

任意書式を適用する前に，0を削除する方法を選択します。デフォルトは「指定なし」です。［書式種別］コンボボックスで「指定なし」または「文字書式」を選択している場合は選択できません。

［ゼロ削除］コンボボックスで選択できる項目を次に示します。

  • 「指定なし」

    書式適用前に0を削除しません。

  • 「左の０を削除」

    数値書式の場合，書式適用前に符号を除いた入力文字の左の0を削除します。ただし，すべて0のときは0を一つ残します。

  • 「右の０を削除」

    数値書式の場合，書式適用前に符号を除いた入力文字の右の0を削除します。ただし，すべて0のときは0を一つ残します。

  • 「左右の０を削除」

    数値書式の場合，書式適用前に符号を除いた入力文字の左右の0を削除します。ただし，すべて0のときは0を一つ残します。

［Z書式での０出力］チェックボックス

［書式種別］コンボボックスで「数値書式」を選択している場合，書式記号”Z”に対応する入力データが0のときは，0を出力するかどうかを選択します。入力データがない場合は，半角空白を出力します。デフォルトは「オフ（0を出力しない）」です。［書式種別］コンボボックスで「指定なし」または「文字書式」を選択している場合は選択できません。

［符号が入らない場合，"，"を削除］チェックボックス

［書式種別］コンボボックスで「数値書式」を選択している場合，書式変換で符号だけが入らないときに，”,”をすべて削除して出力するかどうかを選択します。変換後の”,”をすべて削除し，変換後の左側に符号を付加したあと，書式の桁数と同じになるまで符号の左側に半角空白を付加します。”,”が削除されるため，符号が出力できるようになります。デフォルトは「オフ（”,”を削除しない）」です。

ただし，書式記号に”,”がない場合は選択できません。また，［書式種別］コンボボックスで，「指定なし」または「文字書式」を選択している場合も選択できません。

［0以外の数字の先頭に符号を出力］チェックボックス

［書式種別］コンボボックスで，「数値書式」を選択している場合，符号を0ではない数字の先頭に移動するかどうかを選択します。ただし，整数部に0以外の数字がない場合は符号を移動しません。また，移動前の符号の位置には書式に対応した文字（”9”は「0」，”*”は「*」，それ以外の書式は半角空白）を出力します。デフォルトは「オフ（符号を出力しない）」です。

［書式種別］コンボボックスで，「指定なし」または「文字書式」を選択している場合は選択できません。

［書式記号］テキストボックス

文字列データに，任意書式の書式記号を設定します。［書式種別］コンボボックスで，「指定なし」を選択している場合は，設定できません。

設定する書式記号と意味については，マニュアル「EUR 帳票作成 操作ガイド」を参照してください。

［任意書式サンプル］

［書式種別］コンボボックス，［書式オプション］グループボックスおよび［書式記号］テキストボックスに指定された表示形式に従って，実際の表示状態が表示されます。

［ゼロ埋め桁数］テキストボックス

数値データの桁数を揃えるために，ゼロを埋める桁数を設定します。数値データが表示する桁数に満たない場合，先頭にゼロが付加されます。デフォルトは，「1」です。

［負符号文字］テキストボックス

マイナス符号として表示する文字列を設定します。デフォルトは，「-」です。

［小数点文字］テキストボックス

小数点として表示する文字列を設定します。デフォルトは，「.」です。

［コンマ表示］チェックボックス

数値データを3桁ごとにコンマで区切って表示するかどうかを設定します。デフォルトは，「オフ（コンマ表示をしない）」です。

［指数表示］チェックボックス

数値データを指数で表示するかどうかを設定します。デフォルトは，「オフ（指数表示をしない）」です。

［値が0の場合］グループボックス

数値データが0の場合，どのように表示するかを，次に示す三つの中から一つを選択します。デフォルトは，「0を表示する」です。

指定値

説　　明

0を表示する

「0」を表示します。

0を表示しない ※

「0」を表示しません。

-（ハイフン）を表示する ※

「0」を「-」で表示します。
注※

［表示形式］タブでの，ほかのプロパティの設定（前付加文字，後付加文字，ゼロ埋め桁数，負符号文字，小数点文字，コンマ表示，指数表示，および小数点以下桁揃え）は，すべて無効になります。アイテム枠の中には何も表示されませんので注意してください。

［小数点以下桁揃え］チェックボックス

小数点以下の桁を揃えるかどうかを設定します。

集計アイテムの数値データを選択した場合は，デフォルトは，「オン（桁を揃える）」です。そのほかの数値データを選択した場合は，デフォルトは，「オフ（桁を揃えない）」です。

［小数点以下桁揃え］のチェックボックスをオフ（小数点以下の桁を揃えない）にした場合は，［小数点以下桁数］と［有効桁］は設定できません。

［小数点以下桁数］テキストボックス

小数点以下の桁数を設定します。

［有効桁］ラジオボタン

次に示す三つの中から一つを選択します。デフォルトは「四捨五入」です。

指定値

説　　明

四捨五入

指定された小数桁数以下を四捨五入します。

切り捨て

指定された小数桁数以下を切り捨てます。

切り上げ

指定された小数桁数以下を切り上げます。
［値が空データの場合］グループボックス

数値データが空データの場合，どのように表示するかを，次に示す二つのうち，どちらかを選択します。デフォルトは，「表示しない」です。

指定値

説　　明

表示しない ※

何も表示しません。

-（ハイフン）を表示する ※

空データを「-」で表示します。
注※

［表示形式］タブでの，ほかのプロパティの設定（前付加文字，後付加文字，ゼロ埋め桁数，負符号文字，小数点文字，コンマ表示，指数表示，および小数点以下桁揃え）は，すべて無効になります。アイテム枠の中には何も表示されませんので注意してください。

ページの先頭へ

(2)　画面図

(a)　文字列データの場合

(b)　数値データの場合

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 43 / 139


2.4.4 ［表示形式］（日付・時刻データ）タブ : EUR 帳票作成 画面リファレンス

  • 44 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.4　［アイテムのプロパティ］ダイアログ

  • 2.4.4　［表示形式］（日付・時刻データ）タブ

2.4.4　［表示形式］（日付・時刻データ）タブ

日付データ（西暦・和暦），印刷日付データ，および印刷時刻データの表示形式の属性を変更します。

日付アイテムを選択した場合

  • 西暦のとき

    ［分類］リストボックスには「日付データ」と表示されます。日付アイテムのほかに，複数アイテムを選択している場合は，［分類］に示す内容に優先順位があります。アイテムの優先順位は，「年次＞月次＞日次＞日付・時刻」です。

  • 和暦のとき

    ［分類］リストボックスには「和暦」と表示されます。日付アイテムのほかに，複数アイテムを選択している場合は，［分類］に示す内容に優先順位があります。アイテムの優先順位は，「和暦（年次）＞和暦（月次）＞和暦（日次）」です。

印刷日付アイテムを選択した場合

［分類］リストボックスには，［印刷日付］と表示されます。

印刷時刻アイテムを選択した場合

［分類］リストボックスには，［印刷時刻］と表示されます。

〈この項の構成〉

  • (1)　［表示形式］（日付・時刻データ）タブで設定できる項目

  • (2)　画面図

(1)　［表示形式］（日付・時刻データ）タブで設定できる項目

［表示形式］（日付・時刻データ）タブで設定できる項目を次に示します。

［種別］リストボックス

選択されたアイテムによって，分類される種別の一覧が表示されます。

選択したアイテム別に表示される［種別］の一覧を次の表に示します。

表2‒5　選択したアイテム別に表示される「種別」

選択したアイテム

表示される［種別］

日次データ

日次：フォームシートファイル形式（和暦）

日次：フォームシートファイル形式（西暦）

日次：レポートファイル形式（和暦）

日次：レポートファイル形式（西暦）

月次データ

月次：フォームシートファイル形式（和暦）

月次：フォームシートファイル形式（西暦）

月次：レポートファイル形式（和暦）

月次：レポートファイル形式（西暦）

年次データ

年次：フォームシートファイル形式（和暦）

年次：フォームシートファイル形式（西暦）

年次：レポートファイル形式（和暦）

年次：レポートファイル形式（西暦）

日付・時刻データ

日付・時刻：レポートファイル形式（和暦）

日付・時刻：レポートファイル形式（西暦）

和暦（日次）データ

日次：フォームシートファイル形式（和暦）

日次：レポートファイル形式（和暦）

和暦（月次）データ

月次：フォームシートファイル形式（和暦）

月次：レポートファイル形式（和暦）

和暦（年次）データ

年次：フォームシートファイル形式（和暦）

年次：レポートファイル形式（和暦）

印刷日付データ

印刷日付（西暦）

印刷日付（和暦）

印刷時刻

－
（凡例）

－：該当する項目がありません。

注

  • 英語ロケールおよび中国語ロケールでは，フォームシートファイル形式は使用できません。

  • 英語ロケールおよび中国語ロケールでは，和暦は使用できません。

  • 西暦に全角文字が含まれる場合は，英語ロケールでは使用できません。

［表示形式一覧］リストボックス

種別を選択すると，その分類に属するユーザ定義の表示形式の一覧が表示されます。

［定義］テキストボックス

表示形式一覧から選択された表示形式が表示されます。ユーザは，表示形式を任意に指定することもできます。「2011年7月2日　10時42分34秒」を表示する場合の日付および時刻データの指定例を次の表に示します。

表2‒6　日付および時刻データの指定例

データ種別

［定義］テキストボックスでの指定例

表示結果

日付

%4Y-%02M-%02D

2011-07-02

'%2Y.%M.%D

'11/7/2

印刷日：%4Y/%02M/%02D

印刷日：2011/07/02

%1u%3u年%02M月%02D日

平23年07月02日

%3u/%02M/%02D

23/07/02

時刻

'%2Y/%M/%D/ %1a %h:%m:%s

'11/7/2 am 10:42:34

%4Y-%2M-%2D %2h:%2m:%2s

2011- 7- 2 10:42:34

%4Y年%2M月%2D日 %2a%2h時%2m分%2s秒

2011年 7月 2日 午前10時42分34秒

%3u/%02M/%02D %0a%02h/%02m/%02s

23/07/02 AM10/42/34

なお，指定方法については，マニュアル「EUR 帳票作成 操作ガイド」もあわせて参照してください。

［元号年1年を元年と表示する］チェックボックス

選択したアイテムが，「日付データ」または「印刷日付データ」の場合に表示される設定項目です。

元号年1年を「元年」と表示するかどうかを設定します。デフォルトは，「オフ（元号年1年を元年と表示しない）」です。

ただし英語ロケールおよび中国語ロケールでは，［元号年1年を元年と表示する］チェックボックスは使用できません。

［サンプル］

［定義］テキストボックスに指定された表示形式に従って，実際の表示状態が表示されます。

ページの先頭へ

(2)　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 44 / 139


2.4.5 ［表示形式］（ページ番号）タブ : EUR 帳票作成 画面リファレンス

  • 45 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.4　［アイテムのプロパティ］ダイアログ

  • 2.4.5　［表示形式］（ページ番号）タブ

2.4.5　［表示形式］（ページ番号）タブ

ページ番号アイテムの表示形式の属性を変更します。［分類］リストボックスには，「ページ番号」と表示されます。

〈この項の構成〉

  • (1)　［表示形式］（ページ番号）タブで設定できる項目

  • (2)　画面図

(1)　［表示形式］（ページ番号）タブで設定できる項目

［表示形式］（ページ番号）タブで設定できる項目を次に示します。

［表示形式］グループボックス

ページ番号アイテムの表示形式を選択します。デフォルトは，「バージョン3形式」です。帳票ファイル上に複数のページ番号を設定している場合，どちらの表示形式も，ページ番号アイテムごとに異なる表示形式を設定できます。

ただし，ASCIIコード以外の文字を含む場合は，英語ロケールでは使用できません。また，半角カナ文字，全角文字などのASCIIコード以外の文字を含む場合は，中国語に翻訳して表示されます。

なお，選択したページ番号アイテムがバージョン2以前に作成した場合と，バージョン3以降で作成した場合とでは，［表示形式］グループボックスのラジオボタンの状態が異なります。

選択したページ番号アイテムが，バージョン2以前に作成したページ番号アイテムの場合は［バージョン2形式］のラジオボタンが，バージョン3以降で作成したページ番号アイテムの場合は［バージョン3形式］のラジオボタンがチェックされています。

［バージョン2形式］ラジオボタン

［レポートのプロパティ］ダイアログの［レポートの構成］タブで設定した，ページ番号の情報と，改ページの設定に従ってページ番号を出力します。

［バージョン3形式］ラジオボタン

ページ番号を初期化するかどうかを設定できます。ページ番号を初期化する場合は，改ページの設定に従います。この形式は，［レポートのプロパティ］ダイアログの［レポートの構成］タブでの［改ページの設定に従う］かどうかの設定には依存しません。

［表示形式一覧］リストボックス

ユーザ定義の表示形式の一覧が表示されます。選択した表示形式は，サンプルに表示されます。

［最大ページ桁数］リストボックス

ページ番号の最大桁数を設定します。［最大ページ桁数］を設定すると，編集したページ番号アイテムの全文字列が印刷できるかどうかを確認できます。設定できる値は，「1，2，3，4，5，任意」です。デフォルトは，「3」です。

ページ番号がアイテム枠に収まらなかった場合は，「***」が表示されます。

［定義］テキストボックス

表示形式一覧から選択された表示形式が表示されます。ユーザは，次に示す表示形式一覧の形式に従って直接入力することで，ページ番号の出力形式を任意に指定することもできます。1/1や-1-などの，/，／，- -，－　－などは，固定文字として扱います。

表2‒7　表示形式で［バージョン2形式］を選択している場合の指定値と印刷結果

表示形式の指定値

印刷結果

*

「*」の位置にページ番号を半角で印刷します。

＊

「＊」の位置にページ番号を全角で印刷します。

*または＊の複数指定

最初の「*」または「＊」の位置に，ページ番号を半角または全角で印刷し，それ以降は「*」または「＊」のまま印刷します。

$

「$」の位置に最終ページ番号を半角で印刷します。

＄

「＄」の位置に最終ページ番号を全角で印刷します。

$または＄の複数指定

最初の「$」または「＄」の位置に，最終ページ番号を半角または全角で印刷し，それ以降は「$」または「＄」のまま印刷します。
（例）5枚から成る帳票を印刷する場合

［定義］のテキストボックスに「*/$」と設定すると，1/5～5/5のページ番号が印刷されます。

表2‒8　表示形式で［バージョン3形式］を選択している場合の指定値と印刷結果

表示形式の指定値

改ページの

初期化指定

印刷結果

%p

初期化なし

現在表示中のページ番号を半角で印刷します。

%ｐ

初期化なし

現在表示中のページ番号を全角で印刷します。

%t

初期化なし

最終ページ番号を半角で印刷します。

%ｔ

初期化なし

最終ページ番号を全角で印刷します。

%ip

初期化あり

現在表示中のページ番号を半角で印刷します。

%ｉｐ

初期化あり

現在表示中のページ番号を全角で印刷します。

%it

初期化あり

改ページされた範囲の最終ページ番号を半角で印刷します。

%ｉｔ

初期化あり

改ページされた範囲の最終ページ番号を全角で印刷します。

%%

－

「%」を印刷します。
（凡例）

－：該当する項目はありません。

（例）8ページの帳票で，6ページ目で改ページしている場合

［定義］のテキストボックスに「%ip/%it」と設定すると，1/5～5/5と1/3～3/3のページ番号が印刷されます。

［サンプル］

［定義］テキストボックスに指定された表示形式に従って，実際の表示状態が表示されます。

ページの先頭へ

(2)　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 45 / 139


2.4.6 ［配置］タブ : EUR 帳票作成 画面リファレンス

  • 46 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.4　［アイテムのプロパティ］ダイアログ

  • 2.4.6　［配置］タブ

2.4.6　［配置］タブ

アイテム枠内での，アイテムの配置を変更します。図形アイテムと線アイテムは配置位置を変更できません。

〈この項の構成〉

  • (1)　［配置］タブで設定できる項目

  • (2)　画面図

(1)　［配置］タブで設定できる項目

［配置］タブで設定できる項目を次に示します。

［横位置］グループボックス

選択されたアイテムを水平方向に揃えます。

［左寄せ］ラジオボタン

選択されたアイテムを左に寄せて配置します。

［中央］ラジオボタン

選択されたアイテムを中央に配置します。ただし，次に示す場合は，「中央」は選択できません。

  • ［アイテムのプロパティ］ダイアログの［文字配置］タブで，［桁数を指定］または［CPIを指定］のラジオボタンがオンの場合

［均等］ラジオボタン

選択されたアイテムを均等に配置します。ただし，次に示す場合は，「均等」は選択できません。

  • ［アイテムのプロパティ］ダイアログの［文字配置］タブで，［桁数を指定］または［CPIを指定］のラジオボタンがオンの場合

  • バーコードアイテムと画像アイテムを選択した場合

    バーコードアイテムと画像アイテムを含めた複数選択の場合は，「均等」を指定しても，バーコードアイテムと画像アイテムは変更されません。

［右寄せ］ラジオボタン

選択されたアイテムを右に寄せて配置します。

［縦位置］グループボックス

選択されたアイテムを垂直方向に揃えます。

［上寄せ］ラジオボタン

選択されたアイテムを上に寄せて配置します。

［中央］ラジオボタン

選択されたアイテムを中央に配置します。

［均等］ラジオボタン

選択されたアイテムを均等に配置します。

なお，バーコードアイテムと画像アイテムを選択した場合，「均等」は選択できません。また，バーコードアイテムと画像アイテムを含めた複数選択をした場合，「均等」を指定しても，バーコードアイテムと画像アイテムは変更されません。

［下寄せ］ラジオボタン

選択されたアイテムを下に寄せて配置します。

［横位置］と［縦位置］を組み合わせると，どのようにアイテムが配置されるかを次に示します。

重要

  • ［アイテムのプロパティ］ダイアログの［画像］タブで［画像サイズで表示］ラジオボタンを選択している場合，画像サイズよりアイテム枠が小さいと，画像はアイテム枠の大きさの分しか表示されません。このとき，横位置，縦位置で指定した指定値は無効になります。

  • ［中央］または［均等］ラジオボタンがオンになっているアイテムに対して，［アイテムのプロパティ］ダイアログボックスの［文字配置］タブで［桁数を指定］または［CPIを指定］ラジオボタンをオンにすると，アイテムは左寄せになります。

ページの先頭へ

(2)　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 46 / 139


2.4.7 ［フォント］タブ : EUR 帳票作成 画面リファレンス

  • 47 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.4　［アイテムのプロパティ］ダイアログ

  • 2.4.7　［フォント］タブ

2.4.7　［フォント］タブ

文字アイテムの属性を変更します。

フォントやサイズを設定することで，実行する環境によっては，帳票が正しく印刷されなかったり，表示されなかったりする場合があります。詳細は，マニュアル「EUR 帳票作成 操作ガイド」を参照してください。

〈この項の構成〉

  • (1)　［フォント］タブで設定できる項目

  • (2)　画面図

(1)　［フォント］タブで設定できる項目

［フォント］タブで設定できる項目を次に示します。

［フォント名］コンボボックス

使用するフォント名を設定します。テキストボックスに直接入力するか，またはリストボックスから選択すると，そのフォント名がテキストボックスに反映されます。また，ユーザのプリンタ固有のフォントを選択した場合，画面表示では，これに最も近いフォントが使用されます。

［スタイル］コンボボックス

使用する文字のスタイルを設定します。テキストボックスに直接入力するか，またはリストボックスから選択すると，そのスタイルがテキストボックスに反映されます。標準，斜体，太字，および太字斜体が選択できます。

［サイズ］コンボボックス

使用する文字のサイズを設定します。単位は，ポイント（pt）です。テキストボックスに直接入力するか，またはリストボックスから選択すると，そのサイズがテキストボックスに反映されます。テキストボックスに直接入力する場合は，3～256の値で，小数点以下1桁までです。ただし，印刷したときに認識できるサイズは，漢字を含む場合は最低10，英字だけの場合は最低8程度です。

選択したフォントによって，リストボックスの表示が異なることがあります。

［色］リストボックス

使用するフォントの色を指定します。指定できる色は，次に示す色のほか，独自の色を作成して指定することもできます。デフォルトは，黒です。モノクロディスプレイの場合は，灰色の濃淡で表示されます。

黒，青，水色，黄緑，赤，明るい紫，黄，白，濃紺，緑青，緑，紫，栗色，オリーブ，灰色，銀，5%灰色，10%灰色，15%灰色，20%灰色，25%灰色，30%灰色，35%灰色，40%灰色，45%灰色，50%灰色，55%灰色，60%灰色，65%灰色，70%灰色，75%灰色，80%灰色，85%灰色，90%灰色，95%灰色

独自の色を作成する場合は，［色］のリストボックス横にある［...］ボタンをクリックしてください。［色の設定］ダイアログが表示されます。作成した独自の色は，以後EURを起動しても使用できます。

［フォント縦横比補正を行う］チェックボックス

文字の高さと幅の比率を2:1に補正して描画するか，またはフォントの属性に従って描画するかのどちらかを設定します。

使用するフォントが固定ピッチで，かつオプションの［表示］タブの［文字幅計算方法］グループボックスで［静的］ラジオボタンを選択している場合だけ有効です。そのほかの場合は，選択しても無効となります。デフォルトは「オフ（フォント縦横比補正を行わない）」です。

描画の違いを次に示します。

［文字修飾］グループボックス

文字修飾を設定します。

［下線］チェックボックス

使用する文字に下線を描画するかどうかを設定します。チェックボックスをオンにすると，文字に下線を描画※1します。デフォルトは，「オフ（文字に下線を描画しない）」です。

文字の方向による下線の描画位置※2の規則は次のようになります。

文字の方向

下線の描画位置

上向きで左から右

文字に対して下側

上向きで上から下

文字に対して右側

左向きで下から上

文字に対して右側

右向きで上から下

文字に対して左側

左向きで左から右

文字に対して上側

文字の方向による下線の描画位置のイメージを次に示します。

注※1

文字に重ならない位置に下線が出力されますが，一部のフォント（メイリオフォントなど）では，文字に重なって下線が出力されることがあります。

注※2

中国語の縦書きの場合も，日本語の縦書きと同じ位置に下線が描画されます。

［プレビュー］

フォント，スタイル，サイズ，色，および下線を設定したときの，文字のサンプルが表示されます。

使用するフォントが英語フォントの場合は，「AaBbYyZz」が表示されます。

使用するフォントが中国語（簡体字）フォントの場合は，「 [図データ] 」が表示されます。中国語（繁体字）フォントの場合は，「中文字型範例」が表示されます。

使用するフォントが日本語フォントの場合は，「Aaあぁアァ亜宇」が表示されます。

メッセージ

選択したフォントが表示，または印刷でどのように使用されるかが表示されます。

ページの先頭へ

(2)　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 47 / 139


2.4.8 ［線］タブ : EUR 帳票作成 画面リファレンス

  • 48 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.4　［アイテムのプロパティ］ダイアログ

  • 2.4.8　［線］タブ

2.4.8　［線］タブ

線アイテムの属性を変更します。

〈この項の構成〉

  • (1)　［線］タブで設定できる項目

  • (2)　画面図

(1)　［線］タブで設定できる項目

［線］タブで設定できる項目を次に示します。

［線種］リストボックス

線の種類を指定します。指定できる線種は，次に示す7種類です。

線の太さは［線の太さ］リストボックスで設定します。

線種を変更する線アイテムが，繰り返し対象でない場合は，［繰り返し線］と［繰り返し外枠線］は，不活性になります。

［線の太さ］リストボックス

線の太さを指定します。指定できる線の太さは，次に示す5種類です。

線の太さを独自に設定する場合は，「任意サイズ」を選択したあと，テキストボックスに線の太さを指定します。テキストボックスは，「任意サイズ」を選択した場合にしか指定できません。

テキストボックスには，線の太さを0.1～10.0の値で設定します。単位は，ポイント（pt）です。なお，ポイント指定で太さを設定した線は，バージョン07-50以前のEURで表示すると，実線で表示されます。

［線色］リストボックス

使用する線の色を指定します。指定できる色は，次に示す色のほか，独自の色を作成して指定することもできます。デフォルトは，黒です。モノクロディスプレイの場合は，灰色の濃淡で表示されます。

黒，青，水色，黄緑，赤，明るい紫，黄，白，濃紺，緑青，緑，紫，栗色，オリーブ，灰色，銀，5%灰色，10%灰色，15%灰色，20%灰色，25%灰色，30%灰色，35%灰色，40%灰色，45%灰色，50%灰色，55%灰色，60%灰色，65%灰色，70%灰色，75%灰色，80%灰色，85%灰色，90%灰色，95%灰色

独自の色を作成する場合は，［色］のリストボックス横にある［...］ボタンをクリックしてください。［色の設定］ダイアログが表示されます。作成した独自の色は，以後EURを起動しても使用できます。

［繰り返し線］グループボックス

選択した線が繰り返し対象である場合，繰り返す線の属性を，任意の個数ごとに変更するかどうか，線の属性を変更できます。

［n個ごと］チェックボックス

繰り返しの個数と線種を指定するかどうかを設定します。

［n個ごと］テキストボックス

何個ごと繰り返し線を変更するか，個数を設定します。設定できる値は，2～32,767です。

［繰り返し線種］リストボックス

繰り返し線の種類を指定します。次に示す7種類です。

線の太さは［線の太さ］リストボックスで設定します。

［線の太さ］リストボックス

線の太さを指定します。指定できる線の太さは，次に示す5種類です。

線の太さを独自に設定する場合は，「任意サイズ」を選択したあと，テキストボックスに線の太さを指定します。テキストボックスは，「任意サイズ」を選択した場合にしか指定できません。

テキストボックスには，線の太さを0.1～10.0の値で設定します。単位は，ポイント（pt）です。なお，ポイント指定で太さを設定した線は，バージョン07-50以前のEURで表示すると，実線で表示されます。

［繰り返し外枠線］グループボックス

繰り返し線の外枠線の属性を変更できます。［外枠線］のチェックボックスをオンにすると，外枠線の線種を設定できます。

［外枠線種］リストボックス

繰り返し線の外枠線の種類を指定します。次に示す7種類です。

線の太さは［線の太さ］リストボックスで設定します。

［線の太さ］リストボックス

線の太さを指定します。指定できる線の太さは，次に示す5種類です。

線の太さを独自に設定する場合は，「任意サイズ」を選択したあと，テキストボックスに線の太さを指定します。テキストボックスは，「任意サイズ」を選択した場合にしか指定できません。

テキストボックスには，線の太さを0.1～10.0の値で設定します。単位は，ポイント（pt）です。なお，ポイント指定で太さを設定した線は，バージョン07-50以前のEURで表示すると，実線で表示されます。

［プレビュー］

線種と線色を設定した時のサンプルが表示されます。ただし，［繰り返し線］と［繰り返し外枠線］で設定した線は，表示されません。

ページの先頭へ

(2)　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 48 / 139


2.4.9 ［図形］タブ : EUR 帳票作成 画面リファレンス

  • 49 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.4　［アイテムのプロパティ］ダイアログ

  • 2.4.9　［図形］タブ

2.4.9　［図形］タブ

図形アイテム（網掛けアイテム，角丸四角アイテム，円／楕円アイテム，および多角形アイテム）の属性を変更します。

〈この項の構成〉

  • (1)　［図形］タブで設定できる項目

  • (2)　画面図

(1)　［図形］タブで設定できる項目

［図形］タブで設定できる項目を次に示します。

［模様］リストボックス

網掛けのパターンの種類を指定します。指定できるパターンは，次に示す14種類です。

アイテム作成時のデフォルトは，網掛けアイテムの場合「薄い網掛け」，網掛けアイテムの以外の場合「透明（塗りつぶしなし）」です。

［背景色］リストボックス

網掛けの背景色を指定します。指定できる色は，次に示す色のほか，独自の色を作成して指定することもできます。デフォルトは，白です。モノクロディスプレイの場合は，灰色の濃淡で表示されます。

黒，青，水色，黄緑，赤，明るい紫，黄，白，濃紺，緑青，緑，紫，栗色，オリーブ，灰色，銀，5%灰色，10%灰色，15%灰色，20%灰色，25%灰色，30%灰色，35%灰色，40%灰色，45%灰色，50%灰色，55%灰色，60%灰色，65%灰色，70%灰色，75%灰色，80%灰色，85%灰色，90%灰色，95%灰色

独自の色を作成する場合は，［色］のリストボックス横にある［...］ボタンをクリックしてください。［色の設定］ダイアログが表示されます。作成した独自の色は，以後EURを起動しても使用できます。

［前景色］リストボックス

網掛けの前景色（模様の色）を指定します。指定できる色は，次に示す色のほか，独自の色を作成して指定することもできます。デフォルトは，黒です。モノクロディスプレイの場合は，灰色の濃淡で表示されます。

黒，青，水色，黄緑，赤，明るい紫，黄，白，濃紺，緑青，緑，紫，栗色，オリーブ，灰色，銀，5%灰色，10%灰色，15%灰色，20%灰色，25%灰色，30%灰色，35%灰色，40%灰色，45%灰色，50%灰色，55%灰色，60%灰色，65%灰色，70%灰色，75%灰色，80%灰色，85%灰色，90%灰色，95%灰色

独自の色を作成する場合は，［色］のリストボックス横にある［...］ボタンをクリックしてください。［色の設定］ダイアログが表示されます。作成した独自の色は，以後EURを起動しても使用できます。

［模様］のリストボックスで「塗りつぶし」を指定した場合は，前景色ではなく，背景色で塗りつぶされます。

［角丸め］グループボックス

角丸四角アイテムの四隅を，丸めるかどうかを指定します。角丸四角アイテム作成時のデフォルトは，すべてのチェックボックスが「オン（角を丸める）」です。

角丸四角アイテムとほかの図形アイテムを一緒に選択した場合，チェックボックスは不活性になります。

［左上］チェックボックス

オンにすると，左上の角を丸めます。

［左下］チェックボックス

オンにすると，左下の角を丸めます。

［右上］チェックボックス

オンにすると，右上の角を丸めます。

［右下］チェックボックス

オンにすると，右下の角を丸めます。

（例）

［影付き］チェックボックス

角丸四角アイテム，円／楕円アイテム，または多角形アイテムに影を付けるかどうかを設定します。アイテム作成時のデフォルトは，「オフ（影を付けない）」です。チェックボックスをオンにすると，角丸四角アイテム，円／楕円アイテム，または多角形アイテムに影を付けます。［模様］のリストボックスで「透明（塗りつぶしなし）」を指定した場合，次に示すように影は透明になります。

［繰り返し網掛け］グループボックス

選択した図形アイテムが繰り返し対象である場合，繰り返す網掛けの属性を，任意の個数ごとに変更するかどうか，網パターンの属性を変更できます。［n個ごと］のチェックボックスをオンにすると，繰り返しの個数と網パターンを設定できます。繰り返し設定時のデフォルトは，「オフ（網掛けを繰り返さない）」です。

［個数］テキストボックス

何個ごと繰り返しパターンを変更するか，個数を設定します。設定できる値は，2～32,767です。

［繰り返し模様］リストボックス

網掛けのパターンの種類を指定します。指定できるパターンは，次に示す14種類です。

デフォルトは，「薄い網掛け」です。

［枠線］グループボックス

図形アイテムの枠線を表示するかどうかを設定します。［枠線表示］のチェックボックスをオンにすると，枠線種，枠線の太さ，枠線色を設定できます。アイテム作成時のデフォルトは，網掛けアイテムの場合は「オフ（枠線を表示しない）」，網掛けアイテム以外の場合は「オン（枠線を表示する）」です。

［枠線種］リストボックス

枠線の種類を指定します。指定できる線種は，次に示す7種類です。

［線の太さ］リストボックス

枠線の太さを指定します。指定できる太さは，次に示す4種類です。

アイテム作成時のデフォルトは，網掛けアイテムの場合は不活性，網掛けアイテム以外の場合は中線です。

［枠線色］リストボックス

枠線の色を指定します。指定できる色は，次に示す色のほか，独自の色を作成して指定することもできます。デフォルトは，黒です。モノクロディスプレイの場合は，灰色の濃淡で表示されます。

黒，青，水色，黄緑，赤，明るい紫，黄，白，濃紺，緑青，緑，紫，栗色，オリーブ，灰色，銀，5%灰色，10%灰色，15%灰色，20%灰色，25%灰色，30%灰色，35%灰色，40%灰色，45%灰色，50%灰色，55%灰色，60%灰色，65%灰色，70%灰色，75%灰色，80%灰色，85%灰色，90%灰色，95%灰色

独自の色を作成する場合は，［色］のリストボックス横にある［...］ボタンをクリックしてください。［色の設定］ダイアログが表示されます。作成した独自の色は，以後EURを起動しても使用できます。

［プレビュー］

模様，背景色，前景色，角丸め，影付き，および枠線を設定した時のサンプルが表示されます。ただし，［繰り返し網掛け］で設定した模様は，表示されません。

ページの先頭へ

(2)　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 49 / 139


2.4.10 ［画像］タブ : EUR 帳票作成 画面リファレンス

  • 50 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.4　［アイテムのプロパティ］ダイアログ

  • 2.4.10　［画像］タブ

2.4.10　［画像］タブ

画像アイテムの属性を変更します。

〈この項の構成〉

  • (1)　［画像］タブで設定できる項目

  • (2)　画面図

(1)　［画像］タブで設定できる項目

［画像］タブで設定できる項目を次に示します。

［表示補正］グループボックス

アイテム枠のサイズを変更した場合に，画像アイテムをどのように表示するかを設定します。

［アイテムに合わせ拡大／縮小］ラジオボタン

画像アイテム枠のサイズを変更した場合，画像データのサイズが変更した画像アイテムの枠のサイズに従って表示されます。［アイテムに合わせ拡大／縮小］のラジオボタンを選択すると，［画像の縦横比を保持］のチェックボックスを設定できます。

［画像の縦横比を保持］チェックボックス

画像アイテム枠のサイズを変更した場合，画像データの縦横比を保持したまま，画像アイテム枠のサイズに収めるかどうかを設定します。デフォルトは，「オフ（画像の縦横比を保持しない）」です。

［画像サイズで表示］ラジオボタン

画像アイテム枠のサイズを変更しても，画像データが持つサイズで表示されます。

［画像アイテムの変更］グループボックス

固定画像を単一選択している時，画像アイテムを変更できます。マッピングデータウィンドウから貼り付けた画像アイテムを選択した場合は，変更できません。

［画像ファイル名］

現在選択している固定画像のファイル名が表示されます。

［変更］ボタン

画像ファイルの変更ダイアログが表示されます。

［再読み込み］ボタン

現在選択している固定画像のファイルを再読み込みする時，クリックします。

固定画像を貼り付けると，帳票ファイルに埋め込まれます。そのため，固定画像のファイルを更新しても，貼り付けた画像アイテムの同期は取れません。ファイルを更新した場合は，再読み込みしてください。

画像ファイルを外部データとして取り込み，自動的に画像の更新を反映したい場合は，ユーザ定義データから画像データを貼り付けてください。画像データの貼り付けについては，マニュアル「EUR 帳票作成 操作ガイド」を参照してください。

ページの先頭へ

(2)　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 50 / 139


2.4.11 ［バーコード］タブ : EUR 帳票作成 画面リファレンス

  • 51 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.4　［アイテムのプロパティ］ダイアログ

  • 2.4.11　［バーコード］タブ

2.4.11　［バーコード］タブ

バーコードアイテムの属性を変更します。［バーコード］タブは，バーコードアイテムを単一選択，または同じ種類のバーコードアイテムを複数選択している時に表示されます。異なる種類のバーコードアイテムを複数選択している時は，表示されません。

［バーコード形式］で設定した［サイズ］と［高さ］は，読み込みリーダで読めるかどうかを確認してから使用されることをお勧めします。

〈この項の構成〉

  • (1)　［バーコード］タブで設定できる項目

  • (2)　画面図

(1)　［バーコード］タブで設定できる項目

［バーコード］タブで設定できる項目を次に示します。

［バーコード形式］グループボックス

バーコードを表示，または印刷した時に，バーコードアイテムをどのように表示するかを設定します。

表2‒9　バーコードの種類別の設定できる項目

種類

サイズ

高さ

入力データ形式

JAN標準/UPC-A

○

○

×

JAN短縮/UPC-E

○

○

×

CODE39

○

○

×

CODE128

○

○

○

NW-7

○

○

×

ITF

○

○

×

カスタマバーコード

○

×

×

QRコード

×

×

○
（凡例）

○：指定できます。

×：指定できません。

［種類］リストボックス

バーコードの種類を指定します。EURで指定できるバーコードは，JIS X 0507（JAN標準※1/UPC-A，JAN短縮※2/UPC-E），X 0502（ITF），X 0503（CODE39），X 0504（CODE128），X 0506（コーダバー。ただし，EURでは「NW-7」と表記します），X 0510（QRコード），および郵便事業株式会社が定めるカスタマバーコードです。デフォルトは，「JAN標準/UPC-A」です。

注※1

    JIS X 0507で規定されているEAN-13に相当します。

注※2

    JIS X 0507で規定されているEAN-8に相当します。

［サイズ］テキストボックス

バーコードのサイズを設定します。サイズの単位は，選択したバーコードの種類によって替わります。デフォルトは，「1」です。

各バーコードの設定内容については，マニュアル「EUR 帳票作成 操作ガイド」を参照してください。

［高さ］テキストボックス

バーコードの高さを設定します。高さの範囲は，1.0～50.0mmで，0.1mm単位で設定します。デフォルトは，「24.5」です。

バーコードの種類が「カスタマバーコード」と「QRコード」の場合は，［高さ］を指定することはできません。

［入力データ形式］リストボックス

バーコードの種類が「CODE128」と「QRコード」の場合，入力データ形式を指定します。

「CODE128」の場合は，「コードセットB」と「コードセットC」のどちらの入力データを指定するかを選択します。デフォルトは，「コードセットB」です。

「QRコード」の場合は，「文字列」，「16進文字列」，「16進バイナリ」のうち，どの入力データを指定するかを選択します。デフォルトは，「文字列」です。

［回転角度］グループボックス

バーコードをどのように表示するか，回転角度を設定します。

［0°］ラジオボタン

バーコードフィールドを帳票ファイルに貼り付けた時の状態で表示します。デフォルトは，「0°」です。

［90°］ラジオボタン

バーコードを左回りに90度回転して表示します。

［270°］ラジオボタン

バーコードを左回りに270度回転して表示します。

［データ形式］グループボックス

バーコードフィールドのデータをどのように表示するかを設定します。

表2‒10　バーコードフィールドに付加できるデータ形式一覧

種類

データ形式

チェックキャラクタ

スタート／ストップキャラクタ

FNC1

JAN標準/UPC-A

○

－

×

JAN短縮/UPC-E

○

－

×

CODE39

○

○

×

CODE128

－

－

○

NW-7

○

○

×

ITF

○

－

×

QRコード

×

×

×
（凡例）

○：付加できます。

×：付加できません。

－：固定（オン）です。

［バーコード形式］の［種類］のリストボックスから，「カスタマバーコード」を指定した場合は，［カスタマバーコードのデータ形式］のグループボックスからデータ形式を選択します。

［チェックキャラクタを付加する］チェックボックス

バーコード表示に，チェックキャラクタを付加するかどうかを設定します。使用するデータにチェックキャラクタが付加されている場合は，チェックキャラクタは付加しないでください。

［スタート／ストップキャラクタを付加する］チェックボックス

バーコード表示に，スタート／ストップキャラクタを付加するかどうかを設定します。デフォルトは，「オフ（付加しない）」です。

［FNC1を付加する］チェックボックス

バーコードの種類が「CODE128」の場合，スタートキャラクタのあとに「FNC1」を付加するかどうかを設定します。FNC1は，特定の工業規格に合致するシンボルを識別するキャラクタです。

［カスタマバーコードのデータ形式］グループボックス

［バーコード形式］の［種類］のリストボックスから，「カスタマバーコード」を指定した場合に，バーコードフィールドのデータをどのように表示するかを設定できます。［種類］リストボックスで「QRコード」を選択した場合は，表示されません。

［郵便番号＋住所表示番号］ラジオボタン

データが「郵便番号と住所表示番号」の場合に選択します。EURがチェックデジットと制御コードを付加してカスタマバーコードを表示します。

［郵便番号＋住所表示番号＋チェックデジット＋制御コード］ラジオボタン

データが「郵便番号，住所表示番号，チェックデジット，および制御コード」の場合に選択します。EURは，データをそのままカスタマバーコードに変換して表示します。

［データキャラクタを表示する］チェックボックス

バーコード表示に，データキャラクタを表示するかどうかを設定します。設定できるバーコードは，JAN標準/UPC-A，JAN短縮/UPC-E，CODE39，CODE128，およびNW-7です。ITFは，オン（固定）です。［種類］リストボックスで「QRコード」を選択した場合は，表示されません。

バーコードCODE128に表示するデータキャラクタは，次に示す属性を設定できます。ただし，バージョン04-07以前のEURでCODE128を貼り付けていた帳票を，バージョン04-08で開いた場合は，データキャラクタの属性は設定できません。

［最大n行］テキストボックス

表示するデータキャラクタの行数を指定します。指定できる値は，1～9の整数です。デフォルトは，「1（行）」です。［種類］リストボックスで「QRコード」を選択した場合は，表示されません。

表示するデータキャラクタを複数行で表示する場合は，データに改行コード「\n」を入れてください。改行コードが指定されていると，改行コードの位置で，データキャラクタを折り返して表示されます。

［表示文字を認識する］チェックボックス

データに指定されている半角記号「( ) -」と半角空白を，データキャラクタの表示文字として認識させるかどうかを設定します。［種類］リストボックスで「QRコード」を選択した場合は，表示されません。設定できるバーコードは，CODE128です。デフォルトは，「オフ（表示文字を認識しない）」です。

なお，データに半角記号「( ) -」と半角空白が指定されていても，表示するバーコードシンボルには，影響はありません。

［機能コードをエスケープシーケンスで指定する］チェックボックス

機能コードをエスケープシーケンスで指定するかどうかを設定します。設定できるバーコードは，CODE128です。デフォルトは，「オフ（機能コードをエスケープシーケンスで指定しない）」です。［種類］リストボックスで「QRコード」を選択した場合は，表示されません。

［機能コードをエスケープシーケンスで指定する］チェックボックスをオンにすると，半角記号「[ ]」で囲まれたデータの文字列が，機能コードとして出力されます。指定できる機能コードを，次に示します。

表2‒11　エスケープシーケンスが指定できる機能コードと指定方法

指定できる機能コード

［機能コードをエスケープシーケンスで指定する］チェックボックスの指定

オン

オフ

[FNC1]

FNC1を挿入します。

[FNC1]を文字列として出力します。

[CODEB]

CODEBを挿入します。

CODEBを文字列として出力します。

[CODEC]

CODECを挿入します。

CODECを文字列として出力します。

\[

[を文字列として出力します。

\[を文字列として出力します。

\\

\を文字列として出力します。

\\を文字列として出力します。

データに\が含まれている場合は，\に続く文字列を「文字」として出力されます。

［QRコード］グループボックス

［バーコード形式］の［種類］のリストボックスから，「QRコード」を指定した場合に，QRコードの訂正レベル，バージョン，セルサイズを設定できます。［種類］リストボックスでQRコード以外を選択した場合は表示されません。

［訂正レベル］リストボックス

MレベルまたはQレベルを選択できます。訂正レベルとは，万一QRコードに損傷が発生した場合，損傷の度合いに応じてデータの復元能力を設定しておくもので，L（7％）＜M（15％）＜Q（25％）＜H（30％）レベルがあります。EURで使用できる訂正レベルは，M（15％）レベルおよびQ（25％）レベルです。

［バージョンを指定する］チェックボックス

QRコードの型番（バージョン）を指定できます。QRコードの型番は1型から40型まであります。型番を指定する場合は，チェックをオンにして，テキストボックスに型番を入力してください。型番は，1～40までの整数です。

［セルサイズを指定する］チェックボックス

QRコードのセルサイズを指定できます。セルサイズの単位は，1/100mmです。セルサイズを指定する場合は，チェックをオンにして，テキストボックスにセルサイズを入力してください。21～126まで指定できます。

ページの先頭へ

(2)　画面図

JAN標準/UPC-A，JAN短縮/UPC-E，CODE39，CODE128，NW-7，ITF，カスタマバーコードの場合

QRコードの場合

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 51 / 139


2.4.12 ［データキャラクタ］タブ : EUR 帳票作成 画面リファレンス

  • 52 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.4　［アイテムのプロパティ］ダイアログ

  • 2.4.12　［データキャラクタ］タブ

2.4.12　［データキャラクタ］タブ

バーコードCODE128に表示する，データキャラクタのプロパティを設定します。

〈この項の構成〉

  • (1)　［データキャラクタ］タブで設定できる項目

  • (2)　画面図

(1)　［データキャラクタ］タブで設定できる項目

［データキャラクタ］タブで設定できる項目を次に示します。

［フォント名］コンボボックス

データキャラクタに使用するフォントを設定します。テキストボックスに直接入力するか，またはリストボックスから選択すると，そのフォント名がテキストボックスに反映されます。デフォルトは，空白です。

フォント名には，縦書きフォントを除くすべてのフォントと，可変ピッチのフォントを設定できます。［フォント名］コンボボックスが空白の場合は「ＭＳ Ｐ明朝」が仮定されます。英語ロケール，中国語ロケールの場合は，「MS PMincho」が仮定されます。

［サイズ］コンボボックス

データキャラクタに使用する文字のサイズを設定します。単位は，ポイント（pt）です。テキストボックスに直接入力するか，またはリストボックスから選択すると，そのサイズがテキストボックスに反映されます。テキストボックスに直接入力する場合は，3～256の値で設定します。選択したフォントによって，リストボックスの表示が異なることがあります。デフォルトは，「9（pt）」です。

［縦位置］テキストボックス

バーコード部とデータキャラクタを，どのくらい離すかを指定します。単位は，mmです。値は，小数点以下1桁まで指定できます。

［横位置］リストボックス

データキャラクタを左寄せで表示するか，または中央に表示するかのどちらかを選択します。デフォルトは，「中央」です。

ページの先頭へ

(2)　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 52 / 139


2.4.13 ［文字配置］タブ : EUR 帳票作成 画面リファレンス

  • 53 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.4　［アイテムのプロパティ］ダイアログ

  • 2.4.13　［文字配置］タブ

2.4.13　［文字配置］タブ

文字アイテムの文字間隔や描画方向を変更します。

〈この項の構成〉

  • (1)　［文字配置］タブで設定できる項目

  • (2)　画面図

(1)　［文字配置］タブで設定できる項目

［文字配置］タブで設定できる項目を次に示します。

［文字ピッチを指定］グループボックス

文字ピッチを指定します。

［指定なし］ラジオボタン

文字ピッチを指定しないときに選択します。

［桁数を指定］ラジオボタン

アイテムの文字ピッチを桁数で指定するときに選択します。設定できるアイテムは，マッピングデータの文字データ，数値データ，および数値データ（集計対象外）です。［ワードラップを行う］チェックボックスがオンになっている場合は，選択できません。

アイテムの桁数を指定する場合は，［桁数を指定］ラジオボタンをオンにして，アイテム枠の分割数を［桁］テキストボックスに指定します。指定した桁数でアイテム枠を分割して，1マスに1文字を中央に配置します。桁数は，1以上の整数で指定してください。上限はありません。指定する桁の数え方は，半角文字を1桁，全角文字を2桁とします。ただし桁数を指定したアイテムに，改行コードを含むデータは指定できません。

桁数を指定した例を次に示します。なお，実際の表示では，1マスを示す線は表示されません。

  • （例）

    表示するデータ：12345（半角数字）

    アイテム枠：100（pt）

    桁：5

    1マスのサイズは，アイテム枠÷桁＝100÷5＝20（pt）となります。

    表示するデータ：あいうえお（全角文字）

    アイテム枠：100（pt）

    桁：10

    1マスのサイズは，アイテム枠÷桁＝100÷10＝10（pt）となります。

表示するフォントは，［フォント］タブで設定されている情報に従います。設定されているフォントのサイズが，分割された1マスの幅より大きい場合は，文字が重なって表示されます。アイテム枠を広げたり，フォントのサイズを変更したりしてください。

［桁数を指定］のチェックボックスをオンにすると，［桁］テキストボックス以外の属性は設定できません。また，以前設定されていた［文字配置］タブの属性は，すべてリセットされます。

［CPIを指定］ラジオボタン

文字ピッチをCPIで指定するときに選択します。すべての文字アイテムで設定できます。CPIで指定する場合は，［CPIで指定］ラジオボタンをオンにして，分割数を［CPI］テキストボックスに指定します。指定できる値は，0.13（CPI）～24（CPI）です。1インチを指定した数で分割して，1マスの中央に1文字を配置します。

CPIを指定した例を次に示します。なお，実際の表示では，1マスを示す線は表示されません。

  • （例）

    表示するデータ：123あ（数字は半角文字，ひらがなは全角文字）

    CPI：5

    1マスのサイズは，1インチ÷CPI値＝1÷5＝1/5（インチ）となります。

［縮小して全体を表示］チェックボックス

文字アイテムに入力された文字の桁数およびサイズから，自動的にアイテム内に表示できるフォントサイズに変更します。

［縮小して全体を表示］チェックボックスをオンにすると，［文字配置］タブの［文字ピッチを指定］グループボックス，および［バージョン2以前の文字配置を行う］チェックボックスの属性は設定できません。

［バージョン2以前の文字配置を行う］チェックボックスがオンになっている場合は，選択できません。

また，［縮小して全体を表示］チェックボックスがオンの場合も，［配置］タブの指定に従います。

縮小して全体を表示する例を次に示します。

指定内容に小数点を含むかどうかによって次のとおり異なります。

  • フォントサイズに整数値を指定している場合

    フォントサイズは3ポイントより小さくなりません。フォントサイズを3ポイントにしても全体を表示できない場合は，3ポイントで表示できる分だけが表示されます。

  • フォントサイズに小数点が付いた値を指定している場合

    小数点が有効となるため，フォントサイズは「3ポイント+小数値」より小さくなりません。

    例えば，10.5ポイントを指定している場合は，3.5ポイントより小さくなりません。フォントサイズを3.5ポイントにしても全体を表示できない場合は，3.5ポイントで表示できる分だけが表示されます。

なお，［縮小して全体を表示］を指定できるのは，動的にアイテム内の桁数が変わるアイテムだけです。［縮小して全体を表示］を指定できるアイテムを次に示します。

  • マッピングデータウィンドウまたはユーザ定義データウィンドウから貼った，文字アイテム，数値アイテム，数値（集計対象外）アイテム

  • 集計アイテム（総集計）

  • 集計アイテム（帳票ヘッダ集計）

  • 集計アイテム（キー集計）

  • 集計アイテム（ページ集計）

  • 集計アイテム（フィールドのデータ）

［ワードラップを行う］チェックボックス

文字アイテム中のデータがアイテムの幅に収まらず，単語が行の末尾から次の行にわたってしまう場合に，単語全体を次の行に送るかどうかを選択します。ただし1単語がアイテム枠内に収まらない場合は，単語の途中で改行します。

［バージョン2以前の文字配置を行う］チェックボックス，［桁数を指定］チェックボックスがオンになっている場合は，選択できません。

EURのワードラップでは，次の文字以外の文字が連続している部分が単語として認識されます。

  • 空白

  • ハイフン

  • ハイフンマイナス

次の文字は単語の一部として認識されます。

  • 括弧，コンマ，ピリオド，アポストロフィ，引用符，ノーブレークスペースなど

また，和字および漢字は，1文字を1単語とします。

ワードラップによって，文字の配置ごとに文字アイテムがどのように表示されるかを次に示します。

ワードラップをした場合の注意事項

  • ワードラップと均等配置を組み合わせると，改行した最終行にも均等配置が適用されるため，読みにくい場合があります。ワードラップを適用するアイテムの文字配置には，均等配置しないようお勧めします。

  • EUR 08-70以前で作成された帳票を印刷，編集または表示する場合，アイテムに設定された［ワードラップを行う］指定は，EUR 09-00以降でも有効となります。ただし，ワードラップの動作は09-00以降の仕様に従います。

［禁則処理を行う］チェックボックス

禁則処理をするかどうかを指定します。禁則処理をする場合［禁則処理を行う］チェックボックスをオンにしてください。デフォルトは，［禁則処理を行う］チェックボックスがオフです。［ワードラップを行う］チェックボックスがオフになっている場合は，選択できません。

禁則処理をすると，ワードラップによって単語間が改行されるとき，指定された禁則文字が行頭または行末にならないように位置が調整されます。なお，禁則文字は［レポートのプロパティ］ダイアログの［禁則文字］タブで指定します。

  • 行頭禁則処理

    行の先頭が行頭禁則文字になる場合，行頭禁則文字の直前の文字も次の行に送ります。

    ただし，次の個所では行頭禁則処理をしません。

    ・文字データの先頭

    ・文字データ中の改行文字の直後

  • 行末禁則処理

    行の末尾が行末禁則文字となる場合，行末禁則文字を次の行に送ります。

    ただし，次の個所では行末禁則処理をしません。

    ・文字データの終端

    ・文字データ中の改行文字の直前

［文字の方向］グループボックス

文字アイテムの描画方向を選択します。ただし，［桁数の指定］のチェックボックスをオンにすると，文字の方向の設定はできません。文字の方向は，次に示す五つの中から選択します。デフォルトは，「上向きで，左から右へ」です。欧文フォントなど縦書きのないフォントが選択されている場合，「上向きで上から下」または「左向きで左から右」を選択すると，正しく表示されないことがあります。

文字の方向によって，表示されるプレビューを次に示します。

文字の方向を設定した場合は，アイテム枠の配置を変更するとき注意が必要です。

例えば，「左向きで，下から上へ」を選択したあと，右詰めで文字を描画したい場合は，［オプション］ダイアログの［文字］タブで，垂直方向から「上寄せ」を選択してください。

文字を縦書きに表示する場合，アイテム枠を縦長に変更すると文字は縦表示になりますが，アイテム枠に合わせて文字を自動改行して表示しているので，文字の描画方向まで変えることはできません。

文字を縦書きに表示するには，［アイテムのプロパティ］ダイアログの［文字配置］タブで描画方向を設定したあと，アイテム枠のサイズを変更してください。

（例）［文字の方向］とアイテム枠を組み合わせた場合の表示

［間隔］グループボックス

［バージョン2以前の文字配置を行う］のチェックボックスがオフの場合，文字間隔と行間隔を設定できます。

ただし，［桁数の指定］のチェックボックスをオンにすると，文字間隔の設定はできません。

［文字間隔］リストボックス

文字アイテムの文字と文字の間隔を選択します。文字間隔は，「標準」，「狭く」，および「広く」のどれかを選択します。「狭く」と「広く」を選択した場合は，文字間隔を設定できます。間隔は，［間隔］テキストボックスで指定します。デフォルトは「標準」です。

［間隔］テキストボックス

文字間隔を直接入力して指定します。デフォルトは，「0」です。

［文字間隔］リストボックスで「狭く」または「広く」のどちらを選択したかによって，指定できる範囲は次のように変わります。

「狭く」の場合：1～10ポイント

「広く」の場合：1～100ポイント

なお，文字間隔が狭い場合，指定した文字のサイズが文字間隔を超える（左右の文字が重なる）ようなサイズである場合は，文字を描画しません。また，出力プリンタによって，文字間隔を狭くした場合は，正しく印刷されないことがあります。

［行間隔］リストボックス

文字アイテムの行と行の間隔を選択します。行間隔は，「標準」，「狭く」，および「広く」のどれかを選択します。「狭く」と「広く」を選択した場合は行間隔を設定できます。間隔は，［間隔］のテキストボックスで変更します。デフォルトは，「標準」です。

［間隔］テキストボックス

行間隔を直接入力して指定します。デフォルトは，「0」です。

［行間隔］リストボックスで「狭く」または「広く」のどちらを選択したかによって，指定できる範囲は次のように変わります。

「狭く」の場合：1～10ポイント

「広く」の場合：1～100ポイント

なお，行間隔が狭い場合，指定した文字のサイズが行間を超える（上下の文字が重なる）ようなサイズである場合は，文字を描画しません。

［プレビュー］

文字間隔，文字の方向が設定されている場合，サンプルが表示されます。

［バージョン2以前の文字配置を行う］チェックボックス

文字アイテムを文字の描画位置で補正して配置するかどうかを選択します。選択した文字アイテムがバージョン2以前に作成した文字アイテムの場合，チェックボックスはオンになります。バージョン3以降で作成した文字アイテムの場合は，オフです。ただし，英語ロケールおよび中国語ロケールでは使用できません。

［ワードラップを行う］チェックボックスがオンになっている場合は選択できません。［フォント］タブの［フォント名］コンボボックスで可変ピッチフォント（プロポーショナルフォント）が選択されている場合，またはオプションの［表示］タブの［文字幅計算方法］グループボックスで［動的］ラジオボタンが選択されている場合は，選択しても無効となります。

バージョン2以前の文字配置を行うか行わないかの違いを次に示します。

バージョン2以前の文字配置を行う場合

UNIXの文字描画に合わせます。そのため，文字アイテムを文字の描画位置で補正して配置します。

バージョン2以前の文字配置を行わない場合

Windowsシステムやデバイスの文字描画に合わせます。そのため，文字アイテムを文字のフォント属性に従って描画します。

バージョン2以前の文字配置を行わない場合は，［間隔］と［文字の方向］の設定ができます。文字間隔と行間隔を，5ptずつ広くした例と狭くした例を次に示します。

なお，指定されているフォントによっては，［文字配置］を設定した帳票が実行する環境で正しく印刷されなかったり，表示されなかったりする場合があります。詳細は，マニュアル「EUR 帳票作成 操作ガイド」を参照してください。

ページの先頭へ

(2)　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 53 / 139


2.4.14 ［位置・サイズ］タブ : EUR 帳票作成 画面リファレンス

  • 54 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.4　［アイテムのプロパティ］ダイアログ

  • 2.4.14　［位置・サイズ］タブ

2.4.14　［位置・サイズ］タブ

選択したアイテムの位置，およびサイズを変更します。

［位置・サイズ］タブは，あらかじめ決められた位置にアイテムを配置したり，アイテムのサイズを直接変更したりする場合に便利です。［レポートのプロパティ］ダイアログの［レポートの構成］タブで，［アイテムをグリッド補正する］のチェックボックスがオンであっても，指定した位置に配置したり，変更したりできます。

複数アイテムを選択して，［位置・サイズ］タブを表示すると，［開始位置］，［サイズ］，および［丸め］は空白で表示されます。何も入力しない場合は，選択したアイテムの位置・サイズ・丸め半径は変わりません。［開始位置］，［サイズ］，および［丸め］に数値を入力すると，選択したすべてのアイテムが，入力した位置・サイズ・丸め半径に変更されるので注意してください。

帳票ウィンドウ上でアイテムの位置，およびサイズを微調整したい場合は，マウスで操作してください。ただし，マウスの操作で微調整する場合は，［レポートのプロパティ］ダイアログの［レポートの構成］タブで，［アイテムをグリッド補正する］のチェックボックスをオフにしておいてください。

［開始位置］，［サイズ］，および［丸め］は，［オプション］ダイアログの［表示］タブで設定されている「使用する単位」で表示されます。テキストボックスには，「使用する単位」と異なる単位で値を指定することもできます。異なる単位で値を指定する場合は，単位も入力してください。例えば，「使用する単位」に「ミリメートル（mm）」が設定されている場合，開始位置の［X］，［Y］のテキストボックスに「1in」を入力して［適用］または［OK］ボタンをクリックすると，それぞれ「25.4mm」の位置から表示されます。

〈この項の構成〉

  • (1)　［位置・サイズ］タブで設定できる項目

  • (2)　画面図

(1)　［位置・サイズ］タブで設定できる項目

［位置・サイズ］タブで設定できる項目を次に示します。

［開始位置］グループボックス

選択したアイテムの開始位置を設定します。

アイテムの座標原点が「用紙の左上」，または「貼付域の左上」のどちらの設定になっているかによって，アイテムの開始位置が異なります。

［X］リストボックス

選択したアイテムの開始位置，X座標値を指定します。

複数アイテムを選択すると，空白で表示されます。何も入力しない場合は，選択したアイテムのX座標値は変わりません。数値を入力すると，選択したすべてのアイテムが，入力したX座標値に変更されるので注意してください。

［Y］リストボックス

選択したアイテムの開始位置，Y座標値を指定します。

複数アイテムを選択すると，空白で表示されます。何も入力しない場合は，選択したアイテムのY座標値は変わりません。数値を入力すると，選択したすべてのアイテムが，入力したY座標値に変更されるので注意してください。

アイテムの開始位置に指定できる最小値と最大値は，座標原点の指定によって，次のように異なります。

［X］リストボックス，［Y］リストボックスに設定できる単位と各単位の最小有効桁数の詳細は，「2.17.1　［表示］タブ」の［使用する単位］リストボックスの説明を参照してください。

［サイズ］グループボックス

選択したアイテムのサイズを設定します。

アイテムのサイズに指定できる［幅］と［高さ］の最小値は，1ミリメートル（mm）です。インチ（in），ピクセル（px）の場合はミリメートル換算したときに1.00以上の値を最小値とします。最大値は，アイテムの開始位置から貼付域すべてです。

［幅］リストボックス

選択したアイテムの幅を指定します。横罫線を選択した場合は，［幅］の指定はできません。

複数アイテムを選択すると，空白で表示されます。何も入力しない場合は，選択したアイテムの幅は変わりません。数値を入力すると，選択したすべてのアイテムが，入力した幅に変更されるので注意してください。

［高さ］リストボックス

選択したアイテムの高さを指定します。縦罫線を選択した場合は，［高さ］の指定はできません。

複数アイテムを選択すると，空白で表示されます。何も入力しない場合は，選択したアイテムの高さは変わりません。数値を入力すると，選択したすべてのアイテムが，入力した高さに変更されるので注意してください。

［丸め］テキストボックス

選択した角丸四角アイテムの丸め半径を設定します。［丸め］のテキストボックスは，角丸四角アイテムを選択した場合に設定できます。また，アイテムは複数選択できます。選択したアイテムの中に角丸四角アイテムが一つもない場合は，［丸め］の指定はできません。複数アイテムのうち，角丸四角アイテムが一つだけの場合は，選択した角丸四角アイテムの丸め半径が表示されます。

複数アイテムを選択すると，空白で表示されます。何も入力しない場合は，選択したアイテムの丸めは変わりません。数値を入力すると，選択したすべてのアイテムが，入力した丸めに変更されるので注意してください。

丸め半径の最小値は0，最大値はアイテムの短辺の1/2です。

［開始位置］，［サイズ］，および［丸め］に設定する値の位置を，次に示します。

アイテムのサイズを変更すると，アイテム内の文字列がはみ出し，表示できない場合があります。文字列がアイテム内からはみ出る場合は，アイテム種別ごとに次のように表示されます。

表2‒12　文字列がアイテム枠内からはみ出す場合の表示形式

アイテム種別

表示形式

ページ番号アイテム

アイテム枠内に「***」と表示されます。高さに余裕がある場合は，複数行に折り曲げて表示されます。

印刷時刻アイテム

アイテム枠内に表示できる範囲だけ表示されます。高さに余裕がある場合は，複数行に折り曲げて表示されます。

印刷日付アイテム

文字アイテム

マッピングしたアイテム
データ種別が数値または数値（集計対象外）の場合

アイテム枠内に「***」と表示されます。高さに余裕がある場合は，複数行に折り曲げて表示されます。

データ種別が文字，日付・時刻，日次，月次，年次の場合

アイテム枠内に表示できる範囲だけ表示されます。高さに余裕がある場合は，複数行に折り曲げて表示されます。

データ種別がバーコードの場合

空白で表示されます。

ページの先頭へ

(2)　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 54 / 139


2.4.15 ［出力ページ］タブ : EUR 帳票作成 画面リファレンス

  • 55 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.4　［アイテムのプロパティ］ダイアログ

  • 2.4.15　［出力ページ］タブ

2.4.15　［出力ページ］タブ

選択したアイテムを，帳票のすべてのページに出力するか，または帳票の先頭ページ，もしくは最終ページだけに出力するかを設定します。

〈この項の構成〉

  • (1)　［出力ページ］タブで設定できる項目

  • (2)　画面図

(1)　［出力ページ］タブで設定できる項目

［出力ページ］タブで設定できる項目を次に示します。

出力するページの指定

選択したアイテムを出力するページを選択します。デフォルトは，「全てのページに出力する」です。

［全てのページに出力する］ラジオボタン

選択したアイテムを，すべてのページに出力します。

［先頭のページだけに出力する］ラジオボタン

選択したアイテムを，先頭ページだけに出力します。

先頭ページは，帳票が単一様式か複数様式かによって次のとおり意味が異なります。

  • 単一様式の帳票の場合

    すべてのデータが出力された最初のページ，または［レポートのプロパティ］ダイアログの［レポートの構成］タブにある［先頭・最終ページの範囲］グループボックスで定義した範囲の最初のページを指します。

  • 複数様式の帳票の場合

    すべてのデータが出力された最初のページ，または複数様式情報定義ファイルのキーワードresetpagenumberの設定によってページ番号を初期化したページ※を指します。

注※

環境変数EUR_RANGE_OF_FIRSTANDLASTPAGES_ON_MULTIFORM_BY_RESETPAGENUMBERでNOを指定した場合は，キーブレイクによって改ページされたページが先頭ページになります。

［最終ページだけに出力する］ラジオボタン

選択したアイテムを，最終ページだけに出力します。

最終ページは，帳票が単一様式か複数様式かによって次のとおり意味が異なります。

  • 単一様式の帳票の場合

    すべてのデータが出力された最終のページ，または［レポートのプロパティ］ダイアログの［レポートの構成］タブにある［先頭・最終ページの範囲］グループボックスで定義した範囲の最終のページを指します。集計ページがある場合は，集計ページの一つ前のページが最終ページです。

  • 複数様式の帳票の場合

    すべてのデータが出力された最終のページ，または複数様式情報定義ファイルのキーワードresetpagenumberの設定によってページ番号を初期化したページの一つ前のページ※を指します。

注※

環境変数EUR_RANGE_OF_FIRSTANDLASTPAGES_ON_MULTIFORM_BY_RESETPAGENUMBERでNOを指定した場合は，キーブレイクによって改ページされたページの一つ前のページが最終ページになります。

先頭ページ・最終ページの定義の詳細については，マニュアル「EUR 帳票作成 操作ガイド」を参照してください。

メモ

複数様式の帳票の場合，帳票設計時の改ページの設定ではページ番号を初期化するかどうかは有効になりません。キーワードresetpagenumberの設定だけが有効になります。

ページの先頭へ

(2)　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 55 / 139


2.4.16 ［置き換え表］タブ : EUR 帳票作成 画面リファレンス

  • 56 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.4　［アイテムのプロパティ］ダイアログ

  • 2.4.16　［置き換え表］タブ

2.4.16　［置き換え表］タブ

選択したアイテムを置き換え表のデータに置き換えて表示するように設定します。

置き換えを指定したアイテムでは［データ］タブの［項目の見出し名］リストボックスが操作できません。

置き換え表ファイルを読み込んだあと，置き換え表ファイルの内容を変更した場合は，置き換え表管理情報ファイルをもう一度読み込んでください。置き換え表管理情報ファイルの読み込みをしないと，変更したファイルの内容が正しく反映されません。置き換え表管理情報ファイルは［レポートのプロパティ］ダイアログの［置き換え表］タブで設定できます。

〈この項の構成〉

  • (1)　［置き換え表］タブで設定できる項目

  • (2)　画面図

(1)　［置き換え表］タブで設定できる項目

［置き換え表］タブで設定できる項目を次に示します。

［置き換えする］チェックボックス

置き換えて表示するかどうかを設定します。デフォルトは「オフ（置き換えて表示しない）」です。

チェックボックスを「オン（置き換えて表示する）」にすると，［アイテムのプロパティ］ダイアログの［表示形式］タブの「前付加文字」と「後付加文字」が設定できなくなります。チェックボックスをオフにすると，置き換えて表示する前の設定に戻ります。

［置き換え表］リストボックス

置き換えする表を指定します。リストボックスには，置き換え表管理情報ファイルで指定した置き換え表ファイルが一覧表示されています。置き換え表管理情報ファイルは［レポートのプロパティ］ダイアログの［置き換え表］タブで設定します。

ページの先頭へ

(2)　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 56 / 139


2.5 ［アイテムの表示条件］ダイアログ : EUR 帳票作成 画面リファレンス

  • 57 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.5　［アイテムの表示条件］ダイアログ

2.5　［アイテムの表示条件］ダイアログ

選択したアイテムに表示条件を設定するダイアログです。

〈この節の構成〉

  • 2.5.1　［アイテムの表示条件］ダイアログで設定できる項目

  • 2.5.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 57 / 139


2.5.1 ［アイテムの表示条件］ダイアログで設定できる項目 : EUR 帳票作成 画面リファレンス

  • 58 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.5　［アイテムの表示条件］ダイアログ

  • 2.5.1　［アイテムの表示条件］ダイアログで設定できる項目

2.5.1　［アイテムの表示条件］ダイアログで設定できる項目

［アイテムの表示条件］ダイアログで設定できる項目を次に示します。

［アイテムの表示条件を有効にする］チェックボックス

選択したアイテムの表示条件を有効にするかどうかを指定します。デフォルトは，「オフ（アイテムの表示条件を無効にする）」です。

このチェックボックスを「オン」にすると，［条件］グループボックスと［表示方法］グループボックスが活性となり，選択したアイテムに表示条件を設定できます。

［条件］グループボックス

アイテムの表示条件を設定します。

［参照フィールド］リストボックス

表示条件を設定するフィールドを指定します。指定できるデータとフィールドの種別を次に示します。

  • 指定できるデータの種別

    マッピングデータ，ユーザ定義データ

  • 指定できるフィールドの種別

    ［フィールド定義］ダイアログで定義したフィールド種別

リストボックスの項目は，「xxx（yyy）」と表示されます。xxxはフィールド名，yyyはデータの種別です。また，選択したアイテムが総集計アイテム，キー集計アイテム，またはページ集計アイテムの場合，これらの項目のほかに「集計値」が表示されます。集計値に表示条件を設定する場合は，参照フィールドに「集計値」を指定してください。

マッピングデータに表示条件を設定する場合，表示条件の参照フィールドにユーザ定義データのフィールドを指定できます。このとき，帳票出力のたびにユーザ定義データを切り替えることで，帳票出力ごとに異なる表示条件を動的に設定できます。

フィールド種別には，帳票で使用していないフィールド種別も指定できます。指定できるフィールド種別は，表2-13に示す参照フィールドの種別です。

［演算子］リストボックス

表示条件の演算子を指定します。指定できる演算子は，参照フィールドの種別によって異なります。参照フィールドの種別ごとの指定できる演算子を次に示します。

表2‒13　指定できる演算子

演算子

参照フィールドの種別

演算子の意味

文字列

数値

日付

和暦

集計対象

集計対象外

集計値

日付・時刻

日次

月次

年次

日次

月次

年次

次の文字列を含む

○

×

×

×

×

×

×

×

×

×

×

参照フィールドの値が指定値を含む

次の文字列から始まる

○

×

×

×

×

×

×

×

×

×

×

参照フィールドの値が指定値から始まる

次の文字列で終わる

○

×

×

×

×

×

×

×

×

×

×

参照フィールドの値が指定値で終わる

値あり

○

○

○

×

○

○

○

○

○

○

○

参照フィールドに値が存在する

値なし※

○

○

○

×

○

○

○

○

○

○

○

参照フィールドに値が存在しない

＞

×

○

○

○

○

○

○

○

○

○

○

参照フィールドの値が指定値より大きい

＜

×

○

○

○

○

○

○

○

○

○

○

参照フィールドの値が指定値より小さい

≧

×

○

○

○

○

○

○

○

○

○

○

参照フィールドの値が指定値以上

≦

×

○

○

○

○

○

○

○

○

○

○

参照フィールドの値が指定値以下

＝

○

○

○

○

○

○

○

○

○

○

○

参照フィールドの値と指定値が一致

≠

○

○

○

○

○

○

○

○

○

○

○

参照フィールドの値と指定値が不一致
（凡例）

○：指定できます。

×：指定できません。

注※

演算子「値なし」は次のどちらかの条件に当てはまる場合に成立します。

・参照フィールドが空データである。

・参照フィールドがない。

［指定値］テキストボックス

演算子に対応する指定値を直接指定します。指定できる文字は半角数字，半角符号，または「.（ピリオド）」です。ただし，［演算子］リストボックスに「値あり」もしくは「値なし」が選択されている場合，または［フィールドを参照する］チェックボックスが「オン」になっている場合は指定できません。［指定値］テキストボックスの入力形式を次に示します。

表2‒14　指定値の入力形式

参照フィールドの種別

入力形式

最小値

最大値

文字列

文字列

1文字

100文字

数値（集計対象）

整数または小数（15桁以内）

-999,999,999,999,999

999,999,999,999,999

数値（集計対象外）

数値（集計値）

日付（日付・時刻）

yyyy/mm/dd HH:MM:SS

0100/01/01 00:00:00

9999/12/31 23:59:59

日付（日次）

yyyymmdd

01000101

99991231

日付（月次）

yyyymm

010001

999912

日付（年次）

yyyy

0100

9999

和暦（日次）

gyymmdd

1010101

4991231

和暦（月次）

gyymm

10101

49912

和暦（年次）

gyy

101

499
（凡例）

yyyy：西暦年（0100～9999）を4桁で指定します。

g：元号を1桁の数値（1：明治，2：大正，3：昭和，4：平成）で指定します。

yy：元号年（01～99）を2桁で指定します。

mm：月（01～12）を2桁で指定します。

dd：日（01～31）を2桁で指定します。

HH：時間（00～23）を2桁で指定します。

MM：分（00～59）を2桁で指定します。

SS：秒（00～59）を2桁で指定します。

［フィールドを参照する］チェックボックス

参照フィールド全体とほかのフィールド全体を比較したい場合，このチェックボックスを「オン」にします。デフォルトは，「オフ（［指定値］テキストボックスで指定する）」です。

このチェックボックスを「オン」にすると，［フィールドを参照する］リストボックスが活性となり，［指定値］テキストボックスが非活性となります。

［フィールドを参照する］リストボックス

参照フィールドと比較したいフィールドを指定します。このリストボックスには，［参照フィールド］リストボックスで指定したフィールドと種別が同じフィールドだけが表示されます。ここでは，数値，数値（集計対象外），および集計値は，まとめて一つの種別として扱われます。

マッピングデータに表示条件を設定する場合，表示条件の参照フィールドにユーザ定義データのフィールドを指定できます。このとき，帳票出力のたびにユーザ定義データを切り替えることで，帳票出力ごとに異なる表示条件を動的に設定できます。

フィールド種別には，帳票で使用していないフィールド種別も指定できます。

［フィールドを参照する］リストボックスから指定できる参照フィールドの値の形式を次に示します。

表2‒15　参照フィールドの値の形式

参照フィールドの種別

入力形式

最小値

最大値

文字列

文字列

1文字

100文字

数値

整数または小数（15桁以内）

-999,999,999,999,999

999,999,999,999,999

数値（集計対象外）

数値（集計値）

日付（日付・時刻）

yyyy/mm/dd HH:MM:SS

0100/01/01 00:00:00

9999/12/31 23:59:59

日付（日次）

yyyymmdd

01000101

99991231

日付（月次）

yyyymm

010001

999912

日付（年次）

yyyy

0100

9999

和暦（日次）

gyymmdd

1010101

4991231

和暦（月次）

gyymm

10101

49912

和暦（年次）

gyy

101

499
（凡例）

yyyy：西暦年（0100～9999）を4桁で指定します。

g：元号を1桁の数値（1：明治，2：大正，3：昭和，4：平成）で指定します。

yy：元号年（01～99）を2桁で指定します。

mm：月（01～12）を2桁で指定します。

dd：日（01～31）を2桁で指定します。

HH：時間（00～23）を2桁で指定します。

MM：分（00～59）を2桁で指定します。

SS：秒（00～59）を2桁で指定します。

［範囲指定］チェックボックス

二つ目の表示条件を指定するための演算子と指定値を有効にします。デフォルトは，「オフ（二つ目の表示条件を無効にする）」です。

演算子1に「＞」，「≧」，「＜」，または「≦」を指定すると，［範囲指定］チェックボックスが活性となります。［範囲指定］チェックボックスを「オン」にすると，二つ目の［演算子］リストボックスおよび［指定値］テキストボックスが活性となります。演算子2に指定できる演算子は，演算子1によって異なります。

二つの演算子で設定できる表示条件を次に示します。

表2‒16　二つの演算子で設定できる表示条件

演算子1

演算子2

演算子の意味

＞

＜

参照フィールドの値が指定値1より大きい，かつ指定値2より小さい

≦

参照フィールドの値が指定値1より大きい，かつ指定値2以下

＜

＞

参照フィールドの値が指定値1より小さい，かつ指定値2より大きい

≧

参照フィールドの値が指定値1より小さい，かつ指定値2以上

≧

＜

参照フィールドの値が指定値1以上，かつ指定値2より小さい

≦

参照フィールドの値が指定値1以上，かつ指定値2以下

≦

＞

参照フィールドの値が指定値1以下，かつ指定値2より大きい

≧

参照フィールドの値が指定値1以下，かつ指定値2以上
［表示方法］グループボックス

条件付きアイテムの表示方法を設定します。

［表示する］ラジオボタン

このラジオボタンを「オン」にすると，参照フィールドのうち表示条件と一致するアイテムだけが表示され，表示条件と一致しないアイテムは表示されません。

［表示しない］ラジオボタン

このラジオボタンを「オン」にすると，参照フィールドのうち表示条件と一致しないアイテムだけが表示され，表示条件と一致するアイテムは表示されません。

なお，次に示す場合にも，表示条件と一致しないと見なされます。

  • 参照フィールドを指定していない場合

  • 演算子を指定していない場合

  • 演算子を指定して指定値を指定していない場合

  • 演算子の型が参照フィールドの型と一致していない場合

  • 指定値の型が参照フィールドの型と一致していない場合

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 58 / 139


2.5.2 画面図 : EUR 帳票作成 画面リファレンス

  • 59 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.5　［アイテムの表示条件］ダイアログ

  • 2.5.2　画面図

2.5.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 59 / 139


2.6 ［部品アイテムのプロパティ］ダイアログ : EUR 帳票作成 画面リファレンス

  • 60 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.6　［部品アイテムのプロパティ］ダイアログ

2.6　［部品アイテムのプロパティ］ダイアログ

アイテムのプロパティを設定するダイアログです。［アイテムのプロパティ］ダイアログは，次に示すタブが表示されます。

  • ［位置・サイズ］タブ

  • ［情報］タブ

〈この節の構成〉

  • 2.6.1　［位置・サイズ］タブ

  • 2.6.2　［情報］タブ

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 60 / 139


2.6.1 ［位置・サイズ］タブ : EUR 帳票作成 画面リファレンス

  • 61 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.6　［部品アイテムのプロパティ］ダイアログ

  • 2.6.1　［位置・サイズ］タブ

2.6.1　［位置・サイズ］タブ

選択された部品の位置とサイズが表示されます。

［常に指定位置に配置］チェックボックスがオフの場合だけ，部品のX座標値とY座標値が設定できます。

［常に指定位置に配置］チェックボックス，［基準位置］リストボックス，および［サイズ］グループボックスの編集はできません。設定を変更したい場合は，部品を登録し直してください。部品の登録についてはマニュアル「EUR 帳票作成 操作ガイド」を参照してください。

〈この項の構成〉

  • (1)　［位置・サイズ］タブで表示される項目

  • (2)　画面図

(1)　［位置・サイズ］タブで表示される項目

［位置・サイズ］タブに表示される項目を次に示します。

［開始位置］グループボックス

選択された部品の貼り付け位置が表示されます。

［常に指定位置に配置］チェックボックス

貼り付けられた部品が，常に指定された座標位置に配置されるかどうかを設定します。

チェックボックスがオンの場合は，部品は指定された座標位置に配置され，貼り付けたあとも移動できません。

チェックボックスがオフの場合は，部品は指定された座標位置に配置されますが，貼り付けたあとは任意の位置に移動できます。

［基準位置］リストボックス

部品を貼り付ける基準位置が表示されます。

［X］テキストボックス，［Y］テキストボックス

選択した部品のX座標値とY座標値が表示されます。［常に指定位置に配置］チェックボックスがオフの場合だけ編集できます。

［X］，［Y］の単位は，［オプション］ダイアログの［表示］タブで設定した単位です。テキストボックスには，表示された単位と異なる単位で値を指定することもできます。異なる単位で値を指定する場合は，単位も入力してください。例えば，「使用する単位」が「ミリメートル（mm）」で設定されている場合，［X］，［Y］テキストボックスにそれぞれ「1in」を入力して［OK］ボタンをクリックすると，X，Y座標値は「25.4mm」になります。設定できる単位と各単位の最小有効桁数の詳細は，「2.17.1　［表示］タブ」の［使用する単位］リストボックスの説明を参照してください。

入力できる値の範囲は基準位置によって変わります。基準位置ごとの入力できる値の範囲を次に示します。

基準位置

座標値

入力できる値

用紙左上

X座標値

左余白≦指定値≦用紙幅 - （部品の幅 + 右余白）

Y座標値

上余白≦指定値≦用紙高さ - （部品の高さ + 下余白）

用紙右上

X座標値

右余白≦指定値≦用紙幅 - （部品の幅 + 左余白）

Y座標値

上余白≦指定値≦用紙高さ - （部品の高さ + 下余白）

用紙左下

X座標値

左余白≦指定値≦用紙幅 - （部品の幅 + 右余白）

Y座標値

下余白≦指定値≦用紙高さ - （部品の高さ + 上余白）

用紙右下

X座標値

右余白≦指定値≦用紙幅 - （部品の幅 + 左余白）

Y座標値

下余白≦指定値≦用紙高さ - （部品の高さ + 上余白）
［サイズ］グループボックス

部品のサイズが表示されます。

［幅］テキストボックス，［高さ］テキストボックス

選択した部品の幅と高さが表示されます。単位は［オプション］ダイアログの［表示］タブで設定した単位です。

ページの先頭へ

(2)　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 61 / 139


2.6.2 ［情報］タブ : EUR 帳票作成 画面リファレンス

  • 62 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.6　［部品アイテムのプロパティ］ダイアログ

  • 2.6.2　［情報］タブ

2.6.2　［情報］タブ

選択された部品の情報が表示されます。

〈この項の構成〉

  • (1)　［情報］タブで表示する項目

  • (2)　画面図

(1)　［情報］タブで表示する項目

［情報］タブに表示される項目を次に示します。

［部品名］テキストボックス

選択した部品の部品名が表示されます。

部品名を変更したい場合は，部品パレットウィンドウで部品名を変更してください。部品名の変更については，マニュアル「EUR 帳票作成 操作ガイド」を参照してください。

［部品ID］テキストボックス

選択した部品の部品IDが表示されます。

［コメント］テキストボックス

選択した部品のコメントが表示されます。

ページの先頭へ

(2)　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 62 / 139


2.7 ［ツールバー］ダイアログ : EUR 帳票作成 画面リファレンス

  • 63 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.7　［ツールバー］ダイアログ

2.7　［ツールバー］ダイアログ

レポート編集ウィンドウで表示する，ツールバーとツールボックスの表示／非表示を切り替えるダイアログです。

〈この節の構成〉

  • 2.7.1　［ツールバー］ダイアログで設定できる項目

  • 2.7.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 63 / 139


2.7.1 ［ツールバー］ダイアログで設定できる項目 : EUR 帳票作成 画面リファレンス

  • 64 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.7　［ツールバー］ダイアログ

  • 2.7.1　［ツールバー］ダイアログで設定できる項目

2.7.1　［ツールバー］ダイアログで設定できる項目

［ツールバー］ダイアログで設定できる項目を次に示します。

［標準］チェックボックス

標準ツールバーを表示するかどうかを設定します。チェックボックスをオンにすると，標準ツールバーを表示します。デフォルトは，「オン（表示する）」です。

［挿入］チェックボックス

挿入ツールバーを表示するかどうかを設定します。チェックボックスをオンにすると，挿入ツールバーを表示します。デフォルトは，「オン（表示する）」です。

［ウィンドウ］チェックボックス

ウィンドウツールバーを表示するかどうかを設定します。チェックボックスをオンにすると，ウィンドウツールバーを表示します。デフォルトは，「オン（表示する）」です。

［揃え］チェックボックス

揃えツールバーを表示するかどうかを設定します。チェックボックスをオンにすると，揃えツールバーを表示します。デフォルトは，「オン（表示する）」です。

［ページ］チェックボックス

ページツールバーを表示するかどうかを設定します。チェックボックスをオンにすると，ページツールバーを表示します。デフォルトは，「オン（表示する）」です。

［ツールボックス］チェックボックス

ツールボックスを表示するかどうかを設定します。チェックボックスをオンにすると，ツールボックスを表示します。デフォルトは，「オン（表示する）」です。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 64 / 139


2.7.2 画面図 : EUR 帳票作成 画面リファレンス

  • 65 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.7　［ツールバー］ダイアログ

  • 2.7.2　画面図

2.7.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 65 / 139


2.8 ［ズーム］ダイアログ : EUR 帳票作成 画面リファレンス

  • 66 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.8　［ズーム］ダイアログ

2.8　［ズーム］ダイアログ

帳票の表示倍率を変更するダイアログです。

〈この節の構成〉

  • 2.8.1　［ズーム］ダイアログで設定できる項目

  • 2.8.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 66 / 139


2.8.1 ［ズーム］ダイアログで設定できる項目 : EUR 帳票作成 画面リファレンス

  • 67 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.8　［ズーム］ダイアログ

  • 2.8.1　［ズーム］ダイアログで設定できる項目

2.8.1　［ズーム］ダイアログで設定できる項目

［ズーム］ダイアログで設定できる項目を次に示します。

表示倍率ラジオボタン

帳票の表示倍率を指定します。

［800%］ラジオボタン：帳票を800%の倍率で表示します。

［400%］ラジオボタン：帳票を400%の倍率で表示します。

［200%］ラジオボタン：帳票を200%の倍率で表示します。

［150%］ラジオボタン：帳票を150%の倍率で表示します。

［100%］ラジオボタン：帳票を100%の倍率で表示します。

［75%］ラジオボタン：帳票を75%の倍率で表示します。

［50%］ラジオボタン：帳票を50%の倍率で表示します。

［10%］ラジオボタン：帳票を10%の倍率で表示します。

［ページ全体を表示］ラジオボタン

帳票ウィンドウの大きさに合わせて帳票全体を表示します。表示されている帳票ウィンドウに対してだけ有効です。ただし，表示されている帳票ウィンドウが帳票の10%より小さい場合，帳票を10%の倍率で表示します。

［指定］スピンボックス

任意の表示倍率を設定します。表示倍率は，テキストボックスに直接入力するか，またはアップダウンコントロールをクリックして設定します。設定できる値は，10～800です。800，400，200，150，100，75，50，または10の値を設定した場合は，該当するラジオボタンが選択状態になります。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 67 / 139


2.8.2 画面図 : EUR 帳票作成 画面リファレンス

  • 68 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.8　［ズーム］ダイアログ

  • 2.8.2　画面図

2.8.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 68 / 139


2.9 ［ページ番号］ダイアログ : EUR 帳票作成 画面リファレンス

  • 69 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.9　［ページ番号］ダイアログ

2.9　［ページ番号］ダイアログ

ページ番号アイテムを作成するダイアログです。

〈この節の構成〉

  • 2.9.1　［ページ番号］ダイアログで設定できる項目

  • 2.9.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 69 / 139


2.9.1 ［ページ番号］ダイアログで設定できる項目 : EUR 帳票作成 画面リファレンス

  • 70 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.9　［ページ番号］ダイアログ

  • 2.9.1　［ページ番号］ダイアログで設定できる項目

2.9.1　［ページ番号］ダイアログで設定できる項目

［ページ番号］ダイアログで設定できる項目を次に示します。

［表示形式］リストボックス

帳票に貼り付けるページ番号の形式を選択します。［OK］ボタンをクリックすると，レポート編集ウィンドウ上のポインタの形が [図データ] に変わります。ページ番号を貼り付ける位置でクリックしてください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 70 / 139


2.9.2 画面図 : EUR 帳票作成 画面リファレンス

  • 71 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.9　［ページ番号］ダイアログ

  • 2.9.2　画面図

2.9.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 71 / 139


2.10 ［印刷日付］ダイアログ : EUR 帳票作成 画面リファレンス

  • 72 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.10　［印刷日付］ダイアログ

2.10　［印刷日付］ダイアログ

印刷日付アイテムを作成するダイアログです。

〈この節の構成〉

  • 2.10.1　［印刷日付］ダイアログで設定できる項目

  • 2.10.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 72 / 139


2.10.1 ［印刷日付］ダイアログで設定できる項目 : EUR 帳票作成 画面リファレンス

  • 73 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.10　［印刷日付］ダイアログ

  • 2.10.1　［印刷日付］ダイアログで設定できる項目

2.10.1　［印刷日付］ダイアログで設定できる項目

［印刷日付］ダイアログで設定できる項目を次に示します。

［表示形式］リストボックス

帳票に貼り付ける日付の形式を選択します。［OK］ボタンをクリックすると，レポート編集ウィンドウ上のポインタの形が [図データ] に変わります。印刷日付を貼り付ける位置でクリックしてください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 73 / 139


2.10.2 画面図 : EUR 帳票作成 画面リファレンス

  • 74 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.10　［印刷日付］ダイアログ

  • 2.10.2　画面図

2.10.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 74 / 139


2.11 ［印刷時刻］ダイアログ : EUR 帳票作成 画面リファレンス

  • 75 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.11　［印刷時刻］ダイアログ

2.11　［印刷時刻］ダイアログ

印刷時刻アイテムを作成するダイアログです。

〈この節の構成〉

  • 2.11.1　［印刷時刻］ダイアログで設定できる項目

  • 2.11.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 75 / 139


2.11.1 ［印刷時刻］ダイアログで設定できる項目 : EUR 帳票作成 画面リファレンス

  • 76 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.11　［印刷時刻］ダイアログ

  • 2.11.1　［印刷時刻］ダイアログで設定できる項目

2.11.1　［印刷時刻］ダイアログで設定できる項目

［印刷時刻］ダイアログで設定できる項目を次に示します。

［表示形式］リストボックス

帳票に貼り付ける時刻の形式を選択します。［OK］ボタンをクリックすると，レポート編集ウィンドウ上のポインタの形が [図データ] に変わります。印刷時刻を貼り付ける位置でクリックしてください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 76 / 139


2.11.2 画面図 : EUR 帳票作成 画面リファレンス

  • 77 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.11　［印刷時刻］ダイアログ

  • 2.11.2　画面図

2.11.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 77 / 139


2.12 ［繰り返し個数指定］ダイアログ : EUR 帳票作成 画面リファレンス

  • 78 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.12　［繰り返し個数指定］ダイアログ

2.12　［繰り返し個数指定］ダイアログ

縦，横の繰り返しの個数を設定するダイアログです。

繰り返しの［縦位置］または［横位置］のどちらか一方を設定している場合，設定されていない方向の［任意指定］ボタンは選択できない状態になります。

〈この節の構成〉

  • 2.12.1　［繰り返し個数指定］ダイアログで設定できる項目

  • 2.12.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 78 / 139


2.12.1 ［繰り返し個数指定］ダイアログで設定できる項目 : EUR 帳票作成 画面リファレンス

  • 79 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.12　［繰り返し個数指定］ダイアログ

  • 2.12.1　［繰り返し個数指定］ダイアログで設定できる項目

2.12.1　［繰り返し個数指定］ダイアログで設定できる項目

［繰り返し個数指定］ダイアログで設定できる項目を次に示します。

［縦個数の設定］グループボックス
［設定できる最大個数］

自動設定時の最大繰り返し個数が表示されます。用紙サイズを変更すると，［設定できる最大個数］が変わります。

［自動設定］ラジオボタン

縦の繰り返し個数を自動設定します。自動設定時の最大繰り返し個数は，［設定できる最大個数］に表示されます。

［任意指定］ラジオボタン

縦の繰り返し個数を任意に設定します。繰り返し個数は，［個数］テキストボックスで設定します。

［個数］テキストボックス

縦の繰り返し個数を設定します。設定できる値は，［設定できる最大個数］以下の数値です。デフォルトは，［設定できる最大個数］です。

［横個数の設定］グループボックス
［設定できる最大個数］

自動設定時の最大繰り返し個数が表示されます。用紙サイズを変更すると，［設定できる最大個数］が変わります。

［自動設定］ラジオボタン

横の繰り返し個数を自動設定します。自動設定時の最大繰り返し個数は，［設定できる最大個数］に表示されています。

［任意設定］ラジオボタン

横の繰り返し個数を任意に設定します。繰り返し個数は，［個数］テキストボックスで設定します。

［個数］テキストボックス

横の繰り返し個数を設定します。設定できる値は，［設定できる最大個数］以下の数値です。デフォルトは，［設定できる最大個数］です。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 79 / 139


2.12.2 画面図 : EUR 帳票作成 画面リファレンス

  • 80 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.12　［繰り返し個数指定］ダイアログ

  • 2.12.2　画面図

2.12.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 80 / 139


2.13 ［まとめ表示］ダイアログ : EUR 帳票作成 画面リファレンス

  • 81 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.13　［まとめ表示］ダイアログ

2.13　［まとめ表示］ダイアログ

同一データのまとめ表示を一括して設定するダイアログです。

〈この節の構成〉

  • 2.13.1　［まとめ表示］ダイアログで設定できる項目

  • 2.13.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 81 / 139


2.13.1 ［まとめ表示］ダイアログで設定できる項目 : EUR 帳票作成 画面リファレンス

  • 82 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.13　［まとめ表示］ダイアログ

  • 2.13.1　［まとめ表示］ダイアログで設定できる項目

2.13.1　［まとめ表示］ダイアログで設定できる項目

［繰り返しアイテム一覧］リストボックス

繰り返しを設定しているフィールドのうち，まとめ表示を設定していないものが表示されます。

まとめ表示を設定するフィールドを選択して，［階層あり］リストボックスの横の［＞］ボタンをクリックすると，［階層あり］リストボックスに表示されます。同様に［階層なし］リストボックスの横の［＞］ボタンをクリックすると，［階層なし］リストボックスに表示されます。

［繰り返しアイテム一覧］リストボックスは，フィールドの種別によって次の形式で表示されます。

フィールドの種別

表示形式

マッピングデータ

マッピングデータ：フィールド名

ユーザ定義データ

ユーザ定義データ：フィールド名

文字アイテム（固定文字列）

固定文字アイテム：設定されている固定文字列※

ページ番号

ページ番号アイテム

印刷日付

印刷日付アイテム

印刷時刻

印刷時刻アイテム

集計アイテム

集計内容によって異なる

  • 件数の場合

    集計アイテム：総集計－件数

  • 合計の場合

    集計アイテム：総集計－合計

  • 平均の場合

    集計アイテム：総集計－平均

  • 最大の場合

    集計アイテム：総集計－最大

  • 最小の場合

    集計アイテム：総集計－最小

（凡例）　斜体：可変値であることを示します。

注※

文字列が複数行ある場合は，1行目だけが表示されます。

［階層あり］リストボックス

優先順位の高い順にデータの階層を作成してまとめを表示するフィールドが表示されます。フィールドを選択して［▲］ボタンまたは［▼］ボタンをクリックすると，優先順位を変更できます。［∨］ボタンをクリックすると，［階層なし］リストボックスに移動します。

［階層なし］リストボックス

階層を作成しないで，同じデータが連続している個所をまとめ表示をするフィールドが表示されます。［∧］ボタンをクリックすると，［階層あり］リストボックスに移動します。

［まとめ表示するアイテムの属性］グループボックス

まとめ表示をした部分に設定されている罫線を一緒にまとめて表示するか，罫線はまとめないで表示するかを設定します。［階層あり］リストボックスまたは［階層なし］リストボックスで選択されたフィールドに対して設定できます。

［罫線もまとめる］チェックボックスをオンにすると，まとめ表示をした部分に設定されている罫線を一緒にまとめて表示します。

［階層あり］リストボックスまたは［階層なし］リストボックスでフィールドが選択されていない場合，［罫線もまとめる］チェックボックスは不活性になります。

［集計行で分断しない］チェックボックス

表の中に集計行がある場合，集計行を分断して表示するかどうかを指定します。

チェックボックスをオンにすると，集計行を分断しないで表示されます。

［1行目が集計行のとき，まとめデータを表示する］チェックボックス

表の中の集計行を分断しないで表示する場合，ページの先頭行が集計行になったときに，まとめ表示を設定したフィールドを表示するかどうかを指定します。

［集計行で分断しない］チェックボックスがオンの場合だけ指定できます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 82 / 139


2.13.2 画面図 : EUR 帳票作成 画面リファレンス

  • 83 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.13　［まとめ表示］ダイアログ

  • 2.13.2　画面図

2.13.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 83 / 139


2.14 ［改ブロック／改ページ一覧］ダイアログ : EUR 帳票作成 画面リファレンス

  • 84 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.14　［改ブロック／改ページ一覧］ダイアログ

2.14　［改ブロック／改ページ一覧］ダイアログ

改ブロックと改ページのキーフィールドの設定内容が表示されます。

［改ブロック／改ページ一覧］ダイアログには，マッピングデータウィンドウのすべてのフィールド名と，改ブロックと改ページのキーフィールドの設定内容を一覧にして表示するので，設定内容を確認するのに便利です。また，改ブロックと改ページの設定は，［繰り返し］メニューから設定できますが，［改ブロック／改ページ一覧］ダイアログからも，改ブロックや改ページのキーフィールドを設定したり，変更したりすることもできます。

〈この節の構成〉

  • 2.14.1　［改ブロック／改ページ一覧］ダイアログで設定できる項目

  • 2.14.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 84 / 139


2.14.1 ［改ブロック／改ページ一覧］ダイアログで設定できる項目 : EUR 帳票作成 画面リファレンス

  • 85 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.14　［改ブロック／改ページ一覧］ダイアログ

  • 2.14.1　［改ブロック／改ページ一覧］ダイアログで設定できる項目

2.14.1　［改ブロック／改ページ一覧］ダイアログで設定できる項目

［改ブロック／改ページ一覧］ダイアログで設定できる項目を次に示します。

［フィールド一覧］リストボックス

マッピングデータウィンドウのすべてのフィールド名と，改ブロックと改ページのキーフィールドの設定内容が一覧で表示されます。表示形式を次に示します。

表示形式

内　　容

［改ブロック］：フィールド名

改ブロックが設定されているキーフィールドです。

［改ページ（初期化あり）］：フィールド名

改ページが設定されているキーフィールドです。ページ番号を初期化します。

［改ページ（初期化なし）］：フィールド名

改ページが設定されているキーフィールドです。ページ番号を初期化しません。

［（空白）］：フィールド名

改ブロック／改ページの設定がありません。

［フィールド一覧］からキーになるフィールドを選択したあと，［設定］のグループボックスから設定内容を選択します。

［設定］グループボックス

［フィールド一覧］からキーになるフィールドを選択していない場合は，設定できません。

［設定なし］ラジオボタン

選択したフィールドの改ブロック，または改ページの設定を解除します。

［改ブロック］ラジオボタン

選択したフィールドをキーにして，改ブロックします。

［改ページ〔ページ番号初期化あり〕］ラジオボタン

選択したフィールドをキーにして，改ページします。帳票にページ番号が設定されている場合は，改ページごとにページ番号を初期化して表示します。ページ番号の初期化の指定は，［ファイル］メニューの［プロパティ］を選択して表示される，［レポートのプロパティ］ダイアログの［レポートの構成］タブで設定します。

［改ページ〔ページ番号初期化なし〕］ラジオボタン

選択したフィールドをキーにして，改ページします。帳票にページ番号が設定されている場合は，通し番号でページ番号を表示します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 85 / 139


2.14.2 画面図 : EUR 帳票作成 画面リファレンス

  • 86 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.14　［改ブロック／改ページ一覧］ダイアログ

  • 2.14.2　画面図

2.14.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 86 / 139


2.15 ［繰り返し設定］ダイアログ : EUR 帳票作成 画面リファレンス

  • 87 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.15　［繰り返し設定］ダイアログ

2.15　［繰り返し設定］ダイアログ

繰り返し情報（繰り返しの縦位置・横位置，繰り返し個数，および繰り返しの優先方向）を設定するダイアログです。既存の帳票と同じように作成するなど，繰り返す情報がすでに決まっている場合，［繰り返し設定］ダイアログに繰り返し情報を設定することでスピーディに表が作成できます。

帳票ファイル上で繰り返し情報の調整が必要な場合は，それぞれの操作をメニューから行ってください。［繰り返し設定］ダイアログで設定した情報は，メニューから設定した情報と同じです。そのため，メニューから繰り返し情報が設定されている場合は，［繰り返し設定］ダイアログを表示したとき，その設定内容が表示されます。また，［繰り返し設定］ダイアログで設定した情報は，メニューからも解除できます。

〈この節の構成〉

  • 2.15.1　［繰り返し設定］ダイアログで設定できる項目

  • 2.15.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 87 / 139


2.15.1 ［繰り返し設定］ダイアログで設定できる項目 : EUR 帳票作成 画面リファレンス

  • 88 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.15　［繰り返し設定］ダイアログ

  • 2.15.1　［繰り返し設定］ダイアログで設定できる項目

2.15.1　［繰り返し設定］ダイアログで設定できる項目

［繰り返し設定］ダイアログで設定できる項目を次に示します。

［繰り返し種別］グループボックス

繰り返しの種別を設定します。デフォルトは，「（1ページ1レコードの）単一」です。

［繰り返し種別］のグループボックスから，「縦方向」と「縦方向優先」を選択した場合は，［繰り返し］メニューの［優先方向］－［縦方向］に「・」印が付きます。また，「横方向」と「横方向優先」を選択した場合は，［繰り返し］メニューの［優先方向］－［横方向］に「・」印が付きます。

［繰り返し種別］のグループボックスから選択した種別によって，［縦繰り返し］と［横繰り返し］のグループボックスで設定できる状態が変わります。

表2‒17　設定できる繰り返し方法

繰り返し方向

単一

縦方向

横方向

縦方向優先

横方向優先

縦繰り返し

×

○

×

○

○

横繰り返し

×

×

○

○

○
（凡例）

○：設定できます。

×：設定できません。

［縦繰り返し］グループボックス

縦方向の繰り返し間隔と繰り返し個数を設定します。

［間隔］ラジオボタン

縦方向の繰り返し間隔をミリメートル（mm），インチ（in），またはピクセル（px）で指定します。値はテキストボックスに指定します。

間隔に指定できる値の最小値は，1ミリメートル（mm）です。インチ（in），ピクセル（px）の場合はミリメートルに換算したとき1.00以上の値を最小値とします。

最大値は，繰り返し対象のアイテムを最低1回繰り返せる値です。最大値の算出例を次に示します。

  • （例）

    用紙サイズの長さ：297（mm）

    アイテムの座標位置のY座標：20（mm）

    余白：上下10（mm）

    アイテムの高さ：5（mm）

    最大値=297-20-10×2-5=252（mm）

設定できる単位と各単位の最小有効桁数の詳細は，「2.17.1　［表示］タブ」の［使用する単位］リストボックスの説明を参照してください。

［LPI］ラジオボタン

縦方向の繰り返し間隔をLPIで指定するとき，1行の高さと繰り返す行数を指定します。値は［LPI］テキストボックスと［行ごと］テキストボックスに指定します。例えば，［LPI］テキストボックスに「6」，［行ごと］テキストボックスに「4」と記入したとき，繰り返し間隔は4/6インチとなります。

［LPI］テキストボックスの値の最小値は0.13（LPI），最大値は24（LPI）です。

［行ごと］テキストボックスの値の最小値は1（行），最大値は99（行）です。

なお，「［LPI］テキストボックスの値×［行ごと］テキストボックスの値」は繰り返し対象のアイテムを最低1回繰り返せる範囲内に設定してください。

［繰り返し個数を設定］チェックボックス

縦の繰り返し個数を任意に設定するかどうかを設定します。デフォルトは，「オフ（繰り返し個数を設定しない）」です。

繰り返し個数を設定しない場合は，現在表示されている帳票の縦方向に繰り返しできる最大個数で繰り返されます。繰り返し最大個数は，［繰り返し個数を設定］のチェックボックスがオフの場合，［個数］のテキストボックスに薄く表示されています。

［繰り返し個数を設定］のチェックボックスをオンにすると，［個数］テキストボックスが入力できます。

［個数］テキストボックス

縦の繰り返し個数を設定します。個数は，1～現在表示されている帳票の繰り返し最大個数を整数値で設定します。デフォルトは，現在の帳票の繰り返し指定状態に従います。

［横繰り返し］グループボックス

横方向の繰り返し間隔と繰り返し個数を設定します。

［間隔］テキストボックス

横方向の繰り返し間隔を指定します。間隔に指定できる値の最小値は，1ミリメートル（mm）です。インチ（in），ピクセル（px）の場合はミリメートル換算したときに1.00以上の値を最小値とします。最大値は，繰り返し対象のアイテムを最低1回は繰り返せる値です。最大値の算出例を次に示します。

  • （例）

    用紙サイズの幅：210（mm）

    アイテムの座標位置のX座標：20（mm）

    余白：左右10（mm）

    アイテムの幅：5（mm）

    最大値=210-20-10×2-5=165（mm）

設定できる単位と各単位の最小有効桁数の詳細は，「2.17.1　［表示］タブ」の［使用する単位］リストボックスの説明を参照してください。

［繰り返し個数を設定］チェックボックス

横の繰り返し個数を任意に設定するかどうかを設定します。デフォルトは，「オフ（繰り返し個数を設定しない）」です。

繰り返し個数を設定しない場合は，現在表示されている帳票の横方向に繰り返しできる最大個数で繰り返されます。繰り返し最大個数は，［繰り返し個数を設定］のチェックボックスがオフの場合，［個数］のテキストボックスに薄く表示されています。

［繰り返し個数を設定］のチェックボックスをオンにすると，［個数］テキストボックスが入力できます。

［個数］テキストボックス

横の繰り返し個数を設定します。個数は，1～現在表示されている帳票の繰り返し最大個数を整数値で設定します。デフォルトは，現在の帳票の繰り返し指定状態に従います。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 88 / 139


2.15.2 画面図 : EUR 帳票作成 画面リファレンス

  • 89 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.15　［繰り返し設定］ダイアログ

  • 2.15.2　画面図

2.15.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 89 / 139


2.16 ［集計アイテム］ダイアログ : EUR 帳票作成 画面リファレンス

  • 90 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.16　［集計アイテム］ダイアログ

2.16　［集計アイテム］ダイアログ

集計アイテムを設定するダイアログです。

〈この節の構成〉

  • 2.16.1　［集計アイテム］ダイアログで設定できる項目

  • 2.16.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 90 / 139


2.16.1 ［集計アイテム］ダイアログで設定できる項目 : EUR 帳票作成 画面リファレンス

  • 91 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.16　［集計アイテム］ダイアログ

  • 2.16.1　［集計アイテム］ダイアログで設定できる項目

2.16.1　［集計アイテム］ダイアログで設定できる項目

［集計アイテム］ダイアログで設定できる項目を次に示します。

［集計種別］リストボックス

集計種別を設定します。集計種別は，集計アイテムが作成できる場所によって表示が異なります。

帳票ヘッダ集計

帳票ヘッダ領域が設定されている帳票に設定できます。帳票ヘッダ集計は，帳票ヘッダ領域から次の帳票ヘッダ領域までの集計結果を，帳票のどこにでも貼り付けられます。ただし，集計行には貼り付けられません。

キー集計

キー集計が設定されている帳票に設定できます。キー集計は，集計行編集モードでしか設定できません。

総集計

帳票のどこにでも，通常の編集，および集計行編集モードで設定できます。

フィールドのデータ

キー集計が設定されている帳票の集計行に，［集計対象フィールド］リストボックスに表示されているフィールドを貼り付けられます。フィールドのデータは，集計行編集モードでしか設定できません。

［集計内容］リストボックス

合計，平均，最大，最小，および件数の中から選択します。［集計種別］リストボックスで「フィールドのデータ」を選択した場合，［集計内容］リストボックスは不活性になります。

［集計対象フィールド］リストボックス

［集計種別］リストボックスで選択した集計種別によって，［集計対象フィールド］に表示されるフィールドは異なります。

  • 「総集計」，「キー集計」，または「帳票ヘッダ集計」の場合

    マッピングデータウィンドウの，すべての数値フィールドが表示されます。集計対象フィールドを一つ選択します。

  • 「フィールドのデータ」の場合

    マッピングデータウィンドウの特殊編集レベル，画像，およびバーコードフィールドを除く，すべてのフィールドが表示されます。貼り付け対象フィールドを一つ選択します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 91 / 139


2.16.2 画面図 : EUR 帳票作成 画面リファレンス

  • 92 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.16　［集計アイテム］ダイアログ

  • 2.16.2　画面図

2.16.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 92 / 139


2.17 ［オプション］ダイアログ : EUR 帳票作成 画面リファレンス

  • 93 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.17　［オプション］ダイアログ

2.17　［オプション］ダイアログ

［オプション］ダイアログでは，次に示すタブを表示します。

  • ［表示］タブ

  • ［配置］タブ

  • ［文字］タブ

  • ［線］タブ

  • ［図形］タブ

  • ［画像］タブ

  • ［バーコード］タブ

  • ［ファイル］タブ

  • ［文字配置］タブ

  • ［データウィンドウ］タブ

このダイアログで設定したオプションは，次回EURを起動した場合も有効です。

〈この節の構成〉

  • 2.17.1　［表示］タブ

  • 2.17.2　［配置］タブ

  • 2.17.3　［文字］タブ

  • 2.17.4　［線］タブ

  • 2.17.5　［図形］タブ

  • 2.17.6　［画像］タブ

  • 2.17.7　［バーコード］タブ

  • 2.17.8　［ファイル］タブ

  • 2.17.9　［文字配置］タブ

  • 2.17.10　［データウィンドウ］タブ

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 93 / 139


2.17.1 ［表示］タブ : EUR 帳票作成 画面リファレンス

  • 94 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.17　［オプション］ダイアログ

  • 2.17.1　［表示］タブ

2.17.1　［表示］タブ

表示オプションを設定します。設定した内容は，レポート編集ウィンドウの表示形態のデフォルトになります。

〈この項の構成〉

  • (1)　［表示］タブで設定できる項目

  • (2)　画面図

(1)　［表示］タブで設定できる項目

［表示］タブで設定できる項目を次に示します。

［ウィンドウ］グループボックス

レポート編集ウィンドウに，ステータスバーを表示するかどうかを設定します。

［ステータスバー］チェックボックス

ステータスバーを表示するかどうかを設定します。デフォルトは，「オン（表示する）」です。

［表示項目の設定］グループボックス

帳票の編集中に，画像データを表示するかどうかを設定します。レポート確認ウィンドウでは，設定できません。

［編集中に画像を表示する］チェックボックス

帳票の編集中に，画像データを表示するかどうかを設定します。デフォルトは，「オン（表示する）」です。チェックボックスをオフ（表示しない）にすると，画像アイテムの枠だけが表示されるので，帳票の表示時間が早くなります。

［位置・サイズ］グループボックス

帳票ウィンドウ上のアイテムの座標原点と，使用する単位を設定します。

［座標の原点］リストボックス

アイテムの座標原点を，「用紙の左上」にするか，または「貼付域の左上」にするかを設定します。

デフォルトは，「用紙の左上」です。そのため，バージョン3以前に設計した帳票を開いた場合は，アイテムの開始位置が異なります。バージョン3以前と同じようにアイテムの開始位置を表示したい場合は，アイテムの座標原点を「貼付域の左上」に設定してください。

なお，アイテムの座標原点が「用紙の左上」，または「貼付域の左上」のどちらに設定されているのかは，ルーラ，およびステータスバーに表示されます。

［使用する単位］リストボックス

グリッド間隔，用紙サイズ，用紙の余白，ルーラ，およびステータスバーの座標位置で使用される単位を設定します。デフォルトは，「ミリメートル（mm）」です。

設定できる単位と各単位の最小有効桁数を，次に示します。

表2‒18　帳票設計で設定できる単位と各単位の最小有効桁数

単位

単位記号

最小有効桁数

ミリメートル

mm

小数点以下第2位

インチ

in

ピクセル

px

整数（小数点以下切り捨て）

「ピクセル」を設定した場合は，［解像度の指定］ダイアログが表示されます。

［解像度の指定］ダイアログでは，使用する解像度を入力してください。指定できる値は，10dpi ≦ n ≦ 999dpiです。「ピクセル」での値の指定は，ここで指定した解像度を基に処理されます。デフォルトは，「148dpi」です。

［文字幅計算方法］グループボックス

帳票を出力するときの固定ピッチフォントの文字幅計算方法を設定します。デフォルトは「静的（フォントの文字幅を固定値として計算する）」です。ただし，可変ピッチフォント（プロポーショナルフォント）の場合は，［静的］と［動的］のどちらを選択しても，使用するフォントに合わせて文字幅を計算します（「動的モード」といいます）。

［静的］ラジオボタン

固定ピッチフォントの文字幅を，固定値として計算します（「静的モード」といいます）。半角の場合はアイテムのフォント幅，全角の場合はアイテムのフォント幅の2倍で計算します。

［動的］ラジオボタン

固定ピッチフォントの文字幅を，使用するフォントに合わせて計算します（動的モード）。

ページの先頭へ

(2)　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 94 / 139


2.17.2 ［配置］タブ : EUR 帳票作成 画面リファレンス

  • 95 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.17　［オプション］ダイアログ

  • 2.17.2　［配置］タブ

2.17.2　［配置］タブ

配置オプションを設定します。設定した内容は，帳票を新規に作成するときのデフォルトになります。

〈この項の構成〉

  • (1)　［配置］タブで設定できる項目

  • (2)　画面図

(1)　［配置］タブで設定できる項目

［配置］タブで設定できる項目を次に示します。

［グリッド］グループボックス

グリッドの間隔，原点を設定します。

グリッドの属性値を［間隔］ラジオボタンのテキストボックスで設定する場合，属性値は［オプション］ダイアログの［表示］タブで設定されている「使用する単位」で表示されます。テキストボックスには，「使用する単位」と異なる単位で値を設定することもできます。例えば，［オプション］ダイアログの［表示］タブで「使用する単位」に「ミリメートル（mm）」が設定されている場合，［高さ］のテキストボックスに「1in」を入力して［適用］または［OK］ボタンをクリックすると，「25.4mm」の高さで表示されます。

［幅］グループボックス

グリッドの横の間隔を設定します。デフォルトでは［間隔］ラジオボタンが選択されています。

  • ［間隔］ラジオボタン

    グリッドの横の間隔を，ミリメートル（mm），インチ（in）またはピクセル（px）で指定するときに選択します。指定できる値は，1（mm）～200（mm）です。インチ（in），ピクセル（px）の場合はミリメートル換算した値が1（mm）～200（mm）になる範囲を指定できます。デフォルトは，2（mm）です。

  • ［CPI］ラジオボタン

    グリッドの横の間隔をCPIで指定するときに選択します。指定できる値は，0.13（CPI）～24（CPI）です。

［高さ］グループボックス

グリッドの縦の間隔を設定します。デフォルトでは［間隔］ラジオボタンが選択されています。

  • ［間隔］ラジオボタン

    グリッドの縦の間隔を，ミリメートル（mm），インチ（in）またはピクセル（px）で指定するときに選択します。指定できる値は，1（mm）～200（mm）です。インチ（in），ピクセル（px）の場合はミリメートル換算した値が1（mm）～200（mm）になる範囲を指定できます。デフォルトは，2（mm）です。

  • ［LPI］ラジオボタン

    グリッドの縦の間隔をLPIで指定するときに選択します。指定できる値は，0.13（LPI）～24（LPI）です。

［原点］テキストボックス

グリッドの原点を設定します。原点は，用紙の左上を基準とします。指定できる値は，0（mm）～200（mm）です。デフォルトは，（10（mm），10（mm））です。ただし，［オプション］ダイアログの［表示］タブで［位置・サイズ］グループの座標の原点を「用紙の左上」に設定している場合は，用紙の上余白，および左余白よりも小さい値は設定できません。

［アイテムをグリッド補正する］チェックボックス

グリッドに合わせて，アイテムのラバーバンドを配置するかどうかを設定します。デフォルトは，「オン（補正する）」です。チェックボックスをオフにすると，グリッドの表示に関係なくラバーバンドを配置できるので，微妙に配置する場合に便利です。

［フォントによるリサイズを行う］チェックボックス

フォントの変更に合わせて，アイテム枠のサイズを自動的に変更するかどうかを設定します。デフォルトは，「オフ（変更しない）」です。

［バーコードのサイズ変更によるリサイズを行う］チェックボックス

バーコードのサイズや高さの変更に合わせて，バーコードアイテムの枠のサイズを自動的に変更するかどうかを設定します。デフォルトは，「オン（リサイズを行う）」です。

ページの先頭へ

(2)　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 95 / 139


2.17.3 ［文字］タブ : EUR 帳票作成 画面リファレンス

  • 96 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.17　［オプション］ダイアログ

  • 2.17.3　［文字］タブ

2.17.3　［文字］タブ

文字オプションを設定します。設定した値は，固定文字列のプロパティのデフォルトになります。

なお，フォントやサイズを設定することで，実行する環境によっては，帳票が正しく印刷されなかったり，表示されなかったりする場合があります。詳細は，マニュアル「EUR 帳票作成 操作ガイド」を参照してください。

〈この項の構成〉

  • (1)　［文字］タブで設定できる項目

  • (2)　画面図

(1)　［文字］タブで設定できる項目

［文字］タブで設定できる項目を次に示します。

［フォント名］コンボボックス

使用するフォント名を設定します。テキストボックスに直接入力するか，またはリストボックスから選択すると，そのフォント名がテキストボックスに反映されます。

デフォルトは，EURを実行したロケールによって異なります。ロケールごとのデフォルトのフォントを次に示します。

英語ロケールの場合：Lucida Console

中国語の場合：新宋体

日本語ロケールの場合：ＭＳ 明朝

［スタイル］コンボボックス

使用する文字のスタイルを設定します。テキストボックスに直接入力するか，またはリストボックスから選択すると，そのスタイルがテキストボックスに反映されます。デフォルトは，「標準」です。

［サイズ］コンボボックス

使用する文字のサイズを設定します。単位は，ポイント（pt）です。テキストボックスに直接入力するか，またはリストボックスから選択すると，そのサイズがテキストボックスに反映されます。テキストボックスに直接入力する場合は，3～256の値で設定します。選択したフォントによって，リストボックスの表示が異なることがあります。デフォルトは，「12（pt）」です。

［プレビュー］

フォント，スタイル，サイズを設定したときの文字のサンプルを表示します。

使用するフォントが英文フォントの場合は，「AaBbYyZz」が表示されます。

使用するフォントが中国語（簡体字）フォントの場合は，「 [図データ] 」が表示されます。中国語（繁体字）フォントの場合は，「中文字型範例」が表示されます。

使用するフォントが日本語フォントの場合は，「Aaあぁアァ亜宇」が表示されます。

また，［プレビュー］の下部には，フォント，スタイル，サイズを設定した時の文字が，表示または印刷でどのように使用されるかを表示します。

［水平方向］リストボックス

文字アイテムを水平方向に揃えます。選択できる配置は，次に示す四つです。デフォルトは，「中央」です。

配　置

説　　明

［左寄せ］

文字アイテムを左に寄せて配置します。

［中央］

文字アイテムを中央に配置します。

［右寄せ］

文字アイテムを右に寄せて配置します。

［均等割付］

文字アイテムを均等に配置します。
［垂直方向］リストボックス

文字アイテムを垂直方向に揃えます。選択できる配置は，次に示す四つです。デフォルトは，「中央」です。

配　置

説　　明

［上寄せ］

文字アイテムを上に寄せて配置します。

［中央］

文字アイテムを中央に配置します。

［下寄せ］

文字アイテムを下に寄せて配置します。

［均等割付］

文字アイテムを均等に配置します。

ページの先頭へ

(2)　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 96 / 139


2.17.4 ［線］タブ : EUR 帳票作成 画面リファレンス

  • 97 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.17　［オプション］ダイアログ

  • 2.17.4　［線］タブ

2.17.4　［線］タブ

線オプションを設定します。設定した値は，線アイテムのプロパティのデフォルトになります。

〈この項の構成〉

  • (1)　［線］タブで設定できる項目

  • (2)　画面図

(1)　［線］タブで設定できる項目

［線］タブで設定できる項目を次に示します。

［線種］グループボックス

線の種類を指定します。指定できる線種は，次に示す7種類です。デフォルトは実線です。

線の太さは［線の太さ］リストボックスで設定します。

［線の太さ］リストボックス

線の太さを指定します。指定できる線の太さは，次に示す5種類です。デフォルトは中線です。

線の太さを独自に設定する場合は，「任意サイズ」を選択したあと，テキストボックスに線の太さを指定します。テキストボックスは，「任意サイズ」を選択した場合にしか指定できません。

テキストボックスには，線の太さを0.1～10.0の値で設定します。単位は，ポイント（pt）です。なお，ポイント指定で太さを設定した線は，バージョン07-50以前のEURで表示すると，実線で表示されます。

ページの先頭へ

(2)　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 97 / 139


2.17.5 ［図形］タブ : EUR 帳票作成 画面リファレンス

  • 98 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.17　［オプション］ダイアログ

  • 2.17.5　［図形］タブ

2.17.5　［図形］タブ

図形オプションを設定します。設定した値は図形アイテムの一つ，網掛けアイテムのプロパティのデフォルトになります。

〈この項の構成〉

  • (1)　［図形］タブで設定できる項目

  • (2)　画面図

(1)　［図形］タブで設定できる項目

［図形］タブで設定できる項目を次に示します。

［模様］グループボックス

網掛けのパターンの種類を指定します。指定されたパターンは，凹んだように表示されます。デフォルトは，「薄い網掛け」です。

ページの先頭へ

(2)　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 98 / 139


2.17.6 ［画像］タブ : EUR 帳票作成 画面リファレンス

  • 99 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.17　［オプション］ダイアログ

  • 2.17.6　［画像］タブ

2.17.6　［画像］タブ

画像オプションを設定します。設定した値は，画像アイテムのプロパティのデフォルトになります。

〈この項の構成〉

  • (1)　［画像］タブで設定できる項目

  • (2)　画面図

(1)　［画像］タブで設定できる項目

［画像］タブで設定できる項目を次に示します。

［表示補正］グループボックス

アイテム枠のサイズを変更した場合に，画像アイテムをどのように表示するかを設定します。デフォルトは，「アイテムに合わせ拡大／縮小」です。

［アイテムに合わせ拡大／縮小］ラジオボタン

画像アイテム枠のサイズを変更した場合，画像データのサイズを変更した画像アイテムの枠のサイズに従って表示します。［アイテムに合わせ拡大／縮小］のラジオボタンを選択すると，［画像の縦横比を保持］のチェックボックスを設定できます。

［画像の縦横比を保持］チェックボックス

画像アイテム枠のサイズを変更した場合，画像データの縦横比を保持したまま，画像アイテム枠のサイズに収めるかどうかを設定します。デフォルトは，「オフ（画像の縦横比を保持しない）」です。

［画像サイズで表示］ラジオボタン

画像アイテム枠のサイズを変更しても，画像データが持つサイズで表示します。

［水平方向］リストボックス

選択されたアイテムを水平方向に揃えます。選択できる配置は，次に示す三つです。デフォルトは，「左寄せ」です。

配　置

説　　明

［左寄せ］

選択されたアイテムを左に寄せて配置します。

［中央］

選択されたアイテムを中央に配置します。

［右寄せ］

選択されたアイテムを右に寄せて配置します。
［垂直方向］リストボックス

選択されたアイテムを垂直方向に揃えます。選択できる配置は，次に示す三つです。デフォルトは，「上寄せ」です。

配　置

説　　明

［上寄せ］

選択されたアイテムを上に寄せて配置します。

［中央］

選択されたアイテムを中央に配置します。

［下寄せ］

選択されたアイテムを下に寄せて配置します。

ページの先頭へ

(2)　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 99 / 139


2.17.7 ［バーコード］タブ : EUR 帳票作成 画面リファレンス

  • 100 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.17　［オプション］ダイアログ

  • 2.17.7　［バーコード］タブ

2.17.7　［バーコード］タブ

バーコードオプションを設定します。設定した値は，バーコードアイテムのプロパティのデフォルトになります。

〈この項の構成〉

  • (1)　［バーコード］タブで設定できる項目

  • (2)　画面図

(1)　［バーコード］タブで設定できる項目

［バーコード］タブで設定できる項目を次に示します。

［バーコード形式］グループボックス

バーコードを表示，または印刷した場合に，バーコードアイテムをどのように表示するかを設定します。

表2‒19　バーコードの種類別の設定できる項目

種類

サイズ

高さ

入力データ形式

JAN標準/UPC-A

○

○

×

JAN短縮/UPC-E

○

○

×

CODE39

○

○

×

CODE128

○

○

○

NW-7

○

○

×

ITF

○

○

×

カスタマバーコード

○

×

×

QRコード

×

×

○
（凡例）

○：指定できます。

×：指定できません。

［種類］リストボックス

バーコードの種類を指定します。EURで指定できるバーコードは，JIS X 0507（JAN標準※1/UPC-A，JAN短縮※2/UPC-E），X 0502（ITF），X 0503（CODE39），X 0504（CODE128），X 0506（コーダバー。ただし，EURでは「NW-7」と表記します），X 0510（QRコード），および郵便事業株式会社が定めるカスタマバーコードです。デフォルトは，「JAN標準/UPC-A」です。

注※1

    JIS X 0507で規定されているEAN-13に相当します。

注※2

    JIS X 0507で規定されているEAN-8に相当します。

［サイズ］テキストボックス

バーコードのサイズを設定します。サイズの単位は，選択したバーコードの種類によって替わります。デフォルトは，「1」です。［種類］リストボックスで各バーコードを選択した場合については，「2.4.11　［バーコード］タブ」を参照してください。

［高さ］テキストボックス

バーコードを帳票ファイルに貼り付けた時の高さを設定します。高さの範囲は，1.0～50.0mmで，0.1mm単位で設定します。デフォルトは，「24.5」です。

バーコードの種類が「カスタマバーコード」と「QRコード」の場合は，［高さ］を指定することはできません。

［入力データ形式］リストボックス

バーコードの種類が「CODE128」と「QRコード」の場合，入力データ形式を指定します。

「CODE128」の場合は，「コードセットB」と「コードセットC」のどちらの入力データを指定するかを選択します。デフォルトは，「コードセットB」です。

「QRコード」の場合は，「文字列」と「16進文字列」，「16進バイナリ」のうち，どの入力データを指定するかを選択します。デフォルトは，「文字列」です。

［データ形式］グループボックス

バーコードフィールドのデータをどのように表示するかを設定します。

表2‒20　バーコードフィールドに表示できるデータ形式一覧

種類

データ形式

データキャラクタの表示

チェックキャラクタの付加

スタート／ストップキャラクタの付加

FNC1の付加

JAN標準/UPC-A

○

－

×

－

JAN短縮/UPC-E

○

－

×

－

CODE39

○

○

×

○

CODE128

－

－

○

○

NW-7

○

○

×

○

ITF

○

－

×

－

QRコード

×

×

×

×
（凡例）

○：指定できます。

×：指定できません。

－：固定（オン）です。

［バーコード形式］の［種類］のリストボックスから，「カスタマバーコード」を指定した場合は，［カスタマバーコードのデータ形式］のグループボックスからデータ形式を選択します。

［チェックキャラクタを付加する］チェックボックス

バーコード表示に，チェックキャラクタを付加するかどうかを設定します。使用するデータにチェックキャラクタが付加されている場合は，チェックキャラクタは付加しないでください。

［スタート／ストップキャラクタを付加する］チェックボックス

バーコード表示に，スタート／ストップキャラクタを付加するかどうかを設定します。デフォルトは，「オフ（付加しない）」です。

［FNC1を付加する］チェックボックス

バーコードの種類が「CODE128」の場合，データ形式に「FNC1」を付加するかどうかを設定します。FNC1は，特定の工業規格に合致するシンボルを識別するキャラクタです。

［カスタマバーコードのデータ形式］グループボックス

［バーコード形式］の［種類］のリストボックスから，「カスタマバーコード」を指定した場合に，バーコードフィールドのデータをどのように表示するかを設定できます。［種類］リストボックスで「QRコード」を選択した場合は，表示されません。

［郵便番号＋住所表示番号］ラジオボタン

データが「郵便番号と住所表示番号」の場合に選択します。EURがチェックデジットと制御コードを付加してカスタマバーコードを表示します。

［郵便番号＋住所表示番号＋チェックデジット＋制御コード］ラジオボタン

データが「郵便番号，住所表示番号，チェックデジット，および制御コード」の場合に選択します。EURは，データをそのままカスタマバーコードに変換して表示します。

［データキャラクタを表示する］チェックボックス

バーコード表示に，データキャラクタを表示するかどうかを設定します。［種類］リストボックスで「QRコード」を選択した場合は，表示されません。

［QRコード］グループボックス

［バーコード形式］の［種類］のリストボックスから，「QRコード」を指定した場合に，QRコードの訂正レベル，バージョン，セルサイズを設定できます。［種類］リストボックスでQRコード以外を選択した場合は表示されません。

［訂正レベル］リストボックス

MレベルまたはQレベルを選択できます。訂正レベルとは，万一QRコードに損傷が発生した場合，損傷の度合いに応じてデータの復元能力を設定しておくもので，L（7％）＜M（15％）＜Q（25％）＜H（30％）レベルがあります。EURで使用できる訂正レベルは，M（15％）レベルおよびQ（25％）レベルです。

［バージョンを指定する］チェックボックス

QRコードの型番（バージョン）を指定できます。QRコードの型番は1型から40型まであります。型番を指定する場合は，チェックをオンにして，テキストボックスに型番を入力してください。型番は，1～40までの整数です。

［セルサイズを指定する］チェックボックス

QRコードのセルサイズを指定できます。セルサイズの単位は，1/100mmです。セルサイズを指定する場合は，チェックをオンにして，テキストボックスにセルサイズを入力してください。21～126まで指定できます。

ページの先頭へ

(2)　画面図

JAN標準/UPC-A，JAN短縮/UPC-E，CODE39，CODE128，NW-7，ITF，カスタマバーコードの場合

QRコードの場合

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 100 / 139


2.17.8 ［ファイル］タブ : EUR 帳票作成 画面リファレンス

  • 101 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.17　［オプション］ダイアログ

  • 2.17.8　［ファイル］タブ

2.17.8　［ファイル］タブ

ファイルオプションを設定します。設定した値は，EURで使用するファイルの格納場所になります。

〈この項の構成〉

  • (1)　［ファイル］タブで設定できる項目

  • (2)　画面図

(1)　［ファイル］タブで設定できる項目

［ファイル］タブで設定できる項目を次に示します。

［ファイルの種類］リスト
レポートファイル

帳票ファイル（レポートファイル，またはフォームシートファイル）があるフォルダを設定します。フォルダを設定しない場合は，デフォルトとして，次のフォルダが設定されます。

インストール先フォルダ\Sample\Reports

マッピングデータファイル

マッピングデータファイル，または可変記号値定義ファイルがあるフォルダを設定します。フォルダを設定しない場合は，デフォルトとして，次のフォルダが設定されます。

インストール先フォルダ\Sample\Reports

マッピングディクショナリファイル

マッピングデータ用のディクショナリファイルがあるフォルダを設定します。フォルダを設定しない場合は，デフォルトとして，次のフォルダが設定されます。

インストール先フォルダ\Sample\Report

ただし，英語ロケール，中国語ロケールでは使用できません。

ユーザ定義データファイル

ユーザ定義データファイル，または可変記号値定義ファイルがあるフォルダを設定します。フォルダを設定しない場合は，デフォルトとして，次のフォルダが設定されます。

インストール先フォルダ\Sample\Report

ユーザ定義ディクショナリファイル

ユーザ定義データファイル用のディクショナリファイルがあるフォルダを設定します。フォルダを設定しない場合は，デフォルトとして，次のフォルダが設定されます。

インストール先フォルダ\Sample\Report

ただし，英語ロケール，中国語ロケールでは使用できません。

画像ファイル

画像データがあるフォルダを設定します。フォルダを設定しない場合は，次のフォルダが設定されます。

インストール先フォルダ\Sample\Report

接続情報ファイル

接続情報ファイルがあるフォルダ名を設定します。フォルダを設定しない場合は，デフォルトとして，インストール先フォルダが設定されます。

一時ファイル

データベースと連携してデータを抽出する時に作成される，一時ファイルの出力先を設定します。デフォルトとして，システム環境変数TMP，またはTEMPで指定されるフォルダが設定されます。

下敷きファイル

下敷きに使用する画像ファイルがあるフォルダを設定します。フォルダを設定しない場合は，デフォルトとして，次のフォルダが設定されます。

インストール先フォルダ\Sample\Report

置き換え表管理情報ファイル

置き換え表管理情報ファイルがあるフォルダを設定します。フォルダを設定しない場合は，デフォルトとして，次のフォルダが設定されます。

インストール先フォルダ\Sample\Report

置き換え表ファイル

置き換え表ファイルがあるフォルダを設定します。フォルダを設定しない場合は，デフォルトとして，次のフォルダが設定されます。

インストール先フォルダ\Sample\Report

［変更］ボタン

［フォルダの参照］ダイアログを表示します。［フォルダの参照］ダイアログは，［ファイルの種類］の一覧からファイルを選択したあと，［変更］ボタンをクリックすると表示されます。

ページの先頭へ

(2)　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 101 / 139


2.17.9 ［文字配置］タブ : EUR 帳票作成 画面リファレンス

  • 102 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.17　［オプション］ダイアログ

  • 2.17.9　［文字配置］タブ

2.17.9　［文字配置］タブ

文字アイテムの文字間隔や描画方向を変更します。設定した値は，文字アイテムのプロパティのデフォルトになります。

〈この項の構成〉

  • (1)　［文字配置］タブで設定できる項目

  • (2)　画面図

(1)　［文字配置］タブで設定できる項目

［文字配置］タブで設定できる項目を次に示します。

［バージョン2以前の文字配置を行う］チェックボックス

文字アイテムを文字の描画位置で補正して配置するかどうかを選択します。チェックボックスをオンにすると，文字アイテムを文字の描画位置で補正して配置します。デフォルトは，「オフ（補正しない）」です。ただし，英語ロケールおよび中国語ロケールでは使用できません。

バージョン2以前の文字配置を行うかどうかの違いを次に示します。

  • バージョン2以前の文字配置を行う場合

    UNIXの文字描画に合わせます。そのため，文字アイテムを文字の描画位置で補正して配置します。

  • バージョン2以前の文字配置を行わない場合

    Windowsシステムやデバイスの文字描画に合わせます。そのため，文字アイテムを文字のフォント属性に従って描画します。

    バージョン2以前の文字配置を行わない場合は，［間隔］と［文字の方向］の設定ができます。文字間隔と行間隔を，5ptずつ広くした例と狭くした例を次に示します。

なお，指定されているフォントによっては，［文字配置］を設定した帳票が実行する環境で正しく印刷されなかったり，表示されなかったりする場合があります。詳細は，マニュアル「EUR 帳票作成 操作ガイド」を参照してください。

［間隔］グループボックス

［バージョン2以前の文字配置を行う］のチェックボックスがオフの場合，文字間隔と行間隔を設定できます。

［文字間隔］リストボックス

文字アイテムの文字と文字の間隔を選択します。文字間隔は，「標準」，「狭く」，および「広く」のどれかを選択します。「狭く」と「広く」を選択した場合は，文字間隔を設定できます。間隔は，［間隔］のテキストボックスで指定します。

［間隔］テキストボックス

文字間隔を直接入力して指定します。指定できる範囲は，「狭く」（10pt）～「広く」（100pt）です。

なお，文字間隔が狭い場合，指定した文字のサイズが文字間隔を超える（左右の文字が重なる）ようなサイズである場合は，文字を描画しません。また，出力プリンタによって，文字間隔を狭くした場合は，正しく印刷されないことがあります。

［行間隔］リストボックス

文字アイテムの行と行の間隔を選択します。行間隔は，「標準」，「狭く」，および「広く」のどれかを選択します。「狭く」と「広く」を選択した場合は行間隔を設定できます。間隔は，［間隔］のテキストボックスで指定します。

［間隔］テキストボックス

行間隔を直接入力して指定します。指定できる範囲は，「狭く」（10pt）～「広く」（100pt）です。

なお，行間隔が狭い場合，指定した文字のサイズが行間を超える（上下の文字が重なる）ようなサイズである場合は，文字を描画しません。

ページの先頭へ

(2)　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 102 / 139


2.17.10 ［データウィンドウ］タブ : EUR 帳票作成 画面リファレンス

  • 103 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.17　［オプション］ダイアログ

  • 2.17.10　［データウィンドウ］タブ

2.17.10　［データウィンドウ］タブ

データウィンドウのフォントとサイズを設定します。

〈この項の構成〉

  • (1)　［データウィンドウ］タブで設定できる項目

  • (2)　画面図

(1)　［データウィンドウ］タブで設定できる項目

［データウィンドウ］タブで設定できる項目を次に示します。

［フォント名］コンボボックス

使用するフォント名を設定します。テキストボックスに直接入力するか，またはリストボックスから選択すると，そのフォント名がテキストボックスに反映されます。デフォルトは，EURを実行したロケールによって異なります。ロケールごとのデフォルトのフォントを次に示します。

英語ロケールの場合：Lucida Console

中国語の場合：新宋体

日本語ロケールの場合：ＭＳ 明朝

［サイズ］コンボボックス

使用する文字のサイズを設定します。単位は，ポイント（pt）です。テキストボックスに直接入力するか，またはリストボックスから選択すると，そのサイズがテキストボックスに反映されます。テキストボックスに直接入力する場合は，3～256の値で，小数点以下1桁までです。デフォルトは，9です。

ページの先頭へ

(2)　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 103 / 139


2.18 部品パレットウィンドウ : EUR 帳票作成 画面リファレンス

  • 104 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.18　部品パレットウィンドウ

2.18　部品パレットウィンドウ

部品を登録したり，登録した部品を帳票ウィンドウに貼り付けたりするウィンドウです。

スタートメニューの［EUR Designer］または［EUR Developer］の下位の［部品パレットウィンドウ］を選択すると，表示されます。帳票ウィンドウの［ツール］メニュー－［部品パレット］からも表示できます。

〈この節の構成〉

  • 2.18.1　部品パレットウィンドウのメニュー

  • 2.18.2　部品パレットウィンドウで設定できる項目

  • 2.18.3　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 104 / 139


2.18.1 部品パレットウィンドウのメニュー : EUR 帳票作成 画面リファレンス

  • 105 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.18　部品パレットウィンドウ

  • 2.18.1　部品パレットウィンドウのメニュー

2.18.1　部品パレットウィンドウのメニュー

部品パレットウィンドウに表示されるメニューを次の表に示します。

表2‒21 部品パレットウィンドウのメニュー一覧
メニュー | ドロップダウンメニュー | 機能
ファイル | インポート | 部品アーカイブファイルをインポートします。［ファイルを開く］ダイアログが表示されます。
 | エクスポート | 部品を部品アーカイブファイルにエクスポートします。［名前を付けて保存］ダイアログが表示されます。
 | プロパティ | ［部品のプロパティ］ダイアログが表示されます。
 | 閉じる | 部品パレットウィンドウが閉じます。
編集 | 削除 | 削除してもいいかどうかを確認するメッセージが表示されます。［はい］ボタンをクリックすると，部品が削除されます。
 | すべてを選択 | 部品パレットウィンドウに表示されているすべての部品を選択します。
 | 名前の変更 | ［部品の名称］ダイアログが表示されます。部品の登録名称が変更できます。
ヘルプ | EUR部品パレットのヘルプ | 部品パレットウィンドウのヘルプが表示されます。
 | バージョン情報 | EURのバージョン情報が表示されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 105 / 139


2.18.2 部品パレットウィンドウで設定できる項目 : EUR 帳票作成 画面リファレンス

  • 106 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.18　部品パレットウィンドウ

  • 2.18.2　部品パレットウィンドウで設定できる項目

2.18.2　部品パレットウィンドウで設定できる項目

「共通部品」一覧

部品名および部品のコメントが一覧で表示されます。部品名はソートされて表示されます。部品が登録されていない場合は，一覧は表示されません。

部品名を選択し，帳票ウィンドウにドラッグアンドドロップすることで，部品を帳票ウィンドウに貼り付けられます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 106 / 139


2.18.3 画面図 : EUR 帳票作成 画面リファレンス

  • 107 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.18　部品パレットウィンドウ

  • 2.18.3　画面図

2.18.3　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 107 / 139


2.19 ［部品の登録］ダイアログ : EUR 帳票作成 画面リファレンス

  • 108 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.19　［部品の登録］ダイアログ

2.19　［部品の登録］ダイアログ

帳票ウィンドウで作成したアイテムを部品として登録します。

部品として登録したいアイテムをすべて選択してから，［編集］メニューの［部品の登録］を選択すると，表示されます。

〈この節の構成〉

  • 2.19.1　［部品の登録］ダイアログで設定できる項目

  • 2.19.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 108 / 139


2.19.1 ［部品の登録］ダイアログで設定できる項目 : EUR 帳票作成 画面リファレンス

  • 109 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.19　［部品の登録］ダイアログ

  • 2.19.1　［部品の登録］ダイアログで設定できる項目

2.19.1　［部品の登録］ダイアログで設定できる項目

［部品名］テキストボックス

登録する部品の部品名を指定します。デフォルトは，「部品XXXX」（Xは1からの通し番号）です。部品名は必ず指定してください。部品名は，30文字まで入力できます。

［コメント］テキストボックス

登録する部品のコメントを入力します。デフォルトは，空白です。コメントは，200文字まで入力できます。

［座標］グループボックス

登録する部品の貼り付け時の位置を指定するかどうかを設定します。デフォルトは「任意の位置」です。

［任意の位置］ラジオボタン

登録する部品の帳票ウィンドウ上での貼り付け時の位置を設定しません。

［固定の位置］ラジオボタン

登録する部品の帳票ウィンドウ上での貼り付け時の位置を設定します。

［常に指定位置に配置］チェックボックス

登録する部品を，常に指定された座標位置に配置されるように設定します。

チェックボックスをオンにすると，帳票に貼り付けた部品は指定された座標位置に配置され，貼り付けたあとも移動できません。

チェックボックスをオフにすると，帳票に貼り付けた部品は指定された座標位置に配置されますが，貼り付けたあとは任意の位置に移動できます。

［基準位置］リストボックス

登録する部品を貼り付ける基準位置を「用紙左上」，「用紙右上」，「用紙左下」，「用紙右下」から選択します。［X］テキストボックス（X座標値），［Y］テキストボックス（Y座標値）で指定された座標は，指定した用紙の隅からいちばん近い部品の隅までの距離を指します。デフォルトは「用紙左上」です。

基準位置と部品の座標位置の関係を次に示します。

［X］テキストボックス，［Y］テキストボックス

登録する部品のX座標値とY座標値を指定します。デフォルトは，部品の左上隅の座標（用紙左端を原点とする）が表示されます。

座標の単位は，オプションで選択した単位が表示されます。単位を変更したい場合は，マニュアル「EUR 帳票作成 操作ガイド」を参照してください。

設定できる単位と各単位の最小有効桁数を，次に示します。

単位

単位記号

最小有効桁数

ミリメートル

mm

小数点以下第2位

インチ

in

ピクセル

px

整数

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 109 / 139


2.19.2 画面図 : EUR 帳票作成 画面リファレンス

  • 110 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.19　［部品の登録］ダイアログ

  • 2.19.2　画面図

2.19.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 110 / 139


2.20 ［部品の名称］ダイアログ : EUR 帳票作成 画面リファレンス

  • 111 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.20　［部品の名称］ダイアログ

2.20　［部品の名称］ダイアログ

部品の名称を変更します。

〈この節の構成〉

  • 2.20.1　［部品の名称］ダイアログで設定できる項目

  • 2.20.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 111 / 139


2.20.1 ［部品の名称］ダイアログで設定できる項目 : EUR 帳票作成 画面リファレンス

  • 112 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.20　［部品の名称］ダイアログ

  • 2.20.1　［部品の名称］ダイアログで設定できる項目

2.20.1　［部品の名称］ダイアログで設定できる項目

［部品名］テキストボックス

部品名を指定します。デフォルトは，選択した部品の部品名が表示されます。部品名は必ず指定してください。部品名は，30文字まで指定できます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 112 / 139


2.20.2 画面図 : EUR 帳票作成 画面リファレンス

  • 113 / 139

  • 表紙

  • 2.　帳票ウィンドウのダイアログ

  • 2.20　［部品の名称］ダイアログ

  • 2.20.2　画面図

2.20.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 113 / 139


3. 実行ファイルまたはスタートメニューから表示するダイアログ : EUR 帳票作成 画面リファレンス

  • 114 / 139

  • 表紙

  • 3.　実行ファイルまたはスタートメニューから表示するダイアログ

3.　実行ファイルまたはスタートメニューから表示するダイアログ

この章では，EURの実行ファイルまたはスタートメニューから表示するダイアログについて説明します。

〈この章の構成〉

  • 3.1　［EURログオプションの設定］ダイアログ

  • 3.2　［EURログメンテナンスツール］ダイアログ

  • 3.3　［EURユーザ環境削除］ダイアログ

  • 3.4　［Word/Excel文書の変換］ダイアログ

  • 3.5　［帳票定義情報ファイルの入出力］ダイアログ

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 114 / 139


3.1 ［EURログオプションの設定］ダイアログ : EUR 帳票作成 画面リファレンス

  • 115 / 139

  • 表紙

  • 3.　実行ファイルまたはスタートメニューから表示するダイアログ

  • 3.1　［EURログオプションの設定］ダイアログ

3.1　［EURログオプションの設定］ダイアログ

ログオプション（ログ採取レベル，ログ出力ファイル名，およびログメンテナンス方法）を設定するダイアログです。

次に示すフォルダ下に格納されている「EurLgOpt.exe」をダブルクリックすると表示されます。

「EurLgOpt.exe」の格納先

インストール先フォルダ\Designer\Program

なお，出力されるログファイルのエンコーディングは，UTF-16です。

〈この節の構成〉

  • 3.1.1　［EURログオプションの設定］ダイアログで設定できる項目

  • 3.1.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 115 / 139


3.1.1 ［EURログオプションの設定］ダイアログで設定できる項目 : EUR 帳票作成 画面リファレンス

  • 116 / 139

  • 表紙

  • 3.　実行ファイルまたはスタートメニューから表示するダイアログ

  • 3.1　［EURログオプションの設定］ダイアログ

  • 3.1.1　［EURログオプションの設定］ダイアログで設定できる項目

3.1.1　［EURログオプションの設定］ダイアログで設定できる項目

［ログ採取レベル］リストボックス

ログ採取レベルを設定します。ログ採取レベルは，次に示す5種類です。EURをインストールした直後は，「起動履歴」が設定されています。

  • エラー履歴

    EURの処理でエラーが発生した時，終了コード（RTNCODE=0）以外のエラーを出力します。

  • 起動履歴

    次に示す情報を出力します。

    ・EUR起動時の情報（起動履歴，起動方法，起動時の指定パラメタ）

    ・EUR終了時の情報（終了履歴）

    ・ドキュメントオープン時の情報（処理対象の帳票ファイル名，データファイル名）

    ・印刷処理開始時の情報（出力先プリンタの情報）

    ・各ページ印刷開始時の情報（印刷ページ数）

    ・ユーザが操作した内容

      （OCXの場合はメソッド履歴，DLLインターフェース関数の場合は関数履歴）

  • 要求履歴

    ユーザが操作した内容（プロパティ・ユーザ操作の履歴）を出力します。

  • 処理履歴

    EURの内部関数の処理履歴（入力パラメタ，出力パラメタ，リターンコード）を出力します。

  • システム履歴

    システム関数（OS提供の関数）の処理履歴（入力パラメタ，出力パラメタ，リターンコード）を出力します。

ログ採取のレベルは，エラー履歴＜起動履歴＜要求履歴＜処理履歴＜システム履歴の順に，採取する情報量が多くなります。そのため，上位レベルになるほど，ファイル容量が増加するので，プログラムへの性能に影響が及ぶこともあります。ログ採取のレベルは，下位レベルで採取されることをお勧めします。

［ログを出力するファイル］テキストボックス

ログを出力するファイル名をフルパスで指定します。既存の書き込み権限を持つフォルダを指定してください。EURをインストールした直後は，ユーザアプリケーションデータフォルダ※\HITACHI\EURにファイル名「HIEUR.LOG」が自動生成されています。

注※

ユーザアプリケーションデータフォルダはC:\Users\<ログインユーザ>\AppData\Roamingです。

［自動ログメンテナンスを行う］チェックボックス

自動ログメンテナンスを行うかどうかを設定します。EURをインストールした直後は，「オン（自動ログメンテナンスを行う）」が設定されています。

［自動ログメンテナンスを行う］のチェックボックスをオンにすると，［メンテナンス実行契機］と［メンテナンス方法］が設定できます。

［メンテナンス実行契機］グループボックス

自動メンテナンスを行う契機を，ラジオボタンで設定します。EURをインストールした直後は，「マシン起動時に実行」，実行する日時には「毎日」が設定されています。

指定した曜日にマシンを起動した時，ログファイルがメンテナンスされます。曜日は，「毎日」か，日曜～土曜のどれかを選択します。

指定時刻に実行する場合は，曜日のほか，実行する時刻を指定します。時刻は，テキストボックスに直接入力するか，またはリストボックスから選択してください。直接入力する場合は，24時間表示の時刻（分単位）で指定します。

［メンテナンス方法］グループボックス

ログファイルのメンテナンス方法を，ラジオボタンで設定します。EURをインストール直後は，「経過日数によりログ情報を削除」で，経過日数は「7（日）」です。

  • 経過日数によりログ情報を削除

    指定した日数を経過したログ情報を，ログファイル内から削除します。経過日数は，1～100の整数で指定します。

  • 上限容量を超えた場合に削除

    指定したログファイルの上限容量を超えた場合，無条件にログファイルの容量が1/2に削除されます。ログファイルの上限容量は，1～1,000の整数で指定します。単位は，MBです。

    なお，［上限容量を超えた場合に削除］を選択した場合，ログ採取のレベルと指定したログファイルの上限容量によっては，1回の処理でログファイルの上限容量を超える場合があります。

［オプション読込］ボタン

保存されているEURログオプションファイルを読み込めます。［オプション読込］ボタンをクリックすると，［ファイルの読み込み］ダイアログが表示されます。［ファイルの読み込み］ダイアログで，読み込むファイルの保存されている場所とファイル名を設定すると，［EURログオプションの設定］ダイアログに情報が反映されます。

EURログオプションファイルを読み込む場合は，ファイルの妥当性とバージョンがチェックされます。上位バージョンで作成されたEURログオプションファイル，または保存されている内容が異なるEURログオプションファイルが指定された場合はメッセージを表示して，オプションの情報はダイアログに反映されません。

［オプション保存］ボタン

［EURログオプションの設定］ダイアログで設定したオプションを，EURログオプションファイルに保存できます。［オプション保存］ボタンをクリックすると，［ファイルへ保存］ダイアログが表示されます。EURログオプションファイルの拡張子は，「*.eurlgo」です。保存される情報は，採取したログのほか，使用したEURの製品名，PP形名，およびバージョンです。ログオプションファイル名には，Unicode固有の文字は指定できません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 116 / 139


3.1.2 画面図 : EUR 帳票作成 画面リファレンス

  • 117 / 139

  • 表紙

  • 3.　実行ファイルまたはスタートメニューから表示するダイアログ

  • 3.1　［EURログオプションの設定］ダイアログ

  • 3.1.2　画面図

3.1.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 117 / 139


3.2 ［EURログメンテナンスツール］ダイアログ : EUR 帳票作成 画面リファレンス

  • 118 / 139

  • 表紙

  • 3.　実行ファイルまたはスタートメニューから表示するダイアログ

  • 3.2　［EURログメンテナンスツール］ダイアログ

3.2　［EURログメンテナンスツール］ダイアログ

［EURログオプションの設定］ダイアログで設定されている，ログメンテナンス情報を表示します。

次に示すフォルダ下に格納されている「EurLgMnt.exe」をダブルクリックすると表示されます。

「EurLgMnt.exe」の格納先

インストール先フォルダ\Designer\Program

〈この節の構成〉

  • 3.2.1　［EURログメンテナンスツール］ダイアログで設定できる項目

  • 3.2.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 118 / 139


3.2.1 ［EURログメンテナンスツール］ダイアログで設定できる項目 : EUR 帳票作成 画面リファレンス

  • 119 / 139

  • 表紙

  • 3.　実行ファイルまたはスタートメニューから表示するダイアログ

  • 3.2　［EURログメンテナンスツール］ダイアログ

  • 3.2.1　［EURログメンテナンスツール］ダイアログで設定できる項目

3.2.1　［EURログメンテナンスツール］ダイアログで設定できる項目

［ログメンテナンス契機］グループボックス

［EURログオプションの設定］ダイアログの［メンテナンス実行契機］で設定した情報が表示されます。

［ログメンテナンス方法］グループボックス

［EURログオプションの設定］ダイアログの［メンテナンス方法］で設定した情報が表示されます。

［無効にする］ボタン

ログメンテナンス情報の設定に関係なく，EURログメンテナンスツールを強制終了して，［EURログメンテナンスツール］ダイアログを閉じます。そのため，［ログメンテナンス方法］で指定時刻が設定されている場合は，指定された時刻になっても，自動ログメンテナンスは実行されません。

［メンテナンス実行］ボタン

設定されているログファイルのメンテナンス方法を実行します。EURログメンテナンスツールが実行状態の時に［メンテナンス実行］ボタンをクリックすると，［ログメンテナンス方法］の表示領域の下部に「ログメンテナンス実行中」と表示されます。

［オプション設定］ボタン

EURログオプション設定ツールを起動します。［オプション設定］ボタンをクリックした時，すでにログオプション設定ツールが起動されている場合は，起動されているログオプション設定ツールをアクティブにします。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 119 / 139


3.2.2 画面図 : EUR 帳票作成 画面リファレンス

  • 120 / 139

  • 表紙

  • 3.　実行ファイルまたはスタートメニューから表示するダイアログ

  • 3.2　［EURログメンテナンスツール］ダイアログ

  • 3.2.2　画面図

3.2.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 120 / 139


3.3 ［EURユーザ環境削除］ダイアログ : EUR 帳票作成 画面リファレンス

  • 121 / 139

  • 表紙

  • 3.　実行ファイルまたはスタートメニューから表示するダイアログ

  • 3.3　［EURユーザ環境削除］ダイアログ

3.3　［EURユーザ環境削除］ダイアログ

設定されているユーザ環境を削除します。

スタートメニューの［EUR Designer］または［EUR Developer］の下位の［EURユーザ環境削除］を選択すると，表示されます。

〈この節の構成〉

  • 3.3.1　［EURユーザ環境削除］ダイアログで設定できる項目

  • 3.3.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 121 / 139


3.3.1 ［EURユーザ環境削除］ダイアログで設定できる項目 : EUR 帳票作成 画面リファレンス

  • 122 / 139

  • 表紙

  • 3.　実行ファイルまたはスタートメニューから表示するダイアログ

  • 3.3　［EURユーザ環境削除］ダイアログ

  • 3.3.1　［EURユーザ環境削除］ダイアログで設定できる項目

3.3.1　［EURユーザ環境削除］ダイアログで設定できる項目

［環境削除］ボタン

設定されているユーザ環境を削除します。削除されるユーザ環境は，［オプション］ダイアログで指定した各種オプション情報，ツールバーの表示・非表示，［色の設定］ダイアログで登録した独自の色などです。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 122 / 139


3.3.2 画面図 : EUR 帳票作成 画面リファレンス

  • 123 / 139

  • 表紙

  • 3.　実行ファイルまたはスタートメニューから表示するダイアログ

  • 3.3　［EURユーザ環境削除］ダイアログ

  • 3.3.2　画面図

3.3.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 123 / 139


3.4 ［Word/Excel文書の変換］ダイアログ : EUR 帳票作成 画面リファレンス

  • 124 / 139

  • 表紙

  • 3.　実行ファイルまたはスタートメニューから表示するダイアログ

  • 3.4　［Word/Excel文書の変換］ダイアログ

3.4　［Word/Excel文書の変換］ダイアログ

Word/Excel文書を帳票ファイル（*.fms）に変換するダイアログです。

スタートメニューの［EUR Designer］または［EUR Developer］の下位の［Word／Excel文書の変換］を選択すると表示されます。

〈この節の構成〉

  • 3.4.1　［Word/Excel文書の変換］ダイアログで設定できる項目

  • 3.4.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 124 / 139


3.4.1 ［Word/Excel文書の変換］ダイアログで設定できる項目 : EUR 帳票作成 画面リファレンス

  • 125 / 139

  • 表紙

  • 3.　実行ファイルまたはスタートメニューから表示するダイアログ

  • 3.4　［Word/Excel文書の変換］ダイアログ

  • 3.4.1　［Word/Excel文書の変換］ダイアログで設定できる項目

3.4.1　［Word/Excel文書の変換］ダイアログで設定できる項目

［ファイルの選択］テキストボックス

変換するWordファイルまたはExcelファイルが格納されたフォルダを指定します。［参照］ボタンをクリックすると，［ファイルを選択］ダイアログが開きます。［ファイルを選択］ダイアログで，変換するファイルを選択します。ファイルは複数選択できます。

「ファイル一覧」

［ファイルを選択］ダイアログで選択したファイル名を表示します。ここに表示されたファイルを帳票ファイルに変換します。

［オプション］ボタン

［オプション］ダイアログを表示します。

［オプション］ダイアログでは，罫線の自動補正ができます。罫線の自動補正は，斜線を水平線や垂直線に変換するための補正値を入力します。補正値は，0～9.99まで入力できます。デフォルトは1.3mmです。

［出力先フォルダ］テキストボックス

変換したファイルを格納するフォルダを指定します。［参照］ボタンをクリックすると，［フォルダの参照］ダイアログが開きます。直接入力はできません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 125 / 139


3.4.2 画面図 : EUR 帳票作成 画面リファレンス

  • 126 / 139

  • 表紙

  • 3.　実行ファイルまたはスタートメニューから表示するダイアログ

  • 3.4　［Word/Excel文書の変換］ダイアログ

  • 3.4.2　画面図

3.4.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 126 / 139


3.5 ［帳票定義情報ファイルの入出力］ダイアログ : EUR 帳票作成 画面リファレンス

  • 127 / 139

  • 表紙

  • 3.　実行ファイルまたはスタートメニューから表示するダイアログ

  • 3.5　［帳票定義情報ファイルの入出力］ダイアログ

3.5　［帳票定義情報ファイルの入出力］ダイアログ

帳票ファイルを帳票定義情報ファイルに変換したり，帳票定義情報ファイルを帳票ファイルに変換したりするダイアログです。

スタートメニューの［EUR Designer］または［EUR Developer］の下位の［帳票定義情報ファイルの入出力］を選択すると，表示されます。

〈この節の構成〉

  • 3.5.1　［帳票定義情報ファイルの入出力］ダイアログで設定できる項目

  • 3.5.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 127 / 139


3.5.1 ［帳票定義情報ファイルの入出力］ダイアログで設定できる項目 : EUR 帳票作成 画面リファレンス

  • 128 / 139

  • 表紙

  • 3.　実行ファイルまたはスタートメニューから表示するダイアログ

  • 3.5　［帳票定義情報ファイルの入出力］ダイアログ

  • 3.5.1　［帳票定義情報ファイルの入出力］ダイアログで設定できる項目

3.5.1　［帳票定義情報ファイルの入出力］ダイアログで設定できる項目

［変換方法］グループボックス

帳票定義情報ファイルに変換するか，帳票ファイルに変換するかを選択します。

［帳票ファイルを帳票定義情報ファイルに変換する］ラジオボタン

チェックを入れると，帳票ファイル（.fms）を帳票定義情報ファイルに変換します。

［帳票定義情報ファイルを帳票ファイルに変換する］ラジオボタン

チェックを入れると，帳票定義情報ファイル（.esp）を帳票ファイルに変換します。

［入力ファイルの選択］グループボックス
［入力元フォルダ］テキストボックス

変換するファイルが格納されたフォルダを表示します。［参照］ボタンをクリックすると，［ファイルを選択］ダイアログが開きます。［ファイルを選択］ダイアログで，変換するファイルを選択します。ファイルは複数選択できます。

帳票ファイルを変換する場合は帳票ファイル（.fms）が格納されたフォルダを，帳票定義情報ファイルを変換する場合は帳票定義情報ファイル（.esp）が格納されたフォルダを選択します。直接入力はできません。

「入力ファイル一覧」

［ファイルを選択］ダイアログで選択したファイル名を表示します。ここに表示された帳票ファイルまたは帳票定義情報ファイルを変換します。

［出力先フォルダ］テキストボックス

変換したファイルを格納するフォルダを指定します。［参照］ボタンをクリックすると，［フォルダの参照］ダイアログが開きます。直接入力はできません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 128 / 139


3.5.2 画面図 : EUR 帳票作成 画面リファレンス

  • 129 / 139

  • 表紙

  • 3.　実行ファイルまたはスタートメニューから表示するダイアログ

  • 3.5　［帳票定義情報ファイルの入出力］ダイアログ

  • 3.5.2　画面図

3.5.2　画面図

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 129 / 139


付録 : EUR 帳票作成 画面リファレンス

  • 130 / 139

  • 表紙

  • 付録

付録

〈この付録の構成〉

  • 付録A　このマニュアルの参考情報

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 130 / 139


付録A このマニュアルの参考情報 : EUR 帳票作成 画面リファレンス

  • 131 / 139

  • 表紙

  • 付録

  • 付録A　このマニュアルの参考情報

付録A　このマニュアルの参考情報

このマニュアルを読むに当たっての参考情報を示します。

〈この節の構成〉

  • 付録A.1　関連マニュアル

  • 付録A.2　EUR バージョン10での製品体系の変更

  • 付録A.3　EUR バージョン10でのマニュアル体系の変更

  • 付録A.4　このマニュアルでの表記

  • 付録A.5　このマニュアルで使用する略語

  • 付録A.6　KB（キロバイト）などの単位表記について

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 131 / 139


付録A.1 関連マニュアル : EUR 帳票作成 画面リファレンス

  • 132 / 139

  • 表紙

  • 付録

  • 付録A　このマニュアルの参考情報

  • 付録A.1　関連マニュアル

付録A.1　関連マニュアル

関連マニュアルを次に示します。必要に応じてお読みください。

〈この項の構成〉

  • (1)　EURのマニュアル

  • (2)　関連ソフトウェアのマニュアル

  • (3)　このマニュアルでのマニュアル名表記

(1)　EURのマニュアル

EURの関連マニュアルを次に示します。

  • はじめての帳票作成（3020-7-532）※

    EUR 帳票作成機能をまだ使用したことのない人向けに，簡単な帳票を作成する方法について説明しています。

  • EUR システム設計ガイド（3021-7-001）

    EURを使用した帳票システムの計画・設計時に検討が必要な内容について説明しています。

  • EUR システム構築ガイド（3021-7-002）

    EURを使用した帳票システムを構築する手順について説明しています。

  • EUR 帳票作成 操作ガイド（3021-7-003）

    EUR 帳票作成機能を使用して帳票を作成する方法について説明しています。

  • uCosminexus EUR 帳票設計（EUR Form帳票）（3020-7-534）※

    EUR Form帳票作成機能を使用してEUR Form帳票を作成する方法について説明しています。

  • EUR 帳票出力 EUR Designer/EUR Viewer編（3021-7-005）

    EUR DesignerまたはEUR Viewerを使用して，クライアント環境で帳票を出力する方法について説明しています。

  • uCosminexus EUR クライアント帳票出力（3020-7-535）※

    EUR クライアント帳票出力機能のV8互換機能を使用して，クライアント環境で帳票を出力する方法について説明しています。

  • EUR 帳票出力 機能解説 EUR Server編（3021-7-006）

    EUR サーバ帳票出力機能を使って帳票を出力する方法について説明しています。

  • EUR 帳票出力 リファレンス EUR Server編（3021-7-007）

    EUR サーバ帳票出力機能を使って帳票を出力するときに使用するAPIや入力ファイルの設定方法について説明しています。

  • uCosminexus EUR サーバ帳票出力（3020-7-536）※

    EUR ServerのV8互換機能を使用して，サーバ環境で帳票を出力する方法について説明しています。

  • EUR データベース連携ガイド（3021-7-008）

    データベースから抽出したデータを使って帳票を作成および出力する方法，およびEUR 帳票作成機能のデータベースアクセス定義ウィンドウを使用する方法について説明しています。また，データベースの操作時に出力されるメッセージについても説明しています。

  • EUR メッセージ（3021-7-009）

    EURを使用しているときに出力されるメッセージについて説明しています。

  • EUR 用語集（3021-7-010）

    EURシリーズマニュアル内で使用する用語について説明しています。なお，この用語集は日立ソフトウェアマニュアル公開サイト，または製品同梱のヘルプ（Windows版）だけで参照できます。

注※

バージョン8のマニュアルを提供しています。バージョン10の製品に置き換えて参照してください。

ページの先頭へ

(2)　関連ソフトウェアのマニュアル

関連ソフトウェアのマニュアルを次に示します。

  • TPBroker ユーザーズガイド（3000-3-660）

  • TPBroker Developer's Kit - Extension for C++ プログラマーズガイド（3000-3-680）

  • TPBroker Object Transaction Monitor ユーザーズガイド（3000-3-689）

  • COBOL2002　使用の手引　手引編（3000-3-D42）

  • COBOL2002　使用の手引　操作編（3000-3-D43）

  • COBOL2002　操作ガイド（3020-3-D47）

  • COBOL2002　ユーザーズガイド（3020-3-D48）

  • SEWB+/REPOSITORY 辞書設計ガイド（3020-3-698）

  • SEWB+/REPOSITORY 辞書設計ガイド（3020-3-N82）

  • DBPARTNER2 Client　操作ガイド（3020-6-027）

  • DABroker（3020-6-031）

  • HiRDB Version 8 UAP開発ガイド（3020-6-356）

  • HiRDB Version 8 メッセージ（3020-6-358）

  • HiRDB Version 9 UAP開発ガイド（3020-6-456）

  • HiRDB Version 9 メッセージ（3020-6-458）

  • JP1 Version 10 JP1/Audit Management - Manager 構築・運用ガイド（3021-3-165）

ページの先頭へ

(3)　このマニュアルでのマニュアル名表記

このマニュアルでは，マニュアル名について，次のように表記しています。

マニュアル名 | 表記
uCosminexus EUR 帳票設計（EUR Form帳票） | EUR 帳票設計（EUR Form帳票）
uCosminexus EUR クライアント帳票出力 | EUR クライアント帳票出力
uCosminexus EUR サーバ帳票出力 | EUR サーバ帳票出力
HiRDB Version 8 UAP開発ガイド HiRDB Version 9 UAP開発ガイド | HiRDB UAP開発ガイド
HiRDB Version 8 メッセージ HiRDB Version 9 メッセージ | HiRDB メッセージ
JP1 Version 10 JP1/Audit Management - Manager 構築・運用ガイド | JP1/Audit Management - Manager 構築・運用ガイド

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 132 / 139


付録A.2 EUR バージョン10での製品体系の変更 : EUR 帳票作成 画面リファレンス

  • 133 / 139

  • 表紙

  • 付録

  • 付録A　このマニュアルの参考情報

  • 付録A.2　EUR バージョン10での製品体系の変更

付録A.2　EUR バージョン10での製品体系の変更

  • 製品名称を変更しました。

  • uCosminexus EUR Server Print Editionを廃止しました。

EUR バージョン10での製品体系の変更について，次の図に示します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 133 / 139


付録A.3 EUR バージョン10でのマニュアル体系の変更 : EUR 帳票作成 画面リファレンス

  • 134 / 139

  • 表紙

  • 付録

  • 付録A　このマニュアルの参考情報

  • 付録A.3　EUR バージョン10でのマニュアル体系の変更

付録A.3　EUR バージョン10でのマニュアル体系の変更

  • マニュアル名を変更しました。

EUR バージョン10でのマニュアル体系の変更について，次の表に示します。

EUR バージョン9 | EUR バージョン10
uCosminexus EUR システム設計ガイド | EUR システム設計ガイド
uCosminexus EUR システム構築ガイド | EUR システム構築ガイド
uCosminexus EUR 帳票作成 操作ガイド | EUR 帳票作成 操作ガイド
uCosminexus EUR 帳票作成 画面リファレンス | EUR 帳票作成 画面リファレンス
uCosminexus EUR 帳票出力 機能解説 EUR Server編 | EUR 帳票出力 機能解説 EUR Server編
uCosminexus EUR 帳票出力 リファレンス EUR Server編 | EUR 帳票出力 リファレンス EUR Server編
uCosminexus EUR 帳票出力 EUR Designer/EUR Viewer編 | EUR 帳票出力 EUR Designer/EUR Viewer編
uCosminexus EUR データベース連携ガイド | EUR データベース連携ガイド
uCosminexus EUR メッセージ | EUR メッセージ
uCosminexus EUR 用語集 | EUR 用語集

EUR ServerのV8互換機能を使用する場合は，バージョン8対応のマニュアル「EUR サーバ帳票出力」を参照してください。Windows環境では，インストール先フォルダ\Print\1041\Help\eurps.chmに統合ヘルプが格納されています。

クライアント帳票出力機能のV8互換機能を使用する場合は，バージョン8対応のマニュアル「EUR クライアント帳票出力」を参照してください。Windows環境では，次のフォルダにヘルプが格納されています。

  • EUR Designerの場合

    EUR Designerのインストール先フォルダ\Designer\1041\Help\euroutp.chm

  • EUR Viewerの場合

    EUR Viewerのインストール先フォルダ\1041\Help\euroutp.chm

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 134 / 139


付録A.4 このマニュアルでの表記 : EUR 帳票作成 画面リファレンス

  • 135 / 139

  • 表紙

  • 付録

  • 付録A　このマニュアルの参考情報

  • 付録A.4　このマニュアルでの表記

付録A.4　このマニュアルでの表記

このマニュアルでは，EURの各製品について，次のように表記しています。

表記 |  | 製品名称
EUR Designer |  | EUR Designer
EUR Developer |  | EUR Developer
EUR Viewer |  | EUR Viewer
EUR Server | EUR Server Enterprise | EUR Server Enterprise
 | EUR Server Standard | EUR Server Standard
EUR Server - Cipher option |  | EUR Server - Cipher option
EUR Server Print Edition |  | uCosminexus EUR Server Print Edition
EUR Print Manager - Client |  | uCosminexus EUR Print Manager - Client
EUR Print Manager - Report Server |  | uCosminexus EUR Print Manager - Report Server
EUR Print Service |  | uCosminexus EUR Print Service
EUR Print Service Enterprise |  | uCosminexus EUR Print Service Enterprise
EUR Form | EUR Form Service | uCosminexus EUR Form Service
EUR Form Service - Data Store option |  | uCosminexus EUR Form Service - Data Store option

EUR以外の製品名称などについては，次のように表記しています。

表記 |  | 製品名称
BSP-RM |  | BSP-RM(R)
COBOL |  | COBOL2002
DABroker |  | DABroker 03-17以降 DABroker 03-21以降 DABroker(64) 03-20以降 DABroker(64) 03-21以降
HiRDB |  | HiRDB/Run Time Version 8 08-00 以降 HiRDB/Developer's Kit Version 8 08-00 以降 HiRDB/Run Time Version 8(64) 08-00 以降 HiRDB/Developer's Kit Version 8(64) 08-00 以降 HiRDB/Run Time Version 9 09-00以降 HiRDB/Developer's Kit Version 9 09-00以降 HiRDB/Developer's Suite Version 9 09-00以降 HiRDB/Run Time Version 9(64) 09-00以降 HiRDB/Developer's Kit Version 9(64) 09-00以降 HiRDB Server Version 9 09-00以降 HiRDB Server with Additional Function Version 9 09-00以降
IPF |  | Itanium(R) Processor Family
Linux | Linux 6 | Red Hat Enterprise Linux(R) Server 6 (64-bit x86_64)
 | Linux 7 | Red Hat Enterprise Linux(R) Server 7 (64-bit x86_64)
ODBC Driver |  | EURODBC Driver
 |  | DBPARTNER ODBC Driver 01-11以降
Oracle | Oracle 10g | Oracle 10g 10.1.0 Oracle 10g 10.2.0
 | Oracle 11g | Oracle Database 11g 11.1.0 Oracle Database 11g R2 11.2.0
SEWB+ |  | Software Engineering Workbench+
Hitachi Application Server |  | Hitachi Application Server uCosminexus Application Server uCosminexus Application Server Enterprise uCosminexus Application Server Standard
UNIX | AIX | AIX V6.1 AIX V7.1 AIX V7.2
 | HP-UX | HP-UX 11i V3(IPF)

このほか，このマニュアルでは，次に示す表記を使用しています。

  • EURの各製品を区別する必要がない場合は，総称してEURと表記します。

  • EUR Designer，EUR Developerの帳票作成機能を「EUR 帳票作成機能」と表記します。

  • EUR DeveloperのEUR Form帳票作成機能を「EUR 帳票作成機能（EUR Form帳票）」と表記します。

  • EUR Designer，EUR Developer，EUR Viewerのクライアント環境での帳票出力機能を「EUR クライアント帳票出力機能」と表記します。

  • EUR Developer，EUR Server Enterprise，EUR Server Standardのサーバ環境での帳票出力機能を「EUR サーバ帳票出力機能」と表記します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 135 / 139


付録A.5 このマニュアルで使用する略語 : EUR 帳票作成 画面リファレンス

  • 136 / 139

  • 表紙

  • 付録

  • 付録A　このマニュアルの参考情報

  • 付録A.5　このマニュアルで使用する略語

付録A.5　このマニュアルで使用する略語

このマニュアルで使用する英略語を次に示します。

英略語 | 英字での表記
API | Application Programming Interface
ASP | Active Server Pages
BOM | Byte Order Mark
COBOL | COmmon Business Oriented Language
CPI | Characters Per Inch
CSV | Comma Separated Value
DLL | Dynamic Linking Library
DPI | Dot Per Inch
EAN | European Article Number
EJB | Enterprise JavaBeans
EMF | Enhanced Metafile
EOF | End Of File
EUR | End-User Reporting
GIF | Graphics Interchange Format
GUI | Graphical User Interface
HTTP | Hyper Text Transfer Protocol
ID | IDentifier
IPF | Itanium(R) Processor Family
ISO | International Organization for Standardization
JAN | Japanese Article Number
JDK | JavaTM Development Kit
JIS | Japanese Industrial Standards
JPEG | Joint Photographic Experts Group
JSP | Java Server Pages
LAN | Local Area Network
LIPS | LBP Image Processing System
LPI | Lines Per Inch
MFC | Microsoft Foundation Class
MIME | Multipurpose Internet Mail Extension
MSI | Microsoft Windows Installer
MUI | Multi User Interface
OCR | Optical Character Reader
OCX | OLE Custom Control (OLE Control eXtension)
ODBC | Open Database Connectivity
OLE | Object Linking and Embedding
PCF | Portable Compiled Format
PDF | Portable Document Format
PDL | Page Description Language
PNG | Portable Network Graphics
RPM | RPM Package Manager
TIFF | Tagged Image File Format
UAP | User Application Program
UPC | Universal Product Code
WAN | Wide Area Network
XML | eXtensible Mark-up Language

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 136 / 139


付録A.6 KB（キロバイト）などの単位表記について : EUR 帳票作成 画面リファレンス

  • 137 / 139

  • 表紙

  • 付録

  • 付録A　このマニュアルの参考情報

  • 付録A.6　KB（キロバイト）などの単位表記について

付録A.6　KB（キロバイト）などの単位表記について

1KB（キロバイト），1MB（メガバイト），1GB（ギガバイト），1TB（テラバイト）はそれぞれ1,024バイト，1,0242バイト，1,0243バイト，1,0244バイトです。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 137 / 139


索引 : EUR 帳票作成 画面リファレンス

  • 138 / 139

  • 表紙

  • 索引

索引

  • E W

  • あ行 か行 さ行 た行 は行 ま行 や行 ら行

E

  • ［EURユーザ環境削除］ダイアログ

  • ［EURログオプションの設定］ダイアログ

  • ［EURログメンテナンスツール］ダイアログ

ページの先頭へ

W

  • ［Word/Excel文書の変換］ダイアログ

ページの先頭へ

あ行

あ

  • ［アイテムの表示条件］ダイアログ

  • ［アイテムのプロパティ］ダイアログ

い

  • ［位置・サイズ］タブ〔［アイテムのプロパティ］ダイアログ〕

  • ［位置・サイズ］タブ〔［部品アイテムのプロパティ］ダイアログ〕

  • ［印刷時刻］ダイアログ

  • ［印刷日付］ダイアログ

お

  • ［置き換え表］タブ〔［アイテムのプロパティ］ダイアログ〕

  • ［置き換え表］タブ〔［レポートのプロパティ］ダイアログ〕

  • ［オプション］ダイアログ

ページの先頭へ

か行

か

  • ［改ブロック／改ページ一覧］ダイアログ

  • ［画像］タブ〔［アイテムのプロパティ］ダイアログ〕

  • ［画像］タブ〔［オプション］ダイアログ〕

  • 空レコードを無視する

き

  • ［基準レコード幅変更］ダイアログ

  • ［禁則文字］タブ

く

  • ［区切り情報］（位置）タブ〔［データのプロパティ］ダイアログ〕

  • ［区切り情報］（コンマ）タブ〔［データのプロパティ］ダイアログ〕

  • ［繰り返し個数指定］ダイアログ

  • ［繰り返し設定］ダイアログ

  • グリッドの縦の間隔をLPIで指定する

  • グリッドの横の間隔をCPIで指定する

ページの先頭へ

さ行

し

  • 指数表示〔［表示形式］タブ〕

  • ［下敷きの設定］ダイアログ

  • ［集計アイテム］ダイアログ

  • ［出力ページ］タブ〔［アイテムのプロパティ］ダイアログ〕

  • ［情報］タブ〔［部品アイテムのプロパティ］ダイアログ〕

す

  • ［ズーム］ダイアログ

  • ［図形］タブ〔［アイテムのプロパティ］ダイアログ〕

  • ［図形］タブ〔［オプション］ダイアログ〕

せ

  • 設定できる余白のサイズ

  • ［線］タブ〔［アイテムのプロパティ］ダイアログ〕

  • ［線］タブ〔［オプション］ダイアログ〕

ページの先頭へ

た行

た

  • 縦方向の繰り返し間隔をLPIで指定する

ち

  • ［帳票定義情報ファイルの入出力］ダイアログ

つ

  • ［ツールバー］ダイアログ

て

  • ［データウィンドウ］タブ〔［オプション］ダイアログ〕

  • ［データキャラクタ］タブ〔［アイテムのプロパティ］ダイアログ〕

  • ［データ情報］タブ〔［データのプロパティ］ダイアログ〕

  • ［データソースの選択］ダイアログ

  • ［データ］タブ〔［アイテムのプロパティ］ダイアログ〕

  • ［データのプロパティ］ダイアログ

ページの先頭へ

は行

は

  • ［バーコード］タブ〔［アイテムのプロパティ］ダイアログ〕

  • ［バーコード］タブ〔［オプション］ダイアログ〕

  • ［配置］タブ〔［アイテムのプロパティ］ダイアログ〕

  • ［配置］タブ〔［オプション］ダイアログ〕

ひ

  • ［表示形式］（集計内容）タブ〔［アイテムのプロパティ］ダイアログ〕

  • ［表示形式］（日付・時刻データ）タブ〔［アイテムのプロパティ］ダイアログ〕

  • ［表示形式］（ページ番号）タブ〔［アイテムのプロパティ］ダイアログ〕

  • ［表示形式］（文字列・数値データ）タブ〔［アイテムのプロパティ］ダイアログ〕

  • ［表示］タブ〔［オプション］ダイアログ〕

ふ

  • ［ファイル］タブ〔［オプション］ダイアログ〕

  • ［フィールド定義情報自動作成］ダイアログ

  • ［フィールド定義情報変更］ダイアログ

  • ［フィールド定義］ダイアログ

  • ［フィールド表示幅設定］ダイアログ

  • ［フォント］タブ〔［アイテムのプロパティ］ダイアログ〕

  • ［部品アイテムのプロパティ］ダイアログ

  • ［部品の登録］ダイアログ

  • ［部品の名称］ダイアログ

  • 部品パレットウィンドウ

へ

  • ページ番号アイテムの表示形式

  • ［ページ番号］ダイアログ

ページの先頭へ

ま行

ま

  • ［まとめ表示］ダイアログ

め

  • メインフレームで出力していた帳票を移行する

    • グリッドの縦の間隔をLPIで指定する

    • グリッドの横の間隔をCPIで指定する

    • 縦方向の繰り返し間隔をLPIで指定する

    • 文字ピッチをCPIで指定する

も

  • ［文字］タブ

  • ［文字配置］タブ〔［アイテムのプロパティ］ダイアログ〕

  • ［文字配置］タブ〔［オプション］ダイアログ〕

  • 文字ピッチをCPIで指定する

ページの先頭へ

や行

よ

  • ［用紙の設定］ダイアログ

ページの先頭へ

ら行

れ

  • ［レポートの構成］タブ〔［レポートのプロパティ］ダイアログ〕

  • ［レポートのプロパティ］ダイアログ

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 138 / 139


マニュアル発行元 : EUR 帳票作成 画面リファレンス

  • 139 / 139

  • 表紙

  • マニュアル発行元

マニュアル発行元

株式会社 日立製作所

〒100‒8280　東京都千代田区丸の内一丁目6番6号

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 139 / 139


目次 : EUR 帳票作成 画面リファレンス

  • 2 / 139

  • 表紙

  • 目次

目次

  • 前書き

  • 変更内容

  • はじめに

  • 1.　データウィンドウのダイアログ

    • 1.1　［フィールド定義］ダイアログ

      • 1.1.1　［フィールド定義］ダイアログで設定できる項目

      • 1.1.2　画面図

    • 1.2　［フィールド定義情報自動作成］ダイアログ

      • 1.2.1　［フィールド定義情報自動作成］ダイアログで設定できる項目

      • 1.2.2　画面図

    • 1.3　［フィールド定義情報変更］ダイアログ

      • 1.3.1　［フィールド定義情報変更］ダイアログで設定できる項目

      • 1.3.2　画面図

    • 1.4　［フィールド表示幅設定］ダイアログ

      • 1.4.1　［フィールド表示幅設定］ダイアログで設定できる項目

      • 1.4.2　画面図

    • 1.5　［基準レコード幅変更］ダイアログ

      • 1.5.1　［基準レコード幅変更］ダイアログで設定できる項目

      • 1.5.2　画面図

    • 1.6　［データのプロパティ］ダイアログ

      • 1.6.1　［データ情報］タブ

      • 1.6.2　［区切り情報］（コンマ）タブ

      • 1.6.3　［区切り情報］（位置）タブ

    • 1.7　［データソースの選択］ダイアログ

      • 1.7.1　［データソースの選択］ダイアログで設定できる項目

      • 1.7.2　画面図

  • 2.　帳票ウィンドウのダイアログ

    • 2.1　［レポートのプロパティ］ダイアログ

      • 2.1.1　［レポートの構成］タブ

      • 2.1.2　［置き換え表］タブ

      • 2.1.3　［禁則文字］タブ

    • 2.2　［下敷きの設定］ダイアログ

      • 2.2.1　［下敷きの設定］ダイアログで設定できる項目

      • 2.2.2　画面図

    • 2.3　［用紙の設定］ダイアログ

      • 2.3.1　［用紙の設定］ダイアログで設定できる項目

      • 2.3.2　画面図

    • 2.4　［アイテムのプロパティ］ダイアログ

      • 2.4.1　［データ］タブ

      • 2.4.2　［表示形式］（集計内容）タブ

      • 2.4.3　［表示形式］（文字列・数値データ）タブ

      • 2.4.4　［表示形式］（日付・時刻データ）タブ

      • 2.4.5　［表示形式］（ページ番号）タブ

      • 2.4.6　［配置］タブ

      • 2.4.7　［フォント］タブ

      • 2.4.8　［線］タブ

      • 2.4.9　［図形］タブ

      • 2.4.10　［画像］タブ

      • 2.4.11　［バーコード］タブ

      • 2.4.12　［データキャラクタ］タブ

      • 2.4.13　［文字配置］タブ

      • 2.4.14　［位置・サイズ］タブ

      • 2.4.15　［出力ページ］タブ

      • 2.4.16　［置き換え表］タブ

    • 2.5　［アイテムの表示条件］ダイアログ

      • 2.5.1　［アイテムの表示条件］ダイアログで設定できる項目

      • 2.5.2　画面図

    • 2.6　［部品アイテムのプロパティ］ダイアログ

      • 2.6.1　［位置・サイズ］タブ

      • 2.6.2　［情報］タブ

    • 2.7　［ツールバー］ダイアログ

      • 2.7.1　［ツールバー］ダイアログで設定できる項目

      • 2.7.2　画面図

    • 2.8　［ズーム］ダイアログ

      • 2.8.1　［ズーム］ダイアログで設定できる項目

      • 2.8.2　画面図

    • 2.9　［ページ番号］ダイアログ

      • 2.9.1　［ページ番号］ダイアログで設定できる項目

      • 2.9.2　画面図

    • 2.10　［印刷日付］ダイアログ

      • 2.10.1　［印刷日付］ダイアログで設定できる項目

      • 2.10.2　画面図

    • 2.11　［印刷時刻］ダイアログ

      • 2.11.1　［印刷時刻］ダイアログで設定できる項目

      • 2.11.2　画面図

    • 2.12　［繰り返し個数指定］ダイアログ

      • 2.12.1　［繰り返し個数指定］ダイアログで設定できる項目

      • 2.12.2　画面図

    • 2.13　［まとめ表示］ダイアログ

      • 2.13.1　［まとめ表示］ダイアログで設定できる項目

      • 2.13.2　画面図

    • 2.14　［改ブロック／改ページ一覧］ダイアログ

      • 2.14.1　［改ブロック／改ページ一覧］ダイアログで設定できる項目

      • 2.14.2　画面図

    • 2.15　［繰り返し設定］ダイアログ

      • 2.15.1　［繰り返し設定］ダイアログで設定できる項目

      • 2.15.2　画面図

    • 2.16　［集計アイテム］ダイアログ

      • 2.16.1　［集計アイテム］ダイアログで設定できる項目

      • 2.16.2　画面図

    • 2.17　［オプション］ダイアログ

      • 2.17.1　［表示］タブ

      • 2.17.2　［配置］タブ

      • 2.17.3　［文字］タブ

      • 2.17.4　［線］タブ

      • 2.17.5　［図形］タブ

      • 2.17.6　［画像］タブ

      • 2.17.7　［バーコード］タブ

      • 2.17.8　［ファイル］タブ

      • 2.17.9　［文字配置］タブ

      • 2.17.10　［データウィンドウ］タブ

    • 2.18　部品パレットウィンドウ

      • 2.18.1　部品パレットウィンドウのメニュー

      • 2.18.2　部品パレットウィンドウで設定できる項目

      • 2.18.3　画面図

    • 2.19　［部品の登録］ダイアログ

      • 2.19.1　［部品の登録］ダイアログで設定できる項目

      • 2.19.2　画面図

    • 2.20　［部品の名称］ダイアログ

      • 2.20.1　［部品の名称］ダイアログで設定できる項目

      • 2.20.2　画面図

  • 3.　実行ファイルまたはスタートメニューから表示するダイアログ

    • 3.1　［EURログオプションの設定］ダイアログ

      • 3.1.1　［EURログオプションの設定］ダイアログで設定できる項目

      • 3.1.2　画面図

    • 3.2　［EURログメンテナンスツール］ダイアログ

      • 3.2.1　［EURログメンテナンスツール］ダイアログで設定できる項目

      • 3.2.2　画面図

    • 3.3　［EURユーザ環境削除］ダイアログ

      • 3.3.1　［EURユーザ環境削除］ダイアログで設定できる項目

      • 3.3.2　画面図

    • 3.4　［Word/Excel文書の変換］ダイアログ

      • 3.4.1　［Word/Excel文書の変換］ダイアログで設定できる項目

      • 3.4.2　画面図

    • 3.5　［帳票定義情報ファイルの入出力］ダイアログ

      • 3.5.1　［帳票定義情報ファイルの入出力］ダイアログで設定できる項目

      • 3.5.2　画面図

  • 付録

    • 付録A　このマニュアルの参考情報

      • 付録A.1　関連マニュアル

      • 付録A.2　EUR バージョン10での製品体系の変更

      • 付録A.3　EUR バージョン10でのマニュアル体系の変更

      • 付録A.4　このマニュアルでの表記

      • 付録A.5　このマニュアルで使用する略語

      • 付録A.6　KB（キロバイト）などの単位表記について

  • 索引

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 2 / 139