EUR 帳票作成 操作ガイド

  • 目次

  • 索引

  • 前へ

  • 1 / 356

  • 次へ

EUR 帳票作成 操作ガイド

3021-7-003-20

目次ダイジェスト

  • 前書き

  • 変更内容

  • はじめに

  • 1.　帳票作成の概要

  • 2.　用紙を設定する

  • 3.　データを読み込む

  • 4.　帳票のレイアウトを決める

  • 5.　表を作成する

  • 6.　帳票上でデータを集計する

  • 7.　帳票の表紙ページを作成する

  • 8.　貼り付けたデータを帳票上でカスタマイズする

  • 9.　複数様式の帳票の出力定義をツールで作成する

  • 10.　プレプリント用紙に合わせて帳票を作成する

  • 11.　Word/Excelで作成した帳票を変換する

  • 12.　作成したアイテムを部品化して再利用する

  • 13.　アイテムのプロパティとオプションを設定する

  • 14.　帳票を保存する

  • 15.　作成した帳票の情報をインポート，エクスポートする

  • 16.　帳票作成の注意事項

  • 付録

  • 索引

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 1 / 356

  • 次へ

  • 商品名称に関する表示

  • マニュアル発行元

All Rights Reserved. Copyright (C) 2014, 2017, Hitachi, Ltd.

All Rights Reserved. Copyright (C) 2014, 2017, Hitachi Solutions, Ltd.


前書き : EUR 帳票作成 操作ガイド

  • 3 / 356

  • 次へ

  • 表紙

  • 前書き

前書き

■ 対象製品

●適用OS：Windows 7 x86，Windows 7 x64※1，Windows 8.1 x86※2，Windows 8.1 x64※1※2，Windows 10 x86※2，Windows 10 x64※1※2

  • P-2CD2-56A4 EUR Designer 10-40

  • P-2CD2-5DA4 EUR Developer※3 10-40

  • P-2CD2-53A4 EUR Viewer 10-40

●適用OS：Windows Server 2008，Windows Server 2012

  • P-29D2-59A4 EUR Server Standard※4 10-40

  • P-29D2-5EA4 EUR Server Enterprise※4 10-40

  • P-29D2-5CA4 EUR Server - Cipher option 10-30

●適用OS：HP-UX 11i V3(IPF)

  • P-1JD2-59A1 EUR Server Standard 10-10

  • P-1JD2-5EA1 EUR Server Enterprise 10-10

  • P-1JD2-5CA1 EUR Server - Cipher option 10-00

●適用OS：AIX V6.1，AIX V7.1，AIX V7.2

  • P-1MD2-59A1 EUR Server Standard 10-10

  • P-1MD2-5EA1 EUR Server Enterprise 10-10

  • P-1MD2-5CA1 EUR Server - Cipher option 10-00

●適用OS：Linux 6，Linux 7

  • P-82D2-59A1 EUR Server Standard 10-10

  • P-82D2-5EA1 EUR Server Enterprise 10-10

  • P-82D2-5CA1 EUR Server - Cipher option 10-00

注※1

    WOW64（Windows On Windows 64）環境だけで使用できます。

注※2

    Modern UIには対応していません。

注※3

    次に示す製品を同梱しています。

    ・P-2463-2354　　DABroker

注※4

    次に示す製品を同梱しています。

    ・P-2963-2354　　DABroker(64)

これらの製品は，ISO9001およびTickITの認証を受けた品質マネジメントシステムで開発されました。

■ 輸出時の注意

本製品を輸出される場合には、外国為替及び外国貿易法の規制並びに米国輸出管理規則など外国の輸出関連法規をご確認の上、必要な手続きをお取りください。

なお、不明な場合は、弊社担当営業にお問い合わせください。

■ 商標類

HITACHI，DABroker，DBPARTNER，EUR，Groupmax，HiRDB，JP1，SEWB，TPBroker，uCosminexusは，株式会社 日立製作所の商標または登録商標です。

ActiveXは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

IBM，AIXは，世界の多くの国で登録されたInternational Business Machines Corporationの商標です。

Internet Explorerは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

Itaniumは，アメリカ合衆国および / またはその他の国におけるIntel Corporationの商標です。

Linuxは，Linus Torvalds氏の日本およびその他の国における登録商標または商標です。

MicrosoftおよびMS-DOSは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

MicrosoftおよびSQL Serverは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

MicrosoftおよびVisual Basicは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

MicrosoftおよびVisual C++は，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

Microsoft .NET は，お客様，情報，システムおよびデバイスを繋ぐソフトウェアです。

Microsoft OfficeおよびExcelは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

Microsoft Office Wordは，米国Microsoft Corporation の商品名称です。

ODBCは，米国Microsoft Corporationが提唱するデータベースアクセス機構です。

OLEは，米国Microsoft Corporationが開発したソフトウェア名称です。

OracleとJavaは，Oracle Corporation 及びその子会社，関連会社の米国及びその他の国における登録商標です。

PostScriptは，米国でのAdobe Systems, Inc.の商標です。

Red Hatは，米国およびその他の国でRed Hat, Inc.の登録商標もしくは商標です。

RSAおよびBSAFEは，米国EMC コーポレーションの米国およびその他の国における商標または登録商標です。

UNIXは，The Open Groupの米国ならびに他の国における登録商標です。

Windowsは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

Windows Serverは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

本製品は，米国EMC コーポレーションのRSA BSAFE(R)ソフトウェアを搭載しています。

This product includes software developed by the Apache Software Foundation (http://www.apache.org/).

This product includes software developed by Ben Laurie for use in the Apache-SSL HTTP server project.

Portions of this software were developed at the National Center for Supercomputing Applications (NCSA) at the University of Illinois at Urbana-Champaign.

This product includes software developed by the University of California, Berkeley and its contributors.

This software contains code derived from the RSA Data Security Inc. MD5 Message-Digest Algorithm, including various modifications by Spyglass Inc., Carnegie Mellon University, and Bell Communications Research, Inc (Bellcore).

Regular expression support is provided by the PCRE library package, which is open source software, written by Philip Hazel, and copyright by the University of Cambridge, England. The original software is available from ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/

This product includes software developed by Ralf S. Engelschall <rse@engelschall.com> for use in the mod_ssl project (http://www.modssl.org/).

This product includes software developed by IAIK of Graz University of Technology.

This product includes software developed by Daisuke Okajima and Kohsuke Kawaguchi (http://relaxngcc.sf.net/).

This product includes software developed by the Java Apache Project for use in the Apache JServ servlet engine project (http://java.apache.org/).

This product includes software developed by Andy Clark.

その他記載の会社名，製品名は，それぞれの会社の商標もしくは登録商標です。

■ マイクロソフト製品のスクリーンショットの使用について

マイクロソフトの許可を得て使用しています。

■ マイクロソフト製品の表記について

このマニュアルでは，マイクロソフト製品の名称を次のように表記しています。

表記 |  |  | 製品名称
.NET |  |  | Microsoft(R) .NET
ActiveX |  |  | ActiveX(R)
Excel |  |  | Microsoft(R) Office Excel 2007 Microsoft(R) Office Excel 2010 Microsoft(R) Office Excel 2013
Internet Explorer |  |  | Windows(R) Internet Explorer(R)
SQL Server |  |  | Microsoft(R) SQL Server 2008 Microsoft(R) SQL Server 2008 R2 Microsoft(R) SQL Server 2012
VBScript |  |  | Microsoft(R) Visual Basic(R) Scripting Edition
Visual Basic |  |  | Microsoft(R) Visual Basic(R)
Visual C++ |  |  | Microsoft(R) Visual C++(R)
Windows | Windows 7 | Windows 7 x86 | Microsoft(R) Windows(R) 7 Professional(32ビット版) Microsoft(R) Windows(R) 7 Enterprise(32ビット版) Microsoft(R) Windows(R) 7 Ultimate(32ビット版)
 |  | Windows 7 x64 | Microsoft(R) Windows(R) 7 Professional(64ビット版) Microsoft(R) Windows(R) 7 Enterprise(64ビット版) Microsoft(R) Windows(R) 7 Ultimate(64ビット版)
 | Windows 8 | Windows 8 x86 | Windows(R) 8 Pro(32ビット版) Windows(R) 8 Enterprise(32ビット版)
 |  | Windows 8 x64 | Windows(R) 8 Pro(64ビット版) Windows(R) 8 Enterprise(64ビット版)
 | Windows 8.1 | Windows 8.1 x86 | Windows(R) 8.1 Pro(32ビット版) Windows(R) 8.1 Enterprise(32ビット版)
 |  | Windows 8.1 x64 | Windows(R) 8.1 Pro(64ビット版) Windows(R) 8.1 Enterprise(64ビット版)
 | Windows 10 | Windows 10 x86 | Windows(R) 10 Pro(32ビット版) Windows(R) 10 Enterprise(32ビット版)
 |  | Windows 10 x64 | Windows(R) 10 Pro(64ビット版) Windows(R) 10 Enterprise(64ビット版)
 | Windows Server 2008 |  | Microsoft(R) Windows Server(R) 2008 R2 Standard Microsoft(R) Windows Server(R) 2008 R2 Enterprise Microsoft(R) Windows Server(R) 2008 R2 Datacenter
 | Windows Server 2012 |  | Microsoft(R) Windows Server(R) 2012 Standard Microsoft(R) Windows Server(R) 2012 Datacenter Microsoft(R) Windows Server(R) 2012 R2 Standard Microsoft(R) Windows Server(R) 2012 R2 Datacenter
Word |  |  | Microsoft(R) Office Word 2007 Microsoft(R) Office Word 2010 Microsoft(R) Office Word 2013

■ 発行

2017年3月　3021-7-003-20

■ 著作権

All Rights Reserved. Copyright (C) 2014, 2017, Hitachi, Ltd.

All Rights Reserved. Copyright (C) 2014, 2017, Hitachi Solutions, Ltd.

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 3 / 356


変更内容 : EUR 帳票作成 操作ガイド

  • 4 / 356

  • 表紙

  • 変更内容

変更内容

変更内容（3021-7-003-20）

EUR Designer　10-40

EUR Developer　10-40

EUR Viewer　10-40

EUR Server Standard　10-40

EUR Server Enterprise　10-40

追加・変更内容

変更個所

EUR Server Standard，EUR Server Enterpriseの適用OSに次のOSを追加しました。

  • AIX V7.2

  • Linux 7

－

WordまたはExcel文書をEUR帳票に変換する場合に必要な関連ソフトウェアに，次のプログラムを追加しました。

  • Microsoft(R) Office Word 2013

  • Microsoft(R) Office Excel 2013

11.2.1，11.5

文字アイテムで下線を描画する機能を追加しました。

11.2.2(4)，13.2，13.2.1(2)，13.3，13.7，13.8，15.4.3(40)

EUR Designer，EUR Developer，EUR Viewerの適用OSからWindows 8を除外しました。

11.5

帳票作成の注意事項に，フォントに関する注意事項を追加しました。

16.2.10
（凡例）

－：該当なし

単なる誤字・脱字などはお断りなく訂正しました。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 4 / 356


はじめに : EUR 帳票作成 操作ガイド

  • 5 / 356

  • 表紙

  • はじめに

はじめに

このマニュアルは，次のEUR製品を使用して，Windows(R)環境で帳票を作成する方法について説明したものです。

  • EUR Designer

  • EUR Developer

〈はじめにの構成〉

  • 対象読者

  • このマニュアルの文法で使用する記号

  • このマニュアルのGUIの説明で使用する記号

■ 対象読者

このマニュアルは，Windows環境で帳票を作成する方を対象としています。

なお，次に示す内容を理解されていることを前提としています。

  • Windowsの基本操作

  • マニュアル「EUR システム設計ガイド」に示す入力データのフォーマット

ページの先頭へ

■ このマニュアルの文法で使用する記号

このマニュアルで使用する記号について，次に示します。

記　号

意　　味

｜

横に並べられた複数の項目に対する項目間の区切りを示し，「または」を意味します。

（例）A｜B

「A，またはBを指定する」ことを示します。

｛　｝

この記号で囲まれている複数の項目のうちから一つを選択することを示します。項目が横に並べられ，記号｜で区切られている場合は，そのうちの一つを選択します。

（例）｛A｜B｜C｝

「A，B，またはCのどれかを指定する」ことを示します。

〔　〕

この記号で囲まれている項目は省略してもよいことを示します。複数の項目が横に並べて記述されている場合には，すべてを省略するか，記号｛　｝と同じくどれか一つを選択します。

（例）〔A〕

「何も指定しない」か「Aと指定する」ことを示します。

（例）〔B｜C〕

「何も指定しない」か「B，またはCのどちらかを指定する」ことを示します。

…

記述が省略されていることを示します。この記号の直前に示された項目を繰り返し複数個指定できます。

（例）〔A〔,…〕〕

「Aのあとに，Aを複数個指定できる」ことを示します。

＿

括弧で囲まれた複数項目のうち1項目に対し使用され，括弧内のすべてを省略したときシステムが採る標準値を示します。

（例）〔A｜B｜C〕

「A，B，Cのどれも指定しなかった場合，システムはCが指定されたときと同じ処理をする」ことを示します。

ページの先頭へ

■ このマニュアルのGUIの説明で使用する記号

このマニュアルでは，次に示す記号を使用してGUIを説明しています。

記　号

意　　味

＜　＞

文字キーを表します。

＜　＞＋＜　＞

＋の前のキーを押したまま，後ろのキーを押すことを表します。

［　］

メニュー項目，ダイアログ名，ダイアログのボタンを表します。

［　］－［　］

メニュー項目を連続して選択することを表します。

（例）［ファイル］－［開く］

［ファイル］メニューから［開く］メニューを選択することを表します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 5 / 356


1. 帳票作成の概要 : EUR 帳票作成 操作ガイド

  • 6 / 356

  • 表紙

  • 1.　帳票作成の概要

1.　帳票作成の概要

この章では，帳票作成の手順，作成できる帳票の例，およびEUR 帳票作成機能の画面表示の設定方法について説明します。

〈この章の構成〉

  • 1.1　帳票作成の手順

  • 1.2　EURで作成できる帳票の例

  • 1.3　EUR 帳票作成機能の起動と終了

  • 1.4　グリッドを設定する

  • 1.5　ルーラを表示する

  • 1.6　ウィンドウ表示倍率を変更する

  • 1.7　EURのウィンドウ構成

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 6 / 356


1.1 帳票作成の手順 : EUR 帳票作成 操作ガイド

  • 7 / 356

  • 表紙

  • 1.　帳票作成の概要

  • 1.1　帳票作成の手順

1.1　帳票作成の手順

EURで帳票を作成するときには，EUR 帳票作成機能を使用します。

EURでは画面上で帳票を新規に作成するほかに，印刷用紙に合わせて作成したり，既存の帳票を活用したりできます。それぞれの手順について説明します。

〈この節の構成〉

  • 1.1.1　帳票を新規に作成する

  • 1.1.2　プレプリント用紙に合わせて帳票を作成する

  • 1.1.3　Word/Excelで作成した帳票を変換する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 7 / 356


1.1.1 帳票を新規に作成する : EUR 帳票作成 操作ガイド

  • 8 / 356

  • 表紙

  • 1.　帳票作成の概要

  • 1.1　帳票作成の手順

  • 1.1.1　帳票を新規に作成する

1.1.1　帳票を新規に作成する

  1. EURを起動する

    EUR製品のプログラムメニューから，［帳票作成］－［帳票作成機能］を選択します。EURを起動すると，メインウィンドウ（レポート編集ウィンドウ）が表示されます。

  2. データを読み込む

    帳票を設計するためのデータを読み込みます。データを読み込む方法は，次の二つがあります。

    データファイルからの読み込み

    データファイルからデータを読み込むと，データウィンドウに表示されます。EURで使用できるデータ形式の詳細については，マニュアル「EUR システム設計ガイド」を参照してください。

    データベースからの読み込み

    EUR 帳票作成機能からデータベースに接続して，データを読み込むことができます。データベースからの読み込み方法の詳細については，マニュアル「EUR データベース連携ガイド」を参照してください。

    また，データはまだ用意できない状況で帳票を先に作成しておきたいときには，サンプルデータを使用できます。この場合は，データを読み込む操作は必要ありません。

  3. フィールド定義を確認・変更する

    読み込んだデータの列のまとまり（フィールド）について，フィールド名称と属性を設定します。属性によって設定できるプロパティが変わるので，データ読み込み時にフィールド名とフィールド属性を確認して，適切な属性に変更する必要があります。

  4. 帳票を定義する

    帳票上にアイテムを配置したり，データを貼り付けたりして帳票を定義します。

    アイテムとは，文字，罫線のほか，帳票に配置する角丸四角形や，円などの図形，網掛け，画像データ，バーコードのことです。貼り付けられたデータもアイテムとして扱います。

  5. 帳票を確認して保存する

    作成した帳票を確認し，保存します。EURの帳票ファイル（*.fms）が作成されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 8 / 356


1.1.2 プレプリント用紙に合わせて帳票を作成する : EUR 帳票作成 操作ガイド

  • 9 / 356

  • 表紙

  • 1.　帳票作成の概要

  • 1.1　帳票作成の手順

  • 1.1.2　プレプリント用紙に合わせて帳票を作成する

1.1.2　プレプリント用紙に合わせて帳票を作成する

プレプリント用紙に合わせて帳票を作成する場合，作成する帳票の下に手本（下敷き）を敷いて，それを目安にしながら帳票を作成できます。既存の帳票をEURで作成し直す場合にも，下敷きを使用すれば簡単に作成できます。

  1. 下敷き用の画像ファイルを作成する

    下敷きにしたい帳票をスキャナなどで読み込んで，画像ファイルを作成しておきます。

    EURで使用できる画像ファイルの形式については，マニュアル「EUR システム設計ガイド」を参照してください。

  2. 画像ファイルをEURに読み込む

    ［下敷きの設定］ダイアログで，1.で作成した画像ファイルを読み込みます。

  3. 下敷きに沿って帳票を定義する

    読み込んだ画像ファイルが帳票ウィンドウに表示されるので，表示に合わせて帳票を定義します。

  4. 帳票を確認して保存する

    作成した帳票を確認し，保存します。EURの帳票ファイル（*.fms）が作成されます。

下敷きの設定に関する詳細は，「10.　プレプリント用紙に合わせて帳票を作成する」も参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 9 / 356


1.1.3 Word/Excelで作成した帳票を変換する : EUR 帳票作成 操作ガイド

  • 10 / 356

  • 表紙

  • 1.　帳票作成の概要

  • 1.1　帳票作成の手順

  • 1.1.3　Word/Excelで作成した帳票を変換する

1.1.3　Word/Excelで作成した帳票を変換する

Word文書（*.doc / *.docx）やExcel文書（*.xls / *.xlsx）で作成した帳票を，EURの帳票ファイル（*.fms）に変換できます。

  1. Word/Excel文書を修正する

    変換元となるWord/Excel文書の形式によっては，事前に修正する必要があります。EURで変換しやすいように，帳票を修正しておきます。

  2. 変換時に使用するプリンタドライバを設定する

    Word/Excel文書の変換用のプリンタを追加し，プリンタドライバのEMFスプールを設定します。

  3. Word/Excel文書を変換する

    ［Word/Excel文書の変換］ダイアログで，Word/Excel文書を変換します。

    変換時には2.で設定したプリンタを通常使うプリンタに設定しておいてください。

  4. 変換した帳票ファイルを確認・修正する

    EUR 帳票作成機能で帳票を開いて変換後のファイルを確認し，必要に応じてレイアウトを修正します。

    なお，Word/Excel文書に設定されている種別と属性の情報の一部は帳票ファイルにも引き継がれます。

Word/Excelで作成した帳票の変換に関する詳細は，「11.　Word/Excelで作成した帳票を変換する」も参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 10 / 356


1.2 EURで作成できる帳票の例 : EUR 帳票作成 操作ガイド

  • 11 / 356

  • 表紙

  • 1.　帳票作成の概要

  • 1.2　EURで作成できる帳票の例

1.2　EURで作成できる帳票の例

EURでは，さまざまな形式の帳票を作成できます。ここでは，帳票の特徴と使用されている機能について，幾つかの帳票を例にして説明します。

〈この節の構成〉

  • 1.2.1　EURで提供するサンプル帳票

  • 1.2.2　表紙のある帳票

  • 1.2.3　複数様式の帳票（複数の様式・出力用データを組み合わせた形式）

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 11 / 356


1.2.1 EURで提供するサンプル帳票 : EUR 帳票作成 操作ガイド

  • 12 / 356

  • 表紙

  • 1.　帳票作成の概要

  • 1.2　EURで作成できる帳票の例

  • 1.2.1　EURで提供するサンプル帳票

1.2.1　EURで提供するサンプル帳票

EURで提供しているサンプル帳票は，「インストール先フォルダ\Sample\Reports」および「インストール先フォルダ\Sample\Reports2」下に格納されています。

サンプル帳票で使用している主な機能の一覧を次に示します。

表1‒1 「Reports」下にインストールされるサンプル帳票の種類
サンプル帳票名 | 使用している主な機能およびアイテム
DM葉書.fms | 楕円アイテム
pet.fms | 後付加文字，改ページ［初期化あり］，画像データの貼り付け
Report1.fms | 負符号文字，コンマ表示，繰り返し定義，まとめ表示，n行ごと網掛け，改ブロック，キー集計（合計），総集計（合計）
table.fms
カタログ.fms | 印刷日付アイテム，ページ番号アイテム
ツアー計画.fms | まとめ表示
パート.fms | 前付加文字
プロフィール.fms | 改ページ［初期化なし］，後付加文字，コンマ表示
宛名ラベル.fms | バーコード（カスタマバーコード）
家族.fms | 改ページ［初期化あり］
課別名簿.fms | 改ブロック，改ページ［初期化あり］
勘定元帳.fms | 前付加文字，桁数を指定，総集計（合計）
給料台帳.fms | 改ブロック
系列協力.fms | 改ページ［初期化あり］
見積依頼.fms | 繰り返し定義
見積単価.fms | 印刷日時アイテム，ページ番号アイテム，コンマ表示
見積明細.fms | コンマ表示
採用者.fms | 印刷日時アイテム，ページ番号アイテム
作業状況.fms | 改ブロック，キー集計（合計）
支給通知.fms | コンマ表示
事故保険.fms | 後付加文字，コンマ表示，桁数を指定
辞令任命.fms | 繰り返し定義
受講票.fms | 角丸四角アイテム，改ページ［初期化あり］
従業員勤務歴１（複数様式帳票例２）.fms | 複数様式帳票
従業員勤務歴１－次紙（複数様式帳票例２）.fms
従業員勤務歴２（複数様式帳票例２）.fms
職歴.fms | コンマ表示，改ページ［初期化あり］
精算確認.fms | キー集計（合計）
精算明細.fms | 改ブロック，キー集計（合計）
請求書.fms | 固定形式の表，n行ごと網掛け，キー集計（件数，合計）
退職金.fms | 繰り返し定義
退職者.fms | 改ページ［初期化あり］
注文書.fms | コンマ表示，印刷日時アイテム
注文書２.fms | コンマ表示，印刷日時アイテム，ページ番号アイテム
通勤定期.fms | コンマ表示，後付加文字，改ブロック
訂正通知.fms | コンマ表示，印刷日時アイテム，ページ番号アイテム
伝票.fms | 角丸四角アイテム，バーコード（カスタマバーコード），コンマ表示，後付加文字
電話帳.fms | 改ブロック
納品書.fms | バーコード（CODE128，QRコード）
納品伝票.fms | コンマ表示，前付加文字，キー集計（合計）
納品伝票２.fms | 帳票ヘッダ，改ページ［初期化あり］，キー集計（合計）
派遣管理.fms | 改ブロック，改ページ［初期化あり］，キー集計（合計，平均）
買掛.fms | 桁数を指定，キー集計（合計，件数）
表紙次紙形式の帳票.fms | 帳票ヘッダ集計（合計），まとめ表示，n行ごと網掛け，バーコード（カスタマバーコード），コンマ表示，改ページ［初期化あり］
表紙次紙形式の帳票＿次紙（複数様式帳票例１）.fms | 複数様式帳票，n行ごと網掛け，バーコード（カスタマバーコード），複数フィールドのキー集計（合計）
表紙次紙形式の帳票＿表紙（複数様式帳票例１）.fms
保険申込書（複数様式帳票例３）.fms | 複数様式帳票，角丸四角アイテム，コンマ表示，後付加文字，改ページ［初期化あり］
保険申込書＿契約者控（複数様式帳票例３）.fms
保険申込書＿代理店控（複数様式帳票例３）.fms
葉書表.fms | バーコード（カスタマバーコード）
履歴.fms | 印刷日時アイテム，ページ番号アイテム，改ページ［初期化あり］
旅費精算.fms | まとめ表示，改ページ［初期化あり］，キー集計（合計）
表1‒2 「Reports2」下にインストールされるサンプル帳票の種類
サンプル帳票名 | 使用している主な機能およびアイテム
01-01 表紙次紙形式の帳票＿表紙（複数様式帳票例１）.fms | 複数様式帳票，n行ごと網掛け，バーコード（カスタマバーコード），複数フィールドのキー集計（合計）
01-02 表紙次紙形式の帳票＿次紙（複数様式帳票例１）.fms
02-01 保険申込書（複数様式帳票例３）.fms | 複数様式帳票，角丸四角アイテム，コンマ表示，後付加文字，改ページ［初期化あり］
02-02 保険申込書＿代理店控（複数様式帳票例３）.fms
02-03 保険申込書＿契約者控（複数様式帳票例３）.fms
03-01 従業員勤務歴１－表紙（複数様式帳票例２）.fms | 複数様式帳票
03-02 従業員勤務歴１－次紙（複数様式帳票例２）.fms
03-03 従業員勤務歴２（複数様式帳票例２）.fms
04-01 葉書表.fms | 円アイテム，バーコード（カスタマバーコード）
04-02 DM葉書.fms | 楕円アイテム，角丸四角アイテム
06 HP_払込書.fms | バーコード（CODE128）
07-01 保険の提案書＿提案者記録.fms | 複数様式（サブ様式グループ），多角形アイテム，ページ番号，改ページ［初期化あり］，値が0の場合－（ハイフン）を表示，値が空データの場合－（ハイフン）を表示
07-02 保険の提案書＿提案書の控え.fms
07-03 保険の提案書１.fms
07-04 保険の提案書２.fms
08 納品書.fms | バーコード（CODE128，QRコード）
09 伝票.fms | 角丸四角アイテム，バーコード（カスタマバーコード），コンマ表示，後付加文字
10 Report1.fms | 負符号文字，コンマ表示，繰り返し定義，まとめ表示，n行ごと網掛け，改ブロック，キー集計（合計），総集計（合計）
11 売上実績.fms | 繰り返し定義
12 受講票.fms | 角丸四角アイテム，改ページ［初期化あり］
13 カタログ.fms | 印刷日時アイテム，ページ番号アイテム
14 見積書.fms | 繰り返し定義
15 HP_納品伝票.fms | 繰り返し定義
16 事故保険.fms | 後付加文字，コンマ表示，桁数を指定
17 課別名簿.fms | 改ブロック，改ページ［初期化あり］
18 系列協力.fms | 改ページ［初期化あり］
19 退職者.fms | 改ページ［初期化あり］
20 職歴.fms | コンマ表示，改ページ［初期化あり］
21 採用者.fms | 印刷日時アイテム，ページ番号アイテム
22 構成表.fms | 繰り返し定義
23 家族.fms | 改ページ［初期化あり］
24 パート.fms | 前付加文字
25 支給通知.fms | コンマ表示
26 作業状況.fms | 改ブロック，キー集計（合計）
27 派遣管理.fms | 繰り返し定義
28 給料台帳.fms | 繰り返し定義
29 退職金.fms | 繰り返し定義
30 給与簿.fms | 繰り返し定義
31 給与支払明細書.fms | 繰り返し定義
32 請求書.fms | 固定形式の表，n行ごと網掛け，キー集計（件数，合計）
33 見積単価.fms | 印刷日時アイテム，ページ番号アイテム，コンマ表示
34 見積明細.fms | コンマ表示
35 買掛.fms | 桁数を指定，キー集計（合計，件数）
36 精算確認.fms | キー集計（合計）
37 注文書.fms | コンマ表示，印刷日時アイテム
38 注文書.fms | コンマ表示，印刷日時アイテム，ページ番号アイテム
39 勘定元帳.fms | 前付加文字，桁数を指定，総集計（合計）
40 通勤定期.fms | コンマ表示，後付加文字，改ブロック
41 宛名ラベル.fms | バーコード（カスタマバーコード）
42 プロフィール.fms | 改ページ［初期化なし］，後付加文字，コンマ表示

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 12 / 356


1.2.2 表紙のある帳票 : EUR 帳票作成 操作ガイド

  • 13 / 356

  • 表紙

  • 1.　帳票作成の概要

  • 1.2　EURで作成できる帳票の例

  • 1.2.2　表紙のある帳票

1.2.2　表紙のある帳票

1ページ目と2ページ目以降の帳票形式が異なる帳票を，表紙のある帳票といいます。

表紙のある帳票を作成するには，帳票作成時に1ページ目だけに出力したいデータを帳票ヘッダ領域として設定します。帳票ヘッダ領域に設定した部分は2ページ目以降には出力されません。用意する帳票のテンプレートは一つですが，帳票の様式は1ページ目と2ページ目以降で異なります。

表紙のある帳票例を次に示します。

図1‒1　表紙のある帳票例

[図データ]

〈この項の構成〉

  • (1)　データの貼り付け（表紙のある帳票）

  • (2)　帳票で使用している機能（表紙のある帳票）

(1)　データの貼り付け（表紙のある帳票）

EURでは，読み込んだデータの項目をアイテムとして帳票のレイアウト上に直接貼り付けます。

読み込んだデータと帳票に貼り付けたデータとの関係を次の図に示します。

図1‒2　読み込んだデータと帳票に貼り付けたデータとの関係

[図データ]

ページの先頭へ

(2)　帳票で使用している機能（表紙のある帳票）

EURでは，直接貼り付けたデータ以外に，文字アイテム，線アイテム，および図形アイテムを配置して帳票を装飾します。

また，表紙のある帳票では，アイテムの配置以外に次の設定をします。

  • 表の設定

    1レコード分のデータを貼り付けてから，同じ項目を繰り返して表を作成するように設定します。同じデータが連続している部分（図中の「取引日」や「伝票番号」など）は，一つにまとめて表示できます。

  • 帳票ヘッダ領域の設定

    帳票ヘッダ領域を設定します。

  • 改ページのキーの設定

    データのどの項目が切り替わった時点で帳票のページを切り替えるのかを設定します。

表紙のある帳票で使用している機能について，次の図に示します。

図1‒3　表紙のある帳票で使用している機能

[図データ]

  1. 文字アイテムの配置：全帳票に同じ文字列を表示します。

  2. 角丸四角アイテムの配置：角丸四角アイテムを配置して，帳票を修飾します。

  3. 改ページのキーの設定：会社ごとのデータをまとめて出力します。

  4. ページ番号アイテムの配置：帳票のページ数を印刷します。

  5. 印刷日付アイテムの配置：帳票を出力した日付を印刷します。

  6. 網掛けアイテムの配置：図形アイテム（網掛け）を配置して，帳票を修飾します。

  7. 帳票ヘッダ領域の作成：会社ごとに，宛て先および請求額を表示する帳票ヘッダ領域を作成します。

  8. 集計アイテムの配置：購入金額の小計，消費税の合計，および請求額を表示します。

  9. 表の罫線の作成：線アイテムで表の罫線を作成します。

  10. 表の繰り返しの設定：表を構成するデータを自動的に読み込んで表を作成します。

  11. まとめ表示の設定：同じ内容を一つにまとめて表示します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 13 / 356


1.2.3 複数様式の帳票（複数の様式・出力用データを組み合わせた形式） : EUR 帳票作成 操作ガイド

  • 14 / 356

  • 表紙

  • 1.　帳票作成の概要

  • 1.2　EURで作成できる帳票の例

  • 1.2.3　複数様式の帳票（複数の様式・出力用データを組み合わせた形式）

1.2.3　複数様式の帳票（複数の様式・出力用データを組み合わせた形式）

複数の様式（帳票ファイル）や出力用データを1セットにまとめて出力する帳票を，複数様式の帳票といいます。

複数の様式を組み合わせて出力したい場合，複数様式の帳票を使用します。複数様式の帳票では，帳票の様式と出力用データを対応づけることでまとめて出力できます。

複数の様式，および出力用データを組み合わせた帳票例を次に示します。

図1‒4　複数の様式，および出力用データを組み合わせた帳票の例

[図データ]

〈この項の構成〉

  • (1)　データの貼り付け（複数様式の帳票）

  • (2)　帳票で使用している機能（複数様式の帳票）

  • (3)　出力方法（複数様式の帳票）

(1)　データの貼り付け（複数様式の帳票）

この帳票では，次の2種類のデータを使用しています。

  • 従業員勤務歴カード[ I ]用のデータ

  • 従業員勤務歴カード[ II ]用のデータ

EURでは，読み込んだデータの項目をアイテムとして帳票のレイアウト上に直接貼り付けます。

従業員勤務歴カード[ I ]用のデータと，帳票に貼り付けたデータとの関係を次の図に示します。

図1‒5　読み込んだデータと，帳票に貼り付けたデータとの関係（従業員勤務歴カード[ I ]）

[図データ]

従業員勤務歴カード[ II ]用のデータと，帳票に貼り付けたデータとの関係を次の図に示します。

図1‒6　読み込んだデータと，帳票に貼り付けたデータとの関係（従業員勤務歴カード[ II ]）

[図データ]

ページの先頭へ

(2)　帳票で使用している機能（複数様式の帳票）

EURでは，直接貼り付けたデータ以外に，文字アイテム，線アイテム，および図形アイテムを配置して帳票を装飾します。また，この帳票では，日付をさまざまな形式で表しています。

複数様式の帳票で使用している機能について，次の図に示します。

図1‒7　複数様式の帳票で使用している機能

[図データ]

  1. 角丸四角アイテムの配置：角丸四角アイテムを配置して，帳票を修飾します。

  2. 文字アイテムの配置：角丸四角アイテムの上に白色の文字を配置して，帳票のタイトルを目立たせます。

  3. 表の罫線の作成：線アイテムで表の罫線を作成します。

  4. 図形アイテムの配置：表の項目名を表す欄に図形アイテム（四角アイテム）を配置し，背景色を設定して色分けします。

  5. 日付アイテムの定義：日付アイテムの年月日を「年」，「月」および「日」で区切るように定義します。

  6. 印刷日付アイテムの定義：印刷日付アイテムの前に「出力日付：」を付加し，年月日を「/」で区切るように定義します。

  7. 日付アイテムの定義：日付アイテムのあとに全角空白および「～」を付加し，年月日をピリオドで区切るように定義します。

ページの先頭へ

(3)　出力方法（複数様式の帳票）

この帳票は，次の図のように帳票ファイルを切り替えて出力します。

図1‒8　複数様式の帳票の出力順

[図データ]

出力方法の詳細については，マニュアル「EUR 帳票出力 EUR Designer/EUR Viewer編」および「EUR 帳票出力 機能解説 EUR Server編」を参照してください。

また，複数様式の帳票出力を画面上で簡単に定義することもできます。詳細は「9.　複数様式の帳票の出力定義をツールで作成する」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 14 / 356


1.3 EUR 帳票作成機能の起動と終了 : EUR 帳票作成 操作ガイド

  • 15 / 356

  • 表紙

  • 1.　帳票作成の概要

  • 1.3　EUR 帳票作成機能の起動と終了

1.3　EUR 帳票作成機能の起動と終了

EUR帳票作成機能の起動（新規作成）と終了について説明します。また，既存の帳票ファイルを開いたり，帳票ファイルのプロパティを参照したりする方法について説明します。

〈この節の構成〉

  • 1.3.1　EURを起動する（帳票の新規作成）

  • 1.3.2　既存の帳票ファイルを開く

  • 1.3.3　帳票ファイルのプロパティ表示

  • 1.3.4　EURを終了する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 15 / 356


1.3.1 EURを起動する（帳票の新規作成） : EUR 帳票作成 操作ガイド

  • 16 / 356

  • 表紙

  • 1.　帳票作成の概要

  • 1.3　EUR 帳票作成機能の起動と終了

  • 1.3.1　EURを起動する（帳票の新規作成）

1.3.1　EURを起動する（帳票の新規作成）

EURを起動します。EURを起動するには，スタートメニューの［EUR Designer］または［EUR Developer］－［帳票作成］－［帳票作成機能］を選択します。EURを起動すると，メインウィンドウ（レポート編集ウィンドウ）に新規の帳票が表示されます。

図1‒9　レポート編集ウィンドウ

[図データ]

メモ

［ファイル］－［新規作成］を選択しても，帳票を新規作成できます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 16 / 356


1.3.2 既存の帳票ファイルを開く : EUR 帳票作成 操作ガイド

  • 17 / 356

  • 表紙

  • 1.　帳票作成の概要

  • 1.3　EUR 帳票作成機能の起動と終了

  • 1.3.2　既存の帳票ファイルを開く

1.3.2　既存の帳票ファイルを開く

サンプル帳票などの既存の帳票は，次の方法のどれかで開きます。

  • EURのメニューから開く

    ［ファイル］－［開く］を選択します。［ファイルを開く］ダイアログで帳票が保存されている場所を設定します。

    帳票ファイル名を［ファイル名］テキストボックスに直接入力するか，またはダイアログの［ファイルの場所］から選択して，［開く］ボタンをクリックします。

  • 帳票ファイルをダブルクリックして開く

    帳票ファイル（*.fms）をダブルクリックすると，EURが起動し，帳票ファイルが開きます。

  • ドラッグアンドドロップして開く

    起動したEURに帳票ファイル（*.fms）をドラッグアンドドロップします。

〈この項の構成〉

  • (1)　補足説明

(1)　補足説明

  • 読み取り専用の属性を持つ帳票ファイルを開いた場合，および他プロセスで使用中の帳票ファイルを開いた場合は，タイトルバーに「ファイル名（読み取り専用）」と表示されます。

  • 帳票ファイル（*.fmsまたは*.agr）以外のファイルがドラッグアンドドロップされた場合は，エラーとなります。

  • SEWB+にログインしている場合，最上位結合項目と関連づけされているレポートファイルを開くと，最上位結合項目の更新日時がチェックされます。最上位結合項目が更新されている場合は，現在（最新）の最上位結合項目からフィールド定義情報を再作成するかどうかを問い合わせるメッセージが表示されます。その問い合わせ結果によって，動作は次のように異なります。

    • ［はい］を選択した場合

      フィールド定義情報の再作成が実施されるため，帳票に貼り付けられているデータとフィールド定義情報が一致しなくなるので，帳票の再設計が必要になることがあります。

    • ［キャンセル］を選択した場合

      レポートファイルを保管したときの最上位結合項目を基に，フィールド定義情報が作成されます。

    SEWB+にログインしていない場合は，最上位結合項目の更新の有無に関係なく，レポートファイルを保存したときの最上位結合項目を基に，フィールド定義情報が作成されます。

  • 指定されているフォントによっては，実行する環境で帳票が正しく印刷されなかったり，表示されなかったりする場合があります。詳細は，「14.3.1(1)　フォントに関する注意」を参照してください。

  • 帳票ファイルに配置された固定文字列中にタブが指定されている場合，タブを空白に置き換えて表示します。

  • 部品庫にない部品を使っている帳票ファイルを開いた場合，部品がないことを知らせるメッセージが表示されます。部品がないときも帳票ファイルは使用できますが，帳票ウィンドウには部品のアイテム枠に「部品が存在しません。」と表示されます。部品を表示する場合は，部品をインポートしてから，再度帳票ファイルを開いてください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 17 / 356


1.3.3 帳票ファイルのプロパティ表示 : EUR 帳票作成 操作ガイド

  • 18 / 356

  • 表紙

  • 1.　帳票作成の概要

  • 1.3　EUR 帳票作成機能の起動と終了

  • 1.3.3　帳票ファイルのプロパティ表示

1.3.3　帳票ファイルのプロパティ表示

帳票ファイルを設計したEUR製品のプログラムプロダクト情報とファイルの作成日時を確認できます。

帳票ファイルを設計したEUR製品のプログラムプロダクト情報を確認することで，帳票ファイルを参照，または印刷できるEUR製品のプログラムプロダクト情報を特定できます。例えば，帳票ファイルを設計したプログラムプロダクト情報に「P-2CD2-5694 EUR Designer 09-00」と表示されている場合は，インストールされている製品がバージョン09-00以降のEUR Designer，EUR DeveloperまたはEUR Viewerであれば，帳票ファイルを正しく参照，または印刷できます。

プロパティの表示手順を次に示します。

  1. プロパティ表示する帳票ファイルを選択します。

    エクスプローラ，［帳票を開く］ダイアログなどで，帳票ファイルを一つ選択します。

  2. ［EURのプロパティ］を表示します。

    ポップアップメニューから［プロパティ］を選択します。プロパティダイアログに［EURのプロパティ］タブが表示されます。

〈この項の構成〉

  • (1)　［EURのプロパティ］タブの内容

  • (2)　プロパティ表示に関する注意

(1)　［EURのプロパティ］タブの内容

ダイアログのタイトル

選択したファイルの拡張子が「*.fms」の場合は［フォームシートファイルの作成：］，「*.agr」の場合は［レポートファイルの作成：］が表示されます。

表示される内容

帳票ファイルを設計したEUR製品のプログラムプロダクト情報を次のように表示します。

P-XXXX-XXXX　　ZZZZZZZ　　VV-RR-SS

（凡例）

    P-XXXX-XXXX：製品形名

    ZZZZZZZ：製品名

    VV：バージョン　RR：リビジョン　SS：任意の情報

なお，次に示すEUR製品は，帳票ファイルを設計したEUR製品の製品形名および製品名と，プロパティに表示されるプログラムプロダクト情報の内容が異なります。ただし，バージョン（VV-RR-SS）は，帳票ファイルを設計したときのEUR製品のバージョン（VV-RR-SS）が表示されます。

帳票ファイルを設計したEUR製品

表示される製品形名と製品名

P-26D2-3214　　EUR with DB access

P-26D2-3114　　EUR

P-2651-3234　　EUR Professional Edition

P-2651-3434　　EUR Professional Edition for R/3

P-26D2-3134　　EUR

P-2651-8534　　SEWB+/EUR Professional Edition
作成日時：

帳票ファイルに保存されている作成日時情報を表示します。

ページの先頭へ

(2)　プロパティ表示に関する注意

  • 次に示す要因の場合は，プロパティダイアログに［EURのプロパティ］タブは表示されません。

    • 複数のファイルを選択した場合

    • 「*.fms」「*.agr」以外の拡張子に変更されているフォームシートファイル，またはレポートファイルである場合

    • フォームシートファイル，またはレポートファイル以外のファイルに，「*.fms」「*.agr」の拡張子が付けられている場合

  • ［EURのプロパティ］タブに表示される［作成日時：］は，ファイル内に保存されている作成日時情報なので，プロパティダイアログの［全般］タブに表示される［作成日時：］と異なる場合があります。

  • バージョン08-00以降のEUR Developerで帳票ファイルを設計した場合，プログラムプロダクト情報にはEUR Designerの情報が表示されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 18 / 356


1.3.4 EURを終了する : EUR 帳票作成 操作ガイド

  • 19 / 356

  • 表紙

  • 1.　帳票作成の概要

  • 1.3　EUR 帳票作成機能の起動と終了

  • 1.3.4　EURを終了する

1.3.4　EURを終了する

EURを終了するときは，［ファイル］－［Reportの終了］を選択します。帳票ファイル（*.fms）が保存されていない場合は，帳票ファイルを保存するかどうかを確認するメッセージが表示されます。

メモ

[図データ] ボタンをクリックしても，EURは終了します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 19 / 356


1.4 グリッドを設定する : EUR 帳票作成 操作ガイド

  • 20 / 356

  • 表紙

  • 1.　帳票作成の概要

  • 1.4　グリッドを設定する

1.4　グリッドを設定する

グリッドとは，帳票の用紙上にアイテムを配置するための格子線です。

グリッドを表示すると，アイテムを揃えたり，同じ大きさにしたりしやすくなります。グリッドのサイズは変更できます。

〈この節の構成〉

  • 1.4.1　グリッドの表示

  • 1.4.2　グリッドの属性変更

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 20 / 356


1.4.1 グリッドの表示 : EUR 帳票作成 操作ガイド

  • 21 / 356

  • 表紙

  • 1.　帳票作成の概要

  • 1.4　グリッドを設定する

  • 1.4.1　グリッドの表示

1.4.1　グリッドの表示

グリッドは，データウィンドウからデータを帳票に貼り付けたり，罫線を設定したりするときのレイアウトの目安として利用できます。また，グリッド補正を利用すると，アイテムを新規に配置したり，位置や大きさを変更したりするときに，グリッドのサイズに合わせて配置する位置や大きさを変更できます。

グリッドの表示，非表示は，［表示］－［グリッド］をクリックすることで切り替えられます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 21 / 356


1.4.2 グリッドの属性変更 : EUR 帳票作成 操作ガイド

  • 22 / 356

  • 表紙

  • 1.　帳票作成の概要

  • 1.4　グリッドを設定する

  • 1.4.2　グリッドの属性変更

1.4.2　グリッドの属性変更

グリッドのサイズと原点を変更できます。［オプション］ダイアログで変更する場合と，編集する帳票に対応した設定値に変更する場合があります。

〈この項の構成〉

  • (1)　［オプション］ダイアログで変更する

  • (2)　編集する帳票に対応した設定値に変更する

  • (3)　補足説明

(1)　［オプション］ダイアログで変更する

帳票を新規作成するときのデフォルト値は，［オプション］ダイアログの［配置］タブで変更します（変更した値は，作成済みの帳票や編集中の帳票には反映されません）。

グリッドのサイズは，［高さ］，［幅］ともに「2（mm）」が設定されています。変更できる値は，1（mm）～200（mm）です。メインフレームで出力していた帳票を移行する場合には，LPIおよびCPIでグリッドのサイズを指定することもできます。指定値などの詳細は，マニュアル「EUR 帳票作成 画面リファレンス」を参照してください。

グリッドの原点は，用紙の余白を除いた左上を基準にして「（0（mm）,0（mm））」が設定されています。変更できる値は，0（mm）～200（mm）です。

グリッドの格子線に合わせてアイテムを貼り付けたり，繰り返しを定義したりするときは，［アイテムをグリッド補正する］のチェックボックスをオンにします。チェックボックスをオフにすると，グリッドに関係なく配置できます。

ページの先頭へ

(2)　編集する帳票に対応した設定値に変更する

［レポートのプロパティ］ダイアログの［レポートの構成］タブで変更します。［レポートのプロパティ］ダイアログは，［ファイル］－［プロパティ］を選択すると表示できます。

グリッドのサイズ，グリッドの原点，およびグリッド補正の設定は，［オプション］ダイアログの［配置］タブと同じです。

ページの先頭へ

(3)　補足説明

  • グリッド表示の属性は，ファイルに保存されます。このため，次回帳票を開いた時は，保存されている情報が有効になります。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 22 / 356


1.5 ルーラを表示する : EUR 帳票作成 操作ガイド

  • 23 / 356

  • 表紙

  • 1.　帳票作成の概要

  • 1.5　ルーラを表示する

1.5　ルーラを表示する

帳票を定義するとき，ルーラを表示することで，帳票の大きさ，マウスポインタの位置，選択アイテムの位置などを確認できます。

アイテムを選択している場合，ルーラはアイテムの左上隅の位置を示し，アイテムを選択していない場合にはマウスポインタの位置を示します。

ルーラの表示，非表示は，［表示］メニューの［ルーラ］をクリックすると，切り替えられます。

〈この節の構成〉

  • 1.5.1　補足説明

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 23 / 356


1.5.1 補足説明 : EUR 帳票作成 操作ガイド

  • 24 / 356

  • 表紙

  • 1.　帳票作成の概要

  • 1.5　ルーラを表示する

  • 1.5.1　補足説明

1.5.1　補足説明

ルーラは，アイテムの座標原点を「用紙の左上」にするか，または「貼付域の左上」にするかによって，表示が異なります。アイテムの座標原点は，［オプション］ダイアログの［表示］タブで設定します。

デフォルトは，「用紙の左上」です。そのため，バージョン3以前に設計した帳票を開いた場合は，アイテムの開始位置が異なります。バージョン3以前と同じようにアイテムの開始位置を表示したい場合は，アイテムの座標原点を「貼付域の左上」に設定してください。

なお，アイテムの座標原点が「用紙の左上」または「貼付域の左上」のどちらに設定されているのかは，ステータスバーに表示されています。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 24 / 356


1.6 ウィンドウ表示倍率を変更する : EUR 帳票作成 操作ガイド

  • 25 / 356

  • 表紙

  • 1.　帳票作成の概要

  • 1.6　ウィンドウ表示倍率を変更する

1.6　ウィンドウ表示倍率を変更する

帳票ウィンドウは，表示倍率を変更できます。アイテムの表示位置を正確に調整したり，小さなサイズのアイテムを貼り付けたりするとき便利です。

表示倍率の変更は，［ズーム］ダイアログで変更する方法と，ツールバーボタンから操作する方法があります。

〈この節の構成〉

  • 1.6.1　［ズーム］ダイアログで変更する方法

  • 1.6.2　ツールバーボタンで変更する方法

  • 1.6.3　補足説明

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 25 / 356


1.6.1 ［ズーム］ダイアログで変更する方法 : EUR 帳票作成 操作ガイド

  • 26 / 356

  • 表紙

  • 1.　帳票作成の概要

  • 1.6　ウィンドウ表示倍率を変更する

  • 1.6.1　［ズーム］ダイアログで変更する方法

1.6.1　［ズーム］ダイアログで変更する方法

［ズーム］ダイアログは，［表示］－［ズーム］を選択すると，表示されます。

表示倍率は，［倍率の自動調整］のラジオボタンをクリックするか，または任意のズーム倍率をスピンボックスに指定します。

入力できる値は10～800で，デフォルトは，「100%」です。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 26 / 356


1.6.2 ツールバーボタンで変更する方法 : EUR 帳票作成 操作ガイド

  • 27 / 356

  • 表紙

  • 1.　帳票作成の概要

  • 1.6　ウィンドウ表示倍率を変更する

  • 1.6.2　ツールバーボタンで変更する方法

1.6.2　ツールバーボタンで変更する方法

ツールバーボタンのドロップダウンリストを開いて，次に示す項目から一つを選択します。

ページ全体を表示，10%，50%，75%，100%，150%，200%，400%，800%

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 27 / 356


1.6.3 補足説明 : EUR 帳票作成 操作ガイド

  • 28 / 356

  • 表紙

  • 1.　帳票作成の概要

  • 1.6　ウィンドウ表示倍率を変更する

  • 1.6.3　補足説明

1.6.3　補足説明

  • データウィンドウがアクティブになっているときでも，ツールバーボタンで表示倍率を変更すると，非アクティブの帳票ウィンドウの表示倍率が変更されます。

  • 「ページ全体を表示」は，表示されている帳票ウィンドウに対してだけ有効です。ただし，表示されている帳票ウィンドウが帳票の10%より小さい場合，帳票を10%の倍率で表示します。

  • 表示倍率を拡大しても，設定されている線の太さ，網パターンは変わりません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 28 / 356


1.7 EURのウィンドウ構成 : EUR 帳票作成 操作ガイド

  • 29 / 356

  • 表紙

  • 1.　帳票作成の概要

  • 1.7　EURのウィンドウ構成

1.7　EURのウィンドウ構成

EURを起動すると，メインウィンドウ（レポート編集ウィンドウ）が表示されます。レポート編集ウィンドウのタイトルバーには，「Hitachi Report - 帳票ファイル名」と表示されます。

図1‒10　ウィンドウ構成

[図データ]

レポート編集ウィンドウには，帳票ウィンドウとデータウィンドウが表示されます。帳票ウィンドウには，白紙の用紙が表示されます。帳票ウィンドウ，マッピングデータウィンドウ，およびユーザ定義データウィンドウをサブウィンドウといいます。

帳票ウィンドウ

マッピングデータウィンドウおよびユーザ定義データウィンドウに表示したデータや，線や固定文字などを貼り付けて，帳票を作成するウィンドウです。

マッピングデータウィンドウ

帳票に表示するデータを表形式で表示するウィンドウです。

このウィンドウに表示したデータをドラッグして，帳票ウィンドウに貼り付けます。

マッピングデータウィンドウから帳票ウィンドウにデータを貼り付ける場合，フィールド名は表の見出しとして利用し，レコードを表のデータとして利用します。

ユーザ定義データウィンドウ

直接入力した文字列（固定文字列）と同じように，帳票の全ページの同じ位置に配置するデータを表形式で表示するウィンドウです。

このウィンドウに表示したデータをドラッグして，帳票ウィンドウに貼り付けます。

帳票によって変更するタイトル，会社名，住所などの定型文字列や固定画像を帳票に入れる場合に使用します。

このウィンドウは，EURの起動時には表示されません。このウィンドウを使用する場合は，［表示］－［ユーザ定義データウィンドウ］を選択してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 29 / 356


2. 用紙を設定する : EUR 帳票作成 操作ガイド

  • 30 / 356

  • 表紙

  • 2.　用紙を設定する

2.　用紙を設定する

この章では，帳票の用紙サイズを設定および変更する方法について説明します。

〈この章の構成〉

  • 2.1　デフォルトの用紙の設定

  • 2.2　用紙の設定を変更する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 30 / 356


2.1 デフォルトの用紙の設定 : EUR 帳票作成 操作ガイド

  • 31 / 356

  • 表紙

  • 2.　用紙を設定する

  • 2.1　デフォルトの用紙の設定

2.1　デフォルトの用紙の設定

EUR 帳票作成機能を起動した場合，または［ファイル］－［新規作成］を選択した場合は，次に示すデフォルトが設定されている用紙が帳票ウィンドウに表示されます。

表2‒1 用紙のデフォルト設定
設定項目 | デフォルト
用紙サイズ | A4
印刷の向き | 縦
余白 | 上下左右各10（mm）

帳票をA4縦サイズ以外のサイズで作成したり，余白サイズを変更したりする場合は，用紙の属性を変更します。用紙の属性は，［用紙の設定］ダイアログで設定します。［用紙の設定］ダイアログは，［ファイル］－［用紙の設定］を選択すると表示できます。［用紙の設定］ダイアログについては，マニュアル「EUR 帳票作成 画面リファレンス」を参照してください。

なお，［用紙の設定］ダイアログに表示される値の単位は，［オプション］ダイアログの［表示］タブで設定されている「使用する単位」によって異なります。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 31 / 356


2.2 用紙の設定を変更する : EUR 帳票作成 操作ガイド

  • 32 / 356

  • 表紙

  • 2.　用紙を設定する

  • 2.2　用紙の設定を変更する

2.2　用紙の設定を変更する

〈この節の構成〉

  • 2.2.1　用紙サイズの変更

  • 2.2.2　用紙の向きの変更

  • 2.2.3　用紙の余白の変更

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 32 / 356


2.2.1 用紙サイズの変更 : EUR 帳票作成 操作ガイド

  • 33 / 356

  • 表紙

  • 2.　用紙を設定する

  • 2.2　用紙の設定を変更する

  • 2.2.1　用紙サイズの変更

2.2.1　用紙サイズの変更

用紙サイズを変更するには，次の二つの方法があります。

  • 用紙サイズリストから選択する

  • 独自の用紙サイズを設定する

これらの設定方法を次に示します。

〈この項の構成〉

  • (1)　用紙サイズリストから選択する

  • (2)　独自の用紙サイズを設定する

(1)　用紙サイズリストから選択する

変更する用紙サイズを［用紙サイズ］のリストボックスから選択します。設定できる用紙とそのサイズを次に示します。

表2‒2 設定できる用紙と用紙サイズ
用紙 | サイズ（幅×長さ）
A3 | 297×420 mm
A4 | 210×297 mm
A5 | 148×210 mm
レター | 8.5×11 in
リーガル | 8.5×14 in
B4 | 257×364 mm
B5 | 182×257 mm
ハガキ | 100×148 mm
10×11インチシート | 10×11 in
11×17インチシート | 11×17 in
15×11インチシート | 15×11 in
12×8.5インチシート | 12×8.5 in
ユーザ定義 | －
（凡例）

－：値を指定できます。詳細は「(2)　独自の用紙サイズを設定する」を参照してください。

ページの先頭へ

(2)　独自の用紙サイズを設定する

独自の用紙サイズを設定する場合は，「ユーザ定義」を選択したあと，［幅］と［長さ］のテキストボックスに値を指定します。

指定できる値は，［幅］［長さ］とも「35.0（mm）～431.8（mm）」です。［幅］のデフォルトは，「210.0（mm）」です。［高さ］のデフォルトは，「297.0（mm）」です。幅と長さのサイズを指定すると，［用紙サイズ］のリストボックスの表示は「ユーザ定義」に変わります。

重要

用紙サイズを変更するときの注意

  • データをマッピングしたあと，用紙のサイズを変更したことで実アイテムまたは罫線が用紙からはみ出す場合は，警告メッセージが表示されます。もう一度，設定し直してください。

  • 繰り返しをしたあと，用紙サイズを変更すると，個数の設定が「自動設定」になっている場合は，自動的に繰り返し個数を調整して表示されますが，「任意設定」になっている場合は，調整しないで表示されます。「任意設定」で繰り返しを定義する場合は，用紙サイズを設定してから繰り返し個数を設定してください。［繰り返し個数指定］ダイアログには，用紙サイズに合った最大個数が表示されます。

  • 独自の用紙サイズを設定したり，出力するプリンタの用紙サイズに合わせて，幅と長さを変更したりした場合は，［余白］のサイズに注意してください。また，ウィンドウ表示倍率の指定によっては，帳票ウィンドウ上のアイテムが正しく表示されないことがあります。

  • 「ユーザ定義」を設定した帳票を印刷する場合は，設計した帳票と同じ印刷結果を得るため，プリンタのプロパティでも同じ用紙サイズを設定してください。この場合，［用紙の設定］で設定した用紙サイズの単位を合わせて設定すると便利です。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 33 / 356


2.2.2 用紙の向きの変更 : EUR 帳票作成 操作ガイド

  • 34 / 356

  • 表紙

  • 2.　用紙を設定する

  • 2.2　用紙の設定を変更する

  • 2.2.2　用紙の向きの変更

2.2.2　用紙の向きの変更

印刷する用紙の向きを，縦向きにするか，横向きにするかを「印刷の向き」で選択できます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 34 / 356


2.2.3 用紙の余白の変更 : EUR 帳票作成 操作ガイド

  • 35 / 356

  • 表紙

  • 2.　用紙を設定する

  • 2.2　用紙の設定を変更する

  • 2.2.3　用紙の余白の変更

2.2.3　用紙の余白の変更

用紙の余白のサイズを，［余白］のグループボックスのテキストボックスに入力します。設定できる余白のサイズを次に示します。

上下左右の各余白 ≧ 0（mm）

上下の余白の合計 ≦ 用紙の縦の長さ－25（mm）

上下の余白の合計が設定できる余白のサイズより大きくなる場合は，そのテキストボックスが反転表示されます。

左右の余白の合計 ≦ 用紙の横の長さ－25（mm）

左右の余白の合計が設定できる余白のサイズより大きくなる場合は，そのテキストボックスが反転表示されます。

重要

余白に関する注意

  • EURの帳票は，［用紙の設定］ダイアログで設定された余白のサイズに合わせて印刷されます。そのため，次に示すような印刷結果になることがあります。余白のサイズは，出力先プリンタの印刷できる範囲を調査したあと，ハードマージン以上の値で設定，または変更してください。

    設定された余白のサイズ

    印刷結果

    ［左］と［上］に設定した余白のサイズよりも，出力先プリンタのハードマージンが大きい場合

    ハードマージンの分だけ，帳票が右下にずれて印刷されます。

    ［右］と［下］に設定した余白のサイズよりも，ハードマージンが大きい場合

    ハードマージンの分だけ，帳票の右下が欠けて印刷されます。

  • データをマッピングしたあと，余白を変更したことで実アイテム，または罫線が余白にはみ出す場合は，警告メッセージが表示されます。もう一度，設定し直してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 35 / 356


3. データを読み込む : EUR 帳票作成 操作ガイド

  • 36 / 356

  • 表紙

  • 3.　データを読み込む

3.　データを読み込む

この章では，データの読み込みの種類，読み込み手順，および読み込み後の設定方法について説明します。また，データを準備する前に帳票を設計したい場合，サンプルデータを利用して帳票を設計する方法についても説明します。

〈この章の構成〉

  • 3.1　データ読み込みの種類

  • 3.2　データファイルからの読み込み手順

  • 3.3　データウィンドウのフィールド定義を変更する

  • 3.4　フィールド表示幅を変更する

  • 3.5　基準レコードを変更する

  • 3.6　サンプルデータを作成する

  • 3.7　ディクショナリファイルを使用する

  • 3.8　SEWB+/REPOSITORYで定義した最上位結合項目からデータを読み込む

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 36 / 356


3.1 データ読み込みの種類 : EUR 帳票作成 操作ガイド

  • 37 / 356

  • 表紙

  • 3.　データを読み込む

  • 3.1　データ読み込みの種類

3.1　データ読み込みの種類

帳票を設計するための表形式のデータをデータウィンドウに読み込みます。データ読み込みの方法には次の二つがあります。

データファイルからのデータの読み込み

データファイル（CSV形式，FIX形式）に保存してあるデータを読み込みます。データファイルを読み込む場合は，次に示す二つの方法でファイルを指定することで，データウィンドウにデータが表示されます。

  • ［データのプロパティ］ダイアログで，読み込むファイルを指定する方法

  • ［データファイルの指定］ダイアログで，読み込むファイルを指定する方法

データベースからのデータの読み込み

データベースに登録したデータをデータベースにアクセスして読み込みます。データベースのデータを読み込む場合は，データベースアクセス定義ウィンドウを使用して，データベースから抽出するデータの検索条件を設定することで，検索条件に沿ったデータがデータウィンドウに表示されます。

データベースからのデータの読み込み方法については，マニュアル「EUR データベース連携ガイド」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 37 / 356


3.2 データファイルからの読み込み手順 : EUR 帳票作成 操作ガイド

  • 38 / 356

  • 表紙

  • 3.　データを読み込む

  • 3.2　データファイルからの読み込み手順

3.2　データファイルからの読み込み手順

データファイルからデータを読み込み，帳票設計のデータをデータウィンドウに表示します。データファイルには，CSV形式，DAT形式，およびFIX形式が使用できます。

データファイルからデータを入力し，データウィンドウへ表示するには，入力するレコードからフィールドを切り出す情報（区切り方法，フィールド名，位置，長さ，および属性）が必要です。このため，入力データファイルの種類によって，次に示す方法からデータの入力方法を選択してください。

  • 区切り文字で区切ったデータ

    CSV形式およびDAT形式ファイルに使用

  • 区切り位置で区切ったデータ

    FIX形式ファイルに使用

一つの帳票に指定できるデータファイルは，一つだけです。

重要

帳票ファイルを開いている時の注意

帳票ファイル（フォームシートファイル，またはレポートファイル）を開いている時に，その帳票で使用しているデータファイルや画像ファイルのデータを変更した場合は，［データ］－［最新のデータに更新］を選択して，データが更新されたことを確認してください。

〈この節の構成〉

  • 3.2.1　CSV形式およびDAT形式のデータの読み込み

  • 3.2.2　FIX形式のデータの読み込み

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 38 / 356


3.2.1 CSV形式およびDAT形式のデータの読み込み : EUR 帳票作成 操作ガイド

  • 39 / 356

  • 表紙

  • 3.　データを読み込む

  • 3.2　データファイルからの読み込み手順

  • 3.2.1　CSV形式およびDAT形式のデータの読み込み

3.2.1　CSV形式およびDAT形式のデータの読み込み

CSV形式およびDAT形式のファイルからデータを読み込み，データウィンドウに表示します。CSV形式およびDAT形式は，区切り文字によってデータを区切ったファイルです。

CSV形式およびDAT形式のデータは，ディクショナリファイルを省略できます。

入力レコードからフィールドを切り出す情報（区切り文字の指定，1レコード目をフィールド名として扱うかどうか）は，ダイアログで指定します。手順を次に示します。

  1. データウィンドウを選択する

    マッピングデータウィンドウ，またはユーザ定義データウィンドウをクリックして，アクティブにします。

  2. ［データファイルの指定］ダイアログを表示する

    ［データ］－［データファイル指定］を選択します。

  3. 入力ファイルを指定する

    ［データファイルの指定］ダイアログで，入力するデータファイルを指定します。

  4. ［データのプロパティ］ダイアログを表示する

    ［データファイルの指定］ダイアログの［開く］ボタンをクリックすると，［データのプロパティ］ダイアログが表示されます。

  5. 区切り方法を選択する

    ［区切り情報］タブで，区切り方法に［コンマやスペース等区切り文字でデータを区切る］を選択します。

    「区切り文字」には，データ中で使用している区切り文字を指定します。

  6. 区切り文字の種別を選択する

    区切り文字の種別を選択します。「コンマ」，「タブ」，「スペース」，「指定」が選択できます。「指定」を選択した場合は，テキストボックスに任意の区切り文字を入力してください。

  7. 1行目のデータをフィールド名として扱うかどうかを設定する

    データの先頭レコードにフィールド名が入っている場合，「1行目のデータをフィールド名として扱う」を指定します。

    「1行目のデータをフィールド名として扱う」を指定しなかった場合は，EURが「A」,「B」,「C」と自動的にフィールド名を定義します。この場合，ファイルを読み込んだあと，［フィールド定義］ダイアログでフィールド名を変更できます。

  8. ［OK］ボタンをクリックする

    区切り情報に従って入力ファイルからデータが読み込まれ，データウィンドウにデータが表示されます。

    この時点では，フィールドの属性は自動的に数値属性か文字列属性になります。自動的に設定された属性以外の属性にしたい場合は，フィールド定義で属性を設定してください。フィールド定義の設定については，「3.3　データウィンドウのフィールド定義を変更する」を参照してください。

〈この項の構成〉

  • (1)　補足説明

(1)　補足説明

  • 入力ファイルからデータを読み込む場合，あらかじめ空レコードを無視するときは，［データのプロパティ］ダイアログの［データ情報］タブで［空レコードを無視する］のチェックボックスをオンにします。

  • データを読み込んだあと，データウィンドウの空レコードを省きたい場合は，［空レコードを無視する］のチェックボックスをオンにすると，空レコードがなくなります。また，文字コード（0x00）だけのレコードを無視する場合は，［データのプロパティ］ダイアログの［データ情報］タブで［文字コード（0x00）だけのレコードを無視する］のチェックボックスをオンにします。

  • 空レコードとは，改行コード，区切り文字として指定されていないタブ，または空白だけを含むレコードのことです。タブは，キーボードの＜Tab＞キーで入力した制御文字です。

    空レコードには，次に示す組み合わせがあります。

    • 改行コードだけ

    • 空白と改行コード

    • タブと改行コード

    • タブと空白と改行コード

  • データファイルにタブが指定されている場合，タブを空白に置き換えて表示します。ただし，1行目のデータをフィールド名として扱う場合，フィールド名にタブが使われているときはタブのまま表示します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 39 / 356


3.2.2 FIX形式のデータの読み込み : EUR 帳票作成 操作ガイド

  • 40 / 356

  • 表紙

  • 3.　データを読み込む

  • 3.2　データファイルからの読み込み手順

  • 3.2.2　FIX形式のデータの読み込み

3.2.2　FIX形式のデータの読み込み

FIX形式ファイルからデータを入力し，データウィンドウへ表示する操作方法を次に示します。FIX形式は，区切り位置によってデータを区切ったファイルです。

入力レコードからフィールドを切り出す情報（区切り位置の指定，1レコード目をフィールド名として扱うかどうか）は，ダイアログで指定します。手順を次に示します。

  1. データウィンドウを選択する

    マッピングデータウィンドウ，またはユーザ定義データウィンドウをクリックして，アクティブにします。

  2. ［データファイルの指定］ダイアログを表示する

    ［データ］－［データファイル指定］を選択します。

  3. 入力ファイルを指定する

    ［データファイルの指定］ダイアログで，入力するデータファイルを指定します。

  4. ［データのプロパティ］ダイアログを表示する

    ［データファイルの指定］ダイアログの［開く］ボタンをクリックすると，［データのプロパティ］ダイアログが表示されます。

  5. 区切り位置を設定する

    ［区切り情報］タブで，区切り位置を設定します。

    区切り位置の設定手順を次に示します。

    • ［指定した区切り位置でデータを区切る］を選択します。

    • 区切り位置を設定します。

      表示されているデータを直接マウスで指定するか，または［区切り位置の自動設定］ボタンをクリックします。区切り位置の変更や削除は，ダイアログ上の説明を参照してください。

      重要

      データファイルがUnicodeの場合，表示されているデータは目盛りと不一致になることがあるため，表示されているデータではなく目盛りをもとに区切り位置を設定してください。

    • 1行目のデータをフィールド名として扱うかどうかを指定します。

  6. ［OK］ボタンをクリックする

    区切り情報に従って入力ファイルからデータが読み込まれ，データウィンドウにデータが表示されます。

    この時点では，フィールドの属性は自動的に数値属性か文字列属性になります。自動的に設定された属性以外の属性にしたい場合は，フィールド定義で属性を設定してください。フィールド定義の設定については，「3.3　データウィンドウのフィールド定義を変更する」を参照してください。

〈この項の構成〉

  • (1)　補足説明

(1)　補足説明

  • 入力ファイルからデータを読み込む場合，あらかじめ空レコードを無視するときは，［データのプロパティ］ダイアログの［データ情報］タブで［空レコードを無視する］のチェックボックスをオンにします。

  • データを読み込んだあと，データウィンドウの空レコードを省きたい場合は，［空レコードを無視する］のチェックボックスをオンにすると，空レコードがなくなります。また，文字コード（0x00）だけのレコードを無視する場合は，［データのプロパティ］ダイアログの［データ情報］タブで［文字コード（0x00）だけのレコードを無視する］のチェックボックスをオンにします。

  • 空レコードとは，改行コード，区切り文字として指定されていないタブ，または空白だけを含むレコードのことです。タブは，キーボードの＜Tab＞キーで入力した制御文字です。

    空レコードには，次に示す組み合わせがあります。

    • 改行コードだけ

    • 空白と改行コード

    • タブと改行コード

    • タブと空白と改行コード

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 40 / 356


3.3 データウィンドウのフィールド定義を変更する : EUR 帳票作成 操作ガイド

  • 41 / 356

  • 表紙

  • 3.　データを読み込む

  • 3.3　データウィンドウのフィールド定義を変更する

3.3　データウィンドウのフィールド定義を変更する

データを読み込むと，データウィンドウには，入力データのフィールド名とレコードの内容が表示されています。このデータウィンドウから，データを帳票ファイルに貼り付ける前に，フィールド名とフィールド属性を確認したり，変更したりする必要があります。

フィールド名や属性の定義は，［フィールド定義］ダイアログで定義します。データファイルからデータを入力した場合，フィールドの属性が意図したものとなっていないので，必ずフィールド定義を行ってください。

なお，ディクショナリファイルを使用してフィールド定義情報を指定している場合は，フィールド定義の変更はできません。ディクショナリファイルについては，「3.7　ディクショナリファイルを使用する」を参照してください。

〈この節の構成〉

  • 3.3.1　フィールド定義を変更する前の操作

  • 3.3.2　フィールド定義の変更手順

  • 3.3.3　帳票に貼り付けたデータのフィールド定義の変更・削除

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 41 / 356


3.3.1 フィールド定義を変更する前の操作 : EUR 帳票作成 操作ガイド

  • 42 / 356

  • 表紙

  • 3.　データを読み込む

  • 3.3　データウィンドウのフィールド定義を変更する

  • 3.3.1　フィールド定義を変更する前の操作

3.3.1　フィールド定義を変更する前の操作

フィールド定義を変更する前に，データファイル（CSV形式）からデータを読み込んだ場合の，フィールド定義の操作について説明します。

使用するCSV形式ファイル（Report1.csv）を次に示します。

区切り情報に従って入力ファイルからデータを読み込んだ時のデータウィンドウは，次のように表示されます。

Report1.csvは，1行目にフィールド名を持っていないので，［データのプロパティ］ダイアログの［1レコード目のデータをフィールド名として扱う］のチェックボックスはオフにします。フィールド名は，「A」「B」「C」…と仮定されます。

メモ

  • データファイルからデータを読み込む場合は，データが「"」で囲まれているかどうかでも，次のとおり属性が判断されます。

    " "で囲まれたデータ：文字列データ

    " "で囲まれていないデータ：数値の場合は数値データ，数値以外の場合は文字列データ

    このため，" "で囲まれていない文字列がデータウィンドウに正しく表示されない場合があります。このようなときは，フィールド定義で属性を設定し直すことで，正しく表示されます。

  • FIX形式の場合は，データの属性が，数値の場合は数値データ，数値以外の場合は文字列データとして判断されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 42 / 356


3.3.2 フィールド定義の変更手順 : EUR 帳票作成 操作ガイド

  • 43 / 356

  • 表紙

  • 3.　データを読み込む

  • 3.3　データウィンドウのフィールド定義を変更する

  • 3.3.2　フィールド定義の変更手順

3.3.2　フィールド定義の変更手順

データファイル（CSV形式）を読み込んだ場合，フィールド名称はアルファベット，フィールドのデータ種別は数値データまたは文字列データとして設定されています。

このフィールド定義（フィールド名称，フィールドのデータ種別）を正しい属性に変更しないと，データウィンドウにデータが表示されなかったり，帳票ウィンドウに貼り付けた場合に正しく表示できなかったりします。

フィールド定義は，［フィールド定義］ダイアログで変更します。手順を次に示します。

  1. ［フィールド定義］ダイアログを表示する

    ［データ］－［フィールド定義］を選択します。

    CSV形式ファイル（Report.csv）はフィールド名を持っていないので，［フィールド名称］は仮称で表示されます。

    ［データ］は，1レコード目のデータが表示されます。

    • フィールド名称を変更する

      フィールド名のセルに直接入力するか，または［フィールド定義情報変更］ダイアログで変更します。［フィールド定義情報変更］ダイアログは，フィールド名称の左側にある番号を選択したあと，［変更］ボタンをクリックするか，またはフィールド名称の左側にある番号をダブルクリックすると表示されます。

      なお，フィールド名は，帳票ファイルに作成する表の見出しとしても使用できます。

      帳票を定義したあとで［フィールド名称］を変更すると，帳票上のフィールドと対応が取れなくなり，データが表示されなくなります。

    • フィールドの種別を変更する

      フィールドごとの種別の位置をクリックすると，データ種別一覧が表示されます。データ種別一覧から選択してください。

      種別には，文字列，数値，数値（集計対象外），日付（日付・時刻），日付（日次），日付（月次），日付（年次），和暦（日次），和暦（月次），和暦（年次），画像，バーコード，および特殊編集レベルがあります。「数値（集計対象外）」は，例えば，従業員番号や製品番号などの数値データに設定しておくと，帳票に貼り付けても集計されません。

      種別の変更は，［フィールド定義情報変更］ダイアログでもできます。

  2. ［OK］ボタンをクリックする

    データウィンドウにデータが表示されます。

〈この項の構成〉

  • (1)　補足説明

  • (2)　メインフレーム版 EUR Print Serviceで扱える文字列を設定する場合

(1)　補足説明

  • ［フィールド定義］ダイアログには，フィールド定義のためのボタンが用意されていますが，データファイル（CSV形式）の1レコード目に項目名が入っていない場合は，サンプルデータの作成以外では，フィールドの追加や削除はしないでください。入力データの順序と対応が取れなくなり，印刷時に動作が不正になります。

  • データ長がフィールド表示幅より長い場合は，フィールド表示幅を変更すると表示できます。フィールド表示幅の変更については，「3.4　フィールド表示幅を変更する」を参照してください。

  • マッピングデータのフィールド名は，510桁までです。ユーザ定義データのフィールド名は，499桁までです。

  • 特殊編集レベルが設定されているデータを読み込んだあと，フィールド定義で種別を「特殊編集レベル」に設定すると，データウィンドウのレコード番号の横に記述したレベルが表示されます。

  • フィールド定義を変更する場合，削除したいフィールドがあるときは，フィールド定義を削除する前に，削除対象のフィールドを使用したキー集計または改ページの定義が帳票上に残っていないか確認してください。定義が残った状態でフィールド定義を変更すると，帳票が正しく出力されないことがあります。

ページの先頭へ

(2)　メインフレーム版 EUR Print Serviceで扱える文字列を設定する場合

メインフレーム版 EUR Print Serviceで扱える文字列を設定する場合は，［フィールド定義情報変更］ダイアログで文字列フィールドの［種別詳細］で設定します。

  1. 文字列フィールドを選択する

    ［フィールド定義］ダイアログで，種別が「文字列」のフィールドを選択したあと，フィールド名称の左側にある番号を選択します。

  2. ［フィールド定義情報変更］ダイアログを表示する

    ［変更］ボタンをクリックします。

  3. ［種別詳細］を設定する

    選択したフィールドの種別が「文字列」の場合は，［種別詳細］のリストボックスが表示されます。最初は，何も表示されていません。

    リストボックスから，［KEIS専用］を選択すると，メインフレーム版 EUR Print Serviceで扱えるKEIS 2バイトの文字列が設定できます。

  4. ［OK］ボタンをクリックする

    ［フィールド定義］ダイアログの種別の表示が，「文字列（KEIS専用）」に変わります。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 43 / 356


3.3.3 帳票に貼り付けたデータのフィールド定義の変更・削除 : EUR 帳票作成 操作ガイド

  • 44 / 356

  • 表紙

  • 3.　データを読み込む

  • 3.3　データウィンドウのフィールド定義を変更する

  • 3.3.3　帳票に貼り付けたデータのフィールド定義の変更・削除

3.3.3　帳票に貼り付けたデータのフィールド定義の変更・削除

［フィールド定義］ダイアログで，帳票に貼り付けたデータの［フィールド名称］，および［種別］を変更したり，フィールド情報を削除したりする場合の手順を次に示します。

  1. アイテムを削除する

    変更，または削除するフィールドのアイテムを削除します。

    アイテムに改ブロック，または改ページが設定されていたり，キー集計が設定されていたりする場合は，次に示す操作をしてから，アイテムを削除してください。

    • 改ブロック，または改ページが設定されている場合

      改ブロック，または改ページを解除してください。

      改ブロック，または改ページは，帳票ウィンドウに貼り付けていないフィールドにも設定できます。［改ブロック／改ページ一覧］ダイアログを表示して，改ブロック／改ページのキーフィールドの設定内容を確認することをお勧めします。

    • キー集計が設定されている場合

      キー集計を解除してください。

  2. フィールドの情報を変更，または削除する

    ［フィールド定義］ダイアログで，フィールドの情報を変更，または削除したあと，［更新］ボタンをクリックします。

このあと，必要に応じてアイテムを貼り付け直してください。

〈この項の構成〉

  • (1)　補足説明

(1)　補足説明

帳票に貼り付けたあと，フィールド定義またはデータベースアクセス定義で，フィールドの情報を変更，または削除しても，アイテムのフィールド情報には元のフィールドの情報が残されています。そのため，帳票に貼り付けたアイテムを削除しないまま，元のフィールドと同名のフィールドを追加すると，意図しないデータが表示されることがあります。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 44 / 356


3.4 フィールド表示幅を変更する : EUR 帳票作成 操作ガイド

  • 45 / 356

  • 表紙

  • 3.　データを読み込む

  • 3.4　フィールド表示幅を変更する

3.4　フィールド表示幅を変更する

データを読み込んだり，フィールド定義をしたりしたあと，データウィンドウの表示に戻ったとき，フィールドやレコードのセル幅を超えるような長いデータは途中までしか表示されません。

データウィンドウで，フィールドの区切り線にカーソルを合わせると，形状が [図データ] に変わります。この状態でドラッグすると，フィールド表示幅を自由に変えられます。

フィールド表示幅を変更するには，次に示す二つの方法もあります。

〈この節の構成〉

  • 3.4.1　フィールド表示幅をデータ長に合わせる

  • 3.4.2　任意のフィールド表示幅を設定する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 45 / 356


3.4.1 フィールド表示幅をデータ長に合わせる : EUR 帳票作成 操作ガイド

  • 46 / 356

  • 表紙

  • 3.　データを読み込む

  • 3.4　フィールド表示幅を変更する

  • 3.4.1　フィールド表示幅をデータ長に合わせる

3.4.1　フィールド表示幅をデータ長に合わせる

データウィンドウで，特定のフィールド（一つまたは複数フィールド）の表示幅をデータ長に合わせて表示します。手順を次に示します。

  1. フィールドを選択する

    データウィンドウで特定のフィールド（一つまたは複数フィールド）を選択します。

  2. フィールド表示幅を変更する

    ［データ］－［フィールド表示幅］－［データ長に合わせる］を選択します。

    選択されたフィールドの表示幅が，そのフィールド内の最大長のデータに合わせて変更されます。ただし，表示できる幅は半角99文字までです。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 46 / 356


3.4.2 任意のフィールド表示幅を設定する : EUR 帳票作成 操作ガイド

  • 47 / 356

  • 表紙

  • 3.　データを読み込む

  • 3.4　フィールド表示幅を変更する

  • 3.4.2　任意のフィールド表示幅を設定する

3.4.2　任意のフィールド表示幅を設定する

データウィンドウで，特定のフィールド（一つまたは複数フィールド）を任意の表示幅に変更して表示します。手順を次に示します。

  1. フィールドを選択する

    データウィンドウで特定のフィールド（一つまたは複数フィールド）を選択します。

  2. ［フィールド表示幅設定］ダイアログを表示する

    ［データ］－［フィールド表示幅］－［設定］を選択します。

    ［フィールド幅］のテキストボックスには，前回設定した値，または直接マウス操作で変更した値が表示されています。

  3. フィールド幅を指定する

    フィールドの表示幅を，［フィールド幅］のテキストボックスに入力します。設定できる値は，1～99です。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 47 / 356


3.5 基準レコードを変更する : EUR 帳票作成 操作ガイド

  • 48 / 356

  • 表紙

  • 3.　データを読み込む

  • 3.5　基準レコードを変更する

3.5　基準レコードを変更する

レコードの開始位置，および一つのレコードとして扱いたいレコードの数（幅）を変更できます。

〈この節の構成〉

  • 3.5.1　基準レコード位置の変更

  • 3.5.2　基準レコード幅の変更

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 48 / 356


3.5.1 基準レコード位置の変更 : EUR 帳票作成 操作ガイド

  • 49 / 356

  • 表紙

  • 3.　データを読み込む

  • 3.5　基準レコードを変更する

  • 3.5.1　基準レコード位置の変更

3.5.1　基準レコード位置の変更

基準レコード位置とは，印刷の対象とするレコードの開始位置です。デフォルトでは1レコード目となっています。この機能は，CSV形式ファイルなどで，ある特定のレコード以降のデータを帳票に出力したい場合に使用します。

帳票の設計（繰り返しなどの定義）が完了してから，基準レコード位置を変更します。特に，データウィンドウから帳票ファイルへフィールドを貼り付ける時に，先頭レコードでなく，途中のレコードから貼り付けている場合は，帳票設計時のウィンドウ上では正しく表示されていても，印刷時にずれることがあります。その場合は，基準レコードを設定するか，入力データに不要な情報を入れないようにしてください。

なお，CSV形式ファイルなどの入力で，先頭レコードをフィールド名（見出し）として扱いたい場合は，基準レコード位置の変更ではなく，区切り情報の設定（データのプロパティ）で指定してください。手順を次に示します。

  1. レコード見出し部を選択する

    基準レコードにするレコード見出し部をクリックします。

  2. 基準レコード位置を指定する

    ［データ］－［基準レコード位置変更］を選択します。

基準レコード位置が変更されると，帳票ウィンドウは，基準レコード以降のデータが繰り返されます。

（例）

フロア「1F」からのデータを帳票に表示する場合，9レコード目を基準レコード位置にします。

〈この項の構成〉

  • (1)　補足説明

(1)　補足説明

レコード見出し部をクリックしたあと，ポップアップメニューからも操作できます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 49 / 356


3.5.2 基準レコード幅の変更 : EUR 帳票作成 操作ガイド

  • 50 / 356

  • 表紙

  • 3.　データを読み込む

  • 3.5　基準レコードを変更する

  • 3.5.2　基準レコード幅の変更

3.5.2　基準レコード幅の変更

基準レコード幅とは，繰り返しの基準となるレコードの幅（レコード数）です。デフォルトの基準レコード幅は，1（1レコード）です。

EURでは，基本的に入力データの1レコードを帳票ファイルに貼り付け，この1レコードを繰り返すことで表形式の帳票にしています。この機能は，複数の入力レコードを一つの入力レコードとして扱いたい場合に利用します。

帳票の設計での制約

基準レコード幅の指定には，次のような制約があります。

複数の入力レコードを一つの入力レコードとして扱うため，マッピングデータウィンドウから帳票ファイルへのフィールドの貼り付けは，複数のレコード分となります。また，繰り返しの対象も複数のレコード分です。

手順を次に示します。

  1. ［基準レコード幅変更］ダイアログを表示する

    ［データ］－［基準レコード幅変更］を選択します。

  2. 基準レコード幅を指定する

    ［基準レコード幅］のテキストボックスに直接値を入力するか，またはアップダウンコントロールをクリックして値を設定します。デフォルトは，「1（レコード）」です。

    ［基準レコード幅］のテキストボックスに「0」を入力した場合は，反転表示されます。1以上の整数を入力してください。

    データのレコード数を超える値を［基準レコード幅］のテキストボックスに入力した場合は，データのレコードすべてが基準レコードと見なされます。

    基準レコード幅が指定されると，データウィンドウのレコード番号の表示が赤色に変わります。

〈この項の構成〉

  • (1)　補足説明

  • (2)　基準レコード幅を変更した帳票の例

(1)　補足説明

  • ［基準レコード幅変更］ダイアログは，レコード見出し部をクリックしたあと，ポップアップメニューからも操作できます。

  • 次に示すEURの機能が設定されている帳票には，基準レコード幅の変更はできません。

    • 改ブロックでの表の分割

    • まとめ表示

    • キーとなるデータを指定した改ページ

    • キーとなるデータを指定した集計

    • 表内の数値データの総集計

  • 基準レコード幅を設定した帳票には，次に示すEURの機能は設定できません。

    • キーとなるデータを指定した集計

    • 表内の数値データの総集計

    集計をしたい場合は，集計アイテムの作成機能を使用して設定してください。

    次に示すEURの機能は設定できますが，正しい位置に出力されないことがあります。

    • 改ブロックでの表の分割

    • まとめ表示

    • キーとなるデータを指定した改ページ

ページの先頭へ

(2)　基準レコード幅を変更した帳票の例

複数の入力レコードを，一つの入力レコードとして帳票を設計する例を示します。次のようなデータを準備して，基準レコード幅を「4」に設定します。

4レコード分のデータを帳票ウィンドウに貼り付けて，表の罫線を引きます。4レコード分のデータと表の罫線を繰り返し対象にしたあと，繰り返し方向（この場合は縦方向）を設定します。

帳票ウィンドウには，四半期ごとのデータを一つのまとまりにした表が作成できます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 50 / 356


3.6 サンプルデータを作成する : EUR 帳票作成 操作ガイド

  • 51 / 356

  • 表紙

  • 3.　データを読み込む

  • 3.6　サンプルデータを作成する

3.6　サンプルデータを作成する

EURで帳票を設計するには，データが必要です。データをまだ準備できない状態で，先に帳票を設計しておきたいときには，サンプルデータを作成します。サンプルデータの作成では，フィールド名称，フィールドのデータ種別，1レコード分のサンプルデータを設定します。ここで設定した内容は，データウィンドウに表示されます。

実際のデータで1行目に項目名を入れるときは，サンプルデータのフィールド名に同じ名称を指定してください。

EURではデータの1行目を項目名として認識し，自動的に項目名とデータを対応づけます。そのため，サンプルデータと実際に使用するデータで，項目の並びなどデータのフォーマットが異なっても問題はありません。

サンプルデータは，［フィールド定義］ダイアログで作成したデータを利用する方法で作成します。

〈この節の構成〉

  • 3.6.1　［フィールド定義］ダイアログでサンプルデータを作成する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 51 / 356


3.6.1 ［フィールド定義］ダイアログでサンプルデータを作成する : EUR 帳票作成 操作ガイド

  • 52 / 356

  • 表紙

  • 3.　データを読み込む

  • 3.6　サンプルデータを作成する

  • 3.6.1　［フィールド定義］ダイアログでサンプルデータを作成する

3.6.1　［フィールド定義］ダイアログでサンプルデータを作成する

［フィールド定義］ダイアログで作成したデータを利用して，サンプルデータを作成する手順を次に示します。

  1. データウィンドウを選択する

    マッピングデータウィンドウをクリックして，アクティブにします。

  2. ［フィールド定義］ダイアログを表示する

    ［データ］－［フィールド定義］を選択します。

    新規にサンプルデータを作成する場合は，ダイアログには何も表示されていません。

  3. サンプルデータを作成する

    次に示す操作に従って，フィールド定義とサンプルデータを作成してください。データの設定後，［OK］ボタンをクリックすると，データウィンドウに100レコード分のデータが表示されます。

    • フィールド名の設定

      フィールド名のセルに，直接フィールド名を入力します。セルの左側のフィールド番号を選択したあと，［変更］ボタンをクリックする方法もあります。

    • データ種別の設定

      種別のドロップダウンリストに種別の一覧が表示されます。種別の一覧から選択してください。種別には，文字列，数値，数値（集計対象外），日付（日付・時刻），日付（日次），日付（月次），日付（年次），和暦（日次），和暦（月次），和暦（年次），画像，バーコード，および特殊編集レベルがあります。

    • サンプルデータの設定

      データの種別を設定すると，サンプルデータ欄には，次に示すデフォルトのデータが設定されます。デフォルトのデータは，必要に応じて，直接入力して修正することもできます。

      データ種別

      仮定される値

      文字列

      ABC

      文字列（KEIS専用）※

      あいうえお

      数値

      123

      数値（集計対象外）

      123456

      日付（日付・時刻）

      1996/03/31 12:42:07

      日付（日次）

      19960331

      日付（月次）

      199603

      日付（年次）

      1996

      和暦（日次）

      4080331

      和暦（月次）

      40803

      和暦（年次）

      408

      画像

      sample.bmp

      バーコード

      4901234567894

      特殊編集レベル

      1
      注※

      「文字列（KEIS専用）」は，［フィールド定義］ダイアログで文字列フィールドを選択したあと，［フィールド定義情報変更］ダイアログで種別詳細を「KEIS専用」に変更することで設定できます。

      なお，読み込んだデータが実データの場合，またはSEWB+/REPOSITORYで定義した最上位結合項目から読み込んだ実データが表示されている場合は，データのセルは不活性となり，編集はできません。

    • フィールドの追加

      フィールドを追加する位置の直後のフィールド番号（セルの左側の番号）をクリックしたあと，［挿入］ボタンをクリックします。フィールドが追加されます。

    • フィールドの削除

      削除するフィールド番号（セルの左側の番号）を選択したあと，［削除］ボタンをクリックするか，または＜Delete＞キーを押してください。フィールドが削除されます。

  4. サンプルデータ数を設定する

    ［データ］－［データのプロパティ］を選択すると，［データのプロパティ］ダイアログが表示されます。このダイアログの［データ情報］タブでサンプルデータ数を設定してください。

〈この項の構成〉

  • (1)　補足説明

(1)　補足説明

  • ユーザ定義データウィンドウでも，サンプルデータを作成できます。

  • サンプルデータは，同じ内容のレコードが繰り返されています。同じ内容のレコードが繰り返されているだけでは，改ページ，改ブロック，キー集計などの設計ができません。

    設計する帳票で，改ページ，および改ブロックを使用したい場合は，［データのプロパティ］ダイアログの［データ情報］タブの［サンプル］グループボックスにある，［改ブロック／ページの編集］のチェックボックスをオンにします。これによって，文字フィールドのすべてのデータを10レコード単位で切り替えられ，サンプルデータで改ブロックや改ページの編集が容易になります。

  • 集計行編集で，特殊編集レベルを編集したい場合は，［データのプロパティ］ダイアログの［データ情報］タブの［サンプル］グループボックスにある，［特殊編集レベルの編集］のチェックボックスをオンにします。これによって，サンプルデータ中の特殊編集レベルを0～99の間で繰り返すかどうかを設定でき，サンプルデータで特殊編集レベルを対象とした集計行の編集が容易になります。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 52 / 356


3.7 ディクショナリファイルを使用する : EUR 帳票作成 操作ガイド

  • 53 / 356

  • 表紙

  • 3.　データを読み込む

  • 3.7　ディクショナリファイルを使用する

3.7　ディクショナリファイルを使用する

ディクショナリファイルを使用して，フィールド定義を設定します。ディクショナリファイルは，英語ロケール，および中国語ロケールでは使用できません。

〈この節の構成〉

  • 3.7.1　ディクショナリファイルとは

  • 3.7.2　ディクショナリファイルによるフィールド定義の指定

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 53 / 356


3.7.1 ディクショナリファイルとは : EUR 帳票作成 操作ガイド

  • 54 / 356

  • 表紙

  • 3.　データを読み込む

  • 3.7　ディクショナリファイルを使用する

  • 3.7.1　ディクショナリファイルとは

3.7.1　ディクショナリファイルとは

ディクショナリファイルは，UNIX版 EUR旧製品で設計された帳票の入力データの形式（マッピングデータやユーザ定義データの各項目の属性など）を定義しているファイルです。UNIX版 EUR旧製品のディクショナリファイルを用いてデータを入力し，帳票を設計する場合に使用します。

EUR サーバ帳票出力機能では，ディクショナリファイルは使用できません。

〈この項の構成〉

  • (1)　ディクショナリファイルの記述形式

(1)　ディクショナリファイルの記述形式

ディクショナリファイルには，「CSV形式およびDAT形式」と「FIX形式」のそれぞれに対応した形式があります。

ディクショナリファイルを使用する場合，データファイルの拡張子が「.fix」のときはFIX形式のデータを読み込み，「.fix」以外のときは，CSV形式およびDAT形式のデータとして読み込みます。

図3‒1　ディクショナリファイルの記述例

[図データ]

表3‒1　ディクショナリファイルの記述形式

記述項目

記述内容

1行目に指定する内容

CSV形式およびDAT形式

1行目に「1,」のあと，データファイルの区切り文字として使用する記号を「"」で囲んで指定します。

なお，区切り文字の指定を省略した場合は，区切り文字に「,」を使用します。

  • 区切り文字は，必ず「"」で囲んで指定してください。

  • 「"」は，区切り文字として指定できません。

  • 区切り文字は，改行，\0以外のコードで指定してください。

FIX形式

1行目に「1」を指定します。

区切り文字

フィールド名とフィールドの属性の間は，「,,」を指定します。それ以外は，「,」で区切ります。

(1)フィールド名

フィールド名として使用できる文字を次に示します。

英数字，全角文字，_ ，@ ，# ，$ ，* ，/ ，\ ，-

マッピングデータのフィールド名は，510桁までです。ユーザ定義データのフィールド名は，499桁までです。

(2)フィールドの属性

作成するテーブルのフィールドの属性は，次のように指定します。

  • 文字フィールド：C

  • 数値フィールド：I　　（整数データ）

                    F　　（実数データ）

                    B　　（集計対象外）

  • 日付フィールド：CY　（年次データ）

                    MO　（月次データ）

                    DA　（日次データ）

                    HS　（日付・時刻データ）

  • 和暦フィールド：WCY（和暦（年次）データ）

                    WMO（和暦（月次）データ）

                    WDA（和暦（日次）データ）

  • 画像フィールド：M

  • 特殊編集レベルフィールド：SP

    特殊編集レベルを指定すると，データウィンドウのレコード番号の横に「（レベル：nn）」と表示されます。

  • バーコードフィールド：R

(3)データの属性

「C」を指定します。

(4)フィールドの位置

CSV形式およびDAT形式

  • フィールドを表示する順に，フィールド番号を指定します。順不同にフィールド番号を付けることもできます。

  • 同じフィールド番号を付けたり，フィールドの総数を超えたりした場合は，エラーとなり，データは読み込まれません。

FIX形式

先頭を「1」とする，相対位置で指定します。

(5)データの長さ

（データウィンドウの各フィールド表示幅は，ディクショナリファイルのフィールド名の長さと，データの長さのどちらか大きい方の値とします）。

フィールドをデータウィンドウに表示する幅，フィールド名の長さ，またはデータの長さから，どれか最大のものを記述します。

ただし，文字の場合は，データウィンドウのフィールド長とし，数値の場合は，最大桁数とします。

フィールドの長さを超えるデータが記述された場合は，超えた分を切り捨てたデータが表示されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 54 / 356


3.7.2 ディクショナリファイルによるフィールド定義の指定 : EUR 帳票作成 操作ガイド

  • 55 / 356

  • 表紙

  • 3.　データを読み込む

  • 3.7　ディクショナリファイルを使用する

  • 3.7.2　ディクショナリファイルによるフィールド定義の指定

3.7.2　ディクショナリファイルによるフィールド定義の指定

入力データファイルとは別に，ディクショナリファイル（*.dic）に記述されたフィールド定義情報などを使用して，データウィンドウにデータを入力する操作手順を次に示します。

この方法は，UNIX版 EUR旧製品のディクショナリファイルを使ってデータを入力し，帳票を設計する場合に使用します。バージョン7以降のEURで帳票を出力する場合は，ディクショナリファイルの指定は不要です。

  1. データウィンドウを選択する

    マッピングデータウィンドウ，またはユーザ定義データウィンドウをクリックします。

  2. ［データのプロパティ］ダイアログを表示する

    ［データ］－［データのプロパティ］を選択します。

  3. フィールド定義方法を選択する

    ［データ情報］タブの［フィールド定義］グループボックスで，［定義方法］から「ディクショナリファイルを使用」を選択します。

  4. ディクショナリファイルを指定する

    ［ディクショナリファイル名称］テキストボックスの［...］ボタンをクリックして，ディクショナリファイル名を指定します。

  5. ［OK］ボタンをクリックする

    ディクショナリファイルのフィールド定義が設定されます。

上記の操作で，ディクショナリファイルの情報に従って入力ファイルからデータが読み込まれ，データウィンドウにデータが表示されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 55 / 356


3.8 SEWB+/REPOSITORYで定義した最上位結合項目からデータを読み込む : EUR 帳票作成 操作ガイド

  • 56 / 356

  • 表紙

  • 3.　データを読み込む

  • 3.8　SEWB+/REPOSITORYで定義した最上位結合項目からデータを読み込む

3.8　SEWB+/REPOSITORYで定義した最上位結合項目からデータを読み込む

SEWB+/REPOSITORYで定義した最上位結合項目からデータを読み込み，データウィンドウに表示する手順を説明します。SEWB+/REPOSITORYは，英語ロケール，および中国語ロケールでは使用できません。

〈この節の構成〉

  • 3.8.1　データの読み込み手順

  • 3.8.2　フィールド定義情報の更新

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 56 / 356


3.8.1 データの読み込み手順 : EUR 帳票作成 操作ガイド

  • 57 / 356

  • 表紙

  • 3.　データを読み込む

  • 3.8　SEWB+/REPOSITORYで定義した最上位結合項目からデータを読み込む

  • 3.8.1　データの読み込み手順

3.8.1　データの読み込み手順

SEWB+のデータ項目辞書のレコード定義情報から，帳票設計に使用するフィールド定義情報を読み込めます。このフィールド定義情報を使用して帳票を設計することで，SEWB+で開発したアプリケーションが作成するデータファイルと，帳票のデータ構造を一致させることができます。

図3‒2　SEWB+/REPOSITORYで定義した最上位結合項目からデータを読み込む流れ

[図データ]

帳票設計のデータをSEWB+/REPOSITORYで定義した最上位結合項目から入力し，データウィンドウへ表示するまでの操作について説明します。

なお，SEWB+/REPOSITORY-BROWSERをインストールしていないと操作できません。

〈この項の構成〉

  • (1)　SEWB+にログインする

  • (2)　SEWB+からレコード定義情報を読み込む

  • (3)　補足説明

(1)　SEWB+にログインする

あらかじめ，SEWB+にログインしておいてください。SEWB+にログインをしないで操作を始めると，［SEWB+ログイン］ダイアログが表示されます。

ページの先頭へ

(2)　SEWB+からレコード定義情報を読み込む

  1. データウィンドウを選択する

    マッピングデータウィンドウ，またはユーザ定義データウィンドウをクリックして，アクティブにします。

  2. ［最上位結合項目の検索］ダイアログを表示する

    ［データ］－［最上位結合項目］－［選択］を選択します。

  3. 最上位結合項目を選択する

    検索条件を指定したあと，［検索開始］ボタンをクリックし，最上位結合項目を選択します。

    上記の操作で，選択した最上位結合項目のフィールド定義情報が読み込まれ，データウィンドウには，サンプルデータが表示されます。サンプルデータの表示内容については，マニュアル「SEWB+/REPOSITORY 辞書設計ガイド」を参照してください。

重要

最上位結合項目を利用する帳票を印刷する場合の注意事項

最上位結合項目を利用する帳票を印刷する場合は，使用するデータファイルをCSV形式に，データの区切り文字を「,」（コンマ）にしてください。

ページの先頭へ

(3)　補足説明

  • 最上位結合項目を入力して編集した帳票を印刷する場合に使用するCSV形式のファイルを生成するプログラムの作成には，SEWB+/CONSTRUCTIONの機能を利用できます。

    SEWB+/CONSTRUCTIONでは，帳票を編集した場合と同じ最上位結合項目を入力したデータ定義を利用してプログラムを作成できます。

  • バーコードを印刷したい場合は，次のように操作してください。

    1. 最上位結合項目の構成項目であるデータ項目を，分類「分類なし」，タイプ「フリー定義」，フリー定義「R」に設定しておきます。

    2. EURにデータを読み込むと，データウィンドウには，サンプルデータ「4901234567894」が表示されます。

    3. ［フィールド定義］ダイアログを表示して，印刷するバーコードに合わせたサンプルデータに変更してください。

    バーコードで使用するデータは，バーコードの種類によって異なります。指定するデータの桁数が合っていないと，帳票ファイルに貼り付けた場合，バーコードが表示されないことがあります。バーコードに使用できるデータと桁数については，マニュアル「EUR システム設計ガイド」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 57 / 356


3.8.2 フィールド定義情報の更新 : EUR 帳票作成 操作ガイド

  • 58 / 356

  • 表紙

  • 3.　データを読み込む

  • 3.8　SEWB+/REPOSITORYで定義した最上位結合項目からデータを読み込む

  • 3.8.2　フィールド定義情報の更新

3.8.2　フィールド定義情報の更新

最新の最上位結合項目を基に，フィールド定義情報を更新します。なお，最上位結合項目が選択されていない場合は操作できません。

手順を次に示します。

  1. データウィンドウを選択する

    マッピングデータウィンドウ，またはユーザ定義データウィンドウをクリックします。

  2. 最上位結合項目の更新を確認する

    ［データ］－［最上位結合項目］－［更新］を選択します。

    最上位結合項目が更新されている場合は，帳票を再設計するかどうかを問い合わせるメッセージが表示されます。［OK］ボタンをクリックすると，最上位結合項目を基にフィールド定義の情報が更新されます。ただし，［フィールド名称］と［種別］の情報が同じであっても，［サンプルデータ］のデータが異なる場合は，そのフィールドの情報は更新されません。

    最上位結合項目が更新されていない場合は，更新されていないことを知らせるメッセージが表示されます。

〈この項の構成〉

  • (1)　補足説明

(1)　補足説明

  • 最上位結合項目から作成したフィールド定義情報は，［フィールド定義］ダイアログで変更することはできません。フィールド定義情報を変更する場合は，［データのプロパティ］ダイアログの［データ情報］タブで，フィールド定義の定義方法を「標準」に指定してください。ただし，SEWB+/REPOSITORYの辞書との関連はなくなります。

  • 最上位結合項目を利用して作成したレポートファイルを開く前にSEWB+にログインをしておくと，最上位結合項目が更新されている場合，帳票を再設計するかどうかを問い合わせるメッセージが表示されます。SEWB+にログインしないで操作を始めると，レポートファイルに保管した時の最上位結合項目からフィールド定義情報を作成します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 58 / 356


4. 帳票のレイアウトを決める : EUR 帳票作成 操作ガイド

  • 59 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

4.　帳票のレイアウトを決める

この章では，帳票にアイテムを配置して，帳票のレイアウトを決める方法について説明します。

〈この章の構成〉

  • 4.1　アイテムとは

  • 4.2　アイテムを配置する

  • 4.3　データウィンドウからデータを貼り付ける

  • 4.4　画像ファイルを配置する

  • 4.5　ページ番号を配置する

  • 4.6　印刷日付・印刷時刻を配置する

  • 4.7　アイテムの位置やサイズを変更する

  • 4.8　複数アイテムの重なりや位置を調整する

  • 4.9　特定のページに出力するアイテムを設定する

  • 4.10　アイテムを削除する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 59 / 356


4.1 アイテムとは : EUR 帳票作成 操作ガイド

  • 60 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

  • 4.1　アイテムとは

4.1　アイテムとは

EURでは，帳票にアイテムを配置してレイアウトを決めます。

アイテムとは，文字，線（罫線），角丸四角形や円などの図形，網掛け，画像，マッピングデータウィンドウから貼り付けたデータなどの総称です。これらのアイテムを帳票上に配置し，帳票を定義します。

メモ

アイテムを配置する場合，グリッド，ルーラなどを表示していると，レイアウトの目安になります。「1.4　グリッドを設定する」および「1.5　ルーラを表示する」を参照してください。

アイテムを配置する方法は，アイテムの種類によって異なります。

〈この節の構成〉

  • 4.1.1　文字・線・矩形・網掛けアイテム

  • 4.1.2　図形アイテム

  • 4.1.3　画像アイテム

  • 4.1.4　データウィンドウから貼り付けたデータ

  • 4.1.5　ページ番号・印刷時刻・印刷日付アイテム

  • 4.1.6　部品

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 60 / 356


4.1.1 文字・線・矩形・網掛けアイテム : EUR 帳票作成 操作ガイド

  • 61 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

  • 4.1　アイテムとは

  • 4.1.1　文字・線・矩形・網掛けアイテム

4.1.1　文字・線・矩形・網掛けアイテム

文字・線・矩形・網掛けアイテムは，ツールボックスのボタンを選択して配置します。文字・線・矩形・網掛けアイテムを配置する操作については，「4.2　アイテムを配置する」を参照してください。

文字アイテム

文字アイテムは，帳票のタイトル，表の見出しなどに使用します。改行を入力することで，複数行の文字列も設定できます。直接入力した文字は，帳票が複数ページになった場合，すべてのページの同じ位置に同じ内容で表示されます。設定した文字列は，フォント種別，フォントサイズなどの設定ができます。

線アイテム／矩形アイテム

罫線は，表の枠の作成，および集計行を修飾する場合に使用します。

網掛けアイテム

網掛けは，ほかのアイテムとは独立しています。このため，文字の領域などに網掛けする場合でも，別のアイテムとして作成します。また，この網掛けは，表のセルにも設定でき，繰り返しの対象とすることもできます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 61 / 356


4.1.2 図形アイテム : EUR 帳票作成 操作ガイド

  • 62 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

  • 4.1　アイテムとは

  • 4.1.2　図形アイテム

4.1.2　図形アイテム

図形アイテムには，網掛け，角丸四角，円／楕円，および多角形があります。図形アイテムは，ツールボックスのボタンを選択して配置します。図形アイテムを配置する操作については，「4.2.5　図形アイテムを配置する」を参照してください。

角丸四角アイテム

帳票上に設定したタイトルなどの文字列や，集計したデータなどを角丸四角アイテムで囲んで目立たせられます。角丸四角形は，ほかのアイテムとは独立しています。このため，文字の領域などを角丸四角形で囲む場合でも，別のアイテムとして作成します。また，角丸四角形は，繰り返しの対象とすることもできます。表のセルにも設定できますが，表の枠線に設定すると，表を一つの図形と見なします。

円／楕円アイテム

書類の配布・回覧先を目立たせたり，印を押す場所を示したりする場合，帳票上を円／楕円アイテムで囲めます。円／楕円は，ほかのアイテムとは独立しています。このため，文字の領域などを円／楕円で囲む場合でも，別のアイテムとして作成します。また，円／楕円は，繰り返しの対象とすることもできます。

多角形アイテム

注意を引きたい個所に多角形（矢印や星印など）を作成できます。多角形は，ほかのアイテムとは独立しています。このため，文字の領域などを多角形で囲む場合でも，別のアイテムとして作成します。また，多角形は，繰り返しの対象とすることもできます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 62 / 356


4.1.3 画像アイテム : EUR 帳票作成 操作ガイド

  • 63 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

  • 4.1　アイテムとは

  • 4.1.3　画像アイテム

4.1.3　画像アイテム

画像アイテムには，データウィンドウから画像データを配置する方法と，［挿入］メニューを選択して画像ファイルを直接配置する方法があります。データウィンドウからデータを貼り付ける操作については，「4.3　データウィンドウからデータを貼り付ける」を参照してください。［挿入］メニューを選択して画像ファイルを直接配置する操作については，「4.4　画像ファイルを配置する」を参照してください。

EURで扱える画像データの形式については，マニュアル「EUR システム設計ガイド」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 63 / 356


4.1.4 データウィンドウから貼り付けたデータ : EUR 帳票作成 操作ガイド

  • 64 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

  • 4.1　アイテムとは

  • 4.1.4　データウィンドウから貼り付けたデータ

4.1.4　データウィンドウから貼り付けたデータ

データウィンドウから貼り付けたデータをアイテムとして扱えます。データウィンドウからデータを貼り付ける操作については，「4.3　データウィンドウからデータを貼り付ける」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 64 / 356


4.1.5 ページ番号・印刷時刻・印刷日付アイテム : EUR 帳票作成 操作ガイド

  • 65 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

  • 4.1　アイテムとは

  • 4.1.5　ページ番号・印刷時刻・印刷日付アイテム

4.1.5　ページ番号・印刷時刻・印刷日付アイテム

ページ番号・印刷時刻・印刷日付アイテムは，［挿入］メニューを選択して，帳票に表示形式を指定することで配置します。ページ番号アイテムを配置する操作については，「4.5　ページ番号を配置する」を参照してください。印刷時刻・印刷日付を配置する操作については「4.6　印刷日付・印刷時刻を配置する」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 65 / 356


4.1.6 部品 : EUR 帳票作成 操作ガイド

  • 66 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

  • 4.1　アイテムとは

  • 4.1.6　部品

4.1.6　部品

複数のアイテムをまとめて登録し，部品として再利用できます。

部品パレットウィンドウから帳票ウィンドウに部品を貼り付けられます。部品を帳票ウィンドウに貼り付ける方法については，「12.4　部品を帳票に貼り付ける」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 66 / 356


4.2 アイテムを配置する : EUR 帳票作成 操作ガイド

  • 67 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

  • 4.2　アイテムを配置する

4.2　アイテムを配置する

ツールボックスのボタンを選択して，文字，線，矩形，網掛けアイテムを帳票に配置します。

アイテムを配置したあと，アイテムのプロパティを設定します。アイテムのプロパティを設定したい場合は，「13.　アイテムのプロパティとオプションを設定する」を参照してください。また，配置したアイテムの位置を変更したり，移動したりする操作については，「4.7　アイテムの位置やサイズを変更する」を参照してください。

アイテム種別ごとの手順を説明します。

〈この節の構成〉

  • 4.2.1　文字アイテムを配置する

  • 4.2.2　線アイテムを配置する

  • 4.2.3　矩形アイテムを配置する

  • 4.2.4　網掛けアイテムを配置する

  • 4.2.5　図形アイテムを配置する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 67 / 356


4.2.1 文字アイテムを配置する : EUR 帳票作成 操作ガイド

  • 68 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

  • 4.2　アイテムを配置する

  • 4.2.1　文字アイテムを配置する

4.2.1　文字アイテムを配置する

  1. ツールボックスのボタンを選択する

    [図データ] ボタンを選択したあと，マウスを帳票に移動すると，ポインタが [図データ] に変わります。ポインタが [図データ] になっている状態を「作成モード」といいます。

  2. 文字アイテムを配置する

    アイテムは，貼付域にだけ配置できます。指定できるアイテムの高さおよび幅は，1.3～431.8mmです。

    文字アイテムは，配置位置を決めてから文字列を入力して作成します。配置位置は，開始点から終了点までをドラッグしてアイテム枠を描きます。配置位置とサイズは，ステータスバーに表示されます。ツールボックスで作成モードにしている間は，同じ種類のアイテムを続けて作成できます。ただし，ドラッグ中に＜Esc＞キーを押すと，アイテムの作成が中断されます。

    文字アイテムに指定できる文字列は，510文字までです。改行は1文字と見なします。入力した文字数が510文字を超えたとき，文字は表示されません。既存の文字アイテムを編集するときは，文字数が510文字を超えないようにしてください。また，アイテム枠内に収まらない文字列は表示されません。指定する文字列がアイテム枠より長くなったり，配置したアイテム枠より大きいサイズのフォントに変更したりしたときは，文字列が正しく表示されるようにアイテム枠のサイズやフォントサイズを調整してください。

  3. 作成モードを解除する

    アイテムを配置したあとは，ツールボックスの [図データ] ボタンをクリックするか，＜Esc＞キーを押して作成モードを解除してください。作成モードを解除した状態を「選択モード」といいます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 68 / 356


4.2.2 線アイテムを配置する : EUR 帳票作成 操作ガイド

  • 69 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

  • 4.2　アイテムを配置する

  • 4.2.2　線アイテムを配置する

4.2.2　線アイテムを配置する

  1. ツールボックスのボタンを選択する

    [図データ] ボタンを選択したあと，マウスを帳票に移動すると，ポインタが [図データ] に変わります。

  2. 線アイテムを配置する

    アイテムは，貼付域にだけ配置できます。指定できるアイテムの高さおよび幅は，1.3～431.8mmです。

    直線を引く場合は，開始点から終了点までをドラッグします。角度によって，水平線，垂直線になります。斜め45°の直線を引く場合は，＜Shift＞キーを押したままドラッグします。

  3. 作成モードを解除する

    アイテムを配置したあとは，ツールボックスの [図データ] ボタンをクリックするか，＜Esc＞キーを押して作成モードを解除してください。

メモ

  • 線・矩形アイテムの特徴

    EURの罫線では，次に示す二つの特徴があります。

    矩形アイテムで作成した4本の線は独立しています。そのため，矩形アイテムで作成した線を選択して線種の変更や移動する場合は，4回の操作が必要です。

    重なった線（直線）は，1本の線として認識されます。 [図データ] ボタンや [図データ] ボタンで作成した線が，重なった（直線に見える）場合は，1本の線として認識されます。そのため，表の枠，フィールド間，およびレコード間の線種を変更する場合，線アイテムを選択するだけなので，簡単です。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 69 / 356


4.2.3 矩形アイテムを配置する : EUR 帳票作成 操作ガイド

  • 70 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

  • 4.2　アイテムを配置する

  • 4.2.3　矩形アイテムを配置する

4.2.3　矩形アイテムを配置する

  1. ツールボックスのボタンを選択する

    [図データ] ボタンを選択したあと，マウスを帳票に移動すると，ポインタが [図データ] に変わります。

  2. 矩形アイテムを配置する

    アイテムは，貼付域にだけ配置できます。指定できるアイテムの高さおよび幅は，1.3～431.8mmです。

    線を矩形に引く場合は，開始点から終了点までをドラッグします。

    正方形に引く場合は，＜Shift＞キーを押したままドラッグします。

  3. 作成モードを解除する

    アイテムを配置したあとは，ツールボックスの [図データ] ボタンをクリックするか，＜Esc＞キーを押して作成モードを解除してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 70 / 356


4.2.4 網掛けアイテムを配置する : EUR 帳票作成 操作ガイド

  • 71 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

  • 4.2　アイテムを配置する

  • 4.2.4　網掛けアイテムを配置する

4.2.4　網掛けアイテムを配置する

  1. ツールボックスのボタンを選択する

    [図データ] ボタンを選択したあと，マウスを帳票に移動すると，ポインタが [図データ] に変わります。ポインタが [図データ] になっている状態を「作成モード」といいます。

  2. 網掛けアイテムを配置する

    アイテムは，貼付域にだけ配置できます。指定できるアイテムの高さおよび幅は，1.3～431.8mmです。

    網掛けアイテムは，開始点から終了点までをドラッグして描きます。配置位置とサイズは，ステータスバーに表示されます。ツールボックスで作成モードにしている間は，同じ種類のアイテムを続けて作成できます。ただし，ドラッグ中に＜Esc＞キーを押すと，アイテムの作成が中断されます。

    正方形に網を掛ける場合は，貼付域で＜Shift＞キーを押したままドラッグします。

  3. 作成モードを解除する

    アイテムを配置したあとは，ツールボックスの [図データ] ボタンをクリックするか，＜Esc＞キーを押して作成モードを解除してください。

メモ

  • 角丸四角アイテム，または円／楕円アイテムに網を掛ける場合は，［アイテムのプロパティ］ダイアログの［図形］タブで設定します。ツールボックスの [図データ] を選択した時の網掛けモードからは設定できません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 71 / 356


4.2.5 図形アイテムを配置する : EUR 帳票作成 操作ガイド

  • 72 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

  • 4.2　アイテムを配置する

  • 4.2.5　図形アイテムを配置する

4.2.5　図形アイテムを配置する

ツールボックスのボタンを選択することで，角丸四角，円／楕円，多角形アイテムを帳票に配置できます。

  1. ツールボックスのボタンを選択する

    ツールボックスから次に示すボタンを選択したあと，マウスを帳票に移動すると，ポインタが [図データ] に変わります。

    角丸四角アイテムを描くとき： [図データ]

    円／楕円アイテムを描くとき： [図データ]

    多角形アイテムを描くとき： [図データ]

  2. 図形アイテムを配置する

    • 角丸四角アイテムと円／楕円アイテムの場合

      開始点から終了点までをドラッグして描きます。アイテムの配置位置とサイズは，ステータスバーに表示されます。作成モードの間は，アイテムを続けて作成できます。ドラッグ中に＜Esc＞キーを押すと，アイテムの作成を中断します。

    • 角丸四角アイテムで正方形を描く場合

      貼付域で＜Shift＞キーを押したままドラッグします。

    • 円／楕円アイテムで均等な円（正円）を描く場合

      貼付域で＜Shift＞キーを押したままドラッグします。

    • 多角形を描く場合

      多角形の頂点の位置に [図データ] を移動してクリックすると，一つ目の頂点ができます。次の頂点も同じように， [図データ] を移動しクリックして作成します。最後の頂点を作成したあと，ダブルクリックすると，最後の頂点と一つ目の頂点がつながります。ダブルクリックした個所には頂点は作成されません。

      頂点は，3個以上作成してください。頂点は36個まで作成できます。36個の頂点が作成された時点で，自動的に多角形の編集が終了します。すべての頂点が一直線上に場合は，アイテムは作成されません。

      多角形の作成例を示します。

  3. 作成モードを解除する

    アイテムを配置したあとは，ツールボックスの [図データ] ボタンをクリックするか，＜Esc＞キーを押して作成モードを解除してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 72 / 356


4.3 データウィンドウからデータを貼り付ける : EUR 帳票作成 操作ガイド

  • 73 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

  • 4.3　データウィンドウからデータを貼り付ける

4.3　データウィンドウからデータを貼り付ける

データウィンドウからドラッグアンドドロップしたデータも，アイテムとして扱えます。

〈この節の構成〉

  • 4.3.1　画像以外のデータを貼り付ける

  • 4.3.2　画像データを貼り付ける

  • 4.3.3　標準料金代理収納システムに対応したGS1-128（UCC/EAN-128）バーコードの出力

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 73 / 356


4.3.1 画像以外のデータを貼り付ける : EUR 帳票作成 操作ガイド

  • 74 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

  • 4.3　データウィンドウからデータを貼り付ける

  • 4.3.1　画像以外のデータを貼り付ける

4.3.1　画像以外のデータを貼り付ける

データウィンドウのデータ（フィールド名，フィールドデータ）は，マッピングデータウィンドウとユーザ定義データウィンドウから貼り付けられます。貼り付けたデータを「マッピングデータ」といいます。

貼り付け元のウィンドウによって，次のとおり使用方法が異なります。

マッピングデータウィンドウから貼り付けたデータの場合

  • 表の作成

    表を作成するために，マッピングデータウィンドウからフィールド名と1レコード分のフィールドデータを帳票ウィンドウに貼り付けます。マッピングデータウィンドウから貼り付けたデータは，読み込んだデータとリンクしています。そのあと，貼り付けたデータを選択して繰り返しを指定すると，簡単に表が作成できます。

  • 改ページ／改ブロック

    定義した表を印刷する場合，データ値によって改ページや改ブロックの制御をしたいことがあります。このような場合は，マッピングデータウィンドウから貼り付けたフィールドを，改ページや改ブロックのキーに設定することで制御できます。このキーとなるフィールドは，表中のフィールドでも，表とは別の位置（繰り返しの対象にしない）に貼り付けたフィールドでもかまいません。表とは別の位置に貼り付けることで，表のタイトルに利用することもできます。

ユーザ定義データウィンドウから貼り付けたデータの場合

ユーザ定義データウィンドウから貼り付けたデータは，直接入力した文字と同じように，すべてのページの同じ位置に同じ内容で表示されます。ただし，帳票を印刷する時に，データファイルを変更することでデータを入れ替えられます。画像データなどを利用して，会社のマークを表示したり，会社名，住所など部分的なデータを入れ替えたりする場合に使用します。

〈この項の構成〉

  • (1)　データを貼り付ける手順

  • (2)　貼り付け操作後の処理

  • (3)　データの貼り付け操作での注意

(1)　データを貼り付ける手順

データは，次の2種類の方法で貼り付けることができます。

(a)　レコード単位の貼り付け

  1. レコードを選択する

    データウィンドウの左端のブロックをクリックします。レコード全体に選択枠が付き，選択状態になります。

  2. データを貼り付ける

    少しマウスを移動すると，マウスの形が [図データ] に変わります。ドラッグして帳票ウィンドウ上に移動し，任意の位置でマウスボタンを離します。この操作で，データが貼り付けられます。

(b)　セル単位の貼り付け

  1. セルを選択する

    データウィンドウのセルをクリックします。セルに選択枠が付き，選択状態になります。

  2. データを貼り付ける

    少しマウスを移動すると，マウスの形が [図データ] に変わります。ドラッグして帳票ウィンドウ上に移動し，任意の位置でマウスボタンを離します。この操作で，データが貼り付けられます。

ページの先頭へ

(2)　貼り付け操作後の処理

帳票ウィンドウにデータを貼り付けたあと，次に示す操作をしてください。

  • 貼り付けたデータのサイズの変更

  • 罫線の設定　…表の枠の作成

  • 繰り返し定義　…表の作成

  • 網掛けの設定　…表のセルへの網掛け

  • データのプロパティ設定（文字列データのプロパティ設定／数値データのプロパティ設定／日付・時刻データのプロパティ設定／バーコードのプロパティ設定）

ページの先頭へ

(3)　データの貼り付け操作での注意

  • レコード単位の貼り付けで，選択したデータの量がレポート編集ウィンドウより大きい場合は，フィールド単位でデータを折り曲げて貼り付けます。

    なお，帳票に貼り付けたあとのデータに，次に示す操作をした場合は，データの属性は保証されませんので，注意してください。

    • データの種別を変更した場合

    • フィールドを削除した場合

    • フィールド名を変更した場合

  • 帳票に貼り付けたあと，フィールド定義またはデータベースアクセス定義で，データ種別の変更，フィールドの削除，またはフィールド名の変更をした場合は，帳票ファイル上のデータは保証されませんので，注意してください。

  • EURで取り扱えるレコード数の制限はありません。ただし，ユーザ環境（ディスク容量やメモリ容量）によってデータの取り込み処理の時間が異なります。

  • データウィンドウからバーコードフィールドのデータを帳票ウィンドウに貼り付けた場合，設定しているバーコードの形式とデータ形式によって，貼り付けたデータが表示されないことがあります。その場合は，データウィンドウからデータを貼り付ける前に，デフォルトで使用するバーコードを設定するか，または貼り付けたあと，［編集］－［アイテムのプロパティ］を選択して，個別にバーコードを変更してください。

    バーコードの形式によっては，貼り付けたバーコードフィールドのデータが，大き過ぎて表示されなかったり，表示領域よりも小さ過ぎたりすることがあります。その場合は，表示領域をバーコードのサイズによって自動的に変更するように設定しておくことをお勧めします。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 74 / 356


4.3.2 画像データを貼り付ける : EUR 帳票作成 操作ガイド

  • 75 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

  • 4.3　データウィンドウからデータを貼り付ける

  • 4.3.2　画像データを貼り付ける

4.3.2　画像データを貼り付ける

データウィンドウから画像データを貼り付ける場合，フィールド中のデータは画像ファイル名になります。［オプション］ダイアログの［ファイル］タブで指定した格納先以外の場所から画像ファイルを貼り付ける場合は，パスを含んだ画像ファイル名を指定してください。

画像データを貼り付ける手順を次に示します。

〈この項の構成〉

  • (1)　データウィンドウへの入力データの取り込み

  • (2)　データウィンドウでのフィールド属性の変更

  • (3)　補足説明

(1)　データウィンドウへの入力データの取り込み

データウィンドウへの入力データの取り込みについては，「3.2　データファイルからの読み込み手順」を参照してください。

ページの先頭へ

(2)　データウィンドウでのフィールド属性の変更

フィールドの種別を「画像」にします。データウィンドウでのフィールド属性の変更については，「3.3　データウィンドウのフィールド定義を変更する」を参照してください。

データウィンドウから画像を貼り付ける操作では，あらかじめツールボックスの [図データ] ボタンを選択し，［画像］のチェックボックスをオンにしておいてください。

  1. 画像ファイルのセルを選択する

    データウィンドウの画像ファイル名のセルを選択します。セルに選択枠が付き，選択状態になります。

  2. データを貼り付ける

    少しマウスを移動すると，マウスの形が [図データ] に変わります。ドラッグして帳票ウィンドウ上に移動し，任意の位置でマウスボタンを離します。

ページの先頭へ

(3)　補足説明

帳票に貼り付けたあとのデータウィンドウで，次に示す操作をした場合は，データの属性は保証されませんので，注意してください。

  • データを貼り付けたあと，貼り付けたデータのタイプを変更した場合

    データタイプは，変更されません。データの表示は，表示できるものだけ表示し，そのほかは空白データで表示されます。

  • データを貼り付けたあと，貼り付けたデータのフィールドを削除した場合

    空白データで表示されます。

  • データを貼り付けたあと，貼り付けたデータのフィールド名を変更した場合

    空白データで表示されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 75 / 356


4.3.3 標準料金代理収納システムに対応したGS1-128（UCC/EAN-128）バーコードの出力 : EUR 帳票作成 操作ガイド

  • 76 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

  • 4.3　データウィンドウからデータを貼り付ける

  • 4.3.3　標準料金代理収納システムに対応したGS1-128（UCC/EAN-128）バーコードの出力

4.3.3　標準料金代理収納システムに対応したGS1-128（UCC/EAN-128）バーコードの出力

EURでは，（財）流通システム開発センターの標準料金代理収納システムに対応したGS1-128（UCC/EAN-128）バーコードを出力できます。

バーコードのデータの準備については，マニュアル「EUR システム設計ガイド」を参照してください。ここでは，データ準備後のフィールド定義，データの貼り付け，プロパティ設定の手順について説明します。

〈この項の構成〉

  • (1)　フィールド定義

  • (2)　帳票の定義

  • (3)　標準料金代理収納システムに対応したGS1-128（UCC/EAN-128）バーコードの出力例

(1)　フィールド定義

［フィールド定義情報］ダイアログを開き，バーコードフィールドの種別を「バーコード」に設定します。目視文字用の文字列フィールドを指定する場合は，種別を「文字列」に設定します。

ページの先頭へ

(2)　帳票の定義

(a)　バーコードフィールドのデータを準備した場合

  1. データを貼り付ける

    バーコードフィールドのデータを，データウィンドウから貼り付けます。

    貼り付けたバーコードアイテムは，バーコード種別がCODE128に設定されていない場合は，何も表示されません。

  2. ［アイテムのプロパティ］ダイアログを表示する

    ［編集］－［アイテムのプロパティ］を選択します。

    ［バーコード］タブでは，次のように設定してください。

    ［回転角度］の設定は，任意です。

  3. データキャラクタの表示属性の設定

    ［データキャラクタ］タブで，使用するフォント，サイズなどを設定してください。

(b)　バーコードフィールドのデータと，目視文字用の文字列フィールドを準備した場合

  1. データを貼り付ける

    バーコードフィールドのデータと，目視文字用の文字列フィールドを，データウィンドウから貼り付けます。

    貼り付けたバーコードアイテムは，バーコード種別がCODE128に設定されていない場合は，何も表示されません。

    目視文字用の文字列は，バーコードアイテムの下に並べて配置してください。

  2. ［アイテムのプロパティ］ダイアログを表示する

    ［編集］－［アイテムのプロパティ］を選択します。

    ［バーコード］タブでは，［データキャラクタを表示する］チェックボックスをオフにしてください。［回転角度］の設定は，任意です。

  3. 目視文字用文字列のフォントを設定する

    ［フォント］タブで，文字アイテムのフォント，サイズなどを設定してください。

ページの先頭へ

(3)　標準料金代理収納システムに対応したGS1-128（UCC/EAN-128）バーコードの出力例

標準料金代理収納システムに対応したGS1-128（UCC/EAN-128）バーコードの出力例を次に示します。

(a)　バーコードフィールドのデータを準備した場合

データキャラクタの表示属性は，すべてデフォルトです。

(b)　バーコードフィールドのデータと，目視文字用の文字列フィールドを準備した場合

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 76 / 356


4.4 画像ファイルを配置する : EUR 帳票作成 操作ガイド

  • 77 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

  • 4.4　画像ファイルを配置する

4.4　画像ファイルを配置する

ここでは，［挿入］メニューを選択して画像ファイルを直接帳票に配置する方法について説明します。

画像ファイルから直接貼り付けた画像を，固定画像といいます。固定画像は，繰り返しをしたときに，同じ画像アイテムを繰り返して貼り付けます。

固定画像を貼り付けると，帳票ファイルに埋め込まれます。そのため，貼り付けた時の画像が，そのまま帳票に出力されます。固定画像のファイルを更新しても，貼り付けた画像アイテムの同期は取れません。ファイルを更新した場合は，再読み込みしてください。画像ファイルを外部データとして取り込み，自動的に画像の更新を反映したい場合は，ユーザ定義データから画像データを貼り付けてください。画像データの貼り付けについては，「4.3.2　画像データを貼り付ける」を参照してください。

複数様式の帳票の場合も，各様式を定義した時に埋め込まれた画像が出力されます。

〈この節の構成〉

  • 4.4.1　帳票に画像ファイルを配置する

  • 4.4.2　貼り付けた画像アイテムを更新する

  • 4.4.3　同じファイル名の画像を複数貼り付ける

  • 4.4.4　補足説明

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 77 / 356


4.4.1 帳票に画像ファイルを配置する : EUR 帳票作成 操作ガイド

  • 78 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

  • 4.4　画像ファイルを配置する

  • 4.4.1　帳票に画像ファイルを配置する

4.4.1　帳票に画像ファイルを配置する

  1. ［画像ファイルの指定］ダイアログを表示する

    ［挿入］－［画像］を選択します。

  2. 画像ファイル名を指定する

    ファイル名を，［ファイル名］のテキストボックスに直接入力するか，またはファイル一覧のリストから選択したあと，［開く］ボタンをクリックします。

  3. 画像ファイルを貼り付ける

    マウスの形が [図データ] に変わります。ドラッグすると，画像の枠が点線で表示されます。画像ファイルを貼り付ける位置でマウスボタンを離すと，画像ファイルが貼り付けられます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 78 / 356


4.4.2 貼り付けた画像アイテムを更新する : EUR 帳票作成 操作ガイド

  • 79 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

  • 4.4　画像ファイルを配置する

  • 4.4.2　貼り付けた画像アイテムを更新する

4.4.2　貼り付けた画像アイテムを更新する

画像ファイルを貼り付けたあと，ファイルを更新した場合は，帳票ウィンドウ上の画像アイテムを更新する必要があります。画像アイテムを更新する方法を次に示します。

  1. 画像アイテムを選択する

    ツールボックスの [図データ] ボタンを選択して選択モードにします。画像アイテムを選択します。

  2. ［アイテムのプロパティ］ダイアログを表示する

    ［編集］－［アイテムのプロパティ］を選択するか，またはショートカットキーの［アイテムのプロパティ］を選択します。

  3. ［画像］タブを表示する

  4. 再読み込みを設定する

    ［再読み込み］ボタンをクリックして，更新した画像ファイルを読み込みます。

  5. ［OK］ボタンをクリックする

    帳票ウィンドウに戻り，設定が反映されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 79 / 356


4.4.3 同じファイル名の画像を複数貼り付ける : EUR 帳票作成 操作ガイド

  • 80 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

  • 4.4　画像ファイルを配置する

  • 4.4.3　同じファイル名の画像を複数貼り付ける

4.4.3　同じファイル名の画像を複数貼り付ける

帳票に同じファイル名の画像ファイルを画像アイテムとして複数貼り付ける場合，すべての画像アイテムに同じ内容の画像が表示されます。そのため，同じファイル名の画像を複数貼り付ける場合，あとで貼り付けた画像ファイルの内容が，前に貼り付けた画像アイテムにも反映されます。また，［アイテムのプロパティ］ダイアログの［画像］タブで，画像ファイルの変更，再読み込みをすると，同じ画像ファイル名を参照しているすべての画像アイテムの画像が更新されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 80 / 356


4.4.4 補足説明 : EUR 帳票作成 操作ガイド

  • 81 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

  • 4.4　画像ファイルを配置する

  • 4.4.4　補足説明

4.4.4　補足説明

バージョン4以前で設計した帳票ファイルは，外部データを読み込んで出力されます。そのため，外部データの画像ファイルがない場合は出力できません。複数様式の帳票の場合も外部データを読み込んで出力されるので，各様式で同じファイル名で異なる内容の画像を出力することはできません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 81 / 356


4.5 ページ番号を配置する : EUR 帳票作成 操作ガイド

  • 82 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

  • 4.5　ページ番号を配置する

4.5　ページ番号を配置する

帳票のページ番号を配置します。

次に示すページ番号の形式が用意されています。

ページ番号の形式

ページ番号は，次に示す種類を組み合わせて設定できます。

  • 先頭のページから1で始まる形式（印刷する時，初期値を変更できます）

  • n/m形式で，印刷するページ全体をmにする形式

  • n/m形式で，改ページのキーに設定したフィールドでキーブレイクした時に，ページ番号nをリセットする形式

  • ページ番号を全角文字で表示する形式

  • ページ番号の前後に文字を付加する形式

形式ごとのページ番号の挿入例を次の図に示します。

図4‒1　形式ごとのページ番号の挿入例

[図データ]

ページ番号の設定個所

ページ番号は，貼付域のほかに，用紙の余白にも設定できます。ただし，次に示すように，設定方法が異なります。

  • 貼付域へ設定する場合

    ページ番号アイテムを挿入する方法（貼付域へのページ番号の挿入）で設定します。ページ番号形式は，ページ番号のプロパティ設定で変更します。

  • 余白へ設定する場合

    レポートのプロパティでページ番号を設定します（余白へのページ番号設定）。ページ番号形式は，［レポートのプロパティ］ダイアログの［レポートの構成］タブで変更します。

〈この節の構成〉

  • 4.5.1　貼付域に挿入する

  • 4.5.2　余白にページ番号を配置する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 82 / 356


4.5.1 貼付域に挿入する : EUR 帳票作成 操作ガイド

  • 83 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

  • 4.5　ページ番号を配置する

  • 4.5.1　貼付域に挿入する

4.5.1　貼付域に挿入する

帳票ファイルの貼付域（余白の内側）にページ番号を挿入します。いろいろな形態のページ番号を印刷できます。ページ番号アイテムを挿入する位置は，帳票ファイルの貼付域であれば自由です。

〈この項の構成〉

  • (1)　ページ番号アイテムの挿入

  • (2)　n/m形式でキーブレイク時にページ番号をリセット

  • (3)　余白のページ番号との関係

(1)　ページ番号アイテムの挿入

  1. ［ページ番号］ダイアログを表示する

    ［挿入］－［ページ番号］を選択します。

  2. ページ番号形式を選択する

    ［表示形式］のリストボックスから，ページ番号の形式を選択します。

  3. ページ番号アイテムを挿入する

    ページ番号の形式を選択したあと，［OK］ボタンをクリックすると，ポインタが [図データ] に変わります。帳票ファイル上のページ番号を挿入する位置でクリックします。

ページの先頭へ

(2)　n/m形式でキーブレイク時にページ番号をリセット

繰り返し機能の改ページに合わせてページ番号をリセットできます。データが変化すると改ページされ，ページ番号もリセットされます。

ページ番号をリセットする場合は，改ページのキーフィールドを指定する時に，「改ページ［初期化あり］」を設定します。

ページ番号のリセットをしている例を次に示します。

改ページのキーと設定したフィールドでキーブレイクされた時，ページ番号nがリセットされます。

ページの先頭へ

(3)　余白のページ番号との関係

UNIX版 EUR旧製品の帳票は，貼付域にページ番号アイテムを挿入できないため，ページ番号を余白に設定します。

余白のページ番号は，形式や位置を変更したり，印刷する開始番号を設定したりできますが，印刷プレビューと印刷した帳票でしか確認できません。

余白のページ番号は，［用紙の設定］ダイアログの［余白］で設定した領域に印刷されます。余白のページ番号を出力する場合は，プリンタのハードマージンに掛からないように，用紙の余白は余裕を持って設定してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 83 / 356


4.5.2 余白にページ番号を配置する : EUR 帳票作成 操作ガイド

  • 84 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

  • 4.5　ページ番号を配置する

  • 4.5.2　余白にページ番号を配置する

4.5.2　余白にページ番号を配置する

ページの余白に，ページ番号を挿入できます。

〈この項の構成〉

  • (1)　余白にページ番号を配置する手順

  • (2)　貼付域のページ番号との関係

  • (3)　補足説明

(1)　余白にページ番号を配置する手順

  1. ［レポートのプロパティ］ダイアログを表示する

    ［ファイル］－［プロパティ］を選択します。［レポートの構成］タブを選択します。

  2. 余白へのページ番号を設定する

    次に示す項目を設定します。

    貼付域外の印刷：

    余白へのページ番号を印刷する場合は，［貼付域外の印刷］グループボックスの［する］のラジオボタンをクリックします。

    形式：

    余白のページ番号の印刷形式を指定します。ページ番号を「*」，最終ページ番号を「$」で示して印刷形式を指定します。ほかの文字は，固定文字として扱います。「*」と「$」を全角文字で設定すると，全角文字のページ番号で印刷できます。初期値は，「－＊－」です。

    （例）

    指定した形式

    出力結果

    *

    ページ番号は半角文字。

    1

    －＊－

    ページ番号は全角文字。

    ページ番号の前後に固定文字「－」を付加。

    －１－

    －＊／＄－

    ページ番号，最終ページ番号は全角文字。

    ページ番号の前後に固定文字「－」を付加。

    n/m形式で出力するため，ページ番号と最終ページ番号の間に「／」を指定。

    －１／５－

    （＊）

    ページ番号は全角文字。

    ページ番号の前後に固定文字「（」「）」を付加。

    （１）

    位置：

    余白（帳票上のマージン内）へのページ番号の印刷位置を選択します。

    指定できる印刷位置を次に示します。初期値は，「中央下」です。

    開始番号：

    ページ番号の初期値を指定します。初期値として指定できる値は，1～32,767です。この初期値を設定することで，印刷する時の開始ページ番号を変更できます。*/$形式の場合でも有効です。

    改ページの設定に従う：

    帳票内に改ページの設定（初期化あり）がある場合，その改ページのタイミングでページ番号を初期化するかどうかを指定します。

  3. ［OK］ボタンをクリックする

    ［OK］ボタンをクリックします。帳票ウィンドウに戻り，設定が反映されます。

ページの先頭へ

(2)　貼付域のページ番号との関係

UNIX版 EUR旧製品の帳票は，貼付域にページ番号アイテムを挿入できないため，ページ番号を余白に設定します。

余白のページ番号は，［用紙の設定］ダイアログの［余白］で設定した領域に印刷されます。余白のページ番号を出力する場合は，プリンタのハードマージンに掛からないように，用紙の余白は余裕を持って設定してください。

ページの先頭へ

(3)　補足説明

  • 余白へのページ番号の印刷は，アプリケーションから帳票を印刷する場合に，プログラムから変更できます。

  • 余白へのページ番号を設定しても，帳票ウィンドウには表示されません。印刷プレビューで確認してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 84 / 356


4.6 印刷日付・印刷時刻を配置する : EUR 帳票作成 操作ガイド

  • 85 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

  • 4.6　印刷日付・印刷時刻を配置する

4.6　印刷日付・印刷時刻を配置する

印刷する時の日付や時刻を帳票に設定できます。印刷する時の日付や時刻を帳票に設定したい場合は，印刷日付アイテムや印刷時刻アイテムを帳票に配置します。印刷日付アイテム，印刷時刻アイテムは，印刷対象のデータとは関係なく設定できるアイテムです。

印刷日付・時刻の形式

一般的に使用する形式（西暦および和暦）は，すべてサンプルとして登録されています。

印刷日付・時刻の設定個所

印刷日付・時刻は，貼付域に設定できます。用紙の余白には，設定できません。

貼付域には，印刷日付アイテム，および印刷時刻アイテムを挿入する方法（印刷日付の設定，印刷時刻の設定）で設定します。日付および時刻形式は，日付・時刻データのプロパティ設定で変更します。

印刷日付・時刻は，ページが印刷される日付・時刻を示しているので，一度に複数ページを印刷すると，最初と最後で日付・時刻が異なる場合があります。

印刷日付・印刷時刻アイテムを配置する手順を次に示します。

〈この節の構成〉

  • 4.6.1　印刷日付アイテムを配置する

  • 4.6.2　印刷時刻アイテムを配置する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 85 / 356


4.6.1 印刷日付アイテムを配置する : EUR 帳票作成 操作ガイド

  • 86 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

  • 4.6　印刷日付・印刷時刻を配置する

  • 4.6.1　印刷日付アイテムを配置する

4.6.1　印刷日付アイテムを配置する

  1. ［印刷日付］ダイアログを表示する

    ［挿入］－［印刷日付］を選択します。

  2. 日付形式を選択する

    ［表示形式］のリストボックスから，日付の形式を選択します。

  3. 印刷日付アイテムを配置する

    印刷日付アイテムの形式を選択したあと，［OK］ボタンをクリックすると，ポインタが [図データ] に変わります。印刷日付アイテムを配置する位置でクリックします。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 86 / 356


4.6.2 印刷時刻アイテムを配置する : EUR 帳票作成 操作ガイド

  • 87 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

  • 4.6　印刷日付・印刷時刻を配置する

  • 4.6.2　印刷時刻アイテムを配置する

4.6.2　印刷時刻アイテムを配置する

  1. ［印刷時刻］ダイアログを表示する

    ［挿入］－［印刷時刻］を選択します。

  2. 時刻形式を選択する

    ［表示形式］のリストボックスから時刻の形式を選択します。

  3. 印刷時刻アイテムを配置する

    印刷時刻アイテムの形式を選択したあと，［OK］ボタンをクリックすると，ポインタが [図データ] に変わります。印刷時刻アイテムを配置する位置でクリックします。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 87 / 356


4.7 アイテムの位置やサイズを変更する : EUR 帳票作成 操作ガイド

  • 88 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

  • 4.7　アイテムの位置やサイズを変更する

4.7　アイテムの位置やサイズを変更する

アイテムを選択して，サイズを変更したり，移動したりできます。

貼り付けたアイテムの貼り付け位置，およびサイズを変更するには，マウス操作で変更する方法と，［アイテムのプロパティ］ダイアログで直接変更する方法と，キー操作で変更する方法があります。

〈この節の構成〉

  • 4.7.1　位置やサイズを変更するときの単位を設定する

  • 4.7.2　アイテムを選択する

  • 4.7.3　マウス操作で変更する

  • 4.7.4　ダイアログで変更する

  • 4.7.5　キー操作で変更する

  • 4.7.6　多角形アイテムを調整する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 88 / 356


4.7.1 位置やサイズを変更するときの単位を設定する : EUR 帳票作成 操作ガイド

  • 89 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

  • 4.7　アイテムの位置やサイズを変更する

  • 4.7.1　位置やサイズを変更するときの単位を設定する

4.7.1　位置やサイズを変更するときの単位を設定する

アイテムの移動，およびリサイズは，アイテムをグリッド補正するかどうかの設定によって，単位が異なります。アイテムをグリッド補正するかどうかは，［レポートのプロパティ］ダイアログの［レポートの構成］タブで設定します。

グリッド補正する場合は，選択したアイテムを，押したキーの矢印の方向に一マスずつ移動，またはリサイズします。操作中の帳票は，マス目の大きさも［レポートのプロパティ］ダイアログの［レポートの構成］タブで設定します。

グリッド補正しない場合は，選択したアイテムを使用する単位の最小値で移動，またはリサイズするので，微調整ができます。この場合，帳票ウィンドウの表示倍率を高くしておくと，移動量がわかりやすくなります。使用する単位は，［オプション］ダイアログの［表示］タブで設定します。使用する単位ごとのアイテムの移動，およびリサイズ量を次に示します。

表4‒1 使用する単位ごとのアイテムの移動，およびリサイズ量
使用する単位 | 移動，およびリサイズ量
ミリメートル（mm） | 0.01ミリメートル
インチ（in） | 0.01インチ
ピクセル（px） | 1ピクセル

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 89 / 356


4.7.2 アイテムを選択する : EUR 帳票作成 操作ガイド

  • 90 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

  • 4.7　アイテムの位置やサイズを変更する

  • 4.7.2　アイテムを選択する

4.7.2　アイテムを選択する

アイテムの選択は，ツールボックスで [図データ] ボタンを押して選択モードにしてから，選択したいアイテムのチェックボックスをオンにします。そのあと，帳票ウィンドウで次に示す操作をします。選択されたアイテムは，反転表示されます。

〈この項の構成〉

  • (1)　アイテムを選択する方法

  • (2)　線アイテムを選択するときの注意

(1)　アイテムを選択する方法

アイテムを複数，または追加選択する場合，種別の異なるアイテムを一緒に選択できます。

アイテムの選択には，次に示す三つの方法があります。

  • 単一選択

    選択するアイテムをクリックします。

  • 複数選択

    選択するアイテムを囲むようにドラッグします。ドラッグすると，始点からマウスの動きに合わせてラバーバンドが表示されます。ラバーバンド内のすべてのアイテムが選択されます。

  • 追加選択

    追加して選択するアイテムを＜Ctrl＞キーを押しながらクリックします。

なお，アイテムを複数選択する場合，種類別にアイテムを選択させないようにできます。種類別にアイテムを選択させないようにする場合は，ツールボックスのチェックボックスを使用します。選択したくないアイテムのチェックボックスをオフにすると，アイテムは選択されません。

（例）ツールボックスの線のチェックを外した場合

ページの先頭へ

(2)　線アイテムを選択するときの注意

EURの線は次に示す特徴があります。そのため，線アイテムを選択する場合は，注意が必要です。

  • [図データ] ボタンで作成した枠は，1本1本独立しています。

  • 重なった線（直線）は，1本の線として認識されます。

線アイテムを複数選択する場合は，＜Ctrl＞キーを押したままクリックしてください。

表などを構成する線の一部を複数選択で選択する場合は，選択対象とする線の部分をラバーバンドでなぞるようにドラッグしてください。この場合，線アイテムは，1本1本の線を選択状態にするのではなく，ラバーバンドで囲まれた部分だけを対象とします。

（例）

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 90 / 356


4.7.3 マウス操作で変更する : EUR 帳票作成 操作ガイド

  • 91 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

  • 4.7　アイテムの位置やサイズを変更する

  • 4.7.3　マウス操作で変更する

4.7.3　マウス操作で変更する

アイテムを選択状態にしたあと，マウスポインタが次に示す矢印に変更されたのを確認してドラッグしてください。アイテムは，複数選択できます。

操 作 | マウスポインタの形状
縦方向のサイズを変更する場合 | [図データ]
横方向のサイズを変更する場合 | [図データ]
縦横両方向のサイズを変更する場合 | [図データ] または [図データ]
貼り付け位置を変更（移動）する場合 | [図データ]

線アイテムの位置を移動する場合は，線アイテムを選択状態にしたあと，マウスポインタをドラッグすると，マウスポインタが [図データ] に変わります。

なお，微調整する場合は，［レポートのプロパティ］ダイアログの［レポートの構成］タブで，［アイテムをグリッド補正する］のチェックボックスをオフにしておいてください。

〈この項の構成〉

  • (1)　角丸めの角度を変更するとき

  • (2)　アイテムをリサイズするときの注意

(1)　角丸めの角度を変更するとき

角丸四角モードを解除すると，角丸四角アイテムに [図データ] が表示されます。マウスを [図データ] に移動すると，ポインタが [図データ] に変わります。 [図データ] を [図データ] に合わせてドラッグすると，角丸めの大きさを変更できます。

[図データ] を下方向にドラッグすると角が丸くなり， [図データ] を上方向にドラッグすると角が直角になります。マウスをドラッグしている間， [図データ] は動きません。マウスボタンを離すと，角丸めの半径が確定されます。

角丸四角アイテムの丸め半径の最小値は0，最大値はアイテムの一辺の1/2です。 [図データ] の位置がアイテムの短辺の1/2に位置している場合は，それ以上の丸めを指定することはできません。

ページの先頭へ

(2)　アイテムをリサイズするときの注意

キー操作でのアイテムのリサイズは，選択したアイテムの左上を基準にして，下端，および右端をキー操作で移動できます。そのため，選択したアイテムの右上を基準にした，上端，および左端のリサイズは，キー操作ではできません。

アイテムの右上を基準にして，上端，および左端をリサイズする場合は，アイテムを選択したあと，マウスでドラッグしてください。

アイテムのサイズに指定できる［幅］と［高さ］の最小値は，使用する解像度148dpiとした場合の7pxです。最大値は，アイテムの開始位置から貼付域すべてです。

アイテムのサイズを変更すると，アイテム内の文字列がはみ出し，表示できない場合があります。文字列がアイテム内からはみ出る場合は，アイテム種別ごとに次のように表示されます。

アイテム種別

文字列がアイテム内からはみ出る場合の表示形式

ページ番号アイテム

アイテム枠内に「***」と表示されます。高さに余裕があるときは，複数行に折り曲げて表示されます。

印刷時刻アイテム

アイテム枠内に表示できる範囲だけ表示されます。高さに余裕がある場合は，複数行に折り曲げて表示されます。

印刷日付アイテム

文字アイテム

マッピングしたアイテム
データ種別が数値または数値（集計対象外）の場合

アイテム枠内に「***」と表示されます。高さに余裕がある場合は，複数行に折り曲げて表示されます。

データ種別が文字，日付（日付・時刻），日付（日次），日付（月次），日付（年次），和暦（日次），和暦（月次），または和暦（年次）の場合

アイテム枠内に表示できる範囲だけ表示されます。高さに余裕があるときは，複数行に折り曲げて表示されます。

データ種別がバーコードの場合

空白で表示されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 91 / 356


4.7.4 ダイアログで変更する : EUR 帳票作成 操作ガイド

  • 92 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

  • 4.7　アイテムの位置やサイズを変更する

  • 4.7.4　ダイアログで変更する

4.7.4　ダイアログで変更する

アイテムを選択したあと，［アイテムのプロパティ］ダイアログの［位置・サイズ］タブで変更します。アイテムは，複数選択できます。

［位置・サイズ］タブは，あらかじめ決められた位置にアイテムを配置したり，アイテムのサイズを直接変更したりする場合に便利です。［レポートのプロパティ］ダイアログの［レポートの構成］タブで，［アイテムをグリッド補正する］のチェックボックスがオンであっても，指定した位置に配置したり，変更したりできます。

複数アイテムを選択して，［位置・サイズ］タブを表示すると，［開始位置］，［サイズ］，および［丸め］は空白で表示されます。何も入力しない場合は，選択したアイテムの位置・サイズ・角丸めの半径は変わりません。［開始位置］，［サイズ］，および［丸め］に数値を入力すると，選択したすべてのアイテムが，入力した位置・サイズ・角丸めに変更されるので注意してください。

［位置・サイズ］タブについては，マニュアル「EUR 帳票作成 画面リファレンス」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 92 / 356


4.7.5 キー操作で変更する : EUR 帳票作成 操作ガイド

  • 93 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

  • 4.7　アイテムの位置やサイズを変更する

  • 4.7.5　キー操作で変更する

4.7.5　キー操作で変更する

〈この項の構成〉

  • (1)　位置を移動する

  • (2)　アイテムをリサイズする

(1)　位置を移動する

アイテムを選択状態にしたあと，＜↑＞，＜↓＞，＜←＞，＜→＞キーのどれかを選択すると，アイテムを移動できます。キー操作ができるのは，文字アイテム，線アイテム，図形アイテム，画像アイテム，バーコードアイテム，および部品です。

ただし部品は，［部品の登録］ダイアログで［常に指定位置に配置］チェックボックスにチェックを入れていた場合は，移動できません。

次に示すアイテムの表示例を用いて，キー操作とその結果を示します。

（例）

ページの先頭へ

(2)　アイテムをリサイズする

アイテムを選択状態にしたあと，＜Shift＞キーと＜↑＞，＜↓＞，＜←＞，＜→＞キーのどれかを同時に選択すると，アイテムをリサイズできます。

キーの組み合わせと機能を次に示します。

表4‒2 リサイズのキーの組み合わせ
キー | 機能
＜Shift＞＋＜↑＞ | アイテムの高さが小さくなります。
＜Shift＞＋＜↓＞ | アイテムの高さが下方向に大きくなります。
＜Shift＞＋＜←＞ | アイテムの幅が小さくなります。
＜Shift＞＋＜→＞ | アイテムの幅が右方向に大きくなります。
（例）

選択したアイテムを，右斜め下方向にリサイズします（グリッド補正あり）。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 93 / 356


4.7.6 多角形アイテムを調整する : EUR 帳票作成 操作ガイド

  • 94 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

  • 4.7　アイテムの位置やサイズを変更する

  • 4.7.6　多角形アイテムを調整する

4.7.6　多角形アイテムを調整する

作成した多角形アイテムは，回転したり，反転したりできます。また，多角形の頂点の位置を調節して，多角形アイテムの形を変更できます。

多角形の作成中（頂点の選択中）にほかの操作はできません。いったん操作を完了してください。

〈この項の構成〉

  • (1)　多角形の回転

  • (2)　多角形の反転

  • (3)　多角形の頂点の編集

(1)　多角形の回転

選択した多角形アイテムを反時計回りに回転します。

多角形アイテムを一つ以上選択したあと，［編集］－［回転］を選択して操作します。90°，180°，270°，または任意の角度が指定できます。任意の角度を指定する場合，指定できる角度は，1～359の範囲です。1～359以外の数字または数字以外の文字を入力した場合は，エラーとなります。

(a)　注意事項

  • 角丸四角アイテムおよび円／楕円アイテムは編集できません。

  • 多角形アイテム以外のアイテムが選択されている場合は，［編集］－［回転］は選択できません。

  • 回転の結果，アイテムが貼付域をはみ出ても，位置の補正はされません。

ページの先頭へ

(2)　多角形の反転

選択した多角形アイテムを反転します。アイテムを一つ以上選択したあと，［編集］－［反転］を選択して操作します。左右反転または上下反転が指定できます。

(a)　注意事項

  • 角丸四角アイテムおよび円／楕円アイテムは編集できません。

  • 多角形アイテム以外のアイテムが選択されている場合は，［編集］－［反転］は選択できません。

  • 多角形アイテム以外のアイテムが選択されている場合は，［反転］は選択できません。

ページの先頭へ

(3)　多角形の頂点の編集

多角形アイテムの頂点の位置を変更できます。アイテムを帳票ウィンドウに配置したあと，角度や形を微調整できます。アイテムを選択したあと，［編集］－［頂点の編集］を選択して操作します。

（例）

多角形アイテムを選択したあと，［頂点の編集］を選択すると，多角形アイテムの頂点にハンドルが表示されます。ハンドルにポインタを合わせると，ポインタの形状が [図データ] に変わるので， [図データ] を移動して，頂点を変更します。

(a)　注意事項

  • 角丸四角アイテムおよび円／楕円アイテムは編集できません。

  • 多角形アイテム以外のアイテムが選択されている場合，または複数アイテムを選択している場合は，［編集］－［頂点の編集］は選択できません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 94 / 356


4.8 複数アイテムの重なりや位置を調整する : EUR 帳票作成 操作ガイド

  • 95 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

  • 4.8　複数アイテムの重なりや位置を調整する

4.8　複数アイテムの重なりや位置を調整する

アイテムが別のアイテムの下に隠れてしまった場合は，アイテムの重なりを変更できます。重なりが変更できるアイテムは，文字アイテム，図形アイテム，および画像アイテムです。線アイテムの重なりは変更できません。

重なりを変更できるのは，同じ種別のアイテムだけです。文字アイテムと図形アイテムなど，異なる種別のアイテムを複数選択した場合は，変更できません。また部品を選択していた場合も，重なりは変更できません。

異なる種別のアイテム間では，上から文字アイテム＞線アイテム＞図形アイテム＞画像アイテムの順で表示されます。また，通常行と集計行の間にも表示順序があります。アイテム種別間，および通常行／集計行間での重なりの順序を次に示します。

表4‒3 アイテム種別間の重なりの順序
重なりの順序 | 行の種別 | アイテム種別
1（いちばん上に表示） | 総集計行 | 文字アイテム
2 |  | 線アイテム
3 |  | 図形アイテム
4 |  | 画像アイテム
5 | ページ集計行 | 文字アイテム
6 |  | 線アイテム
7 |  | 図形アイテム
8 |  | 画像アイテム
9 | キー集計行：上位階層 特殊編集レベル：高 | 文字アイテム
10 |  | 線アイテム
11 |  | 図形アイテム
12 |  | 画像アイテム
13 | キー集計行：下位階層 特殊編集レベル：低 | 文字アイテム
14 |  | 線アイテム
15 |  | 図形アイテム
16 |  | 画像アイテム
17 | 通常行 | 文字アイテム
18 |  | 線アイテム
19 |  | 図形アイテム
20（いちばん下に表示） |  | 画像アイテム

重なりの変更は，同じ種別のアイテムを一つ以上選択したあと，［編集］－［順序］を選択して操作します。

〈この節の構成〉

  • 4.8.1　重なりを変更する

  • 4.8.2　レイアウトを揃える

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 95 / 356


4.8.1 重なりを変更する : EUR 帳票作成 操作ガイド

  • 96 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

  • 4.8　複数アイテムの重なりや位置を調整する

  • 4.8.1　重なりを変更する

4.8.1　重なりを変更する

重なりの変更では，次の操作ができます。

〈この項の構成〉

  • (1)　最前面へ移動する

  • (2)　最背面へ移動する

  • (3)　前面へ移動する

  • (4)　背面へ移動する

(1)　最前面へ移動する

選択したアイテムを同じ種別のアイテムの中でいちばん上に入れ替えます。複数アイテムを選択していた場合は，選択したアイテムの中で重なりの順序を保ったまま，入れ替えます。

（例）表を図形アイテムで囲む

次のような表を作成する場合の操作を次に示します。

  1. 角丸四角アイテムを作成し，表の上に配置します。

    表の網掛けが角丸四角に隠れてしまいます。

  2. 網掛けアイテムを選択し，［編集］－［順序］－［最前面へ移動］を選択します。

    網掛けが最前面に表示されます。

ページの先頭へ

(2)　最背面へ移動する

選択したアイテムを同じ種別のアイテムの中でいちばん下に入れ替えます。複数アイテムを選択していた場合は，選択したアイテムの中で重なりの順序を保ったまま，入れ替えます。

（例）表を図形アイテムで囲む

次のような表を作成する場合の操作を次に示します。

  1. 角丸四角アイテムを作成し，表の上に配置します。

    表の網掛けが角丸四角アイテムに隠れてしまいます。

  2. 角丸四角アイテムを選択し，［編集］－［順序］－［最背面へ移動］を選択します。

    角丸四角が最背面に表示されます。

ページの先頭へ

(3)　前面へ移動する

選択したアイテムを同じ種別のアイテムの一つ上に入れ替えます。複数アイテムを選択していた場合は，選択したアイテムの中で重なりの順序を保ったまま，入れ替えます。

（例）表の背景に図形アイテムを貼り付ける

次のような表を作成する場合の操作を次に示します。

  1. 塗りつぶしのアイテムを作成し，表の上に配置します。

    表の網掛けが塗りつぶしアイテムに隠れてしまいます。

  2. 網掛けアイテムを選択し，［編集］－［順序］－［前面へ移動］を選択します。

    網掛けアイテムが前面に表示されます。

ページの先頭へ

(4)　背面へ移動する

選択したアイテムを同じ種別のアイテムの一つ下に入れ替えます。複数アイテムを選択していた場合は，選択したアイテムの中で重なりの順序を保ったまま，入れ替えます。

（例）表の背景に図形アイテムを貼り付ける

次のような表を作成する場合の操作を次に示します。

  1. 塗りつぶしアイテムを作成し，表の上に配置します。

    表の網掛けが塗りつぶしアイテムに隠れてしまいます。

  2. 塗りつぶしアイテムを選択し，［編集］－［順序］－［背面へ移動］を選択します。

    塗りつぶしアイテムが背面に表示されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 96 / 356


4.8.2 レイアウトを揃える : EUR 帳票作成 操作ガイド

  • 97 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

  • 4.8　複数アイテムの重なりや位置を調整する

  • 4.8.2　レイアウトを揃える

4.8.2　レイアウトを揃える

複数アイテムの位置を揃えたり，高さや幅を揃えたりできます。アイテムを複数選択したあと，［編集］－［揃え］を選択するか，または揃えツールバーのボタンをクリックして操作します。

［揃え］および揃えツールバーは，アイテムを複数選択すると，選択できます。

アイテムを一つだけ選択した場合は，利用できません。また部品を選択していた場合も，レイアウト揃えはできません。

レイアウト揃えでは，次に示す操作ができます。

  • 左揃え

  • 右揃え

  • 上揃え

  • 下揃え

  • 幅揃え

  • 高さ揃え

操作の例は，ツールバーを使用して説明しています。また，説明中のX座標とY座標は，帳票ウィンドウの貼付域左上端を原点として，横方向をX座標，縦方向をY座標で示しています。

〈この項の構成〉

  • (1)　左揃え

  • (2)　右揃え

  • (3)　上揃え

  • (4)　下揃え

  • (5)　幅を揃える

  • (6)　高さを揃える

(1)　左揃え

選択したアイテムのうち，X座標値がいちばん小さいアイテムに合わせて，ほかのアイテムを左に揃えます。

複数選択したアイテムが横に配置されている場合は，X座標値がいちばん小さいアイテムに重なって表示されます。重なったアイテムは，［編集］－［順序］で重なりの順序を変更できます。ただし，重なりの順序を変更できるのは，同じ種別のアイテムだけです。

帳票ヘッダアイテムとそのほかのアイテムが同時に選択され，繰り返しの優先方向が横に設定されている場合は，メニューまたはツールバーの［左揃え］は選択できません。

X座標値がいちばん小さいアイテムが用紙からはみ出している場合は，貼付域のいちばん左にアイテムが揃えられます。

（例）

アイテムを複数選択したあと，ツールバーの［左揃え］ボタンをクリックすると，「製品名」の左端に合わせて，「鉛筆」が揃えられます。

ページの先頭へ

(2)　右揃え

選択したアイテムのうち，X座標値がいちばん大きいアイテムに合わせて，ほかのアイテムを右に揃えます。

複数選択したアイテムが横に配置されている場合は，X座標値がいちばん大きいアイテムに重なって表示されます。重なったアイテムは，［編集］－［順序］で重なりの順序を変更できます。ただし，重なりの順序を変更できるのは，同じ種別のアイテムだけです。

帳票ヘッダアイテムとそのほかのアイテムが同時に選択され，繰り返しの優先方向が横に設定されている場合は，メニューまたはツールバーの［右揃え］は選択できません。

X座標値がいちばん大きいアイテムが用紙からはみ出している場合は，貼付域のいちばん右にアイテムが揃えられます。

（例）

アイテムを複数選択したあと，ツールバーの［右揃え］ボタンをクリックすると，「製品名」の右端に合わせて，「鉛筆」が揃えられます。

ページの先頭へ

(3)　上揃え

選択したアイテムのうち，Y座標値がいちばん小さいアイテムに合わせて，ほかのアイテムを上に揃えます。

複数選択したアイテムが縦に配置されている場合は，Y座標値がいちばん小さいアイテムに重なって表示されます。重なったアイテムは，［編集］－［順序］で重なりの順序を変更できます。ただし，重なりの順序を変更できるのは，同じ種別のアイテムだけです。

帳票ヘッダアイテムとそのほかのアイテムが同時に選択され，繰り返しの優先方向が縦に設定されている場合は，メニューまたはツールバーの［上揃え］は選択できません。

Y座標値がいちばん小さいアイテムが用紙からはみ出している場合は，貼付域のいちばん上にアイテムが揃えられます。

（例）

アイテムを複数選択したあと，ツールバーの［上揃え］ボタンをクリックすると，「型」の上端に合わせて，「製品名」と「生産数」が揃えられます。

ページの先頭へ

(4)　下揃え

選択したアイテムのうち，Y座標値がいちばん大きいアイテムに合わせて，ほかのアイテムを下に揃えます。

複数選択したアイテムが縦に配置されている場合は，Y座標値がいちばん大きいアイテムに重なって表示されます。重なったアイテムは，［編集］－［順序］で重なりの順序を変更できます。ただし，重なりの順序を変更できるのは，同じ種別のアイテムだけです。

帳票ヘッダアイテムとそのほかのアイテムが同時に選択され，繰り返しの優先方向が縦に設定されている場合は，メニューまたはツールバーの［下揃え］は選択できません。

Y座標値がいちばん大きいアイテムが用紙からはみ出している場合は，貼付域のいちばん下にアイテムが揃えられます。

（例）

アイテムを複数選択したあと，ツールバーの［下揃え］ボタンをクリックすると，「生産数」の下端に合わせて，「製品名」と「型」が揃えられます。

ページの先頭へ

(5)　幅を揃える

選択したアイテムのうち，Y座標値のいちばん小さいアイテム，またはY座標値がすべて同じであれば，X座標値のいちばん小さいアイテムの幅に合わせて，ほかのアイテムの幅を揃えます。

選択したアイテムに縦罫線がある場合は，メニューまたはツールバーの［幅を揃える］は選択できません。

幅を変更することで，用紙からはみ出したアイテムは，アイテム枠の右端を，右余白に揃えて配置します。

（例）

アイテムを複数選択したあと，ツールバーの［幅を揃える］ボタンをクリックすると，「製品名」の幅に合わせて，「型」と「生産数」の幅が揃えられます。

ページの先頭へ

(6)　高さを揃える

選択したアイテムのうち，Y座標値のいちばん小さいアイテム，またはY座標値がすべて同じであれば，X座標値のいちばん小さいアイテムの高さに合わせて，ほかのアイテムの高さを揃えます。

選択したアイテムに横罫線がある場合は，メニューまたはツールバーの［高さを揃える］は選択できません。

高さを変更することで，用紙からはみ出したアイテムは，アイテム枠の下端を，下余白に揃えて配置します。

（例）

アイテムを複数選択したあと，ツールバーの［高さを揃える］ボタンをクリックすると，「製品名」の高さに合わせて，「鉛筆」の高さが揃えられます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 97 / 356


4.9 特定のページに出力するアイテムを設定する : EUR 帳票作成 操作ガイド

  • 98 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

  • 4.9　特定のページに出力するアイテムを設定する

4.9　特定のページに出力するアイテムを設定する

帳票上に設定したアイテムを，先頭，または最終ページだけに出力できます。先頭，または最終ページだけに出力するアイテムの設定は，［アイテムのプロパティ］ダイアログで設定します。

この機能は，出力する帳票に合わせたデータを準備しておくことで，ほかのユーザアプリケーションプログラムで求めた集計データを帳票に出力することもできます。

〈この節の構成〉

  • 4.9.1　出力ページに出力するデータの準備

  • 4.9.2　アイテムの出力ページの設定

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 98 / 356


4.9.1 出力ページに出力するデータの準備 : EUR 帳票作成 操作ガイド

  • 99 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

  • 4.9　特定のページに出力するアイテムを設定する

  • 4.9.1　出力ページに出力するデータの準備

4.9.1　出力ページに出力するデータの準備

データがキーでソートされていないために，EURが提供している集計機能が使えないとか，EURの集計機能では機能が足りないなどの場合は，ほかのユーザアプリケーションプログラムで集計データを求めて，マッピングデータ，またはユーザ定義データに定義しておくことで利用できます。

最終ページだけに科目別集計データを出力する例を次に示します。

マッピングデータに指定する明細データは，データの発生順であるため，EURの集計機能は使用できません。そのため，科目別集計データは，ほかのユーザアプリケーションプログラムで求めて，ユーザ定義データに定義しておきます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 99 / 356


4.9.2 アイテムの出力ページの設定 : EUR 帳票作成 操作ガイド

  • 100 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

  • 4.9　特定のページに出力するアイテムを設定する

  • 4.9.2　アイテムの出力ページの設定

4.9.2　アイテムの出力ページの設定

アイテムの出力ページは，［アイテムのプロパティ］ダイアログの［出力ページ］タブで設定します。

編集モードの場合は，先頭ページ，または最終ページだけに出力するアイテムは，出力ページが設定された先頭ページ，または最終ページだけアイテム枠が赤色で表示されます。それ以外のページでは，アイテム枠が紫色で表示されます。ただし，線アイテムだけは，先頭ページ，または最終ページだけに出力するアイテムに設定しても，どのページも従来どおり表示します。

レイアウトモードの場合は，設定したページにだけ表示されます。

印刷時のイメージを確認したい場合は［表示］－［レイアウト］を選択するか，［ファイル］－［印刷プレビュー］を選択してください。

先頭ページと最終ページの定義

先頭ページと最終ページの定義は，次のどちらかの範囲で指定します。

  • キーブレイクによる改ページで区切られた範囲

    先頭ページ

    すべてのデータが出力された最初のページ，およびキーブレイクによって改ページされたページを指します。

    最終ページ

    すべてのデータが出力された最終のページ，およびキーブレイクによって改ページされたページの一つ前のページを指します。

  • ページ番号の初期化の指定で区切られた範囲

    先頭ページ

    すべてのデータが出力された最初のページ，およびページ番号が初期化されたページ※1を指します。

    最終ページ

    すべてのデータが出力された最終のページ※2，およびページ番号が初期化されたページ※1の一つ前のページを指します。

注※1

複数様式の帳票の場合，複数様式情報定義ファイルのキーワードresetpagenumberの設定によってページ番号を初期化したページを指します。

注※2

単一様式の帳票の場合，集計ページがあるときは，集計ページの一つ前のページを指します。

先頭ページと最終ページを定義する範囲の指定方法は，帳票が単一様式か複数様式かによって次のとおり異なります。

■単一様式の帳票の場合

［レポートのプロパティ］ダイアログの［レポートの構成］タブにある［先頭・最終ページの範囲］グループボックスで定義します。

■複数様式の帳票の場合

環境変数EUR_RANGE_OF_FIRSTANDLASTPAGES_ON_MULTIFORM_BY_RESETPAGENUMBERで定義します。

〈この項の構成〉

  • (1)　アイテムの出力ページに設定できるアイテム

  • (2)　アイテムの出力ページを設定する

  • (3)　出力ページの出力例

  • (4)　出力ページを設定したアイテムの扱い

(1)　アイテムの出力ページに設定できるアイテム

次に示すアイテムを除くすべてのアイテムを設定できます。

設定できないアイテム

  • 繰り返し対象に設定されているアイテム

  • 見出しの繰り返し対象に設定されているアイテム

  • まとめ表示に設定されているアイテム

  • 帳票ヘッダアイテム（帳票ヘッダ領域に貼り付けられたアイテム） ※

  • 集計ページにあるアイテム

  • 集計行編集モードで生成したアイテム

注※

アイテム配置の設定で［貼付域の左上を基準］が設定されているアイテムは，帳票ヘッダ領域にあっても帳票ヘッダアイテムとは見なされないため，出力ページを設定できます。

ページの先頭へ

(2)　アイテムの出力ページを設定する

  1. アイテムの選択

    先頭ページ，または最終ページだけに出力するアイテムを選択します。

  2. 出力ページの設定

    ［編集］－［アイテムのプロパティ］を選択します。［アイテムのプロパティ］ダイアログの［出力ページ］タブで選択したアイテムを出力するページを選択します。デフォルトは，「全てのページに出力する」です。ただし，複数のアイテムを選択したときは，どのラジオボタンも選択されていない状態で表示されます。

    ［全てのページに出力する］：

    選択したアイテムを，すべてのページに出力します。

    ［先頭のページだけに出力する］：

    選択したアイテムを，先頭ページだけに出力します。

    ［最終ページだけに出力する］：

    選択したアイテムを，最終ページだけに出力します。

  3. ［OK］ボタンのクリック

    ［OK］ボタンをクリックします。帳票ウィンドウに戻り，設定が反映されます。

ページの先頭へ

(3)　出力ページの出力例

アイテムの出力ページを設定した出力例を，先頭ページ，および最終ページの定義ごとに次に示します。

(a)　単一様式の帳票の場合

■全体の3ページ目と4ページ目に「改ページ（初期化なし）」を指定した帳票の出力例

■全体の3ページ目と4ページ目に「改ページ（初期化あり）」を指定した帳票の出力例

■全体の3ページ目に改ページ（初期化なし），全体の4ページ目に改ページ（初期化あり）を指定した帳票の出力例

(b)　複数様式の帳票の場合

■表紙次紙形式の帳票の出力例

■従業員勤務歴の帳票の出力例

■保険申込書の帳票の出力例

ページの先頭へ

(4)　出力ページを設定したアイテムの扱い

［アイテムのプロパティ］ダイアログの［出力ページ］タブで，［先頭のページだけに出力する］，または［最終ページだけに出力する］が設定されたアイテムは，次のような制限事項があります。

(a)　レポート編集ウィンドウでのアイテム枠の表示

先頭ページ，または最終ページだけに出力するアイテムは，出力ページが設定された先頭ページ，または最終ページだけアイテム枠が赤色で表示されます。それ以外のページでは，アイテム枠が紫色で表示されます。ただし，線アイテムだけは，先頭ページ，または最終ページだけに出力するアイテムに設定しても，どのページも従来どおりの表示です。

（例）

貼り付けた科目別集計データのアイテムに，出力ページの設定で［最終ページだけに出力する］を選択すると，レポート編集ウィンドウでのアイテム枠は，次のように表示されます。

(b)　表紙のある帳票でのアイテムの扱い

先頭ページ，または最終ページだけに出力するアイテムを，表紙のある帳票の繰り返し領域から帳票ヘッダ領域に移動した場合，そのアイテムは，帳票ヘッダアイテムに属性が変わります。帳票ヘッダ領域に移動したアイテムを再び繰り返し領域に戻した場合は，アイテムの属性が［アイテムのプロパティ］ダイアログの［出力ページ］タブで［全てのページに出力する］を設定したアイテムに変わります。ただし，繰り返し領域にあるアイテムに［貼付域の左上を基準］が設定されている場合は，帳票ヘッダ領域に移動したアイテムを再び繰り返し領域に戻しても，アイテムの属性は変わりません。

  • 繰り返しの設定

    先頭ページ，または最終ページだけに出力するアイテムは，繰り返し対象，または繰り返し見出し対象を設定できません。

  • まとめ表示の設定

    先頭ページ，または最終ページだけに出力するアイテムは，まとめ表示を設定できません。

  • 印刷プレビューとレイアウト表示

    出力ページが設定されている帳票を，印刷プレビューやレイアウト表示で確認すると，［アイテムのプロパティ］ダイアログの［出力ページ］タブで設定した属性に従って，出力ページが設定されたアイテムは，先頭ページ，または最終ページだけに表示されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 100 / 356


4.10 アイテムを削除する : EUR 帳票作成 操作ガイド

  • 101 / 356

  • 表紙

  • 4.　帳票のレイアウトを決める

  • 4.10　アイテムを削除する

4.10　アイテムを削除する

貼り付けたアイテムを削除する場合は，［編集］－［削除］を選択するか，または＜Delete＞キーを押してください。

ラバーバンドで囲むと，複数のアイテムを削除できます。ただし，線アイテムの場合は，ラバーバンドで囲まれた部分だけを削除します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 101 / 356


5. 表を作成する : EUR 帳票作成 操作ガイド

  • 102 / 356

  • 表紙

  • 5.　表を作成する

5.　表を作成する

この章では，マッピングデータウィンドウから貼り付けたデータで，表を作成する方法について説明します。

〈この章の構成〉

  • 5.1　表の作成手順

  • 5.2　表の罫線を設定する

  • 5.3　繰り返しを定義する

  • 5.4　改ブロックを設定する

  • 5.5　改ページを設定する

  • 5.6　同じ項目をまとめて表示する

  • 5.7　表を確認する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 102 / 356


5.1 表の作成手順 : EUR 帳票作成 操作ガイド

  • 103 / 356

  • 表紙

  • 5.　表を作成する

  • 5.1　表の作成手順

5.1　表の作成手順

表の大きさが変化する帳票（可変形式）か変化しない帳票（固定形式）かによって，表の作成手順が異なります。

  • 可変形式の帳票

    可変形式とは，帳票の罫線の数が表中のデータ量（レコード数）によって自動的に変更される帳票のことです。この場合は，繰り返しの対象となる1レコード分のデータに罫線を設定し，データとともに罫線も繰り返し対象として定義します。

  • 固定形式の帳票

    固定形式とは，帳票の罫線の数が固定の帳票のことです。この場合は，帳票の罫線をすべてユーザが指定し，データだけを繰り返し対象として定義します。

〈この節の構成〉

  • 5.1.1　可変形式の帳票を定義する場合

  • 5.1.2　固定形式の帳票を定義する場合

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 103 / 356


5.1.1 可変形式の帳票を定義する場合 : EUR 帳票作成 操作ガイド

  • 104 / 356

  • 表紙

  • 5.　表を作成する

  • 5.1　表の作成手順

  • 5.1.1　可変形式の帳票を定義する場合

5.1.1　可変形式の帳票を定義する場合

可変形式の表を作成する方法を次に示します。

〈この項の構成〉

  • (1)　データを貼り付ける

  • (2)　罫線を引く

  • (3)　表データの繰り返し

  • (4)　見出しの繰り返し

  • (5)　表を見やすくする

(1)　データを貼り付ける

表の見出しになるデータは，フィールド名（マッピングデータウィンドウの1行目に表示されている見出し）を貼り付けます。

表のデータは，マッピングデータウィンドウの1レコード目のデータを貼り付けます。マッピングデータウィンドウの1レコード目から，必要なデータを選択したまま，帳票ウィンドウへドラッグして任意の位置で離します。この操作を繰り返して，必要なデータを貼り付けます。データの貼り付けについては，「4.3　データウィンドウからデータを貼り付ける」を参照してください。

データを貼り付けたとき，枠だけが表示されてデータが表示されなかったり，「*」で表示されたりすることがあります。マウス操作で枠の大きさを大きくするか，またはフォントのサイズを小さくしてください。

ページの先頭へ

(2)　罫線を引く

繰り返しのひな型となる表を，線アイテムで作成します。見出しの行と1レコード分のデータを囲むように罫線を引きます。罫線の引き方については，「4.2　アイテムを配置する」を参照してください。

ページの先頭へ

(3)　表データの繰り返し

表データの繰り返しを設定する方法を次に示します。

  1. 繰り返したいデータ部分のアイテムの範囲を選択する

    選択するアイテムに線アイテムが含まれる場合は，グリッドを表示したり，表示倍率を拡大したりしておくと，選択しやすくなります。

  2. ［繰り返し］－［繰り返し定義］を選択する

  3. ［繰り返し］－［縦位置］から［設定］を選択する

    帳票ウィンドウのマウスポインタが [図データ] に変わります。

  4. 選択したアイテムの範囲をクリックする

    ラバーバンドが表示されます。

  5. 繰り返しの位置を設定する

    ラバーバンドをドラッグして，自由に繰り返しの位置を設定できます。

用紙の縦サイズを超えるデータがある場合は，何ページにもわたって全データが表示されます。

設定されている用紙の向きや操作1で貼り付けたデータの数にもよりますが，［繰り返し］－［横位置］を選択し，縦位置を決めたときと同じように，ラバーバンドで繰り返しの位置を設定すると，続きのデータが表示されます。

ページの先頭へ

(4)　見出しの繰り返し

横方向の繰り返しで作成された表には見出しが付いていないので，見出しの繰り返しを定義します。見出しの繰り返しを設定する方法を次に示します。

  1. 見出しとして繰り返したいデータ部分のアイテムの範囲を選択する

  2. ［繰り返し］－［見出し指定］を選択する

    帳票ウィンドウのマウスポインタが [図データ] に変わります。

  3. 選択したアイテムの範囲をクリックする

    ラバーバンドが表示されます。

  4. ラバーバンドをドラッグして，見出しの位置を設定する

    このとき，見出しの下辺が表データの上辺と重なるような位置を指定するときれいに配置できます。

ページの先頭へ

(5)　表を見やすくする

表を整えるために，次の設定ができます。

改ブロック／改ページ

表は，指定したフィールドの同じ値を持つデータごとにブロックで分けたり，ページで分けたりできます。ブロックで分けることを「改ブロック」といい，ページで分けることを「改ページ」といいます。

まとめ表示

重複したデータが幾つも並んでいる場合，一つだけ表示するようにするには，まとめ表示を設定します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 104 / 356


5.1.2 固定形式の帳票を定義する場合 : EUR 帳票作成 操作ガイド

  • 105 / 356

  • 表紙

  • 5.　表を作成する

  • 5.1　表の作成手順

  • 5.1.2　固定形式の帳票を定義する場合

5.1.2　固定形式の帳票を定義する場合

固定形式の表を作成する方法を次に示します。

(1)と(2)は逆に操作してもかまいません。

(3)または(4)を定義したとき，データによっては，データのない表セルができます。

まとめ表示をしたときは，罫線もデータと連動して非表示になります。

〈この項の構成〉

  • (1)　データの貼り付け

  • (2)　罫線を引く

  • (3)　「繰り返し」を定義する

  • (4)　表を見やすくする

(1)　データの貼り付け

表の見出しになるデータ，および表のデータの貼り付けは，可変形式の表を作成する場合と同じです。

ページの先頭へ

(2)　罫線を引く

1ページ内に表示する表を線アイテムで作成します。

ページの先頭へ

(3)　「繰り返し」を定義する

「繰り返し」は，表のデータ，表の見出しの順に定義します。繰り返しの操作は，可変形式の表を作成する場合と同じです。ただし，貼り付けたデータだけを「繰り返し」の対象にします。そのため，線アイテムを選択しないように，ツールボックスの「線（罫線アイテム選択）」をオフにしておきます。

ページの先頭へ

(4)　表を見やすくする

改ブロック，改ページ，およびまとめ表示も，可変形式の表を作成する場合と同じように操作できます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 105 / 356


5.2 表の罫線を設定する : EUR 帳票作成 操作ガイド

  • 106 / 356

  • 表紙

  • 5.　表を作成する

  • 5.2　表の罫線を設定する

5.2　表の罫線を設定する

表の罫線の設定については，「4.2　アイテムを配置する」を参照してください。また，線アイテムのプロパティ設定については，「13.4　線アイテムのプロパティを設定する」を参照してください。ここでは，可変形式の帳票の表区切り線や表の枠線を変更する操作について説明します。

可変形式の帳票は，貼り付けたデータと一緒に罫線も繰り返しの対象にするため，線種はすべて同じになります。レコードの下線と次レコードの上線の重なりは，先レコードの下線の下に，次レコードの上線があるイメージです。このため，次レコードの上線の線種を変更してもレコード間の線種は変更されません。

〈この節の構成〉

  • 5.2.1　表区切り線（レコード間）を変更する

  • 5.2.2　表の外枠の線種を変更する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 106 / 356


5.2.1 表区切り線（レコード間）を変更する : EUR 帳票作成 操作ガイド

  • 107 / 356

  • 表紙

  • 5.　表を作成する

  • 5.2　表の罫線を設定する

  • 5.2.1　表区切り線（レコード間）を変更する

5.2.1　表区切り線（レコード間）を変更する

可変形式の帳票で，レコードの下線と次レコードの上線が重なっている場合，レコード間の線種をn行間隔で変更できます。

レコード間の線種を変更するには，繰り返しレコードの下側の線だけを選択したあと，［アイテムのプロパティ］ダイアログの［線］タブに表示されている「繰り返し線」に繰り返しの個数と線種を設定します。繰り返しの個数に指定できる値は，2～32,767です。

［アイテムのプロパティ］ダイアログの［線］タブについては，マニュアル「EUR 帳票作成 画面リファレンス」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 107 / 356


5.2.2 表の外枠の線種を変更する : EUR 帳票作成 操作ガイド

  • 108 / 356

  • 表紙

  • 5.　表を作成する

  • 5.2　表の罫線を設定する

  • 5.2.2　表の外枠の線種を変更する

5.2.2　表の外枠の線種を変更する

レコードの下線と次レコードの上線が重なっている場合，表の外側の線種を変更できます。

〈この項の構成〉

  • (1)　表の枠（上／左／右）の線種を変更する場合

  • (2)　表の枠（下）の線種を変更する場合

(1)　表の枠（上／左／右）の線種を変更する場合

表の枠の，繰り返しレコードの上，左，および右側の線アイテムを選択したあと，［アイテムのプロパティ］ダイアログの［線］タブで線種を変更します。

ページの先頭へ

(2)　表の枠（下）の線種を変更する場合

表の枠の，繰り返しレコードの下側の線だけを選択したあと，［アイテムのプロパティ］ダイアログの［線］タブで外枠線種を変更します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 108 / 356


5.3 繰り返しを定義する : EUR 帳票作成 操作ガイド

  • 109 / 356

  • 表紙

  • 5.　表を作成する

  • 5.3　繰り返しを定義する

5.3　繰り返しを定義する

データウィンドウから貼り付けた1レコード分のデータ，罫線，網掛けなどを選択し，繰り返しを定義することで表を作成します。この操作によって，帳票ファイル上の貼付域（余白を除いた部分）すべてに選択したデータが繰り返されて表が作成されます。

繰り返しの元となるアイテムを実アイテム，繰り返し定義で表示されるアイテムを仮想アイテムといいます。

実アイテムの設定は，仮想アイテムに反映されます。仮想アイテムは，編集モードでは灰色で表示されますが，レイアウトモードで表示すると実アイテムと同じ設定で表示されます。

固定形式の帳票の場合は，データ（レコード）だけを繰り返しの対象とします。可変形式の帳票の場合は，データ（レコード）だけでなく，罫線，網掛けなども繰り返しの対象とします。文字アイテム（固定文字列）に繰り返し定義を指定した場合は，同じ文字列が繰り返されます。

部品は，繰り返しの対象にはできません。選択したアイテムに部品が含まれていた場合は，繰り返し定義はできません。

〈この節の構成〉

  • 5.3.1　繰り返し定義を設定する

  • 5.3.2　繰り返し個数を設定する

  • 5.3.3　表の見出しの繰り返しを定義する

  • 5.3.4　繰り返しを解除する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 109 / 356


5.3.1 繰り返し定義を設定する : EUR 帳票作成 操作ガイド

  • 110 / 356

  • 表紙

  • 5.　表を作成する

  • 5.3　繰り返しを定義する

  • 5.3.1　繰り返し定義を設定する

5.3.1　繰り返し定義を設定する

繰り返し定義は作成する表の形によって，設定の方法が異なります。繰り返し定義の設定方法を次に示します。

〈この項の構成〉

  • (1)　1ページ1レコードの繰り返し

  • (2)　1ページ複数レコードで縦方向への繰り返し

  • (3)　1ページ複数レコードで横方向への繰り返し

  • (4)　1ページ複数レコードで縦横方向への繰り返し

  • (5)　繰り返し定義後の作業

  • (6)　補足説明

(1)　1ページ1レコードの繰り返し

  1. 繰り返し対象を選択する

    1ページ1レコードの繰り返しをする場合は，マッピングデータウィンドウから貼り付けたデータを選択してください。見出しやユーザ定義データウィンドウから貼り付けたデータは，1ページ1レコードの繰り返しにはなりません。

  2. 繰り返し対象を設定する

    ［繰り返し］－［繰り返し指定］を選択します。

ページの先頭へ

(2)　1ページ複数レコードで縦方向への繰り返し

繰り返しの対象（フィールド）を，縦方向に繰り返す手順です。

図5‒1　縦方向への繰り返しの例

[図データ]

  1. 繰り返し対象を選択する

    繰り返し対象を複数個設定するときは，ドラッグして繰り返しの対象を矩形で囲みます。アイテムの種類で，繰り返し対象から外したいアイテムがある場合は，繰り返し対象を選択する前に，ツールボックスで選択対象から外すアイテムのチェックボックスをオフにします。

    ツールボックスで選択対象としたアイテムが，反転表示されて選択状態になります。単一選択の場合は，アイテムをクリックしてください。

  2. 繰り返し対象を設定する

    ［繰り返し］－［繰り返し指定］を選択します。

    単一選択で指定したアイテムがすでに繰り返し設定されている場合は，［繰り返し指定］は不活性となり選択できません。

  3. 繰り返し方向を設定する

    ［繰り返し］－［優先方向］から［縦優先］を選択します。

  4. 繰り返し位置を設定する

    ［繰り返し］－［縦位置］から［設定］を選択します。

    マウスの形が [図データ] に変わります。このとき，マウスをクリックすると，ラバーバンドが表示されます。ドラッグしてラバーバンドを繰り返し位置まで移動させてください。選択したアイテムが繰り返し表示されます。

ページの先頭へ

(3)　1ページ複数レコードで横方向への繰り返し

繰り返しの対象（フィールド）を，横方向に繰り返す手順です。

図5‒2　横方向への繰り返しの例

[図データ]

  1. 繰り返し対象を選択する

    繰り返し対象を複数個設定するときは，ドラッグして繰り返しの対象を矩形で囲みます。アイテムの種類で，繰り返し対象から外したいアイテムがある場合は，繰り返し対象を選択する前に，ツールボックスで選択対象から外すアイテムのチェックボックスをオフにします。

    ツールボックスで選択対象としたアイテムが，反転表示されて選択状態になります。単一選択の場合は，アイテムをクリックしてください。

  2. 繰り返し対象を設定する

    ［繰り返し］－［繰り返し指定］を選択します。

    単一選択で指定アイテムがすでに設定されている場合は，［繰り返し指定］は不活性となり選択できません。

  3. 繰り返し方向を設定する

    ［繰り返し］－［優先方向］から［横優先］を選択します。

  4. 繰り返し位置を設定する

    ［繰り返し］－［横位置］から［設定］を選択します。

    マウスの形が [図データ] に変わります。このとき，マウスをクリックすると，ラバーバンドが表示されます。ドラッグしてラバーバンドを繰り返し位置まで移動させてください。選択したアイテムが繰り返し表示されます。

    横方向に繰り返しを指定した場合，見出しが付かない段ができます。見出しが付いていない段に見出しを付ける場合は，見出し指定をします。見出し指定については，「5.3.3　表の見出しの繰り返しを定義する」を参照してください。

ページの先頭へ

(4)　1ページ複数レコードで縦横方向への繰り返し

繰り返しの対象（フィールド）を，横方向に並んでいるものを縦方向に繰り返し，次に横方向に繰り返す手順です。

図5‒3　縦横方向への繰り返しの例

[図データ]

  1. 繰り返し対象を選択する

    繰り返し対象を複数個設定するときは，ドラッグして繰り返しの対象を矩形で囲みます。アイテムの種類で，繰り返し対象から外したいアイテムがある場合は，繰り返し対象を選択する前に，ツールボックスで選択対象から外すアイテムのチェックボックスをオフにします。

    ツールボックスで選択対象としたアイテムが，反転表示されて選択状態になります。単一選択の場合は，アイテムをクリックしてください。

  2. 繰り返し対象を設定する

    ［繰り返し］－［繰り返し指定］を選択します。

    単一選択で指定したアイテムがすでに繰り返し設定されている場合は，［繰り返し指定］は不活性となり選択できません。

  3. 繰り返し方向を設定する

    ［繰り返し］－［優先方向］から［縦優先］を選択します。

  4. 繰り返し位置（縦方向）を設定する

    ［繰り返し］－［縦位置］から［設定］を選択します。

    マウスの形が [図データ] に変わります。このとき，マウスをクリックすると，ラバーバンドが表示されます。ドラッグしてラバーバンドを繰り返し位置（縦方向）まで移動させてください。選択したアイテムが繰り返し表示されます。

  5. 繰り返し位置（横方向）を設定する

    ［繰り返し］－［横位置］から［設定］を選択します。

    マウスの形が [図データ] に変わります。このとき，マウスをクリックすると，ラバーバンドが表示されます。ドラッグしてラバーバンドを繰り返し位置（横方向）まで移動させてください。マウスボタンを離すと，選択したアイテムが繰り返し表示されます。

    縦横の両方向に繰り返しを指定した場合，見出しが付かない段ができます。見出しが付いていない段に見出しを付ける場合は，見出し指定をします。見出し指定については，「5.3.3　表の見出しの繰り返しを定義する」を参照してください。

ページの先頭へ

(5)　繰り返し定義後の作業

繰り返しの定義をすると，帳票ファイル上の貼付域（余白を除いた部分）すべてにデータが繰り返されて表が作成されます。このため，集計しない帳票の場合は，繰り返しの個数を設定して表の行数を設定してください。集計する帳票の場合は，改ブロックおよび改ページの設定をしたあと，データ集計をしてください。

なお，まとめ表示は，繰り返しの定義のあとで設定してください。

ページの先頭へ

(6)　補足説明

  • ツールボックスで [図データ] ボタン以外を選択している場合は，繰り返しの縦位置，横位置，個数，および優先方向は，不活性となり操作できません。

  • ユーザ定義データウィンドウのデータを繰り返し対象に指定した場合は，同じデータが繰り返されます。

  • あらかじめ決められた繰り返し位置，繰り返しの方向に表を作成する場合は，［繰り返し設定］ダイアログに設定すると便利です。［繰り返し設定］ダイアログについては，マニュアル「EUR 帳票作成 画面リファレンス」を参照してください。［繰り返し設定］ダイアログでは，縦方向の繰り返し間隔をLPIで指定することもできます。

  • アイテムを複数選択して繰り返し定義を設定する場合，アイテムの配置の設定で［貼付域の左上を基準］を指定しているアイテムが一つ以上含まれていると，［繰り返し指定］は不活性となり選択できません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 110 / 356


5.3.2 繰り返し個数を設定する : EUR 帳票作成 操作ガイド

  • 111 / 356

  • 表紙

  • 5.　表を作成する

  • 5.3　繰り返しを定義する

  • 5.3.2　繰り返し個数を設定する

5.3.2　繰り返し個数を設定する

繰り返しを定義すると，帳票ファイル上の貼付域（余白を除いた部分）すべてに，選択したデータが繰り返されて表が作成されます。1ページ中に繰り返すデータ数を制限したい場合は，繰り返しの個数を指定します。特に，固定形式の帳票で表の枠が固定されていてその枠内にデータを納めたい場合などに利用します。

図5‒4　繰り返し個数を設定した例

[図データ]

〈この項の構成〉

  • (1)　繰り返し個数の設定

  • (2)　補足説明

(1)　繰り返し個数の設定

繰り返しの定義をしたあと，繰り返しの個数を設定します。

  1. ［繰り返し個数指定］ダイアログを表示する

    ［繰り返し］－［個数］を選択します。［繰り返し個数指定］ダイアログでは，縦方向，横方向の繰り返し個数が設定できます。

  2. 繰り返し個数を設定する

    ［縦個数］または［横個数］から，「任意設定」を選択し，繰り返し個数を指定します。指定できる個数は，表示されている「設定できる最大個数」までです。

ページの先頭へ

(2)　補足説明

  • 集計行を作成して，その集計行の位置を設定（固定）する場合に，繰り返し個数を設定する方法もあります。

  • 繰り返し個数を「任意設定」している場合は，用紙のサイズ，方向，および余白を変更しても，繰り返し個数は自動調整されません。

  • 繰り返し個数を指定しない場合は，1ページに表示できる最大のデータ数が自動的に貼り付けられます。

    なお，メインウィンドウ下のステータスバーに何個繰り返しができるかという情報が表示されています。また，繰り返し位置が設定されていない場合，繰り返し個数は設定できません。繰り返し位置で，縦方向または横方向のどちらか一方を設定している場合は，設定されていない方向が淡不活性となります。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 111 / 356


5.3.3 表の見出しの繰り返しを定義する : EUR 帳票作成 操作ガイド

  • 112 / 356

  • 表紙

  • 5.　表を作成する

  • 5.3　繰り返しを定義する

  • 5.3.3　表の見出しの繰り返しを定義する

5.3.3　表の見出しの繰り返しを定義する

1ページ複数レコードで縦横方向への繰り返しを定義した帳票（1ページに複数ブロックがある帳票）で，ブロックごとに見出しが必要な場合に，見出しの繰り返しを定義します。

図5‒5　表の見出しの繰り返しを定義した例

[図データ]

ただし，見出しが付くのは縦優先の場合は段の1行目，横優先の場合は段の左端だけです。データ全部に見出しを付けたい場合は，データと一緒に見出しも繰り返しの対象にしてください。

〈この項の構成〉

  • (1)　表の見出しの繰り返し定義を設定する

  • (2)　補足説明

(1)　表の見出しの繰り返し定義を設定する

  1. 見出しアイテムを選択する

    見出しとして繰り返すアイテム（データウィンドウから貼り付けたフィールド名とその周りの罫線）を，ドラッグして矩形で囲みます。

  2. 見出しの繰り返し定義をする

    ［繰り返し］－［見出し指定］を選択します。データの配置に応じて，見出しが自動的に表示されます。見出しは，アイテムの繰り返し優先方向が縦の場合は横に，横の場合は縦に繰り返し表示されます。

    単一選択したアイテムがすでに見出しに指定されていると，［見出し指定］は不活性となり選択できません。

ページの先頭へ

(2)　補足説明

  • 見出しとして使用するアイテムは，データウィンドウから貼り付けたフィールド名やその周りの罫線，網掛け，直接入力した文字などです。

  • アイテムを複数選択して表の見出しの繰り返し定義を設定する場合，アイテムの配置の設定で［貼付域の左上を基準］を指定しているアイテムが一つ以上含まれていると，［見出し指定］は不活性となり選択できません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 112 / 356


5.3.4 繰り返しを解除する : EUR 帳票作成 操作ガイド

  • 113 / 356

  • 表紙

  • 5.　表を作成する

  • 5.3　繰り返しを定義する

  • 5.3.4　繰り返しを解除する

5.3.4　繰り返しを解除する

1レコードの縦方向，または横方向の繰り返しを別々に解除したり，一部のアイテムの繰り返しを解除したりできます。また，表の見出しの繰り返しも全体の解除や一部のアイテムを解除できます。

〈この項の構成〉

  • (1)　1レコードの繰り返し解除

  • (2)　繰り返しの全解除

  • (3)　繰り返し見出しの解除

  • (4)　補足説明

(1)　1レコードの繰り返し解除

  1. 繰り返し解除を指定する

    ［繰り返し］－［縦位置］または［横位置］－［解除］を選択します。

ページの先頭へ

(2)　繰り返しの全解除

  1. 繰り返し解除のアイテムを選択する

    繰り返しを解除するアイテムをすべて選択します。

  2. 繰り返し解除を指定する

    ［繰り返し］－［繰り返し／見出し解除］を選択します。

ページの先頭へ

(3)　繰り返し見出しの解除

  1. 見出しアイテムを選択する

    フィールド単位に選択することもできます。

  2. 繰り返し解除を指定する

    ［繰り返し］－［繰り返し／見出し解除］を選択します。

ページの先頭へ

(4)　補足説明

  • フィールド，罫線，網掛けなどの繰り返しの解除は，［繰り返し］－［繰り返し／見出し解除］から解除することもできます。この場合は，繰り返しの方向や繰り返しの位置が記録されたままになっているので，次に繰り返しの対象を選択しただけで，繰り返しされます。

  • アイテムを複数選択して繰り返しの解除を設定する場合，アイテムの配置の設定で［貼付域の左上を基準］を指定しているアイテムが一つ以上含まれていると，［繰り返し／見出し解除］は不活性となり選択できません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 113 / 356


5.4 改ブロックを設定する : EUR 帳票作成 操作ガイド

  • 114 / 356

  • 表紙

  • 5.　表を作成する

  • 5.4　改ブロックを設定する

5.4　改ブロックを設定する

ブロックとは，1ページの中の一つの表を指します。表が縦横方向に繰り返して設計された帳票の場合，ブロックには入力するレコードを順番に配置して印刷します。この複数のブロックは，繰り返し定義で「1ページ1レコードで縦横方向の繰り返し」を設定すると作成されます。

図5‒6　改ブロックしていない帳票の例

[図データ]

改ブロックとは，データ中の特定のフィールドをキーとして設定しておくことで，そのデータが変わった時点で表を強制的に分割する機能です。例えば，製品ごとの生産数がわかる帳票を出力する場合は，製品名が変わると表を分割するように，製品名フィールドを改ブロックのキーとして設定します。

図5‒7　改ブロックを設定した帳票の例

[図データ]

また，改ブロックは，複数のフィールドに設定することもできます。例えば，製品名と型で表を分割するには，製品名フィールドと型フィールドを改ブロックのキーとして設定します。

図5‒8　複数のフィールドに改ブロックを設定した帳票の例

[図データ]

〈この節の構成〉

  • 5.4.1　表をブロック単位で分割する

  • 5.4.2　改ブロックを解除する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 114 / 356


5.4.1 表をブロック単位で分割する : EUR 帳票作成 操作ガイド

  • 115 / 356

  • 表紙

  • 5.　表を作成する

  • 5.4　改ブロックを設定する

  • 5.4.1　表をブロック単位で分割する

5.4.1　表をブロック単位で分割する

繰り返しを定義したら，複数のブロックを配置した帳票に，改ブロックのキーフィールドを設定します。

改ブロック対象フィールドの条件

  • マッピングデータウィンドウから貼り付けたフィールドであること

  • 表中のフィールドでなくてもよい

〈この項の構成〉

  • (1)　表をブロック単位で分割する

  • (2)　補足説明

(1)　表をブロック単位で分割する

ツールボックスの [図データ] ボタンを選択し，［文字］のチェックボックスをオンにして操作してください。

  1. キーフィールドを指定する

    改ブロックのキーにするフィールドを選択します。複数のフィールドに改ブロックを設定する場合は，フィールドを一つずつ選択してください。

  2. 改ブロックを設定する

    ［繰り返し］－［改ブロック／改ページ］－［改ブロック］を選択します。

ページの先頭へ

(2)　補足説明

  • 改ブロックと改ページに同一のフィールドをキーとして指定した場合は，改ページが優先となります（指定する意味がありません）。

  • 帳票ウィンドウに貼り付けたアイテムを見ながら改ブロックを設定する場合は，キーにするフィールドを選択したあと，［繰り返し］－［改ブロック／改ページ］－［改ブロック］を選択して設定することをお勧めします。

  • 改ブロックの設定は，［改ブロック／改ページ一覧］ダイアログから設定したり，変更したりすることもできます。［改ブロック／改ページ一覧］ダイアログには，マッピングデータウィンドウのすべてのフィールド名と，改ブロック／改ページのキーフィールドの設定内容を一覧にして表示するので，設定内容を確認するのに便利です。また，帳票ウィンドウに貼り付けていないフィールドに，改ブロックの設定もできます。

  • キーにするフィールドを選択したあと，［繰り返し］－［改ブロック／改ページ］を選択すると，選択したフィールドの設定状態をメニューの前のチェックマークで示しています。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 115 / 356


5.4.2 改ブロックを解除する : EUR 帳票作成 操作ガイド

  • 116 / 356

  • 表紙

  • 5.　表を作成する

  • 5.4　改ブロックを設定する

  • 5.4.2　改ブロックを解除する

5.4.2　改ブロックを解除する

設定した改ブロックを解除します。

ツールボックスの [図データ] ボタンを選択し，［文字］のチェックボックスをオンにして操作してください。

  1. 解除するキーフィールドを指定する

    改ブロックを解除する，キーフィールドを一つ選択します。

  2. 改ブロック解除を設定する

    ［繰り返し］－［改ブロック／改ページ］－［設定なし］を選択します。

〈この項の構成〉

  • (1)　補足説明

(1)　補足説明

  • 改ブロックの解除は，［改ブロック／改ページ一覧］ダイアログから解除することもできます。［改ブロック／改ページ一覧］ダイアログには，マッピングデータウィンドウのすべてのフィールド名と，改ブロック／改ページのキーフィールドの設定内容が一覧で表示されます。帳票ウィンドウに貼り付けていないフィールドに，改ブロックが設定されていたり，複数のフィールドに改ブロックが設定されていたりすることもあるので，［改ブロック／改ページ一覧］ダイアログは，設定内容を確認しながら解除するとき便利です。

  • 改ブロックが解除されると，改ブロックを設定していたキーフィールドを選択したあと，［繰り返し］－［改ブロック／改ページ］を選択すると，［設定なし］にチェックマークが付きます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 116 / 356


5.5 改ページを設定する : EUR 帳票作成 操作ガイド

  • 117 / 356

  • 表紙

  • 5.　表を作成する

  • 5.5　改ページを設定する

5.5　改ページを設定する

EURでは，レコードを繰り返して定義することで1ページの中に表を定義できます。この定義によって，入力のレコード順にデータが表へ配置されて印刷できます。

改ページとは，データ中の特定のフィールドをキーとして指定しておくことで，そのデータが変わった時点で改ページする機能です。例えば，製品別に生産高の帳票を出力する場合，製品名が変わるごとに改ページするには，製品名フィールドを改ページのキーとして指定します。

図5‒9　改ページのキーを設定した帳票の例

[図データ]

また，改ページは，複数のフィールドに設定することもできます。例えば，製品名と型で表を改ページするには，製品名フィールドと型フィールドを改ページのキーとして設定します。

図5‒10　複数のフィールドを改ページのキーに設定した例

[図データ]

〈この節の構成〉

  • 5.5.1　表をページ単位で分割する

  • 5.5.2　改ページを解除する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 117 / 356


5.5.1 表をページ単位で分割する : EUR 帳票作成 操作ガイド

  • 118 / 356

  • 表紙

  • 5.　表を作成する

  • 5.5　改ページを設定する

  • 5.5.1　表をページ単位で分割する

5.5.1　表をページ単位で分割する

改ページのキーフィールドを設定します。ここでは，帳票ウィンドウ上でフィールドを選択して設定する方法について説明します。

どの時点で操作するか

繰り返しの定義が終わってから

対象帳票の条件

1ページ1レコードを除くすべての帳票であること

対象フィールドの条件

  • マッピングデータウィンドウから貼り付けたフィールドであること

  • 表中のフィールドでなくてもよい

〈この項の構成〉

  • (1)　表をページ単位で分割する

  • (2)　補足説明

(1)　表をページ単位で分割する

ツールボックスの [図データ] ボタンを選択し，［文字］のチェックボックスをオンにして操作してください。

  1. キーフィールドを指定する

    改ページのキーになるフィールドを一つ選択します。複数のフィールドに改ブロックを設定する場合は，フィールドを一つずつ選択してください。

  2. 改ページを設定する

    ［繰り返し］－［改ブロック／改ページ］－［改ページ〔初期化あり〕］，または［改ページ〔初期化なし〕］を選択します。

    ［改ページ〔初期化あり〕］を選択した場合は，キーとなるフィールドのデータが変わった時点で，ページ番号を開始番号に初期化して印刷します。ページ番号の初期化は，［レポートのプロパティ］ダイアログの［レポートの構成］タブの［改ページの設定に従う］のチェックボックスで指定します。

    ［改ページ〔初期化なし〕］を選択した場合は，キーとなるフィールドのデータが変わっても，通し番号でページ番号を印刷します。

    重要

    ［改ページの設定に従う］のチェックボックスの指定は，［アイテムのプロパティ］ダイアログの［表示形式］（ページ番号）タブで，［バージョン2形式］ラジオボタンが指定されたときに有効になります。

ページの先頭へ

(2)　補足説明

  • 罫線を繰り返しの対象に設定している場合（可変形式の帳票），改ページのキーがブレイクするまで罫線が設定されます。

  • 改ページと集計の機能を組み合わせることで，改ページごとに集計できます。

  • 帳票ウィンドウに貼り付けたアイテムを見ながら改ページを設定する場合は，キーにするフィールドを選択したあと，［繰り返し］－［改ブロック／改ページ］から設定することをお勧めします。

  • 改ページの設定は，［改ブロック／改ページ一覧］ダイアログから設定したり，変更したりすることもできます。［改ブロック／改ページ一覧］ダイアログには，マッピングデータウィンドウのすべてのフィールド名と，改ブロック／改ページのキーフィールドの設定内容を一覧にして表示するので，設定内容を確認しながら設定するのに便利です。また，帳票ウィンドウに貼り付けていないフィールドに，改ページの設定もできます。

  • キーにするフィールドを選択したあと，［繰り返し］－［改ブロック／改ページ］を選択すると，選択したフィールドの設定状態をメニューの前のチェックマークで示しています。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 118 / 356


5.5.2 改ページを解除する : EUR 帳票作成 操作ガイド

  • 119 / 356

  • 表紙

  • 5.　表を作成する

  • 5.5　改ページを設定する

  • 5.5.2　改ページを解除する

5.5.2　改ページを解除する

設定した改ページを解除します。

ツールボックスの [図データ] ボタンを選択し，［文字］のチェックボックスをオンにして操作してください。

  1. 解除するキーフィールドを指定する

    改ページを解除する，キーフィールドを一つ選択します。

  2. 改ページ解除を設定する

    ［繰り返し］－［改ブロック／改ページ］－［設定なし］を選択します。

〈この項の構成〉

  • (1)　補足説明

(1)　補足説明

  • 改ページの解除は，［改ブロック／改ページ一覧］ダイアログから解除することもできます。［改ブロック／改ページ一覧］ダイアログには，マッピングデータウィンドウのすべてのフィールド名と，改ブロック／改ページのキーフィールドの設定内容を一覧にして表示するので，改ブロック／改ページが複数指定されている場合は，［改ブロック／改ページ一覧］ダイアログで解除することをお勧めします。また，帳票ウィンドウに貼り付けていないフィールドに，改ページが設定されていることもあるので，［改ブロック／改ページ一覧］ダイアログは，設定内容を確認しながら解除するとき便利です。

  • 改ページが解除されると，改ページを設定していたキーフィールドを選択したあと，［繰り返し］－［改ブロック／改ページ］を選択すると，［設定なし］にチェックマークが付きます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 119 / 356


5.6 同じ項目をまとめて表示する : EUR 帳票作成 操作ガイド

  • 120 / 356

  • 表紙

  • 5.　表を作成する

  • 5.6　同じ項目をまとめて表示する

5.6　同じ項目をまとめて表示する

表では，同じフィールド中で同じ内容のデータが連続している場合，連続する同じデータを個々に表示しないで，それらをまとめて表示する方が理解しやすいときが多くあります。まとめ表示を利用すれば，同一のデータをまとめて表示できます。まとめ表示では，フィールドが繰り返しの対象になっている場合でも定義できます。罫線が設定されている場合は，EURが自動的に罫線を変更します。自動的に変更された罫線の表示は，あとから変更できます。

複数のフィールドにまとめ表示を指定する場合，階層あり，階層なしが選択できます。階層ありの場合は，優先順位の高いフィールドの順にまとめ表示します。階層なしの場合は，同じデータが連続しているフィールドをまとめ表示します。ほかのフィールドとの関係はありません。

まとめ表示を使用した例を次に示します。

（例1）年度，支店，性別のデータを選択し，階層なしにした場合

（例2）年度，支店，性別の順番でデータを選択し，階層ありにした場合

（例3）年度，性別，支店の順番でデータを選択し，階層ありにした場合

なお，まとめ表示にはフィールドを選択して［繰り返し］メニューから設定する方法と，［まとめ表示］ダイアログで一括して設定する方法があります。［まとめ表示］ダイアログで一括して設定する場合は，フィールドを選択する順番を意識しないで設定できます。例1～例3を［まとめ表示］ダイアログで設定した場合，ダイアログでは次のように表示されます。

（例1）

（例2）

（例3）

〈この節の構成〉

  • 5.6.1　まとめ表示を設定する

  • 5.6.2　まとめ表示を解除する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 120 / 356


5.6.1 まとめ表示を設定する : EUR 帳票作成 操作ガイド

  • 121 / 356

  • 表紙

  • 5.　表を作成する

  • 5.6　同じ項目をまとめて表示する

  • 5.6.1　まとめ表示を設定する

5.6.1　まとめ表示を設定する

フィールドごとに，まとめ表示を設定します。一度に複数のフィールドにまとめ表示を設定したり，複数回の操作でまとめ表示を設定したりもできます。

どの時点で操作するか

繰り返しの定義が終わってから

対象フィールドの条件

  • 同じデータが連続するフィールドであること

〈この項の構成〉

  • (1)　同一のデータをまとめて表示する（［繰り返し］メニューからの操作）

  • (2)　同一のデータをまとめて表示する（［まとめ表示］ダイアログからの操作）

  • (3)　集計行があるときのまとめ表示

  • (4)　まとめ表示をした行の罫線の設定

  • (5)　補足説明

(1)　同一のデータをまとめて表示する（［繰り返し］メニューからの操作）

ツールボックスの [図データ] ボタンを選択し，［文字］のチェックボックスをオンにして操作してください。

  1. アイテムを選択する

    複数のフィールドにまとめ表示を設定する場合は，フィールドを一つずつ選択してください。まとめ表示の優先順位は，最初に選択したフィールドが高く，徐々に低くなります。

  2. まとめ表示を設定する

    ［繰り返し］－［まとめ表示］－［階層なし］または［階層あり］を選択します。

    ［階層あり］の指定は，優先順位が2番目以降のフィールドに有効です。まとめ表示の優先順位はフィールドを選択した順序です。

ページの先頭へ

(2)　同一のデータをまとめて表示する（［まとめ表示］ダイアログからの操作）

  1. ［まとめ表示］ダイアログを表示する

    ［繰り返し］－［まとめ表示］－［設定］を選択します。

  2. まとめ表示の設定をする

    繰り返しを設定しているフィールドが［繰り返しアイテム一覧］リストボックスに表示されます。対象となるアイテムを選択して［＞］ボタンをクリックし，階層を設定する場合は［階層あり］リストボックスに，階層を設定しない場合は［階層なし］リストボックスに移動してください。

    ［階層あり］リストボックスの表示順に優先順位が設定されています。優先順位を変更する場合は［▲］ボタンまたは［▼］ボタンをクリックして移動してください。まとめ表示を解除する場合は，［＜］ボタンをクリックすれば，［繰り返しアイテム一覧］リストボックスに戻すことができます。

ページの先頭へ

(3)　集計行があるときのまとめ表示

表の中に集計行がある場合，集計行を分断して表示する方法と，集計行を分断しないで表示する方法があります。デフォルトでは，集計行を分断しない設定（「集計行で分断しない」を選択する）になっています。

ただし，「集計行で分断しない」を指定しても，総集計行，ページ集計行は分断して集計されます。

集計行を分断するかどうかによる表示の違いを次の図に示します。

図5‒11　集計行を分断するかどうかによる表示の違い

[図データ]

集計行を分断しない場合は，表にまとめ表示を設定し，「型」を選択してキー集計をします。「集計行で分断しない」を指定すると，まとめ表示が分断されないで表示されます。［まとめ表示］ダイアログで設定する場合は，［集計行で分断しない］チェックボックスをオンにします。

集計行を分断する場合は，［編集］－［まとめ表示］－［集計行で分断しない］を選択し，チェックを外します。［まとめ表示］ダイアログで設定する場合は，［集計行で分断しない］チェックボックスをオフにします。

(a)　ページの先頭行が集計行のとき，まとめ表示を設定したフィールドを表示するかどうかの設定

「集計行で分断しない」を指定している場合，ページの先頭行が集計行になったときに，まとめ表示を設定したフィールドを表示するかどうかを設定できます。

［まとめ表示］ダイアログで［1行目が集計行のとき，まとめデータを表示する］チェックボックスをオンにすると，まとめ表示を設定したフィールドが表示されます。

ページの先頭へ

(4)　まとめ表示をした行の罫線の設定

罫線の引かれたフィールドにまとめ表示を設定すると，まとめ表示をした部分の罫線もまとめられるので，表のセルを結合したような見た目になります。このとき，まとめ表示された部分の罫線をまとめないで表示させるように設定できます。

まとめ表示を設定された部分の罫線をまとめない場合は，［まとめ表示］ダイアログの［階層あり］リストボックスまたは［階層なし］リストボックスで対象となるフィールドを選択後，［罫線もまとめる］チェックボックスをオフにします。

［罫線もまとめる］チェックボックスをオフにした場合のまとめ表示の例を次の図に示します。

図5‒12　［罫線もまとめる］チェックボックスをオフにした場合のまとめ表示の例

[図データ]

ページの先頭へ

(5)　補足説明

  • フィールドは，優先順位の順序を認識するため，矩形を使って複数選択することはできません。

  • 集計行はまとめ表示の対象にはなりません。

  • 図形アイテム，画像アイテム，線アイテム，部品のどれかを選択している場合は，［繰り返し］メニューからの操作はできません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 121 / 356


5.6.2 まとめ表示を解除する : EUR 帳票作成 操作ガイド

  • 122 / 356

  • 表紙

  • 5.　表を作成する

  • 5.6　同じ項目をまとめて表示する

  • 5.6.2　まとめ表示を解除する

5.6.2　まとめ表示を解除する

まとめ表示を解除するには，［繰り返し］－［まとめ表示］－［全解除］を選択します。すべてのまとめ表示が解除されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 122 / 356


5.7 表を確認する : EUR 帳票作成 操作ガイド

  • 123 / 356

  • 表紙

  • 5.　表を作成する

  • 5.7　表を確認する

5.7　表を確認する

作成した表を，ページをめくって確認します。ページめくりは，帳票ウィンドウ下部に表示されています。

現在表示している帳票のページ番号を「貼付域に表示中のページ番号／全体のページ数」の形式で表示します。

設計した帳票が複数ページある場合は，ページめくりでページ移動ができます。また，ページ表示の枠内をクリックすると，［指定のページへジャンプ］ダイアログが表示されます。

［指定のページへジャンプ］ダイアログ

指定したページを表示するダイアログです。

［ページ番号］テキストボックス

ページ表示の貼付域に表示中のページ番号を設定します。

［OK］ボタン

設定されたページを表示します。

［キャンセル］ボタン

［指定のページへジャンプ］ダイアログで設定した内容を無効にして，［指定のページへジャンプ］ダイアログを閉じます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 123 / 356


6. 帳票上でデータを集計する : EUR 帳票作成 操作ガイド

  • 124 / 356

  • 表紙

  • 6.　帳票上でデータを集計する

6.　帳票上でデータを集計する

マッピングデータウィンドウから貼り付けたデータを自動的に集計できます。この章では，データ集計の方法について説明します。

〈この章の構成〉

  • 6.1　データ集計の種類

  • 6.2　データ集計をする前に

  • 6.3　キー集計を作成する

  • 6.4　ページ集計を作成する

  • 6.5　総集計を作成する

  • 6.6　集計行を編集する

  • 6.7　集計結果をアイテムとして挿入する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 124 / 356


6.1 データ集計の種類 : EUR 帳票作成 操作ガイド

  • 125 / 356

  • 表紙

  • 6.　帳票上でデータを集計する

  • 6.1　データ集計の種類

6.1　データ集計の種類

フィールドごとに数値データを集計できます。集計内容は，合計，平均，最大，最小および件数から選択できます。

集計結果を表示するアイテムを集計アイテムといいます。

データの集計には，集計キー単位で集計するキー集計，入力データが終了した時点で集計する総集計，ページ単位で集計するページ集計，帳票ヘッダ単位で集計する帳票ヘッダ集計があります。

集計すると，デフォルトでは合計が表示されます。表示された集計データは，平均，最大，最小および件数に変更できます。

〈この節の構成〉

  • 6.1.1　キー集計でできる設定

  • 6.1.2　ページ集計でできる設定

  • 6.1.3　総集計でできる設定

  • 6.1.4　帳票ヘッダ集計でできる設定

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 125 / 356


6.1.1 キー集計でできる設定 : EUR 帳票作成 操作ガイド

  • 126 / 356

  • 表紙

  • 6.　帳票上でデータを集計する

  • 6.1　データ集計の種類

  • 6.1.1　キー集計でできる設定

6.1.1　キー集計でできる設定

〈この項の構成〉

  • (1)　可変形式帳票でのキー集計

  • (2)　キー集計と改ブロック／改ページの組み合わせ

  • (3)　多階層の集計

  • (4)　複数フィールドのキー集計

  • (5)　1件のときキー集計行を削除する集計

  • (6)　キー集計を利用した帳票の例

(1)　可変形式帳票でのキー集計

可変形式の帳票でキー集計を設定した場合，キーに指定したフィールド値が変わるごとに集計行が挿入されます。

キー集計の表示例を次の図に示します。

図6‒1　キー集計の表示例（「製品名」をキーに集計した場合）

[図データ]

ページの先頭へ

(2)　キー集計と改ブロック／改ページの組み合わせ

改ブロック／改ページのキーと集計のキーを同一のフィールドに設定した場合は，集計行がブロックの最後に出力されます。この場合は，集計行を帳票内の任意の位置に移動できます。また，この組み合わせの設定は，可変形式帳票でも，固定形式帳票でも利用できます。

キー集計と改ブロック／改ページを組み合わせた場合の表示例を次の図に示します。

図6‒2　キー集計の表示例（「製品名」を改ページとキー集計のキーに集計した場合）

[図データ]

ページの先頭へ

(3)　多階層の集計

多階層の集計とは，キー集計を複数のフィールドに設定することです。多階層の集計では，キーフィールドの値がブレイク（変化）するごとに集計行が追加されます。複数のフィールドにキー集計を設定すると，集計行が複数作成されるので，固定形式の帳票にはお勧めできません。可変形式の帳票で適用されることをお勧めします。

多階層の集計を求めるときは，下位のキー（連続するデータの少ないフィールドから順に）からキー集計を設定してください。多階層の集計は，設定した順に下位階層から階層化するので，指定する順序が正しくないと，正しい集計結果が得られません。

多階層の集計を設定した場合の表示例を次の図に示します。

図6‒3　多階層の集計の表示例

[図データ]

ページの先頭へ

(4)　複数フィールドのキー集計

複数フィールドをキーに指定して，集計できます。複数指定したキーフィールドの値が一つでもブレイク（変化）すると，集計行が追加されます。

複数フィールドのキー集計をするときは，下位のキー（連続するデータの少ないフィールドから順に）からキー集計を設定してください。

複数フィールドをキーに指定した場合の表示例を次の図に示します。

図6‒4　複数フィールドのキー集計の表示例（「製品名」と「型」をキーに集計した場合）

[図データ]

ページの先頭へ

(5)　1件のときキー集計行を削除する集計

キー集計を設定したフィールドが1件しかない場合は，集計行を自動的に削除できます。

1件のときにキー集計行を削除した場合の表示例を次の図に示します。

図6‒5　1件のときにキー集計行を削除した表示例

[図データ]

ページの先頭へ

(6)　キー集計を利用した帳票の例

複数フィールドのキー集計を利用することで，次の図のような帳票を定義できます。

図6‒6　キー集計を利用した帳票の例

[図データ]

メモ

多階層の集計と複数フィールドのキー集計の違い

多階層の集計と複数フィールドのキー集計の違いについて説明します。

図6‒7　多階層の集計の場合

[図データ]

図6‒8　複数フィールドのキー集計の場合

[図データ]

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 126 / 356


6.1.2 ページ集計でできる設定 : EUR 帳票作成 操作ガイド

  • 127 / 356

  • 表紙

  • 6.　帳票上でデータを集計する

  • 6.1　データ集計の種類

  • 6.1.2　ページ集計でできる設定

6.1.2　ページ集計でできる設定

集計行をページ単位で設定できます。ページ集計の例を次の図に示します。

図6‒9　ページ集計の例

[図データ]

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 127 / 356


6.1.3 総集計でできる設定 : EUR 帳票作成 操作ガイド

  • 128 / 356

  • 表紙

  • 6.　帳票上でデータを集計する

  • 6.1　データ集計の種類

  • 6.1.3　総集計でできる設定

6.1.3　総集計でできる設定

総集計を設定すると，集計レコードが表の最後に追加されます。集計行は，帳票内の任意の位置に移動できます。総集計の例を次の図に示します。

図6‒10　総集計の例

[図データ]

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 128 / 356


6.1.4 帳票ヘッダ集計でできる設定 : EUR 帳票作成 操作ガイド

  • 129 / 356

  • 表紙

  • 6.　帳票上でデータを集計する

  • 6.1　データ集計の種類

  • 6.1.4　帳票ヘッダ集計でできる設定

6.1.4　帳票ヘッダ集計でできる設定

帳票ヘッダ集計を設定すると，帳票ヘッダから次の帳票ヘッダまでのデータを一まとまりにして，集計できます。

帳票ヘッダ集計については，「7.5　帳票ヘッダ集計の作成」を参照してください。

帳票ヘッダ集計の例を次の図に示します。

図6‒11　帳票ヘッダ集計の例

[図データ]

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 129 / 356


6.2 データ集計をする前に : EUR 帳票作成 操作ガイド

  • 130 / 356

  • 表紙

  • 6.　帳票上でデータを集計する

  • 6.2　データ集計をする前に

6.2　データ集計をする前に

繰り返し定義の設定が終わったら，データを集計します。繰り返し定義の設定については「5.3　繰り返しを定義する」を参照してください。

データ集計をするには，キーフィールドに指定するデータに，次の条件が必要です。

  • キーフィールドのデータが階層化されている

  • 階層に従ってデータがソートされている

  • キーフィールドに指定した列にデータがすべて入っている（空データがない）

また，集計行に設定できる数値データは，マッピングデータウィンドウのフィールド定義で，集計対象と宣言された数値データだけです。集計対象の宣言は，［フィールド定義］ダイアログで設定します。

データ集計の対象となる帳票は，1ページ1レコードの繰り返しを除くすべての帳票です。

〈この節の構成〉

  • 6.2.1　空データの扱い

  • 6.2.2　集計行にするデータを集計対象に指定する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 130 / 356


6.2.1 空データの扱い : EUR 帳票作成 操作ガイド

  • 131 / 356

  • 表紙

  • 6.　帳票上でデータを集計する

  • 6.2　データ集計をする前に

  • 6.2.1　空データの扱い

6.2.1　空データの扱い

空データは，キー集計の対象外です。そのため，データ中に空データがある場合，集計方法を指定すると，次のようになります。

  • 合計，平均，最大，および最小

    計算対象外です。

  • 件数

    カウントされません。

また，空データだけを集計した場合，集計アイテムは空白で表示されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 131 / 356


6.2.2 集計行にするデータを集計対象に指定する : EUR 帳票作成 操作ガイド

  • 132 / 356

  • 表紙

  • 6.　帳票上でデータを集計する

  • 6.2　データ集計をする前に

  • 6.2.2　集計行にするデータを集計対象に指定する

6.2.2　集計行にするデータを集計対象に指定する

マッピングデータウィンドウのフィールド定義で，数値データを集計対象に設定します。

  1. ［フィールド定義］ダイアログを表示する

    マッピングデータウィンドウをアクティブにし，［データ］－［フィールド定義］を選択します。

  2. 集計フィールドを選択する

    集計行に設定するデータの「種別」から「数値」を選択します。それ以外の種別を選択した場合は，集計行に設定できません。

  3. ［OK］ボタンをクリックする

    ［OK］ボタンをクリックします。帳票ウィンドウに戻り，設定が反映されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 132 / 356


6.3 キー集計を作成する : EUR 帳票作成 操作ガイド

  • 133 / 356

  • 表紙

  • 6.　帳票上でデータを集計する

  • 6.3　キー集計を作成する

6.3　キー集計を作成する

キー集計とは，集計するキーになるフィールドを指定し，そのフィールドのデータが変わった時点で，集計キー単位に数値データを集計する機能です。集計方法は，合計，平均，最大，最小，件数から選択できます。キー集計を設定すると，集計レコードが表に追加されます。

集計キーフィールドの条件

  • マッピングデータウィンドウから貼り付けたフィールドであること

  • 表中のフィールドでなくてもよい

  • 集計キーのフィールドは複数指定できる

〈この節の構成〉

  • 6.3.1　可変形式帳票での作成手順

  • 6.3.2　キーフィールドを複数設定して作成する手順（多階層の集計）

  • 6.3.3　複数のフィールドをキーに指定して作成する手順

  • 6.3.4　フィールドが1件のときキー集計行を削除する

  • 6.3.5　キー集計を作成したあと

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 133 / 356


6.3.1 可変形式帳票での作成手順 : EUR 帳票作成 操作ガイド

  • 134 / 356

  • 表紙

  • 6.　帳票上でデータを集計する

  • 6.3　キー集計を作成する

  • 6.3.1　可変形式帳票での作成手順

6.3.1　可変形式帳票での作成手順

  1. キーフィールドを選択する

    帳票ウィンドウ上の表で，集計のキーフィールドにするアイテムを選択します。

  2. キー集計を設定する

    ［集計］－［キー集計］を選択します。すべての集計対象のフィールドで集計が行われて，集計行が表に追加されます。集計方法は，合計が設定されます。そのほか（平均，最大，最小，および件数）の集計方法を選択したい場合は，［アイテムのプロパティ］ダイアログ－［表示形式］タブ（集計）で設定してください。集計方法の選択については「6.6.3　集計方法を選択する」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 134 / 356


6.3.2 キーフィールドを複数設定して作成する手順（多階層の集計） : EUR 帳票作成 操作ガイド

  • 135 / 356

  • 表紙

  • 6.　帳票上でデータを集計する

  • 6.3　キー集計を作成する

  • 6.3.2　キーフィールドを複数設定して作成する手順（多階層の集計）

6.3.2　キーフィールドを複数設定して作成する手順（多階層の集計）

キー集計を複数のフィールドに設定できます。選択してキーフィールドの値が一つでもブレイク（変化）するごとに集計行が追加されます。

  1. キーフィールドを選択する

    帳票ウィンドウの表で，集計のキーフィールドにするアイテムを選択します。

    多階層の集計を求めるときは，下位のキー（連続するデータの少ないフィールドから順に）からキー集計を設定してください。

  2. キー集計を設定する

    ［集計］－［キー集計］を選択します。すべての集計対象のフィールドで集計が行われて，集計行が表に追加されます。キーフィールドを複数設定する場合は，1.および2.の手順を繰り返します。選択できるキーフィールドの数は，1～10個です。

    集計方法は，合計が設定されます。そのほか（平均，最大，最小，および件数）の集計方法を選択したい場合は，［アイテムのプロパティ］ダイアログ－［表示形式］タブ（集計）で設定してください。集計方法の選択については「6.6.3　集計方法を選択する」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 135 / 356


6.3.3 複数のフィールドをキーに指定して作成する手順 : EUR 帳票作成 操作ガイド

  • 136 / 356

  • 表紙

  • 6.　帳票上でデータを集計する

  • 6.3　キー集計を作成する

  • 6.3.3　複数のフィールドをキーに指定して作成する手順

6.3.3　複数のフィールドをキーに指定して作成する手順

  1. キーフィールドを選択する

    帳票ウィンドウ上の表で，集計のキーフィールドにするアイテムを同時に選択します。

  2. キー集計を設定する

    ［集計］－［キー集計］を選択します。すべての集計対象のフィールドで集計が行われて，集計行が表に追加されます。

    集計方法は，合計が設定されます。そのほか（平均，最大，最小，および件数）の集計方法を選択したい場合は，［アイテムのプロパティ］ダイアログ－［表示形式］タブ（集計）で設定してください。集計方法の選択については「6.6.3　集計方法を選択する」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 136 / 356


6.3.4 フィールドが1件のときキー集計行を削除する : EUR 帳票作成 操作ガイド

  • 137 / 356

  • 表紙

  • 6.　帳票上でデータを集計する

  • 6.3　キー集計を作成する

  • 6.3.4　フィールドが1件のときキー集計行を削除する

6.3.4　フィールドが1件のときキー集計行を削除する

キー集計を設定したフィールドが1件しかない場合は，集計行を自動的に削除できます。

フィールドが1件のときキー集計行を削除するには，メニュー［集計］－［1件のときキー集計行を削除する］を選択します。

フィールドが1件のキー集計行が削除されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 137 / 356


6.3.5 キー集計を作成したあと : EUR 帳票作成 操作ガイド

  • 138 / 356

  • 表紙

  • 6.　帳票上でデータを集計する

  • 6.3　キー集計を作成する

  • 6.3.5　キー集計を作成したあと

6.3.5　キー集計を作成したあと

集計レコードの扱い

キー集計を設定すると，集計行が作成され，表に追加されます。作成された集計行は，任意の文字を指定したり，網を掛けたりして修飾ができます。改ブロック，改ページと同じフィールドにすると，集計行がブロック（表）の最下位に作成されます。また，作成された集計行は，表から切り離したり，集計行だけを表示する，集計ページを作成したりすることもできます。集計レコードの扱いについては，「6.6　集計行を編集する」を参照してください。

集計アイテムの扱い

キー集計の集計行に集計アイテムを追加したり，キー集計の集計アイテムを新たに作成したりすることもできます。この場合は，キー集計の集計行を作成したあと，集計行編集モードにしてから，［集計アイテム］ダイアログを表示して作成します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 138 / 356


6.4 ページ集計を作成する : EUR 帳票作成 操作ガイド

  • 139 / 356

  • 表紙

  • 6.　帳票上でデータを集計する

  • 6.4　ページ集計を作成する

6.4　ページ集計を作成する

ページ集計とは，1ページに出力されるデータ単位で集計する機能です。集計方法は，合計，平均，最大，最小，件数から選択できます。

〈この節の構成〉

  • 6.4.1　ページ集計の作成手順

  • 6.4.2　ページ集計を設定したあと

  • 6.4.3　ページ集計の表示位置

  • 6.4.4　補足説明

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 139 / 356


6.4.1 ページ集計の作成手順 : EUR 帳票作成 操作ガイド

  • 140 / 356

  • 表紙

  • 6.　帳票上でデータを集計する

  • 6.4　ページ集計を作成する

  • 6.4.1　ページ集計の作成手順

6.4.1　ページ集計の作成手順

  1. ページ集計を設定する

    ［集計］－［ページ集計］を選択します。1ページごとに，数値データの集計行が挿入されます。集計内容のデフォルトは，「合計」です。

  2. ページ集計行を選択する

    ［集計］－［集計行の編集］を選択します。集計行が反転表示され，集計行が選択できます。集計方法の選択は，集計行編集モードで設定します。［終了］ボタンを押すと，集計行編集モードを終了します。

  3. 集計方法を選択する

    ［編集］－［アイテムのプロパティ］を選択し，表示されるダイアログでフィールドごとの集計方法を選択します。集計方法は，合計，平均，最大，最小，および件数から選択できます。［OK］ボタンをクリックすると，集計方法が反映されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 140 / 356


6.4.2 ページ集計を設定したあと : EUR 帳票作成 操作ガイド

  • 141 / 356

  • 表紙

  • 6.　帳票上でデータを集計する

  • 6.4　ページ集計を作成する

  • 6.4.2　ページ集計を設定したあと

6.4.2　ページ集計を設定したあと

集計レコードの扱い

ページ集計を設定すると，集計行が作成され，ページの最後の行に追加されます。この集計行は，任意の文字を指定したり，網を掛けたりして修飾ができます。また，作成された集計行は，表から切り離すこともできます。集計レコードの扱いについては，「6.6　集計行を編集する」を参照してください。

集計アイテムの扱い

ページ集計の集計アイテムを作成する場合は，［集計アイテム］ダイアログを表示して作成します。

なお，集計行編集モードでページ集計の集計行に集計アイテムを追加した場合は，集計行編集モードでしか編集できません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 141 / 356


6.4.3 ページ集計の表示位置 : EUR 帳票作成 操作ガイド

  • 142 / 356

  • 表紙

  • 6.　帳票上でデータを集計する

  • 6.4　ページ集計を作成する

  • 6.4.3　ページ集計の表示位置

6.4.3　ページ集計の表示位置

ページ集計をした表にキー集計や総集計を設定した場合のページ集計の表示位置について説明します。

ページ集計行は，キー集計行の後ろ，総集計行の前に設定されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 142 / 356


6.4.4 補足説明 : EUR 帳票作成 操作ガイド

  • 143 / 356

  • 表紙

  • 6.　帳票上でデータを集計する

  • 6.4　ページ集計を作成する

  • 6.4.4　補足説明

6.4.4　補足説明

  • 特殊編集レベルの集計行は，集計ページには設定できません。

  • 繰り返し定義を設定していない場合，および繰り返し個数が一つの場合は，［ページ集計］メニューは不活性になります。

  • ページ集計行は，集計ページには設定できません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 143 / 356


6.5 総集計を作成する : EUR 帳票作成 操作ガイド

  • 144 / 356

  • 表紙

  • 6.　帳票上でデータを集計する

  • 6.5　総集計を作成する

6.5　総集計を作成する

総集計とは，入力データが終了した時点で，数値データを集計する機能です。集計方法は，合計，平均，最大，最小，件数から選択できます。

〈この節の構成〉

  • 6.5.1　総集計の作成手順

  • 6.5.2　総集計を設定したあと

  • 6.5.3　補足説明

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 144 / 356


6.5.1 総集計の作成手順 : EUR 帳票作成 操作ガイド

  • 145 / 356

  • 表紙

  • 6.　帳票上でデータを集計する

  • 6.5　総集計を作成する

  • 6.5.1　総集計の作成手順

6.5.1　総集計の作成手順

  1. 総集計を設定する

    ［集計］－［総集計］を選択します。最終レコードのあとに，集計行が挿入されます。集計内容のデフォルトは，「合計」です。

  2. 総集計行を選択する

    ［集計］－［集計行の編集］を選択します。集計行が反転表示され，集計行が選択できます。集計方法の選択は，集計行編集モードで設定します。［終了］ボタンを押すと，集計行編集モードを終了します。

  3. 集計方法を選択する

    ［編集］－［アイテムのプロパティ］を選択し，表示されるダイアログでフィールドごとの集計方法を選択します。集計方法は，合計，平均，最大，最小，および件数から選択できます。［OK］ボタンをクリックすると，集計方法が反映されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 145 / 356


6.5.2 総集計を設定したあと : EUR 帳票作成 操作ガイド

  • 146 / 356

  • 表紙

  • 6.　帳票上でデータを集計する

  • 6.5　総集計を作成する

  • 6.5.2　総集計を設定したあと

6.5.2　総集計を設定したあと

集計レコードの扱い

総集計を設定すると，集計行が作成され，表の最後に追加されます。この集計行は，任意の文字を指定したり，網を掛けたりして修飾ができます。また，作成された集計行は，表から切り離したり，集計行だけを表示する，集計ページを作成したりすることもできます。集計レコードの扱いについては，「6.6　集計行を編集する」を参照してください。

集計アイテムの扱い

総集計の集計アイテムを作成する場合は，［集計アイテム］ダイアログを表示して作成します。

なお，集計行編集モードで総集計の集計行に集計アイテムを追加した場合は，集計行編集モードでしか編集できません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 146 / 356


6.5.3 補足説明 : EUR 帳票作成 操作ガイド

  • 147 / 356

  • 表紙

  • 6.　帳票上でデータを集計する

  • 6.5　総集計を作成する

  • 6.5.3　補足説明

6.5.3　補足説明

キー集計と総集計の両方を設定した場合，集計行は同じ形式，同じフィールドの集計となります。キー集計はするが，総集計の対象にはしたくない場合は，集計行から不要なフィールド（集計アイテム）を削除してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 147 / 356


6.6 集計行を編集する : EUR 帳票作成 操作ガイド

  • 148 / 356

  • 表紙

  • 6.　帳票上でデータを集計する

  • 6.6　集計行を編集する

6.6　集計行を編集する

集計行は，集計行編集モードで編集します。

集計行編集モードでは，キー集計行，ページ集計行，総集計行，集計行編集モードで作成した集計アイテム，およびマッピングデータで指定した特殊編集レベルデータが編集できます。

集計行の編集では，次に示す操作ができます。

  • 集計方法の選択（キー集計行，ページ集計行，総集計行）

  • 集計結果フィールドのプロパティ設定

  • 集計行のアイテムの設定（文字列，罫線，網掛け，図形，画像，印刷日付・印刷時刻，ページ番号，集計アイテム）

  • 集計行の位置変更

  • 集計ページの設定

集計行の編集は，先頭の集計行に対して編集します。先頭の集計行に設定した情報は，編集の対象となっている集計行と同じレベルの行にも反映されます。また，集計行編集で生成された文字も，自動的に繰り返しアイテムとなり，編集の対象となっている集計行と同じレベルの行にも反映されます。ただし，集計行編集モードで生成したアイテムは，集計行編集モードでしか編集できません。また集計行編集モードでは，部品の貼り付けや部品の登録はできません。

〈この節の構成〉

  • 6.6.1　集計行の編集手順

  • 6.6.2　集計行編集モードのバーに表示される内容

  • 6.6.3　集計方法を選択する

  • 6.6.4　集計行のアイテムを編集する

  • 6.6.5　1件のときキー集計行を削除する

  • 6.6.6　集計行の位置を変更する

  • 6.6.7　集計ページを設定する

  • 6.6.8　集計行／総集計行を解除する

  • 6.6.9　集計行編集時の注意

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 148 / 356


6.6.1 集計行の編集手順 : EUR 帳票作成 操作ガイド

  • 149 / 356

  • 表紙

  • 6.　帳票上でデータを集計する

  • 6.6　集計行を編集する

  • 6.6.1　集計行の編集手順

6.6.1　集計行の編集手順

集計行は集計行編集モードで編集します。ここでは集計行編集モードの開始から終了までの操作を説明します。

  1. 集計行の編集の開始宣言をする

    ［集計］－［集計行の編集］を選択します。すべての集計行が，反転表示されます。

  2. 集計行を選択する

    ポインタを帳票ウィンドウに移動すると， [図データ] に変わります。集計行編集モードに変わると，レポート編集ウィンドウのメニューバーの下に，集計行編集モードのバーが表示されます。編集する集計行のフィールドをクリックします。

  3. 集計行を編集する

    集計行を編集します。キー集計を編集する場合は，先頭の集計行を編集します。先頭の集計行に設定した情報は，ほかのキー集計にも反映されます。

  4. 集計行の編集の終了宣言をする

    集計行編集モードのバーの［終了］ボタンをクリックします。このボタンをクリックすることで，一連の集計行に設定した内容が有効になります。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 149 / 356


6.6.2 集計行編集モードのバーに表示される内容 : EUR 帳票作成 操作ガイド

  • 150 / 356

  • 表紙

  • 6.　帳票上でデータを集計する

  • 6.6　集計行を編集する

  • 6.6.2　集計行編集モードのバーに表示される内容

6.6.2　集計行編集モードのバーに表示される内容

集計行編集モードになると，レポート編集ウィンドウのメニューバーの下に，集計行編集モードのバーが表示されます。集計行編集モードのバーには，編集行情報を表示する領域と編集ボタンが表示されます。編集行情報を表示する領域は，キー集計の状態によって変わります。

集計行ごとに使用できる機能について，次に示します。

表6‒1 集計行ごとの使用できる機能
行種別 | 集計ページ解除 | 集計ページ指定 | 繰り返し下限位置指定 | 位置固定 | 位置固定解除 | 終了
キー集計行 | × | ○ | ○ | ○ | ○ | ○
ページ集計行 | × | × | ○ | ○ | ○ | ○
総集計行 | × | ○ | ○ | ○ | ○ | ○
集計ページ | ○ | × | × | × | × | ○
（凡例）

○：使用できます。

×：使用できません。

  • 複数フィールドを指定したキー集計の場合

  • 複数フィールドを指定し，改ブロックまたは改ページを設定した場合

    編集行情報を表示する領域と編集ボタンについて次に説明します。

編集行情報を表示する領域

現在編集対象となっている集計行の情報を表示します。

編集対象

集計行情報の表示

キー集計の場合

（キー集計：クラス）

総集計の場合

（総集計）

特殊編集レベルの場合

（レベル：nn※）

改ブロックが設定されている場合

（キー集計：クラス，ブレイク種別：改ブロック）

改ページが設定されている場合

（キー集計：クラス，ブレイク種別：改ページ）

注※　設定したレベルが表示されます。

編集ボタン

編集ボタンは，表示されている帳票の状態によって変わります。

  • 改ブロックまたは改ページの設定はあるが，集計ページの設定はない場合

  • 改ブロックまたは改ページの設定も，集計ページの設定もない場合

  • 集計ページの設定がある場合

集計ページの設定がある場合は，改ブロックまたは改ページの設定があるなしに関係なく，［集計ページ解除］ボタンと［終了］ボタンが表示されます。

［集計ページ設定］ボタン

集計行だけを表示する，集計ページを設定します。このボタンは，帳票に一個所も位置固定の設定がなく，特殊編集レベルの集計行ではないときに選択できます。

集計ページを設定したあと解除すると，集計行を作成したときの状態に戻ります。

［集計ページ解除］ボタン

集計ページを解除します。このボタンは，集計ページが設定されているときに選択できます。

集計ページを解除すると，集計行を作成したときの状態に戻ります。

［繰り返し下限位置指定］ボタン

繰り返しの限界位置を指定します。このボタンは，編集対象となる集計行（キー集計）に改ブロック，または改ページが設定されていて，位置固定を設定しているときに選択できます。

［位置固定］ボタン

集計行を定位置に固定します。このボタンは，編集対象となる集計行（キー集計）に改ブロック，または改ページを設定しているときに選択できます。集計ページが設定されている場合は，選択できません。

［位置固定解除］ボタン

集計行の位置固定を解除します。このボタンは，位置固定を設定していないときは選択できません。

［終了］ボタン

集計行編集モードを終了します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 150 / 356


6.6.3 集計方法を選択する : EUR 帳票作成 操作ガイド

  • 151 / 356

  • 表紙

  • 6.　帳票上でデータを集計する

  • 6.6　集計行を編集する

  • 6.6.3　集計方法を選択する

6.6.3　集計方法を選択する

集計方法は，合計，平均，最大，最小，および件数から選択できます。集計方法の選択手順を次に示します。

  1. 集計アイテムを選択する

    キー集計行，または総集計行を選択します。

  2. 集計方法を選択する

    ［編集］－［アイテムのプロパティ］を選択し，表示された［アイテムのプロパティ］ダイアログ－［表示形式］タブ（集計）でフィールドごとの集計方法を選択します。

  3. ［OK］ボタンをクリックする

    ［OK］ボタンをクリックします。帳票ウィンドウに戻り，設定が反映されます。

注意

平均値が割り切れないときなど，集計した結果の桁数が大きくなる場合があります。このような場合，［アイテムのプロパティ］ダイアログの［表示形式］タブで分類を数値データにして，「小数点以下桁揃え」のチェックを外しておくと，15桁まで表示されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 151 / 356


6.6.4 集計行のアイテムを編集する : EUR 帳票作成 操作ガイド

  • 152 / 356

  • 表紙

  • 6.　帳票上でデータを集計する

  • 6.6　集計行を編集する

  • 6.6.4　集計行のアイテムを編集する

6.6.4　集計行のアイテムを編集する

集計行編集モードで集計行を編集する方法について説明します。

〈この項の構成〉

  • (1)　集計結果フィールドのプロパティ設定

  • (2)　集計行の文字列の設定，および修飾

  • (3)　集計行の罫線設定

  • (4)　集計行への網掛け

  • (5)　集計行への図形の設定

  • (6)　集計アイテムの作成

(1)　集計結果フィールドのプロパティ設定

「13.3　数値データのプロパティを設定する」を参照してください。

ページの先頭へ

(2)　集計行の文字列の設定，および修飾

文字列を設定するには，まず，文字列の設定領域を確保し，その領域に文字列を入力します。集計行に設定した文字列には，フォント名，サイズ，スタイル，および色を設定できます。文字列の修飾については，「13.2　文字アイテムと文字データのプロパティを設定する」を参照してください。

  1. 文字入力モードにする

    ツールボックスの [図データ] ボタンをクリックします。

  2. 文字領域を指定する

    集計行の枠内でドラッグして，入力する文字列の枠の大きさを指定します。

  3. 文字列を入力する

  4. 文字入力モードを解除する

    ツールボックスの [図データ] ボタンを使用したあとは， [図データ] ボタンをクリックするか，＜Esc＞キーを押して選択モードに戻しておいてください。

ページの先頭へ

(3)　集計行の罫線設定

罫線も繰り返しの対象に設定されていると，集計行にも罫線が付加されて作成されます。しかし，ほかのセルと区別するために，線の太さや線種を変更したり，作成された集計行を移動したりした場合はセル上側の線が表に残るので，新たに線を引く必要があります。線を引く操作については，「4.2　アイテムを配置する」を参照してください。

ページの先頭へ

(4)　集計行への網掛け

網掛けも繰り返し対象に設定されていると，集計行にも網掛けが付加されて作成されます。しかし，ほかのセルと区別するために，網のパターンを変更できます。

網掛けの操作については，「4.2　アイテムを配置する」を参照してください。

ページの先頭へ

(5)　集計行への図形の設定

ほかのセルと区別するために，集計行に角丸四角や円／楕円を設定できます。図形の作成については，「4.2.5　図形アイテムを配置する」を参照してください。

ページの先頭へ

(6)　集計アイテムの作成

集計行に集計アイテムを追加したり，集計アイテムを新たに作成したりできます。集計アイテムの作成については，「6.7　集計結果をアイテムとして挿入する」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 152 / 356


6.6.5 1件のときキー集計行を削除する : EUR 帳票作成 操作ガイド

  • 153 / 356

  • 表紙

  • 6.　帳票上でデータを集計する

  • 6.6　集計行を編集する

  • 6.6.5　1件のときキー集計行を削除する

6.6.5　1件のときキー集計行を削除する

キー集計を設定したフィールドが1件しかない場合は，集計行を自動的に削除できます。

フィールドが1件のときキー集計行を削除するには，メニュー［集計］－［1件のときキー集計行を削除する］を選択します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 153 / 356


6.6.6 集計行の位置を変更する : EUR 帳票作成 操作ガイド

  • 154 / 356

  • 表紙

  • 6.　帳票上でデータを集計する

  • 6.6　集計行を編集する

  • 6.6.6　集計行の位置を変更する

6.6.6　集計行の位置を変更する

集計行は，編集対象の集計のキーフィールドで改ブロック，または改ページを設定すれば，ほかの帳票のデータと分けて異なる位置に移動できます。ただし，総集計は除きます。表示位置の移動については，「6.6.6(1)　集計行の表示位置の移動」を参照してください。

集計行の位置を移動したあと，繰り返しの最終位置が集計行の直前になっています。このため，集計行と繰り返しの最終位置を変更できます。繰り返しの最終位置は，繰り返し下限位置を調整してから変更します。下限位置の設定については，「6.6.6(2)　集計行の下限位置の設定」を参照してください。

〈この項の構成〉

  • (1)　集計行の表示位置の移動

  • (2)　集計行の下限位置の設定

  • (3)　集計行の位置解除

(1)　集計行の表示位置の移動

集計行編集モードのバーで［位置固定］ボタンをクリックできる状態のとき，集計行を移動できます。集計行が移動できるのは，改ブロック，または改ページが設定されているキー集計行と総集計行です。手順を次に示します。

  1. 集計行の位置移動の開始宣言をする

    集計行編集モードの［位置固定］ボタンをクリックします。［位置固定］ボタンは，あらかじめ改ブロック，または改ページを設定していないと，選択できません。

  2. 集計行を移動する

    移動対象の集計行の上でドラッグして，集計行を表示する位置にラバーバンドを移動します。ラバーバンドが消え，1ブロックまたは1ページに対して集計行の表示位置が固定されます。

(a)　補足説明

  • マウスボタンを離す前に＜Esc＞キーを押すと，位置固定を取り消せます。

  • ［繰り返し個数指定］ダイアログで繰り返し個数を「自動設定」にしている場合は，表示位置の固定によって繰り返し下限位置が設定されます。

    ブロック内で位置固定する場合，縦優先の繰り返しが設定されているときは垂直方向へ，横優先の繰り返しが設定されているときは水平方向へ移動できます。移動したあと，縦優先の繰り返しをしたときは矩形の上辺，横優先の繰り返しをしたときは矩形の左辺が繰り返しの下限として設定されます。

ページの先頭へ

(2)　集計行の下限位置の設定

集計行の位置を移動すると，繰り返しの最終位置が集計行の直前になっています。このため，集計行と繰り返しの最終位置を，間隔を開けたり，繰り返し個数を調整したりして変更できます。手順を次に示します。

  1. 繰り返し下限位置指定の開始宣言をする

    集計行編集モードの［繰り返し下限位置指定］ボタンをクリックします。貼付域に限界位置を示すラバーバンドが表示されます。繰り返しの方向が縦優先の場合は水平線が，横優先の場合は垂直線が表示されます。

    また，指定された繰り返し下限位置で繰り返せる個数が，ステータスバーに表示されます。

  2. 下限位置を移動する

    下限位置を表す線をドラッグして，変更する位置でマウスボタンを離します。

(a)　補足説明

  • ブロック内で位置固定する場合，縦優先の繰り返しが設定されているときは垂直方向へ，横優先の繰り返しが設定されているときは水平方向へ移動できます。移動したあと，縦優先の繰り返しをしたときは繰り返しの下限，横優先の繰り返しをしたときは繰り返しの右限として設定されます。ただし，繰り返し位置を超えて，繰り返し方向と反対側に設定した場合は，無条件に1個繰り返しできる位置を繰り返しの限界位置として設定されます。

  • マウスボタンを離す前に＜Esc＞キーを押すと，繰り返し下限位置の指定を取り消せます。

ページの先頭へ

(3)　集計行の位置解除

集計行編集モードの［位置固定解除］ボタンをクリックすると，集計行を移動する前の位置に戻ります。フィールド位置は，左に詰められます。

なお，集計行に対してアイテム操作をしている場合は，移動する前の状態には戻りません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 154 / 356


6.6.7 集計ページを設定する : EUR 帳票作成 操作ガイド

  • 155 / 356

  • 表紙

  • 6.　帳票上でデータを集計する

  • 6.6　集計行を編集する

  • 6.6.7　集計ページを設定する

6.6.7　集計ページを設定する

集計行編集では，集計行だけを表示する集計ページを設定できます。

集計ページを設定すると，集計ページに集計行にあるアイテムと見出し文字列を表示します。見出し文字列は，集計行を作成する前に，見出しにしたい文字列を［繰り返し］－［見出し指定］で設定しておいてください。［見出し指定］に設定されていないと，表示されません。線で囲まれていたり，網掛けされていたりする文字列を見出しにしても，集計ページには，文字列だけを表示します。同じように線で囲んだり，網掛けをしたりする場合は，集計行編集モードで設定してください。

集計ページにページ番号を付加したり，集計ページに表示されているページ番号の表示形式を変更したりする場合も，集計行編集モードで設定します。指定するページ番号の表示形式は，通常のページと異なる形式を指定できます。総集計の集計ページでページ番号を初期化したり，キー集計の集計ページで表示形式を変更したりする場合は，［アイテムのプロパティ］ダイアログの［表示形式］（ページ番号）ページで，［バージョン3形式］を選択してください。ページ番号の設定については「4.5　ページ番号を配置する」を，ページ番号の表示形式の変更については「13.7　ページ番号アイテムのプロパティを設定する」を参照してください。

集計ページは，作成したあと解除すると，すべての編集を破棄して，集計行を作成したときの状態に戻ります。

重要

集計ページでは，次に示す設定はできません。

  • 集計ページは，帳票に一つでも集計行の位置固定の指定があると設定できません。

  • 特殊編集レベルの集計行は，集計ページには設定できません。

  • 集計ページには，部品の貼り付けができません。

  • ページ集計行は，集計ページには設定できません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 155 / 356


6.6.8 集計行／総集計行を解除する : EUR 帳票作成 操作ガイド

  • 156 / 356

  • 表紙

  • 6.　帳票上でデータを集計する

  • 6.6　集計行を編集する

  • 6.6.8　集計行／総集計行を解除する

6.6.8　集計行／総集計行を解除する

集計行／総集計行を解除する方法を次に示します。

  1. 集計行解除を設定する

    ［集計］－［集計行解除］を選択します。

  2. 集計行を選択する

    集計を解除する行のフィールドをクリックします。

    解除してもよいかどうかを確認するメッセージが表示されます。アイテムを選択する前に＜Esc＞キーを押すと，集計の解除を取り消せます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 156 / 356


6.6.9 集計行編集時の注意 : EUR 帳票作成 操作ガイド

  • 157 / 356

  • 表紙

  • 6.　帳票上でデータを集計する

  • 6.6　集計行を編集する

  • 6.6.9　集計行編集時の注意

6.6.9　集計行編集時の注意

  • 集計行編集で，集計行が一つの繰り返し幅を超えるような編集をした場合は，集計行がデータの量によって複数ページにわたることがあります。その場合は，正しく印刷されません。複数ページにわたるときは，データに空白行を作成するなど，データ量を調整してください。

  • 1行目に集計行がある帳票では，集計行編集モードでは表示の確認ができない場合があります。そのときは，［表示］－［レイアウト］を選択して，確認してください。

  • 空データは，集計の対象外です。そのため，データ中に空データがある場合，集計方法を指定すると，次のようになります。

    • 合計，平均，最大，および最小は，計算対象外です。

    • 件数は，カウントされません。

    また，空データだけを集計した場合，集計アイテムは空白で表示されます。

  • 集計行（キー集計，総集計）の作成は，繰り返しの定義が終わってから行ってください。集計行を作成したあとで繰り返しなどの変更をしても，作成された集計行には反映されません。また，集計行編集モードで生成したアイテムは，集計行編集モードでしか編集できません。そのため，集計行編集は，帳票定義の最後に実行してください。

  • 複数フィールドをキーにして集計する場合は，データをソートし，階層化してから集計を行ってください。データが階層化されていないと，正しく集計されません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 157 / 356


6.7 集計結果をアイテムとして挿入する : EUR 帳票作成 操作ガイド

  • 158 / 356

  • 表紙

  • 6.　帳票上でデータを集計する

  • 6.7　集計結果をアイテムとして挿入する

6.7　集計結果をアイテムとして挿入する

集計アイテムは，集計結果を表示するアイテムです。集計アイテムには，次に示す二つの生成方法があります。

  • ［集計］－［キー集計］，または［総集計］を実行することで，新しく挿入された行に生成します。この方法では，帳票上に貼り付けられているすべての数値データの集計結果を生成します。編集は，集計行の編集でしか操作できません。

  • ［集計］－［集計アイテム］を実行することで生成します。帳票の任意の位置に貼り付け，通常の編集で操作します。この方法は，指定した集計対象フィールドだけの集計結果を生成します。そのため，集計行の編集中に，誤って削除してしまった集計アイテムを生成するときにも使えます。この場合は，集計行の編集で操作します。

〈この節の構成〉

  • 6.7.1　集計アイテムを作成する

  • 6.7.2　集計アイテムのプロパティを設定する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 158 / 356


6.7.1 集計アイテムを作成する : EUR 帳票作成 操作ガイド

  • 159 / 356

  • 表紙

  • 6.　帳票上でデータを集計する

  • 6.7　集計結果をアイテムとして挿入する

  • 6.7.1　集計アイテムを作成する

6.7.1　集計アイテムを作成する

帳票ウィンドウの任意の位置に，指定した集計対象フィールドの集計結果を貼り付けられます。集計結果を追加したり，誤って削除してしまった集計結果を作成し直したりもできます。

帳票ヘッダ領域に集計アイテムを貼り付ける場合は，「帳票ヘッダ集計」の集計結果を帳票ヘッダ領域に貼り付けてください。

集計アイテムは，通常の編集で操作できますが，集計行編集モードで作成した集計アイテムは，集計行編集モードでしか操作できません。

〈この項の構成〉

  • (1)　集計アイテムを作成する

(1)　集計アイテムを作成する

  1. ［集計アイテム］ダイアログを表示する

    ［集計］－［集計アイテム］を選択します。［集計アイテム］ダイアログの各項目の設定内容については，マニュアル「EUR 帳票作成 画面リファレンス」を参照してください。

  2. 集計アイテムを貼り付ける

    マウスの形が [図データ] に変わります。このとき，マウスをクリックすると，ラバーバンドが表示されます。ドラッグしてラバーバンドを貼り付け位置まで移動させてください。集計アイテムが貼り付けられます。ただし，「フィールドのデータ」の場合は，［集計対象フィールド］から選択したフィールドで，かつキー集計の対象となるレコードの先頭データが表示されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 159 / 356


6.7.2 集計アイテムのプロパティを設定する : EUR 帳票作成 操作ガイド

  • 160 / 356

  • 表紙

  • 6.　帳票上でデータを集計する

  • 6.7　集計結果をアイテムとして挿入する

  • 6.7.2　集計アイテムのプロパティを設定する

6.7.2　集計アイテムのプロパティを設定する

貼り付けられた集計アイテムの配置，フォント，集計内容，および文字配置を変更する場合は，［アイテムのプロパティ］ダイアログで変更します。

集計アイテムを選択したあと，［編集］－［アイテムのプロパティ］を選択すると，［アイテムのプロパティ］ダイアログが表示されます。

［集計種別］リストボックスで「総集計」，「キー集計」，または「帳票ヘッダ集計」が選択されている場合は，集計アイテムを選択すると，［表示形式］タブの分類に「集計」と「数値データ」が表示されます。集計方法を変更する場合は「集計」，集計結果の数値データのプロパティ設定をする場合は「数値データ」を選択してください。

［集計種別］リストボックスで「フィールドのデータ」が選択されている場合は，集計アイテムを選択すると，［表示形式］タブの分類に「集計」が表示されます。ただし，［集計内容］の設定はできません。

〈この項の構成〉

  • (1)　補足説明

(1)　補足説明

「帳票ヘッダ集計」の集計アイテムは，帳票のどこにでも設定できますが，帳票ヘッダ領域に貼り付けた場合は，帳票ヘッダアイテムとなります。そのため，帳票ヘッダ領域を削除すると，「帳票ヘッダ集計」の集計アイテムも削除されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 160 / 356


7. 帳票の表紙ページを作成する : EUR 帳票作成 操作ガイド

  • 161 / 356

  • 表紙

  • 7.　帳票の表紙ページを作成する

7.　帳票の表紙ページを作成する

この章では，帳票ヘッダを設定して，帳票の表紙を作成する方法について説明します。

〈この章の構成〉

  • 7.1　帳票ヘッダ領域を設定する

  • 7.2　帳票ヘッダアイテムを設定する

  • 7.3　アイテムの配置を設定する

  • 7.4　アイテムを固定位置に貼り付ける

  • 7.5　帳票ヘッダ集計の作成

  • 7.6　帳票ヘッダ領域の削除

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 161 / 356


7.1 帳票ヘッダ領域を設定する : EUR 帳票作成 操作ガイド

  • 162 / 356

  • 表紙

  • 7.　帳票の表紙ページを作成する

  • 7.1　帳票ヘッダ領域を設定する

7.1　帳票ヘッダ領域を設定する

1ページ目（表紙ページ）と次紙ページの帳票形式を変更できます。これを表紙のある帳票といいます。

図7‒1　表紙のある帳票の例

[図データ]

表紙には，帳票のタイトルや会社名・住所，データの集計結果など，表紙に表示する内容と，繰り返しで作成する表の一部を表示し，次紙には表の続きだけを表示するようにできます。表紙は，改ページ機能で指定したフィールドのデータが変化するたびに作成されます。表紙にだけ表示されるデータを配置した領域を帳票ヘッダ領域といいます。

表紙のある帳票を設計する場合，次のようなデータを作成します。

  • リストの1行として出力するデータが，1レコードにまとまっている。

  • 改ページのキーとなるデータが，連続して複数行に入っている。

帳票と使用しているデータの例を次に示します。

表紙ページの貼付域の上端から，任意の範囲を帳票ヘッダ領域として確保できます。

〈この節の構成〉

  • 7.1.1　帳票ヘッダ領域を設定する

  • 7.1.2　補足説明

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 162 / 356


7.1.1 帳票ヘッダ領域を設定する : EUR 帳票作成 操作ガイド

  • 163 / 356

  • 表紙

  • 7.　帳票の表紙ページを作成する

  • 7.1　帳票ヘッダ領域を設定する

  • 7.1.1　帳票ヘッダ領域を設定する

7.1.1　帳票ヘッダ領域を設定する

  1. 帳票ヘッダ区切り線を表示する

    ［挿入］－［帳票ヘッダ領域］を選択します。帳票ファイルの上端に「ヘッダ区切り」という文字列を区切り線上に表示した，薄い灰色の帳票ヘッダ区切り線が表示されます。帳票ヘッダ領域の初期サイズは，帳票ファイル上端から5mmです。

  2. 帳票ヘッダ領域を確保する

    帳票ヘッダ区切り線にマウスポインタを合わせると，ポインタの形状が [図データ] に変わります。ドラッグすると，帳票ヘッダ領域のサイズを変更できます。帳票ヘッダ領域の最大サイズは，繰り返し領域のアイテムがないとき，帳票ファイル下端から20mm上までとします。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 163 / 356


7.1.2 補足説明 : EUR 帳票作成 操作ガイド

  • 164 / 356

  • 表紙

  • 7.　帳票の表紙ページを作成する

  • 7.1　帳票ヘッダ領域を設定する

  • 7.1.2　補足説明

7.1.2　補足説明

  • 帳票ヘッダ区切り線は，表紙ページを編集しているときだけ表示されます。次紙ページの編集中やレイアウトモードでは表示されません。

  • 帳票に複数の改ページキーが設定されている場合は，任意のキーブレイクで表紙ページを出したり，出さなかったりすることはできません。複数の改ページキーが設定されている場合は，一つの改ページキーに設定し直してください。

  • 複数様式で帳票を出力する場合は，表紙のある帳票（帳票ヘッダ領域のある帳票）は出力できません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 164 / 356


7.2 帳票ヘッダアイテムを設定する : EUR 帳票作成 操作ガイド

  • 165 / 356

  • 表紙

  • 7.　帳票の表紙ページを作成する

  • 7.2　帳票ヘッダアイテムを設定する

7.2　帳票ヘッダアイテムを設定する

帳票ヘッダアイテムは，帳票ヘッダ領域に貼り付けられたアイテムのことです。表紙ページだけに表示されるアイテムなので，編集操作は，表紙ページでしかできません。

帳票ヘッダ領域には，部品を含むすべてのアイテムを貼り付けられます。ただし，帳票ヘッダアイテムは，繰り返し定義と表の繰り返し見出し定義を設定することはできません。

〈この節の構成〉

  • 7.2.1　帳票ヘッダアイテムを作成する

  • 7.2.2　繰り返し領域のアイテムを操作する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 165 / 356


7.2.1 帳票ヘッダアイテムを作成する : EUR 帳票作成 操作ガイド

  • 166 / 356

  • 表紙

  • 7.　帳票の表紙ページを作成する

  • 7.2　帳票ヘッダアイテムを設定する

  • 7.2.1　帳票ヘッダアイテムを作成する

7.2.1　帳票ヘッダアイテムを作成する

直接，帳票ヘッダ領域にアイテムを作成したり，マッピングしたりすることで，帳票ヘッダアイテムを作成できます。また，繰り返し領域でアイテムを作成したあと，帳票ヘッダ領域にコピー／貼り付けをしたり，移動したりすることもできます。

ただし，アイテムの領域の左上座標が，帳票ヘッダ領域に掛かっていたり，線アイテムの両端の片方が帳票ヘッダ領域に掛かっていたりした場合，そのアイテムは自動的に帳票ヘッダアイテムになります。

帳票ヘッダ領域に集計アイテムを作成する場合は，「6.7　集計結果をアイテムとして挿入する」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 166 / 356


7.2.2 繰り返し領域のアイテムを操作する : EUR 帳票作成 操作ガイド

  • 167 / 356

  • 表紙

  • 7.　帳票の表紙ページを作成する

  • 7.2　帳票ヘッダアイテムを設定する

  • 7.2.2　繰り返し領域のアイテムを操作する

7.2.2　繰り返し領域のアイテムを操作する

帳票ヘッダ領域より下の部分を，「繰り返し領域」といいます。

表紙ページの帳票ヘッダ区切り線の下端から繰り返し領域としてアイテムを配置できます。表紙ページで繰り返しアイテムを配置すると，次紙ページでは，ページ上端から繰り返し領域のアイテムを配置します。このとき，次紙ページでの貼付域の上端とアイテムとの距離は，表紙ページでのヘッダ区切り線とアイテムとの距離と同じになります。

図7‒2　帳票ヘッダ区切り線および貼付域の上端と，アイテムとの関係

[図データ]

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 167 / 356


7.3 アイテムの配置を設定する : EUR 帳票作成 操作ガイド

  • 168 / 356

  • 表紙

  • 7.　帳票の表紙ページを作成する

  • 7.3　アイテムの配置を設定する

7.3　アイテムの配置を設定する

ページ番号，タイトルなど，常に帳票の固定位置に表示されるようなアイテムを作成する場合は，アイテムの配置を設定しておきます。ただし，アイテムの配置を設定できるのは，繰り返し領域にある，非繰り返しアイテムだけです。帳票ヘッダ領域内で固定位置にアイテムを表示させる場合は，繰り返し領域で非繰り返しアイテムにアイテムの配置を設定したあと，アイテムを複写，または移動させてください。また，アイテムを貼り付けた位置によって，アイテムの配置の設定を変更できない場合があります。

アイテムを常に帳票の固定位置に表示する設定を次に示します。

  1. アイテムを選択する

    表紙ページ，または次紙ページの繰り返し領域にある，固定位置に表示する非繰り返しアイテムを選択します。

  2. アイテムの配置を設定する

    ［編集］－［アイテムの配置］－［繰り返し領域の左上を基準］または，［貼付域の左上を基準］を選択します。

［繰り返し領域の左上を基準］または［貼付域の左上を基準］を設定した場合の表示例を次の図に示します。

図7‒3　アイテムの配置を設定した場合の表示例

[図データ]

〈この節の構成〉

  • 7.3.1　アイテムの位置を，繰り返し領域の左上を基準にして表示する

  • 7.3.2　アイテムの位置を，貼付域の左上を基準にして表示する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 168 / 356


7.3.1 アイテムの位置を，繰り返し領域の左上を基準にして表示する : EUR 帳票作成 操作ガイド

  • 169 / 356

  • 表紙

  • 7.　帳票の表紙ページを作成する

  • 7.3　アイテムの配置を設定する

  • 7.3.1　アイテムの位置を，繰り返し領域の左上を基準にして表示する

7.3.1　アイテムの位置を，繰り返し領域の左上を基準にして表示する

［繰り返し領域の左上を基準］を設定したアイテムは，繰り返し領域から帳票ヘッダ領域へアイテムを移動させると，表紙ページだけにアイテムが表示されます。

帳票ヘッダ領域に貼り付けた，［繰り返し領域の左上を基準］を設定したアイテムは，帳票ヘッダ領域を削除すると，貼り付けたアイテムも削除されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 169 / 356


7.3.2 アイテムの位置を，貼付域の左上を基準にして表示する : EUR 帳票作成 操作ガイド

  • 170 / 356

  • 表紙

  • 7.　帳票の表紙ページを作成する

  • 7.3　アイテムの配置を設定する

  • 7.3.2　アイテムの位置を，貼付域の左上を基準にして表示する

7.3.2　アイテムの位置を，貼付域の左上を基準にして表示する

［貼付域の左上を基準］を設定したアイテムは，すべてのページの同じ位置に表示されます。繰り返し領域から帳票ヘッダ領域へ，または繰り返し領域内で，アイテムをコピー，または移動することで，貼付域内のどこにでも表示できます。

帳票ヘッダ領域に貼り付けた，［貼付域の左上を基準］を設定したアイテムは，帳票ヘッダ領域を削除しても，貼り付けたアイテムは残ります。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 170 / 356


7.4 アイテムを固定位置に貼り付ける : EUR 帳票作成 操作ガイド

  • 171 / 356

  • 表紙

  • 7.　帳票の表紙ページを作成する

  • 7.4　アイテムを固定位置に貼り付ける

7.4　アイテムを固定位置に貼り付ける

固定位置に表示させるアイテムを貼り付ける場合，次に示す印刷・表示結果が得られることがあります。

〈この節の構成〉

  • 7.4.1　帳票ヘッダ領域内に，固定位置に表示させるアイテムを貼り付ける場合

  • 7.4.2　繰り返し領域内に，固定位置に表示させるアイテムを貼り付ける場合

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 171 / 356


7.4.1 帳票ヘッダ領域内に，固定位置に表示させるアイテムを貼り付ける場合 : EUR 帳票作成 操作ガイド

  • 172 / 356

  • 表紙

  • 7.　帳票の表紙ページを作成する

  • 7.4　アイテムを固定位置に貼り付ける

  • 7.4.1　帳票ヘッダ領域内に，固定位置に表示させるアイテムを貼り付ける場合

7.4.1　帳票ヘッダ領域内に，固定位置に表示させるアイテムを貼り付ける場合

帳票ヘッダ領域内に，［貼付域の左上を基準］を設定したアイテムを貼り付ける場合，帳票ヘッダ区切り線の下端から繰り返しアイテムを配置した位置が狭いと，次ページの繰り返し領域にアイテムが重なって表示されることがあります。

この場合は，帳票ヘッダ領域内の固定位置に表示させるアイテムの位置を考慮して，帳票ヘッダ区切り線の下端から，配置する繰り返しアイテムの間を空けてください。また，次紙ページで，固定位置に表示させるアイテムの配置と繰り返し領域のアイテムを配置すると，それぞれのアイテムの配置位置を確認しながら作成することもできます。

帳票ヘッダ領域内に，固定位置に表示させるアイテムを貼り付ける場合の表示・印刷結果と対処後の表示・印刷結果を次の図に示します。

図7‒4　帳票ヘッダ領域内に，固定位置に表示させるアイテムを貼り付ける場合の対処

[図データ]

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 172 / 356


7.4.2 繰り返し領域内に，固定位置に表示させるアイテムを貼り付ける場合 : EUR 帳票作成 操作ガイド

  • 173 / 356

  • 表紙

  • 7.　帳票の表紙ページを作成する

  • 7.4　アイテムを固定位置に貼り付ける

  • 7.4.2　繰り返し領域内に，固定位置に表示させるアイテムを貼り付ける場合

7.4.2　繰り返し領域内に，固定位置に表示させるアイテムを貼り付ける場合

繰り返し領域内の表の下に，固定位置に表示させるアイテムを貼り付ける場合，帳票ヘッダ領域のサイズや繰り返しアイテムを貼り付けた位置，繰り返しの幅などによって，繰り返し領域のアイテムと固定位置に表示させるアイテムが重なって表示されることがあります。

この場合は，繰り返し個数を指定することで，重なりを回避できますが，繰り返し個数は，表紙ページと次紙ページとで同じ繰り返し個数で表示されるため，［貼付域の左上を基準］を設定している場合は，表と固定位置に表示させるアイテムの間が広くなります。［繰り返し領域の左上を基準］を設定している場合，次紙ページのページ下端から帳票ヘッダ領域と同じサイズの領域には，アイテムを作成したり，貼り付けたりできないため，余白ができます。

繰り返し領域内に，固定位置に表示させるアイテムを貼り付ける場合の表示・印刷結果と対処後の表示・印刷結果を次の図に示します。

図7‒5　繰り返し領域内に，固定位置に表示させるアイテムを貼り付ける場合の対処

[図データ]

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 173 / 356


7.5 帳票ヘッダ集計の作成 : EUR 帳票作成 操作ガイド

  • 174 / 356

  • 表紙

  • 7.　帳票の表紙ページを作成する

  • 7.5　帳票ヘッダ集計の作成

7.5　帳票ヘッダ集計の作成

帳票ヘッダ領域が設定されている帳票に設定できます。

帳票ヘッダ集計とは，帳票ヘッダ領域から次の帳票ヘッダ領域までのデータを一まとまりにして，集計する機能です。

帳票ヘッダ集計で集計アイテムを作成するには，帳票ヘッダ領域を作成したあと，［集計］－［集計アイテム］を選択すると，［集計アイテム］ダイアログが表示されます。

［集計アイテム］ダイアログで，［集計種別］から［帳票ヘッダ集計］を選択したあと，集計内容と集計フィールドを指定すると，集計アイテムが作成されます。集計アイテムは，集計行以外の，帳票のどこにでも貼り付けられます。

「6.7　集計結果をアイテムとして挿入する」もあわせて参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 174 / 356


7.6 帳票ヘッダ領域の削除 : EUR 帳票作成 操作ガイド

  • 175 / 356

  • 表紙

  • 7.　帳票の表紙ページを作成する

  • 7.6　帳票ヘッダ領域の削除

7.6　帳票ヘッダ領域の削除

帳票ヘッダ領域を削除します。帳票ヘッダ領域に，帳票ヘッダアイテムが貼り付けられている場合は，帳票ヘッダアイテムもすべて削除します。ただし，アイテムの配置で［貼付域の左上を基準］を設定したアイテムは，帳票ヘッダ領域を削除しても，貼り付けたアイテムは残ります。

帳票ヘッダ領域を削除するには，［編集］－［帳票ヘッダ領域の削除］を選択します。帳票ヘッダ領域に，帳票ヘッダアイテムが貼り付けられている場合は，問い合わせダイアログが表示されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 175 / 356


8. 貼り付けたデータを帳票上でカスタマイズする : EUR 帳票作成 操作ガイド

  • 176 / 356

  • 表紙

  • 8.　貼り付けたデータを帳票上でカスタマイズする

8.　貼り付けたデータを帳票上でカスタマイズする

この章では，貼り付けたデータのフォーマットや表示・非表示などを帳票上でカスタマイズする方法について説明します。

〈この章の構成〉

  • 8.1　文字列や数値を置き換えて表示する

  • 8.2　アイテムの表示条件を設定する

  • 8.3　特定の行のデータを編集する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 176 / 356


8.1 文字列や数値を置き換えて表示する : EUR 帳票作成 操作ガイド

  • 177 / 356

  • 表紙

  • 8.　貼り付けたデータを帳票上でカスタマイズする

  • 8.1　文字列や数値を置き換えて表示する

8.1　文字列や数値を置き換えて表示する

データウィンドウから貼り付けたデータを置き換えて表示できます。繰り返し定義を設定したデータに置き換え表を使用することで，繰り返し対象のすべてのデータを置き換えられます。

従来，数値やコードで示していたデータに置き換え表を使用することで，既存のデータファイルやデータベースのデータを変更することなく，よりわかりやすい帳票を定義できます。置き換えが指定できるデータは，文字列データと数値データです。

アイテムの置き換えの手順を次に示します。

  1. マッピングデータまたはユーザ定義データを帳票ウィンドウに貼り付け，帳票を定義する

    アイテムの置き換えをする場合も帳票の定義方法は同じです。ただし，置き換える文字列が長い場合は，アイテム枠をあらかじめ大きめに設定してください。アイテム枠が小さいと，置き換えた文字列が正しく表示されません。

    データを貼り付ける方法については，「4.3　データウィンドウからデータを貼り付ける」を参照してください。

  2. 置き換え表ファイルを作成する

    置き換え表ファイルは，置き換え元のデータと置き換える文字列との関連づけを記述したCSV形式ファイルです。置き換え表ファイルの作成方法は，「8.1.1　置き換え表ファイルを作成する」を参照してください。

  3. 置き換え表管理情報ファイルを作成する

    置き換え表管理情報ファイルとは，置き換え表ファイルの名称と格納先を示したファイルです。置き換え表管理情報ファイルの作成方法は，「8.1.2　置き換え表管理情報ファイルを作成する」を参照してください。

  4. 置き換え表を登録する

    置き換え表管理情報ファイルを読み込むことで，EURに置き換え表が登録できます。置き換え表の登録方法は，「8.1.3　置き換え表を登録する」を参照してください。

  5. 置き換えるアイテムを指定する

    置き換えるアイテムは，帳票ウィンドウで指定します。置き換えるアイテムの指定方法は，「8.1.4　置き換えるアイテムを指定する」を参照してください。

〈この節の構成〉

  • 8.1.1　置き換え表ファイルを作成する

  • 8.1.2　置き換え表管理情報ファイルを作成する

  • 8.1.3　置き換え表を登録する

  • 8.1.4　置き換えるアイテムを指定する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 177 / 356


8.1.1 置き換え表ファイルを作成する : EUR 帳票作成 操作ガイド

  • 178 / 356

  • 表紙

  • 8.　貼り付けたデータを帳票上でカスタマイズする

  • 8.1　文字列や数値を置き換えて表示する

  • 8.1.1　置き換え表ファイルを作成する

8.1.1　置き換え表ファイルを作成する

置き換え表ファイルは，アイテムのデータを置き換えて出力する場合に，1フィールドごとの置き換え対象のデータと，置き換えて出力するデータを定義したファイルです。

置き換え表ファイルは，CSV形式データ（*.csv）で作成します。

〈この項の構成〉

  • (1)　置き換え表ファイルの形式

  • (2)　置き換え表ファイルの保存場所

(1)　置き換え表ファイルの形式

キーデータ,置き換えデータ▼
キーデータ,置き換えデータ▼
            ：
（凡例）

▼：改行コードを示します。

キーデータ

置き換えの対象とする文字列を指定します。指定できる文字列長は，256文字までです。同一のキーデータが指定された場合，最初に記述したキーデータが有効となり，2番目以降の記述は無視されます。

文字列に，空白，コンマ（,）を使用している場合は，その文字を引用符（"）で囲んで指定してください。引用符（"）を使用している場合は，引用符（"）を続けて二つ指定してください。

置き換えデータ

置き換えて出力する文字列を指定します。指定できる文字列長は，256文字までです。

文字列に，空白，コンマ（,）を使用している場合は，その文字を引用符（"）で囲んで指定してください。引用符（"）を使用している場合は，引用符（"）を続けて二つ指定してください。

空データの置き換えもできます。空データは次のように指定します。

  • 空データを文字列に置き換える場合

    ,"置き換え空データ1"　　または

    "","置き換え空データ2"

  • 文字列を空データに置き換える場合

    "キーデータ1",　　または

    "キーデータ2",""

    図8‒1　置き換え表ファイルの表示例

    [図データ]

ページの先頭へ

(2)　置き換え表ファイルの保存場所

置き換え表ファイルは，EUR 帳票作成機能の［オプション］ダイアログ－［ファイル］タブで設定されたフォルダに格納してください。ほかの場所に格納すると，置き換え表を設定した帳票ファイルを開いたときにエラーになります。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 178 / 356


8.1.2 置き換え表管理情報ファイルを作成する : EUR 帳票作成 操作ガイド

  • 179 / 356

  • 表紙

  • 8.　貼り付けたデータを帳票上でカスタマイズする

  • 8.1　文字列や数値を置き換えて表示する

  • 8.1.2　置き換え表管理情報ファイルを作成する

8.1.2　置き換え表管理情報ファイルを作成する

置き換え表管理情報ファイルは，置き換え表ファイルのファイル名と，置き換え表を指定する場合に必要なファイルの表示名（置き換え表名）との対応を定義したファイルです。

置き換え表管理情報ファイルは，CSV形式データ（*.csv）で作成します。

複数の帳票出力や複数様式での帳票出力をする場合は，共通の置き換え表管理情報ファイルが使用されます。

〈この項の構成〉

  • (1)　置き換え表管理情報ファイルの形式

  • (2)　置き換え表管理情報ファイルの保存場所

(1)　置き換え表管理情報ファイルの形式

置き換え表名,置き換え表ファイル名▼
置き換え表名,置き換え表ファイル名▼
            ：
（凡例）

▼：改行コードを示します。

置き換え表名

置き換え表ファイルを区別するために付けた名称を指定します。指定できる置き換え表名の長さは，50文字までです。同一の置き換え表名が指定された場合，最初に記述した置き換え表名が有効となり，2番目以降の記述は無視されます。

置き換え表名に，空白，コンマ（,）を使用している場合は，その文字を引用符（"）で囲んで指定してください。引用符（"）を使用している場合は，引用符（"）を続けて二つ指定してください。

置き換え表ファイル名

置き換え表名に対応する置き換え表ファイル名を指定します。フルパス，相対パスは指定できません。ファイル名は，256文字までです。

図8‒2　置き換え表管理情報ファイルの表示例

[図データ]

ページの先頭へ

(2)　置き換え表管理情報ファイルの保存場所

置き換え表管理情報ファイルは，EUR 帳票作成機能の［オプション］ダイアログ－［ファイル］タブで設定されたフォルダに格納してください。ほかの場所に格納すると，置き換え表を設定した帳票ファイルを開いたときにエラーになります。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 179 / 356


8.1.3 置き換え表を登録する : EUR 帳票作成 操作ガイド

  • 180 / 356

  • 表紙

  • 8.　貼り付けたデータを帳票上でカスタマイズする

  • 8.1　文字列や数値を置き換えて表示する

  • 8.1.3　置き換え表を登録する

8.1.3　置き換え表を登録する

置き換え表管理情報ファイルを読み込み，置き換え表をEURに登録します。置き換え表管理情報ファイルとは，置き換え表の名称と格納先を示したファイルです。

置き換え表管理情報ファイルの作成については，「8.1.2　置き換え表管理情報ファイルを作成する」を参照してください。

〈この項の構成〉

  • (1)　置き換えデータを登録する

(1)　置き換えデータを登録する

  1. ［レポートのプロパティ］ダイアログを表示する

    ［ファイル］－［プロパティ］を選択します。［レポートのプロパティ］ダイアログが表示されます。

  2. ［置き換え表］タブを選択する

  3. 置き換え表管理情報ファイルを指定する

    ［置き換え表管理情報ファイル名称］テキストボックスに置き換え表管理情報ファイルの格納先を指定します。［...］ボタンをクリックすると，［置き換え表管理情報ファイルの指定］ダイアログが開きます。

  4. ［OK］ボタンをクリックする

    置き換え表管理情報ファイルが読み込まれ，置き換え表がEURに登録されます。［OK］ボタンをクリックすると，置き換え表管理情報ファイルの内容を確認します。内容に誤りがある場合は，メッセージが表示されます。

    重要

    置き換え表管理情報ファイルを読み込んだあと，置き換え表ファイルを変更した場合は，置き換え表管理情報ファイルをもう一度読み込んでください。置き換え表管理情報ファイルの読み込みをしないと，置き換え表ファイルの内容が帳票に正しく反映されません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 180 / 356


8.1.4 置き換えるアイテムを指定する : EUR 帳票作成 操作ガイド

  • 181 / 356

  • 表紙

  • 8.　貼り付けたデータを帳票上でカスタマイズする

  • 8.1　文字列や数値を置き換えて表示する

  • 8.1.4　置き換えるアイテムを指定する

8.1.4　置き換えるアイテムを指定する

登録した置き換え表に合わせて，アイテムを置き換えられます。置き換えるアイテムは，帳票ウィンドウで指定します。

置き換えるアイテムを指定する前に，置き換え表を登録しておく必要あります。置き換え表の登録については，「8.1.3　置き換え表を登録する」を参照してください。

通常行の場合，データウィンドウから貼り付けた文字アイテムおよび数値アイテムを置き換えられます。集計行の場合，文字アイテムは置き換えられますが，数値アイテムは置き換えられません。

〈この項の構成〉

  • (1)　置き換えるアイテムを指定する

(1)　置き換えるアイテムを指定する

  1. 置き換えるアイテムを選択する

    ツールボックスの [図データ] ボタンを選択して選択モードにします。置き換えるアイテムを選択します。

    アイテムが重ねて配置されている場合，ツールボックスの［文字］チェックボックスをオンにすると便利です。

  2. ［アイテムのプロパティ］ダイアログを表示する

    ［編集］－［アイテムのプロパティ］を選択するか，またはショートカットキーの［アイテムのプロパティ］を選択します。

  3. ［置き換え表］タブを選択する

  4. 置き換え表を使用するかどうかを選択する

    ［置き換えする］チェックボックスにチェックを入れます。置き換え表を登録していない場合は，［置き換えする］チェックボックスは不活性になります。置き換え表の登録については，「8.1.3　置き換え表を登録する」を参照してください。

  5. 置き換え表を指定する

    ［置き換え表］リストボックスで，置き換え表の名称を指定します。

  6. ［OK］ボタンをクリックする

    帳票ウィンドウに戻り，アイテムが置き換えられます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 181 / 356


8.2 アイテムの表示条件を設定する : EUR 帳票作成 操作ガイド

  • 182 / 356

  • 表紙

  • 8.　貼り付けたデータを帳票上でカスタマイズする

  • 8.2　アイテムの表示条件を設定する

8.2　アイテムの表示条件を設定する

アイテムに表示条件を設定して，条件付きアイテムを作成します。条件付きアイテムを使用すると，数値がマイナスの項目だけ赤字で表示したり，強調したい項目だけに画像を表示したりできます。

〈この節の構成〉

  • 8.2.1　条件付きアイテムとは

  • 8.2.2　表示条件を設定できるアイテム

  • 8.2.3　表示条件の設定手順

  • 8.2.4　条件付きアイテムを使用した帳票の設定例

  • 8.2.5　帳票定義情報ファイルで表示条件を指定する場合の注意事項

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 182 / 356


8.2.1 条件付きアイテムとは : EUR 帳票作成 操作ガイド

  • 183 / 356

  • 表紙

  • 8.　貼り付けたデータを帳票上でカスタマイズする

  • 8.2　アイテムの表示条件を設定する

  • 8.2.1　条件付きアイテムとは

8.2.1　条件付きアイテムとは

アイテムに表示条件を設定すると，条件を満たす項目だけを表示できます。この機能を利用して，数値がマイナスの項目だけ赤字にするなど，一部の項目についてだけアイテムのプロパティを変更した帳票が作成できます。表示条件を設定したアイテムを条件付きアイテムと呼びます。条件付きアイテムを設定した帳票の例を次に示します。

図8‒3　目標値以上の項目のフォントを変更した帳票

[図データ]

図8‒4　値がマイナスの項目のフォントを変更し，目標値以上の項目に画像を表示した帳票

[図データ]

図8‒5　ある日付より前の項目のフォントを変更した帳票

[図データ]

条件つきアイテムは，特定の条件を満たした項目だけを表示したい場合や，条件によって項目の表示を変えたい場合に使用します。マッピングデータ上の「1」や「2」などの数字を「部長」「課長」に変更するなど，項目そのものを変更したい場合は，アイテムの置き換え機能を使用してください。アイテムの置き換え機能の詳細については，「8.1　文字列や数値を置き換えて表示する」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 183 / 356


8.2.2 表示条件を設定できるアイテム : EUR 帳票作成 操作ガイド

  • 184 / 356

  • 表紙

  • 8.　貼り付けたデータを帳票上でカスタマイズする

  • 8.2　アイテムの表示条件を設定する

  • 8.2.2　表示条件を設定できるアイテム

8.2.2　表示条件を設定できるアイテム

表示条件を設定できるアイテムを次に示します。

表8‒1 表示条件を設定できるアイテム
データの種別 | 参照フィールドの種別 | 行の種別
 |  | 通常行 | 集計行 | 特殊編集行
マッピングデータ | 文字列 | ○ | － | ○
 | 数値 | ○ | － | ○
 | 数値（集計対象外） | ○ | － | ○
 | 日付（日付・時刻） | ○ | － | ○
 | 日付（日次） | ○ | － | ○
 | 日付（月次） | ○ | － | ○
 | 日付（年次） | ○ | － | ○
 | 和暦（日次） | ○ | － | ○
 | 和暦（月次） | ○ | － | ○
 | 和暦（年次） | ○ | － | ○
 | 画像 | ○ | － | ○
 | バーコード | ○ | － | ○
ユーザ定義データ | 文字列 | ○ | ○ | ○
 | 数値 | ○ | ○ | ○
 | 数値（集計対象外） | ○ | ○ | ○
 | 日付（日付・時刻） | ○ | ○ | ○
 | 日付（日次） | ○ | ○ | ○
 | 日付（月次） | ○ | ○ | ○
 | 日付（年次） | ○ | ○ | ○
 | 和暦（日次） | ○ | － | ○
 | 和暦（月次） | ○ | － | ○
 | 和暦（年次） | ○ | － | ○
 | 画像 | ○ | ○ | ○
 | バーコード | ○ | ○ | ○
固定アイテム | 固定文字列 | ○ | ○ | ○
 | ページ番号 | ○ | ○ | ○
 | 印刷日付 | ○ | ○ | ○
 | 印刷時刻 | ○ | ○ | ○
 | 固定画像 | ○ | ○ | ○
 | 線 | × | × | ×
 | 図形 | ○ | ○ | ○
集計アイテム | 総集計 | ○ | ○ | ○
 | キー集計 | － | ○ | －
 | フィールドのデータ | － | ○ | －
 | ページ集計 | － | ○ | －
部品アイテム | 部品 | × | － | －
（凡例）

○：表示条件を設定できます。

×：表示条件を設定できません。

－：該当する項目はありません。

複数のアイテムを選択して一度に表示条件を設定する場合の注意事項を次に示します。

  • 総集計アイテム，キー集計アイテム，またはページ集計アイテムとそのほかのアイテムとを同時に選択すると，アイテムの表示条件を設定できません。

  • 選択したアイテムにすべて同じ表示条件が設定されている場合でも，［アイテムの表示条件］ダイアログはすべての項目がデフォルトの状態で表示されます。

  • すべての項目を指定する必要があります。指定していない項目がある場合，アイテムの表示条件を設定できません。

アイテムの出力ページの設定は，表示条件を設定して表示されたアイテムにだけ適用されます。出力ページの設定については，「4.9　特定のページに出力するアイテムを設定する」を参照してください。

データ種別ごとの参照情報を次に示します。

表8‒2 データ種別ごとの参照情報
選択したアイテム | 選択したデータ種別 | 参照情報
通常行（総集計アイテム以外） | マッピングデータ | 選択したアイテムのレコードの値※
 | ユーザ定義データ | 1レコード目の値
特殊編集行 | マッピングデータ | 選択したアイテムのレコードの値※
 | ユーザ定義データ | 1レコード目の値
集計アイテム | 集計値 | 選択したアイテムの集計値
 | 集計値以外 | 各行の内容に従った情報
総集計行（集計アイテム以外） | マッピングデータ | 帳票内で最後のレコードの値
 | ユーザ定義データ | 1レコード目の値
ページ集計行（集計アイテム以外） | マッピングデータ | ページで最後のレコードの値
 | ユーザ定義データ | 1レコード目の値
キー集計行（集計アイテム以外） | マッピングデータ | 集計行の直前にあるレコードの値
 | ユーザ定義データ | 1レコード目の値
注※

繰り返しがある場合：ページの先頭レコードの値

繰り返しがない場合：繰り返された行に対応するレコードの値

まとめ表示がある場合：まとめ表示をする単位の先頭レコードの値

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 184 / 356


8.2.3 表示条件の設定手順 : EUR 帳票作成 操作ガイド

  • 185 / 356

  • 表紙

  • 8.　貼り付けたデータを帳票上でカスタマイズする

  • 8.2　アイテムの表示条件を設定する

  • 8.2.3　表示条件の設定手順

8.2.3　表示条件の設定手順

アイテムに表示条件を設定する手順を次に示します。

〈この項の構成〉

  • (1)　アイテムのプロパティを設定する

  • (2)　表示条件を設定する

  • (3)　条件付きアイテムを配置する

(1)　アイテムのプロパティを設定する

文字アイテムのフォント色を変えるなど，アイテムにプロパティを設定します。

  1. アイテムをコピーする

    マイナスの数値のフォントは赤で，目標値以上のフォントは太字で表示するなど，条件付きアイテムに複数のプロパティを設定するためには，プロパティに応じた数だけアイテムをコピーする必要があります。アイテムをコピーするには，表示条件を設定するアイテムを選択して［コピー］および［貼り付け］を実行します。表示条件を複数設定したい場合は，同様の操作を繰り返して表示条件の数に応じた個数のコピーを作成します。

    売上アイテム1をコピーして売上アイテム2を作成する例を次に示します。

    図8‒6　売上アイテムをコピーする例

    [図データ]

  2. アイテムのプロパティを設定する

    コピーしたアイテムを選択して［アイテムのプロパティ］ダイアログを表示し，アイテムのプロパティを変更します。［アイテムのプロパティ］ダイアログを表示するには，［編集］－［アイテムのプロパティ］を選択します。［アイテムのプロパティ］ダイアログの表示方法については，「13.1　［アイテムのプロパティ］ダイアログの表示」を参照してください。

    売上アイテム2のフォントスタイルを太字にする例を次に示します。

    図8‒7　コピーした売上アイテムのフォントスタイルを太字にする例

    [図データ]

なお，一つのアイテムに対して，プロパティは一つだけ定義できます。そのため，条件によって表示を変えるときは，アイテムをコピーしてそれぞれに異なるプロパティを設定します。

ページの先頭へ

(2)　表示条件を設定する

目標値以上の項目だけ表示するなど，アイテムに表示条件を設定します。

  1. ［アイテムの表示条件］ダイアログを表示する

    アイテムを選択して［アイテムの表示条件］ダイアログを表示します。［アイテムの表示条件］ダイアログを表示するには，［編集］－［アイテムの表示条件］を選択します。［アイテムの表示条件］ダイアログの詳細については，マニュアル「EUR 帳票作成 画面リファレンス」を参照してください。

  2. アイテムの表示条件を有効にする

    ［アイテムの表示条件を有効にする］チェックボックスを「オン」にします。［条件］グループボックスと［表示方法］グループボックスが活性となり，アイテムの表示条件を設定できるようになります。

  3. アイテムの表示条件式を指定する

    ［参照フィールド］リストボックスに，どのフィールド名を基に表示条件を設定するかを指定します。［演算子］リストボックスに，表示条件の演算子を指定します。［指定値］テキストボックスに，参照フィールドの値と演算子で表示条件を判定する対象の値を指定します。

    今月売上と先月売上を比較する場合など，判定の対象にフィールド全体を指定したい場合は，［フィールドを参照する］チェックボックスを「オン」にします。［フィールドを参照する］リストボックスが活性となるので，対象のフィールド名を指定します。

    二つ目の表示条件を設定する場合は，［範囲指定］チェックボックスを「オン」にして，二つ目の演算子と指定値を指定します。

  4. アイテムの表示・非表示を指定する

    表示条件に合うアイテムを表示するかどうかを指定します。［表示する］ラジオボタンを選択すると，参照フィールドのうち表示条件に合う項目が表示され，表示条件に合わない項目は表示されません。［表示しない］ラジオボタンを選択すると，参照フィールドのうち表示条件に合う項目は表示されないで，表示条件に合わない項目が表示されます。

  5. ［OK］ボタンをクリックする

    アイテムに含まれる項目のうち，表示条件に合う項目だけが表示されます。

  6. ほかのアイテムの表示条件を設定する

    表示条件を設定するアイテムがほかにある場合は，1.～5.の操作を実行して条件付きアイテムを作成します。

ページの先頭へ

(3)　条件付きアイテムを配置する

複数の条件付きアイテムを重ねて，数値がマイナスの項目だけ赤字にするなど，アイテムのプロパティが部分的に異なるように配置します。

  1. アイテムを重ねる

    表示条件を設定したアイテムを重ねます。アイテムを複数選択したあと，［編集］－［揃え］を選択して，アイテムの高さと幅を揃えます。

    一度アイテムを重ねると，個々のアイテムを選択しにくくなります。そのため，個々のアイテムのプロパティや表示条件を設定してからアイテムを重ねることをお勧めします。また，アイテムを重ねたあとにプロパティや表示条件を設定する可能性のあるアイテムは，重ねる前に「順序」メニューから「最前面に移動」を選択すると選択しやすくなります。

    図8‒8　条件付きアイテム「売上」を重ねる例

    [図データ]

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 185 / 356


8.2.4 条件付きアイテムを使用した帳票の設定例 : EUR 帳票作成 操作ガイド

  • 186 / 356

  • 表紙

  • 8.　貼り付けたデータを帳票上でカスタマイズする

  • 8.2　アイテムの表示条件を設定する

  • 8.2.4　条件付きアイテムを使用した帳票の設定例

8.2.4　条件付きアイテムを使用した帳票の設定例

ここでは，条件付きアイテムを使用した帳票の設定例を示します。

〈この項の構成〉

  • (1)　目標値以上の項目のフォントを変更した帳票

  • (2)　値がマイナスの項目のフォントを変更し，目標値以上の項目に画像を表示した帳票

  • (3)　ある日付より前の項目のフォントを変更した帳票

(1)　目標値以上の項目のフォントを変更した帳票

売上が10,000以上の場合に売上のフォントを太字で表示する帳票の設定例を示します。

まず，売上アイテムを一つコピーします。ここで，コピー元のアイテムを売上アイテム1，コピーしたアイテムを売上アイテム2とします。

売上アイテム1および売上アイテム2に設定するプロパティは次のとおりです。

  • 売上アイテム1

    フォント：標準

  • 売上アイテム2

    フォントスタイル：太字

売上アイテム1および売上アイテム2に設定する表示条件は次のとおりです。

  • 売上アイテム1

    ［アイテムの表示条件を有効にする］チェックボックス：「オン」

    ［参照フィールド］リストボックス：売上(マッピングデータ)

    ［演算子］リストボックス：≧

    ［指定値］テキストボックス：10000

    ［フィールドを参照する］チェックボックス：「オフ」

    ［範囲指定］チェックボックス：「オフ」

    ［表示しない］ラジオボタンを選択

  • 売上アイテム2

    ［アイテムの表示条件を有効にする］チェックボックス：「オン」

    ［参照フィールド］リストボックス：売上(マッピングデータ)

    ［演算子］リストボックス：≧

    ［指定値］テキストボックス：10000

    ［フィールドを参照する］チェックボックス：「オフ」

    ［範囲指定］チェックボックス：「オフ」

    ［表示する］ラジオボタンを選択

ページの先頭へ

(2)　値がマイナスの項目のフォントを変更し，目標値以上の項目に画像を表示した帳票

売上差額がマイナスの場合に売上差額のフォント色を赤で表示し，売上差額が300,000以上の場合には成績に「達成」の画像を表示する帳票の設定例を示します。

まず，売上差額アイテムを一つコピーします。ここで，コピー元のアイテムを売上差額アイテム1，コピーしたアイテムを売上差額アイテム2とします。

売上差額アイテム1，売上差額アイテム2，および成績アイテムに設定するプロパティは次のとおりです。

  • 売上差額アイテム1

    フォント：標準

  • 売上差額アイテム2

    フォント色：赤

  • 成績アイテム

    （設定しません）

売上差額アイテム1，売上差額アイテム2，および成績アイテムに設定する表示条件は次のとおりです。

  • 売上差額アイテム1

    ［アイテムの表示条件を有効にする］チェックボックス：「オン」

    ［参照フィールド］リストボックス：今回売上(マッピングデータ)

    ［演算子］リストボックス：＜

    ［指定値］テキストボックス：なし

    ［フィールドを参照する］チェックボックス：「オン」

    ［フィールドを参照する］リストボックス：前回売上(マッピングデータ)

    ［範囲指定］チェックボックス：「オフ」

    ［表示しない］ラジオボタンを選択

  • 売上差額アイテム2

    ［アイテムの表示条件を有効にする］チェックボックス：「オン」

    ［参照フィールド］リストボックス：今回売上(マッピングデータ)

    ［演算子］リストボックス：＜

    ［指定値］テキストボックス：なし

    ［フィールドを参照する］チェックボックス：「オン」

    ［フィールドを参照する］リストボックス：前回売上(マッピングデータ)

    ［範囲指定］チェックボックス：「オフ」

    ［表示する］ラジオボタンを選択

  • 成績アイテム

    ［アイテムの表示条件を有効にする］チェックボックス：「オン」

    ［参照フィールド］リストボックス：売上差額(マッピングデータ)

    ［演算子］リストボックス：≧

    ［指定値］テキストボックス：300000

    ［フィールドを参照する］チェックボックス：「オフ」

    ［範囲指定］チェックボックス：「オフ」

    ［表示する］ラジオボタンを選択

ページの先頭へ

(3)　ある日付より前の項目のフォントを変更した帳票

資格・免許の取得年月が2000年1月より前の場合に，資格名を赤字で表示する帳票の設定例を示します。

まず，資格名アイテムを一つコピーします。ここで，コピー元のアイテムを資格名アイテム1，コピーしたアイテムを資格名アイテム2とします。

資格名アイテム1および資格名アイテム2に設定するプロパティは次のとおりです。

  • 資格名アイテム1

    フォント：標準

  • 資格名アイテム2

    フォント色：赤

資格名アイテム1および資格名アイテム2に設定する表示条件は次のとおりです。

  • 資格名アイテム1

    ［アイテムの表示条件を有効にする］チェックボックス：「オン」

    ［参照フィールド］リストボックス：資格・免許＿取得日(マッピングデータ)

    ［演算子］リストボックス：＜

    ［指定値］テキストボックス：200001

    ［フィールドを参照する］チェックボックス：「オフ」

    ［範囲指定］チェックボックス：「オフ」

    ［表示しない］ラジオボタンを選択

  • 資格名アイテム2

    ［アイテムの表示条件を有効にする］チェックボックス：「オン」

    ［参照フィールド］リストボックス：資格・免許＿取得日(マッピングデータ)

    ［演算子］リストボックス：＜

    ［指定値］テキストボックス：200001

    ［フィールドを参照する］チェックボックス：「オフ」

    ［範囲指定］チェックボックス：「オフ」

    ［表示する］ラジオボタンを選択

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 186 / 356


8.2.5 帳票定義情報ファイルで表示条件を指定する場合の注意事項 : EUR 帳票作成 操作ガイド

  • 187 / 356

  • 表紙

  • 8.　貼り付けたデータを帳票上でカスタマイズする

  • 8.2　アイテムの表示条件を設定する

  • 8.2.5　帳票定義情報ファイルで表示条件を指定する場合の注意事項

8.2.5　帳票定義情報ファイルで表示条件を指定する場合の注意事項

帳票定義情報ファイルで表示条件を指定する場合は，指定した表示条件が成立しているか確認してください。次のときには，表示条件が成立しないと見なされます。

  • 参照フィールドを指定していないとき

  • 演算子を指定していないとき

  • 演算子を指定して指定値を指定していないとき

  • 演算子の型が参照フィールドの型と一致していないとき

  • 指定値の型が参照フィールドの型と一致していないとき

  • 指定値として参照したフィールドの種別が［参照フィールド］リストボックスで指定したフィールドの種別と異なるとき※

  • 指定値として参照したフィールドの値の形式が［参照フィールド］リストボックスで指定したフィールドの値の形式と異なるとき

注※

数値（集計対象），数値（集計対象外），および集計値は，まとめて一つの種別として扱われるため，異なるフィールドとは見なされません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 187 / 356


8.3 特定の行のデータを編集する : EUR 帳票作成 操作ガイド

  • 188 / 356

  • 表紙

  • 8.　貼り付けたデータを帳票上でカスタマイズする

  • 8.3　特定の行のデータを編集する

8.3　特定の行のデータを編集する

EURでは，繰り返されたデータの特定の行を編集したい場合に特殊編集レベルを設定します。

ここでは，特殊編集レベルを設定すると有効な帳票，および特殊編集レベルの設定手順について説明します。

〈この節の構成〉

  • 8.3.1　特殊編集レベルとは

  • 8.3.2　特殊編集レベルの設定手順

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 188 / 356


8.3.1 特殊編集レベルとは : EUR 帳票作成 操作ガイド

  • 189 / 356

  • 表紙

  • 8.　貼り付けたデータを帳票上でカスタマイズする

  • 8.3　特定の行のデータを編集する

  • 8.3.1　特殊編集レベルとは

8.3.1　特殊編集レベルとは

特殊編集レベルとは，繰り返されたデータの特定の行を集計行と同じように編集したい場合に付ける分類用のレベルです。

通常の繰り返し設定では，実アイテムの設定内容が繰り返されたすべてのデータに適用されます。特殊編集レベルを設定すると，同じレベルを設定したデータごとに文字装飾などの設定が適用されます。

特殊編集レベルは，次のようなデータが含まれる帳票を作成する場合に設定すると便利です。

  • 読み込んだデータに集計データが含まれる場合

  • データ内に帳票のタイトルや注意事項などの長文が含まれる場合

  • 特定の行の位置をずらすなど，行ごとのレイアウト全体を変えたい場合

特殊編集レベルを設定した帳票の例を，次に示します。

図8‒9　特殊編集レベルを設定した帳票の例

[図データ]

メモ

数値がマイナスの項目だけ赤字にするなど，条件を満たす特定の列だけを編集したい場合は，条件付きアイテムを作成します。条件付きアイテムについては「8.2　アイテムの表示条件を設定する」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 189 / 356


8.3.2 特殊編集レベルの設定手順 : EUR 帳票作成 操作ガイド

  • 190 / 356

  • 表紙

  • 8.　貼り付けたデータを帳票上でカスタマイズする

  • 8.3　特定の行のデータを編集する

  • 8.3.2　特殊編集レベルの設定手順

8.3.2　特殊編集レベルの設定手順

ここでは，特殊編集レベルの設定手順を説明します。

〈この項の構成〉

  • (1)　データファイルの準備

  • (2)　フィールド定義の変更

  • (3)　特殊編集レベルを設定したデータの編集

(1)　データファイルの準備

特殊編集レベルを設定する場合は，準備するデータファイルに特殊編集レベルを記述した列を追加しておいてください。

項目のまとまりごとに，同じレベルを設定していきます。特殊編集レベルには，1～99の整数を指定できます。なお，特殊編集レベルを設定しない場合は，省略するか，または「0」もしくは空白を指定してください。

ページの先頭へ

(2)　フィールド定義の変更

データをEUR 帳票作成機能で読み込んで，特殊編集レベルを定義します。

  1. マッピングデータウィンドウにデータを読み込む

    データの読み込み方法については，「3.2.1　CSV形式およびDAT形式のデータの読み込み」を参照してください。

    データを読み込むと，マッピングデータウィンドウには次のように表示されます。

  2. フィールド定義を変更する

    フィールドの種別を「特殊編集レベル」に変更します。フィールドの種別を変更する方法については，「3.3.2　フィールド定義の変更手順」を参照してください。

    フィールドの種別を変更すると，マッピングデータウィンドウには次のように「（レベル：nn）」と表示されます。

ページの先頭へ

(3)　特殊編集レベルを設定したデータの編集

特殊編集レベルを設定したデータを貼り付け，集計行編集モードで次のように編集します。

  1. データを貼り付ける

    マッピングデータウィンドウから1行目のデータを貼り付けます。データが空欄になっている項目は，アイテムの赤い枠だけが表示されます。

  2. 貼り付けたデータを繰り返す

    繰り返したいデータを選択して，繰り返し定義を設定します。

    1行目のデータが空欄になっている項目も，繰り返しによって，2行目以降のデータが表示されます。

  3. 集計行編集モードに切り替える

    特殊編集レベルを設定した行は，集計行編集モードで編集できます。［集計］－［集計行の編集］を選択すると，特殊編集レベルを設定した行が反転表示されます。

  4. 編集したいレベルのアイテムを選択する

    編集したいレベルのアイテムを選択して，編集します。例えば，ベル1の行を選択すると，集計行編集モードのバーに「レベル：1」と表示され，レベル1の行だけが編集できるようになります。

  5. アイテムを編集する

    選択したレベルのアイテムを編集します。設定したレベルごとにアイテムを編集できます。

    それぞれのレベルの編集が終了したら，集計行編集モードのバーの［終了］ボタンをクリックして，集計行編集モードを終了します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 190 / 356


9. 複数様式の帳票の出力定義をツールで作成する : EUR 帳票作成 操作ガイド

  • 191 / 356

  • 表紙

  • 9.　複数様式の帳票の出力定義をツールで作成する

9.　複数様式の帳票の出力定義をツールで作成する

この章では，複数様式の帳票の出力定義をツールで作成する方法と，出力定義を作成できる複数様式の帳票のパターンについて説明します。

〈この章の構成〉

  • 9.1　複数様式定義作成ツールとは

  • 9.2　作成できる複数様式の帳票のパターン

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 191 / 356


9.1 複数様式定義作成ツールとは : EUR 帳票作成 操作ガイド

  • 192 / 356

  • 表紙

  • 9.　複数様式の帳票の出力定義をツールで作成する

  • 9.1　複数様式定義作成ツールとは

9.1　複数様式定義作成ツールとは

複数様式定義作成ツールは，複数様式の帳票を出力する際に必要な設定内容をGUI上で定義して，複数様式情報定義ファイルに保存できるツールです。このツールは，EUR Developerをインストールしたときだけ使用できます。

複数様式定義作成ツールで作成した複数様式情報定義ファイルは，帳票を出力するときの入力ファイルになります。

なお，ここでは複数様式定義作成ツールの操作手順，および，作成できる帳票のパターンについて説明します。複数様式での帳票出力の機能詳細については，マニュアル「EUR 帳票出力 機能解説 EUR Server編」を，複数様式情報定義ファイルの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

〈この節の構成〉

  • 9.1.1　複数様式定義作成ツールで定義できる内容

  • 9.1.2　複数様式定義作成ツールを使用する前の準備

  • 9.1.3　複数様式定義作成ツールの操作の流れ

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 192 / 356


9.1.1 複数様式定義作成ツールで定義できる内容 : EUR 帳票作成 操作ガイド

  • 193 / 356

  • 表紙

  • 9.　複数様式の帳票の出力定義をツールで作成する

  • 9.1　複数様式定義作成ツールとは

  • 9.1.1　複数様式定義作成ツールで定義できる内容

9.1.1　複数様式定義作成ツールで定義できる内容

複数様式定義作成ツールでは，複数様式情報定義ファイルのキーワードのうち，次の表に示す内容を定義できます。

表9‒1 複数様式情報定義ファイルのキーワードと，複数様式定義作成ツールで定義できる内容との対応
複数様式情報定義ファイルのキーワード | ツールでの定義
group 様式グループ番号 | ○
grouptransfercondition | ○
transfercondition={KBNF|EOFN} | ○
fieldname="フィールド名" | ○
formtransfercondition | ×
keybreaktopform={ON|OFF} | ×
fieldname="フィールド名" | ×
formfilename "帳票ファイル名" | ○
transfercondition={NPNF|KBNF|EOFN} | ○
printnewpaper={ON|OFF} | ○
resetpagenumber={ON|OFF} | ○
traycode=給紙トレイ番号 | ×
subgroup サブ様式グループ番号 | ○
grouptransfercondition | ○
transfercondition=KBNF | ○
fieldname="フィールド名" | ○
formtransfercondition | ×
keybreaktopform={ON|OFF} | ×
fieldname="フィールド名" | ×
formfilename "帳票ファイル名" | ○
transfercondition={NPNF|KBNF} | ○※
printnewpaper={ON|OFF} | ○
resetpagenumber={ON|OFF} | ○
traycode=給紙トレイ番号 | ×
（凡例）

○：複数様式定義作成ツールで定義できます。

×：複数様式定義作成ツールで定義できません。

注※

KBNFだけ指定できます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 193 / 356


9.1.2 複数様式定義作成ツールを使用する前の準備 : EUR 帳票作成 操作ガイド

  • 194 / 356

  • 表紙

  • 9.　複数様式の帳票の出力定義をツールで作成する

  • 9.1　複数様式定義作成ツールとは

  • 9.1.2　複数様式定義作成ツールを使用する前の準備

9.1.2　複数様式定義作成ツールを使用する前の準備

ツールから帳票をプレビュー表示する場合，マッピングデータファイル，帳票ファイル，およびユーザ定義データファイル（ユーザ定義データを使用する場合）を準備してください。

ファイルの格納先については次の注意事項があります。

  • EUR Server Serviceの環境設定ファイル（EURPM.ini）のPATHMODEキーで「0（通常パスモード）」を設定している場合，帳票ファイルは，環境設定ファイル（EURPM.ini）のFORMキーで設定しているフォルダに格納してください。

    なお，複数様式定義作成ツールは，次のディレクトリにある環境設定ファイル（EURPM.ini）を読み込みます。

    インストール先ディレクトリ\Server

  • マッピングデータファイル，帳票ファイル，およびユーザ定義データファイルは，ファイルの種類ごとに同じフォルダに格納してください。例えばマッピングデータファイルAとマッピングデータファイルBを別のフォルダに格納していると，帳票を出力したときにエラーになります。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 194 / 356


9.1.3 複数様式定義作成ツールの操作の流れ : EUR 帳票作成 操作ガイド

  • 195 / 356

  • 表紙

  • 9.　複数様式の帳票の出力定義をツールで作成する

  • 9.1　複数様式定義作成ツールとは

  • 9.1.3　複数様式定義作成ツールの操作の流れ

9.1.3　複数様式定義作成ツールの操作の流れ

複数様式定義作成ツールは，EUR製品のプログラムメニューから，［ツール］－［複数様式定義の作成］を選択すると起動します。

図9‒1　［複数様式定義の作成ツールへようこそ］画面

[図データ]

［複数様式定義の作成ツールへようこそ］画面では，このツールで必要な設定の手順がStep1.～Step7.まで記載されています。［次へ］をクリックするとステップが進み，各ステップでの設定内容の詳細が表示されます。画面の説明に従って設定してください。

各ステップでの設定内容を次に示します。

〈この項の構成〉

  • (1)　Step1. 複数様式パターンの選択

  • (2)　Step2. 様式数の設定

  • (3)　Step3. ファイルの設定

  • (4)　Step4. 様式を切り替えるキーの設定

  • (5)　Step5. ページ番号の設定

  • (6)　Step6. 両面印刷時の設定

  • (7)　Step7. 複数様式定義の保存

(1)　Step1. 複数様式パターンの選択

出力する複数様式の帳票のパターンをラジオボタンで選択します。ラジオボタンを選択すると，次の内容が画面に表示されます。

  • パターンの解説

  • マッピングデータファイル作成時の留意点

  • このパターンで作成できる帳票例

  • サンプル帳票について

［サンプル帳票］ボタンをクリックすると，各パターンの帳票の出力例，およびマッピングデータのどの部分で様式を切り替えているかを示す説明文が表示されます。

各パターンの出力イメージは「9.2　作成できる複数様式の帳票のパターン」を参照してください。

ページの先頭へ

(2)　Step2. 様式数の設定

出力する複数様式の帳票の様式数を選択します。Step1.で選択した複数様式パターンによって，表示される内容が変わります。

Step1.で「キー付き入れ子単純繰り返し」以外を選択した場合

［様式数］リストボックスが表示されます。指定できる様式数の範囲は次のとおりです。

複数様式パターン

指定できる様式数の範囲

初期値

単純繰り返し

2～40

2

単純繰り返し（マッピングデータが一つ）

2～40

2

キー付き単純繰り返し

2～40

2

キー付き単純繰り返し（次紙様式付きA）

3～40

3

キー付き単純繰り返し（次紙様式付きB）

4～40の偶数値

4

カーボンコピー／複写帳票

2～40

2

カーボンコピー／複写帳票（次紙様式付き）

4～40の偶数値

4

順次帳票

2～40

2

順次帳票（次紙様式付きA）

3～40

3

順次帳票（次紙様式付きB）

4～40の偶数値

4
Step1.で「キー付き入れ子単純繰り返し」を選択した場合

［様式数］グループボックス内に，［先頭の様式数］リストボックス，［入れ子の様式数］リストボックス，［後続の様式数］リストボックスが表示されます。三つのリストボックスに指定した数の合計が40以下になるように指定してください。

各リストボックスに指定できる様式数の範囲は次のとおりです。

リストボックス名

指定できる様式数の範囲

初期値

先頭の様式数

1～39

1

入れ子の様式数

1～39

2

後続の様式数

0～38

1

ページの先頭へ

(3)　Step3. ファイルの設定

それぞれの様式に使用するマッピングデータファイル，帳票ファイル，およびユーザ定義データファイルのファイル名を指定します。

ページの先頭へ

(4)　Step4. 様式を切り替えるキーの設定

キーブレイクの対象となるフィールド名（複数様式情報定義ファイルのキーワードfieldname）を指定します。

次に示すマッピングデータファイルが指定されている場合だけ，［キー］リストボックスまたは［サブキー］リストボックス（Step1.で「キー付き入れ子単純繰り返し」を選択したときだけ）にStep3.で設定したマッピングデータファイルのフィールド名が読み込まれて表示されます。

  • コンマで区切られているCSV形式のファイル

  • 1行目にフィールド名が設定されているファイル

なお，Step1.で次の複数様式パターンを選択したときだけ，Step4.の画面が表示されます。

  • キー付き単純繰り返し

  • キー付き単純繰り返し（次紙様式付きA）

  • キー付き単純繰り返し（次紙様式付きB）

  • キー付き入れ子単純繰り返し

  • カーボンコピー／複写帳票

  • カーボンコピー／複写帳票（次紙様式付き）

ページの先頭へ

(5)　Step5. ページ番号の設定

ページ番号アイテムを配置した帳票を使う場合に，ページ番号の振り方を指定します。選択したラジオボタンごとのページ番号の振り方は次のとおりです。

選択したラジオボタン | ページ番号の振り方
すべての様式に通し番号を振る | ページ番号はすべて通し番号になります。
先頭の様式のみ初期化 | 最初の様式に戻るたびにページ番号が初期化され，1から振り直します。
様式ごとに初期化 | 様式が切り替わるたびにページ番号が初期化され，1から振り直します。

また，Step1.で「キー付き入れ子単純繰り返し」を選択していて，［様式ごとに初期化］ラジオボタンを選択した場合は，さらに［入れ子の様式のページ番号］グループボックスが表示されます。

選択したラジオボタンごとのページ番号の振り方は次のとおりです。

選択したラジオボタン | ページ番号の振り方
様式ごとに初期化 | サブ様式が切り替わるたびにページ番号が初期化され，1から振り直します。
先頭の様式のみ初期化 | サブ様式の中で最初の様式に切り替わるたびにページ番号が初期化され，1から振り直します。
直前の様式からの続きの番号を振る | 直前の様式からページ番号が続きます。サブ様式を遷移している間は，そのまま通し番号が振られます。

ページの先頭へ

(6)　Step6. 両面印刷時の設定

両面印刷時に必ず表面から印刷したい様式がある場合に，設定します。

ページの先頭へ

(7)　Step7. 複数様式定義の保存

［保存］ボタンを押して，Step1.～Step6.までで設定した内容を，複数様式情報定義ファイル（*.mfd）に保存します。EUR Server Serviceの環境設定ファイル（EURPM.ini）のPATHMODEキーで「0（通常パスモード）」を設定している場合は，EURPM.iniのMULTIキーのフォルダを指定してください。

なお，複数様式定義作成ツールは，次のディレクトリにある環境設定ファイル（EURPM.ini）を読み込みます。

インストール先ディレクトリ\Server

複数様式情報定義ファイル（*.mfd）を保存した際，複数様式の帳票の出力テストを行うためのバッチファイルも出力されます。

重要

バッチファイルを正常に出力するために，次の点に注意してください。

  • 次のフォルダのパスに，ロケールでサポートしない文字が含まれる場合，短い名前が作成されている必要があります。

    ・インストール先フォルダ

    ・マッピングデータファイルの格納先フォルダ

    ・帳票ファイルの格納先フォルダ

    ・ユーザ定義データファイルの格納先フォルダ

    ・複数様式情報定義ファイルの保存先フォルダ

  • 複数様式情報定義ファイル名にはロケールでサポートしない文字を指定しないでください。

［プレビュー］ボタンをクリックすると，eurpmcコマンドでEPF形式の帳票が生成されて，eurpmcepfviewerコマンドでプレビュー表示されます。

重要

マッピングデータファイル，帳票ファイル，およびユーザ定義データファイル（ユーザ定義データを使用する場合）があるときだけプレビュー表示できます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 195 / 356


9.2 作成できる複数様式の帳票のパターン : EUR 帳票作成 操作ガイド

  • 196 / 356

  • 表紙

  • 9.　複数様式の帳票の出力定義をツールで作成する

  • 9.2　作成できる複数様式の帳票のパターン

9.2　作成できる複数様式の帳票のパターン

［Step1. 複数様式パターンの選択］画面で選択できるそれぞれの帳票パターンの出力イメージについて説明します。

〈この節の構成〉

  • 9.2.1　単純繰り返し

  • 9.2.2　単純繰り返し（マッピングデータが一つ）

  • 9.2.3　キー付き単純繰り返し

  • 9.2.4　キー付き単純繰り返し（次紙様式付きA）

  • 9.2.5　キー付き単純繰り返し（次紙様式付きB）

  • 9.2.6　キー付き入れ子単純繰り返し

  • 9.2.7　カーボンコピー／複写帳票

  • 9.2.8　カーボンコピー／複写帳票（次紙様式付き）

  • 9.2.9　順次帳票

  • 9.2.10　順次帳票（次紙様式付きA）

  • 9.2.11　順次帳票（次紙様式付きB）

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 196 / 356


9.2.1 単純繰り返し : EUR 帳票作成 操作ガイド

  • 197 / 356

  • 表紙

  • 9.　複数様式の帳票の出力定義をツールで作成する

  • 9.2　作成できる複数様式の帳票のパターン

  • 9.2.1　単純繰り返し

9.2.1　単純繰り返し

1ページ分のデータを出力したら，次の様式に遷移するパターンです。1グループにつき1様式を使用し，それぞれの様式でマッピングデータも異なるものを使用します。

単純繰り返しの場合の帳票出力のイメージを次の図に示します。

図9‒2　複数様式の帳票の出力イメージ（単純繰り返し）

[図データ]

  1. 様式AにA.csvのデータを出力します。

  2. A.csvに収まる分のデータを出力し終わると様式Bに切り替わります。

  3. 様式BにB.csvのデータを出力します。

  4. B.csvに収まる分のデータを出力し終わると様式Aに戻ります。

  5. 様式AにA.csvの続きのデータを出力します。

  6. A.csvに収まる分のデータを出力し終わると様式Bに切り替わります。

  7. 様式BにB.csvの続きのデータを出力します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 197 / 356


9.2.2 単純繰り返し（マッピングデータが一つ） : EUR 帳票作成 操作ガイド

  • 198 / 356

  • 表紙

  • 9.　複数様式の帳票の出力定義をツールで作成する

  • 9.2　作成できる複数様式の帳票のパターン

  • 9.2.2　単純繰り返し（マッピングデータが一つ）

9.2.2　単純繰り返し（マッピングデータが一つ）

1ページ分のデータを出力したら，次の様式に遷移するパターンです。1グループにつき1様式を使用し，それぞれの様式でマッピングデータファイルは同じものを使用します。

単純繰り返しでマッピングデータファイルが一つの場合の帳票出力のイメージを次の図に示します。

図9‒3　複数様式の帳票の出力イメージ（単純繰り返し（マッピングデータが一つ））

[図データ]

  1. 様式AにA.csvのデータを出力します。

  2. 様式Aに収まる分のデータを出力し終わると様式Bに切り替わります。

  3. 様式BにA.csvの続きのデータを出力します。

  4. 様式Bに収まる分のデータを出力し終わると様式Aに切り替わります。

  5. 様式AにA.csvの続きのデータを出力します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 198 / 356


9.2.3 キー付き単純繰り返し : EUR 帳票作成 操作ガイド

  • 199 / 356

  • 表紙

  • 9.　複数様式の帳票の出力定義をツールで作成する

  • 9.2　作成できる複数様式の帳票のパターン

  • 9.2.3　キー付き単純繰り返し

9.2.3　キー付き単純繰り返し

特定のフィールドをキーとして，様式を切り替えるパターンです。1グループにつき1様式を使用し，それぞれの様式でマッピングデータも異なるものを使用します。

キー付き単純繰り返しの場合の帳票出力のイメージを次の図に示します。この図では，フィールド名「支店コード」がキーになっています。

図9‒4　複数様式の帳票の出力イメージ（キー付き単純繰り返し）

[図データ]

  1. 様式AにA.csvの支店コードが01のデータを出力します。

  2. A.csvの支店コードが01のデータを出力し終わると様式Bに切り替わります。

  3. 様式BにB.csvの支店コードが01のデータを出力します。

  4. B.csvの支店コードが01のデータを出力し終わると様式Aに切り替わります。

  5. 様式AにA.csvの支店コードが02のデータを出力します。

  6. B.csvには支店コードが02のデータがないため，様式Aに戻ります。

  7. 様式AにA.csvの支店コードが03のデータを出力します。

  8. A.csvの支店コードが03のデータを出力し終わると様式Bに切り替わります。

  9. 様式BにB.csvの支店コードが03のデータを出力します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 199 / 356


9.2.4 キー付き単純繰り返し（次紙様式付きA） : EUR 帳票作成 操作ガイド

  • 200 / 356

  • 表紙

  • 9.　複数様式の帳票の出力定義をツールで作成する

  • 9.2　作成できる複数様式の帳票のパターン

  • 9.2.4　キー付き単純繰り返し（次紙様式付きA）

9.2.4　キー付き単純繰り返し（次紙様式付きA）

特定のフィールドをキーとして，様式を切り替えるパターンです。「9.2.3　キー付き単純繰り返し」とは異なり，様式Aに表紙を付けて表紙次紙形式にしています。1グループにつき1様式を使用し，それぞれの様式でマッピングデータも異なるものを使用します。

キー付き単純繰り返し（次紙様式付きA）の場合の帳票出力のイメージを次の図に示します。この図では，フィールド名「支店コード」がキーになっています。

図9‒5　複数様式の帳票の出力イメージ（キー付き単純繰り返し（次紙様式付きA））

[図データ]

  1. 様式A（表紙）にA.csvの支店コードが01のデータを出力します。

  2. 様式A（表紙）に収まる分のデータを出力し終わると様式A（次紙）に切り替わります。

  3. 様式A（次紙）にA.csvの支店コードが01の続きのデータを出力します。

  4. A.csvの支店コードが01のデータを出力し終わると様式Bに切り替わります。

  5. 様式BにB.csvの支店コードが01のデータを出力します。

  6. B.csvの支店コードが01のデータを出力し終わると様式A（表紙）に切り替わります。

  7. 様式A（表紙）にA.csvの支店コードが02のデータを出力します。

  8. A.csvの支店コードが02のデータはすべて様式A（表紙）に収まり，またB.csvには支店コードが02のデータがないため，様式A（表紙）に戻ります。

  9. 様式A（表紙）にA.csvの支店コードが03のデータを出力します。

  10. A.csvの支店コードが03のデータはすべて様式A（表紙）に収まったため，様式Bに切り替わります。

  11. 様式BにB.csvの支店コードが03のデータを出力します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 200 / 356


9.2.5 キー付き単純繰り返し（次紙様式付きB） : EUR 帳票作成 操作ガイド

  • 201 / 356

  • 表紙

  • 9.　複数様式の帳票の出力定義をツールで作成する

  • 9.2　作成できる複数様式の帳票のパターン

  • 9.2.5　キー付き単純繰り返し（次紙様式付きB）

9.2.5　キー付き単純繰り返し（次紙様式付きB）

特定のフィールドをキーとして，様式を切り替えるパターンです。「9.2.4　キー付き単純繰り返し（次紙様式付きA）」とは異なり，様式Bにも表紙を付けて表紙次紙形式にしています。1グループにつき1様式を使用し，それぞれの様式でマッピングデータも異なるものを使用します。

キー付き単純繰り返し（次紙様式付きB）の場合の帳票出力のイメージを次の図に示します。この図では，フィールド名「支店コード」がキーになっています。

図9‒6　複数様式の帳票の出力イメージ（キー付き単純繰り返し（次紙様式付きB））

[図データ]

  1. 様式A（表紙）にA.csvの支店コードが01のデータを出力します。

  2. 様式A（表紙）に収まる分のデータを出力し終わると様式A（次紙）に切り替わります。

  3. 様式A（次紙）にA.csvの支店コードが01の続きのデータを出力します。

  4. A.csvの支店コードが01のデータを出力し終わると様式B（表紙）に切り替わります。

  5. 様式B（表紙）にB.csvの支店コードが01のデータを出力します。

  6. 様式B（表紙）に収まる分のデータを出力し終わると様式B（次紙）に切り替わります。

  7. 様式B（次紙）にB.csvの支店コードが01の続きのデータを出力します。

  8. B.csvの支店コードが01のデータを出力し終わると様式A（表紙）に切り替わります。

  9. 様式A（表紙）にA.csvの支店コードが02のデータを出力します。

  10. A.csvの支店コードが02のデータはすべて様式A（表紙）に収まり，またB.csvには支店コードが02のデータがないため，様式A（表紙）に戻ります。

  11. 様式A（表紙）にA.csvの支店コードが03のデータを出力します。

  12. A.csvの支店コードが03のデータはすべて様式A（表紙）に収まったため，様式B（表紙）に切り替わります。

  13. 様式B（表紙）にB.csvの支店コードが03のデータを出力します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 201 / 356


9.2.6 キー付き入れ子単純繰り返し : EUR 帳票作成 操作ガイド

  • 202 / 356

  • 表紙

  • 9.　複数様式の帳票の出力定義をツールで作成する

  • 9.2　作成できる複数様式の帳票のパターン

  • 9.2.6　キー付き入れ子単純繰り返し

9.2.6　キー付き入れ子単純繰り返し

サブ様式グループを定義するパターンです。それぞれの様式でマッピングデータも異なるものを使用します。

キー付き入れ子単純繰り返しの場合の帳票出力のイメージを次の図に示します。この図では，フィールド名「コード」が様式グループを切り替えるキー，「名前」がサブ様式グループを切り替えるキーになっています。

図9‒7　複数様式の帳票の出力イメージ（キー付き入れ子単純繰り返し）

[図データ]

  1. 様式AにA.csvのコードが01のデータを出力します。

  2. A.csvのコードが01のデータを出力し終わるとサブ様式Aに切り替わります。

  3. サブ様式AにB.csvの名前が日立太郎のデータを出力します。

  4. B.csvの名前が日立太郎のデータを出力し終わるとサブ様式Bに切り替わります。

  5. サブ様式BにC.csvの名前が日立太郎のデータを出力します。

  6. C.csvの名前が日立太郎のデータを出力し終わるとサブ様式Aに切り替わります。

  7. サブ様式AにB.csvの名前が日立花子のデータを出力します。

  8. B.csvの名前が日立花子のデータを出力し終わるとサブ様式Bに切り替わります。

  9. サブ様式BにC.csvの名前が日立花子のデータを出力します。

  10. C.csvの名前が日立花子のデータを出力し終わると様式Bに切り替わります。

  11. 様式BにD.csvのコードが01のデータを出力します。

  12. D.csvのコードが01のデータを出力し終わると様式Aに切り替わります。

  13. 様式AにA.csvのコードが02のデータを出力します。以降，2.～11.までの動作を繰り返します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 202 / 356


9.2.7 カーボンコピー／複写帳票 : EUR 帳票作成 操作ガイド

  • 203 / 356

  • 表紙

  • 9.　複数様式の帳票の出力定義をツールで作成する

  • 9.2　作成できる複数様式の帳票のパターン

  • 9.2.7　カーボンコピー／複写帳票

9.2.7　カーボンコピー／複写帳票

特定のフィールドをキーとして様式を切り替えますが，キーフィールド内のデータが同じ値のレコードの範囲を，様式を変えて何度も出力するパターンです。様式ごとに異なるマッピングデータを使用する場合は，「9.2.3　キー付き単純繰り返し」を選択してください。

カーボンコピー／複写帳票の場合の帳票出力のイメージを次の図に示します。この図では，フィールド名「お客様コード」がキーになっています。

図9‒8　複数様式の帳票の出力イメージ（カーボンコピー／複写帳票）

[図データ]

  1. 様式AにA.csvのお客様コードが01のデータを出力します。

  2. A.csvのお客様コードが01のデータを出力し終わると様式Bに切り替わります。

  3. 様式BにA.csvのお客様コードが01のデータを出力します。

  4. A.csvのお客様コードが01のデータを出力し終わると様式Aに戻ります。

  5. 様式AにA.csvのお客様コードが02のデータを出力します。

  6. A.csvのお客様コードが02のデータを出力し終わると様式Bに切り替わります。

  7. 様式BにA.csvのお客様コードが02のデータを出力します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 203 / 356


9.2.8 カーボンコピー／複写帳票（次紙様式付き） : EUR 帳票作成 操作ガイド

  • 204 / 356

  • 表紙

  • 9.　複数様式の帳票の出力定義をツールで作成する

  • 9.2　作成できる複数様式の帳票のパターン

  • 9.2.8　カーボンコピー／複写帳票（次紙様式付き）

9.2.8　カーボンコピー／複写帳票（次紙様式付き）

特定のフィールドをキーとして様式を切り替えますが，キーフィールド内のデータが同じ値のレコードの範囲を，様式を変えて何度も出力するパターンです。「9.2.7　カーボンコピー／複写帳票」とは異なり，様式A，様式Bにそれぞれ表紙を付けて表紙次紙形式にしています。

カーボンコピー／複写帳票（次紙様式付き）の場合の帳票出力のイメージを次の図に示します。この図では，フィールド名「お客様コード」がキーになっています。

図9‒9　複数様式の帳票の出力イメージ（カーボンコピー／複写帳票（次紙様式付き））

[図データ]

  1. 様式A（表紙）にA.csvのお客様コードが01のデータを出力します。

  2. 様式A（表紙）に収まる分のデータを出力し終わると様式A（次紙）に切り替わります。

  3. 様式A（次紙）にA.csvのお客様コードが01のデータの続きを出力します。

  4. A.csvのお客様コードが01のデータを出力し終わると様式B（表紙）に切り替わります。

  5. 様式B（表紙）にA.csvのお客様コードが01のデータを出力します。

  6. 様式B（表紙）に収まる分のデータを出力し終わると様式B（次紙）に切り替わります。

  7. 様式B（次紙）にA.csvのお客様コードが01のデータの続きを出力します。

  8. A.csvのお客様コードが01のデータを出力し終わると様式A（表紙）に戻ります。

  9. 様式A（表紙）にA.csvのお客様コードが02のデータを出力します。

  10. 様式A（表紙）に収まる分のデータを出力し終わると様式A（次紙）に切り替わります。

  11. 様式A（次紙）にA.csvのお客様コードが02のデータの続きを出力します。以降，4.～7.の動作を繰り返します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 204 / 356


9.2.9 順次帳票 : EUR 帳票作成 操作ガイド

  • 205 / 356

  • 表紙

  • 9.　複数様式の帳票の出力定義をツールで作成する

  • 9.2　作成できる複数様式の帳票のパターン

  • 9.2.9　順次帳票

9.2.9　順次帳票

特定のフィールドをキーとしないで，一つの様式にマッピングデータのすべてのデータを出力してから次の様式に切り替わるパターンです。

順次帳票の場合の帳票出力のイメージを次の図に示します。

図9‒10　複数様式の帳票の出力イメージ（順次帳票）

[図データ]

  1. 様式AにA.csvのデータをすべて出力します。

  2. A.csvのデータをすべて出力し終わったら，様式Bに切り替わります。

  3. 様式BにB.csvのデータをすべて出力します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 205 / 356


9.2.10 順次帳票（次紙様式付きA） : EUR 帳票作成 操作ガイド

  • 206 / 356

  • 表紙

  • 9.　複数様式の帳票の出力定義をツールで作成する

  • 9.2　作成できる複数様式の帳票のパターン

  • 9.2.10　順次帳票（次紙様式付きA）

9.2.10　順次帳票（次紙様式付きA）

特定のフィールドをキーとしないで，一つの様式にマッピングデータのすべてのデータを出力してから次の様式に切り替わるパターンです。「9.2.9　順次帳票」とは異なり，様式Aに表紙を付けて表紙次紙形式にしています。

順次帳票（次紙様式付きA）の場合の帳票出力のイメージを次の図に示します。

図9‒11　複数様式の帳票の出力イメージ（順次帳票（次紙様式付きA））

[図データ]

  1. 様式A（表紙）にA.csvのデータを出力します。

  2. 様式A（表紙）に収まる分のデータを出力し終わると様式A（次紙）に切り替わります。

  3. 様式A（次紙）にA.csvの残りのデータを出力します。

  4. A.csvのデータをすべて出力し終わったら，様式Bに切り替わります。

  5. 様式BにB.csvのデータをすべて出力します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 206 / 356


9.2.11 順次帳票（次紙様式付きB） : EUR 帳票作成 操作ガイド

  • 207 / 356

  • 表紙

  • 9.　複数様式の帳票の出力定義をツールで作成する

  • 9.2　作成できる複数様式の帳票のパターン

  • 9.2.11　順次帳票（次紙様式付きB）

9.2.11　順次帳票（次紙様式付きB）

特定のフィールドをキーとしないで，一つの様式にマッピングデータのすべてのデータを出力してから次の様式に切り替わるパターンです。「9.2.10　順次帳票（次紙様式付きA）」とは異なり，様式A，様式Bにそれぞれ表紙を付けて表紙次紙形式にしています。

順次帳票（次紙様式付きB）の場合の帳票出力のイメージを次の図に示します。

図9‒12　複数様式の帳票の出力イメージ（順次帳票（次紙様式付きB））

[図データ]

  1. 様式A（表紙）にA.csvのデータを出力します。

  2. 様式A（表紙）に収まる分のデータを出力し終わると様式A（次紙）に切り替わります。

  3. 様式A（次紙）にA.csvの残りのデータを出力します。

  4. A.csvのデータをすべて出力し終わったら，様式B（表紙）に切り替わります。

  5. 様式B（表紙）にB.csvのデータを出力します。

  6. 様式B（表紙）に収まる分のデータを出力し終わると様式B（次紙）に切り替わります。

  7. 様式B（次紙）にB.csvの残りのデータを出力します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 207 / 356


10. プレプリント用紙に合わせて帳票を作成する : EUR 帳票作成 操作ガイド

  • 208 / 356

  • 表紙

  • 10.　プレプリント用紙に合わせて帳票を作成する

10.　プレプリント用紙に合わせて帳票を作成する

この章では，プレプリント用紙に合わせて帳票を作成するための下敷きの使用方法について説明します。

〈この章の構成〉

  • 10.1　下敷きを作成する

  • 10.2　下敷きを読み込む

  • 10.3　下敷きの表示・非表示を設定する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 208 / 356


10.1 下敷きを作成する : EUR 帳票作成 操作ガイド

  • 209 / 356

  • 表紙

  • 10.　プレプリント用紙に合わせて帳票を作成する

  • 10.1　下敷きを作成する

10.1　下敷きを作成する

作成する帳票の下に手本（下敷き）を敷いて，それを目安にしながら帳票を定義できます。

下敷きは，既存の帳票やプレプリント用紙をスキャナで読み込んだ画像ファイルです。下敷きをEURに読み込んで，帳票ウィンドウに重ね合わせて使用します。

帳票を新規に作成する場合は，帳票ウィンドウの下に下敷き（この場合は，既存の帳票）を表示して，文字を配置したり，線を引いたりすることで，簡単に早く帳票を定義できます。

プレプリント用紙に印刷する場合は，帳票ウィンドウの下に下敷き（この場合は，プレプリント用紙）を表示して印刷する文字を配置すると，ずれることなく印刷できます。

〈この節の構成〉

  • 10.1.1　下敷きの準備

  • 10.1.2　下敷きを作成する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 209 / 356


10.1.1 下敷きの準備 : EUR 帳票作成 操作ガイド

  • 210 / 356

  • 表紙

  • 10.　プレプリント用紙に合わせて帳票を作成する

  • 10.1　下敷きを作成する

  • 10.1.1　下敷きの準備

10.1.1　下敷きの準備

下敷きを使用するには，あらかじめ手本となる画像ファイルを作成しておきます。

画像ファイルは，EURで使用できる画像ファイルの形式すべてを使用できます。EURで使用できる画像ファイルの形式については，マニュアル「EUR システム設計ガイド」を参照してください。

スキャニングは，TWAIN対応の画像処理ソフトウェアで行ってください。「紙の傾き」，「切り取り範囲・画像データの大きさ」，および「色の補正」は，スキャニングするドライバの設定と画像処理ソフトウェアで行ってから画像ファイルに出力してください。EURは，その出力された画像ファイルを下敷きとします。

画像処理ソフトウェアは，スキャナ付属の入力プログラム，Windows付属の描画プログラム（ペイント，イメージングなど），または有償のフォトレタッチソフトなどを使用してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 210 / 356


10.1.2 下敷きを作成する : EUR 帳票作成 操作ガイド

  • 211 / 356

  • 表紙

  • 10.　プレプリント用紙に合わせて帳票を作成する

  • 10.1　下敷きを作成する

  • 10.1.2　下敷きを作成する

10.1.2　下敷きを作成する

下敷きを作成する手順を次に示します。

  1. 帳票原稿に位置合わせの目印を記入する

    帳票原稿の端から，記入した位置合わせの目印の位置を控えます。

  2. TWAIN対応の画像処理ソフトウェアを起動する

    スキャナのスキャニング範囲に，すべての位置合わせの目印が入ります。極力帳票原稿が傾かないように帳票原稿をスキャナにセットしてください。このとき，スキャナドライバのプレビューを使用してセットすると便利です。

  3. スキャニングの対象範囲を指定する

    すべての位置合わせの目印が入るように，スキャニングの対象範囲を指定してください。スキャニングの帳票原稿は，画像データの縮尺を1：1にします。

    画像ファイルの用紙サイズは，EURで作成する帳票の用紙サイズと合わせて作成してください。

  4. スキャニングを実行する

  5. 画像データを編集する

    読み込んだ画像データの傾きを，位置合わせの目印に合わせて補正したあと，位置合わせの目印に沿って画像データを切り取ります。このとき，EURでの帳票定義に邪魔にならないように，画像データの色を別の色に変更してもかまいません。

  6. 画像データを保存する

    画像データをファイルに保存します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 211 / 356


10.2 下敷きを読み込む : EUR 帳票作成 操作ガイド

  • 212 / 356

  • 表紙

  • 10.　プレプリント用紙に合わせて帳票を作成する

  • 10.2　下敷きを読み込む

10.2　下敷きを読み込む

下敷きとする画像ファイルの作成が終わったら，使用する画像ファイルをEURに読み込みます。画像ファイルの作成については，「10.1　下敷きを作成する」を参照してください。

〈この節の構成〉

  • 10.2.1　下敷きを読み込む

  • 10.2.2　サイズ情報を持つ画像ファイルを読み込む

  • 10.2.3　サイズ情報を持たない画像ファイルを読み込む

  • 10.2.4　補足説明

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 212 / 356


10.2.1 下敷きを読み込む : EUR 帳票作成 操作ガイド

  • 213 / 356

  • 表紙

  • 10.　プレプリント用紙に合わせて帳票を作成する

  • 10.2　下敷きを読み込む

  • 10.2.1　下敷きを読み込む

10.2.1　下敷きを読み込む

下敷きの読み込みは，［下敷きの設定］ダイアログで設定します。［下敷きの設定］ダイアログの設定項目については，マニュアル「EUR 帳票作成 画面リファレンス」を参照してください。

  1. ［下敷きの設定］ダイアログを表示する

    ［ファイル］－［下敷きの設定］を選択します。

  2. 下敷きを選択する

    「ファイル名」に下敷きファイルを指定します。下敷きファイルは，ファイル名，相対パス，またはフルパスで指定します。［参照］ボタンをクリックし，ファイル名を指定することもできます。ファイル名だけを指定した場合は，［オプション］ダイアログの［ファイル］タブに表示されているファイルの場所から読み込まれます。

    EURで使用できる画像ファイルの形式については，マニュアル「EUR システム設計ガイド」を参照してください。

  3. 表示位置を指定する

    画像ファイルの作成手順で控えておいた，帳票原稿の端からの位置合わせの目印の位置を，用紙の左上隅からオフセットとして指定します。

    表示位置のデフォルトは，［用紙の左端から］，［用紙の上端から］の両方とも「0」です。

  4. 画像サイズを指定する

    画像ファイルのサイズ情報に従って，下敷きを表示するかどうかを指定します。デフォルトは，「オフ（サイズを指定しない）」です。

    画像サイズの指定を「オン（サイズを指定する）」にした場合は，下敷きに使用する画像ファイルのサイズ情報を指定できます。［幅］と［高さ］のテキストボックスに表示されている標準値は，EURの用紙サイズの幅と高さです。

    画像ファイルの形式によって，サイズ情報を持つものと持たないものがあります。

  5. ［OK］ボタンのクリック

    ［OK］ボタンをクリックします。帳票ウィンドウに戻り，設定が反映されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 213 / 356


10.2.2 サイズ情報を持つ画像ファイルを読み込む : EUR 帳票作成 操作ガイド

  • 214 / 356

  • 表紙

  • 10.　プレプリント用紙に合わせて帳票を作成する

  • 10.2　下敷きを読み込む

  • 10.2.2　サイズ情報を持つ画像ファイルを読み込む

10.2.2　サイズ情報を持つ画像ファイルを読み込む

指定した画像ファイルをスキャナで読み込んだ場合，または作成した場合に指定したサイズと同じサイズの画像を下敷きとして使用できます。

使用する画像ファイルの［幅］と［高さ］を指定して，下敷きの画像ファイルを表示する位置を［表示位置］で調整してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 214 / 356


10.2.3 サイズ情報を持たない画像ファイルを読み込む : EUR 帳票作成 操作ガイド

  • 215 / 356

  • 表紙

  • 10.　プレプリント用紙に合わせて帳票を作成する

  • 10.2　下敷きを読み込む

  • 10.2.3　サイズ情報を持たない画像ファイルを読み込む

10.2.3　サイズ情報を持たない画像ファイルを読み込む

［表示位置］の［用紙の左端から］と［用紙の上端から］に「0」を指定して，定義する帳票の用紙サイズと同じ値を［画像サイズ］の［幅］と［高さ］に指定すると，位置がずれることなく下敷きに使用できます。ただし，下敷きに使用する画像ファイルが，指定した用紙サイズや縦横比と異なる場合は，元の画像ファイルの表示と異なることがあります。

指定した画像ファイルがサイズ情報を持っていない場合は，［画像サイズ］を指定しないで［OK］ボタンをクリックすると，サイズの指定を要求するメッセージが表示されます。［サイズを指定する］のチェックボックスをオンにして，［幅］と［高さ］を指定してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 215 / 356


10.2.4 補足説明 : EUR 帳票作成 操作ガイド

  • 216 / 356

  • 表紙

  • 10.　プレプリント用紙に合わせて帳票を作成する

  • 10.2　下敷きを読み込む

  • 10.2.4　補足説明

10.2.4　補足説明

  • 下敷きに指定された画像ファイルは，印刷されません。

  • 帳票定義の途中で用紙サイズを変更した場合，下敷きの位置はチェックされません。

  • 下敷きに指定した画像ファイルは，［オプション］ダイアログの［ファイル］タブに表示されている「下敷きファイル」のフォルダに配置するようにしてください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 216 / 356


10.3 下敷きの表示・非表示を設定する : EUR 帳票作成 操作ガイド

  • 217 / 356

  • 表紙

  • 10.　プレプリント用紙に合わせて帳票を作成する

  • 10.3　下敷きの表示・非表示を設定する

10.3　下敷きの表示・非表示を設定する

下敷きの表示，非表示の操作は，帳票を編集している時，またはレイアウト表示をしている時にできます。

下敷きの表示，非表示は，［表示］－［下敷き］をクリックすることで切り替えられます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 217 / 356


11. Word/Excelで作成した帳票を変換する : EUR 帳票作成 操作ガイド

  • 218 / 356

  • 表紙

  • 11.　Word/Excelで作成した帳票を変換する

11.　Word/Excelで作成した帳票を変換する

この章では，Word文書（*.doc / *.docx）やExcel文書（*.xls / *.xlsx）を，帳票ファイル（*.fms）に変換する方法について説明します。

〈この章の構成〉

  • 11.1　Word/Excel文書を帳票ファイルに変換するまでの流れ

  • 11.2　変換前の準備

  • 11.3　プリンタドライバを設定する

  • 11.4　帳票ファイルに変換する

  • 11.5　Word/Excel文書から引き継がれる情報

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 218 / 356


11.1 Word/Excel文書を帳票ファイルに変換するまでの流れ : EUR 帳票作成 操作ガイド

  • 219 / 356

  • 表紙

  • 11.　Word/Excelで作成した帳票を変換する

  • 11.1　Word/Excel文書を帳票ファイルに変換するまでの流れ

11.1　Word/Excel文書を帳票ファイルに変換するまでの流れ

Word/Excel文書を帳票ファイルに変換するまでの流れを次に示します。

  1. Word/Excel文書を作成する

    変換元となるWord/Excel文書を作成します。変換元となるWord/Excel文書は，作成するときの注意があります。変換元のWord/Excel文書の注意については，「11.2.2(1)　変換元のWord/Excel文書の注意」を参照してください。

  2. プリンタドライバを設定する

    プリンタドライバは，EURを使用する環境に合わせて設定します。プリンタドライバの設定については，「11.3　プリンタドライバを設定する」を参照してください。

  3. Word/Excel文書を帳票ファイルに変換する

    ［Word/Excel文書の変換］ダイアログで，Word/Excel文書を帳票ファイルに変換します。管理者グループまたはAdministratorsグループに属するユーザで実行してください。Word/Excel文書を帳票ファイルに変換する方法については，「11.4　帳票ファイルに変換する」を参照してください。

    帳票ファイルが引き継ぐWord/Excel文書の情報の設定については，「11.5　Word/Excel文書から引き継がれる情報」を参照してください。

  4. 変換したWord/Excel文書を確認する

    変換された帳票ファイルを開き，正しく変換されたかどうかを確認します。変換元のWord/Excel文書と比較して，変換できなかった項目がある場合は，帳票ウィンドウ上で修正してください。

    必要に応じて，データウィンドウからのデータの貼り付け，フォントの設定，アイテムのレイアウト調整，繰り返し定義の設定，キーブレイクの設定，キー集計などを設定して，帳票ファイルを編集します。編集した帳票ファイルとデータファイルを設定して帳票を出力します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 219 / 356


11.2 変換前の準備 : EUR 帳票作成 操作ガイド

  • 220 / 356

  • 表紙

  • 11.　Word/Excelで作成した帳票を変換する

  • 11.2　変換前の準備

11.2　変換前の準備

〈この節の構成〉

  • 11.2.1　前提プログラム

  • 11.2.2　変換前の注意事項

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 220 / 356


11.2.1 前提プログラム : EUR 帳票作成 操作ガイド

  • 221 / 356

  • 表紙

  • 11.　Word/Excelで作成した帳票を変換する

  • 11.2　変換前の準備

  • 11.2.1　前提プログラム

11.2.1　前提プログラム

次に示すプログラムで作成，および保存されたWord/Excel文書が対象となります。

  • Word文書

    プログラム

    ファイル形式

    Microsoft(R) Office Word 2007

    Word 2007形式

    Microsoft(R) Office Word 2010

    Word 2010形式

    Microsoft(R) Office Word 2013

    Word 2013形式

  • Excel文書

    プログラム

    ファイル形式

    Microsoft(R) Office Excel 2007

    Excel 2007形式

    Microsoft(R) Office Excel 2010

    Excel 2010形式

    Microsoft(R) Office Excel 2013

    Excel 2013形式

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 221 / 356


11.2.2 変換前の注意事項 : EUR 帳票作成 操作ガイド

  • 222 / 356

  • 表紙

  • 11.　Word/Excelで作成した帳票を変換する

  • 11.2　変換前の準備

  • 11.2.2　変換前の注意事項

11.2.2　変換前の注意事項

Word/Excel文書から帳票ファイルへ変換する場合の注意事項を次に示します。

〈この項の構成〉

  • (1)　変換元のWord/Excel文書の注意

  • (2)　ファイル形式とプログラムのバージョン

  • (3)　Word/Excel文書を変換するときの注意

  • (4)　Word/Excel文書で指定された文字修飾の下線の扱い

(1)　変換元のWord/Excel文書の注意

Word/Excel文書は，複数ページある場合も1ページ目だけが帳票ファイルに変換されます。このときメッセージなどは表示されません。

また，Excel文書にシートが複数ある場合は，選択されているシートの1ページ目だけが変換されます。

このため，複数ページ・複数シートにわたるWord/Excel文書を変換する場合は，次のように設定してください。

  • 複数ページにわたるWord/Excel文書や，複数シートにわたるExcel文書のすべてのページを帳票ファイルに変換する場合は，1ページごとにファイルを分けて変換を実行してください。

  • Excel文書は，1ページ分の印刷範囲内に収まっているかどうかをプレビューなどで確認して，拡大縮小印刷で1ページに収まるように指定してください。

なお，変換を実行すると，Word/Excel文書のすべてのページがEMFスプールに出力されたあと，1ページ目だけが帳票ファイルに変換されます。そのため，実行する環境によっては，変換に時間が掛かることがあります。

ページの先頭へ

(2)　ファイル形式とプログラムのバージョン

変換対象となるWord文書とExcel文書は，ファイル形式と，Word，またはExcelのバージョンが一致しない場合，動作は保証しません。

（例）Word 2010ファイル形式のファイルを，Word 2007で読み込んで保存した場合

Word/Excel文書のファイル形式と，Word，またはExcelのバージョンが一致していない場合は，Microsoft(R)社が保証する動作範囲に従います。

ページの先頭へ

(3)　Word/Excel文書を変換するときの注意

Word/Excel文書を変換する場合，変換の実行時に［ユーザーアカウント制御］ダイアログが表示されます。変換を実行したアカウントによって，次のように操作してください。

管理者アカウントで実行した場合

［続行］ボタンをクリックしてください。

ユーザーアカウントで実行した場合

管理者アカウントのパスワードを入力して，［OK］ボタンをクリックしてください。

ページの先頭へ

(4)　Word/Excel文書で指定された文字修飾の下線の扱い

Word/Excel文書で文字修飾の下線が指定されている場合，帳票ファイルに変換すると，線アイテムとして出力されます（［アイテムのプロパティ］ダイアログで指定できる下線には変換されません）。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 222 / 356


11.3 プリンタドライバを設定する : EUR 帳票作成 操作ガイド

  • 223 / 356

  • 表紙

  • 11.　Word/Excelで作成した帳票を変換する

  • 11.3　プリンタドライバを設定する

11.3　プリンタドライバを設定する

Word/Excel文書を帳票ファイルに変換するときは，プリンタドライバがインストールされている環境で実行してください。

通常使うプリンタを設定したあと，プリンタドライバのEMFスプールを設定します。

〈この節の構成〉

  • 11.3.1　通常使うプリンタを設定する

  • 11.3.2　EMFスプールを設定する

  • 11.3.3　注意事項

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 223 / 356


11.3.1 通常使うプリンタを設定する : EUR 帳票作成 操作ガイド

  • 224 / 356

  • 表紙

  • 11.　Word/Excelで作成した帳票を変換する

  • 11.3　プリンタドライバを設定する

  • 11.3.1　通常使うプリンタを設定する

11.3.1　通常使うプリンタを設定する

Word/Excel文書を変換するためのプリンタを「通常使うプリンタ」に設定します。プリンタは，次のように設定してください。

  • 通常使うプリンタのプリントプロセッサは，EMFスプールを設定してください。EMFスプールが設定されていない場合は，「フォームシートファイルへの変換中にエラー（XX）が発生しました。」というメッセージが出力されて，変換が中断されます。

  • 通常使うプリンタのドライバの解像度は，Wordの場合はプリンタの解像度を，Excelの場合は文書の解像度を設定してください。解像度の設定が正しくないと，出力される帳票ファイルのサイズが，Word/Excel文書に比べて拡大されたり，縮小されたりします。

  • 通常使うプリンタの［プロパティ］ダイアログの［セキュリティ］タブで，実行ユーザに対して「プリンタの管理」のアクセス許可を設定してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 224 / 356


11.3.2 EMFスプールを設定する : EUR 帳票作成 操作ガイド

  • 225 / 356

  • 表紙

  • 11.　Word/Excelで作成した帳票を変換する

  • 11.3　プリンタドライバを設定する

  • 11.3.2　EMFスプールを設定する

11.3.2　EMFスプールを設定する

Windows 7でEMFスプールを設定する方法を，次に示します。Windows 7以外のOSについては，そのOSでの設定方法を確認してください。

  1. 対象となるプリンタのウィンドウを表示する

    スタートメニューの［コントロールパネル］から［ハードウェアとサウンド］の［デバイスとプリンター］を実行し，通常使うプリンタに設定されているプリンタを選択します。

  2. ［プロパティ］ダイアログの［詳細設定］タブを表示する

    右クリックして表示されたメニューから［プリンターのプロパティ］を選択します。［全般］タブの［プロパティ変更］ボタンを押してから，［詳細設定］タブを選択します。［詳細設定］タブで，［プリント プロセッサ］ボタンがあることを確認してください。

  3. ［詳細な印刷機能を有効にする］チェックボックスを設定する

    ［詳細な印刷機能を有効にする］チェックボックスをオンにします。［詳細な印刷機能を有効にする］チェックボックスをオンにすると，［プリント プロセッサ］ダイアログで設定した内容が有効になります。

  4. ［プリント プロセッサ］ダイアログを表示する

    ［プリント プロセッサ］ボタンを選択します。デフォルトでは，次のように表示されます。

  5. EMFスプールを設定する

    ［プリント プロセッサ］から「WinPrint」を，［既定のデータ型］から「NT EMF 1.00n」（nは任意の数値）を選択します。［既定のデータ型］には，「NT EMF 1.003」，「NT EMF 1.006」，「NT EMF 1.007」，「NT EMF 1.008」が表示されますが，「NT EMF 1.00n」であれば，どれを選択してもかまいません。

  6. ［OK］ボタンをクリックする

    ［プリント プロセッサ］ダイアログを閉じます。

  7. ［OK］ボタンをクリックする

    対象となるプリンタの［プロパティ］ダイアログを閉じます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 225 / 356


11.3.3 注意事項 : EUR 帳票作成 操作ガイド

  • 226 / 356

  • 表紙

  • 11.　Word/Excelで作成した帳票を変換する

  • 11.3　プリンタドライバを設定する

  • 11.3.3　注意事項

11.3.3　注意事項

プリンタドライバを設定する場合は，使用するプリンタの種類によって，次の注意が必要です。

〈この項の構成〉

  • (1)　通常使うプリンタがPostScript Level2対応プリンタの場合

  • (2)　Canon LIPS4 Printer Driverを使用する場合

(1)　通常使うプリンタがPostScript Level2対応プリンタの場合

通常使うプリンタがPostScript Level2対応プリンタの場合は，EMFスプールを設定しても，EMFスプーリングされないことがあります。このとき，「フォームシートファイルへの変換中にエラー（00）が発生しました。」のエラーメッセージが表示されます。通常使うプリンタのプリンタドライバが，EMFスプーリングに対応しているかどうかを確認してください。EMFスプーリングに対応していない場合は，EMFスプーリングに対応しているプリンタドライバを使用してください。EMFスプーリングに対応しているかどうかは，プリンタドライバの提供元に確認してください。

ページの先頭へ

(2)　Canon LIPS4 Printer Driverを使用する場合

プリンタドライバの設定で，Canon LIPS4 Printer Driverの新しい版を使用する場合は，［プリント プロセッサ］ダイアログの［既定のデータ型］で「NT EMF 1.00n」（nは任意の数値）を選択し，［メタファイルスプーリングを行う］をオンにしてください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 226 / 356


11.4 帳票ファイルに変換する : EUR 帳票作成 操作ガイド

  • 227 / 356

  • 表紙

  • 11.　Word/Excelで作成した帳票を変換する

  • 11.4　帳票ファイルに変換する

11.4　帳票ファイルに変換する

［Word/Excel文書の変換］ダイアログでWord/Excel文書を帳票ファイルへ変換します。変換元のWord/Excel文書と，変換された帳票ファイルを出力するフォルダを設定するだけで変換できます。

〈この節の構成〉

  • 11.4.1　変換の手順

  • 11.4.2　帳票ファイル名の規則

  • 11.4.3　変換された帳票ファイルを確認する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 227 / 356


11.4.1 変換の手順 : EUR 帳票作成 操作ガイド

  • 228 / 356

  • 表紙

  • 11.　Word/Excelで作成した帳票を変換する

  • 11.4　帳票ファイルに変換する

  • 11.4.1　変換の手順

11.4.1　変換の手順

Word/Excel文書を帳票ファイルに変換する方法について説明します。

〈この項の構成〉

  • (1)　［Word/Excel文書の変換］ダイアログを表示する

  • (2)　変換元のWord/Excel文書を選択する

  • (3)　罫線を自動補正する

  • (4)　出力先フォルダを設定する

  • (5)　変換を実行する

(1)　［Word/Excel文書の変換］ダイアログを表示する

スタートメニューの［EUR Designer］または［EUR Developer］の下位の［ツール］－［Word／Excel文書の変換］を選択すると，［Word/Excel文書の変換］ダイアログが表示されます。

ページの先頭へ

(2)　変換元のWord/Excel文書を選択する

［ファイルの選択］テキストボックスは，変換元のWord/Excel文書があるフォルダを設定します。初期表示の［ファイルの選択］テキストボックスには何も表示されていません。

［参照］ボタンをクリックすると，［ファイルを選択］ダイアログが表示されます。［ファイルを選択］ダイアログから変換元のWord/Excel文書があるフォルダを選択し，［OK］ボタンをクリックします。［ファイルの選択］テキストボックスに，変換元のWord/Excel文書があるフォルダが設定され，フォルダに格納されているWord/Excel文書のファイル一覧が表示されます。

変換元のWord/Excel文書のファイルは，一つ以上選択できます。変換元のファイルは，Word/Excel文書だけを選択してください。複数のファイルを設定しても，一度に帳票ファイルに変換できます。

ファイル一覧に表示されたファイルは，すべて変換対象のファイルになります。

ページの先頭へ

(3)　罫線を自動補正する

［オプション］ボタンをクリックすると，［オプション］ダイアログが表示されます。［オプション］ダイアログでは，罫線の自動補正ができます。罫線の自動補正は，斜線を水平線や垂直線に変換するための補正値を入力します。

［水平線の補正範囲］テキストボックスと［垂直線の補正範囲］テキストボックスに，補正値を入力して，［OK］ボタンをクリックします。

補正値は，0～9.99まで入力できます。デフォルトは1.3mmです。［オプション］ダイアログで，数値以外を指定した場合は，エラーとなります。

水平線の補正と垂直線の自動補正の例を次に示します。

［水平線の補正範囲］テキストボックスと［垂直線の補正範囲］テキストボックスに1.3mmと入力すると，傾きが1.3mm以内の罫線は自動的に直線で表示されます。表などの罫線が傾いて表示される場合に利用します。罫線の傾きは使用するプリンタによって異なるので，変換後，出力結果を確認することをお勧めします。

重要

設定値が次の場合は，罫線は傾き1.3mmの線となって表示されます。

補正値≦罫線の傾き≦1.3mm

そのため補正値は，1.3mm以上にすることをお勧めします。

ページの先頭へ

(4)　出力先フォルダを設定する

変換された帳票ファイルを出力するフォルダを設定します。

［出力先フォルダ］テキストボックスには，変換された帳票ファイル（フォームシートファイル）を出力するフォルダを設定します。

［出力先フォルダ］テキストボックスには，一度もWord/Excel文書の変換を実行していない場合は，「C:\Users\<ログインユーザ>\Document」が，デフォルトで表示されます。一度でも以前にWord/Excel文書の変換を実行していた場合は，以前に指定したフォルダがデフォルトで表示されます。

変更する場合は，［フォルダの参照］ダイアログで設定します。［フォルダの参照］ダイアログは，［参照］ボタンをクリックすると表示されます。

［フォルダの参照］ダイアログには，既存のフォルダが表示されます。新規にフォルダを作成して帳票ファイルを出力したい場合は，あらかじめエクスプローラなどでフォルダを作成しておいてください。

ページの先頭へ

(5)　変換を実行する

変換元のWord/Excel文書のファイルと，変換された帳票ファイルを出力するフォルダの設定が終わったら，［Word/Excel文書の変換］ダイアログの［実行］ボタンをクリックします。変換元のWord/Excel文書が，帳票ファイル（フォームシートファイル）に出力されます。なお，出力された帳票ファイルは，変換したEURと同じバージョンになります。

［実行］ボタンをクリックすると，変換処理の進捗状況が，次に示すメッセージで表示されます。このメッセージは，［実行］ボタンをクリックする前，および変換終了後は，表示されません。

「フォームシートファイルに変換中・・・（XX/YY）」

（凡例）

XX：変換が終了したファイル数です。

YY：変換対象のファイル数です。

出力先のフォルダに，同一名称の帳票ファイルがある場合，上書きするかどうかを問い合わせるメッセージは表示されません。そのまま上書きされます。

変換が正常に終了すると，変換が終了したことを知らせるメッセージボックスが表示されます。

重要

  • Word/Excel文書を帳票ファイルへ変換する場合は，ほかのアプリケーションで印刷をしないでください。ほかのアプリケーションで印刷すると，「他のプログラムで印刷を実行中です。」のメッセージが表示され，変換されません。

  • 複数のWord/Excel文書を設定して変換している場合，途中のファイルでエラーが発生すると，エラーメッセージを表示して，［Word/Excel文書の変換］ダイアログに制御が戻ります。エラーが発生したファイルの直前までに変換し終わっていた帳票ファイルは，削除されません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 228 / 356


11.4.2 帳票ファイル名の規則 : EUR 帳票作成 操作ガイド

  • 229 / 356

  • 表紙

  • 11.　Word/Excelで作成した帳票を変換する

  • 11.4　帳票ファイルに変換する

  • 11.4.2　帳票ファイル名の規則

11.4.2　帳票ファイル名の規則

帳票ファイル名の規則について説明します。

〈この項の構成〉

  • (1)　帳票ファイル名

  • (2)　帳票ファイル名の長さ

(1)　帳票ファイル名

帳票ファイル名は，変換元のWord文書（*.doc / *.docx），またはExcel文書（*.xls / *.xlsx）のファイル名に，拡張子「.fms」を付加します。

（例）変換元のWord文書名「WORD1.doc」の場合

変換元のファイル名 | 帳票ファイル名
WORD1.doc | WORD1.doc.fms

ページの先頭へ

(2)　帳票ファイル名の長さ

帳票ファイル名（フォルダ＋帳票ファイル名）の長さは，拡張子（*.fms）を含めて，255文字以内で指定してください。255文字を超える場合は，「出力先フォルダの名称が長すぎます。」のメッセージが表示され，変換が中止されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 229 / 356


11.4.3 変換された帳票ファイルを確認する : EUR 帳票作成 操作ガイド

  • 230 / 356

  • 表紙

  • 11.　Word/Excelで作成した帳票を変換する

  • 11.4　帳票ファイルに変換する

  • 11.4.3　変換された帳票ファイルを確認する

11.4.3　変換された帳票ファイルを確認する

変換が完了したら，変換元のWord/Excel文書と変換された帳票ファイルを比較して，変換されなかった項目がないかどうか確認してください。

Word/Excel文書から帳票ファイルに変換されなかった項目があっても，メッセージなどは表示されません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 230 / 356


11.5 Word/Excel文書から引き継がれる情報 : EUR 帳票作成 操作ガイド

  • 231 / 356

  • 表紙

  • 11.　Word/Excelで作成した帳票を変換する

  • 11.5　Word/Excel文書から引き継がれる情報

11.5　Word/Excel文書から引き継がれる情報

Windows 7の場合，OSに付属しているドライバを使用して帳票ファイルを変換したときは，Word/Excel文書に設定されている種別と属性の情報の一部を引き継ぎます。OSに付属しているドライバは，OSや実行ロケールごとに異なります。

Windows 7の場合，OSに付属しているドライバを表11-1に，Word/Excel文書からの情報の引き継ぎの詳細を表11-2に示します。

重要

  • 表11-2に挙げた種別以外の情報は，帳票ファイルに変換されません。必要に応じてEUR 帳票作成機能で編集してください。

  • Windows 7の場合，OSに付属しているドライバ以外のドライバを使用して変換した場合は，表11-2のように変換されないことがあります。OSに付属しているドライバを使用して変換することをお勧めします。OSに付属しているドライバ以外のドライバを使用して変換する場合は，変換元のWord/Excel文書と，変換された帳票ファイルを比較して，変換されなかった種別，属性などがないかどうかを確認してください。

  • Windows 8.1，またはWindows 10の場合，OSに付属しているドライバは使用できません。「11.3　プリンタドライバを設定する」を参照して，条件に適合するプリンタドライバをインストールしてください。

表11‒1 OSに付属しているドライバ
OS | ドライバ
Windows 7 | Canon LBP-3900/3950
表11‒2　Word/Excel文書からの情報の引き継ぎ

Word/Excel文書

帳票ファイル

種別

属性

属性の値

説明

文字列

－

－

○

固定文字列に変換されます。

位置

文字列の位置

○

同じ位置に変換されます。※1

フォント

使用するフォント名

○
英語ロケールで実行した場合

  • MS Gothicは，そのまま変換されます。

  • MS Gothic以外のフォントは，Courier Newに変換されます。

中国語ロケールで実行した場合

  • MS Gothicは，そのまま変換されます。

  • MS Gothic以外のフォントは，新宋体に変換されます。

日本語ロケールで実行した場合

  • ＭＳ ゴシックは，そのまま変換されます。

  • ＭＳ ゴシック以外のフォントは，ＭＳ 明朝に変換されます。

フォントサイズ

フォントのサイズ（pt）

○

  • 3.0～256.0（pt）は，そのまま変換されます。

  • 3.0（pt）未満の場合は3.0（pt）に，256.0（pt）を超える場合は256.0（pt）に変換されます。

  • 小数点が付いた数値の場合のフォントサイズは0.5pt単位に補正されます。

スタイル

フォントのスタイル（標準／太字／斜体／太字斜体）

◎

同じスタイルで変換されます。

色

文字の色

◎

同じ色で変換されます。

文字間隔

文字の間隔

◎

同じ文字間隔で変換されます。

縦書きと横書き

文字上向きで左から右に描画

文字左向きで下から上に描画

文字上向きで上から下に描画

文字右向きで上から下に描画

文字左向きで左から右に描画

○

文字を描画する方向は，すべて「文字上向きで左から右に描画（EURでは，上向きで，左から右へ）」に変換されます。

複数行の文字列

改行，折り返しによる複数行

◎

行ごとに，固定文字列に変換されます。

上記以外の属性

－

×

－

直線（図形線，罫線）

－

－

○

線に変換されます。※2，※3

位置

開始・終了位置

○

同じ位置に変換されます。※1

線種

実線／点線（7種）

○

  • 実線は，任意サイズの実線に変換されます。ただし，線の太さについては，属性「線幅」の変換結果に従います。

  • 実線以外は，すべて点線に変換されます。

線幅

線の幅（pt）

○

  • 実線の幅は，0.1～10.0（pt）の範囲であれば，そのまま変換されます。※4

    0.1（pt）未満の場合は0.1（pt）に，10.0（pt）を超える場合は10.0（pt）に変換されます。

  • 点線の幅は，すべて1ドット（600dpiのプリンタで0.1ポイント）に変換されます。

色

線の色

○

同じ色で変換されます。※5，※6

連続線

連続した直線

◎

複数の線に変換されます。※2

上記以外の属性

－

×

－

図形

－

－

○

図形に変換されます。※7，※8

種類

四角

◎

四角に変換されます。

位置

開始・終了位置

○

同じ位置に変換されます。※1

塗りつぶし色

図形の塗りつぶし色

◎

同じ色の塗りつぶし図形に変換されます。

塗りつぶし効果

パターン，パターン前景色，パターン背景色

○

  • 網パターンは，すべて「薄い網掛け」に変換されます。

  • 前景色は黒，背景色は白に変換されます。

枠線種

実線／点線（7種）

○

  • 実線は，2番目に細い実線（1.0ポイント）に変換されます。※9

  • 実線以外は，すべて点線に変換されます。

枠線幅

枠線の幅（ポイント）

○

  • 実線の幅はすべて1.0（pt）に変換されます。

  • 点線の幅はすべて1ドット（600dpiのプリンタで0.1ポイント）に変換されます。

枠線色

枠線の色

◎

同じ色で変換されます。

テキスト

図形に追加したテキスト

○

種別「文字列」と同じように変換されます。

上記以外の属性

－

×

－
（凡例）

◎：変換されます。

○：変換されますが，機能差があります。

×：変換されません。

－：該当する項目はありません。

注※1

変換元のWord文書で，余白5mm以内に文字列，線，および図形（テキストを含む）が配置されている場合，変換された帳票ファイルでは，表示位置とアイテムのサイズを，次のように配置します。

Word文書 |  | 帳票ファイル
種別 | 余白5mm以内に配置されている情報 | 表示位置 | アイテムのサイズ
文字列 | 上 Y座標 | 上余白5mmの位置に変更されます。 | 高さはそのままです。
 | 下 Y座標 | 同じ位置に配置されます。 | 高さは縮まります（下余白0mm～5mmに掛かる文字は削られます）。
 | 左 X座標 | 左余白5mmの位置に変更されます。 | 幅はそのままです。
 | 右 X座標 | 同じ位置に配置されます。 | 幅は縮まります（右余白0mm～5mmに掛かる文字は削られます）。
直線 | 上 Y座標 | 上余白5mmの位置に変更されます。 | 長さはそのままです。
 | 下 Y座標 | 同じ位置に配置されます。 | 長さが縮まります（下余白0mm～5mmに掛かる線は削られます）。
 | 左 X座標 | 左余白5mmの位置に変更されます。 | 長さはそのままです。
 | 右 X座標 | 同じ位置に配置されます。 | 長さが縮まります（右余白0mm～5mmに掛かる線は削られます）。
図形（テキストを含む） | 上 Y座標 | 上余白5mmの位置に変更されます。 | 高さはそのままです。
 | 下 Y座標 | 同じ位置に配置されます。 | 高さが縮まります（下余白0mm～5mmに掛かる図形は削られます）。
 | 左 X座標 | 左余白5mmの位置に変更されます。 | 幅はそのままです。
 | 右 X座標 | 同じ位置に配置されます。 | 幅が縮まります（右余白0mm～5mmに掛かる図形は削られます）。
注※2

次に示すWord/Excel文書を変換した場合，帳票ファイルには線が出力されません。

Word/Excel文書に設定されている情報 |  | 帳票ファイル
ファイル形式 | 属性
Word 2007形式，またはWord 2010形式 | 表の罫線の線種が「点線」 | 線が出力されません。
Word 2013形式，Excel 2010形式，またはExcel 2013形式 | 線種が「斜線」
 | 線種が「点線（丸）」
 | 線種が「連続線」
注※3

直線で線幅が10ptを超える場合，保存されたファイル形式によって，次のように変換されます。

Word/Excel文書に設定されている情報 |  |  | 帳票ファイル
ファイル形式 | 属性
Word 2013形式，Excel 2010形式，またはExcel 2013形式 | 線幅 | 線幅が10ptを超える | 図形に変換されます。
注※4

プリンタの解像度によって，変換元のWord/Excel文書と，変換された帳票ファイルを別のプリンタで印刷すると，線幅に0.1ポイントの差が発生することがあります。Word/Excel文書と，帳票ファイルを同じプリンタで印刷すると，線幅は等しくなります。

注※5

セルの罫線の線種が「点線」で，かつ線の色が設定されているExcel文書の場合，保存されたファイル形式によって，帳票ファイルは，次のように変換されます。

Excel文書に設定されている情報 |  |  | 帳票ファイル
ファイル形式 | 属性
Excel 2007形式，Excel 2010形式，またはExcel 2013形式 | 線種が「点線」 | 線の色は白 | 白の実線に変換されます。
 |  | 線の色は白以外 | 黒の点線に変換されます。
注※6

セルの罫線の線種が「点線（丸）」，かつ線の色に白以外が設定されているExcel文書の場合，保存されたファイル形式によって，帳票ファイルは，次のように変換されます。

Excel文書に設定されている情報 |  |  | 帳票ファイル
ファイル形式 | 属性
Excel 2013形式 | 線種が「点線（丸）」 | 線の色は白以外 | 黒の実線に変換されます。
注※7

セルに網掛けがあるExcel文書の場合，セルのサイズによって，帳票ファイルは，次のように変換されます。

Excel文書 |  | 帳票ファイル
セルの幅 | 14ピクセル以下 | 線に変換されます。
 | 15ピクセル以上 | 図形に変換されます。
行の高さ | 10.75ポイント以下 （プリンタの解像度：300dpiの場合） | 線に変換されます。
 | 11ポイント以上 （プリンタの解像度：300dpiの場合） | 図形に変換されます。
 | 11ポイント以下 （プリンタの解像度：600dpiの場合） | 線に変換されます。
 | 11.25ポイント以上 （プリンタの解像度：600dpiの場合） | 図形に変換されます。

なお，行の高さは，プリンタの解像度によって異なります。プリンタの解像度が300dpi，または600dpi以外の場合は，変更された帳票ファイルで確認してください。

注※8

図形に塗りつぶし（パターン）が設定されている場合，保存されたファイル形式によって，帳票ファイルは，次のように変換されます。

Word/Excel文書に設定されている情報 |  |  | 帳票ファイル
ファイル形式 | 属性
Word 2013形式，またはExcel 2013形式 | 図形 | 塗りつぶし（パターン） | 複数の図形に分割されて変換されます。
注※9

図形の枠線種は，保存されたファイル形式によって，次のように変換されます。

Word/Excel文書に設定されている情報 |  |  | 帳票ファイル
ファイル形式 | 属性
Word 2013形式，Excel 2010形式，またはExcel 2013形式 | テキストボックスの枠線 | 線種が実線 | 点線に変換されます。
 | 図形の枠線 | 線種が実線 | 点線に変換されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 231 / 356


12. 作成したアイテムを部品化して再利用する : EUR 帳票作成 操作ガイド

  • 232 / 356

  • 表紙

  • 12.　作成したアイテムを部品化して再利用する

12.　作成したアイテムを部品化して再利用する

この章では，複数のアイテムを部品として登録する方法と，部品として登録したアイテムを帳票上に貼り付ける方法について説明します。

〈この章の構成〉

  • 12.1　部品登録機能とは

  • 12.2　部品を登録する

  • 12.3　部品をエクスポート，インポートする

  • 12.4　部品を帳票に貼り付ける

  • 12.5　部品を削除する

  • 12.6　部品使用時の注意事項

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 232 / 356


12.1 部品登録機能とは : EUR 帳票作成 操作ガイド

  • 233 / 356

  • 表紙

  • 12.　作成したアイテムを部品化して再利用する

  • 12.1　部品登録機能とは

12.1　部品登録機能とは

部品登録機能とは，複数のアイテムをまとめて，一つの部品として登録する機能です。

例えば，複数のアイテムから作成した宛名ラベルや表のヘッダを，部品として登録することで，一つのアイテムと同じように帳票ウィンドウ上で使用できます。

部品登録機能を利用すると，アイテムを再利用して帳票を定義できます。今まで複数のアイテムから作成していた宛名ラベルや表のヘッダなど共通のアイテムや定形のアイテムを部品として登録でき，帳票を定義する効率が向上します。登録した部品は，複数のユーザに配布できます。サイズや色などの変更ができないので，ユーザが部品を独自に加工してしまうこともありません。

〈この節の構成〉

  • 12.1.1　部品の使用手順

  • 12.1.2　登録できるアイテムの種類

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 233 / 356


12.1.1 部品の使用手順 : EUR 帳票作成 操作ガイド

  • 234 / 356

  • 表紙

  • 12.　作成したアイテムを部品化して再利用する

  • 12.1　部品登録機能とは

  • 12.1.1　部品の使用手順

12.1.1　部品の使用手順

部品を登録したり，帳票ウィンドウに貼り付けて部品を利用したりする手順を次に示します。

  1. 部品の登録

    帳票ウィンドウで作成したアイテムをまとめて，一つの部品として登録します。帳票ウィンドウ上で登録するアイテムを選択し＜Shift＞キーを押しながら，部品パレットウィンドウにアイテムをドラッグアンドドロップします。登録した部品は部品庫に登録されます。

    部品の登録については，「12.2　部品を登録する」を参照してください。

  2. 部品のエクスポート

    登録した部品を保存したり，他ユーザに配布したりする場合は，部品庫に登録した部品をエクスポートします。部品アーカイブファイルに部品庫の部品を格納することを部品のエクスポートといいます。［ファイル］－［エクスポート］を選択して，エクスポートします。

    部品のエクスポートについては，「12.3.1　部品をエクスポートする」を参照してください。

  3. 部品のインポート

    部品アーカイブファイルに保存した部品を部品庫にインポートします。部品アーカイブファイルを読み込むことを部品のインポートといいます。インポートした部品は，部品庫に登録され，部品パレットウィンドウに表示されます。［ファイル］－［インポート］を選択して，インポートします。

    部品のインポートについては，「12.3.2　部品をインポートする」を参照してください。

  4. 部品の貼り付け

    部品庫に登録された部品を利用するには，部品パレットウィンドウに表示された部品を帳票に貼り付けます。部品はドラッグアンドドロップで貼り付けます。

    部品の貼り付けについては，「12.4　部品を帳票に貼り付ける」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 234 / 356


12.1.2 登録できるアイテムの種類 : EUR 帳票作成 操作ガイド

  • 235 / 356

  • 表紙

  • 12.　作成したアイテムを部品化して再利用する

  • 12.1　部品登録機能とは

  • 12.1.2　登録できるアイテムの種類

12.1.2　登録できるアイテムの種類

部品登録機能では，次のアイテムを部品として登録できます。

  • 文字アイテム

  • 線アイテム

  • 図形アイテム

  • 画像アイテム

  • ページ番号アイテム

  • 印刷日付アイテム

  • 印刷時刻アイテム

  • マッピングデータアイテム

  • ユーザ定義データアイテム

  • 集計アイテム

また，部品と部品，部品とアイテムを組み合わせて，別の部品（入れ子部品）として登録することもできます。

重要

登録できないアイテム，設定を解除されるアイテム

次のアイテムは，部品として登録できません。

  • キー集計行のアイテム

  • ページ集計行のアイテム

  • 総集計行のアイテム

  • 集計ページのアイテム

  • 特殊編集行のアイテム

また，次の設定をした部品を登録した場合，アイテムの設定は解除されます。

表12‒1　解除されるアイテムの設定

解除される設定

部品として登録した場合のアイテムの状態

繰り返し/見出し指定

繰り返し/見出し指定は解除されます。

ブレイクキーの指定

ブレイクキーは解除されます。

まとめ表示

まとめ表示は解除されます。

帳票ヘッダアイテム

帳票ヘッダアイテムとしては登録できません。繰り返し領域のアイテムとして登録されます。

キー集計のキー指定

集計キーのキー指定は解除されます。

アイテムの配置（貼付域の左上を基準）

［繰り返し領域の左上を基準］を設定したアイテムとして登録されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 235 / 356


12.2 部品を登録する : EUR 帳票作成 操作ガイド

  • 236 / 356

  • 表紙

  • 12.　作成したアイテムを部品化して再利用する

  • 12.2　部品を登録する

12.2　部品を登録する

帳票ウィンドウに配置したアイテムを部品庫に部品として登録します。

部品を登録する方法には，次の二つがあります。

  • ［編集］－［部品の登録］を選択して登録する

  • 部品パレットにドラッグアンドドロップして登録する

重要

次の場合は，部品を登録できません。

  • 選択したアイテムに，部品として登録できないアイテムがある場合

  • 部品パレットウィンドウ以外にドラッグアンドドロップした場合

この場合，マウスの形が [図データ] に変わり，［部品の登録］メニューは不活性になります。

登録した部品は，部品名は変更できますが，サイズや色などの変更はできません。変更したい場合は，部品を再登録してください。

〈この節の構成〉

  • 12.2.1　［編集］－［部品の登録］を選択して登録する

  • 12.2.2　部品パレットウィンドウにドラッグアンドドロップして登録する

  • 12.2.3　部品名を変更する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 236 / 356


12.2.1 ［編集］－［部品の登録］を選択して登録する : EUR 帳票作成 操作ガイド

  • 237 / 356

  • 表紙

  • 12.　作成したアイテムを部品化して再利用する

  • 12.2　部品を登録する

  • 12.2.1　［編集］－［部品の登録］を選択して登録する

12.2.1　［編集］－［部品の登録］を選択して登録する

［編集］－［部品の登録］を選択して登録する手順を次に示します。

  1. アイテムを選択する

    帳票ウィンドウ上で部品として登録するアイテムを選択します。複数のアイテムをまとめて登録できます。

  2. ［部品の登録］ダイアログを表示する

    アイテムを選択した状態で，［編集］－［部品の登録］を選択します。部品パレットウィンドウが起動し，［部品の登録］ダイアログが表示されます。

  3. 部品を登録する

    「部品名」と「コメント」をテキストボックスに入力します。部品名は30文字まで，コメントは200文字まで入力できます。

  4. 表示位置を指定する

    「座標」のラジオボタンで表示位置を指定するかどうかを選択します。部品の表示位置の指定については，「12.4.3　部品の表示位置を指定する」を参照してください。

    「固定の位置」を選択した場合は，常に指定位置に配置するかどうかを選択できます。常に指定位置に配置するときは，［常に指定位置に配置］チェックボックスをオンにして，「基準位置」と「X」（X座標位置），「Y」（Y座標位置）を指定します。「X」と「Y」で表示される単位は，［オプション］ダイアログの［使用する単位］で指定した単位が表示されます。

    部品の表示位置は，部品を登録したあとは変更できません。部品の表示位置を変更する場合は，部品を登録し直してください。

  5. ［OK］ボタンをクリックする

    ［OK］ボタンをクリックすると，部品が部品庫に登録されます。部品パレットウィンドウに登録した部品名が表示されます。部品には，部品IDが自動的に割り振られます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 237 / 356


12.2.2 部品パレットウィンドウにドラッグアンドドロップして登録する : EUR 帳票作成 操作ガイド

  • 238 / 356

  • 表紙

  • 12.　作成したアイテムを部品化して再利用する

  • 12.2　部品を登録する

  • 12.2.2　部品パレットウィンドウにドラッグアンドドロップして登録する

12.2.2　部品パレットウィンドウにドラッグアンドドロップして登録する

ドラッグアンドドロップで部品を登録する場合，部品パレットウィンドウをあらかじめ表示しておきます。部品パレットウィンドウは，［ツール］－［部品パレット］で表示できます。

帳票ウィンドウ上で登録するアイテムを選択し＜Shift＞キーを押しながら，部品パレットウィンドウにアイテムをドラッグアンドドロップします。部品パレットウィンドウ上にマウスを移動すると，マウスの形が [図データ] に変わります。マウスボタンを離すと，［部品の登録］ダイアログが表示されます。

［部品の登録］ダイアログが表示されたあとは，「12.2.1　［編集］－［部品の登録］を選択して登録する」と同じです。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 238 / 356


12.2.3 部品名を変更する : EUR 帳票作成 操作ガイド

  • 239 / 356

  • 表紙

  • 12.　作成したアイテムを部品化して再利用する

  • 12.2　部品を登録する

  • 12.2.3　部品名を変更する

12.2.3　部品名を変更する

登録した部品名を変更できます。部品をインポートした結果，同じ名前の部品が登録されたときなどに使用します。

部品名の変更は，部品パレットウィンドウで部品を選択し，［編集］－［名前の変更］を選択します。［部品の名称］ダイアログが表示されます。［部品名］テキストボックスに部品名を入力し，［OK］ボタンをクリックします。部品名は30文字まで入力できます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 239 / 356


12.3 部品をエクスポート，インポートする : EUR 帳票作成 操作ガイド

  • 240 / 356

  • 表紙

  • 12.　作成したアイテムを部品化して再利用する

  • 12.3　部品をエクスポート，インポートする

12.3　部品をエクスポート，インポートする

部品庫に登録した部品は，部品アーカイブファイル（*.epa）としてエクスポートできます。部品をエクスポートして配布すると，複数のユーザが同じ部品を使用できます。部品アーカイブファイルに部品庫の部品を保存することを部品のエクスポート，部品アーカイブファイルを読み込むことを部品のインポートといいます。

部品アーカイブファイル（*.epa）とは，部品庫に登録した複数の部品を一つにまとめて出力したファイルです。

〈この節の構成〉

  • 12.3.1　部品をエクスポートする

  • 12.3.2　部品をインポートする

  • 12.3.3　部品を識別する規則

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 240 / 356


12.3.1 部品をエクスポートする : EUR 帳票作成 操作ガイド

  • 241 / 356

  • 表紙

  • 12.　作成したアイテムを部品化して再利用する

  • 12.3　部品をエクスポート，インポートする

  • 12.3.1　部品をエクスポートする

12.3.1　部品をエクスポートする

部品庫に登録した部品をエクスポートする手順を次に示します。

  1. ［名前を付けて保存］ダイアログを表示する

    ［ファイル］－［エクスポート］を選択します。［名前を付けて保存］ダイアログが表示されます。

  2. ファイルの保存する場所，ファイル名，ファイルの種類を設定する

    ファイルの保存する場所，ファイル名，ファイルの種類を設定します。

    ファイルの種類は，「EUR部品アーカイブファイル（*.epa）」です。

  3. ファイルを保存する

    ［保存］ボタンをクリックします。部品アーカイブファイルが作成されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 241 / 356


12.3.2 部品をインポートする : EUR 帳票作成 操作ガイド

  • 242 / 356

  • 表紙

  • 12.　作成したアイテムを部品化して再利用する

  • 12.3　部品をエクスポート，インポートする

  • 12.3.2　部品をインポートする

12.3.2　部品をインポートする

部品アーカイブファイルに保存された部品を使用するためには，部品をインポートする必要があります。部品をインポートすると，部品庫に部品が登録され，部品パレットウィンドウに表示されます。

部品を部品庫にインポートする手順を次に示します。

  1. ［ファイルを開く］ダイアログを表示する

    ［ファイル］－［インポート］を選択します。［ファイルを開く］ダイアログが表示されます。

  2. 部品アーカイブファイルを選択する

    部品アーカイブファイルを選択します。ファイルの種類は「EUR部品アーカイブファイル（*.epa）」を選択します。

  3. ファイルを開く

    ［開く］ボタンをクリックします。［インポートの結果］ダイアログが表示されます。ただし，部品庫に登録された部品が1,000個以上になった場合，インポートを中止します。

  4. インポート結果を確認する

    ［インポートの結果］ダイアログに部品ごとのインポート結果が表示されます。

    部品庫のデータは部品名と部品IDによって識別されます。部品IDが同じ部品は上書きされます。部品を識別する規則については，「12.3.3　部品を識別する規則」を参照してください。

    ［閉じる］ボタンをクリックして，部品パレットウィンドウに戻ります。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 242 / 356


12.3.3 部品を識別する規則 : EUR 帳票作成 操作ガイド

  • 243 / 356

  • 表紙

  • 12.　作成したアイテムを部品化して再利用する

  • 12.3　部品をエクスポート，インポートする

  • 12.3.3　部品を識別する規則

12.3.3　部品を識別する規則

部品をインポートする場合，元の部品と上書きする部品が同一かどうかを，部品名と部品IDによって識別します。部品を識別するときの規則を次の表に示します。

表12‒2 部品を識別するときの規則
部品の設定 |  | ダイアログのメッセージ | インポートした部品の状態
部品名 | 部品ID
同じ | 同じ | 部品を置き換えました。 | インポートした部品を同じ部品名，部品IDの部品に上書きします。
同じ | 異なる | 部品を追加しました。 | インポートした部品名で新規に部品を登録します。部品IDは変更されません。部品パレットウィンドウには，同じ部品名の部品が表示されます。
異なる | 同じ | 部品を置き換えました。 | インポートした部品を同じ部品IDの部品に上書きします。部品名は，インポートした部品の部品名が表示されます。
異なる | 異なる | 部品を追加しました。 | インポートした部品名，部品IDで新規に部品を登録します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 243 / 356


12.4 部品を帳票に貼り付ける : EUR 帳票作成 操作ガイド

  • 244 / 356

  • 表紙

  • 12.　作成したアイテムを部品化して再利用する

  • 12.4　部品を帳票に貼り付ける

12.4　部品を帳票に貼り付ける

部品パレットウィンドウに登録されている部品を帳票に貼り付けます。

重要

次の場合は，部品を貼り付けられません。

  • 貼付域以外にマウスを移動した場合

  • 部品のサイズが貼付域のサイズを超えた場合

  • ［常に指定位置に配置］をオンにして部品が貼付域をはみ出した場合

〈この節の構成〉

  • 12.4.1　部品を帳票に貼り付ける

  • 12.4.2　部品のプロパティを表示する

  • 12.4.3　部品の表示位置を指定する

  • 12.4.4　帳票ウィンドウ上で部品を移動する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 244 / 356


12.4.1 部品を帳票に貼り付ける : EUR 帳票作成 操作ガイド

  • 245 / 356

  • 表紙

  • 12.　作成したアイテムを部品化して再利用する

  • 12.4　部品を帳票に貼り付ける

  • 12.4.1　部品を帳票に貼り付ける

12.4.1　部品を帳票に貼り付ける

部品を帳票に貼り付ける手順を次に示します。

  1. 部品を選択する

    部品パレットウィンドウから貼り付ける部品を選択します。

  2. 帳票に貼り付ける

    部品を帳票ウィンドウにドラッグアンドドロップして貼り付けます。

    マウスを帳票ウィンドウの貼付域に移動させると，マウスの形が [図データ] に変わり，マウスの位置に，部品のサイズを表すラバーバンドが表示されます。マウスボタンを離すと，部品が貼り付けられます。

    複数の部品を同時に貼り付けることはできません。一つずつ貼り付けてください。

    部品の左上が帳票ヘッダ領域にある場合は，貼り付けた部品は表紙ページにだけ表示されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 245 / 356


12.4.2 部品のプロパティを表示する : EUR 帳票作成 操作ガイド

  • 246 / 356

  • 表紙

  • 12.　作成したアイテムを部品化して再利用する

  • 12.4　部品を帳票に貼り付ける

  • 12.4.2　部品のプロパティを表示する

12.4.2　部品のプロパティを表示する

部品のプロパティは，［部品アイテムのプロパティ］ダイアログで表示できます。［部品アイテムのプロパティ］ダイアログは，部品パレットウィンドウから部品を選択し，［ファイル］－［プロパティ］を選択します。

部品のプロパティでは，部品名，部品ID，コメント，および座標が表示できます。

部品のプロパティは，変更できません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 246 / 356


12.4.3 部品の表示位置を指定する : EUR 帳票作成 操作ガイド

  • 247 / 356

  • 表紙

  • 12.　作成したアイテムを部品化して再利用する

  • 12.4　部品を帳票に貼り付ける

  • 12.4.3　部品の表示位置を指定する

12.4.3　部品の表示位置を指定する

部品登録時に座標を「固定の位置」に指定すると，部品の表示位置を指定できます。部品の表示位置の指定は，宛名ラベルや表のヘッダなど，決まった位置に貼り付ける部品に指定しておくと便利です。

部品の表示位置は，部品登録時に［部品の登録］ダイアログで指定します。部品の登録については，「12.2　部品を登録する」を参照してください。なお部品アイテムは，［アイテムのプロパティ］ダイアログでは，基準位置を指定できません。

部品の座標に「任意の位置」を指定した場合と，「固定の位置」を指定した場合の部品の貼り付け位置について次に示します。

座標を「任意の位置」にして部品を登録した場合

任意の位置に貼り付けられます。部品のサイズを示すラバーバンドは，マウスを中心にして表示されます。

座標を「固定の位置」にして部品を登録した場合

部品登録時に座標に指定した位置にだけ部品を貼り付けられます。マウスを任意の位置に移動しても，ラバーバンドは常に指定した座標の位置に表示されます。

「固定の位置」を選択すると，［部品の登録］ダイアログの［座標］グループボックスには，次のように表示されます。

「基準位置」のデフォルトは，「用紙左上」です。「X」・「Y」には，部品を登録したときの座標値が表示されます。表示される単位は，［オプション］ダイアログ－［表示］タブの「使用する単位」で指定した単位が表示されます。

［常に指定位置に配置］をチェックしない場合

帳票ウィンドウ上に貼り付けたあとは，部品を移動できます。

［常に指定位置に配置］をチェックした場合

帳票ウィンドウ上に貼り付けたあとも部品を移動できません。部品を移動できるように設定する場合は，［常に指定位置に配置］をチェックしないか，「任意の位置」を指定してください。

重要

部品の表示位置は，部品を登録したあとは変更できません。部品の表示位置を変更する場合は，部品を登録し直してください。部品の表示位置を指定する方法については，「12.2　部品を登録する」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 247 / 356


12.4.4 帳票ウィンドウ上で部品を移動する : EUR 帳票作成 操作ガイド

  • 248 / 356

  • 表紙

  • 12.　作成したアイテムを部品化して再利用する

  • 12.4　部品を帳票に貼り付ける

  • 12.4.4　帳票ウィンドウ上で部品を移動する

12.4.4　帳票ウィンドウ上で部品を移動する

帳票ウィンドウに貼り付けた部品を移動する方法は，ほかのアイテムの移動方法と同じです。アイテムの移動については，「4.7　アイテムの位置やサイズを変更する」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 248 / 356


12.5 部品を削除する : EUR 帳票作成 操作ガイド

  • 249 / 356

  • 表紙

  • 12.　作成したアイテムを部品化して再利用する

  • 12.5　部品を削除する

12.5　部品を削除する

部品パレットウィンドウから登録した部品を削除します。

部品パレットウィンドウから部品を削除する場合は，削除する部品を選択し，［編集］－［削除］を選択するか，または＜Delete＞キーを押してください。削除してもいいかどうかを確認するメッセージが表示され，［はい］ボタンをクリックすると，部品が削除されます。複数の部品を選択すると，一度に削除できます。

帳票ウィンドウに貼り付けた部品を削除する方法は，ほかのアイテムを削除する方法と同じです。アイテムの削除については，「4.10　アイテムを削除する」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 249 / 356


12.6 部品使用時の注意事項 : EUR 帳票作成 操作ガイド

  • 250 / 356

  • 表紙

  • 12.　作成したアイテムを部品化して再利用する

  • 12.6　部品使用時の注意事項

12.6　部品使用時の注意事項

部品使用時の注意事項を次に示します。

〈この節の構成〉

  • 12.6.1　登録できる部品・アイテムの上限

  • 12.6.2　部品とフィールド定義の連動

  • 12.6.3　部品を使用するときの注意

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 250 / 356


12.6.1 登録できる部品・アイテムの上限 : EUR 帳票作成 操作ガイド

  • 251 / 356

  • 表紙

  • 12.　作成したアイテムを部品化して再利用する

  • 12.6　部品使用時の注意事項

  • 12.6.1　登録できる部品・アイテムの上限

12.6.1　登録できる部品・アイテムの上限

一つの部品で使用できるアイテムの上限と，部品パレットに登録できる部品の上限について説明します。

〈この項の構成〉

  • (1)　一つの部品で使用できるアイテムの上限

  • (2)　部品庫に登録できる部品の上限

(1)　一つの部品で使用できるアイテムの上限

一つの部品で使用できるアイテムの数は，各アイテム100個までです。文字アイテム，線アイテム，図形アイテム，画像アイテム，部品のどれかが100個を超えている場合，部品を登録しようとすると，上限を超えていることを知らせるメッセージが表示されます。

ページの先頭へ

(2)　部品庫に登録できる部品の上限

部品庫に登録できる部品の上限は1,000個までです。部品を1,000個以上登録しようとすると，上限を超えていることを知らせるメッセージが表示されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 251 / 356


12.6.2 部品とフィールド定義の連動 : EUR 帳票作成 操作ガイド

  • 252 / 356

  • 表紙

  • 12.　作成したアイテムを部品化して再利用する

  • 12.6　部品使用時の注意事項

  • 12.6.2　部品とフィールド定義の連動

12.6.2　部品とフィールド定義の連動

マッピングデータアイテム，ユーザ定義データアイテム，および集計アイテムを部品として登録した場合，フィールド名も登録されます。アイテムと連動するフィールド名がない場合，正しく表示できないことがあります。

マッピングデータアイテム，ユーザ定義データアイテム，および集計アイテムを部品として登録した場合と，その部品を帳票ウィンドウに貼り付けた場合のフィールド定義との連動について，次に示します。

表12‒3 部品とフィールド定義の連動
部品に含まれるアイテム | フィールド定義との連動
 | 部品登録時 | 部品貼り付け時
マッピングデータアイテム | アイテムと同じフィールド名で登録されます。 | マッピングデータと同じフィールド名が表示されます。マッピングデータに該当するフィールド名がないときは空データとなります。
ユーザ定義データアイテム | アイテムと同じフィールド名で登録されます。 | ユーザ定義データと同じフィールド名が表示されます。ユーザ定義データに該当するフィールド名がないときは空データとなります。
集計アイテム | マッピングデータアイテムと連動する集計対象のフィールド名で登録されます。 | マッピングデータアイテムと連動するフィールド名が表示されます。マッピングデータに該当するフィールド名がないときは空データとなります。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 252 / 356


12.6.3 部品を使用するときの注意 : EUR 帳票作成 操作ガイド

  • 253 / 356

  • 表紙

  • 12.　作成したアイテムを部品化して再利用する

  • 12.6　部品使用時の注意事項

  • 12.6.3　部品を使用するときの注意

12.6.3　部品を使用するときの注意

OSの管理者権限を持たないユーザが部品を使用する場合，次のような注意事項があります。

  • 作成した部品はユーザごとに異なる場所に保存されます。

  • 部品の保存先は，ほかのユーザからは参照できません。

このため，ユーザ間で部品を共有するときは，管理者権限を持つユーザで操作を行うか，部品のエクスポート／インポートを実行してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 253 / 356


13. アイテムのプロパティとオプションを設定する : EUR 帳票作成 操作ガイド

  • 254 / 356

  • 表紙

  • 13.　アイテムのプロパティとオプションを設定する

13.　アイテムのプロパティとオプションを設定する

この章では，帳票に配置したアイテム，またはデータウィンドウから貼り付けたデータのプロパティ設定について説明します。

〈この章の構成〉

  • 13.1　［アイテムのプロパティ］ダイアログの表示

  • 13.2　文字アイテムと文字データのプロパティを設定する

  • 13.3　数値データのプロパティを設定する

  • 13.4　線アイテムのプロパティを設定する

  • 13.5　図形アイテムのプロパティを設定する

  • 13.6　画像アイテムのプロパティを設定する

  • 13.7　ページ番号アイテムのプロパティを設定する

  • 13.8　日付データのプロパティを設定する

  • 13.9　バーコードアイテムのプロパティを設定する

  • 13.10　部品のプロパティを設定する

  • 13.11　帳票のオプションを設定する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 254 / 356


13.1 ［アイテムのプロパティ］ダイアログの表示 : EUR 帳票作成 操作ガイド

  • 255 / 356

  • 表紙

  • 13.　アイテムのプロパティとオプションを設定する

  • 13.1　［アイテムのプロパティ］ダイアログの表示

13.1　［アイテムのプロパティ］ダイアログの表示

帳票に配置したアイテム，またはデータウィンドウから貼り付けたデータは，プロパティを設定したり，変更したりできます。プロパティは，［アイテムのプロパティ］ダイアログで設定します。［アイテムのプロパティ］ダイアログの表示方法を次に示します。

  1. アイテムを選択する

    ツールボックスの [図データ] ボタンを選択して選択モードにします。アイテムが重ねて配置されている場合，特定のアイテムを選択するときは，ツールボックスのチェックボックスをオンにすると便利です。

    • 「文字」をオンにすると，次に示すアイテムを選択できます。

      ツールボックスの [図データ] ボタンで設定した文字列

      データウィンドウから貼り付けたデータ（文字データ，数値データ，日付データ）

      バーコードアイテム

    • 「線」をオンにすると，線アイテムを選択できます。

    • 「図形」をオンにすると，図形アイテム（網掛け，角丸四角形，円／楕円，多角形）を選択できます。

    • 「画像」をオンにすると，画像アイテムを選択できます。

    • 「部品」をオンにすると，部品を選択できます。

  2. ［アイテムのプロパティ］ダイアログを表示する

    ［編集］－［アイテムのプロパティ］を選択するか，またはショートカットキーの［アイテムのプロパティ］を選択します。

    操作1で部品を選択していた場合は，［部品アイテムのプロパティ］ダイアログが表示されます。それ以外のアイテムの場合は，［アイテムのプロパティ］ダイアログが表示されます。［アイテムのプロパティ］ダイアログに表示されるタブは，操作1で選択したアイテムによって異なります。

  3. ［OK］ボタンをクリックする

    帳票ウィンドウに戻り，設定が反映されます。

メモ

選択したアイテムが繰り返し対象の場合は，プロパティを設定すると，設定内容がすべてのレコードに反映されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 255 / 356


13.2 文字アイテムと文字データのプロパティを設定する : EUR 帳票作成 操作ガイド

  • 256 / 356

  • 表紙

  • 13.　アイテムのプロパティとオプションを設定する

  • 13.2　文字アイテムと文字データのプロパティを設定する

13.2　文字アイテムと文字データのプロパティを設定する

文字アイテムと文字データは，次の表に示すプロパティを設定したり，変更したりできます。それぞれのタブの詳細については，マニュアル「EUR 帳票作成 画面リファレンス」を参照してください。

表13‒1 文字アイテムのプロパティ設定
プロパティの設定 | 設定するタブ名
項目の見出し名 | ［データ］タブ※1
前付加文字／後付加文字の設定 | ［表示形式］タブ※2
任意書式の設定
アイテムの配置（縦位置，横位置） | ［配置］タブ
文字の変更（フォント・スタイル・サイズ・色） | ［フォント］タブ
フォントの縦横比の補正
文字の修飾（下線）
文字間隔の変更 | ［文字配置］タブ
文字方向の変更
アイテムの桁数の指定※2
縮小して全体を表示※2
ワードラップを行う
文字ピッチを指定
アイテムの表示位置の変更 | ［位置・サイズ］タブ
アイテムのサイズの変更
文字列を置き換えて表示 | ［置き換え表］タブ
出力ページの指定 | ［出力ページ］タブ※3
注※1

文字データを単一選択したとき，表示されます。

注※2

文字データを選択したとき，表示されます。

注※3

文字アイテムを選択したとき，表示されます。

重要

アイテム枠内の桁数を設定するときの注意

［アイテムのプロパティ］ダイアログの［文字配置］タブで，［桁数を指定］のチェックボックスがオンの場合は，設定されている前付加文字，後付加文字，任意書式で指定した文字なども桁数に数えられます。

帳票にアイテムの桁数を設定した場合，入力されるデータの桁数がアイテム枠を超えると，データの入力時にエラーは表示されませんが，印刷時にエラーを表示して中断されます。帳票を定義するときは，入力されるデータの最大桁数を考慮して，アイテムの桁数を設定してください。

〈この節の構成〉

  • 13.2.1　文字アイテムの装飾

  • 13.2.2　任意書式の設定

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 256 / 356


13.2.1 文字アイテムの装飾 : EUR 帳票作成 操作ガイド

  • 257 / 356

  • 表紙

  • 13.　アイテムのプロパティとオプションを設定する

  • 13.2　文字アイテムと文字データのプロパティを設定する

  • 13.2.1　文字アイテムの装飾

13.2.1　文字アイテムの装飾

［アイテムのプロパティ］ダイアログでは設定できない文字アイテムの装飾は，網掛けアイテム，線アイテムなどを使用して，次の方法で設定してください。

〈この項の構成〉

  • (1)　文字に網掛けの装飾をする

  • (2)　文字に下線の装飾をする

  • (3)　文字に枠で囲む装飾をする

  • (4)　文字に囲い文字の装飾をする

  • (5)　補足説明

(1)　文字に網掛けの装飾をする

文字アイテムのアイテム枠をなぞるようにして，網掛けアイテムで網掛けを描きます。「4.2　アイテムを配置する」を参照してください。

ページの先頭へ

(2)　文字に下線の装飾をする

文字アイテムのプロパティで下線を指定できます。マニュアル「EUR 帳票作成 画面リファレンス」を参照してください。

また，文字アイテムのアイテム枠の底辺を基に，線アイテムで下線を描くこともできます。「4.2　アイテムを配置する」を参照してください。

ページの先頭へ

(3)　文字に枠で囲む装飾をする

文字アイテムのアイテム枠を囲むように，角丸四角形などのアイテムで枠を描きます。「4.2.5　図形アイテムを配置する」を参照してください。

ページの先頭へ

(4)　文字に囲い文字の装飾をする

文字アイテムのアイテム枠の縦横どちらかの長さに合わせるか，または文字のサイズに合わせて，円／楕円アイテムで円または楕円を描きます。「4.2.5　図形アイテムを配置する」を参照してください。

ページの先頭へ

(5)　補足説明

  • 文字アイテムに指定できる固定の文字列は，510文字までです。改行は1文字と見なします。入力した文字数が510文字を超えた場合，文字は表示されません。既存の文字アイテムを編集するときは，文字数が510文字を超えないようにしてください。また，アイテム枠内に収まらない文字列は表示されません。指定する文字列がアイテム枠より長くなったり，配置したアイテム枠より大きいサイズのフォントに変更したりした場合は，文字列が正しく表示されるようにアイテム枠のサイズやフォントサイズを調整してください。

  • 文字間隔が狭い場合，指定した文字のサイズが文字間隔を超える（左右の文字が重なる）ようなサイズであるときは，文字を描画しません。また，行間隔が狭い場合，指定した文字のサイズが行間を超える（上下の文字が重なる）ようなサイズであるときも，文字を描画しません。

  • 出力プリンタによって，文字間隔や行間隔を狭くした場合は，正しく印刷されないことがあります。

  • フォントやサイズを設定することで，実行する環境によっては，帳票が正しく印刷されなかったり，表示されなかったりする場合があります。また，指定されているフォントによっては，［文字配置］を設定した帳票が，実行する環境で正しく印刷されなかったり，表示されなかったりすることもあります。詳細は，「14.3.1(1)　フォントに関する注意」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 257 / 356


13.2.2 任意書式の設定 : EUR 帳票作成 操作ガイド

  • 258 / 356

  • 表紙

  • 13.　アイテムのプロパティとオプションを設定する

  • 13.2　文字アイテムと文字データのプロパティを設定する

  • 13.2.2　任意書式の設定

13.2.2　任意書式の設定

任意書式を設定するときには，［書式記号］テキストボックスで書式記号を指定する必要があります。

なお，書式記号を示すときは””，出力される文字を示すときは「」で囲んで説明しています。

〈この項の構成〉

  • (1)　指定できる書式記号

  • (2)　書式記号を指定するときの規則

  • (3)　書式の指定例

(1)　指定できる書式記号

指定できる書式記号と意味を次の表に示します。

表13‒2 ［書式記号］テキストボックスで設定する書式記号と意味
書式記号 |  | 意味
文字書式で設定できる記号 | X | 半角文字を表します。入力文字がない場合は，半角空白に置き換えて出力します。入力文字が全角の場合は，「?」を出力します。
 | N | 全角文字を表します。入力文字がない場合は，全角空白に置き換えて出力します。入力文字が半角の場合は，「？」を出力します。
 | C | 半角文字または全角文字を表します。入力文字が半角の場合は”C”を一つ，全角の場合は”C”を二つとして書式を適用します。入力文字がない場合は，半角空白に置き換えて出力します。最後の”C”に対する入力文字が全角の場合は，半角空白に置き換えて出力します。
 | X(n) | n個の半角文字を表します。入力文字が全角の場合は，「?」を出力します。 nは1から999までの数値を指定します。
 | N(n) | n個の全角文字を表します。入力文字が半角の場合は，「？」を出力します。 nは1から999までの数値を指定します。
 | C(n) | n個の半角文字または全角文字を表します。入力文字が半角の場合は”C”を一つ，全角の場合は”C”を二つとして書式を適用します。入力文字がない場合は，半角空白に置き換えて出力します。最後の”C”に対する入力文字が全角の場合は，半角空白に置き換えて出力します。 nは1から999までの数値を指定します。
数値書式で設定できる記号 | 9 | <数値>を表します。入力文字がない場合は，0に置き換えて出力します。入力文字が数値以外の場合は，「?」を出力します。
 | Z | <数値>を表します。入力文字がない，または0の場合は半角空白に置き換えて出力します。入力文字が数値以外の場合は，「?」を出力します。
 | , | 区切り文字として指定位置に出力します。”,”の左側が，半角空白，「+」，「-」，「\」，「$」，「*」になる場合は，”,”をその文字列に置き換えます。”,”を出力する書式記号を次に示します。 9 | Z | - | + | \ | $ | * | x
 | . | 区切り文字として指定位置に出力します。小数点以下の入力値がない場合は，右側の書式に従って変換します。 ”.”を出力する書式記号を次に示します。 9 | Z | - | + | \ | $ | * | x
 | - | <数値>を表します。入力値から符号を削除して負数の場合，「-」を一つ出力します。入力文字がない場合は，半角空白に置き換えて出力します。入力文字が数値以外の場合は，「?」を出力します。
 | + | <数値>を表します。入力値から符号を削除して正数の場合は「+」を一つ，負数の場合は「-」を一つ出力します。0の場合は符号を出力しません。入力文字がない場合は，半角空白に置き換えて出力します。入力文字が数値以外の場合は，「?」を出力します。
 | \ | <数値>を表します。数値の先頭に「\」を一つ出力します。入力文字がない場合は，半角空白に置き換えて出力します。入力文字が数値以外の場合は，「?」を出力します。
 | $ | <数値>を表します。数値の先頭に「$」を一つ出力します。入力文字がない場合は，半角空白に置き換えて出力します。入力文字が数値以外の場合は，「?」を出力します。
 | * | <数値>を表します。入力文字がない場合は，「*」に置き換えて出力します。入力文字が数値以外の場合は，「?」を出力します。
 | x | <数値>を表します。出力結果の先頭が数字になる場合は，先頭に「*」を一つ出力します。入力文字がない場合は半角空白に置き換えて出力します。入力文字が数値以外の場合は，「?」を出力します。
 | 9(n) | n個の<数値>を表します。入力文字がない場合は，0に置き換えて出力します。 nは1から999までの数値を指定します。
 | Z(n) | n個の<数値>を表します。入力文字がない，または0の場合は半角空白に置き換えて出力します。 nは1から999までの数値を指定します。
 | -(n) | n個の<数値>を表します。入力値から符号を削除して負数の場合，「-」を一つ出力します。入力文字がない場合は，半角空白に置き換えて出力します。 nは1から999までの数値を指定します。
 | +(n) | n個の<数値>を表します。入力値から符号を削除して正数の場合は「+」を一つ，負数の場合は「-」を一つ出力します。0の場合は符号を出力しません。入力文字がない場合は，半角空白に置き換えて出力します。 nは1から999までの数値を指定します。
 | \(n) | n個の<数値>を表します。数値の先頭に「\」を一つ出力します。入力文字がない場合は，半角空白に置き換えて出力します。 nは1から999までの数値を指定します。
 | $(n) | n個の<数値>を表します。数値の先頭に「$」を一つ出力します。入力文字がない場合は，半角空白に置き換えて出力します。 nは1から999までの数値を指定します。
 | *(n) | n個の<数値>を表します。入力文字がない場合は，「*」に置き換えて出力します。 nは1から999までの数値を指定します。
 | x(n) | n個の<数値>を表します。出力結果の先頭が数字になる場合は，先頭に「*」を一つ出力します。入力文字がない場合は半角空白に置き換えて出力します。 nは1から999までの数値を指定します。
文字書式と数値書式の両方で設定できる記号 | 固定文字列 | 文字列は""で囲んで記述します。"を文字列として挿入する場合は，""""と指定します。固定文字列は，書式適用後に書式で指定された位置へ挿入します。挿入位置が変換文字列の長さよりも大きい場合は，変換文字列の末尾に固定文字を挿入します。

なお，表中の<数値>の定義を次に示します。

表13‒3 書式記号の定義
書式記号 | 定義
<数値> | [<符号>]<絶対値>を示します。 <絶対値> = <整数部>[<小数点>[<小数部>]] <整数部> = <数字> <小数部> = <数字> <小数点> =”.” <符号> = + | - <数字> = [0-9]

ページの先頭へ

(2)　書式記号を指定するときの規則

書式記号を指定するときは次の規則があります。

(a)　書式記号で表現するフォーマット

書式記号で表現するフォーマットは最大4,095文字とします。フォーマットの文字数は，nに指定した数値をすべて展開した文字数と固定文字列数の合計です。

固定文字列を囲む""は，4,095文字には数えません。また，固定文字列の"は，展開後の文字数で数えるため，""2文字は"1文字になります。サロゲートペアは，1文字分で数えます。

(b)　［書式記号］テキストボックスで設定できる文字数

［書式記号］テキストボックスで設定できる文字数は，最大506文字とします。書式記号に指定されているすべての文字を数えます。固定文字列を囲む""や，n個指定(n)の括弧も数えます。サロゲートペアは，2文字分として数えます。

ただし，［書式オプション］グループボックスでオプションを一つ指定するごとに，設定できる文字数は少なくなります。

指定するオプションごとの減少する文字数を，次の表に示します。

［書式オプション］グループボックスの指定 |  | 減少する文字数
［データ長］コンボボックスを設定 | 「データ長＞書式の場合，"?"を表示」を選択 | 2
 | 「データ長＜書式の場合，"?"を表示」を選択 | 2
 | 「データ長≠書式の場合，"?"を表示」を選択 | 4
［適用方向］コンボボックスを設定 |  | 2
［空白削除］コンボボックスを設定 |  | 2
［ゼロ削除］コンボボックスを設定 |  | 2
［Z書式での０出力］チェックボックスを設定 |  | 2
［符号が入らない場合，"，"を削除］チェックボックスを設定 |  | 2
［0以外の数字の先頭に符号を出力］チェックボックスを設定 |  | 2

(c)　文字書式を選択した場合の注意事項

文字書式を選択した場合，次の注意事項があります。

  • ”X”，”N”および”C”は同時に指定できません。例えば，”CCX”は指定できません。

(d)　数値書式を選択した場合の注意事項

［適用方向］コンボボックスの選択によって，次の注意事項があります。

「指定なし」または「右から適用」を選択した場合

  • 数値書式では”.”は複数指定できません。例えば，”999.999.999”は指定できません。

  • 数値書式の整数部では，次に示す書式記号が指定できます。

    ”9”，”Z”，”\”，”$”，”*”，”x”，”-”，”+”，”,”

  • 数値書式の整数部では，次に示す書式記号は混在して指定できません。

    ”Z”，”\”，”$”，”*”，”x”，”-”，”+”

  • 数値書式の整数部では，先頭と末尾に”,”は指定できません。

  • 数値書式の整数部では，”,”を連続して指定できません。

  • 数値書式の整数部では，先頭に”9”を指定したときは，”9”または”,”が指定できます。

  • 数値書式の整数部では，先頭に”\”を指定したときは，”\”，”9”または”,”が指定できます。

    ”\”は，先頭から連続する形以外では指定できません。ただし，”,”で区切ることはできます。

    数値書式で設定できるほかの書式記号”Z”，”$”，”*”，”x”，”-”および”+”も”\”と同じ規則を適用します。例えば，”\\\,\\9”は指定できますが，”\\\,\9\”，”999,99\”は指定できません。

  • 数値書式の小数部では，”9”，”Z”および”,”が指定できます。

  • 数値書式の小数部では，先頭と末尾に”,”は指定できません。

  • 数値書式の小数部では，”,”を連続で指定できません。

  • 数値書式の小数部では，先頭に”Z”を指定したときは，”Z”または”，”が指定できます。

    ”9”は先頭から連続する形以外では指定できません。ただし，”,”で区切ることはできます。例えば”999,99Z”は指定できますが，”999,9Z9”，”ZZZ,ZZ9”は指定できません。

「左から適用」を選択した場合

  • ”.”と”,”は指定できません。例えば，”999.999”や”999,999”は指定できません。

  • 次に示す書式記号が指定できます。

    ”9”，”Z”，”\”，”$”，”*”，”x”，”-”，”+”

    ただし，混在して指定できません。例えば，”99999”は指定できますが，”ZZZZ9”や”+9999”は指定できません。

ページの先頭へ

(3)　書式の指定例

書式の指定例を次に示します。

表13‒4 書式の指定例
［書式種別］コンボボックス | ［書式オプション］グループボックス | ［書式記号］テキストボックス | 入力データ | 出力結果
文字書式 | － | "〒"XXX"-"XXXX | 1234567 | 〒123-4567
 | － | XX":"XX | A | A△:△△
 | ［適用方向］コンボボックスで「右から適用」を選択 | XX":"XX | A | △△:△A
 | － | N(2)"/"N(2) | サンプル | サン/プル
 | － | N(2)"/"N(2) | サンプ | サン/プ△
 | － | N(2)"/"N(2) | サン | サン/△△
 | － | N(2)"/"N(2) | サ | サ△/△△
 | － | X(3)"/"X(2) | SAM | SAM/△△
 | － | X(3)"/"X(2) | SA | SA△/△△
 | － | X(3)"/"X(2) | S | S△△/△△
 | － | CCCCC | ABCDE | ABCDE
 | － | CCCCC | ABCあ | ABCあ
 | － | CCCC | ABC | ABC△
 | － | CCCC | ABCあ | ABC△
 | ［データ長］コンボボックスで「データ長＞書式の場合，"?"を表示」を選択 | CCCC | ABCあ | ????
 | ［データ長］コンボボックスで「データ長＜書式の場合，"?"を表示」を選択 | CCCC | ABC | ????
 | ［空白削除］コンボボックスで「左の空白を削除」を選択 | N(10) | △△△サンプル△△△ | サンプル△△△
 | ［空白削除］コンボボックスで「右の空白を削除」を選択 | N(10) | △△△サンプル△△△ | △△△サンプル
 | ［空白削除］コンボボックスで「左右の空白を削除」を選択 | N(10) | △△△サンプル△△△ | サンプル
数値書式 | ［適用方向］コンボボックスで「左から適用」を選択 | 99":"99 | 5 | 50:00
 | － | 999999 | 003456 | 003456
 | － | 999,999 | 003456 | 003,456
 | ［ゼロ削除］コンボボックスで「左の０を削除」を選択 | 999 | 000123000 | 000
 | ［ゼロ削除］コンボボックスで「右の０を削除」を選択 | 999 | 000123000 | 123
 | ［ゼロ削除］コンボボックスで「左右の０を削除」を選択 | 999 | 000123000 | 123
 | － | ZZZZZZ | 003456 | △△3456
 | － | Z(6) | 003456 | △△3456
 | － | Z(6).ZZ | 003456.30 | △△3456.3△
 | － | Z(6).ZZ | 00345630 | 345630△△△
 | － | ZZZ,ZZZ | -123456 | 123,456
 | ［符号が入らない場合，"，"を削除］チェックボックスをオン | ZZZ,ZZZ | -123456 | -123456
 | ［Z書式での０出力］チェックボックスをオン | ZZZZZZ | 000123 | 000123
 | ［0以外の数字の先頭に符号を出力］チェックボックスをオン | 99999 | -123 | 0-123
 | － | 99999 | 100000 | 00000
 | － | \999999 | 150000 | \150000
 | － | \999,999 | 150000 | \150,000
 | － | $999,999 | 150000 | $150,000
 | － | +999999 | +050000 | +050000
 | － | -999999 | -050000 | -050000
 | － | ******9 | 1000 | ***1000
 | － | ******9 | -1000 | **-1000
 | － | xxxxx9 | 5000 | △*5000
 | － | xxxxx9 | -5000 | △-5000
（凡例）

－：すべて「指定なし」を選択します。

△：半角空白または全角空白を示します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 258 / 356


13.3 数値データのプロパティを設定する : EUR 帳票作成 操作ガイド

  • 259 / 356

  • 表紙

  • 13.　アイテムのプロパティとオプションを設定する

  • 13.3　数値データのプロパティを設定する

13.3　数値データのプロパティを設定する

数値データは，次の表に示すプロパティを設定したり，変更したりできます。集計行の場合は，集計行編集モードにしてから，操作してください。それぞれのタブの詳細については，マニュアル「EUR 帳票作成 画面リファレンス」を参照してください。

表13‒5 数値データのプロパティ設定
プロパティの設定 | 設定するタブ名
項目の見出し名 | ［データ］タブ※1
前付加文字／後付加文字の設定※1 | ［表示形式］タブ
ゼロ埋めの桁数
負符号文字の指定
コンマの表示
指数の表示
小数点以下の桁数の指定
「0」，または空データの「-（ハイフン）」表示
アイテムの配置（縦位置，横位置） | ［配置］タブ
文字の変更（フォント・スタイル・サイズ・色） | ［フォント］タブ
フォントの縦横比の補正
文字の修飾（下線）
文字間隔の変更 | ［文字配置］タブ
文字方向の変更
アイテムの桁数の指定
縮小して全体を表示
ワードラップを行う
アイテムの表示位置の変更 | ［位置・サイズ］タブ
アイテムのサイズの変更
数値を置き換えて表示 | ［置き換え表］タブ
出力ページの指定 | ［出力ページ］タブ※2
注※1

数値データを単一選択したとき，表示されます。集計アイテムの数値データでは表示されません。

注※2

数値データが繰り返し対象でないとき，表示されます。数値データが繰り返し対象のとき，または集計アイテムの数値データであるときは表示されません。

重要

  • アイテム枠内の桁数を設定するときの注意

    ［アイテムのプロパティ］ダイアログの［文字配置］タブで，［桁数を指定］のチェックボックスがオンの場合は，設定されている前付加文字，後付加文字，負符号文字なども桁数に数えられます。

    帳票にアイテムの桁数を設定した場合，入力されるデータの桁数がアイテム枠を超えると，データの入力時にエラーは表示されませんが，印刷時にエラーを表示して中断されます。帳票を定義するときは，入力されるデータの最大桁数を考慮して，アイテムの桁数を設定してください。

  • EUR サーバ帳票出力機能でCSVファイルに出力するときの注意

    小数点文字に何も指定されていない帳票を，プリンタから印刷した場合は，「nnn △ n（△は半角空白）」のように，小数点文字が半角空白に置き換わります。しかし，CSVファイルに出力した場合は，小数点文字の部分を詰めて出力されるため，整数部分と小数部分が区別できません。EUR サーバ帳票出力機能でCSVファイルに出力する場合は，帳票設計時に小数点文字を指定するか，またはEUR サーバ帳票出力機能の環境変数EURPS_CSV_PRINT_PERIODにYESを設定しておくと，小数点文字「.」を挿入して出力できます。環境変数EURPS_CSV_PRINT_PERIODについては，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

〈この節の構成〉

  • 13.3.1　補足説明

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 259 / 356


13.3.1 補足説明 : EUR 帳票作成 操作ガイド

  • 260 / 356

  • 表紙

  • 13.　アイテムのプロパティとオプションを設定する

  • 13.3　数値データのプロパティを設定する

  • 13.3.1　補足説明

13.3.1　補足説明

  • 数値データには有効桁数の制限はありませんが，プロパティを変更することで桁数が大きくなり，アイテム枠の表示領域を超える場合は，「***…*」のように表示されます。アイテム枠をリサイズしてください。

  • 集計アイテムの数値データの有効桁数は，小数点以下桁揃えの指定に関係なく15桁までです。集計結果が，有効桁数の15桁を超える場合は，集計する数値の整数部の桁数によって，集計行に表示される数値の小数部の内容が異なるなど，正しく印刷されません。

  • 小数点以下のデータがある場合，集計行は浮動小数点演算しますので，小数点以下の桁揃えを指定してください。

  • 文字間隔が狭い場合，指定した文字のサイズが文字間隔を超える（左右の文字が重なる）ようなサイズであるときは，文字を描画しません。また，行間隔が狭い場合，指定した文字のサイズが行間を超える（上下の文字が重なる）ようなサイズであるときも，文字を描画しません。

  • 出力プリンタによって，文字間隔や行間隔を狭くした場合は，正しく印刷されないことがあります。

  • フォントやサイズを設定することで，実行する環境によっては，帳票が正しく印刷されなかったり，表示されなかったりする場合があります。また，指定されているフォントによっては，［文字配置］を設定した帳票が，実行する環境で正しく印刷されなかったり，表示されなかったりすることもあります。詳細は，「14.3.1(1)　フォントに関する注意」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 260 / 356


13.4 線アイテムのプロパティを設定する : EUR 帳票作成 操作ガイド

  • 261 / 356

  • 表紙

  • 13.　アイテムのプロパティとオプションを設定する

  • 13.4　線アイテムのプロパティを設定する

13.4　線アイテムのプロパティを設定する

線アイテムは，次の表に示すプロパティを設定したり，変更したりできます。それぞれのタブの詳細については，マニュアル「EUR 帳票作成 画面リファレンス」を参照してください。

表13‒6 線アイテムのプロパティ設定
プロパティの設定 | 設定するタブ名
線種・線色の変更 | ［線］タブ
線の太さの変更
繰り返し線の指定
繰り返し外枠線の指定
アイテムの表示位置の変更 | ［位置・サイズ］タブ
アイテムのサイズの変更
出力ページの指定 | ［出力ページ］タブ

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 261 / 356


13.5 図形アイテムのプロパティを設定する : EUR 帳票作成 操作ガイド

  • 262 / 356

  • 表紙

  • 13.　アイテムのプロパティとオプションを設定する

  • 13.5　図形アイテムのプロパティを設定する

13.5　図形アイテムのプロパティを設定する

帳票に配置した角丸四角アイテム，円／楕円アイテム，または多角形アイテムは，次の表に示すプロパティを設定したり，変更したりできます。また，枠で囲むほかに，網を掛けたり，枠の線種や線色を変えたりすることもできます。

それぞれのタブの詳細については，マニュアル「EUR 帳票作成 画面リファレンス」を参照してください。

表13‒7 図形アイテムのプロパティ設定
プロパティの設定 | 設定するタブ名
模様の変更 | ［図形］タブ
背景色の変更
前景色の変更
角丸め（角丸四角アイテムの場合だけ）
繰り返し網掛けの指定
枠線の表示（枠線種・枠線色の指定）
影付きの指定
アイテムの表示位置の変更 | ［位置・サイズ］タブ
アイテムのサイズの変更
出力ページの指定 | ［出力ページ］タブ
〈この節の構成〉

  • 13.5.1　n行間隔ごとに網を掛けたい場合

  • 13.5.2　網掛けの色を設定したい場合

  • 13.5.3　図形アイテムに影を付けたい場合

  • 13.5.4　角丸四角アイテムの角丸めをなくしたい場合

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 262 / 356


13.5.1 n行間隔ごとに網を掛けたい場合 : EUR 帳票作成 操作ガイド

  • 263 / 356

  • 表紙

  • 13.　アイテムのプロパティとオプションを設定する

  • 13.5　図形アイテムのプロパティを設定する

  • 13.5.1　n行間隔ごとに網を掛けたい場合

13.5.1　n行間隔ごとに網を掛けたい場合

網掛け領域を繰り返し指定の対象にすると，全レコードが同じパターンの網掛けになります。この網掛けをn行ごとに設定できます。

先頭レコードの網パターンを［模様］のリストボックスから，次の行の網パターンを［繰り返し網掛け］の［繰り返し模様］のリストボックスから選択します。［n個ごと］のチェックボックスをオンにして，網掛け間隔の行数を入力します。指定できる個数は，2～32,767です。例えば，［模様］から「濃い網掛け」，［繰り返し網掛け］の［繰り返し模様］から「透明」を選択して，［n個ごと］のチェックボックスをオンにして，「2」個ごとに設定すると，網掛け，網掛けなし，網掛け，網掛けなし…のようにできます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 263 / 356


13.5.2 網掛けの色を設定したい場合 : EUR 帳票作成 操作ガイド

  • 264 / 356

  • 表紙

  • 13.　アイテムのプロパティとオプションを設定する

  • 13.5　図形アイテムのプロパティを設定する

  • 13.5.2　網掛けの色を設定したい場合

13.5.2　網掛けの色を設定したい場合

網掛けに色を設定する場合は，［背景色］と［前景色］を設定します。文字列や表のセルに掛けられている網の色を変更する場合は，背景色に濃い色を設定すると，文字が見えにくくなりますので，［図形］タブのプレビューで確認してください。

［模様］に「塗りつぶし」が設定されていると，［前景色］の設定は無効になり，［背景色］の色で塗りつぶされます。また，［模様］に「透明」が設定されていると，［背景色］と［前景色］に色を設定しても，無効になります。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 264 / 356


13.5.3 図形アイテムに影を付けたい場合 : EUR 帳票作成 操作ガイド

  • 265 / 356

  • 表紙

  • 13.　アイテムのプロパティとオプションを設定する

  • 13.5　図形アイテムのプロパティを設定する

  • 13.5.3　図形アイテムに影を付けたい場合

13.5.3　図形アイテムに影を付けたい場合

［影付き］をオンにします。影の部分に色を付ける場合は，［模様］から［透明］以外の網パターンを選択します。色は黒の固定です。影の厚みは調整できません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 265 / 356


13.5.4 角丸四角アイテムの角丸めをなくしたい場合 : EUR 帳票作成 操作ガイド

  • 266 / 356

  • 表紙

  • 13.　アイテムのプロパティとオプションを設定する

  • 13.5　図形アイテムのプロパティを設定する

  • 13.5.4　角丸四角アイテムの角丸めをなくしたい場合

13.5.4　角丸四角アイテムの角丸めをなくしたい場合

角丸四角アイテムを配置すると，四隅がすべて角丸になります。角丸めの微調整は，マウス操作でできますが，四隅すべてが丸めの対象となるため，一部の角を直角にしたい場合は，角丸めのチェックボックスをオフにします。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 266 / 356


13.6 画像アイテムのプロパティを設定する : EUR 帳票作成 操作ガイド

  • 267 / 356

  • 表紙

  • 13.　アイテムのプロパティとオプションを設定する

  • 13.6　画像アイテムのプロパティを設定する

13.6　画像アイテムのプロパティを設定する

画像アイテムは，次の表に示すプロパティを設定したり，変更したりできます。

それぞれのタブの詳細については，マニュアル「EUR 帳票作成 画面リファレンス」を参照してください。

表13‒8 画像アイテムのプロパティ設定
プロパティの設定 | 設定するタブ名
項目の見出し名 | ［データ］タブ※1
アイテムの配置（縦位置，横位置） | ［配置］タブ
画像アイテムの表示補正 | ［画像］タブ
画像アイテムの変更
アイテムの表示位置の変更 | ［位置・サイズ］タブ
アイテムのサイズの変更
出力ページの指定 | ［出力ページ］タブ※2
注※1

画像データを単一選択したとき，表示されます。

注※2

画像データが繰り返し対象でないとき，表示されます。

〈この節の構成〉

  • 13.6.1　アイテム枠のサイズに合わせて表示したい場合

  • 13.6.2　画像ファイルを更新したが，帳票に貼り付けた画像ファイルに反映されない場合

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 267 / 356


13.6.1 アイテム枠のサイズに合わせて表示したい場合 : EUR 帳票作成 操作ガイド

  • 268 / 356

  • 表紙

  • 13.　アイテムのプロパティとオプションを設定する

  • 13.6　画像アイテムのプロパティを設定する

  • 13.6.1　アイテム枠のサイズに合わせて表示したい場合

13.6.1　アイテム枠のサイズに合わせて表示したい場合

画像データを貼り付けたあと，マウス操作などで画像アイテムのサイズを調整すると，縦横比がずれてしまうことがあります。［画像の縦横比を保持］のチェックボックスをオンにしておくと，縦横比を保持したまま，拡大したり，縮小したりできます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 268 / 356


13.6.2 画像ファイルを更新したが，帳票に貼り付けた画像ファイルに反映されない場合 : EUR 帳票作成 操作ガイド

  • 269 / 356

  • 表紙

  • 13.　アイテムのプロパティとオプションを設定する

  • 13.6　画像アイテムのプロパティを設定する

  • 13.6.2　画像ファイルを更新したが，帳票に貼り付けた画像ファイルに反映されない場合

13.6.2　画像ファイルを更新したが，帳票に貼り付けた画像ファイルに反映されない場合

帳票に固定画像として貼り付けられた画像ファイルは，帳票ファイルに埋め込まれてしまうため，画像ファイルを更新しても，同期を取れません。［再読み込み］してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 269 / 356


13.7 ページ番号アイテムのプロパティを設定する : EUR 帳票作成 操作ガイド

  • 270 / 356

  • 表紙

  • 13.　アイテムのプロパティとオプションを設定する

  • 13.7　ページ番号アイテムのプロパティを設定する

13.7　ページ番号アイテムのプロパティを設定する

ページ番号アイテムは，次の表に示すプロパティを設定したり，変更したりできます。

それぞれのタブの詳細については，マニュアル「EUR 帳票作成 画面リファレンス」を参照してください。

余白に設定したページ番号のプロパティ設定については，「4.5.2　余白にページ番号を配置する」を参照してください。

表13‒9 ページ番号アイテムのプロパティ設定
プロパティの項目 | 設定するタブ名
ページ番号の表示形式の変更 | ［表示形式］タブ
最大ページ桁数の変更
アイテムの配置（縦位置，横位置） | ［配置］タブ
文字の変更（フォント・スタイル・サイズ・色） | ［フォント］タブ
フォントの縦横比の補正
文字の修飾（下線）
文字間隔の変更 | ［文字配置］タブ
文字方向の変更
アイテムの桁数の指定
ワードラップを行う
アイテムの表示位置の変更 | ［位置・サイズ］タブ
アイテムのサイズの変更
出力ページの指定 | ［出力ページ］タブ
〈この節の構成〉

  • 13.7.1　補足説明

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 270 / 356


13.7.1 補足説明 : EUR 帳票作成 操作ガイド

  • 271 / 356

  • 表紙

  • 13.　アイテムのプロパティとオプションを設定する

  • 13.7　ページ番号アイテムのプロパティを設定する

  • 13.7.1　補足説明

13.7.1　補足説明

  • 桁数を指定することでページ番号がアイテム枠を超えて，ページ番号が表示，および印刷できない場合は，「***」が表示，および印刷されます。特に，帳票の設計時よりも印刷時にはデータ量が増加するため，注意してください。

  • 帳票ヘッダのある帳票で，帳票ヘッダ領域に位置固定のページ番号アイテムを挿入したあと，集計ページを作成すると，集計ページも同じ位置にページ番号アイテムが表示されます。しかし，集計ページに表示されているページ番号アイテムの表示形式は，表紙ページ，または次紙ページでページ番号アイテムの表示形式を変更しても変わりません。集計行編集モードで変更してください。

    帳票ヘッダのある帳票で，集計ページを作成したあと，帳票ヘッダ領域に位置固定のページ番号アイテムを挿入した場合，集計ページにはページ番号が表示されません。集計行編集モードで，集計ページにページ番号を設定してください。

  • フォントやサイズを設定することで，実行する環境によっては，帳票が正しく印刷されなかったり，表示されなかったりする場合があります。詳細は，「14.3.1(1)　フォントに関する注意」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 271 / 356


13.8 日付データのプロパティを設定する : EUR 帳票作成 操作ガイド

  • 272 / 356

  • 表紙

  • 13.　アイテムのプロパティとオプションを設定する

  • 13.8　日付データのプロパティを設定する

13.8　日付データのプロパティを設定する

日付データは，フィールド定義で設定した種別に応じてデータウィンドウや帳票（帳票ファイル）に表示されます。

日付データは，次の表に示すプロパティを設定したり，変更したりできます。

それぞれのタブの詳細については，マニュアル「EUR 帳票作成 画面リファレンス」を参照してください。

表13‒10 日付データのプロパティ設定
設定 | 設定できるタブ
項目の見出し名 | ［データ］タブ※1
種別（西暦・和暦） | ［表示形式］タブ
日付データの表示形式の変更
元号年1年を元年と表示する
アイテムの配置（縦位置，横位置） | ［配置］タブ
文字の変更（フォント・スタイル・サイズ・色） | ［フォント］タブ
フォントの縦横比の補正
文字の修飾（下線）
文字間隔の変更 | ［文字配置］タブ
文字方向の変更
アイテムの桁数の指定
ワードラップを行う
アイテムの表示位置の変更 | ［位置・サイズ］タブ
アイテムのサイズの変更
出力ページの指定 | ［出力ページ］タブ※2
注※1

日付データを単一選択したとき，表示されます。

注※2

日付データが繰り返し対象でないとき，表示されます。

〈この節の構成〉

  • 13.8.1　日付データの表示形式の設定

  • 13.8.2　元号年1年を元年表示する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 272 / 356


13.8.1 日付データの表示形式の設定 : EUR 帳票作成 操作ガイド

  • 273 / 356

  • 表紙

  • 13.　アイテムのプロパティとオプションを設定する

  • 13.8　日付データのプロパティを設定する

  • 13.8.1　日付データの表示形式の設定

13.8.1　日付データの表示形式の設定

フィールド定義の種別で，「日付（日付・時刻）」を設定した場合，レポートファイル形式とフォームシートファイル形式の違いがあります。また，この形式は，［アイテムのプロパティ］ダイアログ－［表示形式］タブの［表示形式一覧］リストボックス内にサンプルを表示していますが，［定義］テキストボックスには，次に示す形式の組み合わせによる設定もできます。

〈この項の構成〉

  • (1)　レポートファイル形式とフォームシートファイル形式の違い

  • (2)　日付データの定義情報の形式

  • (3)　レポートファイル形式の変換記号

  • (4)　フォームシートファイル形式の変換記号

  • (5)　日付データ・時刻データを使用するときの注意

(1)　レポートファイル形式とフォームシートファイル形式の違い

レポートファイル形式とフォームシートファイル形式では，次のような特徴があります。

  • レポートファイル形式

    • UNIX版 EUR旧製品との互換を意識しません。

    • 全角文字での数値表現ができません。

    • 時刻の表現ができます。

  • フォームシートファイル形式

    • UNIX版 EUR旧製品との互換を意識します。

    • 全角文字での数値表現ができます。

    • 時刻の表現ができません。

上記の特徴を考慮した上で，どちらの形式を設定するかを判断してください。また，ここで説明しているレポートファイル形式とフォームシートファイル形式の意味は，帳票ファイルを保存するときのファイル形式とは異なります。互換を意識しなければ，両方の表示形式を使用できます。

ページの先頭へ

(2)　日付データの定義情報の形式

日付データの表示形式は，"%"，変換記号，および任意の文字を組み合わせることで任意に指定できます。変換記号は，レポートファイル形式とフォームシートファイル形式とでは異なります。

  • レポートファイル形式の場合

    〔<前付加文字列>〕%〔-〕〔0〕<表示桁数><変換記号>〔<後付加文字列>〕

  • フォームシートファイル形式の場合

    〔<前付加文字列>〕%〔0〕〔#〕〔2〕<変換記号>〔<後付加文字列>〕

    指定する文字

    意　　　味

    <前付加文字列>

    データの前に付加する文字列を指定します。全角文字も指定できます。

    %

    書式の開始文字です。%は，省略できません。

    -

    レポートファイル形式で，文字列を左詰めで表示する場合に指定します。省略した場合は，右詰めで表示されます。

    0（ゼロ）

    データの桁数が，<表示桁数>に指定した桁数に満たない場合に，空いている場所を埋め文字0で埋めます。省略した場合は，空白になります。

    #

    フォームシートファイル形式で，桁空けするときに指定します。

    2

    フォームシートファイル形式の西暦表示で，年表示を2桁表示にするときに指定します。

    <表示桁数>

    データを表示する桁数を指定します。<表示桁数>は，省略できません。データの桁数が，<表示桁数>に指定した値に満たない場合は，埋め文字で埋めます。

    <変換記号>

    データの変換記号を指定します。データが，指定した形式に変換して表示されます。変換記号は，省略できません。変換記号は，レポートファイル形式とフォームシートファイル形式で異なります。

    <後付加文字列>

    データの後ろに付加する文字列を指定します。全角文字も指定できます。
重要

文字に"%"を表示する場合，レポートファイル形式とフォームシートファイル形式では次のような制限があります。

  • レポートファイル形式では，日付データに"%"を表示したいときは，"\%"と指定します。"\"を表示したいときは，"\\"と指定します。

  • フォームシートファイル形式では，日付データに"%"を表示したいときは，"%%"と指定します。

ページの先頭へ

(3)　レポートファイル形式の変換記号

レポートファイル形式の変換記号を，次に示します。

表13‒11 レポートファイル形式の変換記号
変換記号 | 意味 | 表示形式
Y※ | 西暦年 | －
M | 月 | －
D | 日 | －
h※ | 時刻 | 24時間制
H※ | 時刻 | 12時間制
m※ | 分 | －
s※ | 秒 | －
0u | 元号 | アルファベット1文字（M，T，S，H）
1u | 元号 | 漢字の省略形（明，大，昭，平）
2u | 元号 | 漢字（明治，大正，昭和，平成）
3u | 元号 | 和暦の年
0n | 月 | 省略した英文字（Jan，Febなど）
1n | 月 | 英文字（January，Februaryなど）
2n | 月 | 日本語（一月，二月など）
0N | 曜日 | 省略した英文字（Sun，Monなど）
1N | 曜日 | 英文字（Sunday，Mondayなど）
2N | 曜日 | 省略した日本語（月，火など）
3N | 曜日 | 日本語（月曜日，火曜日など）
0a※ | 午前または午後 | 英大文字（AM，PM）
1a※ | 午前または午後 | 英小文字（am，pm）
2a※ | 午前または午後 | 日本語（午前，午後）
（凡例）

－：該当する項目はありません。

注※

フィールド定義の種別で，「和暦（日次）」，「和暦（月次）」および「和暦（年次）」を設定した場合，使用できません。

重要

  • レポートファイル形式では，数値を全角文字で表示できません。

ページの先頭へ

(4)　フォームシートファイル形式の変換記号

フォームシートファイル形式の変換記号は，西暦か和暦かによって次のように異なります。

(a)　西暦の変換記号

西暦の場合の変換記号を次に示します。

表13‒12 西暦の変換記号
変換記号 （全角文字） | 意味 | 表示形式 （全角文字） | 備考
DY（ＤＹ） | 西暦年 | 1～9999 （１～９９９９） | 1月始まり
DM（ＤＭ） | 月 | 1～12 （１～１２） | －
DD（ＤＤ） | 日 | 1～31 （１～３１） | －
DF（ＤＦ） | 西暦年度 | 1～9999 （１～９９９９） | 4月始まり
CH（ＣＨ） | 暦年半期 | 1～2 （１～２） | 1（1-6月），2（7-12月）
CQ（ＣＱ） | 暦年四半期 | 1～4 （１～４） | 1（1-3月），2（4-6月）， 3（7-9月），4（10-12月）
H1 | 暦年半期 | 上期，下期 | 上期（1-6月）， 下期（7-12月）
（凡例）

－：該当する項目はありません。

重要

  • フォームシートファイル形式では，変換記号を全角文字で指定すると，数値が全角文字で表示されます。

  • 英語ロケールおよび中国語ロケールでは，フォームシートファイル形式は表示できません。

  • フィールド定義の種別で，「和暦（日次）」，「和暦（月次）」および「和暦（年次）」を設定した場合，西暦の変換記号は無効となります。

(b)　和暦の変換記号

和暦の場合の変換記号を次に示します。

表13‒13 和暦の変換記号
変換記号 （全角文字） | 意味 | 表示形式 （全角文字） | 備考
DM（ＤＭ） | 月 | 1～12 （１～１２） | －
DD（ＤＤ） | 日 | 1～31 （１～３１） | －
JY（ＪＹ） | 和暦 | 1～9999 （１～９９９９） | 1月始まり
JF（ＪＦ）※ | 和暦年度 | 1～9999 （１～９９９９） | 4月始まり
FH（ＦＨ）※ | 年度半期 | 1～2 （１～２） | 1（4-9月），2（10-3月）
FQ（ＦＱ）※ | 年度四半期 | 1～4 （１～４） | 1（4-6月），2（7-9月）， 3（10-12月），4（1-3月）
YA※ | 年度元号1 | M，T，S，H | 4月始まり
YB※ | 年度元号2 | Ｍ，Ｔ，Ｓ，Ｈ | 4月始まり
YC※ | 年度元号3 | 明，大，昭，平 | 4月始まり
YD※ | 年度元号4 | 明治，大正，昭和，平成 | 4月始まり
Y1 | 元号1 | M，T，S，H | －
Y2 | 元号2 | Ｍ，Ｔ，Ｓ，Ｈ | －
Y3 | 元号3 | 明，大，昭，平 | －
Y4 | 元号4 | 明治，大正，昭和，平成 | －
HA※ | 年度半期 | 上期，下期 | 上期（4-9月）， 下期（10-3月）
（凡例）

－：該当する項目はありません。

注※

フィールド定義の種別で，「和暦（日次）」，「和暦（月次）」および「和暦（年次）」を設定した場合，年度表示は使用できません。年度の変換記号を指定すると，指定した変換記号が表示されます。

重要

  • フォームシートファイル形式では，変換記号を全角文字で指定すると，数値が全角文字で表示されます。

  • 英語ロケールおよび中国語ロケールでは，フォームシートファイル形式は表示できません。

(c)　補足説明

フィールドの属性が年次や月次である場合，その期種に関係ない記号を変換記号に設定すると，「1月」，「1日」が仮定されます。また，指定する変換記号と入力する日付データが合っていない場合も，「1月」，「1日」が仮定されます。例えば，変換記号「DF（ＤＦ）」や「JF（ＪＦ）」を指定して年度表示する場合は，入力する日付データが日次（8桁），または月次（6桁）で指定されていないと，正しい年度表示ができません。次のように表示されます。

入力する日付データ | 変換記号「DF（ＤＦ）」指定後の西暦年度表示 | 変換記号「JF（ＪＦ）」指定後の和暦年度表示
20080320 | 2007 | 19
200803 | 2007 | 19
20080523 | 2008 | 20
200805 | 2008 | 20

ページの先頭へ

(5)　日付データ・時刻データを使用するときの注意

日付データ・時刻データを帳票設計時と異なるロケールで出力する場合，次のことに注意してください。

  • 次の変換記号はロケールに応じて変換されるため，帳票を定義したロケールと表示または印刷するロケールが異なる場合，出力結果が異なります。

    レポートファイル形式：2n（月），2N（省略形の曜日），3N（曜日），2a（午前/午後）

  • 元号表記や元年表示など日本語特有の変換記号や，フォームシートファイル形式の変換記号は，実行するロケールに関係なく日本語に変換されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 273 / 356


13.8.2 元号年1年を元年表示する : EUR 帳票作成 操作ガイド

  • 274 / 356

  • 表紙

  • 13.　アイテムのプロパティとオプションを設定する

  • 13.8　日付データのプロパティを設定する

  • 13.8.2　元号年1年を元年表示する

13.8.2　元号年1年を元年表示する

元号年1年を「元年」と表示するには，日付データ，または印刷日付アイテムを選択したあと，次のように設定します。選択した日付データ，または印刷日付アイテムの値が「1」であれば，「元」と表示されます。

  • ［アイテムのプロパティ］ダイアログの［表示形式］タブ

    ［元号年1年を元年と表示する］チェックボックスをオンにします。

  • 日付データの定義情報の形式に指定する変換記号

    • レポートファイル形式のとき

      変換記号

      意味

      3u

      元号が和暦の年で表示されます。

    • フォームシートファイル形式のとき

      変換記号

      （全角文字）

      意味

      表示形式（全角文字）

      備考

      JY（ＪＹ）

      和暦

      1～9999（１～９９９９）

      1月始まり

      JF（ＪＦ）

      和暦年度

      1～9999（１～９９９９）

      4月始まり
〈この項の構成〉

  • (1)　補足説明

(1)　補足説明

  • 文字間隔が狭い場合，指定した文字のサイズが文字間隔を超える（左右の文字が重なる）ようなサイズであるときは，文字を描画しません。また，行間隔が狭い場合，指定した文字のサイズが行間を超える（上下の文字が重なる）ようなサイズであるときも，文字を描画しません。

  • 出力プリンタによって，文字間隔や行間隔を狭くした場合は，正しく印刷されないことがあります。

  • 英語ロケールおよび中国語ロケールでは，元号表示は使用できません。

  • フォントやサイズを設定することで，実行する環境によっては，帳票が正しく印刷されなかったり，表示されなかったりする場合があります。また，指定されているフォントによって，［文字配置］を設定した帳票が，実行する環境で正しく印刷されなかったり，表示されなかったりすることもあります。詳細は，「14.3.1(1)　フォントに関する注意」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 274 / 356


13.9 バーコードアイテムのプロパティを設定する : EUR 帳票作成 操作ガイド

  • 275 / 356

  • 表紙

  • 13.　アイテムのプロパティとオプションを設定する

  • 13.9　バーコードアイテムのプロパティを設定する

13.9　バーコードアイテムのプロパティを設定する

バーコードアイテムは，次の表に示すプロパティを設定したり，変更したりできます。

表13‒14 ［バーコード］タブでできる設定
バーコードの種類 | JAN標準/UPC-A | JAN短縮/UPC-E | CODE39 | CODE128 | NW-7 | ITF | カスタマバーコード | QRコード
サイズ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ×
高さ | ○ | ○ | ○ | ○ | ○ | ○ | × | ×
入力データ形式 | × | × | × | ○ | × | × | × | ○
回転角度 | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
チェックキャラクタを付加する | ○ | ○ | ○ | － | ○ | ○ | ○ | ×
スタート/ストップキャラクタを付加する | － | － | ○ | － | ○ | － | ○ | ×
FNC1を付加する | × | × | × | ○ | × | × | × | ×
カスタマバーコードのデータ形式 | × | × | × | × | × | × | ○ | ×
データキャラクタを表示する | ○ | ○ | ○ | ○※1 | ○ | － | × | ×
表示文字を認識する | × | × | × | ○※2 | × | ○ | × | ×
機能コードをエスケープシーケンスで指定する | × | × | × | ○※2 | × | ○ | × | ×
最大行数 | × | × | × | ○ | × | ○ | × | ×
訂正レベル | × | × | × | × | × | × | × | ○
バージョン | × | × | × | × | × | × | × | ○
セルサイズ | × | × | × | × | × | × | × | ○
（凡例）

○：指定できます。

×：指定できません。

－：固定（オン）です。

注※1

バーコードCODE128は，データキャラクタの行数も指定できます。ただし，バージョン04-07以前のEURで貼り付けられたバーコードCODE128には，設定できません。

注※2

バージョン04-07以前のEURで貼り付けられたバーコードCODE128には，設定できません。

重要

  • ［バーコード形式］での［サイズ］，および［高さ］は，読み込みリーダで読めるかどうかを確認してから使用されることをお勧めします。読み込みリーダによっては，読めない場合があるので，確認が必要です。

  • QRコードは，型番が大きくなるとセルサイズが小さくなります。そのため，読み込みリーダによっては，読めない場合があります。指定するデータには，最大長を指定した確認が必要です。

各種バーコードに指定できるサイズや，指定したサイズによって，バーコードのアイテム枠の幅をどれぐらい確保すればよいかについては，マニュアル「EUR システム設計ガイド」を参照してください。

〈この節の構成〉

  • 13.9.1　データキャラクタのフォントの変更

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 275 / 356


13.9.1 データキャラクタのフォントの変更 : EUR 帳票作成 操作ガイド

  • 276 / 356

  • 表紙

  • 13.　アイテムのプロパティとオプションを設定する

  • 13.9　バーコードアイテムのプロパティを設定する

  • 13.9.1　データキャラクタのフォントの変更

13.9.1　データキャラクタのフォントの変更

編集中の帳票に貼り付けてあるバーコードに表示する，データキャラクタのフォントを変更できます。指定されているフォントによっては，帳票が実行する環境で正しく印刷されなかったり，表示されなかったりする場合があります。詳細は，「14.3.1(1)　フォントに関する注意」を参照してください。

〈この項の構成〉

  • (1)　JAN標準/UPC-A，JAN短縮/UPC-E，CODE39，NW-7，ITF，カスタマバーコードのフォントを変更する

  • (2)　CODE128のフォントを変更する

(1)　JAN標準/UPC-A，JAN短縮/UPC-E，CODE39，NW-7，ITF，カスタマバーコードのフォントを変更する

  1. ［レポートのプロパティ］ダイアログの表示

    ［ファイル］－［プロパティ］を選択します。［レポートの構成］タブを選択します。

  2. 使用するフォントの設定

    データキャラクタのフォントを選択します。選択できるフォントは，縦書きフォントを除くすべてです。デフォルトは，「ＭＳ Ｐ明朝」です。

ページの先頭へ

(2)　CODE128のフォントを変更する

  1. バーコードアイテムの選択

    データキャラクタのフォントを変更する，バーコードCODE128を選択します。

  2. ［アイテムのプロパティ］ダイアログの［データキャラクタ］タブの表示

    ［編集］－［アイテムのプロパティ］を選択します。［データキャラクタ］タブは，バーコードCODE128を選択したときだけ指定できます。

  3. 変更するフォント属性の設定

    データキャラクタのフォント属性を設定します。

    フォント名：

    縦書きフォントを除くすべてのフォントと，可変ピッチのフォントを設定できます。デフォルトは，「ＭＳ Ｐ明朝」です。

    サイズ：

    使用するフォントのサイズを選択します。デフォルトは，「9」です。

    縦位置：

    データキャラクタを，バーコード部からどのくらい離して表示するかを指定します。単位は，「mm」です。値は，小数点以下1桁（nn.n形式）でも指定できます。デフォルトは，「0（mm）」です。

    横位置：

    データキャラクタの表示位置を，「中央」，または「左寄せ」のどちらかで設定します。デフォルトは，「中央」です。

    データに改行コードがある場合は，改行コードの位置でデータを折り返し，最大文字数の行に合わせて表示されます。

    中央

    バーコードシンボルの幅中央を基準にして，データキャラクタが表示されます。

    左寄せ

    バーコード部の左端から，データキャラクタが表示されます。

    データキャラクタが，バーコードシンボルの幅より長い場合は，アイテム枠を超えて表示されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 276 / 356


13.10 部品のプロパティを設定する : EUR 帳票作成 操作ガイド

  • 277 / 356

  • 表紙

  • 13.　アイテムのプロパティとオプションを設定する

  • 13.10　部品のプロパティを設定する

13.10　部品のプロパティを設定する

部品は，次の表に示すプロパティを設定したり，変更したりできます。

表13‒15 部品のプロパティ設定
プロパティの設定 | 設定するタブ名
部品の表示位置の変更 | ［位置・サイズ］タブ
部品のサイズの変更
部品名・部品ID・コメントの設定 | ［情報］タブ

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 277 / 356


13.11 帳票のオプションを設定する : EUR 帳票作成 操作ガイド

  • 278 / 356

  • 表紙

  • 13.　アイテムのプロパティとオプションを設定する

  • 13.11　帳票のオプションを設定する

13.11　帳票のオプションを設定する

EUR 帳票作成機能を初めて起動したときは，帳票を定義するために，あらかじめ次に示す情報が設定されています。

表13‒16　デフォルトオプションの設定

タブ名

項目

設定されているデフォルト

表示

ウィンドウ

ステータスバーを表示

表示項目の設定

編集中に画像を表示する

座標の原点

用紙の左上

使用する単位

ミリメートル（mm）

文字幅計算方法

固定ピッチフォント出力時に，フォントの文字幅を固定値として計算する（［静的］ラジオボタンがオン）

配置

グリッド

幅2mm，高さ2mm（原点：幅10mm，高さ10mm）

アイテムをグリッド補正する

グリッド補正する（「アイテムをグリッド補正する」のチェックがオン）

フォントによるリサイズを行う

フォントをリサイズしない（「フォントによるリサイズを行う」のチェックがオフ）

バーコードのサイズ変更によるリサイズを行う

バーコードをリサイズする（「バーコードのサイズ変更によるリサイズを行う」のチェックがオン）

文字

フォント名

英語ロケールの場合：Lucida Console

中国語ロケールの場合：新宋体

日本語ロケールの場合：ＭＳ 明朝

スタイル

標準

サイズ

12

水平方向

中央

垂直方向

中央

文字配置

バージョン2以前の文字配置を行う

バージョン2以前の文字配置を行わない（「バージョン2以前の文字配置を行う」のチェックがオフ）

間隔

文字間隔（標準，0pt），行間隔（標準，0pt）

線

線種

[図データ]

図形

模様

[図データ]

画像

表示補正

アイテムに合わせて拡大/縮小

水平方向

左寄せ

垂直方向

上寄せ

バーコード

バーコード形式

種類：JAN標準/UPC-A　サイズ：1倍　高さ：24.5mm

データ形式

チェックキャラクタを付加しない（「チェックキャラクタを付加する」のチェックがオフ）

データキャラクタを表示する

データキャラクタを表示する（「データキャラクタを表示する」のチェックがオン）

ファイル

ファイルの種類
一時フォルダ以外：

インストール先フォルダ\Sample\Reports下

一時フォルダ：

C:\Users\<ログインユーザ>\AppData\temp

データウィンドウ

フォント名

MS ゴシック

サイズ

9

帳票を定義するための環境を設定しておく場合や，設定されているデフォルト値を変更する場合は，［オプション］ダイアログで設定します。［オプション］ダイアログは，［ツール］－［オプション］を選択すると表示できます。よく利用する文字，線，網パターンなどをあらかじめ設定しておくことで，帳票を定義する時の手間が少なくなります。

［オプション］ダイアログについては，マニュアル「EUR 帳票作成 画面リファレンス」を参照してください。

［オプション］ダイアログで設定した情報は，EUR 帳票作成機能を使用するマシン環境に保持されるため，次回起動した時も有効になります。

個別に変更したい場合は，変更したいアイテムを選択したあと，［編集］－［アイテムのプロパティ］を選択します。

〈この節の構成〉

  • 13.11.1　デフォルトに使用する文字の設定

  • 13.11.2　文字間隔と行間隔の設定

  • 13.11.3　デフォルトに使用する線の設定

  • 13.11.4　デフォルトに使用する網パターンの設定

  • 13.11.5　使用する単位のデフォルト設定

  • 13.11.6　画像の表示補正の設定

  • 13.11.7　デフォルトに使用するバーコードの設定

  • 13.11.8　フォントによるリサイズの設定

  • 13.11.9　バーコードのリサイズの設定

  • 13.11.10　編集中の画像表示の設定

  • 13.11.11　ファイルの保存場所のデフォルト設定

  • 13.11.12　文字幅計算方法の設定

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 278 / 356


13.11.1 デフォルトに使用する文字の設定 : EUR 帳票作成 操作ガイド

  • 279 / 356

  • 表紙

  • 13.　アイテムのプロパティとオプションを設定する

  • 13.11　帳票のオプションを設定する

  • 13.11.1　デフォルトに使用する文字の設定

13.11.1　デフォルトに使用する文字の設定

文字属性（文字フォント，スタイル，サイズ），または表示位置は，［文字］タブで変更します。

〈この項の構成〉

  • (1)　補足説明

(1)　補足説明

フォントやサイズを設定することで，実行する環境によって，帳票が正しく印刷されなかったり，表示されなかったりする場合があります。詳細は，「14.3.1(1)　フォントに関する注意」を参照してください。文字のフォント，スタイル，およびサイズを選択すると，プレビューに表示されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 279 / 356


13.11.2 文字間隔と行間隔の設定 : EUR 帳票作成 操作ガイド

  • 280 / 356

  • 表紙

  • 13.　アイテムのプロパティとオプションを設定する

  • 13.11　帳票のオプションを設定する

  • 13.11.2　文字間隔と行間隔の設定

13.11.2　文字間隔と行間隔の設定

デフォルトで使用する文字間隔と行間隔を，バージョン2以前の配置にするどうかを設定します。設定は［文字配置］タブで変更します。

バージョン2以前の文字配置を行うかどうかの違いを次に示します。

  • バージョン2以前の文字配置を行う場合

    UNIXの文字描画に合わせます。

  • バージョン2以前の文字配置を行わない場合

    Windowsシステムやデバイスの文字描画に合わせます。文字間隔と行間隔を，5ptずつ広くした例と狭くした例を次に示します。

〈この項の構成〉

  • (1)　補足説明

(1)　補足説明

  • 文字間隔が狭い場合，指定した文字のサイズが文字間隔を超える（左右の文字が重なる）ようなサイズであるときは，文字を描画しません。また，行間隔が狭い場合，指定した文字のサイズが行間を超える（上下の文字が重なる）ようなサイズであるときも，文字を描画しません。

  • 文字間隔や行間隔を狭くした場合，出力プリンタによっては，正しく印刷されないことがあります。

  • 指定されているフォントによっては，［文字配置］を設定した帳票が実行する環境で正しく印刷されなかったり，表示されなかったりする場合があります。詳細は，「14.3.1(1)　フォントに関する注意」を参照してください。

  • バージョン2以前の文字配置は，EURを英語ロケール，中国語ロケールで実行した場合は，使用できません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 280 / 356


13.11.3 デフォルトに使用する線の設定 : EUR 帳票作成 操作ガイド

  • 281 / 356

  • 表紙

  • 13.　アイテムのプロパティとオプションを設定する

  • 13.11　帳票のオプションを設定する

  • 13.11.3　デフォルトに使用する線の設定

13.11.3　デフォルトに使用する線の設定

デフォルトで使用する線種は，［線］タブで変更します。変更できる線種を次に示します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 281 / 356


13.11.4 デフォルトに使用する網パターンの設定 : EUR 帳票作成 操作ガイド

  • 282 / 356

  • 表紙

  • 13.　アイテムのプロパティとオプションを設定する

  • 13.11　帳票のオプションを設定する

  • 13.11.4　デフォルトに使用する網パターンの設定

13.11.4　デフォルトに使用する網パターンの設定

デフォルトで使用する網パターンは，［図形］タブで変更します。変更できる網パターンを次に示します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 282 / 356


13.11.5 使用する単位のデフォルト設定 : EUR 帳票作成 操作ガイド

  • 283 / 356

  • 表紙

  • 13.　アイテムのプロパティとオプションを設定する

  • 13.11　帳票のオプションを設定する

  • 13.11.5　使用する単位のデフォルト設定

13.11.5　使用する単位のデフォルト設定

グリッド間隔，用紙サイズ，余白，ルーラ，およびステータスバーの座標位置で使用する単位は，［表示］タブで変更します。［使用する単位］のグループボックスから，使用する単位を選択します。

表13‒17 使用できる単位
単位 | 単位記号 | 最小有効桁数
ミリメートル | mm | 小数点以下第2位
インチ | in
ピクセル | px | 整数

なお，「使用する単位」で単位を変更しても，値を指定する時に単位も指定すると，「使用する単位」で表示されます。例えば，「使用する単位」に「ミリメートル（mm）」が設定されている場合，用紙の余白に「1in」と指定しても，「25.4mm」と表示されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 283 / 356


13.11.6 画像の表示補正の設定 : EUR 帳票作成 操作ガイド

  • 284 / 356

  • 表紙

  • 13.　アイテムのプロパティとオプションを設定する

  • 13.11　帳票のオプションを設定する

  • 13.11.6　画像の表示補正の設定

13.11.6　画像の表示補正の設定

帳票に貼り付けた画像アイテムの表示補正，および表示方向を［画像］タブで変更できます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 284 / 356


13.11.7 デフォルトに使用するバーコードの設定 : EUR 帳票作成 操作ガイド

  • 285 / 356

  • 表紙

  • 13.　アイテムのプロパティとオプションを設定する

  • 13.11　帳票のオプションを設定する

  • 13.11.7　デフォルトに使用するバーコードの設定

13.11.7　デフォルトに使用するバーコードの設定

帳票に貼り付けるバーコードの種類，サイズ，高さ，またはバーコードフィールドのデータ形式のデフォルトは，［バーコード］タブで変更できます。

変更できるバーコードの種類，サイズ，および高さを次の表に示します。

表13‒18 変更できるバーコードの種類，サイズ，および高さ
種類 | サイズ | 高さ | 入力データ形式
JAN標準/UPC-A | ○ | ○ | ×
JAN短縮/UPC-E | ○ | ○ | ×
CODE39 | ○ | ○ | ×
CODE128 | ○ | ○ | ○
NW-7 | ○ | ○ | ×
ITF | ○ | ○ | ×
カスタマバーコード | ○ | × | ×
QRコード | × | × | ○
（凡例）

○：変更できます。

×：変更できません。

表示するバーコードフィールドのデータ形式は，次の中から変更できます。

表13‒19 表示するバーコードフィールドのデータ形式
種類 | データ形式 |  |  | データキャラクタの表示
 | チェックキャラクタの付加 | スタート／ストップキャラクタの付加 | FNC1の付加
JAN標準/UPC-A | ○ | － | × | ○
JAN短縮/UPC-E | ○ | － | × | ○
CODE39 | ○ | ○ | × | ○
CODE128 | － | － | ○ | ○
NW-7 | ○ | ○ | × | ○
ITF | ○ | － | × | －
QRコード | × | × | × | ×
（凡例）

○：変更できます。

×：変更できません。

－：固定（オン）です。

「カスタマバーコード」を指定した場合は，［カスタマバーコードのデータ形式］のグループボックスからデータ形式を選択します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 285 / 356


13.11.8 フォントによるリサイズの設定 : EUR 帳票作成 操作ガイド

  • 286 / 356

  • 表紙

  • 13.　アイテムのプロパティとオプションを設定する

  • 13.11　帳票のオプションを設定する

  • 13.11.8　フォントによるリサイズの設定

13.11.8　フォントによるリサイズの設定

文字のフォントを変更すると文字列の大きさが変わり，設定していた文字領域と大きさが合わなくなる場合があります。特に，フォントの変更で文字列が大きくなり，文字表示領域を超えた場合は，超えた部分の文字列が帳票に印刷されません。

文字のフォントを変更した場合，その文字列を表示する領域を文字の大きさによって自動的に変更（リサイズ）できます。フォントのリサイズは，［配置］タブで［フォントによるリサイズを行う］をオンにします。［フォントによるリサイズを行う］をオフにすると，マウス操作で帳票ウィンドウ上の文字表示領域の大きさを変更できます。

重要

「フォントによるリサイズの設定」を利用して自動的に文字表示領域を変更した場合は，帳票に設定したレイアウトが崩れることがあります。例えば，文字の表示領域が大きくなることで，帳票上のアイテムが1ページ内に収まらなくなり，次ページにわたる場合があります。ページ内のレイアウトに余裕を持っていない場合は注意が必要です。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 286 / 356


13.11.9 バーコードのリサイズの設定 : EUR 帳票作成 操作ガイド

  • 287 / 356

  • 表紙

  • 13.　アイテムのプロパティとオプションを設定する

  • 13.11　帳票のオプションを設定する

  • 13.11.9　バーコードのリサイズの設定

13.11.9　バーコードのリサイズの設定

データウィンドウからバーコードフィールドのデータを帳票ウィンドウに貼り付けた場合，バーコードの形式とデータ形式によって，貼り付けたデータが表示されないことがあります。また，貼り付けたバーコードのサイズや高さを変更すると，設定していた表示領域が，大き過ぎたり，小さ過ぎたりする場合があります。特に，表示領域を超えた場合は，バーコードが帳票に印刷されません。

バーコードを貼り付けたり，バーコードのサイズや高さを変更したりした場合，変更されたバーコードのサイズによって表示する領域を自動的に変更（リサイズ）できます。バーコードのリサイズは，［配置］タブで［バーコードのサイズ変更によるリサイズを行う］をオンにします。［バーコードのサイズ変更によるリサイズを行う］をオフにすると，マウス操作で帳票ファイル上の文字表示領域の大きさを変更できます。

重要

  • 「バーコードのリサイズの設定」を利用して自動的にバーコードの表示領域を変更した場合は，帳票に設定したレイアウトが崩れる場合があります。例えば，バーコードの表示領域が大きくなることで，帳票上のアイテムが貼付域外にバーコードの表示領域がはみ出す場合があります。ページ内のレイアウトに余裕を持っていない場合は注意が必要です。

  • バーコードの種類が「QRコード」の場合は，バーコードのリサイズの設定は無効です。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 287 / 356


13.11.10 編集中の画像表示の設定 : EUR 帳票作成 操作ガイド

  • 288 / 356

  • 表紙

  • 13.　アイテムのプロパティとオプションを設定する

  • 13.11　帳票のオプションを設定する

  • 13.11.10　編集中の画像表示の設定

13.11.10　編集中の画像表示の設定

帳票に画像データを幾つか貼り付ける場合，画像枠だけを表示するようにしておくと，帳票の表示応答時間が早くなります。

［表示］タブにある［表示項目の設定］の［編集中に画像を表示する］のチェックボックスをオフにします。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 288 / 356


13.11.11 ファイルの保存場所のデフォルト設定 : EUR 帳票作成 操作ガイド

  • 289 / 356

  • 表紙

  • 13.　アイテムのプロパティとオプションを設定する

  • 13.11　帳票のオプションを設定する

  • 13.11.11　ファイルの保存場所のデフォルト設定

13.11.11　ファイルの保存場所のデフォルト設定

利用するファイルを開いたり，保存したりする場合，デフォルトで使用するファイルの場所を，［ファイル］タブで設定，または変更できます。

ファイルの保存場所を設定しておくと，コマンド指定で帳票を出力するときにファイル名だけを指定して出力できたり，編集したファイルを上書き保存したりするとき便利です。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 289 / 356


13.11.12 文字幅計算方法の設定 : EUR 帳票作成 操作ガイド

  • 290 / 356

  • 表紙

  • 13.　アイテムのプロパティとオプションを設定する

  • 13.11　帳票のオプションを設定する

  • 13.11.12　文字幅計算方法の設定

13.11.12　文字幅計算方法の設定

帳票を出力する場合の固定ピッチフォントの文字幅計算方法を，［表示］タブで設定できます。可変ピッチフォント（プロポーショナルフォント）の場合は，［表示］タブでの設定に関係なく，フォントの文字幅を文字ごとに取得して計算します。

設定できる文字幅計算方法のモードを次に示します。

  • 静的モード

    固定ピッチフォントの文字幅を固定値として計算します。半角の場合はアイテムのフォント幅，全角の場合はアイテムのフォント幅の2倍で計算します。全角半角の判定は，フォントの言語によって次のフォントの情報を適用します。

    表13‒20　フォントの言語ごとの文字幅計算に適用するフォント

    フォントの言語

    適用するフォント

    英語フォント

    Courier

    日本語フォント

    MS 明朝

    簡体字中国語フォント

    新宋体

    繁体字中国語フォント

    細明体

    全角半角の判定で，EURがフォントの言語を判定できない場合は，実行ロケールによって次のデフォルトフォントの情報を適用します。

    表13‒21　実行ロケールごとの文字幅計算に適用するフォント

    実行ロケール

    適用するフォント

    中国語（簡体字）ロケール

    NSimSun

    日本語ロケール

    MS 明朝

    上記以外

    Courier

  • 動的モード

    固定ピッチフォントの文字幅を使用するフォントに合わせて計算します。

    出力形式によって出力結果が異なることがあります。出力結果の違いについてはマニュアル「EUR システム設計ガイド」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 290 / 356


14. 帳票を保存する : EUR 帳票作成 操作ガイド

  • 291 / 356

  • 表紙

  • 14.　帳票を保存する

14.　帳票を保存する

この章では，帳票を印刷する方法，保存する方法について説明します。

帳票を印刷する前に，プレビュー画面で確認したり，出力するアイテムを出力ページごとに設定したりする方法についても説明します。

〈この章の構成〉

  • 14.1　帳票を印刷プレビューで確認する

  • 14.2　帳票をレイアウト表示して確認する

  • 14.3　帳票を印刷する

  • 14.4　帳票を保存する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 291 / 356


14.1 帳票を印刷プレビューで確認する : EUR 帳票作成 操作ガイド

  • 292 / 356

  • 表紙

  • 14.　帳票を保存する

  • 14.1　帳票を印刷プレビューで確認する

14.1　帳票を印刷プレビューで確認する

印刷プレビューを使用して，設計した帳票の全体像を確認するときは，［ファイル］－［印刷プレビュー］を選択します。

次のように帳票がプレビューされます。

［印刷プレビュー］ウィンドウでは，次に示す操作ができます。

印刷する場合：

[図データ] をクリックします。［印刷］ダイアログが表示されます。

ページ区切りを確認する場合：

[図データ] をクリックします。

2ページずつ表示する場合：

[図データ] をクリックします。2ページずつ並べて表示されているときは，ボタンが [図データ] に変わります。

拡大／縮小表示する場合：

[図データ] をクリックします。

［印刷プレビュー］ウィンドウを閉じるときは， [図データ] をクリックします。

重要

印刷プレビューは，現在選択されているプリンタのプリンタドライバを介してウィンドウに描画するので，帳票を印刷出力するときの確認として利用できます。ただし，プリンタドライバによって，実際の印刷結果と一部異なる場合があります。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 292 / 356


14.2 帳票をレイアウト表示して確認する : EUR 帳票作成 操作ガイド

  • 293 / 356

  • 表紙

  • 14.　帳票を保存する

  • 14.2　帳票をレイアウト表示して確認する

14.2　帳票をレイアウト表示して確認する

［表示］－［レイアウト］を選択すると，帳票をレイアウト表示できます。レイアウト表示では，アイテム枠が表示されないので，実際に帳票を表示したイメージで確認できます。

この操作のあと，帳票の設計を続ける場合は，［表示］－［編集］を選択する必要があります。

重要

ページの先頭に集計行がある場合，レポート編集ウィンドウでは，集計行が表示される場所にアイテム枠または線アイテムだけが表示されます。ページの先頭にある集計行の実際の表示イメージを確認するときは，レポート編集ウィンドウではなくレイアウト表示で確認してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 293 / 356


14.3 帳票を印刷する : EUR 帳票作成 操作ガイド

  • 294 / 356

  • 表紙

  • 14.　帳票を保存する

  • 14.3　帳票を印刷する

14.3　帳票を印刷する

［ファイル］－［印刷］を選択して，帳票を印刷できます。印刷するプリンタ，ページ範囲および部数を設定したあと，［OK］ボタンをクリックします。

〈この節の構成〉

  • 14.3.1　印刷する前の注意

  • 14.3.2　印刷時の注意

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 294 / 356


14.3.1 印刷する前の注意 : EUR 帳票作成 操作ガイド

  • 295 / 356

  • 表紙

  • 14.　帳票を保存する

  • 14.3　帳票を印刷する

  • 14.3.1　印刷する前の注意

14.3.1　印刷する前の注意

帳票を印刷する前に，次のことに注意してください。

〈この項の構成〉

  • (1)　フォントに関する注意

  • (2)　プリンタ解像度ごとのバーコード最小サイズ

(1)　フォントに関する注意

フォントには，スケーラブルフォント（拡大縮小自在。アウトラインフォントともいいます）とノンスケーラブルフォント（固定サイズ。ビットマップフォントともいいます）があります。通常，Windows環境にインストールされているフォントは，「True Type」と呼ばれるスケーラブルフォントです。

ノンスケーラブルフォントを使用して文字配置を設定している帳票を受け取ったり，帳票を配布したりした場合，表示，または印刷する環境によって，正しく表示できないことがあります。ノンスケーラブルフォントを使用している場合，表示，または印刷する環境で持っているフォントに対して，用意されていない文字サイズが指定されている場合，できるだけ近いフォントで表示，または印刷されます。そのため，文字配置を設定している帳票では，文字サイズの指定によって，アイテム枠からはみ出して描画されることがあります。ノンスケーラブルフォントを使用する場合は，文字サイズの指定に注意してください。

また，設計した帳票で使用されているフォントが実行する環境にない場合や，文字方向に縦書きを指定している帳票を印刷したいが，実行する環境で縦書きができない場合も，できるだけ近いフォントで表示，または印刷されます。

帳票を正しく表示，または印刷するには，帳票で使用するフォントを，帳票を設計する環境と帳票を表示，または印刷する環境の両方に用意することをお勧めします。

ページの先頭へ

(2)　プリンタ解像度ごとのバーコード最小サイズ

プリンタの解像度によって出力できるバーコードの最小サイズを次に示します。

なお，最小サイズで出力したバーコードは，ご使用になるバーコードの読み込み装置によって，読み込めないこともあります。あらかじめ，出力したバーコードが読み取れるかどうかを確認することをお勧めします。

バーコード | 出力するプリンタの解像度
 | 300dpi | 600dpi
JAN標準/UPC-A | 0.8倍 | 0.8倍
JAN短縮/UPC-E | 0.8倍 | 0.8倍
CODE39 | 0.15mm | 0.15mm
CODE128 | 0.20mm | 0.15mm
NW-7 | 0.20mm | 0.15mm
ITF | 0.25倍 | 0.25倍

カスタマバーコードとQRコードは，出力するプリンタに依存しません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 295 / 356


14.3.2 印刷時の注意 : EUR 帳票作成 操作ガイド

  • 296 / 356

  • 表紙

  • 14.　帳票を保存する

  • 14.3　帳票を印刷する

  • 14.3.2　印刷時の注意

14.3.2　印刷時の注意

帳票を印刷するときは，次のことに注意してください。

  • 下敷きに指定された画像ファイルは，印刷されません。

  • 帳票設計で使用できるフォントは，固定ピッチおよび可変ピッチのTrueTypeフォントです。OCRフォントを使用して帳票を定義することもできます。ただし，EURで出力された帳票を光学式文字読み取り装置で読み取る場合は，ご使用になる光学式文字読み取り装置で，文字が読み取れるかどうかを確認してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 296 / 356


14.4 帳票を保存する : EUR 帳票作成 操作ガイド

  • 297 / 356

  • 表紙

  • 14.　帳票を保存する

  • 14.4　帳票を保存する

14.4　帳票を保存する

帳票を保存する手順を次に示します。

  1. ［名前を付けて保存］ダイアログを表示する

    ［ファイル］－［名前を付けて保存］を選択します。

  2. ファイルの保存場所を設定する

  3. ファイルを保存する

    設計した帳票を「フォームシートファイル（*.fms）」で保存します。保存したファイルを「帳票ファイル」といいます。「フォームシートファイル（*.fms）」は，帳票の定義情報とデータウィンドウへの入力となったファイル名を保存します。データウィンドウから入力したデータは保存されません。

なお，使用している機能によっては次の注意点があります。

  • 下敷きを使用して設計した帳票ファイルを保存したときは，使用した画像ファイル名だけを保存します。

  • 固定画像を貼り付けた帳票ファイルを保存すると，画像はフォームシートファイルに埋め込まれて保存されます。

〈この節の構成〉

  • 14.4.1　ファイルサーバからファイルを共用するときの注意

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 297 / 356


14.4.1 ファイルサーバからファイルを共用するときの注意 : EUR 帳票作成 操作ガイド

  • 298 / 356

  • 表紙

  • 14.　帳票を保存する

  • 14.4　帳票を保存する

  • 14.4.1　ファイルサーバからファイルを共用するときの注意

14.4.1　ファイルサーバからファイルを共用するときの注意

  • タイトルバーに「ファイル名（読み取り専用）」と表示されている帳票は，そのまま上書き保存することはできません。［ファイル］－［上書き保存］を選択した場合は，［名前を付けて保存］ダイアログが表示されます。ファイルの保存場所，およびファイル名を設定してください。

  • 帳票の保存を実行したとき，すでにファイルの保存場所に拡張子が異なる同一ファイル名がある場合は，「レポート（レポートファイル名）が使用中です」というメッセージが表示され，帳票の保存ができないことがあります。

  • EURで設計した帳票のファイルの保存場所に，~$から始まり，拡張子がtmpのファイル名があると，そのファイルが削除されることがあります。このため，ファイルの保存場所には，~$から始まる拡張子tmpのファイルを作成しないでください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 298 / 356


15. 作成した帳票の情報をインポート，エクスポートする : EUR 帳票作成 操作ガイド

  • 299 / 356

  • 表紙

  • 15.　作成した帳票の情報をインポート，エクスポートする

15.　作成した帳票の情報をインポート，エクスポートする

EURでは，作成した帳票の情報をインポート，エクスポートできます。

帳票の情報をインポート，エクスポートするためには，帳票ファイルの定義内容をCSV形式のファイル（帳票定義情報ファイル）に変換します。変換した帳票定義情報ファイルを編集し，それを帳票ファイルに再変換します。

この章では，帳票定義情報ファイルの変換方法と編集方法について説明します。

〈この章の構成〉

  • 15.1　帳票定義情報とは

  • 15.2　帳票の情報を帳票定義情報ファイルに変換する

  • 15.3　帳票定義情報ファイルを確認する

  • 15.4　帳票定義情報ファイルの構成

  • 15.5　帳票定義情報ファイルを保存する

  • 15.6　帳票定義情報ファイルから帳票ファイルに変換する

  • 15.7　eurspcsvコマンドを使ってインポート，エクスポートする

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 299 / 356


15.1 帳票定義情報とは : EUR 帳票作成 操作ガイド

  • 300 / 356

  • 表紙

  • 15.　作成した帳票の情報をインポート，エクスポートする

  • 15.1　帳票定義情報とは

15.1　帳票定義情報とは

帳票定義情報とは，帳票ファイルに定義されている内容のことです。帳票定義情報をCSV形式ファイルに変換したものを帳票定義情報ファイル（*.csv）といいます。

帳票定義情報ファイルは，次のように利用できます。

  • CSV形式ファイルとして変換することで，帳票定義情報を一覧で確認できます。

  • 変更した帳票ファイルと元の帳票ファイルの帳票定義情報ファイルを比べる※ことで，変更した個所がわかります。

  • アイテムの位置やサイズ，フォントなどを一度に変更できる※ので，レイアウトが容易に整えられます。

  • 複数の帳票定義情報ファイルを一度に変更できる※ので，多大な量の帳票の変更が簡単にできます。

注※

文書の比較，一括変更は，Excelなどの機能を使って行ってください。

〈この節の構成〉

  • 15.1.1　帳票定義情報ファイルに使用するエンコーディング

  • 15.1.2　帳票定義情報ファイルの使用例

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 300 / 356


15.1.1 帳票定義情報ファイルに使用するエンコーディング : EUR 帳票作成 操作ガイド

  • 301 / 356

  • 表紙

  • 15.　作成した帳票の情報をインポート，エクスポートする

  • 15.1　帳票定義情報とは

  • 15.1.1　帳票定義情報ファイルに使用するエンコーディング

15.1.1　帳票定義情報ファイルに使用するエンコーディング

帳票定義情報ファイルで使用するエンコーディングは，UTF-16です。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 301 / 356


15.1.2 帳票定義情報ファイルの使用例 : EUR 帳票作成 操作ガイド

  • 302 / 356

  • 表紙

  • 15.　作成した帳票の情報をインポート，エクスポートする

  • 15.1　帳票定義情報とは

  • 15.1.2　帳票定義情報ファイルの使用例

15.1.2　帳票定義情報ファイルの使用例

帳票ファイル（report1.fms）を帳票定義情報ファイルに変換した場合の使用例を次に示します。

図15‒1　帳票ファイル（report1.fms）変更前

[図データ]

  1. 帳票ファイル（report1.fms）を帳票定義情報ファイルに変換します。

    帳票定義情報ファイルへの変換方法については，「15.2　帳票の情報を帳票定義情報ファイルに変換する」を参照してください。

  2. 帳票定義情報ファイルを開きます。

    帳票定義情報ファイルをExcelで開く方法については，「15.3.2　帳票定義情報ファイルをExcelで開く」を参照してください。

    図15‒2　帳票定義情報ファイル（アイテム定義情報.csv）の変換例

    [図データ]

  3. 「フォント名」を「ＭＳ 明朝」から「ＭＳ ゴシック」に，「太字」を「ON」に変更します。

    帳票定義情報ファイルの編集方法については，「15.4　帳票定義情報ファイルの構成」を参照してください。

    図15‒3　帳票定義情報ファイルの変更

    [図データ]

  4. 帳票定義情報ファイルを保存します。

    帳票定義情報ファイルの保存方法については，「15.5　帳票定義情報ファイルを保存する」を参照してください。

  5. 帳票定義情報ファイルを帳票ファイルに変換します。

    帳票ファイルへの変換方法については，「15.6　帳票定義情報ファイルから帳票ファイルに変換する」を参照してください。変換された帳票ファイルを開くと次のように表示されます。

    図15‒4　帳票ファイル（report1.fms）変更後

    [図データ]

    帳票ウィンドウで直接フォントを変更する場合は，集計行の変更は集計行編集モードでほかのアイテムとは別に設定する必要がありますが，帳票定義情報ファイルを使えば，一括で変更できます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 302 / 356


15.2 帳票の情報を帳票定義情報ファイルに変換する : EUR 帳票作成 操作ガイド

  • 303 / 356

  • 表紙

  • 15.　作成した帳票の情報をインポート，エクスポートする

  • 15.2　帳票の情報を帳票定義情報ファイルに変換する

15.2　帳票の情報を帳票定義情報ファイルに変換する

帳票ファイルを帳票定義情報ファイルに変換します。一度に複数の帳票ファイルを変換できます。変換したい帳票ファイルを同じフォルダに格納してください。

帳票定義情報ファイルに変換できるのは，EURのバージョン05-00以降で設計した帳票ファイルです。それ以前に設計した帳票ファイル，およびUNIX版 EUR旧製品で設計した帳票は，一度バージョン5以降で保存し直してから使用してください。

また，英語ロケールから中国語ロケール，日本語ロケールから英語ロケールなど異なるロケール間では変換できません。

帳票定義情報ファイルに変換する方法には，次の2種類があります。

  • ［帳票定義情報ファイルの入出力］ダイアログで実行する方法

  • eurspcsvコマンドで実行する方法

ここでは，［帳票定義情報ファイルの入出力］ダイアログで実行する方法について説明します。eurspcsvコマンドで実行する方法については，「15.7　eurspcsvコマンドを使ってインポート，エクスポートする」を参照してください。

〈この節の構成〉

  • 15.2.1　帳票ファイルを帳票定義情報ファイルに変換する（ダイアログで実行する場合）

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 303 / 356


15.2.1 帳票ファイルを帳票定義情報ファイルに変換する（ダイアログで実行する場合） : EUR 帳票作成 操作ガイド

  • 304 / 356

  • 表紙

  • 15.　作成した帳票の情報をインポート，エクスポートする

  • 15.2　帳票の情報を帳票定義情報ファイルに変換する

  • 15.2.1　帳票ファイルを帳票定義情報ファイルに変換する（ダイアログで実行する場合）

15.2.1　帳票ファイルを帳票定義情報ファイルに変換する（ダイアログで実行する場合）

  1. スタートメニューの［EUR Designer］または［EUR Developer］の下位の［ツール］－［帳票定義情報ファイルの入出力］を選択します。

    ［帳票定義情報ファイルの入出力］ダイアログが起動します。

  2. ［帳票ファイルを帳票定義情報ファイルに変換する］ラジオボタンを選択します。

  3. 「入力元フォルダ」の［参照］ボタンをクリックします。

    ［参照］ボタンをクリックすると，［ファイルを選択］ダイアログが開きます。［ファイルを選択］ダイアログで，変換する帳票ファイル（.fms）を選択し，［開く］ボタンをクリックします。ファイルは複数選択できます。「入力ファイル一覧」に選択したファイル名が表示されます。

    ［ファイルを選択］ダイアログでは，変換するファイル以外のファイルを選択しないでください。

  4. 「出力先フォルダ」の［参照］ボタンをクリックします。

    ［参照］ボタンをクリックすると，［フォルダの参照］ダイアログが開きます。［フォルダの参照］ダイアログで，帳票定義情報ファイルを格納するフォルダを選択し，［OK］ボタンをクリックします。

  5. ［実行］ボタンをクリックします。

    変換が成功したかどうかを知らせる［変換結果の確認］ダイアログが表示され，指定したフォルダに帳票定義情報ファイルが格納されます。

    エラーの対処については，マニュアル「EUR メッセージ」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 304 / 356


15.3 帳票定義情報ファイルを確認する : EUR 帳票作成 操作ガイド

  • 305 / 356

  • 表紙

  • 15.　作成した帳票の情報をインポート，エクスポートする

  • 15.3　帳票定義情報ファイルを確認する

15.3　帳票定義情報ファイルを確認する

変換した帳票定義情報ファイルの内容を確認します。帳票ファイルの変更になった個所を数値やテキストで明確にしたい場合などに利用します。

帳票ファイルを変換すると，帳票定義情報構成ファイル（.esp）と帳票定義情報ファイル（.csv）が出力されます。帳票定義情報構成ファイルとは，帳票定義情報ファイルの構成を示したファイルです。

帳票を定義するには，帳票定義情報ファイル（.csv）を編集します。帳票定義情報構成ファイル（.esp）は編集できません。

〈この節の構成〉

  • 15.3.1　帳票定義情報ファイルの格納先と出力形式

  • 15.3.2　帳票定義情報ファイルをExcelで開く

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 305 / 356


15.3.1 帳票定義情報ファイルの格納先と出力形式 : EUR 帳票作成 操作ガイド

  • 306 / 356

  • 表紙

  • 15.　作成した帳票の情報をインポート，エクスポートする

  • 15.3　帳票定義情報ファイルを確認する

  • 15.3.1　帳票定義情報ファイルの格納先と出力形式

15.3.1　帳票定義情報ファイルの格納先と出力形式

ここでは，帳票定義情報ファイルの格納先と出力形式について説明します。

帳票定義情報ファイルの項目の設定内容については，「15.4　帳票定義情報ファイルの構成」を参照してください。

〈この項の構成〉

  • (1)　帳票定義情報ファイルの格納先

  • (2)　帳票定義情報ファイルの出力形式

(1)　帳票定義情報ファイルの格納先

帳票定義情報ファイルのフォルダ構成を次に示します。

図15‒5　帳票定義情報ファイルのフォルダ構成

[図データ]

変換時に指定したフォルダ下には，帳票定義情報構成ファイル（.esp）と帳票定義情報構成フォルダが作成されます。帳票定義情報構成ファイルは，変換した帳票ファイルの名称に拡張子「.esp」を付けた名称となります。

帳票定義情報構成フォルダは，変換した帳票ファイルの名称となります。帳票定義情報構成フォルダ下に，帳票定義情報ファイル（.csv）が出力されます。

ページの先頭へ

(2)　帳票定義情報ファイルの出力形式

帳票定義情報ファイルは，帳票定義情報をコンマで区切ったCSV形式のファイルです。帳票定義情報ファイルの形式を次に示します。

表15‒1 帳票定義情報ファイルの出力形式
出力形式 |  | 説明
1行目 | "項目名","項目名",… | 定義情報の項目名
2行目以降 | "出力値","出力値",… ： ： | 定義情報に対応する内容

  • 項目名と出力値は，Unicodeで出力されます。

  • 出力値が設定されていない場合は，区切り記号のコンマだけを出力します。

  • パラメタのように定義情報が複数あったり，添付ファイルのように個数が可変であったりする場合は，2行目以降の情報が複数行になります。

  • データに「"」，または「\」が含まれている場合は，次のように「"」，または「\」が二つ続けて出力されます。

    （出力例）

    データ　　　　ファイル出力値

    「a"aa」　→　「"a""aa"」

    「a\aa」　→　「"a\\aa"」

  • 改行コードは，「\n」に変換して出力されます。

帳票定義情報ファイルの出力例を次に示します。

図15‒6　帳票定義情報ファイルの出力例

[図データ]

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 306 / 356


15.3.2 帳票定義情報ファイルをExcelで開く : EUR 帳票作成 操作ガイド

  • 307 / 356

  • 表紙

  • 15.　作成した帳票の情報をインポート，エクスポートする

  • 15.3　帳票定義情報ファイルを確認する

  • 15.3.2　帳票定義情報ファイルをExcelで開く

15.3.2　帳票定義情報ファイルをExcelで開く

変換された帳票定義情報ファイルを開くときは，Excelを起動したあと，次に示す設定が必要です。エクスプローラなどから帳票定義情報ファイルをダブルクリックで開くと，情報が正しく表示されません。

  1. Excelを起動します。

  2. ［ファイル］－［開く］から帳票定義情報ファイルを開きます。［ファイルを開く］ダイアログの［ファイルの種類］リストボックスでは，「テキストファイル（*.prn; *.txt; *.csv）」を選択します。

  3. 表示される［テキストファイル ウィザード］で，次のように設定します。

    項目

    設定内容

    ［テキストファイル ウィザード - 1/3］

    元のデータの形式

    「カンマやタブなどの区切り文字によってフィールドごとに区切られたデータ」を選択します。

    取り込み開始行

    「1」のままです。

    ［テキストファイル ウィザード - 2/3］

    区切り文字

    「カンマ」をオンにします。デフォルトの「タブ」はオフにします。

    文字列の引用符

    「"」を選択します。

    連続した区切り文字は1文字として扱う

    オフのままです。

    ［テキストファイル ウィザード - 3/3］

    列のデータ形式

    すべての列を「文字列」に設定します。

  4. ［テキストファイル ウィザード - 3/3］で［完了］ボタンをクリックします。

    帳票定義情報が表示されます。1行目にファイル出力項目名，2行目以降にファイル出力値が表示されます。情報が見やすいように，セル幅などを調整してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 307 / 356


15.4 帳票定義情報ファイルの構成 : EUR 帳票作成 操作ガイド

  • 308 / 356

  • 表紙

  • 15.　作成した帳票の情報をインポート，エクスポートする

  • 15.4　帳票定義情報ファイルの構成

15.4　帳票定義情報ファイルの構成

帳票定義情報ファイルには次の六つのファイルがあります。

表15‒2 帳票定義情報ファイルの種類
帳票定義情報ファイルの種類 | ファイル内容
帳票全体定義情報ファイル | 用紙や下敷きなど，帳票全体についての帳票定義情報が出力されます。
ブレイク定義情報ファイル | 改ブロックやキー集計など，ブレイクについての帳票定義情報が出力されます。
アイテム定義情報ファイル | 文字，画像，バーコードなど，アイテムについての帳票定義情報が出力されます。
部品定義情報ファイル | 部品についての帳票定義情報が出力されます。
フィールド定義情報ファイル | フィールド定義についての帳票定義情報が出力されます。
補足情報ファイル | データベースアクセス定義，および固定画像ファイルについての帳票定義情報が出力されます。

帳票定義情報ファイルに出力された値を変更することで，帳票を定義できます。

帳票定義情報ファイルの出力形式については，「15.3.1(2)　帳票定義情報ファイルの出力形式」を参照してください。

重要

帳票定義情報ファイルを使って帳票を定義する場合は次のことに注意してください。

  • 項目名は，変更・削除できません。

  • 項目名が重複した場合はエラーとなります。

  • 出力値と対になる項目名がない場合，正しく変換できません。

  • 帳票に定義されていない項目は，省略される場合があります。

〈この節の構成〉

  • 15.4.1　帳票全体定義情報ファイル

  • 15.4.2　ブレイク定義情報ファイル

  • 15.4.3　アイテム定義情報ファイル

  • 15.4.4　部品定義情報ファイル

  • 15.4.5　フィールド定義情報ファイル

  • 15.4.6　補足情報ファイル

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 308 / 356


15.4.1 帳票全体定義情報ファイル : EUR 帳票作成 操作ガイド

  • 309 / 356

  • 表紙

  • 15.　作成した帳票の情報をインポート，エクスポートする

  • 15.4　帳票定義情報ファイルの構成

  • 15.4.1　帳票全体定義情報ファイル

15.4.1　帳票全体定義情報ファイル

用紙や下敷きなど，帳票全体についての帳票定義情報が出力されたファイルです。出力された値を変更することで，帳票を定義できます。

帳票全体定義情報ファイルの3行目以降には，値を入力できません。

帳票全体定義情報ファイルに出力される項目名と設定値を次に示します。

〈この項の構成〉

  • (1)　用紙

  • (2)　幅

  • (3)　長さ

  • (4)　向き

  • (5)　上余白

  • (6)　下余白

  • (7)　左余白

  • (8)　右余白

  • (9)　ページ番号印刷

  • (10)　ページ番号書式

  • (11)　ページ番号位置

  • (12)　ページ番号初期値

  • (13)　ページ番号初期化

  • (14)　キー集計生成

  • (15)　下敷き画像

  • (16)　下敷き画像X位置

  • (17)　下敷き画像Y位置

  • (18)　下敷き画像幅

  • (19)　下敷き画像高さ

  • (20)　下敷き画像サイズ指定

  • (21)　置き換え表

  • (22)　禁則文字言語

  • (23)　行頭禁則文字

  • (24)　行末禁則文字

  • (25)　下限位置縦

  • (26)　下限位置横

  • (27)　基準レコード位置

  • (28)　基準レコード幅

  • (29)　繰り返し優先方向

  • (30)　繰り返し横位置

  • (31)　繰り返し縦位置

  • (32)　横繰り返し個数

  • (33)　縦繰り返し個数

  • (34)　グリッド表示

  • (35)　グリッド横間隔

  • (36)　グリッド縦間隔

  • (37)　グリッドX開始

  • (38)　グリッドY開始

  • (39)　グリッド補正

  • (40)　まとめ分断

  • (41)　まとめ先頭

  • (42)　データキャラクタフォント

  • (43)　帳票ヘッダ高さ

  • (44)　画像解像度X

  • (45)　画像解像度Y

  • (46)　まとめリスト

  • (47)　先頭・最終ページ範囲

  • (48)　繰り返しLPI

  • (49)　繰り返しLPI行数

  • (50)　グリッド横間隔(CPI)

  • (51)　グリッド縦間隔(LPI)

(1)　用紙

用紙サイズを出力します。

設定できる値

A3，A4，B4，B5，A5，レター，リーガル，ハガキ，10x11，11x17，15x11，12x8.5，ユーザ定義

参照先

2.2.1　用紙サイズの変更

ページの先頭へ

(2)　幅

用紙の幅を出力します。単位は，1/100mmです。

設定できる値

3,500～43,180

参照先

2.2.1　用紙サイズの変更

ページの先頭へ

(3)　長さ

用紙の長さを出力します。単位は，1/100mmです。

設定できる値

3,500～43,180

参照先

2.2.1　用紙サイズの変更

ページの先頭へ

(4)　向き

印刷の向きを出力します。

設定できる値

縦，横

参照先

2.2.2　用紙の向きの変更

ページの先頭へ

(5)　上余白

用紙の上余白を出力します。単位は，1/100mmです。

設定できる値

0以上，かつ，上下の余白の合計≦用紙の縦の長さ - 2500となる値

参照先

2.2.3　用紙の余白の変更

ページの先頭へ

(6)　下余白

用紙の下余白を出力します。単位は，1/100mmです。

設定できる値

0以上，かつ，上下の余白の合計≦用紙の縦の長さ - 2500となる値

参照先

2.2.3　用紙の余白の変更

ページの先頭へ

(7)　左余白

用紙の左余白を出力します。単位は，1/100mmです。

設定できる値

0以上，かつ，左右の余白の合計≦用紙の横の長さ - 2500となる値

参照先

2.2.3　用紙の余白の変更

ページの先頭へ

(8)　右余白

用紙の右余白を出力します。単位は，1/100mmです。

設定できる値

0以上，かつ，左右の余白の合計≦用紙の横の長さ - 2500となる値

参照先

2.2.3　用紙の余白の変更

ページの先頭へ

(9)　ページ番号印刷

貼り付け域外のページ番号を印刷するかどうかを出力します。

設定できる値

ON，OFF

参照先

4.5.2　余白にページ番号を配置する

ページの先頭へ

(10)　ページ番号書式

貼り付け域外のページ番号の書式を出力します。ページ番号は＊で表します。

設定できる値

510文字以内の文字列

（例）

＊

－＊－

参照先

4.5.2　余白にページ番号を配置する

ページの先頭へ

(11)　ページ番号位置

貼り付け域外のページ番号の位置を出力します。

設定できる値

左上，中央上，右上，左下，中央下，右下

参照先

4.5.2　余白にページ番号を配置する

ページの先頭へ

(12)　ページ番号初期値

貼り付け域外のページ番号の初期値を出力します。

設定できる値

1～32,767

参照先

4.5.2　余白にページ番号を配置する

ページの先頭へ

(13)　ページ番号初期化

貼り付け域外のページ番号を初期化するかどうかを出力します。

設定できる値

ON，OFF

参照先

4.5.2　余白にページ番号を配置する

ページの先頭へ

(14)　キー集計生成

1件のときキー集計行を生成するかどうかを出力します。

設定できる値

ON，OFF

参照先

6.3　キー集計を作成する

ページの先頭へ

(15)　下敷き画像

下敷きの画像ファイル名を出力します。

設定できる値

255文字以内の文字列

（例）

申請書.bmp

注文書.tif

参照先

10.2　下敷きを読み込む

ページの先頭へ

(16)　下敷き画像X位置

下敷きの用紙左端からのX座標位置を出力します。単位は，1/100mmです。

設定できる値

（-1）×用紙の幅≦X≦用紙の幅

参照先

10.2　下敷きを読み込む

ページの先頭へ

(17)　下敷き画像Y位置

下敷きの用紙上端からのY座標位置を出力します。単位は，1/100mmです。

設定できる値

（-1）×用紙の高さ≦Y≦用紙の高さ

参照先

10.2　下敷きを読み込む

ページの先頭へ

(18)　下敷き画像幅

下敷きの画像の幅を出力します。単位は，1/100mmです。

設定できる値

0～43,180

参照先

10.2　下敷きを読み込む

ページの先頭へ

(19)　下敷き画像高さ

下敷きの画像の高さを出力します。単位は，1/100mmです。

設定できる値

0～43,180

参照先

10.2　下敷きを読み込む

ページの先頭へ

(20)　下敷き画像サイズ指定

下敷きの画像のサイズを指定するかどうかを出力します。

設定できる値

ON，OFF

参照先

10.2　下敷きを読み込む

ページの先頭へ

(21)　置き換え表

置き換え表管理情報ファイル名を出力します。

設定できる値

255文字以内の文字列

（例）

性別.csv

参照先

8.1.1　置き換え表ファイルを作成する

ページの先頭へ

(22)　禁則文字言語

禁則文字の言語を出力します。

設定できる値

日本語，中国語，英語，カスタム

参照先

マニュアル「EUR 帳票作成 画面リファレンス」

ページの先頭へ

(23)　行頭禁則文字

行頭禁則文字を出力します。

設定できる値

510文字以内の文字列

参照先

マニュアル「EUR 帳票作成 画面リファレンス」

ページの先頭へ

(24)　行末禁則文字

行末禁則文字を出力します。

設定できる値

510文字以内の文字列

参照先

マニュアル「EUR 帳票作成 画面リファレンス」

ページの先頭へ

(25)　下限位置縦

繰り返しの優先方向が縦の場合の下限位置を出力します。出力される値は，用紙の下端からの距離です。単位は，1/100mmです。

設定できる値

0≦設定値≦用紙高さ

参照先

6.6.6(2)　集計行の下限位置の設定

ページの先頭へ

(26)　下限位置横

繰り返しの優先方向が横の場合の右限位置を出力します。出力される値は，用紙の右端からの距離です。単位は，1/100mmです。

設定できる値

0≦設定値≦用紙幅

参照先

6.6.6(2)　集計行の下限位置の設定

ページの先頭へ

(27)　基準レコード位置

基準レコード位置を出力します。

設定できる値

1～32,767

参照先

3.5.1　基準レコード位置の変更

ページの先頭へ

(28)　基準レコード幅

基準レコード幅を出力します。

設定できる値

1～32,767

参照先

3.5.2　基準レコード幅の変更

ページの先頭へ

(29)　繰り返し優先方向

繰り返しの優先方向を出力します。

設定できる値

縦優先，横優先

参照先

5.3.1　繰り返し定義を設定する

ページの先頭へ

(30)　繰り返し横位置

繰り返しの横位置を出力します。単位は，1/100mmです。

設定できる値

100≦設定値≦用紙の幅

指定しない場合は「0」

参照先

5.3.1　繰り返し定義を設定する

ページの先頭へ

(31)　繰り返し縦位置

繰り返しの縦位置を出力します。単位は，1/100mmです。

設定できる値

100≦設定値≦用紙の高さ

指定しない場合は「0」

参照先

5.3.1　繰り返し定義を設定する

ページの先頭へ

(32)　横繰り返し個数

横の繰り返しをする個数を出力します。

設定できる値

1～999

参照先

5.3.2　繰り返し個数を設定する

ページの先頭へ

(33)　縦繰り返し個数

縦の繰り返しをする個数を出力します。

設定できる値

1～999

参照先

5.3.2　繰り返し個数を設定する

ページの先頭へ

(34)　グリッド表示

グリッドを表示するかどうかを出力します。

設定できる値

ON，OFF

参照先

1.4.1　グリッドの表示

ページの先頭へ

(35)　グリッド横間隔

グリッドの横の間隔を出力します。単位は，1/100mmです。

設定できる値

100～20,000

参照先

1.4.2　グリッドの属性変更

ページの先頭へ

(36)　グリッド縦間隔

グリッドの縦の間隔を出力します。単位は，1/100mmです。

設定できる値

100～20,000

参照先

1.4.2　グリッドの属性変更

ページの先頭へ

(37)　グリッドX開始

グリッドのX座標の開始位置を出力します。単位は，1/100mmです。

設定できる値

0～20,000

参照先

1.4.2　グリッドの属性変更

ページの先頭へ

(38)　グリッドY開始

グリッドのY座標の開始位置を出力します。単位は，1/100mmです。

設定できる値

0～20,000

参照先

1.4.2　グリッドの属性変更

ページの先頭へ

(39)　グリッド補正

グリッド補正をするかどうかを出力します。

設定できる値

ON，OFF

参照先

1.4.2　グリッドの属性変更

ページの先頭へ

(40)　まとめ分断

集計行でまとめ表示をするかどうかを出力します。

設定できる値

ON，OFF

参照先

5.6.1　まとめ表示を設定する

ページの先頭へ

(41)　まとめ先頭

先頭の集計行にまとめアイテムを表示するかどうかを出力します。

設定できる値

ON，OFF

参照先

5.6.1　まとめ表示を設定する

ページの先頭へ

(42)　データキャラクタフォント

データキャラクタのフォント名を出力します。

設定できる値

31文字以内の文字列（縦書きフォントを除くすべてのフォントが対象）

参照先

13.9.1　データキャラクタのフォントの変更

ページの先頭へ

(43)　帳票ヘッダ高さ

帳票ヘッダ領域の高さを出力します。単位は，1/100mmです。帳票ヘッダ領域がない場合は，0になります。

設定できる値

  • 繰り返しの優先方向が縦の場合

    0～用紙の高さ

  • 繰り返しの優先方向が横の場合

    0～用紙の幅

参照先

7.1　帳票ヘッダ領域を設定する

ページの先頭へ

(44)　画像解像度X

画像の縦解像度を出力します。単位は，dpiです。

設定できる値

0～999

参照先

なし

ページの先頭へ

(45)　画像解像度Y

画像の横解像度を出力します。単位は，dpiです。

設定できる値

0～999

参照先

なし

ページの先頭へ

(46)　まとめリスト

まとめ表示を指定したアイテムのアイテムIDを出力します。

設定できる値

510文字以内の文字列

参照先

5.6.1　まとめ表示を設定する

ページの先頭へ

(47)　先頭・最終ページ範囲

先頭ページ・最終ページの範囲を指定します。

設定できる値

標準，リセットページ番号

参照先

4.9.2　アイテムの出力ページの設定

ページの先頭へ

(48)　繰り返しLPI

LPIで指定した繰り返しの縦位置を出力します。単位は，1/100LPIです。

設定できる値

13～2,400

参照先

5.3.1　繰り返し定義を設定する

ページの先頭へ

(49)　繰り返しLPI行数

LPIで指定したときの，縦の繰り返しをする個数を出力します。

設定できる値

1～99

参照先

5.3.2　繰り返し個数を設定する

ページの先頭へ

(50)　グリッド横間隔(CPI)

CPIで指定したグリッドの横の間隔を出力します。単位は，1/100CPIです。

設定できる値

13～2,400

参照先

1.4.2　グリッドの属性変更

ページの先頭へ

(51)　グリッド縦間隔(LPI)

LPIで指定したグリッドの縦の間隔を出力します。単位は，1/100LPIです。

設定できる値

13～2,400

参照先

1.4.2　グリッドの属性変更

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 309 / 356


15.4.2 ブレイク定義情報ファイル : EUR 帳票作成 操作ガイド

  • 310 / 356

  • 表紙

  • 15.　作成した帳票の情報をインポート，エクスポートする

  • 15.4　帳票定義情報ファイルの構成

  • 15.4.2　ブレイク定義情報ファイル

15.4.2　ブレイク定義情報ファイル

改ブロックやキー集計など，ブレイクについての帳票定義情報が出力されます。

ブレイク定義情報ファイルに出力される項目名と設定値を次に示します。

〈この項の構成〉

  • (1)　種別

  • (2)　キー

  • (3)　レベル

  • (4)　位置固定

(1)　種別

ブレイクの場合は改ブロックか改ページのどちらかが出力されます。

集計の場合は集計の種類が出力されます。

設定できる値

  • ブレイクの場合

    改ブロック，改ページ（初期化無し），改ページ（初期化あり）

  • 集計の場合

    キー集計，ページ集計，総集計

参照先

5.4　改ブロックを設定する

5.5　改ページを設定する

6.3　キー集計を作成する

6.4　ページ集計を作成する

6.5　総集計を作成する

ページの先頭へ

(2)　キー

ブレイクまたはキー集計のキーフィールド名称を出力します。

［種別］が［改ブロック］［改ページ（初期化無し）］［改ページ（初期化有り）］［キー集計］の場合だけ出力します。ブレイクの場合はフィールド名をそのまま項目に出力します。キー集計の場合はキーフィールド名を\nで区切って記述します。

設定できる値

510文字以内の文字列

参照先

5.4　改ブロックを設定する

5.5　改ページを設定する

6.3　キー集計を作成する

6.4　ページ集計を作成する

6.5　総集計を作成する

ページの先頭へ

(3)　レベル

キー集計の階層レベルの番号を出力します。

設定できる値

101～4,096

参照先

6.3　キー集計を作成する

ページの先頭へ

(4)　位置固定

総集計，ページ集計，またはキー集計の位置固定をするかどうかを出力します。

設定できる値

  • 総集計の場合

    する，しない

  • ページ集計の場合

    する，しない

  • キー集計の場合

    しない，改ブロック連動，改ページ連動

参照先

6.6　集計行を編集する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 310 / 356


15.4.3 アイテム定義情報ファイル : EUR 帳票作成 操作ガイド

  • 311 / 356

  • 表紙

  • 15.　作成した帳票の情報をインポート，エクスポートする

  • 15.4　帳票定義情報ファイルの構成

  • 15.4.3　アイテム定義情報ファイル

15.4.3　アイテム定義情報ファイル

文字，画像，バーコードなど，アイテムについての帳票定義情報が出力されます。

アイテム定義情報ファイルに出力される項目名と設定値を次に示します。

〈この項の構成〉

  • (1)　行種別

  • (2)　レベル

  • (3)　集計ページ

  • (4)　アイテム種別

  • (5)　順序番号

  • (6)　開始X

  • (7)　開始Y

  • (8)　幅

  • (9)　高さ

  • (10)　繰り返し種別

  • (11)　出力ページ

  • (12)　表示条件指定

  • (13)　表示条件参照フィールド

  • (14)　表示条件参照フィールド種別

  • (15)　表示条件範囲指定

  • (16)　表示条件演算子1

  • (17)　表示条件演算子2

  • (18)　表示条件指定値1

  • (19)　表示条件指定値2

  • (20)　表示条件表示方法

  • (21)　表示条件指定値1フィールド指定

  • (22)　表示条件指定値2フィールド指定

  • (23)　表示条件指定値1フィールド

  • (24)　表示条件指定値2フィールド

  • (25)　表示条件指定値1フィールド種別

  • (26)　表示条件指定値2フィールド種別

  • (27)　原点

  • (28)　横位置

  • (29)　縦位置

  • (30)　固定/可変

  • (31)　フィールド名

  • (32)　レコード相対

  • (33)　セル名

  • (34)　まとめ優先

  • (35)　フォントサイズ

  • (36)　太字

  • (37)　斜体

  • (38)　フォント名

  • (39)　縦横比補正

  • (40)　下線

  • (41)　まとめ

  • (42)　まとめ罫線

  • (43)　文字配置方式

  • (44)　文字間隔

  • (45)　行間隔

  • (46)　文字方向

  • (47)　文字色

  • (48)　元年表記

  • (49)　出力桁数指定

  • (50)　出力桁数

  • (51)　フォントリサイズ

  • (52)　ワードラップ

  • (53)　禁則処理

  • (54)　文字列

  • (55)　書式

  • (56)　固定文字種別

  • (57)　ページ番号桁数

  • (58)　書式バージョン

  • (59)　データ種別

  • (60)　置き換え

  • (61)　置き換え表名

  • (62)　集計種別

  • (63)　前付加文字

  • (64)　後付加文字

  • (65)　任意書式指定

  • (66)　カンマ

  • (67)　小数点以下桁数

  • (68)　小数点文字

  • (69)　四捨五入

  • (70)　ゼロ埋め桁数

  • (71)　指数表示

  • (72)　負符号文字

  • (73)　0データ

  • (74)　空データ

  • (75)　日付書式

  • (76)　日付種別

  • (77)　バーコード種別

  • (78)　バーコード回転

  • (79)　データキャラクタ

  • (80)　バーコード倍率

  • (81)　バーコードサイズ

  • (82)　バーコード高さ

  • (83)　チェックキャラクタ

  • (84)　スタートキャラクタ

  • (85)　バーコードデータ形式

  • (86)　FNC1

  • (87)　表示文字認識

  • (88)　機能コード

  • (89)　データキャラクタプロパティ

  • (90)　データキャラクタ行数

  • (91)　データキャラクタフォント

  • (92)　データキャラクタサイズ

  • (93)　データキャラクタ縦位置

  • (94)　データキャラクタ横位置

  • (95)　訂正レベル

  • (96)　バージョン

  • (97)　セルサイズ

  • (98)　図形種別

  • (99)　模様

  • (100)　ｎ個ごと繰り返し

  • (101)　ｎ個

  • (102)　背景色

  • (103)　前景色

  • (104)　枠線

  • (105)　枠線種別

  • (106)　枠線色

  • (107)　丸め半径X

  • (108)　丸め半径Y

  • (109)　影

  • (110)　角丸

  • (111)　頂点個数

  • (112)　頂点座標

  • (113)　拡大/縮小

  • (114)　縦横比保持

  • (115)　ファイル名

  • (116)　線種

  • (117)　線幅

  • (118)　線色

  • (119)　ｎ個ごと繰り返し

  • (120)　線ｎ個

  • (121)　ｎ個ごと線種

  • (122)　ｎ個ごと線幅

  • (123)　外枠線

  • (124)　外枠線種

  • (125)　外枠線幅

  • (126)　CPI指定

  • (127)　CPI値

(1)　行種別

行種別を出力します。

設定できる値

通常行，特殊編集行，キー集計行，ページ集計行，総集計行

参照先

6.1　データ集計の種類

ページの先頭へ

(2)　レベル

行のレベル番号を出力します。

設定できる値

  • 通常行のとき

    0

  • キー集計行のとき

    101～4,096

  • 特殊編集行のとき

    4,097～4,195

  • ページ集計行のとき

    9,000

  • 総集計行のとき

    10,000

参照先

6.3　キー集計を作成する

ページの先頭へ

(3)　集計ページ

集計ページかどうかを出力します。

設定できる値

ON，OFF

参照先

6.6.7　集計ページを設定する

ページの先頭へ

(4)　アイテム種別

アイテムの種別を出力します。

設定できる値

文字，図形，画像，線

参照先

4.1　アイテムとは

ページの先頭へ

(5)　順序番号

アイテムの重なりの順序を出力します。

設定できる値

整数値

参照先

4.8　複数アイテムの重なりや位置を調整する

ページの先頭へ

(6)　開始X

アイテムの開始X座標を出力します。単位は，1/100mmです。

設定できる値

-41,180～43,180

参照先

4.2　アイテムを配置する

ページの先頭へ

(7)　開始Y

アイテムの開始Y座標を出力します。単位は，1/100mmです。

設定できる値

-41,180～43,180

参照先

4.2　アイテムを配置する

ページの先頭へ

(8)　幅

アイテムの終了X座標を出力します。単位は，1/100mmです。

線の場合は，幅ではなく終了X座標を出力します。

設定できる値

  • 線のとき

    -41,180～43,180

  • 線以外のとき

    100～43,180

参照先

4.2　アイテムを配置する

ページの先頭へ

(9)　高さ

アイテムの終了Y座標を出力します。単位は，1/100mmです。

線の場合は，高さではなく終了Y座標を出力します。

設定できる値

  • 線のとき

    -41,180～43,180

  • 線以外のとき

    100～43,180

参照先

4.2　アイテムを配置する

ページの先頭へ

(10)　繰り返し種別

繰り返しの種別を出力します。

設定できる値

非繰り返し，見出し，繰り返し

参照先

5.3.1　繰り返し定義を設定する

ページの先頭へ

(11)　出力ページ

出力ページを出力します。

設定できる値

表紙，全ページ，先頭ページ，最終ページ

参照先

4.9　特定のページに出力するアイテムを設定する

ページの先頭へ

(12)　表示条件指定

表示条件を有効にするかどうかを出力します。文字/図形/画像アイテムの場合だけ出力します。

設定できる値

ON，OFF

参照先

8.2　アイテムの表示条件を設定する

ページの先頭へ

(13)　表示条件参照フィールド

表示条件を指定するときの参照フィールドを出力します。文字/図形/画像アイテムの場合だけ出力します。

設定できる値

510文字以内の文字列

参照先

8.2　アイテムの表示条件を設定する

ページの先頭へ

(14)　表示条件参照フィールド種別

表示条件を指定するときの参照フィールドの種別を出力します。文字/図形/画像アイテムの場合だけ出力します。

設定できる値

マッピングデータ，ユーザ定義データ，集計値

参照先

8.2　アイテムの表示条件を設定する

ページの先頭へ

(15)　表示条件範囲指定

表示条件を範囲指定するかどうかを出力します。文字/図形/画像アイテムの場合だけ出力します。

設定できる値

ON，OFF

参照先

8.2　アイテムの表示条件を設定する

ページの先頭へ

(16)　表示条件演算子1

表示条件を指定するときに，参照フィールドの値と表示条件指定値1を判定する演算子を出力します。文字/図形/画像アイテムの場合だけ出力します。

設定できる値

次の文字列を含む，次の文字列から始まる，次の文字列で終わる，指定あり，指定なし，＞，＜，≧，≦，＝，≠

参照先

8.2　アイテムの表示条件を設定する

ページの先頭へ

(17)　表示条件演算子2

表示条件を指定するときに，参照フィールドの値と表示条件指定値2を判定する演算子を出力します。文字/図形/画像アイテムの場合だけ出力します。

設定できる値

＞，＜，≧，≦

参照先

8.2　アイテムの表示条件を設定する

ページの先頭へ

(18)　表示条件指定値1

表示条件を指定するときに，参照フィールドの値と判定する値を出力します。文字/図形/画像アイテムの場合だけ出力します。

設定できる値

100文字以内の値

参照先

8.2　アイテムの表示条件を設定する

ページの先頭へ

(19)　表示条件指定値2

表示条件を範囲指定するときに，参照フィールドの値と判定する値を出力します。文字/図形/画像アイテムの場合だけ出力します。

設定できる値

100文字以内の値

参照先

8.2　アイテムの表示条件を設定する

ページの先頭へ

(20)　表示条件表示方法

表示条件を指定するときに，条件が成り立つ場合の動作を出力します。文字/図形/画像アイテムの場合だけ出力します。

設定できる値

表示する，表示しない

参照先

8.2　アイテムの表示条件を設定する

ページの先頭へ

(21)　表示条件指定値1フィールド指定

表示条件の指定値1としてフィールド値を参照するかどうかを出力します。

設定できる値

ON，OFF

参照先

8.2　アイテムの表示条件を設定する

ページの先頭へ

(22)　表示条件指定値2フィールド指定

表示条件の指定値2としてフィールド値を参照するかどうかを出力します。

設定できる値

ON，OFF

参照先

8.2　アイテムの表示条件を設定する

ページの先頭へ

(23)　表示条件指定値1フィールド

表示条件の指定値1として参照するフィールド名を出力します。

設定できる値

510文字以内の文字列

参照先

8.2　アイテムの表示条件を設定する

ページの先頭へ

(24)　表示条件指定値2フィールド

表示条件の指定値2として参照するフィールド名を出力します。

設定できる値

510文字以内の文字列

参照先

8.2　アイテムの表示条件を設定する

ページの先頭へ

(25)　表示条件指定値1フィールド種別

表示条件の指定値1として参照するフィールド種別を出力します。

設定できる値

マッピングデータ，ユーザ定義データ，集計値

参照先

8.2　アイテムの表示条件を設定する

ページの先頭へ

(26)　表示条件指定値2フィールド種別

表示条件の指定値2として参照するフィールド種別を出力します。

設定できる値

マッピングデータユーザ，定義データ，集計値

参照先

8.2　アイテムの表示条件を設定する

ページの先頭へ

(27)　原点

座標の原点を出力します。

設定できる値

貼付域，繰り返し領域

参照先

13.　アイテムのプロパティとオプションを設定する

ページの先頭へ

(28)　横位置

横方向の表示位置を出力します。文字/画像アイテムの場合だけ出力します。

設定できる値

左寄せ，中央，右寄せ，均等

参照先

4.2　アイテムを配置する

ページの先頭へ

(29)　縦位置

縦方向の表示位置を出力します。文字/画像アイテムの場合だけ出力します。

設定できる値

上寄せ，中央，下寄せ，均等

参照先

4.2　アイテムを配置する

ページの先頭へ

(30)　固定/可変

固定アイテム，マッピングデータアイテム，またはユーザ定義データアイテムのどれかを出力します。文字/画像アイテムの場合だけ出力します。

設定できる値

固定，マッピングデータ，ユーザ定義データ

参照先

4.3　データウィンドウからデータを貼り付ける

ページの先頭へ

(31)　フィールド名

マッピングデータアイテムのフィールド名を出力します。文字/画像アイテムの場合だけ出力します。

設定できる値

510文字以内の文字列

参照先

4.3　データウィンドウからデータを貼り付ける

ページの先頭へ

(32)　レコード相対

マッピングデータアイテムの基準レコード位置からの相対位置を出力します。文字/画像アイテムの場合だけ出力します。

設定できる値

-32,766～32,766

参照先

3.5.1　基準レコード位置の変更

ページの先頭へ

(33)　セル名

ユーザ定義データアイテムのフィールド名とレコード番号を出力します。文字/画像アイテムの場合だけ出力します。

設定できる値

510文字以内の文字列

参照先

3.3　データウィンドウのフィールド定義を変更する

ページの先頭へ

(34)　まとめ優先

まとめ表示を指定しているときの階層があるかどうかを出力します。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

ON，OFF

参照先

5.6.1　まとめ表示を設定する

ページの先頭へ

(35)　フォントサイズ

フォントの高さを出力します。単位は，1/10ptです。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

30～2,560

参照先

13.2　文字アイテムと文字データのプロパティを設定する

ページの先頭へ

(36)　太字

フォントを太字にするかどうかを出力します。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

ON，OFF

参照先

13.2　文字アイテムと文字データのプロパティを設定する

ページの先頭へ

(37)　斜体

フォントを斜体にするかどうかを出力します。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

ON，OFF

参照先

13.2　文字アイテムと文字データのプロパティを設定する

ページの先頭へ

(38)　フォント名

フォント名称を出力します。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

31文字以内の文字列

（例）

ＭＳ 明朝

ＭＳゴシック

参照先

13.2　文字アイテムと文字データのプロパティを設定する

ページの先頭へ

(39)　縦横比補正

文字の縦横比を2:1に補正するかどうかを出力します。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

ON，OFF

参照先

13.2　文字アイテムと文字データのプロパティを設定する

ページの先頭へ

(40)　下線

文字に下線を引くかどうかを出力します。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

ON，OFF

参照先

13.2　文字アイテムと文字データのプロパティを設定する

ページの先頭へ

(41)　まとめ

まとめ表示をするかどうかを出力します。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

ON，OFF

参照先

5.6.1　まとめ表示を設定する

ページの先頭へ

(42)　まとめ罫線

まとめ表示をする場合，罫線をまとめるかどうかを出力します。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

ON，OFF

参照先

5.6.1　まとめ表示を設定する

ページの先頭へ

(43)　文字配置方式

バージョン2以前の方式で文字配置するかどうかを出力します。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

ON，OFF

参照先

13.2　文字アイテムと文字データのプロパティを設定する

ページの先頭へ

(44)　文字間隔

文字間隔を出力します。単位は，1/10ptです。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

  • ［狭く］を設定した場合

    1≦設定値≦100

  • ［標準］を設定した場合

    0

  • ［広く］を設定した場合

    1≦設定値≦1,000

参照先

13.2　文字アイテムと文字データのプロパティを設定する

ページの先頭へ

(45)　行間隔

行間隔を出力します。単位は，1/10ptです。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

  • ［狭く］を設定した場合

    1≦設定値≦100

  • ［標準］を設定した場合

    0

  • ［広く］を設定した場合

    1≦設定値≦1,000

参照先

13.2　文字アイテムと文字データのプロパティを設定する

ページの先頭へ

(46)　文字方向

文字の描画方向を出力します。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

上向きで左から右，上向きで上から下，左向きで下から上，右向きで上から下，左向きで左から右

参照先

13.2　文字アイテムと文字データのプロパティを設定する

ページの先頭へ

(47)　文字色

文字色のRGB値を出力します。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

R，G，Bそれぞれ0～255

（例）

0，255，35

参照先

13.2　文字アイテムと文字データのプロパティを設定する

ページの先頭へ

(48)　元年表記

元号年1年を元年と表示するかどうかを出力します。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

ON，OFF

参照先

13.8.2　元号年1年を元年表示する

ページの先頭へ

(49)　出力桁数指定

アイテムの文字ピッチを桁数で指定するかどうかを出力します。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

ON，OFF

参照先

13.2　文字アイテムと文字データのプロパティを設定する

13.3　数値データのプロパティを設定する

ページの先頭へ

(50)　出力桁数

アイテムの桁数を指定したときの桁数を出力します。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

1≦設定値

参照先

13.2　文字アイテムと文字データのプロパティを設定する

13.3　数値データのプロパティを設定する

ページの先頭へ

(51)　フォントリサイズ

縮小して全体を表示するかどうかを出力します。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

ON，OFF

参照先

13.2　文字アイテムと文字データのプロパティを設定する

13.3　数値データのプロパティを設定する

ページの先頭へ

(52)　ワードラップ

ワードラップするかどうかを出力します。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

ON，OFF

参照先

13.2　文字アイテムと文字データのプロパティを設定する

13.3　数値データのプロパティを設定する

13.7　ページ番号アイテムのプロパティを設定する

13.8　日付データのプロパティを設定する

ページの先頭へ

(53)　禁則処理

禁則処理を行うかどうかを出力します。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

ON，OFF

参照先

マニュアル「EUR 帳票作成 画面リファレンス」

ページの先頭へ

(54)　文字列

固定アイテムの文字列を出力します。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

510文字以内の文字列

参照先

4.3　データウィンドウからデータを貼り付ける

ページの先頭へ

(55)　書式

ページ番号アイテム，印刷日付アイテム，印刷時刻アイテムの書式を出力します。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

510文字以内の文字列

（例）

%ip/%it

%p ページ

参照先

4.5　ページ番号を配置する

4.6　印刷日付・印刷時刻を配置する

ページの先頭へ

(56)　固定文字種別

固定文字アイテム，ページ番号アイテム，印刷日付アイテム，または印刷時刻アイテムのどれかを出力します。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

固定，ページ番号，印刷日付，印刷時刻

参照先

4.2　アイテムを配置する

4.5　ページ番号を配置する

4.6　印刷日付・印刷時刻を配置する

ページの先頭へ

(57)　ページ番号桁数

ページ番号アイテムのときのページ番号桁数を出力します。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

0～6の整数値

参照先

13.7　ページ番号アイテムのプロパティを設定する

ページの先頭へ

(58)　書式バージョン

ページ番号アイテムのとき，書式のバージョンを出力します。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

2，3

参照先

13.7　ページ番号アイテムのプロパティを設定する

ページの先頭へ

(59)　データ種別

マッピングデータアイテム，ユーザ定義データアイテムのデータ種別を出力します。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

文字列，数値，数値（集計対象外），日付/時刻，バーコード

参照先

3.6.1　［フィールド定義］ダイアログでサンプルデータを作成する

ページの先頭へ

(60)　置き換え

アイテムの置き換えをするかどうかを出力します。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

ON，OFF

参照先

8.1　文字列や数値を置き換えて表示する

ページの先頭へ

(61)　置き換え表名

置き換えするときの置き換え表名を出力します。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

510文字以内の文字列

参照先

8.1.1　置き換え表ファイルを作成する

ページの先頭へ

(62)　集計種別

集計アイテムの集計種別を出力します。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

合計，件数，最大，最小，平均

参照先

6.6　集計行を編集する

ページの先頭へ

(63)　前付加文字

前付加文字列を出力します。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

510文字以内の文字列

参照先

13.2　文字アイテムと文字データのプロパティを設定する

ページの先頭へ

(64)　後付加文字

後付加文字列を出力します。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

510文字以内の文字列

参照先

13.2　文字アイテムと文字データのプロパティを設定する

ページの先頭へ

(65)　任意書式指定

設定した任意書式を出力します。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

510文字以内の文字列

参照先

13.2　文字アイテムと文字データのプロパティを設定する

(a)　任意書式で設定する書式の記号と意味

書式の設定形式および設定する書式の記号と意味を次に示します。なお，表中では書式記号を””，出力される文字を「」で示します。

書式の設定形式

<書式種別>:[<書式オプション>]:<書式記号>

表15‒3　任意書式で設定する書式の記号と意味

分類

記号

意味

<書式種別>

TS

文字書式の書式を編集します。

TN

数値書式の書式を編集します。数値書式は，入力文字列の前後の空白文字を省略します。

<書式オプション>

OC

適用するデータが書式より長い場合，変換後の文字数分の「?」を出力します。ただし，書式記号が”N”のときは「？」を出力します。数値書式のときは，整数部と小数部を分けてデータ長をチェックします。入力データの長さは，符号を含まない長さでチェックします。

SC

適用するデータが書式より短い場合，変換後の文字数分の「?」を出力します。ただし，書式記号が”N”のときは「？」を出力します。数値書式のときは，整数部と小数部を分けてデータ長をチェックします。入力データの長さは，符号を含まない長さでチェックします。

IR

右の文字から書式を適用します。

IL

左の文字から書式を適用します。

LS

書式適用後，固定文字列を挿入する前に左の<空白文字>を削除します。

RS

書式適用後，固定文字列を挿入する前に右の<空白文字>を削除します。

AS

書式適用後，固定文字列を挿入する前に左右の<空白文字>を削除します。

LZ

数値書式の場合，書式適用前に符号を除いた入力文字の左の0を削除します。ただし，すべて0のときは0を一つ残します。

RZ

数値書式の場合，書式適用前に符号を除いた入力文字の右の0を削除します。ただし，すべて0のときは0を一つ残します。

AZ

数値書式の場合，書式適用前に符号を除いた入力文字の左右の0を削除します。ただし，すべて0のときは0を一つ残します。

ZC

数値書式の場合，書式記号”Z”に対応する入力データが0のときは，0を出力し，入力データがないときは，半角空白を出力します。

CS

数値書式の場合，書式変換で符号だけが入らない場合，”,”をすべて削除して出力します。変換後の”,”をすべて削除し，変換後の左側に符号を付加したあと，書式の桁数と同じになるまで符号の左側に半角スペースを付加します。コンマが削除されるため，符号が出力できるようになります。ただし，書式記号に”,”がない場合は指定できません。

SS

数値書式の場合，符号を0でない数字の先頭に移動します。ただし，整数部に0以外の数字がない場合は符号を移動しません。また，移動前の符号の位置には書式に対応した文字（”9”は「0」，”*”は「*」，それ以外の書式は半角空白）を出力します。

<書式記号>

<文字書式>

X

半角文字を表します。入力文字が全角の場合は，「?」を出力します。

N

全角文字を表します。入力文字が半角の場合は，「？」を出力します。

C

半角文字または全角文字を表します。入力文字が半角の場合は”C”を一つ，全角の場合は”C”を二つとして書式を適用します。入力文字がない場合は，半角空白に置き換えて出力します。最後の”C”に対する入力文字が全角の場合は，半角空白に置き換えて出力します。

X(n)

n個の半角文字を表します。入力文字が全角の場合は，「?」を出力します。

nは1から999までの数値を指定します。

N(n)

n個の全角文字を表します。入力文字が半角の場合は，「？」を出力します。

nは1から999までの数値を指定します。

C(n)

n個の半角文字または全角文字を表します。入力文字が半角の場合は”C”を一つ，全角の場合は”C”を二つとして書式を適用します。入力文字がない場合は，半角空白に置き換えて出力します。最後の”C”に対する入力文字が全角の場合は，半角空白に置き換えて出力します。

nは1から999までの数値を指定します。

<数値書式>

9

<数値>を表します。入力文字がない場合は，0に置き換えて出力します。入力文字が数値以外の場合は，「?」を出力します。

Z

<数値>を表します。入力文字がない，または0の場合は半角空白に置き換えて出力します。入力文字が数値以外の場合は，「?」を出力します。

,

区切り文字として指定位置に出力します。”,”の左側が，半角空白，「+」，「-」，「\」，「$」，「*」になる場合は，”,”をその文字列に置き換えます。

”,”を出力する書式記号を次に示します。

9 | Z | - | + | \ | $ | * | x

.

区切り文字として指定位置に出力します。小数点以下の入力値がない場合は，右側の書式に従って変換します。

”.”を出力する書式記号を次に示します。

9 | Z | - | + | \ | $ | * | x

-

<数値>を表します。入力値から符号を削除して負数の場合，「-」を一つ出力します。入力文字がない場合は，半角空白に置き換えて出力します。入力文字が数値以外の場合は，「?」を出力します。

+

<数値>を表します。入力値から符号を削除して正数の場合は「+」を一つ，負数の場合は「-」を一つ出力します。0の場合は符号を出力しません。入力文字がない場合は，半角空白に置き換えて出力します。入力文字が数値以外の場合は，「?」を出力します。

\

<数値>を表します。数値の先頭に「\」を一つ出力します。入力文字がない場合は，半角空白に置き換えて出力します。入力文字が数値以外の場合は，「?」を出力します。

$

<数値>を表します。先頭に「$」を一つ出力します。入力文字がない場合は，半角空白に置き換えて出力します。入力文字が数値以外の場合は，「?」を出力します。

*

<数値>を表します。入力文字がない場合は，「*」に置き換えて出力します。入力文字が数値以外の場合は，「?」を出力します。

x

<数値>を表します。出力結果の先頭が数字になる場合は，先頭に「*」を一つ出力します。入力文字がない場合は半角空白に置き換えて出力します。入力文字が数値以外の場合は，「?」を出力します。

9(n)

n個の<数値>を表します。入力文字がない場合は，0に置き換えて出力します。

nは1から999までの数値を指定します。

Z(n)

n個の<数値>を表します。入力文字がない，または0の場合は半角空白に置き換えて出力します。

nは1から999までの数値を指定します。

-(n)

n個の<数値>を表します。入力値から符号を削除して負数の場合，「-」を一つ出力します。入力文字がない場合は，半角空白に置き換えて出力します。

nは1から999までの数値を指定します。

+(n)

n個の<数値>を表します。入力値から符号を削除して正数の場合は「+」を一つ，負数の場合は「-」を一つ出力します。0の場合は符号を出力しません。入力文字がない場合は，半角空白に置き換えて出力します。

nは1から999までの数値を指定します。

\(n)

n個の<数値>を表します。数値の先頭に「\」を一つ出力します。入力文字がない場合は，半角空白に置き換えて出力します。

nは1から999までの数値を指定します。

$(n)

n個の<数値>を表します。先頭に「$」を一つ出力します。入力文字がない場合は，半角空白に置き換えて出力します。

nは1から999までの数値を指定します。

*(n)

n個の<数値>を表します。入力文字がない場合は，「*」に置き換えて出力します。

nは1から999までの数値を指定します。

x(n)

n個の<数値>を表します。出力結果の先頭が数字になる場合は，先頭に「*」を一つ出力します。入力文字がない場合は半角空白に置き換えて出力します。

nは1から999までの数値を指定します。

<文字書式>，<数値書式>共通

固定文字列

文字列は""で囲んで記述します。"を文字列として挿入する場合は，""""と指定します。固定文字列は，書式適用後に書式で指定された位置へ挿入します。挿入位置が変換文字列の長さよりも大きい場合は，変換文字列の末尾に固定文字を挿入します。

なお，表中の<空白文字>および<数値>の定義を次に示します。

表15‒4 書式記号と定義
書式記号 | 定義
<空白文字> | #x20，#x09，#x0a，#x0dまたは全角空白を示します。
<数値> | [<符号>]<絶対値>を示します。 <絶対値> = <整数部>[<小数点>[<小数部>]] <整数部> = <数字> <小数部> = <数字> <小数点> =”.” <符号> = + | - <数字> = [0-9]

ページの先頭へ

(66)　カンマ

数値データを3桁ごとにコンマで区切って表示するかどうかを出力します。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

ON，OFF

参照先

13.3　数値データのプロパティを設定する

ページの先頭へ

(67)　小数点以下桁数

小数点以下桁揃えするときの桁数を出力します。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

0～999の整数値

（例）

小数点2桁まで表示する場合，2を指定

参照先

13.3　数値データのプロパティを設定する

ページの先頭へ

(68)　小数点文字

小数点文字を出力します。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

510文字以内の文字列

（例）

.（ピリオド）

参照先

13.3　数値データのプロパティを設定する

ページの先頭へ

(69)　四捨五入

数値データの小数点以下を四捨五入するか，切り上げるか，切り捨てるかを出力します。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

四捨五入，切り捨て，切り上げ

参照先

13.3　数値データのプロパティを設定する

ページの先頭へ

(70)　ゼロ埋め桁数

数値データの桁数を揃えるために，ゼロを埋める桁数を出力します。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

0～999の整数値

（例）

3（3桁に満たない場合は002などと0を付加する）

参照先

13.3　数値データのプロパティを設定する

ページの先頭へ

(71)　指数表示

数値データを指数で表示するかどうかを出力します。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

ON，OFF

参照先

13.3　数値データのプロパティを設定する

ページの先頭へ

(72)　負符号文字

マイナス符号として表示する文字列を出力します。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

510文字以内の文字列

（例）

－

▼

参照先

13.3　数値データのプロパティを設定する

ページの先頭へ

(73)　0データ

値が0のときどのように表示するかを出力します。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

ハイフンを表示，表示しない，0を表示

参照先

13.3　数値データのプロパティを設定する

ページの先頭へ

(74)　空データ

値が空データのとき，どのように表示するかを出力します。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

ハイフンを表示，表示しない

参照先

13.3　数値データのプロパティを設定する

ページの先頭へ

(75)　日付書式

日付の書式を出力します。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

510文字以内の文字列

（例）

%4Y/%2M/%2D（2005/07/06）

%4Y年%2M月%2D日（2005年07月06日）

参照先

13.8　日付データのプロパティを設定する

ページの先頭へ

(76)　日付種別

日付の種別を出力します。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

日付・時刻，日次，月次，年次，和暦（日次），和暦（月次），和暦（年次）

参照先

13.8　日付データのプロパティを設定する

ページの先頭へ

(77)　バーコード種別

バーコードの種別を出力します。

この項目は，アイテムがバーコードのときに出力されます。

設定できる値

JAN標準，JAN短縮，CODE39，CODE128，NW-7，ITF，カスタマバーコード，QRコード

参照先

13.9　バーコードアイテムのプロパティを設定する

ページの先頭へ

(78)　バーコード回転

バーコードの回転方向を出力します。

この項目は，アイテムがバーコードのときに出力されます。

設定できる値

0，90，270

参照先

13.9　バーコードアイテムのプロパティを設定する

ページの先頭へ

(79)　データキャラクタ

データキャラクタを表示するかどうかを出力します。

この項目は，アイテムがバーコードのときに出力されます。

設定できる値

ON，OFF

参照先

13.9　バーコードアイテムのプロパティを設定する

ページの先頭へ

(80)　バーコード倍率

標準サイズに対する倍率を出力します。単位は，1/100倍です。

この項目は，アイテムがバーコードのときに出力されます。

設定できる値

  • JAN標準/UPC-A，JAN短縮/UPC-Eのとき

    15～210

  • ITFのとき

    10～310

参照先

13.9　バーコードアイテムのプロパティを設定する

ページの先頭へ

(81)　バーコードサイズ

バーコードのサイズを出力します。CODE39，CODE128，NW-7のモジュール幅の単位は1/100mm，カスタマバーコードのサイズは1/10ptです。

この項目は，アイテムがバーコードのときに出力されます。

設定できる値

  • CODE39・CODE128のとき

    10～110

  • NW-7のとき

    10～160

  • カスタマバーコードのとき

    80～115

参照先

13.9　バーコードアイテムのプロパティを設定する

ページの先頭へ

(82)　バーコード高さ

JAN標準/UPC-A，JAN短縮/UPC-E，CODE39，CODE128，NW-7/ITFの高さを出力します。単位は，1/100mmです。

この項目は，アイテムがバーコードのときに出力されます。

設定できる値

100～5,000

参照先

13.9　バーコードアイテムのプロパティを設定する

ページの先頭へ

(83)　チェックキャラクタ

チェックキャラクタを付加するかどうかを出力します。

この項目は，アイテムがバーコードのときに出力されます。

設定できる値

ON，OFF

参照先

13.9　バーコードアイテムのプロパティを設定する

ページの先頭へ

(84)　スタートキャラクタ

スタートキャラクタまたはストップキャラクタを付加するかどうかを出力します。

この項目は，アイテムがバーコードのときに出力されます。

設定できる値

ON，OFF

参照先

13.9　バーコードアイテムのプロパティを設定する

ページの先頭へ

(85)　バーコードデータ形式

カスタマバーコード，CODE128またはQRコードの入力データ形式を出力します。

この項目は，アイテムがバーコードのときに出力されます。

設定できる値

チェックデジット無，チェックデジット有，文字列，16進文字列，16進バイナリ，コードセットB，コードセットC

参照先

13.9　バーコードアイテムのプロパティを設定する

ページの先頭へ

(86)　FNC1

CODE128でFNC1を付加するかどうかを出力します。

この項目は，アイテムがバーコードのときに出力されます。

設定できる値

ON，OFF

参照先

13.9　バーコードアイテムのプロパティを設定する

ページの先頭へ

(87)　表示文字認識

CODE128で表示文字を認識するかどうかを出力します。

この項目は，アイテムがバーコードのときに出力されます。

設定できる値

ON，OFF

参照先

13.9　バーコードアイテムのプロパティを設定する

ページの先頭へ

(88)　機能コード

CODE128で機能コードを指定するかどうかを出力します。

この項目は，アイテムがバーコードのときに出力されます。

設定できる値

ON，OFF

参照先

13.9　バーコードアイテムのプロパティを設定する

ページの先頭へ

(89)　データキャラクタプロパティ

データキャラクタの属性を設定するかどうかを出力します。

この項目は，アイテムがバーコードのときに出力されます。

設定できる値

ON，OFF

参照先

13.9　バーコードアイテムのプロパティを設定する

ページの先頭へ

(90)　データキャラクタ行数

CODE128でデータキャラクタの最大行数を出力します。

この項目は，アイテムがバーコードのときに出力されます。

設定できる値

1～9

参照先

13.9　バーコードアイテムのプロパティを設定する

ページの先頭へ

(91)　データキャラクタフォント

CODE128でデータキャラクタのフォント名を出力します。

この項目は，アイテムがバーコードのときに出力されます。

設定できる値

31文字以内の文字列

（例）

ＭＳP明朝

参照先

13.9　バーコードアイテムのプロパティを設定する

ページの先頭へ

(92)　データキャラクタサイズ

CODE128でデータキャラクタのフォントサイズを出力します。単位は，1/10ptです。

この項目は，アイテムがバーコードのときに出力されます。

設定できる値

30～2,560

参照先

13.9　バーコードアイテムのプロパティを設定する

ページの先頭へ

(93)　データキャラクタ縦位置

CODE128でデータキャラクタの縦位置を出力します。単位は，1/100mmです。

この項目は，アイテムがバーコードのときに出力されます。

設定できる値

0～16,860

参照先

13.9　バーコードアイテムのプロパティを設定する

ページの先頭へ

(94)　データキャラクタ横位置

CODE128でデータキャラクタの横位置を出力します。

この項目は，アイテムがバーコードのときに出力されます。

設定できる値

左寄せ，中央

参照先

13.9　バーコードアイテムのプロパティを設定する

ページの先頭へ

(95)　訂正レベル

QRコードの訂正レベルを出力します。

この項目は，アイテムがバーコードのときに出力されます。

設定できる値

M，Q

参照先

13.9　バーコードアイテムのプロパティを設定する

ページの先頭へ

(96)　バージョン

QRコードの最低バージョンを出力します。

この項目は，アイテムがバーコードのときに出力されます。

設定できる値

1～40

参照先

13.9　バーコードアイテムのプロパティを設定する

ページの先頭へ

(97)　セルサイズ

QRコードのセルサイズを出力します。

この項目は，アイテムがバーコードのときに出力されます。

設定できる値

21～126

参照先

13.9　バーコードアイテムのプロパティを設定する

ページの先頭へ

(98)　図形種別

図形の種別を出力します。

この項目は，アイテムが図形アイテムのときに出力されます。

設定できる値

網掛け，角丸四角，円/楕円，多角形

参照先

13.5　図形アイテムのプロパティを設定する

ページの先頭へ

(99)　模様

模様の種別を出力します。

この項目は，アイテムが図形アイテムのときに出力されます。

設定できる値

薄い網掛け，やや薄い網掛け，やや濃い網掛け，濃い網掛け，右下がり点線，右上がり点線，濃い右下がり点線，濃い右上がり点線，透明，塗りつぶし，横縞，縦縞，濃い横縞，濃い縦縞

参照先

13.5　図形アイテムのプロパティを設定する

ページの先頭へ

(100)　ｎ個ごと繰り返し

ｎ個ごと繰り返しをする模様の種別を出力します。

この項目は，アイテムが図形アイテムのときに出力されます。

設定できる値

薄い網掛け，やや薄い網掛け，やや濃い網掛け，濃い網掛け，右下がり点線，右上がり点線，濃い右下がり点線，濃い右上がり点線，透明，塗りつぶし，横縞，縦縞，濃い横縞，濃い縦縞

参照先

13.5　図形アイテムのプロパティを設定する

ページの先頭へ

(101)　ｎ個

模様をｎ個ごと繰り返しするときのｎを出力します。

この項目は，アイテムが図形アイテムのときに出力されます。

設定できる値

0または2～32,767の整数値

参照先

13.5　図形アイテムのプロパティを設定する

ページの先頭へ

(102)　背景色

模様の背景色のRGB値を出力します。

この項目は，アイテムが図形アイテムのときに出力されます。

設定できる値

R，G，Bそれぞれ0～255

（例）

0，255，35

参照先

13.5　図形アイテムのプロパティを設定する

ページの先頭へ

(103)　前景色

模様の前景色のRGB値を出力します。

この項目は，アイテムが図形アイテムのときに出力されます。

設定できる値

R，G，Bそれぞれ0～255

（例）

0，255，35

参照先

13.5　図形アイテムのプロパティを設定する

ページの先頭へ

(104)　枠線

図形の枠線を表示するかどうかを出力します。

この項目は，アイテムが図形アイテムのときに出力されます。

設定できる値

ON，OFF

参照先

13.5　図形アイテムのプロパティを設定する

ページの先頭へ

(105)　枠線種別

図形の枠線の種別を出力します。

この項目は，アイテムが図形アイテムのときに出力されます。

設定できる値

実線1，実線2，実線3，実線4

破線1，破線2，破線3，破線4

点線1，点線2，点線3，点線4

一点鎖線1，一点鎖線2，一点鎖線3，一点鎖線4

二点鎖線1，二点鎖線2，二点鎖線3，二点鎖線4

点線（丸）1，点線（丸）2，点線（丸）3，点線（丸）4

点線（角）1，点線（角）2，点線（角）3，点線（角）4

参照先

13.5　図形アイテムのプロパティを設定する

ページの先頭へ

(106)　枠線色

図形の枠線の色をRGB値で出力します。

この項目は，アイテムが図形アイテムのときに出力されます。

設定できる値

R，G，Bそれぞれ0～255

（例）

0，255，35

参照先

13.5　図形アイテムのプロパティを設定する

ページの先頭へ

(107)　丸め半径X

図形の角丸めの半径Xを出力します。単位は，1/100mmです。

この項目は，アイテムが図形アイテムのときに出力されます。

設定できる値

0≦X≦アイテムの短辺の1/2

参照先

13.5　図形アイテムのプロパティを設定する

ページの先頭へ

(108)　丸め半径Y

図形の角丸めの半径Yを出力します。単位は，1/100mmです。

この項目は，アイテムが図形アイテムのときに出力されます。

設定できる値

0≦Y≦アイテムの短辺の1/2

参照先

13.5　図形アイテムのプロパティを設定する

ページの先頭へ

(109)　影

図形に影を付けるかどうかを出力します。

この項目は，アイテムが図形アイテムのときに出力されます。

設定できる値

ON，OFF

参照先

13.5　図形アイテムのプロパティを設定する

ページの先頭へ

(110)　角丸

図形のどの角を丸めるかを出力します。次の値の合計値で求めます。

左上：1　右上：2　左下：4　右下：8

この項目は，アイテムが図形アイテムのときに出力されます。

設定できる値

0～15の整数値

（例）

  • 左上と右下の角を丸くしたい場合，9を設定

    左上：1＋右下：8＝9

  • 右上と左下と右下の角を丸くしたい場合，14を設定

    右上：2＋左下：4＋右下：8＝14

参照先

13.5　図形アイテムのプロパティを設定する

ページの先頭へ

(111)　頂点個数

多角形の頂点の個数を出力します。

この項目は，アイテムが図形アイテムのときに出力されます。

設定できる値

0または3～36の整数値

参照先

13.5　図形アイテムのプロパティを設定する

ページの先頭へ

(112)　頂点座標

多角形の頂点の座標を出力します。単位は，1/100mmです。

この項目は，アイテムが図形アイテムのときに出力されます。

設定できる値

510文字以内の文字列

参照先

13.5　図形アイテムのプロパティを設定する

ページの先頭へ

(113)　拡大/縮小

画像を拡大/縮小するかどうかを出力します。ONを指定した場合，画像サイズで表示されます。

この項目は，アイテムが画像アイテムのときに出力されます。

設定できる値

ON，OFF

参照先

13.6　画像アイテムのプロパティを設定する

ページの先頭へ

(114)　縦横比保持

画像の拡大/縮小時に縦横比を保持するかどうかを出力します。

この項目は，アイテムが画像アイテムのときに出力されます。

設定できる値

ON，OFF

参照先

13.6　画像アイテムのプロパティを設定する

ページの先頭へ

(115)　ファイル名

固定画像ファイル名を出力します。

この項目は，アイテムが画像アイテムのときに出力されます。

設定できる値

255文字以内の文字列

（例）

XXX.bmp

YYY.tif

参照先

13.6　画像アイテムのプロパティを設定する

ページの先頭へ

(116)　線種

線の種別を出力します。

この項目は，アイテムが線アイテムのときに出力されます。

設定できる値

実線1，実線2，実線3，実線4

破線1，破線2，破線3，破線4

点線1，点線2，点線3，点線4

一点鎖線1，一点鎖線2，一点鎖線3，一点鎖線4

二点鎖線1，二点鎖線2，二点鎖線3，二点鎖線4

点線（丸）1，点線（丸）2，点線（丸）3，点線（丸）4

点線（角）1，点線（角）2，点線（角）3，点線（角）4

任意実線，任意破線，任意点線，任意一点鎖線，任意二点鎖線，任意点線（丸），任意点線（角）

参照先

13.4　線アイテムのプロパティを設定する

ページの先頭へ

(117)　線幅

任意実線の線幅を出力します。単位は，1/10ptです。

この項目は，アイテムが線アイテムのときに出力されます。

設定できる値

1～100

参照先

13.4　線アイテムのプロパティを設定する

ページの先頭へ

(118)　線色

線の色のRGB値を出力します。

この項目は，アイテムが線アイテムのときに出力されます。

設定できる値

R，G，Bそれぞれ0～255

（例）

0，255，35

参照先

13.4　線アイテムのプロパティを設定する

ページの先頭へ

(119)　ｎ個ごと繰り返し

ｎ個ごとの繰り返しをするかどうかを出力します。

この項目は，アイテムが線アイテムのときに出力されます。

設定できる値

ON，OFF

参照先

13.4　線アイテムのプロパティを設定する

ページの先頭へ

(120)　線ｎ個

ｎ個ごとの繰り返しをするときのｎの値を出力します。

この項目は，アイテムが線アイテムのときに出力されます。

設定できる値

0または2～32,767の整数値

参照先

13.4　線アイテムのプロパティを設定する

ページの先頭へ

(121)　ｎ個ごと線種

ｎ個ごと繰り返しするときの線種を出力します。

この項目は，アイテムが線アイテムのときに出力されます。

設定できる値

実線1，実線2，実線3，実線4

破線1，破線2，破線3，破線4

点線1，点線2，点線3，点線4

一点鎖線1，一点鎖線2，一点鎖線3，一点鎖線4

二点鎖線1，二点鎖線2，二点鎖線3，二点鎖線4

点線（丸）1，点線（丸）2，点線（丸）3，点線（丸）4

点線（角）1，点線（角）2，点線（角）3，点線（角）4

任意実線，任意破線，任意点線，任意一点鎖線，任意二点鎖線，任意点線（丸），任意点線（角）

参照先

13.4　線アイテムのプロパティを設定する

ページの先頭へ

(122)　ｎ個ごと線幅

繰り返し線，任意サイズ実線でｎ個ごとの繰り返しをするときの線幅を出力します。単位は，1/10ptです。

この項目は，アイテムが線アイテムのときに出力されます。

設定できる値

1～100

参照先

13.4　線アイテムのプロパティを設定する

ページの先頭へ

(123)　外枠線

繰り返し外枠線を引くかどうかを出力します。

この項目は，アイテムが線アイテムのときに出力されます。

設定できる値

ON，OFF

参照先

13.4　線アイテムのプロパティを設定する

ページの先頭へ

(124)　外枠線種

繰り返し外枠線の線種を出力します。

この項目は，アイテムが線アイテムのときに出力されます。

設定できる値

実線1，実線2，実線3，実線4

破線1，破線2，破線3，破線4

点線1，点線2，点線3，点線4

一点鎖線1，一点鎖線2，一点鎖線3，一点鎖線4

二点鎖線1，二点鎖線2，二点鎖線3，二点鎖線4

点線（丸）1，点線（丸）2，点線（丸）3，点線（丸）4

点線（角）1，点線（角）2，点線（角）3，点線（角）4

任意実線，任意破線，任意点線，任意一点鎖線，任意二点鎖線，任意点線（丸），任意点線（角）

参照先

13.4　線アイテムのプロパティを設定する

ページの先頭へ

(125)　外枠線幅

繰り返し外枠線，および任意サイズ実線の幅を出力します。単位は，1/10ptです。

この項目は，アイテムが線アイテムのときに出力されます。

設定できる値

1～100

参照先

13.4　線アイテムのプロパティを設定する

ページの先頭へ

(126)　CPI指定

アイテムの文字ピッチをCPIで指定するかどうかを出力します。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

ON，OFF

参照先

13.2　文字アイテムと文字データのプロパティを設定する

13.3　数値データのプロパティを設定する

ページの先頭へ

(127)　CPI値

アイテムの文字ピッチをCPIで指定したときの値を出力します。単位は，1/100CPIです。

この項目は，アイテムが文字アイテムのときに出力されます。

設定できる値

13～2,400

参照先

13.2　文字アイテムと文字データのプロパティを設定する

13.3　数値データのプロパティを設定する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 311 / 356


15.4.4 部品定義情報ファイル : EUR 帳票作成 操作ガイド

  • 312 / 356

  • 表紙

  • 15.　作成した帳票の情報をインポート，エクスポートする

  • 15.4　帳票定義情報ファイルの構成

  • 15.4.4　部品定義情報ファイル

15.4.4　部品定義情報ファイル

部品についての帳票定義情報が出力されます。

部品定義情報ファイルの項目の設定値は，部品単位で設定してください。部品名，部品IDなど一つの項目の設定値だけ変更しても，うまく定義できないことがあります。

部品定義情報ファイルに出力される項目名と設定値を次に示します。

〈この項の構成〉

  • (1)　順序番号

  • (2)　部品名

  • (3)　部品ID

  • (4)　部品バージョン

  • (5)　コメント

  • (6)　作成日付

  • (7)　X位置固定

  • (8)　Y位置固定

  • (9)　基準位置

  • (10)　初期X位置

  • (11)　初期Y位置

  • (12)　初期位置

  • (13)　文字アイテム

  • (14)　図形アイテム

  • (15)　画像アイテム

  • (16)　線

  • (17)　開始X

  • (18)　開始Y

  • (19)　幅

  • (20)　高さ

(1)　順序番号

部品の重なりの順序を出力します。

設定できる値

整数値（1以上）

参照先

4.8　複数アイテムの重なりや位置を調整する

ページの先頭へ

(2)　部品名

部品名を出力します。

設定できる値

30文字以内の文字列

（例）

部品0001

参照先

12.2　部品を登録する

ページの先頭へ

(3)　部品ID

部品IDを出力します。

設定できる値

36文字の文字列

参照先

12.2　部品を登録する

ページの先頭へ

(4)　部品バージョン

部品バージョンを出力します。

設定できる値

510文字以内の文字列

参照先

12.2　部品を登録する

ページの先頭へ

(5)　コメント

部品のコメントを出力します。

設定できる値

200文字以内の文字列

参照先

12.2　部品を登録する

ページの先頭へ

(6)　作成日付

部品の作成日付を出力します。

設定できる値

510文字以内の文字列

参照先

12.2　部品を登録する

ページの先頭へ

(7)　X位置固定

部品のX座標の表示位置を指定するかどうかを出力します。

設定できる値

ON，OFF

参照先

12.2　部品を登録する

ページの先頭へ

(8)　Y位置固定

部品のY座標の表示位置を指定するかどうかを出力します。

設定できる値

ON，OFF

参照先

12.2　部品を登録する

ページの先頭へ

(9)　基準位置

部品の表示位置の基準位置を出力します。

設定できる値

用紙左上，用紙右上，用紙左下，用紙右下

参照先

12.2　部品を登録する

ページの先頭へ

(10)　初期X位置

X位置の初期位置を出力します。

設定できる値

0～43,180

参照先

12.2　部品を登録する

ページの先頭へ

(11)　初期Y位置

Y位置の初期位置を出力します。

設定できる値

0～43,180

参照先

12.2　部品を登録する

ページの先頭へ

(12)　初期位置

部品の表示位置に指定するかどうかを出力します。

設定できる値

ON，OFF

参照先

12.2　部品を登録する

ページの先頭へ

(13)　文字アイテム

文字アイテムのアイテムIDを出力します。

設定できる値

510文字以内の文字列

参照先

12.2　部品を登録する

ページの先頭へ

(14)　図形アイテム

図形アイテムのアイテムIDを出力します。

設定できる値

510文字以内の文字列

参照先

12.2　部品を登録する

ページの先頭へ

(15)　画像アイテム

画像アイテムのアイテムIDを出力します。

設定できる値

510文字以内の文字列

参照先

12.2　部品を登録する

ページの先頭へ

(16)　線

線アイテムのアイテムIDを出力します。

設定できる値

510文字以内の文字列

参照先

12.2　部品を登録する

ページの先頭へ

(17)　開始X

部品の表示位置のX座標を出力します。単位は，1/100mmです。

設定できる値

-41,180～43,180

参照先

12.2　部品を登録する

ページの先頭へ

(18)　開始Y

部品の表示位置のY座標を出力します。単位は，1/100mmです。

設定できる値

-41,180～43,180

参照先

12.2　部品を登録する

ページの先頭へ

(19)　幅

部品の幅を出力します。単位は，1/100mmです。

設定できる値

0～43,180

参照先

12.2　部品を登録する

ページの先頭へ

(20)　高さ

部品の高さを出力します。単位は，1/100mmです。

設定できる値

0～43,180

参照先

12.2　部品を登録する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 312 / 356


15.4.5 フィールド定義情報ファイル : EUR 帳票作成 操作ガイド

  • 313 / 356

  • 表紙

  • 15.　作成した帳票の情報をインポート，エクスポートする

  • 15.4　帳票定義情報ファイルの構成

  • 15.4.5　フィールド定義情報ファイル

15.4.5　フィールド定義情報ファイル

フィールド定義についての帳票定義情報が出力されます。

設定値はフィールド定義されている行だけ出力されます。

フィールド定義情報ファイルに出力される項目名と設定値を次に示します。

〈この項の構成〉

  • (1)　対象〔フィールド定義情報ファイル〕

  • (2)　データ種別

  • (3)　データファイル名

  • (4)　サンプル件数

  • (5)　特殊行編集

  • (6)　ブレイク編集

  • (7)　空レコード無視

  • (8)　ヌル無視

  • (9)　辞書定義方法

  • (10)　区切り方法

  • (11)　見出し

  • (12)　区切り文字

  • (13)　区切り位置

  • (14)　辞書ファイル名

  • (15)　フィールド名

  • (16)　種別

  • (17)　サンプルデータ

  • (18)　KEIS専用

(1)　対象〔フィールド定義情報ファイル〕

データの種類を出力します。

設定できる値

マッピングデータ，ユーザ定義データ

参照先

3.3.2　フィールド定義の変更手順

ページの先頭へ

(2)　データ種別

データ種別を出力します。

設定できる値

サンプルデータ，データファイル

参照先

3.　データを読み込む

ページの先頭へ

(3)　データファイル名

データファイル名を出力します。

設定できる値

255文字以内の文字列

（例）

宛名ラベル.csv

参照先

3.　データを読み込む

ページの先頭へ

(4)　サンプル件数

サンプルデータの件数を出力します。

設定できる値

1～100

参照先

3.6.1　［フィールド定義］ダイアログでサンプルデータを作成する

ページの先頭へ

(5)　特殊行編集

特殊編集レベルのサンプルデータを作成するかどうかを出力します。

設定できる値

ON，OFF

参照先

3.6.1　［フィールド定義］ダイアログでサンプルデータを作成する

ページの先頭へ

(6)　ブレイク編集

改ブロック/改ページのサンプルデータを作成するかどうかを出力します。

設定できる値

ON，OFF

参照先

3.6.1　［フィールド定義］ダイアログでサンプルデータを作成する

ページの先頭へ

(7)　空レコード無視

空レコードを無視するかどうかを出力します。

設定できる値

ON，OFF

参照先

3.2.1　CSV形式およびDAT形式のデータの読み込み

ページの先頭へ

(8)　ヌル無視

0x00だけのレコードを無視するかどうかを出力します。

設定できる値

ON，OFF

参照先

3.2.1　CSV形式およびDAT形式のデータの読み込み

ページの先頭へ

(9)　辞書定義方法

フィールド定義の種類を出力します。

設定できる値

フィールド定義，ディクショナリ，SEWB

参照先

マニュアル「EUR データベース連携ガイド」

ページの先頭へ

(10)　区切り方法

コンマやスペースなどの文字で区切るか，指定した位置で区切るかを指定します。

設定できる値

文字区切り（区切り文字指定），桁区切り（区切り位置指定），バイト区切り（区切り位置指定）

参照先

マニュアル「EUR システム設計ガイド」

ページの先頭へ

(11)　見出し

1行目を見出しとするかどうかを出力します。

設定できる値

ON，OFF

参照先

3.5.1　基準レコード位置の変更

ページの先頭へ

(12)　区切り文字

区切り文字（コンマや空白など）を出力します。

設定できる値

1文字以内

参照先

マニュアル「EUR システム設計ガイド」

ページの先頭へ

(13)　区切り位置

区切り位置を出力します。

設定できる値

1～510

参照先

3.2.2　FIX形式のデータの読み込み

ページの先頭へ

(14)　辞書ファイル名

ディクショナリファイルのファイル名を出力します。

設定できる値

255文字以内の文字列

参照先

3.7　ディクショナリファイルを使用する

ページの先頭へ

(15)　フィールド名

フィールド名称を出力します。

設定できる値

510文字以内の文字列

参照先

3.3　データウィンドウのフィールド定義を変更する

ページの先頭へ

(16)　種別

フィールドのデータの種別を出力します。

設定できる値

文字，数値，数値（集計対象外），日付（日付・時刻），日付（日次），日付（月次），日付（年次），和暦（日次），和暦（月次），和暦（年次），画像，バーコード，特殊編集レベル

参照先

3.3　データウィンドウのフィールド定義を変更する

ページの先頭へ

(17)　サンプルデータ

サンプルデータを出力します。

設定できる値

510文字以内の文字列

参照先

3.3　データウィンドウのフィールド定義を変更する

ページの先頭へ

(18)　KEIS専用

KEIS専用かどうかを出力します。

設定できる値

ON，OFF

参照先

3.3　データウィンドウのフィールド定義を変更する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 313 / 356


15.4.6 補足情報ファイル : EUR 帳票作成 操作ガイド

  • 314 / 356

  • 表紙

  • 15.　作成した帳票の情報をインポート，エクスポートする

  • 15.4　帳票定義情報ファイルの構成

  • 15.4.6　補足情報ファイル

15.4.6　補足情報ファイル

データベースアクセス定義情報を示したファイルや固定画像ファイルについての帳票定義情報が出力されます。

補足情報ファイルには，ファイルの内容がそのまま表示されます。ファイルの内容を編集したい場合は，マニュアル「EUR クライアント帳票出力」を参照してください。

表15‒5 補足情報ファイルに出力される項目
出力項目 | 出力内容
マッピングデータの接続先情報ファイル | 接続先情報ファイルの内容が出力されます。
ユーザ定義データの接続先情報ファイル
マッピングデータの抽出結果を出力したCSVファイル | データベースアクセス定義での抽出結果を出力したCSVファイルの内容が出力されます。
ユーザ定義データの抽出結果を出力したCSVファイル
固定画像ファイル名 | 固定画像ファイルのファイル名称が出力されます。
固定画像ファイル | 固定画像ファイルの内容が出力されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 314 / 356


15.5 帳票定義情報ファイルを保存する : EUR 帳票作成 操作ガイド

  • 315 / 356

  • 表紙

  • 15.　作成した帳票の情報をインポート，エクスポートする

  • 15.5　帳票定義情報ファイルを保存する

15.5　帳票定義情報ファイルを保存する

編集した帳票定義情報ファイルを保存します。上書き保存では正しく保存できないので，次の手順に従って保存してください。

  1. ［ファイル］－［名前を付けて保存］を選択します。

    ［ファイル名を付けて保存］ダイアログが表示されます。

  2. ［ファイルの種類］リストボックスで「CSV（カンマ区切り）（*.csv）」を選択します。

    ［ファイル名］テキストボックスに表示されているファイル名は変更しません。

  3. ［保存］ボタンをクリックします。

    CSV形式でファイルを保存するかどうかを確認するダイアログが表示されるので，［はい］ボタンをクリックします。帳票定義情報ファイルが保存されます。

重要

帳票定義情報ファイルを保存する場合は，必ずUnicodeで保存してください。

Excelで編集して保存する場合に「CSV（カンマ区切り）（*.csv）」を選択すると，Unicodeで保存されません。Unicodeで保存するためには，Excelで編集したあとに，次のどちらかの方法でファイルを保存してください。

  • 「Unicode テキスト（*.txt）」で保存したあと，タブコード区切り形式のファイルをカンマ区切り形式のファイルに変換する

  • 「CSV（カンマ区切り）（*.csv）」で保存したあと，メモ帳などのテキストエディタで文字コードをUnicodeに変更して保存し直す

なお，帳票定義情報ファイルでShift JIS以外の文字を使用している場合，Excelの「CSV（カンマ区切り）（*.csv）」でファイルを保存すると，文字化けが発生します。Shift JIS以外の文字を使用する場合は，Unicodeを使用できるテキストエディタで編集してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 315 / 356


15.6 帳票定義情報ファイルから帳票ファイルに変換する : EUR 帳票作成 操作ガイド

  • 316 / 356

  • 表紙

  • 15.　作成した帳票の情報をインポート，エクスポートする

  • 15.6　帳票定義情報ファイルから帳票ファイルに変換する

15.6　帳票定義情報ファイルから帳票ファイルに変換する

帳票定義情報ファイルを帳票ファイルに変換します。

帳票定義情報ファイルを変換するには，帳票定義情報ファイルの構成を示した帳票定義情報構成ファイル（.esp）が必要です。変換された帳票ファイルは，帳票定義情報構成ファイルの拡張子を「.fms」に変更した名称になります。

帳票定義情報ファイルを帳票ファイルに変換した場合，帳票ファイルのバージョンは変換したEURと同じバージョンになります。

また，英語ロケールから中国語ロケール，日本語ロケールから英語ロケールなど異なるロケール間では変換できません。

帳票定義情報ファイルを帳票ファイルに変換する方法には，次の2種類があります。

  • ［帳票定義情報ファイルの入出力］ダイアログで実行する方法

  • eurspcsvコマンドで実行する方法

ここでは，［帳票定義情報ファイルの入出力］ダイアログで実行する方法について説明します。eurspcsvコマンドで実行する方法については，「15.7　eurspcsvコマンドを使ってインポート，エクスポートする」を参照してください。

〈この節の構成〉

  • 15.6.1　帳票定義情報ファイルを帳票ファイルに変換する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 316 / 356


15.6.1 帳票定義情報ファイルを帳票ファイルに変換する : EUR 帳票作成 操作ガイド

  • 317 / 356

  • 表紙

  • 15.　作成した帳票の情報をインポート，エクスポートする

  • 15.6　帳票定義情報ファイルから帳票ファイルに変換する

  • 15.6.1　帳票定義情報ファイルを帳票ファイルに変換する

15.6.1　帳票定義情報ファイルを帳票ファイルに変換する

  1. スタートメニューの［EUR Designer］または［EUR Developer］の下位の［ツール］－［帳票定義情報ファイルの入出力］を選択します。

    ［帳票定義情報ファイルの入出力］ダイアログが起動します。

  2. ［帳票定義情報ファイルを帳票ファイルに変換する］ラジオボタンを選択します。

  3. 「入力元フォルダ」の［参照］ボタンをクリックします。

    ［参照］ボタンをクリックすると，［ファイルを選択］ダイアログが開きます。［ファイルを選択］ダイアログで，変換する帳票定義情報ファイル（.esp）を選択し，［開く］ボタンをクリックします。ファイルは複数選択できます。「入力ファイル一覧」に選択したファイル名が表示されます。

    ［ファイルを選択］ダイアログでは，変換するファイル以外のファイルを選択しないでください。

  4. 「出力先フォルダ」の［参照］ボタンをクリックします。

    ［参照］ボタンをクリックすると，［フォルダの参照］ダイアログが開きます。［フォルダの参照］ダイアログで，帳票ファイルを格納するフォルダを選択し，［OK］ボタンをクリックします。

  5. ［実行］ボタンをクリックします。

    変換が成功したかどうかを知らせる［変換結果の確認］ダイアログが表示され，指定したフォルダに帳票ファイルが格納されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 317 / 356


15.7 eurspcsvコマンドを使ってインポート，エクスポートする : EUR 帳票作成 操作ガイド

  • 318 / 356

  • 表紙

  • 15.　作成した帳票の情報をインポート，エクスポートする

  • 15.7　eurspcsvコマンドを使ってインポート，エクスポートする

15.7　eurspcsvコマンドを使ってインポート，エクスポートする

eurspcsvコマンドを使用して，コマンドラインから帳票定義情報ファイルへの変換および帳票ファイルへの再変換ができます。

〈この節の構成〉

  • 15.7.1　eurspcsvコマンドの構文

  • 15.7.2　eurspcsvコマンドのオプション一覧

  • 15.7.3　eurspcsvコマンドのオプションの説明

  • 15.7.4　終了コード

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 318 / 356


15.7.1 eurspcsvコマンドの構文 : EUR 帳票作成 操作ガイド

  • 319 / 356

  • 表紙

  • 15.　作成した帳票の情報をインポート，エクスポートする

  • 15.7　eurspcsvコマンドを使ってインポート，エクスポートする

  • 15.7.1　eurspcsvコマンドの構文

15.7.1　eurspcsvコマンドの構文

eurspcsvコマンドの構文を次に示します。

eurspcsv〔.exe〕
       〔
        /t { csv | fms }
        /in 変換対象のファイル名
        /out 出力先フォルダのパス
        〔 /msglv { info | error | none }〕
        〔 /w { on | off }〕
       〕

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 319 / 356


15.7.2 eurspcsvコマンドのオプション一覧 : EUR 帳票作成 操作ガイド

  • 320 / 356

  • 表紙

  • 15.　作成した帳票の情報をインポート，エクスポートする

  • 15.7　eurspcsvコマンドを使ってインポート，エクスポートする

  • 15.7.2　eurspcsvコマンドのオプション一覧

15.7.2　eurspcsvコマンドのオプション一覧

eurspcsvコマンドで実行する場合に使用するオプションの一覧を次に示します。各オプションの指定内容の詳細は「15.7.3　eurspcsvコマンドのオプションの説明」を参照してください。

オプションをすべて省略した場合は，［帳票定義情報ファイルの入出力］ダイアログが起動します。一つでもオプションを指定した場合は，コマンドで実行します。

表15‒6 eurspcsvコマンドで指定するオプション一覧
オプション | オプションの指定内容 | 必須/任意
/t | 変換方法の指定 | ◎
/in | 変換対象のファイル名の指定 | ◎
/out | 変換後のファイルを出力するフォルダの指定 | ◎
/msglv | ログファイルへのメッセージ出力レベルの指定 | ○
/w | ファイルを上書きするかどうかの指定 | ○
（凡例）

◎：eurspcsvコマンドで実行する場合に必ず指定するオプションです。

○：指定を省略できるオプションです。

なお，eurspcsvコマンドで必須のオプションを省略した場合，エラー（KEES102-E）になります。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 320 / 356


15.7.3 eurspcsvコマンドのオプションの説明 : EUR 帳票作成 操作ガイド

  • 321 / 356

  • 表紙

  • 15.　作成した帳票の情報をインポート，エクスポートする

  • 15.7　eurspcsvコマンドを使ってインポート，エクスポートする

  • 15.7.3　eurspcsvコマンドのオプションの説明

15.7.3　eurspcsvコマンドのオプションの説明

eurspcsvコマンドに指定するオプションを説明します。オプションの文字列は，大文字，小文字を区別しません。

〈この項の構成〉

  • (1)　/tオプション

  • (2)　/inオプション

  • (3)　/outオプション

  • (4)　/msglvオプション

  • (5)　/wオプション

(1)　/tオプション

帳票ファイルを帳票定義情報ファイルに変換するのか，帳票定義情報ファイルを帳票ファイルに変換するのかを指定します。

表15‒7 /tオプションの指定値
指定値 | 説明
csv | 帳票ファイルを帳票定義情報ファイルに変換します。
fms | 帳票定義情報ファイルを帳票ファイルに変換します。

/tオプションにcsv，fms以外の値を指定した場合，エラー（KEES101-E）になります。

ページの先頭へ

(2)　/inオプション

変換対象のファイル（帳票ファイル，または帳票定義情報ファイル）のファイル名を指定します。フルパス，相対パス，またはファイル名だけのどれかで指定してください。

  • ファイル名をフルパスで指定した場合

    設定されているフォルダからファイルを読み込みます。

  • ファイル名を相対パスで指定した場合

    コマンドを実行したフォルダからの相対パスとしてファイルを読み込みます。

  • ファイル名だけ指定した場合

    コマンドを実行したフォルダからの相対パスとして帳票定義情報ファイルを読み込みます。

ファイル名に指定できる文字数は，ファイル名を含めて259文字までです。259文字を超えた場合は，エラー（KEES101-E）となります。

ページの先頭へ

(3)　/outオプション

変換後のファイルを出力するフォルダを指定します。フルパス，相対パス，またはフォルダ名だけのどれかで指定してください。

  • フォルダ名をフルパスで指定した場合

    設定されているフォルダにファイルを出力します。

  • フォルダ名を相対パスで指定した場合

    コマンドを実行したフォルダからの相対パスとしてファイルを出力します。

  • フォルダ名だけ指定した場合

    コマンドを実行したフォルダからの相対パスとしてファイルを出力します。

フォルダ名に指定できる文字数は，フォルダ名を含めて259文字までです。259文字を超えた場合は，エラー（KEES101-E）となります。

ページの先頭へ

(4)　/msglvオプション

メッセージの出力レベルを指定します。コマンド実行後の変換結果は標準出力に出力されますが，コマンドプロンプトなどの画面上には出力されません。変換結果は，コマンドラインでファイルへの出力を指定して，出力結果を確認してください。

表15‒8 /msglvオプションの指定値
指定値 | 説明
info | 変換結果をすべて出力します。
error | 出力レベルがエラーになったメッセージだけを出力します。
none | 出力しません。

/msglvオプションを省略した場合は，infoが仮定されます。info，error，none以外の値を指定した場合，エラー（KEES101-E）になります。

ページの先頭へ

(5)　/wオプション

変換後のファイルと同じ名称のファイルが出力先フォルダに存在した場合，ファイルを上書きするかどうかを指定します。

表15‒9 /wオプションの指定値
指定値 | 説明
on | 同じ名称のファイルが存在する場合，ファイルを上書きします。
off | 同じ名称のファイルが存在する場合，ファイルを上書きしません。

/wオプションを省略した場合は，onが仮定されます。on，off以外の値を指定した場合，エラー（KEES101-E）になります。

変換後のファイル名について

変換後の帳票定義情報ファイルのファイル名については，「15.3.1　帳票定義情報ファイルの格納先と出力形式」を参照してください。

変換後の帳票ファイルのファイル名については，「15.6　帳票定義情報ファイルから帳票ファイルに変換する」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 321 / 356


15.7.4 終了コード : EUR 帳票作成 操作ガイド

  • 322 / 356

  • 表紙

  • 15.　作成した帳票の情報をインポート，エクスポートする

  • 15.7　eurspcsvコマンドを使ってインポート，エクスポートする

  • 15.7.4　終了コード

15.7.4　終了コード

eurspcsvコマンド実行時の終了コードには，次に示す値が返されます。

表15‒10 eurspcsvコマンド実行時の終了コード一覧
終了コード | 意味
0 | 正常終了しました。
4 | 変換できなかったファイルがあります。
8 | 変換を中断しました。
16 | コマンドでの設定値で文法エラーが発生しました。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 322 / 356


16. 帳票作成の注意事項 : EUR 帳票作成 操作ガイド

  • 323 / 356

  • 表紙

  • 16.　帳票作成の注意事項

16.　帳票作成の注意事項

この章では，EUR 帳票作成機能の操作時や，帳票作成全般の注意事項について説明します。

〈この章の構成〉

  • 16.1　操作についての注意

  • 16.2　帳票作成に関する注意

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 323 / 356


16.1 操作についての注意 : EUR 帳票作成 操作ガイド

  • 324 / 356

  • 表紙

  • 16.　帳票作成の注意事項

  • 16.1　操作についての注意

16.1　操作についての注意

EUR 帳票作成機能の操作をするときの注意事項を次に示します。

  • ダイアログの［×］（閉じる）ボタンの扱い

    ［×］（閉じる）ボタンをクリックすると，変更を無視してウィンドウを閉じます。ユーザが選択した操作はキャンセルされます。

  • スクリーンセーバの動作

    データベース定義ウィンドウでデータを抽出するときに，スクリーンセーバの動作が一時停止する場合があります。スクリーンセーバの動作が停止しても抽出処理は続行され，処理が終了するとスクリーンセーバが動作を再開します。

  • ドラッグアンドドロップ時の注意

    レポート編集ウィンドウ上にファイルをドラッグアンドドロップすると，帳票を開けます。帳票ファイル以外をドラッグアンドドロップするとメッセージ「レポートが不完全です。」が出力されます。

  • HTMLヘルプの履歴を削除したい場合

    HTMLヘルプを使用すると参照した部分が表示済みの色で表示されます。これはInternet Explorerで履歴を管理しているためです。この履歴は，EURをアンインストール後に再インストールした場合や，更新インストールをしても引き継がれます。履歴をクリアしたい場合は，HTMLヘルプのメニュー［オプション］－［インターネットオプション］で履歴のクリアボタンをクリックしてください。

    ただし，履歴クリアを実行すると，Internet Explorerのブラウザの全参照履歴がクリアされることがあるので注意してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 324 / 356


16.2 帳票作成に関する注意 : EUR 帳票作成 操作ガイド

  • 325 / 356

  • 表紙

  • 16.　帳票作成の注意事項

  • 16.2　帳票作成に関する注意

16.2　帳票作成に関する注意

帳票作成全般の注意事項を次に示します。

〈この節の構成〉

  • 16.2.1　フルパスの指定方法

  • 16.2.2　ディクショナリファイルを指定するときの注意

  • 16.2.3　SEWB+/REPOSITORYで定義した最上位結合項目からデータを入力して帳票を出力する場合の注意

  • 16.2.4　EUR Form帳票の編集でバックグラウンドを設定する場合の注意

  • 16.2.5　データ表示ウィンドウを使用する場合の注意

  • 16.2.6　多角形の生成操作中の注意

  • 16.2.7　線種・線幅に関する注意

  • 16.2.8　EUR DesignerまたはEUR Viewerで画像アイテムを配置した帳票を出力する場合の注意

  • 16.2.9　IVS出力する帳票ファイルを作成する場合の注意事項

  • 16.2.10　フォントに関する注意

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 325 / 356


16.2.1 フルパスの指定方法 : EUR 帳票作成 操作ガイド

  • 326 / 356

  • 表紙

  • 16.　帳票作成の注意事項

  • 16.2　帳票作成に関する注意

  • 16.2.1　フルパスの指定方法

16.2.1　フルパスの指定方法

EURが読み込むファイルのフルパスは，次の形式が指定できます。

  • ローカルドライブの指定

    （例）C:\ABC\EUR.fms

  • ネットワークパスの指定

    （例）\\COMP\ABC\EUR.fms

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 326 / 356


16.2.2 ディクショナリファイルを指定するときの注意 : EUR 帳票作成 操作ガイド

  • 327 / 356

  • 表紙

  • 16.　帳票作成の注意事項

  • 16.2　帳票作成に関する注意

  • 16.2.2　ディクショナリファイルを指定するときの注意

16.2.2　ディクショナリファイルを指定するときの注意

フィールド位置が昇順の連続する内容でない場合，フィールド順序をフィールド位置順に並び替え，不連続部分にはフィールドを追加して帳票を表示します。

同じフィールド位置を参照する複数のフィールドが存在する場合，エラーを表示します。エラーが表示された場合には，ディクショナリファイルから重複するフィールド定義を削除してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 327 / 356


16.2.3 SEWB+/REPOSITORYで定義した最上位結合項目からデータを入力して帳票を出力する場合の注意 : EUR 帳票作成 操作ガイド

  • 328 / 356

  • 表紙

  • 16.　帳票作成の注意事項

  • 16.2　帳票作成に関する注意

  • 16.2.3　SEWB+/REPOSITORYで定義した最上位結合項目からデータを入力して帳票を出力する場合の注意

16.2.3　SEWB+/REPOSITORYで定義した最上位結合項目からデータを入力して帳票を出力する場合の注意

SEWB+/REPOSITORYの最上位結合項目を入力してフィールドを定義した帳票ファイルを使って帳票を出力する場合，次の手順で「1行目のデータをフィールド名として扱う」のチェックをオフにして帳票ファイルを定義してください。「1行目のデータをフィールド名として扱う」のチェックがオンのまま帳票を定義すると，EUR クライアント帳票出力機能とEUR サーバ帳票出力機能で出力結果が異なることがあります。

〈この項の構成〉

  • (1)　新規に帳票を定義する場合

  • (2)　既存の帳票を定義する場合

(1)　新規に帳票を定義する場合

  1. マッピングデータウィンドウまたはユーザ定義データウィンドウで，［データのプロパティ］ダイアログを開きます。

  2. 「区切り情報」タブを表示し，「1行目のデータをフィールド名として扱う」のチェックをオフにします。

  3. SEWB+/REPOSITORYの最上位結合項目を入力してフィールドを定義します。

  4. 帳票ファイルを保存します。

ページの先頭へ

(2)　既存の帳票を定義する場合

  1. マッピングデータウィンドウまたはユーザ定義データウィンドウで，［データのプロパティ］ダイアログを開きます。

  2. ［フィールド定義］グループボックスの［定義方法］ドロップダウンリストで「標準」を選択します。

  3. 「区切り情報」タブを表示し，「1行目のデータをフィールド名として扱う」のチェックをオフにします。

  4. ［フィールド定義］グループボックスの［定義方法］ドロップダウンリストで「最上位結合項目を使用」を選択します。

  5. 帳票ファイルを保存します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 328 / 356


16.2.4 EUR Form帳票の編集でバックグラウンドを設定する場合の注意 : EUR 帳票作成 操作ガイド

  • 329 / 356

  • 表紙

  • 16.　帳票作成の注意事項

  • 16.2　帳票作成に関する注意

  • 16.2.4　EUR Form帳票の編集でバックグラウンドを設定する場合の注意

16.2.4　EUR Form帳票の編集でバックグラウンドを設定する場合の注意

〈この項の構成〉

  • (1)　プリンタドライバと解像度の設定

  • (2)　アイテムの表示条件

  • (3)　線アイテムの表示

(1)　プリンタドライバと解像度の設定

次に示す操作をする場合，通常使うプリンタのプリンタドライバと解像度には，EUR Form帳票の編集でバックグラウンドを設定したときと同じ内容を設定してください。プリンタドライバまたは解像度が異なると，EUR Form帳票にバックグラウンドをインポートした時，表示がずれることがあります。

  • 設定されているバックグラウンドを，ほかのバックグラウンドにインポートし直してEUR Form帳票を設計する場合

  • EUR Form帳票ウィンドウから，設定されているバックグラウンドを編集する場合

ページの先頭へ

(2)　アイテムの表示条件

アイテムに表示条件が設定されていても，すべてのアイテムが表示されます。バックグラウンドを設定する場合，アイテムに表示条件を設定していない帳票を使うことをお勧めします。

ページの先頭へ

(3)　線アイテムの表示

バックグラウンドの編集時はすべての線種および線幅を指定できますが，EUR 帳票作成機能（EUR Form帳票）のバックグラウンドには次のように表示されます。

線種が実線の場合

すべて指定した線種・線幅で表示されます。

線種が破線，点線，一点破線，および二点破線の場合

線幅に「細線」を指定した場合は，指定した線種の細線で表示されます。

線幅に「細線」以外を指定した場合は，指定した線幅の実線で表示されます。

線種が点線（丸），および点線（角）の場合

すべて指定した線幅の実線で表示されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 329 / 356


16.2.5 データ表示ウィンドウを使用する場合の注意 : EUR 帳票作成 操作ガイド

  • 330 / 356

  • 表紙

  • 16.　帳票作成の注意事項

  • 16.2　帳票作成に関する注意

  • 16.2.5　データ表示ウィンドウを使用する場合の注意

16.2.5　データ表示ウィンドウを使用する場合の注意

.NET Frameworkがインストールされていない場合，データベースアクセス定義のデータ表示ウィンドウは使用できません。データ表示ウィンドウを使用する場合は，次に示す関連ソフトウェアのどれかが必要です。

  • Microsoft(R) .NET Framework Version 2.0 再頒布可能パッケージ (x86)

  • Microsoft(R) .NET Framework 3.0 再頒布可能パッケージ

.NET Frameworkのインストール方法については，Microsoft社のホームページを参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 330 / 356


16.2.6 多角形の生成操作中の注意 : EUR 帳票作成 操作ガイド

  • 331 / 356

  • 表紙

  • 16.　帳票作成の注意事項

  • 16.2　帳票作成に関する注意

  • 16.2.6　多角形の生成操作中の注意

16.2.6　多角形の生成操作中の注意

多角形の作成中（頂点の選択中）にほかの操作はできません。いったん操作を完了してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 331 / 356


16.2.7 線種・線幅に関する注意 : EUR 帳票作成 操作ガイド

  • 332 / 356

  • 表紙

  • 16.　帳票作成の注意事項

  • 16.2　帳票作成に関する注意

  • 16.2.7　線種・線幅に関する注意

16.2.7　線種・線幅に関する注意

バージョン07-60でサポートされた線種・線幅の情報を帳票ファイルに指定して，バージョン07-50以前のEURで読み込んだ場合，表示・印刷結果は次のようになります。

  • 点線（丸），点線（角）は実線で表示・印刷されます。

  • 点線，破線，一点鎖線，二点鎖線で細線以外の線幅を指定した場合は，指定した線幅の実線で表示・印刷されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 332 / 356


16.2.8 EUR DesignerまたはEUR Viewerで画像アイテムを配置した帳票を出力する場合の注意 : EUR 帳票作成 操作ガイド

  • 333 / 356

  • 表紙

  • 16.　帳票作成の注意事項

  • 16.2　帳票作成に関する注意

  • 16.2.8　EUR DesignerまたはEUR Viewerで画像アイテムを配置した帳票を出力する場合の注意

16.2.8　EUR DesignerまたはEUR Viewerで画像アイテムを配置した帳票を出力する場合の注意

帳票に配置した画像アイテムの画像ファイル名または画像データを帳票出力時に変更する場合は，帳票作成時にユーザ定義データウィンドウから画像データを配置し，帳票出力時にユーザ定義データファイルで指定した画像ファイル名または画像データを変更してください。

帳票作成時に固定画像で画像アイテムを配置した場合は，帳票出力時に画像ファイル名および画像データを変更できません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 333 / 356


16.2.9 IVS出力する帳票ファイルを作成する場合の注意事項 : EUR 帳票作成 操作ガイド

  • 334 / 356

  • 表紙

  • 16.　帳票作成の注意事項

  • 16.2　帳票作成に関する注意

  • 16.2.9　IVS出力する帳票ファイルを作成する場合の注意事項

16.2.9　IVS出力する帳票ファイルを作成する場合の注意事項

帳票作成機能は，IVSに対応していないため，異体字セレクタ部分は1文字として認識されます。

空白や「□」などで表示されたり，サーバ出力するときと異なる結果が表示されたりしますので，実際にサーバ出力を行って出力結果を確認してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 334 / 356


16.2.10 フォントに関する注意 : EUR 帳票作成 操作ガイド

  • 335 / 356

  • 表紙

  • 16.　帳票作成の注意事項

  • 16.2　帳票作成に関する注意

  • 16.2.10　フォントに関する注意

16.2.10　フォントに関する注意

帳票ファイルを編集する場合，帳票を編集するマシンに，帳票ファイル内で使用されているフォントがインストールされていることを確認してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 335 / 356


付録 : EUR 帳票作成 操作ガイド

  • 336 / 356

  • 表紙

  • 付録

付録

〈この付録の構成〉

  • 付録A　メニューとツールバー

  • 付録B　キーボードインターフェース

  • 付録C　帳票の互換性

  • 付録D　このマニュアルの参考情報

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 336 / 356


付録A メニューとツールバー : EUR 帳票作成 操作ガイド

  • 337 / 356

  • 表紙

  • 付録

  • 付録A　メニューとツールバー

付録A　メニューとツールバー

レポート編集ウィンドウに表示されるメニューとツールバーについて説明します。

〈この節の構成〉

  • 付録A.1　メニューとツールバーの一覧

  • 付録A.2　ツールバーとツールボックス

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 337 / 356


付録A.1 メニューとツールバーの一覧 : EUR 帳票作成 操作ガイド

  • 338 / 356

  • 表紙

  • 付録

  • 付録A　メニューとツールバー

  • 付録A.1　メニューとツールバーの一覧

付録A.1　メニューとツールバーの一覧

レポート編集ウィンドウに表示されるメニューとツールバーを，次の表に示します。

表A‒1 レポート編集ウィンドウのメニューとツールバー
メニュー | ドロップダウンメニュー | カスケードメニュー | 機能 | ツールバー | 詳細説明
ファイル(F) | 新規作成(N) | － | 新規の帳票ファイルを作成します。 EUR起動時の初期画面の状態です。 | [図データ] | －
 | 開く(O)... | － | 既存の帳票ファイル（*.fmsまたは*.agr）を開くための［ファイルを開く］ダイアログを表示します。 | [図データ] | 「1.3.2 既存の帳票ファイルを開く」
 | 上書き保存(S) | － | 編集中の帳票ファイル（*.fms）を上書きして保存します。 | [図データ] | －
 | 名前を付けて保存(A)... | － | 編集中の帳票ファイル（*.fmsまたは*.agr）に名前を付けて保存します。 | － | 「14.4 帳票を保存する」
 | プロパティ(R)... | － | 設計した帳票のグリッド属性や，ページ番号の印刷方法などを設定します。 | － | 「1.3.3 帳票ファイルのプロパティ表示」
 | 下敷きの設定(T)... | － | 下敷きに指定する画像ファイルを設定します。 | － | －
 | 用紙の設定(M)... | － | 用紙サイズや用紙の出力方向などを設定します。 | － | 「2.1 デフォルトの用紙の設定」
 | 印刷プレビュー(V) | － | 印刷のプレビュー画面を表示します。 | [図データ] | 「14.1 帳票を印刷プレビューで確認する」
 | 印刷(P)... | － | 設計した帳票を印刷するための［印刷］ダイアログを表示します。 | [図データ] | 「14.3 帳票を印刷する」
 | 以前開いたファイル | － | 過去に開いた帳票ファイルを表示します。 | － | －
 | Reportの終了(X) | － | 表示中の帳票ファイルを閉じます。 | － | －
編集(E) | 元に戻す(U) | － | 直前に行った操作を元に戻します。 | [図データ] | －
 | やり直し(R) | － | 元に戻した操作を取り消します。 | [図データ] | －
 | 切り取り(T) | － | 選択した範囲を切り取ります。 | [図データ] | －
 | コピー(C) | － | 選択した範囲を複写します。 | [図データ] | －
 | 貼り付け(P) | － | 切り取り，またはコピーした範囲を貼り付けます。 | [図データ] | －
 | 削除(D) | － | 選択したアイテムを削除します。 | － | －
 | 帳票ヘッダ領域の削除(H) | － | 帳票ヘッダ領域を削除します。 | － | 「7.6 帳票ヘッダ領域の削除」
 | すべてを選択(A) | － | 帳票ファイルにあるすべてのアイテムを選択します。 | － | －
 | 順序(O) | 最前面へ移動(T) | 選択したアイテムを最前面へ移動します。 | － | 「4.8.1(1) 最前面へ移動する」
 |  | 最背面へ移動(K) | 選択したアイテムを最背面へ移動します。 | － | 「4.8.1(2) 最背面へ移動する」
 |  | 前面へ移動(F) | 選択したアイテムを前面へ移動します。 | － | 「4.8.1(3) 前面へ移動する」
 |  | 背面へ移動(B) | 選択したアイテムを背面へ移動します。 | － | 「4.8.1(4) 背面へ移動する」
 | 揃え(N) | 左揃え(L) | 選択した複数アイテムの配置を左揃えにします。 | [図データ] | 「4.8.2(1) 左揃え」
 |  | 右揃え(R) | 選択した複数アイテムの配置を右揃えにします。 | [図データ] | 「4.8.2(2) 右揃え」
 |  | 上揃え(T) | 選択した複数アイテムの配置を上揃えにします。 | [図データ] | 「4.8.2(3) 上揃え」
 |  | 下揃え(B) | 選択した複数アイテムの配置を下揃えにします。 | [図データ] | 「4.8.2(4) 下揃え」
 |  | 幅を揃える(W) | 選択した複数アイテムの横幅のサイズを揃えます。 | [図データ] | 「4.8.2(5) 幅を揃える」
 |  | 高さを揃える(H) | 選択した複数アイテムの縦幅のサイズを揃えます。 | [図データ] | 「4.8.2(6) 高さを揃える」
 | 回転(Y) | 90°(9) | 選択した多角形アイテムを，反時計周りに90°回転させます。 | － | 「4.7.6(1) 多角形の回転」
 |  | 180°(1) | 選択した多角形アイテムを，反時計周りに180°回転させます。 | －
 |  | 270°(2) | 選択した多角形アイテムを，反時計周りに270°回転させます。 | －
 |  | 任意(E)... | 選択した多角形アイテムを，反時計周りに任意の角度で回転させます。 | －
 | 反転(S) | 左右反転(H) | 選択した多角形アイテムの左右を反転させます。 | － | 「4.7.6(2) 多角形の反転」
 |  | 上下反転(V) | 選択した多角形アイテムの上下を反転させます。 | －
 | 頂点の編集(J) | － | 選択した多角形の頂点を編集します。 | － | 「4.7.6(3) 多角形の頂点の編集」
 | 部品の登録(R) | － | 選択したアイテムを部品として登録します。 | － | 「12.2 部品を登録する」
 | アイテムの配置(L) | 繰り返し領域の左上を基準(R) | アイテムの位置を，繰り返し領域の左上を基準にして表示します。 | － | 「7.3 アイテムの配置を設定する」
 |  | 貼付域の左上を基準(P) | アイテムの位置を，貼付域の左上を基準にして表示します。 | －
 | アイテムのプロパティ(I)... | － | 選択したアイテムのプロパティを設定します。 帳票ウィンドウでアイテムが選択されているときに活性化します。 | － | 「13. アイテムのプロパティとオプションを設定する」
 | アイテムの表示条件(F)... | － | アイテムの表示条件を設定します。 | － | 「8.2.3 表示条件の設定手順」
表示(V) | 編集(E) | － | 帳票ウィンドウのアイテム枠を表示します。 通常，帳票を設計する時は「編集」が選択された状態です。 | － | 「14.2 帳票をレイアウト表示して確認する」
 | レイアウト(L) | － | 帳票ウィンドウのアイテム枠を非表示にして，実際の帳票のイメージで表示します。 | －
 | グリッド(G) | － | 帳票ウィンドウにグリッド（格子線）の表示/非表示を設定します。 | － | 「1.4 グリッドを設定する」
 | 下敷き(A) | － | 帳票ウィンドウに下敷きの表示/非表示を設定します。 | － | 「10. プレプリント用紙に合わせて帳票を作成する」
 | ツールバー(T)... | － | レポート編集ウィンドウに表示するツールバーとツールボックスの表示/非表示を設定します。 | － | －
 | ルーラ(R) | － | 帳票ウィンドウに表示するルーラの表示/非表示を設定します。 | － | 「1.5 ルーラを表示する」
 | マッピングデータウィンドウ(M) | － | レポート編集ウィンドウに表示するマッピングデータウィンドウの表示/非表示を設定します。 | － | －
 | ユーザ定義データウィンドウ(U) | － | レポート編集ウィンドウに表示するユーザ定義データウィンドウの表示/非表示を設定します。 | － | －
 | ズーム(Z)... | － | 帳票ウィンドウの表示倍率を設定します。 | [図データ] | 「1.6 ウィンドウ表示倍率を変更する」
挿入(I) | 帳票ヘッダ領域(H) | － | 帳票ウィンドウに帳票ヘッダ領域を挿入します。 | － | 「7.1 帳票ヘッダ領域を設定する」
 | ページ番号(P)... | － | 帳票ウィンドウにページ番号を挿入します。 | [図データ] | 「4.5.1 貼付域に挿入する」
 | 印刷日付(D)... | － | 帳票ウィンドウに印刷日付を挿入します。 | [図データ] | 「4.6 印刷日付・印刷時刻を配置する」
 | 印刷時刻(T)... | － | 帳票ウィンドウに印刷時刻を挿入します。 | [図データ]
 | 画像(I)... | － | 帳票ウィンドウに画像を挿入します。 | [図データ] | 「4.4 画像ファイルを配置する」
繰り返し(R) | 繰り返し指定(G) | － | 選択したアイテムを，繰り返し対象として設定します。 | － | 「5.3 繰り返しを定義する」
 | 見出し指定(E) | － | 選択したアイテムを，見出しとして設定します。 | － | 「5.3.3 表の見出しの繰り返しを定義する」
 | 繰り返し／見出し解除(R) | － | 選択したアイテムに設定された繰り返し指定/見出し指定を解除します。 | － | 「5.3.4 繰り返しを解除する」
 | 縦位置(V) | 設定(S) | 繰り返し指定したアイテムの縦位置を設定します。 | － | 「5.3.1 繰り返し定義を設定する」
 |  | 解除(C) | 選択したアイテムに設定された縦位置の内容を解除します。 | －
 | 横位置(H) | 設定(S) | 繰り返し指定したアイテムの横位置を設定します。 | －
 |  | 解除(C) | 選択したアイテムに設定された横位置の内容を解除します。 | －
 | 個数(N)... | － | 縦/横の繰り返しの個数を設定します。 | － | 「5.3.2 繰り返し個数を設定する」
 | 優先方向(D) | 縦優先(V) | 繰り返し指定の優先方向を，縦優先で設定します。 | － | 「5.3.1 繰り返し定義を設定する」
 |  | 横優先(H) | 繰り返し指定の優先方向を，横優先で設定します。 | －
 | まとめ表示(S) | 集計行で分断しない(D) | まとめ表示を，集計行で分断しない設定をします。 | － | 「5.6.1 まとめ表示を設定する」
 |  | 階層あり(O) | まとめ表示を設定するときに，階層を付けて表示します。 | －
 |  | 階層なし(F) | まとめ表示を設定するときに，階層を付けないで表示します。 | －
 |  | 全解除(A) | 設定されているすべてのまとめ表示を解除します。 | － | 「5.6.2 まとめ表示を解除する」
 |  | 設定(S)... | ［まとめ表示］ダイアログを表示して，まとめ表示を設定します。 | － | 「5.6.1 まとめ表示を設定する」
 | 改ブロック／改ページ(B) | 設定なし(N) | 設定してある改ブロック/改ページを解除します。 | － | 「5.4.2 改ブロックを解除する」，「5.5.2 改ページを解除する」
 |  | 改ブロック(B) | 選択したフィールドをキーとして改ブロックを設定します。 | － | 「5.4 改ブロックを設定する」
 |  | 改ページ［初期化あり］(R) | 改ページ時に，ページ番号を開始番号に初期化して印刷します。 | － | 「5.5 改ページを設定する」
 |  | 改ページ［初期化なし］(P) | 改ページ時に，ページ番号を通し番号で印刷します。 | －
 | 改ブロック／改ページ一覧(L)... | － | 改ブロックと改ページの設定内容を表示します。 | － | 「5.4 改ブロックを設定する」 「5.5 改ページを設定する」
 | 繰り返し設定(P)... | － | ［繰り返し設定］ダイアログを表示して，繰り返し情報を設定します。 | － | 「5.3 繰り返しを定義する」
集計(S) | キー集計(K) | － | 帳票ウィンドウで選択したフィールドをキーにして集計行を挿入します。 | － | 「6.3 キー集計を作成する」
 | ページ集計(P) | － | 帳票ウィンドウで選択したフィールドをページごとに集計した集計行を挿入します。 | － | 「6.4 ページ集計を作成する」
 | 総集計(G) | － | 選択したフィールドの最終行に集計行を挿入します。集計方法が選択できます。デフォルトは，「合計」です。 | － | 「6.5 総集計を作成する」
 | 集計アイテム(I)... | － | 集計アイテムの設定，および帳票への貼り付けを行います。 | － | 「6.7 集計結果をアイテムとして挿入する」
 | 集計行の編集(E) | － | 設定してある集計行を編集します。 | － | 「6.6 集計行を編集する」
 | 集計行解除(C) | － | 設定してある集計行/総集計を解除します。 | － | 「6.6.8 集計行／総集計行を解除する」
 | 1件のときキー集計行を削除する(1) | － | 対象のレコードが1件のキー集計行を削除します。 | － | 「6.6.5 1件のときキー集計行を削除する」
データ(D) | データファイル指定(T)... | － | データを読み込むデータファイルを指定します。 | － | 「3.2 データファイルからの読み込み手順」
 | データベースアクセス定義(B)... | － | データベースに接続します。 | － | マニュアル「EUR データベース連携ガイド」
 | フィールド定義(F)... | － | 読み込んだデータベースのフィールドを定義します。 | － | 「3.3 データウィンドウのフィールド定義を変更する」
 | 最上位結合項目(S)※ | 選択(E)... | SEWB+のデータ項目辞書のレコード定義情報から読み込むフィールド定義情報を設定します。 | － | 「3.8 SEWB+/REPOSITORYで定義した最上位結合項目からデータを読み込む」
 |  | 更新(U) | 最新の最上位結合項目を読み込んで，フィールド定義情報を更新します。 | －
 | フィールド表示幅(W) | データ長に合わせる(A) | データウィンドウで選択したフィールドの表示幅をデータ長に合わせます。 | － | 「3.4 フィールド表示幅を変更する」
 |  | 設定(S)... | データウィンドウのフィールド表示幅を任意の値に設定します。 | －
 | 基準レコード位置変更(O) | － | 基準レコードの位置を設定します。 | － | 「3.5.1 基準レコード位置の変更」
 | 基準レコード幅変更(G)... | － | 基準レコードの幅を設定します。 | － | 「3.5.2 基準レコード幅の変更」
 | 最新のデータに更新(R) | － | 最新のデータを読み込みます。 | － | －
 | データのプロパティ(D)... | － | 読み込むデータのプロパティを設定します。 | － | マニュアル「EUR 帳票作成 画面リファレンス」
ツール(T) | 部品パレット(P) | － | 部品パレットウィンドウを起動します。 | － | 「12. 作成したアイテムを部品化して再利用する」
 | オプション(O)... | － | EURの各機能のデフォルトを設定します。 | － | 「13.11 帳票のオプションを設定する」
ウィンドウ(W) | 重ねて表示(C) | － | EURで表示中のウィンドウを重ねて表示します。 | [図データ] | －
 | 上下に並べて表示(V) | － | EURで表示中のウィンドウを上下に並べて表示します。 | [図データ] | －
 | 左右に並べて表示(H) | － | EURで表示中のウィンドウを左右に並べて表示します。 | [図データ] | －
 | 表示されているウィンドウ一覧 | － | 表示中のウィンドウ名を表示します。チェックを付けると，選択したウィンドウが最前面に表示されます。 | － | －
ヘルプ(H) | EURのヘルプ(H)... | － | ［ヘルプ］ウィンドウを表示します。 | － | －
 | バージョン情報(A)... | － | EURのバージョン情報を表示します。 | － | －
（凡例）

－：該当する項目はありません。

注※

英語ロケール，および中国語ロケールでは，表示されません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 338 / 356


付録A.2 ツールバーとツールボックス : EUR 帳票作成 操作ガイド

  • 339 / 356

  • 表紙

  • 付録

  • 付録A　メニューとツールバー

  • 付録A.2　ツールバーとツールボックス

付録A.2　ツールバーとツールボックス

レポート編集ウィンドウで表示されるツールバーには，標準ツールバー，揃えツールバー，挿入ツールバー，ウィンドウツールバーおよびページツールバーがあります。ツールバーの表示／非表示は，［表示］－［ツールバー］を選択したあとに表示される，［ツールバー］ダイアログで指定します。

〈この項の構成〉

  • (1)　標準ツールバー

  • (2)　揃えツールバー

  • (3)　挿入ツールバー

  • (4)　ウィンドウツールバー

  • (5)　ページツールバー

  • (6)　ツールボックス

(1)　標準ツールバー

ページの先頭へ

(2)　揃えツールバー

ページの先頭へ

(3)　挿入ツールバー

ページの先頭へ

(4)　ウィンドウツールバー

ページの先頭へ

(5)　ページツールバー

ページの先頭へ

(6)　ツールボックス

ツールボックスは，アイテムを生成または選択する場合に，ボタンを選択して各モードを切り替えるウィンドウです。ツールボックスは自由に移動できます。

帳票ウィンドウ上のアイテムを選択するときは，ツールボックスで [図データ] ボタンを押して選択モードにしてから，選択したいアイテムのチェックボックスをオンにします。そのあと，帳票ウィンドウでアイテムを選択します。

ツールボックスは，モードを選択する部分と選択の種類を指定する部分から成っています。

[図データ] ：選択ボタン

貼付域のアイテムを選択できます。このボタンが選択されている時（選択モードといいます）は，アイテムのチェックボックスが表示され，選択するアイテムを複数選べます。選択モードの場合，帳票ウィンドウでアイテムの選択ができます。

表示されるアイテムのチェックボックスを次に示します。

［文字］チェックボックス

チェックボックスのオン／オフで，文字アイテム，およびバーコードアイテムの選択／非選択を設定します。

［線］チェックボックス

チェックボックスのオン／オフで，線アイテムの選択／非選択を設定します。

［図形］チェックボックス

チェックボックスのオン／オフで，図形アイテムの選択／非選択を設定します。図形アイテムとは，網掛けアイテム，角丸四角アイテム，円／楕円アイテム，および多角形アイテムのことです。

［画像］チェックボックス

チェックボックスのオン／オフで，画像アイテムの選択／非選択を設定します。

［部品］チェックボックス

チェックボックスのオン／オフで，部品の選択／非選択を設定します。

[図データ] ：文字ボタン

固定文字列を入力する場合に，このボタンを選択します。

[図データ] ：線ボタン

直線を描く場合に，このボタンを選択します。

[図データ] ：矩形ボタン

矩形線を描く場合に，このボタンを選択します。

[図データ] ：網ボタン

網掛けする場合に，このボタンを選択します。

角丸四角アイテム，円／楕円アイテム，または多角形アイテムを選択したあと，［アイテムのプロパティ］ダイアログの［図形］タブで設定してください。 [図データ] を選択した場合の網掛けモードからは設定できません。

[図データ] ：角丸四角ボタン

角丸四角を描く場合に，このボタンを選択します。

[図データ] ：円／楕円ボタン

円または楕円を描く場合に，このボタンを選択します。

[図データ] ：多角形ボタン

多角形を描く場合に，このボタンを選択します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 339 / 356


付録B キーボードインターフェース : EUR 帳票作成 操作ガイド

  • 340 / 356

  • 表紙

  • 付録

  • 付録B　キーボードインターフェース

付録B　キーボードインターフェース

EURのキーボードインターフェースについて説明します。

〈この節の構成〉

  • 付録B.1　レポート編集ウィンドウのメニューに対応したショートカットキー

  • 付録B.2　レポート編集ウィンドウのページめくりに対応したショートカットキー

  • 付録B.3　データウィンドウでのショートカットキー

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 340 / 356


付録B.1 レポート編集ウィンドウのメニューに対応したショートカットキー : EUR 帳票作成 操作ガイド

  • 341 / 356

  • 表紙

  • 付録

  • 付録B　キーボードインターフェース

  • 付録B.1　レポート編集ウィンドウのメニューに対応したショートカットキー

付録B.1　レポート編集ウィンドウのメニューに対応したショートカットキー

レポート編集ウィンドウで表示されるメニューに対応したショートカットキーの一覧を次に示します。

表B‒1 メニューに対応したショートカットキーの一覧
ショートカットキー | 機 能
 | 対応するメニュー | 意 味
＜Ctrl＞＋＜N＞ | ［ファイル］－［新規作成］ | 新規作成のファイルを開きます。
＜Ctrl＞＋＜O＞ | ［ファイル］－［開く］ | ［ファイルを開く］ダイアログを表示します。
＜Ctrl＞＋＜S＞ | ［ファイル］－［上書き保存］ | 編集中の帳票を，ファイルに上書きして保存します。
＜Ctrl＞＋＜F2＞ | ［ファイル］－［印刷プレビュー］ | 編集中の帳票を印刷時のイメージで表示します。
＜Ctrl＞＋＜P＞ | ［ファイル］－［印刷］ | ［印刷］ダイアログを表示します。
＜Ctrl＞＋＜Z＞ | ［編集］－［元に戻す］ | 直前に行った操作を元に戻します。
＜Ctrl＞＋＜Y＞ | ［編集］－［やり直し］ | 直前に行った操作をやり直します。
＜Ctrl＞＋＜X＞ | ［編集］－［切り取り］ | 選択した範囲を切り取ります。
＜Ctrl＞＋＜C＞ | ［編集］－［コピー］ | 選択した範囲を複写します。
＜Ctrl＞＋＜V＞ | ［編集］－［貼り付け］ | ［切り取り］，または［コピー］した範囲を帳票に貼り付けます。
＜Ctrl＞＋＜A＞ | ［編集］－［すべてを選択］ | 帳票ファイル上のすべてのアイテムを選択します。
＜Delete＞ | ［編集］－［削除］ | 選択したアイテムを削除します。
＜F5＞ | ［データ］－［最新のデータに更新］ | 最新のデータを読み込みます。
＜F1＞ | ［ヘルプ］－［EURのヘルプ］ | ［ヘルプ］ウィンドウを表示します。
＜Esc＞ | － | 文字，罫線，図形アイテムの生成モードを解除します。
（凡例）

－：該当する項目はありません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 341 / 356


付録B.2 レポート編集ウィンドウのページめくりに対応したショートカットキー : EUR 帳票作成 操作ガイド

  • 342 / 356

  • 表紙

  • 付録

  • 付録B　キーボードインターフェース

  • 付録B.2　レポート編集ウィンドウのページめくりに対応したショートカットキー

付録B.2　レポート編集ウィンドウのページめくりに対応したショートカットキー

レポート編集ウィンドウでのページめくりに対応したショートカットキーの一覧を次に示します。

表B‒2 ページめくりに対応したショートカットキーの一覧
ショートカットキー | 機 能
＜PageUp＞ | 表示領域を上方向にスクロールします。
＜PageDown＞ | 表示領域を下方向にスクロールします。
＜Ctrl＞＋＜PageUp＞ | 表示領域を左方向にスクロールします。
＜Ctrl＞＋＜PageDown＞ | 表示領域を右方向にスクロールします。
＜Home＞ | ページの左上へスクロールします。
＜End＞ | ページの右下へスクロールします。
＜Alt＞＋＜PageUp＞ ＜Alt＞＋＜PageDown＞ | ＜Alt＞キーを押しながら＜PageUp＞キーを押すと，前ページの左上へジャンプします。 ＜Alt＞キーを押しながら＜PageDown＞キーを押すと，次ページの左上へジャンプします。
＜Ctrl＞＋＜Home＞ ＜Ctrl＞＋＜End＞ | ＜Ctrl＞キーを押しながら＜Home＞キーを押すと，帳票の先頭ページの左上へジャンプします。 ＜Ctrl＞キーを押しながら＜End＞キーを押すと，帳票の最終ページの左上へジャンプします。

また，表示領域は，マウスホイールでもスクロールできます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 342 / 356


付録B.3 データウィンドウでのショートカットキー : EUR 帳票作成 操作ガイド

  • 343 / 356

  • 表紙

  • 付録

  • 付録B　キーボードインターフェース

  • 付録B.3　データウィンドウでのショートカットキー

付録B.3　データウィンドウでのショートカットキー

データウィンドウでのショートカットキーについて説明します。

〈この項の構成〉

  • (1)　データウィンドウでのセルの移動

  • (2)　データウィンドウでのデータの選択

(1)　データウィンドウでのセルの移動

＜↑＞，＜↓＞，＜←＞，および＜→＞キーによって移動できる範囲は，データ部分だけです。

キーを押してアクティブセルがデータウィンドウの表示領域外に移動してしまう場合は，移動先のセルがスクロールして表示されます。

データウィンドウでセルを移動するショートカットキーの一覧を次に示します。

表B‒3 データウィンドウでのセルの移動
ショートカットキー | 機 能
＜↑＞ | 1セル上へ移動します。
＜↓＞ | 1セル下へ移動します。
＜←＞ | 1セル左へ移動します。
＜→＞ | 1セル右へ移動します。
＜Ctrl＞＋＜↑＞ | 現在のフィールドの，最上端のセルへ移動します。
＜Ctrl＞＋＜↓＞ | 現在のフィールドの，最下端のセルへ移動します。
＜Ctrl＞＋＜←＞ | 現在のレコードの，行頭のセルへ移動します。
＜Ctrl＞＋＜→＞ | 現在のレコードの，行末のセルへ移動します。
＜Ctrl＞＋＜PageUp＞ | 表示されているデータウィンドウを左方向へスクロールします。
＜Ctrl＞＋＜PageDown＞ | 表示されているデータウィンドウを右方向へスクロールします。
＜Home＞ | 現在のレコードの，行頭のセルへ移動します。
＜End＞ | 現在のレコードの，行末のセルへ移動します。
＜Ctrl＞＋＜Home＞ | データウィンドウの左上端のセル（先頭レコードの先頭フィールドのセル）へ移動します。
＜Ctrl＞＋＜End＞ | データウィンドウの右下端のセル（末尾レコードの末尾フィールドのセル）へ移動します。

また，表示領域は，マウスホイールでもスクロールできます。

ページの先頭へ

(2)　データウィンドウでのデータの選択

データウィンドウの表示領域外のセルも選択に含める場合は，表示領域をスクロールさせてからセルを選択してください。

データウィンドウでの，データの選択のショートカットキーを次に示します。

表B‒4 データウィンドウでのデータの選択
操 作 | 機 能
クリック | クリックした位置のセルを選択状態にします。 アンカーポイント（選択範囲の始点）といいます。
＜Shift＞＋クリック | 設定したアンカーポイントからクリックした位置までの連続したセル範囲を選択状態にします。
＜Ctrl＞＋クリック | クリックした位置のセルを選択状態にします。 連続していないセルを複数選択できます。
ドラッグ | ドラッグした範囲のセルを選択状態にします。ドラッグした選択範囲の始点をアンカーポイント，終点をアクティブエンドといいます。
＜Shift＞＋ドラッグ | 設定したアンカーポイントからドラッグした位置までの連続したセル範囲を選択状態にします。
＜Ctrl＞＋ドラッグ | ドラッグした範囲のセルを選択状態にします。 連続したセルを複数選択できます。
＜Space＞ | アクティブセルが表示されているセルを，アンカーポイントにします。
＜Shift＞＋＜Space＞ | 連続したセル範囲のアクティブエンドをアンカーポイントに変更します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 343 / 356


付録C 帳票の互換性 : EUR 帳票作成 操作ガイド

  • 344 / 356

  • 表紙

  • 付録

  • 付録C　帳票の互換性

付録C　帳票の互換性

Windows版 EUR旧製品，およびUNIX版 EUR旧製品との互換性を次に示します。

〈この節の構成〉

  • 付録C.1　Windows版 EUR旧製品からの互換性

  • 付録C.2　UNIX版 EUR旧製品からの互換性

  • 付録C.3　古いバージョンのEURで使用するときの互換性

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 344 / 356


付録C.1 Windows版 EUR旧製品からの互換性 : EUR 帳票作成 操作ガイド

  • 345 / 356

  • 表紙

  • 付録

  • 付録C　帳票の互換性

  • 付録C.1　Windows版 EUR旧製品からの互換性

付録C.1　Windows版 EUR旧製品からの互換性

異なるバージョンのEURとファイルを共用する場合，使用できない機能や属性があるので，帳票を保存したり，配布したりする場合は注意してください。

〈この項の構成〉

  • (1)　バージョン3とバージョン4からバージョン5以降への移行時の注意

  • (2)　異なるバージョンのEURで設計した帳票を開いた場合

(1)　バージョン3とバージョン4からバージョン5以降への移行時の注意

(a)　レポートファイル（*.agr）の扱い

  • バージョン5以降のEURで保存できる帳票ファイルの種類は，「フォームシートファイル（*.fms）」だけです。既存のレポートファイルは，表示したり，印刷したりできますが，上書き保存はできません。レポートファイルを開いた時は，同じファイル種別で保存できないことを示すメッセージが表示されます。

  • バージョン4以前では，データベースからデータを読み込んで設計された帳票を編集ウィンドウで開いたときに，データベースから最新データを取得していましたが，バージョン5以降ではサンプルデータが表示されます。この場合，データベースアクセス定義ウィンドウを開き，そのまま［OK］ボタンで閉じれば，データベースのデータが帳票に表示されます。

データありのレポートファイル（*.agr）の扱い

バージョン5以降のEURでは，レポートファイルを開いた時，レポートファイルと一緒に保存されているデータは，データウィンドウに表示できません。データウィンドウには，サンプルデータが表示されます。

(b)　OLE埋め込みオブジェクトが貼り付けられた帳票ファイルの扱い

画像やExcelで作成したグラフをOLE埋め込みオブジェクトとして帳票に貼り付けられていましたが，バージョン5以降のEURでは，OLE埋め込みオブジェクトを帳票に貼り付けられません。また，OLE埋め込みオブジェクトが貼り付けられたレポートファイルを開いても，OLE埋め込みオブジェクトは，表示も印刷もできません。

OLE埋め込みオブジェクトが貼り付けられた帳票を表示したい場合は，次のように対処してください。対処は，OLE埋め込みオブジェクトを代用する場合も有効です。

OLE埋め込みオブジェクトとしていた対象物 | 対処
画像 | EURの画像アイテムとして帳票に貼り付けます。
Excelのグラフ | サードパーティの製品で，作成したグラフを画像ファイルに保存したあと，EURの画像アイテムとして帳票に貼り付けます。

(c)　ディクショナリファイルを使用した帳票の扱い

バージョン5以降のEURでは，実行時にディクショナリファイルの指定は不要です。ディクショナリファイルを使用して作成している帳票ファイルを使用するには，次の手順でディクショナリファイルを使用しない形式で保存し直してください。

  1. EUR 帳票作成機能で帳票ファイルを開く

  2. ディクショナリファイルが読み込まれていることを確認してから保存し直す

この手順によって，データ種別などのフィールド定義情報がフォームシートファイル（*.fms）内に保存され，ディクショナリファイルが不要になります。

ページの先頭へ

(2)　異なるバージョンのEURで設計した帳票を開いた場合

  • バージョン5で設計した帳票は，バージョン5以降のEURだけが正しく読み込めます。

  • 使用できない機能や属性が設定されている場合は，エラーになったり，一部の情報が正しく表示されなかったりします。

    帳票ファイルのプロパティで帳票ファイルを設計したEUR製品のプログラムプロダクト情報を確認することで，帳票ファイルを参照，または印刷できるEUR製品のプログラムプロダクト情報を特定できます。帳票ファイルのプロパティ表示については，「1.3.3　帳票ファイルのプロパティ表示」を参照してください。

  • 修飾する文字アイテムは，選択した文字アイテムがバージョン2以前に作成された場合と，バージョン3で作成された場合とで，［文字配置］タブの「バージョン2以前の文字配置を行う」のチェックボックスの状態が異なります。選択した文字アイテムが，バージョン2以前に作成された文字アイテムの場合はオンですが，バージョン3以降に作成された文字アイテムの場合はオフです。

  • バージョン04-03以前のEURで設計された帳票をバージョン04-04以降のEURで開いた場合は，フォント縦横比を補正して表示されます。

  • 表示形式［バージョン3形式］のページ番号を設定した帳票を，バージョン2のEURで表示，または印刷した場合，ページ番号は正しく表示されません。

  • 集計ページでは，表示形式［バージョン3形式］のページ番号を設定すると，独立したページ番号が表示されます。例えば，［定義］のテキストボックスに「%ip/%it」が設定されている場合，集計ページが1ページあるときは「1/1」と表示されます。

  • ［アイテムのプロパティ］ダイアログの［文字配置］タブで，［桁数の指定］が設定できるのは，バージョン04-08以降のEUR Professional Edition，バージョン08-00以降のEUR DesignerおよびEUR Developerです。そのため，［桁数の指定］が設定されている帳票を，バージョン04-07以前のEUR Professional Editionで開いた場合，［桁数の指定］が設定されているアイテムは，次に示す属性に変換して表示されます。

    ［アイテムのプロパティ］ダイアログの［文字配置］タブ

    変換される属性

    バージョン2以前の文字配置を行う

    オフ

    文字の方向

    上向きで，左から右へ

    間隔

    文字間隔

    標準

    間隔

    0（pt）

    行間隔

    標準

    間隔

    0（pt）

  • バージョン7以前のEUR 帳票作成機能で設計した帳票は，静的モードで表示してください。動的モードを指定して表示した場合，フォントの表示位置が異なる場合があります。

    なお，静的モードまたは動的モードの指定を省略した場合は，静的モードで表示されます。

    静的モードと動的モードの詳細についてはマニュアル「EUR システム設計ガイド」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 345 / 356


付録C.2 UNIX版 EUR旧製品からの互換性 : EUR 帳票作成 操作ガイド

  • 346 / 356

  • 表紙

  • 付録

  • 付録C　帳票の互換性

  • 付録C.2　UNIX版 EUR旧製品からの互換性

付録C.2　UNIX版 EUR旧製品からの互換性

UNIX版 EUR旧製品のすべての帳票ファイルと互換性があります。UNIX版 EUR旧製品は，次に示す製品を指します。

  • P-16D2-211 / P-16D2-212　　EUR（HI-UX/WE2）

  • P-1691-141 / P-1691-142　　 EXCEED3/W-EUR（HI-UX/WE2）

  • P-1BD2-2111　　　EUR（HP-UX 11.x）

  • P-92D2-2111　　　EUR（HP-UX 9.x）

  • P-9291-1411　　　　EXCEED3/W-EUR（HP-UX 9.x）

  • P-9DD2-1111　　　 EUR（Solaris）

  • P-91D2-1111　　　 EUR（AIX）

  • P-9191-1411　　　　EXCEED3/W-EUR（AIX）

ただし，UNIX版 EUR旧製品で設計した帳票を，EUR 帳票作成機能に移行した場合は，次に示す機能差があります。

  • 罫線

    • 線幅

      線種が「破線／点線／一点鎖線／二点鎖線」で，かつ線幅が「中／太／極太」の帳票定義を開いた場合，「細」の線幅で表示されます。変更するには，［アイテムのプロパティ］ダイアログで再設定してください。

    • 不可視線

      不可視線は，EUR 帳票作成機能に移行しても，不可視のまま印刷されます。ただし，EUR 帳票作成機能では不可視線の定義はできません。

  • フォント

    縮小（縦1/2倍，横1/2倍）の属性は，EUR 帳票作成機能では無効になります。縮小の属性が設定されている帳票をEUR 帳票作成機能で開くと，メッセージ「レポート内に識別できないデータがありました。」が表示されて，識別できないデータを無視した帳票が表示されます。フォントは縦横1倍で出力されるため，アイテム枠に余裕がない場合は，欠損出力したり，隣り合う文字が重なって表示されたりします。

    EUR 帳票作成機能で帳票を開いたあと，フォントのサイズを小さくするか，または文字アイテムの位置，およびサイズを変更するなどして，レイアウトを調整してください。

  • 画像データ

    UNIXとWindowsでは，ファイル名の規則に違いがあります。Windowsでは使用できない文字（\ / : * ? "< > |）を使用したファイル名で，画像ファイルが貼り付けられていると，画像データを表示できません。

    EUR 帳票作成機能で帳票を開いたあと，画像データを貼り直してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 346 / 356


付録C.3 古いバージョンのEURで使用するときの互換性 : EUR 帳票作成 操作ガイド

  • 347 / 356

  • 表紙

  • 付録

  • 付録C　帳票の互換性

  • 付録C.3　古いバージョンのEURで使用するときの互換性

付録C.3　古いバージョンのEURで使用するときの互換性

EURのバージョン05-00以降で保存した帳票ファイルは，バージョン05-00以降で読み込めます。

なお，バージョン07-60以降で作成したフォームシートファイル（*.fms）を古いバージョンのEURで使用すると，次のように動作します。

〈この項の構成〉

  • (1)　EUR 帳票作成機能での動作

  • (2)　EUR クライアント帳票出力機能，およびEUR サーバ帳票出力機能での動作

(1)　EUR 帳票作成機能での動作

レポート編集ウィンドウで開いた場合

ファイル内の認識できないキーワードに対してメッセージとログが出力され，古いバージョンの機能範囲内でファイルが表示されます。

ファイル内に認識できないキーワードがあった場合は，上書き保存できません。別の名前を付けて新規に保存してください。

レポート確認ウィンドウ，またはレポート印刷ウィンドウで開いた場合

ファイル内の認識できないキーワードに対して起動履歴としてログが出力され，古いバージョンの機能範囲内でファイルが表示されます。

ページの先頭へ

(2)　EUR クライアント帳票出力機能，およびEUR サーバ帳票出力機能での動作

新しいバージョンでサポートされた機能を使用している場合，出力結果が帳票設計時の結果と異なることがあります。帳票設計時には，バージョンごとの機能差に注意してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 347 / 356


付録D このマニュアルの参考情報 : EUR 帳票作成 操作ガイド

  • 348 / 356

  • 表紙

  • 付録

  • 付録D　このマニュアルの参考情報

付録D　このマニュアルの参考情報

このマニュアルを読むに当たっての参考情報を示します。

〈この節の構成〉

  • 付録D.1　関連マニュアル

  • 付録D.2　EUR バージョン10での製品体系の変更

  • 付録D.3　EUR バージョン10でのマニュアル体系の変更

  • 付録D.4　このマニュアルでの表記

  • 付録D.5　このマニュアルで使用する略語

  • 付録D.6　KB（キロバイト）などの単位表記について

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 348 / 356


付録D.1 関連マニュアル : EUR 帳票作成 操作ガイド

  • 349 / 356

  • 表紙

  • 付録

  • 付録D　このマニュアルの参考情報

  • 付録D.1　関連マニュアル

付録D.1　関連マニュアル

関連マニュアルを次に示します。必要に応じてお読みください。

〈この項の構成〉

  • (1)　EURのマニュアル

  • (2)　関連ソフトウェアのマニュアル

  • (3)　このマニュアルでのマニュアル名表記

(1)　EURのマニュアル

EURの関連マニュアルを次に示します。

  • はじめての帳票作成（3020-7-532）※

    EUR 帳票作成機能をまだ使用したことのない人向けに，簡単な帳票を作成する方法について説明しています。

  • EUR システム設計ガイド（3021-7-001）

    EURを使用した帳票システムの計画・設計時に検討が必要な内容について説明しています。

  • EUR システム構築ガイド（3021-7-002）

    EURを使用した帳票システムを構築する手順について説明しています。

  • EUR 帳票作成 画面リファレンス（3020-7-004）

    EUR 帳票作成機能で表示されるダイアログの内容について説明しています。

  • uCosminexus EUR 帳票設計（EUR Form帳票）（3020-7-534）※

    EUR Form帳票作成機能を使用してEUR Form帳票を作成する方法について説明しています。

  • EUR 帳票出力 EUR Designer/EUR Viewer編（3021-7-005）

    EUR DesignerまたはEUR Viewerを使用して，クライアント環境で帳票を出力する方法について説明しています。

  • uCosminexus EUR クライアント帳票出力（3020-7-535）※

    EUR クライアント帳票出力機能のV8互換機能を使用して，クライアント環境で帳票を出力する方法について説明しています。

  • EUR 帳票出力 機能解説 EUR Server編（3021-7-006）

    EUR サーバ帳票出力機能を使って帳票を出力する方法について説明しています。

  • EUR 帳票出力 リファレンス EUR Server編（3021-7-007）

    EUR サーバ帳票出力機能を使って帳票を出力するときに使用するAPIや入力ファイルの設定方法について説明しています。

  • uCosminexus EUR サーバ帳票出力（3020-7-536）※

    EUR ServerのV8互換機能を使用して，サーバ環境で帳票を出力する方法について説明しています。

  • EUR データベース連携ガイド（3021-7-008）

    データベースから抽出したデータを使って帳票を作成および出力する方法，およびEUR 帳票作成機能のデータベースアクセス定義ウィンドウを使用する方法について説明しています。また，データベースの操作時に出力されるメッセージについても説明しています。

  • EUR メッセージ（3021-7-009）

    EURを使用しているときに出力されるメッセージについて説明しています。

  • EUR 用語集（3021-7-010）

    EURシリーズマニュアル内で使用する用語について説明しています。なお，この用語集は日立ソフトウェアマニュアル公開サイト，または製品同梱のヘルプ（Windows版）だけで参照できます。

注※

バージョン8のマニュアルを提供しています。バージョン10の製品に置き換えて参照してください。

ページの先頭へ

(2)　関連ソフトウェアのマニュアル

関連ソフトウェアのマニュアルを次に示します。

  • TPBroker ユーザーズガイド（3000-3-660）

  • TPBroker Developer's Kit - Extension for C++ プログラマーズガイド（3000-3-680）

  • TPBroker Object Transaction Monitor ユーザーズガイド（3000-3-689）

  • COBOL2002　使用の手引　手引編（3000-3-D42）

  • COBOL2002　使用の手引　操作編（3000-3-D43）

  • COBOL2002　操作ガイド（3020-3-D47）

  • COBOL2002　ユーザーズガイド（Web公開限定）（3020-3-D48）

  • SEWB+/REPOSITORY 辞書設計ガイド（3020-3-698）

  • SEWB+/REPOSITORY 辞書設計ガイド（3020-3-N82）

  • DBPARTNER2 Client　操作ガイド（3020-6-027）

  • DABroker（3020-6-031）

  • HiRDB Version 8 UAP開発ガイド（3020-6-356）

  • HiRDB Version 8 メッセージ（3020-6-358）

  • HiRDB Version 9 UAP開発ガイド（3020-6-456）

  • HiRDB Version 9 メッセージ（3020-6-458）

  • JP1 Version 10 JP1/Audit Management - Manager 構築・運用ガイド（3021-3-165）

ページの先頭へ

(3)　このマニュアルでのマニュアル名表記

このマニュアルでは，マニュアル名について，次のように表記しています。

マニュアル名 | 表記
uCosminexus EUR 帳票設計（EUR Form帳票） | EUR 帳票設計（EUR Form帳票）
uCosminexus EUR クライアント帳票出力 | EUR クライアント帳票出力
uCosminexus EUR サーバ帳票出力 | EUR サーバ帳票出力
HiRDB Version 8 UAP開発ガイド HiRDB Version 9 UAP開発ガイド | HiRDB UAP開発ガイド
HiRDB Version 8 メッセージ HiRDB Version 9 メッセージ | HiRDB メッセージ
JP1 Version 10 JP1/Audit Management - Manager 構築・運用ガイド | JP1/Audit Management - Manager 構築・運用ガイド

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 349 / 356


付録D.2 EUR バージョン10での製品体系の変更 : EUR 帳票作成 操作ガイド

  • 350 / 356

  • 表紙

  • 付録

  • 付録D　このマニュアルの参考情報

  • 付録D.2　EUR バージョン10での製品体系の変更

付録D.2　EUR バージョン10での製品体系の変更

  • 製品名称を変更しました。

  • uCosminexus EUR Server Print Editionを廃止しました。

EUR バージョン10での製品体系の変更について，次の図に示します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 350 / 356


付録D.3 EUR バージョン10でのマニュアル体系の変更 : EUR 帳票作成 操作ガイド

  • 351 / 356

  • 表紙

  • 付録

  • 付録D　このマニュアルの参考情報

  • 付録D.3　EUR バージョン10でのマニュアル体系の変更

付録D.3　EUR バージョン10でのマニュアル体系の変更

  • マニュアル名を変更しました。

EUR バージョン10でのマニュアル体系の変更について，次の表に示します。

EUR バージョン9 | EUR バージョン10
uCosminexus EUR システム設計ガイド | EUR システム設計ガイド
uCosminexus EUR システム構築ガイド | EUR システム構築ガイド
uCosminexus EUR 帳票作成 操作ガイド | EUR 帳票作成 操作ガイド
uCosminexus EUR 帳票作成 画面リファレンス | EUR 帳票作成 画面リファレンス
uCosminexus EUR 帳票出力 機能解説 EUR Server編 | EUR 帳票出力 機能解説 EUR Server編
uCosminexus EUR 帳票出力 リファレンス EUR Server編 | EUR 帳票出力 リファレンス EUR Server編
uCosminexus EUR 帳票出力 EUR Designer/EUR Viewer編 | EUR 帳票出力 EUR Designer/EUR Viewer編
uCosminexus EUR データベース連携ガイド | EUR データベース連携ガイド
uCosminexus EUR メッセージ | EUR メッセージ
uCosminexus EUR 用語集 | EUR 用語集

EUR ServerのV8互換機能を使用する場合は，バージョン8対応のマニュアル「EUR サーバ帳票出力」を参照してください。Windows環境では，インストール先フォルダ\Print\1041\Help\eurps.chmに統合ヘルプが格納されています。

クライアント帳票出力機能のV8互換機能を使用する場合は，バージョン8対応のマニュアル「EUR クライアント帳票出力」を参照してください。Windows環境では，次のフォルダにヘルプが格納されています。

  • EUR Designerの場合

    EUR Designerのインストール先フォルダ\Designer\1041\Help\euroutp.chm

  • EUR Viewerの場合

    EUR Viewerのインストール先フォルダ\1041\Help\euroutp.chm

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 351 / 356


付録D.4 このマニュアルでの表記 : EUR 帳票作成 操作ガイド

  • 352 / 356

  • 表紙

  • 付録

  • 付録D　このマニュアルの参考情報

  • 付録D.4　このマニュアルでの表記

付録D.4　このマニュアルでの表記

このマニュアルでは，EURの各製品について，次のように表記しています。

表記 |  | 製品名称
EUR Designer |  | EUR Designer
EUR Developer |  | EUR Developer
EUR Viewer |  | EUR Viewer
EUR Server | EUR Server Enterprise | EUR Server Enterprise
 | EUR Server Standard | EUR Server Standard
EUR Server - Cipher option |  | EUR Server - Cipher option
EUR Server Print Edition |  | uCosminexus EUR Server Print Edition
EUR Print Manager - Client |  | uCosminexus EUR Print Manager - Client
EUR Print Manager - Report Server |  | uCosminexus EUR Print Manager - Report Server
EUR Print Service |  | uCosminexus EUR Print Service
EUR Print Service Enterprise |  | uCosminexus EUR Print Service Enterprise
EUR Form | EUR Form Service | uCosminexus EUR Form Service
EUR Form Service - Data Store option |  | uCosminexus EUR Form Service - Data Store option

EUR以外の製品名称などについては，次のように表記しています。

表記 |  | 製品名称
BSP-RM |  | BSP-RM(R)
COBOL |  | COBOL2002
DABroker |  | DABroker 03-17以降 DABroker 03-21以降 DABroker(64) 03-20以降 DABroker(64) 03-21以降
HiRDB |  | HiRDB/Run Time Version 8 08-00 以降 HiRDB/Developer's Kit Version 8 08-00 以降 HiRDB/Run Time Version 8(64) 08-00 以降 HiRDB/Developer's Kit Version 8(64) 08-00 以降 HiRDB/Run Time Version 9 09-00以降 HiRDB/Developer's Kit Version 9 09-00以降 HiRDB/Developer's Suite Version 9 09-00以降 HiRDB/Run Time Version 9(64) 09-00以降 HiRDB/Developer's Kit Version 9(64) 09-00以降 HiRDB Server Version 9 09-00以降 HiRDB Server with Additional Function Version 9 09-00以降
IPF |  | Itanium(R) Processor Family
Linux | Linux 6 | Red Hat Enterprise Linux(R) Server 6 (64-bit x86_64)
 | Linux 7 | Red Hat Enterprise Linux(R) Server 7 (64-bit x86_64)
ODBC Driver |  | EURODBC Driver
 |  | DBPARTNER ODBC Driver 01-11以降
Oracle | Oracle 10g | Oracle 10g 10.1.0 Oracle 10g 10.2.0
 | Oracle 11g | Oracle Database 11g 11.1.0 Oracle Database 11g R2 11.2.0
SEWB+ |  | Software Engineering Workbench+
Hitachi Application Server |  | Hitachi Application Server uCosminexus Application Server uCosminexus Application Server Enterprise uCosminexus Application Server Standard
UNIX | AIX | AIX V6.1 AIX V7.1 AIX V7.2
 | HP-UX | HP-UX 11i V3(IPF)

このほか，このマニュアルでは，次に示す表記を使用しています。

  • EURの各製品を区別する必要がない場合は，総称してEURと表記します。

  • EUR Designer，EUR Developerの帳票作成機能を「EUR 帳票作成機能」と表記します。

  • EUR DeveloperのEUR Form帳票作成機能を「EUR 帳票作成機能（EUR Form帳票）」と表記します。

  • EUR Designer，EUR Developer，EUR Viewerのクライアント環境での帳票出力機能を「EUR クライアント帳票出力機能」と表記します。

  • EUR Developer，EUR Server Enterprise，EUR Server Standardのサーバ環境での帳票出力機能を「EUR サーバ帳票出力機能」と表記します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 352 / 356


付録D.5 このマニュアルで使用する略語 : EUR 帳票作成 操作ガイド

  • 353 / 356

  • 表紙

  • 付録

  • 付録D　このマニュアルの参考情報

  • 付録D.5　このマニュアルで使用する略語

付録D.5　このマニュアルで使用する略語

このマニュアルで使用する英略語を次に示します。

英略語 | 英字での表記
API | Application Programming Interface
ASP | Active Server Pages
BOM | Byte Order Mark
COBOL | COmmon Business Oriented Language
CPI | Characters Per Inch
CSV | Comma Separated Value
DLL | Dynamic Linking Library
DPI | Dot Per Inch
EAN | European Article Number
EJB | Enterprise JavaBeans
EMF | Enhanced Metafile
EOF | End Of File
EUR | End-User Reporting
GIF | Graphics Interchange Format
GUI | Graphical User Interface
HTTP | Hyper Text Transfer Protocol
ID | IDentifier
IPF | Itanium(R) Processor Family
ISO | International Organization for Standardization
IVS | Ideographic Variation Sequence/Selector
JAN | Japanese Article Number
JDK | Java Development Kit
JIS | Japanese Industrial Standards
JPEG | Joint Photographic Experts Group
JSP | Java Server Pages
LAN | Local Area Network
LDAP | Lightweight Directory Access Protocol
LIPS | LBP Image Processing System
LPI | Lines Per Inch
MFC | Microsoft Foundation Class
MIME | Multipurpose Internet Mail Extension
MSI | Microsoft Windows Installer
MUI | Multi User Interface
OCR | Optical Character Reader
OCX | OLE Custom Control (OLE Control eXtension)
ODBC | Open Database Connectivity
OLE | Object Linking and Embedding
PCF | Portable Compiled Format
PDF | Portable Document Format
PDL | Page Description Language
PNG | Portable Network Graphics
RPM | RPM Package Manager
SSL | Secure Sockets Layer
TIFF | Tagged Image File Format
TLS | Transport Layer Security
UAP | User Application Program
UPC | Universal Product Code
UTC | Coordinated Universal Time
WAN | Wide Area Network
XML | eXtensible Mark-up Language

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 353 / 356


付録D.6 KB（キロバイト）などの単位表記について : EUR 帳票作成 操作ガイド

  • 354 / 356

  • 表紙

  • 付録

  • 付録D　このマニュアルの参考情報

  • 付録D.6　KB（キロバイト）などの単位表記について

付録D.6　KB（キロバイト）などの単位表記について

1KB（キロバイト），1MB（メガバイト），1GB（ギガバイト），1TB（テラバイト）はそれぞれ1,024バイト，1,0242バイト，1,0243バイト，1,0244バイトです。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 354 / 356


索引 : EUR 帳票作成 操作ガイド

  • 355 / 356

  • 表紙

  • 索引

索引

  • 数字

  • C E F G H J K N S T W X Y

  • あ行 か行 さ行 た行 な行 は行 ま行 や行 ら行 わ行

数字

  • 0データ〔アイテム定義情報ファイル〕

  • 1件のときキー集計行を削除する

  • 1件のときキー集計行を削除する集計〔キー集計でできる設定〕

  • 1ページ1レコードの繰り返し

  • 1ページ複数レコードで縦方向への繰り返し

  • 1ページ複数レコードで縦横方向への繰り返し

  • 1ページ複数レコードで横方向への繰り返し

ページの先頭へ

C

  • CODE128のフォントを変更する

  • CPI指定〔アイテム定義情報ファイル〕

  • CPI値〔アイテム定義情報ファイル〕

ページの先頭へ

E

  • EUR DesignerまたはEUR Viewerで画像アイテムを貼り付けた帳票を出力する場合の注意

  • EUR Form帳票の編集でバックグラウンドを設定する場合

  • eurspcsvコマンドのオプション一覧

  • eurspcsvコマンドのオプションの説明

  • eurspcsvコマンドの構文

  • eurspcsvコマンドを使ってインポート，エクスポートする

  • EURで作成できる帳票の例

  • ［EURのプロパティ］タブ

ページの先頭へ

F

  • FNC1〔アイテム定義情報ファイル〕

ページの先頭へ

G

  • GS1-128（UCC/EAN-128）バーコードの出力

ページの先頭へ

H

  • HTMLヘルプの履歴を削除したい場合

ページの先頭へ

J

  • JAN標準/UPC-A，JAN短縮/UPC-E，CODE39，NW-7，ITF，カスタマバーコードのフォントを変更する

ページの先頭へ

K

  • KEIS専用〔フィールド定義情報ファイル〕

ページの先頭へ

N

  • ｎ個〔アイテム定義情報ファイル〕

  • ｎ個ごと繰り返し〔図形アイテム〕〔アイテム定義情報ファイル〕

  • ｎ個ごと繰り返し〔線アイテム〕〔アイテム定義情報ファイル〕

  • ｎ個ごと線種〔アイテム定義情報ファイル〕

  • ｎ個ごと線幅〔アイテム定義情報ファイル〕

ページの先頭へ

S

  • SEWB+/REPOSITORYで定義した最上位結合項目からデータを入力して帳票を出力する場合

ページの先頭へ

T

  • TWAIN

ページの先頭へ

W

  • Windows 7，Windows 8.1，またはWindows 10で部品を使用するときの注意

  • Word/Excelで作成した帳票を変換する

    • Word/Excel文書から引き継がれる情報

    • 準備

    • 前提プログラム

    • 帳票ファイル名の規則

    • 帳票ファイルを確認する

    • プリンタドライバ

    • 変換前の注意事項

    • 変換の手順

  • Word/Excelで作成した帳票を変換する〔帳票作成の手順〕

  • Word/Excel文書を帳票ファイルに変換するまでの流れ

ページの先頭へ

X

  • X位置固定〔部品定義情報ファイル〕

ページの先頭へ

Y

  • Y位置固定〔部品定義情報ファイル〕

ページの先頭へ

あ行

あ

  • アイテム

    • アイテムとは

    • アイテムを削除する

    • 網掛けアイテム

    • 円アイテム

    • 画像アイテム

    • 角丸四角アイテム

    • キー操作で変更する

    • 矩形アイテム

    • 矩形アイテムの特徴

    • 図形アイテム

    • 線アイテム

    • 線アイテムの特徴

    • 楕円アイテム

    • 多角形アイテム

    • データウィンドウから貼り付けたデータ

    • 複数アイテムの重なりや位置を調整する

    • 部品

    • ページ番号・印刷時刻・印刷日付アイテム

    • 文字アイテム

    • 文字列や数値を置き換えて表示する

  • アイテム種別〔アイテム定義情報ファイル〕

  • アイテム定義情報ファイル

  • アイテムの位置やサイズを変更する

  • アイテムの出力ページの設定

  • アイテムの配置を設定する

  • アイテムを固定位置に貼り付ける

  • アイテムを削除する

  • アイテムを選択する

  • アイテムを配置する

    • 網掛けアイテム

    • 印刷時刻

    • 印刷日付

    • 円／楕円アイテム

    • 画像ファイル

    • 角丸四角アイテム

    • 矩形アイテムを配置する

    • 図形アイテム

    • 正方形

    • 線アイテム

    • 多角形アイテム

    • データウィンドウからデータを貼り付ける

    • ページ番号

    • 文字アイテム

  • アイテムをリサイズする〔キー操作で変更する〕

  • 後付加文字〔アイテム定義情報ファイル〕

  • 網掛けアイテム〔アイテムとは〕

い

  • 位置固定〔ブレイク定義情報ファイル〕

  • 位置を移動する〔キー操作で変更する〕

  • 印刷時の注意

  • インポート〔部品〕

う

  • ウィンドウ構成

  • ウィンドウ表示倍率を変更する

  • 上揃え

  • 上余白〔帳票全体定義情報ファイル〕

え

  • エクスポート〔部品〕

  • 円アイテム〔アイテムとは〕

お

  • 置き換え〔アイテム定義情報ファイル〕

  • 置き換え表〔帳票全体定義情報ファイル〕

  • 置き換え表管理情報ファイル

  • 置き換え表管理情報ファイルを作成する

  • 置き換え表ファイル

  • 置き換え表ファイルを作成する

  • 置き換え表名〔アイテム定義情報ファイル〕

  • 置き換え表を登録する

  • 置き換えるアイテムを指定する

  • 同じ項目をまとめて表示する

ページの先頭へ

か行

か

  • 開始X〔アイテム定義情報ファイル〕

  • 開始X〔部品定義情報ファイル〕

  • 開始Y〔アイテム定義情報ファイル〕

  • 開始Y〔部品定義情報ファイル〕

  • 改ブロックを解除する

  • 改ブロックを設定する

  • 改ページを解除する

  • 改ページを設定する

  • 拡大/縮小〔アイテム定義情報ファイル〕

  • 影〔アイテム定義情報ファイル〕

  • 下限位置縦〔帳票全体定義情報ファイル〕

  • 下限位置横〔帳票全体定義情報ファイル〕

  • 重なり

  • 重なりを変更する

    • 最前面へ移動する

    • 最背面へ移動する

    • 前面へ移動する

    • 背面へ移動する

    • 複数アイテムの重なりや位置を調整する

  • 下線

  • 仮想アイテム

  • 画像アイテム〔部品定義情報ファイル〕

  • 画像アイテム〔アイテムとは〕

  • 画像解像度X〔帳票全体定義情報ファイル〕

  • 画像解像度Y〔帳票全体定義情報ファイル〕

  • 画像データを貼り付ける

  • 画像ファイルを貼り付ける

  • 角丸〔アイテム定義情報ファイル〕

  • 角丸四角アイテム〔アイテムとは〕

  • 可変形式

  • 可変形式帳票でのキー集計〔キー集計でできる設定〕

  • 可変形式の帳票を定義する場合

  • 空データ〔アイテム定義情報ファイル〕

  • 空データの扱い

  • 空レコード無視〔フィールド定義情報ファイル〕

  • 空レコードを無視する〔CSV形式およびDAT形式〕

  • 空レコードを無視する〔FIX形式〕

  • 元年表記〔アイテム定義情報ファイル〕

  • カンマ〔アイテム定義情報ファイル〕

き

  • キー〔ブレイク定義情報ファイル〕

  • キー集計

    • 可変形式帳票

    • キー集計を作成する

    • 多階層の集計

    • フィールドが1件のときキー集計行を削除する

    • 複数のフィールドをキーに指定

  • キー集計生成〔帳票全体定義情報ファイル〕

  • キー集計でできる設定

  • キー集計と改ブロック／改ページの組み合わせ〔キー集計でできる設定〕

  • キー集計とは

  • キー集計を利用した帳票の例〔キー集計でできる設定〕

  • キー操作で変更する

  • 基準位置〔部品定義情報ファイル〕

  • 基準レコード位置

  • 基準レコード位置〔帳票全体定義情報ファイル〕

  • 基準レコード幅

  • 基準レコード幅〔帳票全体定義情報ファイル〕

  • 既存の帳票

  • 起動

  • 機能コード〔アイテム定義情報ファイル〕

  • 行間隔〔アイテム定義情報ファイル〕

  • 行種別〔アイテム定義情報ファイル〕

  • 行頭禁則文字〔帳票全体定義情報ファイル〕

  • 行末禁則文字〔帳票全体定義情報ファイル〕

  • 禁則処理〔アイテム定義情報ファイル〕

  • 禁則文字言語〔帳票全体定義情報ファイル〕

く

  • 区切り位置〔フィールド定義情報ファイル〕

  • 区切り方法〔フィールド定義情報ファイル〕

  • 区切り文字〔フィールド定義情報ファイル〕

  • 矩形アイテムの特徴

  • 矩形アイテム〔アイテムとは〕

  • 繰り返しLPI〔帳票全体定義情報ファイル〕

  • 繰り返しLPI行数〔帳票全体定義情報ファイル〕

  • 繰り返し個数を設定する

  • 繰り返し種別〔アイテム定義情報ファイル〕

  • 繰り返し縦位置〔帳票全体定義情報ファイル〕

  • 繰り返し定義を設定する

  • 繰り返し優先方向〔帳票全体定義情報ファイル〕

  • 繰り返し横位置〔帳票全体定義情報ファイル〕

  • 繰り返し領域

  • 繰り返しを解除する

  • グリッド（格子線）

  • グリッドX開始〔帳票全体定義情報ファイル〕

  • グリッドY開始〔帳票全体定義情報ファイル〕

  • グリッド縦間隔〔帳票全体定義情報ファイル〕

  • グリッド縦間隔（LPI）〔帳票全体定義情報ファイル〕

  • グリッドの属性変更

  • グリッドの表示

  • グリッド表示〔帳票全体定義情報ファイル〕

  • グリッド補正〔帳票全体定義情報ファイル〕

  • グリッド補正する

  • グリッド横間隔〔帳票全体定義情報ファイル〕

  • グリッド横間隔（CPI）〔帳票全体定義情報ファイル〕

け

  • 元号年1年を元年表示する

  • 原点〔アイテム定義情報ファイル〕

こ

  • 固定/可変〔アイテム定義情報ファイル〕

  • 固定形式

  • 固定形式の帳票を定義する場合

  • 固定文字種別〔アイテム定義情報ファイル〕

  • 固定文字列

  • コメント〔部品定義情報ファイル〕

ページの先頭へ

さ行

さ

  • 最上位結合項目

  • 最上位結合項目を利用する帳票を印刷する場合の注意事項

  • 最前面へ移動する

  • 最背面へ移動する

  • 作成日付〔部品定義情報ファイル〕

  • サブウィンドウ

  • サンプル件数〔フィールド定義情報ファイル〕

  • サンプル帳票

  • サンプルデータ〔フィールド定義情報ファイル〕

  • サンプルデータを作成する

    • ［フィールド定義］ダイアログでサンプルデータを作成する

し

  • 四捨五入〔アイテム定義情報ファイル〕

  • 辞書定義方法〔フィールド定義情報ファイル〕

  • 辞書ファイル名〔フィールド定義情報ファイル〕

  • 指数表示〔文字アイテム〕〔アイテム定義情報ファイル〕

  • 下敷き

    • 下敷きの表示・非表示を設定する

    • 下敷きを作成する

    • 下敷きを読み込む

  • 下敷き画像〔帳票全体定義情報ファイル〕

  • 下敷き画像X位置〔帳票全体定義情報ファイル〕

  • 下敷き画像Y位置〔帳票全体定義情報ファイル〕

  • 下敷き画像サイズ指定〔帳票全体定義情報ファイル〕

  • 下敷き画像高さ〔帳票全体定義情報ファイル〕

  • 下敷き画像幅〔帳票全体定義情報ファイル〕

  • 下敷きの表示・非表示を設定する

  • 下敷きを作成する

  • 下敷きを読み込む

  • 下揃え

  • 下余白〔帳票全体定義情報ファイル〕

  • 実アイテム

  • ［指定のページへジャンプ］ダイアログ

  • 斜体〔アイテム定義情報ファイル〕

  • 集計

    • 1件のときキー集計行を削除する

    • 1件のときキー集計行を削除する集計〔キー集計でできる設定〕

    • 可変形式帳票でのキー集計〔キー集計でできる設定〕

    • 空データの扱い

    • キー集計でできる設定

    • キー集計と改ブロック／改ページの組み合わせ〔キー集計でできる設定〕

    • キー集計とは

    • キー集計を利用した帳票の例〔キー集計でできる設定〕

    • 集計アイテムのプロパティを設定する

    • 集計アイテムを作成する

    • 集計行／総集計行を解除する

    • 集計行にするデータを集計対象に指定する

    • 集計行のアイテムを編集する

    • 集計行の位置解除

    • 集計行の位置を変更する

    • 集計行の下限位置の設定

    • 集計行の表示位置の移動

    • 集計行の編集手順

    • 集計行編集時の注意

    • 集計ページを設定する

    • 集計方法を選択する

    • 総集計でできる設定

    • 総集計とは

    • 多階層の集計〔キー集計でできる設定〕

    • 帳票ヘッダ集計でできる設定

    • データ集計の種類

    • データ集計をする前に

    • 複数フィールドのキー集計〔キー集計でできる設定〕

    • ページ集計でできる設定

    • ページ集計とは

    • ページ集計の表示位置

  • 集計アイテム

  • 集計アイテムのプロパティを設定する

  • 集計アイテムを作成する

  • 集計アイテムを貼り付ける

  • 集計行／総集計行を解除する

  • 集計行にするデータを集計対象に指定する

  • 集計行のアイテムを編集する

  • 集計行の位置解除

  • 集計行の位置を変更する

  • 集計行の下限位置の設定

  • 集計行の表示位置の移動

  • 集計行の編集手順

  • 集計行編集時の注意

  • 集計行編集モード

  • 集計行編集モードでできる操作

  • 集計種別〔アイテム定義情報ファイル〕

  • 集計ページ〔アイテム定義情報ファイル〕

  • 集計ページを設定する

  • 集計方法を選択する

  • 終了

  • 出力桁数〔アイテム定義情報ファイル〕

  • 出力桁数指定〔アイテム定義情報ファイル〕

  • 出力ページ〔アイテム定義情報ファイル〕

  • 出力ページに出力するデータの準備

  • 種別〔フィールド定義情報ファイル〕

  • 種別〔ブレイク定義情報ファイル〕

  • 順序番号〔アイテム定義情報ファイル〕

  • 順序番号〔部品定義情報ファイル〕

  • 条件付きアイテム

    • アイテムのプロパティを設定する

    • 条件付きアイテムとは

    • 条件付きアイテムを使用した帳票の設定例

    • 条件付きアイテムを配置する

    • 表示条件の設定手順

    • 表示条件を設定する

    • 表示条件を設定できるアイテム

  • 小数点以下桁数〔アイテム定義情報ファイル〕

  • 小数点文字〔アイテム定義情報ファイル〕

  • 使用する単位ごとのアイテムの移動，およびリサイズ量

  • 初期X位置〔部品定義情報ファイル〕

  • 初期Y位置〔部品定義情報ファイル〕

  • 初期位置〔部品定義情報ファイル〕

  • 書式〔アイテム定義情報ファイル〕

  • 書式バージョン〔アイテム定義情報ファイル〕

  • 新規作成

す

  • 数値データのプロパティを設定する

  • スクリーンセーバの動作

  • 図形アイテム〔アイテムとは〕

  • 図形アイテム〔部品定義情報ファイル〕

  • 図形種別〔アイテム定義情報ファイル〕

  • スケーラブルフォント

  • スタートキャラクタ〔アイテム定義情報ファイル〕

せ

  • 西暦の変換記号

  • 設定を解除されるアイテム〔部品〕

  • セルサイズ〔アイテム定義情報ファイル〕

  • セル単位の貼り付け

  • セル名〔アイテム定義情報ファイル〕

  • ゼロ埋め桁数〔アイテム定義情報ファイル〕

  • 線〔部品定義情報ファイル〕

  • 線ｎ個〔アイテム定義情報ファイル〕

  • 線アイテムの特徴

  • 線アイテムを選択するときの注意

  • 前景色〔アイテム定義情報ファイル〕

  • 線種〔アイテム定義情報ファイル〕

  • 線種・線幅に関する注意

  • 線色〔アイテム定義情報ファイル〕

  • 選択する

    • 単一選択

    • 追加選択

    • 複数選択

  • 先頭・最終ページ範囲〔帳票全体定義情報ファイル〕

  • 線幅〔アイテム定義情報ファイル〕

  • 前面へ移動する

そ

  • 総集計でできる設定

  • 総集計とは

  • 総集計を作成する

  • 外枠線〔アイテム定義情報ファイル〕

  • 外枠線種〔アイテム定義情報ファイル〕

  • 外枠線幅〔アイテム定義情報ファイル〕

ページの先頭へ

た行

た

  • ダイアログで変更する

  • ダイアログの［×］（閉じる）ボタンの扱い

  • 対象

  • 楕円アイテム〔アイテムとは〕

  • 多階層の集計〔キー集計でできる設定〕

  • 多角形アイテム

    • 多角形の回転

    • 多角形の頂点の編集

    • 多角形の反転

  • 多角形アイテムを調整する

  • 多角形アイテム〔アイテムとは〕

  • 多角形の回転

  • 多角形の生成操作中の注意

  • 多角形の頂点の編集

  • 多角形の反転

  • 高さ〔アイテム定義情報ファイル〕

  • 高さ〔部品定義情報ファイル〕

  • 高さを揃える

  • 縦位置〔アイテム定義情報ファイル〕

  • 縦繰り返し個数〔帳票全体定義情報ファイル〕

  • 縦横比保持〔アイテム定義情報ファイル〕

  • 縦横比補正〔アイテム定義情報ファイル〕

  • 単位を設定する〔アイテムの位置やサイズを変更する〕

ち

  • チェックキャラクタ〔アイテム定義情報ファイル〕

  • 頂点個数〔アイテム定義情報ファイル〕

  • 頂点座標〔アイテム定義情報ファイル〕

  • 帳票ウィンドウ

  • 帳票作成の概要

  • 帳票作成の手順

  • 帳票全体定義情報ファイル

  • 帳票定義情報

  • 帳票定義情報構成ファイル

  • 帳票定義情報ファイル

    • アイテム定義情報ファイル

    • 帳票全体定義情報ファイル

    • フィールド定義情報ファイル

    • 部品定義情報ファイル

    • ブレイク定義情報ファイル

    • 補足情報ファイル

  • 帳票定義情報ファイル（アイテム定義情報.csv）の変換例

  • 帳票定義情報ファイルから帳票ファイルに変換する

  • 帳票定義情報ファイルの格納先

  • 帳票定義情報ファイルの構成

  • 帳票定義情報ファイルの出力形式

  • 帳票定義情報ファイルの使用例

  • 帳票定義情報ファイルを保存する

  • 帳票の情報を帳票定義情報ファイルに変換する

  • 帳票ファイル名〔Word/Excel文書から変換された帳票ファイル名〕

  • 帳票ファイルを帳票定義情報ファイルに変換する（ダイアログで実行する場合）

  • 帳票ヘッダアイテム

  • 帳票ヘッダアイテムを作成する

  • 帳票ヘッダアイテムを設定する

  • 帳票ヘッダ集計

  • 帳票ヘッダ集計でできる設定

  • 帳票ヘッダ集計の作成

  • 帳票ヘッダ高さ〔帳票全体定義情報ファイル〕

  • 帳票ヘッダ領域

  • 帳票ヘッダ領域の削除

  • 帳票ヘッダ領域を設定する

  • 帳票を印刷プレビューで確認する

  • 帳票を新規に作成する〔帳票作成の手順〕

  • 帳票をレイアウト表示して確認する

  • 直線を引く

つ

  • ツールバーの表示／非表示

  • ツールボックス

  • 次紙ページ

て

  • ディクショナリファイルを指定するときの注意

  • ディクショナリファイルを使用する

  • 訂正レベル〔アイテム定義情報ファイル〕

  • データウィンドウから貼り付けたデータ〔アイテムとは〕

  • データウィンドウでのセルの移動

  • データウィンドウでのデータの選択

  • データキャラクタ〔アイテム定義情報ファイル〕

  • データキャラクタ行数〔アイテム定義情報ファイル〕

  • データキャラクタサイズ〔アイテム定義情報ファイル〕

  • データキャラクタ縦位置〔アイテム定義情報ファイル〕

  • データキャラクタフォント〔アイテム定義情報ファイル〕

  • データキャラクタフォント〔帳票全体定義情報ファイル〕

  • データキャラクタプロパティ〔アイテム定義情報ファイル〕

  • データキャラクタ横位置〔アイテム定義情報ファイル〕

  • データ集計の種類

  • データ種別〔アイテム定義情報ファイル〕

  • データ種別〔フィールド定義情報ファイル〕

  • データの貼り付け操作での注意

  • データファイル名〔フィールド定義情報ファイル〕

  • データ読み込みの種類

と

  • 登録できないアイテム〔部品〕

  • 登録できるアイテムの種類〔部品〕

  • 登録できる部品・アイテムの上限〔部品〕

  • 独自の用紙サイズを設定する

  • 特殊行編集〔フィールド定義情報ファイル〕

  • 特殊編集レベルとは

  • 特殊編集レベルの設定手順

  • 特定の行のデータを編集する

  • ドラッグアンドドロップ時の注意

ページの先頭へ

な行

な

  • 長さ〔帳票全体定義情報ファイル〕

  • 斜め45°の直線を引く

に

  • 任意書式指定〔アイテム定義情報ファイル〕

ぬ

  • ヌル無視〔フィールド定義情報ファイル〕

の

  • ノンスケーラブルフォント

ページの先頭へ

は行

は

  • バーコードアイテムのプロパティを設定する

  • バーコード回転〔アイテム定義情報ファイル〕

  • バーコードサイズ〔アイテム定義情報ファイル〕

  • バーコード種別〔アイテム定義情報ファイル〕

  • バーコード高さ〔アイテム定義情報ファイル〕

  • バーコードデータ形式〔アイテム定義情報ファイル〕

  • バーコード倍率〔アイテム定義情報ファイル〕

  • バージョン〔アイテム定義情報ファイル〕

  • 背景色〔アイテム定義情報ファイル〕

  • 背面へ移動する

  • 幅を揃える

  • 幅〔アイテム定義情報ファイル〕

  • 幅〔帳票全体定義情報ファイル〕

  • 幅〔部品定義情報ファイル〕

  • 貼付域に挿入する

  • 貼り付け操作後の処理

  • 貼り付ける

    • 画像データを貼り付ける

    • 画像ファイルを貼り付ける

    • 集計アイテムを貼り付ける

ひ

  • 左揃え

  • 左余白〔帳票全体定義情報ファイル〕

  • 日付種別〔アイテム定義情報ファイル〕

  • 日付書式〔アイテム定義情報ファイル〕

  • 日付データの表示形式の設定

  • 一つの部品で使用できるアイテムの上限

  • 表

    • 同じ項目をまとめて表示する

    • 改ブロックを解除する

    • 改ブロックを設定する

    • 改ページを解除する

    • 改ページを設定する

    • 可変形式の帳票を定義する場合

    • 繰り返し個数を設定する

    • 繰り返し定義を設定する

    • 繰り返しを解除する

    • 固定形式の帳票を定義する場合

    • 表区切り線（レコード間）を変更する

    • 表の罫線を設定する

    • 表の作成手順

    • 表の外枠の線種を変更する

    • 表の見出しの繰り返しを定義する

    • 表をブロック単位で分割する

    • 表をページ単位で分割する

    • まとめ表示を解除する

    • まとめ表示を設定する

  • 表区切り線（レコード間）を変更する

  • 表示条件演算子1〔アイテム定義情報ファイル〕

  • 表示条件演算子2〔アイテム定義情報ファイル〕

  • 表示条件参照フィールド〔アイテム定義情報ファイル〕

  • 表示条件参照フィールド種別〔アイテム定義情報ファイル〕

  • 表示条件指定〔アイテム定義情報ファイル〕

  • 表示条件指定値1〔アイテム定義情報ファイル〕

  • 表示条件指定値1フィールド〔アイテム定義情報ファイル〕

  • 表示条件指定値1フィールド指定〔アイテム定義情報ファイル〕

  • 表示条件指定値1フィールド種別〔アイテム定義情報ファイル〕

  • 表示条件指定値2〔アイテム定義情報ファイル〕

  • 表示条件指定値2フィールド〔アイテム定義情報ファイル〕

  • 表示条件指定値2フィールド指定〔アイテム定義情報ファイル〕

  • 表示条件指定値2フィールド種別〔アイテム定義情報ファイル〕

  • 表示条件範囲指定〔アイテム定義情報ファイル〕

  • 表示条件表示方法〔アイテム定義情報ファイル〕

  • 表紙のある帳票

  • 表紙ページ

  • 表示文字認識〔アイテム定義情報ファイル〕

  • 標準料金代理収納システムに対応したGS1-128（UCC/EAN-128）バーコードの出力

  • 標準料金代理収納システムに対応したGS1-128（UCC/EAN-128）バーコードの出力例

  • 表の罫線を設定する

  • 表の作成手順

  • 表の外枠の線種を変更する

  • 表の見出しの繰り返しを定義する

  • 表を確認する

  • 表をブロック単位で分割する

  • 表をページ単位で分割する

ふ

  • ファイル形式とプログラムのバージョン〔Word/Excel文書からの変換時の注意〕

  • ファイル名〔アイテム定義情報ファイル〕

  • フィールドが1件のときキー集計行を削除する

  • フィールド定義情報ファイル

  • フィールド定義を変更する前の操作

  • フィールド名〔アイテム定義情報ファイル〕

  • フィールド名〔フィールド定義情報ファイル〕

  • フォームシートファイル形式の変換記号〔日付データ〕

  • フォントサイズ〔アイテム定義情報ファイル〕

  • フォントに関する注意〔帳票の印刷〕

  • フォント名〔アイテム定義情報ファイル〕

  • フォントリサイズ〔アイテム定義情報ファイル〕

  • 複数アイテムの重なりや位置を調整する

  • 複数フィールドのキー集計〔キー集計でできる設定〕

  • 複数様式定義作成ツール

    • 作成できる複数様式の帳票のパターン

    • 使用する前の準備

    • 操作の流れ

    • 定義できる内容

    • ファイルの設定

    • 複数様式定義の保存

    • 複数様式パターンの選択

    • ページ番号の設定

    • 様式数の設定

    • 様式を切り替えるキーの設定

    • 両面印刷時の設定

  • 複数様式定義作成ツールで作成できるパターン

    • カーボンコピー／複写帳票

    • カーボンコピー／複写帳票（次紙様式付き）

    • キー付き入れ子単純繰り返し

    • キー付き単純繰り返し

    • キー付き単純繰り返し（次紙様式付きA）

    • キー付き単純繰り返し（次紙様式付きB）

    • 順次帳票

    • 順次帳票（次紙様式付きA）

    • 順次帳票（次紙様式付きB）

    • 単純繰り返し

    • 単純繰り返し（マッピングデータが一つ）

  • 複数様式の帳票（複数の様式・出力用データを組み合わせた形式）

  • 複数様式の帳票の出力定義をツールで作成する

  • 太字〔アイテム定義情報ファイル〕

  • 部品

    • Windows 7，Windows 8.1，またはWindows 10で部品を使用するときの注意

    • 登録できるアイテムの種類

    • 登録できる部品・アイテムの上限

    • 部品庫に登録できる部品の上限

    • 部品使用時の注意事項

    • 部品登録機能

    • 部品とフィールド定義の連動

    • 部品の使用手順

    • 部品の表示位置を指定する

    • 部品のプロパティを表示する

    • 部品名を変更する

    • 部品を移動する

    • 部品をインポートする

    • 部品をエクスポート，インポートする

    • 部品をエクスポートする

    • 部品を削除する

    • 部品を識別する規則

    • 部品を帳票に貼り付ける

    • 部品を登録する

  • 部品ID〔部品定義情報ファイル〕

  • 部品アーカイブファイル

  • 部品使用時の注意事項

  • 部品定義情報ファイル

  • 部品とフィールド定義の連動

  • 部品の使用手順

  • 部品の表示位置を指定する

  • 部品のプロパティを表示する

  • 部品バージョン〔部品定義情報ファイル〕

  • 部品名〔部品定義情報ファイル〕

  • 部品名を変更する

  • 部品を移動する

  • 部品をインポートする

  • 部品をエクスポート，インポートする

  • 部品をエクスポートする

  • 部品を削除する

  • 部品を識別する規則

  • 部品を帳票に貼り付ける

  • 部品を登録する

  • 部品〔アイテムとは〕

  • 負符号文字〔アイテム定義情報ファイル〕

  • プリンタドライバを設定する

    • EMFスプールを設定する

    • 注意事項

    • 通常使うプリンタを設定する

  • フルパスの指定方法

  • ブレイク定義情報ファイル

  • ブレイク編集〔フィールド定義情報ファイル〕

  • プレプリント用紙に合わせて帳票を作成する〔帳票作成の手順〕

  • ブロック

  • プロパティ

    • ［アイテムのプロパティ］ダイアログの表示

    • 画像アイテムのプロパティを設定する

    • 集計アイテムのプロパティを設定する

    • 数値データのプロパティを設定する

    • 図形アイテムのプロパティを設定する

    • 線アイテムのプロパティを設定する

    • バーコードアイテムのプロパティを設定する

    • 日付データのプロパティを設定する

    • 部品のプロパティを設定する

    • ページ番号アイテムのプロパティを設定する

    • 文字アイテムと文字データのプロパティを設定する

  • プロパティ表示

  • プロパティ表示に関する注意

へ

  • ページ集計

    • ページ集計を作成する

  • ページ集計でできる設定

  • ページ集計とは

  • ページ集計の表示位置

  • ページ番号位置〔帳票全体定義情報ファイル〕

  • ページ番号印刷〔帳票全体定義情報ファイル〕

  • ページ番号桁数〔アイテム定義情報ファイル〕

  • ページ番号初期化〔帳票全体定義情報ファイル〕

  • ページ番号初期値〔帳票全体定義情報ファイル〕

  • ページ番号書式〔帳票全体定義情報ファイル〕

  • ページ番号の形式

  • ページ番号の設定個所

  • ページ番号・印刷時刻・印刷日付アイテム〔アイテムとは〕

  • ページめくり

  • ページめくりに対応したショートカットキーの一覧

  • 変換元のWord/Excel文書の注意

ほ

  • 補足情報ファイル

ページの先頭へ

ま行

ま

  • マウス操作で変更する

  • 前付加文字〔アイテム定義情報ファイル〕

  • マッピングデータ

  • マッピングデータウィンドウ

  • まとめ〔アイテム定義情報ファイル〕

  • まとめ罫線〔アイテム定義情報ファイル〕

  • まとめ先頭〔帳票全体定義情報ファイル〕

  • まとめ表示を解除する

  • まとめ表示を設定する

  • まとめ分断〔帳票全体定義情報ファイル〕

  • まとめ優先〔アイテム定義情報ファイル〕

  • まとめリスト〔帳票全体定義情報ファイル〕

  • 丸め半径X〔アイテム定義情報ファイル〕

  • 丸め半径Y〔アイテム定義情報ファイル〕

み

  • 右揃え

  • 右余白〔帳票全体定義情報ファイル〕

  • 見出し〔フィールド定義情報ファイル〕

む

  • 向き〔帳票全体定義情報ファイル〕

め

  • メインウィンドウ

  • メニューに対応したショートカットキーの一覧

も

  • 文字アイテム〔アイテムとは〕

  • 文字アイテム〔部品定義情報ファイル〕

  • 文字間隔〔アイテム定義情報ファイル〕

  • 文字色〔アイテム定義情報ファイル〕

  • 文字配置方式〔アイテム定義情報ファイル〕

  • 文字方向〔アイテム定義情報ファイル〕

  • 文字列〔アイテム定義情報ファイル〕

  • 文字列や数値を置き換えて表示する

  • 模様〔アイテム定義情報ファイル〕

ページの先頭へ

や行

ゆ

  • ユーザ定義データウィンドウ

よ

  • 用紙〔帳票全体定義情報ファイル〕

  • 用紙サイズの変更

  • 用紙サイズを変更するときの注意

  • 用紙の設定

    • 用紙サイズの変更

    • 用紙のデフォルト設定

    • 用紙の向きの変更

    • 用紙の余白の変更

  • 用紙のデフォルト設定

  • 用紙の向きの変更

  • 用紙の余白の変更

  • 横位置〔アイテム定義情報ファイル〕

  • 横繰り返し個数〔帳票全体定義情報ファイル〕

  • 余白に関する注意〔用紙〕

  • 余白にページ番号を配置する

ページの先頭へ

ら行

ら

  • ラバーバンド

る

  • ルーラを表示する

れ

  • レイアウト表示

  • レイアウトを揃える

    • 上揃え

    • 下揃え

    • 高さを揃える

    • 幅を揃える

    • 左揃え

    • 右揃え

  • レコード相対〔アイテム定義情報ファイル〕

  • レコード単位の貼り付け

  • レベル〔アイテム定義情報ファイル〕

  • レベル〔ブレイク定義情報ファイル〕

  • レポートファイル形式の変換記号〔日付データ〕

  • レポート編集ウィンドウのメニューとツールバー

ページの先頭へ

わ行

わ

  • ワードラップ〔アイテム定義情報ファイル〕

  • 枠線〔アイテム定義情報ファイル〕

  • 枠線種別〔アイテム定義情報ファイル〕

  • 枠線色〔アイテム定義情報ファイル〕

  • 和暦の変換記号

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 355 / 356


マニュアル発行元 : EUR 帳票作成 操作ガイド

  • 356 / 356

  • 表紙

  • マニュアル発行元

マニュアル発行元

株式会社 日立製作所

〒100‒8280　東京都千代田区丸の内一丁目6番6号

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 356 / 356


目次 : EUR 帳票作成 操作ガイド

  • 2 / 356

  • 表紙

  • 目次

目次

  • 前書き

  • 変更内容

  • はじめに

  • 1.　帳票作成の概要

    • 1.1　帳票作成の手順

      • 1.1.1　帳票を新規に作成する

      • 1.1.2　プレプリント用紙に合わせて帳票を作成する

      • 1.1.3　Word/Excelで作成した帳票を変換する

    • 1.2　EURで作成できる帳票の例

      • 1.2.1　EURで提供するサンプル帳票

      • 1.2.2　表紙のある帳票

      • 1.2.3　複数様式の帳票（複数の様式・出力用データを組み合わせた形式）

    • 1.3　EUR 帳票作成機能の起動と終了

      • 1.3.1　EURを起動する（帳票の新規作成）

      • 1.3.2　既存の帳票ファイルを開く

      • 1.3.3　帳票ファイルのプロパティ表示

      • 1.3.4　EURを終了する

    • 1.4　グリッドを設定する

      • 1.4.1　グリッドの表示

      • 1.4.2　グリッドの属性変更

    • 1.5　ルーラを表示する

      • 1.5.1　補足説明

    • 1.6　ウィンドウ表示倍率を変更する

      • 1.6.1　［ズーム］ダイアログで変更する方法

      • 1.6.2　ツールバーボタンで変更する方法

      • 1.6.3　補足説明

    • 1.7　EURのウィンドウ構成

  • 2.　用紙を設定する

    • 2.1　デフォルトの用紙の設定

    • 2.2　用紙の設定を変更する

      • 2.2.1　用紙サイズの変更

      • 2.2.2　用紙の向きの変更

      • 2.2.3　用紙の余白の変更

  • 3.　データを読み込む

    • 3.1　データ読み込みの種類

    • 3.2　データファイルからの読み込み手順

      • 3.2.1　CSV形式およびDAT形式のデータの読み込み

      • 3.2.2　FIX形式のデータの読み込み

    • 3.3　データウィンドウのフィールド定義を変更する

      • 3.3.1　フィールド定義を変更する前の操作

      • 3.3.2　フィールド定義の変更手順

      • 3.3.3　帳票に貼り付けたデータのフィールド定義の変更・削除

    • 3.4　フィールド表示幅を変更する

      • 3.4.1　フィールド表示幅をデータ長に合わせる

      • 3.4.2　任意のフィールド表示幅を設定する

    • 3.5　基準レコードを変更する

      • 3.5.1　基準レコード位置の変更

      • 3.5.2　基準レコード幅の変更

    • 3.6　サンプルデータを作成する

      • 3.6.1　［フィールド定義］ダイアログでサンプルデータを作成する

    • 3.7　ディクショナリファイルを使用する

      • 3.7.1　ディクショナリファイルとは

      • 3.7.2　ディクショナリファイルによるフィールド定義の指定

    • 3.8　SEWB+/REPOSITORYで定義した最上位結合項目からデータを読み込む

      • 3.8.1　データの読み込み手順

      • 3.8.2　フィールド定義情報の更新

  • 4.　帳票のレイアウトを決める

    • 4.1　アイテムとは

      • 4.1.1　文字・線・矩形・網掛けアイテム

      • 4.1.2　図形アイテム

      • 4.1.3　画像アイテム

      • 4.1.4　データウィンドウから貼り付けたデータ

      • 4.1.5　ページ番号・印刷時刻・印刷日付アイテム

      • 4.1.6　部品

    • 4.2　アイテムを配置する

      • 4.2.1　文字アイテムを配置する

      • 4.2.2　線アイテムを配置する

      • 4.2.3　矩形アイテムを配置する

      • 4.2.4　網掛けアイテムを配置する

      • 4.2.5　図形アイテムを配置する

    • 4.3　データウィンドウからデータを貼り付ける

      • 4.3.1　画像以外のデータを貼り付ける

      • 4.3.2　画像データを貼り付ける

      • 4.3.3　標準料金代理収納システムに対応したGS1-128（UCC/EAN-128）バーコードの出力

    • 4.4　画像ファイルを配置する

      • 4.4.1　帳票に画像ファイルを配置する

      • 4.4.2　貼り付けた画像アイテムを更新する

      • 4.4.3　同じファイル名の画像を複数貼り付ける

      • 4.4.4　補足説明

    • 4.5　ページ番号を配置する

      • 4.5.1　貼付域に挿入する

      • 4.5.2　余白にページ番号を配置する

    • 4.6　印刷日付・印刷時刻を配置する

      • 4.6.1　印刷日付アイテムを配置する

      • 4.6.2　印刷時刻アイテムを配置する

    • 4.7　アイテムの位置やサイズを変更する

      • 4.7.1　位置やサイズを変更するときの単位を設定する

      • 4.7.2　アイテムを選択する

      • 4.7.3　マウス操作で変更する

      • 4.7.4　ダイアログで変更する

      • 4.7.5　キー操作で変更する

      • 4.7.6　多角形アイテムを調整する

    • 4.8　複数アイテムの重なりや位置を調整する

      • 4.8.1　重なりを変更する

      • 4.8.2　レイアウトを揃える

    • 4.9　特定のページに出力するアイテムを設定する

      • 4.9.1　出力ページに出力するデータの準備

      • 4.9.2　アイテムの出力ページの設定

    • 4.10　アイテムを削除する

  • 5.　表を作成する

    • 5.1　表の作成手順

      • 5.1.1　可変形式の帳票を定義する場合

      • 5.1.2　固定形式の帳票を定義する場合

    • 5.2　表の罫線を設定する

      • 5.2.1　表区切り線（レコード間）を変更する

      • 5.2.2　表の外枠の線種を変更する

    • 5.3　繰り返しを定義する

      • 5.3.1　繰り返し定義を設定する

      • 5.3.2　繰り返し個数を設定する

      • 5.3.3　表の見出しの繰り返しを定義する

      • 5.3.4　繰り返しを解除する

    • 5.4　改ブロックを設定する

      • 5.4.1　表をブロック単位で分割する

      • 5.4.2　改ブロックを解除する

    • 5.5　改ページを設定する

      • 5.5.1　表をページ単位で分割する

      • 5.5.2　改ページを解除する

    • 5.6　同じ項目をまとめて表示する

      • 5.6.1　まとめ表示を設定する

      • 5.6.2　まとめ表示を解除する

    • 5.7　表を確認する

  • 6.　帳票上でデータを集計する

    • 6.1　データ集計の種類

      • 6.1.1　キー集計でできる設定

      • 6.1.2　ページ集計でできる設定

      • 6.1.3　総集計でできる設定

      • 6.1.4　帳票ヘッダ集計でできる設定

    • 6.2　データ集計をする前に

      • 6.2.1　空データの扱い

      • 6.2.2　集計行にするデータを集計対象に指定する

    • 6.3　キー集計を作成する

      • 6.3.1　可変形式帳票での作成手順

      • 6.3.2　キーフィールドを複数設定して作成する手順（多階層の集計）

      • 6.3.3　複数のフィールドをキーに指定して作成する手順

      • 6.3.4　フィールドが1件のときキー集計行を削除する

      • 6.3.5　キー集計を作成したあと

    • 6.4　ページ集計を作成する

      • 6.4.1　ページ集計の作成手順

      • 6.4.2　ページ集計を設定したあと

      • 6.4.3　ページ集計の表示位置

      • 6.4.4　補足説明

    • 6.5　総集計を作成する

      • 6.5.1　総集計の作成手順

      • 6.5.2　総集計を設定したあと

      • 6.5.3　補足説明

    • 6.6　集計行を編集する

      • 6.6.1　集計行の編集手順

      • 6.6.2　集計行編集モードのバーに表示される内容

      • 6.6.3　集計方法を選択する

      • 6.6.4　集計行のアイテムを編集する

      • 6.6.5　1件のときキー集計行を削除する

      • 6.6.6　集計行の位置を変更する

      • 6.6.7　集計ページを設定する

      • 6.6.8　集計行／総集計行を解除する

      • 6.6.9　集計行編集時の注意

    • 6.7　集計結果をアイテムとして挿入する

      • 6.7.1　集計アイテムを作成する

      • 6.7.2　集計アイテムのプロパティを設定する

  • 7.　帳票の表紙ページを作成する

    • 7.1　帳票ヘッダ領域を設定する

      • 7.1.1　帳票ヘッダ領域を設定する

      • 7.1.2　補足説明

    • 7.2　帳票ヘッダアイテムを設定する

      • 7.2.1　帳票ヘッダアイテムを作成する

      • 7.2.2　繰り返し領域のアイテムを操作する

    • 7.3　アイテムの配置を設定する

      • 7.3.1　アイテムの位置を，繰り返し領域の左上を基準にして表示する

      • 7.3.2　アイテムの位置を，貼付域の左上を基準にして表示する

    • 7.4　アイテムを固定位置に貼り付ける

      • 7.4.1　帳票ヘッダ領域内に，固定位置に表示させるアイテムを貼り付ける場合

      • 7.4.2　繰り返し領域内に，固定位置に表示させるアイテムを貼り付ける場合

    • 7.5　帳票ヘッダ集計の作成

    • 7.6　帳票ヘッダ領域の削除

  • 8.　貼り付けたデータを帳票上でカスタマイズする

    • 8.1　文字列や数値を置き換えて表示する

      • 8.1.1　置き換え表ファイルを作成する

      • 8.1.2　置き換え表管理情報ファイルを作成する

      • 8.1.3　置き換え表を登録する

      • 8.1.4　置き換えるアイテムを指定する

    • 8.2　アイテムの表示条件を設定する

      • 8.2.1　条件付きアイテムとは

      • 8.2.2　表示条件を設定できるアイテム

      • 8.2.3　表示条件の設定手順

      • 8.2.4　条件付きアイテムを使用した帳票の設定例

      • 8.2.5　帳票定義情報ファイルで表示条件を指定する場合の注意事項

    • 8.3　特定の行のデータを編集する

      • 8.3.1　特殊編集レベルとは

      • 8.3.2　特殊編集レベルの設定手順

  • 9.　複数様式の帳票の出力定義をツールで作成する

    • 9.1　複数様式定義作成ツールとは

      • 9.1.1　複数様式定義作成ツールで定義できる内容

      • 9.1.2　複数様式定義作成ツールを使用する前の準備

      • 9.1.3　複数様式定義作成ツールの操作の流れ

    • 9.2　作成できる複数様式の帳票のパターン

      • 9.2.1　単純繰り返し

      • 9.2.2　単純繰り返し（マッピングデータが一つ）

      • 9.2.3　キー付き単純繰り返し

      • 9.2.4　キー付き単純繰り返し（次紙様式付きA）

      • 9.2.5　キー付き単純繰り返し（次紙様式付きB）

      • 9.2.6　キー付き入れ子単純繰り返し

      • 9.2.7　カーボンコピー／複写帳票

      • 9.2.8　カーボンコピー／複写帳票（次紙様式付き）

      • 9.2.9　順次帳票

      • 9.2.10　順次帳票（次紙様式付きA）

      • 9.2.11　順次帳票（次紙様式付きB）

  • 10.　プレプリント用紙に合わせて帳票を作成する

    • 10.1　下敷きを作成する

      • 10.1.1　下敷きの準備

      • 10.1.2　下敷きを作成する

    • 10.2　下敷きを読み込む

      • 10.2.1　下敷きを読み込む

      • 10.2.2　サイズ情報を持つ画像ファイルを読み込む

      • 10.2.3　サイズ情報を持たない画像ファイルを読み込む

      • 10.2.4　補足説明

    • 10.3　下敷きの表示・非表示を設定する

  • 11.　Word/Excelで作成した帳票を変換する

    • 11.1　Word/Excel文書を帳票ファイルに変換するまでの流れ

    • 11.2　変換前の準備

      • 11.2.1　前提プログラム

      • 11.2.2　変換前の注意事項

    • 11.3　プリンタドライバを設定する

      • 11.3.1　通常使うプリンタを設定する

      • 11.3.2　EMFスプールを設定する

      • 11.3.3　注意事項

    • 11.4　帳票ファイルに変換する

      • 11.4.1　変換の手順

      • 11.4.2　帳票ファイル名の規則

      • 11.4.3　変換された帳票ファイルを確認する

    • 11.5　Word/Excel文書から引き継がれる情報

  • 12.　作成したアイテムを部品化して再利用する

    • 12.1　部品登録機能とは

      • 12.1.1　部品の使用手順

      • 12.1.2　登録できるアイテムの種類

    • 12.2　部品を登録する

      • 12.2.1　［編集］－［部品の登録］を選択して登録する

      • 12.2.2　部品パレットウィンドウにドラッグアンドドロップして登録する

      • 12.2.3　部品名を変更する

    • 12.3　部品をエクスポート，インポートする

      • 12.3.1　部品をエクスポートする

      • 12.3.2　部品をインポートする

      • 12.3.3　部品を識別する規則

    • 12.4　部品を帳票に貼り付ける

      • 12.4.1　部品を帳票に貼り付ける

      • 12.4.2　部品のプロパティを表示する

      • 12.4.3　部品の表示位置を指定する

      • 12.4.4　帳票ウィンドウ上で部品を移動する

    • 12.5　部品を削除する

    • 12.6　部品使用時の注意事項

      • 12.6.1　登録できる部品・アイテムの上限

      • 12.6.2　部品とフィールド定義の連動

      • 12.6.3　部品を使用するときの注意

  • 13.　アイテムのプロパティとオプションを設定する

    • 13.1　［アイテムのプロパティ］ダイアログの表示

    • 13.2　文字アイテムと文字データのプロパティを設定する

      • 13.2.1　文字アイテムの装飾

      • 13.2.2　任意書式の設定

    • 13.3　数値データのプロパティを設定する

      • 13.3.1　補足説明

    • 13.4　線アイテムのプロパティを設定する

    • 13.5　図形アイテムのプロパティを設定する

      • 13.5.1　n行間隔ごとに網を掛けたい場合

      • 13.5.2　網掛けの色を設定したい場合

      • 13.5.3　図形アイテムに影を付けたい場合

      • 13.5.4　角丸四角アイテムの角丸めをなくしたい場合

    • 13.6　画像アイテムのプロパティを設定する

      • 13.6.1　アイテム枠のサイズに合わせて表示したい場合

      • 13.6.2　画像ファイルを更新したが，帳票に貼り付けた画像ファイルに反映されない場合

    • 13.7　ページ番号アイテムのプロパティを設定する

      • 13.7.1　補足説明

    • 13.8　日付データのプロパティを設定する

      • 13.8.1　日付データの表示形式の設定

      • 13.8.2　元号年1年を元年表示する

    • 13.9　バーコードアイテムのプロパティを設定する

      • 13.9.1　データキャラクタのフォントの変更

    • 13.10　部品のプロパティを設定する

    • 13.11　帳票のオプションを設定する

      • 13.11.1　デフォルトに使用する文字の設定

      • 13.11.2　文字間隔と行間隔の設定

      • 13.11.3　デフォルトに使用する線の設定

      • 13.11.4　デフォルトに使用する網パターンの設定

      • 13.11.5　使用する単位のデフォルト設定

      • 13.11.6　画像の表示補正の設定

      • 13.11.7　デフォルトに使用するバーコードの設定

      • 13.11.8　フォントによるリサイズの設定

      • 13.11.9　バーコードのリサイズの設定

      • 13.11.10　編集中の画像表示の設定

      • 13.11.11　ファイルの保存場所のデフォルト設定

      • 13.11.12　文字幅計算方法の設定

  • 14.　帳票を保存する

    • 14.1　帳票を印刷プレビューで確認する

    • 14.2　帳票をレイアウト表示して確認する

    • 14.3　帳票を印刷する

      • 14.3.1　印刷する前の注意

      • 14.3.2　印刷時の注意

    • 14.4　帳票を保存する

      • 14.4.1　ファイルサーバからファイルを共用するときの注意

  • 15.　作成した帳票の情報をインポート，エクスポートする

    • 15.1　帳票定義情報とは

      • 15.1.1　帳票定義情報ファイルに使用するエンコーディング

      • 15.1.2　帳票定義情報ファイルの使用例

    • 15.2　帳票の情報を帳票定義情報ファイルに変換する

      • 15.2.1　帳票ファイルを帳票定義情報ファイルに変換する（ダイアログで実行する場合）

    • 15.3　帳票定義情報ファイルを確認する

      • 15.3.1　帳票定義情報ファイルの格納先と出力形式

      • 15.3.2　帳票定義情報ファイルをExcelで開く

    • 15.4　帳票定義情報ファイルの構成

      • 15.4.1　帳票全体定義情報ファイル

      • 15.4.2　ブレイク定義情報ファイル

      • 15.4.3　アイテム定義情報ファイル

      • 15.4.4　部品定義情報ファイル

      • 15.4.5　フィールド定義情報ファイル

      • 15.4.6　補足情報ファイル

    • 15.5　帳票定義情報ファイルを保存する

    • 15.6　帳票定義情報ファイルから帳票ファイルに変換する

      • 15.6.1　帳票定義情報ファイルを帳票ファイルに変換する

    • 15.7　eurspcsvコマンドを使ってインポート，エクスポートする

      • 15.7.1　eurspcsvコマンドの構文

      • 15.7.2　eurspcsvコマンドのオプション一覧

      • 15.7.3　eurspcsvコマンドのオプションの説明

      • 15.7.4　終了コード

  • 16.　帳票作成の注意事項

    • 16.1　操作についての注意

    • 16.2　帳票作成に関する注意

      • 16.2.1　フルパスの指定方法

      • 16.2.2　ディクショナリファイルを指定するときの注意

      • 16.2.3　SEWB+/REPOSITORYで定義した最上位結合項目からデータを入力して帳票を出力する場合の注意

      • 16.2.4　EUR Form帳票の編集でバックグラウンドを設定する場合の注意

      • 16.2.5　データ表示ウィンドウを使用する場合の注意

      • 16.2.6　多角形の生成操作中の注意

      • 16.2.7　線種・線幅に関する注意

      • 16.2.8　EUR DesignerまたはEUR Viewerで画像アイテムを配置した帳票を出力する場合の注意

      • 16.2.9　IVS出力する帳票ファイルを作成する場合の注意事項

      • 16.2.10　フォントに関する注意

  • 付録

    • 付録A　メニューとツールバー

      • 付録A.1　メニューとツールバーの一覧

      • 付録A.2　ツールバーとツールボックス

    • 付録B　キーボードインターフェース

      • 付録B.1　レポート編集ウィンドウのメニューに対応したショートカットキー

      • 付録B.2　レポート編集ウィンドウのページめくりに対応したショートカットキー

      • 付録B.3　データウィンドウでのショートカットキー

    • 付録C　帳票の互換性

      • 付録C.1　Windows版 EUR旧製品からの互換性

      • 付録C.2　UNIX版 EUR旧製品からの互換性

      • 付録C.3　古いバージョンのEURで使用するときの互換性

    • 付録D　このマニュアルの参考情報

      • 付録D.1　関連マニュアル

      • 付録D.2　EUR バージョン10での製品体系の変更

      • 付録D.3　EUR バージョン10でのマニュアル体系の変更

      • 付録D.4　このマニュアルでの表記

      • 付録D.5　このマニュアルで使用する略語

      • 付録D.6　KB（キロバイト）などの単位表記について

  • 索引

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 2 / 356