EUR システム構築ガイド

  • 目次

  • 索引

  • 前へ

  • 1 / 202

  • 次へ

EUR システム構築ガイド

3021-7-002-40

目次ダイジェスト

  • 前書き

  • 変更内容

  • はじめに

  • 第1編　帳票システムの構築

    • 1.　帳票システムを構築するには

  • 第2編　開発環境の構築

    • 2.　EUR Developerをインストールする

  • 第3編　業務プログラムの作成

    • 3.　サーバで動作する業務プログラムを作成する

    • 4.　クライアントで動作する業務プログラムを作成する

  • 第4編　帳票出力で使用するファイルの準備

    • 5.　帳票の出力内容を設定するファイルを準備する

    • 6.　帳票の出力環境を設定するファイルを準備する

  • 第5編　帳票出力環境の構築

    • 7.　帳票サーバを構築する

    • 8.　スプールサーバを帳票サーバとは別に構築する

    • 9.　アプリケーションサーバを帳票サーバとは別に構築する

    • 10.　クライアントを構築する

  • 第6編　帳票システムのアップグレードと移行

    • 11.　EURをアップグレードする

    • 12.　帳票システムを移行する

  • 付録

  • 索引

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 1 / 202

  • 次へ

  • 商品名称に関する表示

  • マニュアル発行元

All Rights Reserved. Copyright (C) 2014, 2017, Hitachi, Ltd.

All Rights Reserved. Copyright (C) 2014, 2017, Hitachi Solutions, Ltd.


前書き : EUR システム構築ガイド

  • 3 / 202

  • 次へ

  • 表紙

  • 前書き

前書き

■ 対象製品

●適用OS：Windows 7 x86，Windows 7 x64※1，Windows 8.1 x86※2，Windows 8.1 x64※1※2，Windows 10 x86※2，Windows 10 x64※1※2

  • P-2CD2-56A4 EUR Designer 10-40

  • P-2CD2-5DA4 EUR Developer※3 10-40

  • P-2CD2-53A4 EUR Viewer 10-40

●適用OS：Windows Server 2008，Windows Server 2012

  • P-29D2-59A4 EUR Server Standard※4 10-40

  • P-29D2-5EA4 EUR Server Enterprise※4 10-40

  • P-29D2-5CA4 EUR Server - Cipher option 10-30

●適用OS：HP-UX 11i V3(IPF)

  • P-1JD2-59A1 EUR Server Standard 10-10

  • P-1JD2-5EA1 EUR Server Enterprise 10-10

  • P-1JD2-5CA1 EUR Server - Cipher option 10-00

●適用OS：AIX V6.1，AIX V7.1，AIX V7.2

  • P-1MD2-59A1 EUR Server Standard 10-10

  • P-1MD2-5EA1 EUR Server Enterprise 10-10

  • P-1MD2-5CA1 EUR Server - Cipher option 10-00

●適用OS：Linux 6，Linux 7

  • P-82D2-59A1 EUR Server Standard 10-10

  • P-82D2-5EA1 EUR Server Enterprise 10-10

  • P-82D2-5CA1 EUR Server - Cipher option 10-00

注※1

    WOW64（Windows On Windows 64）環境だけで使用できます。

注※2

    Modern UIには対応していません。

注※3

    次に示す製品を同梱しています。

    ・P-2463-2354　　DABroker

注※4

    次に示す製品を同梱しています。

    ・P-2963-2354　　DABroker(64)

これらの製品は，ISO9001およびTickITの認証を受けた品質マネジメントシステムで開発されました。

■ 輸出時の注意

本製品を輸出される場合には、外国為替及び外国貿易法の規制並びに米国輸出管理規則など外国の輸出関連法規をご確認の上、必要な手続きをお取りください。

なお、不明な場合は、弊社担当営業にお問い合わせください。

■ 商標類

HITACHI，DABroker，DBPARTNER，EUR，Groupmax，HiRDB，JP1，SEWB，TPBroker，uCosminexusは，株式会社 日立製作所の商標または登録商標です。

ActiveXは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

IBM，AIXは，世界の多くの国で登録されたInternational Business Machines Corporationの商標です。

Internet Explorerは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

Itaniumは，アメリカ合衆国および / またはその他の国におけるIntel Corporationの商標です。

Linuxは，Linus Torvalds氏の日本およびその他の国における登録商標または商標です。

MicrosoftおよびMS-DOSは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

MicrosoftおよびSQL Serverは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

MicrosoftおよびVisual Basicは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

MicrosoftおよびVisual C++は，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

Microsoft .NET は，お客様，情報，システムおよびデバイスを繋ぐソフトウェアです。

Microsoft OfficeおよびExcelは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

Microsoft Office Wordは，米国Microsoft Corporation の商品名称です。

ODBCは，米国Microsoft Corporationが提唱するデータベースアクセス機構です。

OLEは，米国Microsoft Corporationが開発したソフトウェア名称です。

OracleとJavaは，Oracle Corporation 及びその子会社，関連会社の米国及びその他の国における登録商標です。

PostScriptは，米国でのAdobe Systems, Inc.の商標です。

Red Hatは，米国およびその他の国でRed Hat, Inc.の登録商標もしくは商標です。

RSAおよびBSAFEは，米国EMC コーポレーションの米国およびその他の国における商標または登録商標です。

UNIXは，The Open Groupの米国ならびに他の国における登録商標です。

Windowsは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

Windows Serverは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

本製品は，米国EMC コーポレーションのRSA BSAFE(R)ソフトウェアを搭載しています。

This product includes software developed by the Apache Software Foundation (http://www.apache.org/).

This product includes software developed by Ben Laurie for use in the Apache-SSL HTTP server project.

Portions of this software were developed at the National Center for Supercomputing Applications (NCSA) at the University of Illinois at Urbana-Champaign.

This product includes software developed by the University of California, Berkeley and its contributors.

This software contains code derived from the RSA Data Security Inc. MD5 Message-Digest Algorithm, including various modifications by Spyglass Inc., Carnegie Mellon University, and Bell Communications Research, Inc (Bellcore).

Regular expression support is provided by the PCRE library package, which is open source software, written by Philip Hazel, and copyright by the University of Cambridge, England. The original software is available from ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/

This product includes software developed by Ralf S. Engelschall <rse@engelschall.com> for use in the mod_ssl project (http://www.modssl.org/).

This product includes software developed by IAIK of Graz University of Technology.

This product includes software developed by Daisuke Okajima and Kohsuke Kawaguchi (http://relaxngcc.sf.net/).

This product includes software developed by the Java Apache Project for use in the Apache JServ servlet engine project (http://java.apache.org/).

This product includes software developed by Andy Clark.

その他記載の会社名，製品名は，それぞれの会社の商標もしくは登録商標です。

■ マイクロソフト製品のスクリーンショットの使用について

マイクロソフトの許可を得て使用しています。

■ マイクロソフト製品の表記について

このマニュアルでは，マイクロソフト製品の名称を次のように表記しています。

表記 |  |  | 製品名称
.NET |  |  | Microsoft(R) .NET
ActiveX |  |  | ActiveX(R)
Excel |  |  | Microsoft(R) Office Excel 2007 Microsoft(R) Office Excel 2010 Microsoft(R) Office Excel 2013
Internet Explorer |  |  | Windows(R) Internet Explorer(R)
SQL Server |  |  | Microsoft(R) SQL Server 2008 Microsoft(R) SQL Server 2008 R2 Microsoft(R) SQL Server 2012
VBScript |  |  | Microsoft(R) Visual Basic(R) Scripting Edition
Visual Basic |  |  | Microsoft(R) Visual Basic(R)
Visual C++ |  |  | Microsoft(R) Visual C++(R)
Windows | Windows 7 | Windows 7 x86 | Microsoft(R) Windows(R) 7 Professional(32ビット版) Microsoft(R) Windows(R) 7 Enterprise(32ビット版) Microsoft(R) Windows(R) 7 Ultimate(32ビット版)
 |  | Windows 7 x64 | Microsoft(R) Windows(R) 7 Professional(64ビット版) Microsoft(R) Windows(R) 7 Enterprise(64ビット版) Microsoft(R) Windows(R) 7 Ultimate(64ビット版)
 | Windows 8 | Windows 8 x86 | Windows(R) 8 Pro(32ビット版) Windows(R) 8 Enterprise(32ビット版)
 |  | Windows 8 x64 | Windows(R) 8 Pro(64ビット版) Windows(R) 8 Enterprise(64ビット版)
 | Windows 8.1 | Windows 8.1 x86 | Windows(R) 8.1 Pro(32ビット版) Windows(R) 8.1 Enterprise(32ビット版)
 |  | Windows 8.1 x64 | Windows(R) 8.1 Pro(64ビット版) Windows(R) 8.1 Enterprise(64ビット版)
 | Windows 10 | Windows 10 x86 | Windows(R) 10 Pro(32ビット版) Windows(R) 10 Enterprise(32ビット版)
 |  | Windows 10 x64 | Windows(R) 10 Pro(64ビット版) Windows(R) 10 Enterprise(64ビット版)
 | Windows Server 2008 |  | Microsoft(R) Windows Server(R) 2008 R2 Standard Microsoft(R) Windows Server(R) 2008 R2 Enterprise Microsoft(R) Windows Server(R) 2008 R2 Datacenter
 | Windows Server 2012 |  | Microsoft(R) Windows Server(R) 2012 Standard Microsoft(R) Windows Server(R) 2012 Datacenter Microsoft(R) Windows Server(R) 2012 R2 Standard Microsoft(R) Windows Server(R) 2012 R2 Datacenter
Word |  |  | Microsoft(R) Office Word 2007 Microsoft(R) Office Word 2010 Microsoft(R) Office Word 2013

■ 発行

2017年3月　3021-7-002-40

■ 著作権

All Rights Reserved. Copyright (C) 2014, 2017, Hitachi, Ltd.

All Rights Reserved. Copyright (C) 2014, 2017, Hitachi Solutions, Ltd.

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 3 / 202


変更内容 : EUR システム構築ガイド

  • 4 / 202

  • 表紙

  • 変更内容

変更内容

変更内容（3021-7-002-40）

EUR Designer　10-40

EUR Developer　10-40

EUR Viewer　10-40

EUR Server Standard　10-40

EUR Server Enterprise　10-40

追加・変更内容

変更個所

EUR Designer，EUR Developer，EUR Viewerの適用OSからWindows 8を除外しました。

－

EUR Server Standard，EUR Server Enterpriseの適用OSに次のOSを追加しました。

  • AIX V7.2

  • Linux 7

－

単一様式または複数様式での帳票出力時に，新規用紙の表側（奇数ページ）に出力するページを指定する機能を追加しました。

2.2，5.2，7.3.2(1)，付録A.1
（凡例）

－：該当なし

単なる誤字・脱字などはお断りなく訂正しました。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 4 / 202


はじめに : EUR システム構築ガイド

  • 5 / 202

  • 表紙

  • はじめに

はじめに

このマニュアルは，次のEUR製品を使用した帳票システムを構築する方法について説明したものです。

  • EUR Designer

  • EUR Developer

  • EUR Viewer

  • EUR Server Standard

  • EUR Server Enterprise

  • EUR Server - Cipher option

〈はじめにの構成〉

  • 対象読者

  • このマニュアルの文法で使用する記号

  • このマニュアルのGUIの説明で使用する記号

■ 対象読者

このマニュアルは，EURを使用した帳票システムの構築を担当する方を対象としています。なお，次の内容を理解されていることを前提としています。

  • 使用するOSに関する基本的な知識

  • 使用するプログラム言語に関する基本的な知識

  • ネットワークに関する基本的な知識

  • 文字コードに関する基本的な知識

  • プリンタに関する基本的な知識（帳票をプリンタに出力する場合）

ページの先頭へ

■ このマニュアルの文法で使用する記号

このマニュアルで使用する記号について，次に示します。

記　号

意　　味

｜

横に並べられた複数の項目に対する項目間の区切りを示し，「または」を意味します。

（例）A｜B

「A，またはBを指定する」ことを示します。

｛　｝

この記号で囲まれている複数の項目のうちから一つを選択することを示します。項目が横に並べられ，記号｜で区切られている場合は，そのうちの一つを選択します。

（例）｛A｜B｜C｝

「A，B，またはCのどれかを指定する」ことを示します。

〔　〕

この記号で囲まれている項目は省略してもよいことを示します。複数の項目が横に並べて記述されている場合には，すべてを省略するか，記号｛　｝と同じくどれか一つを選択します。

（例）〔A〕

「何も指定しない」か「Aと指定する」ことを示します。

（例）〔B｜C〕

「何も指定しない」か「B，またはCのどちらかを指定する」ことを示します。

…

記述が省略されていることを示します。この記号の直前に示された項目を繰り返し複数個指定できます。

（例）〔A〔,…〕〕

「Aのあとに，Aを複数個指定できる」ことを示します。

＿

括弧で囲まれた複数項目のうち1項目に対し使用され，括弧内のすべてを省略したときシステムが採る標準値を示します。

（例）〔A｜B｜C〕

「A，B，Cのどれも指定しなかった場合，システムはCが指定されたときと同じ処理をする」ことを示します。

ページの先頭へ

■ このマニュアルのGUIの説明で使用する記号

このマニュアルでは，次に示す記号を使用してGUIを説明しています。

記　号

意　　味

＜　＞

文字キーを表します。

＜　＞＋＜　＞

＋の前のキーを押したまま，後ろのキーを押すことを表します。

［　］

メニュー項目，ダイアログ名，ダイアログのボタンを表します。

［　］－［　］

メニュー項目を連続して選択することを表します。

（例）［ファイル］－［開く］

［ファイル］メニューから［開く］メニューを選択することを表します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 5 / 202


1. 帳票システムを構築するには : EUR システム構築ガイド

  • 6 / 202

  • 表紙

  • 1.　帳票システムを構築するには

1.　帳票システムを構築するには

この章では，帳票システムの構築の流れなど，構築作業の全体像について説明します。また，このマニュアルの説明で使用するシステム構成についても説明します。

〈この章の構成〉

  • 1.1　帳票システムの構築の流れ

  • 1.2　構築作業の前に決めておくこと

  • 1.3　このマニュアルの説明で使用するシステム構成

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 6 / 202


1.1 帳票システムの構築の流れ : EUR システム構築ガイド

  • 7 / 202

  • 表紙

  • 1.　帳票システムを構築するには

  • 1.1　帳票システムの構築の流れ

1.1　帳票システムの構築の流れ

帳票システムの構築は，次に示す三つのパターンがあります。

  • システムを新規作成する

    帳票システムを一から構築します。事業統合などでシステム全体を刷新する場合や，メインフレームシステムからオープンシステムへ移行する場合などが該当します。

    帳票システムを新規に作成する場合の構築作業の流れについては，「1.1.1　システムを新規作成する場合の流れ」を参照してください。

  • EURをアップグレードする

    帳票システムを構成する各マシンにインストールされているEURを，新しいバージョンに入れ替えます。業務でEURの新機能を使用する場合が該当します。

    帳票システムのEURをアップグレードする場合の構築作業の流れについては，「1.1.2　EURをアップグレードする場合の流れ」を参照してください。

  • システムを移行する

    帳票システムを構成するマシンを交換したり，統廃合したりします。マシンを増やして負荷分散を図る場合や，テスト環境から本番環境に移行する場合が該当します。

    帳票システムを移行する場合の構築作業の流れについては，「1.1.3　システムを移行する場合の流れ」を参照してください。

〈この節の構成〉

  • 1.1.1　システムを新規作成する場合の流れ

  • 1.1.2　EURをアップグレードする場合の流れ

  • 1.1.3　システムを移行する場合の流れ

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 7 / 202


1.1.1 システムを新規作成する場合の流れ : EUR システム構築ガイド

  • 8 / 202

  • 表紙

  • 1.　帳票システムを構築するには

  • 1.1　帳票システムの構築の流れ

  • 1.1.1　システムを新規作成する場合の流れ

1.1.1　システムを新規作成する場合の流れ

帳票システムを新規作成する場合の作業の流れを，次の図に示します。

図1‒1　帳票システムを新規作成する場合の作業の流れ

[図データ]

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 8 / 202


1.1.2 EURをアップグレードする場合の流れ : EUR システム構築ガイド

  • 9 / 202

  • 表紙

  • 1.　帳票システムを構築するには

  • 1.1　帳票システムの構築の流れ

  • 1.1.2　EURをアップグレードする場合の流れ

1.1.2　EURをアップグレードする場合の流れ

帳票システムのEURをアップグレードする場合の作業の流れを，次の図に示します。

図1‒2　帳票システムのEURをアップグレードする場合の作業の流れ

[図データ]

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 9 / 202


1.1.3 システムを移行する場合の流れ : EUR システム構築ガイド

  • 10 / 202

  • 表紙

  • 1.　帳票システムを構築するには

  • 1.1　帳票システムの構築の流れ

  • 1.1.3　システムを移行する場合の流れ

1.1.3　システムを移行する場合の流れ

帳票システムを移行する場合の作業の流れを，次の図に示します。

図1‒3　帳票システムを移行する場合の作業の流れ

[図データ]

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 10 / 202


1.2 構築作業の前に決めておくこと : EUR システム構築ガイド

  • 11 / 202

  • 表紙

  • 1.　帳票システムを構築するには

  • 1.2　構築作業の前に決めておくこと

1.2　構築作業の前に決めておくこと

構築作業を始める前に，帳票システムの仕様や作成する業務プログラムの仕様などを決めておく必要があります。

構築作業を始める前に検討が必要なことは，マニュアル「EUR システム設計ガイド」で説明しています。マニュアル「EUR システム設計ガイド」の記載内容と，このマニュアルで説明する内容との関係を，次の図に示します。

図1‒4　マニュアル「EUR システム設計ガイド」の記載内容との関係

[図データ]

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 11 / 202


1.3 このマニュアルの説明で使用するシステム構成 : EUR システム構築ガイド

  • 12 / 202

  • 表紙

  • 1.　帳票システムを構築するには

  • 1.3　このマニュアルの説明で使用するシステム構成

1.3　このマニュアルの説明で使用するシステム構成

このマニュアルは，説明で使用する帳票システムの構成要素を次の図に示すように定義します。

図1‒5　マニュアルの説明で使用する帳票システムの構成要素

[図データ]

開発環境

帳票の設計や設定ファイルの作成を行う環境です。

帳票出力環境

帳票を出力する環境です。構成要素を次に示します。

  • 帳票サーバ

  • スプールサーバ

  • アプリケーションサーバ

  • クライアント

実際のシステムを構成する場合には，帳票サーバ以外の要素は任意です。また，サーバの各要素を組み合わせたり，サーバの各要素を帳票サーバに集約したりすることもできます。

EUR Serverは，次の表に示すように二つのエディションを提供しています。帳票システムの構成や利用したいEURの機能に応じて，導入するEUR Serverを選択してください。

表1‒1　EUR Serverの種類と位置づけ

製品名

位置づけ

構築できるサーバの種類

EUR Server Enterprise

EUR Serverの帳票出力機能をすべて利用できます。

次のような場合に適しています。

  • 出力する帳票の枚数が多く，印刷データの生成に時間が掛かる場合

  • 帳票名で出力先を振り分けたい場合

  • 印刷処理の負荷分散を実施したい場合

  • 帳票の印刷履歴を管理したい場合

  • 帳票の出力処理が複数の業務システムにわたるなどで，印刷データの一時保管が必要な場合

  • オンライン処理で素早いレスポンスが求められる場合

  • 帳票サーバ

  • スプールサーバ

  • アプリケーションサーバ

EUR Server Standard

次のような場合に適しています。

  • クライアントPCに帳票を配信して出力する場合

  • PDF形式，Excel形式の帳票を出力する場合

  • サーバで生成した帳票を，クライアントPCのWebブラウザから出力，表示する場合

  • 帳票サーバ

  • アプリケーションサーバ

なお，次の場合は，EUR Server StandardまたはEUR Server Enterpriseに加えて，EUR Server - Cipher optionが帳票サーバに必要です。

  • PDF形式ファイルを暗号化出力する場合

  • 個人番号管理サービス連携機能で個人番号接続情報ファイルを暗号化する場合

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 12 / 202


2. EUR Developerをインストールする : EUR システム構築ガイド

  • 13 / 202

  • 表紙

  • 2.　EUR Developerをインストールする

2.　EUR Developerをインストールする

帳票システムの開発では，EUR Developerを使用します。

この章では，EUR Developerのインストール方法，インストール後に作成されるディレクトリ，およびインストール時の注意事項について説明します。

〈この章の構成〉

  • 2.1　インストール方法

  • 2.2　インストール後に作成されるディレクトリ

  • 2.3　インストール時の注意事項

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 13 / 202


2.1 インストール方法 : EUR システム構築ガイド

  • 14 / 202

  • 表紙

  • 2.　EUR Developerをインストールする

  • 2.1　インストール方法

2.1　インストール方法

ここでは，EUR Developerのインストール方法について説明します。

〈この節の構成〉

  • 2.1.1　インストールの前に

  • 2.1.2　インストール手順

  • 2.1.3　リモートインストール

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 14 / 202


2.1.1 インストールの前に : EUR システム構築ガイド

  • 15 / 202

  • 表紙

  • 2.　EUR Developerをインストールする

  • 2.1　インストール方法

  • 2.1.1　インストールの前に

2.1.1　インストールの前に

  • 管理者権限を持つユーザでログインしてください。

  • インストール時に必要なディスク空き容量を確認してください。

  • ほかのユーザアプリケーションを終了してください。

  • OSから実行許可についてのダイアログが表示されることがあります。このときには，実行を許可する応答をしてください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 15 / 202


2.1.2 インストール手順 : EUR システム構築ガイド

  • 16 / 202

  • 表紙

  • 2.　EUR Developerをインストールする

  • 2.1　インストール方法

  • 2.1.2　インストール手順

2.1.2　インストール手順

EUR製品の統合CD-ROMをPCにセットすると，自動的に日立総合インストーラが起動されます。日立総合インストーラのウィンドウでEUR Developerを選択して，［インストール実行］ボタンをクリックしてください。インストールが開始されます。

インストール画面は，Windowsインストール時の言語で表示されます。ロケールが英語，中国語，日本語のどれでもない場合は英語で表示されます。ただし，サポートしていないロケールで実行した場合，EURの動作は保証されません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 16 / 202


2.1.3 リモートインストール : EUR システム構築ガイド

  • 17 / 202

  • 表紙

  • 2.　EUR Developerをインストールする

  • 2.1　インストール方法

  • 2.1.3　リモートインストール

2.1.3　リモートインストール

EUR Developerは，JP1/NETM/DMおよびGroupmax Remote Installationのリモートインストールに対応しています。操作・運用方法については，JP1/NETM/DMまたはGroupmax Remote Installationのマニュアルを参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 17 / 202


2.2 インストール後に作成されるディレクトリ : EUR システム構築ガイド

  • 18 / 202

  • 表紙

  • 2.　EUR Developerをインストールする

  • 2.2　インストール後に作成されるディレクトリ

2.2　インストール後に作成されるディレクトリ

EUR Developerのインストール後に作成されるディレクトリを次の表に示します。

表2‒1 EUR Developerのインストール後に作成されるディレクトリ
ディレクトリまたはファイル名 | 内容
%EUR% | EURのルートディレクトリ
Document\ | ドキュメントディレクトリ
1033\ | 英語ドキュメント格納ディレクトリ
1041\ | 日本語ドキュメント格納ディレクトリ
Help\ | ヘルプ格納ディレクトリ
eursv.chm | EUR サーバ帳票出力ヘルプ（統合ヘルプ）
eursysd.chm | マニュアル「EUR システム設計ガイド」のヘルプ
eursysa.chm | マニュアル「EUR システム構築ガイド」のヘルプ
eursman.chm | マニュアル「EUR 帳票出力 機能解説 EUR Server編」のヘルプ
eursref.chm | マニュアル「EUR 帳票出力 リファレンス EUR Server編」のヘルプ
eurdb.chm | マニュアル「EUR データベース連携ガイド」のヘルプ
eurmes.chm | マニュアル「EUR メッセージ」のヘルプ
Designer\ | EUR Designerのルートディレクトリ
1033\ | 英語リソースディレクトリ
1041\ | 日本語リソースディレクトリ
Help\ | ヘルプ格納ディレクトリ
eurds.chm | EUR 帳票作成ヘルプ（統合ヘルプ）
eursysd.chm | マニュアル「EUR システム設計ガイド」のヘルプ
eursysa.chm | マニュアル「EUR システム構築ガイド」のヘルプ
eurrpt.chm | マニュアル「EUR 帳票作成 操作ガイド」のヘルプ
eurdlg.chm | マニュアル「EUR 帳票作成 画面リファレンス」のヘルプ
eurvoutp.chm | マニュアル「EUR 帳票出力 EUR Designer/EUR Viewer編」のヘルプ
euroutp.chm | マニュアル「EUR クライアント帳票出力」のヘルプ
eurdb.chm | マニュアル「EUR データベース連携ガイド」のヘルプ
eurmes.chm | マニュアル「EUR メッセージ」のヘルプ
2052\ | 中国語リソースディレクトリ
Include\ | ヘッダファイルディレクトリ
Lib\ | ライブラリディレクトリ
Program\ | 実行ファイル格納ディレクトリ
apgrpt.exe | EUR Designer実行ファイル
EurLgMnt.exe | ログメンテナンスツール
EurLgOpt.exe | ログメンテナンスオプション設定ツール
Eurtyl.exe | 給紙トレイ一覧ツール
eurcvtfm.exe | Word/Excel変換コマンド
eurusenv.exe | EUR ユーザ環境削除ツール
eurspcsv.exe | 帳票定義ファイルの入出力コマンド
EURMfdWz.exe | 複数様式定義作成ツール
Sample\ | EUR 帳票作成機能（EUR Form帳票）サンプル格納ディレクトリ
EUR Form\
TemplateFile\ | SEWB用テンプレートファイルディレクトリ
Tool\Program\ | 共通ツールディレクトリ
expedf32.exe | EURフォントファイル作成ツール
Log\ | ログディレクトリ
Print\ | EUR Print Serviceのルートディレクトリ
1033\ | 英語リソースディレクトリ
1041\ | 日本語リソースディレクトリ
2052\ | 中国語リソースディレクトリ
Program\ | 実行ファイル格納ディレクトリ
eurps.exe | EUR Print Service実行ファイル
eurecdif.exe | 接続情報パスワード暗号化ツール
Eurtyl.exe | 給紙トレイ一覧ツール
EURPSEX.DLL | ActiveXオブジェクト（V8互換機能）
Java\ | JavaBeans起動部品（V8互換機能）格納ディレクトリ
EURPSManager_5.jar | JavaBeans起動部品
EURPSManager.properties | プロパティファイル
Fonts\ | フォントディレクトリ
Server\ | EUR Server Serviceのルートディレクトリ
Program\ | 実行ファイル格納ディレクトリ
EURPM.exe | EUR Server Service実行ファイル
EURPMCTRL.exe | Server Service制御コマンド（eurpmctrlコマンド）
EURPMCTRLGUI.exe | ［EUR Server Service 起動管理］ダイアログ実行ファイル
EURPMUMM.exe | ［EUR Server Service 構成定義］ダイアログ実行ファイル
Conf\ | 構成定義ファイル格納ディレクトリ
DBInfo\ | 接続情報ファイル格納ディレクトリ
DocInfo\ | 文書情報設定ファイル格納ディレクトリ
Form\ | 帳票ファイル格納ディレクトリ
Multi\ | 複数様式情報定義ファイル格納ディレクトリ
PDF\ | PDF形式ファイル出力ディレクトリ
Preference\ | ビューアプレファレンス定義ファイル格納ディレクトリ
PrintDate\ | 印刷日時出力定義ファイル格納ディレクトリ
printnewpaper\ | 新規用紙出力定義ファイル格納ディレクトリ
PSEnv\ | EUR Print Serviceの環境設定ファイル格納ディレクトリ
ReplaceItem\ | 置き換え表管理情報ファイル格納ディレクトリ
reportid\ | 帳票出力定義ファイル格納ディレクトリ
ScriptCnt\ | Acrobat JavaScript定義ファイル格納ディレクトリ
Split\ | 分割定義ファイルまたは仕分け定義ファイル格納ディレクトリ
Temp\ | 一時ファイルディレクトリ
Adapter\ | EUR Server - Adapterのルートディレクトリ
Program\ | 実行ファイル格納ディレクトリ
EURPMC.exe | コマンド起動部品（eurpmcコマンド）
EURPMADP.ocx | ActiveX起動部品（32ビット版）
Program(x64)\ | 実行ファイル格納ディレクトリ
EURPMADP.ocx | ActiveX起動部品（64ビット版）
Java\ | Java起動部品格納ディレクトリ
EURPMAdapter.jar | Java起動部品（32ビット版）
EURPMADJ.dll
Java(x64)\ | Java起動部品格納ディレクトリ
EURPMAdapter.jar | Java起動部品（64ビット版）
EURPMADJ.dll
COBOL\ | COBOL起動部品格納ディレクトリ
EURPMADC.dll | COBOL起動部品（32ビット版）
EURPMADC.lib
COBOL(x64)\ | COBOL起動部品格納ディレクトリ
EURPMADC.dll | COBOL起動部品（64ビット版）
EURPMADC.lib
Eursmpr\ | BSP-RM連携コマンド（eursmprコマンド）のルートディレクトリ
program\ | 実行ファイル格納ディレクトリ
eursmpr.exe | BSP-RM連携コマンド（eursmprコマンド）
divdata\ | 制御情報付データファイル格納ディレクトリ
runparam\ | 起動パラメタファイル格納ディレクトリ
temp\ | 一時ファイルディレクトリ
FileMonitor\ | ファイル監視サービスのルートディレクトリ
program\ | 実行ファイル格納ディレクトリ
eurfm.exe | ファイル監視サービスプログラム
eurivk.exe | ジョブ実行プログラム
fmc\ | 監視管理ディレクトリ
monitor\ | 監視ディレクトリ
check\ | 照合ディレクトリ
data\ | 完了ディレクトリ
conf\ | 構成定義ファイル格納ディレクトリ
runparam\ | 起動パラメタファイル格納ディレクトリ
Spool\ | EUR Server - Spool Serviceのルートディレクトリ
Program\ | 実行ファイル格納ディレクトリ
EURPMLS.exe | EUR Server - Spool Service実行ファイル
EURPMULM.exe | ［EUR Spool Service 構成定義］ダイアログ実行ファイル
EURSSECD.exe | LDAP接続情報暗号化ツール
Conf\ | 構成定義ファイル格納ディレクトリ
ESF\ | スプールデータ格納ディレクトリ
POB\ | 私書箱ディレクトリ
Temp\ | 一時ファイルディレクトリ
Spool Adapter\ | EUR Server - Spool Service Adapterのルートディレクトリ
Program\ | 実行ファイル格納ディレクトリ
EURPMLSC.exe | SS-コマンド起動部品（eurpmlscコマンド）
EURPMLSADP.ocx | SS-ActiveX起動部品（32ビット版）
Program(x64)\ | 実行ファイル格納ディレクトリ
EURPMLSADP.ocx | SS-ActiveX起動部品（64ビット版）
Java\ | SS-Java起動部品格納ディレクトリ
EURPMLSAdapter.jar | SS-Java起動部品（32ビット版）
EURPMLSADJ.dll
Java(x64)\ | SS-Java起動部品格納ディレクトリ
EURPMLSAdapter.jar | SS-Java起動部品（64ビット版）
EURPMLSADJ.dll
euraps\ | EUR Application Service実行ファイル格納ディレクトリ（32ビット）
bin\
euraps.exe | EUR Application Service実行ファイル
eurpmrsgui.ear | 帳票管理GUIサービス
eurssdeli.ear | 配送サービス
Client\ | EUR Client Serviceのルートディレクトリ
Program\ | 実行ファイル格納ディレクトリ
EURPMCL.exe | EUR Client Service実行ファイル
EURPMUCM.exe | ［EUR Client 構成定義］ダイアログ実行ファイル
EURPMCEPFViewer.exe | eurpmcepfviewerコマンド
EURPMPrintAX9.ocx | EUR Web Plug-In実行ファイル（印刷用）
EURPMPreViewAX9.ocx | EUR Web Plug-In実行ファイル（プレビュー用）
Conf\ | 構成定義ファイル格納ディレクトリ
Sample\ | サンプル格納ディレクトリ
EURMfdWz\ | 複数様式定義作成ツールの作成サンプル（EPF形式ファイル）格納ディレクトリ
REPORTS\ | 帳票定義ファイル（FMS形式ファイル）および各種入力ファイルのサンプルファイル格納ディレクトリ
REPORTS2\
Server Service\ | EUR Server Serviceサンプルファイル格納ディレクトリ
Spool Service\ | EUR Server - Spool Serviceサンプルファイル格納ディレクトリ
XLSX\ | Excel形式ファイル出力用サンプルファイル（XLSX形式ファイルおよびFMS形式ファイル）格納ディレクトリ
mynumber\ | マイナンバー対応の法定調書のサンプルファイル格納ディレクトリ※
Component\ | 再配布パッケージ格納ディレクトリ
Client\ | EUR Client再配布用パッケージ格納ディレクトリ
EURPMPrintAX.cab | マシン単位インストール用EUR Web Plug-Inダウンロードパッケージ（印刷用）
EURPMPrintAX.inf | マシン単位インストール用EUR Web Plug-In情報ファイル（印刷用）
EURPMPreViewAX.cab | マシン単位インストール用EUR Web Plug-Inダウンロードパッケージ（プレビュー用）
EURPMPreViewAX.inf | マシン単位インストール用EUR Web Plug-In情報ファイル（プレビュー用）
User\ | ユーザ単位インストール用EUR Web Plug-Inダウンロードパッケージ格納ディレクトリ
EURPMPrintAX.cab | ユーザ単位インストール用EUR Web Plug-Inダウンロードパッケージ（印刷用）
EURPMPrintAX.inf | ユーザ単位インストール用EUR Web Plug-In情報ファイル（印刷用）
EURPMPreViewAX.cab | ユーザ単位インストール用EUR Web Plug-Inダウンロードパッケージ（プレビュー用）
EURPMPreViewAX.inf | ユーザ単位インストール用EUR Web Plug-In情報ファイル（プレビュー用）
DABroker\ | DABrokerのインストーラ格納ディレクトリ
DABroker.msi | DABrokerのインストーラ
ODBC\ | ODBC Driverのインストーラ格納ディレクトリ
Setup.exe | ODBC Driverのインストーラ
Hntrlib2 | EUR Application Service用トレースライブラリ
Common | EUR Application Service共通モジュール
（凡例）

%EUR%：EUR Developerのインストール先ディレクトリを示します。

注※

日本語のOSの場合だけ，インストール後にディレクトリが作成され，法定調書のサンプルファイルが格納されます。法定調書のサンプルファイルの提供範囲，利用方法，保証範囲については，「mynumber」下に格納されている「免責事項.txt」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 18 / 202


2.3 インストール時の注意事項 : EUR システム構築ガイド

  • 19 / 202

  • 表紙

  • 2.　EUR Developerをインストールする

  • 2.3　インストール時の注意事項

2.3　インストール時の注意事項

  • EUR Developerのインストール後に，再起動を求めるダイアログが表示されることがあります。このときには，再起動を許可する応答をしてください。

  • バージョン9以降では，インストールされるヘルプファイルのディレクトリ構成が変更されています。業務プログラムでヘルプファイルを使用している場合は，プログラムのパスなどをバージョン9以降のディレクトリ構成に合わせて作成してください。ディレクトリ構成については，「2.2　インストール後に作成されるディレクトリ」を参照してください。

  • 使用する機能や設定ファイルなどの更新で，管理者権限が必要になる場合があります。

    使用する機能で管理者権限が必要になる場合の詳細については，「7.5.1　［EUR Server Service 起動管理］ダイアログを使用した起動管理」，「7.5.2　Server Service制御コマンドを使用した起動管理」，および「7.6.1　Spool Service制御コマンドを使用した起動管理」を参照してください。

    設定ファイルなどの更新で管理者権限が必要になる場合の詳細については，「付録A　Windows環境の場合の注意」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 19 / 202


3. サーバで動作する業務プログラムを作成する : EUR システム構築ガイド

  • 20 / 202

  • 表紙

  • 3.　サーバで動作する業務プログラムを作成する

3.　サーバで動作する業務プログラムを作成する

この章では，サーバで動作する業務プログラムの作成について説明します。

〈この章の構成〉

  • 3.1　EURが提供するインタフェース

  • 3.2　実行ユーザとアクセス権

  • 3.3　VBScript，Visual Basic，Visual Basic .NET，ASP.NETなどを使用する

  • 3.4　JSP，Javaなどを使用する

  • 3.5　COBOLを使用する

  • 3.6　コマンドを使用する

  • 3.7　ファイル監視サービスを使用する

  • 3.8　サーバで動作する業務プログラムを作成する場合の注意

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 20 / 202


3.1 EURが提供するインタフェース : EUR システム構築ガイド

  • 21 / 202

  • 表紙

  • 3.　サーバで動作する業務プログラムを作成する

  • 3.1　EURが提供するインタフェース

3.1　EURが提供するインタフェース

業務プログラムの作成を支援するために，EURでは次の表に示すインタフェースを提供しています。

表3‒1 サーバで動作する業務プログラムの作成を支援するインタフェース
名称 | 対応するプログラミング言語 | 参照先
ActiveX起動部品 | VBScript，Visual Basic，Visual Basic .NET，ASP.NETなど | 3.3
SS-ActiveX起動部品
Java起動部品 | JSP，Javaなど | 3.4
SS-Java起動部品
COBOL起動部品※1 | COBOL | 3.5
コマンド起動部品（eurpmcコマンド）※2 | － | 3.6
SS-コマンド起動部品（eurpmlscコマンド）※2
BSP-RM連携コマンド（eursmprコマンド）※2
ファイル監視サービス※2 | － | 3.7
注※1

64ビットモードで動作するモジュールは，Windows環境向けだけ提供しています。UNIX／Linux環境向けには提供していません。

注※2

32ビットモードで動作します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 21 / 202


3.2 実行ユーザとアクセス権 : EUR システム構築ガイド

  • 22 / 202

  • 表紙

  • 3.　サーバで動作する業務プログラムを作成する

  • 3.2　実行ユーザとアクセス権

3.2　実行ユーザとアクセス権

サーバで動作するコンポーネントが使用するファイルの操作権限を実行ユーザに与えてください。入出力ファイルには適切なアクセス権を設定してください。入力ファイルには読み取りアクセス権，出力ファイルには書き込みアクセス権が必要です。

また，EUR Server - AdapterとEUR Server Serviceが同一マシンの場合は，EUR Server - AdapterとEUR Server Serviceの両方に，アクセス権を設定してください。

サーバで動作するコンポーネントの実行ユーザを次に示します。

表3‒2　サーバで動作するコンポーネントの実行ユーザ

コンポーネント

機能

実行ユーザ

EUR Server Service

EUR Server Service
Windows環境の場合

ローカルシステムアカウント(SYSTEM)※1

UNIX／Linux環境の場合

Server Service制御コマンド（eurpmctrlコマンド）の実行ユーザ

EUR Print Service

EUR Print Service

  • EUR Print Serviceが帳票サーバ上にある場合

    実行ユーザはEUR Server Serviceの実行ユーザです。

  • EUR Print Serviceがスプールサーバ上にある場合

    実行ユーザはEUR Server - Spool Serviceの実行ユーザです。

EUR Server - Adapter

EUR Server - Adapter

使用するアプリケーションプログラムの実行ユーザ※2

BSP-RM連携コマンド（eursmprコマンド）

ファイル監視サービス

ローカルシステムアカウント(SYSTEM)※1

EUR Server - Spool Service

EUR Server - Spool Service
Windows環境の場合

ローカルシステムアカウント(SYSTEM)※1

UNIX／Linux環境の場合

Spool Service制御コマンド（eurpmlsctrlコマンド）の実行ユーザ

EUR Server - Spool Service Adapter

EUR Server - Spool Service Adapter

使用するアプリケーションプログラムの実行ユーザ※2
注※1

デフォルトの実行ユーザです。

注※2

IISとASP Scriptでブラウザから出力する場合，匿名ログオンを使用したときの実行ユーザは匿名ユーザ（IUSER），認証ログインを使用したときの実行ユーザはログインユーザです。

なお，Server Service制御コマンド（eurpmctrlコマンド）およびSpool Service制御コマンド（eurpmlsctrlコマンド）はEURの起動管理に使用するコマンドです。詳細については，「7.5.2　Server Service制御コマンドを使用した起動管理」および「7.6.1　Spool Service制御コマンドを使用した起動管理」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 22 / 202


3.3 VBScript，Visual Basic，Visual Basic .NET，ASP.NETなどを使用する : EUR システム構築ガイド

  • 23 / 202

  • 表紙

  • 3.　サーバで動作する業務プログラムを作成する

  • 3.3　VBScript，Visual Basic，Visual Basic .NET，ASP.NETなどを使用する

3.3　VBScript，Visual Basic，Visual Basic .NET，ASP.NETなどを使用する

EURが提供するActiveX起動部品およびSS-ActiveX起動部品を使用することで，VBScript，Visual Basic，Visual Basic .NET，ASP.NETなどで開発する業務プログラムからEURを操作できます。

ここでは，各起動部品の使用方法と，実現できる機能の概要について説明します。

〈この節の構成〉

  • 3.3.1　EUR Server Serviceを呼び出すには

  • 3.3.2　EUR Server - Spool Serviceを呼び出すには

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 23 / 202


3.3.1 EUR Server Serviceを呼び出すには : EUR システム構築ガイド

  • 24 / 202

  • 表紙

  • 3.　サーバで動作する業務プログラムを作成する

  • 3.3　VBScript，Visual Basic，Visual Basic .NET，ASP.NETなどを使用する

  • 3.3.1　EUR Server Serviceを呼び出すには

3.3.1　EUR Server Serviceを呼び出すには

EUR Server Serviceを呼び出すには，ActiveX起動部品を使用します。

〈この項の構成〉

  • (1)　使用方法

  • (2)　実現できる機能

(1)　使用方法

ActiveX起動部品を使用するには，次の二つの方法があります。

  • ActiveX起動部品のプログラムID（EURPM.Exec）を指定したServer.CreateObjectメソッド（またはCreateObjectメソッド）を呼び出す

  • ActiveX起動部品が提供するクラス（EURPMADPLib.EURPMAdapterクラス）を呼び出す

指定例を次に示します。

●プログラムIDを指定したServer.CreateObjectメソッド（またはCreateObjectメソッド）を呼び出す例

  • VBScriptの場合

Dim eurpm As Object
Set eurpm=Server.CreateObject("EURPM.Exec")

  • Visual Basicの場合

Dim eurpm As Object
Set eurpm=CreateObject("EURPM.Exec")

eurpmには，Server.CreateObjectメソッドまたはCreateObjectメソッドの呼び出しによって作成されるオブジェクト名を指定します。

●EURPMADPLib.EURPMAdapterクラスを呼び出す例
Dim eurpm As EURPMADPLib.EURPMAdapter
Set eurpm=new EURPMADPLib.EURPMAdapter

eurpmには，EURPMADPLib.EURPMAdapterクラス型の任意のオブジェクト名を指定します。new操作でEURPMADPLib.EURPMAdapterクラスを生成してください。

■注意

EURPMADPLib.EURPMAdapterクラスを生成する前に，ユーザアプリケーションプロジェクトのコントロールまたはCOMの参照設定に，コントロール名「EURPMADP ActiveX コントロール モジュール」を追加してください。

ページの先頭へ

(2)　実現できる機能

ActiveX起動部品で実現できる機能の概要を次に示します。メソッドやプロパティの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

(a)　出力先を選んで出力する

帳票の出力には，PrintPMReportメソッドを使用します。PrintPMReportメソッド実行時に設定したPrintModeパラメタの値によって，次に示すように，帳票の出力先や出力方法を指定できます。

  • 帳票サーバのプリンタに出力する（PrintMode=4）

  • スプールサーバのプリンタに出力する（PrintMode=3）※

  • クライアントPCに出力する（PrintMode=1）

  • 複数のクライアントPCに帳票を配布して出力する（PrintMode=5）

  • スプールサーバに帳票の印刷データを蓄積する（PrintMode=2）

注※

スプールサーバがUNIX／Linux環境の場合は，スプールサーバのプリンタに出力できません。

(b)　ファイル形式を選んで出力する

帳票出力時のファイル形式を指定できます。使用するメソッドを次に示します。

  • EPF形式ファイルを出力する（OutputEPFReportメソッド）

  • PDF形式ファイルを出力する（OutputPDFReportメソッド）

  • Excel形式ファイルを出力する（OutputXLSXReportメソッド）

なお，EPF形式ファイルは出力後に統合することもできます。複数のEPF形式ファイルを統合するには，OutputMergeEPFReportメソッドを使用します。

(c)　帳票サーバの情報を取得する

帳票サーバおよび帳票サーバに登録されているスプールサーバの情報を一覧で取得できます。使用するメソッドを次に示します。

帳票サーバの情報を取得する

  • プリンタクラスの一覧を取得する（GetPMPrinterClassListメソッド）

  • プリンタの一覧を取得する（GetPMPrinterListメソッド）

  • プリンタのトレイの一覧を取得する（GetPMTrayListメソッド）

帳票サーバに登録されているスプールサーバの情報を取得する

  • スプールサーバの一覧を取得する（GetDestinationListメソッド）

  • スプールサーバのプリンタクラスの一覧を取得する（GetPrinterClassListメソッド）※

  • スプールサーバのプリンタの一覧を取得する（GetPrinterListメソッド）※

  • スプールサーバのプリンタのトレイの一覧を取得する（GetTrayListメソッド）※

注※

スプールサーバがUNIX／Linux環境の場合は，これらの情報を取得できません。

(d)　そのほかの情報を取得する

PrintPMReportメソッドでスプールサーバに蓄積した帳票のID（ジョブID）や，EUR Web Plug-In情報を取得できます。使用するメソッドを次に示します。

  • 蓄積した帳票のジョブIDを取得する（GetJobIDメソッド，GetJobIDListメソッド）

  • EUR Web Plug-InのクラスIDを取得する（GetPreviewAXClassIDメソッド，GetPrintAXClassIDメソッド）

  • EUR Web Plug-Inのバージョン情報を取得する（GetPreviewAXVersionメソッド，GetPrintAXVersionメソッド）

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 24 / 202


3.3.2 EUR Server - Spool Serviceを呼び出すには : EUR システム構築ガイド

  • 25 / 202

  • 表紙

  • 3.　サーバで動作する業務プログラムを作成する

  • 3.3　VBScript，Visual Basic，Visual Basic .NET，ASP.NETなどを使用する

  • 3.3.2　EUR Server - Spool Serviceを呼び出すには

3.3.2　EUR Server - Spool Serviceを呼び出すには

EUR Server - Spool Serviceを呼び出すには，SS-ActiveX起動部品を使用します。

〈この項の構成〉

  • (1)　使用方法

  • (2)　実現できる機能

(1)　使用方法

SS-ActiveX起動部品を使用するには，次の二つの方法があります。

  • SS-ActiveX起動部品のプログラムID（EURPMLS.Exec）を指定したServer.CreateObjectメソッド（またはCreateObjectメソッド）を呼び出す。

  • SS-ActiveX起動部品が提供するクラス（EURPMLSADPLib.EURPMLSAdapterクラス）を呼び出す。

指定例を次に示します。

●プログラムIDを指定したServer.CreateObjectメソッド（またはCreateObjectメソッド）を呼び出す例

  • VBScriptの場合

Dim eurpmls As Object
Set eurpmls=Server.CreateObject("EURPMLS.Exec")

  • Visual Basicの場合

Dim eurpmls As Object
Set eurpmls=CreateObject("EURPMLS.Exec")

eurpmlsには，Server.CreateObjectメソッドまたはCreateObjectメソッドの呼び出しによって作成されるオブジェクト名を指定します。

●EURPMLSADPLib.EURPMLSAdapterクラスを呼び出す例
Dim eurpmls As EURPMLSADPLib.EURPMLSAdapter
Set eurpmls=new EURPMLSADPLib.EURPMLSAdapter

eurpmlsには，EURPMLSADPLib.EURPMLSAdapterクラス型の任意のオブジェクト名を指定します。new操作でEURPMLSADPLib.EURPMLSAdapterクラスを生成してください。

■注意

EURPMLSADPLib.EURPMLSAdapterクラスを生成する前に，ユーザアプリケーションプロジェクトのコントロールまたはCOMの参照設定に，コントロール名「EURPMLSADP ActiveX コントロール モジュール」を追加してください。

ページの先頭へ

(2)　実現できる機能

SS-ActiveX起動部品で実現できる機能の概要を次に示します。メソッドやプロパティの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

(a)　スプールデータを操作する

スプールデータとは，帳票の印刷データ（EPF形式ファイル）をスプールサーバに蓄積するときのファイル形式です。次に示すメソッドを使用することで，スプールデータに対してさまざまな操作ができます。

  • スプールデータの一覧を取得する（GetSpoolFileOutlineメソッド）

  • スプールデータの属性値を取得する（GetSpoolFileAttributeメソッド）

  • スプールデータの属性値を変更する（SetSpoolFileAttributeメソッド）

  • スプールデータから印刷データを取得する（GetSpoolFileメソッド）

  • スプールデータから取得した印刷データを出力する（PrintSpoolReportメソッド）

  • スプールデータを削除する（DeleteSpoolFileメソッド）

(b)　スプールサーバの情報を取得する

スプールサーバに登録されているプリンタの情報を一覧で取得できます。使用するメソッドを次に示します。

  • スプールサーバのプリンタクラスの一覧を取得する（GetPrinterClassListメソッド）

  • スプールサーバのOS上のプリンタの一覧を取得する（GetPrinterListメソッド）

  • スプールサーバのOS上のプリンタのトレイの一覧を取得する（GetTrayListメソッド）

スプールサーバがUNIX／Linux環境の場合は，プリンタの情報を取得できません。

(c)　プロパティを初期化する

SS-ActiveX起動部品の各メソッドで指定したプロパティを初期化できます。プロパティの初期化には，Initializeメソッドを使用します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 25 / 202


3.4 JSP，Javaなどを使用する : EUR システム構築ガイド

  • 26 / 202

  • 表紙

  • 3.　サーバで動作する業務プログラムを作成する

  • 3.4　JSP，Javaなどを使用する

3.4　JSP，Javaなどを使用する

EURが提供するJava起動部品およびSS-Java起動部品を使用することで，JSP，Javaなどで開発する業務プログラムからEURを操作できます。

ここでは，各起動部品の使用方法と，実現できる機能の概要について説明します。

〈この節の構成〉

  • 3.4.1　EUR Server Serviceを呼び出すには

  • 3.4.2　EUR Server - Spool Serviceを呼び出すには

  • 3.4.3　業務プログラムから帳票管理GUIを呼び出すには

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 26 / 202


3.4.1 EUR Server Serviceを呼び出すには : EUR システム構築ガイド

  • 27 / 202

  • 表紙

  • 3.　サーバで動作する業務プログラムを作成する

  • 3.4　JSP，Javaなどを使用する

  • 3.4.1　EUR Server Serviceを呼び出すには

3.4.1　EUR Server Serviceを呼び出すには

EUR Server Serviceを呼び出すには，Java起動部品を使用します。

〈この項の構成〉

  • (1)　使用方法

  • (2)　実現できる機能

(1)　使用方法

Java起動部品が提供するJP.co.Hitachi.soft.EURPMパッケージをインポートすることで利用できます。

なお，JP.co.Hitachi.soft.EURPMパッケージは，次に示すクラスを提供します。

  • EUR Server Serviceの制御を行うクラス

    EURPMAdapterForJava：EUR Server Serviceを制御するクラス

  • 例外の制御を行うクラス

    EURPMException：EUR Server Serviceの制御時に発生するエラー（例外）を管理するクラス

ページの先頭へ

(2)　実現できる機能

Java起動部品で実現できる機能の概要を次に示します。メソッドの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

(a)　出力先を選んで出力する

帳票の出力には，printReportメソッドを使用します。printReportメソッド実行時に設定したsetPrintModeメソッドの値によって，次に示すように，帳票の出力先や出力方法を指定できます。

  • 帳票サーバのプリンタに出力する（setPrintMode=4）

  • スプールサーバのプリンタに出力する（setPrintMode=3）※

  • クライアントPCに出力する（setPrintMode=1）

  • 複数のクライアントPCに帳票を配布して出力する（setPrintMode=5）

  • スプールサーバに帳票の印刷データを蓄積する（setPrintMode=2）

注※

スプールサーバがUNIX／Linux環境の場合は，スプールサーバのプリンタに出力できません。

(b)　ファイル形式を選んで出力する

帳票出力時のファイル形式を指定できます。使用するメソッドを次に示します。

ファイルに出力する場合

  • EPF形式ファイルを出力する（outputEPFReportメソッド）

  • PDF形式ファイルを出力する（outputPDFReportメソッド）

  • Excel形式ファイルを出力する（outputXLSXReportメソッド）

メモリに出力する場合

  • EPF形式データを出力する（getEPFReportメソッド）

  • PDF形式データを出力する（getPDFReportメソッド）

  • Excel形式データを出力する（getXLSXReportメソッド）

なお，EPF形式のファイルやデータは出力後に統合することもできます。複数のEPF形式ファイルを統合したEPF形式ファイルを出力するには，outputMergeEPFReportメソッドを使用します。また，複数のEPF形式ファイルを統合したEPF形式データを出力するには，getMergeEPFReportメソッドを使用します。

(c)　帳票サーバの情報を取得する

帳票サーバおよび帳票サーバに登録されているスプールサーバの情報を一覧で取得できます。使用するメソッドを次に示します。

帳票サーバの情報を取得する

  • プリンタクラスの一覧を取得する（getPMPrinterClassListメソッド）

  • プリンタの一覧を取得する（getPMPrinterListメソッド）

  • プリンタのトレイの一覧を取得する（getPMTrayListメソッド）

帳票サーバに登録されているスプールサーバの情報を取得する

  • スプールサーバの一覧を取得する（getDestinationListメソッド）

  • スプールサーバのプリンタクラスの一覧を取得する（getPrinterClassListメソッド）※

  • スプールサーバのプリンタの一覧を取得する（getPrinterListメソッド）※

  • スプールサーバのプリンタのトレイの一覧を取得する（getTrayListメソッド）※

注※

スプールサーバがUNIX／Linux環境の場合は，これらの情報を取得できません。

(d)　エラー情報を取得する

帳票出力時に発生するエラー（例外）情報を取得できます。使用するメソッドを次に示します。

  • エラーコードを取得する（getErrorCodeメソッド）

  • エラーレベルを取得する（getErrorLevelメソッド）

  • エラーメッセージのメッセージIDを取得する（getKeyメソッド）

  • エラーメッセージの文字列を取得する（getMessageメソッド）

  • エラー種別が警告の場合に，印刷データを取得する（getOutputDataメソッド）

(e)　そのほかの情報を取得する

printReportメソッドでスプールサーバに蓄積した帳票のID（ジョブID）や，EUR Web Plug-Inのバージョン情報などを取得できます。使用するメソッドを次に示します。

  • 蓄積した帳票のジョブIDを取得する（getJobIDメソッド，getJobIDListメソッド）

  • EUR Web Plug-InのクラスIDを取得する（getPrintAXClassIDメソッド，getPreviewAXClassIDメソッド）

  • EUR Web Plug-Inのバージョン情報を取得する（getPrintAXVersionメソッド，getPreviewAXVersionメソッド）

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 27 / 202


3.4.2 EUR Server - Spool Serviceを呼び出すには : EUR システム構築ガイド

  • 28 / 202

  • 表紙

  • 3.　サーバで動作する業務プログラムを作成する

  • 3.4　JSP，Javaなどを使用する

  • 3.4.2　EUR Server - Spool Serviceを呼び出すには

3.4.2　EUR Server - Spool Serviceを呼び出すには

EUR Server - Spool Serviceを呼び出すには，SS-Java起動部品を使用します。

〈この項の構成〉

  • (1)　使用方法

  • (2)　実現できる機能

(1)　使用方法

SS-Java起動部品が提供するJP.co.Hitachi.soft.EURPMLSパッケージをインポートすることで利用できます。

なお，JP.co.Hitachi.soft.EURPMLSパッケージは，次に示すクラスを提供します。

  • EUR Server - Spool Serviceの制御を行うクラス

    EURPMLSAdapterForJava：EUR Server - Spool Serviceを制御するクラス

  • 例外の制御を行うクラス

    EURPMLSException：EUR Server - Spool Serviceの制御時に発生するエラー（例外）を管理するクラス

ページの先頭へ

(2)　実現できる機能

SS-Java起動部品で実現できる機能の概要を次に示します。メソッドの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

(a)　スプールデータを操作する

スプールデータとは，帳票の印刷データ（EPF形式ファイル）をスプールサーバに蓄積するときのファイル形式です。次に示すメソッドを使用することで，スプールデータに対してさまざまな操作ができます。

  • スプールデータの一覧を取得する（getSpoolFileOutlineメソッド）

  • スプールデータの属性値を取得する（getSpoolFileAttributeメソッド）

  • スプールデータの属性値を変更する（setSpoolFileAttributeメソッド）

  • スプールデータから印刷データをファイル取得する（getSpoolFileメソッド）

  • スプールデータから印刷データをメモリ取得する（memgetSpoolFileメソッド）

  • スプールデータから取得した印刷データを出力する（printSpoolReportメソッド）

  • スプールデータを削除する（deleteSpoolFileメソッド）

(b)　スプールサーバの情報を取得する

スプールサーバに登録されているプリンタの情報を一覧で取得できます。使用するメソッドを次に示します。

  • スプールサーバのプリンタクラスの一覧を取得する（getPrinterClassListメソッド）

  • スプールサーバのOS上のプリンタの一覧を取得する（getPrinterListメソッド）

  • スプールサーバのOS上のプリンタのトレイの一覧を取得する（getTrayListメソッド）

スプールサーバがUNIX／Linux環境の場合は，プリンタの情報を取得できません。

(c)　プロパティを初期化する

SS-Java起動部品の各メソッドで指定したプロパティを初期化できます。プロパティの初期化には，initializeメソッドを使用します。

(d)　エラー情報を取得する

スプールデータの操作時に発生するエラー（例外）情報を取得できます。使用するメソッドを次に示します。

  • エラーコードを取得する（getErrorCodeメソッド）

  • エラーレベルを取得する（getErrorLevelメソッド）

  • エラーメッセージのメッセージIDを取得する（getKeyメソッド）

  • エラーメッセージの文字列を取得する（getMessageメソッド）

  • エラー種別が警告の場合に，印刷データを取得する（getOutputDataメソッド）

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 28 / 202


3.4.3 業務プログラムから帳票管理GUIを呼び出すには : EUR システム構築ガイド

  • 29 / 202

  • 表紙

  • 3.　サーバで動作する業務プログラムを作成する

  • 3.4　JSP，Javaなどを使用する

  • 3.4.3　業務プログラムから帳票管理GUIを呼び出すには

3.4.3　業務プログラムから帳票管理GUIを呼び出すには

ユーザの認証情報（ユーザ名と確認キー）を業務プログラムと帳票管理GUIとで連携させることで，［ユーザの設定］画面の表示を省略できます。これにより，帳票管理GUIを利用するたびに，ユーザ名および確認キーを入力する手間を省けます。

ユーザの認証情報の連携には，ブラウザのCookieを使用します。システムへのログイン時に入力した，ユーザIDやパスワードなどの認証情報を，ブラウザのCookieに保存しておきます。帳票管理GUIの起動時に，Cookieに保存された認証情報を読み込み，ユーザとして設定します。これにより，ユーザ名および確認キーを入力することなく，帳票管理GUIを利用できます。

〈この項の構成〉

  • (1)　準備しておくこと

  • (2)　コーディング例

(1)　準備しておくこと

次のどちらかの方法で，システムへのログイン時に入力するユーザの認証情報をCookieのNAMEパラメタに設定する仕組みを準備します。

  • シングルサインオン製品など，ユーザの認証情報を管理できる製品を導入する。

  • JavaサーブレットやJavaScriptなどを使用して，システムへのログインフォームを作成し，ユーザの認証情報を事前に取得する。

ユーザの認証情報を設定するCookieのNAMEパラメタを次の表に示します。

表3‒3 ユーザの認証情報を設定するCookieのNAMEパラメタ
項番 | パラメタ名 | データ型 | 説明
1 | EURPM_UserName | String | ユーザ名を80バイト以内で指定します。制御コード（0x00～0x1F，0x7F～0x9F），「"」，「#」，「&」，「+」，「\」，および「,」は指定できません。 80バイトを超えて指定した場合は，デフォルトユーザとして動作します。
2 | EURPM_CheckString | String | ユーザ名に対応する確認キーを，80バイト以内で指定します。制御コード（0x00～0x1F，0x7F～0x9F），「"」，「#」，「&」，「+」，「\」，および「,」は指定できません。 EURPM_CheckStringパラメタは，EURPM_UserNameパラメタが指定されている場合だけ有効になります。 80バイトを超えて指定した場合は，デフォルトユーザとして動作します。
3 | EURPM_DefaultUserFlg | String | デフォルトユーザを設定する場合に，「YES」と指定します。 EURPM_DefaultUserFlgパラメタは，EURPM_UserNameパラメタが指定されていないときだけ有効になります。 「YES」以外の値を指定した場合，または値を指定しなかった場合は，［ユーザの設定］画面が表示されます。

なお，CookieのNAMEパラメタに値を設定するときは，URLエンコードを実施してください。URLエンコードを実施しないと，ユーザ名および確認キーを正しく設定できません。

Javaサーブレットを使用するとき

URLEncode.encode()

JavaScriptを使用するとき

encodeURIComponent()

ページの先頭へ

(2)　コーディング例

ユーザ名と確認キーをCookieに設定するコーディング例を次に示します。

(a)　Javaサーブレットの場合

ログインフォームから送信されたユーザ名（UserName）と確認キー（CheckString）を取得し，Cookieとして保存します。

public void doGet(HttpServletRequest req, HttpServletResponse res)
  throws IOException, ServletException{
  res.setContentType("text/html; charset=UTF-8"); // エンコード方式
  req.setCharacterEncoding("UTF-8");              // エンコード方式
  // ユーザ名を取得する
  String strUserName = req.getParameter("UserName");
  // 確認キーを取得する
  String strPassword = req.getParameter("CheckString");

  // Cookieに保存する値をURLエンコードする
  String strEncUser = URLEncoder.encode(strUserName , "UTF-8");
  String strEncPass = URLEncoder.encode(strPassword , "UTF-8");

  // ユーザ名のCookieのNAMEパラメタを作成する
  Cookie ckEURPMUser = new Cookie("EURPM_UserName " , strEncUser);
  // ユーザ名のCookieを保存する
  res.addCookie(ckEURPMUser);

  // 確認キーのCookieのNAMEパラメタを作成する
  Cookie ckEURPMCheck = new Cookie("EURPM_CheckString " , strEncPass);
  // 確認キーのCookieを保存する
  res.addCookie(ckEURPMCheck);
  }
}

(b)　JavaScriptの場合

［Cookie書き込み］ボタンをクリックすると，［ユーザ名］テキストボックスおよび［確認キー］テキストボックスに入力した値がCookieに書き込まれます。

<HTML>
<HEAD>
<TITLE>Cookieの設定例</TITLE>
</HEAD>
<BODY><SCRIPT language="JavaScript">
<!--
// --==*==-- --==*==-- --==*==-- --==*==-- --==*==--
// Cookieへの書き込み
// 　　引数：kword=キーワード　　kdata=データ
// --==*==-- --==*==-- --==*==-- --==*==-- --==*==--
function CookieWrite(kword, kdata)
{
  // Cookieに保存する値をURLエンコードして保存する
  document.cookie = kword + "=" + encodeURIComponent (kdata);
}
//-->
</SCRIPT>
<P>Cookieの設定例</P>
<FORM name="cookie01">キーワード<BR>
 ユーザ名 = <INPUT size="20" type="text" name="dat">
<BR>
 確認キー = <INPUT size="20" type="text" name="dat">
<BR>
 <INPUT type="button" value="Cookie書き込み"
 onclick='CookieWrite("EURPM_UserName",dat[0].value,1);'
         'CookieWrite("EURPM_CheckString",dat[1].value,1);'>
<BR>
</FORM>
</BODY>
</HTML>

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 29 / 202


3.5 COBOLを使用する : EUR システム構築ガイド

  • 30 / 202

  • 表紙

  • 3.　サーバで動作する業務プログラムを作成する

  • 3.5　COBOLを使用する

3.5　COBOLを使用する

EURが提供するCOBOL起動部品を使用することで，COBOLで開発する業務プログラムからEURを操作できます。

ここでは，COBOL起動部品の使用方法と，実現できる機能の概要について説明します。

〈この節の構成〉

  • 3.5.1　使用方法

  • 3.5.2　実現できる機能

  • 3.5.3　注意事項

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 30 / 202


3.5.1 使用方法 : EUR システム構築ガイド

  • 31 / 202

  • 表紙

  • 3.　サーバで動作する業務プログラムを作成する

  • 3.5　COBOLを使用する

  • 3.5.1　使用方法

3.5.1　使用方法

COBOL起動部品が提供する関数を呼び出して使用します。

COBOL起動部品のファイルを格納するディレクトリやCOBOL起動部品の設定については，マニュアル「COBOL2002 ユーザーズガイド」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 31 / 202


3.5.2 実現できる機能 : EUR システム構築ガイド

  • 32 / 202

  • 表紙

  • 3.　サーバで動作する業務プログラムを作成する

  • 3.5　COBOLを使用する

  • 3.5.2　実現できる機能

3.5.2　実現できる機能

COBOL起動部品で実現できる機能の概要を次に示します。関数の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

〈この項の構成〉

  • (1)　出力先を選んで出力する

  • (2)　ファイル形式を選んで出力する

  • (3)　帳票サーバの情報を取得する

(1)　出力先を選んで出力する

帳票の出力には，PrintReport関数またはPrintReport2関数を使用します。PrintReport関数またはPrintReport2関数に設定したPRINTMODEパラメタの値によって，次に示すように，帳票の出力先や出力方法を指定できます。

  • 帳票サーバのプリンタに出力する（PRINTMODE=4）

  • スプールサーバのプリンタに出力する（PRINTMODE=3）※

  • クライアントPCに出力する（PRINTMODE=1）

  • 複数のクライアントPCに帳票を配布して出力する（PRINTMODE=5）

  • スプールサーバに帳票の印刷データを蓄積する（PRINTMODE=2）

注※

スプールサーバがUNIX／Linux環境の場合は，スプールサーバのプリンタに出力できません。

ページの先頭へ

(2)　ファイル形式を選んで出力する

帳票出力時のファイル形式を指定できます。使用する関数を次に示します。

  • EPF形式ファイルを出力する（OutputEPFReport関数）

  • PDF形式ファイルを出力する（OutputPDFReport関数）

  • Excel形式ファイルを出力する（OutputXLSXReport関数）

なお，EPF形式ファイルは出力後に統合することもできます。複数のEPF形式ファイルを統合するには，OutputMergeEPFReport関数を使用します。

ページの先頭へ

(3)　帳票サーバの情報を取得する

帳票サーバおよび帳票サーバに登録されているスプールサーバの情報を一覧で取得できます。使用する関数を次に示します。

帳票サーバの情報を取得する

  • プリンタクラスの一覧を取得する（GetPMPrinterClassList関数）

  • プリンタの一覧を取得する（GetPMPrinterList関数）

  • プリンタのトレイの一覧を取得する（GetPMTrayList関数）

帳票サーバに登録されているスプールサーバの情報を取得する

  • スプールサーバの一覧を取得する（GetDestinationList関数，GetDestinationList2関数）

  • スプールサーバのプリンタクラスの一覧を取得する（GetPrinterClassList関数，GetPrinterClassList2関数）※

  • スプールサーバのプリンタの一覧を取得する（GetPrinterList関数）※

  • スプールサーバのプリンタのトレイの一覧を取得する（GetTrayList関数）※

注※

スプールサーバがUNIX／Linux環境の場合は，これらの情報を取得できません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 32 / 202


3.5.3 注意事項 : EUR システム構築ガイド

  • 33 / 202

  • 表紙

  • 3.　サーバで動作する業務プログラムを作成する

  • 3.5　COBOLを使用する

  • 3.5.3　注意事項

3.5.3　注意事項

COBOL起動部品のパラメタの文字列項目（PIC X項目）には，「クラス1　」や「トレイ1 」のように，文字列の後ろに空白を付けた値を指定できません。

COBOL起動部品のパラメタの文字列項目は固定長のため，指定したい文字列が項目長に満たない場合は，項目長を満たすまで文字列の後ろに空白を入れます。指定した文字列を判別するときは，文字列の後ろにある空白をすべて削除します。そのため，文字列の後ろに空白を付けた値を指定しても，指定値として扱われるのは文字列の後ろの空白を除いた値になります。

例を次に示します。

例1　PRINTERCLASSNAME（PrintReport関数）の場合
MOVE "クラス1　" TO PRINTERCLASSNAME

「クラス1　」と指定しても，「クラス1」が指定値として扱われます。

例2　SERVERTRAYNAME（PrintReport関数）の場合
MOVE "トレイ1 " TO SERVERTRAYNAME

「トレイ1 」と指定しても，「トレイ1」が指定値として扱われます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 33 / 202


3.6 コマンドを使用する : EUR システム構築ガイド

  • 34 / 202

  • 表紙

  • 3.　サーバで動作する業務プログラムを作成する

  • 3.6　コマンドを使用する

3.6　コマンドを使用する

EURが提供するコマンド起動部品（eurpmcコマンド）やSS-コマンド起動部品（eurpmlscコマンド）を使用することで，業務プログラムやJP1/AJS3などのジョブ管理製品からEURを操作できます。

また，BSP-RMと連携する場合は，EURが提供するBSP-RM連携コマンド（eursmprコマンド）を使用することで，BSP-RMが管理するデータファイルからEURサーバ環境での帳票の印刷やファイル出力ができます。

ここでは，各コマンドの使用方法と，実現できる機能の概要について説明します。なお，オプション名のセパレータは，「/」で示しています。UNIX／Linux環境の場合は，「/」を「-」に置き換えてお読みください。

〈この節の構成〉

  • 3.6.1　EUR Server Serviceを呼び出すには

  • 3.6.2　EUR Server - Spool Serviceを呼び出すには

  • 3.6.3　BSP-RMと連携するには

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 34 / 202


3.6.1 EUR Server Serviceを呼び出すには : EUR システム構築ガイド

  • 35 / 202

  • 表紙

  • 3.　サーバで動作する業務プログラムを作成する

  • 3.6　コマンドを使用する

  • 3.6.1　EUR Server Serviceを呼び出すには

3.6.1　EUR Server Serviceを呼び出すには

EUR Server Serviceを呼び出すには，コマンド起動部品（eurpmcコマンド）を使用します。

〈この項の構成〉

  • (1)　使用方法

  • (2)　実現できる機能

  • (3)　注意事項

(1)　使用方法

EUR Server - Adapterがインストールされているマシンで，eurpmcコマンドのファイル名を指定して実行します。

コマンドの構文は，Windows環境およびUNIX／Linux環境で共通です。ただし，UNIX／Linux環境で実行する場合は，eurpmcコマンドを「eurpmc」と指定してください。「.exe」は指定できません。また，コマンドの構文に指定できる文字列の長さは，約30KBまでです。

ページの先頭へ

(2)　実現できる機能

eurpmcコマンドで実現できる機能の概要を次に示します。オプションの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

(a)　出力先を選んで出力する

帳票の出力には，/mオプションにprintを指定して実行します。コマンド実行時に指定した/pmオプションの値によって，次に示すように，帳票の出力先や出力方法を指定できます。

  • 帳票サーバのプリンタに出力する（/pmオプションにpmを指定）

  • スプールサーバのプリンタに出力する（/pmオプションにsvを指定）※

  • クライアントPCに出力する（/pmオプションにclを指定）

  • 複数のクライアントPCに帳票を配布して出力する（/pmオプションにcldsを指定）

  • スプールサーバに帳票の印刷データを蓄積する（/pmオプションにsplを指定）

注※

スプールサーバがUNIX／Linux環境の場合は，スプールサーバのプリンタに出力できません。

(b)　ファイル形式を選んで出力する

帳票出力時のファイル形式を指定できます。コマンド実行時に/mオプションに指定する値を次に示します。

  • EPF形式ファイルを出力する（/mオプションにepfを指定）

  • PDF形式ファイルを出力する（/mオプションにpdfを指定）

  • Excel形式ファイルを出力する（/mオプションにxlsxを指定）

なお，EPF形式ファイルは出力後に統合することもできます。複数のEPF形式ファイルを統合するには，/mオプションにmergeを指定して実行します。

(c)　帳票サーバの情報を取得する

帳票サーバおよび帳票サーバに登録されているスプールサーバの情報を一覧で取得できます。コマンド実行時に/mオプションに指定する値を次に示します。

帳票サーバの情報を取得する

  • プリンタクラスの一覧を取得する（/mオプションにgetpmprclassを指定）

  • プリンタの一覧を取得する（/mオプションにgetpmprを指定）

  • プリンタのトレイの一覧を取得する（/mオプションにpmtrayを指定）

帳票サーバに登録されているスプールサーバの情報を取得する

  • スプールサーバの一覧を取得する（/mオプションにgetdestを指定）

  • スプールサーバのプリンタクラスの一覧を取得する（/mオプションにgetprclassを指定）※

  • スプールサーバのプリンタの一覧を取得する（/mオプションにgetprを指定）※

  • スプールサーバのプリンタのトレイの一覧を取得する（/mオプションにgettrayを指定）※

注※

スプールサーバがUNIX／Linux環境の場合は，これらの情報を取得できません。

ページの先頭へ

(3)　注意事項

eurpmcコマンドを使用する場合の注意事項を次に示します。

  • オプション，オプションの指定値，およびオプションに指定する文字列は，大文字と小文字を区別します。例えば，/mオプションを「/M」と指定したり，/mオプションの指定値を「/m PRINT」と指定したりすると，エラーになります。

  • 一つのコマンド構文に同じオプションが複数指定されている場合は，コマンド構文の後方に指定されたオプションが有効となります。

  • /mオプションで指定した出力，および情報取得の機能（メソッド）に無効なオプションを指定したときは，無視して実行されます。

  • 数値を指定する場合は，半角数値だけで指定してください。半角数値以外の文字（コンマ「,」など）を指定すると，エラーになります。

    なお，指定可能範囲内の値であれば，前0を含む値を指定してもエラーになりません。ただし，指定可能な桁数は9桁までです。10桁以上の値（"0000000000"など）を指定した場合は，数値の大きさにかかわらず，KEEY904-Eエラーになります。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 35 / 202


3.6.2 EUR Server - Spool Serviceを呼び出すには : EUR システム構築ガイド

  • 36 / 202

  • 表紙

  • 3.　サーバで動作する業務プログラムを作成する

  • 3.6　コマンドを使用する

  • 3.6.2　EUR Server - Spool Serviceを呼び出すには

3.6.2　EUR Server - Spool Serviceを呼び出すには

EUR Server - Spool Serviceを呼び出すには，SS-コマンド起動部品（eurpmlscコマンド）を使用します。

〈この項の構成〉

  • (1)　使用方法

  • (2)　実現できる機能

  • (3)　注意事項

(1)　使用方法

EUR Server - Spool Service Adapterがインストールされているマシンで，eurpmlscコマンドのファイル名を指定して実行します。

コマンドの構文は，Windows環境およびUNIX／Linux環境で共通です。ただし，UNIX／Linux環境で実行する場合は，eurpmlscコマンドを「eurpmlsc」と指定してください。「.exe」は指定できません。また，コマンドの構文に指定できる文字列の長さは，約30KBまでです。

ページの先頭へ

(2)　実現できる機能

eurpmlscコマンドで実現できる機能の概要を次に示します。オプションの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

(a)　スプールデータを操作する

スプールデータとは，帳票の印刷データ（EPF形式ファイル）をスプールサーバに蓄積するときのファイル形式です。コマンド実行時に指定した/mオプションの値によって，次に示すように，スプールデータに対してさまざまな操作ができます。

  • スプールデータの一覧を取得する（/mオプションにgetoutlineを指定）

  • スプールデータの属性値を取得する（/mオプションにgetattrを指定）

  • スプールデータの属性値を変更する（/mオプションにsetattrを指定）

  • スプールデータから印刷データを取得する（/mオプションにgetを指定）

  • スプールデータから取得した印刷データを出力する（/mオプションにprintを指定）

  • スプールデータを削除する（/mオプションにdelを指定）

(b)　スプールサーバの情報を取得する

スプールサーバに登録されているプリンタの情報を一覧で取得できます。コマンド実行時に/mオプションに指定する値を次に示します。

  • スプールサーバのプリンタクラスの一覧を取得する（/mオプションにgetprclassを指定）

  • スプールサーバのOS上のプリンタの一覧を取得する（/mオプションにgetprを指定）

  • スプールサーバのOS上のプリンタのトレイの一覧を取得する（/mオプションにgettrayを指定）

スプールサーバがUNIX／Linux環境の場合は，プリンタの情報を取得できません。

ページの先頭へ

(3)　注意事項

eurpmlscコマンドを使用する場合の注意事項を次に示します。

  • オプション，オプションの指定値，およびオプションに指定する文字列は，大文字と小文字を区別します。例えば，/mオプションを「/M」と指定したり，/mオプションの指定値を「/m GETOUTLINE」と指定したりすると，エラーになります。

  • 一つのコマンド構文に同じオプションが複数指定されている場合は，コマンド構文の後方に指定されたオプションが有効となります。

  • /mオプションで指定したスプールデータの操作，および情報取得の機能（メソッド）に無効なオプションを指定したときは，無視して実行されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 36 / 202


3.6.3 BSP-RMと連携するには : EUR システム構築ガイド

  • 37 / 202

  • 表紙

  • 3.　サーバで動作する業務プログラムを作成する

  • 3.6　コマンドを使用する

  • 3.6.3　BSP-RMと連携するには

3.6.3　BSP-RMと連携するには

BSP-RMとEURを連携することにより，BSP-RMが管理するデータファイル（制御情報付データファイル）をEURサーバ環境で帳票の印刷やファイル出力できます。

BSP-RMからBSP-RM連携コマンド（eursmprコマンド）を実行すると，制御情報付データファイルからマッピングデータファイルおよび帳票セット指定ファイルを生成し，BSP-RM連携コマンドからeurpmcコマンドを呼び出して帳票を出力します。帳票の出力先や出力方法は，BSP-RM連携コマンドに指定する起動パラメタファイルにeurpmcコマンドのオプションの形式で記述します。

BSP-RMとEURを連携する場合の帳票出力の流れの詳細については，マニュアル「EUR 帳票出力 機能解説 EUR Server編」を参照してください。

また，BSP-RM連携コマンドの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

〈この項の構成〉

  • (1)　使用方法

  • (2)　実現できる機能

  • (3)　注意事項

(1)　使用方法

Windows環境のEUR Server - Adapterがインストールされているマシンで，BSP-RM連携コマンドのファイル名を指定して実行します。

引数に制御情報付データファイルと起動パラメタを指定します。BSP-RM連携コマンドからeurpmcコマンドを呼び出して帳票を出力できます。

ページの先頭へ

(2)　実現できる機能

BSP-RMから実行するBSP-RM連携コマンドで実現できる機能の概要を次に示します。オプションの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

(a)　出力先を選んで帳票を出力する

BSP-RM連携コマンドに指定する起動パラメタファイルに，帳票の出力先や出力方法を定義しておくことにより，出力先や出力方法を選んで帳票を出力できます。

起動パラメタファイルにはeurpmcコマンドの/mオプション（printを指定）および/pmオプション（帳票の出力先や出力方法を指定）を記述します。起動パラメタファイルに指定できる/pmオプションの値を次に示します。

  • 帳票サーバのプリンタに出力する（/pmオプションにpmを指定）

  • スプールサーバのプリンタに出力する（/pmオプションにsvを指定）

  • クライアントPCに出力する（/pmオプションにclを指定）

  • スプールサーバに帳票の印刷データを蓄積する（/pmオプションにsplを指定）

(b)　ファイル形式を選んで帳票を出力する

BSP-RM連携コマンドに指定する起動パラメタファイルに，帳票出力時のファイル形式を定義しておくことにより，ファイル形式を選んで帳票を出力できます。

起動パラメタファイルにはeurpmcコマンドの/mオプション（帳票出力時のファイル形式を指定）を記述します。起動パラメタファイルに指定できる/mオプションの値を次に示します。

  • EPF形式ファイルを出力する（/mオプションにedfを指定）

  • PDF形式ファイルを出力する（/mオプションにpdfを指定）

  • EUR形式ファイルを出力する（/mオプションにeurを指定）

  • Excel形式ファイルを出力する（/mオプションにxlsxを指定）

ページの先頭へ

(3)　注意事項

BSP-RM連携コマンドを使用する場合の注意事項を次に示します。

  • BSP-RM連携コマンドの実行時に指定する起動パラメタファイルには，eurpmcコマンドの/mオプションの指定が必須です。

  • 起動パラメタファイルに定義できるeurpmcコマンドのオプションの詳細，およびeurpmcコマンドのオプションを指定するときの注意事項については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 37 / 202


3.7 ファイル監視サービスを使用する : EUR システム構築ガイド

  • 38 / 202

  • 表紙

  • 3.　サーバで動作する業務プログラムを作成する

  • 3.7　ファイル監視サービスを使用する

3.7　ファイル監視サービスを使用する

EURが提供するファイル監視サービスを使用することによって，帳票出力に使用するファイルを監視フォルダに格納するだけで，自動的に帳票の印刷やファイル出力ができます。

〈この節の構成〉

  • 3.7.1　使用方法

  • 3.7.2　実現できる機能

  • 3.7.3　注意事項

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 38 / 202


3.7.1 使用方法 : EUR システム構築ガイド

  • 39 / 202

  • 表紙

  • 3.　サーバで動作する業務プログラムを作成する

  • 3.7　ファイル監視サービスを使用する

  • 3.7.1　使用方法

3.7.1　使用方法

Windows環境のEUR Server - Adapterがインストールされているマシンで，ファイル監視サービスを起動します。ファイル監視サービスの起動や停止する方法については，「7.7　ファイル監視サービスの起動管理設定」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 39 / 202


3.7.2 実現できる機能 : EUR システム構築ガイド

  • 40 / 202

  • 表紙

  • 3.　サーバで動作する業務プログラムを作成する

  • 3.7　ファイル監視サービスを使用する

  • 3.7.2　実現できる機能

3.7.2　実現できる機能

ファイル監視サービスを起動している状態で，帳票出力に使用するファイルを監視フォルダに格納すると，ファイル監視サービスが一定間隔で監視フォルダ内のファイルの着信をチェックして自動的に帳票の印刷やファイル出力を行います。ファイルの着信を監視する間隔は，ファイル監視サービスの環境設定ファイル設定することができます。また，帳票の印刷やファイル出力を行う際にジョブ実行プログラムが動作します。

ファイル監視サービスで実現できる機能の概要を次に示します。オプションの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server 編」を参照してください。

〈この項の構成〉

  • (1)　マッピングデータファイルを監視して帳票を出力する（事前定義型）

  • (2)　制御情報付データファイルを監視して帳票を出力する（上位主導型）

  • (3)　完了フォルダに保持されているマッピングデータファイルまたは制御情報付データファイルを使用して再度帳票を出力する

(1)　マッピングデータファイルを監視して帳票を出力する（事前定義型）

マッピングデータファイルを監視対象として帳票を出力できます。業務アプリケーションから監視フォルダにマッピングデータファイルを格納すると，ファイル監視サービスが一定間隔で監視フォルダ内のファイルの着信をチェックしてファイルを自動的に取得します。取得したファイルが監視定義ファイルに定義したファイル名と一致した場合は，起動パラメタファイルの定義内容に従ってeurpmcコマンドを呼び出して帳票を出力します。ファイル名が一致しない場合，および帳票の出力でエラーが発生した場合は，取得したファイルを完了フォルダに格納します。

起動パラメタファイルにはeurpmcコマンドのオプションを記述して帳票の出力先や出力方法を定義します。監視定義ファイルには着信監視するマッピングデータファイルに対応する起動パラメタファイルの情報を定義します。これらのファイルはファイル監視サービスの使用前にあらかじめ作成しておく必要があります。

起動パラメタファイルおよび監視定義ファイルの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

(2)　制御情報付データファイルを監視して帳票を出力する（上位主導型）

制御情報付データファイルを監視対象として帳票を出力できます。業務アプリケーションから監視フォルダに制御情報付データファイルを格納すると，ファイル監視サービスが一定間隔で監視フォルダ内のファイルの着信をチェックして自動的にファイルを取得し，ファイル内に定義されているマッピングデータおよび帳票の出力先や出力方法に従ってeurpmcコマンドを呼び出して帳票を出力します。帳票の出力時にエラーになった場合は，取得したファイルを完了フォルダに格納します。

制御情報付データファイルに記述する帳票の出力先や出力方法の定義は，eurpmcコマンドのオプションで指定します。

制御情報付データファイルおよび起動パラメタファイルに定義できるeurpmcコマンドのオプションの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

(3)　完了フォルダに保持されているマッピングデータファイルまたは制御情報付データファイルを使用して再度帳票を出力する

完了フォルダに保持されているマッピングデータファイル※および制御情報付データファイルを監視フォルダにコピーすることで再度帳票を出力できます。

注※

監視定義ファイルおよび起動パラメタファイルの定義内容を変更した場合は，変更後の定義内容に従って帳票を出力します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 40 / 202


3.7.3 注意事項 : EUR システム構築ガイド

  • 41 / 202

  • 表紙

  • 3.　サーバで動作する業務プログラムを作成する

  • 3.7　ファイル監視サービスを使用する

  • 3.7.3　注意事項

3.7.3　注意事項

  • ファイル監視サービスを使用する場合の制限事項および注意事項については，マニュアル「EUR 帳票出力 機能解説 EUR Server編」を参照してください。

  • 起動パラメタファイルにeurpmcコマンドのオプションを指定するときの注意事項については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 41 / 202


3.8 サーバで動作する業務プログラムを作成する場合の注意 : EUR システム構築ガイド

  • 42 / 202

  • 表紙

  • 3.　サーバで動作する業務プログラムを作成する

  • 3.8　サーバで動作する業務プログラムを作成する場合の注意

3.8　サーバで動作する業務プログラムを作成する場合の注意

  • EURが読み込むファイルのフルパスは，次の形式が指定できます。

    • ローカルドライブの指定

      （例）C:\ABC\EUR.fms

    • ネットワークパスの指定

      （例）\\COMP\ABC\EUR.fms

    EUR Server ServiceおよびEUR Server - Spool Serviceを使用する場合は，次のことに注意してください。

    • ファイルの入出力でネットワークパスを使用する場合は，EUR Server ServiceおよびEUR Server - Spool Serviceのログオンアカウントを適切なアクセス権を持つアカウントに変更してください。

    • 入出力フォルダにネットワークドライブを使用できません。また，入出力フォルダに適切なアクセス権を設定してください。サービスをLocal Systemで実行している場合は，Local Systemからもアクセスできる必要があります。

  • 起動部品で文字列を指定する場合，次に示す禁止文字を指定しないでください。指定した場合，EURの操作ができなくなるおそれがあります。

    • 引用符（"）

    • コンマ（,）

    • 制御コード（0x00～0x1F，0x7F～0x9F）

  • 非Unicodeアプリケーションの言語で使用できないエンコーディングは，画像ディレクトリおよび一時ファイルディレクトリに使用できません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 42 / 202


4. クライアントで動作する業務プログラムを作成する : EUR システム構築ガイド

  • 43 / 202

  • 表紙

  • 4.　クライアントで動作する業務プログラムを作成する

4.　クライアントで動作する業務プログラムを作成する

この章では，クライアントで動作する業務プログラムの作成について説明します。

〈この章の構成〉

  • 4.1　EURが提供するインタフェース

  • 4.2　実行ユーザとアクセス権

  • 4.3　コマンドを使用する

  • 4.4　EUR Web Plug-Inを使用する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 43 / 202


4.1 EURが提供するインタフェース : EUR システム構築ガイド

  • 44 / 202

  • 表紙

  • 4.　クライアントで動作する業務プログラムを作成する

  • 4.1　EURが提供するインタフェース

4.1　EURが提供するインタフェース

業務プログラムの作成を支援するために，EURでは次の表に示すインタフェースを提供しています。

表4‒1 クライアントで動作する業務プログラムの作成を支援するインタフェース
名称 | 対応するプログラミング言語 | 参照先
eurpmcepfviewerコマンド※ | － | 4.3
EUR Web Plug-In | VBScript，Visual Basic，Visual Basic .NET，ASP.NET，JSP，Javaなど | 4.4
注※

32ビットモードで動作します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 44 / 202


4.2 実行ユーザとアクセス権 : EUR システム構築ガイド

  • 45 / 202

  • 表紙

  • 4.　クライアントで動作する業務プログラムを作成する

  • 4.2　実行ユーザとアクセス権

4.2　実行ユーザとアクセス権

クライアントで動作するコンポーネントが使用するファイルの操作権限を実行ユーザに与えてください。入出力ファイルには適切なアクセス権を設定してください。入力ファイルには読み取りアクセス権，出力ファイルには書き込みアクセス権が必要です。

クライアントで動作するコンポーネントの実行ユーザを次に示します。

表4‒2　クライアントで動作するコンポーネントの実行ユーザ

コンポーネント

機能

実行ユーザ

EUR Client Service

EUR Client Service

ログインユーザ※

EUR Web Plug-In

  • EUR Web Plug-In（印刷用）

  • EUR Web Plug-In（プレビュー用）

使用するアプリケーションプログラムの実行ユーザ
注※

デフォルトの実行ユーザです。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 45 / 202


4.3 コマンドを使用する : EUR システム構築ガイド

  • 46 / 202

  • 表紙

  • 4.　クライアントで動作する業務プログラムを作成する

  • 4.3　コマンドを使用する

4.3　コマンドを使用する

EURが提供するeurpmcepfviewerコマンドを使用することで，業務プログラムからEURを操作できます。

ここでは，eurpmcepfviewerコマンドの使用方法と，実現できる機能の概要について説明します。

〈この節の構成〉

  • 4.3.1　使用方法

  • 4.3.2　実現できる機能

  • 4.3.3　注意事項

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 46 / 202


4.3.1 使用方法 : EUR システム構築ガイド

  • 47 / 202

  • 表紙

  • 4.　クライアントで動作する業務プログラムを作成する

  • 4.3　コマンドを使用する

  • 4.3.1　使用方法

4.3.1　使用方法

EUR Client Serviceがインストールされているマシンで，eurpmcepfviewerコマンドのファイル名を指定して実行します。コマンドの構文に指定できる文字列の長さは，約30KBまでです。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 47 / 202


4.3.2 実現できる機能 : EUR システム構築ガイド

  • 48 / 202

  • 表紙

  • 4.　クライアントで動作する業務プログラムを作成する

  • 4.3　コマンドを使用する

  • 4.3.2　実現できる機能

4.3.2　実現できる機能

eurpmcepfviewerコマンドで実現できる機能の概要を次に示します。

クライアントPCのプリンタに帳票を印刷する

クライアントPCのプリンタに帳票を印刷できます。

クライアントPC上で帳票をプレビューする

クライアントPC上で帳票をプレビューできます。

なお，帳票の印刷先の優先順位は次のとおりです。

  1. プリンタ名の指定（/prオプションで指定）

  2. プリンタクラス名の指定（/prcオプションで指定）

  3. EPF形式ファイルのプリンタクラス名情報

  4. OSのデフォルトのプリンタ

2.または3.で決定したプリンタクラス名が，クライアントPCのプリンタクラスとして設定されていない場合は，OSのデフォルトのプリンタに出力します。また，プリンタ名またはプリンタクラス名の指定によって決定したプリンタが存在しない場合はエラーになります。

オプションの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 48 / 202


4.3.3 注意事項 : EUR システム構築ガイド

  • 49 / 202

  • 表紙

  • 4.　クライアントで動作する業務プログラムを作成する

  • 4.3　コマンドを使用する

  • 4.3.3　注意事項

4.3.3　注意事項

eurpmcepfviewerコマンドを使用する場合の注意事項を次に示します。

  • オプション，オプションの指定値，およびオプションに指定する文字列は，大文字と小文字を区別します。例えば，/rオプションを「/R」と指定すると，エラーになります。

  • 同じオプションが複数指定されている場合は，最後に指定されたオプションの値が有効となります。

  • 無効なオプションが指定されている場合は，エラーになります。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 49 / 202


4.4 EUR Web Plug-Inを使用する : EUR システム構築ガイド

  • 50 / 202

  • 表紙

  • 4.　クライアントで動作する業務プログラムを作成する

  • 4.4　EUR Web Plug-Inを使用する

4.4　EUR Web Plug-Inを使用する

VBScript，Visual Basic，Visual Basic .NET，ASP.NET，JSP，Javaなどで開発する業務プログラムからEUR Web Plug-Inを呼び出すことで，Webブラウザから帳票をダウンロードして出力したり，Webブラウザに帳票を埋め込んで表示したりできます。

〈この節の構成〉

  • 4.4.1　使用方法

  • 4.4.2　実現できる機能

  • 4.4.3　注意事項

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 50 / 202


4.4.1 使用方法 : EUR システム構築ガイド

  • 51 / 202

  • 表紙

  • 4.　クライアントで動作する業務プログラムを作成する

  • 4.4　EUR Web Plug-Inを使用する

  • 4.4.1　使用方法

4.4.1　使用方法

帳票を表示するWebページに，EUR Web Plug-Inのパラメタを<object>タグを使用して記述します。<object>タグの記述内容は，EUR Web Plug-Inのインストール方法によって異なります。<object>タグの記述内容については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 51 / 202


4.4.2 実現できる機能 : EUR システム構築ガイド

  • 52 / 202

  • 表紙

  • 4.　クライアントで動作する業務プログラムを作成する

  • 4.4　EUR Web Plug-Inを使用する

  • 4.4.2　実現できる機能

4.4.2　実現できる機能

EUR Web Plug-Inで実現できる機能の概要を次に示します。

Webブラウザから帳票を印刷する

EUR Web Plug-In（印刷用）を使用して，Webブラウザから帳票をダウンロードして印刷できます。

Webブラウザ上で帳票をプレビューする

EUR Web Plug-In（プレビュー用）を使用して，Webブラウザ上で帳票をプレビューできます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 52 / 202


4.4.3 注意事項 : EUR システム構築ガイド

  • 53 / 202

  • 表紙

  • 4.　クライアントで動作する業務プログラムを作成する

  • 4.4　EUR Web Plug-Inを使用する

  • 4.4.3　注意事項

4.4.3　注意事項

EUR Web Plug-Inを使用する場合の注意事項を次に示します。

  • DefaultPrintDlgパラメタでYESを選択したときは，印刷時にOSの印刷ダイアログが表示されます。プリンタドライバによっては，OSの印刷ダイアログの初期設定に，EPF形式ファイル中の情報が反映されないことがあります。印刷時の属性は，OSの印刷ダイアログで設定してください。

  • EPFFileURLパラメタに，動的にEPF形式ファイルを生成するためのユーザアプリケーションのURLを指定する場合，HTTPレスポンスのHTTPヘッダのContentLength項目には，生成したEPF形式ファイルのファイルサイズを正しく指定してください。間違って指定した場合は，ダウンロードの進捗画面が正しく表示されません。

  • EPFTempDataModeパラメタに「1（ダウンロードするEPF形式ファイルを一時ファイルとして保存しない）」を指定した場合に，ContentLength項目を正しく指定していないときは，ファイルデータを正常にダウンロードできないおそれがあります。

  • ExclusionPrinterNameプロパティおよびExclusionPrinterDriverプロパティを設定することで，EUR Client Serviceの［印刷先指定］ダイアログに表示されるプリンタを制限できます。帳票を自動印刷する場合，ExclusionPrinterNameプロパティまたはExclusionPrinterDriverプロパティの指定によって，印刷先に設定したプリンタが除外されているとエラーになります。

パラメタおよびプロパティの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 53 / 202


5. 帳票の出力内容を設定するファイルを準備する : EUR システム構築ガイド

  • 54 / 202

  • 表紙

  • 5.　帳票の出力内容を設定するファイルを準備する

5.　帳票の出力内容を設定するファイルを準備する

この章では，帳票の出力内容を設定するファイルを準備する方法について説明します。

〈この章の構成〉

  • 5.1　準備の流れ

  • 5.2　帳票サーバに準備するファイル

  • 5.3　アプリケーションサーバに準備するファイル

  • 5.4　運用に応じて格納先を決めるファイル

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 54 / 202


5.1 準備の流れ : EUR システム構築ガイド

  • 55 / 202

  • 表紙

  • 5.　帳票の出力内容を設定するファイルを準備する

  • 5.1　準備の流れ

5.1　準備の流れ

帳票の出力内容を設定するファイルは，次のどちらかの方法で準備します。

  • ファイルを新規作成する

  • 過去に作成したファイルを流用する

それぞれの流れを説明します。

〈この節の構成〉

  • 5.1.1　ファイルを新規作成する

  • 5.1.2　過去に作成したファイルを流用する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 55 / 202


5.1.1 ファイルを新規作成する : EUR システム構築ガイド

  • 56 / 202

  • 表紙

  • 5.　帳票の出力内容を設定するファイルを準備する

  • 5.1　準備の流れ

  • 5.1.1　ファイルを新規作成する

5.1.1　ファイルを新規作成する

ファイルを新規作成する場合の流れを，次の図に示します。

図5‒1　ファイルを新規作成する場合の流れ

[図データ]

帳票ファイルについては，マニュアル「EUR 帳票作成 操作ガイド」を参照して作成してください。帳票ファイル以外のファイルについては，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照して作成してください。

作成したファイルは，次のどちらかのサーバに格納します。

  • 帳票サーバ（EUR Server Service稼働マシン）

  • アプリケーションサーバ（EUR Server - Adapter稼働マシン）

ファイルの格納先については，次の説明を参照してください。

  • 5.2　帳票サーバに準備するファイル

  • 5.3　アプリケーションサーバに準備するファイル

  • 5.4　運用に応じて格納先を決めるファイル

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 56 / 202


5.1.2 過去に作成したファイルを流用する : EUR システム構築ガイド

  • 57 / 202

  • 表紙

  • 5.　帳票の出力内容を設定するファイルを準備する

  • 5.1　準備の流れ

  • 5.1.2　過去に作成したファイルを流用する

5.1.2　過去に作成したファイルを流用する

過去に作成したファイルを流用する場合の流れを，次の図に示します。

図5‒2　過去に作成したファイルを流用する場合の流れ

[図データ]

帳票ファイルについては，マニュアル「EUR 帳票作成 操作ガイド」を参照して修正してください。帳票ファイル以外のファイルについては，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照して修正してください。

作成したファイルは，次のどちらかのサーバに格納します。

  • 帳票サーバ（EUR Server Service稼働マシン）

  • アプリケーションサーバ（EUR Server - Adapter稼働マシン）

ファイルの格納先については，次の説明を参照してください。

  • 5.2　帳票サーバに準備するファイル

  • 5.3　アプリケーションサーバに準備するファイル

  • 5.4　運用に応じて格納先を決めるファイル

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 57 / 202


5.2 帳票サーバに準備するファイル : EUR システム構築ガイド

  • 58 / 202

  • 表紙

  • 5.　帳票の出力内容を設定するファイルを準備する

  • 5.2　帳票サーバに準備するファイル

5.2　帳票サーバに準備するファイル

帳票サーバ（EUR Server Service稼働マシン）に準備するファイルを，次の表に示します。各ファイルの詳細，および起動部品や環境設定ファイルの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

表5‒1　帳票サーバに準備するファイル

ファイルの種類

拡張子

ファイルの格納先

帳票ファイル

*.fms

次のどちらかのディレクトリに格納してください。

  • 起動部品で指定したディレクトリ

  • EUR Server Serviceの環境設定ファイル（EURPM.ini）のPATHセクションのFORMキーに指定したディレクトリ

画像ファイル

*.bmp

*.jpg

*.jpe

*.jpeg

*.gif

*.tif

*.tiff

*.png

EUR Print Serviceの環境変数EURPS_IMAGEPATHに指定したディレクトリ

プリンタ定義ファイル

なし

EUR Print Serviceの環境変数EURPS_PRINTERINFPATHに指定したディレクトリ※1

文書情報設定ファイル

任意

次のどちらかのディレクトリに格納してください。

  • 起動部品で指定したディレクトリ

  • EUR Server Serviceの環境設定ファイル（EURPM.ini）のPATHセクションのDOCINFOキーに指定したディレクトリ

複数様式情報定義ファイル

次のどちらかのディレクトリに格納してください。

  • 起動部品で指定したディレクトリ

  • EUR Server Serviceの環境設定ファイル（EURPM.ini）のPATHセクションのMULTIキーに指定したディレクトリ

接続情報ファイル

次のどちらかのディレクトリに格納してください。

  • 起動部品で指定したディレクトリ

  • EUR Server Serviceの環境設定ファイル（EURPM.ini）のPATHセクションのDBINFOキーに指定したディレクトリ

新規用紙出力定義ファイル

次のどちらかのディレクトリに格納してください。

  • 起動部品で指定したディレクトリ

  • EUR Server Serviceの環境設定ファイル（EURPM.ini）のPATHセクションのPRINTNEWPAPERキーに指定したディレクトリ

置き換え表管理情報ファイル

*.csv

次のどちらかのディレクトリに格納してください。

  • 起動部品で指定したディレクトリ

  • EUR Server Serviceの環境設定ファイル（EURPM.ini）のPATHセクションのREPLACEITEMキーに指定したディレクトリ

置き換え表ファイル

置き換え表管理情報ファイルと同じディレクトリ

Acrobat JavaScript定義ファイル

次のどちらかのディレクトリに格納してください。

  • 起動部品で指定したディレクトリ

  • EUR Server Serviceの環境設定ファイル（EURPM.ini）のPATHセクションのSCRIPTCNTキーに指定したディレクトリ

Acrobat JavaScriptファイル

Acrobat JavaScript定義ファイルと同じディレクトリ

ビューアプレファレンス定義ファイル

次のどちらかのディレクトリに格納してください。

  • 起動部品で指定したディレクトリ

  • EUR Server Serviceの環境設定ファイル（EURPM.ini）のPATHセクションのPREFERENCEキーに指定したディレクトリ

テスト印刷設定ファイル

任意

EUR Print Serviceの環境変数EURPS_TESTPRINTFILEに指定したディレクトリ

印刷日時出力定義ファイル

次のどちらかのディレクトリに格納してください。

  • 起動部品で指定したディレクトリ

  • EUR Server Serviceの環境設定ファイル（EURPM.ini）のPATHセクションのPRINTDATEキーに指定したディレクトリ

帳票出力定義ファイル

EUR Server Serviceの環境設定ファイル（EURPM.ini）のPATHセクションのREPORTIDキーに指定したディレクトリ

個人番号接続情報ファイル

EUR Print Serviceの環境変数EURPS_MMS_CONNECT_INFO_FILEに指定したディレクトリ

個人番号フィールド情報ファイル

帳票出力定義ファイルの設定項目MMSLinkFilePath（個人番号フィールド情報ファイルのパス）に指定したディレクトリ

連携プロファイル※2

－

EUR Print Serviceの環境変数EURPS_MMS_PROFILE_PATHに指定したディレクトリ

個人番号管理サービスのSSL証明書のルート証明書※3

－

個人番号管理サービスのSSL証明書が信頼された証明書と認識されるように，必要に応じて，ルート証明書を帳票サーバにインポート

EUR Application Service動作設定ファイル

*.ini

EUR Application Serviceの実行ファイルと同じフォルダ
（凡例）

－：ユーザが拡張子（ファイル形式）を意識する必要がないことを示します。

注※1

帳票サーバがUNIX／Linux環境の場合，プリンタ定義ファイルを指定しただけでは印刷できません。稼働するOSでプリンタ定義をする必要があります。UNIX／Linux環境でのプリンタ定義方法については，マニュアル「EUR 帳票出力 機能解説 EUR Server編」を参照してください。

注※2

個人番号管理サービス連携機能を使用する場合，個人番号管理サービスから提供される機能を使用して作成します。

注※3

個人番号管理サービス連携機能を使用する場合，個人番号管理サービスのSSLサーバ証明書を入手して帳票サーバにインポートします。

〈この節の構成〉

  • 5.2.1　EUR Application Service動作設定ファイルを作成するには

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 58 / 202


5.2.1 EUR Application Service動作設定ファイルを作成するには : EUR システム構築ガイド

  • 59 / 202

  • 表紙

  • 5.　帳票の出力内容を設定するファイルを準備する

  • 5.2　帳票サーバに準備するファイル

  • 5.2.1　EUR Application Service動作設定ファイルを作成するには

5.2.1　EUR Application Service動作設定ファイルを作成するには

EUR Application Service動作設定ファイルとは，EUR Application Serviceの出力するログファイルのサイズを設定するためのファイルです。

EUR Application Service動作設定ファイルは，テキストエディタなどで作成します。EURではサンプルファイルは提供されていません。

ファイル名および格納先を次に示します。

ファイル名

euraps.ini

格納先

EUR Application Serviceの実行ファイル（euraps.exe）と同じフォルダに配置してください。

デフォルトの格納先は，「インストール先ディレクトリ\euraps\bin」です。

〈この項の構成〉

  • (1)　EUR Application Service動作設定ファイルの形式

  • (2)　EUR Application Service動作設定ファイルのキーワード

(1)　EUR Application Service動作設定ファイルの形式

EUR Application Service動作設定ファイルの形式を次に示します。

[LOG]
LOGFILESIZE=値

ページの先頭へ

(2)　EUR Application Service動作設定ファイルのキーワード

EUR Application Service動作設定ファイルのキーワードを次に示します。

LOGFILESIZE

EUR Application Serviceの出力するログファイルのサイズを指定します。単位はKBで，指定できる値は3,000～2,000,000です。指定できるファイルサイズの範囲外の値を指定した場合，またはキーワードLOGFILESIZEの指定を省略した場合は，3,000が仮定されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 59 / 202


5.3 アプリケーションサーバに準備するファイル : EUR システム構築ガイド

  • 60 / 202

  • 表紙

  • 5.　帳票の出力内容を設定するファイルを準備する

  • 5.3　アプリケーションサーバに準備するファイル

5.3　アプリケーションサーバに準備するファイル

アプリケーションサーバ（EUR Server - Adapter稼働マシン）に準備するファイルを，次の表に示します。各ファイルの詳細，および起動部品の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

表5‒2　アプリケーションサーバに準備するファイル

ファイルの種類

拡張子

ファイルの格納先

データファイル

（マッピングデータファイル，ユーザ定義データファイル）

*.csv

*.dat

*.fix

起動部品で指定したディレクトリ

可変記号値定義ファイル

任意

帳票セット指定ファイル

文書しおり定義ファイル

しおり定義ファイル

暗号化設定ファイル

PDF仕分け定義ファイル

制御情報付データファイル

起動パラメタファイル

EUR Web Plug-In情報ファイル

*.inf
Windows環境の場合

EUR Serverのインストール先ディレクトリ\Adapter

UNIX／Linux環境の場合

/var/opt/eur/adapter

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 60 / 202


5.4 運用に応じて格納先を決めるファイル : EUR システム構築ガイド

  • 61 / 202

  • 表紙

  • 5.　帳票の出力内容を設定するファイルを準備する

  • 5.4　運用に応じて格納先を決めるファイル

5.4　運用に応じて格納先を決めるファイル

運用に応じて格納先を決めるファイルを，次の表に示します。

各ファイルの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

表5‒3 運用に応じて格納先を決めるファイル
ファイルの種類 | 拡張子 | 説明
分割定義ファイル | 任意 | 帳票を分割するときのページ数や分割後の印刷データの印刷先などを定義するファイルです。
仕分け定義ファイル |  | 帳票を仕分けするときのキーワードやキーワードに対応する印刷先などを定義するファイルです。

分割ルールや仕分けルールが帳票ごとに異なる場合は，印刷ジョブことにファイルを指定します。分割ルールや仕分けルールがすべての帳票で同じ場合は，EUR Server Serviceのサービスごとにファイルを指定します。

ファイルの格納先と指定方法を次に示します。

印刷ジョブごとにファイルを指定する場合

ファイルは，アプリケーションサーバ（EUR Server - Adapter稼働マシン）に格納します。

ファイルの格納先

任意のディレクトリに格納してください。

指定方法

次に示す起動部品に，ファイル名とファイルを格納したディレクトリのパスを指定してください。

  • ActiveX起動部品

    SplitFileNameプロパティ，およびSplitFilePathプロパティ

  • Java起動部品

    setSplitFileNameメソッド，およびsetSplitFilePathメソッド

  • COBOL起動部品

    SPLITFILENAMEパラメタ，およびSPLITFILEPATHパラメタ

  • コマンド起動部品（eurpmcコマンド）

    /splitfオプション，および/splitfpオプション

EUR Server Serviceのサービスごとにファイルを指定する場合

ファイルは，帳票サーバ（EUR Server Service稼働マシン）に格納します。

ファイルの格納先

EUR Server Serviceの環境設定ファイル（EURPM.ini）のPATHセクションのSPLITキーで指定したディレクトリに格納してください。

指定方法

ファイル名を，EUR Server Serviceの環境設定ファイル（EURPM.ini）のFILEセクションのSPLITキーに指定してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 61 / 202


6. 帳票の出力環境を設定するファイルを準備する : EUR システム構築ガイド

  • 62 / 202

  • 表紙

  • 6.　帳票の出力環境を設定するファイルを準備する

6.　帳票の出力環境を設定するファイルを準備する

この章では，帳票の出力環境を設定するファイルを準備する方法について説明します。

〈この章の構成〉

  • 6.1　準備の流れ

  • 6.2　環境設定ファイルを作成するには

  • 6.3　構成定義ファイルを作成するには

  • 6.4　EURフォントファイルを作成するには

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 62 / 202


6.1 準備の流れ : EUR システム構築ガイド

  • 63 / 202

  • 表紙

  • 6.　帳票の出力環境を設定するファイルを準備する

  • 6.1　準備の流れ

6.1　準備の流れ

帳票の出力環境を設定するファイルは，次のどちらかの方法で準備します。

  • ファイルを新規作成する

  • 過去に作成したファイルを流用する

それぞれの流れを説明します。

〈この節の構成〉

  • 6.1.1　ファイルを新規作成する

  • 6.1.2　過去に作成したファイルを流用する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 63 / 202


6.1.1 ファイルを新規作成する : EUR システム構築ガイド

  • 64 / 202

  • 表紙

  • 6.　帳票の出力環境を設定するファイルを準備する

  • 6.1　準備の流れ

  • 6.1.1　ファイルを新規作成する

6.1.1　ファイルを新規作成する

ファイルを新規作成する場合の流れを，次の図に示します。

図6‒1　ファイルを新規作成する場合の流れ

[図データ]

ファイルの作成方法，およびファイルの格納先については，次の説明を参照してください。

  • 6.2　環境設定ファイルを作成するには

  • 6.3　構成定義ファイルを作成するには

  • 6.4　EURフォントファイルを作成するには

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 64 / 202


6.1.2 過去に作成したファイルを流用する : EUR システム構築ガイド

  • 65 / 202

  • 表紙

  • 6.　帳票の出力環境を設定するファイルを準備する

  • 6.1　準備の流れ

  • 6.1.2　過去に作成したファイルを流用する

6.1.2　過去に作成したファイルを流用する

過去に作成したファイルを流用する場合の流れについて説明します。

なお，EURフォントファイルについては，過去に作成したファイルを流用できません。「6.4　EURフォントファイルを作成するには」を参照して，ファイルを作成し直してください。

〈この項の構成〉

  • (1)　環境設定ファイルを流用する

  • (2)　構成定義ファイルを流用する

(1)　環境設定ファイルを流用する

流用手順を次に示します。

  1. 流用するファイルを任意のディレクトリに格納します。

  2. メモ帳などのテキストエディタを使用して，必要な個所を修正します。

修正したファイルの格納先については，「6.2　環境設定ファイルを作成するには」を参照してください。

ページの先頭へ

(2)　構成定義ファイルを流用する

(a)　EUR Server Serviceの構成定義ファイルを流用する

流用手順を次に示します。

  1. 流用するファイルを，次のどちらかのディレクトリに格納します。

    • デフォルトのディレクトリ

      Windows環境

        インストール先ディレクトリ\Server\Conf

      UNIX／Linux環境

        /var/opt/eur/server/Conf

    • EUR Server Serviceの環境設定ファイル（EURPM.ini）のPATHセクションのCONFキーに指定したディレクトリ

  2. ［EUR Server Service 構成定義］ダイアログ，またはメモ帳などのテキストエディタで，設定内容を変更します。

    設定内容を変更する方法については，次の説明を参照してください。

    • 出力先定義ファイル（Destination.conf）の設定内容を変更する場合

      「6.3.3　スプールサーバを登録する」を参照してください。

    • 帳票サーバプリンタクラス定義ファイル（PMPrinterClass.conf）の設定内容を変更する場合

      「6.3.4　帳票サーバのプリンタクラスを登録する」を参照してください。

    • 印刷先定義ファイル（PrintDest.conf）の設定内容を変更する場合

      「6.3.5　印刷先を登録する」を参照してください。

(b)　EUR Server - Spool Serviceの構成定義ファイルを流用する

流用手順を次に示します。

  1. 流用するファイルを，次のどちらかのディレクトリに格納します。

    • デフォルトのディレクトリ

      Windows環境

        インストール先ディレクトリ\Spool\Conf

      UNIX／Linux環境

        /var/opt/eur/spool/Conf

    • EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）のPATHセクションのCONFキーに指定したディレクトリ

  2. ［EUR Spool Service 構成定義］ダイアログ，またはメモ帳などのテキストエディタで，設定内容を変更します。

    設定内容を変更する方法については，次の説明を参照してください。

    • 拠点プリンタクラス定義ファイル（ServerPrinterClass.conf）の設定内容を変更する場合

      「6.3.6　スプールサーバのプリンタクラスを登録する」を参照してください。

    • 帳票振り分け定義ファイル（Distribution.conf）の設定内容を変更する場合

      「6.3.7　帳票振り分け定義を登録する」を参照してください。

    • ユーザ管理ファイル（userdef.conf）の設定内容を変更する場合

      「6.3.8　スプールデータを操作するユーザを登録する」を参照してください。

(c)　EUR Client Serviceの構成定義ファイルを流用する

流用手順を次に示します。

  1. 流用するファイルを，次のどちらかのディレクトリに格納します。

    • デフォルトのディレクトリ

      インストール先ディレクトリ\Client\Conf

    • EUR Client Serviceの環境設定ファイル（EURPMCL.ini）のPATHセクションのCONFキーに指定したディレクトリ

  2. ［EUR Client 構成定義］ダイアログで，設定内容を変更します。

    設定内容を変更する方法については，「6.3.9　クライアントのプリンタクラスを登録する」を参照してください。

(d)　ファイル監視サービスの構成定義ファイルを流用する

流用手順を次に示します。

  1. 流用するファイルを，次のどちらかのディレクトリに格納します。

    • デフォルトのディレクトリ

      インストール先ディレクトリ\FileMonitor\conf

    • ファイル監視サービスの環境設定ファイル（eurfm.ini）のPATHセクションのCONFキーに指定したディレクトリ

  2. メモ帳などのテキストエディタで，設定内容を変更します。

    設定内容を変更する方法については，次の説明を参照してください。

    • 監視定義ファイル（monitordef.conf）の設定内容を変更する場合

      「6.3.10　ファイル監視サービスの照合パターンを登録する」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 65 / 202


6.2 環境設定ファイルを作成するには : EUR システム構築ガイド

  • 66 / 202

  • 表紙

  • 6.　帳票の出力環境を設定するファイルを準備する

  • 6.2　環境設定ファイルを作成するには

6.2　環境設定ファイルを作成するには

ここでは，環境設定ファイルを作成する方法について説明します。

〈この節の構成〉

  • 6.2.1　環境設定ファイルとは

  • 6.2.2　ファイルの作成方法

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 66 / 202


6.2.1 環境設定ファイルとは : EUR システム構築ガイド

  • 67 / 202

  • 表紙

  • 6.　帳票の出力環境を設定するファイルを準備する

  • 6.2　環境設定ファイルを作成するには

  • 6.2.1　環境設定ファイルとは

6.2.1　環境設定ファイルとは

環境設定ファイルとは，EUR Serverの各コンポーネントの動作環境を設定するファイルです。各コンポーネントの環境設定ファイルのファイル名と格納先を次の表に示します。

各ファイルの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

表6‒1　環境設定ファイルのファイル名と格納先

環境

コンポーネント

機能

環境設定ファイルのファイル名と格納先

サーバ

EUR Print Service

EUR Print Service

運用によって異なります。詳細については，「(1)　EUR Print Serviceの環境設定ファイルのファイル名と格納先」を参照してください。

EUR Server Service

EUR Server Service

●デフォルト

  • ファイル名

    EURPM.ini

  • 格納先

    Windows環境

      インストール先ディレクトリ\Server

    UNIX／Linux環境

      /var/opt/eur/server

●起動管理定義またはServer Service制御コマンド（eurpmctrlコマンド）で環境設定ファイルの格納先のディレクトリを指定する場合※

  • ファイル名

    EURPM.ini

  • 格納先

    起動管理定義の環境設定ファイルパスまたはServer Service制御コマンド（eurpmctrlコマンド）のiniオプションで指定した環境設定ファイルのディレクトリパス

●起動管理定義またはServer Service制御コマンド（eurpmctrlコマンド）で環境設定ファイルのファイルパスを指定する場合※

  • ファイル名と格納先

    起動管理定義の環境設定ファイルパスまたはServer Service制御コマンド（eurpmctrlコマンド）のiniオプションで指定した環境設定ファイルのファイルパス（ファイル名は任意）

●EUR Server - AdapterまたはEUR Server - Spool Service Adapterで使用する環境設定ファイルの格納先を任意のディレクトリに変更し，EUR Server Serviceの環境設定ファイルを同じディレクトリに格納する場合

  • ファイル名と格納先

    「(2)　EUR Server - AdapterまたはEUR Server - Spool Service Adapterで使用する環境設定ファイルのパスを指定する場合のファイル名と格納先」の「環境設定ファイルの格納先を任意のディレクトリに変更する場合」を参照してください。

●EUR Server - AdapterまたはEUR Server - Spool Service Adapterで使用する環境設定ファイルを任意のファイルパスで指定し，EUR Server Serviceの環境設定ファイルで設定する内容を同じファイルに指定する場合

  • ファイル名と格納先

    「(2)　EUR Server - AdapterまたはEUR Server - Spool Service Adapterで使用する環境設定ファイルのパスを指定する場合のファイル名と格納先」の「環境設定ファイルを任意のファイルパスで指定する場合」を参照してください。

注※

起動管理定義およびServer Service制御コマンド（eurpmctrlコマンド）の詳細については，「7.5　EUR Server Serviceの起動管理設定」を参照してください。

Server Service制御コマンド（eurpmctrlコマンド）

  • ファイル名

    EURPMCTRL.ini

  • 格納先

    Windows環境

      インストール先ディレクトリ\Server

    UNIX／Linux環境

      /var/opt/eur/server

EUR Server - Adapter

EUR Server - Adapter

●デフォルト

  • ファイル名

    EURPMADP.ini

  • 格納先

    Windows環境

      インストール先ディレクトリ\Adapter

    UNIX／Linux環境

      /var/opt/eur/adapter

●EUR Server - AdapterまたはEUR Server - Spool Service Adapterで使用する環境設定ファイルの格納先を任意のディレクトリに変更する場合

  • ファイル名と格納先

    「(2)　EUR Server - AdapterまたはEUR Server - Spool Service Adapterで使用する環境設定ファイルのパスを指定する場合のファイル名と格納先」の「環境設定ファイルの格納先を任意のディレクトリに変更する場合」を参照してください。

●EUR Server - AdapterまたはEUR Server - Spool Service Adapterで使用する環境設定ファイルを任意のファイルパスで指定する場合

  • ファイル名と格納先

    「(2)　EUR Server - AdapterまたはEUR Server - Spool Service Adapterで使用する環境設定ファイルのパスを指定する場合のファイル名と格納先」の「環境設定ファイルを任意のファイルパスで指定する場合」を参照してください。

BSP-RM連携コマンド（eursmprコマンド）

  • ファイル名

    eursmpr.ini

  • 格納先

    インストール先ディレクトリ\Eursmpr

ファイル監視サービス

  • ファイル名

    eurfm.ini

  • 格納先

    インストール先ディレクトリ\FileMonitor

ジョブ実行プログラム

  • ファイル名

    eurivk.ini

  • 格納先

    インストール先ディレクトリ\FileMonitor

EUR Server - Spool Service

EUR Server - Spool Service

●デフォルト

  • ファイル名

    EURPMLS.ini

  • 格納先

    Windows環境

      インストール先ディレクトリ\Spool

    UNIX／Linux環境

      /var/opt/eur/spool

●システム環境変数EUR_SPOOL_SERVICE_ENVFILEに環境設定ファイルの格納先のディレクトリを指定する場合※1

  • ファイル名

    EURPMLS.ini

  • 格納先

    システム環境変数EUR_SPOOL_SERVICE_ENVFILEに指定したディレクトリパス

●システム環境変数EUR_SPOOL_SERVICE_ENVFILEに環境設定ファイルのファイルパスを指定する場合※1

  • ファイル名と格納先

    システム環境変数EUR_SPOOL_SERVICE_ENVFILEで指定したファイルパス（ファイル名は任意）

●Spool Service制御コマンド（eurpmlsctrlコマンド）で環境設定ファイルの格納先のディレクトリを指定する場合※2

  • ファイル名

    EURPMLS.ini

  • 格納先

    Spool Service制御コマンド（eurpmlsctrlコマンド）のiniオプションで指定した環境設定ファイルのディレクトリパス

●Spool Service制御コマンド（eurpmlsctrlコマンド）で環境設定ファイルのファイルパスを指定する場合※2

  • ファイル名と格納先

    Spool Service制御コマンド（eurpmlsctrlコマンド）のiniオプションで指定した環境設定ファイルのファイルパス（ファイル名は任意）

●EUR Server - AdapterまたはEUR Server - Spool Service Adapterで使用する環境設定ファイルの格納先を任意のディレクトリに変更し，EUR Server - Spool Serviceの環境設定ファイルを同じディレクトリに格納する場合

  • ファイル名と格納先

    「(2)　EUR Server - AdapterまたはEUR Server - Spool Service Adapterで使用する環境設定ファイルのパスを指定する場合のファイル名と格納先」の「環境設定ファイルの格納先を任意のディレクトリに変更する場合」を参照してください。

●EUR Server - AdapterまたはEUR Server - Spool Service Adapterで使用する環境設定ファイルを任意のファイルパスで指定し，EUR Server - Spool Serviceの環境設定ファイルで設定する内容を同じファイルに指定する場合

  • ファイル名と格納先

    「(2)　EUR Server - AdapterまたはEUR Server - Spool Service Adapterで使用する環境設定ファイルのパスを指定する場合のファイル名と格納先」の「環境設定ファイルを任意のファイルパスで指定する場合」を参照してください。

注※1

システム環境変数EUR_SPOOL_SERVICE_ENVFILEを設定した場合は，EUR Server - Spool Serviceが稼働するマシンのOSを再起動してください。

注※2

Spool Service制御コマンド（eurpmlsctrlコマンド）の詳細については，「7.6　EUR Server - Spool Serviceの起動管理設定」を参照してください。

Spool Service制御コマンド（eurpmlsctrlコマンド）

  • ファイル名

    EURPMCTRL.ini

  • 格納先

    /var/opt/eur/spool

EUR Server - Spool Service Adapter

EUR Server - Spool Service Adapter

●デフォルト

  • ファイル名

    EURPMLSADP.ini

  • 格納先

    Windows環境

      インストール先ディレクトリ\Spool Adapter

    UNIX／Linux環境

      /var/opt/eur/spool-adp

●EUR Server - AdapterまたはEUR Server - Spool Service Adapterで使用する環境設定ファイルの格納先を任意のディレクトリに変更し，EUR Server - Spool Service Adapterの環境設定ファイルを同じディレクトリに格納する場合

  • ファイル名と格納先

    「(2)　EUR Server - AdapterまたはEUR Server - Spool Service Adapterで使用する環境設定ファイルのパスを指定する場合のファイル名と格納先」の「環境設定ファイルの格納先を任意のディレクトリに変更する場合」を参照してください。

●EUR Server - AdapterまたはEUR Server - Spool Service Adapterで使用する環境設定ファイルを任意のファイルパスで指定し，EUR Server - Spool Service Adapterの環境設定ファイルで設定する内容を同じファイルに指定する場合

  • ファイル名と格納先

    「(2)　EUR Server - AdapterまたはEUR Server - Spool Service Adapterで使用する環境設定ファイルのパスを指定する場合のファイル名と格納先」の「環境設定ファイルを任意のファイルパスで指定する場合」を参照してください。

帳票管理GUI

  • ファイル名

    EURPMRSGUI.ini

  • 格納先

    Windows環境

      インストール先ディレクトリ\Spool Adapter

    UNIX／Linux環境

      /var/opt/eur/spool-adp

クライアント

EUR Client Service

EUR Client Service

  • ファイル名

    EURPMCL.ini

  • 格納先

    インストール先ディレクトリ\Client

〈この項の構成〉

  • (1)　EUR Print Serviceの環境設定ファイルのファイル名と格納先

  • (2)　EUR Server - AdapterまたはEUR Server - Spool Service Adapterで使用する環境設定ファイルのパスを指定する場合のファイル名と格納先

(1)　EUR Print Serviceの環境設定ファイルのファイル名と格納先

EUR Print Serviceの環境設定ファイルのファイル名と格納先は，次に示すように指定方法によって異なります。

  • 印刷ジョブごとにファイルを指定する場合

    • ファイル名

      次に示す起動部品で指定したファイル名

      ・ActiveX起動部品：PSEnvFileNameプロパティ

      ・Java起動部品：setPSEnvFileNameメソッド

      ・COBOL起動部品：PSENVFILENAMEパラメタ

      ・コマンド起動部品：eurpmcコマンドの/psenvfオプション

    • 格納先

      次に示す起動部品で指定したディレクトリパス

      ・ActiveX起動部品：PSEnvFilePathプロパティ

      ・Java起動部品：setPSEnvFilePathメソッド

      ・COBOL起動部品：PSENVFILEPATHパラメタ

      ・コマンド起動部品：eurpmcコマンドの/psenvfpオプション

  • EUR Server Serviceのサービスごとにファイルを指定する場合

    • ファイル名

      EUR Server Serviceの環境設定ファイル（EURPM.ini）のENVセクションのPSENVFILENAMEキーで指定したファイル名

    • 格納先

      EUR Server Serviceの環境設定ファイル（EURPM.ini）のPATHセクションのPSENVキーで指定したディレクトリパス

  • EUR Print Serviceの実行ユーザごとにファイルを指定する場合

    • ファイル名と格納先

      EUR Print Serviceの環境変数EURPS_ENVFILEで指定したファイルパス（ファイル名は任意）

  • 何も指定しなかった場合（デフォルトの格納先）

    • ファイル名

      Windows環境

        EURPS_ENV

      UNIX／Linux環境

        eurps_env

    • 格納先

      Windows環境

        インストール先ディレクトリ\Print

      UNIX／Linux環境

        /etc/opt/eur

また，EUR Print Serviceの環境設定ファイルは複数指定することもできます。複数の環境設定ファイルを指定した場合で，同じ環境変数に異なる値を指定したときは，次の優先順位で設定内容が適用されます。

  1. 起動部品で指定した環境設定ファイルの内容

  2. EUR Server Serviceの環境設定ファイル（EURPM.ini）で指定した環境設定ファイルの内容

  3. 環境変数EURPS_ENVFILEで指定した環境設定ファイルの内容

  4. デフォルトのディレクトリに格納した環境設定ファイルの内容

ページの先頭へ

(2)　EUR Server - AdapterまたはEUR Server - Spool Service Adapterで使用する環境設定ファイルのパスを指定する場合のファイル名と格納先

EUR Server - AdapterまたはEUR Server - Spool Server Adapterで使用する環境設定ファイルのパスを指定する場合の，各コンポーネントの環境設定ファイルのファイル名と格納先は，次に示す指定方法によって異なります。

  • 環境設定ファイルの格納先を任意のディレクトリに変更する場合

    • ファイル名

      次に示すデフォルトのファイル名

      ・EUR Server Serviceの環境設定ファイル：EURPM.ini

      ・EUR Server - Adapterの環境設定ファイル：EURPMADP.ini

      ・EUR Server - Spool Serviceの環境設定ファイル：EURPMLS.ini

      ・EUR Server - Spool Service Adapterの環境設定ファイル：EURPMLSADP.ini

    • 格納先

      次に示す起動部品で指定したディレクトリパス

      ・ActiveX起動部品：AdpEnvFileプロパティ

      ・Java起動部品：setAdpEnvFileメソッド

      ・コマンド起動部品：eurpmcコマンドの/adpenvオプション

      ・SS-ActiveX起動部品：AdpEnvFileプロパティ

      ・SS-Java起動部品：setAdpEnvFileメソッド

      ・SS-コマンド起動部品：eurpmlscコマンドの/adpenvオプション

  • 環境設定ファイルを任意のファイルパスで指定する場合

    • ファイル名と格納先

      次に示す起動部品で指定したファイルパス（ファイル名は任意）

      ・ActiveX起動部品：AdpEnvFileプロパティ

      ・Java起動部品：setAdpEnvFileメソッド

      ・コマンド起動部品：eurpmcコマンドの/adpenvオプション

      ・SS-ActiveX起動部品：AdpEnvFileプロパティ

      ・SS-Java起動部品：setAdpEnvFileメソッド

      ・SS-コマンド起動部品：eurpmlscコマンドの/adpenvオプション

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 67 / 202


6.2.2 ファイルの作成方法 : EUR システム構築ガイド

  • 68 / 202

  • 表紙

  • 6.　帳票の出力環境を設定するファイルを準備する

  • 6.2　環境設定ファイルを作成するには

  • 6.2.2　ファイルの作成方法

6.2.2　ファイルの作成方法

環境設定ファイルは，各コンポーネントのルートディレクトリ（Windows環境）またはサンプルディレクトリ（UNIX／Linux環境）に格納されています。テキストエディタなどで開いて直接編集します。

UNIX／Linux環境の場合，サンプルディレクトリに格納されているファイルを任意の場所に保存してから編集してください。サンプルディレクトリの場所は次のとおりです。

/opt/eur/sample

■作成時の注意

  • ファイルを作成するマシンのロケールに応じたエンコードで編集してください。

  • EUR Developer，およびEUR Serverをデフォルトディレクトリにインストールした場合，環境設定ファイルは管理者権限で編集してください。

作成したファイルは，編集前のファイルと同じファイル名で「表6-1　環境設定ファイルのファイル名と格納先」に示す格納先に格納します。格納先には，EUR Serverの各コンポーネントを利用するユーザが読み書きできるようにアクセス権を設定します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 68 / 202


6.3 構成定義ファイルを作成するには : EUR システム構築ガイド

  • 69 / 202

  • 表紙

  • 6.　帳票の出力環境を設定するファイルを準備する

  • 6.3　構成定義ファイルを作成するには

6.3　構成定義ファイルを作成するには

ここでは，構成定義ファイルを作成する方法について説明します。

〈この節の構成〉

  • 6.3.1　構成定義ファイルとは

  • 6.3.2　ファイルの作成方法

  • 6.3.3　スプールサーバを登録する

  • 6.3.4　帳票サーバのプリンタクラスを登録する

  • 6.3.5　印刷先を登録する

  • 6.3.6　スプールサーバのプリンタクラスを登録する

  • 6.3.7　帳票振り分け定義を登録する

  • 6.3.8　スプールデータを操作するユーザを登録する

  • 6.3.9　クライアントのプリンタクラスを登録する

  • 6.3.10　ファイル監視サービスの照合パターンを登録する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 69 / 202


6.3.1 構成定義ファイルとは : EUR システム構築ガイド

  • 70 / 202

  • 表紙

  • 6.　帳票の出力環境を設定するファイルを準備する

  • 6.3　構成定義ファイルを作成するには

  • 6.3.1　構成定義ファイルとは

6.3.1　構成定義ファイルとは

構成定義ファイルとは，EUR Serverの各コンポーネントの構成情報を定義するファイルです。構成定義ファイルの種類と格納先を次の表に示します。

各ファイルの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

表6‒2　構成定義ファイルの種類と格納先

環境

コンポーネント

ファイルの種類

説明

ファイルの格納先

サーバ

EUR Server Service

出力先定義ファイル（Destination.conf）

スプールサーバを帳票の出力先として登録するためのファイルです。

次のどちらかのディレクトリに格納してください。

  • デフォルトのディレクトリ

    Windows環境の場合

    インストール先ディレクトリ\Server\Conf

    UNIX／Linux環境の場合

    /var/opt/eur/server/Conf

  • EUR Server Serviceの環境設定ファイル（EURPM.ini）のPATHセクションのCONFキーに指定したディレクトリ

帳票サーバプリンタクラス定義ファイル（PMPrinterClass.conf）

帳票サーバのプリンタクラスを登録するためのファイルです。

印刷先定義ファイル（PrintDest.conf）

帳票の蓄積時に指定する情報を，印刷先として登録するためのファイルです。

EUR Server - Adapter

監視定義ファイル（monitordef.conf）

ファイル監視サービスの照合パターンを定義するファイルです。

次のどちらかのディレクトリに格納してください。

  • デフォルトのディレクトリ

    インストール先ディレクトリ\FileMonitor\conf

  • ファイル監視サービスの環境設定ファイル（eurfm.ini）のPATHセクションのCONFキーに指定したディレクトリ

EUR Server - Spool Service

拠点プリンタクラス定義ファイル（ServerPrinterClass.conf）

スプールサーバのプリンタクラスを登録するためのファイルです。

次のどちらかのディレクトリに格納してください。

  • デフォルトのディレクトリ

    インストール先ディレクトリ\Spool\Conf

  • EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）のPATHセクションのCONFキーに指定したディレクトリ

帳票振り分け定義ファイル（Distribution.conf）

帳票振り分け定義を登録するためのファイルです。

ユーザ管理ファイル（userdef.conf）

スプールデータを操作するユーザを登録するためのファイルです。

次のどちらかのディレクトリに格納してください。

  • デフォルトのディレクトリ

    Windows環境の場合

    インストール先ディレクトリ\Spool\Conf

    UNIX／Linux環境の場合

    /var/opt/eur/spool/Conf

  • EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）のPATHセクションのCONFキーに指定したディレクトリ

宛先定義ファイル（addrdef.conf※）

配送印刷をするときに，宛先ごとに割り当てるユーザを定義するためのファイルです。

次のどちらかのディレクトリに格納してください。

  • デフォルトのディレクトリ

    Windows環境の場合

    インストール先ディレクトリ\Spool\Conf

    UNIX／Linux環境の場合

    /var/opt/eur/spool/Conf

  • EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）のPATHセクションのCONFキーに指定したディレクトリ

クライアント

EUR Client Service

クライアントプリンタクラス定義ファイル（ClientPrinterClass.conf）

クライアントのプリンタクラスを登録するためのファイルです。

次のどちらかのディレクトリに格納してください。

  • デフォルトのディレクトリ

    インストール先ディレクトリ\Client\Conf

  • EUR Client Serviceの環境設定ファイル（EURPMCL.ini）のPATHセクションのCONFキーに指定したディレクトリ
注※

宛先定義ファイルのファイル名およびファイル形式は，EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）のCONFセクションのADDRDEFFILENAMEキーで変更できます。ADDRDEFFILENAMEキーの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 70 / 202


6.3.2 ファイルの作成方法 : EUR システム構築ガイド

  • 71 / 202

  • 表紙

  • 6.　帳票の出力環境を設定するファイルを準備する

  • 6.3　構成定義ファイルを作成するには

  • 6.3.2　ファイルの作成方法

6.3.2　ファイルの作成方法

構成定義ファイルは，次のどれかの方法で作成します。

  • ダイアログを使用して作成する

    各コンポーネントの構成定義ダイアログを使用して作成します。構成定義ダイアログは，Windows環境で使用できます。

    ［EUR Server Service 構成定義］ダイアログを使用して作成するファイル

    ・出力先定義ファイル

    ・帳票サーバプリンタクラス定義ファイル

    ［EUR Spool Service 構成定義］ダイアログを使用して作成するファイル

    ・拠点プリンタクラス定義ファイル

    ・帳票振り分け定義ファイル

    ・ユーザ管理ファイル

    ［EUR Client 構成定義］ダイアログを使用して作成するファイル

    ・クライアントプリンタクラス定義ファイル

  • サンプルファイルを編集して作成する

    次のディレクトリに格納されているサンプルファイルを編集して作成します。

    Windows環境の場合

    インストール先ディレクトリ\Sample

    UNIX／Linux環境の場合

    /opt/eur/sample

    サンプルファイルを編集して作成するファイルを，次に示します。

    ・出力先定義ファイル（UNIX／Linux環境の場合だけ）

    ・帳票サーバプリンタクラス定義ファイル（UNIX／Linux環境の場合だけ）

    ・印刷先定義ファイル

    ・ユーザ管理ファイル（UNIX／Linux環境の場合だけ）

    ・宛先定義ファイル

  • テキストエディタなどで新規に作成する

    テキストエディタなどで新規に作成するファイルを，次に示します。

    ・監視定義ファイル

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 71 / 202


6.3.3 スプールサーバを登録する : EUR システム構築ガイド

  • 72 / 202

  • 表紙

  • 6.　帳票の出力環境を設定するファイルを準備する

  • 6.3　構成定義ファイルを作成するには

  • 6.3.3　スプールサーバを登録する

6.3.3　スプールサーバを登録する

スプールサーバを帳票の出力先として登録するために，出力先定義ファイルを作成します。

〈この項の構成〉

  • (1)　ダイアログを使用して作成する

  • (2)　サンプルファイルを編集して作成する

  • (3)　ダイアログの設定項目

(1)　ダイアログを使用して作成する

［EUR Server Service 構成定義］ダイアログでスプールサーバを帳票の出力先として登録すると，出力先定義ファイルが次のディレクトリに作成されます。

インストール先ディレクトリ\Server\Conf

［EUR Server Service 構成定義］ダイアログは，EUR製品のプログラムメニューから，［Server］－［Server Service 構成定義］を選択すると表示されます。なお，複数のEUR Server Serviceが起動管理定義に登録されている場合は，［EUR Server Service 構成定義］ダイアログが表示される前に，［サービスの選択］ダイアログが表示されます。

［識別名］

EUR Server Serviceの識別名が，登録した順に一覧で表示されます。

出力先を設定，変更または削除したいEUR Server Serviceを選択して，［OK］ボタンをクリックすると，［EUR Server Service 構成定義］ダイアログが表示されます。

(a)　出力先を登録する

出力先の登録手順を次に示します。最大登録数のデフォルトは，65,536個です。

  1. ［EUR Server Service 構成定義］ダイアログの［出力先］タブを表示します。

  2. ［追加］ボタンをクリックします。

    ［出力先の追加］ダイアログが表示されます。

  3. 次の項目を設定します。

    • 出力先（必須）

    • IPアドレス（必須）

    • 説明（任意）

  4. ［OK］ボタンをクリックします。

    出力先が［EUR Server Service 構成定義］ダイアログに追加されます。

    ただし，次の場合は，メッセージが表示されて，［出力先の追加］ダイアログに戻ります。

    • 指定が必須の項目が指定されていない場合

    • すでにデフォルトの出力先が登録されている場合に，［デフォルト出力先］ラジオボタンを選択したとき

    • 同じ出力先名が登録されている場合

    • 出力先，説明が入力できる文字数を超えている場合

    • 出力先，説明に入力できない文字があった場合

    • 出力先名に半角空白だけを入力した場合

(b)　出力先を変更する

出力先の変更手順を次に示します。

  1. ［EUR Server Service 構成定義］ダイアログの［出力先］タブを表示します。

  2. 変更する出力先を選択して，［変更］ボタンをクリックします。

    ［出力先の変更］ダイアログが表示されます。

  3. 設定内容を変更します。

  4. ［OK］ボタンをクリックします。

    出力先が変更されます。変更後の登録内容が［EUR Server Service 構成定義］ダイアログに表示されます。

    ただし，次の場合は，メッセージが表示されて，［出力先の変更］ダイアログに戻ります。

    • 指定が必須の項目が指定されていない場合

    • すでにデフォルトの出力先が登録されている場合に，［デフォルト出力先］ラジオボタンを選択したとき

    • 同じ出力先名が登録されている場合

    • 出力先，説明が入力できる文字数を超えている場合

    • 出力先，説明に入力できない文字があった場合

    • 出力先名に半角空白だけを入力した場合

(c)　出力先を削除する

出力先の削除手順を次に示します。

  1. ［EUR Server Service 構成定義］ダイアログの［出力先］タブを表示します。

  2. 削除する出力先を選択して，［削除］ボタンをクリックします。

    削除を確認するダイアログが表示されます。

  3. ［OK］ボタンをクリックします。

    出力先が削除されます。

ページの先頭へ

(2)　サンプルファイルを編集して作成する

作成手順を次に示します。

  1. 出力先定義ファイル（Destination.conf）のサンプルを任意の場所に保存します。

  2. 出力先定義ファイルを編集します。

    出力先定義ファイルは，マシンのロケールに応じたエンコードで編集してください。

作成したファイルは，同じファイル名（Destination.conf）で「表6-2　構成定義ファイルの種類と格納先」に示す格納先に格納してください。また，格納先には，EUR Server Serviceを利用するユーザが読み書きできるようにアクセス権を設定してください。

出力先定義ファイルの設定項目については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

(3)　ダイアログの設定項目

出力先定義ファイルの作成で使用するダイアログの設定項目について説明します。

(a)　［EUR Server Service 構成定義］ダイアログ（［出力先］タブ）

［EUR Server Service 構成定義］ダイアログのタイトルバーには，選択したEUR Server Serviceの識別名が表示されます。

［出力先一覧］

登録したスプールサーバの構成定義が表示されます。［出力先名］，［IPアドレス］，または［説明］をクリックすると，Shift-JISのコード順にソートして表示されます。

［出力先名］

登録した出力先名が表示されます。出力先名は，登録順に表示されます。デフォルトの出力先には，「"デフォルト"」と表示されます。

［IPアドレス］

出力先名と対応するスプールサーバのIPアドレスが表示されます。

［説明］

出力先の説明が表示されます。

［追加］ボタン

［出力先の追加］ダイアログが表示され，出力先が登録できます。ただし，出力先の登録数が上限を超えていた場合は，不活性になります。最大登録数のデフォルトは，65,536個です。

［変更］ボタン

［出力先の変更］ダイアログが表示され，出力先の情報が変更できます。

［削除］ボタン

削除を確認するダイアログが表示され，出力先が削除できます。

(b)　［出力先の追加］ダイアログ

［出力先］グループボックス

出力先名を登録するか，デフォルトの出力先を登録するかのどちらかを選択します。出力先は，［出力先名登録］ラジオボタン，または［デフォルト出力先］ラジオボタンを必ず指定してください。

［出力先名登録］ラジオボタン

出力先名を指定する場合に選択します。

［出力先名］テキストボックス

出力先名を入力します。80バイトまで入力できます。［出力先名登録］ラジオボタンを選択した場合は，必ず入力してください。ただし，制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」は入力できません。先頭と末尾の半角空白は登録時に削除されます。半角空白だけを入力した場合はエラーとなります。

すでに登録された出力先名は登録できません。

［デフォルト出力先］ラジオボタン

デフォルトの出力先を指定する場合に選択します。すでにデフォルトの出力先が登録されている場合は，選択できません。

デフォルト出力先には，帳票サーバで出力先名を指定していない場合，または指定された出力先が定義されていない場合に，出力するスプールサーバを定義します。

［IPアドレス］テキストボックス

出力先名と対応するスプールサーバのIPアドレスを255.255.255.255形式で入力します。IPアドレスは必ず指定してください。何も入力しなかった場合は，「0.0.0.0」で登録されます。

［説明］テキストボックス

出力先の説明を入力します。256バイトまで入力できます。ただし，制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」は入力できません。先頭と末尾の半角空白は登録時に削除されます。半角空白だけを入力した場合は，未入力となります。

(c)　［出力先の変更］ダイアログ

変更する出力先の設定内容が表示されます。［出力先の変更］ダイアログの各項目については，「(b)　［出力先の追加］ダイアログ」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 72 / 202


6.3.4 帳票サーバのプリンタクラスを登録する : EUR システム構築ガイド

  • 73 / 202

  • 表紙

  • 6.　帳票の出力環境を設定するファイルを準備する

  • 6.3　構成定義ファイルを作成するには

  • 6.3.4　帳票サーバのプリンタクラスを登録する

6.3.4　帳票サーバのプリンタクラスを登録する

帳票サーバのプリンタクラスを登録するために，帳票サーバプリンタクラス定義ファイルを作成します。

〈この項の構成〉

  • (1)　ダイアログを使用して作成する

  • (2)　サンプルファイルを編集して作成する

  • (3)　ダイアログの設定項目

(1)　ダイアログを使用して作成する

［EUR Server Service 構成定義］ダイアログで帳票サーバのプリンタクラスを登録すると，帳票サーバプリンタクラス定義ファイルが次のディレクトリに作成されます。

インストール先ディレクトリ\Server\Conf

［EUR Server Service 構成定義］ダイアログは，EUR製品のプログラムメニューから，［Server］－［Server Service 構成定義］を選択すると表示されます。なお，複数のEUR Server Serviceが起動管理定義に登録されている場合は，［EUR Server Service 構成定義］ダイアログが表示される前に，［サービスの選択］ダイアログが表示されます。

［識別名］

EUR Server Serviceの識別名が，登録した順に一覧で表示されます。

帳票サーバのプリンタクラスを登録，変更または削除したいEUR Server Serviceを選択して，［OK］ボタンをクリックすると，［EUR Server Service 構成定義］ダイアログが表示されます。

(a)　帳票サーバのプリンタクラスを登録する

帳票サーバのプリンタクラスの登録手順を次に示します。最大登録数のデフォルトは，65,536個です。

  1. ［EUR Server Service 構成定義］ダイアログの［プリンタクラス］タブを表示します。

  2. ［追加］ボタンをクリックします。

    ［プリンタクラスの追加］ダイアログが表示されます。

  3. 次の項目を設定します。

    • プリンタクラス（必須）

    • プリンタ名（必須）

    • トレイ名（任意）

    • 説明（任意）

  4. ［OK］ボタンをクリックします。

    プリンタクラスが［EUR Server Service 構成定義］ダイアログに追加されます。

    ただし，次の場合は，メッセージが表示されて，［プリンタクラスの追加］ダイアログに戻ります。

    • 指定が必須の項目が指定されていない場合

    • すでにデフォルトのプリンタクラス名が登録されている場合に，［デフォルトプリンタクラス］ラジオボタンを選択したとき

    • 同じプリンタクラス名が登録されている場合

    • 帳票サーバのプリンタクラス名，プリンタ名，トレイ名，および説明が入力できる文字数を超えている場合

    • 帳票サーバのプリンタクラス名，プリンタ名，トレイ名，および説明に入力できない文字があった場合

    • 帳票サーバのプリンタクラス名，プリンタ名，およびトレイ名に半角空白だけを入力した場合

(b)　帳票サーバのプリンタクラスを変更する

帳票サーバのプリンタクラスの変更手順を次に示します。

  1. ［EUR Server Service 構成定義］ダイアログの［プリンタクラス］タブを表示します。

  2. 変更するプリンタクラスを選択して，［変更］ボタンをクリックします。

    ［プリンタクラスの変更］ダイアログが表示されます。

  3. 設定内容を変更します。

  4. ［OK］ボタンをクリックします。

    プリンタクラスが変更されます。変更後の登録内容が［EUR Server Service 構成定義］ダイアログに表示されます。

    ただし，次の場合は，メッセージが表示されて，［プリンタクラスの変更］ダイアログに戻ります。

    • 指定が必須の項目が指定されていない場合

    • すでにデフォルトの帳票サーバのプリンタクラスが登録されている場合に，［デフォルトプリンタクラス］ラジオボタンを選択したとき

    • 同じプリンタクラス名が登録されている場合

    • 帳票サーバのプリンタクラス名，プリンタ名，トレイ名，および説明が入力できる文字数を超えている場合

    • 帳票サーバのプリンタクラス名，プリンタ名，トレイ名，および説明に入力できない文字があった場合

    • 帳票サーバのプリンタクラス名，プリンタ名，およびトレイ名に半角空白だけを入力した場合

(c)　帳票サーバのプリンタクラスを削除する

帳票サーバのプリンタクラスの削除手順を次に示します。

  1. ［EUR Server Service 構成定義］ダイアログの［プリンタクラス］タブを表示します。

  2. 削除するプリンタクラスを選択して，［削除］ボタンをクリックします。

    削除を確認するダイアログが表示されます。

  3. ［OK］ボタンをクリックします。

    プリンタクラスが削除されます。

ページの先頭へ

(2)　サンプルファイルを編集して作成する

作成手順を次に示します。

  1. 帳票サーバプリンタクラス定義ファイル（PMPrinterClass.conf）のサンプルを任意の場所に保存します。

  2. 帳票サーバプリンタクラス定義ファイルを編集します。

    帳票サーバプリンタクラス定義ファイルは，マシンのロケールに応じたエンコードで編集してください。

作成したファイルは，同じファイル名（PMPrinterClass.conf）で「表6-2　構成定義ファイルの種類と格納先」に示す格納先に格納してください。また，格納先には，EUR Server Serviceを利用するユーザが読み書きできるようにアクセス権を設定してください。

帳票サーバプリンタクラス定義ファイルの設定項目については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

(3)　ダイアログの設定項目

帳票サーバプリンタクラス定義ファイルの作成で使用するダイアログの設定項目について説明します。

(a)　［EUR Server Service 構成定義］ダイアログ（［プリンタクラス］タブ）

［EUR Server Service 構成定義］ダイアログのタイトルバーには，選択したEUR Server Serviceの識別名が表示されます。

［プリンタクラス一覧］

登録した帳票サーバのプリンタクラスの一覧が表示されます。［プリンタクラス名］，［プリンタ名］，［トレイ名］，または［説明］をクリックすると，Shift-JISのコード順にソートして表示されます。

［プリンタクラス名］

登録した帳票サーバのプリンタクラス名が表示されます。帳票サーバのプリンタクラス名は，登録順に表示されます。デフォルトの帳票サーバのプリンタクラス名には，「"デフォルト"」と表示されます。

［プリンタ名］

帳票サーバのプリンタクラスに対応する，帳票サーバのプリンタが表示されます。

［トレイ名］

帳票サーバのプリンタクラスに対応する，帳票サーバのプリンタのトレイが表示されます。

［説明］

帳票サーバのプリンタクラスの説明が表示されます。

［追加］ボタン

［プリンタクラスの追加］ダイアログが表示され，帳票サーバのプリンタクラスが登録できます。ただし，帳票サーバのプリンタクラスの登録数が上限を超えていた場合は，不活性になります。最大登録数のデフォルトは，65,536個です。

［変更］ボタン

［プリンタクラスの変更］ダイアログが表示され，帳票サーバのプリンタクラスの情報が変更できます。

［削除］ボタン

削除を確認するダイアログが表示され，帳票サーバのプリンタクラスの情報が削除できます。

(b)　［プリンタクラスの追加］ダイアログ

［プリンタクラス］グループボックス

帳票サーバのプリンタクラス名を登録するか，デフォルトの帳票サーバのプリンタクラス名を登録するかのどちらかを選択します。［プリンタクラス名登録］ラジオボタン，または［デフォルトプリンタクラス］ラジオボタンを必ず指定してください。

［プリンタクラス名登録］ラジオボタン

帳票サーバのプリンタクラス名を指定する場合に選択します。

［プリンタクラス名］テキストボックス

帳票サーバのプリンタクラス名を入力します。80バイトまで入力できます。ただし，制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」は入力できません。先頭と末尾の半角空白は登録時に削除されます。半角空白だけを入力した場合はエラーとなります。

［プリンタクラス名登録］ラジオボタンを選択した場合は，必ず入力してください。すでに登録されている帳票サーバのプリンタクラス名は登録できません。

［デフォルトプリンタクラス］ラジオボタン

デフォルトの帳票サーバのプリンタクラスを指定する場合に選択します。すでにデフォルトの帳票サーバのプリンタクラスが登録されている場合は，選択できません。

デフォルトの帳票サーバのプリンタクラスには，起動部品でプリンタクラスを指定していない場合，または指定されたプリンタクラスが定義されていない場合に，印刷するプリンタを定義します。

［プリンタ名］リストボックス

帳票サーバに登録されている，帳票サーバのプリンタ名が表示されます。プリンタ名は必ず指定してください。プリンタ名は，Shift-JISのコード順にソートして表示されます。

帳票サーバのプリンタ名に，制御コード（0x00～0x1F，0x7F～0x9F），「"」，または「,」を使用していた場合は，帳票サーバのプリンタクラスの登録時にエラーになります。

［トレイ名］リストボックス

［プリンタ名］リストボックスでプリンタ名を選択すると，選択したプリンタのトレイ名が表示されます。トレイ名は，Shift-JISのコード順にソートして表示されます。帳票サーバのプリンタのトレイ名に，制御コード（0x00～0x1F，0x7F～0x9F），「"」，または「,」を使用していた場合は，帳票サーバのプリンタクラスの登録時にエラーになります。

［説明］テキストボックス

帳票サーバのプリンタクラスの説明を入力します。256バイトまで入力できます。ただし，制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」は入力できません。先頭と末尾の半角空白は登録時に削除されます。半角空白だけを入力した場合は，未入力となります。

(c)　［プリンタクラスの変更］ダイアログ

変更するプリンタクラスの設定内容が表示されます。［プリンタ名］リストボックスでプリンタ名を変更すると，［トレイ名］リストボックスの表示は解除されます。［プリンタクラスの変更］ダイアログの各項目については，「(b)　［プリンタクラスの追加］ダイアログ」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 73 / 202


6.3.5 印刷先を登録する : EUR システム構築ガイド

  • 74 / 202

  • 表紙

  • 6.　帳票の出力環境を設定するファイルを準備する

  • 6.3　構成定義ファイルを作成するには

  • 6.3.5　印刷先を登録する

6.3.5　印刷先を登録する

帳票の蓄積時に指定する情報を印刷先として登録するために，印刷先定義ファイルを作成します。

作成手順を次に示します。

  1. 印刷先定義ファイル（PrintDest.conf）のサンプルを任意の場所に保存します。

  2. 印刷先定義ファイルを編集します。

    印刷先定義ファイルは，マシンのロケールに応じたエンコードで編集してください。

作成したファイルは，同じファイル名（PrintDest.conf）で「表6-2　構成定義ファイルの種類と格納先」に示す格納先に格納してください。また，格納先には，EUR Server Serviceを利用するユーザが読み書きできるようにアクセス権を設定してください。

印刷先定義ファイルの設定項目については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 74 / 202


6.3.6 スプールサーバのプリンタクラスを登録する : EUR システム構築ガイド

  • 75 / 202

  • 表紙

  • 6.　帳票の出力環境を設定するファイルを準備する

  • 6.3　構成定義ファイルを作成するには

  • 6.3.6　スプールサーバのプリンタクラスを登録する

6.3.6　スプールサーバのプリンタクラスを登録する

スプールサーバのプリンタクラスを登録するために，拠点プリンタクラス定義ファイルを作成します。

［EUR Spool Service 構成定義］ダイアログでスプールサーバのプリンタクラスを登録すると，拠点プリンタクラス定義ファイルが次のディレクトリに作成されます。

インストール先ディレクトリ\Spool\Conf

［EUR Spool Service 構成定義］ダイアログは，EUR製品のプログラムメニューから，［Server］－［Spool Service 構成定義］を選択すると表示されます。

〈この項の構成〉

  • (1)　スプールサーバのプリンタクラスを登録する

  • (2)　スプールサーバのプリンタクラスを変更する

  • (3)　スプールサーバのプリンタクラスを削除する

  • (4)　ダイアログの設定項目

(1)　スプールサーバのプリンタクラスを登録する

スプールサーバのプリンタクラスの登録手順を次に示します。最大登録数のデフォルトは，65,536個です。

  1. ［EUR Spool Service 構成定義］ダイアログの［プリンタクラス］タブを表示します。

  2. ［追加］ボタンをクリックします。

    ［プリンタクラスの追加］ダイアログが表示されます。

  3. 次の項目を設定します。

    • プリンタクラス（必須）

    • プリンタ名（必須）

    • トレイ名（任意）

    • 説明（任意）

  4. ［OK］ボタンをクリックします。

    プリンタクラスが［EUR Spool Service 構成定義］ダイアログに追加されます。

    ただし，次の場合は，メッセージが表示されて，［プリンタクラスの追加］ダイアログに戻ります。

    • 指定が必須の項目が指定されていない場合

    • すでにデフォルトの拠点プリンタクラスが登録されている場合に，［デフォルトプリンタクラス］ラジオボタンを選択したとき

    • 同じ拠点プリンタクラス名が登録されている場合

    • 拠点プリンタクラス名，プリンタ名，トレイ名，および説明が入力できる文字数を超えている場合

    • 拠点プリンタクラス名，プリンタ名，トレイ名，および説明に入力できない文字があった場合

    • 拠点プリンタクラス名，プリンタ名，およびトレイ名に半角空白だけを入力した場合

ページの先頭へ

(2)　スプールサーバのプリンタクラスを変更する

スプールサーバのプリンタクラスの変更手順を次に示します。

  1. ［EUR Spool Service 構成定義］ダイアログの［プリンタクラス］タブを表示します。

  2. 変更するプリンタクラスを選択して，［変更］ボタンをクリックします。

    ［プリンタクラスの変更］ダイアログが表示されます。

  3. 設定内容を変更します。

  4. ［OK］ボタンをクリックします。

    プリンタクラスが変更されます。変更後の登録内容が［EUR Spool Service 構成定義］ダイアログに表示されます。

    ただし，次の場合は，メッセージが表示されて，［プリンタクラスの変更］ダイアログに戻ります。

    • 指定が必須の項目が指定されていない場合

    • すでにデフォルトの拠点プリンタクラスが登録されている場合に，［デフォルトプリンタクラス］ラジオボタンを選択したとき

    • 同じ拠点プリンタクラス名が登録されている場合

    • 拠点プリンタクラス名，プリンタ名，トレイ名，および説明が入力できる文字数を超えている場合

    • 拠点プリンタクラス名，プリンタ名，トレイ名，および説明に入力できない文字があった場合

    • 拠点プリンタクラス名，プリンタ名，およびトレイ名に半角空白だけを入力した場合

ページの先頭へ

(3)　スプールサーバのプリンタクラスを削除する

スプールサーバのプリンタクラスの削除手順を次に示します。

  1. ［EUR Spool Service 構成定義］ダイアログの［プリンタクラス］タブを表示します。

  2. 削除するプリンタクラスを選択して，［削除］ボタンをクリックします。

    削除を確認するダイアログが表示されます。

  3. ［OK］ボタンをクリックします。

    プリンタクラスが削除されます。

ページの先頭へ

(4)　ダイアログの設定項目

拠点プリンタクラス定義ファイルの作成で使用するダイアログの設定項目について説明します。

(a)　［EUR Spool Service 構成定義］ダイアログ（［プリンタクラス］タブ）

［プリンタクラス一覧］

登録した拠点プリンタクラスの一覧が表示されます。［プリンタクラス名］，［プリンタ名］，［トレイ名］，または［説明］をクリックすると，Shift-JISのコード順にソートして表示されます。

［プリンタクラス名］

登録した拠点プリンタクラス名が表示されます。拠点プリンタクラス名は，登録順に表示されます。デフォルトの拠点プリンタクラスには，「"デフォルト"」と表示されます。

［プリンタ名］

拠点プリンタクラス名と対応するスプールサーバのプリンタが表示されます。

［トレイ名］

拠点プリンタクラス名と対応するスプールサーバのプリンタのトレイが表示されます。

［説明］

拠点プリンタクラスの説明が表示されます。

［追加］ボタン

［プリンタクラスの追加］ダイアログが表示され，拠点プリンタクラスが登録できます。ただし，拠点プリンタクラスの登録数が上限を超えていた場合は，不活性になります。最大登録数のデフォルトは，65,536個です。

［変更］ボタン

［プリンタクラスの変更］ダイアログが表示され，拠点プリンタクラスの情報が変更できます。

［削除］ボタン

削除を確認するダイアログが表示され，拠点プリンタクラスが削除できます。

(b)　［プリンタクラスの追加］ダイアログ

［プリンタクラス］グループボックス

拠点プリンタクラス名を登録するか，デフォルトの拠点プリンタクラスを登録するかのどちらかを選択します。拠点プリンタクラス名は，［プリンタクラス名登録］ラジオボタン，または［デフォルトプリンタクラス］ラジオボタンを必ず指定してください。

［プリンタクラス名登録］ラジオボタン

拠点プリンタクラス名を指定する場合に選択します。

［プリンタクラス名］テキストボックス

拠点プリンタクラス名を入力します。80バイトまで入力できます。［プリンタクラス名登録］ラジオボタンを選択した場合は，必ず入力してください。ただし，制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」は入力できません。先頭と末尾の半角空白は登録時に削除されます。半角空白だけを入力した場合はエラーとなります。

すでに登録された拠点プリンタクラス名は登録できません。

［デフォルトプリンタクラス］ラジオボタン

デフォルトの拠点プリンタクラスを指定する場合に選択します。すでにデフォルトの拠点プリンタクラスが登録されている場合は，選択できません。

デフォルトの拠点プリンタクラスには，起動部品でプリンタクラスを指定していない場合，または指定されたプリンタクラスが定義されていない場合に，印刷するプリンタを定義します。

［プリンタ名］リストボックス

スプールサーバに登録された拠点プリンタクラス名が表示されます。プリンタ名は必ず指定してください。プリンタ名は，Shift-JISのコード順にソートして表示されます。スプールサーバのプリンタ名に，制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」を使用していた場合は，拠点プリンタクラスの登録時にエラーになります。

［トレイ名］リストボックス

［プリンタ名］リストボックスでプリンタ名を選択すると，選択したプリンタのトレイ名が表示されます。トレイ名は，Shift-JISのコード順にソートして表示されます。スプールサーバのプリンタのトレイ名に，制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」を使用していた場合は，拠点プリンタクラスの登録時にエラーになります。

［説明］テキストボックス

拠点プリンタクラスの説明を入力します。256バイトまで入力できます。ただし，制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」は入力できません。先頭と末尾の半角空白は登録時に削除されます。半角空白だけを入力した場合は，未入力となります。

(c)　［プリンタクラスの変更］ダイアログ

変更するプリンタクラスの設定内容が表示されます。［プリンタ名］リストボックスでプリンタ名を変更すると，［トレイ名］リストボックスの表示は解除されます。［プリンタクラスの変更］ダイアログの各項目については，「(b)　［プリンタクラスの追加］ダイアログ」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 75 / 202


6.3.7 帳票振り分け定義を登録する : EUR システム構築ガイド

  • 76 / 202

  • 表紙

  • 6.　帳票の出力環境を設定するファイルを準備する

  • 6.3　構成定義ファイルを作成するには

  • 6.3.7　帳票振り分け定義を登録する

6.3.7　帳票振り分け定義を登録する

帳票振り分け定義を登録するために，帳票振り分け定義ファイルを作成します。

［EUR Spool Service 構成定義］ダイアログでスプールサーバの帳票振り分け定義を登録すると，帳票振り分け定義ファイルが次のディレクトリに作成されます。

インストール先ディレクトリ\Spool\Conf

［EUR Spool Service 構成定義］ダイアログは，EUR製品のプログラムメニューから，［Server］－［Spool Service 構成定義］を選択すると表示されます。

〈この項の構成〉

  • (1)　帳票振り分け定義を登録する

  • (2)　帳票振り分け定義を変更する

  • (3)　帳票振り分け定義を削除する

  • (4)　ダイアログの設定項目

(1)　帳票振り分け定義を登録する

帳票振り分け定義の登録手順を次に示します。最大登録数のデフォルトは，65,536個です。

  1. ［EUR Spool Service 構成定義］ダイアログの［帳票振り分け］タブを表示します。

  2. ［追加］ボタンをクリックします。

    ［帳票振り分け定義の追加］ダイアログが表示されます。

  3. 次の項目を設定します。

    • 振り分けグループ（必須）

    • 帳票（必須）

    • プリンタクラス名（必須）

    • 説明（任意）

  4. ［OK］ボタンをクリックします。

    帳票振り分け定義が［EUR Spool Service 構成定義］ダイアログに追加されます。

    ただし，次の場合は，メッセージが表示されて，［帳票振り分け定義の追加］ダイアログに戻ります。

    • 指定が必須の項目が指定されていない場合

    • 同じ組み合わせの振り分けグループ名と帳票名が登録されている場合

    • 振り分けグループ名，帳票名，説明が入力できる文字数を超えている場合

    • 振り分けグループ名，帳票名，説明に入力できない文字があった場合

    • 振り分けグループ名または帳票名に半角空白だけを入力した場合

ページの先頭へ

(2)　帳票振り分け定義を変更する

帳票振り分け定義の変更手順を次に示します。

  1. ［EUR Spool Service 構成定義］ダイアログの［帳票振り分け］タブを表示します。

  2. 変更する帳票振り分け定義を選択して，［変更］ボタンをクリックします。

    ［帳票振り分け定義の変更］ダイアログが表示されます。

  3. 設定内容を変更します。

  4. ［OK］ボタンをクリックします。

    帳票振り分け定義が変更されます。変更後の登録内容が［EUR Spool Service 構成定義］ダイアログに表示されます。

    ただし，次の場合は，メッセージが表示されて，［帳票振り分け定義の変更］ダイアログに戻ります。

    • 指定が必須の項目が指定されていない場合

    • 同じ組み合わせの振り分けグループ名と帳票名が登録されている場合

    • 振り分けグループ名，帳票名，説明が入力できる文字数を超えている場合

    • 振り分けグループ名，帳票名，説明に入力できない文字があった場合

    • 振り分けグループ名または帳票名に半角空白だけを入力した場合

ページの先頭へ

(3)　帳票振り分け定義を削除する

帳票振り分け定義の削除手順を次に示します。

  1. ［EUR Spool Service 構成定義］ダイアログの［帳票振り分け］タブを表示します。

  2. 削除する帳票振り分け定義を選択して，［削除］ボタンをクリックします。

    削除を確認するダイアログが表示されます。

  3. ［OK］ボタンをクリックします。

    帳票振り分け定義が削除されます。

ページの先頭へ

(4)　ダイアログの設定項目

帳票振り分け定義ファイルの作成で使用するダイアログの設定項目について説明します。

(a)　［EUR Spool Service 構成定義］ダイアログ（［帳票振り分け］タブ）

［帳票振り分け一覧］

登録した帳票振り分け定義の一覧が表示されます。［振り分けグループ名］，［帳票名］，［プリンタクラス名］，または［説明］をクリックすると，Shift-JISのコード順にソートして表示されます。

［振り分けグループ名］

帳票名を分類した振り分けグループ名が表示されます。振り分けグループは，帳票振り分け時に帳票を識別するキーとなります。振り分けグループ名は，登録順に表示されます。デフォルトの振り分けグループには，「"デフォルト"」と表示されます。

［帳票名］

振り分けグループ名に分類された帳票名が表示されます。帳票名は，帳票振り分け時に分類された振り分けグループを識別するキーとなります。

［プリンタクラス名］

［振り分けグループ名］と［帳票名］の組み合わせに対応する拠点プリンタクラス名が表示されます。

［説明］

帳票振り分け定義の説明が表示されます。

［追加］ボタン

［帳票振り分け定義の追加］ダイアログが表示され，帳票振り分け定義が登録できます。ただし，帳票振り分け定義の登録数が上限を超えていた場合は，不活性になります。最大登録数のデフォルトは，65,536個です。

［変更］ボタン

［帳票振り分け定義の変更］ダイアログが表示され，帳票振り分け定義の情報が変更できます。

［削除］ボタン

削除を確認するダイアログが表示され，帳票振り分け定義が削除できます。

(b)　［帳票振り分け定義の追加］ダイアログ

［振り分けグループ］グループボックス

振り分けグループ名を登録するか，デフォルトの振り分けグループを登録するかのどちらかを選択します。振り分けグループ名は，［振り分けグループ名登録］ラジオボタン，または［デフォルト振り分けグループ］ラジオボタンを必ず指定してください。

［振り分けグループ名登録］ラジオボタン

振り分けグループ名を指定する場合に選択します。

［振り分けグループ名］テキストボックス

振り分けグループ名を入力します。80バイトまで入力できます。［振り分けグループ名登録］ラジオボタンを選択した場合は，必ず入力してください。ただし，制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」は入力できません。先頭と末尾の半角空白は登録時に削除されます。半角空白だけを入力した場合はエラーとなります。

［デフォルト振り分けグループ］ラジオボタン

デフォルトの振り分けグループを指定する場合に選択します。

デフォルトの振り分けグループには，帳票サーバで振り分けグループを指定していない，または指定された振り分けグループが定義されていない帳票が分類されます。

［帳票］グループボックス

帳票名を登録するか，デフォルトの帳票を登録するかのどちらかを選択します。帳票は，［帳票名登録］ラジオボタン，または［デフォルト帳票］ラジオボタンを必ず指定してください。

［帳票名登録］ラジオボタン

帳票名を指定する場合に選択します。

［帳票名］テキストボックス

帳票名を入力します。256バイトまで入力できます。［帳票名登録］ラジオボタンを選択した場合は，必ず入力してください。ただし，ファイル名に使用できない文字（\　/　:　;　*　?　"　<　>　|），制御コード（0x00～0x1F，0x7F～0x9F），および「,」は入力できません。先頭と末尾の半角空白は登録時に削除されます。半角空白だけを入力した場合はエラーとなります。

［デフォルト帳票］ラジオボタン

デフォルトの帳票を指定する場合に選択します。デフォルトの帳票を選択した場合，振り分けグループに分類していない帳票はデフォルト帳票で設定したプリンタクラスで印刷されます。

［プリンタクラス名］リストボックス

スプールサーバに登録された拠点プリンタクラス名がリストボックスで表示されます。拠点プリンタクラス名は，必ず指定してください。拠点プリンタクラス名は，Shift-JISのコード順にソートして表示されます。ただし，デフォルトの拠点プリンタクラスは，表示されません。

拠点プリンタクラス名に，制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」を使用していた場合は，帳票振り分け定義の登録時にエラーになります。

［説明］テキストボックス

帳票振り分け定義の説明を入力します。256バイトまで入力できます。ただし，制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」は入力できません。先頭と末尾の半角空白は登録時に削除されます。半角空白だけを入力した場合は，未入力となります。

(c)　［帳票振り分け定義の変更］ダイアログ

変更する帳票振り分け定義の設定内容が表示されます。［帳票振り分け定義の変更］ダイアログの各項目については，「(b)　［帳票振り分け定義の追加］ダイアログ」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 76 / 202


6.3.8 スプールデータを操作するユーザを登録する : EUR システム構築ガイド

  • 77 / 202

  • 表紙

  • 6.　帳票の出力環境を設定するファイルを準備する

  • 6.3　構成定義ファイルを作成するには

  • 6.3.8　スプールデータを操作するユーザを登録する

6.3.8　スプールデータを操作するユーザを登録する

スプールデータを操作するユーザを登録するために，ユーザ管理ファイルを作成します。

〈この項の構成〉

  • (1)　ダイアログを使用して作成する

  • (2)　サンプルファイルを編集して作成する

  • (3)　ダイアログの設定項目

(1)　ダイアログを使用して作成する

［EUR Spool Service 構成定義］ダイアログでユーザ定義を登録すると，ユーザ管理ファイルが次のディレクトリに作成されます。

インストール先ディレクトリ\Spool\Conf

［EUR Spool Service 構成定義］ダイアログは，EUR製品のプログラムメニューから，［Server］－［Spool Service 構成定義］を選択すると表示されます。

(a)　ユーザ定義を登録する

ユーザ定義の登録手順を次に示します。最大100,000件のユーザ定義を登録できます。

  1. ［EUR Spool Service 構成定義］ダイアログの［ユーザ定義］タブを表示します。

  2. ［ユーザ名に使用する分類名］を設定します。

  3. ［追加］ボタンをクリックします。

    ［ユーザ定義の追加］ダイアログが表示されます。

  4. 次の項目を設定します。

    • ユーザ（必須）

    • アクセス制限方式（任意）

    • ユーザ名が一致する帳票の扱い（任意）

    • 分類の詳細設定（任意）

  5. ［OK］ボタンをクリックします。

    ユーザ定義が［EUR Spool Service 構成定義］ダイアログに追加されます。

    ただし，次の場合は，メッセージが表示されて，［ユーザ定義の追加］ダイアログに戻ります。

    • ユーザ名，確認キー，またはアクセス許可キーに使用する分類名が入力できる文字数を超えている場合

    • ユーザ名，確認キー，またはアクセス許可キーに使用する分類名に入力できない文字があった場合

    • ユーザ名がすでに存在する場合

    • ユーザ名が未入力の場合

    • アクセス許可キーに使用する分類名に半角空白だけを入力した場合

(b)　ユーザ定義を変更する

ユーザ定義の変更手順を次に示します。

  1. ［EUR Spool Service 構成定義］ダイアログの［ユーザ定義］タブを表示します。

  2. 変更するユーザ定義を選択して，［変更］ボタンをクリックします。

    ［ユーザ定義の変更］ダイアログが表示されます。

  3. 設定内容を変更します。

  4. ［OK］ボタンをクリックします。

    ユーザ定義が変更されます。変更後の登録内容が［EUR Spool Service 構成定義］ダイアログに表示されます。

    ただし，次の場合は，メッセージが表示されて，［ユーザ定義の変更］ダイアログに戻ります。

    • アクセス許可キーに使用する分類名が入力できる文字数を超えている場合

    • アクセス許可キーに使用する分類名に入力できない文字があった場合

    • アクセス許可キーに使用する分類名に半角空白だけを入力した場合

(c)　ユーザ定義を削除する

ユーザ定義の削除手順を次に示します。

  1. ［EUR Spool Service 構成定義］ダイアログの［ユーザ定義］タブを表示します。

  2. 削除するユーザ定義を選択して，［削除］ボタンをクリックします。

    削除を確認するダイアログが表示されます。

  3. ［OK］ボタンをクリックします。

    ユーザ定義が削除されます。

ページの先頭へ

(2)　サンプルファイルを編集して作成する

作成手順を次に示します。

  1. ユーザ管理ファイル（userdef.conf）のサンプルを任意の場所に保存します。

  2. ユーザ管理ファイルを編集します。

    ユーザ管理ファイルは，マシンのロケールに応じたエンコードで編集してください。

作成したファイルは，同じファイル名（userdef.conf）で「表6-2　構成定義ファイルの種類と格納先」に示す格納先に格納してください。また，格納先には，EUR Server - Spool Serviceを利用するユーザが読み書きできるようにアクセス権を設定してください。

ユーザ管理ファイルの設定項目については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

(3)　ダイアログの設定項目

ユーザ管理ファイルの作成で使用するダイアログの設定項目について説明します。

(a)　［EUR Spool Service 構成定義］ダイアログ（［ユーザ定義］タブ）

［ユーザ名一覧］

ユーザ定義に登録されているユーザ名が一覧で表示されます。初期表示では定義順で表示され，［ユーザ名］をクリックすると，Shift JISのコード順にソートして表示されます。なお，ユーザ名は複数選択できません。なお，デフォルトユーザの場合は，「"デフォルト"」と表示されます。

［ユーザ名］

ユーザ名が表示されます。

［ユーザ名に使用する分類名］テキストボックス

ユーザ名に使用するジョブ検索キーの分類名を入力します。80バイトまで入力できます。ただし，制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」は入力できません。先頭と末尾の半角空白は登録時に削除されます。半角空白だけを入力した場合は未入力と見なされます。

［追加］ボタン

［ユーザ定義の追加］ダイアログが表示され，ユーザ定義を登録できます。ただし，ユーザ定義の登録数が上限を超えていた場合は，不活性になります。最大100,000件のユーザ定義を登録できます。

［変更］ボタン

［ユーザ定義の変更］ダイアログが表示され，ユーザ定義の情報を変更できます。

［削除］ボタン

削除を確認するダイアログが表示され，ユーザ定義に登録されているユーザを削除できます。

(b)　［ユーザ定義の追加］ダイアログ

［ユーザ］グループボックス

ユーザを登録するか，デフォルトユーザを登録するかのどちらかを選択します。

［ユーザ登録］ラジオボタン

ユーザを登録する場合に選択します。

［ユーザ名］テキストボックス

ユーザ名を入力します。［ユーザ登録］ラジオボタンを選択した場合は，必ず入力してください。80バイトまで入力できます。ただし，制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」は入力できません。帳票管理GUIを利用するときは，「#」，「&」，「+」，「\」を入力すると正しく動作しません。先頭と末尾の半角空白は登録時に削除されます。半角空白だけを入力した場合は未入力と見なされます。

なお，すでに登録されているユーザは登録できません。

［確認キー］テキストボックス

ユーザの確認キーを入力します。［ユーザ登録］ラジオボタンを選択した場合は，必ず入力してください。半角文字で80バイトまで入力できます。ただし，制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」は入力できません。帳票管理GUIを利用するときは，「#」，「&」，「+」，「\」を入力すると正しく動作しません。入力した文字列は「*」で表示されます。

［デフォルトユーザ］ラジオボタン

デフォルトユーザを登録する場合に選択します。

［デフォルトユーザ］ラジオボタンを選択した場合，アクセス制限の対象としないスプールデータにアクセスするための最低限の権限を持つユーザとしてスプールデータにアクセスできます。

［アクセス制限］タブ

ユーザがアクセスできるスプールデータの制限方法を設定します。

［アクセス制限方式］リストボックス

スプールデータのアクセス制限方式（表示するスプールデータ）を選択します。選択できるアクセス制限方式を次に示します。

  • 制限なし：すべてのスプールデータを表示します。

  • 全部：すべてのスプールデータを表示しないようにします。

  • 分類：［アクセス許可キー値一覧］に表示されているキー値と一致するスプールデータを表示します。

［ユーザ名が一致する帳票の扱い］グループボックス

ユーザ名と一致するジョブ検索キーのキー値を持つスプールデータにアクセスするかどうかを選択します。

［常にアクセス可能］ラジオボタン

アクセス制限方式に関係なく，常にユーザ名と一致するジョブ検索キーのキー値を持つスプールデータにアクセスします。

［アクセス制限方式に従う］ラジオボタン

ユーザ名と一致するジョブ検索キーのキー値を持つかどうかに関係なく，アクセス制限方式によって決められたスプールデータにアクセスします。

［アクセス許可キーに使用する分類名］テキストボックス

アクセスを許可するジョブ検索キーの分類名を入力します。80バイトまで入力できます。ただし，制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」は入力できません。先頭と末尾の半角空白は登録時に削除されます。半角空白だけを入力した場合は未入力と見なされます。

［アクセス許可キー分類名のない帳票の扱い］グループボックス

アクセスを許可する分類名がジョブ検索キーに設定されていないスプールデータにアクセスするかどうかを選択します。

［アクセス不可］ラジオボタン

アクセスを許可する分類名がジョブ検索キーに設定されていないスプールデータにアクセスしません。

［アクセス可能］ラジオボタン

アクセスを許可する分類名がジョブ検索キーに設定されていないスプールデータにアクセスします。

［アクセス許可キー値一覧］

ユーザにアクセスを許可するジョブ検索キーのキー値が一覧で表示されます。初期表示では定義順で表示され，項目名をクリックすると，Shift JISのコード順にソートして表示されます。最大1,024個のキー値を定義できます。

［項番］

アクセスを許可するジョブ検索キーのキー値の項番が表示されます。

［キー値］

ユーザにアクセスを許可するジョブ検索キーのキー値が表示されます。

［キー値］テキストボックス

［アクセス許可キー値一覧］にアクセスを許可するジョブ検索キーのキー値を追加するときに入力します。80バイトまで入力できます。ただし，制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」は入力できません。先頭と末尾の半角空白は登録時に削除されます。半角空白だけを入力した場合は未入力と見なされます。

すでに登録されているキー値は登録できません。

［追加］ボタン

［キー値］テキストボックスに入力した値を，［アクセス許可キー値一覧］に追加できます。［アクセス許可キー値一覧］に追加するときは，［アクセス許可キーに使用する分類名］テキストボックス，および［キー値］テキストボックスの両方の入力が必要です。

［削除］ボタン

削除を確認するダイアログが表示され，［アクセス許可キー値一覧］に追加したキー値を削除できます。

(c)　［ユーザ定義の変更］ダイアログ

変更するユーザ定義の設定内容が表示されます。［ユーザ定義の変更］ダイアログの各項目については，「(b)　［ユーザ定義の追加］ダイアログ」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 77 / 202


6.3.9 クライアントのプリンタクラスを登録する : EUR システム構築ガイド

  • 78 / 202

  • 表紙

  • 6.　帳票の出力環境を設定するファイルを準備する

  • 6.3　構成定義ファイルを作成するには

  • 6.3.9　クライアントのプリンタクラスを登録する

6.3.9　クライアントのプリンタクラスを登録する

クライアントのプリンタクラスを登録するために，クライアントプリンタクラス定義ファイルを作成します。

［EUR Client 構成定義］ダイアログでクライアントのプリンタクラスを登録すると，クライアントプリンタクラス定義ファイルが次のディレクトリに作成されます。

インストール先ディレクトリ\Client\Conf

［EUR Client 構成定義］ダイアログは，EUR製品のプログラムメニューから，［Client］－［Client Service 構成定義］※を選択すると表示されます。

注※

EUR ClientのサイレントインストールでEUR Web Plug-Inだけをインストールした場合は作成されません。

〈この項の構成〉

  • (1)　クライアントのプリンタクラスを登録する

  • (2)　クライアントのプリンタクラスを変更する

  • (3)　クライアントのプリンタクラスを削除する

  • (4)　ダイアログの設定項目

(1)　クライアントのプリンタクラスを登録する

クライアントのプリンタクラスの登録手順を次に示します。最大登録数のデフォルトは，65,536個です。

  1. ［EUR Client 構成定義］ダイアログを表示します。

  2. ［追加］ボタンをクリックします。

    ［プリンタクラスの追加］ダイアログが表示されます。

  3. 次の項目を設定します。

    • プリンタクラス名（必須）

    • プリンタ名（必須）

    • トレイ名（任意）

    • 説明（任意）

  4. ［OK］ボタンをクリックします。

    プリンタクラスが［EUR Client 構成定義］ダイアログに追加されます。

    ただし，次の場合は，メッセージが表示されて，［プリンタクラスの追加］ダイアログに戻ります。

    • 指定が必須の項目が指定されていない場合

    • 同じクライアントプリンタクラス名が登録されている場合

    • クライアントプリンタクラス名，プリンタ名，トレイ名，および説明が入力できる文字数を超えている場合

    • クライアントプリンタクラス名，プリンタ名，トレイ名，および説明に入力できない文字があった場合

    • クライアントプリンタクラス名，プリンタ名，およびトレイ名に半角空白だけを入力した場合

ページの先頭へ

(2)　クライアントのプリンタクラスを変更する

クライアントのプリンタクラスの変更手順を次に示します。

  1. ［EUR Client 構成定義］ダイアログを表示します。

  2. 変更するプリンタクラスを選択して，［変更］ボタンをクリックします。

    ［プリンタクラスの変更］ダイアログが表示されます。

  3. 設定内容を変更します。

  4. ［OK］ボタンをクリックします。

    プリンタクラスが変更されます。変更後の登録内容が［EUR Client 構成定義］ダイアログに表示されます。

    ただし，次の場合は，メッセージが表示されて，［プリンタクラスの変更］ダイアログに戻ります。

    • 指定が必須の項目が指定されていない場合

    • 同じクライアントプリンタクラス名が登録されている場合

    • クライアントプリンタクラス名，プリンタ名，トレイ名，および説明が入力できる文字数を超えている場合

    • クライアントプリンタクラス名，プリンタ名，トレイ名，および説明に入力できない文字があった場合

    • クライアントプリンタクラス名，プリンタ名，およびトレイ名に半角空白だけを入力した場合

ページの先頭へ

(3)　クライアントのプリンタクラスを削除する

クライアントのプリンタクラスの削除手順を次に示します。

  1. ［EUR Client 構成定義］ダイアログを表示します。

  2. 削除するプリンタクラスを選択して，［削除］ボタンをクリックします。

    削除を確認するダイアログが表示されます。

  3. ［OK］ボタンをクリックします。

    プリンタクラスが削除されます。

ページの先頭へ

(4)　ダイアログの設定項目

クライアントプリンタクラス定義ファイルの作成で使用するダイアログの設定項目について説明します。

(a)　［EUR Client 構成定義］ダイアログ

［プリンタクラス一覧］

登録したクライアントプリンタクラスの一覧が表示されます。［プリンタクラス名］，［プリンタ名］，［トレイ名］，［説明］をクリックすると，Shift-JISのコード順にソートして表示されます。

［プリンタクラス名］

登録したクライアントプリンタクラス名が表示されます。クライアントプリンタクラス名は，登録順に表示されます。

［プリンタ名］

クライアントプリンタクラス名と対応するOS上のプリンタが表示されます。プリンタの種類と状態は，次に示すアイコンで示します。

  • [図データ] ：OS上の通常使うプリンタ

  • [図データ] ：OS上の通常使うプリンタ以外のOSに登録されているプリンタ

  • [図データ] ：OSに登録されていないプリンタ

    OSに登録されていないプリンタは，次に示すどちらかの場合に存在します。

    ・配布された構成定義ファイルを，テキストエディタなどで編集したとき

    ・プリンタクラス一覧に追加登録したプリンタを，OSから削除したり，名称変更したりしたとき

［トレイ名］

クライアントプリンタクラス名と対応するOS上のプリンタのトレイが表示されます。

［説明］

クライアントプリンタクラスの説明が表示されます。

［追加］ボタン

［プリンタクラスの追加］ダイアログが表示され，クライアントプリンタクラスが登録できます。ただし，クライアントプリンタクラスの登録数が上限を超えていた場合は，不活性になります。最大登録数のデフォルトは，65,536個です。

［変更］ボタン

［プリンタクラスの変更］ダイアログが表示され，クライアントプリンタクラスの情報が変更できます。

［削除］ボタン

削除を確認するダイアログが表示され，クライアントプリンタクラスが削除できます。

メモ

［EUR Client 構成定義］ダイアログはタスクトレイのアイコンから表示することもできます。

［構成定義］をクリックすると，［EUR Client 構成定義］ダイアログが表示されます。

［バージョン情報］をクリックすると，［バージョン情報］ダイアログが表示されます。

［終了］をクリックすると，EUR Client Serviceが終了します。

(b)　［プリンタクラスの追加］ダイアログ

［プリンタクラス］グループボックス

クライアントプリンタクラス名を登録するか，デフォルトのクライアントプリンタクラスを登録するかのどちらかを選択します。クライアントプリンタクラス名は，［プリンタクラス名登録］ラジオボタン，または［デフォルトプリンタクラス］ラジオボタンを必ず指定してください。

［プリンタクラス名登録］ラジオボタン

クライアントプリンタクラス名を指定する場合に選択します。

［プリンタクラス名］テキストボックス

クライアントプリンタクラス名を入力します。80バイトまで入力できます。［プリンタクラス名登録］ラジオボタンを選択した場合は，必ず入力してください。ただし，制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」は入力できません。先頭と末尾の半角空白は登録時に削除されます。半角空白だけを入力した場合はエラーとなります。

すでに登録されたクライアントプリンタクラス名は登録できません。

また，クライアントプリンタクラス名に「EUR_DELIVERY_PRINT_OUTPUT_DEFAULT_PRINTER_CLASS_________________________________」は使用できません。

［デフォルトプリンタクラス］ラジオボタン

デフォルトのクライアントプリンタクラスを指定する場合に選択します。すでにデフォルトのクライアントプリンタクラスが登録されている場合は，選択できません。

デフォルトのクライアントプリンタクラスには，起動部品でプリンタクラスを指定していない場合，または指定されたプリンタクラスが定義されていない場合に，印刷するプリンタを定義します。

［プリンタ名］リストボックス

OS上に登録されたプリンタ名が表示されます。プリンタ名は必ず選択してください。デフォルトは，OS上の通常使うプリンタです。プリンタ名は，Shift-JISのコード順にソートして表示されます。プリンタ名に，制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」を使用していた場合は，クライアントプリンタクラスの登録時にエラーになります。

［プリンタ名］リストボックスは，プリンタの種類と状態を次に示すアイコンで示します。

  • [図データ] ：OS上の通常使うプリンタ

  • [図データ] ：OS上の通常使うプリンタ以外のOSに登録されているプリンタ

［トレイ名］リストボックス

［プリンタ名］リストボックスでプリンタ名を選択すると，選択したプリンタのトレイ名が表示されます。トレイ名は，Shift-JISのコード順にソートして表示されます。トレイ名に，制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」を使用していた場合は，クライアントプリンタクラスの登録時にエラーになります。

［説明］テキストボックス

クライアントプリンタクラスの説明を入力します。256バイトまで入力できます。ただし，制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」は入力できません。先頭と末尾の半角空白は登録時に削除されます。半角空白だけを入力した場合は，未入力となります。

(c)　［プリンタクラスの変更］ダイアログ

変更するプリンタクラスの設定内容が表示されます。［プリンタ名］リストボックスでプリンタ名を変更すると，［トレイ名］リストボックスの表示は解除されます。［プリンタクラスの変更］ダイアログの各項目については，「(b)　［プリンタクラスの追加］ダイアログ」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 78 / 202


6.3.10 ファイル監視サービスの照合パターンを登録する : EUR システム構築ガイド

  • 79 / 202

  • 表紙

  • 6.　帳票の出力環境を設定するファイルを準備する

  • 6.3　構成定義ファイルを作成するには

  • 6.3.10　ファイル監視サービスの照合パターンを登録する

6.3.10　ファイル監視サービスの照合パターンを登録する

ファイル監視サービスの照合パターンを登録するために，監視定義ファイルを作成します。

〈この項の構成〉

  • (1)　テキストエディタなどで新規に作成する

(1)　テキストエディタなどで新規に作成する

監視定義ファイルは，テキストエディタなどで新規に作成します。マシンのロケールに応じたエンコードで作成してください。

作成した監視定義ファイルは，次に示すファイル名で「表6-2　構成定義ファイルの種類と格納先」に示す格納先に格納してください。また，格納先には，ファイル監視サービスを起動するアカウントが読み書きできるようにアクセス権を設定してください。

ファイル名

monitordef.conf

監視定義ファイルの設定項目については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 79 / 202


6.4 EURフォントファイルを作成するには : EUR システム構築ガイド

  • 80 / 202

  • 表紙

  • 6.　帳票の出力環境を設定するファイルを準備する

  • 6.4　EURフォントファイルを作成するには

6.4　EURフォントファイルを作成するには

EURフォントファイルは，Windows環境で作成した外字をUNIX／Linux環境で出力できるように変換したものです。Windows環境でもPDF形式ファイル出力の場合だけ使用できます。EURフォントファイルの作成時には，指定した文字が画像として収録されます。

作成したEURフォントファイルは，次に示すEUR Print Serviceの環境変数で指定したディレクトリに格納します。

  • EURPS_PDL_EXMINFONTPATH

    明朝体用として作成したEURフォントファイルを指定します。

  • EURPS_PDL_EXGOTFONTPATH

    ゴシック体用として作成したEURフォントファイルを指定します。

環境変数の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

〈この節の構成〉

  • 6.4.1　ファイルの作成方法

  • 6.4.2　EURフォントファイル作成ツールの使用方法

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 80 / 202


6.4.1 ファイルの作成方法 : EUR システム構築ガイド

  • 81 / 202

  • 表紙

  • 6.　帳票の出力環境を設定するファイルを準備する

  • 6.4　EURフォントファイルを作成するには

  • 6.4.1　ファイルの作成方法

6.4.1　ファイルの作成方法

EURフォントファイルの作成には，EURフォントファイル作成ツール（expedf32コマンド）を使用します。

EURフォントファイル作成ツールは，EUR Designer，EUR Developer，およびWindows環境のEUR Serverに同梱されています。EURフォントファイル作成ツールの格納先を次に示します。

インストール先ディレクトリ\Tool\Program

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 81 / 202


6.4.2 EURフォントファイル作成ツールの使用方法 : EUR システム構築ガイド

  • 82 / 202

  • 表紙

  • 6.　帳票の出力環境を設定するファイルを準備する

  • 6.4　EURフォントファイルを作成するには

  • 6.4.2　EURフォントファイル作成ツールの使用方法

6.4.2　EURフォントファイル作成ツールの使用方法

EURフォントファイル作成ツールは，コマンドラインで起動して使用します。EURフォントファイル作成ツールのコマンドの構文，オプション，および指定例を説明します。

〈この項の構成〉

  • (1)　EURフォントファイル作成ツールのコマンドの構文

  • (2)　オプションの説明

  • (3)　指定例

(1)　EURフォントファイル作成ツールのコマンドの構文

EURフォントファイル作成ツールのコマンドの構文を次に示します。

expedf32.exe
       /eudc 外字ファイル名 │ /base ベースフォント名
       /size ピクセルサイズ
       /out EURフォントファイル名

ページの先頭へ

(2)　オプションの説明

EURフォントファイル作成ツールで指定するオプションを説明します。オプションの文字列は，大文字，小文字を区別しません。

(a)　/eudcオプション

外字ファイル（*.tte）を指定します。

/eudcオプションを指定した場合は，フォントであらかじめ定義されている符号位置にも，外字ファイルで定義した文字が収録されます。

(b)　/baseオプション

外字ファイル（*.tte）を指定する代わりに，Windowsの外字エディタでの外字登録時に「指定したフォントにリンクする」として選択したフォント名（「ＭＳ 明朝」や「ＭＳ ゴシック」など）を指定します。指定したフォントにリンクする外字がEURフォントファイルに収録されます。

不正なフォント名称を指定した場合，Windowsによってデフォルトフォントが仮定されます。このとき，エラー（KEEU F0601-W）を出力して仮定したフォント名が通知されます。

なお，指定するフォントによっては，登録した外字が収録されない場合があります。

(c)　/sizeオプション

8から96までの8の整数倍の値を指定します。

指定したサイズが大きいほど，鮮明な文字を出力できますが，ファイルの容量が大きくなり，処理も遅くなるのでご注意ください。

(d)　/outオプション

作成するEURフォントファイル名を指定します。フォントの出力時に区別しやすいように，明朝体として作成したファイルか，ゴシック体として作成したファイルかがわかるようなファイル名にしておくと便利です。

ページの先頭へ

(3)　指定例

指定内容および指定例を次に示します。

(a)　Windowsの外字ファイルから，明朝体として使用するEURフォントファイルを作成する場合

指定内容

外字ファイル名 ：C:\WINDOWS\Fonts\EUDC.TTE

サイズ ：24ピクセル

EURフォントファイル名 ：msmin24.edf

指定例
インストール先ディレクトリ\Tool\Program\expedf32.exe
                          /eudc C:\WINDOWS\Fonts\EUDC.TTE
                          /size 24
                          /out C:\TEMP\msmin24.edf

(b)　ＭＳ 明朝にリンクされた外字から，明朝体として使用するEURフォントファイルを作成する場合

指定内容

ベースフォントファイル ：ＭＳ 明朝

サイズ ：24ピクセル

EURフォントファイル名 ：msmin24.edf

指定例
インストール先ディレクトリ\Tool\Program\expedf32.exe
                          /base "ＭＳ 明朝"
                          /size 24
                          /out C:\TEMP\msmin24.edf

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 82 / 202


7. 帳票サーバを構築する : EUR システム構築ガイド

  • 83 / 202

  • 表紙

  • 7.　帳票サーバを構築する

7.　帳票サーバを構築する

この章では，帳票サーバの構築方法について説明します。

〈この章の構成〉

  • 7.1　構築の流れ

  • 7.2　事前準備

  • 7.3　EUR Serverのインストール

  • 7.4　必要なファイルのインポート

  • 7.5　EUR Server Serviceの起動管理設定

  • 7.6　EUR Server - Spool Serviceの起動管理設定

  • 7.7　ファイル監視サービスの起動管理設定

  • 7.8　帳票管理GUIサービスの設定

  • 7.9　配送サービスの設定

  • 7.10　業務プログラムの配置と登録

  • 7.11　監査証跡管理システムとの連携

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 83 / 202


7.1 構築の流れ : EUR システム構築ガイド

  • 84 / 202

  • 表紙

  • 7.　帳票サーバを構築する

  • 7.1　構築の流れ

7.1　構築の流れ

帳票サーバの構築の流れを次の図に示します。構築する帳票システムのシステム構成に応じて，必要な作業を実施してください。

図7‒1　帳票サーバの構築の流れ

[図データ]

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 84 / 202


7.2 事前準備 : EUR システム構築ガイド

  • 85 / 202

  • 表紙

  • 7.　帳票サーバを構築する

  • 7.2　事前準備

7.2　事前準備

帳票サーバを構築する前に，事前に準備しておくことを次に示します。

  • マシンの準備（必須）

    帳票サーバとして使用するマシンを準備します。

  • インストール媒体の準備（必須）

    帳票サーバにインストールするEUR Serverの媒体を準備します。

    帳票サーバに帳票管理GUIサービスや業務プログラムを配置する場合は，Web/APサーバやJDKなどの前提製品のインストール媒体も準備します。

  • ファイルの準備（必須）

    帳票サーバに格納するファイルを準備します。準備方法については，次の章を参照してください。

    • 5.　帳票の出力内容を設定するファイルを準備する

    • 6.　帳票の出力環境を設定するファイルを準備する

  • 業務プログラムの準備（任意）

    帳票サーバに業務プログラムを配置する場合，配置する業務プログラムのプログラムファイルを準備します。

  • 構築で使用するユーザの作成（任意）

    必要に応じて，帳票サーバの構築で使用するユーザを作成します。

    帳票サーバの構築で使用するユーザには，必ず管理者権限を設定してください。

  • インストール先ディレクトリとアクセス権の設定（任意）

    必要に応じて，製品をインストールするためのディレクトリを作成します。

    作成したディレクトリには，帳票サーバを構築するユーザに対して，必要なアクセス権を設定してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 85 / 202


7.3 EUR Serverのインストール : EUR システム構築ガイド

  • 86 / 202

  • 表紙

  • 7.　帳票サーバを構築する

  • 7.3　EUR Serverのインストール

7.3　EUR Serverのインストール

ここでは，EUR Serverのインストール方法について説明します。

〈この節の構成〉

  • 7.3.1　インストール方法

  • 7.3.2　インストール後に作成されるディレクトリ

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 86 / 202


7.3.1 インストール方法 : EUR システム構築ガイド

  • 87 / 202

  • 表紙

  • 7.　帳票サーバを構築する

  • 7.3　EUR Serverのインストール

  • 7.3.1　インストール方法

7.3.1　インストール方法

〈この項の構成〉

  • (1)　インストールの前に

  • (2)　インストール手順

  • (3)　リモートインストール

  • (4)　注意事項

(1)　インストールの前に

  • 管理者権限を持つユーザでログインしてください。

  • インストール時に必要なディスク空き容量を確認してください。

  • ほかのユーザアプリケーションを終了してください。

  • OSから実行許可についてのダイアログが表示されることがあります。このときには，実行を許可する応答をしてください。

ページの先頭へ

(2)　インストール手順

EUR Serverのインストール方法は，Windows環境とUNIX／Linux環境とで異なります。

(a)　Windows環境の場合

EUR製品の統合CD-ROMをPCにセットすると，自動的に日立総合インストーラが起動されます。日立総合インストーラのウィンドウでEUR Serverを選択して，［インストール実行］ボタンをクリックしてください。インストールが開始されます。

インストール画面は，Windowsインストール時の言語で表示されます。ロケールが英語，中国語，日本語のどれでもない場合は英語で表示されます。ただし，サポートしていないロケールで実行した場合，EURの動作は保証されません。

(b)　UNIX／Linux環境の場合

UNIX／Linux環境の場合，日立PPインストーラを使用してインストールします。

日立PPインストーラは，提供された媒体に格納されています。次のことに注意して実行してください。

  • デバイススペシャルファイル名やCD-ROMのマウントディレクトリは，OS，ハード，および環境によって異なります。OSのマニュアルや使用環境を確認して実行してください。

  • 日立PPインストーラ実行時の言語種別と実行するターミナルの言語を一致させてください。

日立PPインストーラのメインメニューで［I］を選択すると，インストール画面が表示されます。インストール画面の例を次に示します。

        PP-NO.          VR                  PP-NAME
<@>001  形名        バージョン番号     EUR Server Enterprise
     ：
F) Forward B) Backward J) Down K) Up Space) Select/Unselect I) Install Q) Quit

EUR Serverにカーソルを移動させて，スペースキーを押します。選択した製品の左側に「<@>」が表示されます。続いて［I］を入力すると，最下行に次のメッセージが表示されます。

Install PP? (y: install,  n: cancel)==>

ここで，［y］または［Y］を選択するとインストールが開始されます。［y］または［Y］以外を選択すると，インストールが中止されてインストール画面に戻ります。

ページの先頭へ

(3)　リモートインストール

EUR Serverは，JP1/NETM/DMおよびGroupmax Remote Installationのリモートインストールに対応しています。操作・運用方法については，JP1/NETM/DMまたはGroupmax Remote Installationのマニュアルを参照してください。

ページの先頭へ

(4)　注意事項

  • EUR Serverのインストール後に，再起動を求めるダイアログが表示されることがあります。このときには，再起動を許可する応答をしてください。

  • バージョン9以降では，インストールされるヘルプファイルのディレクトリ構成が変更されています。業務プログラムでヘルプファイルを使用している場合は，プログラムのパスなどをバージョン9以降のディレクトリ構成に合わせて作成してください。ディレクトリ構成については，「7.3.2　インストール後に作成されるディレクトリ」を参照してください。

  • 使用する機能や設定ファイルなどの更新で，管理者権限が必要になる場合があります。

    使用する機能で管理者権限が必要になる場合の詳細については，「7.5.1　［EUR Server Service 起動管理］ダイアログを使用した起動管理」，「7.5.2　Server Service制御コマンドを使用した起動管理」，および「7.6.1　Spool Service制御コマンドを使用した起動管理」を参照してください。

    設定ファイルなどの更新で管理者権限が必要になる場合の詳細については，「付録A　Windows環境の場合の注意」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 87 / 202


7.3.2 インストール後に作成されるディレクトリ : EUR システム構築ガイド

  • 88 / 202

  • 表紙

  • 7.　帳票サーバを構築する

  • 7.3　EUR Serverのインストール

  • 7.3.2　インストール後に作成されるディレクトリ

7.3.2　インストール後に作成されるディレクトリ

EUR Serverのインストール後に作成されるディレクトリについて説明します。

〈この項の構成〉

  • (1)　Windows環境の場合

  • (2)　UNIX／Linux環境の場合

(1)　Windows環境の場合

表7‒1　EUR Serverのインストール後に作成されるディレクトリ（Windows環境の場合）

ディレクトリまたはファイル名

内容

エディション

%EUR%

EURのルートディレクトリ

E／S

  Document\

ドキュメントディレクトリ

E／S

    1033\

英語ドキュメント格納ディレクトリ

E／S

    1041\

日本語ドキュメント格納ディレクトリ

E／S

      Help\

ヘルプ格納ディレクトリ

E／S

        eursv.chm

EUR サーバ帳票出力ヘルプ（統合ヘルプ）

E／S

        eursysd.chm

マニュアル「EUR システム設計ガイド」のヘルプ

E／S

        eursysa.chm

マニュアル「EUR システム構築ガイド」のヘルプ

E／S

        eursman.chm

マニュアル「EUR 帳票出力 機能解説 EUR Server編」のヘルプ

E／S

        eursref.chm

マニュアル「EUR 帳票出力 リファレンス EUR Server編」のヘルプ

E／S

        eurdb.chm

マニュアル「EUR データベース連携ガイド」のヘルプ

E／S

        eurmes.chm

マニュアル「EUR メッセージ」のヘルプ

E／S

  Tool\Program\

共通ツールディレクトリ

E／S

    expedf32.exe

EURフォントファイル作成ツール

E／S

  Log\

ログディレクトリ

E／S

  Print\

  • EUR Print Serviceのルートディレクトリ

  • EUR Print Serviceの環境設定ファイル格納ディレクトリ（デフォルト）

E／S

    1033\

英語リソースディレクトリ

E／S

    1041\

日本語リソースディレクトリ

E／S

    2052\

中国語リソースディレクトリ

E／S

    Program\

実行ファイル格納ディレクトリ

E／S

      eurps.exe

EUR Print Service実行ファイル

E／S

      eurecdif.exe

接続情報パスワード暗号化ツール

E／S

      Eurtyl.exe

給紙トレイ一覧ツール

E／S

      EURPSEX.DLL

ActiveXオブジェクト（V8互換機能）

E／S

    Java\

JavaBeans起動部品（V8互換機能）格納ディレクトリ

E／S

      EURPSManager_5.jar

JavaBeans起動部品

E／S

      EURPSManager.properties

プロパティファイル

E／S

    Fonts\

フォントディレクトリ

E／S

  Server\

  • EUR Server Serviceのルートディレクトリ

  • EUR Server Serviceの環境設定ファイル格納ディレクトリ（デフォルト）

  • Server Service制御コマンド（eurpmctrlコマンド）の環境設定ファイル格納ディレクトリ

E／S

    Program\

実行ファイル格納ディレクトリ

E／S

      EURPM.exe

EUR Server Service実行ファイル

E／S

      EURPMCTRL.exe

Server Service制御コマンド（eurpmctrlコマンド）

E／S

      EURPMCTRLGUI.exe

［EUR Server Service 起動管理］ダイアログ実行ファイル

E／S

      EURPMUMM.exe

［EUR Server Service 構成定義］ダイアログ実行ファイル

E／S

    Conf\

構成定義ファイル格納ディレクトリ

E／S

    DBInfo\

接続情報ファイル格納ディレクトリ

E／S

    DocInfo\

文書情報設定ファイル格納ディレクトリ

E／S

    Form\

帳票ファイル格納ディレクトリ

E／S

    Multi\

複数様式情報定義ファイル格納ディレクトリ

E／S

    PDF\

PDF形式ファイル出力ディレクトリ

E／S

    Preference\

ビューアプレファレンス定義ファイル格納ディレクトリ

E／S

    PrintDate\

印刷日時出力定義ファイル格納ディレクトリ

E／S

    printnewpaper\

新規用紙出力定義ファイル格納ディレクトリ

E／S

    PSEnv\

EUR Print Serviceの環境設定ファイル格納ディレクトリ（デフォルト）

E／S

    ReplaceItem\

置き換え表管理情報ファイル格納ディレクトリ

E／S

    reportid\

帳票出力定義ファイル格納ディレクトリ

E／S

    ScriptCnt\

Acrobat JavaScript定義ファイル格納ディレクトリ

E／S

    Split\

分割定義ファイルまたは仕分け定義ファイル格納ディレクトリ

E／S

    Temp\

一時ファイルディレクトリ

E／S

  Adapter\

  • EUR Server - Adapterのルートディレクトリ

  • EUR Server - Adapterの環境設定ファイル格納ディレクトリ（デフォルト）

E／S

    Program\

実行ファイル格納ディレクトリ

E／S

      EURPMC.exe

コマンド起動部品（eurpmcコマンド）

E／S

      EURPMADP.ocx

ActiveX起動部品（32ビット版）

E／S

    Program(x64)\

実行ファイル格納ディレクトリ

E／S

      EURPMADP.ocx

ActiveX起動部品（64ビット版）

E／S

    Java\

Java起動部品格納ディレクトリ

E／S

      EURPMAdapter.jar

Java起動部品（32ビット版）

E／S

      EURPMADJ.dll

    Java(x64)\

Java起動部品格納ディレクトリ

E／S

      EURPMAdapter.jar

Java起動部品（64ビット版）

E／S

      EURPMADJ.dll

    COBOL\

COBOL起動部品格納ディレクトリ

E／S

      EURPMADC.dll

COBOL起動部品（32ビット版）

E／S

      EURPMADC.lib

    COBOL(x64)\

COBOL起動部品格納ディレクトリ

E／S

      EURPMADC.dll

COBOL起動部品（64ビット版）

E／S

      EURPMADC.lib

  Eursmpr\

  • BSP-RM連携コマンド（eursmprコマンド）のルートディレクトリ

  • BSP-RM連携コマンド（eursmprコマンド）の環境設定ファイル格納ディレクトリ

E／S

    program\

実行ファイル格納ディレクトリ

E／S

      eursmpr.exe

BSP-RM連携コマンド（eursmprコマンド）

E／S

    divdata\

制御情報付データファイル格納ディレクトリ

E／S

    runparam\

起動パラメタファイル格納ディレクトリ

E／S

    temp\

一時ファイルディレクトリ

E／S

  FileMonitor\

  • ファイル監視サービスのルートディレクトリ

  • ファイル監視サービスの環境設定ファイル格納ディレクトリ

E／S

    program\

実行ファイル格納ディレクトリ

E／S

      eurfm.exe

ファイル監視サービスプログラム

E／S

      eurivk.exe

ジョブ実行プログラム

E／S

    fmc\

監視管理ディレクトリ

E／S

      monitor\

監視ディレクトリ

E／S

      check\

照合ディレクトリ

E／S

      data\

完了ディレクトリ

E／S

    conf\

構成定義ファイル格納ディレクトリ

E／S

    runparam\

起動パラメタファイル格納ディレクトリ

E／S

  Spool\

  • EUR Server - Spool Serviceのルートディレクトリ

  • EUR Server - Spool Serviceの環境設定ファイル格納ディレクトリ（デフォルト）

E

    Program\

実行ファイル格納ディレクトリ

E

      EURPMLS.exe

EUR Server - Spool Service実行ファイル

E

      EURPMULM.exe

［EUR Spool Service 構成定義］ダイアログ実行ファイル

E

      EURSSECD.exe

LDAP接続情報暗号化ツール

E

    Conf\

構成定義ファイル格納ディレクトリ

E

    ESF\

スプールデータ格納ディレクトリ

E

    POB\

私書箱ディレクトリ

E

    Temp\

一時ファイルディレクトリ

E

  Spool Adapter\

  • EUR Server - Spool Service Adapterのルートディレクトリ

  • EUR Server - Spool Service Adapterの環境設定ファイル格納ディレクトリ（デフォルト）

  • 帳票管理GUIの環境設定ファイル格納ディレクトリ

E

    Program\

実行ファイル格納ディレクトリ

E

      EURPMLSC.exe

SS-コマンド起動部品（eurpmlscコマンド）

E

      EURPMLSADP.ocx

SS-ActiveX起動部品（32ビット版）

E

    Program(x64)\

実行ファイル格納ディレクトリ

E

      EURPMLSADP.ocx

SS-ActiveX起動部品（64ビット版）

E

    Java\

SS-Java起動部品格納ディレクトリ

E

      EURPMLSAdapter.jar

SS-Java起動部品（32ビット版）

E

      EURPMLSADJ.dll

    Java(x64)\

SS-Java起動部品格納ディレクトリ

E

      EURPMLSAdapter.jar

SS-Java起動部品（64ビット版）

E

      EURPMLSADJ.dll

  euraps\

EUR Application Service実行ファイル格納ディレクトリ（32ビット）

E

    bin\

E

      euraps.exe

EUR Application Service実行ファイル

E

      eurpmrsgui.ear

帳票管理GUIサービス

E

      eurssdeli.ear

配送サービス

E

  Sample\

サンプル格納ディレクトリ

E／S

    Server Service\

EUR Server Serviceサンプルファイル格納ディレクトリ

E／S

    Spool Service\

EUR Server - Spool Serviceサンプルファイル格納ディレクトリ

E

    mynumber\

マイナンバー対応の法定調書のサンプルファイル格納ディレクトリ※

E／S

  Component\

再配布パッケージ格納ディレクトリ

E／S

    ServerAdapter32\

EUR Server - Adapter再配布パッケージ格納ディレクトリ（32ビット）

E／S

      EURPM-ADP32.exe

Windows用再配布パッケージ（32ビット）

E／S

    ServerAdapter\

EUR Server - Adapter再配布パッケージ格納ディレクトリ

E／S

      EURPM-ADP.exe

Windows用再配布パッケージ（64ビット）

E／S

      EURPM-ADP-AIX.tar

AIX用再配布パッケージ

E／S

      EURPM-ADP-AIX.sh

      EURPM-ADP-HPIPF.tar

HP-UX用再配布パッケージ

E／S

      EURPM-ADP-HPIPF.sh

      EURPM-ADP-RHEL.tar

Linux用再配布パッケージ

E／S

      EURPM-ADP-RHEL.sh

    SpoolServer\

EUR Server - Spool Service再配布パッケージ格納ディレクトリ

E

      EURPM-LS.exe

Windows用再配布パッケージ

E

      eurpmrsgui.ear

再配布用の帳票管理GUIサービス

E

      eurssdeli.ear

再配布用の配送サービス

E

    SpoolAdapter32\

EUR Server - Spool Service Adapter再配布パッケージ格納ディレクトリ（32ビット）

E

      EURPM-LS-ADP32.exe

Windows用再配布パッケージ（32ビット）

E

    SpoolAdapter\

EUR Server - Spool Service Adapter再配布パッケージ格納ディレクトリ

E

      EURPM-LS-ADP.exe

Windows用再配布パッケージ（64ビット）

E

      EURPM-LS-ADP-AIX.tar

AIX用再配布パッケージ

E

      EURPM-LS-ADP-AIX.sh

      EURPM-LS-ADP-HPIPF.tar

HP-UX用再配布パッケージ

E

      EURPM-LS-ADP-HPIPF.sh

      EURPM-LS-ADP-RHEL.tar

Linux用再配布パッケージ

E

      EURPM-LS-ADP-RHEL.sh

    Client\

EUR Client再配布用パッケージ格納ディレクトリ

E／S

      EURPM-CL.exe

EUR Client再配布用パッケージ

E／S

      EURPMPrintAX.cab

マシン単位インストール用EUR Web Plug-Inダウンロードパッケージ（印刷用）

E／S

      EURPMPrintAX.inf

マシン単位インストール用EUR Web Plug-In情報ファイル（印刷用）

E／S

      EURPMPreViewAX.cab

マシン単位インストール用EUR Web Plug-Inダウンロードパッケージ（プレビュー用）

E／S

      EURPMPreViewAX.inf

マシン単位インストール用EUR Web Plug-In情報ファイル（プレビュー用）

E／S

      User\

ユーザ単位インストール用EUR Web Plug-Inダウンロードパッケージ格納ディレクトリ

E／S

        EURPMPrintAX.cab

ユーザ単位インストール用EUR Web Plug-Inダウンロードパッケージ（印刷用）

E／S

        EURPMPrintAX.inf

ユーザ単位インストール用EUR Web Plug-In情報ファイル（印刷用）

E／S

        EURPMPreViewAX.cab

ユーザ単位インストール用EUR Web Plug-Inダウンロードパッケージ（プレビュー用）

E／S

        EURPMPreViewAX.inf

ユーザ単位インストール用EUR Web Plug-In情報ファイル（プレビュー用）

E／S

    DABroker\

DABrokerのインストーラ格納ディレクトリ

E／S

      DABroker.msi

DABrokerのインストーラ

E／S

Hntrlib2

EUR Application Service用トレースライブラリ

E

Common

EUR Application Service共通モジュール

E
（凡例）

%EUR%：EUR Serverのインストール先ディレクトリを示します。

E：EUR Server Enterpriseをインストールすると作成されます。

S：EUR Server Standardをインストールすると作成されます。

注※

日本語のOSの場合だけ，インストール後にディレクトリが作成され，法定調書のサンプルファイルが格納されます。法定調書のサンプルファイルの提供範囲，利用方法，保証範囲については，「mynumber」下に格納されている「免責事項.txt」を参照してください。

ページの先頭へ

(2)　UNIX／Linux環境の場合

表7‒2　EUR Serverのインストール後に作成されるディレクトリ（UNIX／Linux環境の場合）

ディレクトリまたはファイル名

内容

エディション

/opt/eur/

EURのルートディレクトリ

E／S

  print/

EUR Print Serviceのルートディレクトリ

E／S

    C/

英語リソースディレクトリ

E／S

    ja_JP/

日本語リソースディレクトリ

E／S

    zh_CN/

中国語リソースディレクトリ

E／S

    bin/

実行ファイル格納ディレクトリ

E／S

      eurps

EUR Print Service実行ファイル

E／S

      eurecdif

接続情報パスワード暗号化ツール

E／S

    lib/

共有ライブラリディレクトリ

E／S

    java/

JavaBeans起動部品（V8互換機能）格納ディレクトリ

E／S

      EURPSManager_5.jar

JavaBeans起動部品

E／S

      EURPSManager.properties

プロパティファイル

E／S

    fonts/

フォントディレクトリ

E／S

  server/

EUR Server Serviceのルートディレクトリ

E／S

    bin/

実行ファイル格納ディレクトリ

E／S

      eurpmd

EUR Server Service実行ファイル

E／S

      eurpmctrl

Server Service制御コマンド（eurpmctrlコマンド）

E／S

    lib/

共有ライブラリディレクトリ

E／S

  adapter/

EUR Server - Adapterのルートディレクトリ

E／S

    bin/

実行ファイル格納ディレクトリ

E／S

      eurpmc

コマンド起動部品（eurpmcコマンド）

E／S

    java/

Java起動部品格納ディレクトリ

E／S

      EURPMAdapter.jar

Java起動部品（32ビット版・64ビット版共通）

E／S

    lib/

共有ライブラリディレクトリ

E／S

      libEURPMADJ.so

Java起動部品（32ビット版）

E／S

      libEURPMADC.so

COBOL起動部品

E／S

    lib64/

共有ライブラリディレクトリ

E／S

      libEURPMADJ.so

Java起動部品（64ビット版）

E／S

  spool/

EUR Server - Spool Serviceのルートディレクトリ

E

    bin/

実行ファイル格納ディレクトリ

E

      eurpmlsd

EUR Server - Spool Service実行ファイル

E

      eurpmlsctrl

Spool Service制御コマンド（eurpmlsctrlコマンド）

E

    lib/

共有ライブラリディレクトリ

E

  spool-adp/

EUR Server - Spool Service Adapterのルートディレクトリ

E

    bin/

実行ファイル格納ディレクトリ

E

      eurpmlsc

SS-コマンド起動部品（eurpmlscコマンド）

E

    java/

SS-Java起動部品格納ディレクトリ

E

      EURPMLSAdapter.jar

SS-Java起動部品（32ビット版・64ビット版共通）

E

    lib/

共有ライブラリディレクトリ

E

      libEURPMLSADJ.so

SS-Java起動部品（32ビット版）

E

    lib64/

共有ライブラリディレクトリ

E

      libEURPMLSADJ.so

SS-Java起動部品（64ビット版）

E

  sample/

サンプル格納ディレクトリ

E／S

    Server Service/

EUR Server Serviceサンプルファイル格納ディレクトリ

E／S

    Spool Service/

EUR Server - Spool Serviceサンプルファイル格納ディレクトリ

E

  component/

再配布パッケージ格納ディレクトリ

E／S

    server-adp32/

EUR Server - Adapter再配布パッケージ格納ディレクトリ（32ビット）

E／S

      EURPM-ADP32.exe

Windows用再配布パッケージ（32ビット）

E／S

    server-adp/

EUR Server - Adapter再配布パッケージ格納ディレクトリ

E／S

      EURPM-ADP.exe

Windows用再配布パッケージ（64ビット）

E／S

      EURPM-ADP-AIX.tar

AIX用再配布パッケージ

E／S

      EURPM-ADP-AIX.sh

      EURPM-ADP-HPIPF.tar

HP-UX用再配布パッケージ

E／S

      EURPM-ADP-HPIPF.sh

      EURPM-ADP-RHEL.tar

Linux用再配布パッケージ

E／S

      EURPM-ADP-RHEL.sh

    spool/

EUR Server - Spool Service再配布パッケージ格納ディレクトリ

E

      EURPM-LS.exe

Windows用再配布パッケージ

E

      EURPM-LS-AIX.tar

AIX用再配布パッケージ※

E

      EURPM-LS-AIX.sh

      EURPM-LS-HPIPF.tar

HP-UX用再配布パッケージ※

E

      EURPM-LS-HPIPF.sh

      EURPM-LS-RHEL.tar

Linux用再配布パッケージ※

E

      EURPM-LS-RHEL.sh

      eurpmrsgui.ear

再配布用の帳票管理GUIサービス

E

      eurssdeli.ear

再配布用の配送サービス

E

    spool-adp32/

EUR Server - Spool Service Adapter再配布パッケージ格納ディレクトリ（32ビット）

E

      EURPM-LS-ADP32.exe

Windows用再配布パッケージ（32ビット）

E

    spool-adp/

EUR Server - Spool Service Adapter再配布パッケージ格納ディレクトリ

E

      EURPM-LS-ADP.exe

Windows用再配布パッケージ（64ビット）

E

      EURPM-LS-ADP-AIX.tar

AIX用再配布パッケージ

E

      EURPM-LS-ADP-AIX.sh

      EURPM-LS-ADP-HPIPF.tar

HP-UX用再配布パッケージ

E

      EURPM-LS-ADP-HPIPF.sh

      EURPM-LS-ADP-RHEL.tar

Linux用再配布パッケージ

E

      EURPM-LS-ADP-RHEL.sh

    client/

EUR Client再配布用パッケージ格納ディレクトリ

E／S

      EURPM-CL.exe

EUR Client再配布用パッケージ

E／S

      EURPMPrintAX.cab

マシン単位インストール用EUR Web Plug-Inダウンロードパッケージ（印刷用）

E／S

      EURPMPrintAX.inf

マシン単位インストール用EUR Web Plug-In情報ファイル（印刷用）

E／S

      EURPMPreViewAX.cab

マシン単位インストール用EUR Web Plug-Inダウンロードパッケージ（プレビュー用）

E／S

      EURPMPreViewAX.inf

マシン単位インストール用EUR Web Plug-In情報ファイル（プレビュー用）

E／S

      user/

ユーザ単位インストール用EUR Web Plug-Inダウンロードパッケージ格納ディレクトリ

E／S

        EURPMPrintAX.cab

ユーザ単位インストール用EUR Web Plug-Inダウンロードパッケージ（印刷用）

E／S

        EURPMPrintAX.inf

ユーザ単位インストール用EUR Web Plug-In情報ファイル（印刷用）

E／S

        EURPMPreViewAX.cab

ユーザ単位インストール用EUR Web Plug-Inダウンロードパッケージ（プレビュー用）

E／S

        EURPMPreViewAX.inf

ユーザ単位インストール用EUR Web Plug-In情報ファイル（プレビュー用）

E／S

/etc/opt/eur/

  • EUR Print Serviceの設定ファイル格納ディレクトリ

  • EUR Print Serviceの環境設定ファイル格納ディレクトリ（デフォルト）

E／S

/var/opt/eur/

データディレクトリ

E／S

  server/

  • EUR Server Serviceの環境設定ファイル格納ディレクトリ（デフォルト）

  • Server Service制御コマンド（eurpmctrlコマンド）の環境設定ファイル格納ディレクトリ

  • 起動管理定義ファイル格納ディレクトリ

E／S

    Conf/

構成定義ファイル格納ディレクトリ

E／S

    DBInfo/

接続情報ファイル格納ディレクトリ

E／S

    DocInfo/

文書情報設定ファイル格納ディレクトリ

E／S

    Form/

帳票ファイル格納ディレクトリ

E／S

    Multi/

複数様式情報定義ファイル格納ディレクトリ

E／S

    PDF/

PDF形式ファイル出力ディレクトリ

E／S

    Preference/

ビューアプレファレンス定義ファイル格納ディレクトリ

E／S

    PrintDate/

印刷日時出力定義ファイル格納ディレクトリ

E／S

    PSEnv/

EUR Print Serviceの環境設定ファイル格納ディレクトリ

E／S

    ReplaceItem/

置き換え表管理情報ファイル格納ディレクトリ

E／S

    reportid/

帳票出力定義ファイル格納ディレクトリ

E／S

    ScriptCnt/

Acrobat JavaScript定義ファイル格納ディレクトリ

E／S

    Split/

分割定義ファイルまたは仕分け定義ファイル格納ディレクトリ

E／S

    Temp/

一時ファイルディレクトリ

E／S

  adapter/

EUR Server - Adapterの環境設定ファイル格納ディレクトリ（デフォルト）

E／S

  spool/

  • EUR Server - Spool Serviceの環境設定ファイル格納ディレクトリ（デフォルト）

  • Spool Service制御コマンド（eurpmlsctrlコマンド）の環境設定ファイル格納ディレクトリ

E

    Conf/

構成定義ファイル格納ディレクトリ

E

    ESF/

スプールデータ格納ディレクトリ

E

    POB/

私書箱ディレクトリ

E

    Temp/

一時ファイルディレクトリ

E

  spool-adp/

  • EUR Server - Spool Service Adapterの環境設定ファイル格納ディレクトリ（デフォルト）

  • 帳票管理GUIの環境設定ファイル格納ディレクトリ

E

  log/

ログディレクトリ

E／S
（凡例）

E：EUR Server Enterpriseをインストールすると作成されます。

S：EUR Server Standardをインストールすると作成されます。

注※

インストールしたEUR Server Enterpriseの適用OSと同じOSのパッケージだけがインストールされます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 88 / 202


7.4 必要なファイルのインポート : EUR システム構築ガイド

  • 89 / 202

  • 表紙

  • 7.　帳票サーバを構築する

  • 7.4　必要なファイルのインポート

7.4　必要なファイルのインポート

「5.　帳票の出力内容を設定するファイルを準備する」および「6.　帳票の出力環境を設定するファイルを準備する」で準備したファイルのうち，帳票サーバに格納するファイルをインポートします。帳票サーバのロケールに応じたエンコードを設定してインポートしてください。

帳票サーバにインポートするファイルを，次の表に示します。

表7‒3　帳票サーバにインポートするファイル

ファイルの種類

ファイル名

説明

帳票の出力内容を設定するファイル

帳票ファイル（*.fms），画像ファイルなど

必要なファイルをインポートします。

環境設定ファイル

EUR Server Serviceの環境設定ファイル（EURPM.ini）

必ずインポートします。

  • Server Service制御コマンド（eurpmctrlコマンド）の環境設定ファイル（EURPMCTRL.ini）

  • EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）

  • Spool Service制御コマンド（eurpmlsctrlコマンド）の環境設定ファイル（EURPMLSCTRL.ini）※1

  • EUR Server - Adapterの環境設定ファイル（EURPMADP.ini）

  • EUR Server - Spool Service Adapterの環境設定ファイル（EURPMLSADP.ini）

  • 帳票管理GUIの環境設定ファイル（EURPMRSGUI.ini）

  • EUR Print Serviceの環境設定ファイル（EURPS_ENVまたはeurps_env）

必要なファイルをインポートします。

構成定義ファイル

  • 出力先定義ファイル（Destination.conf）

  • 帳票サーバプリンタクラス定義ファイル（PMPrinterClass.conf）

  • 印刷先定義ファイル（PrintDest.conf）

  • 拠点プリンタクラス定義ファイル（ServerPrinterClass.conf）※2

  • 帳票振り分け定義ファイル（Distribution.conf）※2

  • ユーザ管理ファイル（userdef.conf）

  • 宛先定義ファイル（addrdef.conf）

EURフォントファイル

*.edf

必要に応じてインポートします。

EUR Application Service動作設定ファイル

euraps.ini

EUR Application Serviceを使用する場合にインポートします。
注※1

帳票サーバがWindows環境の場合，Spool Service制御コマンド（eurpmlsctrlコマンド）は使用できません。そのため，Spool Service制御コマンドの環境設定ファイル（EURPMLSCTRL.ini）のインポートは不要です。

注※2

帳票サーバがUNIX／Linux環境の場合，EUR Server - Spool Serviceの機能を使用して帳票サーバのプリンタに帳票を出力できません。そのため，次のファイルをインポートしても帳票出力には使用できません。

・拠点プリンタクラス定義ファイル（ServerPrinterClass.conf）

・帳票振り分け定義ファイル（Distribution.conf）

なお，ファイルのインポート後は次の作業を実施してください。

  • 環境設定ファイルをインポートした場合は，次のコンポーネントを再起動してください。

    • EUR Server Service

    • EUR Server - Adapterを使用しているプログラム

    • EUR Server - Spool Service

    • EUR Server - Spool Service Adapterを使用しているプログラム

    ただし，Server Service制御コマンド（eurpmctrlコマンド）の環境設定ファイルを変更した場合は，コンポーネントの再起動は必要ありません。Server Service制御コマンドの環境設定ファイルは，次にServer Service制御コマンドを実行したときから有効になります。

  • EUR Server Serviceの起動中に，環境設定ファイル（EURPMCTRL.ini）のPATHセクションのTEMPキーの値は変更できません。起動中に変更した場合，Server Service制御コマンド（eurpmctrlコマンド）の機能が使用できなくなります。

  • 構成定義ファイルをインポートした場合は，次のコンポーネントを再起動してください。

    • EUR Server Service

    • EUR Server - Spool Service

  • EUR Application Service動作設定ファイルをインポートした場合は，次のコンポーネントを再起動してください。

    • EUR Server - Spool Service

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 89 / 202


7.5 EUR Server Serviceの起動管理設定 : EUR システム構築ガイド

  • 90 / 202

  • 表紙

  • 7.　帳票サーバを構築する

  • 7.5　EUR Server Serviceの起動管理設定

7.5　EUR Server Serviceの起動管理設定

EUR Server Serviceでは，起動管理定義を使用してEUR Server Serviceの起動や停止を管理します。起動するEUR Server Serviceの識別名や環境設定ファイルのパスなどの情報は，起動管理定義ファイル（startdef.conf）で管理します。

EUR Server Serviceの起動管理定義は，次のどちらかの方法で作成します。

  • ダイアログを使用して作成する

    ［EUR Server Service 起動管理］ダイアログを使用して作成します。［EUR Server Service 起動管理］ダイアログは，Windows環境で使用できます。

  • コマンドを使用して作成する

    Server Service制御コマンド（eurpmctrlコマンド）を使用して作成します。Server Service制御コマンドは，Windows環境およびUNIX／Linux環境で使用できます。

なお，起動管理定義ファイルは次のディレクトリに作成されます。

  • Windows環境の場合

    EUR Serverのインストール先ディレクトリ\Server

  • UNIX／Linux環境の場合

    /var/opt/eur/server

〈この節の構成〉

  • 7.5.1　［EUR Server Service 起動管理］ダイアログを使用した起動管理

  • 7.5.2　Server Service制御コマンドを使用した起動管理

  • 7.5.3　EUR Server Serviceの自動起動の設定

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 90 / 202


7.5.1 ［EUR Server Service 起動管理］ダイアログを使用した起動管理 : EUR システム構築ガイド

  • 91 / 202

  • 表紙

  • 7.　帳票サーバを構築する

  • 7.5　EUR Server Serviceの起動管理設定

  • 7.5.1　［EUR Server Service 起動管理］ダイアログを使用した起動管理

7.5.1　［EUR Server Service 起動管理］ダイアログを使用した起動管理

［EUR Server Service 起動管理］ダイアログは，EUR製品のプログラムメニューから，［Server］－［Server Service 起動管理］を選択すると表示されます。なお，［EUR Server Service 起動管理］ダイアログの操作は，管理者権限を持つユーザが実行してください。

〈この項の構成〉

  • (1)　起動管理定義を登録する

  • (2)　起動管理定義を変更する

  • (3)　起動管理定義を削除する

  • (4)　ダイアログの設定項目

(1)　起動管理定義を登録する

起動管理定義の登録手順を次に示します。最大5件の起動管理定義を登録できます。

  1. ［EUR Server Service 起動管理］ダイアログで［追加］ボタンをクリックします。

    ［サービスの追加］ダイアログが表示されます。

  2. 次の項目を設定します。

    • 識別名（必須）

    • 自動起動設定（必須）

    • 環境設定ファイルパス（任意）

    環境設定ファイルパスには，EUR Server Serviceの環境設定ファイルの格納先のディレクトリパス，またはファイルパスを指定できます。ディレクトリパスを指定する場合はEUR Server Serviceの環境設定ファイルのデフォルトのファイル名（EURPM.ini）が仮定されます。ファイルパスを指定する場合は任意のファイル名を指定できます。

  3. ［OK］ボタンをクリックします。

    起動管理定義が［EUR Server Service 起動管理］ダイアログに追加されます。

    ただし，次の場合は，メッセージが表示されて，［サービスの追加］ダイアログに戻ります。

    • 識別名に半角空白だけを入力した場合

    • 識別名が16バイトを超えている場合

    • 識別名および環境設定ファイルパスに使用できない文字があった場合

    • すでに同じ名前の識別名が登録されている場合

    また，次の場合はメッセージが表示されますが，処理は続行します。

    • 指定した環境設定ファイルパスが別のEUR Server Serviceの起動管理定義で使用されている場合

ページの先頭へ

(2)　起動管理定義を変更する

起動管理定義の変更手順を次に示します。

  1. ［EUR Server Service 起動管理］ダイアログで変更する起動管理定義を選択して，［変更］ボタンをクリックします。

    ［サービスの変更］ダイアログが表示されます。

  2. 設定内容を変更します。

    次の項目の設定が変更できます。

    • 自動起動設定

    • 環境設定ファイルパス

    なお，識別名は変更できません。識別名を変更したい場合は，起動管理定義を登録し直してください。

  3. ［OK］ボタンをクリックします。

    起動管理定義が変更されます。変更後の登録内容が［EUR Server Service 起動管理］ダイアログに表示されます。

    指定した環境設定ファイルパスが別のEUR Server Serviceの起動管理定義で使用されている場合はメッセージが表示されますが，処理は続行します。

ページの先頭へ

(3)　起動管理定義を削除する

起動管理定義の削除手順を次に示します。

  1. ［EUR Server Service 起動管理］ダイアログで削除する起動管理定義を選択して，［削除］ボタンをクリックします。

    削除を確認するダイアログが表示されます。

  2. ［OK］ボタンをクリックします。

    起動管理定義が削除されます。

ページの先頭へ

(4)　ダイアログの設定項目

起動管理定義ファイルの作成で使用するダイアログの設定項目について説明します。

(a)　［EUR Server Service 起動管理］ダイアログ

起動管理定義一覧

起動管理定義に登録されているEUR Server Serviceとその稼働状態が一覧で表示されます。初期表示では登録順で表示され，項目名をクリックするとその項目でShift JISのコード順にソートして表示されます。稼働状態は自動では更新されないため，最新の稼働状態を表示させたい場合は，［稼働確認］ボタンをクリックしてください。

なお，起動管理定義をダブルクリックすると，［サービスの変更］ダイアログが表示されて登録内容を変更できます。

［識別名］

EUR Server Serviceの識別名が表示されます。

［状態］

EUR Server Serviceの稼働状態が表示されます。表示される内容とその意味は次のとおりです。

Running：稼働

Starting：起動処理中

Stopping：停止処理中

Stopped：停止

ErrorStopped：異常停止

Unknown：不明

［自動起動設定］

EUR Server Serviceを自動で起動するかどうかが表示されます。表示される内容とその意味は次のとおりです。

AUTO：自動で起動します。

MANUAL：手動で起動します。

［環境設定ファイルパス］

EUR Server Serviceの環境設定ファイルの格納先のディレクトリパスまたはファイルパスが表示されます。

［起動］ボタン

選択したEUR Server Serviceを起動できます。

［停止］ボタン

選択したEUR Server Serviceを停止できます。

［追加］ボタン

［サービスの追加］ダイアログが表示され，起動管理定義を登録できます。ただし，起動管理定義の登録数が上限を超えていた場合は，不活性になります。最大5件の起動管理定義を登録できます。

［変更］ボタン

［サービスの変更］ダイアログが表示され，起動管理定義の情報を変更できます。

［削除］ボタン

削除を確認するダイアログが表示され，起動管理定義を削除できます。

［構成定義］ボタン

［EUR Server Service 構成定義］ダイアログが表示され，選択したEUR Server Serviceに登録されている出力先やプリンタクラスを確認できます。

［稼働確認］ボタン

EUR Server Serviceの最新の稼働状態を表示できます。

［閉じる］ボタン

［EUR Server Service 起動管理］ダイアログを閉じます。

(b)　［サービスの追加］ダイアログ

［識別名］テキストボックス

EUR Server Serviceの識別名を，1～16バイトの範囲で入力します。半角英数字および「_」（アンダースコア）を使用できます。先頭と末尾に半角空白を入力した場合は登録時に削除されます。また，半角空白だけを入力した場合は，値を指定していないと見なされ，そのまま登録しようとするとエラーになります。

なお，すでに登録された識別名は登録できません。

［自動起動設定］グループボックス

EUR Server Serviceを自動で起動するかどうかを選択します。デフォルトでは，［自動起動しない］ラジオボタンが選択されています。

［自動起動する］ラジオボタン

自動で起動します。

［自動起動しない］ラジオボタン

手動で起動します。

［環境設定ファイルパス］テキストボックス

EUR Server Serviceの環境設定ファイルの格納先のパスを入力します。ただし，「;」，「*」，「?」，「"」，「<」，「>」，および「|」を含むパスは指定できません。先頭と末尾の半角空白は登録時に削除されます。半角空白だけを入力した場合は未入力とされます。

デフォルトでは，EUR Server Serviceのインストールパスが表示されています。

［参照］ボタン

EUR Server Serviceの環境設定ファイルの格納先のディレクトリパスまたはファイルパスを選択するためのダイアログが表示されます。

(c)　［サービスの変更］ダイアログ

［識別名］テキストボックス

EUR Server Serviceの識別名が表示されます。変更はできません。

そのほかの項目については，「(b)　［サービスの追加］ダイアログ」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 91 / 202


7.5.2 Server Service制御コマンドを使用した起動管理 : EUR システム構築ガイド

  • 92 / 202

  • 表紙

  • 7.　帳票サーバを構築する

  • 7.5　EUR Server Serviceの起動管理設定

  • 7.5.2　Server Service制御コマンドを使用した起動管理

7.5.2　Server Service制御コマンドを使用した起動管理

Server Service制御コマンド（eurpmctrlコマンド）のファイル名と格納先を次に示します。

  • Windows環境の場合

    EURPMCTRL.exe

    EUR Serverのインストール先ディレクトリ\Server\Program下にあります。

  • UNIX／Linux環境の場合

    eurpmctrl

    /opt/eur/server/binディレクトリにあります。

Server Service制御コマンドは，管理者権限を持つユーザが実行してください。例えば，コマンドプロンプトからServer Service制御コマンドを実行するときには，コマンドプロンプトは管理者権限を持つユーザが起動してください。

〈この項の構成〉

  • (1)　Server Service制御コマンドのオプション

  • (2)　形式と指定例

  • (3)　Server Service制御コマンドのエラー情報

(1)　Server Service制御コマンドのオプション

Server Service制御コマンド（eurpmctrlコマンド）が提供するオプションの一覧を次の表に示します。なお，オプション名のセパレータは「/」で示しています。UNIX／Linux環境の場合は，「/」を「-」に置き換えてお読みください。

表7‒4 Server Service制御コマンド（eurpmctrlコマンド）のオプション一覧
オプション | 指定値 | 内容
/id | 識別名※ | 操作対象となるEUR Server Serviceの識別名を指定します。
/ini | 環境設定ファイルパス | 操作対象となるEUR Server Serviceが使用する環境設定ファイルのパスを指定します。 環境設定ファイルパスには，EUR Server Serviceの環境設定ファイルの格納先のディレクトリパス，またはファイルパスを指定できます。ディレクトリパスを指定する場合はEUR Server Serviceの環境設定ファイルのデフォルトのファイル名（EURPM.ini）が仮定されます。ファイルパスを指定する場合は任意のファイル名を指定できます。
/kind | ALL | 起動管理定義に登録されているすべてのEUR Server Serviceを操作対象とします。
 | AUTOONLY | 起動管理定義に登録されているEUR Server Serviceのうち，自動起動の設定がされているEUR Server Serviceを操作対象とします。
/m | add | EUR Server Serviceの起動管理定義を登録します。
 | disp | EUR Server Serviceの起動管理定義の登録内容を出力します。
 | chg | EUR Server Serviceの起動管理定義を変更します。
 | del | EUR Server Serviceの起動管理定義を削除します。
 | start | EUR Server Serviceを起動します。
 | stop | EUR Server Serviceを停止します。
 | stat | EUR Server Serviceの稼働状態を確認します。
 | auto | EUR Server Serviceの自動起動の設定をします。
/message | /nomessage | － | 標準エラー出力にメッセージを出力するかどうかを指定します。
/mode | AUTO | 自動で起動します。
 | MANUAL | 手動で起動します。
注※

1～16バイトで指定します。半角英数字および「_」（アンダースコア）が使用できます。値の先頭と末尾に半角空白を指定した場合は削除されます。また，半角空白だけを指定した場合は，値を指定していないと見なされます。

■注意

  • オプション，オプションの指定値，およびオプションに指定する文字列は，大文字と小文字を区別します。ただし，識別名については大文字と小文字を区別しません。例えば，/mオプションを「/M」と指定したり，/mオプションの指定値を「/m STOP」と指定したりすると，エラーになります。

  • 一つのコマンド構文に，同じオプションが複数指定されている場合は，コマンド構文の後方に指定されたオプションが有効となります。

  • 無効なオプションが指定されている場合は，そのオプションを無視して処理を実行します。

  • ファイルパスを指定するときの規則，および注意については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。また，パスに日本語を使用する場合の注意については，「付録B.2　EUR Server Service，およびEUR Server - Spool Serviceを使用する場合の注意」を参照してください。

ページの先頭へ

(2)　形式と指定例

EUR Server Serviceの起動管理をするときのコマンドの形式と指定例について説明します。

(a)　起動管理定義を登録する

起動管理定義を登録するときのコマンドの形式と指定例を次に示します。

eurpmctrl
/m add
/id 識別名
〔/message | /nomessage〕
〔/mode ｛AUTO | MANUAL｝〕
〔/ini 環境設定ファイルパス〕
/m add

EUR Server Serviceの制御種別を指定します。

  • add：EUR Server Serviceの起動管理定義を登録します。

    ただし，起動管理定義の登録数が上限を超えた場合は，登録できません。最大5件の起動管理定義を登録できます。

/id 識別名

操作対象のEUR Server Serviceの識別名を1～16バイトの範囲で指定します。半角英数字および「_」（アンダースコア）を使用できます。

〔/message | /nomessage〕

標準エラー出力にメッセージを出力するかどうかを指定します。

  • /message：メッセージを出力します。

  • /nomessage：メッセージを出力しません。

指定を省略した場合は，/messageが仮定されます。/nomessageを指定した場合も，コマンドの終了コードは出力されます。

〔/mode ｛AUTO | MANUAL｝〕

EUR Server Serviceを自動で起動するかどうかを指定します。

  • AUTO：自動で起動します。

  • MANUAL：手動で起動します。

指定を省略した場合は，/mode MANUALが仮定されます。

〔/ini 環境設定ファイルパス〕

EUR Server Serviceが使用する環境設定ファイルのパスを指定します。指定を省略した場合は，デフォルトのパス（Windows環境の場合：EUR Serverのインストール先ディレクトリ\Server，UNIX／Linux環境の場合：/var/opt/eur/server）が仮定されます。

環境設定ファイルパスには，EUR Server Serviceの環境設定ファイルの格納先のディレクトリパス，またはファイルパスを指定できます。ディレクトリパスを指定する場合はEUR Server Serviceの環境設定ファイルのデフォルトのファイル名（EURPM.ini）が仮定されます。ファイルパスを指定する場合は任意のファイル名を指定できます。

■指定例

識別名が「EURSV_TEST」のEUR Server Serviceの起動管理定義を登録します。

eurpmctrl /m add /id EURSV_TEST /message /ini C:\Program Files\EURSV_TEST

(b)　起動管理定義の登録内容を確認する

起動管理定義の登録内容を確認するときのコマンドの形式と指定例を次に示します。

eurpmctrl
/m disp
〔/message | /nomessage〕
〔/kind ALL | /id 識別名〕
/m disp

EUR Server Serviceの制御種別を指定します。

  • disp：EUR Server Serviceの起動管理定義の登録内容を確認します。

〔/message | /nomessage〕

標準エラー出力にメッセージを出力するかどうかを指定します。

  • /message：メッセージを出力します。

  • /nomessage：メッセージを出力しません。

指定を省略した場合は，/messageが仮定されます。/nomessageを指定した場合も，コマンドの終了コードは出力されます。

〔/kind ALL〕

操作対象のEUR Server Serviceを指定します。このオプションは/idオプションと同時に指定できません。

  • ALL：起動管理定義に登録されているすべてのEUR Server Serviceを操作対象とします。

〔/id 識別名〕

操作対象のEUR Server Serviceの識別名を1～16バイトの範囲で指定します。半角英数字および「_」（アンダースコア）を使用できます。このオプションは/kindオプションと同時に指定できません。

■指定例

起動管理定義に登録されているEUR Server Serviceの登録内容を確認します。

eurpmctrl /m disp /message
■出力例

EUR Server Serviceの起動管理定義の登録内容は，標準出力（stdout）に出力されます。出力例を次に示します。

+-----------+-----------+--------------------------------------
|<EURPMID>  |<AutoFlag> |<DefinitionFile>
+-----------+-----------+--------------------------------------
|EURSV      |AUTO       |/var/opt/eur/server/      …デフォルト
|EURSV_MAIN |AUTO       |/var/opt/eur/server/EURSV_MAIN/
|EURSV_SUB  |MANUAL     |/var/opt/eur/server/EURSV_SUB/
| .         | .         | .
| .         | .         | .
| .         | .         | .
|EURSV_TEST |MANUAL     |/var/opt/eur/server/EURSV_TEST/
+-----------+-----------+--------------------------------------
<EURPMID>

EUR Server Serviceの識別名を示します。

<AutoFlag>

EUR Server Serviceを自動で起動するかどうかを示します。

AUTO：自動で起動します。

MANUAL：手動で起動します。

<DefinitionFile>

EUR Server Serviceの環境設定ファイルパスを示します。

(c)　起動管理定義を変更する

起動管理定義を変更するときのコマンドの形式と指定例を次に示します。

eurpmctrl
/m chg
/id 識別名
〔/message | /nomessage〕
〔/mode ｛AUTO | MANUAL｝〕
〔/ini 環境設定ファイルパス〕
/m chg

EUR Server Serviceの制御種別を指定します。

  • chg：EUR Server Serviceの起動管理定義を変更します。

/id 識別名

操作対象のEUR Server Serviceの識別名を1～16バイトの範囲で指定します。半角英数字および「_」（アンダースコア）を使用できます。

〔/message | /nomessage〕

標準エラー出力にメッセージを出力するかどうかを指定します。

  • /message：メッセージを出力します。

  • /nomessage：メッセージを出力しません。

指定を省略した場合は，/messageが仮定されます。/nomessageを指定した場合も，コマンドの終了コードは出力されます。

〔/mode ｛AUTO | MANUAL｝〕

EUR Server Serviceを自動で起動するかどうかを指定します。

  • AUTO：自動で起動します。

  • MANUAL：手動で起動します。

指定を省略した場合は，自動起動の定義は変更されません。

〔/ini 環境設定ファイルパス〕

EUR Server Serviceが使用する環境設定ファイルのパスを指定します。指定を省略した場合は，環境設定ファイルのパスの定義は変更されません。

環境設定ファイルパスには，EUR Server Serviceの環境設定ファイルの格納先のディレクトリパス，またはファイルパスを指定できます。ディレクトリパスを指定する場合はEUR Server Serviceの環境設定ファイルのデフォルトのファイル名（EURPM.ini）が仮定されます。ファイルパスを指定する場合は任意のファイル名を指定できます。

■指定例

識別名が「EURSV_SUB」のEUR Server Serviceが自動で起動するように，起動管理定義を変更します。

eurpmctrl /m chg /id EURSV_SUB /message /mode AUTO

(d)　起動管理定義を削除する

起動管理定義を削除するときのコマンドの形式と指定例を次に示します。

eurpmctrl
/m del
〔/message | /nomessage〕
〔/kind ALL | /id 識別名〕
/m del

EUR Server Serviceの制御種別を指定します。

  • del：EUR Server Serviceの起動管理定義を削除します。

〔/message | /nomessage〕

標準エラー出力にメッセージを出力するかどうかを指定します。

  • /message：メッセージを出力します。

  • /nomessage：メッセージを出力しません。

指定を省略した場合は，/messageが仮定されます。/nomessageを指定した場合も，コマンドの終了コードは出力されます。

〔/kind ALL〕

操作対象のEUR Server Serviceを指定します。このオプションは/idオプションと同時に指定できません。

  • ALL：起動管理定義に登録されているすべてのEUR Server Serviceを操作対象とします。

〔/id 識別名〕

操作対象のEUR Server Serviceの識別名を1～16バイトの範囲で指定します。半角英数字および「_」（アンダースコア）を使用できます。このオプションは/kindオプションと同時に指定できません。

■指定例

識別名が「EURSV_TEMP」の起動管理定義を削除します。

eurpmctrl /m del /message /id EURSV_TEMP

(e)　EUR Server Serviceを起動する

eurpmctrl
/m start
〔/message | /nomessage〕
〔/kind ｛ALL | AUTOONLY｝| /id 識別名〕
/m start

EUR Server Serviceの制御種別を指定します。

  • start：EUR Server Serviceを起動します。

〔/message | /nomessage〕

標準エラー出力にメッセージを出力するかどうかを指定します。

  • /message：メッセージを出力します。

  • /nomessage：メッセージを出力しません。

指定を省略した場合は，/messageが仮定されます。/nomessageを指定した場合も，コマンドの終了コードは出力されます。

〔/kind ｛ALL | AUTOONLY｝〕

操作対象のEUR Server Serviceを指定します。このオプションは/idオプションと同時に指定できません。

  • ALL：起動管理定義に登録されているすべてのEUR Server Serviceを操作対象とします。

  • AUTOONLY：起動管理定義に登録されているEUR Server Serviceのうち，自動起動の設定がされたEUR Server Serviceを操作対象とします。

〔/id 識別名〕

操作対象のEUR Server Serviceの識別名を1～16バイトの範囲で指定します。半角英数字および「_」（アンダースコア）を使用できます。このオプションは/kindオプションと同時に指定できません。

■指定例

起動管理定義に登録されているEUR Server Serviceのうち，自動起動が設定されたEUR Server Serviceを起動します。

eurpmctrl /m start /message /kind AUTOONLY

(f)　EUR Server Serviceを停止する

eurpmctrl
/m stop
〔/message | /nomessage〕
〔/kind ｛ALL | AUTOONLY｝| /id 識別名〕
/m stop

EUR Server Serviceの制御種別を指定します。

  • stop：EUR Server Serviceを停止します。

〔/message | /nomessage〕

標準エラー出力にメッセージを出力するかどうかを指定します。

  • /message：メッセージを出力します。

  • /nomessage：メッセージを出力しません。

指定を省略した場合は，/messageが仮定されます。/nomessageを指定した場合も，コマンドの終了コードは出力されます。

〔/kind ｛ALL | AUTOONLY｝〕

操作対象のEUR Server Serviceを指定します。このオプションは/idオプションと同時に指定できません。

  • ALL：起動管理定義に登録されているすべてのEUR Server Serviceを操作対象とします。

  • AUTOONLY：起動管理定義に登録されているEUR Server Serviceのうち，自動起動が設定されたEUR Server Serviceを操作対象とします。

〔/id 識別名〕

操作対象のEUR Server Serviceの識別名を1～16バイトの範囲で指定します。半角英数字および「_」（アンダースコア）を使用できます。このオプションは/kindオプションと同時に指定できません。

■指定例

識別名が「EURSV_MAIN」のEUR Server Serviceを停止します。

eurpmctrl /m stop /message /id EURSV_MAIN

(g)　EUR Server Serviceの稼働状態を確認する

eurpmctrl
/m stat
〔/message | /nomessage〕
〔/kind ｛ALL | AUTOONLY｝| /id 識別名〕
/m stat

EUR Server Serviceの制御種別を指定します。

  • stat：EUR Server Serviceの稼働状態を確認します。

〔/message | /nomessage〕

標準エラー出力にメッセージを出力するかどうかを指定します。

  • /message：メッセージを出力します。

  • /nomessage：メッセージを出力しません。

指定を省略した場合は，/messageが仮定されます。/nomessageを指定した場合も，コマンドの終了コードは出力されます。

〔/kind ｛ALL | AUTOONLY｝〕

操作対象のEUR Server Serviceを指定します。このオプションは/idオプションと同時に指定できません。

  • ALL：起動管理定義に登録されているすべてのEUR Server Serviceを操作対象とします。

  • AUTOONLY：起動管理定義に登録されているEUR Server Serviceのうち，自動起動が設定されたEUR Server Serviceを操作対象とします。

〔/id 識別名〕

操作対象のEUR Server Serviceの識別名を1～16バイトの範囲で指定します。半角英数字および「_」（アンダースコア）を使用できます。このオプションは/kindオプションと同時に指定できません。

■指定例

起動管理定義に登録されているEUR Server Serviceの稼働状態を確認します。

eurpmctrl /m stat /message
■出力例

EUR Server Serviceの稼働状態は，標準出力（stdout）に出力されます。出力例を次に示します。

+--------------+--------------+-----------+
|<EURPMID>     |<Status>      |<PID>      |
+--------------+--------------+-----------+
|EURSV         |Running       |4236       | …デフォルトエントリ
|EURSV_MAIN    |Starting      |           |
|EURSV_SUB     |Stopping      |4242       |
| .            | .            | .         |
| .            | .            | .         |
| .            | .            | .         |
|EURSV_TEST    |Stopped       |           |
+--------------+--------------+-----------+
<EURPMID>

EUR Server Serviceの識別名を示します。

<Status>

EUR Server Serviceの稼働状態を示します。

Running：稼働

Starting：起動処理中

Stopping：停止処理中

Stopped：停止

ErrorStopped：異常停止

Unknown：不明

<PID>

プロセスIDを示します。

プロセスIDは，StatusがRunning（稼働）またはStopping（停止処理中）の場合に表示されます。

(h)　EUR Server Serviceの自動起動の設定をする

eurpmctrl
/m auto
/mode ｛AUTO | MANUAL｝
〔/message | /nomessage〕
〔/kind ALL | /id 識別名〕
/m auto

EUR Server Serviceの制御種別を指定します。

  • auto：EUR Server Serviceの自動起動の設定をします。

/mode ｛AUTO | MANUAL｝

EUR Server Serviceを自動で起動するかどうかを指定します。

  • AUTO：自動で起動します。

  • MANUAL：手動で起動します。

〔/message | /nomessage〕

標準エラー出力にメッセージを出力するかどうかを指定します。

  • /message：メッセージを出力します。

  • /nomessage：メッセージを出力しません。

指定を省略した場合は，/messageが仮定されます。/nomessageを指定した場合も，コマンドの終了コードは出力されます。

〔/kind ALL〕

操作対象のEUR Server Serviceを指定します。このオプションは/idオプションと同時に指定できません。

  • ALL：起動管理定義に登録されているすべてのEUR Server Serviceを操作対象とします。

〔/id 識別名〕

操作対象のEUR Server Serviceの識別名を1～16バイトの範囲で指定します。半角英数字および「_」（アンダースコア）を使用できます。このオプションは/kindオプションと同時に指定できません。

■指定例

識別名が「EURSV_TEST」のEUR Server Serviceが自動で起動するように設定します。

eurpmctrl /m auto /mode AUTO /message /id EURSV_TEST

EUR Server Serviceの自動起動の設定方法については，「7.5.3　EUR Server Serviceの自動起動の設定」を参照してください。

ページの先頭へ

(3)　Server Service制御コマンドのエラー情報

Server Service制御コマンド（eurpmctrlコマンド）では，エラーを検知すると，メッセージオプション（/message）によって次に示す標準エラーを出力します。

表7‒5 Server Service制御コマンド（eurpmctrlコマンド）の標準エラー出力
エラー種別 | 発生条件 | メッセージID
コマンドシンタックスエラー | 不明なオプションを指定したとき | KEEY001-E
 | オプションに値の指定がないとき | KEEY002-E
 | オプションの指定値が不正なとき | KEEY003-E
 | 必須オプションの指定がないとき | KEEY004-E
 | 同時に指定できないオプションを指定したとき | KEEY005-E
 | 指定した識別名の起動管理定義が存在しないとき | KEEY006-E
 | 追加しようとした識別名の起動管理定義が存在するとき | KEEY008-E
コマンドシンタックスワーニング | 起動管理定義が一つも存在しないとき | KEEY007-W
 | 自動起動の対象が一つも存在しないとき | KEEY009-W
 | 環境設定ファイルパスの追加または変更で指定したディレクトリパスまたはファイルパスが，ほかのエントリの環境設定ファイルパスと重複したとき | KEEY010-W
コマンド実行時エラー | すでに起動している識別名のEUR Server Serviceを起動しようとしたとき | KEEY020-E
 | 起動処理中または停止処理中の識別名のEUR Server Serviceを起動しようとしたとき | KEEY021-E
 | すでに停止している識別名のEUR Server Serviceを停止しようとしたとき | KEEY022-E
 | 起動処理中または停止処理中の識別名のEUR Server Serviceを停止しようとしたとき | KEEY023-E
 | プロセス管理ファイルの読み込みでエラーが発生したとき | KEEY024-E
 | EUR Server Serviceの起動時にエラーが発生したとき | KEEY025-E
 | EUR Server Serviceの停止時にエラーが発生したとき | KEEY026-E
 | 指定した識別名の起動管理定義の書き込みでエラーが発生したとき | KEEY027-E
 | 指定した識別名の起動管理定義の読み込みでエラーが発生したとき | KEEY028-E
 | メモリが不足したとき | KEEY030-E
 | 環境設定ファイル読み込み中にエラーが発生したとき | KEEY031-S
 | ログファイル処理時にエラーが発生したとき | KEEY032-S
 | 起動している識別名のEUR Server Serviceの起動管理定義を，変更または削除しようとしたとき | KEEY038-E
 | 登録できる件数を超えて起動管理定義を追加しようとしたとき | KEEY039-E
 | Windows環境でEUR Server Serviceの呼び出しでエラーが発生したとき | KEEY040-E
 | サービスのオープンまたは情報取得でエラーが発生したとき | KEEY041-E
コマンド実行ワーニング | ログファイルのオープンエラーが発生したとき | KEEY035-W
コマンド実行タイムアウト | コマンド実行時にタイムアウトが発生したとき | KEEY050-E

(a)　Server Service制御コマンドの終了コード

Server Service制御コマンド（eurpmctrlコマンド）を実行すると，終了コードが返されます。終了コード一覧を次に示します。

表7‒6 Server Service制御コマンド（eurpmctrlコマンド）の終了コード
終了コード | 意味
0 | Server Service制御コマンドが正常に終了しました。
4 | Server Service制御コマンドの実行中，警告が発生しました。
8 | Server Service制御コマンドの実行中，エラーが発生しました。

Server Service制御コマンドを呼び出しているプログラムでは，Server Service制御コマンドの終了コードを参照して，エラーチェックしてください。

(b)　エラーメッセージのフォーマット

Server Service制御コマンド（eurpmctrlコマンド）を実行したとき，標準エラーに出力されるメッセージのフォーマットを次に示します。

eurpmctrl:△KEEY0XX-E△エラーメッセージ▼
（凡例）

△：半角空白を示します。

▼：改行（0x0d+0x0a）を示します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 92 / 202


7.5.3 EUR Server Serviceの自動起動の設定 : EUR システム構築ガイド

  • 93 / 202

  • 表紙

  • 7.　帳票サーバを構築する

  • 7.5　EUR Server Serviceの起動管理設定

  • 7.5.3　EUR Server Serviceの自動起動の設定

7.5.3　EUR Server Serviceの自動起動の設定

EUR Server Serviceの自動起動の設定は，次の方法で実施できます。

〈この項の構成〉

  • (1)　Windows環境の場合

  • (2)　UNIX／Linux環境の場合

(1)　Windows環境の場合

(a)　OSのサービス管理機能を使用する場合

  1. スタートメニューの［コントロールパネル］－［管理ツール］－［サービス］を選択する。

    デフォルトのサービス名は「EUR Server Service」です。

    ［サービス］ウィンドウが表示されます。

  2. EUR Server Serviceのサービス名をダブルクリックする。

    サービスのプロパティを設定するダイアログが表示されます。

  3. ［スタートアップの種類］に「自動」を設定する。

  4. ダイアログで［OK］ボタンをクリックする。

    自動起動が設定されます。

［スタートアップの種類］が「手動」または「無効」の場合は，EUR Server Serviceを自動で起動できません。デフォルトでは，［スタートアップの種類］に「自動」が設定されたEUR Server Serviceが一つ登録されています。

(b)　運用管理ツールを使用する場合

  1. 自動起動を設定するEUR Server Serviceを起動管理定義に登録する。

    ［EUR Server Service起動管理］ダイアログまたはServer Service制御コマンド（eurpmctrlコマンド）を使用して登録します。

  2. Server Service制御コマンドを運用管理ツールに登録する。

    EUR Server Serviceを起動するためのServer Service制御コマンド（eurpmctrlコマンド）を，運用管理ツールに登録します。登録方法の詳細については，使用している運用管理ツールのマニュアルを参照してください。

    登録するServer Service制御コマンドを次に示します。

    eurpmctrl /m start /kind AUTOONLY

    なお，自動でEUR Server Serviceを停止させる場合は，次のコマンドを登録します。

    eurpmctrl /m stop /kind AUTOONLY

［EUR Server Service起動管理］ダイアログで起動管理定義を登録する方法については，「7.5.1　［EUR Server Service 起動管理］ダイアログを使用した起動管理」を参照してください。また，Server Service制御コマンド（eurpmctrlコマンド）で起動管理定義を登録する方法については，「7.5.2　Server Service制御コマンドを使用した起動管理」を参照してください。

ページの先頭へ

(2)　UNIX／Linux環境の場合

Server Service制御コマンド（eurpmctrlコマンド）とOSの起動管理機能とを組み合わせると，EUR Server Serviceの起動と停止を自動で実施できます。手順を次に示します。

  1. 自動起動を設定するEUR Server Serviceを起動管理定義に登録する。

    Server Service制御コマンド（eurpmctrlコマンド）を使用して登録します。

  2. Server Service制御コマンドをOSの起動管理機能を使用して登録する。

    EUR Server Serviceを起動するためのServer Service制御コマンド（eurpmctrlコマンド）を，OSの起動管理機能を使用して登録します。登録方法の詳細については，OSのマニュアルを参照してください。

    登録するServer Service制御コマンドを次に示します。

    eurpmctrl -m start -kind AUTOONLY

    なお，自動でEUR Server Serviceを停止させる場合は，次のコマンドを登録します。

    eurpmctrl -m stop -kind AUTOONLY

Server Service制御コマンド（eurpmctrlコマンド）を使用した起動管理設定の方法については，「7.5.2　Server Service制御コマンドを使用した起動管理」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 93 / 202


7.6 EUR Server - Spool Serviceの起動管理設定 : EUR システム構築ガイド

  • 94 / 202

  • 表紙

  • 7.　帳票サーバを構築する

  • 7.6　EUR Server - Spool Serviceの起動管理設定

7.6　EUR Server - Spool Serviceの起動管理設定

  • Windows環境の場合

    帳票サーバがWindows環境の場合，EUR Server - Spool Serviceの起動管理設定は，OSのサービス管理機能を使用して管理します。手順を次に示します。

    1. スタートメニューの［コントロールパネル］－［管理ツール］－［サービス］を選択する。

      ［サービス］ウィンドウが表示されます。

    2. EUR Server - Spool Serviceのサービス名をダブルクリックする。

      デフォルトのサービス名は「EUR Spool Service」です。

      サービスのプロパティを設定するダイアログが表示されます。

    3. ［スタートアップの種類］に「自動」を設定する。

    4. ダイアログで［OK］ボタンをクリックする。

      自動起動が設定されます。

    ［スタートアップの種類］が「手動」または「無効」の場合は，EUR Server - Spool Serviceを自動で起動できません。デフォルトでは，［スタートアップの種類］に「自動」が設定されたEUR Server - Spool Serviceが一つ登録されています。

  • UNIX／Linux環境の場合

    帳票サーバがUNIX／Linux環境の場合，EUR Server - Spool Serviceの起動管理設定は，Spool Service制御コマンド（eurpmlsctrlコマンド）を使用して実施します。

    Spool Service制御コマンドとOSの起動管理機能とを組み合わせると，EUR Server - Spool Serviceの起動と停止を自動で実施できます。手順を次に示します。

    1. EUR Server - Spool Serviceの自動起動を設定するコマンドを，OSの起動管理機能を使用して登録する。

      コマンドの登録方法の詳細については，OSのマニュアルを参照してください。

      EUR Server - Spool Serviceの自動起動を設定するコマンドを次に示します。

      eurpmlsctrl -m start

      なお，自動でEUR Server - Spool Serviceを停止させる場合は，次のコマンドを登録します。

      eurpmlsctrl -m stop

    Spool Service制御コマンド（eurpmlsctrlコマンド）を使用した起動管理設定の方法については，「7.6.1　Spool Service制御コマンドを使用した起動管理」を参照してください。

〈この節の構成〉

  • 7.6.1　Spool Service制御コマンドを使用した起動管理

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 94 / 202


7.6.1 Spool Service制御コマンドを使用した起動管理 : EUR システム構築ガイド

  • 95 / 202

  • 表紙

  • 7.　帳票サーバを構築する

  • 7.6　EUR Server - Spool Serviceの起動管理設定

  • 7.6.1　Spool Service制御コマンドを使用した起動管理

7.6.1　Spool Service制御コマンドを使用した起動管理

Spool Service制御コマンド（eurpmlsctrlコマンド）のファイル名と格納先を次に示します。

eurpmlsctrl

/opt/eur/spool/binディレクトリにあります。

なお，Spool Service制御コマンドは，管理者権限を持つユーザが実行してください。

〈この項の構成〉

  • (1)　Spool Service制御コマンドのオプション

  • (2)　形式と指定例

  • (3)　Spool Service制御コマンドのエラー情報

(1)　Spool Service制御コマンドのオプション

Spool Service制御コマンド（eurpmlsctrlコマンド）が提供するオプションの一覧を次の表に示します。

表7‒7 Spool Service制御コマンド（eurpmlsctrlコマンド）のオプション一覧
オプション | 指定値 | 内容
-m | start | EUR Server - Spool Serviceを起動します。
 | stop | EUR Server - Spool Serviceを停止します。
 | stat | EUR Server - Spool Serviceの稼働状態を確認します。
 | chg | EUR Server - Spool Serviceの起動管理定義を変更します。
 | disp | EUR Server - Spool Serviceの起動管理定義の登録内容を出力します。
-message | -nomessage | － | 標準エラー出力にメッセージを出力するかどうかを指定します。
-ini | 環境設定ファイルパス | 操作対象となるEUR Server - Spool Serviceが使用する環境設定ファイルのパスを指定します。 環境設定ファイルパスには，EUR Server - Spool Serviceの環境設定ファイルの格納先のディレクトリパス，またはファイルパスを指定できます。ディレクトリパスを指定する場合はEUR Server - Spool Serviceの環境設定ファイルのデフォルトのファイル名（EURPMLS.ini）が仮定されます。ファイルパスを指定する場合は任意のファイル名を指定できます。
■注意

  • オプションおよびオプションの指定値は，大文字と小文字を区別します。例えば，-mオプションを「-M」と指定したり，-mオプションの指定値を「-m STOP」と指定したりすると，エラーになります。

  • 一つのコマンド構文に，同じオプションが複数指定されている場合は，コマンド構文の後方に指定されたオプションが有効となります。

  • 無効なオプションが指定されている場合は，そのオプションを無視して処理を実行します。

  • ファイルパスを指定するときの規則，および注意については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。また，パスに日本語を使用する場合の注意については，「付録B.2　EUR Server Service，およびEUR Server - Spool Serviceを使用する場合の注意」を参照してください。

ページの先頭へ

(2)　形式と指定例

EUR Server - Spool Serviceの起動管理をするときのコマンドの形式と指定例について説明します。

(a)　起動管理定義の登録内容を確認する

起動管理定義の登録内容を確認するときのコマンドの形式と指定例を次に示します。

eurpmlsctrl
/m disp
〔/message | /nomessage〕
/m disp

EUR Server - Spool Serviceの制御種別を指定します。

  • disp：EUR Server - Spool Serviceの起動管理定義の登録内容を確認します。

〔/message | /nomessage〕

標準エラー出力にメッセージを出力するかどうかを指定します。

  • /message：メッセージを出力します。

  • /nomessage：メッセージを出力しません。

指定を省略した場合は，/messageが仮定されます。/nomessageを指定した場合も，コマンドの終了コードは出力されます。

■指定例

起動管理定義に登録されているEUR Server - Spool Serviceの登録内容を確認します。

eurpmlsctrl /m disp /message
■出力例

EUR Server - Spool Serviceの起動管理定義の登録内容は，標準出力（stdout）に出力されます。出力例を次に示します。

+-------------+-----------+-----------------------------------
|<EURPMRSID>  |<AutoFlag> |<DefinitionFile>
+-------------+-----------+-----------------------------------
|EURPMRS      |MANUAL     |/var/opt/eur/spool/   …デフォルト
+-------------+-----------+-----------------------------------
<EURPMRSID>

EUR Server - Spool Serviceの識別名（EURPMRS）を示します。

<AutoFlag>

EUR Server - Spool Serviceを手動（MANUAL）で起動することを示します。

<DefinitionFile>

EUR Server - Spool Serviceの環境設定ファイルパスを示します。

(b)　起動管理定義を変更する

起動管理定義を変更するときのコマンドの形式と指定例を次に示します。

eurpmlsctrl
/m chg
〔/message | /nomessage〕
〔/ini 環境設定ファイルパス〕
/m chg

EUR Server - Spool Serviceの制御種別を指定します。

  • chg：EUR Server - Spool Serviceの起動管理定義を変更します。

〔/message | /nomessage〕

標準エラー出力にメッセージを出力するかどうかを指定します。

  • /message：メッセージを出力します。

  • /nomessage：メッセージを出力しません。

指定を省略した場合は，/messageが仮定されます。/nomessageを指定した場合も，コマンドの終了コードは出力されます。

〔/ini 環境設定ファイルパス〕

EUR Server - Spool Serviceが使用する環境設定ファイルのパスを指定します。指定を省略した場合は，環境設定ファイルのパスの定義は変更されません。

環境設定ファイルパスには，EUR Server - Spool Serviceの環境設定ファイルの格納先のディレクトリパス，またはファイルパスを指定できます。ディレクトリパスを指定する場合はEUR Server - Spool Serviceの環境設定ファイルのデフォルトのファイル名（EURPMLS.ini）が仮定されます。ファイルパスを指定する場合は任意のファイル名を指定できます。

■指定例

EUR Server - Spool Serviceの環境設定ファイルパスを変更します。

eurpmctrl /m chg /message /ini "/var/opt/eur/spool/EURPMRS_MAIN/"

(c)　EUR Server - Spool Serviceを起動する

eurpmlsctrl
-m start
〔-message | -nomessage〕
-m start

EUR Server - Spool Serviceの制御種別を指定します。

  • start：EUR Server - Spool Serviceを起動します。

〔-message | -nomessage〕

標準エラー出力にメッセージを出力するかどうかを指定します。

  • -message：メッセージを出力します。

  • -nomessage：メッセージを出力しません。

指定を省略した場合は，-messageが仮定されます。-nomessageを指定した場合も，コマンドの終了コードは出力されます。

■指定例

EUR Server - Spool Serviceを起動します。

eurpmlsctrl -m start -message

(d)　EUR Server - Spool Serviceを停止する

eurpmlsctrl
-m stop
〔-message | -nomessage〕
-m stop

EUR Server - Spool Serviceの制御種別を指定します。

  • stop：EUR Server - Spool Serviceを停止します。

〔-message | -nomessage〕

標準エラー出力にメッセージを出力するかどうかを指定します。

  • -message：メッセージを出力します。

  • -nomessage：メッセージを出力しません。

指定を省略した場合は，-messageが仮定されます。-nomessageを指定した場合も，コマンドの終了コードは出力されます。

■指定例

EUR Server - Spool Serviceを停止します。

eurpmlsctrl -m stop -message

(e)　EUR Server - Spool Serviceの稼働状態を確認する

eurpmlsctrl
-m stat
〔-message | -nomessage〕
-m stat

EUR Server - Spool Serviceの制御種別を指定します。

  • stat：EUR Server - Spool Serviceの稼働状態を確認します。

〔-message | -nomessage〕

標準エラー出力にメッセージを出力するかどうかを指定します。

  • -message：メッセージを出力します。

  • -nomessage：メッセージを出力しません。

指定を省略した場合は，-messageが仮定されます。-nomessageを指定した場合も，コマンドの終了コードは出力されます。

■指定例

EUR Server - Spool Serviceの稼働状態を確認します。

eurpmlsctrl -m stat -message
■出力例

EUR Server - Spool Serviceの稼働状態は，標準出力（stdout）に出力されます。出力例を次に示します。

+--------------+--------------+--------------+
|<EURPMRSID>   |<Status>      |<PID>         |
+--------------+--------------+--------------+
|EURPMRS       |Running       |4237          |
+--------------+--------------+--------------+
<EURPMRSID>

固定値「EURPMRS」を示します。

<Status>

EUR Server - Spool Serviceの稼働状態を示します。

Running：稼働

Starting：起動処理中

Stopping：停止処理中

Stopped：停止

ErrorStopped：異常停止

Unknown：不明

<PID>

プロセスIDを示します。

プロセスIDは，StatusがRunning（稼働）またはStopping（停止処理中）の場合に表示されます。

ページの先頭へ

(3)　Spool Service制御コマンドのエラー情報

Spool Service制御コマンド（eurpmlsctrlコマンド）では，エラーを検知すると，メッセージオプション（-message）によって次に示す標準エラーを出力します。

表7‒8 Spool Service制御コマンド（eurpmlsctrlコマンド）の標準エラー出力
エラー種別 | 発生条件 | メッセージID
コマンドシンタックスエラー | 不明なオプションを指定したとき | KEEY001-E
 | オプションに値の指定がないとき | KEEY002-E
 | オプションの指定値が不正なとき | KEEY003-E
 | 必須オプションの指定がないとき | KEEY004-E
コマンド実行時エラー | すでに起動しているEUR Server - Spool Serviceを起動しようとしたとき | KEEY020-E
 | 起動処理中または停止処理中のEUR Server - Spool Serviceを起動しようとしたとき | KEEY021-E
 | すでに停止しているEUR Server - Spool Serviceを停止しようとしたとき | KEEY022-E
 | 起動処理中または停止処理中のEUR Server - Spool Serviceを停止しようとしたとき | KEEY023-E
 | プロセス管理ファイルの読み込みでエラーが発生したとき | KEEY024-E
 | 起動管理定義の書き込みでエラーが発生したとき | KEEY027-E
 | 起動管理定義の読み込みでエラーが発生したとき | KEEY028-E
 | メモリが不足したとき | KEEY030-E
 | 環境設定ファイル読み込み中にエラーが発生したとき | KEEY031-S
 | ログファイル処理時にエラーが発生したとき | KEEY032-S
 | EUR Server - Spool Serviceの起動時にエラーが発生したとき | KEEY053-E
 | EUR Server - Spool Serviceの停止時にエラーが発生したとき | KEEY054-E
 | EUR Server - Spool Serviceの呼び出しでエラーが発生したとき | KEEY055-E
コマンド実行ワーニング | ログファイルのオープンエラーが発生したとき | KEEY035-W
コマンド実行タイムアウト | コマンド実行時にタイムアウトが発生したとき | KEEY050-E

(a)　Spool Service制御コマンドの終了コード

Spool Service制御コマンド（eurpmlsctrlコマンド）を実行すると，終了コードが返されます。終了コード一覧を次に示します。

表7‒9 Spool Service制御コマンド（eurpmlsctrlコマンド）の終了コード
終了コード | 意味
0 | Spool Service制御コマンドが正常に終了しました。
4 | Spool Service制御コマンドの実行中，警告が発生しました。
8 | Spool Service制御コマンドの実行中，エラーが発生しました。

Spool Service制御コマンド（eurpmlsctrlコマンド）を呼び出しているプログラムでは，Spool Service制御コマンドの終了コードを参照して，エラーチェックしてください。

(b)　エラーメッセージのフォーマット

Spool Service制御コマンド（eurpmlsctrlコマンド）を実行したとき，標準エラーに出力されるメッセージのフォーマットを次に示します。

eurpmlsctrl:△KEEY0XX-E△エラーメッセージ▼
（凡例）

△：半角空白を示します。

▼：改行（0x0d+0x0a）を示します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 95 / 202


7.7 ファイル監視サービスの起動管理設定 : EUR システム構築ガイド

  • 96 / 202

  • 表紙

  • 7.　帳票サーバを構築する

  • 7.7　ファイル監視サービスの起動管理設定

7.7　ファイル監視サービスの起動管理設定

ファイル監視サービスでは，Windows環境のOSの起動管理機能を使用してファイル監視サービスプログラム（eurfm.exe）の起動や停止を管理します。ファイル監視サービスのサービス名は「EUR File Monitor Service」です。

ファイル監視サービスを自動起動の設定方法については，「7.7.1　ファイル監視サービスの自動起動の設定」を参照してください。

なお，ファイル監視サービスを事前定義型で運用する場合，着信監視するマッピングデータファイルに対応する起動パラメタファイルの情報は，監視定義ファイル（monitordef.conf）で管理します。監視定義ファイルは，メモ帳などのテキストエディタで作成します。

〈この節の構成〉

  • 7.7.1　ファイル監視サービスの自動起動の設定

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 96 / 202


7.7.1 ファイル監視サービスの自動起動の設定 : EUR システム構築ガイド

  • 97 / 202

  • 表紙

  • 7.　帳票サーバを構築する

  • 7.7　ファイル監視サービスの起動管理設定

  • 7.7.1　ファイル監視サービスの自動起動の設定

7.7.1　ファイル監視サービスの自動起動の設定

ファイル監視サービスの自動起動の設定は，Windows環境のOSの起動管理機能を使用します。

  1. スタートメニューの［コントロールパネル］－［管理ツール］－［サービス］を選択する。

    サービス名は「EUR File Monitor Service」です。

    ［サービス］ウィンドウが表示されます。

  2. ファイル監視サービスのサービス名をダブルクリックする。

    サービスのプロパティを設定するダイアログが表示されます。

  3. ［スタートアップの種類］に「自動」を設定する。

  4. ダイアログで［OK］ボタンを設定する。

    自動起動が設定されます。

［スタートアップの種類］が「手動」または「無効」の場合は，ファイル監視サービスを自動起動できません。デフォルトでは，［スタートアップの種類］に「手動」が設定されたファイル監視サービスが一つ登録されています。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 97 / 202


7.8 帳票管理GUIサービスの設定 : EUR システム構築ガイド

  • 98 / 202

  • 表紙

  • 7.　帳票サーバを構築する

  • 7.8　帳票管理GUIサービスの設定

7.8　帳票管理GUIサービスの設定

ここでは，帳票サーバに帳票管理GUIサービスを配置する場合の設定方法について説明します。帳票サーバに帳票管理GUIサービスを配置する場合，JDK 5.0以上を提供するWeb/APサーバの環境が必要です。

なお，帳票管理GUIはイントラネット内でご使用ください。

〈この節の構成〉

  • 7.8.1　JDKのインストール

  • 7.8.2　Web/APサーバのインストール

  • 7.8.3　EUR Web Plug-Inのダウンロードパッケージの配置

  • 7.8.4　サービスプログラムのインストール

  • 7.8.5　起動部品の環境設定

  • 7.8.6　サービスの登録・起動

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 98 / 202


7.8.1 JDKのインストール : EUR システム構築ガイド

  • 99 / 202

  • 表紙

  • 7.　帳票サーバを構築する

  • 7.8　帳票管理GUIサービスの設定

  • 7.8.1　JDKのインストール

7.8.1　JDKのインストール

帳票管理GUIサービスの前提プログラムであるJDK 5.0がインストールされていない場合，JDK 5.0をインストールします。インストール方法については，Web/APサーバのマニュアルを参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 99 / 202


7.8.2 Web/APサーバのインストール : EUR システム構築ガイド

  • 100 / 202

  • 表紙

  • 7.　帳票サーバを構築する

  • 7.8　帳票管理GUIサービスの設定

  • 7.8.2　Web/APサーバのインストール

7.8.2　Web/APサーバのインストール

JDK 5.0が動作するWeb/APサーバをインストールします。EUR Application Serviceも使用できます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 100 / 202


7.8.3 EUR Web Plug-Inのダウンロードパッケージの配置 : EUR システム構築ガイド

  • 101 / 202

  • 表紙

  • 7.　帳票サーバを構築する

  • 7.8　帳票管理GUIサービスの設定

  • 7.8.3　EUR Web Plug-Inのダウンロードパッケージの配置

7.8.3　EUR Web Plug-Inのダウンロードパッケージの配置

帳票管理GUIの初回接続時に，クライアントPCにEUR Web Plug-Inをインストールさせる場合は，帳票管理GUIの環境設定ファイル（EURPMRSGUI.ini）のOPTIONセクションで指定したパスに，EUR Web Plug-Inのダウンロードパッケージを配置します。

EUR Web Plug-Inのダウンロードパッケージは，帳票サーバの次に示すディレクトリに格納されています。インストール方法に応じて，必要なファイルを配置してください。

  • マシン単位でインストールする場合

    • Windows環境

      EUR Serverのインストール先ディレクトリ\Component\Client

    • UNIX／Linux環境

      /opt/eur/component/client

  • ユーザ単位でインストールする場合

    • Windows環境

      EUR Serverのインストール先ディレクトリ\Component\Client\User

    • UNIX／Linux環境

      /opt/eur/component/client/user

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 101 / 202


7.8.4 サービスプログラムのインストール : EUR システム構築ガイド

  • 102 / 202

  • 表紙

  • 7.　帳票サーバを構築する

  • 7.8　帳票管理GUIサービスの設定

  • 7.8.4　サービスプログラムのインストール

7.8.4　サービスプログラムのインストール

帳票管理GUIのサービスプログラム（eurpmrsgui.ear）をWeb/APサーバにデプロイします。war形式のファイルを使用したい場合は，eurpmrsgui.earからwar形式のファイルを取り出してください。

なお，帳票管理GUIのサービスプログラム（eurpmrsgui.ear）は，次のディレクトリに格納されています。

  • Windows環境の場合

    EUR Serverのインストール先ディレクトリ\Component\SpoolServer

  • UNIX／Linux環境の場合

    /opt/eur/component/spool

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 102 / 202


7.8.5 起動部品の環境設定 : EUR システム構築ガイド

  • 103 / 202

  • 表紙

  • 7.　帳票サーバを構築する

  • 7.8　帳票管理GUIサービスの設定

  • 7.8.5　起動部品の環境設定

7.8.5　起動部品の環境設定

EUR Server - AdapterとEUR Server - Spool Service Adapterの環境設定をします。

次に示すファイルのフルパスをクラスパスに設定してください。

  • EUR Server - Adapterの設定

    • Windows環境（32ビット）の場合

      EUR Serverのインストール先ディレクトリ\Adapter\Java\EURPMAdapter.jar

    • Windows環境（64ビット）の場合

      EUR Serverのインストール先ディレクトリ\Adapter\Java(x64)\EURPMAdapter.jar

    • UNIX／Linux環境の場合

      /opt/eur/adapter/java/EURPMAdapter.jar

  • EUR Server - Spool Service Adapterの設定

    • Windows環境（32ビット）の場合

      EUR Serverのインストール先ディレクトリ\Spool Adapter\Java\EURPMLSAdapter.jar

    • Windows環境（64ビット）の場合

      EUR Serverのインストール先ディレクトリ\Spool Adapter\Java(x64)\EURPMLSAdapter.jar

    • UNIX／Linux環境の場合

      /opt/eur/spool-adp/java/EURPMLSAdapter.jar

また，次に示すディレクトリに，ライブラリのパスを通してください。

  • EUR Server - Adapterの設定

    • Windows環境（32ビット）の場合

      EUR Serverのインストール先ディレクトリ\Adapter\Java

    • Windows環境（64ビット）の場合

      EUR Serverのインストール先ディレクトリ\Adapter\Java(x64)

    • UNIX／Linux環境（32ビット）の場合

      /opt/eur/adapter/lib

    • UNIX／Linux環境（64ビット）の場合

      /opt/eur/adapter/lib64

  • EUR Server - Spool Service Adapterの設定

    • Windows環境（32ビット）の場合

      EUR Serverのインストール先ディレクトリ\Spool Adapter\Java

    • Windows環境（64ビット）の場合

      EUR Serverのインストール先ディレクトリ\Spool Adapter\Java(x64)

    • UNIX／Linux環境（32ビット）の場合

      /opt/eur/spool-adp/lib

    • UNIX／Linux環境（64ビット）の場合

      /opt/eur/spool-adp/lib64

クラスパスの設定，およびライブラリのパスの設定については，JDKのマニュアルを参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 103 / 202


7.8.6 サービスの登録・起動 : EUR システム構築ガイド

  • 104 / 202

  • 表紙

  • 7.　帳票サーバを構築する

  • 7.8　帳票管理GUIサービスの設定

  • 7.8.6　サービスの登録・起動

7.8.6　サービスの登録・起動

Web/APサーバに帳票管理GUIサービスを登録，起動します。

サービスの登録方法および起動方法については，Web/APサーバのマニュアルを参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 104 / 202


7.9 配送サービスの設定 : EUR システム構築ガイド

  • 105 / 202

  • 表紙

  • 7.　帳票サーバを構築する

  • 7.9　配送サービスの設定

7.9　配送サービスの設定

ここでは，帳票サーバに配送サービスを配置する場合の設定方法について説明します。

〈この節の構成〉

  • 7.9.1　JDKのインストール

  • 7.9.2　Web/APサーバのインストール

  • 7.9.3　サービスプログラムのインストール

  • 7.9.4　起動部品の環境設定

  • 7.9.5　サービスの登録・起動

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 105 / 202


7.9.1 JDKのインストール : EUR システム構築ガイド

  • 106 / 202

  • 表紙

  • 7.　帳票サーバを構築する

  • 7.9　配送サービスの設定

  • 7.9.1　JDKのインストール

7.9.1　JDKのインストール

配送サービスの前提プログラムである，JDK 5.0をインストールします。インストール方法については，JDKのマニュアルを参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 106 / 202


7.9.2 Web/APサーバのインストール : EUR システム構築ガイド

  • 107 / 202

  • 表紙

  • 7.　帳票サーバを構築する

  • 7.9　配送サービスの設定

  • 7.9.2　Web/APサーバのインストール

7.9.2　Web/APサーバのインストール

JDK 5.0が動作するWeb/APサーバをインストールします。EUR Application Serviceも使用できます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 107 / 202


7.9.3 サービスプログラムのインストール : EUR システム構築ガイド

  • 108 / 202

  • 表紙

  • 7.　帳票サーバを構築する

  • 7.9　配送サービスの設定

  • 7.9.3　サービスプログラムのインストール

7.9.3　サービスプログラムのインストール

配送サービスのサービスプログラム（eurssdeli.ear）をWeb/APサーバにデプロイします。war形式のファイルを使用したい場合は，eurssdeli.earからwar形式のファイルを取り出してください。

なお，配送サービスのサービスプログラム（eurssdeli.ear）は，次のディレクトリに格納されています。

  • Windows環境の場合

    EUR Serverのインストール先ディレクトリ\Component\SpoolServer

  • UNIX／Linux環境の場合

    /opt/eur/component/spool

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 108 / 202


7.9.4 起動部品の環境設定 : EUR システム構築ガイド

  • 109 / 202

  • 表紙

  • 7.　帳票サーバを構築する

  • 7.9　配送サービスの設定

  • 7.9.4　起動部品の環境設定

7.9.4　起動部品の環境設定

EUR Server - Spool Service Adapterの環境設定をします。

次に示すファイルのフルパスをクラスパスに設定してください。

  • EUR Server - Spool Service Adapterの設定

    • Windows環境（32ビット）の場合

      EUR Serverのインストール先ディレクトリ\Spool Adapter\Java\EURPMLSAdapter.jar

    • Windows環境（64ビット）の場合

      EUR Serverのインストール先ディレクトリ\Spool Adapter\Java(x64)\EURPMLSAdapter.jar

    • UNIX／Linux環境の場合

      /opt/eur/spool-adp/java/EURPMLSAdapter.jar

また，次に示すディレクトリに，ライブラリのパスを通してください。

  • EUR Server - Spool Service Adapterの設定

    • Windows環境（32ビット）の場合

      EUR Serverのインストール先ディレクトリ\Spool Adapter\Java

    • Windows環境（64ビット）の場合

      EUR Serverのインストール先ディレクトリ\Spool Adapter\Java(x64)

    • UNIX／Linux環境（32ビット）の場合

      /opt/eur/spool-adp/lib

    • UNIX／Linux環境（64ビット）の場合

      /opt/eur/spool-adp/lib64

クラスパスの設定，およびライブラリのパスの設定については，JDKのマニュアルを参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 109 / 202


7.9.5 サービスの登録・起動 : EUR システム構築ガイド

  • 110 / 202

  • 表紙

  • 7.　帳票サーバを構築する

  • 7.9　配送サービスの設定

  • 7.9.5　サービスの登録・起動

7.9.5　サービスの登録・起動

Web/APサーバに配送サービスを登録，起動します。

サービスの登録方法および起動方法については，Web/APサーバのマニュアルを参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 110 / 202


7.10 業務プログラムの配置と登録 : EUR システム構築ガイド

  • 111 / 202

  • 表紙

  • 7.　帳票サーバを構築する

  • 7.10　業務プログラムの配置と登録

7.10　業務プログラムの配置と登録

ここでは，業務プログラムからEUR Serverを利用するための配置方法と登録方法を説明します。なお，EUR Web Plug-In情報ファイルは，EUR Web Plug-Inを使用する場合に必要です。

〈この節の構成〉

  • 7.10.1　起動部品の設定

  • 7.10.2　EUR Web Plug-In情報ファイルの配置

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 111 / 202


7.10.1 起動部品の設定 : EUR システム構築ガイド

  • 112 / 202

  • 表紙

  • 7.　帳票サーバを構築する

  • 7.10　業務プログラムの配置と登録

  • 7.10.1　起動部品の設定

7.10.1　起動部品の設定

EURが提供する起動部品を使用する場合，次に示す設定をします。

〈この項の構成〉

  • (1)　Java起動部品を使用する場合

  • (2)　SS-Java起動部品を使用する場合

  • (3)　COBOL起動部品を使用する場合

(1)　Java起動部品を使用する場合

次に示すファイルのフルパスをクラスパスに設定してください。

  • Windows環境（32ビット）の場合

    EUR Serverのインストール先ディレクトリ\Adapter\Java\EURPMAdapter.jar

  • Windows環境（64ビット）の場合

    EUR Serverのインストール先ディレクトリ\Adapter\Java(x64)\EURPMAdapter.jar

  • UNIX／Linux環境の場合

    /opt/eur/adapter/java/EURPMAdapter.jar

また，次に示すディレクトリに，ライブラリのパスを通してください。

  • Windows環境（32ビット）の場合

    EUR Serverのインストール先ディレクトリ\Adapter\Java

  • Windows環境（64ビット）の場合

    EUR Serverのインストール先ディレクトリ\Adapter\Java(x64)

  • UNIX／Linux環境（32ビット）の場合

    /opt/eur/adapter/lib

  • UNIX／Linux環境（64ビット）の場合

    /opt/eur/adapter/lib64

クラスパスの設定，およびライブラリのパスの設定については，JDKのマニュアルを参照してください。

ページの先頭へ

(2)　SS-Java起動部品を使用する場合

次に示すファイルのフルパスをクラスパスに設定してください。

  • Windows環境（32ビット）の場合

    EUR Serverのインストール先ディレクトリ\Spool Adapter\Java\EURPMLSAdapter.jar

  • Windows環境（64ビット）の場合

    EUR Serverのインストール先ディレクトリ\Spool Adapter\Java(x64)\EURPMLSAdapter.jar

  • UNIX／Linux環境の場合

    /opt/eur/spool-adp/java/EURPMLSAdapter.jar

また，次に示すディレクトリに，ライブラリのパスを通してください。

  • Windows環境（32ビット）の場合

    EUR Serverのインストール先ディレクトリ\Spool Adapter\Java

  • Windows環境（64ビット）の場合

    EUR Serverのインストール先ディレクトリ\Spool Adapter\Java(x64)

  • UNIX／Linux環境（32ビット）の場合

    /opt/eur/spool-adp/lib

  • UNIX／Linux環境（64ビット）の場合

    /opt/eur/spool-adp/lib64

クラスパスの設定，およびライブラリのパスの設定については，JDKのマニュアルを参照してください。

ページの先頭へ

(3)　COBOL起動部品を使用する場合

次に示すディレクトリにパスを通してください。

  • Windows環境（32ビット）の場合

    EUR Serverのインストール先ディレクトリ\Adapter\COBOL

  • Windows環境（64ビット）の場合

    EUR Serverのインストール先ディレクトリ\Adapter\COBOL(x64)

  • UNIX／Linux環境の場合

    /opt/eur/adapter/lib

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 112 / 202


7.10.2 EUR Web Plug-In情報ファイルの配置 : EUR システム構築ガイド

  • 113 / 202

  • 表紙

  • 7.　帳票サーバを構築する

  • 7.10　業務プログラムの配置と登録

  • 7.10.2　EUR Web Plug-In情報ファイルの配置

7.10.2　EUR Web Plug-In情報ファイルの配置

EUR Web Plug-In情報ファイルとは，EUR Web Plug-In情報を管理するファイルです。ActiveX起動部品またはJava起動部品で，EUR Web Plug-InのクラスIDおよびバージョン情報を取得する場合，次のディレクトリにEUR Web Plug-In情報ファイルを配置します。

  • Windows環境

    EUR Serverのインストール先ディレクトリ\Adapter

  • UNIX／Linux環境

    /var/opt/eur/adapter

配置したEUR Web Plug-In情報ファイル，およびファイルの格納先には，EUR Server - Adapterを利用するユーザが読み書きできるようにアクセス権を設定してください。

なお，EUR Web Plug-In情報ファイルは，EUR Developer，EUR Server Standard，またはEUR Server Enterpriseをインストールするとインストールされます。

EUR Web Plug-In情報ファイルのファイル名と格納先を次に示します。

ファイル名
EURPMPrintAX.inf

印刷用のEUR Web Plug-InのEUR Web Plug-In情報を管理するファイルです。

EURPMPreViewAX.inf

プレビュー用のEUR Web Plug-InのEUR Web Plug-In情報を管理するファイルです。

格納先
EUR Web Plug-Inをマシン単位でインストールする場合

  • Windows環境

    インストール先ディレクトリ\Component\Client

  • UNIX／Linux環境

    /opt/eur/component/client

EUR Web Plug-Inをユーザ単位でインストールする場合

  • Windows環境

    インストール先ディレクトリ\Component\Client\User

  • UNIX／Linux環境

    /opt/eur/component/client/user

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 113 / 202


7.11 監査証跡管理システムとの連携 : EUR システム構築ガイド

  • 114 / 202

  • 表紙

  • 7.　帳票サーバを構築する

  • 7.11　監査証跡管理システムとの連携

7.11　監査証跡管理システムとの連携

EURでは，スプールデータを操作したときの情報を監査ログとして出力できます。

監査ログの運用方法には，次の二つの方法があります。

  • 監査証跡管理システムと連携する

    JP1/Audit Management - Managerを導入して構築する監査証跡管理システムと連携することで，監査ログを自動的に収集して一元管理する運用方法です。

    EUR Server - Spool Serviceの稼働中に監査ログファイルを取得して参照できます。

  • 監査ログを業務プログラムで管理する

    監査ログの管理や運用に独自の規定があるなど，監査証跡管理システムを適用できない場合に，監査ログを業務プログラムで収集して管理する運用方法です。

    監査を実施するときは，監査ログの切り替えを実行してEUR Server - Spool Serviceが出力中の監査ログファイルをバックアップし，バックアップファイルを監査用に参照します。

ここでは，監査証跡管理システムと連携して運用する場合の帳票サーバの構築方法について説明します。監査証跡管理システムは，監査ログ管理サーバと監査ログ収集対象サーバで構成されます。

〈この節の構成〉

  • 7.11.1　監査ログ管理サーバの構築

  • 7.11.2　監査ログ収集対象サーバの構築

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 114 / 202


7.11.1 監査ログ管理サーバの構築 : EUR システム構築ガイド

  • 115 / 202

  • 表紙

  • 7.　帳票サーバを構築する

  • 7.11　監査証跡管理システムとの連携

  • 7.11.1　監査ログ管理サーバの構築

7.11.1　監査ログ管理サーバの構築

監査ログの収集対象のサーバから監査ログを収集して管理するサーバを監査ログ管理サーバと呼びます。

監査ログ管理サーバのプログラムのインストールとセットアップの手順については，マニュアル「JP1/Audit Management - Manager 構築・運用ガイド」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 115 / 202


7.11.2 監査ログ収集対象サーバの構築 : EUR システム構築ガイド

  • 116 / 202

  • 表紙

  • 7.　帳票サーバを構築する

  • 7.11　監査証跡管理システムとの連携

  • 7.11.2　監査ログ収集対象サーバの構築

7.11.2　監査ログ収集対象サーバの構築

監査ログの収集対象のサーバを監査ログ収集対象サーバと呼びます。

EUR Serverのスプールサーバを帳票サーバと別のマシンに構築しない場合は，帳票サーバのマシンに監査ログ収集対象サーバのインストールとセットアップを実施します。また，EUR Serverのスプールサーバを帳票サーバと別のマシンに構築する場合は，スプールサーバのマシンに監査ログ収集対象サーバのインストールとセットアップを実施します。

監査ログ収集対象サーバのプログラムのインストールとセットアップの手順について説明します。

〈この項の構成〉

  • (1)　JP1/Baseのインストールとセットアップ

  • (2)　JP1/Audit Management - Managerのアダプタコマンドのインストールとセットアップ

  • (3)　EUR Serverのアップグレード

  • (4)　EUR Serverの環境設定

(1)　JP1/Baseのインストールとセットアップ

JP1/Baseのインストールとセットアップを実施します。

JP1/Baseのインストールとセットアップの手順については，マニュアル「JP1/Base 運用ガイド」を参照してください。

ページの先頭へ

(2)　JP1/Audit Management - Managerのアダプタコマンドのインストールとセットアップ

JP1/Audit Management - Managerのアダプタコマンドのインストールとセットアップを実施します。

JP1/Audit Management - Managerのアダプタコマンドのインストールとセットアップの手順については，マニュアル「JP1/Audit Management - Manager 構築・運用ガイド」を参照してください。

ページの先頭へ

(3)　EUR Serverのアップグレード

EURをアップグレードする場合は，「11.　EURをアップグレードする」を参照してください。

ページの先頭へ

(4)　EUR Serverの環境設定

EUR Serverの環境設定の手順を説明します。

(a)　サービスの停止

EUR Server - Spool Serviceを停止します。EUR Service - Spool Serverを停止する方法については，「7.6　EUR Server - Spool Serviceの起動管理設定」を参照してください。

(b)　監査ログ出力の設定

EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）を編集して，AUDITセクションのSPOOLAUDITLOGキーで，監査ログを出力するように設定します。

AUDITセクションのSPOOLAUDITLOGキーを次のとおり設定してください。

[AUDIT]
SPOOLAUDITLOG=1

SPOOLAUDITLOGキーの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

(c)　監査ログ出力のモード設定

EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）を編集して，AUDITセクションのSPOOLAUDITLOGキーで，監査ログ出力モードを監査証跡管理システム連携モードに設定します。

AUDITセクションのSPOOLLOGMODEキーを次のとおり設定してください。

[AUDIT]
SPOOLLOGMODE=0

SPOOLLOGMODEキーの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

(d)　監査ログの出力先の設定

EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）を編集して，AUDITセクションのSPOOLLOGキーで，監査ログファイル（eur_spool_audit.log）の出力先を設定します。

SPOOLLOGキーの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

(e)　スプールデータを操作するユーザの設定

スプールデータを操作するユーザの認証方式に「ユーザ管理ファイルによる認証」を使用する場合，スプールデータを操作するデフォルトユーザが，すべてのスプールデータにアクセスできないように設定する運用を推奨します。

スプールデータを操作するユーザの認証方式は，EUR Server - Spool Serverの環境設定ファイル（EURPMLS.ini）のOPTIONセクションのAUTHENTICATIONキーで設定します。AUTHENTICATIONキーの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

スプールデータを操作するデフォルトユーザが，すべてのスプールデータにアクセスできないように設定する場合は，デフォルトユーザを次のとおり設定してください。

［EUR Spool Service 構成定義］ダイアログを使用する場合

  • アクセス制限方式

    「全部」を設定します。

  • ユーザ名が一致する帳票の扱い

    「アクセス制限方式に従う」を設定します。

ユーザ管理ファイルを編集する場合

  • アクセス制限方式

    DefaultセクションのGroupFilterキーに「ALL」を設定します。

  • ユーザ名が一致する帳票の扱い

    DefaultセクションのGroupFilterKeyOwnerキーに「DISENABLE」を設定します。

スプールデータを操作するユーザの定義については，マニュアル「EUR システム構築ガイド」を参照してください。ユーザ管理ファイルについては，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

(f)　監査ログのファイルサイズ上限の設定

EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）を編集して，AUDITセクションのSPOOLLOGSIZEキーで，監査ログファイル（eur_spool_audit.log）のファイルサイズの上限（単位：KB）を設定します。デフォルトは3,000KBです。

ファイルサイズの上限を100MBにする場合の設定例を次に示します。

[AUDIT]
SPOOLLOGSIZE=102400

この例の場合，監査ログファイルが100MBを超えるときに，世代管理が発生し，バックアップファイルが作成されます。

SPOOLLOGSIZEキーの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

(g)　監査ログのバックアップファイル作成時刻の設定

EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）を編集して，AUDITセクションのSPOOLLOGDATEキーで，監査ログファイル（eur_spool_audit.log）の作成時刻（ローカルタイム）を設定します。

監査ログファイルのバックアップファイル作成時刻を設定した場合，監査ログファイルのバックアップファイルは，バックアップ作成時刻を経過したあと，EUR Server - Spool Serviceがスプールデータの操作を実行したタイミングで作成されます（バックアップ作成時刻を経過しただけではバックアップファイルは作成されません）。

SPOOLLOGDATEキーの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

(h)　監査ログのバックアップファイル保持数の設定

EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）を編集して，AUDITセクションのSPOOLLOGNUMキーで，監査ログファイル（eur_spool_audit.log）のバックアップファイルの保持数を設定します。デフォルトは10です。

バックアップファイルの保持数を5にする場合の設定例を次に示します。

[AUDIT]
SPOOLLOGNUM=5

この例の場合，監査ログファイルのバックアップファイルは最大5個まで保持されます。6番目以降の世代のバックアップファイルを作成するときは，世代管理が発生するごとに，世代番号が最も大きいバックアップファイルが削除されます。

SPOOLLOGNUMキーの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

(i)　サービスの起動

EUR Server - Spool Serviceを起動します。EUR Service - Spool Serverを起動する方法については，「7.6　EUR Server - Spool Serviceの起動管理設定」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 116 / 202


8. スプールサーバを帳票サーバとは別に構築する : EUR システム構築ガイド

  • 117 / 202

  • 表紙

  • 8.　スプールサーバを帳票サーバとは別に構築する

8.　スプールサーバを帳票サーバとは別に構築する

この章では，スプールサーバを帳票サーバとは別に構築する場合の構築方法について説明します。

〈この章の構成〉

  • 8.1　構築の流れ

  • 8.2　事前準備

  • 8.3　EUR Server - Spool Serviceのインストール

  • 8.4　必要なファイルのインポート

  • 8.5　EUR Server - Spool Serviceの起動管理設定

  • 8.6　帳票管理GUIサービスの設定

  • 8.7　配送サービスの設定

  • 8.8　業務プログラムの配置と登録

  • 8.9　監査証跡管理システムとの連携

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 117 / 202


8.1 構築の流れ : EUR システム構築ガイド

  • 118 / 202

  • 表紙

  • 8.　スプールサーバを帳票サーバとは別に構築する

  • 8.1　構築の流れ

8.1　構築の流れ

帳票サーバとは別にスプールサーバを構築する場合の構築の流れを次の図に示します。構築する帳票システムのシステム構成に応じて，必要な作業を実施してください。

図8‒1　帳票サーバとは別にスプールサーバを構築する場合の構築の流れ

[図データ]

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 118 / 202


8.2 事前準備 : EUR システム構築ガイド

  • 119 / 202

  • 表紙

  • 8.　スプールサーバを帳票サーバとは別に構築する

  • 8.2　事前準備

8.2　事前準備

スプールサーバを構築する前に，事前に準備しておくことを次に示します。

  • マシンの準備（必須）

    スプールサーバとして使用するマシンを準備します。

  • インストール媒体の準備（必須）

    スプールサーバにインストールするEUR Server - Spool Serviceの再配布パッケージを準備します。EUR Server - Spool Serviceの再配布パッケージは，帳票サーバの次に示すディレクトリに格納されています。

    • Windows環境の場合

      EUR Serverのインストール先ディレクトリ\Component\SpoolServer

    • UNIX／Linux環境の場合

      /opt/eur/component/spool

    また，スプールサーバに帳票管理GUIサービスや業務プログラムを配置する場合は，Web/APサーバやJDKなどの前提製品のインストール媒体も準備します。

  • ファイルの準備（必須）

    スプールサーバに格納するファイルを準備します。準備方法については，「6.　帳票の出力環境を設定するファイルを準備する」を参照してください。

  • 業務プログラムの準備（任意）

    スプールサーバに業務プログラムを配置する場合，配置する業務プログラムのプログラムファイルを準備します。

  • 構築で使用するユーザの作成（任意）

    必要に応じて，スプールサーバの構築で使用するユーザを作成します。

    スプールサーバの構築で使用するユーザには，必ず管理者権限を設定してください。

  • インストール先ディレクトリとアクセス権の設定（任意）

    必要に応じて，製品をインストールするためのディレクトリを作成します。

    作成したディレクトリには，スプールサーバを構築するユーザに対して，必要なアクセス権を設定してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 119 / 202


8.3 EUR Server - Spool Serviceのインストール : EUR システム構築ガイド

  • 120 / 202

  • 表紙

  • 8.　スプールサーバを帳票サーバとは別に構築する

  • 8.3　EUR Server - Spool Serviceのインストール

8.3　EUR Server - Spool Serviceのインストール

ここでは，EUR Server - Spool Serviceのインストール方法について説明します。

〈この節の構成〉

  • 8.3.1　インストール方法

  • 8.3.2　インストール後に作成されるディレクトリ

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 120 / 202


8.3.1 インストール方法 : EUR システム構築ガイド

  • 121 / 202

  • 表紙

  • 8.　スプールサーバを帳票サーバとは別に構築する

  • 8.3　EUR Server - Spool Serviceのインストール

  • 8.3.1　インストール方法

8.3.1　インストール方法

〈この項の構成〉

  • (1)　インストールの前に

  • (2)　インストール手順

(1)　インストールの前に

  • 管理者権限を持つユーザでログインしてください。

  • インストール時に必要なディスク空き容量を確認してください。

  • ほかのユーザアプリケーションを終了してください。

  • OSから実行許可についてのダイアログが表示されることがあります。このときには，実行を許可する応答をしてください。

ページの先頭へ

(2)　インストール手順

EUR Server - Spool Serviceのインストール方法は，Windows環境とUNIX／Linux環境とで異なります。

(a)　Windows環境の場合

EUR Server - Spool Serviceの再配布パッケージ（EURPM-LS.exe）を実行すると，インストーラが起動します。画面の指示に従ってインストールを完了させてください。

インストール画面は，Windowsインストール時の言語で表示されます。ロケールが英語，中国語，日本語のどれでもない場合は英語で表示されます。ただし，サポートしていないロケールで実行した場合，EURの動作は保証されません。

(b)　UNIX／Linux環境の場合

UNIX／Linux環境の場合，次の手順でインストールします。

  1. 次のファイルを同一ディレクトリに格納します。

    • EUR Server - Spool Serviceの再配布パッケージ（EURPM-LS-pppp.tar）

    • インストール用のシェルスクリプト（EURPM-LS-pppp.sh）

    ppppには次のプラットフォーム名が表示されます。

    AIXの場合：AIX

    HP-UXの場合：HPIPF

    Linuxの場合：RHEL

  2. インストール用のシェルスクリプト（EURPM-LS-pppp.sh）を実行します。

    日立PPインストーラが起動して，メインメニューが表示されます。

  3. ［I］を選択します。

    インストール画面が表示されます。

  4. EUR Server - Spool Serviceにカーソルを移動させて，スペースキーを押します。

    選択した製品の左側に「<@>」が表示されます。

            PP-NO.          VR                  PP-NAME
<@>001  形名        バージョン番号     EUR Server - Spool Service
     ：
F) Forward B) Backward J) Down K) Up Space) Select/Unselect I) Install Q) Quit

  5. ［I］を入力します。

    確認メッセージが表示されます。

    Install PP? (y: install,  n: cancel)==>

  6. ［y］または［Y］を選択します。

    インストールが開始されます。［y］または［Y］以外を選択すると，インストールが中止されてインストール画面に戻ります。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 121 / 202


8.3.2 インストール後に作成されるディレクトリ : EUR システム構築ガイド

  • 122 / 202

  • 表紙

  • 8.　スプールサーバを帳票サーバとは別に構築する

  • 8.3　EUR Server - Spool Serviceのインストール

  • 8.3.2　インストール後に作成されるディレクトリ

8.3.2　インストール後に作成されるディレクトリ

EUR Server - Spool Serviceのインストール後に作成されるディレクトリについて説明します。

〈この項の構成〉

  • (1)　Windows環境の場合

  • (2)　UNIX／Linux環境の場合

(1)　Windows環境の場合

表8‒1 EUR Server - Spool Serviceのインストール後に作成されるディレクトリ（Windows環境の場合）
ディレクトリまたはファイル名 | 内容
%EUR% | EURのルートディレクトリ
Spool\ | EUR Server - Spool Serviceのルートディレクトリ
Program\ | 実行ファイル格納ディレクトリ
EURPMLS.exe | EUR Server - Spool Service実行ファイル
EURPMULM.exe | ［EUR Spool Service 構成定義］ダイアログ実行ファイル
EURSSECD.exe | LDAP接続情報暗号化ツール
Conf\ | 構成定義ファイル格納ディレクトリ
ESF\ | スプールデータ格納ディレクトリ
POB\ | 私書箱ディレクトリ
Temp\ | 一時ファイルディレクトリ
Spool Adapter\ | EUR Server - Spool Service Adapterのルートディレクトリ
Program\ | 実行ファイル格納ディレクトリ
EURPMLSC.exe | SS-コマンド起動部品（eurpmlscコマンド）
EURPMLSADP.ocx | SS-ActiveX起動部品（32ビット版）
Program(x64)\ | 実行ファイル格納ディレクトリ
EURPMLSADP.ocx | SS-ActiveX起動部品（64ビット版）
Java\ | SS-Java起動部品格納ディレクトリ
EURPMLSAdapter.jar | SS-Java起動部品（32ビット版）
EURPMLSADJ.dll
Java(x64)\ | SS-Java起動部品格納ディレクトリ
EURPMLSAdapter.jar | SS-Java起動部品（64ビット版）
EURPMLSADJ.dll
Log\ | ログディレクトリ
（凡例）

%EUR%：EUR Server - Spool Serviceのインストール先ディレクトリを示します。

ページの先頭へ

(2)　UNIX／Linux環境の場合

表8‒2 EUR Server - Spool Serviceのインストール後に作成されるディレクトリ（UNIX／Linux環境の場合）
ディレクトリまたはファイル名 | 内容
/opt/eur/ | EURのルートディレクトリ
spool/ | EUR Server - Spool Serviceのルートディレクトリ
bin/ | 実行ファイル格納ディレクトリ
eurpmlsd | EUR Server - Spool Service実行ファイル
eurpmlsctrl | Spool Service制御コマンド（eurpmlsctrlコマンド）
lib/ | 共有ライブラリディレクトリ
spool-adp/ | EUR Server - Spool Service Adapterのルートディレクトリ
bin/ | 実行ファイル格納ディレクトリ
eurpmlsc | SS-コマンド起動部品（eurpmlscコマンド）
java/ | SS-Java起動部品格納ディレクトリ
EURPMLSAdapter.jar | SS-Java起動部品（32ビット版・64ビット版共通）
lib/ | 共有ライブラリディレクトリ
libEURPMLSADJ.so | SS-Java起動部品（32ビット版）
lib64/ | 共有ライブラリディレクトリ
libEURPMLSADJ.so | SS-Java起動部品（64ビット版）
sample/ | サンプル格納ディレクトリ
/var/opt/eur/ | データディレクトリ
spool/ | EUR Server - Spool ServiceおよびSpool Service制御コマンド（eurpmlsctrlコマンド）の環境設定ファイル格納ディレクトリ
Conf/ | 構成定義ファイル格納ディレクトリ
ESF/ | スプールデータ格納ディレクトリ
POB/ | 私書箱ディレクトリ
Temp/ | 一時ファイルディレクトリ
spool-adp/ | EUR Server - Spool Service Adapterおよび帳票管理GUIの環境設定ファイル格納ディレクトリ
log/ | ログディレクトリ

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 122 / 202


8.4 必要なファイルのインポート : EUR システム構築ガイド

  • 123 / 202

  • 表紙

  • 8.　スプールサーバを帳票サーバとは別に構築する

  • 8.4　必要なファイルのインポート

8.4　必要なファイルのインポート

「6.　帳票の出力環境を設定するファイルを準備する」で準備したファイルのうち，スプールサーバに格納するファイルをインポートします。スプールサーバのロケールに応じたエンコードを設定してインポートしてください。

スプールサーバにインポートするファイルを，次の表に示します。

表8‒3　スプールサーバにインポートするファイル

ファイルの種類

ファイル名

説明

環境設定ファイル

EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）

必ずインポートします。

  • Spool Service制御コマンド（eurpmlsctrlコマンド）の環境設定ファイル（EURPMLSCTRL.ini）※1

  • EUR Server - Adapterの環境設定ファイル（EURPMADP.ini）

  • EUR Server - Spool Service Adapterの環境設定ファイル（EURPMLSADP.ini）

  • 帳票管理GUIの環境設定ファイル（EURPMRSGUI.ini）

必要なファイルをインポートします。

構成定義ファイル

  • 拠点プリンタクラス定義ファイル（ServerPrinterClass.conf）※2

  • 帳票振り分け定義ファイル（Distribution.conf）※2

  • ユーザ管理ファイル（userdef.conf）
注※1

スプールサーバがWindows環境の場合，Spool Service制御コマンド（eurpmlsctrlコマンド）は使用できません。そのため，Spool Service制御コマンドの環境設定ファイル（EURPMLSCTRL.ini）のインポートは不要です。

注※2

スプールサーバがUNIX／Linux環境の場合，スプールサーバのプリンタには帳票を出力できません。そのため，次のファイルをインポートしても帳票出力には使用できません。

・拠点プリンタクラス定義ファイル（ServerPrinterClass.conf）

・帳票振り分け定義ファイル（Distribution.conf）

なお，ファイルのインポート後は次の作業を実施してください。

  • 環境設定ファイルをインポートした場合は，次のコンポーネントを再起動してください。

    • EUR Server - Spool Service

    • EUR Server - Adapterを使用しているプログラム

    • EUR Server - Spool Service Adapterを使用しているプログラム

  • 構成定義ファイルをインポートした場合は，EUR Server - Spool Serviceを再起動してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 123 / 202


8.5 EUR Server - Spool Serviceの起動管理設定 : EUR システム構築ガイド

  • 124 / 202

  • 表紙

  • 8.　スプールサーバを帳票サーバとは別に構築する

  • 8.5　EUR Server - Spool Serviceの起動管理設定

8.5　EUR Server - Spool Serviceの起動管理設定

スプールサーバでのEUR Server - Spool Serviceの起動管理設定は，帳票サーバと同じです。起動管理設定の詳細については，「7.6　EUR Server - Spool Serviceの起動管理設定」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 124 / 202


8.6 帳票管理GUIサービスの設定 : EUR システム構築ガイド

  • 125 / 202

  • 表紙

  • 8.　スプールサーバを帳票サーバとは別に構築する

  • 8.6　帳票管理GUIサービスの設定

8.6　帳票管理GUIサービスの設定

スプールサーバでの帳票管理GUIサービスの設定方法は，帳票サーバと同じです。帳票管理GUIサービスの設定の詳細については，「7.8　帳票管理GUIサービスの設定」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 125 / 202


8.7 配送サービスの設定 : EUR システム構築ガイド

  • 126 / 202

  • 表紙

  • 8.　スプールサーバを帳票サーバとは別に構築する

  • 8.7　配送サービスの設定

8.7　配送サービスの設定

スプールサーバでの配送サービスの設定方法は，帳票サーバと同じです。配送サービスの設定の詳細については，「7.9　配送サービスの設定」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 126 / 202


8.8 業務プログラムの配置と登録 : EUR システム構築ガイド

  • 127 / 202

  • 表紙

  • 8.　スプールサーバを帳票サーバとは別に構築する

  • 8.8　業務プログラムの配置と登録

8.8　業務プログラムの配置と登録

スプールサーバでの業務プログラムの配置方法と登録方法は，帳票サーバと同じです。詳細については，「7.10　業務プログラムの配置と登録」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 127 / 202


8.9 監査証跡管理システムとの連携 : EUR システム構築ガイド

  • 128 / 202

  • 表紙

  • 8.　スプールサーバを帳票サーバとは別に構築する

  • 8.9　監査証跡管理システムとの連携

8.9　監査証跡管理システムとの連携

スプールサーバでの監査証跡管理システムとの連携方法は，帳票サーバと同じです。詳細については，「7.11　監査証跡管理システムとの連携」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 128 / 202


9. アプリケーションサーバを帳票サーバとは別に構築する : EUR システム構築ガイド

  • 129 / 202

  • 表紙

  • 9.　アプリケーションサーバを帳票サーバとは別に構築する

9.　アプリケーションサーバを帳票サーバとは別に構築する

この章では，アプリケーションサーバを帳票サーバとは別に構築する場合の構築方法について説明します。

〈この章の構成〉

  • 9.1　構築の流れ

  • 9.2　事前準備

  • 9.3　前提プログラムのインストール

  • 9.4　EUR Server - Adapterのインストール

  • 9.5　EUR Server - Spool Service Adapterのインストール

  • 9.6　必要なファイルのインポート

  • 9.7　ファイル監視サービスの起動管理設定

  • 9.8　帳票管理GUIサービスの設定

  • 9.9　配送サービスの設定

  • 9.10　業務プログラムの配置と登録

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 129 / 202


9.1 構築の流れ : EUR システム構築ガイド

  • 130 / 202

  • 表紙

  • 9.　アプリケーションサーバを帳票サーバとは別に構築する

  • 9.1　構築の流れ

9.1　構築の流れ

帳票サーバとは別にアプリケーションサーバを構築する場合の流れを次の図に示します。構築する帳票システムのシステム構成に応じて，必要な作業を実施してください。

図9‒1　帳票サーバとは別にアプリケーションサーバを構築する場合の構築の流れ

[図データ]

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 130 / 202


9.2 事前準備 : EUR システム構築ガイド

  • 131 / 202

  • 表紙

  • 9.　アプリケーションサーバを帳票サーバとは別に構築する

  • 9.2　事前準備

9.2　事前準備

アプリケーションサーバを構築する前に，事前に準備しておくことを次に示します。

  • マシンの準備（必須）

    アプリケーションサーバとして使用するマシンを準備します。

  • インストール媒体の準備（必須）

    アプリケーションサーバにインストールするEUR製品の再配布パッケージを準備します。

    アプリケーションサーバに帳票管理GUIサービスや業務プログラムを配置する場合は，JDKやCOBOL2002 Net Server Suiteなどの前提製品のインストール媒体も準備します。

  • ファイルの準備（必須）

    アプリケーションサーバに格納するファイルを準備します。準備方法については，次の章を参照してください。

    • 5.　帳票の出力内容を設定するファイルを準備する

    • 6.　帳票の出力環境を設定するファイルを準備する

  • 業務プログラムの準備（必須）

    アプリケーションサーバに業務プログラムを配置する場合，配置する業務プログラムのプログラムファイルを準備します。

  • 構築で使用するユーザの作成（任意）

    必要に応じて，アプリケーションサーバの構築で使用するユーザを作成します。

    アプリケーションサーバの構築で使用するユーザには，必ず管理者権限を設定してください。

  • インストール先ディレクトリとアクセス権の設定（任意）

    必要に応じて，製品をインストールするためのディレクトリを作成します。

    作成したディレクトリには，アプリケーションサーバを構築するユーザに対して，必要なアクセス権を設定してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 131 / 202


9.3 前提プログラムのインストール : EUR システム構築ガイド

  • 132 / 202

  • 表紙

  • 9.　アプリケーションサーバを帳票サーバとは別に構築する

  • 9.3　前提プログラムのインストール

9.3　前提プログラムのインストール

ここでは，アプリケーションサーバ上で動作するプログラムの前提プログラムのインストールについて説明します。

インストールが必要な前提プログラムを次に示します。

〈この節の構成〉

  • 9.3.1　アプリケーションサーバ

  • 9.3.2　起動部品の前提プログラム

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 132 / 202


9.3.1 アプリケーションサーバ : EUR システム構築ガイド

  • 133 / 202

  • 表紙

  • 9.　アプリケーションサーバを帳票サーバとは別に構築する

  • 9.3　前提プログラムのインストール

  • 9.3.1　アプリケーションサーバ

9.3.1　アプリケーションサーバ

業務プログラムに対応するアプリケーションサーバをインストールしてください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 133 / 202


9.3.2 起動部品の前提プログラム : EUR システム構築ガイド

  • 134 / 202

  • 表紙

  • 9.　アプリケーションサーバを帳票サーバとは別に構築する

  • 9.3　前提プログラムのインストール

  • 9.3.2　起動部品の前提プログラム

9.3.2　起動部品の前提プログラム

起動部品の前提プログラムをインストールしてください。

  • Java起動部品，およびSS-Java起動部品を使用する場合

    JDK5.0以降をインストールしてください。

  • 32ビット版のCOBOL起動部品を使用する場合

    COBOL2002 Net Server Suiteをインストールしてください。

  • 64ビット版のCOBOL起動部品を使用する場合

    次のどれかをインストールしてください。

    • COBOL2002 Net Developer(64)

    • COBOL2002 Net Server Runtime(64)

    • COBOL2002 Net Server Suite(64)

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 134 / 202


9.4 EUR Server - Adapterのインストール : EUR システム構築ガイド

  • 135 / 202

  • 表紙

  • 9.　アプリケーションサーバを帳票サーバとは別に構築する

  • 9.4　EUR Server - Adapterのインストール

9.4　EUR Server - Adapterのインストール

ここでは，EUR Server - Adapterのインストール方法について説明します。

〈この節の構成〉

  • 9.4.1　インストール方法

  • 9.4.2　インストール後に作成されるディレクトリ

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 135 / 202


9.4.1 インストール方法 : EUR システム構築ガイド

  • 136 / 202

  • 表紙

  • 9.　アプリケーションサーバを帳票サーバとは別に構築する

  • 9.4　EUR Server - Adapterのインストール

  • 9.4.1　インストール方法

9.4.1　インストール方法

〈この項の構成〉

  • (1)　インストールの前に

  • (2)　インストール手順

  • (3)　注意事項

(1)　インストールの前に

  • 管理者権限を持つユーザでログインしてください。

  • インストール時に必要なディスク空き容量を確認してください。

  • ほかのユーザアプリケーションを終了してください。

  • OSから実行許可についてのダイアログが表示されることがあります。このときには，実行を許可する応答をしてください。

ページの先頭へ

(2)　インストール手順

EUR Server - Adapterのインストール方法は，Windows環境とUNIX／Linux環境とで異なります。

(a)　Windows環境の場合

EUR Server - Adapterの再配布パッケージ（EURPM-ADP.exe）を実行すると，インストーラが起動します。画面の指示に従ってインストールを完了させてください。

インストール画面は，Windowsインストール時の言語で表示されます。ロケールが英語，中国語，日本語のどれでもない場合は英語で表示されます。ただし，サポートしていないロケールで実行した場合，EURの動作は保証されません。

(b)　UNIX／Linux環境の場合

UNIX／Linux環境の場合，次の手順でインストールします。

  1. 次のファイルを同一ディレクトリに格納します。

    • EUR Server - Adapterの再配布パッケージ（EURPM-ADP-pppp.tar）

    • インストール用のシェルスクリプト（EURPM-ADP-pppp.sh）

    ppppには次のプラットフォーム名が表示されます。

    AIXの場合：AIX

    HP-UXの場合：HPIPF

    Linuxの場合：RHEL

  2. インストール用のシェルスクリプト（EURPM-ADP-pppp.sh）を実行します。

    日立PPインストーラが起動して，メインメニューが表示されます。

  3. ［I］を選択します。

    インストール画面が表示されます。

  4. EUR Server - Adapterにカーソルを移動させて，スペースキーを押します。

    選択した製品の左側に「<@>」が表示されます。

            PP-NO.          VR                  PP-NAME
<@>001  形名        バージョン番号     EUR Server - Adapter
     ：
F) Forward B) Backward J) Down K) Up Space) Select/Unselect I) Install Q) Quit

  5. ［I］を入力します。

    確認メッセージが表示されます。

    Install PP? (y: install,  n: cancel)==>

  6. ［y］または［Y］を選択します。

    インストールが開始されます。［y］または［Y］以外を選択すると，インストールが中止されてインストール画面に戻ります。

ページの先頭へ

(3)　注意事項

EUR Server - AdapterのWindows用再配布パッケージ（32ビット）（EURPM-ADP32.exe）とWindows用再配布パッケージ（64ビット）（EURPM-ADP.exe）は同一マシンにインストールしないでください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 136 / 202


9.4.2 インストール後に作成されるディレクトリ : EUR システム構築ガイド

  • 137 / 202

  • 表紙

  • 9.　アプリケーションサーバを帳票サーバとは別に構築する

  • 9.4　EUR Server - Adapterのインストール

  • 9.4.2　インストール後に作成されるディレクトリ

9.4.2　インストール後に作成されるディレクトリ

EUR Server - Adapterのインストール後に作成されるディレクトリについて説明します。

〈この項の構成〉

  • (1)　Windows環境の場合

  • (2)　UNIX／Linux環境の場合

(1)　Windows環境の場合

表9‒1 EUR Server - Adapterのインストール後に作成されるディレクトリ（Windows環境の場合）
ディレクトリまたはファイル名 | 内容
%EUR% | EURのルートディレクトリ
Adapter\ | EUR Server - Adapterのルートディレクトリ
Program\ | 実行ファイル格納ディレクトリ
EURPMC.exe | コマンド起動部品（eurpmcコマンド）
EURPMADP.ocx | ActiveX起動部品（32ビット版）
Program(x64)\ | 実行ファイル格納ディレクトリ
EURPMADP.ocx | ActiveX起動部品（64ビット版）
Java\ | Java起動部品格納ディレクトリ
EURPMAdapter.jar | Java起動部品（32ビット版）
EURPMADJ.dll
Java(x64)\ | Java起動部品格納ディレクトリ
EURPMAdapter.jar | Java起動部品（64ビット版）
EURPMADJ.dll
COBOL\ | COBOL起動部品格納ディレクトリ
EURPMADC.dll | COBOL起動部品（32ビット版）
EURPMADC.lib
COBOL(x64)\ | COBOL起動部品格納ディレクトリ
EURPMADC.dll | COBOL起動部品（64ビット版）
EURPMADC.lib
Eursmpr\ | BSP-RM連携コマンド（eursmprコマンド）のルートディレクトリ
program\ | 実行ファイル格納ディレクトリ
eursmpr.exe | BSP-RM連携コマンド（eursmprコマンド）
divdata\ | 制御情報付データファイル格納ディレクトリ
runparam\ | 起動パラメタファイル格納ディレクトリ
temp\ | 一時ファイルディレクトリ
FileMonitor\ | ファイル監視サービスのルートディレクトリ
program\ | 実行ファイル格納ディレクトリ
eurfm.exe | ファイル監視サービスプログラム
eurivk.exe | ジョブ実行プログラム
fmc\ | 監視管理ディレクトリ
monitor\ | 監視ディレクトリ
check\ | 照合ディレクトリ
data\ | 完了ディレクトリ
conf\ | 構成定義ファイル格納ディレクトリ
runparam\ | 起動パラメタファイル格納ディレクトリ
Log\ | ログディレクトリ
（凡例）

%EUR%：EUR Server - Adapterのインストール先ディレクトリを示します。

ページの先頭へ

(2)　UNIX／Linux環境の場合

表9‒2 EUR Server - Adapterのインストール後に作成されるディレクトリ（UNIX／Linux環境の場合）
ディレクトリまたはファイル名 | 内容
/opt/eur/ | EURのルートディレクトリ
adapter/ | EUR Server - Adapterのルートディレクトリ
bin/ | 実行ファイル格納ディレクトリ
eurpmc | コマンド起動部品（eurpmcコマンド）
java/ | Java起動部品格納ディレクトリ
EURPMAdapter.jar | Java起動部品（32ビット版・64ビット版共通）
lib/ | 共有ライブラリディレクトリ
libEURPMADJ.so | Java起動部品（32ビット版）
libEURPMADC.so | COBOL起動部品
lib64/ | 共有ライブラリディレクトリ
libEURPMADJ.so | Java起動部品（64ビット版）
/var/opt/eur/ | データディレクトリ
adapter/ | EUR Server - Adapterの環境設定ファイル格納ディレクトリ
log/ | ログディレクトリ

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 137 / 202


9.5 EUR Server - Spool Service Adapterのインストール : EUR システム構築ガイド

  • 138 / 202

  • 表紙

  • 9.　アプリケーションサーバを帳票サーバとは別に構築する

  • 9.5　EUR Server - Spool Service Adapterのインストール

9.5　EUR Server - Spool Service Adapterのインストール

ここでは，EUR Server - Spool Service Adapterのインストール方法について説明します。

〈この節の構成〉

  • 9.5.1　インストール方法

  • 9.5.2　インストール後に作成されるディレクトリ

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 138 / 202


9.5.1 インストール方法 : EUR システム構築ガイド

  • 139 / 202

  • 表紙

  • 9.　アプリケーションサーバを帳票サーバとは別に構築する

  • 9.5　EUR Server - Spool Service Adapterのインストール

  • 9.5.1　インストール方法

9.5.1　インストール方法

〈この項の構成〉

  • (1)　インストールの前に

  • (2)　インストール手順

  • (3)　注意事項

(1)　インストールの前に

  • 管理者権限を持つユーザでログインしてください。

  • インストール時に必要なディスク空き容量を確認してください。

  • ほかのユーザアプリケーションを終了してください。

  • OSから実行許可についてのダイアログが表示されることがあります。このときには，実行を許可する応答をしてください。

ページの先頭へ

(2)　インストール手順

EUR Server - Spool Service Adapterのインストール方法は，Windows環境とUNIX／Linux環境とで異なります。

(a)　Windows環境の場合

EUR Server - Spool Service Adapterの再配布パッケージ（EURPM-LS-ADP.exe）を実行すると，インストーラが起動します。画面の指示に従ってインストールを完了させてください。

インストール画面は，Windowsインストール時の言語で表示されます。ロケールが英語，中国語，日本語のどれでもない場合は英語で表示されます。ただし，サポートしていないロケールで実行した場合，EURの動作は保証されません。

(b)　UNIX／Linux環境の場合

UNIX／Linux環境の場合，次の手順でインストールします。

  1. 次のファイルを同一ディレクトリに格納します。

    • EUR Server - Spool Service Adapterの再配布パッケージ（EURPM-LS-ADP-pppp.tar）

    • インストール用のシェルスクリプト（EURPM-LS-ADP-pppp.sh）

    ppppには次のプラットフォーム名が表示されます。

    AIXの場合：AIX

    HP-UXの場合：HPIPF

    Linuxの場合：RHEL

  2. インストール用のシェルスクリプト（EURPM-LS-ADP-pppp.sh）を実行します。

    日立PPインストーラが起動して，メインメニューが表示されます。

  3. ［I］を選択します。

    インストール画面が表示されます。

  4. EUR Server - Spool Service Adapterにカーソルを移動させて，スペースキーを押します。

    選択した製品の左側に「<@>」が表示されます。

            PP-NO.          VR                  PP-NAME
<@>001  形名        バージョン番号     EUR Server - Spool Service Adapter
     ：
F) Forward B) Backward J) Down K) Up Space) Select/Unselect I) Install Q) Quit

  5. ［I］を入力します。

    確認メッセージが表示されます。

    Install PP? (y: install,  n: cancel)==>

  6. ［y］または［Y］を選択します。

    インストールが開始されます。［y］または［Y］以外を選択すると，インストールが中止されてインストール画面に戻ります。

ページの先頭へ

(3)　注意事項

EUR Server - Spool Service AdapterのWindows用再配布パッケージ（32ビット）（EURPM-LS-ADP32.exe）とWindows用再配布パッケージ（64ビット）（EURPM-LS-ADP.exe）は同一マシンにインストールしないでください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 139 / 202


9.5.2 インストール後に作成されるディレクトリ : EUR システム構築ガイド

  • 140 / 202

  • 表紙

  • 9.　アプリケーションサーバを帳票サーバとは別に構築する

  • 9.5　EUR Server - Spool Service Adapterのインストール

  • 9.5.2　インストール後に作成されるディレクトリ

9.5.2　インストール後に作成されるディレクトリ

EUR Server - Spool Service Adapterのインストール後に作成されるディレクトリについて説明します。

〈この項の構成〉

  • (1)　Windows環境の場合

  • (2)　UNIX／Linux環境の場合

(1)　Windows環境の場合

表9‒3 EUR Server - Spool Service Adapterのインストール後に作成されるディレクトリ（Windows環境の場合）
ディレクトリまたはファイル名 | 内容
%EUR% | EURのルートディレクトリ
Spool Adapter\ | EUR Server - Spool Service Adapterのルートディレクトリ
Program\ | 実行ファイル格納ディレクトリ
EURPMLSC.exe | SS-コマンド起動部品（eurpmlscコマンド）
EURPMLSADP.ocx | SS-ActiveX起動部品（32ビット版）
Program(x64)\ | 実行ファイル格納ディレクトリ
EURPMLSADP.ocx | SS-ActiveX起動部品（64ビット版）
Java\ | SS-Java起動部品格納ディレクトリ
EURPMLSAdapter.jar | SS-Java起動部品（32ビット版）
EURPMLSADJ.dll
Java(x64)\ | SS-Java起動部品格納ディレクトリ
EURPMLSAdapter.jar | SS-Java起動部品（64ビット版）
EURPMLSADJ.dll
Log\ | ログディレクトリ
（凡例）

%EUR%：EUR Server - Spool Service Adapterのインストール先ディレクトリを示します。

ページの先頭へ

(2)　UNIX／Linux環境の場合

表9‒4 EUR Server - Spool Service Adapterのインストール後に作成されるディレクトリ（UNIX／Linux環境の場合）
ディレクトリまたはファイル名 | 内容
/opt/eur/ | EURのルートディレクトリ
spool-adp/ | EUR Server - Spool Service Adapterのルートディレクトリ
bin/ | 実行ファイル格納ディレクトリ
eurpmlsc | SS-コマンド起動部品（eurpmlscコマンド）
java/ | SS-Java起動部品格納ディレクトリ
EURPMLSAdapter.jar | SS-Java起動部品（32ビット版・64ビット版共通）
lib/ | 共有ライブラリディレクトリ
libEURPMLSADJ.so | SS-Java起動部品（32ビット版）
lib64/ | 共有ライブラリディレクトリ
libEURPMLSADJ.so | SS-Java起動部品（64ビット版）
/var/opt/eur/ | データディレクトリ
spool-adp/ | EUR Server - Spool Service Adapterおよび帳票管理GUIの環境設定ファイル格納ディレクトリ
log/ | ログディレクトリ

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 140 / 202


9.6 必要なファイルのインポート : EUR システム構築ガイド

  • 141 / 202

  • 表紙

  • 9.　アプリケーションサーバを帳票サーバとは別に構築する

  • 9.6　必要なファイルのインポート

9.6　必要なファイルのインポート

「5.　帳票の出力内容を設定するファイルを準備する」および「6.　帳票の出力環境を設定するファイルを準備する」で準備したファイルのうち，アプリケーションサーバに格納するファイルをインポートします。アプリケーションサーバのロケールに応じたエンコードを設定してインポートしてください。

アプリケーションサーバにインポートするファイルを，次の表に示します。

表9‒5　アプリケーションサーバにインポートするファイル

ファイルの種類

ファイル名

説明

帳票の出力内容を設定するファイル

データファイル，可変記号値定義ファイルなど

必要なファイルをインポートします。

環境設定ファイル

  • EUR Server - Adapterの環境設定ファイル（EURPMADP.ini）

  • EUR Server - Spool Service Adapterの環境設定ファイル（EURPMLSADP.ini）

  • 帳票管理GUIの環境設定ファイル（EURPMRSGUI.ini）

  • BSP-RM連携コマンド（eursmprコマンド）の環境設定ファイル（eursmpr.ini）

  • ファイル監視サービスの環境設定ファイル（eurfm.ini）

  • ジョブ実行プログラムの環境設定ファイル（eurivk.ini）

なお，環境設定ファイルをインポートした場合は，次のコンポーネントを再起動してください。

  • EUR Server - Adapterを使用しているプログラム

  • EUR Server - Spool Service Adapterを使用しているプログラム

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 141 / 202


9.7 ファイル監視サービスの起動管理設定 : EUR システム構築ガイド

  • 142 / 202

  • 表紙

  • 9.　アプリケーションサーバを帳票サーバとは別に構築する

  • 9.7　ファイル監視サービスの起動管理設定

9.7　ファイル監視サービスの起動管理設定

アプリケーションサーバでのファイル監視サービスの設定方法は，帳票サーバと同じです。ファイル監視サービスの設定の詳細については，「7.7　ファイル監視サービスの起動管理設定」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 142 / 202


9.8 帳票管理GUIサービスの設定 : EUR システム構築ガイド

  • 143 / 202

  • 表紙

  • 9.　アプリケーションサーバを帳票サーバとは別に構築する

  • 9.8　帳票管理GUIサービスの設定

9.8　帳票管理GUIサービスの設定

アプリケーションサーバでの帳票管理GUIサービスの設定方法は，帳票サーバと同じです。帳票管理GUIサービスの設定の詳細については，「7.8　帳票管理GUIサービスの設定」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 143 / 202


9.9 配送サービスの設定 : EUR システム構築ガイド

  • 144 / 202

  • 表紙

  • 9.　アプリケーションサーバを帳票サーバとは別に構築する

  • 9.9　配送サービスの設定

9.9　配送サービスの設定

アプリケーションサーバでの配送サービスの設定方法は，帳票サーバと同じです。配送サービスの設定の詳細については，「7.9　配送サービスの設定」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 144 / 202


9.10 業務プログラムの配置と登録 : EUR システム構築ガイド

  • 145 / 202

  • 表紙

  • 9.　アプリケーションサーバを帳票サーバとは別に構築する

  • 9.10　業務プログラムの配置と登録

9.10　業務プログラムの配置と登録

アプリケーションサーバでの業務プログラムの配置方法と登録方法は，帳票サーバと同じです。詳細については，「7.10　業務プログラムの配置と登録」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 145 / 202


10. クライアントを構築する : EUR システム構築ガイド

  • 146 / 202

  • 表紙

  • 10.　クライアントを構築する

10.　クライアントを構築する

この章では，クライアントの構築方法について説明します。

〈この章の構成〉

  • 10.1　構築の流れ

  • 10.2　事前準備

  • 10.3　前提プログラムのインストール

  • 10.4　EUR Clientのインストール

  • 10.5　EUR Web Plug-Inのインストール

  • 10.6　必要なファイルのインポート

  • 10.7　業務プログラムの配置と登録

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 146 / 202


10.1 構築の流れ : EUR システム構築ガイド

  • 147 / 202

  • 表紙

  • 10.　クライアントを構築する

  • 10.1　構築の流れ

10.1　構築の流れ

クライアントの構築の流れを次の図に示します。構築する帳票システムのシステム構成に応じて，必要な作業を実施してください。

図10‒1　クライアントの構築の流れ

[図データ]

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 147 / 202


10.2 事前準備 : EUR システム構築ガイド

  • 148 / 202

  • 表紙

  • 10.　クライアントを構築する

  • 10.2　事前準備

10.2　事前準備

クライアントを構築する前に，事前に準備しておくことを次に示します。

  • マシンの準備（必須）

    クライアントとして使用するマシンを準備します。

  • インストール媒体の準備（必須）

    クライアントにインストールするEUR製品の再配布パッケージを準備します。

    クライアントから帳票管理GUIサービスや業務プログラムにアクセスする場合は，WebブラウザやAdobe Flash Playerなどの前提製品のインストール媒体も準備します。

  • ファイルの準備（必須）

    クライアントに格納するファイルを準備します。準備方法については，「6.　帳票の出力環境を設定するファイルを準備する」を参照してください。

  • 業務プログラムの準備（任意）

    クライアントに業務プログラムを配置する場合，配置する業務プログラムのプログラムファイルを準備します。

  • 構築で使用するユーザの作成（任意）

    必要に応じて，クライアントの構築で使用するユーザを作成します。

  • インストール先ディレクトリとアクセス権の設定（任意）

    必要に応じて，製品をインストールするためのディレクトリを作成します。

    作成したディレクトリには，クライアントを構築するユーザに対して，必要なアクセス権を設定してください。

■参考

EUR Web Plug-Inをインストールするには，次の二つの方法があります。

  • EUR Clientの再配布用パッケージを使用したインストール

  • EUR Web Plug-Inのダウンロードパッケージを使用したインストール

EUR Web Plug-Inダウンロードパッケージを使用してインストールする場合，事前に次の作業を実施してください。

  1. Webサーバの任意の場所にEUR Web Plug-Inダウンロードパッケージを配置します。

  2. EUR Web Plug-Inダウンロードパッケージをクライアントに配布するためのWebページを作成し，<object>タグにEUR Web Plug-Inダウンロードパッケージのファイル名やバージョンなどを記述します。

<object>タグの記述内容については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。また，EUR Web Plug-Inダウンロードパッケージを使用したEUR Web Plug-Inのインストール方法については，「10.5　EUR Web Plug-Inのインストール」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 148 / 202


10.3 前提プログラムのインストール : EUR システム構築ガイド

  • 149 / 202

  • 表紙

  • 10.　クライアントを構築する

  • 10.3　前提プログラムのインストール

10.3　前提プログラムのインストール

クライアントで実施する帳票出力業務に必要なプログラムをインストールします。次に示す製品のうち，必要なプログラムをインストールしてください。

〈この節の構成〉

  • 10.3.1　Adobe Flash Player

  • 10.3.2　Adobe Reader

  • 10.3.3　Microsoft Office Excel

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 149 / 202


10.3.1 Adobe Flash Player : EUR システム構築ガイド

  • 150 / 202

  • 表紙

  • 10.　クライアントを構築する

  • 10.3　前提プログラムのインストール

  • 10.3.1　Adobe Flash Player

10.3.1　Adobe Flash Player

帳票管理GUIサービスを利用する場合，Adobe Flash Player 12以降が必要です。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 150 / 202


10.3.2 Adobe Reader : EUR システム構築ガイド

  • 151 / 202

  • 表紙

  • 10.　クライアントを構築する

  • 10.3　前提プログラムのインストール

  • 10.3.2　Adobe Reader

10.3.2　Adobe Reader

PDF形式ファイルの帳票を出力・プレビューする場合，Adobe Reader 9以降が必要です。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 151 / 202


10.3.3 Microsoft Office Excel : EUR システム構築ガイド

  • 152 / 202

  • 表紙

  • 10.　クライアントを構築する

  • 10.3　前提プログラムのインストール

  • 10.3.3　Microsoft Office Excel

10.3.3　Microsoft Office Excel

Excel形式ファイルの帳票を出力・プレビューする場合，Microsoft Office Excel 2007以降が必要です。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 152 / 202


10.4 EUR Clientのインストール : EUR システム構築ガイド

  • 153 / 202

  • 表紙

  • 10.　クライアントを構築する

  • 10.4　EUR Clientのインストール

10.4　EUR Clientのインストール

ここでは，EUR Clientのインストール方法について説明します。

〈この節の構成〉

  • 10.4.1　インストール方法

  • 10.4.2　インストール後に作成されるディレクトリ

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 153 / 202


10.4.1 インストール方法 : EUR システム構築ガイド

  • 154 / 202

  • 表紙

  • 10.　クライアントを構築する

  • 10.4　EUR Clientのインストール

  • 10.4.1　インストール方法

10.4.1　インストール方法

〈この項の構成〉

  • (1)　インストールの前に

  • (2)　インストール手順

  • (3)　サイレントインストール

(1)　インストールの前に

  • 管理者権限を持つユーザでログインしてください。

  • インストール時に必要なディスク空き容量を確認してください。

  • ほかのユーザアプリケーションを終了してください。

  • OSから実行許可についてのダイアログが表示されることがあります。このときには，実行を許可する応答をしてください。

  • EUR Clientはサイレントインストールすることができます。サイレントインストールではEUR Web Plug-Inだけをインストールする指定もできます。詳細については，「(3)サイレントインストール」を参照してください。

ページの先頭へ

(2)　インストール手順

EUR Clientの再配布用パッケージ（EURPM-CL.exe）を実行すると，インストーラが起動します。画面の指示に従ってインストールを完了させてください。

インストール画面は，Windowsインストール時の言語で表示されます。ロケールが英語，中国語，日本語のどれでもない場合は英語で表示されます。ただし，サポートしていないロケールで実行した場合，EURの動作は保証されません。

ページの先頭へ

(3)　サイレントインストール

サイレントインストールは，インストール時にインストーラの画面でのユーザの応答を必要としないインストール方法です。

EUR Clientは，EUR Client再配布用パッケージ（EURPM-CL.exe）からサイレントインストールすることができます。サイレントインストールではEUR Web Plug-Inだけをインストールする指定もできます。

コマンドプロンプトなどから，サイレントインストールのパラメタを指定してEUR Client再配布用パッケージ（EURPM-CL.exe）を実行すると，EUR ClientまたはEUR Web Plug-Inのサイレントインストールを実行します。

EUR Client再配布用パッケージ（EURPM-CL.exe）でサイレントインストールを実行するときのパラメタの形式，指定例，および終了通知について，次に示します。

■形式

EURPM-CL.exe△/s△/v"
/qn
〔△STARTFROM=NETM〕
〔△NETMNEW=Y〕
〔△REBOOT=R〕
〔△/L*△ログファイル名〕
〔△INSTALLDIR=インストール先フォルダ名〕
〔△USERNAME=登録ユーザ名〕
〔△COMPANYNAME=登録会社名〕
〔△ONLYWEBPLUGIN=｛Y|N｝〕"
（凡例）

△：半角空白を示します。

表10‒1　EUR Client再配布用パッケージのサイレントインストールのパラメタ

項番

パラメタ

内容

1

/s

サイレントモードを指定するパラメタです。必ず指定してください。

EURのインストーラを，ダイアログを表示せずに起動します。

2

/v

EURのインストーラから呼び出すWindows Installerのパラメタを使用するために指定するパラメタです。必ず指定してください。

Windows Installerで使用するパラメタ（項番3～10）は「"」で囲みます。

3

/qn

Windows Installerを，ダイアログを表示せずに実行するために指定するパラメタです。必ず指定してください。

4

STARTFROM=NETM

NETMNEW=Y

インストールの結果ファイルを出力する場合に指定します。

省略した場合は，インストールの結果ファイルを出力しません。

5

REBOOT=R

インストール直後の再起動を抑止する場合に指定します。

省略した場合は，再起動を抑止しません。

6

/L*△ログファイル名

（凡例）

△：半角空白を示します。

ログファイルの出力先をフルパスで指定します。

空白を含む場合は「\"」で囲みます。

（例）

/L* \"C:\Temp Dir\Install.log\"

省略した場合は，ログファイルを出力しません。

7

USERNAME=登録ユーザ名

登録するユーザ名を指定します。

省略した場合は，インストールするマシンに設定されているユーザ名が登録されます。

8

COMPANYNAME=登録会社名

登録する会社名を指定します。

省略した場合は，インストールするマシンに設定されている会社名が登録されます。

9

INSTALLDIR=インストール先フォルダ名

インストール先のフォルダを指定します。

空白を含む場合は「\"」で囲みます。

（例）

INSTALLDIR=\"C:\Program Files (x86)\EUR\"

省略した場合は，デフォルトのインストール先にインストールされます。

10

ONLYWEBPLUGIN=｛Y｜N｝

インストールする対象を指定します。

  • Y

    EUR Web Plug-Inだけをインストールする場合に指定します。

  • N

    EUR Client ServiceとEUR Web Plug-Inをインストールする場合に指定します。

省略した場合は「N」が仮定されます。

■指定例

EURPM-CL.exe /s /v"/qn STARTFROM=NETM NETMNEW=Y REBOOT=R /L* C:\Temp\Install.log INSTALLDIR=\"C:\Program files\EUR\" USERNAME=日立太郎 COMPANYNAME=EUR ONLYWEBPLUGIN=Y"

■終了通知

  • ログ出力

    パラメタ「/L*」でログファイルを指定している場合，障害調査用の情報をログファイルに出力します。

    ログファイルの出力に失敗した場合，インストーラはエラー終了します。

    エラーを検知する場合は，Windowsの終了コードをサイレントインストール実行後の%ERRORLEVEL%で取得してください。

  • 終了コード

    パラメタ「STARTFROM=NETM」とパラメタ「NETMNEW=Y」を指定している場合，EUR Client再配布用パッケージと同じフォルダに「__NETMRT」のファイル名で結果ファイルを出力します。結果ファイルには次の表に示す終了コードを出力します。ただし，終了コードを出力する前にエラーになった場合，結果ファイルは出力されません。

    なお，結果ファイルの出力に失敗した場合，インストーラはエラー終了します。エラーの詳細は，パラメタ「/L*」で指定したログファイルに出力されます。

    表10‒2　EUR Client再配布用パッケージのサイレントインストールの終了コード

    終了コード

    意味

    00

    インストール成功

    80

    インストール失敗

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 154 / 202


10.4.2 インストール後に作成されるディレクトリ : EUR システム構築ガイド

  • 155 / 202

  • 表紙

  • 10.　クライアントを構築する

  • 10.4　EUR Clientのインストール

  • 10.4.2　インストール後に作成されるディレクトリ

10.4.2　インストール後に作成されるディレクトリ

EUR Clientのインストール後に作成されるディレクトリについて説明します。

表10‒3 EUR Clientのインストール後に作成されるディレクトリ
ディレクトリまたはファイル名 | 内容
%EUR% | EURのルートディレクトリ
Client\ | EUR Client Serviceのルートディレクトリ
Program\ | 実行ファイル格納ディレクトリ
EURPMCL.exe | EUR Client Service実行ファイル※1
EURPMUCM.exe | ［EUR Client 構成定義］ダイアログ実行ファイル※1
EURPMCEPFViewer.exe | eurpmcepfviewerコマンド※1
EURPMPrintAX9.ocx | EUR Web Plug-In実行ファイル（印刷用）
EURPMPreViewAX9.ocx | EUR Web Plug-In実行ファイル（プレビュー用）
Conf\ | 構成定義ファイル格納ディレクトリ※2
（凡例）

%EUR%：EUR Clientのインストール先ディレクトリを示します。

注※1

EUR ClientのサイレントインストールでEUR Web Plug-Inだけをインストールした場合は格納されません。

注※2

EUR ClientのサイレントインストールでEUR Web Plug-Inだけをインストールした場合は作成されません。

なお，EUR Clientをデフォルトディレクトリにインストールした場合，ログファイルや一時ファイルは，次のディレクトリに格納されます。

  • EUR Client Serviceのログファイルや一時ファイル

    C:\Users\<ログインユーザ>\AppData\Roaming\HITACHI\EUR

  • EUR Web Plug-Inのログファイルや一時ファイル

    C:\Users\<ログインユーザ>\AppData\Local\Temp\Low

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 155 / 202


10.5 EUR Web Plug-Inのインストール : EUR システム構築ガイド

  • 156 / 202

  • 表紙

  • 10.　クライアントを構築する

  • 10.5　EUR Web Plug-Inのインストール

10.5　EUR Web Plug-Inのインストール

EUR Web Plug-Inのインストール方法には，次の二つの方法があります。

  • EUR Clientの再配布用パッケージを使用したインストール

  • EUR Web Plug-Inのダウンロードパッケージを使用したインストール

〈この節の構成〉

  • 10.5.1　EUR Client再配布用パッケージを使用したインストール

  • 10.5.2　EUR Web Plug-Inダウンロードパッケージを使用したインストール

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 156 / 202


10.5.1 EUR Client再配布用パッケージを使用したインストール : EUR システム構築ガイド

  • 157 / 202

  • 表紙

  • 10.　クライアントを構築する

  • 10.5　EUR Web Plug-Inのインストール

  • 10.5.1　EUR Client再配布用パッケージを使用したインストール

10.5.1　EUR Client再配布用パッケージを使用したインストール

EUR Client再配布用パッケージをクライアントにインストール，またはEUR Client再配布用パッケージのサイレントインストールでEUR Web Plug-Inだけをインストールすると，次に示すEUR Web Plug-Inの実行ファイルが一緒にインストールされます。

  • EUR Web Plug-In実行ファイル（印刷用）

  • EUR Web Plug-In実行ファイル（プレビュー用）

EUR Clientの再配布用パッケージのインストール方法，およびEUR Web Plug-Inの実行ファイルについては，「10.4　EUR Clientのインストール」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 157 / 202


10.5.2 EUR Web Plug-Inダウンロードパッケージを使用したインストール : EUR システム構築ガイド

  • 158 / 202

  • 表紙

  • 10.　クライアントを構築する

  • 10.5　EUR Web Plug-Inのインストール

  • 10.5.2　EUR Web Plug-Inダウンロードパッケージを使用したインストール

10.5.2　EUR Web Plug-Inダウンロードパッケージを使用したインストール

EUR Web Plug-Inのダウンロードパッケージを使用したインストールでは，クライアントのWebブラウザから，EUR Web Plug-Inダウンロードパッケージ配布用のWebページにアクセスしてEUR Web Plug-Inをインストールします。

〈この項の構成〉

  • (1)　インストールの前に

  • (2)　インストール手順

(1)　インストールの前に

OSから実行許可についてのダイアログが表示されることがあります。このときには，実行を許可する応答をしてください。

ページの先頭へ

(2)　インストール手順

  1. WebページをクライアントPCで開きます。

    情報バーが表示されます。

  2. 情報バーをクリックします。

    ポップアップメニューが表示されます。

    ポップアップメニューで［このコンピューター上のすべてのユーザーにこのアドオンをインストールする］または［このアドオンのインストール］を選択すると，EUR Web Plug-Inがインストールされます。

    このコンピューター上のすべてのユーザーにこのアドオンをインストールする

    マシン単位でインストールする場合に表示されます。

    このアドオンのインストール

    ユーザ単位でインストールする場合に表示されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 158 / 202


10.6 必要なファイルのインポート : EUR システム構築ガイド

  • 159 / 202

  • 表紙

  • 10.　クライアントを構築する

  • 10.6　必要なファイルのインポート

10.6　必要なファイルのインポート

「6.　帳票の出力環境を設定するファイルを準備する」で準備したファイルのうち，クライアントに準備するファイルをインポートします。クライアントのロケールに応じたエンコードを設定してインポートしてください。

クライアントにインポートするファイルを，次の表に示します。

表10‒4 クライアントにインポートするファイル
ファイルの種類 | ファイル名 | 説明
環境設定ファイル | EUR Client Serviceの環境設定ファイル（EURPMCL.ini） | 必要なファイルをインポートします。
構成定義ファイル | クライアントプリンタクラス定義ファイル（ClientPrinterClass.conf）

なお，環境設定ファイルおよび構成定義ファイルのインポート後は，EUR Client Serviceを再起動してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 159 / 202


10.7 業務プログラムの配置と登録 : EUR システム構築ガイド

  • 160 / 202

  • 表紙

  • 10.　クライアントを構築する

  • 10.7　業務プログラムの配置と登録

10.7　業務プログラムの配置と登録

ここでは，クライアントへの業務プログラムの配置方法と登録方法について説明します。

〈この節の構成〉

  • 10.7.1　前提プログラムのインストール

  • 10.7.2　業務プログラムの配置

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 160 / 202


10.7.1 前提プログラムのインストール : EUR システム構築ガイド

  • 161 / 202

  • 表紙

  • 10.　クライアントを構築する

  • 10.7　業務プログラムの配置と登録

  • 10.7.1　前提プログラムのインストール

10.7.1　前提プログラムのインストール

業務プログラムの動作に必要なプログラム（前提プログラム）をインストールします。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 161 / 202


10.7.2 業務プログラムの配置 : EUR システム構築ガイド

  • 162 / 202

  • 表紙

  • 10.　クライアントを構築する

  • 10.7　業務プログラムの配置と登録

  • 10.7.2　業務プログラムの配置

10.7.2　業務プログラムの配置

業務プログラムを配置します。配置した業務プログラムは，スタートアップやタスクスケジューラに登録することで，クライアントの起動時やクライアントへのログイン時に自動で実行させることもできます。スタートアップやタスクスケジューラへの業務プログラムの登録方法については，Windowsのマニュアルを参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 162 / 202


11. EURをアップグレードする : EUR システム構築ガイド

  • 163 / 202

  • 表紙

  • 11.　EURをアップグレードする

11.　EURをアップグレードする

この章では，EURのアップグレード方法について説明します。作業の流れについては，「1.1.2　EURをアップグレードする場合の流れ」を参照してください。

〈この章の構成〉

  • 11.1　ファイルのバックアップ

  • 11.2　EURのアップグレードインストール

  • 11.3　業務プログラムの修正と再配置

  • 11.4　ファイルの修正とリストア

  • 11.5　帳票管理GUIサービスの再設定

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 163 / 202


11.1 ファイルのバックアップ : EUR システム構築ガイド

  • 164 / 202

  • 表紙

  • 11.　EURをアップグレードする

  • 11.1　ファイルのバックアップ

11.1　ファイルのバックアップ

アップグレードするマシンに格納されているファイルを，別のマシンにバックアップします。EUR バージョン8からアップグレードする場合は，次の表に示すファイルをバックアップしてください。

各ファイルの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

表11‒1　アップグレード前にバックアップするファイル

インストールされているコンポーネント

ファイル名

格納先

説明

EUR Print Service
Windows環境

EURPS_ENV

UNIX／Linux環境

eurps_env
Windows環境

EUR Print Serviceのインストール先ディレクトリ

UNIX／Linux環境

/etc/opt/eurps

環境設定ファイル

printerinf

プリンタ定義ファイル

EUR Print Manager

EURPM.ini
Windows環境

EUR Print Managerのインストール先ディレクトリ

UNIX／Linux環境

/etc/opt/eurpm

環境設定ファイル

EURPMCTRL.ini

Destination.conf
Windows環境

EUR Print Managerのインストール先ディレクトリ\Conf

UNIX／Linux環境

/etc/opt/eurpm/Conf

出力先定義ファイル

PMPrinterClass.conf

印刷管理サーバプリンタクラス定義ファイル※1

PrintDest.conf

印刷先定義ファイル
Windows環境

EURPS_ENV

UNIX／Linux環境

eurps_env
Windows環境

EUR Print Managerのインストール先ディレクトリ\PSEnv

UNIX／Linux環境

/etc/opt/eurpm/PSEnv

環境設定ファイル

EUR Print Manager - Report Server

EURPMLS.ini
Windows環境

EUR Print Manager - Report Serverのインストール先ディレクトリ

UNIX／Linux環境

/etc/opt/eurpmls

環境設定ファイル

EURPMLSCTRL.ini

/etc/opt/eurpmls

環境設定ファイル

ServerPrinterClass.conf
Windows環境

EUR Print Manager - Report Serverのインストール先ディレクトリ\Conf

UNIX／Linux環境

/etc/opt/eurpmls/Conf

拠点プリンタクラス定義ファイル

Distribution.conf

帳票振り分け定義ファイル

userdef.conf

蓄積管理ユーザ定義ファイル※2

EUR Print Manager - Adapter

EURPMADP.ini
Windows環境

EUR Print Manager - Adapterのインストール先ディレクトリ

UNIX／Linux環境

/etc/opt/eurpm_adp

環境設定ファイル

EUR Print Manager - Report Server Adapter

EURPMLSADP.ini
Windows環境

EUR Print Manager - Report Server Adapterのインストール先ディレクトリ

UNIX／Linux環境

/etc/opt/eurpmls_adp

環境設定ファイル

EURPMRSGUI.ini

EUR Print Manager - Client

EURPMCL.ini

EUR Print Manager - Clientのインストール先ディレクトリ

環境設定ファイル

ClientPrinterClass.conf

EUR Print Manager - Clientのインストール先ディレクトリ\Conf

クライアントプリンタクラス定義ファイル
注

デフォルトのファイル名と格納先を示しています。

注※1

EUR バージョン9以降では，「帳票サーバプリンタクラス定義ファイル」と呼んでいます。

注※2

EUR バージョン9以降では，「ユーザ管理ファイル」と呼んでいます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 164 / 202


11.2 EURのアップグレードインストール : EUR システム構築ガイド

  • 165 / 202

  • 表紙

  • 11.　EURをアップグレードする

  • 11.2　EURのアップグレードインストール

11.2　EURのアップグレードインストール

アップグレードするマシンに，新しいバージョンのEURをインストールします。

〈この節の構成〉

  • 11.2.1　インストールの前に

  • 11.2.2　インストール手順

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 165 / 202


11.2.1 インストールの前に : EUR システム構築ガイド

  • 166 / 202

  • 表紙

  • 11.　EURをアップグレードする

  • 11.2　EURのアップグレードインストール

  • 11.2.1　インストールの前に

11.2.1　インストールの前に

  • 管理者権限を持つユーザでログインしてください。

  • EURのサービスをすべて停止してください。

  • ほかのユーザアプリケーションを終了してください。

  • OSから実行許可についてのダイアログが表示されることがあります。このときには，実行を許可する応答をしてください。

  • 新しいバージョンのEUR Web Plug-Inを，EUR Web Plug-Inダウンロードパッケージを使用してインストールする場合，事前に次の作業を実施してください。

    1. Webサーバの任意の場所に，新しいバージョンのEUR Web Plug-Inダウンロードパッケージを配置します。

    2. EUR Web Plug-Inダウンロードパッケージをクライアントに配布するためのWebページを作成し，<object>タグにEUR Web Plug-Inダウンロードパッケージのファイル名やバージョンなどを記述します。

      EUR Web Plug-Inダウンロードパッケージを使用してEUR Web Plug-Inをインストールする場合の<object>タグの記述内容については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

      EUR Web Plug-Inダウンロードパッケージを使用したEUR Web Plug-Inのインストール方法については，「10.5.2　EUR Web Plug-Inダウンロードパッケージを使用したインストール」を参照してください。

    過去に作成したWebページを流用する場合は，古いバージョンのEUR Web Plug-Inダウンロードパッケージを新しいバージョンに置き換えたあと，EUR Web Plug-Inダウンロードパッケージ配布用のWebページの<object>タグのバージョン値を変更してください。

  • サーバで動作する次のコンポーネントのバージョンは同じバージョンで運用してください。

    • EUR Server Service

    • EUR Server - Adapter

    • EUR Server - Spool Service

    • EUR Server - Spool Service Adapter

    なお，クライアントで動作する次のコンポーネントが古いバージョンの場合は，古いバージョンの機能範囲で動作します。

    • EUR Client Service

    • EUR Web Plug-In

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 166 / 202


11.2.2 インストール手順 : EUR システム構築ガイド

  • 167 / 202

  • 表紙

  • 11.　EURをアップグレードする

  • 11.2　EURのアップグレードインストール

  • 11.2.2　インストール手順

11.2.2　インストール手順

アップグレードインストールの手順を次に示します。

  1. バージョン8以前のEURからアップグレードする場合，古いバージョンのEURをアンインストールします。

    アンインストール方法については，インストールされているバージョンのマニュアルを参照してください。

  2. 新しいバージョンのEURをインストールします。

    インストール方法は，新規にインストールする場合と同じです。参照先を次に示します。

    • EUR Developer：2.1

    • EUR Server：7.3.1

    • EUR Server - Spool Service：8.3.1

    • EUR Server - Adapter：9.4.1

    • EUR Server - Spool Service Adapter：9.5.1

    • EUR Client：10.4.1

    • EUR Web Plug-In：10.5

■参考

バージョン8以前のEUR Print Manager - Client Print ActiveX，およびEUR Print Manager - Client Preview ActiveXは，ダウンロードパッケージを使用してインストールしていた場合に限り，EUR Web Plug-Inと共存できます。EUR Print Manager - Client Print ActiveX，およびEUR Print Manager - Client Preview ActiveXがインストールされているマシンに，EUR Web Plug-Inを新規インストールしてください。

このとき，EUR Web Plug-Inのインストールにもダウンロードパッケージを使用してください。マシン単位インストール，ユーザ単位インストールのどちらの方法でもインストールできます。EUR Print Manager - Client Print ActiveX，およびEUR Print Manager - Client Preview ActiveXのインストール方法に合わせる必要はありません。

なお，ユーザ単位インストールの場合は，実行ユーザごとに標準ユーザ権限でインストールできます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 167 / 202


11.3 業務プログラムの修正と再配置 : EUR システム構築ガイド

  • 168 / 202

  • 表紙

  • 11.　EURをアップグレードする

  • 11.3　業務プログラムの修正と再配置

11.3　業務プログラムの修正と再配置

EUR バージョン9で製品構成を大幅に変更しているため，バージョン8以前のEURからアップグレードする場合は，業務プログラムの修正が必要になることがあります。業務プログラムの修正が必要な場合を次に示します。

  • EUR Web Plug-Inを使用している場合

    EUR Web Plug-InのクラスIDが変わるため，EUR Web Plug-Inを呼び出す処理でクラスIDを直接指定しているときは，指定する値を変更してください。

    ActiveX起動部品またはJava起動部品のメソッドを使用してクラスIDを取得しているときは，業務プログラムの修正は不要です。新しいバージョンのEUR Web Plug-In情報ファイル（EURPMPrintAX.infまたはEURPMPreViewAX.inf）をEUR Server - Adapter稼働マシンに配置すると，変更後のクラスIDが取得できます。

  • コマンド起動部品（eurpmcコマンド），SS-コマンド起動部品（eurpmlscコマンド），eurpmcepfviewerコマンド，およびeurpsコマンド（V8互換機能）を使用している場合

    コマンドの実行ファイルの格納先が変更になるため，コマンドの実行ファイルをフルパスで呼び出しているときは，呼び出し部分の処理を変更してください。

  • JavaBeans起動部品（V8互換機能）を使用している場合

    プロパティファイル（EURPSManager.properties）にパス情報が含まれるため，業務プログラムにプロパティファイルを取り込んでいるときは，プロパティファイルを修正してリビルドしてください。

修正が完了したら，業務プログラムを再配置してください。

また，業務プログラムの修正は不要でも，マシンの設定変更が必要になることがあります。マシンの設定変更が必要な場合を次に示します。

  • Java起動部品，SS-Java起動部品，およびJavaBeans起動部品（V8互換機能）を使用している場合

    起動部品の格納先が変わるため，クラスパス，およびライブラリのパスの設定を変更してください。

  • COBOL起動部品を使用している場合

    起動部品の格納先が変わるため，パスの設定を変更してください。

  • コマンド起動部品（eurpmcコマンド），SS-コマンド起動部品（eurpmlscコマンド），eurpmcepfviewerコマンド，およびeurpsコマンド（V8互換機能）を使用している場合

    コマンドの実行ファイルの格納先が変更になるため，コマンドの実行ファイルの格納先にパスを通しているときは，パスの設定を変更してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 168 / 202


11.4 ファイルの修正とリストア : EUR システム構築ガイド

  • 169 / 202

  • 表紙

  • 11.　EURをアップグレードする

  • 11.4　ファイルの修正とリストア

11.4　ファイルの修正とリストア

「11.1　ファイルのバックアップ」でバックアップしたファイルの内容を，アップグレードするマシンのディレクトリ構成に合わせて修正し，アップグレードするマシンにリストアします。ファイルの修正およびリストアは，アップグレードするマシンのロケールに応じたエンコードで実施してください。

ファイルの修正方法については，次の説明を参照してください。

  • 5.1.2　過去に作成したファイルを流用する

  • 6.1.2　過去に作成したファイルを流用する

また，ファイルのリストア先については，次の説明を参照してください。

  • 5.2　帳票サーバに準備するファイル

  • 5.3　アプリケーションサーバに準備するファイル

  • 5.4　運用に応じて格納先を決めるファイル

  • 6.2.1　環境設定ファイルとは

  • 6.3.1　構成定義ファイルとは

■注意

アップグレードするマシンがUNIX／Linux環境の場合，次のことに注意してください。

  • バージョン5以降で作成した帳票ファイルは，バイナリモードで転送してください。

  • バージョン4で作成した帳票ファイルは，ASCIIモードのまま転送してください。文字コード変換は必要ありません。

  • 日本語EUCロケールでは，日本語EUCのコードセット3には対応していません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 169 / 202


11.5 帳票管理GUIサービスの再設定 : EUR システム構築ガイド

  • 170 / 202

  • 表紙

  • 11.　EURをアップグレードする

  • 11.5　帳票管理GUIサービスの再設定

11.5　帳票管理GUIサービスの再設定

帳票管理GUIサービスを使用している場合，帳票管理GUIサービスを再設定します。

〈この節の構成〉

  • 11.5.1　EUR Web Plug-Inのダウンロードパッケージの配置

  • 11.5.2　サービスプログラムの再インストール

  • 11.5.3　起動部品の環境設定

  • 11.5.4　サービスの再登録・起動

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 170 / 202


11.5.1 EUR Web Plug-Inのダウンロードパッケージの配置 : EUR システム構築ガイド

  • 171 / 202

  • 表紙

  • 11.　EURをアップグレードする

  • 11.5　帳票管理GUIサービスの再設定

  • 11.5.1　EUR Web Plug-Inのダウンロードパッケージの配置

11.5.1　EUR Web Plug-Inのダウンロードパッケージの配置

帳票管理GUIの初回接続時に，クライアントPCにEUR Web Plug-Inをインストールさせる場合は，帳票管理GUIの環境設定ファイル（EURPMRSGUI.ini）のOPTIONセクションで指定したパスに，新しいバージョンのEUR Web Plug-Inのダウンロードパッケージを配置します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 171 / 202


11.5.2 サービスプログラムの再インストール : EUR システム構築ガイド

  • 172 / 202

  • 表紙

  • 11.　EURをアップグレードする

  • 11.5　帳票管理GUIサービスの再設定

  • 11.5.2　サービスプログラムの再インストール

11.5.2　サービスプログラムの再インストール

新しいバージョンの帳票管理GUIサービスのサービスプログラムを再インストールします。インストール方法については，「7.8.4　サービスプログラムのインストール」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 172 / 202


11.5.3 起動部品の環境設定 : EUR システム構築ガイド

  • 173 / 202

  • 表紙

  • 11.　EURをアップグレードする

  • 11.5　帳票管理GUIサービスの再設定

  • 11.5.3　起動部品の環境設定

11.5.3　起動部品の環境設定

EUR Server - AdapterとEUR Server - Spool Service Adapterの環境設定をします。設定方法については，「7.8.5　起動部品の環境設定」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 173 / 202


11.5.4 サービスの再登録・起動 : EUR システム構築ガイド

  • 174 / 202

  • 表紙

  • 11.　EURをアップグレードする

  • 11.5　帳票管理GUIサービスの再設定

  • 11.5.4　サービスの再登録・起動

11.5.4　サービスの再登録・起動

Web/APサーバに帳票管理GUIサービスを再登録，起動します。

サービスの登録方法および起動方法については，Web/APサーバのマニュアルを参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 174 / 202


12. 帳票システムを移行する : EUR システム構築ガイド

  • 175 / 202

  • 表紙

  • 12.　帳票システムを移行する

12.　帳票システムを移行する

この章では，帳票システムの移行方法について説明します。作業の流れについては，「1.1.3　システムを移行する場合の流れ」を参照してください。

〈この章の構成〉

  • 12.1　移行先マシンのセットアップ

  • 12.2　業務プログラムの修正と再配置

  • 12.3　ファイルの修正とインポート

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 175 / 202


12.1 移行先マシンのセットアップ : EUR システム構築ガイド

  • 176 / 202

  • 表紙

  • 12.　帳票システムを移行する

  • 12.1　移行先マシンのセットアップ

12.1　移行先マシンのセットアップ

移行先マシンをセットアップします。セットアップ方法については，次の説明を参照してください。

  • 7.　帳票サーバを構築する

  • 8.　スプールサーバを帳票サーバとは別に構築する

  • 9.　アプリケーションサーバを帳票サーバとは別に構築する

  • 10.　クライアントを構築する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 176 / 202


12.2 業務プログラムの修正と再配置 : EUR システム構築ガイド

  • 177 / 202

  • 表紙

  • 12.　帳票システムを移行する

  • 12.2　業務プログラムの修正と再配置

12.2　業務プログラムの修正と再配置

移行後の帳票システムの構成に合わせて，業務プログラムを修正して再配置します。

なお，EUR バージョン9でディレクトリ構成を大幅に変更しています。そのため，システム構成に変更はなくても，バージョン8以前のEURからのアップグレードを伴う移行の場合は，業務プログラムの修正が必要になることがあります。詳細については，「11.3　業務プログラムの修正と再配置」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 177 / 202


12.3 ファイルの修正とインポート : EUR システム構築ガイド

  • 178 / 202

  • 表紙

  • 12.　帳票システムを移行する

  • 12.3　ファイルの修正とインポート

12.3　ファイルの修正とインポート

移行元マシンに格納されているファイルの内容を，移行先マシンのディレクトリ構成に合わせて修正して，移行先マシンにインポートします。ファイルの修正およびインポートは，移行先マシンのロケールに応じたエンコードで実施してください。

ファイルの修正方法については，次の説明を参照してください。

  • 5.1.2　過去に作成したファイルを流用する

  • 6.1.2　過去に作成したファイルを流用する

また，ファイルのインポート先については，次の説明を参照してください。

  • 5.2　帳票サーバに準備するファイル

  • 5.3　アプリケーションサーバに準備するファイル

  • 5.4　運用に応じて格納先を決めるファイル

  • 6.2.1　環境設定ファイルとは

  • 6.3.1　構成定義ファイルとは

■注意

移行先のマシンがUNIX／Linux環境の場合，次のことに注意してください。

  • バージョン5以降で作成した帳票ファイルは，バイナリモードで転送してください。

  • バージョン4で作成した帳票ファイルは，ASCIIモードのまま転送してください。文字コード変換は必要ありません。

  • 日本語EUCロケールでは，日本語EUCのコードセット3には対応していません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 178 / 202


付録 : EUR システム構築ガイド

  • 179 / 202

  • 表紙

  • 付録

付録

〈この付録の構成〉

  • 付録A　Windows環境の場合の注意

  • 付録B　UNIX／Linux環境の場合の注意

  • 付録C　アンインストール

  • 付録D　このマニュアルの参考情報

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 179 / 202


付録A Windows環境の場合の注意 : EUR システム構築ガイド

  • 180 / 202

  • 表紙

  • 付録

  • 付録A　Windows環境の場合の注意

付録A　Windows環境の場合の注意

ここでは，Windows環境に帳票システムを構築する場合の注意事項について説明します。

〈この節の構成〉

  • 付録A.1　共通の注意

  • 付録A.2　EUR Server Service，およびEUR Server - Spool Serviceを使用する場合の注意

  • 付録A.3　EUR Server - Adapter，およびEUR Server - Spool Service Adapterを使用する場合の注意

  • 付録A.4　EUR Clientを使用する場合の注意

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 180 / 202


付録A.1 共通の注意 : EUR システム構築ガイド

  • 181 / 202

  • 表紙

  • 付録

  • 付録A　Windows環境の場合の注意

  • 付録A.1　共通の注意

付録A.1　共通の注意

  • EUR Developer，およびEUR Serverのインストールは，管理者権限を持つユーザで実行してください。

    インストール時に，OSから実行許可についてのダイアログが表示される場合があります。このときには，実行を許可する応答をしてください。

  • EUR Developer，およびEUR Serverをデフォルトディレクトリにインストールした場合，環境設定ファイルは管理者権限で編集してください。

  • EUR サーバ帳票出力機能の実行中に一時フォルダを操作しないでください。操作した場合，予期しないエラーが発生するおそれがあります。

  • EUR Serverのインストール先にデフォルトディレクトリを指定した場合の，各ファイルの格納先を次に示します。

    • 帳票ファイル

      C:\Program Files\HITACHI\EUR\Server\Form

    • 複数様式情報定義ファイル

      C:\Program Files\HITACHI\EUR\Server\Multi

    • 文書情報設定ファイル

      C:\Program Files\HITACHI\EUR\Server\DocInfo

    • 接続情報ファイル

      C:\Program Files\HITACHI\EUR\Server\DBInfo

    • 新規用紙出力定義ファイル

      C:\Program Files\HITACHI\EUR\Server\printnewpaper

    • 置き換え表管理情報ファイル

      C:\Program Files\HITACHI\EUR\Server\ReplaceItem

    • Acrobat JavaScript定義ファイル

      C:\Program Files\HITACHI\EUR\Server\ScriptCnt

    • ビューアプレファレンス定義ファイル

      C:\Program Files\HITACHI\EUR\Server\Preference

    • 印刷日時出力定義ファイル

      C:\Program Files\HITACHI\EUR\Server\PrintDate

    • EUR Print Serviceの環境設定ファイル

      C:\Program Files\HITACHI\EUR\Server\PSEnv

    • 分割定義ファイルまたは仕分け定義ファイル

      C:\Program Files\HITACHI\EUR\Server\Split

    • 構成定義ファイル

      EUR Server Serviceの構成定義ファイル

        C:\Program Files\HITACHI\EUR\Server\Conf

      EUR Server - Spool Serviceの構成定義ファイル

        C:\Program Files\HITACHI\EUR\Spool\Conf

      EUR Client Serviceの構成定義ファイル

        C:\Program Files\HITACHI\EUR\Client\Conf

      ファイル監視サービスの構成定義ファイル

        C:\Program Files\HITACHI\EUR\FileMonitor\conf

    • 制御情報付データファイル

      BSP-RM連携コマンド（eursmprコマンド）の制御情報付データファイル

        C:\Program Files\HITACHI\EUR\Eursmpr\divdata

    • 起動パラメタファイル

      BSP-RM連携コマンド（eursmprコマンド）の起動パラメタファイル

        C:\Program Files\HITACHI\EUR\Eursmpr\runparam

      ファイル監視サービスの起動パラメタファイル

        C:\Program Files\HITACHI\EUR\FileMonitor\runparam

    • 帳票出力定義ファイル

      C:\Program Files\HITACHI\EUR\Server\reportid

    また，各ファイルの出力先は次に示すディレクトリに設定されます。

    • ログファイル

      EUR Developer，およびEUR Serverのログファイル

        C:\Program Files\HITACHI\EUR\Log

      EUR Clientのログファイル

        ・EUR Client Service

          C:\Users\<ログインユーザ>\AppData\Roaming\HITACHI\EUR

        ・EUR Web Plug-In

          C:\Users\<ログインユーザ>\AppData\Local\Temp\Low

    • 一時ファイル

      EUR Server Serviceの一時ファイル

        C:\Program Files\HITACHI\EUR\Server\Temp

      EUR Server - Spool Serviceの一時ファイル

        C:\Program Files\HITACHI\EUR\Spool\Temp

      EUR Client Serviceの一時ファイル

        C:\Users\<ログインユーザ>\AppData\Roaming\HITACHI\EUR

      EUR Web Plug-Inの一時ファイル

        C:\Users\<ログインユーザ>\AppData\Local\Temp\Low

      BSP-RM連携コマンド（eursmprコマンド）の一時ファイル

        C:\Program Files\HITACHI\EUR\Eursmpr\temp

      ファイル監視サービスの一時ファイル

        C:\Program Files\HITACHI\EUR\FileMonitor\fmc\data

    • PDF形式ファイル

      C:\Program Files\HITACHI\EUR\Server\PDF

    • スプールデータ

      C:\Program Files\HITACHI\EUR\Spool\ESF

  • HTMLヘルプを使用すると参照した部分が表示済みの色で表示されます。これはInternet Explorer(R)で履歴を管理しているためです。この履歴は，EURをアンインストール後に再インストールした場合や，更新インストールをしても引き継がれます。HTMLヘルプの履歴を削除したい場合は，HTMLヘルプのメニュー［オプション］－［インターネットオプション］で［履歴のクリア］ボタンをクリックしてください。

    ただし，履歴を削除すると，使用するOSによってはInternet Explorerのブラウザの全参照履歴が削除されることがあるので注意してください。

  • 環境設定ファイルに同じセクションまたは同じキーを複数指定しないでください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 181 / 202


付録A.2 EUR Server Service，およびEUR Server - Spool Serviceを使用する場合の注意 : EUR システム構築ガイド

  • 182 / 202

  • 表紙

  • 付録

  • 付録A　Windows環境の場合の注意

  • 付録A.2　EUR Server Service，およびEUR Server - Spool Serviceを使用する場合の注意

付録A.2　EUR Server Service，およびEUR Server - Spool Serviceを使用する場合の注意

  • 入出力フォルダにネットワークドライブを使用できません。

  • 入出力フォルダに適切なアクセス権を設定してください。サービスをLocal Systemで実行している場合は，Local Systemからもアクセスできる必要があります。

  • EUR Developer，およびEUR Serverをシステムフォルダ（Program Files）以下にインストールした場合，帳票定義ファイルを配置するなどデフォルトディレクトリ内のデータを更新するには管理者権限が必要です。

  • ファイルの入出力でネットワークパスを使用する場合は，EUR Server ServiceおよびEUR Server - Spool Serviceのログオンアカウントを適切なアクセス権を持つアカウントに変更してください。

  • EUR Server Serviceを複数起動する場合は，EUR Server Serviceの起動管理定義で登録できるEUR Server Serviceの環境設定ファイルパスについて，次に示す登録はしないでください。

    • 同じディレクトリパスまたは同じファイルパスの複数登録

    • ディレクトリパスが登録されている場合，同じディレクトリパスのEURPM.iniのファイルパスでの登録

    • EURPM.iniのファイルパスが登録されている場合，EURPM.iniの格納先ディレクトリのディレクトリパスでの登録

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 182 / 202


付録A.3 EUR Server - Adapter，およびEUR Server - Spool Service Adapterを使用する場合の注意 : EUR システム構築ガイド

  • 183 / 202

  • 表紙

  • 付録

  • 付録A　Windows環境の場合の注意

  • 付録A.3　EUR Server - Adapter，およびEUR Server - Spool Service Adapterを使用する場合の注意

付録A.3　EUR Server - Adapter，およびEUR Server - Spool Service Adapterを使用する場合の注意

  • ログファイルの出力先ディレクトリがシステムフォルダ（Program FilesまたはProgram Files (x86)）以下にある場合で，EUR Server - Adapter，およびEUR Server - Spool Service Adapterを管理者権限で実行しないときは，ログファイルの出力先ディレクトリではなく，リダイレクトフォルダにログファイルが出力されます。

    例えば，ログファイルの出力先ディレクトリを変更しないでEUR Server - Adapter，およびEUR Server - Spool Service Adapterをデフォルトディレクトリにインストールした場合，管理者権限で実行しないときは，次のディレクトリにログファイルが出力されます。

    C:\Users\<ログインユーザ>\AppData\Local\VirtualStore\Program Files\HITACHI\EUR\Log

  • EUR Server - AdapterまたはEUR Server - Spool Service Adapterを使用する場合，呼び出すプログラムの動作モードに応じて，次のモジュールを使用してください。

    32ビットプログラムから呼び出すとき

    ・ActiveX起動部品（32ビット版），またはSS-ActiveX起動部品（32ビット版）

    ・Java起動部品（32ビット版），またはSS-Java起動部品（32ビット版）

    ・COBOL起動部品（32ビット版）

    ・コマンド起動部品，またはSS-コマンド起動部品

    64ビットプログラムから呼び出すとき

    ・ActiveX起動部品（64ビット版），またはSS-ActiveX起動部品（64ビット版）

    ・Java起動部品（64ビット版），またはSS-Java起動部品（64ビット版）

    ・COBOL起動部品（64ビット版）

    ・コマンド起動部品※，またはSS-コマンド起動部品※

    注※　32ビットモードで動作します。

  • EUR Server - AdapterまたはEUR Server - Spool Service Adapterで使用する環境設定ファイルのパスを任意のパスに変更している場合，環境設定ファイルでログの出力先を変更していても，EUR Server - AdapterまたはEUR Sever - Spool Service Adapterの各起動部品の実行時に，次に示すファイルパスの環境設定ファイルが存在すると，そのファイルのLOGFILEキーに従った出力先ディレクトリに一部のログ情報が出力されることがあります。

    EUR Serverのインストール先ディレクトリ\Adapter\EURPMADP.ini

    EUR Serverのインストール先ディレクトリ\Spool Adapter\EURPMLSADP.ini

    また，上記の場所に環境設定ファイルが存在しない場合は，次に示すディレクトリパスに一部ログ情報が出力されることがあります。

    EUR Serverのインストール先ディレクトリ\Log

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 183 / 202


付録A.4 EUR Clientを使用する場合の注意 : EUR システム構築ガイド

  • 184 / 202

  • 表紙

  • 付録

  • 付録A　Windows環境の場合の注意

  • 付録A.4　EUR Clientを使用する場合の注意

付録A.4　EUR Clientを使用する場合の注意

構成定義ファイルの格納先ディレクトリがシステムフォルダ（Program FilesまたはProgram Files (x86)）以下にある場合で，EUR Clientを管理者権限で実行しないときは，構成定義ファイルを更新すると，構成定義ファイルの格納先ディレクトリではなく，リダイレクトフォルダにファイルが作成，更新されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 184 / 202


付録B UNIX／Linux環境の場合の注意 : EUR システム構築ガイド

  • 185 / 202

  • 表紙

  • 付録

  • 付録B　UNIX／Linux環境の場合の注意

付録B　UNIX／Linux環境の場合の注意

ここでは，UNIX／Linux環境に帳票システムを構築する場合の注意事項について説明します。

〈この節の構成〉

  • 付録B.1　共通の注意

  • 付録B.2　EUR Server Service，およびEUR Server - Spool Serviceを使用する場合の注意

  • 付録B.3　EUR Server - Adapter，およびEUR Server - Spool Service Adapterを使用する場合の注意

  • 付録B.4　EUR Server Service，およびEUR Server - Spool ServiceをHP-UX環境で使用する場合の注意

  • 付録B.5　一時フォルダを使用する場合の注意

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 185 / 202


付録B.1 共通の注意 : EUR システム構築ガイド

  • 186 / 202

  • 表紙

  • 付録

  • 付録B　UNIX／Linux環境の場合の注意

  • 付録B.1　共通の注意

付録B.1　共通の注意

  • 環境設定ファイルに同じセクションまたは同じキーを複数指定しないでください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 186 / 202


付録B.2 EUR Server Service，およびEUR Server - Spool Serviceを使用する場合の注意 : EUR システム構築ガイド

  • 187 / 202

  • 表紙

  • 付録

  • 付録B　UNIX／Linux環境の場合の注意

  • 付録B.2　EUR Server Service，およびEUR Server - Spool Serviceを使用する場合の注意

付録B.2　EUR Server Service，およびEUR Server - Spool Serviceを使用する場合の注意

  • EUR Server ServiceまたはEUR Server - Spool Serviceを異なるロケールで使用する場合，EUR Server ServiceまたはEUR Server - Spool Serviceの起動管理定義の環境設定ファイルのパスに日本語が含まれていると文字を正しく判別できません。Server Service制御コマンド（eurpmctrlコマンド）またはSpool Service制御コマンド（eurpmlsctrlコマンド）で該当する起動管理定義を定義し直してください。

  • EUR Server Serviceを複数起動する場合は，EUR Server Serviceの起動管理定義で登録できるEUR Server Serviceの環境設定ファイルパスについて，次に示す登録はしないでください。

    • 同じディレクトリパスまたは同じファイルパスの複数登録

    • ディレクトリパスが登録されている場合，同じディレクトリパスのEURPM.iniのファイルパスでの登録

    • EURPM.iniのファイルパスが登録されている場合，EURPM.iniの格納先ディレクトリのディレクトリパスでの登録

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 187 / 202


付録B.3 EUR Server - Adapter，およびEUR Server - Spool Service Adapterを使用する場合の注意 : EUR システム構築ガイド

  • 188 / 202

  • 表紙

  • 付録

  • 付録B　UNIX／Linux環境の場合の注意

  • 付録B.3　EUR Server - Adapter，およびEUR Server - Spool Service Adapterを使用する場合の注意

付録B.3　EUR Server - Adapter，およびEUR Server - Spool Service Adapterを使用する場合の注意

  • EUR Server - AdapterまたはEUR Server - Spool Service Adapterを使用する場合，呼び出すプログラムの動作モードに応じて，次のモジュールを使用してください。

    32ビットプログラムから呼び出すとき

    ・Java起動部品（32ビット版），またはSS-Java起動部品（32ビット版）

    ・コマンド起動部品，またはSS-コマンド起動部品

    ・COBOL起動部品

    64ビットプログラムから呼び出すとき

    ・Java起動部品（64ビット版），またはSS-Java起動部品（64ビット版）

    ・コマンド起動部品※，またはSS-コマンド起動部品※

    注※　32ビットモードで動作します。

    COBOL起動部品の64ビットモードで動作するモジュールは，Windows環境向けだけ提供しています。UNIX／Linux環境向けには提供していません。

  • 起動部品の機能を大量に同時に実行すると，OSのリソースの上限を超えて，EURがタイムアウトする場合があります。起動部品の機能の同時実行数は1000以下となるように運用してください。

    なお，OSのリソース制限（ulimit）の上限を増やすことで，起動部品の同時実行数の制限を緩和できます。リソース制限の設定については，OSのマニュアルを参照してください。

  • EUR Server - AdapterまたはEUR Server - Spool Service Adapterで使用する環境設定ファイルのパスを任意のパスに変更している場合，環境設定ファイルでログの出力先を変更していても，EUR Server - AdapterまたはEUR Sever - Spool Service Adapterの各起動部品の実行時に，次に示すファイルパスの環境設定ファイルが存在すると，そのファイルのLOGFILEキーに従った出力先ディレクトリに一部のログ情報が出力されることがあります。

    /var/opt/eur/adapter/EURPMADP.ini

    /var/opt/eur/spool-adp/EURPMLSADP.ini

    また，上記の場所に環境設定ファイルが存在しない場合は，次に示すディレクトリパスに一部ログ情報が出力されることがあります。

    /var/opt/eur/log

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 188 / 202


付録B.4 EUR Server Service，およびEUR Server - Spool ServiceをHP-UX環境で使用する場合の注意 : EUR システム構築ガイド

  • 189 / 202

  • 表紙

  • 付録

  • 付録B　UNIX／Linux環境の場合の注意

  • 付録B.4　EUR Server Service，およびEUR Server - Spool ServiceをHP-UX環境で使用する場合の注意

付録B.4　EUR Server Service，およびEUR Server - Spool ServiceをHP-UX環境で使用する場合の注意

OSの問題によって，EUR Server ServiceまたはEUR Server - Spool Serviceが応答しなくなることがあります。このようなときには次の手順で対応してください。

  1. psコマンドでEUR Server ServiceまたはEUR Server - Spool ServiceのプロセスIDを確認します。

    • EUR Server Serviceの場合

    # ps -ef | grep eurpmd
root プロセスID 1 0 hh:mm:ss ? 0:00 /opt/eur/server/bin/eurpmd

    • EUR Server - Spool Serviceの場合

    # ps -ef | grep eurpmlsd
root プロセスID 1 0 hh:mm:ss ? 0:00 /opt/eur/spool/bin/eurpmlsd

  2. killコマンドでEUR Server ServiceまたはEUR Server - Spool ServiceのプロセスIDに停止シグナルを送ります。

    # kill -9 プロセスID

なお，このOSの問題は次のどちらかを実施すると回避できます。

  • 対策パッチ「PHCO_31553」を適用する

  • 環境変数「PTHREAD_COMPAT_MODE=1」を設定する

対策パッチの適用および環境変数の設定方法については，OSのマニュアルを参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 189 / 202


付録B.5 一時フォルダを使用する場合の注意 : EUR システム構築ガイド

  • 190 / 202

  • 表紙

  • 付録

  • 付録B　UNIX／Linux環境の場合の注意

  • 付録B.5　一時フォルダを使用する場合の注意

付録B.5　一時フォルダを使用する場合の注意

EUR サーバ帳票出力機能の実行中に一時フォルダを操作しないでください。操作した場合，予期しないエラーが発生するおそれがあります。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 190 / 202


付録C アンインストール : EUR システム構築ガイド

  • 191 / 202

  • 表紙

  • 付録

  • 付録C　アンインストール

付録C　アンインストール

ここでは，EUR Developer，およびEUR Serverのアンインストールについて説明します。

〈この節の構成〉

  • 付録C.1　Windows環境からアンインストールする

  • 付録C.2　UNIX／Linux環境からアンインストールする

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 191 / 202


付録C.1 Windows環境からアンインストールする : EUR システム構築ガイド

  • 192 / 202

  • 表紙

  • 付録

  • 付録C　アンインストール

  • 付録C.1　Windows環境からアンインストールする

付録C.1　Windows環境からアンインストールする

〈この項の構成〉

  • (1)　アンインストールの前に

  • (2)　アンインストール手順

  • (3)　サイレントアンインストール

  • (4)　手動で削除が必要なファイル

(1)　アンインストールの前に

  • アンインストールは，管理者権限を持つユーザで，かつ半角英数字のログインユーザ名で実施してください。ただし，ユーザ単位インストール用のEUR Web Plug-Inダウンロードパッケージを使用してインストールしたEUR Web Plug-Inのアンインストールは，標準ユーザ権限を持つユーザでも実施できます。

  • EUR Clientは，次のどちらかの方法でアンインストールできます。

    • ［プログラムの機能］ダイアログからEUR Clientをアンインストール

    • EUR Client再配布用パッケージのサイレントアンインストールを実行

  • EUR Web Plug-Inのアンインストール方法は，EUR Web Plug-Inをインストールしたときのインストール方法によって異なります。

    EUR Client再配布用パッケージからインストールまたはサイレントインストールした場合

    次のどちらかの方法でアンインストールできます。

    ・［プログラムの機能］ダイアログからEUR Clientをアンインストール

    ・EUR Client再配布用パッケージのサイレントアンインストールを実行

    EUR Web Plug-Inダウンロードパッケージからインストールした場合

    ブラウザのメニューからアンインストールします。

ページの先頭へ

(2)　アンインストール手順

アンインストール手順を次に示します。どちらかの方法でアンインストールしてください。

なお，EUR ClientまたはEUR Web Plug-Inをサイレントアンインストールする方法については，「(3)サイレントアンインストール」を参照してください。

(a)　［プログラムの機能］ダイアログを使用する

［プログラムの機能］ダイアログからアンインストールする手順を次に示します。

  1. ［スタート］メニューから，［コントロールパネル］－［プログラム］－［プログラムのアンインストール］を選択します。

    ［プログラムの機能］ダイアログが表示されます。

  2. アンインストールする製品の［削除］ボタンをクリックします。

    アンインストールを確認するダイアログが表示されます。

  3. ［はい］ボタンをクリックします。

    製品がアンインストールされます。

アンインストールを実行すると，次に示す情報が削除されます。

  • 対象製品関連ファイル（ディレクトリを含む）

  • スタートメニュー

  • レジストリ

(b)　ブラウザのメニューを使用する（EUR Web Plug-Inの場合）

EUR Web Plug-InをEUR Web Plug-Inダウンロードパッケージからインストールした場合は，ブラウザのメニューからアンインストールします。

なお，Internet Explorerでは，複数のプログラムファイルを一度に選択できないため，印刷用のEUR Web Plug-Inとプレビュー用のEUR Web Plug-Inの両方をインストールしているときは，一つずつアンインストールしてください。

アンインストールするプログラムファイルの名前を次に示します。

EUR Web Plug-In - Print

印刷用のEUR Web Plug-Inのプログラムファイルです。

EUR Web Plug-In - Preview

プレビュー用のEUR Web Plug-Inのプログラムファイルです。

ブラウザのメニューからアンインストールする手順を次に示します。

Internet Explorer

  1. メニューから［ツール］－［アドオンの管理］を選択します。

    ［アドオンの管理］ダイアログが表示されます。

  2. EUR Web Plug-Inのプログラムファイルをダブルクリックします。

    ［詳細情報］ダイアログが表示されます。

  3. ［削除］ボタンをクリックします。

    EUR Web Plug-Inがアンインストールされます。

ページの先頭へ

(3)　サイレントアンインストール

サイレントアンインストールは，アンインストール時にインストーラの画面でのユーザの応答を必要としないアンインストール方法です。

EUR ClientまたはEUR Web Plug-Inをサイレントアンインストールする場合は，EUR Client再配布用パッケージ（EURPM-CL.exe）からサイレントアンインストールを実行します。

コマンドプロンプトなどから，サイレントアンインストールのパラメタを指定してEUR Client再配布用パッケージ（EURPM-CL.exe）を実行すると，EUR ClientまたはEUR Web Plug-Inのサイレントアンインストールを実行します。

EUR Client再配布用パッケージ（EURPM-CL.exe）でサイレントアンインストールを実行するときのパラメタの形式，指定例，および終了通知について，次に示します。

■形式

EURPM-CL.exe△/x△/s△/v"
/qn
〔△STARTFROM=NETM〕
〔△REBOOT=R〕
〔△/L*△ログファイル名〕"
（凡例）

△：半角空白を示します。

表C‒1　EUR Client再配布用パッケージのサイレントアンインストールのパラメタ

項番

パラメタ

内容

1

/x

アンインストールするときに指定するパラメタです。必ず指定してください。

2

/s

サイレントモードを指定するパラメタです。必ず指定してください。

EURのインストーラを，ダイアログを表示せずに起動します。

3

/v

EURのインストーラから呼び出すWindows Installerのパラメタを使用するために指定するパラメタです。必ず指定してください。

Windows Installerで使用するパラメタ（項番3～10）は「"」で囲みます。

4

/qn

Windows Installerを，ダイアログを表示せずに実行するために指定するパラメタです。必ず指定してください。

5

STARTFROM=NETM

アンインストールの結果ファイルを出力する場合に指定します。

省略した場合は，アンインストールの結果ファイルを出力しません。

6

REBOOT=R

アンインストール直後の再起動を抑止する場合に指定します。

省略した場合は，再起動を抑止しません。

7

/L*△ログファイル名

（凡例）

△：半角空白を示します。

ログファイルの出力先をフルパスで指定します。

空白を含む場合は「\"」で囲みます。

（例）

/L* \"C:\Temp Dir\UnInstall.log\"

省略した場合は，ログファイルを出力しません。

■指定例

EURPM-CL.exe /x /s /v"/qn STARTFROM=NETM REBOOT=R /L* C:\Temp\UnInstall.log"

■終了通知

  • ログ出力

    パラメタ「/L*」でログファイルを指定している場合，障害調査用の情報をログファイルに出力します。

    ログファイルの出力に失敗した場合，インストーラはエラー終了します。

    エラーを検知する場合は，Windowsの終了コードをサイレントアンインストール実行後の%ERRORLEVEL%で取得してください。

  • 終了コード

    パラメタ「STARTFROM=NETM」を指定している場合，EUR Client再配布用パッケージと同じフォルダに「__NETMRT」のファイル名で結果ファイルを出力します。結果ファイルには次の表に示す終了コードを出力します。ただし，終了コードを出力する前にエラーになった場合，結果ファイルは出力されません。

    なお，結果ファイルの出力に失敗した場合，インストーラはエラー終了します。エラーの詳細は，パラメタ「/L*」で指定したログファイルに出力されます。

    表C‒2　EUR Client再配布用パッケージのサイレントアンインストールの終了コード

    終了コード

    意味

    00

    アンインストール成功

    80

    アンインストール失敗

ページの先頭へ

(4)　手動で削除が必要なファイル

次に示すファイルはアンインストール時に自動で削除されません。手動で削除してください。

  • 環境設定ファイル

    • EURPM.ini

    • EURPMCTRL.ini

    • EURPMLS.ini

    • EURPMADP.ini

    • EURPMLSADP.ini

    • EURPMRSGUI.ini

    • EURPMCL.ini

    • EURPS_ENV

    • eursmpr.ini

    • eurfm.ini

    • eurivk.ini

  • 構成定義ファイル

    • Destination.conf

    • PMPrinterClass.conf

    • PrintDest.conf

    • ServerPrinterClass.conf

    • Distribution.conf

    • userdef.conf

    • ClientPrinterClass.conf

    • addrdef.conf

    • monitordef.conf

  • そのほかの設定ファイル

    printerinf

    euraps.ini

  • 帳票出力に使用するファイル

    次に示すディレクトリ以外のディレクトリに格納されているファイル

    インストール先ディレクトリ\Server\Program

    インストール先ディレクトリ\Spool\Program

    インストール先ディレクトリ\Spool\Program(x64)

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 192 / 202


付録C.2 UNIX／Linux環境からアンインストールする : EUR システム構築ガイド

  • 193 / 202

  • 表紙

  • 付録

  • 付録C　アンインストール

  • 付録C.2　UNIX／Linux環境からアンインストールする

付録C.2　UNIX／Linux環境からアンインストールする

〈この項の構成〉

  • (1)　アンインストールの前に

  • (2)　アンインストール手順

  • (3)　手動で削除が必要なファイル

(1)　アンインストールの前に

  • アンインストールは，スーパーユーザで実施してください。

  • 起動中のEUR Serverをすべて停止してください。

  • Server Service制御コマンド（eurpmctrlコマンド）でEUR Server Serviceの起動管理定義をすべて削除してください。

ページの先頭へ

(2)　アンインストール手順

アンインストール手順を次に示します。

  1. 次に示すコマンドを実行します。

    /etc/hitachi_setup

    日立PPインストーラが起動して，メインメニューが表示されます。

  2. ［D］を選択します。

    PP削除画面が表示されます。

  3. アンインストールする製品にカーソルを移動させて，スペースキーを押します。

    選択した製品の左側に「<@>」が表示されます。複数の製品を選択することもできます。

            PP-NO.          VR                  PP-NAME
<@>001  形名        バージョン番号     EUR Server Enterprise
     ：
F) Forward B) Backward J) Down K) Up Space) Select/Unselect D) Delete Q) Quit

  4. ［D］を入力します。

    確認メッセージが表示されます。

    Delete PP? (y: delete,  n: cancel)==>

  5. ［y］または［Y］を入力します。

    アンインストールが開始されます。［y］または［Y］以外を選択すると，アンインストールが中止されてPP削除画面に戻ります。

ページの先頭へ

(3)　手動で削除が必要なファイル

次に示すファイルはアンインストール時に自動で削除されません。手動で削除してください。

  • 環境設定ファイル

    • EURPM.ini

    • EURPMCTRL.ini

    • EURPMLS.ini

    • EURPMLSCTRL.ini

    • EURPMADP.ini

    • EURPMLSADP.ini

    • EURPMRSGUI.ini

    • eurps_env

  • 構成定義ファイル

    • Destination.conf

    • PMPrinterClass.conf

    • PrintDest.conf

    • userdef.conf

    • addrdef.conf

  • 帳票出力定義ファイル

    次に示すディレクトリ配下に格納されているファイル

    /var/opt/usr/server/reportid/※

    注※

    帳票出力定義ファイルが存在しない場合は，アンインストール時にreportidディレクトリが削除されます。

  • 起動管理定義ファイル

    startdef.conf

  • そのほかの設定ファイル

    printerinf

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 193 / 202


付録D このマニュアルの参考情報 : EUR システム構築ガイド

  • 194 / 202

  • 表紙

  • 付録

  • 付録D　このマニュアルの参考情報

付録D　このマニュアルの参考情報

このマニュアルを読むに当たっての参考情報を示します。

〈この節の構成〉

  • 付録D.1　関連マニュアル

  • 付録D.2　EUR バージョン10での製品体系の変更

  • 付録D.3　EUR バージョン10でのマニュアル体系の変更

  • 付録D.4　このマニュアルでの表記

  • 付録D.5　このマニュアルで使用する略語

  • 付録D.6　KB（キロバイト）などの単位表記について

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 194 / 202


付録D.1 関連マニュアル : EUR システム構築ガイド

  • 195 / 202

  • 表紙

  • 付録

  • 付録D　このマニュアルの参考情報

  • 付録D.1　関連マニュアル

付録D.1　関連マニュアル

関連マニュアルを次に示します。必要に応じてお読みください。

〈この項の構成〉

  • (1)　EURのマニュアル

  • (2)　関連ソフトウェアのマニュアル

  • (3)　このマニュアルでのマニュアル名表記

(1)　EURのマニュアル

EURの関連マニュアルを次に示します。

  • はじめての帳票作成（3020-7-532）※

    EUR 帳票作成機能をまだ使用したことのない人向けに，簡単な帳票を作成する方法について説明しています。

  • EUR システム設計ガイド（3021-7-001）

    EURを使用した帳票システムの計画・設計時に検討が必要な内容について説明しています。

  • EUR 帳票作成 操作ガイド（3021-7-003）

    EUR 帳票作成機能を使用して帳票を作成する方法について説明しています。

  • EUR 帳票作成 画面リファレンス（3021-7-004）

    EUR 帳票作成機能で表示されるダイアログの内容について説明しています。

  • uCosminexus EUR 帳票設計（EUR Form帳票）（3020-7-534）※

    EUR Form帳票作成機能を使用してEUR Form帳票を作成する方法について説明しています。

  • EUR 帳票出力 EUR Designer/EUR Viewer編（3021-7-005）

    EUR DesignerまたはEUR Viewerを使用して，クライアント環境で帳票を出力する方法について説明しています。

  • uCosminexus EUR クライアント帳票出力（3020-7-535）※

    EUR クライアント帳票出力機能のV8互換機能を使用して，クライアント環境で帳票を出力する方法について説明しています。

  • EUR 帳票出力 機能解説 EUR Server編（3021-7-006）

    EUR サーバ帳票出力機能を使って帳票を出力する方法について説明しています。

  • EUR 帳票出力 リファレンス EUR Server編（3021-7-007）

    EUR サーバ帳票出力機能を使って帳票を出力するときに使用するAPIや入力ファイルの設定方法について説明しています。

  • uCosminexus EUR サーバ帳票出力（3020-7-536）※

    EUR ServerのV8互換機能を使用して，サーバ環境で帳票を出力する方法について説明しています。

  • EUR データベース連携ガイド（3021-7-008）

    データベースから抽出したデータを使って帳票を作成および出力する方法，およびEUR 帳票作成機能のデータベースアクセス定義ウィンドウを使用する方法について説明しています。また，データベースの操作時に出力されるメッセージについても説明しています。

  • EUR メッセージ（3021-7-009）

    EURを使用しているときに出力されるメッセージについて説明しています。

  • EUR 用語集（3021-7-010）

    EURシリーズマニュアル内で使用する用語について説明しています。なお，この用語集は日立ソフトウェアマニュアル公開サイト，または製品同梱のヘルプ（Windows版）だけで参照できます。

注※

バージョン8のマニュアルを提供しています。バージョン10の製品に置き換えて参照してください。

ページの先頭へ

(2)　関連ソフトウェアのマニュアル

関連ソフトウェアのマニュアルを次に示します。

  • TPBroker ユーザーズガイド（3000-3-660）

  • TPBroker Developer's Kit - Extension for C++ プログラマーズガイド（3000-3-680）

  • TPBroker Object Transaction Monitor ユーザーズガイド（3000-3-689）

  • COBOL2002　使用の手引　手引編（3000-3-D42）

  • COBOL2002　使用の手引　操作編（3000-3-D43）

  • COBOL2002　操作ガイド（3020-3-D47）

  • COBOL2002　ユーザーズガイド（3020-3-D48）

  • SEWB+/REPOSITORY 辞書設計ガイド（3020-3-698）

  • SEWB+/REPOSITORY 辞書設計ガイド（3020-3-N82）

  • DBPARTNER2 Client　操作ガイド（3020-6-027）

  • DABroker（3020-6-031）

  • HiRDB Version 8 UAP開発ガイド（3020-6-356）

  • HiRDB Version 8 メッセージ（3020-6-358）

  • HiRDB Version 9 UAP開発ガイド（3020-6-456）

  • HiRDB Version 9 メッセージ（3020-6-458）

  • JP1 Version 10 JP1/Audit Management - Manager 構築・運用ガイド（3021-3-165）

ページの先頭へ

(3)　このマニュアルでのマニュアル名表記

このマニュアルでは，マニュアル名について，次のように表記しています。

マニュアル名 | 表記
uCosminexus EUR 帳票設計（EUR Form帳票） | EUR 帳票設計（EUR Form帳票）
uCosminexus EUR クライアント帳票出力 | EUR クライアント帳票出力
uCosminexus EUR サーバ帳票出力 | EUR サーバ帳票出力
HiRDB Version 8 UAP開発ガイド HiRDB Version 9 UAP開発ガイド | HiRDB UAP開発ガイド
HiRDB Version 8 メッセージ HiRDB Version 9 メッセージ | HiRDB メッセージ
JP1 Version 10 JP1/Audit Management - Manager 構築・運用ガイド | JP1/Audit Management - Manager 構築・運用ガイド

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 195 / 202


付録D.2 EUR バージョン10での製品体系の変更 : EUR システム構築ガイド

  • 196 / 202

  • 表紙

  • 付録

  • 付録D　このマニュアルの参考情報

  • 付録D.2　EUR バージョン10での製品体系の変更

付録D.2　EUR バージョン10での製品体系の変更

  • 製品名称を変更しました。

  • uCosminexus EUR Server Print Editionを廃止しました。

EUR バージョン10での製品体系の変更について，次の図に示します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 196 / 202


付録D.3 EUR バージョン10でのマニュアル体系の変更 : EUR システム構築ガイド

  • 197 / 202

  • 表紙

  • 付録

  • 付録D　このマニュアルの参考情報

  • 付録D.3　EUR バージョン10でのマニュアル体系の変更

付録D.3　EUR バージョン10でのマニュアル体系の変更

  • マニュアル名を変更しました。

EUR バージョン10でのマニュアル体系の変更について，次の表に示します。

EUR バージョン9 | EUR バージョン10
uCosminexus EUR システム設計ガイド | EUR システム設計ガイド
uCosminexus EUR システム構築ガイド | EUR システム構築ガイド
uCosminexus EUR 帳票作成 操作ガイド | EUR 帳票作成 操作ガイド
uCosminexus EUR 帳票作成 画面リファレンス | EUR 帳票作成 画面リファレンス
uCosminexus EUR 帳票出力 機能解説 EUR Server編 | EUR 帳票出力 機能解説 EUR Server編
uCosminexus EUR 帳票出力 リファレンス EUR Server編 | EUR 帳票出力 リファレンス EUR Server編
uCosminexus EUR 帳票出力 EUR Designer/EUR Viewer編 | EUR 帳票出力 EUR Designer/EUR Viewer編
uCosminexus EUR データベース連携ガイド | EUR データベース連携ガイド
uCosminexus EUR メッセージ | EUR メッセージ
uCosminexus EUR 用語集 | EUR 用語集

EUR ServerのV8互換機能を使用する場合は，バージョン8対応のマニュアル「EUR サーバ帳票出力」を参照してください。Windows環境では，インストール先フォルダ\Print\1041\Help\eurps.chmに統合ヘルプが格納されています。

クライアント帳票出力機能のV8互換機能を使用する場合は，バージョン8対応のマニュアル「EUR クライアント帳票出力」を参照してください。Windows環境では，次のフォルダにヘルプが格納されています。

  • EUR Designerの場合

    EUR Designerのインストール先フォルダ\Designer\1041\Help\euroutp.chm

  • EUR Viewerの場合

    EUR Viewerのインストール先フォルダ\1041\Help\euroutp.chm

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 197 / 202


付録D.4 このマニュアルでの表記 : EUR システム構築ガイド

  • 198 / 202

  • 表紙

  • 付録

  • 付録D　このマニュアルの参考情報

  • 付録D.4　このマニュアルでの表記

付録D.4　このマニュアルでの表記

このマニュアルでは，EURの各製品について，次のように表記しています。

表記 |  | 製品名称
EUR Designer |  | EUR Designer
EUR Developer |  | EUR Developer
EUR Viewer |  | EUR Viewer
EUR Server | EUR Server Enterprise | EUR Server Enterprise
 | EUR Server Standard | EUR Server Standard
EUR Server - Cipher option |  | EUR Server - Cipher option
EUR Server Print Edition |  | uCosminexus EUR Server Print Edition
EUR Print Manager - Client |  | uCosminexus EUR Print Manager - Client
EUR Print Manager - Report Server |  | uCosminexus EUR Print Manager - Report Server
EUR Print Service |  | uCosminexus EUR Print Service
EUR Print Service Enterprise |  | uCosminexus EUR Print Service Enterprise
EUR Form | EUR Form Service | uCosminexus EUR Form Service
EUR Form Service - Data Store option |  | uCosminexus EUR Form Service - Data Store option

EUR以外の製品名称などについては，次のように表記しています。

表記 |  | 製品名称
BSP-RM |  | BSP-RM(R)
COBOL |  | COBOL2002
DABroker |  | DABroker 03-17以降 DABroker 03-21以降 DABroker(64) 03-20以降 DABroker(64) 03-21以降
HiRDB |  | HiRDB/Run Time Version 8 08-00 以降 HiRDB/Developer's Kit Version 8 08-00 以降 HiRDB/Run Time Version 8(64) 08-00 以降 HiRDB/Developer's Kit Version 8(64) 08-00 以降 HiRDB/Run Time Version 9 09-00以降 HiRDB/Developer's Kit Version 9 09-00以降 HiRDB/Developer's Suite Version 9 09-00以降 HiRDB/Run Time Version 9(64) 09-00以降 HiRDB/Developer's Kit Version 9(64) 09-00以降 HiRDB Server Version 9 09-00以降 HiRDB Server with Additional Function Version 9 09-00以降
IPF |  | Itanium(R) Processor Family
Linux | Linux 6 | Red Hat Enterprise Linux(R) Server 6 (64-bit x86_64)
 | Linux 7 | Red Hat Enterprise Linux(R) Server 7 (64-bit x86_64)
ODBC Driver |  | EURODBC Driver
 |  | DBPARTNER ODBC Driver 01-11以降
Oracle | Oracle 10g | Oracle 10g 10.1.0 Oracle 10g 10.2.0
 | Oracle 11g | Oracle Database 11g 11.1.0 Oracle Database 11g R2 11.2.0
SEWB+ |  | Software Engineering Workbench+
Hitachi Application Server |  | Hitachi Application Server uCosminexus Application Server uCosminexus Application Server Enterprise uCosminexus Application Server Standard
UNIX | AIX | AIX V6.1 AIX V7.1 AIX V7.2
 | HP-UX | HP-UX 11i V3(IPF)

このほか，このマニュアルでは，次に示す表記を使用しています。

  • EURの各製品を区別する必要がない場合は，総称してEURと表記します。

  • EUR Designer，EUR Developerの帳票作成機能を「EUR 帳票作成機能」と表記します。

  • EUR DeveloperのEUR Form帳票作成機能を「EUR 帳票作成機能（EUR Form帳票）」と表記します。

  • EUR Designer，EUR Developer，EUR Viewerのクライアント環境での帳票出力機能を「EUR クライアント帳票出力機能」と表記します。

  • EUR Developer，EUR Server Enterprise，EUR Server Standardのサーバ環境での帳票出力機能を「EUR サーバ帳票出力機能」と表記します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 198 / 202


付録D.5 このマニュアルで使用する略語 : EUR システム構築ガイド

  • 199 / 202

  • 表紙

  • 付録

  • 付録D　このマニュアルの参考情報

  • 付録D.5　このマニュアルで使用する略語

付録D.5　このマニュアルで使用する略語

このマニュアルで使用する英略語を次に示します。

英略語 | 英字での表記
API | Application Programming Interface
ASP | Active Server Pages
BOM | Byte Order Mark
COBOL | COmmon Business Oriented Language
CPI | Characters Per Inch
CSV | Comma Separated Value
DLL | Dynamic Linking Library
DPI | Dot Per Inch
EAN | European Article Number
EJB | Enterprise JavaBeans
EMF | Enhanced Metafile
EOF | End Of File
EUR | End-User Reporting
GIF | Graphics Interchange Format
GUI | Graphical User Interface
HTTP | Hyper Text Transfer Protocol
ID | IDentifier
IPF | Itanium(R) Processor Family
ISO | International Organization for Standardization
IVS | Ideographic Variation Sequence/Selector
JAN | Japanese Article Number
JDK | JavaTM Development Kit
JIS | Japanese Industrial Standards
JPEG | Joint Photographic Experts Group
JSP | Java Server Pages
LAN | Local Area Network
LDAP | Lightweight Directory Access Protocol
LIPS | LBP Image Processing System
LPI | Lines Per Inch
MFC | Microsoft Foundation Class
MIME | Multipurpose Internet Mail Extension
MSI | Microsoft Windows Installer
MUI | Multi User Interface
OCR | Optical Character Reader
OCX | OLE Custom Control (OLE Control eXtension)
ODBC | Open Database Connectivity
OLE | Object Linking and Embedding
PCF | Portable Compiled Format
PDF | Portable Document Format
PDL | Page Description Language
PNG | Portable Network Graphics
RPM | RPM Package Manager
SSL | Secure Sockets Layer
TIFF | Tagged Image File Format
TLS | Transport Layer Security
UAP | User Application Program
UPC | Universal Product Code
UTC | Coordinated Universal Time
WAN | Wide Area Network
XML | eXtensible Mark-up Language

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 199 / 202


付録D.6 KB（キロバイト）などの単位表記について : EUR システム構築ガイド

  • 200 / 202

  • 表紙

  • 付録

  • 付録D　このマニュアルの参考情報

  • 付録D.6　KB（キロバイト）などの単位表記について

付録D.6　KB（キロバイト）などの単位表記について

1KB（キロバイト），1MB（メガバイト），1GB（ギガバイト），1TB（テラバイト）はそれぞれ1,024バイト，1,0242バイト，1,0243バイト，1,0244バイトです。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 200 / 202


索引 : EUR システム構築ガイド

  • 201 / 202

  • 表紙

  • 索引

索引

  • A B C E J P S U V W

  • あ行 か行 さ行 た行 は行 ま行 や行 ら行

A

  • Acrobat JavaScript定義ファイル〔格納先〕

  • Acrobat JavaScriptファイル〔格納先〕

  • ActiveX起動部品

  • ASP.NETを使用する

ページの先頭へ

B

  • BSP-RM連携コマンド

ページの先頭へ

C

  • COBOL起動部品

  • COBOLを使用する

ページの先頭へ

E

  • EUR Application Service動作設定ファイル

  • EUR Application Service動作設定ファイル〔格納先〕

  • ［EUR Client 構成定義］ダイアログ

  • EUR Client再配布用パッケージを使用したインストール

  • EURPM.Exec

  • EURPMAdapterForJavaクラス

  • EURPMADPLib.EURPMAdapterクラス

  • eurpmcepfviewerコマンド

  • eurpmctrl

  • EURPMCTRL.exe

  • eurpmcコマンド

  • EURPMExceptionクラス

  • EURPMLS.Exec

  • EURPMLSAdapterForJavaクラス

  • EURPMLSADPLib.EURPMLSAdapterクラス

  • eurpmlsctrl

  • eurpmlscコマンド

  • EURPMLSExceptionクラス

  • EUR Print Serviceの環境設定ファイル〔ファイル名と格納先〕

  • EUR Server Enterprise〔位置づけ〕

  • EUR Server Service稼働マシンに準備するファイル

  • ［EUR Server Service 起動管理］ダイアログ

  • ［EUR Server Service 起動管理］ダイアログを使用した起動管理

  • ［EUR Server Service 構成定義］ダイアログ

    • ［出力先］タブ

    • ［プリンタクラス］タブ

  • EUR Server Serviceの稼働状態を確認する〔Server Service制御コマンド〕

  • EUR Server Serviceの起動管理設定

  • EUR Server Serviceの自動起動の設定をする〔Server Service制御コマンド〕

  • EUR Server Serviceを起動する〔Server Service制御コマンド〕

  • EUR Server Serviceを停止する〔Server Service制御コマンド〕

  • EUR Server Standard〔位置づけ〕

  • EUR Serverの種類

  • EUR Server - Adapter稼働マシンに準備するファイル

  • EUR Server - AdapterまたはEUR Server - Spool Service Adapterで使用する環境設定ファイルのパスを指定する場合〔ファイル名と格納先〕

  • EUR Server - Spool Serviceの稼働状態を確認する〔Spool Service制御コマンド〕

  • EUR Server - Spool Serviceの起動管理設定

  • EUR Server - Spool Serviceを起動する〔Spool Service制御コマンド〕

  • EUR Server - Spool Serviceを停止する〔Spool Service制御コマンド〕

  • eursmprコマンド

  • ［EUR Spool Service 構成定義］ダイアログ

    • ［帳票振り分け］タブ

    • ［プリンタクラス］タブ

    • ［ユーザ定義］タブ

  • EUR Web Plug-In情報ファイル

  • EUR Web Plug-In情報ファイル〔格納先〕

  • EUR Web Plug-Inダウンロードパッケージを使用したインストール

  • EURフォントファイル

  • EURフォントファイル作成ツール

  • EURをアップグレードする

  • expedf32コマンド

ページの先頭へ

J

  • Java起動部品

  • Javaを使用する

  • JP.co.Hitachi.soft.EURPMLSパッケージ

  • JP.co.Hitachi.soft.EURPMパッケージ

  • JSPを使用する

ページの先頭へ

P

  • PDF仕分け定義ファイル〔格納先〕

ページの先頭へ

S

  • SS-ActiveX起動部品

  • SS-Java起動部品

  • SS-コマンド起動部品

ページの先頭へ

U

  • UNIX／Linux環境の場合の注意

ページの先頭へ

V

  • VBScriptを使用する

  • Visual Basic .NETを使用する

  • Visual Basicを使用する

ページの先頭へ

W

  • Windows環境の場合の注意

ページの先頭へ

あ行

あ

  • アップグレードインストール

  • アップグレード前にバックアップするファイル

  • アプリケーションサーバに準備するファイル

  • アプリケーションサーバを帳票サーバとは別に構築する

  • アンインストール〔UNIX／Linux環境〕

  • アンインストール〔Windows環境〕

  • 暗号化設定ファイル〔格納先〕

い

  • 印刷先定義ファイル〔作成方法〕

  • 印刷日時出力定義ファイル〔格納先〕

  • インストール後に作成されるディレクトリ

    • EUR Client

    • EUR Developer

    • EUR Server

    • EUR Server - Adapter

    • EUR Server - Spool Service

    • EUR Server - Spool Service Adapter

  • インストール方法

    • EUR Client

    • EUR Developer

    • EUR Server

    • EUR Server - Adapter

    • EUR Server - Spool Service

    • EUR Server - Spool Service Adapter

    • EUR Web Plug-In

  • インポートするファイル

    • アプリケーションサーバ

    • クライアント

    • スプールサーバ

    • 帳票サーバ

う

  • 運用に応じて格納先を決めるファイル

え

  • エラー情報〔Server Service制御コマンド〕

  • エラー情報〔Spool Service制御コマンド〕

お

  • 置き換え表管理情報ファイル〔格納先〕

  • 置き換え表ファイル〔格納先〕

  • オプション

    • EURフォントファイル作成ツール

    • Server Service制御コマンド

    • Spool Service制御コマンド

ページの先頭へ

か行

か

  • 開発環境〔システム構成〕

  • 過去に作成したファイルを流用する〔出力環境を設定するファイル〕

  • 過去に作成したファイルを流用する〔出力内容を設定するファイル〕

  • 画像ファイル〔格納先〕

  • 可変記号値定義ファイル〔格納先〕

  • 環境設定ファイルのファイル名と格納先

  • 監査証跡管理システムとの連携

    • 監査ログ管理サーバの構築

    • 監査ログ収集対象サーバの構築

  • 監査ログ

  • 監視定義ファイル〔作成方法〕

き

  • 起動管理定義

  • 起動管理定義の登録内容を確認する〔Server Service制御コマンド〕

  • 起動管理定義の登録内容を確認する〔Spool Service制御コマンド〕

  • 起動管理定義を削除する〔Server Service制御コマンド〕

  • 起動管理定義を削除する〔ダイアログ〕

  • 起動管理定義を登録する〔Server Service制御コマンド〕

  • 起動管理定義を登録する〔ダイアログ〕

  • 起動管理定義を変更する〔Server Service制御コマンド〕

  • 起動管理定義を変更する〔Spool Service制御コマンド〕

  • 起動管理定義を変更する〔ダイアログ〕

  • 起動パラメタファイル〔格納先〕

  • 起動部品の環境設定〔帳票管理GUI〕

  • 起動部品の環境設定〔配送サービス〕

  • 起動部品の設定〔業務プログラム〕

  • 業務プログラムの作成を支援するインタフェース〔クライアント〕

  • 業務プログラムの作成を支援するインタフェース〔サーバ〕

  • 業務プログラムの修正と再配置

  • 業務プログラムの配置と登録〔クライアント〕

  • 業務プログラムの配置と登録〔サーバ〕

  • 拠点プリンタクラス定義ファイル〔作成方法〕

く

  • クライアントで動作する業務プログラムを作成する

  • クライアントプリンタクラス定義ファイル〔作成方法〕

  • クライアントを構築する

こ

  • 構成定義ファイルの種類と格納先

  • 構築作業の前に決めておくこと

  • 構築できるサーバの種類

  • 構築の流れ

    • アプリケーションサーバを帳票サーバとは別に構築する場合

    • クライアントを構築する場合

    • スプールサーバを帳票サーバとは別に構築する場合

    • 帳票サーバを構築する場合

  • 個人番号管理サービスのSSLサーバ証明書〔格納先〕

  • 個人番号接続情報ファイル〔格納先〕

  • 個人番号フィールド情報ファイル〔格納先〕

  • コマンド起動部品

  • コマンドの構文

    • EURフォントファイル作成ツール

  • コマンドを使用する

ページの先頭へ

さ行

さ

  • サーバで動作する業務プログラムを作成する

  • サーバで動作する業務プログラムを作成する場合の注意

  • ［サービスの追加］ダイアログ

  • ［サービスの変更］ダイアログ

  • サービスプログラムのインストール〔帳票管理GUI〕

  • サービスプログラムのインストール〔配送サービス〕

  • サイレントアンインストール〔EUR ClientおよびEUR Web Plug-In〕

  • サイレントインストール〔EUR ClientおよびEUR Web Plug-In〕, [2]

  • 作業の流れ

    • 帳票システムのEURをアップグレードする場合

    • 帳票システムを移行する場合

    • 帳票システムを新規作成する場合

し

  • しおり定義ファイル〔格納先〕

  • 事前準備

    • アプリケーションサーバを帳票サーバとは別に構築する場合

    • クライアントを構築する場合

    • スプールサーバを帳票サーバとは別に構築する場合

    • 帳票サーバを構築する場合

  • 実現できる機能〔ActiveX起動部品〕

  • 実現できる機能〔BSP-RM連携コマンド〕, [2]

  • 実現できる機能〔COBOL起動部品〕

  • 実現できる機能〔eurpmcepfviewerコマンド〕

  • 実現できる機能〔eurpmcコマンド〕

  • 実現できる機能〔eurpmlscコマンド〕

  • 実現できる機能〔EUR Web Plug-In〕

  • 実現できる機能〔Java起動部品〕

  • 実現できる機能〔SS-ActiveX起動部品〕

  • 実現できる機能〔SS-Java起動部品〕

  • 自動起動の設定〔Server Service〕

  • 終了コード〔Server Service制御コマンド〕

  • 終了コード〔Spool Service制御コマンド〕

  • 出力先定義ファイル〔作成方法〕

  • ［出力先の追加］ダイアログ

  • ［出力先の変更］ダイアログ

  • 出力先を削除する

  • 出力先を登録する

  • 出力先を変更する

  • 準備の流れ

    • 過去に作成したファイルを流用する場合〔出力環境を設定するファイル〕

    • 過去に作成したファイルを流用する場合〔出力内容を設定するファイル〕

    • ファイルを新規作成する場合〔出力環境を設定するファイル〕

    • ファイルを新規作成する場合〔出力内容を設定するファイル〕

  • 仕分け定義ファイル〔格納先〕

  • 新規用紙出力定義ファイル〔格納先〕

す

  • スプールサーバを帳票サーバとは別に構築する

せ

  • 制御情報付データファイル〔格納先〕

  • 接続情報ファイル〔格納先〕

ページの先頭へ

た行

た

  • ダウンロードパッケージの配置〔帳票管理GUI〕

ち

  • 帳票管理GUIサービスの再設定

  • 帳票管理GUIサービスの設定

  • 帳票管理GUIを呼び出すには

  • 帳票サーバに準備するファイル

  • 帳票サーバプリンタクラス定義ファイル〔作成方法〕

  • 帳票サーバを構築する

  • 帳票システムの構成要素

  • 帳票システムの構築の流れ

  • 帳票システムを移行する

  • 帳票出力環境〔システム構成〕

  • 帳票出力定義ファイル〔格納先〕

  • 帳票セット指定ファイル〔格納先〕

  • 帳票の出力環境を設定するファイルを準備する

  • 帳票の出力内容を設定するファイルを準備する

  • 帳票ファイル〔格納先〕

  • ［帳票振り分け定義の追加］ダイアログ

  • ［帳票振り分け定義の変更］ダイアログ

  • 帳票振り分け定義ファイル〔作成方法〕

  • 帳票振り分け定義を削除する

  • 帳票振り分け定義を登録する

  • 帳票振り分け定義を変更する

て

  • テスト印刷設定ファイル〔格納先〕

ページの先頭へ

は行

は

  • 配送サービスの設定

ひ

  • ビューアプレファレンス定義ファイル〔格納先〕

ふ

  • ファイル監視サービス

  • ファイル監視サービスの起動管理設定〔アプリケーションサーバ〕

  • ファイル監視サービスの起動管理設定〔帳票サーバ〕

  • ファイル監視サービスを使用する

  • ファイルの作成方法

    • EURフォントファイル

    • 環境設定ファイル

    • 構成定義ファイル

  • ファイルを新規作成する〔出力環境を設定するファイル〕

  • ファイルを新規作成する〔出力内容を設定するファイル〕

  • 複数様式情報定義ファイル〔格納先〕

  • ［プリンタクラスの追加］ダイアログ〔EUR Client〕

  • ［プリンタクラスの追加］ダイアログ〔EUR Server Service〕

  • ［プリンタクラスの追加］ダイアログ〔EUR Server - Spool Service〕

  • ［プリンタクラスの変更］ダイアログ〔EUR Client〕

  • ［プリンタクラスの変更］ダイアログ〔EUR Server Service〕

  • ［プリンタクラスの変更］ダイアログ〔EUR Server - Spool Service〕

  • プリンタクラスを削除する〔クライアント〕

  • プリンタクラスを削除する〔スプールサーバ〕

  • プリンタクラスを削除する〔帳票サーバ〕

  • プリンタクラスを登録する〔クライアント〕

  • プリンタクラスを登録する〔スプールサーバ〕

  • プリンタクラスを登録する〔帳票サーバ〕

  • プリンタクラスを変更する〔クライアント〕

  • プリンタクラスを変更する〔スプールサーバ〕

  • プリンタクラスを変更する〔帳票サーバ〕

  • プリンタ定義ファイル〔格納先〕

  • 分割定義ファイル〔格納先〕

  • 文書しおり定義ファイル〔格納先〕

  • 文書情報設定ファイル〔格納先〕

ページの先頭へ

ま行

ま

  • マッピングデータファイル〔格納先〕

  • マニュアルの説明で使用するシステム構成

ページの先頭へ

や行

ゆ

  • ユーザ管理ファイル〔作成方法〕

  • ユーザ定義データファイル〔格納先〕

  • ［ユーザ定義の追加］ダイアログ

  • ［ユーザ定義の変更］ダイアログ

  • ユーザ定義を削除する

  • ユーザ定義を登録する

  • ユーザ定義を変更する

ページの先頭へ

ら行

れ

  • 連携プロファイル〔格納先〕

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 201 / 202


マニュアル発行元 : EUR システム構築ガイド

  • 202 / 202

  • 表紙

  • マニュアル発行元

マニュアル発行元

株式会社 日立製作所

〒100‒8280　東京都千代田区丸の内一丁目6番6号

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 202 / 202


目次 : EUR システム構築ガイド

  • 2 / 202

  • 表紙

  • 目次

目次

  • 前書き

  • 変更内容

  • はじめに

  • 第1編　帳票システムの構築

    • 1.　帳票システムを構築するには

      • 1.1　帳票システムの構築の流れ

        • 1.1.1　システムを新規作成する場合の流れ

        • 1.1.2　EURをアップグレードする場合の流れ

        • 1.1.3　システムを移行する場合の流れ

      • 1.2　構築作業の前に決めておくこと

      • 1.3　このマニュアルの説明で使用するシステム構成

  • 第2編　開発環境の構築

    • 2.　EUR Developerをインストールする

      • 2.1　インストール方法

        • 2.1.1　インストールの前に

        • 2.1.2　インストール手順

        • 2.1.3　リモートインストール

      • 2.2　インストール後に作成されるディレクトリ

      • 2.3　インストール時の注意事項

  • 第3編　業務プログラムの作成

    • 3.　サーバで動作する業務プログラムを作成する

      • 3.1　EURが提供するインタフェース

      • 3.2　実行ユーザとアクセス権

      • 3.3　VBScript，Visual Basic，Visual Basic .NET，ASP.NETなどを使用する

        • 3.3.1　EUR Server Serviceを呼び出すには

        • 3.3.2　EUR Server - Spool Serviceを呼び出すには

      • 3.4　JSP，Javaなどを使用する

        • 3.4.1　EUR Server Serviceを呼び出すには

        • 3.4.2　EUR Server - Spool Serviceを呼び出すには

        • 3.4.3　業務プログラムから帳票管理GUIを呼び出すには

      • 3.5　COBOLを使用する

        • 3.5.1　使用方法

        • 3.5.2　実現できる機能

        • 3.5.3　注意事項

      • 3.6　コマンドを使用する

        • 3.6.1　EUR Server Serviceを呼び出すには

        • 3.6.2　EUR Server - Spool Serviceを呼び出すには

        • 3.6.3　BSP-RMと連携するには

      • 3.7　ファイル監視サービスを使用する

        • 3.7.1　使用方法

        • 3.7.2　実現できる機能

        • 3.7.3　注意事項

      • 3.8　サーバで動作する業務プログラムを作成する場合の注意

    • 4.　クライアントで動作する業務プログラムを作成する

      • 4.1　EURが提供するインタフェース

      • 4.2　実行ユーザとアクセス権

      • 4.3　コマンドを使用する

        • 4.3.1　使用方法

        • 4.3.2　実現できる機能

        • 4.3.3　注意事項

      • 4.4　EUR Web Plug-Inを使用する

        • 4.4.1　使用方法

        • 4.4.2　実現できる機能

        • 4.4.3　注意事項

  • 第4編　帳票出力で使用するファイルの準備

    • 5.　帳票の出力内容を設定するファイルを準備する

      • 5.1　準備の流れ

        • 5.1.1　ファイルを新規作成する

        • 5.1.2　過去に作成したファイルを流用する

      • 5.2　帳票サーバに準備するファイル

        • 5.2.1　EUR Application Service動作設定ファイルを作成するには

      • 5.3　アプリケーションサーバに準備するファイル

      • 5.4　運用に応じて格納先を決めるファイル

    • 6.　帳票の出力環境を設定するファイルを準備する

      • 6.1　準備の流れ

        • 6.1.1　ファイルを新規作成する

        • 6.1.2　過去に作成したファイルを流用する

      • 6.2　環境設定ファイルを作成するには

        • 6.2.1　環境設定ファイルとは

        • 6.2.2　ファイルの作成方法

      • 6.3　構成定義ファイルを作成するには

        • 6.3.1　構成定義ファイルとは

        • 6.3.2　ファイルの作成方法

        • 6.3.3　スプールサーバを登録する

        • 6.3.4　帳票サーバのプリンタクラスを登録する

        • 6.3.5　印刷先を登録する

        • 6.3.6　スプールサーバのプリンタクラスを登録する

        • 6.3.7　帳票振り分け定義を登録する

        • 6.3.8　スプールデータを操作するユーザを登録する

        • 6.3.9　クライアントのプリンタクラスを登録する

        • 6.3.10　ファイル監視サービスの照合パターンを登録する

      • 6.4　EURフォントファイルを作成するには

        • 6.4.1　ファイルの作成方法

        • 6.4.2　EURフォントファイル作成ツールの使用方法

  • 第5編　帳票出力環境の構築

    • 7.　帳票サーバを構築する

      • 7.1　構築の流れ

      • 7.2　事前準備

      • 7.3　EUR Serverのインストール

        • 7.3.1　インストール方法

        • 7.3.2　インストール後に作成されるディレクトリ

      • 7.4　必要なファイルのインポート

      • 7.5　EUR Server Serviceの起動管理設定

        • 7.5.1　［EUR Server Service 起動管理］ダイアログを使用した起動管理

        • 7.5.2　Server Service制御コマンドを使用した起動管理

        • 7.5.3　EUR Server Serviceの自動起動の設定

      • 7.6　EUR Server - Spool Serviceの起動管理設定

        • 7.6.1　Spool Service制御コマンドを使用した起動管理

      • 7.7　ファイル監視サービスの起動管理設定

        • 7.7.1　ファイル監視サービスの自動起動の設定

      • 7.8　帳票管理GUIサービスの設定

        • 7.8.1　JDKのインストール

        • 7.8.2　Web/APサーバのインストール

        • 7.8.3　EUR Web Plug-Inのダウンロードパッケージの配置

        • 7.8.4　サービスプログラムのインストール

        • 7.8.5　起動部品の環境設定

        • 7.8.6　サービスの登録・起動

      • 7.9　配送サービスの設定

        • 7.9.1　JDKのインストール

        • 7.9.2　Web/APサーバのインストール

        • 7.9.3　サービスプログラムのインストール

        • 7.9.4　起動部品の環境設定

        • 7.9.5　サービスの登録・起動

      • 7.10　業務プログラムの配置と登録

        • 7.10.1　起動部品の設定

        • 7.10.2　EUR Web Plug-In情報ファイルの配置

      • 7.11　監査証跡管理システムとの連携

        • 7.11.1　監査ログ管理サーバの構築

        • 7.11.2　監査ログ収集対象サーバの構築

    • 8.　スプールサーバを帳票サーバとは別に構築する

      • 8.1　構築の流れ

      • 8.2　事前準備

      • 8.3　EUR Server - Spool Serviceのインストール

        • 8.3.1　インストール方法

        • 8.3.2　インストール後に作成されるディレクトリ

      • 8.4　必要なファイルのインポート

      • 8.5　EUR Server - Spool Serviceの起動管理設定

      • 8.6　帳票管理GUIサービスの設定

      • 8.7　配送サービスの設定

      • 8.8　業務プログラムの配置と登録

      • 8.9　監査証跡管理システムとの連携

    • 9.　アプリケーションサーバを帳票サーバとは別に構築する

      • 9.1　構築の流れ

      • 9.2　事前準備

      • 9.3　前提プログラムのインストール

        • 9.3.1　アプリケーションサーバ

        • 9.3.2　起動部品の前提プログラム

      • 9.4　EUR Server - Adapterのインストール

        • 9.4.1　インストール方法

        • 9.4.2　インストール後に作成されるディレクトリ

      • 9.5　EUR Server - Spool Service Adapterのインストール

        • 9.5.1　インストール方法

        • 9.5.2　インストール後に作成されるディレクトリ

      • 9.6　必要なファイルのインポート

      • 9.7　ファイル監視サービスの起動管理設定

      • 9.8　帳票管理GUIサービスの設定

      • 9.9　配送サービスの設定

      • 9.10　業務プログラムの配置と登録

    • 10.　クライアントを構築する

      • 10.1　構築の流れ

      • 10.2　事前準備

      • 10.3　前提プログラムのインストール

        • 10.3.1　Adobe Flash Player

        • 10.3.2　Adobe Reader

        • 10.3.3　Microsoft Office Excel

      • 10.4　EUR Clientのインストール

        • 10.4.1　インストール方法

        • 10.4.2　インストール後に作成されるディレクトリ

      • 10.5　EUR Web Plug-Inのインストール

        • 10.5.1　EUR Client再配布用パッケージを使用したインストール

        • 10.5.2　EUR Web Plug-Inダウンロードパッケージを使用したインストール

      • 10.6　必要なファイルのインポート

      • 10.7　業務プログラムの配置と登録

        • 10.7.1　前提プログラムのインストール

        • 10.7.2　業務プログラムの配置

  • 第6編　帳票システムのアップグレードと移行

    • 11.　EURをアップグレードする

      • 11.1　ファイルのバックアップ

      • 11.2　EURのアップグレードインストール

        • 11.2.1　インストールの前に

        • 11.2.2　インストール手順

      • 11.3　業務プログラムの修正と再配置

      • 11.4　ファイルの修正とリストア

      • 11.5　帳票管理GUIサービスの再設定

        • 11.5.1　EUR Web Plug-Inのダウンロードパッケージの配置

        • 11.5.2　サービスプログラムの再インストール

        • 11.5.3　起動部品の環境設定

        • 11.5.4　サービスの再登録・起動

    • 12.　帳票システムを移行する

      • 12.1　移行先マシンのセットアップ

      • 12.2　業務プログラムの修正と再配置

      • 12.3　ファイルの修正とインポート

  • 付録

    • 付録A　Windows環境の場合の注意

      • 付録A.1　共通の注意

      • 付録A.2　EUR Server Service，およびEUR Server - Spool Serviceを使用する場合の注意

      • 付録A.3　EUR Server - Adapter，およびEUR Server - Spool Service Adapterを使用する場合の注意

      • 付録A.4　EUR Clientを使用する場合の注意

    • 付録B　UNIX／Linux環境の場合の注意

      • 付録B.1　共通の注意

      • 付録B.2　EUR Server Service，およびEUR Server - Spool Serviceを使用する場合の注意

      • 付録B.3　EUR Server - Adapter，およびEUR Server - Spool Service Adapterを使用する場合の注意

      • 付録B.4　EUR Server Service，およびEUR Server - Spool ServiceをHP-UX環境で使用する場合の注意

      • 付録B.5　一時フォルダを使用する場合の注意

    • 付録C　アンインストール

      • 付録C.1　Windows環境からアンインストールする

      • 付録C.2　UNIX／Linux環境からアンインストールする

    • 付録D　このマニュアルの参考情報

      • 付録D.1　関連マニュアル

      • 付録D.2　EUR バージョン10での製品体系の変更

      • 付録D.3　EUR バージョン10でのマニュアル体系の変更

      • 付録D.4　このマニュアルでの表記

      • 付録D.5　このマニュアルで使用する略語

      • 付録D.6　KB（キロバイト）などの単位表記について

  • 索引

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 2 / 202