EUR システム設計ガイド

  • 目次

  • 索引

  • 前へ

  • 1 / 195

  • 次へ

EUR システム設計ガイド

3021-7-001-40

目次ダイジェスト

  • 前書き

  • 変更内容

  • はじめに

  • 第1編　基本設計編

    • 1.　帳票出力業務の検討

    • 2.　システム構成，ネットワーク構成の検討

    • 3.　業務プログラムの検討

    • 4.　帳票に出力するデータの検討

    • 5.　帳票の運用方法の検討

  • 第2編　詳細設計編

    • 6.　業務プログラムの設計

    • 7.　EURの入力ファイルの設計

    • 8.　帳票出力環境の設計

    • 9.　帳票デザインの設計

  • 付録

  • 索引

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 1 / 195

  • 次へ

  • 商品名称に関する表示

  • マニュアル発行元

All Rights Reserved. Copyright (C) 2014, 2017, Hitachi, Ltd.

All Rights Reserved. Copyright (C) 2014, 2017, Hitachi Solutions, Ltd.


前書き : EUR システム設計ガイド

  • 3 / 195

  • 次へ

  • 表紙

  • 前書き

前書き

■ 対象製品

●適用OS：Windows 7 x86，Windows 7 x64※1，Windows 8.1 x86※2，Windows 8.1 x64※1※2，Windows 10 x86※2，Windows 10 x64※1※2

  • P-2CD2-56A4 EUR Designer 10-40

  • P-2CD2-5DA4 EUR Developer※3 10-40

  • P-2CD2-53A4 EUR Viewer 10-40

●適用OS：Windows Server 2008，Windows Server 2012

  • P-29D2-59A4 EUR Server Standard※4 10-40

  • P-29D2-5EA4 EUR Server Enterprise※4 10-40

  • P-29D2-5CA4 EUR Server - Cipher option 10-30

●適用OS：HP-UX 11i V3(IPF)

  • P-1JD2-59A1 EUR Server Standard 10-10

  • P-1JD2-5EA1 EUR Server Enterprise 10-10

  • P-1JD2-5CA1 EUR Server - Cipher option 10-00

●適用OS：AIX V6.1，AIX V7.1，AIX V7.2

  • P-1MD2-59A1 EUR Server Standard 10-10

  • P-1MD2-5EA1 EUR Server Enterprise 10-10

  • P-1MD2-5CA1 EUR Server - Cipher option 10-00

●適用OS：Linux 6，Linux 7

  • P-82D2-59A1 EUR Server Standard 10-10

  • P-82D2-5EA1 EUR Server Enterprise 10-10

  • P-82D2-5CA1 EUR Server - Cipher option 10-00

注※1

    WOW64（Windows On Windows 64）環境だけで使用できます。

注※2

    Modern UIには対応していません。

注※3

    次に示す製品を同梱しています。

    ・P-2463-2354　　DABroker

注※4

    次に示す製品を同梱しています。

    ・P-2963-2354　　DABroker(64)

これらの製品は，ISO9001およびTickITの認証を受けた品質マネジメントシステムで開発されました。

■ 輸出時の注意

本製品を輸出される場合には、外国為替及び外国貿易法の規制並びに米国輸出管理規則など外国の輸出関連法規をご確認の上、必要な手続きをお取りください。

なお、不明な場合は、弊社担当営業にお問い合わせください。

■ 商標類

HITACHI，DABroker，DBPARTNER，EUR，Groupmax，HiRDB，JP1，SEWB，TPBroker，uCosminexusは，株式会社 日立製作所の商標または登録商標です。

ActiveXは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

IBM，AIXは，世界の多くの国で登録されたInternational Business Machines Corporationの商標です。

Internet Explorerは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

Itaniumは，アメリカ合衆国および / またはその他の国におけるIntel Corporationの商標です。

Linuxは，Linus Torvalds氏の日本およびその他の国における登録商標または商標です。

MicrosoftおよびMS-DOSは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

MicrosoftおよびSQL Serverは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

MicrosoftおよびVisual Basicは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

MicrosoftおよびVisual C++は，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

Microsoft .NET は，お客様，情報，システムおよびデバイスを繋ぐソフトウェアです。

Microsoft OfficeおよびExcelは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

Microsoft Office Wordは，米国Microsoft Corporation の商品名称です。

ODBCは，米国Microsoft Corporationが提唱するデータベースアクセス機構です。

OLEは，米国Microsoft Corporationが開発したソフトウェア名称です。

OracleとJavaは，Oracle Corporation 及びその子会社，関連会社の米国及びその他の国における登録商標です。

PostScriptは，米国でのAdobe Systems, Inc.の商標です。

Red Hatは，米国およびその他の国でRed Hat, Inc.の登録商標もしくは商標です。

RSAおよびBSAFEは，米国EMC コーポレーションの米国およびその他の国における商標または登録商標です。

UNIXは，The Open Groupの米国ならびに他の国における登録商標です。

Windowsは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

Windows Serverは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

本製品は，米国EMC コーポレーションのRSA BSAFE(R)ソフトウェアを搭載しています。

This product includes software developed by the Apache Software Foundation (http://www.apache.org/).

This product includes software developed by Ben Laurie for use in the Apache-SSL HTTP server project.

Portions of this software were developed at the National Center for Supercomputing Applications (NCSA) at the University of Illinois at Urbana-Champaign.

This product includes software developed by the University of California, Berkeley and its contributors.

This software contains code derived from the RSA Data Security Inc. MD5 Message-Digest Algorithm, including various modifications by Spyglass Inc., Carnegie Mellon University, and Bell Communications Research, Inc (Bellcore).

Regular expression support is provided by the PCRE library package, which is open source software, written by Philip Hazel, and copyright by the University of Cambridge, England. The original software is available from ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/

This product includes software developed by Ralf S. Engelschall <rse@engelschall.com> for use in the mod_ssl project (http://www.modssl.org/).

This product includes software developed by IAIK of Graz University of Technology.

This product includes software developed by Daisuke Okajima and Kohsuke Kawaguchi (http://relaxngcc.sf.net/).

This product includes software developed by the Java Apache Project for use in the Apache JServ servlet engine project (http://java.apache.org/).

This product includes software developed by Andy Clark.

その他記載の会社名，製品名は，それぞれの会社の商標もしくは登録商標です。

■ マイクロソフト製品の表記について

このマニュアルでは，マイクロソフト製品の名称を次のように表記しています。

表記 |  |  | 製品名称
.NET |  |  | Microsoft(R) .NET
ActiveX |  |  | ActiveX(R)
Excel |  |  | Microsoft(R) Office Excel 2007 Microsoft(R) Office Excel 2010 Microsoft(R) Office Excel 2013
Internet Explorer |  |  | Windows(R) Internet Explorer(R)
SQL Server |  |  | Microsoft(R) SQL Server 2008 Microsoft(R) SQL Server 2008 R2 Microsoft(R) SQL Server 2012
VBScript |  |  | Microsoft(R) Visual Basic(R) Scripting Edition
Visual Basic |  |  | Microsoft(R) Visual Basic(R)
Visual C++ |  |  | Microsoft(R) Visual C++(R)
Windows | Windows 7 | Windows 7 x86 | Microsoft(R) Windows(R) 7 Professional(32ビット版) Microsoft(R) Windows(R) 7 Enterprise(32ビット版) Microsoft(R) Windows(R) 7 Ultimate(32ビット版)
 |  | Windows 7 x64 | Microsoft(R) Windows(R) 7 Professional(64ビット版) Microsoft(R) Windows(R) 7 Enterprise(64ビット版) Microsoft(R) Windows(R) 7 Ultimate(64ビット版)
 | Windows 8 | Windows 8 x86 | Windows(R) 8 Pro(32ビット版) Windows(R) 8 Enterprise(32ビット版)
 |  | Windows 8 x64 | Windows(R) 8 Pro(64ビット版) Windows(R) 8 Enterprise(64ビット版)
 | Windows 8.1 | Windows 8.1 x86 | Windows(R) 8.1 Pro(32ビット版) Windows(R) 8.1 Enterprise(32ビット版)
 |  | Windows 8.1 x64 | Windows(R) 8.1 Pro(64ビット版) Windows(R) 8.1 Enterprise(64ビット版)
 | Windows 10 | Windows 10 x86 | Windows(R) 10 Pro(32ビット版) Windows(R) 10 Enterprise(32ビット版)
 |  | Windows 10 x64 | Windows(R) 10 Pro(64ビット版) Windows(R) 10 Enterprise(64ビット版)
 | Windows Server 2008 |  | Microsoft(R) Windows Server(R) 2008 R2 Standard Microsoft(R) Windows Server(R) 2008 R2 Enterprise Microsoft(R) Windows Server(R) 2008 R2 Datacenter
 | Windows Server 2012 |  | Microsoft(R) Windows Server(R) 2012 Standard Microsoft(R) Windows Server(R) 2012 Datacenter Microsoft(R) Windows Server(R) 2012 R2 Standard Microsoft(R) Windows Server(R) 2012 R2 Datacenter
Word |  |  | Microsoft(R) Office Word 2007 Microsoft(R) Office Word 2010 Microsoft(R) Office Word 2013

■ 発行

2017年3月　3021-7-001-40

■ 著作権

All Rights Reserved. Copyright (C) 2014, 2017, Hitachi, Ltd.

All Rights Reserved. Copyright (C) 2014, 2017, Hitachi Solutions, Ltd.

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 3 / 195


変更内容 : EUR システム設計ガイド

  • 4 / 195

  • 表紙

  • 変更内容

変更内容

変更内容（3021-7-001-40）

EUR Designer　10-40

EUR Developer　10-40

EUR Viewer　10-40

EUR Server Standard　10-40

EUR Server Enterprise　10-40

追加・変更内容

変更個所

EUR Designer，EUR Developer，EUR Viewerの適用OSからWindows 8を除外しました。

－

EUR Server Standard，EUR Server Enterpriseの適用OSに次のOSを追加しました。

  • AIX V7.2

  • Linux 7

－

EURの言語環境の説明を変更しました。

1.2，1.2.1，4.6，4.6.1，4.6.2，4.6.3，4.6.4，4.6.5，4.6.6，付録A

EUR Server - Adapterの起動部品で，分割ページ数を指定してPDF形式ファイルを分割出力する機能を追加しました。

2.2.2(2)(a)，2.2.2(3)，付録A

サンプル帳票を使用してファイル出力した場合の出力ページ数とファイルサイズの説明を追加しました。

2.2.2(3)

EUR Serverでのデータファイル（CSV形式，FIX形式）のファイルサイズの制限を解除しました。これに伴い，レコード数，フィールド数の上限値を変更しました。

4.3.1，4.3.2

バーコードの出力時の注意事項に，データに関する注意事項を追加しました。

4.4.12(3)

EURで使用する入力ファイルに新規用紙出力定義ファイルを追加しました。

5.6.2(3)(b)，7.1，7.1.1(1)，7.2.1

クライアントPC，EUR Web Plug-In，帳票GUIの前提プログラムからInternet Explorer 8を除外しました。

8.3.1，付録C.10，付録C.11

帳票設計時の注意事項に，文字修飾の下線の説明を追加しました。

9.2.3(1)，付録A

WordまたはExcel文書をEUR帳票に変換する場合に必要な関連ソフトウェアに，次のプログラムを追加しました。

  • Microsoft(R) Office Word 2013

  • Microsoft(R) Office Excel 2013

付録C.2

Excel形式ファイルを閲覧・出力する場合に必要な関連ソフトウェアに，次のプログラムを追加しました。

  • Microsoft(R) Office Excel 2013

付録C.6
（凡例）

－：該当なし

単なる誤字・脱字などはお断りなく訂正しました。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 4 / 195


はじめに : EUR システム設計ガイド

  • 5 / 195

  • 表紙

  • はじめに

はじめに

このマニュアルは，次のEUR製品を使用した帳票システムの計画および設計をする方法について説明したものです。

  • EUR Designer

  • EUR Developer

  • EUR Viewer

  • EUR Server Standard

  • EUR Server Enterprise

  • EUR Server - Cipher option

なお，バージョン8以前と同様に，EUR Print Serviceだけを使用して帳票をバッチ出力する場合は，EUR ServerのV8互換機能を使用します。システム構成例や出力方法の詳細については，バージョン8対応のマニュアル「EUR サーバ帳票出力」を参照してください。

〈はじめにの構成〉

  • 対象読者

  • このマニュアルの文法で使用する記号

  • このマニュアルのGUIの説明で使用する記号

■ 対象読者

このマニュアルは，EURを使用した帳票システムの計画・設計を担当する方を対象としています。なお，次の内容を理解されていることを前提としています。

  • 使用するOSに関する基本的な知識

  • 使用するプログラム言語に関する基本的な知識

  • ネットワークに関する基本的な知識

  • 文字コードに関する基本的な知識

  • プリンタに関する基本的な知識（帳票をプリンタに出力する場合）

ページの先頭へ

■ このマニュアルの文法で使用する記号

このマニュアルで使用する記号について，次に示します。

記　号

意　　味

｜

横に並べられた複数の項目に対する項目間の区切りを示し，「または」を意味します。

（例）A｜B

「A，またはBを指定する」ことを示します。

｛　｝

この記号で囲まれている複数の項目のうちから一つを選択することを示します。項目が横に並べられ，記号｜で区切られている場合は，そのうちの一つを選択します。

（例）｛A｜B｜C｝

「A，B，またはCのどれかを指定する」ことを示します。

〔　〕

この記号で囲まれている項目は省略してもよいことを示します。複数の項目が横に並べて記述されている場合には，すべてを省略するか，記号｛　｝と同じくどれか一つを選択します。

（例）〔A〕

「何も指定しない」か「Aと指定する」ことを示します。

（例）〔B｜C〕

「何も指定しない」か「B，またはCのどちらかを指定する」ことを示します。

…

記述が省略されていることを示します。この記号の直前に示された項目を繰り返し複数個指定できます。

（例）〔A〔,…〕〕

「Aのあとに，Aを複数個指定できる」ことを示します。

＿

括弧で囲まれた複数項目のうち1項目に対し使用され，括弧内のすべてを省略したときシステムが採る標準値を示します。

（例）〔A｜B｜C〕

「A，B，Cのどれも指定しなかった場合，システムはCが指定されたときと同じ処理をする」ことを示します。

ページの先頭へ

■ このマニュアルのGUIの説明で使用する記号

このマニュアルでは，次に示す記号を使用してGUIを説明しています。

記　号

意　　味

＜　＞

文字キーを表します。

＜　＞＋＜　＞

＋の前のキーを押したまま，後ろのキーを押すことを表します。

［　］

メニュー項目，ダイアログ名，ダイアログのボタンを表します。

［　］－［　］

メニュー項目を連続して選択することを表します。

（例）［ファイル］－［開く］

［ファイル］メニューから［開く］メニューを選択することを表します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 5 / 195


1. 帳票出力業務の検討 : EUR システム設計ガイド

  • 6 / 195

  • 表紙

  • 1.　帳票出力業務の検討

1.　帳票出力業務の検討

この章では，帳票の出力業務から，システム構成，データの流れ，使用環境，実行ユーザ，および認証方式について検討します。この章での検討内容を基に，システムの論理構成や物理構成を決定してください。

〈この章の構成〉

  • 1.1　帳票出力のデータの流れを検討する

  • 1.2　どんな言語環境で利用するか検討する

  • 1.3　帳票出力業務の実行ユーザを検討する

  • 1.4　ユーザの認証方式を検討する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 6 / 195


1.1 帳票出力のデータの流れを検討する : EUR システム設計ガイド

  • 7 / 195

  • 表紙

  • 1.　帳票出力業務の検討

  • 1.1　帳票出力のデータの流れを検討する

1.1　帳票出力のデータの流れを検討する

帳票システムを設計するときには，開発環境，サーバ，クライアントPCのデータの流れを検討する必要があります。代表的なシステム構成とデータの流れを次に説明します。

この例では帳票ファイルやCSV形式ファイルを入力ファイルとして説明していますが，これ以外にもさまざまな入力ファイルを使用して帳票を出力します。EURで使用する入力ファイルの種類と格納先のサーバについては，「7.1　EURで使用する入力ファイル」を参照してください。

〈この節の構成〉

  • 1.1.1　センターサーバで帳票を印刷する

  • 1.1.2　バッチ処理で拠点のクライアントPCに帳票を送って印刷する

  • 1.1.3　Webブラウザに帳票を埋め込んで印刷する

  • 1.1.4　帳票を再印刷する

  • 1.1.5　帳票を配送印刷する

  • 1.1.6　帳票をクライアントPCで印刷する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 7 / 195


1.1.1 センターサーバで帳票を印刷する : EUR システム設計ガイド

  • 8 / 195

  • 表紙

  • 1.　帳票出力業務の検討

  • 1.1　帳票出力のデータの流れを検討する

  • 1.1.1　センターサーバで帳票を印刷する

1.1.1　センターサーバで帳票を印刷する

EURでは，センターサーバで帳票を印刷できます。センターサーバで帳票を印刷するには，次の製品が必要です。

  • EUR Designer

  • EUR Server製品（EUR Server EnterpriseまたはEUR Server Standard）

システム構成例を次に示します。

図1‒1　システム構成例（センターサーバで帳票を印刷する）

[図データ]

センターサーバで帳票を印刷するときのデータの流れは，次のようになります。

図1‒2　センターサーバで帳票を印刷するときのデータの流れ

[図データ]

  1. EUR DesignerのEUR 帳票作成機能で帳票ファイルを作成し，あらかじめセンターサーバに転送しておきます。

  2. 業務アプリケーションから，EUR Server - Adapterを起動します。また，データをCSV形式ファイルに格納し，入力します。

  3. EUR Server - AdapterからEUR Server Serviceに入力データを転送します。

  4. EUR Server ServiceはEUR Print Serviceを呼び出し，転送されたデータと帳票ファイルを入力します。

  5. センターサーバに接続されたプリンタで帳票が印刷されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 8 / 195


1.1.2 バッチ処理で拠点のクライアントPCに帳票を送って印刷する : EUR システム設計ガイド

  • 9 / 195

  • 表紙

  • 1.　帳票出力業務の検討

  • 1.1　帳票出力のデータの流れを検討する

  • 1.1.2　バッチ処理で拠点のクライアントPCに帳票を送って印刷する

1.1.2　バッチ処理で拠点のクライアントPCに帳票を送って印刷する

EURでは，バッチ処理で拠点のクライアントPCに帳票を送って印刷できます。このとき，クライアントPCでは帳票が自動で印刷されます。

バッチ処理で拠点のクライアントPCに帳票を送って印刷するには，次の製品が必要です。

  • EUR Designer

  • EUR Server製品（EUR Server Enterprise，EUR Server Standard）のうちのどちらか一つ

システム構成例を次に示します。

図1‒3　システム構成例（バッチ処理で拠点のクライアントPCに帳票を送って印刷する）

[図データ]

アプリケーションサーバのEUR Server - Adapter，およびクライアントPCのEUR Client Serviceは，コンポーネントを再配布して使用します。

バッチ処理で拠点のクライアントPCに帳票を送って印刷するときのデータの流れは，次のようになります。

図1‒4　バッチ処理で拠点のクライアントPCに帳票を送って印刷するときのデータの流れ

[図データ]

  1. EUR DesignerのEUR 帳票作成機能で帳票ファイルを作成し，あらかじめ帳票サーバに転送しておきます。

  2. 業務アプリケーションから，バッチ処理でEUR Server - Adapterを起動します。また，データをCSV形式ファイルに格納し，入力します。

  3. EUR Server - Adapterから帳票サーバのEUR Server Serviceに入力データを転送します。

  4. EUR Server ServiceはEUR Print Serviceを呼び出し，転送されたデータと帳票ファイルを入力します。

  5. EUR Print ServiceがEPF形式ファイルを出力します。

  6. 出力されたEPF形式ファイルは拠点のクライアントPCに転送されます。

  7. 拠点のクライアントPCに接続されたプリンタで帳票が印刷されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 9 / 195


1.1.3 Webブラウザに帳票を埋め込んで印刷する : EUR システム設計ガイド

  • 10 / 195

  • 表紙

  • 1.　帳票出力業務の検討

  • 1.1　帳票出力のデータの流れを検討する

  • 1.1.3　Webブラウザに帳票を埋め込んで印刷する

1.1.3　Webブラウザに帳票を埋め込んで印刷する

EURでは，Webブラウザに帳票を埋め込んで印刷できます。クライアントPC上で帳票のプレビュー，印刷および保存ができます。

Webブラウザに帳票を埋め込んで印刷するには，次の製品が必要です。

  • EUR Designer

  • EUR Server製品（EUR Server Enterprise，EUR Server Standard）のうちのどちらか一つ

システム構成例を次に示します。

図1‒5　システム構成例（Webブラウザに帳票を埋め込んで印刷する）

[図データ]

アプリケーションサーバのEUR Server - Adapterは，コンポーネントを再配布して使用します。クライアントPCのEUR Web Plug-Inは，クライアントPCのWebブラウザに埋め込んで使用します。

Webブラウザに帳票を埋め込んで印刷するときのデータの流れは，次のようになります。

図1‒6　Webブラウザに帳票を埋め込んで印刷するときのデータの流れ

[図データ]

  1. EUR DesignerのEUR 帳票作成機能で帳票ファイルを作成し，あらかじめ帳票サーバに転送しておきます。

  2. クライアント実行環境のWebブラウザから，印刷リクエストを送信します。

  3. 業務アプリケーションから，EUR Server - Adapterを起動します。また，データをCSV形式ファイルに格納し，入力します。

  4. EUR Server - Adapterから帳票サーバのEUR Server Serviceに入力データを転送します。

  5. EUR Server ServiceはEUR Print Serviceを呼び出し，転送されたデータと帳票ファイルを入力します。

  6. EUR Print ServiceがEPF形式ファイルを出力します。

  7. 出力されたEPF形式ファイルはクライアントPCに転送されます。クライアントPCでは，Webブラウザに埋め込まれた状態で帳票が表示されます。

  8. クライアントPCに接続されたプリンタで帳票が印刷されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 10 / 195


1.1.4 帳票を再印刷する : EUR システム設計ガイド

  • 11 / 195

  • 表紙

  • 1.　帳票出力業務の検討

  • 1.1　帳票出力のデータの流れを検討する

  • 1.1.4　帳票を再印刷する

1.1.4　帳票を再印刷する

EURでは，スプールサーバにいったん帳票を蓄積し，リクエストがあったタイミングで再印刷できます。

帳票を再印刷するには，次の製品が必要です。

  • EUR Designer

  • EUR Server Enterprise

システム構成例を次に示します。

図1‒7　システム構成例（帳票を再印刷する）

[図データ]

次のコンポーネントは再配布したものを使用します。

  • Webサーバ，アプリケーションサーバのEUR Server - Adapter

  • スプールサーバのEUR Server - Spool ServiceおよびEUR Server - Spool Service Adapter

また，クライアントPCのEUR Web Plug-Inは，クライアントPCのWebブラウザに埋め込んで使用します。

帳票を再印刷するときのデータの流れについて，「帳票の蓄積」と「帳票のプレビューまたは印刷」に分けて，次に説明します。

〈この項の構成〉

  • (1)　帳票の蓄積

  • (2)　帳票のプレビューまたは印刷

(1)　帳票の蓄積

帳票を蓄積するときのデータの流れは，次のようになります。

図1‒8　帳票を蓄積するときのデータの流れ

[図データ]

  1. EUR DesignerのEUR 帳票作成機能で帳票ファイルを作成し，あらかじめ帳票サーバに転送しておきます。

  2. 業務アプリケーションから，EUR Server - Adapterを起動します。また，データをCSV形式ファイルに格納し，入力します。

  3. EUR Server - Adapterから帳票サーバのEUR Server Serviceに入力データを転送します。

  4. EUR Server ServiceはEUR Print Serviceを呼び出し，転送されたデータと帳票ファイルを入力します。

  5. EUR Print ServiceがEPF形式ファイルを出力します。

  6. 出力されたEPF形式ファイルは，EUR Server ServiceおよびEUR Server - Spool Serviceを経由してスプールサーバに蓄積されます。

ページの先頭へ

(2)　帳票のプレビューまたは印刷

蓄積した帳票をプレビューするときのデータの流れは，次のようになります。

図1‒9　蓄積した帳票をプレビューするときのデータの流れ

[図データ]

  1. クライアントPCのWebブラウザから，リクエストを送信します。

  2. Webアプリケーションから，EUR Server - Spool Service Adapterを起動します。

  3. EUR Server - Spool Service AdapterはEUR Server - Spool Serviceを経由して，蓄積された帳票の中から目的のスプールデータを取得します。

  4. 取得したスプールデータは，EUR Server - Spool ServiceおよびEUR Server - Spool Service Adapterを経由してクライアントPCに転送されます。

  5. クライアントPCのEUR Web Plug-Inでプレビューされます。

なお，蓄積した帳票を直接印刷するときも，データの流れは同じです。この場合，取得したスプールデータは，クライアントPCにインストールしたEUR Clientから印刷されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 11 / 195


1.1.5 帳票を配送印刷する : EUR システム設計ガイド

  • 12 / 195

  • 表紙

  • 1.　帳票出力業務の検討

  • 1.1　帳票出力のデータの流れを検討する

  • 1.1.5　帳票を配送印刷する

1.1.5　帳票を配送印刷する

クライアントPCから，蓄積した帳票の中に印刷できる帳票がないかどうかを自動的に問い合わせて（ポーリング）印刷できます。この印刷方法を配送印刷といいます。

帳票を配送印刷するには，次の製品が必要です。

  • EUR Designer

  • EUR Server Enterprise

システム構成例を次に示します。

図1‒10　システム構成例（帳票を配送印刷する）

[図データ]

スプールサーバには，EURの配送サービスを登録しておきます。

帳票を配送印刷するときのデータの流れは，次のようになります。なお，帳票を蓄積するまでのデータの流れは「1.1.4(1)　帳票の蓄積」と同じです。

  1. クライアントPCから，スプールサーバに対してポーリングを行います。ポーリングを行ったユーザが印刷できる帳票が蓄積されている場合，自動的に帳票が取得され，クライアントPCに転送されます。

  2. クライアントPCに接続されたプリンタで，転送された帳票を印刷します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 12 / 195


1.1.6 帳票をクライアントPCで印刷する : EUR システム設計ガイド

  • 13 / 195

  • 表紙

  • 1.　帳票出力業務の検討

  • 1.1　帳票出力のデータの流れを検討する

  • 1.1.6　帳票をクライアントPCで印刷する

1.1.6　帳票をクライアントPCで印刷する

EUR クライアント帳票出力機能を使って，クライアントPCだけで帳票を印刷できます。

EUR クライアント帳票出力機能を使って帳票を印刷するには，次の製品が必要です。

  • EUR Designer

  • EUR Viewer

システム構成例を次に示します。

図1‒11　システム構成例（帳票をクライアントPCで印刷する）

[図データ]

帳票をクライアントPCで印刷するときのデータの流れは，次のようになります。

図1‒12　帳票をクライアントPCで印刷するときのデータの流れ

[図データ]

  1. EUR DesignerのEUR 帳票作成機能で帳票ファイルを作成し，あらかじめクライアントPCに転送しておきます。

  2. 業務アプリケーションから，EUR ViewerのEUR クライアント帳票出力機能を起動します。CSV形式ファイルに格納したデータと帳票ファイルを入力します。

  3. 拠点のクライアントに接続されたプリンタで帳票を印刷します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 13 / 195


1.2 どんな言語環境で利用するか検討する : EUR システム設計ガイド

  • 14 / 195

  • 表紙

  • 1.　帳票出力業務の検討

  • 1.2　どんな言語環境で利用するか検討する

1.2　どんな言語環境で利用するか検討する

EURは，英語，中国語（簡体字および繁体字），および日本語の作業環境に対応しています。作業環境に応じた言語で，画面やメッセージを出力し，データを取り扱います。※1

また，Unicodeに対応した入力データを指定することで，作業環境と異なる言語の文字を帳票に出力することもできます。※2

言語環境（OSのロケール）が異なるサーバにEUR Server - AdapterやEUR Server - Spool Service Adapter経由でデータを転送するときには，EURが自動で文字コードをUnicodeに変換します。複数の言語環境でEURを使用する場合は，すべてのデータをUTF-16で作成すれば，環境ごとのエンコーディングを意識する必要はありません。なお，文字コードを変換しない場合，転送時の効率は上がります。

言語環境ごとにサポートする入力データの文字集合，および各コンポーネント間でファイル転送をする場合の文字コードの変換規則を次に説明します。

注※1

EUR DesignerおよびEUR Viewerの言語環境については，マニュアル「EUR 帳票出力 EUR Designer/EUR Viewer編」の「表示言語の切り替え」を参照してください。

EUR Server製品の言語環境には，次の制限があります。

  • 中国語環境の場合，EUR Print Service以外のコンポーネントは，英語で画面やメッセージを出力します。

  • 帳票管理GUIサービスは，日本語だけをサポートしています。

  • EUR Server - Cipher optionは，日本語だけをサポートしています。

注※2

結合文字列には対応していません。

使用する言語に結合文字列が含まれているかは，事前に確認してください。

使用する言語に結合文字列が含まれる場合でも，結合文字列に相当する合成済み文字が存在するときは，合成済み文字を使用して出力することができます。

〈この節の構成〉

  • 1.2.1　サポートする入力データの文字集合

  • 1.2.2　ファイル転送時の文字コード変換

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 14 / 195


1.2.1 サポートする入力データの文字集合 : EUR システム設計ガイド

  • 15 / 195

  • 表紙

  • 1.　帳票出力業務の検討

  • 1.2　どんな言語環境で利用するか検討する

  • 1.2.1　サポートする入力データの文字集合

1.2.1　サポートする入力データの文字集合

EURでは，Unicodeのすべての文字をサポートしています。※1

また，Unicode以外のマルチバイト文字は，言語（OSのロケール）ごとに，次の文字集合をサポートしています。

表1‒1 サポートする文字集合
言語（OSのロケール） | 文字集合
英語 | ISO8859-1 ISO8859-15※2 CP1252※3
中国語 | GB18030:2000
日本語 | JIS X 0213:2004※4
注※1

結合文字列には対応していません。

注※2

UNIX／Linux環境の場合に対応しています。

注※3

Windows環境の場合に対応しています。

注※4

出力形式によってサポート範囲が異なります。詳細については，「4.6　EURで出力できる文字」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 15 / 195


1.2.2 ファイル転送時の文字コード変換 : EUR システム設計ガイド

  • 16 / 195

  • 表紙

  • 1.　帳票出力業務の検討

  • 1.2　どんな言語環境で利用するか検討する

  • 1.2.2　ファイル転送時の文字コード変換

1.2.2　ファイル転送時の文字コード変換

EUR Server ServiceやEUR Server - Adapterなどの各コンポーネント間でファイル転送をする場合の，ファイルの文字コードの変換規則について説明します。

〈この項の構成〉

  • (1)　EUR Server - AdapterとEUR Server Service間

  • (2)　EUR Server ServiceとEUR Server - Spool Service間

  • (3)　注意事項

(1)　EUR Server - AdapterとEUR Server Service間

EUR Server - AdapterとEUR Server Service間でファイル転送を実施する場合の，ファイルの文字コードの変換規則を次の表に示します。

表1‒2 EUR Server - AdapterがWindows環境で動作する場合のファイルの文字コードの変換規則
EUR Server - Adapterの動作環境（コードページ） | 転送するファイルの文字コード | EUR Server Serviceの動作環境
 |  | Windows（コードページ） |  | UNIX／Linux（エンコーディング）
 |  | 932（日本語環境） | その他 | Shift-JIS | EUC | UTF-8 | 特定しない
932（日本語環境） | Shift-JIS | － | ○ | － | ○ | ○ | ○
 | UTF-8（BOMあり） | － | － | ○ | ○ | － | ○
 | UTF-16（BOMあり） | － | － | － | － | － | －
その他 | UTF-8（BOMあり） | － | － | ○ | ○ | － | ○
 | UTF-16（BOMあり） | － | － | － | － | － | －
 | 上記以外 | － | － | － | － | － | －
（凡例）

○：文字コードを「UTF-16（BOMあり）」に変換します。

－：文字コードを変換しません。

表1‒3 EUR Server - AdapterがUNIX／Linux環境で動作する場合のファイルの文字コードの変換規則
EUR Server - Adapterの動作環境（エンコーディング） | 転送するファイルの文字コード | EUR Server Serviceの動作環境
 |  | Windows（コードページ） |  | UNIX／Linux（エンコーディング）
 |  | 932（日本語環境） | その他 | Shift-JIS | EUC | UTF-8 | 特定しない
Shift-JIS | Shift-JIS | － | ○ | － | ○ | ○ | ○
 | UTF-16（BOMあり） | － | － | － | － | － | －
EUC | EUC | ○ | ○ | ○ | － | ○ | ○
 | UTF-16（BOMあり） | － | － | － | － | － | －
UTF-8 | UTF-8（BOMあり） | － | － | ○ | ○ | － | ○
 | UTF-8（BOMなし） | △ | △ | ○ | ○ | － | ○
 | UTF-16（BOMあり） | － | － | － | － | － | －
上記以外 | UTF-16（BOMあり） | － | － | － | － | － | －
 | 上記以外 | － | － | － | － | － | －
（凡例）

○：文字コードを「UTF-16（BOMあり）」に変換します。

△：BOMを付けて転送します。

－：文字コードを変換しません。

重要

EUR Server Serviceの実行環境とEUR Server - Adapterの実行環境とでエンコーディングが異なる場合で，マッピングデータファイルまたはユーザ定義データファイルの文字コードが「UTF-16」以外のときは，データファイルの区切り方法に「指定した区切り位置でデータを区切る」を指定して定義した帳票は使用しないでください。EUR Server - AdapterからEUR Server Serviceにファイルを転送するときに区切り位置の情報がずれてしまうため，帳票を正しく出力できなくなります。

EUR Server Serviceの実行環境とEUR Server - Adapterの実行環境とでエンコーディングが異なる場合は，次のどちらかの帳票を使用してください。

  • データファイルの区切り方法に「コンマやスペース等区切り文字でデータを区切る」を指定して定義した帳票

  • 文字コードが「UTF-16」のマッピングデータファイルまたはユーザ定義データファイルを使用して定義した帳票

ページの先頭へ

(2)　EUR Server ServiceとEUR Server - Spool Service間

EUR Server ServiceとEUR Server - Spool Service間でファイル転送を実施する場合の，ファイルの文字コードの変換規則を次の表に示します。

表1‒4 EUR Server ServiceがWindows環境で動作する場合のファイルの文字コードの変換規則
EUR Server Serviceの動作環境（コードページ） | 転送するファイルの文字コード | EUR Server - Spool Serviceの動作環境（コードページ）
 |  | 932（日本語環境） | その他
932（日本語環境） | Shift-JIS | － | ○
 | UTF-8（BOMあり） | － | －
 | UTF-16（BOMあり） | － | －
その他 | UTF-8（BOMあり） | － | －
 | UTF-16（BOMあり） | － | －
 | 上記以外 | － | －
（凡例）

○：文字コードを「UTF-16（BOMあり）」に変換します。

－：文字コードを変換しません。

表1‒5 EUR Server ServiceがUNIX／Linux環境で動作する場合のファイルの文字コードの変換規則
EUR Server Serviceの動作環境（エンコーディング） | 転送するファイルの文字コード | EUR Server - Spool Serviceの動作環境（コードページ）
 |  | 932（日本語環境） | その他
Shift-JIS | Shift-JIS | － | ○
 | UTF-16（BOMあり） | － | －
EUC | EUC | ○ | ○
 | UTF-16（BOMあり） | － | －
UTF-8 | UTF-8（BOMあり） | － | －
 | UTF-8（BOMなし） | △ | △
 | UTF-16（BOMあり） | － | －
上記以外 | UTF-16（BOMあり） | － | －
 | 上記以外 | － | －
（凡例）

○：文字コードを「UTF-16（BOMあり）」に変換します。

△：BOMを付けて転送します。

－：文字コードを変換しません。

ページの先頭へ

(3)　注意事項

文字コード変換時に適用される文字コードによって，変換後にファイルサイズが大きくなる場合があります。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 16 / 195


1.3 帳票出力業務の実行ユーザを検討する : EUR システム設計ガイド

  • 17 / 195

  • 表紙

  • 1.　帳票出力業務の検討

  • 1.3　帳票出力業務の実行ユーザを検討する

1.3　帳票出力業務の実行ユーザを検討する

帳票を出力するときの実行ユーザごとに，使用するファイルへのアクセス権を検討します。帳票を蓄積する場合は，スプールデータへのアクセス権も検討します。

ここでは，実行ユーザに設定できるアクセス権について説明します。

〈この節の構成〉

  • 1.3.1　実行ユーザとアクセス権

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 17 / 195


1.3.1 実行ユーザとアクセス権 : EUR システム設計ガイド

  • 18 / 195

  • 表紙

  • 1.　帳票出力業務の検討

  • 1.3　帳票出力業務の実行ユーザを検討する

  • 1.3.1　実行ユーザとアクセス権

1.3.1　実行ユーザとアクセス権

サーバおよびクライアントで動作するコンポーネントが使用するファイルの操作権限を実行ユーザに与えてください。入出力ファイルには適切なアクセス権を設定してください。入力ファイルには読み取りアクセス権，出力ファイルには書き込みアクセス権が必要です。

サーバおよびクライアントで動作するコンポーネントの実行ユーザについては，マニュアル「EUR システム構築ガイド」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 18 / 195


1.4 ユーザの認証方式を検討する : EUR システム設計ガイド

  • 19 / 195

  • 表紙

  • 1.　帳票出力業務の検討

  • 1.4　ユーザの認証方式を検討する

1.4　ユーザの認証方式を検討する

EURでは，「ユーザ定義を使用した認証方式」または「LDAPサーバと連携した認証方式」のどちらかの方式で，帳票管理GUI上でスプールデータを操作したり，配送印刷したりするときのセキュリティを管理できます。

どちらの認証方式を使用するかはEUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）のキーワードAUTHENTICATIONで指定します。詳細はマニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

それぞれの認証方式の設定方法について次に説明します。なお，LDAPサーバと連携した認証方式はWindows環境だけで使用できます。

〈この節の構成〉

  • 1.4.1　ユーザ定義を使用する

  • 1.4.2　LDAPサーバと連携する（Windows環境だけ）

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 19 / 195


1.4.1 ユーザ定義を使用する : EUR システム設計ガイド

  • 20 / 195

  • 表紙

  • 1.　帳票出力業務の検討

  • 1.4　ユーザの認証方式を検討する

  • 1.4.1　ユーザ定義を使用する

1.4.1　ユーザ定義を使用する

ユーザ定義には，スプールデータを操作するユーザごとに，アクセスできるスプールデータの条件を定義します。

ユーザ定義には，次の情報を定義します。

  • ユーザ認証情報

    ユーザ名と確認キーを定義します。

  • スプールデータに対するアクセス制限情報

    アクセス制限方式，およびアクセスを許可するスプールデータの属性情報を定義します。また，ユーザ名が一致するスプールデータのアクセス可否，およびアクセスを許可する分類名がジョブ検索キーに設定されていないスプールデータのアクセス可否も定義します。

ユーザ認証情報，およびスプールデータに対するアクセス制限情報は，スプールデータの属性情報を基に定義します。利用できる属性情報がない場合は，属性情報を新たに追加します。また，新規にスプールデータを作成する場合は，帳票の蓄積時に，スプールデータの管理方法に合わせて必要な属性情報（ジョブ検索キーの分類と値）を指定します。

スプールデータの属性情報を追加する方法，および蓄積方法の詳細については，マニュアル「EUR 帳票出力 機能解説 EUR Server編」を参照してください。

〈この項の構成〉

  • (1)　定義する情報とアクセス制限との関係

  • (2)　ユーザの定義方法

  • (3)　注意事項

(1)　定義する情報とアクセス制限との関係

スプールデータに指定したユーザ名と確認キーが，ユーザ定義の定義内容と一致すると，条件に一致するスプールデータにアクセスできます。

存在しないユーザ名を指定した場合，またはユーザ名と確認キーがユーザ定義の内容と一致しなかった場合は，デフォルトユーザとしてスプールデータにアクセスします。デフォルトユーザとは，アクセス制限の対象としないスプールデータにアクセスするための最低限の権限を持つユーザのことです。

例えば，ユーザ定義を次の表に示すように定義します。

表1‒6 ユーザ定義の定義例
ユーザ名※1 | アクセス制限方式 | アクセスを許可する属性情報※2 |  | ユーザ名が一致するスプールデータの場合 | アクセスを許可する分類名がジョブ検索キーに設定されていない場合
 |  | 分類名 | キー値
ユーザA | 分類 | 公開先 | 部内 社内 | ○ | ×
ユーザB | 分類 | 公開先 | 社内 | △ | ○
（凡例）

○：アクセスできるようにします。

△：ユーザ名が一致するかどうかに関係なく，指定したアクセス制限方式で，対象になるスプールデータにアクセスできるようにします。

×：アクセスできないようにします。

注※1

ユーザ名に使用する分類名は，「ユーザ名」と定義するものとします。

注※2

分類名はスプールデータのジョブ検索キーの分類に，キー値はジョブ検索キーの値に，それぞれ対応します。

このとき，スプールデータの属性情報とユーザがアクセスできるスプールデータとの関係は，次の表に示すようになります。

表1‒7 スプールデータの属性情報とアクセス可否
スプールデータの属性 |  |  |  |  | ユーザ別 アクセス可否
ファイル名 | ジョブ検索キー
 | 分類1 | 値1 | 分類2 | 値2 | ユーザA | ユーザB
ファイルA | ユーザ名 | ユーザA | － | － | ○ | ○
ファイルB | ユーザ名 | ユーザA | 公開先 | 部内 | ○ | ×
ファイルC | ユーザ名 | ユーザA | 公開先 | 社内 | ○ | ○
ファイルD | ユーザ名 | ユーザB | － | － | × | ○
ファイルE | ユーザ名 | ユーザB | 公開先 | 部内 | ○ | ×
ファイルF | ユーザ名 | ユーザB | 公開先 | 社内 | ○ | ○
ファイルG | － | － | － | － | × | ○
（凡例）

－：属性情報がありません。

○：アクセスできます。

×：アクセスできません。

「ユーザA」は，ユーザ名が一致するスプールデータ，および「公開先」の値が「部内」と「社内」のスプールデータにアクセスできます。そのため，「ファイルA」，「ファイルB」，「ファイルC」，「ファイルE」，「ファイルF」にアクセスできます。

「ユーザB」は，ユーザ名が一致するかどうかに関係なく，「公開先」の値が「社内」のスプールデータ，および「公開先」がジョブ検索キーに設定されていないスプールデータにアクセスできます。そのため，「ファイルA」，「ファイルC」，「ファイルD」，「ファイルF」，「ファイルG」にアクセスできます。

ページの先頭へ

(2)　ユーザの定義方法

ユーザ定義は最大100,000件登録できます。ユーザ定義の定義方法と定義する際に決めておく内容を説明します。

(a)　Windows環境の場合

Windows環境では，［EUR Spool Service 構成定義］ダイアログの［ユーザ定義］タブでユーザを定義します。

［ユーザ定義］タブでの設定手順の詳細は，マニュアル「EUR システム構築ガイド」を参照してください。

(b)　UNIX／Linux環境の場合

UNIX／Linux環境では，サンプルファイルを基にユーザ管理ファイルを作成し，ユーザを定義します。

(c)　ユーザを定義する際に決めておく情報

ユーザを登録するためには，次の情報を決定しておいてください。なお，4.～7.はスプールデータへのアクセスを制限する場合に必要です。

  1. ユーザ名に使用するジョブ検索キーの分類名

  2. ユーザ名

  3. ユーザの確認キー

  4. スプールデータのアクセス制限方式（表示するスプールデータ）

  5. ユーザ名が一致するスプールデータにアクセスするかどうか

  6. アクセスを許可するジョブ検索キーの分類名

  7. アクセスを許可するジョブ検索キーのキー値

ページの先頭へ

(3)　注意事項

ユーザ定義を定義する場合の注意事項について次に示します。

デフォルトユーザのユーザ名について

デフォルトユーザは，ユーザ名を持ちません。したがって，ユーザ名が一致するスプールデータにアクセスできるように定義した場合，デフォルトユーザは，ユーザ名のジョブ検索キーを持たないスプールデータにアクセスできます。

ジョブ検索キーの分類名と値の指定について

ユーザ名およびアクセス許可キーに使用するジョブ検索キーは，指定した分類名に対応する値を必ず指定してください。

分類名だけ指定して値に指定がないスプールデータを作成することもできますが，どのユーザ名ともユーザ名が一致しなくなるため，アクセス制御ができなくなります。アクセス許可キーの場合も同様に，どのアクセス許可キーともキー値が一致しなくなるため，アクセス制御ができなくなります。

起動部品を使用する場合のユーザについて

起動部品を使用する場合は，ユーザを指定できないため，デフォルトユーザとして動作します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 20 / 195


1.4.2 LDAPサーバと連携する（Windows環境だけ） : EUR システム設計ガイド

  • 21 / 195

  • 表紙

  • 1.　帳票出力業務の検討

  • 1.4　ユーザの認証方式を検討する

  • 1.4.2　LDAPサーバと連携する（Windows環境だけ）

1.4.2　LDAPサーバと連携する（Windows環境だけ）

LDAPサーバで定義されているログオンユーザおよびパスワードを使用して認証します。あらかじめ，LDAPサーバで適切なユーザを定義しておいてください。

このとき，EURではEUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）で認証方式を「LDAP認証」に設定します。

また，次の内容も設定します。

  • 接続するLDAPサーバ（最大5個）

  • LDAPサーバでユーザ検索ができる権限を持つユーザID

  • LDAPサーバでユーザ検索ができる権限を持つユーザのパスワード

  • LDAPサーバの検索ベースDN

  • ログオンユーザの属性名

  • LDAPサーバとの通信をTLS通信で行うかどうか

なお，EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）に指定したパスワードはLDAP接続情報暗号化ツールを使用して暗号化できます。LDAP接続情報暗号化ツールでの暗号化の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 21 / 195


2. システム構成，ネットワーク構成の検討 : EUR システム設計ガイド

  • 22 / 195

  • 表紙

  • 2.　システム構成，ネットワーク構成の検討

2.　システム構成，ネットワーク構成の検討

この章では，1章で決まった内容を基に，帳票システムのシステム構成およびネットワーク構成の詳細を検討します。この章での検討内容を基に，マシンの性能や接続方法を決定してください。

〈この章の構成〉

  • 2.1　システム構成およびネットワーク構成で検討する内容

  • 2.2　帳票の出力規模を検討する

  • 2.3　システムの負荷分散方法を検討する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 22 / 195


2.1 システム構成およびネットワーク構成で検討する内容 : EUR システム設計ガイド

  • 23 / 195

  • 表紙

  • 2.　システム構成，ネットワーク構成の検討

  • 2.1　システム構成およびネットワーク構成で検討する内容

2.1　システム構成およびネットワーク構成で検討する内容

この章では，システム構成およびネットワーク構成に関係する次の内容を検討します。

  • 帳票の出力規模を検討する（2.2参照）

    帳票の帳票システムのサイジング，ファイルサイズや出力ページ数の上限およびスプールデータを格納するフォルダのディスク量を検討します。

  • システムの負荷分散方法を検討する（2.3参照）

    システムの負荷分散と多重化について検討します。

また，同時に次の内容についても検討しておいてください。

  • ネットワークの接続形態

  • プリンタの台数と接続方法

  • 帳票を出力するクライアント数

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 23 / 195


2.2 帳票の出力規模を検討する : EUR システム設計ガイド

  • 24 / 195

  • 表紙

  • 2.　システム構成，ネットワーク構成の検討

  • 2.2　帳票の出力規模を検討する

2.2　帳票の出力規模を検討する

業務で使用する帳票の出力規模（マシンのCPUコア数，ファイルサイズおよびページ数）を検討します。

〈この節の構成〉

  • 2.2.1　サイジングの検討

  • 2.2.2　ファイルサイズ，ページ数の検討

  • 2.2.3　スプールデータを格納するフォルダのディスク量の検討

  • 2.2.4　スプールデータから取得する印刷データのサイズの検討

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 24 / 195


2.2.1 サイジングの検討 : EUR システム設計ガイド

  • 25 / 195

  • 表紙

  • 2.　システム構成，ネットワーク構成の検討

  • 2.2　帳票の出力規模を検討する

  • 2.2.1　サイジングの検討

2.2.1　サイジングの検討

業務で使用する帳票のページ数（ファイルサイズ）から，ピーク時に必要なCPUコア数を計算します。

〈この項の構成〉

  • (1)　計算する前の準備

  • (2)　計算方法

  • (3)　集中率の考え方

(1)　計算する前の準備

計算する前に，次の内容を決定しておいてください。

(a)　モデルとなる帳票の選定

計算時のモデルとなる帳票を選定します。業務上で重要な帳票や，特に利用される帳票を選定することをお勧めします。

なお，各項目に振られたアルファベットは，(2)の計算式で使用します。

(b)　基礎数値の決定

(a)で選定した帳票を測定して，次の基本数値を決定しておきます。

  • A：測定マシンのCPUクロック数（単位：GHz）

  • B：モデルとなる帳票のページ数

  • C：モデルとなる帳票のファイルサイズ（単位：KB）

  • D：1帳票当たりの処理時間（単位：ミリ秒）

(c)　前提条件の決定

(a)で選定した帳票や運用する環境に関する次の前提条件を決定しておきます。

  • E：実際の業務で使用するマシンのCPUクロック数（単位：GHz）

  • F：帳票のページ数※

  • G：帳票のファイルサイズ（単位：KB）※

  • H：1か月当たりのトランザクション数

注※

測定マシンと実際の業務で使用するマシンで同じ帳票をモデルとして使用する場合は，(b)で説明したものと同じ値を使用します。

ページの先頭へ

(2)　計算方法

(1)で示した各項目の値を次のとおりとした場合の計算例とともに，計算方法を説明します。

  • A：2.8GHz

  • B：9,988ページ

  • C：22,000KB

  • D：33,000ミリ秒

  • E：2.26GHz

  • F：10,000ページ

  • G：22,000KB

  • H：4,500件

なお，数式の「↑（式）↑」は値の切り上げを示します。

  1. 1日当たりの平均トランザクション数を算出します。

    計算式：

    ↑（H÷営業日数）↑

    例：

    ↑（4,500÷20）↑=225

  2. 1日当たりの最大トランザクション数を算出します。

    計算式：

    ↑（H×処理が集中する日の集中率）↑

    集中率は，1か月当たりの処理のうち何パーセントが1日に集中するかを見積もった値です。

    例：

    ↑（4,500×0.1）↑=450

  3. 1時間当たりの最大トランザクション数を算出します。

    計算式：

    ↑（1日当たりの最大トランザクション数×処理が集中する時間の集中率）↑

    集中率は，処理が集中する日の処理のうち何パーセントが1時間に集中するかを見積もった値です。

    例：

    ↑（450×0.35）↑=158

  4. 本番環境の1帳票当たりの処理時間（単位：ミリ秒）を算出します。

    計算式：

    ↑（D×（（G÷E）÷（C÷A）））↑

    例：

    ↑（33,000×（（22,000÷2.26）÷（22,000÷2.8）））↑=40,885

  5. 1CPUコア当たりの，1時間に処理できるリクエスト数を算出します。

    計算式：

    ↑（（1,000×60×60）÷本番環境の1帳票当たりの処理時間）↑

    例：

    ↑（（1,000×60×60）÷40,885）↑=88

  6. 1CPUコア当たりの，1日に処理できるリクエスト数を算出します。

    計算式：

    ↑（5.で算出した値×1日当たりの稼働時間）↑

    例（1日当たりの稼働時間を8時間とした場合）：

    ↑（88×8）↑=704

  7. 処理が集中する日で必要なCPUコア数を算出します。

    計算式：

    ↑（2.で算出した値÷6.で算出した値）↑

    例：

    ↑450÷704↑=1

  8. 処理が集中する時間帯で必要なCPUコア数を算出します。

    計算式：

    ↑（3.で算出した値÷5.で算出した値）↑

    例：

    ↑158÷88↑=2

計算結果を基に，必要なコア数の条件を満たす性能のマシンを選択してください。

ページの先頭へ

(3)　集中率の考え方

業務によっては，特定の日または特定の時間に処理が集中することがあります。

この「特定の日」または「特定の時間」のリクエストを処理するためにはどの程度のCPUが必要なのかを，集中率を設定することで計算しています。

例えば，業務の内容が月次処理であれば締め日に集中しますし，日々の締め処理であれば特定の時間帯に集中します。このように，業務のピークを考えて集中率を算出してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 25 / 195


2.2.2 ファイルサイズ，ページ数の検討 : EUR システム設計ガイド

  • 26 / 195

  • 表紙

  • 2.　システム構成，ネットワーク構成の検討

  • 2.2　帳票の出力規模を検討する

  • 2.2.2　ファイルサイズ，ページ数の検討

2.2.2　ファイルサイズ，ページ数の検討

出力する帳票のファイルサイズ，およびページ数を検討します。次に説明する上限値を超えていないかどうか確認してください。

なお，ページ数の多い帳票を出力する場合，一度に出力するページ数によっては出力速度に影響が出ることがあります。実際に出力する帳票データを使用してテストし，性能を確認してください。

〈この項の構成〉

  • (1)　ファイルサイズの上限

  • (2)　出力ページ数の上限

  • (3)　サンプル帳票を使用してファイル出力した場合の出力ページ数とファイルサイズ

(1)　ファイルサイズの上限

  • EPF形式ファイルを作成する際に一時ファイルを作成しますが，一時ファイルのサイズが2GB以上となる場合はエラーとなり，EPF形式ファイルを作成できません。一時ファイルサイズは，解像度（DPI値）や画像データの圧縮有無といったEPF形式ファイル出力時の設定を変更することで小さくできます。詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

  • PDF形式ファイルのサイズが2GB以上のファイルはエラーとなり，作成できません。

  • EUR形式ファイルを作成する際に一時ファイルを作成します。一時ファイルのサイズが4GB以上となる場合，エラーとなり，EUR形式ファイルは作成できません。

  • 帳票をLIPSIII対応プリンタへ出力する際に一時ファイルを作成します。一時ファイルのサイズが4GB以上となる場合，エラーとなり，印刷できません。

ページの先頭へ

(2)　出力ページ数の上限

使用する機能ごとの，出力ページ数の上限について次に説明します。

(a)　EUR サーバ帳票出力機能の場合

EUR サーバ帳票出力機能で出力できるページ数／シート数の上限を次の表に示します。

表2‒1 出力ページ数／シート数の上限値（EUR サーバ帳票出力機能）
出力先 | 出力ページ数／シート数の上限値
Windows対応プリンタ | 999,999ページ
PDF形式ファイル | 999,999ページ
EPF形式ファイル | 999,999ページ
EUR形式ファイル | 拡張子が*.eupの場合：32,767ページ 拡張子が*.euvの場合：65,534ページ
Excel形式ファイル | 100シート
LIPSIII，PostScript，およびESC/P対応プリンタ | 999,999ページ
PDLファイル | 999,999ページ

プリンタ出力，PDF形式ファイル出力およびEPF形式ファイル出力の場合，出力ページ数の上限値までしか出力しません。出力ページ数の上限値を超えた場合は，エラー（KEEU123-E）になります。

Excel形式ファイル出力の場合，出力シート数の上限値を超えると，上限値まで出力し，エラー（KEEU321-W）になります。また，ページ単位でシートを分けない設定の場合，縦繰り返しのExcelのシート上での行数の上限は1シートあたり10,000です。行数が10,000を超えるときは，10,000行までを出力し，メッセージ（KEEU322-W）を出力して終了します。ページ単位でシートを分けるかどうかの設定の詳細については，マニュアル「EUR 帳票出力 機能解説 EUR Server編」を参照してください。

なお，上限値に収まらないような大量のページ数をプリンタ，PDF形式ファイルおよびEPF形式ファイルに出力する場合は，次の方法で自動的に分割するように設定できます。分割後のページ数が上限値以下になれば問題ありません。

  • プリンタに出力する場合

    環境設定ファイル（EURPS_ENV）のEURPS_MAX_SPOOL_PAGESで，印刷ジョブを分割するページ数を指定できます。

  • PDF形式ファイルに出力する場合

    • PDF仕分け定義ファイルで，キーワードが含まれているマッピングデータファイルのフィールドごとにファイルを分割できます（仕分け出力）。

    • EUR Server - Adapterの起動部品で，分割ページ数を指定してファイルを分割できます（分割出力）。なお，分割ファイル数の上限は999,999ファイルです。上限を超えると，エラー（KEEU128-E）になります。また，分割したファイル全体のページ数の上限は2,147,483,646ページです。上限を超えると，エラー（KEEU123-E）になります。

  • EPF形式ファイルに出力する場合

    • 分割定義ファイルで，分割するページ数を指定できます（蓄積分割出力）。

    • 仕分け定義ファイルで，キーワードが含まれているマッピングデータファイルのフィールドごとにファイルを分割できます（蓄積仕分け出力）。

    なお，蓄積分割出力／蓄積仕分け出力を行う前の全体のページ数上限は2,147,483,646ページとなります。

プリンタ出力，PDF形式ファイル出力およびEPF形式ファイル出力で，各種定義ファイルの指定によって挿入された空白ページが，ページ数上限のチェック対象に含まれるどうかは，出力形式と出力方法によって次にようになります。

  • プリンタ出力，PDF形式ファイル出力，PDF形式ファイルの仕分け出力，EPF形式ファイル出力の場合

    次に示す空白ページはページ数上限のチェック対象に含まれます。

    • 単一様式帳票または帳票セットを複数指定した帳票で，新規用紙出力定義ファイルを指定して挿入された空白ページ

    • 複数様式帳票で，複数様式情報定義ファイルにprintnewpaper=ONを指定，かつ，EUR Print Serviceの環境設定ファイル（EURPS_ENV）の環境変数EURPS_PRINTNEWPAPER_INCLUDE_OUTPUTPAGECOUNTキーに「YES」を指定して挿入された空白ページ

    次に示す空白ページはページ数上限のチェック対象に含まれません。

    • 複数様式帳票で，複数様式情報定義ファイルにprintnewpaper=ONを指定，かつ，EUR Print Serviceの環境設定ファイル（EURPS_ENV）の環境変数EURPS_PRINTNEWPAPER_INCLUDE_OUTPUTPAGECOUNTキーに「NO」を指定して挿入された空白ページ

  • PDF形式ファイルの分割出力，EPF形式ファイルの蓄積分割出力および蓄積仕分け出力の場合

    次に示す空白ページはページ数上限のチェック対象に含まれます。

    • 単一様式帳票または帳票セットを複数指定した帳票で，新規用紙出力定義ファイルを指定して挿入された空白ページ

    • 複数様式帳票で，複数様式情報定義ファイルにprintnewpaper=ONを指定して挿入された空白ページ

また，業務プログラムからEUR Server - Adapterの起動部品を使用して，印刷またはファイル出力を実行した帳票の総ページ数を出力することができます。詳細については，マニュアル「EUR 帳票出力 機能解説 EUR Server編」を参照してください。

(b)　EUR クライアント帳票出力機能の場合

EUR クライアント帳票出力機能で印刷できるページ数の上限を次に示します。

表2‒2 出力ページ数の上限値（EUR クライアント帳票出力機能）
操作する場所 | 印刷できるページ数の上限
メニュー | 65,534ページ
apgrptコマンド | 32,767ページ
OLEオートメーション | 9,999ページ

印刷できるページ数を超えると，エラーになり，印刷処理を中止します。印刷開始ページと印刷終了ページ，または部数の指定を見直して，印刷できるページ数以内になるように修正したあと，プログラムを再度実行してください。必要ならば，数回に分けて印刷してください。

なお，印刷できるページ数の上限は，メモリ容量やスプールファイルの空き容量に依存されます。スプールファイルとは，印刷を実行する時，ユーザのハードディスク，またはネットワークプリンタが接続されているコンピュータのハードディスクに生成される，一時的なファイルです。

(c)　EUR 帳票作成機能の場合

出力ページの上限は，ファイルの出力先やスプールのディスク，ディスクの容量やマシンのメモリ容量に依存します。

(d)　EUR Viewerでプレビューする場合

EUR Viewerでプレビューできるページ数の上限はありません。

ページの先頭へ

(3)　サンプル帳票を使用してファイル出力した場合の出力ページ数とファイルサイズ

EURで提供しているサンプル帳票（Report1.fmsとReport1.csv）を使用してファイル出力した場合の出力ページ数とファイルサイズを，次の表に示します。

帳票やデータの内容によって出力ファイルのサイズは異なりますが，大量データをEURに入力するシステムを構築する場合は，入力データ量の調整や分割出力機能で，出力ファイル（EPF形式ファイル，PDF形式ファイル）のサイズが2GBを超えないようにしてください。

表2‒3 サンプル帳票（Report1.fmsとReport1.csv）を使用してファイル出力した場合の出力ページ数とファイルサイズ
出力形式 | 出力ページ数とファイルサイズ
 | 100ページ | 1,000ページ | 10,000ページ | 100,000ページ
PDF形式ファイル | 216KB（221,207バイト） | 2.08KB（2,190,841バイト） | 20.9MB（21,940,879バイト） | 209MB（219,980,917バイト）
EPF形式ファイル | 5.65KB（5,787バイト） | 26.8KB（27,459バイト） | 237KB（243,610バイト） | 2.29MB（2,404,544バイト）
EUR形式ファイル | 6.51KB（6,668バイト） | 15.6KB（16,043バイト） | 106KB（109,438バイト） | 0.99MB（1,043,407バイト）
Excel形式ファイル | 615KB（630,676バイト） | － | － | －
（凡例）

－：該当する項目はありません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 26 / 195


2.2.3 スプールデータを格納するフォルダのディスク量の検討 : EUR システム設計ガイド

  • 27 / 195

  • 表紙

  • 2.　システム構成，ネットワーク構成の検討

  • 2.2　帳票の出力規模を検討する

  • 2.2.3　スプールデータを格納するフォルダのディスク量の検討

2.2.3　スプールデータを格納するフォルダのディスク量の検討

スプールデータはいったん保存されると，蓄積期限日数が経過するまで削除されません。スプールデータを格納するフォルダに必要なディスク容量は，蓄積する帳票のページ数，1日に蓄積されるスプールデータの数，蓄積の期限などによって変わります。スプールデータを蓄積する前に，蓄積に掛かるデータ量を算出して，スプールデータを格納するフォルダに十分なディスク容量を確保してください。

スプールデータのデフォルトの格納先は「インストール先フォルダ\Spool\ESF\」です。スプールデータを格納するのに十分なディスク容量が格納先で確保できない場合は，別のフォルダを指定してください。スプールデータの格納先は，EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）のESFキーで設定できます。

〈この項の構成〉

  • (1)　スプールデータを格納するフォルダに必要なディスク容量の算出方法

  • (2)　算出例

(1)　スプールデータを格納するフォルダに必要なディスク容量の算出方法

フォルダに必要なディスク容量は，次の計算式で求められます。

ディスク容量＝スプールデータのデータ量×スプールデータ数（単位：KB）

(a)　スプールデータのデータ量

スプールデータのデータ量は，次のように求めます。

スプールデータのデータ量＝a+b+3　（単位：KB）

a：スプールデータに格納するEPF形式ファイルのサイズ（単位：KB）

b：スプールデータを印刷したり，属性を変更したりした場合に保存される履歴データの総量（単位：KB）

履歴データの総量は，「1回分の履歴データ×保存できる履歴データのレコード数」で求められます。1回分の履歴データの平均値は0.4（KB）です。保存できる履歴データのレコード数は，100（個）です。例えば，1回分の履歴データのサイズが0.4（KB）の場合，bの値は0.4×100=40（KB）となります。

3：スプールデータで必要なヘッダ部分のバイト数（単位：KB）（固定）

(b)　スプールデータ数

フォルダ内に保存するスプールデータ数は，次のように求めます。

スプールデータ数＝c×d

c：1日に発生する帳票の蓄積数（個）

d：スプールデータの蓄積期限日数（日）

蓄積期限日数は，帳票を蓄積するときに設定できます。蓄積時に起動部品で指定しなかった場合は，EUR Server - Adapterの環境設定ファイル（EURPMADP.ini）のSPOOLLIMITキーの設定に従います。デフォルトは，30（日）です。

ページの先頭へ

(2)　算出例

スプールデータを格納するフォルダに必要なディスク容量の算出例を次に示します。

  • スプールデータのサイズ：8.6KB

  • 履歴データの総量：40KB（1回分の履歴データのサイズが0.4KBで，レコード数が100個）

  • 1日に発生する帳票の蓄積数：1,000個

  • 蓄積期限日：30日

    ディスク容量＝(8.6+40+3)×1,000×30＝1,548,000　（単位：KB）

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 27 / 195


2.2.4 スプールデータから取得する印刷データのサイズの検討 : EUR システム設計ガイド

  • 28 / 195

  • 表紙

  • 2.　システム構成，ネットワーク構成の検討

  • 2.2　帳票の出力規模を検討する

  • 2.2.4　スプールデータから取得する印刷データのサイズの検討

2.2.4　スプールデータから取得する印刷データのサイズの検討

スプールデータから帳票の印刷データを取得するときのデータサイズを検討します。

スプールデータから印刷データ（EPF形式ファイル）を取得するには，任意のフォルダにファイルを取得する方法（ファイル取得）と，サーバのメモリ上にデータとして取得する方法（メモリ取得）の2種類があります。また，印刷データをPDF形式ファイルで取得することもできます。

印刷データをファイル取得またはメモリ取得するときのデータサイズが，次に説明する上限を超えていないかどうかを確認してください。

スプールデータから帳票の印刷データを取得する方法の詳細については，マニュアル「EUR 帳票出力 機能解説 EUR Server編」を参照してください。

〈この項の構成〉

  • (1)　EPF形式で取得する場合のデータサイズの上限

  • (2)　PDF形式で取得する場合のデータサイズの上限

(1)　EPF形式で取得する場合のデータサイズの上限

  • ファイル取得

    400MBを超えるデータは取得できません。

  • メモリ取得

    200MBを超えるデータは取得できません。

ページの先頭へ

(2)　PDF形式で取得する場合のデータサイズの上限

  • ファイル取得

    2GB以上のデータは取得できません。

  • メモリ取得

    2GB以上のデータは取得できません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 28 / 195


2.3 システムの負荷分散方法を検討する : EUR システム設計ガイド

  • 29 / 195

  • 表紙

  • 2.　システム構成，ネットワーク構成の検討

  • 2.3　システムの負荷分散方法を検討する

2.3　システムの負荷分散方法を検討する

帳票サーバで複数のEUR Server Serviceを同時に起動したり，帳票サーバを複数台設定したりすることで，システムの負荷分散と多重化が図れます。

システムの負荷分散と多重化を実現するためのシステム構成とその構築方法について説明します。

〈この節の構成〉

  • 2.3.1　システム構成の概要

  • 2.3.2　ロードバランサを使用した構成

  • 2.3.3　IPアドレス指定で処理の振り分けを行う構成

  • 2.3.4　ポート番号指定で処理の振り分けを行う構成

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 29 / 195


2.3.1 システム構成の概要 : EUR システム設計ガイド

  • 30 / 195

  • 表紙

  • 2.　システム構成，ネットワーク構成の検討

  • 2.3　システムの負荷分散方法を検討する

  • 2.3.1　システム構成の概要

2.3.1　システム構成の概要

システムの負荷分散と多重化を実現するためのシステム構成は次のとおりです。また，それぞれの構成を組み合わせることもできます。

ロードバランサを使用して処理の自動振り分けを行う構成

複数台の帳票サーバを設定し，ロードバランサによって処理を並列で実行させて負荷分散する構成です。帳票サーバへの処理の振り分けはロードバランサが自動的に行います。そのため，帳票の種類や業務によって特定の帳票サーバに処理を振り分けたい場合には適していませんが，手軽に負荷分散できます。

なお，一方の帳票サーバで障害が発生した場合，ロードバランサの設定変更によって処理を切り替えることができ，EUR Server - Adapterの設定変更は必要ありません。

詳細については，「2.3.2　ロードバランサを使用した構成」を参照してください。

EUR Server - AdapterのIPアドレス指定で処理の振り分けを行う構成

複数台の帳票サーバを設定し，処理を並列で実行させて負荷分散する構成です。

EUR Server - Adapterで帳票サーバのIPアドレスを指定することで，帳票サーバへの処理の振り分けを行うため，帳票の種類や業務によって明示的に制御できます。

なお，一方の帳票サーバで障害が発生した場合，事前に業務アプリケーション側で設定しておくことによって，EUR Server - Adapterのプロパティを変更して処理を切り替えられます。

詳細については，「2.3.3　IPアドレス指定で処理の振り分けを行う構成」を参照してください。

EUR Server - Adapterのポート番号指定で処理の振り分けを行う構成

1台の帳票サーバでEUR Server Serviceを複数起動する構成です。帳票サーバを1台で構成するため，処理の並列実行による負荷分散はできません。

EUR Server - Adapterで帳票サーバのポート番号を指定することで，EUR Server Serviceへの処理の振り分けを行うため，帳票の種類や業務によって明示的に制御できます。

なお，一方のEUR Server Serviceで障害が発生した場合，事前に業務アプリケーション側で設定しておくことにより，EUR Server - Adapterのプロパティを変更して処理を切り替えられます。

詳細については，「2.3.4　ポート番号指定で処理の振り分けを行う構成」を参照してください。

それぞれの構成の特徴を次の表にまとめて示します。

表2‒4 システムの負荷分散と多重化の各構成の特徴
特徴 |  | ロードバランサを使用した構成 | IPアドレス指定で処理の振り分けを行う構成 | ポート番号指定で処理の振り分けを行う構成
システム構成 | 帳票サーバの台数 | 複数台設定できます。 | 複数台設定できます。 | 1台の設定です。
 | ロードバランサ | 必要です。 | 不要です。 | 不要です。
負荷分散 |  | ○ | ○ | ×
帳票サーバでの明示的な処理の振り分け |  | × | ○ | ○
障害時の切り替え |  | ○ | ○※ | ○※
（凡例）

○：できます。

×：できません。

注※

事前に業務アプリケーション側で設定し，障害時にはEUR Server - Adapterのプロパティを変更する必要があります。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 30 / 195


2.3.2 ロードバランサを使用した構成 : EUR システム設計ガイド

  • 31 / 195

  • 表紙

  • 2.　システム構成，ネットワーク構成の検討

  • 2.3　システムの負荷分散方法を検討する

  • 2.3.2　ロードバランサを使用した構成

2.3.2　ロードバランサを使用した構成

複数台の帳票サーバを設定し，ロードバランサによってシステムの負荷分散と多重化ができます。ロードバランサによって，処理は自動的にそれぞれのEUR Server Serviceに振り分けられて負荷分散されます。ロードバランサの負荷分散仕様については，使用するロードバランサのマニュアルを参照してください。

なお，Webサーバやアプリケーションサーバを複数構成にして，負荷分散の効果を高めることもできます。

ロードバランサを使用して，EUR Server Serviceで処理の自動振り分けを行う構成例を次に示します。

図2‒1　ロードバランサを使用した構成例

[図データ]

帳票サーバのIPアドレス設定

それぞれの帳票サーバに異なるIPアドレスを設定します。

この例では，帳票サーバ1にX.X.X.X，帳票サーバ2にX.X.X.Yと設定します。

ロードバランサの設定

ロードバランサには仮想IPアドレスを設定します。仮想IPアドレスに対して，帳票サーバのIPアドレスを対応付けます。

（設定例）

  • ロードバランサの仮想IPアドレス（X.X.X.Z）への対応付け1

    帳票サーバ1のIPアドレス（X.X.X.X）

  • ロードバランサの仮想IPアドレス（X.X.X.Z）への対応付け2

    帳票サーバ2のIPアドレス（X.X.X.Y）

ロードバランサの設定方法は，使用するロードバランサのマニュアルを参照してください。

EUR Server - Adapterの設定

EUR Server - Adapterの環境設定ファイル（EURPMADP.ini）の，IPADDRESSセクションのEURPMキーにロードバランサの仮想IPアドレスを指定します。EUR Server - Adapterの環境設定ファイルについての詳細は，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 31 / 195


2.3.3 IPアドレス指定で処理の振り分けを行う構成 : EUR システム設計ガイド

  • 32 / 195

  • 表紙

  • 2.　システム構成，ネットワーク構成の検討

  • 2.3　システムの負荷分散方法を検討する

  • 2.3.3　IPアドレス指定で処理の振り分けを行う構成

2.3.3　IPアドレス指定で処理の振り分けを行う構成

複数台の帳票サーバを設定し，処理を並列実行して負荷分散と多重化ができます。EUR Server - Adapterに設定されている帳票サーバのIPアドレスを指定してジョブを実行することで，処理は指定したEUR Server Serviceにジョブ単位で振り分けられて負荷分散されます。次のような振り分け例があります。

  • EUR Server Serviceを順番に振り分ける

  • 業務種別ごとに専用のEUR Server Serviceを振り分ける

  • 帳票種別ごとにEUR Server Serviceを振り分ける

なお，Webサーバやアプリケーションサーバを複数構成にして，負荷分散の効果を高めることもできます。

IPアドレスを指定して，EUR Server Serviceの処理を振り分ける構成例を次に示します。

図2‒2　IPアドレス指定で処理の振り分けを行う構成例

[図データ]

帳票サーバのIPアドレス設定

それぞれの帳票サーバに異なるIPアドレスを設定します。

この例では，帳票サーバ1にX.X.X.X，帳票サーバ2にX.X.X.Yと設定します。

EUR Server - Adapterの設定

EUR Server - Adapterの環境設定ファイル（EURPMADP.ini）の，IPADDRESSセクションのEURPMキーには，デフォルトに設定するEUR Server ServiceのIPアドレスを指定します。EUR Server - Adapterの環境設定ファイルについての詳細は，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

業務アプリケーションの設定

業務アプリケーションからEUR Server - Adapterを呼び出す処理の際に，帳票サーバのIPアドレスを指定するように設定します。IPアドレスの指定を省略した場合は，デフォルトのEUR Server Serviceに処理が振り分けられます。

メモ

帳票サーバのIPアドレスのプロパティの指定はアプリケーションサーバで設定します。詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 32 / 195


2.3.4 ポート番号指定で処理の振り分けを行う構成 : EUR システム設計ガイド

  • 33 / 195

  • 表紙

  • 2.　システム構成，ネットワーク構成の検討

  • 2.3　システムの負荷分散方法を検討する

  • 2.3.4　ポート番号指定で処理の振り分けを行う構成

2.3.4　ポート番号指定で処理の振り分けを行う構成

1台の帳票サーバ上に複数のEUR Server Serviceを起動し，EUR Server - Adapterに設定されている帳票サーバのポート番号を指定してジョブを実行することで，処理は指定したEUR Server Serviceにジョブ単位で振り分けられます。次のような振り分け例があります。

  • EUR Server Serviceを順番に振り分ける

  • 業務種別ごとに専用のEUR Server Serviceを振り分ける

  • 帳票種別ごとにEUR Server Serviceを振り分ける

なお，Webサーバやアプリケーションサーバを複数構成にすることもできます。複数の業務からの処理を別々のEUR Server Serviceに振り分けることで，業務ごとにリソースを管理できます。

ポート番号を指定して，EUR Server Serviceでの処理を振り分ける構成例を次に示します。

図2‒3　ポート番号指定で処理の振り分けを行う構成例

[図データ]

EUR Server Serviceのポート番号の設定

EUR Server Serviceを複数起動する場合，1台のサーバマシンで同じポート番号を使用できないため，EUR Server Serviceを追加するときには，EUR Server Serviceの環境設定ファイル（EURPM.ini）の，PORTセクションのEURPMキーに，EUR Server Serviceごとに異なるポート番号を指定します。EUR Server Serviceの環境設定ファイルについての詳細は，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

なお，EUR Server Serviceの追加は，起動管理定義ファイルで設定します。詳細については，マニュアル「EUR システム構築ガイド」を参照してください。

EUR Server Serviceの複数起動

Server Service制御コマンド（eurpmctrlコマンド），またはWindows環境の場合は［EUR Server Service 起動管理］ダイアログで，EUR Server Serviceを複数起動します。なお，EUR Server Serviceを自動で起動することもできます。

EUR Server Serviceの起動方法，およびEUR Server Serviceの自動起動についての詳細は，マニュアル「EUR システム構築ガイド」を参照してください。

EUR Server - Adapterの設定

EUR Server - Adapterの環境設定ファイル（EURPMADP.ini）の，PORTセクションのEURPMキーには，デフォルトに設定するEUR Server Serviceのポート番号を指定します。EUR Server - Adapterの環境設定ファイルについての詳細は，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

業務アプリケーションの設定

業務アプリケーションからEUR Server - Adapterを呼び出す処理の際に，帳票サーバのポート番号を指定するように設定します。ポート番号の指定を省略した場合は，デフォルトのEUR Server Serviceに処理が振り分けられます。

メモ

帳票サーバのポート番号のプロパティの指定はアプリケーションサーバで設定します。詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 33 / 195


3. 業務プログラムの検討 : EUR システム設計ガイド

  • 34 / 195

  • 表紙

  • 3.　業務プログラムの検討

3.　業務プログラムの検討

この章では，2章までに検討した業務やシステム構成を基に，開発する業務プログラムの配置や開発言語について検討します。

〈この章の構成〉

  • 3.1　業務プログラムの開発言語を検討する

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 34 / 195


3.1 業務プログラムの開発言語を検討する : EUR システム設計ガイド

  • 35 / 195

  • 表紙

  • 3.　業務プログラムの検討

  • 3.1　業務プログラムの開発言語を検討する

3.1　業務プログラムの開発言語を検討する

EURシリーズでは，次のインターフェースを提供しています。開発環境に合わせた言語を選択してください。

〈この節の構成〉

  • 3.1.1　クライアント環境での帳票の出力

  • 3.1.2　サーバ環境での帳票の出力

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 35 / 195


3.1.1 クライアント環境での帳票の出力 : EUR システム設計ガイド

  • 36 / 195

  • 表紙

  • 3.　業務プログラムの検討

  • 3.1　業務プログラムの開発言語を検討する

  • 3.1.1　クライアント環境での帳票の出力

3.1.1　クライアント環境での帳票の出力

EUR 帳票作成機能およびEUR クライアント帳票出力機能で提供されているインターフェースを次に示します。それぞれのインターフェースの設定方法については，マニュアル「EUR 帳票出力 EUR Designer/EUR Viewer編」を参照してください。

EUR クライアント帳票出力機能のV8互換機能を使用する場合は，バージョン8対応のマニュアル「EUR クライアント帳票出力」を参照してください。

〈この項の構成〉

  • (1)　OLEオートメーション

  • (2)　コマンド

(1)　OLEオートメーション

EUR 帳票作成機能，およびEUR クライアント帳票出力機能では，OLEオートメーションを開発するためのインターフェースを提供しています。OLEオートメーションは，Visual Basicで作成したアプリケーションで使用できます。

OLEオートメーションを使用すると，アプリケーションと同期を取って印刷できます。

ページの先頭へ

(2)　コマンド

EUR 帳票作成機能，およびEUR クライアント帳票出力機能では，コマンドからEURを起動して帳票を出力するためにapgrptコマンドを提供しています。apgrptコマンドは，Visual Basic，Visual C++，COBOLで作成したアプリケーションやMS-DOS(R)のバッチファイルなどから使用できます。

EUR 帳票作成機能，およびEUR クライアント帳票出力機能では，Webクライアント環境から帳票を出力するためのeurerコマンドを提供しています。詳細はマニュアル「EUR 帳票出力 EUR Designer/EUR Viewer編」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 36 / 195


3.1.2 サーバ環境での帳票の出力 : EUR システム設計ガイド

  • 37 / 195

  • 表紙

  • 3.　業務プログラムの検討

  • 3.1　業務プログラムの開発言語を検討する

  • 3.1.2　サーバ環境での帳票の出力

3.1.2　サーバ環境での帳票の出力

EUR サーバ帳票出力機能で提供されているインターフェースを次に示します。それぞれのインターフェースの設定方法については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

EUR Print Serviceのインターフェースについては，EUR ServerのV8互換機能として提供しています。詳細については，バージョン8対応のマニュアル「EUR サーバ帳票出力」を参照してください。なお，Windows Server 2008およびWindows Server 2012では，EUR Print ServiceのActiveX起動部品を使用した帳票出力はできません。

〈この項の構成〉

  • (1)　ActiveX

  • (2)　Java

  • (3)　COBOL

  • (4)　コマンド

  • (5)　ファイル監視サービス

(1)　ActiveX

次の2種類のActiveX起動部品を提供しています。

  • サーバアプリケーションからEUR Server Serviceを起動して帳票出力できるActiveX起動部品

  • サーバアプリケーションからEUR Server - Spool Serviceを起動して，蓄積したスプールデータを操作できるSS-ActiveX起動部品

ActiveX起動部品は，VBScript，Visual BasicおよびASP.Netで使用できます。

ActiveX起動部品を利用することで，Webサーバと印刷サーバを分散サーバ構成で構築できます。印刷結果は，EPF形式，PDF形式，およびExcel形式のどれかを選択できるので，利用形態に合わせた配信形式を選択できます。

ページの先頭へ

(2)　Java

次の2種類のJava起動部品を提供しています。

  • サーバ側で動作するJavaプログラムからEUR Server Serviceを起動して帳票出力できるJava起動部品

  • サーバ側で動作するJavaプログラムからEUR Server - Spool Serviceを起動して，蓄積したスプールデータを操作できるSS-Java起動部品

Webサーバ側のアプリケーション実行環境（Javaサーブレット，JSP，およびEJB）からJava起動部品を利用することで，サーバ側のアプリケーションを効率良く作成できます。

Java起動部品を利用することで，Webサーバと印刷サーバを分散サーバ構成で構築できます。印刷結果は，EPF形式，PDF形式，およびExcel形式のどれかを選択できますので，利用形態に合わせた配信形式を選択できます。

ページの先頭へ

(3)　COBOL

COBOL言語で記述されたプログラムからEUR Server Serviceを起動して帳票を出力できるCOBOL起動部品を提供しています。

ページの先頭へ

(4)　コマンド

次に示すコマンドを提供しています。

  • EUR Server Serviceの起動や停止を制御できるServer Service制御コマンド（eurpmctrlコマンド）

  • EUR Server Serviceを起動して，印刷や蓄積を制御できるコマンド起動部品（eurpmcコマンド）

  • EUR Server - Spool Serviceの起動や停止を制御できるSpool Service制御コマンド（eurpmlsctrlコマンド）

  • EUR Server - Spool Serviceを起動して，蓄積したスプールデータを操作できるSS-コマンド起動部品（eurpmlscコマンド）

  • クライアントPC上で帳票のプレビュー表示や印刷ができるeurpmcepfviewerコマンド

  • BSP-RMが管理するデータファイルをEURサーバ環境で帳票の印刷やファイル出力ができるBSP-RM連携コマンド（eursmprコマンド）

ページの先頭へ

(5)　ファイル監視サービス

帳票出力に使用するファイルを監視フォルダに格納すると，自動的に帳票の印刷やファイル出力ができるファイル監視サービスを提供しています。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 37 / 195


4. 帳票に出力するデータの検討 : EUR システム設計ガイド

  • 38 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

4.　帳票に出力するデータの検討

この章では，帳票に出力するデータの形式を検討します。また，データ設計の際に知っておくべき内容についても説明します。

〈この章の構成〉

  • 4.1　EURの帳票ファイル

  • 4.2　EURで使用できるデータベース

  • 4.3　EURで使用できるデータ形式

  • 4.4　EURで使用できるバーコード

  • 4.5　EURで使用できる画像ファイル

  • 4.6　EURで出力できる文字

  • 4.7　EURで使用できるフォント

  • 4.8　EURのPDF出力で使用できるフォント

  • 4.9　EURのEPF出力および帳票の蓄積で使用できるフォント

  • 4.10　EURで使用できる外字

  • 4.11　UnicodeのIVS対応

  • 4.12　UNIX／Linux環境のプリンタに出力するときの注意

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 38 / 195


4.1 EURの帳票ファイル : EUR システム設計ガイド

  • 39 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.1　EURの帳票ファイル

4.1　EURの帳票ファイル

EURで扱える帳票ファイルは，レポートファイル（*.agr）とフォームシートファイル（*.fms）です。

帳票ファイルの作成については，マニュアル「EUR 帳票作成 操作ガイド」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 39 / 195


4.2 EURで使用できるデータベース : EUR システム設計ガイド

  • 40 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.2　EURで使用できるデータベース

4.2　EURで使用できるデータベース

EURで使用できるデータベースは，次に示す3種類です。

  • HiRDB

  • Oracle

  • SQL Server

EURとデータベースを接続するには，あらかじめデータベース接続に必要な環境を設定しておく必要があります。詳細は，マニュアル「EUR データベース連携ガイド」を参照してください。

また，データベースごとに使用できるロケール，使用できる文字コード，扱えるデータ型，使用できる文字の注意事項についても，マニュアル「EUR データベース連携ガイド」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 40 / 195


4.3 EURで使用できるデータ形式 : EUR システム設計ガイド

  • 41 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.3　EURで使用できるデータ形式

4.3　EURで使用できるデータ形式

EURでは帳票を設計するときにデータファイルの内容をデータウィンドウに読み込みます。EURでマッピングデータおよびユーザ定義データとして扱えるデータ形式には，CSV形式（*.csv），DAT形式（*.dat），およびFIX形式（*.fix）があります。

データファイルの行をレコード，列をフィールドと呼びます。1レコードの終端は，改行コード※（0x0a，または0x0d＋0x0a）またはEOFです。1レコードは区切り文字または開始位置で区切ることができ，区切られたそれぞれをフィールドと呼びます。同じフィールドのデータは，すべて同じデータ型として扱われます。

注※

CSV形式およびDAT形式の場合，「"」で囲まれた文字列中の改行コードは終端ではなく文字として扱われます。改行コードを含む文字列を「"」で囲むことにより，改行コードを含むデータを作成することができます。

この節ではEURで扱えるデータ形式について例題を交えて説明します。なお，例題に使用する「△」は，空白（半角または全角）の1文字を示します。

また，帳票自動出力機能とBSP-RM連携機能では，制御情報付データファイルを使用します。制御情報付データファイルのデータ形式については，「4.3.3　制御情報付データファイルのデータ形式」を参照してください。

重要

  • データファイルのフィールドの区切り方法やフィールド定義などは，EUR 帳票作成機能で帳票を設計する時に指定してください。

  • データファイル中のタブコードは，半角空白一つと見なして読み込まれます。ただし，データファイルの1行目をフィールド名として扱う場合は，そのままタブコードとして読み込まれます。

  • EUR サーバ帳票出力機能では，DAT形式ファイルはCSV形式ファイルと同じと見なします。

〈この節の構成〉

  • 4.3.1　CSV形式（DAT形式）のデータ形式

  • 4.3.2　FIX形式のデータ形式

  • 4.3.3　制御情報付データファイルのデータ形式

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 41 / 195


4.3.1 CSV形式（DAT形式）のデータ形式 : EUR システム設計ガイド

  • 42 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.3　EURで使用できるデータ形式

  • 4.3.1　CSV形式（DAT形式）のデータ形式

4.3.1　CSV形式（DAT形式）のデータ形式

CSV形式（DAT形式）のデータファイルは，フィールドとフィールドの間を区切り記号で区切ったファイルです。区切り記号は，EUR 帳票作成機能で帳票設計する時に，データのプロパティで指定できます。区切り記号のデフォルトは「,（コンマ）」です。指定した区切り文字は，帳票ファイル中に保存されます。

CSV形式（DAT形式）のデータに共通の記述形式を次に示します。

  • データは，そのまま記述するか，または「"」で囲んで記述します。

    データをそのまま記述する場合は，前後の半角空白またはタブを除いたデータが入力データとなります。

    データを「"」で囲んで記述する場合は，「"」で囲まれた範囲内が入力データとなります。「"」で囲まれた範囲内のデータの前後に，半角空白またはタブを指定できます。また，「"」で囲まれた範囲の前後に，一つ以上の半角空白またはタブを指定できます（入力データにはなりません）。

  • 区切り文字をデータとして記述する場合は，「"」で囲みます。

  • 連続する二つの「"」は，一つの「"」に変換されたものが入力データとなります。

  • データ中に\0（Null：0x00）を含む場合は，先頭から\0までの範囲が入力データとなります。

CSV形式（DAT形式）のデータファイルのファイルサイズ，およびレコードの上限値を，次に示します。

表4‒1 CSV形式（DAT形式）データファイルの上限値
項目 | EUR Designer，EUR Viewerでの上限値 | EUR Serverでの上限値
ファイルサイズ | 2GBを上限とします。 | 上限はありません。
レコード数 | 上限はありません。 | 2,147,483,647を上限とします。
レコード長 | 上限はありません。 | 上限はありません。
フィールド数 | 上限はありません。 | 2,147,483,647を上限とします。
1フィールドの長さ | 99,999バイトを上限とします。 | 上限はありません。
フィールド名の長さ | マッピングデータのフィールド名：510桁を上限とします。 ユーザ定義データのフィールド名：499桁を上限とします。 | －
（凡例）

－：該当する項目はありません。

データの記述形式について，次に示します。

〈この項の構成〉

  • (1)　数値データ

  • (2)　文字データ

  • (3)　画像データ

  • (4)　日付データ

  • (5)　バーコードデータ

  • (6)　特殊編集レベルデータ

  • (7)　区切り文字

  • (8)　補足事項

(1)　数値データ

先頭に一つ以上の半角空白のある数値データの両端を「"」で囲んで記述した場合，先頭の半角空白を除いたデータが，入力データとなります。

（例）

「"△126"」と記述した場合は，「126」が入力データとなります。

「"△-126"」と記述した場合は，「-126」が入力データとなります。

なお，数値データを「"」で囲む場合，データの後ろに半角空白は指定できません。

EUR 帳票作成機能でデータを読み込んだあと

フィールド定義で種別を「数値」，または「数値（集計対象外）」に設定します。1桁以上のデータがある場合は，ゼロサプレス処理をします。

ページの先頭へ

(2)　文字データ

「"」を文字データとして使用する場合は，「"」を二つ続けて記述し，文字データの両端を「"」で囲んでください。

（例）

「E"UR」とする場合は，「"E""UR"」と指定します。

EUR 帳票作成機能でデータを読み込んだあと

フィールド定義で種別を「文字列」に設定します。

ページの先頭へ

(3)　画像データ

指定できる画像データは，次のとおりです。

  • Windows BITMAP形式の画像データ

  • JPEG形式の画像データ

  • GIF形式の画像データ

  • TIFF形式の画像データ

  • PNG形式の画像データ

EURで扱える画像データについては，マニュアル「EUR 帳票出力 リファレンス EUR Server編」またはマニュアル「EUR 帳票出力 EUR Designer/EUR Viewer編」を参照してください。

EUR 帳票作成機能でデータを読み込んだあと

フィールド定義で種別を「画像」に設定します。

補足説明

一つの帳票で複数の画像ファイルを使用する場合は，使用する画像ファイルを同じフォルダに保存しておいてください。

ページの先頭へ

(4)　日付データ

日付データは，西暦または和暦を数値で指定します。

日付データには，入力データの桁数と，指定したいデータ種別の桁数が一致するように入力データを指定してください。入力データの桁数とデータ種別の桁数が合っていないと，マッピングデータウィンドウに表示されないことがあります。

  • 西暦

    西暦を数値で記述します。指定できるデータの種別と桁数を次に示します。

    データ種別

    桁数

    指定例

    （「2004年5月23日12時10分05秒」の場合）

    日付（年次）

    4桁

    2004

    日付（月次）

    6桁

    200405

    日付（日次）

    8桁

    20040523

    日付（日付・時刻）※

    年：4桁

    月：2桁

    日：2桁

    時：2桁

    分：2桁

    秒：2桁

    2004/05/23 12:10:05

    注※

    • 日付は「/」で，時刻は「:」で区切り，日付と時刻の間は半角空白一つで区切ってください。

    • 日付は省略できませんが，時刻は省略できます。時刻を省略した場合は，00:00:00が仮定されます。

  • 和暦

    和暦を指定する場合，1桁目に元号を次の数値で指定します。

    元号

    指定値

    平成

    4

    昭和

    3

    大正

    2

    明治

    1

    指定できるデータ種別と桁数を次に示します。

    データ種別

    桁数

    指定例

    「平成21年1月1日」を表示させる場合

    「昭和64年1月1日」を表示させる場合

    和暦（年次）

    3桁

    421

    364

    和暦（月次）

    5桁

    42101

    36401

    和暦（日次）

    7桁

    4210101

    3640101

    和暦日付は，「平成元年1月1日」のような架空の日付も表示できます。また，［アイテムのプロパティ］ダイアログの［表示形式］（日付・時刻データ）タブで，日付の表示形式を次のように設定することもできます。

    • 「平成1年」を「平成元年」と表示できます。

    • 「平成21年」を「H21」と表示できます。

EUR 帳票作成機能でデータを読み込んだあと

指定したデータの桁数に合わせて，フィールド定義で種別を設定します。

補足説明

年号を表すデータは4桁で認識されます。そのため，［コントロールパネル］の［地域のオプション］の設定で，年号を2桁に設定している場合は，［日付］ページの［短い形式］のリストボックスから，年号を4桁で表示する形式「yyyy」に選択し直してください。［区切り記号］は，「/」を指定してください。また，Windowsの時刻表示を12時間制の形式に設定している場合は，［時刻］ページの［時間の形式］のリストボックスから，24時間制の形式に選択し直してください。この場合，午前，または午後を表す「t」の付く形式は設定しないでください。

ページの先頭へ

(5)　バーコードデータ

バーコードで使用するデータを指定します。表示するバーコードの種類によって，使用できるデータや桁数が異なります。バーコードのデータについては，「4.4　EURで使用できるバーコード」を参照してください。

EUR 帳票作成機能でデータを読み込んだあと

フィールド定義で種別を「バーコード」に設定します。

ページの先頭へ

(6)　特殊編集レベルデータ

繰り返し機能で，帳票に読み込んだデータをレコード単位で任意に編集したい場合は，特殊編集レベルを1～99の範囲で記述します。

  • 記述したレベルは，EUR 帳票作成機能のデータウィンドウで，レコード番号の横に「（レベル：nn）」と表示されます。

  • 複数レコードに同一レベルを指定した場合，一つのレコードを編集すると，同一レベルのレコードすべてが編集されます。

  • 編集しない場合は，特殊編集レベルの指定を省略するか，または「0」もしくは空白を指定してください。

EUR 帳票作成機能でデータを読み込んだあと

フィールド定義で種別を「特殊編集レベル」に設定します。

ページの先頭へ

(7)　区切り文字

データを区切る区切り文字は，EUR 帳票作成機能のデータのプロパティ，またはディクショナリファイルで指定します。

なお，「"」は，区切り文字には使用できません。ディクショナリファイルで区切り文字の指定を省略した場合，およびディクショナリファイルを指定しなかった場合は，区切り文字に「,」を使用します。

CSV形式のデータファイルに空データを指定する場合は，次のように指定します。次の例では，区切り文字として「,（コンマ）」を指定しています。

(a)　コンマを並べて指定した場合

コンマを並べて指定した場合，コンマの間が空データになります。

（例）

指定したデータ："あか","きいろ",,"あお"
入力されるデータ

一つ目のデータ：あか

二つ目のデータ：きいろ

三つ目のデータ：（空データ）

四つ目のデータ：あお

指定したデータ：,,,500
入力されるデータ

一つ目のデータ：（空データ）

二つ目のデータ：（空データ）

三つ目のデータ：（空データ）

四つ目のデータ：500

(b)　コンマの間に一つ以上の半角空白を指定した場合

コンマの間に一つ以上の半角空白を指定した場合，指定した半角空白の数に関係なくコンマの間が空データになります（△は半角空白を示します）。

（例）

指定したデータ："あか","きいろ",△△,"あお"
入力されるデータ

一つ目のデータ：あか

二つ目のデータ：きいろ

三つ目のデータ：（空データ）

四つ目のデータ：あお

指定したデータ：△△△,△△,△△△△,500
入力されるデータ

一つ目のデータ：（空データ）

二つ目のデータ：（空データ）

三つ目のデータ：（空データ）

四つ目のデータ：500

(c)　複数フィールドでn番目以降にコンマだけを並べて指定した場合

複数フィールドでn番目以降にコンマだけを並べて指定した場合，n番目以降のフィールドが空データになります。

（例）

指定したデータ："あか","きいろ",,,
入力されるデータ

一つ目のデータ：あか

二つ目のデータ：きいろ

三つ目のデータ：（空データ）

四つ目のデータ：（空データ）

このように，n番目以降にコンマだけを並べて指定する場合，帳票を定義するときに項目数を定義してあれば，コンマを省略することもできます。項目数を4とした場合，次のようになります。

（例）

指定したデータ："あか"
入力されるデータ

一つ目のデータ：あか

二つ目のデータ：（空データ）

三つ目のデータ：（空データ）

四つ目のデータ：（空データ）

指定したデータ：,500
入力されるデータ

一つ目のデータ：（空データ）

二つ目のデータ：500

三つ目のデータ：（空データ）

四つ目のデータ：（空データ）

(d)　1行すべてのフィールドを空データにする場合

1行すべてのフィールドを空データにする場合は，コンマだけを指定するか，または改行コードだけを指定します。

（例）

指定したデータ：,,,
入力されるデータ

一つ目のデータ：（空データ）

二つ目のデータ：（空データ）

三つ目のデータ：（空データ）

四つ目のデータ：（空データ）

指定したデータ：改行コード
入力されるデータ

一つ目のデータ：（空データ）

二つ目のデータ：（空データ）

三つ目のデータ：（空データ）

四つ目のデータ：（空データ）

ページの先頭へ

(8)　補足事項

  • EUR クライアント帳票出力機能を使用する場合，CSV形式（DAT形式）のデータは，ディクショナリファイル（UNIX版 EUR旧製品で設計された帳票の入力データの形式を定義しているファイル）を省略できます。その場合は，データファイルの1行目のデータ（1行目のデータをフィールド名として扱う場合は2行目のデータ）が「"」で囲まれている場合は文字列として，それ以外は数値データとしてフィールド定義情報が自動生成されます。

  • 「"」でデータを囲んで指定する場合，「"」が対になるように指定してください。「"」が対になっていない場合，出力結果が不正になることがあります。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 42 / 195


4.3.2 FIX形式のデータ形式 : EUR システム設計ガイド

  • 43 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.3　EURで使用できるデータ形式

  • 4.3.2　FIX形式のデータ形式

4.3.2　FIX形式のデータ形式

レコード中に区切り文字がなく，すべてのレコードの，フィールドの開始位置とデータ長が固定である形式を持つファイルです。フィールドの開始位置とデータ長は，EUR 帳票作成機能で帳票設計する時に，データのプロパティで指定できます。

\0（Null：0x00）は，改行コードと同様に1レコードの終端と見なされます。

データに記述できるFIX形式のファイルサイズ，およびレコードの上限値は，次のとおりです。

表4‒2 FIX形式のファイルサイズ，およびレコードの上限値
項目 | EUR Designer，EUR Viewerでの上限値 | EUR Serverでの上限値
ファイルサイズ | 2GBを上限とします。 | 上限はありません。
レコード数 | 上限はありません。 | 2,147,483,647を上限とします。
レコード長 | 改行コードを含めないで32,767バイトを上限とします。 | 改行コードを含めないで100,000バイトを上限とします。
フィールド数 | 上限はありません。ただし，レコード長と1フィールド長の上限値によって制限されます。 | 2,147,483,647を上限とします。
1フィールドの長さ | 32,767バイトを上限とします。 | 100,000バイトを上限とします。
フィールド名の長さ | マッピングデータのフィールド名：510桁を上限とします。 ユーザ定義データのフィールド名：499桁を上限とします。 | －
（凡例）

－：該当する項目はありません。

データの記述形式について，次に示します。

〈この項の構成〉

  • (1)　数値データ

  • (2)　文字データ

  • (3)　画像データ

  • (4)　日付データ

  • (5)　バーコードデータ

  • (6)　特殊編集レベルデータ

  • (7)　区切り文字

(1)　数値データ

数値をそのまま記述します。

EUR 帳票作成機能でデータを読み込んだあと

フィールド定義で種別を「数値」，または「数値（集計対象外）」に設定します。1桁以上のデータがある場合は，ゼロサプレス処理をします。

ページの先頭へ

(2)　文字データ

文字列をそのまま記述します。文字列中のタブは，空白に変換されます。

EUR 帳票作成機能でデータを読み込んだあと

フィールド定義で種別を「文字列」に設定します。

ページの先頭へ

(3)　画像データ

画像ファイル名（拡張子を含む）をそのまま記述します。指定できる画像データは，次のとおりです。

  • Windows BITMAP形式の画像データ

  • JPEG形式の画像データ

  • GIF形式の画像データ

  • TIFF形式の画像データ

  • PNG形式の画像データ

EURで扱える画像データについては，マニュアル「EUR 帳票出力 リファレンス EUR Server編」またはマニュアル「EUR 帳票出力 EUR Designer/EUR Viewer編」を参照してください。

EUR 帳票作成機能でデータを読み込んだあと

フィールド定義で種別を「画像」に設定します。

補足説明

一つの帳票で複数の画像ファイルを使用する場合は，使用する画像ファイルを同じフォルダに保存しておいてください。

ページの先頭へ

(4)　日付データ

日付データは，西暦または和暦を数値で指定します。

日付データには，入力データの桁数と，指定したいデータ種別の桁数が一致するように入力データを指定してください。入力データの桁数とデータ種別の桁数が合っていないと，マッピングデータウィンドウに表示されないことがあります。

  • 西暦

    西暦を数値で記述します。指定できるデータの種別と桁数を次に示します。

    データ種別

    桁数

    指定例

    （「2012年3月23日12時10分05秒」の場合）

    日付（年次）

    4桁

    2012

    日付（月次）

    6桁

    201203

    日付（日次）

    8桁

    20120323

    日付（日付・時刻）※

    年：4桁

    月：2桁

    日：2桁

    時：2桁

    分：2桁

    秒：2桁

    2012/03/23 12:10:05

    注※

    • 日付は「/」で，時刻は「:」で区切り，日付と時刻の間は半角空白一つで区切ってください。

    • 日付は省略できませんが，時刻は省略できます。時刻を省略した場合は，00:00:00が仮定されます。

  • 和暦

    和暦を指定する場合，1桁目に元号を次の数値で指定します。

    元号

    指定値

    平成

    4

    昭和

    3

    大正

    2

    明治

    1

    指定できるデータ種別と桁数を次に示します。

    データ種別

    桁数

    指定例

    「平成24年1月1日」を表示させる場合

    「昭和64年1月1日」を表示させる場合

    和暦（年次）

    3桁

    424

    364

    和暦（月次）

    5桁

    42401

    36401

    和暦（日次）

    7桁

    4240101

    3640101

    和暦日付は，「平成元年1月1日」のような架空の日付も表示できます。また，［アイテムのプロパティ］ダイアログの［表示形式］（日付・時刻データ）タブで，日付の表示形式を次のように設定することもできます。

    • 「平成1年」を「平成元年」と表示できます。

    • 「平成21年」を「H21」と表示できます。

    ［アイテムのプロパティ］ダイアログについては，マニュアル「EUR 帳票作成 画面リファレンス」を参照してください。

EUR 帳票作成機能でデータを読み込んだあと

指定したデータの桁数に合わせて，フィールド定義で種別を設定します。

補足説明

年号を表すデータは4桁で認識されます。そのため，［コントロールパネル］の［地域のオプション］の設定で，年号を2桁に設定している場合は，［日付］ページの［短い形式］のリストボックスから，年号を4桁で表示する形式「yyyy」に選択し直してください。［区切り記号］は，「/」を指定してください。また，Windowsの時刻表示を12時間制の形式に設定している場合は，［時刻］ページの［時間の形式］のリストボックスから，24時間制の形式に選択し直してください。この場合，午前，または午後を表す「t」の付く形式は設定しないでください。

ページの先頭へ

(5)　バーコードデータ

バーコードで使用するデータを指定します。表示するバーコードの種類によって，使用できるデータや桁数が異なります。バーコードのデータについては，「4.4　EURで使用できるバーコード」を参照してください。

データを読み込んだあと

フィールド定義で種別を「バーコード」に設定します。

ページの先頭へ

(6)　特殊編集レベルデータ

繰り返し機能で，帳票に読み込んだデータをレコード単位で任意に編集したい場合は，特殊編集レベルを1～99の範囲で記述します。

  • 記述したレベルは，データウィンドウのレコード番号の横に「（レベル：nn）」と表示されます。

  • 複数レコードに同一レベルを指定した場合，一つのレコードを編集すると，同一レベルのレコードすべてが編集されます。

  • 編集しない場合は，省略するか，または「0」もしくは空白を指定してください。

EUR 帳票作成機能でデータを読み込んだあと

フィールド定義で種別を「特殊編集レベル」に設定します。

ページの先頭へ

(7)　区切り文字

データの区切りは，データの開始位置で決まるため，区切り文字は使用しません。

なお，データ中に「,」などを記述すると，データとして扱われます。

FIX形式のデータファイルでは，空データを次のように指定します（△は半角空白を示します）。

(a)　あるフィールドのデータに，データ長分の半角空白を並べて指定した場合

あるフィールドのデータに，データ長分の半角空白を並べて指定した場合，そのフィールドは空データになります。データ長を4とした場合，次のようになります。

（例）

指定したデータ：あかしろ△△△△あお
入力されるデータ

一つ目のデータ：あか

二つ目のデータ：しろ

三つ目のデータ：（空データ）

四つ目のデータ：あお

指定したデータ：△△△△△△△△500△△△△△
入力されるデータ

一つ目のデータ：（空データ）

二つ目のデータ：（空データ）

三つ目のデータ：500

四つ目のデータ：（空データ）

(b)　n番目以降のデータに，データ長分の半角空白を並べて指定した場合

n番目以降のデータに，データ長分の半角空白を並べて指定した場合，n番目以降のフィールドがすべて空データになります。データ長を4とした場合，次のようになります。

（例）

指定したデータ：あかしろ△△△△△△△△
入力されるデータ

一つ目のデータ：あか

二つ目のデータ：しろ

三つ目のデータ：（空データ）

四つ目のデータ：（空データ）

このように，n番目以降のデータに，データ長分の半角空白を並べて指定する場合，半角空白は省略できます。

（例）

指定したデータ：500△1000
入力されるデータ

一つ目のデータ：500

二つ目のデータ：1000

三つ目のデータ：（空データ）

四つ目のデータ：（空データ）

(c)　1行すべてのフィールドを空データにする場合

1行すべてのフィールドを空データにする場合は，半角空白だけを指定するか，または改行コードだけを指定します。

（例）

データの指定：△△△△△△△△△△△△
入力されるデータ

一つ目のデータ：（空データ）

二つ目のデータ：（空データ）

三つ目のデータ：（空データ）

四つ目のデータ：（空データ）

指定したデータ：△△△△△△
入力されるデータ

一つ目のデータ：（空データ）

二つ目のデータ：（空データ）

三つ目のデータ：（空データ）

四つ目のデータ：（空データ）

指定したデータ：改行コード
入力されるデータ

一つ目のデータ：（空データ）

二つ目のデータ：（空データ）

三つ目のデータ：（空データ）

四つ目のデータ：（空データ）

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 43 / 195


4.3.3 制御情報付データファイルのデータ形式 : EUR システム設計ガイド

  • 44 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.3　EURで使用できるデータ形式

  • 4.3.3　制御情報付データファイルのデータ形式

4.3.3　制御情報付データファイルのデータ形式

制御情報付データファイルは，BSP-RM連携機能，および上位主導型で帳票自動出力機能を使用するときに準備するファイルです。マッピングデータに帳票の出力方法や出力先などの制御情報を付加したデータファイルです。ファイル形式はテキストファイルです。

制御情報付データファイルには，次に示す要素を必須で定義します。帳票ファイル名，ユーザ定義データファイル名，しおり定義ファイル名※，およびマッピングデータは複数指定できます。

  • eurpmcコマンドを実行するときのオプション※

  • 帳票ファイル名，ユーザ定義データファイル名，しおり定義ファイル名※

  • マッピングデータ

注※

上位主導型の帳票自動出力機能で使用する制御情報付データファイルに定義する要素です。BSP-RM連携機能で使用する制御情報付データファイルではサポートしていません。

マッピングデータの記述形式には，データファイルのCSV形式，DAT形式，およびFIX形式のデータの記述形式を使用できます。

CSV形式（DAT形式）のデータの記述形式については，「4.3.1　CSV形式（DAT形式）のデータ形式」を，FIX形式のデータの記述形式については，「4.3.2　FIX形式のデータ形式」を参照してください。

また，制御情報付データファイルのファイル形式の詳細については，マニュアル「EUR 帳票出力リファレンス EUR Server編」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 44 / 195


4.4 EURで使用できるバーコード : EUR システム設計ガイド

  • 45 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.4　EURで使用できるバーコード

4.4　EURで使用できるバーコード

EURで指定できるバーコードは，JIS X 0507（JAN標準※1，JAN短縮※2，UPC-A，UPC-E），X 0502（ITF），X 0503（CODE39），X 0504（CODE128），X 0506（コーダバー。ただし，EURでは「NW-7」と表記します），X 0510（QRコード），および郵便事業株式会社が定めるカスタマバーコードです。

成形されたバーコードそのものを貼り付けるのではなく，データウィンドウのデータ（バーコードにして表すデータをフィールドデータとして準備しておきます）を帳票ファイルにマッピングすることで，バーコードが貼り付けられます。バーコードで使用するデータは，バーコードの種類によって異なります。指定するデータの桁数が合っていないと，帳票ファイルに貼り付けた場合，バーコードが表示されないことがあります。

なお，バーコードの読み取りについては，使用するプリンタおよび読み取り装置で十分な評価をしてから使用してください。

それぞれのバーコードのサイズは，EUR 帳票作成機能の［アイテムのプロパティ］ダイアログの［バーコード］タブで設定します。バーコードアイテムのプロパティのデフォルト値は，［オプション］ダイアログの［バーコード］タブで設定します。ダイアログでの設定手順の詳細はマニュアル「EUR 帳票作成 操作ガイド」を，各ダイアログの指定内容の詳細は，マニュアル「EUR 帳票作成 画面リファレンス」を参照してください。

注1※

JIS X 0507で規定されているEAN-13に相当します。

注2※

JIS X 0507で規定されているEAN-8に相当します。

この節では，バーコードごとに次の内容を説明します。

  • データファイルでのデータの指定

  • サイズの指定

  • アイテム枠の幅の指定

  • プリンタの解像度によって出力できるバーコードの最小サイズ

なお，使用するバーコードの読み込み装置によっては，出力したバーコードが読み込めないこともあります。あらかじめ，出力したバーコードが読み取れるかどうかを確認してください。

〈この節の構成〉

  • 4.4.1　JAN標準バーコード

  • 4.4.2　JAN短縮バーコード

  • 4.4.3　ITFバーコード

  • 4.4.4　CODE39バーコード

  • 4.4.5　CODE128バーコード

  • 4.4.6　GS1-128（UCC/EAN-128）バーコード

  • 4.4.7　NW-7バーコード

  • 4.4.8　QRコード

  • 4.4.9　カスタマバーコード

  • 4.4.10　UPC-Aバーコード

  • 4.4.11　UPC-Eバーコード

  • 4.4.12　バーコードの出力時の注意事項

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 45 / 195


4.4.1 JAN標準バーコード : EUR システム設計ガイド

  • 46 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.4　EURで使用できるバーコード

  • 4.4.1　JAN標準バーコード

4.4.1　JAN標準バーコード

〈この項の構成〉

  • (1)　データの指定

  • (2)　サイズの指定

  • (3)　アイテム枠の幅の指定

  • (4)　プリンタの解像度によって出力できるバーコードの最小サイズ

(1)　データの指定

JAN標準バーコードを表示する場合は，半角数字（0～9）を使用して，13桁（固定）のデータ（データキャラクタ）をデータファイルに指定します。

JAN標準バーコードの形式を次に示します。

データ（データキャラクタ）は，商品コードを表すキャラクタで，プリフィックスキャラクタを含む場合もあります。プリフィックスキャラクタは，国コードなど商品コードの管理単位を識別するキャラクタです。

チェックキャラクタ（モジュラチェックキャラクタ）は，バーコードの読み取りの正確性を保つために，データ（データキャラクタ）とプリフィックスキャラクタから，ある計算方法に基づいて求めた値を表すキャラクタです。

業務アプリケーションでチェックキャラクタをあらかじめ付加する場合，例えば，「490123456789」のデータ（データキャラクタ）のチェックキャラクタ（モジュラチェックキャラクタ）は，次のような計算方法で求められます。

  1. 桁位置を付けます。求めるチェックキャラクタ（モジュラチェックキャラクタ）は，1桁目です。

    桁位置

    13

    12

    11

    10

    9

    8

    7

    6

    5

    4

    3

    2

    1

    データ

    4

    9

    0

    1

    2

    3

    4

    5

    6

    7

    8

    9

  2. 偶数桁の数字を加算します。

    9＋1＋3＋5＋7＋9＝34

  3. 2で求めた値を3倍します。

    34×3＝102

  4. 1桁目を除く，奇数桁の数字を加算します。

    4＋0＋2＋4＋6＋8＝24

  5. 3で求めた値と，4で求めた値を加算します。

    102＋24＝126

  6. 5で求めた値の下1桁の数字を10から減算します。

    10－6＝4

    この値が，チェックキャラクタ（モジュラチェックキャラクタ）です。

    なお，5で求めた値の下1桁の数字が「0」の場合は，チェックキャラクタ（モジュラチェックキャラクタ）は「0」です。

チェックキャラクタ（モジュラチェックキャラクタ）は，EUR 帳票作成機能で付加することもできます。その場合は，半角数字（0～9）を使用して，12桁（固定）のデータ（データキャラクタ）をデータファイルに指定します。チェックキャラクタ（モジュラチェックキャラクタ）は，［オプション］ダイアログ，または［アイテムのプロパティ］ダイアログで指定できます。

ページの先頭へ

(2)　サイズの指定

JAN標準バーコードで指定できるサイズと単位は0.15～2.1倍です。JIS X0507で規定されている0.8～2.0倍の範囲で指定することを推奨します。

JAN標準バーコードのサイズは，JIS X 0507で規定されている1モジュール幅に対する倍率を0.01倍単位で指定します。JIS X 0507では，1モジュール幅の標準サイズを0.33mmと規定しています。「モジュール」とは，白バーと黒バー，およびマージンを構成する基本単位を示します。

JAN標準バーコードは，113モジュールで構成されています。

(1)レフトマージン（9モジュール）

(2)レフトガードバー（3モジュール）

(3)左データキャラクタ（6キャラクタ，42モジュール）

(4)センタバー（5モジュール）

(5)右データキャラクタ（5キャラクタ，35モジュール）

(6)モジュラチェックキャラクタ（1キャラクタ，7モジュール）

(7)ライトガードバー（3モジュール）

(8)ライトマージン（9モジュール）

例えば，サイズに「2」を指定すると，「｛113（モジュール）×0.33（mm）｝×2（倍）」という式によって，幅74.58（mm）のJAN標準バーコードが帳票に出力できます。

ページの先頭へ

(3)　アイテム枠の幅の指定

帳票にJAN標準バーコードを収めるとき，アイテム枠の幅は，求めた値の小数点以下を切り上げた値で確保すると収まります。この場合は，アイテム枠の幅を75（mm）程度確保すると収まります。

表4‒3 JAN標準バーコードの実サイズ参考値
［サイズ］の値 | 帳票に出力されるバーコードの実サイズ
0.5 | 幅 約19（mm）
1 | 幅 約38（mm）
1.5 | 幅 約56（mm）

ページの先頭へ

(4)　プリンタの解像度によって出力できるバーコードの最小サイズ

出力するプリンタの解像度が300dpiの場合および600dpiの場合

最小サイズは0.8倍です。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 46 / 195


4.4.2 JAN短縮バーコード : EUR システム設計ガイド

  • 47 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.4　EURで使用できるバーコード

  • 4.4.2　JAN短縮バーコード

4.4.2　JAN短縮バーコード

JAN短縮バーコードのデータの指定方法およびプロパティの設定方法について説明します。

〈この項の構成〉

  • (1)　データの指定

  • (2)　サイズの指定

  • (3)　アイテム枠の幅の指定

  • (4)　プリンタの解像度によって出力できるバーコードの最小サイズ

(1)　データの指定

JAN短縮バーコードを表示する場合は，半角数字（0～9）を使用して，「0」以外で始まる8桁（固定）のデータ（データキャラクタ）をデータファイルに指定します。

なお，環境変数EURPS_UPC_BARCODEでUPCバーコードの出力を無効にした場合は，「0」で始まるデータも指定できます。

JAN短縮バーコードの形式を次に示します。

データ（データキャラクタ）は，商品コードを表すキャラクタで，プリフィックスキャラクタを含む場合もあります。プリフィックスキャラクタは，国コードなど商品コードの管理単位を識別するキャラクタです。

チェックキャラクタ（モジュラチェックキャラクタ）は，バーコードの読み取りの正確性を保つために，データ（データキャラクタ）とプリフィックスキャラクタから，ある計算方法に基づいて求めた値を表すキャラクタです。JAN短縮バーコードも，JAN標準バーコードと同じように，桁位置を決めて計算します。

業務アプリケーションでチェックキャラクタをあらかじめ付加する場合，例えば，「4901234」のデータ（データキャラクタ）のチェックキャラクタ（モジュラチェックキャラクタ）は，次のような計算方法で求められます。

  1. 桁位置を付けます。求めるチェックキャラクタ（モジュラチェックキャラクタ）は，1桁目です。

    桁位置

    8

    7

    6

    5

    4

    3

    2

    1

    データ

    4

    9

    0

    1

    2

    3

    4

  2. 偶数桁の数字を加算します。

    4＋0＋2＋4＝10

  3. 2で求めた値を3倍します。

    10×3＝30

  4. 1桁目を除く，奇数桁の数字を加算します。

    9＋1＋3＝13

  5. 3で求めた値と，4で求めた値を加算します。

    30＋13＝43

  6. 5で求めた値の下1桁の数字を10から減算します。

    10－3＝7

    この値が，チェックキャラクタ（モジュラチェックキャラクタ）です。

    なお，5で求めた値の下1桁の数字が「0」の場合は，チェックキャラクタ（モジュラチェックキャラクタ）は「0」です。

チェックキャラクタ（モジュラチェックキャラクタ）は，EUR 帳票作成機能で付加することもできます。その場合は，半角数字（0～9）を使用して，「0」以外で始まる7桁（固定）のデータ（データキャラクタ）をデータファイルに指定します。チェックキャラクタ（モジュラチェックキャラクタ）は，［オプション］ダイアログ，または［アイテムのプロパティ］ダイアログで指定できます。

なお，環境変数EURPS_UPC_BARCODEでUPCバーコードの出力を無効にした場合は，「0」で始まるデータも指定できます。

ページの先頭へ

(2)　サイズの指定

JAN短縮バーコードで指定できるサイズと単位は0.15～2.1倍です。JIS X0507で規定されている0.8～2.0倍の範囲で指定することを推奨します。

JAN短縮バーコードのサイズは，JIS X 0507で規定されている1モジュール幅に対する倍率を0.01倍単位で指定します。JIS X 0507では，1モジュール幅の標準サイズを0.33mmと規定しています。「モジュール」とは，白バーと黒バー，およびマージンを構成する基本単位を示します。

JAN短縮バーコードは，81モジュールで構成されています。

(1)レフトマージン（7モジュール）

(2)レフトガードバー（3モジュール）

(3)左データキャラクタ（4キャラクタ，28モジュール）

(4)センタバー（5モジュール）

(5)右データキャラクタ（3キャラクタ，21モジュール）

(6)モジュラチェックキャラクタ（1キャラクタ，7モジュール）

(7)ライトガードバー（3モジュール）

(8)ライトマージン（7モジュール）

例えば，サイズに「2」を指定すると，「｛81（モジュール）×0.33（mm）｝×2（倍）」という式によって，幅53.46（mm）のJAN短縮バーコードが帳票に出力できます。

表4‒4 JAN短縮バーコードのサイズ
［サイズ］の値 | 帳票に出力されるバーコードの実サイズ
0.5 | 幅 約14（mm）
1 | 幅 約27（mm）
1.5 | 幅 約41（mm）

ページの先頭へ

(3)　アイテム枠の幅の指定

帳票にJAN短縮バーコードを収めるとき，アイテム枠の幅は，求めた値の小数点以下を切り上げた値で確保すると収まります。サイズに「2」を指定した場合は，アイテム枠の幅を54（mm）程度確保すると収まります。

ページの先頭へ

(4)　プリンタの解像度によって出力できるバーコードの最小サイズ

出力するプリンタの解像度が300dpiの場合および600dpiの場合

最小サイズは0.8倍です。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 47 / 195


4.4.3 ITFバーコード : EUR システム設計ガイド

  • 48 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.4　EURで使用できるバーコード

  • 4.4.3　ITFバーコード

4.4.3　ITFバーコード

〈この項の構成〉

  • (1)　データの指定

  • (2)　サイズの指定

  • (3)　アイテム枠の幅の指定

  • (4)　プリンタの解像度によって出力できるバーコードの最小サイズ

(1)　データの指定

ITFバーコードは，指定したデータの情報によって，表示される形式（標準バージョン，拡張バージョン，およびアドオンバージョン）が異なります。

(a)　標準バージョン

標準バージョンで表示する場合は，半角数字（0～9）を使用して，次に示すどちらかの方法で，14桁（固定）の情報をデータファイルに指定します。

  • 物流識別キャラクタ（1桁固定）＋フラッグキャラクタ（2桁）＋データ（データキャラクタ）（10桁）＋チェックキャラクタ（モジュラチェックキャラクタ）（1桁）

  • 物流識別キャラクタ（1桁固定）＋フラッグキャラクタ（3桁）＋データ（データキャラクタ）（9桁）＋チェックキャラクタ（モジュラチェックキャラクタ）（1桁）

標準バージョンの形式を次に示します。

物流識別キャラクタは，物流商品コードのうち，個装，または内装商品の数や組み合わせなどの相違を識別するキャラクタです。

フラッグキャラクタは，物流商品コードのうち，国コードなどのフラッグコードを表し，商品コードの管理単位を識別するキャラクタです。フラッグキャラクタは，国によって，2桁の場合と3桁の場合があります。日本の場合は，EANインターナショナル協会（International Article Numbering Association EAN）から，「49」と「45」が付番されています。

チェックキャラクタ（モジュラチェックキャラクタ）は，物流識別キャラクタ，フラッグキャラクタ，およびデータ（データキャラクタ）から，「モジュラス10」という，モジュラチェックキャラクタを算出する計算方法を使用して求めてください。

なお，チェックキャラクタ（モジュラチェックキャラクタ）は，EUR 帳票作成機能で付加することもできます。その場合は，半角数字（0～9）を使用して，13桁（固定）の情報を，次に示すどちらかの方法でデータファイルに指定します。

  • 物流識別キャラクタ（1桁固定）＋フラッグキャラクタ（2桁）＋データ（データキャラクタ）（10桁）

  • 物流識別キャラクタ（1桁固定）＋フラッグキャラクタ（3桁）＋データ（データキャラクタ）（9桁）

チェックキャラクタ（モジュラチェックキャラクタ）は，［オプション］ダイアログ，または［アイテムのプロパティ］ダイアログで指定できます。

(b)　拡張バージョン

拡張バージョンで表示する場合は，半角数字（0～9）を使用して，次に示すどちらかの方法で，16桁（固定）の情報をデータファイルに指定します。

  • スペアキャラクタ「0」（1桁固定）＋物流識別キャラクタ（2桁固定）＋フラッグキャラクタ（2桁）＋データ（データキャラクタ）（10桁）＋チェックキャラクタ（モジュラチェックキャラクタ）（1桁）

  • スペアキャラクタ「0」（1桁固定）＋物流識別キャラクタ（2桁固定）＋フラッグキャラクタ（3桁）＋データ（データキャラクタ）（9桁）＋チェックキャラクタ（モジュラチェックキャラクタ）（1桁）

拡張バージョンの形式を次に示します。

スペアキャラクタは，コード体系を調整するためのキャラクタで，「0」固定です。

物流識別キャラクタは，物流商品コードのうち，個装，または内装商品の数や組み合わせなどの相違を識別するキャラクタです。

フラッグキャラクタは，物流商品コードのうち，国コードなどのフラッグコードを表し，商品コードの管理単位を識別するキャラクタです。フラッグキャラクタは，国によって，2桁の場合と3桁の場合があります。日本の場合は，EANインターナショナル協会（International Article Numbering Association EAN）から，「49」と「45」が付番されています。

チェックキャラクタ（モジュラチェックキャラクタ）は，物流識別キャラクタ，フラッグキャラクタ，およびデータ（データキャラクタ）から，「モジュラス10」という，モジュラチェックキャラクタを算出する計算方法を使用して求めてください。

なお，チェックキャラクタ（モジュラチェックキャラクタ）は，EUR 帳票作成機能で付加することもできます。その場合は，半角数字（0～9）を使用して，15桁（固定）の情報を，次に示すどちらかの方法でデータファイルに指定します。

  • スペアキャラクタ「0」（1桁固定）＋物流識別キャラクタ（2桁固定）＋フラッグキャラクタ（2桁）＋データ（データキャラクタ）（10桁）

  • スペアキャラクタ「0」（1桁固定）＋物流識別キャラクタ（2桁固定）＋フラッグキャラクタ（3桁）＋データ（データキャラクタ）（9桁）

チェックキャラクタ（モジュラチェックキャラクタ）は，［オプション］ダイアログ，または［アイテムのプロパティ］ダイアログで指定できます。

(c)　アドオンバージョン

アドオンバージョンで表示する場合は，半角数字（0～9）を使用して，データ（データキャラクタ）（5桁）＋チェックキャラクタ（モジュラチェックキャラクタ）の情報をデータファイルに指定します。

アドオンバージョンの形式を次に示します。

なお，チェックキャラクタ（モジュラチェックキャラクタ）は，EUR 帳票作成機能で付加することもできます。その場合は，半角数字（0～9）を使用して，データ（データキャラクタ）5桁（固定）の情報をデータファイルに指定します。

チェックキャラクタ（モジュラチェックキャラクタ）は，［オプション］ダイアログ，または［アイテムのプロパティ］ダイアログで指定できます。

ページの先頭へ

(2)　サイズの指定

指定できるサイズと単位は，0.1～1.3倍です。

JIS X 0502で規定されているエレメントのサイズに対する倍率を，0.01倍単位で指定します。JIS X 0502では，倍率「1」のとき，エレメントのサイズを，細エレメント幅を1.016mm，太エレメント幅を2.540mmに規定しています。「エレメント」とは，1本の白バー，または黒バーを示します。

(a)　標準バージョンの場合

標準バージョンの場合，データは14桁固定です。

(1)ベアラーバー（細エレメント幅1.016mmのとき，4.8mm）

「ベアラーバー」とは，バーコードの周辺を縦，横に取り囲むバーです。

(2)クワイエットゾーン（細エレメント×10）

「クワイエットゾーン」とは，バーコードの両端にある余白部分です。

(3)スタートコードバー（細エレメント×4）

(4)データ（1桁は，細エレメント×3と太エレメント×2）

(5)ストップコードバー（細エレメント×2と太エレメント×1）

(6)クワイエットゾーン（細エレメント×10）

(7)ベアラーバー

例えば，サイズに「1」を指定すると，次に示す式によって，幅 約152（mm）のITF標準バージョンのバーコードが帳票に出力できます。

ベアラーバー＝（4.8（mm）×1（倍））×2（個所）
クワイエットゾーン＝｛（1.016（mm）×1（倍））×10｝×2（個所）
スタートコードバー＝（1.016（mm）×1（倍））×4
ストップコードバー＝｛（1.016（mm）×1（倍））×2｝＋｛（2.540（mm）×1（倍））×1｝
データ＝｛（1.016（mm）×1（倍））×3＋（2.540（mm）×1（倍））×2｝×14（桁）
表4‒5 標準バージョンのサイズ
［サイズ］の値 | 帳票に出力されるバーコードの実サイズ
0.1 | 幅 約16（mm）
0.7 | 幅 約107（mm）
1.3 | 幅 約198（mm）

スタートコードバー／ストップコードバーは，2進法記号で表され，スタートコードバーは「0000」，ストップコードバーは「100」の固定です。

(b)　拡張バージョンの場合

拡張バージョンの場合は，データは16桁固定です。

表4‒6 拡張バージョンのサイズ
［サイズ］の値 | 帳票に出力されるバーコードの実サイズ
0.1 | 幅 約17（mm）
0.7 | 幅 約118（mm）
1.0 | 幅 約167（mm）
1.3 | 幅 約219（mm）

(c)　アドオンバージョンの場合

アドオンバージョンの場合は，データは6桁固定です。

表4‒7 アドオンバージョンのサイズ
［サイズ］の値 | 帳票に出力されるバーコードの実サイズ
0.1 | 幅 約9（mm）※
0.7 | 幅 約62（mm）
1.0 | 幅 約87（mm）
1.3 | 幅 約114（mm）
注※

計算すると，幅約9mmのITF・アドオンバージョンのバーコードを出力できますが，EURでは，アイテム枠の幅が13（mm）程度ないと出力されません。

ページの先頭へ

(3)　アイテム枠の幅の指定

帳票にITFバーコードを収める場合は，求めた値と同じアイテム枠の幅を確保することで収まります。

ページの先頭へ

(4)　プリンタの解像度によって出力できるバーコードの最小サイズ

出力するプリンタの解像度が300dpiの場合および600dpiの場合

最小サイズは0.25倍です。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 48 / 195


4.4.4 CODE39バーコード : EUR システム設計ガイド

  • 49 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.4　EURで使用できるバーコード

  • 4.4.4　CODE39バーコード

4.4.4　CODE39バーコード

〈この項の構成〉

  • (1)　データの指定

  • (2)　サイズの指定

  • (3)　アイテム枠の幅の指定

  • (4)　プリンタの解像度によって出力できるバーコードの最小サイズ

(1)　データの指定

CODE39バーコードを表示する場合は，半角数字（0～9），半角英大文字（A～Z），半角記号「- $ / + % .」，および半角空白を使用して，データ（データキャラクタ）をデータファイルに指定します。指定するデータ（データキャラクタ）の桁数は，任意です。

CODE39バーコードの形式を次に示します。

CODE39バーコードには，スタート／ストップキャラクタと，チェックキャラクタ（モジュラチェックキャラクタ）をEUR 帳票作成機能で付加できます。

スタート／ストップキャラクタを付加指定すると，データ（データキャラクタ）の前後に「*」（固定）が表示されます。

スタート／ストップキャラクタと，チェックキャラクタ（モジュラチェックキャラクタ）の付加指定は，［オプション］ダイアログ，または［アイテムのプロパティ］ダイアログで指定できます。

なお，CODE39バーコードでは，EUR サーバ帳票出力機能での帳票出力時にバーコードの線の太さを補正できます。補正値は，プリンタ定義ファイルまたは環境変数で指定します。詳細は，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

(2)　サイズの指定

CODE39で指定できるサイズと単位は，0.1～1.1mmです。

CODE39バーコードは，細エレメントの幅を0.01mm単位で指定します。「エレメント」とは，1本の白バー，または黒バーを示します。また，「細エレメント」は幅が細いバー，「太エレメント」は幅が太いバーを示します。

(1)クワイエットゾーン（スタート／ストップキャラクタの幅＋α）

「クワイエットゾーン」とは，バーコードの両端にある余白部分です。

(2)スタートキャラクタ（細エレメント×6と太エレメント×3）

(3)データ（1データキャラクタは，細エレメント×6と太エレメント×3）

(4)チェックキャラクタ（細エレメント×6と太エレメント×3）

(5)ストップキャラクタ（細エレメント×6と太エレメント×3）

(6)クワイエットゾーン

(7)キャラクタ間ギャップ（1ギャップは，細エレメントの2倍）

例えば，13桁のデータ（データキャラクタ）を表示するとき，サイズに「0.5」を指定すると，次に示す式によって，幅 約123（mm）のCODE39バーコードが帳票に出力できます。

クワイエットゾーン＝スタートキャラクタの値（mm）×2（個所）
スタートキャラクタ＝｛（0.5（mm）×6）＋（1.0 ※（mm）×3）｝×1（桁）
データ＝｛（0.5（mm）×6）＋（1.0 ※（mm）×3）｝×13（桁）
チェックキャラクタ＝｛（0.5（mm）×6）＋（1.0 ※（mm）×3）｝×1（桁）
ストップキャラクタ＝｛（0.5（mm）×6）＋（1.0 ※（mm）×3）｝×1（桁）
キャラクタ間ギャップ＝（0.5（mm）×2）×15（個所）
注※

太エレメントは，細エレメントのサイズ（mm）×2.24で計算します。

ページの先頭へ

(3)　アイテム枠の幅の指定

CODE39バーコードの場合，計算で求めた値でアイテム枠を確保しても，多少横に広がって出力されます。そのため，帳票にCODE39バーコードを収めるときは，アイテム枠の幅を少し余裕を持って確保してください。サイズに「0.5」を指定した場合，求めた値は幅 約123（mm）ですが，帳票に確保するアイテム枠の幅を約130（mm）程度確保すると収まります。

ページの先頭へ

(4)　プリンタの解像度によって出力できるバーコードの最小サイズ

出力するプリンタの解像度が300dpiの場合

最小サイズは0.15mmです。

出力するプリンタの解像度が600dpiの場合

最小サイズは0.15mmです。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 49 / 195


4.4.5 CODE128バーコード : EUR システム設計ガイド

  • 50 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.4　EURで使用できるバーコード

  • 4.4.5　CODE128バーコード

4.4.5　CODE128バーコード

〈この項の構成〉

  • (1)　データの指定

  • (2)　サイズの指定

  • (3)　アイテム枠の幅の指定

  • (4)　プリンタの解像度によって出力できるバーコードの最小サイズ

(1)　データの指定

JIS X 0504で規格されているCODE128バーコードのコードセットは，コードセットA，コードセットB，およびコードセットCがあります。そのうち，EURでCODE128バーコードを表示する場合は，コードセットBとコードセットCを使用して，データ（データキャラクタ）をデータファイルに指定します。どちらのコードセットを使用するかは，［オプション］ダイアログ，または［アイテムのプロパティ］ダイアログの［入力データ形式］で指定します。

指定したコードセットで使用できるデータを次に示します。

表4‒8 CODE128バーコードで指定できる入力データ
数値 | EURのデータファイルに指定できるデータ
 | コードセットBを使用する場合 | コードセットCを使用する場合
0 | △（0x20：半角空白） | 00
1 | ! | 01
2 | " | 02
3 | # | 03
4 | $ | 04
5 | % | 05
6 | & | 06
7 | ' | 07
8 | ( | 08
9 | ) | 09
10 | * | 10
11 | + | 11
12 | , | 12
13 | - | 13
14 | . | 14
15 | / | 15
16 | 0 | 16
17 | 1 | 17
18 | 2 | 18
19 | 3 | 19
20 | 4 | 20
21 | 5 | 21
22 | 6 | 22
23 | 7 | 23
24 | 8 | 24
25 | 9 | 25
26 | : | 26
27 | ; | 27
28 | < | 28
29 | = | 29
30 | > | 30
31 | ? | 31
32 | @ | 32
33 | A | 33
34 | B | 34
35 | C | 35
36 | D | 36
37 | E | 37
38 | F | 38
39 | G | 39
40 | H | 40
41 | I | 41
42 | J | 42
43 | K | 43
44 | L | 44
45 | M | 45
46 | N | 46
47 | O | 47
48 | P | 48
49 | Q | 49
50 | R | 50
51 | S | 51
52 | T | 52
53 | U | 53
54 | V | 54
55 | W | 55
56 | X | 56
57 | Y | 57
58 | Z | 58
59 | [ | 59
60 | \ ※ | 60
61 | ] | 61
62 | ^ | 62
63 | _ | 63
64 | ` | 64
65 | a | 65
66 | b | 66
67 | c | 67
68 | d | 68
69 | e | 69
70 | f | 70
71 | g | 71
72 | h | 72
73 | i | 73
74 | j | 74
75 | k | 75
76 | l | 76
77 | m | 77
78 | n | 78
79 | o | 79
80 | p | 80
81 | q | 81
82 | r | 82
83 | s | 83
84 | t | 84
85 | u | 85
86 | v | 86
87 | w | 87
88 | x | 88
89 | y | 89
90 | z | 90
91 | { | 91
92 | | | 92
93 | } | 93
94 | ~ | 94
95 | － | 95
96 | － | 96
97 | － | 97
98 | － | 98
99 | [CODEC] | 99
100 | － | [CODEB]
101 | － | －
102 | [FNC1] | [FNC1]
（凡例）

－：該当する項目はありません。

注※

コードセットBを使用してデータファイルに「0x5C」を指定した場合，出力するときのフォント指定によって，「＼」に出力できます。

「\」を「＼」に出力する場合は，データキャラクタのフォントに，Arialなどの欧文フォントを指定してください。ＭＳ ゴシックなどの日本語フォントを指定した場合は，「\」のまま出力されます。

コードセットBも，コードセットCも，指定するデータの桁数は任意です。ただし，コードセットCの場合は，2桁の数字で一つのバーコードキャラクタを表すので，偶数になるように入力してください。奇数指定の場合，データは欠損値として扱われ，バーコードは表示されません。

CODE128バーコードの形式を次に示します。

CODE128バーコードのスタート／ストップキャラクタと，チェックキャラクタ（モジュラチェックキャラクタ）は，バーで表します。

また，CODE128バーコードのスタート／ストップキャラクタとチェックキャラクタ（モジュラチェックキャラクタ）は，EUR 帳票作成機能が自動付加しているために指定できませんが，指定した入力データ形式によって，スタートキャラクタが次のように異なります。

CODE128バーコードには，FNC1のファンクションキャラクタをEUR 帳票作成機能で付加できます。FNC1は，特定の工業規格に合致するシンボルを識別するキャラクタです。FNC1の付加指定は，［オプション］ダイアログ，または［アイテムのプロパティ］ダイアログで指定できます。FNC1は，スタートキャラクタのあとに付加されます。

CODE128バーコードでは，帳票出力時にバーコードの幅を補正できます。補正値は，プリンタ定義ファイルまたは環境変数で指定します。詳細は，マニュアル「EUR 帳票出力 EUR Designer/EUR Viewer編」またはマニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

(2)　サイズの指定

CODE128で指定できるサイズと単位は，0.1～1.1mmです。

CODE128バーコードは，1モジュールの幅を，0.01mm単位で指定します。「モジュール」とは，黒バー，白バー，およびクワイエットゾーンを表現する最小単位です。「クワイエットゾーン」とは，バーコードの両端にある余白部分です。

CODE128バーコードには，入力データ形式に「コードセットB」と「コードセットC」がありますが，サイズの求め方は同じです。

(1)クワイエットゾーン（1モジュール×10）

(2)スタートキャラクタ（11モジュール）

(3)データ（1データキャラクタは，11モジュール）

(4)チェックキャラクタ（11モジュール）

(5)ストップキャラクタ（13モジュール）

(6)クワイエットゾーン（1モジュール×10）

例えば，12桁のデータ（データキャラクタ）を表示するとき，サイズに「0.5」を指定すると，次に示す式によって，幅 93.5（mm）のCODE128バーコードが帳票に出力できます。

クワイエットゾーン＝（0.5（mm）×10）×2（個所）
スタートキャラクタ＝11（モジュール）×0.5（mm）
データ＝（11（モジュール）×12（桁））×0.5（mm）
チェックキャラクタ＝11（モジュール）×0.5（mm）
ストップキャラクタ＝13（モジュール）×0.5（mm）
CODE128バーコードにFNC1を付加する場合

［FNC1を付加する］のチェックボックスをオンにしたときは，スタートキャラクタの右横にファンクションキャラクタが付加されます。

(7)ファンクションキャラクタ（11モジュール）

例えば，12桁のデータ（データキャラクタ）を表示するとき，サイズに「0.5」を指定すると，次に示す式によって，幅 99（mm）のCODE128バーコードが帳票に出力できます。

クワイエットゾーン＝（0.5（mm）×10）×2（個所）
スタートキャラクタ＝11（モジュール）×0.5（mm）
ファンクションキャラクタ＝11（モジュール）×0.5（mm）
データ＝（11（モジュール）×12（桁））×0.5（mm）
チェックキャラクタ＝11（モジュール）×0.5（mm）
ストップキャラクタ＝13（モジュール）×0.5（mm）

ページの先頭へ

(3)　アイテム枠の幅の指定

CODE128バーコードの場合，計算で求めた値でアイテム枠を確保しても，多少横に広がって出力されます。そのため，帳票にCODE128バーコードを収めるときは，アイテム枠の幅を少し余裕を持って確保してください。サイズに「0.5」を指定した場合，求めた値は幅 93.5（mm）ですが，帳票に確保するアイテム枠の幅を94（mm）程度確保すると収まります。

  • FNC1を付加したCODE128バーコードの場合

    帳票にFNC1を付加したCODE128バーコードを収める場合は，サイズに「0.5」を指定したとき，帳票に確保するアイテム枠の幅を100（mm）程度確保すると収まります。

ページの先頭へ

(4)　プリンタの解像度によって出力できるバーコードの最小サイズ

出力するプリンタの解像度が300dpiの場合

最小サイズは0.20mmです。

出力するプリンタの解像度が600dpiの場合

最小サイズは0.15mmです。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 50 / 195


4.4.6 GS1-128（UCC/EAN-128）バーコード : EUR システム設計ガイド

  • 51 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.4　EURで使用できるバーコード

  • 4.4.6　GS1-128（UCC/EAN-128）バーコード

4.4.6　GS1-128（UCC/EAN-128）バーコード

EURでは，（財）流通システム開発センターの標準料金代理収納システムに対応したGS1-128（UCC/EAN-128）バーコードを出力できます。

〈この項の構成〉

  • (1)　データの指定

(1)　データの指定

バーコードフィールドのデータを，次に示す形式で指定します。データは，半角数字（0～9），半角記号「( ) -」，および半角空白を使用できます。半角記号「( ) -」と半角空白は，データ属性を示すアプリケーション識別子（AI）の囲み文字と，形式の各項目の区切りをわかりやすくするために指定できます。ただし，表示するバーコードは，半角記号「( ) -」と半角空白を除いた44桁（固定）が用いられます。

データキャラクタを2行にする場合は，改行コード「\n」を入れてください。

形式に指定する項目について，説明します。

項番 | 項目 | 指定する内容 | 指定するデータの桁数
(1) | (91) | データ属性を示すアプリケーション識別子（AI）です。 | 2
(2) | MMMMMM | 「請求書発行企業コード（JANメーカーコード7桁）」のうち，先頭の「4」を除いた6桁を指定します。 旧請求書発行企業コード（メーカーコード5桁）を使用する場合は，「国コード（2桁目の「9」，または「5」）＋メーカーコード（5桁）」の形式で指定します。 | 6
(3) | EEEEEEEEEEEEEEEEEEEEE | 自由使用欄です。21桁に満たない場合は，後ろを「0」で埋めて指定してください。 | 21
(4) | S | 再発行区分（再発行した回数）を指定します。 | 1
(5) | YYMMDD | 支払い期限日を指定します。 YY：西暦下2桁を指定します。 MM：月を指定します。例えば，5月の場合は，「05」と指定してください。 DD：日を指定します。例えば，3日の場合は，「03」と指定してください。 | 6
(6) | F | 印紙フラグを指定します。 0：印紙を貼り付けません。 1：印紙を貼り付けます。 2～9：予備 | 1
(7) | PPPPPP | 支払い金額を指定します。単位は，円です。 | 6
(8) | T | 全体チェックデジットを，モジュラス10で指定します。 | 1
データの指定例

バーコードフィールドのデータの指定例を，CSV形式ファイルに出力した例で示します。

(91)912345-0123456789012345678901\n010331-0-123000-1

「\n」は，改行コードを示しています。改行コードは，次のように指定します。

  • Shift JISの場合

    0x0d 0x0a，または0x0aのどちらかを使用します。

  • Unicodeの場合

    0x000d 0x000a，または0x000aのどちらかを使用します。

目視文字用データを指定する場合

目視文字用データの文字列は，両端を「"」で囲んで指定します。バーコードフィールドのデータと，目視文字用の文字列フィールドの指定例を，CSV形式ファイルに出力した例で示します。

"91912345012345678901234567890101033101230001","(91)912345-0123456789012345678901\n010331-0-123000-1"

バーコードの幅を指定する場合

GS1-128（UCC/EAN-128）バーコードの幅は，環境設定ファイルEUR_CODE128_PARAM，またはプリンタ定義ファイルのCODE128PARAMで指定できます。環境設定ファイル，またはプリンタ定義ファイルについては，マニュアル「EUR 帳票出力 EUR Designer/EUR Viewer編」または「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 51 / 195


4.4.7 NW-7バーコード : EUR システム設計ガイド

  • 52 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.4　EURで使用できるバーコード

  • 4.4.7　NW-7バーコード

4.4.7　NW-7バーコード

〈この項の構成〉

  • (1)　データの指定

  • (2)　サイズの指定

  • (3)　アイテム枠の幅の指定

  • (4)　プリンタの解像度によって出力できるバーコードの最小サイズ

(1)　データの指定

NW-7バーコードを表示する場合は，半角数字（0～9），および半角記号「- $ : / . +」を使用して，データ（データキャラクタ）をデータファイルに指定します。指定するデータ（データキャラクタ）の桁数は任意です。

NW-7バーコードの形式を次に示します。

NW-7バーコードには，スタート／ストップキャラクタと，チェックキャラクタ（モジュラチェックキャラクタ）をEUR 帳票作成機能で付加できます。

スタート／ストップキャラクタを付加指定すると，データ（データキャラクタ）の前後に「A」（固定）が表示されます。チェックキャラクタ（モジュラチェックキャラクタ）を付加すると，データの読み取りの信頼性が向上します。

スタート／ストップキャラクタと，チェックキャラクタ（モジュラチェックキャラクタ）の付加指定は，［オプション］ダイアログ，または［アイテムのプロパティ］ダイアログで指定できます。

なお，データ（データキャラクタ）といっしょにスタート／ストップキャラクタを指定しておくこともできます。この場合は，半角英字（A，B，C，D）から選択して指定します。スタートキャラクタとストップキャラクタに使用するキャラクタの組み合わせは自由です。

ページの先頭へ

(2)　サイズの指定

NW-7で指定できるサイズと単位は，0.1～1.6mmです。

NW-7バーコードは，細エレメントの幅を0.01mm単位で指定します。「エレメント」とは，1本の白バー，または黒バーを示します。また，「細エレメント」は幅が細いバー，「太エレメント」は幅が太いバーを示します。

(1)クワイエットゾーン（スタート／ストップキャラクタの幅＋α）

「クワイエットゾーン」とは，バーコードの両端にある余白部分です。

(2)スタートキャラクタ（細エレメント×4と太エレメント×3）

(3)データ（半角数字「0～9」と半角記号「- $」は，細エレメント×5と太エレメント×2。半角記号「, / . +」は，細エレメント×4と太エレメント×3）

(4)チェックキャラクタ（データと同様に，表示されるチェックキャラクタの値を計算します）

(5)ストップキャラクタ（細エレメント×4と太エレメント×3）

(6)クワイエットゾーン

(7)キャラクタ間ギャップ（1ギャップは，細エレメントの2倍）

例えば，13桁のデータ（データキャラクタ）を表示するとき，サイズに「0.5」を指定すると，次に示す式によって，幅 118（mm）のNW-7バーコードが帳票に出力できます。

クワイエットゾーン＝スタートキャラクタの値（mm）×2（個所）
スタートキャラクタ＝｛（0.5（mm）×4）＋（1.5 ※（mm）×3）｝×1（桁）
データ＝｛（0.5（mm）×5）＋（1.5 ※（mm）×2）｝×13（桁）
チェックキャラクタ＝｛（0.5（mm）×5）＋（1.5 ※（mm）×2）｝×1（桁）
ストップキャラクタ＝｛（0.5（mm）×4）＋（1.5 ※（mm）×3）｝×1（桁）
キャラクタ間ギャップ＝（0.5（mm）×2）×15（個所）
注※

太エレメントは，細エレメントのサイズ（mm）×3で計算します。

ページの先頭へ

(3)　アイテム枠の幅の指定

帳票にNW-7バーコードを収める場合は，求めた値と同じアイテム枠の幅を確保することで収まります。

ページの先頭へ

(4)　プリンタの解像度によって出力できるバーコードの最小サイズ

出力するプリンタの解像度が300dpiの場合

最小サイズは0.20mmです。

出力するプリンタの解像度が600dpiの場合

最小サイズは0.15mmです。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 52 / 195


4.4.8 QRコード : EUR システム設計ガイド

  • 53 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.4　EURで使用できるバーコード

  • 4.4.8　QRコード

4.4.8　QRコード

〈この項の構成〉

  • (1)　データの指定

  • (2)　サイズの指定

  • (3)　アイテム枠の幅の指定

  • (4)　プリンタの解像度によって出力できるバーコードの最小サイズ

(1)　データの指定

QRコードを表示する場合は，入力データ形式によって，使用できる文字が異なります。また，指定するデータ（データキャラクタ）の桁数も異なります。

QRコードの表示例を次に示します。

QRコードでEURがサポートする範囲を次に示します。

機能 | EURでサポートする範囲
モデル | モデル2をサポートします。
バージョン | バージョン1から40をサポートします。
訂正レベル | M(15%)，Q(25%)をサポートします。
モード | 数字モード，英数字モード，8ビットバイトモード，漢字モード，混在モードをサポートします。
セルサイズ | ［アイテムのプロパティ］ダイアログ，環境変数EURPS_QR_CELL_SIZE_D，または環境変数EURPS_QR_CELL_SIZE_Mで指定できます。指定されていない場合は，アイテムサイズとバージョンから自動計算します。
クワイエットゾーン | クワイエットゾーンはEURが付加します。サイズは4モジュールです。

(a)　使用できる文字

QRコードに指定できる入力データ文字は，入力データ形式によって異なります。

入力データ形式が「文字列」の場合

使用しているロケールの文字コードに従って，データ（データキャラクタ）を文字列でデータファイルに指定します。

入力データ形式が「16進文字列」の場合

使用しているロケールの文字コードに従って，データ（データキャラクタ）を16進文字列でデータファイルに指定します。

なお，16進文字列のQRコードをEUR DeveloperまたはEUR Serverで使用する場合は，文字コードに関係なく，Shift JISを指定してください。

入力データ形式が「16進バイナリ」の場合

8ビットバイナリエンコーディングに従って，データ（データキャラクタ）を16進バイナリの文字列でデータファイルに指定します。

(b)　QRコードのバージョン

QRコードは，アイテム枠の大きさ，および指定するデータから求められた型番によって，帳票に表示できるQRコードの大きさが異なります。また，QRコードは，出力するプリンタの解像度によっても，大きさが異なります。EURでは入力データから適切なバージョンを計算して使用します。

［アイテムのプロパティ］ダイアログまたは環境変数EURPS_QR_VERSIONで指定された値よりも入力データが小さい場合は指定された値になるように調整します。環境変数EURPS_QR_VERSIONについては，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

最小バージョン

［アイテムのプロパティ］ダイアログおよび環境変数EURPS_QR_VERSIONの指定によって最小バージョンが異なります。

指定条件によるQRコードの最小バージョンを次に示します。

表4‒9　QRコードの最小バージョン

指定条件

最小バージョン

［アイテムのプロパティ］ダイアログ

環境変数EURPS_QR_VERSION

なし

なし

バージョン1

なし

V1

バージョン1

バージョン2

－

バージョン2
（凡例）

－：指定しません。

出力バーコードバージョン

出力バーコードのバージョンは，入力データのバージョンと最小バージョンによって異なります。

条件別の出力バーコードのバージョンを次に示します。

表4‒10　出力バーコードのバージョン

条件

出力バージョン

入力データのバージョン≦最小バージョン

最小バージョン

入力データのバージョン＞最小バージョン

入力データのバージョン

(c)　QRコードのモード

QRコードのモードは，入力データ形式によって異なります。

入力データ形式が「文字列」または「16進文字列」の場合

入力データ形式「文字列」または「16進文字列」では，QRコードに混在モードを使用し，データ内容に応じてモードを切り替えます。非漢字データについては数字モード，英数字モード，または8ビットバイトモードを使用します。デフォルトは，数字モードです。

表4‒11　条件別の遷移後のモード（「文字列」または「16進文字列」）

条件

遷移後のモード

現在モード

出現文字

数字モード

数字

数字モード

英字

英数字モード

漢字

漢字モード

英数字モード

数字

英数字モード

英字

英数字モード

漢字

漢字モード

8ビットバイトモード

数字

8ビットバイトモード

英字

8ビットバイトモード

漢字

漢字モード

漢字モード

数字

数字モード

英字

英数字モード

漢字

漢字モード
注

出現文字が数字，英字，漢字以外の場合は，8ビットバイトモードに切り替わります。

入力データ形式が「16進バイナリ」の場合

入力データ形式「16進バイナリ」では，データを8ビットバイトモードで生成します。

(d)　モジュール幅

出力バージョンに対応するモジュール数とアイテムサイズからセルサイズを計算します。［アイテムのプロパティ］ダイアログ，環境変数EURPS_QR_CELL_SIZE_D，または環境変数EURPS_QR_CELL_SIZE_Mでセルサイズが指定された場合，計算した標準セルサイズより小さいときには指定されたセルサイズを出力します。環境変数EURPS_QR_CELL_SIZE_D，環境変数EURPS_QR_CELL_SIZE_Mについては，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

表4‒12 出力セルサイズ
条件 |  |  | 出力セルサイズ
［アイテムのプロパティ］ダイアログ | EURPS_QR_CELL_SIZE_D | EURPS_QR_CELL_SIZE_M
なし | なし | なし | 標準セルサイズ
なし | D | なし | D×解像度
なし | － | M | ↓(M×解像度)/解像度↓
Mi | － | － | ↓(Mi×解像度)/解像度↓
（凡例）

－：指定しません。

出力セルサイズでバーコードを描画するとアイテムサイズより大きくなる場合は，バーコードは表示されません。指定セルサイズが標準セルサイズよりも大きい場合は，アイテムサイズを超えます。標準セルサイズが0となる場合もバーコードは表示されません。

標準セルサイズの計算式を次に示します。

標準セルサイズ＝↓((min(アイテム幅，アイテム高)×解像度)/(モジュール数＋8※))↓÷解像度
モジュール数＝21＋4×(バージョン－1)
注※

クワイエットゾーン4モジュールの2個分です。

(e)　クワイエットゾーン

EURでは，クワイエットゾーンは4モジュールです。

ページの先頭へ

(2)　サイズの指定

QRコードは，サイズの指定ができません。QRコードのサイズを変更したい場合は，アイテム枠の大きさをマウス操作で変更してください。

ページの先頭へ

(3)　アイテム枠の幅の指定

指定されたアイテム枠に収まる適切なサイズに自動調整して出力されます。

ページの先頭へ

(4)　プリンタの解像度によって出力できるバーコードの最小サイズ

QRコードは，出力するプリンタに依存しません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 53 / 195


4.4.9 カスタマバーコード : EUR システム設計ガイド

  • 54 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.4　EURで使用できるバーコード

  • 4.4.9　カスタマバーコード

4.4.9　カスタマバーコード

〈この項の構成〉

  • (1)　データの指定

  • (2)　サイズの指定

  • (3)　アイテム枠の幅の指定

  • (4)　プリンタの解像度によって出力できるバーコードの最小サイズ

(1)　データの指定

カスタマバーコードを表示する場合は，半角数字（0～9），半角英大文字（A～Z），半角記号「-」，および8種類の制御コード（CC1～CC8）を使用して，データをデータファイルに指定します。データの桁数は，指定するカスタマバーコードのデータ形式によって異なります。

(a)　「郵便番号＋住所表示番号」のデータ形式

「郵便番号＋住所表示番号」は，郵便番号の値に，住所文字列からカスタマバーコードに必要な文字を抜き出した文字列を付加したデータ形式です。「文字タイプ」ともいわれます。

「郵便番号＋住所表示番号」のデータは，郵便番号（7桁固定）＋住所表示番号（最大13桁）で指定します。

ただし，スタートコード（1文字）チェックデジット（1文字），ストップコード（1文字）はEURによって自動生成され，付加されます。

「郵便番号＋住所表示番号」のカスタマバーコードの構成を次に示します。

データの抽出方法

例として，「〒623-0011　京都府綾部市青野町出口 6-7 LプラザB 106」からデータを抽出する手順を示します。

手　順

結　果

(1)

郵便番号の「623-0011」から「-」を削除します。

6230011

(2)

住所表示番号を取り出します。

6-7 L B 106

(3)

住所表示番号を郵便番号の後ろに付加します。

「62300116-7LB106」が，「郵便番号＋住所表示番号」のデータになります。

62300116-7LB106

「郵便番号＋住所表示番号」のデータを抽出した場合は，EURのカスタマバーコードのデータ形式で「郵便番号＋住所表示番号」を選択します。

EURが，「郵便番号＋住所表示番号」のデータのあとに，チェックデジットと制御コードを付加してカスタマバーコードを表示します。

抽出されたデータ「62300116-7LB106」を，データ形式「郵便番号＋住所表示番号」で表示した場合のカスタマバーコードを次に示します。

(b)　「郵便番号＋住所表示番号＋チェックデジット＋制御コード」のデータ形式

「郵便番号＋住所表示番号＋チェックデジット＋制御コード」は，「郵便番号＋住所表示番号」のデータに，次に示す加工をした結果を，記号を用いて表現したデータ形式です。「記号タイプ」ともいわれます。

  • 英字を，制御コードと数字で表します。

  • チェックデジットを算出します。

  • スタートコード「(」（固定）とストップコード「)」（固定）を付加します。

「郵便番号＋住所表示番号＋チェックデジット＋制御コード」のデータは，スタートコード「(」（1桁固定）＋郵便番号（7桁固定）＋住所表示番号（最大13桁）＋チェックデジット（1桁固定）＋ストップコード「)」（1桁固定）で指定します。

「郵便番号＋住所表示番号＋チェックデジット＋制御コード」のカスタマバーコードの構成を次に示します。

データの抽出方法

例として，「〒623-0011　京都府綾部市青野町出口 6-7 LプラザB 106」からデータを抽出する手順を示します。

手　順

結　果

(1)

郵便番号の「623-0011」から「-」を削除します。

6230011

(2)

住所表示番号を取り出します。

住所表示番号の中に英字がある場合は，英字変換コード表 ※1に従って，制御コードと数字の組み合わせに変換します。

「L」→「CC2 1」

「B」→「CC1 1」

6-7 L B 106

  ↓

6-7 CC2 1 CC1 1 106

(3)

住所表示番号を郵便番号の後ろに付加します。

62300116-7 CC2 1 CC1 1 106

(4)

数字，「-」，および制御コードを，すべて1文字として文字数を数えます。20文字に満たない場合は，後ろに制御コード4（CC4）を付加します。

この例の場合は，3文字分の制御コード4を付加しています。

62300116-7 CC2 1 CC1 1 106 CC4 CC4 CC4

(5)

(4)で作成した文字列に，チェック用文字置き換えコード表 ※2に従って，チェック用文字に変換し，すべての値を加算します。

62300116-7 CC2 1 CC1 1 106 CC4 CC4 CC4

  ↓

6+2+3+0+0+1+1+6+10+7+12+1+11+1+1+0+6+14+14+14

=110

(6)

(5)で算出した値より大きい19の倍数から，(5)で算出した値を減算します。これが，「チェックデジット」です。

114-110=4

(7)

(4)で生成した文字列の後ろに，(6)で算出したチェックデジット「4」を付加します。

62300116-7 CC2 1 CC1 1 106 CC4 CC4 CC4 4

(8)

(7)で生成した文字列の前後に，スタートコード（ST）とストップコード（SP）を付加します。

スタートコードは「(」，ストップコードは「)」で指定します。

(62300116-7 CC2 1 CC1 1 106 CC4 CC4 CC4 4)

(9)

(8)で生成した文字列から，制御コードを次に示すASCIIコードで置き換えてEURのデータに指定します。

  制御コード　　ASCIIコード

    CC1　　　→　　a

    CC2　　　→　　b

    CC3　　　→　　c

    CC4　　　→　　d

    CC5　　　→　　e

    CC6　　　→　　f

    CC7　　　→　　g

    CC8　　　→　　h

「(62300116-7b1a1106ddd4)」が，「郵便番号＋住所表示番号＋チェックデジット＋制御コード」のデータになります。

(62300116-7b1a1106ddd4)
注※1

英字変換コード表

住所表示番号中に英字がある場合，次に示す英字変換コード表に従って，制御コードと数字の組み合わせに変換します。

表4‒13　カスタマバーコードの英字変換コード表

英字データ

コード

英字データ

コード

英字データ

コード

A

CC1 0

K

CC2 0

U

CC3 0

B

CC1 1

L

CC2 1

V

CC3 1

C

CC1 2

M

CC2 2

W

CC3 2

D

CC1 3

N

CC2 3

X

CC3 3

E

CC1 4

O

CC2 4

Y

CC3 4

F

CC1 5

P

CC2 5

Z

CC3 5

G

CC1 6

Q

CC2 6

－

－

H

CC1 7

R

CC2 7

－

－

I

CC1 8

S

CC2 8

－

－

J

CC1 9

T

CC2 9

－

－
（凡例）

－：該当する項目はありません。

注※2

チェック用文字置き換えコード表

カスタマバーコードのチェックデジットを算出するためのコード表です。

郵便番号と住所表示番号を合わせた20文字のデータを，次に示すチェック用文字置き換えコード表に従ってチェック用文字に変換し，すべての値を加算します。そのあと，算出した値より大きい19の倍数から，算出した値を減算した結果が，チェックデジットです。

表4‒14　カスタマバーコードのチェック用文字置き換えコード表

変換データ

チェック用文字

変換データ

チェック用文字

0

0

CC1

11

1

1

CC2

12

2

2

CC3

13

3

3

CC4

14

4

4

CC5

15

5

5

CC6

16

6

6

CC7

17

7

7

CC8

18

8

8

－

－

9

9

－

－

－

10

－

－
（凡例）

－：該当する項目はありません。

「郵便番号＋住所表示番号＋チェックデジット＋制御コード」のデータを抽出した場合は，EURのカスタマバーコードのデータ形式で「郵便番号＋住所表示番号＋チェックデジット＋制御コード」を選択します。

抽出されたデータ「(62300116-7b1a1106ddd4)」を，データ形式「郵便番号＋住所表示番号＋チェックデジット＋制御コード」で表示した場合のカスタマバーコードを次に示します。

ページの先頭へ

(2)　サイズの指定

指定できるサイズと単位は，8.0～11.5ptです。0.1pt単位で指定します。

ページの先頭へ

(3)　アイテム枠の幅の指定

指定されたサイズでアイテム枠を自動調整して出力されます。

ページの先頭へ

(4)　プリンタの解像度によって出力できるバーコードの最小サイズ

カスタマバーコードは，出力するプリンタに依存しません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 54 / 195


4.4.10 UPC-Aバーコード : EUR システム設計ガイド

  • 55 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.4　EURで使用できるバーコード

  • 4.4.10　UPC-Aバーコード

4.4.10　UPC-Aバーコード

〈この項の構成〉

  • (1)　データの指定

  • (2)　サイズの指定

  • (3)　アイテム枠の幅の指定

  • (4)　プリンタの解像度によって出力できるバーコードの最小サイズ

(1)　データの指定

UPC-Aバーコードを表示する場合は，半角数字（0～9）を使用して，12桁（固定）のデータ（データキャラクタ）をデータファイルに指定します。

UPC-Aバーコードの形式を次に示します。

データ（データキャラクタ）は，商品コードを表すキャラクタです。

ナンバーシステムキャラクタは，商品の種別を表すキャラクタです。

チェックキャラクタ（モジュラチェックキャラクタ）は，バーコードの読み取りの正確性を保つために，データ（データキャラクタ）から，ある計算方法に基づいて求めた値を表すキャラクタです。

業務アプリケーションでチェックキャラクタをあらかじめ付加する場合，例えば，「12345678901」のデータ（データキャラクタ）のチェックキャラクタ（モジュラチェックキャラクタ）は，次のような計算方法で求められます。

  1. 桁位置を付けます。求めるチェックキャラクタ（モジュラチェックキャラクタ）は，1桁目です。

    桁位置

    12

    11

    10

    9

    8

    7

    6

    5

    4

    3

    2

    1

    データ

    1

    2

    3

    4

    5

    6

    7

    8

    9

    0

    1

  2. 偶数桁の数字を加算します。

    1＋3＋5＋7＋9＋1＝26

  3. 2で求めた値を3倍します。

    26×3＝78

  4. 1桁目を除く，奇数桁の数字を加算します。

    2＋4＋6＋8＋0＝20

  5. 3で求めた値と，4で求めた値を加算します。

    78＋20＝98

  6. 5で求めた値の下1桁の数字を10から減算します。

    10－8＝2

    この値が，チェックキャラクタ（モジュラチェックキャラクタ）です。

    なお，5で求めた値の下1桁の数字が「0」の場合は，チェックキャラクタ（モジュラチェックキャラクタ）は「0」です。

チェックキャラクタ（モジュラチェックキャラクタ）は，EUR 帳票作成機能で付加することもできます。その場合は，半角数字（0～9）を使用して，11桁（固定）のデータ（データキャラクタ）をデータファイルに指定します。チェックキャラクタ（モジュラチェックキャラクタ）は，［オプション］ダイアログ，または［アイテムのプロパティ］ダイアログで指定できます。

ページの先頭へ

(2)　サイズの指定

UPC-Aバーコードで指定できるサイズと単位は0.15～2.1倍です。JIS X0507で規定されている0.8～2.0倍の範囲で指定することを推奨します。

UPC-Aバーコードのサイズは，JIS X 0507で規定されている1モジュール幅に対する倍率を0.01倍単位で指定します。JIS X 0507では，1モジュール幅の標準サイズを0.33mmと規定しています。「モジュール」とは，白バーと黒バー，およびマージンを構成する基本単位を示します。

UPC-Aバーコードは，113モジュールで構成されています。

(1)レフトマージン（9モジュール）

(2)レフトガードバー（3モジュール）

(3)ナンバーシステムキャラクタ（1キャラクタ，7モジュール）

(4)左データキャラクタ（5キャラクタ，35モジュール）

(5)センタバー（5モジュール）

(6)右データキャラクタ（5キャラクタ，35モジュール）

(7)モジュラチェックキャラクタ（1キャラクタ，7モジュール）

(8)ライトガードバー（3モジュール）

(9)ライトマージン（9モジュール）

例えば，サイズに「2」を指定すると，「｛113（モジュール）×0.33（mm）｝×2（倍）」という式によって，幅74.58（mm）のUPC-Aバーコードが帳票に出力できます。

ページの先頭へ

(3)　アイテム枠の幅の指定

帳票にUPC-Aバーコードを収めるとき，アイテム枠の幅は，求めた値の小数点以下を切り上げた値で確保すると収まります。この場合は，アイテム枠の幅を75（mm）程度確保すると収まります。

表4‒15 UPC-Aバーコードの実サイズ参考値
［サイズ］の値 | 帳票に出力されるバーコードの実サイズ
0.5 | 幅 約19（mm）
1 | 幅 約38（mm）
1.5 | 幅 約56（mm）

ページの先頭へ

(4)　プリンタの解像度によって出力できるバーコードの最小サイズ

出力するプリンタの解像度が300dpiの場合および600dpiの場合

最小サイズは0.8倍です。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 55 / 195


4.4.11 UPC-Eバーコード : EUR システム設計ガイド

  • 56 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.4　EURで使用できるバーコード

  • 4.4.11　UPC-Eバーコード

4.4.11　UPC-Eバーコード

UPC-Eバーコードのデータの指定方法およびプロパティの設定方法について説明します。

〈この項の構成〉

  • (1)　データの指定

  • (2)　サイズの指定

  • (3)　アイテム枠の幅の指定

  • (4)　プリンタの解像度によって出力できるバーコードの最小サイズ

(1)　データの指定

UPC-Eバーコードを表示する場合は，半角数字（0～9）を使用して，「0」で始まる8桁（固定）のデータ（データキャラクタ）をデータファイルに指定します。

UPC-Eバーコードの形式を次に示します。

データ（データキャラクタ）は，商品コードを表すキャラクタです。

ナンバーシステムキャラクタには，自動的に「0」が付加されます。

チェックキャラクタ（モジュラチェックキャラクタ）は，バーコードの読み取りの正確性を保つために，データ（データキャラクタ）とナンバーシステムキャラクタから，ある計算方法に基づいて求めた値を表すキャラクタです。

UPC-Eバーコードのチェックキャラクタは，6桁のデータ（データキャラクタ）の先頭にナンバーシステムキャラクタの「0」を付加した7桁の数字を，規則に従って11桁に復号したあと，UPC-Aバーコードのチェックキャラクタの計算方法に従って求めます。

業務アプリケーションでチェックキャラクタをあらかじめ付加する場合，例えば，「123456」のデータ（データキャラクタ）の先頭にナンバーシステムキャラクタの「0」を付加した7桁の数字「0123456」のチェックキャラクタは，次のような計算方法で求められます。

  1. 桁位置を付けます。求めるチェックキャラクタ（モジュラチェックキャラクタ）は，1桁目です。

    桁位置

    1

    2

    3

    4

    5

    6

    7

    8

    データ

    0

    1

    2

    3

    4

    5

    6

  2. 7桁のデータを11桁に復号します。

    次に示す4つのパターンの中から当てはまるパターンに従って復号します。

    「0123456」は，パターン4に従って「01234500006」に復号されます。

    ■パターン1：1桁目が「0」，7桁目が「0～2」の場合

    7桁目を3桁目と4桁目の間に移動させて，その後ろに「0」を4つ挿入します。

    例えば，データが「0013452」の場合は，「00120000345」となります。

    ■パターン2：1桁目が「0」，7桁目が「3」の場合

    7桁目を削除して，4桁目と5桁目の間に「0」を5つ挿入します。

    例えば，データが「0123453」の場合は，「01230000045」となります。

    ■パターン3：1桁目が「0」，7桁目が「4」の場合

    7桁目を削除して，5桁目と6桁目の間に「0」を5つ挿入します。

    例えば，データが「0123454」の場合は，「01234000005」となります。

    ■パターン4：1桁目が「0」，7桁目が「5～9」の場合

    6桁目と7桁目の間に「0」を4つ挿入します。

    例えば，データが「0123456」の場合は，「01234500006」となります。

  3. UPC-Aバーコードの計算方法に従ってチェックキャラクタを計算します。

    復号した11桁のデータのチェックキャラクタを，UPC-Aバーコードの計算方法に従って計算します。

    「01234500006」のチェックキャラクタを計算すると，「5」となります。

    UPC-Aバーコードの計算方法については，「4.4.10(1)　データの指定」を参照してください。

チェックキャラクタ（モジュラチェックキャラクタ）は，EUR 帳票作成機能で付加することもできます。その場合は，半角数字（0～9）を使用して，「0」で始まる7桁（固定）のデータ（データキャラクタ）をデータファイルに指定します。チェックキャラクタ（モジュラチェックキャラクタ）は，［オプション］ダイアログ，または［アイテムのプロパティ］ダイアログで指定できます。

ページの先頭へ

(2)　サイズの指定

UPC-Eバーコードで指定できるサイズと単位は0.15～2.1倍です。JIS X0507で規定されている0.8～2.0倍の範囲で指定することを推奨します。

UPC-Eバーコードのサイズは，JIS X 0507で規定されている1モジュール幅に対する倍率を0.01倍単位で指定します。JIS X 0507では，1モジュール幅の標準サイズを0.33mmと規定しています。「モジュール」とは，白バーと黒バー，およびマージンを構成する基本単位を示します。

UPC-Eバーコードは，67モジュールで構成されています。

(1)レフトマージン（9モジュール）

(2)レフトガードバー（3モジュール）

(3)データキャラクタ（6キャラクタ，42モジュール）

(4)ライトガードバー（6モジュール）

(5)ライトマージン（7モジュール）

例えば，サイズに「2」を指定すると，「｛67（モジュール）×0.33（mm）｝×2（倍）」という式によって，幅44.22（mm）のUPC-Eバーコードが帳票に出力できます。

表4‒16 UPC-Eバーコードのサイズ
［サイズ］の値 | 帳票に出力されるバーコードの実サイズ
0.5 | 幅 約12（mm）
1 | 幅 約23（mm）
1.5 | 幅 約34（mm）

ページの先頭へ

(3)　アイテム枠の幅の指定

帳票にUPC-Eバーコードを収めるとき，アイテム枠の幅は，求めた値の小数点以下を切り上げた値で確保すると収まります。サイズに「2」を指定した場合は，アイテム枠の幅を45（mm）程度確保すると収まります。

ページの先頭へ

(4)　プリンタの解像度によって出力できるバーコードの最小サイズ

出力するプリンタの解像度が300dpiの場合および600dpiの場合

最小サイズは0.8倍です。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 56 / 195


4.4.12 バーコードの出力時の注意事項 : EUR システム設計ガイド

  • 57 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.4　EURで使用できるバーコード

  • 4.4.12　バーコードの出力時の注意事項

4.4.12　バーコードの出力時の注意事項

〈この項の構成〉

  • (1)　バーコードの余白の設定

  • (2)　EUR サーバ帳票出力機能で出力する場合の機能差

  • (3)　データに関する注意事項

(1)　バーコードの余白の設定

バーコードの周りには，次の余白部分が必要です。

  • JAN：マージン

  • UPC：マージン

  • カスタマバーコード：空白

  • 上記以外のバーコード：クワイエットゾーン

バーコードの余白部分にほかのアイテムが配置されていた場合，バーコードの余白部分を優先して印刷します。バーコードの余白部分にほかのアイテムを配置しないようにしてください。

ページの先頭へ

(2)　EUR サーバ帳票出力機能で出力する場合の機能差

バーコードを貼り付けた帳票をEUR サーバ帳票出力機能で出力する場合，次に示す機能差があります。

  • EURのバージョン3で作成した帳票を，そのままEUR サーバ帳票出力機能で出力すると，バーコードのサイズがわずかに異なる場合があります。サイズは変わりますが，バーコードの読み取り精度は向上します。

  • EURのバージョン3では，バーコードの色を指定できましたが，EUR サーバ帳票出力機能では，黒固定で出力します。

ページの先頭へ

(3)　データに関する注意事項

バーコードの入力データに，制御コードなどのバーコードデータとして使用できない文字が含まれている場合，バーコードに不適切なデータが指定されたと認識して，アイテム内にバーコードを出力しません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 57 / 195


4.5 EURで使用できる画像ファイル : EUR システム設計ガイド

  • 58 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.5　EURで使用できる画像ファイル

4.5　EURで使用できる画像ファイル

EURで扱える画像データの形式は次のとおりです。

  • Windows BITMAP

  • JPEG

  • GIF（GIF GIF87a，GIF GIF89a）

  • TIFF（TIFF 6.0）

  • PNG

    表4‒17　EURで扱える画像ファイルのデータ形式

    画像データの形式

    詳細形式

    Windows BITMAP（*.bmp）

    2色モノクロ

    16色パレットカラー

    256色パレットカラー

    24ビットフルカラー

    16色RLE圧縮

    EUR サーバ帳票出力機能で帳票を出力する場合，Windows環境のプリンタ印刷では出力できますが，次に示すときには出力できません。

    • Windows環境でのPDF形式ファイル出力

    • UNIX／Linux環境でのプリンタ印刷，PDLファイル出力，およびPDF形式ファイル出力

    256色RLE圧縮

    EUR サーバ帳票出力機能で帳票を出力する場合，Windows環境のプリンタ印刷では出力できますが，次に示すときには出力できません。

    • Windows環境でのPDF形式ファイル出力

    • UNIX／Linux環境でのプリンタ印刷，PDLファイル出力，およびPDF形式ファイル出力

    Windows 3.0以前のビットマップ形式

    JPEG（*.jpg / *.jpe / *.jpeg）

    JFIFフォーマット基本DCT（ベースライン）フルカラー

    JFIFフォーマット基本DCT（ベースライン）256色グレイスケール

    GIF GIF87a（*.gif）

    2色モノクロ ノンインタレース

    2色モノクロ インタレース

    4色パレットカラー ノンインタレース

    4色パレットカラー インタレース

    16色パレットカラー ノンインタレース

    16色パレットカラー インタレース

    256色パレットカラー ノンインタレース

    256色パレットカラー インタレース

    GIF GIF89a（*.gif）

    2色モノクロ ノンインタレース

    2色モノクロ インタレース

    4色パレットカラー ノンインタレース

    4色パレットカラー インタレース

    16色パレットカラー ノンインタレース

    16色パレットカラー インタレース

    256色パレットカラー ノンインタレース

    256色パレットカラー インタレース

    透明色指定

    上記の8フォーマット（色4種×インタレース2種）それぞれで透明色の有無の指定ができます。ただし，透明部分は，GIF画像中の背景色が使用されます。

    アニメーション

    上記の8フォーマット（色4種×インタレース2種）それぞれでアニメーションの有無の指定ができます。ただし，先頭の1枚目だけが使用されます。

    TIFF 6.0（*.tif / *.tiff）

    2色モノクロ 非圧縮

    2色モノクロ ハフマン圧縮

    2色モノクロ G3/G4 FAX互換圧縮

    16色 非圧縮

    256色 非圧縮

    24ビット色 非圧縮

    グレイスケール 非圧縮

    カラー：RGB指定

    カラー：YCbCr指定

    複数画像（ただし，先頭の1枚だけを対象とします）

    ストリップ形式（カラーTIFFのストリップも使用できます）

    PNG（*.png）

    2色パレットカラー ノンインタレース

    2色パレットカラー インタレース

    4色パレットカラー ノンインタレース

    4色パレットカラー インタレース

    16色パレットカラー ノンインタレース

    16色パレットカラー インタレース

    256色パレットカラー ノンインタレース

    256色パレットカラー インタレース

    2色グレイスケール ノンインタレース

    2色グレイスケール インタレース

    4色グレイスケール ノンインタレース

    4色グレイスケール インタレース

    16色グレイスケール ノンインタレース

    16色グレイスケール インタレース

    256色グレイスケール ノンインタレース

    256色グレイスケール インタレース

    65536色グレイスケール ノンインタレース（ただし，256色グレイスケールに減色されます）

    65536色グレイスケール インタレース（ただし，256色グレイスケールに減色されます）

    24ビットフルカラー ノンインタレース

    24ビットフルカラー インタレース

    48ビットフルカラー ノンインタレース（ただし，24ビットフルカラーに減色されます）

    48ビットフルカラー インタレース（ただし，24ビットフルカラーに減色されます）

    透明色指定

    上記の22フォーマット（色11種×インタレース2種）それぞれで透明色の有無の指定ができます。ただし，透明部分は，PNG画像中の背景色が使用されます。

    アニメーション

    上記の22フォーマット（色11種×インタレース2種）でアニメーション有の指定はできません。

    αチャネル指定

    αチャネルは指定しても無効になります。
■注意

画像が正しく出力されない場合，画像データの内容に問題があることがあります。このような場合は，画像を作成したソフトウェアとは別のソフトウェアで，画像を保存し直すことをお勧めします。

〈この節の構成〉

  • 4.5.1　画像ファイルの印刷・出力に関する注意事項

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 58 / 195


4.5.1 画像ファイルの印刷・出力に関する注意事項 : EUR システム設計ガイド

  • 59 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.5　EURで使用できる画像ファイル

  • 4.5.1　画像ファイルの印刷・出力に関する注意事項

4.5.1　画像ファイルの印刷・出力に関する注意事項

  • TIFF形式のモノクロ画像，およびGIF形式のモノクロ画像はカラープリンタがサポートしていない画像形式のため印刷できない場合があります。ただし，エラーにはなりません。

  • 256色以上のカラー画像を帳票上に貼り付けた場合，画像の色が実際の色と異なることがありますが，プリンタ出力では画像データで設定されている色に従って印刷されます。

  • 16色RLE圧縮と256色RLE圧縮のWindows BITMAP画像データが使用された帳票をEUR サーバ帳票出力機能で出力するとき，プリンタ印刷では出力できますが，次に示す場合には出力できません。

    • Windows環境でのPDF形式ファイル出力

    • UNIX／Linux環境でのプリンタ印刷，PDLファイル出力，およびPDF形式ファイル出力

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 59 / 195


4.6 EURで出力できる文字 : EUR システム設計ガイド

  • 60 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.6　EURで出力できる文字

4.6　EURで出力できる文字

EURでは，帳票を出力するファイルやプリンタによって，使用できる文字範囲が異なります。

出力形式ごとに，次に示す文字を出力できます。

〈この節の構成〉

  • 4.6.1　Windows対応プリンタ，EPF形式ファイル

  • 4.6.2　PDF形式ファイル

  • 4.6.3　PostScript対応プリンタ

  • 4.6.4　LIPSIII対応プリンタ

  • 4.6.5　ESC/P対応プリンタ

  • 4.6.6　Excel形式ファイル

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 60 / 195


4.6.1 Windows対応プリンタ，EPF形式ファイル : EUR システム設計ガイド

  • 61 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.6　EURで出力できる文字

  • 4.6.1　Windows対応プリンタ，EPF形式ファイル

4.6.1　Windows対応プリンタ，EPF形式ファイル

入力データがUnicodeの場合は，言語（OSのロケール）に関係なく，指定のフォントに従って文字を出力できます。※1

Unicode以外のマルチバイト文字の場合は，言語（OSのロケール）に従ったエンコード範囲の文字を出力できます。

外字は，出力環境に外字を定義することで，出力できるようになります。

例えば，次の文字集合の文字を出力できます。

  1. JISX0201:1997のローマ字，カタカナ

  2. JISX0208:1997

  3. NEC特殊文字のうちJISX0208，JISX0212に含まれない文字

  4. Windows31J-NEC特殊文字のうち，JISX0212に含まれる文字

  5. Windows31J-IBM拡張文字，NEC選定IBM拡張文字のうち，JISX0212に含まれない文字

  6. JISX0212

  7. UCS-2の私用領域（U+E000～U+F8FF）に定義されている6,400字※2

  8. JISX0213:2004

  9. GB18030:2000

  10. ISO 8859-1

  11. ISO 8859-15

  12. CP1252

注※1

結合文字列は正しく出力できません。

注※2

外字の出力については，「4.10　EURで使用できる外字」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 61 / 195


4.6.2 PDF形式ファイル : EUR システム設計ガイド

  • 62 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.6　EURで出力できる文字

  • 4.6.2　PDF形式ファイル

4.6.2　PDF形式ファイル

入力データがUnicodeの場合は，言語（OSのロケール）に関係なく，指定のフォントに従って文字を出力できます。※1

Unicode以外のマルチバイト文字の場合は，言語（OSのロケール）に従ったエンコード範囲の文字を出力できます。

外字などの一部の文字は，事前にフォント埋め込み指定やEURフォントファイルへの登録などの設定をしておくことで出力できるようなります。

次の文字集合の文字を出力できます。

  1. JISX0201:1997のローマ字，カタカナ

  2. JISX0208:1997

  3. NEC特殊文字のうちJISX0208，JISX0212に含まれない文字

  4. Windows31J-NEC特殊文字のうち，JISX0212に含まれる文字

  5. Windows31J-IBM拡張文字，NEC選定IBM拡張文字のうち，JISX0212に含まれない文字

  6. JISX0212

  7. UCS-2の私用領域（U+E000～U+F8FF）に定義されている6,400字※2

  8. JISX0213:2004

  9. GB18030:2000

  10. ISO 8859-1

  11. ISO 8859-15

  12. CP1252

上記以外の文字は，PDF形式ファイルにフォントを埋め込んで出力できます。フォントの埋め込みの詳細については，マニュアル「EUR 帳票出力 機能解説 EUR Server編」を参照してください。

注※1

結合文字列は正しく出力できません。

注※2

EURフォントファイルに文字を登録し，画像として出力します。EURフォントファイルを使用しない場合は，OSごとに作成した外字を出力することもできます（Linux環境の場合は，全角の空白に置き換えて出力します）。

EURフォントファイルについては，マニュアル「EUR システム構築ガイド」を参照してください。外字の出力については，「4.10　EURで使用できる外字」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 62 / 195


4.6.3 PostScript対応プリンタ : EUR システム設計ガイド

  • 63 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.6　EURで出力できる文字

  • 4.6.3　PostScript対応プリンタ

4.6.3　PostScript対応プリンタ

日本語のエンコード範囲の文字を出力できます。

外字などの一部の文字は，事前にEURフォントファイルやプリンタフォントへの登録などの設定をしておくことで出力できるようになります。

次の文字集合の文字を出力できます。

  1. JISX0201:1997のローマ字，カタカナ

  2. JISX0208:1997

  3. NEC特殊文字のうちJISX0208，JISX0212に含まれない文字

  4. Windows31J-NEC特殊文字のうち，JISX0212に含まれる文字

  5. Windows31J-IBM拡張文字，NEC選定IBM拡張文字のうち，JISX0212に含まれない文字

  6. JISX0212※1

  7. UCS-2の私用領域（U+E000～U+F8FF）に定義されている6,400字※1

  8. JISX0213:2004※2

注※1

JISX0212のうちWindows31Jに含まれない文字，およびUCS-2の私用領域（U+E000～U+F8FF）に定義されている6,400字については，EURフォントファイルに文字を登録し，画像として出力します。

EURフォントファイルを使用しない場合は，OSごとに作成した外字を出力することもできます（Linux環境の場合は，全角の空白に置き換えて出力します）。

EURフォントファイルについては，マニュアル「EUR システム構築ガイド」を参照してください。外字の出力については，「4.10　EURで使用できる外字」を参照してください。

注※2

UNIX／Linux環境の場合，日立のJISX0213:2004フォントを搭載したPostScript対応プリンタで出力できます。

JISX0213:2004フォントをプリンタに出力するためには，プリンタ定義ファイルにキーワードGenTextModeの指定が必要です。

プリンタ定義ファイルの設定の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 63 / 195


4.6.4 LIPSIII対応プリンタ : EUR システム設計ガイド

  • 64 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.6　EURで出力できる文字

  • 4.6.4　LIPSIII対応プリンタ

4.6.4　LIPSIII対応プリンタ

日本語のエンコード範囲の文字を出力できます。

外字などの一部の文字は，事前にEURフォントファイルへの登録などの設定をしておくことで出力できるようになります。

次の文字集合の文字を出力できます。

  1. JISX0201:1997のローマ字，カタカナ

  2. JISX0208:1997

  3. NEC特殊文字のうちJISX0208，JISX0212に含まれない文字

  4. Windows31J-NEC特殊文字のうち，JISX0212に含まれる文字

  5. JISX0212※

  6. UCS-2の私用領域（U+E000～U+F8FF）に定義されている6,400字※

注※

EURフォントファイルに文字を登録し，画像として出力します。

EURフォントファイルを使用しない場合は，OSごとに作成した外字を出力することもできます（Linux環境の場合は，全角の空白に置き換えて出力します）。

EURフォントファイルについては，マニュアル「EUR システム構築ガイド」を参照してください。外字の出力については，「4.10　EURで使用できる外字」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 64 / 195


4.6.5 ESC/P対応プリンタ : EUR システム設計ガイド

  • 65 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.6　EURで出力できる文字

  • 4.6.5　ESC/P対応プリンタ

4.6.5　ESC/P対応プリンタ

日本語のエンコード範囲の文字を出力できます。

外字などの一部の文字は，事前にEURフォントファイルへの登録の設定をしておくことで出力できるようになります。

次の文字集合の文字を出力できます。

  1. JISX0201:1997のローマ字，カタカナ※1

  2. JISX0208:1997※1

  3. Windows31J-NEC特殊文字のうち，JISX0212に含まれる文字※2

  4. JISX0212※2

  5. UCS-2の私用領域（U+E000～U+F8FF）に定義されている6,400字※2

注※1

環境変数や環境設定ファイルに指定した，ESC/P対応プリンタで使用するフォントファイルに登録されている文字のイメージを，画像処理で出力します。

注※2

EURフォントファイルに文字を登録し，画像として出力します。

EURフォントファイルを使用しない場合は，OSごとに作成した外字を出力することもできます（Linux環境の場合は，全角の空白に置き換えて出力します）。

EURフォントファイルについては，マニュアル「EUR システム構築ガイド」を参照してください。外字の出力については，「4.10　EURで使用できる外字」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 65 / 195


4.6.6 Excel形式ファイル : EUR システム設計ガイド

  • 66 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.6　EURで出力できる文字

  • 4.6.6　Excel形式ファイル

4.6.6　Excel形式ファイル

入力データがUnicodeの場合は，言語（OSのロケール）に関係なく，指定のフォントに従って文字を出力できます。※1，※2

Unicode以外のマルチバイト文字の場合は，言語（OSのロケール）に従ったエンコード範囲の文字を出力できます。

外字は，クライアント環境に外字を定義することで，出力できるようになります。

次の文字集合の文字を出力できます。

  1. JISX0201:1997のローマ字，カタカナ

  2. JISX0208:1997

  3. NEC特殊文字のうちJISX0208，JISX0212に含まれない文字

  4. Windows31J-NEC特殊文字のうち，JISX0212に含まれる文字

  5. Windows31J-IBM拡張文字，NEC選定IBM拡張文字のうち，JISX0212に含まれない文字

  6. JISX0212

  7. UCS-2の私用領域（U+E000～U+F8FF）に定義されている6,400字※3

  8. JISX0213:2004

  9. GB18030:2000

  10. ISO 8859-1

  11. ISO 8859-15

  12. CP1252

注※1

結合文字列は正しく出力できません。

注※2

フォントは言語ごとに固定です。詳細については，「9.2.3　Excel形式ファイルに出力する場合の注意」を参照してください。

注※3

外字の出力については，「4.10　EURで使用できる外字」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 66 / 195


4.7 EURで使用できるフォント : EUR システム設計ガイド

  • 67 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.7　EURで使用できるフォント

4.7　EURで使用できるフォント

〈この節の構成〉

  • 4.7.1　帳票作成時に使用できるフォント

  • 4.7.2　Windows環境のプリンタ出力時のフォント

  • 4.7.3　UNIX／Linux環境のプリンタ出力時のフォント

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 67 / 195


4.7.1 帳票作成時に使用できるフォント : EUR システム設計ガイド

  • 68 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.7　EURで使用できるフォント

  • 4.7.1　帳票作成時に使用できるフォント

4.7.1　帳票作成時に使用できるフォント

帳票作成時に使用できるフォントは，固定ピッチおよび可変ピッチ（プロポーショナル）のTrueTypeフォントです。

OCRフォントを使用して帳票を定義することもできます。ただし，EURで出力された帳票を光学式文字読み取り装置で読み取る場合は，ご使用になる光学式文字読み取り装置で，文字が読み取れるかどうかを確認してください。

縦書きのないフォントと縦書き配置を組み合わせた場合，正しく表示されないことがあります。

メイリオフォントの場合，縦書き配置を指定すると文字の出力位置がずれるため，縦書き配置を指定しないでください。

帳票を正しく表示または印刷するには，帳票で使用するフォントを，帳票を設計する環境と，帳票を表示または印刷する環境の両方に用意することをお勧めします。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 68 / 195


4.7.2 Windows環境のプリンタ出力時のフォント : EUR システム設計ガイド

  • 69 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.7　EURで使用できるフォント

  • 4.7.2　Windows環境のプリンタ出力時のフォント

4.7.2　Windows環境のプリンタ出力時のフォント

EUR サーバ帳票出力機能では，フォントを出力する際に文字幅を計算しています。

プロポーショナルフォントを出力するときは，フォントの文字幅を文字ごとに取得して計算します。固定ピッチフォントを出力するときは，プロポーショナルフォントを出力するときと同じ計算をする方法（動的モード），またはフォントの文字幅を固定値として計算する方法（静的モード）を指定できます。

ここでは文字幅の計算方法について説明します。

〈この項の構成〉

  • (1)　文字幅の計算方法

  • (2)　文字幅計算方法の設定

  • (3)　プリンタ出力でのフォントの出力結果

(1)　文字幅の計算方法

帳票アイテムのフォントおよび文字幅計算方法の指定によって，どのように文字幅が計算されるかを次に示します。

表4‒18 文字幅の計算方法
帳票アイテムのフォント | 文字幅計算方法の指定 | 文字幅の計算方法
プロポーショナルフォント | － | 使用するフォントに合わせて文字幅を計算します（動的モード）。
固定ピッチフォント | 動的
 | 静的※ | 固定値で文字幅を計算します（静的モード）。
（凡例）

－：文字幅計算方法の指定は適用されません。プロポーショナルフォントの場合は，常に動的モードとして計算されます。

注※

文字幅計算方法の指定を省略したときは，「静的」が仮定されます。

ページの先頭へ

(2)　文字幅計算方法の設定

EUR サーバ帳票出力機能での，文字幅計算方法の設定方法を次に示します。

(a)　文字幅計算方法の設定方法

環境変数EURPS_FONT_WIDTH_MODEで文字幅計算方法を設定します。設定方法の詳細についてはマニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

(3)　プリンタ出力でのフォントの出力結果

Window環境のプリンタに出力するときは，文字幅の計算方法と出力結果が次のように異なります。

  • 動的モードの場合

    帳票に指定されているフォントが帳票サーバの環境にあるときは，指定されたフォントで出力します。

    帳票に指定されているフォントが帳票サーバの環境にないときは，フォントを置き換えて出力します。詳細については，「4.8.2(2)　置き換えられて出力されるフォント」を参照してください。

  • 静的モードの場合

    帳票に指定されているフォントで出力します。しかし，帳票に指定されたフォントの文字幅と半角全角判定の文字幅が異なると，文字が重なったり離れたりして出力されることがあります。

    • EURで適用される半角全角判定の文字幅

      半角の文字幅はアイテムのフォント幅，全角の文字幅はアイテムのフォント幅の2倍で計算されます。

      半角全角判定の文字幅は，英語フォントではCourier，簡体字中国語フォントでは新宋体，繁体字中国語フォントでは細明体，日本語フォントではＭＳ 明朝の文字幅が適用されます。フォントの言語を判定できない場合は，中国語（簡体字）ロケールでは新宋体，日本語ロケールではＭＳ 明朝，その他のロケールではCourierの文字幅が適用されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 69 / 195


4.7.3 UNIX／Linux環境のプリンタ出力時のフォント : EUR システム設計ガイド

  • 70 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.7　EURで使用できるフォント

  • 4.7.3　UNIX／Linux環境のプリンタ出力時のフォント

4.7.3　UNIX／Linux環境のプリンタ出力時のフォント

〈この項の構成〉

  • (1)　プリンタと対応するフォント

  • (2)　半角全角判定の設定

  • (3)　フォントの置き換え結果

(1)　プリンタと対応するフォント

プリンタによって，出力できないフォントがあります。プリンタごとに対応するフォントを次に示します。

表4‒19 プリンタと対応するフォント
フォント | PostScript対応プリンタ | ESC/P対応プリンタ | LIPS対応プリンタ
欧文フォント(Courier)対応 | × | × | ×
簡体字中国語フォント対応 | × | × | ×
繁体字中国語フォント対応 | × | × | ×
日本語MS932出力(05-06以前の範囲) | ○ | ○ | ○
JISX0213:2004対応 | ○※ | × | ×
GB18030.2000(中国語)対応 | × | × | ×
（凡例）

○：出力できます。

×：出力できません。

注※

日立のJISX0213:2004フォントを搭載したPostScript対応プリンタで出力できます。

JISX0213:2004フォントをプリンタに出力するためには，プリンタ定義ファイルにキーワードGenTextModeの指定が必要です。

プリンタ定義ファイルの設定の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

(2)　半角全角判定の設定

バージョン05-06の帳票をバージョン05-08以降で開いた場合，フォントごとに半角全角判定が設定されていると，帳票の見た目が異なって表示されることがあります。半角全角判定は，EURPS_USE_05_06_FONT_LANGで設定します。EURPS_USE_05_06_FONT_LANGについては，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

(3)　フォントの置き換え結果

EUR 帳票作成機能で設計した帳票を，UNIX／Linux環境のプリンタ（PostScript，LIPSIII，およびESC/P対応プリンタ）に出力する場合は，次に示すフォントに置き換えて出力します。

  • PostScript対応プリンタに出力する場合

    次のフォントに置き換えます。

    ただし，文字幅計算方法の指定に「動的」を設定して，PostScript対応プリンタに出力した場合は，エラー（KEEU079-E）になります。

    フォントの置き換えに必要なプリンタ定義ファイルの設定の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

    表4‒20　 PostScript対応プリンタの帳票フォントに対応する出力フォント

    帳票に使用されているフォント

    出力時のフォント

    ＭＳ 明朝

    リュウミンL-KL

    MS Mincho

    HG行書体

    HG教科書体

    HG明朝B

    HG明朝E

    ＭＳ ゴシック

    中ゴシックBBB

    MS Gothic

    HGゴシックE

    HGゴシックM

    HG創英角ポップ体

    HG創英プレゼンスEB

    HG創英角ゴシックUB

    注　表にないフォントを使用している場合，「リュウミンL-KL」に置き換えて出力します。

  • LIPSIII対応プリンタに出力する場合

    次のフォントに置き換えます。

    表4‒21　 LIPSIII対応プリンタの帳票フォントに対応する出力フォント

    帳票に使用されているフォント

    出力時のフォント

    ＭＳ 明朝

    Mincho-Medium

    MS Mincho

    HG行書体

    HG教科書体

    HG明朝B

    HG明朝E

    ＭＳ ゴシック

    Gothic-Medium

    MS Gothic

    HGゴシックE

    HGゴシックM

    HG創英角ポップ体

    HG創英プレゼンスEB

    HG創英角ゴシックUB

    注　表にないフォントを使用している場合，「Mincho-Medium」に置き換えて出力します。

  • ESC/P対応プリンタに出力する場合

    表4‒22　 ESC/P対応プリンタの帳票フォントに対応する出力フォント

    帳票に使用されているフォント

    出力時のフォント

    ＭＳ 明朝

    明朝

    MS Mincho

    HG行書体

    HG教科書体

    HG明朝B

    HG明朝E

    ＭＳ ゴシック

    ゴシック

    MS Gothic

    HGゴシックE

    HGゴシックM

    HG創英角ポップ体

    HG創英プレゼンスEB

    HG創英角ゴシックUB

    注　表にないフォントを使用している場合，「明朝」に置き換えて出力します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 70 / 195


4.8 EURのPDF出力で使用できるフォント : EUR システム設計ガイド

  • 71 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.8　EURのPDF出力で使用できるフォント

4.8　EURのPDF出力で使用できるフォント

PDF出力では，欧文フォント，中国語フォント，および日本語フォントが使用できます。ただし，PDF形式ファイルを暗号化出力するときは，日本語ロケールでだけ正しく動作します。PDF形式ファイルを暗号化出力するときは，ロケールを日本語環境に設定してください。

帳票アイテムのフォント，フォント埋め込みの有無，および文字幅計算方法の指定によって，PDF形式ファイルへのフォントの出力方法は次のとおり異なります。なお，環境変数EURPS_USE_05_06_FONT_REPLACEにYESが設定されており，かつ「フォント縦横比を補正する」が設定されている文字列アイテムのフォントがＭＳ ゴシックでない場合，すべて「ＭＳ 明朝」で出力されます。

PDF形式ファイル出力の詳細については，マニュアル「EUR 帳票出力 機能解説 EUR Server編」を参照してください。

表4‒23 PDF形式ファイルへのフォントの出力方法の違い
帳票アイテムのフォント | フォント埋め込み | 文字幅計算方法の指定 | PDF形式ファイルへのフォントの出力方法
プロポーショナルフォント | なし | － | フォントの書体名称を出力※1
 | あり |  | フォントを埋め込んで出力
固定ピッチフォント | なし | 動的 | フォントの書体名称を出力※1
 |  | 静的 | フォントを置き換えて出力※2
 | あり | 動的 | フォントを埋め込んで出力
 |  | 静的
（凡例）

－：文字幅計算方法の指定は適用されません。プロポーショナルフォントの場合は常に動的モードとして計算されます。

注※1

出力できるフォントの詳細については，「4.8.2(2)　置き換えられて出力されるフォント」を参照してください。

注※2

07-60以前のEUR サーバ帳票出力機能でPDF形式ファイルを出力した場合と同じフォントに置き換えて出力します。詳細については，「4.8.1(4)　フォントの置き換え結果」を参照してください。

重要

EUR サーバ帳票出力機能で出力したPDF形式ファイルに縦書きの文字が含まれる場合，Adobe Reader 9で表示および印刷してください。Adobe Reader 9より前のバージョンで表示または印刷した場合，正しく表示または印刷されないことがあります。

〈この節の構成〉

  • 4.8.1　静的モード，または文字幅計算方法を指定しなかったときに置き換えて出力されるフォント

  • 4.8.2　動的モードで使用できるフォント

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 71 / 195


4.8.1 静的モード，または文字幅計算方法を指定しなかったときに置き換えて出力されるフォント : EUR システム設計ガイド

  • 72 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.8　EURのPDF出力で使用できるフォント

  • 4.8.1　静的モード，または文字幅計算方法を指定しなかったときに置き換えて出力されるフォント

4.8.1　静的モード，または文字幅計算方法を指定しなかったときに置き換えて出力されるフォント

この項では，文字幅計算方法の指定を「静的」，または指定しなかった場合に置き換えて出力されるフォントについて説明します。

〈この項の構成〉

  • (1)　使用できる欧文フォント

  • (2)　使用できる中国語フォント

  • (3)　使用できる日本語フォント

  • (4)　フォントの置き換え結果

  • (5)　注意事項

(1)　使用できる欧文フォント

フォントを置き換えて出力するとき，固定ピッチの欧文フォントを使用できます。

(a)　出力できる文字

Windows ANSIの文字を出力できます。Windows ANSI以外の文字については，空白に置き換えて出力します。

(b)　ラテン文字を使用した場合

ラテン補助文字のうち，日本語フォントでは全角となっている文字もラテン基本文字と同じ幅で出力します。

ページの先頭へ

(2)　使用できる中国語フォント

フォントを置き換えて出力するとき，中国語フォントを使用できます。

(a)　出力できる文字

  • 宋体の場合

    Adobe Technical Note #5079 30 November 2000「Adobe-GB1-4 Character Collection for CID-Keyed Fonts」文字集合の中のTechnical Note #5094「UniGB-UTF16-H/V」で規定される文字集合が出力できます。Unicode3.1 CJK拡張Aの文字をすべて含みます。

    中国語で全角の文字については全角で出力します。

  • 明体の場合

    Adobe Technical Note #5080 27 May 2003「Adobe-CNS1-4 Character Collection for CID-Keyed Fonts」文字集合の中のTechnical Note #5094「UniCNS-UTF16-H/V」で規定される文字集合が出力できます。

(b)　宋体で出力されるフォント

次のフォントは宋体で出力されます。

  • 新宋体(NSimSun) - simsun.ttc

  • 新宋体-18030(NSimSun-18030) - simsun18030.ttc

  • ほう宋_GB2312(FangSong_GB2312) - simfang.ttf

  • 楷体_GB2312(KaiTi_GB2312) - simkai.ttf

(c)　明体で出力されるフォント

次のフォントは明体で出力されます。

  • 細明体(MingLiU) - mingliu.ttc

  • 標楷体(DFKai-SB) - kaiu.ttf

(d)　ラテン文字を使用した場合

  • 宋体の場合

    ラテン基本文字は，Windowsの新宋体と字形が異なる場合があります。ラテン補助文字を使用した場合は，文字幅が不正に出力されるので，文字が重なって表示されることがあります。

  • 明体の場合

    ラテン基本文字は，Windowsで細明体と字形が異なる場合があります。

ページの先頭へ

(3)　使用できる日本語フォント

フォントを置き換えて出力するとき，JISX0213:2004文字集合の文字を使用できます。

MS932文字集合はCMAP名90ms-RKSJで，UniJIS-UTF16文字集合はCMAP名UniJIS-UTF16で出力します。MS932文字集合とUniJIS-UTF16文字集合が混在する帳票も作成できます。

(a)　出力できる文字

Adobe Technical Note #5078 11 June 2004「Adobe-Japan1-6 Character Collection for CID-Keyed Fonts」文字集合中のTechnical Note #5094「UniJIS-UTF16-H/V」で規定された文字集合が出力できます。Unicode3.1 CJK拡張Aの文字をすべて含みます。

(b)　ラテン補助文字を使用した場合

ラテン補助文字を使用した場合は，文字幅が不正に出力されるので，文字が重なって表示されることがあります。

ページの先頭へ

(4)　フォントの置き換え結果

EUR 帳票作成機能で設計した帳票を，フォントを置き換えてPDF形式ファイルに出力する場合，次に示すフォントに置き換えて出力します。

  • PDF形式ファイルに出力する場合

    表4‒24　 帳票フォントに対応する出力フォント

    帳票に使用されているフォント

    出力時のフォント

    ＭＳ 明朝

    Mincho

    MS Mincho

    ＭＳ Ｐ明朝

    MS PMincho

    HG行書体

    HG教科書体

    HG明朝B

    HG明朝E

    ＭＳ ゴシック

    Gothic

    MS Gothic

    ＭＳ Ｐゴシック

    MS PGothic

    HGゴシックE

    HGゴシックM

    HG創英角ポップ体

    HG創英プレゼンスEB

    HG創英角ゴシックUB

    メイリオ

    Meiryo

    Arial Unicode MS

    新宋体

    Song

    NSimSun

    新宋体-18030

    NSimSun-18030

    宋体

    SimSun

    ほう宋_GB2312

    FangSong_GB2312

    ほう宋

    FangSong

    楷体_GB2312

    KaiTi_GB2312

    楷体

    KaiTi

    細明体

    Ming

    MingLiU

    新細明体

    PMingLiU

    標楷体

    DFKai-SB

    Courier New

    Courier

    Lucida Console

    Lucida Sans Typewriter

    OCRB

    Arial

    Times New Roman

    Microsoft Sans Serif

    Tahoma

    Segoe UI

    注　表にないフォントを使用している場合，ロケールによって次のフォントに置き換えて出力します。

    • 英語ロケールで実行した場合

      「Courier」に置き換えて出力します。

    • 中国語ロケールで実行した場合

      「Song」に置き換えて出力します。

    • 日本語ロケールで実行した場合

      「Mincho」に置き換えて出力します。

ページの先頭へ

(5)　注意事項

静的モードでPDF形式ファイルを出力する場合，欧文フォントやOCRBフォントなどの縦横比が2：1以外のフォントを指定するときは，文字配置の設定に桁数を指定しないでください。

EUR 帳票作成機能で帳票を作成するとき，［アイテムのプロパティ］ダイアログの［文字配置］タブで［桁数を指定］チェックボックスをオンにした場合，文字の出力位置がずれて，PDF形式ファイルに正しく出力できません。

［アイテムのプロパティ］ダイアログの［文字配置］タブについては，マニュアル「EUR 帳票作成 画面リファレンス」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 72 / 195


4.8.2 動的モードで使用できるフォント : EUR システム設計ガイド

  • 73 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.8　EURのPDF出力で使用できるフォント

  • 4.8.2　動的モードで使用できるフォント

4.8.2　動的モードで使用できるフォント

文字幅計算方法の指定を「動的」にした場合，フォント埋め込みの有無によって，書体名称を出力したり，フォントを埋め込んで出力したりします。

ここでは，フォントの書体名称を出力する場合，またはフォントを埋め込んで出力する場合に使用できるフォントについて説明します。

なお，文字幅の計算方法はプリンタ出力の場合と同じです。詳細は，「4.7.2　Windows環境のプリンタ出力時のフォント」を参照してください。

〈この項の構成〉

  • (1)　そのまま出力されるフォント

  • (2)　置き換えられて出力されるフォント

  • (3)　フォントの書体名称を出力した場合の注意事項

(1)　そのまま出力されるフォント

次に示すフォントが帳票に指定されている場合，帳票に指定されたフォントがそのまま出力されます。

  • ＭＳ 明朝

  • ＭＳ ゴシック

  • ＭＳ Ｐ明朝

  • ＭＳ Ｐゴシック

  • メイリオ

  • MingLiU

  • NSimSun

  • PmingLiU

  • SimSun

  • Courier

  • Times New Roman

  • Arial

  • Arial Unicode MS

  • Microsoft Sans Serif

  • Tahoma

  • Segoe UI

また，Windows環境でプリンタ出力する場合は，出力環境にあるフォントも出力できます。

ページの先頭へ

(2)　置き換えられて出力されるフォント

「(1)　そのまま出力されるフォント」以外のフォントが帳票に指定されている場合，ロケールやフォントの種類によって，次に示すフォントが置き換えられて出力されます。

表4‒25 置き換えられて出力されるフォント
ロケール | フォントの種類 | 出力されるフォント
日本語 | 固定ピッチフォント | ＭＳ 明朝
 | プロポーショナルフォント | ＭＳ Ｐ明朝
中国語（簡体字） | 固定ピッチフォント | NSimSun
 | プロポーショナルフォント | SimSun
その他 | 固定ピッチフォント | Courier New
 | プロポーショナルフォント | Arial

ページの先頭へ

(3)　フォントの書体名称を出力した場合の注意事項

フォントの書体名称を出力した場合の注意事項を説明します。

(a)　印刷・表示環境にインストールが必要なフォント

フォントの書体名称を出力した場合，印刷・表示環境にフォントがインストールされている必要があります。フォントを埋め込んで出力した場合は，印刷・表示環境にフォントがインストールされている必要はありません。フォント埋め込みの有無によるPDF形式ファイルの表示・印刷結果の違いを，次に示します。

表4‒26 PDF形式ファイル出力のフォントの埋め込み
フォント埋め込み | 印刷・表示環境でのPDF形式ファイルのフォント | PDF形式ファイルの表示・印刷結果
なし | あり | PDF形式ファイル出力時のフォントで表示・印刷されます。
 | なし | 正しく表示・印刷できません。
あり | あり | PDF形式ファイルに埋め込んだフォントで表示・印刷されます。
 | なし

なお，フォントを埋め込まない場合，PDF形式ファイルのファイルサイズはフォントを埋め込んだ場合に比べて小さくなります。

(b)　フォントパッケージのインストールが必要なフォント

次に示すフォントで表示・印刷してください。

  • メイリオ

  • MingLiU

  • NSimSun

  • PmingLiU

  • SimSun

  • Microsoft Sans Serif

  • Tahoma

  • Segoe UI

(c)　Arial Unicode MSを表示・印刷する場合の環境

Arial Unicode MSを表示・印刷する場合は，Microsoft Office 2007に標準で搭載されているフォント情報を利用するため，Microsoft Office 2007をインストールしておく必要があります。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 73 / 195


4.9 EURのEPF出力および帳票の蓄積で使用できるフォント : EUR システム設計ガイド

  • 74 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.9　EURのEPF出力および帳票の蓄積で使用できるフォント

4.9　EURのEPF出力および帳票の蓄積で使用できるフォント

EURのEPF出力および帳票の蓄積では，帳票サーバのOSによってフォントの出力結果が異なります。

〈この節の構成〉

  • 4.9.1　Windows環境

  • 4.9.2　UNIX／Linux環境

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 74 / 195


4.9.1 Windows環境 : EUR システム設計ガイド

  • 75 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.9　EURのEPF出力および帳票の蓄積で使用できるフォント

  • 4.9.1　Windows環境

4.9.1　Windows環境

帳票サーバがWindows環境の場合，文字幅の計算方法によって，出力結果が次のように異なります。

なお，帳票アイテムのフォントがプロポーショナルフォントのときは，常に動的モードとして処理されます。

〈この項の構成〉

  • (1)　動的モードの場合

  • (2)　静的モードの場合

(1)　動的モードの場合

帳票に指定されているフォントがEURサーバ環境にあるときは，指定されたフォントで出力します。

帳票に指定されているフォントが出力環境にないときは，フォントを置き換えて出力します。

詳細については，「4.8.2　動的モードで使用できるフォント」を参照してください。

ページの先頭へ

(2)　静的モードの場合

帳票に指定されているフォントで出力します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 75 / 195


4.9.2 UNIX／Linux環境 : EUR システム設計ガイド

  • 76 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.9　EURのEPF出力および帳票の蓄積で使用できるフォント

  • 4.9.2　UNIX／Linux環境

4.9.2　UNIX／Linux環境

帳票サーバがUNIX／Linux環境の場合，文字幅の計算方法によって，出力結果が次のように異なります。

なお，帳票アイテムのフォントがプロポーショナルフォントのときは，常に動的モードとして処理されます。

〈この項の構成〉

  • (1)　動的モードの場合

  • (2)　静的モードの場合

(1)　動的モードの場合

フォントを置き換えて出力します。

詳細については，「4.8.2　動的モードで使用できるフォント」を参照してください。

ページの先頭へ

(2)　静的モードの場合

帳票に指定されているフォントで出力します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 76 / 195


4.10 EURで使用できる外字 : EUR システム設計ガイド

  • 77 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.10　EURで使用できる外字

4.10　EURで使用できる外字

EURでは，外字を定義したファイルを指定して外字を出力できます。

Windows環境の場合は，EUR サーバ帳票出力機能で外字ファイル（*.tte）を指定すれば，特定のフォントにリンクした状態で保存した外字も，すべてのフォントで印刷できます。また，外字ファイルを差し替えて，別の外字を出力することもできます。

支社ごとに作成した外字ファイルを使用して，同じ帳票に別の外字を出力するイメージを次の図に示します。

図4‒1　同じ帳票に別の外字を出力するイメージ（Windows環境の場合）

[図データ]

また，EURフォントファイルを使用することで，Windows環境で作成した外字をUNIX／Linux環境でも使用できるようになります。

なお，欧文フォントを指定する場合は，外字を使用しないでください。

〈この節の構成〉

  • 4.10.1　プリンタでの印刷，およびPDF形式ファイル出力での外字の使用方法

  • 4.10.2　EPF形式ファイル，およびExcel形式ファイル出力での外字の使用方法

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 77 / 195


4.10.1 プリンタでの印刷，およびPDF形式ファイル出力での外字の使用方法 : EUR システム設計ガイド

  • 78 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.10　EURで使用できる外字

  • 4.10.1　プリンタでの印刷，およびPDF形式ファイル出力での外字の使用方法

4.10.1　プリンタでの印刷，およびPDF形式ファイル出力での外字の使用方法

プリンタで印刷したり，PDF形式ファイルに出力したりする場合の外字の使用方法は，OSごとに異なります。

OSごとの外字の使用方法を説明します。

〈この項の構成〉

  • (1)　Windows環境での外字の使用方法

  • (2)　UNIX／Linux環境での外字の使用方法

(1)　Windows環境での外字の使用方法

Windows環境で外字を含む帳票を出力するには，次の2種類の方法があります。

  • 外字ファイルを使用する

  • EURフォントファイルを使用する（PDF形式ファイル出力の場合だけ）

(a)　外字ファイルを使用する

次のどちらかの方法で出力する場合，外字ファイル（*.tte）を環境変数「EURPS_GAIJIFONT」に指定して外字を出力できます。外字ファイルは帳票サーバに準備してください。

  • 帳票サーバに登録されたプリンタに出力する

  • PDF形式ファイルに出力する

PDF形式ファイルに出力する場合も，外字ファイルはPDFを作成する環境（帳票サーバ）だけに必要です。PDF形式ファイルには，外字は画像として埋め込まれるため，クライアント環境にPDF形式ファイルを転送しても，外字の閲覧，印刷ができます。

外字ファイルを使用して，外字を含む帳票をPDF形式ファイルに出力する場合のイメージを次の図に示します。

図4‒2　外字ファイルを使用した外字の出力（PDF形式ファイル出力）

[図データ]

なお，外字ファイルを使用しない場合はWindows標準外字を使用することもできますが，正しく出力されなかったり，サービスから使用できなかったりすることがあります。

■注意

  • 帳票をPDF形式ファイルに出力した場合，外字は画像としてPDF形式ファイル中に埋め込むので，外字の検索と複写はできません。

  • ベンダ定義文字は，プリンタドライバで「TrueTypeをプリンタフォントで置き換える」が設定されていると，プリンタによってはベンダ定義文字が正しく印刷されないことがあります。この場合は，TrueTypeで出力するように設定してください。

メモ

環境変数「EURPS_GAIJIFONT」を指定すれば，Windowsをログオフした環境でも外字を出力できます。

(b)　EURフォントファイルを使用する

PDF形式ファイルに出力する場合，EURフォントファイルを使用して外字を出力できます。

EURフォントファイル（*.edf）は，Windows環境の外字をUNIX／Linux環境でも出力できるようにするためのファイルです。Windows環境でもPDF形式ファイル出力の場合だけ，Windows環境でも使用できます。EURフォントファイルの作成時には，指定した文字が画像として収録されます。

EURフォントファイルを使用して，外字を含む帳票をPDF形式ファイル出力する場合のイメージを次の図に示します。なお，図中では例としてEUR 帳票作成機能を使用しています。

図4‒3　EURフォントファイルを使用した外字の出力（PDF形式ファイル出力）

[図データ]

EURフォントファイルの作成には，EURフォントファイル作成ツール（expedf32コマンド）を使用します。EURフォントファイルの作成方法については，マニュアル「EUR システム構築ガイド」を参照してください。

■EURフォントファイルの使用方法

作成したEURフォントファイルを使用する場合，使用するEURフォントファイルを次に示す環境変数に指定する必要があります。

  • EURPS_PDL_EXMINFONTPATH

    明朝体用として作成したEURフォントファイル名（*.edf）をフルパスで指定します。

  • EURPS_PDL_EXGOTFONTPATH

    ゴシック体用として作成したEURフォントファイル名（*.edf）をフルパスで指定します。

■EURフォントファイルについての注意事項

  • PDF形式ファイル出力でEURフォントファイルを使用する場合，出力される文字にボールド属性は適用されません。

  • 出力する文字がEURフォントファイルに収録されていない場合は，「　（全角空白）」を出力します。

  • 環境変数「EURPS_GAIJIFONT」で外字ファイル（*.tte）を指定した場合は，EURフォントファイルの指定が優先されます。

  • EURフォントファイルは，ローカルディスクに保存してください。

  • EURフォントファイルが読み込めない，またはメモリが不足すると，エラーになります。制限値を使用するEURフォントファイルのサイズに合わせて拡張してから，再度実行してください。

  • PDF形式ファイル出力中にエラーが発生した場合，次に示すエラーが表示されます。

    KEEU101-E PDF変換中にエラーが発生しました。

ページの先頭へ

(2)　UNIX／Linux環境での外字の使用方法

UNIX／Linux環境で外字を含む帳票を出力するには，次の2種類の方法があります。

  • EURフォントファイルを使用する

  • OSの外字システムを使用する（UNIX環境だけ）

(a)　EURフォントファイルを使用する

EURフォントファイルを使用してWindows環境の外字をUNIX／Linux環境で出力できます。

EURフォントファイル（*.edf）は，Windows環境で作成した外字をUNIX／Linux環境で出力できるように変換したものです。EURフォントファイルの作成時には，指定した文字が画像として収録されます。

外字ファイルに登録された外字をEURフォントファイルに収録して，UNIX／Linux環境でプリンタ出力する場合のイメージを次の図に示します。なお，図中では例としてEUR 帳票作成機能を使用しています。

図4‒4　EURフォントファイルを使用した外字の出力（プリンタ出力）

[図データ]

EURフォントファイルの作成には，EURフォントファイル作成ツール（expedf32コマンド）を使用します。EURフォントファイルの作成方法については，マニュアル「EUR システム構築ガイド」を参照してください。

■EURフォントファイルの使用方法

作成したEURフォントファイルを使用する場合，使用するEURフォントファイルを次に示す環境変数に指定する必要があります。

  • EURPS_PDL_EXMINFONTPATH

    明朝体用として作成したEURフォントファイル名（*.edf）をフルパスで指定します。

  • EURPS_PDL_EXGOTFONTPATH

    ゴシック体用として作成したEURフォントファイル名（*.edf）をフルパスで指定します。

■EURフォントファイルについての注意事項

  • EURフォントファイルを使用する場合，出力される文字については出力先別に次の制限があります。

    PDF：ボールド属性は適用されません。

    PostScript：ボールド属性は適用されません。

    LIPS：ボールド属性，イタリック属性は適用されません。

    ESC/P：ボールド属性，イタリック属性は適用されません。

  • 出力する文字がEURフォントファイルに収録されていない場合は，「　（全角空白）」を出力します。

  • 環境変数「EURPS_GAIJIFONT」でOSごとに用意された外字を定義したフォントファイル（*.pcf）を指定した場合は，EURフォントファイルの指定が優先されます。

  • EURフォントファイルは，ローカルディスクに保存してください。

  • EURフォントファイルが読み込めない，またはメモリが不足すると，エラーになります。制限値を使用するEURフォントファイルのサイズに合わせて拡張してから，再度実行してください。

  • プリンタ出力中またはPDF形式ファイル出力中にエラーが発生した場合，次に示すエラーが表示されます。

    プリンタ出力の場合

    KEEU102-E 印刷処理中にエラーが発生しました。

    PDF形式ファイル出力の場合

    KEEU101-E PDF変換中にエラーが発生しました。

(b)　OSの外字システムを使用する（UNIX環境だけ）

OSの外字システムで定義した外字を出力できます。ただし，Linux環境では外字を使用できません。

また，私用領域のうち，外字が定義されていない符号位置を指定した場合は，「　（全角空白）」を出力します。

外字システムでの外字の定義方法は次のとおりです。

  • AIX環境の場合

    AIX外字ツール（fontutilコマンド）を使用して，24×24ドットの外字パターンを定義します。AIX外字ツールについては，AIX環境での外字の登録方法が記載されているマニュアルなどを参照してください。

    AIXの場合，作成したフォントファイル（*.pcf）を，EUR サーバ帳票出力機能で使用できるように非圧縮形式に解凍したあと，環境変数「EURPS_GAIJIFONT」にフルパスで指定することで使用できます。

  • HP-UX環境の場合

    HP-UX外字ツール（xudcedコマンド）を使用して，24×24ドットの外字パターンを定義します。HP-UX外字ツールについては，HP-UX環境での外字の登録方法が記載されているマニュアルなどを参照してください。

    作成されたudcファイルをフォントファイル（*.pcf）にマージしたあと，マージしたファイルを環境変数「EURPS_GAIJIFONT」にフルパスで指定することで使用できます。

■注意

  • 帳票をPDF形式ファイルに出力した場合は，外字は画像としてPDF形式ファイル中に埋め込むので，外字の検索と複写はできません。

  • Shift JISロケール環境で実行する場合，ベンダ定義文字はコードで出力されますので，プリンタによって，正しく印刷されないことがあります。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 78 / 195


4.10.2 EPF形式ファイル，およびExcel形式ファイル出力での外字の使用方法 : EUR システム設計ガイド

  • 79 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.10　EURで使用できる外字

  • 4.10.2　EPF形式ファイル，およびExcel形式ファイル出力での外字の使用方法

4.10.2　EPF形式ファイル，およびExcel形式ファイル出力での外字の使用方法

EPF形式ファイル，およびExcel形式ファイルに出力する場合の外字の定義方法は，プリンタでの印刷，およびPDF形式ファイル出力の場合と同じです。ただし，出力した帳票をクライアント環境に転送するときには，クライアント環境のWindows標準外字ファイル（EUDC.TTE）の同じコードに同じ外字を定義する必要があります。クライアント環境のWindows標準外字ファイル（EUDC.TTE）の同じコードに別の外字を定義すると，クライアント環境では別の外字が表示・印刷されてしまいます。

帳票をEPF形式ファイルに出力する場合を例に，クライアント環境のWindows標準外字ファイル（EUDC.TTE）に別の外字が定義されたときのイメージを次の図に示します。

図4‒5　帳票をEPF形式ファイルに出力する場合（クライアント環境のWindows標準外字ファイル（EUDC.TTE）に別の外字が定義されたとき）

[図データ]

なお，EPF形式ファイル，およびExcel形式ファイルに出力する場合に使用できる外字については，「4.6　EURで出力できる文字」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 79 / 195


4.11 UnicodeのIVS対応 : EUR システム設計ガイド

  • 80 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.11　UnicodeのIVS対応

4.11　UnicodeのIVS対応

〈この節の構成〉

  • 4.11.1　IVSとは

  • 4.11.2　帳票出力時の異体字セレクタの扱い

  • 4.11.3　IVSの対応範囲

  • 4.11.4　注意事項

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 80 / 195


4.11.1 IVSとは : EUR システム設計ガイド

  • 81 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.11　UnicodeのIVS対応

  • 4.11.1　IVSとは

4.11.1　IVSとは

同じ意味の漢字文字の異体字（字形が異なる字）を表現できる仕組みで，ISO/IEC 10646で規定されているUnicodeで実装されています。漢字（基底文字）を表すコードの直後に，異体字セレクタと呼ばれるコードを付加することで，その漢字の異体字を表現します。

また，漢字を表すコードを基底文字と呼び，基底文字と異体字セレクタを並べた文字符号列を「IVS」（Ideographic Variation Sequence）と呼びます。IVS（基底文字+異体字セレクタ）の文字コードは，「U+hhhh;U+E01hh」（hは16進数）の形式で表現します。

異体字セレクタによって，同一文字コードの漢字文字（基底文字）の異体字（基底文字+異体字セレクタ）を表現する例を次に示します。ここでは，IPAmj明朝フォントを使用した場合の「葛」（U+845B）の例を示します。

■基底文字「葛」の異体字（基底文字+異体字セレクタ）の例

  • 基底文字（U+845B;異体字セレクタなし）

  • 基底文字+異体字セレクタ（U+845B;U+E102）※

注※

異体字セレクタのコード，および使用するフォントによって，ほかの異体字も存在します。

基底文字と基底文字+異体字セレクタは，文字の意味で分けた場合は同じ文字を差しますが，文字の字形で分けた場合は異なる文字となります。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 81 / 195


4.11.2 帳票出力時の異体字セレクタの扱い : EUR システム設計ガイド

  • 82 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.11　UnicodeのIVS対応

  • 4.11.2　帳票出力時の異体字セレクタの扱い

4.11.2　帳票出力時の異体字セレクタの扱い

EUR Serverでは，文字コードがUTF-8またはUTF-16で，IVSの異体字に対応しているフォント（IPAmj明朝フォントなど）を使用している場合，Windows環境の帳票サーバでの印刷およびEPF形式ファイル出力で，UnicodeのIVS（基底文字+異体字セレクタ）で表現される漢字文字の異体字に対応しています。

〈この項の構成〉

  • (1)　文字間隔

  • (2)　桁数

  • (3)　折り返し位置

  • (4)　任意書式

  • (5)　区切り

(1)　文字間隔

  • 10-20より前のバージョンの場合

    異体字セレクタを1文字として扱います。この場合，異体字セレクタは空白で印字または出力されます。

  • 10-20以降のバージョンの場合

    異体字セレクタを含めて1文字として扱います（異体字セレクタは文字間隔に影響しません）。

ページの先頭へ

(2)　桁数

  • 10-20より前のバージョンの場合

    異体字セレクタを1文字として扱います。

  • 10-20以降のバージョンの場合

    異体字セレクタを含めて1文字として扱います（異体字セレクタは桁数に影響しません）。

ページの先頭へ

(3)　折り返し位置

  • 10-20より前のバージョンの場合

    基底文字と異体字セレクタの間に折り返しが存在する場合，異体字セレクタの前で折り返しを行います。この場合，異体字セレクタは，折り返した行の先頭文字となり，空白や「□」などで印字または出力されます（フォントが不正な文字を指定した場合と同様です）。印字または出力される文字は，使用しているフォントに依存します。

  • 10-20以降のバージョンの場合

    基底文字と異体字セレクタの間に折り返しが存在する場合，異体字セレクタを含めて1文字として扱い，異体字セレクタの後ろで折り返しを行います（異体字セレクタは折り返し位置に影響しません）。

ページの先頭へ

(4)　任意書式

  • 10-20より前のバージョンの場合

    任意書式を指定した書式記号から印字する文字を置換する場合，異体字セレクタを1文字として扱います。この場合，異体字セレクタは空白で印字または出力されます。

  • 10-20以降のバージョンの場合

    任意書式を指定した書式記号から印字する文字を置換する場合，異体字セレクタを含めて1文字として扱います（異体字セレクタは任意書式に影響しません）。

ページの先頭へ

(5)　区切り

  • 区切り文字（CSV形式）

    異体字セレクタは区切り文字に影響しません。

  • 区切り位置（FIX形式）

    IVS（基底文字+異体字セレクタ）などの文字コードの長さが，見た目のデータの長さと異なる場合も考慮した上で，すべてのレコードの，フィールドの開始位置とデータ長が固定となるデータを作成してください。作成したデータが想定しているデータ長を超えると，意図しない文字が印字または表示される場合があります。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 82 / 195


4.11.3 IVSの対応範囲 : EUR システム設計ガイド

  • 83 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.11　UnicodeのIVS対応

  • 4.11.3　IVSの対応範囲

4.11.3　IVSの対応範囲

EUR Serverでは，文字コードがUTF-8またはUTF-16で，IVSの異体字に対応しているフォント（IPAmj明朝フォントなど）を使用している場合，Windows環境での印刷およびEPF形式ファイル出力などで異体字に対応しています。

〈この項の構成〉

  • (1)　サーバ環境での動作

  • (2)　クライアント環境での動作

(1)　サーバ環境での動作

EUR サーバ帳票出力機能でのIVSの異体字の動作を次に示します。

(a)　入力

次に示す範囲で異体字の入力に対応しています。

  • 帳票上の固定文字の文字列

  • データファイル中で帳票上の文字データとして扱われる文字列

  • 上記の文字列との比較または置き換えに使用される文字列（アイテムの表示条件，置き換えデータ，スプールデータのEPF形式ファイル名での検索など）

(b)　出力

Windows環境の場合，次に示す範囲で異体字の出力に対応しています。

■印刷

  • Windows対応プリンタでの出力

■ファイル出力

  • EPF形式ファイル

    • ファイル出力※1

    • EPF形式ファイルの印刷※2

    • EPF形式ファイルの表示※2

  • EUR形式ファイル

    • ファイル出力※1

    • EUR形式ファイルの印刷（EUR サーバ帳票出力機能）※2

  • PDF形式ファイル

    • ファイル出力（フォント埋め込み）※1, ※3

注※1

IVSに対応するフォント（IPAmj明朝フォントなど）が必要です。

注※2

ファイル出力時に使用したIVSに対応するフォント（IPAmj明朝フォントなど）が必要です。

注※3

  • 異体字を埋め込んだPDF形式ファイルの表示および印刷時に，異体字に対応するフォントは不要です。

  • PDF形式ファイルに埋め込んだ異体字の検索は，Adobe Readerの機能に従います。

  • スプールデータからファイル取得したPDF形式ファイルは，IVSの異体字に対応していません。

ページの先頭へ

(2)　クライアント環境での動作

EUR 帳票作成機能およびEUR クライアント帳票出力機能でのIVSの異体字の動作を次に示します。

(a)　入力

文字コードがUTF-8またはUTF-16で，異体字に対応しているフォント（IPAmj明朝フォントなど）を使用している場合，異体字を入力して表示できることがあります。

(b)　出力

クライアント環境での帳票の印刷およびファイル出力は，IVSの異体字に対応していません。

EUR 帳票作成機能およびEUR クライアント帳票出力機能（apgrptコマンド，eurerコマンド）では，IVSの異体字セレクタが1文字としてカウントされ，異体字セレクタが空白で印字または出力されます。

IVSの異体字に対応したフォント（IPAmj明朝フォントなど）を使用している場合，IVSの異体字は印字または出力されますが，異体字の後ろに空白が印字または出力されます。IVSの異体字に対応したフォントを使用していない場合は，異体字の代わりに基底文字が印字または出力されます。

異体字の後ろに空白が出力される例を次に示します。ここでは，IPAmj明朝フォントを使用した場合の例を示します。

■基底文字「葛」の異体字（基底文字+異体字セレクタ）の出力例

  • 入力文字列

  • 出力文字列

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 83 / 195


4.11.4 注意事項 : EUR システム設計ガイド

  • 84 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.11　UnicodeのIVS対応

  • 4.11.4　注意事項

4.11.4　注意事項

IVS（基底文字+異体字セレクタ）で表現される漢字文字の異体字を，印刷またはファイル出力する場合は，異体字セレクタに対応したフォント（IPAmj明朝フォントなど）を使用してください。対応するフォントが存在しない場合は正しく表示されません。

メモ

IVSの字形一覧は，UnicodeコンソーシアムからIVD（Ideographic Variation Database）として公開されています。IVDには，IVSを利用する社会や目的ごとに，区別すべき字形とIVSの対応関係の集合（コレクション）が登録されています。コレクションごとに異体字セレクタのコード範囲が異なっており，IVSを利用できるフォントごとに対応するコレクションが異なります。

IVSを利用できるフォントと対応するコレクションの対応，コレクションと異体字セレクタのコード範囲の例を次に示します。

表4‒27　IVSを利用できるフォントと対応するコレクション

フォント

対応するコレクション

IPAexフォント

Adobe-Japan1

IPAmj明朝フォント

Hanyo-Denshi，Moji_Joho
表4‒28　コレクションと異体字セレクタのコードの範囲（基底文字「葛」の場合）

コレクション

異体字セレクタのコードの範囲

Adobe-Japan1

U+E0100～U+E0101

Hanyo-Denshi

U+E0102～U+E0109

Moji_Joho

U+E0102～U+E0108

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 84 / 195


4.12 UNIX／Linux環境のプリンタに出力するときの注意 : EUR システム設計ガイド

  • 85 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.12　UNIX／Linux環境のプリンタに出力するときの注意

4.12　UNIX／Linux環境のプリンタに出力するときの注意

帳票をUNIX／Linux環境のプリンタに出力するときの注意事項を次に示します。

〈この節の構成〉

  • 4.12.1　LIPSIII対応プリンタに出力するときの注意

  • 4.12.2　PostScript対応プリンタに出力するときの注意

  • 4.12.3　ESC/P対応プリンタに出力するときの注意

  • 4.12.4　PDLファイルに出力するときの注意

  • 4.12.5　印刷先プリンタをBSDシステムと接続したときのジョブ制限

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 85 / 195


4.12.1 LIPSIII対応プリンタに出力するときの注意 : EUR システム設計ガイド

  • 86 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.12　UNIX／Linux環境のプリンタに出力するときの注意

  • 4.12.1　LIPSIII対応プリンタに出力するときの注意

4.12.1　LIPSIII対応プリンタに出力するときの注意

UNIX／Linux対応のLIPSIII対応プリンタに出力するとき，次に示す制限事項があります。

  • LIPSIV対応プリンタで出力しても，次に示すようにLIPSIII対応プリンタの機能範囲で印刷されます。

    • LIPSIVのカラープリンタに印刷しても，モノクロで印刷されます。

    • UNIX／Linux対応のプリンタに指定できる給紙トレイは，2段までです。そのため，出力先が3段以上の給紙トレイを持つプリンタであっても，給紙トレイ番号は1と2だけが有効です。

      また，給紙トレイ番号に3以上の値を指定した場合は，常に自動給紙となります。

    • 出力するLIPSIV対応プリンタが両面印刷できても，LIPSIII対応プリンタの機能範囲では両面印刷できません。

  • カラー指定の帳票を印刷する場合，モノクロ2値に変換して印刷されます。文字は，黒色で印刷されます。

  • 外字は，常に標準で印刷されます。外字にボールド体やイタリック体が指定されていても，標準で印刷されます。

  • JIS X 0208 1983コードだけに対応しているため，IBM拡張文字（0xFA40～0xFCFC），NEC選定IBM拡張文字（0xED40～0xEEFC）などのベンダ定義文字は印刷されません。

  • ゴシックフォントを搭載していないプリンタでは，文字をゴシックに指定しても正しく印刷されません。

  • 点線は，実線で印刷されます。

  • 実線以外の線種で，線幅に細線以外を指定している場合は，指定した線幅の実線で出力されます。帳票定義時に指定できる線幅を次に示します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 86 / 195


4.12.2 PostScript対応プリンタに出力するときの注意 : EUR システム設計ガイド

  • 87 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.12　UNIX／Linux環境のプリンタに出力するときの注意

  • 4.12.2　PostScript対応プリンタに出力するときの注意

4.12.2　PostScript対応プリンタに出力するときの注意

UNIX／Linux対応のPostScript対応プリンタに出力するとき，次に示す制限事項があります。

  • PostScript対応プリンタに出力する場合は，Adobe PostScript バージョン2015以降，および次に示す書体を搭載しているプリンタをご使用ください。

    • リュウミンL-KL（Ryumin-Light-90ms-RKSJ-H，Ryumin-Light-90ms-RKSJ-V）

    • 中ゴシックBBB（GothicBBB-Medium-90ms-RKSJ-H，GothicBBB-Medium-90ms-RKSJ-V）

  • 外字への文字のスタイル指定は，イタリック（斜字）だけ有効です。ボールド（太字）を指定して印刷しても，標準スタイルで印刷されます。

  • 文字幅計算方法に動的を指定して出力した場合，エラーになります。

  • 給紙トレイ番号を指定して帳票を印刷する場合，編集時の帳票の用紙サイズと異なる給紙トレイ番号を指定すると，プリンタによっては指定した給紙トレイ番号が有効にならないことがあります。

  • 線種に点線が指定された帳票定義ファイルを使用して帳票を出力した場合，線幅が細いと印刷結果が実線に見えることがあります。

  • フォントを置き換える場合は，マニュアル「EUR 帳票出力 リファレンスEUR Server編」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 87 / 195


4.12.3 ESC/P対応プリンタに出力するときの注意 : EUR システム設計ガイド

  • 88 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.12　UNIX／Linux環境のプリンタに出力するときの注意

  • 4.12.3　ESC/P対応プリンタに出力するときの注意

4.12.3　ESC/P対応プリンタに出力するときの注意

UNIX／Linux対応のESC/P対応プリンタに出力するとき，次に示す制限事項があります。

  • カラー指定の帳票を印刷する場合，モノクロで印刷されます。

  • 文字は，常に標準で印刷されます。太字，斜体，太字斜体が指定されていても，標準で印刷されます。

  • デフォルトフォント以外のフォント，および文字サイズの文字を出力するときは，環境変数で指定します。環境変数については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。デフォルトフォントだけを使用する場合は，次のように出力します。

    • 9.6ポイントより小さい文字：ゴシック体で出力

    • 9.6ポイントより大きい文字：明朝体で出力

  • 縦書き文字は，印刷できません。

  • バーコードを回転（90°，270°）している場合，データキャラクタは出力されません。

  • 斜め線，網掛け，円，楕円，多角形および影は，印刷できません。

  • ページの最終行が5mm以上で24ドットにわたる場合，1ページ多く改ページされることがあります。

  • 外字は，常に標準で印刷されます。外字にボールド体やイタリック体が指定されていても，標準で印刷されます。

  • 指定されたフォームシート中の文字属性のポイントが大きい場合，環境変数に適当なフォントファイルが指定されていないと，文字の描画状態が悪くなります。

  • 指定されたフォントファイルのサイズが大きい場合，印字に時間が掛かります。

  • HP-UX，AIXおよびLinuxでは，デフォルトフォントが異なるため，印字テストをしてから運用してください。

  • 環境変数で指定するフォントファイルは，半角と全角で一つのフォントとしているため，半角または全角のどちらか片方のフォントファイルを指定した場合，文字は印刷されません。

  • 点線は実線で出力されます。

  • 実線以外の線種で，線幅に細線以外を指定している場合は，指定した線幅の実線で出力されます。帳票定義時に指定できる線幅を次に示します。

  • EURで設計した帳票をESC/P対応プリンタに出力するときは，次のようにフォントが置き換わります。

    帳票に使用されているフォント

    出力時のフォント

    ＭＳ ゴシック

    ゴシック

    ＭＳ 明朝

    明朝

    それ以外のフォント

    明朝

    そのため，EURでは，「ＭＳ ゴシック」，もしくは「ＭＳ 明朝」だけを使用して帳票を設計するか，または既存の帳票を「ＭＳ ゴシック」，もしくは「ＭＳ 明朝」に修正しておくことをお勧めします。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 88 / 195


4.12.4 PDLファイルに出力するときの注意 : EUR システム設計ガイド

  • 89 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.12　UNIX／Linux環境のプリンタに出力するときの注意

  • 4.12.4　PDLファイルに出力するときの注意

4.12.4　PDLファイルに出力するときの注意

UNIX／Linux環境で帳票をPDLファイル出力するとき，プリンタ定義ファイルのキーワードCommandに指定した情報が，正常終了したのか，またはエラー終了したのかは，コマンドの終了コードでチェックしてください。eurpsコマンド（内部で実行される帳票出力コマンド）の終了コードが0の場合は正常終了を示し，終了コードが0以外の場合はエラー終了を示します。

なお，eurpsコマンドの実行結果をINFOレベルでログに出力しています。出力時にエラーが発生した場合は，ログの内容を参照し，キーワードCommandに指定した情報が正しいかどうかを見直してください。

プリンタ定義ファイルの指定内容の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 89 / 195


4.12.5 印刷先プリンタをBSDシステムと接続したときのジョブ制限 : EUR システム設計ガイド

  • 90 / 195

  • 表紙

  • 4.　帳票に出力するデータの検討

  • 4.12　UNIX／Linux環境のプリンタに出力するときの注意

  • 4.12.5　印刷先プリンタをBSDシステムと接続したときのジョブ制限

4.12.5　印刷先プリンタをBSDシステムと接続したときのジョブ制限

PDLファイル出力の印刷先プリンタをBSDシステムとの接続用に登録した場合（lpadminコマンドに-ob3オプションを付加して登録した場合），プリンタ定義ファイルのキーワードCommandに「/usr/bin/lp」を指定してLP印刷を実行すると，同一プリンタあてに登録できるジョブ数は1,000個までという制限があります。

1,000個を超えるジョブを登録しようとすると，登録できるジョブに空きができるまで，コマンドは終了しません。ジョブの分割数を減らすなどして，システム設計に注意してください。

プリンタ定義ファイルの指定内容の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 90 / 195


5. 帳票の運用方法の検討 : EUR システム設計ガイド

  • 91 / 195

  • 表紙

  • 5.　帳票の運用方法の検討

5.　帳票の運用方法の検討

この章では，ログ採取など日々の帳票業務の運用方法を検討します。また，障害が発生した場合の対処の方法や，帳票を運用するときの注意事項についても説明します。

〈この章の構成〉

  • 5.1　EUR Serverの各コンポーネントの情報

  • 5.2　帳票運用時の注意事項

  • 5.3　EUR Serverでのログの採取

  • 5.4　EUR Designer，またはEUR Viewerでのログの採取

  • 5.5　EUR Serverでのトレース情報の採取

  • 5.6　障害対策

  • 5.7　IT Report Utility（システム情報採取ツール）による構成情報の採取

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 91 / 195


5.1 EUR Serverの各コンポーネントの情報 : EUR システム設計ガイド

  • 92 / 195

  • 表紙

  • 5.　帳票の運用方法の検討

  • 5.1　EUR Serverの各コンポーネントの情報

5.1　EUR Serverの各コンポーネントの情報

EUR Serverの各コンポーネントのサービス名，プロセス名，実行ユーザ，およびログの種類について説明します。

〈この節の構成〉

  • 5.1.1　各コンポーネントのサービス名およびプロセス名

  • 5.1.2　各コンポーネントの実行ユーザ

  • 5.1.3　各コンポーネントのログの種類

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 92 / 195


5.1.1 各コンポーネントのサービス名およびプロセス名 : EUR システム設計ガイド

  • 93 / 195

  • 表紙

  • 5.　帳票の運用方法の検討

  • 5.1　EUR Serverの各コンポーネントの情報

  • 5.1.1　各コンポーネントのサービス名およびプロセス名

5.1.1　各コンポーネントのサービス名およびプロセス名

EUR Serverの各コンポーネントのサービス名およびプロセス名を，次の表に示します。

表5‒1　EUR Serverの各コンポーネントのサービス名とプロセス名

環境

コンポーネント

サービス名（Windows環境の場合）

説明

プロセス名

サーバ

EUR Print Service

なし

－

－

EUR Server Service

EUR Server Service

生成された印刷データの出力指示，およびEUR Serverの全体的な管理を行います。
Windows環境の場合

EURPM.exe

UNIX／Linux環境の場合

eurpmd

EUR Server - Adapter

EUR File Monitor Service

帳票出力に使用するファイルを監視フォルダに格納すると，自動的に帳票の印刷やファイル出力を行うファイル監視サービスです。
Windows環境の場合

eurfm.exe

UNIX／Linux環境の場合

なし

EUR Server - Spool Service

EUR Spool Service

帳票の印刷データ（EPF形式ファイル）をサーバに蓄積します。また，蓄積されている印刷データの操作，および管理を行います。
Windows環境の場合

EURPMLS.exe

UNIX／Linux環境の場合

eurpmlsd

EUR Application Service

帳票管理GUIサービスや配送サービスを使用するためのアプリケーションサーバです。
Windows環境の場合

euraps.exe

UNIX／Linux環境の場合

なし

EUR HTTP Server

帳票管理GUIサービスや配送サービスを使用するためのWebサーバです。
Windows環境の場合

httpsd.exe

UNIX／Linux環境の場合

なし

EUR Server - Spool Service Adapter

なし

－

－

クライアント

EUR Client Service

なし

－

－

EUR Web Plug-In

なし

－

－
（凡例）

－：該当する項目はありません。

コンポーネントの詳細については，マニュアル「EUR 帳票出力 機能解説 EUR Server編」の「EUR Serverを構成するコンポーネント」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 93 / 195


5.1.2 各コンポーネントの実行ユーザ : EUR システム設計ガイド

  • 94 / 195

  • 表紙

  • 5.　帳票の運用方法の検討

  • 5.1　EUR Serverの各コンポーネントの情報

  • 5.1.2　各コンポーネントの実行ユーザ

5.1.2　各コンポーネントの実行ユーザ

EUR Serverの各コンポーネントの実行ユーザについては，「1.3.1　実行ユーザとアクセス権」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 94 / 195


5.1.3 各コンポーネントのログの種類 : EUR システム設計ガイド

  • 95 / 195

  • 表紙

  • 5.　帳票の運用方法の検討

  • 5.1　EUR Serverの各コンポーネントの情報

  • 5.1.3　各コンポーネントのログの種類

5.1.3　各コンポーネントのログの種類

EUR Serverの各コンポーネントのログの種類を，次の表に示します。

各ログの詳細については，それぞれの参照先を参照してください。

表5‒2　EUR Serverの各コンポーネントのログの種類

環境

コンポーネント

機能

ログの種類

参照先

サーバ

EUR Print Service

EUR Print Service

eurpsログ

5.3.5

EPS-XLSXログ（Excel形式ファイルの出力時）

5.3.6

個人番号管理サービス連携機能

eurmmsログ

5.3.9

EUR Server Service

  • EUR Server Service

  • Server Service制御コマンド（eurpmctrlコマンド）

イベントログ

5.3.1

syslog

5.3.2

EURPMログ

5.3.3

EUR Server - Adapter

EUR Server - Adapter

EURPMログ

5.3.3

  • BSP-RM連携コマンド（eursmprコマンド）

  • ファイル監視サービス

  • ジョブ実行プログラム

イベントログ

5.3.1

EURPMログ

5.3.3

EUR Server - Spool Service

EUR Server - Spool Service

イベントログ

5.3.1

syslog

5.3.2

EURPMログ

5.3.3

監査ログ

5.3.8

Spool Service制御コマンド（eurpmlsctrlコマンド）

イベントログ

5.3.1

syslog

5.3.2

EURPMログ

5.3.3

EUR Application Service

イベントログ

5.3.1

eurapsログ

5.3.7

EUR Server - Spool Service Adapter

EUR Server - Spool Service Adapter

EURPMログ

5.3.3

クライアント

EUR Client Service

EUR Client Service

イベントログ

5.3.1

EURPMログ

5.3.3

EUR Web Plug-In

  • EUR Web Plug-In（印刷用）

  • EUR Web Plug-In（プレビュー用）

EURPMログ

5.3.3

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 95 / 195


5.2 帳票運用時の注意事項 : EUR システム設計ガイド

  • 96 / 195

  • 表紙

  • 5.　帳票の運用方法の検討

  • 5.2　帳票運用時の注意事項

5.2　帳票運用時の注意事項

帳票の運用時には，次の内容に注意してください。

  • 帳票ファイル（*.fms）は，運用を開始したあとでも更新できます。ただし，帳票の出力中には更新しないでください。

  • 定期的に，次のファイルのバックアップを取得することをお勧めします。

    • ログファイルのバックアップ

      使用している製品や機能によって，取得が必要なログは異なります。

      EUR Serverで出力するログについては「5.3　EUR Serverでのログの採取」を，EUR Designer，EUR Viewerで出力するログについては「5.4　EUR Designer，またはEUR Viewerでのログの採取」を参照してください。

    • スプールデータのバックアップ

      帳票を再印刷するシステムを構築している場合は，定期的にスプールデータのバックアップを取得してください。スプールデータの格納先については，マニュアル「EUR 帳票出力 機能解説 EUR Server編」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 96 / 195


5.3 EUR Serverでのログの採取 : EUR システム設計ガイド

  • 97 / 195

  • 表紙

  • 5.　帳票の運用方法の検討

  • 5.3　EUR Serverでのログの採取

5.3　EUR Serverでのログの採取

EUR Serverでは，実行時に発生したエラー情報（イベントログまたはsyslog）や，エラーの詳細情報（EURPMログ，eurpsログ，EPS-XLSXログ，eurapsログ）を出力します。

また，スプールデータを操作したときの情報を監査ログとして出力することもできます。

出力されるログについて説明します。

〈この節の構成〉

  • 5.3.1　イベントログ

  • 5.3.2　syslog

  • 5.3.3　EURPMログ

  • 5.3.4　ログファイル出力時にエラーが発生した場合のメッセージ

  • 5.3.5　eurpsログ

  • 5.3.6　EPS-XLSXログ

  • 5.3.7　eurapsログ

  • 5.3.8　監査ログ

  • 5.3.9　eurmmsログ

  • 5.3.10　注意事項

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 97 / 195


5.3.1 イベントログ : EUR システム設計ガイド

  • 98 / 195

  • 表紙

  • 5.　帳票の運用方法の検討

  • 5.3　EUR Serverでのログの採取

  • 5.3.1　イベントログ

5.3.1　イベントログ

Windows環境では，エラーが発生した場合，発生した障害の情報を，イベントログとして出力します。イベントログは，Windows上の管理ツールのイベントビューアで参照します。

〈この項の構成〉

  • (1)　サーバに出力されるイベントログ

  • (2)　クライアントPCに出力されるイベントログ

(1)　サーバに出力されるイベントログ

イベントログは，次に示す形式でメッセージを出力します。各項目の詳細については，マニュアル「EUR メッセージ」を参照してください。

メッセージID メッセージ文 : 詳細情報

また，次に示す情報を出力します。

表5‒3 イベントログに出力される情報（EUR Server）
項目 | 内容
日付 | イベントログを出力した日付
時刻 | イベントログを出力した時刻
ユーザ | サービスを実行したユーザのID
コンピュータ | サービスを実行したコンピュータ名
イベントID | メッセージのエラーレベルのID ERRORレベル：1003 WARNINGレベル：1002 INFORMATIONレベル：1001
ソース | 「EUR Server」
種類 | メッセージのエラーレベル ERRORレベル：エラー WARNINGレベル：警告 INFORMATIONレベル：情報
分類 | EUR Server Serviceの場合：EURPM※ EUR Server - Spool Serviceの場合：EURPMLS EUR Client Serviceの場合：EURPMCL BSP-RM連携コマンド（eursmprコマンド）の場合：eursmpr ファイル監視サービスの場合：eurfm ジョブ実行プログラムの場合：eurivk
説明 | EUR Server Service，EUR Server - Spool Service，およびEUR Client Serviceの場合 メッセージ文 BSP-RM連携コマンド（eursmprコマンド），ファイル監視サービス，およびジョブ実行プログラムの場合 メッセージ文［付加情報］
データ | 出力しない
注※

EUR Server Serviceが複数起動している場合は，ログファイル名が「EURPM_<識別名>.log」になります。

メッセージ文については，マニュアル「EUR メッセージ」を参照してください。

BSP-RM連携コマンド（eursmprコマンド），ファイル監視サービス，およびジョブ実行プログラムのエラーメッセージや警告メッセージの出力時，メッセージに続いて次の付加情報が出力されます。ただし，エラーが発生したタイミングによって実行ジョブIDが取得されていないときは出力されません。

  • BSP-RM連携コマンド（eursmprコマンド）の場合

    帳票セット指定ファイル名（MRSFILE）

    コマンド実行時に使用した帳票セット指定ファイル（一時ファイル）のフルパスが出力されます。

  • ファイル監視サービスおよびジョブ実行プログラムの場合

    ファイル監視サービスの識別名（EURFMID）

    「EURFM」固定で出力されます。

    実行ジョブID（EXECJOBID）

    ファイル監視サービスの実行ジョブIDが出力されます。

    処理日時（DATE）

    処理日時がYYYYMMDDhhmmss形式で出力されます。

    呼び出し種別（CALLEXEC）

    ジョブ実行プログラムの呼び出し種別が出力されます。

      before：ファイル監視サービス（事前定義型）

      after：ファイル監視サービス（上位主導型）

    ファイル名（DATAFILE）

    ジョブ実行時に使用したマッピングデータファイルまたは制御情報付データファイルを監視フォルダから完了フォルダに移動した後のフルパスが出力されます。

    照合パターンID（PATTERNID）

    ジョブ実行時に使用した照合パターンIDが出力されます。

    起動パラメタファイル名（RUNPARAM）

    ジョブ実行時に使用した起動パラメタファイルのフルパスが出力されます。

    終了コード（RESULTCODE）

    コマンド起動部品（eurpmcコマンド）の終了コードが出力されます。

      0：正常

      4：警告

      8：エラー

    実行コマンド（COMMAND）

    ジョブ実行時に使用したコマンド起動部品（eurpmcコマンド）のオプションが出力されます。

また，EUR Application Serviceを使用している場合は，次に示す情報を出力します。

表5‒4 イベントログに出力される情報（EUR Application Service）
項目 | 内容
日付 | イベントログを出力した日付
時刻 | イベントログを出力した時刻
ユーザ | サービスを実行したユーザのID
コンピュータ | サービスを実行したコンピュータ名
イベントID | メッセージのエラーレベルのID ERRORレベル：3 WARNINGレベル： 2 INFORMATIONレベル：1
ソース | 「EUR Application Service」
種類 | メッセージのエラーレベル ERRORレベル：エラー WARNINGレベル：警告 INFORMATIONレベル：情報
説明 | メッセージ文
データ | 出力しない

ページの先頭へ

(2)　クライアントPCに出力されるイベントログ

EUR Client Serviceを使用してクライアントPCで帳票出力する場合，次の情報がイベントログとして出力されます。

  • EUR Client Serviceの開始と終了

  • ジョブの実行

  • エラーメッセージや警告メッセージの出力

EUR Client Serviceの環境設定ファイル（EURPMCL.ini）でイベントログの出力レベルを設定することで，上記の情報に加えて次の情報もイベントログに出力できます。

  • ジョブの開始と終了（KEEY161-IおよびKEEY162-I）

  • 印刷の正常終了（KEEY163-I）

EUR Client Serviceの環境設定ファイルの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

エラーメッセージ（KEEY102-E，KEEY111-E，KEEY140-Eを除く）や警告メッセージの出力時，ジョブの終了時，および印刷の正常終了時には，メッセージに続いて次の付加情報が出力されます。ただし，エラーが発生したタイミングによっては出力されないこともあります。

蓄積ジョブID（SPOOLJOBID）

EPF形式ファイルの蓄積時のジョブIDです。蓄積されたEPF形式ファイルを印刷した場合に値が出力されます。それ以外の場合は，値は空のまま出力されます。

なお，出力される値は，EPF形式ファイルをプレビュー表示した場合に，［プロパティ］ダイアログの［蓄積ジョブID］に表示される値と同じです。

帳票名（TITLE）

EPF形式ファイルの帳票名です。印刷するデータに設定されているスプールタイトルが出力されます。

なお，出力される値は，EPF形式ファイルをプレビュー表示した場合に，［プロパティ］ダイアログの［スプールタイトル］に表示される値と同じです。

帳票ファイル名（REPORTFILENAME）

EPF形式ファイルのファイル名です。複数のファイルを指定している場合は，先頭ページのファイル名が出力されます。

なお，出力される値は，EPF形式ファイルをプレビュー表示した場合に，［プロパティ］ダイアログの［先頭ページの帳票ファイル名］に表示される値と同じです。

なお，［プロパティ］ダイアログについては，マニュアル「EUR 帳票出力 機能解説 EUR Server編」を参照してください。

出力例を次に示します。

  • ジョブ正常終了時

    KEEY137-I ジョブを終了しました。
SPOOLJOBID=[EUR200806020415033580000001000000016]
TITLE=[文書A]
REPORTFILENAME=[帳票A.fms]

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 98 / 195


5.3.2 syslog : EUR システム設計ガイド

  • 99 / 195

  • 表紙

  • 5.　帳票の運用方法の検討

  • 5.3　EUR Serverでのログの採取

  • 5.3.2　syslog

5.3.2　syslog

UNIX／Linux環境では，EUR Server ServiceおよびEUR Server - Spool Serviceの起動・停止の情報をsyslogに出力します。また，EURPMログに出力できないタイミングでの障害発生時に，発生した障害情報をsyslogに出力します。

syslogの形式は，EURPMログと同じです。「5.3.3(3)　EURPMログに出力される情報」を参照してください。

EUR Server Serviceの場合

EUR Server Serviceを複数起動している場合は，syslogにEUR Server Serviceの識別名を次の形式で出力します。

EURPMID = EURPM識別名

syslogの出力先や出力するかどうかなど，syslogの出力設定については，該当するOSのマニュアルを参照ください。

重要

EUR Server ServiceおよびEUR Server - Spool Serviceが，メッセージをEURPMログに出力できなかった場合，syslogに出力します。また，そのメッセージに日本語文字列が含まれる場合，文字化けすることがあります。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 99 / 195


5.3.3 EURPMログ : EUR システム設計ガイド

  • 100 / 195

  • 表紙

  • 5.　帳票の運用方法の検討

  • 5.3　EUR Serverでのログの採取

  • 5.3.3　EURPMログ

5.3.3　EURPMログ

EUR Serverでは，エラーが発生した場合，発生した障害の情報を，EUR Serverのコンポーネントごとに，EURPMログとして出力します。

EURPMログには，イベントログよりも詳細な情報が出力されます。また，詳細なトレースログも出力されます。

コンポーネントごとに出力されるEURPMログファイルを次に示します。

表5‒5　出力されるログファイル

環境

コンポーネント

機能

EURPMログファイル名

デフォルトの出力先

サーバ

EUR Server Service

EUR Server Service

EURPM.log※

  • Windows環境の場合

    インストール先フォルダ\Log

  • UNIX／Linux環境の場合

    /var/opt/eur/log

Server Service制御コマンド（eurpmctrlコマンド）

EURPMCTRL.log

EUR Server - Adapter

EUR Server - Adapter

EURPMADP.log

  • Windows環境の場合

    インストール先フォルダ\Log

  • UNIX／Linux環境の場合

    /var/opt/eur/log

BSP-RM連携コマンド（eursmprコマンド）

eursmpr.log

インストール先フォルダ\Log

ファイル監視サービス

eurfm.log

ジョブ実行プログラム

eurivk.log

EUR Server - Spool Service

EUR Server - Spool Service

EURPMLS.log

  • Windows環境の場合

    インストール先フォルダ\Log

  • UNIX／Linux環境の場合

    /var/opt/eur/log

Spool Service制御コマンド（eurpmlsctrlコマンド）

EURPMLSCTRL.log

/var/opt/eur/log

EUR Server - Spool Service Adapter

EUR Server - Spool Service Adapter

EURPMLSADP.log

  • Windows環境の場合

    インストール先フォルダ\Log

  • UNIX／Linux環境の場合

    /var/opt/eur/log

クライアント

EUR Client Service

EUR Client Service

EURPMCL.log

C:\Users\<ログインユーザ>\AppData\Roaming\Hitachi\EUR

EUR Web Plug-In

EUR Web Plug-In（印刷用）

EURPMPrintAX.log

環境変数TMPに指定されたフォルダ，環境変数TEMPに指定されたフォルダ，およびカレントフォルダのどれか

EUR Web Plug-In（プレビュー用）

EURPMPreViewAX.log
注※

EUR Server Serviceを複数起動している場合，ログファイル名は「EURPM_<識別名>.log」になります。

〈この項の構成〉

  • (1)　出力レベルの指定

  • (2)　ファイルサイズの指定

  • (3)　EURPMログに出力される情報

  • (4)　ログの出力例

(1)　出力レベルの指定

EURPMログファイルに出力するログの量を，出力レベルで制御できます。出力レベルは，各コンポーネントの環境設定ファイルのLOGLEVELキーまたは実行ファイルのLogLevelパラメタで指定します。

各コンポーネントの出力レベルの指定場所を次に示します。

表5‒6 各コンポーネントの出力レベル指定
環境 | コンポーネント | 機能 | 出力レベルの指定場所
サーバ | EUR Server Service | EUR Server Service | 環境設定ファイル（EURPM.ini）のLOGLEVELキー
 |  | Server Service制御コマンド（eurpmctrlコマンド） | 環境設定ファイル（EURPMCTRL.ini）のLOGLEVELキー
 | EUR Server - Adapter | EUR Server - Adapter | 環境設定ファイル（EURPMADP.ini）のLOGLEVELキー
 |  | BSP-RM連携コマンド（eursmprコマンド） | 環境設定ファイル（eursmpr.ini）のLOGLEVELキー
 |  | ファイル監視サービス | 環境設定ファイル（eurfm.ini）のLOGLEVELキー
 |  | ジョブ実行プログラム | 環境設定ファイル（eurivk.ini）のLOGLEVELキー
 | EUR Server - Spool Service | EUR Server - Spool Service | 環境設定ファイル（EURPMLS.ini）のLOGLEVELキー
 |  | Spool Service制御コマンド（eurpmlsctrlコマンド） | 環境設定ファイル（EURPMLSCTRL.ini）のLOGLEVELキー
 | EUR Server - Spool Service Adapter | EUR Server - Spool Service Adapter | 環境設定ファイル（EURPMLSADP.ini）のLOGLEVELキー
クライアント | EUR Client Service | EUR Client Service | 環境設定ファイル（EURPMCL.ini）のLOGLEVELキー
 | EUR Web Plug-In | EUR Web Plug-In（印刷用） | 実行ファイル（EURPMPrintAX9.ocx）のLogLevelパラメタ
 |  | EUR Web Plug-In（プレビュー用） | 実行ファイル（EURPMPreViewAX9.ocx）のLogLevelパラメタ

出力レベルには，次の値を設定します。出力レベルの標準は「8」です。

表5‒7 出力レベル
レベル | 出力内容
0 | ログを出力しない
4 | ・起動ログ ・終了ログ ・エラーログ
8 | ・起動ログ ・終了ログ ・エラーログ ・警告ログ
16 | ・起動ログ ・終了ログ ・エラーログ ・警告ログ ・情報ログ
重要

出力レベルを16に指定すると，トレース情報が大量に出力されるため，性能が落ちるおそれがあります。障害調査時以外には指定しないでください。

出力されるログの内容を次に示します。なお，それぞれのメッセージ文については，マニュアル「EUR メッセージ」を参照してください。

(a)　起動ログ

ジョブごとの起動メッセージが出力されます。

  • EUR Client Service，EUR Web Plug-Inの場合

    メッセージID：KEEY136-I

  • EUR Server - Adapterの場合

    メッセージID：KEEY213-I

  • EUR Server Serviceの場合

    メッセージID：KEEY355-I

  • EUR Server - Spool Serviceの場合

    メッセージID：KEEY424-I

  • EUR Server - Spool Service Adapterの場合

    メッセージID：KEEY508-I

  • Server Service制御コマンド（eurpmctrlコマンド）またはSpool Service制御コマンド（eurpmlsctrlコマンド）の場合

    メッセージID：KEEY033-I

  • BSP-RM連携コマンド（eursmprコマンド）の場合

    メッセージID：KEEU3001-I

  • ファイル監視サービスの場合

    メッセージID：KEEU1001-I

  • ジョブ実行プログラムの場合

    メッセージID：KEEU1501-I

(b)　終了ログ

ジョブごとの終了メッセージが出力されます。

  • EUR Client Service，EUR Web Plug-Inの場合

    メッセージID：KEEY137-I

  • EUR Server - Adapterの場合

    メッセージID：KEEY214-I

  • EUR Server Serviceの場合

    メッセージID：KEEY356-I

  • EUR Server - Spool Serviceの場合

    メッセージID：KEEY425-I

  • EUR Server - Spool Service Adapterの場合

    メッセージID：KEEY509-I

  • Server Service制御コマンド（eurpmctrlコマンド）またはSpool Service制御コマンド（eurpmlsctrlコマンド）の場合

    メッセージID：KEEY034-I

  • BSP-RM連携コマンド（eursmprコマンド）の場合

    メッセージID：KEEU3002-I

  • ファイル監視サービスの場合

    メッセージID：KEEU1002-I

  • ジョブ実行プログラムの場合

    メッセージID：KEEU1502-I

(c)　エラーログ

エラー発生時に，エラーメッセージとエラー詳細情報ログが出力されます。

  • メッセージID：KEEYxxx-EおよびKEEUxxxx-E（xxxはメッセージ番号を示します）

(d)　警告ログ

警告発生時に，警告のメッセージと警告詳細情報ログが出力されます。

  • メッセージID：KEEYxxx-WおよびKEEUxxxx-W（xxxはメッセージ番号を示します）

(e)　情報ログ

情報メッセージ，トレースログおよび詳細情報ログが出力されます。

  • メッセージID：KEEYxxx-IおよびKEEUxxxx-I（xxxはメッセージ番号を示します）

ページの先頭へ

(2)　ファイルサイズの指定

EURPMログファイルのファイルサイズの上限を指定できます。

EURPMログファイルのファイルサイズは，各コンポーネントの環境設定ファイルに指定します。各コンポーネントの環境設定ファイルについては，表5-6を参照してください。

指定できるファイルサイズは，750～2,000,000KBです。ファイルサイズの標準は，750KBです。

EURPMログファイルには，指定したファイルサイズを超えた場合，ログをバックアップファイルに保存する機能があります。バックアップファイルがある場合，既存のバックアップファイルは削除されます。

ページの先頭へ

(3)　EURPMログに出力される情報

EURPMログは，次の形式で出力されます。

[通番],[日付，時刻],[nnn],[エラーレベル],[xx…xx::yy…yy],[nnnn],[タスク通番],[プロセスID],[スレッドID],ログ出力文字列

出力される情報を次に示します。

表5‒8 EURPMログに出力される情報
項目 | 内容
通番 | 000000001～999999999のログの通し番号を出力します。
日付，時刻 | EURPMログを出力した日付，時刻がYY/MM/DD hh:mm:ss ttt形式で出力されます。
nnn | 数字が出力されます。
エラーレベル | 次のレベルが出力されます。 PARAM：実行時パラメタログ ERROR：エラー WARNING：警告 INFORMATION：情報，起動/停止ログ
xx…xx::yy…yy | 文字列が出力されます。
nnnn | 数字が出力されます。
タスク通番 | 次のタスクの種類に応じて，タスク番号が出力されます。 0：メインタスク 1：ソケット接続待機タスク 2：ソケット監視タスク 3～999999999：ジョブタスク
プロセスID | 1～9999999999のプロセスIDが出力されます。
スレッドID | 1～9999999999のスレッドIDが出力されます。
ログ出力文字列 | ログの詳細情報が出力されます。ログ出力文字列に「KEEY」で始まるメッセージが出力された場合は，マニュアル「EUR メッセージ」を参照してください。

ページの先頭へ

(4)　ログの出力例

EURPMログの出力例を次に示します。

  • 起動ログの出力例

    [000000001],[05/10/05 21:35:57 794],[997],[INFO ],[CEURPMGLog::MessagePut ],[0150],[ 2],[ 1824],[ 2092],KEEY355-I ジョブを起動しました。

  • 終了ログの出力例

    [000001025],[05/10/05 21:35:57 794],[997],[INFO ],[CEURPMGLog::MessagePut ],[0150],[ 2],[ 1824],[ 2092],KEEY356-I ジョブを終了しました。

  • エラーログの出力例

    [000000003],[05/10/05 20:53:54 026],[999],[ERROR ],[CEURPMGLog::MessagePut ],[0050],[ 2],[ 1824],[ 2092],KEEY339-E 指定された帳票ファイルが帳票サーバに存在しません。

  • 警告ログの出力例

    [000000010],[05/10/05 20:53:58 026],[998],[WARNING],[CEURPMGLog::MessagePut ],[0050],[ 2],[ 1824],[ 2092],KEEY393-W 帳票サーバでEUR Print Serviceを実行しているときに警告が発生しました。

  • 情報ログの出力例

    [000000020],[05/10/05 21:53:58 026],[997],[INFO ],[CEURPMGLog::MessagePut ],[0050],[ 2],[ 1824],[ 2092],KEEY343-I サービスを停止しました。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 100 / 195


5.3.4 ログファイル出力時にエラーが発生した場合のメッセージ : EUR システム設計ガイド

  • 101 / 195

  • 表紙

  • 5.　帳票の運用方法の検討

  • 5.3　EUR Serverでのログの採取

  • 5.3.4　ログファイル出力時にエラーが発生した場合のメッセージ

5.3.4　ログファイル出力時にエラーが発生した場合のメッセージ

ログファイルの出力時にエラーが発生し，エラーによってログファイルにメッセージを書き込めなかった場合，EUR Server ServiceとEUR Server - Spool Serviceは，そのメッセージをイベントログ（Windows環境の場合）またはsyslog（UNIX／Linux環境の場合）に出力します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 101 / 195


5.3.5 eurpsログ : EUR システム設計ガイド

  • 102 / 195

  • 表紙

  • 5.　帳票の運用方法の検討

  • 5.3　EUR Serverでのログの採取

  • 5.3.5　eurpsログ

5.3.5　eurpsログ

システム上で動作するEUR サーバ帳票出力機能の帳票出力要求の実行ログを出力します。ログ採取レベルは，環境変数EURPS_LOGFILELEVELで変更できます。実行時のログ情報には，メッセージ文のほか，出力日時，プロセス番号などの共通情報が付加されて出力されます。

ログファイル名

ログファイル名は，eurps.logです。

ログファイルの出力先の指定

環境変数，または環境設定ファイルのEURPS_LOGFILEPATHで指定します。指定したログファイルの出力先が存在しない場合，またはログファイルの出力先が指定されていない場合は，出力先フォルダを自動的に作成し，ログファイルを出力します。

EURPS_LOGFILEPATHについては，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ログファイルの出力先の自動生成については，「5.3.5(1)　帳票出力時にeurpsログの出力先フォルダを作成する機能」を参照してください。

ログファイルのファイルサイズの指定

ログファイルのファイルサイズの標準は，3,000KBです。指定できるファイルサイズは，3,000～2,000,000KBです。

ログファイルのファイルサイズは，環境変数EURPS_LOGSIZEで変更できます。

ログファイルのファイルサイズは，印刷ページ総数量ではなく，印刷要求数（印刷ジョブ数）に依存してログの採取量が変わります。そのため，業務システム上の一日当たりの印刷要求数などを目安にしたり，システム保守上，保存できる期限も考慮したりして，ログファイルのファイルサイズを見積もってください。

例えば，印刷要求数の一日平均を1,000回，1回の実行で出力するファイル容量を0.5KBとした場合，15日間分のログを記録するためには，

「0.5（KB）×1,000（回）×15（日）＝7,500（KB）」のファイルサイズが必要になります。

なお，ログファイルには，指定したファイルサイズを超えた場合，ログをバックアップファイルに保存する機能があります。そのため，7,500KBのファイルサイズが必要な場合，ログファイルのファイルサイズは3,750KBで済みます。余裕を持ってファイルサイズを設定するならば，この場合は4,000KB程度とすることをお勧めします。

ログファイルの切り替え

採取したログが，指定したファイルサイズを超えた場合は，ログファイルの名前をeurps.oldと変更して保存し，新たにログファイルeurps.logを作成してメッセージの採取を続けます。すでにeurps.oldがある場合は，そのeurps.oldに上書き保存されます。

EUR サーバ帳票出力機能では，ログファイルをeurps.log（最新情報）とeurps.old（一つ前の情報）の2世代で管理します。

ログファイルへのメッセージ出力レベルの指定

ログファイルに出力するメッセージは，メッセージ出力レベルの指定によって出力する内容を変更できます。メッセージ出力レベルは，環境変数EURPS_LOGFILELEVELに設定します。次に示す2種類のメッセージ出力レベルを設定することで，出力されるメッセージの内容を選択できます。

表5‒9　EURPS_LOGFILELEVELの設定値

環境変数への設定値

出力されるメッセージの内容

INFO

エラーレベル（Error（Err））と情報レベル（Information（Inf））のログを出力します（デフォルト）。

ERROR

エラーレベル（Error（Err））だけを出力します。

ログファイルへのメッセージ出力レベルの標準は，「INFO」です。警告発生時のエラー（Warning（War））を出力する場合は，「INFO」を指定してください。

ログファイルに出力されるメッセージは，次に示す文字コードで表示されます。なお，変換できない文字は，「？」で出力されます。

  • Windows環境の場合：UTF-16で表示されます。

  • UNIX／Linux環境の場合：設定されている文字ロケール環境に依存します。

〈この項の構成〉

  • (1)　帳票出力時にeurpsログの出力先フォルダを作成する機能

  • (2)　eurpsログが出力できないときにユーザに通知する機能

  • (3)　eurpsログの出力例

(1)　帳票出力時にeurpsログの出力先フォルダを作成する機能

帳票出力時に，eurpsログの出力先フォルダが存在しない場合，出力先のフォルダを作成してから，eurpsログを出力します。

作成されるフォルダは，環境変数EURPS_LOGFILEPATHに指定されたフォルダです。

ページの先頭へ

(2)　eurpsログが出力できないときにユーザに通知する機能

帳票出力時にeurpsログが出力できない場合，Windows環境では，eurpsログが出力できないことをイベントログで通知します。

eurpsログが出力できない場合を次に示します。

  • eurpsログの出力時に出力先フォルダを作成できなくて，eurpsログが出力できなかったとき。

  • 出力先フォルダは存在するが，eurps.logを出力できなかったとき。

  • 出力先フォルダは存在するが，eurps.lock（排他を制御するファイル）を出力できなかったとき。

  • 出力先ディレクトリが存在するが，eurps.old（バックアップファイル）を出力できなかったとき。

ページの先頭へ

(3)　eurpsログの出力例

eurpsログの出力例を次に示します。

時刻の後ろに表示されている［ nnnn］の数値は，実行したプロセス番号を示します。例えば，EUR サーバ帳票出力機能のActiveXオブジェクトを利用してサーバアプリケーションから実行した場合は，実行したアプリケーションのプロセス番号が表示されます。

(a)　メッセージレベルがInformationの場合（正常終了のとき）

  • Windows環境の場合

    04/09/07 17:15:00 [      2532] Inf KEEU400-I EUR Print Serviceを起動しました。 : ユーザ=UserAccount : コマンド=eurps formsheet.fms,mapdata.csv,usrdata.csv /t pdf /pf output.pdf
04/09/07 17:15:00 [      2532] Inf KEEU401-I EUR Print Serviceの出力が終了しました。 : ユーザ=UserAccount : 終了コード=0 : ページ数=8 : コマンド= eurps formsheet.fms,mapdata.csv,usrdata.csv /t pdf /pf output.pdf

  • UNIX／Linux環境の場合

    04/09/07 17:15:00 [      2532] Inf KEEU400-I EUR Print Serviceを起動しました。 : ユーザ=UserAccount : コマンド=eurps formsheet.fms,mapdata.csv,usrdata.csv -t pdf -pf output.pdf
04/09/07 17:15:00 [      2532] Inf KEEU401-I EUR Print Serviceの出力が終了しました。 : ユーザ=UserAccount : 終了コード=0 : ページ数=8 : コマンド= eurps formsheet.fms,mapdata.csv,usrdata.csv -t pdf -pf output.pdf

(b)　メッセージレベルがInformationの場合（警告が発生したとき）

  • Windows環境の場合

    04/09/07 17:15:00 [      2532] Inf KEEU400-I EUR Print Serviceを起動しました。 : ユーザ=UserAccount : コマンド=eurps formsheet.fms,mapdata.csv,usrdata.csv /t pdf /pf output.pdf
04/09/07 17:15:00 [      2532] War KEEU300-W 帳票に正しく出力されない項目がありました。 : ユーザ=UserAccount : コマンド= eurps formsheet.fms,mapdata.csv,usrdata.csv /t pdf /pf output.pdf
04/09/07 17:15:00 [      2532] Inf KEEU401-I EUR Print Serviceの出力が終了しました。 : ユーザ=UserAccount : 終了コード=4 : ページ数=8 : コマンド= eurps formsheet.fms,mapdata.csv,usrdata.csv /t pdf /pf output.pdf

  • UNIX／Linux環境の場合

    04/09/07 17:15:00 [      2532] Inf KEEU400-I EUR Print Serviceを起動しました。 : ユーザ=UserAccount : コマンド=eurps formsheet.fms,mapdata.csv,usrdata.csv -t pdf -pf output.pdf
04/09/07 17:15:00 [      2532] War KEEU300-W 帳票に正しく出力されない項目がありました。 : ユーザ=UserAccount : コマンド= eurps formsheet.fms,mapdata.csv,usrdata.csv -t pdf -pf output.pdf
04/09/07 17:15:00 [      2532] Inf KEEU401-I EUR Print Serviceの出力が終了しました。 : ユーザ=UserAccount : 終了コード=4 : ページ数=8 : コマンド= eurps formsheet.fms,mapdata.csv,usrdata.csv -t pdf -pf output.pdf

(c)　メッセージレベルがErrorの場合

出力レベル「Err」のあと，メッセージID（KEEUxxx-y）が付加されていない情報は，製品内の保守情報です。出力されるログによって，障害の切り分けを行う場合は，メッセージIDが付加されているログ情報を参照してください。

  • Windows環境の場合

出力例1
04/09/07 17:15:00 [      2532] Err Category=001, Detail=0001, StartDoc HANDLE=0x0012facc, DOCINFO=0x00130110 CPIError reason:0x00000000 module:0x00000000 position:0x00000000 errorno:13
04/09/07 17:15:00 [      2532] Err KEEU101-E PDF変換中にエラーが発生しました。（13） : ユーザ=UserAccount : コマンド=eurps formsheet.fms,mapdata.csv,usrdata.csv /t pdf /pf output.pdf
出力例2
04/09/07 17:15:00 [      2532] Err Category=002, Detail=0001, C:\EUR\DATAFILE\usrdata error = 2
04/09/07 17:15:00 [      2532] Err KEEU006-E 指定したデータファイル（usrdata）を読み込めません。（2） : ユーザ=UserAccount : コマンド=eurps formsheet.fms,mapdata.csv,usrdata.csv /t pdf /pf output.pdf

  • UNIX／Linux環境の場合

出力例1
04/09/07 17:15:00 [      2532] Err Category=001, Detail=0001, StartDoc HANDLE=0x0012facc, DOCINFO=0x00130110 CPIError reason:0x00000000 module:0x00000000 position:0x00000000 errorno:13
04/09/07 17:15:00 [      2532] Err KEEU101-E PDF変換中にエラーが発生しました。（13） : ユーザ=UserAccount : コマンド=eurps formsheet.fms,mapdata.csv,usrdata.csv -t pdf -pf output.pdf
出力例2
04/09/07 17:15:00 [      2532] Err Category=002, Detail=0001, /eurps/datafile/usrdata error = 2
04/09/07 17:15:00 [      2532] Err KEEU006-E 指定したデータファイル（usrdata）を読み込めません。（2） : ユーザ=UserAccount : コマンド=eurps formsheet.fms,mapdata.csv,usrdata.csv -t pdf -pf output.pdf

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 102 / 195


5.3.6 EPS-XLSXログ : EUR システム設計ガイド

  • 103 / 195

  • 表紙

  • 5.　帳票の運用方法の検討

  • 5.3　EUR Serverでのログの採取

  • 5.3.6　EPS-XLSXログ

5.3.6　EPS-XLSXログ

EUR サーバ帳票出力機能を使って帳票をExcel形式ファイルに出力する場合に，エラーレベルまたはワーニングレベルのメッセージを出力します。ログ採取レベルは，環境変数EURPS_EXCELLOGFILELEVELで変更できます。

ログファイルに出力する情報

ヘッダ情報として，Excel形式ファイル出力を実行した製品の形名，およびライブラリ（Windows環境の場合はLibXLS.dll，UNIX／Linux環境の場合はlibxls.so）のバージョン，リビジョン番号が出力されます。

ワーニングレベルのメッセージとして，複数のアイテムが同一セルに配置された場合に，出力されないアイテムの情報が出力されます。

エラーレベルのメッセージとして，Excel形式ファイル出力時に発生したエラーメッセージが出力されます。

ログファイルの出力形式の詳細については，「5.3.6(1)　EPS-XLSXログの出力形式」を参照してください。

ログファイル名

ログファイルは次の名称で出力されます。

eurpsxlsxYYYYMMDDhhmmsslll_PPPPPPPPPP.log

YYYY

実行時刻の西暦年を示します。

MM

実行時刻の月を示します。

DD

実行時刻の日を示します。

hh

実行時刻の時を示します。

mm

実行時刻の分を示します。

ss

実行時刻の秒を示します。

lll

実行時刻のミリ秒を示します。

PPPPPPPPPP

実行時のプロセスIDを示します。

ログファイルの出力先の指定

環境変数，または環境設定ファイルのEURPS_LOGFILEPATHで指定したeurps.logの出力先フォルダと同じフォルダに出力します。指定したログファイルの出力先が存在しない場合，またはログファイルの出力先が指定されていない場合は，出力先フォルダを自動的に作成し，ログファイルを出力します。

EURPS_LOGFILEPATHについては，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ログファイルの出力先の自動生成については，「5.3.5(1)　帳票出力時にeurpsログの出力先フォルダを作成する機能」を参照してください。

ログファイルの出力単位

ログファイルは，Excel形式ファイルを出力するたびに，エラーレベルまたはワーニングレベルのメッセージと一緒に一つのファイルとして出力されます。Excel形式ファイルを複数回出力すると，出力した回数だけログファイルが出力されます。ただし，出力するエラーレベルまたはワーニングレベルのメッセージがない場合は，ログファイルは出力されません。

ログファイルの容量

出力されるEPS-XLSXログファイルの最大ファイル容量は2GBです。採取したログの容量が2GBを超えた場合は，2GBまではログファイルに出力されます。それ以降のログは出力されません。

ログファイルへのメッセージ出力レベルの指定

ログファイルに出力するメッセージは，メッセージ出力レベルの指定によって出力する内容を変更できます。メッセージ出力レベルは，環境変数EURPS_EXCELLOGFILELEVELに設定します。次に示す2種類のメッセージ出力レベルを設定することで，出力されるメッセージの内容を選択できます。

表5‒10　メッセージ出力レベル

環境変数の設定値

出力されるメッセージの内容

INFO

エラーレベル（Error（Err））とワーニングレベル（Warning（War））のログを出力します（デフォルト）。

ERROR

エラーレベル（Error（Err））だけを出力します。

ログファイルに出力されるメッセージの内容を次に示します。

エラーレベル

Excel形式ファイル出力時に発生したエラーメッセージを出力します。

ワーニングレベル

複数のアイテムが同一セルに配置された場合に，出力されないアイテムの情報を出力します。

ログファイルに出力される情報の詳細については，「5.3.6(1)　EPS-XLSXログの出力形式」を参照してください。

ログファイルに出力されるメッセージは，次に示す文字コードで表示されます。なお，変換できない文字は，「？」で出力されます。

  • Windows環境の場合：UTF-16で表示されます。

  • UNIX／Linux環境の場合：設定されている文字ロケール環境に依存します。

〈この項の構成〉

  • (1)　EPS-XLSXログの出力形式

  • (2)　出力例

(1)　EPS-XLSXログの出力形式

EPS-XLSXログの出力形式について，次に示します。

(a)　ヘッダ情報

EPS-XLSXログは，次に示す形式でヘッダ情報を出力します。

PP△VV-RR[Ret]
[Ret]
PP

EUR Server Standardの形名を示します。

VV

ライブラリ（Windows環境の場合はLibXLS.dll，UNIX／Linux環境の場合はlibxls.so）のバージョン番号を示します。

RR

ライブラリ（Windows環境の場合はLibXLS.dll，UNIX／Linux環境の場合はlibxls.so）のリビジョン番号を示します。

[Ret]

改行コード（Windows環境の場合CR+LF，UNIX／Linux環境の場合LF）を示します。

△

半角空白を示します。

(b)　メッセージ情報

EPS-XLSXログは，次に示す形式でメッセージ情報を出力します。

YY/MM/DD△HH:MM:SS△PPPPPPPPPP△状態△実メッセージ[Ret]
YY

実行時刻の西暦下2桁を示します。

MM

実行時刻の月を示します。

DD

実行時刻の日を示します。

HH

実行時刻の時を示します。

MM

実行時刻の分を示します。

SS

実行時刻の秒を示します。

PPPPPPPPPP

実行時のプロセスIDを示します。

状態

メッセージのレベル（エラー（Err）またはワーニング（War））を示します。

実メッセージ

EPS-XLSXログに出力される詳細情報を示します。詳細情報については，「5.3.6(1)(c)　実メッセージに出力される情報（エラーレベルのメッセージ）」および「5.3.6(1)(d)　実メッセージに出力される情報（ワーニングレベルのメッセージ）」を参照してください。

[Ret]

改行コード（Windows環境の場合CR+LF，UNIX／Linux環境の場合LF）を示します。

△

半角空白を示します。

(c)　実メッセージに出力される情報（エラーレベルのメッセージ）

メッセージのレベルが「Err」（エラーレベル）のログについて，実メッセージに出力される情報を次に示します。

APINAME:reason(0xXXXXXXXX):module(0xXXXXXXXX):pos(0xXXXXXXXX):errno(xx):message(xx)

なお，「errno(xx)」および「message(xx)」は，システムエラーの場合だけ出力されます。

APINAME

エラーが発生したAPI名を示します。

reason(0xXXXXXXXX)

エラーが発生した場合の理由コードを示します。

module(0xXXXXXXXX)

メンテナンスコードのモジュール番号を示します。

pos(0xXXXXXXXX)

メンテナンスコードのエラー出力位置を示します。

errno(xx)

エラーコードを示します。「xx」は，Windows環境の場合は，GetLastError関数で返ってきた値，UNIX／Linux環境の場合は，errnoに設定されている値を示します。

message(xx)

errno(xx)で取得したエラーコードに対応するシステムエラーメッセージを示します。Windows環境の場合は，FormatMessage関数で返ってきた値，UNIX／Linux環境の場合は，strerror関数で取得した値を示します。

(d)　実メッセージに出力される情報（ワーニングレベルのメッセージ）

メッセージのレベルが「War」（ワーニングレベル）のログについて，実メッセージに出力される情報を説明します。

複数のアイテムが同一セルに配置された結果，出力されなかったアイテムの情報はアイテムごとに1行で記述されます。

出力されないアイテムごとの，実メッセージに出力される情報を次に示します。

文字アイテム（固定文字列，マッピングデータ（文字列型，日付型），またはユーザ定義データ（文字列型，日付型））
KEEU320-W△type=String,△sheet=SHEET,△rc=RC[Ret]
type

アイテム種別を示します。固定文字列，マッピングデータ（文字列型，日付型），およびユーザ定義データ（文字列型，日付型）の場合は，「String」になります。

sheet

シート番号を示します。

rc

出力されなかったアイテムが本来配置されるはずだった，Excelのセルの行列番号を示します。

[Ret]

改行コード（Windows環境の場合CR+LF，UNIX／Linux環境の場合LF）を示します。

△

半角空白を示します。

文字アイテム（マッピングデータ（数値型），またはユーザ定義データ（数値型））
KEEU320-W△type=Numeric,△sheet=SHEET,△rc=RC[Ret]
type

アイテム種別を示します。マッピングデータ（数値型），およびユーザ定義データ（数値型）の場合は，「Numeric」になります。

sheet

シート番号を示します。

rc

出力されなかったアイテムが，本来配置されるはずだったExcelのセルの行列番号を示します。

[Ret]

改行コード（Windows環境の場合CR+LF，UNIX／Linux環境の場合LF）を示します。

△

半角空白を示します。

線アイテム
KEEU320-W△type=Line,△sheet=SHEET,△rc=RC,△btrl=D,△Color="RRGGBB",△pattern="PAT"[Ret]
type

アイテム種別を示します。線アイテムの場合は，「Line」になります。

sheet

シート番号を示します。

rc

出力されなかったアイテムが，本来配置されるはずだったExcelのセルの行列番号を示します。

btrl

出力されなかったアイテムがrcで示したセルのどの位置の罫線として配置されるはずだったかを示します。Dにはbottom（下罫線），top（上罫線），right（右罫線），left（左罫線）のどれかが表示されます。

Color

線アイテムの色を16進数表記のRGB値で示します。

pattern

線アイテムの線種を示します。PATにはExcel形式ファイルに出力した場合の線種が表示されます。

[Ret]

改行コード（Windows環境の場合CR+LF，UNIX／Linux環境の場合LF）を示します。

△

半角空白を示します。

網掛けアイテム，角丸四角アイテム
KEEU320-W△type=Rectangle,△sheet=SHEET,△rc=RC,△bgColor="RRGGBB",△pattern="PAT"[Ret]
type

アイテム種別を示します。網掛けアイテム，角丸四角アイテムの場合は，「Rectangle」になります。

sheet

シート番号を示します。

rc

出力されなかったアイテムが，本来配置されるはずだったExcelのセルの行列番号を示します。

bgColor

網掛けアイテム，角丸四角アイテムの背景色を16進数表記のRGB値で示します。

pattern

網掛けアイテム，角丸四角アイテムの塗りつぶしパターンを示します。PATにはExcel形式ファイルに出力した場合の塗りつぶしパターンが表示されます。

[Ret]

改行コード（Windows環境の場合CR+LF，UNIX／Linux環境の場合LF）を示します。

△

半角空白を示します。

ページの先頭へ

(2)　出力例

EPS-XLSXログの出力例を次に示します。

(a)　メッセージレベルがINFOの場合

文字アイテム（固定文字列，マッピングデータ（文字列型，日付型），またはユーザ定義データ（文字列型，日付型））が出力されないとき

Excelの1シート目でセルA1に出力されるはずだった文字アイテム（固定文字列，マッピングデータ（文字列型，日付型），またはユーザ定義データ（文字列型，日付型））が，ほかのアイテムと同一セルに配置された結果，出力されなかった場合の出力例を次に示します。

出力例
09/02/06 15:13:29 [      3356] War KEEU320-W type=String, sheet=1, rc=A1
文字アイテム（マッピングデータ（数値型），またはユーザ定義データ（数値型））が出力されないとき

Excelの1シート目でセルA1に出力されるはずだった文字アイテム（マッピングデータ（数値型），またはユーザ定義データ（数値型））が，ほかのアイテムと同一セルに配置された結果，出力されなかった場合の出力例を次に示します。

出力例
09/02/06 15:13:29 [      3356] War KEEU320-W type=Numeric, sheet=1, rc=A1
線アイテムが出力されない場合

Excelの1シート目でセルA1の左罫線に出力されるはずだった線アイテム（色：黒，線種：実線，線幅：細線）が，ほかのアイテムと同一セルに配置された結果，出力されなかった場合の出力例を次に示します。

出力例
09/02/06 15:13:30 [      3420] War KEEU320-W type=Line, sheet=1, rc=A1, btrl=left, Color="auto", pattern="thin"
網掛けアイテム，角丸四角アイテムが出力されない場合

Excelの1シート目でセルA1に出力されるはずだった網掛けアイテム（色：白，網掛けパターン：薄い網掛け）が，ほかのアイテムと同一セルに配置された結果，出力されなかった場合の出力例を次に示します。

出力例
09/02/06 15:13:29 [       128] War KEEU320-W type=Rectangle, sheet=1, rc=A1, bgColor="auto", pattern="gray0625"

(b)　メッセージレベルがERRORの場合

出力例
09/02/06 15:13:30 [      3220] Err _AbortDoc:reason(0x20001000):module(0xfc000001):pos(0x433):errno(87):message(パラメータが間違っています。)

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 103 / 195


5.3.7 eurapsログ : EUR システム設計ガイド

  • 104 / 195

  • 表紙

  • 5.　帳票の運用方法の検討

  • 5.3　EUR Serverでのログの採取

  • 5.3.7　eurapsログ

5.3.7　eurapsログ

EUR Application Serviceを使用している場合にUTF-8（BOMあり）でエンコードされたメッセージを出力します。

ログファイル名

euraps.log

ログファイルの出力先

インストール先フォルダ\Log

ログファイルのファイルサイズの指定

EUR Application Serviceの出力するログファイルのサイズは，EUR Application Service動作設定ファイルのキーワードLOGFILESIZEで設定します。指定できる値は3,000～2,000,000で，単位はKBです。

なお，eurapsログには，指定したファイルサイズを超えた場合，ログをバックアップファイル（euraps.old）に保存する機能があります。バックアップファイルがある場合，既存のバックアップファイルは削除されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 104 / 195


5.3.8 監査ログ : EUR システム設計ガイド

  • 105 / 195

  • 表紙

  • 5.　帳票の運用方法の検討

  • 5.3　EUR Serverでのログの採取

  • 5.3.8　監査ログ

5.3.8　監査ログ

EURでは，スプールデータを操作したときの情報を監査ログとして出力できます。

監査ログを出力するかどうかは，EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）のAUDITセクションのSPOOLAUDITLOGキーで設定します。監査ログを出力する場合は，SPOOLAUDITLOGキーに「1」を指定します。

監査ログ出力モード

監査ログ出力モードは，監査ログに出力する情報量を指定するモードです。次に示すモードがあります。

  • 監査証跡管理システム連携モード

    一般的に監査ログとして求められる「誰が」「いつ」「何を」「どうした」などの情報を出力するモードです。

  • 詳細情報モード

    監査証跡管理システム連携モードで出力する情報に加えて，EURの機能を実行するときに指定したプロパティや蓄積ファイルの属性情報を出力するモードです。

監査ログ出力モードは，環境設定ファイル（EURPMLS.ini）のAUDITセクションのSPOOLLOGMODEキーで設定します。

監査証跡管理システムと連携する場合は，SPOOLLOGMODEキーに「0」（監査証跡管理システム連携モード）を指定します。

監査ログファイルに出力する情報

監査ログファイルの出力形式の詳細については，「(1)　出力形式」を参照してください。

監査ログファイルの出力項目の詳細については，「(2)　出力項目」を参照してください。

監査ログファイル名

監査ログファイルのファイル名は，eur_spool_audit.logです。

監査ログファイルのバックアップファイルのファイル名は，「eur_spool_audit_n.log」（nは整数値）です。

監査ログファイルの出力先の指定

監査ログファイルの出力先フォルダは，環境設定ファイル（EURPMLS.ini）のAUDITセクションのSPOOLLOGキーで設定します。

監査ログファイルのファイルサイズ上限の指定

監査ログファイルのファイルサイズの上限は，環境設定ファイル（EURPMLS.ini）のAUDITセクションのSPOOLLOGSIZEキーで設定します。指定できる値は750～2,000,000で，単位はKBです。

監査ログファイルのファイルサイズの計算方法を次に示します。

  • 監査ログ出力モードが監査証跡管理システム連携モードの場合

    監査証跡管理システム連携モードの場合，監査ログの対象となる機能を1回実行すると，約300バイトの監査ログを出力します。

    例えば，監査ログの対象となる機能を1日に10,000回実行すると仮定した場合の監査ログファイルのファイルサイズは，

    「300（バイト）×10,000（回）＝3,000,000（バイト）≒3,000（KB）」となります。

    この例の場合は，監査ログファイルのファイルサイズ上限を設定するSPOOLLOGSIZEキーに「3000」を指定します。

  • 監査ログ出力モードが詳細情報モードの場合

    詳細情報モードの場合，監査ログの対象となる機能を1回実行すると，約500バイトの監査ログを出力します。

    例えば，監査ログの対象となる機能を1日に10,000回実行すると仮定した場合の監査ログファイルのファイルサイズは，

    「500（バイト）×10,000（回）＝5,000,000（バイト）≒5,000（KB）」となります。

    この例の場合は，監査ログファイルのファイルサイズ上限を設定するSPOOLLOGSIZEキーに「5000」を指定します。

監査ログファイルのバックアップファイル作成時刻の指定

監査ログファイルのバックアップファイルの作成時刻（ローカルタイム）は，環境設定ファイル（EURPMLS.ini）のAUDITセクションのSPOOLLOGDATEキーで設定します。

監査ログファイルのバックアップファイル保持数の指定

監査ログファイルのバックアップファイルの保持数は，環境設定ファイル（EURPMLS.ini）のAUDITセクションのSPOOLLOGNUMキーで設定します。指定できる値は1～31です。

監査ログファイルの切り替え

監査ログファイルの切り替えを行う場合は，EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）のAUDITセクションのSPOOLAUDITLOGキーに「1」を指定します。

監査ログファイルの切り替えを行う設定にすると，監査ログファイルは世代管理され，監査ログファイルのバックアップファイルは，バックアップファイル保持数までの世代が作成されます。

次に示すタイミング※で世代の切り替えが行われます。

  1. 監査ログファイルのファイルサイズが，環境設定ファイル（EURPMLS.ini）のSPOOLLOGSIZEキーの設定値を超えたとき

  2. 環境設定ファイル（EURPMLS.ini）のSPOOLLOGDATEキーのバックアップファイルの作成時刻を経過したあと，EUR Server - Spool Serviceがスプールデータの操作を実行したとき

  3. eurpmlscコマンドまたは監査ログメソッドで，監査ログの切り替えを実行したとき

注※

  • 1と2が同時に発生した場合，バックアップファイルは1つ作成されます。

  • 1～3が同時に発生した場合，バックアップファイルは2つ作成されます。

世代の切り替えが発生すると，監査ログファイル"eur_spool_audit.log"のファイル名が"eur_spool_audit_1.log"に変更されてバックアップファイルとして保存され，監査ログの出力先が新しい監査ログファイル"eur_spool_audit.log"に切り替わります。次に世代の切り替えが発生すると，保存済みのバックアップファイル"eur_spool_audit_1.log"のファイル名が"eur_spool_audit_2.log"に変更されたあと，同様にバックアップファイル"eur_spool_audit_1.log"と新しい監査ログファイル"eur_spool_audit.log"が作成されます。

以降，保存済みのバックアップファイルは，世代の切り替えが発生するごとに，ファイル名の末尾の数値に1を加えたファイル名に変更されます。ファイル名末尾の数値が大きいファイルほど，古いファイルになります。

なお，バックアップファイルの数がSPOOLLOGNUMキーで指定したバックアップファイルの保持数を超えるときは，古いファイル（ファイル名末尾の数値が最も大きいファイル）から順番に削除されます。

監査ログファイルの切り替えの流れを次の図に示します。

図5‒1　監査ログファイルの切り替えの流れ

[図データ]

監査ログファイルを出力するタイミング

監査ログの出力対象となる機能の操作で，実行結果が正常終了の監査ログは，各操作の実行後のタイミングで出力されます。

ただし，次に示す操作の場合は，監査ログが出力されるタイミングが異なります。

  • 蓄積した印刷データを，クライアントPCで印刷する場合※1

    クライアントPCのEUR Client Serviceに印刷データ（EPF形式ファイル）を転送したときに監査ログが出力されます。

  • 蓄積した印刷データを，帳票管理GUIを操作しているマシンで印刷またはプレビューする場合※1

    帳票管理GUIを操作しているマシンのEUR Server - Spool Server Adapterに印刷データ（EPF形式ファイル）を転送したときに監査ログが出力されます。

  • 蓄積した印刷データから生成したPDF形式ファイルを，帳票管理GUIを操作しているマシンで取得する場合※2

    スプールサーバのEUR Server - Spool Serviceから帳票管理GUIを操作しているマシンのEUR Server - Spool Server Adapterにファイルデータ（PDF形式ファイル）を転送したときに監査ログが出力されます。

注※1

印刷データ（EPF形式ファイル）を転送したあとに，印刷がキャンセルされた場合，および印刷実行時にエラーが発生した場合も，監査ログに出力される実行結果は正常終了となります。

注※2

PDF形式ファイルを転送したあと，次に示す場合は，監査ログに出力される実行結果は正常終了となります。

  • 帳票管理GUIを操作しているマシンのEUR Server - Spool Server AdapterでPDF形式ファイルの取得後にエラーが発生した場合

  • クライアントPCでPDF形式ファイルの取得がキャンセルされた場合

  • クライアントPCでPDF形式ファイルの取得時または取得後にエラーが発生した場合

〈この項の構成〉

  • (1)　出力形式

  • (2)　出力項目

  • (3)　出力例

  • (4)　監査ログのエンコーディング

(1)　出力形式

監査ログファイルの出力形式は，監査ログのフォーマットであることを示す「CALFHM」，監査ログのリビジョン番号，該当する出力項目の順で出力されます。

監査ログの出力形式を次に示します。

CALFHM X.X,△出力項目1=値1,△出力項目2=値2,・・・,△出力項目n=値n▼
（凡例）

△：半角空白を示します。

▼：Windows環境の場合，改行コード（0x0d+0x0a）を示します。UNIX／Linux環境の場合，改行コード（0x0a）を示します。

ページの先頭へ

(2)　出力項目

監査ログファイルの出力項目は，共通出力項目と固有出力項目の2種類があります。それぞれについて説明します。

  • 共通出力項目

    日立オープンミドルウェア製品で共通して出力される項目です。

  • 固有出力項目

    EUR独自で出力される項目です。

(a)　共通出力項目

共通出力項目に出力される値および内容を次の表に示します。

表5‒11　監査ログの共通出力項目

項番

出力項目

値

内容

項目名

出力される属性名

1

共通仕様識別子

－

「CALFHM」固定

監査ログのフォーマットであることを示す識別子が出力されます。

2

共通仕様リビジョン番号

－

「1.0」固定

監査ログを管理するためのリビジョン番号が出力されます。

3

通番

seqnum

通番（1～10桁の10進数）

監査ログの通し番号が出力されます。

初期値は「1」です。最大値に到達した場合は初期値に戻ります。

4

メッセージID

msgid

KEEUnnnn-x

EURのメッセージIDが出力されます。

  • KEEU：メッセージの識別子（固定）です。

  • nnnn：メッセージの通番です。

  • x：メッセージの種別（I：情報，W：警告，E：エラー）です。

メッセージについては，マニュアル「EUR メッセージ」を参照してください。

5

日付・時刻

date

YYYY-MM-DDThh:mm:ss.tttTZD※1

監査ログの出力対象となる機能を実行した日時およびタイムゾーンが出力されます。

6

プログラム名

progid

「EUR」固定

監査ログを出力するプログラムの名称が出力されます。

7

コンポーネント名

compid

  • SpoolService

    蓄積，蓄積ファイル操作

監査ログを出力するコンポーネントの名称が出力されます。

8

プロセスID

pid

プロセスID

監査ログを出力するコンポーネントのプロセスIDが出力されます。

9

発生場所

ocp:host

ホスト名

監査ログを出力するホストのホスト名が出力されます。

10

事象の種別

ctgry

  • AccessControl

    蓄積および蓄積ファイル操作

  • StartStop

    EUR Server - Spool Service起動・停止

監査ログのカテゴリ名が出力されます。

11

事象の結果

result

  • Success

    正常終了

  • Failure

    エラー終了

監査ログの出力対象となる機能の実行結果が出力されます。

12

サブジェクト識別情報

subj:uid
帳票管理GUIの操作の場合

実行ユーザ名※2

業務プログラムの操作（蓄積以外）の場合

EUR Server - Spool Service Adapterの環境設定ファイルEURPMLSADP.iniのキーワードUSERNAMEの指定値※2

業務プログラムの操作（蓄積），蓄積ファイルの一括削除（自動削除），EUR Server - Spool Service起動・停止の場合

""

配送印刷の場合

EUR Client Serviceのログインユーザ名

監査ログの出力対象となる機能を実行したユーザ名が出力されます。
（凡例）

－：属性名の出力なし

注※1

・YYYY：年（西暦）を4桁で示します。

・MM：月（01～12）を2桁で示します。01～09は，ゼロ埋めされます。

・DD：日（01～31）を2桁で示します。01～09は，ゼロ埋めされます。

・hh：時（00～23）を2桁で示します。00～09は，ゼロ埋めされます。

・mm：分（00～59）を2桁で示します。00～09は，ゼロ埋めされます。

・ss：秒（00～59）を2桁で示します。00～09は，ゼロ埋めされます。

・ttt：ミリ秒（000～999）を3桁で示します。000～099は，ゼロ埋めされます。

・T：日付と時刻の区切り（固定）です。

・TZD：タイムゾーン指定子です。次のどれかが出力されます。

  +hh:mm：協定世界時（UTC）からhh:mmだけ進んでいることを示します。

  -hh:mm：協定世界時（UTC）からhh:mmだけ遅れていることを示します。

  Z：協定世界時（UTC）と同じであることを示します。

注※2

デフォルトユーザとして実行される場合は，次に示す値が出力されます。

・ユーザ名を指定していないとき

  「"default"」

・ユーザ管理ファイルによるユーザ認証に失敗したとき

  「実行ユーザ名＋"default"」

  例えば，実行ユーザ名が「yoshida」の場合は，「yoshida"default"」と出力されます。

(b)　固有出力項目

固有出力項目に出力される値および内容を次の表に示します。

表5‒12　監査ログの固有出力項目

項番

出力項目

値

内容

項目名

出力される属性名

1

動作情報

op

  • Spool

    蓄積

  • PrintSpoolReportServer

    スプールサーバでの印刷

  • PrintSpoolReportClient

    クライアントPCでの印刷

  • memGetSpoolFilePrint

    帳票サーバでの印刷

  • memGetSpoolFilePreview

    帳票サーバでのプレビュー

  • GetSpoolFile

    印刷データのファイル取得（EPF形式またはPDF形式）

  • memGetSpoolFile

    印刷データのメモリ取得（EPF形式）

  • memGetSpoolFilePDF

    印刷データのメモリ取得（PDF形式）

  • SetSpoolFileAttribute

    属性値変更

  • DeleteSpoolFile

    削除

  • DeleteSpoolFileAll

    一括削除

  • GetSpoolFileOutline

    一覧取得

  • DeliveryLogin

    配送サービスへのログイン

  • Delivery

    配送印刷

  • GetReportList

    配送印刷した帳票の一覧取得

  • Start

    EUR Server - Spool Serviceの起動

  • Stop

    EUR Server - Spool Serviceの停止

監査ログの出力対象となる機能の操作種別が出力されます。

操作種別に対応する帳票管理GUIの操作については，表5-13を参照してください。

2

オブジェクトロケーション情報※1

objloc:name

格納ファイル名

格納ファイル名が出力されます。

3

objloc:date

YYYYMMDD※3

作成日時が出力されます。

4

objloc:jobid

ジョブID

ジョブIDが出力されます。

5

objloc:printstartpage※2

印刷開始ページ

印刷開始ページが出力されます。

6

objloc:printendpage※2

印刷終了ページ

印刷終了ページが出力されます。

7

objloc:printerclass※2

プリンタクラス名

プリンタクラス名が出力されます。

8

objloc:clientaddress※2

蓄積クライアント印刷時のクライアントPCのIPアドレス

蓄積クライアント印刷時のクライアントPCのIPアドレスが出力されます。

9

objloc:dispprintdlg※2

  • dialog

    対話型印刷モード

  • auto

    自動印刷モード

  • preview

    対話型印刷プレビューモード

  • fullauto

    全自動印刷モード

  • pvonly

    対話型印刷プレビュー表示限定モード

ダイアログ表示モードが出力されます。

10

objloc:printerselect※2

  • class

    プリンタクラス名指定

  • printer

    OS上のプリンタ名指定

  • group

    帳票名による自動振り分け

プリンタ指定方法が出力されます。

11

objloc:serverprinter※2

サーバプリンタ名

サーバプリンタ名が出力されます。

12

objloc:servertray※2

サーバトレイ名

サーバトレイ名が出力されます。

13

objloc:clientprinter※2

クライアントプリンタ名

クライアントプリンタ名が出力されます。

14

objloc:clienttray※2

クライアントトレイ名

クライアントトレイ名が出力されます。

15

objloc:groupname※2

帳票振り分けグループ名

帳票振り分けグループ名が出力されます。

16

objloc:printcopies※2

印刷部数

印刷部数が出力されます。

17

objloc:sortprint※2

  • sort

    部単位

  • stack

    ページ単位

印刷部数の単位が出力されます。

18

objloc:paperorientation※2

  • none

    蓄積したときのページごとの属性

  • portrait

    縦

  • landscape

    横

用紙の向きが出力されます。

19

objloc:spooltitle※2

スプールタイトル

スプールタイトルが出力されます。

20

objloc:spoollimit※2

蓄積期限日

蓄積期限日が出力されます。

21

objloc:maxprintcount※2

上限印刷回数

上限印刷回数が出力されます。

22

objloc:enableget※2

  • noget

    取得不可

  • get

    取得可

取得可否が出力されます。

23

objloc:executableprint※2

  • sv

    蓄積拠点サーバ印刷

  • svcl

    蓄積拠点サーバ印刷および蓄積拠点クライアント印刷

  • cl

    蓄積クライアント印刷

実行可能印刷方式が出力されます。

24

objloc:jobkeycategory[n]※2※4

ジョブ検索キー分類

ジョブ検索キーの分類が出力されます。

25

objloc:jobkeydata[n]※2※4

ジョブ検索キー値

ジョブ検索キーの値が出力されます。

26

objloc:addrkeycategory※2

宛先キー分類

宛先キーの分類が出力されます。

27

objloc:addrkeydata※2

宛先キー値

宛先キーの値が出力されます。

28

objloc:outputfilekind※2

  • epf

    EPF形式

  • pdf

    PDF形式

スプールデータの印刷データをファイル取得するときのファイル形式が出力されます。

29

変更前情報※2※5

before:printerclass

プリンタクラス名

項番7「プリンタクラス名」の変更前の値が出力されます。

30

before:clientaddress

蓄積クライアント印刷時のクライアントPCのIPアドレス

項番8「蓄積クライアント印刷時のクライアントPCのIPアドレス」の変更前の値が出力されます。

31

before:dispprintdlg

ダイアログ表示モード

項番9「ダイアログ表示モード」の変更前の値が出力されます。

32

before:spoollimit

蓄積期限日

項番20「蓄積期限日」の変更前の値が出力されます。

33

before:maxprintcount

上限印刷回数

項番21「上限印刷回数」の変更前の値が出力されます。

34

before:enableget

取得可否

項番22「取得可否」の変更前の値が出力されます。

35

before:printerselect

プリンタ指定方法

項番10「プリンタ指定方法」の変更前の値が出力されます。

36

before:serverprinter

サーバプリンタ名

項番11「サーバプリンタ名」の変更前の値が出力されます。

37

before:servertray

サーバトレイ名

項番12「サーバトレイ名」の変更前の値が出力されます。

38

before:clientprinter

クライアントプリンタ名

項番13「クライアントプリンタ名」の変更前の値が出力されます。

39

before:clienttray

クライアントトレイ名

項番14「クライアントトレイ名」の変更前の値が出力されます。

40

before:groupname

帳票振り分けグループ名

項番15「帳票振り分けグループ名」の変更前の値が出力されます。

41

before:executableprint

実行可能印刷方式

項番23「帳票振り分けグループ名」の変更前の値が出力されます。

42

before:jobkeycategory[n]※4

ジョブ検索キー分類

項番24「ジョブ検索キー分類」の変更前の値が出力されます。

43

before:jobkeydata[n]※4

ジョブ検索キー値

項番25「ジョブ検索キー値」の変更前の値が出力されます。

44

変更後情報※2※6

after:printerclass

プリンタクラス名

項番7「プリンタクラス名」の変更後の値が出力されます。

45

after:clientaddress

蓄積クライアント印刷時のクライアントPCのIPアドレス

項番8「蓄積クライアント印刷時のクライアントPCのIPアドレス」の変更後の値が出力されます。

46

after:dispprintdlg

ダイアログ表示モード

項番9「ダイアログ表示モード」の変更後の値が出力されます。

47

after:spoollimit

蓄積期限日

項番20「蓄積期限日」の変更後の値が出力されます。

48

after:maxprintcount

上限印刷回数

項番21「上限印刷回数」の変更後の値が出力されます。

49

after:enableget

取得可否

項番22「取得可否」の変更後の値が出力されます。

50

after:printerselect

プリンタ指定方法

項番10「プリンタ指定方法」の変更後の値が出力されます。

51

after:serverprinter

サーバプリンタ名

項番11「サーバプリンタ名」の変更後の値が出力されます。

52

after:servertray

サーバトレイ名

項番12「サーバトレイ名」の変更後の値が出力されます。

53

after:clientprinter

クライアントプリンタ名

項番13「クライアントプリンタ名」の変更後の値が出力されます。

54

after:clienttray

クライアントトレイ名

項番14「クライアントトレイ名」の変更後の値が出力されます。

55

after:groupname

帳票振り分けグループ名

項番15「帳票振り分けグループ名」の変更後の値が出力されます。

56

after:executableprint

実行可能印刷方式

項番23「帳票振り分けグループ名」の変更後の値が出力されます。

57

after:jobkeycategory[n]※4

ジョブ検索キー分類

項番24「ジョブ検索キー分類」の変更後の値が出力されます。

58

after:jobkeydata[n]※4

ジョブ検索キー値

項番25「ジョブ検索キー値」の変更後の値が出力されます。
注※1

蓄積ファイルを操作したときに，該当する項目の値が出力されます。該当しない項目は出力されません。該当する項目に値が無い場合は「""」が出力されます。

注※2

監査ログ出力モードが監査証跡管理システム連携モードの場合，この項目は出力されません。

注※3

・YYYY：年（西暦）を4桁で示します。

・MM：月（01～12）を2桁で示します。01～09は，ゼロ埋めされます。

・DD：日（01～31）を2桁で示します。01～09は，ゼロ埋めされます。

・hh：時（00～23）を2桁で示します。00～09は，ゼロ埋めされます。

・mm：分（00～59）を2桁で示します。00～09は，ゼロ埋めされます。

・ss：秒（00～59）を2桁で示します。00～09は，ゼロ埋めされます。

協定世界時（UTC）の値が出力されます。

注※4

[n]には，1～10の整数値が入ります。ジョブ検索キーは，10個まで固定で出力されます。

注※5

蓄積ファイルの属性を変更したときに，操作したオブジェクトの変更前の情報が出力される項目です。変更されていない項目の値も出力されます。値が無い場合は「""」が出力されます。

注※6

蓄積ファイルの属性を変更したときに，操作したオブジェクトの変更後の情報が出力される項目です。変更されていない項目の値も出力されます。値が無い場合は「""」が出力されます。

表5‒13 監査ログの出力対象となる機能の操作種別
項番 | 機能分類 | 出力対象となる機能 | 帳票管理GUIの操作 | 操作種別
1 | 帳票出力 | 蓄積 | なし | Spool
2 | スプールデータの操作 | スプールサーバでの印刷 | 印刷（蓄積拠点サーバ印刷） | PrintSpoolReportServer
3 |  | クライアントPCでの印刷 | 印刷（蓄積クライアント印刷） | PrintSpoolReportClient
4 |  | 帳票管理GUIを操作しているマシンで印刷 | 印刷（このマシンで印刷） | memGetSpoolFilePrint
5 |  | 帳票管理GUIを操作しているマシンでプレビュー | プレビュー | memGetSpoolFilePreview
6 |  | 印刷データのファイル取得（EPF形式またはPDF形式） | なし | GetSpoolFile
7 |  | 印刷データのメモリ取得（EPF形式またはPDF形式） |  | memGetSpoolFile
8 |  | 帳票管理GUIを操作しているマシンでPDF形式ファイルを取得 | PDF取得をクリック | memGetSpoolFilePDF
9 |  | 属性値変更 | 属性変更 | SetSpoolFileAttribute
10 |  | 削除 | 削除 | DeleteSpoolFile
11 |  | 一括削除 | 蓄積期限の切れた蓄積ファイルの一括削除 | DeleteSpoolFileAll
12 |  | 一覧取得 | 検索条件名をクリック | GetSpoolFileOutline
13 |  | 配送サービスへのログイン | なし | DeliveryLogin
14 |  | 配送印刷 |  | Delivery
15 |  | 配送印刷した帳票の一覧取得 |  | GetReportList
16 | EUR Server - Spool Serviceの操作 | EUR Server - Spool Serviceの起動 | なし | Start
17 |  | EUR Server - Spool Serviceの停止 |  | Stop

(c)　連続出力項目

  • 蓄積

    蓄積のあとに続けて印刷を行う場合は，蓄積の監査ログに続けて，スプールサーバでの印刷またはクライアントPCでの印刷の監査ログが出力されます。

  • ユーザ管理ファイルによるユーザ認証の失敗

    ユーザ管理ファイルによるユーザ認証に失敗したときは，認証失敗の監査ログに続けて，デフォルトユーザでの各蓄積ファイル操作の監査ログが出力されます。

    また，そのあとも続けて操作する場合は，毎回認証失敗の監査ログとデフォルトユーザでの各蓄積ファイル操作の監査ログがセットで出力されます。

(d)　複数の帳票を一度に操作する場合

帳票管理GUIで複数の帳票を選択して一度に操作する場合やEUR Server - Spool Service Adapterで複数の帳票を指定して一度に実行する場合は，帳票ごとに1レコードの監査ログを出力します。

ページの先頭へ

(3)　出力例

帳票をスプールサーバに蓄積したときの監査ログの出力例を次に示します。

  • 監査ログ出力モードが監査証跡管理システム連携モードの場合

  • 監査ログ出力モードが詳細情報モードの場合

ページの先頭へ

(4)　監査ログのエンコーディング

監査ログのエンコーディングは，OSの言語およびロケール情報によって決まります。監査ログのエンコーディングを次の表に示します。

表5‒14 監査ログのエンコーディング
エンコーディング
Windows | UNIX／Linux※
 | Shift-JIS | EUC | UTF-8 | 特定しない
Shift-JIS（日本語版以外の場合はASCII文字の範囲） | Shift-JIS | EUC | UTF-8 | Shift-JIS（ASCII文字の範囲）
注※

Linux環境で監査証跡管理システム（JP1/Audit Management - Manager）と連携する場合は，UTF-8だけをサポートします。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 105 / 195


5.3.9 eurmmsログ : EUR システム設計ガイド

  • 106 / 195

  • 表紙

  • 5.　帳票の運用方法の検討

  • 5.3　EUR Serverでのログの採取

  • 5.3.9　eurmmsログ

5.3.9　eurmmsログ

Windows環境で個人番号管理サービス連携機能を使用しているときの実行ログを出力します。ログ採取レベルは，環境変数，または環境設定ファイル（EURPS_ENV）中の変数EURPS_LOGFILELEVELおよび変数EURPS_MMS_LOGDETAILで変更できます。実行時のログ情報には，メッセージ文のほか，出力日時，プロセス番号などの共通情報が付加されて出力されます。

eurmmsログには，イベントログよりも詳細な情報が出力されます。また，詳細なトレースログも出力されます。

ログファイルに出力されるメッセージは，UTF-16で表示されます。

ログファイル名

ログファイル名は，eurmms.logです。

ログファイルの出力先の指定

ログファイルの出力先は，eurpsログと共通で使用する環境変数，または環境設定ファイル（EURPS_ENV）中の変数EURPS_LOGFILEPATHで指定します。指定したログファイルの出力先が存在しない場合，またはログファイルの出力先が指定されていない場合は，出力先フォルダを自動的に作成し，ログファイルを出力します。

EURPS_LOGFILEPATHについては，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ログファイルの出力先の自動生成については，「5.3.5(1)　帳票出力時にeurpsログの出力先フォルダを作成する機能」を参照してください。

ログファイルのファイルサイズの指定

ログファイルのファイルサイズの指定は，eurpsログと共通で使用する環境変数，または環境設定ファイル（EURPS_ENV）中の変数EURPS_LOGSIZEで変更できます。

EURPS_LOGSIZEについては，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ログファイルのファイルサイズの標準サイズや見積もりについては，「5.3.5　eurpsログ」を参照してください。

ログファイルの切り替え

採取したログが，指定したファイルサイズを超えた場合は，ログファイルの名前をeurmms.oldと変更して保存し，新たにログファイルeurmms.logを作成してメッセージの採取を続けます。すでにeurmms.oldがある場合は，そのeurmms.oldに上書き保存されます。

個人番号管理サービス連携機能では，ログファイルをeurmms.log（最新情報）とeurmms.old（一つ前の情報）の2世代で管理します。

ログファイルへのメッセージ出力レベルの指定

ログファイルに出力するメッセージは，メッセージ出力レベルの指定によって出力する内容を変更できます。メッセージ出力レベルは，eurpsログと共通で使用する環境変数，または環境設定ファイル（EURPS_ENV）中の変数EURPS_LOGFILELEVELで設定します。

ログファイルへのメッセージ出力レベルの設定については，「5.3.5　eurpsログ」を参照してください。

なお，ログファイルに出力されるメッセージは，UTF-16で表示されます。

ログファイルへの詳細情報出力の指定

メッセージ出力レベルの設定値が「INFO」の場合は，eurmmsログに詳細な情報を出力するかどうかを，環境変数，または環境設定ファイル（EURPS_ENV）中の変数EURPS_MMS_LOGDETAILで指定できます。

EURPS_ MMS_LOGDETAILについては，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

〈この項の構成〉

  • (1)　eurmmsログの出力形式

(1)　eurmmsログの出力形式

eurmmsログは，次の形式で出力されます。

YYYY/MM/DD△hh:mm:ss△ttt△PPPPPPPPPP△状態△実メッセージ▼
（凡例）

△：半角空白を示します。

▼：改行コード（0x0d+0x0a）を示します。

出力される情報を次の表に示します。

表5‒15 eurmmsログに出力される情報
項目 | 内容
YYYY | 出力時刻の西暦年を示します。
MM | 出力時刻の月を示します。
DD | 出力時刻の日を示します。
hh | 出力時刻の時を示します。
mm | 出力時刻の分を示します。
ss | 出力時刻の秒を示します。
ttt | 出力時刻のミリ秒を示します。
PPPPPPPPPP | 出力時のプロセスIDを示します。 EUR Print ServiceのプロセスIDが出力されます。
状態 | メッセージのレベルを示します。 Inf（情報レベル），War（警告レベル），およびErr（エラーレベル）があります。
実メッセージ | eurmmsログに出力される詳細情報を示します。 メッセージ出力レベルの設定値が「ERROR」，かつ例外が発生した場合，実メッセージにトレース情報が出力されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 106 / 195


5.3.10 注意事項 : EUR システム設計ガイド

  • 107 / 195

  • 表紙

  • 5.　帳票の運用方法の検討

  • 5.3　EUR Serverでのログの採取

  • 5.3.10　注意事項

5.3.10　注意事項

〈この項の構成〉

  • (1)　EUR Server - Adapter，EUR Server - Spool Service AdapterをWindows環境で使用する場合の注意

  • (2)　EUR Clientを使用する場合の注意

  • (3)　ログ機能に関する注意

  • (4)　トレース採取に関する注意

(1)　EUR Server - Adapter，EUR Server - Spool Service AdapterをWindows環境で使用する場合の注意

ログファイルの出力先ディレクトリがシステムフォルダ（Program FilesまたはProgram Files (x86)）以下にある場合で，EUR Server - Adapter，およびEUR Server - Spool Service Adapterを管理者権限で実行しないときは，ログファイルの出力先ディレクトリではなく，リダイレクトフォルダにログファイルが出力されます。

例えば，ログファイルの出力先ディレクトリを変更しないでEUR Server - Adapter，およびEUR Server - Spool Service Adapterをデフォルトディレクトリにインストールした場合，管理者権限で実行しないときは，次のディレクトリにログファイルが出力されます。

C:\Users\<ログインユーザ>\AppData\Local\VirtualStore\Program Files\HITACHI\EUR\Log

ページの先頭へ

(2)　EUR Clientを使用する場合の注意

構成定義ファイルの格納先ディレクトリがシステムフォルダ（Program FilesまたはProgram Files (x86)）以下にある場合で，EUR Clientを管理者権限で実行しないときは，構成定義ファイルを更新すると，構成定義ファイルの格納先ディレクトリではなく，リダイレクトフォルダにファイルが作成，更新されます。

ページの先頭へ

(3)　ログ機能に関する注意

ログファイルは，次に示す状況のどれかが当てはまる場合，EUR サーバ帳票出力機能の正常終了，またはエラー終了に関係なく，ログを出力しません。

  • ログファイル，またはログ出力制御ファイルの出力先ディレクトリに対して，EUR サーバ帳票出力機能の実行ユーザに書き込み権限がない場合。

  • ログファイル，またはログ出力制御ファイルは存在するが，EUR サーバ帳票出力機能の実行ユーザに書き込み権限がない場合。

  • ログファイル，またはログ出力制御ファイルの出力先ハードディスクに，空き容量がない場合。

次のように対処したあと，再度EUR サーバ帳票出力機能を実行してください。

  • EUR サーバ帳票出力機能の実行ユーザに対して，出力先ディレクトリに書き込み権限を与えてください。

    出力先ディレクトリは，環境変数EURPS_LOGFILEPATH，または環境設定ファイル（eurps_env）中の変数EURPS_LOGFILEPATHに設定されているディレクトリです。環境変数EURPS_LOGFILEPATHが設定されていない場合は，「/var/opt/eur/log」が出力先ディレクトリです。環境変数EURPS_LOGFILEPATHについては，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

  • EUR サーバ帳票出力機能の実行ユーザに対して，ログファイルとログ出力制御ファイルに，書き込み権限を与えてください。ログファイル名は「eurps.log，およびeurps.old」，ログ出力制御ファイルは「eurps.lock」です。

  • 不要なファイルを削除するなどして，出力先ハードディスクの空き容量を増やしてください。

ページの先頭へ

(4)　トレース採取に関する注意

トレースファイルは，EUR サーバ帳票出力機能を実行するごとに作成されます。既存ファイルへ上書きされませんので，必要に応じて削除してください。

トレースファイルについては，「5.5　EUR Serverでのトレース情報の採取」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 107 / 195


5.4 EUR Designer，またはEUR Viewerでのログの採取 : EUR システム設計ガイド

  • 108 / 195

  • 表紙

  • 5.　帳票の運用方法の検討

  • 5.4　EUR Designer，またはEUR Viewerでのログの採取

5.4　EUR Designer，またはEUR Viewerでのログの採取

EURでの処理の経過もしくはプリンタドライバ，またはOS上で発生したエラーなど，処理中に発生した情報のログを出力します。出力したログの情報は，指定したログファイルに記録されます。

採取したログを指定したログファイルへ出力しておくと，エラーが発生した時に表示されたメッセージ（またはリターンコード）や使用した帳票ファイルからは，原因の特定が困難であった現象についても，迅速な対応を図れます。

〈この節の構成〉

  • 5.4.1　ログ採取の概要

  • 5.4.2　ログ採取のデフォルトの設定

  • 5.4.3　ログオプションの設定

  • 5.4.4　ログファイルメンテナンスの実行

  • 5.4.5　注意事項

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 108 / 195


5.4.1 ログ採取の概要 : EUR システム設計ガイド

  • 109 / 195

  • 表紙

  • 5.　帳票の運用方法の検討

  • 5.4　EUR Designer，またはEUR Viewerでのログの採取

  • 5.4.1　ログ採取の概要

5.4.1　ログ採取の概要

〈この項の構成〉

  • (1)　採取できるログの種類

  • (2)　ログ採取のレベルの種類

  • (3)　ログファイルの容量

  • (4)　イベントログの出力

(1)　採取できるログの種類

EUR Designer，またはEUR Viewerでは，次に示す2種類のログを採取できます。

  • EURの処理経過に関するログ

  • EUR処理中に発生したエラーに関するログ

ページの先頭へ

(2)　ログ採取のレベルの種類

ログ採取のレベルには，次に示す5種類があります。EURをインストールした直後は，「起動履歴」が設定されています。

エラー履歴

EURの処理でエラーが発生した時，終了コード（RTNCODE=0）以外のエラーを出力します。

起動履歴

次に示す情報を出力します。

  • EUR起動時の情報（起動履歴，起動方法，起動時の指定パラメタ）

  • EUR終了時の情報（終了履歴）

  • ドキュメントオープン時の情報（処理対象の帳票ファイル名，データファイル名）

  • 印刷処理開始時の情報（出力先プリンタの情報）

  • 各ページ印刷開始時の情報（印刷ページ数）

  • ユーザが操作した内容

要求履歴

ユーザが操作した内容（プロパティ・ユーザ操作の履歴）を出力します。

処理履歴

EURの内部関数の処理履歴（入力パラメタ，出力パラメタ，リターンコード）を出力します。

システム履歴

システム関数（OS提供の関数）の処理履歴（入力パラメタ，出力パラメタ，リターンコード）を出力します。

ログ採取のレベルは，エラー履歴＜起動履歴＜要求履歴＜処理履歴＜システム履歴の順に，採取する情報量が多くなります。そのため，上位レベルになるほど，ファイル容量が増加するので，プログラムへの性能に影響が及ぶこともあります。ログ採取のレベルは，下位レベルで採取されることをお勧めします。

ページの先頭へ

(3)　ログファイルの容量

ログファイルの容量は，指定するログ採取のレベル，運用形態，およびエラーの発生の有無によって異なります。また，ログ採取のレベルが上位であるほど，出力量も多くなります。

ページの先頭へ

(4)　イベントログの出力

EURの処理中にエラーが発生した場合は，イベントログが出力されます。ログの出力先は，「アプリケーション」です。

イベントログは，指定されているログ採取レベルに関係なく，エラー発生情報のログを出力する時に出力されます。イベントログに出力するメッセージの内容を示します。

項目 | 説明
イベントID | 9
ソース | EurLogTrc
種別 | エラー
分類 | EurInfo
説明 | EURの処理中にエラーが発生しました
付加情報 | 日付時刻＋プロセスID＋エラー発生ソースファイル名＋エラー発生ソース行番号
項目 | 説明
イベントID | 10
ソース | EurLogTrc
種別 | エラー
分類 | EurInfo
説明 | UDCを含む文字列の印刷中にエラーが発生しました
付加情報 | 帳票名 page = nn vertical = nn horizontal = nn
付加情報の説明

  • 「帳票名」には，エラーが発生した帳票名が出力されます。

  • 「page」には，エラーが発生したページ番号が，1から始まる通し番号で出力されます。帳票に設定したページ番号の形式ではありません。

  • 「vertical」と「horizontal」には，エラーの原因になったUDCを含む繰り返しアイテムの位置を，縦（vertical）と横（horizontal）で示します。繰り返しアイテムでない場合は，「vertical = 0 horizontal = 0」が出力されます。また，データは，16進形式のバイナリデータとして出力され，その横にシステムが読み取れる文字列を出力します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 109 / 195


5.4.2 ログ採取のデフォルトの設定 : EUR システム設計ガイド

  • 110 / 195

  • 表紙

  • 5.　帳票の運用方法の検討

  • 5.4　EUR Designer，またはEUR Viewerでのログの採取

  • 5.4.2　ログ採取のデフォルトの設定

5.4.2　ログ採取のデフォルトの設定

ログオプション設定ツールでログファイル名称が設定されていない場合，次のデフォルト値に従って，エラーの個所とその内容をログファイルに出力します。

表5‒16 EURをインストールした直後のログオプションの設定
ログオプションの設定 | 設定値
ログ採取レベル | 起動履歴
ログを出力するファイル | ユーザアプリケーションデータフォルダ\HITACHI\EUR※に自動生成されたファイル名「HIEUR.LOG」
自動ログメンテナンスを行う | 行う
メンテナンス実行契機 | 「マシン起動時に実行」，実行する日時は「毎日」
メンテナンス方法 | 「経過日数によりログ情報を削除」，経過日数は「7（日）」
注※

ユーザアプリケーションデータフォルダはC:\Users\<ログインユーザ>\AppData\Roamingです。ログはC:\Users\<ログインユーザ>\AppData\Roaming\HITACHI\EUR\HIEUR.LOGに記録されます。

ログ採取レベルは運用に応じて変更できます。

デフォルトで出力されるログ情報では調査が困難な場合は，ログオプション設定ツールで，ハードディスクの空き容量や使用されているシステムの環境に合わせたログオプションを設定してからログを採取してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 110 / 195


5.4.3 ログオプションの設定 : EUR システム設計ガイド

  • 111 / 195

  • 表紙

  • 5.　帳票の運用方法の検討

  • 5.4　EUR Designer，またはEUR Viewerでのログの採取

  • 5.4.3　ログオプションの設定

5.4.3　ログオプションの設定

この節では，ログオプションの設定方法の詳細について説明します。また，設定したオプションを保存する方法と，それをほかのPCへ配布する方法についても説明します。

ログファイルは，ログインしたユーザごとに作成されます。同じファイルに複数のユーザがログを出力するような運用をする場合は，ユーザごとにログオプション設定ツールで同じファイルを指定してください。

〈この項の構成〉

  • (1)　ログオプションの設定手順

  • (2)　ログオプションの変更

  • (3)　EURログオプションファイルの保存と読み込み

  • (4)　EURログオプションファイルの配布

(1)　ログオプションの設定手順

ログオプションは，ログオプション設定ツールを起動して表示された，［EURログオプションの設定］ダイアログで設定します。設定手順は次のとおりです。

操作

  1. ［EURログオプションの設定］ダイアログの表示

    ログオプション設定ツールを起動すると，［EURログオプションの設定］ダイアログが表示されます。ログオプション設定ツールの実行ファイル「EurLgOpt.exe」は，EURの実行ファイル「apgrpt.exe」と同じフォルダに格納されている場合に起動できます。実行ファイル「eurlgopt.exe」をダブルクリックして起動してください。

    なお，ログオプション設定ツールは複数起動しないでください。複数起動すると，起動中のツールが終了されます。

  2. ログ採取レベルの指定

    ログ採取のレベルには，次に示す5種類があります。EURをインストールした直後は，「起動履歴」が設定されています。

    • エラー履歴

      EURの処理でエラーが発生した時，終了コード（RTNCODE=0）以外のエラーを出力します。

    • 起動履歴

      次に示す情報を出力します。

      ・EUR起動時の情報（起動履歴，起動方法，起動時の指定パラメタ）

      ・EUR終了時の情報（終了履歴）

      ・ドキュメントオープン時の情報（処理対象の帳票ファイル名，データファイル名）

      ・印刷処理開始時の情報（出力先プリンタの情報）

      ・各ページ印刷開始時の情報（印刷ページ数）

      ・ユーザが操作した内容

    • 要求履歴

      ユーザが操作した内容（プロパティ・ユーザ操作の履歴）を出力します。

    • 処理履歴

      EURの内部関数の処理履歴（入力パラメタ，出力パラメタ，リターンコード）を出力します。

    • システム履歴

      システム関数（OS提供の関数）の処理履歴（入力パラメタ，出力パラメタ，リターンコード）を出力します。

    ログ採取のレベルは，エラー履歴＜起動履歴＜要求履歴＜処理履歴＜システム履歴の順に，採取する情報量が多くなります。そのため，上位レベルになるほど，ファイル容量が増加するので，プログラムへの性能に影響が及ぶこともあります。ログ採取のレベルは，下位レベルで採取されることをお勧めします。

  3. ログを出力するファイルを指定

    ログを出力するファイル名をフルパスで指定します。既存の書き込み権限のあるフォルダを指定してください。

  4. メンテナンス実行契機の指定

    「自動ログメンテナンスを行う」チェックボックスをオンにした場合，［メンテナンス実行契機］グループボックスと［メンテナンス方法］グループボックスの内容が設定できます。

    ［メンテナンス実行契機］グループボックス

    自動メンテナンスを，マシン起動時に実行するか，または指定した時刻に実行するかのどちらかを設定します。

    ［メンテナンス方法］グループボックス

    ログのメンテナンスを，経過した日数によって削除するか，またはファイルの上限容量を超えた場合に削除するかのどちらかを設定します。

ページの先頭へ

(2)　ログオプションの変更

デフォルトで出力されるログ情報では調査が困難な場合は，次に示す手順でログオプションを変更してください。

  1. ログオプション設定ツールの起動

    ログオプション設定ツールを起動すると，［EURログオプションの設定］ダイアログが表示されます。

  2. ログ採取レベルとログファイルの設定

  3. ログファイルメンテナンスオプションの設定

    使用する環境に合わせた，ログファイルのメンテナンスオプションを設定します。

ページの先頭へ

(3)　EURログオプションファイルの保存と読み込み

ログオプション設定ツールで設定したオプションをEURログオプションファイルへ保存できます。EURログオプションファイルは，既存のEURログオプションファイルから読み込んで利用できます。

ログオプションを保存する手順を次に示します。

  1. ［EURログオプションの設定］ダイアログの表示

  2. オプションの保存

    ［オプション保存］ボタンをクリックすると，設定したオプションがEURログオプションファイル（拡張子は「*.eurlgo」）に保存され，ログが採取されます。EURログオプションファイルには，採取したログのほか，使用したEURの製品名，PP形名，バージョン，およびログオプションの情報も保存されます。

注意

ログオプションに保存されるログファイル名は，保存時のロケールに従った文字コードで保存されます。よって，Unicode固有文字を含んだファイル名は指定できません。

既存のログオプションの情報を読み込んで利用する手順を次に示します。

  1. ［EURログオプションの設定］ダイアログの表示

  2. ［ファイルの読み込み］ダイアログの表示

    ［EURログオプションの設定］ダイアログで［オプション読込］ボタンをクリックすると，［ファイルの読み込み］ダイアログが表示されます。

  3. ファイルの保存場所とファイル名選択

    EURログオプションファイルが保存されている場所を設定し，読み込むファイル名をテキストボックスに直接入力するか，またはダイアログのリストから選択して，［開く］ボタンをクリックします。

    ［EURログオプションの設定］ダイアログに情報が表示されたあと，修正してください。

既存のログオプションの情報が［EURログオプションの設定］ダイアログに読み込まれる時，ファイルの妥当性とバージョンがチェックされます。上位バージョンで作成されたEURログオプションファイル，または保存されている内容が異なるEURログオプションファイルが指定された場合は，メッセージが表示され，オプションの情報はダイアログに反映されません。

ページの先頭へ

(4)　EURログオプションファイルの配布

保存したEURログオプションファイルを配布することで，ほかのPCにも同一のオプション情報を設定できます。

配布したログオプションファイルは，次の方法で設定できます。

  • エクスプローラでの設定

    ログオプションを反映しようとするマシンで，配布されたログオプションファイルをダブルクリックするか，またはポップアップメニューの「設定」を実行します。

  • コマンドでの設定

    ログオプションを反映しようとするマシンで，配布されたログオプションファイルを第1引数に指定して，ログオプション設定ツールを起動します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 111 / 195


5.4.4 ログファイルメンテナンスの実行 : EUR システム設計ガイド

  • 112 / 195

  • 表紙

  • 5.　帳票の運用方法の検討

  • 5.4　EUR Designer，またはEUR Viewerでのログの採取

  • 5.4.4　ログファイルメンテナンスの実行

5.4.4　ログファイルメンテナンスの実行

ログ採取レベルを設定した場合，EURの処理が正常に終了してもログ情報が出力されるため，ログファイルの容量が増加します。そのため，EURログオプション設定ツールで指定されたオプションの情報に従って，ログファイルのメンテナンスを実行してください。

ログメンテナンスツールの起動には，次に示す二つの方法があります。EURログメンテナンスツールが実行されている場合は，タスクバーにアイコン [図データ] が表示され，ツールが起動中であることを示します。

  • スタートアップからの起動

    EURをインストールした時，スタートメニューのスタートアップにプログラムファイルのショートカットが登録されます。そのため，PCを起動すると，EURログメンテナンスツールが起動されます。スタートアップから起動された場合は，非表示で実行されます。

  • プログラムファイルからの起動

    EURログメンテナンスツールの実行ファイル名は，「eurlgmnt.exe」です。

    EURログメンテナンスツールが起動されると，ログメンテナンス実行契機の設定とメンテナンス方法の設定情報によって，EURログオプションファイルのメンテナンスが実行されます。

    例えば，「月曜，マシン起動時に実行」と設定している場合は，月曜日にPCを起動した場合，ログファイルのメンテナンスが実行されます。また，「水曜，指定時刻10:00に実行」と設定している場合は，水曜日の10:00になると，ログファイルのメンテナンスが実行されます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 112 / 195


5.4.5 注意事項 : EUR システム設計ガイド

  • 113 / 195

  • 表紙

  • 5.　帳票の運用方法の検討

  • 5.4　EUR Designer，またはEUR Viewerでのログの採取

  • 5.4.5　注意事項

5.4.5　注意事項

バージョン4からバージョン5以降に移行した場合，バージョン4のログファイルを削除して実行します。バージョン4のログファイルが必要な場合は実行前にバックアップを採取してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 113 / 195


5.5 EUR Serverでのトレース情報の採取 : EUR システム設計ガイド

  • 114 / 195

  • 表紙

  • 5.　帳票の運用方法の検討

  • 5.5　EUR Serverでのトレース情報の採取

5.5　EUR Serverでのトレース情報の採取

帳票をプリンタやPDF形式ファイルに出力するごとに，トレース情報をトレースファイルに採取します。

トレース情報は，次の障害が発生した場合の障害調査に役立ちます。

  • EUR サーバ帳票出力機能がエラー終了し，帳票が出力されなかった場合。

  • EUR サーバ帳票出力機能は正常終了したが，帳票が出力されない，または出力結果が不正だった場合。

〈この節の構成〉

  • 5.5.1　採取するトレース情報

  • 5.5.2　トレースファイルの出力場所

  • 5.5.3　トレースファイルの文字コード

  • 5.5.4　トレース情報採取の指定

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 114 / 195


5.5.1 採取するトレース情報 : EUR システム設計ガイド

  • 115 / 195

  • 表紙

  • 5.　帳票の運用方法の検討

  • 5.5　EUR Serverでのトレース情報の採取

  • 5.5.1　採取するトレース情報

5.5.1　採取するトレース情報

次のトレース情報を採取します。

  • 関数を呼び出す前のトレース

  • エラーが発生した時のトレース

  • 正常終了時のトレース

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 115 / 195


5.5.2 トレースファイルの出力場所 : EUR システム設計ガイド

  • 116 / 195

  • 表紙

  • 5.　帳票の運用方法の検討

  • 5.5　EUR Serverでのトレース情報の採取

  • 5.5.2　トレースファイルの出力場所

5.5.2　トレースファイルの出力場所

出力されるトレースファイルの名称と，出力場所を次に示します。

トレースファイル名

次の名称で出力されます。

EurtrcYYYYMMDDhhmmsslll_pppppppppp.log

（凡例）

YYYY：実行時の年

MM：実行時の月

DD：実行時の日

hh：実行時の時

mm：実行時の分

ss：実行時の秒

lll：実行時のミリ秒

pppppppppp：プロセスID

出力場所

環境変数EURPS_LOGFILEPATHで指定されたフォルダ（ディレクトリ）に出力します。

注意

トレースファイルは，EUR サーバ帳票出力機能を実行するごとに作成されます。既存ファイルには上書きされないので，必要に応じて削除してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 116 / 195


5.5.3 トレースファイルの文字コード : EUR システム設計ガイド

  • 117 / 195

  • 表紙

  • 5.　帳票の運用方法の検討

  • 5.5　EUR Serverでのトレース情報の採取

  • 5.5.3　トレースファイルの文字コード

5.5.3　トレースファイルの文字コード

トレースファイルの文字コードは，ロケールの文字コードに従います。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 117 / 195


5.5.4 トレース情報採取の指定 : EUR システム設計ガイド

  • 118 / 195

  • 表紙

  • 5.　帳票の運用方法の検討

  • 5.5　EUR Serverでのトレース情報の採取

  • 5.5.4　トレース情報採取の指定

5.5.4　トレース情報採取の指定

トレース情報を採取するか，採取しないかを指定できます。トレース情報の採取は，環境変数「EURPS_TRACE」で指定します。

APIのトレース情報を採取するか採取しないかも指定できます。APIのトレース情報の採取は，環境変数「EURPS_TRACE_DRAWAPI」で指定します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 118 / 195


5.6 障害対策 : EUR システム設計ガイド

  • 119 / 195

  • 表紙

  • 5.　帳票の運用方法の検討

  • 5.6　障害対策

5.6　障害対策

障害が発生した場合は，保守情報をできるだけ採取して，保守員に連絡してください。

採取する保守情報について，コンポーネントごとに説明します。

〈この節の構成〉

  • 5.6.1　EUR Designer，EUR Viewerでの保守情報の採取

  • 5.6.2　EUR Serverでの保守情報の採取

  • 5.6.3　EUR Serverでの保守情報の採取（V8互換機能を使用している場合）

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 119 / 195


5.6.1 EUR Designer，EUR Viewerでの保守情報の採取 : EUR システム設計ガイド

  • 120 / 195

  • 表紙

  • 5.　帳票の運用方法の検討

  • 5.6　障害対策

  • 5.6.1　EUR Designer，EUR Viewerでの保守情報の採取

5.6.1　EUR Designer，EUR Viewerでの保守情報の採取

EUR Designer，EUR Viewerで採取が必要な情報について説明します。

〈この項の構成〉

  • (1)　連絡時に必要な保守情報

  • (2)　障害が再現する場合に追加採取する保守情報

  • (3)　データベースと接続している場合に採取する保守情報

(1)　連絡時に必要な保守情報

連絡時に必要な保守情報を次に示します。

  • OS，製品のバージョン情報（修正情報およびパッチ情報を含む）

  • システム構成（ハードウェア構成，ソフトウェア構成）

  • 障害情報（画面のハードコピー，印刷結果，出力ファイルなど）

  • 障害の発生時刻

  • 障害の再現性の有無

  • 障害発生時のオペレーション

    • コマンドの実行時に発行したコマンドライン

    • 指定したオプション記述ファイル

    • OLEオートメーションでメソッドを発行した際のプロパティ情報

  • 動作環境

    • EUR 帳票作成機能，またはEUR クライアント帳票出力機能の動作環境を設定している環境設定ファイル

    • プリンタ定義ファイル

    環境設定ファイル，およびプリンタ定義ファイルの内容の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

  • ログファイル

    • EUR 帳票作成機能，またはEUR クライアント帳票出力機能が出力したログファイル

      ログ採取の方法については，「5.4　EUR Designer，またはEUR Viewerでのログの採取」を参照してください。

  • イベントログファイル

    イベントログについては，「5.4.1(4)　イベントログの出力」を参照してください。

  • プリンタ情報

    出力先プリンタの次の情報を採取します。

    • メーカー名

    • プリンタの名称と型番

    • ドライバの名称とバージョン情報

  • 入出力ファイル

    次のファイルのうち，帳票出力時に指定したファイルを採取します。

    • 指定したファイル

      帳票ファイル，マッピングデータファイル，ユーザ定義データファイル，接続情報ファイル，帳票セット指定ファイル，複数様式情報定義ファイル，画像ファイル，置き換え表管理情報ファイル，置き換え表ファイル，オプション記述ファイル

  • ダンプファイル

    異常終了した場合は，次に示す情報も採取してください。

    • ワトソン博士のログ，クラッシュダンプ

ページの先頭へ

(2)　障害が再現する場合に追加採取する保守情報

障害が再現する場合は，次に示す情報も採取してください。

  • PDLファイル

    印刷結果が不正な場合に採取します。

  • 詳細ログ

    • ログ採取レベルを「システム履歴」にした状態でのログファイル

ページの先頭へ

(3)　データベースと接続している場合に採取する保守情報

データベースに接続して帳票を出力している場合は，次に示す情報も採取してください。

  • 接続先データベースの種別とバージョン

  • DABrokerの動作環境の設定内容

  • DABrokerのトレース情報

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 120 / 195


5.6.2 EUR Serverでの保守情報の採取 : EUR システム設計ガイド

  • 121 / 195

  • 表紙

  • 5.　帳票の運用方法の検討

  • 5.6　障害対策

  • 5.6.2　EUR Serverでの保守情報の採取

5.6.2　EUR Serverでの保守情報の採取

EUR Serverで採取が必要な情報について説明します。

〈この項の構成〉

  • (1)　連絡時に必要な保守情報

  • (2)　発生した現象によって必要な保守情報

  • (3)　障害が再現する場合に追加採取する保守情報

(1)　連絡時に必要な保守情報

連絡時に必要な保守情報を次に示します。

  • EUR Server製品のバージョン情報

  • プラットフォームとOSバージョン情報（修正情報およびパッチ情報を含む）

    • Windows環境の場合

      ［システムのプロパティ］ダイアログで，「Windows Edition」に表示されている情報が対象です。［システムのプロパティ］ダイアログは，スタートメニューの［コントロールパネル］から［システムとセキュリティ］－［システム］を選択すると，表示されます。

      （Windows 7の表示例）

      Windows 7 Ultimate

    • AIX環境の場合

      次に示すコマンドを実行して表示されたバージョン情報が対象です。

      # oslevel -r

      （実行結果の例）

      5200_00

    • HP-UX環境の場合

      次に示すコマンドを実行して表示されたバージョン情報が対象です。

      # uname -r

      （実行結果の例）

      B.11.23

    • Linux環境の場合

      次に示すコマンドを実行して表示されたOSのリリース番号が対象です。

      # uname -r

      （実行結果の例）

      2.6.9_11.EL

  • システム構成（ハードウェア構成，ソフトウェア構成）

  • 障害情報（画面のハードコピー，印刷結果，出力ファイルなど）

  • 障害の発生時刻

  • 障害の再現性の有無

  • エラーメッセージ（画面のハードコピー，エラーコード）

ページの先頭へ

(2)　発生した現象によって必要な保守情報

  • 動作環境

    管理者に問い合わせて，EUR Serverをインストールしたマシンの情報を入手してください。

    • メーカー名

    • 製品名と型番

    • 搭載CPUの種類，CPUクロック数，CPU数

    • 搭載メモリ容量

    • 搭載HDD容量

  • アダプタ言語種別

    管理者に問い合わせて，業務アプリケーションの言語種別を入手してください。

    • ActiveX起動部品（VBScript，Visual Basic，Visual Basic .NETなど）

    • Java起動部品（JSP，Javaなど）

    • COBOL起動部品（COBOL）

    • コマンド起動部品（eurpmcコマンドによる直接実行）

    • SS-ActiveX起動部品（ASP，Visual Basic，Visual Basic .NETなど）

    • SS-Java起動部品（JSP，Javaなど）

    • SS-コマンド起動部品（eurpmlscコマンドによる直接実行）

  • 環境設定ファイル

    次の表に示すEUR Serverの各コンポーネントの環境設定ファイル情報を採取します。

    環境設定ファイルの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

    表5‒17　EUR Serverの各コンポーネントの環境設定ファイル

    環境

    コンポーネント

    機能

    ファイル名

    格納先

    サーバ

    EUR Print Service

    EUR Print Service

    EURPS_ENV※1
    Windows環境の場合

    インストール先フォルダ\Print※1

    UNIX／Linux環境の場合

    /etc/opt/eur※1

    EUR Server Service

    EUR Server Service

    EURPM.ini※2
    Windows環境の場合

    インストール先フォルダ\Server※2

    UNIX／Linux環境の場合

    /var/opt/eur/server※2

    Server Service制御コマンド（eurpmctrlコマンド）

    EURPMCTRL.ini

    EUR Server - Adapter

    EUR Server - Adapter

    EURPMADP.ini※2
    Windows環境の場合

    インストール先フォルダ\Adapter※2

    UNIX／Linux環境の場合

    /var/opt/eur/adapter※2

    BSP-RM連携コマンド（eursmprコマンド）

    eursmpr.ini

    インストール先フォルダ\Eursmpr

    ファイル監視サービス

    eurfm.ini

    インストール先フォルダ\FileMonitor

    ジョブ実行プログラム

    eurivk.ini

    EUR Server - Spool Service

    EUR Server - Spool Service

    EURPMLS.ini※2
    Windows環境の場合

    インストール先フォルダ\Spool※2

    UNIX／Linux環境の場合

    /var/opt/eur/spool※2

    Spool Service制御コマンド（eurpmlsctrlコマンド）

    EURPMLSCTRL.ini

    /var/opt/eur/spool

    EUR Server - Spool Service Adapter

    EUR Server - Spool Service Adapter

    EURPMLSADP.ini※2
    Windows環境の場合

    インストール先フォルダ\Spool Adapter※2

    UNIX／Linux環境の場合

    /var/opt/eur/spool-adp※2

    帳票管理GUI

    EURPMRSGUI.ini

    クライアント

    EUR Client Service

    EUR Client Service

    EURPMCL.ini

    インストール先フォルダ\Client

    注※1

    デフォルトのファイル名と格納先です。EUR Print Serviceの環境設定ファイルのファイル名と格納先は運用によって異なります。詳細については，マニュアル「EUR システム構築ガイド」およびマニュアル「EUR 帳票出力リファレンス EUR Server編」を参照してください。

    注※2

    デフォルトのファイル名と格納先です。EUR Server Service，EUR Server - Adapter，EUR Server - Spool Service，およびEUR Server - Spool Service Adapterの環境設定ファイルのファイル名と格納先は運用によって異なります。詳細については，マニュアル「EUR システム構築ガイド」およびマニュアル「EUR 帳票出力リファレンス EUR Server編」を参照してください。

  • 構成定義ファイル

    次の表に示すEUR Serverの各コンポーネントの構成定義ファイル情報を採取します。

    構成定義ファイルの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

    表5‒18　 EUR Serverの各コンポーネントの構成定義ファイル

    環境

    コンポーネント

    機能

    ファイルの種類

    格納先

    サーバ

    EUR Server Service

    EUR Server Service

    出力先定義ファイル（Destination.conf）
    Windows環境の場合

    インストール先フォルダ\Server\Conf

    または

    環境設定ファイル（EURPM.ini）のPATHセクションのCONFキーで指定したフォルダ

    UNIX／Linux環境の場合

    /var/opt/eur/server/Conf

    または

    環境設定ファイル（EURPM.ini）のPATHセクションのCONFキーで指定したディレクトリ

    帳票サーバプリンタクラス定義ファイル（PMPrinterClass.conf）

    印刷先定義ファイル（PrintDest.conf）

    EUR Server - Adapter

    ファイル監視サービス

    監視定義ファイル（monitordef.conf）

    インストール先フォルダ\FileMonitor\conf

    または

    環境設定ファイル（eurfm.ini）のPATHセクションのCONFキーで指定したフォルダ

    EUR Server - Spool Service

    EUR Server - Spool Service

    拠点プリンタクラス定義ファイル（ServerPrinterClass.conf）

    インストール先フォルダ\Spool\Conf

    または

    環境設定ファイル（EURPMLS.ini）のPATHセクションのCONFキーで指定したフォルダ

    帳票振り分け定義ファイル（Distribution.conf）

    ユーザ管理ファイル（userdef.conf）

    宛先定義ファイル（addrdef.conf）

    クライアント

    EUR Client Service

    EUR Client Service

    クライアントプリンタクラス定義ファイル（ClientPrinterClass.conf）

    インストール先フォルダ\Client\Conf

    または

    環境設定ファイル（EURPMCL.ini）のPATHセクションのCONFキーで指定したフォルダ

  • イベントログファイルまたはsyslog

    Windows環境の場合は，イベントビューアで，システムとアプリケーションのイベントログファイルを出力してください。イベントログファイルについては，「5.3.1　イベントログ」を参照してください。

    UNIX／Linux環境の場合は，syslogを採取してください。syslogについては，「5.3.2　syslog」を参照してください。

  • EURPMログファイル

    • EUR Server Serviceの各コンポーネントが出力したログファイル

      ログファイルについては，「5.3.3　EURPMログ」を参照してください。

  • 環境変数

    次に示すコマンドを実行して表示された情報を採取します。

    • Windows環境の場合

      > set

      （実行結果の例）

      ALLUSERSPROFILE=C:\Documents and Settings\All Users

      APPDATA=C:\Documents and Settings\196084\Application Data

          ：

    • UNIX／Linux環境の場合

      # env

      （実行結果の例）

      SHELL=/bin/bash

      LANG=ja_JP.UTF-8

          ：

  • ネットワーク情報

    管理者に問い合わせて，マシンのIPアドレス情報を入手してください。

  • アプリケーションサーバのログファイル

    アプリケーションサーバのログファイルを入手してください。

ページの先頭へ

(3)　障害が再現する場合に追加採取する保守情報

(a)　プリンタ情報

管理者に問い合わせて，出力先プリンタの次の情報を入手してください。

  • メーカー名

  • プリンタの名称と型番

  • ドライバの名称とバージョン情報

(b)　入力ファイル

次のファイルのうち，帳票出力時に指定したファイルを採取します。

  • 帳票ファイル

  • マッピングデータファイル

  • ユーザ定義データファイル

  • 文書情報設定ファイル

  • 文書しおり定義ファイル

  • しおり定義ファイル

  • 暗号化設定ファイル

  • プリンタ定義ファイル

  • 帳票セット指定ファイル

  • 複数様式情報定義ファイル

  • 接続情報ファイル

  • 置き換え表管理情報ファイル

  • 置き換え表ファイル

  • 画像ファイル

  • PDF仕分け定義ファイル

  • Acrobat JavaScript定義ファイル

  • Acrobat JavaScriptファイル

  • ビューアプレファレンス定義ファイル

  • EPF形式ファイル

  • 印刷日時出力定義ファイル

  • 分割定義ファイル

  • 仕分け定義ファイル

  • 制御情報付データファイル

  • 起動パラメタファイル

  • 帳票出力定義ファイル

  • 新規用紙出力定義ファイル

(c)　出力ファイル

次のファイルのうち，帳票として出力したファイルを採取します。

  • EPF形式ファイル

  • PDF形式ファイル

  • Excel形式ファイル

(d)　一時ファイル

障害の状況によって，一時ファイルが残ることがあります。次のファイルがある場合は，そのファイルを採取してください。環境設定ファイルで出力フォルダを変更している場合は，変更したフォルダから採取します。

  • EUR Server Service，EUR Server - Spool Serviceの場合

    Windows環境のとき

    デフォルトの格納先は，C:\Program Files\HITACHI\EUR\Server\Tempフォルダです。フォルダに格納されているファイルをすべて採取します。

    UNIX／Linux環境のとき

    デフォルトの格納先は，/var/opt/eur/server/tempディレクトリ，および/var/opt/eur/spool/tempディレクトリです。フォルダに格納されているファイルをすべて採取します。

  • EUR Client Serviceの場合

    デフォルトの格納先は，C:\Users\<ログインユーザ>\AppData\Roaming\Hitachi\EURフォルダです。フォルダに格納されているファイルをすべて採取します。

  • EUR Client Serviceでヘルパクライアント印刷をする場合

    Internet Explorerのインターネット一時ファイルのフォルダに格納されているファイルを採取します。

  • EUR Web Plug-Inの場合

    デフォルトの場合は，次のフォルダ下の，フォルダ名の先頭2バイトが「EPF」で始まるフォルダに格納されているすべてのファイルを採取します。

        C:\Users\<ログインユーザ>\AppData\Local\Temp\Low

  • EUR Print Serviceの場合

    EUR Server Serviceのサービスの実行ユーザがsystemアカウントのとき

    デフォルトの場合は，「C:\Windows\Temp」と，フォルダ名の先頭2バイトが「EU」で始まるフォルダに格納されているすべてのファイルを採取します。

    EUR Server Serviceのサービスの実行ユーザが特定のユーザアカウントのとき

    デフォルトの場合は，「C:\Users\<ログインユーザ>\AppData\Local\Temp」で，フォルダ名の先頭2バイトが「EU」で始まるフォルダに格納されているすべてのファイルを採取します。

  • BSP-RM連携コマンド（eursmprコマンド）の場合

    デフォルトの格納先は，C:\Program Files\HITACHI\EUR\Eursmpr\tempです。フォルダに格納されているファイルをすべて採取します。

  • ファイル監視サービスの場合

    デフォルトの格納先は，C:\Program Files\HITACHI\EUR\FileMonitor\fmc\dataです。フォルダに格納されているファイルをすべて採取します。

(e)　トレースログ

EUR Server Serviceの各コンポーネントのトレース情報を採集します。トレース情報は，EUR Server Serviceのログの出力レベルを「16（情報ログ）」に設定すると，出力されます。

重要

出力レベルを16に指定すると，トレース情報が大量に出力されるため，性能が落ちるおそれがあります。障害調査時以外には指定しないでください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 121 / 195


5.6.3 EUR Serverでの保守情報の採取（V8互換機能を使用している場合） : EUR システム設計ガイド

  • 122 / 195

  • 表紙

  • 5.　帳票の運用方法の検討

  • 5.6　障害対策

  • 5.6.3　EUR Serverでの保守情報の採取（V8互換機能を使用している場合）

5.6.3　EUR Serverでの保守情報の採取（V8互換機能を使用している場合）

EUR ServerのV8互換機能を使用している場合に採取が必要な情報について説明します。

〈この項の構成〉

  • (1)　連絡時に必要な保守情報

  • (2)　障害が再現する場合に追加採取する保守情報

  • (3)　データベースと接続している場合に採取する保守情報

(1)　連絡時に必要な保守情報

連絡時に必要な保守情報を次に示します。

  • OS，製品のバージョン情報（修正情報およびパッチ情報を含む）

  • システム構成（ハードウェア構成，ソフトウェア構成）

  • 障害情報（画面のハードコピー，印刷結果，出力ファイルなど）

  • 障害の発生時刻

  • 障害の再現性の有無

  • 障害発生時のオペレーション（コマンド実行時のオプション，ActiveXオブジェクト実行時のプロパティ情報，JavaBeans実行時のメソッドの引数情報）

  • 動作環境

    • EUR サーバ帳票出力機能の動作環境を設定している環境設定ファイル

    • プリンタ定義ファイル

    環境設定ファイル，およびプリンタ定義ファイルの内容の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

  • ログファイル，トレースファイル

    • EUR サーバ帳票出力機能が出力したログファイルとトレースファイル

      ログファイルについては，「5.3.5　eurpsログ」を参照してください。

      Excel形式ファイルを出力した場合のログファイルについては，「5.3.6　EPS-XLSXログ」を参照してください。

      トレースファイルについては，「5.5　EUR Serverでのトレース情報の採取」を参照してください。

  • イベントログファイル

    • Windows環境の場合，イベントログ

      イベントログについては，「5.3.1　イベントログ」を参照してください。

    • UNIX／Linux環境の場合，syslog

  • プリンタ情報

    出力先プリンタの次の情報を採取します。

    • メーカー名

    • プリンタの名称と型番

    • ドライバの名称とバージョン情報

  • 入出力ファイル

    次のファイルのうち，帳票出力時に指定した入力ファイルおよび出力ファイルを採取します。

    • 入力ファイル

      「7.1　EURで使用する入力ファイル」に記載されているファイルを参照してください。

    • 出力ファイル

      出力ページ情報ファイル，PDF形式ファイル，Excel形式ファイル

  • ダンプファイル

    異常終了した場合は，次に示す情報も採取してください。

    • Windows環境の場合，ワトソン博士のログ，クラッシュダンプ

    • UNIX／Linux環境の場合，coreファイル

ページの先頭へ

(2)　障害が再現する場合に追加採取する保守情報

障害が再現する場合は，次に示す情報も採取してください。

  • PDLファイル（スプールファイル）

    印刷結果が不正な場合に採取します。

    採取する方法は，起動方法によって異なります。

    • コマンドで起動する場合：「/pfオプション」

    • ActiveXオブジェクトで起動する場合：ActiveXオブジェクトのOutFileNameプロパティ

    • JavaBeansで起動する場合：EURPSManagerクラスのsetOutFileNameメソッド

    それぞれの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

  • 詳細ログ

    APIのトレース情報（採取する方法については，マニュアル「EUR 帳票出力 機能解説 EUR Server編」を参照してください）

ページの先頭へ

(3)　データベースと接続している場合に採取する保守情報

データベースに接続して帳票を出力している場合は，次に示す情報も採取してください。

  • 接続先データベースの種別とバージョン

  • DABrokerの動作環境の設定内容

  • DABrokerのトレース情報

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 122 / 195


5.7 IT Report Utility（システム情報採取ツール）による構成情報の採取 : EUR システム設計ガイド

  • 123 / 195

  • 表紙

  • 5.　帳票の運用方法の検討

  • 5.7　IT Report Utility（システム情報採取ツール）による構成情報の採取

5.7　IT Report Utility（システム情報採取ツール）による構成情報の採取

IT Report Utilityがインストールされている環境の場合，IT Report Utilityを使用してEURの構成情報を採取できます。

IT Report Utilityのインストール方法および使用方法の詳細については，IT Report Utilityが提供するドキュメントを参照してください。

〈この節の構成〉

  • 5.7.1　使用方法

  • 5.7.2　採取できる資料

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 123 / 195


5.7.1 使用方法 : EUR システム設計ガイド

  • 124 / 195

  • 表紙

  • 5.　帳票の運用方法の検討

  • 5.7　IT Report Utility（システム情報採取ツール）による構成情報の採取

  • 5.7.1　使用方法

5.7.1　使用方法

IT Report Utilityを使用してEURの構成情報を採取する場合，IT Report Utilityのコマンドのオプションで指定するグループ名には「EUR」を指定してください。

重要

  • IT Report Utilityのコマンドを実行する前にEURのサービスをすべて停止してください。

  • IT Report Utilityのコマンドの実行中は，環境設定ファイルおよび構成定義ファイルは編集しないでください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 124 / 195


5.7.2 採取できる資料 : EUR システム設計ガイド

  • 125 / 195

  • 表紙

  • 5.　帳票の運用方法の検討

  • 5.7　IT Report Utility（システム情報採取ツール）による構成情報の採取

  • 5.7.2　採取できる資料

5.7.2　採取できる資料

IT Report Utilityを使用して採取できるEURの資料を次に示します。

  • 環境設定ファイル

  • 構成定義ファイル

重要

  • 構成定義ファイルの格納先をデフォルトから変更している場合，変更先の構成定義ファイルは採取できません。

  • 環境設定ファイルの格納先またはファイル名をデフォルトから変更している場合，変更した環境設定ファイルは採取できません。

  • IT Report Utilityを使用して保守資料は採取できません。障害調査に必要な保守情報の採取については，「5.6 障害対策」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 125 / 195


6. 業務プログラムの設計 : EUR システム設計ガイド

  • 126 / 195

  • 表紙

  • 6.　業務プログラムの設計

6.　業務プログラムの設計

この章では，EURを起動する業務プログラムの設計方法を検討します。

〈この章の構成〉

  • 6.1　EURのコーディング例

  • 6.2　業務プログラムの設計に関する注意事項

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 126 / 195


6.1 EURのコーディング例 : EUR システム設計ガイド

  • 127 / 195

  • 表紙

  • 6.　業務プログラムの設計

  • 6.1　EURのコーディング例

6.1　EURのコーディング例

EURで帳票を出力したり，蓄積したりするときのコーディング例については，マニュアル「EUR 帳票出力 機能解説 EUR Server編」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 127 / 195


6.2 業務プログラムの設計に関する注意事項 : EUR システム設計ガイド

  • 128 / 195

  • 表紙

  • 6.　業務プログラムの設計

  • 6.2　業務プログラムの設計に関する注意事項

6.2　業務プログラムの設計に関する注意事項

EURを起動する業務プログラムを設計する際に注意する内容について説明します。

〈この節の構成〉

  • 6.2.1　ファイル転送時間を省略する場合の注意

  • 6.2.2　印刷時に使用するデータファイルの注意

  • 6.2.3　帳票管理GUIと業務アプリケーションを併用してスプールデータを操作する場合の注意

  • 6.2.4　PDF取得機能を使用する場合の注意

  • 6.2.5　Java起動部品でメモリ取得機能を使用する場合の注意

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 128 / 195


6.2.1 ファイル転送時間を省略する場合の注意 : EUR システム設計ガイド

  • 129 / 195

  • 表紙

  • 6.　業務プログラムの設計

  • 6.2　業務プログラムの設計に関する注意事項

  • 6.2.1　ファイル転送時間を省略する場合の注意

6.2.1　ファイル転送時間を省略する場合の注意

EUR Server ServiceやEUR Server - Adapterなどの各コンポーネントが同じマシン上で稼働している場合，ファイル転送を省略し，ファイルの入出力に掛かる時間を短縮できます。

〈この項の構成〉

  • (1)　EUR Server ServiceとEUR Server - Adapter間

  • (2)　EUR Server ServiceとEUR Server - Spool Service間

  • (3)　EUR Server - Spool ServiceとEUR Server - Spool Service Adapter間

(1)　EUR Server ServiceとEUR Server - Adapter間

EUR Print Serviceに渡す入力ファイルやPDF形式ファイルなどの出力ファイルのファイル転送を省略できます。

ファイル転送を省略するには，次の条件をすべて満たす必要があります。

  • EUR Server ServiceとEUR Server - Adapterが同じマシン上で稼働する

    EUR Server - Adapterの環境設定ファイル（EURPMADP.ini）で設定するIPADDRESSセクションのEURPMキー（EUR Server Serviceが稼働するマシンのIPアドレス）の設定値が「127」で始まるとき，同一マシンと判断されます。

  • EUR Server ServiceとEUR Server - Adapterが同一ロケールで稼働する

    EUR Server - Adapterの実行環境で環境変数LANGの値が同じとき，同一ロケールと判断されます。ただし，同じロケールでも，サポートしていないロケールでは動作を保証しません。

  • Java起動部品のメモリ入出力メソッドを使用しない

    EUR Server - AdapterのJava起動部品のメモリ入出力に関する次のメソッドは使用できません。

    出力

    メソッド名

    機能

    メモリ入出力

    EPF形式ファイル出力

    setDataFileData

    マッピング用のデータまたは可変記号値定義データを設定する

    入力

    setUserDataFileData

    ユーザ定義用のデータまたは可変記号値定義データを設定する

    入力

    getEPFReport

    EPF形式データを取得する

    出力

    getMergeEPFReport

    複数のEPF形式ファイルを統合したEPF形式データを取得する

    出力

    PDF形式ファイル出力

    setDataFileData

    マッピング用のデータまたは可変記号値定義データを設定する

    入力

    setUserDataFileData

    ユーザ定義用のデータまたは可変記号値定義データを設定する

    入力

    setBookmarkFileData

    しおり定義データを設定する

    入力

    setDocBookmarkFileData

    文書しおり定義データを設定する

    入力

    setCryptoFileData

    暗号化設定データを設定する

    入力

    setDistributeFileData

    PDF仕分けデータを設定する

    入力

    getPDFReport

    PDFデータを取得する

    出力

    Excel形式ファイル出力

    setDataFileData

    マッピング用のデータまたは可変記号値定義データを設定する

    入力

    setUserDataFileData

    ユーザ定義用のデータまたは可変記号値定義データを設定する

    入力

    getXLSXReport

    Excel形式データを取得する

    出力

    印刷（拠点プリンタ印刷，蓄積印刷）

    setDataFileData

    マッピング用のデータまたは可変記号値定義データを設定する

    入力

    setUserDataFileData

    ユーザ定義用のデータまたは可変記号値定義データを設定する

    入力

    印刷（クライアントプリンタ印刷）

    setDataFileData

    マッピング用のデータまたは可変記号値定義データを設定する

    入力

    setUserDataFileData

    ユーザ定義用のデータまたは可変記号値定義データを設定する

    入力

ページの先頭へ

(2)　EUR Server ServiceとEUR Server - Spool Service間

EUR Server ServiceとEUR Server - Spool Serviceが同一マシンで稼働するとき，蓄積されるスプールデータのファイル転送を省略できます。

EUR Server - AdapterのDestinationNameで指定された出力先名のEUR Server Service の出力先定義でのIPアドレス，またはServerAddressプロパティの設定値が「127」で始まるときは，同一マシンと判断されます。

ページの先頭へ

(3)　EUR Server - Spool ServiceとEUR Server - Spool Service Adapter間

EUR Server - Spool ServiceとEUR Server - Spool Service Adapterが次の条件をすべて満たすとき，スプールデータから取得する印刷データのファイル転送を省略できます。

  • EUR Server - Spool ServiceとEUR Server - Spool Service Adapterが同じマシン上で稼働する

    EUR Server - Spool Service AdapterのServerAddressプロパティの設定値が「127」で始まるとき，同一マシンと判断されます。ServerAddressプロパティを省略していたときは，EUR Server - Spool Service Adapterの環境設定ファイル（EURPMLSADP.ini）のIPADDRESSセクションのEURPMLSキーの設定値が仮定されます。

  • EUR Server - Spool ServiceとEUR Server - Spool Service Adapterが同一ロケールで稼働する

    EUR Server - Spool Service Adapterの実行環境で環境変数LANGの値が同じとき，同一ロケールと判断されます。ただし，同じロケールでも，サポートしていないロケールでは動作を保証しません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 129 / 195


6.2.2 印刷時に使用するデータファイルの注意 : EUR システム設計ガイド

  • 130 / 195

  • 表紙

  • 6.　業務プログラムの設計

  • 6.2　業務プログラムの設計に関する注意事項

  • 6.2.2　印刷時に使用するデータファイルの注意

6.2.2　印刷時に使用するデータファイルの注意

印刷時に使用するデータファイルのデータが0件の場合は，タイトルや見出しだけを印刷した帳票が出力されます。アプリケーションを設計するとき，データファイルのデータが0件の場合は印刷を実行しないように設定してください。

なお，データベース連携で抽出した結果が0件だった場合には，環境変数EURPS_DONT_PRINT_IF_DB_RESULT_EMPTYに「YES」を設定すれば，白紙の帳票を出さないで終了させることができます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 130 / 195


6.2.3 帳票管理GUIと業務アプリケーションを併用してスプールデータを操作する場合の注意 : EUR システム設計ガイド

  • 131 / 195

  • 表紙

  • 6.　業務プログラムの設計

  • 6.2　業務プログラムの設計に関する注意事項

  • 6.2.3　帳票管理GUIと業務アプリケーションを併用してスプールデータを操作する場合の注意

6.2.3　帳票管理GUIと業務アプリケーションを併用してスプールデータを操作する場合の注意

帳票管理GUIと業務アプリケーションを併用してスプールデータを操作する場合は，環境設定ファイル（EURPMLSADP.ini）のOPTIONセクションにUSERNAMEキーとCHECKSTRINGキーを指定してください。業務アプリケーションからスプールデータを操作するときに，ユーザ名と確認キーを指定できるため，ユーザ認証ができるようになります。

環境設定ファイル（EURPMLSADP.ini）の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 131 / 195


6.2.4 PDF取得機能を使用する場合の注意 : EUR システム設計ガイド

  • 132 / 195

  • 表紙

  • 6.　業務プログラムの設計

  • 6.2　業務プログラムの設計に関する注意事項

  • 6.2.4　PDF取得機能を使用する場合の注意

6.2.4　PDF取得機能を使用する場合の注意

〈この項の構成〉

  • (1)　タイムアウトに関する注意点

  • (2)　Webサーバのヒープサイズに関する注意点

(1)　タイムアウトに関する注意点

ページ数の多い帳票や画像の多い帳票からPDF取得を実行する際，サーバ環境によっては，PDF形式ファイルの生成処理に時間が掛かることがあるため，帳票管理GUIから操作すると，タイムアウト※1が発生してPDF形式ファイルを取得できない場合があります。

帳票管理GUIは小さめの帳票※2を操作する運用に適しています。PDF形式ファイルの生成に時間が掛かる帳票からPDF取得を実行する場合は，EUR Server - Spool Service Adapterのタイムアウト値をチューニングし，業務プログラムから起動部品※3を使用してスプールデータのファイルを取得することを推奨します。

注※1

EUR Server - Spool Service Adapterのタイムアウト値（デフォルトは30秒）です。

EUR Server - Spool Service Adapterのタイムアウトの指定については，マニュアル「EUR 帳票出力 機能解説 EUR Server編」の「応答に時間がかかる操作のタイムアウト」を参照してください。

注※2

約1,000ページ以内の帳票が目安となります。サーバ環境や帳票によって，PDF形式ファイルの生成に掛かる時間が変わりますので，運用される環境によって，帳票管理GUIで操作する帳票の目安を確認してください。

注※3

次に示す起動部品が該当します。

  • SS-ActiveX起動部品：GetSpoolFileメソッド

  • SS-Java起動部品：getSpoolFileメソッド

  • SS-コマンド起動部品：eurpmlscコマンド（/mオプションにgetを指定）

各起動部品の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

(2)　Webサーバのヒープサイズに関する注意点

ファイルサイズの大きいPDF形式ファイルを取得する場合，または同時に複数のPDF形式ファイルを取得する場合，メモリ不足でエラーとなることがあります。

メモリ不足を回避するには，使用しているWebサーバのヒープサイズの上限値を拡張してください。※

注※

EUR Server Enterpriseが同梱するEUR HTTP Serverの場合，同時に取得するPDF形式ファイルの合計サイズが約160MBを超えるとメモリ不足となります。

なお，EUR HTTP Serverのヒープサイズの上限値は変更できませんので，メモリ不足となる場合は，ほかのWebサーバをご使用ください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 132 / 195


6.2.5 Java起動部品でメモリ取得機能を使用する場合の注意 : EUR システム設計ガイド

  • 133 / 195

  • 表紙

  • 6.　業務プログラムの設計

  • 6.2　業務プログラムの設計に関する注意事項

  • 6.2.5　Java起動部品でメモリ取得機能を使用する場合の注意

6.2.5　Java起動部品でメモリ取得機能を使用する場合の注意

Java起動部品のメモリ取得機能※でサイズの大きいデータを取得した場合，メモリ不足でエラーとなることがあります。

メモリ不足を回避するには，JavaVMのヒープサイズの上限値を拡張してください。

拡張するサイズは，同時に取得する帳票データの合計サイズの3倍以上を目安としてください。

注※

次に示すメソッドが該当します。

■EUR Server - AdapterのEURPMAdapterForJavaクラス

  • getEPFReportメソッド

  • getEURReportメソッド

  • getMergeEPFReportメソッド

  • getPDFReportメソッド

  • getXLSXReportメソッド

■EUR Server - Spool Service AdapterのEURPMLSAdapterForJavaクラス

  • memgetSpoolFileメソッド

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 133 / 195


7. EURの入力ファイルの設計 : EUR システム設計ガイド

  • 134 / 195

  • 表紙

  • 7.　EURの入力ファイルの設計

7.　EURの入力ファイルの設計

この章では，EURで使用する入力ファイルの格納先および設計方法を検討します。

〈この章の構成〉

  • 7.1　EURで使用する入力ファイル

  • 7.2　エンコーディング

  • 7.3　入力ファイル名の規則

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 134 / 195


7.1 EURで使用する入力ファイル : EUR システム設計ガイド

  • 135 / 195

  • 表紙

  • 7.　EURの入力ファイルの設計

  • 7.1　EURで使用する入力ファイル

7.1　EURで使用する入力ファイル

EURでは，次の表に示すファイルを入力ファイルとして使用できます。

各ファイルの詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

入力ファイルの種類

ファイル名

ファイル形式（拡張子）

説明

帳票サーバに準備するファイル

帳票ファイル

FMSファイル（*.fms）

EUR 帳票作成機能で作成した帳票ファイルです。

画像ファイル

BITMAPファイル（*.bmp）

JPEGファイル（*.jpg / *.jpe / *.jpeg）

GIFファイル（*.gif / *.gif）

TIFFファイル（*.tif / *.tiff）

PNGファイル（*.png）

帳票に表示する画像ファイルです。

文書情報設定ファイル

テキストファイル（任意）

出力先に表示する帳票名や，PDF文書情報を指定したファイルです。

プリンタ定義ファイル（printerinf）

テキストファイル（拡張子なし）

印刷位置補正情報や，印刷で使用するプリンタの情報などを定義したファイルです。

複数様式情報定義ファイル

テキストファイル（任意）

複数の帳票ファイルを組み合わせて一つの帳票のように入力するための情報を定義したファイルです。

接続情報ファイル

テキストファイル（任意）

データベースと接続するために必要な情報を定義したファイルです。

新規用紙出力定義ファイル

テキストファイル

（任意）

単一様式帳票，または帳票セットを複数指定した帳票の出力で，常に表面に出力する対象の帳票ファイルを定義するファイルです。

置き換え表管理情報ファイル

CSV形式ファイル（*.csv）

帳票を設計した時に設定された置き換え表名と，置き換え表ファイルの対応を定義したファイルです。

置き換え表ファイル

CSV形式ファイル（*.csv）

アイテムのデータを置き換えて出力する場合に，1フィールドごとの置き換え対象のデータと，置き換えて出力するデータを定義したファイルです。

Acrobat JavaScript定義ファイル

CSV形式ファイル（*.csv）

PDF形式ファイルに埋め込むAcrobat JavaScriptファイル名を指定したファイルです。

Acrobat JavaScriptファイル

テキストファイル（任意）

PDF形式ファイルに埋め込むJavaScriptプログラムを指定したファイルです。

ビューアプレファレンス定義ファイル

CSV形式ファイル（*.csv）

出力したPDF形式ファイルを開いたときに実行するビューアプレファレンスを指定するファイルです。

テスト印刷設定ファイル

テキストファイル（任意）

テスト印刷用の文字列を重ねて出力するための情報を指定したファイルです。

EURフォントファイル

EDFファイル（*.edf）

Windows環境で作成した外字をUNIX／Linux環境で出力できるように変換したファイルです。Windows環境でもPDF形式ファイル出力の場合だけ使用できます。

印刷日時出力定義ファイル

テキストファイル（任意）

プリンタでの印刷実行時の日時情報を帳票に出力するために必要な情報を定義するファイルです。

帳票出力定義ファイル

テキストファイル

（任意）

起動部品で帳票IDを使用して帳票を出力する場合に，起動部品のプロパティ情報やメソッドの引数情報で指定する項目を定義するファイルです。

個人番号接続情報ファイル

テキストファイル

（任意）

個人番号管理サービス連携機能を使用する場合に，個人番号管理サービスとの接続に必要な情報を定義するファイルです。

個人番号フィールド情報ファイル

テキストファイル

（任意）

個人番号管理サービス連携機能を使用する場合に，個人番号管理サービスから個人番号を取得するために必要なキー情報となるフィールド名を定義するファイルです。

連携プロファイル

－

個人番号管理サービス連携機能を使用する場合に，個人番号管理サービスから提供される機能を使用して作成する必要があるファイルです。

個人番号管理サービスのSSL証明書のルート証明書

－

個人番号管理サービスで使用するSSL証明書を信頼済みと認識するためにインポートする証明書です。

環境によっては，既存で信頼済みと認識されている場合があります。

EUR Application Service動作設定ファイル（euraps.ini）

テキストファイル（*.ini）

EUR Application Serviceを使用するときに，ログファイルのサイズを設定するためのファイルです。

アプリケーションサーバに準備するファイル

データファイル

CSV形式ファイル（*.csv）

DAT形式ファイル（*.dat）

FIX形式ファイル（*.fix）

帳票を設計するための表形式のデータです。

可変記号値定義ファイル

テキストファイル（任意）

条件に合ったデータを抽出する時に必要な，検索条件の可変記号とその値を定義するためのファイルです。

帳票セット指定ファイル

テキストファイル（任意）

複数の帳票ファイルを統合する順番と帳票に読み込むデータファイルを指定しておくファイルです。

文書しおり定義ファイル

テキストファイル（任意）

しおりとして表示する文字列と，しおりをクリックしたときのページの表示方法を設定したファイルです。

しおり定義ファイル

テキストファイル（任意）

次に示すしおりの文字列とPDF形式ファイルのページの表示方法を設定したファイルです。

  • 「PDF形式ファイルを構成するサブ文書（帳票）を示すしおり」

  • 「（帳票に出力する）データのまとまりを表す項目のしおり」

暗号化設定ファイル

テキストファイル（任意）

PDF形式ファイルを暗号化するためのセキュリティ属性を設定するファイルです。

PDF仕分け定義ファイル

CSV形式ファイル（*.csv）

PDF形式ファイルを仕分け出力するための情報を定義したファイルです。

EUR Web Plug-In情報ファイル（EURPMPrintAX.infまたはEURPMPreViewAX.inf）

INFファイル（*.inf）

EUR Server - AdapterまたはEUR Client Serviceが，EUR Web Plug-InのクラスIDおよびバージョン情報を取得するときに参照するファイルです。

制御情報付データファイル

テキストファイル（任意）

BSP-RM連携機能および上位主導型で帳票自動出力機能を使用するときに準備するファイルです。

マッピングデータに帳票の出力に関する制御情報を付加したデータファイルです。

起動パラメタファイル

テキストファイル（任意）

BSP-RM連携コマンド（eursmprコマンド）およびファイル監視サービス（事前定義型の場合）から呼び出すことができるeurpmcコマンドのオプションを定義するファイルです。

運用に応じて格納先を決めるファイル

分割定義ファイル

テキストファイル（任意）

帳票を分割するときのページ数や分割後のEPF形式ファイルの印刷先などを定義するファイルです。

仕分け定義ファイル

テキストファイル（任意）

帳票を仕分けするときのキーワードやキーワードに対応する印刷先などを定義するファイルです。

帳票出力環境の構築で使用するファイル

出力先定義ファイル（Destination.conf）

CONFファイル（*.conf）

スプールサーバの出力先名と，IPアドレスの対応を定義するためのファイルです。

帳票サーバプリンタクラス定義ファイル（PMPrinterClass.conf）

CONFファイル（*.conf）

帳票サーバによる直接印刷方式で，プリンタクラスを定義するためのファイルです。

印刷先定義ファイル（PrintDest.conf）

CONFファイル（*.conf）

蓄積時に指定する帳票の蓄積先やスプールデータの格納ファイル名などの情報を，印刷先として定義するためのファイルです。

拠点プリンタクラス定義ファイル（ServerPrinterClass.conf）

CONFファイル（*.conf）

スプールサーバのプリンタとトレイの組み合わせを定義するためのファイルです。

帳票振り分け定義ファイル（Distribution.conf）

CONFファイル（*.conf）

帳票名ごとにプリンタを定義したファイルです。

ユーザ管理ファイル（userdef.conf）

CONFファイル（*.conf）

ユーザの認証情報，およびスプールデータへのアクセス制限情報が定義されたファイルです。

宛先定義ファイル（addrdef.conf）

CONFファイル（*.conf）※1

配送印刷をするときに，宛先ごとに割り当てるユーザを定義するためのファイルです。

クライアントプリンタクラス定義ファイル（ClientPrinterClass.conf）

CONFファイル（*.conf）

クライアントPCのプリンタとトレイの組み合わせを定義するためのファイルです。

監視定義ファイル（monitordef.conf）

CONFファイル（*.conf）

事前定義型で帳票自動出力機能を使用する場合に，着信監視するマッピングデータに対応する起動パラメタファイルを定義するためのファイルです。

環境設定ファイル

EUR Server Serviceの環境設定ファイル（EURPM.ini※2）

テキストファイル（*.ini※3）

EUR Server Serviceの動作環境を設定するファイルです。

EUR Print Serviceの環境設定ファイル（EURPS_ENV※2）

テキストファイル（拡張子なし）

EUR Print Serviceの動作環境を設定するファイルです。

EUR Server - Adapterの環境設定ファイル（EURPMADP.ini※2）

テキストファイル（*.ini※3）

EUR Server - Adapterの動作環境を設定するファイルです。

EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini※2）

テキストファイル（*.ini※3）

EUR Server - Spool Serviceの動作環境を設定するファイルです。

EUR Server - Spool Service Adapterの環境設定ファイル（EURPMLSADP.ini※2）

テキストファイル（*.ini※3）

EUR Server - Spool Service Adapterの動作環境を設定するファイルです。

帳票管理GUIの環境設定ファイル（EURPMRSGUI.ini）

テキストファイル（*.ini）

帳票管理GUIの動作環境を設定するファイルです。

EUR Client Serviceの環境設定ファイル（EURPMCL.ini）

テキストファイル（*.ini）

EUR Client Serviceの動作環境を設定するファイルです。

EUR Web Plug-Inだけをインストールした場合は格納されません。

Server Service制御コマンド（eurpmctrlコマンド）の環境設定ファイル（EURPMCTRL.ini）

テキストファイル（*.ini）

Server Service制御コマンド（eurpmctrlコマンド）の動作環境を設定するファイルです。

Spool Service制御コマンド（eurpmlsctrlコマンド）の環境設定ファイル（EURPMLSCTRL.ini）

テキストファイル（*.ini）

Spool Service制御コマンド（eurpmlsctrlコマンド）の動作環境を設定するファイルです。

BSP-RM連携コマンド（eursmprコマンド）の環境設定ファイル（eursmpr.ini）

テキストファイル（*.ini）

BSP-RM連携コマンド（eursmprコマンド）の動作環境を設定するファイルです。

ファイル監視サービスの環境設定ファイル（eurfm.ini）

テキストファイル（*.ini）

ファイル監視サービスの動作環境を設定するファイルです。

ジョブ実行プログラムの環境設定ファイル（eurivk.ini）

テキストファイル（*.ini）

ジョブ実行プログラムの動作環境を設定するファイルです。
（凡例）

－：ユーザがファイル形式を意識する必要がないことを示します。

注※1

デフォルトの設定ではCONFファイルを使用しますが，ほかのファイル形式を使用することもできます。詳細は，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

注※2

デフォルトのファイル名です。

注※3

環境設定ファイルの格納先またはファイル名をデフォルトから変更する場合は，拡張子は任意です。

〈この節の構成〉

  • 7.1.1　デフォルトのインストール先および出力先

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 135 / 195


7.1.1 デフォルトのインストール先および出力先 : EUR システム設計ガイド

  • 136 / 195

  • 表紙

  • 7.　EURの入力ファイルの設計

  • 7.1　EURで使用する入力ファイル

  • 7.1.1　デフォルトのインストール先および出力先

7.1.1　デフォルトのインストール先および出力先

EUR Serverの各コンポーネントのインストール先にデフォルトフォルダを指定した場合，各ファイルの配置先および出力先は次に示すフォルダに設定されます。なお，OSが64ビット版の場合は，「Program Files」を「Program Files (x86)」に読み替えてください。

〈この項の構成〉

  • (1)　EUR Server Service

  • (2)　EUR Server - Adapter

  • (3)　EUR Server - Spool Service

  • (4)　EUR Server - Spool Service Adapter

  • (5)　EUR Client Service

(1)　EUR Server Service

各ファイルの配置先

  • 帳票ファイル

    C:\Program Files\HITACHI\EUR\Server\Form

  • 複数様式情報定義ファイル

    C:\Program Files\HITACHI\EUR\Server\Multi

  • 文書情報設定ファイル

    C:\Program Files\HITACHI\EUR\Server\DocInfo

  • 接続情報ファイル

    C:\Program Files\HITACHI\EUR\Server\DBInfo

  • 新規用紙出力定義ファイル

    C:\Program Files\HITACHI\EUR\Server\printnewpaper

  • 置き換え表管理情報ファイル

    C:\Program Files\HITACHI\EUR\Server\ReplaceItem

  • Acrobat JavaScript定義ファイル

    C:\Program Files\HITACHI\EUR\Server\ScriptCnt

  • ビューアプレファレンス定義ファイル

    C:\Program Files\HITACHI\EUR\Server\Preference

  • 帳票出力定義ファイル

    C:\Program Files\HITACHI\EUR\Server\reportid

各ファイルの出力先

  • ログファイル

    C:\Program Files\HITACHI\EUR\Log

  • 一時ファイル

    C:\Program Files\HITACHI\EUR\Server\Temp

  • 構成定義ファイル

    C:\Program Files\HITACHI\EUR\Server\Conf

ページの先頭へ

(2)　EUR Server - Adapter

各ファイルの出力先

  • ログファイル

    C:\Program Files\HITACHI\EUR\Log

  • 一時ファイル（BSP-RM連携コマンド（eursmprコマンド）を使用する場合）

    C:\Program Files\HITACHI\EUR\Eursmpr\temp

  • 一時ファイル（ファイル監視サービスを使用する場合）

    C:\Program Files\HITACHI\EUR\FileMonitor\fmc\data

  • 構成定義ファイル（ファイル監視サービスの監視定義ファイル）

    C:\Program Files\HITACHI\EUR\FileMonitor\conf

ページの先頭へ

(3)　EUR Server - Spool Service

各ファイルの出力先

  • ログファイル

    C:\Program Files\HITACHI\EUR\Log

  • 一時ファイル

    C:\Program Files\HITACHI\EUR\Spool\Temp

  • スプールデータを格納するフォルダ（蓄積フォルダ）

    C:\Program Files\HITACHI\EUR\Spool\ESF

  • 構成定義ファイル

    C:\Program Files\HITACHI\EUR\Spool\Conf

ページの先頭へ

(4)　EUR Server - Spool Service Adapter

各ファイルの出力先

  • ログファイル

    C:\Program Files\HITACHI\EUR\Log

ページの先頭へ

(5)　EUR Client Service

各ファイルの出力先

  • ログファイル

    C:\Users\<ログインユーザ>\AppData\Roaming\Hitachi\EUR

  • 一時ファイル

    C:\Program Files\HITACHI\EUR\Client\Temp

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 136 / 195


7.2 エンコーディング : EUR システム設計ガイド

  • 137 / 195

  • 表紙

  • 7.　EURの入力ファイルの設計

  • 7.2　エンコーディング

7.2　エンコーディング

EURのエンコーディング規則について説明します。

〈この節の構成〉

  • 7.2.1　入力ファイルのエンコーディング

  • 7.2.2　起動部品，コマンド，環境変数および標準出力の文字集合とエンコーディング

  • 7.2.3　画面に入力する項目の文字集合

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 137 / 195


7.2.1 入力ファイルのエンコーディング : EUR システム設計ガイド

  • 138 / 195

  • 表紙

  • 7.　EURの入力ファイルの設計

  • 7.2　エンコーディング

  • 7.2.1　入力ファイルのエンコーディング

7.2.1　入力ファイルのエンコーディング

EUR Server Serviceの入力ファイルの文字集合およびエンコーディングを次の表に示します。

エンコーディングがUnicodeの場合は，実装水準1に対応しています。なお，実装水準1に結合文字は含まれません。

表7‒1 EUR Server Serviceでの入力ファイルの文字集合とエンコーディング
対象 |  | 文字集合 | エンコーディング
 |  |  | Windows | UNIX／Linux
 |  |  |  | Shift-JIS ※1 | EUC ※1 | UTF-8 ※1 | 特定しない ※1
印刷定義ファイルの定義情報 | 帳票ファイル | UTF-16 | Shift-JIS UTF-16（BOMあり）※3 | Shift-JIS UTF-16（BOMあり）※3 | Shift-JIS UTF-16（BOMあり）※3 | Shift-JIS UTF-16（BOMあり）※3 | Shift-JIS UTF-16（BOMあり）※3
 | 複数様式情報定義ファイル 文書情報設定ファイル 接続情報ファイル 置き換え表管理情報ファイル Acrobat JavaScript定義ファイル ビューアプレファレンス定義ファイル | UTF-16 | Shift-JIS UTF-8（BOMあり）※4 UTF-16（BOMあり）※3 | Shift-JIS UTF-16（BOMあり）※3 | EUC UTF-16（BOMあり）※3 | UTF-8（BOMあり） UTF-8（BOMなし） UTF-16（BOMあり）※3 | UTF-16（BOMあり）※3, ※5
 | 新規用紙出力定義ファイル | UTF-16 | Shift-JIS UTF-8（BOMあり）※4 UTF-16（BOMあり）※3 | － | － | － | －
ユーザデータファイルの定義情報 | マッピングデータファイル ユーザ定義データファイル 可変記号値定義ファイル しおり定義ファイル 文書しおり定義ファイル 暗号化設定ファイル PDF仕分け定義ファイル | UTF-16 | Shift-JIS UTF-8（BOMあり）※4 UTF-16（BOMあり）※3 | Shift-JIS UTF-16（BOMあり）※3 | EUC ※6 UTF-16（BOMあり）※3 | UTF-8（BOMあり）※6 UTF-8（BOMなし）※6 UTF-16（BOMあり）※3 | UTF-16（BOMあり）※3, ※7
 | 帳票セット指定ファイル | Shift-JIS | Shift-JIS※8 UTF-8（BOMあり）※2, ※4 UTF-16（BOMあり）※2, ※3 | Shift-JIS UTF-16（BOMあり）※2, ※3 | EUC ※6 UTF-16（BOMあり）※2, ※3 | UTF-8（BOMあり）※6 UTF-8（BOMなし）※6 UTF-16（BOMあり）※2, ※3 | UTF-16（BOMあり）※3, ※7
 | 分割定義ファイル 仕分け定義ファイル | Shift-JIS | Shift-JIS※8 UTF-8（BOMあり）※4 UTF-16（BOMあり）※2, ※3 | Shift-JIS UTF-16（BOMあり）※2, ※3 | EUC ※2 UTF-16（BOMあり）※2, ※3 | UTF-8（BOMあり）※2 UTF-8（BOMなし）※2 UTF-16（BOMあり）※2, ※3 | UTF-16（BOMあり）※2, ※3
スプールデータの定義情報 |  | － | Shift-JIS | Shift-JIS | EUC ※2 | UTF-8（BOMなし）※2 | Shift-JIS （ASCII範囲）
構成定義ファイルの定義情報 | 出力先定義ファイル 帳票サーバプリンタクラス定義ファイル 印刷先定義ファイル 拠点プリンタクラス定義ファイル 帳票振り分け定義ファイル ユーザ管理ファイル クライアントプリンタクラス定義ファイル 宛先定義ファイル | Shift-JIS | Shift-JIS※8 | Shift-JIS | EUC ※2 | UTF-8（BOMなし）※2 | Shift-JIS （ASCII範囲）
 | 監視定義ファイル | Shift-JIS | Shift-JIS※8 UTF-8（BOMあり）※2, ※4 UTF-16（BOMあり）※2, ※3 | － | － | － | －
EUR Web Plug-In情報ファイルの定義情報 |  | Shift-JIS | Shift-JIS※8 | Shift-JIS | EUC ※2 | UTF-8（BOMなし）※2 | Shift-JIS （ASCII範囲）
印刷日時出力定義ファイルの定義情報 |  | UTF-16 | Shift-JIS※8 UTF-8（BOMあり）※2, ※4 UTF-16（BOMあり）※2, ※3 | Shift-JIS UTF-16（BOMあり）※2, ※3 | EUC ※6 UTF-16（BOMあり）※2, ※3 | UTF-8（BOMあり）※6 UTF-8（BOMなし）※6 UTF-16（BOMあり）※2, ※3 | UTF-16（BOMあり）※3
制御情報付データファイルの定義情報 |  | UTF-16※10 | Shift-JIS※8 UTF-8（BOMあり）※4 UTF-16（BOMあり）※3 | － | － | － | －
起動パラメタファイルの定義情報 |  | Shift-JIS | Shift-JIS※8 UTF-8（BOMあり）※2, ※4 UTF-16（BOMあり）※2, ※3 | － | － | － | －
帳票出力定義ファイル |  | Shift-JIS | Shift-JIS※8 UTF-8（BOMあり）※2, ※4 | Shift-JIS | EUC※2 | UTF-8（BOMあり）※2 UTF-8（BOMなし）※2 | Shift-JIS （ASCII範囲）
個人番号接続情報ファイル 個人番号フィールド情報ファイル |  | UTF-16 | Shift-JIS UTF-8（BOMあり）※4 UTF-16（BOMあり）※3, ※4 | － | － | － | －
環境設定ファイルのキーに指定する情報，および値 |  | Shift-JIS | Shift-JIS※8 | Shift-JIS | EUC ※2 | UTF-8（BOMなし）※2 | Shift-JIS （ASCII範囲）
ログファイルに出力される情報 |  | Shift-JIS | Shift-JIS※8 | UTF-16（BOMあり）※9 | UTF-16（BOMあり）※9 | UTF-16（BOMあり）※9 | UTF-16（BOMあり）※9
（凡例）

－：ユーザが文字集合を意識する必要がないことを示します。または，該当しません。

注※1

EUR Server Serviceのエンコーディングは，OSの言語およびロケール情報によって決まります。

なお，OSの言語およびロケール情報が，Shift-JIS，EUC，およびUTF-8のどれにも対応しない場合，EUR Server Serviceのエンコーディングを特定しません。そのため，入力データの文字コードの変換ができないので，入力データとして扱えるのは，表7-1に示す範囲のデータとなります。

注※2

Shift-JISエンコーディングで表現できる範囲を対象とします。

注※3

エンディアンは，BOMで自動判別します。

注※4

Windows環境にはロケールがないため，BOMで自動判別します。

注※5

EUR Server Serviceの実行環境がエンコーディングを特定しない環境の場合，帳票ファイル以外の印刷定義ファイルには，「UTF-16（BOMあり）」のファイルに加えて，その環境でEUR Print Serviceがサポートするエンコーディングのファイルを指定できます。

注※6

EUR Server - AdapterとEUR Server Service間でファイル転送時に文字コードを変換する場合，Shift-JISエンコーディングで表現できる範囲をサポート範囲とします。文字コードを変換する条件については，「1.2.2　ファイル転送時の文字コード変換」を参照してください。

注※7

EUR Server - Adapterの実行環境がエンコーディングを特定しない環境の場合，ファイル転送時に文字コードを変換しないため，ユーザデータファイルには「UTF-16（BOMあり）」のファイルに加えて，接続先のEUR Server Serviceの実行環境でEUR Print Serviceがサポートするエンコーディングのファイルを指定できます。文字コードを変換する条件については，「1.2.2　ファイル転送時の文字コード変換」を参照してください。

注※8

日本語以外のOSの場合はASCIIをサポートします。日本語OSの場合も「ロケール」と「表示言語」が一致しないときはASCIIだけをサポートします。

注※9

適用OSごとのエンディアンを次に示します。

適用OS | エンディアン
Windows | リトルエンディアン
AIX | ビッグエンディアン
HP-UX | ビッグエンディアン
Linux | リトルエンディアン
注※10

帳票ファイル名，ユーザ定義データファイル名，しおり定義ファイル名，およびeurpmcコマンドを実行するときのオプションの指定値については，Shift-JISエンコーディングで表現できる範囲をサポート範囲とします。なお，しおり定義ファイル名，およびeurpmcコマンドを実行するときのオプションの指定値は，上位主導型の帳票自動出力機能で使用する制御情報付データファイルの場合にだけ定義する要素です。BSP-RM連携機能で使用する制御情報付データファイルではサポートしていません。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 138 / 195


7.2.2 起動部品，コマンド，環境変数および標準出力の文字集合とエンコーディング : EUR システム設計ガイド

  • 139 / 195

  • 表紙

  • 7.　EURの入力ファイルの設計

  • 7.2　エンコーディング

  • 7.2.2　起動部品，コマンド，環境変数および標準出力の文字集合とエンコーディング

7.2.2　起動部品，コマンド，環境変数および標準出力の文字集合とエンコーディング

EUR Server Serviceの起動部品・コマンド・環境変数で指定する各種ファイル名，パス，プリンタ名，標準出力などの対応する文字集合とエンコーディングを次の表に説明します。

表7‒2 EUR Server Serviceの起動部品，コマンド，環境変数，および標準出力の対応する文字集合とエンコーディング
種類 | 対応する文字集合※1 | エンコーディング，またはコードページ
 |  | Windows | UNIX／Linux
 |  |  | Shift-JIS ※2 | EUC ※2 | UTF-8 ※2 | 特定しない ※2
ActiveX起動部品 | Shift-JIS | － | －
SS-ActiveX起動部品 | Shift-JIS | － | －
Java起動部品 | Shift-JIS | － | －
Java起動部品 （データをメモリ入力する場合） | UTF-16 | UTF-16（BOMなし）※3 UTF-16（BOMあり）※4 | UTF-16（BOMなし）※3 UTF-16（BOMあり）※4 | UTF-16（BOMなし）※3 UTF-16（BOMあり）※4 | UTF-16（BOMなし）※3 UTF-16（BOMあり）※4 | UTF-16（BOMなし）※3 UTF-16（BOMあり）※4
Java起動部品 （仕分けまたは分割したEPF形式ファイルをメモリ入力する場合） | Shift-JIS | UTF-16（BOMなし）※3 UTF-16（BOMあり）※4 | UTF-16（BOMなし）※3 UTF-16（BOMあり）※4 | UTF-16（BOMなし）※3 UTF-16（BOMあり）※4 | UTF-16（BOMなし）※3 UTF-16（BOMあり）※4 | UTF-16（BOMなし）※3 UTF-16（BOMあり）※4
SS-Java起動部品 | Shift-JIS | － | －
COBOL起動部品 | Shift-JIS | 932 | Shift-JIS | EUC_JP.EUR | UTF8 | ASCII
コマンド起動部品（eurpmcコマンド） | Shift-JIS | 932 | Shift-JIS | EUC_JP.EUR | UTF8 | ASCII
SS-コマンド起動部品（eurpmlscコマンド） | Shift-JIS | 932 | Shift-JIS | EUC_JP.EUR | UTF8 | ASCII
Server Service制御コマンド（eurpmctrlコマンド） | Shift-JIS | 932 | Shift-JIS | EUC_JP.EUR | UTF8 | ASCII
Spool Service制御コマンド（eurpmlsctrlコマンド） | Shift-JIS | 932 | Shift-JIS | EUC_JP.EUR | UTF8 | ASCII
eurpmcepfviewerコマンド | Shift-JIS | 932 | Shift-JIS | EUC_JP.EUR | UTF8 | ASCII
BSP-RM連携コマンド（eursmprコマンド） | Shift-JIS | 932 | －
環境設定ファイル | Shift-JIS | 932 | Shift-JIS | EUC_JP.EUR | UTF8 | ASCII
標準出力 | Shift-JIS | 932 | Shift-JIS | EUC_JP.EUR | UTF8 | ASCII
（凡例）

－：該当する項目がないことを示します。

注※1

制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」は入力できません。

注※2

各OSの言語およびロケール情報によって，EUR Server Serviceの各プログラムが使用するエンコーディングを設定します。

各OSの言語およびロケール情報が，Shift-JIS，EUC，およびUTF-8のどれにも対応しない場合，EUR Server Serviceのエンコーディングを特定しません。そのため，入力データの文字コードの変換ができないので，入力データとして扱えるのは，表7-2に示す範囲のデータとなります。

注※3

OSごとに，次に示すエンディアンに判別されます。

OS | エンディアン
Windows | リトルエンディアン
AIX | ビッグエンディアン
HP-UX | ビッグエンディアン
Linux | リトルエンディアン
注※4

エンディアンは，BOMで自動判別します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 139 / 195


7.2.3 画面に入力する項目の文字集合 : EUR システム設計ガイド

  • 140 / 195

  • 表紙

  • 7.　EURの入力ファイルの設計

  • 7.2　エンコーディング

  • 7.2.3　画面に入力する項目の文字集合

7.2.3　画面に入力する項目の文字集合

帳票管理GUIなどの画面に入力する項目には，Shift-JIS範囲の文字が入力できます。

なお，制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」は使用できません。これらの文字を指定した場合，帳票管理GUI，［EUR Server Service 構成定義］ダイアログ，［EUR Spool Service 構成定義］ダイアログ，および［EUR Client 構成定義］ダイアログを操作できないことがあります。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 140 / 195


7.3 入力ファイル名の規則 : EUR システム設計ガイド

  • 141 / 195

  • 表紙

  • 7.　EURの入力ファイルの設計

  • 7.3　入力ファイル名の規則

7.3　入力ファイル名の規則

〈この節の構成〉

  • 7.3.1　ファイル名に使用できる文字数

  • 7.3.2　EURで使用するファイル名に指定できる文字

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 141 / 195


7.3.1 ファイル名に使用できる文字数 : EUR システム設計ガイド

  • 142 / 195

  • 表紙

  • 7.　EURの入力ファイルの設計

  • 7.3　入力ファイル名の規則

  • 7.3.1　ファイル名に使用できる文字数

7.3.1　ファイル名に使用できる文字数

ファイル名に指定できる文字数（フルパス）を，次に示します。

表7‒3 ファイル名に指定できる文字数
適用OS | ファイル名に指定できる文字数
Windows | 259文字以内※
HP-UX | 1,023バイト以内
AIX | 1,023バイト以内
Linux | 1,023バイト以内
注※

Windows環境で相対パス，またはファイル名だけを指定する場合は，255文字以内です。

ファイル名は，EUR サーバ帳票出力機能が稼働するOSのファイルシステムのファイル名称規則に従って指定してください。なお，EUR サーバ帳票出力機能を実行するUNIX環境の文字ロケールがShift JISの場合，NEC選定IBM特殊文字（89区～92区）の文字を使用したファイル名のファイルは，使用できません。

ほかのOSから転送した帳票ファイルやデータファイルを使用する場合は，使用できる文字数やファイル名称規則が異なるので注意してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 142 / 195


7.3.2 EURで使用するファイル名に指定できる文字 : EUR システム設計ガイド

  • 143 / 195

  • 表紙

  • 7.　EURの入力ファイルの設計

  • 7.3　入力ファイル名の規則

  • 7.3.2　EURで使用するファイル名に指定できる文字

7.3.2　EURで使用するファイル名に指定できる文字

次に示す文字は，ファイル名には使用できません。

\　/　:　*　?　"　<　>　|

英数字は，大文字，小文字の区別はしません。また，空白，および「.」も使用できます。ファイル名に複数個の「.」を使用している場合は，最後の「.」を区切り文字として扱います。

〈この項の構成〉

  • (1)　ファイル名にNEC選定IBM拡張文字を指定する場合の注意

(1)　ファイル名にNEC選定IBM拡張文字を指定する場合の注意

UNIX版 EUR サーバ帳票出力機能をShift JISロケールで実行すると，コマンドライン，帳票セット指定ファイル，複数様式定義ファイル，およびPDF仕分け定義ファイルのファイル名にNEC選定IBM拡張文字を指定できません。

入力ファイルにNEC選定IBM拡張文字を指定した場合は，エラーとなります。

出力ファイルにNEC選定IBM拡張文字を指定した場合は，NEC選定IBM拡張文字がIBM拡張文字に置き換えられて出力されます。

なお，Windows版 EUR サーバ帳票出力機能では，NEC選定IBM拡張文字を出力できます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 143 / 195


8. 帳票出力環境の設計 : EUR システム設計ガイド

  • 144 / 195

  • 表紙

  • 8.　帳票出力環境の設計

8.　帳票出力環境の設計

この章では，帳票出力環境を設計するに当たり，EURで設定が必要な項目を検討します。決定した内容を基に，システム構築時の設定内容の一覧を作成してください。

〈この章の構成〉

  • 8.1　EURの起動管理

  • 8.2　サーバ環境の設計

  • 8.3　クライアント環境の設計

  • 8.4　動作環境の設定

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 144 / 195


8.1 EURの起動管理 : EUR システム設計ガイド

  • 145 / 195

  • 表紙

  • 8.　帳票出力環境の設計

  • 8.1　EURの起動管理

8.1　EURの起動管理

EURのサーバでは，次に示すコンポーネントの起動や停止を管理します。

  • EUR Server Service

  • EUR Server - Spool Service

  • ファイル監視サービス（帳票自動出力機能を使用する場合）

また，EURのクライアントでは，次に示すコンポーネントが自動起動します。

  • EUR Client Service

〈この節の構成〉

  • 8.1.1　EUR Server Serviceの起動管理

  • 8.1.2　EUR Server - Spool Serviceの起動管理

  • 8.1.3　ファイル監視サービスの起動管理

  • 8.1.4　EUR Client Serviceの起動管理

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 145 / 195


8.1.1 EUR Server Serviceの起動管理 : EUR システム設計ガイド

  • 146 / 195

  • 表紙

  • 8.　帳票出力環境の設計

  • 8.1　EURの起動管理

  • 8.1.1　EUR Server Serviceの起動管理

8.1.1　EUR Server Serviceの起動管理

EUR Server Serviceの起動や停止の管理には，起動管理定義を使用します。起動管理定義には，起動するEUR Server Serviceの識別名や環境設定ファイルの格納先などの情報を定義します。

EUR Server Serviceの起動管理方法には，次の2とおりの方法があります。環境によって管理方法を検討してください。

  • ［EUR Server Service 起動管理］ダイアログを使用して管理する（Windows環境）

  • Server Service制御コマンド（eurpmctrlコマンド）を使用して管理する（Windows環境およびUNIX／Linux環境）

事前に，EUR Server Serviceの識別名，自動起動するかどうか，および環境設定ファイルのパスを決めておいてください。

［EUR Server Service 起動管理］ダイアログおよびServer Service制御コマンド（eurpmctrlコマンド）での定義方法の詳細については，マニュアル「EUR システム構築ガイド」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 146 / 195


8.1.2 EUR Server - Spool Serviceの起動管理 : EUR システム設計ガイド

  • 147 / 195

  • 表紙

  • 8.　帳票出力環境の設計

  • 8.1　EURの起動管理

  • 8.1.2　EUR Server - Spool Serviceの起動管理

8.1.2　EUR Server - Spool Serviceの起動管理

EUR Server - Spool Serviceの起動や停止の管理は，次の方法で行います。環境によって管理方法を検討してください。

  • OSのサービス管理機能を使用して管理する（Windows環境）

  • Spool Service制御コマンド（eurpmlsctrlコマンド）を使用して管理する（UNIX／Linux環境）

OSのサービス管理機能の詳細については，OSのマニュアルを参照してください。

Spool Service制御コマンド（eurpmlsctrlコマンド）の詳細については，マニュアル「EUR システム構築ガイド」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 147 / 195


8.1.3 ファイル監視サービスの起動管理 : EUR システム設計ガイド

  • 148 / 195

  • 表紙

  • 8.　帳票出力環境の設計

  • 8.1　EURの起動管理

  • 8.1.3　ファイル監視サービスの起動管理

8.1.3　ファイル監視サービスの起動管理

帳票自動出力機能を使用する場合は，ファイル監視サービスを起動しておく必要があります。

ファイル監視サービス（EUR File Monitor Service）の起動や停止は，次の方法で行います。

  • OSのサービス管理機能を使用して管理する（Windows環境）

    OSのサービス管理機能の詳細については，OSのマニュアルを参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 148 / 195


8.1.4 EUR Client Serviceの起動管理 : EUR システム設計ガイド

  • 149 / 195

  • 表紙

  • 8.　帳票出力環境の設計

  • 8.1　EURの起動管理

  • 8.1.4　EUR Client Serviceの起動管理

8.1.4　EUR Client Serviceの起動管理

クライアントPCでのEUR DesignerやEUR Viewerを使用した帳票出力，およびEUR Web Plug-Inを使用したWebブラウザからの印刷やプレビューでは，EUR Client Serviceを使用します。

EUR Client Serviceは，クライアントPCにEUR Clientをインストールすると，スタートメニューのスタートアップに登録※され，Windowsにログインしたときに自動起動してタスクトレイに常駐します。

なお，配送印刷機能を使用する場合は，EUR Client Serviceをいったん停止し，EUR Client Serviceの環境設定ファイルで配送印刷機能を使用するための設定をしてから，EUR Client Serviceを再起動します。EUR Client Serviceが起動すると，EUR Client Serviceのログインダイアログが表示され，ログイン後に配送印刷が開始されます。

配送印刷機能を使用する場合のEUR Client Serviceの起動と停止の詳細については，マニュアル「EUR 帳票出力 機能解説 EUR Server編」の「帳票を配送印刷する手順」を参照してください。

注※

EUR ClientのサイレントインストールでEUR Web Plug-Inだけをインストールした場合は，スタートメニューのスタートアップに「EUR Client Service」は登録されません。EUR Clientのサイレントインストールの詳細については，マニュアル「EUR システム構築ガイド」の「EUR Clientのインストール」を参照してください。

重要

EUR クライアント帳票出力機能では，サービス起動（Windowsログインなし）での印刷はできません。サービス起動（Windowsログインなし）での印刷をする場合は，EUR サーバ帳票出力機能を使用してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 149 / 195


8.2 サーバ環境の設計 : EUR システム設計ガイド

  • 150 / 195

  • 表紙

  • 8.　帳票出力環境の設計

  • 8.2　サーバ環境の設計

8.2　サーバ環境の設計

Web/アプリケーションサーバ，帳票サーバ，スプールサーバの環境を設計します。

ここでは，それぞれのサーバでの設定項目について説明します。使用する環境に合わせて，設定する内容を検討してください。

設定手順の詳細については，マニュアル「EUR システム構築ガイド」を参照してください。

〈この節の構成〉

  • 8.2.1　Web/アプリケーションサーバの設定

  • 8.2.2　帳票サーバの設定

  • 8.2.3　スプールサーバの設定

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 150 / 195


8.2.1 Web/アプリケーションサーバの設定 : EUR システム設計ガイド

  • 151 / 195

  • 表紙

  • 8.　帳票出力環境の設計

  • 8.2　サーバ環境の設計

  • 8.2.1　Web/アプリケーションサーバの設定

8.2.1　Web/アプリケーションサーバの設定

Web/アプリケーションサーバで設定しておく内容について説明します。

〈この項の構成〉

  • (1)　Web/アプリケーションサーバの選択

  • (2)　準備しておく内容

  • (3)　業務アプリケーションとの連携

(1)　Web/アプリケーションサーバの選択

EURでは，帳票管理GUIサービスや配送サービスを使用するためのWeb/アプリケーションサーバとして，EUR Application Serviceを提供しています。EUR DeveloperまたはEUR Server Enterpriseをインストールすると，次のサービスプログラムが自動でインストールされます。

  • EUR Application Service

  • EUR HTTP Server

ただし，SSLを使用する，大量のアクセスを処理するための性能が求められるなどの高度な要件が必要な場合は，要件に合ったWeb/アプリケーションサーバを別途構築する必要があります。

なお，EUR Application Serviceは，Hitachi Application Serverと同じマシンに配置できます。

ページの先頭へ

(2)　準備しておく内容

Web/アプリケーションサーバを設定するために準備しておく内容を次に示します。

  • 前提コンポーネント

    EUR Server - AdapterおよびEUR Server - Spool Service Adapter

  • 前提プログラム

    JDK 5.0またはJDK6.0，およびJDK 5.0以降を使用するWeb/アプリケーションサーバ

  • 帳票管理GUIのサービスプログラム

    eurpmrsgui.ear

  • 配送サービスのサービスプログラム

    eurssdeli.ear

また，Web/アプリケーションサーバに登録したサービスを起動するタイミングについて検討しておいてください。

eurpmrsgui.earファイルおよびeurssdeli.earファイルの格納先や，Web/アプリケーションサーバの構築手順についてはマニュアル「EUR システム構築ガイド」を参照してください。

ページの先頭へ

(3)　業務アプリケーションとの連携

ユーザの認証情報（ユーザ名と確認キー）を業務アプリケーションと帳票管理GUIとで連携させることで，［ユーザの設定］画面の表示を省略できます。これにより，帳票管理GUIを利用するたびに，ユーザ名および確認キーを入力する手間を省けます。

ユーザの認証情報の連携には，ブラウザのCookieを使用します。ユーザの認証情報を，業務アプリケーションと帳票管理GUIとで連携させたときのシステムの利用イメージを，次の図に示します。

図8‒1　ユーザの認証情報を連携させたときのシステムの利用イメージ

[図データ]

システムへのログイン時に入力した，ユーザIDやパスワードなどの認証情報を，ブラウザのCookieに保存しておきます。帳票管理GUIの起動時に，Cookieに保存された認証情報を読み込み，ユーザとして設定します。これによって，ユーザ名および確認キーを入力することなく，帳票管理GUIを利用できます。

連携方法の詳細については，マニュアル「EUR システム構築ガイド」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 151 / 195


8.2.2 帳票サーバの設定 : EUR システム設計ガイド

  • 152 / 195

  • 表紙

  • 8.　帳票出力環境の設計

  • 8.2　サーバ環境の設計

  • 8.2.2　帳票サーバの設定

8.2.2　帳票サーバの設定

帳票サーバでは，スプールサーバの登録およびプリンタクラスの設定を行います。

設定した内容は，構成定義ファイルに反映されます。構成定義ファイルの詳細はマニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

〈この項の構成〉

  • (1)　スプールサーバの登録

  • (2)　帳票サーバのプリンタクラスの設定

(1)　スプールサーバの登録

スプールサーバのIPアドレスを出力先として登録します。［EUR Server Service 構成定義］ダイアログで設定します。設定項目を次に示します。

［EUR Server Service 構成定義］ダイアログでの項目 | 設定内容の説明 | 設定要否
［出力先］グループボックス | 出力先名を登録するか，デフォルトの出力先※を登録するかのどちらかを選択します。 | 必須
［出力先名］テキストボックス | 出力先名を登録する場合の出力先名を指定します。 | 出力先名を登録する場合は必須
［IPアドレス］テキストボックス | スプールサーバのIPアドレスを指定します。 | 必須
［説明］テキストボックス | スプールサーバの説明を入力します。 | 任意
注※

デフォルトの出力先に設定したIPアドレスは，通常使うプリンタとして登録されます。

ページの先頭へ

(2)　帳票サーバのプリンタクラスの設定

帳票サーバでは，プリンタとトレイを組み合わせて，帳票サーバのプリンタクラスとして定義できます。帳票サーバのプリンタクラスを設定すると，プリンタに任意の名前を付けられるため，プリンタを簡単に管理できます。また，プリンタとトレイを一度に指定できます。

帳票サーバのプリンタクラスの設定は，EUR Server Serviceがインストールされた帳票サーバの［EUR Server Service 構成定義］ダイアログで行います。

設定項目を次に示します。

［EUR Server Service 構成定義］ダイアログでの項目 | 設定内容の説明 | 設定要否
［プリンタクラス］グループボックス | 帳票サーバのプリンタクラス名を登録するか，デフォルトの帳票サーバのプリンタクラス※を登録するかのどちらかを選択します。 | 必須
［プリンタクラス名］テキストボックス | 帳票サーバのプリンタクラス名を指定します。 | プリンタクラスを登録する場合は必須
［プリンタ名］リストボックス | プリンタクラスに設定するプリンタ名を選択します。 | 必須
［トレイ名］リストボックス | プリンタクラスに設定するプリンタのトレイ名を選択します。 | 任意
［説明］テキストボックス | プリンタクラスの説明を入力します。 | 任意
注※

帳票サーバでプリンタクラスを指定していない場合，または指定されたプリンタクラスが定義されていない場合に，印刷するプリンタをデフォルトプリンタクラスとして一つ定義しておくことができます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 152 / 195


8.2.3 スプールサーバの設定 : EUR システム設計ガイド

  • 153 / 195

  • 表紙

  • 8.　帳票出力環境の設計

  • 8.2　サーバ環境の設計

  • 8.2.3　スプールサーバの設定

8.2.3　スプールサーバの設定

スプールサーバでは，プリンタクラスの設定および帳票振り分け定義の設定を行います。

設定した内容は，構成定義ファイルに反映されます。構成定義ファイルの詳細はマニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

〈この項の構成〉

  • (1)　スプールサーバのプリンタクラスの設定

  • (2)　帳票振り分け定義の設定

(1)　スプールサーバのプリンタクラスの設定

スプールサーバでは，プリンタとトレイを組み合わせて，スプールサーバのプリンタクラスとして定義できます。スプールサーバのプリンタクラスを設定すると，プリンタに任意の名前を付けられるため，プリンタを簡単に管理できます。また，プリンタとトレイを一度に指定できます。

スプールサーバのプリンタクラスの設定は，EUR Server - Spool Serviceがインストールされたスプールサーバの［EUR Spool Service 構成定義］ダイアログで行います。

設定項目を次に示します。

［EUR Spool Service 構成定義］ダイアログでの項目 | 設定内容の説明 | 設定要否
［プリンタクラス］グループボックス | スプールサーバのプリンタクラス名を登録するか，デフォルトのスプールサーバのプリンタクラス※を登録するかのどちらかを選択します。 | 必須
［プリンタクラス名］テキストボックス | スプールサーバのプリンタクラス名を指定します。 | プリンタクラスを登録する場合は必須
［プリンタ名］リストボックス | プリンタクラスに設定するプリンタ名を選択します。 | 必須
［トレイ名］リストボックス | プリンタクラスに設定するプリンタのトレイ名を選択します。 | 任意
［説明］テキストボックス | プリンタクラスの説明を入力します。 | 任意
注※

スプールサーバでプリンタクラスを指定していない場合，または指定されたプリンタクラスが定義されていない場合に，印刷するプリンタをデフォルトプリンタクラスとして一つ定義しておくことができます。

ページの先頭へ

(2)　帳票振り分け定義の設定

スプールサーバでは，帳票名ごとに自動的にプリンタを定義して印刷できます。帳票名ごとに自動的にプリンタを定義することを帳票振り分け定義といいます。帳票振り分け定義をするためには，帳票名を振り分けグループに分類して，帳票名ごとにプリンタクラスを設定します。帳票名を振り分けグループに分類することで，同じ名前の帳票を別のプリンタで印刷できます。

帳票振り分け定義の設定は，［EUR Spool Service 構成定義］ダイアログの［帳票振り分け］タブで行います。Windows版のEUR Server - Spool Serviceがインストールされたスプールサーバで設定します。

設定項目を次に示します。

［EUR Spool Service 構成定義］ダイアログでの項目 | 設定内容の説明 | 設定要否
［振り分けグループ］グループボックス | 振り分けグループ名を登録するか，デフォルトの振り分けグループ※1を登録するかのどちらかを選択します。 | 必須
［振り分けグループ名］テキストボックス | 振り分けグループ名を指定します。 | 振り分けグループを登録する場合は必須
［帳票］グループボックス | 帳票名を登録するか，デフォルトの帳票※2を登録するかのどちらかを選択します。 | 必須
［帳票名］テキストボックス | 帳票名を入力します。 | 帳票名を登録する場合は必須
［プリンタクラス名］テキストボックス | EUR Server - Spool Serviceに登録されているプリンタクラスを選択します。 | 任意
［説明］テキストボックス | 振り分けグループの説明を入力します。 | 任意
注※1

帳票サーバで振り分けグループを指定していない，または指定された振り分けグループが定義されていない帳票を分類するグループを，デフォルトの振り分けグループとして一つ定義しておくことができます。

注※2

振り分けグループ名に分類されていない帳票を，デフォルトの帳票として一つ定義しておくことができます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 153 / 195


8.3 クライアント環境の設計 : EUR システム設計ガイド

  • 154 / 195

  • 表紙

  • 8.　帳票出力環境の設計

  • 8.3　クライアント環境の設計

8.3　クライアント環境の設計

クライアントPCの環境を設計します。

〈この節の構成〉

  • 8.3.1　クライアントPCの設定

  • 8.3.2　クライアントプリンタクラスの設定

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 154 / 195


8.3.1 クライアントPCの設定 : EUR システム設計ガイド

  • 155 / 195

  • 表紙

  • 8.　帳票出力環境の設計

  • 8.3　クライアント環境の設計

  • 8.3.1　クライアントPCの設定

8.3.1　クライアントPCの設定

クライアントPCを設定するために準備しておく内容を次に示します。

  • 前提コンポーネント

    スプールデータを印刷する場合はEUR Web Plug-In（印刷用）を，スプールデータをプレビュー表示する場合はEUR Web Plug-In（プレビュー用）を準備してください。

  • 前提プログラム

    次のどれかのInternet Explorerを使用してください。

    • Internet Explorer 9（32ビット版）

    • Internet Explorer 10（Windowsデスクトップ版）

    • Internet Explorer 11（Windowsデスクトップ版）

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 155 / 195


8.3.2 クライアントプリンタクラスの設定 : EUR システム設計ガイド

  • 156 / 195

  • 表紙

  • 8.　帳票出力環境の設計

  • 8.3　クライアント環境の設計

  • 8.3.2　クライアントプリンタクラスの設定

8.3.2　クライアントプリンタクラスの設定

クライアントPCでは，プリンタとトレイを組み合わせたクライアントプリンタクラスを定義します。クライアントプリンタクラスを設定すると，プリンタに任意の名前を付けられるため，プリンタを簡単に管理できます。また，プリンタとトレイを一度に指定できます。

クライアントプリンタクラスの設定は，［EUR Client 構成定義］ダイアログで行います。EUR Client ServiceがインストールされたクライアントPCで設定します。

設定項目を次に示します。

［EUR Client 構成定義］ダイアログでの項目 | 設定内容の説明 | 設定要否
［プリンタクラス］グループボックス | クライアントPCのプリンタクラス名を登録するか，デフォルトのクライアントPCのプリンタクラス※を登録するかのどちらかを選択します。 | 必須
［プリンタクラス名］テキストボックス | クライアントPCのプリンタクラス名を指定します。 | プリンタクラスを登録する場合は必須
［プリンタ名］リストボックス | プリンタクラスに設定するプリンタ名を選択します。 | 必須
［トレイ名］リストボックス | プリンタクラスに設定するプリンタのトレイ名を選択します。 | 任意
［説明］テキストボックス | プリンタクラスの説明を入力します。 | 任意
注※

クライアントPCでプリンタクラスを指定していない場合，または指定されたプリンタクラスが定義されていない場合に，印刷するプリンタをデフォルトプリンタクラスとして一つ定義しておくことができます。

〈この項の構成〉

  • (1)　クライアントプリンタクラスの配布

(1)　クライアントプリンタクラスの配布

クライアントプリンタクラスの設定は，クライアントプリンタクラス定義ファイル（ClientPrinterClass.conf）に保存されます。クライアントプリンタクラス定義ファイル（ClientPrinterClass.conf）は，環境設定ファイル（EURPMCL.ini）のPATHセクションのCONFキーに設定したパスに格納されます。

クライアントプリンタクラス定義ファイルをシステム管理者がひな型として配布すれば，各クライアントPCでクライアントプリンタクラスを設定する手間が省けます。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 156 / 195


8.4 動作環境の設定 : EUR システム設計ガイド

  • 157 / 195

  • 表紙

  • 8.　帳票出力環境の設計

  • 8.4　動作環境の設定

8.4　動作環境の設定

コンポーネントや機能ごとの動作環境は，環境設定ファイルで設定します。

環境設定ファイルの概要を次の表に示します。

表8‒1 環境設定ファイルの一覧
環境 | コンポーネント | 機能 | ファイル名 | 説明
サーバ | EUR Print Service | EUR Print Service | EURPS_ENV※ | EUR Print Serviceの動作環境を設定するファイルです。
 | EUR Server Service | EUR Server Service | EURPM.ini※ | EUR Server Serviceの動作環境を設定するファイルです。
 |  | Server Service制御コマンド（eurpmctrlコマンド） | EURPMCTRL.ini | Server Service制御コマンド（eurpmctrlコマンド）の動作環境を設定するファイルです。
 | EUR Server - Adapter | EUR Server - Adapter | EURPMADP.ini※ | EUR Server - Adapterの動作環境を設定するファイルです。
 |  | BSP-RM連携コマンド（eursmprコマンド） | eursmpr.ini | BSP-RM連携コマンド（eursmprコマンド）の動作環境を設定するファイルです。
 |  | ファイル監視サービス | eurfm.ini | ファイル監視サービスの動作環境を設定するファイルです。
 |  | ジョブ実行プログラム | eurivk.ini | ジョブ実行プログラムの動作環境を設定するファイルです。
 | EUR Server - Spool Service | EUR Server - Spool Service | EURPMLS.ini※ | EUR Server - Spool Serviceの動作環境を設定するファイルです。
 |  | Spool Service制御コマンド（eurpmlsctrlコマンド） | EURPMLSCTRL.ini | Spool Service制御コマンド（eurpmlsctrlコマンド）の動作環境を設定するファイルです。
 | EUR Server - Spool Service Adapter | EUR Server - Spool Service Adapter | EURPMLSADP.ini※ | EUR Server - Spool Service Adapterの動作環境を設定するファイルです。
 |  | 帳票管理GUI | EURPMRSGUI.ini | 帳票管理GUIの動作環境を設定するファイルです。
クライアント | EUR Client Service | EUR Client Service | EURPMCL.ini | EUR Client Serviceの動作環境を設定するファイルです。
注※

デフォルトのファイル名です。

それぞれの環境設定ファイルで指定できる内容の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 157 / 195


9. 帳票デザインの設計 : EUR システム設計ガイド

  • 158 / 195

  • 表紙

  • 9.　帳票デザインの設計

9.　帳票デザインの設計

この章では，帳票のデザインを検討します。

なお，EUR 帳票作成機能での帳票作成の詳細については，マニュアル「EUR 帳票作成 操作ガイド」を参照してください。

〈この章の構成〉

  • 9.1　帳票デザインを設計する

  • 9.2　帳票デザイン設計時の注意

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 158 / 195


9.1 帳票デザインを設計する : EUR システム設計ガイド

  • 159 / 195

  • 表紙

  • 9.　帳票デザインの設計

  • 9.1　帳票デザインを設計する

9.1　帳票デザインを設計する

帳票デザインを設計するときには，目的の帳票の要素に合わせてEUR 帳票作成機能で使用する機能を決定します。

なお，EURで表を作成する場合，すべてのデータをドラッグアンドドロップで貼り付ける必要はありません。1行目のデータを貼り付けたあとで，繰り返し機能を設定すれば，簡単に表を作成できます。

帳票のレイアウトに関する主な機能を次に示します。詳細は，それぞれの参照先マニュアルを参照してください。

表9‒1 帳票のレイアウトに関する主な機能
目的 |  | 使用する機能 | 参照先マニュアル
既存帳票からの移行 | Word文書またはExcel文書から移行したい | Word/Excel文書を利用した帳票 | EUR 帳票作成 操作ガイド
 | メインフレームで作成していた帳票から移行したい | LPIおよびCPIでの指定
用紙の形態 | プレプリント用紙に出力したい | 下敷き機能
フォーマットの切り替え | 1ページ目と2ページ目以降のフォーマットを変更したい（帳票ファイルは一つだけ作成） | 表紙
 | データや帳票の切り替わるタイミングで，帳票ファイルのフォーマットを変更したい（帳票ファイルを複数作成） | 複数様式での帳票出力 | EUR 帳票出力 機能解説 EUR Server編
データの加工 | 設定した条件によって，データを強調したり非表示にしたりしたい | 条件付きアイテム | EUR 帳票作成 操作ガイド
 | データを置換して表示したい | アイテムの置き換え
 | データの前後に「￥」や「様」などの任意の文字が出るようにしたい | 前付加文字，後付加文字
 | 文字データの表示形式を独自に設定したい | 任意書式
データの集計 | 帳票上でデータを集計したい | データの集計
 | ページ番号を挿入したい | ページ番号アイテム
 | 印刷した日付や時刻を挿入したい | 印刷日付・印刷時刻アイテム
帳票作成の効率向上 | EUR 帳票作成機能で自作した図形を登録しておきたい | 部品登録機能
 | 大量の帳票の情報を修正する手間を省きたい | 帳票定義情報ファイルからの帳票定義
 | 帳票を定義するための環境を自分用にカスタマイズしたい | デフォルトオプションの設定

EUR 帳票作成機能で簡単な帳票を作成する手順については，マニュアル「はじめての帳票作成」にも記載があるので参考にしてください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 159 / 195


9.2 帳票デザイン設計時の注意 : EUR システム設計ガイド

  • 160 / 195

  • 表紙

  • 9.　帳票デザインの設計

  • 9.2　帳票デザイン設計時の注意

9.2　帳票デザイン設計時の注意

帳票デザインを設計するときの注意事項について説明します。

〈この節の構成〉

  • 9.2.1　帳票の印刷範囲についての注意

  • 9.2.2　EUR サーバ帳票出力機能で出力する場合の注意

  • 9.2.3　Excel形式ファイルに出力する場合の注意

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 160 / 195


9.2.1 帳票の印刷範囲についての注意 : EUR システム設計ガイド

  • 161 / 195

  • 表紙

  • 9.　帳票デザインの設計

  • 9.2　帳票デザイン設計時の注意

  • 9.2.1　帳票の印刷範囲についての注意

9.2.1　帳票の印刷範囲についての注意

EURの帳票は，［用紙の設定］ダイアログで設定された余白に従って印刷します。このため出力先プリンタによっては，［用紙の設定］ダイアログで設定した左上余白よりプリンタのハードマージンが大きいと，帳票がハードマージンの分だけ右下にずれて印刷されたり，右下方向の余白よりプリンタのハードマージンが大きいと，帳票の右下方向が欠けて印刷されたりする場合があります。あらかじめ出力先プリンタの印刷範囲を調査した上で，帳票の余白を設定してください。

印刷の結果，帳票の一部が欠けてしまった場合は，［ファイル］メニューの［用紙の設定］を選択し，欠けた方向の余白を大きくして再度印刷してください。

なお，コマンドのオプション，または印刷ダイアログで，ページ番号の印刷を設定して印刷すると，ページ番号を帳票の余白の部分に印刷します。このため，ページ番号印刷位置の余白の外側5mmまでが，出力先プリンタの印刷できる範囲内でなければなりません。また，使用するプリンタとプリンタドライバの組み合わせによっては，プリンタのハード的な印刷できる範囲よりも小さくなる場合がありますので注意してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 161 / 195


9.2.2 EUR サーバ帳票出力機能で出力する場合の注意 : EUR システム設計ガイド

  • 162 / 195

  • 表紙

  • 9.　帳票デザインの設計

  • 9.2　帳票デザイン設計時の注意

  • 9.2.2　EUR サーバ帳票出力機能で出力する場合の注意

9.2.2　EUR サーバ帳票出力機能で出力する場合の注意

EUR 帳票作成機能で設計した帳票をEUR サーバ帳票出力機能で出力する場合は，次に示すEUR サーバ帳票出力機能で使用できる機能範囲で帳票を設計してください。

〈この項の構成〉

  • (1)　帳票の設計

  • (2)　データの準備

  • (3)　その他

(1)　帳票の設計

EUR サーバ帳票出力機能で帳票を出力する場合は，次に示すバージョン以降のEUR 帳票作成機能で設計してください。

  • P-2CD2-5DA4　　EUR Developer　　10-00以降

  • P-2CD2-56A4　　EUR Designer　　10-00以降

  • P-2CD2-5D9L　　uCosminexus EUR Developer　　09-10以降

  • P-2CD2-5694　　uCosminexus EUR Designer　　09-00以降

  • P-2CD2-5794　　uCosminexus EUR Developer　　09-00以降

  • P-26D2-5684　　uCosminexus EUR Designer　　08-00以降

  • P-26D2-5784　　uCosminexus EUR Developer　　08-00以降

  • P-26D2-3274　　EUR Professional Edition　　07-50以降

  • P-26D2-3254　　EUR Professional Edition　　05-00以降

  • P-26D2-3244　　EUR Professional Edition　　04-01以降

  • P-26D2-3134　　EUR　　03-00以降

  • P-26D2-3234　　EUR Professional Edition　　03-00以降

  • P-2651-8534　　SEWB+/EUR Professional Edition　　03-00以降

使用できる機能は，EUR 帳票作成機能の各バージョンで使用できる範囲とします。

ページの先頭へ

(2)　データの準備

  • EUR サーバ帳票出力機能で扱えるデータファイルは，CSV形式およびDAT形式，FIX形式です。

  • EUR サーバ帳票出力機能では，ディクショナリファイルを使用することはできません。フィールド定義は，ディクショナリファイルを使用しないで，「標準」の定義方法で定義してください。ディクショナリファイルを使用している場合は，［データのプロパティ］ダイアログの［データ情報］ページでフィールド定義情報の定義方法を「標準」にしてから，フォームシートファイルに保存してください。

  • EUR 帳票作成機能では，サンプルデータを使って帳票を設計できますが，EUR サーバ帳票出力機能では，使用したサンプルデータを読み込むことはできません。

  • EUR サーバ帳票出力機能では，クリップボードから読み込んだデータを使用することはできません。

  • EUR サーバ帳票出力機能では，稼働環境によって使用できる入力ファイルでの文字コードと外字の扱いが異なります。入力ファイルの文字コード，および外字の扱いについては，「4.10　EURで使用できる外字」および「7.2.1　入力ファイルのエンコーディング」を参照してください。

ページの先頭へ

(3)　その他

  • EUR サーバ帳票出力機能では，Windows上のOLE情報を利用できません。そのため，OLEオブジェクトを貼り付けて設計した帳票を，EUR サーバ帳票出力機能で出力しても，OLEオブジェクトは何も出力されません。

  • EUR サーバ帳票出力機能では，網パターンが設定されている帳票をPDF形式ファイルに出力すると，網掛けの表示が乱れたり，印刷に時間が掛かったりすることがあります。そのため，EUR 帳票作成機能では，網パターンから「塗りつぶし」を使用して帳票を設計するか，または設定された網パターンを「塗りつぶし」に変更されることをお勧めします。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 162 / 195


9.2.3 Excel形式ファイルに出力する場合の注意 : EUR システム設計ガイド

  • 163 / 195

  • 表紙

  • 9.　帳票デザインの設計

  • 9.2　帳票デザイン設計時の注意

  • 9.2.3　Excel形式ファイルに出力する場合の注意

9.2.3　Excel形式ファイルに出力する場合の注意

帳票をExcel形式ファイルに出力する場合の帳票設計時の注意事項と，Excel形式ファイルに出力できる内容について説明します。

〈この項の構成〉

  • (1)　帳票設計時の注意事項

  • (2)　Excel形式ファイルに出力できる内容

(1)　帳票設計時の注意事項

帳票をExcel形式ファイルに出力する場合，帳票設計時には次のことに注意してください。

  • 文字アイテムのアイテム枠は重ねないでください。文字アイテムが重なると，Excel形式ファイルにはどちらの文字も出力されません。

  • 文字アイテムのアイテム枠には，余裕のある大きさを設定してください。アイテム枠からはみ出した文字は，Excel形式ファイルには出力されません。

  • 「100.0000」のような小数をExcel形式ファイルに出力したい場合，［アイテムのプロパティ］ダイアログの［表示形式］タブの［小数点以下桁数］テキストボックスで，小数点以下の桁数を設定してください。

  • ［アイテムのプロパティ］ダイアログの［表示形式］タブの［指数表示］チェックボックスで指数表示を設定している場合，［小数点以下桁数］テキストボックスで小数点以下の桁数を指定してください。桁数を指定しないと，Excel出力時に小数点以下の桁数はデフォルトの「0」が設定されます。

  • アイテムは貼付域外に配置できませんが，誤った値を帳票定義情報ファイルに指定して帳票ファイルに変換すると，アイテムが貼付域外にはみ出してしまうことがあります。貼付域外にはみ出したアイテムがあるとKEEU083-Eのエラーが出力されて，コマンドの実行を終了します。

  • 誤った値を帳票定義情報ファイルに指定して帳票ファイルに変換すると，繰り返し指定したアイテムが繰り返し下限位置よりも下，または右限位置よりも右に配置されてしまうことがあります。

    繰り返し下限位置よりも下，または右限位置よりも右に配置されたアイテムがあると，KEEU083-Eのエラーが出力されて，コマンドの実行を終了します。

  • 帳票設計時には，ロケールごとの出力されるフォントで文字アイテムを配置してください。ロケールごとの出力されるフォントを次に示します。

    • 日本語ロケールの場合：MS　明朝

    • 中国語ロケールの場合：NSimSun

    • その他のロケールの場合：Courier New

    上記以外のフォントを使用すると，文字列がセルからはみ出たり，セル幅に余裕があっても表示が切れたりしてしまう場合があります。

  • 置き換え表を使用した帳票の場合，Excel上では置き換えられた値がそのまま出力されます。このとき，置き換えられた値のデータ種別はすべて文字列として出力されます。

  • 数値データの「0」と空データとを区別したい場合，［アイテムのプロパティ］ダイアログ－［表示形式］（文字列・数値データ）タブで，［値が0の場合］グループボックスと，［値が空データの場合］グループボックスでは必ず異なる内容を指定してください。

    どちらも「-（ハイフン）を表示する」とした場合，Excel形式ファイル内でのデータはどちらも「0」になるため，数値データの「0」と空データが区別できなくなってしまいます。

  • Excel上のセルに出力できる数値の最大有効桁数は，15桁までです。Excel形式ファイルに15桁を超える数値データを出力した場合は，16桁目以降が省略されます。

  • Excelの下線には，下線，二重下線，会計タイプの下線（会計），二重下線（会計）の4種類があります。

    ［アイテムのプロパティ］ダイアログの［フォント］タブで，文字修飾の下線の設定をしてExcel形式ファイルを出力した場合，下線で出力されます。EURの帳票作成機能では，文字の外側に下線を引くため，「g」のような文字の場合，帳票設計時は文字と下線が重なりませんが，Excel形式ファイルに出力すると，セルの属性として下線を出力するため，文字と下線が重なって出力され，EUR帳票作成機能で表示した場合と見た目が異なります。

  • Excel形式ファイル出力で指数表示する場合は，0より大きく1より小さい数値データを使用できません。

ページの先頭へ

(2)　Excel形式ファイルに出力できる内容

Excel形式ファイルに出力できる内容を次の表に示します。なお，各項目の出力結果の詳細については，マニュアル「EUR 帳票出力 機能解説 EUR Server編」を参照してください。

表9‒2 Excel形式ファイルに出力できる内容
分類 | 帳票ファイルに定義された内容 |  | 出力結果
用紙 | 用紙サイズ |  | △
 | 印刷の向き |  | ○
 | 用紙の余白サイズ |  | 1 cm
固定文字列 | 配置 | 横位置／縦位置 | ○
 | フォント | フォント名 | ○※1
 |  | スタイル | ○※1
 |  | サイズ | ○
 |  | 色 | △
 |  | フォント縦横比補正を行う | ×
 |  | 下線 | ○
 | 文字配置 | バージョン2以前の文字配置を行う | ×
 |  | 文字の方向 | ○※1
 |  | 文字間隔 | ×
 |  | 行間隔 | ×
 |  | ワードラップを行う | △
 | 出力ページ |  | △
 | 条件付きアイテム表示／非表示切り替え |  | △
マッピングデータ（文字列） | 表示形式 | 前付加文字列 | △
 |  | 後付加文字列 | △
 |  | 任意書式指定 | △
 | 配置※1 |  | ○
 | フォント※1 |  | △
 | 文字配置※1 |  | △
 | アイテムの桁数指定 |  | △
 | 縮小して全体を表示 |  | △
 | 置き換え表 |  | △
 | 出力ページ |  | △
 | 条件付きアイテム表示／非表示切り替え |  | △
マッピングデータ（数値，数値（集計対象外）） | 表示形式 | 前付加文字列 | ○
 |  | 後付加文字列 | ○
 |  | ゼロ埋め桁数 | ○
 |  | 負符号文字 | ○
 |  | 小数点文字 | ○
 |  | コンマ表示 | ○
 |  | 指数表示 | ○
 |  | 小数点以下桁揃え | ○
 |  | 小数点以下桁数 | ○
 | 配置※1 |  | ○
 | フォント※1 |  | △
 | 文字配置※1 |  | △
 | 0のとき0表示／表示しない／ハイフン表示 |  | ○
 | 空データのとき表示しない／ハイフン表示 |  | △
 | アイテムの桁数指定 |  | △
 | 縮小して全体を表示 |  | △
 | 置き換え表 |  | △
 | ワードラップを行う |  | △
 | 出力ページ |  | △
 | 条件付きアイテム表示／非表示切り替え |  | △
マッピングデータ（日付時刻，日次／月次／年次，和暦（日次）／和暦（月次）／和暦（年次）） | 表示形式 |  | △
 | 配置※1 |  | ○
 | フォント※1 |  | △
 | 文字配置※1 |  | △
 | 縮小して全体を表示 |  | △
 | 出力ページ |  | △
 | 条件付きアイテム表示／非表示切り替え |  | △
マッピングデータ（日次／月次／年次，和暦（日次）／和暦（月次）／和暦（年次）） | ワードラップを行う |  | △
ページ番号，印刷日付，印刷時刻 | 配置※1 |  | ○
 | フォント※1 |  | △
 | 文字配置※1 |  | △
 | ワードラップを行う |  | △
 | 出力ページ |  | △
 | 条件付きアイテム表示／非表示切り替え |  | △
バーコード |  |  | ×
画像 |  |  | ×
線 | 水平線 垂直線 | 線種 | ○
 |  | 線幅 | △
 |  | 線色 | △
 |  | 繰り返し | △
 | 出力ページ |  | △
斜線 |  |  | ×
図形 | 網掛け | パターン | △
 |  | 繰り返し | △
 |  | 枠線表示 | ○※1
 |  | 背景色 | △
 |  | 前景色 | △
 | 角丸四角 | 角丸め | △
 |  | パターン n個ごと 枠線 色 | △
 | 円／楕円 |  | ○
 | 多角形 |  | ×
 | 出力ページ |  | △
 | 条件付きアイテム表示／非表示切り替え |  | △
集計アイテム | 種別 |  | △
 | 集計種別 |  | △
 | 配置 |  | ○
 | フォント※1 |  | △
 | 文字配置※1 |  | △
 | ワードラップを行う |  | △
 | 出力ページ |  | △
 | 条件付きアイテム表示／非表示切り替え |  | △
繰り返し |  |  | ○
ブレイク |  |  | ○
帳票ヘッダ | ヘッダ領域 | あり／なし | △
 | ヘッダアイテム | あり／なし | △
 | アイテムの配置規準 | 貼り付け域／繰り返し領域 | △
特殊編集行 |  |  | ×※2
集計行 |  |  | ○
（凡例）

○：出力されます。

△：加工して出力されます。

×：定義内容は反映されません。

注※1

一部加工されて出力されるものがあります。詳細はマニュアル「EUR 帳票出力 機能解説 EUR Server編」を参照してください。

注※2

エラー（KEEU083-E）となります。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 163 / 195


付録 : EUR システム設計ガイド

  • 164 / 195

  • 表紙

  • 付録

付録

〈この付録の構成〉

  • 付録A　EURで使用できる機能の一覧

  • 付録B　制限値一覧

  • 付録C　EURシリーズの関連プログラム

  • 付録D　このマニュアルの参考情報

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 164 / 195


付録A EURで使用できる機能の一覧 : EUR システム設計ガイド

  • 165 / 195

  • 表紙

  • 付録

  • 付録A　EURで使用できる機能の一覧

付録A　EURで使用できる機能の一覧

EURで使用できる機能を，製品ごとに次の表に示します。

なお，説明文中では，バージョン10の製品名およびコンポーネント名を次のとおり表記しています。

DS：EUR Designer

DEV：EUR Developer

VW：EUR Viewer

SVE：EUR Server Enterprise

SVS：EUR Server Standard

表A‒1 EURで使用できる機能の一覧
機能 |  |  |  | DS | DEV | VW | SVE | SVS
共通 | 用紙サイズ |  | A3，A4，A5，B4，B5の各縦横 連続紙 はがき レター リーガル 任意サイズ | ○ | ○ | ○ | ○ | ○
 | データ型 |  | 文字列 数値 日付 画像（TIFF，GIF，BMP，JPEG，PNG） バーコード※1（JAN標準，JAN短縮，UPC-A，UPC-E，CODE39，CODE128（コードセットB，コードセットC），NW-7，ITF，QRコード，カスタマバーコード，GS1-128（UCC/EAN-128）） | ○ | ○ | ○ | ○ | ○
 | 文字コード※2 |  | Unicode（UTF-8，UTF-16）※3 ロケールに対応する文字コード | ○ | ○ | ○ | ○ | ○
 | IVS対応 |  | Windows環境での印刷，EPF形式ファイル出力，およびPDF形式ファイル出力（フォント埋め込み） | －※4 | ○ | －※4 | ○ | ○
 | 文字集合 |  | 詳細については，「1.2.1 サポートする入力データの文字集合」を参照してください。 | ○ | ○ | ○ | ○ | ○
 | 入力可能データ |  | CSV形式ファイル DAT形式ファイル FIX形式ファイル データベース連携※5（HiRDB，Oracle，SQL Server） | ○ | ○ | ○ | ○ | ○
 | その他 |  | DABrokerを同梱（Windows版） | － | ○ | － | ○ | ○
 |  |  | マルチロケール対応※6 | ○ | ○ | ○ | ○ | ○
帳票作成 | 修飾機能 | データ修飾 | 前付加文字 後付加文字 文字ピッチの桁数またはCPI指定 文字間隔 行間隔 自動縮小全体表示 ワードラップ 禁則処理（JIS X4051/4052） 横位置（左寄せ，中央，均等，右寄せ） 縦位置（上寄せ，中央，均等，下寄せ） フォント指定 スタイル（標準，太字，斜体，太字斜体） サイズ指定 文字の方向（縦書き，横書き） 下線 | ○ | ○ | － | － | －
 |  | 数値データ修飾 | コンマ表示 指数表示 小数点以下桁揃え 前付加文字 後付加文字 ゼロ埋め桁数指定 負符号文字指定 小数点文字の変更 値がゼロのときのゼロ非表示（ゼロサプレス）または‐（ハイフン）指定 値が空のときの-（ハイフン）指定 | ○ | ○ | － | － | －
 |  | 日付データ修飾 | 西暦 和暦 | ○ | ○ | － | － | －
 |  | フォント | 固定ピッチフォント（動的，静的） 可変ピッチ（プロポーショナル）フォント※7 | ○ | ○ | － | － | －
 |  | 罫線 | 7種類の線種（実線，点線（丸），点線（角），点線，破線，一点鎖線，二点鎖線） 4種類の線幅（細線，中線，太線，極太線） 任意線幅（線アイテム） 線色指定 | ○ | ○ | － | － | －
 |  | 網掛け | 14種類の網掛け 枠線表示（枠線種，線幅，線色）指定 背景色 前景色 | ○ | ○ | － | － | －
 |  | 図形 | 四角形 角丸四角形 円 楕円 多角形 | ○ | ○ | － | － | －
 |  | アイテムの修飾 | 置き換え表で表示データを置換 しきい値条件で表示・非表示を指定 | ○ | ○ | － | － | －
 | 編集 | 繰り返し | アイテム（データ，罫線，図形，網掛け，画像）の縦横繰り返し 繰り返し個数指定 繰り返し間隔指定（mm，LPI） 縦横優先指定 改ブロック 改ページ まとめ表示（階層あり/なし，罫線まとめ，集計行を分断しない） | ○ | ○ | － | － | －
 |  | 書式作成支援機能 | 下敷き機能（帳票作成時に参考にする帳票の画像を表示） Word/Excel文書からEUR帳票への変換機能 帳票定義情報ファイル入出力機能 アイテムの部品化機能 | ○ | ○ | － | － | －
 |  | 整列機能 | 文字，図形，または画像の同種アイテム間での表示順序指定（最前面，最背面，前面，背面） 多角形の回転，反転 整列（上下左右） 複数アイテムの幅・高さ揃え 位置・サイズ指定（0.01mm単位，0.01in単位，1px単位） 幅・高さのグリッド指定（mm，LPI，CPI） | ○ | ○ | － | － | －
 |  | ズーム機能 | 10～800％の範囲の拡大・縮小表示 | ○ | ○ | － | － | －
 |  | 多段UNDO機能 | 直前の操作の取り消し | ○ | ○ | － | － | －
 |  | 多段REDO機能 | 元に戻した操作のやり直し | ○ | ○ | － | － | －
 |  | サンプルデータ自動生成機能 | 帳票作成時にサンプルデータを自動で作成 | ○ | ○ | － | － | －
 |  | 出力ページ指定 | 表紙，全ページ，先頭ページ，または最終ページにアイテムを表示 改ページ（ページ番号初期化あり）で先頭または最終ページにアイテム表示 | ○ | ○ | － | － | －
 |  | 帳票ヘッダ定義 | 表紙次紙形式の帳票（1ページ目と2ページ目が異なる様式） | ○ | ○ | － | － | －
 |  | 集計データ定義 | データ修飾 表示位置の変更 | ○ | ○ | － | － | －
 | 演算機能 | 集計機能 | キー集計 総集計（合計，平均，件数，最大，最小） ページ集計 | ○ | ○ | － | － | －
 |  | 式・関数※8 | 四則演算 論理演算 文字列演算 集計関数 変換関数 日付関数 数学関数 文字列関数 システム関数 | ○ | ○ | － | － | －
 |  | データソート | 昇順または降順（データベース使用時） | ○ | ○ | － | － | －
 | その他 |  | 複数様式のGUI定義 | － | ○ | － | － | －
帳票出力 | 起動インターフェース |  | サーバ実行環境： コマンド ActiveX（Windows版） Java COBOL サービスプログラム | － | ○ | － | ○ | ○
 |  |  | クライアント実行環境： コマンド OLEオートメーション | ○ | ○ | ○ | － | －
 | 出力方式 |  | プリンタ出力（サーバ，クライアント） 複数様式出力 | ○ | ○ | ○ | ○ | ○
 |  |  | PDF形式ファイル出力， Excel形式ファイル出力 | － | ○ | － | ○ | ○
 | 負荷制御 |  | 流量制御（受付リクエスト数の指定，同時起動プロセス数の指定） ページ数指定による印刷ジョブの分割機能 | － | ○ | － | ○ | ○
 | プリンタ |  | Windows版： Windows対応プリンタ | ○ | ○ | ○ | ○ | ○
 |  |  | UNIX／Linux版： LIPSⅢ対応プリンタ，PostScript対応プリンタ ESC/P J84対応プリンタ | － | － | － | ○ | ○
 | 独自スプール機能 | セキュリティ管理 | ユーザ認証（LDAPまたは帳票管理ユーザ） スプールデータのアクセス可否の設定 | － | ○ | － | ○ | －
 |  | ユーザ管理 | LDAP IDでのユーザ指定 新規追加 アクセス制限指定（アクセス制御方式，分類，キー値） 宛先管理指定（帳票の取得可否，分類，キー値，ポーリング間隔） ユーザ削除 | － | ○ | － | ○ | －
 |  | 出力先指定 | スプールサーバ管理名指定 スプールサーバIPアドレス指定 プリンタ名・トレイ名指定 配送印刷指定（ユーザ，プリンタ，部署など） | － | ○ | － | ○ | －
 |  | 出力先管理 | サーバプリンタクラス定義（サーバ，プリンタ，トレイの組み合わせ） クライアントプリンタクラス定義（プリンタ，トレイの組み合わせ） 振り分け定義（帳票単位でプリンタトレイ指定） | － | ○ | － | ○ | －
 |  | 帳票管理GUI | ユーザの設定 スプールサーバの情報取得 スプールデータ（EPF形式ファイル）の検索 一覧取得 属性値の参照，変更 プレビュー 印刷 まとめ印刷 直接印刷 削除 一括削除 | － | ○ | － | ○ | －
 |  | 配送印刷 | 定期的に問い合わせポーリングを行い，取得した帳票をクライアントプリンタに配送して印刷 | － | ○ | － | ○ | －
 |  | サーバ印刷 | サーバプリンタクラス定義指定 振り分け定義指定 出力先指定 データのファイル，メモリ渡し 蓄積日時や印刷日時の表示 対話型印刷 自動印刷 再印刷 直接印刷 | － | ○ | － | ○ | －
 |  | クライアント印刷 | クライアントプリンタクラス指定 出力先指定 データのファイル，メモリ渡し 蓄積日時や印刷日時の表示 プレビュー 対話型印刷 自動印刷 再印刷 直接印刷 Webクライアントでのプレビュー（対話型） Webクライアントでの印刷（対話型） | － | ○ | － | ○ | －
 | 印刷オプション |  | プリンタ給紙トレイ指定（トレイコード指定） プリンタ印刷位置補正機能（水平シフト量，垂直シフト量） バーコード補正機能 | ○ | ○ | ○ | ○ | ○
 |  |  | 両面印刷指定 両面印刷のとじ代指定 テスト印刷機能 | － | ○ | － | ○ | ○
 |  |  | 仕分け印刷（入力データ/ページ数指定で帳票仕分けして蓄積，指定出力先に印刷） | － | ○ | － | ○ | －
 | PDF形式ファイル |  | しおり機能 仕分け出力機能 分割出力機能 Adobe Readerのビューアプレファレンス指定機能 Acrobat JavaScript埋め込み機能 フォント埋め込み機能 解像度指定 | － | ○ | － | ○ | ○
 | 暗号化機能 |  | PDF形式ファイルの暗号化出力，暗号化仕分け出力，または暗号化分割出力 | － | － | － | ○※9 | ○※9
 |  |  | PDFパスワード暗号化ツール | － | － | － | ○ | ○
 |  |  | ファイル暗号化ツール（個人番号接続情報ファイルの暗号化） | － | － | － | ○※10 | ○※10
 | 外字対応 |  | Windows環境で作成した外字をEURフォントファイルに変換して出力（Windows環境，UNIX／Linux環境） | － | ○ | － | ○ | ○
 |  |  | 外字ファイル指定（Windows環境） 外字を定義したフォントファイル指定（UNIX環境） | － | ○ | － | ○ | ○
 | BSP-RM連携 |  | BSP-RM連携コマンド（eursmprコマンド） | － | ○ | － | ○ | ○
 | 個人番号管理サービス連携 |  | Windows環境での帳票出力時に個人番号管理サービスから取得した個人番号を帳票に出力 | － | － | － | ○ | ○
 | その他 |  | 実行単位で環境設定ファイルの切り替え | ○ | ○ | ○ | ○ | ○
 |  |  | サーバ環境設定ファイルエディタ※11 サーバ帳票出力コマンド指定機能※11 | － | ○ | － | ○ | ○
 |  |  | 実行時ログ採取機能 | ○ | ○ | ○ | ○ | ○
 |  |  | IT Report Utility（システム情報採取ツール） | － | － | － | ○ | ○
（凡例）

○：使用できます。

－：使用できません。

注※1

バーコードの読み取りは，実際に使用するプリンタおよび読み取り装置で十分な評価をしてから使用してください。

注※2

データベース連携機能を利用するときに使用できる文字コードは，Shift JISまたはUnicode（UTF-8）です。詳細はマニュアル「EUR データベース連携ガイド」を参照してください。

注※3

結合文字列には対応していません。合成済み文字を利用してください。結合文字列の場合は，声調記号などが正しく表示されないことがあります。

注※4

IVS（基底文字+異体字セレクタ）で表現される文字を入力した場合，文字幅の計算では異体字セレクタは1文字としてカウントされ，異体字セレクタが空白で印字または出力されます。IVSの異体字に対応したフォント（IPAmj明朝フォントなど）を使用している場合，IVSの異体字は印字または出力されますが，異体字の後ろに空白が印字または出力されます。IVSの異体字に対応したフォントを使用していない場合は，異体字の代わりに基底文字が印字または出力されます。

注※5

DABrokerが同梱されていない製品がデータベース連携機能を利用する場合，別途DABrokerが必要となります。詳細はマニュアル「EUR データベース連携ガイド」を参照してください。

注※6

開発環境の製品では，日本語版OS，中国語版OS，英語版OSに合わせて，日本語，簡体中国語，英語で表示されます。実行環境の製品では，日本語OS以外は英語で表示されます。

注※7

出力先にフォントがない場合，出力できるフォントに置き換えられます。置き換えられるフォントの詳細については，「4.7　EURで使用できるフォント」を参照してください。

注※8

使用できる式および関数は，データベースによって異なります。詳細はマニュアル「EUR データベース連携ガイド」を参照してください。

注※9

PDF形式ファイルを暗号化して出力するときに使用します。この機能を使用するときには，EUR Server EnterpriseまたはEUR Server Standardのほかに，オプション製品のEUR Server - Cipher optionが必要です。

注※10

個人番号管理サービス連携機能で個人番号接続情報ファイルを暗号化する場合に使用します。ファイル暗号化ツールを使用する場合は，EUR Server EnterpriseまたはEUR Server Standardのほかに，オプション製品のEUR Server - Cipher optionが必要です。

注※11

V8互換機能として提供しています。詳細については，バージョン8対応のマニュアル「EUR サーバ帳票出力」を参照してください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 165 / 195


付録B 制限値一覧 : EUR システム設計ガイド

  • 166 / 195

  • 表紙

  • 付録

  • 付録B　制限値一覧

付録B　制限値一覧

EURでシステムを設計するときの各種の制限値を次の表に示します。

表B‒1 制限値一覧
項目 | 制限値
ユーザ定義 | 1,024件
ユーザ名に使用するジョブ検索キーの分類名 | 80バイト
ユーザ名 | 80バイト
ユーザの確認キー | 80バイト
アクセスを許可するジョブ検索キーの分類名 | 80バイト
アクセスを許可するジョブ検索キーの個数 | 1,024個
アクセスを許可するジョブ検索キーのキー値 | 80バイト
スプールサーバの登録台数 | 65,536台
スプールサーバの出力先名 | 80バイト
スプールサーバの出力先の説明 | 256バイト
帳票サーバのプリンタクラスの登録数 | 65,536個
帳票サーバのプリンタクラス名 | 80バイト
帳票サーバのプリンタクラスの説明 | 256バイト
スプールサーバのプリンタクラスの登録数 | 65,536個
スプールサーバのプリンタクラス名 | 80バイト
スプールサーバのプリンタクラスの説明 | 256バイト
帳票振り分け定義の振り分けグループ名 | 80バイト
振り分けグループに登録する帳票名 | 256バイト
帳票振り分け定義の説明 | 256バイト
クライアントプリンタクラスの登録数 | 65,536個
クライアントPCのプリンタクラス名 | 80バイト
クライアントPCのプリンタクラスの説明 | 256バイト
宛先定義ファイルの1行に定義できるユーザ数 | 100人
宛先定義ファイルに定義できる行数 | 100,000行

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 166 / 195


付録C EURシリーズの関連プログラム : EUR システム設計ガイド

  • 167 / 195

  • 表紙

  • 付録

  • 付録C　EURシリーズの関連プログラム

付録C　EURシリーズの関連プログラム

EURシリーズのバージョン10の関連プログラムについて説明します。

〈この節の構成〉

  • 付録C.1　データベースからデータを読み込む場合

  • 付録C.2　WordまたはExcel文書をEUR帳票に変換する場合

  • 付録C.3　SEWB+で定義した最上位結合項目からデータを読み込む場合

  • 付録C.4　データベースアクセス定義でデータ表示ウィンドウを使用する場合

  • 付録C.5　PDF形式ファイルを閲覧する場合

  • 付録C.6　Excel形式ファイルを閲覧・出力する場合

  • 付録C.7　JavaBeans起動部品（V8互換機能）を使用して帳票を出力する場合

  • 付録C.8　ActiveX起動部品を使用する場合

  • 付録C.9　COBOL起動部品を使用する場合

  • 付録C.10　EUR Web Plug-Inを使用する場合

  • 付録C.11　帳票管理GUIを使用する場合

  • 付録C.12　帳票管理GUIサービスを使用する場合

  • 付録C.13　配送サービスを使用する場合

  • 付録C.14　日立電子帳票システムと連携する場合

  • 付録C.15　LDAP認証を使用する場合

  • 付録C.16　BSP-RMと連携する場合

  • 付録C.17　監査証跡管理システムと連携する場合

  • 付録C.18　IT Report Utility（システム情報採取ツール）と連携する場合

  • 付録C.19　個人番号管理サービスと連携する場合

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 167 / 195


付録C.1 データベースからデータを読み込む場合 : EUR システム設計ガイド

  • 168 / 195

  • 表紙

  • 付録

  • 付録C　EURシリーズの関連プログラム

  • 付録C.1　データベースからデータを読み込む場合

付録C.1　データベースからデータを読み込む場合

〈この項の構成〉

  • (1)　データベースとの接続に使用する関連プログラム

  • (2)　接続するデータベース

(1)　データベースとの接続に使用する関連プログラム

次に示す関連ソフトウェアと連携することで，データベースに接続できます。

  • P-2463-2354　　DABroker　　03-21以降

  • P-2463-2364　　DABroker　　03-21以降

  • P-1J63-2451　　DABroker　　03-21以降

  • P-1M63-2251　　DABroker　　03-17以降

  • P-8163-2351　　DABroker　　03-21以降

  • P-1M63-2351　　DABroker(64)　　03-20以降

  • P-2963-2354　　DABroker(64)　　03-21以降

  • P-8263-2351　　DABroker(64)　　03-21以降

ページの先頭へ

(2)　接続するデータベース

次に示す関連ソフトウェアのどれかと連携することで，帳票設計に必要なデータを準備できます。

EURで使用できるデータベースは次のとおりです。

使用できる各データベースのバージョンは，DABrokerに依存します。

  • HiRDB

  • Oracle

  • SQL Server

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 168 / 195


付録C.2 WordまたはExcel文書をEUR帳票に変換する場合 : EUR システム設計ガイド

  • 169 / 195

  • 表紙

  • 付録

  • 付録C　EURシリーズの関連プログラム

  • 付録C.2　WordまたはExcel文書をEUR帳票に変換する場合

付録C.2　WordまたはExcel文書をEUR帳票に変換する場合

WordまたはExcel文書をEUR帳票に変換する場合，次に示す関連ソフトウェアのどれかが必要です。

Word文書のとき

  • Microsoft(R) Office Word 2007

  • Microsoft(R) Office Word 2010

  • Microsoft(R) Office Word 2013

Excel文書のとき

  • Microsoft(R) Office Excel 2007

  • Microsoft(R) Office Excel 2010

  • Microsoft(R) Office Excel 2013

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 169 / 195


付録C.3 SEWB+で定義した最上位結合項目からデータを読み込む場合 : EUR システム設計ガイド

  • 170 / 195

  • 表紙

  • 付録

  • 付録C　EURシリーズの関連プログラム

  • 付録C.3　SEWB+で定義した最上位結合項目からデータを読み込む場合

付録C.3　SEWB+で定義した最上位結合項目からデータを読み込む場合

次に示す関連ソフトウェアをインストールすることで，帳票設計に必要なデータを準備できます。

  • P-2451-1434　　SEWB+ 基本開発環境 セット　　03-00以降

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 170 / 195


付録C.4 データベースアクセス定義でデータ表示ウィンドウを使用する場合 : EUR システム設計ガイド

  • 171 / 195

  • 表紙

  • 付録

  • 付録C　EURシリーズの関連プログラム

  • 付録C.4　データベースアクセス定義でデータ表示ウィンドウを使用する場合

付録C.4　データベースアクセス定義でデータ表示ウィンドウを使用する場合

データ表示ウィンドウを使用する場合は，次に示す関連ソフトウェアのどちらかが必要です。

  • Microsoft(R) .NET Framework Version 2.0 再頒布可能パッケージ (x86)

  • Microsoft(R) .NET Framework 3.0 再頒布可能パッケージ

また，英語ロケール以外（中国語ロケールまたは日本語ロケール）で使用するときは，それぞれの言語に対応した.NET Framework Language Packが必要です。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 171 / 195


付録C.5 PDF形式ファイルを閲覧する場合 : EUR システム設計ガイド

  • 172 / 195

  • 表紙

  • 付録

  • 付録C　EURシリーズの関連プログラム

  • 付録C.5　PDF形式ファイルを閲覧する場合

付録C.5　PDF形式ファイルを閲覧する場合

PDF形式ファイルを閲覧する場合は，次に示す関連ソフトウェアが必要です。

  • Windows版 Adobe(R) Reader(R) 9以降

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 172 / 195


付録C.6 Excel形式ファイルを閲覧・出力する場合 : EUR システム設計ガイド

  • 173 / 195

  • 表紙

  • 付録

  • 付録C　EURシリーズの関連プログラム

  • 付録C.6　Excel形式ファイルを閲覧・出力する場合

付録C.6　Excel形式ファイルを閲覧・出力する場合

  • Microsoft(R) Office Excel 2007

  • Microsoft(R) Office Excel 2010

  • Microsoft(R) Office Excel 2013

また，実行環境に次のロケールがインストールされている必要があります。

AIX環境のとき

  • 英語環境：EN_US.UTF-8

  • 中国語環境：ZH_CN.UTF-8

  • 日本語環境：JA_JP.UTF-8

HP-UX環境のとき

  • 英語環境：en_US.utf8

  • 中国語環境：zh_CN.utf8

  • 日本語環境：ja_JP.utf8

Linux環境のとき

  • 英語環境：en_US.utf8

  • 中国語環境：zh_CN.utf8

  • 日本語環境：ja_JP.utf8

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 173 / 195


付録C.7 JavaBeans起動部品（V8互換機能）を使用して帳票を出力する場合 : EUR システム設計ガイド

  • 174 / 195

  • 表紙

  • 付録

  • 付録C　EURシリーズの関連プログラム

  • 付録C.7　JavaBeans起動部品（V8互換機能）を使用して帳票を出力する場合

付録C.7　JavaBeans起動部品（V8互換機能）を使用して帳票を出力する場合

次に示す関連ソフトウェアを使用することで，JavaBeans起動部品（V8互換機能）を使用して，帳票を出力できます。

  • JavaTM2 Platform Standard Edition Development Kit 5.0以降

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 174 / 195


付録C.8 ActiveX起動部品を使用する場合 : EUR システム設計ガイド

  • 175 / 195

  • 表紙

  • 付録

  • 付録C　EURシリーズの関連プログラム

  • 付録C.8　ActiveX起動部品を使用する場合

付録C.8　ActiveX起動部品を使用する場合

次に示す関連ソフトウェアのどちらかを使用することで，ActiveX起動部品を使用して，Web環境で帳票を出力できます。

  • Internet Information Services 7.5

  • Microsoft(R) Internet Information Services 8.0

  • Microsoft(R) Internet Information Services 8.5

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 175 / 195


付録C.9 COBOL起動部品を使用する場合 : EUR システム設計ガイド

  • 176 / 195

  • 表紙

  • 付録

  • 付録C　EURシリーズの関連プログラム

  • 付録C.9　COBOL起動部品を使用する場合

付録C.9　COBOL起動部品を使用する場合

〈この項の構成〉

  • (1)　EUR Developerのとき

  • (2)　EUR Serverのとき

(1)　EUR Developerのとき

32ビット版

  • P-2636-2324　COBOL2002 Net Developer 02-01-/D以降

  • P-2636-2334　COBOL2002 Net Developer 03-00以降

64ビット版

  • P-2936-2314　COBOL2002 Net Developer(64) 02-01以降

  • P-2936-2324　COBOL2002 Net Developer(64) 03-00以降

ページの先頭へ

(2)　EUR Serverのとき

Windows環境
32ビット版

  • P-2636-2324　COBOL2002 Net Developer 02-01以降

  • P-2436-5324　COBOL2002 Net Server Runtime 02-01以降

  • P-2436-6324　COBOL2002 Net Server Suite 02-01以降

  • P-2636-2334　COBOL2002 Net Developer 03-00以降

  • P-2436-5334　COBOL2002 Net Server Runtime 03-00以降

  • P-2436-6334　COBOL2002 Net Server Suite 03-00以降

64ビット版

  • P-2936-2314　COBOL2002 Net Developer(64) 02-00-/A以降

  • P-2936-5314　COBOL2002 Net Server Runtime(64) 02-00-/A以降

  • P-2936-6314　COBOL2002 Net Server Suite(64) 02-00-/A以降

  • P-2936-2334　COBOL2002 Net Developer(64) 03-00以降

  • P-2936-5334　COBOL2002 Net Server Runtime(64) 03-00以降

  • P-2936-6334　COBOL2002 Net Server Suite(64) 03-00以降

AIX環境（32ビット版だけ）

  • P-1M36-2111　COBOL2002 Net Server Runtime 01-03以降-

  • P-1M36-1111　COBOL2002 Net Server Suite 01-03以降

HP-UX環境（32ビット版だけ）

  • P-1J36-2111　COBOL2002 Net Server Runtime 01-01-/D以降-

  • P-1J36-1111　COBOL2002 Net Server Suite 01-01-/C以降

Linux環境（32ビット版だけ）

  • P-9S36-2111　COBOL2002 Net Server Runtime 01-02-02以降-

  • P-9S36-1111　COBOL2002 Net Server Suite 01-02-02以降

  • P-9S36-2131　COBOL2002 Net Server Runtime 03-01以降

  • P-9S36-1131　COBOL2002 Net Server Suite 03-01以降

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 176 / 195


付録C.10 EUR Web Plug-Inを使用する場合 : EUR システム設計ガイド

  • 177 / 195

  • 表紙

  • 付録

  • 付録C　EURシリーズの関連プログラム

  • 付録C.10　EUR Web Plug-Inを使用する場合

付録C.10　EUR Web Plug-Inを使用する場合

  • Internet Explorer 9（32ビット版）

  • Internet Explorer 10（Windowsデスクトップ版）

  • Internet Explorer 11（Windowsデスクトップ版）

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 177 / 195


付録C.11 帳票管理GUIを使用する場合 : EUR システム設計ガイド

  • 178 / 195

  • 表紙

  • 付録

  • 付録C　EURシリーズの関連プログラム

  • 付録C.11　帳票管理GUIを使用する場合

付録C.11　帳票管理GUIを使用する場合

  • Adobe(R) Flash(R) Player 12以降

  • Internet Explorer

    • Internet Explorer 9（32ビット版）

    • Internet Explorer 10（Windowsデスクトップ版）

    • Internet Explorer 11（Windowsデスクトップ版）

なお，帳票管理GUIはイントラネット内でご使用ください。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 178 / 195


付録C.12 帳票管理GUIサービスを使用する場合 : EUR システム設計ガイド

  • 179 / 195

  • 表紙

  • 付録

  • 付録C　EURシリーズの関連プログラム

  • 付録C.12　帳票管理GUIサービスを使用する場合

付録C.12　帳票管理GUIサービスを使用する場合

  • JavaTM2 Platform Standard Edition Development Kit 5.0以降を使用するAPサーバ

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 179 / 195


付録C.13 配送サービスを使用する場合 : EUR システム設計ガイド

  • 180 / 195

  • 表紙

  • 付録

  • 付録C　EURシリーズの関連プログラム

  • 付録C.13　配送サービスを使用する場合

付録C.13　配送サービスを使用する場合

  • JavaTM2 Platform Standard Edition Development Kit 5.0以降を使用するAPサーバ

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 180 / 195


付録C.14 日立電子帳票システムと連携する場合 : EUR システム設計ガイド

  • 181 / 195

  • 表紙

  • 付録

  • 付録C　EURシリーズの関連プログラム

  • 付録C.14　日立電子帳票システムと連携する場合

付録C.14　日立電子帳票システムと連携する場合

日立電子帳票システムと連携する場合は，次に示す関連ソフトウェアが必要です。

  • C-7810-200　　HOPSS3/AS REV/OSE　　07-00以降

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 181 / 195


付録C.15 LDAP認証を使用する場合 : EUR システム設計ガイド

  • 182 / 195

  • 表紙

  • 付録

  • 付録C　EURシリーズの関連プログラム

  • 付録C.15　LDAP認証を使用する場合

付録C.15　LDAP認証を使用する場合

  • LDAPv3に準拠したLDAP製品

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 182 / 195


付録C.16 BSP-RMと連携する場合 : EUR システム設計ガイド

  • 183 / 195

  • 表紙

  • 付録

  • 付録C　EURシリーズの関連プログラム

  • 付録C.16　BSP-RMと連携する場合

付録C.16　BSP-RMと連携する場合

  • BSP-RM

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 183 / 195


付録C.17 監査証跡管理システムと連携する場合 : EUR システム設計ガイド

  • 184 / 195

  • 表紙

  • 付録

  • 付録C　EURシリーズの関連プログラム

  • 付録C.17　監査証跡管理システムと連携する場合

付録C.17　監査証跡管理システムと連携する場合

  • P-2W42-7DA4　JP1/Audit Management - Manager　10-00以降

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 184 / 195


付録C.18 IT Report Utility（システム情報採取ツール）と連携する場合 : EUR システム設計ガイド

  • 185 / 195

  • 表紙

  • 付録

  • 付録C　EURシリーズの関連プログラム

  • 付録C.18　IT Report Utility（システム情報採取ツール）と連携する場合

付録C.18　IT Report Utility（システム情報採取ツール）と連携する場合

  • P-241Z-1111　IT Report Utility／システム情報採取ツール　02-01以降

  • P-1B1Z-1111　IT Report Utility／システム情報採取ツール　02-00以降

  • P-1M1Z-1111　システム情報採取ツール　01-10以降

  • P-9S1Z-1111　システム情報採取ツール　01-02以降

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 185 / 195


付録C.19 個人番号管理サービスと連携する場合 : EUR システム設計ガイド

  • 186 / 195

  • 表紙

  • 付録

  • 付録C　EURシリーズの関連プログラム

  • 付録C.19　個人番号管理サービスと連携する場合

付録C.19　個人番号管理サービスと連携する場合

マイナンバーセキュア管理システムと連携する場合

  • マイナンバーセキュア管理システム 01-01

  • クライアントSDK※

  • Microsoft(R) .NET Framework Version 4.5以降

注※

マイナンバーセキュア管理システムに同梱されている個人番号管理サービスのクライアント用のライブラリです。

匿名バンクと連携する場合

  • SL-NH608-021 匿名バンク 検索可能暗号化情報管理サービスWEBAPI 01-00以降

  • クライアント用秘匿検索ライブラリ※ 01-01

  • Microsoft(R) .NET Framework Version 4.5以降

注※

匿名バンクで提供される個人番号管理サービスのクライアント用のライブラリです。

個人番号管理サービス連携機能で個人番号接続情報ファイルを暗号化する場合

  • P-29D2-5CA4　EUR Server - Cipher option　10-30以降

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 186 / 195


付録D このマニュアルの参考情報 : EUR システム設計ガイド

  • 187 / 195

  • 表紙

  • 付録

  • 付録D　このマニュアルの参考情報

付録D　このマニュアルの参考情報

このマニュアルを読むに当たっての参考情報を示します。

〈この節の構成〉

  • 付録D.1　関連マニュアル

  • 付録D.2　EUR バージョン10での製品体系の変更

  • 付録D.3　EUR バージョン10でのマニュアル体系の変更

  • 付録D.4　このマニュアルでの表記

  • 付録D.5　このマニュアルで使用する略語

  • 付録D.6　KB（キロバイト）などの単位表記について

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 187 / 195


付録D.1 関連マニュアル : EUR システム設計ガイド

  • 188 / 195

  • 表紙

  • 付録

  • 付録D　このマニュアルの参考情報

  • 付録D.1　関連マニュアル

付録D.1　関連マニュアル

関連マニュアルを次に示します。必要に応じてお読みください。

〈この項の構成〉

  • (1)　EURのマニュアル

  • (2)　関連ソフトウェアのマニュアル

  • (3)　このマニュアルでのマニュアル名表記

(1)　EURのマニュアル

EURの関連マニュアルを次に示します。

  • はじめての帳票作成（3020-7-532）※

    EUR 帳票作成機能をまだ使用したことのない人向けに，簡単な帳票を作成する方法について説明しています。

  • EUR システム構築ガイド（3021-7-002）

    EURを使用した帳票システムを構築する手順について説明しています。

  • EUR 帳票作成 操作ガイド（3021-7-003）

    EUR 帳票作成機能を使用して帳票を作成する方法について説明しています。

  • EUR 帳票作成 画面リファレンス（3021-7-004）

    EUR 帳票作成機能で表示されるダイアログの内容について説明しています。

  • uCosminexus EUR 帳票設計（EUR Form帳票）（3020-7-534）※

    EUR Form帳票作成機能を使用してEUR Form帳票を作成する方法について説明しています。

  • EUR 帳票出力 EUR Designer/EUR Viewer編（3021-7-005）

    EUR DesignerまたはEUR Viewerを使用して，クライアント環境で帳票を出力する方法について説明しています。

  • uCosminexus EUR クライアント帳票出力（3020-7-535）※

    EUR クライアント帳票出力機能のV8互換機能を使用して，クライアント環境で帳票を出力する方法について説明しています。

  • EUR 帳票出力 機能解説 EUR Server編（3021-7-006）

    EUR サーバ帳票出力機能を使って帳票を出力する方法について説明しています。

  • EUR 帳票出力 リファレンス EUR Server編（3021-7-007）

    EUR サーバ帳票出力機能を使って帳票を出力するときに使用するAPIや入力ファイルの設定方法について説明しています。

  • uCosminexus EUR サーバ帳票出力（3020-7-536）※

    EUR ServerのV8互換機能を使用して，サーバ環境で帳票を出力する方法について説明しています。

  • EUR データベース連携ガイド（3021-7-008）

    データベースから抽出したデータを使って帳票を作成および出力する方法，およびEUR 帳票作成機能のデータベースアクセス定義ウィンドウを使用する方法について説明しています。また，データベースの操作時に出力されるメッセージについても説明しています。

  • EUR メッセージ（3021-7-009）

    EURを使用しているときに出力されるメッセージについて説明しています。

  • EUR 用語集（3021-7-010）

    EURシリーズマニュアル内で使用する用語について説明しています。なお，この用語集は日立ソフトウェアマニュアル公開サイト，または製品同梱のヘルプ（Windows版）だけで参照できます。

注※

バージョン8のマニュアルを提供しています。バージョン10の製品に置き換えて参照してください。

ページの先頭へ

(2)　関連ソフトウェアのマニュアル

関連ソフトウェアのマニュアルを次に示します。

  • TPBroker ユーザーズガイド（3000-3-660）

  • TPBroker Developer's Kit - Extension for C++ プログラマーズガイド（3000-3-680）

  • TPBroker Object Transaction Monitor ユーザーズガイド（3000-3-689）

  • COBOL2002　使用の手引　手引編（3000-3-D42）

  • COBOL2002　使用の手引　操作編（3000-3-D43）

  • COBOL2002　操作ガイド（3020-3-D47）

  • COBOL2002　ユーザーズガイド（3020-3-D48）

  • SEWB+/REPOSITORY 辞書設計ガイド（3020-3-698）

  • SEWB+/REPOSITORY 辞書設計ガイド（3020-3-N82）

  • DBPARTNER2 Client　操作ガイド（3020-6-027）

  • DABroker（3020-6-031）

  • HiRDB Version 8 UAP開発ガイド（3020-6-356）

  • HiRDB Version 8 メッセージ（3020-6-358）

  • HiRDB Version 9 UAP開発ガイド（3020-6-456）

  • HiRDB Version 9 メッセージ（3020-6-458）

  • JP1 Version 10 JP1/Audit Management - Manager 構築・運用ガイド（3021-3-165）

ページの先頭へ

(3)　このマニュアルでのマニュアル名表記

このマニュアルでは，マニュアル名について，次のように表記しています。

マニュアル名 | 表記
uCosminexus EUR 帳票設計（EUR Form帳票） | EUR 帳票設計（EUR Form帳票）
uCosminexus EUR クライアント帳票出力 | EUR クライアント帳票出力
uCosminexus EUR サーバ帳票出力 | EUR サーバ帳票出力
HiRDB Version 8 UAP開発ガイド HiRDB Version 9 UAP開発ガイド | HiRDB UAP開発ガイド
HiRDB Version 8 メッセージ HiRDB Version 9 メッセージ | HiRDB メッセージ
JP1 Version 10 JP1/Audit Management - Manager 構築・運用ガイド | JP1/Audit Management - Manager 構築・運用ガイド

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 188 / 195


付録D.2 EUR バージョン10での製品体系の変更 : EUR システム設計ガイド

  • 189 / 195

  • 表紙

  • 付録

  • 付録D　このマニュアルの参考情報

  • 付録D.2　EUR バージョン10での製品体系の変更

付録D.2　EUR バージョン10での製品体系の変更

  • 製品名称を変更しました。

  • uCosminexus EUR Server Print Editionを廃止しました。

EUR バージョン10での製品体系の変更について，次の図に示します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 189 / 195


付録D.3 EUR バージョン10でのマニュアル体系の変更 : EUR システム設計ガイド

  • 190 / 195

  • 表紙

  • 付録

  • 付録D　このマニュアルの参考情報

  • 付録D.3　EUR バージョン10でのマニュアル体系の変更

付録D.3　EUR バージョン10でのマニュアル体系の変更

  • マニュアル名を変更しました。

EUR バージョン10でのマニュアル体系の変更について，次の表に示します。

EUR バージョン9 | EUR バージョン10
uCosminexus EUR システム設計ガイド | EUR システム設計ガイド
uCosminexus EUR システム構築ガイド | EUR システム構築ガイド
uCosminexus EUR 帳票作成 操作ガイド | EUR 帳票作成 操作ガイド
uCosminexus EUR 帳票作成 画面リファレンス | EUR 帳票作成 画面リファレンス
uCosminexus EUR 帳票出力 機能解説 EUR Server編 | EUR 帳票出力 機能解説 EUR Server編
uCosminexus EUR 帳票出力 リファレンス EUR Server編 | EUR 帳票出力 リファレンス EUR Server編
uCosminexus EUR 帳票出力 EUR Designer/EUR Viewer編 | EUR 帳票出力 EUR Designer/EUR Viewer編
uCosminexus EUR データベース連携ガイド | EUR データベース連携ガイド
uCosminexus EUR メッセージ | EUR メッセージ
uCosminexus EUR 用語集 | EUR 用語集

EUR ServerのV8互換機能を使用する場合は，バージョン8対応のマニュアル「EUR サーバ帳票出力」を参照してください。Windows環境では，インストール先フォルダ\Print\1041\Help\eurps.chmに統合ヘルプが格納されています。

クライアント帳票出力機能のV8互換機能を使用する場合は，バージョン8対応のマニュアル「EUR クライアント帳票出力」を参照してください。Windows環境では，次のフォルダにヘルプが格納されています。

  • EUR Designerの場合

    EUR Designerのインストール先フォルダ\Designer\1041\Help\euroutp.chm

  • EUR Viewerの場合

    EUR Viewerのインストール先フォルダ\1041\Help\euroutp.chm

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 190 / 195


付録D.4 このマニュアルでの表記 : EUR システム設計ガイド

  • 191 / 195

  • 表紙

  • 付録

  • 付録D　このマニュアルの参考情報

  • 付録D.4　このマニュアルでの表記

付録D.4　このマニュアルでの表記

このマニュアルでは，EURの各製品について，次のように表記しています。

表記 |  | 製品名称
EUR Designer |  | EUR Designer
EUR Developer |  | EUR Developer
EUR Viewer |  | EUR Viewer
EUR Server | EUR Server Enterprise | EUR Server Enterprise
 | EUR Server Standard | EUR Server Standard
EUR Server - Cipher option |  | EUR Server - Cipher option
EUR Server Print Edition |  | uCosminexus EUR Server Print Edition
EUR Print Manager - Client |  | uCosminexus EUR Print Manager - Client
EUR Print Manager - Report Server |  | uCosminexus EUR Print Manager - Report Server
EUR Print Service |  | uCosminexus EUR Print Service
EUR Print Service Enterprise |  | uCosminexus EUR Print Service Enterprise
EUR Form | EUR Form Service | uCosminexus EUR Form Service
EUR Form Service - Data Store option |  | uCosminexus EUR Form Service - Data Store option

EUR以外の製品名称などについては，次のように表記しています。

表記 |  | 製品名称
BSP-RM |  | BSP-RM(R)
COBOL |  | COBOL2002
DABroker |  | DABroker 03-17以降 DABroker 03-21以降 DABroker(64) 03-20以降 DABroker(64) 03-21以降
HiRDB |  | HiRDB/Run Time Version 8 08-00 以降 HiRDB/Developer's Kit Version 8 08-00 以降 HiRDB/Run Time Version 8(64) 08-00 以降 HiRDB/Developer's Kit Version 8(64) 08-00 以降 HiRDB/Run Time Version 9 09-00以降 HiRDB/Developer's Kit Version 9 09-00以降 HiRDB/Developer's Suite Version 9 09-00以降 HiRDB/Run Time Version 9(64) 09-00以降 HiRDB/Developer's Kit Version 9(64) 09-00以降 HiRDB Server Version 9 09-00以降 HiRDB Server with Additional Function Version 9 09-00以降
IPF |  | Itanium(R) Processor Family
Linux | Linux 6 | Red Hat Enterprise Linux(R) Server 6 (64-bit x86_64)
 | Linux 7 | Red Hat Enterprise Linux(R) Server 7 (64-bit x86_64)
ODBC Driver |  | EURODBC Driver
 |  | DBPARTNER ODBC Driver 01-11以降
Oracle | Oracle 10g | Oracle 10g 10.1.0 Oracle 10g 10.2.0
 | Oracle 11g | Oracle Database 11g 11.1.0 Oracle Database 11g R2 11.2.0
SEWB+ |  | Software Engineering Workbench+
Hitachi Application Server |  | Hitachi Application Server uCosminexus Application Server uCosminexus Application Server Enterprise uCosminexus Application Server Standard
UNIX | AIX | AIX V6.1 AIX V7.1 AIX V7.2
 | HP-UX | HP-UX 11i V3(IPF)

このほか，このマニュアルでは，次に示す表記を使用しています。

  • EURの各製品を区別する必要がない場合は，総称してEURと表記します。

  • EUR Designer，EUR Developerの帳票作成機能を「EUR 帳票作成機能」と表記します。

  • EUR DeveloperのEUR Form帳票作成機能を「EUR 帳票作成機能（EUR Form帳票）」と表記します。

  • EUR Designer，EUR Developer，EUR Viewerのクライアント環境での帳票出力機能を「EUR クライアント帳票出力機能」と表記します。

  • EUR Developer，EUR Server Enterprise，EUR Server Standardのサーバ環境での帳票出力機能を「EUR サーバ帳票出力機能」と表記します。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 191 / 195


付録D.5 このマニュアルで使用する略語 : EUR システム設計ガイド

  • 192 / 195

  • 表紙

  • 付録

  • 付録D　このマニュアルの参考情報

  • 付録D.5　このマニュアルで使用する略語

付録D.5　このマニュアルで使用する略語

このマニュアルで使用する英略語を次に示します。

英略語 | 英字での表記
API | Application Programming Interface
ASP | Active Server Pages
BOM | Byte Order Mark
COBOL | COmmon Business Oriented Language
CPI | Characters Per Inch
CSV | Comma Separated Value
DLL | Dynamic Linking Library
DPI | Dot Per Inch
EAN | European Article Number
EJB | Enterprise JavaBeans
EMF | Enhanced Metafile
EOF | End Of File
EUR | End-User Reporting
GIF | Graphics Interchange Format
GUI | Graphical User Interface
HTTP | Hyper Text Transfer Protocol
ID | IDentifier
IPF | Itanium(R) Processor Family
ISO | International Organization for Standardization
IVS | Ideographic Variation Sequence/Selector
JAN | Japanese Article Number
JDK | JavaTM Development Kit
JIS | Japanese Industrial Standards
JPEG | Joint Photographic Experts Group
JSP | Java Server Pages
LAN | Local Area Network
LDAP | Lightweight Directory Access Protocol
LIPS | LBP Image Processing System
LPI | Lines Per Inch
MFC | Microsoft Foundation Class
MIME | Multipurpose Internet Mail Extension
MSI | Microsoft Windows Installer
MUI | Multi User Interface
OCR | Optical Character Reader
OCX | OLE Custom Control (OLE Control eXtension)
ODBC | Open Database Connectivity
OLE | Object Linking and Embedding
PCF | Portable Compiled Format
PDF | Portable Document Format
PDL | Page Description Language
PNG | Portable Network Graphics
RPM | RPM Package Manager
SSL | Secure Sockets Layer
TIFF | Tagged Image File Format
TLS | Transport Layer Security
UAP | User Application Program
UPC | Universal Product Code
UTC | Coordinated Universal Time
WAN | Wide Area Network
XML | eXtensible Mark-up Language

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 192 / 195


付録D.6 KB（キロバイト）などの単位表記について : EUR システム設計ガイド

  • 193 / 195

  • 表紙

  • 付録

  • 付録D　このマニュアルの参考情報

  • 付録D.6　KB（キロバイト）などの単位表記について

付録D.6　KB（キロバイト）などの単位表記について

1KB（キロバイト），1MB（メガバイト），1GB（ギガバイト），1TB（テラバイト）はそれぞれ1,024バイト，1,0242バイト，1,0243バイト，1,0244バイトです。

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 193 / 195


索引 : EUR システム設計ガイド

  • 194 / 195

  • 表紙

  • 索引

索引

  • C E F G H I J L N P Q S U W

  • あ行 か行 さ行 た行 な行 は行 ま行 や行 ら行

C

  • CODE128バーコード

    • アイテム枠の幅の指定

    • 最小サイズ

    • サイズの指定

    • データの指定

  • CODE128バーコードで指定できる入力データ

  • CODE128バーコード〔アイテム枠の幅の指定〕

  • CODE128バーコード〔最小サイズ〕

  • CODE128バーコード〔サイズの指定〕

  • CODE128バーコード〔データの指定〕

  • CODE39バーコード

    • アイテム枠の幅の指定

    • 最小サイズ

    • サイズの指定

    • データの指定

  • CODE39バーコード〔アイテム枠の幅の指定〕

  • CODE39バーコード〔最小サイズ〕

  • CODE39バーコード〔サイズの指定〕

  • CODE39バーコード〔データの指定〕

  • CSV形式のデータファイルに空データを指定する場合

  • CSV形式のファイルデータ〔画像データ〕

  • CSV形式のファイルデータ〔区切り文字〕

  • CSV形式のファイルデータ〔特殊編集レベルデータ〕

  • CSV形式のファイルデータ〔バーコードデータ〕

  • CSV形式のファイルデータ〔日付データ〕

  • CSV形式のファイルデータ〔文字データ〕

ページの先頭へ

E

  • EPF形式ファイル〔出力できる文字〕

  • EPF出力で使用できるフォント

  • EPS-XLSXログ〔EUR Server〕

    • 出力形式

    • 出力例

  • ESC/P対応プリンタに出力するときの注意

  • ESC/P対応プリンタ〔出力できる文字〕

  • eurapsログ〔EUR Server〕

  • EUR Client Serviceの起動管理

  • EUR Designer，またはEUR Viewerでのログの採取

  • eurlgmnt.exe〔ログメンテナンスツール〕

  • EurLgOpt.exe〔ログオプションの設定〕

  • eurmms.log〔ログファイル名〕

  • eurmmsログ〔EUR Server〕

    • 出力形式

  • EURPMログ〔EUR Server〕

    • 出力される情報

    • 出力例

    • 出力レベルの指定

    • ファイルサイズの指定

  • eurps.log〔ログファイル名〕

  • eurpsログ〔EUR Server〕

  • ［EUR Server Service 起動管理］ダイアログ

  • EUR Server Serviceの起動管理

  • EUR Serverでのログの採取

  • EUR Serverの各コンポーネントの情報

    • サービス名およびプロセス名

    • 実行ユーザ

    • ログの種類

  • EUR Server - AdapterのIPアドレス指定で処理の振り分けを行う構成

  • EUR Server - Adapterのポート番号指定で処理の振り分けを行う構成

  • EUR Server - Spool Serviceの起動管理

  • EUR サーバ帳票出力機能で出力する場合〔帳票デザイン設計時の注意〕

  • EURで扱える画像データ

  • EURで扱える帳票ファイル

  • EURの入力ファイルの設計

  • EURフォントファイル, [2]

  • Excel形式ファイルに出力する場合〔帳票デザイン設計時の注意〕

  • Excel形式ファイル〔出力できる文字〕

ページの先頭へ

F

  • FIX形式のファイルデータ〔画像データ〕

  • FIX形式のファイルデータ〔区切り文字〕

  • FIX形式のファイルデータ〔数値データ〕

  • FIX形式のファイルデータ〔特殊編集レベルデータ〕

  • FIX形式のファイルデータ〔バーコードデータ〕

  • FIX形式のファイルデータ〔日付データ〕

  • FIX形式のファイルデータ〔文字データ〕

ページの先頭へ

G

  • GS1-128（UCC/EAN-128）バーコード

    • データの指定

  • GS1-128（UCC/EAN-128）バーコード〔データの指定〕

ページの先頭へ

H

  • HIEUR.LOG〔ログファイル名〕

ページの先頭へ

I

  • IPアドレス指定で処理の振り分けを行う構成〔システムの負荷分散と多重化〕

  • ITFバーコード

    • アイテム枠の幅の指定

    • 最小サイズ

    • サイズの指定

    • データの指定

  • ITFバーコード〔アイテム枠の幅の指定〕

  • ITFバーコード〔最小サイズ〕

  • ITFバーコード〔サイズの指定〕

  • ITFバーコード〔データの指定〕

  • IT Report Utility（システム情報採取ツール）

  • IVSとは

  • IVSの対応範囲

ページの先頭へ

J

  • JAN短縮バーコード

    • アイテム枠の幅の指定

    • 最小サイズ

    • サイズの指定

    • データの指定

  • JAN短縮バーコード〔アイテム枠の幅の指定〕

  • JAN短縮バーコード〔最小サイズ〕

  • JAN短縮バーコード〔サイズの指定〕

  • JAN短縮バーコード〔データの指定〕

  • JAN標準バーコード

    • アイテム枠の幅の指定

    • 最小サイズ

    • サイズの指定

    • データの指定

  • JAN標準バーコード〔アイテム枠の幅の指定〕

  • JAN標準バーコード〔最小サイズ〕

  • JAN標準バーコード〔サイズの指定〕

  • JAN標準バーコード〔データの指定〕

  • Java起動部品でメモリ取得機能を使用する場合の注意

ページの先頭へ

L

  • LIPSIII対応プリンタに出力するときの注意

  • LIPSIII対応プリンタ〔出力できる文字〕

ページの先頭へ

N

  • NW-7バーコード

    • アイテム枠の幅の指定

    • 最小サイズ

    • サイズの指定

    • データの指定

  • NW-7バーコード〔アイテム枠の幅の指定〕

  • NW-7バーコード〔最小サイズ〕

  • NW-7バーコード〔サイズの指定〕

  • NW-7バーコード〔データの指定〕

ページの先頭へ

P

  • PDF形式ファイル〔出力できる文字〕

  • PDF出力で使用できるフォント

  • PDF取得機能を使用する場合の注意

  • PDLファイルに出力するときの注意

  • PostScript対応プリンタに出力するときの注意

  • PostScript対応プリンタ〔出力できる文字〕

ページの先頭へ

Q

  • QRコード

    • アイテム枠の幅の指定

    • 最小サイズ

    • サイズの指定

    • データの指定

  • QRコード〔アイテム枠の幅の指定〕

  • QRコード〔最小サイズ〕

  • QRコード〔サイズの指定〕

  • QRコード〔使用できる文字〕

  • QRコード〔データの指定〕

ページの先頭へ

S

  • Server Service制御コマンド

  • Spool Service制御コマンド

  • syslog〔EUR Server〕

ページの先頭へ

U

  • UnicodeのIVS対応

    • 注意事項

  • UNIX／Linux環境のプリンタ出力時のフォント

  • UNIX／Linux環境のプリンタに出力するときの注意

  • UPC-Eバーコード

    • アイテム枠の幅の指定

    • 最小サイズ

    • サイズの指定

    • データの指定

  • UPC-Eバーコード〔最小サイズ〕

  • UPC-Eバーコード〔アイテム枠の幅の指定〕

  • UPC-Eバーコード〔サイズの指定〕

  • UPC-Eバーコード〔データの指定〕

  • UPC-Aバーコード

    • アイテム枠の幅の指定

    • 最小サイズ

    • サイズの指定

    • データの指定

  • UPC-Aバーコード〔アイテム枠の幅の指定〕

  • UPC-Aバーコード〔最小サイズ〕

  • UPC-Aバーコード〔サイズの指定〕

  • UPC-Aバーコード〔データの指定〕

  • UPC-Eバーコード

ページの先頭へ

W

  • Webサーバの設定

  • Webブラウザに帳票を埋め込んで印刷する〔データの流れの検討〕

  • Windows環境のプリンタ出力時のフォント

  • Windows対応プリンタ〔出力できる文字〕

ページの先頭へ

あ行

あ

  • アクセス権

  • アプリケーションサーバの設定

い

  • イベントログの出力形式

  • イベントログの出力〔EUR Designer，またはEUR Viewer〕

  • イベントログ〔EUR Server〕

  • 印刷先プリンタをBSDシステムと接続したときのジョブ制限

  • 印刷時に使用するデータファイルの注意

  • 印刷範囲〔帳票デザイン設計時の注意〕

  • インストール先〔入力ファイル〕

    • EUR Server Service

  • インターフェース

    • ActiveX

    • COBOL

    • Java

    • OLEオートメーション〔クライアント〕

    • コマンド〔クライアント〕

    • コマンド〔サーバ〕

え

  • エンコーディング

    • 環境変数

    • 起動部品

    • コマンド

    • 入力ファイル

    • 標準出力

お

  • 置き換えて出力されるフォント〔PDF出力〕

    • 欧文フォント

    • 置き換え結果

    • 注意事項

    • 中国語フォント

    • 日本語フォント

ページの先頭へ

か行

か

  • 外字

    • EPF形式ファイル，およびExcel形式ファイル出力での外字の使用方法

    • プリンタでの印刷，およびPDF形式ファイル出力での外字の使用方法

  • 開発言語

    • クライアント環境

    • サーバ環境

  • カスタマバーコード

    • アイテム枠の幅の指定

    • 最小サイズ

    • サイズの指定

    • データの指定

  • カスタマバーコードの英字変換コード表

  • カスタマバーコードのチェック用文字置き換えコード表

  • カスタマバーコード〔アイテム枠の幅の指定〕

  • カスタマバーコード〔最小サイズ〕

  • カスタマバーコード〔サイズの指定〕

  • カスタマバーコード〔データの指定〕

  • 画像データ

  • 画像ファイル

  • 画面に入力する項目の文字集合

  • 監査ログ〔EUR Server〕

き

  • 起動管理

    • EUR Client Service

    • EUR Server Service

    • EUR Server - Spool Service

    • ファイル監視サービス

  • 起動管理定義

  • 起動部品，コマンド，環境変数および標準出力の文字集合とエンコーディング

  • 業務プログラムの開発言語を検討する

  • 業務プログラムの検討

  • 業務プログラムの設計に関する注意事項

く

  • クライアントPCの設定

  • クライアント環境の設計

  • クライアントプリンタクラスの設定

  • クライアントプリンタクラスの配布

け

  • 言語環境

    • サポートする入力データの文字集合

    • ファイル転送時の文字コード変換

  • 検討する内容〔システム構成およびネットワーク構成〕

ページの先頭へ

さ行

さ

  • サーバ環境の設計

  • 採取できるログ〔EUR Designer，またはEUR Viewer〕

  • サイジングの検討

  • サポートする入力データの文字集合

し

  • システム構成，ネットワーク構成の検討

  • システム構成およびネットワーク構成で検討する内容

    • 帳票の出力規模を検討する

  • システム構成の概要〔システムの負荷分散と多重化〕

  • システム構成例

    • Webブラウザに帳票を埋め込んで印刷する

    • センターサーバで帳票を印刷する

    • 帳票をクライアントPCで印刷する

    • 帳票を再印刷する

    • 帳票を配送印刷する

    • バッチ処理で拠点のクライアントPCに帳票を送って印刷する

  • システム構成例〔Webブラウザに帳票を埋め込んで印刷する〕

  • システム構成例〔センターサーバで帳票を印刷する〕

  • システム構成例〔帳票をクライアントPCで印刷する〕

  • システム構成例〔帳票を再印刷する〕

  • システム構成例〔帳票を配送印刷する〕

  • システム構成例〔バッチ処理で拠点のクライアントPCに帳票を送って印刷する〕

  • システムの負荷分散方法を検討する

  • 実行ユーザの検討

    • アクセス権

    • ユーザ定義を定義する場合の注意事項

    • ユーザの定義方法

  • 出力先

    • EUR Client Service

    • EUR Server Service

    • EUR Server - Adapter

    • EUR Server - Spool Service

    • EUR Server - Spool Service Adapter

  • 出力できる文字

  • 出力ページ数の上限値

  • 障害対策

  • 上限値

    • EURPMログファイルのファイルサイズ

    • EUR Viewer〔プレビューできるページ数〕

    • EUR クライアント帳票出力機能〔出力ページ数〕

    • EUR サーバ帳票出力機能〔出力ページ数〕

    • EUR 帳票作成機能〔出力ページ数〕

    • 監査ログファイルのファイルサイズ

    • 出力ファイルサイズ

    • 出力ページ数

    • スプールデータから取得する印刷データのサイズ

    • データファイル〔CSV形式（DAT形式）〕のファイルサイズおよびレコード

    • データファイル〔FIX形式〕のファイルサイズおよびレコード

す

  • スタートコードバー

  • ストップコードバー

  • スプールサーバの設定

  • スプールデータから取得する印刷データのサイズの検討

  • スプールデータから取得する印刷データのサイズの上限値

    • EPF形式

    • PDF形式

  • スプールデータを格納するフォルダのディスク量の検討

せ

  • 制御情報付データファイルのデータ形式

  • 静的モード

  • 静的モード，または文字幅計算方法を指定しなかったときに置き換えて出力されるフォント〔PDF出力〕

  • 設定

    • Web/アプリケーションサーバ

    • クライアントPC

    • クライアントプリンタクラス

    • スプールサーバ

    • 帳票サーバ

  • センターサーバで帳票を印刷する〔データの流れの検討〕

ページの先頭へ

た行

た

  • 多重化

    • IPアドレス指定で処理の振り分けを行う構成

    • システム構成

    • ポート番号指定で処理の振り分けを行う構成

    • ロードバランサを使用した構成

ち

  • チェックキャラクタ〔JAN標準バーコード〕

  • チェックキャラクタ〔UPC標準バーコード〕

  • 注意事項〔EUR Serverでのログの採取〕

  • 注意事項〔業務プログラムの設計〕

    • Java起動部品でメモリ取得機能を使用する場合

    • PDF取得機能を使用する場合

    • 印刷時に使用するデータファイル

    • 帳票管理GUIと業務アプリケーションを併用してスプールデータを操作する場合

    • ファイル転送時間を省略する場合

  • 注意事項〔帳票運用時〕

  • 注意事項〔バーコード〕

  • 帳票運用時の注意事項

  • 帳票管理GUIと業務アプリケーションを併用してスプールデータを操作する場合の注意

  • 帳票サーバの設定

  • 帳票作成時に使用できるフォント

  • 帳票出力環境の設計

  • 帳票出力業務の検討

  • 帳票出力業務の実行ユーザを検討する

  • 帳票出力時の異体字セレクタの扱い

  • 帳票出力のデータの流れを検討する

  • 帳票デザイン設計時の注意

    • EUR サーバ帳票出力機能で出力する場合

    • Excel形式ファイルに出力する場合

    • 印刷範囲

  • 帳票デザインの設計

  • 帳票の運用方法の検討

  • 帳票の出力規模の検討

    • サイジングの検討

    • スプールデータから取得する印刷データのサイズの検討

    • ファイルサイズ，ページ数の検討

  • 帳票の出力規模を検討する

  • 帳票のレイアウトに関する主な機能

  • 帳票ファイル

  • 帳票をクライアントPCで印刷する〔データの流れの検討〕

  • 帳票を再印刷する〔データの流れの検討〕

  • 帳票を配送印刷する〔データの流れの検討〕

て

  • 定義する際に決めておく内容〔ユーザの定義方法〕

  • ディスク量〔スプールデータを格納するフォルダ〕

  • データ形式

    • CSV形式

    • DAT形式

    • FIX形式

  • データの流れ

    • Webブラウザに帳票を埋め込んで印刷する

    • センターサーバで帳票を印刷する

    • 蓄積した帳票をプレビューする〔帳票の再印刷〕

    • 帳票をクライアントPCで印刷する

    • 帳票を蓄積する〔帳票の再印刷〕

    • 帳票を配送印刷する

    • バッチ処理で拠点のクライアントPCに帳票を送って印刷する

  • データの流れの検討

    • Webブラウザに帳票を埋め込んで印刷する

    • センターサーバで帳票を印刷する

    • 帳票をクライアントPCで印刷する

    • 帳票を再印刷する

    • 帳票を配送印刷する

    • バッチ処理で拠点のクライアントPCに帳票を送って印刷する

  • データベース

  • デフォルトのインストール先および出力先

  • デフォルトユーザ

と

  • 動作環境の設定

  • 動的モード

  • 動的モードで使用できるフォント〔PDF出力〕

    • 置き換えられて出力されるフォント

    • そのまま出力されるフォント

    • 注意事項

  • トレース採取に関する注意〔EUR Serverでのログの採取〕

  • トレース情報〔EUR Server〕

  • トレースファイル

  • どんな言語環境で利用するか検討する

ページの先頭へ

な行

に

  • 入力ファイル

  • 入力ファイルのエンコーディング

  • 入力ファイル名の規則

    • NEC選定IBM拡張文字を指定する場合の注意

    • 指定できる文字

    • 文字数

  • 認証方式

    • LDAPサーバと連携する

    • ユーザ定義を使用する

ページの先頭へ

は行

は

  • バーコード

  • バッチ処理で拠点のクライアントPCに帳票を送って印刷する〔データの流れの検討〕

ひ

  • 日付データ

ふ

  • ファイル監視サービス

  • ファイル監視サービスの起動管理

  • ファイルサイズ，ページ数の検討

  • ファイルサイズの上限値, [2], [3]

    • EURPMログファイル

    • 監査ログファイル

    • 出力ファイル

    • スプールデータから取得する印刷データ

    • データファイル〔CSV形式（DAT形式）〕

    • データファイル〔FIX形式〕

  • ファイル転送

    • EUR Server ServiceとEUR Server - Spool Service間

    • EUR Server - AdapterとEUR Server Service間

  • ファイル転送時間を省略する場合の注意

  • ファイル転送時の文字コード変換

  • ファイルの操作権限

  • ファイルの文字コードの変換規則〔EUR Server ServiceとEUR Server - Spool Service間〕

  • ファイルの文字コードの変換規則〔EUR Server - AdapterとEUR Server Service間〕

  • ファイル名にNEC選定IBM拡張文字を指定する場合の注意

  • フォント

    • EPF出力

    • PDF出力

    • UNIX／Linux環境のプリンタ出力時のフォント

    • Windows環境のプリンタ出力時のフォント

    • 置き換えて出力されるフォント〔PDF出力〕

    • 帳票作成時

    • フォントの置き換え結果〔UNIX／Linux環境のプリンタ出力〕

    • プリンタ出力でのフォントの出力結果〔プロポーショナルフォントの出力〕

    • 文字幅計算方法の設定

    • 文字幅の計算方法

  • 負荷分散

    • IPアドレス指定で処理の振り分けを行う構成

    • システム構成

    • ポート番号指定で処理の振り分けを行う構成

    • ロードバランサを使用した構成

  • 複数の言語環境でEURを使用する

ほ

  • ポート番号指定で処理の振り分けを行う構成〔システムの負荷分散と多重化〕

  • 保守情報の採取〔EUR Designer，またはEUR Viewer〕

  • 保守情報の採取〔EUR Server〕

  • 保守情報の採取〔V8互換機能〕

ページの先頭へ

ま行

も

  • 文字データ

ページの先頭へ

や行

ゆ

  • ユーザ定義を定義する場合の注意事項

  • ユーザの定義方法

  • ユーザの認証方式を検討する

ページの先頭へ

ら行

れ

  • レコードの上限値, [2]

    • データファイル〔CSV形式（DAT形式）〕

    • データファイル〔FIX形式〕

ろ

  • ロードバランサを使用した構成〔システムの負荷分散と多重化〕

  • ロードバランサを使用して処理の自動振り分けを行う構成

  • ログオプション〔EUR Designer，またはEUR Viewer〕

  • ログ機能に関する注意〔EUR Serverでのログの採取〕

  • ログ採取のデフォルトの設定〔EUR Designer，またはEUR Viewer〕

  • ログ採取のレベル〔EUR Designer，またはEUR Viewer〕

  • ログの採取

    • EUR Designer

    • EUR Server

    • EUR Viewer

  • ログファイル出力時にエラーが発生した場合のメッセージ〔EUR Server〕

  • ログファイルに出力する情報〔EPS-XLSXログ〕

  • ログファイルの切り替え〔eurmmsログ〕

  • ログファイルの切り替え〔eurpsログ〕

  • ログファイルの出力先の指定〔EPS-XLSXログ〕

  • ログファイルの出力先の指定〔eurmmsログ〕

  • ログファイルの出力先の指定〔eurpsログ〕

  • ログファイルの出力単位〔EPS-XLSXログ〕

  • ログファイルのファイルサイズの指定〔eurmmsログ〕

  • ログファイルのファイルサイズの指定〔eurpsログ〕

  • ログファイルの容量〔EPS-XLSXログ〕

  • ログファイルの容量〔EUR Designer，またはEUR Viewer〕

  • ログファイルへの詳細情報出力の指定〔eurmmsログ〕

  • ログファイルへのメッセージ出力レベルの指定〔EPS-XLSXログ〕

  • ログファイルへのメッセージ出力レベルの指定〔eurmmsログ〕

  • ログファイルへのメッセージ出力レベルの指定〔eurpsログ〕

  • ログファイル名〔EPS-XLSXログ〕

  • ログファイル名〔eurmmssログ〕

  • ログファイル名〔eurpsログ〕

  • ログファイルメンテナンスの実行〔スタートアップからの起動〕

  • ログファイルメンテナンスの実行〔プログラムファイルからの起動〕

  • ログファイルメンテナンス〔EUR Designer，またはEUR Viewer〕

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 194 / 195


マニュアル発行元 : EUR システム設計ガイド

  • 195 / 195

  • 表紙

  • マニュアル発行元

マニュアル発行元

株式会社 日立製作所

〒100‒8280　東京都千代田区丸の内一丁目6番6号

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 195 / 195


目次 : EUR システム設計ガイド

  • 2 / 195

  • 表紙

  • 目次

目次

  • 前書き

  • 変更内容

  • はじめに

  • 第1編　基本設計編

    • 1.　帳票出力業務の検討

      • 1.1　帳票出力のデータの流れを検討する

        • 1.1.1　センターサーバで帳票を印刷する

        • 1.1.2　バッチ処理で拠点のクライアントPCに帳票を送って印刷する

        • 1.1.3　Webブラウザに帳票を埋め込んで印刷する

        • 1.1.4　帳票を再印刷する

        • 1.1.5　帳票を配送印刷する

        • 1.1.6　帳票をクライアントPCで印刷する

      • 1.2　どんな言語環境で利用するか検討する

        • 1.2.1　サポートする入力データの文字集合

        • 1.2.2　ファイル転送時の文字コード変換

      • 1.3　帳票出力業務の実行ユーザを検討する

        • 1.3.1　実行ユーザとアクセス権

      • 1.4　ユーザの認証方式を検討する

        • 1.4.1　ユーザ定義を使用する

        • 1.4.2　LDAPサーバと連携する（Windows環境だけ）

    • 2.　システム構成，ネットワーク構成の検討

      • 2.1　システム構成およびネットワーク構成で検討する内容

      • 2.2　帳票の出力規模を検討する

        • 2.2.1　サイジングの検討

        • 2.2.2　ファイルサイズ，ページ数の検討

        • 2.2.3　スプールデータを格納するフォルダのディスク量の検討

        • 2.2.4　スプールデータから取得する印刷データのサイズの検討

      • 2.3　システムの負荷分散方法を検討する

        • 2.3.1　システム構成の概要

        • 2.3.2　ロードバランサを使用した構成

        • 2.3.3　IPアドレス指定で処理の振り分けを行う構成

        • 2.3.4　ポート番号指定で処理の振り分けを行う構成

    • 3.　業務プログラムの検討

      • 3.1　業務プログラムの開発言語を検討する

        • 3.1.1　クライアント環境での帳票の出力

        • 3.1.2　サーバ環境での帳票の出力

    • 4.　帳票に出力するデータの検討

      • 4.1　EURの帳票ファイル

      • 4.2　EURで使用できるデータベース

      • 4.3　EURで使用できるデータ形式

        • 4.3.1　CSV形式（DAT形式）のデータ形式

        • 4.3.2　FIX形式のデータ形式

        • 4.3.3　制御情報付データファイルのデータ形式

      • 4.4　EURで使用できるバーコード

        • 4.4.1　JAN標準バーコード

        • 4.4.2　JAN短縮バーコード

        • 4.4.3　ITFバーコード

        • 4.4.4　CODE39バーコード

        • 4.4.5　CODE128バーコード

        • 4.4.6　GS1-128（UCC/EAN-128）バーコード

        • 4.4.7　NW-7バーコード

        • 4.4.8　QRコード

        • 4.4.9　カスタマバーコード

        • 4.4.10　UPC-Aバーコード

        • 4.4.11　UPC-Eバーコード

        • 4.4.12　バーコードの出力時の注意事項

      • 4.5　EURで使用できる画像ファイル

        • 4.5.1　画像ファイルの印刷・出力に関する注意事項

      • 4.6　EURで出力できる文字

        • 4.6.1　Windows対応プリンタ，EPF形式ファイル

        • 4.6.2　PDF形式ファイル

        • 4.6.3　PostScript対応プリンタ

        • 4.6.4　LIPSIII対応プリンタ

        • 4.6.5　ESC/P対応プリンタ

        • 4.6.6　Excel形式ファイル

      • 4.7　EURで使用できるフォント

        • 4.7.1　帳票作成時に使用できるフォント

        • 4.7.2　Windows環境のプリンタ出力時のフォント

        • 4.7.3　UNIX／Linux環境のプリンタ出力時のフォント

      • 4.8　EURのPDF出力で使用できるフォント

        • 4.8.1　静的モード，または文字幅計算方法を指定しなかったときに置き換えて出力されるフォント

        • 4.8.2　動的モードで使用できるフォント

      • 4.9　EURのEPF出力および帳票の蓄積で使用できるフォント

        • 4.9.1　Windows環境

        • 4.9.2　UNIX／Linux環境

      • 4.10　EURで使用できる外字

        • 4.10.1　プリンタでの印刷，およびPDF形式ファイル出力での外字の使用方法

        • 4.10.2　EPF形式ファイル，およびExcel形式ファイル出力での外字の使用方法

      • 4.11　UnicodeのIVS対応

        • 4.11.1　IVSとは

        • 4.11.2　帳票出力時の異体字セレクタの扱い

        • 4.11.3　IVSの対応範囲

        • 4.11.4　注意事項

      • 4.12　UNIX／Linux環境のプリンタに出力するときの注意

        • 4.12.1　LIPSIII対応プリンタに出力するときの注意

        • 4.12.2　PostScript対応プリンタに出力するときの注意

        • 4.12.3　ESC/P対応プリンタに出力するときの注意

        • 4.12.4　PDLファイルに出力するときの注意

        • 4.12.5　印刷先プリンタをBSDシステムと接続したときのジョブ制限

    • 5.　帳票の運用方法の検討

      • 5.1　EUR Serverの各コンポーネントの情報

        • 5.1.1　各コンポーネントのサービス名およびプロセス名

        • 5.1.2　各コンポーネントの実行ユーザ

        • 5.1.3　各コンポーネントのログの種類

      • 5.2　帳票運用時の注意事項

      • 5.3　EUR Serverでのログの採取

        • 5.3.1　イベントログ

        • 5.3.2　syslog

        • 5.3.3　EURPMログ

        • 5.3.4　ログファイル出力時にエラーが発生した場合のメッセージ

        • 5.3.5　eurpsログ

        • 5.3.6　EPS-XLSXログ

        • 5.3.7　eurapsログ

        • 5.3.8　監査ログ

        • 5.3.9　eurmmsログ

        • 5.3.10　注意事項

      • 5.4　EUR Designer，またはEUR Viewerでのログの採取

        • 5.4.1　ログ採取の概要

        • 5.4.2　ログ採取のデフォルトの設定

        • 5.4.3　ログオプションの設定

        • 5.4.4　ログファイルメンテナンスの実行

        • 5.4.5　注意事項

      • 5.5　EUR Serverでのトレース情報の採取

        • 5.5.1　採取するトレース情報

        • 5.5.2　トレースファイルの出力場所

        • 5.5.3　トレースファイルの文字コード

        • 5.5.4　トレース情報採取の指定

      • 5.6　障害対策

        • 5.6.1　EUR Designer，EUR Viewerでの保守情報の採取

        • 5.6.2　EUR Serverでの保守情報の採取

        • 5.6.3　EUR Serverでの保守情報の採取（V8互換機能を使用している場合）

      • 5.7　IT Report Utility（システム情報採取ツール）による構成情報の採取

        • 5.7.1　使用方法

        • 5.7.2　採取できる資料

  • 第2編　詳細設計編

    • 6.　業務プログラムの設計

      • 6.1　EURのコーディング例

      • 6.2　業務プログラムの設計に関する注意事項

        • 6.2.1　ファイル転送時間を省略する場合の注意

        • 6.2.2　印刷時に使用するデータファイルの注意

        • 6.2.3　帳票管理GUIと業務アプリケーションを併用してスプールデータを操作する場合の注意

        • 6.2.4　PDF取得機能を使用する場合の注意

        • 6.2.5　Java起動部品でメモリ取得機能を使用する場合の注意

    • 7.　EURの入力ファイルの設計

      • 7.1　EURで使用する入力ファイル

        • 7.1.1　デフォルトのインストール先および出力先

      • 7.2　エンコーディング

        • 7.2.1　入力ファイルのエンコーディング

        • 7.2.2　起動部品，コマンド，環境変数および標準出力の文字集合とエンコーディング

        • 7.2.3　画面に入力する項目の文字集合

      • 7.3　入力ファイル名の規則

        • 7.3.1　ファイル名に使用できる文字数

        • 7.3.2　EURで使用するファイル名に指定できる文字

    • 8.　帳票出力環境の設計

      • 8.1　EURの起動管理

        • 8.1.1　EUR Server Serviceの起動管理

        • 8.1.2　EUR Server - Spool Serviceの起動管理

        • 8.1.3　ファイル監視サービスの起動管理

        • 8.1.4　EUR Client Serviceの起動管理

      • 8.2　サーバ環境の設計

        • 8.2.1　Web/アプリケーションサーバの設定

        • 8.2.2　帳票サーバの設定

        • 8.2.3　スプールサーバの設定

      • 8.3　クライアント環境の設計

        • 8.3.1　クライアントPCの設定

        • 8.3.2　クライアントプリンタクラスの設定

      • 8.4　動作環境の設定

    • 9.　帳票デザインの設計

      • 9.1　帳票デザインを設計する

      • 9.2　帳票デザイン設計時の注意

        • 9.2.1　帳票の印刷範囲についての注意

        • 9.2.2　EUR サーバ帳票出力機能で出力する場合の注意

        • 9.2.3　Excel形式ファイルに出力する場合の注意

  • 付録

    • 付録A　EURで使用できる機能の一覧

    • 付録B　制限値一覧

    • 付録C　EURシリーズの関連プログラム

      • 付録C.1　データベースからデータを読み込む場合

      • 付録C.2　WordまたはExcel文書をEUR帳票に変換する場合

      • 付録C.3　SEWB+で定義した最上位結合項目からデータを読み込む場合

      • 付録C.4　データベースアクセス定義でデータ表示ウィンドウを使用する場合

      • 付録C.5　PDF形式ファイルを閲覧する場合

      • 付録C.6　Excel形式ファイルを閲覧・出力する場合

      • 付録C.7　JavaBeans起動部品（V8互換機能）を使用して帳票を出力する場合

      • 付録C.8　ActiveX起動部品を使用する場合

      • 付録C.9　COBOL起動部品を使用する場合

      • 付録C.10　EUR Web Plug-Inを使用する場合

      • 付録C.11　帳票管理GUIを使用する場合

      • 付録C.12　帳票管理GUIサービスを使用する場合

      • 付録C.13　配送サービスを使用する場合

      • 付録C.14　日立電子帳票システムと連携する場合

      • 付録C.15　LDAP認証を使用する場合

      • 付録C.16　BSP-RMと連携する場合

      • 付録C.17　監査証跡管理システムと連携する場合

      • 付録C.18　IT Report Utility（システム情報採取ツール）と連携する場合

      • 付録C.19　個人番号管理サービスと連携する場合

    • 付録D　このマニュアルの参考情報

      • 付録D.1　関連マニュアル

      • 付録D.2　EUR バージョン10での製品体系の変更

      • 付録D.3　EUR バージョン10でのマニュアル体系の変更

      • 付録D.4　このマニュアルでの表記

      • 付録D.5　このマニュアルで使用する略語

      • 付録D.6　KB（キロバイト）などの単位表記について

  • 索引

ページの先頭へ

  • 目次

  • 索引

  • 前へ

  • 2 / 195