Extensible SNMP Agent - Contents

Extensible SNMP Agent 11-00

Contents

Notices
Preface

1. Network Management
1.1 Managers and agents
1.2 Definition of MIB
1.3 MIB Structure
1.4 sysObjectID

2. Extensible Agent Function
2.1. Features of extensible agents

3. Environment Setup and Customization
3.1. Environment setup for an extensible agent

4. Command Reference
Command syntax conventions
systemtrap (issuing a system trap to the specified node)
snmptrap (issuing an SNMP trap to the specified node)
snmpcheck (displaying the operating status of the extensible agent)
jp1esalog.bat (data collection command when an error occurs)
esareg (re-registering the registry of sub-agent)

5 Business-specific MIB Objects
5.1 HP's business-specific objects
HP's business-specific MIB object list
computerSystem group (general 1)
fileSystem group (general 2)
processes group (general 4)
cluster group (general 5)
ieee8023Mac group (interface 1)
icmp group (nm 7)
trap group (snmp 1)
snmpdConf group (snmp 2)
authFail group (snmp 4)
5.2 Hitachi's business-specific MIB objects
Hitachi's business-specific MIB object list
opConf group (cometOP 10)
swapSpace group (hiux 7)
fileSystem64 group (hiux 21)
computerSystem64 group(hiux 24)
system group (windowsNT 1)
memory group (windowsNT 2)
process group (windowsNT 3)
processor group (windowsNT 4)
domainConf group (windowsNT 5)

Appendixes
A Glossary

Index

[Trademarks]

Copyright (C) 2015, Hitachi, Ltd.
Copyright (C) 2015, Hitachi Solutions, Ltd.


Notices

Relevant program products

P-2A42-8BBL JP1/Extensible SNMP Agent for Windows 11-00

Trademarks

HP is a trademark of Hewlett-Packard Development Company, L.P. in the U.S. and other countries.
Microsoft, Windows, and Windows Server are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

Edition history

Edition 1 : January 2016

Copyright

Copyright (C) 2015, Hitachi, Ltd.
Copyright (C) 2015, Hitachi Solutions, Ltd.

[Contents][Back][Next]


Trademarks

Extensible SNMP Agent

Trademarks

HP is a trademark of Hewlett-Packard Development Company, L.P. in the U.S. and other countries.
Microsoft, Windows, and Windows Server are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

[Contents]


Preface

Conventions: Abbreviations

This manual uses the following abbreviations for product names:

Full name or meaning | Abbreviation
JP1/Extensible SNMP Agent for Windows | ESA
JP1/SNMP System Observer | SSO
JP1/Cm2/Network Node Manager Starter Edition Enterprise | NNM
JP1/Cm2/Network Node Manager Starter Edition 250
HP OpenView Network Node Manager
Microsoft(R) Windows Server(R) 2008 R2 Standard | Windows
Microsoft(R) Windows Server(R) 2008 R2 Enterprise
Microsoft(R) Windows Server(R) 2008 R2 Datacenter
Microsoft(R) Windows Server(R) 2012 Standard
Microsoft(R) Windows Server(R) 2012 Datacenter
Microsoft(R) Windows Server(R) 2012 R2 Standard
Microsoft(R) Windows Server(R) 2012 R2 Datacenter

This manual also uses the following abbreviations:

Abbreviation | Full name or meaning
ASN.1 | Abstract Syntax Notation One
CPU | Central Processing Unit
EUC | Extended UNIX Code
IAB | Internet Activities Board
ICMP | Internet Control Message Protocol
ID | Identification
IP | Internet Protocol
JIS | Japanese Industrial Standard code
LAN | Local Area Network
MIB | Management Information Base
OS | Operating System
SJIS | Shift JIS
SMI | Structure of Management Information
SNMP | Simple Network Management Protocol
TCP | Transmission Control Protocol
TCP/IP | Transmission Control Protocol/Internet Protocol
UDP | User Datagram Protocol

Conventions: KB, MB, GB, and TB

This manual uses the following conventions:

  • 1 KB (kilobyte) is 1,024 bytes.
  • 1 MB (megabyte) is 1,0242 bytes.
  • 1 GB (gigabyte) is 1,0243 bytes.
  • 1 TB (terabyte) is 1,0244 bytes.


Network Management

1. Network Management

This chapter provides an overview of network management through SNMP.

Organization of this chapter
1.1 Managers and agents
1.2 Definition of MIB
1.3 MIB Structure
1.4 sysObjectID


Managers and agents

1.1 Managers and agents

Organization of this section
(1) A network manageable through SNMP
(2) Communication between manager and agent through SNMP

(1) Networks manageable through SNMP

A network manageable through SNMP consists of one or multiple manager systems (network management stations) and a group of agent systems (network members).

  • A manager system manages a network by monitoring and controlling agent systems. A system that achieves network management is called a "manager".
  • An agent system is a device on which the SNMP agent runs. An agent system executes SNMP requests from a manager. The types of agent system include a host, gateway (router), terminal server, hub, and bridge.

Managers and agents can operate on the same system.

(2) Communication between the manager and agents through SNMP

SNMP helps exchange management information (MIB) between the manager and agents. The following features are realized through SNMP:

  • A manager can collect management information from an agent (Get). A manager sends a request for management information to an agent, and the agent sends a response containing the requested management information.
  • A manager can change management information on an agent (Set).
  • An agent can send management information to a manager without a manager's request. This operation is called a trap. A trap is a message to notify a manager of a change that occurs on an agent system, such as restarting. An agent recognizes which manager system to send a trap to by the trap destination set by the user.

A request for management information on an agent is assigned a community name. A manager uses such a community name to access management information on an agent.


Definition of MIB

1.2 Definition of MIB

MIB
Management information on an agent is called a management information base (MIB: Management Information Base). An MIB is not a physically independent database, but a virtual database. MIB contains configuration information and status values, which can be normally used by a manager system.

MIB object
Management information of a certain type or class, such as a system code or interface status, is called an MIB object. A specific value for an MIB object is called an instance. Like a system code, for example, an MIB object might have only one instance for one agent system. However, like the interface status of each interface on a system, an MIB object might have multiple instances for one agent system.
An MIB is defined by using the Internet Standard management information structure (SMI: Structure of Management Information) and becomes a virtual data storage area on an agent system. SMI is defined by RFC1155: Structure and Identification of Management Information for TCP/IP-based Internets and revised by RFC1212: Concise MIB Definitions. Both RFC1155 and RFC1212 define the structure of management information for SNMP based network management.

MIB module
Multiple MIBs are filed into an MIB module. An MIB module is a file for defining all MIB objects under sub-trees. MIB modules are based on the Internet Standard MIB-II module defined by RFC1213: Management Information Base of Network Management of TCP/IP internets:MIB-II. Apart from using an Internet Standard MIB-II object, many hardware vendors have extended MIBs for their own products. MIBs defined by various hardware vendors are called "business-specific MIBs" in this online Help.
In addition, many standard MIBs are under development for such functions as LAN Ethernet linkage, remote LAN monitoring, bridges, hubs, and routers. These standard MIBs under development are worked on based on collaboration among vendors, universities, and standards institutions. The purpose of such development is to constitute common management information from business-specific MIBs and realize uniform access to management information across all vendor devices.

Related items
Extensible Agent Function
Business-specific MIB Objects


MIB Structure

1.3 MIB Structure

Conceptually, MIB objects are organized into a hierarchical tree structure. Each branch in a tree is assigned a unique name and numeric identifier. Middle branches in a tree function to organize inter-related MIB objects. Leaves in a tree express actual MIB objects. Subtrees are used to express an entire group that consists of branches and leaves under a specific middle branch. The following figure shows a tree structure example:

An MIB object is uniquely identified (specified) by the position in a tree. An object identifier in complete form is composed of the identifiers of the branches from the top (iso) to the relevant leaf along a path through a hierarchical tree. An object identifier is expressed by the dot notation (dot address) that separates the identifier of each branch along a path with dots (.). The following examples show an object identifier:

Examples of dot address
  • mib-2 subtree
    Object identifier: iso.org.dod.internet.mgmt.mib-2
    Numeric identifier: 1.3.6.1.2.1

  • sysObjectID
    Object identifier: iso.org.dod.internet.mgmt.mib-2.system.sysObjectID
    Numeric identifier: 1.3.6.1.2.1.1.2

For an MIB object with only one instance, 0 is set for the instance identifier. For an MIB object with multiple instances, a value equal to or more than 1 is set for the instance identifier. The notion for these MIB objects is based on the standard notation defined in ASN.1 (Abstract Syntax Notation One). This specification by the ASN.1 standard notation can be considered an MIB template.

To avoid duplication of object identifiers, each branch of a tree must be registered (defined) through the designated organization. For example, IAB (Internet Activities Board) has authority over Internet subtrees including the Internet Standard MIB-II registered under the mib-2 subtree. In addition, IAB grants privileges regarding business-specific subtrees to vendors. A business-specific MIB object is registered under the privileges assigned to the relevant company. The following examples show a business-specific MIB:

Examples of a business-specific MIB
  • Hitachi
    Business-specific MIB registration destination: 1.3.6.1.4.1.116
    Obtained privileges: Privileges regarding the enterprises.hitachi subtree.

  • HP
    Business-specific MIB registration destination: 1.3.6.1.4.1.11
    Obtained privileges: Privileges regarding the enterprises.hp subtree.


sysObjectID

1.4 sysObjectID

A sysObjectID is an important MIB object in ESA and related puroducts. This section describes a sysObjectID and how a sysObjectID is used in ESA and related puroducts.

In ESA and related puroducts, a sysObjectID is used as follows:

  • To identify a vendor (the name of a hardware manufacturer)
  • To identify an SNMP agent source (the type of agent software running on hardware)
  • To determine the action of an IP topology. The sysObjectID of an agent gives management information of an agent's node type such as a gateway, bridge, and host.
  • To determine the type of a symbol to be displayed on a manager's map. A sysObjectID is used to attach a symbol like a bridge, gateway, or hub, to a node newly found on the map.
  • To check an event source. A sysObjectID is attached to every trap. A sysObjectID is used to set an event. In general, a business ID to be referenced in the event setup dialog box of a manager is equal to the sysObjectID of an agent that generated a trap.

A sysObjectID is registered in an Internet Standard MIB-II module as iso.org.dod.internet.mgmt.mib-2.system.sysObjectID (1.3.6.1.2.1.1.2). A sysObjectID is used for an administrative purpose so as to uniquely identify the type of agent software running on the hardware of a specific vendor. A sysObjectID is different from other MIB objects. When a query is sent for a sysObjectID, the object identifier describing the relevant product is returned.

A sysObjectID contains both hardware information and software information, and changes according to the types of hardware and agent software. Some vendors have a different sysObjectID for each version of their agents.


Extensible Agent Function

2. Extensible Agent Function

This chapter describes the features of extensible agents.

Organization of this chapter
2.1. Features of extensible agents


Features of extensible agents

2.1 Features of extensible agents

In addition to the SNMP service features provided as standard in the Windows system, an extensible agent (ESA) provides a function to monitor Windows system resources. The system resources to be monitored by an extensible agent include the system, memory, processes, and processor.

System:
CPU usage time, the number of I/O operations and transferred bytes for file systems, and the number of hardware interrupts

Memory:
Virtual memory size, system cache size, frame transfer size, the number of page table entries, the number of paging operations, and the number of page faults

Processes:
The number of executing processes, process elapsed time, processor time consumed, the number of page faults, paging file size, basic priority level, the number of threads, virtual address space, and working set size

Processor:
Processor time and the number of device interrupts

Other items

Related items
HP's business-specific MIB object list
Hitachi's business-specific MIB object list


Environment Setup and Customization

3. Environment Setup and Customization

This chapter describes how to set up and customize the environment setup for an extensible agent.

Organization of this chapter
3.1. Environment setup for an extensible agent


Environment setup for an extensible agent

3.1 Environment setup for an extensible agent

Installing TCP/IP and SNMP Service

It is assumed that TCP/IP and SNMP service are already installed in Windows as the operating environments for an agent. If TCP/IP and SNMP service are not installed, install them by following the instructions in Windows Help.

Specifying settings for the network

Set the extensible agent system and the name of the IP node with which to communicate. There are three types of setting methods, as described below. Specify the settings to suit your network environment.

  • Specify the settings in the file (%SystemRoot%\system32\drivers\etc\hosts).
  • Specify the settings in the domain name system (DNS).
  • Specify the settings in Windows Internet Naming Service (WINS).
Setting security for the installation directory

To delete Everyone or deny Full Control in the Security settings of the installation directory of this product, set as follows:

In the security setting for the directory, permit Read & Execute for the account used to log on to the Windows service "SNMP Service" (or for the SYSTEM account if this is the local system account).

Setting the community name

To communicate with a manager, the community name for Get must be the same between manager and agent. To set the community name for Get on the agent side:

  1. From the Control Panel, open Administrative Tools, and then select Services.
  2. From the list of services, select SNMP Service, and then open the properties.
  3. In the Security configuration, set the community name with privileges equal to or higher than READ_ONLY.

In addition, when this product is monitored by using a manager system, the community name for Set "snmpd" needs to be included in the Security configuration to enable the automatic setting for the trap destination. In such cases, in the Security configuration of SNMP Service, set the community name "snmpd" with the READ_WRITE or READ_CREATE privileges.

Setting the "SNMP Service" service account

For the "SNMP Service" service account, specify either the local system account or an account belonging to the Administrators group. The local system account is set by default. To set an account belonging to the Administrators group:

  1. From the Control Panel, open Administrative Tools, and then select Services.
  2. From the list of services, select SNMP Service, and then open the properties.
  3. For the SNMP Service account, set a user name that belongs to the Administrators group.
  4. Specify the password for the user name set above.
Setting the system environment variable

With the extensible agent default settings, an MIB value cannot be obtained for the HP extensible MIB fileSystemFiles (a total file count in the file system). Setting the system environment variable below enables the system to obtain this MIB value. After setting the environment variable, restart the system.

Environment variable name
NO_FILECOUNT

Variable value
OFF

However, due to this setting, the number of files in the entire system will be counted every time an extensible agent receives a request for acquisition of an MIB value of a fileSystem group MIB. This might significantly degrade the response of the entire system. Note that fileSystemFiles is not used by the resource collection function of SSO. That is, the default setting (NO_FILECOUNT=ON) does not affect the resource collection function of SSO. Therefore, unless the need arises, the default setting is recommended.


Command Reference

4. Command Reference

This chapter describes the commands provided by the extensible agent.

Organization of this chapter
Command syntax conventions
systemtrap (issuing a system trap to the specified node)
snmptrap (issuing an SNMP trap to the specified node)
snmpcheck (displaying the operating status of the extensible agent)
jp1esalog.bat (data collection command when an error occurs)
esareg (re-registering the registry of sub-agent)


Command syntax conventions

Command syntax conventions

The following symbols are used in command syntax explanations:

Symbol | Meaning
[ ] | The item or items enclosed in square brackets are optional.
| | Only one of the options separated by a vertical bar can be used at one time.
{ } | One of the items enclosed in curly brackets and separated by a vertical bar must be specified.
... | The item or items preceding the ellipsis (...) can be repeated.
_ | The underlined characters are the system default when you omit all the items enclosed in brackets.


systemtrap (issuing a system trap to the specified node)

systemtrap (issuing a system trap to the specified node)

Format

<Adding or changing an object>
How the hierarchical level is specified:
systemtrap [-S|-E] -s [-c]
      destination issuing-source management-information-name[[@symbol-type],...]
      status ["user-text" ...]

<Deleting an object>
systemtrap [-S|-E] -d
      destination issuing-source management-information-name[[@symbol-type],...]

Description

Instructs the addition, deletion, or status change of a user symbol to the node submap of a manager.

Options

-S

Used to issue the symbol type, management information name, and user text values converted into S-JIS code, to the specified node.

Specify this option prior to the -s, -c, or -d option.

Do not specify together with the -E option.

-E

Used to issue the symbol type, management information name, and user text values converted into EUC code, to the specified node.

Other details are the same as the -S option.

-s

Used to generate a user symbol into the node submap and to change the status of a user symbol.

-d

Used to delete a user symbol from the node submap.

The user symbol to be deleted (name1, name2, ... parameter) is the same value as specified with the -s or -c option, and when a middle hierarchical level is specified, all the lower symbols including the relevant symbol will be deleted.

<Examples>
How the option is specified when generating a user symbol:
                      systemtrap -s netmd01 netmd01 name_1,name_2,name_3 Nor
How the option is specified when deleting a user symbol:
                      systemtrap -d netmd01 netmd01 name_1,name_2,name_3
                      systemtrap -d netmd01 netmd01 name_1,name_2
                      systemtrap -d netmd01 netmd01 name_1

-c

Used to change the status source of a node symbol on the segment submap that corresponds to the IP address shown by the issuing source, into complex status.

Arguments

destination

Specify the node name of a trap destination with an IP address or host name. Specify two double quotation marks ("") to omit the node name. When "" is specified, the destination is assumed as the SNMP agent trap destination or the trap destination defined in the definition file for system trap destinations (%installation-directory%\conf\systemtrap_node.conf).

issuing-source

Specify the IP address or host name of an issuing source node. Specify two double quotation marks ("") to omit the issuing source node. When "" is specified, the issuing source is assumed as the local node.

management-information-name[[@symbol-type],...]

Specify the hierarchical level of management information. When management information is displayed with a symbol in NNM, the level is "the 1st level (Node submap), the 2nd level, ..." The maximum number of levels is 10.

To specify a symbol type, note that a symbol type is enabled only for addition or change. Specify a symbol type after the management information name, separated by an at mark (@).

For the parameters,

  • the status and user text are values for the lowest object, and
  • the value specified with the -s option is valid for the highest object.

Note that you cannot specify a value including a comma (,) or at mark (@) for the management information name and symbol type.

status

Specify the status of a user symbol. Strings that can be specified and their meanings are as follows:

String | Meaning
Unk | Unknown
Nor | Normal/Running
War | Warning
Min | Minor
Maj | Major
Cri | Critical/Not running
Tes | Testing
Res | Restricted

user-text

Specify text that can be entered arbitrarily by the user. The maximum length for one text string is 255 bytes and a maximum of 10 text strings can be specified.

Note:
When Japanese text is specified in an argument, that text might be garbled if the language environment is not the same between the manager and agent.

Definition file for system trap destinations
The definition file for system trap destinations refers to a file that defines where to send traps and is loaded when "" is specified for the systemtrap command destination.
The priority of the systemtrap command destination is as follows:
The destination specified in the command > the destination specified in systemtrap_node.conf > the snmp service trap destination
For the file format,
  • write a "host name or IP address" in a single line.
  • when a hash mark (#) is specified at the top of a line, treat the line as a comment line.
<Example of defining the definition file for system trap destinations>
#systemtrap_node
netmd01
netmrx09
172.16.45.8
172.16.45.9

Definition file for hierarchical levels
The definition file for hierarchical levels refers to any file that defines the hierarchical level of management information and a symbol type in any key string. This file is loaded when "-f name-of-the-definition-file-for-hierarchical-levels, key-string" is specified instead of the "management-information-name[[@symbol-type],...]" parameter of the -c, -s, or -d option in the systemtrap command. Then, the setting value in the file that corresponds to the "key-string"is expanded to the "management-information-name[[@symbol-type],...]" parameter and a trap is sent.
For the file format,
  • write "key-string management-information-name[@symbol-type],management-information-name[@symbol-type],..." in a single line.
  • when a hash mark (#) is specified at the top of a line, treat the line as a comment line.
  • place any number of spaces or a tab to separate each parameter in a single line.
  • when multiple hierarchical levels are defined, apply the first defined level.
<Example of defining a definition file for hierarchical levels>
#systemtrap_kaisou
obj_1    1-A@typeA,2-B,3-C@typeB
obj_2    1-A@typeA,2-B,3-D@typeB
obj_3    1-A@typeA,2-E,3-F@typeC
How to specify the systemtrap command by using the definition file for hierarchical levels (c:\tmp\key.conf) in the above example is described as follows:

systemtrap -s -f netmd01 netmd01 c:\tmp\key.conf,obj_1 Nor
systemtrap -s -f netmd01 netmd01 c:\tmp\key.conf,obj_2 War
systemtrap -s -f netmd01 netmd01 c:\tmp\key.conf,obj_3 Cri


snmptrap (issuing an SNMP trap to the specified node)

snmptrap (issuing an SNMP trap to the specified node)

Format

snmptrap [-d] [-p port-number] [-c community-name]
    node-name company-ID agent-address standard-trap-number extensible-trap-number
    time-stamp [object-identifier value-syntax value...]

Description

Issues an SNMP trap to the specified node.

Options

-d

Used to output an SNMP packet in hexadecimal notation and in decoded ASN.1 format, into the standard output.

-p

Used to specify the port number of a sending manager. When nothing is specified, the port is 162.

-c community-name

Used to specify a community name. When nothing is specified, the community name is assumed as public.

Arguments

node-name

Specify an IP address or host name.

company-ID

Specify a sysObjectID. The format is A.B.C.D.... A, B, C, and D are sub-identifiers in decimal notation. In the A.B.C.D... format, when the beginning of an object identifier is "1.3.6.1.2.1", "1.3.6.1.2.1" can be omitted. The null string ("") is the sysObjectID of an SNMP agent.

agent-address

Specify an IP address or host name. When the null string ("") is specified, the IP address of a host that executed the command is specified.

If you want to use a specific IP address for the agent address in a trap message issued by the snmptrap command, specify that IP address for the "agent-address".

standard-trap-number

Specify an integer 0-6 for the standard trap number. Specify 6 to issue an extensible trap.

extensible-trap-number

Specify an integer of 32 bits for the extensible trap number.

time-stamp

Specify an integer equal to or greater than 0 for the time of day. When the null string ("") is specified, the timeticks (1/100 seconds) from when the command starts to immediately before a trap is sent are set.

object-identifier

In the snmptrap command, multiple arguments - each being composed of an object-identifier, value-syntax, and value - can be specified. Assume that the number of arguments that can be specified once is a maximum of 20 when the length of one argument is 256 bytes. The format for the object identifier is A.B.C.D.... A, B, C, and D here are sub-identifiers in decimal notation. In the A.B.C.D... format, when the beginning of an object identifier is "1.3.6.1.2.1", "1.3.6.1.2.1" can be omitted.

value-syntax

Select a value syntax among the following:

Integer (-231 to 231-1), octetstring, objectidentifier (when the format is A.B.C.D... and the beginning of an object identifier is "1.3.6.1.2.1", "1.3.6.1.2.1" can be omitted), null (any value set after this argument is ignored), ipaddress, counter (0 to 4294967295), gauge, timeticks, and opaque. For details of each description, see RFC1155.

You can also specify the following as special cases of octetstring: octetstringhex (specify a hexadecimal string from 00 to FF; example: 01FF), octetstringoctal (specify an octal string from 000 to 377; example: 001377), octetstringascii (specify an ASCII string), and octetstringsjis (specify an SJIS string). You can also specify the following as special cases of opaque: opaquehex (specify a hexadecimal string from 00 to FF; example: 01FF), opaqueoctal (specify an octal string from 000 to 377; example: 001377), opaqueascii (specify an ASCII string), and opaquesjis (specify an SJIS string).

value

Specify a valid value with respect to the value syntax.


snmpcheck (displaying the operating status of the extensible agent)

snmpcheck (displaying the operating status of the extensible agent)

Format

snmpcheck

Description

Displays the operating status of the processes that constitute the extensible agent function in the standard output.

Options

None.

Display format

The process name, operating status, and process ID are displayed by separating each with a tab as shown below. However, when the operating status is "not running", the process ID is not displayed.

Process name <TAB> Operating status <TAB> pid=Process ID

Displayed process names
hiextmib, hpextmib, and hismsmib

Displayed operating status
When the process is running: running
When the process stops: not running

Execution example

An example of executing the snmpcheck command is as follows:

C:\>snmpcheck                  <- Command issued
hiextmib  running  pid=2380    <- Standard output
hpextmib  running  pid=3132
hismsmib  not running
C:\>

Termination codes

The termination code of the snmpcheck command is as follows:

Code | Description
0 | Normal termination
1 | Execution failure. An error message is output.

Notes

The operating status of the hismsmib process is always "not running".


jp1esalog.bat (data collection command when an error occurs)

jp1esalog.bat (data collection command when an error occurs)

Format

jp1esalog.bat [-d output-destination-directory-name]

Description

Collects data for fault investigation when an error occurs in ESA. This command is provided only by ESA that runs on a Windows system.

By default, data is collected under %TEMP%\jp1log.

All the previously collected files under the above folder are deleted.

Note that the output destination directory for the files of collected data can be specified by using an option. Priority is placed on the output destination specified by using an option instead of the default output destination and the edited output destination.

Options

-d output-destination-directory-name

Used to specify the output destination for the file created by this command.

For the directory name, you cannot use spaces, double quotation marks ("), asterisks (*), vertical bars (|), angle brackets (< >), question marks (?), commas (,), backslashes (\), equal signs (=), or hash marks (#).

Customize

This command is executed in batch file format. The following items can be customized as needed:

  • If you want to change the default output destination,
    edit the output file name in the following line:

set OUTDIR=%TEMP%\jp1log
  • If the install path for ESA is different from the standard install path,
    edit the install path in the following line:

set INST_DIR_EA=%SystemDrive%\win32app\HITACHI\Cm2

Collected data list

The following table lists and describes data for fault investigation that is collected:

Classification | Collection condition | Acquired data
Main information#1 | Common | An environment configuration chart (OS, IP address, No. of interfaces, and the product configuration and version of each terminal)
 |  | A memo about how an error occurred (Details about the occurrence date, OS, host name, IP address, performed operations, and symptoms)
 |  | An event log file
 |  | A process list window of Task Manager
 |  | System information
OS information | Common | Collected files | Files under the %SystemRoot%\system32\driver\etc folder (a hosts file, services file, and so on)
 |  |  | drwtsn32.log and user.dmp#2
 |  | Command execution results | hostname
 |  |  | set
 |  |  | netstat -a
 |  |  | netstat -an
 |  |  | netstat -ano
 |  |  | net start
 |  |  | ipconfig /all
 |  |  | Registry information | (Under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\)
 |  |  |  | (Under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\)
 |  |  |  | (Under HKEY_LOCAL_MACHINE\SOFTWARE\HITACHI\)
 |  |  |  | (Under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Perflib\)
ESA information | Common | Collected files | Files under the ESA-installation-folder\conf folder
 |  |  | Files under the ESA-installation-folder\log folder
 |  |  | Files under the ESA-installation-folder\tmp folder
 |  |  | Files under the ESA-installation-folder\readme\esa\Version.txt
 |  |  | Files under the ESA-installation-folder\readme\esa\ProductInfo.txt
 |  |  | Hitachi integrated installer log file
 |  | Command execution results | snmpcheck
 |  |  | esareg -view
 |  |  | A list of folders and files under the installation directory | dir /S ESA installation folder

#1
Data to be manually collected.
#2
If this file does not exist, it cannot be collected.

Termination code

The termination code of the jp1esalog.bat command is as follows:

Termination code | Meaning
0 | Data collection complete

Notes

  • Execute this command when the ESA process is running. Do not restart the abnormally terminated ESA process. Execute this command instead.
  • Execute this command immediately after an error has occurred, when possible.
  • When the disk becomes full while saving files, data cannot be stored correctly. Before executing this command, make sure that the disk has sufficient free space.


esareg (re-registering the registry of sub-agent)

esareg (re-registering the registry of sub-agent)

Format

esareg {-view | -update}

Description

This command refers to the registration status of the registry of all sub-agents and updates (re-registers) the registry for all ESA sub-agents to modify priority.

Options

-view

Outputs the registration status of the registry of all sub-agents to the standard output. The sub-agents output to the standard output will be shown in the order of registration (in the order of low to high priority).
This optional function is only for referring to the registry and does not perform any update of the registration status.

-update

Updates (re-registers) the registry for all ESA sub-agents to modify priority. Although registration status will not be updated for sub agents other than the ESA sub-agents, the registration sequence of other sub agents relative to the ESA sub-agents can sometimes change.

Execution permissions

Administrator permissions

Installation directory

%installation-directory-of-this-product%\bin

Log file

The log information of this command is output to the following log file:

%installation-directory-of-this-product%\log\esareg.log

The maximum size of this log file is fixed to 2 MB. If the file size exceeds this limit, all previous logs will be saved with ".old" attached to the file name. In such a case, an existing log file with ".old" attached to its file name will be discarded.

Termination codes

The termination code of the esareg command is as follows:

Code | Description
0 | Normal completion
1 | Registry update processing cancelled by the user
2 | Incorrect command option
3 | Required software (either the "SNMP Service" service or ESA) not installed
4 | Incorrect required OS
5 | The "SNMP Service" service not stopped
7 | Preprocessing for registry reference or update failed
8 | Processing for registry reference or update failed

Notes

  • You can only execute the -update option while the "SNMP Service" service is stopped.
  • You can only execute this command in an environment where ESA is installed.
  • Do not execute this command while installing programs, including ESA.


Business-specific MIB Objects

5. Business-specific MIB Objects

This chapter describes business-specific MIB objects.

Organization of this chapter
5.1 HP's business-specific objects
5.2 Hitachi's business-specific MIB objects


HP's business-specific objects

5.1 HP's business-specific objects

Organization of this section
HP's business-specific MIB object list
computerSystem group (general 1)
fileSystem group (general 2)
processes group (general 4)
cluster group (general 5)
ieee8023Mac group (interface 1)
icmp group (nm 7)
trap group (snmp 1)
snmpdConf group (snmp 2)
authFail group (snmp 4)


HP's business-specific MIB object list

HP's business-specific MIB object list

The following figure shows the structure of HP's business-specific MIB objects:

enterprises(1)
    [Figure]  hp(11)
       [Figure]  nm(2)
          [Figure]  system(3)
          [Figure]     [Figure]  general(1)
          [Figure]         [Figure]  computerSystem(1)
          [Figure]         [Figure]  fileSystem(2)
          [Figure]         [Figure]  processes(4)
          [Figure]         [Figure]  cluster(5)
          [Figure]  interface(4)
          [Figure]      [Figure] ieee8023Mac(1)
          [Figure]  icmp(7)
          [Figure]  snmp(13)
              [Figure]  trap(1)
              [Figure]  snmpdConf(2)
              [Figure]  authFail(4)


computerSystem group (general 1)

computerSystem group (general 1)

Format

object-name MIB operation Get: Set:

The content of the object is described here.

Identifiers are shown here.

Example of the MIB operation Get: Set:
Y: The value can be obtained or set through the Get or Set operation.
N: The value cannot be obtained or set through the Get or Set operation. noSuchName is returned.
--: No access permissions. noSuchName is returned.

Objects

computerSystemUpTime Get:Y Set:--

Time elapsed since the system startup. The time is in 1/100 seconds.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).computerSystem(1).computerSystemUpTime(1)

computerSystemUsers Get:N Set:--

The number of logged in users.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).computerSystem(1).computerSystemUsers(2)

computerSystemAvgJobs1 Get:N Set:--

The average number of jobs over the past one minute * 100.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).computerSystem(1).computerSystemAvgJobs1(3)

computerSystemAvgJobs5 Get:N Set:--

The average number of jobs over the past five minutes * 100.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).computerSystem(1).computerSystemAvgJobs5(4)

computerSystemAvgJobs15 Get:N Set:--

The average number of jobs over the past 15 minutes * 100.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).computerSystem(1).computerSystemAvgJobs15(5)

computerSystemMaxProc Get:N Set:--

The maximum number of processes allowed in the system.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).computerSystem(1).computerSystemMaxProc(6)

computerSystemFreeMemory Get:Y Set:--

Free memory size. The size is in kilobytes. The range of values that can be handled correctly is from 0 to 2,147,483,647 (kilobytes).

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).computerSystem(1).computerSystemFreeMemory(7)

computerSystemPhysMemory Get:Y Set:--

Physical memory size. The size is in kilobytes. The range of values that can be handled correctly is from 0 to 2,147,483,647 (kilobytes).

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).computerSystem(1).computerSystemPhysMemory(8)

computerSystemMaxUserMem Get:Y Set:--

The maximum user memory size. The size is in kilobytes.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).computerSystem(1).computerSystemMaxUserMem(9)

computerSystemSwapConfig Get:Y Set:--

Commit charge in total (the limit). The amount is in bytes. The range of values that can be handled correctly is from 0 to 2,147,483,647 (bytes).

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).computerSystem(1).computerSystemSwapConfig(10)

computerSystemEnabledSwap Get:Y Set:--

Same as computerSystemSwapConfig. The amount is in bytes. The range of values that can be handled correctly is from 0 to 2,147,483,647 (bytes).

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).computerSystem(1).computerSystemEnableSwap(11)

computerSystemFreeSwap Get:Y Set:--

Size of free space that excludes the commit charge. The size is in bytes. The range of values that can be handled correctly is from 0 to 2,147,483,647 (bytes).

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).computerSystem(1).computerSystemFreeSwap(12)

computerSystemUserCPU Get:N Set:--

CPU usage time in user mode with the nice value being equal to or greater than 21. The time is in seconds.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).computerSystem(1).computerSystemUserCPU(13)

computerSystemSysCPU Get:Y Set:--

CPU usage time in privileged mode. The time is in seconds.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).computerSystem(1).computerSystemSysCPU(14)

computerSystemIdleCPU Get:Y Set:--

CPU idle time. The time is in seconds.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).computerSystem(1).computerSystemIdleCPU(15)

computerSystemNiceCPU Get:N Set:--

CPU usage time in user mode with the nice value being equal to or smaller than 20. The time is in seconds.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).computerSystem(1).computerSystemNiceCPU(16)


fileSystem group (general 2)

fileSystem group (general 2)

Format

object-name MIB operation Get: Set:

The content of the object is described here.

Identifiers are shown here.

Example of the MIB operation Get: Set:
Y: The value can be obtained or set through the Get or Set operation.
N: The value cannot be obtained or set through the Get or Set operation. noSuchName is returned.
--: No access permissions. noSuchName is returned.

Objects

fileSystemMounted Get:Y Set:--

The number of mounted file systems.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).fileSystem(2).fileSystemMounted(1)

fileSystemTable

File system information table.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).fileSystem(2).fileSystemTable(2)

fileSystemEntry

File system information table entries.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).fileSystem(2).fileSystemTable(2).fileSystemEntry(1)

fileSystemID1 Get:Y Set:--

File system ID1 (a file system serial number starting from 0).

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).fileSystem(2).fileSystemTable(2).fileSystemEntry(1).fileSystemID1(1)

fileSystemID2 Get:Y Set:--

File system ID2 (fixed as 0).

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).fileSystem(2).fileSystemTable(2).fileSystemEntry(1).fileSystemID2(2)

fileSystemName Get:Y Set:--

Name of the file system mounted (FAT, NTFS, and so on).

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).fileSystem(2).fileSystemTable(2).fileSystemEntry(1).fileSystemName(3)

fileSystemBlock Get:Y Set:--

Total file system space. The size is in kilobytes. The range of values that can be handled correctly is from 0 to 2,147,483,647 (kilobytes).

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).fileSystem(2).fileSystemTable(2).fileSystemEntry(1).fileSystemBlock(4)

fileSystemBfree Get:Y Set:--

File system free space. The size is in kilobytes. The range of values that can be handled correctly is from 0 to 2,147,483,647 (kilobytes).

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).fileSystem(2).fileSystemTable(2).fileSystemEntry(1).fileSystemBfree(5)

fileSystemBavail Get:Y Set:--

Same as fileSystemBfree. The size is in kilobytes. The range of values that can be handled correctly is from 0 to 2,147,483,647 (kilobytes).

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).fileSystem(2).fileSystemTable(2).fileSystemEntry(1).fileSystemBavail(6)

fileSystemBsize Get:N Set:--

Basic file system block size. The size is in kilobytes.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).fileSystem(2).fileSystemTable(2).fileSystemEntry(1).fileSystemBsize(7)

fileSystemFiles Get:N# Set:--

The total number of files in the file system.

#
The total number of the files can be obtained by setting the environment variable. For details on the setting procedure and notes, see "Setting the system environment variable" in Environment setup for an extensible agent.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).fileSystem(2).fileSystemTable(2).fileSystemEntry(1).fileSystemFiles(8)

fileSystemFfree Get:N Set:--

The total number of free files in the file system.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).fileSystem(2).fileSystemTable(2).fileSystemEntry(1).fileSystemFfree(9)

fileSystemDir Get:Y Set:--

File system path.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).fileSystem(2).fileSystemTable(2).fileSystemEntry(1).fileSystemDir(10)


processes group (general 4)

processes group (general 4)

Format

object-name MIB operation Get: Set:

The content of the object is described here.

Identifiers are shown here.

Example of the MIB operation Get: Set:
Y: The value can be obtained or set through the Get or Set operation.
N: The value cannot be obtained or set through the Get or Set operation. noSuchName is returned.
--: No access permissions. noSuchName is returned.

Objects

processNum Get:Y Set:--

The number of executing processes.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processNum(1)

processTable

Executing process information table.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2)

processEntry

Executing process information table entries.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1)

processPID Get:Y Set:--

Process ID.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processPID(1)

processIdx Get:Y Set:--

Process table entry number.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processIdx(2)

processUID Get:N Set:--

Process user ID.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processUID(3)

processPPID Get:N Set:--

Parent process ID.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processPPID(4)

processDsize Get:N Set:--

Process data size. The size is in pages.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processDsize(5)

processTsize Get:N Set:--

Process text size. The size is in pages.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processTsize(6)

processSsize Get:N Set:--

Process stack size. The size is in pages.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).prosessSsize(7)

processNice Get:N Set:--

Process nice value.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processNice(8)

processMajor Get:N Set:--

Process control terminal major number.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processMajor(9)

processMinor Get:N Set:--

Process control terminal minor number.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processMinor(10)

processPgrp Get:N Set:--

Process group ID of the process.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processPgrp(11)

processPrio Get:Y Set:--

Process priority.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processPrio(12)

processAddr Get:N Set:--

Pointer to the virtual address space table.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processAddr(13)

processCPU Get:N Set:--

Processor usage for scheduling.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processCPU(14)

processUtime Get:Y Set:--

Actually used user time. The time is in 1/100 seconds.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processUtime(15)

processStime Get:Y Set:--

Actually used system time. The time is in 1/100 seconds.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processStime(16)

processStart Get:Y Set:--

Process start time. The time is in 1/100 seconds.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processStart(17)

processFlags Get:N Set:--

Process-related flags.

  • incore(1)
  • sys(2)
  • locked(4)
  • trace(8)
  • trace2(16)

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processFlags(18)

processStatus Get:N Set:--

Process status.

  • sleep(1)
  • run(2)
  • stop(3)
  • zombie(4)
  • other(5)
  • idle(6)

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processStatus(19)

processWchan Get:N Set:--

Sleeping address.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processWchan(20)

processProcNum Get:N Set:--

Processor that last executed the process.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processProcNum(21)

processCmd Get:Y Set:--

Command that executed the process.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processCmd(22)

processTime Get:N Set:--

In-core elapsed time. The time is in seconds.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processTime(23)

processCPUticks Get:N Set:--

CPU time ticks.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processCPUticks(24)

processCPUticksTotal Get:N Set:--

The total number of ticks while the process is running.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processCPUticksTotal(25)

processFss Get:N Set:--

Scheduler group FSS group ID.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processFss(26)

processPctCPU Get:N Set:--

CPU occupancy rate of the process.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processPctCPU(27)

processRssize Get:Y Set:--

The number of pages loaded in-core. The value is in pages.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processRssize(28)

processSUID Get:N Set:--

Valid user ID.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processSUID(29)

processUname Get:N Set:--

User name.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processUname(30)

processTTY Get:N Set:--

Process tty.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processTTY(31)


cluster group (general 5)

cluster group (general 5)

Format

object-name MIB operation Get: Set:

The content of the object is described here.

Identifiers are shown here.

Example of the MIB operation Get: Set:
Y: The value can be obtained or set through the Get or Set operation.
N: The value cannot be obtained or set through the Get or Set operation. noSuchName is returned.
--: No access permissions. noSuchName is returned.

Objects

isClustered Get:N Set:--

Identifies whether the machine is in a cluster configuration.

  • standalone(1)
  • rootserver(2)
  • cnode(3)

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).cluster(5).isClustered(1)

clusterTable

Cluster node information table.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).cluster(5).clusterTable(2)

clusterEntry

Cluster node information table entries.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).cluster(5).clusterTable(2).clusterEntry(1)

clusterID Get:N Set:--

cnode ID.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).cluster(5).clusterTable(2).clusterEntry(1).clusterID(1)

clusterMachineID Get:N Set:--

cnode machine ID.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).cluster(5).clusterTable(2).clusterEntry(1).clusterMachine(2)

clusterType Get:N Set:--

cnode type (r or c).

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).cluster(5).clusterTable(2).clusterEntry(1).clusterType(3)

clusterCnodeName Get:N Set:--

cnode name.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).cluster(5).clusterTable(2).clusterEntry(1).clusterCnodeName(4)

clusterSwapServingCnode Get:N Set:--

Swap serving cnode.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).cluster(5).clusterTable(2).clusterEntry(1).clusterSwapServingCnode(5)

clusterKcsp Get:N Set:--

KCSP.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).cluster(5).clusterTable(2).clusterEntry(1).clusterKcsp(6)

clusterCnodeAddress Get:N Set:--

cnode IP address.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).cluster(5).clusterTable(2).clusterEntry(1).clusterCnodeAddress(7)

clusterCnodeID Get:N Set:--

Machine's cnode ID.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).cluster(5).clusterCnodeID(3)


ieee8023Mac group (interface 1)

ieee8023Mac group (interface 1)

Format

object-name MIB operation Get: Set:

The content of the object is described here.

Identifiers are shown here.

Example of the MIB operation Get: Set:
Y: The value can be obtained or set through the Get or Set operation.
N: The value cannot be obtained or set through the Get or Set operation. noSuchName is returned.
--: No access permissions. noSuchName is returned.

Objects

ieee8023MacTable

ieee802.3 interface information table.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).interface(4).ieee8023Mac(1).ieee8023MacTable(1)

ieee8023MacEntry

ieee802.3 interface information table entries.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).interface(4).ieee8023Mac(1).ieee8023MacTable(1).ieee8023MacEntry(1)

ieee8023MacIndex Get:N Set:--

Interface number corresponding to ifIndex.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).interface(4).ieee8023Mac(1).ieee8023MacTable(1).ieee8023MacEntry(1).ieee8023MacIndex(1)

ieee8023MacTransmitted Get:N Set:--

The number of successfully transferred frames.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).interface(4).ieee8023Mac(1).ieee8023MacTable(1).ieee8023MacEntry(1).ieee8023MacTransmitted(2)

ieee8023MacNotTransmitted Get:N Set:--

The number of untransferred frames.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).interface(4).ieee8023Mac(1).ieee8023MacTable(1).ieee8023MacEntry(1).ieee8023MacNotTransmitted(3)

ieee8023MacDeferred Get:N Set:--

The number of frames deferred because the medium was busy.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).interface(4).ieee8023Mac(1).ieee8023MacTable(1).ieee8023MacEntry(1).ieee8023MacDeferred(4)

ieee8023MacCollisions Get:N Set:--

The total number of retried transfer attempts due to collisions.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).interface(4).ieee8023Mac(1).ieee8023MacTable(1).ieee8023MacEntry.ieee8023MacCollisions(5)

ieee8023MacSingleCollisions Get:N Set:--

The number of retried transfer attempts successful after being blocked by a single collision.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).interface(4).ieee8023Mac(1).ieee8023MacTable(1).ieee8023MacEntry(1).ieee8023MacSingleCollisions(6)

ieee8023MacMultipleCollisions Get:N Set:--

The number of retried transfer attempts successful after being blocked by 2 to 5 collisions.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).interface(4).ieee8023Mac(1).ieee8023MacTable(1).ieee8023MacEntry(1).ieee8023MacMultipleCollisions(7)

ieee8023MacExcessCollisions Get:N Set:--

The number of retried transfer attempts successful after being blocked by 15 or more collisions.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).interface(4).ieee8023Mac(1).ieee8023MacTable(1).ieee8023MacEntry(1).ieee8023MacExcessCollisions(8)

ieee8023MacLateCollisions Get:N Set:--

The number of retried transfer attempts that failed due to collision occurrence after the allocated channel time elapsed.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).interface(4).ieee8023Mac(1).ieee8023MacTable(1).ieee8023MacEntry(1).ieee8023MacLateCollisions(9)

ieee8023MacCarrierLostErrors Get:N Set:--

The number of times carrier sense was lost during the transfer attempt.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).interface(4).ieee8023Mac(1).ieee8023MacTable(1).ieee8023MacEntry(1).ieee8023MacCarrierLostErrors(10)

ieee8023MacNoHeartBeatErrors Get:N Set:--

The number of times hear beat was not indicated after the transfer.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).interface(4).ieee8023Mac(1).ieee8023MacTable(1).ieee8023MacEntry(1)ieee8023MacNoHeartBeatErrors(11)

ieee8023MacFramesReceived Get:N Set:--

The number of successfully received frames.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).interface(4).ieee8023Mac(1).ieee8023MacTable(1).ieee8023MacEntry(1).ieee8023MacFramesReceived(12)

ieee8023MacUndeliverableFramesReceived Get:N Set:--

The number of received frames undelivered due to software buffer overrun when frames were transmitted more rapidly than they were received.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).interface(4).ieee8023Mac(1).ieee8023MacTable(1).ieee8023MacEntry(1).ieee9023MacUndeliverableFramesReceived(13)

ieee8023MacCRCErrors Get:N Set:--

The number of times a CRC error was detected.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).interface(4).ieee8023Mac(1).ieee8023MacTable(1).ieee8023MacEntry(1).ieee8023MacCRCErrors(14)

ieee8023MacAlignmentErrors Get:N Set:--

The number of received frames with a misalignment error on both CRCs.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).interface(4).ieee8023Mac(1).ieee8023MacTable(1).ieee8023MacEntry(1).ieee8023MacAlignmentErrors(15)

ieee8023MacResourceErrors Get:N Set:--

The number of received frames lost due to resource shortage.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).interface(4).ieee8023Mac(1).ieee8023MacTable(1).ieee8023MacEntry(1).ieee8023MacResourceErrors(16)

ieee8023MacControlFieldErrors Get:N Set:--

The number of received frames with an error in the control field.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).interface(4).ieee8023Mac(1).ieee8023MacTable(1).ieee8023MacEntry(1).ieee8023MacControlFieldErrors(17)

ieee8023MacUnknownProtocolErrors Get:N Set:--

The number of frames dropped because the type field or SAP field referenced the wrong protocol.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).interface(4).ieee8023Mac(1).ieee8023MacTable(1).ieee8023MacEntry(1).ieee8023MacUnknownProtocolErrors(18)

ieee8023MacMulticastsAccepted Get:N Set:--

The number of accepted multicast addresses.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).interface(4).ieee8023Mac(1).ieee8023MacTable(1).ieee8023MacEntry(1).ieee8023MacMulticastsAccepted(19)


icmp group (nm 7)

icmp group (nm 7)

Format

object-name MIB operation Get: Set:

The content of the object is described here.

Identifiers are shown here.

Example of the MIB operation Get: Set:
Y: The value can be obtained or set through the Get or Set operation.
N: The value cannot be obtained or set through the Get or Set operation. noSuchName is returned.
--: No access permissions. noSuchName is returned.

Objects

icmpEchoReq Get:Y Set:--

Error information and the number of seconds required for responding to an ICMP echo request.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).icmp(7).icmpEchoReq(1)


trap group (snmp 1)

trap group (snmp 1)

Format

object-name MIB operation Get: Set:

The content of the object is described here.

Identifiers are shown here.

Example of the MIB operation Get: Set:
Y: The value can be obtained or set through the Get or Set operation.
N: The value cannot be obtained or set through the Get or Set operation. noSuchName is returned.
--: No access permissions. noSuchName is returned.

Objects

trapDestinationNum Get:Y Set:--

The number of trap destinations.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).snmp(13).Trap(1).trapDestinationNum(1)

trapDestinationTable

Agent trap destination address table.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).snmp(13).trap(1).trapDestinationTable(2)

trapDestinationEntry

Trap destination address table entries.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).snmp(13).trap(1).trapDestinationTable(2).trapDestinationEntry(1)

trapDestination Get:Y Set:Y

Agent trap destination address.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).snmp(13).Trap(1).trapDestinationTable(2).trapDestrinationEntry(1).trapDestination(1)


snmpdConf group (snmp 2)

snmpdConf group (snmp 2)

Format

object-name MIB operation Get: Set:

The content of the object is described here.

Identifiers are shown here.

Example of the MIB operation Get: Set:
Y: The value can be obtained or set through the Get or Set operation.
N: The value cannot be obtained or set through the Get or Set operation. noSuchName is returned.
--: No access permissions. noSuchName is returned.

Objects

snmpdConfRespond Get:N Set:N

Responds to all objects when true(1) is set.

  • true(1)
  • false(2)

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).snmp(13).snmpdConf(2).snmpdConfRespond(1)

snmpdReConfigure Get:N Set:N

Reconfigures the agent when reset(1) is set.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).snmp(13).snmpdConf(2).snmpReconfigure(2)

snmpdFlag Get:Y Set:--

Agent capability.

  • removetrap(1)
  • netwareproxy(2)

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).snmp(13).snmpdConf(2).snmpFlag(3)

snmpdLogMask Get:Y Set:Y

Agent log mask.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).snmp(13).snmpdConf(2).snmpLogMask(4)

snmpdVersion Get:N Set:--

Agent version number.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).snmp(13).snmpdConf(2).snmpVersion(5)

snmpdStatus Get:N Set:N

Daemon status.

  • up(1)
  • down(2)

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).snmp(13).snmpdConf(2).snmpStatus(6)

snmpdSize Get:N Set:--

Data segment size secured by the process. The size is in bytes.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).snmp(13).snmpdConf(2).snmpSize(7)

snmpdWhatString Get:N Set:--

Daemon profile (product name, version, date, and copyright).

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).snmp(13).snmpdConf(2).snmpWhatString(9)


authFail group (snmp 4)

authFail group (snmp 4)

Format

object-name MIB operation Get: Set:

The content of the object is described here.

Identifiers are shown here.

Example of the MIB operation Get: Set:
Y: The value can be obtained or set through the Get or Set operation.
N: The value cannot be obtained or set through the Get or Set operation. noSuchName is returned.
--: No access permissions. noSuchName is returned.

Objects

authFailTable

Authentication failure information table.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).snmp(13).authFail(4).authFailTable(1)

authFailEntry

Authentication failure information table entry.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).snmp(13).authFail(4).authFailTable(1).authFailEntry(1)

authIpAddress Get:N Set:--

IP address of the manager transmitting a request with a wrong community name to an agent.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).snmp(13).authFail(4).authFailTable(1).authFailEntry(1).authIpAddress(1)

authTime Get:N Set:--

Time elapsed since the agent received an unauthenticated request. The time is in 1/100 seconds.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).snmp(13).authFail(4).authFailTable(1).authFailEntry(1).authTime(2)

authCommunityName Get:N Set:--

Wrong community name.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).snmp(13).authFail(4).authFailTable(1).authFailEntry(1).authCommunityName(3)


Hitachi's business-specific MIB objects

5.2 Hitachi's business-specific MIB objects

Organization of this section
Hitachi's business-specific MIB object list
opConf group (cometOP 10)
swapSpace group (hiux 7)
fileSystem64 group (hiux 21)
computerSystem64 group(hiux 24)
system group (windowsNT 1)
memory group (windowsNT 2)
process group (windowsNT 3)
processor group (windowsNT 4)
domainConf group (windowsNT 5)


Hitachi's business-specific MIB object list

Hitachi's business-specific MIB object list

The following figure shows the structure of Hitachi's business-specific MIB objects:

enterprises(1)
    [Figure]  hitachi(116)
         [Figure]  system(3)
         [Figure]     [Figure]  hiuxwe2(5)
         [Figure]     [Figure]     [Figure]  comet3050rx(1)
         [Figure]     [Figure]     [Figure]      [Figure]  mgr(1)
         [Figure]     [Figure]     [Figure]      [Figure]  smg(2)
         [Figure]     [Figure]     [Figure]      [Figure]  agt(3)
         [Figure]     [Figure]     [Figure]  comet3500(2)
         [Figure]     [Figure]          [Figure]  mgr(1)
         [Figure]     [Figure]          [Figure]  smg(2)
         [Figure]     [Figure]          [Figure]  agt(3)
         [Figure]     [Figure]  solaris(8)
         [Figure]     [Figure]     [Figure]  sparc(1)
         [Figure]     [Figure]          [Figure]  smg(2)
         [Figure]     [Figure]          [Figure]  agt(3)
         [Figure]     [Figure]  hp-ux(9)
         [Figure]     [Figure]     [Figure]  h9000(1)
         [Figure]     [Figure]          [Figure]  smg(2)
         [Figure]     [Figure]          [Figure]  agt(3)
         [Figure]     [Figure]  windowsNT(10)
         [Figure]         [Figure]  x86(1)
         [Figure]              [Figure]  mgr(1)
         [Figure]              [Figure]  smg(2)
         [Figure]              [Figure]  agt(3)
         [Figure] systemExMib(5)
             [Figure]  cometMibs(1)
                 [Figure]  subSystems(1)
                 [Figure]      [Figure]  cometOP(2)
                 [Figure]          [Figure]  opConf(10)
                 [Figure]  systems(2)
                      [Figure]  hiux(1)
                      [Figure]     [Figure]  systemInfo(1)
                      [Figure]     [Figure]  virtualMemory(2)
                      [Figure]     [Figure]  process(3)
                      [Figure]     [Figure]  processor(4)
                      [Figure]     [Figure]  diskInfo(5)
                      [Figure]     [Figure]  swapInfo(6)
                      [Figure]     [Figure]  swapSpace(7)
                      [Figure]     [Figure]  fileSystem64(21)
                      [Figure]     [Figure]  computerSystem64(24)
                      [Figure]  windowsNT(2)
                          [Figure]  system(1)
                          [Figure]  memory(2)
                          [Figure]  process(3)
                          [Figure]  processor(4)
                          [Figure]  domainConf(5)


opConf group (cometOP 10)

opConf group (cometOP 10)

Format

object-name MIB operation Get: Set:

The content of the object is described here.

Identifiers are shown here.

Example of the MIB operation Get: Set:
Y: The value can be obtained or set through the Get or Set operation.
N: The value cannot be obtained or set through the Get or Set operation. noSuchName is returned.
--: No access permissions. noSuchName is returned.

Objects

opConfCharCode Get:Y Set:--

Character encoding Comet/OP uses for code conversion.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).subSystems(1).cometOP(2).opConf(10).opConfCharCode(1)


swapSpace group (hiux 7)

swapSpace group (hiux 7)

Format

object-name MIB operation Get: Set:

The content of the object is described here.

Identifiers are shown here.

Example of the MIB operation Get: Set:
Y: The value can be obtained or set through the Get or Set operation.
N: The value cannot be obtained or set through the Get or Set operation. noSuchName is returned.
--: No access permissions. noSuchName is returned.

Objects

swapSpaceConfig Get:Y Set:--

Commit charge total (the limit). The amount is in kilobytes. The range of values that can be handled correctly is from 0 to 2,147,483,647 (kilobytes).

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).swapSpace(7).swapSpaceConfig(1)

swapSpaceEnable Get:Y Set:--

Same as swapSpaceConfig. The amount is in kilobytes. The range of values that can be handled correctly is from 0 to 2,147,483,647 (kilobytes).

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).swapSpace(7).swapSpaceEnable(2)

swapSpaceFree Get:Y Set:--

Size of commit charge free space. The size is in kilobytes. The range of values that can be handled correctly is from 0 to 2,147,483,647 (kilobytes).

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).swapSpace(7).swapSpaceFree(3)


fileSystem64 group (hiux 21)

fileSystem64 group (hiux 21)

Format

object-name MIB operation Get: Set:

The content of the object is described here.

Identifiers are shown here.

Example of the MIB operation Get: Set:
Y: The value can be obtained or set through the Get or Set operation. However, depending on the conditions such as the required OS, Y and N might be the same.
N: The value cannot be obtained or set through the Get or Set operation. noSuchName is returned.
--: No access permissions. noSuchName is returned.

Objects

fileSystem64Mounted Get:Y Set:--

The number of mounted file systems.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).fileSystem64(21).fileSystem64Mounted(1)

fileSystem64Table

File system information table.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).fileSystem64(21).fileSystem64Table(2)

fileSystem64Entry

File system information table entries.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).fileSystem64(21).fileSystem64Table(2).fileSystem64Entry(1)

fileSystem64HighID1 Get:Y Set:--

High bit of file system ID1 (a file system serial number starting from 0).

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).fileSystem64(21).fileSystem64Table(2).fileSystem64Entry(1).fileSystem64HighID1(1)

fileSystem64LowID1 Get:Y Set:--

Low bit of file system ID1 (a file system serial number starting from 0).

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).fileSystem64(21).fileSystem64Table(2).fileSystem64Entry(1).fileSystem64LowID1(2)

fileSystem64ID2 Get:Y Set:--

File system ID2 (fixed as 0).

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).fileSystem64(21).fileSystem64Table(2).fileSystem64Entry(1).fileSystem64ID2(3)

fileSystem64Name Get:Y Set:--

Name of the mounted file system (FAT, NTFS, and so on).

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).fileSystem64(21).fileSystem64Table(2).fileSystem64Entry(1).fileSystem64Name(4)

fileSystem64Block Get:Y Set:--

Total file system space. The size is in kilobytes. The range of values that can be handled correctly is from 0 to 18,014,398,509,481,983 (kilobytes).

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).fileSystem64(21).fileSystem64Table(2).fileSystem64Entry(1).fileSystem64Block(5)

fileSystem64Bfree Get:Y Set:--

File system free space. The size is in kilobytes. The range of values that can be handled correctly is from 0 to 18,014,398,509,481,983 (kilobytes).

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).fileSystem64(21).fileSystem64Table(2).fileSystem64Entry(1).fileSystem64Bfree(6)

fileSystem64Bavail Get:Y Set:--

Same as fileSystem64Bfree. The size is in kilobytes. The range of values that can be handled correctly is from 0 to 18,014,398,509,481,983 (kilobytes).

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).fileSystem64(21).fileSystem64Table(2).fileSystem64Entry(1).fileSystem64Bavail(7)

fileSystem64Bsize Get:N Set:--

Basic file system block size. The size is in kilobytes.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).fileSystem64(21).fileSystem64Table(2).fileSystem64Entry(1).fileSystem64Bsize(8)

fileSystem64Files Get:N Set:--

The total number of files in the file system.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).fileSystem64(21).fileSystem64Table(2).fileSystem64Entry(1).fileSystem64Files(9)

fileSystem64Ffree Get:N Set:--

The total number of free files in the file system.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).fileSystem64(21).fileSystem64Table(2).fileSystem64Entry(1).fileSystem64Ffree(10)

fileSystem64Dir Get:Y Set:--

File system path.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).fileSystem64(21).fileSystem64Table(2).fileSystem64Entry(1).fileSystem64Dir(11)


computerSystem64 group(hiux 24)

computerSystem64 group(hiux 24)

Format

object-name MIB operation Get: Set:

The content of the object is described here.

Identifiers are shown here.

Example of the MIB operation Get: Set:
Y: The value can be obtained or set through the Get or Set operation.
N: The value cannot be obtained or set through the Get or Set operation. noSuchName is returned.
--: No access permissions. noSuchName is returned.

Objects

computerSystem64FreeMemory Get:Y Set:--

Free memory size. The size is in kilobytes. The range of values that can be handled correctly is from 0 to 18,014,398,509,481,983 (kilobytes).

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).ComputerSystem64(24).computerSystem64FreeMemory(7)

computerSystem64PhysMemory Get:Y Set:--

Physical memory size. The size is in kilobytes. The range of values that can be handled correctly is from 0 to 18,014,398,509,481,983 (kilobytes).

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).ComputerSystem64(24).computerSystem64PhysMemory(8)

computerSystem64SwapConfig Get:Y Set:--

Commit charge in total (the limit). The amount is in kilobytes. The range of values that can be handled correctly is from 0 to 18,014,398,509,481,983 (kilobytes).

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).ComputerSystem64(24).computerSystem64SwapConfig(10)

computerSystem64EnabledSwap Get:Y Set:--

Same as computerSystem64SwapConfig. The amount is in kilobytes. The range of values that can be handled correctly is from 0 to 18,014,398,509,481,983 (kilobytes).

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).ComputerSystem64(24).computerSystem64EnabledSwap(11)

computerSystem64FreeSwap Get:Y Set:--

Size of free space that excludes the commit charge. The size is in kilobytes. The range of values that can be handled correctly is from 0 to 18,014,398,509,481,983 (kilobytes).

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).ComputerSystem64(24).computerSystem64FreeSwap(12)


system group (windowsNT 1)

system group (windowsNT 1)

Format

object-name MIB operation Get: Set:

The content of the object is described here.

Identifiers are shown here.

Example of the MIB operation Get: Set:
Y: The value can be obtained or set through the Get or Set operation.
N: The value cannot be obtained or set through the Get or Set operation. noSuchName is returned.
--: No access permissions. noSuchName is returned.

Objects

systemTotalPrivilegedTime Get:Y Set:--

Total time consumed in privileged mode by all processors. When a Windows system service is called up, in many cases, that service runs in privileged mode and access to the data dedicated to the system becomes possible. Such data cannot be accessed by threads running in user mode. The system can be called up explicitly, and in such cases as page fault and interrupt occurrence, the system might be also called up implicitly. Unlike certain existing OS platforms, in addition to conventional protection methods such as user mode and privileged mode, Windows adopts the concept of process boundaries to protect subsystems. Subsystem processes in this concept provide additional protection other than conventional methods. So, certain processing performed by Windows on behalf of an application might be performed also in other subsystem processes in addition to the Privileged Time of the application. The time is in 1/100 seconds.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).system(1).systemTotalPrivilegedTime(1)

systemTotalProcessorTime Get:Y Set:--

Total time consumed by all processors on the system executing idle threads. Every processor is assigned an idle thread in an idle process, and that idle thread consumes the unproductive processor cycles that are not utilized by any other threads. The time is in 1/100 seconds.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).system(1).systemTotalProcessorTime(2)

systemTotalUserTime Get:Y Set:--

Total time consumed in user mode by all processors. Like subsystems such as window managers and graphics engines, applications operate in user mode. Codes operating in user mode do not cause damage to Windows Executive, Kernel, or device drivers. Unlike certain existing OS platforms, in addition to conventional protection methods such as user mode and privileged mode, Windows adopts the concept of process boundaries to protect subsystems. Subsystem processes in this concept provide their own protection. So, certain processing performed by Windows on behalf of an application might be performed also in other subsystem processes in addition to the Privileged Time of the application. The time is in 1/100 seconds.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).system(1).systemTotalUserTime(3)

systemAlignmentFixups Get:Y Set:--

The number of alignment violation fixups by the system.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).system(1).systemAlignmentFixups(4)

systemContextSwitches Get:Y Set:--

The number of thread switching times. Thread switching is performed in a single process as well as between multiple processes. This switching is performed when one thread requests another thread for information or when, while one thread is being executed, a higher priority thread becomes ready to execute. Unlike certain existing OS platforms, in addition to conventional protection methods such as user mode and privileged mode, Windows adopts the concept of process boundaries to protect subsystems. Subsystem processes in this concept provide additional protection other than conventional methods. So, certain processing performed by Windows on behalf of an application might be performed also in other subsystem processes in addition to the Privileged Time of the application. When operation changes to a subsystem process, a context switch is performed in an application thread. On the contrary, when operation switches to an application, a context switch is performed in the subsystem thread.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).system(1).systemContextSwitches(5)

systemExceptionDispatch Get:Y Set:--

The number of exception dispatches by the system.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).system(1).systemExceptionDispatch(6)

systemFileControlBytes Get:Y Set:--

The total number of bytes transferred through all operations on the computer, except for read and write operations, performed on file systems. Normally, such operations except for read and write operations include file system control requests or requests for information on device characteristics and status. The value is in bytes.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).system(1).systemFileControlBytes(7)

systemFileControlOperations Get:Y Set:--

Integrated value of all operations performed on file systems except for read and write operations. Normally, such operations except for read and write operations include file system control requests or requests for information on device characteristics and status.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).system(1).systemFileControlOperations(8)

systemFileDataOperations Get:Y Set:--

The number of times requests for read and write operations were sent to the file system device. File control operations are not included there.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).system(1).systemFileDataOperations(9)

systemFileReadBytes Get:Y Set:--

The total number of bytes transferred through all read operations performed on file systems on the computer. The value is in bytes.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).system(1).systemFileReadBytes(10)

systemFileReadOperations Get:Y Set:--

Integrated value of all read operations performed on file systems on the computer.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).system(1).systemFileReadOperations(11)

systemFileWriteBytes Get:Y Set:--

The total number of bytes transferred through all write operations performed on file systems on the computer. The value is in bytes.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).system(1).systemFileWriteBytes(12)

systemFileWriteOperations Get:Y Set:--

Integrated value of all write operations performed on file systems on the computer.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).system(1).systemFileWriteOperations(13)

systemFloatingEmulations Get:Y Set:--

The total number of floating emulations by the system.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).system(1).systemFloatingEmulations(14)

systemProcessorQueueLength Get:Y Set:--

Value expressed by the number of threads for the instantaneous length of a processor queue. This counter is always set to 0 as long as monitoring through the thread counter is not performed. All the processors use one processor queue, and threads stand by for processor cycles in that queue. This queue length does not cover the threads being executed at that time. If the processor queue length continues to keep a value greater than 2, normally, it is considered that heavy load is placed on the processors. This value is an instantaneous value, not showing an average value over a certain period of time.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).system(1).systemProcessorQueueLength(15)

systemSystemCalls Get:Y Set:--

The total number of Windows system service routines called. These routines perform basic scheduling and synchronization of all activities carried out on the computer, providing a means of utilizing the non-graphical devices, the memory management function, and the name space management function.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).system(1).systemSystemCalls(16)

systemSystemUpTime Get:Y Set:--

Total time of the computer being operable since its last startup. The time is in 1/100 seconds.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).system(1).systemSystemUpTime(17)

systemTotalInterrupts Get:Y Set:--

The number of hardware interrupts received and processed by the computer. The devices to be interrupted include the system timer, mouse, data communication line, network interface card, and other peripheral devices. This counter roughly indicates how much these devices are used throughout the entire computer.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).system(1).systemTotalInterrupts(18)


memory group (windowsNT 2)

memory group (windowsNT 2)

Format

object-name MIB operation Get: Set:

The content of the object is described here.

Identifiers are shown here.

Example of the MIB operation Get: Set:
Y: The value can be obtained or set through the Get or Set operation.
N: The value cannot be obtained or set through the Get or Set operation. noSuchName is returned.
--: No access permissions. noSuchName is returned.

Objects

memoryAvailableBytes Get:Y Set:--

Size of virtual memory totaling the memory spaces currently listed in the Zeroed, Free, and Standby lists. The Zeroed memory and Free memory refer to an always available memory space. The Zeroed memory is a memory space cleared to zero inside. The Standby memory is a memory space that has been deleted from a process's working set but is still available. Note that this value is an instantaneous value at a certain time, not an average value over a certain period of time. The value is in bytes. The range of values that can be handled correctly is from 0 to 4,294,967,295 (bytes).

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryAvailableBytes(1)

memoryCacheBytes Get:Y Set:--

The number of bytes currently used by the system cache. The system cache is used for buffering data extracted from disk or LAN. The system cache uses a memory space not used by active processes on the computer. The value is in bytes. The range of values that can be handled correctly is from 0 to 4,294,967,295 (bytes).

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryCacheBytes(2)

memoryCacheBytesPeak Get:Y Set:--

The maximum number of bytes used by the system cache. The system cache is used for buffering data extracted from disk or LAN. The system cache uses a memory space not used by active processes on the computer. The value is in bytes. The range of values that can be handled correctly is from 0 to 4,294,967,295 (bytes).

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryCacheBytesPeak(3)

memoryCacheFaults Get:Y Set:--

A cache fault occurs when the cache manager cannot detect a certain page in the file, in the immediate cache. In such cases, the cache manager needs to reference the memory manager and check the location of that page in the memory or on the disk to make it possible to load that page into the immediate cache. The value is expressed by the number of cache faults.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryCacheFaults(4)

memoryCommitLimit Get:Y Set:--

Size (bytes) of virtual memory that can be committed without expanding the paging file size. If the paging file is expandable, this size is called "soft limit". The value is in bytes. The range of values that can be handled correctly is from 0 to 4,294,967,295 (bytes).

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryCommitLimit(5)

memoryCommittedBytes Get:Y Set:--

Size (bytes) of the virtual memory committed (not just reserved). For the committed memory, it must be certain that an auxiliary storage device (that is, a disk) is available or there is no need to use a storage disk device (when the main memory is large enough to hold the size of the committed memory). Note that this value is an instantaneous value at a point time, not an average value over a period of time. The value is in bytes. The range of values that can be handled correctly is from 0 to 4,294,967,295 (bytes).

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryCommittedBytes(6)

memoryDemandZeroFaults Get:Y Set:--

The number of page faults for the page that requires zero filling before fault resolution. If the Zeroed list is not empty, this fault can be resolved by deleting the page from the Zeroed list.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryDemandZeroFaults(7)

memoryFreeSystemPageTableEntries Get:Y Set:--

The number of page table entries not currently used by the system.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryFreeSystemPageTableEntries(8)

memoryPageFaults Get:Y Set:--

The number of page faults that occurred in the processor. When a process references a virtual memory page not existing in the working set in the main memory, a page fault occurs. However, if that page exists in the Standby list (that is, the page already exists in the main memory), a page fault does not occur and the relevant page will not be extracted from the disk. The same applies when a page is being used by another process sharing that page.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryPageFaults(9)

memoryPageReads Get:Y Set:--

The number of disk read operations performed for extracting the virtual memory page required to resolve the page fault. Note that multiple pages might be read at one disk read operation.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryPageReads(10)

memoryPageWrites Get:Y Set:--

Counter that records the number of times a page has been written to disk due to alterations after the page was last extracted. In such cases, multiple pages might be written at one time.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryPageWrites(11)

memoryPagesInput Get:Y Set:--

The number of pages read from disk to resolve memory reference to a page not existing at the time of the reference. This counter value includes paging traffic by the system cache accessing the application's file data. This counter is an important counter to be monitored when paying attention to excessive memory usage rate (that is, thrashing) and excessive paging caused by thrashing. The value is in pages.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryPagesInput(12)

memoryPagesOutput Get:Y Set:--

This counter records the number of times a page altered in the main memory has been written to disk.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryPagesOutput(13)

memoryPages Get:Y Set:--

The total number of pages read from or written to disk to resolve memory reference to a page that did not exist in the memory at the time of the reference. The value is a sum of Pages Input and Pages Output. This counter value includes paging traffic by the system cache accessing the application's file data. This counter is the main counter to be used for monitoring the existence of excessive memory usage rate (that is, thrashing) and excessive paging caused by thrashing. The value is in pages.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryPages(14)

memoryPoolNonpagedAllocs Get:Y Set:--

The number of calls made to allocate a space to the system's nonpaged pool. The nonpaged pool is one of the system memory areas, and when the specified task is executed, each component of the OS secures a certain space in this area. Pages in the nonpaged pool cannot be paged out into the paging file, but they continue to exist in the main memory as long as they are allocated there.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryPoolNonpagedAllocs(15)

memoryPoolNonpagedBytes Get:Y Set:--

The number of bytes in the nonpaged pool. The nonpaged pool is one of the system memory areas, and when the specified task is executed, each component of the OS secures a certain space in this area. Pages in the nonpaged pool cannot be paged out into the paging file, but they continue to exist in the main memory as long as they are allocated there. The value is in bytes. The range of values that can be handled correctly is from 0 to 4,294,967,295 (bytes).

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryPoolNonpagedBytes(16)

memoryPoolPagedAllocs Get:Y Set:--

The number of calls made to allocate a space to the system's paged pool. The paged pool is one of the system memory areas, and when the specified task is executed, each component of the OS secures a certain space in this area. If the system does not access pages in the paged pool for a certain period of time, the pages can be paged out into the paging file.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryPoolPagedAllocs(17)

memoryPoolPagedBytes Get:Y Set:--

The number of bytes in the paged pool. The paged pool is one of the system memory areas, and when the specified task is executed, each component of the OS secures a certain space in this area. If the system does not access pages in the paged pool for a period of time, the pages can be paged out into the paging file. The value is in bytes. The range of values that can be handled correctly is from 0 to 4,294,967,295 (bytes).

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryPoolPagedBytes(18)

memoryPoolPagedResidentBytes Get:Y Set:--

A sum of Frame Bytes and Datagram Bytes. This value is the total number of bytes transferred from the network through protocol transfer (transmission/reception), but covers only the number of bytes transferred by frame (that is, by packet). The value is in bytes. The range of values that can be handled correctly is from 0 to 4,294,967,295 (bytes).

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryPoolPagedResidentBytes(19)

memorySystemCacheResidentBytes Get:Y Set:--

The number of resident bytes in the current global disk cache. The value is in bytes. The range of values that can be handled correctly is from 0 to 4,294,967,295 (bytes).

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memorySystemCasheResidentBytes(20)

memorySystemCodeResidentBytes Get:Y Set:--

The number of bytes of System Code Total Bytes that are currently resident in the core memory. These bytes are a pageable executive's code working set. In addition to these bytes, nonpaged Kernel code up to 300000 bytes exists. The value is in bytes. The range of values that can be handled correctly is from 0 to 4,294,967,295 (bytes).

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memorySystemCodeResidentBytes(21)

memorySystemCodeTotalBytes Get:Y Set:--

The number of bytes of pageable pages in ntoskrnl.exe, hal.dll, and the boot drivers and file systems loaded by ntldr or osloader. The value is in bytes. The range of values that can be handled correctly is from 0 to 4,294,967,295 (bytes).

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memorySystemCodeTotalBytes(22)

memoryDriverResidentBytes Get:Y Set:--

The number of bytes of System Driver Total Bytes that are currently resident in the core memory. These bytes are a pageable driver's code working set. In addition to these bytes, nonpaged driver code up to 700000 bytes exists. The value is in bytes. The range of values that can be handled correctly is from 0 to 4,294,967,295 (bytes).

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryDriverResidentBytes(23)

memoryDriverTotalBytes Get:Y Set:--

The number of bytes of pageable pages in all other loaded device drivers. The value is in bytes. The range of values that can be handled correctly is from 0 to 4,294,967,295 (bytes).

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryDriverTotalBytes(24)

memoryTransitionFaults Get:Y Set:--

The number of page faults resolved by transition, that is, by recovering the pages being written to disk, at the time a page fault occurs. Such pages are recovered without access to disk.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryTransitionFaults(25)

memoryWriteCopies Get:Y Set:--

Virtual address space used by the selected image having this protection. Write Copy protection is set for sharing memory for reading, but prohibiting writing to memory. For memory reading, processes can all share the same memory. However, when some shared process needs read and write access to this shared memory, a copy of that memory is created for that process. The value is expressed by the number of page faults.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryWriteCopies(26)


process group (windowsNT 3)

process group (windowsNT 3)

Format

object-name MIB operation Get: Set:

The content of the object is described here.

Identifiers are shown here.

Example of the MIB operation Get: Set:
Y: The value can be obtained or set through the Get or Set operation.
N: The value cannot be obtained or set through the Get or Set operation. noSuchName is returned.
--: No access permissions. noSuchName is returned.

Objects

processNum Get:Y Set:--

The number of executing processes.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).process(3).processNum(1)

processTable

Process information table.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).process(3).processTable(2)

processEntry

Each entry is identified by the process index number.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).process(3).processTable(2).processEntry(1)

processIndex Get:Y Set:--

Process index number.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).process(3).processTable(2).processEntry(1).processIndex(1)

processPrivilegedTime Get:Y Set:--

Processor time consumed in privileged mode in a non-idle thread. Windows Service Layer, Executive routines, and Kernel operate in privileged mode. The device drivers for most devices, except graphics adapters and printers, also operate in privileged mode. Unlike certain existing OS platforms, in addition to conventional protection methods such as user mode and privileged mode, Windows adopts the concept of process boundaries to protect subsystems. Subsystem processes in this concept provide additional protection other than conventional methods. Therefore, certain processing performed by Windows on behalf of an application might be performed also in other subsystem processes in addition to the Privileged Time of the user process. The time is in 1/100 seconds.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).process(3).processTable(2).processEntry(1).processPrivilegedTime(2)

processProcessorTime Get:Y Set:--

Value expressing the time spent by a certain processor to execute non-idle threads. This value is considered the time spent for execution of useful tasks. Every processor is assigned an idle thread in an idle process, and that idle thread consumes the unproductive processor cycles that are not utilized by any other threads. The time is in 1/100 seconds.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).process(3).processTable(2).processEntry(1).processProcessorTime(3)

processUserTime Get:Y Set:--

Processor time consumed in user mode in a non-idle thread. Application code and subsystem code all operate in user mode. Graphics engine, graphics device drivers, printer device drivers, and window managers also operate in user mode. Codes operating in user mode do not cause damage to Windows Executive, Kernel, or device drivers. Unlike certain existing OS platforms, in addition to conventional protection methods such as user mode and privileged mode, Windows adopts the concept of process boundaries to protect subsystems. Subsystem processes in this concept provide additional protection other than conventional methods. So, certain processing performed by Windows on behalf of an application might be performed also in other subsystem processes in addition to the Privileged Time of the user process. The time is in 1/100 seconds.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).process(3).processTable(2).processEntry(1).processUserTime(4)

processElapsedTime Get:Y Set:--

Total elapsed execution time of the process. The time is in 1/100 seconds.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).process(3).processTable(2).processEntry(1).processElapsedTime(5)

processIDProcess Get:Y Set:--

A unique identifier of the process. Because this number is reused, the identifier used for a certain process at a certain time is valid until that process ends.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).process(3).processTable(2).processEntry(1).processIDProcess(6)

processPageFaults Get:Y Set:--

The number of page faults that occurred in the processor. When a process references a virtual memory page not existing in the working set in the main memory, a page fault occurs. However, if that page exists in the Standby list (that is, the page already exists in the main memory), a page fault does not occur and the relevant page will not be extracted from the disk. The same applies when a page is being used by another process sharing that page.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).process(3).processTable(2).processEntry(1).processPageFault(7)

processPageFileBytes Get:Y Set:--

The current number of bytes the relevant process has used in the paging file. The paging file is used for storing pages that exist in the memory used by the relevant process and are not included in other files. The paging file is shared among all processes, and if the paging file runs out of space, other processes cannot allocate a memory space anymore. The value is in bytes.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).process(3).processTable(2).processEntry(1).processPageFileBytes(8)

processPageFileBytesPeak Get:Y Set:--

The maximum number of bytes the relevant process has used in the paging file. The paging file is used for storing pages that exist in the memory used by the relevant process and are not included in other files. The paging file is shared among all processes, and if the paging file runs out of space, other processes cannot allocate a memory space anymore. The value is in bytes.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).process(3).processTable(2).processEntry(1).processPageFileBytesPeak(9)

processPoolNonpagedBytes Get:Y Set:--

The number of bytes in the nonpaged pool. The nonpaged pool is one of the system memory areas, and when the specified task is executed, each component of the OS secures a certain space in this area. Pages in the nonpaged pool cannot be paged out into the paging file, but they continue to exist in the main memory as long as they are allocated there. The value is in bytes.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).process(3).processTable(2).processEntry(1).processPoolNonpagedBytes(10)

processPoolPagedBytes Get:Y Set:--

The number of bytes in the paged pool. The paged pool is one of the system memory areas, and when the specified task is executed, each component of the OS secures a certain space in this area. If the system does not access pages in the paged pool for a period of time, the pages can be paged out into the paging file. The value is in bytes.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).process(3).processTable(2).processEntry(1).processPoolPagedBytes(11)

processPriorityBase Get:Y Set:--

Current base priority of the process. Execution priority of a thread in a process goes up or down depending on each individual base priority relative to the base priority of the process.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).process(3).processTable(2).processEntry(1).processPriorityBase(12)

processPrivateBytes Get:Y Set:--

The current number of bytes the relevant process cannot share with other processes. The value is in bytes.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).process(3).processTable(2).processEntry(1).processPrivateBytes(13)

processThreadCount Get:Y Set:--

The number of threads currently active in this process. An instruction is the basic unit of execution in a processor and a thread is an object that executes an instruction. Every executing process has at least one thread.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).process(3).processTable(2).processEntry(1).processThreadCount(14)

processVirtualBytes Get:Y Set:--

Current size (the current number of bytes) of the virtual address space used by the process. Using the virtual address space does not always mean using pages on disk or in the main memory. Note that there is a limit to the virtual space, and if the virtual space is over-used, the space for processes to load libraries might run out. The value is in bytes.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).process(3).processTable(2).processEntry(1).processVirtualBytes(15)

processVirtualBytesPeak Get:Y Set:--

The maximum number of bytes of the virtual address space used by the process at any given time. Using the virtual address space does not always mean using pages on disk or in the main memory. Note that there is a limit to the virtual space, and if the virtual space is over-used, the space for processes to load libraries might run out. The value is in bytes.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).process(3).processTable(2).processEntry(1).processVirtualBytesPeak(16)

processWorkingSet Get:Y Set:--

The current number of bytes in the working set of the relevant process. The working set is a group of pages most recently referenced by a thread that belongs to the relevant process. When the size of the free memory space on the computer is greater than the threshold, usable pages are left as is in the process's working set (even when such pages are not being used). However, when the size of the free memory space is smaller than the threshold, pages are removed from the working set. When the removed pages become necessary, they are returned from disk to the working set and placed in the main memory. The value is in bytes.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).process(3).processTable(2).processEntry(1).processWorkingSet(17)

processWorkingSetPeak Get:Y Set:--

The maximum number of bytes existing in the working set of the relevant process at any given time. The working set is a group of pages most recently referenced by a thread that belongs to the relevant process. When the size of the free memory space on the computer is greater than the threshold, usable pages are left as is in the process's working set (even when such pages are not being used). However, when the size of the free memory space is smaller than the threshold, pages are removed from the working set. When the removed pages become necessary, they are returned from disk to the working set and placed in the main memory. The value is in bytes.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).process(3).processTable(2).processEntry(1).processWorkingSetPeak(18)


processor group (windowsNT 4)

processor group (windowsNT 4)

Format

object-name MIB operation Get: Set:

The content of the object is described here.

Identifiers are shown here.

Example of the MIB operation Get: Set:
Y: The value can be obtained or set through the Get or Set operation.
N: The value cannot be obtained or set through the Get or Set operation. noSuchName is returned.
--: No access permissions. noSuchName is returned.

Objects

processorNum Get:Y Set:--

The number of processor information entries.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).processor(4).processorNum(1)

processorTable

Processor information table.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).processor(4).processorTable(2)

processorEntry

Each entry is identified by the processor index number.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).processor(4).processorTable(2).processorEntry(1)

processorIndex Get:Y Set:--

Processor index number.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).processor(4).processorTable(2).processorEntry(1).processorIndex(1)

processorPrivilegedTime Get:Y Set:--

Processor time consumed in privileged mode in a non-idle thread. Windows Service Layer, Executive routines, and Kernel operate in privileged mode. The device drivers for most devices, except graphics adapters and printers, also operate in privileged mode. Unlike certain existing OS platforms, in addition to conventional protection methods such as user mode and privileged mode, Windows adopts the concept of process boundaries to protect subsystems. Subsystem processes in this concept provide additional protection other than conventional methods. Therefore, certain processing performed by Windows on behalf of an application might be performed also in other subsystem processes in addition to the Privileged Time of the user process. The time is in 1/100 seconds.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).processor(4).processorTable(2).processorEntry(1).processorPrivilegedTime(2)

processorTime Get:Y Set:--

Value expressing the time spent by each individual processor to execute idle process threads (idle threads). Every processor is assigned an idle thread in an idle process, and that idle thread consumes the unproductive processor cycles that are not utilized by any other threads. The time is in 1/100 seconds.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).processor(4).processorTable(2).processorEntry(1).processorTime(3)

processorUserTime Get:Y Set:--

Processor time consumed in user mode in a non-idle thread. Application code and subsystem code all operate in user mode. Graphics engine, graphics device drivers, printer device drivers, and window managers also operate in user mode. Codes operating in user mode do not cause damage to Windows Executive, Kernel, or device drivers. Unlike certain existing OS platforms, in addition to conventional protection methods such as user mode and privileged mode, Windows adopts the concept of process boundaries to protect subsystems. Subsystem processes in this concept provide additional protection other than conventional methods. Therefore, certain processing performed by Windows on behalf of an application might be performed also in other subsystem processes in addition to the Privileged Time of the user process. The time is in 1/100 seconds.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).processor(4).processorTable(2).processorEntry(1).processorUserTime(4)

processorInterrupts Get:Y Set:--

The number of device interrupts experienced by the processor. A device interrupts the processor when the device has completed a task or when the device needs to process some response. Normal thread execution is suspended during interrupts. When an interrupt occurs, the processor might switch to another higher priority thread. For example, clock interrupts are one of the basic interrupts that frequently and periodically occur.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).processor(4).processorTable(2).processorEntry(1).processorInterrupts(5)


domainConf group (windowsNT 5)

domainConf group (windowsNT 5)

Format

object-name MIB operation Get: Set:

The content of the object is described here.

Identifiers are shown here.

Example of the MIB operation Get: Set:
Y: The value can be obtained or set through the Get or Set operation.
N: The value cannot be obtained or set through the Get or Set operation. noSuchName is returned.
--: No access permissions. noSuchName is returned.

Objects

domainConfDomainName Get:Y Set:--

Computer domain name.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).domainConf(5).domainConfDomainName(1)

domainConfDomainController Get:Y Set:--

Computer domain controller name.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).domainConf(5).domainConfDomainController(2)

domainConfSystemRole Get:Y Set:--

Role of the computer in the domain.

  • Primary domain controller (1)
  • Backup domain controller (2)
  • Server (3)
  • Workstation (4)

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).domainConf(5).domainConfSystemRole(3)

domainConfTrustedDomainTable

Information table of the computer's trust relationship.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).domainConf(5).domainConfTrustedDomainTable (4)

domainConfTrustedDomainEntry

Each entry is identified by the trusted domain index value.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).domainConf(5).domainConfTrustedDomainTable(4).domainConfTrustedDomainEntry(1)

domainConfTrustedDomainIndex Get:Y Set:--

Trusted domain index.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).domainConf(5).domainConfTrustedDomainTable(4).domainConfTrustedDomainEntry(1).domainConfTrustedDomainIndezx(1)

domainConfTrustedDomainName Get:Y Set:--

Trusted domain name.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).domainConf(5).domainConfTrustedDomainTable(4).domainConfTrustedDomainEntry(1).domainConfTrustedDomainName(2)

domainConfDomainMemberTable

Domain configuration information table.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).domainConf(5).domainConfDomainMemberTable(5)

domainConfDomainMemberEntry

Each entry is identified by the domain member computer index.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).domainConf(5).domainConfDomainMemberTable(5).domainConfDomainMemberEntry(1)

domainConfDomainMemberIndex Get:Y Set:--

Domain member computer index.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).domainConf(5).domainConfDomainMemberTable(5).domainConfDomainMemberEntry(1).domainConfDomainMemberIndex(1)

domainConfDomainMemberName Get:Y Set:--

Domain member computer name.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).domainConf(5).domainConfDomainMemberTable(5).domainConfDomainMemberEntry(1).domainConfDomainMemberName(2)

domainConfChangeItem Get:Y Set:--

Domain configuration change information.

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).domainConf(5).domainConfChangeItem(6)

domainConfSererID Get:Y Set:--

Whether the SMS service is provided.

  • SMS server (1)
  • Others (0)

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).domainConf(5).domainConfServerID(7)


Appendixes

Organization of the appendixes
A Glossary


Glossary

Appendix A. Glossary

agent
Process running on a node or on the node to send SNMP traps, in response to SNMP requests.
agent system
Device on which the SNMP agent runs. An agent system executes an SNMP request from a manager. The types of agent system include a personal computer, workstation, host, gateway (router), terminal server, hub, and bridge.
alarm MIB
One of Hitachi's business-specific MIBs that expresses the threshold monitoring conditions or the operating status. A sub-manager has this MIB.
business-specific MIB
MIB developed by each individual vendor for its own product. Each vendor registers its private MIB under the company object identifier tree.
community name
Password for access to the MIB value of the agent.
consolidated MIB
One of Hitachi's business-specific MIBs that consolidates the information of TCP connections within the management range at the time a sub-manager receives a request from the manager.
Critical
State in which a critical fault exists in the object and normal operation is either suspended or significantly obstructed. This is the most important warning level.
definition file for filtering traps
File for defining the filtering conditions used by the trap's filtering function.
definition file for issuing traps
File for defining the issuing conditions for traps that change the status of the interfacing MIB.
definition file for monitoring thresholds
File for defining target items to be monitored by the threshold monitoring function.
definition file for node management
Option file for determining the management range of a sub-manager.
event
Notification transmitted from the manager software or SNMP agent when at least one of the following occurs:
  • An information message or error occurs.
  • The MIB value exceeds the threshold.
  • The status of an object is changed.
  • The setting of an object is changed.
filter MIB
One of Hitachi's business-specific MIBs that expresses the trap's filtering conditions and its operating status. A sub-manager has this MIB.
gateway
Object with multiple network interfaces. The gateway is physically connected to one or more networks. The gateway transfers packets between these networks based on the network addresses.
The term "gateway" often refers to a system that transfers a transfer protocol, route, and other messages. An example of the gateway is a mail gateway.
hierarchy management
Function to place a sub-manager between a manager and agent. This function helps in selecting information gathered into a manager system and minimizes the number of packets transferred on the network for management.
hiextmib
Process of the extensible agent to monitor the system resources for Hitachi's business-specific MIB.
host
Computer system (connected to a network) that provides general computing services. For example, hosts include main frames, minicomputers, personal computers, and workstations. When a host has multiple interfaces and performs routing beyond the network, the host can also function as a gateway.
hpextmib
Process of the extensible agent to monitor the system resources for HP's business-specific MIB.
independent extensible trap
Extensible trap issued by a sub-manager.
instance
Specific value for an MIB object in the agent database. Like system code, for example, an MIB object might have only one instance for one agent system. However, like the interface status of each interface on a system, an MIB object might have multiple instances for one agent system.
IP address
The IP (Internet Protocol) address identifies a node on the network using the TCP/IP protocol. Each individual node on the network using the TCP/IP protocol needs to have its unique IP address.
The IP address can be divided into two fields.
Network field
Shows a specific physical network on the Internet.
Host field
Shows a specific node connected to the physical network.
manager
Network management function to monitor and control agent systems.
manager system
Manages a network by monitoring and controlling agent systems.
master agent
The SNMP agent that functions as a proxy for extensible agents. A master agent directly receives SNMP requests from a manager and distributes them to extensible agents according to their MIBs. There are two types of master agents: an SNMP service and SNMP EMANATE agent.
In contrast, SNMP agents for which a master agent is set as a proxy are called sub-agents.
MIB
Abbreviation for Management Information Base.
Group of objects (management information) accessible through the network management protocol.
MIB module
A file for defining all MIB objects under sub-trees. The base module is based on the Internet Standard MIB-II module defined by RFC1213: Management Information Base of Network Management of TCP/IP internets:MIB-II.
MIB object
Management information of a specific type or class.
An MIB object is defined by using the Internet Standard management information structure.
MIB tree
Hierarchical relationships of multiple MIB objects expressed in tree form. This tree is used to illustrate the organization of MIB objects.
Minor
State indicating a fault of relatively lower importance and no problem with normal use of the object.
network
Group of data communication devices interconnected with each other through the common communication medium.
Each network node belongs to a network with a network address that enables routing between networks. Nodes belonging to the same network generally use a common physical medium for intercommunication.
NNM
Abbreviation for Network Node Manager.
Management base program for performing integrated management of the TCP/IP network.
Normal
State in which the object functions normally. There is no phenomenon indicating the existence of a fault, and no alarm in the object. The object can communicate through an application and responds properly.
object
An object expresses a group of logical or physical entities or a group of physical entities existing in the resources or network. For example, a network, computer, interface, or process is an object.
object ID
Name used for uniquely identifying an MIB object. An object ID is based on an object arranged in the MIB tree.
polling
Requests periodically sent from a management station to a managed node to collect node information.
relay extensible trap
Extensible trap relayed by a sub-manager.
routing
Action for determining the path (route) packets take to reach the destination on the network.
seed file
Option file to be defined for extending a sub-manager's management target subnet.
SNMP
Abbreviation for Simple Network Management Protocol.
The management protocol used to search for network information from nodes. Defined by RFC1157.
SNMP EMANATE agent
Agent program that provides the SNMP agent function on the system in which NNM is installed. This agent has the master agent function to become a proxy for sub-agents.
sub-agent
The SNMP agent for which the master agent acts as a proxy. A sub-agent communicates with a manager through the master agent, not directly communicating with a manager. Extensible agent is sub-agent.
sub-manager
Combined with the manager, manages the network hierarchically. A sub-manager manages the network efficiently by selecting information concentrated on the manager system or reducing the number of packets for management.
SSO
Abbreviation for JP1/SNMP System Observer.
Manager program to perform resource collection and process monitoring in conjunction with the SNMP agent.
sysObjectID
Used for administrative purposes so as to uniquely identify the type of agent software running on the hardware of a specific vendor. A sysObjectID is different from other MIB objects. When a query is sent for a sysObjectID, the object identifier describing the relevant product is returned.
A sysObjectID contains both hardware information and software information, and changes according to the types of hardware and agent software. Some vendors have a different sysObjectID for each version of their agents.
threshold
Threshold of event occurrence that can be set for each MIB object. When the MIB value exceeds the threshold, an event occurs.
trap
Information to be sent from SNMP-supported nodes to managers without being explicitly requested. Traps notify managers of changes such as restarting that occur in these nodes.


Index

[A][B][C][D][E][F][G][H][I][J][M][N][O][P][R][S][T]

(A)
agent
agent
agent system
alarm MIB
authFail
(B)
business-specific MIB
business-specific MIB objects
(C)
cluster
commands
community name
community name
computerSystem
computerSystem64
consolidated MIB
Critical
(D)
data collection command when an error occurs
definition file for filtering traps
definition file for issuing traps
definition file for monitoring thresholds
definition file for node management
domainConf
(E)
environment setup
environment setup and customization
esareg
event
extensible agent
extensible agent: environment setup
extensible agent: operating status
(F)
file system
fileSystem
fileSystem
fileSystem64
fileSystemFiles
filter MIB
(G)
gateway
(H)
hierarchy management
hiextmib
hiextmib
hismsmib
Hitachi's business-specific MIB objects
host
hpextmib
hpextmib
HP's business-specific MIB objects
(I)
icmp
ieee8023Mac
independent extensible trap
instance
IP address
issuing SNMP trap to specified node
issuing system trap to specified node
(J)
jp1esalog.bat
(M)
management information base
manager
manager
manager system
master agent
memory
MIB
MIB
MIB module
MIB module
MIB object
MIB object
MIB tree
Minor
(N)
network
network management
network management: overview
NNM
NNM
NO_FILECOUNT
Normal
(O)
object
object ID
object identifier
opConf
(P)
polling
port number
process
processes
processor
(R)
relay extensible trap
routing
(S)
seed file
SNMP
snmpcheck
snmpdConf
SNMP EMANATE agent
snmptrap
specifying settings for network
SSO
SSO
sub-agent
sub-manager
swapSpace
sysObjectID
sysObjectID
systemtrap
(T)
threshold
trap