Version 11 Extensible SNMP Agent - 目次

Version 11

Extensible SNMP Agent

目　　次

前書き
はじめに

1.　ネットワーク管理とは
1.1　マネージャとエージェント
1.2　MIBとは
1.3　MIBの構成
1.4　sysObjectID

2.　拡張エージェント機能
2.1　拡張エージェントの特徴

3.　環境設定とカスタマイズ
3.1　拡張エージェントの環境設定

4.　コマンドリファレンス
文法の記述で使用する記号
systemtrap（指定ノードに対してシステム・トラップを発行する）
snmptrap（指定ノードに対してSNMP・トラップを発行する）
snmpcheck（拡張エージェントの稼働状況を表示する）
jp1esalog.bat（障害発生時における資料採取コマンド）
esareg（サブエージェントのレジストリを再登録する）

5.　企業固有MIBオブジェクト
5.1　HP企業固有オブジェクト
HP企業固有MIBオブジェクト一覧
computerSystemグループ(general 1)
fileSystemグループ(general 2)
processesグループ(general 4)
clusterグループ(general 5)
ieee8023Macグループ(interface 1)
icmpグループ(nm 7)
trapグループ(snmp 1)
snmpdConfグループ(snmp 2)
authFailグループ(snmp 4)
5.2　日立企業固有MIBオブジェクト
日立企業固有MIBオブジェクト一覧
opConfグループ(cometOP 10)
swapSpaceグループ(hiux 7)
fileSystem64グループ(hiux 21)
computerSystem64グループ(hiux 24)
systemグループ(windowsNT 1)
memoryグループ(windowsNT 2)
processグループ(windowsNT 3)
processorグループ(windowsNT 4)
domainConfグループ(windowsNT 5)

付録
付録A　用語解説

索引

[他社商品名称に関する表示]

Copyright (C) 2015, Hitachi, Ltd.
Copyright (C) 2015, Hitachi Solutions, Ltd.


前書き

■ 対象製品

P-2A42-8BBL JP1/Extensible SNMP Agent for Windows 11-00

■ 商標類

HPは，米国Hewlett-Packard Companyの会社名です。
Microsoftは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
Windowsは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
Windows Serverは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

■ 発行

2016年 1月 (第1版)

■ 著作権

Copyright (C) 2015, Hitachi, Ltd.
Copyright (C) 2015, Hitachi Solutions, Ltd.

[目次][前へ][次へ]


他社商品名称に関する表示

Version 11　Extensible SNMP Agent

■ 商標類

HPは，米国Hewlett-Packard Companyの会社名です。
Microsoftは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
Windowsは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
Windows Serverは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

[目次]


はじめに

このマニュアルでの表記

このマニュアルでは，製品名称を，略称を使って表記しています。正式名称と，このマニュアルでの表記を次の表に示します。

正式名称 | このマニュアルでの表記
JP1/Extensible SNMP Agent for Windows | ESA
JP1/SNMP System Observer | SSO
JP1/Cm2/Network Node Manager Starter Edition Enterprise | NNM
JP1/Cm2/Network Node Manager Starter Edition 250
HP OpenView Network Node Manager
Microsoft(R) Windows Server(R) 2008 R2 Standard | Windows
Microsoft(R) Windows Server(R) 2008 R2 Enterprise
Microsoft(R) Windows Server(R) 2008 R2 Datacenter
Microsoft(R) Windows Server(R) 2012 Standard
Microsoft(R) Windows Server(R) 2012 Datacenter
Microsoft(R) Windows Server(R) 2012 R2 Standard
Microsoft(R) Windows Server(R) 2012 R2 Datacenter

このマニュアルで使用する英略語

英略語 | 正式名称
ASN.1 | Abstract Syntax Notation One
CPU | Central Processing Unit
EUC | Extended UNIX Code
IAB | Internet Activities Board
ICMP | Internet Control Message Protocol
ID | Identification
IP | Internet Protocol
JIS | Japanese Industrial Standard code
LAN | Local Area Network
MIB | Management Information Base
OS | Operating System
SJIS | Shift JIS
SMI | Structure of Management Information
SNMP | Simple Network Management Protocol
TCP | Transmission Control Protocol
TCP/IP | Transmission Control Protocol/Internet Protocol
UDP | User Datagram Protocol

KB（キロバイト）などの単位表記について

1KB（キロバイト），1MB（メガバイト），1GB（ギガバイト），1TB（テラバイト）はそれぞれ1,024バイト，1,0242バイト，1,0243バイト，1,0244バイトです。


ネットワーク管理とは

1.　ネットワーク管理とは

SNMPによるネットワーク管理の概要について説明します。

＜この章の構成＞
1.1　マネージャとエージェント
1.2　MIBとは
1.3　MIBの構成
1.4　sysObjectID


マネージャとエージェント

1.1　マネージャとエージェント

＜この節の構成＞
(1)　SNMPで管理できるネットワーク
(2)　SNMPを使用したマネージャとエージェントの通信

(1)　SNMPで管理できるネットワーク

SNMPで管理できるネットワークは，一つまたは複数のマネージャ・システム（ネットワーク管理ステーション）と，エージェント・システム（ネットワーク構成要素）の集合から構成されています。

  • マネージャ・システムは，エージェント・システムを監視したり制御したりしてネットワークを管理します。このように，ネットワーク管理を実現するものをマネージャと呼びます。
  • エージェント・システムは，SNMPエージェントが動作する機器です。エージェント・システムは，マネージャからのSNMPリクエストを実行します。エージェント・システムには，ホスト，ゲートウェイ（ルータ），ターミナル・サーバ，ハブ，ブリッジなどがあります。

マネージャとエージェントは同一システム上で動作できます。

(2)　SNMPを使用したマネージャとエージェントの通信

SNMPは，マネージャとエージェントとの間で管理情報（MIB）をやり取りします。SNMPでは，次に示す機能を実現しています。

  • マネージャは，エージェントから管理情報を収集できます（Get）。マネージャはエージェントに管理情報の要求を送信し，エージェントは要求された管理情報を含む応答を返信します。
  • マネージャは，エージェント上の管理情報を変更できます（Set）。
  • エージェントは，マネージャからの要求がなくてもマネージャに管理情報を送信できます。この操作をトラップと呼びます。トラップは，エージェント・システム上で発生する再起動などの変化をマネージャに通知するメッセージです。エージェントは，どのマネージャ・システムにトラップを送信するかを，ユーザが設定したトラップのあて先から識別します。

エージェント上の管理情報に対する要求には，コミュニティ名が付いています。マネージャは，コミュニティ名を使用してエージェント上の管理情報にアクセスします。


MIBとは

1.2　MIBとは

MIB
エージェント上の管理情報は，管理情報ベース（MIB：Management Information Base）と呼ばれています。MIBは，物理的には独立したデータベースではなく，仮想的なデータベースです。MIBは構成情報とステータス値を含んでいて，これらの値は通常マネージャ・システムで利用できます。

MIBオブジェクト
システム記述やインタフェース・ステータスのように，ある特定のタイプまたはクラスの管理情報のことをMIBオブジェクトと呼びます。また，MIBオブジェクトの特定の値のことをインスタンスと呼びます。MIBオブジェクトは，例えば，システム記述のように，ある一つのエージェント・システムについて一つのインスタンスしか持たない場合もあります。また，システム上の各インタフェースのインタフェース・ステータスのように，ある一つのエージェント・システムについて複数のインスタンスを持つ場合もあります。
MIBオブジェクトは，インターネット標準の管理情報構造（SMI：Structure of Management Information）を使用して定義され，エージェント・システム上の仮想的なデータ保存域になります。SMIは，RFC1155：Structure and Identification of Management Information for TCP/IP-based Internetsによって定義され，RFC1212：Concise MIB Definitionsによって修正が加えられています。RFC1155と1212の両方で，SNMPベースのネットワーク管理用の管理情報の構造を定義しています。

MIBモジュール
複数のMIBは，MIBモジュールにまとめられます。MIBモジュールは，すべてのMIBオブジェクトをサブツリーの下に定義するファイルです。基盤となるモジュールは，RFC1213：Management Information Base of Network Management of TCP/IP internets:MIB-Ⅱによって定義されたインターネット標準のMIB-Ⅱモジュールです。インターネット標準のMIB-Ⅱオブジェクトのほかに，多数のハードウェア・ベンダが自社製品用にMIBを拡張しています。様々なハードウェア・ベンダが定義したこれらのMIBのことを，このヘルプでは企業固有MIBと呼んでいます。
このほか，LAN Ethernet方式のリンク，リモートLAN監視，ブリッジ，ハブ，ルータなどの多数の標準MIBが開発中です。これらの作成中の標準MIBは，ベンダ各社，大学，および規格制定組織などの協同作業に基づいています。その目的は，各企業固有MIBから共通の管理情報を構成し，マルチベンダの機器全体を通して一貫した管理情報へのアクセスを実現することです。

関連項目
拡張エージェント機能
企業固有MIBオブジェクト


MIBの構成

1.3　MIBの構成

MIBオブジェクトは，概念的には階層的なツリー構造（木構造）に体系化されています。ツリーの中の各ブランチ（枝）は，ユニークな名称と数値の識別子を持ちます。ツリーの中間ブランチには，相互に関連し合ったMIBオブジェクトをまとめる役割があります。ツリーのリーフ（葉）は，実際のMIBオブジェクトを表現します。サブツリーは，特定の中間ブランチの下のブランチとリーフから構成されるグループ全体を表現するために使用されます。次に，ツリー構造の例を示します。

MIBオブジェクトは，ツリー中の位置によってユニークに識別（指定）されます。完全な形のオブジェクト識別子は，ツリー階層を通したパスに沿って，最上位（iso）からリーフまでの各ブランチの識別子で構成されます。オブジェクト識別子は，パスに沿った各ブランチの識別子をドット（.）で区切る表記法（ドット表記法）で表現します。例を次に示します。

ドット表記法の例
  • mib-2サブツリーの場合
    オブジェクト識別子：iso.org.dod.internet.mgmt.mib-2
    数値識別子：1.3.6.1.2.1

  • sysObjectIDの場合
    オブジェクト識別子：iso.org.dod.internet.mgmt.mib-2.system.sysObjectID
    数値識別子：1.3.6.1.2.1.1.2

インスタンスが一つしかないMIBオブジェクトのインスタンス識別子は0です。複数のインスタンスを持つMIBオブジェクトのインスタンス識別子は1以上です。これらのMIBオブジェクト表記は，ASN.1（Abstract Syntax Notation One）の中で定義された標準記法に従っています。ASN.1標準記法の規定は，MIBのテンプレートと考えることができます。

オブジェクト識別子の重複を避けるため，ツリーの各ブランチは指定された機関を通じて登録（定義）されなければなりません。例えば，IAB（Internet Activities Board）は，mib-2サブツリーの下に登録されているインターネット標準MIB-Ⅱを含むinternetサブツリーに対する権限を持っています。また，IABは企業固有のサブツリーに対する権限をベンダに与えます。企業固有のMIBオブジェクトは，その企業のために指定された権限の下に登録されます。例を次に示します。

企業固有MIBの例
  • 日立の場合
    企業固有MIBの登録先：1.3.6.1.4.1.116
    取得している権限：enterprises.hitachiサブツリーに対する権限

  • HPの場合
    企業固有MIBの登録先：1.3.6.1.4.1.11
    取得している権限：enterprises.hpサブツリーに対する権限


sysObjectID

1.4　sysObjectID

sysObjectIDは，ESAおよび関連製品では重要なMIBオブジェクトです。ここでは，sysObjectIDとは何か，ESAおよび関連製品でsysObjectIDをどのように使用するかを説明します。

ESAおよび関連製品では，sysObjectIDを次のように利用しています。

  • ベンダ（ハードウェアのメーカ名）を判別します。
  • SNMPエージェントのソース（ハードウェア上で動作しているエージェント・ソフトウェアのタイプ）を判別します。
  • IPトポロジの動作を決定します。エージェントのsysObjectIDは，エージェントのノードのタイプについて，例えばゲートウェイ，ブリッジ，ホストなどの管理情報を与えます。
  • マネージャのマップに表示されるシンボル・タイプを決定します。マップ上に新しく発見されたノードに，ブリッジ，ゲートウェイ，ハブなどのシンボルを付けるときに使用します。
  • イベント・ソースを確認します。sysObjectIDは，すべてのトラップに付けられます。イベントを設定する場合にsysObjectIDを使用します。マネージャのイベント設定ダイアログ・ボックスで参照する企業IDは，一般的にトラップを生成したエージェントのsysObjectIDと同じです。

sysObjectIDは，インターネット標準MIB-Ⅱモジュールにiso.org.dod.internet.mgmt.mib-2.system.sysObjectID（1.3.6.1.2.1.1.2）として登録されています。sysObjectIDは，ある特定のベンダのハードウェア上で実行されているエージェント・ソフトウェアのタイプをユニークに識別するために，管理上の目的で使用されます。sysObjectIDは，その他のMIBオブジェクトと異なっています。sysObjectIDについて照会すると，その製品を表すオブジェクト識別子が戻されます。

sysObjectIDはハードウェア情報とソフトウェア情報の両方を含んでいて，ハードウェアおよびエージェント・ソフトウェアのタイプに従って変化します。一部のベンダは，自社のエージェントのバージョンごとにすべて異なるsysObjectIDを持っています。


拡張エージェント機能

2.　拡張エージェント機能

拡張エージェントの特徴について説明します。

＜この章の構成＞
2.1　拡張エージェントの特徴


拡張エージェントの特徴

2.1　拡張エージェントの特徴

拡張エージェント（ESA）は，Windowsシステムが標準に備えているSNMPサービスの機能に加えて，Windowsのシステムリソースを監視する機能を提供します。拡張エージェントが監視するシステムリソースには，システム，メモリ，プロセス，プロセッサなどがあります。

システム：
CPU使用時間，ファイル・システムへのI/O回数・転送バイト数，ハードウェア割り込み回数

メモリ：
仮想メモリサイズ，システムキャッシュサイズ，フレーム転送サイズ，ページテーブルエントリ数，ページング回数，ページフォルト回数

プロセス：
実行中プロセス数，プロセスの経過時間，消費したプロセッサ時間，ページフォールト回数，ページングファイルサイズ，基本優先度，スレッド数，仮想アドレススペース，ワーキングセットサイズ

プロセッサ：
プロセッサ時間，デバイス割り込み回数

など

関連項目
HP企業固有MIBオブジェクト一覧
日立企業固有MIBオブジェクト一覧


環境設定とカスタマイズ

3.　環境設定とカスタマイズ

拡張エージェントの環境設定およびカスタマイズの方法について説明します。

＜この章の構成＞
3.1　拡張エージェントの環境設定


拡張エージェントの環境設定

3.1　拡張エージェントの環境設定

●TCP/IP，SNMPサービスの組み込み

エージェントの動作環境として，WindowsにTCP/IPとSNMPサービスが組み込まれていることが前提となります。これらの環境が組み込まれていない場合は，Windowsのヘルプの記述に従って，組み込んでください。

●ネットワークの設定

拡張エージェント・システムおよび通信するIPノードの名前を設定します。設定方法として，次の３種類の方法があります。ご使用のネットワーク環境に合わせて設定してください。

  • ファイル（%SystemRoot%\system32\drivers\etc\hosts）に設定します。
  • ドメインネームシステム（DNS）に設定します。
  • Windows Internet Naming Service（WINS）に設定します。
●インストールディレクトリのセキュリティ設定

この製品のインストール先ディレクトリのセキュリティ設定で，Everyoneを削除またはフルコントロールを拒否に設定する場合は，次のように設定してください。

Windowsサービス「SNMP Service」のログオンに設定しているアカウント（ローカルシステムアカウントの場合はSYSTEMアカウント）を，該当するディレクトリのセキュリティに「読み取りと実行」を許可して設定してください。

●コミュニティ名の設定

マネージャと通信するために，マネージャ－エージェント間でGet用のコミュニティ名を一致させる必要があります。エージェント側のGet用のコミュニティ名は，次の方法で設定します。

  1. コントロールパネルから管理ツールを開き，サービスを選択します。
  2. サービス一覧から"SNMP Service"を選択しプロパティを開きます。
  3. セキュリティの構成で，コミュニティ名をREAD_ONLY（読み取りのみ）以上の権利で設定します。

また，この製品をマネージャ・システムで監視する場合，トラップあて先の自動設定を有効とするためには，SNMPサービスのセキュリティの構成にSet用コミュニティ名"snmpd"が必要となります。必要な場合はSNMPサービスのセキュリティの構成で，コミュニティ名"snmpd"をREAD_WRITE（読み取り，書き込み）またはREAD_CREATE（読み取り，作成）の権利で設定してください。

●"SNMP Service" サービスアカウントの設定

"SNMP Service"サービスのアカウントはローカルシステムアカウントまたはAdministratorsグループに属するアカウントを指定してください。デフォルトの設定はローカルシステムアカウントです。Administratorsグループに属するアカウントの設定方法を次に示します。

  1. コントロールパネルから管理ツールを開き，サービスを選択します。
  2. サービス一覧から"SNMP Service"を選択しプロパティを開きます。
  3. サービスのアカウントにAdministratorsグループに属するユーザ名を設定します。
  4. 設定したユーザ名に対するパスワードを設定します。
●システム環境変数の設定

拡張エージェントのデフォルト設定では，HP拡張MIB fileSystemFiles（ファイル・システム中の総ファイル数）のMIB値を取得できません。次のシステム環境変数を設定することで，取得可能となります。システム環境変数設定後は，システムを再起動してください。

環境変数名
NO_FILECOUNT

変数値
OFF

ただし，この設定によって拡張エージェントがfileSystemグループMIBに対する取得要求を受信するごとにシステム全体のファイル数をカウントするようになるため，システム全体のレスポンスが著しく劣化する場合があります。また，fileSystemFilesは，SSOのリソース収集機能では使用されません。したがって，デフォルト設定（NO_FILECOUNT=ON）がSSOのリソース収集機能に影響を与えることはありません。特に必要のない場合は，デフォルト設定による運用をお勧めします。


コマンドリファレンス

4.　コマンドリファレンス

拡張エージェントが提供するコマンドについて説明します。

＜この章の構成＞
文法の記述で使用する記号
systemtrap（指定ノードに対してシステム・トラップを発行する）
snmptrap（指定ノードに対してSNMP・トラップを発行する）
snmpcheck（拡張エージェントの稼働状況を表示する）
jp1esalog.bat（障害発生時における資料採取コマンド）
esareg（サブエージェントのレジストリを再登録する）


文法の記述で使用する記号

文法の記述で使用する記号

文法の記述で使用する記号を次の表に示します。

記号 | 意味
［］ | この記号で囲まれている項目は省略できます。
| | この記号で区切られた項目のうちの一つを選択できます。
｛｝ | この記号で囲まれている複数の項目のうちから一つを選択します。
... | この記号の直前に示された項目を繰り返し複数個指定できます。
＿ | ｛｝で囲まれた複数の項目のうち，システムがとる標準値を示します。


systemtrap（指定ノードに対してシステム・トラップを発行する）

systemtrap（指定ノードに対してシステム・トラップを発行する）

形式

＜オブジェクトの追加・変更＞
階層指定：
systemtrap [-S|-E]　-s　[-c]
            あて先　発行元　管理情報名[[＠シンボル・タイプ ],...]
            状態　["ユーザ・テキスト"　...]

＜オブジェクトの削除＞
systemtrap [-S|-E]　-d
            あて先　発行元　管理情報名[[＠シンボル・タイプ ],...]

機能

マネージャのノード・サブマップに対してユーザ・シンボルの追加，削除，およびユーザ・シンボルの状態変更を指示します。

オプション

-S

シンボル・タイプ，管理情報名およびユーザ・テキストをSJISコードに変換した値を指定ノードに対して発行します。

-s，-cまたは-dオプションより前に指定してください。

-Eオプションを同時に指定しないでください。

-E

シンボル・タイプ，管理情報名およびユーザ・テキストをEUCコードに変換した値を指定ノードに対して発行します。

ほかは-Sオプションと同じです。

-s

ノード・サブマップへのユーザ・シンボルの生成およびユーザ・シンボルの状態を変更します。

-d

ノード・サブマップからユーザ・シンボルを削除します。

削除するユーザ・シンボル（name1,name2,...パラメタ）は-s，-cで指定した時と同じ値とし，階層の中間を指定した場合は，そのシンボルを含むすべての下位シンボルが削除されます。

＜例＞
生成時の指定：systemtrap -s netmd01 netmd01 name_1,name_2,name_3 Nor
削除時の指定：systemtrap -d netmd01 netmd01 name_1,name_2,name_3
              systemtrap -d netmd01 netmd01 name_1,name_2
              systemtrap -d netmd01 netmd01 name_1

-c

発行元が示すIPアドレスが該当するグメント・サブマップ上のノード・シンボルのステータス・ソースを複合ステータスにします。

引数

あて先

トラップの通知先ノード名をIPアドレスまたはホスト名で指定します。省略時は""を指定します。省略時にはSNMPエージェントのトラップのあて先，あるいはシステムトラップ送信先定義ファイル（%インストール先ディレクトリ%\conf\systemtrap_node.conf）に定義されたトラップのあて先を仮定します。

発行元

発行元ノードのIPアドレスまたはホスト名を指定する。省略時は""を指定します。省略時には自ノードを仮定します。

管理情報名[[＠シンボル・タイプ],...]

管理情報の階層を指定します。管理情報がNNMでシンボル表示された場合に「1階層（ノード・サブマップ），2階層，...」となります。階層数は，最大10階層までとします。

シンボル・タイプを指定する場合は追加・変更の場合だけ有効となり，管理情報名の次に「＠」で区切って指定します。

また，各パラメタは，

  • 状態，ユーザ・テキストは最下位のオブジェクトに対しての値。
  • -sの指定は最上位のオブジェクトに対して有効。

となります。

なお，管理情報名およびシンボル・タイプに「,」または「＠」を含む指定はできません。

状態

ユーザ・シンボルの状態を指定します。指定できる文字列およびその意味を次に示します。

文字列 | 意 味
Unk | 認識不能
Nor | 正常域／動作中
War | 注意域
Min | 警戒域
Maj | 重要警戒域
Cri | 危険域／停止中
Tes | テスト中
Res | 制限動作中

ユーザ・テキスト

ユーザ任意のテキストを指定します。一つのテキストの最大長は255バイトで，最大10個まで指定できます。

注意
引数に日本語を指定する場合はマネージャとエージェントの言語環境を同一にしないと文字化けすることがあります。

システムトラップ送信先定義ファイル
システムトラップ送信先定義ファイルとは，トラップの送信先を定義したファイルで，systemtrapコマンドのあて先に""を指定した場合に読み込まれます。
なお，systemtrapコマンドの送信先指定の優先順位は，
コマンドに指定したあて先＞systemtrap_node.confに指定したあて先＞snmpサービスのトラップあて先となります。
ファイル・フォーマットは，
  • "ホスト名またはIPアドレス"を1行として記述します。
  • 行の先頭に「#」を指定した場合はコメント行とします。
＜システムトラップ送信先定義ファイルの定義例＞
#systemtrap_node
netmd01
netmrx09
172.16.45.8
172.16.45.9

階層定義ファイル
階層定義ファイルとは，任意のキー文字列に対して管理情報の階層とシンボル・タイプを定義した任意のファイルのことです。systemtrapコマンドの-c，-sまたは-dオプションの"管理情報名[[＠シンボル・タイプ],...]"パラメタの代わりに"-f　階層定義ファイル名，キー文字列"を指定した場合に読み込まれ，「キー文字列」に対応したファイルの設定値を"管理情報名[[＠シンボル・タイプ],...]"パラメタに展開してトラップを送信します。
ファイル・フォーマットは，
  • "キー文字列　管理情報名[＠シンボル・タイプ],管理情報名[＠シンボル・タイプ],..."を1行として記述します。
  • 行の先頭に「#」を指定した場合はコメント行とします。
  • 1行中の各パラメタの区切り文字は任意個数のスペースまたはタブします。
  • 複数定義した場合は最初に定義したものを反映します。
＜階層定義ファイルの定義例＞
#systemtrap_kaisou
obj_1　1-A@typeA,2-B,3-C@typeB
obj_2　1-A@typeA,2-B,3-D@typeB
obj_3　1-A@typeA,2-E,3-F@typeC
この階層定義ファイル（c:\tmp\key.conf）の定義例を使用したsystemtrapコマンドの指定方法を次に示します。

systemtrap -s -f netmd01 netmd01 c:\tmp\key.conf,obj_1 Nor
systemtrap -s -f netmd01 netmd01 c:\tmp\key.conf,obj_2 War
systemtrap -s -f netmd01 netmd01 c:\tmp\key.conf,obj_3 Cri


snmptrap（指定ノードに対してSNMP・トラップを発行する）

snmptrap（指定ノードに対してSNMP・トラップを発行する）

形式

snmptrap [-d]　[-p　ポート番号]　[-c　コミュニティ名]
        ノード名　企業ID　agentアドレス　標準トラップ番号　拡張トラップ番号
        タイムスタンプ　[オブジェクト識別子　値のシンタクス　値...]

機能

指定ノードに対してSNMP・トラップを発行します。

オプション

-d

SNMPパケットを16進数表示，およびデコーディングされたASN.1形式で標準出力に出力します。

-p

送信するマネージャのポート番号を指定します。省略時は162です。

-c　コミュニティ名

コミュニティ名を指定します。省略するとpublicを仮定します。

引数

ノード

IPアドレスまたはホスト名を指定します。

企業ID

sysObjectIDを指定します。形式はA.B.C.D...です。ただしA，B，C，Dは10進数表示のサブ識別子です。形式A.B.C.D...ではオブジェクト識別子の先頭が「1.3.6.1.2.1」であれば，「1.3.6.1.2.1」は省略できます。null文字列（""）はSNMPエージェントのsysObjectIDになります。

agentアドレス

IPアドレス，またはホスト名を指定します。null文字列（""）を指定した場合は，コマンドを実行したホストのIPアドレスが指定されます。

なお，snmptrapコマンドで発行するトラップメッセージ中のエージェントアドレスに，特定のIPアドレスを使用したい場合は，「agentアドレス」にそのIPアドレスを指定してください。

標準トラップ番号

標準トラップ番号0～6を整数で指定します。拡張トラップを発行する場合は6を指定します。

拡張トラップ番号

拡張トラップ番号を32ビットの整数で指定します。

タイムスタンプ

時刻を0以上の整数で指定します。null文字列（""）を指定した場合は，コマンド開始からトラップ送信直前までのtimeticks（1/100秒）が設定されます。

オブジェクト識別子

snmptrapは，「オブジェクト識別子，値のシンタクス，値」を1組とした引数を複数指定できます。一度に指定できる引数の数は一つの値の長さを256バイトとした場合，最大20個を目安としてください。オブジェクト識別子の形式はA.B.C.D…です。A，B，C，Dは10進数表示のサブ識別子です。形式A.B.C.D…ではオブジェクト識別子の先頭が「1.3.6.1.2.1」であれば，「1.3.6.1.2.1」は省略できます。

値のシンタクス

値のシンタクスは次の中から選択します。

integer（-231～231-1），octetstring，objectidentifier（形式がA.B.C.D…で，オブジェクト識別子の先頭が「1.3.6.1.2.1」であれば，「1.3.6.1.2.1」は省略できます），null（このあとの「値」に何を設定しても無視されます），ipaddress，counter（0～4294967295），gauge，timeticks，opaque。それぞれの記述の詳細についてはRFC1155を参照してください。

また，octetstringの特別なケースとして，octetstringhex（00～FFの16進数列指定，例：01FF），octetstringoctal（000～377の8進数列指定，例：001377），octetstringascii（ASCIIコード文字列指定），octetstringsjis（SJISコード文字列指定），opaqueの特別なケースとして，opaquehex（00～FFの16進数列指定，例：01FF），opaqueoctal（000～377の8進数列指定，例：001377），opaqueascii（ASCIIコード文字列指定），opaquesjis（SJISコード文字列指定）が指定できます。

値

値のシンタクスに対して正しい値を指定します。


snmpcheck（拡張エージェントの稼働状況を表示する）

snmpcheck（拡張エージェントの稼働状況を表示する）

形式

snmpcheck

機能

拡張エージェント機能を構成するプロセスの稼働状況を標準出力に表示します。

オプション

なし。

表示形式

次のように，プロセス名，実行状態，プロセスIDをタブ区切りで表示します。ただし，実行状態がnot runningの場合，プロセスIDは表示しません。

プロセス名　<TAB>　実行状態　<TAB>　pid=プロセスID

●表示するプロセス名
hiextmib，hpextmib，およびhismsmib

●表示する実行状態
プロセス稼働時：running
プロセス停止時：not running

実行例

snmpcheckコマンドの実行例を次に示します。

C:\>snmpcheck                  ←コマンド投入
hiextmib  running  pid=2380    ←標準出力
hpextmib  running  pid=3132
hismsmib  not running
C:\>

終了コード

snmpcheckコマンドの終了コードを次に示します。

コード | 説明
0 | 正常終了。
1 | 実行エラー。エラーメッセージを出力する。

注意事項

hismsmibプロセスの稼働状況は常にnot runnningとなります。


jp1esalog.bat（障害発生時における資料採取コマンド）

jp1esalog.bat（障害発生時における資料採取コマンド）

形式

jp1esalog.bat　[-d　出力先ディレクトリ名]

説明

ESAの障害発生時に障害調査用資料を採取します。このコマンドはWindowsシステムで動作するESAだけが提供しています。

デフォルトでは，%TEMP%\jp1logの配下に資料が採取されます。

以前に採取された同フォルダ配下のファイルはすべて消去されます。

また，採取した資料などのファイルの出力先ディレクトリはオプションで指定できます。デフォルトの出力先や編集された出力先よりもオプションで指定した出力先を優先します。

オプション

-d　出力先ディレクトリ名

このコマンドで作成されたファイルの出力先を指定します。

ディレクトリ名にはスペース，「"（ダブルクォート）」，「*（アスタリスク）」，「|（パイプ文字）」，「<，>（小なり，大なり）」，「?（クエスチョンマーク）」，「,（カンマ）」，「＼（バックスラッシュ）」，「=（イコール）」および「#（シャープ）」は記載できません。

カスタマイズ

このコマンドはバッチファイルであり，必要に応じて次の項目をカスタマイズできます。

  • デフォルトの出力先を変更したい場合
    次に示す行の出力ファイル名を編集してください。

set OUTDIR=%TEMP%\jp1log
  • ESAのインストールパスが標準のインストールパスと異なっている場合
    次に示す行のインストールパスを編集してください。

set INST_DIR_EA=%SystemDrive%\win32app\HITACHI\Cm2

採取資料一覧

採取する障害調査用の資料の一覧を次に示します。

分類 | 採取条件 | 取得資料
基本情報※1 | 共通 | 環境構成図（OS，IPアドレス，インターフェース数，各端末の製品構成とバージョン）
 |  | 障害発生経緯のメモ（詳細な発生日時，OS，ホスト名，IPアドレス，実施した操作，どのような現象になったのか）
 |  | イベントログファイル
 |  | タスクマネージャのプロセス一覧画面
 |  | システム情報
OSの情報 | 共通 | 採取ファイル | %SystemRoot%\system32\driver\etcフォルダ配下のファイル （hostsファイル，servicesファイルなど）
 |  |  | drwtsn32.log およびuser.dmp※2
 |  | コマンド実行結果 | hostname
 |  |  | set
 |  |  | netstat -a
 |  |  | netstat -an
 |  |  | netstat -ano
 |  |  | net start
 |  |  | ipconfig /all
 |  |  | レジストリ情報 | （HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\配下）
 |  |  |  | （HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\配下）
 |  |  |  | （HKEY_LOCAL_MACHINE\SOFTWARE\HITACHI\配下）
 |  |  |  | （HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Perflib\配下）
ESAの情報 | 共通 | 採取ファイル | ESAのインストールフォルダ\confフォルダ配下のファイル
 |  |  | ESAのインストールフォルダ\logフォルダ配下のファイル
 |  |  | ESAのインストールフォルダ\tmpフォルダ配下のファイル
 |  |  | ESAのインストールフォルダ\readme\esa\Version.txt
 |  |  | ESAのインストールフォルダ\readme\esa\ProductInfo.txt
 |  |  | 日立総合インストーラのログファイル
 |  | コマンド実行結果 | snmpcheck
 |  |  | esareg -view
 |  |  | インストールディレクトリ配下リスト | dir /S ESAのインストールフォルダ

注※1
手動で採取していただく資料です。
注※2
存在しない場合は，取得できません。

終了コード

jp1esalog.batコマンドの終了コードを次に示します。

終了コード | 意味
0 | 資料採取完了

注意事項

  • このコマンドは，ESAのプロセスが起動している状態で実行してください。ただし，異常終了したESAのプロセスについては再起動しないでこのコマンドを実行してください。
  • このコマンドは，可能な限り障害が発生した直後に実行してください。
  • ファイルの保存中にディスクが満杯状態になると，データが正しく保存できません。このコマンドを実行する場合はディスクに十分な空きがあることを確認してから実行してください。


esareg（サブエージェントのレジストリを再登録する）

esareg（サブエージェントのレジストリを再登録する）

形式

esareg {-view | -update}

機能

全サブエージェントのレジストリ登録状態の参照，または，ESAの全サブエージェントについて優先順位を修正するためのレジストリ更新(再登録)を実行します。

オプション

-view

全サブエージェントのレジストリ登録状態を標準出力します。サブエージェントの標準出力の順序は，登録された順(優先順位の低い順)で表しています。
なお，本オプション機能ではレジストリは参照するのみであり，登録状態の更新は一切実施しません。

-update

ESAの全サブエージェントについて，優先順位を修正するためのレジストリ更新(再登録)を実行します。このとき，ESA以外のサブエージェントについては登録状態の更新は実施しませんが，ESAのサブエージェントとの相対的な登録順序は変化することがあります。

実行権限

Administrators権限

格納先ディレクトリ

%本製品のインストールディレクトリ%\bin

ログファイル

本コマンドのログ情報は下記ログファイルに出力されます。

%本製品のインストールディレクトリ%\log\esareg.log
このログファイルサイズの上限は2メガバイト固定です。ファイルサイズが上限を超えると，ファイル名に「.old」を付加し，それまでのログファイルは退避されます。その際，すでに存在する「.old」付きで退避されたログファイルは破棄されます。

終了コード

esaregコマンドの終了コードを次に示します。

コード | 説明
0 | 正常終了
1 | レジストリ更新処理のユーザによるキャンセル
2 | コマンドオプション不正
3 | 前提ソフトウェア("SNMP Service"サービスまたはESA)がインストールされていない
4 | 前提OS不正
5 | "SNMP Service"サービスが停止されていない
7 | レジストリ参照/更新の前処理失敗
8 | レジストリ参照/更新処理失敗

注意事項

  • -updateオプションは，"SNMP Service"サービスが停止している状態でのみ実行可能です。
  • 本コマンドは，ESAがインストールされている環境でのみ実行可能です。
  • 本コマンドは，ESAを含む各種プログラムのインストール作業中には実行しないでください。


企業固有MIBオブジェクト

5.　企業固有MIBオブジェクト

企業固有MIBオブジェクトについて説明します。

＜この章の構成＞
5.1　HP企業固有オブジェクト
5.2　日立企業固有MIBオブジェクト


HP企業固有オブジェクト

5.1　HP企業固有オブジェクト

＜この節の構成＞
HP企業固有MIBオブジェクト一覧
computerSystemグループ(general 1)
fileSystemグループ(general 2)
processesグループ(general 4)
clusterグループ(general 5)
ieee8023Macグループ(interface 1)
icmpグループ(nm 7)
trapグループ(snmp 1)
snmpdConfグループ(snmp 2)
authFailグループ(snmp 4)


HP企業固有MIBオブジェクト一覧

HP企業固有MIBオブジェクト一覧

HP企業固有MIBオブジェクトの構成を，次に示します。

enterprises(1)
  └ hp(11)
     └ nm(2)
        ├ system(3)
        │  └ general(1)
        │      ├ computerSystem(1)
        │      ├ fileSystem(2)
        │      ├ processes(4)
        │      └ cluster(5)
        ├ interface(4)
        │   └ieee8023Mac(1)
        ├ icmp(7)
        └ snmp(13)
            ├ trap(1)
            ├ snmpdConf(2)
            └ authFail(4)


computerSystemグループ(general 1)

computerSystemグループ(general 1)

形式

オブジェクト名　　MIBオペレーション　Get：　Set：

オブジェクトの内容を示します。

識別子を示します。

（MIBオペレーション　Get：　Set：　の凡例）
○：GetまたはSetオペレーションで値を取得またはセットできます。
N：GetまたはSetオペレーションで値を取得またはセットできません。noSuchNameで応答します。
－：アクセス権限がありません。noSuchNameで応答します。

オブジェクト

computerSystemUpTime　　Get：○　Set：－

システムが起動してからの経過時間です。単位は1/100秒です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).computerSystem(1).computerSystemUpTime(1)

computerSystemUsers　　Get：N　Set：－

システムにログインしているユーザ数です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).computerSystem(1).computerSystemUsers(2)

computerSystemAvgJobs1　　Get：N　Set：－

過去1分間の平均ジョブ数*100です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).computerSystem(1).computerSystemAvgJobs1(3)

computerSystemAvgJobs5　　Get：N　Set：－

過去5分間の平均ジョブ数*100です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).computerSystem(1).computerSystemAvgJobs5(4)

computerSystemAvgJobs15　　Get：N　Set：－

過去15分間の平均ジョブ数*100です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).computerSystem(1).computerSystemAvgJobs15(5)

computerSystemMaxProc　　Get：N　Set：－

システムで許される最大プロセス数です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).computerSystem(1).computerSystemMaxProc(6)

computerSystemFreeMemory　　Get：○　Set：－

空きメモリの大きさです。単位はキロバイトです。正しく扱える値の範囲は，0～2,147,483,647（キロバイト）です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).computerSystem(1).computerSystemFreeMemory(7)

computerSystemPhysMemory　　Get：○　Set：－

物理メモリの大きさです。単位はキロバイトです。正しく扱える値の範囲は，0～2,147,483,647（キロバイト）です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).computerSystem(1).computerSystemPhysMemory(8)

computerSystemMaxUserMem　　Get：○　Set：－

ユーザメモリの最大の大きさです。単位はキロバイトです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).computerSystem(1).computerSystemMaxUserMem(9)

computerSystemSwapConfig　　Get：○　Set：－

コミットチャージの総計（制限値）です。単位はバイトです。正しく扱える値の範囲は0～2,147,483,647（バイト）です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).computerSystem(1).computerSystemSwapConfig(10)

computerSystemEnabledSwap　　Get：○　Set：－

computerSystemSwapConfigと同じです。単位はバイトです。正しく扱える値の範囲は0～2,147,483,647（バイト）です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).computerSystem(1).computerSystemEnableSwap(11)

computerSystemFreeSwap　　Get：○　Set：－

コミットチャージの空きサイズです。単位はバイトです。正しく扱える値の範囲は0～2,147,483,647（バイト）です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).computerSystem(1).computerSystemFreeSwap(12)

computerSystemUserCPU　　Get：N　Set：－

nice値21以上で，ユーザ・モードで実行されたCPU時間です。単位は秒です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).computerSystem(1).computerSystemUserCPU(13)

computerSystemSysCPU　　Get：○　Set：－

特権モードで実行されたCPU時間です。単位は秒です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).computerSystem(1).computerSystemSysCPU(14)

computerSystemIdleCPU　　Get：○　Set：－

CPUがアイドル状態の時間です。単位は秒です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).computerSystem(1).computerSystemIdleCPU(15)

computerSystemNiceCPU　　Get：N　Set：－

nice値20以下で，ユーザ・モードで実行されたCPU時間です。単位は秒です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).computerSystem(1).computerSystemNiceCPU(16)


fileSystemグループ(general 2)

fileSystemグループ(general 2)

形式

オブジェクト名　　MIBオペレーション　Get：　Set：

オブジェクトの内容を示します。

識別子を示します。

（MIBオペレーション　Get：　Set：　の凡例）
○：GetまたはSetオペレーションで値を取得またはセットできます。
N：GetまたはSetオペレーションで値を取得またはセットできません。noSuchNameで応答します。
－：アクセス権限がありません。noSuchNameで応答します。

オブジェクト

fileSystemMounted　　Get：○　Set：－

マウントされているファイル・システムの数です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).fileSystem(2).fileSystemMounted(1)

fileSystemTable

ファイル・システム情報テーブルです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).fileSystem(2).fileSystemTable(2)

fileSystemEntry

ファイル・システム情報テーブル・エントリです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).fileSystem(2).fileSystemTable(2).fileSystemEntry(1)

fileSystemID1　　Get：○　Set：－

ファイル・システムID1（0から始まるファイル・システムの通し番号）です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).fileSystem(2).fileSystemTable(2).fileSystemEntry(1).fileSystemID1(1)

fileSystemID2　　Get：○　Set：－

ファイル・システムID2（0固定）です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).fileSystem(2).fileSystemTable(2).fileSystemEntry(1).fileSystemID2(2)

fileSystemName　　Get：○　Set：－

マウントされたファイル・システム名（FAT，NTFSなど）です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).fileSystem(2).fileSystemTable(2).fileSystemEntry(1).fileSystemName(3)

fileSystemBlock　　Get：○　Set：－

ファイル・システムの総容量です。単位はキロバイトです。正しく扱える値の範囲は0～2,147,483,647（キロバイト）です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).fileSystem(2).fileSystemTable(2).fileSystemEntry(1).fileSystemBlock(4)

fileSystemBfree　　Get：○　Set：－

ファイル・システムの空き容量です。単位はキロバイトです。正しく扱える値の範囲は0～2,147,483,647（キロバイト）です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).fileSystem(2).fileSystemTable(2).fileSystemEntry(1).fileSystemBfree(5)

fileSystemBavail　　Get：○　Set：－

fileSystemBfreeと同じです。単位はキロバイトです。正しく扱える値の範囲は0～2,147,483,647（キロバイト）です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).fileSystem(2).fileSystemTable(2).fileSystemEntry(1).fileSystemBavail(6)

fileSystemBsize　　Get：N　Set：－

基本ファイル・システムのブロックサイズです。単位はキロバイトです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).fileSystem(2).fileSystemTable(2).fileSystemEntry(1).fileSystemBsize(7)

fileSystemFiles　　Get：N※　Set：－

ファイル・システム中のファイル総数です。

注※
環境変数の設定によって取得可能となります。設定方法および注意事項については拡張エージェントの環境設定の「システム環境変数の設定」を参照してください。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).fileSystem(2).fileSystemTable(2).fileSystemEntry(1).fileSystemFiles(8)

fileSystemFfree　　Get：N　Set：－

ファイル・システム中のフリーファイル総数です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).fileSystem(2).fileSystemTable(2).fileSystemEntry(1).fileSystemFfree(9)

fileSystemDir　　Get：○　Set：－

ファイル・システムのpathです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).fileSystem(2).fileSystemTable(2).fileSystemEntry(1).fileSystemDir(10)


processesグループ(general 4)

processesグループ(general 4)

形式

オブジェクト名　　MIBオペレーション　Get：　Set：

オブジェクトの内容を示します。

識別子を示します。

（MIBオペレーション　Get：　Set：　の凡例）
○：GetまたはSetオペレーションで値を取得またはセットできます。
N：GetまたはSetオペレーションで値を取得またはセットできません。noSuchNameで応答します。
－：アクセス権限がありません。noSuchNameで応答します。

オブジェクト

processNum　　Get：○　Set：－

実行中のプロセス数です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processNum(1)

processTable

実行中のプロセス情報テーブルです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2)

processEntry

実行中のプロセス情報テーブル・エントリです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1)

processPID　　Get：○　Set：－

プロセスIDです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processPID(1)

processIdx　　Get：○　Set：－

プロセス・テーブルのエントリ番号です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processIdx(2)

processUID　　Get：N　Set：－

プロセス・ユーザIDです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processUID(3)

processPPID　　Get：N　Set：－

親プロセスIDです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processPPID(4)

processDsize　　Get：N　Set：－

プロセス・データ・サイズです。単位はページです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processDsize(5)

processTsize　　Get：N　Set：－

プロセス・テキスト・サイズです。単位はページです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processTsize(6)

processSsize　　Get：N　Set：－

プロセス・スタック・サイズです。単位はページです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).prosessSsize(7)

processNice　　Get：N　Set：－

プロセスnice値です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processNice(8)

processMajor　　Get：N　Set：－

プロセス制御端末のメジャー番号です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processMajor(9)

processMinor　　Get：N　Set：－

プロセス制御端末のマイナー番号です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processMinor(10)

processPgrp　　Get：N　Set：－

そのプロセスのプロセス・グループIDです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processPgrp(11)

processPrio　　Get：○　Set：－

プロセスの優先順位です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processPrio(12)

processAddr　　Get：N　Set：－

仮想アドレス空間テーブルへのポインタです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processAddr(13)

processCPU　　Get：N　Set：－

スケジューリングのためのプロセサ利用です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processCPU(14)

processUtime　　Get：○　Set：－

実行に使用されたユーザ時間です。単位は1/100秒です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processUtime(15)

processStime　　Get：○　Set：－

実行に使用されたシステム時間です。単位は1/100秒です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processStime(16)

processStart　　Get：○　Set：－

プロセス開始時間です。単位は1/100秒です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processStart(17)

processFlags　　Get：N　Set：－

プロセスに関係するフラグです。

  • incore(1)
  • sys(2)
  • locked(4)
  • trace(8)
  • trace2(16)

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processFlags(18)

processStatus　　Get：N　Set：－

プロセスの状態です。

  • sleep(1)
  • run(2)
  • stop(3)
  • zombie(4)
  • other(5)
  • idle(6)

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processStatus(19)

processWchan　　Get：N　Set：－

スリープしているアドレスです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processWchan(20)

processProcNum　　Get：N　Set：－

そのプロセスが最後に実行されたプロセサです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processProcNum(21)

processCmd　　Get：○　Set：－

プロセスを実行させたコマンドです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processCmd(22)

processTime　　Get：N　Set：－

インコアでの経過時間です。単位は秒です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processTime(23)

processCPUticks　　Get：N　Set：－

CPU時間のticksです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processCPUticks(24)

processCPUticksTotal　　Get：N　Set：－

プロセスが動作中のticksの総数です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processCPUticksTotal(25)

processFss　　Get：N　Set：－

スケジューラ・グループのFSSグループIDです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processFss(26)

processPctCPU　　Get：N　Set：－

そのプロセスのCPU占有率です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processPctCPU(27)

processRssize　　Get：○　Set：－

インコアにロードされているページ数です。単位はページです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processRssize(28)

processSUID　　Get：N　Set：－

有効ユーザIDです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processSUID(29)

processUname　　Get：N　Set：－

ユーザ名です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processUname(30)

processTTY　　Get：N　Set：－

プロセスのttyです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).processes(4).processTable(2).processEntry(1).processTTY(31)


clusterグループ(general 5)

clusterグループ(general 5)

形式

オブジェクト名　　MIBオペレーション　Get：　Set：

オブジェクトの内容を示します。

識別子を示します。

（MIBオペレーション　Get：　Set：　の凡例）
○：GetまたはSetオペレーションで値を取得またはセットできます。
N：GetまたはSetオペレーションで値を取得またはセットできません。noSuchNameで応答します。
－：アクセス権限がありません。noSuchNameで応答します。

オブジェクト

isClustered　　Get：N　Set：－

マシンがクラスタかどうかの識別です。

  • standalone(1)
  • rootserver(2)
  • cnode(3)

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).cluster(5).isClustered(1)

clusterTable

クラスタノード情報テーブルです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).cluster(5).clusterTable(2)

clusterEntry

クラスタノード情報テーブル・エントリです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).cluster(5).clusterTable(2).clusterEntry(1)

clusterID　　Get：N　Set：－

cnode IDです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).cluster(5).clusterTable(2).clusterEntry(1).clusterID(1)

clusterMachineID　　Get：N　Set：－

cnodeマシンIDです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).cluster(5).clusterTable(2).clusterEntry(1).clusterMachine(2)

clusterType　　Get：N　Set：－

cnodeタイプ（rまたはc）です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).cluster(5).clusterTable(2).clusterEntry(1).clusterType(3)

clusterCnodeName　　Get：N　Set：－

cnode名です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).cluster(5).clusterTable(2).clusterEntry(1).clusterCnodeName(4)

clusterSwapServingCnode　　Get：N　Set：－

スワップ・サービングcnodeです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).cluster(5).clusterTable(2).clusterEntry(1).clusterSwapServingCnode(5)

clusterKcsp　　Get：N　Set：－

KCSPです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).cluster(5).clusterTable(2).clusterEntry(1).clusterKcsp(6)

clusterCnodeAddress　　Get：N　Set：－

cnode IPアドレスです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).cluster(5).clusterTable(2).clusterEntry(1).clusterCnodeAddress(7)

clusterCnodeID　　Get：N　Set：－

マシンのcnode IDです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).system(3).general(1).cluster(5).clusterCnodeID(3)


ieee8023Macグループ(interface 1)

ieee8023Macグループ(interface 1)

形式

オブジェクト名　　MIBオペレーション　Get：　Set：

オブジェクトの内容を示します。

識別子を示します。

（MIBオペレーション　Get：　Set：　の凡例）
○：GetまたはSetオペレーションで値を取得またはセットできます。
N：GetまたはSetオペレーションで値を取得またはセットできません。noSuchNameで応答します。
－：アクセス権限がありません。noSuchNameで応答します。

オブジェクト

ieee8023MacTable

ieee802.3インタフェース情報テーブルです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).interface(4).ieee8023Mac(1).ieee8023MacTable(1)

ieee8023MacEntry

ieee802.3インタフェース情報テーブル・エントリです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).interface(4).ieee8023Mac(1).ieee8023MacTable(1).ieee8023MacEntry(1)

ieee8023MacIndex　　Get：N　Set：－

ifIndexに対応したインタフェース番号です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).interface(4).ieee8023Mac(1).ieee8023MacTable(1).ieee8023MacEntry(1).ieee8023MacIndex(1)

ieee8023MacTransmitted　　Get：N　Set：－

転送に成功したフレーム数です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).interface(4).ieee8023Mac(1).ieee8023MacTable(1).ieee8023MacEntry(1).ieee8023MacTransmitted(2)

ieee8023MacNotTransmitted　　Get：N　Set：－

転送されなかったフレーム数です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).interface(4).ieee8023Mac(1).ieee8023MacTable(1).ieee8023MacEntry(1).ieee8023MacNotTransmitted(3)

ieee8023MacDeferred　　Get：N　Set：－

媒体のbusyによって据え置かれたフレーム数です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).interface(4).ieee8023Mac(1).ieee8023MacTable(1).ieee8023MacEntry(1).ieee8023MacDeferred(4)

ieee8023MacCollisions　　Get：N　Set：－

衝突のために再転送された転送試行回数の総数です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).interface(4).ieee8023Mac(1).ieee8023MacTable(1).ieee8023MacEntry.ieee8023MacCollisions(5)

ieee8023MacSingleCollisions　　Get：N　Set：－

一つの衝突に妨げられ，その後転送に成功した転送試行回数です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).interface(4).ieee8023Mac(1).ieee8023MacTable(1).ieee8023MacEntry(1).ieee8023MacSingleCollisions(6)

ieee8023MacMultipleCollisions　　Get：N　Set：－

2～5回の衝突試行で妨げられ，その後転送に成功した転送試行回数です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).interface(4).ieee8023Mac(1).ieee8023MacTable(1).ieee8023MacEntry(1).ieee8023MacMultipleCollisions(7)

ieee8023MacExcessCollisions　　Get：N　Set：－

15回以上衝突試行で妨げられ，その後転送に成功した転送試行回数です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).interface(4).ieee8023Mac(1).ieee8023MacTable(1).ieee8023MacEntry(1).ieee8023MacExcessCollisions(8)

ieee8023MacLateCollisions　　Get：N　Set：－

割り当てられたチャンネル時間が経過した後，発生した衝突のために失敗した転送試行回数です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).interface(4).ieee8023Mac(1).ieee8023MacTable(1).ieee8023MacEntry(1).ieee8023MacLateCollisions(9)

ieee8023MacCarrierLostErrors　　Get：N　Set：－

転送を試みたとき，carrier senseが失われた回数です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).interface(4).ieee8023Mac(1).ieee8023MacTable(1).ieee8023MacEntry(1).ieee8023MacCarrierLostErrors(10)

ieee8023MacNoHeartBeatErrors　　Get：N　Set：－

転送の後，heart beatが指し示されることのない回数です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).interface(4).ieee8023Mac(1).ieee8023MacTable(1).ieee8023MacEntry(1)ieee8023MacNoHeartBeatErrors(11)

ieee8023MacFramesReceived　　Get：N　Set：－

受信に成功したフレーム数です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).interface(4).ieee8023Mac(1).ieee8023MacTable(1).ieee8023MacEntry(1).ieee8023MacFramesReceived(12)

ieee8023MacUndeliverableFramesReceived　　Get：N　Set：－

フレームが受信されるより速く送信されたとき，ソフトウェア・バッファがオーバーランのため配送されなかった受信フレーム数です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).interface(4).ieee8023Mac(1).ieee8023MacTable(1).ieee8023MacEntry(1).ieee9023MacUndeliverableFramesReceived(13)

ieee8023MacCRCErrors　　Get：N　Set：－

CRCエラー発見回数です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).interface(4).ieee8023Mac(1).ieee8023MacTable(1).ieee8023MacEntry(1).ieee8023MacCRCErrors(14)

ieee8023MacAlignmentErrors　　Get：N　Set：－

misalignedで，誤ったCRC両方の受信フレーム数です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).interface(4).ieee8023Mac(1).ieee8023MacTable(1).ieee8023MacEntry(1).ieee8023MacAlignmentErrors(15)

ieee8023MacResourceErrors　　Get：N　Set：－

リソースが不足したため，失われた受信フレーム数です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).interface(4).ieee8023Mac(1).ieee8023MacTable(1).ieee8023MacEntry(1).ieee8023MacResourceErrors(16)

ieee8023MacControlFieldErrors　　Get：N　Set：－

コントロール・フィールドにエラーがある受信フレーム数です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).interface(4).ieee8023Mac(1).ieee8023MacTable(1).ieee8023MacEntry(1).ieee8023MacControlFieldErrors(17)

ieee8023MacUnknownProtocolErrors　　Get：N　Set：－

タイプ・フィールドまたはサップ・フィールドが誤ったプロトコルを参照したためドロップしたフレーム数です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).interface(4).ieee8023Mac(1).ieee8023MacTable(1).ieee8023MacEntry(1).ieee8023MacUnknownProtocolErrors(18)

ieee8023MacMulticastsAccepted　　Get：N　Set：－

マルチキャスト・アドレスを受け取った数です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).interface(4).ieee8023Mac(1).ieee8023MacTable(1).ieee8023MacEntry(1).ieee8023MacMulticastsAccepted(19)


icmpグループ(nm 7)

icmpグループ(nm 7)

形式

オブジェクト名　　MIBオペレーション　Get：　Set：

オブジェクトの内容を示します。

識別子を示します。

（MIBオペレーション　Get：　Set：　の凡例）
○：GetまたはSetオペレーションで値を取得またはセットできます。
N：GetまたはSetオペレーションで値を取得またはセットできません。noSuchNameで応答します。
－：アクセス権限がありません。noSuchNameで応答します。

オブジェクト

icmpEchoReq　　Get：○　Set：－

ICMPエコー要求に応答するのに掛かる秒数およびエラー情報です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).icmp(7).icmpEchoReq(1)


trapグループ(snmp 1)

trapグループ(snmp 1)

形式

オブジェクト名　　MIBオペレーション　Get：　Set：

オブジェクトの内容を示します。

識別子を示します。

（MIBオペレーション　Get：　Set：　の凡例）
○：GetまたはSetオペレーションで値を取得またはセットできます。
N：GetまたはSetオペレーションで値を取得またはセットできません。noSuchNameで応答します。
－：アクセス権限がありません。noSuchNameで応答します。

オブジェクト

trapDestinationNum　　Get：○　Set：－

トラップあて先数です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).snmp(13).Trap(1).trapDestinationNum(1)

trapDestinationTable

エージェントのトラップあて先アドレス・テーブルです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).snmp(13).trap(1).trapDestinationTable(2)

trapDestinationEntry

トラップあて先アドレス・テーブル・エントリです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).snmp(13).trap(1).trapDestinationTable(2).trapDestinationEntry(1)

trapDestination　　Get：○　Set：○

エージェントのトラップあて先アドレスです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).snmp(13).Trap(1).trapDestinationTable(2).trapDestrinationEntry(1).trapDestination(1)


snmpdConfグループ(snmp 2)

snmpdConfグループ(snmp 2)

形式

オブジェクト名　　MIBオペレーション　Get：　Set：

オブジェクトの内容を示します。

識別子を示します。

（MIBオペレーション　Get：　Set：　の凡例）
○：GetまたはSetオペレーションで値を取得またはセットできます。
N：GetまたはSetオペレーションで値を取得またはセットできません。noSuchNameで応答します。
－：アクセス権限がありません。noSuchNameで応答します。

オブジェクト

snmpdConfRespond　　Get：N　Set：N

true(1)がセットされていると全オブジェクトに応答します。

  • true(1)
  • false(2)

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).snmp(13).snmpdConf(2).snmpdConfRespond(1)

snmpdReConfigure　　Get：N　Set：N

reset(1)がセットされるとエージェントを再構成します。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).snmp(13).snmpdConf(2).snmpReconfigure(2)

snmpdFlag　　Get：○　Set：－

エージェントの能力です。

  • removetrap(1)
  • netwareproxy(2)

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).snmp(13).snmpdConf(2).snmpFlag(3)

snmpdLogMask　　Get：○　Set：○

エージェントのログマスクです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).snmp(13).snmpdConf(2).snmpLogMask(4)

snmpdVersion　　Get：N　Set：－

エージェントのバージョン番号です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).snmp(13).snmpdConf(2).snmpVersion(5)

snmpdStatus　　Get：N　Set：N

デーモンの状態です。

  • up(1)
  • down(2)

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).snmp(13).snmpdConf(2).snmpStatus(6)

snmpdSize　　Get：N　Set：－

プロセスが確保したデータ・セグメントの大きさです。単位はバイトです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).snmp(13).snmpdConf(2).snmpSize(7)

snmpdWhatString　　Get：N　Set：－

デーモンのプロフィール（製品名・バージョン・日付・コピーライト）です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).snmp(13).snmpdConf(2).snmpWhatString(9)


authFailグループ(snmp 4)

authFailグループ(snmp 4)

形式

オブジェクト名　　MIBオペレーション　Get：　Set：

オブジェクトの内容を示します。

識別子を示します。

（MIBオペレーション　Get：　Set：　の凡例）
○：GetまたはSetオペレーションで値を取得またはセットできます。
N：GetまたはSetオペレーションで値を取得またはセットできません。noSuchNameで応答します。
－：アクセス権限がありません。noSuchNameで応答します。

オブジェクト

authFailTable

認証エラー情報テーブルです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).snmp(13).authFail(4).authFailTable(1)

authFailEntry

認証エラー情報テーブル・エントリです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).snmp(13).authFail(4).authFailTable(1).authFailEntry(1)

authIpAddress　　Get：N　Set：－

誤ったコミュニティ名でエージェントに要求を送信したマネージャのIPアドレスです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).snmp(13).authFail(4).authFailTable(1).authFailEntry(1).authIpAddress(1)

authTime　　Get：N　Set：－

エージェントが認証エラーの要求を受け取ってからの経過時間です。単位は1/100秒です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).snmp(13).authFail(4).authFailTable(1).authFailEntry(1).authTime(2)

authCommunityName　　Get：N　Set：－

誤ったコミュニティ名です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hp(11).nm(2).snmp(13).authFail(4).authFailTable(1).authFailEntry(1).authCommunityName(3)


日立企業固有MIBオブジェクト

5.2　日立企業固有MIBオブジェクト

＜この節の構成＞
日立企業固有MIBオブジェクト一覧
opConfグループ(cometOP 10)
swapSpaceグループ(hiux 7)
fileSystem64グループ(hiux 21)
computerSystem64グループ(hiux 24)
systemグループ(windowsNT 1)
memoryグループ(windowsNT 2)
processグループ(windowsNT 3)
processorグループ(windowsNT 4)
domainConfグループ(windowsNT 5)


日立企業固有MIBオブジェクト一覧

日立企業固有MIBオブジェクト一覧

日立企業固有MIBオブジェクトの構成を，次に示します。

enterprises(1)
  └ hitachi(116)
      ├ system(3)
      │  ├ hiuxwe2(5)
      │  │  ├ comet3050rx(1)
      │  │  │   ├ mgr(1)
      │  │  │   ├ smg(2)
      │  │  │   └ agt(3)
      │  │  └ comet3500(2)
      │  │       ├ mgr(1)
      │  │       ├ smg(2)
      │  │       └ agt(3)
      │  ├ solaris(8)
      │  │  └ sparc(1)
      │  │       ├ smg(2)
      │  │       └ agt(3)
      │  ├ hp-ux(9)
      │  │  └ h9000(1)
      │  │       ├ smg(2)
      │  │       └ agt(3)
      │  └ windowsNT(10)
      │      └ x86(1)
      │           ├ mgr(1)
      │           ├ smg(2)
      │           └ agt(3)
      └systemExMib(5)
          └ cometMibs(1)
              ├ subSystems(1)
              │   └ cometOP(2)
              │       └ opConf(10)
              └ systems(2)
                   ├ hiux(1)
                   │  ├ systemInfo(1)
                   │  ├ virtualMemory(2)
                   │  ├ process(3)
                   │  ├ processor(4)
                   │  ├ diskInfo(5)
                   │  ├ swapInfo(6)
                   │  ├ swapSpace(7)
                   │  ├ fileSystem64(21)
                   │  └ computerSystem64(24)
                   └ windowsNT(2)
                       ├ system(1)
                       ├ memory(2)
                       ├ process(3)
                       ├ processor(4)
                       └ domainConf(5)


opConfグループ(cometOP 10)

opConfグループ(cometOP 10)

形式

オブジェクト名　　MIBオペレーション　Get：　Set：

オブジェクトの内容を示します。

識別子を示します。

（MIBオペレーション　Get：　Set：　の凡例）
○：GetまたはSetオペレーションで値を取得またはセットできます。
N：GetまたはSetオペレーションで値を取得またはセットできません。noSuchNameで応答します。
－：アクセス権限がありません。noSuchNameで応答します。

オブジェクト

opConfCharCode　　Get：○　Set：－

Comet/OPがコード変換に使用する文字コードです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).subSystems(1).cometOP(2).opConf(10).opConfCharCode(1)


swapSpaceグループ(hiux 7)

swapSpaceグループ(hiux 7)

形式

オブジェクト名　　MIBオペレーション　Get：　Set：

オブジェクトの内容を示します。

識別子を示します。

（MIBオペレーション　Get：　Set：　の凡例）
○：GetまたはSetオペレーションで値を取得またはセットできます。
N：GetまたはSetオペレーションで値を取得またはセットできません。noSuchNameで応答します。
－：アクセス権限がありません。noSuchNameで応答します。

オブジェクト

swapSpaceConfig　　Get：○　Set：－

コミットチャージの総計（制限値）です。単位はキロバイトです。正しく扱える値の範囲は，0～2,147,483,647（キロバイト）です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).swapSpace(7).swapSpaceConfig(1)

swapSpaceEnable　　Get：○　Set：－

swapSpaceConfigと同じです。単位はキロバイトです。正しく扱える値の範囲は，0～2,147,483,647（キロバイト）です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).swapSpace(7).swapSpaceEnable(2)

swapSpaceFree　　Get：○　Set：－

コミットチャージの空きサイズです。単位はキロバイトです。正しく扱える値の範囲は，0～2,147,483,647（キロバイト）です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).swapSpace(7).swapSpaceFree(3)


fileSystem64グループ(hiux 21)

fileSystem64グループ(hiux 21)

形式

オブジェクト名　　MIBオペレーション　Get：　Set：

オブジェクトの内容を示します。

識別子を示します。

（MIBオペレーション　Get：　Set：　の凡例）
○：GetまたはSetオペレーションで値を取得またはセットできます。ただし，前提OSその他の条件によってNと同等になる場合があります。
N：GetまたはSetオペレーションで値を取得またはセットできません。noSuchNameで応答します。
－：アクセス権限がありません。noSuchNameで応答します。

オブジェクト

fileSystem64Mounted　　Get：○　Set：－

マウントされているファイル・システムの数です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).fileSystem64(21).fileSystem64Mounted(1)

fileSystem64Table

ファイル・システム情報テーブルです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).fileSystem64(21).fileSystem64Table(2)

fileSystem64Entry

ファイル・システム情報テーブル・エントリです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).fileSystem64(21).fileSystem64Table(2).fileSystem64Entry(1)

fileSystem64HighID1　　Get：○　Set：－

ファイル・システムID1（0から始まるファイル・システムの通し番号）のHigh Bitです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).fileSystem64(21).fileSystem64Table(2).fileSystem64Entry(1).fileSystem64HighID1(1)

fileSystem64LowID1　　Get：○　Set：－

ファイル・システムID1（0から始まるファイル・システムの通し番号）のLow Bitです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).fileSystem64(21).fileSystem64Table(2).fileSystem64Entry(1).fileSystem64LowID1(2)

fileSystem64ID2　　Get：○　Set：－

ファイル・システムID2（0固定）です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).fileSystem64(21).fileSystem64Table(2).fileSystem64Entry(1).fileSystem64ID2(3)

fileSystem64Name　　Get：○　Set：－

マウントされたファイル・システム名（FAT，NTFSなど）です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).fileSystem64(21).fileSystem64Table(2).fileSystem64Entry(1).fileSystem64Name(4)

fileSystem64Block　　Get：○　Set：－

ファイル・システムの総容量です。単位はキロバイトです。正しく扱える値の範囲は0～18,014,398,509,481,983（キロバイト）です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).fileSystem64(21).fileSystem64Table(2).fileSystem64Entry(1).fileSystem64Block(5)

fileSystem64Bfree　　Get：○　Set：－

ファイル・システムの空き容量です。単位はキロバイトです。正しく扱える値の範囲は0～18,014,398,509,481,983（キロバイト）です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).fileSystem64(21).fileSystem64Table(2).fileSystem64Entry(1).fileSystem64Bfree(6)

fileSystem64Bavail　　Get：○　Set：－

fileSystem64Bfreeと同じです。単位はキロバイトです。正しく扱える値の範囲は0～18,014,398,509,481,983（キロバイト）です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).fileSystem64(21).fileSystem64Table(2).fileSystem64Entry(1).fileSystem64Bavail(7)

fileSystem64Bsize　　Get：N　Set：－

基本ファイル・システムのブロックサイズです。単位はキロバイトです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).fileSystem64(21).fileSystem64Table(2).fileSystem64Entry(1).fileSystem64Bsize(8)

fileSystem64Files　　Get：N　Set：－

ファイル・システム中のファイル総数です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).fileSystem64(21).fileSystem64Table(2).fileSystem64Entry(1).fileSystem64Files(9)

fileSystem64Ffree　　Get：N　Set：－

ファイル・システム中のフリーファイル総数です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).fileSystem64(21).fileSystem64Table(2).fileSystem64Entry(1).fileSystem64Ffree(10)

fileSystem64Dir　　Get：○　Set：－

ファイル・システムのpathです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).fileSystem64(21).fileSystem64Table(2).fileSystem64Entry(1).fileSystem64Dir(11)


computerSystem64グループ(hiux 24)

computerSystem64グループ(hiux 24)

形式

オブジェクト名　　MIBオペレーション　Get：　Set：

オブジェクトの内容を示します。

識別子を示します。

（MIBオペレーション　Get：　Set：　の凡例）
○：GetまたはSetオペレーションで値を取得またはセットできます。
N：GetまたはSetオペレーションで値を取得またはセットできません。noSuchNameで応答します。
－：アクセス権限がありません。noSuchNameで応答します。

オブジェクト

computerSystem64FreeMemory　　Get：○　Set：－

空きメモリの大きさです。単位はキロバイトです。正しく扱える値の範囲は0～18,014,398,509,481,983（キロバイト）です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).ComputerSystem64(24).computerSystem64FreeMemory(7)

computerSystem64PhysMemory　　Get：○　Set：－

物理メモリの大きさです。単位はキロバイトです。正しく扱える値の範囲は0～18,014,398,509,481,983（キロバイト）です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).ComputerSystem64(24).computerSystem64PhysMemory(8)

computerSystem64SwapConfig　　Get：○　Set：－

コミットチャージの総計（制限値）です。単位はキロバイトです。正しく扱える値の範囲は0～18,014,398,509,481,983（キロバイト）です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).ComputerSystem64(24).computerSystem64SwapConfig(10)

computerSystem64EnabledSwap　　Get：○　Set：－

computerSystem64SwapConfigと同じです。単位はキロバイトです。正しく扱える値の範囲は0～18,014,398,509,481,983（キロバイト）です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).ComputerSystem64(24).computerSystem64EnabledSwap(11)

computerSystem64FreeSwap　　Get：○　Set：－

コミットチャージの空きサイズです。単位はキロバイトです。正しく扱える値の範囲は0～18,014,398,509,481,983（キロバイト）です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).hiux(1).ComputerSystem64(24).computerSystem64FreeSwap(12)


systemグループ(windowsNT 1)

systemグループ(windowsNT 1)

形式

オブジェクト名　　MIBオペレーション　Get：　Set：

オブジェクトの内容を示します。

識別子を示します。

（MIBオペレーション　Get：　Set：　の凡例）
○：GetまたはSetオペレーションで値を取得またはセットできます。
N：GetまたはSetオペレーションで値を取得またはセットできません。noSuchNameで応答します。
－：アクセス権限がありません。noSuchNameで応答します。

オブジェクト

systemTotalPrivilegedTime　　Get：○　Set：－

全プロセサが特権モードで費やしたトータル時間です。Windowsのシステム・サービスを呼び出すと，そのサービスは多くの場合，特権モードで動作し，システムの専用データへのアクセスが可能になります。これらのデータはユーザ・モードで動作するスレッドからはアクセスできません。システムの呼び出しは明示的に行うこともできますし，ページ・フォールトや割り込みの発生時のように暗黙に行われる場合もあります。これまでのある種のオペレーティング・システムと異なり，Windowsは，ユーザ・モードや特権モードといった従来の保護方式に加えて，サブシステムを保護するためのプロセス境界という考え方を採用しています。これらのサブシステムのプロセスは，それら追加の保護を提供します。したがって，アプリケーションに代わってWindowsが行うある種の処理は，アプリケーションでのPrivileged Timeのほかに，別のサブシステムのプロセスでも行われる場合があります。単位は1/100秒です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).system(1).systemTotalPrivilegedTime(1)

systemTotalProcessorTime　　Get：○　Set：－

システム上のすべてのプロセサがアイドル状態のスレッドを実行しているトータル時間を表します。どのプロセサにも，アイドル・プロセス内のアイドル・スレッドが割り当てられ，このスレッドがほかのいかなるスレッドにも使用されない非生産的なプロセサ・サイクルを消費するようになっています。単位は1/100秒です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).system(1).systemTotalProcessorTime(2)

systemTotalUserTime　　Get：○　Set：－

すべてのプロセサがユーザ・モードで費やしたトータル時間です。アプリケーションは，ウィンドウ・マネージャやグラフィックス・エンジンなどのサブシステムと同様，ユーザ・モードで動作します。ユーザ・モードで実行されるコードは，WindowsのExecutive，カーネル，デバイス・ドライバに損傷を与えることはありません。ある種の従来のオペレーティング・システムと異なり，Windowsは，ユーザ・モードや特権モードといった従来の保護方式に加えて，サブシステムを保護するためのプロセス境界という考え方を採用しています。これらのサブシステムのプロセスは，それら固有の保護を提供します。したがって，アプリケーションに代わってWindowsが行うある種の処理は，アプリケーションでのPrivileged Timeのほかに，別のサブシステムのプロセスでも行われる場合があります。単位は1/100秒です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).system(1).systemTotalUserTime(3)

systemAlignmentFixups　　Get：○　Set：－

システムによる配置違反修復のカウント数です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).system(1).systemAlignmentFixups(4)

systemContextSwitches　　Get：○　Set：－

あるスレッドから別のスレッドへの切り替え回数を表します。スレッドの切り替えは，一つのプロセス内で行われる場合と，複数のプロセス間で行われる場合があります。この切り替えは，一方のスレッドが他方のスレッドに情報を要求した場合，あるいはあるスレッドの実行中にそれより優先順位の高い方のスレッドの実行準備が整った場合に行われます。これまでのある種のオペレーティング・システムと異なり，Windowsは，ユーザ・モードや特権モードといった従来の保護方式に加えて，サブシステムを保護するためのプロセス境界という考え方を採用しています。これらのサブシステムのプロセスは，それら追加の保護を提供します。したがって，アプリケーションに代わってWindowsが行うある種の処理は，アプリケーションでのPrivileged Timeのほかに，別のサブシステムのプロセスでも行われる場合があります。サブシステムのプロセスへ切り替えを行うと，アプリケーション・スレッドでContext Switchが実行されます。逆に，アプリケーションに切り替えると，サブシステム・スレッド側でContext Switchが実行されます。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).system(1).systemContextSwitches(5)

systemExceptionDispatch　　Get：○　Set：－

システムによる例外ディスパッチ回数です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).system(1).systemExceptionDispatch(6)

systemFileControlBytes　　Get：○　Set：－

コンピュータ上で行われたファイル・システムに対する読み書き以外の全操作で転送された総バイト数です。これらの操作には，通常，ファイル・システムの制御要求，またはデバイスの特性や状態に関する情報の要求が含まれます。単位はバイトです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).system(1).systemFileControlBytes(7)

systemFileControlOperations　　Get：○　Set：－

ファイル・システムに対する読み書き以外のすべての操作を積算した値です。これらの操作には，通常，ファイル・システムの制御要求，またはデバイスの特性や状態に関する情報の要求が含まれます。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).system(1).systemFileControlOperations(8)

systemFileDataOperations　　Get：○　Set：－

ファイル・システム・デバイスに対して読み取りおよび書き込み操作の要求を出している回数を表します。これには，ファイル制御操作は含まれません。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).system(1).systemFileDataOperations(9)

systemFileReadBytes　　Get：○　Set：－

コンピュータ上で行われたファイル・システムに対する全読み取り操作で転送された総バイト数です。単位はバイトです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).system(1).systemFileReadBytes(10)

systemFileReadOperations　　Get：○　Set：－

コンピュータ上のファイル・システムのすべての読み取り操作を積算した値です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).system(1).systemFileReadOperations(11)

systemFileWriteBytes　　Get：○　Set：－

コンピュータ上で行われたファイル・システムに対する全書き込み操作で転送された総バイト数です。単位はバイトです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).system(1).systemFileWriteBytes(12)

systemFileWriteOperations　　Get：○　Set：－

コンピュータ上のファイル・システムのすべての書き込み操作を積算した値です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).system(1).systemFileWriteOperations(13)

systemFloatingEmulations　　Get：○　Set：－

システムによるフローティング・エミュレーションのトータル数です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).system(1).systemFloatingEmulations(14)

systemProcessorQueueLength　　Get：○　Set：－

プロセサ待ち行列の瞬間的な長さをスレッド数で表した値です。このカウンタは，スレッド・カウンタの監視を行っていないかぎり，常に0です。すべてのプロセサは一つの待ち行列を使用し，この待ち行列でスレッドはプロセサ・サイクルを待機するようになっています。この待ち行列の長さには，その時点で実行されているスレッドは含まれません。プロセサ待ち行列の長さが2を超える状態が持続する場合，プロセサに大きな負荷が掛かっていると見るのが普通です。この値は瞬間的なものであり，一定の時間帯の平均値を表すものではありません。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).system(1).systemProcessorQueueLength(15)

systemSystemCalls　　Get：○　Set：－

Windowsのシステム・サービス・ルーチンの呼び出し総数です。これらのルーチンは，コンピュータ上で行われるあらゆる活動の基本的スケジューリングと同期処理を行い，非グラフィカル・デバイス，メモリ管理機能，ネーム・スペース管理機能を利用する手段となります。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).system(1).systemSystemCalls(16)

systemSystemUpTime　　Get：○　Set：－

コンピュータが最後に起動してから運用可能な状態であった総計時間です。単位は1/100秒です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).system(1).systemSystemUpTime(17)

systemTotalInterrupts　　Get：○　Set：－

コンピュータによって受け取られ，処理されるハードウェア割り込みの数です。割り込みを行うデバイスには，システム・タイマ，マウス，データ通信回線，ネットワーク・インタフェース・カード，そのほかの周辺デバイスなどがあります。このカウンタは，あるコンピュータ全体でどの程度これらのデバイスが使用されているかを示す目安となります。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).system(1).systemTotalInterrupts(18)


memoryグループ(windowsNT 2)

memoryグループ(windowsNT 2)

形式

オブジェクト名　　MIBオペレーション　Get：　Set：

オブジェクトの内容を示します。

識別子を示します。

（MIBオペレーション　Get：　Set：　の凡例）
○：GetまたはSetオペレーションで値を取得またはセットできます。
N：GetまたはSetオペレーションで値を取得またはセットできません。noSuchNameで応答します。
－：アクセス権限がありません。noSuchNameで応答します。

オブジェクト

memoryAvailableBytes　　Get：○　Set：－

Zeroed，Free，およびStandbyの各リストにその時点で列挙されている仮想メモリのサイズです。ZeroedメモリとFreeメモリは，いつでも利用できるメモリのことであり，Zeroedメモリはその内容がゼロにクリアされたものです。また，Standbyメモリは，プロセスのワーキング・セットからは削除されているが，依然として利用可能なメモリのことです。なお，この値は，ある時点での瞬間的な値であって，一定時間帯での平均値ではありません。単位はバイトです。正しく扱える値の範囲は0～4,294,967,295（バイト）です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryAvailableBytes(1)

memoryCacheBytes　　Get：○　Set：－

システム・キャッシュによって現在使用されているバイト数を示します。システム・キャッシュは，ディスクあるいはLANから取り出したデータをバッファリングするために使用されます。システム・キャッシュは，コンピュータ上のアクティブなプロセスによって使用されていないメモリを使用します。単位はバイトです。正しく扱える値の範囲は0～4,294,967,295（バイト）です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryCacheBytes(2)

memoryCacheBytesPeak　　Get：○　Set：－

システム・キャッシュによって使用されている最大バイト数を示します。システム・キャッシュは，ディスクあるいはLANから取り出したデータをバッファリングするために使用されます。システム・キャッシュは，コンピュータ上のアクティブなプロセスによって使用されていないメモリを使用します。単位はバイトです。正しく扱える値の範囲は0～4,294,967,295（バイト）です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryCacheBytesPeak(3)

memoryCacheFaults　　Get：○　Set：－

キャッシュ・マネージャが即時キャッシュでファイル内のあるページを検出できなかった場合に発生します。この場合，キャッシュ・マネージャはメモリ・マネージャに照会して，メモリあるいはディスク上でのそのページの存在場所を確認し，即時キャッシュにロードできるようにしなければなりません。単位はキャッシュ・フォールト回数です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryCacheFaults(4)

memoryCommitLimit　　Get：○　Set：－

ページング・ファイルのサイズを拡張しなくてもコミットできる仮想メモリのサイズ（バイト数）です。ページング・ファイルを拡張できる場合は，このサイズをソフト・リミットといいます。単位はバイトです。正しく扱える値の範囲は0～4,294,967,295（バイト）です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryCommitLimit(5)

memoryCommittedBytes　　Get：○　Set：－

（単に予約されたのではなく）コミットされた仮想メモリのサイズ（バイト数）を表します。コミットされたメモリは，補助記憶装置（すなわち，ディスク）が存在するか，あるいはディスク記憶装置をいっさい必要としないことが確実でなければなりません（メイン・メモリがこれを収めるのに十分な大きさである場合）。なお，この値は，ある時点での瞬間的な値であって，一定時間帯での平均値ではありません。単位はバイトです。正しく扱える値の範囲は0～4,294,967,295（バイト）です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryCommittedBytes(6)

memoryDemandZeroFaults　　Get：○　Set：－

フォールトが解決されるまでにゼロ充てんすべきページのページ・フォールト数です。Zeroedリストが空でない場合，このフォールトはZeroedリストからページを削除することによって解決することができます。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryDemandZeroFaults(7)

memoryFreeSystemPageTableEntries　　Get：○　Set：－

システムが現在使用していないページ・テーブル・エントリの数。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryFreeSystemPageTableEntries(8)

memoryPageFaults　　Get：○　Set：－

プロセサ内で発生したページ・フォールトの回数を表します。メイン・メモリ上のワーキング・セットに存在しない仮想メモリ・ページをプロセスが参照すると，ページ・フォールトが発生します。ただし，そのページがStandbyリストに存在すれば（つまり，既にメイン・メモリに存在すれば），ページ・フォールトは発生せず，該当ページがディスクから取り出されることはありません。また，そのページを共有している別のプロセスによって使用されている場合も同様です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryPageFaults(9)

memoryPageReads　　Get：○　Set：－

ページ・フォールトを解消するために必要とされる仮想メモリのページを取り出すときに行われたディスクの読み取り回数です。なお，1回のディスク読み取り操作で複数のページが読み取られる場合があります。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryPageReads(10)

memoryPageWrites　　Get：○　Set：－

あるページが最後に取り出された後，変更があったためにそのページがディスクに書き込まれた回数を記録するカウンタです。この場合，1回で複数のページが書き込まれる場合があります。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryPageWrites(11)

memoryPagesInput　　Get：○　Set：－

その時点でメモリ上に存在しないページに対するメモリ参照を解決するため，ディスクから読み取られたページ数を示します。このカウンタの値には，アプリケーションのファイル・データをアクセスするシステム・キャッシュによるページング・トラフィックが含まれます。このカウンタは，メモリの過度な使用率（すなわち，スラッシング）およびその結果生じる過度なページングに関心がある場合に監視すべき重要なカウンタです。単位はページです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryPagesInput(12)

memoryPagesOutput　　Get：○　Set：－

メイン・メモリ上で変更があったページがディスクに書き込まれた回数を記録するカウンタです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryPagesOutput(13)

memoryPages　　Get：○　Set：－

メモリ参照時にメモリ上に存在しないページがあったときに，これを解決するためにディスクから読み取られたり，ディスクに書き込まれたりしたページの総数です。この値は，Pages InputとPages Outputの合計です。このカウンタには，アプリケーションのファイル・データをアクセスするシステム・キャッシュによるページング・トラフィックが含まれます。このカウンタは，メモリへの過度な負荷（スラッシング），およびそれによって生じる可能性のある過度なページングの有無を監視する際に使用される主なカウンタです。単位はページです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryPages(14)

memoryPoolNonpagedAllocs　　Get：○　Set：－

システムの非ページド・プールにスペースを割り当てるときに出された呼び出しの数です。非ページド・プールはシステム・メモリ領域の一つで，オペレーティング・システムの各コンポーネントは指定されたタスクの実行時にこの領域に一定のスペースを獲得します。非ページド・プールのページはページング・ファイルにページアウトすることはできませんが，ページ割り当てが存在するかぎりメイン・メモリ上に存在しています。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryPoolNonpagedAllocs(15)

memoryPoolNonpagedBytes　　Get：○　Set：－

非ページド・プールのバイト数です。非ページド・プールはシステム・メモリ領域の一つで，オペレーティング・システムの各コンポーネントは指定されたタスクの実行時にこの領域に一定のスペースを獲得します。非ページド・プールのページはページング・ファイルにページアウトすることはできませんが，ページ割り当てが存在するかぎりメイン・メモリ上に存在しています。単位はバイトです。正しく扱える値の範囲は0～4,294,967,295（バイト）です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryPoolNonpagedBytes(16)

memoryPoolPagedAllocs　　Get：○　Set：－

システムのページド・プールにスペースを割り当てるときに出された呼び出しの数です。ページド・プールはシステム・メモリ領域の一つで，オペレーティング・システムの各コンポーネントは指定されたタスクの実行時にこの領域に一定のスペースを獲得します。ページド・プールのページは，一定の期間システムがアクセスしない場合には，ページング・ファイルにページアウトすることができます。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryPoolPagedAllocs(17)

memoryPoolPagedBytes　　Get：○　Set：－

ページド・プールのバイト数です。ページド・プールはシステム・メモリ領域の一つで，オペレーティング・システムの各コンポーネントは指定されたタスクの実行時にこの領域に一定のスペースを獲得します。ページド・プールのページは，一定の期間システムがアクセスしない場合には，ページング・ファイルにページアウトすることができます。単位はバイトです。正しく扱える値の範囲は0～4,294,967,295（バイト）です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryPoolPagedBytes(18)

memoryPoolPagedResidentBytes　　Get：○　Set：－

Frame BytesとDatagram Bytesの総和です。この値は，ネットワークからプロトコル転送（送受信）された総バイト数ですが，フレーム単位（すなわち，パケット）で転送されたバイト数しかカウントしません。単位はバイトです。正しく扱える値の範囲は0～4,294,967,295（バイト）です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryPoolPagedResidentBytes(19)

memorySystemCacheResidentBytes　　Get：○　Set：－

現在のグローバル・ディスク・キャッシュの常駐バイト数です。単位はバイトです。正しく扱える値の範囲は0～4,294,967,295（バイト）です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memorySystemCasheResidentBytes(20)

memorySystemCodeResidentBytes　　Get：○　Set：－

System Code Total Bytesのうちその時点でコアメモリに常駐している部分のバイト数で，これはページ可能なexecutiveのコード・ワーキング・セットです。このほかに，非ページド・カーネル・コードが～300kバイトあります。単位はバイトです。正しく扱える値の範囲は0～4,294,967,295（バイト）です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memorySystemCodeResidentBytes(21)

memorySystemCodeTotalBytes　　Get：○　Set：－

ntldrまたはosloaderがロードするブート・ドライバとファイル・システム，およびntoskrnl.exe，hal.dllの中のページ可能なページのバイト数です。単位はバイトです。正しく扱える値の範囲は0～4,294,967,295（バイト）です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memorySystemCodeTotalBytes(22)

memoryDriverResidentBytes　　Get：○　Set：－

System Driver Total Bytesのうち，その時点でコアメモリに常駐している部分のバイト数で，これはページ可能なドライバのコードワーキング・セットです。このほかに，非ページド・ドライバ・コードが～700kバイトあります。単位はバイトです。正しく扱える値の範囲は0～4,294,967,295（バイト）です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryDriverResidentBytes(23)

memoryDriverTotalBytes　　Get：○　Set：－

その他のロードされているデバイス・ドライバすべてのページ可能なページのバイト数です。単位はバイトです。正しく扱える値の範囲は0～4,294,967,295（バイト）です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryDriverTotalBytes(24)

memoryTransitionFaults　　Get：○　Set：－

ページ・フォールト発生時に遷移，すなわちディスクへの書き込み中であったページを回復することによって解決したページ・フォールトの数です。これらのページは，ディスクにアクセスしないで回復されます。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryTransitionFaults(25)

memoryWriteCopies　　Get：○　Set：－

この保護を持つ選択されたイメージによって使用されている仮想アドレス・スペースです。Write Copy保護は，読み取りのためのメモリの共有は行うが，書き込みは不可とする場合に設定します。メモリ読み取りの際には，それぞれのプロセスはすべて同じメモリを共有することができます。ただし，ある共有プロセスがこの共有メモリに対して読み取りおよび書き込みのアクセスを必要とする場合には，そのプロセスに対してメモリのコピーが作成されます。単位はページ・フォールトの回数です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).memory(2).memoryWriteCopies(26)


processグループ(windowsNT 3)

processグループ(windowsNT 3)

形式

オブジェクト名　　MIBオペレーション　Get：　Set：

オブジェクトの内容を示します。

識別子を示します。

（MIBオペレーション　Get：　Set：　の凡例）
○：GetまたはSetオペレーションで値を取得またはセットできます。
N：GetまたはSetオペレーションで値を取得またはセットできません。noSuchNameで応答します。
－：アクセス権限がありません。noSuchNameで応答します。

オブジェクト

processNum　　Get：○　Set：－

実行中のプロセス数です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).process(3).processNum(1)

processTable

プロセス情報テーブルです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).process(3).processTable(2)

processEntry

各エントリはプロセスのインデクス番号で識別されます。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).process(3).processTable(2).processEntry(1)

processIndex　　Get：○　Set：－

プロセスのインデクス番号です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).process(3).processTable(2).processEntry(1).processIndex(1)

processPrivilegedTime　　Get：○　Set：－

非アイドル状態のスレッドで特権モードで消費されたプロセサ時間を表します。Windowsのサービス・レイヤ，Executiveルーチン，Windowsのカーネルは，特権モードで動作します。グラフィックス・アダプタやプリンタを除くほとんどのデバイスのデバイス・ドライバも，特権モードで動作します。これまでのある種のオペレーティング・システムと異なり，Windowsは，ユーザ・モードや特権モードといった従来の保護方式に加えて，サブシステムを保護するためのプロセス境界という考え方を採用しています。これらのサブシステムのプロセスは，それら追加の保護を提供します。したがって，アプリケーションに代わってWindowsが行うある種の処理は，ユーザ・プロセスでのPrivileged Timeのほかに，別のサブシステムのプロセスでも行われる場合があります。単位は1/100秒です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).process(3).processTable(2).processEntry(1).processPrivilegedTime(2)

processProcessorTime　　Get：○　Set：－

あるプロセサが非アイドル状態のスレッドの実行に費やした時間を表した値です。この値は，有用な作業の実行に費やした時間とみなすことができます。各プロセサには，アイドル・プロセスのアイドル・スレッドが割り当てられ，このスレッドがほかのいかなるスレッドにも使用されない非生産的なプロセサ・サイクルを消費するようになっています。単位は1/100秒です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).process(3).processTable(2).processEntry(1).processProcessorTime(3)

processUserTime　　Get：○　Set：－

非アイドル状態のスレッドでユーザ・モードで消費されたプロセサ時間を表します。アプリケーション・コードとサブシステム・コードはすべてユーザ・モードで実行されます。グラフィックス・エンジン，グラフィックス・デバイス・ドライバ，プリンタ・デバイス・ドライバ，およびウィンドウ・マネージャもユーザ・モードで実行されます。ユーザ・モードで実行されるコードは，WindowsのExecutive，カーネル，デバイス・ドライバに損傷を与えることはありません。これまでのある種のオペレーティング・システムと異なり，Windowsは，ユーザ・モードや特権モードといった従来の保護方式に加えて，サブシステムを保護するためのプロセス境界という考え方を採用しています。これらのサブシステムのプロセスは，それら追加の保護を提供します。したがって，アプリケーションに代わってWindowsが行うある種の処理は，ユーザのプロセスのPrivileged Timeのほかに，別のサブシステムのプロセスでも行われる場合があります。単位は1/100秒です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).process(3).processTable(2).processEntry(1).processUserTime(4)

processElapsedTime　　Get：○　Set：－

このプロセスの総実行経過時間です。単位は1/100秒です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).process(3).processTable(2).processEntry(1).processElapsedTime(5)

processIDProcess　　Get：○　Set：－

このプロセスの一意の識別子です。この番号は再利用されるので，ある時点であるプロセスに使用されている識別子は，そのプロセスが終了するまでの間だけ有効です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).process(3).processTable(2).processEntry(1).processIDProcess(6)

processPageFaults　　Get：○　Set：－

プロセサ内で発生したページ・フォールトの回数を表します。メイン・メモリ上のワーキング・セットに存在しない仮想メモリ・ページをプロセスが参照すると，ページ・フォールトが発生します。ただし，そのページがStandbyリストに存在すれば（つまり，既にメイン・メモリに存在すれば），ページ・フォールトは発生せず，該当ページがディスクから取り出されることはありません。また，そのページを共有している別のプロセスによって使用されている場合も同様です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).process(3).processTable(2).processEntry(1).processPageFault(7)

processPageFileBytes　　Get：○　Set：－

該当プロセスがその時点でページング・ファイルで使用していたバイト数です。ページング・ファイルは，該当プロセスが使用するメモリ上のページで，ほかのファイルには含まれていないページを格納するときに使用されます。ページング・ファイルはすべてのプロセスに共有され，ページング・ファイルのスペースが足りなくなると，ほかのプロセスはそれ以上メモリを割り当てることはできなくなります。単位はバイトです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).process(3).processTable(2).processEntry(1).processPageFileBytes(8)

processPageFileBytesPeak　　Get：○　Set：－

該当プロセスがページング・ファイルで使用していた最大バイト数です。ページング・ファイルは，該当プロセスが使用するメモリ上のページで，ほかのファイルには含まれていないページを格納するときに使用されます。ページング・ファイルはすべてのプロセスに共有され，ページング・ファイルのスペースが足りなくなると，ほかのプロセスはそれ以上メモリを割り当てることはできなくなります。単位はバイトです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).process(3).processTable(2).processEntry(1).processPageFileBytesPeak(9)

processPoolNonpagedBytes　　Get：○　Set：－

非ページド・プールのバイト数です。非ページド・プールはシステム・メモリ領域の一つで，オペレーティング・システムの各コンポーネントは指定されたタスクの実行時にこの領域に一定のスペースを獲得します。非ページド・プールのページはページング・ファイルにページアウトすることはできませんが，ページ割り当てが存在するかぎりメイン・メモリ上に存在しています。単位はバイトです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).process(3).processTable(2).processEntry(1).processPoolNonpagedBytes(10)

processPoolPagedBytes　　Get：○　Set：－

ページド・プールのバイト数です。ページド・プールはシステム・メモリ領域の一つで，オペレーティング・システムの各コンポーネントは指定されたタスクの実行時にこの領域に一定のスペースを獲得します。ページド・プールのページは，一定の期間システムがアクセスしない場合には，ページング・ファイルにページアウトすることができます。単位はバイトです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).process(3).processTable(2).processEntry(1).processPoolPagedBytes(11)

processPriorityBase　　Get：○　Set：－

このプロセスの現在の基本優先度。プロセス内のスレッドの実行優先度は，そのプロセスの基本優先度に相対したそれぞれの基本優先度によって上下します。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).process(3).processTable(2).processEntry(1).processPriorityBase(12)

processPrivateBytes　　Get：○　Set：－

該当プロセスが現時点ではほかのプロセスと共有できないバイト数です。単位はバイトです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).process(3).processTable(2).processEntry(1).processPrivateBytes(13)

processThreadCount　　Get：○　Set：－

このプロセスで現在アクティブ状態にあるスレッドの数。命令とはプロセサ内での基本実行単位であり，スレッドとは命令を実行するオブジェクトです。実行中のプロセスはすべて，少なくとも一つのスレッドを持っています。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).process(3).processTable(2).processEntry(1).processThreadCount(14)

processVirtualBytes　　Get：○　Set：－

プロセスがその時点で使用している仮想アドレス・スペースの大きさ（バイト数）を表します。仮想アドレス・スペースを使用することは，必ずしもディスクあるいはメイン・メモリ上のページを使用することにはつながりません。ただし，仮想スペースは有限であり，使用し過ぎると，プロセスがライブラリをロードするためのスペースが足りなくなるという事態に陥りかねません。単位はバイトです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).process(3).processTable(2).processEntry(1).processVirtualBytes(15)

processVirtualBytesPeak　　Get：○　Set：－

任意のある時点でプロセスが使用した仮想アドレス・スペースの最大バイト数を表します。仮想アドレス・スペースを使用することは，必ずしもディスクあるいはメイン・メモリ上のページを使用することにはつながりません。ただし，仮想スペースは有限であり，使用し過ぎると，プロセスがライブラリをロードするためのスペースが足りなくなるという事態に陥りかねません。単位はバイトです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).process(3).processTable(2).processEntry(1).processVirtualBytesPeak(16)

processWorkingSet　　Get：○　Set：－

該当プロセスのワーキング・セットの現時点でのバイト数です。ワーキング・セットとは，該当プロセスに属するスレッドが直近に参照したメモリ上のページの集合です。コンピュータ上に空きメモリがしきい値以上ある場合，プロセスのワーキング・セットには使用可能なページがそのまま残されています（それらのページが使用されていない場合でも）。一方，空きメモリの容量がしきい値を下回る場合には，ワーキング・セットからページが取り除かれます。取り除かれたページが必要になると，それらのページはディスクからワーキング・セットに戻され，メイン・メモリに置かれます。単位はバイトです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).process(3).processTable(2).processEntry(1).processWorkingSet(17)

processWorkingSetPeak　　Get：○　Set：－

任意の時点で該当プロセスのワーキング・セットに存在する最大バイト数を表します。このワーキング・セットとは，該当プロセスに属するスレッドが直近に参照したメモリ上のページの集合です。コンピュータ上に空きメモリがしきい値以上ある場合，プロセスのワーキング・セットには使用可能なページがそのまま残されています（それらのページが使用されていない場合でも）。一方，空きメモリの容量がしきい値を下回る場合には，ワーキング・セットからページが取り除かれます。取り除かれたページが必要になると，それらのページはディスクからワーキング・セットに戻され，メイン・メモリに置かれます。単位はバイトです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).process(3).processTable(2).processEntry(1).processWorkingSetPeak(18)


processorグループ(windowsNT 4)

processorグループ(windowsNT 4)

形式

オブジェクト名　　MIBオペレーション　Get：　Set：

オブジェクトの内容を示します。

識別子を示します。

（MIBオペレーション　Get：　Set：　の凡例）
○：GetまたはSetオペレーションで値を取得またはセットできます。
N：GetまたはSetオペレーションで値を取得またはセットできません。noSuchNameで応答します。
－：アクセス権限がありません。noSuchNameで応答します。

オブジェクト

processorNum　　Get：○　Set：－

プロセサ情報のエントリ数です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).processor(4).processorNum(1)

processorTable

プロセサ情報テーブルです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).processor(4).processorTable(2)

processorEntry

各エントリはプロセサのインデクスで識別されます。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).processor(4).processorTable(2).processorEntry(1)

processorIndex　　Get：○　Set：－

プロセサのインデクス番号です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).processor(4).processorTable(2).processorEntry(1).processorIndex(1)

processorPrivilegedTime　　Get：○　Set：－

非アイドル状態のスレッドで特権モードで消費されたプロセサ時間を表します。Windowsのサービスレイヤ，Executiveルーチン，Windowsのカーネルは，特権モードで動作します。グラフィックス・アダプタやプリンタを除くほとんどのデバイスのデバイス・ドライバも，特権モードで動作します。これまでのある種のオペレーティング・システムと異なり，Windowsは，ユーザ・モードや特権モードといった従来の保護方式に加えて，サブシステムを保護するためのプロセス境界という考え方を採用しています。これらのサブシステムのプロセスは，それら追加の保護を提供します。したがって，アプリケーションに代わってWindowsが行うある種の処理は，ユーザプロセスでのPrivileged Timeのほかに，別のサブシステムのプロセスでも行われる場合があります。単位は1/100秒です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).processor(4).processorTable(2).processorEntry(1).processorPrivilegedTime(2)

processorTime　　Get：○　Set：－

各プロセサがアイドル状態のプロセスのスレッド（アイドル・スレッド）を実行するのに費やした時間を表した値です。各プロセサには，アイドル・プロセスのアイドル・スレッドが割り当てられ，このスレッドがほかのいかなるスレッドにも使用されない非生産的なプロセサ・サイクルを消費するようになっています。単位は1/100秒です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).processor(4).processorTable(2).processorEntry(1).processorTime(3)

processorUserTime　　Get：○　Set：－

非アイドル状態のスレッドでユーザ・モードで消費されたプロセサ時間を表します。アプリケーション・コードとサブシステム・コードはすべてユーザ・モードで実行されます。グラフィックス・エンジン，グラフィックス・デバイス・ドライバ，プリンタ・デバイス・ドライバ，およびウィンドウ・マネージャもユーザ・モードで実行されます。ユーザ・モードで実行されるコードは，WindowsのExecutive，カーネル，デバイス・ドライバに損傷を与えることはありません。これまでのある種のオペレーティング・システムと異なり，Windowsは，ユーザ・モードや特権モードといった従来の保護方式に加えて，サブシステムを保護するためのプロセス境界という考え方を採用しています。これらのサブシステムのプロセスは，それら追加の保護を提供します。したがって，アプリケーションに代わってWindowsが行うある種の処理は，ユーザのプロセスのPrivileged Timeのほかに，別のサブシステムのプロセスでも行われる場合があります。単位は1/100秒です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).processor(4).processorTable(2).processorEntry(1).processorUserTime(4)

processorInterrupts　　Get：○　Set：－

プロセサが遭遇したデバイス割り込みの回数を表します。デバイスは，あるタスクを完了したとき，あるいはある種の応答処置が必要になるような状態になったときにプロセサに割り込みをかけます。通常のスレッドの実行は，割り込み中は中断されます。割り込みが発生すると，プロセサが優先順位の高い別のスレッドへの切り替えを行う場合があります。例えば，クロック割り込みは頻繁かつ定期的に発生するごく基本的な割り込みの一つです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).processor(4).processorTable(2).processorEntry(1).processorInterrupts(5)


domainConfグループ(windowsNT 5)

domainConfグループ(windowsNT 5)

形式

オブジェクト名　　MIBオペレーション　Get：　Set：

オブジェクトの内容を示します。

識別子を示します。

（MIBオペレーション　Get：　Set：　の凡例）
○：GetまたはSetオペレーションで値を取得またはセットできます。
N：GetまたはSetオペレーションで値を取得またはセットできません。noSuchNameで応答します。
－：アクセス権限がありません。noSuchNameで応答します。

オブジェクト

domainConfDomainName　　Get：○　Set：－

コンピュータのドメイン名称です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).domainConf(5).domainConfDomainName(1)

domainConfDomainController　　Get：○　Set：－

コンピュータのドメイン・コントローラ名称です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).domainConf(5).domainConfDomainController(2)

domainConfSystemRole　　Get：○　Set：－

コンピュータのドメイン内での役割です。

  • プライマリドメインコントローラー（１）
  • バックアップドメインコントローラー（２）
  • サーバー（３）
  • ワークステーション（４）

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).domainConf(5).domainConfSystemRole(3)

domainConfTrustedDomainTable

コンピュータの信頼関係情報テーブルです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).domainConf(5).domainConfTrustedDomainTable (4)

domainConfTrustedDomainEntry

各エントリはドメインの信頼関係を持つドメイン・インデックスの値で識別されます。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).domainConf(5).domainConfTrustedDomainTable(4).domainConfTrustedDomainEntry(1)

domainConfTrustedDomainIndex　　Get：○　Set：－

ドメインの信頼関係を持つドメイン・インデックスです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).domainConf(5).domainConfTrustedDomainTable(4).domainConfTrustedDomainEntry(1).domainConfTrustedDomainIndezx(1)

domainConfTrustedDomainName　　Get：○　Set：－

ドメインの信頼関係を持つドメイン名称です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).domainConf(5).domainConfTrustedDomainTable(4).domainConfTrustedDomainEntry(1).domainConfTrustedDomainName(2)

domainConfDomainMemberTable

ドメイン構成情報テーブルです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).domainConf(5).domainConfDomainMemberTable(5)

domainConfDomainMemberEntry

各エントリはドメイン構成のコンピュータ・インデックスで識別されます。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).domainConf(5).domainConfDomainMemberTable(5).domainConfDomainMemberEntry(1)

domainConfDomainMemberIndex　　Get：○　Set：－

ドメイン構成のコンピュータ・インデックスです。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).domainConf(5).domainConfDomainMemberTable(5).domainConfDomainMemberEntry(1).domainConfDomainMemberIndex(1)

domainConfDomainMemberName　　Get：○　Set：－

ドメイン構成のコンピュータ名称です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).domainConf(5).domainConfDomainMemberTable(5).domainConfDomainMemberEntry(1).domainConfDomainMemberName(2)

domainConfChangeItem　　Get：○　Set：－

ドメイン構成の変更情報です。

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).domainConf(5).domainConfChangeItem(6)

domainConfSererID　　Get：○　Set：－

SMSサービスの搭載の有無です。

  • SMSサーバー（１）
  • その他（０）

iso(1).org(3).dod(6).internet(1).private(4).enterprises(1).hitachi(116).systemExMib(5).cometMibs(1).systems(2).windowsNT(2).domainConf(5).domainConfServerID(7)


付録

＜この付録の構成＞
付録A　用語解説


用語解説

付録A　用語解説

（英字）

hiextmib
日立企業固有MIBのシステムリソースを監視する拡張エージェントのプロセスです。
hpextmib
HP企業固有MIBのシステムリソースを監視する拡張エージェントのプロセスです。
IPアドレス
IP（インターネット・プロトコル）アドレスは，TCP/IPプロトコルを使用するネットワーク上のノードを識別します。TCP/IPプロトコルを使用するネットワーク上の各々のノードはユニークなIPアドレスを持つ必要があります。
IPアドレスは二つのフィールドに分割されます。
ネットワーク・フィールド
インターネット上の特定の物理的ネットワークを示します。
ホスト・フィールド
その物理的ネットワークに接続された特定のノードを示します。
MIB
Management Information Base（管理情報ベース）の略。
ネットワーク管理プロトコル経由でアクセスできるオブジェクト（管理情報）の集合です。
MIBオブジェクト
ある特定のタイプ，またはクラスの管理情報です。
MIBオブジェクトは，インターネット標準の管理情報構造を使用して定義されています。
MIBツリー
複数のMIBオブジェクトの階層関係を，ツリー上に表したものです。MIBオブジェクトの編成を図示するために使用されます。
MIBモジュール
すべてのMIBオブジェクトをサブツリーの下に定義するファイルです。基盤となるモジュールは，RFC1213:Management Information Base of Network Management of TCP/IP internets:MIB-Ⅱによって定義されたインターネット標準のMIB-Ⅱモジュールです。
NNM
Network Node Manager（ネットワークノードマネージャ）の略。
TCP/IPネットワークを統合的に管理するための管理基盤プログラムです。
SNMP
Simple Network Management Protocolの略。
ノードからネットワーク情報を検索するために使用される，管理プロトコルです。RFC1157で定義されています。
SNMP EMANATEエージェント
NNMがインストールされているシステム上でSNMPエージェント機能を提供するエージェントプログラムです。サブエージェントのプロキシとなるマスタエージェントの機能を備えています。
SSO
JP1/SNMP System Observerの略。
SNMPエージェントと連携してリソース収集やプロセス監視を行うためのマネージャプログラムです。
sysObjectID
ある特定のベンダのハードウェア上で実行されているエージェント・ソフトウェアのタイプをユニークに識別するために，管理上の目的で使用されます。sysObjectIDは，その他のMIBオブジェクトと異なっています。sysObjectIDについて照会すると，その製品を表すオブジェクト識別子が戻されます。
sysObjectIDはハードウェア情報とソフトウェア情報の両方を含んでいて，ハードウェアおよびエージェント・ソフトウェアのタイプに従って変化します。一部のベンダは，自社のエージェントのバージョンごとにすべて異なるsysObjectIDを持っています。

（ア行）

アラームMIB
しきい値監視条件や動作状態を表現した日立企業固有MIBの一つです。サブマネージャが持ちます。
イベント
次の現象のうち少なくとも一つが起きたとき，マネージャ・ソフトウェアまたはSNMPエージェントから送信されてくる通知です。
  • 情報メッセージまたはエラーが発生した
  • MIB値がしきい値を超えた
  • オブジェクトのステータスが変更された
  • オブジェクトの設定が変更された
インスタンス
エージェント・データベースの中のMIBオブジェクトに対する特定の値のことです。MIBオブジェクトは，例えば，システム記述のように，ある一つのエージェント・システムについて一つのインスタンスしか持たない場合もあります。また，システム上の各インタフェースごとのインタフェース・ステータスのように，ある一つのエージェント・システムについて複数のインスタンスを持つ場合もあります。
エージェント
SNMPリクエストに応答し，SNMPトラップを送信するノード，またはノード上で動作しているプロセスです。
エージェント・システム
SNMPエージェントが動作する機器です。エージェントシステムはマネージャからのSNMPリクエストを実行します。エージェント・システムには，パーソナル・コンピュータ，ワークステーション，ホスト，ゲートウェイ（ルータ），ターミナル・サーバ，ハブ，ブリッジなどがあります。
オブジェクト
オブジェクトは論理的・物理的なエンティティ，リソース，ネットワークに存在する物理的エンティティのグループを表現します。オブジェクトの例は，ネットワーク，コンピュータ，インタフェース，プロセスです。
オブジェクトID
MIBオブジェクトをユニークに識別するために使用する名称です。オブジェクトIDは，MIBツリーに配置されるオブジェクトに基づいています。

（カ行）

階層管理機能
マネージャとエージェントの間にサブマネージャを配置する機能です。マネージャ・システムへ集まる情報を選択したり，管理のためにネットワーク上を伝送されるパケット数を最小限に抑えたりできます。
管理対象ノード定義ファイル
サブマネージャの管理範囲を決定するオプションファイルです。
企業固有MIB
個々のベンダが，その固有の製品のために開発したMIBです。ベンダはそれらのプライベートMIBを企業オブジェクト識別子のツリーの下に登録します。
危険域
オブジェクトに重大な障害が存在し，通常の使用が中断されるかひどく妨げられる状態です。これは，最も重大な警告レベルです。
警戒域
比較的低い重要度の障害を示す状態であり，オブジェクトの通常の使用上は問題ない状態です。
ゲートウェイ
ネットワーク・インタフェースを複数持つオブジェクトです。ゲートウェイは一つ以上のネットワークに物理的に接続されています。ゲートウェイはこれらのネットワーク間でネットワーク・アドレスに基づいてパケットを転送します。
"ゲートウェイ"という用語はよく，転送プロトコル，ルート，その他のメッセージを転送するシステムのことを言います。例えば，メール・ゲートウェイがあります。
コミュニティ名
エージェントのMIB値にアクセスするためのパスワードです。

（サ行）

サブエージェント
マスタエージェントをプロキシとするSNMPエージェントです。マネージャと直接通信せず，マスタエージェントを経由します。拡張エージェントはサブエージェントに該当します。
サブマネージャ
マネージャと組み合わせることによって，ネットワークを階層的に管理します。マネージャ・システムに集中する情報を選択したり，管理のためのパケット数を削減したりしてネットワークを効率的に管理します。
シード・ファイル
サブマネージャの管理対象サブネットを拡張する場合に定義するオプションファイルです。
しきい値
MIBオブジェクトごとに設定できる，イベント発生の境界値です。MIB値がしきい値を超えるとイベントが発生します。
しきい値監視条件定義ファイル
しきい値監視機能で監視対象とする項目を定義するファイルです。
集約MIB
サブマネージャが，マネージャから要求を受信した時点の管理範囲にあるTCPコネクション情報を集約した日立企業固有MIBの一つです。
状態変更トラップ発行条件定義ファイル
インタフェース状態MIBの状態変更トラップの発行条件を定義するファイルです。
自立拡張トラップ
サブマネージャが発行する拡張トラップです。
正常域
オブジェクトが正常に機能している状態です。そのオブジェクトでは障害の存在を示す事象やアラームはありません。そのオブジェクトは，アプリケーションによって交信でき，適切に応答しています。

（タ行）

中継拡張トラップ
サブマネージャが中継する拡張トラップです。
トラップ
マネージャからの明示的な要求がなくても，SNMPをサポートしているノードからマネージャに送られる情報です。トラップは，これらのノードで起きる変化（例えば，再起動）をマネージャに通知します。
トラップフィルタ条件定義ファイル
トラップのフィルタリング機能で使用するフィルタリング条件を定義するファイルです。

（ナ行）

ネットワーク
共通の通信媒体で相互接続された，データ通信装置のグループです。
ネットワークの各ノードは，ネットワーク間のルーティングを可能とするネットワーク・アドレスを持つネットワークに属しています。また，同じネットワークに属しているノードは一般的に，互いの通信のために共通の物理媒体を使用します。

（ハ行）

フィルタMIB
トラップのフィルタリング条件やその動作状態を表現した日立企業固有MIBの一つです。サブマネージャが持ちます。
ポーリング
ノードの情報を収集するために，管理ステーションから被管理ノードに定期的に送信される要求です。
ホスト
一般的なコンピューティング・サービスを提供する（ネットワークに接続された）コンピュータ・システム。例えば，メイン・フレーム，ミニコンピュータ，パーソナル・コンピュータ，ワークステーション。ホストが複数のインタフェースを持ち，ネットワークを超えてデータをルーティングするなら，ホストはゲートウェイとしても機能します。

（マ行）

マスタエージェント
拡張エージェントのプロキシとして機能するSNMPエージェントです。マネージャからのSNMP要求を直接受信し，MIBによって要求を拡張エージェントに振り分けます。マスタエージェントにはSNMPサービス，SNMP EMANATEエージェントがあります。
これに対して，マスタエージェントをプロキシとするSNMPエージェントをサブエージェントと呼びます。
マネージャ
エージェントシステムを監視・制御するためのネットワーク管理機能です。
マネージャ・システム
エージェント・システムを監視したり制御したりしてネットワークを管理します。

（ラ行）

ルーティング
ネットワーク上のあて先へ到達するためにパケットが取るパス（ルート）を決定する動作です。


索引

[Ａ][Ｃ][Ｄ][Ｅ][Ｆ][Ｈ][Ｉ][Ｊ][Ｍ][Ｎ][Ｏ][Ｐ][Ｓ]
[ア行][カ行][サ行][タ行][ナ行][ハ行][マ行][ラ行]

(英字)

(Ａ)
authFail
(Ｃ)
cluster
computerSystem
computerSystem64
(Ｄ)
domainConf
(Ｅ)
esareg
(Ｆ)
fileSystem
fileSystem
fileSystem64
fileSystemFiles
(Ｈ)
hiextmib
hiextmib
hismsmib
hpextmib
hpextmib
HP企業固有MIBオブジェクト
(Ｉ)
icmp
ieee8023Mac
IPアドレス
(Ｊ)
jp1esalog.bat
(Ｍ)
memory
MIB
MIB
MIBオブジェクト
MIBオブジェクト
MIBツリー
MIBモジュール
MIBモジュール
(Ｎ)
NNM
NNM
NO_FILECOUNT
(Ｏ)
opConf
(Ｐ)
process
processes
processor
(Ｓ)
SNMP
snmpcheck
snmpdConf
SNMP EMANATEエージェント
snmptrap
SSO
SSO
swapSpace
sysObjectID
sysObjectID
systemtrap

(ア行)

(あ)
アラームMIB
(い)
イベント
インスタンス
(え)
エージェント
エージェント
エージェント・システム
(お)
オブジェクト
オブジェクトID
オブジェクト識別子

(カ行)

(か)
階層管理機能
拡張エージェント
拡張エージェントの稼働状況
拡張エージェントの環境設定
環境設定
環境設定とカスタマイズ
管理情報ベース
管理対象ノード定義ファイル
(き)
企業固有MIB
企業固有MIBオブジェクト
危険域
(け)
警戒域
ゲートウェイ
(こ)
コマンド
コミュニティ名
コミュニティ名

(サ行)

(さ)
サブエージェント
サブマネージャ
(し)
シード・ファイル
しきい値
しきい値監視条件定義ファイル
指定ノードに対してSNMP・トラップを発行する
指定ノードに対してシステム・トラップを発行する
集約MIB
障害発生時における資料採取コマンド
状態変更トラップ発行条件定義ファイル
自立拡張トラップ
(せ)
正常域

(タ行)

(ち)
中継拡張トラップ
(と)
トラップ
トラップフィルタ条件定義ファイル

(ナ行)

(ね)
ネットワーク
ネットワーク管理
ネットワーク管理の概要
ネットワークの設定

(ハ行)

(ひ)
日立企業固有MIBオブジェクト
(ふ)
ファイル・システム
フィルタMIB
(ほ)
ポート番号
ポーリング
ホスト

(マ行)

(ま)
マスタエージェント
マネージャ
マネージャ
マネージャ・システム

(ラ行)

(る)
ルーティング