uCosminexus EUR データベース連携ガイド - 目次

uCosminexus EUR データベース連携ガイド

解説・操作書

3020-7-713

目　　次

前書き
はじめに
1.　データベースからEURにデータを読み込むには
1.1　データベースからデータを読み込む流れ
1.1.1　EUR 帳票作成機能でのデータを読み込む流れ
1.1.2　EUR クライアント帳票出力機能でのデータを読み込む流れ
1.1.3　EUR サーバ帳票出力機能でのデータを読み込む流れ
1.2　EURで使用できるデータベース
1.2.1　ロケールごとの接続可否
1.2.2　使用できる文字コードの一覧
1.2.3　データ型の一覧
1.2.4　使用できる文字の注意事項
1.3　EURで使用できるODBC Driver
1.3.1　抽出するデータの文字コードをUTF-8とした場合の制限事項
2.　データベースの接続設定
2.1　データベースの接続の概要
2.2　データベースの接続設定の流れ
2.3　DABrokerのセットアップ
2.3.1　DABrokerをインストールする環境
2.3.2　インストール
2.3.3　ネットワーク環境の設定
2.3.4　DABrokerの動作環境の設定
2.3.5　データベースごとの設定
2.4　DABrokerの起動と終了
2.4.1　起動
2.4.2　終了
2.5　EURからDABrokerに接続するための設定
2.6　ODBC Driverの設定
2.6.1　ポート番号の登録
2.6.2　ODBCデータソースの設定
3.　帳票作成時のデータベースからのデータの読み込み
3.1　データ読み込みの操作の流れ
3.2　データベースの接続
3.2.1　EURからのデータベースの接続
3.2.2　データベースに再接続するには
3.3　データの抽出
3.3.1　表の選択
3.3.2　列の設定
3.3.3　条件の設定
3.3.4　最新列情報の取得
3.4　抽出データの確認
3.5　データウィンドウへの表示
3.6　データウィンドウのフィールド定義
3.6.1　データベースのデータ型とEURで扱えるデータ種別との対応
3.6.2　抽出したデータが表示されるときの規則
3.6.3　データウィンドウのフィールド定義
3.7　見出し辞書の設定
3.7.1　見出し辞書とは
3.7.2　見出し辞書の作成
3.7.3　見出し辞書の編集
3.7.4　見出し辞書の使用
3.7.5　見出し辞書の削除
4.　帳票出力でデータベースからのデータの読み込みに使用するファイル
4.1　接続情報ファイル
4.1.1　接続情報ファイルの作成
4.2　可変記号値定義ファイル
4.2.1　可変記号値定義ファイルの作成
5.　データベースアクセス定義のウィンドウとダイアログ
5.1　データベースアクセス定義ウィンドウ
5.2　データ表示ウィンドウ
5.3　［表選択］ダイアログ
5.4　［表一覧表示方法の設定］ダイアログ
5.5　［表の絞り込み条件設定］ダイアログ
5.6　［列設定］ダイアログ
5.7　［集合関数設定］ダイアログ
5.8　［ソート設定］ダイアログ
5.9　［仮想列編集］ダイアログ
5.10　［条件設定］ダイアログ
5.11　［表結合条件］ダイアログ
5.12　［IN条件式］ダイアログ
5.13　［BETWEEN条件式］ダイアログ
5.14　［列演算条件式］ダイアログ
5.15　［条件式直接入力］ダイアログ
5.16　［可変記号入力］ダイアログ
5.17　［見出し編集］ダイアログ
5.18　［読み込み先の指定］ダイアログ
5.19　［見出し選択］ダイアログ
5.20　［辞書一覧表示方法の設定］ダイアログ
5.21　［格納先の指定］ダイアログ
5.22　［オプション設定］ダイアログ
5.22.1　［抽出］タブ
5.22.2　［表示］タブ
5.22.3　［見出し辞書］タブ
5.23　［実行値入力］ダイアログ
5.24　［辞書の指定］ダイアログ
5.25　［EUR ODBC Driver - セットアップ -］ダイアログ
5.26　［EUR ODBC Driver - 環境定義 -］ダイアログ
6.　EUR 帳票作成機能のメッセージ
6.1　メッセージの出力形式
6.2　メッセージの記載形式
メッセージID
6.3　メッセージの出力先
6.4　DBL0001～DBL0999のメッセージ
DBL0010E
DBL0020E
DBL0100E
DBL0101E
DBL0401E
6.5　DBL1000～DBL1999のメッセージ
DBL1001E
DBL1002E
DBL1003E
DBL1004E
DBL1005E
DBL1006E
DBL1007E
DBL1011E
6.6　DBP0001～DBP0999のメッセージ
DBP0001E
DBP0002E
DBP0005W
DBP0006W
DBP0007E
DBP0010W
DBP0011W
DBP0012W
DBP0013W
DBP0018W
DBP0019I
DBP0020W
DBP0022I
DBP0025W
DBP0501W
DBP0502W
DBP0503W
DBP0505W
DBP0507W
DBP0508W
DBP0509W
DBP0510W
DBP0511W
DBP0512W
DBP0513W
DBP0514W
DBP0515W
DBP0516W
DBP0517W
DBP0518W
DBP0519W
DBP0520W
DBP0521W
DBP0522W
DBP0523W
DBP0524W
DBP0525W
DBP0526W
DBP0527W
DBP0529W
DBP0530W
DBP0532W
DBP0533W
DBP0534W
DBP0535W
6.7　DBP1000～DBP1999のメッセージ
DBP1005W
DBP1013E
DBP1015W
DBP1019W
DBP1024W
DBP1025W
DBP1029W
DBP1030W
DBP1032W
DBP1038W
DBP1040W
DBP1045I
DBP1046I
DBP1048I
DBP1049W
DBP1050W
DBP1055W
DBP1056W
DBP1058W
DBP1082I
DBP1083W
DBP1084W
DBP1085W
DBP1087W
DBP1117W
DBP1118W
DBP1119W
DBP1120W
DBP1123W
DBP1124W
DBP1127W
DBP1128W
DBP1129W
DBP1133W
DBP1136I
DBP1137W
DBP1138W
DBP1140W
DBP1141W
DBP1143W
DBP1144W
DBP1151W
6.8　DBP2000～DBP2999のメッセージ
DBP2001W
DBP2002E
DBP2007W
DBP2008W
DBP2009W
DBP2010E
DBP2017E
6.9　DBP3000～DBP3999のメッセージ
DBP3000W
DBP3001E
DBP3007E
DBP3008E
DBP3009E
DBP3600E
DBP3601E
DBP3602E
DBP3603I
DBP3604I
DBP3605W
DBP3606E
DBP3607I
DBP3608I
DBP3609E
DBP3610I
DBP3611I
DBP3612I
DBP3613I
DBP3614W
DBP3701W
DBP3702W
DBP3703W
DBP3704W
DBP3706W
DBP3904W
6.10　DBP6000～DBP6999のメッセージ
DBP6201W
DBP6202E
DBP6203E
DBP6204E
DBP6205W
DBP6206W
DBP6208E
DBP6215W
6.11　DBP8000～DBP8999のメッセージ
DBP8007E
7.　DABrokerのメッセージ
7.1　メッセージの出力形式
7.2　メッセージの記載形式
メッセージID
7.3　メッセージの出力先
7.4　KFDB001DB～KFDB999DBのメッセージ
KFDB001DB-E
KFDB002DB-E
KFDB003DB-E
KFDB004DB-I
KFDB005DB-E
KFDB006DB-E
KFDB007DB-E
KFDB011DB-E
KFDB012DB-E
KFDB013DB-E
KFDB017DB-E
KFDB018DB-E
KFDB019DB-E
KFDB020DB-E
KFDB021DB-E
KFDB024DB-E
KFDB025DB-E
KFDB026DB-E
KFDB030DB-E
KFDB031DB-E
KFDB032DB-E
KFDB040DB-E
KFDB041DB-E
KFDB042DB-E
KFDB043DB-E
KFDB044DB-E
KFDB045DB-E
KFDB051DB-E
KFDB052DB-E
KFDB053DB-E
KFDB054DB-E
KFDB070DB-E
KFDB071DB-E
KFDB101DB-E
7.5　KFDB001EC～KFDB999ECのメッセージ
KFDB002EC-E
KFDB008EC-E
KFDB012EC-E
KFDB013EC-E
KFDB014EC-E
KFDB015EC-E
KFDB016EC-E
KFDB017EC-E
7.6　KFDB001LC～KFDB999LCのメッセージ
KFDB003LC-E
KFDB005LC-E
7.7　KFDB001LM～KFDB999LMのメッセージ
KFDB001LM-E
7.8　KFDB001MM～KFDB999MMのメッセージ
KFDB001MM-E
KFDB002MM-E
KFDB003MM-E
KFDB004MM-E
KFDB005MM-E
KFDB006MM-E
KFDB009MM-E
KFDB011MM-E
KFDB019MM-E
KFDB020MM-E
7.9　KFDB001NM～KFDB999NMのメッセージ
KFDB001NM-E
KFDB002NM-E
KFDB003NM-E
KFDB004NM-E
KFDB005NM-E
KFDB101NM-E
KFDB102NM-E
KFDB103NM-I
KFDB104NM-Q
KFDB105NM-E
KFDB201NM-E
KFDB202NM-E
KFDB203NM-Q
KFDB204NM-E
KFDB205NM-E
KFDB206NM-E
KFDB207NM-E
KFDB211NM-E
KFDB213NM-E
KFDB214NM-E
KFDB215NM-E
KFDB216NM-W
KFDB250NM-I
KFDB251NM-I
KFDB252NM-E
KFDB253NM-E
7.10　KFDB001RC～KFDB999RCのメッセージ
KFDB003RC-E
7.11　KFDB001RM～KFDB999RMのメッセージ
KFDB001RM-E
7.12　KFDB001RR～KFDB999RRのメッセージ
KFDB001RR-E
KFDB002RR-E
KFDB003RR-E
7.13　KFDB001SC～KFDB999SCのメッセージ
KFDB002SC-E
KFDB005SC-I
KFDB007SC-E
KFDB008SC-E
KFDB009SC-E
7.14　KFDB001SM～KFDB999SMのメッセージ
KFDB001SM-E
KFDB002SM-E
KFDB003SM-E
KFDB004SM-E
KFDB005SM-E
KFDB006SM-E
7.15　KFDB001TD～KFDB999TDのメッセージ
KFDB001TD-E
KFDB002TD-E
KFDB003TD-E
KFDB004TD-E
KFDB005TD-E
KFDB006TD-E
KFDB007TD-E
KFDB008TD-E
KFDB009TD-E
KFDB010TD-E
KFDB011TD-E
KFDB012TD-E
KFDB013TD-E
KFDB015TD-E
KFDB016TD-E
KFDB030TD-W
KFDB031TD-W
KFDB032TD-E
KFDB033TD-E
KFDB034TD-E
KFDB035TD-E
KFDB036TD-E
KFDB037TD-E
KFDB049TD-E
7.16　KFDB001TM～KFDB999TMのメッセージ
KFDB001TM-E
KFDB002TM-E
KFDB003TM-E
KFDB004TM-E
KFDB005TM-E
KFDB006TM-I
KFDB007TM-I
KFDB008TM-E
KFDB009TM-E
KFDB010TM-E
KFDB011TM-E
KFDB012TM-E
KFDB013TM-E
KFDB014TM-I
KFDB016TM-E
KFDB017TM-E
KFDB018TM-E
KFDB019TM-E
KFDB020TM-E
KFDB021TM-E
KFDB022TM-W
KFDB023TM-E
7.17　KFDB001TR～KFDB999TRのメッセージ
KFDB001TR-E
KFDB002TR-E
KFDB003TR-E
7.18　KFDB001YM～KFDB999YMのメッセージ
KFDB003YM-I
KFDB004YM-I
KFDB005YM-I
KFDB006YM-I
KFDB007YM-E
KFDB008YM-E
KFDB009YM-E
KFDB010YM-E
KFDB011YM-E
KFDB012YM-E
KFDB013YM-E
KFDB014YM-E
KFDB015YM-E
KFDB016YM-E
KFDB019YM-E
KFDB020YM-E
KFDB021YM-E
KFDB022YM-I
KFDB023YM-E
KFDB100YM-E
KFDB101YM-E
KFDB301YM-I
KFDB302YM-I
KFDB303YM-I
KFDB310YM-I
付録
付録A　DABrokerの利用
付録A.1　DABrokerの起動中に使用できるユティリティ
付録B　DABrokerの詳細コード，要求コード，および応答コード
付録B.1　DABrokerの詳細コード
付録B.2　DABrokerの要求コードおよび応答コード
付録C　このマニュアルの参考情報
付録C.1　関連マニュアル
付録C.2　EUR バージョン9での製品体系の変更
付録C.3　EUR バージョン9でのマニュアル体系の変更
付録C.4　このマニュアルでの表記
付録C.5　このマニュアルで使用する略語
付録C.6　KB（キロバイト）などの単位表記について
索引

[他社商品名称に関する表示]

All Rights Reserved. Copyright (C) 2012, Hitachi, Ltd.
All Rights Reserved. Copyright (C) 2012, Hitachi Solutions, Ltd.


前書き

■ 対象製品

●適用OS：Windows 7 x86，Windows 7 x64※1

P-2CD2-5694　 uCosminexus EUR：イーユーアール Designer　 09-00
P-2CD2-5794　 uCosminexus EUR：イーユーアール Developer※2　 09-00
P-2CD2-5394　 uCosminexus EUR：イーユーアール Viewer　 09-00

●適用OS：Windows Server 2008 R2

P-29D2-5994　 uCosminexus EUR：イーユーアール Server Standard※3　 09-00
P-29D2-5A94　 uCosminexus EUR：イーユーアール Server Enterprise※3　 09-00
P-29D2-5794　 uCosminexus EUR：イーユーアール Server Print Edition※3　 09-00
P-29D2-5C94　 uCosminexus EUR：イーユーアール Server - Cipher option　 09-00

●適用OS：HP-UX 11i V3(IPF)

P-1JD2-5991　 uCosminexus EUR：イーユーアール Server Standard　 09-00
P-1JD2-5A91　 uCosminexus EUR：イーユーアール Server Enterprise　 09-00
P-1JD2-5791　 uCosminexus EUR：イーユーアール Server Print Edition　 09-00
P-1JD2-5C91　 uCosminexus EUR：イーユーアール Server - Cipher option　 09-00

●適用OS：AIX V6.1，AIX V7.1

P-1MD2-5991　 uCosminexus EUR：イーユーアール Server Standard　 09-00
P-1MD2-5A91　 uCosminexus EUR：イーユーアール Server Enterprise　 09-00
P-1MD2-5791　 uCosminexus EUR：イーユーアール Server Print Edition　 09-00
P-1MD2-5C91　 uCosminexus EUR：イーユーアール Server - Cipher option　 09-00

●適用OS：Red Hat Enterprise Linux Server 6 (64-bit x86_64)

P-82D2-5991　 uCosminexus EUR：イーユーアール Server Standard　 09-00
P-82D2-5A91　 uCosminexus EUR：イーユーアール Server Enterprise　 09-00
P-82D2-5791　 uCosminexus EUR：イーユーアール Server Print Edition　 09-00
P-82D2-5C91　 uCosminexus EUR：イーユーアール Server - Cipher option　 09-00

注※1
WOW64（Windows On Windows 64）環境だけで使用できます。
注※2
次に示す製品を同梱しています。
・P-2463-2354　　DABroker
注※3
次に示す製品を同梱しています。
・P-2963-2354　　DABroker(64)

これらの製品は，ISO9001およびTickITの認証を受けた品質マネジメントシステムで開発されました。

■ 輸出時の注意

本製品を輸出される場合には，外国為替および外国貿易法ならびに米国の輸出管理関連法規などの規制をご確認の上，必要な手続きをお取りください。
なお，ご不明な場合は，弊社担当営業にお問い合わせください。

■ 商標類

Acrobatは，Adobe Systems Incorporated（アドビシステムズ社）の商標です。
ActiveXは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
Adobe，およびFlashは，Adobe Systems Incorporated(アドビシステムズ社)の米国ならびに他の国における商標または登録商標です。
Adobe，およびReaderは，Adobe Systems Incorporated(アドビシステムズ社)の米国ならびに他の国における商標または登録商標です。
AIXは，米国およびその他の国におけるInternational Business Machines Corporationの商標です。
AMDは，Advanced Micro Devices, Inc.の商標です。
BSAFEは，EMC Corporationの米国およびその他の国における登録商標または商標です。
ESC/Pは，セイコーエプソン(株)の商標です。
GIFは，米国CompuServe Inc.が開発したフォーマットの名称です。
HP-UXは，Hewlett-Packard Development Company, L.P.のオペレーティングシステムの名称です。
Internet Explorerは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
Itaniumは，アメリカ合衆国およびその他の国におけるIntel Corporationの商標です。
Linuxは，Linus Torvalds氏の日本およびその他の国における登録商標または商標です。
LIPSIIIは，キヤノン（株）が開発した言語仕様です。
MicrosoftおよびHyper-Vは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
MicrosoftおよびMS-DOSは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
MicrosoftおよびVisual Basicは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
MicrosoftおよびVisual C++は，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
Microsoft .NET は，お客様，情報，システムおよびデバイスを繋ぐソフトウェアです。
Microsoft Excelは，米国Microsoft Corporationの商品名称です。
Microsoft Officeは，米国Microsoft Corporationの商品名称です。
Microsoft Office Excelは，米国 Microsoft Corporation の商品名称です。
Microsoft Office Wordは，米国 Microsoft Corporation の商品名称です。
Microsoft Wordは，米国Microsoft Corporationの商品名称です。
ODBCは，米国Microsoft Corporationが提唱するデータベースアクセス機構です。
OLEは，米国Microsoft Corporationが開発したソフトウェア名称です。
OracleとJavaは，Oracle Corporation 及びその子会社，関連会社の米国及びその他の国における登録商標です。
PostScriptは，米国Adobe Systems, Inc.が開発した言語仕様です。
QRコードは，株式会社デンソーウェーブの登録商標です。
Red Hatは，米国およびその他の国でRed Hat, Inc.の登録商標もしくは商標です。
RPMは，RPM Package Managerの略称です。
RSAは，EMC Corporationの米国およびその他の国における登録商標または商標です。
SQL Serverは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
UNIXは，The Open Groupの米国ならびに他の国における登録商標です。
Windowsは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
Windows Serverは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
中ゴシックBBBは，株式会社モリサワとアドビシステムズ社が共同開発したフォントで承認外の複製は禁止されており，それらの書体名は株式会社モリサワの商標です。
リュウミンL-KLは，株式会社モリサワとアドビシステムズ社が共同開発したフォントで承認外の複製は禁止されており，それらの書体名は株式会社モリサワの商標です。
その他記載の会社名，製品名は，それぞれの会社の商標もしくは登録商標です。

プログラムプロダクト「P-29D2-5C94，P-1JD2-5C91，P-1MD2-5C91およびP-82D2-5C91」は，EMC CorporationのRSA BSAFE(R)ソフトウェアを搭載しています。

■ マイクロソフト製品の表記について

このマニュアルでは，マイクロソフト製品の名称を次のように表記しています。
表記 | 製品名称
.NET | Microsoft(R) .NET
ActiveX | ActiveX(R)
Excel Microsoft(R) Excel Version 2002
Microsoft(R) Office Excel 2003
Microsoft(R) Office Excel 2007
Microsoft(R) Office Excel 2010
Internet Explorer | Microsoft(R) Internet Explorer(R)
Windows(R) Internet Explorer(R)
SQL Server Microsoft(R) SQL Server 2005
Microsoft(R) SQL Server 2008
Microsoft(R) SQL Server 2008 R2
VBScript | Microsoft(R) Visual Basic(R) Scripting Edition
Visual Basic | Microsoft(R) Visual Basic(R)
Visual C++ | Microsoft(R) Visual C++(R)
Windows Windows 7 Windows 7 x86 Microsoft(R) Windows(R) 7 Professional(32ビット版)
Microsoft(R) Windows(R) 7 Enterprise(32ビット版)
Microsoft(R) Windows(R) 7 Ultimate(32ビット版)
Windows 7 x64 Microsoft(R) Windows(R) 7 Professional(64ビット版)
Microsoft(R) Windows(R) 7 Enterprise(64ビット版)
Microsoft(R) Windows(R) 7 Ultimate(64ビット版)
Windows Server 2003 Windows Server 2003 Microsoft(R) Windows Server(R) 2003, Standard Edition
Microsoft(R) Windows Server(R) 2003, Enterprise Edition
Windows Server 2003 R2 Microsoft(R) Windows Server(R) 2003 R2, Standard Edition
Microsoft(R) Windows Server(R) 2003 R2, Enterprise Edition
Windows Server 2003 R2 x64 Microsoft(R) Windows Server(R) 2003 R2, Standard x64 Edition
Microsoft(R) Windows Server(R) 2003 R2, Enterprise x64 Edition
Windows Server 2003 x64 Microsoft(R) Windows Server(R) 2003, Standard x64 Edition
Microsoft(R) Windows Server(R) 2003, Enterprise x64 Edition
Windows Server 2008 Microsoft(R) Windows Server(R) 2008 R2 Standard
Microsoft(R) Windows Server(R) 2008 R2 Enterprise
Microsoft(R) Windows Server(R) 2008 R2 Datacenter
Windows XP Microsoft(R) Windows(R) XP Professional Operating System
Microsoft(R) Windows(R) XP Home Edition Operating System
Word Microsoft(R) Word Version 2002
Microsoft(R) Office Word 2003
Microsoft(R) Office Word 2007
Microsoft(R) Office Word 2010

■ 発行

2012年3月　3020-7-713

■ 著作権

All Rights Reserved. Copyright (C) 2012, Hitachi, Ltd.
All Rights Reserved. Copyright (C) 2012, Hitachi Solutions, Ltd.

[目次][前へ][次へ]


他社商品名称に関する表示

■ 商標類

Acrobatは，Adobe Systems Incorporated（アドビシステムズ社）の商標です。
ActiveXは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
Adobe，およびFlashは，Adobe Systems Incorporated(アドビシステムズ社)の米国ならびに他の国における商標または登録商標です。
Adobe，およびReaderは，Adobe Systems Incorporated(アドビシステムズ社)の米国ならびに他の国における商標または登録商標です。
AIXは，米国およびその他の国におけるInternational Business Machines Corporationの商標です。
AMDは，Advanced Micro Devices, Inc.の商標です。
BSAFEは，EMC Corporationの米国およびその他の国における登録商標または商標です。
ESC/Pは，セイコーエプソン(株)の商標です。
GIFは，米国CompuServe Inc.が開発したフォーマットの名称です。
HP-UXは，Hewlett-Packard Development Company, L.P.のオペレーティングシステムの名称です。
Internet Explorerは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
Itaniumは，アメリカ合衆国およびその他の国におけるIntel Corporationの商標です。
Linuxは，Linus Torvalds氏の日本およびその他の国における登録商標または商標です。
LIPSIIIは，キヤノン（株）が開発した言語仕様です。
MicrosoftおよびHyper-Vは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
MicrosoftおよびMS-DOSは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
MicrosoftおよびVisual Basicは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
MicrosoftおよびVisual C++は，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
Microsoft .NET は，お客様，情報，システムおよびデバイスを繋ぐソフトウェアです。
Microsoft Excelは，米国Microsoft Corporationの商品名称です。
Microsoft Officeは，米国Microsoft Corporationの商品名称です。
Microsoft Office Excelは，米国 Microsoft Corporation の商品名称です。
Microsoft Office Wordは，米国 Microsoft Corporation の商品名称です。
Microsoft Wordは，米国Microsoft Corporationの商品名称です。
ODBCは，米国Microsoft Corporationが提唱するデータベースアクセス機構です。
OLEは，米国Microsoft Corporationが開発したソフトウェア名称です。
OracleとJavaは，Oracle Corporation 及びその子会社，関連会社の米国及びその他の国における登録商標です。
PostScriptは，米国Adobe Systems, Inc.が開発した言語仕様です。
QRコードは，株式会社デンソーウェーブの登録商標です。
Red Hatは，米国およびその他の国でRed Hat, Inc.の登録商標もしくは商標です。
RPMは，RPM Package Managerの略称です。
RSAは，EMC Corporationの米国およびその他の国における登録商標または商標です。
SQL Serverは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
UNIXは，The Open Groupの米国ならびに他の国における登録商標です。
Windowsは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
Windows Serverは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
中ゴシックBBBは，株式会社モリサワとアドビシステムズ社が共同開発したフォントで承認外の複製は禁止されており，それらの書体名は株式会社モリサワの商標です。
リュウミンL-KLは，株式会社モリサワとアドビシステムズ社が共同開発したフォントで承認外の複製は禁止されており，それらの書体名は株式会社モリサワの商標です。
その他記載の会社名，製品名は，それぞれの会社の商標もしくは登録商標です。

プログラムプロダクト「P-29D2-5C94，P-1JD2-5C91，P-1MD2-5C91およびP-82D2-5C91」は，EMC CorporationのRSA BSAFE(R)ソフトウェアを搭載しています。

[目次]


はじめに

このマニュアルは，次に示すプログラムプロダクトを使用して，データベースから抽出したデータを帳票に出力する方法について説明したものです。

  • uCosminexus EUR：イーユーアール Designer
  • uCosminexus EUR：イーユーアール Developer
  • uCosminexus EUR：イーユーアール Viewer
  • uCosminexus EUR：イーユーアール Server Standard
  • uCosminexus EUR：イーユーアール Server Enterprise
  • uCosminexus EUR：イーユーアール Server Print Edition
  • uCosminexus EUR：イーユーアール Server - Cipher option

以降，「EUR：イーユーアール」を「EUR」と表記します。

＜はじめにの構成＞
対象読者
このマニュアルの文法で使用する記号
このマニュアルのGUIの説明で使用する記号

対象読者

このマニュアルは，データベースから抽出したデータを使って帳票を作成および出力する方，およびEUR 帳票作成機能のデータベースアクセス定義ウィンドウを使用する方を対象としています。なお，次の内容を理解されていることを前提としています。

  • 使用するデータベースに関する基本的な知識

このマニュアルの文法で使用する記号

このマニュアルで使用する記号について，次に示します。

記　号 意　　味
｜ 横に並べられた複数の項目に対する項目間の区切りを示し，「または」を意味します。
（例）A｜B
「A，またはBを指定する」ことを示します。
｛　｝ この記号で囲まれている複数の項目のうちから一つを選択することを示します。項目が横に並べられ，記号｜で区切られている場合は，そのうちの一つを選択します。
（例）｛A｜B｜C｝
「A，B，またはCのどれかを指定する」ことを示します。
〔　〕 この記号で囲まれている項目は省略してもよいことを示します。複数の項目が横に並べて記述されている場合には，すべてを省略するか，記号｛　｝と同じくどれか一つを選択します。
（例）〔A〕
「何も指定しない」か「Aと指定する」ことを示します。
（例）〔B｜C〕
「何も指定しない」か「B，またはCのどちらかを指定する」ことを示します。
…
記述が省略されていることを示します。この記号の直前に示された項目を繰り返し複数個指定できます。
（例）〔A〔,…〕〕
「Aのあとに，Aを複数個指定できる」ことを示します。
＿ 括弧で囲まれた複数項目のうち1項目に対し使用され，括弧内のすべてを省略したときシステムが採る標準値を示します。
（例）〔A｜B｜C〕
「A，B，Cのどれも指定しなかった場合，システムはCが指定されたときと同じ処理をする」ことを示します。

このマニュアルのGUIの説明で使用する記号

このマニュアルでは，次に示す記号を使用してGUIを説明しています。

記　号 意　　味
＜　＞ 文字キーを表します。
＜　＞＋＜　＞ ＋の前のキーを押したまま，後ろのキーを押すことを表します。
［　］ メニュー項目，ダイアログ名，ダイアログのボタンを表します。
［　］－［　］ メニュー項目を連続して選択することを表します。
（例）［ファイル］－［開く］
［ファイル］メニューから［開く］メニューを選択することを表します。


データベースからEURにデータを読み込むには

1.　データベースからEURにデータを読み込むには

この章では，EURでのデータベース接続の概要や，使用できるデータベースおよびODBC Driverについて説明しています。

＜この章の構成＞
1.1　データベースからデータを読み込む流れ
1.2　EURで使用できるデータベース
1.3　EURで使用できるODBC Driver


データベースからデータを読み込む流れ

1.1　データベースからデータを読み込む流れ

EURでは，データベースのデータを入力した帳票を作成・出力できます。データベースからデータを読み込む流れについて，機能ごとに説明します。

＜この節の構成＞
1.1.1　EUR 帳票作成機能でのデータを読み込む流れ
1.1.2　EUR クライアント帳票出力機能でのデータを読み込む流れ
1.1.3　EUR サーバ帳票出力機能でのデータを読み込む流れ


EUR 帳票作成機能でのデータを読み込む流れ

1.1.1　EUR 帳票作成機能でのデータを読み込む流れ

EUR 帳票作成機能でのデータを読み込む流れについては，「3.　帳票作成時のデータベースからのデータの読み込み」を参照してください。


EUR クライアント帳票出力機能でのデータを読み込む流れ

1.1.2　EUR クライアント帳票出力機能でのデータを読み込む流れ

システム管理者は，DABrokerを使用して，データベースの接続に必要な環境を設定します。データベースの接続設定については，「2.　データベースの接続設定」を参照してください。

データベースからのデータ入力の流れを次に示します。

図1-1　データベースからのデータ入力の流れ（EUR クライアント帳票出力機能）

  1. 帳票ファイルの配布
    帳票を使用するクライアントに帳票ファイルを配布します。
  2. データベースの接続
    データベースに接続します。EUR クライアント帳票出力機能の1回の実行で接続できるデータベースは一つだけです。
  3. データの抽出
    データベースからデータを抽出します。
  4. 帳票出力
    配布された帳票ファイルに抽出したデータを読み込んで，帳票を出力します。

データの入力元としてCSV形式のデータファイルを使用する場合とは異なり，データベースに接続してデータを取得します。データベースからデータを入力するには，次に示すファイルを使用します。

  • 接続情報ファイル
  • 可変記号値定義ファイル

接続情報ファイルの詳細については「4.1　接続情報ファイル」を，可変記号値定義ファイルの詳細については「4.2　可変記号値定義ファイル」を参照してください。

ただし，すべての帳票セットのマッピングデータおよびユーザ定義データの入力元として指定できるデータベースは，一つだけです。


EUR サーバ帳票出力機能でのデータを読み込む流れ

1.1.3　EUR サーバ帳票出力機能でのデータを読み込む流れ

システム管理者は，DABrokerを使用して，データベースの接続に必要な環境を設定します。データベースの接続設定については，「2.　データベースの接続設定」を参照してください。

データベースからのデータ入力の流れを次に示します。

図1-2　 データベースからのデータ入力の流れ（EUR サーバ帳票出力機能）

データの入力元としてCSV形式のデータファイルを使用する場合とは異なり，データベースに接続してデータを取得します。データベースからデータを入力するには，次に示すファイルを使用します。

  • 接続情報ファイル
  • 可変記号値定義ファイル

接続情報ファイルの詳細については「4.1　接続情報ファイル」を，可変記号値定義ファイルの詳細については「4.2　可変記号値定義ファイル」を参照してください。

ただし，すべての帳票セットのマッピングデータおよびユーザ定義データの入力元として指定できるデータベースは，一つだけです。


EURで使用できるデータベース

1.2　EURで使用できるデータベース

EURが接続できるデータベースは，次に示す3種類です。

  • HiRDB
  • Oracle
  • SQL Server

EURとデータベースを接続するには，あらかじめデータベース接続に必要な環境を設定しておく必要があります。

＜この節の構成＞
1.2.1　ロケールごとの接続可否
1.2.2　使用できる文字コードの一覧
1.2.3　データ型の一覧
1.2.4　使用できる文字の注意事項


ロケールごとの接続可否

1.2.1　ロケールごとの接続可否

EURのロケールごとの，接続できるデータベースを次に示します。

表1-1　ロケールごとの接続可否

データベース | EURのロケール
 | 英語ロケール | 中国語ロケール | 日本語ロケール
HiRDB | × | × | ○
Oracle | ○ | ○ | ○
SQL Server | × | × | ○
（凡例）
○：接続できます。
×：接続できません。


使用できる文字コードの一覧

1.2.2　使用できる文字コードの一覧

データベースごとの，使用できる文字コードの一覧を次に示します。

表1-2　使用できる文字コードの一覧

データベース | Shift JIS | UTF-8※
HiRDB | ○ | ○
Oracle | ○ | ○
SQL Server | ○ | ○
（凡例）
○：使用できます。
×：使用できません。
注※
SQL ServerではUnicode文字列型（nchar，nvarchar，ntext）を使用します。


データ型の一覧

1.2.3　データ型の一覧

データベースのデータ型のうち，EURで扱えるデータ型を次に示します。

表1-3　データベースのデータ型とEURで扱えるデータ型

データベースごとのデータ型 |  | データベースアクセス定義でのデータ型（列属性）
HiRDB | CHARACTER(n) | CHAR
 | VARCHAR(n) | VARCHAR
 | NCHAR(n)，NATIONAL CHARACTER(n) | NCHAR
 | NVARCHAR(n) | NVARCHAR
 | MCHAR(n) | MCHAR
 | MVARCHAR(n) | MVARCHAR
 | DATE | DATE
 | TIME | TIME
 | LARGE DECIMAL(m,n) | DECIMAL
 | FLOAT，DOUBLE PRECISION | FLOAT
 | INTEGER | INTEGER
 | SMALLFLT，REAL | REAL
 | SMALLINT | SMALLINT
Oracle | CHAR(n) | CHAR
 | VARCHAR2(n) | VARCHAR
 | LONG | LONG VARCHAR
 | DATE | TIMESTAMP
 | RAW | VARBINARY
 | FLOAT | FLOAT
 | NUMBER(p,s) ※1 | NUMERIC
SQL Server | char | CHAR
 | varchar | VARCHAR
 | text | LONG VARCHAR
 | nchar | UCHAR ※2
 | nvarchar | UVARCHAR ※2
 | ntext | LONG UVARCHAR ※2
 | datetime，smalldatetime | TIMESTAMP
 | binary，timestamp | BINARY
 | varbinary | VARBINARY
 | bit | BIT
 | decimal，money，smallmoney | DECIMAL
 | float | DOUBLE
 | int | INTEGER
 | numeric | NUMERIC
 | real | REAL
 | smallint | SMALLINT
 | tinyint | TINYINT
注※1
Oracleのデータ型「NUMBER（精度・位取りなし）」（浮動小数点数）を［条件設定］ダイアログで表示すると，「列属性：NUMERIC（38,0）」となり，「38桁小数部なしの固定小数点数」と見なされます。そのため，EUR 帳票作成機能では，列の条件値や可変記号の初期値に，小数点付きのデータは指定できません。ただし，EUR サーバ帳票出力機能またはEUR クライアント帳票出力機能で帳票を出力する場合は，この型を浮動小数点数として扱うので，可変記号値に小数点付きの値を抽出条件として指定できます。
注※2
Unicodeデータを抽出する場合だけ使用できます。


使用できる文字の注意事項

1.2.4　使用できる文字の注意事項

データベース連携で使用できる文字についての注意を次に示します。

  • データベースの文字コードごとに，次の注意事項があります。
    Shift JISデータベースの場合
    データベースに格納されているデータは，DABrokerの動作環境設定の「漢字コードセット（DABLANGMODE）」に「SJIS」を指定してShift JISで取り出してください。DABroker動作環境設定については「2.3.4　DABrokerの動作環境の設定」を参照してください。Shift JISコードの文字とは，次のような文字です。
    ・1バイト文字で0x20～0x7E，または0xA1～0xDF
    ・2バイト文字で1バイト目が，0x81～0x9F，または0xE0～0xFC
    ・2バイト文字で2バイト目が，0x40～0x7E，または0x80～0xFC
    例えば，CHAR属性の列に0x00が入っている場合は，0x00以降のデータは取り出されません。データを取り出す対象となる列に0x00から始まるデータが格納されている場合は，NULL値となります。
    データを取り出す対象となる列にバイナリデータが格納されている場合は，文字列として取り出されます。
    Unicodeデータベースの場合
    データベースに格納されているデータは，DABrokerの動作環境の「漢字コードセット(DABLANGMODE)」に「UTF-8」を指定して，UTF-8で取り出してください。UTF-8は，次のような文字です。
    UTF-8 | 文字の種類
    1バイト目 | 2バイト目 | 3バイト目
    00-7F － － 制御コード
    ASCII文字
    C0-DF 80-BF － UCS-2マルチバイト文字（0x0080-0x07FF）
    E0-EF | 80-BF | 80-BF | UCS-2マルチバイト文字（0x0800-0xFFFF）
    （凡例）
    －：該当しません。

    サポート文字は，ASCII文字(X'20'～X'7E')，UCS-2マルチバイト文字(0x0080-0x07FF，0x0800-0xFFFF)の範囲です。サロゲートペアにも対応します。
    サポートしていない文字が指定されていた場合，データベースに格納されているデータと異なる文字で出力されることがあります。
  • データベース連携では，0バイト定数とNULL値はどちらもNULL値として扱われ，区別されません。0バイト定数とNULL値を区別してデータを設計しないようにしてください。
  • Shift JISデータベースの場合，データはShift JISコードでデータベースに格納してください。
  • 表名や列名に「"」が含まれている場合は，正しく動作しません。
  • 上記以外の文字コードを含むデータを抽出した場合の動作は保証しません。


EURで使用できるODBC Driver

1.3　EURで使用できるODBC Driver

EUR 帳票作成機能でデータベースと接続するためにはODBC Driverが必要です。

EURで使用できるODBC Driverと抽出できるデータの文字コードを次に示します。

  • EUR ODBC Driver
    EUR ODBC DriverはEUR専用のODBC Driverです。EURをインストールすると，自動的にインストールされます。
    EUR ODBC Driverは，Shift JISデータベースとUnicodeデータベースに接続できます。
  • DBPARTNER ODBC Driver
    DBPARTNER ODBC DriverはEUR Developerにだけ同梱されています。
    DBPARTNER ODBC Driverは，Shift JISデータベースにだけ接続できます。旧バージョンとの互換用であるため，通常はEUR ODBC Driverを使用してください。

EUR帳票作成機能でデータベース接続に使用するODBCデータソースは，ODBC Driverで設定してください。ODBC Driverを設定する手順については，「2.6.2　ODBCデータソースの設定」を参照してください。

＜この節の構成＞
1.3.1　抽出するデータの文字コードをUTF-8とした場合の制限事項


抽出するデータの文字コードをUTF-8とした場合の制限事項

1.3.1　抽出するデータの文字コードをUTF-8とした場合の制限事項

EURを実行する環境のロケールによって，次のような制限事項があります。

＜この項の構成＞
(1)　英語ロケールのとき
(2)　中国語ロケールのとき
(3)　日本語ロケールのとき

(1)　英語ロケールのとき

データベースに接続するユーザID，表の所有者名，表名，列名の文字コードはANSI（ASCII（0x20～0x7E））となります。

(2)　中国語ロケールのとき

データベースに接続するユーザID，表の所有者名，表名，列名の文字コードはANSI（ASCII（0x20～0x7E）およびGB2312）となります。

(3)　日本語ロケールのとき

データベースに接続するユーザID，表の所有者名，表名，列名の文字コードはANSI（ASCII（0x20～0x7E）およびShift JIS）となります。


データベースの接続設定

2.　データベースの接続設定

この章では，EURの関連プログラムプロダクト「DABroker」を使用して，データベースに接続するために必要な環境設定を行う方法について説明します。また，EUR 帳票作成機能で使用する「ODBC Driver」の設定方法についても説明します。

＜この章の構成＞
2.1　データベースの接続の概要
2.2　データベースの接続設定の流れ
2.3　DABrokerのセットアップ
2.4　DABrokerの起動と終了
2.5　EURからDABrokerに接続するための設定
2.6　ODBC Driverの設定


データベースの接続の概要

2.1　データベースの接続の概要

データベースからデータを抽出する場合，EURの関連プログラムプロダクト「DABroker」を使用してデータベースに接続します。また，EUR 帳票作成機能では「ODBC Driver」も使用します。

EURに同梱しているDABrokerを使用する場合のシステム構成，マシン環境とその概要を，帳票作成時と帳票出力時に分けて説明します。

帳票作成時
EUR DeveloperのEUR 帳票作成機能から，ODBC Driverを使用してDABrokerに接続します。この際，ODBC Driverで接続先のDABrokerを指定する必要があります。

注※
ODBC Driverは，EURをインストールすると，自動的にインストールされます。
帳票出力時
EUR DeveloperのEUR クライアント帳票出力機能，またはEUR Server製品のEUR サーバ帳票出力機能から，DABrokerに接続します。この際，接続情報ファイルで接続先のDABrokerを指定する必要があります。

なお，DABrokerをEURとは別のマシンやサーバにインストールした構成や，データベースとは別のサーバにインストールした構成にもできます。

DABrokerの設定とODBC Driverの設定については，「2.2　データベースの接続設定の流れ」以降で説明します。接続情報ファイルの詳細については，「4.1　接続情報ファイル」で説明します。

なお，これらの説明は，次に示す条件を前提にしています。

  • データベースを使用できる環境が構築されていること
  • EURをインストールするマシン，およびDABrokerをインストールするマシンをネットワーク上で使用できる環境がすでに構築されていること


データベースの接続設定の流れ

2.2　データベースの接続設定の流れ

データベースを接続する場合の流れを次に示します。

  1. DABrokerのセットアップを実施します。
    詳細は，「2.3　DABrokerのセットアップ」を参照してください。
  2. EURからデータベースに接続するための設定をします。
    詳細は，「2.3.5　データベースごとの設定」を参照してください。
  3. DABrokerを起動します。
    詳細は，「2.4　DABrokerの起動と終了」を参照してください。
  4. DABrokerに接続します（EUR クライアント帳票出力機能またはEUR サーバ帳票出力機能からデータベースに接続する場合）。
    詳細は，「2.5　EURからDABrokerに接続するための設定」を参照してください。
  5. ODBC Driverを設定します（EUR 帳票作成機能からデータベースに接続する場合）。
    詳細は，「2.6　ODBC Driverの設定」を参照してください。


DABrokerのセットアップ

2.3　DABrokerのセットアップ

ここでは，Windows環境に，EURに同梱しているDABrokerをインストールし，セットアップする方法について説明します。

参考
UNIX/Linux環境など別途DABrokerを購入している場合は，この節の説明を参考にDABrokerの設定を実行してください。

DABrokerをインストールし，環境設定を完了するまでの手順を次の図に示します。

図2-1　DABrokerセットアップの手順

＜この節の構成＞
2.3.1　DABrokerをインストールする環境
2.3.2　インストール
2.3.3　ネットワーク環境の設定
2.3.4　DABrokerの動作環境の設定
2.3.5　データベースごとの設定


DABrokerをインストールする環境

2.3.1　DABrokerをインストールする環境

EURに同梱しているDABrokerは，EURと同じマシンにインストールしてください。

参考
EUR Developerは32bit版のDABrokerを，EUR Serverは64bit版のDABroker(64)を同梱しています。

DABrokerはリレーショナルデータベースのクライアントアプリケーションとなるため，データベースと接続するにはリレーショナルデータベースのクライアントプログラムが必要です。データベースの接続設定については，「2.5　EURからDABrokerに接続するための設定」を参照してください。

必要な関連プログラムの詳細については，リリースノートを参照してください。

32bit版DABrokerを使用する場合
リレーショナルデータベースの32bitクライアントプログラムが必要です。
64bit版DABroker(64)を使用する場合
リレーショナルデータベースの64bitクライアントプログラムが必要です。


インストール

2.3.2　インストール

DABrokerをインストールするには，「DABroker.msi」を実行してください。

「DABroker.msi」は，EUR DeveloperおよびEUR Server製品（EUR Server Print Edition，EUR Server Standard，EUR Server Enterprise）のインストール先フォルダ\Component\DABROKER\下にあります。

注意
次に示す文字が含まれているディレクトリに，DABrokerをインストールしないでください。
インストールディレクトリに指定できない文字
()="'#\
64bit OSに32bit版DABrokerをインストールする場合は，製品インストール時に表示されるデフォルトのインストール先のディレクトリが「C:\Program Files (x86)\Hitachi\DABroker」になっているため，必ずディレクトリを変更してください。

インストールしたあと，次のように設定してください。

環境変数を設定する
DABrokerをインストールしたあと，システム環境変数のPathに「DABrokerインストールディレクトリ\lib」を必ず設定してください。環境変数を設定し，マシンを再起動すると，DABrokerを使用できるようになります。
＜この項の構成＞
(1)　インストール時に作成されるディレクトリ
(2)　DABroker(64)使用時の注意事項

(1)　インストール時に作成されるディレクトリ

DABrokerのインストール時に作成されるディレクトリを次の表に示します。これらのディレクトリは，DABrokerのインストール先に指定したディレクトリの下に作成されます。

なお，DABrokerのインストール先に指定したディレクトリを，これ以降DABroker運用ディレクトリと呼びます。

表2-1　DABrokerのディレクトリ

ディレクトリ |  | 説明
DABroker | － | DABrokerのインストール先ディレクトリ （＝DABroker運用ディレクトリ）
 | \bin | 実行ファイル格納ディレクトリ
 | \lib | ライブラリ格納用ディレクトリ
 | \AGT | エージェント処理用ディレクトリ
 | \AGTGRP | グループ管理用ディレクトリ
 | \msg | メッセージ用ディレクトリ
 | \conf | DABroker動作環境定義ファイル格納ディレクトリ
 | \spool | DABrokerスプールディレクトリ
 | \tmp | DABroker標準作業ディレクトリ
（凡例）
－：該当するディレクトリはありません。

(2)　DABroker(64)使用時の注意事項

DABroker(64)を動作させるには，Microsoft Visual C++ 2005 Service Pack 1 再頒布可能パッケージのセキュリティ更新プログラムが必要になる場合があります。セキュリティ更新プログラムはMicrosoft社のホームページからダウンロードしてください。


ネットワーク環境の設定

2.3.3　ネットワーク環境の設定

TCP/IP環境でのDABrokerのサービス名およびポート番号として，「Windowsインストールディレクトリ\system32\drivers\etc\services」ファイルに次の記述を追加してください。DABrokerのサービス名の指定は省略できません。

参考
UNIX／Linux環境の場合，servicesファイルは「/etc」に格納されています。
DABROKER_SV　40179/tcp
DABROKER_SV：DABrokerのサービス名です。
40179：ポート番号です。
tcp：プロトコル名です。TCP/IPを使用することを示します。
注意
  • servicesファイルでの設定で，40179がほかのサービス名で使用されている場合は，5001～65535の範囲内で任意の番号を指定してください。ただし，ポート番号はクライアント側と同じ番号を指定してください。
  • NIS（Network Information Service）を使用している場合，ネットワーク環境をNISのサーバで設定してください。NISのサーバを使用している場合，ネットワーク環境の設定は，NISのサーバでの設定が有効になります。
  • クライアント側では，DABrokerの組み込まれたサーバのホスト名，IPアドレスおよびポート番号を別途登録してください。


DABrokerの動作環境の設定

2.3.4　DABrokerの動作環境の設定

ここでは，DABrokerの動作環境を設定する操作について説明します。DABroker(64)を使用する場合も，必要な設定内容は同じです。

＜この項の構成＞
(1)　環境設定の方法
(2)　操作できるユーザ
(3)　操作方法
(4)　［共通設定］タブの設定内容
(5)　［リモートアクセス設定］タブの設定内容

(1)　環境設定の方法

DABroker動作環境は，「DABroker動作環境定義ファイル」を設定して定義します。このファイルの定義にはDABrokerが提供する環境設定ユティリティを使用します。環境設定ユティリティは，プログラムフォルダに登録された［DABroker環境設定］から起動します。

参考
UNIX/Linux環境の場合，DABroker動作環境定義ファイルは，「DABroker運用ディレクトリ/conf」に格納されています。

(2)　操作できるユーザ

環境設定ユティリティを実行して，DABroker動作環境定義ファイルを操作できるのは，Windowsの管理者グループまたはAdministratorsグループに属するユーザです。

(3)　操作方法

環境設定ユティリティは，DABrokerが終了している状態で使用します。環境設定後にDABrokerを起動すると，変更したDABroker動作環境定義ファイルの内容が有効になります。

操作方法を次に示します。

  1. プログラムフォルダに登録された［環境設定］を起動する
    環境設定ユティリティが起動し，［DABroker動作環境設定］ダイアログが表示されます。
  2. ［共通設定］タブ，および［リモートアクセス設定］タブの項目を設定する
  3. 設定内容を確認して［OK］ボタンを選択する
    設定した内容が登録され，環境設定ユティリティは終了します。

(4)　［共通設定］タブの設定内容

記載のない項目については，次の図に示す標準値のままで使用してください。

図2-2　［共通設定］タブの設定内容

  1. 作業ディレクトリ名（DABTMP）
    標準値
    DABroker運用ディレクトリ\tmp
    指定範囲
    任意のディレクトリ（ただし，パーティションを圧迫しないところ）。ただし，ネットワークドライブ上のディレクトリは指定できません。また，指定したディレクトリのアクセス権限として，システムにフルコントロールを指定してください。
    説明
    DABrokerの作業ディレクトリを指定します。このディレクトリは，予約処理用のSQLの格納や，処理途中で作成される一時ファイルの格納などに使用されます。
    ［...］ボタンを押すと，［ディレクトリ選択］ダイアログが表示されます。
  2. ログファイルサイズ［dabsv.log］（DABSVLOGSIZE）
    標準値
    64（キロバイト）
    指定範囲
    0，または64～32,767（キロバイト）
    説明
    DABrokerのログを取得するファイルの容量を設定します。ログはDABroker運用ディレクトリ\spool\dabsv.logに取得されます。
    0を設定した場合
    ファイルの容量は無限大になります。
    64～32,767を設定した場合
    設定した値がファイルの容量になります。
    注意
    ログファイルが満杯になったら，ラップアラウンドでログを取得します。ラップアラウンドした場合，1世代前のバックアップファイル（dabsv.logold）を作成し，1世代だけを管理します。
  3. 使用するORACLEのバージョン（DABORACLE_TYPE）
    標準値
    ORACLE9i
    指定範囲
    ORACLE9i，ORACLE 10g，またはORACLE 11g
    説明
    使用するOracleのバージョンを設定します。
    注意
    DABroker(64)ではORACLE9iは指定できません。また，標準値はORACLE10gとなります。
  4. HiRDBのディクショナリ表のデータ属性（DABSQL_HiRDB_DICTIONARY_DATATYPE）
    標準値
    C：VARCHAR
    指定範囲
    MまたはC
    説明
    HiRDBのディクショナリ表の列属性を指定します。
    Mを設定した場合
    混在文字データ（MVARCHAR）として処理します。
    Cを設定した場合
    文字データ（VARCHAR）として処理します。
    注意
    ここでの指定とHiRDBで使用されているディクショナリ表のデータ属性が異なる場合は，結果不正やSQLエラーになる場合があります。
  5. HiRDB環境変数区切り文字（DAB_HIRDB_DBINF_ESC）
    標準値
    @
    指定範囲
    @　!　$　%　&　*　+　-　/　:　?　\　|
    説明
    HiRDB環境変数区切り文字を指定します。
    注意
    特に問題がない場合，区切り文字には@を使用してください。
    区切り文字は必ず半角1文字で指定してください。全角文字は指定できません。
    DABroker Driver for JavaTM TechnologyからHiRDBクライアント環境変数グループを指定してデータベースと接続する場合は，標準値「@」を指定してください。
  6. データベースアクセストレースを取得する（DABSQL_TRCSIZE）
    標準値
    OFF（取得しません）
    指定範囲
    OFF（チェックなし），またはON（チェックあり）
    （OFF：取得しません　ON：取得します）
    説明
    データベースアクセストレースを取得するかどうかを設定します。アクセストレースの出力については，「付録A.1(2)　DABrokerトレース出力ユティリティ」を参照してください。
    ［データベースアクセストレース設定］ボタンを押すと［アクセストレース設定］ダイアログが表示され，アクセストレースで出力する項目を選択できます。
    取得するを設定した場合
    次に示すファイル名ですべてのアクセストレースを取得するファイルが，DABroker運用ディレクトリ\spool\db_accessの下に作成されます（データベースアクセストレースはDABrokerトレース出力ユティリティで出力します）。
    db_XXXXX
    XXXXX：システム任意の番号
    ハードディスクの空き容量がなくなった場合，それ以降のアクセストレースは取得しません。なお，格納する領域のサイズは設定できません。
    クライアントからの要求量が多い場合は，トレースのファイル容量も多く必要です。ハードディスクの容量に余裕をもたせてください。必要容量の概算方法については，「付録A.1(2)　DABrokerトレース出力ユティリティ」のデータベースアクセストレースの出力の注意事項を参照してください。また，クライアントからの要求量が多ければ，DABrokerを終了するまでに時間が掛かります。ご注意ください。
    取得しないを設定した場合
    データベースアクセストレースを取得しません。
  7. 拡張データベースアクセストレースを取得する（DABEXSQL_TRC_LINE）
    標準値
    OFF（取得しません）
    指定範囲
    OFF（チェックなし），またはON（チェックあり）
    （OFF：取得しません　ON：取得します）
    説明
    拡張データベースアクセストレースを取得するかどうかを設定します。
    OFF（チェックなし）を設定した場合
    拡張データベースアクセストレースを取得しません。
    ON（チェックあり）を設定した場合
    拡張データベースアクセストレースを取得します。
    拡張データベースアクセストレースの詳細については，「付録A.1(3)　拡張データベースアクセストレースユーティリティ」を参照してください。
  8. トレースファイルサイズ
    標準値
    1,024（行）
    指定範囲
    0（トレース取得行数を無限大にします），または1,024～32,767（行）
    説明
    「7.拡張データベースアクセストレースを取得する（DABEXSQL_TRC_LINE）」でONを設定した場合に，拡張データベースアクセストレースのトレースファイルサイズを指定します。
    0を設定した場合
    出力行数は，無限大となります。
    1,024～32,767を設定した場合
    拡張データベースアクセストレースを取得します。出力行数は，設定した数値分となります。
    拡張データベースアクセストレースのファイルは，1行に134バイトまで出力されます。拡張データベースアクセストレースのファイルの出力行数は，ここでの設定値に従います。ただし，ヘッダは行数に含まれません。
    拡張データベースアクセストレースの詳細については，「付録A.1(3)　拡張データベースアクセストレースユーティリティ」を参照してください。

(5)　［リモートアクセス設定］タブの設定内容

図2-3　［リモートアクセス設定］タブの設定内容

  1. クライアントからの要求待ちタイムアウト（DABCLIENT_TIMEOUT）
    標準値
    3,600（秒）
    指定範囲
    0，または1～65,535（秒）
    説明
    クライアントからの要求待ちタイムアウトを監視するかどうかを設定します。
    1～65,535（秒）を設定した場合
    DABrokerがアクセス要求に対する応答をクライアントに返してから，次のアクセス要求を受けるまでの時間を監視します。
    ここで設定した時間を超えてクライアントからのアクセス要求がない場合，DABrokerは次の処理をします。
    クライアントに対しては，要求待ちタイムアウトの発生を通知して，コネクションを解放します。処理を続ける場合，クライアントは一度終了して再起動する必要があります。
    データベースに対しては，このタイムアウトが発生したクライアントの処理がデータベースで実行中の場合は，トランザクションのロールバックを要求し，データベースを切り離します。
    0を設定した場合
    クライアントからの要求待ちタイムアウトを監視しません。
  2. 最大接続ユーザ数（DABMAXUSERS）
    標準値
    10（ユーザ）
    指定範囲
    1～100,000（ユーザ）
    説明
    コネクションを確立できる最大ユーザ数を設定します。ここで設定した値を超えるユーザが接続しようとした場合，DABrokerは，クライアントにエラーメッセージを返してコネクションを確立しません。
    EURから同時にデータベースをアクセスするユーザ数以上の値を指定してください。
  3. 同時実行可能なデータベースアクセス数（DABDBANUMBER）
    標準値
    20（データベース接続数）
    指定範囲
    1～100,000（データベース接続数）
    説明
    DABrokerが一度に受け付けられる，複数のクライアントからのデータベースアクセス要求（同期アクセス処理要求）の合計数を設定します。ここで設定した値を超える要求があった場合は，クライアントにエラーメッセージを返し，処理を受け付けません。
    EURで使用する場合は，最大接続ユーザ数以上の値を指定してください。
  4. 1プロセス当たりの実行ユーザ数（DABMAXBLOCKUSERS）
    標準値
    1（ユーザ数）
    指定範囲
    1～100（ユーザ数）
    説明
    一つのプロセスで処理する最大ユーザ数を設定します。ここで設定した値を超えた場合は，クライアントにエラーメッセージを返し，処理を受け付けません。
    EURで使用する場合は，1を指定してください。
  5. 最大処理プロセス数（DABMAXPROCESS）
    標準値
    10（プロセス数）
    指定範囲
    1～1,000（プロセス数）
    説明
    DABrokerで起動する最大プロセス数を設定します。ここで設定した値を超えた場合は，クライアントにエラーメッセージを返し，処理を受け付けません。
    （1プロセス当たりの実行ユーザ数×最大処理プロセス数）が最大接続ユーザ数以上となるように指定してください。
  6. 漢字コードセット（DABLANGMODE）
    標準値
    SJIS（シフトJISモード）
    指定範囲
    SJIS（シフトJISモード），UTF-8（UTF-8モード），またはASCII（ASCIIモード）
    説明
    DABrokerが稼働する言語モードを設定します。
    各言語モードで操作できるデータベースを次の表に示します。

    表2-2　各言語モードで操作できるデータベース

    データベース | DABrokerでの設定
    シフトJISモード | UTF-8モード | ASCIIモード
    HiRDB ○ ○ ○
    Oracle ○ ○ ○
    SQL Server ○ ○※ ○
    （凡例）
    ○：操作できる
    ×：操作できない
    注※
    SQL Server 2000の場合は操作できません。

    各データベースで使用する言語モードは，必ずDABrokerの言語モードと合わせてください。データベースとDABrokerの言語モードが異なっている場合は動作を保証しません。
    SQL Server 2005以降でUTF-16を使用する場合は，DABrokerの言語モードにUTF-8を指定してください。
    DABrokerを日本語EUCモード，ASCIIモード，またはUTF-8モードで動作させた場合，メッセージは英文で出力されます。
    DBPARTNER ODBC Driverを使用する場合，DABrokerの言語モードは，SJIS（シフトJISモード）を指定してください。
  7. TCP/IP通信時キープアライブを監視する（DABKEEPALIVE）
    標準値
    OFF（キープアライブによる監視を行いません）
    指定範囲
    OFF（チェックなし），またはON（チェックあり）
    （OFF：キープアライブによる監視を行いません　ON：キープアライブによる監視を行います）
    説明
    キープアライブによる監視を行うかどうかを設定します。キープアライブとは，クライアントとの通信経路が確立されているかどうかを常に監視するTCP/IPの機能です。
    ONを設定した場合
    キープアライブによる監視が行われます（クライアントとの通信径路を監視する）。
    OFFを設定した場合
    キープアライブによる監視は行われません（クライアントとの通信径路を監視しない）。
  8. IPアドレスからホスト名へ変換する（DABIPCONVERT）
    標準値
    ON（変換します）
    指定範囲
    OFF（チェックなし），またはON（チェックあり）
    （OFF：変換しません　ON：変換します）
    説明
    メッセージおよびユティリティで表示されるIPアドレスをホスト名に変換するかどうかを設定します。
    ONを設定した場合
    表示されるIPアドレスをホスト名に変換します。
    動作環境によってこの変換処理に時間が掛かり，接続処理が遅くなることがあります。
    OFFを設定した場合
    表示されるIPアドレスをホスト名に変換しません。
  9. 通信トレースの取得をする（DABTCP_TRCSIZE）
    標準値
    OFF（取得しません）
    指定範囲
    OFF（チェックなし），またはON（チェックあり）
    （OFF：取得しません　ON：取得します）
    説明
    クライアントとの通信トレースを取得するかどうかを設定します。通信トレースの出力については，「付録A.1(2)　DABrokerトレース出力ユティリティ」を参照してください。
    「取得する」を設定した場合
    次に示すファイル名ですべての通信トレースを取得するファイルがDABroker運用ディレクトリ\spool\dabcltrcの下に作成されます（通信トレースはDABrokerトレース出力ユティリティで出力します）。
    XXXXXXXX.cmt
    XXXXXXXX.cmt_AA～AA
    XXXXXXXX：任意の文字列
    AA～AA：任意の文字列
    ハードディスクの空き容量がなくなった場合，それ以降の通信トレースは取得しません。なお，格納するファイルサイズは設定できません。
    クライアントからの要求量が多い場合は，トレースのファイルの容量も多く必要です。ハードディスクの容量は余裕を持たせてください。必要容量の概算方法については，マニュアル「DABroker」を参照してください。また，クライアントからの要求量が多ければ，DABrokerを終了するまでに時間が掛かります。ご注意ください。
    「取得しない」を設定した場合
    クライアントとの通信トレースを取得しません。


データベースごとの設定

2.3.5　データベースごとの設定

ここでは，EURでDABrokerを経由してデータベースと接続する場合のデータベースごとの設定内容について説明します。

＜この項の構成＞
(1)　HiRDBを使用する場合の設定
(2)　Oracleを使用する場合の設定
(3)　SQL Serverを使用する場合の設定

(1)　HiRDBを使用する場合の設定

DABrokerがインストールされているマシンに，HiRDBのクライアントの設定をしてください。接続するHiRDBのPDHOSTおよびPDNAMEPORTの指定値をデータベースの接続情報に指定してください。そこで設定したホスト名，IPアドレスまたは接続ポート名を，データベースアクセス定義が使用するODBC Driverで指定してください。HiRDBのクライアントの設定については，マニュアル「HiRDB UAP開発ガイド」を参照してください。

(2)　Oracleを使用する場合の設定

(a)　Oracleのクライアントの設定

DABrokerがインストールされているマシンに，Oracleのクライアントの設定をしてください。そこで設定したネット・サービス名称をデータベースの接続情報に指定してください。Oracleのクライアントの設定については，Oracleのマニュアルを参照してください。

(b)　Oracleのバージョンの設定

Oracleに接続する場合，DABrokerの環境設定で，使用するOracleのバージョンを設定してください。

(c)　Oracleから抽出する文字コードをUTF-8とする場合

DABrokerがインストールされているマシンのシステム環境変数に，Oracleの環境変数NLS_LANGを指定してください。NLS_LANGについては，Oracleのマニュアルを参照してください。

（例）NLS_LANG=JAPANESE_JAPAN.UTF8

(3)　SQL Serverを使用する場合の設定

DABrokerがインストールされているマシンで，システムデータソースとして，SQL ServerのODBCデータソースを追加してください。SQL ServerのODBCデータソース追加時の設定で，「SQL Serverが，ログインIDの権限の確認を行う方法は？」に「ユーザーが入力するSQL Server用のログインIDとパスワードを使う」を選択してください。追加したSQL ServerのODBCデータソース名を，データベースの接続情報に指定してください。

注意
64bit OSで32bit版DABrokerを使用する場合は，WindowsディレクトリのSysWow64フォルダにあるODBCアドミニストレータ（odbcad32.exe）を使用する必要があります。


DABrokerの起動と終了

2.4　DABrokerの起動と終了

DABrokerの起動方法と終了方法について説明します。

＜この節の構成＞
2.4.1　起動
2.4.2　終了


起動

2.4.1　起動

(a)　操作できるユーザ

Windowsの管理者グループ，およびAdministratorsグループに属するユーザです。

(b)　起動順序

DABrokerを起動する場合は，次の順序で各プログラムを起動してください。

  1. リレーショナルデータベース
  2. DABroker
  3. EUR

1と2の順序は前後してもかまいません。

(c)　起動方法

DABrokerの起動方法には，次の二つがあります。

  • プログラムフォルダからの起動
    ［スタート］－［プログラム］で表示されるフォルダ［DABroker］から［起動］を選択してください。
  • サービスの開始による起動
    ［コントロールパネル］ダイアログで［サービス］を選択します。［サービス］ダイアログで［DABroker］を選択し，［開始］ボタンをクリックしてください。
    ［スタートアップの種別］を［自動］にすると，Windowsの起動と同時にDABrokerを起動できます。


終了

2.4.2　終了

(a)　操作できるユーザ

Windowsの管理者グループ，およびAdministratorsグループに属するユーザです。

(b)　終了順序

DABrokerを終了する場合は，次の順序で各プログラムを終了してください。

  1. EUR
  2. DABroker
  3. リレーショナルデータベース

2と3の順序は前後してもかまいません。

(c)　終了方法

DABrokerの終了方法を次に示します。

  • 通常の終了
    接続中のEURがない場合の終了方法です。
    1. ［スタート］－［プログラム］で表示されるフォルダ［DABroker］から［終了］を選択する
      ［DABroker終了］ダイアログが表示されます。
    2. 終了形態に「通常の終了」を選択し，［実行］ボタンを選択する
      確認のためのダイアログが表示されます。
    3. ［はい］を選択する
      DABrokerが終了します。
    接続中のEURがある場合はエラーメッセージが表示され，終了できません。接続中のクライアントの有無は，DABroker管理ユティリティで確認できます。DABroker管理ユティリティについては，「付録A.1　DABrokerの起動中に使用できるユティリティ」を参照してください。
  • 計画終了
    接続中のクライアントがある場合，すべての処理の終了を待ってDABrokerを終了する方法です。新たなEURからの接続要求は受け付けません。
    終了手順は「通常の終了」と同様です。ただし，手順2で終了形態に「計画終了」を選択してください。
  • 強制終了
    接続中のEURがあっても，処理を中断してDABrokerを強制的に終了する方法です。
    1. ［コントロールパネル］ダイアログで［サービス］を選択する
      ［サービス］ダイアログが表示されます。
    2. ［DABroker］を選択し，［停止］ボタンを選択する
      DABrokerが終了します。
計画終了を強制終了に変更する方法
計画終了中に［DABroker終了］ダイアログから強制終了を実行すると，計画終了を強制終了に変更できます。


EURからDABrokerに接続するための設定

2.5　EURからDABrokerに接続するための設定

クライアントやサーバでの帳票出力時にEURがDABrokerと別のマシンにインストールされている場合，DABrokerに接続するために次の設定をします。

EURがインストールされているマシンで，DABrokerのサービス名「DABROKER_SV」とポート番号を，servicesファイルに登録します。登録する内容は，「2.3.3　ネットワーク環境の設定」を参照し，同じ値にしてください。

サービス名の指定を省略した場合は，ポート番号に「40179」を使用します。

EUR 帳票作成機能で帳票を作成する場合は，「2.6　ODBC Driverの設定」を参照してください。


ODBC Driverの設定

2.6　ODBC Driverの設定

ここでは，EURで帳票を作成するためのODBC Driverの設定について説明します。ODBC Driverは，EUR 帳票作成機能をインストールしたマシンで設定します。

＜この節の構成＞
2.6.1　ポート番号の登録
2.6.2　ODBCデータソースの設定


ポート番号の登録

2.6.1　ポート番号の登録

EURをインストールしているマシンで，ODBC DriverがDABrokerと接続するためのサービス名「DBPARTNER_SV」とDABrokerが使用するポート番号を，servicesファイルに登録します。DABrokerが使用するポート番号には「2.3.3　ネットワーク環境の設定」で設定したポート番号を指定してください。サービス名の指定を省略した場合は，ポート番号に「40179」を使用します。

このサービス名は帳票作成時に使用します。クライアントやサーバでの帳票出力時には使用しません。なお，クライアントやサーバでの帳票出力時に使用するサービス名については，「2.5　EURからDABrokerに接続するための設定」を参照してください。

（記述例）
DBPARTNER_SV 40179/tcp


ODBCデータソースの設定

2.6.2　ODBCデータソースの設定

ODBC Driverに対して，DABrokerを使用してデータベースに接続するための設定をします。使用できるODBCドライバは，「EUR ODBC Driver」です。

ODBCドライバは，次の手順で設定します。

  1. スタートメニューの［設定］から，［コントロールパネル］を選択します。
  2. ［管理ツール］から，［データソース（ODBC）］を選択します。
    ［ODBCデータソース アドミニストレータ］ダイアログが表示されます。
  3. ［ODBCデータソース アドミニストレータ］ダイアログの［ユーザーDSN］タブにある［追加］ボタンをクリックします。
    ［データソースの新規作成］ダイアログが表示されます。
  4. セットアップするデータソースのドライバから，「EUR ODBC Driver」を選択したあと，［完了］ボタンをクリックします。
    ［EUR ODBC Driver - セットアップ -］ダイアログが表示されます。［EUR ODBC Driver - セットアップ -］ダイアログに，DABrokerを使用したデータベースへの接続情報を設定します。
注
64bit OSで使用する場合，Windowsディレクトリのsystem32フォルダにあるODBCアドミニストレータ（odbcad32.exe）には，EURのODBCドライバ（EUR ODBC Driver）は表示されません。EURのODBCドライバのデータソースを登録するときは，WindowsディレクトリのSysWow64フォルダにあるODBCアドミニストレータを使用してください。


帳票作成時のデータベースからのデータの読み込み

3.　帳票作成時のデータベースからのデータの読み込み

この章では，EUR 帳票作成機能でデータベースからデータを抽出し，マッピングデータとしてデータウィンドウへ表示するまでの操作と機能について説明します。

＜この章の構成＞
3.1　データ読み込みの操作の流れ
3.2　データベースの接続
3.3　データの抽出
3.4　抽出データの確認
3.5　データウィンドウへの表示
3.6　データウィンドウのフィールド定義
3.7　見出し辞書の設定


データ読み込みの操作の流れ

3.1　データ読み込みの操作の流れ

EURでは，データベースに接続し，帳票に必要なデータを取り出して，マッピングデータとして使用できます。データベースからデータを取り出すことをデータの抽出と呼びます。

データを抽出するには，接続するデータベースをあらかじめ設定しておく必要があります。使用できるデータベースについては，「1.2　EURで使用できるデータベース」を，データベースの接続方法については，「2.1　データベースの接続の概要」を参照してください。

データを抽出して，フィールド定義をするまでの操作の流れを次に示します。

図3-1　データ読み込みの操作の流れ


データベースの接続

3.2　データベースの接続

データベースの接続設定を行ったら，EURを起動し，データベースに接続します。EURからデータベースに接続すると，データベースアクセス定義ウィンドウが表示されます。

＜この節の構成＞
3.2.1　EURからのデータベースの接続
3.2.2　データベースに再接続するには


EURからのデータベースの接続

3.2.1　EURからのデータベースの接続

データベースに接続する方法を次に示します。

＜この項の構成＞
(1)　データベースに接続する
(2)　注意事項

(1)　データベースに接続する

  1. データウィンドウの選択
    マッピングデータウィンドウ，またはユーザ定義データウィンドウをクリックして，アクティブにします。

  2. ［データソースの選択］ダイアログの表示
    ［データ］メニューから，［データベースアクセス定義］を選択します。
    ［データソースの選択］ダイアログが表示されます。
  3. 接続先データソースの選択
    接続先データソースをリストから選択し，データベースに接続するユーザの「ユーザID」と「パスワード」を設定します。「パスワード」は，文字列を入力すると「*」に置き換えて表示されます。

    リストに表示されるデータソースは，EURで使用できるODBC Driverで設定されたデータソース名です。データソースの設定については，「2.1　データベースの接続の概要」を参照してください。
  4. ［OK］ボタンのクリック
    ［OK］ボタンは，「データソース名」と「ユーザID」が設定されると活性になります。
    ［OK］ボタンをクリックすると，データベースアクセス定義ウィンドウが表示されます。

    表3-1　データベースアクセス定義ウィンドウのメニュー一覧

    メニュー | ドロップダウンメニュー | 機能
    ［接続］ | ［接続］ | データベースに接続します。操作中にタイムアウトした場合に，再接続するために使用します。
    ［切断］ | データベースとの接続を切ります。接続しているデータベースとの接続を切るために使用します。
    ［抽出］ | ［表名］ | 接続したデータベースから表を選択します。
    ［列設定］ | 選択した表の中から，抽出する列を選択します。
    ［条件設定］ | 列データを絞り込む条件を設定します。
    ［抽出確認］ | データベースアクセス定義ウィンドウで定義した条件で抽出したデータが表形式で表示されます。
    ［列情報の最新］ | 列情報を最新にします。
    ［ツール］ | ［見出し編集］ | 見出し辞書の新規作成，または見出し辞書に登録されている見出し情報を編集します。
    ［オプション］ | ［抽出］，［表示］，および［見出し辞書］のオプションを設定します。
    ［ヘルプ］ | ［このウィンドウの説明］ | EURのヘルプが表示されます。

(2)　注意事項

  • データベースアクセス定義ウィンドウが表示されている場合は，データウィンドウの操作はできません。
  • データベースアクセス定義ウィンドウで項目を追加するなどして，一度定義した情報を更新した場合は，フィールド情報を再生成しなければ，マッピングデータウィンドウに変更が反映されません。［フィールド定義］ダイアログで項目を追加定義するか，または［自動作成］ボタンをクリックして表示される［フィールド定義情報自動作成］ダイアログで定義情報を再作成してください。


データベースに再接続するには

3.2.2　データベースに再接続するには

接続がタイムアウトした場合やほかのデータベースに接続したい場合は，データベースに再接続します。データベースに再接続する方法を次に示します。

＜この項の構成＞
(1)　接続がタイムアウトした場合
(2)　ほかのデータベースに接続したい場合

(1)　接続がタイムアウトした場合

データベースとの接続中，タイムアウトが発生すると，データの抽出ができなくなりますが，データベースとは接続したままです。そのため，明示的に切断したあとで接続し直す必要があります。

  1. データベースと切断
    データベースアクセス定義ウィンドウの［接続］メニューの［切断］を選択します。
  2. データベースと再接続
    データベースアクセス定義ウィンドウの［接続］メニューの［接続］を選択します。［データソースの選択］ダイアログに設定されている情報で，データベースに再接続します。

(2)　ほかのデータベースに接続したい場合

データベースアクセス定義ウィンドウの［キャンセル］ボタンをクリックして，データベースとの接続を切断します。このあと，［データソースの選択］ダイアログを表示して，接続先データベースを設定します。


データの抽出

3.3　データの抽出

データベースに格納されたデータを抽出して，マッピングデータとして使用します。EURを使用すれば，SQLを意識しなくても表結合や条件を設定できます。使用できる文字コードは，Shift JISまたはUTF-8です。

なお，1回の抽出で接続できるデータベースは一つだけです。複数様式帳票を作成する場合，すべての帳票セットのマッピングデータおよびユーザ定義データに入力できるデータは，一つのデータベースからだけです。

データベースからデータを抽出する場合に使う機能を次に示します。

表3-2　データの抽出の機能

機能 | 説明 | 参照先
表を選択する | 抽出する表を選択します。 | 3.3.1 表の選択
表一覧に表示する項目を設定する | 抽出する表を選択するときに，目安となる情報が一覧に表示されます。 | 3.3.1(2) 詳細情報に表示する項目の設定
表を選択するときに絞り込みをする | 抽出対象の表の一覧から抽出する表を選ぶときに，条件を付けて絞り込めます。抽出対象の表が大量にある場合などに，効率良く表を選べます。 | 3.3.1(3) 表の絞り込み
複数の表を結合する | 表と表で共通する列を結び付けて，一つの表として抽出できます(表結合)。関連する表のデータを一括して利用できます。 | 3.3.1(4) 複数の表からのデータ抽出（表結合）
抽出する列を選択する | 抽出する表から特定の列だけを選んで抽出できます。選択した列のデータをソートしたり，列のデータの最大値，最小値などを抽出したりできます。 | 3.3.2 列の設定
抽出するデータを列の値で絞り込む | 抽出する表から条件に合うデータだけを抽出できます。また，複数の条件式を関連づけることもできます。 例えば，定価が50,000円以上のデータを抽出する条件と，商品名が冷蔵庫またはテレビのデータを抽出する条件を「AND」で関連づけます。この場合，定価が50,000円以上でかつ，商品名が冷蔵庫またはテレビのデータだけを抽出できます。 | 3.3.3 条件の設定
条件式の条件値を実行時に変更できるようにする | 条件に合うデータを抽出するときに設定する条件式に，可変記号を設定できます。条件式の条件値だけを変更するときに使います。帳票出力する場合，可変記号に対する実行値を設定するだけでデータを抽出できます。これによって，実行時に変化する値に応じてデータを抽出できます。 | 3.3.3 条件の設定
抽出するデータの件数を確認する | データを抽出するときに，その件数を確認できます。また，抽出する件数を制限することもできます。 | 3.4 抽出データの確認
表名や列名に任意の名称を設定する | データベース内の表名や列名に対して，任意の名称を設定できます。データベースを意識しないで，業務で使い慣れた名称で操作できます。任意の名称を登録する辞書を見出し辞書といいます。見出し辞書を使うと，EURはデータベースではなく見出し辞書にアクセスして表名や列名を取得するため，データベースにアクセスしている間の待ち時間が短縮できます。 | 3.7 見出し辞書の設定
＜この節の構成＞
3.3.1　表の選択
3.3.2　列の設定
3.3.3　条件の設定
3.3.4　最新列情報の取得


表の選択

3.3.1　表の選択

表を選択します。対象となる表は，次に示すどちらかの方法で選択します。

  • データベースに定義されている表から選択する
  • 見出し辞書に登録されている表から選択する
    見出し辞書に登録されている表から選択する場合は，あらかじめ［オプション］ダイアログの［見出し辞書］タブで，［見出し辞書］チェックボックスをオンにして，［表一覧］リストに表示する情報を設定しておきます。見出し辞書については，「3.7　見出し辞書の設定」を参照してください。
＜この項の構成＞
(1)　データベースからの表の選択
(2)　詳細情報に表示する項目の設定
(3)　表の絞り込み
(4)　複数の表からのデータ抽出 （表結合）

(1)　データベースからの表の選択

表は，［表選択］ダイアログで選択します。データベースに登録されている表から選択する方法を示します。

  1. ［表選択］ダイアログの表示
    データベースアクセス定義ウィンドウで［表名］ボタンをクリックします。［表選択］ダイアログが表示されます。
    ［詳細表示］チェックボックスにチェックすると，表名以外の詳細情報を表示できます。［詳細情報］で表示できる項目については，「(2)　詳細情報に表示する項目の設定」を参照してください。
  2. 表の選択
    抽出する表を選択し，［選択］ボタンをクリックします。選択した表名が，「選択表一覧」に表示されます。所有者名，または表名がShift JIS以外の場合は，エラーとなります。
    選択できる表の数は，15個までです。表数が15個になると，［選択］ボタンは不活性になります。
    複数の表を使用する場合
    複数の表を使用してマッピングデータを作成する場合は，表の結合条件を設定できます。表の結合条件の設定方法については，「(4)　複数の表からのデータ抽出（表結合）」を参照してください。
    表を絞り込む場合
    「表一覧」に表示された表の中から，指定した条件に合った表が表示されます。表の絞り込み条件の設定方法については，「(3)　表の絞り込み」を参照してください。
    選択した表を削除する場合
    「選択表一覧」に表示された表を削除する場合は，削除する表を選択し，［削除］ボタンをクリックします。また表をダブルクリックしても，削除できます。
  3. ［OK］ボタンのクリック
    データベースアクセス定義ウィンドウに選択した表名が表示されます。

(2)　詳細情報に表示する項目の設定

データベースから表を選択する場合，表を選択しやすいように，［表選択］ダイアログの「表一覧」に詳細情報を表示できます。

詳細情報には，次の項目が表示できます。

  • グループ名
  • 所有者
  • 表名
  • 種別
  • 注釈

項目が表示されるときの規則について，次に示します。

  • 表名は，非表示に設定できません。
  • 見出し辞書でグループ名を設定している場合に表示されます。
  • 項目の表示順序は，グループ名，所有者，表名，種別，注釈の順です。
(a)　操作方法

詳細情報に表示する項目は，［表一覧表示方法の設定］ダイアログで設定します。

  1. ［表選択］ダイアログの表示
    データベースアクセス定義ウィンドウで［表名］ボタンをクリックします。［表選択］ダイアログが表示されます。
  2. 表示する詳細項目の選択
    ［表示設定］ボタンをクリックします。［表一覧表示方法の設定］ダイアログが表示されます。［表示設定］ボタンは，［表選択］ダイアログの［詳細表示］チェックボックスをチェックすると，活性になります。
  3. 表示・非表示の選択
    表示したい項目を選択し，［表示］ボタンをクリックします。項目には，「グループ名」，「所有者」，「表名」，「種別」，および「注釈」があります。非表示にしたい項目がある場合は，［非表示］ボタンをクリックしてください。ただし，表名は非表示にできません。
  4. ［OK］ボタンのクリック
    ［表選択］ダイアログに設定した項目が表示されます。

(3)　表の絞り込み

［表選択］ダイアログに表示された表一覧から表を選択する場合，条件を付けて絞り込めます。表の抽出および見出し辞書で使用できます。

絞り込み条件は，表の「所有者」「表名」それぞれに設定できます。ワイルドカード（「所有者」，「表名」で条件文字列以外の部分）には，半角文字の「*」および「?」を使用します。

半角文字「*」は0文字以上の任意の文字列を示します。半角文字「?」は1文字の任意の文字列を示します。

表を絞り込むときの規則を次に示します。

  • 全角文字および半角文字が使用できます。
  • 条件に指定できる長さ（所有者 + 表名）は，254バイトです。
  • 見出し辞書を設定している場合は，見出し辞書に登録されている表名で検索されます。
  • 絞り込み条件の文字列の前後に指定された空白は無視されます。
  • ワイルドカード以外で，「*」「?」を使用した場合は，絞り込み条件として扱われません。

表の絞り込みの種類と指定例を次に示します。

前方一致
文字列の先頭を指定して，以降は任意の文字列を検索します。
指定例：「仕入れ*」と入力すると，「仕入れ台帳」や「仕入れ表」などが表示されます。
後方一致
文字列の最後を指定して，以前は任意の文字列を検索します。
指定例：「*在庫表」と入力すると，「小売り在庫表」や「商品在庫表」が表示されます。
部分一致
文字数と文字列の一部を指定して検索します。
指定例：「??売上??」と入力すると，「月末売上台帳」や「総合売上一覧」などが表示されます。
中間一致
文字列の一部を指定して検索します。
指定例：「*月末*」と入力すると，「月末売上台帳」や「3月末在庫一覧」などが表示されます。
(a)　操作方法

表の絞り込みは，［表の絞り込み条件の設定］ダイアログで設定します。［表の絞り込み条件の設定］ダイアログの設定項目については，「5.5　［表の絞り込み条件設定］ダイアログ」を参照してください。表の絞り込み方法を次に示します。

  1. ［表選択］ダイアログの表示
    データベースアクセス定義ウィンドウで［表名］ボタンをクリックします。［表選択］ダイアログが表示されます。
  2. ［表絞り込み条件設定］ダイアログの表示
    ［絞り込み］ボタンをクリックします。［表絞り込み条件設定］ダイアログが表示されます。
  3. 絞り込み条件の設定
    「所有者」または「表名」に検索条件を入力します。
  4. ［OK］ボタンのクリック
    「表一覧」に設定した条件に合う表が表示されます。

(4)　複数の表からのデータ抽出 （表結合）

複数の表を結合させて，データを抽出できます。結合するためには，それぞれの表に共通する列が必要です。複数の表からのデータ抽出は，［表結合条件］ダイアログで設定します。

EURでは，結合条件を満たす行だけを抽出する結合（内結合）ができます。

  • =：列の値と条件値が同じ
  • <>：列の値が条件値と異なる
  • >：列の値が条件値より大きい
  • >=：列の値が条件値以上
  • <：列の値が条件値より小さい
  • <=：列の値が条件値以下

表結合条件を複数設定した場合は，すべての条件を満たす行だけが表示されます。

比較できる列属性の組み合わせを，次に示します。

表3-3　比較できる列属性の組み合わせ

左辺 | 右辺
CHAR，VARCHAR，LONG VARCHAR，MCHAR，MVARCHAR，NCHAR，NVARCHAR，UCHAR※，UVARCHAR※，LONG UVARCHAR※ | CHAR，VARCHAR，LONG VARCHAR，MCHAR，MVARCHAR，NCHAR，NVARCHAR，UCHAR※，UVARCHAR※，LONG UVARCHAR※
NUMERIC，DECIMAL，SMALLINT，INTEGER，REAL，FLOAT，BIT，TINYINT，DOUBLE | NUMERIC，DECIMAL，SMALLINT，INTEGER，REAL，FLOAT，BIT，TINYINT，DOUBLE
DATE | DATE
TIME | TIME
BINARY，VARBINARY，LONG VARBINARY | BINARY，VARBINARY，LONG VARBINARY
TIMESTAMP | TIMESTAMP
注※
SQL Serverを使用する場合で，Unicodeデータを抽出する場合だけ使用できます。

内結合の例を次に示します。

(a)　操作方法

表結合条件は，［表結合条件］ダイアログで設定します。

  1. 複数の表の選択
    データ抽出する表を複数選択します。表の選択方法については，「(1)　データベースからの表の選択」を参照してください。
  2. ［条件設定］ボタンのクリック
    ［条件設定］ダイアログが表示されます。
  3. ［表結合条件］ダイアログの表示
    ［表結合］ボタンをクリックします。［表結合条件］ダイアログが表示されます。
  4. 表結合条件の設定
    ［表1］と［表2］で，結合させる表の情報を選択します。［演算子］コンボボックスには表1と表2を結合させる比較演算子を選択します。演算子には，「=」「<>」「>」「>=」「<」「<=」が指定できます。
  5. ［OK］ボタンのクリック
    ［条件設定］ダイアログに戻ります。［条件設定］ダイアログの［OK］ボタンをクリックすると，データベースアクセス定義ウィンドウに設定した条件が表示されます。
(b)　設定した表結合条件を変更または削除する方法

［条件設定］ダイアログで，表結合条件を選択します。

表結合条件を変更する場合は，［変更］ボタンをクリックして，［表結合条件］ダイアログを表示して変更します。

表結合条件を削除する場合は，［削除］ボタンをクリックして削除します。

(c)　補足説明
  • 結合条件での注意事項
    結合条件を設定しないと，すべての組み合わせで抽出されます。すべての組み合わせとは，結合条件を設定している表の各行に結合条件を設定していない表の全行を付けることです。例えば，結合条件が設定されていない表A（h行）と表B（i行）から無条件でデータを抽出すると，（h×i）個の行が抽出されます。
  • HiRDBで表結合する場合
    表種別が「ALIAS」の場合は，「ALIAS」表としか結合できません。表種別は［表選択］ダイアログの［詳細表示］チェックボックスをオンにすると，［表一覧］リストに表示されます。表種別を確認してから，結合条件を設定してください。
    同一表の列を表結合条件式の両辺に設定した場合は，通常の列比較条件式となります。


列の設定

3.3.2　列の設定

選択した表から，データを抽出したい列を選択します。この場合，列のデータをソートしたり，最大値や最小値のデータを抽出したりできます。

表3-4　列設定の機能

機能 | 説明
列の追加 | ［選択列］リストに列を追加できます。
列の挿入 | ［選択列］リストに列を挿入できます。
列の削除 | ［選択列］リストの不要な列を削除できます。
すべての列の削除 | ［選択列］リストのすべての列を削除できます。
集合関数の設定 | 列に集合関数を設定できます。
列のソート | 列を昇順，または降順に並べ替えられます。
仮想列の設定 | 列と列を演算した結果を，仮想列として設定できます。
＜この項の構成＞
(1)　列の追加
(2)　集合関数の設定
(3)　グループ分けの設定
(4)　ソートの設定
(5)　仮想列の設定

(1)　列の追加

選択した表の中で，マッピングデータとして使用するデータの列を追加します。複数の表から列データを追加できます。

集合関数またはグループ分けをしたあとに列を追加すると，追加した列にはグループ分けが設定されます。

(a)　操作方法

列の追加は，［列選択］ダイアログで行います。

  1. ［列設定］ダイアログの表示
    ［列設定］ボタンをクリックします。［列設定］ダイアログが表示されます。
  2. 列の選択
    マッピングデータとして使用するデータの列を選択します。「列一覧」リストから，列名を選択し，［追加］ボタンをクリックすると，選択した列が［選択列］リストに表示されます。
    集合関数を使用する場合
    集合関数を設定すると，列中のデータの最大値，最小値などを抽出できます。集合関数の設定方法については，「(2)　集合関数の設定」を参照してください。
    列データをソートする場合
    選択した列のデータをソートできます。列データのソートの方法については，「(4)　ソートの設定」を参照してください。
    仮想列を追加する場合
    データベース中から抽出した列の値を編集して，新しい列(仮想列)を追加できます。仮想列の設定方法については，「(5)　仮想列の設定」を参照してください。
    選択した列を削除する場合
    「選択列」リストに表示された列を削除する場合は，削除する列を選択し，［削除］ボタンをクリックします。選択したすべての列を削除する場合は，［全列削除］ボタンをクリックしてください。
  3. ［OK］ボタンのクリック
    データベースアクセス定義ウィンドウに選択した列名が表示されます。

(2)　集合関数の設定

集合関数を設定すると，列中のデータの最大値，最小値などを抽出できます。ただし，集合関数を設定した場合は，表データそのものは抽出できません。

集合関数は，［集合関数設定］ダイアログを使って設定します。設定できる集合関数を，次に示します。

表3-5　集合関数の種類

集合関数 | ボタン | 説 明
最大 | ［最大］ | 選択した列のデータの中から，最大値を求める関数です。 ボタンをクリックすると，［設定内容一覧］エリアに「最大（選択した列名）」と表示されます。
最小 | ［最小］ | 選択した列のデータの中から，最小値を求める関数です。 ボタンをクリックすると，［設定内容一覧］エリアに「最小（選択した列名）」と表示されます。
平均 | ［平均］ | 選択した列の，データの平均値を求める関数です。 ボタンをクリックすると，［設定内容一覧］エリアに「平均（選択した列名）」と表示されます。
合計 | ［合計］ | 選択した列の，データの合計値を求める関数です。 ボタンをクリックすると，［設定内容一覧］エリアに「合計（選択した列名）」と表示されます。
件数 | ［件数］ | 選択した列の，データの件数を求める関数です。 ボタンをクリックすると，［設定内容一覧］エリアに「件数（選択した列名）」と表示されます。
グループ | ［グループ］ | グループ（列中の同じデータの集合）単位で集合関数を算出してデータが抽出する関数です。 ボタンをクリックすると，［設定内容一覧］エリアに「グループ（選択した列名）」と表示されます。

列属性によって，設定できない集合関数があります。列属性と設定できる集合関数の組み合わせを次に示します。

なお，選択した列に，どの集合関数が設定できるかは，列を単一選択した時に，ボタンの活性，または不活性でもわかります。

表3-6　列属性ごとの使用できる集合関数

列属性 | 集合関数
 | 最大 | 最小 | 平均 | 合計 | 件数 | グループ
NUMERIC，DECIMAL，SMALLINT，INTEGER，REAL，FLOAT，BIT，TINYINT，DOUBLE | ○ | ○ | ○ | ○ | ○ | ○
CHAR，VARCHAR，LONG VARCHAR，NCHAR，NVARCHAR，MCHAR，MVARCHAR，UCHAR※，UVARCHAR※，LONG UVARCHAR※ | ○ | ○ | × | × | ○ | ○
DATE，TIME，TIMESTAMP | ○ | ○ | × | × | ○ | ○
BINARY，VARBINARY | ○ | ○ | × | × | ○ | ○
（凡例）
○：設定できます。
×：設定できません。
注※
SQL Serverを使用する場合で，Unicodeデータを抽出する場合だけ使用できます。

(a)　操作方法

集合関数は，［集合関数設定］ダイアログで設定します。

  1. ［列設定］ダイアログの表示
    ［列設定］ボタンをクリックします。［列設定］ダイアログが表示されます。
  2. ［集合関数設定］ダイアログの表示
    ［集合関数］ボタンをクリックします。［集合関数設定］ダイアログが表示されます。「設定内容一覧」に，列名が表示されます。
  3. 集合関数の設定
    選択した列に集合関数を設定します。「設定内容一覧」に表示されたすべての列には，グループ分けが設定されています。集合関数を設定する列を選択し，集合関数のボタンをクリックします。集合関数には，最大，最小，平均，合計，件数が設定できます。ただし，設定できない集合関数のボタンは不活性になっています。
    設定した集合関数を解除する場合
    設定した集合関数を解除する場合は，［全取消］ボタンをクリックします。ただし，［全取消］ボタンをクリックすると，設定した集合関数はすべて解除されます。
  4. ［OK］ボタンのクリック
    ［列設定］ダイアログに戻ります。［列設定］ダイアログの［OK］ボタンをクリックすると，設定した集合関数が「列名」に表示されます。

(3)　グループ分けの設定

列にグループ分けを設定しておくと，グループ（列中の同じデータの集合）単位で集合関数を算出してデータが抽出されます。その場合，抽出されるデータは，昇順でソートされます。

同じ列にグループ分けと集合関数を同時に指定することはできません。集合関数またはグループ分けをしたあとに列を追加すると，追加した列にはグループ分けが設定されます。

グループ分けと集合関数を設定した場合の抽出結果を次に示します。

図3-2　グループ分けと集合関数を設定した場合の抽出結果の例

(a)　操作方法

グループ分けは，［集合関数設定］ダイアログで設定します。

  1. ［列設定］ダイアログの表示
    ［列設定］ボタンをクリックします。［列設定］ダイアログが表示されます。
  2. ［集合関数設定］ダイアログの表示
    ［集合関数］ボタンをクリックします。［集合関数設定］ダイアログが表示されます。「設定内容一覧」に，列名が表示されます。
  3. グループ分けの設定
    「設定内容一覧」に表示されたすべての列には，グループ分けが設定されています。また，必要に応じて集合関数を設定してください。
    設定したグループ分けを解除する場合
    設定したグループ分けを解除する場合は，［全取消］ボタンをクリックします。ただし，［全取消］ボタンをクリックすると，設定したグループ分けはすべて解除されます。
  4. ［OK］ボタンのクリック
    ［列設定］ダイアログに戻ります。［列設定］ダイアログの［OK］ボタンをクリックすると，設定したグループ分けが「列名」に表示されます。

(4)　ソートの設定

選択した列のデータをソートします。ソートする列は，255列まで設定できます。［ソート］ボタンをクリックして表示される［ソート設定］ダイアログで，ソートやソート時の優先順位を設定します。ソートには，昇順と降順が設定できます。

複数の列にソートを設定した場合は，［設定内容一覧］の上位の項目から順にソートされます。

複数の列にソートを設定した場合の例を次に示します。

ただし，ソート設定ができる列は，255列までです。

(a)　操作方法

ソートの設定は，［ソート設定］ダイアログで設定します。

  1. ［列設定］ダイアログの表示
    ［列設定］ボタンをクリックします。［列設定］ダイアログが表示されます。
  2. ［ソート設定］ダイアログの表示
    ［ソート］ボタンをクリックします。［ソート設定］ダイアログが表示されます。「列名一覧」に，列名が表示されます。
  3. 昇順，降順の設定
    ソートを設定する列を選択し，［降順］ボタンまたは［降順］ボタンをクリックします。「設定内容一覧」に選択した列名と設定内容が表示されます。▲は昇順，▼は降順を表します。
    設定したソートを削除する場合
    設定したソートを削除する場合は，［削除］ボタンをクリックします。
  4. 優先順位の設定
    複数のソート条件を設定する場合，ソートの優先順位を設定します。「設定内容一覧」で列名を選択し，［↑］ボタンまたは［↓］ボタンをクリックします。「設定内容一覧」の列名の順番が変わり，優先順位が設定されます。優先順位は，「設定内容一覧」の上の列から順に設定されます。
  5. ［OK］ボタンのクリック
    ［列設定］ダイアログに戻ります。［列設定］ダイアログの［OK］ボタンをクリックすると，設定したソートと優先順位が「情報」に表示されます。

(5)　仮想列の設定

データベース中から抽出した列の値を編集して，新しい列(仮想列)を追加できます。［仮想列編集］ダイアログで，仮想列を追加します。仮想列はデータべース連携で抽出した結果にだけ追加され，データベースの内容には影響しません。

例えば，価格と数量を掛けて合計金額の列を出したり，納入数と在庫数を足して合計数の列を出したりできます。

仮想列を設定する場合の規則を次に示します。

  • 列名称に指定できる文字列の長さは，46バイトまでです。
  • 列内容に指定できる式の長さは，30,000バイトまでです。
  • 列内容にLONG VARBINARY属性の列は指定できません。

仮想列を設定した場合の抽出結果を次に示します。

図3-3　仮想列を設定した場合の抽出結果の例

注意
仮想列は，SQLを使用して作成した仮想的な列として実現します。そのため，仮想列の列の属性はデータベースの仕様に左右されます。
仮想列として使用できるSQLで使用する関数と関数の形式は，データベースによって異なります。また，データベースのバージョンによっても異なります。詳細については，使用するデータベースのマニュアルを参照してください。
(a)　操作方法

仮想列の設定は，［仮想列編集］ダイアログで設定します。

  1. ［列設定］ダイアログの表示
    ［列設定］ボタンをクリックします。［列設定］ダイアログが表示されます。
  2. ［仮想列編集］ダイアログの表示
    ［仮想列］オプションボタンを選択し，［追加］ボタンをクリックします。［仮想列編集］ダイアログが表示されます。
  3. 列名称，列内容の設定
    「列名称」に仮想列の名称を入力します。入力できる名称は，46バイトまでです。
    「列内容」に仮想列の式を入力します。データの値を使用する場合は，列一覧から使用する列を選択し，［選択］ボタンをクリックします。列名を直接入力することもできます。列名を直接入力する場合は，列名を「"」で囲みます。
    仮想列を変更する場合
    「選択列」リストに表示された仮想列を変更する場合は，変更する列を選択し，［編集］ボタンをクリックします。［仮想列編集］ダイアログが表示され，仮想列を変更できます。
    仮想列を削除する場合
    「選択列」リストに表示された仮想列を削除する場合は，削除する列を選択し，［削除］ボタンをクリックします。選択したすべての列を削除する場合は，［全列削除］ボタンをクリックしてください。
  4. ［OK］ボタンのクリック
    ［列設定］ダイアログに戻ります。［列設定］ダイアログの［OK］ボタンをクリックすると，設定した仮想列が「列名」に表示されます。


条件の設定

3.3.3　条件の設定

データを抽出するための条件を設定します。［条件設定］ダイアログで設定します。［条件設定］ダイアログは，データベースアクセス定義ウィンドウの［条件設定］ボタンをクリックすると表示されます。設定できる条件の種類を，次に示します。

表3-7　条件の種類

条件 | 説明 | 条件記号 | 意味
比較条件 | 左辺と右辺を比較し，条件に合うデータを抽出します。右辺の定数は可変記号を設定できます。 | = | 列の値と条件値が同じ
 |  | <> | 列の値が条件値と異なる
 |  | > | 列の値が条件値より大きい
 |  | >= | 列の値が条件値以上
 |  | < | 列の値が条件値より小さい
 |  | <= | 列の値が条件値以下
NULL条件 | NULL値を持つデータ，またはNULL値を持たないデータを抽出します。 | NULL | 列の値がNULL値
 |  | NOT NULL | 列の値がNULL値以外
LIKE条件 | 右辺に指定した文字パターンと同じデータ，または異なるデータを抽出します。右辺の文字パターンは可変記号を設定できます。 | LIKE | 列の値が，指定した文字パターンと同じ
 |  | NOT LIKE | 列の値が，指定した文字パターンと異なる
IN条件 | 右辺に指定した定数が含まれるデータ，または含まれないデータを抽出します。右辺の定数は可変記号を設定できます。指定できる定数の数はアクセスするデータベースによって異なります。 | － | －
BETWEEN条件 | 右辺に指定した定数1と定数2の間(定数1および定数2を含む)のデータ，または間以外(定数1および定数2を含まない)のデータを抽出します。右辺の定数は可変記号を設定できます。 | － | －
列演算条件 | 演算を用いた条件式で比較します。「+ － * / ( )」および定数を使って条件式を設定して，左辺と右辺を比較して条件に合うデータを抽出します。 | － | －
WHERE句に指定できる条件 | SQLのWHERE句の形式で記述した条件を，そのまま指定します。 | － | －
表結合条件 | 表と表を結合します。 | － | －
（凡例）
－：該当する項目はありません。

＜この項の構成＞
(1)　操作方法
(2)　列と定数の規則
(3)　比較条件
(4)　NULL条件
(5)　LIKE条件
(6)　IN条件
(7)　BETWEEN条件
(8)　列演算条件
(9)　WHERE句に指定できる条件
(10)　表結合条件
(11)　可変記号の設定

(1)　操作方法

条件式の設定方法を次に示します。

  1. ［条件設定］ダイアログの表示
    ［条件設定］ボタンをクリックします。［条件設定］ダイアログが表示されます。
  2. 条件式の設定
    条件式を設定します。設定できる条件を次に示します。
    • 比較条件
    • NULL条件
    • LIKE条件
    • IN条件
    • BETWEEN条件
    • 列演算条件
    • WHERE句に指定できる条件
    • 表結合条件
  3. ［OK］ボタンのクリック
    ［条件設定］ダイアログに戻ります。［条件設定］ダイアログの［OK］ボタンをクリックすると，設定した条件式が表示されます。
    設定した条件式を削除する場合
    設定した条件式を削除する場合は，［条件設定］ダイアログの［削除］ボタンをクリックします。

(2)　列と定数の規則

列の属性によって，定数や指定範囲が異なります。列と定数の規則を次に示します。

表3-8　列と定数の規則

列の属性 | 使用する定数 | 指定方法 | 指定範囲
CHAR | 文字 | 〔'〕全角，および半角の文字列〔'〕 「'」を記述する場合「''」と記述します。 | 1～255バイト
VARCHAR | 文字 | 〔'〕全角，および半角の文字列〔'〕 「'」を記述する場合「''」と記述します。 | 1～255バイト
LONG VARCHAR | 文字 | 〔'〕全角，および半角の文字列〔'〕 「'」を記述する場合「''」と記述します。 | 1～255バイト
MCHAR | 文字 | 〔'〕全角，および半角の文字列〔'〕 「'」を記述する場合「''」と記述します。 | 1～255バイト
MVARCHAR | 文字 | 〔'〕全角，および半角の文字列〔'〕 「'」を記述する場合「''」と記述します。 | 1～255バイト
NCHAR | 日本語文字 | 〔'〕全角の文字列〔'〕 | 1～254バイト
NVARCHAR | 日本語文字 | 〔'〕全角の文字列〔'〕 | 1～254バイト
UCHAR※ | 文字 | 〔'〕全角，および半角の文字列〔'〕 「'」を記述する場合「''」と記述します。 | 1～255バイト
UVARCHAR※ | 文字 | 〔'〕全角，および半角の文字列〔'〕 「'」を記述する場合「''」と記述します。 | 1～255バイト
LONG UVARCHAR※ | 文字 | 〔'〕全角，および半角の文字列〔'〕 「'」を記述する場合「''」と記述します。 | 1～255バイト
BINARY | 16進数 | 〔'〕0～9，A～Fの半角の文字列〔'〕 | 1～254バイト
VARBINARY | － | － | －
LONG VARBINARY | － | － | －
NUMERIC | 10進数 | 〔符号〕整数部.小数部 | 定義桁数
DECIMAL | 10進数 | 〔符号〕整数部.小数部 | 定義桁数
SMALLINT | 整数 | 〔符号〕整数 | -32768～32767
INTEGER | 整数 | 〔符号〕整数 | -2147483648～2147483647
TINYINT | 整数 | 〔符号〕整数 | -256～255
BIT | 整数 | 0，または1 | 0，または1
REAL | 浮動小数点数 | 〔符号〕仮数E〔符号〕指数 | 約±1.7E±308 ただし指数18桁，仮数3桁
FLOAT | 浮動小数点数 | 〔符号〕仮数E〔符号〕指数 | 約±1.7E±308 ただし指数18桁，仮数3桁
DOUBLE | 浮動小数点数 | 〔符号〕仮数E〔符号〕指数 | 約±1.7E±308 ただし指数18桁，仮数3桁
DATE | 日付の文字表現 | 〔'〕YYYY-MM-DD〔'〕 年（YYYY），月（MM），日（DD）を「-」で結びます。 | YYYY：0001～9999 MM：01～12 DD：01～その月の最終日
TIME | 時間の文字表現 | 〔'〕hh:mm:ss〔'〕 時（hh），分（mm），秒（ss）を「:」で結びます。 | hh：00～23 mm：00～59 ss：00～59
TIMESTAMP(16桁) | タイムスタンプ | 〔'〕YYYY-MM-DD△hh:mm〔'〕 日付の文字表現と時間の文字表現の時分を，半角空白（△）で結びます。 | YYYY：0001～9999 MM：01～12 DD：01～その月の最終日 hh：00～23 mm：00～59
TIMESTAMP(19桁) | タイムスタンプ | 〔'〕YYYY-MM-DD△hh:mm:ss〔'〕 日付の文字表現と時間の文字表現を，半角空白（△）で結びます。 | YYYY：0001～9999 MM：01～12 DD：01～その月の最終日 hh：00～23 mm：00～59 ss：00～59
TIMESTAMP(23桁) | タイムスタンプ | 〔'〕YYYY-MM-DD△hh:mm:ss〔.nnn〔'〕〕 日付の文字表現と時間の文字表現を，半角空白（△）で結び，「.」のあとに3桁の小数秒を付けます。 | YYYY：0001～9999 MM：01～12 DD：01～その月の最終日 hh：00～23 mm：00～59 ss：00～59 nnn：000～999
TIMESTAMP(26桁) | タイムスタンプ | 〔'〕YYYY-MM-DD△hh:mm:ss〔.nnnnnn〔'〕〕 日付の文字表現と時間の文字表現を，半角空白（△）で結び，「.」のあとに6桁の小数秒を付けます。 | YYYY：0001～9999 MM：01～12 DD：01～その月の最終日 hh：00～23 mm：00～59 ss：00～59 nnn：000～999
（凡例）
－：該当する項目はありません。
注※
SQL Serverを使用する場合で，Unicodeデータを抽出するときだけ使用できます。

(3)　比較条件

左辺と右辺を比較し，条件に合うデータを抽出します。比較条件の設定は，［条件設定］ダイアログで設定します。

列と定数の比較は，列属性によっては使用できない定数があります。列と定数の規則については，「表3-8　列と定数の規則」を参照してください。

［条件設定］ダイアログの「列一覧」リストから条件を設定する列を選択し，［条件］リストボックスから，比較条件式（=，<>，>，>=，<，<=）を選択します。［条件］テキストボックスに設定値を入力し，［設定］ボタンをクリックします。「一覧」リストに条件式が表示されます。右辺の定数に可変記号を指定したい場合は，［可変記号］ボタンをクリックし，［可変記号］ダイアログで可変記号を入力します。

(4)　NULL条件

NULL値を持つデータ，またはNULL値を持たないデータを抽出します。NULL条件の設定は，［条件設定］ダイアログで設定します。

［条件設定］ダイアログの「列一覧」リストから条件を設定する列を選択し，［条件］リストボックスから，NULL条件式（NULL，NOT NULL）を選択します。［設定］ボタンをクリックします。「一覧」リストに条件式が表示されます。

(5)　LIKE条件

右辺に指定した文字パターンと同じデータ，または異なるデータを抽出します。LIKE条件の設定は，［条件設定］ダイアログで設定します。

「_」と「%」は，次に示すように，列属性によって表示できる文字が異なります。

  • 全角文字の「＿」と「％」
    NCHAR，またはNVARCHARで指定します。
  • 半角文字の「_」と「%」
    CHAR，VARCHAR，LONG VARCHAR，MCHAR，MVARCHAR，UCHAR，UVARCHAR，またはLONG UVARCHARで指定します。
    UCHAR，UVARCHAR，またはLONG UVARCHARは，SQL Serverを使用する場合で，Unicodeデータを抽出するときだけ使用できます。

文字パターンの指定方法を，次に示します。

表3-9　文字パターンの指定方法

項目 | 指定例 | 意 味
前方一致 | ABC% | 文字列の先頭がABCであり，以降の文字は任意です。
後方一致 | %ABC | 文字列の最後がABCであり，以前の文字は任意です。
任意一致 | %ABC% | 文字列中の任意の部分がABCです。
完全一致 | ABC | 文字列がABCと等しいです。
部分一致 | _ _ABC_ | 6文字の文字列のうち，3～5文字目がABCであり，ほかの部分は任意の文字です。
その他 | ABC%DE | 文字列の先頭がABCであり，最後がDEです。
 | %ABC%DE% | 文字列中の任意の部分にABCを含み，以降の任意の部分にDEを含みます。
 | ABC_ _DE% | 文字列の先頭がABC，任意の文字列2文字を挟んでDE，以降の文字が任意です。

［条件設定］ダイアログの「列一覧」リストから条件を設定する列を選択し，［条件］リストボックスから，LIKE条件式（LIKE，NOT LIKE）を選択します。［条件］テキストボックスに設定値を入力し，［設定］ボタンをクリックします。「一覧」リストに条件式が表示されます。右辺の定数に可変記号を指定したい場合は，［可変記号］ボタンをクリックし，［可変記号］ダイアログで可変記号を入力します。列と定数の規則については，「表3-8　列と定数の規則」を参照してください。

(6)　IN条件

右辺に指定した定数が含まれるデータ，または含まれないデータを抽出します。IN条件の設定は，［IN条件式］ダイアログで設定します。

［条件設定］ダイアログの「列一覧」リストから条件を設定する列を選択し，［IN］ボタンをクリックします。［IN条件式］ダイアログが表示されます。種別を選択し，比較する値を［値］テキストボックスに入力します。比較する値が11個以上になる場合は，［次頁］ボタンをクリックします。右辺の定数に可変記号を指定したい場合は，［可変記号］ボタンをクリックし，［可変記号］ダイアログで可変記号を入力します。入力したら，［IN条件式］ダイアログの［OK］ボタンをクリックします。「一覧」リストに条件式が表示されます。列と定数の規則については，「表3-8　列と定数の規則」を参照してください。

(7)　BETWEEN条件

右辺に指定した定数1と定数2の間(定数1および定数2を含む)のデータ，または間以外(定数1および定数2を含まない)のデータを抽出します。BETWEEN条件の設定は，［BETWEEN条件式］ダイアログで設定します。

［条件設定］ダイアログの「列一覧」リストから条件を設定する列を選択し，［BETWEEN］ボタンをクリックします。［BETWEEN条件式］ダイアログが表示されます。種別を選択し，値1と値2を入力します。右辺の定数に可変記号を指定したい場合は，［可変記号］ボタンをクリックし，［可変記号］ダイアログで可変記号を入力します。入力したら，［BETWEEN条件式］ダイアログの［OK］ボタンをクリックします。「一覧」リストに条件式が表示されます。列と定数の規則については，「表3-8　列と定数の規則」を参照してください。

(8)　列演算条件

演算を用いた条件式で比較します。「+　－　*　/　(　)」および定数を使って条件式を設定して，左辺と右辺を比較して条件に合うデータを抽出します。列演算条件の設定は，［列演算条件式］ダイアログで設定します。

列演算の条件式の指定例を次に示します。

列　{=|<>|>|>=|<|<=}　列
値式　{=|<>|>|>=|<|<=}　値式
値式::=　{ {+|-} 一次子|値式 {+|-|*|/} }　定数
一次子::=　{列|定数}
（凡例）
::=　は，左辺を右辺のとおりに定義することを示します。この形式では，値式，一次子をそれぞれ右辺で定義します。

「+　－　*　/　(　)」および定数を使って条件式を設定して，左辺と右辺を比較して条件に合うデータを抽出します。

列と定数の規則については，「表3-8　列と定数の規則」を参照してください。

条件式に指定する列名は，直接入力するか，または［列一覧］リストから選択します。［列一覧］リストから選択する場合は，列名を選択したあと，［選択］ボタンをクリックすると，［条件式］テキストボックスに入力されます。ただし，列演算の条件式に指定できる列名は，次に示す列属性を持つ列です。

表3-10　条件式に指定できる列名

左辺 | 右辺
NUMERIC，DECIMAL，SMALLINT，INTEGER，REAL，FLOAT，BIT，TINYINT，DOUBLE | NUMERIC，DECIMAL，SMALLINT，INTEGER，REAL，FLOAT，BIT，TINYINT，DOUBLE

［条件設定］ダイアログの「列一覧」リストから条件を設定する列を選択し，［列演算］ボタンをクリックします。［列演算条件式］ダイアログが表示されます。ただし，数値属性以外の列を選択した場合は，［列演算］ボタンは不活性となります。［条件式］テキストボックスに条件式を入力し，［列演算条件式］ダイアログの［OK］ボタンをクリックします。「一覧」リストに条件式が表示されます。

(9)　WHERE句に指定できる条件

SQLのWHERE句の形式で記述した条件を，そのまま指定します。WHERE句に指定できる条件の設定は，［条件式直接入力］ダイアログで設定します。

条件式に指定する列名は，直接入力するか，または［列一覧］リストから選択します。［列一覧］リストから選択する場合は，列名を選択したあと，［選択］ボタンをクリックすると，［条件式］テキストボックスに入力されます。ただし，列演算の条件式に指定できる列名は，次に示す列属性を持つ列です。

表3-11　条件式に指定できる列名

左辺 | 右辺
CHAR，VARCHAR，LONG VARCHAR，MCHAR，MVARCHAR，NCHAR，NVARCHAR | CHAR，VARCHAR，LONG VARCHAR，MCHAR，MVARCHAR，NCHAR，NVARCHAR
NUMERIC，DECIMAL，SMALLINT，INTEGER，REAL，FLOAT，BIT，TINYINT，DOUBLE | NUMERIC，DECIMAL，SMALLINT，INTEGER，REAL，FLOAT，BIT，TINYINT，DOUBLE
DATE | DATE
TIME | TIME
BINARY，VARBINARY，LONG VARBINARY | BINARY，VARBINARY，LONG VARBINARY
TIMESTAMP | TIMESTAMP

［条件設定］ダイアログの「列一覧」リストから条件を設定する列を選択し，［直接入力］ボタンをクリックします。［条件式直接入力］ダイアログが表示されます。［条件式］テキストボックスに条件式を入力し，［条件式直接入力］ダイアログの［OK］ボタンをクリックします。「一覧」リストに条件式が表示されます。

(10)　表結合条件

表と表を結合します。表結合条件については，「3.3.1(4)　複数の表からのデータ抽出（表結合）」を参照してください。

(11)　可変記号の設定

可変記号と初期値を設定します。

(a)　可変記号

可変記号に指定できる文字は，次のとおりです。文字列中に，空白は指定できません。文字列の前後に空白を指定しても無視されます。

  • 全角文字
  • 半角カタカナ
  • 半角英字：A～Z，a～z
  • 半角数字：0～9

先頭1文字目は，全角文字，半角カタカナ，または半角英字を指定してください。

(b)　初期値

指定できる文字列長は255バイト以下です。指定できる属性は，文字定数，数値定数です。一つの可変記号名に対して指定できる初期値は一つです。二つ以上の初期値は指定できません。

指定できる定数の規則は，［条件設定］ダイアログで条件式を設定する場合と同じです。列と定数の規則については，「表3-8　列と定数の規則」を参照してください。

初期値は，指定を省略することもできます。ただし，初期値を指定しない場合は，データを検索する「実行値」を指定する必要があります。「実行値」は，［実行値入力］ダイアログで指定します。


最新列情報の取得

3.3.4　最新列情報の取得

データベースの列情報を更新したあと，再度抽出するデータの抽出条件を設定する場合，実際のデータベースの情報と帳票ファイルまたは見出し辞書に保存される情報の内容が異なることがあります。この場合，最新の列情報を取得し直し，抽出条件を最新の条件に自動更新できます。

列情報は，［抽出］メニューの［列情報の最新］で最新の状態に更新します。抽出条件中の次の内容が更新できます。

  • ［列設定］ダイアログで設定した内容
  • ［条件設定］ダイアログで設定した内容

データベースの列情報の変更内容によって，［列情報の最新］を使用した場合の動作が変わります。

データベースの列情報の変更内容によって，［列情報の最新］を使用した場合の動作がどのように変わるのかを次の表に示します。

表3-12　データベースの変更内容と［列情報の最新］使用時の動作

データベースの変更内容 | ［列情報の最新］使用時の動作
 | ［列設定］ダイアログ | ［条件設定］ダイアログ
列の追加 | 変更はありません。 | 変更はありません。
列の削除 | 削除した列を選択している場合だけ，該当する列が非選択状態になります。 | 条件式中に削除した列が含まれている場合だけ，該当条件式が削除されます。※
列の順序変更 | 変更はありません。 | 変更はありません。
列名変更 | 列名変更した列を選択している場合だけ，該当する列が非選択状態になります。 | 条件式中に列名変更した列が含まれている場合だけ，該当条件式が削除されます。※
その他列情報の変更 | 最新の状態になります。 | 最新の状態になります。
注※
条件式を削除した場合，条件関連式をクリアします。

＜この項の構成＞
(1)　補足説明

(1)　補足説明

  • 最新情報の取得後，［列設定］ダイアログまたは［条件設定］ダイアログを表示した場合の列一覧は，列情報の変更内容に関係なく，最新の状態となります。
  • ［列情報の最新］で列情報を更新しても，仮想列の記述内容は変わりません。
  • 削除した選択列にソートを指定していた場合，削除した選択列のソート優先度より低い優先度を持つ選択列の優先度は，すべて一つ繰り上げとなります。
  • すべての選択列がなくなった場合は，［列設定］ダイアログで列を選択してください。


抽出データの確認

3.4　抽出データの確認

データベースアクセス定義ウィンドウで定義して抽出されたデータを，データ表示ウィンドウに表示して確認できます。

データ表示ウィンドウでできることを次に示します。

  • 実際に抽出を実行する前に，対象となるデータを表示して，そこでデータの内容を確認できます。
    対象となるデータの件数も表示されます。
  • 抽出するデータが正しいか，抽出する条件が正しいかなどを確認できます。
  • データを抽出する時に，データの件数を指定できるので，件数を制限できます。
  • 確認したデータをファイルに保存したり，条件を変更／追加して絞り込んだりできます。

データ表示ウィンドウの機能を次に示します。

表3-13　データ表示ウィンドウの機能

機能 | 説明
次データの抽出 | 表示されている表の最終行に次のデータを追加して表示します。
データの一括表示 | すべてのデータを一括して表示できます。
データのファイル出力 | 抽出結果をCSVファイルに出力できます。データベースアクセス定義ウィンドウの［行番号の付加］チェックボックスにチェックを入れると，CSVファイルに行番号が付加できます。
抽出の中断 | 抽出を中断します。データ量が多い場合に表示されているデータ以降を表示する必要がないときに使用します。
データ表示ウィンドウの終了 | 抽出結果を確認したあとは，データベースアクセス定義ウィンドウに戻ります。

.NET Frameworkがインストールされていない場合，データベースアクセス定義ウィンドウの［抽出確認］ボタンは使用できないため，抽出データは確認できません。

  1. 抽出件数の確認
    データベースアクセス定義ウィンドウの［抽出確認］ボタンをクリックすると，抽出データ数を確認するダイアログが表示されます。

  2. 抽出データの表示
    ［はい］ボタンをクリックすると，データ表示ウィンドウが表示されます。

    抽出されたデータは，表形式で表示され，抽出されたデータ件数は，ステータスバーに表示されます。


データウィンドウへの表示

3.5　データウィンドウへの表示

データベースアクセス定義ウィンドウでデータを抽出して，データウィンドウに表示します。

＜この節の構成＞
(1)　抽出したデータをデータウィンドウに表示する

(1)　抽出したデータをデータウィンドウに表示する

  1. データベースアクセス定義ウィンドウの［OK］ボタンのクリック
    データベースアクセス定義ウィンドウの［OK］ボタンをクリックします。［OK］ボタンは，データベースアクセス定義ウィンドウで表選択と列設定をすると活性になります。
    抽出データ数を確認するダイアログが表示されます。
  2. 抽出データ数の確認
    抽出データの数を確認したら，ダイアログの［はい］ボタンをクリックします。

  3. 抽出データ数の表示
    データベースアクセス定義ウィンドウで抽出したデータが，データウィンドウに表示されます。

    データにタブが指定されている場合，タブを空白に置き換えて表示します。


データウィンドウのフィールド定義

3.6　データウィンドウのフィールド定義

データウィンドウにデータを表示したら，フィールド定義を設定します。

データウィンドウに読み込まれた時のデータ種別のまま，データを帳票ウィンドウに貼り付けると，データの属性が意図したものと異なることがあります。その場合，定義されているデータを正しく扱えません。

データウィンドウから，フィールドを帳票ファイルに貼り付ける前に，フィールド名とフィールド属性を確認したり，変更したりする必要があります。

フィールド定義の操作，注意事項については，マニュアル「EUR 帳票設計」を参照してください。

＜この節の構成＞
3.6.1　データベースのデータ型とEURで扱えるデータ種別との対応
3.6.2　抽出したデータが表示されるときの規則
3.6.3　データウィンドウのフィールド定義


データベースのデータ型とEURで扱えるデータ種別との対応

3.6.1　データベースのデータ型とEURで扱えるデータ種別との対応

データベースから抽出したデータをデータウィンドウに読み込むと，EURで扱えるデータ種別に変換されます。変換されたデータ種別は，［フィールド定義］ダイアログの「種別」で確認できます。

データベースアクセス定義ウィンドウで表示されるデータ型と，EURのデータ種別との対応を次に示します。

表3-14　データベースアクセス定義でのデータ型とEURのデータ種別との対応

データベースアクセス定義でのデータ型（列属性） | データウィンドウでのデータ種別
CHAR，VARCHAR，NCHAR，NVARCHAR，MCHAR， MVARCHAR，LONG VARCHAR，UCHAR※1，UVARCHAR※1，LONG UVARCHAR※1 | 文字列
DATE，TIME，TIMESTAMP | 文字列※2
BINARY，VARBINARY | 文字列※3
DECIMAL，FLOAT，INTEGER，REAL，SMALLINT， NUMERIC，BIT，DOUBLE，TINYINT | 数値
注※1
SQL Serverを使用する場合で，Unicodeデータを抽出するときだけ使用できます。
注※2
データを「日付」として扱う場合は，データ種別を［フィールド定義］ダイアログで変更してください。種別を変更しないと，データベースに格納されているデータがそのまま文字列として表示されます。
注※3
データ種別を［フィールド定義］ダイアログで変更しないと，データベースに格納されているデータがそのまま表示されます。

データ種別については，マニュアル「EUR システム設計ガイド」を参照してください。


抽出したデータが表示されるときの規則

3.6.2　抽出したデータが表示されるときの規則

データウィンドウに抽出したデータが表示されるときの規則について説明します。

＜この項の構成＞
(1)　フィールド名称の設定規則
(2)　フィールドのデータ種別の設定規則
(3)　表示されるレコード件数

(1)　フィールド名称の設定規則

データウィンドウでは，［列設定］ダイアログで設定した列数だけフィールドが定義されます。フィールド名称は，設定した列の属性によって変わります。

定義されるフィールド名称は，次の規則に従って設定されます。

表3-15　フィールド名称の規則

［列設定］ダイアログの設定 | 見出し辞書の使用※ | 列見出しの指定 | 設定される フィールド名称
列一覧 | 使用しない | － | 列名
 | 使用する | なし | 列名
 |  | あり | 列見出し
仮想列 | － | － | 仮想列名
（凡例）
－：該当しません。
注※
［オプション設定］ダイアログの［見出し辞書］チェックボックスにチェックしているかどうかで確認できます。

設定によっては，フィールド名称が重複する場合がありますが，EURではチェックしません。重複したフィールド名称がある場合，重複したフィールドを帳票ウィンドウに貼り付けると，いちばん最初のフィールドのデータだけが表示されます。2番目以降のフィールドのデータは表示されません。

重複したフィールド名称は，［フィールド定義］ダイアログで変更してください。

(2)　フィールドのデータ種別の設定規則

フィールドのデータ種別の設定規則については，「3.6.1　データベースのデータ型とEURで扱えるデータ種別との対応」を参照してください。

(3)　表示されるレコード件数

データウィンドウに表示されるレコード件数は，［条件設定］ダイアログで指定した条件に合ったレコード件数となります。

また，［件数制限］コンボボックスに「なし」以外が指定されている場合は，指定した件数を上限としたレコード件数になります。


データウィンドウのフィールド定義

3.6.3　データウィンドウのフィールド定義

データベースからデータを抽出した場合，フィールド名称はデータベースの列名，フィールドのデータ種別は「表 3-14　データベースアクセス定義でのデータ型とEURのデータ種別との対応」に対応する種別が設定されます。

フィールド名称やフィールド定義を変更したり，削除したりする場合は，マニュアル「EUR 帳票設計」を参照してください。


見出し辞書の設定

3.7　見出し辞書の設定

ここでは，見出し辞書の設定方法と使用方法について説明します。

＜この節の構成＞
3.7.1　見出し辞書とは
3.7.2　見出し辞書の作成
3.7.3　見出し辞書の編集
3.7.4　見出し辞書の使用
3.7.5　見出し辞書の削除


見出し辞書とは

3.7.1　見出し辞書とは

見出し辞書とは，データベースから抽出する表や列に対して，ユーザが付けた表名や列名を登録する辞書のことです。ウィンドウに表示される表名や列名は，通常データベースで定義された名称ですが，見出し辞書を使って表示すると登録した名称で表示できます。登録する表名や列名には，データベースの定義に依存しない業務で使い慣れた名称を使用できるので，表や列を抽出する時に使い慣れた名称で検索できます。

また，見出し辞書を使用した場合，データベースではなく見出し辞書（任意の場所に格納された見出し情報ファイル）にアクセスして，表名や列名を取得するため，データベースへの接続待ち時間を短縮できます。

＜この項の構成＞
(1)　見出し辞書を使用するための設定

(1)　見出し辞書を使用するための設定

見出し辞書機能を使うには，見出し辞書を使用するための設定が必要です。見出し辞書を使用できるようにする設定方法を次に示します。

  1. ［オプション設定］ダイアログの表示
    ［データベースアクセス定義］ウィンドウの［ツール］メニューから［オプション］を選択します。
    ［オプション設定］ダイアログが表示されます。
  2. ［見出し辞書］タブの表示
    ［オプション設定］ダイアログの［見出し辞書］タブを選択します。

  3. ［見出し辞書］の設定
    ［見出し辞書］タブのチェックボックスをオンにします。
  4. 見出し辞書の使用方法の選択
    見出し辞書だけを使うか，データベースの情報と組み合わせて使うかをコンボボックスで選びます。
    • 「見出し辞書の情報を使用する」を選択した場合
      見出し辞書に登録した情報だけが表示されます。
    • 「見出し辞書とDBの情報を使用する」を選択した場合
      見出し辞書に登録した情報とデータベースの情報を組み合わせて表示されます。
  5. 辞書フォルダ参照先の設定
    見出し辞書の参照先は，デフォルトでは次の場所に設定されています。
    見出し辞書で使用するファイルの格納場所
    EUR Designerの場合
    EUR Designerのインストール先フォルダ\partnerW
    EUR Developerの場合
    EUR Developerのインストール先フォルダ\EUR Designer\partnerW
    デフォルトの参照先を変更する場合は，［辞書フォルダ］に変更後の参照先を入力します。
    辞書フォルダの設定は，参照先を直接入力する方法と，選択して入力する方法があります。
    参照先を選択して入力する場合は，［...］ボタンを押すと［辞書の指定］ダイアログが表示されるので，フォルダを指定します。指定した内容は，［辞書フォルダ］に表示されます。

注意
  • 見出し辞書とDBの情報を組み合わせて表示する場合に，見出し辞書に登録していない表や列があるときは，データベースに定義してある情報だけが表示されます。
  • 見出し辞書だけを使う指定(データベースの情報を組み合わせない指定)の場合は，見出し辞書に登録していない表名は，表を選ぶ時に表示されないで使えなくなります。
  • 見出し辞書だけを使う指定をすると，接続先に関係なく，見出し辞書に登録されている表がすべて表示されます。


見出し辞書の作成

3.7.2　見出し辞書の作成

見出し辞書に登録する「見出し」は，一つの表に対して一つ作成します。一つの表ごとに，データベースで定義中の表名や列名に対応する表見出しと列見出しを設定します。設定した内容は，接続先名，所有者名などの情報と合わせて見出し辞書に登録されます。見出し辞書に登録される情報を見出し情報といいます。

＜この項の構成＞
(1)　操作方法

(1)　操作方法

見出し情報の作成方法を次に示します。

  1. ［見出し編集］ダイアログの表示
    ［データベースアクセス定義ウィンドウ］の［ツール］メニューから［見出し編集］を選択します。
    ［見出し編集］ダイアログが表示されます。
  2. ［表選択］ダイアログの表示
    ［見出し編集］ダイアログの［新規作成］ボタンをクリックします。
    ［表選択］ダイアログが表示されます。
  3. 見出しを作成する表の選択
    ［表選択］ダイアログの［表一覧］リストボックスから見出し情報に登録する表を選択します。
    表の選択方法は，表をダブルクリック，または表を選択して［選択］ボタンをクリックして［表選択］ダイアログの［選択表一覧］に設定します。
    ［表選択］ダイアログで選択できる表は一つです。二つ以上は選択できません。
    絞り込み表示をする場合
    ［表一覧］に表示する表は，ワイルドカードを使った絞り込み表示ができます。［表選択］ダイアログの［絞り込み］ボタンをクリックすると，［表の絞り込み条件設定］ダイアログが表示されますので，絞り込む条件を設定してください。

  4. ［OK］ボタンのクリック
    ［OK］ボタンは，［選択表一覧］に表が選択されると活性になります。
    ［OK］ボタンをクリックすると，［表選択］ダイアログが閉じて，［見出し編集］ダイアログに戻ります。
    ［見出し編集］ダイアログでは，［接続先名］，［所有者名］，［表名］，および［列一覧］に選択した表の情報が表示されます。

    接続先名，所有者名，表名，または列一覧がShift JIS以外の場合は，エラーとなります。
  5. 表見出し，グループ名，および列見出しの入力
    見出し情報に設定する項目の定義情報を次に示します。

    表3-16　見出し情報に設定する項目の定義情報

    定義項目 | 最大長（バイト） | 省略時の設定値 | 使用できる文字
    表見出し | 0～30 | デフォルトの表名が設定される※ | 半角文字・全角文字
    列見出し | 0～46 | デフォルトの列名が設定される※ | 半角文字・全角文字
    注※
    データベースで表見出しまたは列見出しが定義されている場合は，データベースで定義した表見出しまたは列見出しが表示されます。

    グループ名は，［見出し選択］ダイアログで設定したグループ名が表示されます。
  6. ［登録］ボタンのクリック
    入力した内容を見出し辞書に登録します。
  7. ［終了］ボタンのクリック
    ［見出し編集］ダイアログが閉じて，［データベースアクセス定義］ウィンドウに戻ります。


見出し辞書の編集

3.7.3　見出し辞書の編集

見出し辞書に登録してある見出し情報を編集します。

見出し情報を編集するには，まず見出し辞書から見出し情報を呼び出します。その後，呼び出した見出し情報の内容を変更し，最後に見出し辞書に再登録します。

＜この項の構成＞
(1)　操作方法

(1)　操作方法

見出し情報の編集方法を次に示します。

  1. ［見出し編集］ダイアログの表示
    ［データベースアクセス定義ウィンドウ］の［ツール］メニューから［見出し編集］を選択します。
    ［見出し編集］ダイアログが表示されます。
  2. ［見出し選択］ダイアログの表示
    ［見出し編集］ダイアログの［見出し一覧］ボタンをクリックします。
    ［見出し選択］ダイアログが表示されます。
    ［登録表一覧］に見出し辞書に登録されている見出し情報が表示されます。

  3. 表見出しの選択
    編集した表見出しの行を選択します。
    ［見出し選択］ダイアログで選択できる行は一つだけです。複数選択すると［編集］ボタンが不活性になり，選択できません。
  4. ［編集］ボタンのクリック
    ［編集］ボタンをクリックすると［見出し選択］ダイアログが閉じて［見出し編集］ダイアログが表示されます。
    ［見出し編集］ダイアログには，選択した表の見出し情報が表示されます。
  5. 表見出し，グループ名，および列見出しの編集
    見出し情報に設定する項目の定義情報を次に示します。

    表3-17　見出し情報に設定する項目の定義情報

    定義項目 | 最大長（バイト） | 省略時の設定値 | 使用できる文字
    表見出し | 0～30 | デフォルトの表名が設定される※ | 半角文字・全角文字
    列見出し | 0～46 | デフォルトの列名が設定される※ | 半角文字・全角文字
    注※
    データベースで表見出しまたは列見出しが定義されている場合は，データベースで定義した表見出しまたは列見出しが表示されます。

    グループ名は，［見出し選択］ダイアログで設定したグループ名が表示されます。グループ名がShift JIS以外の場合は，エラーとなります。
  6. ［登録］ボタンのクリック
    変更した内容が［見出し編集］ダイアログに表示されます。
  7. ［終了］ボタンのクリック
    ［見出し編集］ダイアログが閉じて，［データベースアクセス定義］ウィンドウに戻ります。


見出し辞書の使用

3.7.4　見出し辞書の使用

ここでは，見出し辞書の主な使用方法について説明します。

＜この項の構成＞
(1)　格納先を指定した見出し情報の登録
(2)　見出し情報の一括登録
(3)　見出し辞書のグループ設定
(4)　別のドライブまたはフォルダの見出し情報を読み込む

(1)　格納先を指定した見出し情報の登録

見出し辞書で作成した見出し情報は，デフォルトで指定されたフォルダに格納されています。

編集した見出し情報を別の場所へ格納したい場合は，任意の場所へ設定を変えられます。作成した見出し辞書をほかの使用者に配布する場合や，現在使っている見出し辞書の内容を別のEUR 帳票作成機能で使用する場合などに利用できます。

見出し辞書で作成したファイルの格納場所と，各ファイルの内容は次のとおりです。

見出し辞書で使用するファイルの格納場所
  • EUR Designerの場合
    EUR Designerのインストール先フォルダ\partnerW
  • EUR Developerの場合
    EUR Developerのインストール先フォルダ\EUR Designer\partnerW

    表3-18　見出し辞書で使用するファイル

    内容 | ファイル名
    登録されている見出し情報の一覧 | Dptindex.dpd
    見出しグループの情報 | Dptindex2.dpd
    個々の見出し情報 | Dpt00001.dpd～Dpt65535.dpd
(a)　操作方法

格納先を指定した見出し辞書の登録方法を次に示します。

  1. ［見出し編集］ダイアログの表示
    ［データベースアクセス定義ウィンドウ］の［ツール］メニューから［見出し編集］を選択します。
    ［見出し編集］ダイアログが表示されます。
  2. ［見出し選択］ダイアログの表示
    ［見出し編集］ダイアログの［見出し一覧］ボタンをクリックします。
    ［見出し選択］ダイアログが表示されます。
  3. 格納したい表見出しの選択
    ＜Shift＞キーを押しながら選択すると，複数選択できます。
  4. ［格納先の指定］ダイアログの表示
    ［格納］ボタンをクリックします。［格納先の指定］ダイアログが表示されます。［フォルダ（F）］エリアに現在の見出し情報の格納先が表示されています。
  5. ［見出し選択ダイアログ］の表示
    手順4.で選択した表見出しの格納先を設定したら，［OK］ボタンをクリックします。
    ［格納先の指定］ダイアログが閉じて，［見出し選択］ダイアログに戻ります。
  6. ［見出し選択］ダイアログの表示
    ［閉じる］ボタンをクリックします。［見出し選択］ダイアログが閉じて，［見出し編集］ダイアログに戻ります。

(2)　見出し情報の一括登録

複数の表の見出し情報を，見出し辞書に一括登録できます。

(a)　操作方法

見出し情報の一括登録方法を次に示します。

  1. ［見出し編集］ダイアログの表示
    ［データベースアクセス定義ウィンドウ］の［ツール］メニューから［見出し編集］を選択します。
    ［見出し編集］ダイアログが表示されます。
  2. ［表選択］ダイアログの表示
    ［見出し編集］ダイアログの［一括作成］ボタンをクリックします。［表選択］ダイアログが表示されます。
  3. 一括登録をする表の選択
    一括登録したい表を選択して，［OK］ボタンをクリックします。
    表の選択は，表をダブルクリック，または表を選択して［選択］ボタンをクリックして［選択表一覧］に設定します。表をクリックしただけでは選択されませんので，［見出し編集］ダイアログの下段の［選択表一覧］に選択した表がきちんと設定されているか確認してください。
    • ［登録経過］メッセージボックスの操作方法
      ［OK］ボタンをクリックすると［登録経過］ダイアログが表示され，辞書登録が完了した表名が順番に表示されていきます。［キャンセル］ボタンをクリックすると，現在の辞書登録完了後に残りの辞書登録がキャンセルされます。
  4. ［上書き確認］ダイアログの設定
    すでに見出し情報が登録されている表を選択した場合は，［上書き］ダイアログが表示されます。

    ［はい］ボタンをクリックした場合は，現在の表を上書き登録します。
    ［いいえ］ボタンをクリックした場合は，現在の表の登録を中止して次の表の登録に進みます。
    ［すべて上書き］ボタンをクリックした場合は，現在の表以降に登録済みの表があっても，メッセージで確認することなくすべて上書きします。
    ただし，グループ名の情報は，上書きしても変更されません。
  5. ［OK］ボタンのクリック
    ［見出し編集］ダイアログに戻ります。

(3)　見出し辞書のグループ設定

見出し辞書は，表ごとにグループを設定できます。

表を見出し辞書に登録する時にグループを設定しておくと，グループ名を条件にして表を抽出できます。

(a)　操作方法

見出し辞書のグループ設定方法を次に示します。

  1. ［見出し編集］ダイアログの表示
    ［データベースアクセス定義ウィンドウ］の［ツール］メニューから［見出し編集］を選択します。
    ［見出し編集］ダイアログが表示されます。
  2. ［見出し選択］ダイアログの表示
    ［見出し編集］ダイアログの［見出し一覧］ボタンをクリックします。
    ［見出し選択］ダイアログが表示されます。
  3. 表の選択
    グループを設定したい表を，［登録表一覧］リストから選択します。
    一度に複数の表を登録することもできます。
    表を複数選択する場合は，＜Shift＞キーを押しながら表をクリックすると，複数の表を選択できます。
  4. グループ名の入力
    選択した表に設定するグループ名を，［グループ名］コンボボックスに入力するか，またはリストから選択します。すでに登録されているグループ名は，［グループ名］コンボボックスに格納されています。

  5. グループの設定
    ［グループ名］コンボボックスにグループ名を入力したら，［設定］ボタンをクリックしてグループを設定します。
    ［設定］ボタンをクリックすると，グループ名の設定（変更または削除）を確認するメッセージが表示されます。［はい］をクリックすると，グループ名が設定されます。
    設定した内容は，［見出し選択］ダイアログで登録した表を選択すると，［グループ名］コンボボックスに表示されるので確認できます。

(4)　別のドライブまたはフォルダの見出し情報を読み込む

見出し辞書で参照する見出し情報は，設定されたフォルダのファイルを参照しています。設定された場所ではなく，別の場所にある見出し情報を参照したい場合は，任意の参照先を指定して読み込めます。一つの見出し辞書をマスタ辞書として，必要な見出し情報だけを読み込んで編集して個人用の見出し辞書に登録する場合などに利用すると便利です。

(a)　操作方法

別のドライブまたはフォルダの見出し情報を読み込む方法を次に示します。

  1. ［見出し編集］ダイアログの表示
    ［データベースアクセス定義ウィンドウ］の［ツール］メニューから［見出し編集］を選択します。
    ［見出し編集］ダイアログが表示されます。
  2. ［読み込み先指定］ダイアログの表示
    ［見出し編集］ダイアログの［読み込み］ボタンをクリックします。
    ［読み込み先指定］ダイアログが表示されます。
  3. 読み込み先の指定
    読み込む見出し情報が格納されているドライブまたはフォルダを指定します。
    読み込み先のドライブまたはフォルダをダブルクリックすると，選択した場所が［フォルダ（F）：］下段に表示されます。［［...］］をダブルクリックすると，選択中の階層が一つ上位に上がります。
  4. ［見出し選択］ダイアログの表示
    ［OK］ボタンをクリックすると，［読み込み先指定］ダイアログが閉じて，［見出し選択］ダイアログが表示されます。［見出し選択］ダイアログには，手順3で選択したフォルダに格納されている表見出しの一覧が表示されます。
  5. 読み込む表見出しの選択
    選択できる見出し情報は一つだけです。複数選択すると［編集］ボタンが不活性になり，選択できません。
  6. ［編集］ボタンのクリック
    ［見出し選択］ダイアログが閉じて，［見出し編集］ダイアログが表示されます。［見出し編集］ダイアログには，手順5で選択した表見出しが表示されています。
    読み込んだ見出し情報を編集，または削除する場合は，［見出し編集］ダイアログが行ってください。


見出し辞書の削除

3.7.5　見出し辞書の削除

不要な見出し情報を，見出し辞書から削除します。

＜この項の構成＞
(1)　操作方法

(1)　操作方法

見出し情報の削除方法を次に示します。

  1. ［見出し編集］ダイアログの表示
    ［データベースアクセス定義ウィンドウ］の［ツール］メニューから［見出し編集］を選択します。
    ［見出し編集］ダイアログが表示されます。
  2. ［見出し選択］ダイアログの表示
    ［見出し編集］ダイアログの［見出し一覧］ボタンをクリックします。
    ［見出し選択］ダイアログが表示されます。
  3. ［削除］ボタンのクリック
    削除する表見出しを選択して，［削除］ボタンをクリックします。
    見出し辞書から見出し情報が削除されます。
    ［見出し選択］ダイアログで選択できる見出し情報は一つだけです。複数選択すると［編集］ボタンが不活性になり，選択できません。
    内容を確認してから見出し情報を削除したい場合
    見出し情報を確認したい場合は，［編集］ボタンをクリックして［見出し編集］ダイアログを表示してください。内容を確認後，［見出し編集］ダイアログの［削除］ボタンで削除できます。
  4. ［閉じる］ボタンのクリック
    ［見出し選択］ダイアログが閉じて，［見出し編集］ダイアログが表示されます。
  5. ［終了］ボタンのクリック
    ［見出し編集］ダイアログが閉じて，［データベースアクセス定義］ウィンドウに戻ります。


帳票出力でデータベースからのデータの読み込みに使用するファイル

4.　帳票出力でデータベースからのデータの読み込みに使用するファイル

この章では，帳票出力でデータベースからのデータの読み込みに使用するファイルの形式について説明します。

＜この章の構成＞
4.1　接続情報ファイル
4.2　可変記号値定義ファイル


接続情報ファイル

4.1　接続情報ファイル

接続情報ファイルは，データベースと接続するために必要な情報を定義するファイルです。入力データをデータベースから読み込んで帳票を出力する場合に，接続するデータベースの情報を接続情報ファイルに定義します。

接続情報ファイルは，一つの接続先について一つ作成します。EURの実行時には，接続情報ファイルを一つだけ指定できます。

＜この節の構成＞
4.1.1　接続情報ファイルの作成


接続情報ファイルの作成

4.1.1　接続情報ファイルの作成

接続情報ファイルは，メモ帳などのテキストエディタを使って作成，または編集してください。任意の拡張子のファイルを使用できます。

＜この項の構成＞
(1)　接続情報ファイルの形式
(2)　接続情報ファイルのキーワード
(3)　接続情報ファイルの指定例
(4)　接続情報ファイルでの注意事項
(5)　パスワードの暗号化

(1)　接続情報ファイルの形式

△キーワード△=△値△

（凡例）
△：0個以上のタブ，半角空白，または全角空白を示します。

(2)　接続情報ファイルのキーワード

接続情報ファイルに記述するキーワードを次に示します。接続情報ファイルに指定するキーワードは，大文字，小文字を区別します。

なお，不正なキーワードが指定された場合は，エラー（EUR クライアント帳票出力機能の場合は4651，EUR サーバ帳票出力機能の場合はKEEU055-E）になります。

表4-1　 接続情報ファイルのキーワード

キーワード 値 省略の可否
DABrokerHost DABrokerのホスト名またはIPアドレスを指定します。 ×
DBType データベースの種別を指定します。指定できる種別は，「HiRDB」「ORACLE」または「SQLServer」です。 ×
SendBufferSize 送受信領域サイズを，1～16,000（KB）の値で指定します。 ×
TimeoutInterval 応答監視時間を，0～3,600（秒）の値で指定します。 ×
Hostname※1※2 データベースの種別ごとに，データベースホスト名を指定します。
  • 「HiRDB」の場合：ホスト名またはIPアドレス（PDHOST指定値）
  • 「ORACLE」の場合：ネット・サービス名（省略可）
  • 「SQLServer」の場合：ODBCデータソース名
 ○
HostInfo※1※2 データベースの種別ごとに，データベース識別子を指定します。
  • 「HiRDB」の場合：接続ポート番号（PDNAMEPORT指定値）
  • 「ORACLE」の場合：指定不要
  • 「SQLServer」の場合：指定不要
 ○
User※1※3 ユーザIDを指定します。 ×
Password※1※3 パスワードを指定します。EURサーバ帳票出力機能では，暗号化したパスワードも指定できます。パスワードの暗号化については，「4.1.1(5)　パスワードの暗号化」を参照してください。 ○
QueryExclusiveString※1
  • データを抽出する時のデータベースへの排他オプションを指定します。ここで指定した文字列は，EUR サーバ帳票出力機能が作成したSQLの最後に付加されます。
  • キーワードQueryExclusiveStringの指定は，接続先データベースがHiRDBの場合に有効です。排他オプションの詳細については，マニュアル「HiRDB UAP開発ガイド」を参照してください。
 ○
EncryptPassword パスワードが，暗号化されているかされていないかが設定されます。
このキーワードは，EUR サーバ帳票出力機能で接続情報パスワード暗号化ツールを実行すると自動的に設定されるので，指定および変更をしないでください。 		△
（凡例）
○：指定を省略できるキーワードです。
△：指定および変更してはいけないキーワードです。
×：必ず指定するキーワードです。
注※1
キーワードの指定は，接続先データベースに依存します。そのため，指定を省略できるキーワードでも，接続先データベースでは指定が必要な場合もあります。接続情報ファイルに記述するキーワードの指定規則については，接続先データベースのマニュアルを参照してください。
注※2
DABrokerをインストールしたマシンで設定したデータベースの接続情報を指定してください。データベースの接続情報の詳細ついては「2.3.5　データベースごとの設定」を参照してください。
注※3
EURは，指定されたユーザIDおよびパスワードを，直接データベースに渡します。指定する文字列の規則については，接続先データベースのマニュアルを参照してください。

(3)　接続情報ファイルの指定例

接続情報ファイルの指定例を次に示します。

DABrokerHost = hostname
DBType = HiRDB
SendBufferSize = 64
TimeoutInterval = 60
User = USERID
QueryExclusiveString = WITH ROLLBACK

(4)　接続情報ファイルでの注意事項

各データベースへ接続するときの注意事項について説明します。データベースの接続設定については，「2.3.5　データベースごとの設定」を参照してください。

(a)　HiRDBと接続する場合
  • Hostnameに，接続先のHiRDBのホスト名またはIPアドレス（PDHOST指定値）を指定します。データベースホスト名の指定を省略したときは，DABrokerがインストールされているマシンのPDHOSTの値が仮定されます。
  • HostInfoに，接続先のHiRDBが使用するポート番号（PDNAMEPORT指定値）を指定します。データベース識別子の指定を省略したときは，DABrokerがインストールされているマシンのPDNAMEPORTの値が仮定されます。
(b)　Oracleと接続する場合

Hostnameに，DABrokerが使用するOracleのネット・サービス名を指定します。Hostnameの指定を省略したときは，DABrokerがインストールされているマシンのORACLE_SIDの値が仮定されます。

(c)　SQL Serverと接続する場合

Hostnameに，DABrokerがインストールされているマシンの，［ODBCデータソースアドミニストレータ］ダイアログの［システムDSN］タブで設定したSQL Serverのデータソース名を指定します。

(5)　パスワードの暗号化

EUR サーバ帳票出力機能では，セキュリティを強化するために，接続情報ファイルに設定されたキーワードPasswordのパスワードを暗号化できます。パスワードを暗号化すると，接続情報ファイルのキーワード「EncryptPassword」に「TRUE」が設定されます。

(a)　パスワードを暗号化する方法

パスワードの暗号化は，接続情報パスワード暗号化ツールで行います。 接続情報パスワード暗号化ツールは，EUR DeveloperおよびEUR Server製品（EUR Server Print Edition，EUR Server Standard，EUR Server Enterprise）に同梱されています。

  • Windows環境のファイルを暗号化する場合
    Windows環境の接続情報ファイルのパスワードを暗号化する場合は，接続情報パスワード暗号化ツール「eurecdif.exe」を使用します。「eurecdif.exe」はEUR Developer，またはWindows版のEUR Server製品（EUR Server Print Edition，EUR Server Standard，EUR Server Enterprise）のインストール先フォルダ\Cipher\x64\下にあります。
  • コマンドの構文
    eurecdif.exe
     /if 暗号化対象ファイルパス
     /of 出力先ファイルパス
  • /ifオプション
    パスワードを暗号化する接続情報ファイル名のフルパスを，259文字以内で指定します。
  • /ofオプション
    パスワードを暗号化したデータを出力するファイルのフルパスを，259文字以内で指定します。
  • UNIX／Linux環境のファイルを暗号化する場合
    UNIX／Linux環境の接続情報ファイルを暗号化する場合は，接続情報パスワード暗号化ツール「eurecdif」を使用します。「eurecdif」は，/opt/eur/print/bin/下にあります。
  • コマンドの構文
    eurecdif
     -if 暗号化対象ファイルパス
     -of 出力先ファイルパス
  • -ifオプション
    パスワードを暗号化する接続情報ファイル名のフルパスを，1,023バイト以内で指定します。
  • -ofオプション
    パスワードを暗号化したデータを出力するファイルのフルパスを，1,023バイト以内で指定します。
(b)　出力されるファイル

パスワード暗号化ツールのコマンドを実行すると，接続情報ファイルの中のパスワードだけを暗号化し，指定したファイルに出力されます。暗号化前のファイルへの上書きはできません。


可変記号値定義ファイル

4.2　可変記号値定義ファイル

可変記号値定義ファイルは，データベースからデータを検索し，条件に合ったデータを抽出する時に必要な，検索条件の可変記号とその値（可変記号値）を定義するためのファイルです。

帳票作成時に設定された可変記号に，可変記号値を定義することで，条件に合った抽出データで帳票を出力できます。接続情報ファイルと組み合わせて使用します。

可変記号値定義ファイルは，一つの帳票ファイルに対して，マッピングデータ用とユーザ定義データ用にそれぞれ一つずつ作成できます。可変記号を使用しない場合は，可変記号値定義ファイルは省略できます。

＜この節の構成＞
4.2.1　可変記号値定義ファイルの作成


可変記号値定義ファイルの作成

4.2.1　可変記号値定義ファイルの作成

可変記号値定義ファイルは，メモ帳などのテキストエディタを使って作成，または編集してください。任意の拡張子のファイルを使用できます。

＜この項の構成＞
(1)　可変記号値定義ファイルの形式
(2)　可変記号値定義ファイルの指定例

(1)　可変記号値定義ファイルの形式

△可変記号1△=△値1△
△可変記号2△=△値2△
           ：
△可変記号n△=△値n△
（凡例）
△：0個以上のタブ，半角空白または全角空白を示します。
n ：複数指定ができることを示します。
■可変記号
可変記号には，EUR 帳票作成機能で［可変記号入力］ダイアログに設定した可変記号の文字列を指定します。指定できる可変記号の数は，255個までです。1個の可変記号の文字列長は，254バイトまでです。同一名の可変記号は指定できません。指定された場合，最初に記述した可変記号名だけが有効となり，2番目以降の記述は無視されます。
可変記号に指定できる文字は，次のとおりです。半角空白は指定できません。
  • 全角文字：漢字，ひらがな，カタカナ，英字（Ａ～Ｚ），数字（０～９）
  • 半角カタカナ
  • 半角英字：A～Z
  • 半角数字：0～9
先頭1文字目は，全角文字，半角カタカナ，または半角英字を指定してください。先頭1文字目に，半角数字は指定できません。
帳票作成時に設定された可変記号を指定しなかった場合，または可変記号値定義ファイルを省略した場合は，可変記号値は初期値を使用します。
帳票作成時に設定されていない可変記号を指定した場合エラー（EUR クライアント帳票出力機能の場合は4658または4672，EUR サーバ帳票出力機能の場合はKEEU056-E）となります。
■可変記号値
検索条件の文字列を指定します。
可変記号値については，各データベースの仕様に依存します。

(2)　可変記号値定義ファイルの指定例

可変記号値定義ファイルの指定例を次に示します。

代理店 = 横浜
請求書番号 = 100


データベースアクセス定義のウィンドウとダイアログ

5.　データベースアクセス定義のウィンドウとダイアログ

この章では，データベースアクセス定義のウィンドウとダイアログについて説明します。

＜この章の構成＞
5.1　データベースアクセス定義ウィンドウ
5.2　データ表示ウィンドウ
5.3　［表選択］ダイアログ
5.4　［表一覧表示方法の設定］ダイアログ
5.5　［表の絞り込み条件設定］ダイアログ
5.6　［列設定］ダイアログ
5.7　［集合関数設定］ダイアログ
5.8　［ソート設定］ダイアログ
5.9　［仮想列編集］ダイアログ
5.10　［条件設定］ダイアログ
5.11　［表結合条件］ダイアログ
5.12　［IN条件式］ダイアログ
5.13　［BETWEEN条件式］ダイアログ
5.14　［列演算条件式］ダイアログ
5.15　［条件式直接入力］ダイアログ
5.16　［可変記号入力］ダイアログ
5.17　［見出し編集］ダイアログ
5.18　［読み込み先の指定］ダイアログ
5.19　［見出し選択］ダイアログ
5.20　［辞書一覧表示方法の設定］ダイアログ
5.21　［格納先の指定］ダイアログ
5.22　［オプション設定］ダイアログ
5.23　［実行値入力］ダイアログ
5.24　［辞書の指定］ダイアログ
5.25　［EUR ODBC Driver - セットアップ -］ダイアログ
5.26　［EUR ODBC Driver - 環境定義 -］ダイアログ


データベースアクセス定義ウィンドウ

5.1　データベースアクセス定義ウィンドウ

データベースからデータを抽出する時に，絞り込む条件を定義するウィンドウです。

［データ］メニューの［データベースアクセス定義］を選択すると，［データソースの選択］ダイアログが表示されます。接続するデータの情報を入力し，データベースへ接続ができると，データベースアクセス定義ウィンドウが表示されます。

データベースへの接続情報の設定方法については，「2.1　データベースの接続の概要」の説明を参照してください。

＜この節の構成＞
(1)　データベースアクセス定義ウィンドウのメニュー
(2)　データベースアクセス定義ウィンドウで設定できる項目
(3)　画面構成

(1)　データベースアクセス定義ウィンドウのメニュー

データベースアクセス定義ウィンドウに表示されるメニューと，各メニューに対応するツールバーボタンを次の表に示します。

表5-1　データベースアクセス定義ウィンドウのメニュー一覧

メニュー | ドロップダウンメニュー | 機能 | ツールバーボタン
接続(A) | 接続(C)... | データベースに接続します。操作中にタイムアウトした場合に，再接続するために使用します。 | [図データ]
 | 切断(D) | データベースとの接続を切ります。接続しているデータベースとの接続を切るために使用します。 | [図データ]
抽出(S) | 表名(T)... | ［表選択］ダイアログが表示されます。［表選択］ダイアログでは，接続したデータベースから表を選択できます。［表選択］ダイアログから制御が戻ると，選択された表名が［表名］ボタン横に表示されます。 | [図データ]
 | 列設定(U)... | ［列設定］ダイアログが表示されます。［列設定］ダイアログでは，選択した表の中から，抽出する列を選択できます。［列設定］ダイアログから制御が戻ると，選択された列名が［列設定］ボタン横に表示されます。 | [図データ]
 | 条件設定(C)... | ［条件設定］ダイアログが表示されます。［条件設定］ダイアログでは，列データを絞り込む条件を設定します。［条件設定］ダイアログから制御が戻ると，［条件設定］ボタン下に条件が表示されます。また，条件関連式が［関連］テキストボックスに設定されている場合は，「条件関連：」横に条件式が表示されます。 | [図データ]
 | 抽出確認(E) | データ表示ウィンドウが表示されます。データ表示ウィンドウでは，データベースアクセス定義ウィンドウで定義した結果，抽出されたデータを表形式で表示します。可変記号が設定されている場合は，データ表示ウィンドウを表示する前に，［実行値入力］ダイアログが表示されます。 ただし，.NET Frameworkがインストールされていない場合，抽出確認はできません。 | [図データ]
 | 列情報の最新(N) | 列情報を最新にします。 | －
ツール(X) | 見出し編集(L)... | ［見出し編集］ダイアログが表示されます。［見出し編集］ダイアログでは，見出し辞書の新規作成，または見出し辞書に登録されている見出し情報を編集できます。 | [図データ]
 | オプション(O)... | ［オプション設定］ダイアログが表示されます。［オプション設定］ダイアログでは，［抽出］，［表示］，および［見出し辞書］のタブを表示します。 | －
ヘルプ(H) | このウィンドウの説明(W) | ヘルプが表示されます。 | －
（凡例）
－：該当しません。

(2)　データベースアクセス定義ウィンドウで設定できる項目

［表名］ボタン
［表選択］ダイアログが表示されます。
［表選択］ダイアログから制御が戻ると，選択された表名が［表名］ボタン横に表示されます。
［列設定］ボタン
［列設定］ダイアログが表示されます。
［列設定］ダイアログから制御が戻ると，選択された列名が［列設定］ボタン横に表示されます。［列設定］ダイアログで選択した列に，フォーカスを持つ列の表ヘッダ，または列ヘッダを表示する表ヘッダがない場合は「表名」が表示されます。列ヘッダがない場合は「列名」が表示されます。表名，または列名が，表示エリアを超えるような場合は，エリア内で文字列をスクロールすることで参照できます。また，［列設定］ダイアログの［選択列］リストに抽出された列の個数（nnn）が，「選択列：」横に表示されます。表示範囲は，1～99,999（個）です。抽出した列の個数が表示範囲を超える場合は，表示されません。
［選択列表示］グリッド
［列設定］ボタンの下に，選択された表名，列名，および情報が表形式で表示されます。
［行番号の付加］チェックボックス
抽出結果を表示するデータウィンドウに行番号を追加するかどうかを指定します。チェックを入れると，［項目名］テキストボックスに，行番号のタイトルを入力できます。
［項目名］テキストボックス
行番号のタイトルを入力します。デフォルトは，「項番」です。30文字まで入力できます。［行番号の付加］チェックボックスにチェックを入れると，入力できます。
［条件設定］ボタン
［条件設定］ダイアログが表示されます。［条件設定］ダイアログから制御が戻ると，［条件設定］ボタン下に条件が表示されます。また，条件関連式が［関連］テキストボックスに設定されている場合は，「条件関連：」横に条件式が表示されます。
［件数制限］コンボボックス
抽出するデータ件数を指定します。データ件数は，直接入力するか，またはリストから選択します。抽出できるデータ件数は，1～999,999,999です。リストには，次に示す値が表示されます。
なし，1～9，10，20，30，40，50，100，200，300，400，500，1000，2000，3000，4000，5000，10000
［件数制限］コンボボックスに何も指定しなかった場合，または「なし」を入力した場合は，「制限なし（999,999,999）」と見なされます。
［件数表示］チェックボックス
データを抽出する時，抽出された件数をメッセージ表示するかどうかを設定します。デフォルトは，「オン（メッセージ表示する）」です。
［抽出確認］ボタン
データ表示ウィンドウを表示します。データ表示ウィンドウについては，「5.2　データ表示ウィンドウ」を参照してください。また，可変記号が設定されている場合は，データ表示ウィンドウを表示する前に，［実行値入力］ダイアログが表示されます。
ただし，.NET Frameworkがインストールされていない場合，抽出確認はできません。
［逐次出力］チェックボックス
データ表示ウィンドウを表示した時，抽出されたデータを特定の件数ずつ区切って表示するかどうかを設定します。デフォルトは，「オフ（区切って出力しない）」です。［逐次出力］チェックボックスをオンにすると，表示する件数を指定できます。デフォルトは，「10（件）」です。
［OK］ボタン
データを抽出するかどうかを確認するダイアログが表示されます。［はい］ボタンをクリックすると，データウィンドウに抽出したデータが表示されます。
［キャンセル］ボタン
データウィンドウに戻ります。確認ダイアログが表示され，データベースアクセス定義ウィンドウでの操作が無効になることが通知されます。

(3)　画面構成

[目次][前へ][次へ]

[他社商品名称に関する表示]

All Rights Reserved. Copyright (C) 2012, Hitachi, Ltd.
All Rights Reserved. Copyright (C) 2012, Hitachi Solutions, Ltd.


データ表示ウィンドウ

5.2　データ表示ウィンドウ

データベースアクセス定義ウィンドウで定義した結果，抽出されたデータを表形式で表示するウィンドウです。抽出データを確認するために利用します。ただし，.NET Frameworkがインストールされていない場合，データ表示ウィンドウは使用できません。

データ表示ウィンドウの表示方法については，「3.　帳票作成時のデータベースからのデータの読み込み」を参照してください。

＜この節の構成＞
(1)　データ表示ウィンドウのメニュー
(2)　データ表示ウィンドウで設定できる項目
(3)　画面構成

(1)　データ表示ウィンドウのメニュー

データ表示ウィンドウに表示されるメニューと，各メニューに対応するツールバーボタンを次の表に示します。

表5-2　データ表示ウィンドウのメニュー一覧

メニュー | ドロップダウンメニュー | 機能 | ツールバーボタン
ファイル(F) | 終了(X) | データベースアクセス定義ウィンドウに戻ります。 | －
抽出(S) | 次データ表示(N) | 逐次出力の場合，表示されている表の最終行に次データを追加します。 | [図データ]
 | 一括表示(A) | 逐次出力の場合，すべてのデータを一括して表示できます。 | [図データ]
 | ファイルへ出力(O)... | 抽出結果をCSVファイルに出力できます。 | [図データ]
 | 中断(C) | 抽出を中断します。データ量が多い場合に表示されているデータ以降を表示する必要がないときに使用します。 | [図データ]
ヘルプ(H) | このウィンドウの説明(W) | ヘルプが表示されます。 | －
（凡例）
－：該当しません。

(2)　データ表示ウィンドウで設定できる項目

項目行
項目行には，行番号列のタイトルと，抽出したデータの各列の名称が表示されます。行番号の編集はできません。列幅は，各列の境界をドラッグすると，変更できます。表示できる列数は，1～1,000です。1,000列を超える列は，表示されません。
データ行
データ行には，行番号と，抽出したデータが表示されます。抽出されたデータが20,000行以上ある場合は，切り捨てられます。
行番号セル
行番号には，抽出されたデータの先頭行を1として，番号が昇順に表示されます。
データセル
データセルには，抽出されたデータが表示されます。文字属性の列は左詰めに表示され，数値属性のデータは右詰めに表示されます。
列幅は，表示する文字数に合わせて，自動的に拡張されます。
(a)　表形式の表示件数を制限する場合

表形式で表示されるデータ数は，データベースアクセス定義ウィンドウの［逐次出力］チェックボックスの設定によって異なります。

［逐次出力］チェックボックスがオフの場合は，抽出されたデータ件数すべてが表示されます。

［逐次出力］チェックボックスをオンにして，件数を設定している場合は，設定されている件数分のデータが表形式で表示されます。

逐次出力の場合，ツールバーの [図データ] ボタンをクリックすると，表示されている表形式の最終行に次データを追加して表示されます。現在表示されているデータ以降を表示する必要がない場合は， [図データ] ボタンをクリックすると，中断できます。すべてのデータを一括して表示したい場合は， [図データ] ボタンをクリックしてください。

(b)　抽出するデータ件数を制限する場合

データを抽出する時，あらかじめデータ件数を指定できます。例えば，次のような抽出をする場合は，件数を制限しておくと便利です。

  • 大量のデータを抽出する前に，指定した件数のデータを抽出して，その内容を確認したいとき
(c)　抽出結果をファイル出力する場合

抽出結果をCSV形式ファイルに出力できます。［抽出］メニューから［ファイルへ出力］を選択してください。

出力する文字コードはUTF-16（リトルエンディアン固定）となります。

(3)　画面構成

抽出されたデータ件数は，ステータスバーに表示されます。

表形式で表示されるデータ数は，データベースアクセス定義ウィンドウの［逐次出力］チェックボックスの設定によって異なります。

［逐次出力］チェックボックスがオフの場合は，抽出されたデータ件数すべてが表示されます。

［逐次出力］チェックボックスをオンにして，件数を設定している場合は，設定されている件数分のデータが表形式で表示されます。


［表選択］ダイアログ

5.3　［表選択］ダイアログ

接続先のデータベースに定義されている表の一覧から，抽出する表を選択するダイアログです。

＜この節の構成＞
(1)　［表選択］ダイアログで設定できる項目
(2)　画面図

(1)　［表選択］ダイアログで設定できる項目

［表選択］ダイアログで設定できる項目を次に示します。

［表一覧］リスト
接続先のデータベースに定義されている表の一覧が表示されます。
  • ［表一覧］に表示する項目を変更したい場合
    ［表一覧表示方法の設定］ダイアログで設定します。［表一覧表示方法の設定］ダイアログは，［詳細表示］チェックボックスをオンにしたあと，［表示設定］ボタンをクリックすると表示されます。表示項目には，「グループ名」，「所有者」，「表名」，「種別」，および「注釈」があります。［表一覧表示方法の設定］ダイアログについては，「5.4　［表一覧表示方法の設定］ダイアログ」を参照してください。
    ［詳細表示］チェックボックスがオフの場合は，「所有者」と「表名」が表示されます。見出し辞書を読み込んでいる場合は，「表名」の代わりに「表見出し」が表示されます。
  • 抽出する表を選択する場合
    ［表一覧］リストの中から抽出する表を選択したあと，［選択］ボタンをクリックするか，または抽出する表をダブルクリックすると，［選択表一覧］リストに設定できます。選択された表は，現在表示されている表の末尾に追加されます。選択できる表数は，15までです。表数が15になると，［選択］ボタンは不活性になります。
    ［選択表一覧］リストに表示する項目も［表一覧表示方法の設定］ダイアログで設定できます。
  • 表を絞り込む場合
    ［表一覧］に表示されている表名（見出し辞書を読み込んでいる場合は「表見出し」）を基に，選択する表を絞り込めます。表の絞り込みは，［表の絞り込み条件設定］ダイアログで設定します。［表の絞り込み条件設定］ダイアログは，［絞り込み］ボタンをクリックすると表示されます。［表の絞り込み条件設定］ダイアログについては，「5.5　［表の絞り込み条件設定］ダイアログ」を参照してください。
  • 選択した表を削除する場合
    ［選択表一覧］の中から削除する表を選択したあと，［削除］ボタンをクリックするか，または削除する表をダブルクリックすると，［選択表一覧］リストから削除できます。
［接続先］情報
［オプション設定］ダイアログの［見出し辞書］タブで，［見出し辞書の情報を使用する］がオンに設定されている場合，見出し辞書に格納されている接続先が表示されます。接続先は，「表一覧：」横の「接続先：」に表示されます。

(2)　画面図

[目次][前へ][次へ]

[他社商品名称に関する表示]

All Rights Reserved. Copyright (C) 2012, Hitachi, Ltd.
All Rights Reserved. Copyright (C) 2012, Hitachi Solutions, Ltd.


［表一覧表示方法の設定］ダイアログ

5.4　［表一覧表示方法の設定］ダイアログ

［表選択］ダイアログの［表一覧］リスト，または［選択表一覧］リストに表示する項目を設定，または変更するダイアログです。

＜この節の構成＞
(1)　［表一覧表示方法の設定］ダイアログで設定できる項目
(2)　画面図

(1)　［表一覧表示方法の設定］ダイアログで設定できる項目

［表一覧表示方法の設定］ダイアログで設定できる項目を次に示します。

［表示項目］リスト
［表一覧］，または［選択表一覧］に表示する項目と，各項目の表示設定状態が表示されます。
［表示項目］リストには，「表示種別」と「項目名」が表示されます。項目には，「グループ名」，「所有者」，「表名」，「種別」，および「注釈」があります。
項目名を選択したあと，［表示］ボタン，または［非表示］ボタンをクリックすると，［表一覧］，または［選択表一覧］に表示する項目を設定，または変更できます。ただし，表名は非表示にできません。グループ名は，見出し辞書を使用した場合に表示されます。
デフォルトは，「グループ名」だけ非表示に設定されています。

(2)　画面図

[目次][前へ][次へ]

[他社商品名称に関する表示]

All Rights Reserved. Copyright (C) 2012, Hitachi, Ltd.
All Rights Reserved. Copyright (C) 2012, Hitachi Solutions, Ltd.


［表の絞り込み条件設定］ダイアログ

5.5　［表の絞り込み条件設定］ダイアログ

［表選択］ダイアログの［表一覧］リストに表示されている表名（見出し辞書を読み込んでいる場合は「表見出し」）を基に，選択する表を絞り込む条件を設定するダイアログです。

＜この節の構成＞
(1)　［表の絞り込み条件設定］ダイアログで設定できる項目
(2)　画面図

(1)　［表の絞り込み条件設定］ダイアログで設定できる項目

［表の絞り込み条件設定］ダイアログで設定できる項目を次に示します。

［所有者］／［表名］コンボボックス
所有者名，または表名に対する絞り込み条件を指定します。絞り込み条件は，今までに設定した条件のうち，最新の5個が表示されます。
条件に指定できる文字
使える文字は，全角文字または半角文字です。Unicodeが入力できます。
絞り込み条件の文字列の前後に指定された空白は無視されます。
［表の絞り込み条件設定］ダイアログを表示した時，［所有者］コンボボックスと［表名］コンボボックスには，「*」が表示されます。
絞り込む条件の文字列があいまいな場合は，ワイルドカードを使用できます。ワイルドカードに使用できる記号を次に示します。
使用できる記号 説明
* 任意の長さの文字列を示します。
0文字以上の文字列を絞り込む場合に指定します。
? 任意の1文字（半角文字または全角文字）を示します。
また，次の文字パターンで表を絞り込めます。
前方一致(例：ABC*)：文字列の先頭がABCで以降は任意の文字
後方一致(例：*ABC)：文字列の最後がABCで以前は任意の文字
部分一致(例：?ABC?)：5文字の文字列のうち，2～4文字目がABC
中間一致(例：*ABC*)：文字列にABCを含む
「*」と「?」はワイルドカードに使用するため，絞り込みのキーワードに指定できません。
指定できる長さ
条件に指定できる長さは，所有者名と表名の合計で254バイト以内です。前後に空白が設定されている場合は，空白は無視します。
絞り込み対象
表名で絞り込まれます。見出し辞書を使っている場合は，見出し辞書に登録している表見出しで絞り込まれます。
［英大小文字同一視］チェックボックス
絞り込む文字列の英字の大文字と小文字を同一視するかどうかを設定します。絞り込む文字列に英字が含まれていない場合，設定は無視されます。デフォルトは，「オフ（同一視しない）」です。
［英大小文字同一視］チェックボックスをオンにすると，「abc」と「ABC」は同じ文字列（同一視する）と見なされます。ただし，全角文字は，対象としません。

(2)　画面図

[目次][前へ][次へ]

[他社商品名称に関する表示]

All Rights Reserved. Copyright (C) 2012, Hitachi, Ltd.
All Rights Reserved. Copyright (C) 2012, Hitachi Solutions, Ltd.


［列設定］ダイアログ

5.6　［列設定］ダイアログ

選択した表の中から，さらに抽出する列を選択するダイアログです。

＜この節の構成＞
(1)　［列設定］ダイアログで設定できる項目
(2)　画面図

(1)　［列設定］ダイアログで設定できる項目

［列設定］ダイアログで設定できる項目を次に示します。

［表名］コンボボックス
データベースアクセス定義ウィンドウに設定されている表名が表示されます。複数の表が選択されている場合は，「全表示」が表示されます。
［列一覧］オプションボタン
選択された表に定義されている列名が，［列一覧］リストに表示されます。デフォルトは，「オン（表名を表示する）」です。
［仮想列］オプションボタン
データベース中から抽出した列の値を編集した仮想列名が，［列一覧］リストに表示されます。仮想列が設定されていない場合は，「（仮想列）」が表示されます。デフォルトは「オフ（仮想列を表示しない）」です。
［表名非表示］チェックボックス
複数の表が選択されている場合，活性になります。
［選択列］リストに表名を表示するかどうかを設定できます。デフォルトは，「オフ（表示する）」です。
［列一覧］リスト
表に定義されている列名が一覧表示されます。複数の表が選択されている場合は，［表名］コンボボックスの状態によって，［列一覧］リストの表示が異なります。
  • ［表名］コンボボックスから「全表示」を選択した場合
    すべての表の列名が表示されます。
  • ［表名］コンボボックスの表名リストから，一つの表を選択した場合
    選択した表の列名だけが表示されます。
  • ［選択列］リストに列を表示する場合
    ［列一覧］リストから選択する列名を一つ，または複数選択したあと，［追加］ボタンをクリックすると，［選択列］リストの末尾に追加表示されます。［選択列］リストの任意の位置に列名を追加したい場合は，列名を一つ，または複数選択したあと，挿入したい位置で［挿入］ボタンをクリックします。
  • ［列一覧］リストに仮想列を表示する場合
    ［仮想列］オプションボタンをチェックします。仮想列は，列名に対する任意の文字列が設定されている場合，表示されます。仮想列が設定されていると，［列一覧］リストに仮想列名が表示されます。仮想列が設定されていない場合は，「（仮想列）」が表示されます。
  • ［列一覧］リストに表示されている仮想列を追加，または挿入する場合
    仮想列を選択したあと，［追加］ボタン，または［挿入］ボタンをクリックすると，［仮想列編集］ダイアログが表示されます。［仮想列編集］ダイアログについては，「5.9　［仮想列編集］ダイアログ」を参照してください。
    ［仮想列編集］ダイアログで仮想列を作成または編集すると，仮想列が［列一覧］リストと［選択列］リストに追加または挿入されます。仮想列は，データベースアクセス定義で抽出した結果にだけ追加され，データベースの内容には影響しません。
  • ［列一覧］リストの表示幅を広げたい場合
    マウスを［列一覧］リストと［選択列］リストの境界線に合わせて，左右にドラッグします。
［選択列］リスト
［列一覧］リストから選択した列名が一覧表示されます。［列一覧］リストから列名を選択すると，［選択列］リストに設定されている列数が，［選択列］リスト右下の「選択列：」に表示されます。［列選択］リストに選択または追加できる列は，1～10,000です。
［列名］には，選択した列名が表示されます。集合関数が設定されている場合は，「集合関数（列名）」の書式で表示されます。
  • ［選択列］リストの列，または仮想列の表示位置を変更する場合
    列，または仮想列を選択したあと，［↑］ボタン，または［↓］ボタンをクリックします。
  • ［選択列］リストに表示されている仮想列を編集する場合
    編集する仮想列を選択したあと［編集］ボタンをクリックすると，［仮想列編集］ダイアログが表示されます。［仮想列編集］ダイアログには，選択した仮想列の情報が表示されます。［仮想列編集］ダイアログについては，「5.9　［仮想列編集］ダイアログ」を参照してください。
  • ［選択列］リストから列を削除する場合
    削除する列を選択したあと，［削除］ボタンをクリックします。仮想列を削除すると，［列一覧］リストに表示されている仮想列も削除されます。
  • ［選択列］リストに表示されている列をすべて削除する場合
    ［全列削除］ボタンをクリックします。［列一覧］リストに表示されている仮想列も削除されます。
  • ［選択列］リストの表示幅を広げたい場合
    マウスを［列一覧］リストと［選択列］リストの境界線に合わせて，左右にドラッグします。
［削除］ボタン
［選択列］リストから選択した列を削除します。仮想列を削除すると，［列一覧］リストに表示されている仮想列も削除されます。
［全列削除］ボタン
［選択列］リストに表示されているすべての列を削除します。仮想列を削除すると，［列一覧］リストに表示されている仮想列も削除されます。
［集合関数］ボタン
列に集合関数を設定する［集合関数設定］ダイアログが表示されます。［集合関数設定］ダイアログについては，「5.7　［集合関数設定］ダイアログ」を参照してください。
［ソート］ボタン
列にソート条件を設定する［ソート設定］ダイアログが表示されます。［ソート設定］ダイアログについては，「5.8　［ソート設定］ダイアログ」を参照してください。
［編集］ボタン
［仮想列編集］ダイアログが表示されます。［仮想列編集］ダイアログについては，「5.9　［仮想列編集］ダイアログ」を参照してください。
［↑］ボタン，［↓］ボタン
列または仮想列の表示位置を変更します。
［追加］ボタン
［列一覧］リストで選択した列を，［選択列］リストの最終行に追加します。
［挿入］ボタン
［列一覧］リストで選択した列を，［選択列］リストで選択した列の前に挿入します。

(2)　画面図

[目次][前へ][次へ]

[他社商品名称に関する表示]

All Rights Reserved. Copyright (C) 2012, Hitachi, Ltd.
All Rights Reserved. Copyright (C) 2012, Hitachi Solutions, Ltd.


［集合関数設定］ダイアログ

5.7　［集合関数設定］ダイアログ

［列設定］ダイアログで指定した列のデータに，集合関数を設定するダイアログです。

＜この節の構成＞
(1)　［集合関数設定］ダイアログで設定できる項目
(2)　画面図

(1)　［集合関数設定］ダイアログで設定できる項目

［集合関数設定］ダイアログで設定できる項目を次に示します。

［設定内容一覧］リスト
［列設定］ダイアログの［選択列］リストに表示されている列名が一覧表示されます。デフォルトでは，すべての列にグループ分けが設定されています。グループは，255列まで設定できます。また，「設定内容一覧：」横には，選択された列名がある表が表示されます。列名を単一選択，または複数選択したあと，設定する集合関数のボタンをクリックします。
  • グループ分けを設定する場合
    列にグループ分けを設定しておくと，グループ（列中の同じデータの集合）単位で集合関数を算出してデータが抽出されます。その場合，抽出されるデータのソート順は，データベースに依存します。
    集合関数を設定した列をグループ分けの設定に戻す場合は，列を選択後，［グループ］ボタンをクリックします。同一名称の列に，グループ分けを2回以上設定できません。また，すでに集合関数を設定した表に列を挿入すると，その列にはグループ分けが設定されます。
  • 設定した集合関数，およびグループを解除する場合
    ［全取消］ボタンをクリックします。ボタンをクリックすると，［集合関数設定］ダイアログを閉じます。
［最大］ボタン
選択した列のデータの中から，最大値を求める関数です。ボタンをクリックすると，［設定内容一覧］エリアに「最大（選択した列名）」と表示されます。
［最小］ボタン
選択した列のデータの中から，最小値を求める関数です。ボタンをクリックすると，［設定内容一覧］エリアに「最小（選択した列名）」と表示されます。
［平均］ボタン
選択した列の，データの平均値を求める関数です。ボタンをクリックすると，［設定内容一覧］エリアに「平均（選択した列名）」と表示されます。
［合計］ボタン
選択した列の，データの合計値を求める関数です。ボタンをクリックすると，［設定内容一覧］エリアに「合計（選択した列名）」と表示されます。
［件数］ボタン
選択した列の，データの件数を求める関数です。ボタンをクリックすると，［設定内容一覧］エリアに「件数（選択した列名）」と表示されます。
［グループ］ボタン
グループ（列中の同じデータの集合）単位で集合関数を算出してデータが抽出する関数です。ボタンをクリックすると，［設定内容一覧］エリアに「グループ（選択した列名）」と表示されます。
［全取消］ボタン
設定した集合関数を解除します。ボタンをクリックすると，［設定内容一覧］エリアの選択した列名が削除されます。

(2)　画面図

[目次][前へ][次へ]

[他社商品名称に関する表示]

All Rights Reserved. Copyright (C) 2012, Hitachi, Ltd.
All Rights Reserved. Copyright (C) 2012, Hitachi Solutions, Ltd.


［ソート設定］ダイアログ

5.8　［ソート設定］ダイアログ

［列設定］ダイアログで指定した列のデータを，昇順，または降順に並べ替えを設定するダイアログです。

＜この節の構成＞
(1)　［ソート設定］ダイアログで設定できる項目
(2)　画面図

(1)　［ソート設定］ダイアログで設定できる項目

［ソート設定］ダイアログで設定できる項目を次に示します。

［列名一覧］リスト
［列設定］ダイアログの［選択列］リストに表示されている列名が一覧表示されます。
「列名一覧：」横には，選択された列名がある表名が表示されます。
［列名一覧］リストに表示できる列は，255列までです。
列名を単一選択，または複数選択したあと，［昇順］ボタン，または［降順］ボタンをクリックすると，設定された内容が［設定内容一覧］リストに表示されます。
［設定内容一覧］リスト
設定された内容が一覧表示されます。
  • 表示されている列の優先順位を入れ替える場合
    ソート条件が複数ある場合，［設定内容一覧］の上位にある条件が優先順位の高い条件になります。列の優先順位を入れ替える場合には，列名を単一選択したあと，［↑］ボタン，または［↓］ボタンをクリックします。
  • ソートの設定を削除する場合
    削除する列を選択したあと，［削除］ボタンをクリックします。

(2)　画面図

[目次][前へ][次へ]

[他社商品名称に関する表示]

All Rights Reserved. Copyright (C) 2012, Hitachi, Ltd.
All Rights Reserved. Copyright (C) 2012, Hitachi Solutions, Ltd.


［仮想列編集］ダイアログ

5.9　［仮想列編集］ダイアログ

仮想列を作成したり，編集したりするダイアログです。

＜この節の構成＞
(1)　［仮想列編集］ダイアログで設定できる項目
(2)　画面図

(1)　［仮想列編集］ダイアログで設定できる項目

［仮想列編集］ダイアログで設定できる項目を次に示します。

［表名］コンボボックス
データベースアクセス定義ウィンドウに設定されている表名が表示されます。
［列一覧］リスト
［表名］コンボボックスで選択した表に定義されている列名が一覧表示されます。
複数の表が選択されている場合は，［表名］コンボボックスの状態によって，［列一覧］リストの表示が異なります。
  • ［表名］コンボボックスの表名リストから，一つの表を選択したとき
    選択した表の列名だけが一覧表示されます。
  • ［表名］コンボボックスから「全表示」を選択したとき
    すべての表の列名が一覧表示されます。また，［列一覧］リストの列を選択すると，「属性：」の横にその列の属性が，「長さ：」の横にその列の長さが表示されます。
［列名称］テキストボックス
作成する仮想列の名称を，直接入力します。指定できる文字列長は，46バイトまでです。Unicodeが入力できます。
［列内容］テキストボックス
仮想列の演算内容を設定します。
演算に利用する列は，直接入力するか，または［列一覧］リストから選択します。ただし，LONG VARBINARY属性の列は指定できません。［列一覧］リストから選択する場合は，列名を選択したあと，［選択］ボタンをクリックすると，［列内容］テキストボックスに列名が入力されます。
演算に利用する演算子や数字は，直接入力するか，または次に示すボタンをクリックして指定します。指定できる文字列長は，30,000バイトまでです。Unicodeが入力できます。
［後退］ボタン
カーソルの1文字前を消去します。
［削除］ボタン
カーソルの1文字後ろを消去します。
［(］［)］［||］［+］［-］［*］［/］［0～9］［000］［.］ボタン
カーソルの後ろに，クリックしたボタンの文字を挿入します。

(2)　画面図

[目次][前へ][次へ]

[他社商品名称に関する表示]

All Rights Reserved. Copyright (C) 2012, Hitachi, Ltd.
All Rights Reserved. Copyright (C) 2012, Hitachi Solutions, Ltd.


［条件設定］ダイアログ

5.10　［条件設定］ダイアログ

データを絞り込む条件を設定するダイアログです。

＜この節の構成＞
(1)　［条件設定］ダイアログで設定できる項目
(2)　画面図

(1)　［条件設定］ダイアログで設定できる項目

［条件設定］ダイアログで設定できる項目を次に示します。

［表名］コンボボックス
データベースアクセス定義ウィンドウに設定されている表名が表示されます。
［列一覧］リスト
条件を設定できる列名が一覧表示されます。［列一覧］リストから列を選択すると，その列の属性と長さが，「列属性：」横に表示されます。
複数の表が選択されている場合は，［表名］コンボボックスの状態によって，［列一覧］リストの表示が異なります。
  • ［表名］コンボボックスの表名リストから，一つの表を選択したとき
    選択した表の列名だけが一覧表示されます。
  • ［表名］コンボボックスから「全表示」を選択したとき
    すべての表の列名が一覧表示されます。
［オプション設定］ダイアログの［表示］タブで，［インデクス情報を表示］チェックボックスがオンの場合は，列名の前に次に示す情報が表示されます。［オプション設定］ダイアログについては，「5.22　［オプション設定］ダイアログ」を参照してください。
表示される情報 | 情報の意味
UNQ | 列にユニークインデクスが定義されていることを示します。
［UNQ］ | 列にユニークインデクスが定義されていることを示します（一つのインデクスが複数の列から構成されている場合の2列目以降）。
DUP | 列に重複インデクスが定義されていることを示します。
［DUP］ | 列に重複インデクスが定義されていることを示します（一つのインデクスが複数の列から構成されている場合の2列目以降）。
重複インデクスとは，キー値がユニークでないインデクスのことです。
一つの列に複数インデクスがある場合は，「ユニークインデクス／重複インデクス」の順で一つ表示されます。
繰り返し列にインデクスがある場合は，繰り返し列の要素の先頭列に情報が表示されます。

列名を選択したあと，条件式を設定します。設定できる条件式を次に示します。

設定できる条件式 条件式を設定する場所 説明
表結合 ［表結合条件］ダイアログ
  • ［表結合］ボタンをクリックしてください。
  • 複数の表を結合して，設定した条件に合うデータを抽出できます。
IN，NOT IN ［IN条件式］ダイアログ
  • ［IN］ボタンをクリックしてください。
  • 指定した値と一致する行，または指定した値と一致しない行を抽出できます。
BETWEEN，NOT BETWEEN ［BETWEEN条件式］ダイアログ
  • ［BETWEEN］ボタンをクリックしてください。
  • 指定した範囲の値が含まれる行，または指定した範囲の値が含まれていない行を抽出できます。
演算数式（=，<>，<，<=，>，>=，(，)，E+，E-，/，*，-，+） ［列演算条件式］ダイアログ
  • ［列演算］ボタンをクリックしてください。
  • 列と列を演算した値が含まれる行を抽出できます。
演算数式の直接入力（=，<>，<，<=，>，>=，(，)，||，/，*，-，+） ［条件式直接入力］ダイアログ
  • ［直接入力］ボタンをクリックしてください。
  • 条件を設定する各ダイアログでは設定できない条件式を設定できます。
比較条件（=，<>，<，<=，>，>=），NULL条件，NOT NULL条件，LIKE条件，NOT LIKE条件 ［条件設定］ダイアログの［条件］コンボボックス 条件式の値は，［条件］コンボボックスの右にあるテキストボックスに入力します。［設定］ボタンをクリックすると，条件式が［一覧］リストに追加されます。
条件は，列の属性によって使用が制限されます。詳細は，「表3-8　列と定数の規則」を参照してください。
条件式の値に可変記号を設定する場合
比較条件，LIKE条件，およびNOT LIKE条件の値には，可変記号を設定できます。可変記号は，［可変記号入力］ダイアログで設定します。［可変記号入力］ダイアログは，［可変記号］ボタンをクリックすると表示されます。
可変記号を設定すると，テキストボックスには，「&可変記号名〔（省略値）〕」の形式で表示されます。〔 〕内は，省略値が指定されている場合，表示されます。また，可変記号が設定されたテキストボックスは，書き込みができません。
［可変記号入力］ダイアログについては，「5.16　［可変記号入力］ダイアログ」を参照してください。
［条件］コンボボックス
比較条件（=，<>，<，<=，>，>=），「NULL」，「NOT NULL」，「LIKE」，および「NOT LIKE」のうち，どれかを選択します。ただし，「LIKE」と「NOT LIKE」を選択した場合，条件式に指定できる列名は，次に示す列属性を持つ列です。
CHAR，VARCHAR，LONG VARCHAR，NCHAR，NVARCHAR，MCHAR，MVARCHAR，UCHAR，UVARCHAR，LONG UVARCHAR
UCHAR，UVARCHAR，またはLONG UVARCHARはSQL Serverを使用する場合で，Unicodeデータを抽出するときだけ使用できます。
［条件］テキストボックス
条件式の右辺を入力します。Unicodeが入力できます。
［一覧］リスト
設定された条件式が一覧表示されます。表示される条件式は，ダイアログで設定した条件，または［条件］コンボボックスで設定した条件から作成された，データの抽出条件です。
  • 条件式の表示位置を入れ替える場合
    条件式を選択したあと，［↑］ボタン，または［↓］ボタンをクリックします。
  • 条件式を変更する場合
    条件式を単一選択したあと，［変更］ボタンをクリックします。変更を決定する場合は，［設定］ボタンをクリックします。変更を取りやめる場合は，［取消］ボタンをクリックします。
  • 条件式を削除する場合
    条件式を選択したあと，［削除］ボタンをクリックします。削除する条件式が条件関連式で設定されている場合は，条件番号が「?」に置き換えられます。このとき，条件関連式に誤りがあった場合は，エラーが表示され，条件式が削除されます。
    ［一覧］リストに表示されている条件式がすべて削除された場合は，条件関連式も削除されます。
［関連］テキストボックス
複数の条件式を関連させる式（条件関連式）を指定します。条件関連式は，次に示す文字を半角で指定します。
  • ［一覧］リストに表示される条件番号
  • 論理演算子「AND」「OR」「NOT」
  • 半角記号「(」「)」
条件関連式に指定できる論理演算子の組み合わせは，255個までです。
次に示すように，条件関連式は，論理演算子の前後に半角空白（△）を指定してください。
（指定例）
(1△OR△2)△AND△(3△OR△4)
複数の条件を設定して，条件関連式を入力しない場合は，すべての条件を「AND」で関連づけます。

(2)　画面図

[目次][前へ][次へ]

[他社商品名称に関する表示]

All Rights Reserved. Copyright (C) 2012, Hitachi, Ltd.
All Rights Reserved. Copyright (C) 2012, Hitachi Solutions, Ltd.


［表結合条件］ダイアログ

5.11　［表結合条件］ダイアログ

表結合を使用した条件式を設定するダイアログです。［条件設定］ダイアログで，［表結合］ボタンがクリックされた時に表示されます。複数の表から結合条件を満たす行だけを抽出します。

＜この節の構成＞
(1)　［表結合条件］ダイアログで設定できる項目
(2)　画面図

(1)　［表結合条件］ダイアログで設定できる項目

［表結合条件］ダイアログで設定できる項目を次に示します。

［表1］コンボボックス
結合させる一つ目の表を選択します。
［表1］コンボボックス下には，選択した表に指定されているすべての列名が表示されます。列名を選択すると，選択された列の属性が「属性：」に表示されます。
［演算子］コンボボックス
表1と表2を結合させる比較演算子を選択します。選択できる比較演算子を次に示します。
「=」「<>」「>」「>=」「<」「<=」
［表2］コンボボックス
結合させる二つ目の表を選択します。
［表2］コンボボックス下には，選択した表に指定されているすべての列名が表示されます。列名を選択すると，選択された列の属性が「属性：」に表示されます。
［結合条件：］ラベル
［表1］，［表2］，および［演算子］で設定した内容から作成された結合条件が表示されます。演算子の前後は，半角空白（△）が表示されます。
（表示例）
コード△=△コード

(2)　画面図

[目次][前へ][次へ]

[他社商品名称に関する表示]

All Rights Reserved. Copyright (C) 2012, Hitachi, Ltd.
All Rights Reserved. Copyright (C) 2012, Hitachi Solutions, Ltd.


［IN条件式］ダイアログ

5.12　［IN条件式］ダイアログ

IN条件を設定するダイアログです。［条件設定］ダイアログで，［IN］ボタンがクリックされた時に表示されます。指定した値と，［条件設定］ダイアログで選択した列の値が一致する行，または一致しない行を抽出できます。

＜この節の構成＞
(1)　［IN条件式］ダイアログで設定できる項目
(2)　画面図

(1)　［IN条件式］ダイアログで設定できる項目

［IN条件式］ダイアログで設定できる項目を次に示します。

［種別］コンボボックス
IN条件の種別を選択します。
  • IN条件で抽出する場合
    「列が値のいずれかと一致しているデータを検索」を選択します。
  • NOT IN条件で抽出する場合
    「列が値のいずれでもないデータを検索」を選択します。
［表名：］ラベル
［条件設定］ダイアログの［表名］コンボボックスで選択した表名が表示されます。
［列名：］ラベル
［条件設定］ダイアログの［列一覧］リストで選択した列名が表示されます。
列名に設定されている属性と列の長さも「属性：」と「長さ：」に表示されます。
［値］テキストボックス
条件値を指定します。指定できる条件値は，255個までです。Unicodeが入力できます。列と定数の規則については，「表3-8　列と定数の規則」を参照してください。
一度に表示できる［値］テキストボックスは，10個です。10個を超える条件値を指定する場合は，［次頁］ボタン，または［前頁］ボタンをクリックして表示を切り替えてください。［前頁］ボタン横には，「頁番号：現在のページ番号／全体のページ番号」が表示されます。
  • 条件値に可変記号を指定する場合
    使用する可変記号を［可変記号入力］ダイアログで設定します。［可変記号入力］ダイアログは，［可変記号］ボタンをクリックすると表示されます。
    可変記号を設定すると，［値］テキストボックスには，「&可変記号名〔（省略値）〕」の形式で表示されます。〔 〕内は，省略値が指定されている場合，表示されます。
    可変記号が設定されたテキストボックスは，書き込みができません。［可変記号入力］ダイアログについては，「5.16　［可変記号入力］ダイアログ」を参照してください。

(2)　画面図

[目次][前へ][次へ]

[他社商品名称に関する表示]

All Rights Reserved. Copyright (C) 2012, Hitachi, Ltd.
All Rights Reserved. Copyright (C) 2012, Hitachi Solutions, Ltd.


［BETWEEN条件式］ダイアログ

5.13　［BETWEEN条件式］ダイアログ

BETWEEN条件を設定するダイアログです。［条件設定］ダイアログで，［BETWEEN］ボタンがクリックされた時に表示されます。指定した範囲の値が含まれる行，または含まれない行を抽出できます。

＜この節の構成＞
(1)　［BETWEEN条件式］ダイアログで設定できる項目
(2)　画面図

(1)　［BETWEEN条件式］ダイアログで設定できる項目

［BETWEEN条件式］ダイアログで設定できる項目を次に示します。

［種別］コンボボックス
BETWEEN条件の種別を選択します。列と定数の規則については，「表3-8　列と定数の規則」を参照してください。
  • BETWEEN条件で抽出する場合
    「列の値が，値1と値2の間のデータ検索」を選択します。
  • NOT BETWEEN条件で抽出する場合
    「列の値が，値1と値2の間以外のデータ検索」を選択します。
［表名：］ラベル
［条件設定］ダイアログの［表名］コンボボックスで選択した表名が表示されます。
［列名：］ラベル
［条件設定］ダイアログの［列一覧］リストで選択した列名が表示されます。
列名に設定されている属性と列の長さも表示されます。
［値1］／［値2］テキストボックス
最小値と最大値を指定します。Unicodeが入力できます。値に可変記号を指定する場合は，使用する可変記号を［可変記号入力］ダイアログで設定します。［可変記号入力］ダイアログは，［可変記号］ボタンをクリックすると表示されます。可変記号を設定すると，［値1］テキストボックス，または［値2］テキストボックスには，「&可変記号名〔（省略値）〕」の形式で表示されます。〔 〕内は，省略値が指定されている場合，表示されます。可変記号が設定されたテキストボックスは，書き込みができません。［可変記号入力］ダイアログについては，「5.16　［可変記号入力］ダイアログ」を参照してください。

(2)　画面図

[目次][前へ][次へ]

[他社商品名称に関する表示]

All Rights Reserved. Copyright (C) 2012, Hitachi, Ltd.
All Rights Reserved. Copyright (C) 2012, Hitachi Solutions, Ltd.


［列演算条件式］ダイアログ

5.14　［列演算条件式］ダイアログ

列演算を使用した条件式を設定するダイアログです。［条件設定］ダイアログで，［列演算］ボタンがクリックされた時に表示されます。列と列を演算した値が含まれる行を抽出できます。

＜この節の構成＞
(1)　［列演算条件式］ダイアログで設定できる項目
(2)　画面図

(1)　［列演算条件式］ダイアログで設定できる項目

［列演算条件式］ダイアログで設定できる項目を次に示します。

［表名］コンボボックス
データベースアクセス定義ウィンドウに設定されている表名が表示されます。
［列一覧］リスト
［表名］コンボボックスで選択した表に定義されている列名，（列の）属性，および長さが一覧表示されます。
複数の表が選択されている場合は，［表名］コンボボックスの状態によって，［列一覧］リストの表示が異なります。
  • ［表名］コンボボックスの表名リストから，一つの表を選択したとき
    選択した表の列名だけが一覧表示されます。
  • ［表名］コンボボックスから「全表示」を選択したとき
    すべての表の列名が一覧表示されます。
［条件式］テキストボックス
列演算の条件式を指定します。Unicodeが入力できます。演算数式は，直接入力するか，または次に示すダイアログに表示されているボタンをクリックして指定します。
［<］［<=］［=］［<>］［>=］［>］ボタン
カーソルの後ろに，クリックしたボタンの文字を挿入します。
［後退］ボタン
カーソルの1文字前を消去します。
［削除］ボタン
カーソルの1文字後ろを消去します。
［(］［)］［E+］［E-］［+］［-］［*］［/］［0～9］［000］［.］ボタン
カーソルの後ろに，クリックしたボタンの文字を挿入します。
演算式を指定するときの注意
次に示す演算数式は，各辺に64個まで指定できます。
「+」，「-」，「*」，「/」，および「( )」
  • 除算「/」の後ろに「0」は指定できません。
  • 指定できる定数は，整数，10進数，および浮動小数点です。

(2)　画面図

[目次][前へ][次へ]

[他社商品名称に関する表示]

All Rights Reserved. Copyright (C) 2012, Hitachi, Ltd.
All Rights Reserved. Copyright (C) 2012, Hitachi Solutions, Ltd.


［条件式直接入力］ダイアログ

5.15　［条件式直接入力］ダイアログ

［条件設定］ダイアログで，［直接入力］ボタンがクリックされた時に表示されるダイアログです。表結合，IN条件，BETWEEN条件，および列演算条件以外の条件式を設定できます。

＜この節の構成＞
(1)　［条件式直接入力］ダイアログで設定できる項目
(2)　画面図

(1)　［条件式直接入力］ダイアログで設定できる項目

［条件式直接入力］ダイアログで設定できる項目を次に示します。

［表名］コンボボックス
データベースアクセス定義ウィンドウに設定されている表名が表示されます。
［列一覧］リスト
［表名］コンボボックスで選択した表に定義されている列名，（列の）属性，および長さが一覧表示されます。
複数の表が選択されている場合は，［表名］コンボボックスの状態によって，［列一覧］リストの表示が異なります。
  • ［表名］コンボボックスの表名リストから，一つの表を選択したとき
    選択した表の列名だけが一覧表示されます。
  • ［表名］コンボボックスから「全表示」を選択したとき
    すべての表の列名が一覧表示されます。
［条件式］テキストボックス
SQL文のWHERE句に指定できる条件を直接入力できます。Unicodeが入力できます。入力した条件の構文については，EURでは構文チェックできません。また，可変記号は指定できません。
演算数式は，直接入力するか，または次に示すダイアログに表示されているボタンをクリックして指定します。
［<］［<=］［=］［<>］［>=］［>］ボタン
カーソルの後ろに，クリックしたボタンの文字を挿入します。
［後退］ボタン
カーソルの1文字前を消去します。
［削除］ボタン
カーソルの1文字後ろを消去します。
［(］［)］［||］［+］［-］［*］［/］［0～9］［000］［.］ボタン
カーソルの後ろに，クリックしたボタンの文字を挿入します。
演算式を指定するときの注意
EURでは，［条件式］テキストボックスに入力した条件の構文チェックはしません。使用しているデータベースに合わせた条件式を記述してください。

(2)　画面図

[目次][前へ][次へ]

[他社商品名称に関する表示]

All Rights Reserved. Copyright (C) 2012, Hitachi, Ltd.
All Rights Reserved. Copyright (C) 2012, Hitachi Solutions, Ltd.


［可変記号入力］ダイアログ

5.16　［可変記号入力］ダイアログ

可変記号を設定するダイアログです。

＜この節の構成＞
(1)　［可変記号入力］ダイアログで設定できる項目
(2)　画面図

(1)　［可変記号入力］ダイアログで設定できる項目

［可変記号入力］ダイアログで設定できる項目を次に示します。

［可変記号名］テキストボックス
可変記号を指定します。可変記号を設定する場合は，カーソルが可変記号名を入力する部分にあることを確認してください。カーソルが入力する部分にない場合，［可変記号(V)...］ボタンは不活性です。指定できる可変記号の数は，255個までです。1個の可変記号に指定できる文字列長は，254バイトまでです。同一名の可変記号は指定できません。
可変記号に指定できる文字は，次のとおりです。文字列中に，空白は指定できません。文字列の前後に空白を指定しても無視されます。
  • 全角文字
  • 半角カタカナ
  • 半角英字：A～Z，a～z
  • 半角数字：0～9
先頭1文字目は，全角文字，半角カタカナ，または半角英字を指定してください。Unicodeが入力できます。
［初期値］テキストボックス
可変記号に設定する初期値を指定します。条件式の右辺に定数が指定されているときに，［可変記号］ボタンをクリックすると，右辺の定数が初期値として表示されます。指定できる文字列長は255バイト以下です。Unicodeが入力できます。指定できる属性は，文字定数，数値定数です。一つの可変記号名に対して指定できる初期値は一つです。二つ以上の初期値は指定できません。

(2)　画面図

[目次][前へ][次へ]

[他社商品名称に関する表示]

All Rights Reserved. Copyright (C) 2012, Hitachi, Ltd.
All Rights Reserved. Copyright (C) 2012, Hitachi Solutions, Ltd.


［見出し編集］ダイアログ

5.17　［見出し編集］ダイアログ

見出し辞書の新規作成，または見出し辞書に登録されている見出し情報を編集するダイアログです。

＜この節の構成＞
(1)　［見出し編集］ダイアログで設定できる項目
(2)　画面図

(1)　［見出し編集］ダイアログで設定できる項目

［見出し編集］ダイアログで設定できる項目を次に示します。

［接続先名］／［所有者名］／［表名］テキストボックス
［表選択］ダイアログ，または［見出し選択］ダイアログで選択した表情報が表示されます。編集はできません。表にShift JIS以外の文字が含まれていた場合はエラーとなります。
［表見出し］テキストボックス
表名に対応する表見出しの文字列を指定します。指定できる文字列長は，30バイトまでです。指定できる文字は，半角文字と全角文字です。省略した場合は，表見出しが設定されません。
データベースで表見出しが定義されている場合は，定義されている表見出しが表示されます。
［グループ名］コンボボックス
見出し辞書に登録する表をグループに設定できます。グループを設定すると，見出し辞書から表を選択する場合，設定されたグループ名で抽出できます。
見出し辞書に登録されている表のグループに加える場合，またはグループ名を変更したい場合は，［見出し選択］ダイアログを表示します。［見出し選択］ダイアログは，［見出し一覧］ボタンをクリックすると表示されます。［見出し選択］ダイアログについては，「5.19　［見出し選択］ダイアログ」を参照してください。
［列一覧］リスト
選択された表の列名が「列名」に表示されます。「列名」は編集できません。列名にShift JIS以外の文字が含まれていた場合はエラーとなります。
表示されている「列名」に対応する列見出しを指定します。列見出しに指定できる文字列の長さは，46バイトまでです。指定できる文字は，半角文字と全角文字です。省略した場合は，列見出しが設定されません。
データベースで列見出しが定義されている場合は，列名と一緒に，定義されている列見出しが表示されます。
［見出し一覧］ボタン
［見出し選択］ダイアログが表示されます。見出し辞書に登録されている表を選択して，見出し辞書を作成できます。［見出し選択］ダイアログについては，「5.19　［見出し選択］ダイアログ」を参照してください。
［新規作成］ボタン
［表選択］ダイアログが表示されます。データベースに登録されている表を選択して，見出し辞書を作成できます。
［表選択］ダイアログについては，「5.3　［表選択］ダイアログ」を参照してください。
［一括作成］ボタン
［表選択］ダイアログが表示されます。複数の表の見出し情報を見出し辞書に一括登録できます。［表選択］ダイアログについては，「5.3　［表選択］ダイアログ」を参照してください。
［読み込み］ボタン
別のドライブ，またはフォルダから見出し辞書を読み込む場合は，［読み込み先の指定］ダイアログで指定します。［読み込み先の指定］ダイアログについては，「5.18　［読み込み先の指定］ダイアログ」を参照してください。
［登録］ボタン
［見出し編集］ダイアログに設定した情報が，見出し辞書に登録されます。
EURが管理するフォルダにある見出し辞書に登録されます。この見出し辞書ではなく，別のフォルダに格納することもできます。この場合，［見出し選択］ダイアログの［格納］ボタンを使用してください。
［削除］ボタン
［見出し編集］ダイアログに表示されている見出し情報を削除します。
［終了］ボタン
見出し編集を終了します。

(2)　画面図

[目次][前へ][次へ]

[他社商品名称に関する表示]

All Rights Reserved. Copyright (C) 2012, Hitachi, Ltd.
All Rights Reserved. Copyright (C) 2012, Hitachi Solutions, Ltd.


［読み込み先の指定］ダイアログ

5.18　［読み込み先の指定］ダイアログ

読み込む見出し辞書のファイルの場所を設定するダイアログです。［見出し編集］ダイアログで，［読み込み］ボタンがクリックされた時に表示されます。

＜この節の構成＞
(1)　［読み込み先の指定］ダイアログで設定できる項目
(2)　画面図

(1)　［読み込み先の指定］ダイアログで設定できる項目

［読み込み先の指定］ダイアログで設定できる項目を次に示します。

［フォルダ］リストボックス
見出し辞書のファイルの場所を選択します。

(2)　画面図

[目次][前へ][次へ]

[他社商品名称に関する表示]

All Rights Reserved. Copyright (C) 2012, Hitachi, Ltd.
All Rights Reserved. Copyright (C) 2012, Hitachi Solutions, Ltd.


［見出し選択］ダイアログ

5.19　［見出し選択］ダイアログ

見出し辞書に登録されている表の情報を一覧表示するダイアログです。［見出し編集］ダイアログで［見出し一覧］ボタンをクリックした時，表示されます。

＜この節の構成＞
(1)　［見出し選択］ダイアログで設定できる項目
(2)　画面図

(1)　［見出し選択］ダイアログで設定できる項目

［見出し選択］ダイアログで設定できる項目を次に示します。

［登録表一覧］リスト
見出し辞書に登録されている表が一覧表示されます。［登録表一覧］リストに表示できる表数は，32,767個までです。見出し辞書に登録されている表数が，32,767個を超えている場合は，［登録表一覧］リストに表示できない場合があります。
  • 表示する項目名を設定，または変更したい場合
    ［辞書一覧表示方法の設定］ダイアログで設定します。［辞書一覧表示方法の設定］ダイアログは，［表示設定］ボタンをクリックすると表示されます。［辞書一覧表示方法の設定］ダイアログについては，「5.20　［辞書一覧表示方法の設定］ダイアログ」を参照してください。
  • 項目名の表示幅を広げたい場合
    表示する項目名が長い場合，または項目名の表示幅が狭い場合は，文字列の途中で切れて表示されます。表示幅を変更する場合は，マウスを項目名と項目名の境界線に合わせて，左右にドラッグします。
  • 項目名を並べ替えたい場合
    項目名をクリックすると，昇順，または降順に並べ替えできます。
  • 表示されている見出し情報を削除する場合
    削除する表名を選択したあと，［削除］ボタンをクリックします。
［グループ名］コンボボックス
表に設定するグループ名を指定します。グループ名にShift JIS以外の文字が含まれていた場合はエラーとなります。
グループに設定する表を［登録表一覧］リストから単一選択，または複数選択したあと，グループ名を指定します。
  • 新規のグループ名を指定する場合
    コンボボックスに入力します。
  • 既存のグループに加える場合
    リスト表示されたグループ名から選択します。
グループ名を指定したあと，［設定］ボタンをクリックします。
［編集］ボタン
設定された内容を［見出し編集］ダイアログに反映します。
［格納］ボタン
見出し辞書の［格納先の指定］ダイアログが表示されます。
  • 編集した内容を見出し辞書に格納する場合
    ［格納］ボタンをクリックすると，［格納先の指定］ダイアログが表示されます。見出し辞書の格納先を指定してください。［格納先の指定］ダイアログについては，「5.21　［格納先の指定］ダイアログ」を参照してください。

(2)　画面図

[目次][前へ][次へ]

[他社商品名称に関する表示]

All Rights Reserved. Copyright (C) 2012, Hitachi, Ltd.
All Rights Reserved. Copyright (C) 2012, Hitachi Solutions, Ltd.


［辞書一覧表示方法の設定］ダイアログ

5.20　［辞書一覧表示方法の設定］ダイアログ

［見出し選択］ダイアログの［登録表一覧］リストに表示する項目を設定するダイアログです。［見出し選択］ダイアログで［表示設定］ボタンをクリックした時，表示されます。

＜この節の構成＞
(1)　［辞書一覧表示方法の設定］ダイアログで設定できる項目
(2)　画面図

(1)　［辞書一覧表示方法の設定］ダイアログで設定できる項目

［辞書一覧表示方法の設定］ダイアログで設定できる項目を次に示します。

［表示項目］リスト
［見出し選択］ダイアログの［登録表一覧］リストに表示する項目と，各項目の表示設定状態が表示されます。
［表示項目］リストは，「表示種別」と「項目名」が表示されます。項目には，「接続先名」，「グループ名」，「所有者」，「表名」，および「表見出し」の順に表示されます。
  • ［登録表一覧］リストに表示する項目を設定，または変更する場合
    項目名を選択したあと，［表示］ボタン，または［非表示］ボタンをクリックします。また，「表名」と「表見出し」は，どちらか一方を表示に設定してください。どちらも非表示に設定した場合はエラーになります。

(2)　画面図

[目次][前へ][次へ]

[他社商品名称に関する表示]

All Rights Reserved. Copyright (C) 2012, Hitachi, Ltd.
All Rights Reserved. Copyright (C) 2012, Hitachi Solutions, Ltd.


［格納先の指定］ダイアログ

5.21　［格納先の指定］ダイアログ

見出し辞書のファイルの格納先を設定するダイアログです。［見出し選択］ダイアログで，［格納］ボタンがクリックされた時に表示されます。

＜この節の構成＞
(1)　［格納先の指定］ダイアログで設定できる項目
(2)　画面図

(1)　［格納先の指定］ダイアログで設定できる項目

［格納先の指定］ダイアログで設定できる項目を次に示します。

［フォルダ］リストボックス
見出し辞書のファイルの格納先を選択します。

(2)　画面図

[目次][前へ][次へ]

[他社商品名称に関する表示]

All Rights Reserved. Copyright (C) 2012, Hitachi, Ltd.
All Rights Reserved. Copyright (C) 2012, Hitachi Solutions, Ltd.


［オプション設定］ダイアログ

5.22　［オプション設定］ダイアログ

［オプション設定］ダイアログは，次に示すタブが表示されます。

  • ［抽出］タブ
  • ［表示］タブ
  • ［見出し辞書］タブ

このダイアログで設定したオプションは，データベースアクセス定義を次回起動した場合も有効です。

＜この節の構成＞
5.22.1　［抽出］タブ
5.22.2　［表示］タブ
5.22.3　［見出し辞書］タブ


［抽出］タブ

5.22.1　［抽出］タブ

抽出の動作に関連するオプションを設定します。

抽出に掛かる時間を［抽出時間の上限］チェックボックスに設定できます。デフォルトは，「オフ（抽出時間の上限を設定しない）」です。

＜この項の構成＞
(1)　［抽出］タブで設定できる項目
(2)　画面図

(1)　［抽出］タブで設定できる項目

［抽出時間の上限］チェックボックス
抽出開始時間から中断までの時間を指定するかどうか設定します。指定できる時間の範囲は，1～999（分）です。ただし，接続先データベースや動作環境によって，抽出時間の上限時間が異なりますので，目安としてください。デフォルトは，「オフ（指定しない）」です。

(2)　画面図

[目次][前へ][次へ]

[他社商品名称に関する表示]

All Rights Reserved. Copyright (C) 2012, Hitachi, Ltd.
All Rights Reserved. Copyright (C) 2012, Hitachi Solutions, Ltd.


［表示］タブ

5.22.2　［表示］タブ

ダイアログの表示動作に関連するオプションを設定します。

＜この項の構成＞
(1)　［表示］タブで設定できる項目
(2)　画面図

(1)　［表示］タブで設定できる項目

［表示］タブで設定できる項目を次に示します。

［可変記号のソート］チェックボックス
［実行値入力］ダイアログを開いた時，可変記号をソートして表示するかどうかを設定します。
チェックボックスの選択状態 | 説明
オン | 可変記号をソートして表示します。
オフ（デフォルト） | ［条件設定］ダイアログの［一覧］リストに表示されている順で表示します。
［集合関数を指定した項目名の見出し表示］チェックボックス
列に集合関数を指定して抽出した場合，データ表示ウィンドウの項目行には，見出し辞書オプションの指定に関係なく，データベースでの列名が表示されます。［集合関数を指定した項目名の見出し表示］オプションを使用すると，列に集合関数を指定した場合でも，抽出結果では見出し辞書オプションの指定に従って，見出し辞書の列見出しが表示できます。
チェックボックスの選択状態 | 説明
オン（デフォルト） | 列名，または列見出しを見出し辞書の指定に従って表示します。※1
オフ | 列名で表示します。※2
注※1
表示形式
漢字集合関数名（｛列名 | 列見出し｝）

漢字集合関数には，「最大」，「最小」，「平均」，「合計」，および「件数」があります。
（例）最大（商品番号）
注※2
表示形式
英字集合関数名（列名）

英字集合関数には，「MAX」，「MIN」，「AVG」，「SUM」，および「COUNT」があります。
（例）MAX（支店コード）
［インデクス情報を表示］チェックボックス
［条件設定］ダイアログを開いた時，［列一覧］リストに表示する列名にインデクス情報を表示するかどうかを設定します。
チェックボックスの選択状態 | 説明
オン | 列名の前にインデクス情報を表示します。表示されるインデクス情報については，「5.10　［条件設定］ダイアログ」を参照してください。
オフ（デフォルト） | インデクス情報を表示しません。
［表一覧情報をソートして表示］チェックボックス
［表選択］ダイアログを開いた時，［表一覧］リストに表示する表名をソートして表示するかどうかを設定します。
チェックボックスの選択状態 | 説明
オン（デフォルト） | 表名をソートして表示します。
オフ | 接続先データベースに定義されている順に表示します。
［表一覧情報を毎回サーバから取得して表示］チェックボックス
データベースアクセス定義ウィンドウの［表名］ボタンを押した時，［表選択］ダイアログの［表一覧］リストに表示する表の情報を，毎回サーバから取得するかどうかを設定します。
チェックボックスの選択状態 | 説明
オン | 毎回サーバから情報を取得して表示します。
オフ（デフォルト） | 以前サーバから取得した情報を表示します。

(2)　画面図

[目次][前へ][次へ]

[他社商品名称に関する表示]

All Rights Reserved. Copyright (C) 2012, Hitachi, Ltd.
All Rights Reserved. Copyright (C) 2012, Hitachi Solutions, Ltd.


［見出し辞書］タブ

5.22.3　［見出し辞書］タブ

見出し辞書の動作に関連するオプションを設定します。

＜この項の構成＞
(1)　［見出し辞書］タブで設定できる項目
(2)　画面図

(1)　［見出し辞書］タブで設定できる項目

［見出し辞書］タブで設定できる項目を次に示します。

［見出し辞書］チェックボックス
抽出する表や列を選ぶ場合に，あらかじめ登録した表名や列名で表示できます。表示する表名や列名は，見出し辞書に登録します。表名や列名を見出し辞書を使って表示する場合は，見出し辞書の内容だけを表示したり，見出し辞書とデータベースの内容（データベースに定義してある表名や列名）を組み合わせて表示したりできます。
見出し辞書に登録されている表を使用するかどうかを設定します。デフォルトは，「オフ（見出し辞書を使用しない）」です。
［見出し辞書］チェックボックスをオンにすると，［表選択］ダイアログの［表一覧］リストに表示する情報と，使用する見出し辞書のある場所を設定できます。
  • 見出し辞書に登録されている表の情報を表示する場合
    「見出し辞書の情報を使用する」を選択します。
  • 接続先データベースに登録されている表の情報を表示する場合
    「見出し辞書とDBの情報を使用する」を選択します。
注意事項
  • 見出し辞書とデータベースの情報を組み合わせて表示する場合，見出し辞書に登録していない表や列があるときは，データベースに定義してある情報だけが表示されます。
  • 見出し辞書だけを使う指定（データベースの情報を組み合わせない指定）の場合は，見出し辞書に登録していない表名は表を選ぶときに表示されないので，使えなくなります。
  • 見出し辞書だけを使う指定にすると，接続先に関係なく，見出し辞書に登録されている表がすべて表示されます。
［辞書フォルダ］テキストボックス
見出し辞書のあるフォルダを設定します。Unicodeが入力できます。
［辞書の指定］ダイアログについては，「5.24　［辞書の指定］ダイアログ」を参照してください。

(2)　画面図

[目次][前へ][次へ]

[他社商品名称に関する表示]

All Rights Reserved. Copyright (C) 2012, Hitachi, Ltd.
All Rights Reserved. Copyright (C) 2012, Hitachi Solutions, Ltd.


［実行値入力］ダイアログ

5.23　［実行値入力］ダイアログ

可変記号に対する実行値を指定するダイアログです。データベースアクセス定義ウィンドウの［抽出確認］ボタンがクリックされた時，可変記号が設定されていると表示されます。

＜この節の構成＞
(1)　［実行値入力］ダイアログで設定できる項目
(2)　画面図

(1)　［実行値入力］ダイアログで設定できる項目

［実行値入力］ダイアログで設定できる項目を次に示します。

［可変記号］リスト
条件式に設定した可変記号名が表示されます。また，可変記号を設定した列の列属性と列の長さも表示されます。
［実行値］テキストボックス
可変記号に対する実行値を指定します。［可変記号入力］ダイアログの［初期値］が指定されていない場合は，「実行値」を指定してください。指定できる文字列長は255バイト以下です。Unicodeが入力できます。実行値に文字定数を指定する場合は，文字列を「'」で囲んでください。
条件式の右辺に定数が指定されているときに，［可変記号］ボタンをクリックすると，右辺の定数が初期値として表示されます。
指定できる属性は，文字定数，数値定数です。一つの可変記号名に対して指定できる初期値は一つです。二つ以上の初期値は指定できません。
指定できる定数の規則は，［条件設定］ダイアログで条件式を設定するときと同じです。規則については，「表3-8　列と定数の規則」を参照してください。
実行値は，次のように指定してください。

表5-3　実行値の指定方法

列の属性 | 実行値の指定方法
BINARY | 〔'〕0～9，A～Fの半角の文字列〔'〕
BIT | 0，または1
CHAR，VARCHAR，LONG VARCHAR | 〔'〕全角，および半角の文字列〔'〕
DATE
〔'〕YYYY-MM-DD〔'〕
年（YYYY），月（MM），日（DD）を「-」で結びます。
DOUBLE，FLOAT，REAL | 〔符号〕仮数E〔符号〕指数
LONG VARBINARY | 定数として設定できません。
MCHAR，MVARCHAR | 〔'〕全角，および半角の文字列〔'〕
NCHAR，NVARCHAR | 〔'〕全角の文字列〔'〕
NUMERIC，DECIMAL | 〔符号〕整数部.小数部
TIME
〔'〕hh:mm:ss〔'〕
時（hh），分（mm），秒（ss）を「:」で結びます。
TIMESTAMP（16桁）
〔'〕YYYY-MM-DD△hh:mm〔'〕
日付の文字表現と時間の文字表現の時分を，半角空白（△）で結びます。
TIMESTAMP（19桁）
〔'〕YYYY-MM-DD△hh:mm:ss〔'〕
日付の文字表現と時間の文字表現を，半角空白（△）で結びます。
TIMESTAMP（23桁）
〔'〕YYYY-MM-DD△hh:mm:ss〔.nnn〔'〕〕
日付の文字表現と時間の文字表現を，半角空白（△）で結び，「.」のあとに3桁の小数秒を付けます。
TIMESTAMP（26桁）
〔'〕YYYY-MM-DD△hh:mm:ss〔.nnnnnn〔'〕〕
日付の文字表現と時間の文字表現を，半角空白（△）で結び，「.」のあとに6桁の小数秒を付けます。
TINYINT，INTEGER，SMALLINT | 〔符号〕整数
UCHAR※，UVARCHAR※，LONG UVARCHAR※ | 〔'〕全角，および半角の文字列〔'〕
VARBINARY | 定数として設定できません。
注※
SQL Serverを使用する場合で，Unicodeデータを抽出する場合だけ使用できます。

(2)　画面図

[目次][前へ][次へ]

[他社商品名称に関する表示]

All Rights Reserved. Copyright (C) 2012, Hitachi, Ltd.
All Rights Reserved. Copyright (C) 2012, Hitachi Solutions, Ltd.


［辞書の指定］ダイアログ

5.24　［辞書の指定］ダイアログ

見出し辞書のある場所を設定するダイアログです。［オプション］ダイアログの［見出し辞書］タブで，［辞書フォルダ］テキストボックス横の［...］ボタンをクリックしたときに表示されます。

＜この節の構成＞
(1)　［辞書の指定］ダイアログで設定できる項目
(2)　画面図

(1)　［辞書の指定］ダイアログで設定できる項目

［フォルダ］リストボックス
見出し辞書のある場所が表示されます。使用する見出し辞書のフォルダを選択してください。

(2)　画面図

[目次][前へ][次へ]

[他社商品名称に関する表示]

All Rights Reserved. Copyright (C) 2012, Hitachi, Ltd.
All Rights Reserved. Copyright (C) 2012, Hitachi Solutions, Ltd.


［EUR ODBC Driver - セットアップ -］ダイアログ

5.25　［EUR ODBC Driver - セットアップ -］ダイアログ

［EUR ODBC Driver - セットアップ -］ダイアログでは，次に示す項目を設定します。

＜この節の構成＞
(1)　［EUR ODBC Driver - セットアップ -］ダイアログで設定できる項目
(2)　画面図

(1)　［EUR ODBC Driver - セットアップ -］ダイアログで設定できる項目

［データソース名］テキストボックス
任意の名称を指定します。文字数は32文字までです。ここで指定したデータソース名は［データソースの選択］ダイアログに表示されます。
［ホスト名称］テキストボックス
接続先のDABrokerがインストールされているホスト名，またはIPアドレスを指定します。文字数は32文字までです。省略した場合は，ODBC Driverがインストールされているマシンが設定されます。
［接続データベース］リストボックス
接続するデータベースの種別を選択します。EURは，次に示すデータベースにアクセスできます。
  • HiRDB
  • Oracle
  • SQL Server
接続データベースには，そのほかのデータベースの種別が表示されますが，ここではEURがアクセスできるデータベースの種別から選択してください。データベースの接続設定については，「2.3.5　データベースごとの設定」を参照してください。
［データベース識別子］テキストボックス
データベース識別子に指定する情報は，［接続データベース］で選択したデータベースによって，次のように異なります。
  • HiRDBを選択した場合
    接続先のHiRDBが使用するポート番号（PDNAMEPORT指定値）を指定します。データベース識別子の指定を省略した場合は，DABrokerがインストールされているマシンのPDNAMEPORTの値が仮定されます。
  • Oracleを選択した場合
    DABrokerが使用するOracleのネット・サービス名を指定します。データベース識別子の指定を省略したときは，DABrokerがインストールされているマシンのORACLE_SIDの値が仮定されます。
  • SQL Serverを選択した場合
    DABrokerがインストールされているマシンに，［ODBCデータソースアドミニストレータ］ダイアログの［システムDSN］タブで設定したSQL Serverのデータソース名を指定します。SQL Serverを選択した場合は，データベース識別子を必ず指定してください。
［データベースホスト名］テキストボックス
データベースホスト名は，［接続データベース］で「HiRDB」を選択したとき指定できます。
データベースホスト名には，HiRDBのホスト名を指定します。データベースホスト名の指定を省略した場合は，DABrokerがインストールされているマシンのPDHOSTの値が仮定されます。
［送受信領域サイズ］テキストボックス
データ検索で使用する送受信用領域サイズを指定します。指定できる送受信用領域サイズは，1～16,000（KB）です。デフォルトは，「64（KB）」です。
［環境定義］ボタン
［EUR ODBC Driver - 環境定義 -］ダイアログが表示されます。

(2)　画面図

[目次][前へ][次へ]

[他社商品名称に関する表示]

All Rights Reserved. Copyright (C) 2012, Hitachi, Ltd.
All Rights Reserved. Copyright (C) 2012, Hitachi Solutions, Ltd.


［EUR ODBC Driver - 環境定義 -］ダイアログ

5.26　［EUR ODBC Driver - 環境定義 -］ダイアログ

［EUR ODBC Driver - 環境定義 -］ダイアログでは，次に示す項目を設定します。

＜この節の構成＞
(1)　［EUR ODBC Driver - 環境定義 -］ダイアログで設定できる項目
(2)　画面図

(1)　［EUR ODBC Driver - 環境定義 -］ダイアログで設定できる項目

［通信ドライバ］リストボックス
「WINSOCK」固定です。編集できません。
［応答監視時間］テキストボックス
サーバプログラムから処理結果が戻らない場合，処理を打ち切る時間を指定します。指定できる応答監視時間は，0～3,600（秒）です。デフォルトは，「60（秒）」です。「0（秒）」を指定した場合は，サーバプログラムからの応答を監視しません。

(2)　画面図

[目次][前へ][次へ]

[他社商品名称に関する表示]

All Rights Reserved. Copyright (C) 2012, Hitachi, Ltd.
All Rights Reserved. Copyright (C) 2012, Hitachi Solutions, Ltd.


EUR 帳票作成機能のメッセージ

6.　EUR 帳票作成機能のメッセージ

この章では，EUR 帳票作成機能でEURから出力されるメッセージの意味，およびその対策について説明します。

＜この章の構成＞
6.1　メッセージの出力形式
6.2　メッセージの記載形式
6.3　メッセージの出力先
6.4　DBL0001～DBL0999のメッセージ
6.5　DBL1000～DBL1999のメッセージ
6.6　DBP0001～DBP0999のメッセージ
6.7　DBP1000～DBP1999のメッセージ
6.8　DBP2000～DBP2999のメッセージ
6.9　DBP3000～DBP3999のメッセージ
6.10　DBP6000～DBP6999のメッセージ
6.11　DBP8000～DBP8999のメッセージ


メッセージの出力形式

6.1　メッセージの出力形式

＜この節の構成＞
(1)　データベースアクセス定義が表示するメッセージ形式
(2)　ODBC Driverのメッセージ形式

(1)　データベースアクセス定義が表示するメッセージ形式

データベースアクセス定義の操作をしている時に出力されるメッセージは，次に示す形式で標準エラー出力に表示されます。

DBPxxxxy：メッセージ文

メッセージの表示内容を項目ごとに次に示します。

表6-1　 メッセージの表示内容（データベースアクセス定義の場合）

形式の項目 | 説明
DBPxxxxy | メッセージIDを示します。 xxxxは，メッセージ番号を示します。 yは，レベル（I（Information），W（Warning），またはE（Error））を示します。
メッセージ文 | メッセージ文を示します。

(2)　ODBC Driverのメッセージ形式

EUR 帳票作成機能を操作している時に出力されるメッセージは，次に示す形式で標準エラー出力に表示されます。

DBLxxxxy メッセージ文

メッセージの表示内容を項目ごとに次に示します。

表6-2　 メッセージの表示内容（ODBC Driverの場合）

形式の項目 | 説明
DBLxxxxy | メッセージIDを示します。 xxxは，メッセージ番号を示します。 yは，レベル（I（Information），W（Warning），またはE（Error））を示します。
メッセージ文 | メッセージ文を示します。


メッセージの記載形式

6.2　メッセージの記載形式

このマニュアルでのメッセージの記載形式について説明します。

＜この節の構成＞
メッセージID


メッセージID

メッセージID

メッセージ文（エラーコード）

詳細情報
メッセージの詳細情報を示します。
説明
メッセージの説明を示します。
要因
メッセージの要因を示します。
対処
表示されたメッセージに対する対処方法を示します。
対処の参照先
対処するための参照先を示します。
対処時に関係するプロパティ，メソッドおよび関数を示します。
レベル
メッセージのレベルを示します。
終了コード
メッセージIDの終了コードを示します。
注意
対処する場合の注意事項を示します。
補足
メッセージの補足説明を示します。

メッセージ記載形式の各項目の意味を次に示します。

表6-3　 メッセージ記載形式の項目

項目名 | 意味
メッセージID | メッセージIDを示します。メッセージIDがない場合は，メッセージIDの代わりにメッセージ文を示します。
メッセージ文 | メッセージ文を示します。
（エラーコード） | OS上のシステム関数エラーリターン時のerror情報を示します。エラーコードについては，OSのヘッダファイル，またはOSのヘルプファイルを参照してください。
詳細情報 | イベントログ，またはEURで出力するログ（eurpsログなど）に出力される詳細情報を示します。
 | U | 実行ユーザアカウント
 | R | フォームシートファイル名
 | F | 帳票機能名
 | P | ページ番号
 | D | 対象のマッピングデータファイル名，またはユーザ定義データファイル名
 | DI | 入力データ値（正）
 | DO | 欠落などで不正出力となった出力値
 | E | 終了時の終了コード（10進数表示）
 | C | 指定されたコマンド文字列
説明 | メッセージのレベルが「I（Information）」の場合，メッセージの説明をします。
要因 | メッセージが出力された要因を示します。
対処 | メッセージのレベルが「W（Warning）」と「E（Error）」の場合，メッセージの対処を示します。
対処の参照先 | 対処に必要な情報を示します。
レベル | メッセージのレベルを示します。I（Information），W（Warning），およびE（Error）があります。
終了コード | 終了コードを示します。参照先を次に示します。 終了コードは，コマンドの/nomessageオプション（UNIX／Linux環境の場合は-nomessageオプション）が指定されていても設定されます。ただし，終了コードだけでは，エラーの詳細が判別できないため，/messageオプション（UNIX／Linux環境の場合は-messageオプション）を指定して，出力されるメッセージを参照して解析するか，またはログ機能で出力されるエラー情報で調査してください。ログのエラー情報については，マニュアル「EUR システム設計ガイド」を参照してください。
 | 0 | 正常終了しました。
 | 4 | 警告が発生しました。警告が発生する要因については，マニュアル「EUR メッセージ」を参照してください。
 | 8 | システムエラーが発生しました。または，出力でエラーが発生しました。
 | 10 | データベースアクセスでエラーが発生しました。
 | 12 | データエラーが発生しました。
 | 16 | コマンド，メソッドでの設定値，またはプリンタ定義ファイル内で文法エラーがあります。
 | 2008 | ActiveXオブジェクトによる起動で，起動時にシステムエラーが発生しました。
 | 2016 | ActiveXオブジェクトによる起動で，プロパティの指定でエラーが発生しました。
 | 32 | 上記以外のエラーが発生しました。
注意または補足 | メッセージの注意事項，補足情報を示します。


メッセージの出力先

6.3　メッセージの出力先

EUR 帳票作成機能，およびEUR クライアント帳票出力機能では，メッセージをダイアログやログに出力します。メッセージの出力先を次に示します。

＜この節の構成＞
(1)　ダイアログ
(2)　イベントログ
(3)　EUR 帳票作成機能およびEUR クライアント帳票出力機能が出力するログ

(1)　ダイアログ

EUR 帳票作成機能，およびEUR クライアント帳票出力機能の画面を操作している場合，ダイアログにメッセージが表示されます。

(2)　イベントログ

Windows環境では，コマンド実行中にエラーが発生した場合，エラーレベル（レベル：Error）のメッセージを，Windowsのイベントログへアプリケーションのイベントとして出力します。ログには，エラーの発生要因となったエラーメッセージのメッセージ文に加えて，詳細情報が出力されます。なお，イベントログの参照は，Windows上の管理ツールのイベント ビューアで参照できます。

(3)　EUR 帳票作成機能およびEUR クライアント帳票出力機能が出力するログ

ログ採取機能を利用できるEURでは，ユーザがログ採取の情報を設定する必要はありません。EURの処理中にエラーを感知した場合，ユーザアプリケーションデータフォルダ\HITACHI\EURにファイル名「HIEUR.LOG」を自動生成して，エラーの個所とその内容をログファイルに出力します。ユーザアプリケーションデータフォルダはC:\Users\ユーザ名\AppData\Roamingです。


DBL0001～DBL0999のメッセージ

6.4　DBL0001～DBL0999のメッセージ

＜この節の構成＞
DBL0010E
DBL0020E
DBL0100E
DBL0101E
DBL0401E


DBL0010E

DBL0010E

応答監視時間の指定に誤りがあります。

要因
応答監視時間に0～3600の整数以外が指定されています。
対処
0～3600の整数を指定して，再実行してください。


DBL0020E

DBL0020E

送受信領域サイズに数字以外の文字が指定されました。

要因
送受信領域サイズの指定に数字以外の文字が指定されています。
対処
送受信領域サイズを数字で指定してください。


DBL0100E

DBL0100E

通信ドライバの指定が不正なため，処理を中止しました。

要因
次に示す要因によって，処理を中止しました。
  • EUR ODBC Driverをインストールしたあと，通信ドライバが設定されていません。
  • 環境定義ファイルが不正です。
対処
［EUR ODBC Driver - 環境定義 - ］ダイアログで，通信ドライバを設定してください。


DBL0101E

DBL0101E

指定された通信ドライバに対応したEUR ODBC Driverが見つかりませんでした。

要因
次に示す要因によって，EUR ODBC Driverが見つかりません。
  • 環境定義で指定された通信ドライバに対応したEUR ODBC Driverがインストールされていません。
  • EUR ODBC Driverがインストールされているフォルダが移動されています。
対処
使用する通信ドライバに対応したEUR ODBC Driverをインストールしたあと，再実行してください。


DBL0401E

DBL0401E

システムコールでエラーが発生しました。[システムコール名称(),errno=エラー番号]

要因
OSのシステムコール関数でエラーが発生しました。
対処
操作を再実行してください。
再度発生する場合は，システム管理者に連絡してください。


DBL1000～DBL1999のメッセージ

6.5　DBL1000～DBL1999のメッセージ

＜この節の構成＞
DBL1001E
DBL1002E
DBL1003E
DBL1004E
DBL1005E
DBL1006E
DBL1007E
DBL1011E


DBL1001E

DBL1001E

通信ドライバのローディングに失敗しました。

要因
下位の通信ドライバのローディングに失敗しました。
対処
次に示す対処をしてください。
  • 通信ドライバをインストールしているかどうかを確認してください。
  • EUR ODBC Driverをセットアップしたときの通信ドライバの選択が正しいかどうかを確認してください。


DBL1002E

DBL1002E

コネクション確立時，ソケットのオープンに失敗しました。[errno=エラーコード]

要因
コネクションを確立しようとしましたが，空いているソケットがありません。
対処
ほかのアプリケーションを終了して再実行してください。
再度エラーが起こるときは，通信ドライバに設定するソケット数を増やしてください。ソケット数の設定については，通信ドライバのマニュアルまたはヘルプを参照してください。


DBL1003E

DBL1003E

コネクション確立時にTCPコネクション確立処理に失敗しました。[errno=エラーコード]

要因
コネクションを確立時にTCPコネクション確立処理に失敗しました。
対処
次に示す対処をしてください。
  • 一定時間後，再実行してください。
  • サーバプログラム（DABroker），またはサーバプログラム下の通信プログラムがエラーになっていないかどうかを確認してください。
  • 通信ドライバに登録したインターネットアドレスを見直してください。
  • ポート番号を見直してください。
  • 回線の接続状態を確認してください。
  • TCP/IPを使っているほかのアプリケーションを終了させてください。
  • 通信ドライバに設定するTCPコネクションの数を増やしてください。


DBL1004E

DBL1004E

コネクションが切断されました。[errno=エラーコード]

要因
データの送受信時にコネクションが切断されました。
対処
次に示す処置をしてください。
  • 一定時間後，再実行してください。
  • サーバプログラム（DABroker），またはサーバプログラム下の通信プログラムがエラーになっていないかどうかを確認してください。
  • 回線の接続状態を確認してください。
  • サーバプログラムの動作環境設定ファイルの内容とEUR ODBC Driverをセットアップしたときの設定内容を見直してください。


DBL1005E

DBL1005E

応答監視時間を超えました。

要因
データの送受信時に応答時間を超えました。
対処
サーバプログラム（DABroker）がエラーになっていないかどうかを確認してください。エラーになっていないときは，EUR ODBC Driverの［EUR ODBC Driver - 環境定義 -］ダイアログで設定した応答監視時間の値を大きくしてください。


DBL1006E

DBL1006E

インタネットアドレスが取得できません。

要因
接続先のインターネットアドレスが取得できません。
対処
通信ドライバの接続先のインターネットアドレスが登録されているかどうかを確認してください。


DBL1007E

DBL1007E

通信時に異常が発生しました。[errno=エラーコード]

要因
サーバとの通信時に異常が発生しました。
対処
再実行してください。再度エラーが発生する場合は，システム管理者に連絡してください。


DBL1011E

DBL1011E

接続したデータベースとデータソースに指定したデータベースの種類が異なります。

要因
接続したデータベースとデータソースに指定したデータベースの種類が異なります。
対処
［EUR ODBC Driver - セットアップ -］ダイアログで設定したデータソースに指定したデータベース識別子が正しいかどうか見直してください。


DBP0001～DBP0999のメッセージ

6.6　DBP0001～DBP0999のメッセージ

＜この節の構成＞
DBP0001E
DBP0002E
DBP0005W
DBP0006W
DBP0007E
DBP0010W
DBP0011W
DBP0012W
DBP0013W
DBP0018W
DBP0019I
DBP0020W
DBP0022I
DBP0025W
DBP0501W
DBP0502W
DBP0503W
DBP0505W
DBP0507W
DBP0508W
DBP0509W
DBP0510W
DBP0511W
DBP0512W
DBP0513W
DBP0514W
DBP0515W
DBP0516W
DBP0517W
DBP0518W
DBP0519W
DBP0520W
DBP0521W
DBP0522W
DBP0523W
DBP0524W
DBP0525W
DBP0526W
DBP0527W
DBP0529W
DBP0530W
DBP0532W
DBP0533W
DBP0534W
DBP0535W


DBP0001E

DBP0001E

データベースアクセス定義の稼働に必要なメモリがありません。他のプログラムを終了して，再実行してください。

要因
メモリの確保に失敗しました。次に示す要因が考えられます。
  • 複数のアプリケーションが起動されています。
  • Windowsシステムが使用できるメモリ，またはリソースが不足しています。
対処
ほかのアプリケーションプログラムを終了したあと，再実行してください。


DBP0002E

DBP0002E

データベースアクセス定義の実行中に異常が発生しました。データベースアクセス定義を終了します（詳細コード）。

要因
データベースアクセス定義の実行中に異常が発生しました。
対処
データベースアクセス定義を終了させてください。
補足
保守用の情報が「（詳細コード）」に表示されます。


DBP0005W

DBP0005W

処理を中断しますか？

要因
処理の中断が選択されました。
対処
次のように対処してください。
  • 処理を中断する場合は，［はい］ボタンをクリックしてください。
  • 処理を続行する場合は，［いいえ］ボタンをクリックしてください。


DBP0006W

DBP0006W

抽出するデータがnnn件あります。抽出しますか？

要因
抽出するデータがnnn件ありました。
対処
抽出件数を確認したあと，次のように対処してください。
  • nnn件分のデータを抽出する場合は，［はい］ボタンをクリックしてください。
  • データを抽出しない場合は，［いいえ］ボタンをクリックしてください。


DBP0007E

DBP0007E

起動パラメタの指定が誤っています。

要因
次に示す要因が考えられます。
  • エクスプローラなどから，直接，データベースアクセス定義が起動されました。
  • EUR 帳票作成機能またはEUR 帳票作成機能（EUR Form帳票）のメニュー以外から，データベースアクセス定義が起動されました。
対処
EUR 帳票作成機能またはEUR 帳票作成機能（EUR Form帳票）のメニューから起動してください。


DBP0010W

DBP0010W

ファイルの書き込み中にエラーが発生しました。

要因
次に示す要因が考えられます。
  • ファイルが見つからない，オープンされているファイルが多いなどの理由で，ファイルの書き込み中にエラーが発生しました。
  • ファイルに書き込み権限がありません。
  • ドライブの容量不足が発生しました。
対処
次のように対処してください。
  • 既存のファイルがあるかどうかを確認してください。
  • オープンされているファイルのうち，不要なファイルは閉じてください。
  • 出力先フォルダには，書き込み権限を与えてください。
  • 既存のファイルに上書きする場合は，書き込み権限を与えてください。
  • ドライブの空き容量を増やしてください。


DBP0011W

DBP0011W

ファイルの読み込み中にエラーが発生しました。

要因
次に示す要因が考えられます。
  • ファイルが見つからない，オープンされているファイルが多いなどの理由で，ファイルの読み込み中にエラーが発生しました。
  • ファイルに読み込み権限がありません。
  • ファイルが破壊されています。
対処
次のように対処してください。
  • 存在するファイルを指定してください。
  • 指定するファイルに，読み込み権限を与えてください。
  • 指定するファイルが壊れていないかどうか，確認してください。


DBP0012W

DBP0012W

ファイルのオープン又は作成に失敗しました。

要因
ファイルが見つからない，オープンされているファイルが多いなどの理由で，指定されたファイルのオープンまたは作成に失敗しました。
対処
ファイルが使用できる状態か調査してください。使用できない場合は，要因を取り除いて，再実行してください。


DBP0013W

DBP0013W

ファイルの削除に失敗しました。

要因
ファイルが見つからない，オープンされているファイルが多いなどの理由で，指定されたファイルの削除に失敗しました。
対処
ファイルが使用できる状態か調査してください。使用できない場合は，要因を取り除いて，再実行してください。


DBP0018W

DBP0018W

絞り込み条件の指定に誤りがあります。

要因
絞り込み条件に，「.」が指定されています。
対処
絞り込み条件を正しく指定して，再実行してください。


DBP0019I

DBP0019I

絞り込み条件に一致する表はありません。

要因
絞り込み条件に合う表が見つかりません。次に示す要因が考えられます。
  • 表に，絞り込み条件に指定された文字列がありません。
  • 全角／半角文字，または英字の大文字／小文字が正しく指定されていません。
  • 空白文字で始まる所有者名／表名を探す条件に，前方一致，または完全一致の条件が指定されました。
  • 空白文字で終わる所有者名／表名を探す条件に，後方一致，または完全一致の条件が指定されました。
対処
絞り込み条件を指定し直して，再実行してください。


DBP0020W

DBP0020W

絞り込み条件に指定された文字数が多すぎます。

要因
所有者と表名の最大文字数が，半角254文字を超えています。
対処
絞り込み条件を正しく指定して，再実行してください。


DBP0022I

DBP0022I

データベースアクセス定義を終了できません。

要因
データベースアクセス定義が終了できる状態ではありません。
対処
データベースアクセス定義の状態を確認してください。


DBP0025W

DBP0025W

指定したファイルまたはフォルダのパスが長すぎます。

要因
ロングファイル名で256バイトより長いパスを選択しました。
対処
ファイル名，またはフォルダ名のパスを指定し直したあと，再実行してください。


DBP0501W

DBP0501W

括弧の指定方法に誤りがあります。

要因
条件関連式の左括弧と右括弧の数が一致しません。
対処
左括弧と右括弧の数が合っているかどうかを確認してください。


DBP0502W

DBP0502W

条件関連式に指定できない文字があります。

要因
条件関連式に指定できない文字があります。
対処
条件関連式に指定できる文字は，使用するデータベースによって異なります。条件を設定するときの規則については，「3.3.3　条件の設定」またはマニュアル「EUR 帳票設計（EUR Form帳票）」を参照してください。


DBP0503W

DBP0503W

条件一覧に存在しない番号が指定されています。

要因
条件一覧にない番号が条件関連式に指定されています。
対処
条件一覧にない番号を削除してください。


DBP0505W

DBP0505W

数値データのけた落ちが発生しました。

要因
浮動小数点の有効範囲を超える定数が指定されました。
対処
定数の有効範囲は，使用するデータベースによって異なります。定数の規則については，「3.3.3(2)　列と定数の規則」またはマニュアル「EUR 帳票設計（EUR Form帳票）」を参照してください。


DBP0507W

DBP0507W

SQL文の長さがシステムの制限を超えました。

要因
生成されたSQL文の長さがシステムの制限を超えています。
対処
次に示す対処を，一つ以上実行してください。
  • 指定した列の数を減らしてください。
  • 指定した条件の数を減らしてください。
  • 指定した条件関連式を短くしてください。


DBP0508W

DBP0508W

条件関連式のネスト数が64を超えました。

要因
条件関連式のネスト数が64を超えています。
対処
次に示す対処を，一つ以上実行してください。
  • 括弧内の検索条件を減らしてください。
  • 括弧の数を減らしてください。
  • OR，ANDの順に指定している論理式の数を減らしてください。


DBP0509W

DBP0509W

AND，OR，及びNOTの総数が255個を超えました。

要因
条件関連式のAND，OR，およびNOTの総数が255個を超えました。
対処
条件関連式のAND，OR，およびNOTの総数が255個以下になるように変更したあと，再実行してください。


DBP0510W

DBP0510W

文字パターンの指定に誤りがあります。

要因
指定できない文字パターンが設定されました。
対処
文字パターンの規則は，使用するデータベースによって異なります。文字パターンの規則については，「3.3.3(5)　LIKE条件」またはマニュアル「EUR 帳票設計（EUR Form帳票）」を参照してください。


DBP0511W

DBP0511W

アポストロフィの指定方法に誤りがあります。

要因
文字定数の「'」の指定に誤りがあります。
対処
「'」を文字データとして使用する場合は，「'」を二つ続けて指定してください。


DBP0512W

DBP0512W

条件関連式の構文が誤っています。

要因
条件関連式の構文が誤っています。
対処
条件関連式の構文を見直したあと，再実行してください。


DBP0513W

DBP0513W

比較できない属性の列を指定しています。

要因
比較できない属性の列を比較しようとしました。
対処
列比較の規則は，使用するデータベースによって異なります。比較できる列属性の組み合わせを次に示します。

表6-4　比較できる列属性の組み合わせ

左辺（表1の列名） | 右辺（表2の列名）
CHAR，VARCHAR，LONG VARCHAR，MCHAR，MVARCHAR，NCHAR，NVARCHAR，UCHAR※，UVARCHAR※，LONG UVARCHAR※ | CHAR，VARCHAR，LONG VARCHAR，MCHAR，MVARCHAR，NCHAR，NVARCHAR，UCHAR※，UVARCHAR※，LONG UVARCHAR※
NUMERIC，DECIMAL，SMALLINT，INTEGER，REAL，FLOAT，BIT，TINYINT，DOUBLE | NUMERIC，DECIMAL，SMALLINT，INTEGER，REAL，FLOAT，BIT，TINYINT，DOUBLE
DATE | DATE
TIME | TIME
BINARY，VARBINARY，LONG VARBINARY | BINARY，VARBINARY，LONG VARBINARY
TIMESTAMP | TIMESTAMP
注※
SQL Serverを使用する場合で，Unicodeデータを抽出するときだけ使用できます。


DBP0514W

DBP0514W

文字データの列又は定数に四則演算を指定しています。

要因
文字データの列，または定数に四則演算が指定されています。
対処
文字データの列，または定数には，四則演算を指定できません。四則演算の指定を削除してください。


DBP0515W

DBP0515W

列記号の指定に誤りがあります。

要因
列記号の指定が誤っています。
対処
列記号の指定を見直したあと，再実行してください。


DBP0516W

DBP0516W

条件式の数値の指定に誤りがあります。

要因
条件式の数値の指定が誤っています。
対処
条件式の指定を見直したあと，再実行してください。


DBP0517W

DBP0517W

列演算条件式の演算子の指定に誤りがあります。

要因
次に示す要因が考えられます。
  • 演算子を二つ続けて指定しています。
  • 列名と列名の間，または数値の間に，演算子がありません。
  • 演算子の後ろに列名，または数値がありません。
対処
列演算条件式の演算子を見直したあと，再実行してください。


DBP0518W

DBP0518W

括弧の指定方法に誤りがあります。

要因
次に示す要因が考えられます。
  • 列演算条件式の左括弧と右括弧の数が一致しません。
  • 左括弧の前に右括弧を指定しています。
対処
括弧の指定，および括弧の数が合っているかどうかを確認してください。


DBP0519W

DBP0519W

列演算条件式のネスト数が64を超えました。

要因
列演算条件式のネスト数が64を超えています。
対処
列演算条件式中の演算子，または括弧の数を減らしてください。


DBP0520W

DBP0520W

条件式に不正な文字があります。

要因
条件式に指定できない文字があります。
対処
条件式に指定できる文字は，数値，文字定数，演算子，「(」，および「)」です。
条件式の構文を見直したあと，再実行してください。


DBP0521W

DBP0521W

指定された列が見つかりません。

要因
列一覧にない列が指定されています。
対処
列一覧に表示されている列を指定してください。


DBP0522W

DBP0522W

条件式に列が指定されていません。

要因
左辺，または右辺に，列が指定されていません。
対処
左辺，または右辺に列を指定したあと，再実行してください。


DBP0523W

DBP0523W

列の指定方法に誤りがあります。

要因
列の指定方法に誤りがあります。
対処
列の指定を見直したあと，再実行してください。
列名に予約語，または区切り記号を使用している場合は，列名の前後を「"」で囲んでください。


DBP0524W

DBP0524W

条件式に誤りがあります。

要因
次に示す要因が考えられます。
  • 条件式の指定に誤りがあります。
  • ［列演算条件式］ダイアログに，NULL，IN，LIKE，またはBETWEEN条件式が指定されています。
対処
条件式の指定を見直したあと，再実行してください。


DBP0525W

DBP0525W

指定された値は列の属性と合っていません。

要因
指定された値が，列の属性と合っていません。
対処
列属性と定数の組み合わせは，使用するデータベースによって異なります。条件を設定するときの規則については，「3.3.3　条件の設定」またはマニュアル「EUR 帳票設計（EUR Form帳票）」を参照してください。


DBP0526W

DBP0526W

指定された値は指定できる有効範囲を超えています。

要因
定数に指定された値が，有効範囲を超えています。
対処
定数の有効範囲は，使用するデータベースによって異なります。定数の規則については，「3.3.3(2)　列と定数の規則」またはマニュアル「EUR 帳票設計（EUR Form帳票）」を参照してください。


DBP0527W

DBP0527W

指定された値は列の定義長を超えています。

要因
指定された値が，列の定義長を超えています。
対処
列の定義長を確認したあと，定義以内の値を入力してください。


DBP0529W

DBP0529W

演算できない列が指定されています。

要因
演算できない列が条件式に指定されています。
対処
演算できる属性の列を指定してください。


DBP0530W

DBP0530W

四則演算を使用していない条件式は指定できません。

要因
［列演算条件式］ダイアログは，四則演算が使用されていない条件式を指定できません。
対処
四則演算を使用した条件式を指定してください。四則演算を使用しない場合は，［条件設定］ダイアログで指定してください。


DBP0532W

DBP0532W

指定された値は指定できる有効範囲を超えています。

要因
定数の有効範囲を超えた値が指定されました。
対処
定数の有効範囲は，使用するデータベースによって異なります。定数の規則については，「3.3.3(2)　列と定数の規則」またはマニュアル「EUR 帳票設計（EUR Form帳票）」を参照してください。


DBP0533W

DBP0533W

条件関連式の括弧の数が64を超えました。

要因
条件関連式に指定された括弧の数が64を超えています。
対処
条件関連式の括弧の数が，64以内になるように見直したあと，再実行してください。


DBP0534W

DBP0534W

AND，及びORの総数が254を超えました。

要因
条件関連式のAND，およびORの総数が254を超えました。
対処
AND，およびORの総数が254以内になるように見直したあと，再実行してください。


DBP0535W

DBP0535W

抽出条件を設定できない属性の列が含まれています。

要因
抽出条件の中に，条件を設定できない列が設定されています。
対処
条件を設定できる列属性は，使用するデータベースによって異なります。条件を設定するときの規則については，「3.3.3　条件の設定」またはマニュアル「EUR 帳票設計（EUR Form帳票）」を参照してください。


DBP1000～DBP1999のメッセージ

6.7　DBP1000～DBP1999のメッセージ

＜この節の構成＞
DBP1005W
DBP1013E
DBP1015W
DBP1019W
DBP1024W
DBP1025W
DBP1029W
DBP1030W
DBP1032W
DBP1038W
DBP1040W
DBP1045I
DBP1046I
DBP1048I
DBP1049W
DBP1050W
DBP1055W
DBP1056W
DBP1058W
DBP1082I
DBP1083W
DBP1084W
DBP1085W
DBP1087W
DBP1117W
DBP1118W
DBP1119W
DBP1120W
DBP1123W
DBP1124W
DBP1127W
DBP1128W
DBP1129W
DBP1133W
DBP1136I
DBP1137W
DBP1138W
DBP1140W
DBP1141W
DBP1143W
DBP1144W
DBP1151W


DBP1005W

DBP1005W

グループを設定できない属性の列（列名）を選択しているため，集合関数の設定はできません。

要因
選択された列の中に，グループ分けを設定できない属性の列があったので，集合関数を設定できません。
対処
グループ分けが設定できない属性の列を削除したあと，再実行してください。


DBP1013E

DBP1013E

データベース接続情報がありません。

要因
データベース接続情報がありません。
対処
データベースアクセス定義を再起動してください。


DBP1015W

DBP1015W

値が指定されていません。

要因
［IN条件式］ダイアログのIN条件式に，値が指定されていません。
対処
IN条件式の値を指定してください。


DBP1019W

DBP1019W

条件を設定できる属性の列がありません。

要因
条件を設定できる列属性が設定されていません。
対処
［キャンセル］ボタンをクリックして［条件設定］ダイアログを閉じてください。


DBP1024W

DBP1024W

これ以上ソートは設定できません。

要因
ソートの数が多いため，これ以上は設定できません。
対処
ソートできる列数は255以内です。


DBP1025W

DBP1025W

グループ分けの列が多過ぎます。

要因
グループ分けの列が多いため，集合関数は設定できません。
対処
グループ分けに設定できる列数は，255以内です。


DBP1029W

DBP1029W

データの転送を中断します。中断するまでに検索したデータを転送しますか？

要因
データの転送の中断が指定されました。
対処
次のように対処してください。
  • 転送を中断するまでに検索されたデータを使用する場合は，［はい］ボタンをクリックしてください。
  • 転送を中断する場合は，［いいえ］ボタンをクリックしてください。
  • 処理を取り消す場合は，［キャンセル］ボタンをクリックしてください。


DBP1030W

DBP1030W

データの転送を中断しますか？

要因
データの転送処理が中断されました。
対処
次のように対処してください。
  • データの転送を中断する場合は，［はい］ボタンをクリックしてください。
  • データの転送を続行する場合は，［いいえ］ボタンをクリックしてください。


DBP1032W

DBP1032W

抽出データの件数は取得できませんでした。処理を続行しますか？

要因
抽出データの件数の取得に失敗しました。次に示す要因が考えられます。
  • HiRDB，Oracle以外のデータベースの場合
    抽出条件に，集合関数が指定されています。
対処
次のように対処してください。
  • 処理を続行する場合は，［はい］ボタンをクリックしてください。
  • 処理を中断する場合は，［いいえ］ボタンをクリックしてください。


DBP1038W

DBP1038W

選択された表に，表示できる列がありません。

要因
選択された表が，すべてLONG VARBINARYの列です。
対処
LONG VARBINARY以外の列で定義されている表を選択してください。


DBP1040W

DBP1040W

グループ分けのできない列は，グループ分けされている設定内容の中に追加又は挿入できません。

要因
グループ分けされている設定内容の中に，グループ分けのできない列を追加，または挿入しようとしました。
対処
次のように対処してください。
  • ［集合関数設定］ダイアログで，グループ分けの設定を取り消したあと，列の追加，または挿入をしてください。
  • グループ分けを設定できる列を選択して，再実行してください。


DBP1045I

DBP1045I

条件表示リストボックスに結合条件を設定していない表があるため，抽出データが大量になることがあります。処理を続行しますか？

要因
選択された表の中に，結合条件が設定されていない表があります。
対処
次のように対処してください。
  • 処理を続行する場合は，［はい］ボタンをクリックしてください。結合条件が設定されている表の各行に，結合条件が設定されていない表の全行を付けた形でデータが抽出されます。この場合，抽出データが大量になることがあります。
  • 処理を中止する場合は，［いいえ］ボタンをクリックしてください。［条件設定］ダイアログで，抽出する表に結合条件を設定してください。


DBP1046I

DBP1046I

結合条件を設定できない表があります。処理を続行しますか？

要因
選択された表の中に，結合条件を設定できない表があります。
対処
次のように対処してください。
  • 処理を続行する場合は，［はい］ボタンをクリックしてください。［条件設定］ダイアログが表示されます。
  • 処理を中止する場合は，［いいえ］ボタンをクリックしてください。
  • 複数の表を結合して抽出する場合は，結合条件が設定できる表だけを選択してください。


DBP1048I

DBP1048I

設定した抽出時間の上限を超えました。転送を中断します。

説明
［オプション］メニューで設定された「抽出時間」の上限値を超えたことを示すメッセージです。


DBP1049W

DBP1049W

［抽出時間の上限］の値が，設定可能な範囲（1～nnn分）を超えています。

要因
［オプション］ダイアログの［表示］タブで，［抽出時間の上限］に指定されている値に誤りがあります。
対処
接続先のデータベースによって，抽出時間の上限値の範囲は異なります。1～999分を目安に指定してください。


DBP1050W

DBP1050W

aa...aa属性の列があるため，処理できません。

要因
列に「aa...aa」に示す属性が設定されているため，処理を中止しました。
対処
［列設定］ダイアログで，「aa...aa」属性を削除してください。


DBP1055W

DBP1055W

抽出する列がnnn列を超えています。

要因
抽出する列数が，制限のnnn列を超えました。
対処
抽出する列が，メッセージに表示された列数以下になるようにしてください。


DBP1056W

DBP1056W

抽出する列の定義長の合計がnnnバイトを超えています。

要因
抽出する列の定義長の合計が，制限のnnnバイトを超えました。
対処
列の定義長の合計が，メッセージに表示されたバイト数以下になるようにしてください。数値属性の列は，1桁を1バイトとします。


DBP1058W

DBP1058W

ソートまたはグループ分けを設定した列がnnn列を超えています。

要因
ソートを設定した列と，グループ分けを設定した列の合計が，制限のnnn列を超えました。
対処
ソート，またはグループ分けを設定した列の合計が，メッセージに表示された列数以下になるようにしたあと，再実行してください。
同じ列にソートとグループ分けを設定する場合，列数は1と数えます。


DBP1082I

DBP1082I

複数の表を使用しているため，条件の指定方法によりデータが大量になることがあります。処理を続行しますか？

説明
複数の表からデータを抽出する場合は，抽出されるデータが大量になることがあります。そのため，結合条件だけでは，十分にデータを絞り込めません。結合条件とは別に，「データを絞り込むための条件」も指定されることをお勧めします。
対処
次のように対処してください。
  • 処理を続行する場合は，［はい］ボタンをクリックしてください。現在の条件で抽出されます。
  • 処理を中止する場合は，［いいえ］ボタンをクリックしてください。「条件設定」を設定し直してください。


DBP1083W

DBP1083W

ソートが設定できない列がありました。

要因
ソートが設定できない列がありました。次に示す要因が考えられます。
  • 別の種類のソートがすでに設定されています。
  • 同じ列に対して，すでにソートが設定されています。
対処
ソートの設定内容を確認してください。


DBP1084W

DBP1084W

集合関数が設定できない列がありました。

要因
集合関数が設定できない列がありました。次に示す要因が考えられます。
  • 数値属性でない列に，平均，または合計が設定されました。
  • 選択された列は，集合関数が設定できません。
対処
集合関数の設定内容を確認してください。


DBP1085W

DBP1085W

すべての表の列を表示することができませんでした。続行しますか？

要因
次に示す要因が考えられます。
  • 列一覧表示領域の最大文字数を超えました。
  • メモリ不足が発生しました。
対処
次のように対処してください。
  • 処理を続行する場合は，［はい］ボタンをクリックしてください。列一覧に先頭の表の列が表示されます。
  • 処理を中止する場合は，［いいえ］ボタンをクリックしてください。


DBP1087W

DBP1087W

ALIAS表とALIAS表以外の結合はできません。

要因
表種別「ALIAS」は，異なる種別の表と結合できません。
対処
表の選択を変更したあと，再実行してください。


DBP1117W

DBP1117W

［件数制限］の値が，設定可能な範囲（1～nnn件）を超えています。最大の件数に変更して処理を続行しますか？

要因
［件数制限］に設定された値が，設定できる最大件数を超えています。
対処
次のように対処してください。
  • ［件数制限］の値を，最大件数分（nnn件）で処理を続行する場合は，［はい］ボタンを選択してください。
  • ［件数制限］の値を範囲内の値に変更する場合は，［いいえ］ボタンを選択してください。


DBP1118W

DBP1118W

仮想列の指定に誤りがあります。

要因
次に示す要因が考えられます。
  • 仮想列に指定されている「所有者」，「表名」，および「列名」の文字列が，「"」で囲まれていません。
  • 「"」で囲まれている文字列が，256バイトを超えています。
対処
仮想列の指定を見直してください。


DBP1119W

DBP1119W

指定された列が見つかりません。

要因
選択された表にない列が指定されています。
対処
仮想列の指定を見直してください。


DBP1120W

DBP1120W

データ表示ウィンドウと連携できません。

要因
データ表示ウィンドウが連携できる状態ではありません。
対処
データ表示ウィンドウから表示されたダイアログを閉じてください。


DBP1123W

DBP1123W

条件式（条件式）は設定できません。

要因
使用できない条件式を設定しようとしました。または，条件式の設定に誤りがあります。
対処
条件式を見直してください。


DBP1124W

DBP1124W

aa...aaは使用できません。

要因
使用できない条件式，または機能が指定されました。
対処
メッセージに示されている条件式，または機能が使用できるかどうかを見直してください。


DBP1127W

DBP1127W

LONG VARBINARYを含む抽出方法に誤りがあります。

要因
  • EUR 帳票作成機能の場合
    LONG VARBINARYの列を選択した状態で，データベースアクセス定義を終了しようとしました。
  • EUR 帳票作成機能（EUR Form帳票）の場合
    LONG VARBINARYの列を選択した状態で，項目定義を更新しようとしました。
対処
  • EUR 帳票作成機能の場合
    LONG VARBINARYの列を削除してから，終了してください。
  • EUR 帳票作成機能（EUR Form帳票）の場合
    LONG VARBINARYの列を削除したあと，項目定義を更新してください。


DBP1128W

DBP1128W

選択できる列の最大数を超えました。処理を続行しますか？

要因
選択された列数が，10,000列を超えています。
対処
次のように対処してください。
  • 処理を続行する場合は，［はい］ボタンをクリックしてください。選択する列を10,000列分にして処理が続行されます。
  • 処理を中止する場合は，［いいえ］ボタンをクリックしてください。


DBP1129W

DBP1129W

選択できる列の最大数を超えました。

要因
選択された列数が，10,000列を超えています。
対処
選択されている列数を減らしてください。


DBP1133W

DBP1133W

条件式の指定に誤りがあります。

要因
次に示す要因が考えられます。
  • 条件式に指定されている「所有者」，「表名」，および「列名」の文字列が，「"」で囲まれていません。
  • 「"」で囲まれている文字列が，256バイトを超えています。
対処
条件式を正しく指定して，再実行してください。


DBP1136I

DBP1136I

行番号の項目名を項番にしました。

要因
行番号の項目名が指定されていません。項目名を「項番」にします。


DBP1137W

DBP1137W

aa...aaは非表示にできません。

要因
表一覧の非表示にできない項目名が，非表示に設定されています。
対処
メッセージに表示された項目名を表示するように設定してください。


DBP1138W

DBP1138W

辞書フォルダが指定されていません。

要因
辞書フォルダが指定されていません。
対処
辞書フォルダを指定してください。


DBP1140W

DBP1140W

抽出するデータnnn件あり，上限のデータ件数mmm件を超えました。抽出処理を中止します。

要因
抽出するデータ件数が，上限のデータ件数を超えました。
対処
「件数制限」，または「条件」の設定を見直して，抽出データの件数が制限内になるようにしてください。


DBP1141W

DBP1141W

抽出するデータnnn件あり，上限のデータ件数mmm件を超えました。抽出処理を続行しますか？

要因
抽出するデータ件数が，上限のデータ件数を超えました。
対処
次のように対処してください。
  • 抽出を続行する場合は，［はい］ボタンをクリックしてください。
  • 抽出を中止する場合は，［いいえ］ボタンをクリックしてください。


DBP1143W

DBP1143W

抽出するセル数がnnnを超えるため，抽出処理を中止します。

要因
抽出するデータのセル数が制限を超えました。
対処
「件数制限」，または「条件」の設定を見直して，抽出データのセル数が制限内になるようにしてください。


DBP1144W

DBP1144W

抽出するセル数がnnnを超えます。抽出処理を続行しますか？

要因
抽出するデータのセル数が制限を超えました。
対処
次のように対処してください。
  • 処理を続行する場合は，［はい］ボタンをクリックしてください。
  • 処理を中止する場合は，［いいえ］ボタンをクリックしてください。抽出データのセル数が制限内になるように，「件数制限」，または「抽出条件」を設定してください。


DBP1151W

DBP1151W

抽出データの件数が取得できません。

要因
抽出データの件数の取得に失敗しました。次に示す要因が考えられます。
  • HiRDB，Oracle以外のデータベースの場合
    抽出条件に，集合関数が指定されています。
対処
選択している接続先と抽出条件に誤りがないかどうかを確認してください。


DBP2000～DBP2999のメッセージ

6.8　DBP2000～DBP2999のメッセージ

＜この節の構成＞
DBP2001W
DBP2002E
DBP2007W
DBP2008W
DBP2009W
DBP2010E
DBP2017E


DBP2001W

DBP2001W

表示可能セル数を超えたため，データの表示を中止しました。

要因
データ表示ウィンドウで表示できるセル数が350,000セルを超えたため，データの表示を中止しました。
対処
データ表示ウィンドウに表示するセル数が，「（列数+1）*（行数+1）＜350,000」になるように，列数，または行数を少なくしてください。


DBP2002E

DBP2002E

ファイルのオープンに失敗しました。（nnn，mmm）

要因
ファイルのオープン処理に失敗しました。
対処
システム管理者は，指定したファイルが使用できる状態かどうかを調査してください。
補足
保守用の情報が「（nnn，mmm）」に表示されます。


DBP2007W

DBP2007W

20000行目以降，1000列目以降のデータは切り捨てました。

要因
抽出したデータが，20,000行以上，または1,000列以上ありました。20,000行以上，または1,000列以上のデータを切り捨てます。


DBP2008W

DBP2008W

20000行目以降のデータは切り捨てました。

要因
抽出したデータが，20,000行以上ありました。20,000行目以降のデータを切り捨てます。


DBP2009W

DBP2009W

1000列目以降のデータは切り捨てました。

要因
抽出したデータが，1,000列以上ありました。1,000列目以降のデータを切り捨てます。


DBP2010E

DBP2010E

ドライブの容量が不足しています。（nnn，mmm）

要因
データをファイルに格納しようとしましたが，ドライブの容量が不足しているため，格納できません。次に示すドライブの容量を確認してください。
  • システムの一時フォルダがあるドライブ
  • 抽出したデータをCSV形式ファイルに出力するドライブ
対処
不要なファイルを削除してください。
補足
保守用の情報が詳細コード「（nnn，mmm）」に表示されます。
参考
システムの一時フォルダについては，［システムのプロパティ］ダイアログで環境変数TMPまたはTEMPの設定を確認してください。
なお，出力先は環境変数TMPまたはTEMPの設定によって次の順に決定されます。
  1. 環境変数TMPで指定されているフォルダ
  2. 環境変数TMPが指定されていない場合，環境変数TEMPで指定されているフォルダ
  3. 環境変数TMPとTEMPがどちらも指定されていない場合，Windowsのフォルダ


DBP2017E

DBP2017E

データ表示ウィンドウが起動できません。

要因
次に示す要因が考えられます。
  • エクスプローラなどから，直接，データ表示ウィンドウが起動されました。
  • データベースアクセス定義以外から，データ表示ウィンドウが起動されました。
対処
データ表示ウィンドウは，データベースアクセス定義専用のプログラムです。データベースアクセス定義以外から起動させることはできません。


DBP3000～DBP3999のメッセージ

6.9　DBP3000～DBP3999のメッセージ

＜この節の構成＞
DBP3000W
DBP3001E
DBP3007E
DBP3008E
DBP3009E
DBP3600E
DBP3601E
DBP3602E
DBP3603I
DBP3604I
DBP3605W
DBP3606E
DBP3607I
DBP3608I
DBP3609E
DBP3610I
DBP3611I
DBP3612I
DBP3613I
DBP3614W
DBP3701W
DBP3702W
DBP3703W
DBP3704W
DBP3706W
DBP3904W


DBP3000W

DBP3000W

ODBCドライバでデータベースにアクセス中にエラーが発生しました。メッセージ：ODBCドライバから出力されるメッセージ SQLState：メッセージID SQLサーバエラー：詳細コード

要因
ODBCドライバでデータベースにアクセス中にエラーが発生しました。
対処
接続先のODBCドライバによって，ODBCドライバから出力されるメッセージが異なります。
なお，対処したあとも同じエラーが発生する場合は，システム管理者に連絡してください。また，下記に示した対処以外のエラーが発生した場合は，使用されているODBCドライバ，またはアクセスされているデータベースに依存します。
  • ［HITACHI］［DBPARTNER］の場合
    次に示すSQLStateに対応した対処をしたあと，再実行してください。
    SQLState | 要　因 | 対　処
    01004，22001
    • データが長いため，途中で切り捨てます。
    • 小数点以下の桁を切り捨てます。
             接続先のデータベースで使用できるデータの長さに合わせてください。
    08S01 | 回線が切断されました。 | 表示されている画面から障害が発生した要因を調査してください。要因を取り除いたあと，データベースアクセス定義を終了して再起動してください。
    22003 | 数値として扱える範囲を超えています。 | 条件を設定し直したあと，再実行してください。
    22008 | DATE型，またはTIME型で扱える範囲を超えています。 | 条件を設定し直したあと，再実行してください。
    IM002，IM003，SI090，28000
    • データベース連携のデータソース名，ユーザID，またはパスワードの指定が誤っています。
    • ODBCドライバをセットアップしたとき，指定されたデータソース名に誤りがありました。
    • ユーザID，またはパスワードが，データベースの制限長を超えています。
             データソース名，ユーザID，またはパスワードを正しく指定して再実行してください。
    S1001 | メモリ不足が発生しました。 | ほかのアプリケーションプログラムを終了したあと，再実行してください。
    DBL03 | 抽出できないデータ型があります。指定した表は使用できません。 | 設定されている列属性を見直してください。
    S1000 出力されたメッセージによって，次に示す処置をしてください。
    • Restricted Datatype attribute violation.
      抽出できないデータ型があります。指定した表は使用できません。
    • Too many number of columns.
      列設定または条件設定でこのエラーが発生した場合は，選択している表は使用できません。
             このほかのエラーが発生した場合は，選択されている列数を少なくしたあと，再実行してください。
    上記以外のSQLState － システム管理者に連絡してください。

    （凡例）－：該当する要因はありません。

  • ［HITACHI］［DBPARTNER］［ORACLE］の場合
    「ORA-01918：ユーザは存在しません」と出力されたときは，データベース連携の接続ユーザIDを全角文字で起動して，抽出操作をしたと考えられます。
  • ［Microsoft］［ODBCDLL］の場合
    次に示すSQLStateに対応した対処をしたあと，再実行してください。
    SQLState | 要　因 | 対　処
    IM004 | 接続しているアプリケーションが多過ぎるため，メモリ確保に失敗しました。 | 接続しているほかのアプリケーションを終了して，再接続してください。
    上記以外のSQLState － システム管理者に連絡してください。

    （凡例）－：該当する要因はありません。


DBP3001E

DBP3001E

表又は列がありません。

要因
表，または表の列がありません。
対処
サーバ実行環境に，表，または列があるかどうかを確認してください。


DBP3007E

DBP3007E

ODBC32.DLLのロードに失敗しました。

要因
ODBC32.DLLが削除されているか，または壊れているおそれがあります。
対処
EUR DesignerまたはEUR Developerを再インストールしてください。


DBP3008E

DBP3008E

抽出するデータがありません。

要因
選択された表に，抽出するデータがありません。または，設定された条件に合うデータがありません。
対処
条件を変更したあと，再実行してください。


DBP3009E

DBP3009E

選択した列の数と，抽出データの列数が一致していないため処理を中断しました。

要因
抽出する列数と，実際に取得したデータの列数が一致していません。
対処
次に示す仮想列の設定に，誤りがないかどうかを確認してください。
  • "表名".*
  • "列名","列名"


DBP3600E

DBP3600E

指定された見出し辞書ファイルは使用できません。

要因
指定された見出し辞書ファイルの内容と，サーバ上の内容が一致していません。
対処
見出し辞書ファイルを削除したあと，再実行してください。


DBP3601E

DBP3601E

指定されたフォルダには，見出し辞書ファイルがありません。

要因
見出し辞書ファイルを読み込もうとしましたが，指定されたフォルダに，見出し辞書ファイルがありません。
対処
見出し辞書ファイルの存在するフォルダを指定したあと，再実行してください。


DBP3602E

DBP3602E

見出し辞書ファイルが一杯です。

要因
見出し情報は，65,536個以上作成できません。
対処
不要な見出し情報を削除したあと，再実行してください。


DBP3603I

DBP3603I

編集した見出し情報は辞書登録されていません。破棄してもよろしいですか？

要因
編集した見出し情報は，見出し辞書に登録されていません。
対処
次のように対処してください。
  • 見出し辞書ファイルを破棄する場合は，［はい］ボタンをクリックしてください。
  • 見出し辞書ファイルを破棄しない場合は，［いいえ］ボタンをクリックしてください。


DBP3604I

DBP3604I

表（表名）の見出しは既に辞書ファイルに存在します。上書きしますか？

要因
作成した見出し辞書ファイルと同じ内容のファイルがあります。
対処
次のように対処してください。
  • 上書きする場合は，［はい］ボタンをクリックしてください。
  • 上書きしない場合は，［いいえ］ボタンをクリックしてください。


DBP3605W

DBP3605W

見出し辞書ファイルから削除しますか？

要因
指定された見出し辞書ファイルを削除します。
対処
次のように対処してください。
  • 削除する場合は，［はい］ボタンをクリックしてください。
  • 削除しない場合は，［いいえ］ボタンをクリックしてください。


DBP3606E

DBP3606E

EDBWDIC.DLLのロードに失敗しました。

要因
  • EUR 帳票作成機能の場合
    見出し辞書の処理に必要なEDBWDIC.DLLのロードに失敗しました。
    詳細コード | 説明
    02 | 必要なEDBWDIC.DLLがありません。
    08 | EDBWDIC.DLLのロードに必要なメモリがありません。
  • EUR 帳票作成機能（EUR Form帳票）の場合
    見出し辞書の処理に必要なEUDBDIC.DLLのロードに失敗しました。
    詳細コード | 説明
    02 | 必要なEUDBDIC.DLLがありません。
    08 | EUDBDIC.DLLのロードに必要なメモリがありません。
対処
次のように対処してください。
詳細コード | 説明
02 | EUR DesignerまたはEUR Developerを再インストールしたあと，再実行してください。
08 | 不要なアプリケーションを終了したあと，再実行してください。


DBP3607I

DBP3607I

見出し辞書への登録が完了しました。

説明
見出し辞書に，見出し情報が登録されたことを示すメッセージです。


DBP3608I

DBP3608I

見出し辞書の一括登録が完了しました。

説明
見出し辞書の一括登録が完了したことを示すメッセージです。


DBP3609E

DBP3609E

指定された表は見出し辞書ファイル中にないため，列情報が取得できません。

要因
指定された表は，見出し辞書ファイル中に登録されていないため，列情報が取得できません。
対処
次のように対処してください。
  • 列設定，または条件設定をしないで，抽出，または更新用抽出をしてください。
  • 列設定，または条件設定をする場合は，［オプション設定］ダイアログの［見出し辞書］タブで，［見出し辞書］をオフに設定したあと，再実行してください。


DBP3610I

DBP3610I

見出し辞書の一括登録を中止しました。

要因
次に示す要因のため，一括登録処理を中止しました。
  • ［キャンセル］がクリックされました。
  • 登録処理中にエラーが発生しました。
対処
次のように対処してください。
  • ［キャンセル］ボタンがクリックされた場合は，［キャンセル］ボタンがクリックするまでに処理された辞書は登録されています。辞書を削除したい場合は，［見出し選択］ダイアログで指定してください。
  • 登録処理中にエラーが発生した場合は，エラーが発生するまでに処理された辞書は登録されています。辞書を削除したい場合は，［見出し選択］ダイアログで指定してください。


DBP3611I

DBP3611I

表（表名）は既に辞書登録されています。上書きした場合は，現在の表見出し，列見出しを削除します。上書きしますか？

要因
一括作成で選択された表の見出し辞書が，すでにあります。
対処
次のように対処してください。
  • 辞書を上書きする場合は，［はい］ボタンをクリックしてください。
  • 辞書を上書きしない場合は，［いいえ］ボタンをクリックしてください。
  • 一括作成で選択した表をすべて上書きする場合は，［すべて上書き］ボタンをクリックしてください。
  • 辞書の一括作成を中止する場合は，［キャンセル］ボタンをクリックしてください。


DBP3612I

DBP3612I

選択したnnn表について，グループ名をaa…aaに設定します。よろしいですか？

要因
［見出し選択］ダイアログで選択した表数（nnn）のグループ名を，「aa…aa」に設定するかどうかを問い合わせています。
対処
次のように対処してください。
  • グループ名を設定する場合は，［はい］ボタンをクリックしてください。
  • グループ名を設定しない場合は，［いいえ］ボタンをクリックしてください。


DBP3613I

DBP3613I

選択したnnn表のグループ名を削除します。よろしいですか？

要因
［見出し選択］ダイアログで選択した表に設定されているグループ名を削除します。メッセージの「nnn」には選択した表数が表示されます。
対処
次のように対処してください。
  • グループ名を削除する場合は，［はい］ボタンをクリックしてください。
  • グループ名を削除しない場合は，［いいえ］ボタンをクリックしてください。


DBP3614W

DBP3614W

見出し選択画面で表名と表見出しの両方を非表示に設定できません。

要因
辞書一覧表示項目の設定で，表名と表見出しの両方を非表示にできません。
対処
表名，または表見出しのどちらかが「表示」になるように設定してください。


DBP3701W

DBP3701W

可変記号名の指定に誤りがあります。

要因
可変記号名の指定に誤りがあります。次に示す要因が考えられます。
  • 可変記号名の長さが制限を超えています。
  • 使用できない文字が使用されています。
対処
可変記号名の指定を見直したあと，再実行してください。


DBP3702W

DBP3702W

初期値の指定に誤りがあります。

要因
初期値の指定に誤りがあります。次に示す要因が考えられます。
  • 初期値の長さが制限を超えています。
  • 使用できない文字が使用されています。
対処
初期値の指定を見直したあと，再実行してください。


DBP3703W

DBP3703W

実行値の指定に誤りがあります。

要因
実行値の指定に誤りがあります。次に示す要因が考えられます。
  • 実行値の長さが制限を超えています。
  • 使用できない文字が使用されています。
  • 実行値の省略はできません。
対処
実行値の指定を見直したあと，再実行してください。


DBP3704W

DBP3704W

同一可変記号が存在します。

要因
すでに使用されている可変記号が指定されました。
対処
可変記号名を変更したあと，再実行してください。


DBP3706W

DBP3706W

可変記号の総数が255個を超えました。

要因
可変記号の総数が，制限の255個を超えました。
対処
可変記号の総数が255個以下になるように，不要な可変記号を削除したあと，再実行してください。


DBP3904W

DBP3904W

接続先が異なる表は結合できません。

要因
異なる接続先の表を結合しようとしました。
対処
同じ接続先の表を指定したあと，再実行してください。


DBP6000～DBP6999のメッセージ

6.10　DBP6000～DBP6999のメッセージ

＜この節の構成＞
DBP6201W
DBP6202E
DBP6203E
DBP6204E
DBP6205W
DBP6206W
DBP6208E
DBP6215W


DBP6201W

DBP6201W

更新せずに終了します。

要因
データベースアクセス定義ウィンドウの［キャンセル］ボタンをクリックしたときに表示される確認メッセージです。
対処
次のように対処してください。
  • 更新しないで終了する場合は，［OK］ボタンをクリックしてください。
  • データベースアクセス定義ウィンドウの操作に戻る場合は，［キャンセル］ボタンをクリックしてください。


DBP6202E

DBP6202E

表が選択されていません。

要因
  • EUR 帳票作成機能の場合
    表を選択していない状態で，データベースアクセス定義を終了しようとしました。
  • EUR 帳票作成機能（EUR Form帳票）の場合
    表が選択されていない状態で，項目定義を更新しようとしました。
対処
  • EUR 帳票作成機能の場合
    表と列を選択してから，終了してください。
  • EUR 帳票作成機能（EUR Form帳票）の場合
    表と列を選択したあと，項目定義を更新してください。


DBP6203E

DBP6203E

列が選択されていません。

要因
  • EUR 帳票作成機能の場合
    列を選択していない状態で，データベースアクセス定義を終了しようとしました。
  • EUR 帳票作成機能（EUR Form帳票）の場合
    列が選択されていない状態で，項目定義を更新しようとしました。
対処
  • EUR 帳票作成機能の場合
    列を選択してから，終了してください。
  • EUR 帳票作成機能（EUR Form帳票）の場合
    列を選択したあと，項目定義を更新してください。


DBP6204E

DBP6204E

LONG VARBINARYの列は使用できません。

要因
  • EUR 帳票作成機能の場合
    LONG VARBINARYの列を選択した状態で，データベースアクセス定義を終了しようとしました。
  • EUR 帳票作成機能（EUR Form帳票）の場合
    LONG VARBINARYの列を選択した状態で，項目定義を更新しようとしました。
対処
  • EUR 帳票作成機能の場合
    LONG VARBINARYの列を削除してから，終了してください。
  • EUR 帳票作成機能（EUR Form帳票）の場合
    LONG VARBINARYの列を削除したあと，項目定義を更新してください。


DBP6205W

DBP6205W

データベースの接続先名称（データベース名）が現在の接続先と異なるため，設定した内容を回復できません。

要因
接続するデータベース名が，以前に接続していたデータベースと異なります。以前設定した表と列の情報は，回復できません。
対処
以前に接続していたデータベースに接続してください。


DBP6206W

DBP6206W

抽出するデータがありません。現在の設定で終了しますか？

要因
保存終了時に，抽出するデータがありません。
対処
次のように対処してください。
  • 現在の設定で終了する場合は，［はい］ボタンをクリックしてください。
  • 設定を変更する場合は，［いいえ］ボタンをクリックしてください。


DBP6208E

DBP6208E

所有者名，表名，列名のいずれかにSJIS以外のコードが含まれています。

要因
表の選択または列の設定のときに選択した所有者名，表名，または列名にShift JIS以外の文字が含まれています。所有者名，表名，列名にShift JIS以外の文字が含まれている表は使用できません。
対処
次のように対処してください。
  • 所有者名，表名，列名にShift JISだけ使用した表を指定してください。
  • 所有者名，表名，列名をShift JISの文字に変更してください。


DBP6215W

DBP6215W

帳票作成時のデータソース名(aa...aa)と，指定されたデータソース名(bb...bb)が異なります。接続先が異なる場合は，設定したデータベースアクセス定義を使用できない場合があります。設定した定義を使用しますか。

要因
帳票作成時のデータソース名(aa...aa)と，指定されたデータソース名(bb...bb)が異なります。データベースの接続先が異なる場合は，以前に設定したデータベースアクセス定義を使用できないときがあります。
対処
次のように対処してください。
  • 設定した定義を使用する場合は，［はい］ボタンをクリックしてください。
  • 設定した定義を破棄する場合は，［いいえ］ボタンをクリックしてください。


DBP8000～DBP8999のメッセージ

6.11　DBP8000～DBP8999のメッセージ

＜この節の構成＞
DBP8007E


DBP8007E

DBP8007E

（詳細情報）に辞書ファイルとして使用できない文字が含まれています。

要因
詳細情報に入力された文字列に辞書ファイルとして使用できないShift JIS以外の文字が含まれています。
対処
詳細情報に入力する文字列を，Shift JISの文字に変更してください。


DABrokerのメッセージ

7.　DABrokerのメッセージ

データベースとの接続時にDABrokerから出力されるメッセージの意味，およびその対策について説明します。

＜この章の構成＞
7.1　メッセージの出力形式
7.2　メッセージの記載形式
7.3　メッセージの出力先
7.4　KFDB001DB～KFDB999DBのメッセージ
7.5　KFDB001EC～KFDB999ECのメッセージ
7.6　KFDB001LC～KFDB999LCのメッセージ
7.7　KFDB001LM～KFDB999LMのメッセージ
7.8　KFDB001MM～KFDB999MMのメッセージ
7.9　KFDB001NM～KFDB999NMのメッセージ
7.10　KFDB001RC～KFDB999RCのメッセージ
7.11　KFDB001RM～KFDB999RMのメッセージ
7.12　KFDB001RR～KFDB999RRのメッセージ
7.13　KFDB001SC～KFDB999SCのメッセージ
7.14　KFDB001SM～KFDB999SMのメッセージ
7.15　KFDB001TD～KFDB999TDのメッセージ
7.16　KFDB001TM～KFDB999TMのメッセージ
7.17　KFDB001TR～KFDB999TRのメッセージ
7.18　KFDB001YM～KFDB999YMのメッセージ


メッセージの出力形式

7.1　メッセージの出力形式

DABrokerで表示されるメッセージの形式を次に示します。

KFDBxxxxx-y：メッセージ文

メッセージの表示内容を項目ごとに次に示します。

表7-1　 メッセージの表示内容（DABrokerの場合）

形式の項目 | 説明
KFDBxxxxx-y | メッセージIDを示します。 xxxxxは，メッセージ番号を示します。 yは，レベル（I（Information），W（Warning），E（Error），またはQ（question））を示します。
メッセージ文 | メッセージ文を示します。


メッセージの記載形式

7.2　メッセージの記載形式

このマニュアルでのメッセージの記載形式について説明します。

＜この節の構成＞
メッセージID


メッセージID

メッセージID

メッセージ文（エラーコード）

詳細情報
メッセージの詳細情報を示します。
説明
メッセージの説明を示します。
要因
メッセージの要因を示します。
対処
表示されたメッセージに対する対処方法を示します。
対処の参照先
対処するための参照先を示します。
対処時に関係するプロパティ，メソッドおよび関数を示します。
レベル
メッセージのレベルを示します。
終了コード
メッセージIDの終了コードを示します。
注意
対処する場合の注意事項を示します。
補足
メッセージの補足説明を示します。

メッセージ記載形式の各項目の意味を次に示します。

表7-2　 メッセージ記載形式の項目

項目名 | 意味
メッセージID | メッセージIDを示します。メッセージIDがない場合は，メッセージIDの代わりにメッセージ文を示します。
メッセージ文 | メッセージ文を示します。
（エラーコード） | OS上のシステム関数エラーリターン時のerror情報を示します。エラーコードについては，OSのヘッダファイル，またはOSのヘルプファイルを参照してください。
詳細情報 | イベントログ，またはEURで出力するログ（eurpsログなど）に出力される詳細情報を示します。
 | U | 実行ユーザアカウント
 | R | フォームシートファイル名
 | F | 帳票機能名
 | P | ページ番号
 | D | 対象のマッピングデータファイル名，またはユーザ定義データファイル名
 | DI | 入力データ値（正）
 | DO | 欠落などで不正出力となった出力値
 | E | 終了時の終了コード（10進数表示）
 | C | 指定されたコマンド文字列
説明 | メッセージのレベルが「I（Information）」の場合，メッセージの説明をします。
要因 | メッセージが出力された要因を示します。
対処 | メッセージのレベルが「W（Warning）」と「E（Error）」の場合，メッセージの対処を示します。
対処の参照先 | 対処に必要な情報を示します。
レベル | メッセージのレベルを示します。I（Information），W（Warning），およびE（Error）があります。
終了コード | 終了コードを示します。参照先を次に示します。 終了コードは，コマンドの/nomessageオプション（UNIX／Linux環境の場合は-nomessageオプション）が指定されていても設定されます。ただし，終了コードだけでは，エラーの詳細が判別できないため，/messageオプション（UNIX／Linux環境の場合は-messageオプション）を指定して，出力されるメッセージを参照して解析するか，またはログ機能で出力されるエラー情報で調査してください。ログのエラー情報については，マニュアル「EUR システム設計ガイド」を参照してください。
 | 0 | 正常終了しました。
 | 4 | 警告が発生しました。警告が発生する要因については，マニュアル「EUR メッセージ」を参照してください。
 | 8 | システムエラーが発生しました。または，出力でエラーが発生しました。
 | 10 | データベースアクセスでエラーが発生しました。
 | 12 | データエラーが発生しました。
 | 16 | コマンド，メソッドでの設定値，またはプリンタ定義ファイル内で文法エラーがあります。
 | 2008 | ActiveXオブジェクトによる起動で，起動時にシステムエラーが発生しました。
 | 2016 | ActiveXオブジェクトによる起動で，プロパティの指定でエラーが発生しました。
 | 32 | 上記以外のエラーが発生しました。
注意または補足 | メッセージの注意事項，補足情報を示します。


メッセージの出力先

7.3　メッセージの出力先

DABrokerが発行するメッセージは，次のどれかに出力されます。

  • クライアント
  • イベントログ（Windowsのイベントビューア）
  • メッセージログ（DABroker運用ディレクトリ\spool\dabsv.log，およびdabsv.logold）
＜この節の構成＞
(1)　注意事項
(2)　環境変数

(1)　注意事項

  • メッセージログファイルには，サーバまたはクライアントの標準エラー出力に出力されないメッセージも出力されます。ただし，メッセージログファイルには出力されないで，サーバまたはクライアントの標準エラー出力にだけ出力されるメッセージもあります。
  • データベース側で発行されたメッセージについては，各DBMSのマニュアルを参照してください。
  • 可変情報に表示する情報がない場合，「*」を表示することがあります。
  • ファイル名など，可変情報に表示する情報が長い場合，先頭79バイトだけを表示し，残りは切り捨てます。

(2)　環境変数

環境変数とDABroker動作環境定義ファイルの対応を次に示します。

DABroker動作環境定義ファイルおよび項目の詳細については，マニュアル「DABroker」を参照してください。

表7-3　 環境変数とDABroker動作環境定義ファイルの項目対応表

環境変数名 | DABroker動作環境定義ファイルで対応する項目
DABTMP | 作業ディレクトリ
DABSVLOGSIZE | ログファイルサイズ[dabsv.log]
DABSELECTCOLCNT | 表検索カラム数
DABSELECTINFCNT | 更新・検索条件カラム数
DABSQL_TRC_CANCEL | CANCEL（アクセストレースの種類）
DABSQL_TRC_CLOSE | CLOSE（アクセストレースの種類）
DABSQL_TRC_COMMIT | COMMIT（アクセストレースの種類）
DABSQL_TRC_CONNECT | CONNECT（アクセストレースの種類）
DABSQL_TRC_DECLARE | DECLARE（アクセストレースの種類）
DABSQL_TRC_DESCRIBE | DESCRIBE（アクセストレースの種類）
DABSQL_TRC_DISCONNECT | DISCONNECT（アクセストレースの種類）
DABSQL_TRC_EXECUTE | EXECUTE（アクセストレースの種類）
DABSQL_TRC_FETCH | FETCH（アクセストレースの種類）
DABSQL_TRC_PREPARE | PREPARE（アクセストレースの種類）
DABSQL_TRC_ROLLBACK | ROLLBACK（アクセストレースの種類）
DABSQL_TRC_OPEN | OPEN（アクセストレースの種類）
DABSQL_TRC_BIND | BIND（アクセストレースの種類）
DABSQL_TRC_GETDIAG | GETDIAG（アクセストレースの種類）
DABSQL_TRC_AUTO_COMMIT_OFF | AUTO_COMMIT_OFF（アクセストレースの種類）
DABSQL_TRC_AUTO_COMMIT_ON | AUTO_COMMIT_ON（アクセストレースの種類）
DABSQL_TRC_GET_INFO | GET_INFO（アクセストレースの種類）
DABSQL_TRC_SET_INFO | SET_INFO（アクセストレースの種類）
DABSQL_TRC_EXECUTE_DIRECT | EXECUTE_DIRECT（アクセストレースの種類）
DABCLIENT_TIMEOUT | クライアントからの要求待ちタイムアウト
DABMAXUSERS | 最大接続ユーザ数
DABDBANUMBER | 同時実行可能なデータベースアクセス数
DABMAXBLOCKUSERS | 1プロセス当たりの実行ユーザ数
DABMAXPROCESS | 最大処理プロセス数
DABORADBA_LONGBUFSIZE | LONG型データ受取バッファサイズ(ORACLE)


KFDB001DB～KFDB999DBのメッセージ

7.4　KFDB001DB～KFDB999DBのメッセージ

＜この節の構成＞
KFDB001DB-E
KFDB002DB-E
KFDB003DB-E
KFDB004DB-I
KFDB005DB-E
KFDB006DB-E
KFDB007DB-E
KFDB011DB-E
KFDB012DB-E
KFDB013DB-E
KFDB017DB-E
KFDB018DB-E
KFDB019DB-E
KFDB020DB-E
KFDB021DB-E
KFDB024DB-E
KFDB025DB-E
KFDB026DB-E
KFDB030DB-E
KFDB031DB-E
KFDB032DB-E
KFDB040DB-E
KFDB041DB-E
KFDB042DB-E
KFDB043DB-E
KFDB044DB-E
KFDB045DB-E
KFDB051DB-E
KFDB052DB-E
KFDB053DB-E
KFDB054DB-E
KFDB070DB-E
KFDB071DB-E
KFDB101DB-E


KFDB001DB-E

KFDB001DB-E

Required memory cannot be obtained. ErrInfo［XXXX］

XXXX：保守用情報
要因
処理に必要な領域の確保時，メモリ不足が発生しました。
処理
処理を終了します。
対処
実行中の不要なプログラムを終了してから，再実行してください。なお，このメッセージが繰り返し発生する場合は，実メモリ，または仮想メモリの設定を見直してください。


KFDB002DB-E

KFDB002DB-E

RDBMSに対する要求シーケンスが不正です。ErrInfo［XXXX］
The request sequence for the RDBMS is invalid. ErrInfo[XXXX]
XXXX：保守用情報

要因
ユーザからRDBMSに対する要求シーケンスが誤っています。
処理
ユーザからの要求を受け付けません。
対処
RDBMSに対する要求シーケンスを見直してください。


KFDB003DB-E

KFDB003DB-E

システムコールでエラーが発生しました。ErrInfo［XXXX() errno=YYYY］
An error occurred in a system call. ErrInfo[XXXX() errno=YYYY]

XXXX：システムコール名称
YYYY：エラー番号
要因
OSのシステムコール関数でエラーが発生しました。
処理
処理を終了します。
対処
使用するOSのマニュアルを参照しエラー原因を取り除いてから，再実行してください。


KFDB004DB-I

KFDB004DB-I

DBMSに対する処理を中断しました。
DBMS processing was canceled.

要因
DBMSに対する処理を中断しました。
処理
DBMSに対する処理を中断します。
対処
必要に応じて再実行してください。


KFDB005DB-E

KFDB005DB-E

DABrokerでサポートされていないデータ属性がありました。［XXXX］
A data attribute that is not supported by DABroker was found. [XXXX]

XXXX：サポートされていない列属性コード（16進表示）
要因
指定した表列属性（XXXX）は，DABrokerでサポートしていません。
処理
ユーザからの要求を受け付けません。
対処
列属性，またはDABrokerのバージョンを見直してください。また，列属性コードについては接続先のデータベースのマニュアルを参照してください。


KFDB006DB-E

KFDB006DB-E

指定したDBMSと接続したDBMSが異なります。user DBMS=XXXX system DBMS=YYYY nodename=ZZZZ
The specified DBMS differs from the connected DBMS.
user DBMS=XXXX system DBMS=YYYY nodename=ZZZZ

XXXX：ユーザが指定したDBMS
YYYY：DABrokerが接続したDBMS
ZZZZ：RDノード名称
要因
ユーザが指定したDBMSと接続したDBMSが異なります。
処理
ユーザの要求を受け付けません。
対処
接続するDBMSを見直し，指定し直してください。


KFDB007DB-E

KFDB007DB-E

DABrokerでは，繰り返し列，及び配列列を含む表はサポートしていません。
DABroker does not support tables containing multivalue columns and array columns.

要因
DABrokerでは繰り返し列，および配列列を含む表はサポートしていません。
処理
ユーザからの要求を受け付けません。
対処
列属性を修正し，ユーザからの要求を再実行してください。


KFDB011DB-E

KFDB011DB-E

接続しているDBMSでエラーが発生しました。nodename=XXXX SQLCODE=YYYY Info=[ZZZZ]
An error occurred in the connected DBMS. nodename=XXXX SQLCODE=YYYY Info=[ZZZZ]

XXXX：RDノード名称
YYYY：接続しているDBMSのSQLコード
ZZZZ：接続しているDBMSのSQLコードに対する付加情報（付加情報がない場合は出力されません）。
要因
接続しているDBMSでエラーが発生しました。
処理
ユーザからの要求を受け付けません。
対処
接続しているDBMSのマニュアルを参照してください。


KFDB012DB-E

KFDB012DB-E

接続しているDBMSでエラーが発生しました。
nodename=XXXX SQLCODE=YYYY IPADDR=ZZZZ
An error occurred in the connected DBMS. nodename=XXXX SQLCODE=YYYY IPADDR=ZZZZ

XXXX：RDノード名称
YYYY：接続しているDBMSのSQLコード
ZZZZ：IPアドレスまたはホスト名
要因
接続しているDBMSでエラーが発生しました。
処理
ユーザからの要求を受け付けません。
対処
接続しているDBMSのマニュアルを参照してください。


KFDB013DB-E

KFDB013DB-E

ユーザが指定した，認可識別子，パスワード，又はDBMS情報のどれかが32バイトを超えています。
The permission identifier, password or DBMS information specified by the user exceeded 32 bytes.

要因
ユーザが指定した，認可識別子，パスワード，またはDBMS情報のどれかが32バイトを超えています。
処理
ユーザからの要求を受け付けません。
対処
認可識別子，パスワード，またはDBMS情報の文字列の長さを確認し，制限バイト以内になるように指定し直してください。


KFDB017DB-E

KFDB017DB-E

表属性の指定が誤っています。ErrInfo［XXXX］
The specified table attribute is incorrect. ErrInfo[XXXX]

XXXX：エラーコード
要因
表属性の指定が誤っています。
処理
ユーザからの要求を受け付けません。
対処
表属性を正しく指定してから，再実行してください。
なお，出力されたエラーコードによって次の内容を見直してください。
  • エラーコードが1の場合
    表属性の前後が`で囲まれているか確認してください。
  • エラーコードが2の場合
    指定されている表属性が誤っていないか確認してください。
  • エラーコードが3の場合
    複数の表属性を指定した場合の区切り文字を確認してください。


KFDB018DB-E

KFDB018DB-E

入力パラメタの指定が誤っています。ErrInfo［XXXX，YYYY，ZZZZ］
The specified input parameter is incorrect. ErrInfo［XXXX，YYYY，ZZZZ］

XXXX：入力パラメタの行番号
YYYY：入力パラメタの列番号
ZZZZ：エラー項目名
要因
入力パラメタの指定が誤っています。
処理
ユーザからの要求を受け付けません。
対処
入力パラメタを正しく指定してから，再実行してください。


KFDB019DB-E

KFDB019DB-E

出力パラメタの指定が誤っています。ErrInfo［XXXX，YYYY］
The specified output parameter is incorrect. ErrInfo[XXXX, YYYY]

XXXX：出力パラメタの列番号
YYYY：エラー項目名
要因
出力パラメタの指定が誤っています。
処理
ユーザからの要求を受け付けません。
対処
出力パラメタを正しく指定してから，再実行してください。


KFDB020DB-E

KFDB020DB-E

DBMSのバージョンが違います。ErrInfo［XXXX］
Incorrect version of the DBMS. ErrInfo[XXXX]

XXXX：保守用情報
要因
DBMSは接続できるバージョンではありません。
処理
ユーザからの要求を受け付けません。
対処
システム管理者にDBMSのバージョンを確認してください。


KFDB021DB-E

KFDB021DB-E

複数SQL実行の指定が誤っています。ErrInfo［XXXX，YYYY］
The specified multiple SQL execution is incorrect. ErrInfo[XXXX,YYYY]

XXXX：SQL番号
YYYY：詳細コード
要因
複数SQL実行の指定が誤っています。
処理
ユーザからの要求を受け付けません。
対処
複数SQL実行を正しく指定してから，再実行してください。


KFDB024DB-E

KFDB024DB-E

接続しているDBMSの制限のため，？パラメタでNULLを指定できません。［XXXX］
You cannot specify NULL in the ? parameter because of a limit of the connected DBMS. [XXXX]

XXXX：NULLが指定された？パラメタの位置
要因
？パラメタにNULLが指定されました。
処理
ユーザからの要求を受け付けません。
対処
？パラメタを見直して再実行してください。


KFDB025DB-E

KFDB025DB-E

HiRDB または ORACLEに対する接続環境が整っていません。エラーコード=XXXX
Not prepared to connect to HiRDB or ORACLE. Error code=XXXX

XXXX：保守コード
DBMSがORACLEの場合，次のOCI関数名を表示します。
-1：xaoEnv
-2：xaoSvcCtx
-3：OCIHandleAlloc
-4：OCISvcCtxToLda
要因
次のどれかの要因が考えられます。
  1. OTSの初期化が完了していない。
  2. HiRDBがTPBroker(OTS)に登録されていない。
  3. DABroker for C++ を使用したUAPを利用している場合，DBRDatabaseクラスのConnectメソッドの引数lpctDBNに指定したxa_open文字列のDBフィールドで指定するデータベース名が誤っている。
処理
ユーザからの要求を受け付けません。
対処
  1. OTSの初期化完了前にDABrokerにアクセスを要求している可能性があります。アプリケーションを確認してください。OTSの初期化については，接続するデータベースのマニュアルを参照してください。
  2. TPBrokerにHiRDBを登録しているかを確認してください。TPBrokerへのHiRDBの登録については，TPBrokerおよびHiRDBのマニュアルを参照してください。
  3. DABroker for C++ を使用したUAPを利用した場合，DBRDatabaseクラスのConnectメソッドの引数lpctDBNに指定したxa_open文字列のDBフィールドで指定するデータベース名を見直してください。


KFDB026DB-E

KFDB026DB-E

ORACLEのOCI関数でエラーが発生しました。関数名=XXXX リターンコード=YYYY
The error occurred by the OCI function of ORACLE. Function name=XXXX return code=YYYY

XXXX：OCI関数名
YYYY：OCI関数のリターンコード
要因
OCI関数XXXXでエラーが発生しました。
処理
ユーザからの要求を受け付けません。
対処
Oracleのドキュメントを参照してください。


KFDB030DB-E

KFDB030DB-E

ODBC接続でエラーが発生しました。
DATASOURCE NAME=WWWW　SQL CODE=XXXX SQLSTATE=YYYY　MESSAGE TEXT=ZZZZ
An error occurred in an ODBC access. DATASOURCE NAME=WWWW SQL CODE=XXXX SQLSTATE=YYYY MESSAGE TEXT=ZZZZ

WWWW：接続データソース名
XXXX：SQLコード，またはDABrokerの保守用情報
YYYY：SQLSTATE
ZZZZ：メッセージテキスト（エラー発生システムのエラーメッセージ）
要因
ODBCで障害が発生しました。
処理
ユーザからの要求を受け付けません。
対処
接続しているDBMSのマニュアルを参照してください。


KFDB031DB-E

KFDB031DB-E

ODBC接続でエラーが発生しました。
SQL CODE=XXXX　SQLSTATE=YYYY　MESSAGE TEXT=ZZZZ
An error occurred in an ODBC access.
SQL CODE=XXXX SQLSTATE=YYYY MESSAGE TEXT=ZZZZ

XXXX：SQLコード，またはDABrokerの保守用情報
YYYY：SQLSTATE
ZZZZ：メッセージテキスト（エラー発生システムのエラーメッセージ）
要因
ODBCで障害が発生しました。
処理
ユーザからの要求を受け付けません。
対処
接続しているDBMSのマニュアルを参照してください。


KFDB032DB-E

KFDB032DB-E

ODBC接続で要求パラメタが不正です。ErrInfo=XXXX
A request parameter is invalid for ODBC access. ErrInfo=XXXX

XXXX：保守用情報
要因
ODBCでパラメタが誤っています。
処理
ユーザからの要求を受け付けません。
対処
保守員に連絡してください。


KFDB040DB-E

KFDB040DB-E

DABroker ODBC接続でエラーが発生しました。
DATASOURCE NAME=WWWW SQL CODE=XXXX SQLSTATE=YYYY
MESSAGE TEXT=ZZZZ
An error occurred in a DABroker ODBC access.
DATASOURCE NAME=WWWW SQL CODE=XXXX SQLSTATE=YYYY
MESSAGE TEXT=ZZZZ

WWWW：接続データソース名
XXXX：SQLコード，またはDABrokerの保守用情報
YYYY：SQLSTATE
ZZZZ：メッセージテキスト（エラー発生システムのエラーメッセージ）
要因
DABroker ODBCで障害が発生しました。
処理
ユーザからの要求を受け付けません。
対処
接続しているDBMSのマニュアルを参照してください。


KFDB041DB-E

KFDB041DB-E

DABroker ODBC接続でエラーが発生しました。
SQL CODE=XXXX SQLSTATE=YYYY MESSAGE TEXT=ZZZZ
An error occurred in a DABroker ODBC access.
SQL CODE=XXXX SQLSTATE=YYYY MESSAGE TEXT=ZZZZ

XXXX：SQLコード，またはDABrokerの保守用情報
YYYY：SQLSTATE
ZZZZ：メッセージテキスト（エラー発生システムのエラーメッセージ）
要因
DABroker ODBCで障害が発生しました。
処理
ユーザからの要求を受け付けません。
対処
接続しているDBMSのマニュアルを参照してください。


KFDB042DB-E

KFDB042DB-E

DABroker　ODBC接続で要求パラメタが不正です。
ErrInfo=XXXX
A request parameter is invalid for DABroker ODBC access.
ErrInfo=XXXX

XXXX：保守用情報
要因
DABroker ODBC接続でパラメタが誤っています。
処理
ユーザからの要求を受け付けません。
対処
保守員に連絡してください。


KFDB043DB-E

KFDB043DB-E

接続した ODBC Driverのバージョンは未サポートです。[XXXX]
DABroker does not support the ODBC Driver version.[XXXX]
XXXX:ODBC Driverのバージョン

要因
接続したODBC Driverはサポートされていないバージョンです。
処理
ユーザからの要求を受け付けません。
対処
ODBC Driverのバージョンを確認してください。


KFDB044DB-E

KFDB044DB-E

接続したDBMSは未サポートです。[XXXX]
DABroker does not support the DBMS. [XXXX]

XXXX：保守用情報
要因
接続したDBMSはサポートしていません。
処理
ユーザからの要求を受け付けません。
対処
接続したDBMSを見直し，指定し直してください。


KFDB045DB-E

KFDB045DB-E

指定したDBMSと接続したDBMSが異なります。
user DBMS=XXXX system DBMS=YYYY
The specified DBMS differs from the connected DBMS.
user DBMS=XXXX system DBMS=YYYY

XXXX：ユーザが指定したDBMS
YYYY：DABrokerが接続したDBMS
要因
ユーザが指定したDBMSと接続したDBMSが異なります。
処理
ユーザからの要求を受け付けません。
対処
接続するDBMSを見直し，指定し直してください。


KFDB051DB-E

KFDB051DB-E

接続したサーバーシステムはサポートしていません。[XXXX,YYYY]
DABroker does not support the connected server system. [XXXX,YYYY]

XXXX：接続サーバ名
YYYY：保守用情報
要因
接続しようとしたサーバシステムはサポートしていません。
処理
ユーザからの要求を受け付けません。
対処
接続するDBMSを見直し，指定し直してください。


KFDB052DB-E

KFDB052DB-E

接続したサーバーシステムでシステムエラーが発生しました。[XXXX]
A system error occurred in the connected server system. [XXXX]

XXXX：保守用情報
要因
接続したサーバシステムでエラーが発生しました。
処理
ユーザからの要求を受け付けません。
対処
接続したDBMSを見直し，指定し直してください。


KFDB053DB-E

KFDB053DB-E

DABroker DBMSドライバでシステムエラーが発生しました。[XXXX]
A system error occurred in the DABroker DBMS driver. [XXXX]

XXXX：保守用情報
要因
DBMSドライバでエラーが発生しました。
処理
ユーザからの要求を受け付けません。
対処
接続するDBMSを見直し，指定し直してください。


KFDB054DB-E

KFDB054DB-E

タイムオーバのため処理を中断しました。
Processing was canceled because a timeover occurred.

要因
タイムアウトが発生しました。
処理
ユーザからの要求を受け付けません。
対処
再実行してください。なお，このエラーが繰り返し発生する場合は，データベースアクセス処理終了待ちタイムアウト（DABDBA_TIMEOUT）の値を大きくしてください。


KFDB070DB-E

KFDB070DB-E

配列の要素に，異なるデータ型があります。[XXXX]
There is a data type which is different in element of arrangement.[XXXX]

XXXX：エラーの原因となったパラメタインデックス
要因
HiRDBの配列インサート機能使用時，配列に指定するデータ型が一致していません。
処理
ユーザからの要求を受け付けません。
対処
配列に指定するデータ型をすべて同じにして，再実行してください。


KFDB071DB-E

KFDB071DB-E

セットされたデータのサイズが，文字データ型の有効範囲を超えています。[XXXX]
The size of data is over the effective range of character data.[xxxx]

XXXX：エラーの原因となったパラメタインデックス
要因
？パラメタにセットされた文字データのサイズが，文字データ型サイズの有効範囲を超えています。
処理
クライアントからの要求を受け付けません。
対処
？パラメタにセットしたデータのサイズを確認し，再実行してください。


KFDB101DB-E

KFDB101DB-E

メモリが不足しているため，処理に必要な領域を確保できません。
Memory is insufficient for processing.

要因
処理に必要な領域の確保時に，メモリ不足が発生しました。
処理
処理を終了します。
対処
実行中のほかの処理を終了してから，再実行してください。


KFDB001EC～KFDB999ECのメッセージ

7.5　KFDB001EC～KFDB999ECのメッセージ

＜この節の構成＞
KFDB002EC-E
KFDB008EC-E
KFDB012EC-E
KFDB013EC-E
KFDB014EC-E
KFDB015EC-E
KFDB016EC-E
KFDB017EC-E


KFDB002EC-E

KFDB002EC-E

DABrokerは起動していません。
DABroker is not running.

要因
DABrokerを終了しようとしましたが，起動していません。
処理
処理を終了します。


KFDB008EC-E

KFDB008EC-E

DABrokerを終了する権限がありません。
The user does not have authorization to stop DABroker.

要因
DABrokerを終了しようとしたユーザがAdministratorsグループに属していないため，終了できません。
処理
処理を終了します。
対処
DABrokerはAdministratorsグループに属しているユーザで終了してください。


KFDB012EC-E

KFDB012EC-E

DABrokerは起動処理中です。
DABroker is starting.

要因
DABrokerを終了しようとしましたが，起動処理が完了していません。
処理
処理を終了します。
対処
しばらく時間を空けてから，再実行してください。


KFDB013EC-E

KFDB013EC-E

DABrokerは終了処理中です。
DABroker is terminating.

要因
DABrokerを終了しようとしましたが，終了処理中です。
処理
処理を終了します。


KFDB014EC-E

KFDB014EC-E

DABrokerは計画終了処理中です。
DABroker is terminating in the planned termination mode.

要因
DABrokerを終了しようとしましたが，計画終了処理中です。
処理
処理を終了します。


KFDB015EC-E

KFDB015EC-E

DABrokerは強制終了処理中です。
DABroker is terminating in the forced termination mode.

要因
DABrokerを終了しようとしましたが，強制終了処理中です。
処理
処理を終了します。


KFDB016EC-E

KFDB016EC-E

実行中の処理があるため，終了できません。
DABroker cannot terminate because of current processing.

要因
DABrokerを通常終了しようとしましたが，接続中のクライアントがあるため，DABrokerを終了できません。
処理
処理を終了します。
対処
次に示すどちらかの対処をしてください。
  • 実行中の処理，およびすべてのクライアントが終了してから，通常終了※1してください。
  • 強制終了※2，または計画終了※3してください。
注※1
［DABroker終了］ダイアログで通常終了を選択します。
注※2
［DABroker終了］ダイアログで強制終了を選択します。または，サービスを停止させます。
注※3
［DABroker終了］ダイアログで計画終了を選択します。


KFDB017EC-E

KFDB017EC-E

指定したクライアントの処理はありません。
The specified client processing was not found.

要因
クライアントの処理を中断しようとしましたが，該当する処理※1はありませんでした。
注※1
［DABroker管理］ウィンドウで選択されたクライアントの処理です。
処理
処理を終了します。
対処
クライアントの処理状態※2を確認してください。
注※2
DABroker管理ユティリティを使用して確認してください。


KFDB001LC～KFDB999LCのメッセージ

7.6　KFDB001LC～KFDB999LCのメッセージ

＜この節の構成＞
KFDB003LC-E
KFDB005LC-E


KFDB003LC-E

KFDB003LC-E

ユティリティの実行中にメモリ不足が発生しました。
Memory became insufficient during execution of a utility program.

要因
ユティリティの実行中にメモリ不足が発生しました。
処理
処理を終了します。
対処
しばらく時間を空けてから，再実行してください。なお，このエラーが繰り返し発生する場合は，システム管理者に連絡してください。


KFDB005LC-E

KFDB005LC-E

指定されたIPアドレス又はホスト名のクライアントとの通信トレースは見つかりません。
Communication information with the specified IP address or host name cannot be traced.

要因
指定したIPアドレス，またはホスト名のクライアントとの通信トレースが見つかりません。
処理
処理を終了します。
対処
指定したIPアドレスまたはホスト名を確認してください。


KFDB001LM～KFDB999LMのメッセージ

7.7　KFDB001LM～KFDB999LMのメッセージ

＜この節の構成＞
KFDB001LM-E


KFDB001LM-E

KFDB001LM-E

システムコールでエラーが発生しました。［XXXX()error=YYYY］
An error occurred in a system call. [XXXX() errno=YYYY]

XXXX：システムコール名称
YYYY：エラー番号
要因
OSのシステムコール関数でエラーが発生しました。
処理
処理を終了します。
対処
操作を再実行してください。なお，このエラーが繰り返し発生する場合は，システム管理者に連絡してください。


KFDB001MM～KFDB999MMのメッセージ

7.8　KFDB001MM～KFDB999MMのメッセージ

＜この節の構成＞
KFDB001MM-E
KFDB002MM-E
KFDB003MM-E
KFDB004MM-E
KFDB005MM-E
KFDB006MM-E
KFDB009MM-E
KFDB011MM-E
KFDB019MM-E
KFDB020MM-E


KFDB001MM-E

KFDB001MM-E

動作環境定義ファイルが存在しません。［XXXX］
The DABroker environment definition file was not found. [XXXX]

XXXX：DABroker動作環境定義ファイル名称
要因
DABroker動作環境定義ファイルが，DABroker運用ディレクトリ\confに存在しません。
処理
DABrokerを終了します。
対処
DABroker動作環境定義ファイルを作成してください。


KFDB002MM-E

KFDB002MM-E

動作環境定義に誤りがあります。［XXXX］
The environment definition is incorrect. [XXXX]

XXXX：環境変数名
要因
次のどちらかが考えられます。
  • DABroker動作環境定義ファイルに設定した環境変数の値に誤りがあります。
  • ユーザが設定した環境変数の値に誤りがあります。
処理
処理を終了します。
対処
次に示すどちらかの対処をしてから，再実行してください。
  • テキストエディタを使用して，DABroker動作環境定義ファイルの環境変数の値を修正してください。
  • ユーザが設定した環境変数の値を修正してください。


KFDB003MM-E

KFDB003MM-E

動作環境定義に誤りがあります。LINE=XXXX［YYYY］
The environment definition is incorrect. LINE=XXXX [YYYY]

XXXX：エラー発生行
YYYY：エラー発生定義
要因
  • DABroker動作環境定義ファイルの構文に誤りがあります。
  • DABroker動作環境定義ファイルに設定した環境変数の値に誤りがあります。
処理
処理を終了します。
対処
テキストエディタを使用して，DABroker動作環境定義ファイルを修正してください。


KFDB004MM-E

KFDB004MM-E

DABroker is not installed.

要因
DABrokerがインストールされていません。DABrokerのインストール環境が不正です。
処理
処理を中断します。
対処
DABrokerを再インストールしてください。


KFDB005MM-E

KFDB005MM-E

システムコールでエラーが発生しました。［XXXX errno=YYYY］
An error occurred in a system call. [XXXX errno=YYYY]

XXXX：エラー発生関数の名称
YYYY：エラー番号
要因
XXXX関数でエラーが発生しました。
処理
処理を中断します。
対処
使用するOSのマニュアルを参照しエラー原因を取り除いてから，再実行してください。


KFDB006MM-E

KFDB006MM-E

System call error occured. [XXXX errno=YYYY]

XXXX：エラー発生関数の名称
YYYY：エラー番号
要因
XXXX関数でエラーが発生しました。
処理
処理を終了します。
対処
使用するOSのマニュアルを参照しエラー原因を取り除いてから，再実行してください。


KFDB009MM-E

KFDB009MM-E

メモリを確保できませんでした。XXXX
Required memory cannot be obtained. XXXX

XXXX：確保しようとしたメモリのサイズ，またはメモリ不足でエラーとなったシステムコール名称
要因
DABrokerの動作に必要なメモリが不足しています。
処理
DABrokerを終了します。
対処
しばらく時間を空けてから，再実行してください。なお，このエラーが繰り返し発生する場合は，システム管理者に連絡してください。


KFDB011MM-E

KFDB011MM-E

動作環境定義ファイルに対するアクセス権限が有りません。［XXXX］
The user does not have authority to access the environment definition file. [XXXX]

XXXX：DABroker動作環境定義ファイル名称
要因
DABroker動作環境定義ファイルに対するアクセス権限がありません。
処理
処理を終了します。
対処
DABroker動作環境定義ファイルに読み込み権限があるかどうか調べてください。読み込み権限がなければ，読み込み権限を付加してください。


KFDB019MM-E

KFDB019MM-E

ディレクトリが存在しません。ディフォルトディレクトリを使用します。［XXXX］
The directory was not found. DABroker will use the default directory. [XXXX]

XXXX：環境変数名
要因
次の要因が考えられます。
  • DABroker動作環境定義ファイルで環境変数に設定したディレクトリが存在しないか，使用できません。
  • ユーザが環境変数に設定したディレクトリが存在しないか，使用できません。
処理
環境変数に指定したディレクトリを無視して，デフォルトのディレクトリを使用します。
対処
次に示すどれかの対処をしてから，再実行してください。
  • 環境変数に設定したディレクトリを作成してください。
  • テキストエディタなどを使用して，DABroker動作環境定義ファイルの環境変数の値を修正してください。
  • ユーザが設定した環境変数の値を修正してください。
  • DABroker環境設定ユティリティを使用して，正しいディレクトリを指定してください。


KFDB020MM-E

KFDB020MM-E

ディレクトリが存在しません。［XXXX］
The directory was not found. [XXXX]

XXXX：環境変数名
要因
次の要因が考えられます。
  • DABroker動作環境定義ファイルで環境変数に設定したディレクトリが存在しないか，使用できません。
  • ユーザが環境変数に設定したディレクトリが存在しないか，使用できません。
処理
処理を終了します。
対策
次に示すどれかの対処をしてから，再実行してください。
  • 環境変数に設定したディレクトリを作成してください。
  • テキストエディタなどを使用して，DABroker動作環境定義ファイルの環境変数の値を修正してください。
  • ユーザが設定した環境変数の値を修正してください。


KFDB001NM～KFDB999NMのメッセージ

7.9　KFDB001NM～KFDB999NMのメッセージ

＜この節の構成＞
KFDB001NM-E
KFDB002NM-E
KFDB003NM-E
KFDB004NM-E
KFDB005NM-E
KFDB101NM-E
KFDB102NM-E
KFDB103NM-I
KFDB104NM-Q
KFDB105NM-E
KFDB201NM-E
KFDB202NM-E
KFDB203NM-Q
KFDB204NM-E
KFDB205NM-E
KFDB206NM-E
KFDB207NM-E
KFDB211NM-E
KFDB213NM-E
KFDB214NM-E
KFDB215NM-E
KFDB216NM-W
KFDB250NM-I
KFDB251NM-I
KFDB252NM-E
KFDB253NM-E


KFDB001NM-E

KFDB001NM-E

システムコールでエラーが発生しました。（エラー関数：XXXX，エラーコード：YYYY）
An error occurred in a system call. (Error function:XXXX, error code:YYYY)

XXXX：エラー発生関数名
YYYY：GetLastError関数で返ってきたエラーコード
要因
システムコールでエラーが発生しました。
処理
処理を終了します。
対処
Windowsをシャットダウンさせて再実行してください。なお，このエラーが繰り返し発生する場合は，保守員に連絡してください。


KFDB002NM-E

KFDB002NM-E

DABrokerの実行中に異常が発生しました。DABrokerを終了します。(ファイル名：XXXX，行番号：YYYY）
An abnormality occurred during DABroker processing. DABroker terminates.
(File name:XXXX, Line number:YYYY)

XXXX：エラーが発生したソースファイル
YYYY：エラーが発生した行番号
要因
DABroker実行中に異常が発生しました。
処理
処理を終了します。
対処
保守員に連絡してください。


KFDB003NM-E

KFDB003NM-E

DABrokerの実行中にメモリ不足が発生しました。
Memory became insufficient during DABroker processing.

要因
DABrokerの実行中にメモリ不足が発生しました。
処理
処理を終了します。
対処
ほかのアプリケーションプログラムを終了して，再実行してください。


KFDB004NM-E

KFDB004NM-E

動作環境が不正です。DABrokerをインストールし直してください。
The environment is incorrect. Re-install DABroker.

要因
次の原因が考えられます。
  • インストールが正しく完了していません。
  • 環境変数（レジストリ）の設定が不正です。
  • DABrokerのファイルがありません。
  • DABrokerのファイルが壊れています。
処理
処理を終了します。
対処
イベントログ（アプリケーション）にほかのメッセージが出力されている場合は，出力されているエラーメッセージを参照してください。
DABrokerをインストールし直して，再実行してください。


KFDB005NM-E

KFDB005NM-E

DABrokerの初期化中にエラーが発生しました。
An error occurred during DABroker initialization processing.

要因
DABrokerの初期化処理でエラーが発生しました。
処理
処理を終了します。
対処
次に示すどれかの対処をしてから，再実行してください。
  • イベントログ（アプリケーション）にほかのメッセージが出力されている場合は，出力されているエラーメッセージを参照してください。
  • ログファイル（dabsv.log）にほかのメッセージが出力されている場合は，出力されているエラーメッセージを参照してください。
  • 定義エラーに対処できない場合は，該当する定義ファイルを削除してください。


KFDB101NM-E

KFDB101NM-E

サービス制御処理中にエラーが発生しました。（エラーコード１：XXXX，エラーコード２：YYYY）
An error occurred during service controlled processing. (Error code 1:XXXX, error code 2:YYYY)

XXXX：エラー発生関数種別
YYYY：GetLastError関数で返ってきたエラーコード
要因
サービス制御処理中にエラーが発生しました。
処理
処理を終了します。
対処
次に示す方法で対処できない場合は，Windowsをシャットダウンさせて再実行してください。なお，このエラーが繰り返し発生する場合は，保守員に連絡してください。
  • イベントログ（アプリケーション），またはメッセージログにほかのメッセージが出力されている場合は，出力されているエラーメッセージを参照してください。
  • 定義エラーに対処できない場合は，該当する定義ファイルを削除してください。
  • DABrokerをインストールし直して，再実行してください。


KFDB102NM-E

KFDB102NM-E

サービス制御処理中にメモリ不足が発生しました。
Memory became insufficient during service controlled processing.

要因
サービス制御処理中にメモリ不足が発生しました。
処理
DABrokerのサービス制御処理を終了します。
対処
ほかのアプリケーションプログラムの終了などによって，動作環境のメモリを確保してから，再実行してください。


KFDB103NM-I

KFDB103NM-I

DABrokerサービスを開始しました。
DABroker service has started.

要因
DABrokerサービスを開始し，DABrokerを起動しました。
処理
DABrokerサービスを起動しました。


KFDB104NM-Q

KFDB104NM-Q

DABrokerサービスを停止してもよろしいですか？
Do you want to terminate the DABroker service?

要因
DABrokerサービスを停止し，DABrokerを終了しようとしました。
処理
ユーザの応答を待ちます。
対処
DABrokerを停止する場合は［はい］ボタンを，停止しない場合は［いいえ］ボタンを選択してください。


KFDB105NM-E

KFDB105NM-E

DABrokerサービスの情報が誤っているため起動できません。（エラーコード：XXXX）
DABroker cannot start because a DABroker service parameter is invalid. (Error code:XXXX)

XXXX：GetLastError関数で返ってきたエラーコード
要因
DABrokerサービスを開始しようとしましたが，DABrokerサービスの情報が誤っていたためエラーが発生しました。
処理
処理を終了します。
対処
DABrokerをインストールし直してください。その後，再実行してください。


KFDB201NM-E

KFDB201NM-E

ディレクトリが正しくありません。
The directory is invalid.

要因
次の原因が考えられます。
  • ディレクトリ名の指定に誤りがある
  • 存在しないディレクトリが指定されている
処理
処理を終了します。
対処
ディレクトリ名を正しく指定して，再実行してください。


KFDB202NM-E

KFDB202NM-E

範囲外の数値データが入力されました。
The entered numerical data is outside the range.

要因
次の原因が考えられます。
  • 数値データ以外の文字が入力された
  • 全角文字が入力された
  • 指定できる範囲外の数値データ入力された
処理
処理を終了します。
対処
指定できるデータの範囲を確認してから，データを再入力してください。


KFDB203NM-Q

KFDB203NM-Q

クライアントの処理を中断します。IPアドレス：XXXX，ホスト名：YYYY
The client processing was canceled. IP address:XXXX host name:YYYY

XXXX：中断するクライアント処理のIPアドレス
YYYY：中断するクライアント処理のホスト名
要因
クライアントプロセスを管理ユティリティで中断しようとしました。
処理
ユーザの応答を待ちます。
対処
クライアントプロセスを中断する場合は［はい］ボタンを，中断しない場合は［いいえ］ボタンを選択してください。


KFDB204NM-E

KFDB204NM-E

レジストリ名XXXXの値が長過ぎます。
The registry name XXXX is too long.

XXXX：レジストリの値の名前
要因
レジストリ名XXXXの値の文字列長が1,024バイトを超えました。
処理
処理を終了します。
対処
レジストリエディタで，レジストリ名XXXXの値の文字列を1,024バイト以下に設定してください。


KFDB205NM-E

KFDB205NM-E

レジストリ名XXXXで，DABrokerがサポートしているデータタイプと異なるデータタイプが取得されました。
DABroker found a non-supported data type in the registry name XXXX.

XXXX：レジストリの値の名前
要因
レジストリ名XXXXにDABrokerがサポートしているデータタイプと異なるデータタイプが指定されました。
処理
処理を終了します。
対処
レジストリエディタでデータを修正してください。


KFDB206NM-E

KFDB206NM-E

レジストリ名XXXXの値の取得に失敗しました。（エラー関数：YYYY，エラーコード：ZZZZ）
DABroker failed to get the value of registry name XXXX.
(Error function:YYYY, error code:ZZZZ)

XXXX：レジストリの値の名前
YYYY：エラー関数名
ZZZZ：GetLastError関数に返されたエラーコード
要因
次の原因が考えられます。
  • レジストリが破壊された
  • DABroker，またはユティリティの稼働環境が不安定になった
  • DABroker，またはユティリティが破壊された
  • レジストリの読み取り権限がない
処理
処理を終了します。
対処
次に示す方法で対処できない場合は，Windowsを再起動するか，またはDABrokerをインストールし直してください。
  • DABroker，またはユティリティを一度終了して，操作を再実行してください。
  • レジストリに読み取り権限を付与してください。


KFDB207NM-E

KFDB207NM-E

レジストリ名XXXXの値の更新に失敗しました。（エラー関数：YYYY，エラーコード：ZZZZ）
DABroker failed to update the value of registry name XXXX. (Error function:YYYY, error code:ZZZZ)

XXXX：レジストリの値の名前
YYYY：エラー関数名
ZZZZ：GetLastError関数に返されたエラーコード
要因
次の原因が考えられます。
  • レジストリが破壊された
  • DABroker，またはユティリティの稼働環境が不安定になった
  • DABroker，またはユティリティが破壊された
  • レジストリに書き込み権限がない
処理
処理を続行します。
対処
次に示す方法で対処できない場合は，Windowsを再起動するか，またはDABrokerをインストールし直してください。
  • DABroker，またはユティリティを一度終了して，操作を再実行してください。
  • レジストリに書き込み権限を付与してください。


KFDB211NM-E

KFDB211NM-E

DABrokerが起動中のため，動作環境定義の更新はできません。
An environment definition cannot be updated because DABroker is running.

要因
環境設定ユティリティで，DABrokerの動作環境を更新しようとしましたが，DABrokerが起動中のためできませんでした。
処理
処理を終了します。
対処
DABrokerを終了してから，再実行してください。


KFDB213NM-E

KFDB213NM-E

環境設定ユティリティを実行する権限がありません。
The user does not have authority to execute the environment setting utility.

要因
環境設定ユティリティを実行したユーザがAdministratorsグループに属していないため，実行できません。
処理
処理を終了します。
対処
環境設定ユティリティは，Administratorsグループに属しているユーザが実行してください。


KFDB214NM-E

KFDB214NM-E

取得する情報の種類が指定されていません。
The type of information to be acquired is not specified.

要因
データベースアクセストレースの取得が指示されましたが，取得する情報の種類が一つも指定されていません。
処理
［設定値変更］ダイアログを再表示し，ユーザの操作を待ちます。
対処
取得する情報の種類を一つ以上指定するか，［アクセストレースを取得する］チェックボックスをオフにして，再実行してください。


KFDB215NM-E

KFDB215NM-E

DABrokerが起動中のため，更新できません。
Cannot update because DABroker is running.

要因
DABrokerの定義を更新しようとしましたが，DABrokerが起動中のため更新できませんでした。
処理
処理を終了します。
対処
DABrokerを終了してから，再実行してください。


KFDB216NM-W

KFDB216NM-W

DABrokerが起動中のため，更新できません。
Cannot update because DABroker is running.

要因
DABrokerの定義を更新しようとしましたが，DABrokerが起動中のためできませんでした。
処理
読み取り専用モードで実行します。
対処
DABrokerを終了してから，再実行してください。


KFDB250NM-I

KFDB250NM-I

トレースを出力しました。
The trace has been output.

要因
トレース出力ユティリティで指定したファイルにトレースを出力しました。
処理
処理を続行します。


KFDB251NM-I

KFDB251NM-I

出力するトレースがありません。
The trace to be output was not found.

要因
出力を要求された種別のトレースが1件も取得されていません。
処理
処理を続行します。


KFDB252NM-E

KFDB252NM-E

通信トレースの出力処理中にエラーが発生しました。
An error occurred during output processing for the communication-trace.

要因
次の原因が考えられます。
  • 出力先のディスクに十分な容量がない
  • 出力先のディスクに書き込む権限がない
  • 出力先のディスクが書き込み禁止である
  • 出力先のファイル指定に誤りがある
処理
処理を終了します。
対処
出力先のディスク，ファイル，およびファイルの指定を確認し，再実行してください。


KFDB253NM-E

KFDB253NM-E

アクセストレースの出力処理中にエラーが発生しました。
An error occurred during output processing for the access-trace.

要因
次の原因が考えられます。
  • 出力先のディスクに十分な容量がない
  • 出力先のディスクに書き込む権限がない
  • 出力先のディスクが書き込み禁止である
処理
処理を終了します。
対処
出力先のディスク，またはファイルを確認し，再実行してください。


KFDB001RC～KFDB999RCのメッセージ

7.10　KFDB001RC～KFDB999RCのメッセージ

＜この節の構成＞
KFDB003RC-E


KFDB003RC-E

KFDB003RC-E

ユティリティの実行中にメモリ不足が発生しました。
Memory became insufficient during execution of a utility program.

要因
ユティリティの実行中にメモリ不足が発生しました。
処理
処理を終了します。
対処
しばらく時間を空けてから，再実行してください。なお，このエラーが繰り返し発生する場合は，システム管理者に連絡してください。


KFDB001RM～KFDB999RMのメッセージ

7.11　KFDB001RM～KFDB999RMのメッセージ

＜この節の構成＞
KFDB001RM-E


KFDB001RM-E

KFDB001RM-E

システムコールでエラーが発生しました。［XXXX()error=YYYY］
An error occurred in a system call. [XXXX() errno=YYYY]

XXXX：システムコール名称
YYYY：エラー番号
要因
OSのシステムコール関数でエラーが発生しました。
処理
処理を終了します。
対処
操作を再実行してください。なお，このエラーが繰り返し発生する場合は，システム管理者に連絡してください。


KFDB001RR～KFDB999RRのメッセージ

7.12　KFDB001RR～KFDB999RRのメッセージ

＜この節の構成＞
KFDB001RR-E
KFDB002RR-E
KFDB003RR-E


KFDB001RR-E

KFDB001RR-E

指定されたユーザIDのデータベースとのアクセストレースは見つかりません。
The access-trace for the database that has the specified user ID could not be found.

要因
指定したユーザIDの，データベースアクセストレースが見つかりません。
処理
処理を終了します。
対処
指定したユーザIDを確認してください。


KFDB002RR-E

KFDB002RR-E

指定されたプログラム名のデータベースとのアクセストレースは見つかりません。
The access-trace for the database that has the specified program name could not be found.

要因
指定したクライアントのプログラム名の，データベースアクセストレースが見つかりません。
処理
処理を終了します。
対処
指定したクライアントのプログラム名を確認してください。


KFDB003RR-E

KFDB003RR-E

指定されたユーザID，又はプログラム名のデータベースとのアクセストレースは見つかりません。
The access-trace for the database that has the specified user ID or program name could not be found.

要因
指定したユーザID，またはクライアントのプログラム名の，データベースアクセストレースが見つかりません。
処理
処理を終了します。
対処
指定したユーザID，またはクライアントのプログラム名を確認してください。


KFDB001SC～KFDB999SCのメッセージ

7.13　KFDB001SC～KFDB999SCのメッセージ

＜この節の構成＞
KFDB002SC-E
KFDB005SC-I
KFDB007SC-E
KFDB008SC-E
KFDB009SC-E


KFDB002SC-E

KFDB002SC-E

DABrokerは起動していません。
DABroker is not running.

要因
DABrokerの動作状態を表示しようとしましたが，DABrokerは起動していません。
処理
処理を終了します。


KFDB005SC-I

KFDB005SC-I

DABrokerは計画終了処理中です。
DABroker is terminating in the planned termination mode.

要因
DABrokerの動作状態を表示しようとしましたが，DABrokerは計画終了処理中です。
処理
DABrokerの動作状態を表示し，計画終了を続行します。


KFDB007SC-E

KFDB007SC-E

DABrokerは起動処理中です。
DABroker is starting.

要因
DABroker管理ユティリティを実行しましたが，DABrokerの起動処理が完了していません。
処理
処理を終了します。
対処
しばらく時間を空けて，再実行してください。


KFDB008SC-E

KFDB008SC-E

DABrokerは終了処理中です。
DABroker is terminating.

要因
DABroker管理ユティリティを実行しましたが，DABrokerは終了処理中です。
処理
処理を終了します。


KFDB009SC-E

KFDB009SC-E

DABrokerは強制終了処理中です。
DABroker is terminating in the forced termination mode.

要因
DABroker管理ユティリティを実行しましたが，DABrokerは強制終了処理中です。
処理
処理を終了します。


KFDB001SM～KFDB999SMのメッセージ

7.14　KFDB001SM～KFDB999SMのメッセージ

＜この節の構成＞
KFDB001SM-E
KFDB002SM-E
KFDB003SM-E
KFDB004SM-E
KFDB005SM-E
KFDB006SM-E


KFDB001SM-E

KFDB001SM-E

システムコールでエラーが発生しました。［XXXX()errno=YYYY］
An error occurred in a system call. [XXXX() errno=YYYY]

XXXX：システムコール名称
YYYY：エラー番号
要因
OSのシステムコール関数でエラーが発生しました。
処理
処理を終了します。
対処
操作を再実行してください。なお，このエラーが繰り返し発生する場合は，システム管理者に連絡してください。


KFDB002SM-E

KFDB002SM-E

共有メモリを取得できませんでした。［shmget()errno=XXXX］
Shared memory cannot be obtained. [shmget() errno=XXXX]

XXXX：エラー番号
要因
OSのシステムコール関数（shmget）でエラーが発生しました。
処理
処理を終了します。
対処
操作を再実行してください。なお，このエラーが繰り返し発生する場合は，システム管理者に連絡してください。


KFDB003SM-E

KFDB003SM-E

共有メモリを削除できませんでした。［shmctl()errno=XXXX］
Shared memory cannot be deleted. [shmctl() errno=XXXX]

XXXX：エラー番号
要因
OSのシステムコール関数（shmctl）でエラーが発生しました。
処理
処理を続行します。
対処
このエラーが繰り返し発生する場合は，システム管理者に連絡してください。


KFDB004SM-E

KFDB004SM-E

セマフォを取得できませんでした。［semget()errno=XXXX］
The semaphore cannot be obtained. [semget() errno=XXXX]

XXXX：エラー番号
要因
OSのシステムコール関数（semget）でエラーが発生しました。
処理
処理を終了します。
対処
操作を再実行してください。なお，このエラーが繰り返し発生する場合は，システム管理者に連絡してください。


KFDB005SM-E

KFDB005SM-E

セマフォを削除できませんでした。［semctl()errno=XXXX］
The semaphore cannot be deleted. [semctl() errno=XXXX]

XXXX：エラー番号
要因
OSのシステムコール関数（semctl）でエラーが発生しました。
処理
処理を続行します。
対処
このエラーが繰り返し発生する場合は，システム管理者に連絡してください。


KFDB006SM-E

KFDB006SM-E

ユティリティの実行中にメモリ不足が発生しました。
Memory is insufficient during execution of a utility program.

要因
ユティリティの実行中にメモリ不足が発生しました。
処理
処理を終了します。
対処
しばらく時間を空けてから，再実行してください。なお，このエラーが繰り返し発生する場合は，システム管理者に連絡してください。


KFDB001TD～KFDB999TDのメッセージ

7.15　KFDB001TD～KFDB999TDのメッセージ

＜この節の構成＞
KFDB001TD-E
KFDB002TD-E
KFDB003TD-E
KFDB004TD-E
KFDB005TD-E
KFDB006TD-E
KFDB007TD-E
KFDB008TD-E
KFDB009TD-E
KFDB010TD-E
KFDB011TD-E
KFDB012TD-E
KFDB013TD-E
KFDB015TD-E
KFDB016TD-E
KFDB030TD-W
KFDB031TD-W
KFDB032TD-E
KFDB033TD-E
KFDB034TD-E
KFDB035TD-E
KFDB036TD-E
KFDB037TD-E
KFDB049TD-E


KFDB001TD-E

KFDB001TD-E

システムコールでエラーが発生しました。[XXXX errno=YYYY]
An error occurred in a system call. [XXXX errno=YYYY]

XXXX：システムコール名称
YYYY：システムコールのエラー番号
要因
XXXXシステムコールでエラーが発生しました。
処理
クライアントからの要求を受け付けません。
対処
使用するOSのマニュアルを参照しエラー原因を取り除いてから，再実行してください。


KFDB002TD-E

KFDB002TD-E

メモリ不足が発生しました。
Memory is insufficient.

要因
メモリ不足が発生しました。
処理
クライアントからの要求を受け付けません。
対処
しばらく時間を空けてから，再実行してください。なお，このエラーが繰り返し発生する場合は，実メモリ，または仮想メモリの設定を見直してください。


KFDB003TD-E

KFDB003TD-E

指定されたカーソルは使用中，又は初期化処理がされていません。［CursorId=XXXX］
The specified cursor is being used, or it is not initialized. [CursorId=XXXX]

XXXX：カーソル番号
要因
指定されたカーソルは，ほかの処理で使用中です。または，初期化処理がされていません。
処理
クライアントからの要求を受け付けません。
対処
未使用のカーソルを使用して，再実行してください。または，初期化処理をしてください。


KFDB004TD-E

KFDB004TD-E

カーソルの値が不正です。［CursorId=XXXX］
The cursor value is invalid. [CursorId=XXXX]

XXXX：カーソルの値
要因
指定されたカーソルの値が不正です。
処理
クライアントからの要求を受け付けません。
対処
カーソルは1～64の値を指定してください。


KFDB005TD-E

KFDB005TD-E

不正なデータを受信しました。［ErrorCode=XXXX］
Invalid data was received. [ErrorCode=XXXX]

XXXX：保守用情報
要因
クライアントから不正なデータを受信しました。
処理
クライアントからの要求を受け付けません。
対処
クライアントのバージョン，またはDABrokerのバージョンを確認してください。


KFDB006TD-E

KFDB006TD-E

必要なパラメタがありません。または，パラメタの値が不正です。［XXXX］
The required parameter was not found, or the parameter value is invalid. [XXXX]

XXXX：パラメタ名
  USER ID：ユーザID
  RD NODE NAME：RDノード名称
  TABLE TYPE：表属性
  ABSTRACT KIND：データベース種別名
  ABSTRACT NAME：データベース名
  DATASOURCE：ODBC3.0のデータソース名
要因
パラメタがありません。または，パラメタの値が不正です。
処理
クライアントからの要求を受け付けません。
対処
パラメタを正しく設定して，再実行してください。


KFDB007TD-E

KFDB007TD-E

指定された機能はサポートしていません。［RequestCode=XXXX］
DABroker does not support the specified function. [RequestCode=XXXX]

XXXX：保守用情報
要因
クライアントのバージョンが新しいため，サポートしていない機能を要求しました。または，クライアントが不正なデータを送信しました。
処理
クライアントからの要求を受け付けません。
対処
クライアントのバージョン，またはDABrokerのバージョンを確認してください。なお，クライアントからの要求コードについては，「付録B.2　DABrokerの要求コードおよび応答コード」を参照してください。


KFDB008TD-E

KFDB008TD-E

システムでエラーが発生しました。［ErrorCode=XXXX］
An error occurred in the system. [ErrorCode=XXXX]

XXXX：保守用情報
要因
DABrokerシステム内でエラーが発生しました。
処理
クライアントからの要求を受け付けません。
対処
保守員に連絡してください。


KFDB009TD-E

KFDB009TD-E

返信データの要求サイズが不正です。［ResponseSize=XXXX］
The request size of reply data is invalid. [ResponseSize=XXXX]

XXXX：保守用情報
要因
クライアントが要求した返信データのサイズが不正です。
処理
クライアントからの要求を受け付けません。
対処
保守員に連絡してください。


KFDB010TD-E

KFDB010TD-E

要求コードのシーケンスエラーが発生しました。[RequestCode=XXXX-YYYY]
A sequence error of the request code occurred. [RequestCode=XXXX-YYYY]

XXXX：前回の要求コード
YYYY：今回の要求コード
要因
クライアントからの要求コードのシーケンスエラーが発生しました。
処理
クライアントからの要求を受け付けません。
対処
出力された要求コードを基に要求シーケンスを見直してください。なお，要求コードについては，「付録B.2　DABrokerの要求コードおよび応答コード」を参照してください。


KFDB011TD-E

KFDB011TD-E

指定されたデータベースは未サポートです。
DABroker does not support the specified database.

要因
クライアントのバージョンが新しいため，サポートしていないデータベースを指定しました。または，クライアントが不正なデータを送信しました。
処理
クライアントからの要求を受け付けません。
対処
接続先のデータベースを見直してください。


KFDB012TD-E

KFDB012TD-E

指定されたSQLに誤りがあります。
The specified SQL is incorrect.

要因
クライアントが指定したSQLに次に示す誤りがあります。
  • 「:」の使用方法が不正です。
処理
クライアントからの要求を受け付けません。
対処
SQLの誤りを修正し，再実行してください。


KFDB013TD-E

KFDB013TD-E

データベースアクセスライブラリでエラーが発生しました。［ErrorCode=XXXX］
An error occurred in the database access library. [ErrorCode=XXXX]

XXXX：詳細コード
要因
データベースアクセスライブラリでエラーが発生しました。
処理
クライアントからの要求を受け付けません。
対処
詳細コードを参照しエラー原因を取り除いてから，再実行してください。なお，詳細コードについては，「付録B.1　DABrokerの詳細コード」を参照してください。


KFDB015TD-E

KFDB015TD-E

タイムオーバのため処理を中断しました。
Processing was canceled because a timeover occurred.

要因
タイムアウトが発生しました。
処理
クライアントからの要求を受け付けません。
対処
クライアントを再起動してから，操作を再実行してください。なお，このエラーが繰り返し発生する場合は，システム管理者に連絡してください。


KFDB016TD-E

KFDB016TD-E

データベースアクセスでエラーが発生しました。［ErrorCode=XXXX］
A database access error occurred. [ErrorCode=XXXX]

XXXX：DBMSのエラーコード
要因
データベースアクセスでエラーが発生しました。
処理
クライアントからの要求を受け付けません。
対処
DBMSのマニュアルを参照してエラーとなる原因を取り除き，操作を再実行してください。


KFDB030TD-W

KFDB030TD-W

キャンセルされたため，処理を中断しました。
Processing was canceled.

要因
キャンセルされたため，処理を中断しました。
処理
処理を終了します。


KFDB031TD-W

KFDB031TD-W

処理が終了したため，キャンセルできません。
Processing cannot be canceled because it has already ended

要因
処理をキャンセルしようとしましたが，処理が終了したため，キャンセルできませんでした。
処理
キャンセル処理を終了します。


KFDB032TD-E

KFDB032TD-E

クライアントでサポートされていないデータ型があります。(DataType=XXXX)
A data type that the client does not support was found. (DataType=XXXX)

XXXX：データ属性コード
要因
クライアントでサポートされていないデータ型があります。
処理
処理を終了します。
対処
表の定義，またはDABrokerのバージョンを見直してください。また，データ属性コードについては，接続先のデータベースのマニュアルを参照してください。


KFDB033TD-E

KFDB033TD-E

データベースに接続されていません。
Not connected to the database.

要因
データベースに接続されていません。
処理
処理を終了します。
対処
データベースに接続してから，処理を再実行してください。


KFDB034TD-E

KFDB034TD-E

指定されたファイルを削除する権限がありません。
ファイル名：XXXX
The user does not have authorization to delete the specified file. File:XXXX

XXXX：ファイル名
要因
指定されたファイルを削除する権限がありません。
処理
処理を終了します。
対処
ファイルの権限を確認し，再実行してください。


KFDB035TD-E

KFDB035TD-E

指定されたファイルがありません。ファイル名：XXXX
The specified file was not found. File:XXXX

XXXX：ファイル名
要因
指定されたファイルが見つかりません。
処理
処理を終了します。
対処
ファイルの名を確認し，再実行してください。


KFDB036TD-E

KFDB036TD-E

指定されたファイルの削除に失敗しました。ファイル名：XXXX［unlink（）errno＝YYYY］
DABroker failed to delete the specified file. File:XXXX [unlink() errno=YYYY]

XXXX：ファイル名
YYYY：unlink()のエラー番号
要因
指定されたファイルの削除に失敗しました。
処理
処理を終了します。
対処
unlink()のエラー番号を参照してエラーとなる原因を取り除いてください。


KFDB037TD-E

KFDB037TD-E

クライアントへの情報の送信に使用する領域が不足しました。要因＝XXXX
The area for sending information to the client was insufficient. Cause=XXXX

XXXX：処理種別
要因
クライアントへの情報の送信に使用する領域が不足しました。
処理
クライアントからの要求を受け付け，処理をしました。
対処
クライアントプログラムで設定した受信データ領域長を見直してください。データベースに対して更新，または表の定義を要求した場合，データベースにアクセスし，処理が正しく実行されているか確認してください。
なお，出力された処理種別によって次の計算式を使用して必要な受信データ領域長を算出し，受信データ領域長を見直してください。ただし，対策後もこのエラーが繰り返し発生する場合，およびこのほかの処理種別が出力された場合は，保守員に連絡してください。
  • 処理種別がEXT-CMD <Prepare>の場合

  • 処理種別がEXT-CMD <Fetch>の場合
    検索する1レコードの長さ＋4＊検索する列数 バイト
  • 処理種別がPROCEDURE PREPAREの場合

  • 処理種別がPROCEDURE EXECUTEの場合

  • 処理種別がPROCEDURE-PARAMETERの場合

  • 処理種別がPROCEDURE-RESULTの場合

  • 処理種別がEXT-CMD <EXECUTE>の場合
    52＋4＊設定された可変値データのうち実行されたレコード数 バイト


KFDB049TD-E

KFDB049TD-E

データ処理中にメモリ不足が発生しました。 ErrInfo[XXXX]
Memory is insufficient during data processing. ErrInfo[XXXX]

XXXX：保守用情報
要因
処理に必要な領域を確保しようとした時，メモリ不足が発生しました。
処理
処理を終了します。
対処
しばらく時間を空けてから，再実行してください。なお，このエラーが繰り返し発生する場合は，実メモリ，または仮想メモリの設定を見直してください。


KFDB001TM～KFDB999TMのメッセージ

7.16　KFDB001TM～KFDB999TMのメッセージ

＜この節の構成＞
KFDB001TM-E
KFDB002TM-E
KFDB003TM-E
KFDB004TM-E
KFDB005TM-E
KFDB006TM-I
KFDB007TM-I
KFDB008TM-E
KFDB009TM-E
KFDB010TM-E
KFDB011TM-E
KFDB012TM-E
KFDB013TM-E
KFDB014TM-I
KFDB016TM-E
KFDB017TM-E
KFDB018TM-E
KFDB019TM-E
KFDB020TM-E
KFDB021TM-E
KFDB022TM-W
KFDB023TM-E


KFDB001TM-E

KFDB001TM-E

servicesファイルに，DABrokerのサービス名とポート番号(DABROKER_SV)が登録されていません。
The services name and port number(DABROKER_SV) of DABroker are not listed in the "services" file.

要因
システムのservicesファイルに，DABrokerのサービス名とポート番号が登録されていません。
処理
処理を終了します。
対処
servicesファイルに，次の記述を追加してください。

DABROKER_SV 40179/tcp
NISを使用している場合は，NISのサーバに追加してください。


KFDB002TM-E

KFDB002TM-E

ソケットをオープンできません。［socket() errno=XXXX］
The socket cannot be opened. [socket() errno=XXXX]

XXXX：エラー番号
要因
OSのシステムコール関数（socket）でエラーが発生しました。
処理
処理を終了します。
対処
操作を再実行してください。なお，このエラーが繰り返し発生する場合は，システム管理者に連絡してください。


KFDB003TM-E

KFDB003TM-E

ソケットへのアドレスの割り付けができません。［bind() errno=XXXX］
The address cannot be allocated to the socket. [bind() errno=XXXX]

XXXX：エラー番号
要因
OSのシステムコール関数（bind）でエラーが発生しました。DABrokerの強制終了時に，LAN上に通信データが残った可能性があります。
処理
処理を終了します。
対処
しばらく時間を空けてから，DABrokerを再起動してください。


KFDB004TM-E

KFDB004TM-E

コネクション要求の受付開始時にエラーが発生しました。［listen() errno=XXXX］
An error occurred when a requested connection was accepted. [listen() errno=XXXX]

XXXX：エラー番号
要因
OSのシステムコール関数（listen）でエラーが発生しました。
処理
処理を終了します。
対処
保守員に連絡してください。


KFDB005TM-E

KFDB005TM-E

コネクションの確立時にエラーが発生しました。［accept() errno=XXXX］
An error occurred when a connection was established. [accept() errno=XXXX]

XXXX：エラー番号
要因
OSのシステムコール関数（accept）でエラーが発生しました。
処理
処理を終了します。
対処
システムに負荷が掛かっていることが考えられます。時間を空けてから，再度実行してください。なお，このエラーが繰り返し発生する場合は，保守員に連絡してください。


KFDB006TM-I

KFDB006TM-I

コネクションを確立します。［XXXX］
A connection is established. [XXXX]

XXXX：クライアントのIPアドレスまたはホスト名
要因
クライアントとの接続を開始しました。
処理
処理を続行します。


KFDB007TM-I

KFDB007TM-I

コネクションを解放します。［XXXX］
A connection is released. [XXXX]

XXXX：クライアントのIPアドレスまたはホスト名
要因
クライアントとの接続を終了しました。
対処
処理を続行します。


KFDB008TM-E

KFDB008TM-E

クライアントプログラムのバージョンが違います。
Incorrect version of the client program.

要因
クライアントプログラムは接続できるバージョンではありません。
処理
クライアントからの要求を受け付けません。
対処
クライアントプログラムのバージョンを確認してください。


KFDB009TM-E

KFDB009TM-E

メモリ不足が発生したため，データベースに接続できません。IPADDR=XXXX
Cannot connect the database because of insufficient memory. IPADDR=XXXX

XXXX：IPアドレスまたはホスト名
クライアントには「IPADDR=XXXX」は表示されません。
要因
メモリ不足が発生したため，データベースに接続できません。
処理
データベースとの接続を中止し，コネクションを解放します。
対処
DABrokerで実行中のほかの処理が終了してから，再実行してください。


KFDB010TM-E

KFDB010TM-E

不正なデータを受信しました。エラーコード=XXXX，IPADDR=YYYY
Invalid data was received. Error code=XXXX IPADDR=YYYY

XXXX：保守用情報
YYYY：IPアドレスまたはホスト名
クライアントには「IPADDR=YYYY」は表示されません。
要因
クライアントから不正なデータを受信しました。
処理
クライアントからの要求を無視します。または，処理を終了します。
対処
保守員に連絡してください。


KFDB011TM-E

KFDB011TM-E

通信処理でエラーが発生しました。エラーコード=XXXX，IPADDR=YYYY
An error occurred during communication processing. Error code=XXXX IPADDR=YYYY

XXXX：保守用情報
YYYY：IPアドレスまたはホスト名
クライアントには「IPADDR=YYYY」は表示されません。
要因
データの送信時，通信管理プログラムでエラーが発生しました。
処理
処理を終了します。
対処
システム管理者に連絡してください。


KFDB012TM-E

KFDB012TM-E

データの送受信中にシーケンスエラーが発生しました。エラーコード=XXXX　IPADDR=YYYY
A sequence error occurred during sending or receiving of data.
Error code=XXXX IPADDR=YYYY

XXXX：保守用情報
YYYY：IPアドレスまたはホスト名
クライアントには「IPADDR=YYYY」は表示されません。
要因
クライアントから不正なシーケンスでデータを受信しました。
処理
クライアントからの要求を無視します。または，処理を終了します。
対処
保守員に連絡してください。


KFDB013TM-E

KFDB013TM-E

DABrokerが計画終了中のため，処理要求を受け付けられません。IPADDR=XXXX
The processing request cannot be accepted because DABroker is terminating in the planned termination mode. IPADDR=XXXX

XXXX：IPアドレスまたはホスト名
クライアントには「IPADDR=XXXX」は表示されません。
要因
データベースと接続しようとしましたが，DABrokerが計画終了中です。計画終了中は，新たなクライアントからの処理要求を受け付けません。
処理
クライアントからの要求を無視します。
対処
DABrokerの計画終了が終わってから，DABrokerを再起動してください。その後，DABrokerおよびデータベースへの接続を再実行してください。


KFDB014TM-I

KFDB014TM-I

TCP/IP通信処理スレッドを終了します。要因：［XXXX］，IPADDR=YYYY
The TCP/IP communication thread is terminated. Cause:[XXXX] IPADDR=YYYY

XXXX：終了要因
  CANCEL_REQUEST：ユーザキャンセル要求
  TERM_REQUEST：強制終了要求
YYYY：IPアドレスまたはホスト名
クライアントには「IPADDR=XXXX」は表示されません。
要因
強制終了※1，またはユーザキャンセル※2要求によってTCP/IP通信用の処理スレッドが終了しました。
注※1
［DABroker終了］ダイアログで強制終了を選択，またはサービスを停止させた時です。
注※2
［DABroker管理］ウィンドウで選択されたクライアントの処理を中断した時です。
処理
トランザクションのロールバックおよびデータベースとの切り離しをして，コネクションを解放します。
対処
システム管理者が強制終了，またはユーザキャンセル要求をしていないか確認してください。


KFDB016TM-E

KFDB016TM-E

クライアントからの要求待ちタイムアウトが発生しました。コネクションを解放します。IPADDR=XXXX
A timeout occurred during the wait for the request from the client.
DABroker releases the connection. IPADDR=XXXX

XXXX：IPアドレスまたはホスト名
クライアントには「IPADDR=XXXX」は表示されません。
要因
DABroker動作環境定義ファイルでDABCLIENT_TIMEOUTに指定した値以内に，クライアントからの要求がありませんでした。
処理
トランザクションのロールバックおよびデータベースとの切り離しをして，コネクションを解放します。
対処
クライアントを再起動してから，操作を再実行してください。なお，このエラーが繰り返し発生する場合は，DABCLIENT_TIMEOUTの値を大きくしてください。


KFDB017TM-E

KFDB017TM-E

データベースアクセス処理終了待ちタイムアウトが発生しました。コネクションを解放します。IPADDR=XXXX
A timeout occurred during the wait for termination of the database access.
DABroker releases the connection. IPADDR=XXXX

XXXX：IPアドレスまたはホスト名
クライアントには「IPADDR=XXXX」は表示されません。
要因
DABroker動作環境定義ファイルでDABDBA_TIMEOUTに指定した値以内に，データベースアクセス処理が終了しませんでした。
処理
実行中の処理を中断し，コネクションを解放します。
対処
クライアントを再起動してから，操作を再実行してください。なお，このエラーが繰り返し発生する場合は，DABDBA_TIMEOUTの値を大きくしてください。


KFDB018TM-E

KFDB018TM-E

コネクションが強制解放されました。IPADDR=XXXX
The connection was forcibly released. IPADDR=XXXX

XXXX：IPアドレスまたはホスト名
クライアントには「IPADDR=XXXX」は表示されません。
要因
クライアントシステムが原因で，コネクションを強制解放しました。
処理
トランザクションのロールバックおよびデータベースとの切り離しをして，コネクションを解放します。
対処
クライアントでシステムダウンやタイムアウトなどが発生していないかどうか調査してください。また，ケーブルの接続や電源の状態などを確認してください。


KFDB019TM-E

KFDB019TM-E

コネクションが強制解放されました。IPADDR=XXXX
The connection was forcibly released. IPADDR=XXXX

XXXX：IPアドレスまたはホスト名
クライアントには「IPADDR=XXXX」は表示されません。
要因
TCP/IP通信時のキープアライブ機能によって，障害が検知されました。
処理
トランザクションのロールバックおよびデータベースとの切り離しを行い，コネクションを解放します。
対処
  1. クライアントシステムまたはクライアント通信システムが障害を起こしていないか確認してください。
  2. 回線の接続状態を調査してください。


KFDB020TM-E

KFDB020TM-E

データベースアクセス処理が異常終了しました。エラーコード=XXXX　IPADDR=YYYY
The database access process terminated abnormally. Error code=XXXX IPADDR=YYYY

XXXX：保守用情報
YYYY：IPアドレスまたはホスト名
クライアントには「IPADDR=YYYY」は表示されません。
要因
システムに負荷が掛かり過ぎているか，またはほかの障害によって，データベースアクセス処理が異常終了しました。
処理
コネクションを解放します。
対処
システムに負荷が掛かり過ぎていないか，またはほかの障害が発生していないか確認してください。エラーの原因がわからない場合は，保守員に連絡してください。


KFDB021TM-E

KFDB021TM-E

TCP/IP通信処理プロセスを終了します。要因：[XXXX]
The TCP/IP communication process terminated. Cause:[XXXX]

XXXX：終了要因（保守用情報）
要因
TCP/IP通信処理プロセスが異常終了しました。
処理
コネクションを解放します。
以降のクライアントからの要求を受け付けません。
対処
killコマンドなどを入力していないか，またはシステムに負荷が掛かり過ぎていないか確認してください。エラーの原因がわからない場合は，保守員に連絡してください。


KFDB022TM-W

KFDB022TM-W

キャンセル処理要求を受け付けられる状態ではありません。［XXXX］　IPADDR=YYYY
The cancel processing request cannot be accepted. [XXXX] IPADDR=YYYY

XXXX：保守用情報
YYYY：IPアドレスまたはホスト名
クライアントには「IPADDR=YYYY」は表示されません。
要因
DABrokerは，非同期キャンセル要求を受け付けましたが，キャンセル処理を実行できる状態ではありません。
処理
キャンセル処理を実行しませんでした。
対処
必要ならば，再度，キャンセル要求を実行してください。


KFDB023TM-E

KFDB023TM-E

指定されたDBMSに対する環境変数に誤りがあります。［XXXX=YYYY］IPADDR=ZZZZ
The specified DBMS environment variable is incorrect. [XXXX] IPADDR=YYYY

XXXX：環境変数名
YYYY：環境変数の値
ZZZZ：IPアドレスまたはホスト名
クライアントには「IPADDR=ZZZZ」は表示されません。
要因
指定されたDBMSに対して，動作環境定義ファイルに設定した環境変数の値に誤りがあります。
処理
クライアントからの要求を無視します。
対処
動作環境定義ファイルの環境変数の値を修正してください。


KFDB001TR～KFDB999TRのメッセージ

7.17　KFDB001TR～KFDB999TRのメッセージ

＜この節の構成＞
KFDB001TR-E
KFDB002TR-E
KFDB003TR-E


KFDB001TR-E

KFDB001TR-E

クライアントとの通信トレースの取得中に，メモリ不足が発生しました。
Memory became insufficient during collection of a trace of communication with a client.

要因
クライアントとの通信トレースの取得に必要なメモリが不足しました。
処理
処理を続行します。ただし，このエラーが発生したクライアントとの通信トレースは取得しません。
対処
このエラーが繰り返し発生する場合は，システム管理者に連絡してください。


KFDB002TR-E

KFDB002TR-E

クライアントとの通信トレースの取得中に，ディスクの容量不足が発生しました。
Disk space became insufficient during collection of a trace of communication with a client.

要因
クライアントとの通信トレースの取得中に，ディスクの容量不足が発生しました。
処理
処理を続行します。ただし，このエラーが発生したクライアントとの通信トレースは取得しません。
対処
通信トレースを取得するディレクトリ下の不要なファイルを削除してください。


KFDB003TR-E

KFDB003TR-E

クライアントとの通信トレースの取得中に，システムコールでエラーが発生しました。
［XXXX()errno=YYYY］
An error occurred in a system call during collection of a trace of communication with a client.
[XXXX() errno=YYYY]

XXXX：システムコール名称
YYYY：エラー番号
要因
OSのシステムコール関数，あるいはDABrokerの共通関数でエラーが発生しました。
処理
処理を続行します。ただし，このエラーが発生したクライアントとの通信トレースは取得しません。
対処
このエラーが繰り返し発生する場合は，システム管理者に連絡してください。


KFDB001YM～KFDB999YMのメッセージ

7.18　KFDB001YM～KFDB999YMのメッセージ

＜この節の構成＞
KFDB003YM-I
KFDB004YM-I
KFDB005YM-I
KFDB006YM-I
KFDB007YM-E
KFDB008YM-E
KFDB009YM-E
KFDB010YM-E
KFDB011YM-E
KFDB012YM-E
KFDB013YM-E
KFDB014YM-E
KFDB015YM-E
KFDB016YM-E
KFDB019YM-E
KFDB020YM-E
KFDB021YM-E
KFDB022YM-I
KFDB023YM-E
KFDB100YM-E
KFDB101YM-E
KFDB301YM-I
KFDB302YM-I
KFDB303YM-I
KFDB310YM-I


KFDB003YM-I

KFDB003YM-I

DABrokerの初期化処理が完了しました。
DABroker initialization processing has finished.

要因
DABrokerの起動要求を受け付け，初期化処理が完了しました。
DABrokerの起動要求とは，［DABroker起動］アイコンをダブルクリックまたはサービスを開始した時を指します。
処理
DABrokerを起動し，クライアントからのアクセス要求の受け付けを開始します。


KFDB004YM-I

KFDB004YM-I

DABrokerの終了処理を開始しました。mode=NORMAL
DABroker termination processing has started. mode=NORMAL

要因
DABrokerの通常終了処理を開始しました。
DABrokerの通常終了とは，［DABroker終了］ダイアログで通常終了を選択した時を指します。
処理
DABrokerを終了します。


KFDB005YM-I

KFDB005YM-I

DABrokerの終了処理を開始しました。mode=FORCED
DABroker termination processing has started. mode=FORCED

要因
DABrokerの強制終了処理を開始しました。
DABrokerの強制終了とは，［DABroker終了］ダイアログで強制終了を選択，またはサービスの停止を実行した時を指します。
処理
データベースへのアクセスを中断します。実行中の処理のロールバックおよびデータベースとの切り離しを行い，コネクションを解放します。


KFDB006YM-I

KFDB006YM-I

DABrokerの終了処理を開始しました。mode=PLANNED
DABroker termination processing has started. mode=PLANNED

要因
DABrokerの計画終了処理を開始しました。
DABrokerの計画終了とは，［DABroker終了］ダイアログで計画終了を選択した時を指します。
処理
実行中のデータベースへのアクセス処理が終了し，接続中のクライアントがすべて終了した時点でDABrokerを終了します。計画終了中は，クライアントからの処理要求や，新たなクライアントからの接続要求は受け付けません。


KFDB007YM-E

KFDB007YM-E

DABrokerは計画終了中です。クライアントは接続できません。
DABroker is terminating in the planned termination mode. A client cannot be connected.

要因
DABrokerに接続しようとしましたが，DABrokerが計画終了中です。計画終了中は，新たなクライアントからの接続要求は受け付けません。
処理
クライアントからの要求を受け付けません。
対処
DABrokerの計画終了が終わってから，DABrokerを再起動してください。その後，DABrokerへの接続を再実行してください。


KFDB008YM-E

KFDB008YM-E

接続できる最大クライアント数を超えました。クライアントは接続できません。
［DABMAXUSERS=XXX］
The number of clients exceeds the maximum that can be connected.
A client cannot be connected. [DABMAXUSERS=XXXX]

XXX：接続できる最大クライアント数
要因
DABroker動作環境定義ファイルでDABMAXUSERSに設定した値を超えて，クライアントからの接続要求が発生しました。
処理
クライアントからの要求を受け付けません。
対処
ほかのクライアントが終了するまで待って，DABrokerへの接続を再実行してください。または，DABroker動作環境定義ファイルのDABMAXUSERSの値を大きくしてから，再実行してください。


KFDB009YM-E

KFDB009YM-E

DABrokerは既に起動しています。
DABroker is already running.

要因
DABrokerがすでに起動されているマシン上で，DABrokerの起動要求※を受け付けました。
注※
DABrokerの起動要求とは，［DABroker起動］アイコンをダブルクリック，またはサービスの開始を実行した時を指します。
処理
処理を終了します。
対処
一つのマシン上では，複数のDABrokerは起動できません。


KFDB010YM-E

KFDB010YM-E

DABrokerのロードモジュールに実行権限がありません。
ロードモジュール名：[XXXX]
The user does not have authority to execute the load module of DABroker. Name:[XXXX]

XXXX：エラーとなったロードモジュールのファイル名称
要因
DABrokerのロードモジュールに実行権限がないため，クライアントからの要求を処理できません。
処理
クライアントからの要求を受け付けません。
対処
DABrokerを組み込み直してください。


KFDB011YM-E

KFDB011YM-E

シンボリックリンクが多過ぎるため，DABrokerを実行できません。
ロードモジュール名：[XXXX]
DABroker cannot start because there are too many symbolic links. Name:[XXXX]

XXXX：エラーとなったロードモジュールのファイル名称
要因
DABroker組み込み先ディレクトリのシンボリックリンクが多過ぎるため，クライアントからの要求を処理できません。
処理
クライアントからの要求を受け付けません。
対処
データベース接続時に発生した場合は，DBMSライブラリの組み込み先ディレクトリのシンボリックリンクが多過ぎることが考えられます。DBMSライブラリの組み込み環境を確認してください。
それ以外の場合は，システム管理者に連絡し，シンボリックリンクの少ないディレクトリにDABrokerを組み込み直してもらってください。


KFDB012YM-E

KFDB012YM-E

DABrokerのロードモジュールがありません。
ロードモジュール名：[XXXX]
A load module of DABroker was not found. Name:[XXXX]

XXXX：エラーとなったロードモジュールのファイル名称
要因
DABrokerの動作環境が正しく設定されていないため，クライアントからの要求を処理できません。
処理
クライアントからの要求を受け付けません。
対処
DABrokerを組み込み直してください。
データベースのクライアント製品が正しくセットアップされているか確認してください。


KFDB013YM-E

KFDB013YM-E

メモリ不足のため，DABrokerを実行できません。
ロードモジュール名：[XXXX]
DABroker cannot start because of insufficient memory. Name:[XXXX]

XXXX：エラーとなったロードモジュールのファイル名称
要因
DABrokerの動作に必要なメモリが不足しています。
処理
クライアントからの要求を受け付けません。
対処
しばらく時間を空けてから，再実行してください。なお，このエラーが繰り返し発生する場合は，システム管理者に連絡してください。


KFDB014YM-E

KFDB014YM-E

DABrokerを起動する権限がありません。
The user does not have authority to execute DABroker.

要因
DABrokerを起動しようとしたユーザが，DABrokerの管理ユーザ（Administratorsグループに属しているユーザ）ではないため，DABrokerを起動できません。
処理
処理を終了します。
対処
DABrokerは，DABrokerの管理ユーザが起動してください。


KFDB015YM-E

KFDB015YM-E

TCP/IP通信処理プロセスが異常終了しました。要因：［XXXX］
The TCP/IP communication process terminated abnormally. Cause:[XXXX]

XXXX：終了要因（保守用情報）
要因
TCP/IP通信処理プロセスが異常終了しました。
処理
コネクションを解放します。以降のクライアントからの要求を受け付けません。
対処
killコマンドなどを入力していないか，またはシステムに負荷が掛かり過ぎていないか確認してください。エラーの原因がわからない場合は，システム管理者に連絡してください。


KFDB016YM-E

KFDB016YM-E

DABrokerが異常終了しました。要因：[XXXX]
DABroker terminated abnormally. Cause:[XXXX]

XXXX：終了要因（保守用情報）
要因
killコマンドを入力したか，またはシステムに負荷が掛かり過ぎて，DABrokerが異常終了しました。
処理
DABrokerを終了します。
対処
DABrokerを再起動する場合は，強制終了を実行後，再起動してください。
このエラーが繰り返し発生する場合は，システム管理者に連絡してください。保守員に連絡する場合は，次のファイルを退避しておいてください。
  • DABroker運用ディレクトリ\spool以下のファイル


KFDB019YM-E

KFDB019YM-E

実行可能な最大ユーザ処理プロセス数を超えました。クライアントは接続できません。
[DABMAXPROCESS=XXXX]
The number of users exceeds the maximum that can be executed.
A client cannot be connected. [DABMAXPROCESS=XXXX]

XXXX：DABrokerが実行できる最大処理プロセス数
要因
DABroker動作環境定義ファイルでDABMAXPROCESSに設定した値を超えて，クライアントからの接続要求が発生しました。
処理
クライアントからの要求を受け付けません。
対処
ほかのクライアントが終了するまで待って，DABrokerへの接続を再実行してください。または，DABroker動作環境定義ファイルのDABMAXPROCESSの値を大きくしてから，再実行してください。


KFDB020YM-E

KFDB020YM-E

DABrokerを起動できません。
DABroker cannot start.

要因
DABrokerの起動に失敗しました。
処理
DABrokerを終了します。
対処
直前に出力されたメッセージの指示に従って対処してください。対処後，DABrokerを再起動してください。


KFDB021YM-E

KFDB021YM-E

同時実行可能な最大データベースアクセス数を超えました。データベースアクセスできません。
［DABDBANUMBER=XXX］
The number of database accesses exceeds the maximum that can be executed. Database access is not possible. [DABDBANUMBER=XXXX]

XXX：同時実行可能なデータベースアクセス数
要因
DABroker動作環境定義ファイルでDABDBANUMBERに設定した値を超えて，データベースアクセス要求を受け付けました。
処理
クライアントからの要求を受け付けません。
対処
ほかのデータベースアクセスが終了するまで待って，再実行してください。または，DABroker動作環境定義ファイルのDABDBANUMBERの値を大きくしてから，再実行してください。


KFDB022YM-I

KFDB022YM-I

DABrokerの終了処理が完了しました。
DABroker has terminated.

要因
DABrokerが終了しました。


KFDB023YM-E

KFDB023YM-E

TCP/IP通信処理プロセスを起動できません。
The TCP/IP communication process cannot start.

要因
TCP/IP通信処理プロセスの起動に失敗しました。
処理
DABroker初期化処理を続行します。
対処
DABrokerを終了させ，直前に出力されたメッセージに対する指示に従ってください。


KFDB100YM-E

KFDB100YM-E

システムコールでエラーが発生しました。［XXXX() errno=YYYY］
An error occurred in a system call. [XXXX() errno=YYYY]

XXXX：関数名称（保守用情報）
YYYY：エラー番号（保守用情報）
要因
OSのシステムコール関数，またはDABrokerの共通関数でエラーが発生しました。
処理
処理を終了します。
対処
操作を再実行してください。なお，このエラーが繰り返し発生する場合は，システム管理者に連絡してください。


KFDB101YM-E

KFDB101YM-E

メモリを確保できません。
Required memory cannot be obtained.

要因
DABrokerの動作に必要なメモリが不足しています。
処理
DABrokerを終了します。
対処
しばらく時間を空けてから，再実行してください。なお，このエラーが繰り返し発生する場合は，システム管理者に連絡してください。


KFDB301YM-I

KFDB301YM-I

Clean up. {xxx,yyy,zzz}, {sss}

要因
クライアントとの通信サーバデーモンのクリーンアップを実行しました。
処理
クライアントとの通信サーバデーモンのクリーンアップを実行します。
対処
ありません。
備考
xxx：クリーンアップ前のデーモン数を示します。
yyy：クリーンアップしたデーモン数を示します。
zzz：クリーンアップ実行後のデーモン数を示します。
sss：DABrokerの状態を示します。
    0：正常実行中です。
    1：正常終了中です。
    2：計画終了中です。
    3：強制終了中です。


KFDB302YM-I

KFDB302YM-I

dabtcpdmn {xxx} start. [yyyy]

要因
クライアントとの通信サーバデーモンを起動しました。
処理
クライアントとの通信サーバデーモンを起動します。
対処
ありません。
備考
xxx：dabtcpdmnの引数を示します。
yyyy：起動したプロセスIDを示します。


KFDB303YM-I

KFDB303YM-I

dabtcpdmn end. [xxxx]

要因
クライアントとの通信サーバデーモンを終了しました。
処理
クライアントとの通信サーバデーモンを終了します。
対処
ありません。
備考
yyyy：起動したプロセスIDを示します。


KFDB310YM-I

KFDB310YM-I

Thread stack size = xxxx（yyyy）

要因
スレッドのスタックサイズを設定しました。
処理
スレッドのスタックサイズをxxxxバイトに設定します。
対処
ありません。
備考
xxx：スレッドのスタックサイズを示します。
yyyy：環境変数で指定されたスレッドのスタックサイズを示します。

DABPTHREAD_STACK_SIZE is undefined.：
環境変数DABPTHREAD_STACK_SIZEが定義されていません。

DABPTHREAD_STACK_SIZE=aaa：
aaa：環境変数DABPTHREAD_STACK_SIZEに指定されている値
    （最大55バイト）を示します。


付録

＜この付録の構成＞
付録A　DABrokerの利用
付録B　DABrokerの詳細コード，要求コード，および応答コード
付録C　このマニュアルの参考情報


DABrokerの利用

付録A　DABrokerの利用

EURでは，データベースからデータを読み込む場合にDABrokerを使用してデータベースに接続します。DABrokerは，データベース接続を実現するミドルウェアです。複数の異なるリレーショナルデータベースに一つのインタフェースで接続できる環境を提供します。

ここでは，EUR Developer，およびWindows版のEUR Server製品（EUR Server Print Edition，EUR Server Standard，EUR Server Enterprise）にバンドルされるDABrokerの起動中に使用できるユティリティと，その操作手順について説明します。

＜この節の構成＞
付録A.1　DABrokerの起動中に使用できるユティリティ


DABrokerの起動中に使用できるユティリティ

付録A.1　DABrokerの起動中に使用できるユティリティ

DABrokerの起動中には，次の三つのユティリティおよび一つのビューアを使って情報を取得したり，EURの処理を制御したりできます。これ以外のユティリティやビューアはEURでは使用しないため説明は省略します。

DABroker管理ユティリティ
DABrokerの動作状態を表示したり，特定のEURの処理を中断したりできます。
DABrokerトレース出力ユティリティ
通信トレース，およびアクセストレースを出力できます。このユティリティは，DABrokerが起動していなくても使用できます。
拡張データベースアクセストレースユティリティ
拡張データベースアクセストレースを出力できます。
DABrokerメッセージログビューア
DABrokerのログファイルの出力内容を参照できます。
＜この項の構成＞
(1)　DABroker管理ユティリティ
(2)　DABrokerトレース出力ユティリティ
(3)　拡張データベースアクセストレースユーティリティ
(4)　DABrokerメッセージログビューア

(1)　DABroker管理ユティリティ

DABroker管理ユティリティの機能，操作できるユーザ，各機能を使用する場合の操作手順について説明します。

(a)　機能

DABroker管理ユティリティには次の二つの機能があります。

DABrokerの動作状態の表示
各EURとの接続時間の状態を表示します。
EURの処理の中断
指定したEURとの接続を解放し，実行中の処理を中断します。この場合，DABrokerはリレーショナルデータベースに要求した処理のロールバックを要求します。
(b)　操作できるユーザ

すべてのユーザが管理ユティリティを実行できます。ただし，特定のクライアントの処理を中断できるのは，Windowsの管理者グループまたはAdministratorsグループに属するユーザだけです。

(c)　DABrokerの動作状態を表示する操作手順

DABrokerの動作状態を表示する手順を次に示します。

  1. DABrokerが起動していることを確認する
  2. プログラムフォルダに登録された［DABroker］から［DABroker管理］を選択する
    DABroker管理ユティリティが起動し，［DABroker管理］に動作状態が表示されます。 [図データ] をクリックすると，最新の動作状態に表示が更新されます。

    図A-1　［DABroker管理］ダイアログ

    ［DABroker管理］ダイアログに表示される項目の意味は次のとおりです。
    識別子
    DABrokerに接続されているクライアント処理を識別するための番号です。
    IPアドレス
    接続しているEURがあるマシンのIPアドレス
    接続時刻
    EURと接続した日時（年／月／日 時：分：秒）
    接続時間
    接続してからの経過時間（時：分：秒）
    予約
    実行中の予約処理数（EURでは使用しません）
    状態
    EURとの接続状態
    「接続中」と表示されている場合は，EURとのコネクションが確立されていることを示します。
    ホスト名
    接続しているEURがあるマシンのホスト名
    次の条件をすべて満たしている場合に表示されます。
    ・［リモートアクセス設定］タブで「IPアドレスからホスト名へ変換する」をチェックしている場合
    ・次のフォルダのhostsファイルに各クライアントのホスト名を登録している場合
    ［Windowsをインストールしたフォルダ］\SYSTEM32\DRIVERS\ETC
    なお，ホスト名の長さによっては，途中までしか表示されない場合があります。
  3. DABrokerの動作状態の確認が済んだら，［DABroker管理］ダイアログを閉じ，DABroker管理ユティリティを終了させる
(d)　EURの処理を中断する操作手順

特定のEURの処理を中断する手順を次に示します。

  1. DABrokerが起動していることを確認する
  2. プログラムフォルダに登録された［DABroker］から［DABroker管理］を選択する
    DABroker管理ユティリティが起動し，［DABroker管理］ダイアログに動作状態が表示されます。
  3. ［DABroker管理］ダイアログで処理を中断するEURを選択し， [図データ] をクリックする
    確認のダイアログが表示されます。
  4. ［はい］を選択する
    DABrokerは選択したクライアントとのコネクションを解放します。同時にリレーショナルデータベースに処理のロールバックを要求します。

(2)　DABrokerトレース出力ユティリティ

DABrokerトレース出力ユティリティの機能，操作できるユーザ，各機能を使用する場合の操作手順について説明します。

(a)　機能

DABrokerトレース出力ユティリティでは，次の2種類のトレースを出力できます。

通信トレース
通信トレースとは，DABrokerとEUR間のデータの送受信についての情報です。DABrokerがこの情報を取得するのは，クライアントからの要求受け付け直後，およびDABrokerからの結果送信直後です。通信トレースは，「DABroker運用ディレクトリ\spool\dabcltrc」の下に出力されます。
アクセストレース
アクセストレースとは，DABrokerがリレーショナルデータベースに要求した処理，およびその処理に対するリレーショナルデータベースからの応答についての情報です。DABrokerがこの情報を出力するのは，リレーショナルデータベースに要求を出す直前およびリレーショナルデータベースから応答が返ってきた直後です。リレーショナルデータベースとのアクセストレースは，「DABroker運用ディレクトリ」\spool\db_accessの下に出力されます。
(b)　操作できるユーザ

すべてのユーザがDABrokerトレース出力ユティリティを実行できます。

(c)　トレースを出力する操作手順

通信トレース，およびリレーショナルデータベースとのアクセストレースを出力する操作手順を次に示します。

  1. プログラムフォルダに登録された［DABroker］から［トレース出力］を選択する
    DABrokerトレース出力ユティリティが起動し，［DABrokerトレース出力］ダイアログが表示されます。

    図A-2　［DABrokerトレース出力］ダイアログ

    • 通信トレースを出力する場合の操作
      1.［通信トレースを出力する］チェックボックスをチェックする
      2.［IPアドレスまたはホスト名］を設定する
      すべての通信トレースを出力する場合は，［IPアドレスまたはホスト名］に何も指定しないでください。特定のIPアドレスまたはホスト名の通信トレースを出力する場合，［IPアドレスまたはホスト名］に，通信トレースを出力するIPアドレスまたはホスト名を指定してください。
      3.通信トレースの出力先を指定する
      ［出力先］ボタンをクリックすると，出力先を指定するダイアログが表示されます。出力先のファイル名を指定してください。省略した場合は，［DABroker運用ディレクトリ］\spool\DABTT.TXTに出力されます。
    • アクセストレースを出力する場合の操作
      1.［アクセストレースを出力する］チェックボックスをチェックする
      2.［UAP名］，［ユーザID］を設定する
      すべてのアクセストレースを出力する場合は，［UAP名］，［ユーザID］に何も指定しないでください。
      特定のリレーショナルデータベースへログインするユーザIDのアクセストレースを出力する場合は，［ユーザID］にリレーショナルデータベースへログインするためのユーザIDを指定してください。
      ［UAP名］は使用しません。
      3.アクセストレースの出力先を指定する
      ［出力先］ボタンをクリックすると，出力先を指定するダイアログが表示されます。出力先のファイル名を指定してください。省略した場合は，［DABroker運用ディレクトリ］\spool\DABDT.TXTに出力されます。
  2. 「通信トレースを出力する場合の操作」，「アクセストレースを出力する場合の操作」が済んだら，［実行］ボタンを選択する
    指定した出力先が登録されます。
    なお，「通信トレースを出力する場合の操作」および「アクセストレースを出力する場合の操作」の両方をすると，2種類のトレースが出力できます。
(d)　トレース出力内容

通信トレースおよびアクセストレースの出力例と，出力される項目の意味について説明します。

  • 通信トレースの場合
    IPADDR=xx.xx.1.10 PROT=TCP PAP-NAME=DBPARTNER2 Runtime 00000a0c
     DATE       TIME        EVT      SIZE   DATA
 2008/09/02 15:23:28.98     PUT       164   Connection(0,0)
 2008/09/02 15:23:28.98     GET       148   Connect(Database)
 2008/09/02 15:23:29.18     PUT        64   Result(0,0)
 2008/09/02 15:23:29.18     GET       187   EXT-CMD <Prepare>
 2008/09/02 15:23:29.18     PUT       461   Result(0,0)
    IPADDR=XXXXXXXX
    EURのあるマシンのIPアドレスまたはホスト名
    PROT=XXX
    通信プロトコル
    TCP：TCP/IP
    PAP-NAME=XXXXXX
    UAP名
    帳票定義：「DBPODBC」＋「IPアドレス」
    帳票出力：「DBPARTNER2 Runtime」＋「実行プロセスID」
    DATE
    送受信の発生日付（年／月／日）
    TIME
    送受信の発生時刻（時:分:秒.n）
    nは100分の1秒を表します。
    EVT
    DABrokerでの事象区分
    ・PUT：リレーショナルデータベースからEURへの送信
    ・GET：EURからリレーショナルデータベースへの受信
    SIZE
    送受信データ長（単位：バイト）
    DATA
    送受信データ種別
    aa…aa <bb…bb>（cc…cc,dd…dd）の形式で出力されます。
    ・aa…aa：オペレーション種別※
    ・bb…bb：付加情報
    オペレーション種別が，LIST（xxxxx）およびEXT-CMDの場合に表示されます。
    ・cc…cc：リターンコード
    ・dd…dd：詳細コード
    注※
    表示されるオペレーション種別の意味を次の表に示します。

    表A-1　オペレーション種別の意味

    オペレーション種別 | 意味
    Connect（Database） | データベースとの接続要求
    Disconnect（Database） | データベースとの切り離し要求
    Disconnect（Connection） | コネクションの解放要求
    Commit | トランザクションのコミット要求
    Rollback | トランザクションのロールバック要求
    LIST（Table） | 表一覧取得要求
    LIST（Column） | 列一覧取得要求
    LIST（Index） | 索引一覧取得要求
    LIST（Table Privileges） | 表権限一覧取得要求
    LIST（Column Privileges） | 列権限一覧取得要求
    EXT-CMD | SQL文の実行要求
    SQL Fetch Option | SQL実行オプション実行
    File Delete | SQL実行結果格納ファイル削除
    Save | データベースへの表の保存要求
    Cancel | リレーショナルデータベースに対する処理の中断要求
    Illegal Request | 不正要求
    Connection | コネクション確立応答
    Result | 正常応答
    Error | 異常応答
    Result（Cancel） | 正常応答（リレーショナルデータベースに対する処理の中断要求時）
    Error（Cancel） | 異常応答（リレーショナルデータベースに対する処理の中断要求時）
    その他 | 説明省略
    注意
    クライアントからの要求量が多いほど，クライアントとの通信トレースのファイル容量も多くなります。通信トレースのファイル容量の目安として，概算式を次に示します。
    通信トレースのファイル容量（単位：バイト）＝80（ヘッダ情報長） + クライアントからの要求数 * 2 （PUTおよびGET分） * 36（PUTおよびGET情報長）
    あらかじめ，この概算式で計算したサイズ以上のハードディスク容量を用意しておいてください。また，クライアントからの要求量が多いほど，トレース出力が終わるまで時間が掛かります。ご注意ください。
  • アクセストレースの場合
    UID=EUR PAPNAME=DBPARTNER2 Runtime 00000a0c DBNAME=HiRDB
   DATE        TIME      EVT      RETCODE        INFORMATION
2008/09/02 15:23:28.98 CONNECT
2008/09/02 15:23:29.18 CONNECT          0
2008/09/02 15:23:29.18 PREPARE
 (SQL) SELECT "地区コード","商品コード","性別","天気","年齢","年月","売上数","単
       価","売上金額" FROM "EUR"."ZAIKO"
2008/09/02 15:23:29.18 PREPARE          0
2008/09/02 15:23:29.18 DESCRIBE
2008/09/02 15:23:29.18 DESCRIBE         0
2008/09/02 15:23:29.18 DESCRIBE
2008/09/02 15:23:29.18 DESCRIBE         0
2008/09/02 15:23:29.18 DESCRIBE
2008/09/02 15:23:29.18 DESCRIBE         0
2008/09/02 15:23:29.19 OPEN
2008/09/02 15:23:29.19 OPEN             0
2008/09/02 15:23:29.19 FETCH              BLOCK COUNT(1)
2008/09/02 15:23:29.19 FETCH            0 BLOCK COUNT(1)
    UID=XXXXXXXX
    ユーザID
    PAPNAME=XXXXXXX
    UAP名
    帳票定義：「DBPODBC」＋「IPアドレス」
    帳票出力：「DBPARTNER2 Runtime」＋「実行プロセスID」
    DBNAME=XXXXXXX
    接続先データベース名
    次のどれかが出力されます。
    ・HiRDB：HiRDBの場合です。
    ・Oracle7：Oracleの場合です。使用するOracleのバージョンに依存しません。
    ・ODBC3.0：Microsoft SQL Serverの場合です。
    DATE
    アクセスの発生日（年／月／日）
    TIME
    アクセスの発生時刻（時:分:秒.n）
    nは100分の1秒を表します。
    EVT
    DABrokerがデータベースに要求した処理の内容
    EVTの表示と対応する処理内容を次の表に示します。

    表A-2　EVTの表示と処理内容（DABrokerトレース出力ユティリティ）

    EVTの表示 | 処理内容
    CONNECT | データベースと接続します。
    PREPARE | SQLの前処理をします。
    DESCRIBE | 前処理したSQLの情報を返します。
    DECLARE | 前処理したSELECTに対してカーソルを宣言します。
    OPEN | カーソルを位置づけます。
    FETCH | 行を読み込んでカーソルを進めます。
    CLOSE | カーソルを閉じます。
    EXECUTE | 前処理したSQLを実行します。
    COMMIT | トランザクションを正常終了し，更新を有効にします。
    ROLLBACK | トランザクションを取り消し，更新を無効にします。
    DISCONNECT | トランザクションを正常終了し，切り離します。
    CANCEL | リレーショナルデータベースに対し，処理の中断をします。
    LOGGING | リレーショナルデータベースに対し，ログ取得要求します。ただし，HiRDBの場合だけです。
    LOGLESS | リレーショナルデータベースに対し，ログレス要求します。ただし，HiRDBの場合だけです。
    その他 | 説明省略
    データベースとのアクセストレースの取得内容は任意に選択できます。環境設定ユティリティの［アクセストレースの種類］で選択します。
    RETCODE
    DABrokerが要求した処理に対して，リレーショナルデータベースから返されるリターンコード。
    ・0：正常終了
    ・0以外：異常終了またはメッセージ付きの正常終了
    DABrokerからリレーショナルデータベースへの要求の送信を表示している行は，RETCODEは空白になります。
    INFORMATION
    FETCH時の行取得要求数および取得結果の情報
    SQL
    クライアントから要求のあったSQLの内容
    この項目は，Microsoft SQL Server使用時にEVTがPREPAREの場合にだけ出力されます。表示内容と意味を次の表に示します。

    表A-3　「SQL」への表示内容と意味

    表示内容 | 意味
    (SQL) ODBC:{SQLTables} | テーブル一覧情報
    (SQL) ODBC:{SQLColumns } | カラム一覧情報
    (SQL) ODBC:{SQLTablePrivileges} | テーブル権限一覧情報
    (SQL) ODBC:{SQLColumnPrivileges} | カラム権限一覧情報
    (SQL) ODBC:{SQLStatistics} | インデックス一覧情報
    (SQL) ODBC:{SQLPrimaryKeys} | プライマリキー一覧情報
    注意
    クライアントからの要求量（SQL文）が多いほど，アクセストレースのファイル容量も多くなります。トレースは，1レコード80バイトで表示されます。クライアントからの要求（SQL文）が多い場合は，折り返して表示します。アクセストレースのファイル容量の目安として，概算式を次に示します。
    アクセストレースのファイル容量（バイト）＝{(クライアントからの要求（SQL長など）* 2) + 2 [ +↓(クライアントからの要求SQL長/73)↓-1] } * 80
    注
    下線は，SQL長が73バイト以上の場合です。
    あらかじめ，この概算式で計算したサイズ以上のハードディスク容量を用意しておいてください。また，クライアントからの要求量が多いほど，トレース表示が終わるまで時間が掛かります。

(3)　拡張データベースアクセストレースユーティリティ

拡張データベースアクセストレースは，次のような場合に有効です。

  • データベースのアクセス中に障害が発生した時など，迅速に障害を切り分ける必要がある場合
  • 24時間稼働などのため，稼働中のアプリケーションを終了させないで障害を調査する必要がある場合
  • 障害の再現調査ができないため，常時トレースを取得する必要がある場合

ここでは，拡張データベースアクセストレースユティリティの機能，拡張データベースアクセストレースの取得方法，ファイル出力形式，ファイル名称および注意事項について説明します。

(a)　機能

拡張データベースアクセストレースでは，従来のDABrokerのアクセストレースに比べて，次の機能が拡張されています。

  • データベースへの接続ごと（接続から切断まで）にトレースを取得できます。
  • データベース接続中でも，トレースファイルの参照やコピーができます。
  • DABroker動作環境定義ファイルの設定によって，出力するイベントの種類を選択できます。
  • DABroker動作環境定義ファイルの設定によって，ファイルの最大容量を設定できます。トレース情報が最大容量を超える場合，最大2世代で取得ファイルを切り替えてトレースを取得できます。
(b)　拡張データベースアクセストレースの取得方法

拡張データベースアクセストレースの取得は，DABroker動作環境定義ファイルで設定します。DABroker動作環境定義ファイルでの設定方法については，マニュアル「DABroker」を参照してください。

(c)　ファイル出力形式

拡張データベースアクセストレースのファイル出力形式を次に示します。

ヘッダ情報
*-------------------------------------------------------*
*- DataBase Access Information (DRV)                   -*
*- Date  YYYY/MM/DD hh:mm:ss.nnnnnn                    -*
*-------------------------------------------------------*
DABroker Connect ID    : AAAAA(BBBBB)
Process ID             : CCCCC
UserID                 : DDDDD
Client Name            : EEEEE
(DB別出力情報)
Lang Mode              : GGGGG
個々のトレース情報
THREAD-ID  CID   EVT   START-TIME   END-TIME   RETCODE
BLOCKCNT   (SQL)

それぞれの出力項目について，次に説明します。

DRV
DABrokerのアクセスドライバの種別に従い，次の識別子が出力されます。

表A-4　アクセスドライバの種別と識別子

アクセスドライバの種別 | 識別子
HiRDB | HiRDB Driver
Oracle | ORACLE7 Driver
Microsoft SQL Server | ODBC30
Date
ファイル作成日時
YYYY/MM/DD hh:mm:ss.nnnnnnの形式で出力されます。
  • YYYY：西暦年
  • MM：月
  • DD：日
  • hh：時
  • mm：分
  • ss：秒
  • nnnnnn：マイクロ秒
DABroker Connect ID
データベース接続識別子が出力されます。
Process ID
実行プロセスIDが出力されます。
UserID
接続ユーザIDが出力されます。
Client Name
UAP名称が出力されます。
帳票定義：「DBPODBC」＋「IPアドレス」
帳票出力：「DBPARTNER2 Runtime」＋「実行プロセスID」
(DB別出力情報)
接続データベースによって異なる情報が出力されます。出力内容について次の表に示します。

表A-5　接続データベースごとのトレース出力内容

接続データベース 出力内容 説明
HiRDB PDHOST: HiRDB接続時のPDHOSTの設定内容です。未設定の場合は，"Not Indicator"が出力されます。
PDNAMEPORT: HiRDB接続時のPDNAMEPORTの設定内容です。未設定の場合は，"Not Indicator"が出力されます。
Oracle SQLNET: Oracleサービス（リスナー）名が出力されます。未設定の場合は，"Not Indicator"が出力されます。
Microsoft SQL Server ODBC Dara Sourcs: ODBC設定のデータソース名が出力されます。未設定の場合は，"Not Indicator"が出力されます。
ODBC Key Word: ODBC設定の接続情報が出力されます。未設定の場合は，"Not Indicator"が出力されます。
Lang Mode
実行言語モードが出力されます。
THREAD-ID
実行スレッドIDが出力されます。
CID
カーソル番号が出力されます。
EVT
DABrokerがデータベースに要求した処理の内容です。内容の種類は任意に選択できます。拡張データベースアクセストレースで表示の種類を変更すると，従来のアクセストレース表示の種類も変更されます。
すべての表示をOFFにした場合はヘッダだけが出力されます。
従来のアクセストレースにはないEVTの表示とその処理内容を次に示します。表示を一つでもONにした場合，GET_DIAGの表示を抑止できません。

表A-6　EVTの表示と処理の内容（拡張データベースアクセストレースユティリティ）

EVTの表示 | 処理内容
DESC_OUT | 前処理したSQLの出力情報を返します。
DESC_IN | 前処理したSQLの入力情報を返します。
GET_DIAG | エラー詳細情報の取得処理を実行します。
BIND | パラメタのバインド要求を実行します。
DEFINE | パラメタの定義要求を実行します。
DESALLOC | 記述子の領域確保を実行します。
DESFREE | 記述子の領域解放を実行します。
ERRGET | エラー情報取得要求を実行します。
HDLALLOC | ハンドルの領域確保を実行します。
HEDLFREE | ハンドルの領域解放を実行します。
その他 | 省略
START-TIME
アクセス開始日時
YYYY/MM/DD hh:mm:ss.nnnnnnの形式で出力されます。
  • YYYY：西暦年
  • MM：月
  • DD：日
  • hh：時
  • mm：分
  • ss：秒
  • nnnnnn：マイクロ秒
END-TIME
アクセス終了日時
YYYY/MM/DD hh:mm:ss.nnnnnnの形式で出力されます。
  • YYYY：西暦年
  • MM：月
  • DD：日
  • hh：時
  • mm：分
  • ss：秒
  • nnnnnn：マイクロ秒
RETCODE
データベースから返されるリターンコードが出力されます。
BLOCKCNT
FETCH時の行取得件数が出力されます。
(SQL)
クライアントから要求のあったSQLの内容が出力されます。この項目は，必要に応じて出力されます。
(d)　ファイル名称

拡張データベースアクセストレースのファイルは，次のディレクトリに作成されます。

DABroker運用ディレクトリ\spool\db_access

拡張データベースアクセストレースのファイル名称は，次の規則に従います。

spdb_XXXXXXXX_YYYYYYYY_****ZZZZZ.IIIIII
  • XXXXXXXX：実行プロセスID※1
  • YYYYYYYY：データベース接続識別子
  • ****：接続データベース名称※2
  • ZZZZZ：識別順序番号
  • IIIIII：ファイル拡張子
    • log：最新のトレースファイル
    • logold：1世代前のトレースファイル
注※1
同じプロセスIDで，かつ同じデータベース接続識別子のファイルがある場合に，00000から32767までの番号を付けます。
注※2
接続データベースの名称とその識別子を次に示します。

表A-7　接続データベース名称と識別子

接続データベース名称 | 識別子
HiRDB | HiRDB Driver
Oracle | ORACLE7 Driver
Microsoft SQL Server | ODBC30
注意
拡張データベースアクセストレースのファイルを運用する際には，次の点に注意してください。
  • 拡張データベースアクセストレースは，出力した行数がDABroker動作環境定義ファイルでの設定行数を超えると，現在のトレースファイルがバックアップファイルとして別名で保存されます。トレース内容は，トレースファイルの先頭から再び出力されます。
  • バックアップファイルは1世代前までしか残しません。このため，現在のトレースファイルが設定した行数を超えると，既存のバックアップファイルは上書きされます。既存のバックアップファイルを保存する必要がある場合は，上書きされる前に別のディレクトリに退避してください。
  • トレースファイルは実行しているコネクションの数だけ作成されます。
  • トレースファイルは自動的に削除されません。ユーザが不要になった時点で削除してください。
  • ハードディスクの空き容量が不十分な場合，トレースの出力が停止されることがあります。

(4)　DABrokerメッセージログビューア

DABrokerメッセージログビューアの機能，操作できるユーザ，DABrokerのログを表示する操作手順について説明します。

(a)　機能

DABrokerのログファイルの出力内容を参照できます。

(b)　操作できるユーザ

すべてのユーザがDABrokerトレース出力ユティリティを実行できます。

(c)　DABrokerのログを表示する操作手順

DABrokerのログを表示する操作手順を次に示します。

  1. プログラムフォルダに登録された［DABroker］から［メッセージログビューア］を選択する
    DABrokerメッセージログビューアが起動します。 [図データ] をクリックすると，最新のログに表示が更新されます。

    図A-3　DABrokerメッセージログビューア


DABrokerの詳細コード，要求コード，および応答コード

付録B　DABrokerの詳細コード，要求コード，および応答コード

ここでは，DABrokerのメッセージ中に出力される詳細コード，要求コード，および応答コードについて説明します。

＜この節の構成＞
付録B.1　DABrokerの詳細コード
付録B.2　DABrokerの要求コードおよび応答コード


DABrokerの詳細コード

付録B.1　DABrokerの詳細コード

DABrokerが出力するエラーメッセージの詳細コードを次に示します。

表B-1　 DABrokerの詳細コード

詳細コード | 要因 | 対策
-12001 | このタイミングではキャンセル要求は受け付けられません。 | キャンセル要求が受け付けられるタイミングになってから，要求してください。キャンセル要求が受け付けられるのは，データベース接続完了から，データベース切り離し要求受け付けまでです。
-16002 | このバージョン，またはDBMSでサポートされていない要求を受け付けました。 | DABroker，または接続先のDBMSを確認してください。
-16004 | DABrokerが動作できる環境ではありません。 | DABrokerをインストールした環境を見直して，エラー要因を取り除いてください。
その他負のコード | DABrokerシステムで異常が発生しました。 | 保守員に連絡してください。


DABrokerの要求コードおよび応答コード

付録B.2　DABrokerの要求コードおよび応答コード

DABrokerからの要求コードおよび応答コードを次に示します。

表B-2　 DABrokerの要求コードおよび応答コード

要求コード / 応答コード | 種別
1001 | コネクション解放
1002 | データベース接続
1003 | データベース切り離し
1004 | Commit
1005 | Rollback
1006 | 表一覧取得準備
1007 | 表一覧取得
1008 | 表一覧取得後処理
1009 | 列一覧取得準備
1010 | 列一覧取得
1011 | 列一覧取得後処理
1012 | 索引一覧取得準備
1013 | 索引一覧取得
1014 | 索引一覧取得後処理
1015 | 表権限一覧取得準備
1016 | 表権限一覧取得
1017 | 表権限一覧取得後処理
1018 | 列権限一覧取得準備
1019 | 列権限一覧取得
1020 | 列権限一覧取得後処理
1021 | SQL実行準備
1022 | SQL実行
1023 | SQL実行結果取得
1024 | SQL実行後処理
1035 | SQL実行結果取得オプション
1037 | プライマリキー一覧取得準備
1038 | プライマリキー一覧取得
1039 | プライマリキー一覧取得後処理
1041 | 自動Commit設定
1042 | 自動Commit解除
2001 | 正常応答
2002 | 異常応答


このマニュアルの参考情報

付録C　このマニュアルの参考情報

このマニュアルを読むに当たっての参考情報を示します。

＜この節の構成＞
付録C.1　関連マニュアル
付録C.2　EUR バージョン9での製品体系の変更
付録C.3　EUR バージョン9でのマニュアル体系の変更
付録C.4　このマニュアルでの表記
付録C.5　このマニュアルで使用する略語
付録C.6　KB（キロバイト）などの単位表記について


関連マニュアル

付録C.1　関連マニュアル

関連マニュアルを次に示します。必要に応じてお読みください。

＜この項の構成＞
(1)　EURのマニュアル
(2)　関連ソフトウェアのマニュアル
(3)　このマニュアルでのマニュアル名表記

(1)　EURのマニュアル

EURの関連マニュアルを次に示します。

  • はじめての帳票作成（3020-7-532）※
    EUR 帳票作成機能をまだ使用したことのない人向けに，簡単な帳票を作成する方法について説明しています。
  • uCosminexus EUR システム設計ガイド（3020-7-702）
    EURを使用した帳票システムの計画・設計時に検討が必要な内容について説明しています。
  • uCosminexus EUR システム構築ガイド（3020-7-703）
    EURを使用した帳票システムを構築する手順について説明しています。
  • uCosminexus EUR 帳票設計（3020-7-533）※
    EUR 帳票作成機能を使用して帳票を作成する方法について説明しています。
  • uCosminexus EUR 帳票作成 画面リファレンス（3020-7-705）
    EUR 帳票作成機能で表示されるダイアログの内容について説明しています。
  • uCosminexus EUR 帳票設計（EUR Form帳票）（3020-7-534）※
    EUR Form帳票作成機能を使用してEUR Form帳票を作成する方法について説明しています。
  • uCosminexus EUR クライアント帳票出力（3020-7-535）※
    EUR クライアント帳票出力機能を使用してクライアント環境で帳票を出力する方法について説明しています。
  • uCosminexus EUR 帳票出力 機能解説 EUR Server編（3020-7-708）
    EUR サーバ帳票出力機能を使って帳票を出力する方法について説明しています。
  • uCosminexus EUR 帳票出力 リファレンス EUR Server編（3020-7-710）
    EUR サーバ帳票出力機能を使って帳票を出力するときに使用するAPIや入力ファイルの設定方法について説明しています。
  • uCosminexus EUR サーバ帳票出力（3020-7-536）※
    EUR ServerのV8互換機能を使用して，サーバ環境で帳票を出力する方法について説明しています。
  • uCosminexus EUR メッセージ（3020-7-714）
    EURを使用しているときに出力されるメッセージについて説明しています。
  • uCosminexus EUR 用語集（3020-7-715）
    EURシリーズマニュアル内で使用する用語について説明しています。なお，この用語集は日立ソフトウェアマニュアル公開サイト，または製品同梱のヘルプ（Windows版）だけで参照できます。
注※
バージョン8のマニュアルを提供しています。バージョン9の製品に置き換えて参照してください。

(2)　関連ソフトウェアのマニュアル

関連ソフトウェアのマニュアルを次に示します。

  • TPBroker ユーザーズガイド（3000-3-660）
  • TPBroker Developer's Kit - Extension for C++ プログラマーズガイド（3000-3-680）
  • TPBroker Object Transaction Monitor ユーザーズガイド（3000-3-689）
  • COBOL2002　使用の手引　手引編（3000-3-D42）
  • COBOL2002　使用の手引　操作編（3000-3-D43）
  • COBOL2002　操作ガイド（3020-3-D47）
  • COBOL2002　ユーザーズガイド（3020-3-D48）
  • SEWB+/REPOSITORY 辞書設計ガイド（3020-3-698）
  • SEWB+/REPOSITORY 辞書設計ガイド（3020-3-N82）
  • DBPARTNER2 Client　操作ガイド（3020-6-027）
  • DABroker（3020-6-031）
  • HiRDB Version 8 UAP開発ガイド（3020-6-356）
  • HiRDB Version 8 メッセージ（3020-6-358）
  • HiRDB Version 9 UAP開発ガイド（3020-6-456）
  • HiRDB Version 9 メッセージ（3020-6-458）

(3)　このマニュアルでのマニュアル名表記

このマニュアルでは，マニュアル名について，次のように表記しています。

マニュアル名 | 表記
uCosminexus EUR システム設計ガイド | EUR システム設計ガイド
uCosminexus EUR システム構築ガイド | EUR システム構築ガイド
uCosminexus EUR 帳票作成 画面リファレンス | EUR 帳票作成 画面リファレンス
uCosminexus EUR 帳票出力 機能解説 EUR Server編 | EUR 帳票出力 機能解説 EUR Server編
uCosminexus EUR 帳票出力 リファレンス EUR Server編 | EUR 帳票出力 リファレンス EUR Server編
uCosminexus EUR データベース連携ガイド | EUR データベース連携ガイド
uCosminexus EUR メッセージ | EUR メッセージ
uCosminexus EUR 用語集 | EUR 用語集
uCosminexus EUR 帳票設計 | EUR 帳票設計
uCosminexus EUR 帳票設計（EUR Form帳票） | EUR 帳票設計（EUR Form帳票）
uCosminexus EUR クライアント帳票出力 | EUR クライアント帳票出力
uCosminexus EUR サーバ帳票出力 | EUR サーバ帳票出力
HiRDB Version 8 UAP開発ガイド HiRDB Version 9 UAP開発ガイド | HiRDB UAP開発ガイド
HiRDB Version 8 メッセージ HiRDB Version 9 メッセージ | HiRDB メッセージ


EUR バージョン9での製品体系の変更

付録C.2　EUR バージョン9での製品体系の変更

EUR バージョン9での製品体系の変更について，次の図に示します。


EUR バージョン9でのマニュアル体系の変更

付録C.3　EUR バージョン9でのマニュアル体系の変更

EUR バージョン9では，マニュアル体系を次の表に示す各使用目的に合わせて次のとおり変更しました。

EUR バージョン8 | EUR バージョン9
次のマニュアルの，システム計画・設計に関連する部分
  • EUR 概説
  • EUR 帳票設計
  • EUR クライアント帳票出力
  • EUR サーバ帳票出力
  • EUR Print Manager 帳票出力
 EUR システム設計ガイド
次のマニュアルの，システム構築に関連する部分
  • EUR 帳票設計
  • EUR クライアント帳票出力
  • EUR サーバ帳票出力
  • EUR Print Manager 帳票出力
 EUR システム構築ガイド
EUR 帳票設計（第5編） | EUR 帳票作成 画面リファレンス
次のマニュアルの，機能概要を説明している部分，およびコーディング例
  • EUR サーバ帳票出力
  • EUR Print Manager 帳票出力
 EUR 帳票出力 機能解説 EUR Server編
次のマニュアルの，各APIや入力ファイルの設定値を説明している部分
  • EUR サーバ帳票出力（7章のリファレンス部分）
  • EUR Print Manager 帳票出力（8～15章）
 EUR 帳票出力 リファレンス EUR Server編
次のマニュアルの，データベースから抽出したデータを使って帳票を作成および出力する方法を説明している部分
  • EUR 帳票設計
  • EUR クライアント帳票出力
  • EUR サーバ帳票出力
  • EUR メッセージ
 EUR データベース連携ガイド

  • EUR メッセージ
  • EUR Print Manager メッセージ
 EUR メッセージ

  • EUR 概説（付録A）
  • EUR Print Manager 帳票出力（付録H）
 EUR 用語集


このマニュアルでの表記

付録C.4　このマニュアルでの表記

このマニュアルでは，uCosminexus EURの各製品について，次のように表記しています。

表記 |  | 製品名称
EUR Client |  | uCosminexus EUR Client
EUR Designer |  | uCosminexus EUR Designer
EUR Developer |  | uCosminexus EUR Developer
EUR Viewer |  | uCosminexus EUR Viewer
EUR Server | EUR Server Enterprise | uCosminexus EUR Server Enterprise
 | EUR Server Standard | uCosminexus EUR Server Standard
 | EUR Server Print Edition | uCosminexus EUR Server Print Edition
EUR Server - Cipher option |  | uCosminexus EUR Server - Cipher option
EUR Form | EUR Form Service | uCosminexus EUR Form Service
EUR Form Service - Data Store option |  | uCosminexus EUR Form Service - Data Store option

uCosminexus EUR以外の製品名称などについては，次のように表記しています。

表記 |  | 製品名称
COBOL |  | COBOL2002
DABroker |  | DABroker 03-17以降 DABroker 03-21以降 DABroker(64) 03-20以降 DABroker(64) 03-21以降
HiRDB |  | HiRDB/Run Time Version 8 08-00 以降 HiRDB/Developer's Kit Version 8 08-00 以降 HiRDB/Run Time Version 8(64) 08-00 以降 HiRDB/Developer's Kit Version 8(64) 08-00 以降 HiRDB/Run Time Version 9 09-00以降 HiRDB/Developer's Kit Version 9 09-00以降 HiRDB/Developer's Suite Version 9 09-00以降 HiRDB/Run Time Version 9(64) 09-00以降 HiRDB/Developer's Kit Version 9(64) 09-00以降 HiRDB Server Version 9 09-00以降 HiRDB Server with Additional Function Version 9 09-00以降
IPF |  | Itanium(R) Processor Family
Linux | Linux(R) | Red Hat Enterprise Linux Server 6 (64-bit x86_64)
Oracle | Oracle 10g | Oracle 10g 10.1.0 Oracle 10g 10.2.0
 | Oracle 11g | Oracle Database 11g 11.1.0 Oracle Database 11g R2 11.2.0
SEWB+ |  | Software Engineering Workbench+
uCosminexus Application Server |  | uCosminexus Application Server Enterprise
 |  | uCosminexus Application Server Standard
UNIX | AIX | AIX V6.1 AIX V7.1
 | HP-UX | HP-UX 11i V3(IPF)

このほか，このマニュアルでは，次に示す表記を使用しています。

  • EURの各製品を区別する必要がない場合は，総称してEURと表記します。
  • EUR Designer，EUR Developerの帳票作成機能を「EUR 帳票作成機能」と表記します。
  • EUR DeveloperのEUR Form帳票作成機能を「EUR 帳票作成機能（EUR Form帳票）」と表記します。
  • EUR Designer，EUR Developer，EUR Viewerのクライアント環境での帳票出力機能を「EUR クライアント帳票出力機能」と表記します。
  • EUR Developer，EUR Server Enterprise，EUR Server Standard，EUR Server Print Editionのサーバ環境での帳票出力機能を「EUR サーバ帳票出力機能」と表記します。


このマニュアルで使用する略語

付録C.5　このマニュアルで使用する略語

このマニュアルで使用する英略語を次に示します。

英略語 | 英字での表記
API | Application Programming Interface
ASP | Active Server Pages
BOM | Byte Order Mark
COBOL | COmmon Business Oriented Language
CPI | Characters Per Inch
CSV | Comma Separated Value
DLL | Dynamic Linking Library
DPI | Dot Per Inch
EJB | Enterprise JavaBeans
EMF | Enhanced Metafile
EOF | End Of File
EUR | End-User Reporting
GIF | Graphics Interchange Format
GUI | Graphical User Interface
HTTP | Hyper Text Transfer Protocol
ID | IDentifier
IPF | Itanium(R) Processor Family
ISO | International Organization for Standardization
JDK | JavaTM Development Kit
JIS | Japanese Industrial Standards
JPEG | Joint Photographic Experts Group
JSP | Java Server Pages
LAN | Local Area Network
LIPS | LBP Image Processing System
LPI | Lines Per Inch
MFC | Microsoft Foundation Class
MIME | Multipurpose Internet Mail Extension
MSI | Microsoft Windows Installer
MUI | Multi User Interface
OCR | Optical Character Reader
OCX | OLE Custom Control (OLE Control eXtension)
ODBC | Open Database Connectivity
OLE | Object Linking and Embedding
PCF | Portable Compiled Format
PDF | Portable Document Format
PDL | Page Description Language
RPM | RPM Package Manager
TIFF | Tagged Image File Format
UAP | User Application Program
WAN | Wide Area Network
XML | eXtensible Mark-up Language


KB（キロバイト）などの単位表記について

付録C.6　KB（キロバイト）などの単位表記について

1KB（キロバイト），1MB（メガバイト），1GB（ギガバイト），1TB（テラバイト）はそれぞれ1,024バイト，1,0242バイト，1,0243バイト，1,0244バイトです。


索引

[Ｂ][Ｄ][Ｅ][Ｈ][Ｉ][Ｌ][Ｎ][Ｏ][Ｓ][Ｗ]
[ア行][カ行][サ行][タ行][ハ行][マ行][ヤ行][ラ行]

(英字)

(Ｂ)
BETWEEN条件〔データの抽出〕
［BETWEEN条件式］ダイアログ
(Ｄ)
DABroker管理ユティリティ
DABrokerトレース出力ユティリティ
DABrokerの起動中に使用できるユティリティ
DABrokerの起動と終了
DABrokerの利用
DABrokerメッセージログビューア
DBPARTNER ODBC Driver
(Ｅ)
EUR ODBC Driver
［EUR ODBC Driver - 環境定義 -］ダイアログ
［EUR ODBC Driver - セットアップ -］ダイアログ
EURで使用できるデータベース
(Ｈ)
HiRDBと接続する場合〔データベースへ接続するときの注意事項〕
(Ｉ)
IN条件〔データの抽出〕
［IN条件式］ダイアログ
(Ｌ)
LIKE条件〔データの抽出〕
(Ｎ)
NULL条件〔データの抽出〕
(Ｏ)
ODBC Driver
ODBCデータソースの設定
Oracleと接続する場合〔データベースへ接続するときの注意事項〕
(Ｓ)
SQL
SQL Serverと接続する場合〔データベースへ接続するときの注意事項〕
(Ｗ)
WHERE句に指定できる条件〔データの抽出〕

(ア行)

(あ)
アクセストレース
(う)
内結合
(お)
［オプション設定］ダイアログ

(カ行)

(か)
拡張データベースアクセストレースユティリティ
［格納先の指定］ダイアログ
仮想列の設定
［仮想列編集］ダイアログ
可変記号値
可変記号値定義ファイル
可変記号値定義ファイルの形式
可変記号値定義ファイルの指定例
［可変記号入力］ダイアログ
(き)
起動
(く)
グループ分けの設定

(サ行)

(さ)
最新列情報の取得
(し)
［辞書一覧表示方法の設定］ダイアログ
［辞書の指定］ダイアログ
［実行値入力］ダイアログ
［集合関数設定］ダイアログ
集合関数の設定
出力されるファイル〔パスワードの暗号化（接続情報）〕
［条件式直接入力］ダイアログ
［条件設定］ダイアログ
条件の設定〔データの抽出〕
詳細情報
(せ)
接続情報パスワード暗号化ツール
接続情報ファイル
接続情報ファイルのキーワード
接続情報ファイルの形式
接続情報ファイルの指定例
前提環境
データベース〔前提環境〕
(そ)
［ソート設定］ダイアログ
ソートの設定

(タ行)

(ち)
抽出したデータが表示されるときの規則
抽出データの確認
(つ)
通信トレース
(て)
データウィンドウへの表示
データの抽出
データ表示ウィンドウ
データベース
BETWEEN条件〔データの抽出〕
EURで使用できるデータベース
IN条件〔データの抽出〕
LIKE条件〔データの抽出〕
NULL条件〔データの抽出〕
WHERE句に指定できる条件〔データの抽出〕
内結合
仮想列の設定
グループ分けの設定
最新列情報の取得
集合関数の設定
条件の設定〔データの抽出〕
ソートの設定
抽出したデータが表示されるときの規則
抽出データの確認
データウィンドウへの表示
データベースからデータを抽出する
データベースに再接続する
データベースに接続する
データベースの接続設定の流れ
データベースの接続の概要
データベースのデータ型とEURで扱えるデータ種別との対応
比較条件〔データの抽出〕
表結合〔データの抽出〕
表結合条件の設定
表結合条件を削除する
表結合条件を変更する
表の選択
複数の表からのデータ抽出
見出し辞書の削除
見出し辞書の作成
見出し辞書の使用
見出し辞書の設定
見出し辞書の編集
列演算条件〔データの抽出〕
列の設定
列の追加
データベース〔前提環境〕
データベースアクセス定義ウィンドウ
データベースからデータを抽出する
データベースに再接続する
データベースに接続する
データベースの接続
データベースの接続設定の流れ
データベースの接続の概要
データベースのデータ型とEURで扱えるデータ型
データベースのデータ型とEURで扱えるデータ種別との対応

(ハ行)

(は)
パスワード暗号化ツール〔接続情報〕
パスワードの暗号化〔接続情報〕
パスワードを暗号化する方法〔接続情報〕
(ひ)
比較条件〔データの抽出〕
比較できる列属性の組み合わせ
［表一覧表示方法の設定］ダイアログ
表結合
［表結合条件］ダイアログ
表結合条件の設定
表結合条件を削除する
表結合条件を変更する
［表選択］ダイアログ
表の絞り込み
［表の絞り込み条件設定］ダイアログ
表の選択〔データベース〕
(ふ)
複数の表からのデータ抽出
(ほ)
ポート番号の登録

(マ行)

(み)
見出し辞書の削除
見出し辞書の作成
見出し辞書の使用
見出し辞書の設定
見出し辞書の編集
［見出し選択］ダイアログ
［見出し編集］ダイアログ

(ヤ行)

(よ)
［読み込み先の指定］ダイアログ

(ラ行)

(れ)
列演算条件〔データの抽出〕
［列演算条件式］ダイアログ
［列設定］ダイアログ
列属性〔表結合〕
列属性ごとの使用できる集合関数
列と定数の規則
列の設定
列の追加