uCosminexus EUR 帳票出力 リファレンス EUR Server編 - 目次

uCosminexus EUR 帳票出力 リファレンス EUR Server編

文法・操作書

3020-7-710-30

目　　次

前書き
変更内容
はじめに
第1編　帳票出力で使用するコマンド
1.　eurpmcコマンド
1.1　eurpmcコマンドとは
1.1.1　eurpmcコマンドのファイル名
1.2　eurpmcコマンドが提供するオプション
1.2.1　メソッドオプション一覧
1.2.2　プロパティオプション一覧
1.2.3　オプションを指定するときの注意
1.3　eurpmcコマンドの構文
1.3.1　プリンタに出力する場合
1.3.2　スプールデータを出力する場合
1.3.3　EPF形式ファイルを出力する場合
1.3.4　複数のEPF形式ファイルを統合して出力する場合
1.3.5　EUR形式ファイルを出力する場合
1.3.6　PDF形式ファイルを出力する場合
1.3.7　Excel形式ファイルを出力する場合
1.3.8　出力先一覧を取得する場合
1.3.9　プリンタクラス一覧を取得する場合
1.3.10　プリンタ一覧を取得する場合
1.3.11　トレイ一覧を取得する場合
1.3.12　帳票サーバプリンタクラス一覧を取得する場合
1.3.13　帳票サーバプリンタ一覧を取得する場合
1.3.14　帳票サーバプリンタのトレイ一覧を取得する場合
1.4　エラー情報
1.4.1　eurpmcコマンドの終了コード
1.4.2　エラーメッセージのフォーマット
2.　eurpmlscコマンド
2.1　eurpmlscコマンドとは
2.1.1　eurpmlscコマンドのファイル名
2.2　eurpmlscコマンドが提供するオプション
2.2.1　メソッドオプション一覧
2.2.2　プロパティオプション一覧
2.2.3　オプションを指定するときの注意
2.3　eurpmlscコマンドの構文
2.3.1　スプールデータの一覧を取得する場合
2.3.2　スプールデータの属性値を取得する場合
2.3.3　スプールデータの属性値を変更する場合
2.3.4　スプールデータを蓄積データ印刷する場合
2.3.5　スプールデータを取得する場合
2.3.6　スプールデータを削除する場合
2.3.7　プリンタクラス一覧を取得する場合
2.3.8　プリンタ一覧を取得する場合
2.3.9　トレイ一覧を取得する場合
2.3.10　監査ログを切り替える場合
2.4　エラー情報
2.4.1　eurpmlscコマンドの終了コード
2.4.2　エラーメッセージのフォーマット
3.　eurpmcepfviewerコマンド
3.1　eurpmcepfviewerコマンドとは
3.1.1　eurpmcepfviewerコマンドのファイル名
3.1.2　オプション一覧
3.1.3　オプションを指定するときの注意
3.2　eurpmcepfviewerコマンドの構文
3.2.1　帳票を自動印刷する場合
3.2.2　帳票をプレビュー表示する場合
3.3　エラー情報
4.　BSP-RM連携コマンド
4.1　BSP-RM連携コマンドとは
4.1.1　BSP-RM連携コマンドのファイル名
4.2　BSP-RM連携コマンドの構文
4.3　エラー情報
4.3.1　BSP-RM連携コマンドの終了コード
4.3.2　エラーメッセージのフォーマット
第2編　帳票出力で使用するAPI
5.　EUR Web Plug-In
5.1　EUR Web Plug-Inとは
5.1.1　ファイル名
5.1.2　EUR Web Plug-Inの使用方法
5.2　パラメタ，メソッド，プロパティ一覧
5.2.1　パラメタ一覧
5.2.2　メソッド一覧
5.2.3　プロパティ一覧
5.2.4　イベント一覧
5.2.5　指定値に使用できない文字について
5.3　パラメタ仕様
DefaultPrintDlgパラメタ
EPFDataMaxSizeパラメタ
EPFFileURLパラメタ
EPFTempDataModeパラメタ
LogFileパラメタ
LogLevelパラメタ
LogSizeパラメタ
NoPrintパラメタ
NoSetPrinterDlgパラメタ
PrintEndPageパラメタ
PrinterNameパラメタ
PrintStartPageパラメタ
SelectDisplayPrinterパラメタ
SendResultURLパラメタ
ShowScrollBarパラメタ
TempFileDelパラメタ
TrayNameパラメタ
UserParamパラメタ
Zoomパラメタ
5.4　メソッド仕様
Findメソッド
FindNextメソッド
HScrollメソッド
PrintEPFメソッド
TurnPageメソッド
VScrollメソッド
Zoomメソッド
5.5　プロパティ仕様
CurrentPageプロパティ
ExclusionPrinterDriverプロパティ
ExclusionPrinterNameプロパティ
PermissionPrinterDriverプロパティ
PermissionPrinterNameプロパティ
SelectDisplayPrinterプロパティ
TotalPageプロパティ
5.6　イベント仕様
PageChangedイベント
5.7　タグの記述例
6.　ActiveX起動部品
6.1　ActiveX起動部品とは
6.1.1　ファイル名
6.1.2　プログラムIDとコントロール名
6.1.3　提供するクラス
6.1.4　構文
6.2　ActiveX起動部品のメソッドとプロパティ
6.2.1　メソッド一覧
6.2.2　プロパティ一覧（出力メソッド）
6.2.3　プロパティ一覧（情報取得メソッド）
6.2.4　指定値に使用できない文字について
6.3　ActiveX起動部品のメソッド仕様
GetDestinationListメソッド
GetJobIDメソッド
GetJobIDListメソッド
GetPMPrinterClassListメソッド
GetPMPrinterListメソッド
GetPMTrayListメソッド
GetPreviewAXClassIDメソッド
GetPreviewAXVersionメソッド
GetPrintAXClassIDメソッド
GetPrintAXVersionメソッド
GetPrinterClassListメソッド
GetPrinterListメソッド
GetTrayListメソッド
OutputEPFReportメソッド
OutputEURReportメソッド
OutputMergeEPFReportメソッド
OutputPDFReportメソッド
OutputXLSXReportメソッド
PrintPMReportメソッド
6.4　ActiveX起動部品のプロパティ仕様
BookmarkFileNameプロパティ
BookmarkFilePathプロパティ
ClientAddressプロパティ
ClientPrinterNameプロパティ
ClientTrayNameプロパティ
Cryptoプロパティ
CryptoFileNameプロパティ
CryptoFilePathプロパティ
DataFileNameプロパティ
DataFilePathプロパティ
DBInfoFileNameプロパティ
DBInfoFilePathプロパティ
DestinationNameプロパティ
DispPrintDlgプロパティ
DistributeFileNameプロパティ
DistributeFilePathプロパティ
DocBookmarkFileNameプロパティ
DocInfoFileNameプロパティ
DocInfoFilePathプロパティ
EnableGetプロパティ
EncryptionPasswordKeyプロパティ
EPFFileNameプロパティ
EPFFilePathプロパティ
EURFileNameプロパティ
EURFilePathプロパティ
ExecutablePrintModeプロパティ
FileOutputDestinationプロパティ
FirstPageNumberプロパティ
GroupNameプロパティ
InitPageNumberプロパティ
JobKeyCategoryプロパティ
JobKeyDataプロパティ
MaxPrintCountプロパティ
MergeEPFFileNameプロパティ
MergeEPFFilePathプロパティ
MultiFormInfoDefFileNameプロパティ
MultiFormInfoDefFilePathプロパティ
MultiReportSetFileNameプロパティ
MultiReportSetFilePathプロパティ
PageNumberFormatプロパティ
PageNumberLocationプロパティ
PaperOrientationプロパティ
PDFFileNameプロパティ
PDFFilePathプロパティ
PMServerAddressプロパティ
PMServerPortプロパティ
PrintCopiesプロパティ
PrintDateFileNameプロパティ
PrintDateFilePathプロパティ
PrintEndPageプロパティ
PrinterClassNameプロパティ
PrinterSelectModeプロパティ
PrintHoldModeプロパティ
PrintKindプロパティ
PrintModeプロパティ
PrintPageNumberプロパティ
PrintStartPageプロパティ
PSEnvFileNameプロパティ
PSEnvFilePathプロパティ
ReplaceItemCntlFileNameプロパティ
ReplaceItemCntlFilePathプロパティ
ReportAddressKeyCategoryプロパティ
ReportAddressKeyDataプロパティ
ReportFileNameプロパティ
ReportFilePathプロパティ
ScriptCntlFileNameプロパティ
ScriptCntlFilePathプロパティ
ServerAddressプロパティ
ServerPrinterNameプロパティ
ServerSelectModeプロパティ
ServerTrayNameプロパティ
SortPrintプロパティ
SplitFileNameプロパティ
SplitFilePathプロパティ
SplitModeプロパティ
SpoolFileNameプロパティ
SpoolLimitプロパティ
SpoolTitleプロパティ
UserDataFileNameプロパティ
UserDataFilePathプロパティ
ViewerPreferenceFileNameプロパティ
ViewerPreferenceFilePathプロパティ
XLSXFileNameプロパティ
XLSXFilePathプロパティ
6.5　エラー情報
6.5.1　ActiveX起動部品実行時のエラー情報一覧
6.5.2　Err.Numberプロパティ（終了コード）
6.5.3　Err.Descriptionプロパティ（メッセージ文）
7.　SS-ActiveX起動部品
7.1　SS-ActiveX起動部品とは
7.1.1　ファイル名
7.1.2　プログラムIDとコントロール名
7.1.3　提供するクラス
7.1.4　構文
7.2　SS-ActiveX起動部品のメソッドとプロパティ
7.2.1　メソッド一覧
7.2.2　プロパティ一覧
7.2.3　指定値に使用できない文字について
7.3　SS-ActiveX起動部品のメソッド仕様
ChangeAuditLogメソッド
DeleteSpoolFileメソッド
GetPrinterClassListメソッド
GetPrinterListメソッド
GetSpoolFileメソッド
GetSpoolFileAttributeメソッド
GetSpoolFileOutlineメソッド
GetTrayListメソッド
Initializeメソッド
PrintSpoolReportメソッド
SetSpoolFileAttributeメソッド
7.4　SS-ActiveX起動部品のプロパティ仕様
ClientAddressプロパティ
ClientPrinterNameプロパティ
ClientTrayNameプロパティ
CreateIPAddressプロパティ
CreateLSVersionプロパティ
CreateTimeプロパティ
DeleteKindプロパティ
DispPrintDlgプロパティ
EnableGetプロパティ
ExecPrintCountプロパティ
ExecutablePrintModeプロパティ
GroupNameプロパティ
JobIDプロパティ
JobKeyCategoryプロパティ
JobKeyDataプロパティ
MaxPrintCountプロパティ
OutputFileNameプロパティ
OutputFilePathプロパティ
PageNumプロパティ
PaperOrientationプロパティ
PrintCopiesプロパティ
PrintEndPageプロパティ
PrinterClassListプロパティ
PrinterClassNameプロパティ
PrinterSelectModeプロパティ
PrintModeプロパティ
PrintResultプロパティ
PrintStartPageプロパティ
PrintTimeプロパティ
ReportAddressKeyCategoryプロパティ
ReportAddressKeyDataプロパティ
SearchCreateTimeEndプロパティ
SearchCreateTimeStartプロパティ
SearchJobIDプロパティ
SearchJobKeyCategoryプロパティ
SearchJobKeyDataプロパティ
SearchPrinterClassNameプロパティ
SearchReportAddressKeyCategoryプロパティ
SearchReportAddressKeyDataプロパティ
SearchSpoolFileNameプロパティ
ServerAddressプロパティ
ServerPrinterListプロパティ
ServerPrinterNameプロパティ
ServerTrayListプロパティ
ServerTrayNameプロパティ
SortPrintプロパティ
SpoolFileNameプロパティ
SpoolFileSizeプロパティ
SpoolHistoryプロパティ
SpoolLimitプロパティ
SpoolPathプロパティ
SpoolTitleプロパティ
7.5　エラー情報
7.5.1　SS-ActiveX起動部品実行時のエラー情報一覧
7.5.2　Err.Numberプロパティ（終了コード）
7.5.3　Err.Descriptionプロパティ（メッセージ文）
8.　Java起動部品
8.1　Java起動部品とは
8.1.1　JDKバージョン
8.1.2　ファイル名
8.1.3　パッケージ
8.2　EURPMAdapterForJavaクラス
8.2.1　コンストラクタ
8.2.2　メソッド一覧
8.2.3　指定値に使用できない文字について
8.3　EURPMExceptionクラス
8.3.1　メソッド一覧
8.3.2　指定値に使用できない文字について
8.4　EURPMAdapterForJavaクラスのメソッド仕様
getDestinationListメソッド
getEPFReportメソッド
getEURReportメソッド
getJobIDメソッド
getJobIDListメソッド
getMergeEPFReportメソッド
getPDFReportメソッド
getPMPrinterClassListメソッド
getPMPrinterListメソッド
getPMTrayListメソッド
getPreviewAXClassIDメソッド
getPreviewAXVersionメソッド
getPrintAXClassIDメソッド
getPrintAXVersionメソッド
getPrinterClassListメソッド
getPrinterListメソッド
getTrayListメソッド
getXLSXReportメソッド
outputEPFReportメソッド
outputEURReportメソッド
outputMergeEPFReportメソッド
outputPDFReportメソッド
outputXLSXReportメソッド
printReportメソッド
setBookmarkFileDataメソッド
setBookmarkFileNameメソッド
setBookmarkFilePathメソッド
setClientAddressメソッド
setClientPrinterNameメソッド
setClientTrayNameメソッド
setCryptoメソッド
setCryptoFileDataメソッド
setCryptoFileNameメソッド
setCryptoFilePathメソッド
setDataFileDataメソッド
setDataFileNameメソッド
setDataFilePathメソッド
setDBInfoFileNameメソッド
setDBInfoFilePathメソッド
setDestinationNameメソッド
setDispPrintDlgメソッド
setDistributeFileDataメソッド
setDistributeFileNameメソッド
setDistributeFilePathメソッド
setDocBookmarkFileDataメソッド
setDocBookmarkFileNameメソッド
setDocInfoFileNameメソッド
setDocInfoFilePathメソッド
setEnableGetメソッド
setEncryptionPasswordKeyメソッド
setEPFFileDataメソッド
setEPFFileNameメソッド
setEPFFilePathメソッド
setEURFileNameメソッド
setEURFilePathメソッド
setExecutablePrintModeメソッド
setFileOutputDestinationメソッド
setFirstPageNumberメソッド
setGroupNameメソッド
setInitPageNumberメソッド
setJobKeyCategoryメソッド
setJobKeyDataメソッド
setMaxPrintCountメソッド
setMergeEPFFileNameメソッド
setMergeEPFFilePathメソッド
setMultiBookmarkFileNameメソッド
setMultiDataFileNameメソッド
setMultiFormInfoDefFileNameメソッド
setMultiFormInfoDefFilePathメソッド
setMultiReportFileNameメソッド
setMultiReportSetFileNameメソッド
setMultiReportSetFilePathメソッド
setMultiUserDataFileNameメソッド
setPageNumberFormatメソッド
setPageNumberLocationメソッド
setPaperOrientationメソッド
setPDFFileNameメソッド
setPDFFilePathメソッド
setPMServerAddressメソッド
setPMServerPortメソッド
setPrintCopiesメソッド
setPrintDateFileNameメソッド
setPrintDateFilePathメソッド
setPrintEndPageメソッド
setPrinterClassNameメソッド
setPrinterSelectModeメソッド
setPrintHoldModeメソッド
setPrintKindメソッド
setPrintModeメソッド
setPrintPageNumberメソッド
setPrintStartPageメソッド
setPSEnvFileNameメソッド
setPSEnvFilePathメソッド
setReplaceItemCntlFileNameメソッド
setReplaceItemCntlFilePathメソッド
setReportAddressKeyCategoryメソッド
setReportAddressKeyDataメソッド
setReportFileNameメソッド
setReportFilePathメソッド
setScriptCntlFileNameメソッド
setScriptCntlFilePathメソッド
setServerAddressメソッド
setServerPrinterNameメソッド
setServerSelectModeメソッド
setServerTrayNameメソッド
setSortPrintメソッド
setSplitFileDataメソッド
setSplitFileNameメソッド
setSplitFilePathメソッド
setSplitModeメソッド
setSpoolFileNameメソッド
setSpoolLimitメソッド
setSpoolTitleメソッド
setUserDataFileDataメソッド
setUserDataFileNameメソッド
setUserDataFilePathメソッド
setViewerPreferenceFileNameメソッド
setViewerPreferenceFilePathメソッド
setXLSXFileNameメソッド
setXLSXFilePathメソッド
8.5　EURPMExceptionクラスのメソッド仕様
getErrorCodeメソッド
getErrorLevelメソッド
getKeyメソッド
getMessageメソッド
getOutputDataメソッド
8.6　例外情報
8.6.1　Java起動部品実行時の例外情報一覧
8.6.2　getErrorCodeメソッド（終了コード）
8.6.3　getErrorLevelメソッド（エラーレベル）
8.6.4　getKeyメソッド（メッセージID）
8.6.5　getMessageメソッド（メッセージ文）
8.6.6　getOutputDataメソッド
9.　SS-Java起動部品
9.1　SS-Java起動部品とは
9.1.1　JDKバージョン
9.1.2　ファイル名
9.1.3　パッケージ
9.2　EURPMLSAdapterForJavaクラス
9.2.1　コンストラクタ
9.2.2　メソッド一覧
9.2.3　指定値に使用できない文字について
9.3　EURPMLSExceptionクラス
9.3.1　メソッド一覧
9.3.2　指定値に使用できない文字について
9.4　EURPMLSAdapterForJavaクラスのメソッド仕様
changeAuditLogメソッド
deleteSpoolFileメソッド
getClientAddressメソッド
getClientPrinterNameメソッド
getClientTrayNameメソッド
getCreateIPAddressメソッド
getCreateLSVersionメソッド
getCreateTimeメソッド
getCreateTimeMultiメソッド
getDispPrintDlgメソッド
getEnableGetメソッド
getExecPrintCountメソッド
getExecutablePrintModeメソッド
getGroupNameメソッド
getJobIDメソッド
getJobKeyCategoryメソッド
getJobKeyDataメソッド
getMaxPrintCountメソッド
getPageNumメソッド
getPageNumMultiメソッド
getPrinterClassListメソッド
getPrinterClassNameメソッド
getPrinterClassNameMultiメソッド
getPrinterListメソッド
getPrinterSelectModeメソッド
getPrintResultメソッド
getPrintResultMultiメソッド
getPrintTimeメソッド
getReportAddressKeyCategoryメソッド
getReportAddressKeyDataメソッド
getServerPrinterNameメソッド
getServerTrayNameメソッド
getSpoolFileメソッド
getSpoolFileAttributeメソッド
getSpoolFileNameメソッド
getSpoolFileNameMultiメソッド
getSpoolFileOutlineメソッド
getSpoolFileSizeメソッド
getSpoolHistoryメソッド
getSpoolLimitメソッド
getSpoolPathメソッド
getSpoolPathMultiメソッド
getTrayListメソッド
initializeメソッド
memgetSpoolFileメソッド
printSpoolReportメソッド
setClientAddressメソッド
setClientPrinterNameメソッド
setClientTrayNameメソッド
setDeleteKindメソッド
setDispPrintDlgメソッド
setEnableGetメソッド
setExecutablePrintModeメソッド
setGroupNameメソッド
setJobKeyCategoryメソッド
setJobKeyDataメソッド
setMaxPrintCountメソッド
setOutputFileNameメソッド
setOutputFilePathメソッド
setPaperOrientationメソッド
setPrintCopiesメソッド
setPrintEndPageメソッド
setPrinterClassNameメソッド
setPrinterSelectModeメソッド
setPrintModeメソッド
setPrintStartPageメソッド
setSearchCreateTimeEndメソッド
setSearchCreateTimeStartメソッド
setSearchJobIDメソッド
setSearchJobIDMultiメソッド
setSearchJobKeyCategoryメソッド
setSearchJobKeyDataメソッド
setSearchPrinterClassNameメソッド
setSearchReportAddressKeyCategoryメソッド
setSearchReportAddressKeyDataメソッド
setSearchSpoolFileNameメソッド
setServerAddressメソッド
setServerPrinterNameメソッド
setServerTrayNameメソッド
setSortPrintメソッド
setSpoolFileAttributeメソッド
setSpoolLimitメソッド
setSpoolTitleメソッド
9.5　EURPMLSExceptionクラスのメソッド仕様
getErrorCodeメソッド
getErrorLevelメソッド
getKeyメソッド
getMessageメソッド
getOutputDataメソッド
9.6　例外情報
9.6.1　SS-Java起動部品実行時の例外情報一覧
9.6.2　getErrorCodeメソッド（終了コード）
9.6.3　getErrorLevelメソッド（エラーレベル）
9.6.4　getKeyメソッド（メッセージID）
9.6.5　getMessageメソッド（メッセージ文）
9.6.6　getOutputDataメソッド
10.　COBOL起動部品
10.1　COBOL起動部品とは
10.1.1　COBOL起動部品の構成
10.1.2　COBOL起動部品の呼び出し規約
10.2　関数一覧
10.3　関数仕様
GetDestinationList関数
GetDestinationList2関数
GetPMPrinterClassList関数
GetPMPrinterList関数
GetPMTrayList関数
GetPrinterClassList関数
GetPrinterClassList2関数
GetPrinterList関数
GetTrayList関数
OutputEPFReport関数
OutputEURReport関数
OutputMergeEPFReport関数
OutputPDFReport関数
OutputXLSXReport関数
PrintReport関数
PrintReport2関数
10.4　エラー情報
10.4.1　エラー情報一覧
10.4.2　RTNCODE（終了コード）
10.4.3　ERRORMESSAGE（メッセージ）
第3編　帳票出力で使用するファイル
11.　帳票サーバに準備するファイル
11.1　帳票サーバに準備するファイルの一覧
11.2　帳票ファイル
11.3　画像ファイル
11.4　文書情報設定ファイル
11.5　プリンタ定義ファイル
11.6　複数様式情報定義ファイル
11.7　接続情報ファイル
11.8　置き換え表管理情報ファイル
11.9　置き換え表ファイル
11.10　Acrobat JavaScript定義ファイル
11.11　Acrobat JavaScriptファイル
11.12　ビューアプレファレンス定義ファイル
11.13　テスト印刷設定ファイル
11.14　印刷日時出力定義ファイル
11.15　EURフォントファイル
12.　アプリケーションサーバに準備するファイル
12.1　アプリケーションサーバに準備するファイルの一覧
12.2　データファイル
12.3　可変記号値定義ファイル
12.4　帳票セット指定ファイル
12.5　文書しおり定義ファイル
12.6　しおり定義ファイル
12.7　暗号化設定ファイル
12.8　PDF仕分け定義ファイル
12.8.1　PDF形式ファイルを仕分け出力する場合
12.8.2　PDF形式ファイルを暗号化仕分け出力する場合
12.8.3　注意事項
12.9　制御情報付データファイル
12.10　起動パラメタファイル
12.11　EUR Web Plug-In情報ファイル
13.　運用に応じて格納先を決めるファイル
13.1　運用に応じて格納先を決めるファイルの一覧
13.2　分割定義ファイル
13.3　仕分け定義ファイル
第4編　帳票出力環境の構築で使用するファイル
14.　構成定義ファイル
14.1　構成定義ファイルの一覧
14.2　出力先定義ファイル
14.3　帳票サーバプリンタクラス定義ファイル
14.4　印刷先定義ファイル
14.5　拠点プリンタクラス定義ファイル
14.6　帳票振り分け定義ファイル
14.7　ユーザ管理ファイル
14.8　クライアントプリンタクラス定義ファイル
14.9　宛先定義ファイル
14.10　監視定義ファイル
15.　環境設定ファイル
15.1　環境設定ファイルの一覧
15.2　環境設定ファイル（EURPM.ini）
15.2.1　設定項目一覧
15.2.2　EURPM
15.2.3　EURPMLS
15.2.4　EURPMCL
15.2.5　FORM
15.2.6　CONF
15.2.7　TEMP
15.2.8　MULTI
15.2.9　DOCINFO
15.2.10　DBINFO
15.2.11　REPLACEITEM
15.2.12　SCRIPTCNT
15.2.13　PREFERENCE
15.2.14　PSENV
15.2.15　PDF
15.2.16　PRINTDATE
15.2.17　SPLIT
15.2.18　LOGFILE
15.2.19　LOGLEVEL
15.2.20　LOGSIZE
15.2.21　PATHMODE
15.2.22　TEMPFILEDEL
15.2.23　SOCKBUFFSIZE
15.2.24　SPLITMODE
15.2.25　RMDIRRETRYCOUNT
15.2.26　RMDIRINTERVALTIME
15.2.27　GENERAL
15.2.28　EURPS
15.2.29　MERGE
15.2.30　CONNECT
15.2.31　ERRIGNORE
15.2.32　PSENVFILENAME
15.2.33　PRINTDATE
15.2.34　SPLIT
15.3　環境設定ファイル（EURPS_ENV）
15.3.1　環境変数一覧
15.3.2　EURPS_LOGFILEPATH
15.3.3　EURPS_LOGSIZE
15.3.4　EURPS_LOGFILELEVEL
15.3.5　EURPS_IMAGEPATH
15.3.6　EURPS_REPORT_WARNING
15.3.7　EURPS_GAIJIFONT
15.3.8　EURPS_PDF_OUTPUT
15.3.9　EURPS_PDF_SAMEIMAGE
15.3.10　EURPS_PDF_IMAGE_OPTIMIZEMEM
15.3.11　EURPS_CSV_PRINT_PERIOD
15.3.12　EURPS_TMPPATH
15.3.13　EURPS_PDL_EXMINFONTPATH
15.3.14　EURPS_PDL_EXGOTFONTPATH
15.3.15　EURPS_TRACE
15.3.16　EURPS_TRACE_DRAWAPI
15.3.17　EURPS_REPORT_LOGERROR
15.3.18　EURPS_REPLACEITEMPATH
15.3.19　EURPS_SKIP_OUTPUTSPACE
15.3.20　EURPS_PRINT
15.3.21　EURPS_CODE39_PARAM
15.3.22　EURPS_CODE128_PARAM
15.3.23　EURPS_QR_CORRECTION_LEVEL
15.3.24　EURPS_QR_VERSION
15.3.25　EURPS_NOSKIP_OUTPUTSPACE
15.3.26　EURPS_QR_CELL_SIZE_D
15.3.27　EURPS_QR_CELL_SIZE_M
15.3.28　EURPS_SCRIPTFILEPATH
15.3.29　EURPS_FIXOPT
15.3.30　EURPS_PRINTERINFPATH
15.3.31　EURPS_USE_05_06_FONT_LANG
15.3.32　EURPS_OUTPUTPDF_VER
15.3.33　EURPS_USE_05_06_FONT_REPLACE
15.3.34　EURPS_FONT_WIDTH_MODE
15.3.35　EURPS_EXCELLOGFILELEVEL
15.3.36　EURPS_EXCELTMPPATH
15.3.37　EURPS_TESTPRINTFILE
15.3.38　EURPS_FONT_ROUNDDOWN
15.3.39　EURPS_MAX_SPOOL_PAGES
15.3.40　EURPS_DONT_PRINT_IF_DB_RESULT_EMPTY
15.3.41　EURPS_PDF_BUFSIZE
15.3.42　EURPS_PDF_IMAGEDRAWUNIT
15.3.43　EURPS_EPFDPI
15.3.44　EURPS_EPF_IMAGE_COMPRESS
15.3.45　EURPS_UPC_BARCODE
15.3.46　EURPS_OUTPUTPATH
15.3.47　EURPS_EXCEL_REPEAT_MODE
15.3.48　ESC/P対応プリンタ出力用の環境変数
15.3.49　環境設定ファイルの指定例
15.4　EUR Server - Adapterの環境設定ファイル（EURPMADP.ini）
15.4.1　設定項目一覧
15.4.2　EURPM
15.4.3　EURPM
15.4.4　LOGFILE
15.4.5　LOGLEVEL
15.4.6　LOGSIZE
15.4.7　DBZEROEXITCODE
15.4.8　PRINTMODE
15.4.9　DEFAULTPRINTMODE
15.4.10　SOCKBUFFSIZE
15.4.11　DATABUFFSIZE
15.4.12　DISPPRINTDLG
15.4.13　FILEOUTPUTDESTINATION
15.4.14　SPOOLLIMIT
15.4.15　OUTPUT
15.4.16　EPFOUTPUT
15.4.17　EUROUTPUT
15.4.18　PDFOUTPUT
15.4.19　DESTLIST
15.4.20　PRTCLSLIST
15.4.21　XLSXOUTPUT
15.4.22　MERGEOUTPUT
15.5　EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）
15.5.1　設定項目一覧
15.5.2　EURPMLS
15.5.3　EURPMCL
15.5.4　CONF
15.5.5　TEMP
15.5.6　ESF
15.5.7　POB
15.5.8　LOGFILE
15.5.9　LOGLEVEL
15.5.10　LOGSIZE
15.5.11　TEMPFILEDEL
15.5.12　ESFAUTODEL
15.5.13　SOCKBUFFSIZE
15.5.14　SPLOUTLINELIMIT
15.5.15　ESFID
15.5.16　AUTHENTICATION
15.5.17　INTERVAL
15.5.18　PERSONALCATEGORY
15.5.19　APSAUTO
15.5.20　LDAPSERVER
15.5.21　LDAPBINDDN
15.5.22　LDAPPASSWORD
15.5.23　LDAPBASEDN
15.5.24　LDAPUIDATTR
15.5.25　LDAPTLS
15.5.26　ENCRYPTPASSWORD
15.5.27　RMDIRRETRYCOUNT
15.5.28　RMDIRINTERVALTIME
15.5.29　LDAPPASSWORDEMPTYCHECK
15.5.30　STANDARDTIME
15.5.31　ADDRDEFFILENAME
15.5.32　GENERAL
15.5.33　EURPS
15.5.34　MERGE
15.5.35　CONNECT
15.5.36　ERRIGNORE
15.5.37　WAITINGLIMIT
15.5.38　PRINTINGLIMIT
15.5.39　PRINTEDLIMIT
15.5.40　ERRORLIMIT
15.5.41　LDAPCONNECT
15.5.42　SPOOLAUDITLOG
15.5.43　SPOOLLOG
15.5.44　SPOOLLOGSIZE
15.5.45　SPOOLLOGDATE
15.5.46　SPOOLLOGNUM
15.5.47　SPOOLLOGMODE
15.6　EUR Server - Spool Service Adapterの環境設定ファイル（EURPMLSADP.ini）
15.6.1　設定項目一覧
15.6.2　EURPMLS
15.6.3　EURPMLS
15.6.4　LOGFILE
15.6.5　LOGLEVEL
15.6.6　LOGSIZE
15.6.7　PRINT
15.6.8　GETFILE
15.6.9　FILELIST
15.6.10　FILEOPERATE
15.6.11　DELETE
15.6.12　PRTCLSLIST
15.6.13　AUTHENTICATION
15.6.14　POLLINGREPORT
15.6.15　PRINTSTATE
15.6.16　CHANGEAUDITLOG
15.6.17　OUTPUTFILE
15.6.18　SOCKBUFFSIZE
15.6.19　USERNAME
15.6.20　CHECKSTRING
15.7　帳票管理GUIの環境設定ファイル（EURPMRSGUI.ini）
15.7.1　設定項目一覧
15.7.2　PATH
15.7.3　PATH_MACHINE
15.7.4　EPFDATAMAXSIZE
15.7.5　DEFAULTPRINTDLG
15.8　EUR Client Serviceの環境設定ファイル（EURPMCL.ini）
15.8.1　設定項目一覧
15.8.2　EURPMCL
15.8.3　CONF
15.8.4　TEMP
15.8.5　DELISERVICE
15.8.6　LOGFILE
15.8.7　LOGLEVEL
15.8.8　LOGSIZE
15.8.9　EVENTLOGLEVEL
15.8.10　TEMPFILEDEL
15.8.11　SOCKBUFFSIZE
15.8.12　FIRSTDELIVERY
15.8.13　RMDIRRETRYCOUNT
15.8.14　RMDIRINTERVALTIME
15.8.15　SELECTDISPLAYPRINTER
15.8.16　CONNECT
15.8.17　ERRIGNORE
15.8.18　HTTPDATARECEIVE
15.9　Server Service制御コマンドの環境設定ファイル（EURPMCTRL.ini）
15.9.1　設定項目一覧
15.9.2　TEMP
15.9.3　LOGFILE
15.9.4　LOGLEVEL
15.9.5　LOGSIZE
15.9.6　START
15.9.7　STOP
15.10　Spool Service制御コマンドの環境設定ファイル（EURPMLSCTRL.ini）
15.10.1　設定項目一覧
15.10.2　TEMP
15.10.3　LOGFILE
15.10.4　LOGLEVEL
15.10.5　LOGSIZE
15.10.6　START
15.10.7　STOP
15.11　BSP-RM連携コマンドの環境設定ファイル（eursmpr.ini）
15.11.1　設定項目一覧
15.11.2　環境変数一覧
15.11.3　TEMP
15.11.4　DIVDATA
15.11.5　RUNPARAM
15.11.6　REMAINFLAG
15.11.7　ERRORREMAIN
15.11.8　LOGFILE
15.11.9　LOGLEVEL
15.11.10　LOGSIZE
15.12　ファイル監視サービスの環境設定ファイル（eurfm.ini）
15.12.1　設定項目一覧
15.12.2　FMC
15.12.3　CONF
15.12.4　RUNPARAM
15.12.5　LOGFILE
15.12.6　LOGLEVEL
15.12.7　LOGSIZE
15.12.8　INTERVAL
15.12.9　STANDARDTIME
15.12.10　DATALIMIT
15.12.11　GENERAL
15.13　ジョブ実行プログラムの環境設定ファイル（eurivk.ini）
15.13.1　設定項目一覧
15.13.2　LOGFILE
15.13.3　LOGLEVEL
15.13.4　LOGSIZE
付録
付録A　コマンドやAPIを使用するときの注意
付録A.1　ファイル名，およびファイルのパスを指定するときの注意
付録A.2　環境設定ファイルとの関係
付録B　このマニュアルの参考情報
付録B.1　関連マニュアル
付録B.2　EUR バージョン9での製品体系の変更
付録B.3　EUR バージョン9でのマニュアル体系の変更
付録B.4　このマニュアルでの表記
付録B.5　このマニュアルで使用する略語
付録B.6　KB（キロバイト）などの単位表記について
索引

[他社商品名称に関する表示]

All Rights Reserved. Copyright (C) 2012, 2014, Hitachi, Ltd.
All Rights Reserved. Copyright (C) 2012, 2014, Hitachi Solutions, Ltd.


前書き

■ 対象製品

●適用OS：Windows XP Professional，Windows 7 x86，Windows 7 x64※1，Windows 8 x86※2，Windows 8 x64※1※2

P-2CD2-5694　 uCosminexus EUR Designer　 09-60
P-2CD2-5D9L　 uCosminexus EUR Developer※3　 09-60
P-2CD2-5394　 uCosminexus EUR Viewer　 09-60

●適用OS：Windows Server 2008 R2，Windows Server 2012

P-29D2-5994　 uCosminexus EUR Server Standard※4　 09-60
P-29D2-5E9L　 uCosminexus EUR Server Enterprise※4　 09-60
P-29D2-5794　 uCosminexus EUR Server Print Edition※4　 09-60
P-29D2-5C94　 uCosminexus EUR Server - Cipher option　 09-00

●適用OS：HP-UX 11i V3(IPF)

P-1JD2-5991　 uCosminexus EUR Server Standard　 09-60
P-1JD2-5A91　 uCosminexus EUR Server Enterprise　 09-60
P-1JD2-5791　 uCosminexus EUR Server Print Edition　 09-60
P-1JD2-5C91　 uCosminexus EUR Server - Cipher option　 09-00

●適用OS：AIX V6.1，AIX V7.1

P-1MD2-5991　 uCosminexus EUR Server Standard　 09-60
P-1MD2-5A91　 uCosminexus EUR Server Enterprise　 09-60
P-1MD2-5791　 uCosminexus EUR Server Print Edition　 09-60
P-1MD2-5C91　 uCosminexus EUR Server - Cipher option　 09-00

●適用OS：Red Hat Enterprise Linux Server 6 (64-bit x86_64)

P-82D2-5991　 uCosminexus EUR Server Standard　 09-60
P-82D2-5A91　 uCosminexus EUR Server Enterprise　 09-60
P-82D2-5791　 uCosminexus EUR Server Print Edition　 09-60
P-82D2-5C91　 uCosminexus EUR Server - Cipher option　 09-00

注※1
WOW64（Windows On Windows 64）環境だけで使用できます。
注※2
Windows 8 Modern UI designには対応していません。
注※3
次に示す製品を同梱しています。
・P-2463-2354　　DABroker
注※4
次に示す製品を同梱しています。
・P-2963-2354　　DABroker(64)

これらの製品は，ISO9001およびTickITの認証を受けた品質マネジメントシステムで開発されました。

■ 輸出時の注意

本製品を輸出される場合には、外国為替及び外国貿易法の規制並びに米国輸出管理規則など外国の輸出関連法規をご確認の上、必要な手続きをお取りください。
なお、不明な場合は、弊社担当営業にお問い合わせください。

■ 商標類

Acrobatは，Adobe Systems Incorporated（アドビシステムズ社）の商標です。
ActiveXは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
Adobe，およびFlashは，Adobe Systems Incorporated(アドビシステムズ社)の米国ならびに他の国における商標または登録商標です。
Adobe，およびReaderは，Adobe Systems Incorporated(アドビシステムズ社)の米国ならびに他の国における商標または登録商標です。
AIXは，米国およびその他の国におけるInternational Business Machines Corporationの商標です。
BSAFEは，EMC Corporationの米国およびその他の国における登録商標または商標です。
BSP-RMは，株式会社ビーエスピーの登録商標です。
ESC/Pは，セイコーエプソン(株)の商標です。
GIFは，米国CompuServe Inc.が開発したフォーマットの名称です。
HP-UXは，Hewlett-Packard Development Company, L.P.のオペレーティングシステムの名称です。
Itaniumは，アメリカ合衆国およびその他の国におけるIntel Corporationの商標です。
Linuxは，Linus Torvalds氏の日本およびその他の国における登録商標または商標です。
LIPSIIIは，キヤノン（株）が開発した言語仕様です。
MicrosoftおよびExcelは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
MicrosoftおよびInternet Explorerは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
MicrosoftおよびMS-DOSは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
MicrosoftおよびVisual Basicは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
MicrosoftおよびVisual C++は，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
Microsoft .NET は，お客様，情報，システムおよびデバイスを繋ぐソフトウェアです。
Microsoft Officeは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
Microsoft OfficeおよびExcelは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
Microsoft Office Wordは，米国Microsoft Corporationの商品名称です。
Microsoft Wordは，米国Microsoft Corporationの商品名称です。
ODBCは，米国Microsoft Corporationが提唱するデータベースアクセス機構です。
OLEは，米国Microsoft Corporationが開発したソフトウェア名称です。
OracleとJavaは，Oracle Corporation 及びその子会社，関連会社の米国及びその他の国における登録商標です。
PostScriptは，米国Adobe Systems, Inc.が開発した言語仕様です。
QRコードは，株式会社デンソーウェーブの登録商標です。
Red Hatは，米国およびその他の国でRed Hat, Inc.の登録商標もしくは商標です。
RPMは，RPM Package Managerの略称です。
RSAは，EMC Corporationの米国およびその他の国における登録商標または商標です。
SQL Serverは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
UNIXは，The Open Groupの米国ならびに他の国における登録商標です。
Windowsは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
Windows Serverは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
中ゴシックBBBは，株式会社モリサワとアドビシステムズ社が共同開発したフォントで承認外の複製は禁止されており，それらの書体名は株式会社モリサワの商標です。
リュウミンL-KLは，株式会社モリサワとアドビシステムズ社が共同開発したフォントで承認外の複製は禁止されており，それらの書体名は株式会社モリサワの商標です。
その他記載の会社名，製品名は，それぞれの会社の商標もしくは登録商標です。
This product includes software developed by the Apache Software Foundation (http://www.apache.org/).
This product includes software developed by Ben Laurie for use in the Apache-SSL HTTP server project.
Portions of this software were developed at the National Center for Supercomputing Applications (NCSA) at the University of Illinois at Urbana-Champaign.
This product includes software developed by the University of California, Berkeley and its contributors.
This software contains code derived from the RSA Data Security Inc. MD5 Message-Digest Algorithm, including various modifications by Spyglass Inc., Carnegie Mellon University, and Bell Communications Research, Inc (Bellcore).
Regular expression support is provided by the PCRE library package, which is open source software, written by Philip Hazel, and copyright by the University of Cambridge, England. The original software is available from ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/
This product includes software developed by Ralf S. Engelschall <rse@engelschall.com> for use in the mod_ssl project (http://www.modssl.org/).
This product includes software developed by IAIK of Graz University of Technology.
This product includes software developed by Daisuke Okajima and Kohsuke Kawaguchi (http://relaxngcc.sf.net/).
This product includes software developed by the Java Apache Project for use in the Apache JServ servlet engine project (http://java.apache.org/).
This product includes software developed by Andy Clark.

本製品は，米国EMC コーポレーションのRSA BSAFE(R)ソフトウェアを搭載しています。

■ マイクロソフト製品の表記について

このマニュアルでは，マイクロソフト製品の名称を次のように表記しています。
表記 | 製品名称
.NET | Microsoft(R) .NET
ActiveX | ActiveX(R)
Excel Microsoft(R) Excel Version 2002
Microsoft(R) Office Excel 2003
Microsoft(R) Office Excel 2007
Microsoft(R) Office Excel 2010
Internet Explorer | Microsoft(R) Internet Explorer(R)
Windows(R) Internet Explorer(R)
SQL Server Microsoft(R) SQL Server 2005
Microsoft(R) SQL Server 2008
Microsoft(R) SQL Server 2008 R2
Microsoft(R) SQL Server 2012
VBScript | Microsoft(R) Visual Basic(R) Scripting Edition
Visual Basic | Microsoft(R) Visual Basic(R)
Visual C++ | Microsoft(R) Visual C++(R)
Windows Windows 7 Windows 7 x86 Microsoft(R) Windows(R) 7 Professional(32ビット版)
Microsoft(R) Windows(R) 7 Enterprise(32ビット版)
Microsoft(R) Windows(R) 7 Ultimate(32ビット版)
Windows 7 x64 Microsoft(R) Windows(R) 7 Professional(64ビット版)
Microsoft(R) Windows(R) 7 Enterprise(64ビット版)
Microsoft(R) Windows(R) 7 Ultimate(64ビット版)
Windows 8 Windows 8 x86 Windows(R) 8 Pro(32ビット版)
Windows(R) 8 Enterprise(32ビット版)
Windows 8 x64 Windows(R) 8 Pro(64ビット版)
Windows(R) 8 Enterprise(64ビット版)
Windows Server 2008 Microsoft(R) Windows Server(R) 2008 R2 Standard
Microsoft(R) Windows Server(R) 2008 R2 Enterprise
Microsoft(R) Windows Server(R) 2008 R2 Datacenter
Windows Server 2012 Microsoft(R) Windows Server(R) 2012 Standard
Microsoft(R) Windows Server(R) 2012 Datacenter
Windows XP | Microsoft(R) Windows(R) XP Professional Operating System
Word Microsoft(R) Word Version 2002
Microsoft(R) Office Word 2003
Microsoft(R) Office Word 2007
Microsoft(R) Office Word 2010

■ 発行

2014年1月　3020-7-710-30

■ 著作権

All Rights Reserved. Copyright (C) 2012, 2014, Hitachi, Ltd.
All Rights Reserved. Copyright (C) 2012, 2014, Hitachi Solutions, Ltd.

[目次][前へ][次へ]


他社商品名称に関する表示

■ 商標類

Acrobatは，Adobe Systems Incorporated（アドビシステムズ社）の商標です。
ActiveXは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
Adobe，およびFlashは，Adobe Systems Incorporated(アドビシステムズ社)の米国ならびに他の国における商標または登録商標です。
Adobe，およびReaderは，Adobe Systems Incorporated(アドビシステムズ社)の米国ならびに他の国における商標または登録商標です。
AIXは，米国およびその他の国におけるInternational Business Machines Corporationの商標です。
BSAFEは，EMC Corporationの米国およびその他の国における登録商標または商標です。
BSP-RMは，株式会社ビーエスピーの登録商標です。
ESC/Pは，セイコーエプソン(株)の商標です。
GIFは，米国CompuServe Inc.が開発したフォーマットの名称です。
HP-UXは，Hewlett-Packard Development Company, L.P.のオペレーティングシステムの名称です。
Itaniumは，アメリカ合衆国およびその他の国におけるIntel Corporationの商標です。
Linuxは，Linus Torvalds氏の日本およびその他の国における登録商標または商標です。
LIPSIIIは，キヤノン（株）が開発した言語仕様です。
MicrosoftおよびExcelは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
MicrosoftおよびInternet Explorerは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
MicrosoftおよびMS-DOSは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
MicrosoftおよびVisual Basicは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
MicrosoftおよびVisual C++は，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
Microsoft .NET は，お客様，情報，システムおよびデバイスを繋ぐソフトウェアです。
Microsoft Officeは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
Microsoft OfficeおよびExcelは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
Microsoft Office Wordは，米国Microsoft Corporationの商品名称です。
Microsoft Wordは，米国Microsoft Corporationの商品名称です。
ODBCは，米国Microsoft Corporationが提唱するデータベースアクセス機構です。
OLEは，米国Microsoft Corporationが開発したソフトウェア名称です。
OracleとJavaは，Oracle Corporation 及びその子会社，関連会社の米国及びその他の国における登録商標です。
PostScriptは，米国Adobe Systems, Inc.が開発した言語仕様です。
QRコードは，株式会社デンソーウェーブの登録商標です。
Red Hatは，米国およびその他の国でRed Hat, Inc.の登録商標もしくは商標です。
RPMは，RPM Package Managerの略称です。
RSAは，EMC Corporationの米国およびその他の国における登録商標または商標です。
SQL Serverは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
UNIXは，The Open Groupの米国ならびに他の国における登録商標です。
Windowsは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
Windows Serverは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
中ゴシックBBBは，株式会社モリサワとアドビシステムズ社が共同開発したフォントで承認外の複製は禁止されており，それらの書体名は株式会社モリサワの商標です。
リュウミンL-KLは，株式会社モリサワとアドビシステムズ社が共同開発したフォントで承認外の複製は禁止されており，それらの書体名は株式会社モリサワの商標です。
その他記載の会社名，製品名は，それぞれの会社の商標もしくは登録商標です。
This product includes software developed by the Apache Software Foundation (http://www.apache.org/).
This product includes software developed by Ben Laurie for use in the Apache-SSL HTTP server project.
Portions of this software were developed at the National Center for Supercomputing Applications (NCSA) at the University of Illinois at Urbana-Champaign.
This product includes software developed by the University of California, Berkeley and its contributors.
This software contains code derived from the RSA Data Security Inc. MD5 Message-Digest Algorithm, including various modifications by Spyglass Inc., Carnegie Mellon University, and Bell Communications Research, Inc (Bellcore).
Regular expression support is provided by the PCRE library package, which is open source software, written by Philip Hazel, and copyright by the University of Cambridge, England. The original software is available from ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/
This product includes software developed by Ralf S. Engelschall <rse@engelschall.com> for use in the mod_ssl project (http://www.modssl.org/).
This product includes software developed by IAIK of Graz University of Technology.
This product includes software developed by Daisuke Okajima and Kohsuke Kawaguchi (http://relaxngcc.sf.net/).
This product includes software developed by the Java Apache Project for use in the Apache JServ servlet engine project (http://java.apache.org/).
This product includes software developed by Andy Clark.

本製品は，米国EMC コーポレーションのRSA BSAFE(R)ソフトウェアを搭載しています。

[目次]


変更内容

変更内容（3020-7-710-30）

uCosminexus EUR Designer　09-60

uCosminexus EUR Developer　09-60

uCosminexus EUR Viewer　09-60

uCosminexus EUR Server Standard　09-60

uCosminexus EUR Server Enterprise　09-60

uCosminexus EUR Server Print Edition　09-60

追加・変更内容 | 変更個所
帳票を印刷，蓄積，EPF形式ファイル出力，およびEUR形式ファイル出力を実行するときにスプールタイトルを指定できるようになりました。これに伴い，次に示す項目を追加，変更しました。
  • eurpmcコマンドの/sptlオプションの説明を追加，変更しました。
  • ActiveX起動部品の出力メソッドで使用するSpoolTitleプロパティの説明を変更しました。
  • Java起動部品の出力メソッドで使用するsetSpoolTitleメソッドの説明を変更しました。
  • COBOL起動部品のOutputEPFReport関数，OutputEURReport関数，PrintReport関数，およびPrintReport2関数に，SPOOLTITLEパラメタの説明を追加しました。
  • 印刷先定義ファイルのDestnセクションにSpoolTitleキーを追加しました。
  • EUR Server Serviceの環境設定ファイル（EURPS_ENV）の環境変数EURPS_MAX_SPOOL_PAGESの説明を変更しました。
 1.3.1，1.3.2，1.3.3，1.3.5，6.2.2，6.4，8.2.2，8.4，10.3，12.10(3)(b)，14.4(3)，15.3.39
スプールデータの操作の監査ログを出力できるようになりました。これに伴い，次に示す項目を追加，変更しました。
  • eurpmlscコマンドの/mオプションの指定値にchgadtlogを追加しました。
  • SS-ActiveX起動部品のメソッドにChangeAuditLogメソッドの説明を追加しました。
  • SS-ActiveX起動部品実行時のエラー情報の一覧に終了コードを追加しました。
  • SS-Java起動部品のメソッドにChangeAuditLogメソッドの説明を追加しました。
  • SS-Java起動部品実行時の例外情報の一覧に終了コードを追加しました。
  • EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）にAUDITセクション，SPOOLAUDITLOGキー，SPOOLLOGキー，SPOOLLOGSIZEキー，SPOOLLOGDATEキー，SPOOLLOGNUMキー，およびSPOOLLOGMODEキーの説明を追加しました。
  • EUR Server - Spool Service Adapterの環境設定ファイル（EURPMLSADP.ini）にCHANGEAUDITLOGキーの説明を追加しました。
 2.2.1，2.2.3(3)，2.3.10，7.2.1，7.2.2，7.3，7.5.1，9.2.2，9.4，9.6.1，15.5，15.5.42，15.5.43，15.5.44，15.5.45，15.5.46，15.5.47，15.6.16
EUR Web Plug-InでプレビューしているEPF形式ファイルの文字列検索ができるようになりました。これに伴い，次に示す項目を追加しました。
  • Findメソッド
  • FindNextメソッド
  • PageChangedイベント
 5.2.2，5.2.4，5.4，5.6
次に示す項目に，EUR Web Plug-Inの印刷ダイアログに初期表示するプリンタ名の説明を追加しました。
  • EUR Web Plug-InのSelectDisplayPrinterパラメタ
  • EUR Web Plug-InのSelectDisplayPrinterプロパティ
 5.3，5.5
次に示す項目に，EUR Web Plug-In情報ファイルから情報を取得できなかったときの説明を追加しました。
  • ActiveX起動部品のGetPreviewAXClassIDメソッド，GetPreviewAXVersionメソッド，GetPrintAXClassIDメソッド，GetPrintAXVersionメソッド，
  • Java起動部品のgetPreviewAXClassIDメソッド，getPreviewAXVersionメソッド，getPrintAXClassIDメソッド，getPrintAXVersionメソッド
 6.3，8.4
次に示す項目に，PDF形式ファイルの出力先の指定が有効になる条件およびPDF仕分け定義ファイル名を指定したときの動作の説明を追加しました。
  • ActiveX起動部品のDistributeFileNameプロパティおよびFileOutputDestinationプロパティ
  • Java起動部品のsetDistributeFileNameメソッドおよびsetFileOutputDestinationメソッド
  • COBOL起動部品のOutputPDFReport関数のDISTRIBUTEFILENAMEパラメタおよびFILEOUTPUTDESTINATIONパラメタ
  • 起動パラメタファイルの/dsfオプションおよび/foutdestオプション
  • EUR Server - Adapterの環境設定ファイル（EURPMADP.ini）のFILEOUTPUTDESTINATIONキー
 6.4，8.4，10.3，12.10(3)(b)，15.4.13
次に示す項目に，EPF形式ファイルの属性情報に設定するプリンタクラス名の説明を追加しました。
  • ActiveX起動部品のPrinterClassNameプロパティ
  • Java起動部品のsetPrinterClassnameメソッド
  • COBOL起動部品のPRINTERCLASSNAMEパラメタ（OutputEPFReport関数，OutputMergeEPFReport関数，PrintReport関数，およびPrintReport2関数）
  • 起動パラメタファイルの/prcオプション
 6.4，8.4，10.3，12.10(3)(b)
次に示す項目に，EPF形式ファイルの出力で，プリンタクラス名の指定を省略または空文字を指定したときの説明を追加しました。
  • ActiveX起動部品のPrinterClassNameプロパティ
  • Java起動部品のsetPrinterClassNameメソッド
  • COBOL起動部品のPRINTERCLASSNAMEパラメタ（OutputEPFReport関数，PrintReport関数，およびPrintReport2関数）
  • 起動パラメタファイルの/prcオプション
 6.4，8.4，10.3，12.10(3)(b)
次に示すJava起動部品のメソッドに，setSplitFileDataメソッドで分割定義データまたは仕分け定義データを指定するときの説明を追加しました。
  • setBookmarkFileDataメソッド
  • setCryptoFileDataメソッド
  • setDataFileDataメソッド
  • setDistributeFileDataメソッド
  • setDocBookmarkFileDataメソッド
  • setSplitFileDataメソッド
  • setUserDataFileDataメソッド
 8.4
次に示すJava起動部品のメソッドに，setSplitFileNameメソッドで分割定義ファイルまたは仕分け定義ファイルを指定するときの説明を追加しました。
  • setBookmarkFileNameメソッド
  • setCryptoFileNameメソッド
  • setDataFileNameメソッド
  • setDistributeFileNameメソッド
  • setDocBookmarkFileNameメソッド
  • setSplitFileNameメソッド
  • setUserDataFileNameメソッド
 8.4
次に示す項目に，PDF仕分け定義データを指定したときの動作の説明を追加しました。
  • Java起動部品のsetDistributeFileDataメソッドおよびsetFileOutputDestinationメソッド
  • EUR Server - Adapterの環境設定ファイル（EURPMADP.ini）のFILEOUTPUTDESTINATIONキー
 8.4，15.4.13
EURで使用できる画像ファイルにPNG形式を追加しました。 | 11.3
プリンタ定義ファイルのファイル名と格納先の説明を追加しました。 | 11.5(1)
プリンタ定義ファイルのキーワードDrawBarStyleの説明を変更しました。 | 11.5(3)
プリンタ定義ファイルの帳票フォント置き換えの説明を変更しました。 | 11.5(3)(n)
次に示す構成定義ファイルの格納先の説明を変更しました。
  • 拠点プリンタクラス定義ファイル
  • 帳票振り分け定義ファイル
  • クライアントプリンタクラス定義ファイル
 14.5(2)，14.6(2)，14.8(2)
環境設定ファイルと環境変数の説明に見出しを追加して再構成しました。 | 15.2，15.3，15.4，15.5，15.6，15.7，15.8，15.9，15.10，15.11，15.12，15.13
Excel形式ファイル出力時に，ページ単位でExcelのシートを分けるかどうかを指定できるようになりました。これに伴い，次に示す項目を追加しました。
  • EUR Server Serviceの環境設定ファイル（EURPS_ENV）に，環境変数EURPS_EXCEL_REPEAT_MODEの説明を追加しました。
 15.3.1(4)，15.3.47
EUR Server Serviceの環境設定ファイル（EURPS_ENV）で，環境変数EURPS_LOGFILEPATH，EURPS_IMAGEPATH，EURPS_REPLACEITEMPATH，EURPS_SCRIPTFILEPATH，およびEURPS_PRINTERINFPATHの「Windows環境のとき」の説明を変更しました。 | 15.3.2，15.3.5，15.3.18，15.3.28，15.3.30
EUR Server Serviceの環境設定ファイル（EURPS_ENV）で，環境変数EURPS_SKIP_OUTPUTSPACEの指定が有効になるアイテムの説明を変更しました。 | 15.3.19
EUR Server Serviceの環境設定ファイル（EURPS_ENV）で，環境変数EURPS_FIXOPTが有効になる条件と指定内容の説明を変更しました。 | 15.3.29
EUR Server - Adapterの環境設定ファイル（EURPMADP.ini）で，DATABUFFSIZEキーの転送の対象になるファイルの説明を変更しました。 | 15.4.11
LDAP接続情報暗号化ツールの説明を追加しました。 | 15.5.1，15.5.22，15.5.26
利用できるデータベースにMicrosoft(R) SQL Server 2012を追加しました。 －

単なる誤字・脱字などはお断りなく訂正しました。


はじめに

このマニュアルは，EUR 帳票作成機能で設計した帳票を，次に示すプログラムプロダクトを使用して帳票出力する方法について説明したものです。

  • uCosminexus EUR Server Standard
  • uCosminexus EUR Server Enterprise
  • uCosminexus EUR Server Print Edition
  • uCosminexus EUR Server - Cipher option
＜はじめにの構成＞
対象読者
このマニュアルの文法で使用する記号

対象読者

このマニュアルは，EUR サーバ帳票出力機能を使って帳票を出力する方を対象としています。なお，次の内容を理解されていることを前提としています。

  • 使用するプログラム言語に関する基本的な知識

このマニュアルの文法で使用する記号

このマニュアルで使用する記号について，次に示します。

記　号 意　　味
｜ 横に並べられた複数の項目に対する項目間の区切りを示し，「または」を意味します。
（例）A｜B
「A，またはBを指定する」ことを示します。
｛　｝ この記号で囲まれている複数の項目のうちから一つを選択することを示します。項目が横に並べられ，記号｜で区切られている場合は，そのうちの一つを選択します。
（例）｛A｜B｜C｝
「A，B，またはCのどれかを指定する」ことを示します。
〔　〕 この記号で囲まれている項目は省略してもよいことを示します。複数の項目が横に並べて記述されている場合には，すべてを省略するか，記号｛　｝と同じくどれか一つを選択します。
（例）〔A〕
「何も指定しない」か「Aと指定する」ことを示します。
（例）〔B｜C〕
「何も指定しない」か「B，またはCのどちらかを指定する」ことを示します。
…
記述が省略されていることを示します。この記号の直前に示された項目を繰り返し複数個指定できます。
（例）〔A〔,…〕〕
「Aのあとに，Aを複数個指定できる」ことを示します。
＿ 括弧で囲まれた複数項目のうち1項目に対し使用され，括弧内のすべてを省略したときシステムが採る標準値を示します。
（例）〔A｜B｜C〕
「A，B，Cのどれも指定しなかった場合，システムはCが指定されたときと同じ処理をする」ことを示します。


eurpmcコマンド

1.　eurpmcコマンド

この章では，EUR Server Serviceを起動するeurpmcコマンドについて説明します。

＜この章の構成＞
1.1　eurpmcコマンドとは
1.2　eurpmcコマンドが提供するオプション
1.3　eurpmcコマンドの構文
1.4　エラー情報


eurpmcコマンドとは

1.1　eurpmcコマンドとは

eurpmcコマンドを使用して，EUR Server Serviceをコマンド起動できます。

eurpmcコマンドでは，メソッド種別などをコマンドのオプションに設定することで，帳票を出力できます。

＜この節の構成＞
1.1.1　eurpmcコマンドのファイル名


eurpmcコマンドのファイル名

1.1.1　eurpmcコマンドのファイル名

＜この項の構成＞
(1)　Windows環境の場合
(2)　UNIX／Linux環境の場合

(1)　Windows環境の場合

EURPMC.exe
eurpmcコマンドのファイルです。EUR Server - Adapterをインストールしたときに，次に示すフォルダにインストールされます。
    インストール先フォルダ\Adapter\Program

(2)　UNIX／Linux環境の場合

eurpmc
eurpmcコマンドのファイルです。/opt/eur/adapter/bin/にあります。


eurpmcコマンドが提供するオプション

1.2　eurpmcコマンドが提供するオプション

eurpmcコマンドでは，オプションを指定して帳票を出力します。

オプション名のセパレータは，「/」で示しています。UNIX／Linux環境の場合は，「/」を「-」に置き換えてお読みください。

＜この節の構成＞
1.2.1　メソッドオプション一覧
1.2.2　プロパティオプション一覧
1.2.3　オプションを指定するときの注意


メソッドオプション一覧

1.2.1　メソッドオプション一覧

eurpmcコマンドでは，出力と情報取得の機能（メソッド）を，/mオプションで次のように指定します。

/m ｛epf | eur | merge | pdf | print | xlsx | getdest | getpmpr | getpmprclass | getpmtray | getpr | getprclass | gettray｝

/mオプションの指定値とその内容を次に示します。また，/mオプションの指定値が，どのActiveX起動部品のメソッドと対応しているかも示します。

表1-1　/mオプションの指定値と対応するActiveX起動部品のメソッド

種類 | /mオプションの指定値 | 内容 | 対応するActiveX起動部品のメソッド
情報取得 | getdest | 出力先の一覧を取得します。 | GetDestinationList
 | getpmpr | 帳票サーバのプリンタ一覧を取得します。 | GetPMPrinterList
 | getpmprclass | 帳票サーバのプリンタクラス一覧を取得します。 | GetPMPrinterClassList
 | getpmtray | 帳票サーバのトレイ一覧を取得します。 | GetPMTrayList
 | getpr | 指定した出力先のスプールサーバに登録されたOS上のプリンタ一覧を取得します。 | GetPrinterList
 | getprclass | 指定した出力先の拠点プリンタクラスの一覧を取得します。 | GetPrinterClassList
 | gettray | 出力先とOS上のプリンタを指定し，そのOS上のプリンタのトレイ一覧を取得します。 | GetTrayList
出力 | epf | プロパティで指定した帳票名およびデータファイルに従って，EPF形式ファイルを出力します。 | OutputEPFReport
 | eur | プロパティで指定した帳票名およびデータファイルに従って，EUR形式ファイルを出力します。 | OutputEURReport
 | merge | 複数のEPF形式ファイルを一つのEPF形式ファイルに統合します。 | OutputMergeEPFReport
 | pdf | プロパティで指定した帳票名およびデータファイルに従って，PDF形式ファイルを出力します。 | OutputPDFReport
 | print | プロパティで指定した帳票名およびデータファイルに従って，帳票を印刷または蓄積します。 | PrintPMReport
 | xlsx | プロパティで指定した帳票名およびデータファイルに従って，Excel形式ファイルを出力します。 | OutputXLSXReport


プロパティオプション一覧

1.2.2　プロパティオプション一覧

eurpmcコマンドで指定できるプロパティオプションについて説明します。

プロパティオプションの指定値は，ActiveX起動部品のプロパティと対応しています。プロパティオプションの指定値と，対応するActiveX起動部品のプロパティを次に示します。

表1-2　プロパティオプションの内容（指定値）と対応するActiveX起動部品のプロパティ

プロパティオプション 内容
（指定値） 		対応するActiveX起動部品のプロパティ
/alljob 帳票の蓄積時に指定すると，蓄積したスプールデータのジョブIDの一覧を取得できます。 －
/bm ※1 しおり定義ファイル名
（255バイト以内の文字列） 		BookmarkFileName
/bmf 文書しおり定義ファイル名
（255バイト以内の文字列） 		DocBookmarkFileName
/bmp 文書しおり定義ファイルまたはしおり定義ファイルのパス
（255バイト以内の文字列） 		BookmarkFilePath
/c 印刷部数
（1～99） 		PrintCopies
/client クライアントPCのIPアドレス
（255.255.255.255形式） 		ClientAddress
/cry PDF形式ファイルの暗号化出力の有無
  • 1：PDF形式ファイルを暗号化する
  • 0：PDF形式ファイルを暗号化しない
 Crypto
/cryf 暗号化設定ファイル名
（255バイト以内の文字列） 		CryptoFileName
/cryfp 暗号化設定ファイルのパス
（255バイト以内の文字列） 		CryptoFilePath
/dest 出力先名
（80バイト以内の文字列） 		DestinationName
/df 文書情報設定ファイル名
（255バイト以内の文字列） 		DocInfoFileName
/dfp 文書情報設定ファイルのパス
（255バイト以内の文字列） 		DocInfoFilePath
/dialog ダイアログの表示モード
  • dialog：印刷先指定ダイアログを表示する（対話型印刷）
  • auto：直接印刷を実行する（自動印刷）
  • preview：プレビューウィンドウを表示する（対話型印刷プレビュー表示）
  • fullauto：直接印刷を実行する（全自動印刷）
  • pvonly：印刷を実行できないプレビューウィンドウを表示する（対話型印刷プレビュー表示限定）
 DispPrintDlg
/dif 接続情報ファイル名
（255バイト以内の文字列） 		DBInfoFileName
/difp 接続情報ファイルのパス
（255バイト以内の文字列） 		DBInfoFilePath
/dsf PDF仕分け定義ファイル名
（255バイト以内の文字列） 		DistributeFileName
/dsfp PDF仕分け定義ファイルのパス
（255バイト以内の文字列） 		DistributeFilePath
/enc パスワード暗号化鍵
（32バイト以内の文字列） 		EncryptionPasswordKey
/ep 印刷終了ページ
（0～999,999） 		PrintEndPage
/epfn EPF形式ファイル名
（255バイト以内の文字列） 		EPFFileName
/epfnp EPF形式ファイルのパス
（255バイト以内の文字列） 		EPFFilePath
/eurn 出力EUR形式ファイル名
（255バイト以内の文字列） 		EURFileName
/eurnp 出力EUR形式ファイルのパス
（255バイト以内の文字列） 		EURFilePath
/exp 実行可能印刷方式
  • sv：スプールサーバで印刷する
  • svcl：スプールサーバでの印刷，またはクライアントで印刷する
  • cl：クライアントで印刷する
 ExecutablePrintMode
/fc スプールデータの検索キーの分類
（80バイト以内の文字列を10個まで指定できる） 		JobKeyCategory
/fd スプールデータの検索キーの値
（80バイト以内の文字列を10個まで指定できる） 		JobKeyData
/foutdest ※2 PDF形式ファイルの出力先
  • adp：EUR Server - Adapter稼働マシンに出力する
  • pm：EUR Server Service稼働マシンに出力する
 FileOutputDestination
/fp ページ番号の初期値
（1～999,999） 		FirstPageNumber
/g スプールデータの取得可否
  • get：スプールデータの取得を許可する
  • noget：スプールデータの取得を許可しない
 EnableGet
/group 帳票振り分け定義の振り分けグループ名
（80バイト以内の文字列） 		GroupName
/ip ページ番号の開始番号の初期化
  • reset：初期化する
  • normal：初期化しない
 InitPageNumber
/jsc Acrobat JavaScript定義ファイル名
（255バイト以内の文字列） 		ScriptCntlFileName
/jscp Acrobat JavaScript定義ファイルのパス
（255バイト以内の文字列） 		ScriptCntlFilePath
/lm スプールデータの蓄積期限日
  • 日付で指定する場合
    YYYYMMDD形式
  • 日数で指定する場合
    +XXX形式
 SpoolLimit
/lsp 印刷先サーバプリンタ名
（80バイト以内の文字列） 		ServerPrinterName
/lst 印刷先サーバプリンタのトレイ名
（80バイト以内の文字列） 		ServerTrayName
/m 出力と情報取得の機能（メソッド） －
/map ※1 マッピングデータファイル名または可変記号値定義ファイル名
（255バイト以内の文字列） 		DataFileName
/mapp マッピングデータファイルまたは可変記号値定義ファイルのパス
（255バイト以内の文字列） 		DataFilePath
/mepfn ※1 統合対象EPF形式ファイル名
（255バイト以内の文字列） 		MergeEPFFileName
/mepfnp 統合対象EPF形式ファイルのパス
（255バイト以内の文字列） 		MergeEPFFilePath
/message エラーメッセージを出力する －
/mfd 複数様式情報定義ファイル名
（255バイト以内の文字列） 		MultiFormInfoDefFileName
/mfdp 複数様式情報定義ファイルのパス
（255バイト以内の文字列） 		MultiFormInfoDefFilePath
/mrs 帳票セット指定ファイル名
（255バイト以内の文字列） 		MultiReportSetFileName
/mrsp 帳票セット指定ファイルのパス
（255バイト以内の文字列） 		MultiReportSetFilePath
/nomessage エラーメッセージを出力しない －
/num 印刷部数の単位
  • sort：部単位
  • stack：ページ単位
 SortPrint
/p 印刷先クライアントプリンタ名
（80バイト以内の文字列） 		ClientPrinterName
/pdfn ※2 出力PDF形式ファイル名
（255バイト以内の文字列） 		PDFFileName
/pdfnp 出力PDF形式ファイルのパス
（255バイト以内の文字列） 		PDFFilePath
/pf ※3 ページ番号のフォーマット
（任意のフォーマット文字列） 		PageNumberFormat
/pk スプールサーバ印刷方式の印刷モード
  • epf：EPF形式ファイルでの印刷
  • eur：EUR形式ファイルでの印刷
 PrintKind
/pl 余白へのページ番号の印刷位置
  • topl：ページ番号を左上に出力する
  • topc：ページ番号を中央上に出力する
  • topr：ページ番号を右上に出力する
  • btml：ページ番号を左下に出力する
  • btmc：ページ番号を中央下に出力する
  • btmr：ページ番号を右下に出力する
 PageNumberLocation
/pm 出力メソッド（/mオプションの指定値print）の印刷方式
  • default：EUR Server - Adapterの環境設定ファイル（EURPMADP.ini）に設定したデフォルト印刷方式で印刷する
  • cl：クライアントPCで印刷する
  • spl：蓄積する
  • sv：スプールサーバで印刷する
  • pm：帳票サーバで直接印刷する
  • clds：クライアントPCへの配布印刷をする
 PrintMode
/pmip 接続する帳票サーバのIPアドレス
（255.255.255.255形式） 		PMServerAddress
/pmpn 帳票サーバのポート番号
（1～65,535） 		PMServerPort
/pn 余白へのページ番号印刷の有無
  • on：余白へのページ番号を出力する
  • off：余白へのページ番号を出力しない
 PrintPageNumber
/po ※4 用紙の向き
  • portrait：用紙の向きを縦にして印刷する
  • landscape：用紙の向きを横にして印刷する
 PaperOrientation
/prc ※5 プリンタクラス名
（80バイト以内の文字列） 		PrinterClassName
/prdatef 印刷日時出力定義ファイル名
（255バイト以内の文字列） 		PrintDateFileName
/prdatefp 印刷日時出力定義ファイルのパス
（255バイト以内の文字列） 		PrintDateFilePath
/prh 蓄積後に続けて印刷するかどうか
  • hold：続けて印刷しない（印刷保留）
  • sv：続けてスプールサーバで印刷する
  • cl：続けてクライアントPCで印刷する
 PrintHoldMode
/psenvf 環境設定ファイル名
（255バイト以内の文字列） 		PSEnvFileName
/psenvfp 環境設定ファイルのパス
（255バイト以内の文字列） 		PSEnvFilePath
/pvp ビューアプレファレンス定義ファイル名
（255バイト以内の文字列） 		ViewerPreferenceFileName
/pvpp ビューアプレファレンス定義ファイルのパス
（255バイト以内の文字列） 		ViewerPreferenceFilePath
/rac スプールデータの宛先キーの分類
（1～80バイトの文字列） 		ReportAddressKeyCategory
/rad スプールデータの宛先キーの値
（1～80バイトの文字列） 		ReportAddressKeyData
/rf ※1, ※6 帳票ファイル名
（255バイト以内の文字列） 		ReportFileName
/rfp 帳票ファイルのパス
（255バイト以内の文字列） 		ReportFilePath
/rif 置き換え表管理情報ファイル名
（255バイト以内の文字列） 		ReplaceItemCntlFileName
/rifp 置き換え表管理情報ファイルのパス
（255バイト以内の文字列） 		ReplaceItemCntlFilePath
/sf スプールデータに格納する印刷データ（EPF形式ファイル）のファイル名
（255バイト以内の文字列） 		SpoolFileName
/sm プリンタの指定方法
  • class：プリンタクラス名を指定する
  • printer：OS上のプリンタ名を指定する
  • group：帳票名による自動振り分けを行う
 PrinterSelectMode
/sp 印刷開始ページ
（0～999,999） 		PrintStartPage
/split 帳票を分割または仕分けして蓄積するかどうか
  • default：EUR Server Serviceの環境設定ファイル（EURPM.ini）の設定に従う
  • no：分割または仕分けしない
  • key：仕分けする
  • page：分割する
 SplitMode
/splitf 分割定義ファイルまたは仕分け定義ファイル名
（255バイト以内の文字列） 		SplitFileName
/splitfp 分割定義ファイルまたは仕分け定義ファイルのパス
（255バイト以内の文字列） 		SplitFilePath
/sptl スプールタイトル
（255バイト以内の文字列） 		SpoolTitle
/srm スプールサーバの指定方法
  • dest：出力先名を指定する
  • sv：スプールサーバIPアドレスを指定する
 ServerSelectMode
/svr スプールサーバのIPアドレス
（255.255.255.255形式） 		ServerAddress
/t 印刷先クライアントプリンタのトレイ名
（80バイト以内の文字列） 		ClientTrayName
/usr ※1 ユーザ定義データファイル名
（255バイト以内の文字列） 		UserDataFileName
/usrp ユーザ定義データファイルのパス
（255バイト以内の文字列） 		UserDataFilePath
/xlfn 出力Excel形式ファイル名
（255バイト以内の文字列） 		XLSXFileName
/xlfnp 出力Excel形式ファイルのパス
（255バイト以内の文字列） 		XLSXFilePath
/xp スプールデータの上限印刷回数
  • -1：無限に印刷できる
  • 0：印刷を禁止する
  • 1～65,536：印刷回数の上限を指定する
 MaxPrintCount
注※1
複数のファイルを指定できます。複数のファイルを指定する場合は，コンマ（，）で区切ってください。
なお，/mapおよび/usrオプションを指定する場合は，/rfオプションと指定数を合わせる必要があります。
注※2
PDF仕分け定義ファイル名（/dsfオプション）を指定している場合は，指定を省略できます。
注※3
Windows環境の場合とUNIX／Linux環境の場合では，eurpmcコマンドの指定方法が異なります。
  • Windows環境の場合
    ページ番号を「*」，最終ページ番号を「$」で示して出力形式を指定します。
    詳細については，対応するActiveX起動部品のプロパティのPageNumberFormatを参照してください。
  • UNIX／Linux環境の場合
    ページ番号を「*」，最終ページ番号を「\$」で示して出力形式を指定します。
注※4
指定を省略した場合は，帳票を定義したときの情報になります。
注※5
クライアントPCへの配布印刷では，指定できません。
注※6
帳票セット指定ファイル名（/mrsオプション）を指定している場合は，指定を省略できます。

eurpmcコマンドを使用して実行している場合にエラーが発生したときは，標準エラー出力へエラーメッセージを出力するかしないかを，次に示すメッセージオプションで指定します。

  • /message：エラーメッセージを出力します。
  • /nomessage：エラーメッセージを出力しません。

オプションの指定を省略した場合は，/messageが仮定されます。

なお，/nomessageが指定されていても，コマンドの終了コードは設定されます。


オプションを指定するときの注意

1.2.3　オプションを指定するときの注意

＜この項の構成＞
(1)　大文字と小文字の区別について
(2)　同一オプションを複数指定する場合
(3)　無効なオプションについて
(4)　数値項目オプションの指定について
(5)　指定値に使用できない文字について

(1)　大文字と小文字の区別について

オプション，オプションの指定値，およびオプションに指定する文字列は，大文字と小文字を区別します。

例えば，/mオプションを「/M」と指定したり，/mオプションの指定値を「/m PRINT」と指定したりすると，エラーになります。

(2)　同一オプションを複数指定する場合

一つのコマンド構文に同じオプションが複数指定されている場合は，コマンド構文の後方に指定されたオプションが有効となります。

(3)　無効なオプションについて

/mオプションで指定した出力，および情報取得の機能（メソッド）に無効なオプションを指定したときは，無視して実行されます。

(4)　数値項目オプションの指定について

eurpmcコマンドのオプションで数値を指定する場合は，次の点に注意してください。

  • 半角数値だけで指定してください。半角数値以外の文字（コンマ「,」など）を指定すると，エラーになります。
  • 指定可能範囲内の値であれば，前0を含む値を指定してもエラーになりません。ただし，指定可能な桁数は9桁までです。10桁以上の値（"0000000000"など）を指定した場合は，数値の大きさにかかわらず，KEEY904-Eエラーになります。

(5)　指定値に使用できない文字について

オプションの指定値には，制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」は使用できません。これらの文字を指定した場合，帳票管理GUI，［EUR Server Service 構成定義］ダイアログ，［EUR Spool Service 構成定義］ダイアログ，および［EUR Client 構成定義］ダイアログを操作できないことがあります。


eurpmcコマンドの構文

1.3　eurpmcコマンドの構文

eurpmcコマンドの構文は，Windows環境およびUNIX／Linux環境で共通です。ただし，UNIX／Linux環境の場合は，「.exe」は指定できません。eurpmcコマンドは「eurpmc」と指定してください。

ここでは，オプション名のセパレータは，「/」で示しています。UNIX／Linux環境の場合は，「/」を「-」に置き換えてお読みください。

＜この節の構成＞
1.3.1　プリンタに出力する場合
1.3.2　スプールデータを出力する場合
1.3.3　EPF形式ファイルを出力する場合
1.3.4　複数のEPF形式ファイルを統合して出力する場合
1.3.5　EUR形式ファイルを出力する場合
1.3.6　PDF形式ファイルを出力する場合
1.3.7　Excel形式ファイルを出力する場合
1.3.8　出力先一覧を取得する場合
1.3.9　プリンタクラス一覧を取得する場合
1.3.10　プリンタ一覧を取得する場合
1.3.11　トレイ一覧を取得する場合
1.3.12　帳票サーバプリンタクラス一覧を取得する場合
1.3.13　帳票サーバプリンタ一覧を取得する場合
1.3.14　帳票サーバプリンタのトレイ一覧を取得する場合


プリンタに出力する場合

1.3.1　プリンタに出力する場合

eurpmc〔.exe〕
〔/message | /nomessage〕
 /m print
 /rf 帳票ファイル名
〔/rfp 帳票ファイルのパス〕
〔/map マッピングデータファイル名〕
〔/mapp マッピングデータファイルのパス〕
〔/usr ユーザ定義データファイル名〕
〔/usrp ユーザ定義データファイルのパス〕
〔/mrs 帳票セット指定ファイル名〕
〔/mrsp 帳票セット指定ファイルのパス〕
〔/mfd 複数様式情報定義ファイル名〕
〔/mfdp 複数様式情報定義ファイルのパス〕
〔/df 文書情報設定ファイル名〕
〔/dfp 文書情報設定ファイルのパス〕
〔/client クライアントPCのIPアドレス〕
〔/sp 印刷開始ページ〕
〔/ep 印刷終了ページ〕
〔/p 印刷先クライアントプリンタ名〕
〔/t 印刷先クライアントプリンタのトレイ名〕
〔/c 印刷部数〕
〔/num ｛sort｜stack｝〕
〔/po ｛portrait｜landscape｝〕
〔/pn ｛on｜off｝〕
〔/pl ｛topl｜topc｜topr｜btml｜btmc｜btmr｝〕
〔/pf ページ番号のフォーマット〕
〔/fp ページ番号の初期値〕
〔/ip ｛reset｜normal｝〕
〔/dif 接続情報ファイル名〕
〔/difp 接続情報ファイルのパス〕
〔/pm ｛default｜cl｜sv｜pm｜clds｝〕
〔/pk ｛epf｜eur｝〕
〔/srm ｛dest｜sv｝〕
〔/sm ｛class｜printer｜group｝〕
〔/dialog ｛dialog｜auto｜preview｜fullauto｜pvonly｝〕
〔/dest 出力先名〕
〔/svr スプールサーバのIPアドレス〕
〔/prc プリンタクラス名〕
〔/lsp 印刷先サーバプリンタ名〕
〔/lst 印刷先サーバプリンタのトレイ名〕
〔/group 帳票振り分け定義の振り分けグループ名〕
〔/rif 置き換え表管理情報ファイル名〕
〔/rifp 置き換え表管理情報ファイルのパス〕
〔/pmip 帳票サーバのIPアドレス〕
〔/pmpn 帳票サーバのポート番号〕
〔/epfn EPF形式ファイル名〕
〔/epfnp EPF形式ファイルのパス〕
〔/psenvf 環境設定ファイル（EURPS_ENV）のファイル名〕
〔/psenvfp 環境設定ファイル（EURPS_ENV）のパス〕
〔/prdatef 印刷日時出力定義ファイル名〕
〔/prdatefp 印刷日時出力定義ファイルのパス〕
〔/sptl スプールタイトル〕
＜この項の構成＞
(1)　オプション指定時の注意

(1)　オプション指定時の注意

帳票セット（/rfオプション，/mapオプション，/usrオプション）は，複数のファイルを指定する場合，項目を「,」で区切ります。また，/mapオプションおよび/usrオプションを指定する場合は，指定する数を/rfオプションと合わせます。

（指定例1）
  • 帳票セットとして次のように指定したい。
    /rf | Report1.fms | Report2.fms
    /map | Report1.csv | Report2.csv
    /usr | utest.csv | 03_seikyusyo_u.csv
    指定方法
    /rf Report1.fms,Report2.fms /map Report1.csv,Report2.csv /usr utest.csv,03_seikyusyo_u.csv
（指定例2）
  • 帳票セットとして次のように指定したい。
    /rf | Report1.fms | Report2.fms
    /map | Report1.csv | Report2.csv
    /usr | 指定なし | 03_seikyusyo_u.csv
    指定方法
    /rf Report1.fms,Report2.fms /map Report1.csv,Report2.csv /usr ,03_seikyusyo_u.csv

なお，帳票セット指定ファイル名が指定されている場合は，帳票ファイル名の指定は省略できます。

メッセージオプション（/message | /nomessage）については，「1.2　eurpmcコマンドが提供するオプション」を参照してください。

/numオプション，/poオプション，/pnオプション，/plオプション，/ipオプション，/pmオプション，/pkオプション，/srmオプション，/smオプション，および/dialogオプションに指定する値の内容については，「表1-2 プロパティオプションの内容（指定値）と対応するActiveX起動部品のプロパティ」の内容（指定値）を参照してください。

なお，/pmオプションで「cl（クライアント印刷）」または「clds（クライアント配布印刷）」を指定した場合は，必ず/clientオプションを指定してください。

そのほかのオプションについては，ActiveX起動部品のPrintPMReportメソッドを参照してください。


スプールデータを出力する場合

1.3.2　スプールデータを出力する場合

eurpmc〔.exe〕
〔/message | /nomessage〕
 /m print
 /rf 帳票ファイル名
〔/rfp 帳票ファイルのパス〕
〔/map マッピングデータファイル名〕
〔/mapp マッピングデータファイルのパス〕
〔/usr ユーザ定義データファイル名〕
〔/usrp ユーザ定義データファイルのパス〕
〔/mrs 帳票セット指定ファイル名〕
〔/mrsp 帳票セット指定ファイルのパス〕
〔/mfd 複数様式情報定義ファイル名〕
〔/mfdp 複数様式情報定義ファイルのパス〕
〔/df 文書情報設定ファイル名〕
〔/dfp 文書情報設定ファイルのパス〕
〔/client クライアントPCのIPアドレス〕
〔/sp 印刷開始ページ〕
〔/ep 印刷終了ページ〕
〔/p 印刷先クライアントプリンタ名〕
〔/t 印刷先クライアントプリンタのトレイ名〕
〔/c 印刷部数〕
〔/num ｛sort｜stack｝〕
〔/po ｛portrait｜landscape｝〕
〔/pn ｛on｜off｝〕
〔/pl ｛topl｜topc｜topr｜btml｜btmc｜btmr｝〕
〔/pf ページ番号のフォーマット〕
〔/fp ページ番号の初期値〕
〔/ip ｛reset｜normal｝〕
〔/pm ｛default｜spl｝〕
〔/srm ｛dest｜sv｝〕
〔/sm ｛class｜printer｜group｝〕
〔/dialog ｛dialog｜auto｜preview｜fullauto｜pvonly｝〕
〔/dest 出力先名〕
〔/svr スプールサーバのIPアドレス〕
〔/prc プリンタクラス名〕
〔/lsp 印刷先サーバプリンタ名〕
〔/lst 印刷先サーバプリンタのトレイ名〕
〔/group 帳票振り分け定義の振り分けグループ名〕
〔/rif 置き換え表管理情報ファイル名〕
〔/rifp 置き換え表管理情報ファイルのパス〕
〔/exp ｛sv｜svcl｜cl｝〕
〔/sf スプールデータに格納する印刷データ（EPF形式ファイル）のファイル名〕
〔/fc スプールデータの検索キーの分類〕
〔/fd スプールデータの検索キーの値〕
〔/lm スプールデータの蓄積期限日〕
〔/xp ｛-1｜0｜1～65536｝〕
〔/g ｛get｜noget｝〕
〔/prh ｛hold｜sv｜cl｝〕
〔/pmip 帳票サーバのIPアドレス〕
〔/pmpn 帳票サーバのポート番号〕
〔/epfn EPF形式ファイル名〕
〔/epfnp EPF形式ファイルのパス〕
〔/psenvf 環境設定ファイル（EURPS_ENV）のファイル名〕
〔/psenvfp 環境設定ファイル（EURPS_ENV）のパス〕
〔/prdatef 印刷日時出力定義ファイル名〕
〔/prdatefp 印刷日時出力定義ファイルのパス〕
〔/split ｛default｜no｜key｜page｝〕
〔/splitf 分割定義ファイルまたは仕分け定義ファイル名〕
〔/splitfp 分割定義ファイルまたは仕分け定義ファイルのパス〕
〔/alljob〕
〔/rac スプールデータの宛先キーの分類〕
〔/rad スプールデータの宛先キーの値〕
〔/sptl スプールタイトル〕
＜この項の構成＞
(1)　オプション指定時の注意
(2)　出力結果

(1)　オプション指定時の注意

帳票セット（/rfオプション，/mapオプション，/usrオプション）は，複数のファイルを指定する場合，項目を「,」で区切ります。また，/mapオプションおよび/usrオプションを指定する場合は，指定する数を/rfオプションと合わせます。

（指定例1）
  • 帳票セットとして次のように指定したい。
    /rf | Report1.fms | Report2.fms
    /map | Report1.csv | Report2.csv
    /usr | utest.csv | 03_seikyusyo_u.csv
    指定方法
    /rf Report1.fms,Report2.fms /map Report1.csv,Report2.csv /usr utest.csv,03_seikyusyo_u.csv
（指定例2）
  • 帳票セットとして次のように指定したい。
    /rf | Report1.fms | Report2.fms
    /map | Report1.csv | Report2.csv
    /usr | 指定なし | 03_seikyusyo_u.csv
    指定方法
    /rf Report1.fms,Report2.fms /map Report1.csv,Report2.csv /usr ,03_seikyusyo_u.csv

なお，帳票セット指定ファイル名が指定されている場合は，帳票ファイル名の指定は省略できます。

メッセージオプション（/message | /nomessage）については，「1.2　eurpmcコマンドが提供するオプション」を参照してください。

/numオプション，/poオプション，/pnオプション，/plオプション，/ipオプション，/pmオプション，/srmオプション，/smオプション，/dialogオプション，/expオプション，/xpオプション，/gオプション，/prhオプション，および/splitオプションに指定する値の内容については，「表1-2 プロパティオプションの内容（指定値）と対応するActiveX起動部品のプロパティ」の内容（指定値）を参照してください。

そのほかのオプションについては，ActiveX起動部品のPrintPMReportメソッドを参照してください。

(2)　出力結果

出力結果からスプールデータのジョブIDを確認できます。出力結果は標準出力（stdout）に出力されます。出力結果を次に示します。

なお，出力されたプロパティについては，「6.4　ActiveX起動部品のプロパティ仕様」を参照してください。

行 | 書式 | 説明
1 | VVRR▼ | 書式を変更したときのバージョン情報が「VVRR」形式で常に出力されます。
2 | JobID▼ | 見出し名称（プロパティ名を含む）が，1行で常に出力されます。
3 | JobID名▼ 〔JobID名▼〕… | 取得結果（スプールデータのジョブID）が出力されます。 /alljobオプションが指定されている場合，すべてのスプールデータのジョブIDが，改行で区切られて出力されます。なお，蓄積処理中に警告（KEEY387-W）が発生した場合，最終行に文字列「Error」が出力されます。 /alljobオプションが指定されていない場合で，スプールデータが複数あるときは，最初に蓄積したスプールデータのジョブIDが出力されます。
（凡例）
▼：Windows環境の場合，改行コード（0x0d+0x0a）を示します。UNIX／Linux環境の場合，改行コード（0x0a）を示します。


EPF形式ファイルを出力する場合

1.3.3　EPF形式ファイルを出力する場合

eurpmc〔.exe〕
〔/message | /nomessage〕
 /m epf
 /rf 帳票ファイル名
〔/rfp 帳票ファイルのパス〕
〔/map マッピングデータファイル名〕
〔/mapp マッピングデータファイルのパス〕
〔/usr ユーザ定義データファイル名〕
〔/usrp ユーザ定義データファイルのパス〕
〔/mrs 帳票セット指定ファイル名〕
〔/mrsp 帳票セット指定ファイルのパス〕
〔/mfd 複数様式情報定義ファイル名〕
〔/mfdp 複数様式情報定義ファイルのパス〕
〔/df 文書情報設定ファイル名〕
〔/dfp 文書情報設定ファイルのパス〕
〔/sp 印刷開始ページ〕
〔/ep 印刷終了ページ〕
〔/c 印刷部数〕
〔/num ｛sort｜stack｝〕
〔/po ｛portrait｜landscape｝〕
〔/pn ｛on｜off｝〕
〔/pl ｛topl｜topc｜topr｜btml｜btmc｜btmr｝〕
〔/pf ページ番号のフォーマット〕
〔/fp ページ番号の初期値〕
〔/ip ｛reset｜normal｝〕
〔/dif 接続情報ファイル名〕
〔/difp 接続情報ファイルのパス〕
 /epfn EPF形式ファイル名
〔/epfnp EPF形式ファイルのパス〕
〔/prc プリンタクラス名〕
〔/rif 置き換え表管理情報ファイル名〕
〔/rifp 置き換え表管理情報ファイルのパス〕
〔/pmip 帳票サーバのIPアドレス〕
〔/pmpn 帳票サーバのポート番号〕
〔/psenvf 環境設定ファイル（EURPS_ENV）のファイル名〕
〔/psenvfp 環境設定ファイル（EURPS_ENV）のパス〕
〔/prdatef 印刷日時出力定義ファイル名〕
〔/prdatefp 印刷日時出力定義ファイルのパス〕
〔/sptl スプールタイトル〕
＜この項の構成＞
(1)　オプション指定時の注意

(1)　オプション指定時の注意

帳票セット（/rfオプション，/mapオプション，/usrオプション）は，複数のファイルを指定する場合，項目を「,」で区切ります。また，/mapオプションおよび/usrオプションを指定する場合は，指定する数を/rfオプションと合わせます。

（指定例1）
  • 帳票セットとして次のように指定したい。
    /rf | Report1.fms | Report2.fms
    /map | Report1.csv | Report2.csv
    /usr | utest.csv | 03_seikyusyo_u.csv
    指定方法
    /rf Report1.fms,Report2.fms /map Report1.csv,Report2.csv /usr utest.csv,03_seikyusyo_u.csv
（指定例2）
  • 帳票セットとして次のように指定したい。
    /rf | Report1.fms | Report2.fms
    /map | Report1.csv | Report2.csv
    /usr | 指定なし | 03_seikyusyo_u.csv
    指定方法
    /rf Report1.fms,Report2.fms /map Report1.csv,Report2.csv /usr ,03_seikyusyo_u.csv

なお，帳票セット指定ファイル名が指定されている場合は，帳票ファイル名の指定は省略できます。

メッセージオプション（/message | /nomessage）については，「1.2　eurpmcコマンドが提供するオプション」を参照してください。

/numオプション，/poオプション，/pnオプション，/plオプション，および/ipオプションに指定する値の内容については，「表1-2 プロパティオプションの内容（指定値）と対応するActiveX起動部品のプロパティ」の内容（指定値）を参照してください。

そのほかのオプションについては，ActiveX起動部品のOutputEPFReportメソッドを参照してください。


複数のEPF形式ファイルを統合して出力する場合

1.3.4　複数のEPF形式ファイルを統合して出力する場合

eurpmc〔.exe〕
〔/message | /nomessage〕
 /m merge
 /mepfn 統合対象EPF形式ファイル名
〔/mepfnp 統合対象EPF形式ファイルのパス〕
 /epfn 出力EPF形式ファイル名
〔/epfnp 出力EPF形式ファイルのパス〕
〔/sptl スプールタイトル〕
〔/c 印刷部数〕
〔/num ｛sort｜stack｝〕
〔/po ｛portrait｜landscape｝〕
〔/prc プリンタクラス名〕
〔/pmip 帳票サーバのIPアドレス〕
〔/pmpn 帳票サーバのポート番号〕
＜この項の構成＞
(1)　オプション指定時の注意

(1)　オプション指定時の注意

メッセージオプション（/message | /nomessage）については，「1.2　 eurpmcコマンドが提供するオプション」を参照してください。

/mepfnオプションには，複数のファイルを指定します。ファイル名をコンマ（,）で区切って指定してください。

/numオプションおよび/poオプションに指定する値の内容については，「表1-2 プロパティオプションの内容（指定値）と対応するActiveX起動部品のプロパティ」の内容（指定値）を参照してください。

そのほかのオプションについては，ActiveX起動部品のOutputMergeEPFReportメソッドを参照してください。


EUR形式ファイルを出力する場合

1.3.5　EUR形式ファイルを出力する場合

eurpmc〔.exe〕
〔/message | /nomessage〕
 /m eur
 /rf 帳票ファイル名
〔/rfp 帳票ファイルのパス〕
〔/map マッピングデータファイル名〕
〔/mapp マッピングデータファイルのパス〕
〔/usr ユーザ定義データファイル名〕
〔/usrp ユーザ定義データファイルのパス〕
〔/mrs 帳票セット指定ファイル名〕
〔/mrsp 帳票セット指定ファイルのパス〕
〔/mfd 複数様式情報定義ファイル名〕
〔/mfdp 複数様式情報定義ファイルのパス〕
〔/df 文書情報設定ファイル名〕
〔/dfp 文書情報設定ファイルのパス〕
 /eurn 出力EUR形式ファイル名
〔/eurnp 出力EUR形式ファイルのパス〕
〔/dif 接続情報ファイル名〕
〔/difp 接続情報ファイルのパス〕
〔/rif 置き換え表管理情報ファイル名〕
〔/rifp 置き換え表管理情報ファイルのパス〕
〔/pmip 帳票サーバのIPアドレス〕
〔/pmpn 帳票サーバのポート番号〕
〔/psenvf 環境設定ファイル（EURPS_ENV）のファイル名〕
〔/psenvfp 環境設定ファイル（EURPS_ENV）のパス〕
〔/sptl スプールタイトル〕
＜この項の構成＞
(1)　オプション指定時の注意

(1)　オプション指定時の注意

帳票セット（/rfオプション，/mapオプション，/usrオプション）は，複数のファイルを指定する場合，項目を「,」で区切ります。また，/mapオプションおよび/usrオプションを指定する場合は，指定する数を/rfオプションと合わせます。

（指定例1）
  • 帳票セットとして次のように指定したい。
    /rf | Report1.fms | Report2.fms
    /map | Report1.csv | Report2.csv
    /usr | utest.csv | 03_seikyusyo_u.csv
    指定方法
    /rf Report1.fms,Report2.fms /map Report1.csv,Report2.csv /usr utest.csv,03_seikyusyo_u.csv
（指定例2）
  • 帳票セットとして次のように指定したい。
    /rf | Report1.fms | Report2.fms
    /map | Report1.csv | Report2.csv
    /usr | 指定なし | 03_seikyusyo_u.csv
    指定方法
    /rf Report1.fms,Report2.fms /map Report1.csv,Report2.csv /usr ,03_seikyusyo_u.csv

なお，帳票セット指定ファイル名が指定されている場合は，帳票ファイル名の指定は省略できます。

メッセージオプション（/message | /nomessage）については，「1.2　 eurpmcコマンドが提供するオプション」を参照してください。

そのほかのオプションについては，ActiveX起動部品のOutputEURReportメソッドを参照してください。


PDF形式ファイルを出力する場合

1.3.6　PDF形式ファイルを出力する場合

eurpmc〔.exe〕
〔/message | /nomessage〕
 /m pdf
 /rf 帳票ファイル名
〔/rfp 帳票ファイルのパス〕
〔/map マッピングデータファイル名〕
〔/mapp マッピングデータファイルのパス〕
〔/usr ユーザ定義データファイル名〕
〔/usrp ユーザ定義データファイルのパス〕
〔/bmf 文書しおり定義ファイル名〕
〔/bm しおり定義ファイル名〕
〔/bmp 文書しおり定義またはしおり定義ファイルのパス〕
〔/cryf 暗号化設定ファイル名〕
〔/cryfp 暗号化設定ファイルのパス〕
〔/mrs 帳票セット指定ファイル名〕
〔/mrsp 帳票セット指定ファイルのパス〕
〔/mfd 複数様式情報定義ファイル名〕
〔/mfdp 複数様式情報定義ファイルのパス〕
〔/df 文書情報設定ファイル名〕
〔/dfp 文書情報設定ファイルのパス〕
 /pdfn 出力PDF形式ファイル名
〔/pdfnp 出力PDF形式ファイルのパス〕
〔/sp 印刷開始ページ〕
〔/ep 印刷終了ページ〕
〔/pn ｛on｜off｝〕
〔/pl ｛topl｜topc｜topr｜btml｜btmc｜btmr｝〕
〔/pf ページ番号のフォーマット〕
〔/fp ページ番号の初期値〕
〔/ip ｛reset｜normal｝〕
〔/cry ｛1｜0｝〕
〔/dif 接続情報ファイル名〕
〔/difp 接続情報ファイルのパス〕
〔/enc パスワード暗号化鍵〕
〔/rif 置き換え表管理情報ファイル名〕
〔/rifp 置き換え表管理情報ファイルのパス〕
〔/dsf PDF仕分け定義ファイル名〕
〔/dsfp PDF仕分け定義ファイルのパス〕
〔/jscp Acrobat JavaScript定義ファイルのパス〕
〔/jsc Acrobat JavaScript定義ファイル名〕
〔/pvpp ビューアプレファレンス定義ファイルのパス〕
〔/pvp ビューアプレファレンス定義ファイル名〕
〔/pmip 帳票サーバのIPアドレス〕
〔/pmpn 帳票サーバのポート番号〕
〔/psenvf 環境設定ファイル（EURPS_ENV）のファイル名〕
〔/psenvfp 環境設定ファイル（EURPS_ENV）のパス〕
〔/foutdest ファイルの出力先〕
＜この項の構成＞
(1)　オプション指定時の注意

(1)　オプション指定時の注意

帳票セット（/rfオプション，/mapオプション，/usrオプション，/bmオプション）は，複数のファイルを指定する場合，項目を「,」で区切ります。また，/mapオプションおよび/usrオプションを指定する場合は，指定する数を/rfオプションと合わせます。

（指定例1）
  • 帳票セットとして次のように指定したい。
    /rf | Report1.fms | Report2.fms
    /map | Report1.csv | Report2.csv
    /usr | utest.csv | 03_seikyusyo_u.csv
    /bm | shiori1.txt | shiori2.txt
    指定方法
    /rf Report1.fms,Report2.fms /map Report1.csv,Report2.csv /usr utest.csv,03_seikyusyo_u.csv /bm shiori1.txt,shiori2.txt
（指定例2）
  • 帳票セットとして次のように指定したい。
    /rf | Report1.fms | Report2.fms
    /map | Report1.csv | Report2.csv
    /usr | 指定なし | 03_seikyusyo_u.csv
    /bm | shiori1.txt | shiori2.txt
    指定方法
    /rf Report1.fms,Report2.fms /map Report1.csv,Report2.csv /usr ,03_seikyusyo_u.csv /bm shiori1.txt,shiori2.txt

なお，帳票セット指定ファイル名が指定されている場合は，帳票ファイル名の指定は省略できます。

PDF仕分け定義ファイル名が指定されている場合は，出力PDF形式ファイル名の指定は省略できます。

メッセージオプション（/message | /nomessage）については，「1.2　 eurpmcコマンドが提供するオプション」を参照してください。

/pnオプション，/plオプション，/ipオプション，および/cryオプションに指定する値の内容については，「表1-2 プロパティオプションの内容（指定値）と対応するActiveX起動部品のプロパティ」を参照してください。

そのほかのオプションについては，ActiveX起動部品のOutputPDFReportメソッドを参照してください。


Excel形式ファイルを出力する場合

1.3.7　Excel形式ファイルを出力する場合

eurpmc〔.exe〕
〔/message | /nomessage〕
 /m  xlsx
 /rf 帳票ファイル名
〔/rfp 帳票ファイルのパス〕
〔/map マッピングデータファイル名〕
〔/mapp マッピングデータファイルのパス〕
〔/usr ユーザ定義データファイル名〕
〔/usrp ユーザ定義データファイルのパス〕
〔/sp 印刷開始ページ〕
〔/ep 印刷終了ページ〕
〔/dif 接続情報ファイル名〕
〔/difp 接続情報ファイルのパス〕
 /xlfn Excel形式ファイル名
〔/xlfnp Excel形式ファイルのパス〕
〔/rif 置き換え表管理情報ファイル名〕
〔/rifp 置き換え表管理情報ファイルのパス〕
〔/pmip 帳票サーバのIPアドレス〕
〔/pmpn 帳票サーバのポート番号〕
〔/psenvf 環境設定ファイル（EURPS_ENV）のファイル名〕
〔/psenvfp 環境設定ファイル（EURPS_ENV）のパス〕
＜この項の構成＞
(1)　オプション指定時の注意

(1)　オプション指定時の注意

帳票セット（/rfオプション，/mapオプション，/usrオプション）は，単数のファイルしか指定できません。また，/mapオプションおよび/usrオプションを指定する場合は，指定する数を/rfオプションと合わせます。

メッセージオプション（/message | /nomessage）については，「1.2　 eurpmcコマンドが提供するオプション」を参照してください。

そのほかのオプションについては，ActiveX起動部品のOutputXLSXReportメソッドを参照してください。


出力先一覧を取得する場合

1.3.8　出力先一覧を取得する場合

eurpmc〔.exe〕
〔/message | /nomessage〕
 /m getdest
〔/pmip   帳票サーバのIPアドレス〕
〔/pmpn   帳票サーバのポート番号〕
＜この項の構成＞
(1)　オプション指定時の注意
(2)　出力結果

(1)　オプション指定時の注意

メッセージオプション（/message | /nomessage）については，「1.2　 eurpmcコマンドが提供するオプション」を参照してください。

そのほかのオプションについては，ActiveX起動部品のGetDestinationListメソッドを参照してください。

(2)　出力結果

出力先の一覧が標準出力（stdout）に出力されます。出力結果を次に示します。

なお，出力されたプロパティについては，「6.4　ActiveX起動部品のプロパティ仕様」を参照してください。

行 | 書式 | 説明
1 | VVRR▼ | 書式を変更したときのバージョン情報が「VVRR」形式で常に出力されます。
2 | DestinationName,IPAddress,Explanation▼ | 「,」で区切られた見出し名称（プロパティ名を含む）が，常に出力されます。
3～ | 出力先一覧▼ 〔出力先一覧▼〕… | 2行目に出力された見出し名称（プロパティ名を含む）に設定されている値が「,」で区切られて出力されます。 取得結果は1件につき1行で，件数分出力されます。取得結果が0件のときは出力されません。
（凡例）
▼：Windows環境の場合，改行コード（0x0d+0x0a）を示します。UNIX／Linux環境の場合，改行コード（0x0a）を示します。


プリンタクラス一覧を取得する場合

1.3.9　プリンタクラス一覧を取得する場合

eurpmc〔.exe〕
〔/message | /nomessage〕
 /m getprclass
〔/dest 出力先名〕
〔/pmip  帳票サーバのIPアドレス〕
〔/pmpn  帳票サーバのポート番号〕
＜この項の構成＞
(1)　オプション指定時の注意
(2)　出力結果

(1)　オプション指定時の注意

メッセージオプション（/message | /nomessage）については，「1.2　 eurpmcコマンドが提供するオプション」を参照してください。

そのほかのオプションについては，ActiveX起動部品のGetPrinterClassListメソッドを参照してください。

(2)　出力結果

プリンタクラス一覧が標準出力（stdout）に出力されます。出力結果を次に示します。出力されたプロパティについては，「6.4　ActiveX起動部品のプロパティ仕様」の内容（指定値）を参照してください。

なお，/destオプションを指定していない場合は，デフォルトの出力先として登録されたスプールサーバに定義されているプリンタクラスの一覧を取得します。

行 | 書式 | 説明
1 | VVRR▼ | 書式を変更したときのバージョン情報が「VVRR」形式で常に出力されます。
2 | PrinterClassName, PrinterName, TrayName, Description▼ | 「,」で区切られた見出し名称（プロパティ名を含む）が，1行で常に出力されます。
3～ | プリンタクラス名, OS上のプリンタ名, OS上のプリンタのトレイ名, 説明▼ 〔プリンタクラス名, OS上のプリンタ名, OS上のプリンタのトレイ名, 説明▼〕… | 2行目に出力された見出し名称（プロパティ名を含む）に設定されている値が「,」で区切られて出力されます。「SpoolPath」の値には，常に""が出力されます。 取得結果は1件につき1行で，件数分出力されます。取得結果が0件のときは出力されません。
（凡例）
▼：Windows環境の場合，改行コード（0x0d+0x0a）を示します。UNIX／Linux環境の場合，改行コード（0x0a）を示します。


プリンタ一覧を取得する場合

1.3.10　プリンタ一覧を取得する場合

eurpmc〔.exe〕
〔/message | /nomessage〕
 /m getpr
〔/dest 出力先名〕
〔/pmip  帳票サーバのIPアドレス〕
〔/pmpn  帳票サーバのポート番号〕
＜この項の構成＞
(1)　オプション指定時の注意
(2)　出力結果

(1)　オプション指定時の注意

メッセージオプション（/message | /nomessage）については，「1.2　 eurpmcコマンドが提供するオプション」を参照してください。

そのほかのオプションについては，ActiveX起動部品のGetPrinterListメソッドを参照してください。

(2)　出力結果

OS上のプリンタ名が標準出力（stdout）に出力されます。出力結果を次に示します。出力されたプロパティについては，「6.4　ActiveX起動部品のプロパティ仕様」の内容（指定値）を参照してください。

なお，/destオプションを指定していない場合は，デフォルトの出力先として登録されたスプールサーバのOS上のプリンタ一覧を取得します。

行 | 書式 | 説明
1 | VVRR▼ | 書式を変更したときのバージョン情報が「VVRR」形式で常に出力されます。
2 | PrinterName▼ | 見出し名称（プロパティ名を含む）が，1行で常に出力されます。
3～ | OS上のプリンタ名▼ 〔OS上のプリンタ名▼〕… | 2行目に出力されたプロパティに設定されている値が出力されます。 取得結果は1件につき1行で，件数分出力されます。取得結果が0件のときは出力されません。
（凡例）
▼：Windows環境の場合，改行コード（0x0d+0x0a）を示します。UNIX／Linux環境の場合，改行コード（0x0a）を示します。


トレイ一覧を取得する場合

1.3.11　トレイ一覧を取得する場合

eurpmc〔.exe〕
〔/message | /nomessage〕
 /m gettray
 /lsp 印刷先サーバプリンタ名
〔/dest 出力先名〕
〔/pmip   帳票サーバのIPアドレス〕
〔/pmpn   帳票サーバのポート番号〕
＜この項の構成＞
(1)　オプション指定時の注意
(2)　出力結果

(1)　オプション指定時の注意

メッセージオプション（/message | /nomessage）については，「1.2　 eurpmcコマンドが提供するオプション」を参照してください。

そのほかのオプションについては，ActiveX起動部品のGetTrayListメソッドを参照してください。

(2)　出力結果

OS上のプリンタのトレイ名が標準出力（stdout）に出力されます。出力結果を次に示します。出力されたプロパティについては，「6.4　ActiveX起動部品のプロパティ仕様」を参照してください。

なお，/destオプションを指定していない場合は，デフォルトの出力先として登録されたスプールサーバのOS上のプリンタのトレイ一覧を取得します。

行 | 書式 | 説明
1 | VVRR▼ | 書式を変更したときのバージョン情報が「VVRR」形式で常に出力されます。
2 | TrayName▼ | 見出し名称（プロパティ名を含む）が，1行で常に出力されます。
3～ | OS上のプリンタのトレイ名▼ 〔OS上のプリンタのトレイ名▼〕… | 2行目に出力されたプロパティに設定されている値が出力されます。 取得結果は1件につき1行で，件数分出力されます。取得結果が0件のときは出力されません。
（凡例）
▼：Windows環境の場合，改行コード（0x0d+0x0a）を示します。UNIX／Linux環境の場合，改行コード（0x0a）を示します。


帳票サーバプリンタクラス一覧を取得する場合

1.3.12　帳票サーバプリンタクラス一覧を取得する場合

eurpmc〔.exe〕
〔/nomessage | /message〕
 /m  getpmprclass
〔/pmip   帳票サーバのIPアドレス〕
〔/pmpn   帳票サーバのポート番号〕
＜この項の構成＞
(1)　オプション指定時の注意
(2)　出力結果

(1)　オプション指定時の注意

メッセージオプション（/message | /nomessage）については，「1.2　 eurpmcコマンドが提供するオプション」を参照してください。

そのほかのオプションについては，ActiveX起動部品のGetPMPrinterClassListを参照してください。

(2)　出力結果

帳票サーバのプリンタクラス一覧が標準出力（stdout）に出力されます。出力結果を次に示します。

なお，出力されたプロパティについては，「6.4　ActiveX起動部品のプロパティ仕様」を参照してください。

行 | 書式 | 説明
1 | VVRR▼ | 書式を変更したときのバージョン情報が「VVRR」形式で常に出力されます。
2 | PrinterClassName,PrinterName,TrayName, Description▼ | 「,」で区切られた見出し名称（プロパティ名を含む）が，1行で常に出力されます。
3～ | プリンタクラス名, OS上のプリンタ名, OS上のプリンタのトレイ名, 説明▼… | 取得値（帳票サーバプリンタクラス一覧）が出力されます。 取得結果は1件につき1行で，件数分出力されます。取得結果が0件のときは出力されません。
（凡例）
▼：Windows環境の場合，改行コード（0x0d+0x0a）を示します。UNIX／Linux環境の場合，改行コード（0x0a）を示します。


帳票サーバプリンタ一覧を取得する場合

1.3.13　帳票サーバプリンタ一覧を取得する場合

eurpmc〔.exe〕
〔/nomessage | /message〕
 /m  getpmpr
〔/pmip   帳票サーバのIPアドレス〕
〔/pmpn   帳票サーバのポート番号〕
＜この項の構成＞
(1)　オプション指定時の注意
(2)　出力結果

(1)　オプション指定時の注意

メッセージオプション（/nomessage | /message）については，「1.2　 eurpmcコマンドが提供するオプション」を参照してください。

そのほかのオプションについては，ActiveX起動部品のGetPMPrinterListを参照してください。

(2)　出力結果

帳票サーバに登録されているOS上のプリンタ名が標準出力（stdout）に出力されます。出力結果を次に示します。

なお，出力されたプロパティについては，「6.4　ActiveX起動部品のプロパティ仕様」を参照してください。

行 | 書式 | 説明
1 | VVRR▼ | 書式を変更したときのバージョン情報が「VVRR」形式で常に出力されます。
2 | PrinterName▼ | 見出し名称（プロパティ名を含む）が，1行で常に出力されます。
3～ | 帳票サーバに登録されているOS上のプリンタ名▼ | 取得値（帳票サーバに登録されているOS上のプリンタ名）が出力されます。 取得結果は1件につき1行で，件数分出力されます。取得結果が0件のときは出力されません。
（凡例）
▼：Windows環境の場合，改行コード（0x0d+0x0a）を示します。UNIX／Linux環境の場合，改行コード（0x0a）を示します。


帳票サーバプリンタのトレイ一覧を取得する場合

1.3.14　帳票サーバプリンタのトレイ一覧を取得する場合

eurpmc〔.exe〕
〔/nomessage | /message〕
 /m  getpmtray
 /lsp サーバプリンタ名
〔/pmip   帳票サーバのIPアドレス〕
〔/pmpn   帳票サーバのポート番号〕
＜この項の構成＞
(1)　オプション指定時の注意
(2)　出力結果

(1)　オプション指定時の注意

メッセージオプション（/nomessage | /message）については，「1.2　 eurpmcコマンドが提供するオプション」を参照してください。

そのほかのオプションについては，ActiveX起動部品のGetPMTrayListを参照してください。

(2)　出力結果

帳票サーバ上のプリンタのトレイ名が標準出力（stdout）に出力されます。出力結果を次に示します。

なお，出力されたプロパティについては，「6.4　ActiveX起動部品のプロパティ仕様」を参照してください。

行 | 書式 | 説明
1 | VVRR▼ | 書式を変更したときのバージョン情報が「VVRR」形式で常に出力されます。
2 | TrayName▼ | 見出し名称（プロパティ名を含む）が，1行で常に出力されます。
3～ | 帳票サーバ上のプリンタのトレイ名▼ | 取得値（帳票サーバ上のプリンタのトレイ名）が出力されます。 取得結果は1件につき1行で，件数分出力されます。取得結果が0件のときは出力されません。
（凡例）
▼：Windows環境の場合，改行コード（0x0d+0x0a）を示します。UNIX／Linux環境の場合，改行コード（0x0a）を示します。


エラー情報

1.4　エラー情報

eurpmcコマンドでは，エラーを検知すると，メッセージオプション（/message）によって次に示す標準エラーを出力します。

表1-3　eurpmcコマンドの標準エラー出力

エラー種別 | 発生条件 | メッセージID
コマンド実行時エラー | コマンド実行時にエラーが発生したとき | KEEY901-E
 | コマンド実行時に警告が発生したとき | KEEY908-W
 | メモリ不足が発生したとき | KEEY906-E
コマンドシンタックスエラー | 不明なオプションを指定したとき | KEEY902-E
 | オプションに値の指定がないとき | KEEY903-E
 | オプションの指定値が不正なとき | KEEY904-E
 | 指定が必須のオプションが指定されていないとき | KEEY905-E
＜この節の構成＞
1.4.1　eurpmcコマンドの終了コード
1.4.2　エラーメッセージのフォーマット


eurpmcコマンドの終了コード

1.4.1　eurpmcコマンドの終了コード

eurpmcコマンドを実行すると，終了コードが返されます。終了コード一覧を次に示します。

表1-4　eurpmcコマンドの終了コード

終了コード | 意味
0 | eurpmcコマンドが正常に終了しました。
4 | eurpmcコマンドの実行中に，警告が発生しました。
8 | eurpmcコマンドの実行中に，エラーが発生しました。

eurpmcコマンドを呼び出しているAPIでは，eurpmcコマンドの終了コードを参照して，エラーチェックしてください。ただし，環境設定ファイル（EURPMADP.ini）の[ERROR]セクションのDBZEROEXITCODEキーに値が設定されている場合，KEEY909-Wメッセージの終了コードはDBZEROEXITCODEキーで指定した値になります。

DBZEROEXITCODEキーの詳細については，「15.4.7　DBZEROEXITCODE」を参照してください。


エラーメッセージのフォーマット

1.4.2　エラーメッセージのフォーマット

eurpmcコマンドを実行したとき，標準エラーに出力されるメッセージのフォーマットを次に示します。

エラーメッセージの場合
eurpmc:△KEEY9XX-E△エラーメッセージ▼
（凡例）
△：半角空白を示します。
▼：改行（0x0d+0x0a）を示します。
警告メッセージの場合
eurpmc:△KEEY9XX-W△エラーメッセージ▼
（凡例）
△：半角空白を示します。
▼：改行（0x0d+0x0a）を示します。


eurpmlscコマンド

2.　eurpmlscコマンド

この章では，EUR Server - Spool Serviceを起動するeurpmlscコマンドについて説明します。

＜この章の構成＞
2.1　eurpmlscコマンドとは
2.2　eurpmlscコマンドが提供するオプション
2.3　eurpmlscコマンドの構文
2.4　エラー情報


eurpmlscコマンドとは

2.1　eurpmlscコマンドとは

eurpmlscコマンドを使用して，EUR Server - Spool Serviceをコマンド起動できます。

eurpmlscコマンドでは，ジョブIDやメソッド種別などをコマンドのオプションに設定することで，スプールデータを操作します。

＜この節の構成＞
2.1.1　eurpmlscコマンドのファイル名


eurpmlscコマンドのファイル名

2.1.1　eurpmlscコマンドのファイル名

＜この項の構成＞
(1)　Windows環境の場合
(2)　UNIX／Linux環境の場合

(1)　Windows環境の場合

EURPMLSC.exe
eurpmlscコマンドのファイルです。EUR Server - Spool Service Adapterをインストールしたときに，次に示すフォルダにインストールされます。
    インストール先フォルダ\SpoolAdapter\Program

(2)　UNIX／Linux環境の場合

eurpmlsc
eurpmlscコマンドのファイルです。/opt/eur/spool-adp/bin/にあります。


eurpmlscコマンドが提供するオプション

2.2　eurpmlscコマンドが提供するオプション

eurpmlscコマンドは，eurpmlscコマンドにオプションを指定することで，スプールデータを操作します。

オプション名のセパレータは，「/」で示しています。UNIX／Linux環境の場合は，「/」を「-」に置き換えてお読みください。

＜この節の構成＞
2.2.1　メソッドオプション一覧
2.2.2　プロパティオプション一覧
2.2.3　オプションを指定するときの注意


メソッドオプション一覧

2.2.1　メソッドオプション一覧

eurpmlscコマンドでは，蓄積操作と構成定義情報取得の機能（メソッド）を，/mオプションで次のように指定します。

/m ｛getoutline | getattr | setattr | print | get | del | getprclass | getpr | gettray｝

/mオプションの指定値とその内容を次に示します。また，/mオプションの指定値が，どのSS-ActiveX起動部品のメソッドと対応しているかも示します。

表2-1　/mオプションの指定値と対応するSS-ActiveX起動部品のメソッド

種類 | /mオプションの指定値 | 内容 | 対応するSS-ActiveX起動部品のメソッド
蓄積操作 | getoutline | 指定条件に適合するEUR Server - Spool Serviceのスプールデータの一覧を取得します。 | GetSpoolFileOutline
 | getattr | 指定したジョブIDのスプールデータの属性情報を取得します。 | GetSpoolFileAttribute
 | setattr | 指定したジョブIDのスプールデータの属性情報を変更します。 | SetSpoolFileAttribute
 | print | 指定したジョブIDのスプールデータに格納されているEPF形式ファイルを印刷します。 | PrintSpoolReport
 | get | ジョブIDのスプールデータに格納されているEPF形式ファイルを，指定したパスに取得します。 | GetSpoolFile
 | del | 指定したジョブIDのスプールデータを削除したり，蓄積期限を経過したスプールデータを削除したりします。 | DeleteSpoolFile
構成定義情報取得※ | getprclass | PrinterClassListプロパティで指定したEUR Server - Spool Serviceのプリンタクラス一覧を取得します。 | GetPrinterClassList
 | getpr | ServerPrinterListプロパティで指定したEUR Server - Spool ServiceがあるOS上のプリンタ一覧を取得します。 | GetPrinterList
 | gettray | ServerTrayListプロパティで指定したEUR Server - Spool ServiceがあるOS上のプリンタのトレイ一覧を取得します。 | GetTrayList
監査ログ | chgadtlog | 指定したスプールサーバ上で出力する監査ログを切り替えます。 | ChangeAuditLog
注※
UNIX／Linux環境の場合，構成定義情報取得メソッドは指定できません。


プロパティオプション一覧

2.2.2　プロパティオプション一覧

eurpmlscコマンドで指定できるプロパティオプションを次に示します。また，各プロパティオプションの指定値が，どのSS-ActiveX起動部品のプロパティと対応しているかも示します。

表2-2　プロパティオプションの内容（指定値）と対応するSS-ActiveX起動部品のプロパティ

プロパティオプション 内容
（指定値） 		対応するSS-ActiveX起動部品のプロパティ
/c 印刷部数
（1～99） 		PrintCopies
/ca スプールデータの検索キーの分類
（80バイト以内の文字列を10個まで指定できる） 		JobKeyCategory
/client 蓄積クライアント印刷時のクライアントPCのIPアドレス
（255.255.255.255形式） 		ClientAddress
/da スプールデータの検索キーの値
（80バイト以内の文字列を10個まで指定できる） 		JobKeyData
/dialog 蓄積クライアント印刷時のダイアログ表示モード
  • dialog：印刷先指定ダイアログを表示する（対話型印刷）
  • auto：直接印刷を実行する（自動印刷）
  • preview：プレビューウィンドウを表示する（対話型印刷プレビュー表示）
  • fullauto：直接印刷を実行する（全自動印刷）
  • pvonly：印刷を実行できないプレビューウィンドウを表示する（対話型印刷プレビュー表示限定）
 DispPrintDlg
/dk スプールデータ削除時の削除種別
  • direct：指定したスプールデータを削除する
  • expire：蓄積期限切れファイルを削除する
 DeleteKind
/ep 蓄積スプールサーバ印刷の終了ページ
（0～999,999） 		PrintEndPage
/exp スプールデータの実行可能印刷方式
  • sv：スプールサーバで印刷する
  • svcl：スプールサーバでの印刷，またはクライアントで印刷する
  • cl：クライアントで印刷する
 ExecutablePrintMode
/fc 検索キーでスプールデータを検索するときの検索キーの分類
（80バイト以内の文字列を10個まで指定できる） 		SearchJobKeyCategory
/fd スプールデータを検索するときのジョブ検索キーの値
（80バイト以内の文字列を10個まで指定できる） 		SearchJobKeyData
/g スプールデータの取得可否
  • get：スプールデータの取得を許可する
  • noget：スプールデータの取得を許可しない
 EnableGet
/group スプールデータの振り分けグループ名
（80バイト以内の文字列） 		GroupName
/id スプールデータを検索するときのジョブID
（36バイト以内の文字列） 		SearchJobID
/inc スプールデータをスプールデータに格納されているEPF形式ファイル名で検索するときに指定するEPF形式ファイル名
（255バイト以内の文字列） 		SearchSpoolFileName
/lm スプールデータの蓄積期限日
（YYYYMMDD形式） 		SpoolLimit
/lsp スプールサーバでのOS上のプリンタ名
（80バイト以内の文字列） 		ServerPrinterName
/lst スプールサーバでのOS上のプリンタのトレイ名
（80バイト以内の文字列） 		ServerTrayName
/m 蓄積操作と構成定義情報取得の機能（メソッド） －
/message エラーメッセージを出力する －
/nomessage エラーメッセージを出力しない －
/num 印刷部数の単位
  • sort：部単位
  • stack：ページ単位
 SortPrint
/o スプールデータを取得するフォルダのパス
（255バイト以内の文字列） 		OutputFilePath
/ofn スプールデータから取得後のEPF形式ファイル名
（255バイト以内の文字列） 		OutputFileName
/p 蓄積クライアント印刷するときのOS上のプリンタ名
（80バイト以内の文字列） 		ClientPrinterName
/pc プリンタクラス名で蓄積フォルダのファイル一覧を検索するときのプリンタクラス名
（80バイト以内の文字列） 		SearchPrinterClassName
/pm スプールデータの印刷方式
  • cl：蓄積クライアントで印刷する
  • sv：蓄積スプールサーバで印刷する
 PrintMode
/po 用紙の向き
  • none：EPF形式ファイルを蓄積したときのページごとの属性に従う
  • portrait：用紙の向きを縦にして印刷する
  • landscape：用紙の向きを横にして印刷する
 PaperOrientation
/prc スプールデータのプリンタクラス名
（80バイト以内の文字列） 		PrinterClassName
/rac スプールデータを検索するときの宛先キーの分類
（1～80バイトの文字列） 		SearchReportAddressKeyCategory
/rad スプールデータを検索するときの宛先キーの値
（1～80バイトの文字列） 		SearchReportAddressKeyData
/sm 蓄積スプールサーバ印刷方式のプリンタ指定方式
  • class：プリンタクラス名を指定する
  • printer：OS上のプリンタ名を指定する
  • group：帳票名による自動振り分け
 PrinterSelectMode
/sp 蓄積スプールサーバ印刷の開始ページ
（0～999,999） 		PrintStartPage
/sptl スプールタイトル
（255バイト以内の文字列） 		SpoolTitle
/svr スプールサーバのIPアドレス
（255.255.255.255形式） 		ServerAddress
/t 蓄積クライアント印刷するときのプリンタのトレイ名
（80バイト以内の文字列） 		ClientTrayName
/te ファイル作成日時でスプールデータを検索するときの検索終了日時
（YYYYMMDDhhmmss形式） 		SearchCreateTimeEnd
/ts ファイル作成日時でスプールデータを検索するときの検索開始日時
（YYYYMMDDhhmmss形式） 		SearchCreateTimeStart
/xp スプールデータの印刷上限回数
  • -1：無限に印刷できる
  • 0：印刷を禁止する
  • 1～65,536：印刷回数の上限
 MaxPrintCount

eurpmlscコマンドを使用して実行している場合にエラーが発生したときは，標準エラー出力へエラーメッセージを出力するかしないかを，次に示すメッセージオプションで指定します。

  • /message：エラーメッセージを出力します。
  • /nomessage：エラーメッセージを出力しません。

オプションの指定を省略した場合は，/messageが仮定されます。

なお，/nomessageが指定されていても，コマンドの終了コードは設定されます。


オプションを指定するときの注意

2.2.3　オプションを指定するときの注意

＜この項の構成＞
(1)　大文字と小文字の区別について
(2)　同一オプションを複数指定する場合
(3)　無効なオプションについて
(4)　指定値に使用できない文字について

(1)　大文字と小文字の区別について

オプション，オプションの指定値，およびオプションに指定する文字列は，大文字と小文字を区別します。

例えば，/mオプションを「/M」と指定したり，/mオプションの指定値を「/m GETOUTLINE」と指定したりすると，エラーになります。

(2)　同一オプションを複数指定する場合

一つのコマンド構文に，同じオプションが複数指定されている場合は，コマンド構文の後方に指定されたオプションが有効となります。

(3)　無効なオプションについて

/mオプションで指定した蓄積操作，および構成定義情報取得の機能（メソッド）に無効なプロパティオプションを指定したときは，無視して実行されます。

/mオプションで指定した蓄積操作，および構成定義情報取得の機能（メソッド）を実行するとき，どのプロパティオプションの指定が必要かを表2-3に示します。

/mオプションを指定したときに必要なオプションは，蓄積操作および構成定義情報取得で使用します。表2-3の表見出しの番号は，次に示すメソッドに対応しています。

表見出しの番号 | 対応するメソッド
1 | getoutline
2 | getattr
3 | setattr
4 | print
5 | get
6 | del
7 | getprclass
8 | getpr
9 | gettray
10 | chgadtlog

表2-3　/mオプションを指定したときに必要なプロパティオプション

プロパティオプション | /mオプション
 | 蓄積操作 |  |  |  |  |  | 構成定義情報取得 |  |  | 監査ログ
 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10
/c | － | － | － | △ | △ | － | － | － | － | －
/ca | － | － | △ | － | － | － | － | － | － | －
/client | － | － | △ | △ | － | － | － | － | － | －
/da | － | － | △ | － | － | － | － | － | － | －
/dialog | － | － | △ | △ | － | － | － | － | － | －
/dk | － | － | － | － | － | △ | － | － | － | －
/ep | － | － | － | △ | － | － | － | － | － | －
/exp | － | － | △ | － | － | － | － | － | － | －
/fc | △ | － | － | － | － | － | － | － | － | －
/fd | △ | － | － | － | － | － | － | － | － | －
/g | － | － | △ | － | － | － | － | － | － | －
/group | － | － | △ | △ | － | － | － | － | － | －
/id | △ | ○ | ○ | ○ | ○ | ○／－ | － | － | － | －
/inc | △ | － | － | － | － | － | － | － | － | －
/lm | － | － | △ | － | － | － | － | － | － | －
/lsp | － | － | △ | △ | － | － | － | － | ○ | －
/lst | － | － | △ | △ | － | － | － | － | － | －
/message | /nomessage | △ | △ | △ | △ | △ | △ | △ | △ | △ | △
/num | － | － | － | △ | △ | － | － | － | － | －
/o | － | － | － | － | △ | － | － | － | － | －
/ofn | － | － | － | － | △ | － | － | － | － | －
/p | － | － | △ | △ | － | － | － | － | － | －
/pc | △ | － | － | － | － | － | － | － | － | －
/pm | － | － | － | △ | － | － | － | － | － | －
/po | － | － | － | △ | △ | － | － | － | － | －
/prc | － | － | △ | △ | △ | － | － | － | － | －
/rac | △ | － | － | － | － | － | － | － | － | －
/rad | △ | － | － | － | － | － | － | － | － | －
/sm | － | － | △ | △ | － | － | － | － | － | －
/sp | － | － | － | △ | － | － | － | － | － | －
/sptl | － | － | － | △ | △ | － | － | － | － | －
/svr | △ | △ | △ | △ | △ | △ | △ | △ | △ | △
/t | － | － | △ | △ | － | － | － | － | － | －
/te | △ | － | － | － | － | － | － | － | － | －
/ts | △ | － | － | － | － | － | － | － | － | －
/xp | － | － | △ | － | － | － | － | － | － | －
（凡例）
○：必ず指定します。
△：指定を省略できます。
－：指定できません。

(4)　指定値に使用できない文字について

オプションの指定値には，制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」は使用できません。これらの文字を指定した場合，帳票管理GUI，［EUR Server Service 構成定義］ダイアログ，［EUR Spool Service 構成定義］ダイアログ，および［EUR Client 構成定義］ダイアログを操作できないことがあります。


eurpmlscコマンドの構文

2.3　eurpmlscコマンドの構文

eurpmlscコマンドの構文は，Windows環境およびUNIX／Linux環境で共通です。ただし，UNIX／Linux環境の場合は，eurpmlscコマンドを「eurpmlsc」と指定してください。「.exe」は指定できません。

ここでは，オプション名のセパレータは，「/」で示しています。UNIX／Linux環境の場合は，「/」を「-」に置き換えてお読みください。

＜この節の構成＞
2.3.1　スプールデータの一覧を取得する場合
2.3.2　スプールデータの属性値を取得する場合
2.3.3　スプールデータの属性値を変更する場合
2.3.4　スプールデータを蓄積データ印刷する場合
2.3.5　スプールデータを取得する場合
2.3.6　スプールデータを削除する場合
2.3.7　プリンタクラス一覧を取得する場合
2.3.8　プリンタ一覧を取得する場合
2.3.9　トレイ一覧を取得する場合
2.3.10　監査ログを切り替える場合


スプールデータの一覧を取得する場合

2.3.1　スプールデータの一覧を取得する場合

eurpmlsc〔.exe〕
〔/message | /nomessage〕
 /m getoutline
〔/svr スプールサーバのIPアドレス〕
〔/id スプールデータを検索するときのジョブID〕
〔/inc 格納ファイル名で蓄積フォルダのファイル一覧を検索するときの
       格納ファイル名〕
〔/pc プリンタクラス名で蓄積フォルダのファイル一覧を検索するときの
      プリンタクラス名〕
〔/ts ファイル作成日時でスプールデータを検索するときの検索開始日時〕
〔/te ファイル作成日時でスプールデータを検索するときの検索終了日時〕
〔/fc スプールデータを検索するときのジョブ検索キーの分類〕
〔/fd スプールデータを検索するときのジョブ検索キーの値〕
〔/rac スプールデータを検索するときの宛先キーの分類〕
〔/rad スプールデータを検索するときの宛先キーの値〕
＜この項の構成＞
(1)　オプション指定時の注意
(2)　出力結果

(1)　オプション指定時の注意

/fcオプションと/fdオプションを入力するときは，項目を「,」で区切って，10個まで指定できます。

（指定例）
/fc “住所,氏名,年齢,電話番号”
/fd “東京,日立 太郎,20,123-4567”

メッセージオプション（/message | /nomessage）については，「2.2　eurpmlscコマンドが提供するオプション」を参照してください。そのほかのオプションについては，SS-ActiveX起動部品のGetSpoolFileOutlineメソッドを参照してください。

(2)　出力結果

プロパティを「,」で区切って標準出力（stdout）に出力されます。出力結果を次に示します。

なお，出力された各プロパティについては，「7.4　SS-ActiveX起動部品のプロパティ仕様」を参照してください。

行 | 書式 | 説明
1 | VVRR▼ | 書式を変更したときのバージョン情報が「VVRR」形式で常に出力されます。
2 | JobID, SpoolPath, SpoolFileName, PageNum, CreateTime, PrintResult, PrinterClassName▼ | 「,」で区切られたプロパティ名が，1行で常に出力されます。
3～ | JobIDプロパティ値 , … , PrinterClassNameプロパティ値▼ 〔JobIDプロパティ値 , … , PrinterClassNameプロパティ値▼〕… | 2行目に出力されたプロパティに設定されている値が「,」で区切られて出力されます。「SpoolPath」の値には，常に""が出力されます。 取得結果は1件につき1行で，件数分出力されます。取得結果が0件のときは出力されません。
（凡例）
▼：改行コード（0x0d+0x0a）を示します。


スプールデータの属性値を取得する場合

2.3.2　スプールデータの属性値を取得する場合

eurpmlsc〔.exe〕
〔/message | /nomessage〕
 /m getattr
〔/svr スプールサーバのIPアドレス〕
 /id スプールデータを検索するときのジョブID
＜この項の構成＞
(1)　オプション指定時の注意
(2)　出力結果

(1)　オプション指定時の注意

メッセージオプション（/message | /nomessage）については，「2.2　eurpmlscコマンドが提供するオプション」を参照してください。そのほかのオプションについては，SS-ActiveX起動部品のGetSpoolFileAttributeメソッドを参照してください。

(2)　出力結果

プロパティを「,」で区切って標準出力（stdout）に出力されます。出力結果を次に示します。

なお，出力された各プロパティについては，「7.4　SS-ActiveX起動部品のプロパティ仕様」を参照してください。

行 | 書式 | 説明
1 | VVRR▼ | 書式を変更したときのバージョン情報が「VVRR」形式で常に出力されます。
2 | SpoolPath, SpoolFileName, PageNum, CreateTime, PrintResult, PrinterClassName, ClientAddress, DispPrintDlg, SpoolFileSize, CreateLSVersion, CreateIPAddress, SpoolLimit, ExecPrintCount, MaxPrintCount, EnableGet, PrinterSelectMode, ServerPrinterName, ServerTrayName, ClientPrinterName, ClientTrayName, GroupName, ExecutablePrintMode, JobKeyCategory1, JobKeyCategory2, JobKeyCategory3, JobKeyCategory4, JobKeyCategory5, JobKeyCategory6, JobKeyCategory7, JobKeyCategory8, JobKeyCategory9, JobKeyCategory10, JobKeyData1, JobKeyData2, JobKeyData3, JobKeyData4, JobKeyData5, JobKeyData6, JobKeyData7, JobKeyData8, JobKeyData9, JobKeyData10, PrintTime, ReportAddressKeyCategory, ReportAddressKeyData▼ | 「,」で区切られたプロパティ名が，1行で常に出力されます。
3 | SpoolPathプロパティ値 , … , ReportAddressKeyDataプロパティ値▼ | 2行目に出力されたプロパティに設定されている値が「,」で区切られて出力されます。「SpoolPath」の値には，常に""が出力されます。 取得結果は1件につき1行で，件数分出力されます。取得結果が0件のときは出力されません。
4 | OperationKind, OperationTime, IPAddress, OperationObject, BeforeData, AfterData, PrintResult▼ | 「,」で区切られた履歴情報の見出し名が，1行で常に出力されます。
5～ | 操作種別, 操作日時, IPアドレス, 操作対象, 変更前, 変更後, 印刷実行結果▼ 〔操作種別, 操作日時, IPアドレス, 操作対象, 変更前, 変更後, 印刷実行結果▼〕… | 履歴情報が「,」で区切られて出力されます。取得結果は1件につき1行で，件数分出力されます。取得結果が0件のときは出力されません。
（凡例）
▼：改行コード（0x0d+0x0a）を示します。


スプールデータの属性値を変更する場合

2.3.3　スプールデータの属性値を変更する場合

eurpmlsc〔.exe〕
〔/message | /nomessage〕
 /m setattr
〔/svr スプールサーバのIPアドレス〕
 /id スプールデータを検索するときのジョブID
〔/prc スプールデータのプリンタクラス名〕
〔/client 蓄積クライアント印刷時のクライアントPCのIPアドレス〕
〔/dialog ｛dialog | auto | preview | fullauto | pvonly｝〕
〔/lm スプールデータの蓄積期限日〕
〔/xp スプールデータの印刷上限回数〕
〔/g ｛get | noget｝〕
〔/sm｛class | printer | group｝〕
〔/lsp スプールサーバでのOS上のプリンタ名〕
〔/lst スプールサーバでのOS上のプリンタのトレイ名〕
〔/p スプールデータのクライアントプリンタ名〕
〔/t スプールデータのクライアントプリンタのトレイ名〕
〔/group スプールデータの振り分けグループ名〕
〔/exp｛sv | svcl | cl｝〕
〔/ca スプールデータのジョブ検索キー分類〕
〔/da スプールデータのジョブ検索キー値〕
＜この項の構成＞
(1)　オプション指定時の注意

(1)　オプション指定時の注意

/caオプションと/daオプションを入力するときは，項目を「,」で区切って，10個まで指定できます。

（指定例）
/ca “住所,氏名,年齢,電話番号”
/da “東京,日立 花子,19,123-4567”

/dialogオプション，/gオプション，/smオプション，および/expオプションに指定する値の内容を次に示します。

オプション 説明
/dialog 蓄積クライアント印刷時のダイアログ表示モードを指定します。
  • dialog：対話型印刷
  • auto：自動印刷
  • preview：対話型印刷プレビュー表示
  • fullauto：全自動印刷※1
  • pvonly：対話型印刷プレビュー表示限定※2
【参考】
SS-ActiveX起動部品のプロパティでは，次に該当します。
DispPrintDlg=0（対話型印刷）
DispPrintDlg=1（自動印刷印刷）
DispPrintDlg=2（対話型印刷プレビュー表示）
DispPrintDlg=3（全自動印刷）※1
DispPrintDlg=4（対話型印刷プレビュー表示限定）※2
/g スプールデータの取得可否を指定します。
  • get：（スプールデータの取得を許可します）
  • noget：（スプールデータの取得を許可しません）
【参考】
SS-ActiveX起動部品のプロパティでは，次に該当します。
EnableGet=True（スプールデータの取得を許可します）
EnableGet=False（スプールデータの取得を許可しません）
/sm 蓄積スプールサーバ印刷方式のプリンタ指定方式を指定します。
  • class：プリンタクラス名指定
  • printer：OS上のプリンタ名指定
  • group：帳票名による自動振り分け
【参考】
SS-ActiveX起動部品のプロパティでは，次に該当します。
PrinterSelectMode=0（プリンタクラス名指定）
PrinterSelectMode=1（OS上のプリンタ名指定）
PrinterSelectMode=2（帳票名による自動振り分け）
/exp スプールデータの実行可能印刷方式を指定します。
  • sv：蓄積スプールサーバ印刷
  • svcl：蓄積スプールサーバ/蓄積クライアント印刷
  • cl：蓄積クライアント印刷
【参考】
SS-ActiveX起動部品のプロパティでは，次に該当します。
ExecutablePrintMode=0（蓄積スプールサーバ印刷）
ExecutablePrintMode=1（蓄積スプールサーバ/蓄積クライアント印刷）
ExecutablePrintMode=2（蓄積クライアント印刷）

注※1　印刷実行時に印刷中のダイアログが表示されません。

注※2　印刷は実行できません。

メッセージオプション（/message | /nomessage）については，「2.2　eurpmlscコマンドが提供するオプション」を参照してください。そのほかのオプションについては，SS-ActiveX起動部品のSetSpoolFileAttributeメソッドを参照してください。


スプールデータを蓄積データ印刷する場合

2.3.4　スプールデータを蓄積データ印刷する場合

eurpmlsc〔.exe〕
〔/message | /nomessage〕
 /m print
〔/svr スプールサーバのIPアドレス〕
 /id スプールデータを検索するときのジョブID
〔/pm ｛sv｜cl｝〕
〔/sp 蓄積スプールサーバ印刷の開始ページ〕
〔/ep 蓄積スプールサーバ印刷の終了ページ〕
〔/sm ｛class｜printer｜group｝〕
〔/prc プリンタクラス名〕
〔/lsp スプールサーバでのOS上のプリンタ名〕
〔/lst スプールサーバでのOS上のプリンタのトレイ名〕
〔/p スプールデータのクライアントプリンタ名〕
〔/t スプールデータのクライアントプリンタのトレイ名〕
〔/group スプールデータの振り分けグループ名〕
〔/client 蓄積クライアント印刷時のクライアントPCのIPアドレス〕
〔/c 印刷部数〕
〔/num ｛sort｜stack｝〕
〔/po ｛none｜portrait｜landscape｝〕
〔/sptl スプールタイトル〕
〔/dialog ｛dialog | auto | preview | fullauto | pvonly｝〕
＜この項の構成＞
(1)　オプション指定時の注意

(1)　オプション指定時の注意

/idオプションには，複数のスプールデータを指定できます。ジョブIDをコンマ（,）で区切って指定してください。

/pmオプション，/smオプション，/numオプション，/poオプション，および/dialogオプションに指定する値の内容を次に示します。

オプション 説明
/pm 蓄積印刷方式を指定します。
  • sv：蓄積スプールサーバ印刷
  • cl：蓄積クライアント印刷
【参考】
SS-ActiveX起動部品のプロパティでは，次に該当します。
PrintMode=0（蓄積スプールサーバ印刷）
PrintMode=1（蓄積クライアント印刷）
/sm 蓄積スプールサーバ印刷方式のプリンタ指定方式を指定します。
  • class：プリンタクラス名指定
  • printer：OS上のプリンタ名指定
  • group：帳票名による自動振り分け
【参考】
SS-ActiveX起動部品のプロパティでは，次に該当します。
PrinterSelectMode=0（プリンタクラス名指定）
PrinterSelectMode=1（OS上のプリンタ名指定）
PrinterSelectMode=2（帳票名による自動振り分け）
/num 印刷部数の単位を指定します。
  • sort：部単位
  • stack：ページ単位
【参考】
SS-ActiveX起動部品のプロパティでは，次に該当します。
SortPrint=0（部単位）
SortPrint=1（ページ単位）
/po 用紙の向きを指定します。
  • none：EPF形式ファイルを蓄積したときのページごとの属性に従う
  • portrait：用紙の向きを縦にして印刷する
  • landscape：用紙の向きを横にして印刷する
【参考】
SS-ActiveX起動部品のプロパティでは，次に該当します。
PaperOrientation=0（EPF形式ファイルを蓄積したときのページごとの属性に従う）
PaperOrientation=1（用紙の向きを縦にして印刷する）
PaperOrientation=2（用紙の向きを横にして印刷する）
/dialog 蓄積クライアント印刷時のダイアログ表示モードを指定します。
  • dialog：対話型印刷
  • auto：自動印刷
  • preview：対話型印刷プレビュー表示
  • fullauto：全自動印刷※1
  • pvonly：対話型印刷プレビュー表示限定※2
【参考】
SS-ActiveX起動部品のプロパティでは，次に該当します。
DispPrintDlg=0（対話型印刷）
DispPrintDlg=1（自動印刷印刷）
DispPrintDlg=2（対話型印刷プレビュー表示）
DispPrintDlg=3（全自動印刷）※1
DispPrintDlg=4（対話型印刷プレビュー表示限定）※2

注※1　印刷実行時に印刷中のダイアログが表示されません。

注※2　印刷は実行できません。

メッセージオプション（/message | /nomessage）については，「2.2　eurpmlscコマンドが提供するオプション」を参照してください。そのほかのオプションについては，SS-ActiveX起動部品のPrintSpoolReportメソッドを参照してください。


スプールデータを取得する場合

2.3.5　スプールデータを取得する場合

eurpmlsc〔.exe〕
〔/message | /nomessage〕
 /m get
〔/svr スプールサーバのIPアドレス〕
 /id スプールデータを検索するときのジョブID
〔/ofn 出力ファイル名〕
〔/o スプールデータを取得するフォルダのパス〕
〔/prc プリンタクラス名〕
〔/c 印刷部数〕
〔/num ｛sort｜stack｝〕
〔/po ｛none｜portrait｜landscape｝〕
〔/sptl スプールタイトル〕
＜この項の構成＞
(1)　オプション指定時の注意

(1)　オプション指定時の注意

/idオプションには，複数のスプールデータを指定できます。ジョブIDをコンマ（,）で区切って指定してください。

/numオプションおよび/poオプションに指定する値の内容を次に示します。

オプション 説明
/num 印刷部数の単位を指定します。
  • sort：部単位
  • stack：ページ単位
【参考】
SS-ActiveX起動部品のプロパティでは，次に該当します。
SortPrint=0（部単位）
SortPrint=1（ページ単位）
/po 用紙の向きを指定します。
  • none：EPF形式ファイルを蓄積したときのページごとの属性に従う
  • portrait：用紙の向きを縦にして印刷する
  • landscape：用紙の向きを横にして印刷する
【参考】
SS-ActiveX起動部品のプロパティでは，次に該当します。
PaperOrientation=0（EPF形式ファイルを蓄積したときのページごとの属性に従う）
PaperOrientation=1（用紙の向きを縦にして印刷する）
PaperOrientation=2（用紙の向きを横にして印刷する）

メッセージオプション（/message | /nomessage）については，「2.2　eurpmlscコマンドが提供するオプション」を参照してください。そのほかのオプションについては，SS-ActiveX起動部品のGetSpoolFileメソッドを参照してください。


スプールデータを削除する場合

2.3.6　スプールデータを削除する場合

eurpmlsc〔.exe〕
〔/message | /nomessage〕
 /m del
〔/svr スプールサーバのIPアドレス〕
〔/id スプールデータを検索するときのジョブID〕
〔/dk ｛direct｜expire｝〕
＜この項の構成＞
(1)　オプション指定時の注意

(1)　オプション指定時の注意

/idオプションを複数指定するときは，項目を「,」で区切ります。

（指定例）
/id “id001, id002, id003”

/dkオプションに指定する値の内容を次に示します。

オプション 説明
/dk スプールデータ削除時の削除種別を指定します。
  • direct：指定したスプールデータを削除
  • expire：蓄積期限切れファイルの削除
【参考】
SS-ActiveX起動部品のプロパティでは，次に該当します。
DeleteKind=0（通常削除）
DeleteKind=1（蓄積期限切れファイルの削除）

メッセージオプション（/message | /nomessage）については，「2.2　eurpmlscコマンドが提供するオプション」を参照してください。そのほかのオプションについては，SS-ActiveX起動部品のDeleteSpoolFileメソッドを参照してください。


プリンタクラス一覧を取得する場合

2.3.7　プリンタクラス一覧を取得する場合

eurpmlsc〔.exe〕
〔/message | /nomessage〕
 /m getprclass
〔/svr スプールサーバのIPアドレス〕
＜この項の構成＞
(1)　オプション指定時の注意
(2)　出力結果

(1)　オプション指定時の注意

メッセージオプション（/message | /nomessage）については，「2.2　eurpmlscコマンドが提供するオプション」を参照してください。そのほかのオプションについては，SS-ActiveX起動部品のGetPrinterClassListメソッドを参照してください。

(2)　出力結果

スプールサーバのプリンタクラス一覧が標準出力（stdout）に出力されます。

なお，出力された各プロパティについては，「7.4　SS-ActiveX起動部品のプロパティ仕様」を参照してください。

行 | 書式 | 説明
1 | VVRR▼ | 書式を変更したときのバージョン情報が「VVRR」形式で常に出力されます。
2 | PrinterClassName, PrinterName, TrayName, Description▼ | 「,」で区切られた見出し名（プロパティ名を含む）が，1行で常に出力されます。
3～ | プリンタクラス名, OS上のプリンタ名, OS上のプリンタのトレイ名, 説明▼ 〔プリンタクラス名, OS上のプリンタ名, OS上のプリンタのトレイ名, 説明▼〕… | 2行目に出力された見出し名（プロパティ名を含む）に設定されている値が「,」で区切られて出力されます。「SpoolPath」の値には，常に""が出力されます。 取得結果は1件につき1行で，件数分出力されます。取得結果が0件のときは出力されません。
（凡例）
▼：改行コード（0x0d+0x0a）を示します。


プリンタ一覧を取得する場合

2.3.8　プリンタ一覧を取得する場合

eurpmlsc〔.exe〕
〔/message | /nomessage〕
 /m getpr
〔/svr スプールサーバのIPアドレス〕
＜この項の構成＞
(1)　オプション指定時の注意
(2)　出力結果

(1)　オプション指定時の注意

メッセージオプション（/message | /nomessage）については，「2.2　eurpmlscコマンドが提供するオプション」を参照してください。そのほかのオプションについては，SS-ActiveX起動部品のGetPrinterListメソッドを参照してください。

(2)　出力結果

OS上のプリンタ名が標準出力（stdout）に出力されます。出力結果を次に示します。

なお，出力されたプロパティについては，「7.4　SS-ActiveX起動部品のプロパティ仕様」を参照してください。

行 | 書式 | 説明
1 | VVRR▼ | 書式を変更したときのバージョン情報が「VVRR」形式で常に出力されます。
2 | PrinterName▼ | プロパティ名が，1行で常に出力されます。
3～ | OS上のプリンタ名▼ 〔OS上のプリンタ名▼〕… | 2行目に出力されたプロパティに設定されている値が出力されます。 取得結果は1件につき1行で，件数分出力されます。取得結果が0件のときは出力されません。
（凡例）
▼：改行コード（0x0d+0x0a）を示します。


トレイ一覧を取得する場合

2.3.9　トレイ一覧を取得する場合

eurpmlsc〔.exe〕
〔/message | /nomessage〕
 /m gettray
〔/svr スプールサーバのIPアドレス〕
 /lsp スプールサーバでのOS上のプリンタ名
＜この項の構成＞
(1)　オプション指定時の注意
(2)　出力結果

(1)　オプション指定時の注意

メッセージオプション（/message | /nomessage）については，「2.2　eurpmlscコマンドが提供するオプション」を参照してください。そのほかのオプションについては，SS-ActiveX起動部品のGetTrayListメソッドを参照してください。

(2)　出力結果

OS上のプリンタのトレイ名が標準出力（stdout）に出力されます。出力結果を次に示します。

なお，出力されたプロパティについては，「7.4　SS-ActiveX起動部品のプロパティ仕様」を参照してください。

行 | 書式 | 説明
1 | VVRR▼ | 書式を変更したときのバージョン情報が「VVRR」形式で常に出力されます。
2 | TrayName▼ | プロパティ名が，1行で常に出力されます。
3～ | OS上のプリンタのトレイ名▼ 〔OS上のプリンタのトレイ名▼〕… | 2行目に出力されたプロパティに設定されている値が出力されます。 取得結果は1件につき1行で，件数分出力されます。取得結果が0件のときは出力されません。
（凡例）
▼：改行コード（0x0d+0x0a）を示します。


監査ログを切り替える場合

2.3.10　監査ログを切り替える場合

eurpmlsc〔.exe〕
〔/message | /nomessage〕
 /m chgadtlog
〔/svr スプールサーバのIPアドレス〕
＜この項の構成＞
(1)　オプション指定時の注意

(1)　オプション指定時の注意

メッセージオプション（/message | /nomessage）については，「2.2　eurpmlscコマンドが提供するオプション」を参照してください。そのほかのオプションについては，SS-ActiveX起動部品のChangeAuditLogメソッドを参照してください。


エラー情報

2.4　エラー情報

eurpmlscコマンドでは，エラーを検知すると，メッセージオプション（/message）によって次に示す標準エラーを出力します。

表2-4　eurpmlscコマンドの標準エラー出力

エラー種別 | 発生条件 | メッセージID
コマンド実行時エラー | コマンド実行時にエラーが発生したとき | KEEY801-E
 | メモリ不足が発生したとき | KEEY806-E
コマンドシンタックスエラー | 不明なオプションを指定したとき | KEEY802-E
 | オプションに値の指定がないとき | KEEY803-E
 | オプションの指定値が不正なとき | KEEY804-E
 | 指定が必須のオプションが指定されていないとき | KEEY805-E
＜この節の構成＞
2.4.1　eurpmlscコマンドの終了コード
2.4.2　エラーメッセージのフォーマット


eurpmlscコマンドの終了コード

2.4.1　eurpmlscコマンドの終了コード

eurpmlscコマンドを実行すると，終了コードが返されます。終了コード一覧を次に示します。

表2-5　eurpmlscコマンドの終了コード

終了コード | 意味
0 | eurpmlscコマンドが正常に終了しました。
8 | eurpmlscコマンドの実行中，エラーが発生しました。

eurpmlscコマンドを呼び出しているAPIでは，eurpmlscコマンドの終了コードを参照して，エラーチェックしてください。


エラーメッセージのフォーマット

2.4.2　エラーメッセージのフォーマット

eurpmlscコマンドを実行したとき，標準エラーに出力されるメッセージのフォーマットを次に示します。

eurpmlsc:△KEEY8XX-E△エラーメッセージ▼
（凡例）
△：半角空白を示します。
▼：改行（0x0d+0x0a）を示します。


eurpmcepfviewerコマンド

3.　eurpmcepfviewerコマンド

この章では，EUR Client Serviceを起動するeurpmcepfviewerコマンドについて説明します。

＜この章の構成＞
3.1　eurpmcepfviewerコマンドとは
3.2　eurpmcepfviewerコマンドの構文
3.3　エラー情報


eurpmcepfviewerコマンドとは

3.1　eurpmcepfviewerコマンドとは

クライアント側で動作するプログラムから，EUR Client Serviceをコマンド起動することで，帳票のプレビュー表示や印刷ができます。このときに使用するコマンドを，eurpmcepfviewerコマンドといいます。

＜この節の構成＞
3.1.1　eurpmcepfviewerコマンドのファイル名
3.1.2　オプション一覧
3.1.3　オプションを指定するときの注意


eurpmcepfviewerコマンドのファイル名

3.1.1　eurpmcepfviewerコマンドのファイル名

eurpmcepfviewerコマンドのファイル名を次に示します。

EURPMCEPFViewer.exe
eurpmcepfviewerコマンドのファイルです。インストール先フォルダ\Client\Program\下にあります。


オプション一覧

3.1.2　オプション一覧

eurpmcepfviewerコマンドが提供するオプションの一覧を次に示します。

表3-1　eurpmcepfviewerコマンドのオプション一覧

オプション | 指定値※ | /rオプションの指定 | 内容
/e | 印刷終了ページ | ○ | 1～999,999の数値で指定します。 範囲外の値を指定した場合，および/sオプションに指定した値より小さい値を指定した場合はエラーになります。 /eオプションの指定を省略した場合は，最終ページまで印刷されます。
/nomessage | － | ○ | 印刷時にダイアログを表示しない場合（全自動印刷したい場合）に指定します。
/pr | プリンタ名 | ○ | 80バイト以内の文字列で指定します。
/prc | プリンタクラス名 | ○ | 80バイト以内の文字列で指定します。 /prオプションと同時に指定した場合は無視されます。
/r | － | － | 帳票を自動印刷する場合に指定します。なお，/rオプションを指定した場合は，EPF形式ファイル名を必ず指定してください。 /rオプションの指定を省略した場合は，帳票をプレビュー表示します。
/s | 印刷開始ページ | ○ | 1～999,999の数値で指定します。 範囲外の値を指定した場合，および/eオプションに指定した値より大きい値を指定した場合はエラーになります。 /sオプションの指定を省略した場合は，1ページから印刷されます。
/tr | トレイ名 | ○ | 80バイト以内の文字列で指定します。 /prオプションと同時に指定した場合に有効になります。 /trオプションの指定を省略した場合は，/prオプションで指定したプリンタのデフォルトのトレイから給紙されます。
－ | EPF形式ファイル名 | △ | EPF形式ファイル名をフルパスで指定します。 255バイト以内の文字列で指定してください。 EPF形式ファイルの指定を省略した場合は，ファイルを表示しない状態でEUR Client Serviceが起動します。また，ファイルを複数指定するとエラーとなります。 なお，ファイルの拡張子はコマンド実行時の動作に影響しません。ファイルの拡張子が*.epfであっても，/rオプションを指定した場合は帳票が自動印刷されます。
（凡例）
○：/rオプションの指定が必須です。
△：/rオプションの指定は任意です。
－：該当しません。
注※
半角空白を含む値を指定する場合は，値を「"」で囲んで指定します。


オプションを指定するときの注意

3.1.3　オプションを指定するときの注意

オプションを指定するときの注意を次に示します。

＜この項の構成＞
(1)　大文字と小文字の区別について
(2)　同一オプションを複数指定する場合
(3)　無効なオプションについて
(4)　帳票の印刷先について

(1)　大文字と小文字の区別について

オプション，オプションの指定値，およびオプションに指定する文字列は，大文字と小文字を区別します。

例えば，/rオプションを「/R」と指定すると，エラーになります。

(2)　同一オプションを複数指定する場合

同じオプションが複数指定されている場合は，最後に指定されたオプションの値が有効となります。

(3)　無効なオプションについて

無効なオプションが指定されていた場合は，エラーになります。

(4)　帳票の印刷先について

優先順位は次のとおりです。

  1. プリンタ名の指定（/prオプションで指定）
  2. プリンタクラス名の指定（/prcオプションで指定）
  3. EPF形式ファイルの属性値のプリンタクラス名
  4. デフォルトプリンタクラス
  5. OSのデフォルトのプリンタ

2.または3.で決定したプリンタクラス名が，クライアントPCのプリンタクラスとして設定されていない場合は，デフォルトプリンタクラスに出力します。デフォルトプリンタクラスが登録されていない場合は，OSのデフォルトのプリンタに出力します。また，プリンタ名またはプリンタクラス名の指定によって決定したプリンタが存在しない場合はエラーになります。


eurpmcepfviewerコマンドの構文

3.2　eurpmcepfviewerコマンドの構文

EURPMCEPFViewer〔.exe〕
〔/r〕
〔/nomessage〕
〔/pr プリンタ名〕
〔/tr トレイ名〕
〔/prc プリンタクラス名〕
〔/s 印刷開始ページ〕
〔/e 印刷終了ページ〕
〔EPF形式ファイル名〕
〔/r〕
帳票を自動印刷する場合に指定します。
指定を省略した場合は，帳票をプレビュー表示します。
〔/nomessage〕
印刷時にダイアログを表示しない場合（全自動印刷したい場合）に指定します。
/rオプションと同時に指定した場合に有効になります。
〔/pr プリンタ名〕
プリンタ名を80バイト以内の文字列で指定します。
/rオプションと同時に指定した場合に有効になります。
〔/tr トレイ名〕
トレイ名を80バイト以内の文字列で指定します。
/rオプションおよび/prオプションと同時に指定した場合に有効になります。
指定を省略した場合は，/prオプションで指定したプリンタのデフォルトのトレイから給紙されます。
〔/prc プリンタクラス名〕
プリンタクラス名を80バイト以内の文字列で指定します。
/rオプションと同時に指定した場合に有効になります。
/prオプションと同時に指定した場合は無視されます。
〔/s 印刷開始ページ〕
印刷開始ページを1～999,999の数値で指定します。
/rオプションと同時に指定した場合に有効になります。
範囲外の値を指定した場合，および/eオプションに指定した値より大きい値を指定した場合はエラーになります。指定を省略した場合は，1ページから印刷されます。
〔/e 印刷終了ページ〕
印刷終了ページを1～999,999の数値で指定します。
/rオプションと同時に指定した場合に有効になります。
範囲外の値を指定した場合，および/sオプションに指定した値より小さい値を指定した場合はエラーになります。指定を省略した場合は，最終ページまで印刷されます。
〔EPF形式ファイル名〕
EPF形式ファイル名をフルパスで指定します。
255バイト以内の文字列で指定してください。
指定を省略した場合は，ファイルを表示しない状態でEUR Client Serviceが起動します。また，ファイルを複数指定するとエラーとなります。
/rオプションを指定した場合は必ず指定してください。
＜この節の構成＞
3.2.1　帳票を自動印刷する場合
3.2.2　帳票をプレビュー表示する場合


帳票を自動印刷する場合

3.2.1　帳票を自動印刷する場合

eurpmcepfviewerコマンドの指定例を次に示します。

＜この項の構成＞
(1)　プリンタクラス名を指定して帳票を全自動印刷したい場合
(2)　プリンタ名とトレイ名を指定して帳票を自動印刷したい場合
(3)　帳票のプリンタクラス名情報を使用して自動印刷したい場合

(1)　プリンタクラス名を指定して帳票を全自動印刷したい場合

プリンタクラス名：AClass
EPF形式ファイル名：EPFFile.epf
ファイルのある場所：C:\temp\

"C:\Program Files\Hitachi\EUR\Client\Program\EURPMCEPFViewer.exe" /r /nomessage /prc AClass C:\temp\EPFFile.epf

(2)　プリンタ名とトレイ名を指定して帳票を自動印刷したい場合

プリンタ名：Port C4300
トレイ名：自動
EPF形式ファイル名：EPFFile.epf
ファイルのある場所：C:\temp

"C:\Program Files\Hitachi\EUR\Client\Program\EURPMCEPFViewer.exe" /r /pr "Port C4300" /tr 自動 C:\temp\EPFFile.epf

(3)　帳票のプリンタクラス名情報を使用して自動印刷したい場合

EPF形式ファイル名：EPFFile.epf
ファイルのある場所：C:\temp folder

"C:\Program Files\Hitachi\EUR\Client\Program\EURPMCEPFViewer.exe" /r "C:\temp folder\EPFFile.epf"


帳票をプレビュー表示する場合

3.2.2　帳票をプレビュー表示する場合

EPF形式ファイル名：EPFFile.epf
ファイルのある場所：C:\temp\

"C:\Program Files\Hitachi\EUR\Client\Program\EURPMCEPFViewer.exe" C:\temp\EPFFile.epf


エラー情報

3.3　エラー情報

eurpmcepfviewerコマンドを実行すると，終了コードが返されます。終了コード一覧を次に示します。

表3-2　eurpmcepfviewerコマンドの終了コード

終了コード | 意味
0 | eurpmcepfviewerコマンドが正常に終了しました。
100～199 | eurpmcepfviewerコマンドの実行中に，エラーが発生しました。 該当するKEEYメッセージを参照してください。

eurpmcepfviewerコマンドを呼び出しているAPIでは，eurpmcepfviewerコマンドの終了コードを参照して，エラーチェックしてください。

また，eurpmcepfviewerコマンドを実行したとき，ダイアログに出力されるメッセージの表示例を次に示します。

ただし，/nomessageオプションを指定してeurpmcepfviewerコマンドを実行した場合は，ダイアログは表示されません。


BSP-RM連携コマンド

4.　BSP-RM連携コマンド

この章では，BSP-RMが管理するデータファイルをEURサーバ環境で帳票の印刷やファイル出力をするBSP-RM連携コマンドについて説明します。

＜この章の構成＞
4.1　BSP-RM連携コマンドとは
4.2　BSP-RM連携コマンドの構文
4.3　エラー情報


BSP-RM連携コマンドとは

4.1　BSP-RM連携コマンドとは

BSP-RMを使用して，BSP-RMが管理するデータファイル（制御情報付データファイル）をEURサーバ環境で帳票の印刷やファイル出力ができます。このときに使用するコマンドを，BSP-RM連携コマンド（eursmprコマンド）といいます。BSP-RM連携コマンドは，BSP-RMから呼び出して実行するコマンドです。

BSP-RMとEURを連携する場合の帳票出力の流れの詳細については，マニュアル「EUR 帳票出力 機能解説 EUR Server編」を参照してください。

＜この節の構成＞
4.1.1　BSP-RM連携コマンドのファイル名


BSP-RM連携コマンドのファイル名

4.1.1　BSP-RM連携コマンドのファイル名

BSP-RM連携コマンド（eursmprコマンド）のファイル名を次に示します。

eursmpr.exe
BSP-RM連携コマンドのファイルです。インストール先フォルダ\Eursmpr\Program\下にあります。


BSP-RM連携コマンドの構文

4.2　BSP-RM連携コマンドの構文

eursmpr.exe
制御情報付データファイル名
起動パラメタファイル名
制御情報付データファイル名
制御情報付データファイル名を，フルパス，相対パスまたはファイル名だけのどれかで指定します。
255バイト以内の文字列で指定してください。制御情報付データファイル名は必ず指定してください。指定を省略した場合，KEEU3016エラーになります。
ファイル名だけで指定する場合は，インストール先フォルダ\Eursmpr\divadata下，または環境設定ファイル（eursmpr.ini）のPATHセクションのDIVDATAキーで指定したフォルダ下にあるファイル名を指定します。
起動パラメタファイル名
起動パラメタファイル名を，フルパス，相対パスまたはファイル名だけのどれかで指定します。255バイト以内の文字列で指定してください。起動パラメタファイル名は必ず指定してください。
ファイル名だけで指定する場合は，インストール先フォルダ\Eursmpr\runparam下，または環境設定ファイル（eursmpr.ini）のPATHセクションのRUNPARAMキーで指定したフォルダ下にあるファイル名を指定します。
■注意事項
  • 指定する文字列は，大文字と小文字を区別しません。
  • 指定する文字列には，「"」および「,」は使用できません。


エラー情報

4.3　エラー情報

BSP-RM連携コマンド（eursmprコマンド）では，エラーを検知すると，標準エラーを出力します。

＜この節の構成＞
4.3.1　BSP-RM連携コマンドの終了コード
4.3.2　エラーメッセージのフォーマット


BSP-RM連携コマンドの終了コード

4.3.1　BSP-RM連携コマンドの終了コード

BSP-RM連携コマンド（eursmprコマンド）を実行すると，終了コードが返されます。終了コード一覧を次に示します。

表4-1　BSP-RM連携コマンド（eursmprコマンド）の終了コード

終了コード | 意味
0 | BSP-RM連携コマンドが正常に終了しました。
4 | BSP-RM連携から呼び出すeurpmcコマンドの実行中に，警告が発生しました。
8 | BSP-RM連携から呼び出すeurpmcコマンドの実行中に，エラーが発生しました。
3008 | BSP-RM連携コマンドのファイル入出力処理で，エラーが発生しました。
3012 | 制御情報付データファイルまたは起動パラメタファイルの構文に誤りがあります。
3016 | 引数の指定に誤りがあります。
3032 | 上記以外のエラーが発生しました。

BSP-RM連携コマンド（eursmprコマンド）を呼び出しているAPIでは，BSP-RM連携コマンドの終了コードを参照して，エラーチェックしてください。


エラーメッセージのフォーマット

4.3.2　エラーメッセージのフォーマット

BSP-RM連携コマンド（eursmprコマンド）を実行したとき，標準エラーに出力されるメッセージのフォーマットを次に示します。

エラーメッセージの場合
eursmpr:△KEEU3XXX-E△エラーメッセージ▼
（凡例）
△：半角空白を示します。
▼：改行（0x0d+0x0a）を示します。
警告メッセージの場合
eursmpr:△KEEU3XXX-W△エラーメッセージ▼
（凡例）
△：半角空白を示します。
▼：改行（0x0d+0x0a）を示します。


EUR Web Plug-In

5.　EUR Web Plug-In

この章では，Webブラウザを使用して帳票を印刷するためのActiveX部品（EUR Web Plug-In）を使用した帳票出力について説明します。

＜この章の構成＞
5.1　EUR Web Plug-Inとは
5.2　パラメタ，メソッド，プロパティ一覧
5.3　パラメタ仕様
5.4　メソッド仕様
5.5　プロパティ仕様
5.6　イベント仕様
5.7　タグの記述例


EUR Web Plug-Inとは

5.1　EUR Web Plug-Inとは

EUR Clientでは，Web出力で使用するActiveX部品を提供しています。これを，EUR Web Plug-Inと呼びます。EUR Web Plug-Inを使用してクライアントPCのWebブラウザ上で帳票を印刷したり，プレビュー表示したりできます。

＜この節の構成＞
5.1.1　ファイル名
5.1.2　EUR Web Plug-Inの使用方法


ファイル名

5.1.1　ファイル名

EURPMPrintAX9.ocx
Webブラウザ上で帳票を印刷するActiveX部品です。以降，EUR Web Plug-In（印刷用）と呼びます。
EURPMPreViewAX9.ocx
Webブラウザ上で帳票を印刷したり，表示したりするActiveX部品です。以降，EUR Web Plug-In（プレビュー用）と呼びます。


EUR Web Plug-Inの使用方法

5.1.2　EUR Web Plug-Inの使用方法

EUR Web Plug-Inの使用方法には，配布用パッケージからインストールして使用する方法と，ダウンロードパッケージを配置して使用する方法があります。

ダウンロードパッケージは，キャビネットファイル（.cab）とInternet Explorerの機能を使用してインストールするパッケージです。

ダウンロードパッケージでEUR Web Plug-Inをインストールした場合，アプリケーションとしてコンピュータに登録されないため，コントロールパネルの［アプリケーションの追加と削除］メニューからのアンインストールはできません。また，プログラムフォルダおよびスタートメニューは作成されません。

＜この項の構成＞
(1)　配布用パッケージによるインストールでの使用方法
(2)　ダウンロードパッケージでの使用方法

(1)　配布用パッケージによるインストールでの使用方法

EUR Web Plug-Inの配布用パッケージによるインストールでの使用方法は次のとおりです。

(a)　配布用パッケージによるインストール

配布用パッケージによるインストールでは，クライアントPCに直接インストールします。

インストールの手順，インストール後のフォルダ構成は，マニュアル「EUR システム構築ガイド」を参照してください。

(b)　EUR Web Plug-Inの起動方法

EUR Web Plug-Inは，HTMLページに<object>タグを記述して使用します。<object>タグの記述方法については，「5.7　タグの記述例」を参照してください。

(2)　ダウンロードパッケージでの使用方法

クライアントのWebブラウザから，ダウンロードパッケージ配布用のWebページにアクセスしてインストールします。インストールの手順は，マニュアル「EUR システム構築ガイド」を参照してください。

(a)　EUR Web Plug-Inの起動方法

EUR Web Plug-Inは，HTMLページに<object>タグを記述して使用します。<object>タグの記述方法については，「5.7　タグの記述例」を参照してください。


パラメタ，メソッド，プロパティ一覧

5.2　パラメタ，メソッド，プロパティ一覧

EUR Web Plug-Inのパラメタ，メソッド，プロパティの一覧を示します。

＜この節の構成＞
5.2.1　パラメタ一覧
5.2.2　メソッド一覧
5.2.3　プロパティ一覧
5.2.4　イベント一覧
5.2.5　指定値に使用できない文字について


パラメタ一覧

5.2.1　パラメタ一覧

EUR Web Plug-Inのパラメタの一覧を次に示します。

表5-1　Web出力で使用するEUR Web Plug-Inのパラメタ一覧

パラメタ | 概要 | EUR Web Plug-In（印刷用） | EUR Web Plug-In（プレビュー用）
DefaultPrintDlg | 印刷実行時にEUR Server Serviceのプリンタ選択ダイアログを表示するか，OSの印刷ダイアログを表示するかを選択します。 | ○ | ○
EPFDataMaxSize | ダウンロードするEPF形式ファイルの，ファイルサイズの上限を指定します。 | ○ | ○
EPFFileURL | ダウンロードするEPF形式ファイルのURLを指定します。 | ○ | ○
EPFTempDataMode | ダウンロードするEPF形式ファイルを，一時ファイルとして保存するかどうかを指定します。 | ○ | ○
LogFile | EUR Web Plug-Inのログファイルの出力先フォルダを指定します。 | ○ | ○
LogLevel | 実行ログの出力レベルを指定します。 | ○ | ○
LogSize | EUR Web Plug-Inのログファイルのファイルサイズの上限を指定します。 | ○ | ○
NoPrint | 起動時に印刷を実行するかどうかを指定します。 | ○ | ×
NoSetPrinterDlg | 印刷実行時にプリンタ選択ダイアログを表示するかどうかを指定します。 | ○ | ○
PrintEndPage | EPF形式ファイルの印刷終了ページを指定します。 | ○ | ×
PrinterName | 帳票を印刷するプリンタを指定します。 | ○ | ○
PrintStartPage | EPF形式ファイルの印刷開始ページを指定します。 | ○ | ×
SelectDisplayPrinter | 印刷ダイアログに初期表示するプリンタ名の表示モードを指定します。 | ○ | ○
SendResultURL | 印刷結果を報告するURLを指定します。 | ○ | ○
ShowScrollBar | 印刷プレビューが表示領域を超える場合，スクロールバーを表示するかどうかを指定します。 | × | ○
TempFileDel | 印刷実行時に生成した一時ファイルを削除するかどうかを選択します。 | ○ | ○
TrayName | 帳票を印刷するプリンタのトレイ名を指定します。 | ○ | ○
UserParam | SendResultURLパラメタで送信するユーザ付加情報を指定します。 | ○ | ○
Zoom | 印刷プレビューの表示倍率の初期値を指定します。 | × | ○

（凡例）○：指定できます。　×：指定できません。


メソッド一覧

5.2.2　メソッド一覧

EUR Web Plug-Inのメソッドの一覧を次に示します。

表5-2　 Web出力で使用するEUR Web Plug-Inのメソッド一覧

メソッド | 概要 | EUR Web Plug-In（印刷用） | EUR Web Plug-In（プレビュー用）
Find | 検索ダイアログを表示します。 | × | ○
FindNext | 検索ダイアログで前回実行した検索の内容に従って，次の検索を実行します。一度も検索を実行していない場合は，検索ダイアログを表示します。 | × | ○
HScroll | 横方向にスクロールします。 | × | ○
PrintEPF | 印刷を実行します。 | ○ | ○
TurnPage | 指定ページを表示します。 | × | ○
VScroll | 縦方向にスクロールします。 | × | ○
Zoom | 印刷プレビューの表示倍率を変更します。 | × | ○

（凡例）○：指定できます。　×：指定できません。


プロパティ一覧

5.2.3　プロパティ一覧

EUR Web Plug-Inのプロパティの一覧を次に示します。

表5-3　 Web出力で使用するEUR Web Plug-Inのプロパティ一覧

プロパティ | 概要 | EUR Web Plug-In（印刷用） | EUR Web Plug-In（プレビュー用）
CurrentPage | 表示中のページ番号を取得します。 | × | ○
ExclusionPrinterDriver | PrintEPFメソッドの実行時に，表示するプリンタ選択ダイアログ中のプリンタ一覧から，除外したいプリンタのドライバ名を指定します。 | ○ | ○
ExclusionPrinterName | PrintEPFメソッドの実行時に，表示するプリンタ選択ダイアログ中のプリンタ一覧から，除外したいプリンタのプリンタ名を指定します。 | ○ | ○
PermissionPrinterDriver | PrintEPFメソッドの実行時に，印刷を許可するプリンタのドライバ名を指定します。指定したプリンタは，プリンタの選択ダイアログ中のプリンタ一覧に表示されます。 | ○ | ○
PermissionPrinterName | PrintEPFメソッドの実行時に，印刷を許可するプリンタのプリンタ名を指定します。指定したプリンタは，プリンタの選択ダイアログ中のプリンタ一覧に表示されます。 | ○ | ○
SelectDisplayPrinter | 印刷ダイアログに初期表示するプリンタ名の表示モードを指定します。 | ○ | ○
TotalPage | 表示データの総ページ数を取得します。 | × | ○

（凡例）○：指定できます。　×：指定できません。


イベント一覧

5.2.4　イベント一覧

EUR Web Plug-Inのイベントの一覧を次に示します。

表5-4　 Web出力で使用するEUR Web Plug-Inのイベント一覧

イベント | 概要 | EUR Web Plug-In（印刷用） | EUR Web Plug-In（プレビュー用）
PageChanged | 検索を実行してプレビューしている表示ページが変わったときに，ページ番号を通知するためのイベントです。 | × | ○

（凡例）○：通知できます。　×：通知できません。


指定値に使用できない文字について

5.2.5　指定値に使用できない文字について

オプションの指定値には，制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」は使用できません。


パラメタ仕様

5.3　パラメタ仕様

EUR Web Plug-Inのパラメタの詳細を説明します。

＜この節の構成＞
DefaultPrintDlgパラメタ
EPFDataMaxSizeパラメタ
EPFFileURLパラメタ
EPFTempDataModeパラメタ
LogFileパラメタ
LogLevelパラメタ
LogSizeパラメタ
NoPrintパラメタ
NoSetPrinterDlgパラメタ
PrintEndPageパラメタ
PrinterNameパラメタ
PrintStartPageパラメタ
SelectDisplayPrinterパラメタ
SendResultURLパラメタ
ShowScrollBarパラメタ
TempFileDelパラメタ
TrayNameパラメタ
UserParamパラメタ
Zoomパラメタ


DefaultPrintDlgパラメタ

DefaultPrintDlgパラメタ

印刷実行時にEUR Web Plug-Inのプリンタ選択ダイアログを表示するか，OSの印刷ダイアログを表示するかを選択します。

指定できる値を次に示します。

  • YES：印刷実行時，OSの印刷ダイアログを表示します。
  • NO：印刷実行時，EUR Server Serviceのプリンタ選択ダイアログを表示します。

DefaultPrintDlgパラメタを省略した場合，または指定できる値以外の文字を指定した場合は，NOが仮定されます。

PrinterNameパラメタで指定したプリンタがある場合，またはNoSetPrinterDlgパラメタでYESを指定した場合は，DefaultPrintDlgパラメタの指定は無効になります。

注意
OSの印刷ダイアログでは，印刷開始ページおよび印刷終了ページに65,534より大きい値を指定できません。65,534より大きい値を指定するとエラーが表示されるか，または指定していないページが印刷されます。大量ページの帳票を印刷する場合には，EUR Server Serviceのプリンタ選択ダイアログを使用してください。


EPFDataMaxSizeパラメタ

EPFDataMaxSizeパラメタ

EPFTempDataModeパラメタに1を指定した場合，ダウンロードするEPF形式ファイルの，ファイルサイズの上限を指定します。

指定できる値は750～2,000,000です。単位はKBです。

EPFDataMaxSizeパラメタを省略した場合，または指定できない値を指定した場合は2,000,000が仮定されます。

EPFTempDataModeパラメタに1以外を指定した場合，EPFDataMaxSizeパラメタに指定した内容は無視されます。

ダウンロードするEPF形式ファイルのファイルサイズが上限を超えるとエラーになり，KEEY142-Eメッセージが出力されます。


EPFFileURLパラメタ

EPFFileURLパラメタ

印刷するEPF形式ファイルをダウンロードするURLを指定します。

URLの指定方法には次に示す二つの方法があります。

  • 生成済みのEPF形式ファイルを指定
    生成済みのEPF形式ファイルをWebサーバ上に配置しておき，そのURLを指定します。
    （指定例）http://localhost/epf/abc.epf
  • 動的にEPF形式ファイルを生成するユーザプログラムを指定
    HTTPリクエストでEUR Server - Adapterを呼び出し，動的にEPF形式ファイルを生成してダウンロードしたい場合は，EPF形式ファイルを生成してHTTPレスポンスにEPF形式のファイルデータを返すユーザプログラムのURLを指定します。
    （指定例）http://localhost/sample/create_epf.jsp
    ただし，HTTPレスポンスのHTTPヘッダのContentLength項目には，生成したEPF形式ファイルのファイルサイズを正しく指定してください。間違って指定した場合は，ダウンロードの進捗画面が正しく表示されません。
    また，EPFTempDataModeパラメタに「1（ダウンロードするEPF形式ファイルを一時ファイルとして保存しない）」を指定した場合に，ContentLength項目を正しく指定していないときは，ファイルデータを正常にダウンロードできないおそれがあります。

ダウンロード先は，GetTempPath()で取得されるテンポラリフォルダです。ダウンロードしたEPF形式ファイルを一時ファイルとして保存するかどうかは，EPFTempDataModeパラメタで指定できます。ダウンロードしたEPF形式ファイルは，印刷が終了すると自動的に削除されます。


EPFTempDataModeパラメタ

EPFTempDataModeパラメタ

ダウンロードするEPF形式ファイルを，一時ファイルとして保存するかどうかを指定します。

指定できる値を次に示します。

  • 0：一時ファイルとして保存します。
    GetTempPath()で取得されるテンポラリフォルダに保存します。
    保存した一時ファイルは，印刷が終了すると自動的に削除されます。
  • 1：一時ファイルとして保存しません。

EPFTempDataModeパラメタを省略した場合，または0，1以外を指定した場合は，0が仮定されます。


LogFileパラメタ

LogFileパラメタ

EUR Web Plug-Inのログファイル（EURPMPrintAX.logまたはEURPMPreViewAX.log）の出力先フォルダを指定します。

LogFileパラメタを省略した場合，次の順に出力先フォルダを決定します。

  1. 環境変数TMPに指定されたフォルダ
  2. 環境変数TEMPに指定されたフォルダ
  3. 実行しているプログラムのカレントフォルダ


LogLevelパラメタ

LogLevelパラメタ

EUR Web Plug-Inの実行ログの出力レベルを指定します。

指定できる値を次に示します。

  • 0：ログ出力しません。
  • 4：起動，終了，実行時パラメタ，エラーを出力します。
  • 8：起動，終了，実行時パラメタ，エラー，警告を出力します。
  • 16：起動，終了，実行時パラメタ，エラー，警告，情報を出力します。

LogLevelパラメタを省略した場合は，8が仮定されます。

注意
出力レベルを16に指定すると，トレース情報が大量に出力されるため，性能が落ちるおそれがあります。障害調査時以外には指定しないでください。


LogSizeパラメタ

LogSizeパラメタ

EUR Web Plug-Inのログファイル（EURPMPrintAX.logまたはEURPMPreViewAX.log）のファイルサイズの上限を指定します。

指定できる値は750～2,000,000です。単位はKBです。

LogSizeパラメタを省略した場合，または指定できない値を指定した場合は750が仮定されます。

ログのファイルサイズが上限を超えると，現在のログファイルをバックアップファイル（EURPMPrintAX_bak.log）に保存し，再びログファイルの先頭から記録します。すでにバックアップファイルがある場合は，古いバックアップファイルを上書きします。


NoPrintパラメタ

NoPrintパラメタ

EUR Web Plug-In（印刷用）の起動時に印刷を実行するかどうかを指定します。

指定できる値を次に示します。

  • YES：EUR Web Plug-In（印刷用）の起動時にEPF形式ファイルを印刷しません。
  • NO：EUR Web Plug-In（印刷用）の起動時にEPF形式ファイルを印刷します。

NoPrintパラメタでYESを指定した場合，PrintEPFメソッドを呼び出すまで印刷しません。NoPrintパラメタでNOを指定した場合，起動時に印刷されます。

NoPrintパラメタを省略した場合，または指定できない値を指定した場合，NOが仮定されます。


NoSetPrinterDlgパラメタ

NoSetPrinterDlgパラメタ

印刷実行時にプリンタ選択ダイアログを表示するかどうかを指定します。

指定できる値を次に示します。

  • YES：印刷実行時，プリンタ選択ダイアログを表示しません。
  • NO：印刷実行時，プリンタ選択ダイアログを表示します。

NoSetPrinterDlgパラメタにYESを指定した場合，Windows環境で通常使うプリンタに出力されます。

NoSetPrinterDlgパラメタを省略した場合，または指定できない値を指定した場合は，NOが仮定されます。

PrinterNameパラメタで指定したプリンタがある場合は，NoSetPrinterDlgパラメタの指定は無効になります。

プリンタ選択ダイアログを表示しない場合，次に示すどれかが指定されていると印刷されません。印刷実行時にエラーが表示されます。

  • ExclusionPrinterNameプロパティ，またはExclusionPrinterDriverプロパティに通常使うプリンタのプリンタ名またはプリンタドライバ名が指定されているとき
  • PermissionPrinterNameプロパティ，またはPermissionPrinterDirverプロパティに通常使うプリンタ以外のプリンタ名またはプリンタドライバ名が指定されているとき


PrintEndPageパラメタ

PrintEndPageパラメタ

EPF形式ファイルの印刷終了ページを指定します。指定できる値は，1～999,999です。単位は，ページです。

PrintEndPageパラメタを省略した場合は，1ページから最終ページまで印刷されます。

PrintEndPageパラメタに，最終ページを超える値を指定した場合は，最終ページまで印刷されます。

PrintEndPageプロパティに，次に示すどれかが指定された場合は，印刷されません。印刷実行時にエラーが表示されます。

  • 印刷終了ページに，1～999,999以外の値が指定されているとき
  • PrintEndPageパラメタの指定はあるが，印刷終了ページが指定されていないとき
  • PrintStartPageプロパティで指定する印刷開始ページが，印刷終了ページより大きいとき


PrinterNameパラメタ

PrinterNameパラメタ

帳票を印刷するプリンタを指定します。プリンタ名には，クライアントPCのOS上に設定した名称を指定します。

プリンタ名の大文字・小文字は区別されません。

PrinterNameパラメタを省略した場合，または指定したプリンタ名がOS上にない場合は，NoSetPrinterDlgパラメタとDefaultPrintDlgパラメタの設定に従います。

指定したプリンタに印刷する場合，次に示すどれかが指定されていると印刷されません。印刷実行時にエラーが表示されます。

  • ExclusionPrinterNameプロパティ，またはExclusionPrinterDriverプロパティにPrinterNameパラメタで指定したプリンタ名またはプリンタドライバ名が指定されているとき
  • PermissionPrinterNameプロパティ，またはPermissionPrinterDirverプロパティにPrinterNameパラメタで指定したプリンタ以外のプリンタ名またはプリンタドライバ名が指定されているとき


PrintStartPageパラメタ

PrintStartPageパラメタ

EPF形式ファイルの印刷開始ページを指定します。指定できる値は，1～999,999です。単位は，ページです。

PrintStartPageパラメタを省略した場合は，1ページから印刷されます。

PrintStartPageパラメタに，最終ページを超える値を指定した場合は，最終ページが印刷されます。

PrintStartPageプロパティに，次に示すどれかが指定された場合は，印刷されません。印刷実行時にエラーが表示されます。

  • 印刷開始ページに，1～999,999以外の値が指定されているとき
  • PrintStartPageパラメタの指定はあるが，印刷開始ページが指定されていないとき
  • 印刷開始ページが，PrintEndPageプロパティで指定する印刷終了ページより大きいとき


SelectDisplayPrinterパラメタ

SelectDisplayPrinterパラメタ

印刷ダイアログに初期表示するプリンタ名の表示モードを指定します。

指定できる値を次に示します。

  • 0：標準モード
    印刷先指定ダイアログに初期表示するプリンタ名
    ・初めて印刷する帳票ジョブを受信した場合
        プリンタ名は表示されません。※1
    ・印刷したことがある帳票ジョブを受信した場合
        前回の受信時に設定したプリンタ名が表示されます。※2
    OSの印刷ダイアログに初期表示するプリンタ名
    ・初めて印刷する帳票ジョブを受信した場合
        通常使うプリンタのプリンタ名が表示されます。
    ・印刷したことがある帳票ジョブを受信した場合
        前回の受信時に設定したプリンタ名が表示されます。※3
  • 1：通常使うプリンタ初期表示モード
    印刷先指定ダイアログに初期表示するプリンタ名※4
    ・初めて印刷する帳票ジョブを受信した場合
        通常使うプリンタのプリンタ名が表示されます。
    ・印刷したことがある帳票ジョブを受信した場合
        通常使うプリンタのプリンタ名が表示されます。
    OSの印刷ダイアログに初期表示するプリンタ名
    ・初めて印刷する帳票ジョブを受信した場合
        通常使うプリンタのプリンタ名が表示されます。
    ・印刷したことがある帳票ジョブを受信した場合
        通常使うプリンタのプリンタ名が表示されます。

SelectDisplayPrinterパラメタを省略した場合，または0，1以外の値を指定した場合は0が仮定されます。

注※1
ExclusionPrinterNameプロパティ，またはExclusionPrinterDriverプロパティが指定されている場合，次のどちらかの条件を満たすときは，通常使うプリンタのプリンタ名が表示されます。
  • ExclusionPrinterNameプロパティ，またはExclusionPrinterDriverプロパティの指定が有効，かつ指定値に通常使うプリンタのプリンタ名が指定されていないとき
  • PermissionPrinterNameプロパティ，またはPermissionPrinterDriverプロパティの指定が有効，かつ指定値に通常使うプリンタのプリンタ名が指定されているとき
注※2
前回の受信時に設定したプリンタ名が存在しない場合，またはプロパティ（ExclusionPrinterNameプロパティ，ExclusionPrinterDriverプロパティ，PermissionPrinterNameプロパティ，またはPermissionPrinterDriverプロパティ）の指定によってプリンタ名が表示できない場合は，次に示すプリンタ名が表示されます。
  • 注※1の条件を満たすときは，通常使うプリンタのプリンタ名が表示されます。
  • 注※4の条件を満たすときは，プリンタ名は表示されません。
  • ExclusionPrinterNameプロパティ，またはExclusionPrinterDriverプロパティが指定されていないときは，プリンタ名は表示されません。
注※3
前回の受信時に設定したプリンタ名のプリンタが存在しない場合，通常使うプリンタのプリンタ名が表示されます。
注※4
次のどちらかの条件を満たす場合，プリンタ名は表示されません。
  • ExclusionPrinterNameプロパティ，またはExclusionPrinterDriverプロパティの指定が有効，かつ指定値に通常使うプリンタのプリンタ名が指定されているとき
  • PermissionPrinterNameプロパティ，またはPermissionPrinterDriverプロパティの指定が有効，かつ指定値に通常使うプリンタのプリンタ名が指定されていないとき


SendResultURLパラメタ

SendResultURLパラメタ

印刷結果を報告するURLを指定します。指定したURLに結果が出力され，HTTPリクエストが送信されます。

SendResultURLパラメタで指定するURLで，EPF形式ファイルの削除などの処理ができます。

報告される結果の形式を次に示します。

  • 印刷成功時：?PrintResult=OK
  • 印刷失敗（キャンセルを含む）時：?PrintResult=NG

SendResultURLパラメタを省略した場合，印刷結果は報告されません。

SendResultURLパラメタで指定するURLのHTTPレスポンスは無効になります。


ShowScrollBarパラメタ

ShowScrollBarパラメタ

印刷プレビューが表示領域を超える場合，スクロールバーを表示するかどうかを指定します。EUR Web Plug-In（プレビュー用）で指定できます。

指定できる値を次に示します。

  • YES：スクロールバーを表示します。
  • NO：スクロールバーを表示しません。

ShowScrollBarパラメタを省略した場合，または指定できない値を指定した場合，YESが仮定されます。

YESを指定しても，印刷プレビューが表示領域を超えなければ，スクロールバーは表示されません。


TempFileDelパラメタ

TempFileDelパラメタ

印刷実行時に生成した一時ファイルを削除するかどうかを選択します。一時ファイルは障害対策のために使用します。

指定できる値を次に示します。

  • 0：常に削除します。
  • 1：正常終了時には削除します。異常終了時には削除しません。
  • 2：常に削除しません。

TempFileDelパラメタを省略した場合，または0，1，2以外を指定した場合は1が仮定されます。

EPFTempDataModeパラメタに1を指定している場合，TempFileDelパラメタに指定した内容は無視されます。

一時ファイルは，次の順に出力先フォルダを決定します。

  1. 環境変数TMPに指定されたフォルダ
  2. 環境変数TEMPに指定されたフォルダ
  3. 実行しているプログラムのカレントフォルダ

一時ファイルを削除しなかった場合は，プログラムが稼働していないときに定期的に削除してください。


TrayNameパラメタ

TrayNameパラメタ

帳票を印刷するプリンタのトレイ名を指定します。トレイ名には，PrinterNameパラメタで指定したプリンタのトレイ名を指定します。

PrinterNameパラメタを省略した場合，またはPrinterNameパラメタで指定したプリンタがない場合は，TrayNameパラメタの指定は無効になります。

TrayNameパラメタで指定したトレイ名がない場合は，NoSetPrinterDlgパラメタとDefaultPrintDlgパラメタの指定に従います。


UserParamパラメタ

UserParamパラメタ

ユーザ付加情報を指定します。

UserParamパラメタを指定した場合，SendResultURLパラメタで指定したURLの後ろに，"?"に続いてUserParamパラメタの文字列を付け，さらに"&"と結果文字列を付けて印刷結果が報告されます。

UserParamパラメタを省略した場合，SendResultURLパラメタで指定したURLの後ろに，"?"に続いて結果文字列を付けて印刷結果が報告されます。

SendResultURLパラメタを省略した場合，UserParamパラメタは無効になります。


Zoomパラメタ

Zoomパラメタ

印刷プレビューの表示倍率の初期値を指定します。EUR Web Plug-In（プレビュー用）で指定できます。

指定できる値は，25～200です。単位は%です。

25より小さい値を指定した場合は，25が仮定されます。200より大きい値を指定した場合は，200が仮定されます。

Zoomパラメタを省略した場合，または数値以外を指定した場合は，100が仮定されます。


メソッド仕様

5.4　メソッド仕様

EUR Web Plug-Inのメソッドの詳細を説明します。

＜この節の構成＞
Findメソッド
FindNextメソッド
HScrollメソッド
PrintEPFメソッド
TurnPageメソッド
VScrollメソッド
Zoomメソッド


Findメソッド

Findメソッド

検索ダイアログを表示します。

検索を実行してプレビューしている帳票の表示ページが変わった場合は，PageChangedイベントを発行します。

形式

long Find()

引数

なし

戻り値

リターンコード

0：正常終了

上記以外：エラー


FindNextメソッド

FindNextメソッド

検索ダイアログで前回実行した検索の内容に従って，次の検索を実行します。一度も検索を実行していない場合は，検索ダイアログを表示します。

検索を実行してプレビューしている帳票の表示ページが変わった場合は，PageChangedイベントを発行します。

形式

long FindNext()

引数

なし

戻り値

リターンコード

0：正常終了

上記以外：エラー


HScrollメソッド

HScrollメソッド

横方向にスクロールします。単位はpx（ピクセル）です。EUR Web Plug-In（プレビュー用）で指定できます。

正の値を指定すると左方向にスクロールします。負の値を指定すると右方向にスクロールします。

形式

long HScroll(long lPixel)

引数

lPixel

スクロール量

戻り値

リターンコード

0：正常終了

上記以外：エラー


PrintEPFメソッド

PrintEPFメソッド

印刷を実行します。パラメタの指示に従って印刷します。

形式

long PrintEPF()

引数

なし

戻り値

リターンコード

0：正常終了

上記以外：エラー


TurnPageメソッド

TurnPageメソッド

指定したページを表示します。EUR Web Plug-In（プレビュー用）で指定できます。

指定したページ数が，帳票にない場合は，次の規則に従います。

  • 0以下を指定した場合：先頭ページを表示します。
  • 最終ページより大きい値を指定した場合：最終ページを表示します。

形式

long TurnPage(long lPage)

引数

lPage

ページ番号

戻り値

リターンコード

0：正常終了

上記以外：エラー


VScrollメソッド

VScrollメソッド

縦方向にスクロールします。単位はpx（ピクセル）です。EUR Web Plug-In（プレビュー用）で指定できます。正の値を指定すると上方向にスクロールします。負の値を指定すると下方向にスクロールします。

形式

long VScroll(long lPixel)

引数

lPixel

スクロール量

戻り値

リターンコード

0：正常終了

上記以外：エラー


Zoomメソッド

Zoomメソッド

印刷プレビューの表示倍率を変更します。EUR Web Plug-In（プレビュー用）で指定できます。

指定できる値は，25～200です。単位は%です。

形式

long Zoom(long lPercent)

引数

lPercent

倍率

戻り値

リターンコード

0：正常終了

上記以外：エラー


プロパティ仕様

5.5　プロパティ仕様

EUR Web Plug-Inのプロパティの詳細を説明します。

＜この節の構成＞
CurrentPageプロパティ
ExclusionPrinterDriverプロパティ
ExclusionPrinterNameプロパティ
PermissionPrinterDriverプロパティ
PermissionPrinterNameプロパティ
SelectDisplayPrinterプロパティ
TotalPageプロパティ


CurrentPageプロパティ

CurrentPageプロパティ

表示中のページ番号を取得します。

形式

long CurrentPage


ExclusionPrinterDriverプロパティ

ExclusionPrinterDriverプロパティ

PrintEPFメソッドの実行時に，表示するプリンタ選択ダイアログ中のプリンタ一覧から，除外したいプリンタのドライバ名を指定します。

指定したドライバ名がPrinterNameパラメタ，またはNoSetPrinterDlgパラメタの指定によって自動で印刷されるプリンタの場合，KEEY181-Eエラーとなります。

DefaultPrintDlgパラメタでYESを指定した場合は，ExclusionPrinterDriverプロパティの指定値は無効になります。

PermissionPrinterNameプロパティ，またはPermissionPrinterDriverプロパティに値が指定されている場合は，ExclusionPrinterDriverプロパティの指定値は無効になります。

指定できるドライバ名は100個までです。100を超えるドライバ名を指定した場合，PrintEPFメソッド実行時にKEEY153-Eエラーとなります。

形式

一つの除外ドライバ名を指定する場合。
文字型
複数の除外ドライバ名を指定する場合。要素数が一つの文字型配列も指定できます。
文字型配列

指定例

複数の除外ドライバ名を指定する場合の例を次に示します。

（指定例1）VBScriptの場合

Set drivers = CreateObject("Scripting.Dictionary")
drivers.add 0, "Driver1"       'drivers(0) = "Driver1"でも可能
drivers.add 1, "Driver2"       'drivers(1) = "Driver2"でも可能
drivers.add 2, "Driver3"       'drivers(2) = "Driver3"でも可能
document.Form1.EURPMPRINTAX.ExclusionPrinterDriver = drivers.items

（指定例2）VBScriptの場合

document.Form1.EURPMPRINTAX.ExclusionPrinterDriver
                         = Array("Driver1","Driver2","Driver3")

（指定例3）VBScriptの場合

Dim drivers(2)
drivers(0) = "Driver1"
drivers(1) = "Driver2"
drivers(2) = "Driver3"
document.Form1.EURPMPRINTAX.ExclusionPrinterDriver = drivers

（指定例4）JavaScriptの場合

var drivers = new ActiveXObject("Scripting.Dictionary");
drivers.add(0, "Driver1");       //drivers(0) = "Driver1"でも可能
drivers.add(1, "Driver2");       //drivers(1) = "Driver2"でも可能
drivers.add(2, "Driver3");       //drivers(2) = "Driver3"でも可能
document.Form1.EURPMPRINTAX.ExclusionPrinterDriver = drivers.items();


ExclusionPrinterNameプロパティ

ExclusionPrinterNameプロパティ

PrintEPFメソッドの実行時に，表示するプリンタ選択ダイアログ中のプリンタ一覧から，除外したいプリンタのプリンタ名を指定します。

指定したプリンタ名がPrinterNameパラメタ，またはNoSetPrinterDlgパラメタの指定によって自動で印刷されるプリンタの場合，KEEY181-Eエラーとなります。

DefaultPrintDlgパラメタでYESを指定した場合は，ExclusionPrinterNameプロパティの指定値は無効になります。

PermissionPrinterNameプロパティ，またはPermissionPrinterDriverプロパティに値が指定されている場合は，ExclusionPrinterNameプロパティの指定値は無効になります。

指定できるプリンタ名は100個までです。100を超えるプリンタ名を指定した場合，PrintEPFメソッド実行時にKEEY153-Eエラーとなります。

形式

一つの除外プリンタ名を指定する場合。
文字型
複数の除外プリンタ名を指定する場合。要素数が一つの文字型配列も指定できます。
文字型配列

指定例

複数の除外プリンタ名を指定する場合の例を次に示します。

（指定例1）VBScriptの場合

Set printers = CreateObject("Scripting.Dictionary")
printers.add 0, "Printer1"       'printers(0) = "Printer1"でも可能
printers.add 1, "Printer2"       'printers(1) = "Printer2"でも可能
printers.add 2, "Printer3"       'printers(2) = "Printer3"でも可能
document.Form1.EURPMPRINTAX.ExclusionPrinterName = printers.items

（指定例2）VBScriptの場合

document.Form1.EURPMPRINTAX.ExclusionPrinterName
                         = Array("Printer1","Printer2","Printer3")

（指定例3）VBScriptの場合

Dim printers(2)
printers(0) = "Printer1"
printers(1) = "Printer2"
printers(2) = "Printer3"
document.Form1.EURPMPRINTAX.ExclusionPrinterName = printers

（指定例4）JavaScriptの場合

var printers = new ActiveXObject("Scripting.Dictionary");
printers.add(0, "Printer1");       //printers(0) = "Printer1"でも可能
printers.add(1, "Printer2");       //printers(1) = "Printer2"でも可能
printers.add(2, "Printer3");       //printers(2) = "Printer3"でも可能
document.Form1.EURPMPRINTAX.ExclusionPrinterName = printers.items();


PermissionPrinterDriverプロパティ

PermissionPrinterDriverプロパティ

印刷を許可するプリンタのドライバ名を指定します。指定したプリンタは，PrintEPFメソッドの実行時に，プリンタの選択ダイアログ中のプリンタ一覧に表示されます。

PermissionPrinterDriverプロパティでプリンタのドライバ名を指定した場合，ExclusionPrinterNameプロパティおよびExclusionPrinterDriverプロパティの指定値は無効になります。

指定したドライバ名が，PrinterNameパラメタ，またはNoSetPrinterDlgパラメタの指定によって自動で印刷されるプリンタではない場合，KEEY181-Eエラーとなります。

DefaultPrintDlgパラメタでYESを指定した場合は，PermissionPrinterDriverプロパティの指定値は無効になり，登録されているプリンタがすべて表示されます。

指定できるドライバ名は100個までです。100を超えるドライバ名を指定した場合，PrintEPFメソッド実行時にKEEY153-Eエラーとなります。

形式

一つの許可ドライバ名を指定する場合。
文字型
複数の許可ドライバ名を指定する場合。要素数が一つの文字型配列も指定できます。
文字型配列

指定例

複数の許可ドライバ名を指定する場合の例を次に示します。

（指定例1）VBScriptの場合

Set drivers = CreateObject("Scripting.Dictionary")
drivers.add 0, "Driver1"       'drivers(0) = "Driver1"でも可能
drivers.add 1, "Driver2"       'drivers(1) = "Driver2"でも可能
drivers.add 2, "Driver3"       'drivers(2) = "Driver3"でも可能
document.Form1.EURPMPRINTAX.PermissionPrinterDriver = drivers.items

（指定例2）VBScriptの場合

document.Form1.EURPMPRINTAX.PermissionPrinterDriver
                       = Array("Driver1","Driver2","Driver3")

（指定例3）VBScriptの場合

Dim drivers(2)
drivers(0) = "Driver1"
drivers(1) = "Driver2"
drivers(2) = "Driver3"
document.Form1.EURPMPRINTAX.PermissionPrinterDriver = drivers

（指定例4）JavaScriptの場合

var drivers = new ActiveXObject("Scripting.Dictionary");
drivers.add(0, "Driver1");       //drivers(0) = "Driver1"でも可能
drivers.add(1, "Driver2");       //drivers(1) = "Driver2"でも可能
drivers.add(2, "Driver3");       //drivers(2) = "Driver3"でも可能
document.Form1.EURPMPRINTAX.PermissionPrinterDriver = drivers.items();


PermissionPrinterNameプロパティ

PermissionPrinterNameプロパティ

印刷を許可するプリンタのプリンタ名を指定します。指定したプリンタは，PrintEPFメソッドの実行時に，プリンタの選択ダイアログ中のプリンタ一覧に表示されます。

PermissionPrinterNameプロパティでプリンタ名を指定した場合，ExclusionPrinterNameプロパティおよびExclusionPrinterDriverプロパティの指定値は無効になります。

指定したプリンタ名が，PrinterNameパラメタ，またはNoSetPrinterDlgパラメタの指定によって自動で印刷されるプリンタではない場合，KEEY181-Eエラーとなります。

DefaultPrintDlgパラメタでYESを指定した場合は，PermissionPrinterNameプロパティの指定値は無効になり，登録されているプリンタがすべて表示されます。

指定できるプリンタ名は100個までです。100を超えるプリンタ名を指定した場合，PrintEPFメソッド実行時にKEEY153-Eエラーとなります。

形式

一つの許可プリンタ名を指定する場合。
文字型
複数の許可プリンタ名を指定する場合。要素数が一つの文字型配列も指定できます。
文字型配列

指定例

複数の許可プリンタ名を指定する場合の例を次に示します。

（指定例1）VBScriptの場合

Set printers = CreateObject("Scripting.Dictionary")
printers.add 0, "Printer1"       'printers(0) = "Printer1"でも可能
printers.add 1, "Printer2"       'printers(1) = "Printer2"でも可能
printers.add 2, "Printer3"       'printers(2) = "Printer3"でも可能
document.Form1.EURPMPRINTAX.PermissionPrinterName = printers.items

（指定例2）VBScriptの場合

document.Form1.EURPMPRINTAX.PermissionPrinterName
                       = Array("Printer1","Printer2","Printer3")

（指定例3）VBScriptの場合

Dim printers(2)
printers(0) = "Printer1"
printers(1) = "Printer2"
printers(2) = "Printer3"
document.Form1.EURPMPRINTAX.PermissionPrinterName = printers

（指定例4）JavaScriptの場合

var printers = new ActiveXObject("Scripting.Dictionary");
printers.add(0, "Printer1");       //printers(0) = "Printer1"でも可能
printers.add(1, "Printer2");       //printers(1) = "Printer2"でも可能
printers.add(2, "Printer3");       //printers(2) = "Printer3"でも可能
document.Form1.EURPMPRINTAX.PermissionPrinterName = printers.items();


SelectDisplayPrinterプロパティ

SelectDisplayPrinterプロパティ

印刷ダイアログに初期表示するプリンタ名の表示モードを指定します。

指定できる値を次に示します。

  • 0：標準モード
    印刷先指定ダイアログに初期表示するプリンタ名
    ・初めて印刷する帳票ジョブを受信した場合
        プリンタ名は表示されません。※1
    ・印刷したことがある帳票ジョブを受信した場合
        前回の受信時に設定したプリンタ名が表示されます。※2
    OSの印刷ダイアログに初期表示するプリンタ名
    ・初めて印刷する帳票ジョブを受信した場合
        通常使うプリンタのプリンタ名が表示されます。
    ・印刷したことがある帳票ジョブを受信した場合
        前回の受信時に設定したプリンタ名が表示されます。※3
  • 1：通常使うプリンタ初期表示モード
    印刷先指定ダイアログに初期表示するプリンタ名※4
    ・初めて印刷する帳票ジョブを受信した場合
        通常使うプリンタのプリンタ名が表示されます。
    ・印刷したことがある帳票ジョブを受信した場合
        通常使うプリンタのプリンタ名が表示されます。
    OSの印刷ダイアログに初期表示するプリンタ名
    ・初めて印刷する帳票ジョブを受信した場合
        通常使うプリンタのプリンタ名が表示されます。
    ・印刷したことがある帳票ジョブを受信した場合
        通常使うプリンタのプリンタ名が表示されます。

SelectDisplayPrinterプロパティを省略した場合，または0，1以外の値を指定した場合は0が仮定されます。

注※1
ExclusionPrinterNameプロパティ，またはExclusionPrinterDriverプロパティが指定されている場合，次のどちらかの条件を満たすときは，通常使うプリンタのプリンタ名が表示されます。
  • ExclusionPrinterNameプロパティ，またはExclusionPrinterDriverプロパティの指定が有効，かつ指定値に通常使うプリンタのプリンタ名が指定されていないとき
  • PermissionPrinterNameプロパティ，またはPermissionPrinterDriverプロパティの指定が有効，かつ指定値に通常使うプリンタのプリンタ名が指定されているとき
注※2
前回の受信時に設定したプリンタ名が存在しない場合，またはプロパティ（ExclusionPrinterNameプロパティ，ExclusionPrinterDriverプロパティ，PermissionPrinterNameプロパティ，またはPermissionPrinterDriverプロパティ）の指定によってプリンタ名が表示できない場合は，次に示すプリンタ名が表示されます。
  • 注※1の条件を満たすときは，通常使うプリンタのプリンタ名が表示されます。
  • 注※4の条件を満たすときは，プリンタ名は表示されません。
  • ExclusionPrinterNameプロパティ，またはExclusionPrinterDriverプロパティが指定されていないときは，プリンタ名は表示されません。
注※3
前回の受信時に設定したプリンタ名のプリンタが存在しない場合，通常使うプリンタのプリンタ名が表示されます。
注※4
次のどちらかの条件を満たす場合，プリンタ名は表示されません。
  • ExclusionPrinterNameプロパティ，またはExclusionPrinterDriverプロパティの指定が有効，かつ指定値に通常使うプリンタのプリンタ名が指定されているとき
  • PermissionPrinterNameプロパティ，またはPermissionPrinterDriverプロパティの指定が有効，かつ指定値に通常使うプリンタのプリンタ名が指定されていないとき


TotalPageプロパティ

TotalPageプロパティ

表示データの総ページ数を取得します。

形式

long TotalPage


イベント仕様

5.6　イベント仕様

EUR Web Plug-Inのイベントの詳細を説明します。

＜この節の構成＞
PageChangedイベント


PageChangedイベント

PageChangedイベント

検索を実行してプレビューしている表示ページが変わったときに，ページ番号を通知します。

形式

void PageChanged(long lPageNo)

引数

lPageNo

表示中のページ番号

戻り値

なし


タグの記述例

5.7　タグの記述例

クライアントPCのWebブラウザ上で帳票を印刷する場合，HTMLページに<object>タグを記述してEUR Web Plug-Inを使用します。

＜この節の構成＞
(1)　Webブラウザ上で帳票を印刷するEUR Web Plug-In（印刷用）を使用するときの<object>タグの記述例
(2)　Webブラウザ上で帳票を表示・印刷するEUR Web Plug-In（プレビュー用）を使用するときの<object>タグの記述例

(1)　Webブラウザ上で帳票を印刷するEUR Web Plug-In（印刷用）を使用するときの<object>タグの記述例

Webブラウザ上で帳票を印刷するEUR Web Plug-In（印刷用）を使用するときの<object>タグの記述例を次に示します。

「clsid」と「version」に指定する値は，EUR Web Plug-In情報ファイルに記載されています。EUR Server - AdapterのActiveX起動部品またはJava起動部品の次に示すメソッドを指定して取得できます。

  • ActiveX起動部品の場合
    clsid：GetPrintAXClassIDメソッド
    version：GetPrintAXVersionメソッド
  • Java起動部品の場合
    clsid：getPrintAXClassIDメソッド
    version：getPrintAXVersionメソッド

また，取得処理については，マニュアル「EUR 帳票出力 機能解説 EUR Server編」を参照してください。

(a)　配布用パッケージによるインストールの場合

<object
 classid="clsid:368EE1C4-5A52-4C2E-A4C0-27C46B946A2C"
 ID="EURPMPRINTAX"
 type="application/x-oleobject">
<param name= "EPFFileURL" value="http://test/EPF/sampleEPF.epf">
<param name= "LogLevel" value="16">
</object>
classid
クラスIDを指定します。指定するクラスIDは，368EE1C4-5A52-4C2E-A4C0-27C46B946A2Cです。
ID
IDを指定します。
type
オブジェクトのタイプを指定します。
param name
パラメタを指定します。
(b)　ダウンロードパッケージでのインストールの場合

<object
 classid="clsid:368EE1C4-5A52-4C2E-A4C0-27C46B946A2C"
 codebase="http://test/EURPMCLAX/EURPMPrintAX.cab#version=8,70,0,1"
 ID="EURPMPRINTAX"
 type="application/x-oleobject">
<param name= "EPFFileURL" value="http://test/EPF/sampleEPF.epf">
<param name= "LogLevel" value="16">
</object>
classid
クラスIDを指定します。指定するクラスIDは，マシン単位インストールの場合，368EE1C4-5A52-4C2E-A4C0-27C46B946A2C，ユーザ単位インストールの場合，7A50CEB4-6A70-4DAD-B8F9-D9F791F7C9E5です。
codebase
ダウンロードパッケージのcabファイルの名前とバージョンを指定します。ダウンロードパッケージのcabファイルの名前は，EURPMPrintAX.cabです。バージョンは，製品のバージョンによって指定する値が異なります。
ID
IDを指定します。
type
オブジェクトのタイプを指定します。
param name
パラメタを指定します。

(2)　Webブラウザ上で帳票を表示・印刷するEUR Web Plug-In（プレビュー用）を使用するときの<object>タグの記述例

Webブラウザ上で帳票を印刷したり，表示したりするEUR Web Plug-In（プレビュー用）を使用するときの<object>タグの記述例を次に示します。

「clsid」と「version」に指定する値は，EUR Web Plug-In情報ファイルに記載されています。EUR Server - AdapterのActiveX起動部品またはJava起動部品の次に示すメソッドを指定して取得できます。

  • ActiveX起動部品の場合
    clsid：GetPreviewAXClassIDメソッド
    version：GetPreviewAXVersionメソッド
  • Java起動部品の場合
    clsid：getPreviewAXClassIDメソッド
    version：getPreviewAXVersionメソッド

また，取得処理については，マニュアル「EUR 帳票出力 機能解説 EUR Server編」を参照してください。

(a)　配布用パッケージによるインストールの場合

<object
 classid="clsid:D07DA8D2-3459-488E-860E-DD47A71C39D2"
 width=850
 height=650
 ID="EURPMPREVIEWAX"
 type="application/x-oleobject">
<param name= "EPFFileURL" value="http://test/EPF/sampleEPF.epf">
<param name= "LogLevel" value="16">
</object>
classid
クラスIDを指定します。指定するクラスIDは，D07DA8D2-3459-488E-860E-DD47A71C39D2です。
width
プレビュー画面の幅を指定します。
height
プレビュー画面の高さを指定します。
ID
IDを指定します。
type
オブジェクトのタイプを指定します。
param name
パラメタを指定します。
(b)　ダウンロードパッケージでのインストールの場合

<object
 classid="clsid:D07DA8D2-3459-488E-860E-DD47A71C39D2"
 codebase="http://test/EURPMCLPVX/EURPMPreViewAX.cab#version=8,70,0,1"
 width=850
 height=650
 ID="EURPMPREVIEWAX"
 type="application/x-oleobject">
<param name= "EPFFileURL" value="http://test/EPF/sampleEPF.epf">
<param name= "LogLevel" value="16">
</object>
classid
クラスIDを指定します。指定するクラスIDは，マシン単位インストールの場合，D07DA8D2-3459-488E-860E-DD47A71C39D2，ユーザ単位インストールの場合，51B88D4D-8FE2-4E68-8035-3482C44F1E29です。
codebase
ダウンロードパッケージのcabファイルの名前とバージョンを指定します。ダウンロードパッケージのcabファイルの名前は，EURPMPreViewAX.cabです。バージョンは，製品のバージョンによって指定する値が異なります。
width
プレビュー画面の幅を指定します。
height
プレビュー画面の高さを指定します。
ID
IDを指定します。
type
オブジェクトのタイプを指定します。
param name
パラメタを指定します。


ActiveX起動部品

6.　ActiveX起動部品

この章では，EUR Server Serviceで提供するActiveX起動部品を使用した帳票出力について説明します。

＜この章の構成＞
6.1　ActiveX起動部品とは
6.2　ActiveX起動部品のメソッドとプロパティ
6.3　ActiveX起動部品のメソッド仕様
6.4　ActiveX起動部品のプロパティ仕様
6.5　エラー情報


ActiveX起動部品とは

6.1　ActiveX起動部品とは

Visual Basic ScriptやVisual Basicで開発するサーバアプリケーションからEUR Server Serviceを使って帳票出力できるように，EUR Server ServiceではActiveX起動部品を提供しています。ActiveX起動部品は，STA（Single-Threaded Apartment）のCOMオブジェクトとして作成しています。

ActiveX起動部品を利用することで，次のことができます。

  • Web/APサーバ上のサーバアプリケーションからの帳票の印刷
  • EPF形式ファイルへの出力
  • サーバへの帳票の蓄積
＜この節の構成＞
6.1.1　ファイル名
6.1.2　プログラムIDとコントロール名
6.1.3　提供するクラス
6.1.4　構文


ファイル名

6.1.1　ファイル名

EURPMADP.ocx
ActiveX起動部品のファイルです。インストール先フォルダ\Adapter\Program\下にあります。


プログラムIDとコントロール名

6.1.2　プログラムIDとコントロール名

ActiveX起動部品のプログラムIDおよびコントロール名は，EUR Server - Adapterをインストールしたときに登録されます。

EURPM.Exec
ActiveX起動部品のプログラムIDです。
EURPMADP ActiveX コントロールモジュール
ActiveX起動部品のコントロール名です。


提供するクラス

6.1.3　提供するクラス

ActiveX起動部品では，帳票出力の制御を行うEURPMADPLib.EURPMAdapterクラスを提供します。

EURPMADPLib.EURPMAdapterクラスでは，帳票ファイルやデータファイルなどのプロパティを設定するメソッドと，帳票の出力先やバージョン情報などを取得するメソッドを提供します。EURPMADPLib.EURPMAdapterクラスは次のように指定します。

Public Class EURPMADPLib.EURPMAdapter

Visual Basic ScriptやVisual Basicで開発するサーバアプリケーションから，次の手順で帳票を出力します。

  1. CSV形式ファイルの作成
  2. ActiveX起動部品の構築
  3. プロパティの設定
    帳票ファイル，データファイルなどのプロパティを設定します。プロパティの設定については，「6.4　ActiveX起動部品のプロパティ仕様」を参照してください。
  4. 帳票の出力
    帳票出力メソッド（PrintPMReportメソッドなど）を呼び出して帳票を出力します。

3.と4.の処理で発生したエラー，または発生するエラーは，例外を処理するようにプログラムに記述します。


構文

6.1.4　構文

ActiveX起動部品を構築する場合とEURPMADPLib.EURPMAdapterクラスを生成する場合の構文を次に示します。

＜この項の構成＞
(1)　ActiveX起動部品を構築する場合
(2)　EURPMADPLib.EURPMAdapterクラスを生成する場合

(1)　ActiveX起動部品を構築する場合

ActiveX起動部品を構築する場合は，次のように指定します。

Visual Basic Scriptの場合
Dim eurpm As Object
Set eurpm=Server.CreateObject("EURPM.Exec")
Visual Basicの場合
Dim eurpm As Object
Set eurpm=CreateObject("EURPM.Exec")
パラメタ
  • eurpmには，Server.CreateObjectまたはCreateObjectの呼び出しによって作成されるオブジェクト名を指定します。
  • EURPM.Execは，ActiveX起動部品のプログラムIDです。
    ASPファイルのあるVisual Basic ScriptのCreateObject関数にプログラムIDを指定して，ActiveX起動部品を生成してください。

(2)　EURPMADPLib.EURPMAdapterクラスを生成する場合

EURPMADPLib.EURPMAdapterクラスを生成することで，ActiveX起動部品を生成することもできます。この場合は，クラスを生成する前に，ユーザアプリケーションプロジェクトのコントロールまたはCOMの参照設定に，コントロール名「EURPMADP ActiveX コントロール モジュール」を追加してください。

EURPMADPLib.EURPMAdapterクラスを生成する場合は，次のように指定します。

Dim eurpm As EURPMADPLib.EURPMAdapter
Set eurpm=new EURPMADPLib.EURPMAdapter
パラメタ
  • eurpmには，EURPMADPLib.EURPMAdapterクラス型の任意のオブジェクト名を指定します。
  • new操作でEURPMADPLib.EURPMAdapterクラスを生成してください。


ActiveX起動部品のメソッドとプロパティ

6.2　ActiveX起動部品のメソッドとプロパティ

ActiveX起動部品が提供するメソッドとプロパティの一覧を示します。

＜この節の構成＞
6.2.1　メソッド一覧
6.2.2　プロパティ一覧（出力メソッド）
6.2.3　プロパティ一覧（情報取得メソッド）
6.2.4　指定値に使用できない文字について


メソッド一覧

6.2.1　メソッド一覧

ActiveX起動部品が提供するメソッドの一覧を次に示します。

表6-1　ActiveX起動部品が提供するメソッド一覧

種類 | メソッド | 概要
情報取得メソッド | GetDestinationList | 出力先（スプールサーバ）の一覧を取得します。
 | GetJobID | GetJobIDメソッドを実行する直前に蓄積したスプールデータのジョブIDを取得します。 帳票を分割または仕分けして蓄積した場合など，直前に蓄積したスプールデータが複数あるときは，最初に蓄積したスプールデータのジョブIDを取得します。
 | GetJobIDList | GetJobIDListメソッドを実行する直前に蓄積したスプールデータのジョブIDの一覧を取得します。
 | GetPMPrinterClassList | 帳票サーバに登録されているプリンタクラスの一覧を取得します。
 | GetPMPrinterList ※1 | 帳票サーバのOSに登録されているプリンタの一覧を取得します。
 | GetPMTrayList ※1 | 帳票サーバのOSに登録されているプリンタのトレイ一覧を取得します。
 | GetPreviewAXClassID | EUR Web Plug-In（プレビュー用）のクラスIDを取得します。
 | GetPreviewAXVersion | EUR Web Plug-In（プレビュー用）のバージョンを取得します。
 | GetPrintAXClassID | EUR Web Plug-In（印刷用）のクラスIDを取得します。
 | GetPrintAXVersion | EUR Web Plug-In（印刷用）のバージョンを取得します。
 | GetPrinterClassList ※2 | 指定した出力先（スプールサーバ）に登録されているプリンタクラスの一覧を取得します。
 | GetPrinterList ※2 | 指定した出力先（スプールサーバ）のOSに登録されているプリンタの一覧を取得します。
 | GetTrayList ※2 | 指定した出力先（スプールサーバ）のOSに登録されているプリンタのトレイ一覧を取得します。
出力メソッド | OutputEPFReport | EPF形式ファイルを出力します。
 | OutputEURReport | EUR形式ファイルを出力します。
 | OutputMergeEPFReport | 複数のEPF形式ファイルを一つのEPF形式ファイルに統合して出力します。
 | OutputPDFReport | PDF形式ファイルを出力します。
 | OutputXLSXReport | Excel形式ファイルを出力します。
 | PrintPMReport | 帳票を印刷または蓄積します。
注※1
帳票サーバがUNIX／Linux環境の場合は指定できません。
注※2
対象となるスプールサーバがUNIX／Linux環境の場合は指定できません。


プロパティ一覧（出力メソッド）

6.2.2　プロパティ一覧（出力メソッド）

ActiveX起動部品が提供するプロパティのうち，出力メソッドで使用するプロパティを表6-3に示します。表5-3では，出力メソッドを表5-2のように省略して表記します。

表6-2　出力メソッドの略称

略称 | 出力メソッド
PMRS | PrintPMReport（スプールサーバでの印刷）
PMRC | PrintPMReport（クライアントPCでの印刷）
PMRT | PrintPMReport（蓄積）
PMRD | PrintPMReport（直接印刷）
PMRH | PrintPMReport（クライアントPCへの配布印刷）
OPDF | OutputPDFReport（PDF形式ファイル出力）
OEPF | OutputEPFReport（EPF形式ファイル出力）
MEPF | OutputMergeEPFReport（複数EPF形式ファイル統合出力）
OEUR | OutputEURReport（EUR形式ファイル出力）
OXLS | OutputXLSXReport（Excel形式ファイル出力）

表6-3　 ActiveX起動部品が提供するプロパティ一覧（出力メソッド）

プロパティ | 設定内容 | データ型 | 出力メソッド
 |  |  | PMRS | PMRC | PMRT | PMRD | PMRH | OPDF | OEPF | MEPF | OEUR | OXLS
BookmarkFileName | しおり定義ファイル名 | String String配列 | － | － | － | － | － | △ | － | － | － | －
BookmarkFilePath | 文書しおり定義ファイルまたはしおり定義ファイルのパス | String | － | － | － | － | － | △ | － | － | － | －
ClientAddress | クライアントPCのIPアドレス | String | － | △ | △ | － | △ | － | － | － | － | －
ClientPrinterName | 印刷先クライアントプリンタ名 | String | － | △ | △ | － | △ | － | － | － | － | －
ClientTrayName | 印刷先クライアントプリンタのトレイ名 | String | － | △ | △ | － | △ | － | － | － | － | －
Crypto | PDF形式ファイルの暗号化出力の有無 | Boolean | － | － | － | － | － | △ | － | － | － | －
CryptoFileName | 暗号化設定ファイル名 | String | － | － | － | － | － | △ | － | － | － | －
CryptoFilePath | 暗号化設定ファイルのパス | String | － | － | － | － | － | △ | － | － | － | －
DataFileName | マッピングデータファイル名または可変記号値定義ファイル名 | String String配列 | △ | △ | △ | △ | － | △ | △ | － | △ | △
DataFilePath | マッピングデータファイルのパスまたは可変記号値定義ファイルのパス | String | △ | △ | △ | △ | － | △ | △ | － | △ | △
DBInfoFileName | 接続情報ファイル名 | String | △ | △ | △ | △ | － | △ | △ | － | △ | △
DBInfoFilePath | 接続情報ファイルのパス | String | △ | △ | △ | △ | － | △ | △ | － | △ | △
DestinationName | 出力先名 | String | △ | － | △ | － | － | － | － | － | － | －
DispPrintDlg | ダイアログ表示モード | Long | － | △ | △ | － | △ | － | － | － | － | －
DistributeFileName | PDF仕分け定義ファイル名 | String | － | － | － | － | － | △ | － | － | － | －
DistributeFilePath | PDF仕分け定義ファイルのパス | String | － | － | － | － | － | △ | － | － | － | －
DocBookmarkFileName | 文書しおり定義ファイル名 | String | － | － | － | － | － | △ | － | － | － | －
DocInfoFileName | 文書情報設定ファイル名 | String | △ | △ | △ | △ | － | △ | △ | － | △ | －
DocInfoFilePath | 文書情報設定ファイルのパス | String | △ | △ | △ | △ | － | △ | △ | － | △ | －
EnableGet | スプールデータに格納されているEPF形式ファイルの取得可否 | Boolean | － | － | △ | － | － | － | － | － | － | －
EncryptionPasswordKey | パスワード暗号化鍵 | String | － | － | － | － | － | △ | － | － | － | －
EPFFileName | 出力EPF形式ファイル名 | String | － | － | － | － | ○ | － | ○ | ○ | － | －
EPFFilePath | 出力EPF形式ファイルのパス | String | － | － | － | － | △ | － | △ | △ | － | －
EURFileName | 出力EUR形式ファイル名 | String | － | － | － | － | － | － | － | － | ○ | －
EURFilePath | 出力EUR形式ファイルのパス | String | － | － | － | － | － | － | － | － | △ | －
ExecutablePrintMode | 実行可能印刷方式 | Long | － | － | △ | － | － | － | － | － | － | －
FileOutputDestination | PDF形式ファイルの出力先マシン | Long | － | － | － | － | － | △ | － | － | － | －
FirstPageNumber | ページ番号の初期値 | Long | △ | △ | △ | △ | － | △ | △ | － | － | －
GroupName | 帳票振り分け定義の振り分けグループ名 | String | △ | － | △ | － | － | － | － | － | － | －
InitPageNumber | ページ番号の開始番号の初期化 | Boolean | △ | △ | △ | △ | － | △ | △ | － | － | －
JobKeyCategory | スプールデータの検索キーの分類 | String配列 | － | － | △ | － | － | － | － | － | － | －
JobKeyData | スプールデータの検索キーの値 | String配列 | － | － | △ | － | － | － | － | － | － | －
MaxPrintCount | スプールデータの上限印刷回数 | Long | － | － | △ | － | － | － | － | － | － | －
MergeEPFFileName | 統合対象EPF形式ファイル名 | String配列 | － | － | － | － | － | － | － | ○ | － | －
MergeEPFFilePath | 統合対象EPF形式ファイルのパス | String | － | － | － | － | － | － | － | △ | － | －
MultiFormInfoDefFileName | 複数様式情報定義ファイル名 | String | △ | △ | △ | △ | － | △ | △ | － | △ | －
MultiFormInfoDefFilePath | 複数様式情報定義ファイルのパス | String | △ | △ | △ | △ | － | △ | △ | － | △ | －
MultiReportSetFileName | 帳票セット指定ファイル名 | String | △ | △ | △ | △ | － | △ | △ | － | △ | －
MultiReportSetFilePath | 帳票セット指定ファイルのパス | String | △ | △ | △ | △ | － | △ | △ | － | △ | －
PageNumberFormat | ページ番号のフォーマット | String | △ | △ | △ | △ | － | △ | △ | － | － | －
PageNumberLocation | 余白へのページ番号の印刷位置 | Long | △ | △ | △ | △ | － | △ | △ | － | － | －
PaperOrientation | 用紙の向き | Long | △ | △ | △ | △ | － | － | △ | △ | － | －
PDFFileName | 出力PDF形式ファイル名 | String | － | － | － | － | － | ○※2 | － | － | － | －
PDFFilePath | 出力PDF形式ファイルのパス | String | － | － | － | － | － | △ | － | － | － | －
PMServerAddress | 帳票サーバのIPアドレス | String | △ | △ | △ | △ | △ | △ | △ | △ | △ | △
PMServerPort | 帳票サーバのポート番号 | Long | △ | △ | △ | △ | △ | △ | △ | △ | △ | △
PrintCopies | 印刷部数 | Long | △ | △ | △ | △ | － | － | △ | △ | － | －
PrintDateFileName | 印刷日時出力定義ファイル名 | String | △ | △ | △ | － | － | － | △ | － | － | －
PrintDateFilePath | 印刷日時出力定義ファイルのパス | String | △ | △ | △ | － | － | － | △ | － | － | －
PrintEndPage | 印刷終了ページ | Long | △ | △ | △ | △ | － | △ | △ | － | － | △
PrinterClassName | プリンタクラス名 | String | △ | △ | △ | △ | － | － | △ | △ | － | －
PrinterSelectMode | プリンタ指定方法 | Long | △ | － | △ | △※3 | － | － | － | － | － | －
PrintHoldMode | 蓄積後に続けて印刷するかどうか | Long | － | － | △ | － | － | － | － | － | － | －
PrintKind | スプールサーバ印刷方式の印刷モード | Long | △ | － | － | － | － | － | － | － | － | －
PrintMode | 印刷メソッド（PrintPMReportメソッド）の印刷方式 | Long | △ | △ | △ | △ | △ | － | － | － | － | －
PrintPageNumber | 余白へのページ番号印刷 | Boolean | △ | △ | △ | △ | － | △ | △ | － | － | －
PrintStartPage | 印刷開始ページ | Long | △ | △ | △ | △ | － | △ | △ | － | － | △
PSEnvFileName | EUR Server Serviceの環境設定ファイル（EURPS_ENV）名 | String | △ | △ | △ | △ | － | △ | △ | － | △ | △
PSEnvFilePath | EUR Server Serviceの環境設定ファイル（EURPS_ENV）のパス | String | △ | △ | △ | △ | － | △ | △ | － | △ | △
ReplaceItemCntlFileName | 置き換え表管理情報ファイル名 | String | △ | △ | △ | △ | － | △ | △ | － | △ | △
ReplaceItemCntlFilePath | 置き換え表管理情報ファイルのパス | String | △ | △ | △ | △ | － | △ | △ | － | △ | △
ReportAddressKeyCategory | スプールデータの宛先キーの分類 | String | － | － | △ | － | － | － | － | － | － | －
ReportAddressKeyData | スプールデータの宛先キーの値 | String | － | － | △ | － | － | － | － | － | － | －
ReportFileName | 帳票ファイル名 | String String配列 | ○※4 | ○※4 | ○※4 | ○※4 | － | ○※4 | ○※4 | － | ○※4 | ○※4
ReportFilePath | 帳票ファイルのパス | String | △ | △ | △ | △ | － | △ | △ | － | △ | △
ScriptCntlFileName | Acrobat JavaScript定義ファイル名 | String | － | － | － | － | － | △ | － | － | － | －
ScriptCntlFilePath | Acrobat JavaScript定義ファイルのパス | String | － | － | － | － | － | △ | － | － | － | －
ServerAddress | スプールサーバのIPアドレス | String | △ | － | △ | － | － | － | － | － | － | －
ServerPrinterName | サーバプリンタ名 | String | △ | － | △ | △ | － | － | － | － | － | －
ServerSelectMode | スプールサーバ指定方法 | Long | △ | － | △ | － | － | － | － | － | － | －
ServerTrayName | サーバプリンタのトレイ名 | String | △ | － | △ | △ | － | － | － | － | － | －
SortPrint | 印刷部数の単位 | Long | △ | △ | △ | △ | － | － | △ | △ | － | －
SplitFileName | 分割/仕分け定義ファイル名 | String | － | － | △ | － | － | － | － | － | － | －
SplitFilePath | 分割/仕分け定義ファイルのパス | String | － | － | △ | － | － | － | － | － | － | －
SplitMode | 分割/仕分けの実行 | Long | － | － | △ | － | － | － | － | － | － | －
SpoolFileName | スプールデータに格納するファイルのファイル名 | String | － | － | △ | － | － | － | － | － | － | －
SpoolLimit | スプールデータの蓄積期限日 | String | － | － | △ | － | － | － | － | － | － | －
SpoolTitle | スプールタイトル | String | △ | △ | △ | △ | － | － | △ | △ | △ | －
UserDataFileName | ユーザ定義データファイル名または可変記号値定義ファイル名 | String String配列 | △ | △ | △ | △ | － | △ | △ | － | △ | △
UserDataFilePath | ユーザ定義データファイルまたは可変記号値定義ファイルのパス | String | △ | △ | △ | △ | － | △ | △ | － | △ | △
ViewerPreferenceFileName | ビューアプレファレンス定義ファイル名 | String | － | － | － | － | － | △ | － | － | － | －
ViewerPreferenceFilePath | ビューアプレファレンス定義ファイルのパス | String | － | － | － | － | － | △ | － | － | － | －
XLSXFileName | 出力Excel形式ファイル名 | String | － | － | － | － | － | － | － | － | － | ○
XLSXFilePath | 出力Excel形式ファイルのパス | String | － | － | － | － | － | － | － | － | － | △
（凡例）
○：必ず指定します。
△：指定を省略できます。
－：指定できません。
注※1
UNIX／Linux環境では指定できません。
注※2
PDF仕分け定義ファイル名（DistributeFileNameプロパティ）を指定している場合は，指定を省略できます。
注※3
指定できるプリンタ印刷方式は，「プリンタクラス名指定」または「OS上のプリンタ名指定」です。
注※4
帳票セット指定ファイル名（MultiReportSetFileNameプロパティ）を指定している場合は，指定を省略できます。

注意
EUR Print Serviceと連携して使用するプロパティでエラーが発生した場合は，次のエラーメッセージが出力されます。メッセージが表示されたときは，EUR Print Serviceのイベントログ，またはeurpsログを参照してください。
メッセージID | メッセージ
KEEY221-E | 印刷処理でエラーが発生しました。（337）
KEEY223-E | PDF形式ファイル出力処理でエラーが発生しました。（337）
KEEY225-E | EPF形式ファイル出力処理でエラーが発生しました。（337）
KEEY243-E | EUR形式ファイル出力処理でエラーが発生しました。（337）
KEEY263-E | XLSX形式ファイル出力処理でエラーが発生しました。（337）


プロパティ一覧（情報取得メソッド）

6.2.3　プロパティ一覧（情報取得メソッド）

ActiveX起動部品が提供するプロパティのうち，情報取得メソッドで使用するプロパティを表6-5に示します。表6-5では，情報取得メソッドを表6-4のように省略して表記します。

表6-4　情報取得メソッドの略称

略称 | 情報取得メソッド
GEDL | GetDestinationList（出力先一覧の取得）
GEPC | GetPMPrinterClassList（帳票サーバのプリンタクラス一覧の取得）
GEPP | GetPMPrinterList（帳票サーバのプリンタ一覧の取得）
GEPT | GetPMTrayList（帳票サーバのトレイ一覧の取得）
GECL | GetPrinterClassList（プリンタクラス一覧の取得）
GEPL | GetPrinterList（プリンタ一覧の取得）
GETL | GetTrayList（トレイ一覧の取得）

表6-5　ActiveX起動部品が提供するプロパティ一覧（情報取得メソッド）

プロパティ | 設定内容 | データ型 | 情報取得メソッド
 |  |  | GEDL | GEPC | GEPP | GEPT | GECL | GEPL | GETL
DestinationName | 出力先名 | String | － | － | － | － | △ | △ | △
PMServerAddress | 帳票サーバのIPアドレス | String | △ | △ | △ | △ | △ | △ | △
PMServerPort | 帳票サーバのポート番号 | Long | △ | △ | △ | △ | △ | △ | △
ServerPrinterName | サーバのプリンタ名 | String | － | － | － | ○ | － | － | ○
（凡例）
○：必ず指定します。
△：指定を省略できます。
－：指定できません。


指定値に使用できない文字について

6.2.4　指定値に使用できない文字について

オプションの指定値には，制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」は使用できません。これらの文字を指定した場合，帳票管理GUI，［EUR Server Service 構成定義］ダイアログ，［EUR Spool Service 構成定義］ダイアログ，および［EUR Client 構成定義］ダイアログを操作できないことがあります。


ActiveX起動部品のメソッド仕様

6.3　ActiveX起動部品のメソッド仕様

ActiveX起動部品が提供するメソッドの詳細を説明します。

＜この節の構成＞
GetDestinationListメソッド
GetJobIDメソッド
GetJobIDListメソッド
GetPMPrinterClassListメソッド
GetPMPrinterListメソッド
GetPMTrayListメソッド
GetPreviewAXClassIDメソッド
GetPreviewAXVersionメソッド
GetPrintAXClassIDメソッド
GetPrintAXVersionメソッド
GetPrinterClassListメソッド
GetPrinterListメソッド
GetTrayListメソッド
OutputEPFReportメソッド
OutputEURReportメソッド
OutputMergeEPFReportメソッド
OutputPDFReportメソッド
OutputXLSXReportメソッド
PrintPMReportメソッド


GetDestinationListメソッド

GetDestinationListメソッド

出力先として登録されているスプールサーバの一覧を取得します。

形式

GetDestinationList()

パラメタ

なし

解説

GetDestinationListメソッドは，EUR Server Serviceに登録された出力先の一覧を取得します。出力先の一覧は，出力先定義ファイルから取得します。取得できる情報は，定義された出力先の情報です。スプールサーバの稼働状況は取得できません。

メソッド実行時にエラーが発生した場合，Err.Numberプロパティに終了コード，Err.Descriptionプロパティにメッセージが設定されます。

戻り値

出力先の一覧を次に示す形式で返します。

出力先名1,IPアドレス1,説明1
出力先名2,IPアドレス2,説明2
              :

データ型

Stringの2次元配列

呼び出し例

GetDestinationListメソッドの呼び出し例を次に示します。

'GetDestinationList実行
Private Sub SUB_GetDestinationList()

    Dim objEURPM, wk_Return
    Dim iLower, iUpper, I
    Dim jLower, jUpper, J
    Dim sEntry  As String

    Set objEURPM = CreateObject("EURPM.Exec")

    Me.Refresh

    Err.Clear
    On Error Resume Next
    wk_Return = objEURPM.GetDestinationList
    List5.AddItem "Err.Number=(" & Err.Number & ")"
    List5.AddItem "Err.Description=(" & Err.Description & ")"

    If Err.Number = 0 Then
        List5.AddItem ""
        List5.AddItem "★★★★★ 結果出力ココカラ ★★★★★"
        iLower = LBound(wk_Return, 1)
        iUpper = UBound(wk_Return, 1)
        jLower = LBound(wk_Return, 2)
        jUpper = UBound(wk_Return, 2)
        For I = iLower To iUpper
            sEntry = ""
            For J = jLower To jUpper
                If J > 0 Then
                    sEntry = sEntry + ","
                End If
                sEntry = sEntry + wk_Return(I, J)
            Next
            List5.AddItem sEntry
        Next
        ''Label51.Caption = List5.ListCount
        List5.AddItem "★★★★★ 結果出力ココマデ ★★★★★"
    End If

    Set objEURPM = Nothing

End Sub


GetJobIDメソッド

GetJobIDメソッド

GetJobIDメソッドを実行する直前に蓄積したスプールデータのジョブIDを取得します。

帳票を分割または仕分けして蓄積した場合など，直前に蓄積したスプールデータが複数あるときは，最初に蓄積したスプールデータのジョブIDを取得します。

形式

GetJobID()

パラメタ

なし

解説

PrintPMReportメソッドで印刷方式が蓄積（PrintMode=2）の場合で，かつ正常または警告でメソッドが戻ったときだけスプールデータのジョブIDを取得できます。取得した情報は，ActiveX起動部品がメモリから解放されるか，またはPrintPMReportメソッドが次に呼び出されるまで有効になります。

メソッド実行時にエラーが発生した場合，Err.Numberプロパティに終了コード，Err.Descriptionプロパティにメッセージが設定されます。

戻り値

直前に蓄積したスプールデータのジョブID

データ型

String


GetJobIDListメソッド

GetJobIDListメソッド

GetJobIDListメソッドを実行する直前に蓄積したスプールデータのジョブIDの一覧を取得します。直前に蓄積したスプールデータが複数あるときは，すべてのスプールデータのジョブIDを取得します。

形式

GetJobIDList()

パラメタ

なし

解説

PrintPMReportメソッドで印刷方式が蓄積（PrintMode=2）の場合で，かつ正常または警告でメソッドが戻ったときだけスプールデータのジョブIDの一覧を取得できます。取得した情報は，ActiveX起動部品がメモリから解放されるか，またはPrintPMReportメソッドが次に呼び出されるまで有効になります。

メソッド実行時にエラーが発生した場合，Err.Numberプロパティに終了コード，Err.Descriptionプロパティにメッセージが設定されます。

また，蓄積を中断する警告が発生した場合，戻り値の配列の最後に「Error」が設定されます。

戻り値

直前に蓄積したスプールデータのジョブIDの一覧を，次に示す形式で返します。

＜正常時＞
ジョブID1
ジョブID2
   :
ジョブIDn

＜警告（KEEY387-W）発生時＞
ジョブID1
ジョブID2
Error

データ型

String配列


GetPMPrinterClassListメソッド

GetPMPrinterClassListメソッド

帳票サーバのプリンタクラスの一覧を取得します。

形式

GetPMPrinterClassList()

パラメタ

なし

解説

GetPMPrinterClassListメソッドは，指定した帳票サーバのEUR Server Serviceに登録されたプリンタクラスの一覧を取得します。

取得できる情報は，定義されたプリンタクラス情報です。帳票サーバでのプリンタの稼働状況は取得できません。

メソッド実行時にエラーが発生した場合は，Err.Numberプロパティに終了コード，Err.Descriptionプロパティにメッセージが設定されます。

戻り値

帳票サーバのプリンタクラスの一覧を，次に示す形式で返します。

＜２次元配列イメージ：ｎ行４列＞
プリンタクラス名1,OS上のプリンタ名1,OS上のプリンタのトレイ名1,説明1
プリンタクラス名2,OS上のプリンタ名2,OS上のプリンタのトレイ名2,説明2
                          :
プリンタクラス名n,OS上のプリンタ名n,OS上のプリンタのトレイ名n,説明ｎ

データ型

String の２次元配列

呼び出し例

GetPMPrinterClassListメソッドの呼び出し例を次に示します。

'GetPMPrinterClassList実行
Private Sub SUB_ GetPMPrinterClassList ()

    Dim objEURPM, wk_Return
    Dim iLower, iUpper, I
    Dim jLower, jUpper, J
    Dim sEntry  As String

    Set objEURPM = CreateObject("EURPM.Exec")

    Me.Refresh

    Err.Clear
    On Error Resume Next
    wk_Return = objEURPM.GetPMPrinterClassList()
    List5.AddItem "Err.Number=(" & Err.Number & ")"
    List5.AddItem "Err.Description=(" & Err.Description & ")"

    If Err.Number = 0 Then
        List5.AddItem ""
        List5.AddItem "★★★★★ 結果出力ココカラ ★★★★★"
        iLower = LBound(wk_Return, 1)
        iUpper = UBound(wk_Return, 1)
        jLower = LBound(wk_Return, 2)
        jUpper = UBound(wk_Return, 2)
        For I = iLower To iUpper
            sEntry = ""
            For J = jLower To jUpper
                If J > 0 Then
                    sEntry = sEntry + ","
                End If
                sEntry = sEntry + wk_Return(I, J)
            Next
            List5.AddItem sEntry
        Next
        List5.AddItem "★★★★★ 結果出力ココマデ ★★★★★"
    End If

    Set objEURPM = Nothing

End Sub


GetPMPrinterListメソッド

GetPMPrinterListメソッド

帳票サーバのOSに登録されているプリンタの一覧を取得します。

形式

GetPMPrinterList()

パラメタ

なし

解説

GetPMPrinterListメソッドは，指定した帳票サーバのOS上のプリンタの一覧を取得します。EUR Server Serviceが稼働中でない場合，エラーとなります。

帳票サーバがUNIX／Linux環境の場合は使用できません。

メソッド実行時にエラーが発生した場合は，Err.Numberプロパティに終了コード，Err.Descriptionプロパティにメッセージが設定されます。

戻り値

OS上のプリンタ一覧を，次に示す形式で返します。

＜配列イメージ＞
OS上のプリンタ名1
OS上のプリンタ名2
    ：
OS上のプリンタ名n

データ型

String 配列

呼び出し例

GetPMPrinterListメソッドの呼び出し例を次に示します。

'GetPMPrinterList実行
Private Sub SUB_ GetPMPrinterList()

    Dim objEURPM, wk_Return
    Dim iLower, iUpper, I
    Dim sEntry  As String

    Set objEURPM = CreateObject("EURPM.Exec")

    Me.Refresh

    Err.Clear
    On Error Resume Next
    wk_Return = objEURPM.GetPMPrinterList()
    List5.AddItem "Err.Number=(" & Err.Number & ")"
    List5.AddItem "Err.Description=(" & Err.Description & ")"

    If Err.Number = 0 Then
        List5.AddItem ""
        List5.AddItem "★★★★★ 結果出力ココカラ ★★★★★"
        iLower = LBound(wk_Return, 1)
        iUpper = UBound(wk_Return, 1)
        For I = iLower To iUpper
            List5.AddItem wk_Return(I)
        Next
        List5.AddItem "★★★★★ 結果出力ココマデ ★★★★★"
    End If

    Set objEURPM = Nothing

End Sub


GetPMTrayListメソッド

GetPMTrayListメソッド

帳票サーバのOSに登録されているプリンタを指定し，そのプリンタのトレイ一覧を取得します。

形式

GetPMTrayList(String PrinterName)

パラメタ

PrinterName

OS上のプリンタ名

解説

GetPMTrayListメソッドは，帳票サーバのOSに登録されているプリンタのトレイ一覧を取得します。EUR Server Serviceが稼働中でない場合，エラーとなります。

帳票サーバがUNIX／Linux環境の場合は使用できません。

メソッド実行時にエラーが発生した場合は，Err.Numberプロパティに終了コード，Err.Descriptionプロパティにメッセージが設定されます。

戻り値

帳票サーバ上の指定したプリンタのトレイ一覧を，次に示す形式で返します。

＜配列イメージ＞
OS上のプリンタのトレイ名1
OS上のプリンタのトレイ名2
    ：
OS上のプリンタのトレイ名n

データ型

String 配列

呼び出し例

GetPMTrayListメソッドの呼び出し例を次に示します。

' GetPMTrayList実行
Private Sub SUB_ GetPMTrayList()

    Dim objEURPM, wk_Return
    Dim iLower, iUpper, I
    Dim sEntry  As String

    Set objEURPM = CreateObject("EURPM.Exec")

    Me.Refresh

    Err.Clear
    On Error Resume Next
    wk_Return = objEURPM. GetPMTrayList("PRINTER1")
    List5.AddItem "Err.Number=(" & Err.Number & ")"
    List5.AddItem "Err.Description=(" & Err.Description & ")"

    If Err.Number = 0 Then
        List5.AddItem ""
        List5.AddItem "★★★★★ 結果出力ココカラ ★★★★★"
        iLower = LBound(wk_Return, 1)
        iUpper = UBound(wk_Return, 1)
        For I = iLower To iUpper
            List5.AddItem wk_Return(I)
        Next
        List5.AddItem "★★★★★ 結果出力ココマデ ★★★★★"
    End If

    Set objEURPM = Nothing

End Sub


GetPreviewAXClassIDメソッド

GetPreviewAXClassIDメソッド

EUR Web Plug-In（プレビュー用）のクラスIDを取得します。

形式

GetPreviewAXClassID()

パラメタ

なし

解説

このメソッドを使用する場合は，EUR Server - Adapterが稼働するマシンにEUR Web Plug-In情報ファイル（EURPMPreViewAX.inf）を配置する必要があります。EUR Web Plug-In情報ファイルの配置方法については，マニュアル「EUR システム構築ガイド」を参照してください。

クラスIDは，次のように決定されます。

  1. EUR Server - Adapterに配置されたEUR Web Plug-In情報ファイル（EURPMPreViewAX.inf）に指定されているクラスIDを取得します。
  2. 1.が取得できなかった場合は，警告メッセージ（KEEY276-W）をログに出力し，D07DA8D2-3459-488E-860E-DD47A71C39D2を返します。

メソッド実行時にエラーが発生した場合，Err.Numberプロパティに終了コード，Err.Descriptionプロパティにメッセージが設定されます。

戻り値

EURPMPreViewAX9.ocxのクラスID

データ型

String


GetPreviewAXVersionメソッド

GetPreviewAXVersionメソッド

EUR Web Plug-In（プレビュー用）のバージョンを取得します。

形式

GetPreviewAXVersion()

パラメタ

なし

解説

このメソッドを使用する場合は，EUR Server - Adapterが稼働するマシンにEUR Web Plug-In情報ファイル（EURPMPreViewAX.inf）を配置する必要があります。EUR Web Plug-In情報ファイルの配置方法については，マニュアル「EUR システム構築ガイド」を参照してください。

バージョンは，次のように決定されます。

  1. EUR Server - Adapterに配置されたEUR Web Plug-In情報ファイル（EURPMPreViewAX.inf）に指定されているバージョン値を取得します。
  2. 1.が取得できなかった場合は，警告メッセージ（KEEY276-W）をログに出力し，99,99,99,99を返します。

メソッド実行時にエラーが発生した場合，Err.Numberプロパティに終了コード，Err.Descriptionプロパティにメッセージが設定されます。

戻り値

EURPMPreViewAX9.ocxのバージョン値

データ型

String


GetPrintAXClassIDメソッド

GetPrintAXClassIDメソッド

EUR Web Plug-In（印刷用）のクラスIDを取得します。

形式

GetPrintAXClassID()

パラメタ

なし

解説

このメソッドを使用する場合は，EUR Server - Adapterが稼働するマシンにEUR Web Plug-In情報ファイル（EURPMPrintAX.inf）を配置する必要があります。EUR Web Plug-In情報ファイルの配置方法については，マニュアル「EUR システム構築ガイド」を参照してください。

クラスIDは，次のように決定されます。

  1. EUR Server - Adapterに配置されたEUR Web Plug-In情報ファイル（EURPMPrintAX.inf）に指定されているクラスIDを取得します。
  2. 1.が取得できなかった場合は，警告メッセージ（KEEY276-W）をログに出力し，368EE1C4-5A52-4C2E-A4C0-27C46B946A2Cを返します。

メソッド実行時にエラーが発生した場合，Err.Numberプロパティに終了コード，Err.Descriptionプロパティにメッセージが設定されます。

戻り値

EURPMPrintAX9.ocxのクラスID

データ型

String


GetPrintAXVersionメソッド

GetPrintAXVersionメソッド

EUR Web Plug-In（印刷用）のバージョンを取得します。

形式

GetPrintAXVersion()

パラメタ

なし

解説

このメソッドを使用する場合は，EUR Server - Adapterが稼働するマシンにEUR Web Plug-In情報ファイル（EURPMPrintAX.inf）を配置する必要があります。EUR Web Plug-In情報ファイルの配置方法については，マニュアル「EUR システム構築ガイド」を参照してください。

バージョンは，次のように決定されます。

  1. EUR Server - Adapterに配置されたEUR Web Plug-In情報ファイル（EURPMPrintAX.inf）に指定されているバージョン値を取得します。
  2. 1.が取得できなかった場合は，警告メッセージ（KEEY276-W）をログに出力し，99,99,99,99を返します。

メソッド実行時にエラーが発生した場合，Err.Numberプロパティに終了コード，Err.Descriptionプロパティにメッセージが設定されます。

戻り値

EURPMPrintAX9.ocxのバージョン値

データ型

String


GetPrinterClassListメソッド

GetPrinterClassListメソッド

指定した出力先（スプールサーバ）に登録されているプリンタクラスの一覧を取得します。

形式

GetPrinterClassList(String DestinationName)

パラメタ

DestinationName

出力先名

解説

GetPrinterClassListメソッドは，指定した出力先のEUR Server - Spool Serviceに登録されたプリンタクラスの一覧を取得します。出力先を指定していない場合は，デフォルトの出力先として登録されたスプールサーバのプリンタクラスの一覧を取得します。EUR Server - Spool Serviceが稼働中でない場合，エラーとなります。

取得できる情報は，定義された拠点プリンタクラス情報です。スプールサーバでのプリンタの稼働状況は取得できません。

メソッド実行時にエラーが発生した場合，Err.Numberプロパティに終了コード，Err.Descriptionプロパティにメッセージが設定されます。

UNIX／Linux環境の場合，拠点プリンタクラス一覧の取得はサポートしていません。UNIX／Linux環境のEUR Server - Spool Serviceに対して，拠点プリンタクラス一覧の取得を実行した場合はエラーとなります。

戻り値

プリンタクラスの一覧を次に示す形式で返します。

プリンタクラス名1,OS上のプリンタ名1,OS上のプリンタのトレイ名1,説明1
プリンタクラス名2,OS上のプリンタ名2,OS上のプリンタのトレイ名2,説明2
                          :
プリンタクラス名n,OS上のプリンタ名n,OS上のプリンタのトレイ名n,説明n

データ型

Stringの2次元配列

呼び出し例

GetPrinterClassListメソッドの呼び出し例を次に示します。

'GetPrinterClassList実行
Private Sub SUB_GetPrinterClassList()

    Dim objEURPM, wk_Return
    Dim iLower, iUpper, I
    Dim jLower, jUpper, J
    Dim sEntry  As String

    Set objEURPM = CreateObject("EURPM.Exec")

    Me.Refresh

    Err.Clear
    On Error Resume Next
    wk_Return = objEURPM.GetPrinterClassList("SERVER1")
    List5.AddItem "Err.Number=(" & Err.Number & ")"
    List5.AddItem "Err.Description=(" & Err.Description & ")"

    If Err.Number = 0 Then
        List5.AddItem ""
        List5.AddItem "★★★★★ 結果出力ココカラ ★★★★★"
        iLower = LBound(wk_Return, 1)
        iUpper = UBound(wk_Return, 1)
        jLower = LBound(wk_Return, 2)
        jUpper = UBound(wk_Return, 2)
        For I = iLower To iUpper
            sEntry = ""
            For J = jLower To jUpper
                If J > 0 Then
                    sEntry = sEntry + ","
                End If
                sEntry = sEntry + wk_Return(I, J)
            Next
            List5.AddItem sEntry
        Next
        List5.AddItem "★★★★★ 結果出力ココマデ ★★★★★"
    End If

    Set objEURPM = Nothing

End Sub


GetPrinterListメソッド

GetPrinterListメソッド

指定した出力先（スプールサーバ）のOSに登録されているプリンタの一覧を取得します。

形式

GetPrinterList(String DestinationName)

パラメタ

DestinationName

出力先名

解説

GetPrinterListメソッドは，出力先のスプールサーバのOSに登録されているプリンタの一覧を取得します。出力先を指定していない場合は，デフォルトの出力先として登録されたスプールサーバのOS上のプリンタ一覧を取得します。EUR Server - Spool Serviceが稼働中でない場合，エラーとなります。

取得できる情報は，定義されたプリンタ情報です。スプールサーバでのプリンタの稼働状況は取得できません。

メソッド実行時にエラーが発生した場合，Err.Numberプロパティに終了コード，Err.Descriptionプロパティにメッセージが設定されます。

UNIX／Linux環境の場合，プリンタ一覧の取得はサポートしていません。UNIX／Linux環境のEUR Server - Spool Serviceに対して，プリンタ一覧の取得を実行した場合はエラーとなります。

戻り値

OS上のプリンタの一覧を次に示す形式で返します。

OS上のプリンタ名1
OS上のプリンタ名2
         :
OS上のプリンタ名n

データ型

String配列

呼び出し例

'GetPrinterList実行
Private Sub SUB_GetPrinterList()

    Dim objEURPM, wk_Return
    Dim iLower, iUpper, I
    Dim sEntry  As String

    Set objEURPM = CreateObject("EURPM.Exec")

    Me.Refresh

    Err.Clear
    On Error Resume Next
    wk_Return = objEURPM.GetPrinterList("SERVER1")
    List5.AddItem "Err.Number=(" & Err.Number & ")"
    List5.AddItem "Err.Description=(" & Err.Description & ")"

    If Err.Number = 0 Then
        List5.AddItem ""
        List5.AddItem "★★★★★ 結果出力ココカラ ★★★★★"
        iLower = LBound(wk_Return, 1)
        iUpper = UBound(wk_Return, 1)
        For I = iLower To iUpper
            List5.AddItem wk_Return(I)
        Next
        List5.AddItem "★★★★★ 結果出力ココマデ ★★★★★"
    End If

    Set objEURPM = Nothing

End Sub


GetTrayListメソッド

GetTrayListメソッド

出力先（スプールサーバ）とOS上のプリンタを指定し，そのプリンタのトレイ一覧を取得します。

形式

GetTrayList(String DestinationName, String PrinterName)

パラメタ

DestinationName

出力先名

PrinterName

OS上のプリンタ名

解説

GetTrayListメソッドは，出力先のスプールサーバのOSに登録されているプリンタのトレイ一覧を取得します。出力先を指定していない場合は，デフォルトの出力先として登録されたスプールサーバのOS上のプリンタのトレイ一覧を取得します。EUR Server - Spool Serviceが稼働中でない場合，エラーとなります。

取得できる情報は，定義されたプリンタのトレイ情報です。スプールサーバでのプリンタのトレイ稼働状況は取得できません。

メソッド実行時にエラーが発生した場合，Err.Numberプロパティに終了コード，Err.Descriptionプロパティにメッセージが設定されます。

UNIX／Linux環境の場合，トレイ一覧の取得はサポートしていません。UNIX／Linux環境のEUR Server - Spool Serviceに対して，トレイ一覧の取得を実行した場合はエラーとなります。

戻り値

OS上のプリンタのトレイ一覧を次に示す形式で返します。

OS上のプリンタのトレイ名1
OS上のプリンタのトレイ名2
         :
OS上のプリンタのトレイ名n

データ型

String配列

呼び出し例

'GetTrayList実行
Private Sub SUB_GetTrayList()

    Dim objEURPM, wk_Return
    Dim iLower, iUpper, I
    Dim sEntry  As String

    Set objEURPM = CreateObject("EURPM.Exec")

    Me.Refresh

    Err.Clear
    On Error Resume Next
    wk_Return = objEURPM.GetPrinterList("SERVER1", "PRINTER1")
    List5.AddItem "Err.Number=(" & Err.Number & ")"
    List5.AddItem "Err.Description=(" & Err.Description & ")"

    If Err.Number = 0 Then
        List5.AddItem ""
        List5.AddItem "★★★★★ 結果出力ココカラ ★★★★★"
        iLower = LBound(wk_Return, 1)
        iUpper = UBound(wk_Return, 1)
        For I = iLower To iUpper
            List5.AddItem wk_Return(I)
        Next
        List5.AddItem "★★★★★ 結果出力ココマデ ★★★★★"
    End If

    Set objEURPM = Nothing

End Sub


OutputEPFReportメソッド

OutputEPFReportメソッド

プロパティで指定した帳票名およびデータファイルに従って，EPF形式ファイルを出力します。指定したファイルがすでにある場合は，上書きされます。

形式

OutputEPFReport()

パラメタ

なし

解説

OutputEPFReportメソッドは，EUR Server - Adapterが稼働するマシンにEPF形式ファイルを出力します。出力するEPF形式ファイルは，EPFFilePathプロパティおよびEPFFileNameプロパティで指定します。

OutputEPFReportメソッドが終了すると，それまでに設定したプロパティはすべてリセットされます。

メソッド実行時にエラーが発生した場合，Err.Numberプロパティに終了コード，Err.Descriptionプロパティにメッセージが設定されます。

戻り値

なし

データ型

Empty


OutputEURReportメソッド

OutputEURReportメソッド

プロパティで指定した帳票名およびデータファイルに従って，EUR形式ファイルを出力します。指定したファイルがすでにある場合は，上書きされます。

形式

OutputEURReport()

パラメタ

なし

解説

OutputEURReportメソッドは，EUR Server - Adapterが稼働するマシンにEUR形式ファイルを出力します。出力するEUR形式ファイルは，EURFilePathプロパティおよびEURFileNameプロパティで指定します。

OutputEURReportメソッドが終了すると，それまでに設定したプロパティはすべてリセットされます。

メソッド実行時にエラーが発生した場合，Err.Numberプロパティに終了コード，Err.Descriptionプロパティにメッセージが設定されます。

戻り値

なし

データ型

Empty


OutputMergeEPFReportメソッド

OutputMergeEPFReportメソッド

複数のEPF形式ファイルを一つのEPF形式ファイルに統合して出力します。出力先に指定したEPF形式ファイルがすでにある場合は，上書きされます。

形式

OutputMergeEPFReport()

パラメタ

なし

解説

OutputMergeEPFReportメソッドは，EUR Server - Adapterが稼働するマシンに複数のEPF形式ファイルを統合して出力します。統合対象のEPF形式ファイルは，MergeEPFFilePathプロパティおよびMergeEPFFileNameプロパティで指定します。また，出力するEPF形式ファイルは，EPFFilePathプロパティおよびEPFFileNameプロパティで指定します。

OutputMergeEPFReportメソッドが終了すると，それまでに設定したプロパティはすべてリセットされます。

メソッド実行時にエラーが発生した場合，Err.Numberプロパティに終了コード，Err.Descriptionプロパティにメッセージが設定されます。

戻り値

なし

データ型

Empty


OutputPDFReportメソッド

OutputPDFReportメソッド

プロパティで指定した帳票名およびデータファイルに従って，PDF形式ファイルを出力します。指定したファイルがすでにある場合は，上書きされます。

形式

OutputPDFReport()

パラメタ

なし

解説

OutputPDFReportメソッドは，EUR Server Serviceが稼働するマシンまたはEUR Server - Adapterが稼働するマシンにPDF形式ファイルを出力します。PDF形式ファイルの出力先は，FileOutputDestinationプロパティ，PDFFilePathプロパティ，およびPDFFileNameプロパティで指定します。

ただし，PDF仕分け定義ファイル（DistributeFileNameプロパティ）が指定されている場合は，PDF仕分け定義ファイルに記述されている出力先ファイル名に従って，EUR Server Serviceが稼働するマシンにPDF形式ファイルを出力します。PDF仕分け出力の場合，出力先のPDF形式ファイルがすでにある場合は上書きしないでエラーになります。

OutputPDFReportメソッドが終了すると，それまでに設定したプロパティはすべてリセットされます。

メソッド実行時にエラーが発生した場合，Err.Numberプロパティに終了コード，Err.Descriptionプロパティにメッセージが設定されます。

戻り値

なし

データ型

Empty


OutputXLSXReportメソッド

OutputXLSXReportメソッド

プロパティで指定した帳票名およびデータファイルに従って，Excel形式ファイルを出力します。指定したファイルがすでにある場合は，上書きされます。

形式

OutputXLSXReport()

パラメタ

なし

解説

OutputXLSXReportメソッドは，EUR Server - Adapterが稼働するマシンにExcel形式ファイルを出力します。出力するExcel形式ファイルは，XLSXFilePathプロパティおよびXLSXFileNameプロパティで指定します。

OutputXLSXReportメソッドが終了すると，それまでに設定したプロパティはすべてリセットされます。

メソッド実行時にエラーが発生した場合，Err.Numberプロパティに終了コード，Err.Descriptionプロパティにメッセージが設定されます。

戻り値

なし

データ型

Empty


PrintPMReportメソッド

PrintPMReportメソッド

帳票の印刷，またはEPF形式ファイルの蓄積をします。

形式

PrintPMReport()

パラメタ

なし

解説

PrintPMReportメソッドは，次の場合に呼び出し元に制御が戻ります。

  • スプールサーバでの印刷の場合
    スプールサーバ上のプリンタスプールへの出力が終了した時点
  • クライアントPCでの印刷の場合
    クライアントPCへの配信が完了した時点
  • 蓄積の場合
    蓄積先のサーバにEPF形式ファイルの蓄積が完了した時点
  • 帳票サーバ直接印刷の場合
    帳票サーバ上のプリンタスプールへの出力が完了した時点
  • クライアント配布印刷
    クライアントPCへの配信が完了した時点

PrintPMReportメソッドが終了すると，それまでに設定したプロパティはすべてリセットされます。

PrintPMReportメソッドで印刷方式が蓄積（PrintMode=2）の場合は，正常または警告でメソッドが戻ったときだけスプールデータに対応するジョブIDをGetJobIDメソッドで取得できます。取得した情報は，ActiveX起動部品がメモリから解放されるか，またはPrintPMReportメソッドが次に呼び出されるまで有効になります。

PrintPMReportメソッド実行時にエラーが発生した場合，Err.Numberプロパティに終了コード，Err.Descriptionプロパティにメッセージが設定されます。

UNIX／Linux環境の場合，スプールサーバでの印刷はサポートしていません。UNIX／Linux環境のEUR Server - Spool Serviceに対して，印刷を実行した場合はエラーとなります。

戻り値

なし

データ型

Empty


ActiveX起動部品のプロパティ仕様

6.4　ActiveX起動部品のプロパティ仕様

ActiveX起動部品が提供するプロパティの詳細を説明します。

＜この節の構成＞
BookmarkFileNameプロパティ
BookmarkFilePathプロパティ
ClientAddressプロパティ
ClientPrinterNameプロパティ
ClientTrayNameプロパティ
Cryptoプロパティ
CryptoFileNameプロパティ
CryptoFilePathプロパティ
DataFileNameプロパティ
DataFilePathプロパティ
DBInfoFileNameプロパティ
DBInfoFilePathプロパティ
DestinationNameプロパティ
DispPrintDlgプロパティ
DistributeFileNameプロパティ
DistributeFilePathプロパティ
DocBookmarkFileNameプロパティ
DocInfoFileNameプロパティ
DocInfoFilePathプロパティ
EnableGetプロパティ
EncryptionPasswordKeyプロパティ
EPFFileNameプロパティ
EPFFilePathプロパティ
EURFileNameプロパティ
EURFilePathプロパティ
ExecutablePrintModeプロパティ
FileOutputDestinationプロパティ
FirstPageNumberプロパティ
GroupNameプロパティ
InitPageNumberプロパティ
JobKeyCategoryプロパティ
JobKeyDataプロパティ
MaxPrintCountプロパティ
MergeEPFFileNameプロパティ
MergeEPFFilePathプロパティ
MultiFormInfoDefFileNameプロパティ
MultiFormInfoDefFilePathプロパティ
MultiReportSetFileNameプロパティ
MultiReportSetFilePathプロパティ
PageNumberFormatプロパティ
PageNumberLocationプロパティ
PaperOrientationプロパティ
PDFFileNameプロパティ
PDFFilePathプロパティ
PMServerAddressプロパティ
PMServerPortプロパティ
PrintCopiesプロパティ
PrintDateFileNameプロパティ
PrintDateFilePathプロパティ
PrintEndPageプロパティ
PrinterClassNameプロパティ
PrinterSelectModeプロパティ
PrintHoldModeプロパティ
PrintKindプロパティ
PrintModeプロパティ
PrintPageNumberプロパティ
PrintStartPageプロパティ
PSEnvFileNameプロパティ
PSEnvFilePathプロパティ
ReplaceItemCntlFileNameプロパティ
ReplaceItemCntlFilePathプロパティ
ReportAddressKeyCategoryプロパティ
ReportAddressKeyDataプロパティ
ReportFileNameプロパティ
ReportFilePathプロパティ
ScriptCntlFileNameプロパティ
ScriptCntlFilePathプロパティ
ServerAddressプロパティ
ServerPrinterNameプロパティ
ServerSelectModeプロパティ
ServerTrayNameプロパティ
SortPrintプロパティ
SplitFileNameプロパティ
SplitFilePathプロパティ
SplitModeプロパティ
SpoolFileNameプロパティ
SpoolLimitプロパティ
SpoolTitleプロパティ
UserDataFileNameプロパティ
UserDataFilePathプロパティ
ViewerPreferenceFileNameプロパティ
ViewerPreferenceFilePathプロパティ
XLSXFileNameプロパティ
XLSXFilePathプロパティ


BookmarkFileNameプロパティ

BookmarkFileNameプロパティ

しおり定義ファイル名を指定します。

解説

  • BookmarkFileNameプロパティには，ReportFileNameプロパティで指定した帳票ファイルに対応するしおり定義ファイルを指定します。指定するファイル名は，ReportFileNameプロパティで指定したファイル名と同じ数を指定してください。
  • しおり定義ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • BookmarkFileNameプロパティは，OutputPDFReportメソッドでPDF形式ファイルを出力する場合，指定が有効になります。OutputPDFReportメソッド以外の場合は，BookmarkFileNameプロパティを指定しても無視されます。
  • しおり定義ファイルは，EUR Server - Adapter稼働マシンに配置してください。

データ型

  • String（一つの帳票セットを指定する場合）
  • String配列（複数の帳票セットを指定する場合）

指定例

複数の帳票セットを指定する場合，一部の帳票に対してしおり定義ファイルの指定を省略したいときは，配列の要素に空文字を指定してください。

2番目の帳票のしおり定義ファイルの指定を省略する場合の例を次に示します。

' 帳票ファイル名を配列fmsに指定
fms(0)="Sample1.fms"
fms(1)="Sample2.fms"
fms(2)="Sample3.fms"
' しおり定義ファイル名を配列bokに指定
bok(0)="Book1.csv"
bok(1)=""
bok(2)="Book3.csv"


BookmarkFilePathプロパティ

BookmarkFilePathプロパティ

DocBookmarkFileNameプロパティで指定した文書しおり定義ファイルのパス，またはBookmarkFileNameプロパティで指定したしおり定義ファイルのパスを指定します。

解説

  • 指定されたファイルのパスは，DocBookmarkFileNameプロパティで指定する文書しおり定義ファイルと，BookmarkFileNameプロパティで指定するしおり定義ファイルのデフォルトの場所になります。
  • ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • BookmarkFilePathプロパティは，OutputPDFReportメソッドでPDF形式ファイルを出力する場合，指定が有効になります。OutputPDFReportメソッド以外の場合は，BookmarkFilePathプロパティを指定しても無視されます。

データ型

String


ClientAddressプロパティ

ClientAddressプロパティ

印刷を実行するクライアントPCのIPアドレス，または蓄積クライアント印刷実行を要求するクライアントPCのIPアドレスを指定します。

解説

  • 次に示す場合以外は，ClientAddressプロパティを指定しても無視されます。
    • PrintPMReportメソッドで印刷方式が蓄積（PrintMode=2）の場合，ClientAddressプロパティの指定は任意です。
    • PrintPMReportメソッドで印刷方式がスプールサーバ印刷方式（PrintMode=3）の場合は，ClientAddressプロパティを指定しても無視されます。
  • 印刷を実行するクライアントPCのIPアドレスを指定します。サーバアプリケーションから次のようなAPIを使用すると，Webクライアントの要求元を取得できます。指定方法などについては，各APIのアプリケーションサーバの仕様を確認してください。
    ASPの場合
    Request.ServerVariables("REMOTE_ADDR")
    JSPの場合
    request.getRemoteAddr()
  • ClientAddressプロパティを省略した場合は，デフォルト値（127.0.0.1）が仮定されます。

データ型

String


ClientPrinterNameプロパティ

ClientPrinterNameプロパティ

クライアントPCのプリンタ名をOS上のプリンタ名で指定します。

解説

  • クライアントPCのプリンタ名をOS上のプリンタ名で指定します。ClientPrinterNameプロパティを指定した場合，対話型印刷は使用できません。
  • プリンタ名を指定するときの注意
    プリンタ名は，次のことに注意して指定してください。
    • プリンタ名は，80バイト以内で指定してください。
    • プリンタ名には「"」および「,」を含めないでください。
  • ClientPrinterNameプロパティが指定されると，DispPrintDlgプロパティは強制的に「1（ダイアログを表示しません）」を仮定します。
  • ClientPrinterNameプロパティとPrinterClassNameプロパティでは，ClientPrinterNameプロパティの指定を優先します。
  • ClientPrinterNameプロパティは，PrintPMReportメソッドで印刷方式がクライアント印刷方式（PrintMode=1）の場合，およびPrintPMReportメソッドで印刷方式が蓄積（PrintMode=2）の場合に指定が有効になります。それ以外の場合は，ClientPrinterNameプロパティを指定しても無視されます。

データ型

String


ClientTrayNameプロパティ

ClientTrayNameプロパティ

クライアントプリンタのトレイ名を指定します。クライアントプリンタは，OS上のプリンタを指します。

解説

  • トレイ名を指定するときの注意
    トレイ名は，次のことに注意して指定してください。
    • トレイ名は，80バイト以内で指定してください。
    • トレイ名には「"」および「,」を含めないでください。
  • ClientTrayNameプロパティを指定する場合は，ClientPrinterNameプロパティを必ず指定してください。
    ClientTrayNameプロパティに指定したトレイ名が，ClientPrinterNameプロパティで指定したプリンタで使用できない場合は，ClientPrinterNameプロパティで指定したプリンタのデフォルトのトレイから給紙されます。
  • ClientTrayNameプロパティを指定しない場合は，ClientPrinterNameプロパティで指定したプリンタのデフォルトのトレイから給紙されます。
  • ClientTrayNameプロパティは，PrintPMReportメソッドで印刷方式がクライアント印刷方式（PrintMode=1）の場合，およびPrintPMReportメソッドで印刷方式が蓄積（PrintMode=2）の場合に指定が有効になります。それ以外の場合は，ClientTrayNameプロパティを指定しても無視されます。

データ型

String


Cryptoプロパティ

Cryptoプロパティ

PDF形式ファイルを暗号化して出力するかどうかを指定します。

解説

指定できる値を次に示します。

  • True：PDF形式ファイルを暗号化します。
  • False：PDF形式ファイルを暗号化しません。

Cryptoプロパティを省略した場合，Falseが仮定されます。

Cryptoプロパティは，OutputPDFReportメソッドでPDF形式ファイルを出力する場合，指定が有効になります。OutputPDFReportメソッド以外の場合は，Cryptoプロパティを指定しても無視されます。

データ型

Boolean


CryptoFileNameプロパティ

CryptoFileNameプロパティ

暗号化設定ファイル名を指定します。

解説

  • 暗号化設定ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • CryptoFileNameプロパティは，OutputPDFReportメソッドでPDF形式ファイルを出力する場合，指定が有効になります。OutputPDFReportメソッド以外の場合は，CryptoFileNameプロパティを指定しても無視されます。
  • 暗号化設定ファイルは，EUR Server - Adapter稼働マシンに配置してください。

データ型

String


CryptoFilePathプロパティ

CryptoFilePathプロパティ

CryptoFileNameプロパティで指定した暗号化設定ファイルのパスを指定します。

解説

  • 暗号化設定ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • CryptoFilePathプロパティは，OutputPDFReportメソッドでPDF形式ファイルを出力する場合，指定が有効になります。OutputPDFReportメソッド以外の場合は，CryptoFilePathプロパティを指定しても無視されます。

データ型

String


DataFileNameプロパティ

DataFileNameプロパティ

マッピングデータファイル名または可変記号値定義ファイル名を指定します。

解説

  • 指定するファイル名は，ReportFileNameプロパティで指定したファイル名と同じ数を指定してください。
  • ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • マッピングデータファイルは，EUR Server - Adapter稼働マシンに配置してください。

データ型

  • String（一つの帳票セットを指定する場合）
  • String配列（複数の帳票セットを指定する場合）

指定例

複数の帳票セットを指定する場合，一部の帳票に対してマッピングデータファイル（または可変記号値定義ファイル）の指定を省略したいときは，配列の要素に空文字を指定してください。

2番目の帳票のマッピングデータファイルの指定を省略する場合の例を次に示します。

' 帳票ファイル名を配列fmsに指定
fms(0)="Sample1.fms"
fms(1)="Sample2.fms"
fms(2)="Sample3.fms"
' マッピングデータファイル名を配列mapに指定
map(0)="Data1.csv"
map(1)=""
map(2)="Data3.csv"


DataFilePathプロパティ

DataFilePathプロパティ

DataFileNameプロパティまたは帳票セット指定ファイルで指定したマッピングデータファイルのパス，もしくは可変記号値定義ファイルのパスを指定します。

解説

  • ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

データ型

String


DBInfoFileNameプロパティ

DBInfoFileNameプロパティ

接続情報ファイル名を指定します。

解説

  • EUR Server Serviceの環境設定ファイル（EURPM.ini）で，OPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，接続情報ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのDBINFOキーで設定しているフォルダに格納しておいてください。
    OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。
    パスは，DBInfoFilePathプロパティに指定することもできます。DBInfoFilePathプロパティにパスを指定しない場合は，次のことに注意してください。
    • フルパスを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのDBINFOキーには指定が要りません。
    • 相対パスを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのDBINFOキーで設定している起点フォルダ下にあるファイル名を指定してください。
    • ファイル名だけを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのDBINFOキーで設定しているフォルダにあるファイル名を指定してください。
  • 接続情報ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • 接続情報ファイルは，EUR Server Service稼働マシンに配置してください。

データ型

String


DBInfoFilePathプロパティ

DBInfoFilePathプロパティ

DBInfoFileNameプロパティで指定した接続情報ファイルのパスを指定します。

解説

  • 接続情報ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

データ型

String


DestinationNameプロパティ

DestinationNameプロパティ

スプールサーバの出力先名を指定します。

解説

  • 出力先名を指定するときの注意
    出力先名は，任意文字列を指定できます。次のことに注意して指定してください。
    • 出力先名は，80バイト以内で指定してください。
    • 出力先名には「"」および「,」を含めないでください。
  • 次に示すどちらかの指定がある場合，DestinationNameプロパティは有効になります。それ以外の場合は，DestinationNameプロパティを指定しても無視されます。
    • PrintPMReportメソッドで印刷方式がスプールサーバ印刷方式（PrintMode=3），かつスプールサーバ指定方式が出力先名指定（ServerSelectMode=0）のとき
    • PrintPMReportメソッドで印刷方式が蓄積（PrintMode=2），かつスプールサーバ指定方式が出力先名指定（ServerSelectMode=0）のとき

データ型

String


DispPrintDlgプロパティ

DispPrintDlgプロパティ

クライアントPCで印刷する場合，ダイアログの表示モードを選択します。

解説

  • 指定できる値と印刷時の動作を次に示します。
    • 0：印刷先指定ダイアログを表示します（対話型印刷）。
      プレビューボタンを選択すると，プレビューウィンドウが表示されます。
    • 1：直接印刷を実行します（自動印刷）。
      印刷実行中に印刷中のダイアログが表示されます。
    • 2：プレビューウィンドウを表示します（対話型印刷プレビュー表示）。
      印刷メニューまたは印刷ボタンを選択すると，印刷先指定ダイアログが表示されます。
    • 3：直接印刷を実行します（全自動印刷）。
      印刷実行中に印刷中のダイアログは表示されません。
    • 4：プレビューウィンドウを表示します（対話型印刷プレビュー表示限定）。
      印刷は実行できません。
  • DispPrintDlgプロパティを省略した場合，EUR Server - Adapterの環境設定ファイル（EURPMADP.ini）でOPTIONセクションのDISPPRINTDLGキーの設定値（0～4）が仮定されます。環境設定ファイルDISPPRINTDLGキーおよびDispPrintDlgプロパティとも省略した場合，0が仮定されます。ClientPrinterNameプロパティを指定した場合は，かつDispPrintDlgプロパティに0または2を指定した場合は，1が仮定されます。
  • DispPrintDlgプロパティは，PrintPMReportメソッドで印刷方式がクライアント印刷方式（PrintMode=1）の場合，およびPrintPMReportメソッドで印刷方式が蓄積（PrintMode=2）の場合に指定が有効になります。それ以外の場合は，DispPrintDlgプロパティを指定しても無視されます。

データ型

Long


DistributeFileNameプロパティ

DistributeFileNameプロパティ

PDF仕分け定義ファイル名を指定します。

解説

  • PDF仕分け定義ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • DistributeFileNameプロパティは，OutputPDFReportメソッドでPDF形式ファイルを出力する場合，指定が有効になります。OutputPDFReportメソッドでPDF形式ファイルを出力する場合は，PDFFileNameプロパティ，またはDistributeFileNameプロパティのどちらかは，必ず指定してください。PDFFileNameプロパティとDistributeFileNameプロパティを同時に指定した場合は，PDFFileNameプロパティの指定は無視されます。OutputPDFReportメソッド以外の場合は，DistributeFileNameプロパティを指定しても無視されます。
  • PDF仕分け定義ファイルは，EUR Server - Adapter稼働マシンに配置してください。
  • DistributeFileNameプロパティでPDF仕分け定義ファイル名を指定した場合は，FileOutputDestinationプロパティの指定は無視されます。この場合，PDF仕分け定義ファイルに記述されている出力先ファイル名に従って，EUR Server Service稼働マシンにPDF形式ファイルを出力します。

データ型

String


DistributeFilePathプロパティ

DistributeFilePathプロパティ

DistributeFileNameプロパティで指定したPDF仕分け定義ファイルのパスを指定します。

解説

  • 指定されたファイルのパスは，DistributeFileNameプロパティで指定する仕分け定義ファイルのデフォルトの場所になります。
  • PDF仕分け定義ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • DistributeFilePathプロパティは，OutputPDFReportメソッドでPDF形式ファイルを出力する場合，指定が有効になります。OutputPDFReportメソッド以外の場合は，DistributeFilePathプロパティを指定しても無視されます。

データ型

String


DocBookmarkFileNameプロパティ

DocBookmarkFileNameプロパティ

文書しおり定義ファイル名を指定します。

解説

  • 文書しおり定義ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • DocBookmarkFileNameプロパティは，OutputPDFReportメソッドでPDF形式ファイルを出力する場合，指定が有効になります。OutputPDFReportメソッド以外の場合は，DocBookmarkFileNameプロパティを指定しても無視されます。
  • 文書しおり定義ファイルは，EUR Server - Adapter稼働マシンに配置してください。

データ型

String


DocInfoFileNameプロパティ

DocInfoFileNameプロパティ

文書情報設定ファイル名を指定します。

解説

  • EUR Server Serviceの環境設定ファイル（EURPM.ini）で，OPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，文書情報設定ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのDOCINFOキーで設定しているフォルダに格納しておいてください。
    OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。
    パスは，DocInfoFilePathプロパティに指定することもできます。DocInfoFilePathプロパティにパスを指定しない場合は，次のことに注意してください。
    • フルパスを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのDOCINFOキーには指定が要りません。
    • 相対パスを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのDOCINFOキーで設定している起点フォルダ下にあるファイル名を指定してください。
    • ファイル名だけを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのDOCINFOキーで設定しているフォルダにあるファイル名を指定してください。
  • 文書情報設定ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • 文書情報設定ファイルは，EUR Server Service稼働マシンに配置してください。

データ型

String


DocInfoFilePathプロパティ

DocInfoFilePathプロパティ

DocInfoFileNameプロパティで指定した文書情報設定ファイルのパスを指定します。

解説

  • 文書情報設定ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

データ型

String


EnableGetプロパティ

EnableGetプロパティ

スプールデータからEPF形式ファイルの取得を許可するかどうかを指定します。

解説

指定できる値を次に示します。

  • True：EPF形式ファイルの取得を許可します。
  • False：EPF形式ファイルの取得を許可しません。

EnableGetプロパティを指定しない場合は，Trueが仮定されます。

EnableGetプロパティは，PrintPMReportメソッドで印刷方式が蓄積（PrintMode=2）の場合，指定が有効になります。それ以外の場合は，EnableGetプロパティを指定しても無視されます。

データ型

Boolean


EncryptionPasswordKeyプロパティ

EncryptionPasswordKeyプロパティ

オーナパスワードとユーザパスワードを暗号化した暗号化設定ファイルを使用して，暗号化したPDF形式ファイルを出力するときにパスワード暗号化鍵を指定します。

解説

パスワード暗号化鍵に指定できる文字は，次のとおりです。

  • 半角数字
    0～9
  • 半角英字
    A～Z，a～z

指定できるパスワード暗号化鍵の長さは，32バイトまでです。

EncryptionPasswordKeyプロパティは，OutputPDFReportメソッドでPDF形式ファイルを出力する場合，指定が有効になります。OutputPDFReportメソッド以外の場合は，EncryptionPasswordKeyプロパティを指定しても無視されます。

データ型

String


EPFFileNameプロパティ

EPFFileNameプロパティ

入力または出力するEPF形式ファイル名を指定します。

解説

  • OutputEPFReportメソッドまたはOutputMergeEPFReportメソッドでEPF形式ファイルを出力する場合や，PrintPMReportメソッドでクライアントPCへの配布印刷をする場合は，EPFFileNameプロパティを必ず指定してください。OutputEPFReportメソッド，OutputMergeEPFReportメソッド，およびPrintPMReportメソッド以外の場合は，EPFFileNameプロパティを指定しても無視されます。
  • EPF形式ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • EPF形式ファイルの拡張子は，*.epfです。EPF形式ファイル名は，拡張子を含めて指定してください。ただし，出力したEPF形式ファイルを使用してヘルパクライアント印刷するときは，次に示す拡張子でEPF形式ファイル名を指定してください。
    • EPF形式ファイルをプレビューする場合：*.epf
    • EPF形式ファイルをプリンタ印刷する場合：*.epp

データ型

String


EPFFilePathプロパティ

EPFFilePathプロパティ

EPFFileNameプロパティで指定したEPF形式ファイルのパスを指定します。

解説

  • 指定されたファイルのパスは，EPFFileNameプロパティで指定するEPF形式ファイルのデフォルトの場所になります。
  • EPFFilePathプロパティは，OutputEPFReportメソッドまたはOutputMergeEPFReportメソッドでEPF形式ファイルを出力する場合や，PrintPMReportメソッドでクライアントPCへの配布印刷をする場合に指定が有効になります。OutputEPFReportメソッド，OutputMergeEPFReportメソッド，およびPrintPMReportメソッド以外の場合は，EPFFilePathプロパティを指定しても無視されます。
  • パスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

データ型

String


EURFileNameプロパティ

EURFileNameプロパティ

出力するEUR形式ファイル名を指定します。

解説

  • OutputEURReportメソッドでEUR形式ファイルを出力する場合は，EURFileNameプロパティを必ず指定してください。OutputEURReportメソッド以外の場合は，EURFileNameプロパティを指定しても無視されます。
  • EUR形式ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

データ型

String


EURFilePathプロパティ

EURFilePathプロパティ

EURFileNameプロパティで指定したEUR形式ファイルのパスを指定します。

解説

  • 指定されたファイルのパスは，EURFileNameプロパティで指定するEUR形式ファイルのデフォルトの場所になります。
  • EURFilePathプロパティは，OutputEURReportメソッドでEUR形式ファイルを出力する場合，指定が有効になります。OutputEURReportメソッド以外の場合は，EURFilePathプロパティを指定しても無視されます。
  • パスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

データ型

String


ExecutablePrintModeプロパティ

ExecutablePrintModeプロパティ

実行可能印刷方式を指定します。

解説

指定できる値を次に示します。

  • 0：スプールサーバでの印刷
  • 1：スプールサーバでの印刷，またはクライアントPCでの印刷
  • 2：クライアントPCでの印刷

0，1，および2以外の値を指定した場合は，1が仮定されます。

ExecutablePrintModeプロパティは，PrintPMReportメソッドで印刷方式が蓄積（PrintMode=2）の場合，指定が有効になります。それ以外の場合は，ExecutablePrintModeプロパティを指定しても無視されます。

データ型

Long


FileOutputDestinationプロパティ

FileOutputDestinationプロパティ

PDF形式ファイルの出力先を，EUR Server - Adapter稼働マシンにするか，またはEUR Server Service稼働マシンにするかのどちらかを指定します。

解説

指定できる値を次に示します。

  • 0：EUR Server - Adapter稼働マシンに出力します。
  • 1：EUR Server Service稼働マシンに出力します。

FileOutputDestinationプロパティを省略した場合は，EUR Server - Adapterの環境設定ファイル（EURPMADP.ini）のOPTIONセクションのFILEOUTPUTDESTINATIONキーが仮定されます。

また，0，1以外の値を指定した場合は，0が仮定されます。

FileOutputDestinationプロパティは，OutputPDFReportメソッドでPDF形式ファイルを出力する場合，指定が有効になります。OutputPDFReportメソッド以外の場合は，FileOutputDestinationプロパティを指定しても無視されます。

DistributeFileNameプロパティでPDF仕分け定義ファイル名を指定した場合は，FileOutputDestinationプロパティの指定は無視されます。この場合，PDF仕分け定義ファイルに記述されている出力先ファイル名に従って，EUR Server Service稼働マシンにPDF形式ファイルを出力します。

データ型

Long


FirstPageNumberプロパティ

FirstPageNumberプロパティ

ページ番号の初期値を指定します。

解説

指定できる値は，1～999,999です。FirstPageNumberプロパティを省略した場合，1が仮定されます。

FirstPageNumberプロパティは，PrintPageNumberプロパティを指定した場合だけ有効になります。ただし，MultiFormInfoDefFileNameプロパティを指定した場合は，FirstPageNumberプロパティの設定値は無視されます。

FirstPageNumberプロパティは，次に示すメソッドで印刷実行する場合，指定が有効になります。それ以外の場合は，FirstPageNumberプロパティを指定しても無視されます。

  • PrintPMReportメソッド
  • OutputPDFReportメソッド
  • OutputEPFReportメソッド

データ型

Long


GroupNameプロパティ

GroupNameプロパティ

帳票振り分け定義の振り分けグループ名を指定します。

解説

  • 振り分けグループ名を指定するときの注意
    振り分けグループ名は，任意文字列を指定できます。次のことに注意して指定してください。
    • 振り分けグループ名は，80バイト以内で指定してください。
    • 振り分けグループ名には「"」および「,」を含めないでください。
  • 次に示すどちらかの指定がある場合，GroupNameプロパティは有効になります。それ以外の場合は，GroupNameプロパティを指定しても無視されます。
    • PrintPMReportメソッドで印刷方式がスプールサーバ印刷方式（PrintMode=3），かつ印刷モードがEPF形式ファイル印刷モード（PrintKind=0），かつプリンタ指定方式が帳票名による自動振り分け（PrinterSelectMode=2）のとき
    • PrintPMReportメソッドで印刷方式が蓄積（PrintMode=2），かつプリンタ指定方式が帳票名による自動振り分け（PrinterSelectMode=2）のとき

データ型

String


InitPageNumberプロパティ

InitPageNumberプロパティ

改ページのキーが設定されている場合，そのキーがブレイクするごとにページ番号の開始番号を初期化するかどうかを指定します。

解説

指定できる値を次に示します。

  • True：初期化します。
  • False：初期化しません。

InitPageNumberプロパティを指定しない場合は，出力する帳票の属性に従います。帳票の属性の初期値は，Falseが仮定されます。ただし，MultiFormInfoDefFileNameプロパティを指定した場合は，InitPageNumberプロパティの設定値は無視されます。

InitPageNumberプロパティは，次に示すメソッドで印刷実行する場合，指定が有効になります。それ以外の場合は，InitPageNumberプロパティを指定しても無視されます。

  • PrintPMReportメソッド
  • OutputPDFReportメソッド
  • OutputEPFReportメソッド

データ型

Boolean


JobKeyCategoryプロパティ

JobKeyCategoryプロパティ

スプールデータの検索キーの分類を指定します。

解説

  • 検索キーを指定する場合は，1～10個の配列で指定してください。また，JobKeyCategoryプロパティを指定する場合は，検索キーの分類に対応する検索キーの値を必ずJobKeyDataプロパティに指定してください。このとき，配列の要素数は同じにしてください。配列の要素数が異なると，エラーになります。
    検索キーを指定しない場合，JobKeyCategoryプロパティとJobKeyDataプロパティは，どちらも指定しないでください。どちらかの指定があると対応する情報がないため，エラーになります。
  • 分類を指定するときの注意
    分類は，任意文字列を指定できます。次のことに注意して指定してください。
    • 文字列は，80バイト以内で指定してください。
    • 文字列に「,」を含めないでください。
  • JobKeyCategoryプロパティは，PrintPMReportメソッドで印刷方式が蓄積（PrintMode=2）の場合，指定が有効になります。それ以外の場合は，JobKeyCategoryプロパティを指定しても無視されます。

データ型

String配列


JobKeyDataプロパティ

JobKeyDataプロパティ

スプールデータの検索キーの値を指定します。

解説

  • 検索キーを指定する場合は，1～10個の配列で指定してください。また，JobKeyCategoryプロパティを指定する場合は，検索キーの分類に対応する検索キーの値を必ずJobKeyDataプロパティに指定してください。このとき，配列の要素数は同じにしてください。配列の要素数が異なると，エラーになります。
    検索キーを指定しない場合，JobKeyCategoryプロパティとJobKeyDataプロパティは，どちらも指定しないでください。どちらかの指定があると対応する情報がないため，エラーになります。
  • 値を指定するときの注意
    値は，任意文字列を指定できます。次のことに注意して指定してください。
    • 文字列は，80バイト以内で指定してください。
    • 文字列に「,」を含めないでください。
  • JobKeyDataプロパティは，PrintPMReportメソッドで印刷方式が蓄積（PrintMode=2）の場合，指定が有効になります。それ以外の場合は，JobKeyDataプロパティを指定しても無視されます。

データ型

String配列


MaxPrintCountプロパティ

MaxPrintCountプロパティ

スプールデータの上限印刷回数を指定します。

解説

  • 印刷上限回数に指定できる値は，-1～65,536です。
    • 印刷回数を無限にする場合は，-1を指定してください。
    • 印刷を禁止する場合は，0を指定してください。
    • 印刷回数を指定する場合は，1～65,536の範囲内で指定してください。
  • MaxPrintCountプロパティを省略した場合，または1～65,536以外の値を指定した場合は，-1（無限）が仮定されます。
  • MaxPrintCountプロパティは，PrintPMReportメソッドで印刷方式が蓄積（PrintMode=2）の場合，指定が有効になります。それ以外の場合は，MaxPrintCountプロパティを指定しても無視されます。

データ型

Long


MergeEPFFileNameプロパティ

MergeEPFFileNameプロパティ

統合対象のEPF形式ファイル名を指定します。

解説

  • OutputMergeEPFReportメソッドで複数のEPF形式ファイルを統合して出力する場合は，MergeEPFFileNameプロパティを必ず指定してください。OutputMergeEPFReportメソッド以外の場合は，MergeEPFFileNameプロパティを指定しても無視されます。
  • 指定できるEPF形式ファイルの数は，2～10,000ファイルです。ファイル名はファイルの統合順に指定してください。
  • 統合対象のEPF形式ファイルは，EUR Server - Adapterが稼働するマシンに準備してください。
  • EPF形式ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • EPF形式ファイルの拡張子は，*.epfです。EPF形式ファイル名は，拡張子を含めて指定してください。

データ型

String配列


MergeEPFFilePathプロパティ

MergeEPFFilePathプロパティ

MergeEPFFileNameプロパティで指定した統合対象のEPF形式ファイルのパスを指定します。

解説

  • 指定されたファイルのパスは，MergeEPFFileNameプロパティで指定するEPF形式ファイルのデフォルトの場所になります。
  • MergeEPFFilePathプロパティは，OutputMergeEPFReportメソッドで複数のEPF形式ファイルを統合して出力する場合，指定が有効になります。OutputMergeEPFReportメソッド以外の場合は，MergeEPFFilePathプロパティを指定しても無視されます。
  • パスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

データ型

String


MultiFormInfoDefFileNameプロパティ

MultiFormInfoDefFileNameプロパティ

複数様式情報定義ファイル名を指定します。

解説

  • 複数様式で帳票を出力する場合は，MultiFormInfoDefFileNameプロパティを必ず指定してください。MultiFormInfoDefFileNameプロパティを省略すると，ReportFileNameプロパティで指定した複数の帳票ファイル，またはMultiReportSetFileNameプロパティの帳票セット指定ファイルで指定した帳票ファイルが順に出力されます。
  • EUR Server Serviceの環境設定ファイル（EURPM.ini）で，OPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，複数様式情報定義ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのMULTIキーで設定しているフォルダに格納しておいてください。
    OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。
    パスは，MultiFormInfoDefFilePathプロパティに指定することもできます。MultiFormInfoDefFilePathプロパティにパスを指定しない場合は，次のことに注意してください。
    • フルパスを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのMULTIキーには指定が要りません。
    • 相対パスを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのMULTIキーで設定している起点フォルダ下にあるファイル名を指定してください。
    • ファイル名だけを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのMULTIキーで設定しているフォルダにあるファイル名を指定してください。
  • 複数様式情報定義ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • 複数様式情報定義ファイルは，EUR Server Service稼働マシンに配置してください。

データ型

String


MultiFormInfoDefFilePathプロパティ

MultiFormInfoDefFilePathプロパティ

MultiFormInfoDefFileNameプロパティで指定した複数様式情報定義ファイルのパスを指定します。

解説

  • 複数様式情報定義ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

データ型

String


MultiReportSetFileNameプロパティ

MultiReportSetFileNameプロパティ

帳票セット指定ファイル名を指定します。

解説

  • MultiReportSetFileNameプロパティ，またはReportFileNameプロパティのどちらかは，必ず指定してください。MultiReportSetFileNameプロパティとReportFileNameプロパティを同時に指定した場合は，MultiReportSetFileNameプロパティで指定した帳票ファイルのあとに，ReportFileNameプロパティで指定した帳票ファイルが出力されます。
  • 帳票セット指定ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • 帳票セット指定ファイルは，EUR Server - Adapter稼働マシンに配置してください。

データ型

String


MultiReportSetFilePathプロパティ

MultiReportSetFilePathプロパティ

MultiReportSetFileNameプロパティで指定した帳票セット指定ファイルのパスを指定します。

解説

  • 帳票セット指定ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

データ型

String


PageNumberFormatプロパティ

PageNumberFormatプロパティ

ページ番号のフォーマットを指定します。

解説

PageNumberFormatプロパティには，ページ番号のフォーマットを指定します。ページ番号を「*」，最終ページ番号を「$」で示して出力形式を指定します。

ページ番号および最終ページ番号を全角で表示したいときは全角の記号で，半角で表示したいときは半角の記号で指定します。

PageNumberFormatプロパティを指定しても，PrintPageNumberプロパティを省略した場合は無効となります。ただし，MultiFormInfoDefFileNameプロパティを指定した場合は，PageNumberFormatプロパティの設定値は無視されます。

PageNumberFormatプロパティは，次に示すメソッドで印刷実行する場合，指定が有効になります。それ以外の場合は，PageNumberFormatプロパティを指定しても無視されます。

  • PrintPMReportメソッド
  • OutputPDFReportメソッド
  • OutputEPFReportメソッド

データ型

String


PageNumberLocationプロパティ

PageNumberLocationプロパティ

余白へのページ番号の印刷位置を指定します。

解説

指定できる値を次に示します。

  • 1：ページ番号を左上に出力します。
  • 2：ページ番号を中央上に出力します。
  • 3：ページ番号を右上に出力します。
  • 4：ページ番号を左下に出力します。
  • 5：ページ番号を中央下に出力します。
  • 6：ページ番号を右下に出力します。

PageNumberLocationプロパティを指定しても，PrintPageNumberプロパティを省略した場合は無効となります。ただし，MultiFormInfoDefFileNameプロパティを指定した場合は，PageNumberLocationプロパティの設定値は無視されます。

PageNumberLocationプロパティは，次に示すメソッドで印刷実行する場合，指定が有効になります。それ以外の場合は，PageNumberLocationプロパティを指定しても無視されます。

  • PrintPMReportメソッド
  • OutputPDFReportメソッド
  • OutputEPFReportメソッド

データ型

Long


PaperOrientationプロパティ

PaperOrientationプロパティ

用紙の向きを指定します。

解説

指定できる値を次に示します。

  • 0：帳票を定義したときの情報に従います。
    複数のEPF形式ファイルを統合して出力する場合は，統合するEPF形式ファイルのページごとの属性に従います。
  • 1：用紙の向きを縦にして出力します。
  • 2：用紙の向きを横にして出力します。

PaperOrientationプロパティを省略した場合，0が仮定されます。

複数帳票を出力する場合は，PaperOrientationプロパティの指定に関係なく0が仮定されます。ただし，OutputMergeEPFReportメソッドで複数のEPF形式ファイルを統合して出力するときは，PaperOrientationプロパティの指定に従います。

PaperOrientationプロパティは，次に示すメソッドで印刷実行する場合，指定が有効になります。それ以外の場合は，PaperOrientationプロパティを指定しても無視されます。

  • PrintPMReportメソッド
  • OutputEPFReportメソッド
  • OutputMergeEPFReportメソッド

データ型

Long


PDFFileNameプロパティ

PDFFileNameプロパティ

出力するPDF形式ファイル名を指定します。

解説

  • OutputPDFReportメソッドでPDF形式ファイルを出力する場合は，PDFFileNameプロパティまたはDistributeFileNameプロパティのどちらかは，必ず指定してください。PDFFileNameプロパティとDistributeFileNameプロパティを同時に指定した場合は，PDFFileNameプロパティの指定は無視されます。OutputPDFReportメソッド以外の場合は，PDFFileNameプロパティを指定しても無視されます。
  • PDF形式ファイルをEUR Server Service稼働マシンに出力する（FileOutputDestination=1）場合で，EUR Server Serviceの環境設定ファイル（EURPM.ini）でOPTIONセクションのPATHMODEキーに0（通常モード）を設定しているときは，PDFFileNameプロパティにはファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのPDFキーで設定しているフォルダに出力されます。
    OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定しているときは，PDFFileNameプロパティはフルパス，相対パス，またはファイル名だけのどれかで指定してください。
    パスは，PDFFilePathプロパティに指定することもできます。PDFFilePathプロパティにパスを指定しない場合のPDF形式ファイルの出力先を次に示します。
    • フルパスを指定する場合
      PDFFileNameプロパティで指定したパスに出力されます。なお，環境設定ファイル（EURPM.ini）のPATHセクションのPDFキーには指定が要りません。
    • 相対パスを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのPDFキーで設定しているフォルダを起点とし，そこからPDFFileNameプロパティで指定したパスに出力されます。
    • ファイル名だけを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのPDFキーで設定しているフォルダに，PDFFileNameプロパティで指定したファイル名で出力されます。
  • PDF形式ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

データ型

String


PDFFilePathプロパティ

PDFFilePathプロパティ

PDFFileNameプロパティで指定したPDF形式ファイルのパスを指定します。

解説

  • 指定されたフォルダのパスは，PDFFileNameプロパティで指定するPDF形式ファイルのデフォルトの場所になります。
  • PDFFilePathプロパティは，OutputPDFReportメソッドでPDF形式ファイルを出力する場合に指定が有効になります。ただし，次の場合はPDFFilePathプロパティを指定しても無視されます。
    • OutputPDFReportメソッド以外の場合
    • PDF形式ファイルをEUR Server Service稼働マシンに出力する（FileOutputDestination=1）場合で，かつEUR Server Serviceの環境設定ファイル（EURPM.ini）のOPTIONセクションのPATHMODEキーに0（通常モード）を指定している場合
  • パスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

データ型

String


PMServerAddressプロパティ

PMServerAddressプロパティ

接続する帳票サーバのIPアドレスを指定します。

解説

  • 帳票サーバが複数台起動されている場合に，PMServerAddressプロパティを指定すると，接続する帳票サーバを振り分けられます。
  • PMServerAddressプロパティを省略した場合，EUR Server - Adapterの環境設定ファイル（EURPMADP.ini）のIPADDRESSセクションのEURPMキーが仮定されます。EURPMキーの指定が省略されているとき，または値が指定されていないときは，デフォルト値（127.0.0.1）が仮定されます。

データ型

String


PMServerPortプロパティ

PMServerPortプロパティ

帳票サーバのポート番号を指定します。

解説

  • EUR Server Serviceが複数起動されている場合に，PMServerPortプロパティを指定すると，接続するポートを振り分けられます。
  • PMServerPortプロパティを省略した場合，EUR Server - Adapterの環境設定ファイル（EURPMADP.ini）のPORTセクションのEURPMキーが仮定されます。
  • PMServerPortプロパティを省略した場合，およびEUR Server - Adapterの環境設定ファイル（EURPMADP.ini）のPORTセクションのEURPMキーが指定されていない場合は，環境設定ファイルの省略時の値が仮定されます。

データ型

Long


PrintCopiesプロパティ

PrintCopiesプロパティ

印刷部数を指定します。

解説

指定できる値は，1～99です。PrintCopiesプロパティを省略した場合，1が仮定されます。

PrintCopiesプロパティは，次に示すメソッドで印刷実行する場合，指定が有効になります。それ以外の場合は，PrintCopiesプロパティを指定しても無視されます。

  • PrintPMReportメソッド
  • OutputEPFReportメソッド
  • OutputMergeEPFReportメソッド

データ型

Long


PrintDateFileNameプロパティ

PrintDateFileNameプロパティ

印刷日時出力定義ファイル名を指定します。

解説

  • EUR Server Serviceの環境設定ファイル（EURPM.ini）で，OPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，PrintDateFileNameプロパティは，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのPRINTDATEキーで設定しているフォルダに格納しておいてください。
    OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。
    パスは，PrintDateFilePathプロパティに指定することもできます。PrintDateFilePathプロパティにパスを指定しない場合は，次のことに注意してください。
    • フルパスを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのPRINTDATEキーには指定が要りません。
    • 相対パスを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのPRINTDATEキーで設定している起点フォルダ下にあるファイル名を指定してください。
    • ファイル名だけを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのPRINTDATEキーで設定しているフォルダにあるファイル名を指定してください。
  • 印刷日時出力定義ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • 印刷日時出力定義ファイルは，EUR Server Service稼働マシンに配置してください。
  • PrintDateFileNameプロパティは，次に示すメソッドで印刷実行する場合，指定が有効になります。それ以外の場合は，PrintDateFileNameプロパティを指定しても無視されます。
    • PrintPMReportメソッド
    • OutputEPFReportメソッド

データ型

String


PrintDateFilePathプロパティ

PrintDateFilePathプロパティ

PrintDateFileNameプロパティで指定した印刷日時出力定義ファイルのパスを指定します。

解説

  • 指定されたファイルのパスは，PrintDateFileNameプロパティで指定する印刷日時出力定義ファイルのデフォルトの場所になります。
  • 印刷日時出力定義ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • PrintDateFilePathプロパティは，次に示すメソッドで印刷実行する場合，指定が有効になります。それ以外の場合は，PrintDateFilePathプロパティを指定しても無視されます。
    • PrintPMReportメソッド
    • OutputEPFReportメソッド

データ型

String


PrintEndPageプロパティ

PrintEndPageプロパティ

印刷終了ページを指定します。

解説

指定できる値は，0～999,999です。PrintEndPageプロパティを省略した場合，または指定した値が0の場合は，最終ページまで印刷されます。

複数の帳票ファイルを指定した場合は，PrintEndPageプロパティの指定に関係なく，複数帳票ファイルの全ページが印刷されます。

PrintEndPageプロパティは，次に示すメソッドで印刷実行する場合，指定が有効になります。それ以外の場合は，PrintEndPageプロパティを指定しても無視されます。

  • PrintPMReportメソッド
  • OutputPDFReportメソッド
  • OutputEPFReportメソッド
  • OutputXLSXReportメソッド

データ型

Long


PrinterClassNameプロパティ

PrinterClassNameプロパティ

プリンタクラス名を指定します。

解説

  • プリンタクラス名を指定するときの注意
    プリンタクラス名は，任意文字列を指定できます。次のことに注意して指定してください。
    • プリンタクラス名は，80バイト以内で指定してください。
    • プリンタクラス名には「"」および「,」を含めないでください。
    • プリンタクラス名に「EUR_DELIVERY_PRINT_OUTPUT_DEFAULT_PRINTER_CLASS_________________________________」は使用できません。
  • 印刷方法ごとに指定するプロパティを次に示します。
    • スプールサーバでの印刷
      PrintModeプロパティ：3
      PrinterSelectModeプロパティ：0
      PrinterClassNameプロパティ：拠点プリンタクラス名
    • クライアントPCでの対話型印刷
      PrintModeプロパティ：1
      DispPrintDlgプロパティ：0
      PrinterClassNameプロパティ：帳票ジョブ名，およびEPF形式ファイルの属性情報に設定するプリンタクラス名
    • クライアントPCでの自動印刷
      PrintModeプロパティ：1
      DispPrintDlgプロパティ：1
      PrinterClassNameプロパティ：クライアントプリンタクラス名
    • クライアントPCでの対話型印刷プレビュー表示
      PrintModeプロパティ：1
      DispPrintDlgプロパティ：2
      PrinterClassNameプロパティ：帳票ジョブ名，およびEPF形式ファイルの属性情報に設定するプリンタクラス名
    • クライアントPCでの全自動印刷
      PrintModeプロパティ：1
      DispPrintDlgプロパティ：3
      PrinterClassNameプロパティ：クライアントプリンタクラス名
    • クライアントPCでの対話型印刷プレビュー表示限定
      PrintModeプロパティ：1
      DispPrintDlgプロパティ：4
      PrinterClassNameプロパティ：EPF形式ファイルの属性情報に設定するプリンタクラス名
    • 帳票サーバでの印刷
      PrintModeプロパティ：4
      PrinterSelectModeプロパティ：0
      PrinterClassNameプロパティ：帳票サーバプリンタクラス名
    • 蓄積（プリンタクラス名指定）
      PrintModeプロパティ：2
      PrinterSelectModeプロパティ：0
      PrinterClassNameプロパティ：拠点プリンタクラス名，または蓄積クライアント印刷方式のプリンタクラス名
    • 蓄積（OS上のプリンタ名指定）
      PrintModeプロパティ：2
      PrinterSelectModeプロパティ：1
      PrinterClassNameプロパティ：EPF形式ファイルの属性情報に設定するプリンタクラス名
    • 蓄積（帳票名による自動振り分け）
      PrintModeプロパティ：2
      PrinterSelectModeプロパティ：2
      PrinterClassNameプロパティ：EPF形式ファイルの属性情報に設定するプリンタクラス名
    「クライアントPCでの自動印刷」と「蓄積クライアント印刷」の場合，ClientPrinterNameプロパティとPrinterClassNameプロパティでは，ClientPrinterNameプロパティの指定を優先します。
  • EPF形式ファイルを出力する場合に指定するプロパティを次に示します。
    PrinterClassNameプロパティ：EPF形式ファイルの属性情報に設定するプリンタクラス名
  • 複数のEPF形式ファイルを統合して出力する場合に指定するプロパティを次に示します。
    PrinterClassNameプロパティ：EPF形式ファイルの属性情報に設定するプリンタクラス名
  • クライアントPCへの配布印刷では，指定できません。
  • EPF形式ファイルを出力する場合に，PrinterClassNameプロパティの指定を省略したときや空文字を指定したときは，EPF形式ファイルのプリンタクラス名情報は未設定となります。
  • 複数のEPF形式ファイルを統合して出力する場合に，PrinterClassNameプロパティの指定を省略したときや空文字を指定したときは，統合対象のEPF形式ファイルにプリンタクラス名情報が設定されていても，統合後のEPF形式ファイルのプリンタクラス名情報は未設定となります。

データ型

String


PrinterSelectModeプロパティ

PrinterSelectModeプロパティ

プリンタの指定方法を選択します。

解説

指定できる値を次に示します。

  • 0：プリンタクラス名の指定
  • 1：OS上のプリンタ名の指定
  • 2：帳票振り分け定義の指定

PrinterSelectModeプロパティを省略した場合，または0，1，2以外の値を指定した場合は，0が仮定されます。

PrinterSelectModeプロパティは，次の場合に指定が有効になります。

  • PrintPMReportメソッドで印刷方式がスプールサーバ印刷方式（PrintMode=3）の場合
  • PrintPMReportメソッドで印刷方式が蓄積（PrintMode=2）の場合
  • PrintPMReportメソッドで印刷方式が帳票サーバ直接印刷方式（PrintMode=4）の場合

それ以外の場合は，PrinterSelectModeプロパティを指定しても無視されます。

また，帳票サーバによる直接印刷（PrintMode=4）の場合，2の値を指定するとエラーになります。

データ型

Long


PrintHoldModeプロパティ

PrintHoldModeプロパティ

蓄積印刷方式で，蓄積後に続けて印刷するかどうかを選択します。

解説

指定できる値を次に示します。

  • 0：蓄積後に続けて印刷しません（印刷保留）。
  • 1：蓄積後に続けてスプールサーバで印刷します。
  • 2：蓄積後に続けてクライアントPCで印刷します。

PrintHoldModeプロパティを省略した場合，または0，1，2以外の値を指定した場合は，ReportAddressKeyCategoryプロパティおよびReportAddressKeyDataプロパティの指定の有無によって次の値が仮定されます。

ReportAddressKeyCategoryプロパティおよびReportAddressKeyDataプロパティの指定がある場合
0が仮定されます。
ReportAddressKeyCategoryプロパティおよびReportAddressKeyDataプロパティの指定がない場合
1が仮定されます。

PrintHoldModeプロパティは，PrintPMReportメソッドで印刷方式が蓄積（PrintMode=2）の場合，指定が有効になります。それ以外の場合は，PrintHoldModeプロパティを指定しても無視されます。

データ型

Long


PrintKindプロパティ

PrintKindプロパティ

スプールサーバ印刷方式の印刷モードを指定します。

解説

指定できる値を次に示します。

  • 0：EPF形式ファイル印刷モード
  • 1：EUR形式ファイル印刷モード

PrintKindプロパティを省略した場合，または0，1以外の値を指定した場合は，0が仮定されます。

PrintKindプロパティは，PrintPMReportメソッドで印刷方式がスプールサーバ印刷方式（PrintMode=3）の場合，指定が有効になります。それ以外の場合は，PrintKindプロパティを指定しても無視されます。

データ型

Long


PrintModeプロパティ

PrintModeプロパティ

印刷メソッド（PrintPMReportメソッド）の印刷方式を指定します。

解説

指定できる値を次に示します。

  • 0：デフォルト印刷方式 ※
  • 1：クライアント印刷方式
  • 2：蓄積
  • 3：スプールサーバ印刷方式
  • 4：帳票サーバ直接印刷方式
  • 5：クライアント配布印刷方式
    注※
    「0（デフォルト印刷方式）」を定義する場合は，EUR Server - Adapterの環境設定ファイル（EURPMADP.ini）でOPTIONセクションのDEFAULTPRINTMODEキーに値を設定してください。

0，1，2，3，4，5以外の値を指定した場合は，0が仮定されます。

PrintModeプロパティを省略した場合は，環境設定ファイル（EURPMADP.ini）でOPTIONセクションのPRINTMODEキーに指定されている値をデフォルトにします。

データ型

Long


PrintPageNumberプロパティ

PrintPageNumberプロパティ

余白へのページ番号印刷を指定します。

解説

指定できる値を次に示します。

  • True：余白へのページ番号を出力します。
  • False：余白へのページ番号は出力しません。

PrintPageNumberプロパティを省略した場合，Falseが仮定されます。ただし，MultiFormInfoDefFileNameプロパティを指定した場合は，PrintPageNumberプロパティの設定値は無視されます。

PrintPageNumberプロパティは，次に示すメソッドで印刷実行する場合，指定が有効になります。それ以外の場合は，PrintPageNumberプロパティを指定しても無視されます。

  • PrintPMReportメソッド
  • OutputPDFReportメソッド
  • OutputEPFReportメソッド

データ型

Boolean


PrintStartPageプロパティ

PrintStartPageプロパティ

印刷開始ページを指定します。

解説

指定できる値は，0～999,999です。PrintStartPageプロパティを省略した場合，または指定した値が0の場合は，1ページから印刷されます。

複数の帳票ファイルを指定した場合は，PrintStartPageプロパティの指定に関係なく，指定した複数の帳票ファイルの全ページが印刷されます。

PrintPageNumberプロパティは，次に示すメソッドで印刷実行する場合，指定が有効になります。それ以外の場合は，PrintPageNumberプロパティを指定しても無視されます。

  • PrintPMReportメソッド
  • OutputPDFReportメソッド
  • OutputEPFReportメソッド
  • OutputXLSXReportメソッド

データ型

Long


PSEnvFileNameプロパティ

PSEnvFileNameプロパティ

EUR Print Serviceの動作環境を印刷ジョブごとに変更する場合に，EUR Server Serviceの環境設定ファイル（EURPS_ENV）名を指定します。

解説

  • EUR Server Serviceの環境設定ファイル（EURPM.ini）で，OPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，PSEnvFileNameプロパティは，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのPSENVキーで設定しているフォルダに格納しておいてください。
    OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。
    パスは，PSEnvFilePathプロパティに指定することもできます。PSEnvFilePathプロパティにパスを指定しない場合は，次のことに注意してください。
    • フルパスを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのPSENVキーには指定が要りません。
    • 相対パスを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのPSENVキーで設定している起点フォルダ下にあるファイル名を指定してください。
    • ファイル名だけを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのPSENVキーで設定しているフォルダにあるファイル名を指定してください。
  • EUR Server Serviceの環境設定ファイル（EURPS_ENV）名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • EUR Server Serviceの環境設定ファイル（EURPS_ENV）は，EUR Server Service稼働マシンに配置してください。
  • PSEnvFileNameプロパティは，次に示すメソッドで印刷実行する場合，指定が有効になります。それ以外の場合は，PSEnvFileNameプロパティを指定しても無視されます。
    • PrintPMReportメソッド
    • OutputPDFReportメソッド
    • OutputEPFReportメソッド
    • OutputEURReportメソッド
    • OutputXLSXReportメソッド

データ型

String


PSEnvFilePathプロパティ

PSEnvFilePathプロパティ

PSEnvFileNameプロパティで指定したEUR Server Serviceの環境設定ファイル（EURPS_ENV）のパスを指定します。

解説

  • 指定されたファイルのパスは，PSEnvFileNameプロパティで指定するEUR Server Serviceの環境設定ファイル（EURPS_ENV）のデフォルトの場所になります。
  • EUR Server Serviceの環境設定ファイル（EURPS_ENV）のパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • PSEnvFilePathプロパティは，次に示すメソッドで印刷実行する場合，指定が有効になります。それ以外の場合は，PSEnvFilePathプロパティを指定しても無視されます。
    • PrintPMReportメソッド
    • OutputPDFReportメソッド
    • OutputEPFReportメソッド
    • OutputEURReportメソッド
    • OutputXLSXReportメソッド

データ型

String


ReplaceItemCntlFileNameプロパティ

ReplaceItemCntlFileNameプロパティ

置き換え表管理情報ファイル名を指定します。

解説

  • EUR Server Serviceの環境設定ファイル（EURPM.ini）で，OPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，置き換え表管理情報ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのREPLACEITEMキーで設定しているフォルダに格納しておいてください。
    OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。
    パスは，ReplaceItemCntlFilePathプロパティに指定することもできます。ReplaceItemCntlFilePathプロパティにパスを指定しない場合は，次のことに注意してください。
    • フルパスを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのREPLACEITEMキーには指定が要りません。
    • 相対パスを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのREPLACEITEMキーで設定している起点フォルダ下にあるファイル名を指定してください。
    • ファイル名だけを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのREPLACEITEMキーで設定しているフォルダにあるファイル名を指定してください。
  • 置き換え表管理情報ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • 次に示すどれかの指定がある場合，ReplaceItemCntlFileNameプロパティは有効になります。PrintPMReportメソッドで印刷方式がスプールサーバ印刷方式（PrintMode=3），かつ印刷モードがEUR形式ファイル印刷モード（PrintKind=1）の場合は，ReplaceItemCntlFileNameプロパティを指定しても無視されます。
    • PrintPMReportメソッドで印刷方式がスプールサーバ印刷方式（PrintMode=3），かつ印刷モードがEPF形式ファイル印刷モード（PrintKind=0）のとき
    • PrintPMReportメソッドで印刷方式がクライアント印刷方式（PrintMode=1）のとき
    • PrintPMReportメソッドで印刷方式が蓄積（PrintMode=2）のとき
    • OutputPDFReportメソッド，OutputEPFReportメソッド，OutputEURReportメソッド，およびOutputXLSXReportメソッドで印刷実行するとき
  • 置き換え表管理情報ファイルは，EUR Server Service稼働マシンに配置してください。

データ型

String


ReplaceItemCntlFilePathプロパティ

ReplaceItemCntlFilePathプロパティ

ReplaceItemCntlFileNameプロパティで指定した置き換え表管理情報ファイルのパスを指定します。

解説

  • 置き換え表管理情報ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • 次に示すどれかの指定がある場合，ReplaceItemCntlFilePathプロパティは有効になります。PrintPMReportメソッドで印刷方式がスプールサーバ印刷方式（PrintMode=3），かつ印刷モードがEUR形式ファイル印刷モード（PrintKind=1）の場合は，ReplaceItemCntlFilePathプロパティを指定しても無視されます。
    • PrintPMReportメソッドで印刷方式がスプールサーバ印刷方式（PrintMode=3），かつ印刷モードがEPF形式ファイル印刷モード（PrintKind=0）のとき
    • PrintPMReportメソッドで印刷方式がクライアント印刷方式（PrintMode=1）のとき
    • PrintPMReportメソッドで印刷方式が蓄積（PrintMode=2）のとき
    • OutputPDFReportメソッド，OutputEPFReportメソッド，OutputEURReportメソッド，およびOutputXLSXReportメソッドで印刷実行するとき

データ型

String


ReportAddressKeyCategoryプロパティ

ReportAddressKeyCategoryプロパティ

スプールデータの宛先キーの分類を指定します。

解説

  • 宛先キーの分類は，任意の文字列を指定できます。次のことに注意して指定してください。
    • 文字列は，1～80バイトで指定してください。
    • 文字列に「"」，「,」および制御コード（0x00～0x1F，0x7F～0x9F）を含めないでください。
  • ReportAddressKeyCategoryプロパティは，PrintPMReportメソッドで印刷方式が蓄積（PrintMode=2）の場合に指定が有効になります。それ以外のメソッドでは，ReportAddressKeyCategoryプロパティを指定しても無視されます。
  • ReportAddressKeyDataプロパティが指定されていない場合はエラーになります。

データ型

String


ReportAddressKeyDataプロパティ

ReportAddressKeyDataプロパティ

スプールデータの宛先キーの値を指定します。

解説

  • 宛先キーの値は，任意の文字列を指定できます。次のことに注意して指定してください。
    • 文字列は，1～80バイトで指定してください。
    • 文字列に「"」，「,」および制御コード（0x00～0x1F，0x7F～0x9F）を含めないでください。
  • ReportAddressKeyDataプロパティは，PrintPMReportメソッドで印刷方式が蓄積（PrintMode=2）場合に指定が有効になります。それ以外のメソッドでは，ReportAddressKeyDataプロパティを指定しても無視されます。
  • ReportAddressKeyCategoryプロパティが指定されていない場合はエラーになります。

データ型

String


ReportFileNameプロパティ

ReportFileNameプロパティ

帳票ファイル名（*.fms）を指定します。

解説

  • ReportFileNameプロパティ，またはMultiReportSetFileNameプロパティのどちらかは，必ず指定してください。ReportFileNameプロパティとMultiReportSetFileNameプロパティを同時に指定した場合は，MultiReportSetFileNameプロパティで指定した帳票ファイルのあとに，ReportFileNameプロパティで指定した帳票ファイルが出力されます。
  • EUR Server Serviceの環境設定ファイル（EURPM.ini）で，OPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，帳票ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのFORMキーで設定しているフォルダに格納しておいてください。
    OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。
    パスは，ReportFilePathプロパティに指定することもできます。ReportFilePathプロパティにパスを指定しない場合は，次のことに注意してください。
    • フルパスを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのFORMキーには指定が要りません。
    • 相対パスを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのFORMキーで設定している起点フォルダ下にあるファイル名を指定してください。
    • ファイル名だけを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのFORMキーで設定しているフォルダにあるファイル名を指定してください。
  • 帳票ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • 帳票ファイルは，EUR Server Service稼働マシンに配置してください。

データ型

  • String（一つの帳票セットを指定する場合）
  • String配列（複数の帳票セットを指定する場合）


ReportFilePathプロパティ

ReportFilePathプロパティ

ReportFileNameプロパティで指定した帳票ファイルのパスを指定します。

解説

  • 帳票ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

データ型

String


ScriptCntlFileNameプロパティ

ScriptCntlFileNameプロパティ

Acrobat JavaScript定義ファイル名を指定します。

解説

  • EUR Server Serviceの環境設定ファイル（EURPM.ini）で，OPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，Acrobat JavaScript定義ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのSCRIPTCNTキーで設定しているフォルダに格納しておいてください。
    OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。
    パスは，ScriptCntlFilePathプロパティに指定することもできます。ScriptCntlFilePathプロパティにパスを指定しない場合は，次のことに注意してください。
    • フルパスを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのSCRIPTCNTキーには指定が要りません。
    • 相対パスを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのSCRIPTCNTキーで設定している起点フォルダ下にあるファイル名を指定してください。
    • ファイル名だけを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのSCRIPTCNTキーで設定しているフォルダにあるファイル名を指定してください。
  • Acrobat JavaScript定義ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • ScriptCntlFileNameプロパティは，OutputPDFReportメソッドでPDF形式ファイルを出力する場合，指定が有効になります。OutputPDFReportメソッド以外の場合は，ScriptCntlFileNameプロパティを指定しても無視されます。
  • Acrobat JavaScript定義ファイルは，EUR Server Service稼働マシンに配置してください。

データ型

String


ScriptCntlFilePathプロパティ

ScriptCntlFilePathプロパティ

ScriptCntlFileNameプロパティで指定したAcrobat JavaScript定義ファイルのパスを指定します。

解説

  • Acrobat JavaScript定義ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • ScriptCntlFilePathプロパティは，OutputPDFReportメソッドでPDF形式ファイルを出力する場合，指定が有効になります。OutputPDFReportメソッド以外の場合は，ScriptCntlFilePathプロパティを指定しても無視されます。

データ型

String


ServerAddressプロパティ

ServerAddressプロパティ

スプールサーバのIPアドレスを「255.255.255.255」形式で指定します。

解説

  • 次に示すどちらかの指定がある場合，ServerAddressプロパティは有効になります。それ以外の場合は，ServerAddressプロパティを指定しても無視されます。
    • PrintPMReportメソッドで印刷方式がスプールサーバ印刷方式（PrintMode=3），かつスプールサーバ指定方式がIPアドレス指定（ServerSelectMode=1）のとき
    • PrintPMReportメソッドで印刷方式が蓄積（PrintMode=2），かつスプールサーバ指定方式がIPアドレス指定（ServerSelectMode=1）のとき
  • ServerAddressプロパティを省略した場合は，デフォルト値（127.0.0.1）が仮定されます。

データ型

String


ServerPrinterNameプロパティ

ServerPrinterNameプロパティ

サーバのプリンタ名を指定します。プリンタ名は，OS上のプリンタ名を指定してください。

解説

  • プリンタ名を指定するときの注意
    プリンタ名は，次のことに注意して指定してください。
    • プリンタ名は，80バイト以内で指定してください。
    • プリンタ名には「"」および「,」を含めないでください。
  • 次に示す指定がある場合，ServerPrinterNameプロパティは有効になります。それ以外の場合は，ServerPrinterNameプロパティを指定しても無視されます。
    • PrintPMReportメソッドで印刷方式がスプールサーバ印刷方式（PrintMode=3），かつプリンタ指定方式がOS上のプリンタ名指定（PrinterSelectMode=1）のとき
    • PrintPMReportメソッドで印刷方式が蓄積（PrintMode=2），かつプリンタ指定方式がOS上のプリンタ名指定（PrinterSelectMode=1）のとき
    • PrintPMReportメソッドで印刷方式が帳票サーバ直接印刷方式（PrintMode=4），かつプリンタ指定方式がOS上のプリンタ名指定（PrinterSelectMode=1）のとき

データ型

String


ServerSelectModeプロパティ

ServerSelectModeプロパティ

スプールサーバの指定方法を選択します。

解説

指定できる値を次に示します。

  • 0：出力先名を指定します。
  • 1：スプールサーバのIPアドレスを指定します。

ServerSelectModeプロパティを省略した場合，または0，1以外の値を指定した場合は，0が仮定されます。

次に示すどちらかの指定がある場合，ServerSelectModeプロパティは有効になります。それ以外の場合は，ServerSelectModeプロパティを指定しても無視されます。

  • PrintPMReportメソッドで印刷方式がスプールサーバ印刷方式（PrintMode=3）のとき
  • PrintPMReportメソッドで印刷方式が蓄積（PrintMode=2）のとき

データ型

Long


ServerTrayNameプロパティ

ServerTrayNameプロパティ

サーバのプリンタのトレイ名を指定します。トレイ名は，OS上のプリンタのトレイ名を指定してください。

解説

Windows環境の場合
  • トレイ名を指定するときの注意
    トレイ名は，次のことに注意して指定してください。
    ・トレイ名は，80バイト以内で指定してください。
    ・トレイ名には「"」および「,」を含めないでください。
  • ServerTrayNameプロパティを指定しない場合は，ServerPrinterNameプロパティで指定したプリンタのデフォルトのトレイから給紙されます。
  • ServerTrayNameプロパティに指定したトレイ名が，出力先のプリンタで使用できない場合は，デフォルトのトレイから給紙されます。
  • 次に示す指定がある場合，ServerTrayNameプロパティは有効になります。それ以外の場合は，ServerTrayNameプロパティを指定しても無視されます。
    ・PrintPMReportメソッドで印刷方式がスプールサーバ印刷方式（PrintMode=3），かつプリンタ指定方式がOS上のプリンタ名指定（PrinterSelectMode=1）のとき
    ・PrintPMReportメソッドで印刷方式が蓄積（PrintMode=2），かつプリンタ指定方式がOS上のプリンタ名指定（PrinterSelectMode=1）のとき
    ・PrintPMReportメソッドで印刷方式が帳票サーバ直接印刷方式（PrintMode=4），かつプリンタ指定方式がOS上のプリンタ名指定（PrinterSelectMode=1）のとき
UNIX／Linux環境の場合
  • 給紙トレイ情報を指定します。ServerTrayNameプロパティを指定しない場合は，プリンタ定義ファイルのキーワード（DefaultCassette）に指定されているデフォルトのトレイから給紙されます。
    プリンタ定義ファイルの詳細については，「11.5　プリンタ定義ファイル」を参照してください。
  • 指定する給紙トレイ情報を次に示します。
    指定内容 | 給紙トレイ
    auto | 印刷用紙を自動で給紙します。出力する帳票の用紙サイズから給紙トレイを自動選択します。
    manual | 手差しトレイから印刷用紙を給紙します。
    トレイ番号 トレイ番号の給紙トレイから印刷用紙を給紙します。トレイ番号は，1～n（nはプリンタ定義ファイルのキーワードCassettesで指定した値）で指定します。
    6以上の値を指定した場合は自動給紙となります。
    注意
    ServerTrayNameプロパティでは次に示す指定があった場合，プリンタのハードウェアによって動作が異なります。
    • manualが指定されたとき
    • トレイ番号が指定されたとき
    • autoが指定されたのに，プリンタのパネルで給紙トレイが選択されたとき
    また，帳票の用紙サイズと給紙される用紙のサイズが異なる場合も，プリンタのハードウェアによって動作が異なります。
    帳票の用紙サイズと給紙される用紙のサイズを合わせておくか，または帳票の用紙サイズと異なる用紙に出力する場合は，あらかじめ試し印刷を実施してプリンタの動作を確認してください。

データ型

String


SortPrintプロパティ

SortPrintプロパティ

印刷部数の単位を指定します。

解説

指定できる値を次に示します。

  • 0：部単位で出力します。
  • 1：ページ単位で出力します。

SortPrintプロパティを省略した場合，0が仮定されます。

複数帳票を出力する場合は，SortPrintプロパティの指定に関係なく0が仮定されます。ただし，OutputMergeEPFReportメソッドで複数のEPF形式ファイルを統合して出力するときは，SortPrintプロパティの指定に従います。

SortPrintプロパティは，次に示すメソッドで印刷実行する場合，指定が有効になります。それ以外の場合は，SortPrintプロパティを指定しても無視されます。

  • PrintPMReportメソッド
  • OutputEPFReportメソッド
  • OutputMergeEPFReportメソッド

データ型

Long


SplitFileNameプロパティ

SplitFileNameプロパティ

帳票を分割または仕分けして蓄積する場合に，分割定義ファイルまたは仕分け定義ファイルのファイル名を指定します。

解説

  • SplitFileNameプロパティは，PrintPMReportメソッドで印刷方式が蓄積（PrintMode=2）の場合で，かつ次のどちらかの条件に当てはまるときに指定が有効になります。それ以外の場合は，SplitFileNameプロパティを指定しても無視されます。
    • 帳票を分割（SplitMode=3）または仕分け（SplitMode=2）する設定にしているとき。
    • 帳票を分割または仕分けするかどうかをEUR Server Serviceの環境設定ファイルの指定に従う（SplitMode=0）設定にしていて，かつEUR Server Serviceの環境設定ファイルのOPTIONセクションのSPLITMODEキーにPAGE（分割）またはKEY（仕分け）を指定しているとき。
  • ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • 分割定義ファイルまたは仕分け定義ファイルは，EUR Server - Adapter稼働マシンに配置してください。

データ型

String


SplitFilePathプロパティ

SplitFilePathプロパティ

SplitFileNameプロパティで指定した，分割定義ファイルまたは仕分け定義ファイルのパスを指定します。

解説

  • 指定されたフォルダのパスは，SplitFileNameプロパティで指定するファイルのデフォルトの場所になります。
  • パスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • SplitFilePathプロパティは，PrintPMReportメソッドで印刷方式が蓄積（PrintMode=2）の場合で，かつ次のどちらかの条件に当てはまるときに指定が有効になります。それ以外の場合は，SplitFilePathプロパティを指定しても無視されます。
    • 帳票を分割（SplitMode=3）または仕分け（SplitMode=2）する設定にしているとき。
    • 帳票を分割または仕分けするかどうかをEUR Server Serviceの環境設定ファイルの指定に従う（SplitMode=0）設定にしていて，かつEUR Server Serviceの環境設定ファイルのOPTIONセクションのSPLITMODEキーにPAGE（分割）またはKEY（仕分け）を指定しているとき。

データ型

String


SplitModeプロパティ

SplitModeプロパティ

蓄積時に，帳票を分割または仕分けするかどうかを指定します。

解説

指定できる値を次に示します。

  • 0：EUR Server Serviceの環境設定ファイル（EURPM.ini）のOPTIONセクションのSPLITMODEキーの指定に従います。
  • 1：分割または仕分けしないで蓄積します。
  • 2：帳票を仕分けして蓄積します。
  • 3：帳票を分割して蓄積します。

SplitModeプロパティの指定を省略した場合，0が仮定されます。

SplitModeプロパティは，PrintPMReportメソッドで印刷方式が蓄積（PrintMode=2）の場合に指定が有効になります。それ以外の場合は，SplitModeプロパティを指定しても無視されます。

データ型

Long


SpoolFileNameプロパティ

SpoolFileNameプロパティ

スプールデータに格納するファイルのファイル名を指定します。

解説

  • 格納ファイル名は，255バイト以内になるように指定してください。そのほか，格納ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • 「%N」を指定すると，00000001から始まる8桁の通し番号を設定できます。
  • SpoolFileNameプロパティを省略した場合は，自動的にファイル名が生成されます。自動的に生成されるファイル名は「ジョブID.epf」※です。
  • 複数のスプールデータに同一ファイル名が指定されている場合，スプールデータ取得時に同一パスで取得されると，ファイルが上書きされます。同一パスで取得する可能性のあるファイルは，別の格納ファイル名に指定することをお勧めします。
  • SpoolFileNameプロパティは，PrintPMReportメソッドで印刷方式が蓄積（PrintMode=2）の場合，指定が有効になります。それ以外の場合は，SpoolFileNameプロパティを指定しても無視されます。
    注※
    「ジョブID」の形式を次に示します。
    E＋ESFID＋処理実行日時＋通番フォルダ番号＋通し番号
    ESFID（2桁）：EURPMLS.iniのキーワードESFIDに指定された値（0～99）
    処理実行日時（17桁）：YYYYMMDDhhmmssmmm
    通番フォルダ番号（7桁）：0000001～2000000
    通し番号（9桁）：000000001～999999999
    通番フォルダ番号が2000000を超えた場合は，エラー（KEEY430-S）になります。
    通し番号が999999999を超えた場合は，000000003に戻ります。

データ型

String


SpoolLimitプロパティ

SpoolLimitプロパティ

スプールデータの蓄積期限日を指定します。

解説

蓄積期限日は，日付または日数で指定してください。

日付で指定する場合
  • 「YYYYMMDD」の形式で指定してください。
  • 年（西暦）は4桁，月と日は2桁で入力します。
  • 月，または日が1～9の場合は，ゼロ埋めをして入力します。
  • 指定できる値の上限は，20380118（2038年1月18日）です。
  • 過去の日付は指定できません。
（指定例）20120521，20141008
日数で指定する場合
  • 「+XXX」の形式で指定してください。
  • 「XXX」には，蓄積実行時からの保管日数を指定します。指定できる値は000～999です。0を指定した場合は，翌日にスプールデータが削除されます。
  • 2038年1月18日を超える日数は指定できません。
（指定例）+030，+999

SpoolLimitプロパティの指定がない場合，蓄積期限日は蓄積を要求したEUR Server - Adapterの環境設定ファイル（EURPMADP.ini）のOPTIONセクションのSPOOLLIMITキーの指定に従います。

SpoolLimitプロパティは，PrintPMReportメソッドで印刷方式が蓄積（PrintMode=2）の場合，指定が有効になります。それ以外の場合は，SpoolLimitプロパティを指定しても無視されます。

データ型

String


SpoolTitleプロパティ

SpoolTitleプロパティ

スプールタイトルを指定します。

解説

  • スプールタイトルには，任意文字列を指定できます。次のことに注意して指定してください。
    • スプールタイトルは，255バイト以内で指定してください。
    • スプールタイトルには「"」および「,」を含めないでください。
  • SpoolTitleプロパティは，次に示すメソッドで印刷またはファイル出力を実行する場合，指定が有効になります。それ以外の場合は，SpoolTitleプロパティを指定しても無視されます。
    • PrintPMReportメソッドで印刷方式がスプールサーバ印刷方式（PrintMode=3）のとき
    • PrintPMReportメソッドで印刷方式がクライアント印刷方式（PrintMode=1）のとき
    • PrintPMReportメソッドで印刷方式が蓄積（PrintMode=2）のとき
    • PrintPMReportメソッドで印刷方式が帳票サーバ直接印刷方式（PrintMode=4）のとき
    • OutputEPFReportメソッド，およびOutputEURReportメソッドで印刷実行するとき
    • OutputMergeEPFReportメソッドで複数のEPF形式ファイルを統合して出力するとき
  • SpoolTitleプロパティの指定を省略したときや空文字を指定したときは，スプールタイトル情報は未設定となります。スプールタイトル情報が未設定の場合，印刷時のスプールタイトルに出力される内容は次のとおりです。
    • PrintPMReportメソッド，およびOutputEPFReportメソッドの場合
      文書情報設定ファイルでTITLEキーを設定しているときは，TITLEキーの指定値が出力されます。TITLEキーを設定していないときは，「HITACHI Report - 帳票ファイル名」が出力されます。
    • OutputEURReportメソッドの場合
      文書情報設定ファイルでTITLEキーを設定しているときは，TITLEキーの指定値が出力されます。TITLEキーを設定していないときは，次に示す表示形式で出力されます。
      ・単一様式帳票の場合
        「HITACHI Report - EUR形式ファイル名（拡張子なし）」
      ・複数の帳票セットを指定した帳票，または複数様式を指定した帳票の場合
        「EUR形式ファイル名（拡張子なし）」
    • OutputMergeEPFReportメソッドの場合
      最初に指定するEPF形式ファイルの帳票ファイル名が出力されます。

データ型

String


UserDataFileNameプロパティ

UserDataFileNameプロパティ

ユーザ定義データファイル名または可変記号値定義ファイル名を指定します。

解説

  • 指定するファイル名は，ReportFileNameプロパティで指定したファイル名と同じ数を指定してください。
  • ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • ユーザ定義データファイルは，EUR Server - Adapter稼働マシンに配置してください。

データ型

  • String（一つの帳票セットを指定する場合）
  • String配列（複数の帳票セットを指定する場合）

指定例

複数の帳票セットを指定する場合，一部の帳票に対してユーザ定義データファイル（または可変記号値定義ファイル）の指定を省略したいときは，配列の要素に空文字を指定してください。

2番目の帳票のユーザ定義データファイルの指定を省略する場合の例を次に示します。

' 帳票ファイル名を配列fmsに指定
fms(0)="Sample1.fms"
fms(1)="Sample2.fms"
fms(2)="Sample3.fms"
' ユーザ定義データファイル名を配列usrに指定
usr(0)="Data1.csv"
usr(1)=""
usr(2)="Data3.csv"


UserDataFilePathプロパティ

UserDataFilePathプロパティ

UserDataFileNameプロパティで指定したユーザ定義データファイルのパス，または可変記号値定義ファイルのパスを指定します。

解説

  • ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

データ型

String


ViewerPreferenceFileNameプロパティ

ViewerPreferenceFileNameプロパティ

ビューアプレファレンス定義ファイル名を指定します。

解説

  • EUR Server Serviceの環境設定ファイル（EURPM.ini）で，OPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，ビューアプレファレンス定義ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのPREFERENCEキーで設定しているフォルダに格納しておいてください。
    OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。
    パスは，ViewerPreferenceFilePathプロパティに指定することもできます。ViewerPreferenceFilePathプロパティにパスを指定しない場合は，次のことに注意してください。
    • フルパスを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのPREFERENCEキーには指定が要りません。
    • 相対パスを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのPREFERENCEキーで設定している起点フォルダ下にあるファイル名を指定してください。
    • ファイル名だけを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのPREFERENCEキーで設定しているフォルダにあるファイル名を指定してください。
  • ビューアプレファレンス定義ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • ViewerPreferenceFileNameプロパティは，OutputPDFReportメソッドでPDF形式ファイルを出力する場合，指定が有効になります。OutputPDFReportメソッド以外の場合は，ViewerPreferenceFileNameプロパティを指定しても無視されます。
  • ビューアプレファレンス定義ファイルは，EUR Server Service稼働マシンに配置してください。

データ型

String


ViewerPreferenceFilePathプロパティ

ViewerPreferenceFilePathプロパティ

ViewerPreferenceFileNameプロパティで指定したビューアプレファレンス定義ファイルのパスを指定します。

解説

  • ビューアプレファレンス定義ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • ViewerPreferenceFilePathプロパティは，OutputPDFReportメソッドでPDF形式ファイルを出力する場合，指定が有効になります。OutputPDFReportメソッド以外の場合は，ViewerPreferenceFilePathプロパティを指定しても無視されます。

データ型

String


XLSXFileNameプロパティ

XLSXFileNameプロパティ

出力するExcel形式ファイル名を指定します。

解説

  • OutputXLSXReportメソッドでExcel形式ファイルを出力する場合は，XLSXFileNameプロパティを必ず指定してください。OutputXLSXReportメソッド以外の場合は，XLSXFileNameプロパティを指定しても無視されます。
  • Excel形式ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • Excel形式ファイルの拡張子は，*.xlsxです。Excel形式ファイル名は，拡張子を含めて指定してください。

データ型

String


XLSXFilePathプロパティ

XLSXFilePathプロパティ

XLSXFilePathプロパティで指定したExcel形式ファイルのパスを指定します。

解説

  • 指定されたフォルダのパスは，XLSXFileNameプロパティで指定するExcel形式ファイルのデフォルトの場所になります。
  • XLSXFilePathプロパティは，OutputXLSXReportメソッドでExcel形式ファイルを出力する場合，指定が有効になります。OutputXLSXReportメソッド以外の場合は，XLSXFilePathプロパティを指定しても無視されます。
  • パスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

データ型

String


エラー情報

6.5　エラー情報

ActiveX起動部品，またはSS-ActiveX起動部品を使用して実行している場合にエラーが発生したときは，ErrオブジェクトのNumberプロパティに終了コード，Descriptionプロパティにメッセージが設定されます。

＜この節の構成＞
6.5.1　ActiveX起動部品実行時のエラー情報一覧
6.5.2　Err.Numberプロパティ（終了コード）
6.5.3　Err.Descriptionプロパティ（メッセージ文）


ActiveX起動部品実行時のエラー情報一覧

6.5.1　ActiveX起動部品実行時のエラー情報一覧

ActiveX起動部品実行時のエラー情報の一覧を次に示します。

表6-6　ActiveX起動部品実行時のエラー情報の一覧

終了コード | メッセージ文
-201 | プロパティ(プロパティ名)の指定値に誤りがあります。
-202 | プロパティ(プロパティ名)が指定されていません。
-203 | マッピングデータファイルの読み込みに失敗しました。
-204 | ユーザ定義データファイルの読み込みに失敗しました。
-205 | パラメタに誤りがあります。
-206 | 必須パラメタの指定がありません。
-207 | サーバプリンタ名の指定がありません。
-208 | 原因不明のエラーで処理が中断されました。EUR Server Serviceの状態を確認してください。
-209 | 印刷処理で警告が発生しました。(nnn)
-210 | 環境設定ファイルに不正があります。詳細コード = [nnnnnn]
-211 | ログファイルの書き込みに失敗しました。
-212 | EUR Server Serviceへの接続に失敗しました。
-213 | ジョブを起動しました。
-214 | ジョブを終了しました。
-215 | メモリ不足が発生しました。
-216 | 通信タイムアウトが発生しました。
-217 | システムエラーが発生しました。
-218 | 出力先一覧取得処理でエラーが発生しました。（nnn）
-219 | プリンタクラス一覧取得処理でエラーが発生しました。（nnn）
-221 | 印刷処理でエラーが発生しました。（nnn）
-222 | クライアントプリンタ名の指定がありません。
-223 | PDF形式ファイル出力処理でエラーが発生しました。(nnn)
-224 | PDF形式ファイル出力処理で警告が発生しました。(nnn)
-225 | EPF形式ファイル出力処理でエラーが発生しました。(nnn)
-226 | EPF形式ファイル出力処理で警告が発生しました。(nnn)
-227 | PDF形式ファイルの初期化に失敗しました。
-228 | EPF形式ファイルの初期化に失敗しました。
-229 | PDF形式ファイルの作成に失敗しました。
-230 | EPF形式ファイルの作成に失敗しました。
-231 | 指定されたPDF形式ファイルはほかの人が使用中です。
-232 | 指定されたEPF形式ファイルはほかの人が使用中です。
-233 | 帳票セット指定ファイルのフォーマットが不正です。
-234 | 帳票セット指定ファイルの読み込みに失敗しました。
-235 | しおり定義ファイルの読み込みに失敗しました。
-236 | 文書しおり定義ファイルの読み込みに失敗しました。
-237 | EUR Server Serviceでコネクション数が限界値をオーバーしました。
-238 | EUR Spool Serviceでコネクション数が限界値をオーバーしました。
-239 | EUR Client Serviceでコネクション数が限界値をオーバーしました。
-241 | 指定されたEUR形式ファイルはほかの人が使用中です。
-242 | EUR形式ファイルの初期化に失敗しました。
-243 | EUR形式ファイル出力処理でエラーが発生しました。(nnn)
-244 | EUR形式ファイル出力処理で警告が発生しました。(nnn)
-245 | EUR形式ファイルの作成に失敗しました。
-246 | EUR Server Serviceのバージョンが不正です。
-247 | レジストリに不正があります。詳細コード = [nnnnnn]
-248 | 暗号化設定ファイルの読み込みに失敗しました。
-249 | 指定されたマッピングデータファイルが存在しません。
-250 | 指定されたユーザ定義データファイルが存在しません。
-251 | 指定されたしおり定義ファイルが存在しません。
-252 | 指定された文書しおり定義ファイルが存在しません。
-253 | 指定された暗号化設定ファイルが存在しません。
-255 | プリンタ一覧取得処理でエラーが発生しました。（nnn）
-256 | トレイ一覧取得処理でエラーが発生しました。（nnn）
-257 | 蓄積処理でエラーが発生しました。（nnn）
-258 | 蓄積処理で警告が発生しました。（nnn）
-259 | PDF仕分け定義ファイルの読み込みに失敗しました。
-260 | 指定されたPDF仕分け定義ファイルが存在しません。
-261 | EPF形式ファイルの読み込みに失敗しました。
-262 | 指定されたEPF形式ファイルが存在しません。
-263 | XLSX形式ファイル出力処理でエラーが発生しました。(nnn)
-264 | XLSX形式ファイル出力処理で警告が発生しました。(nnn)
-265 | 指定されたXLSX形式ファイルはほかの人が使用中です。
-266 | XLSX形式ファイルの初期化に失敗しました。
-267 | XLSX形式ファイルの作成に失敗しました。
-269 | 統合対象EPF形式ファイルの指定数が有効範囲外です。
-270 | 複数EPF形式ファイルの統合処理でエラーが発生しました。（nnn）
-271 | 統合対象EPF形式ファイルの読み込みに失敗しました。
-272 | 指定された統合対象EPF形式ファイルが存在しません。
-273 | An attempt to load string resource DLL has failed. Error:[nnn]
-274 | 仕分け/分割定義ファイルの読み込みに失敗しました。
-275 | 出力すべき帳票セットがありません。(950)


Err.Numberプロパティ（終了コード）

6.5.2　Err.Numberプロパティ（終了コード）

ActiveX起動部品，またはSS-ActiveX起動部品のメソッドの実行でエラーが発生した場合，ErrオブジェクトのNumberプロパティに終了コードが設定，または更新されます。正常終了した場合は，終了コードは更新されません。そのため，ActiveX起動部品，またはSS-ActiveX起動部品のメソッドの実行後にNumberプロパティの終了コードを参照しても正しいエラー判定ができません。

ActiveX起動部品，またはSS-ActiveX起動部品のメソッドを実行する前は，Numberプロパティに終了コードが設定されていない（エラーが発生していない）ことを判定してからEUR Server Serviceのメソッドを実行することをお勧めします。

終了コードとメッセージの一覧については，「6.5.1　ActiveX起動部品実行時のエラー情報一覧」，または「7.5.1　SS-ActiveX起動部品実行時のエラー情報一覧」を参照してください。エラーの対処については，マニュアル「EUR メッセージ」を参照してください。


Err.Descriptionプロパティ（メッセージ文）

6.5.3　Err.Descriptionプロパティ（メッセージ文）

ErrオブジェクトのDescriptionプロパティは，エラー，または警告発生時のメッセージが設定されます。終了コードとメッセージの一覧については，「6.5.1　ActiveX起動部品実行時のエラー情報一覧」，または「7.5.1　SS-ActiveX起動部品実行時のエラー情報一覧」を参照してください。エラーの対処については，マニュアル「EUR メッセージ」を参照してください。


SS-ActiveX起動部品

7.　SS-ActiveX起動部品

この章では，EUR Server - Spool Serviceで提供するSS-ActiveX起動部品を使用した帳票出力について説明します。

＜この章の構成＞
7.1　SS-ActiveX起動部品とは
7.2　SS-ActiveX起動部品のメソッドとプロパティ
7.3　SS-ActiveX起動部品のメソッド仕様
7.4　SS-ActiveX起動部品のプロパティ仕様
7.5　エラー情報


SS-ActiveX起動部品とは

7.1　SS-ActiveX起動部品とは

EUR Server - Spool Service Adapterは，Visual Basic ScriptやVisual Basicなどで開発するサーバアプリケーションから，EUR Server - Spool Serviceを利用できる部品を提供しています。これを，SS-ActiveX起動部品といいます。

SS-ActiveX起動部品を利用することで，EUR Server - Spool Service上に蓄積されているスプールデータ（ESF形式ファイル）に対して業務アプリケーションからの操作指示をEUR Server - Spool Serviceに送信できます。

＜この節の構成＞
7.1.1　ファイル名
7.1.2　プログラムIDとコントロール名
7.1.3　提供するクラス
7.1.4　構文


ファイル名

7.1.1　ファイル名

EURPMLSADP.ocx
SS-ActiveX起動部品のファイルです。インストール先フォルダ\SpoolAdapter\Program\下にあります。


プログラムIDとコントロール名

7.1.2　プログラムIDとコントロール名

SS-ActiveX起動部品のプログラムIDおよびコントロール名は，EUR Server - Spool Service Adapterをインストールしたときに登録されます。

EURPMLS.Exec
SS-ActiveX起動部品のプログラムIDです。
EURPMLSADP ActiveX コントロールモジュール
SS-ActiveX起動部品のコントロール名です。


提供するクラス

7.1.3　提供するクラス

SS-ActiveX起動部品では，EUR Server - Spool Serviceの制御を行うEURPMLSADPLib.EURPMLSAdapterクラスを提供します。

EURPMLSADPLib.EURPMLSAdapterクラスでは，印刷，削除などのオプションを指定するプロパティを設定するメソッドと，印刷，削除などを行うメソッドを提供します。

EURPMLSADPLib.EURPMLSAdapterクラスは次のように指定します。

Public Class EURPMLSADPLib.EURPMLSAdapter

Visual Basic ScriptやVisual Basicで開発するサーバアプリケーションから，次の手順で帳票を出力します。

  1. SS-ActiveX起動部品の構築
  2. プロパティの設定
    ジョブID，印刷開始ページなどのプロパティを設定します。
  3. スプールデータの印刷
    蓄積印刷メソッド（PrintSpoolReportメソッドなど）を呼び出してスプールデータを蓄積印刷します。

3.の処理で発生したエラー，または発生するエラーは，例外を処理するようにプログラムに記述します。


構文

7.1.4　構文

SS-ActiveX起動部品を構築する場合とEURPMLSADPLib.EURPMLSAdapterクラスを生成する場合の構文を次に示します。

＜この項の構成＞
(1)　SS-ActiveX起動部品を構築する場合
(2)　EURPMLSADPLib.EURPMLSAdapterクラスを生成する場合

(1)　SS-ActiveX起動部品を構築する場合

SS-ActiveX起動部品を構築する場合は，次のように指定します。

Visual Basic Scriptの場合
Dim eurpmls As Object
Set eurpmls=Server.CreateObject("EURPMLS.Exec")
Visual Basicの場合
Dim eurpmls As Object
Set eurpmls=CreateObject("EURPMLS.Exec")
パラメタ
  • eurpmlsには，Server.CreateObjectまたはCreateObjectの呼び出しによって作成されるオブジェクト名を指定します。
  • EURPMLS.Execは，SS-ActiveX起動部品のプログラムIDです。
    ASPファイルのあるVisual Basic ScriptのCreateObject関数にプログラムIDを指定して，SS-ActiveX起動部品を生成してください。

(2)　EURPMLSADPLib.EURPMLSAdapterクラスを生成する場合

EURPMLSADPLib.EURPMLSAdapterクラスを生成することで，SS-ActiveX起動部品を生成することもできます。この場合は，クラスを生成する前に，ユーザアプリケーションプロジェクトのコントロールまたはCOMの参照設定に，コントロール名「EURPMLSADP ActiveX コントロール モジュール」を追加してください。

EURPMLSADPLib.EURPMLSAdapterクラスを生成する場合は，次のように指定します。

Dim eurpmls As EURPMLSADPLib.EURPMLSAdapter
Set eurpmls=new EURPMLSADPLib.EURPMLSAdapter
パラメタ
  • eurpmlsには，EURPMLSADPLib.EURPMLSAdapterクラス型の任意のオブジェクト名を指定します。
  • new操作でEURPMLSADPLib.EURPMLSAdapterクラスを生成してください。


SS-ActiveX起動部品のメソッドとプロパティ

7.2　SS-ActiveX起動部品のメソッドとプロパティ

SS-ActiveX起動部品が提供するメソッドとプロパティの一覧を示します。

＜この節の構成＞
7.2.1　メソッド一覧
7.2.2　プロパティ一覧
7.2.3　指定値に使用できない文字について


メソッド一覧

7.2.1　メソッド一覧

SS-ActiveX起動部品が提供するメソッドの一覧を次に示します。

表7-1　 SS-ActiveX起動部品が提供するメソッド一覧

種類 | メソッド | 概要
蓄積操作メソッド | DeleteSpoolFile | 指定したジョブIDのスプールデータを削除したり，蓄積期限を経過したスプールデータを削除したりします。
 | GetSpoolFile | 指定したジョブIDのスプールデータからEPF形式ファイルを取得します。
 | GetSpoolFileAttribute | 指定したジョブIDのスプールデータの属性情報を取得します。
 | GetSpoolFileOutline | 指定条件に合ったEUR Server - Spool Serviceのスプールデータの一覧を取得します。
 | PrintSpoolReport | 指定したジョブIDのスプールデータを印刷します。
 | SetSpoolFileAttribute | 指定したジョブIDのスプールデータの属性情報を変更します。
構成定義情報取得メソッド※ | GetPrinterClassList | 指定したスプールサーバのEUR Server - Spool Serviceに登録されているプリンタクラス一覧をPrinterClassListプロパティに取得します。
 | GetPrinterList | 指定したスプールサーバのOS上のプリンタ一覧をServerPrinterListプロパティに取得します。
 | GetTrayList | 指定したスプールサーバのOS上のプリンタのトレイ一覧をServerTrayListプロパティに取得します。
監査ログメソッド | ChangeAuditLog | 指定したスプールサーバ上で出力する監査ログを切り替えます。
プロパティ初期化メソッド | Initialize | 指定されたすべてのプロパティをクリアにして，初期状態に戻します。
注※
UNIX／Linux環境の場合，構成定義情報取得メソッドは指定できません。


プロパティ一覧

7.2.2　プロパティ一覧

SS-ActiveX起動部品が提供するプロパティを表6-2に示します。

SS-ActiveX起動部品が提供するプロパティは，蓄積操作メソッド，および構成定義情報取得メソッドで使用します。表6-2の表見出しの番号は，次に示すメソッドに対応しています。

表見出しの番号 | 対応するメソッド
1 | GetSpoolFileOutline
2 | GetSpoolFileAttribute
3 | SetSpoolFileAttribute
4 | PrintSpoolReport
5 | GetSpoolFile
6 | DeleteSpoolFile
7 | GetPrinterClassList
8 | GetPrinterList
9 | GetTrayList
10 | ChangeAuditLog

表7-2　SS-ActiveX起動部品が提供するプロパティ一覧

プロパティ
           設定内容
           データ型
           蓄積操作メソッド 構成定義情報取得メソッド 監査ログメソッド
1 2 3 4 5 6 7 8 9 10
ClientAddress 蓄積クライアント印刷時のクライアントPCのIPアドレス String － □ △ △ － － － － － －
ClientPrinterName スプールデータのクライアントプリンタ名 String － □ △ △ － － － － － －
ClientTrayName スプールデータのクライアントプリンタのトレイ名 String － □ △ △ － － － － － －
CreateIPAddress スプールデータを作成したマシンのIPアドレス String － □ － － － － － － － －
CreateLSVersion スプールデータのフォーマットバージョン String － □ － － － － － － － －
CreateTime スプールデータの作成日時
  • GetSpoolFileOutlineメソッドを呼び出したあと
    String配列
  • GetSpoolFileAttributeメソッドを呼び出したあと
    String
 □ □ － － － － － － － －
DeleteKind スプールデータ削除時の削除種別 Long － － － － － △ － － － －
DispPrintDlg 蓄積クライアント印刷時のダイアログ表示モード Long － □ △ △ － － － － － －
EnableGet スプールデータ内のEPF形式ファイルの取得可否 Boolean － □ △ － － － － － － －
ExecPrintCount スプールデータの印刷実行回数 Long － □ － － － － － － － －
ExecutablePrintMode スプールデータの実行可能印刷方式 Long － □ △ － － － － － － －
GroupName スプールデータの振り分けグループ名 String － □ △ △ － － － － － －
JobID ジョブID String配列 □ － － － － － － － － －
JobKeyCategory スプールデータのジョブ検索キー分類 String配列 － □ △ － － － － － － －
JobKeyData スプールデータのジョブ検索キー値 String配列 － □ △ － － － － － － －
MaxPrintCount スプールデータの印刷上限回数 Long － □ △ － － － － － － －
OutputFileName スプールデータから取得後のEPF形式ファイル名 String － － － － △ － － － － －
OutputFilePath スプールデータからEPF形式ファイルを取得するフォルダのパス String － － － － △ － － － － －
PageNum スプールデータ内のEPF形式ファイルのページ数
  • GetSpoolFileOutlineメソッドを呼び出したあと
    Long配列
  • GetSpoolFileAttributeメソッドを呼び出したあと
    Long
 □ □ － － － － － － － －
PaperOrientation 用紙の向き Long － － － △ △ － － － － －
PrintCopies 印刷部数 Long － － － △ △ － － － － －
PrintEndPage 蓄積スプールサーバ印刷の終了ページ Long － － － －／△ － － － － － －
PrinterClassList プリンタクラス一覧 String二次元配列 － － － － － － □ － － －
PrinterClassName スプールデータのプリンタクラス名
  • GetSpoolFileOutlineメソッドを呼び出したあと
    String配列
  • GetSpoolFileAttributeメソッドを呼び出したあと
    String
  • SetSpoolFileAttributeメソッド，PrintSpoolReportメソッド，またはGetSpoolFileメソッドを呼び出す前
    String
 □ □ △ △ △ － － － － －
PrinterSelectMode 蓄積スプールサーバ印刷方式のプリンタ指定方式 Long － □ △ △ － － － － － －
PrintMode 蓄積印刷方式 Long － － － △ － － － － － －
PrintResult スプールデータの印刷結果
  • GetSpoolFileOutlineメソッドを呼び出したあと
    Long配列
  • GetSpoolFileAttributeメソッドを呼び出したあと
    Long
 □ □ － － － － － － － －
PrintStartPage 蓄積スプールサーバ印刷の開始ページ Long － － － －／△ － － － － － －
PrintTime スプールデータの印刷日時 String － □ － － － － － － － －
ReportAddressKeyCategory スプールデータの宛先キーの分類 String － □ － － － － － － － －
ReportAddressKeyData スプールデータの宛先キーの値 String － □ － － － － － － － －
SearchCreateTimeEnd ファイル作成日時でスプールデータを検索するときの検索終了日時 String △ － － － － － － － － －
SearchCreateTimeStart ファイル作成日時でスプールデータを検索するときの検索開始日時 String △ － － － － － － － － －
SearchJobID スプールデータを検索するときのジョブID
  • PrintSpoolReportメソッド，GetSpoolFileメソッド，またはDeleteSpoolFileメソッドを呼び出す前
    String（一つのジョブIDを指定する場合）
    String配列（複数のジョブIDを指定する場合）
  • 上記以外のメソッドを呼び出す前
    String
 △ ○ ○ ○ ○ ○／－ － － － －
SearchJobKeyCategory スプールデータを検索するときのジョブ検索キーの分類 String配列 △ － － － － － － － － －
SearchJobKeyData スプールデータを検索するときのジョブ検索キーの値 String配列 △ － － － － － － － － －
SearchPrinterClassName プリンタクラス名でスプールデータを検索するときのプリンタクラス名 String △ － － － － － － － － －
SearchReportAddressKeyCategory 検索キーでスプールデータを検索するときの検索キーの分類 String △ － － － － － － － － －
SearchReportAddressKeyData 検索キーでスプールデータを検索するときの検索キーの値 String △ － － － － － － － － －
SearchSpoolFileName 格納されているEPF形式ファイル名でスプールデータを検索するときのEPF形式ファイル名 String △ － － － － － － － － －
ServerAddress スプールサーバのIPアドレス String △ △ △ △ △ △ △ △ △ △
ServerPrinterList スプールサーバでのOS上のプリンタ一覧 String配列 － － － － － － － □ － －
ServerPrinterName スプールサーバでのOS上のプリンタ名 String － □ △ △ － － － － ○ －
ServerTrayList スプールサーバでのOS上のプリンタのトレイ一覧 String配列 － － － － － － － － □ －
ServerTrayName スプールサーバでのOS上のプリンタのトレイ名 String － □ △ △ － － － － － －
SortPrint 印刷部数の単位 Long － － － △ △ － － － － －
SpoolFileName スプールデータ内のEPF形式ファイル名
  • GetSpoolFileOutlineメソッドを呼び出したあと
    String配列
  • GetSpoolFileAttributeメソッドを呼び出したあと
    String
 □ □ － － － － － － － －
SpoolFileSize スプールデータ内のEPF形式ファイルのサイズ（バイト） Long － □ － － － － － － － －
SpoolHistory スプールデータの履歴 String二次元配列 － □ － － － － － － － －
SpoolLimit スプールデータの蓄積期限日 String － □ △ － － － － － － －
SpoolPath 常に""を出力
  • GetSpoolFileOutlineメソッドを呼び出したあと
    String配列
  • GetSpoolFileAttributeメソッドを呼び出したあと
    String
 □ □ － － － － － － － －
SpoolTitle スプールタイトル String － － － △ △ － － － － －
（凡例）
○：必ず指定します。
△：指定を省略できます。
□：結果を出力します。
－：指定できません。


指定値に使用できない文字について

7.2.3　指定値に使用できない文字について

オプションの指定値には，制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」は使用できません。これらの文字を指定した場合，帳票管理GUI，［EUR Server Service 構成定義］ダイアログ，［EUR Spool Service 構成定義］ダイアログ，および［EUR Client 構成定義］ダイアログを操作できないことがあります。


SS-ActiveX起動部品のメソッド仕様

7.3　SS-ActiveX起動部品のメソッド仕様

SS-ActiveX起動部品が提供するメソッドの詳細を説明します。

＜この節の構成＞
ChangeAuditLogメソッド
DeleteSpoolFileメソッド
GetPrinterClassListメソッド
GetPrinterListメソッド
GetSpoolFileメソッド
GetSpoolFileAttributeメソッド
GetSpoolFileOutlineメソッド
GetTrayListメソッド
Initializeメソッド
PrintSpoolReportメソッド
SetSpoolFileAttributeメソッド


ChangeAuditLogメソッド

ChangeAuditLogメソッド

指定したスプールサーバ上で出力する監査ログを切り替えます。

形式

ChangeAuditLog()

パラメタ

なし

解説

ChangeAuditLogメソッドは，スプールサーバ上で出力する監査ログの切り替えが終了した時点で呼び出し元に制御が戻ります。

実行時にエラーが発生した場合，Err.Numberプロパティに終了コード，Err.Descriptionプロパティにメッセージが設定されます。

戻り値

なし

データ型

Empty

呼び出し例

' ChangeAuditLog実行
Private Sub SUB_ChangeAuditLog()
    Err.Clear
    On Error GoTo Err_Trap
    List5.Clear

    Dim objEURPMLS
    Set objEURPMLS = CreateObject("EURPMLS.Exec")

    objEURPMLS.ServerAddress = "255.255.***.***"
    ''監査ログの切り替え
    Call objEURPMLS.ChangeAuditLog

Err_Trap:
    List5.AddItem "GetAttr Err.Number=(" & Err.Number & ")"
    List5.AddItem "GetAttr Err.Description=(" & Err.Description & ")"

    If Err.Number = 0 Then
    End If

    Set objEURPMLS = Nothing

End Sub


DeleteSpoolFileメソッド

DeleteSpoolFileメソッド

指定したジョブIDのスプールデータを削除したり，蓄積期限を経過したスプールデータを削除したりします。スプールデータの削除，および蓄積期限切れスプールデータの一括削除については，マニュアル「EUR 帳票出力 機能解説 EUR Server編」を参照してください。

形式

DeleteSpoolFile()

パラメタ

なし

解説

DeleteSpoolFileメソッドは，スプールサーバ上のスプールデータ内の削除が終了した時点で呼び出し元に制御が戻ります。

実行時にエラーが発生した場合，Err.Numberプロパティに終了コード，Err.Descriptionプロパティにメッセージが設定されます。

戻り値

なし

データ型

Empty

呼び出し例

' DeleteSpoolFile実行
Private Sub SUB_DeleteSpoolFile()
    Err.Clear
    On Error GoTo Err_Trap
    List5.Clear

    Dim objEURPMLS
    Dim JobID(3) As String

    Set objEURPMLS = CreateObject("EURPMLS.Exec")

    objEURPMLS.ServerAddress = "255.255.***.***"
    ''削除種別＝「通常」の設定
    If 削除種別 = "通常" Then
        objEURPMLS.DeleteKind = 0

        ''ジョブＩＤの設定
        Dim lstSearchJobID(3) As String

        lstSearchJobID(0) = "E00200605291249433190000001******004"
        lstSearchJobID(1) = "E00200605291252460280000001******005"
        lstSearchJobID(2) = "E00200605291252461380000001******006"
        lstSearchJobID(3) = "E00200605291252462630000001******007"

        objEURPMLS.SearchJobID = lstSearchJobID

    ElseIf 削除種別 = "一括" Then
        ''削除種別＝「期限切れ一括削除」の設定
        objEURPMLS.DeleteKind = 1
    End If
    ''削除実行
    Call objEURPMLS.DeleteSpoolFile

Err_Trap:
    List5.AddItem "GetAttr Err.Number=(" & Err.Number & ")"
    List5.AddItem "GetAttr Err.Description=(" & Err.Description & ")"

    Set objEURPMLS = Nothing

End Sub


GetPrinterClassListメソッド

GetPrinterClassListメソッド

スプールサーバのプリンタクラス一覧を取得します。

形式

GetPrinterClassList()

パラメタ

なし

解説

指定したスプールサーバのEUR Server - Spool Serviceに登録されているプリンタクラス一覧をPrinterClassListプロパティに取得します。

GetPrinterClassListメソッドは，スプールサーバ上のプリンタクラス一覧の取得が終了した時点で呼び出し元に制御が戻ります。

実行時にエラーが発生した場合，Err.Numberプロパティに終了コード，Err.Descriptionプロパティにメッセージが設定されます。

UNIX／Linux環境の場合，プリンタクラス一覧の取得はサポートしていません。UNIX／Linux環境のEUR Server - Spool Serviceに対して，プリンタクラス一覧の取得を実行した場合はエラーとなります。

戻り値

なし

データ型

Empty

呼び出し例

'GetPrinterClassList実行
Private Sub SUB_GetPrinterClassList()
    Err.Clear
    On Error GoTo Err_Trap
    List5.Clear

    Dim objEURPMLS
    Dim iLower, iUpper, I As Integer
    Dim jLower, jUpper, J As Integer
    Dim sEntry  As String

    Set objEURPMLS = CreateObject("EURPMLS.Exec")

    objEURPMLS.ServerAddress = "255.255.***.***"
    ''プリンタクラス一覧の取得
    objEURPMLS.GetPrinterClassList

Err_Trap:
    List5.AddItem "Err.Number=(" & Err.Number & ")"
    List5.AddItem "Err.Description=(" & Err.Description & ")"

    If Err.Number = 0 Then
        List5.AddItem ""
        List5.AddItem "★★★★★ 結果出力ココカラ ★★★★★"
        Dim cstPrinterClsList As Variant
        cstPrinterClsList = objEURPMLS.PrinterClassList

        iLower = LBound(cstPrinterClsList, 1)
        iUpper = UBound(cstPrinterClsList, 1)
        jLower = LBound(cstPrinterClsList, 2)
        jUpper = UBound(cstPrinterClsList, 2)
        For I = iLower To iUpper
            sEntry = ""
            For J = jLower To jUpper
                If J > 0 Then
                    sEntry = sEntry + ","
                End If
                sEntry = sEntry + cstPrinterClsList(I, J)
            Next
            List5.AddItem sEntry
        Next
        List5.AddItem "★★★★★ 結果出力ココマデ ★★★★★"
    End If

    Set objEURPMLS = Nothing

End Sub


GetPrinterListメソッド

GetPrinterListメソッド

指定したスプールサーバのOS上のプリンタ一覧をServerPrinterListプロパティに取得します。

形式

GetPrinterList()

パラメタ

なし

解説

GetPrinterListメソッドは，OS上のプリンタ一覧の取得が終了した時点で呼び出し元に制御が戻ります。

実行時にエラーが発生した場合，Err.Numberプロパティに終了コード，Err.Descriptionプロパティにメッセージが設定されます。

UNIX／Linux環境の場合，プリンタ一覧の取得はサポートしていません。UNIX／Linux環境のEUR Server - Spool Serviceに対して，プリンタ一覧の取得を実行した場合はエラーとなります。

戻り値

なし

データ型

Empty

呼び出し例

' GetPrinterList実行
Private Sub SUB_GetPrinterList()
    Err.Clear
    On Error GoTo Err_Trap
    List5.Clear

    Dim objEURPMLS
    Dim iLower, iUpper, I As Integer

    Set objEURPMLS = CreateObject("EURPMLS.Exec")

    objEURPMLS.ServerAddress = "255.255.***.***"
    ''プリンタ一覧の取得
    Call objEURPMLS.GetPrinterList

Err_Trap:
    List5.AddItem "Err.Number=(" & Err.Number & ")"
    List5.AddItem "Err.Description=(" & Err.Description & ")"

    If Err.Number = 0 Then
        List5.AddItem ""
        List5.AddItem "★★★★★ 結果出力ココカラ ★★★★★"
        Dim cstPrinterList As Variant
        cstPrinterList = objEURPMLS.ServerPrinterList
        iLower = LBound(cstPrinterList)
        iUpper = UBound(cstPrinterList)
        For I = iLower To iUpper
            List5.AddItem cstPrinterList(I)
        Next
        List5.AddItem "★★★★★ 結果出力ココマデ ★★★★★"
    End If

    Set objEURPMLS = Nothing

End Sub


GetSpoolFileメソッド

GetSpoolFileメソッド

ジョブIDのスプールデータに格納されているEPF形式ファイルを，指定したパスに取得します。

取得後のEPF形式ファイルは，OutputFileNameプロパティで指定したファイル名になります。

指定したパスに同一名のファイルがある場合は，上書きされます。スプールデータの取得については，マニュアル「EUR 帳票出力 機能解説 EUR Server編」を参照してください。

形式

GetSpoolFile ()

パラメタ

なし

解説

GetSpoolFileメソッドは，スプールサーバ上のスプールデータ内のEPF形式ファイルをOutputFilePathプロパティで指定されたフォルダに出力が終了した時点で呼び出し元に制御が戻ります。

実行時にエラーが発生した場合，Err.Numberプロパティに終了コード，Err.Descriptionプロパティにメッセージが設定されます。

戻り値

なし

データ型

Empty

呼び出し例

' GetSpoolFile実行
Private Sub SUB_GetSpoolFile()
    Err.Clear
    On Error GoTo Err_Trap
    List5.Clear

    Dim objEURPMLS

    Set objEURPMLS = CreateObject("EURPMLS.Exec")

    objEURPMLS.ServerAddress = "255.255.***.***"
    objEURPMLS.SearchJobID = "E00200605291252462630000001******007"
    ''取得フォルダの設定
    objEURPMLS.OutputFilePath = "c:\\tmp"
    ''取得実行
    Call objEURPMLS.GetSpoolFile

Err_Trap:
    List5.AddItem "GetAttr Err.Number=(" & Err.Number & ")"
    List5.AddItem "GetAttr Err.Description=(" & Err.Description & ")"

    Set objEURPMLS = Nothing

End Sub


GetSpoolFileAttributeメソッド

GetSpoolFileAttributeメソッド

指定したジョブIDのスプールデータの属性情報を取得します。取得されるスプールデータの属性情報については，マニュアル「EUR 帳票出力 機能解説 EUR Server編」を参照してください。

形式

GetSpoolFileAttribute()

パラメタ

なし

解説

GetSpoolFileAttributeメソッドは，スプールサーバにあるスプールデータの属性情報の取得が終了した時点で呼び出し元に制御が戻ります。

実行時にエラーが発生した場合，Err.Numberプロパティに終了コード，Err.Descriptionプロパティにメッセージが設定されます。

戻り値

なし

データ型

Empty

呼び出し例

' GetSpoolFileAttribute実行
Private Sub SUB_GetSpoolFileAttribute()
    Err.Clear
    On Error GoTo Err_Trap
    List5.Clear

    Dim objEURPMLS

    Set objEURPMLS = CreateObject("EURPMLS.Exec")

    objEURPMLS.ServerAddress = "255.255.***.***"
    objEURPMLS.SearchJobID = "E00200605291252462630000001******007"
    Call objEURPMLS.GetSpoolFileAttribute

Err_Trap:
    List5.AddItem "Err.Number=(" & Err.Number & ")"
    List5.AddItem "Err.Description=(" & Err.Description & ")"

    If Err.Number = 0 Then
        List5.AddItem ""
        List5.AddItem "★★★★★ 結果出力ココカラ ★★★★★"
        List5.AddItem "格納ファイル名：" & objEURPMLS.SpoolFileName
        List5.AddItem "ページ数：" & objEURPMLS.PageNum
        ''その他参照したい情報をプロパティから取得する
        List5.AddItem "★★★★★ 結果出力ココマデ ★★★★★"
    End If

    Set objEURPMLS = Nothing

End Sub


GetSpoolFileOutlineメソッド

GetSpoolFileOutlineメソッド

指定条件に合ったEUR Server - Spool Serviceのスプールデータの一覧を取得します。取得されるスプールデータの一覧については，マニュアル「EUR 帳票出力 機能解説 EUR Server編」を参照してください。

形式

GetSpoolFileOutline()

パラメタ

なし

解説

GetSpoolFileOutlineメソッドは，スプールサーバ上の蓄積フォルダから検索条件に合ったスプールデータの一覧の取得が終了した時点で呼び出し元に制御が戻ります。

次のプロパティのうちどれかが指定されていると，スプールデータの検索処理が高速になります。

  • SearchCreateTimeEnd
  • SearchCreateTimeStart
  • SearchJobID

実行時にエラーが発生した場合，Err.Numberプロパティに終了コード，Err.Descriptionプロパティにメッセージが設定されます。

戻り値

なし

データ型

Empty

呼び出し例

' GetSpoolFileOutline実行
Private Sub SUB_GetSpoolFileOutline()
    Err.Clear
    On Error GoTo Err_Trap
    List5.Clear

    Dim objEURPMLS
    Dim iLower, iUpper, I As Integer
    Dim cstJobIDList() As Variant
    Dim cstSpoolFileNameList() As Variant
    Dim cstPageNumList() As Variant
    Dim cstCreateTimeList() As Variant
    Dim cstPrintResultList() As Variant
    Dim cstPrinterClassNameList() As Variant

    Set objEURPMLS = CreateObject("EURPMLS.Exec")

    objEURPMLS.ServerAddress = "255.255.***.***"
    Call objEURPMLS.GetSpoolFileOutline

Err_Trap:
    List5.AddItem "Err.Number=(" & Err.Number & ")"
    List5.AddItem "Err.Description=(" & Err.Description & ")"

    If Err.Number = 0 Then
        List5.AddItem ""
        List5.AddItem "★★★★★ 結果出力ココカラ ★★★★★"
        iLower = LBound(objEURPMLS.JobID)
        iUpper = UBound(objEURPMLS.JobID)
        cstJobIDList = objEURPMLS.JobID
        cstSpoolFileNameList = objEURPMLS.SpoolFileName
        cstPageNumList = objEURPMLS.PageNum
        cstCreateTimeList = objEURPMLS.CreateTime
        cstPrintResultList = objEURPMLS.PrintResult
        cstPrinterClassNameList = objEURPMLS.PrinterClassName

        For I = iLower To iUpper
            List5.AddItem "ジョブＩＤ[" & Trim(Str(I)) & "]：" & cstJobIDList(I)
            List5.AddItem "格納ファイル名[" & Trim(Str(I)) & "]：" & cstSpoolFileNameList(I)
            List5.AddItem "ページ数[" & Trim(Str(I)) & "]：" & cstPageNumList(I)
            List5.AddItem "作成日時[" & Trim(Str(I)) & "]：" & cstCreateTimeList(I)
            List5.AddItem "印刷結果[" & Trim(Str(I)) & "]：" & cstPrintResultList(I)
            List5.AddItem "プリンタクラス名[" & Trim(Str(I)) & "]：" & cstPrinterClassNameList(I)

        Next
        List5.AddItem "★★★★★ 結果出力ココマデ ★★★★★"
    End If

    Set objEURPMLS = Nothing

End Sub


GetTrayListメソッド

GetTrayListメソッド

指定したスプールサーバのOS上のプリンタのトレイ一覧をServerTrayListプロパティに取得します。

形式

GetTrayList()

パラメタ

なし

解説

GetTrayListメソッドは，OS上のプリンタのトレイ一覧が取得終了した時点で呼び出し元に制御が戻ります。

実行時にエラーが発生した場合，Err.Numberプロパティに終了コード，Err.Descriptionプロパティにメッセージが設定されます。

UNIX／Linux環境の場合，トレイ一覧の取得はサポートしていません。UNIX／Linux環境のEUR Server - Spool Serviceに対して，トレイ一覧の取得を実行した場合はエラーとなります。

戻り値

なし

データ型

Empty

呼び出し例

' GetTrayList実行
Private Sub SUB_GetTrayList()
    Err.Clear
    On Error GoTo Err_Trap
    List5.Clear

    Dim objEURPMLS
    Dim iLower, iUpper, I As Integer

    Set objEURPMLS = CreateObject("EURPMLS.Exec")

    objEURPMLS.ServerAddress = "255.255.***.***"
    ''OS上のプリンタ名の設定
    objEURPMLS.ServerPrinterName = "Printer1"
    ''OS上のプリンタのトレイ一覧の取得
    Call objEURPMLS.GetTrayList

Err_Trap:
    List5.AddItem "Err.Number=(" & Err.Number & ")"
    List5.AddItem "Err.Description=(" & Err.Description & ")"

    If Err.Number = 0 Then
        Dim cstTrayList As Variant
        cstTrayList = objEURPMLS.ServerTrayList

        List5.AddItem ""
        List5.AddItem "★★★★★ 結果出力ココカラ ★★★★★"
        iLower = LBound(cstTrayList)
        iUpper = UBound(cstTrayList)
        For I = iLower To iUpper
            List5.AddItem cstTrayList(I)
        Next
        List5.AddItem "★★★★★ 結果出力ココマデ ★★★★★"
    End If

    Set objEURPMLS = Nothing

End Sub


Initializeメソッド

Initializeメソッド

指定されたすべてのプロパティをクリアにして，初期状態に戻します。

形式

Initialize()

パラメタ

なし

解説

Initializeメソッドは，EUR Server - Spool Service Adapterのプロパティの初期化処理が終了した時点で呼び出し元に制御が戻ります。

実行時にエラーが発生した場合，Err.Numberプロパティに終了コード，Err.Descriptionプロパティにメッセージが設定されます。

戻り値

なし

データ型

Empty

呼び出し例

' Initialize実行
Private Sub SUB_Initialize()
    Err.Clear
    On Error GoTo Err_Trap
    List5.Clear

    Dim objEURPMLS

    Set objEURPMLS = CreateObject("EURPMLS.Exec")

    '変更したい項目を修正する
    objEURPMLS.ServerAddress = "255.255.***.***"
    objEURPMLS.SearchJobID = "E00200605291252462630000001000000007"
    objEURPMLS.SpoolLimit = "20060615"
    objEURPMLS.PrinterClassName = "Ａ３"

    Call objEURPMLS.SetSpoolFileAttribute

    '先に指定したプロパティを初期化する
    Call objEURPMLS.Initialize

    '変更したい項目を修正する
    objEURPMLS.ServerAddress = "255.255.***.***"
    objEURPMLS.SearchJobID = "E00200605190259498390000001000000019"
    objEURPMLS.MaxPrintCount = 100

    Call objEURPMLS.SetSpoolFileAttribute

Err_Trap:
    List5.AddItem "GetAttr Err.Number=(" & Err.Number & ")"
    List5.AddItem "GetAttr Err.Description=(" & Err.Description & ")"

    Set objEURPMLS = Nothing

End Sub


PrintSpoolReportメソッド

PrintSpoolReportメソッド

指定したジョブIDのスプールデータに格納されているEPF形式ファイルを印刷します。

形式

PrintSpoolReport()

パラメタ

なし

解説

PrintSpoolReportメソッドは，印刷方式に応じて次に示すタイミングで呼び出し元に制御が戻ります。

  • 蓄積スプールサーバ印刷時
    スプールサーバ上のプリンタスプールへの出力が完了したタイミング
  • 蓄積クライアント印刷時
    EUR Clientへの配信が完了したタイミング

実行時にエラーが発生した場合，Err.Numberプロパティに終了コード，Err.Descriptionプロパティにメッセージが設定されます。

戻り値

なし

データ型

Empty

呼び出し例

' PrintSpoolReport実行
Private Sub SUB_PrintSpoolReport()
    Err.Clear
    On Error GoTo Err_Trap
    List5.Clear

    Dim objEURPMLS

    Set objEURPMLS = CreateObject("EURPMLS.Exec")

    objEURPMLS.ServerAddress = "255.255.***.***"
    objEURPMLS.SearchJobID = "E00200605291252462630000001******007"
    ''印刷モード=拠点印刷
    objEURPMLS.PrintStartPage = 0
    ''開始，終了ページの指定
    objEURPMLS.PrintStartPage = 3
    objEURPMLS.PrintEndPage = 5
    ''印刷実行
    Call objEURPMLS.PrintSpoolReport

Err_Trap:
    List5.AddItem "GetAttr Err.Number=(" & Err.Number & ")"
    List5.AddItem "GetAttr Err.Description=(" & Err.Description & ")"

    Set objEURPMLS = Nothing

End Sub


SetSpoolFileAttributeメソッド

SetSpoolFileAttributeメソッド

指定したジョブIDのスプールデータの属性情報を変更します。変更できるスプールデータの属性情報については，マニュアル「EUR 帳票出力 機能解説 EUR Server編」を参照してください。

形式

SetSpoolFileAttribute()

パラメタ

なし

解説

SetSpoolFileAttributeメソッドは，スプールサーバにあるスプールデータの属性情報の変更が終了した時点で呼び出し元に制御が戻ります。

SetSpoolFileAttributeメソッドは，指定できるプロパティのうち，指定のあったプロパティだけを変更します。SetSpoolFileAttributeメソッドで指定できるプロパティについては，「7.2.2　プロパティ一覧」を参照してください。また，指定できるプロパティは，一つ以上指定してください。指定されていない場合は，エラー（KEEY528-E）になります。

実行時にエラーが発生した場合，Err.Numberプロパティに終了コード，Err.Descriptionプロパティにメッセージが設定されます。

戻り値

なし

データ型

Empty

呼び出し例

' SetSpoolFileAttribute実行
Private Sub SUB_SetSpoolFileAttribute()
    Err.Clear
    On Error GoTo Err_Trap
    List5.Clear

    Dim objEURPMLS

    Set objEURPMLS = CreateObject("EURPMLS.Exec")

    objEURPMLS.ServerAddress = "255.255.***.***"
    objEURPMLS.SearchJobID = "EUR200605291252462630000001******007"
    '変更したい項目を修正する
    objEURPMLS.SpoolLimit = "20060615"
    objEURPMLS.PrinterClassName = "Ａ３"

    Call objEURPMLS.SetSpoolFileAttribute

Err_Trap:
    List5.AddItem "GetAttr Err.Number=(" & Err.Number & ")"
    List5.AddItem "GetAttr Err.Description=(" & Err.Description & ")"

    Set objEURPMLS = Nothing

End Sub


SS-ActiveX起動部品のプロパティ仕様

7.4　SS-ActiveX起動部品のプロパティ仕様

SS-ActiveX起動部品が提供するプロパティの詳細を説明します。

＜この節の構成＞
ClientAddressプロパティ
ClientPrinterNameプロパティ
ClientTrayNameプロパティ
CreateIPAddressプロパティ
CreateLSVersionプロパティ
CreateTimeプロパティ
DeleteKindプロパティ
DispPrintDlgプロパティ
EnableGetプロパティ
ExecPrintCountプロパティ
ExecutablePrintModeプロパティ
GroupNameプロパティ
JobIDプロパティ
JobKeyCategoryプロパティ
JobKeyDataプロパティ
MaxPrintCountプロパティ
OutputFileNameプロパティ
OutputFilePathプロパティ
PageNumプロパティ
PaperOrientationプロパティ
PrintCopiesプロパティ
PrintEndPageプロパティ
PrinterClassListプロパティ
PrinterClassNameプロパティ
PrinterSelectModeプロパティ
PrintModeプロパティ
PrintResultプロパティ
PrintStartPageプロパティ
PrintTimeプロパティ
ReportAddressKeyCategoryプロパティ
ReportAddressKeyDataプロパティ
SearchCreateTimeEndプロパティ
SearchCreateTimeStartプロパティ
SearchJobIDプロパティ
SearchJobKeyCategoryプロパティ
SearchJobKeyDataプロパティ
SearchPrinterClassNameプロパティ
SearchReportAddressKeyCategoryプロパティ
SearchReportAddressKeyDataプロパティ
SearchSpoolFileNameプロパティ
ServerAddressプロパティ
ServerPrinterListプロパティ
ServerPrinterNameプロパティ
ServerTrayListプロパティ
ServerTrayNameプロパティ
SortPrintプロパティ
SpoolFileNameプロパティ
SpoolFileSizeプロパティ
SpoolHistoryプロパティ
SpoolLimitプロパティ
SpoolPathプロパティ
SpoolTitleプロパティ


ClientAddressプロパティ

ClientAddressプロパティ

蓄積クライアント印刷するときのクライアントPCのIPアドレスを指定または取得します。

解説

  • ClientAddressプロパティは，次に示すメソッドを呼び出すタイミングによって，値が異なります。
    • GetSpoolFileAttributeメソッドを呼び出したあと
      蓄積クライアント印刷するときのクライアントIPアドレスが「255.255.255.255」形式で取得されます。
    • SetSpoolFileAttributeメソッド，およびPrintSpoolReportメソッドを呼び出す前
      蓄積クライアント印刷するときのクライアントIPアドレスを「255.255.255.255」形式で指定します。長さは15バイトまでです。
  • サーバアプリケーションから次のようなAPIを使用すると，Webクライアントの要求元を取得できます。指定方法などについては，各APIのアプリケーションサーバの仕様を確認してください。
    ASPの場合
    Request.ServerVariables("REMOTE_ADDR")
    JSPの場合
    request.getRemoteAddr()
  • ClientAddressプロパティは，GetSpoolFileAttributeメソッド，およびSetSpoolFileAttributeメソッドでスプールデータを操作する場合，ならびにPrintSpoolReportメソッドで蓄積クライアント印刷する場合に指定が有効になります。それ以外のメソッドでは，ClientAddressプロパティを指定しても無視されます。
  • 蓄積クライアント印刷する場合にClientAddressプロパティの指定を省略したときは，デフォルト値（127.0.0.1）を仮定して印刷します。複数のスプールデータのEPF形式ファイルを統合して印刷するときは，最初に指定したスプールデータの属性情報でクライアントPCのIPアドレスを決定します。
    なお，ClientAddressプロパティとスプールデータの属性情報のどちらにもクライアントIPアドレスの設定がないときは，蓄積クライアント印刷実行時にエラーとなります。

データ型

String


ClientPrinterNameプロパティ

ClientPrinterNameプロパティ

蓄積クライアント印刷するときのOS上のプリンタ名を指定または取得します。

解説

  • プリンタ名を指定するときは，次のことに注意してください。
    • プリンタ名は，80バイト以内で指定してください。
    • プリンタ名には「"」および「,」を含めないでください。
  • 蓄積クライアント印刷するときにClientPrinterNameプロパティの指定があると，DispPrintDlgプロパティは強制的に「1（自動印刷）」になります。蓄積時に指定したクライアントPCのプリンタに出力されます。
  • ClientPrinterNameプロパティは，次に示すメソッドを呼び出すタイミングによって，値が異なります。
    • GetSpoolFileAttributeメソッドを呼び出したあと
      クライアントPCの，OS上のプリンタ名が取得されます。
    • SetSpoolFileAttributeメソッド，およびPrintSpoolReportメソッドを呼び出す前
      クライアントPCの，OS上のプリンタ名を指定します。
  • ClientPrinterNameプロパティは，GetSpoolFileAttributeメソッド，およびSetSpoolFileAttributeメソッドでスプールデータを操作する場合，ならびにPrintSpoolReportメソッドで蓄積クライアント印刷する場合に指定が有効になります。それ以外のメソッドでは，ClientPrinterNameプロパティを指定しても無視されます。
  • 蓄積クライアント印刷する場合にClientPrinterNameプロパティの指定を省略したときは，次の値が仮定されます。
    • ジョブIDを一つだけ指定しているとき
      指定したジョブIDのスプールデータの属性情報に設定されている値
    • ジョブIDを複数指定しているとき
      最初に指定したジョブIDのスプールデータの属性情報に設定されている値
  • 蓄積クライアント印刷する場合にClientPrinterNameプロパティに空文字を指定したときは，プリンタ名情報は未設定となります。

データ型

String


ClientTrayNameプロパティ

ClientTrayNameプロパティ

蓄積クライアント印刷するときのプリンタのトレイ名を指定または取得します。

解説

  • トレイ名を指定するときは，次のことに注意してください。
    • トレイ名は，80バイト以内で指定してください。
    • トレイ名には「"」および「,」を含めないでください。
  • 蓄積クライアント印刷するときにClientPrinterNameプロパティの指定があると，ClientTrayNameプロパティで指定したトレイから給紙されます。
    ClientPrinterNameプロパティで指定したプリンタでClientTrayNameプロパティに指定したトレイ名が使用できないときは，ClientPrinterNameプロパティで指定したプリンタのデフォルトのトレイから給紙されます。
  • 蓄積クライアント印刷する場合にClientTrayNameプロパティの指定を省略したときは，次の値が仮定されます。
    • ジョブIDを一つだけ指定しているとき
      指定したジョブIDのスプールデータの属性情報に設定されている値
    • ジョブIDを複数指定しているとき
      最初に指定したジョブIDのスプールデータの属性情報に設定されている値
  • 蓄積クライアント印刷する場合にClientTrayNameプロパティに空文字を指定したときは，トレイ名情報は未設定となります。
  • ClientTrayNameプロパティは，次に示すメソッドを呼び出すタイミングによって，値が異なります。
    • GetSpoolFileAttributeメソッドを呼び出したあと
      クライアントPCの，OS上のプリンタのトレイ名が取得されます。
    • SetSpoolFileAttributeメソッド，およびPrintSpoolReportメソッドを呼び出す前
      クライアントPCの，OS上のプリンタのトレイ名を指定します。
  • ClientTrayNameプロパティは，GetSpoolFileAttributeメソッド，およびSetSpoolFileAttributeメソッドでスプールデータを操作する場合，ならびにPrintSpoolReportメソッドで蓄積クライアント印刷する場合に指定が有効になります。それ以外のメソッドでは，ClientTrayNameプロパティを指定しても無視されます。

データ型

String


CreateIPAddressプロパティ

CreateIPAddressプロパティ

スプールデータを作成したマシンのIPアドレスを取得します。

解説

  • CreateIPAddressプロパティは，GetSpoolFileAttributeメソッドを呼び出したあと，スプールデータ作成者のIPアドレスが「255.255.255.255」形式で取得されます。
  • CreateIPAddressプロパティは，GetSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，CreateIPAddressプロパティを指定しても無視されます。

データ型

String


CreateLSVersionプロパティ

CreateLSVersionプロパティ

スプールデータのフォーマットバージョンを取得します。

解説

  • CreateLSVersionプロパティは，GetSpoolFileAttributeメソッドを呼び出したあと，スプールデータのフォーマットバージョンが「VV－RR」形式で取得されます。
    スプールデータのフォーマットバージョンは，EUR Server - Spool Serviceのバージョンとは異なります。
  • CreateLSVersionプロパティは，GetSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，CreateLSVersionプロパティを指定しても無視されます。

データ型

String


CreateTimeプロパティ

CreateTimeプロパティ

スプールデータの作成日時を取得します。

解説

  • CreateTimeプロパティは，次に示すどちらのメソッドを呼び出すかによって，値が異なります。
    • GetSpoolFileOutlineメソッドを呼び出したあと
      検索条件に合ったスプールデータの作成日時が配列で取得されます。
    • GetSpoolFileAttributeメソッドを呼び出したあと
      指定したジョブIDのスプールデータの作成日時が取得されます。
  • 取得されるスプールデータの作成日時の形式は「YYYYMMDDhhmmss」です。
    「YYYYMMDDhhmmss」形式の内容を次に示します。
    • YYYY：年（西暦）を4桁で示します。
    • MM：月（01～12）を2桁で示します。01～09は，ゼロ埋めされます。
    • DD：日（01～31）を2桁で示します。01～09は，ゼロ埋めされます。
    • hh：時（00～23）を2桁で示します。00～09は，ゼロ埋めされます。
    • mm：分（00～59）を2桁で示します。00～09は，ゼロ埋めされます。
    • ss：秒（00～59）を2桁で示します。00～09は，ゼロ埋めされます。
    （出力例）20060523015630
  • CreateTimeプロパティは，GetSpoolFileOutlineメソッド，およびGetSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，CreateTimeプロパティを指定しても無視されます。

データ型

  • String 配列（GetSpoolFileOutlineメソッドを呼び出したあとの場合）
  • String（GetSpoolFileAttributeメソッドを呼び出したあとの場合）


DeleteKindプロパティ

DeleteKindプロパティ

スプールデータを削除するときの削除種別を指定します。

解説

  • スプールデータを削除するときの削除種別を，0，または1で指定します。0，または1以外の値を指定したときは，エラーになります。デフォルトは，「0（通常削除）」です。
    • 0：通常削除
      SearchJobIDプロパティで指定したジョブIDに該当するスプールデータを削除します。
    • 1：蓄積期限切れファイルの削除
      EUR Server - Spool Serviceのあるマシンで，蓄積期限が過ぎているスプールデータを削除します。
  • 蓄積期限切れファイルの削除は，EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）でOPTIONセクションのESFAUTODELキーに「1（自動削除します）」を設定しておくことで，次に示すタイミングで自動的に実行することもできます。
    • EUR Server - Spool Serviceのサービスを起動したとき
    • EUR Server - Spool Serviceが稼働するマシンの日付が変わったあと，EUR Server - Spool Serviceに対して最初の要求があったとき（日付変更の契機にローカルタイムと協定世界時（UTC）のどちらを使用するかを，環境設定ファイル（EURPMLS.ini）のOPTIONセクションのSTANDARDTIMEキーで設定できます）
  • DeleteKindプロパティは，DeleteSpoolFileメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，DeleteKindプロパティを指定しても無視されます。

データ型

Long


DispPrintDlgプロパティ

DispPrintDlgプロパティ

蓄積クライアント印刷するときのダイアログ表示モードを指定または取得します。

解説

  • 指定できる値と蓄積クライアント印刷時の動作を次に示します。
    • 0：印刷先指定ダイアログを表示します（対話型印刷）。
      プレビューボタンを選択すると，プレビューウィンドウが表示されます。
    • 1：直接印刷を実行します（自動印刷）。
      印刷実行中に印刷中のダイアログが表示されます。
    • 2：プレビューウィンドウを表示します（対話型印刷プレビュー表示）。
      印刷メニューまたは印刷ボタンを選択すると，印刷先指定ダイアログが表示されます。
    • 3：直接印刷を実行します（全自動印刷）。
      印刷実行中に印刷中のダイアログは表示されません。
    • 4：プレビューウィンドウを表示します（対話型印刷プレビュー表示限定）。
      印刷は実行できません。
  • 蓄積クライアント印刷実行時，ClientPrinterNameプロパティに値を指定している場合，かつDispPrintDlgプロパティに0または2を指定した場合は，DispPrintDlgプロパティに1が仮定されます。
  • DispPrintDlgプロパティは，次に示すメソッドを呼び出すタイミングによって，値が異なります。
    • GetSpoolFileAttributeメソッドを呼び出したあと
      蓄積クライアント印刷するときのダイアログ表示モードが取得されます。
    • SetSpoolFileAttributeメソッド，およびPrintSpoolReportメソッドを呼び出す前
      蓄積クライアント印刷するときのダイアログ表示モードを指定します。
  • SetSpoolFileAttributeメソッド実行時に，0～4以外の値が指定されていたときは，エラーになります。
  • DispPrintDlgプロパティは，GetSpoolFileAttributeメソッド，およびSetSpoolFileAttributeメソッドでスプールデータを操作する場合，ならびにPrintSpoolReportメソッドで蓄積クライアント印刷する場合に指定が有効になります。それ以外のメソッドでは，DispPrintDlgプロパティを指定しても無視されます。

データ型

Long


EnableGetプロパティ

EnableGetプロパティ

スプールデータに格納されているEPF形式ファイルの取得を許可するかどうかを指定または取得します。

解説

  • EnableGetプロパティは，次に示すメソッドを呼び出すタイミングによって，値が異なります。
    • GetSpoolFileAttributeメソッドを呼び出したあと
      EPF形式ファイルの取得許可情報が取得されます。
    • SetSpoolFileAttributeメソッドを呼び出す前
      EPF形式ファイルの取得許可を指定します。
  • EPF形式ファイルの取得許可情報を次に示します。
    • True：EPF形式ファイルの取得を許可します。
    • False：EPF形式ファイルの取得を許可しません。
  • EnableGetプロパティは，GetSpoolFileAttributeメソッド，およびSetSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，EnableGetプロパティを指定しても無視されます。

データ型

Boolean


ExecPrintCountプロパティ

ExecPrintCountプロパティ

スプールデータの印刷実行回数を取得します。

解説

  • ExecPrintCountプロパティは，GetSpoolFileAttributeメソッドを呼び出したあと，スプールデータの印刷実行回数が取得されます。
    印刷実行回数は，スプールサーバでの印刷で印刷スプールへの出力が成功したとき，またはクライアントPCでの印刷でEPF形式ファイルの転送が成功したときに，1カウントずつアップされます。
  • ExecPrintCountプロパティは，GetSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，ExecPrintCountプロパティを指定しても無視されます。

データ型

Long


ExecutablePrintModeプロパティ

ExecutablePrintModeプロパティ

スプールデータの実行可能印刷方式を指定または取得します。

解説

  • ExecutablePrintModeプロパティは，次に示すメソッドを呼び出すタイミングによって，値が異なります。
    • GetSpoolFileAttributeメソッドを呼び出したあと
      スプールデータの実行可能印刷方式が取得されます。
    • SetSpoolFileAttributeメソッドを呼び出す前
      スプールデータの実行可能印刷方式を指定します。
  • スプールデータの実行可能印刷方式を次に示します。
    • 0：蓄積スプールサーバ印刷
    • 1：蓄積スプールサーバ印刷／蓄積クライアント印刷
    • 2：蓄積クライアント印刷
    SetSpoolFileAttributeメソッド実行時に，0，1，または2以外の値が指定されていたときは，エラーになります。
  • ExecutablePrintModeプロパティは，GetSpoolFileAttributeメソッド，およびSetSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，ExecutablePrintModeプロパティを指定しても無視されます。

データ型

Long


GroupNameプロパティ

GroupNameプロパティ

スプールデータの振り分けグループ名を指定または取得します。

解説

  • 振り分けグループ名を指定するときは，次のことに注意してください。
    • 振り分けグループ名は，80バイト以内で指定してください。
    • 文字列に「"」，および「,」を含めないでください。
  • GroupNameプロパティは，次に示すメソッドを呼び出すタイミングによって，値が異なります。
    • GetSpoolFileAttributeメソッドを呼び出したあと
      スプールデータの振り分けグループ名が取得されます。
    • SetSpoolFileAttributeメソッド，およびPrintSpoolReportメソッドを呼び出す前
      スプールデータの振り分けグループ名を指定します。
  • GroupNameプロパティは，GetSpoolFileAttributeメソッド，およびSetSpoolFileAttributeメソッドでスプールデータを操作する場合，ならびにPrintSpoolReportメソッドで蓄積スプールサーバ印刷する場合でプリンタ指定方式に帳票名による自動振り分け（PrinterSelectMode=2）を指定したときに指定が有効になります。それ以外のメソッドでは，GroupNameプロパティを指定しても無視されます。
  • 蓄積スプールサーバ印刷でGroupNameプロパティの指定が有効な場合に，GroupNameプロパティの指定を省略したときや空文字を指定したときは，デフォルトの振り分けグループで出力先を決定して印刷します。

データ型

String


JobIDプロパティ

JobIDプロパティ

ジョブIDを取得します。

解説

  • JobIDプロパティは，GetSpoolFileOutlineメソッドを呼び出したあと，検索条件に合ったスプールデータのジョブIDが配列で取得されます。
  • JobIDプロパティは，GetSpoolFileOutlineメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，JobIDプロパティを指定しても無視されます。

データ型

String 配列


JobKeyCategoryプロパティ

JobKeyCategoryプロパティ

スプールデータのジョブ検索キーの分類を指定または取得します。

解説

  • JobKeyCategoryプロパティは，次に示すメソッドを呼び出すタイミングによって，値が異なります。
    • GetSpoolFileAttributeメソッドを呼び出したあと
      スプールデータのジョブ検索キーの分類が取得されます。
    • SetSpoolFileAttributeメソッドを呼び出す前
      スプールデータのジョブ検索キーの分類を指定します。
  • ジョブ検索キーを指定する場合は，1～10個の配列で指定してください。また，JobKeyCategoryプロパティを指定する場合は，ジョブ検索キーの分類に対応する検索キーの値を必ずJobKeyDataプロパティに指定してください。このとき，配列の要素数は同じにしてください。配列の要素数が異なると，SetSpoolFileAttributeメソッド実行時にエラーになります。また，ジョブ検索キーを指定しない場合は，JobKeyCategoryプロパティとJobKeyDataプロパティのどちらも指定しないでください。どちらかの指定があると対応する情報がないため，SetSpoolFileAttributeメソッド実行時にエラーになります。
  • ジョブ検索キーは，任意文字列を指定できます。指定するときは，次のことに注意してください。
    • 文字列は，80バイト以内で指定してください。
    • 文字列に「,」を含めないでください。
  • JobKeyCategoryプロパティは，GetSpoolFileAttributeメソッド，およびSetSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，JobKeyCategoryプロパティを指定しても無視されます。

データ型

String 配列


JobKeyDataプロパティ

JobKeyDataプロパティ

スプールデータのジョブ検索キーの値を指定または取得します。

解説

  • JobKeyDataプロパティは，次に示すメソッドを呼び出すタイミングによって，値が異なります。
    • GetSpoolFileAttributeメソッドを呼び出したあと
      スプールデータのジョブ検索キーの値が取得されます。
    • SetSpoolFileAttributeメソッドを呼び出す前
      スプールデータのジョブ検索キーの値を指定します。
  • ジョブ検索キーを指定する場合は，1～10個の配列で指定してください。また，JobKeyCategoryプロパティを指定する場合は，検索キーの分類に対応する検索キーの値を必ずJobKeyDataプロパティに指定してください。このとき，配列の要素数は同じにしてください。配列の要素数が異なると，SetSpoolFileAttributeメソッド実行時にエラーになります。また，検索キーを指定しない場合は，JobKeyCategoryプロパティとJobKeyDataプロパティのどちらも指定しないでください。どちらかの指定があると対応する情報がないため，SetSpoolFileAttributeメソッド実行時にエラーになります。
  • 値は，任意文字列を指定できます。指定するときは，次のことに注意してください。
    • 文字列は，80バイト以内で指定してください。
    • 文字列に「,」を含めないでください。
  • JobKeyDataプロパティは，GetSpoolFileAttributeメソッド，およびSetSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，JobKeyDataプロパティを指定しても無視されます。

データ型

String 配列


MaxPrintCountプロパティ

MaxPrintCountプロパティ

スプールデータの印刷上限回数を指定または取得します。

解説

  • MaxPrintCountプロパティは，次に示すメソッドを呼び出すタイミングによって，値が異なります。
    • GetSpoolFileAttributeメソッドを呼び出したあと
      スプールデータの印刷上限回数が取得されます。
    • SetSpoolFileAttributeメソッドを呼び出す前
      スプールデータの印刷上限回数を指定します。
  • 印刷上限回数に指定できる値は，-1～65,536です。
    • 印刷回数の上限を無限にする場合は，-1を指定してください。
    • 印刷を禁止する場合は，0を指定してください。
    • 印刷回数を指定する場合は，1～65,536の範囲内で指定してください。
    SetSpoolFileAttributeメソッド実行時に，-1，0，または1～65,536以外の値が指定されていたときは，エラーになります。
  • MaxPrintCountプロパティは，GetSpoolFileAttributeメソッド，およびSetSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，MaxPrintCountプロパティを指定しても無視されます。

データ型

Long


OutputFileNameプロパティ

OutputFileNameプロパティ

スプールデータから取得後のEPF形式ファイル名を指定します。

解説

  • EPF形式ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • OutputFileNameプロパティを省略した場合，ファイル名は次のようになります。
    • ジョブIDを一つだけ指定しているとき
      指定したジョブIDのスプールデータに格納されているEPF形式ファイルのファイル名
    • ジョブIDを複数指定しているとき
      最初に指定したジョブIDのスプールデータに格納されているEPF形式ファイルのファイル名
  • OutputFileNameプロパティは，GetSpoolFileメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，OutputFileNameプロパティを指定しても無視されます。

データ型

String


OutputFilePathプロパティ

OutputFilePathプロパティ

スプールデータからEPF形式ファイルを取得するとき，取得するフォルダのパスを指定します。

解説

  • EUR Server - Spool Service Adapterの環境設定ファイル（EURPMLSADP.ini）で，PATHセクションにOUTPUTFILEキーを指定することで，デフォルトのスプールデータ取得フォルダを指定することもできます。
  • GetSpoolFileメソッドを実行した場合，OutputFilePathプロパティおよび環境設定ファイルのどちらも指定されていないときは，エラーになります。
  • フォルダのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • OutputFilePathプロパティは，GetSpoolFileメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，OutputFilePathプロパティを指定しても無視されます。

データ型

String


PageNumプロパティ

PageNumプロパティ

スプールデータに格納されたEPF形式ファイルのページ数を取得します。

解説

  • PageNumプロパティは，次に示すどちらのメソッドを呼び出すかによって，スプールデータに格納されたEPF形式ファイルのページ数の情報が異なります。
    • GetSpoolFileOutlineメソッドを呼び出したあと
      検索条件に合ったスプールデータに格納されているEPF形式ファイルのページ数が配列で取得されます。
    • GetSpoolFileAttributeメソッドを呼び出したあと
      指定したジョブIDのスプールデータに格納されているEPF形式ファイルのページ数が取得されます。
  • PageNumプロパティは，GetSpoolFileOutlineメソッド，およびGetSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，PageNumプロパティを指定しても無視されます。

データ型

  • Long 配列（GetSpoolFileOutlineメソッドを呼び出したあとの場合）
  • Long（GetSpoolFileAttributeメソッドを呼び出したあとの場合）


PaperOrientationプロパティ

PaperOrientationプロパティ

用紙の向きを指定します。

解説

指定できる値を次に示します。

  • 0：EPF形式ファイルを蓄積したときのページごとの属性に従います。
  • 1：用紙の向きを縦にして出力します。
  • 2：用紙の向きを横にして出力します。

PaperOrientationプロパティを省略した場合，次のように動作します。

  • ジョブIDを一つだけ指定しているとき
    指定したジョブIDのスプールデータに格納されているEPF形式ファイルの属性情報に従います。
  • ジョブIDを複数指定しているとき
    EPF形式ファイルを蓄積したときのページごとの属性に従います。

PaperOrientationプロパティは，GetSpoolFileメソッドでスプールデータを操作する場合，およびPrintSpoolReportメソッドで印刷する場合に指定が有効になります。それ以外のメソッドでは，PaperOrientationプロパティを指定しても無視されます。

データ型

Long


PrintCopiesプロパティ

PrintCopiesプロパティ

印刷部数を指定します。

解説

指定できる値は，1～99です。PrintCopiesプロパティを省略した場合，次の値が仮定されます。

  • ジョブIDを一つだけ指定しているとき
    指定したジョブIDのスプールデータに格納されているEPF形式ファイルの属性情報に設定されている値
  • ジョブIDを複数指定しているとき
    1

PrintCopiesプロパティは，GetSpoolFileメソッドでスプールデータを操作する場合，およびPrintSpoolReportメソッドで印刷する場合に指定が有効になります。それ以外のメソッドでは，PrintCopiesプロパティを指定しても無視されます。

データ型

Long


PrintEndPageプロパティ

PrintEndPageプロパティ

スプールデータをスプールサーバで印刷するときの終了ページを指定します。

解説

  • PrintEndPageプロパティは，蓄積印刷方式が蓄積スプールサーバ印刷（PrintMode=0）のとき，有効になります。蓄積クライアント印刷（PrintMode=1）のときは，PrintEndPageプロパティを指定しても無視されます。
  • 指定できる値は，1～999,999です。PrintEndPageプロパティを省略した場合は，最終ページまで印刷されます。また，スプールデータに格納されているEPF形式ファイルの最終ページ数よりPrintEndPageプロパティに指定した値が大きい場合も，最終ページまで印刷されます。
  • PrintEndPageプロパティは，PrintSpoolReportメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，PrintEndPageプロパティを指定しても無視されます。

データ型

Long


PrinterClassListプロパティ

PrinterClassListプロパティ

スプールサーバに登録されているプリンタクラス一覧を取得します。

解説

  • GetPrinterClassListメソッドを呼び出したあと，プリンタクラス一覧が取得されます。プリンタクラス一覧は，次に示す形式でプリンタクラス情報数分取得されます。
    [プリンタクラス名][OS上のプリンタ名][OS上のプリンタのトレイ名][説明]
  • スプールサーバにプリンタクラス定義がない場合，配列の要素数は0になります。
  • PrinterClassListプロパティは，GetPrinterClassListメソッドでプリンタクラス一覧を取得する場合，指定が有効になります。それ以外のメソッドでは，PrinterClassListプロパティを指定しても無視されます。

データ型

String 二次元配列


PrinterClassNameプロパティ

PrinterClassNameプロパティ

スプールデータのプリンタクラス名を指定または取得します。

解説

  • 蓄積スプールサーバ印刷する場合にプリンタ指定方式でプリンタクラス名指定（PrinterSelectMode=0）を指定したとき，および蓄積クライアント印刷する場合にClientPrinterNameプロパティの指定がないときに，PrinterClassNameプロパティで指定したプリンタクラスを出力先にします。SetSpoolFileAttributeメソッドの呼び出しでプリンタクラス名を変更しても無視されます。
  • PrinterClassNameプロパティは，次に示すどのメソッドを呼び出すかによって，値が異なります。
    • GetSpoolFileOutlineメソッドを呼び出したあと
      検索条件に合ったスプールデータのプリンタクラス名が配列で取得されます。
    • GetSpoolFileAttributeメソッドを呼び出したあと
      指定したジョブIDのスプールデータのプリンタクラス名が取得されます。
    • SetSpoolFileAttributeメソッド，PrintSpoolReportメソッド，およびGetSpoolFileメソッドを呼び出す前
      スプールデータのプリンタクラス名を指定します。SetSpoolFileAttributeメソッドで蓄積後に変更したプリンタクラス名が有効になるのは，スプールサーバ印刷だけです。
  • プリンタクラス名は，任意の文字列を指定できます。指定するときは，次のことに注意してください。
    • プリンタクラス名は，80バイト以内で指定してください。
    • プリンタクラス名に「"」および「,」を含めないでください。
  • PrinterClassNameプロパティは，GetSpoolFileOutlineメソッド，GetSpoolFileAttributeメソッド，SetSpoolFileAttributeメソッド，およびGetSpoolFileメソッドでスプールデータを操作する場合，ならびにPrintSpoolReportメソッドで印刷する場合に指定が有効になります。それ以外のメソッドでは，PrinterClassNameプロパティを指定しても無視されます。
  • 蓄積スプールサーバ印刷でプリンタ指定方式がプリンタクラス名指定（PrinterSelectMode=0）の場合に，PrinterClassNameプロパティの指定を省略したときや空文字を指定したときは，デフォルトのプリンタクラスで印刷します。
  • 蓄積クライアント印刷する場合，およびスプールデータを取得する場合にPrinterClassNameプロパティに空文字を指定したときは，プリンタクラス情報は未設定となります。
  • 蓄積クライアント印刷する場合，およびスプールデータを取得する場合にPrinterClassNameプロパティの指定を省略したときは，次のようになります。
    • ジョブIDを一つだけ指定しているとき
      指定したジョブIDのスプールデータの属性情報に設定されている値が仮定されます。
    • ジョブIDを複数指定しているとき
      プリンタクラス情報は未設定となります。

データ型

  • String 配列（GetSpoolFileOutlineメソッドを呼び出したあとの場合）
  • String（GetSpoolFileAttributeメソッドを呼び出したあとの場合）
  • String（SetSpoolFileAttributeメソッド，GetSpoolFileメソッド，またはPrintSpoolReportメソッドを呼び出す前の場合）


PrinterSelectModeプロパティ

PrinterSelectModeプロパティ

蓄積スプールサーバ印刷するときのプリンタ指定方式を指定または取得します。

解説

  • PrinterSelectModeプロパティは，次に示すメソッドを呼び出すタイミングによって，値が異なります。
    • GetSpoolFileAttributeメソッドを呼び出したあと
      蓄積スプールサーバ印刷するときのプリンタ指定方式が取得されます。
    • SetSpoolFileAttributeメソッド，およびPrintSpoolReportメソッドを呼び出す前
      蓄積スプールサーバ印刷するときのプリンタ指定方式を指定します。
  • PrintSpoolReportメソッド実行時にPrinterSelectModeプロパティを指定する場合，帳票の出力先は次のプロパティの指定値によって決定します。
    • PrinterClassNameプロパティ
    • ServerPrinterNameプロパティ
    • ServerTrayNameプロパティ
    • GroupNameプロパティ
    どのプロパティの指定値が有効になるかは，PrinterSelectModeプロパティの指定値によって異なります。また，指定を省略した場合は，そのプロパティの情報は未設定として扱われます。
  • PrintSpoolReportメソッド実行時にPrinterSelectModeプロパティの指定を省略する場合は，次の値が仮定されます。
    • ジョブIDを一つだけ指定しているとき
      指定したジョブIDのスプールデータの属性情報に設定されている値
    • ジョブIDを複数指定しているとき
      最初に指定したジョブIDのスプールデータの属性情報に設定されている値
  • 蓄積スプールサーバ印刷するときのプリンタ指定方式を次に示します。
    • 0：プリンタクラス名指定
    • 1：OS上のプリンタ名指定
    • 2：帳票名による自動振り分け
    SetSpoolFileAttributeメソッド実行時に，0，1，または2以外の値が指定されていたときは，エラーになります。
  • PrinterSelectModeプロパティは，GetSpoolFileAttributeメソッド，およびSetSpoolFileAttributeメソッドでスプールデータを操作する場合，ならびにPrintSpoolReportメソッドで印刷を実行する場合に指定が有効になります。それ以外のメソッドでは，PrinterSelectModeプロパティを指定しても無視されます。

データ型

Long


PrintModeプロパティ

PrintModeプロパティ

スプールデータの印刷方式を指定します。

解説

  • 蓄積したデータの印刷方式を次に示します。PrintModeプロパティを省略した場合は，0が仮定されます。
    • 0：蓄積スプールサーバ印刷
    • 1：蓄積クライアント印刷
    PrintSpoolReportメソッド実行時に，0，または1以外の値が指定されていたときは，エラーになります。
  • PrintModeプロパティは，PrintSpoolReportメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，PrintModeプロパティを指定しても無視されます。

データ型

Long


PrintResultプロパティ

PrintResultプロパティ

スプールデータの印刷結果を取得します。

解説

  • 取得される印刷結果を次に示します。
    • 0：未印刷であることを示します。
    • 1：印刷済みであることを示します。
    • 2：印刷エラーがあったことを示します。
  • PrintResultプロパティは，次に示すどちらのメソッドを呼び出すかによって，スプールデータ内の印刷結果の情報が異なります。
    • GetSpoolFileOutlineメソッドを呼び出したあと
      検索条件に合ったスプールデータの印刷結果が配列で取得されます。
    • GetSpoolFileAttributeメソッドを呼び出したあと
      指定したジョブIDのスプールデータの印刷結果が取得されます。
  • PrintResultプロパティは，GetSpoolFileOutlineメソッド，およびGetSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，PrintResultプロパティを指定しても無視されます。

データ型

  • Long 配列（GetSpoolFileOutlineメソッドを呼び出したあとの場合）
  • Long（GetSpoolFileAttributeメソッド呼び出したあとの場合）


PrintStartPageプロパティ

PrintStartPageプロパティ

スプールデータをスプールサーバで印刷するときの開始ページを指定します。

解説

  • PrintStartPageプロパティは，蓄積印刷方式が蓄積スプールサーバ印刷（PrintMode=0）のとき，有効になります。蓄積クライアント印刷（PrintMode=1）のときは，PrintStartPageプロパティを指定しても無視されます。
  • 指定できる値は，1～999,999です。PrintStartPageプロパティを省略した場合は，1ページから印刷されます。
  • PrintStartPageプロパティに指定した値がスプールデータに格納されているEPF形式ファイルの最終ページ数より大きい場合は，EPF形式ファイルの最終ページだけ印刷されます。
  • PrintStartPageプロパティは，PrintSpoolReportメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，PrintStartPageプロパティを指定しても無視されます。

データ型

Long


PrintTimeプロパティ

PrintTimeプロパティ

スプールデータの印刷日時を取得します。

解説

  • 取得されるスプールデータの印刷日時の形式は「YYYYMMDDhhmmss」です。
    「YYYYMMDDhhmmss」形式の内容を次に示します。
    • YYYY：年（西暦）を4桁で示します。
    • MM：月（01～12）を2桁で示します。01～09は，ゼロ埋めされます。
    • DD：日（01～31）を2桁で示します。01～09は，ゼロ埋めされます。
    • hh：時（00～23）を2桁で示します。00～09は，ゼロ埋めされます。
    • mm：分（00～59）を2桁で示します。00～09は，ゼロ埋めされます。
    • ss：秒（00～59）を2桁で示します。00～09は，ゼロ埋めされます。
    （出力例）20060523015630
  • スプールデータが一度も印刷されていない場合は，"" が取得されます。
  • PrintTimeプロパティは，GetSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，PrintTimeプロパティを指定しても無視されます。
  • スプールデータの印刷日時は，蓄積したデータをスプールサーバまたはクライアントPCで印刷したタイミングで，ジョブ実行時の日時に更新されます。

データ型

String


ReportAddressKeyCategoryプロパティ

ReportAddressKeyCategoryプロパティ

スプールデータの宛先キーの分類を取得します。

解説

ReportAddressKeyCategoryプロパティは，GetSpoolFileAttributeメソッドを呼び出したあと，指定したスプールデータの宛先キーの分類を取得します。

データ型

String


ReportAddressKeyDataプロパティ

ReportAddressKeyDataプロパティ

スプールデータの宛先キーの値を取得します。

解説

ReportAddressKeyDataプロパティは，GetSpoolFileAttributeメソッドを呼び出したあと，指定したスプールデータの宛先キーの値を取得します。

データ型

String


SearchCreateTimeEndプロパティ

SearchCreateTimeEndプロパティ

スプールデータを作成日時で検索するときに，検索終了日時を指定します。

SearchCreateTimeEndプロパティを指定すると，メソッド実行速度が速くなることがあります。

解説

  • 蓄積フォルダのファイル一覧を取得する場合，検索条件としてファイル作成日時を使用するときに，検索終了日時を「YYYYMMDDhhmmss」形式で指定します。指定できる文字列は，14バイトまでです。
    「YYYYMMDDhhmmss」形式の内容を次に示します。
    • YYYY：年（西暦）を4桁で示します。
    • MM：月（01～12）を2桁で示します。01～09は，ゼロ埋めします。
    • DD：日（01～31）を2桁で示します。01～09は，ゼロ埋めします。
    • hh：時（00～23）を2桁で示します。00～09は，ゼロ埋めします。
    • mm：分（00～59）を2桁で示します。00～09は，ゼロ埋めします。
    • ss：秒（00～59）を2桁で示します。00～09は，ゼロ埋めします。
    （指定例）
    2006年11月8日15:1:40　→　20061108150140
  • SearchCreateTimeEndプロパティは，GetSpoolFileOutlineメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，SearchCreateTimeEndプロパティを指定しても無視されます。

データ型

String


SearchCreateTimeStartプロパティ

SearchCreateTimeStartプロパティ

スプールデータを作成日時で検索するときに，検索開始日時を指定します。

SearchCreateTimeStartプロパティを指定すると，メソッド実行速度が速くなることがあります。

解説

  • 蓄積フォルダのファイル一覧を取得する場合，検索条件としてファイル作成日時を使用するときに，検索開始日時を「YYYYMMDDhhmmss」形式で指定します。指定できる文字列は，14バイトまでです。
    「YYYYMMDDhhmmss」形式の内容を次に示します。
    • YYYY：年（西暦）を4桁で示します。
    • MM：月（01～12）を2桁で示します。01～09は，ゼロ埋めします。
    • DD：日（01～31）を2桁で示します。01～09は，ゼロ埋めします。
    • hh：時（00～23）を2桁で示します。00～09は，ゼロ埋めします。
    • mm：分（00～59）を2桁で示します。00～09は，ゼロ埋めします。
    • ss：秒（00～59）を2桁で示します。00～09は，ゼロ埋めします。
    （指定例）
    2006年5月23日9:56:30　→　20060523095630
  • SearchCreateTimeStartプロパティは，GetSpoolFileOutlineメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，SearchCreateTimeStartプロパティを指定しても無視されます。

データ型

String


SearchJobIDプロパティ

SearchJobIDプロパティ

スプールデータを検索するジョブIDを指定します。

解説

  • ジョブIDに指定できる文字列は，36バイトまでです。
  • GetSpoolFileメソッド，GetSpoolFileAttributeメソッド，PrintSpoolReportメソッド，およびSetSpoolFileAttributeメソッドを呼び出す場合に使用するときは，必ずSearchJobIDプロパティを指定してください。
  • GetSpoolFileOutlineメソッドを呼び出す場合に使用するときは，SearchJobIDプロパティの指定は任意です。
  • DeleteSpoolFileメソッドを呼び出す場合に使用するときは，DeleteKindプロパティの指定によって次のように異なります。
    • 指定したジョブIDのスプールデータの削除（DeleteKind=0）のときは，必ず指定してください。
    • 蓄積期限切れファイルの削除（DeleteKind=1）のときは，指定する必要はありません。
  • SearchJobIDプロパティは，GetSpoolFileOutlineメソッド，GetSpoolFileAttributeメソッド，SetSpoolFileAttributeメソッド，PrintSpoolReportメソッド，GetSpoolFileメソッド，およびDeleteSpoolFileメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，SearchJobIDプロパティを指定しても無視されます。

データ型

  • String（PrintSpoolReportメソッド，GetSpoolFileメソッド，またはDeleteSpoolFileメソッドを呼び出す場合に一つのジョブIDを指定するとき）
  • String配列（PrintSpoolReportメソッド，GetSpoolFileメソッド，またはDeleteSpoolFileメソッドを呼び出す場合に複数のジョブIDを指定するとき）
  • String（上記以外のメソッドを呼び出す場合）


SearchJobKeyCategoryプロパティ

SearchJobKeyCategoryプロパティ

スプールデータをジョブ検索キーで検索するときに，ジョブ検索キーの分類を指定します。

解説

  • 蓄積フォルダのファイル一覧を取得する場合，検索条件としてSearchJobKeyCategoryプロパティで指定したジョブ検索キーの分類と，SearchJobKeyDataプロパティで指定したジョブ検索キーの配列値の順番が一致するものを検索します。
  • ジョブ検索キーを指定する場合は，1～10個の配列で指定してください。また，SearchJobKeyCategoryプロパティを指定する場合は，ジョブ検索キーの分類に対応する検索キーの値を必ずSearchJobKeyDataプロパティに指定してください。このとき，配列の要素数は同じにしてください。配列の要素数が異なると，エラーになります。
    ジョブ検索キーを指定しない場合，SearchJobKeyCategoryプロパティとSearchJobKeyDataプロパティは，どちらも指定しないでください。どちらかの指定があると対応する情報がないため，エラーになります。
  • 分類は，任意文字列を指定できます。指定するときは，次のことに注意してください。
    • 文字列は，80バイト以内で指定してください。
    • 文字列に「,」を含めないでください。
    • 空文字列「""」は指定しないでください。
  • SearchJobKeyCategoryプロパティは，GetSpoolFileOutlineメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，SearchJobKeyCategoryプロパティを指定しても無視されます。

データ型

String 配列


SearchJobKeyDataプロパティ

SearchJobKeyDataプロパティ

スプールデータをジョブ検索キーで検索するときに，ジョブ検索キーの値を指定します。

解説

  • 蓄積フォルダのファイル一覧を取得する場合，検索条件としてSearchJobKeyCategoryプロパティで指定したジョブ検索キーの分類と，SearchJobKeyDataプロパティで指定したジョブ検索キーの配列値の順番が一致するものを検索します。
  • ジョブ検索キーを指定する場合は，1～10個の配列で指定してください。また，SearchJobKeyCategoryプロパティを指定する場合は，ジョブ検索キーの分類に対応する検索キーの値を必ずSearchJobKeyDataプロパティに指定してください。このとき，配列の要素数は同じにしてください。配列の要素数が異なると，エラーになります。
    ジョブ検索キーを指定しない場合，SearchJobKeyCategoryプロパティとSearchJobKeyDataプロパティは，どちらも指定しないでください。どちらかの指定があると対応する情報がないため，エラーになります。
  • ジョブ検索キーの値は，任意文字列を指定できます。指定するときは，次のことに注意してください。
    • 文字列は，80バイト以内で指定してください。
    • 文字列に「,」を含めないでください。
  • SearchJobKeyDataプロパティは，GetSpoolFileOutlineメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，SearchJobKeyDataプロパティを指定しても無視されます。

データ型

String 配列


SearchPrinterClassNameプロパティ

SearchPrinterClassNameプロパティ

スプールデータをプリンタクラス名で検索するときに，プリンタクラス名を指定します。

解説

  • プリンタクラス名は，任意の文字列を指定できます。指定するときは，次のことに注意してください。
    • プリンタクラス名は，80バイト以内で指定してください。
    • プリンタクラス名に「"」および「,」を含めないでください。
  • SearchPrinterClassNameプロパティは，GetSpoolFileOutlineメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，SearchPrinterClassNameプロパティを指定しても無視されます。

データ型

String


SearchReportAddressKeyCategoryプロパティ

SearchReportAddressKeyCategoryプロパティ

スプールデータを宛先キーで検索するときに，宛先キーの分類を指定します。

解説

  • 宛先キーの分類は，任意の文字列を指定できます。次のことに注意して指定してください。
    • 文字列は，1～80バイトで指定してください。
    • 文字列に，「"」，「,」および制御コード（0x00～0x1F，0x7F～0x9F）を含めないでください。
  • 蓄積フォルダのファイル一覧を取得する場合，SearchReportAddressKeyCategoryプロパティで指定した宛先キーの分類と，SearchReportAddressKeyDataプロパティで指定した宛先キーの値が一致するものを検索します。
  • SearchReportAddressKeyDataプロパティが指定されていない場合エラーになります。

データ型

String配列


SearchReportAddressKeyDataプロパティ

SearchReportAddressKeyDataプロパティ

スプールデータを宛先キーで検索するときに，宛先キーの値を指定します。

解説

  • 宛先キーの値は，任意の文字列を指定できます。次のことに注意して指定してください。
    • 文字列は，1～80バイトで指定してください。
    • 文字列に，「"」，「,」および制御コード（0x00～0x1F，0x7F～0x9F）を含めないでください。
  • 蓄積フォルダのファイル一覧を取得する場合，SearchReportAddressKeyCategoryプロパティで指定した宛先キーの分類と，SearchReportAddressKeyDataプロパティで指定した宛先キーの値が一致するものを検索します。
  • SearchReportAddressKeyCategoryプロパティが指定されていない場合エラーになります。

データ型

String配列


SearchSpoolFileNameプロパティ

SearchSpoolFileNameプロパティ

スプールデータをスプールデータに格納されているEPF形式ファイル名で検索するときに，EPF形式ファイル名を指定します。

解説

  • EPF形式ファイル名は，255バイト以内になるように指定してください。
  • SearchSpoolFileNameプロパティは，GetSpoolFileOutlineメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，SearchSpoolFileNameプロパティを指定しても無視されます。

データ型

String


ServerAddressプロパティ

ServerAddressプロパティ

スプールサーバのIPアドレスを指定します。

解説

  • スプールサーバのIPアドレスを「255.255.255.255」形式で指定します。指定できる文字列は，15バイトまでです。
  • ServerAddressプロパティの指定がない場合は，EUR Server - Spool Service Adapterの環境設定ファイル（EURPMLSADP.ini）のIPADDRESSセクションのEURPMLSキーに設定されているEUR Server - Spool Serviceが稼働するサーバのIPアドレスが仮定されます。EURPMLSキーが省略されているとき，または値が指定されていないときは，デフォルト値（127.0.0.1）が仮定されます。
  • ServerAddressプロパティは，次に示すメソッドで操作する場合，指定が有効になります。それ以外のメソッドでは，ServerAddressプロパティを指定しても無視されます。
    • GetSpoolFileOutlineメソッド，GetSpoolFileAttributeメソッド，SetSpoolFileAttributeメソッド，PrintSpoolReportメソッド，GetSpoolFileメソッド，DeleteSpoolFileメソッドでスプールデータを操作するとき
    • GetPrinterClassListメソッドでプリンタクラス一覧を取得するとき
    • GetPrinterListメソッドでプリンタ一覧を取得するとき
    • GetTrayListメソッドでトレイ一覧を取得するとき

データ型

String


ServerPrinterListプロパティ

ServerPrinterListプロパティ

スプールサーバでのOS上のプリンタ一覧を取得します。

解説

  • ServerPrinterListプロパティは，GetPrinterListメソッドでプリンタ一覧を取得する場合だけ値が取得されます。それ以外のメソッドでは，ServerPrinterListプロパティを指定しても無視されます。

データ型

String 配列


ServerPrinterNameプロパティ

ServerPrinterNameプロパティ

スプールサーバでのOS上のプリンタ名を指定または取得します。

解説

  • ServerPrinterNameプロパティは，次に示すどのメソッドを呼び出すかによって，値が異なります。
    • GetSpoolFileAttributeメソッドを呼び出したあと
      スプールデータを蓄積スプールサーバ印刷するときのOS上のプリンタ名を取得します。
    • SetSpoolFileAttributeメソッド，およびPrintSpoolReportメソッドを呼び出す前
      スプールデータを蓄積スプールサーバ印刷するときのOS上のプリンタ名を指定します。
    • GetTrayListメソッドを呼び出す前
      トレイ一覧を取得したいスプールサーバでのOS上のプリンタ名を指定します。
  • GetTrayListメソッドを呼び出す場合に使用するときは，必ずServerPrinterNameプロパティを指定してください。
  • SetSpoolFileAttributeメソッド，およびPrintSpoolReportメソッドを呼び出す場合に使用するときは，ServerPrinterNameプロパティの指定は任意です。
  • プリンタ名を指定するときは，次のことに注意してください。
    • プリンタ名は，80バイト以内で指定してください。
    • プリンタ名に「"」および「,」を含めないでください。
  • ServerPrinterNameプロパティは，GetSpoolFileAttributeメソッド，およびSetSpoolFileAttributeメソッドでスプールデータを操作する場合，PrintSpoolReportメソッドで蓄積スプールサーバ印刷する場合でプリンタ指定方式にOS上のプリンタ名指定（PrinterSelectMode=1）を指定したとき，ならびにGetTrayListメソッドでトレイ一覧を取得する場合に指定が有効になります。それ以外のメソッドでは，ServerPrinterNameプロパティを指定しても無視されます。
  • 蓄積スプールサーバ印刷でServerPrinterNameプロパティの指定が有効な場合に，ServerPrinterNameプロパティの指定を省略したときや空文字を指定したときは，デフォルトのプリンタで印刷します。

データ型

String


ServerTrayListプロパティ

ServerTrayListプロパティ

ServerPrinterNameプロパティで指定したOS上のプリンタのトレイ一覧を取得します。

解説

  • ServerTrayListプロパティは，GetTrayListメソッドでトレイ一覧を取得する場合だけ値が取得されます。それ以外のメソッドでは，ServerTrayListプロパティを指定しても無視されます。

データ型

String 配列


ServerTrayNameプロパティ

ServerTrayNameプロパティ

スプールサーバでのOS上のプリンタのトレイ名を指定または取得します。

解説

  • ServerTrayNameプロパティは，次に示すメソッドを呼び出すタイミングによって，値が異なります。
    • GetSpoolFileAttributeメソッドを呼び出したあと
      蓄積スプールサーバ印刷するときの，OS上のプリンタのトレイ名が取得されます。
    • SetSpoolFileAttributeメソッド，およびPrintSpoolReportメソッドを呼び出す前
      蓄積スプールサーバ印刷するときの，OS上のプリンタのトレイ名を指定します。
  • トレイ名を指定するときは，次のことに注意してください。
    • トレイ名は，80バイト以内で指定してください。
    • トレイ名には「"」および「,」を含めないでください。
  • ServerTrayNameプロパティは，GetSpoolFileAttributeメソッド，およびSetSpoolFileAttributeメソッドでスプールデータを操作する場合，ならびにPrintSpoolReportメソッドで蓄積スプールサーバ印刷する場合でプリンタ指定方式にOS上のプリンタ名指定（PrinterSelectMode=1）を指定したときに指定が有効になります。それ以外のメソッドでは，ServerTrayNameプロパティを指定しても無視されます。
  • 蓄積スプールサーバ印刷でServerTrayNameプロパティの指定が有効な場合に，ServerTrayNameプロパティの指定を省略したときや空文字を指定したときは，デフォルトのトレイから給紙されます。

データ型

String


SortPrintプロパティ

SortPrintプロパティ

印刷部数の単位を指定します。

解説

指定できる値を次に示します。

  • 0：部単位で出力します。
  • 1：ページ単位で出力します。

SortPrintプロパティを省略した場合，次の値が仮定されます。

  • ジョブIDを一つだけ指定しているとき
    指定したジョブIDのスプールデータに格納されているEPF形式ファイルの属性情報に設定されている値
  • ジョブIDを複数指定しているとき
    0

SortPrintプロパティは，GetSpoolFileメソッドでスプールデータを操作する場合，およびPrintSpoolReportメソッドで蓄積スプールサーバ印刷する場合に指定が有効になります。それ以外の場合は，SortPrintプロパティを指定しても無視されます。

データ型

Long


SpoolFileNameプロパティ

SpoolFileNameプロパティ

スプールデータにあるEPF形式ファイル名を取得します。

解説

  • SpoolFileNameプロパティは，次に示すメソッドを呼び出すタイミングによって，スプールデータにあるEPF形式ファイル名の取得情報が異なります。
    • GetSpoolFileOutlineメソッドを呼び出したあと
      検索条件に合ったスプールデータにあるEPF形式ファイル名が配列で取得されます。
    • GetSpoolFileAttributeメソッドを呼び出したあと
      指定したジョブIDのスプールデータにあるEPF形式ファイル名が取得されます。
  • SpoolFileNameプロパティは，GetSpoolFileOutlineメソッド，およびGetSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，SpoolFileNameプロパティを指定しても無視されます。

データ型

  • String配列（GetSpoolFileOutlineメソッドを呼び出したあとの場合）
  • String（GetSpoolFileAttributeメソッドを呼び出したあとの場合）


SpoolFileSizeプロパティ

SpoolFileSizeプロパティ

指定したジョブIDのスプールデータにあるEPF形式ファイルのサイズ（バイト）を取得します。

解説

  • SpoolFileSizeプロパティは，GetSpoolFileAttributeメソッドでスプールデータの属性情報を取得する場合に取得されます。それ以外のメソッドでは，SpoolFileSizeプロパティを指定しても無視されます。

データ型

Long


SpoolHistoryプロパティ

SpoolHistoryプロパティ

スプールデータの履歴を取得します。

解説

  • GetSpoolFileAttributeメソッドを呼び出すことで，スプールデータの履歴が情報数分取得されます。取得されるスプールデータの履歴の形式を次に示します。
    [操作種別][操作日時][IPアドレス][操作対象][変更前][変更後][印刷実行結果]
    （出力例）
    [拠点印刷][20060314164300][255.255.xxx.xxx][][][][印刷済み]
    [変更][20060314181501][255.255.xxx.xxx][プリンタクラス][標準][A3][]
    [取得][20060314190506][255.255.xxx.xxx][][][][]
  • 蓄積直後の配列の要素数は0です。
  • SpoolHistoryプロパティは，GetSpoolFileAttributeメソッドでスプールデータの属性情報を取得する場合に取得されます。それ以外のメソッドでは，SpoolHistoryプロパティを指定しても無視されます。

データ型

String 二次元配列


SpoolLimitプロパティ

SpoolLimitプロパティ

スプールデータの蓄積期限日を指定または取得します。

解説

  • SpoolLimitプロパティは，次に示すメソッドを呼び出すタイミングによって，値が異なります。
    • GetSpoolFileAttributeメソッドを呼び出したあと
      スプールデータの蓄積期限日が取得されます。
    • SetSpoolFileAttributeメソッドを呼び出す前
      スプールデータの蓄積期限日を指定します。
  • スプールデータの蓄積期限日は「YYYYMMDD」形式で指定します。指定できる文字列は，8バイトまでです。
    「YYYYMMDD」形式の内容を次に示します。
    • YYYY：年（西暦）を4桁で示します。
    • MM：月（01～12）を2桁で示します。01～09は，ゼロ埋めします。
    • DD：日（01～31）を2桁で示します。01～09は，ゼロ埋めします。
    （指定例）
    2006年5月23日　→　20060523
  • SpoolLimitプロパティは，GetSpoolFileAttributeメソッド，およびSetSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，SpoolLimitプロパティを指定しても無視されます。

データ型

String


SpoolPathプロパティ

SpoolPathプロパティ

常に""が取得されます。

解説

  • SpoolPathプロパティは，次に示すどちらのメソッドを呼び出しても，常に""が取得されます。
    • GetSpoolFileOutlineメソッドを呼び出したあと
    • GetSpoolFileAttributeメソッドを呼び出したあと
  • SpoolPathプロパティは，GetSpoolFileOutlineメソッド，およびGetSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，SpoolPathプロパティを指定しても無視されます。

データ型

  • String 配列（GetSpoolFileOutlineメソッドを呼び出したあとの場合）
  • String（GetSpoolFileAttributeメソッドを呼び出したあとの場合）


SpoolTitleプロパティ

SpoolTitleプロパティ

スプールタイトルを指定します。

解説

  • スプールタイトルには，任意文字列を指定できます。次のことに注意して指定してください。
    • スプールタイトルは，255バイト以内で指定してください。
    • スプールタイトルには「"」および「,」を含めないでください。
    • 空文字を指定したときは，スプールタイトル情報は未設定となります。
  • SpoolTitleプロパティは，GetSpoolFileメソッドでスプールデータを操作する場合，およびPrintSpoolReportメソッドで印刷する場合に指定が有効になります。それ以外のメソッドでは，SpoolTitleプロパティを指定しても無視されます。
  • SpoolTitleプロパティの指定を省略した場合は，次のようになります。
    • ジョブIDを一つだけ指定しているとき
      指定したジョブIDのスプールデータに格納されているEPF形式ファイルの属性情報が設定されます。
    • ジョブIDを複数指定しているとき
      スプールタイトル情報は未設定となります。

データ型

String


エラー情報

7.5　エラー情報

ActiveX起動部品，またはSS-ActiveX起動部品を使用して実行している場合にエラーが発生したときは，ErrオブジェクトのNumberプロパティに終了コード，Descriptionプロパティにメッセージが設定されます。

＜この節の構成＞
7.5.1　SS-ActiveX起動部品実行時のエラー情報一覧
7.5.2　Err.Numberプロパティ（終了コード）
7.5.3　Err.Descriptionプロパティ（メッセージ文）


SS-ActiveX起動部品実行時のエラー情報一覧

7.5.1　SS-ActiveX起動部品実行時のエラー情報一覧

SS-ActiveX起動部品実行時のエラー情報の一覧を次に示します。

表7-3　 SS-ActiveX起動部品実行時のエラー情報の一覧

終了コード | メッセージ文
-501 | プロパティ(プロパティ名)の指定値に誤りがあります。
-502 | プロパティ(プロパティ名)が指定されていません。
-503 | 原因不明のエラーで処理が中断されました。EUR Spool Serviceの状態を確認してください。
-504 | 印刷開始ページの入力値が印刷終了ページの入力値より大きいです。
-505 | 環境設定ファイルに不正があります。詳細コード = [nnnnnn]
-506 | ログファイルの書き込みに失敗しました。
-507 | EUR Spool Serviceへの接続に失敗しました。
-508 | ジョブを起動しました。
-509 | ジョブを終了しました。
-510 | メモリ不足が発生しました。
-511 | 通信タイムアウトが発生しました。
-512 | システムエラーが発生しました。
-513 | 蓄積ファイル一覧取得処理でエラーが発生しました。（nnn）
-515 | プリンタクラス一覧取得処理でエラーが発生しました。（nnn）
-516 | プリンタ一覧取得処理でエラーが発生しました。（nnn）
-517 | トレイ一覧取得処理でエラーが発生しました。（nnn）
-518 | 蓄積ファイルの取得処理でエラーが発生しました。（nnn）
-519 | 蓄積ファイルの印刷処理でエラーが発生しました。（nnn）
-520 | 蓄積ファイルの属性取得処理でエラーが発生しました。（nnn）
-521 | 蓄積ファイルの属性設定処理でエラーが発生しました。（nnn）
-522 | 蓄積ファイルの削除処理でエラーが発生しました。（nnn）
-523 | 蓄積ファイルの初期化に失敗しました。
-524 | 蓄積ファイルの作成に失敗しました。
-525 | EUR Spool Serviceでコネクション数が限界値をオーバーしました。
-526 | レジストリに不正があります。詳細コード = [nnnnnn]
-527 | 指定された蓄積ファイルはほかの人が使用中です。
-528 | 属性値設定プロパティが一つも指定されていません。
-529 | EUR Client Serviceでコネクション数が限界値をオーバーしました。
-531 | 蓄積ファイルのデータ取得処理でエラーが発生しました。（nnn）
-532 | 蓄積ファイル一覧取得処理で警告が発生しました。（nnn）
-533 | 蓄積ファイルの取得処理で警告が発生しました。（nnn）
-534 | 蓄積ファイルの印刷処理で警告が発生しました。（nnn）
-535 | 蓄積ファイルの属性取得処理で警告が発生しました。（nnn）
-536 | 蓄積ファイルの属性設定処理で警告が発生しました。（nnn）
-537 | 蓄積ファイルの削除処理で警告が発生しました。（nnn）
-538 | 指定されたジョブID検索値の数が上限値を超えています。
-540 | An attempt to load string resource DLL has failed. Error:[nnn]
-541 | EUR Spool Serviceのバージョンが不正です。
-542 | ユーザ認証に失敗しました。（nnn）
-543 | 配送帳票取得処理でエラーが発生しました。（nnn）
-544 | 帳票一覧取得処理でエラーが発生しました。（nnn）
-545 | 蓄積ファイル一覧取得処理で警告が発生しました。（nnn）
-546 | 蓄積ファイルの取得処理で警告が発生しました。（nnn）
-547 | 蓄積ファイルの印刷処理で警告が発生しました。（nnn）
-548 | 蓄積ファイルの属性取得処理で警告が発生しました。（nnn）
-549 | 蓄積ファイルの属性設定処理で警告が発生しました。（nnn）
-550 | 蓄積ファイルの削除処理で警告が発生しました。（nnn）
-551 | ログイン処理でエラーが発生しました。（nnn）
-552 | 監査ログファイルの切り替えに失敗しました。（nnn）
-553 | 監査ログ切り替え機能で警告が発生しました。（nnn）


Err.Numberプロパティ（終了コード）

7.5.2　Err.Numberプロパティ（終了コード）

ActiveX起動部品，またはSS-ActiveX起動部品のメソッドの実行でエラーが発生した場合，ErrオブジェクトのNumberプロパティに終了コードが設定，または更新されます。正常終了した場合は，終了コードは更新されません。そのため，ActiveX起動部品，またはSS-ActiveX起動部品のメソッドの実行後にNumberプロパティの終了コードを参照しても正しいエラー判定ができません。

ActiveX起動部品，またはSS-ActiveX起動部品のメソッドを実行する前は，Numberプロパティに終了コードが設定されていない（エラーが発生していない）ことを判定してからEUR Server Serviceのメソッドを実行することをお勧めします。

終了コードとメッセージの一覧については，「6.5.1　ActiveX起動部品実行時のエラー情報一覧」，または「7.5.1　SS-ActiveX起動部品実行時のエラー情報一覧」を参照してください。エラーの対処については，マニュアル「EUR メッセージ」を参照してください。


Err.Descriptionプロパティ（メッセージ文）

7.5.3　Err.Descriptionプロパティ（メッセージ文）

ErrオブジェクトのDescriptionプロパティは，エラー，または警告発生時のメッセージが設定されます。終了コードとメッセージの一覧については，「6.5.1　ActiveX起動部品実行時のエラー情報一覧」，または「7.5.1　SS-ActiveX起動部品実行時のエラー情報一覧」を参照してください。エラーの対処については，マニュアル「EUR メッセージ」を参照してください。


Java起動部品

8.　Java起動部品

この章では，EUR Server Serviceで提供するJava起動部品を使用した帳票出力について説明します。

＜この章の構成＞
8.1　Java起動部品とは
8.2　EURPMAdapterForJavaクラス
8.3　EURPMExceptionクラス
8.4　EURPMAdapterForJavaクラスのメソッド仕様
8.5　EURPMExceptionクラスのメソッド仕様
8.6　例外情報


Java起動部品とは

8.1　Java起動部品とは

サーバ側で動作するJavaプログラムから，EUR Server Serviceを起動して帳票出力できる部品を提供しています。これを，Java起動部品といいます。

Web/APサーバ側のアプリケーション実行環境からJava起動部品を利用することで，サーバ側のアプリケーションを効率良く作成できます。

Java起動部品は，帳票ファイル名などを設定メソッドで設定し，実行メソッドを呼び出して帳票を出力します。

＜この節の構成＞
8.1.1　JDKバージョン
8.1.2　ファイル名
8.1.3　パッケージ


JDKバージョン

8.1.1　JDKバージョン

Java起動部品（EURPMAdapter.jar）が前提とするJDKのバージョンを次に示します。

表8-1　Java起動部品のJDKバージョン

OS | JDKのバージョン
Windows | JDK 5.0以降
AIX | JDK 5.0以降
HP-UX | JDK 5.0以降
Linux | JDK 5.0以降


ファイル名

8.1.2　ファイル名

＜この項の構成＞
(1)　Java起動部品のファイル構成
(2)　Java起動部品の設定方法

(1)　Java起動部品のファイル構成

(a)　Windows環境の場合

Java起動部品は，次に示す二つのファイルから構成されます。

  • EURPMAdapter.jar
  • EURPMADJ.dll

EURPMAdapter.jarとEURPMADJ.dllは，EUR Server - Adapterをインストールしたときに，次に示すフォルダにインストールされます。

32ビットプログラムから呼び出すとき
インストール先フォルダ\Adapter\Java
64ビットプログラムから呼び出すとき
インストール先フォルダ\Adapter\Java(x64)
(b)　UNIX／Linux環境の場合

Java起動部品は，次に示す二つのファイルから構成されます。

  • EURPMAdapter.jar
  • libEURPMADJ.so

EURPMAdapter.jarは，EUR Server - Adapterをインストールしたときに，次に示すディレクトリにインストールされます。

/opt/eur/adapter/java/

libEURPMADJ.soは，次に示すディレクトリにインストールされます。

32ビットプログラムから呼び出すとき
/opt/eur/adapter/lib/
64ビットプログラムから呼び出すとき
/opt/eur/adapter/lib64/

(2)　Java起動部品の設定方法

Java起動部品の設定方法を次に示します。両方とも実施してください。

  • EURPMAdapter.jarファイルのフルパスをクラスパスに追加します。
  • Windows環境の場合はEURPMADJ.dllのインストール先フォルダに，UNIX／Linux環境の場合はlibEURPMADJ.soのインストール先ディレクトリに，ライブラリのパスを通します。

JSPやJavaサーブレットアプリケーションで管理するフォルダ，クラスパスの設定，およびライブラリのパスの設定については，JSP環境のマニュアルを参照してください。


パッケージ

8.1.3　パッケージ

Java起動部品では，JP.co.Hitachi.soft.EURPMパッケージを提供します。

JP.co.Hitachi.soft.EURPMパッケージは，次に示すクラスを提供します。

  • 帳票出力の制御を行うクラス
    EURPMAdapterForJava：帳票出力を制御するクラス
  • 例外の制御を行うクラス
    EURPMException：帳票出力時に発生するエラー（例外）を管理するクラス


EURPMAdapterForJavaクラス

8.2　EURPMAdapterForJavaクラス

EURPMAdapterForJavaクラスは，帳票出力を制御するクラスです。

public class EURPMAdapterForJava
クラス継承
java.lang.Object
JP.co.Hitachi.soft.EURPM.EURPMAdapterForJava
解説
帳票ファイル，データファイル，出力種別（プリンタ出力，EPF形式ファイル，PDF形式ファイル，EUR形式ファイル，またはExcel形式ファイル）などのプロパティを設定するメソッドと，帳票出力を行うメソッドを提供します。
JSPやJavaサーブレットなどのアプリケーションプログラムからは，次に示す手順で帳票出力をします。
  1. CSV形式ファイルの作成
  2. EURPMAdapterForJavaオブジェクトの作成
  3. プロパティの設定
    帳票ファイル，データファイル，出力種別（プリンタ出力，EPF形式ファイル，PDF形式ファイル，EUR形式ファイル，またはExcel形式ファイル）などのプロパティを設定するメソッドに情報を設定します。メソッドの設定については，「8.4　EURPMAdapterForJavaクラスのメソッド仕様」を参照してください。
    なお，参照先にActiveX起動部品のプロパティ名が指定されている場合は，対応するJava起動部品のメソッドに置き換えてください。
  4. 帳票の出力
    帳票出力メソッドを呼び出して帳票を出力します。
3.と4.の処理で発生したエラー，または発生するエラーは，例外を処理するようにプログラムに記述します。
＜この節の構成＞
8.2.1　コンストラクタ
8.2.2　メソッド一覧
8.2.3　指定値に使用できない文字について


コンストラクタ

8.2.1　コンストラクタ

EURPMAdapterForJavaクラスのコンストラクタは，EURPMAdapterForJavaオブジェクトを生成します。

public EURPMAdapterForJava() throws EURPMException
解説
ユーザアプリケーションプログラムからコンストラクタを呼び出すことで，EURPMAdapterForJavaオブジェクトを生成します。帳票ファイル名，データファイル，出力種別（プリンタ出力，EPF形式ファイル，PDF形式ファイル，EUR形式ファイル，またはExcel形式ファイル）などを，EURPMAdapterForJavaクラスのメソッドで設定したあと，帳票出力メソッドで帳票出力をします。
引数
なし
例外処理
EURPMException
EURPMAdapterForJavaオブジェクトの生成時にエラーが発生したときは，EURPMExceptionクラスの例外が発生します。


メソッド一覧

8.2.2　メソッド一覧

EURPMAdapterForJavaクラスのメソッドには，帳票の出力や出力情報を採取するメソッド（実行メソッド）と，帳票を出力するために帳票ファイル名やデータファイル名などの情報を設定するメソッド（設定メソッド）があります。また，実行メソッドには，出力情報などを取得するメソッド（情報取得メソッド）と，帳票を出力するメソッド（出力メソッド）があります。実行メソッドを表8-2に示します。

表8-2　EURPMAdapterForJavaクラスの実行メソッド

種類 | メソッド | 概要
情報取得メソッド | getDestinationList | 出力先（スプールサーバ）の一覧を取得します。
 | getJobID | getJobIDメソッドを実行する直前に蓄積したスプールデータのジョブIDを取得します。 帳票を分割または仕分けして蓄積した場合など，直前に蓄積したスプールデータが複数あるときは，最初に蓄積したスプールデータのジョブIDを取得します。
 | getJobIDList | getJobIDListメソッドを実行する直前に蓄積したスプールデータのジョブIDの一覧を取得します。
 | getPMPrinterClassList | 帳票サーバに登録されているプリンタクラスの一覧を取得します。
 | getPMPrinterList ※1 | 帳票サーバのOSに登録されているプリンタの一覧を取得します。
 | getPMTrayList ※1 | 帳票サーバのOSに登録されているプリンタのトレイ一覧を取得します。
 | getPreviewAXClassID | EUR Web Plug-In（プレビュー用）のクラスIDを取得します。
 | getPreviewAXVersion | EUR Web Plug-In（プレビュー用）のバージョンを取得します。
 | getPrintAXClassID | EUR Web Plug-In（印刷用）のクラスIDを取得します。
 | getPrintAXVersion | EUR Web Plug-In（印刷用）のバージョンを取得します。
 | getPrinterClassList ※2 | 指定した出力先（スプールサーバ）に登録されているプリンタクラスの一覧を取得します。
 | getPrinterList ※2 | 指定した出力先（スプールサーバ）のOSに登録されているプリンタの一覧を取得します。
 | getTrayList ※2 | 指定した出力先（スプールサーバ）のOSに登録されているプリンタのトレイ一覧を取得します。
出力メソッド | getEPFReport | EPF形式データをメモリに取得します。
 | getEURReport | EUR形式データをメモリに取得します。
 | getMergeEPFReport | 複数のEPF形式ファイルを一つに統合してメモリに取得します。
 | getPDFReport | PDF形式データをメモリに取得します。
 | getXLSXReport | Excel形式データをメモリに取得します。
 | outputEPFReport | EPF形式ファイルを出力します。
 | outputEURReport | EUR形式ファイルを出力します。
 | outputMergeEPFReport | 複数のEPF形式ファイルを一つのEPF形式ファイルに統合して出力します。
 | outputPDFReport | PDF形式ファイルを出力します。
 | outputXLSXReport | Excel形式ファイルを出力します。
 | printReport | 帳票を印刷または蓄積します。
注※1
帳票サーバがUNIX／Linux環境の場合は指定できません。
注※2
対象となるスプールサーバがUNIX／Linux環境の場合は指定できません。

EURPMAdapterForJavaクラスのメソッドのうち，出力メソッドで使用する設定メソッドを表8-4に示します。表8-4では，出力メソッドを表8-3のように省略して表記します。

表8-3　出力メソッドの略称

略称 | 出力メソッド
PMRS | printReport（スプールサーバでの印刷）
PMRC | printReport（クライアントPCでの印刷）
PMRT | printReport（蓄積）
PMRD | printReport（直接印刷）
PMRH | printReport（クライアントPCへの配布印刷）
PDF | outputPDFReport（PDF形式ファイル出力）または getPDFReport（PDF形式データ出力）
EPF | outputEPFReport（EPF形式ファイル出力）または getEPFReport（EPF形式データ出力）
MEPF | outputMergeEPFReport（複数EPF形式ファイル統合出力）または getMergeEPFReport（複数EPF形式ファイル統合データ出力）
EUR | outputEURReport（EUR形式ファイル出力）または getEURReport（EUR形式データ出力）
XLSX | outputXLSXReport（Excel形式ファイル出力）または getXLSXReport（Excel形式データ出力）

表8-4　 EURPMAdapterForJavaクラスの出力メソッドで使用する設定メソッド

メソッド | 設定内容 | 出力メソッド
 |  | PMRS | PMRC | PMRT | PMRD | PMRH | PDF | EPF | MEPF | EUR | XLSX
setBookmarkFileData | しおり定義データ | － | － | － | － | － | △ | － | － | － | －
setBookmarkFileName | しおり定義ファイル名 | － | － | － | － | － | △ | － | － | － | －
setBookmarkFilePath | 文書しおり定義ファイルのパス，およびしおり定義ファイルのパス | － | － | － | － | － | △ | － | － | － | －
setClientAddress | クライアントPCのIPアドレス | － | △ | △ | － | △ | － | － | － | － | －
setClientPrinterName | 印刷先クライアントプリンタ名 | － | △ | △ | － | △ | － | － | － | － | －
setClientTrayName | 印刷先クライアントプリンタのトレイ名 | － | △ | △ | － | △ | － | － | － | － | －
setCrypto | PDF形式ファイルの暗号化出力の有無 | － | － | － | － | － | △ | － | － | － | －
setCryptoFileData | 暗号化設定データ | － | － | － | － | － | △ | － | － | － | －
setCryptoFileName | 暗号化設定ファイル名 | － | － | － | － | － | △ | － | － | － | －
setCryptoFilePath | 暗号化設定ファイルのパス | － | － | － | － | － | △ | － | － | － | －
setDataFileData | マッピングデータまたは可変記号値定義データ | △ | △ | △ | △ | － | △ | △ | － | △ | △
setDataFileName | マッピングデータファイル名または可変記号値定義ファイル名 | △ | △ | △ | △ | － | △ | △ | － | △ | △
setDataFilePath | マッピングデータファイルのパスまたは可変記号値定義ファイルのパス | △ | △ | △ | △ | － | △ | △ | － | △ | △
setDBInfoFileName | 接続情報ファイル名 | △ | △ | △ | △ | － | △ | △ | － | △ | △
setDBInfoFilePath | 接続情報ファイルのパス | △ | △ | △ | △ | － | △ | △ | － | △ | △
setDestinationName | 帳票の出力先名 | △ | － | △ | － | － | － | － | － | － | －
setDispPrintDlg | ダイアログ表示モード | － | △ | △ | － | △ | － | － | － | － | －
setDistributeFileData | PDF仕分け定義データ | － | － | － | － | － | △ | － | － | － | －
setDistributeFileName | PDF仕分け定義ファイル名 | － | － | － | － | － | △ | － | － | － | －
setDistributeFilePath | PDF仕分け定義ファイルのパス | － | － | － | － | － | △ | － | － | － | －
setDocBookmarkFileData | 文書しおり定義データ | － | － | － | － | － | △ | － | － | － | －
setDocBookmarkFileName | 文書しおり定義ファイル名 | － | － | － | － | － | △ | － | － | － | －
setDocInfoFileName | 文書情報設定ファイル名 | △ | △ | △ | △ | － | △ | △ | － | △ | －
setDocInfoFilePath | 文書情報設定ファイルのパス | △ | △ | △ | △ | － | △ | △ | － | △ | －
setEnableGet | スプールデータに格納されているEPF形式ファイルの取得可否 | － | － | △ | － | － | － | － | － | － | －
setEncryptionPasswordKey | パスワード暗号化鍵 | － | － | － | － | － | △ | － | － | － | －
setEPFFileData | メモリ取得したEPF形式ファイルデータ | － | － | － | － | △※1 | － | － | － | － | －
setEPFFileName | EPF形式ファイル名 | － | － | － | － | △※1 | － | ○※2 | ○※2 | － | －
setEPFFilePath | EPF形式ファイルの出力フォルダ | － | － | － | － | △ | － | △※2 | △※2 | － | －
setEURFileName | 出力するEUR形式ファイル名 | － | － | － | － | － | － | － | － | ○※3 | －
setEURFilePath | 出力するEUR形式ファイルのパス | － | － | － | － | － | － | － | － | △※3 | －
setExecutablePrintMode | 実行可能印刷方式 | － | － | △ | － | － | － | － | － | － | －
setFileOutputDestination | PDF形式ファイルの出力先マシン | － | － | － | － | － | △ | － | － | － | －
setFirstPageNumber | ページ番号の初期値 | △ | △ | △ | △ | － | △ | △ | － | － | －
setGroupName | 帳票振り分け定義の振り分けグループ名 | △ | － | △ | － | － | － | － | － | － | －
setInitPageNumber | ページ番号の開始番号の初期化 | △ | △ | △ | △ | － | △ | △ | － | － | －
setJobKeyCategory | スプールデータとして格納するファイルの検索キーの分類 | － | － | △ | － | － | － | － | － | － | －
setJobKeyData | スプールデータの検索キーの値 | － | － | △ | － | － | － | － | － | － | －
setMaxPrintCount | スプールデータの上限印刷回数 | － | － | △ | － | － | － | － | － | － | －
setMergeEPFFileName | 統合対象のEPF形式ファイル名 | － | － | － | － | － | － | － | ○ | － | －
setMergeEPFFilePath | 統合対象のEPF形式ファイルのパス | － | － | － | － | － | － | － | △ | － | －
setMultiBookmarkFileName | 複数のしおり定義ファイル名 | － | － | － | － | － | △ | － | － | － | －
setMultiDataFileName | 複数のマッピングデータファイル名または可変記号値定義ファイル名 | △ | △ | △ | △ | － | △ | △ | － | △ | －
setMultiFormInfoDefFileName | 複数様式情報定義ファイル名 | △ | △ | △ | △ | － | △ | △ | － | △ | －
setMultiFormInfoDefFilePath | 複数様式情報定義ファイルのパス | △ | △ | △ | △ | － | △ | △ | － | △ | －
setMultiReportFileName | 複数の帳票ファイル名 | △ | △ | △ | ○ | － | △ | △ | － | △ | －
setMultiReportSetFileName | 帳票セット指定ファイル名 | △ | △ | △ | △ | － | △ | △ | － | △ | －
setMultiReportSetFilePath | 帳票セット指定ファイルのパス | △ | △ | △ | △ | － | △ | △ | － | △ | －
setMultiUserDataFileName | 複数のユーザ定義データファイル名または可変記号値定義ファイル名 | △ | △ | △ | △ | － | △ | △ | － | △ | －
setPageNumberFormat | ページ番号のフォーマット | △ | △ | △ | △ | － | △ | △ | － | － | －
setPageNumberLocation | 余白へのページ番号の印刷位置 | △ | △ | △ | △ | － | △ | △ | － | － | －
setPaperOrientation | 用紙の向き | △ | △ | △ | △ | － | － | △ | △ | － | －
setPDFFileName | PDF形式ファイル名 | － | － | － | － | － | ○※4, ※5 | － | － | － | －
setPDFFilePath | PDF形式ファイルのパス | － | － | － | － | － | △※5 | － | － | － | －
setPMServerAddress | 帳票サーバのIPアドレス | △ | △ | △ | △ | △ | △ | △ | △ | △ | △
setPMServerPort | 帳票サーバのポート番号 | △ | △ | △ | △ | △ | △ | △ | △ | △ | △
setPrintCopies | 印刷部数 | △ | △ | △ | △ | － | － | △ | △ | － | －
setPrintDateFileName | 印刷日時出力定義ファイル名 | △ | △ | △ | － | － | － | △ | － | － | －
setPrintDateFilePath | 印刷日時出力定義ファイルのパス | △ | △ | △ | － | － | － | △ | － | － | －
setPrintEndPage | 印刷終了ページ | △ | △ | △ | △ | － | △ | △ | － | － | △
setPrinterClassName | プリンタクラス名 | △ | △ | △ | △ | － | － | △ | △ | － | －
setPrinterSelectMode | プリンタ指定方式 | △ | － | △ | △※6 | － | － | － | － | － | －
setPrintHoldMode | 蓄積印刷方式で，蓄積後に続けて印刷するかどうか | － | － | △ | － | － | － | － | － | － | －
setPrintKind | スプールサーバ印刷方式の印刷モード | △ | － | － | － | － | － | － | － | － | －
setPrintMode | 印刷メソッド（printReportメソッド）の印刷方式 | △ | △ | △ | △ | △ | － | － | － | － | －
setPrintPageNumber | 余白へのページ番号印刷 | △ | △ | △ | △ | － | △ | △ | － | － | －
setPrintStartPage | 印刷開始ページ | △ | △ | △ | △ | － | △ | △ | － | － | △
setPSEnvFileName | EUR Server Serviceの環境設定ファイル（EURPS_ENV）名 | △ | △ | △ | △ | － | △ | △ | － | △ | △
setPSEnvFilePath | EUR Server Serviceの環境設定ファイル（EURPS_ENV）のパス | △ | △ | △ | △ | － | △ | △ | － | △ | △
setReplaceItemCntlFileName | 置き換え表管理情報ファイル名 | △ | △ | △ | △ | － | △ | △ | － | △ | △
setReplaceItemCntlFilePath | 置き換え表管理情報ファイルのパス | △ | △ | △ | △ | － | △ | △ | － | △ | △
setReportAddressKeyCategory | 宛先キーの分類 | － | － | △ | － | － | － | － | － | － | －
setReportAddressKeyData | 宛先キーの値 | － | － | △ | － | － | － | － | － | － | －
setReportFileName | 帳票ファイル名 | ○※7 | ○※7 | ○※7 | ○※7 | － | ○※7 | ○※7 | － | ○※7 | ○
setReportFilePath | 帳票ファイルのパス | △ | △ | △ | △ | － | △ | △ | － | △ | △
setScriptCntlFileName | Acrobat JavaScript定義ファイル名 | － | － | － | － | － | △ | － | － | － | －
setScriptCntlFilePath | Acrobat JavaScript定義ファイルのパス | － | － | － | － | － | △ | － | － | － | －
setServerAddress | スプールサーバのIPアドレス | △ | － | △ | － | － | － | － | － | － | －
setServerPrinterName | サーバプリンタ名 | △ | － | △ | － | － | － | － | － | － | －
setServerSelectMode | スプールサーバの選択方法 | △ | － | △ | － | － | － | － | － | － | －
setServerTrayName | サーバプリンタのトレイ名 | △ | － | △ | － | － | － | － | － | － | －
setSortPrint | 印刷部数の単位 | △ | △ | △ | △ | － | － | △ | △ | － | －
setSplitFileData | 分割/仕分け定義データ | － | － | △ | － | － | － | － | － | － | －
setSplitFileName | 分割/仕分け定義ファイル名 | － | － | △ | － | － | － | － | － | － | －
setSplitFilePath | 分割/仕分け定義ファイルのパス | － | － | △ | － | － | － | － | － | － | －
setSplitMode | 帳票を分割または仕分けするかどうか | － | － | △ | － | － | － | － | － | － | －
setSpoolFileName | スプールデータに格納するファイルのファイル名 | － | － | △ | － | － | － | － | － | － | －
setSpoolLimit | スプールデータの蓄積期限日 | － | － | △ | － | － | － | － | － | － | －
setSpoolTitle | スプールタイトル | △ | △ | △ | △ | － | － | △ | △ | △ | －
setUserDataFileData | ユーザ定義データまたは可変記号値定義データ | △ | △ | △ | △ | － | △ | △ | － | △ | △
setUserDataFileName | ユーザ定義データファイル名または可変記号値定義ファイル名 | △ | △ | △ | △ | － | △ | △ | － | △ | △
setUserDataFilePath | ユーザ定義データファイルのパスまたは可変記号値定義ファイルのパス | △ | △ | △ | △ | － | △ | △ | － | △ | △
setViewerPreferenceFileName | ビューアプレファレンス定義ファイル名 | － | － | － | － | － | △ | － | － | － | －
setViewerPreferenceFilePath | ビューアプレファレンス定義ファイルのパス | － | － | － | － | － | △ | － | － | － | －
setXLSXFileName | Excel形式ファイル名 | － | － | － | － | － | － | － | － | － | ○※8
setXLSXFilePath | Excel形式ファイルのパス | － | － | － | － | － | － | － | － | － | △※8
（凡例）
○：必ず指定します。
△：指定を省略できます。
－：指定できません。
注
指定できないメソッドを指定した場合は，その指定を無視します。
注※1
クライアントPCへの配布印刷の場合は，EPF形式ファイル名（setEPFFileNameメソッド）またはEPF形式ファイルデータ（setEPFFileDataメソッド）のどちらかを必ず指定してください。
注※2
EPF形式データ（getEPFReportメソッド）およびEPF形式データ（getMergeEPFReportメソッド）では指定できません。
注※3
EUR形式データ（getEURReportメソッド）では指定できません。
注※4
PDF仕分け定義ファイル名（setDistributeFileNameメソッド）を指定している場合は，指定を省略できます。
注※5
PDF形式データ（getPDFReportメソッド）では指定できません。
注※6
指定できるプリンタ印刷方式は，「プリンタクラス名指定」または「OS上のプリンタ名指定」です。
注※7
帳票セット指定ファイル名（setMultiReportSetFileNameメソッド）を指定している場合は，指定を省略できます。
注※8
Excel形式データ（getXLSXReportメソッド）では指定できません。

注意
EUR Print Serviceと連携して使用するメソッドでエラーが発生した場合は，次のエラーメッセージが出力されます。メッセージが表示されたときは，EUR Print Serviceのイベントログ，またはeurpsログを参照してください。
メッセージID | メッセージ
KEEY221-E | 印刷処理でエラーが発生しました。（337）
KEEY223-E | PDF形式ファイル出力処理でエラーが発生しました。（337）
KEEY225-E | EPF形式ファイル出力処理でエラーが発生しました。（337）
KEEY243-E | EUR形式ファイル出力処理でエラーが発生しました。（337）
KEEY263-E | XLSX形式ファイル出力処理でエラーが発生しました。（337）

EURPMAdapterForJavaクラスのメソッドのうち，情報取得メソッドで使用する設定メソッドを表8-6に示します。表8-6では，情報取得メソッドを表8-5のように省略して表記します。

表8-5　情報取得メソッドの略称

略称 | 情報取得メソッド
GEDL | getDestinationList（出力先一覧の取得）
GEPC | getPMPrinterClassList（帳票サーバのプリンタクラス一覧の取得）
GEPP | getPMPrinterList（帳票サーバのプリンタ一覧の取得）
GEPT | getPMTrayList（帳票サーバのトレイ一覧を取得）
GECL | getPrinterClassList（プリンタクラス一覧の取得）
GEPL | getPrinterList（プリンタ一覧の取得）
GETL | getTrayList（トレイ一覧の取得）

表8-6　EURPMAdapterForJavaクラスの情報取得メソッドで使用する設定メソッド

メソッド | 設定内容 | 情報取得メソッド
 |  | GEDL | GEPC | GEPP | GEPT | GECL | GEPL | GETL
setDestinationName | 出力先名を指定します。 | － | － | － | － | △ | △ | △
setPMServerAddress | 帳票サーバのIPアドレスを指定します。 | △ | △ | △ | △ | △ | △ | △
setPMServerPort | 帳票サーバのポート番号を指定します。 | △ | △ | △ | △ | △ | △ | △
setServerPrinterName | サーバのプリンタ名を指定します。 | － | － | － | ○ | － | － | ○
（凡例）
○：必ず指定します。
△：指定を省略できます。
－：指定できません。


指定値に使用できない文字について

8.2.3　指定値に使用できない文字について

オプションの指定値には，制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」は使用できません。これらの文字を指定した場合，帳票管理GUI，［EUR Server Service 構成定義］ダイアログ，［EUR Spool Service 構成定義］ダイアログ，および［EUR Client 構成定義］ダイアログを操作できないことがあります。


EURPMExceptionクラス

8.3　EURPMExceptionクラス

EURPMExceptionクラスは，Java起動部品の各メソッドで例外が発生した場合にスローされるクラスです。

public class EURPMException extends java.lang.Exception
クラス継承
java.lang.Exception
JP.co.Hitachi.soft.EURPM.EURPMException
解説
EURPMExceptionクラスのオブジェクトは，Java起動部品の内部で生成します。
ユーザプログラムは，このオブジェクトを例外ハンドラで受け取り，getMessageメソッド，またはgetErrorCodeメソッドを呼び出してエラー情報を取得します。
＜この節の構成＞
8.3.1　メソッド一覧
8.3.2　指定値に使用できない文字について


メソッド一覧

8.3.1　メソッド一覧

EURPMExceptionクラスのメソッドを次に示します。

表8-7　 EURPMExceptionクラスのメソッド

メソッド | 設定内容
getErrorCode | エラーコードを取得します。
getErrorLevel | エラーレベルを取得します。
getKey | メッセージのメッセージIDを取得します。
getMessage | エラーメッセージの文字列を取得します。
getOutputData | 例外発生時にエラー種別が警告の場合，EPF形式ファイルを取得します。


指定値に使用できない文字について

8.3.2　指定値に使用できない文字について

オプションの指定値に指定できない文字については，「8.2.3　指定値に使用できない文字について」を参照してください。


EURPMAdapterForJavaクラスのメソッド仕様

8.4　EURPMAdapterForJavaクラスのメソッド仕様

EURPMAdapterForJavaクラスで使用できるメソッドの詳細を説明します。

＜この節の構成＞
getDestinationListメソッド
getEPFReportメソッド
getEURReportメソッド
getJobIDメソッド
getJobIDListメソッド
getMergeEPFReportメソッド
getPDFReportメソッド
getPMPrinterClassListメソッド
getPMPrinterListメソッド
getPMTrayListメソッド
getPreviewAXClassIDメソッド
getPreviewAXVersionメソッド
getPrintAXClassIDメソッド
getPrintAXVersionメソッド
getPrinterClassListメソッド
getPrinterListメソッド
getTrayListメソッド
getXLSXReportメソッド
outputEPFReportメソッド
outputEURReportメソッド
outputMergeEPFReportメソッド
outputPDFReportメソッド
outputXLSXReportメソッド
printReportメソッド
setBookmarkFileDataメソッド
setBookmarkFileNameメソッド
setBookmarkFilePathメソッド
setClientAddressメソッド
setClientPrinterNameメソッド
setClientTrayNameメソッド
setCryptoメソッド
setCryptoFileDataメソッド
setCryptoFileNameメソッド
setCryptoFilePathメソッド
setDataFileDataメソッド
setDataFileNameメソッド
setDataFilePathメソッド
setDBInfoFileNameメソッド
setDBInfoFilePathメソッド
setDestinationNameメソッド
setDispPrintDlgメソッド
setDistributeFileDataメソッド
setDistributeFileNameメソッド
setDistributeFilePathメソッド
setDocBookmarkFileDataメソッド
setDocBookmarkFileNameメソッド
setDocInfoFileNameメソッド
setDocInfoFilePathメソッド
setEnableGetメソッド
setEncryptionPasswordKeyメソッド
setEPFFileDataメソッド
setEPFFileNameメソッド
setEPFFilePathメソッド
setEURFileNameメソッド
setEURFilePathメソッド
setExecutablePrintModeメソッド
setFileOutputDestinationメソッド
setFirstPageNumberメソッド
setGroupNameメソッド
setInitPageNumberメソッド
setJobKeyCategoryメソッド
setJobKeyDataメソッド
setMaxPrintCountメソッド
setMergeEPFFileNameメソッド
setMergeEPFFilePathメソッド
setMultiBookmarkFileNameメソッド
setMultiDataFileNameメソッド
setMultiFormInfoDefFileNameメソッド
setMultiFormInfoDefFilePathメソッド
setMultiReportFileNameメソッド
setMultiReportSetFileNameメソッド
setMultiReportSetFilePathメソッド
setMultiUserDataFileNameメソッド
setPageNumberFormatメソッド
setPageNumberLocationメソッド
setPaperOrientationメソッド
setPDFFileNameメソッド
setPDFFilePathメソッド
setPMServerAddressメソッド
setPMServerPortメソッド
setPrintCopiesメソッド
setPrintDateFileNameメソッド
setPrintDateFilePathメソッド
setPrintEndPageメソッド
setPrinterClassNameメソッド
setPrinterSelectModeメソッド
setPrintHoldModeメソッド
setPrintKindメソッド
setPrintModeメソッド
setPrintPageNumberメソッド
setPrintStartPageメソッド
setPSEnvFileNameメソッド
setPSEnvFilePathメソッド
setReplaceItemCntlFileNameメソッド
setReplaceItemCntlFilePathメソッド
setReportAddressKeyCategoryメソッド
setReportAddressKeyDataメソッド
setReportFileNameメソッド
setReportFilePathメソッド
setScriptCntlFileNameメソッド
setScriptCntlFilePathメソッド
setServerAddressメソッド
setServerPrinterNameメソッド
setServerSelectModeメソッド
setServerTrayNameメソッド
setSortPrintメソッド
setSplitFileDataメソッド
setSplitFileNameメソッド
setSplitFilePathメソッド
setSplitModeメソッド
setSpoolFileNameメソッド
setSpoolLimitメソッド
setSpoolTitleメソッド
setUserDataFileDataメソッド
setUserDataFileNameメソッド
setUserDataFilePathメソッド
setViewerPreferenceFileNameメソッド
setViewerPreferenceFilePathメソッド
setXLSXFileNameメソッド
setXLSXFilePathメソッド


getDestinationListメソッド

getDestinationListメソッド

出力先として登録されているスプールサーバの一覧を取得します。

形式

public ArrayList[] getDestinationList() throws EURPMException

解説

getDestinationListメソッドは，EUR Server Serviceに登録された出力先の一覧を取得します。出力先の一覧は，出力先定義ファイルから取得します。取得できる情報は，定義された出力先の情報です。スプールサーバの稼働状況は取得できません。

メソッド実行時にエラーが発生した場合，getErrorCodeメソッドに終了コード，getMessageメソッドにメッセージが設定されます。

引数

なし

戻り値

出力先の一覧を次に示す形式で返します。

出力先名1,IPアドレス1,説明1
出力先名2,IPアドレス2,説明2
              :

例外処理

EURPMException

エラー発生時は，EURPMException例外がスローされます。

呼び出し例

getDestinationListメソッドの呼び出し例を次に示します。

try {
  adp = new EURPMAdapterForJava();
}
catch (Exception e) {
  System.out.println("Adapterオブジェクト生成エラー");
}
System.out.println("getDestinationList実行");
try {
  ArrayList[] alDestinations = adp.getDestinationList();
  for(cntj = 0 ; cntj < alDestinations[0].size() ; cntj++){
    System.out.println("出力先名  [" + cntj + "]=[" +
      alDestinations[0].get(cntj) + "]");
    System.out.println("IPアドレス[" + cntj + "]=[" +
      alDestinations[1].get(cntj) + "]");
    System.out.println("説明      [" + cntj + "]=[" +
      alDestinations[2].get(cntj) + "]");
  }
}
catch (EURPMException e) {
  int iCode = e.getErrorCode();
  System.out.println(Integer.toString(iCode));
  System.out.println(e.getMessage());
  System.out.println(e.getKey());
  e.printStackTrace();
}


getEPFReportメソッド

getEPFReportメソッド

EPF形式データをメモリに取得します。

形式

public ByteBuffer getEPFReport()

引数

なし

戻り値

EPF形式データをバイナリデータで返します。

例外処理

EURPMException

エラー発生時は，EURPMException例外がスローされます。エラー種別が警告の場合，データはEURPMExceptionクラスのgetOutputDataメソッドで取得してください。


getEURReportメソッド

getEURReportメソッド

EUR形式データをメモリに取得します。

形式

public ByteBuffer getEURReport()

引数

なし

戻り値

EUR形式データをバイナリデータで返します。

例外処理

EURPMException

エラー発生時は，EURPMException例外がスローされます。エラー種別が警告の場合，データはEURPMExceptionクラスのgetOutputDataメソッドで取得してください。


getJobIDメソッド

getJobIDメソッド

getJobIDメソッドを実行する直前に蓄積したスプールデータのジョブIDを取得します。

帳票を分割または仕分けして蓄積した場合など，直前に蓄積したスプールデータが複数あるときは，最初に蓄積したスプールデータのジョブIDを取得します。

形式

public String getJobID()

引数

なし

戻り値

直前に蓄積したスプールデータのジョブID


getJobIDListメソッド

getJobIDListメソッド

getJobIDListメソッドを実行する直前に蓄積したスプールデータのジョブIDの一覧を取得します。直前に蓄積したスプールデータが複数あるときは，すべてのスプールデータのジョブIDを取得します。

形式

public ArrayList getJobIDList()

引数

なし

戻り値

直前に蓄積したスプールデータのジョブIDの一覧を，次に示す形式で返します。

＜正常時＞
ジョブID1
ジョブID2
   :
ジョブIDn

＜警告（KEEY387-W）発生時＞
ジョブID1
ジョブID2
Error


getMergeEPFReportメソッド

getMergeEPFReportメソッド

複数のEPF形式ファイルを統合してメモリに取得します。

形式

public ByteBuffer getMergeEPFReport() throws EURPMException

引数

なし

戻り値

EPF形式データをバイナリデータで返します。

例外処理

EURPMException

エラー発生時は，EURPMException例外がスローされます。エラー種別が警告の場合，データはEURPMExceptionクラスのgetOutputDataメソッドで取得してください。


getPDFReportメソッド

getPDFReportメソッド

PDF形式データをメモリに取得します。

形式

public ByteBuffer getPDFReport()

引数

なし

戻り値

PDF形式データをバイナリデータで返します。

例外処理

EURPMException

エラー発生時は，EURPMException例外がスローされます。エラー種別が警告の場合，データはEURPMExceptionクラスのgetOutputDataメソッドで取得してください。


getPMPrinterClassListメソッド

getPMPrinterClassListメソッド

帳票サーバのプリンタクラスの一覧を取得します。

形式

public ArrayList[ ] getPMPrinterClassList ( ) throws EURPMException

引数

なし

戻り値

帳票サーバのプリンタクラスの一覧を，次に示す形式で返します。

＜２次元配列イメージ：ｎ行４列＞
プリンタクラス名1,OS上のプリンタ名1,OS上のプリンタのトレイ名1,説明1
プリンタクラス名2,OS上のプリンタ名2,OS上のプリンタのトレイ名2,説明2
                          :
プリンタクラス名n,OS上のプリンタ名n,OS上のプリンタのトレイ名n,説明n

例外処理

EURPMException

エラー発生時は，EURPMException例外がスローされます。

呼び出し例

getPMPrinterClassListメソッドの呼び出し例を次に示します。

try {
    adp = new EURPMAdapterForJava();
}
catch (Exception e) {
    System.out.println("Adapterオブジェクト生成エラー");
}
System.out.println("getPMPrinterClassList実行");
  try{
    ArrayList[]alPrinterClasses=adp.getPMPrinterClassList();
    for(cntj=0;cntj<alPrinterClasses[0].size();cntj++){
      System.out.println("プリンタクラス名["+cntj+"]=
        ["+alPrinterClasses[0].get(cntj)+"]");
      System.out.println("OS上のプリンタ名["+cntj+"]=
        ["+alPrinterClasses[1].get(cntj)+"]");
      System.out.println("OS上のプリンタのトレイ名["+cntj+"]=
        ["+alPrinterClasses[2].get(cntj)+"]");
      System.out.println("説明["+cntj+"]=
        ["+alPrinterClasses[3].get(cntj)+"]");
    }
}
catch(EURPMException e){
  intiCode=e.getErrorCode();
  System.out.println(Integer.toString(iCode));
  System.out.println(e.getMessage());
  System.out.println(e.getKey());
  e.printStackTrace();
}


getPMPrinterListメソッド

getPMPrinterListメソッド

帳票サーバのOSに登録されているプリンタの一覧を取得します。

形式

public ArrayList getPMPrinterList ( ) throws EURPMException

引数

なし

戻り値

帳票サーバに登録されたOS上のプリンタ一覧を，次に示す形式で返します。

＜配列イメージ＞
OS上のプリンタ名1
OS上のプリンタ名2
       :
OS上のプリンタ名n

例外処理

EURPMException

エラー発生時は，EURPMException例外がスローされます。

呼び出し例

getPMPrinterListメソッドの呼び出し例を次に示します。

try {
  adp = new EURPMAdapterForJava();
}
catch (Exception e) {
  System.out.println("Adapterオブジェクト生成エラー");
}
System.out.println("getPMPrinterList実行");
try{
  ArrayList alPrinters=adp.getPMPrinterList();
  for(cntj=0;cntj<alPrinters.size();cntj++){
    System.out.println("帳票サーバ上のプリンタ名
  =["+alPrinters.get(cntj)+"]");
    }
}
catch(EURPMException e){
  intiCode=e.getErrorCode();
  System.out.println(Integer.toString(iCode));
  System.out.println(e.getMessage());
  System.out.println(e.getKey());
  e.printStackTrace();
}


getPMTrayListメソッド

getPMTrayListメソッド

帳票サーバのOSに登録されているプリンタを指定し，そのプリンタのトレイ一覧を取得します。

形式

public ArrayList getPMTrayList (String newPrinterName) throws EURPMException

引数

newPrinterName

OS上のプリンタ名

戻り値

指定したOS上のプリンタのトレイ一覧を，次に示す形式で返します。

＜配列イメージ＞
OS上のプリンタのトレイ名1
OS上のプリンタのトレイ名2
       :
OS上のプリンタのトレイ名n

例外処理

EURPMException

エラー発生時は，EURPMException例外がスローされます。

呼び出し例

getPMTrayListメソッドの呼び出し例を次に示します。

try {
  adp = new EURPMAdapterForJava();
}
catch (Exception e) {
  System.out.println("Adapterオブジェクト生成エラー");
}
strPrinterName="PRINTER1";
System.out.println("PrinterName =["+ strPrinterName +"]");
System.out.println("getPMTrayList実行");
try{
  ArrayList alTrays=adp.getPMTrayList(strPrinterName);
  for(cntj=0;cntj<alTrays.size();cntj++){
    System.out.println("OS上のプリンタのトレイ名
      =["+alTrays.get(cntj)+"]");
    }
}
catch(EURPMException e){
  intiCode=e.getErrorCode();
  System.out.println(Integer.toString(iCode));
  System.out.println(e.getMessage());
  System.out.println(e.getKey());
  e.printStackTrace();
}


getPreviewAXClassIDメソッド

getPreviewAXClassIDメソッド

EUR Web Plug-In（プレビュー用）のクラスIDを取得します。

形式

public String getPreviewAXClassID()

解説

このメソッドを使用する場合は，EUR Server - Adapterが稼働するマシンにEUR Web Plug-In情報ファイル（EURPMPreViewAX.inf）を配置する必要があります。EUR Web Plug-In情報ファイルの配置方法については，マニュアル「EUR システム構築ガイド」を参照してください。

クラスIDは，次のように決定されます。

  1. EUR Server - Adapterに配置されたEUR Web Plug-In情報ファイル（EURPMPreViewAX.inf）に指定されているクラスIDを取得します。
  2. 1.が取得できなかった場合は，警告メッセージ（KEEY276-W）をログに出力し，D07DA8D2-3459-488E-860E-DD47A71C39D2を返します。

getPreviewAXClassIDメソッド実行時にエラーが発生した場合，getErrorCodeメソッドに終了コード，getMessageメソッドにメッセージが設定されます。

引数

なし

戻り値

EURPMPreViewAX9.ocxのクラスID（"xxxx-xxxx-xxxx-xxxx-xxxx"）


getPreviewAXVersionメソッド

getPreviewAXVersionメソッド

EUR Web Plug-In（プレビュー用）のバージョンを取得します。

形式

public String getPreviewAXVersion()

解説

このメソッドを使用する場合は，EUR Server - Adapterが稼働するマシンにEUR Web Plug-In情報ファイル（EURPMPreViewAX.inf）を配置する必要があります。EUR Web Plug-In情報ファイルの配置方法については，マニュアル「EUR システム構築ガイド」を参照してください。

バージョンは，次のように決定されます。

  1. EUR Server - Adapterに配置されたEUR Web Plug-In情報ファイル（EURPMPreViewAX.inf）に指定されているバージョンを取得します。
  2. 1.が取得できなかった場合は，警告メッセージ（KEEY276-W）をログに出力し，99,99,99,99を返します。

getPreviewAXVersionメソッド実行時にエラーが発生した場合，getErrorCodeメソッドに終了コード，getMessageメソッドにメッセージが設定されます。

引数

なし

戻り値

EURPMPreViewAX9.ocxのバージョン値（"n,n,n,n"）


getPrintAXClassIDメソッド

getPrintAXClassIDメソッド

EUR Web Plug-In（印刷用）のクラスIDを取得します。

形式

public String getPrintAXClassID()

解説

このメソッドを使用する場合は，EUR Server - Adapterが稼働するマシンにEUR Web Plug-In情報ファイル（EURPMPrintAX.inf）を配置する必要があります。EUR Web Plug-In情報ファイルの配置方法については，マニュアル「EUR システム構築ガイド」を参照してください。

クラスIDは，次のように決定されます。

  1. EUR Server - Adapterに配置されたEUR Web Plug-In情報ファイル（EURPMPrintAX.inf）に指定されているクラスIDを取得します。
  2. 1.が取得できなかった場合は，警告メッセージ（KEEY276-W）をログに出力し，368EE1C4-5A52-4C2E-A4C0-27C46B946A2Cを返します。

getPrintAXClassIDメソッド実行時にエラーが発生した場合，getErrorCodeメソッドに終了コード，getMessageメソッドにメッセージが設定されます。

引数

なし

戻り値

EURPMPrintAX9.ocxのクラスID（"xxxx-xxxx-xxxx-xxxx-xxxx"）


getPrintAXVersionメソッド

getPrintAXVersionメソッド

EUR Web Plug-In（印刷用）のバージョンを取得します。

形式

public String getPrintAXVersion()

解説

このメソッドを使用する場合は，EUR Server - Adapterが稼働するマシンにEUR Web Plug-In情報ファイル（EURPMPrintAX.inf）を配置する必要があります。EUR Web Plug-In情報ファイルの配置方法については，マニュアル「EUR システム構築ガイド」を参照してください。

バージョンは，次のように決定されます。

  1. EUR Server - Adapterに配置されたEUR Web Plug-In情報ファイル（EURPMPrintAX.inf）に指定されているバージョンを取得します。
  2. 1.が取得できなかった場合は，警告メッセージ（KEEY276-W）をログに出力し，99,99,99,99を返します。

getPrintAXVersionメソッド実行時にエラーが発生した場合，getErrorCodeメソッドに終了コード，getMessageメソッドにメッセージが設定されます。

引数

なし

戻り値

EURPMPrintAX9.ocxのバージョン値（"n,n,n,n"）


getPrinterClassListメソッド

getPrinterClassListメソッド

指定した出力先（スプールサーバ）に登録されているプリンタクラスの一覧を取得します。

形式

public ArrayList[] getPrinterClassList(String newDestinationName) throws EURPMException

解説

指定した出力先のEUR Server - Spool Serviceに登録された拠点プリンタクラスの一覧を取得します。出力先を指定していない場合は，デフォルトの出力先として登録されたスプールサーバのプリンタクラスの一覧を取得します。EUR Server - Spool Serviceが稼働中でない場合，エラーとなります。

取得できる情報は，定義された拠点プリンタクラス情報です。スプールサーバでのプリンタの稼働状況は取得できません。

getPrinterClassListメソッド実行時にエラーが発生した場合，getErrorCodeメソッドに終了コード，getMessageメソッドにメッセージが設定されます。

UNIX／Linux環境の場合，拠点プリンタクラス一覧の取得はサポートしていません。UNIX／Linux環境のEUR Server - Spool Serviceに対して，拠点プリンタクラス一覧の取得を実行した場合はエラーとなります。

引数

newDestinationName

出力先名

戻り値

拠点プリンタクラスの一覧を次に示す形式で返します。

拠点プリンタクラス名1,OS上のプリンタ名1,OS上のプリンタのトレイ名1,説明1
拠点プリンタクラス名2,OS上のプリンタ名2,OS上のプリンタのトレイ名2,説明2
                          :
拠点プリンタクラス名n,OS上のプリンタ名n,OS上のプリンタのトレイ名n,説明n

例外処理

EURPMException

エラー発生時は，EURPMException例外がスローされます。

呼び出し例

getPrinterClassListメソッドの呼び出し例を次に示します。

try {
  adp = new EURPMAdapterForJava();
}
catch (Exception e) {
  System.out.println("Adapterオブジェクト生成エラー");
}
strDestName="SERVER1";
System.out.println("DestName=["+strDestName+"]");
System.out.println("getPrinterClassList実行");
try{
  ArrayList[]alPrinterClasses=adp.getPrinterClassList(strDestName);
  for(cntj=0;cntj<alPrinterClasses[0].size();cntj++){
    System.out.println("プリンタクラス名["+cntj+"]=
      ["+alPrinterClasses[0].get(cntj)+"]");
    System.out.println("OS上のプリンタ名["+cntj+"]=
      ["+alPrinterClasses[1].get(cntj)+"]");
    System.out.println("OS上のプリンタのトレイ名["+cntj+"]=
      ["+alPrinterClasses[2].get(cntj)+"]");
    System.out.println("説明["+cntj+"]=
      ["+alPrinterClasses[3].get(cntj)+"]");
  }
}
catch(EURPMException e){
  intiCode=e.getErrorCode();
  System.out.println(Integer.toString(iCode));
  System.out.println(e.getMessage());
  System.out.println(e.getKey());
  e.printStackTrace();
}


getPrinterListメソッド

getPrinterListメソッド

指定した出力先（スプールサーバ）のOSに登録されているプリンタの一覧を取得します。

形式

public ArrayList getPrinterList(String newDestinationName) throws EURPMException

解説

getPrinterListメソッドは，指定した出力先のEUR Server - Spool Serviceに登録されたOS上のプリンタの一覧を取得します。出力先を指定していない場合は，デフォルトの出力先として登録されたスプールサーバのOS上のプリンタ一覧を取得します。EUR Server - Spool Serviceが稼働中でない場合，エラーとなります。

取得できる情報は，定義されたプリンタ情報です。スプールサーバでのプリンタの稼働状況は取得できません。

getPrinterListメソッド実行時にエラーが発生した場合，getErrorCodeメソッドに終了コード，getMessageメソッドにメッセージが設定されます。

UNIX／Linux環境の場合，プリンタ一覧の取得はサポートしていません。UNIX／Linux環境のEUR Server - Spool Serviceに対して，プリンタ一覧の取得を実行した場合はエラーとなります。

引数

newDestinationName

出力先名

戻り値

OS上のプリンタ一覧を次に示す形式で返します。

OS上のプリンタ名1
OS上のプリンタ名2
         :
OS上のプリンタ名n

例外処理

EURPMException

エラー発生時は，EURPMException例外がスローされます。

呼び出し例

getPrinterListメソッドの呼び出し例を次に示します。

try {
  adp = new EURPMAdapterForJava();
}
catch (Exception e) {
  System.out.println("Adapterオブジェクト生成エラー");
}
strDestName="SERVER1";
System.out.println("DestName=["+strDestName+"]");
System.out.println("getPrinterList実行");
try{
  ArrayList alPrinters=adp.getPrinterList(strDestName);
  for(cntj=0;cntj<alPrinters.size();cntj++){
    System.out.println("OS上のプリンタ名=["+alPrinters.get(cntj)+"]");
  }
}
catch(EURPMException e){
  intiCode=e.getErrorCode();
  System.out.println(Integer.toString(iCode));
  System.out.println(e.getMessage());
  System.out.println(e.getKey());
  e.printStackTrace();
}


getTrayListメソッド

getTrayListメソッド

出力先（スプールサーバ）とOS上のプリンタを指定し，そのプリンタのトレイ一覧を取得します。

形式

public ArrayList getTrayList(String newDestinationName, String newPrinterName) throws EURPMException

解説

getTrayListメソッドは，指定した出力先のEUR Server - Spool Serviceに登録されたOS上のプリンタのトレイ一覧を取得します。出力先を指定していない場合は，デフォルトの出力先として登録されたスプールサーバのOS上のプリンタのトレイ一覧を取得します。EUR Server - Spool Serviceが稼働中でない場合，エラーとなります。

取得できる情報は，定義されたプリンタのトレイ情報です。スプールサーバでのプリンタのトレイ稼働状況は取得できません。

getTrayListメソッド実行時にエラーが発生した場合，getErrorCodeメソッドに終了コード，getMessageメソッドにメッセージが設定されます。

UNIX／Linux環境の場合，トレイ一覧の取得はサポートしていません。UNIX／Linux環境のEUR Server - Spool Serviceに対して，トレイ一覧の取得を実行した場合はエラーとなります。

引数

newDestinationName

出力先名

newPrinterName

OS上のプリンタ名

戻り値

指定したプリンタのトレイ一覧を次に示す形式で返します。

OS上のプリンタのトレイ名1
OS上のプリンタのトレイ名2
         :
OS上のプリンタのトレイ名n

例外処理

EURPMException

エラー発生時は，EURPMException例外がスローされます。

呼び出し例

getTrayListメソッドの呼び出し例を次に示します。

try {
  adp = new EURPMAdapterForJava();
}
catch (Exception e) {
  System.out.println("Adapterオブジェクト生成エラー");
}
strDestName="SERVER1";
System.out.println("DestName=["+strDestName+"]");
strPrinterName="PRINTER1";
System.out.println("PrinterName =["+ strPrinterName +"]");
System.out.println("getTrayList実行");
try{
  ArrayList alTrays=adp.getTrayList(strDestName, strPrinterName);
  for(cntj=0;cntj<alTrays.size();cntj++){
    System.out.println("トレイ名=["+alTrays.get(cntj)+"]");
  }
}
catch(EURPMException e){
  intiCode=e.getErrorCode();
  System.out.println(Integer.toString(iCode));
  System.out.println(e.getMessage());
  System.out.println(e.getKey());
  e.printStackTrace();
}


getXLSXReportメソッド

getXLSXReportメソッド

Excel形式データをメモリに取得します。

形式

public ByteBuffer getXLSXReport()

引数

なし

戻り値

Excel形式データをバイナリデータで返します。

例外処理

EURPMException

エラー発生時は，EURPMException例外がスローされます。エラー種別が警告の場合，データはEURPMExceptionクラスのgetOutputDataメソッドで取得してください。


outputEPFReportメソッド

outputEPFReportメソッド

EPF形式ファイルを出力します。

形式

public void outputEPFReport() throws EURPMException

解説

指定したファイルがすでにある場合は，上書きされます。

EUR Server - Adapterが稼働するマシンにEPF形式ファイルを出力します。出力するEPF形式ファイルは，setEPFFilePathメソッドおよびsetEPFFileNameメソッドで指定します。

outputEPFReportメソッド実行時にエラーが発生した場合，getErrorCodeメソッドに終了コード，getMessageメソッドにメッセージが設定されます。

引数

なし

戻り値

なし

例外処理

EURPMException

エラー発生時は，EURPMException例外がスローされます。


outputEURReportメソッド

outputEURReportメソッド

EUR形式ファイルを出力します。

形式

public void outputEURReport() throws EURPMException

解説

指定したファイルがすでにある場合は，上書きされます。

EUR Server - Adapterが稼働するマシンにEUR形式ファイルを出力します。出力するEUR形式ファイルは，setEURFilePathメソッドおよびsetEURFileNameメソッドで指定します。

outputEURReportメソッド実行時にエラーが発生した場合，getErrorCodeメソッドに終了コード，getMessageメソッドにメッセージが設定されます。

引数

なし

戻り値

なし

例外処理

EURPMException

エラー発生時は，EURPMException例外がスローされます。


outputMergeEPFReportメソッド

outputMergeEPFReportメソッド

複数のEPF形式ファイルを一つのEPF形式ファイルに統合して出力します。

形式

public void outputMergeEPFReport() throws EURPMException

解説

出力先に指定したEPF形式ファイルがすでにある場合は，上書きされます。

EUR Server - Adapterが稼働するマシンに複数のEPF形式ファイルを統合して出力します。統合対象のEPF形式ファイルは，setMergeEPFFilePathメソッドおよびsetMergeEPFFileNameメソッドで指定します。また，出力するEPF形式ファイルは，setEPFFilePathメソッドおよびsetEPFFileNameメソッドで指定します。

outputMergeEPFReportメソッド実行時にエラーが発生した場合，getErrorCodeメソッドに終了コード，getMessageメソッドにメッセージが設定されます。

引数

なし

戻り値

なし

例外処理

EURPMException

エラー発生時は，EURPMException例外がスローされます。


outputPDFReportメソッド

outputPDFReportメソッド

PDF形式ファイルを出力します。

形式

public void outputPDFReport() throws EURPMException

解説

指定したファイルがすでにある場合は，上書きされます。

EUR Server Serviceが稼働するマシンまたはEUR Server - Adapterが稼働するマシンにPDF形式ファイルを出力します。PDF形式ファイルの出力先は，setFileOutputDestinationメソッド，setPDFFilePathメソッド，およびsetPDFFileNameメソッドで指定します。

ただし，PDF仕分け定義ファイル（setDistributeFileNameメソッド）が指定されている場合は，PDF仕分け定義ファイルに記述されている出力先ファイル名に従って，EUR Server Serviceが稼働するマシンにPDF形式ファイルを出力します。

PDF仕分け出力の場合，出力先のPDF形式ファイルがすでにある場合は上書きしないでエラーになります。

outputPDFReportメソッド実行時にエラーが発生した場合，getErrorCodeメソッドに終了コード，getMessageメソッドにメッセージが設定されます。

引数

なし

戻り値

なし

例外処理

EURPMException

エラー発生時は，EURPMException例外がスローされます。


outputXLSXReportメソッド

outputXLSXReportメソッド

Excel形式ファイルを出力します。

形式

public void outputXLSXReport() throws EURPMException

解説

指定したファイルがすでにある場合は，上書きされます。

EUR Server - Adapterが稼働するマシンにExcel形式ファイルを出力します。出力するExcel形式ファイルは，setXLSXFilePathメソッドおよびsetXLSXFileNameメソッドで指定します。

outputXLSXReportメソッド実行時にエラーが発生した場合，getErrorCodeメソッドに終了コード，getMessageメソッドにメッセージが設定されます。

引数

なし

戻り値

なし

例外処理

EURPMException

エラー発生時は，EURPMException例外がスローされます。


printReportメソッド

printReportメソッド

メソッドで指定した帳票名およびデータファイルで帳票を出力したり，印刷データを蓄積したりします。

形式

public void printReport() throws EURPMException

解説

printReportメソッドは，次の場合に呼び出し元に制御が戻ります。

  • スプールサーバでの印刷の場合
    スプールサーバ上のプリンタスプールへの出力が終了した時点
  • クライアントPCでの印刷の場合
    クライアントPCへの配信が完了した時点
  • 蓄積の場合
    蓄積先のサーバにEPF形式ファイルの蓄積が完了した時点

printReportメソッドが終了すると，それまでに設定したメソッドはすべてリセットされます。

printReportメソッドで印刷方式が蓄積（setPrintMode=2）の場合は，正常または警告でメソッドが戻ったときだけスプールデータに対応するジョブIDをgetJobIDメソッドで取得できます。取得した情報は，Java起動部品がメモリから解放されるか，またはprintReportメソッドが次に呼び出されるまで有効になります。

printReportメソッド実行時にエラーが発生した場合，getErrorCodeメソッドに終了コード，getMessageメソッドにメッセージが設定されます。

UNIX／Linux環境の場合，スプールサーバでの印刷はサポートしていません。UNIX／Linux環境のEUR Server - Spool Serviceに対して，印刷を実行した場合はエラーとなります。

引数

なし

戻り値

なし

例外処理

EURPMException

エラー発生時は，EURPMException例外がスローされます。


setBookmarkFileDataメソッド

setBookmarkFileDataメソッド

しおり定義データをメモリ渡しする場合，各帳票ファイルに指定するしおり定義ファイルを配列で指定します。帳票との対応づけは，配列の要素順です。

形式

public void setBookmarkFileData(StringBuffer[] newBookmarkFileData)

解説

  • setBookmarkFileDataメソッドは，outputPDFReportメソッド，またはgetPDFReportメソッドでPDF形式ファイルを出力する場合，指定が有効になります。outputPDFReportメソッド，またはgetPDFReportメソッド以外の場合は，setBookmarkFileDataメソッドを指定しても無視されます。
  • setBookmarkFileDataメソッドには，setReportFileNameメソッド，またはsetMultiReportFileNameメソッドで指定した帳票ファイルに対応するしおり定義データを指定します。指定するときは，配列の要素数が，setReportFileNameメソッド，またはsetMultiReportFileNameで指定した要素数と同じにしてください。
  • setBookmarkFileDataメソッドは，setBookmarkFileNameメソッドと同時に使用できません。また，setBookmarkFileDataメソッドを使用する場合は，ほかのファイルを指定するときも，次に示すメモリ入力（データ指定）のメソッドを使用してください。ファイル入力のメソッドと組み合わせて使用した場合は，ファイル入力のメソッドを無視します。
    • マッピングデータ（setDataFileData）
    • ユーザ定義データ（setUserDataFileData）
    • 文書しおり定義データ（setDocBookmarkFileData）
    • 暗号化設定データ（setCryptoFileData）
    • PDF仕分け定義データ（setDistributeFileData）
    • 分割定義データまたは仕分け定義データ（setSplitFileData）

引数

newBookmarkFileData

しおり定義データ配列

戻り値

なし

指定例

複数の帳票セットを指定する場合，一部の帳票に対してしおり定義データの指定を省略したいときは，配列の要素に空文字を指定してください。

2番目の帳票のしおり定義データの指定を省略する場合の例を次に示します。

// 帳票ファイル名を配列fmsに指定
fms[0]="Sample1.fms";
fms[1]="Sample2.fms";
fms[2]="Sample3.fms";
// しおり定義データを配列strBokに指定
bokFileData1 = new StringBuffer("参加者");
Array.set(strBok, 0, bokFileData1);
bokFileData2 = new StringBuffer("");
Array.set(strBok, 1, bokFileData2);
bokFileData3 = new StringBuffer("出納");
Array.set(strBok, 2, bokFileData3);

また，複数の帳票セットを指定する場合，複数の帳票に対して同じしおり定義データを指定したいときは，それぞれに同じオブジェクトを指定してください。

1番目と2番目の帳票に，同じしおり定義データを指定するときの例を次に示します。

// 帳票ファイル名を配列fmsに指定
fms[0]="Sample1.fms";
fms[1]="Sample2.fms";
fms[2]="Sample3.fms";
// しおり定義データを配列strBokに指定
bokFileDataA = new StringBuffer("参加者");
Array.set(strBok, 0, bokFileDataA);
Array.set(strBok, 1, bokFileDataA);
bokFileDataB = new StringBuffer("出納");
Array.set(strBok, 2, bokFileDataB);


setBookmarkFileNameメソッド

setBookmarkFileNameメソッド

しおり定義ファイル名を指定します。

形式

public void setBookmarkFileName(String newBookmarkFileName)

解説

  • しおり定義ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • setBookmarkFileNameメソッドは，outputPDFReportメソッド，またはgetPDFReportメソッドでPDF形式ファイルを出力する場合，指定が有効になります。outputPDFReportメソッド，またはgetPDFReportメソッド以外の場合は，setBookmarkFileNameメソッドを指定しても無視されます。
  • setBookmarkFileNameメソッドは，setBookmarkFileDataメソッドと同時に使用できません。また，setBookmarkFileNameメソッドを使用する場合は，ほかのファイルを指定するときも，次に示すファイル入力（ファイル指定）のメソッドを使用してください。
    • マッピングデータファイル（setDataFileName）
    • ユーザ定義データファイル（setUserDataFileName）
    • 文書しおり定義ファイル（setDocBookmarkFileName）
    • 暗号化設定ファイル（setCryptoFileName）
    • 帳票セット指定ファイル（setMultiReportSetFileName）
    • PDF仕分け定義ファイル（setDistributeFileName）
    • 分割定義ファイルまたは仕分け定義ファイル（setSplitFileName）
  • しおり定義ファイルは，EUR Server - Adapter稼働マシンに配置してください。

引数

newBookmarkFileName

しおり定義ファイル名

戻り値

なし


setBookmarkFilePathメソッド

setBookmarkFilePathメソッド

setDocBookmarkFileNameメソッドで指定した文書しおり定義ファイルのパス，またはsetBookmarkFileNameメソッドで指定したしおり定義ファイルのパスを指定します。

形式

public void setBookmarkFilePath(String newBookmarkFilePath)

解説

  • 指定されたファイルのパスは，setDocBookmarkFileNameメソッドで指定する文書しおり定義ファイルと，setBookmarkFileNameメソッドで指定するしおり定義ファイルのデフォルトの場所になります。
  • ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • setBookmarkFilePathメソッドは，outputPDFReportメソッド，またはgetPDFReportメソッドでPDF形式ファイルを出力する場合，指定が有効になります。outputPDFReportメソッド，またはgetPDFReportメソッド以外の場合は，setBookmarkFilePathメソッドを指定しても無視されます。

引数

newBookmarkFilePath

文書しおり定義ファイル，またはしおり定義ファイルのパス

戻り値

なし


setClientAddressメソッド

setClientAddressメソッド

印刷を実行するクライアントPCのIPアドレス，または蓄積クライアント印刷実行を要求するクライアントPCのIPアドレスを指定します。

形式

public void setClientAddress(String newClientAddress)

解説

  • 次に示す場合以外は，setClientAddressメソッドを指定しても無視されます。
    • printReportメソッドで印刷方式が蓄積（setPrintMode=2）の場合，setClientAddressメソッドの指定は任意です。
    • printReportメソッドで印刷方式がスプールサーバ印刷方式（setPrintMode=3）の場合は，setClientAddressメソッドを指定しても無視されます。
  • setClientAddressメソッドを省略した場合は，デフォルト値（127.0.0.1）が仮定されます。

引数

newClientAddress

クライアントPCのIPアドレス

戻り値

なし


setClientPrinterNameメソッド

setClientPrinterNameメソッド

帳票を印刷するクライアントプリンタ名をOS上のプリンタ名で指定します。

形式

public void setClientPrinterName(String newClientPrinterName)

解説

  • クライアントプリンタ名をOS上のプリンタ名で指定します。setClientPrinterNameメソッドを指定した場合，対話型印刷は使用できません。
  • プリンタ名を指定するときの注意
    プリンタ名は，次のことに注意して指定してください。
    • プリンタ名は，80バイト以内で指定してください。
    • プリンタ名には「"」および「,」を含めないでください。
  • setClientPrinterNameメソッドが指定されると，setDispPrintDlgメソッドは強制的に「1（ダイアログを表示しません）」を仮定します。
  • setClientPrinterNameメソッドとsetPrinterClassNameメソッドでは，setClientPrinterNameメソッドの指定を優先します。
  • setClientPrinterNameメソッドは，printReportメソッドで印刷方式がクライアント印刷方式（setPrintMode=1）の場合，およびprintReportメソッドで印刷方式が蓄積（setPrintMode=2）の場合に指定が有効になります。それ以外の場合は，setClientPrinterNameメソッドを指定しても無視されます。

引数

newClientPrinterName

クライアントプリンタ名

戻り値

なし


setClientTrayNameメソッド

setClientTrayNameメソッド

クライアントプリンタのトレイ名を指定します。クライアントプリンタは，OS上のプリンタを指します。

形式

public void setClientTrayName(String newClientTrayName)

解説

  • トレイ名を指定するときの注意
    トレイ名は，次のことに注意して指定してください。
    • トレイ名は，80バイト以内で指定してください。
    • トレイ名には「"」および「,」を含めないでください。
  • setClientTrayNameメソッドを指定する場合は，setClientPrinterNameメソッドを必ず指定してください。
    setClientTrayNameメソッドに指定したトレイ名が，setClientPrinterNameメソッドで指定したプリンタで使用できない場合は，setClientPrinterNameメソッドで指定したプリンタのデフォルトのトレイから給紙されます。
  • setClientTrayNameメソッドを指定しない場合は，setClientPrinterNameメソッドで指定したプリンタのデフォルトのトレイから給紙されます。
  • setClientTrayNameメソッドは，printReportメソッドで印刷方式がクライアント印刷方式（setPrintMode=1）の場合，およびprintReportメソッドで印刷方式が蓄積（setPrintMode=2）の場合に指定が有効になります。それ以外の場合は，setClientTrayNameメソッドを指定しても無視されます。

引数

newClientTrayName

トレイ名

戻り値

なし


setCryptoメソッド

setCryptoメソッド

PDF形式ファイルを暗号化して出力するかどうかを指定します。

形式

public void setCrypto(boolean newCrypto)

解説

setCryptoメソッドは，outputPDFReportメソッド，またはgetPDFReportメソッドでPDF形式ファイルを出力する場合，指定が有効になります。outputPDFReportメソッド，またはgetPDFReportメソッド以外の場合は，setCryptoメソッドを指定しても無視されます。

引数

newCrypto

PDF形式ファイルの暗号化出力の有無を指定します。

指定できる値を次に示します。

  • True：PDF形式ファイルを暗号化します。
  • False：PDF形式ファイルを暗号化しません。

setCryptoメソッドを省略した場合，Falseが仮定されます。

戻り値

なし


setCryptoFileDataメソッド

setCryptoFileDataメソッド

暗号化設定データをメモリ渡しする場合，暗号化設定データを指定します。

形式

public void setCryptoFileData(StringBuffer newCryptoFileData)

解説

  • setCryptoFileDataメソッドは，outputPDFReportメソッド，またはgetPDFReportメソッドでPDF形式ファイルを出力する場合，指定が有効になります。outputPDFReportメソッド，またはgetPDFReportメソッド以外の場合は，setCryptoFileDataメソッドを指定しても無視されます。
  • setCryptoFileDataメソッドは，setCryptoFileNameメソッドと同時に使用できません。また，setCryptoFileDataメソッドを使用する場合は，ほかのファイルを指定するときも，次に示すメモリ入力（データ指定）のメソッドを使用してください。ファイル入力のメソッドと組み合わせて使用した場合は，ファイル入力のメソッドを無視します。
    • マッピングデータ（setDataFileData）
    • ユーザ定義データ（setUserDataFileData）
    • しおり定義データ（setBookmarkFileData）
    • 文書しおり定義データ（setDocBookmarkFileData）
    • PDF仕分け定義データ（setDistributeFileData）
    • 分割定義データまたは仕分け定義データ（setSplitFileData）

引数

newCryptoFileData

暗号化設定データ

戻り値

なし


setCryptoFileNameメソッド

setCryptoFileNameメソッド

暗号化設定ファイル名を指定します。

形式

public void setCryptoFileName(String newCryptoFileName)

解説

  • 暗号化設定ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • setCryptoFileNameメソッドは，outputPDFReportメソッド，またはgetPDFReportメソッドでPDF形式ファイルを出力する場合，指定が有効になります。outputPDFReportメソッド，またはgetPDFReportメソッド以外の場合は，setCryptoFileNameメソッドを指定しても無視されます。
  • setCryptoFileNameメソッドは，setCryptoFileDataメソッドと同時に使用できません。また，setCryptoFileNameメソッドを使用する場合は，ほかのファイルを指定するときも，次に示すファイル入力（ファイル指定）のメソッドを使用してください。
    • マッピングデータファイル（setDataFileName）
    • ユーザ定義データファイル（setUserDataFileName）
    • しおり定義ファイル（setBookmarkFileName）
    • 文書しおり定義ファイル（setDocBookmarkFileName）
    • 帳票セット指定ファイル（setMultiReportSetFileName）
    • PDF仕分け定義ファイル（setDistributeFileName）
    • 分割定義ファイルまたは仕分け定義ファイル（setSplitFileName）
  • 暗号化設定ファイルは，EUR Server - Adapter稼働マシンに配置してください。

引数

newCryptoFileName

暗号化設定ファイル名

戻り値

なし


setCryptoFilePathメソッド

setCryptoFilePathメソッド

setCryptoFileNameメソッドで指定した暗号化設定ファイルのパスを指定します。

形式

public void setCryptoFilePath(String newCryptoFilePath)

解説

  • 暗号化設定ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • setCryptoFilePathメソッドは，outputPDFReportメソッド，またはgetPDFReportメソッドでPDF形式ファイルを出力する場合，指定が有効になります。outputPDFReportメソッド，またはgetPDFReportメソッド以外の場合は，setCryptoFilePathメソッドを指定しても無視されます。

引数

newCryptoFilePath

暗号化設定ファイルのパス

戻り値

なし


setDataFileDataメソッド

setDataFileDataメソッド

マッピングデータまたは可変記号値定義データをメモリ渡しする場合，各帳票ファイルで使用するデータを配列で指定します。帳票との対応づけは，配列の要素順です。

形式

public void setDataFileData(StringBuffer[] newDataFileData)

解説

  • setDataFileDataメソッドには，setReportFileNameメソッドまたはsetMultiReportFileNameメソッドで指定した帳票ファイルに対応するマッピングデータ，または可変記号値定義データを指定します。指定するときは，配列の要素数が，setReportFileNameメソッド，またはsetMultiReportFileNameメソッドで指定した要素数と同じにしてください。
  • setDataFileDataメソッドは，setDataFileNameメソッドと同時に使用できません。また，setDataFileDataメソッドを使用する場合は，ほかのファイルを指定するときも，次に示すメモリ入力（データ指定）のメソッドを使用してください。ファイル入力のメソッドと組み合わせて使用した場合は，ファイル入力のメソッドを無視します。
    • ユーザ定義データ（setUserDataFileData）
    • しおり定義データ（setBookmarkFileData）
    • 文書しおり定義データ（setDocBookmarkFileData）
    • 暗号化設定データ（setCryptoFileData）
    • PDF仕分け定義データ（setDistributeFileData）
    • 分割定義データまたは仕分け定義データ（setSplitFileData）
  • setDataFileDataメソッドで指定したマッピングデータまたは可変記号値定義データの配列に従って，帳票をExcel形式ファイルに出力する場合，配列の要素数が複数のときは，先頭の要素だけが有効になります。

引数

newDataFileData

マッピングデータまたは可変記号値定義データの配列

戻り値

なし

指定例

複数の帳票セットを指定する場合，一部の帳票に対してマッピングデータ（または可変記号値定義データ）の指定を省略したいときは，配列の要素に空文字を指定してください。

2番目の帳票のマッピングデータの指定を省略する場合の例を次に示します。

// 帳票ファイル名を配列fmsに指定
fms[0]="Sample1.fms";
fms[1]="Sample2.fms";
fms[2]="Sample3.fms";
// マッピングデータを配列strMapに指定
mapFileData1 = new StringBuffer("東京,男性,24\r\n大阪,女性,22\r\n");
Array.set(strMap, 0, mapFileData1);
mapFileData2 = new StringBuffer("");
Array.set(strMap, 1, mapFileData2);
mapFileData3 = new StringBuffer("入金,300\r\n出金,500\r\n,入金,400\r\n");
Array.set(strMap, 2, mapFileData3);

また，複数の帳票セットを指定する場合，複数の帳票に対して同じマッピングデータ（または可変記号値定義データ）を指定したいときは，それぞれに同じオブジェクトを指定してください。

1番目と2番目の帳票に，同じマッピングデータを指定するときの例を次に示します。

// 帳票ファイル名を配列fmsに指定
fms[0]="Sample1.fms";
fms[1]="Sample2.fms";
fms[2]="Sample3.fms";
// マッピングデータを配列strMapに指定
mapFileDataA = new StringBuffer("東京,男性,24\r\n大阪,女性,22\r\n");
Array.set(strMap, 0, mapFileDataA);
Array.set(strMap, 1, mapFileDataA);
mapFileDataB = new StringBuffer("入金,300\r\n出金,500\r\n,入金,400\r\n");
Array.set(strMap, 2, mapFileDataB);


setDataFileNameメソッド

setDataFileNameメソッド

マッピングデータファイル名または可変記号値定義ファイル名を指定します。

形式

public void setDataFileName(String newDataFileName)

解説

  • ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • setDataFileNameメソッドは，setDataFileDataメソッドと同時に使用できません。また，setDataFileNameメソッドを使用する場合は，ほかのファイルを指定するときも，次に示すファイル入力（ファイル指定）のメソッドを使用してください。
    • ユーザ定義データファイル（setUserDataFileName）
    • しおり定義ファイル（setBookmarkFileName）
    • 文書しおり定義ファイル（setDocBookmarkFileName）
    • 暗号化設定ファイル（setCryptoFileName）
    • 帳票セット指定ファイル（setMultiReportSetFileName）
    • PDF仕分け定義ファイル（setDistributeFileName）
    • 分割定義ファイルまたは仕分け定義ファイル（setSplitFileName）
  • マッピングデータファイルは，EUR Server - Adapter稼働マシンに配置してください。

引数

newDataFileName

マッピングデータファイル名または可変記号値定義ファイル名

戻り値

なし


setDataFilePathメソッド

setDataFilePathメソッド

setDataFileNameメソッドまたは帳票セット指定ファイルで指定したマッピングデータファイルのパス，もしくは可変記号値定義ファイルのパスを指定します。

形式

public void setDataFilePath(String newDataFilePath)

解説

ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

引数

newDataFilePath

マッピングデータファイルまたは可変記号値定義ファイルのパス

戻り値

なし


setDBInfoFileNameメソッド

setDBInfoFileNameメソッド

接続情報ファイル名を指定します。

形式

public void setDBInfoFileName(String newDBInfoFileName)

解説

  • EUR Server Serviceの環境設定ファイル（EURPM.ini）で，OPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，接続情報ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのDBINFOキーで設定しているフォルダに格納しておいてください。
    OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。
    パスは，setDBInfoFilePathメソッドに指定することもできます。setDBInfoFilePathメソッドにパスを指定しない場合は，次のことに注意してください。
    • フルパスを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのDBINFOキーには指定が要りません。
    • 相対パスを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのDBINFOキーで設定している起点フォルダ下にあるファイル名を指定してください。
    • ファイル名だけを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのDBINFOキーで設定しているフォルダにあるファイル名を指定してください。
  • 接続情報ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • 接続情報ファイルは，EUR Server Service稼働マシンに配置してください。

引数

newDBInfoFileName

接続情報ファイル名

戻り値

なし


setDBInfoFilePathメソッド

setDBInfoFilePathメソッド

setDBInfoFileNameメソッドで指定した接続情報ファイルのパスを指定します。

形式

public void setDBInfoFilePath(String newDBInfoFilePath)

解説

  • 接続情報ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

引数

newDBInfoFilePath

接続情報ファイルのパス

戻り値

なし


setDestinationNameメソッド

setDestinationNameメソッド

スプールサーバの出力先名を指定します。

形式

public void setDestinationName(String newDestinationName)

解説

  • 出力先名を指定するときの注意
    出力先名は，任意文字列を指定できます。次のことに注意して指定してください。
    • 出力先名は，80バイト以内で指定してください。
    • 出力先名には「"」および「,」を含めないでください。
  • 次に示すどちらかの指定がある場合，setDestinationNameメソッドは有効になります。それ以外の場合は，setDestinationNameメソッドを指定しても無視されます。
    • printReportメソッドで印刷方式がスプールサーバ印刷方式（setPrintMode=3），かつスプールサーバ指定方式が出力先名指定（setServerSelectMode=0）のとき
    • printReportメソッドで印刷方式が蓄積（setPrintMode=2），かつスプールサーバ指定方式が出力先名指定（setServerSelectMode=0）のとき

引数

newDestinationName

出力先名

戻り値

なし


setDispPrintDlgメソッド

setDispPrintDlgメソッド

クライアントPCで印刷する場合，ダイアログの表示モードを選択します。

形式

public void setDispPrintDlg(int newDispPrintDlg)

解説

  • 指定できる値と印刷時の動作を次に示します。
    • 0：印刷先指定ダイアログを表示します（対話型印刷）。
      プレビューボタンを選択すると，プレビューウィンドウが表示されます。
    • 1：直接印刷を実行します（自動印刷）。
      印刷実行中に印刷中のダイアログが表示されます。
    • 2：プレビューウィンドウを表示します（対話型印刷プレビュー表示）。
      印刷メニューまたは印刷ボタンを選択すると，印刷先指定ダイアログが表示されます。
    • 3：直接印刷を実行します（全自動印刷）。
      印刷実行中に印刷中のダイアログは表示されません。
    • 4：プレビューウィンドウを表示します（対話型印刷プレビュー表示限定）。
      印刷は実行できません。
  • setDispPrintDlgメソッドを省略した場合，EUR Server - Adapterの環境設定ファイル（EURPMADP.ini）でOPTIONセクションのDISPPRINTDLGキーの設定値（0～4）が仮定されます。環境設定ファイルDISPPRINTDLGキーおよびsetDispPrintDlgメソッドとも省略した場合，0が仮定されます。setClientPrinterNameメソッドを指定した場合，かつsetDispPrintDlgメソッドに0または2を指定した場合は，1が仮定されます。
  • setDispPrintDlgメソッドは，printReportメソッドで印刷方式がクライアント印刷方式（setPrintMode=1）の場合，およびprintReportメソッドで印刷方式が蓄積（setPrintMode=2）の場合に指定が有効になります。それ以外の場合は，setDispPrintDlgメソッドを指定しても無視されます。

戻り値

なし


setDistributeFileDataメソッド

setDistributeFileDataメソッド

PDF仕分け定義データをメモリ渡しする場合，PDF仕分け定義データを指定します。

形式

public void setDistributeFileData(StringBuffer newDistributeFileData)

解説

  • setDistributeFileDataメソッドは，outputPDFReportメソッド，またはgetPDFReportメソッドでPDF形式ファイルを出力する場合，指定が有効になります。outputPDFReportメソッド，またはgetPDFReportメソッド以外の場合は，setDistributeFileDataメソッドを指定しても無視されます。
  • setDistributeFileDataメソッドは，setDistributeFileNameメソッドと同時に使用できません。また，setDistributeFileDataメソッドを使用する場合は，ほかのファイルを指定するときも，次に示すメモリ入力（データ指定）のメソッドを使用してください。ファイル入力のメソッドと組み合わせて使用した場合は，ファイル入力のメソッドを無視します。
    • マッピングデータ（setDataFileData）
    • ユーザ定義データ（setUserDataFileData）
    • しおり定義データ（setBookmarkFileData）
    • 文書しおり定義データ（setDocBookmarkFileData）
    • 暗号化設定データ（setCryptoFileData）
    • 分割定義データまたは仕分け定義データ（setSplitFileData）
  • setDistributeFileDataメソッドでPDF仕分け定義データを指定した場合は，setFileOutputDestinationメソッドの指定は無視されます。この場合，PDF仕分け定義データに記述されている出力先ファイル名に従って，EUR Server Service稼働マシンにPDF形式ファイルを出力します。

引数

newDistributeFileData

PDF仕分け定義データ

戻り値

なし


setDistributeFileNameメソッド

setDistributeFileNameメソッド

PDF仕分け定義ファイル名を指定します。

形式

public void setDistributeFileName(String newDistributeFileName)

解説

  • PDF仕分け定義ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • setDistributeFileNameメソッドは，outputPDFReportメソッド，またはgetPDFReportメソッドでPDF形式ファイルを出力する場合，指定が有効になります。outputPDFReportメソッド，またはgetPDFReportメソッドでPDF形式ファイルを出力する場合は，setPDFFileNameメソッドまたはsetDistributeFileNameメソッドのどちらかは，必ず指定してください。setPDFFileNameメソッドとsetDistributeFileNameメソッドを同時に指定した場合は，setPDFFileNameメソッドの指定は無視されます。outputPDFReportメソッド，またはgetPDFReportメソッド以外の場合は，setDistributeFileNameメソッドを指定しても無視されます。
  • setDistributeFileNameメソッドは，setDistributeFileDataメソッドと同時に使用できません。また，setDistributeFileNameメソッドを使用する場合は，ほかのファイルを指定するときも，次に示すファイル入力（ファイル指定）のメソッドを使用してください。
    • マッピングデータファイル（setDataFileName）
    • ユーザ定義データファイル（setUserDataFileName）
    • しおり定義ファイル（setBookmarkFileName）
    • 文書しおり定義ファイル（setDocBookmarkFileName）
    • 暗号化設定ファイル（setCryptoFileName）
    • 帳票セット指定ファイル（setMultiReportSetFileName）
    • 分割定義ファイルまたは仕分け定義ファイル（setSplitFileName）
  • setDistributeFileNameメソッドでPDF仕分け定義ファイル名を指定した場合は，setFileOutputDestinationメソッドの指定は無視されます。この場合，PDF仕分け定義ファイルに記述されている出力先ファイル名に従って，EUR Server Service稼働マシンにPDF形式ファイルを出力します。
  • PDF仕分け定義ファイルは，EUR Server - Adapter稼働マシンに配置してください。

引数

newDistributeFileName

PDF仕分け定義ファイル名

戻り値

なし


setDistributeFilePathメソッド

setDistributeFilePathメソッド

setDistributeFileNameメソッドで指定したPDF仕分け定義ファイルのパスを指定します。

形式

public void setDistributeFilePath(String newDistributeFilePath)

解説

  • 指定されたファイルのパスは，setDistributeFileNameメソッドで指定するPDF仕分け定義ファイルのデフォルトの場所になります。
  • PDF仕分け定義ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • setDistributeFilePathメソッドは，outputPDFReportメソッド，またはgetPDFReportメソッドでPDF形式ファイルを出力する場合，指定が有効になります。outputPDFReportメソッド，またはgetPDFReportメソッド以外の場合は，setDistributeFilePathメソッドを指定しても無視されます。

引数

newDistributeFilePath

PDF仕分け定義ファイルのパス

戻り値

なし


setDocBookmarkFileDataメソッド

setDocBookmarkFileDataメソッド

文書しおり定義データをメモリ渡しする場合，文書しおり定義データを指定します。

形式

public void setDocBookmarkFileData(StringBuffer newDocBookmarkFileData)

解説

  • setDocBookmarkFileDataメソッドは，outputPDFReportメソッド，またはgetPDFReportメソッドでPDF形式ファイルを出力する場合，指定が有効になります。outputPDFReportメソッド，またはgetPDFReportメソッド以外の場合は，setDocBookmarkFileDataメソッドを指定しても無視されます。
  • setDocBookmarkFileDataメソッドは，setDocBookmarkFileNameメソッドと同時に使用できません。また，setDocBookmarkFileDataメソッドを使用する場合は，ほかのファイルを指定するときも，次に示すメモリ入力（データ指定）のメソッドを使用してください。ファイル入力のメソッドと組み合わせて使用した場合は，ファイル入力のメソッドを無視します。
    • マッピングデータ（setDataFileData）
    • ユーザ定義データ（setUserDataFileData）
    • しおり定義データ（setBookmarkFileData）
    • 暗号化設定データ（setCryptoFileData）
    • PDF仕分け定義データ（setDistributeFileData）
    • 分割定義データまたは仕分け定義データ（setSplitFileData）

引数

newDocBookmarkFileData

文書しおり定義データ

戻り値

なし


setDocBookmarkFileNameメソッド

setDocBookmarkFileNameメソッド

文書しおり定義ファイル名を指定します。

形式

public void setDocBookmarkFileName(String newDocBookmarkFileName)

解説

  • 文書しおり定義ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • setDocBookmarkFileNameメソッドは，outputPDFReportメソッドでPDF形式ファイルを出力する場合，指定が有効になります。outputPDFReportメソッド以外の場合は，setDocBookmarkFileNameメソッドを指定しても無視されます。
  • setDocBookmarkFileNameメソッドは，setDocBookmarkFileDataメソッドと同時に使用できません。また，setDocBookmarkFileNameメソッドを使用する場合は，ほかのファイルを指定するときも，次に示すファイル入力（ファイル指定）のメソッドを使用してください。
    • マッピングデータファイル（setDataFileName）
    • ユーザ定義データファイル（setUserDataFileName）
    • しおり定義ファイル（setBookmarkFileName）
    • 暗号化設定ファイル（setCryptoFileName）
    • 帳票セット指定ファイル（setMultiReportSetFileName）
    • PDF仕分け定義ファイル（setDistributeFileName）
    • 分割定義ファイルまたは仕分け定義ファイル（setSplitFileName）
  • 文書しおり定義ファイルは，EUR Server - Adapter稼働マシンに配置してください。

引数

newDocBookmarkFileName

文書しおり定義ファイル名

戻り値

なし


setDocInfoFileNameメソッド

setDocInfoFileNameメソッド

文書情報設定ファイル名を指定します。

形式

public void setDocInfoFileName(String newDocInfoFileName)

解説

  • EUR Server Serviceの環境設定ファイル（EURPM.ini）で，OPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，文書情報設定ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのDOCINFOキーで設定しているフォルダに格納しておいてください。
    OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。
    パスは，setDocInfoFilePathメソッドに指定することもできます。setDocInfoFilePathメソッドにパスを指定しない場合は，次のことに注意してください。
    • フルパスを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのDOCINFOキーには指定が要りません。
    • 相対パスを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのDOCINFOキーで設定している起点フォルダ下にあるファイル名を指定してください。
    • ファイル名だけを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのDOCINFOキーで設定しているフォルダにあるファイル名を指定してください。
  • 文書情報設定ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • 文書情報設定ファイルは，EUR Server Service稼働マシンに配置してください。

引数

newDocInfoFileName

文書情報設定ファイル名

戻り値

なし


setDocInfoFilePathメソッド

setDocInfoFilePathメソッド

setDocInfoFileNameメソッドで指定した文書情報設定ファイルのパスを指定します。

形式

public void setDocInfoFilePath(String newDocInfoFilePath)

解説

  • 文書情報設定ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

引数

newDocInfoFilePath

文書情報設定ファイルのパス

戻り値

なし


setEnableGetメソッド

setEnableGetメソッド

スプールデータからEPF形式ファイルの取得を許可するかどうかを指定します。

形式

public void setEnableGet(boolean newEnableGet)

解説

指定できる値を次に示します。

  • True：EPF形式ファイルの取得を許可します。
  • False：EPF形式ファイルの取得を許可しません。

setEnableGetメソッドを指定しない場合は，Trueが仮定されます。

setEnableGetメソッドは，printReportメソッドで印刷方式が蓄積（setPrintMode=2）の場合，指定が有効になります。それ以外の場合は，setEnableGetメソッドを指定しても無視されます。

引数

newEnableGet

EPF形式ファイルの取得可否

戻り値

なし


setEncryptionPasswordKeyメソッド

setEncryptionPasswordKeyメソッド

オーナパスワードとユーザパスワードを暗号化した暗号化設定ファイルを使用して，暗号化したPDF形式ファイルを出力するときにパスワード暗号化鍵を指定します。

形式

public void setEncryptionPasswordKey(String newEncryptionPasswordKey)

解説

パスワード暗号化鍵に指定できる文字は，次のとおりです。

  • 半角数字
    0～9
  • 半角英字
    A～Z，a～z

指定できるパスワード暗号化鍵の長さは，32バイトまでです。

setEncryptionPasswordKeyメソッドは，outputPDFReportメソッド，またはgetPDFReportメソッドでPDF形式ファイルを出力する場合，指定が有効になります。outputPDFReportメソッド，またはgetPDFReportメソッド以外の場合は，setEncryptionPasswordKeyメソッドを指定しても無視されます。

引数

newEncryptionPasswordKey

パスワード暗号化鍵

戻り値

なし


setEPFFileDataメソッド

setEPFFileDataメソッド

クライアントPCへの配布印刷の場合に，メモリ取得したEPF形式ファイルデータを指定します。

形式

public void setEPFFileData(ByteBuffer newEPFFileData)

解説

setEPFFileDataメソッドには，getEPFReportメソッドおよびmemgetSpoolFileメソッドで取得したデータを指定できます。printReportメソッドでクライアントPCへの配布印刷をする場合は，setEPFFileDataメソッドかsetEPFFileNameメソッドのどちらかを必ず指定してください。

引数

newEPFFileData

EPF形式ファイルのデータ

戻り値

なし


setEPFFileNameメソッド

setEPFFileNameメソッド

入力または出力するEPF形式ファイル名を指定します。

形式

public void setEPFFileName(String newEPFFileName)

解説

  • outputEPFReportメソッドまたはoutputMergeEPFReportメソッドでEPF形式ファイルを出力する場合は，setEPFFileNameメソッドを必ず指定してください。
  • printReportメソッドでクライアントPCへの配布印刷をする場合は，setEPFFileNameメソッドかsetEPFFileDataメソッドのどちらかを必ず指定してください。
  • outputEPFReportメソッド，outputMergeEPFReportメソッド，およびprintReportメソッド以外の場合は，setEPFFileNameメソッドを指定しても無視されます。
  • EPF形式ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • EPF形式ファイルの拡張子は，*.epfです。EPF形式ファイル名は，拡張子を含めて指定してください。ただし，出力したEPF形式ファイルを使用してヘルパクライアント印刷するときは，次に示す拡張子でEPF形式ファイル名を指定してください。
    • EPF形式ファイルをプレビューする場合：*.epf
    • EPF形式ファイルをプリンタ印刷する場合：*.epp

引数

newEPFFileName

EPF形式ファイル名

戻り値

なし


setEPFFilePathメソッド

setEPFFilePathメソッド

setEPFFileNameメソッドで指定したEPF形式ファイルのパスを指定します。

形式

public void setEPFFilePath(String newEPFFilePath)

解説

  • 指定されたファイルのパスは，setEPFFileNameメソッドで指定するEPF形式ファイルのデフォルトの場所になります。
  • setEPFFilePathメソッドは，outputEPFReportメソッドまたはoutputMergeEPFReportメソッドでEPF形式ファイルを出力する場合や，printReportメソッドでクライアントPCへの配布印刷をする場合に指定が有効になります。outputEPFReportメソッド，outputMergeEPFReportメソッド，およびprintReportメソッド以外の場合は，setEPFFilePathメソッドを指定しても無視されます。
  • パスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

引数

newEPFFilePath

EPF形式ファイルを入力または出力するパス

戻り値

なし


setEURFileNameメソッド

setEURFileNameメソッド

出力するEUR形式ファイル名を指定します。

形式

public void setEURFileName(String newEURFileName)

解説

  • outputEURReportメソッドでEUR形式ファイルを出力する場合は，setEURFileNameメソッドを必ず指定してください。outputEURReportメソッド以外の場合は，setEURFileNameメソッドを指定しても無視されます。
  • EUR形式ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

引数

newEURFileName

出力するEUR形式ファイル名

戻り値

なし


setEURFilePathメソッド

setEURFilePathメソッド

setEURFileNameメソッドで指定したEUR形式ファイルのパスを指定します。

形式

public void setEURFilePath(String newEURFilePath)

解説

  • 指定されたファイルのパスは，setEURFileNameメソッドで指定するEUR形式ファイルのデフォルトの場所になります。
  • setEURFilePathメソッドは，outputEURReportメソッドでEUR形式ファイルを出力する場合，指定が有効になります。outputEURReportメソッド以外の場合は，setEURFilePathメソッドを指定しても無視されます。
  • パスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

引数

newEURFilePath

EUR形式ファイルを出力するパス

戻り値

なし


setExecutablePrintModeメソッド

setExecutablePrintModeメソッド

実行可能印刷方式を指定します。

形式

public void setExecutablePrintMode(int newExecutablePrintMode)

解説

指定できる値を次に示します。

  • 0：スプールサーバでの印刷
  • 1：スプールサーバでの印刷，またはクライアントPCでの印刷
  • 2：クライアントPCでの印刷

0，1，および2以外の値を指定した場合は，1が仮定されます。

setExecutablePrintModeメソッドは，printReportメソッドで印刷方式が蓄積（setPrintMode=2）の場合，指定が有効になります。それ以外の場合は，setExecutablePrintModeメソッドを指定しても無視されます。

引数

newExecutablePrintMode

実行可能印刷方式

戻り値

なし


setFileOutputDestinationメソッド

setFileOutputDestinationメソッド

PDF形式ファイルの出力先を，EUR Server - Adapter稼働マシンにするか，またはEUR Server Service稼働マシンにするかのどちらかを指定します。

形式

public void setFileOutputDestination (int newFileOutputDestination)

解説

指定できる値を次に示します。

  • 0：EUR Server - Adapter稼働マシンに出力します。
  • 1：EUR Server Service稼働マシンに出力します。

setFileOutputDestinationメソッドを省略した場合は，EUR Server - Adapterの環境設定ファイル（EURPMADP.ini）のOPTIONセクションのFILEOUTPUTDESTINATIONキーが仮定されます。

また，0，1以外の値を指定した場合は，0が仮定されます。

setFileOutputDestinationメソッドは，outputPDFReportメソッド，またはgetPDFReportメソッドでPDF形式ファイルを出力する場合，指定が有効になります。それ以外の場合は，setFileOutputDestinationメソッドを指定しても無視されます。

setDistributeFileDataメソッドでPDF仕分け定義データを指定した場合は，setFileOutputDestinationメソッドの指定は無視されます。この場合，PDF仕分け定義データに記述されている出力先ファイル名に従って，EUR Server Service稼働マシンにPDF形式ファイルを出力します。

setDistributeFileNameメソッドでPDF仕分け定義ファイル名を指定した場合は，setFileOutputDestinationメソッドの指定は無視されます。この場合，PDF仕分け定義ファイルに記述されている出力先ファイル名に従って，EUR Server Service稼働マシンにPDF形式ファイルを出力します。

引数

FileOutputDestination

ファイルの出力先

戻り値

なし


setFirstPageNumberメソッド

setFirstPageNumberメソッド

ページ番号の初期値を指定します。

形式

public void setFirstPageNumber(int newFirstPageNumber)

解説

指定できる値は，1～999,999です。setFirstPageNumberメソッドを省略した場合，1が仮定されます。ただし，setMultiFormInfoDefFileNameメソッドを指定した場合は，setFirstPageNumberメソッドの設定値は無視されます。

setFirstPageNumberメソッドは，setPrintPageNumberメソッドを指定した場合だけ有効になります。また，setFirstPageNumberメソッドは，次に示すメソッドで印刷実行する場合，指定が有効になります。それ以外の場合は，setFirstPageNumberメソッドを指定しても無視されます。

  • printReportメソッド
  • outputPDFReportメソッド
  • outputEPFReportメソッド

引数

newFirstPageNumber

ページ番号の初期値

戻り値

なし


setGroupNameメソッド

setGroupNameメソッド

帳票振り分け定義の振り分けグループ名を指定します。

形式

public void setGroupName(String newGroupName)

解説

  • 振り分けグループ名を指定するときの注意
    振り分けグループ名は，任意文字列を指定できます。次のことに注意して指定してください。
    • 振り分けグループ名は，80バイト以内で指定してください。
    • 振り分けグループ名には「"」および「,」を含めないでください。
  • 次に示すどちらかの指定がある場合，setGroupNameメソッドは有効になります。それ以外の場合は，setGroupNameメソッドを指定しても無視されます。
    • printReportメソッドで印刷方式がスプールサーバ印刷方式（setPrintMode=3），かつ印刷モードがEPF形式ファイル印刷モード（setPrintKind=0）のとき
    • printReportメソッドで印刷方式がスプールサーバ印刷方式（setPrintMode=3），かつ印刷モードがEPF形式ファイル印刷モード（setPrintKind=0），かつプリンタ指定方式が帳票名による自動振り分け（setPrinterSelectMode=2）のとき
    • printReportメソッドで印刷方式が蓄積（setPrintMode=2），かつプリンタ指定方式が帳票名による自動振り分け（setPrinterSelectMode=2）のとき

引数

newGroupName

振り分けグループ名

戻り値

なし


setInitPageNumberメソッド

setInitPageNumberメソッド

改ページのキーが設定されている場合，そのキーがブレイクするごとにページ番号の開始番号を初期化するかどうかを指定します。

形式

public void setInitPageNumber(boolean newInitPageNumber)

解説

指定できる値を次に示します。

  • True：初期化します。
  • False：初期化しません。

setInitPageNumberメソッドを指定しない場合は，出力する帳票の属性に従います。帳票の属性の初期値は，Falseが仮定されます。ただし，setMultiFormInfoDefFileNameメソッドを指定した場合は，setInitPageNumberメソッドの設定値は無視されます。

setInitPageNumberメソッドは，次に示すメソッドで印刷実行する場合，指定が有効になります。それ以外の場合は，setInitPageNumberメソッドを指定しても無視されます。

  • printReportメソッド
  • outputPDFReportメソッド
  • outputEPFReportメソッド

引数

newInitPageNumber

ページ番号の開始番号の初期化

戻り値

なし


setJobKeyCategoryメソッド

setJobKeyCategoryメソッド

スプールデータの検索キーの分類を指定します。

形式

public void setJobKeyCategory(String[] newJobKeyCategory)

解説

  • 検索キーを指定する場合は，1～10個の配列で指定してください。また，setJobKeyCategoryメソッドを指定する場合は，検索キーの分類に対応する検索キーの値を必ずsetJobKeyDataメソッドに指定してください。このとき，配列の要素数は同じにしてください。配列の要素数が異なると，エラーになります。
    検索キーを指定しない場合，setJobKeyCategoryメソッドとsetJobKeyDataメソッドは，どちらも指定しないでください。どちらかの指定があると対応する情報がないため，エラーになります。
  • 分類を指定するときの注意
    分類は，任意文字列を指定できます。次のことに注意して指定してください。
    • 文字列は，80バイト以内で指定してください。
    • 文字列に「,」を含めないでください。
  • setJobKeyCategoryメソッドは，printReportメソッドで印刷方式が蓄積（setPrintMode=2）の場合，指定が有効になります。それ以外の場合は，setJobKeyCategoryメソッドを指定しても無視されます。

引数

newJobKeyCategory

検索キーとする分類の配列

戻り値

なし


setJobKeyDataメソッド

setJobKeyDataメソッド

スプールデータの検索キーの値を指定します。

形式

public void setJobKeyData(String[] newJobKeyData)

解説

  • 検索キーを指定する場合は，1～10個の配列で指定してください。また，setJobKeyCategoryメソッドを指定する場合は，検索キーの分類に対応する検索キーの値を必ずsetJobKeyDataメソッドに指定してください。このとき，配列の要素数は同じにしてください。配列の要素数が異なると，エラーになります。
    検索キーを指定しない場合，setJobKeyCategoryメソッドとsetJobKeyDataメソッドは，どちらも指定しないでください。どちらかの指定があると対応する情報がないため，エラーになります。
  • 値を指定するときの注意
    値は，任意文字列を指定できます。次のことに注意して指定してください。
    • 文字列は，80バイト以内で指定してください。
    • 文字列に「,」を含めないでください。
  • setJobKeyDataメソッドは，printReportメソッドで印刷方式が蓄積（setPrintMode=2）の場合，指定が有効になります。それ以外の場合は，setJobKeyDataメソッドを指定しても無視されます。

引数

newJobKeyData

検索キーとする値の配列

戻り値

なし


setMaxPrintCountメソッド

setMaxPrintCountメソッド

スプールデータの上限印刷回数を指定します。

形式

public void setMaxPrintCount(int newMaxPrintCount)

解説

  • スプールデータに指定できる値は，-1～65,536です。
    • 印刷回数の上限を無限にする場合は，-1を指定してください。
    • 印刷を禁止する場合は，0を指定してください。
  • setMaxPrintCountメソッドを省略した場合，または-1～65,536以外の値を指定した場合は，-1（無限）が仮定されます。
  • setMaxPrintCountメソッドは，printReportメソッドで印刷方式が蓄積（setPrintMode=2）の場合，指定が有効になります。それ以外の場合は，setMaxPrintCountメソッドを指定しても無視されます。

引数

newMaxPrintCount

スプールデータの上限印刷回数

戻り値

なし


setMergeEPFFileNameメソッド

setMergeEPFFileNameメソッド

統合対象のEPF形式ファイル名を指定します。

形式

public void setMergeEPFFileName (String[] newMergeEPFFileName)

解説

  • getMergeEPFReportメソッドまたはoutputMergeEPFReportメソッドで複数のEPF形式ファイルを統合して出力する場合は，setMergeEPFFileNameメソッドを必ず指定してください。getMergeEPFReportメソッドまたはoutputMergeEPFReportメソッド以外の場合は，setMergeEPFFileNameメソッドを指定しても無視されます。
  • 指定できるEPF形式ファイルの数は，2～10,000ファイルです。ファイル名はファイルの統合順に指定してください。
  • 統合対象のEPF形式ファイルは，EUR Server - Adapterが稼働するマシンに準備してください。
  • EPF形式ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • EPF形式ファイルの拡張子は，*.epfです。EPF形式ファイル名は，拡張子を含めて指定してください。

引数

newMergeEPFFileName

統合対象のEPF形式ファイル名

戻り値

なし


setMergeEPFFilePathメソッド

setMergeEPFFilePathメソッド

setMergeEPFFileNameメソッドで指定した統合対象のEPF形式ファイルのパスを指定します。

形式

public void setMergeEPFFilePath (String newMergeEPFFilePath)

解説

  • 指定されたファイルのパスは，setMergeEPFFileNameメソッドで指定するEPF形式ファイルのデフォルトの場所になります。
  • setMergeEPFFilePathメソッドは，outputMergeEPFReportメソッドで複数のEPF形式ファイルを統合して出力する場合，指定が有効になります。outputMergeEPFReportメソッド以外の場合は，setMergeEPFFilePathメソッドを指定しても無視されます。
  • パスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

引数

newMergeEPFFilePath

統合対象のEPF形式ファイルのパス

戻り値

なし


setMultiBookmarkFileNameメソッド

setMultiBookmarkFileNameメソッド

setMultiReportFileNameメソッドで複数の帳票ファイルを指定して出力する場合，各帳票ファイルで使用するしおり定義ファイル名を配列で指定します。帳票との対応づけは，配列の要素順です。

形式

public void setMultiBookmarkFileName(String[] newMultiBookmarkFileName)

解説

  • しおり定義ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • setMultiBookmarkFileNameメソッドは，outputPDFReportメソッド，またはgetPDFReportメソッドでPDF形式ファイルを出力する場合，指定が有効になります。outputPDFReportメソッド，またはgetPDFReportメソッド以外の場合は，setMultiBookmarkFileNameメソッドを指定しても無視されます。
  • しおり定義ファイルは，EUR Server - Adapter稼働マシンに配置してください。

引数

newMultiBookmarkFileName

しおり定義ファイル名の配列

戻り値

なし

指定例

複数の帳票セットを指定する場合，一部の帳票に対してしおり定義ファイルの指定を省略したいときは，配列の要素に空文字を指定してください。

2番目の帳票のしおり定義ファイルの指定を省略する場合の例を次に示します。

// 帳票ファイル名を配列fmsに指定
fms[0]="Sample1.fms";
fms[1]="Sample2.fms";
fms[2]="Sample3.fms";
// しおり定義ファイル名を配列bokに指定
bok[0]="Book1.csv";
bok[1]="";
bok[2]="Book3.csv";


setMultiDataFileNameメソッド

setMultiDataFileNameメソッド

setMultiReportFileNameメソッドで複数の帳票ファイルを指定して出力する場合，各帳票ファイルで使用するマッピングデータファイルまたは可変記号値定義ファイル名を配列で指定します。帳票との対応づけは，配列の要素順です。

形式

public void setMultiDataFileName(String[] newMultiDataFileName)

解説

  • 指定するファイル名は，setReportFileNameメソッドで指定したファイル名と同じ数を指定してください。
  • ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • マッピングデータファイルは，EUR Server - Adapter稼働マシンに配置してください。

引数

newMultiDataFileName

マッピングデータファイルまたは可変記号値定義ファイル名の配列

戻り値

なし

指定例

複数の帳票セットを指定する場合，一部の帳票に対してマッピングデータファイル（または可変記号値定義ファイル）の指定を省略したいときは，配列の要素に空文字を指定してください。

2番目の帳票のマッピングデータファイルの指定を省略する場合の例を次に示します。

// 帳票ファイル名を配列fmsに指定
fms[0]="Sample1.fms";
fms[1]="Sample2.fms";
fms[2]="Sample3.fms";
// マッピングデータファイル名を配列mapに指定
map[0]="Data1.csv";
map[1]="";
map[2]="Data3.csv";


setMultiFormInfoDefFileNameメソッド

setMultiFormInfoDefFileNameメソッド

複数様式情報定義ファイル名を指定します。

形式

public void setMultiFormInfoDefFileName(String newMultiFormInfoDefFileName)

解説

  • 複数様式で帳票を出力する場合は，setMultiFormInfoDefFileNameメソッドを必ず指定してください。setMultiFormInfoDefFileNameメソッドを省略すると，setReportFileNameメソッドで指定した複数の帳票ファイル，またはsetMultiReportSetFileNameメソッドの帳票セット指定ファイルで指定した帳票ファイルが順に出力されます。
  • EUR Server Serviceの環境設定ファイル（EURPM.ini）で，OPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，複数様式情報定義ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのMULTIキーで設定しているフォルダに格納しておいてください。
    OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。
    パスは，setMultiFormInfoDefFilePathメソッドに指定することもできます。setMultiFormInfoDefFilePathメソッドにパスを指定しない場合は，次のことに注意してください。
    • フルパスを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのMULTIキーには指定が要りません。
    • 相対パスを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのMULTIキーで設定している起点フォルダ下にあるファイル名を指定してください。
    • ファイル名だけを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのMULTIキーで設定しているフォルダにあるファイル名を指定してください。
  • 複数様式情報定義ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • 複数様式情報定義ファイルは，EUR Server Service稼働マシンに配置してください。

引数

newMultiFormInfoDefFileName

複数様式情報定義ファイル名

戻り値

なし


setMultiFormInfoDefFilePathメソッド

setMultiFormInfoDefFilePathメソッド

setMultiFormInfoDefFileNameメソッドで指定した複数様式情報定義ファイルのパスを指定します。

形式

public void setMultiFormInfoDefFilePath(String newMultiFormInfoDefFilePath)

解説

  • 複数様式情報定義ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

引数

newMultiFormInfoDefFilePath

複数様式情報定義ファイルのパス

戻り値

なし


setMultiReportFileNameメソッド

setMultiReportFileNameメソッド

複数の帳票ファイルを指定して出力する場合，帳票ファイル名を配列で指定します。帳票は，配列の要素順に出力されます。帳票ファイル名（*.fms）を指定してください。

形式

public void setMultiReportFileName(String[] newMultiReportFileName)

解説

  • setMultiReportSetFileNameメソッド，またはsetReportFileNameメソッドのどちらかは，必ず指定してください。setMultiReportSetFileNameメソッドとsetReportFileNameメソッドを同時に指定した場合は，setMultiReportSetFileNameメソッドで指定した帳票ファイルのあとに，setReportFileNameメソッドで指定した帳票ファイルが出力されます。
  • EUR Server Serviceの環境設定ファイル（EURPM.ini）で，OPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，帳票ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのFORMキーで設定しているフォルダに格納しておいてください。
    OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。
    パスは，setReportFilePathメソッドに指定することもできます。setReportFilePathメソッドにパスを指定しない場合は，次のことに注意してください。
    • フルパスを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのFORMキーには指定が要りません。
    • 相対パスを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのFORMキーで設定している起点フォルダ下にあるファイル名を指定してください。
    • ファイル名だけを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのFORMキーで設定しているフォルダにあるファイル名を指定してください。
  • 帳票ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • 帳票ファイルは，EUR Server Service稼働マシンに配置してください。

引数

newMultiReportFileName

帳票ファイル名の配列

戻り値

なし


setMultiReportSetFileNameメソッド

setMultiReportSetFileNameメソッド

帳票セット指定ファイル名を指定します。

形式

public void setMultiReportSetFileName(String newMultiReportSetFileName)

解説

  • setMultiReportSetFileNameメソッド，またはsetReportFileNameメソッドのどちらかは，必ず指定してください。setMultiReportSetFileNameメソッドとsetReportFileNameメソッドを同時に指定した場合は，setMultiReportSetFileNameメソッドで指定した帳票ファイルのあとに，setReportFileNameメソッドで指定した帳票ファイルが出力されます。
  • 帳票セット指定ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • 帳票セット指定ファイルは，EUR Server - Adapter稼働マシンに配置してください。

引数

newMultiReportSetFileName

帳票セット指定ファイル名

戻り値

なし


setMultiReportSetFilePathメソッド

setMultiReportSetFilePathメソッド

setMultiReportSetFileNameメソッドで指定した帳票セット指定ファイルのパスを指定します。

形式

public void setMultiReportSetFilePath(String newMultiReportSetFilePath)

解説

  • 帳票セット指定ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

引数

newMultiReportSetFilePath

帳票セット指定ファイルのパス

戻り値

なし


setMultiUserDataFileNameメソッド

setMultiUserDataFileNameメソッド

setMultiReportFileNameメソッドで複数の帳票ファイルを指定して出力する場合，各帳票ファイルで使用するユーザ定義データファイル名または可変記号値定義ファイル名を配列で指定します。帳票との対応づけは，配列の要素順です。

形式

public void setMultiUserDataFileName(String[] newMultiUserDataFileName)

解説

  • 指定するファイル名は，setReportFileNameメソッドで指定したファイル名と同じ数を指定してください。
  • ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • ユーザ定義データファイルは，EUR Server - Adapter稼働マシンに配置してください。

引数

newMultiUserDataFileName

ユーザ定義データファイルまたは可変記号値定義ファイル名の配列

戻り値

なし

指定例

複数の帳票セットを指定する場合，一部の帳票に対してユーザ定義データファイル（または可変記号値定義ファイル）の指定を省略したいときは，配列の要素に空文字を指定してください。

2番目の帳票のユーザ定義データファイルの指定を省略する場合の例を次に示します。

// 帳票ファイル名を配列fmsに指定
fms[0]="Sample1.fms";
fms[1]="Sample2.fms";
fms[2]="Sample3.fms";
// ユーザ定義データファイル名を配列usrに指定
usr[0]="Data1.csv";
usr[1]="";
usr[2]="Data3.csv";


setPageNumberFormatメソッド

setPageNumberFormatメソッド

ページ番号のフォーマットを指定します。

形式

public void setPageNumberFormat(String newPageNumberFormat)

解説

ページ番号を「*」，最終ページ番号を「$」で示して出力形式を指定します。ページ番号および最終ページ番号を全角で表示したいときは全角の記号で，半角で表示したいときは半角の記号で指定します。

setPageNumberFormatメソッドを指定しても，setPrintPageNumberメソッドを省略した場合は無効となります。また，setMultiFormInfoDefFileNameメソッドを指定した場合は，setPageNumberFormatメソッドの設定値は無視されます。

setPageNumberFormatメソッドは，次に示すメソッドで印刷実行する場合，指定が有効になります。それ以外の場合は，setPageNumberFormatメソッドを指定しても無視されます。

  • printReportメソッド
  • outputPDFReportメソッド
  • outputEPFReportメソッド

引数

newPageNumberFormat

ページ番号のフォーマット

戻り値

なし


setPageNumberLocationメソッド

setPageNumberLocationメソッド

余白へのページ番号の印刷位置を指定します。

形式

public void setPageNumberLocation(int newPageNumberLocation)

解説

指定できる値を次に示します。

  • 1：ページ番号を左上に出力します。
  • 2：ページ番号を中央上に出力します。
  • 3：ページ番号を右上に出力します。
  • 4：ページ番号を左下に出力します。
  • 5：ページ番号を中央下に出力します。
  • 6：ページ番号を右下に出力します。

setPageNumberLocationメソッドを指定しても，setPrintPageNumberメソッドを省略した場合は無効となります。また，setMultiFormInfoDefFileNameメソッドを指定した場合は，setPageNumberLocationメソッドの設定値は無視されます。

setPageNumberLocationメソッドは，次に示すメソッドで印刷実行する場合，指定が有効になります。それ以外の場合は，setPageNumberLocationメソッドを指定しても無視されます。

  • printReportメソッド
  • outputPDFReportメソッド
  • outputEPFReportメソッド

引数

newPageNumberLocation

余白へのページ番号の印刷位置

戻り値

なし


setPaperOrientationメソッド

setPaperOrientationメソッド

用紙の向きを指定します。

形式

public void setPaperOrientation(int newPaperOrientation)

解説

指定できる値を次に示します。

  • 0：帳票を定義したときの情報に従います。
    複数のEPF形式ファイルを統合して出力する場合は，統合するEPF形式ファイルのページごとの属性に従います。
  • 1：用紙の向きを縦にして出力します。
  • 2：用紙の向きを横にして出力します。

setPaperOrientationメソッドを省略した場合，0が仮定されます。

複数帳票を出力する場合は，setPaperOrientationメソッドの指定に関係なく0が仮定されます。ただし，getMergeEPFReportメソッドまたはoutputMergeEPFReportメソッドで，複数のEPF形式ファイルを統合して出力するときは，setPaperOrientationメソッドの指定に従います。

setPaperOrientationメソッドは，次に示すメソッドで印刷実行する場合，指定が有効になります。それ以外の場合は，setPaperOrientationメソッドを指定しても無視されます。

  • printReportメソッド
  • getEPFReportメソッド
  • getMergeEPFReportメソッド
  • outputEPFReportメソッド
  • outputMergeEPFReportメソッド

引数

newPaperOrientation

用紙の向き

戻り値

なし


setPDFFileNameメソッド

setPDFFileNameメソッド

出力するPDF形式ファイル名を指定します。

形式

public void setPDFFileName(String newPDFFileName)

解説

  • setPDFFileNameメソッドは，outputPDFReportメソッド，またはgetPDFReportメソッドでPDF形式ファイルを出力する場合，指定が有効になります。outputPDFReportメソッド，またはgetPDFReportメソッドでPDF形式ファイルを出力する場合は，setPDFFileNameメソッドまたはsetDistributeFileNameメソッドのどちらかは，必ず指定してください。setPDFFileNameメソッドとsetDistributeFileNameメソッドを同時に指定した場合は，setPDFFileNameメソッドの指定は無視されます。outputPDFReportメソッド，またはgetPDFReportメソッド以外の場合は，setPDFFileNameメソッドを指定しても無視されます。
  • PDF形式ファイルをEUR Server Service稼働マシンに出力する（setFileOutputDestination=1）場合で，EUR Server Serviceの環境設定ファイル（EURPM.ini）でOPTIONセクションのPATHMODEキーに0（通常モード）を設定しているときは，setPDFFileNameメソッドにはファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのPDFキーで設定しているフォルダに出力されます。
    OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定しているときは，setPDFFileNameメソッドはフルパス，相対パス，またはファイル名だけのどれかで指定してください。
    パスは，setPDFFilePathメソッドに指定することもできます。setPDFFilePathメソッドにパスを指定しない場合のPDF形式ファイルの出力先を次に示します。
    • フルパスを指定する場合
      setPDFFileNameメソッドで指定したパスに出力されます。なお，環境設定ファイル（EURPM.ini）のPATHセクションのPDFキーには指定が要りません。
    • 相対パスを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのPDFキーで設定しているフォルダを起点とし，そこからsetPDFFileNameメソッドで指定したパスに出力されます。
    • ファイル名だけを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのPDFキーで設定しているフォルダに，setPDFFileNameメソッドで指定したファイル名で出力されます。
  • PDF形式ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

引数

newPDFFileName

出力するPDF形式ファイル名

戻り値

なし


setPDFFilePathメソッド

setPDFFilePathメソッド

setPDFFileNameメソッドで指定したPDF形式ファイルのパスを指定します。

形式

public void setPDFFilePath(String newPDFFilePath)

解説

  • 指定されたフォルダのパスは，setPDFFileNameメソッドで指定するPDF形式ファイルのデフォルトの場所になります。
  • setPDFFilePathメソッドは，outputPDFReportメソッド，またはgetPDFReportメソッドでPDF形式ファイルを出力する場合に指定が有効になります。ただし，次の場合はsetPDFFilePathメソッドを指定しても無視されます。
    • outputPDFReportメソッド，またはgetPDFReportメソッド以外の場合
    • PDF形式ファイルをEUR Server Service稼働マシンに出力する（setFileOutputDestination=1）場合，かつEUR Server Serviceの環境設定ファイル（EURPM.ini）のOPTIONセクションのPATHMODEキーに0（通常モード）を指定している場合
  • パスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

引数

newPDFFilePath

PDF形式ファイルを出力するパス

戻り値

なし


setPMServerAddressメソッド

setPMServerAddressメソッド

帳票サーバが複数台ある場合，接続する帳票サーバのIPアドレスを指定します。

形式

public void setPMServerAddress(String newPMServerAddress)

解説

  • 帳票サーバが複数台起動されている場合に，setPMServerAddressメソッドを指定すると，接続する帳票サーバを振り分けられます。
  • setPMServerAddressメソッドを省略した場合，EUR Server - Adapterの環境設定ファイル（EURPMADP.ini）のIPADDRESSセクションのEURPMキーが仮定されます。EURPMキーの指定が省略されているとき，または値が指定されていないときは，デフォルト値（127.0.0.1）が仮定されます。

引数

newPMServerAddress

帳票サーバのIPアドレス

戻り値

なし


setPMServerPortメソッド

setPMServerPortメソッド

帳票サーバでEUR Server Serviceを複数起動する場合，ポート番号を指定します。

形式

public void setPMServerPort(int newPMServerPort)

解説

  • EUR Server Serviceが複数起動されている場合に，setPMServerPortメソッドを指定すると，接続するポートを振り分けられます。
  • setPMServerAddressメソッドを省略した場合，EUR Server - Adapterの環境設定ファイル（EURPMADP.ini）のPORTセクションのEURPMキーが仮定されます。
  • setPMServerPortメソッドを省略した場合，およびEUR Server - Adapterの環境設定ファイル（EURPMADP.ini）のPORTセクションのEURPMキーが指定されていない場合は，環境設定ファイルの省略時の値が仮定されます。

引数

newPMServerPort

帳票サーバのポート番号

戻り値

なし


setPrintCopiesメソッド

setPrintCopiesメソッド

印刷部数を指定します。

形式

public void setPrintCopies(int newPrintCopies)

解説

指定できる値は，1～99です。setPrintCopiesメソッドを省略した場合，1が仮定されます。

setPrintCopiesメソッドは，次に示すメソッドで印刷実行する場合，指定が有効になります。それ以外の場合は，setPrintCopiesメソッドを指定しても無視されます。

  • printReportメソッド
  • getEPFReportメソッド
  • getMergeEPFReportメソッド
  • outputEPFReportメソッド
  • outputMergeEPFReportメソッド

引数

newPrintCopies

印刷部数

戻り値

なし


setPrintDateFileNameメソッド

setPrintDateFileNameメソッド

印刷日時出力定義ファイル名を指定します。

形式

public void setPrintDateFileName (String newPrintDateFileName)

解説

  • EUR Server Serviceの環境設定ファイル（EURPM.ini）で，OPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，setPrintDateFileNameメソッドは，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのPRINTDATEキーで設定しているフォルダに格納しておいてください。
    OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。
    パスは，setPrintDateFilePathメソッドに指定することもできます。setPrintDateFilePathメソッドにパスを指定しない場合は，次のことに注意してください。
    • フルパスを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのPRINTDATEキーには指定が要りません。
    • 相対パスを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのPRINTDATEキーで設定している起点フォルダ下にあるファイル名を指定してください。
    • ファイル名だけを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのPRINTDATEキーで設定しているフォルダにあるファイル名を指定してください。
  • 印刷日時出力定義ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • 印刷日時出力定義ファイルは，EUR Server Service稼働マシンに配置してください。
  • setPrintDateFileNameメソッドは，次に示すメソッドで印刷実行する場合，指定が有効になります。それ以外の場合は，setPrintDateFileNameメソッドを指定しても無視されます。
    • printReportメソッド
    • outputEPFReportメソッド

引数

newPrintDateFileName

印刷日時出力定義ファイル名

戻り値

なし


setPrintDateFilePathメソッド

setPrintDateFilePathメソッド

setPrintDateFileNameメソッドで指定した印刷日時出力定義ファイルのパスを指定します。

形式

public void setPrintDateFilePath (String newPrintDateFilePath)

解説

  • 指定されたファイルのパスは，setPrintDateFileNameメソッドで指定する印刷日時出力定義ファイルのデフォルトの場所になります。
  • 印刷日時出力定義ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • setPrintDateFilePathメソッドは，次に示すメソッドで印刷実行する場合，指定が有効になります。それ以外の場合は，setPrintDateFilePathメソッドを指定しても無視されます。
    • printReportメソッド
    • outputEPFReportメソッド

引数

newPrintDateFilePath

印刷日時出力定義ファイルのパス

戻り値

なし


setPrintEndPageメソッド

setPrintEndPageメソッド

印刷終了ページを指定します。

形式

public void setPrintEndPage(int newPrintEndPage)

解説

指定できる値は，0～999,999です。setPrintEndPageメソッドを省略した場合，または指定した値が0の場合は，最終ページまで印刷されます。

複数の帳票ファイルを指定した場合は，setPrintEndPageメソッドの指定に関係なく，複数帳票ファイルの全ページが印刷されます。

setPrintEndPageメソッドは，次に示すメソッドで印刷実行する場合，指定が有効になります。それ以外の場合は，setPrintEndPageメソッドを指定しても無視されます。

  • printReportメソッド
  • outputPDFReportメソッド
  • outputEPFReportメソッド
  • outputXLSXReportメソッド

引数

newPrintEndPage

印刷終了ページ

戻り値

なし


setPrinterClassNameメソッド

setPrinterClassNameメソッド

プリンタクラス名を指定します。

形式

public void setPrinterClassName(String newPrinterClassName)

解説

  • プリンタクラス名を指定するときの注意
    プリンタクラス名は，任意文字列を指定できます。次のことに注意して指定してください。
    • プリンタクラス名は，80バイト以内で指定してください。
    • プリンタクラス名には「"」および「,」を含めないでください。
    • プリンタクラス名に「EUR_DELIVERY_PRINT_OUTPUT_DEFAULT_PRINTER_CLASS_________________________________」は使用できません。
  • 印刷方法ごとに指定するメソッドを次に示します。
    • スプールサーバでの印刷
      setPrintModeメソッド：3
      setPrinterSelectModeメソッド：0
      setPrinterClassNameメソッド：拠点プリンタクラス名
    • クライアントPCでの対話型印刷
      setPrintModeメソッド：1
      setDispPrintDlgメソッド：0
      setPrinterClassNameメソッド：帳票ジョブ名，およびEPF形式ファイルの属性情報に設定するプリンタクラス名
    • クライアントPCでの自動印刷
      setPrintModeメソッド：1
      setDispPrintDlgメソッド：1
      setPrinterClassNameメソッド：クライアントプリンタクラス名
    • クライアントPCでの対話型印刷プレビュー表示
      setPrintModeメソッド：1
      setDispPrintDlgメソッド：2
      setPrinterClassNameメソッド：帳票ジョブ名，およびEPF形式ファイルの属性情報に設定するプリンタクラス名
    • クライアントPCでの全自動印刷
      setPrintModeメソッド：1
      setDispPrintDlgメソッド：3
      setPrinterClassNameメソッド：クライアントプリンタクラス名
    • クライアントPCでの対話型印刷プレビュー表示限定
      setPrintModeメソッド：1
      setDispPrintDlgメソッド：4
      setPrinterClassNameメソッド：EPF形式ファイルの属性情報に設定するプリンタクラス名
    • 帳票サーバでの印刷
      setPrintModeメソッド：4
      setPrinterSelectModeメソッド：0
      setPrinterClassNameメソッド：帳票サーバプリンタクラス名
    • 蓄積（プリンタクラス名指定）
      setPrintModeメソッド：2
      setPrinterSelectModeメソッド：0
      setPrinterClassNameメソッド：拠点プリンタクラス名，または蓄積クライアント印刷方式のプリンタクラス名
    • 蓄積（OS上のプリンタ名指定）
      setPrintModeメソッド：2
      setPrinterSelectModeメソッド：1
      setPrinterClassNameメソッド：EPF形式ファイルの属性情報に設定するプリンタクラス名
    • 蓄積（帳票名による自動振り分け）
      setPrintModeメソッド：2
      setPrinterSelectModeメソッド：2
      setPrinterClassNameメソッド：EPF形式ファイルの属性情報に設定するプリンタクラス名
    「クライアントPCでの自動印刷」と「蓄積クライアント印刷」の場合，setClientPrinterNameメソッドとsetPrinterClassNameメソッドでは，setClientPrinterNameメソッドの指定を優先します。
  • EPF形式ファイルを出力する場合，またはEPF形式データを取得する場合に，指定するメソッドを次に示します。
    setPrinterClassNameメソッド：EPF形式ファイルまたはEPF形式データの属性情報に設定するプリンタクラス名
  • 複数のEPF形式ファイルを統合して出力する場合，または複数のEPF形式ファイルを統合してメモリに取得する場合に，指定するメソッドを次に示します。
    setPrinterClassNameメソッド：EPF形式ファイルまたはEPF形式データの属性情報に設定するプリンタクラス名
  • クライアントPCへの配布印刷では，指定できません。
  • EPF形式ファイルを出力する場合，またはEPF形式データを取得する場合に，setPrinterClassNameメソッドの指定を省略したときや空文字を指定したときは，EPF形式ファイルまたはEPF形式データのプリンタクラス名情報は未設定となります。
  • 複数のEPF形式ファイルを統合して出力する場合，または複数のEPF形式ファイルを統合してメモリに取得する場合に，setPrinterClassNameメソッドの指定を省略したときや空文字を指定したときは，統合対象のEPF形式ファイルにプリンタクラス名情報が設定されていても，統合後のEPF形式ファイルまたはEPF形式データのプリンタクラス名情報は未設定となります。

引数

newPrinterClassName

プリンタクラス名

戻り値

なし


setPrinterSelectModeメソッド

setPrinterSelectModeメソッド

プリンタの指定方法を選択します。

形式

public void setPrinterSelectMode(int newPrinterSelectMode)

解説

指定できる値を次に示します。

  • 0：プリンタクラス名の指定
  • 1：OS上のプリンタ名の指定
  • 2：帳票振り分け定義の指定

setPrinterSelectModeメソッドを省略した場合，または0，1，2以外の値を指定した場合は，0が仮定されます。

setPrinterSelectModeメソッドは，次の場合に指定が有効になります。

  • printReportメソッドで印刷方式がスプールサーバ印刷方式（setPrintMode=3）の場合
  • printReportメソッドで印刷方式が蓄積（setPrintMode=2）の場合
  • printReportメソッドで印刷方式が帳票サーバ直接印刷方式（setPrintMode=4）の場合

それ以外の場合は，setPrinterSelectModeメソッドを指定しても無視されます。

また，帳票サーバによる直接印刷（setPrintMode=4）の場合，2の値を指定するとエラーになります。

引数

newPrinterSelectMode

プリンタの指定方法

戻り値

なし


setPrintHoldModeメソッド

setPrintHoldModeメソッド

蓄積印刷方式で，蓄積後に続けて印刷するかどうかを選択します。

形式

public void setPrintHoldMode(int newPrintHoldMode)

解説

指定できる値を次に示します。

  • 0：蓄積後に続けて印刷しません（印刷保留）。
  • 1：蓄積後に続けてスプールサーバで印刷します。
  • 2：蓄積後に続けてクライアントPCで印刷します。

setPrintHoldModeメソッドを省略した場合，または0，1，2以外の値を指定した場合は，setReportAddressKeyCategoryメソッドおよびsetReportAddressKeyDataメソッドの指定の有無によって次の値が仮定されます。

setReportAddressKeyCategoryメソッドおよびsetReportAddressKeyDataメソッドの指定がある場合
0が仮定されます。
setReportAddressKeyCategoryメソッドおよびsetReportAddressKeyDataメソッドの指定がない場合
1が仮定されます。

setPrintHoldModeメソッドは，printReportメソッドで印刷方式が蓄積（setPrintMode=2）の場合，指定が有効になります。それ以外の場合は，setPrintHoldModeメソッドを指定しても無視されます。

引数

newPrintHoldMode

蓄積印刷方式で，蓄積後に続けて印刷するかどうかの指定

戻り値

なし


setPrintKindメソッド

setPrintKindメソッド

スプールサーバ印刷方式の印刷モードを指定します。

形式

public void setPrintKind(int newPrintKind)

解説

指定できる値を次に示します。

  • 0：EPF形式ファイル印刷モード
  • 1：EUR形式ファイル印刷モード

setPrintKindメソッドを省略した場合，または0，1以外の値を指定した場合は，0が仮定されます。

setPrintKindメソッドは，printReportメソッドで印刷方式がスプールサーバ印刷方式（setPrintMode=3）の場合，指定が有効になります。それ以外の場合は，setPrintKindメソッドを指定しても無視されます。

引数

newPrintKind

スプールサーバでの印刷の出力するファイル形式

戻り値

なし


setPrintModeメソッド

setPrintModeメソッド

印刷メソッド（printReportメソッド）の印刷方式を指定します。

形式

public void setPrintMode(int newPrintMode)

解説

指定できる値を次に示します。

  • 0：デフォルト印刷方式 ※
  • 1：クライアント印刷方式
  • 2：蓄積
  • 3：スプールサーバ印刷方式
  • 4：帳票サーバ直接印刷方式
  • 5：クライアント配布印刷方式
    注※
    「0（デフォルト印刷方式）」を定義する場合は，EUR Server - Adapterの環境設定ファイル（EURPMADP.ini）でOPTIONセクションのDEFAULTPRINTMODEキーに値を設定してください。

0，1，2，3，4，5以外の値を指定した場合は，0が仮定されます。

setPrintModeメソッドを省略した場合は，環境設定ファイル（EURPMADP.ini）でOPTIONセクションのPRINTMODEキーに指定されている値をデフォルトにします。

引数

newPrintMode

印刷方法

戻り値

なし


setPrintPageNumberメソッド

setPrintPageNumberメソッド

余白へのページ番号印刷を指定します。

形式

public void setPrintPageNumber(boolean newPrintPageNumber)

解説

指定できる値を次に示します。

  • True：余白へのページ番号を出力します。
  • False：余白へのページ番号は出力しません。

setPrintPageNumberメソッドを省略した場合，Falseが仮定されます。ただし，setMultiFormInfoDefFileNameメソッドを指定した場合は，setPrintPageNumberメソッドの設定値は無視されます。

setPrintPageNumberメソッドは，次に示すメソッドで印刷実行する場合，指定が有効になります。それ以外の場合は，setPrintPageNumberメソッドを指定しても無視されます。

  • printReportメソッド
  • outputPDFReportメソッド
  • outputEPFReportメソッド

引数

newPrintPageNumber

余白へのページ番号印刷

戻り値

なし


setPrintStartPageメソッド

setPrintStartPageメソッド

印刷開始ページを指定します。

形式

public void setPrintStartPage(int newPrintStartPage)

解説

指定できる値は，0～999,999です。setPrintStartPageメソッドを省略した場合，または指定した値が0の場合は，1ページから印刷されます。

複数の帳票ファイルを指定した場合は，setPrintStartPageメソッドの指定に関係なく，指定した複数の帳票ファイルの全ページが印刷されます。

setPrintStartPageメソッドは，次に示すメソッドで印刷実行する場合，指定が有効になります。それ以外の場合は，setPrintStartPageメソッドを指定しても無視されます。

  • printReportメソッド
  • outputPDFReportメソッド
  • outputEPFReportメソッド
  • outputXLSXReportメソッド

引数

newPrintStartPage

印刷開始ページ

戻り値

なし


setPSEnvFileNameメソッド

setPSEnvFileNameメソッド

EUR Print Serviceの動作環境を印刷ジョブごとに変更する場合に，EUR Server Serviceの環境設定ファイル（EURPS_ENV）名を指定します。

形式

public void setPSEnvFileName (String newPSEnvFileName)

解説

  • EUR Server Serviceの環境設定ファイル（EURPM.ini）で，OPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，setPSEnvFileNameメソッドは，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのPSENVキーで設定しているフォルダに格納しておいてください。
    OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。
    パスは，setPSEnvFilePathメソッドに指定することもできます。setPSEnvFilePathメソッドにパスを指定しない場合は，次のことに注意してください。
    • フルパスを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのPSENVキーには指定が要りません。
    • 相対パスを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのPSENVキーで設定している起点フォルダ下にあるファイル名を指定してください。
    • ファイル名だけを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのPSENVキーで設定しているフォルダにあるファイル名を指定してください。
  • EUR Server Serviceの環境設定ファイル（EURPS_ENV）名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • EUR Server Serviceの環境設定ファイル（EURPS_ENV）は，EUR Server Service稼働マシンに配置してください。
  • setPSEnvFileNameメソッドは，次に示すメソッドで印刷実行する場合，指定が有効になります。それ以外の場合は，setPSEnvFileNameメソッドを指定しても無視されます。
    • printReportメソッド
    • outputPDFReportメソッド
    • outputEPFReportメソッド
    • outputEURReportメソッド
    • outputXLSXReportメソッド

引数

newPSEnvFileName

EUR Server Serviceの環境設定ファイル（EURPS_ENV）名

戻り値

なし


setPSEnvFilePathメソッド

setPSEnvFilePathメソッド

setPSEnvFileNameメソッドで指定したEUR Server Serviceの環境設定ファイル（EURPS_ENV）のパスを指定します。

形式

public void setPSEnvFilePath (String newPSEnvFilePath)

解説

  • 指定されたファイルのパスは，setPSEnvFileNameメソッドで指定するEUR Server Serviceの環境設定ファイル（EURPS_ENV）のデフォルトの場所になります。
  • EUR Server Serviceの環境設定ファイル（EURPS_ENV）のパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • setPSEnvFilePathメソッドは，次に示すメソッドで印刷実行する場合，指定が有効になります。それ以外の場合は，setPSEnvFilePathメソッドを指定しても無視されます。
    • printReportメソッド
    • outputPDFReportメソッド
    • outputEPFReportメソッド
    • outputEURReportメソッド
    • outputXLSXReportメソッド

引数

newPSEnvFilePath

EUR Server Serviceの環境設定ファイル（EURPS_ENV）のパス

戻り値

なし


setReplaceItemCntlFileNameメソッド

setReplaceItemCntlFileNameメソッド

置き換え表管理情報ファイル名を指定します。

形式

public void setReplaceItemCntlFileName(String newReplaceItemCntlFileName)

解説

  • EUR Server Serviceの環境設定ファイル（EURPM.ini）で，OPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，置き換え表管理情報ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのREPLACEITEMキーで設定しているフォルダに格納しておいてください。
    OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。
    パスは，setReplaceItemCntlFilePathメソッドに指定することもできます。setReplaceItemCntlFilePathメソッドにパスを指定しない場合は，次のことに注意してください。
    • フルパスを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのREPLACEITEMキーには指定が要りません。
    • 相対パスを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのREPLACEITEMキーで設定している起点フォルダ下にあるファイル名を指定してください。
    • ファイル名だけを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのREPLACEITEMキーで設定しているフォルダにあるファイル名を指定してください。
  • 置き換え表管理情報ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • 次に示すどれかの指定がある場合，setReplaceItemCntlFileNameメソッドは有効になります。printReportメソッドで印刷方式がスプールサーバ印刷方式（setPrintMode=3），かつ印刷モードがEUR形式ファイル印刷モード（setPrintKind=1）の場合は，setReplaceItemCntlFileNameメソッドを指定しても無視されます。
    • printReportメソッドで印刷方式がスプールサーバ印刷方式（setPrintMode=3），かつ印刷モードがEPF形式ファイル印刷モード（setPrintKind=0）のとき
    • printReportメソッドで印刷方式がクライアント印刷方式（setPrintMode=1）のとき
    • printReportメソッドで印刷方式が蓄積（setPrintMode=2）のとき
    • outputPDFReportメソッド，outputEPFReportメソッド，outputEURReportメソッド，およびoutputXLSXReportメソッドで印刷実行するとき
  • 置き換え表管理情報ファイルは，EUR Server Service稼働マシンに配置してください。

引数

newReplaceItemCntlFileName

置き換え表管理情報ファイル名

戻り値

なし


setReplaceItemCntlFilePathメソッド

setReplaceItemCntlFilePathメソッド

setReplaceItemCntlFileNameメソッドで指定した置き換え表管理情報ファイルのパスを指定します。

形式

public void setReplaceItemCntlFilePath(String newReplaceItemCntlFilePath)

解説

  • 置き換え表管理情報ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • 次に示すどれかの指定がある場合，setReplaceItemCntlFilePathメソッドは有効になります。printReportメソッドで印刷方式がスプールサーバ印刷方式（setPrintMode=3），かつ印刷モードがEUR形式ファイル印刷モード（setPrintKind=1）の場合は，setReplaceItemCntlFilePathメソッドを指定しても無視されます。
    • printReportメソッドで印刷方式がスプールサーバ印刷方式（setPrintMode=3），かつ印刷モードがEPF形式ファイル印刷モード（setPrintKind=0）のとき
    • printReportメソッドで印刷方式がクライアント印刷方式（setPrintMode=1）のとき
    • printReportメソッドで印刷方式が蓄積（setPrintMode=2）のとき
    • outputPDFReportメソッド，outputEPFReportメソッド，outputEURReportメソッド，およびoutputXLSXReportメソッドで印刷実行するとき

引数

newReplaceItemCntlFilePath

置き換え表管理情報ファイルのパス

戻り値

なし


setReportAddressKeyCategoryメソッド

setReportAddressKeyCategoryメソッド

スプールデータの宛先キーの分類を指定します。

形式

public void setReportAddressKeyCategory (String newKeyCategory)

解説

  • 宛先キーの分類は，任意の文字列を指定できます。次のことに注意して指定してください。
    • 文字列は，1～80バイトで指定してください。
    • 文字列には「"」，「,」および制御コード（0x00～0x1F，0x7F～0x9F）を含めないでください。
  • setReportAddressKeyCategoryメソッドはprintReportメソッドで印刷方式が蓄積（setPrintMode=2）の場合，指定が有効になります。それ以外のメソッドでは，setReportAddressKeyCategoryメソッドを指定しても無視されます。
  • setReportAddressKeyDataメソッドが指定されていない場合はエラーになります。

引数

newKeyCategory

宛先キー分類

戻り値

なし


setReportAddressKeyDataメソッド

setReportAddressKeyDataメソッド

スプールデータの宛先キーの値を指定します。

形式

public void setReportAddressKeyData (String newKeyData)

解説

  • 宛先キーの値は，任意の文字列を指定できます。次のことに注意して指定してください。
    • 文字列は，1～80バイトで指定してください。
    • 文字列の値には「"」，「,」および制御コード（0x00～0x1F，0x7F～0x9F）を含めないでください。
  • setReportAddressKeyDataメソッドはprintReportメソッドで印刷方式が蓄積（setPrintMode=2）の場合，指定が有効になります。それ以外のメソッドでは，setReportAddressKeyDataメソッドを指定しても無視されます。
  • setReportAddressKeyCategoryメソッドが指定されていない場合はエラーになります。

引数

newKeyData

宛先キー値

戻値

なし


setReportFileNameメソッド

setReportFileNameメソッド

帳票ファイル名（*.fms）を指定します。

形式

public void setReportFileName(String newReportFileName)

解説

  • setReportFileNameメソッド，またはsetMultiReportSetFileNameメソッドのどちらかは，必ず指定してください。setReportFileNameメソッドとsetMultiReportSetFileNameメソッドを同時に指定した場合は，setMultiReportSetFileNameメソッドで指定した帳票ファイルのあとに，setReportFileNameメソッドで指定した帳票ファイルが出力されます。
  • EUR Server Serviceの環境設定ファイル（EURPM.ini）で，OPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，帳票ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのFORMキーで設定しているフォルダに格納しておいてください。
    OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。
    パスは，setReportFilePathメソッドに指定することもできます。setReportFilePathメソッドにパスを指定しない場合は，次のことに注意してください。
    • フルパスを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのFORMキーには指定が要りません。
    • 相対パスを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのFORMキーで設定している起点フォルダ下にあるファイル名を指定してください。
    • ファイル名だけを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのFORMキーで設定しているフォルダにあるファイル名を指定してください。
  • 帳票ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • 帳票ファイルは，EUR Server Service稼働マシンに配置してください。

引数

newReportFileName

帳票ファイル名

戻り値

なし


setReportFilePathメソッド

setReportFilePathメソッド

setReportFileNameメソッドで指定した帳票ファイルのパスを指定します。

形式

public void setReportFilePath(String newReportFilePath)

解説

  • 帳票ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

引数

newReportFilePath

帳票ファイルのパス

戻り値

なし


setScriptCntlFileNameメソッド

setScriptCntlFileNameメソッド

Acrobat JavaScript定義ファイル名を指定します。

形式

public void setScriptCntlFileName(String newScriptCntlFileName)

解説

  • EUR Server Serviceの環境設定ファイル（EURPM.ini）で，OPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，Acrobat JavaScript定義ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのSCRIPTCNTキーで設定しているフォルダに格納しておいてください。
    OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。
    パスは，setScriptCntlFilePathメソッドに指定することもできます。setScriptCntlFilePathメソッドにパスを指定しない場合は，次のことに注意してください。
    • フルパスを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのSCRIPTCNTキーには指定が要りません。
    • 相対パスを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのSCRIPTCNTキーで設定している起点フォルダ下にあるファイル名を指定してください。
    • ファイル名だけを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのSCRIPTCNTキーで設定しているフォルダにあるファイル名を指定してください。
  • Acrobat JavaScript定義ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • setScriptCntlFileNameメソッドは，outputPDFReportメソッド，またはgetPDFReportメソッドでPDF形式ファイルを出力する場合，指定が有効になります。outputPDFReportメソッド，またはgetPDFReportメソッド以外の場合は，setScriptCntlFileNameメソッドを指定しても無視されます。
  • Acrobat JavaScript定義ファイルは，EUR Server Service稼働マシンに配置してください。

引数

newScriptCntlFileName

Acrobat JavaScript定義ファイル名

戻り値

なし


setScriptCntlFilePathメソッド

setScriptCntlFilePathメソッド

setScriptCntlFileNameメソッドで指定したAcrobat JavaScript定義ファイルのパスを指定します。

形式

public void setScriptCntlFilePath(String newScriptCntlFilePath)

解説

  • Acrobat JavaScript定義ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • setScriptCntlFilePathメソッドは，outputPDFReportメソッド，またはgetPDFReportメソッドでPDF形式ファイルを出力する場合，指定が有効になります。outputPDFReportメソッド，またはgetPDFReportメソッド以外の場合は，setScriptCntlFilePathメソッドを指定しても無視されます。

引数

newScriptCntlFilePath

Acrobat JavaScript定義ファイルのパス

戻り値

なし


setServerAddressメソッド

setServerAddressメソッド

スプールサーバのIPアドレスを「255.255.255.255」形式で指定します。

形式

public void setServerAddress(String newServerAddress)

解説

  • 次に示すどちらかの指定がある場合，setServerAddressメソッドは有効になります。それ以外の場合は，setServerAddressメソッドを指定しても無視されます。
    • printReportメソッドで印刷方式がスプールサーバ印刷方式（setPrintMode=3），かつスプールサーバ指定方式がIPアドレス指定（setServerSelectMode=1）のとき
    • printReportメソッドで印刷方式が蓄積（setPrintMode=2），かつスプールサーバ指定方式がIPアドレス指定（setServerSelectMode=1）のとき
  • setServerAddressメソッドを省略した場合は，デフォルト値（127.0.0.1）が仮定されます。

引数

newServerAddress

スプールサーバのIPアドレス

戻り値

なし


setServerPrinterNameメソッド

setServerPrinterNameメソッド

サーバプリンタ名を指定します。プリンタ名は，OS上のプリンタ名を指定してください。

形式

public void setServerPrinterName(String newServerPrinterName)

解説

  • プリンタ名を指定するときの注意
    プリンタ名は，次のことに注意して指定してください。
    • プリンタ名は，80バイト以内で指定してください。
    • プリンタ名には「"」および「,」を含めないでください。
  • 次に示す指定がある場合，setServerPrinterNameメソッドは有効になります。それ以外の場合は，setServerPrinterNameメソッドを指定しても無視されます。
    • printReportメソッドで印刷方式がスプールサーバ印刷方式（setPrintMode=3），かつプリンタ指定方式がOS上のプリンタ名指定（setPrinterSelectMode=1）のとき
    • printReportメソッドで印刷方式が蓄積（setPrintMode=2），かつプリンタ指定方式がOS上のプリンタ名指定（setPrinterSelectMode=1）のとき
    • printReportメソッドで印刷方式が帳票サーバ直接印刷方式（setPrintMode=4），かつプリンタ指定方式がOS上のプリンタ名指定（setPrinterSelectMode=1）のとき

引数

newServerPrinterName

サーバプリンタ名

戻り値

なし


setServerSelectModeメソッド

setServerSelectModeメソッド

スプールサーバの選択方法を指定します。

形式

public void setServerSelectMode(int newServerSelectMode)

解説

指定できる値を次に示します。

  • 0：出力先名を指定します。
  • 1：スプールサーバのIPアドレスを指定します。

setServerSelectModeメソッドを省略した場合，または0，1以外の値を指定した場合は，0が仮定されます。

次に示すどちらかの指定がある場合，setServerSelectModeメソッドは有効になります。それ以外の場合は，setServerSelectModeメソッドを指定しても無視されます。

  • printReportメソッドで印刷方式がスプールサーバ印刷方式（setPrintMode=3）のとき
  • printReportメソッドで印刷方式が蓄積（setPrintMode=2）のとき

引数

newServerSelectMode

スプールサーバの選択方法

戻り値

なし


setServerTrayNameメソッド

setServerTrayNameメソッド

サーバのプリンタのトレイ名を指定します。トレイ名は，OS上のプリンタのトレイ名を指定してください。

形式

public void setServerTrayName(String newServerTrayName)

解説

Windows環境の場合
  • トレイ名を指定するときの注意
    トレイ名は，次のことに注意して指定してください。
    ・トレイ名は，80バイト以内で指定してください。
    ・トレイ名には「"」および「,」を含めないでください。
  • setServerTrayNameメソッドを指定しない場合は，setServerPrinterNameメソッドで指定したプリンタのデフォルトのトレイから給紙されます。
  • setServerTrayNameメソッドに指定したトレイ名が，出力先のプリンタで使用できない場合は，デフォルトのトレイから給紙されます。
  • 次に示す指定がある場合，setServerTrayNameメソッドは有効になります。それ以外の場合は，setServerTrayNameメソッドを指定しても無視されます。
    ・printReportメソッドで印刷方式がスプールサーバ印刷方式（setPrintMode=3），かつプリンタ指定方式がOS上のプリンタ名指定（setPrinterSelectMode=1）のとき
    ・printReportメソッドで印刷方式が蓄積（setPrintMode=2），かつプリンタ指定方式がOS上のプリンタ名指定（setPrinterSelectMode=1）のとき
    ・printReportメソッドで印刷方式が帳票サーバ直接印刷方式（setPrintMode=4），かつプリンタ指定方式がOS上のプリンタ名指定（setPrinterSelectMode=1）のとき
UNIX／Linux環境の場合
  • 給紙トレイ情報を指定します。setServerTrayNameメソッドを指定しない場合は，プリンタ定義ファイルのキーワード（DefaultCassette）に指定されているデフォルトのトレイから給紙されます。
    プリンタ定義ファイルの詳細については，「11.5　プリンタ定義ファイル」を参照してください。
  • 指定する給紙トレイ情報を次に示します。
    指定内容 | 給紙トレイ
    auto | 印刷用紙を自動で給紙します。出力する帳票の用紙サイズから給紙トレイを自動選択します。
    manual | 手差しトレイから印刷用紙を給紙します。
    トレイ番号 トレイ番号の給紙トレイから印刷用紙を給紙します。トレイ番号は，1～n（nはプリンタ定義ファイルのキーワードCassettesで指定した値）で指定します。
    6以上の値を指定した場合は自動給紙となります。
    注意
    setServerTrayNameメソッドでは次に示す指定があった場合，プリンタのハードウェアによって動作が異なります。
    • manualが指定されたとき
    • トレイ番号が指定されたとき
    • autoが指定されたのに，プリンタのパネルで給紙トレイが選択されたとき
    また，帳票の用紙サイズと給紙される用紙のサイズが異なる場合も，プリンタのハードウェアによって動作が異なります。
    帳票の用紙サイズと給紙される用紙のサイズを合わせておくか，または帳票の用紙サイズと異なる用紙に出力する場合は，あらかじめ試し印刷を実施してプリンタの動作を確認してください。

引数

newServerTrayName

サーバのプリンタのトレイ名

戻り値

なし


setSortPrintメソッド

setSortPrintメソッド

印刷部数の単位を指定します。

形式

public void setSortPrint(int newSortPrint)

解説

指定できる値を次に示します。

  • 0：部単位で出力します。
  • 1：ページ単位で出力します。

setSortPrintメソッドを省略した場合，0が仮定されます。

複数帳票を出力する場合は，setSortPrintメソッドの指定に関係なく0が仮定されます。ただし，getMergeEPFReportメソッドまたはoutputMergeEPFReportメソッドで，複数のEPF形式ファイルを統合して出力するときは，setSortPrintメソッドの指定に従います。

setSortPrintメソッドは，次に示すメソッドで印刷実行する場合，指定が有効になります。それ以外の場合は，setSortPrintメソッドを指定しても無視されます。

  • printReportメソッド
  • getEPFReportメソッド
  • getMergeEPFReportメソッド
  • outputEPFReportメソッド
  • outputMergeEPFReportメソッド

引数

newSortPrint

印刷部数の単位

戻り値

なし


setSplitFileDataメソッド

setSplitFileDataメソッド

帳票を分割または仕分けして蓄積する場合，分割定義データまたは仕分け定義データをメモリ渡しするときに指定します。

形式

public void setSplitFileData (StringBuffer newSplitFileData)

解説

  • setSplitFileDataメソッドは，printReportメソッドで印刷方式が蓄積（setPrintMode=2）の場合で，かつ次のどちらかの条件に当てはまるときに指定が有効になります。それ以外の場合は，setSplitFileDataメソッドを指定しても無視されます。
    • 帳票を分割（setSplitMode=3）または仕分け（setSplitMode=2）する設定にしているとき。
    • 帳票を分割または仕分けするかどうかをEUR Server Serviceの環境設定ファイルの指定に従う（setSplitMode=0）設定にしていて，かつEUR Server Serviceの環境設定ファイルのOPTIONセクションのSPLITMODEキーにPAGE（分割）またはKEY（仕分け）を指定しているとき。
  • setSplitFileDataメソッドは，setSplitFileNameメソッドと同時に使用できません。また，setSplitFileDataメソッドを使用する場合は，ほかのファイルを指定するときも，次に示すメモリ入力（データ指定）のメソッドを使用してください。ファイル入力のメソッドと組み合わせて使用した場合は，ファイル入力のメソッドを無視します。
    • マッピングデータ（setDataFileData）
    • ユーザ定義データ（setUserDataFileData）
    • しおり定義データ（setBookmarkFileData）
    • 文書しおり定義データ（setDocBookmarkFileData）
    • 暗号化設定データ（setCryptoFileData）
    • PDF仕分け定義データ（setDistributeFileData）
  • 分割定義ファイルまたは仕分け定義ファイルは，EUR Server - Adapter稼働マシンに配置してください。

引数

newSplitFileData

分割定義データまたは仕分け定義データ

戻り値

なし


setSplitFileNameメソッド

setSplitFileNameメソッド

帳票を分割または仕分けして蓄積する場合に，分割定義ファイルまたは仕分け定義ファイルのファイル名を指定します。

形式

public void setSplitFileName (String newSplitFileName)

解説

  • setSplitFileNameメソッドは，printReportメソッドで印刷方式が蓄積（setPrintMode=2）の場合で，かつ次のどちらかの条件に当てはまるときに指定が有効になります。それ以外の場合は，setSplitFileNameメソッドを指定しても無視されます。
    • 帳票を分割（setSplitMode=3）または仕分け（setSplitMode=2）する設定にしているとき。
    • 帳票を分割または仕分けするかどうかをEUR Server Serviceの環境設定ファイルの指定に従う（setSplitMode=0）設定にしていて，かつEUR Server Serviceの環境設定ファイルのOPTIONセクションのSPLITMODEキーにPAGE（分割）またはKEY（仕分け）を指定しているとき。
  • ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • setSplitFileNameメソッドは，setSplitFileDataメソッドと同時に使用できません。また，setSplitFileNameメソッドを使用する場合は，ほかのファイルを指定するときも，次に示すファイル入力（ファイル指定）のメソッドを使用してください。
    • マッピングデータファイル（setDataFileName）
    • ユーザ定義データファイル（setUserDataFileName）
    • しおり定義ファイル（setBookmarkFileName）
    • 文書しおり定義ファイル（setDocBookmarkFileName）
    • 暗号化設定ファイル（setCryptoFileName）
    • 帳票セット指定ファイル（setMultiReportSetFileName）
    • PDF仕分け定義ファイル（setDistributeFileName）
  • 分割定義ファイルまたは仕分け定義ファイルは，EUR Server - Adapter稼働マシンに配置してください。

引数

newSplitFileName

分割定義ファイルまたは仕分け定義ファイル名

戻り値

なし


setSplitFilePathメソッド

setSplitFilePathメソッド

setSplitFileNameメソッドで指定した，分割定義ファイルまたは仕分け定義ファイルのパスを指定します。

形式

public void setSplitFilePath (String newSplitFilePath)

解説

  • 指定されたフォルダのパスは，setSplitFileNameメソッドで指定するファイルのデフォルトの場所になります。
  • パスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • setSplitFilePathメソッドは，printReportメソッドで印刷方式が蓄積（setPrintMode=2）の場合で，かつ次のどちらかの条件に当てはまるときに指定が有効になります。それ以外の場合は，setSplitFilePathメソッドを指定しても無視されます。
    • 帳票を分割（setSplitMode=3）または仕分け（setSplitMode=2）する設定にしているとき。
    • 帳票を分割または仕分けするかどうかをEUR Server Serviceの環境設定ファイルの指定に従う（setSplitMode=0）設定にしていて，かつEUR Server Serviceの環境設定ファイルのOPTIONセクションのSPLITMODEキーにPAGE（分割）またはKEY（仕分け）を指定しているとき。

引数

newSplitFilePath

分割定義ファイルまたは仕分け定義ファイルのパス

戻り値

なし


setSplitModeメソッド

setSplitModeメソッド

蓄積時に，帳票を分割または仕分けするかどうかを指定します。

形式

public void setSplitMode (int newSplitMode)

解説

指定できる値を次に示します。

  • 0：EUR Server Serviceの環境設定ファイル（EURPM.ini）のOPTIONセクションのSPLITMODEキーの指定に従います。
  • 1：分割または仕分けしないで蓄積します。
  • 2：帳票を仕分けして蓄積します。
  • 3：帳票を分割して蓄積します。

setSplitModeメソッドの指定を省略した場合，0が仮定されます。

setSplitModeメソッドは，printReportメソッドで印刷方式が蓄積（setPrintMode=2）の場合に指定が有効になります。それ以外の場合は，setSplitModeメソッドを指定しても無視されます。

引数

newSplitMode

帳票を分割または仕分けするかどうか

戻り値

なし


setSpoolFileNameメソッド

setSpoolFileNameメソッド

スプールデータに格納するファイルのファイル名を指定します。

形式

public void setSpoolFileName(String newSpoolFileName)

解説

  • 格納ファイル名は，255バイト以内になるように指定してください。格納ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • 「%N」を指定すると，00000001から始まる8桁の通し番号を設定できます。
  • setSpoolFileNameメソッドを省略した場合は，自動的にファイル名が生成されます。自動的に生成されるファイル名は「ジョブID.epf」※です。
  • 複数のスプールデータに同一ファイル名が指定されている場合，スプールデータ取得時に同一パスで取得されると，ファイルが上書きされます。同一パスで取得する可能性のあるファイルは，別の格納ファイル名に指定することをお勧めします。
  • setSpoolFileNameメソッドは，printReportメソッドで印刷方式が蓄積（setPrintMode=2）の場合，指定が有効になります。それ以外の場合は，setSpoolFileNameメソッドを指定しても無視されます。
    注※
    「ジョブID」の形式を次に示します。
    EUR＋処理実行日時＋通番フォルダ番号+通し番号
    処理実行日時（17桁）：YYYYMMDDhhmmssmmm
    通番フォルダ番号（7桁）：0000001～2000000
    通し番号（9桁）：000000001～999999999
    通番フォルダ番号が2000000を超えた場合は，エラー（KEEY430-S）になります。
    通し番号が999999999を超えた場合は，000000003に戻ります。

引数

newSpoolFileName

スプールデータの格納ファイル名

戻り値

なし


setSpoolLimitメソッド

setSpoolLimitメソッド

スプールデータの蓄積期限日を指定します。

形式

public void setSpoolLimit(String newSpoolLimit)

解説

蓄積期限日は，日付または日数で指定してください。

日付で指定する場合
  • 「YYYYMMDD」の形式で指定してください。
  • 年（西暦）は4桁，月と日は2桁で入力します。
  • 月，または日が1～9の場合は，ゼロ埋めをして入力します。
  • 指定できる値の上限は，20380118（2038年1月18日）です。
  • 過去の日付は指定できません。
（指定例）20120521，20141008
日数で指定する場合
  • 「+XXX」の形式で指定してください。
  • 「XXX」には，蓄積実行時からの保管日数を指定します。指定できる値は000～999です。0を指定した場合は，翌日にスプールデータが削除されます。
  • 2038年1月18日を超える日数は指定できません。
（指定例）+030，+999

setSpoolLimitメソッドの指定がない場合，蓄積期限日は蓄積を要求したEUR Server - Adapterの環境設定ファイルの（EURPMADP.ini）OPTIONセクションのSPOOLLIMITキーの指定に従います。

setSpoolLimitメソッドは，printReportメソッドで印刷方式が蓄積（setPrintMode=2）の場合，指定が有効になります。それ以外の場合は，setSpoolLimitメソッドを指定しても無視されます。

引数

newSpoolLimit

スプールデータの蓄積期限日

戻り値

なし


setSpoolTitleメソッド

setSpoolTitleメソッド

スプールタイトルを指定します。

形式

public void setSpoolTitle (String newSpoolTitle)

解説

  • スプールタイトルには，任意文字列を指定できます。次のことに注意して指定してください。
    • スプールタイトルは，255バイト以内で指定してください。
    • スプールタイトルには「"」および「,」を含めないでください。
  • setSpoolTitleメソッドは，次に示すメソッドで印刷またはファイル出力を実行する場合，指定が有効になります。それ以外の場合は，setSpoolTitleメソッドを指定しても無視されます。
    • printReportメソッド
    • getEPFReportメソッド
    • getEURReportメソッド
    • getMergeEPFReportメソッド
    • outputEPFReportメソッド
    • outputEURReportメソッド
    • outputMergeEPFReportメソッド
  • setSpoolTitleメソッドの指定を省略したときや空文字を指定したときは，スプールタイトル情報は未設定となります。スプールタイトル情報が未設定の場合，印刷時のスプールタイトルに出力される内容は次のとおりです。
    • printReportメソッド，getEPFReportメソッド，およびoutputEPFReportメソッドの場合
      文書情報設定ファイルでTITLEキーを設定しているときは，TITLEキーの指定値が出力されます。TITLEキーを設定していないときは，「HITACHI Report - 帳票ファイル名」が出力されます。
    • getEURReportメソッド，およびoutputEURReportメソッドの場合
      文書情報設定ファイルでTITLEキーを設定しているときは，TITLEキーの指定値が出力されます。TITLEキーを設定していないときは，次に示す表示形式で出力されます。
      ・単一様式帳票の場合
        「HITACHI Report - EUR形式ファイル名（拡張子なし）」
      ・複数の帳票セットを指定した帳票，または複数様式を指定した帳票の場合
        「EUR形式ファイル名（拡張子なし）」
    • getMergeEPFReportメソッド，およびoutputMergeEPFReportメソッドの場合
      最初に指定するEPF形式ファイルの帳票ファイル名が出力されます。

引数

newSpoolTitle

スプールタイトル

戻り値

なし


setUserDataFileDataメソッド

setUserDataFileDataメソッド

ユーザ定義データまたは可変記号値定義データをメモリ渡しする場合，各帳票ファイルで使用するデータを配列で指定します。帳票との対応づけは，配列の要素順です。

形式

public void setUserDataFileData(StringBuffer[] newUserDataFileData)

解説

  • setUserDataFileDataメソッドには，setReportFileNameメソッド，またはsetMultiReportFileNameメソッドで指定したユーザ定義データ，または可変記号値定義データを指定します。指定するときは，配列の要素数が，setReportFileNameメソッド，またはsetMultiReportFileNameメソッドで指定した要素数と同じにしてください。
  • setUserDataFileDataメソッドは，setUserDataFileNameメソッドと同時に使用できません。また，setUserDataFileDataメソッドを使用する場合は，ほかのファイルを指定するときも，次に示すメモリ入力（データ指定）のメソッドを使用してください。ファイル入力のメソッドと組み合わせて使用した場合は，ファイル入力のメソッドを無視します。
    • マッピングデータ（setDataFileData）
    • しおり定義データ（setBookmarkFileData）
    • 文書しおり定義データ（setDocBookmarkFileData）
    • 暗号化設定データ（setCryptoFileData）
    • PDF仕分け定義データ（setDistributeFileData）
    • 分割定義データまたは仕分け定義データ（setSplitFileData）
  • setUserDataFileDataメソッドで指定したユーザ定義データまたは可変記号値定義データの配列に従って，帳票をExcel形式ファイルに出力する場合，配列の要素数が複数のときは，先頭の要素だけが有効になります。

引数

newUserDataFileData

ユーザ定義データまたは可変記号値定義データの配列

戻り値

なし

指定例

複数の帳票セットを指定する場合，一部の帳票に対してユーザ定義データ（または可変記号値定義データ）の指定を省略したいときは，配列の要素に空文字を指定してください。

2番目の帳票のユーザ定義データの指定を省略する場合の例を次に示します。

// 帳票ファイル名を配列fmsに指定
fms[0]="Sample1.fms";
fms[1]="Sample2.fms";
fms[2]="Sample3.fms";
// ユーザ定義データを配列strUsrに指定
usrFileData1 = new StringBuffer("参加者名簿");
Array.set(strUsr, 0, usrFileData1);
mapFileData2 = new StringBuffer("");
Array.set(strUsr, 1, usrFileData2);
mapFileData3 = new StringBuffer("出納帳");
Array.set(strUsr, 2, usrFileData3);

また，複数の帳票セットを指定する場合，複数の帳票に対して同じユーザ定義データ（または可変記号値定義データ）を指定したいときは，それぞれに同じオブジェクトを指定してください。

1番目と2番目の帳票に，同じユーザ定義データを指定するときの例を次に示します。

// 帳票ファイル名を配列fmsに指定
fms[0]="Sample1.fms";
fms[1]="Sample2.fms";
fms[2]="Sample3.fms";
// ユーザ定義データを配列strUsrに指定
usrFileDataA = new StringBuffer("参加者名簿");
Array.set(strUsr, 0, usrFileDataA);
Array.set(strUsr, 1, usrFileDataA);
usrFileDataB = new StringBuffer("出納帳");
Array.set(strUsr, 2, usrFileDataB);


setUserDataFileNameメソッド

setUserDataFileNameメソッド

ユーザ定義データファイル名または可変記号値定義ファイル名を指定します。

形式

public void setUserDataFileName(String newUserDataFileName)

解説

  • ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • setUserDataFileNameメソッドは，setUserDataFileDataメソッドと同時に使用できません。また，setUserDataFileNameメソッドを使用する場合は，ほかのファイルを指定するときも，次に示すファイル入力（ファイル指定）のメソッドを使用してください。
    • マッピングデータファイル（setDataFileName）
    • しおり定義ファイル（setBookmarkFileName）
    • 文書しおり定義ファイル（setDocBookmarkFileName）
    • 暗号化設定ファイル（setCryptoFileName）
    • 帳票セット指定ファイル（setMultiReportSetFileName）
    • PDF仕分け定義ファイル（setDistributeFileName）
    • 分割定義ファイルまたは仕分け定義ファイル（setSplitFileName）
  • ユーザ定義データファイルは，EUR Server - Adapter稼働マシンに配置してください。

引数

newUserDataFileName

ユーザ定義データファイルまたは可変記号値定義ファイル名

戻り値

なし


setUserDataFilePathメソッド

setUserDataFilePathメソッド

setUserDataFileNameメソッドで指定したユーザ定義データファイルのパス，または可変記号値定義ファイルのパスを指定します。

形式

public void setUserDataFilePath(String newUserDataFilePath)

解説

  • ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

引数

newUserDataFilePath

ユーザ定義データファイルまたは可変記号値定義ファイルのパス

戻り値

なし


setViewerPreferenceFileNameメソッド

setViewerPreferenceFileNameメソッド

ビューアプレファレンス定義ファイル名を指定します。

形式

public void setViewerPreferenceFileName(String newViewerPreferenceFileName)

解説

  • EUR Server Serviceの環境設定ファイル（EURPM.ini）で，OPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，ビューアプレファレンス定義ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのPREFERENCEキーで設定しているフォルダに格納しておいてください。
    OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。
    パスは，setViewerPreferenceFilePathメソッドに指定することもできます。setViewerPreferenceFilePathメソッドにパスを指定しない場合は，次のことに注意してください。
    • フルパスを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのPREFERENCEキーには指定が要りません。
    • 相対パスを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのPREFERENCEキーで設定している起点フォルダ下にあるファイル名を指定してください。
    • ファイル名だけを指定する場合
      環境設定ファイル（EURPM.ini）のPATHセクションのPREFERENCEキーで設定しているフォルダにあるファイル名を指定してください。
  • ビューアプレファレンス定義ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • setViewerPreferenceFileNameメソッドは，outputPDFReportメソッド，またはgetPDFReportメソッドでPDF形式ファイルを出力する場合，指定が有効になります。outputPDFReportメソッド，またはgetPDFReportメソッド以外の場合は，setViewerPreferenceFileNameメソッドを指定しても無視されます。
  • ビューアプレファレンス定義ファイルは，EUR Server Service稼働マシンに配置してください。

引数

newPreferenceFileName

ビューアプレファレンス定義ファイル名

戻り値

なし


setViewerPreferenceFilePathメソッド

setViewerPreferenceFilePathメソッド

setViewerPreferenceFileNameメソッドで指定したビューアプレファレンス定義ファイルのパスを指定します。

形式

public void setViewerPreferenceFilePath(String newViewerPreferenceFilePath)

解説

  • ビューアプレファレンス定義ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • setViewerPreferenceFilePathメソッドは，outputPDFReportメソッド，またはgetPDFReportメソッドでPDF形式ファイルを出力する場合，指定が有効になります。outputPDFReportメソッド，またはgetPDFReportメソッド以外の場合は，setViewerPreferenceFilePathメソッドを指定しても無視されます。

引数

newPreferenceFilePath

ビューアプレファレンス定義ファイルのパス

戻り値

なし


setXLSXFileNameメソッド

setXLSXFileNameメソッド

出力するExcel形式ファイル名を指定します。

形式

public void setXLSXFileName(String newXLSXFileName)

解説

  • outputXLSXReportメソッドでExcel形式ファイルを出力する場合は，setXLSXFileNameメソッドを必ず指定してください。outputXLSXReportメソッド以外の場合は，setXLSXFileNameメソッドを指定しても無視されます。
  • Excel形式ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • Excel形式ファイルの拡張子は，*.xlsxです。Excel形式ファイル名は，拡張子を含めて指定してください。

引数

newXLSXFileName

出力するExcel形式ファイル名

戻り値

なし


setXLSXFilePathメソッド

setXLSXFilePathメソッド

setXLSXFileNameメソッドで指定したExcel形式ファイルのパスを指定します。

形式

public void setXLSXFilePath(String newXLSXFilePath)

解説

  • 指定されたフォルダのパスは，setXLSXFileNameメソッドで指定するExcel形式ファイルのデフォルトの場所になります。
  • setXLSXFilePathメソッドは，outputXLSXReportメソッドでExcel形式ファイルを出力する場合，指定が有効になります。outputXLSXReportメソッド以外の場合は，setXLSXFilePathメソッドを指定しても無視されます。
  • パスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

引数

newXLSXFilePath

Excel形式ファイルを出力するパス

戻り値

なし


EURPMExceptionクラスのメソッド仕様

8.5　EURPMExceptionクラスのメソッド仕様

EURPMExceptionクラスで使用できるメソッドの詳細を説明します。

＜この節の構成＞
getErrorCodeメソッド
getErrorLevelメソッド
getKeyメソッド
getMessageメソッド
getOutputDataメソッド


getErrorCodeメソッド

getErrorCodeメソッド

エラーコードを取得します。

形式

public int getErrorCode()

引数

なし

戻り値

エラーコードを返します。


getErrorLevelメソッド

getErrorLevelメソッド

エラーレベルを取得します。

形式

public char getErrorLevel()

引数

なし

戻り値

エラーレベルを示す文字を返します。

  • W：警告
  • E：エラー
  • S：システムエラー


getKeyメソッド

getKeyメソッド

エラーメッセージのメッセージIDを取得します。

形式

public String getKey()

引数

なし

戻り値

エラーメッセージのメッセージIDを返します。


getMessageメソッド

getMessageメソッド

エラーメッセージの文字列を取得します。

形式

public String getMessage()

引数

なし

戻り値

エラーメッセージの文字列を返します。


getOutputDataメソッド

getOutputDataメソッド

例外発生時にエラー種別が警告の場合，次のEPF形式ファイルを取得します。

  • getPDFReportメソッド呼び出し時：PDF形式データ
  • getEURReportメソッド呼び出し時：EUR形式データ
  • getEPFReportメソッド呼び出し時：EPF形式データ
  • getXLSXReportメソッド呼び出し時：Excel形式データ

形式

public ByteBuffer getOutputData ()

引数

なし

戻り値

エラー種別が警告の場合だけ，EPF形式ファイルをバイナリデータで返します。

エラー種別がエラーまたはシステムエラーの場合は，空データを返します。


例外情報

8.6　例外情報

Java起動部品を使用して実行している場合にエラーが発生したときは，例外を発生させます。ユーザプログラムは，EURPMExceptionオブジェクトによって例外情報を取得します。例外情報には，エラーコード（終了コード），エラーレベル，メッセージID，メッセージが含まれます。

＜この節の構成＞
8.6.1　Java起動部品実行時の例外情報一覧
8.6.2　getErrorCodeメソッド（終了コード）
8.6.3　getErrorLevelメソッド（エラーレベル）
8.6.4　getKeyメソッド（メッセージID）
8.6.5　getMessageメソッド（メッセージ文）
8.6.6　getOutputDataメソッド


Java起動部品実行時の例外情報一覧

8.6.1　Java起動部品実行時の例外情報一覧

Java起動部品実行時の例外情報の一覧を次に示します。

表8-8　 Java起動部品実行時の例外情報の一覧

終了 コード | エラー レベル | メッセージ文 | メッセージID
201 | E | プロパティ(プロパティ名)の指定値に誤りがあります。 | KEEY201-E
202 | E | プロパティ(プロパティ名)が指定されていません。 | KEEY202-E
203 | E | マッピングデータファイルの読み込みに失敗しました。 | KEEY203-E
204 | E | ユーザ定義データファイルの読み込みに失敗しました。 | KEEY204-E
205 | E | パラメタに誤りがあります。 | KEEY205-E
206 | E | 必須パラメタの指定がありません。 | KEEY206-E
207 | E | サーバプリンタ名の指定がありません。 | KEEY207-E
208 | E | 原因不明のエラーで処理が中断されました。EUR Server Serviceの状態を確認してください。 | KEEY208-E
209 | W | 印刷処理で警告が発生しました。(nnn) | KEEY209-W
210 | S | 環境設定ファイルに不正があります。詳細コード = [nnnnnn] | KEEY210-S
211 | S | ログファイルの書き込みに失敗しました。 | KEEY211-S
212 | E | EUR Server Serviceへの接続に失敗しました。 | KEEY212-E
213 | I | ジョブを起動しました。 | KEEY213-I
214 | I | ジョブを終了しました。 | KEEY214-I
215 | S | メモリ不足が発生しました。 | KEEY215-S
216 | E | 通信タイムアウトが発生しました。 | KEEY216-E
217 | S | システムエラーが発生しました。 | KEEY217-S
218 | E | 出力先一覧取得処理でエラーが発生しました。（nnn） | KEEY218-E
219 | E | プリンタクラス一覧取得処理でエラーが発生しました。（nnn） | KEEY219-E
221 | E | 印刷処理でエラーが発生しました。（nnn） | KEEY221-E
222 | E | クライアントプリンタ名の指定がありません。 | KEEY222-E
223 | E | PDF形式ファイル出力処理でエラーが発生しました。(nnn) | KEEY223-E
224 | W | PDF形式ファイル出力処理で警告が発生しました。(nnn) | KEEY224-W
225 | E | EPF形式ファイル出力処理でエラーが発生しました。(nnn) | KEEY225-E
226 | W | EPF形式ファイル出力処理で警告が発生しました。(nnn) | KEEY226-W
227 | E | PDF形式ファイルの初期化に失敗しました。 | KEEY227-E
228 | E | EPF形式ファイルの初期化に失敗しました。 | KEEY228-E
229 | E | PDF形式ファイルの作成に失敗しました。 | KEEY229-E
230 | E | EPF形式ファイルの作成に失敗しました。 | KEEY230-E
231 | E | 指定されたPDF形式ファイルはほかの人が使用中です。 | KEEY231-E
232 | E | 指定されたEPF形式ファイルはほかの人が使用中です。 | KEEY232-E
233 | E | 帳票セット指定ファイルのフォーマットが不正です。 | KEEY233-E
234 | E | 帳票セット指定ファイルの読み込みに失敗しました。 | KEEY234-E
235 | E | しおり定義ファイルの読み込みに失敗しました。 | KEEY235-E
236 | E | 文書しおり定義ファイルの読み込みに失敗しました。 | KEEY236-E
237 | E | EUR Server Serviceでコネクション数が限界値をオーバーしました。 | KEEY237-E
238 | E | EUR Spool Serviceでコネクション数が限界値をオーバーしました。 | KEEY238-E
239 | E | EUR Client Serviceでコネクション数が限界値をオーバーしました。 | KEEY239-E
241 | E | 指定されたEUR形式ファイルはほかの人が使用中です。 | KEEY241-E
242 | E | EUR形式ファイルの初期化に失敗しました。 | KEEY242-E
243 | E | EUR形式ファイル出力処理でエラーが発生しました。(nnn) | KEEY243-E
244 | W | EUR形式ファイル出力処理で警告が発生しました。(nnn) | KEEY244-W
245 | E | EUR形式ファイルの作成に失敗しました。 | KEEY245-E
246 | E | EUR Server Serviceのバージョンが不正です。 | KEEY246-E
247 | S | レジストリに不正があります。詳細コード = [nnnnnn] | KEEY247-S
248 | E | 暗号化設定ファイルの読み込みに失敗しました。 | KEEY248-E
249 | E | 指定されたマッピングデータファイルが存在しません。 | KEEY249-E
250 | E | 指定されたユーザ定義データファイルが存在しません。 | KEEY250-E
251 | E | 指定されたしおり定義ファイルが存在しません。 | KEEY251-E
252 | E | 指定された文書しおり定義ファイルが存在しません。 | KEEY252-E
253 | E | 指定された暗号化設定ファイルが存在しません。 | KEEY253-E
255 | E | プリンタ一覧取得処理でエラーが発生しました。（nnn） | KEEY255-E
256 | E | トレイ一覧取得処理でエラーが発生しました。（nnn） | KEEY256-E
257 | E | 蓄積処理でエラーが発生しました。（nnn） | KEEY257-E
258 | W | 蓄積処理で警告が発生しました。（nnn） | KEEY258-W
259 | E | PDF仕分け定義ファイルの読み込みに失敗しました。 | KEEY259-E
260 | E | 指定されたPDF仕分け定義ファイルが存在しません。 | KEEY260-E
261 | E | EPF形式ファイルの読み込みに失敗しました。 | KEEY261-E
262 | E | 指定されたEPF形式ファイルが存在しません。 | KEEY262-E
263 | E | XLSX形式ファイル出力処理でエラーが発生しました。(nnn) | KEEY263-E
264 | W | XLSX形式ファイル出力処理で警告が発生しました。(nnn) | KEEY264-W
265 | E | 指定されたXLSX形式ファイルはほかの人が使用中です。 | KEEY265-E
266 | E | XLSX形式ファイルの初期化に失敗しました。 | KEEY266-E
267 | E | XLSX形式ファイルの作成に失敗しました。 | KEEY267-E
269 | E | 統合対象EPF形式ファイルの指定数が有効範囲外です。 | KEEY269-E
270 | E | 複数EPF形式ファイルの統合処理でエラーが発生しました。（nnn） | KEEY270-E
271 | E | 統合対象EPF形式ファイルの読み込みに失敗しました。 | KEEY271-E
272 | E | 指定された統合対象EPF形式ファイルが存在しません。 | KEEY272-E
273 | S | An attempt to load string resource DLL has failed. Error:[nnn] | KEEY273-S
274 | E | 仕分け/分割定義ファイルの読み込みに失敗しました。 | KEEY274-E
275 | W | 出力すべき帳票セットがありません。(950) | KEEY275-W


getErrorCodeメソッド（終了コード）

8.6.2　getErrorCodeメソッド（終了コード）

EURPMExceptionオブジェクトのgetErrorCodeメソッドは，終了コードを返します。終了コードとメッセージの一覧については，「8.6.1　Java起動部品実行時の例外情報一覧」を参照してください。エラーの対処については，マニュアル「EUR メッセージ」を参照してください。


getErrorLevelメソッド（エラーレベル）

8.6.3　getErrorLevelメソッド（エラーレベル）

EURPMExceptionオブジェクトのgetErrorLevelメソッドは，メッセージのエラーレベルを返します。エラーレベルを次に示します。

  • W：Warning（軽いエラーに対する警告）
  • E：Error（エラー）
  • S：Error（システムエラー）


getKeyメソッド（メッセージID）

8.6.4　getKeyメソッド（メッセージID）

EURPMExceptionオブジェクトのgetKeyメソッドは，メッセージのメッセージIDを返します。終了コードとメッセージの一覧については，「8.6.1　Java起動部品実行時の例外情報一覧」を参照してください。エラーの対処については，マニュアル「EUR メッセージ」を参照してください。


getMessageメソッド（メッセージ文）

8.6.5　getMessageメソッド（メッセージ文）

EURPMExceptionオブジェクトのgetMessageメソッドは，メッセージ文を返します。終了コードとメッセージの一覧については，「8.6.1　Java起動部品実行時の例外情報一覧」を参照してください。エラーの対処については，マニュアル「EUR メッセージ」を参照してください。


getOutputDataメソッド

8.6.6　getOutputDataメソッド

EURPMExceptionオブジェクトのgetOutputDataメソッドは，例外発生時にエラー種別が警告の場合，次のEPF形式ファイルを取得します。

  • getPDFReportメソッド呼び出し時：PDF形式データ
  • getEURReportメソッド呼び出し時：EUR形式データ
  • getEPFReportメソッド呼び出し時：EPF形式データ
  • getXLSXReportメソッド呼び出し時：Excel形式データ


SS-Java起動部品

9.　SS-Java起動部品

この章では，EUR Server - Spool Serviceで提供するSS-Java起動部品を使用した帳票出力について説明します。

＜この章の構成＞
9.1　SS-Java起動部品とは
9.2　EURPMLSAdapterForJavaクラス
9.3　EURPMLSExceptionクラス
9.4　EURPMLSAdapterForJavaクラスのメソッド仕様
9.5　EURPMLSExceptionクラスのメソッド仕様
9.6　例外情報


SS-Java起動部品とは

9.1　SS-Java起動部品とは

EUR Server - Spool Service Adapterは，サーバ側で動作するJavaプログラムから，EUR Server - Spool Serviceを利用できる部品を提供しています。これを，SS-Java起動部品といいます。

Web/APサーバ側のアプリケーション実行環境からSS-Java起動部品を利用することで，サーバ側のアプリケーションを効率良く作成できます。

SS-Java起動部品は，設定メソッドでジョブIDなどを設定し，実行メソッドを呼び出してスプールデータを操作します。

＜この節の構成＞
9.1.1　JDKバージョン
9.1.2　ファイル名
9.1.3　パッケージ


JDKバージョン

9.1.1　JDKバージョン

SS-Java起動部品（EURPMLSAdapter.jar）が前提とするJDKのバージョンを次に示します。

表9-1　Java起動部品のJDKバージョン

OS | JDKのバージョン
Windows | JDK 5.0以降
AIX | JDK 5.0以降
HP-UX | JDK 5.0以降
Linux | JDK 5.0以降


ファイル名

9.1.2　ファイル名

＜この項の構成＞
(1)　SS-Java起動部品のファイル構成
(2)　SS-Java起動部品の設定方法

(1)　SS-Java起動部品のファイル構成

(a)　Windows環境の場合

SS-Java起動部品は，次に示す二つのファイルから構成されます。

  • EURPMLSAdapter.jar
  • EURPMLSADJ.dll

EURPMLSAdapter.jarとEURPMLSADJ.dllは，EUR Server - Spool Service Adapterをインストールしたときに，次に示すフォルダにインストールされます。

32ビットプログラムから呼び出すとき
インストール先フォルダ\SpoolAdapter\Java
64ビットプログラムから呼び出すとき
インストール先フォルダ\SpoolAdapter\Java(x64)
(b)　UNIX／Linux環境の場合

SS-Java起動部品は，次に示す二つのファイルから構成されます。

  • EURPMLSAdapter.jar
  • libEURPMLSADJ.so

EURPMLSAdapter.jarは，EUR Server - Spool Service Adapterをインストールしたときに，次に示すディレクトリにインストールされます。

/opt/eur/spool-adp/java/

libEURPMLSADJ.soは，次に示すディレクトリにインストールされます。

32ビットプログラムから呼び出すとき
/opt/eur/spool-adp/lib/
64ビットプログラムから呼び出すとき
/opt/eur/spool-adp/lib64/

(2)　SS-Java起動部品の設定方法

SS-Java起動部品の設定方法を次に示します。両方とも実施してください。

  • EURPMLSAdapter.jarファイルのフルパスをクラスパスに追加します。
  • Windows環境の場合はEURPMLSADJ.dllのインストール先フォルダに，UNIX／Linux環境の場合はlibEURPMLSADJ.soのインストール先ディレクトリに，ライブラリのパスを通します。

JSPやJavaサーブレットアプリケーションで管理するフォルダ，クラスパスの設定，およびライブラリのパスの設定については，JSP環境のマニュアルを参照してください。


パッケージ

9.1.3　パッケージ

SS-Java起動部品では，JP.co.Hitachi.soft.EURPMLSパッケージを提供します。

JP.co.Hitachi.soft.EURPMLSパッケージは，次に示すクラスを提供します。

  • EUR Server - Spool Serviceの制御を行うクラス
    EURPMLSAdapterForJava：EUR Server - Spool Serviceを制御するクラス
  • 例外の制御を行うクラス
    EURPMLSException：EUR Server - Spool Serviceの制御時に発生するエラー（例外）を管理するクラス


EURPMLSAdapterForJavaクラス

9.2　EURPMLSAdapterForJavaクラス

EURPMLSAdapterForJavaクラスは，EUR Server - Spool Serviceを制御するクラスです。

public class EURPMLSAdapterForJava
クラス継承
java.lang.Object
JP.co.Hitachi.soft.EURPMLS.EURPMLSAdapterForJava
解説
スプールサーバのアドレス，ジョブIDなどのプロパティを設定するメソッドと，スプールデータ一覧取得，蓄積先のサーバ印刷などを行うメソッドを提供します。
JSPやJavaサーブレットなどのアプリケーションプログラムからは，次に示す手順で帳票出力をします。
  1. EURPMLSAdapterForJavaオブジェクトの作成
  2. プロパティの設定
    スプールサーバのアドレス，ジョブIDなどのプロパティを設定するメソッドで情報を設定します。
  3. スプールデータの印刷
    蓄積印刷メソッド（printSpoolReportメソッド）を呼び出してスプールデータを印刷します。
3.の処理で発生したエラー，または発生するエラーは，例外を処理するようにプログラムに記述します。
＜この節の構成＞
9.2.1　コンストラクタ
9.2.2　メソッド一覧
9.2.3　指定値に使用できない文字について


コンストラクタ

9.2.1　コンストラクタ

EURPMLSAdapterForJavaクラスのコンストラクタは，EURPMLSAdapterForJavaオブジェクトを生成します。

public EURPMLSAdapterForJava() throws EURPMLSException
解説
ユーザアプリケーションプログラムからコンストラクタを呼び出すことで，EURPMLSAdapterForJavaオブジェクトを生成します。スプールサーバアドレス，ジョブIDなど，EURPMLSAdapterForJavaクラスのメソッドで設定したあと，printSpoolReportメソッドで帳票出力をします。
引数
なし
例外処理
EURPMLSException
EURPMLSAdapterForJavaオブジェクトの生成時にエラーが発生したときは，EURPMLSExceptionクラスの例外が発生します。


メソッド一覧

9.2.2　メソッド一覧

EURPMLSAdapterForJavaクラスのメソッドには，スプールデータの操作や情報を採取するメソッド（操作メソッド）と，プリンタ一覧，スプールデータ一覧などのプロパティを設定するメソッド（プロパティメソッド）があります。操作メソッドを表9-2に，プロパティメソッドを表9-3に示します。

表9-2　EURPMLSAdapterForJavaクラスの操作メソッド

種類 | メソッド | 概要
蓄積操作メソッド | deleteSpoolFile | 指定したジョブIDのスプールデータを削除したり，蓄積期限を経過したスプールデータを削除したりします。
 | getSpoolFile | 指定したジョブIDのスプールデータからEPF形式ファイルを取得します。
 | getSpoolFileAttribute | 指定したジョブIDのスプールデータの属性情報を取得します。
 | getSpoolFileOutline | 指定条件に合ったEUR Server - Spool Serviceのスプールデータの一覧を取得します。
 | memgetSpoolFile | 指定したジョブIDのスプールデータのEPF形式ファイルをメモリに取得します。
 | printSpoolReport | 指定したジョブIDのスプールデータを印刷します。
 | setSpoolFileAttribute | 指定したジョブIDのスプールデータの属性情報を変更します。
構成定義情報取得メソッド※ | getPrinterClassList | EUR Server - Spool Serviceのプリンタクラス一覧を取得します。
 | getPrinterList | EUR Server - Spool ServiceがあるスプールサーバのOS上のプリンタ一覧を取得します。
 | getTrayList | EUR Server - Spool Serviceがあるスプールサーバの，OS上のプリンタのトレイ一覧を取得します。
監査ログメソッド | changeAuditLog | EUR Server - Spool Serviceがあるスプールサーバ上で出力する監査ログを切り替えます。
初期化メソッド | initialize | 指定されたすべてのプロパティメソッドをクリアにして，初期状態に戻します。
注※
UNIX／Linux環境の場合，構成定義情報取得メソッドは指定できません。

表9-3の表見出しの番号は，次に示すメソッドに対応しています。

表見出しの番号 | 対応するメソッド
1 | getSpoolFileOutline
2 | getSpoolFileAttribute
3 | setSpoolFileAttribute
4 | printSpoolReport
5 | getSpoolFile
6 | deleteSpoolFile
7 | memgetSpoolFile
8 | getPrinterClassList
9 | getPrinterList
10 | getTrayList
11 | changeAuditLog

表9-3　EURPMLSAdapterForJavaクラスのプロパティメソッド

メソッド | 設定内容 | 蓄積操作メソッド |  |  |  |  |  |  | 構成定義情報取得メソッド |  |  | 監査ログメソッド
 |  | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11
getClientAddress | 蓄積クライアント印刷時のクライアントPCのIPアドレスを取得します。 | － | □ | － | － | － | － | － | － | － | － | －
getClientPrinterName | スプールデータのクライアントプリンタ名を取得します。 | － | □ | － | － | － | － | － | － | － | － | －
getClientTrayName | スプールデータのクライアントプリンタのトレイ名を取得します。 | － | □ | － | － | － | － | － | － | － | － | －
getCreateIPAddress | スプールデータを作成したマシンのIPアドレスを取得します。 | － | □ | － | － | － | － | － | － | － | － | －
getCreateLSVersion | スプールデータのフォーマットバージョンを取得します。 | － | □ | － | － | － | － | － | － | － | － | －
getCreateTime | スプールデータの作成日時を取得します。 | － | □ | － | － | － | － | － | － | － | － | －
getCreateTimeMulti | スプールデータ内の作成日時を配列で取得します。 | □ | － | － | － | － | － | － | － | － | － | －
getDispPrintDlg | 蓄積クライアント印刷時のダイアログ表示モードを取得します。 | － | □ | － | － | － | － | － | － | － | － | －
getEnableGet | スプールデータに格納されているEPF形式ファイルの取得可否を取得します。 | － | □ | － | － | － | － | － | － | － | － | －
getExecPrintCount | スプールデータの印刷実行回数を取得します。 | － | □ | － | － | － | － | － | － | － | － | －
getExecutablePrintMode | スプールデータの実行可能印刷方式を取得します。 | － | □ | － | － | － | － | － | － | － | － | －
getGroupName | スプールデータの振り分けグループ名を取得します。 | － | □ | － | － | － | － | － | － | － | － | －
getJobID | ジョブIDを取得します。 | □ | － | － | － | － | － | － | － | － | － | －
getJobKeyCategory | スプールデータのジョブ検索キーの分類を取得します。 | － | □ | － | － | － | － | － | － | － | － | －
getJobKeyData | スプールデータのジョブ検索キー値を取得します。 | － | □ | － | － | － | － | － | － | － | － | －
getMaxPrintCount | スプールデータの印刷上限回数を取得します。 | － | □ | － | － | － | － | － | － | － | － | －
getPageNum | スプールデータ内のEPF形式ファイルのページ数を取得します。 | － | □ | － | － | － | － | － | － | － | － | －
getPageNumMulti | スプールデータ内のEPF形式ファイルのページ数を配列で取得します。 | □ | － | － | － | － | － | － | － | － | － | －
getPrinterClassName | スプールデータのプリンタクラス名を取得します。 | □ | □ | － | － | － | － | － | － | － | － | －
getPrinterClassNameMulti | スプールデータのプリンタクラス名を配列で取得します。 | － | □ | － | － | － | － | － | － | － | － | －
getPrinterSelectMode | 蓄積スプールサーバ印刷方式のプリンタ指定方式を取得します。 | － | □ | － | － | － | － | － | － | － | － | －
getPrintResult | スプールデータの印刷結果を取得します。 | － | □ | － | － | － | － | － | － | － | － | －
getPrintResultMulti | スプールデータ内の印刷結果を配列で取得します。 | □ | － | － | － | － | － | － | － | － | － | －
getPrintTime | スプールデータの印刷日時を取得します。 | － | □ | － | － | － | － | － | － | － | － | －
getReportAddressKeyCategory | 宛先キーの分類を取得します。 | － | □ | － | － | － | － | － | － | － | － | －
getReportAddressKeyData | 宛先キーの値を取得します。 | － | □ | － | － | － | － | － | － | － | － | －
getServerPrinterName | スプールサーバでのOS上のプリンタ名を取得します。 | － | □ | － | － | － | － | － | － | － | ○ | －
getServerTrayName | スプールサーバでのOS上のプリンタのトレイ名を取得します。 | － | □ | － | － | － | － | － | － | － | － | －
getSpoolFileName | スプールデータ内のEPF形式ファイル名を取得します。 | － | □ | － | － | － | － | － | － | － | － | －
getSpoolFileNameMulti | スプールデータ内のEPF形式ファイル名を配列で取得します。 | □ | － | － | － | － | － | － | － | － | － | －
getSpoolFileSize | 格納ファイルのサイズ（バイト）を取得します。 | － | □ | － | － | － | － | － | － | － | － | －
getSpoolHistory | スプールデータの履歴を取得します。 | － | □ | － | － | － | － | － | － | － | － | －
getSpoolLimit | スプールデータの蓄積期限日を取得します。 | － | □ | － | － | － | － | － | － | － | － | －
getSpoolPath | 常に""が出力されます。 | － | □ | － | － | － | － | － | － | － | － | －
getSpoolPathMulti | 常に""が配列で出力されます。 | □ | － | － | － | － | － | － | － | － | － | －
setClientAddress | 蓄積クライアント印刷時のクライアントPCのIPアドレスを指定します。 | － | － | △ | △ | － | － | － | － | － | － | －
setClientPrinterName | スプールデータのクライアントプリンタ名を指定します。 | － | － | △ | △ | － | － | － | － | － | － | －
setClientTrayName | スプールデータのクライアントプリンタのトレイ名を指定します。 | － | － | △ | △ | － | － | － | － | － | － | －
setDeleteKind | スプールデータを削除するときの削除種別を指定します。 | － | － | － | － | － | △ | － | － | － | － | －
setDispPrintDlg | 蓄積クライアント印刷するときのダイアログ表示モードを指定します。 | － | － | △ | △ | － | － | － | － | － | － | －
setEnableGet | スプールデータ内のEPF形式ファイルの取得可否を指定します。 | － | － | △ | － | － | － | － | － | － | － | －
setExecutablePrintMode | スプールデータの実行可能印刷方式を指定します。 | － | － | △ | － | － | － | － | － | － | － | －
setGroupName | スプールデータの振り分けグループ名を指定します。 | － | － | △ | △ | － | － | － | － | － | － | －
setJobKeyCategory | スプールデータのジョブ検索キーの分類を指定します。 | － | － | △ | － | － | － | － | － | － | － | －
setJobKeyData | スプールデータのジョブ検索キーの値を指定します。 | － | － | △ | － | － | － | － | － | － | － | －
setMaxPrintCount | スプールデータの印刷上限回数を指定します。 | － | － | △ | － | － | － | － | － | － | － | －
setOutputFileName | スプールデータから取得した，EPF形式ファイル名を指定します。 | － | － | － | － | △ | － | － | － | － | － | －
setOutputFilePath | スプールデータからEPF形式ファイルを取得するフォルダのパスを指定します。 | － | － | － | － | △ | － | － | － | － | － | －
setPaperOrientation | 用紙の向きを指定します。 | － | － | － | △ | △ | － | △ | － | － | － | －
setPrintCopies | 印刷部数を指定します。 | － | － | － | △ | △ | － | △ | － | － | － | －
setPrintEndPage | 蓄積スプールサーバ印刷するときの終了ページを指定します。 | － | － | － | △ | － | － | － | － | － | － | －
setPrinterClassName | スプールデータのプリンタクラス名を指定します。 | － | － | △ | △ | △ | － | △ | － | － | － | －
setPrinterSelectMode | 蓄積スプールサーバ印刷するときのプリンタ指定方式を指定します。 | － | － | △ | △ | － | － | － | － | － | － | －
setPrintMode | 蓄積したデータの印刷方式を指定します。 | － | － | － | － | － | － | － | － | － | － | －
setPrintStartPage | 蓄積スプールサーバ印刷するときの開始ページを指定します。 | － | － | － | △ | － | － | － | － | － | － | －
setSearchCreateTimeEnd | ファイル作成日時でスプールデータを検索するときの検索終了日時を指定します。 | △ | － | － | － | － | － | － | － | － | － | －
setSearchCreateTimeStart | ファイル作成日時でスプールデータを検索するときの検索開始日時を指定します。 | △ | － | － | － | － | － | － | － | － | － | －
setSearchJobID | スプールデータを検索するときのジョブIDを指定します。 | △ | ○ | ○ | ○ | ○ | ○／－ | ○ | － | － | － | －
setSearchJobIDMulti | スプールデータを検索するときのジョブIDを配列で指定します。 | － | － | － | － | － | ○／－ | － | － | － | － | －
setSearchJobKeyCategory | スプールデータを検索するときのジョブ検索キーの分類を指定します。 | △ | － | － | － | － | － | － | － | － | － | －
setSearchJobKeyData | スプールデータを検索するときのジョブ検索キーの値を指定します。 | △ | － | － | － | － | － | － | － | － | － | －
setSearchPrinterClassName | プリンタクラス名でスプールデータを検索するときのプリンタクラス名を指定します。 | △ | － | － | － | － | － | － | － | － | － | －
setSearchReportAddressKeyCategory | スプールデータを検索するときの検索キーの分類を指定します。 | △ | － | － | － | － | － | － | － | － | － | －
setSearchReportAddressKeyData | スプールデータを検索するときの検索キーの値を指定します。 | △ | － | － | － | － | － | － | － | － | － | －
setSearchSpoolFileName | 格納されているEPF形式ファイル名でスプールデータを検索するときのEPF形式ファイル名を指定します。 | △ | － | － | － | － | － | － | － | － | － | －
setServerAddress | スプールサーバのIPアドレスを指定します。 | △ | △ | △ | △ | △ | △ | △ | △ | △ | △ | △
setServerPrinterName | スプールサーバでのOS上のプリンタ名を指定します。 | － | － | △ | △ | － | － | － | － | － | ○ | －
setServerTrayName | スプールサーバでのOS上のプリンタのトレイ名を指定します。 | － | － | △ | △ | － | － | － | － | － | － | －
setSortPrint | 印刷部数の単位を指定します。 | － | － | － | △ | △ | － | △ | － | － | － | －
setSpoolLimit | スプールデータの蓄積期限日を指定します。 | － | － | △ | － | － | － | － | － | － | － | －
setSpoolTitle | スプールタイトルを指定します。 | － | － | － | △ | △ | － | △ | － | － | － | －
（凡例）
○：必ず指定します。
△：指定を省略できます。
□：結果を出力します。
－：指定できません。


指定値に使用できない文字について

9.2.3　指定値に使用できない文字について

オプションの指定値には，制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」は使用できません。これらの文字を指定した場合，帳票管理GUI，［EUR Server Service 構成定義］ダイアログ，［EUR Spool Service 構成定義］ダイアログ，および［EUR Client 構成定義］ダイアログを操作できないことがあります。


EURPMLSExceptionクラス

9.3　EURPMLSExceptionクラス

EURPMLSExceptionクラスは，SS-Java起動部品の各メソッドで例外が発生した場合にスローされるクラスです。

public class EURPMLSException extends java.lang.Exception
クラス継承
java.lang.Exception
JP.co.Hitachi.soft.EURPMLS.EURPMLSException
解説
EURPMLSExceptionクラスのオブジェクトは，SS-Java起動部品の内部で生成します。
ユーザプログラムは，このオブジェクトを例外ハンドラで受け取り，getMessageメソッド，またはgetErrorCodeメソッドを呼び出してエラー情報を取得します。
＜この節の構成＞
9.3.1　メソッド一覧
9.3.2　指定値に使用できない文字について


メソッド一覧

9.3.1　メソッド一覧

EURPMLSExceptionクラスのメソッドを次に示します。

表9-4　EURPMLSExceptionクラスのメソッド

メソッド | 設定内容
getErrorCode | エラーコードを取得します。
getErrorLevel | エラーレベルを取得します。
getKey | エラーメッセージのキー文字列を取得します。
getMessage | エラーメッセージの文字列を取得します。
getOutputData | 例外発生時にエラー種別が警告の場合，EPF形式ファイルを取得します。


指定値に使用できない文字について

9.3.2　指定値に使用できない文字について

オプションの指定値に指定できない文字については，「9.2.3　指定値に使用できない文字について」を参照してください。


EURPMLSAdapterForJavaクラスのメソッド仕様

9.4　EURPMLSAdapterForJavaクラスのメソッド仕様

EURPMLSAdapterForJavaクラスで使用できるメソッドの詳細を説明します。

＜この節の構成＞
changeAuditLogメソッド
deleteSpoolFileメソッド
getClientAddressメソッド
getClientPrinterNameメソッド
getClientTrayNameメソッド
getCreateIPAddressメソッド
getCreateLSVersionメソッド
getCreateTimeメソッド
getCreateTimeMultiメソッド
getDispPrintDlgメソッド
getEnableGetメソッド
getExecPrintCountメソッド
getExecutablePrintModeメソッド
getGroupNameメソッド
getJobIDメソッド
getJobKeyCategoryメソッド
getJobKeyDataメソッド
getMaxPrintCountメソッド
getPageNumメソッド
getPageNumMultiメソッド
getPrinterClassListメソッド
getPrinterClassNameメソッド
getPrinterClassNameMultiメソッド
getPrinterListメソッド
getPrinterSelectModeメソッド
getPrintResultメソッド
getPrintResultMultiメソッド
getPrintTimeメソッド
getReportAddressKeyCategoryメソッド
getReportAddressKeyDataメソッド
getServerPrinterNameメソッド
getServerTrayNameメソッド
getSpoolFileメソッド
getSpoolFileAttributeメソッド
getSpoolFileNameメソッド
getSpoolFileNameMultiメソッド
getSpoolFileOutlineメソッド
getSpoolFileSizeメソッド
getSpoolHistoryメソッド
getSpoolLimitメソッド
getSpoolPathメソッド
getSpoolPathMultiメソッド
getTrayListメソッド
initializeメソッド
memgetSpoolFileメソッド
printSpoolReportメソッド
setClientAddressメソッド
setClientPrinterNameメソッド
setClientTrayNameメソッド
setDeleteKindメソッド
setDispPrintDlgメソッド
setEnableGetメソッド
setExecutablePrintModeメソッド
setGroupNameメソッド
setJobKeyCategoryメソッド
setJobKeyDataメソッド
setMaxPrintCountメソッド
setOutputFileNameメソッド
setOutputFilePathメソッド
setPaperOrientationメソッド
setPrintCopiesメソッド
setPrintEndPageメソッド
setPrinterClassNameメソッド
setPrinterSelectModeメソッド
setPrintModeメソッド
setPrintStartPageメソッド
setSearchCreateTimeEndメソッド
setSearchCreateTimeStartメソッド
setSearchJobIDメソッド
setSearchJobIDMultiメソッド
setSearchJobKeyCategoryメソッド
setSearchJobKeyDataメソッド
setSearchPrinterClassNameメソッド
setSearchReportAddressKeyCategoryメソッド
setSearchReportAddressKeyDataメソッド
setSearchSpoolFileNameメソッド
setServerAddressメソッド
setServerPrinterNameメソッド
setServerTrayNameメソッド
setSortPrintメソッド
setSpoolFileAttributeメソッド
setSpoolLimitメソッド
setSpoolTitleメソッド


changeAuditLogメソッド

changeAuditLogメソッド

指定したスプールサーバ上で出力する監査ログを切り替えます。

形式

public void changeAuditLog() throws EURPMLSException

解説

  • changeAuditLogメソッドは，スプールサーバ上で出力する監査ログの切り替えが終了した時点で呼び出し元に制御が戻ります。
  • 実行時にエラーが発生した場合，getErrorCodeメソッドに終了コード，getMessageメソッドにメッセージが設定されます。

引数

なし

戻り値

なし

例外処理

EURPMLSException

エラー発生時は，EURPMLSException例外がスローされます。


deleteSpoolFileメソッド

deleteSpoolFileメソッド

指定したジョブIDのスプールデータを削除したり，蓄積期限を経過したスプールデータを削除したりします。スプールデータの削除，および蓄積期限切れスプールデータの一括削除については，マニュアル「EUR 帳票出力 機能解説 EUR Server編」を参照してください。

形式

public void deleteSpoolFile() throws EURPMLSException

解説

  • deleteSpoolFileメソッドは，スプールサーバ上のスプールデータ内の削除が終了した時点で呼び出し元に制御が戻ります。
  • 実行時にエラーが発生した場合，getErrorCodeメソッドに終了コード，getMessageメソッドにメッセージが設定されます。

引数

なし

戻り値

なし

例外処理

EURPMLSException

エラー発生時は，EURPMLSException例外がスローされます。


getClientAddressメソッド

getClientAddressメソッド

蓄積クライアント印刷するときのクライアントPCのIPアドレスを取得します。

形式

public String getClientAddress()

解説

  • getClientAddressメソッドは，getSpoolFileAttributeメソッドを呼び出すことで，蓄積クライアント印刷するときのクライアントIPアドレスが「255.255.255.255」形式で出力されます。
  • getClientAddressメソッドは，getSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，getClientAddressメソッドを指定しても無視されます。

引数

なし

戻り値

蓄積クライアント印刷するときのクライアントPCのIPアドレス


getClientPrinterNameメソッド

getClientPrinterNameメソッド

蓄積クライアント印刷するときのOS上のプリンタ名を取得します。

形式

public String getClientPrinterName()

解説

  • getClientPrinterNameメソッドは，getSpoolFileAttributeメソッドを呼び出すことで，蓄積クライアント印刷するときのプリンタ名が出力されます。
  • getClientPrinterNameメソッドは，getSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，getClientPrinterNameメソッドを指定しても無視されます。

引数

なし

戻り値

蓄積クライアント印刷するときのOS上のプリンタ名


getClientTrayNameメソッド

getClientTrayNameメソッド

蓄積クライアント印刷するときのプリンタのトレイ名を取得します。

形式

public String getClientTrayName()

解説

  • getClientTrayNameメソッドは，getSpoolFileAttributeメソッドを呼び出すことで，蓄積クライアント印刷するときのプリンタのトレイ名が出力されます。
  • getClientTrayNameメソッドは，getSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，getClientTrayNameメソッドを指定しても無視されます。

引数

なし

戻り値

蓄積クライアント印刷するときのプリンタのトレイ名


getCreateIPAddressメソッド

getCreateIPAddressメソッド

スプールデータを作成したマシンのIPアドレスを取得します。

形式

public String getCreateIPAddress()

解説

  • getCreateIPAddressメソッドは，getSpoolFileAttributeメソッドを呼び出すことで，スプールデータ作成者のIPアドレスが「255.255.255.255」形式で出力されます。
  • getCreateIPAddressメソッドは，getSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，getCreateIPAddressメソッドを指定しても無視されます。

引数

なし

戻り値

スプールデータ作成者のIPアドレス


getCreateLSVersionメソッド

getCreateLSVersionメソッド

スプールデータのフォーマットバージョンを取得します。

形式

public String getCreateLSVersion()

解説

  • getCreateLSVersionメソッドは，getSpoolFileAttributeメソッドを呼び出すことで，スプールデータのフォーマットバージョンが「VV－RR」形式で出力されます。
    スプールデータのフォーマットバージョンは，EUR Server - Spool Serviceのバージョンとは異なります。
  • getCreateLSVersionメソッドは，getSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，getCreateLSVersionメソッドを指定しても無視されます。

引数

なし

戻り値

スプールデータを作成したEUR Server - Spool Serviceのバージョン「VV－RR」


getCreateTimeメソッド

getCreateTimeメソッド

スプールデータの作成日時を取得します。

形式

public String getCreateTime()

解説

  • getCreateTimeメソッドは，getSpoolFileAttributeメソッドを呼び出すことで，指定したジョブIDのスプールデータの作成日時が出力されます。
  • 出力されるスプールデータの作成日時の形式は「YYYYMMDDhhmmss」です。
    「YYYYMMDDhhmmss」形式の内容を次に示します。
    • YYYY：年（西暦）を4桁で示します。
    • MM：月（01～12）を2桁で示します。01～09は，ゼロ埋めされます。
    • DD：日（01～31）を2桁で示します。01～09は，ゼロ埋めされます。
    • hh：時（00～23）を2桁で示します。00～09は，ゼロ埋めされます。
    • mm：分（00～59）を2桁で示します。00～09は，ゼロ埋めされます。
    • ss：秒（00～59）を2桁で示します。00～09は，ゼロ埋めされます。
    （出力例）20060523015630
  • getCreateTimeメソッドは，getSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，getCreateTimeメソッドを指定しても無視されます。

引数

なし

戻り値

スプールデータ内の作成日時「YYYYMMDDhhmmss」


getCreateTimeMultiメソッド

getCreateTimeMultiメソッド

スプールデータ内の作成日時を配列で取得します。

形式

public String[] getCreateTimeMulti()

解説

  • getCreateTimeMultiメソッドは，getSpoolFileOutlineメソッドを呼び出すことで，検索条件に合ったスプールデータの作成日時が配列で出力されます。
  • 出力されるスプールデータの作成日時の形式は「YYYYMMDDhhmmss」です。
    「YYYYMMDDhhmmss」形式の内容を次に示します。
    • YYYY：年（西暦）を4桁で示します。
    • MM：月（01～12）を2桁で示します。01～09は，ゼロ埋めされます。
    • DD：日（01～31）を2桁で示します。01～09は，ゼロ埋めされます。
    • hh：時（00～23）を2桁で示します。00～09は，ゼロ埋めされます。
    • mm：分（00～59）を2桁で示します。00～09は，ゼロ埋めされます。
    • ss：秒（00～59）を2桁で示します。00～09は，ゼロ埋めされます。
    （出力例）20060523015630
  • getCreateTimeMultiメソッドは，getSpoolFileOutlineメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，getCreateTimeMultiメソッドを指定しても無視されます。

引数

なし

戻り値

スプールデータ内の作成日時「YYYYMMDDhhmmss」を配列で返します。


getDispPrintDlgメソッド

getDispPrintDlgメソッド

蓄積クライアント印刷するときのダイアログ表示モードを取得します。

形式

public int getDispPrintDlg()

解説

  • getDispPrintDlgメソッドは，getSpoolFileAttributeメソッドを呼び出すことで，蓄積クライアント印刷するときのダイアログ表示モードが出力されます。
  • 出力される蓄積クライアント印刷するときのダイアログ表示モードと印刷時の動作を次に示します。
    • 0：印刷先指定ダイアログを表示します（対話型印刷）。
      プレビューボタンを選択すると，プレビューウィンドウが表示されます。
    • 1：直接印刷を実行します（自動印刷）。
      印刷実行中に印刷中のダイアログが表示されます。
    • 2：プレビューウィンドウを表示します（対話型印刷プレビュー表示）。
      印刷メニューまたは印刷ボタンを選択すると，印刷先指定ダイアログが表示されます。
    • 3：直接印刷を実行します（全自動印刷）。
      印刷実行中に印刷中のダイアログは表示されません。
    • 4：プレビューウィンドウを表示します（対話型印刷プレビュー表示限定）。
      印刷は実行できません。
  • getDispPrintDlgメソッドは，getSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，getDispPrintDlgメソッドを指定しても無視されます。

引数

なし

戻り値

蓄積クライアント印刷するときのダイアログ表示モード


getEnableGetメソッド

getEnableGetメソッド

スプールデータに格納されているEPF形式ファイルの取得が許可されているかどうかを取得します。

形式

public boolean getEnableGet()

解説

  • getEnableGetメソッドは，getSpoolFileAttributeメソッドを呼び出すことで，スプールデータの取得許可情報が出力されます。
  • 出力されるスプールデータの取得許可情報を次に示します。
    • True：スプールデータの取得を許可します。
    • False：スプールデータの取得を許可しません。
  • getEnableGetメソッドは，getSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，getEnableGetメソッドを指定しても無視されます。

引数

なし

戻り値

EPF形式ファイルの取得許可情報


getExecPrintCountメソッド

getExecPrintCountメソッド

スプールデータの印刷実行回数を取得します。

形式

public int getExecPrintCount()

解説

  • getExecPrintCountメソッドは，getSpoolFileAttributeメソッドを呼び出すことで，スプールデータの印刷実行回数が出力されます。
    印刷実行回数は，スプールサーバでの印刷で印刷スプールへの出力が成功したとき，またはクライアントPCでの印刷でEPF形式ファイルの転送が成功したときに，1カウントずつアップされます。
  • getExecPrintCountメソッドは，getSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，getExecPrintCountメソッドを指定しても無視されます。

引数

なし

戻り値

スプールデータの印刷実行回数


getExecutablePrintModeメソッド

getExecutablePrintModeメソッド

スプールデータの実行可能印刷方式を取得します。

形式

public int getExecutablePrintMode()

解説

  • getExecutablePrintModeメソッドは，getSpoolFileAttributeメソッドを呼び出すことで，スプールデータの実行可能印刷方式が出力されます。
  • 出力されるスプールデータの実行可能印刷方式を次に示します。
    • 0：蓄積スプールサーバ印刷
    • 1：蓄積スプールサーバ印刷／蓄積クライアント印刷
    • 2：蓄積クライアント印刷
  • getExecutablePrintModeメソッドは，getSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，getExecutablePrintModeメソッドを指定しても無視されます。

引数

なし

戻り値

スプールデータの実行可能印刷方式


getGroupNameメソッド

getGroupNameメソッド

スプールデータの振り分けグループ名を取得します。

形式

public String getGroupName()

解説

  • getGroupNameメソッドは，getSpoolFileAttributeメソッドを呼び出すことで，スプールデータの振り分けグループ名が出力されます。
  • getGroupNameメソッドは，getSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，getGroupNameメソッドを指定しても無視されます。

引数

なし

戻り値

スプールデータの振り分けグループ名


getJobIDメソッド

getJobIDメソッド

ジョブIDを取得します。

形式

public String[] getJobID()

解説

  • getJobIDメソッドは，getSpoolFileOutlineメソッドを呼び出すことで，検索条件に合ったスプールデータのジョブIDが配列で出力されます。
  • getJobIDメソッドは，getSpoolFileOutlineメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，getJobIDメソッドを指定しても無視されます。

引数

なし

戻り値

ジョブIDを配列で返します。


getJobKeyCategoryメソッド

getJobKeyCategoryメソッド

スプールデータのジョブ検索キーの分類を取得します。

形式

public String[] getJobKeyCategory()

解説

  • getJobKeyCategoryメソッドは，getSpoolFileAttributeメソッドを呼び出すことで，スプールデータのジョブ検索キーの分類が出力されます。
  • getJobKeyCategoryメソッドは，getSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，getJobKeyCategoryメソッドを指定しても無視されます。

引数

なし

戻り値

スプールデータのジョブ検索キーの分類を配列で返します。


getJobKeyDataメソッド

getJobKeyDataメソッド

スプールデータのジョブ検索キーの値を取得します。

形式

public String[] getJobKeyData()

解説

  • getJobKeyDataメソッドは，getSpoolFileAttributeメソッドを呼び出すことで，スプールデータのジョブ検索キーの値が出力されます。
  • getJobKeyDataメソッドは，getSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，getJobKeyDataメソッドを指定しても無視されます。

引数

なし

戻り値

スプールデータのジョブ検索キーの値を配列で返します。


getMaxPrintCountメソッド

getMaxPrintCountメソッド

スプールデータの印刷上限回数を取得します。

形式

public int getMaxPrintCount()

解説

  • getMaxPrintCountメソッドは，getSpoolFileAttributeメソッドを呼び出すことで，スプールデータの印刷上限回数が出力されます。
  • 出力される印刷上限回数の値は，-1～65,536です。
    • -1：印刷回数の上限が無限であることを示します。
    • 0：印刷を禁止していることを示します。
    • 1～65,536：印刷上限回数を示します。
  • getMaxPrintCountメソッドは，getSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，getMaxPrintCountメソッドを指定しても無視されます。

引数

なし

戻り値

スプールデータの印刷上限回数


getPageNumメソッド

getPageNumメソッド

スプールデータに格納されたEPF形式ファイルのページ数を取得します。

形式

public int getPageNum()

解説

  • getPageNumメソッドは，getSpoolFileAttributeメソッドを呼び出すことで，指定したジョブIDのスプールデータに格納されているEPF形式ファイルのページ数が出力されます。
  • getPageNumメソッドは，getSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，getPageNumメソッドを指定しても無視されます。

引数

なし

戻り値

スプールデータに格納されたEPF形式ファイルのページ数


getPageNumMultiメソッド

getPageNumMultiメソッド

スプールデータに格納されたEPF形式ファイルのページ数を配列で取得します。

形式

public int[] getPageNumMulti()

解説

  • getPageNumMultiメソッドは，getSpoolFileOutlineメソッドを呼び出すことで，検索条件に合ったスプールデータに格納されているEPF形式ファイルのページ数が配列で出力されます。
  • getPageNumMultiメソッドは，getSpoolFileOutlineメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，getPageNumMultiメソッドを指定しても無視されます。

引数

なし

戻り値

スプールデータに格納されたEPF形式ファイルのページ数を配列で返します。


getPrinterClassListメソッド

getPrinterClassListメソッド

EUR Server - Spool Serviceのプリンタクラス一覧を取得します。

形式

public String[][] getPrinterClassList() throws EURPMLSException

解説

  • getPrinterClassListメソッドは，スプールサーバ上のプリンタクラス一覧の取得が終了した時点で呼び出し元に制御が戻ります。
  • EUR Server - Spool ServiceがあるスプールサーバのIPアドレスをsetServerAddressメソッドで指定します。
  • 実行時にエラーが発生した場合，getErrorCodeメソッドに終了コード，getMessageメソッドにメッセージが設定されます。
  • UNIX／Linux環境の場合，プリンタクラス一覧の取得はサポートしていません。UNIX／Linux環境のEUR Server - Spool Serviceに対して，プリンタクラス一覧の取得を実行した場合はエラーとなります。

引数

なし

戻り値

拠点プリンタクラス定義ファイルのデータを，次に示す2次元配列の文字列で返します。

String[0]：プリンタクラス名の一覧が格納されているString配列
String[1]：プリンタ名の一覧が格納されているString配列
String[2]：トレイ名の一覧が格納されているString配列
String[3]：説明の一覧が格納されているString配列

各要素数は同一となります。

例外処理

EURPMLSException

エラー発生時は，EURPMLSException例外がスローされます。


getPrinterClassNameメソッド

getPrinterClassNameメソッド

スプールデータのプリンタクラス名を取得します。

形式

public String getPrinterClassName()

解説

  • getPrinterClassNameメソッドは，getSpoolFileAttributeメソッドを呼び出すことで，指定したジョブIDのスプールデータのプリンタクラス名が出力されます。
  • getPrinterClassNameメソッドは，getSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，getPrinterClassNameメソッドを指定しても無視されます。

引数

なし

戻り値

スプールデータのプリンタクラス名


getPrinterClassNameMultiメソッド

getPrinterClassNameMultiメソッド

スプールデータのプリンタクラス名を配列で取得します。

形式

public String[] getPrinterClassNameMulti()

解説

  • getPrinterClassNameMultiメソッドは，getSpoolFileOutlineメソッドを呼び出すことで，検索条件に合ったスプールデータのプリンタクラス名が配列で出力されます。
  • getPrinterClassNameMultiメソッドは，getSpoolFileOutlineメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，getPrinterClassNameMultiメソッドを指定しても無視されます。

引数

なし

戻り値

スプールデータのプリンタクラス名を配列で返します。


getPrinterListメソッド

getPrinterListメソッド

指定した出力先のスプールサーバのOS上のプリンタ一覧を取得します。

形式

public String[] getPrinterList() throws EURPMLSException

解説

  • getPrinterListメソッドは，OS上のプリンタ一覧の取得が終了した時点で呼び出し元に制御が戻ります。
  • EUR Server - Spool ServiceがあるスプールサーバのIPアドレスは，setServerAddressメソッドで指定します。
  • 実行時にエラーが発生した場合，getErrorCodeメソッドに終了コード，getMessageメソッドにメッセージが設定されます。
  • UNIX／Linux環境の場合，プリンタ一覧の取得はサポートしていません。UNIX／Linux環境のEUR Server - Spool Serviceに対して，プリンタ一覧の取得を実行した場合はエラーとなります。

引数

なし

戻り値

OS上のプリンタ一覧を，次に示す形式で返します。

OS上のプリンタ名1
OS上のプリンタ名2
        ：
OS上のプリンタ名n

例外処理

EURPMLSException

エラー発生時は，EURPMLSException例外がスローされます。


getPrinterSelectModeメソッド

getPrinterSelectModeメソッド

蓄積スプールサーバ印刷するときのプリンタ指定方式を取得します。

形式

public int getPrinterSelectMode()

解説

  • getPrinterSelectModeメソッドは，getSpoolFileAttributeメソッドを呼び出すことで，蓄積スプールサーバ印刷するときのプリンタ指定方式が出力されます。
  • 出力されるプリンタ指定方式を次に示します。
    • 0：プリンタクラス名指定
    • 1：OS上のプリンタ名指定
    • 2：帳票名による自動振り分け
  • getPrinterSelectModeメソッドは，getSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，getPrinterSelectModeメソッドを指定しても無視されます。

引数

なし

戻り値

蓄積スプールサーバ印刷するときのプリンタ指定方式


getPrintResultメソッド

getPrintResultメソッド

スプールデータの印刷結果を取得します。

形式

public int getPrintResult()

解説

  • 出力される印刷結果を次に示します。
    • 0：未印刷であることを示します。
    • 1：印刷済みであることを示します。
    • 2：印刷エラーがあったことを示します。
  • getPrintResultメソッドは，getSpoolFileAttributeメソッドを呼び出すことで，指定したジョブIDのスプールデータの印刷結果が出力されます。
  • getPrintResultメソッドは，getSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，getPrintResultメソッドを指定しても無視されます。

引数

なし

戻り値

スプールデータ内の印刷結果


getPrintResultMultiメソッド

getPrintResultMultiメソッド

スプールデータ内の印刷結果を配列で取得します。

形式

public int[] getPrintResultMulti()

解説

  • 出力される印刷結果を次に示します。
    • 0：未印刷であることを示します。
    • 1：印刷済みであることを示します。
    • 2：印刷エラーがあったことを示します。
  • getPrintResultMultiメソッドは，getSpoolFileOutlineメソッドを呼び出すことで，検索条件に合ったスプールデータの印刷結果が配列で出力されます。
  • getPrintResultMultiメソッドは，getSpoolFileOutlineメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，getPrintResultMultiメソッドを指定しても無視されます。

引数

なし

戻り値

スプールデータ内の印刷結果を，数値型の配列で返します。


getPrintTimeメソッド

getPrintTimeメソッド

スプールデータの印刷日時を取得します。

形式

public String getPrintTime()

解説

  • スプールデータの印刷日時は，蓄積したデータをスプールサーバまたはクライアントPCで印刷したタイミングで，ジョブ実行時の日時に更新されます。
  • 出力されるスプールデータの印刷日時の形式は「YYYYMMDDhhmmss」です。
    「YYYYMMDDhhmmss」形式の内容を次に示します。
    • YYYY：年（西暦）を4桁で示します。
    • MM：月（01～12）を2桁で示します。01～09は，ゼロ埋めされます。
    • DD：日（01～31）を2桁で示します。01～09は，ゼロ埋めされます。
    • hh：時（00～23）を2桁で示します。00～09は，ゼロ埋めされます。
    • mm：分（00～59）を2桁で示します。00～09は，ゼロ埋めされます。
    • ss：秒（00～59）を2桁で示します。00～09は，ゼロ埋めされます。
    （出力例）20060523015630
  • スプールデータが一度も印刷されていない場合は，"" が出力されます。
  • getPrintTimeメソッドは，getSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，getPrintTimeメソッドを指定しても無視されます。

引数

なし

戻り値

スプールデータの印刷日時「YYYYMMDDhhmmss」


getReportAddressKeyCategoryメソッド

getReportAddressKeyCategoryメソッド

スプールデータの宛先キーの分類を取得します。

形式

public String getReportAddressKeyCategory ()

解説

getReportAddressKeyCategoryメソッドは，getSpoolFileAttributeメソッドを呼び出したあと，指定したスプールデータの宛先キーの分類を取得します。

引数

なし

戻り値

String


getReportAddressKeyDataメソッド

getReportAddressKeyDataメソッド

スプールデータの宛先キーの値を取得します。

形式

public String getReportAddressKeyData ()

解説

getReportAddressKeyDataメソッドは，getSpoolFileAttributeメソッドを呼び出したあと，指定したスプールデータの宛先キーの値を取得します。

引数

なし

戻り値

String


getServerPrinterNameメソッド

getServerPrinterNameメソッド

スプールサーバでのOS上のプリンタ名を取得します。

形式

public String getServerPrinterName()

解説

  • getServerPrinterNameメソッドは，getSpoolFileAttributeメソッドを呼び出すことで，スプールデータを蓄積スプールサーバ印刷するときのOS上のプリンタ名が出力されます。
  • getServerPrinterNameメソッドは，getSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，getServerPrinterNameメソッドを指定しても無視されます。

引数

なし

戻り値

スプールサーバでのOS上のプリンタ名


getServerTrayNameメソッド

getServerTrayNameメソッド

スプールサーバでのOS上のプリンタのトレイ名を取得します。

形式

public String getServerTrayName()

解説

  • getServerTrayNameメソッドは，getSpoolFileAttributeメソッドを呼び出すことで，蓄積スプールサーバ印刷するときのプリンタのトレイ名が出力されます。
  • getServerTrayNameメソッドは，getSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，getServerTrayNameメソッドを指定しても無視されます。

引数

なし

戻り値

スプールサーバでのOS上のプリンタのトレイ名


getSpoolFileメソッド

getSpoolFileメソッド

指定したジョブIDのスプールデータに格納されているEPF形式ファイルを，指定したパスに取得します。

取得後のEPF形式ファイルは，setOutputFileNameメソッドで指定したファイル名になります。

指定したパスに同一名のファイルがある場合は，上書きされます。スプールデータの取得については，マニュアル「EUR 帳票出力 機能解説 EUR Server編」を参照してください。

形式

public void getSpoolFile() throws EURPMLSException

解説

  • getSpoolFileメソッドは，スプールサーバ上のスプールデータ内の格納ファイルをsetOutputFilePathメソッドで指定されたフォルダに出力が終了した時点で呼び出し元に制御が戻ります。
  • 実行時にエラーが発生した場合，getErrorCodeメソッドに終了コード，getMessageメソッドにメッセージが設定されます。

引数

なし

戻り値

なし

例外処理

EURPMLSException

エラー発生時は，EURPMLSException例外がスローされます。


getSpoolFileAttributeメソッド

getSpoolFileAttributeメソッド

指定したジョブIDのスプールデータの属性情報を取得します。取得されるスプールデータの属性情報については，マニュアル「EUR 帳票出力 機能解説 EUR Server編」を参照してください。

形式

public void getSpoolFileAttribute() throws EURPMLSException

解説

  • getSpoolFileAttributeメソッドは，スプールサーバにあるスプールデータの属性情報の取得が終了した時点で呼び出し元に制御が戻ります。
  • 実行時にエラーが発生した場合，getErrorCodeメソッドに終了コード，getMessageメソッドにメッセージが設定されます。

引数

なし

戻り値

なし

例外処理

EURPMLSException

エラー発生時は，EURPMLSException例外がスローされます。


getSpoolFileNameメソッド

getSpoolFileNameメソッド

スプールデータに格納されているEPF形式ファイル名を取得します。

形式

public String getSpoolFileName()

解説

  • getSpoolFileNameメソッドは，getSpoolFileAttributeメソッドを呼び出すことで，指定したジョブIDのスプールデータにある格納ファイル名が出力されます。
  • getSpoolFileNameメソッドは，getSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，getSpoolFileNameメソッドを指定しても無視されます。

引数

なし

戻り値

スプールデータにあるEPF形式ファイル名


getSpoolFileNameMultiメソッド

getSpoolFileNameMultiメソッド

スプールデータにあるEPF形式ファイル名を配列で取得します。

形式

public String[] getSpoolFileNameMulti()

解説

  • getSpoolFileNameMultiメソッドは，getSpoolFileOutlineメソッドを呼び出すことで，検索条件に合ったスプールデータにあるEPF形式ファイル名が配列で出力されます。
  • getSpoolFileNameMultiメソッドは，getSpoolFileOutlineメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，getSpoolFileNameMultiメソッドを指定しても無視されます。

引数

なし

戻り値

スプールデータにあるEPF形式ファイル名の一覧を，文字列型の配列で返します。


getSpoolFileOutlineメソッド

getSpoolFileOutlineメソッド

指定条件に合ったEUR Server - Spool Serviceのスプールデータの一覧を取得します。取得されるスプールデータの一覧については，マニュアル「EUR 帳票出力 機能解説 EUR Server編」を参照してください。

形式

public void getSpoolFileOutline() throws EURPMLSException

解説

  • getSpoolFileOutlineメソッドは，スプールサーバ上の蓄積フォルダから検索条件に合ったスプールデータの一覧の取得が終了した時点で呼び出し元に制御が戻ります。
  • 次のメソッドのうちどれかが指定されていると，スプールデータの検索処理が高速になります。
    • setSearchCreateTimeEnd
    • setSearchCreateTimeStart
    • setSearchJobID
    • setSearchJobIDMulti
  • 実行時にエラーが発生した場合，getErrorCodeメソッドに終了コード，getMessageメソッドにメッセージが設定されます。

引数

なし

戻り値

なし

例外処理

EURPMLSException

エラー発生時は，EURPMLSException例外がスローされます。


getSpoolFileSizeメソッド

getSpoolFileSizeメソッド

指定したジョブIDのスプールデータにある格納ファイルのサイズ（バイト）を取得します。

形式

public int getSpoolFileSize()

解説

  • getSpoolFileSizeメソッドは，getSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，getSpoolFileSizeメソッドを指定しても無視されます。

引数

なし

戻り値

指定したジョブIDのスプールデータにある格納ファイルのサイズ（バイト）


getSpoolHistoryメソッド

getSpoolHistoryメソッド

スプールデータの履歴を取得します。

形式

public String[][] getSpoolHistory() throws EURPMLSException

解説

  • getSpoolFileAttributeメソッドを呼び出すことで，スプールデータの履歴が情報数分出力されます。出力されるスプールデータの履歴の形式を次に示します。
    [操作種別][操作日時][IPアドレス][操作対象][変更前][変更後][印刷実行結果]
    （出力例）
    [拠点印刷][20060314164300][255.255.xxx.xxx][][][][印刷済み]
    [変更][20060314181501][255.255.xxx.xxx][プリンタクラス][標準][A3][]
    [取得][20060314190506][255.255.xxx.xxx][][][][]
  • 蓄積直後の配列の要素数は0です。
  • getSpoolHistoryメソッドは，getSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，getSpoolHistoryメソッドを指定しても無視されます。

引数

なし

戻り値

スプールデータの履歴を，次に示す2次元配列の文字列で返します。

String[0]：操作種別の一覧が格納されているString配列
String[1]：操作日時の一覧が格納されているString配列
String[2]：IPアドレスの一覧が格納されているString配列
String[3]：操作対象の一覧が格納されているString配列
String[4]：変更前の一覧が格納されているString配列
String[5]：変更後の一覧が格納されているString配列
String[6]：印刷実行結果の一覧が格納されているString配列

各要素数は同一となります。


getSpoolLimitメソッド

getSpoolLimitメソッド

スプールデータの蓄積期限日を取得します。

形式

public String getSpoolLimit()

解説

  • getSpoolLimitメソッドは，getSpoolFileAttributeメソッドを呼び出すことで，スプールデータの蓄積期限日が出力されます。
  • 出力されるスプールデータの蓄積期限日の形式は「YYYYMMDD」です。
    「YYYYMMDD」形式の内容を次に示します。
    • YYYY：年（西暦）を4桁で示します。
    • MM：月（01～12）を2桁で示します。01～09は，ゼロ埋めします。
    • DD：日（01～31）を2桁で示します。01～09は，ゼロ埋めします。
    （出力例）20060523
  • getSpoolLimitメソッドは，getSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，getSpoolLimitメソッドを指定しても無視されます。

引数

なし

戻り値

スプールデータの蓄積期限日「YYYYMMDD」


getSpoolPathメソッド

getSpoolPathメソッド

常に""が出力されます。

形式

public String getSpoolPath()

解説

  • getSpoolPathメソッドは，getSpoolFileAttributeメソッドを呼び出しても，常に""が出力されます。
  • getSpoolPathメソッドは，getSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，getSpoolPathメソッドを指定しても無視されます。

引数

なし

戻り値

""


getSpoolPathMultiメソッド

getSpoolPathMultiメソッド

常に""が配列で出力されます。

形式

public String[] getSpoolPathMulti()

解説

  • getSpoolPathMultiメソッドは，getSpoolFileOutlineメソッドを呼び出しても，常に""が配列で出力されます。
  • getSpoolPathMultiメソッドは，getSpoolFileOutlineメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，getSpoolPathMultiメソッドを指定しても無視されます。

引数

なし

戻り値

""の配列


getTrayListメソッド

getTrayListメソッド

指定した帳票サーバのOS上のプリンタのトレイ一覧を取得します。

形式

public String[] getTrayList() throws EURPMLSException

解説

  • getTrayListメソッドは，OS上のプリンタのトレイ一覧が取得終了した時点で呼び出し元に制御が戻ります。
  • EUR Server - Spool ServiceがあるスプールサーバのIPアドレスは，setServerAddressメソッドで指定します。
  • 実行時にエラーが発生した場合，getErrorCodeメソッドに終了コード，getMessageメソッドにメッセージが設定されます。
  • UNIX／Linux環境の場合，トレイ一覧の取得はサポートしていません。UNIX／Linux環境のEUR Server - Spool Serviceに対して，トレイ一覧の取得を実行した場合はエラーとなります。

引数

なし

戻り値

プリンタのトレイ一覧を次に示す形式で返します。

OS上のプリンタのトレイ名1
OS上のプリンタのトレイ名2
          ：
OS上のプリンタのトレイ名n

例外処理

EURPMLSException

エラー発生時は，EURPMLSException例外がスローされます。


initializeメソッド

initializeメソッド

指定されたすべてのプロパティメソッドをクリアにして，初期状態に戻します。

形式

public void initialize ()

解説

  • initializeメソッドは，EUR Server - Spool Service Adapterのメソッドの初期化処理が終了した時点で呼び出し元に制御が戻ります。
  • 実行時にエラーが発生した場合，getErrorCodeメソッドに終了コード，getMessageメソッドにメッセージが設定されます。

引数

なし

戻り値

なし

例外処理

なし


memgetSpoolFileメソッド

memgetSpoolFileメソッド

指定したスプールデータのEPF形式ファイルをメモリに取得します。

形式

public ByteBuffer memgetSpoolFile() throws EURPMLSException

解説

  • 指定したジョブIDのスプールデータのEPF形式ファイルをメモリに取得します。
  • memgetSpoolFileメソッドは，スプールサーバ上のスプールデータ内の格納ファイルのデータをメモリに取得した時点で呼び出し元に制御が戻ります。

引数

なし

戻り値

スプールデータのEPF形式ファイルをバイナリデータで返します。

例外処理

EURPMLSException

エラー発生時は，EURPMLSException例外がスローされます。エラー種別が警告の場合，データはEURPMLSExceptionクラスのgetOutputDataメソッドで取得してください。


printSpoolReportメソッド

printSpoolReportメソッド

指定したジョブIDのスプールデータを印刷します。

形式

public void printSpoolReport() throws EURPMLSException

解説

printSpoolReportメソッドは，スプールサーバ上のプリンタスプールへの出力が終了した時点で呼び出し元に制御が戻ります。

実行時にエラーが発生した場合，getErrorCodeメソッドに終了コード，getMessageメソッドにメッセージが設定されます。

引数

なし

戻り値

なし

例外処理

EURPMLSException

エラー発生時は，EURPMLSException例外がスローされます。


setClientAddressメソッド

setClientAddressメソッド

蓄積クライアント印刷するときのクライアントPCのIPアドレスを指定します。

形式

public void setClientAddress(String ClientAddress) throws EURPMLSException

解説

  • 蓄積クライアント印刷するときのクライアントIPアドレスを「255.255.255.255」形式で指定します。長さは15バイトまでです。
  • setClientAddressメソッドは，setSpoolFileAttributeメソッドでスプールデータを操作する場合，およびprintSpoolReportメソッドで蓄積クライアント印刷する場合に指定が有効になります。それ以外のメソッドでは，setClientAddressメソッドを指定しても無視されます。
  • 蓄積クライアント印刷する場合にsetClientAddressメソッドの指定を省略したときは，デフォルト値（127.0.0.1）を仮定して印刷します。複数のスプールデータのEPF形式ファイルを統合して印刷するときは，最初に指定したスプールデータの属性情報でクライアントPCのIPアドレスを決定します。
    なお，setClientAddressメソッドとスプールデータの属性情報のどちらにもクライアントIPアドレスの設定がないときは，蓄積クライアント印刷実行時にエラーとなります。

引数

ClientAddress

蓄積クライアント印刷するときのクライアントIPアドレス

戻り値

なし

例外処理

引数にnullが指定された場合は，エラー（KEEY702-E）のEURPMLSException例外がスローされます。


setClientPrinterNameメソッド

setClientPrinterNameメソッド

蓄積クライアント印刷するときのOS上のプリンタ名を指定します。

形式

public void setClientPrinterName (String ClientPrinterName) throws EURPMLSException

解説

  • プリンタ名を指定するときは，次のことに注意してください。
    • プリンタ名は，80バイト以内で指定してください。
    • プリンタ名には「"」および「,」を含めないでください。
  • 蓄積クライアント印刷するときにsetClientPrinterNameメソッドの指定があると，setDispPrintDlgメソッドは強制的に「1（自動印刷）」になります。蓄積時に指定したクライアントPCのプリンタに出力されます。
  • setClientPrinterNameメソッドは，setSpoolFileAttributeメソッドでスプールデータを操作する場合，およびprintSpoolReportメソッドで蓄積クライアント印刷する場合に指定が有効になります。それ以外のメソッドでは，setClientPrinterNameメソッドを指定しても無視されます。
  • 蓄積クライアント印刷する場合にsetClientPrinterNameメソッドの指定を省略したときは，次の値が仮定されます。
    • ジョブIDを一つだけ指定しているとき
      指定したジョブIDのスプールデータの属性情報に設定されている値
    • ジョブIDを複数指定しているとき
      最初に指定したジョブIDのスプールデータの属性情報に設定されている値
  • 蓄積クライアント印刷する場合にsetClientPrinterNameメソッドに空文字を指定したときは，プリンタ名情報は未設定となります。

引数

ClientPrinterName

蓄積クライアント印刷するときのOS上のプリンタ名

戻り値

なし

例外処理

引数にnullが指定された場合は，エラー（KEEY702-E）のEURPMLSException例外がスローされます。


setClientTrayNameメソッド

setClientTrayNameメソッド

蓄積クライアント印刷するときのプリンタのトレイ名を指定します。

形式

public void setClientTrayName (String ClientTrayName) throws EURPMLSException

解説

  • トレイ名を指定するときは，次のことに注意してください。
    • トレイ名は，80バイト以内で指定してください。
    • トレイ名には「"」および「,」を含めないでください。
  • 蓄積クライアント印刷するときにsetClientPrinterNameメソッドの指定があると，setClientTrayNameメソッドで指定したトレイから給紙されます。
    setClientPrinterNameメソッドで指定したプリンタでsetClientTrayNameメソッドに指定したトレイ名が使用できないときは，setClientPrinterNameメソッドで指定したプリンタのデフォルトのトレイから給紙されます。
  • 蓄積クライアント印刷する場合にsetClientTrayNameメソッドの指定を省略したときは，次の値が仮定されます。
    • ジョブIDを一つだけ指定しているとき
      指定したジョブIDのスプールデータの属性情報に設定されている値
    • ジョブIDを複数指定しているとき
      最初に指定したジョブIDのスプールデータの属性情報に設定されている値
  • 蓄積クライアント印刷する場合にsetClientTrayNameメソッドに空文字を指定したときは，トレイ名情報は未設定となります。
  • setClientTrayNameメソッドは，setSpoolFileAttributeメソッドでスプールデータを操作する場合，およびprintSpoolReportメソッドで蓄積クライアント印刷する場合に指定が有効になります。それ以外のメソッドでは，setClientTrayNameメソッドを指定しても無視されます。

引数

ClientTrayName

蓄積クライアント印刷するときのプリンタのトレイ名

戻り値

なし

例外処理

引数にnullが指定された場合は，エラー（KEEY702-E）のEURPMLSException例外がスローされます。


setDeleteKindメソッド

setDeleteKindメソッド

スプールデータを削除するときの削除種別を指定します。

形式

public void setDeleteKind (int DeleteKind)

解説

  • スプールデータを削除するときの削除種別を，0，または1で指定します。0，または1以外の値を入力したときは，エラーになります。デフォルトは，「0（通常削除）」です。
    • 0：通常削除
      setSearchJobIDメソッド，またはsetSearchJobIDMultiメソッドで指定したジョブIDに該当するスプールデータを削除します。
    • 1：蓄積期限切れファイルの削除
      EUR Server - Spool Serviceのあるマシンで，蓄積期限が過ぎているスプールデータを削除します。
  • 蓄積期限切れファイルの削除は，EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）でOPTIONセクションのESFAUTODELキーに「1（自動削除します）」を設定しておくことで，次に示すタイミングで自動的に実行することもできます。
    • EUR Server - Spool Serviceのサービスを起動したとき
    • EUR Server - Spool Serviceが稼働するマシンの日付が変わったあと，EUR Server - Spool Serviceに対して最初の要求があったとき（日付変更の契機にローカルタイムと協定世界時（UTC）のどちらを使用するかを，環境設定ファイル（EURPMLS.ini）のOPTIONセクションのSTANDARDTIMEキーで設定できます）
  • setDeleteKindメソッドは，deleteSpoolFileメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，setDeleteKindメソッドを指定しても無視されます。

引数

DeleteKind

スプールデータを削除するときの削除種別

戻り値

なし


setDispPrintDlgメソッド

setDispPrintDlgメソッド

蓄積クライアント印刷するときのダイアログ表示モードを指定します。

形式

public void setDispPrintDlg (int DispPrintDlg)

解説

  • 指定できる値と蓄積クライアント印刷時の動作を次に示します。
    • 0：印刷先指定ダイアログを表示します（対話型印刷）。
      プレビューボタンを選択すると，プレビューウィンドウが表示されます。
    • 1：直接印刷を実行します（自動印刷）。
      印刷実行中に印刷中のダイアログが表示されます。
    • 2：プレビューウィンドウを表示します（対話型印刷プレビュー表示）。
      印刷メニューまたは印刷ボタンを選択すると，印刷先指定ダイアログが表示されます。
    • 3：直接印刷を実行します（全自動印刷）。
      印刷実行中に印刷中のダイアログは表示されません。
    • 4：プレビューウィンドウを表示します（対話型印刷プレビュー表示限定）。
      印刷は実行できません。
  • 蓄積クライアント印刷実行時，setClientPrinterNameメソッドに値が指定されている場合，かつsetDispPrintDlgメソッドに0または2を指定した場合は，setDispPrintDlgメソッドに1が仮定されます。
  • setSpoolFileAttributeメソッド実行時に，0～4以外の値が入力されていたときは，エラーになります。
  • setDispPrintDlgメソッドは，setSpoolFileAttributeメソッドでスプールデータを操作する場合，およびprintSpoolReportメソッドで蓄積クライアント印刷する場合に指定が有効になります。それ以外のメソッドでは，setDispPrintDlgメソッドを指定しても無視されます。

引数

DispPrintDlg

蓄積クライアント印刷するときのダイアログ表示モード

戻り値

なし


setEnableGetメソッド

setEnableGetメソッド

スプールデータに格納されているEPF形式ファイルの取得を許可するかどうかを指定します。

形式

public void setEnableGet (boolean EnableGet)

解説

  • スプールデータの取得許可情報を次に示します。
    • True：EPF形式ファイルの取得を許可します。
    • False：EPF形式ファイルの取得を許可しません。
  • setEnableGetメソッドは，setSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，setEnableGetメソッドを指定しても無視されます。

引数

EnableGet

スプールデータに格納されているEPF形式ファイルの取得許可情報

戻り値

なし


setExecutablePrintModeメソッド

setExecutablePrintModeメソッド

スプールデータの実行可能印刷方式を指定します。

形式

public void setExecutablePrintMode (int ExecutablePrintMode)

解説

  • スプールデータの実行可能印刷方式を次に示します。
    • 0：蓄積スプールサーバ印刷
    • 1：蓄積スプールサーバ印刷／蓄積クライアント印刷
    • 2：蓄積クライアント印刷
    setSpoolFileAttributeメソッド実行時に，0，1，または2以外の値が入力されていたときは，エラーになります。
  • setExecutablePrintModeメソッドは，setSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，setExecutablePrintModeメソッドを指定しても無視されます。

引数

ExecutablePrintMode

スプールデータの実行可能印刷方式

戻り値

なし


setGroupNameメソッド

setGroupNameメソッド

スプールデータの振り分けグループ名を指定します。

形式

public void setGroupName (String GroupName) throws EURPMLSException

解説

  • 振り分けグループ名を指定するときは，次のことに注意してください。
    • 振り分けグループ名は，80バイト以内で指定してください。
    • 文字列に「"」，および「,」を含めないでください。
  • setGroupNameメソッドは，setSpoolFileAttributeメソッドでスプールデータを操作する場合，およびprintSpoolReportメソッドで蓄積スプールサーバ印刷する場合でプリンタ指定方式に帳票名による自動振り分け（setPrinterSelectMode=2）を指定したときに指定が有効になります。それ以外のメソッドでは，setGroupNameメソッドを指定しても無視されます。
  • 蓄積スプールサーバ印刷でsetGroupNameメソッドの指定が有効な場合に，setGroupNameメソッドの指定を省略したときや空文字を指定したときは，デフォルトの振り分けグループで出力先を決定して印刷します。

引数

GroupName

スプールデータの振り分けグループ名

戻り値

なし

例外処理

引数にnullが指定された場合は，エラー（KEEY702-E）のEURPMLSException例外がスローされます。


setJobKeyCategoryメソッド

setJobKeyCategoryメソッド

スプールデータのジョブ検索キーの分類を指定します。

形式

public void setJobKeyCategory (String[] JobKeyCategory) throws EURPMLSException

解説

  • ジョブ検索キーを入力する場合は，1～10個の配列で指定してください。また，setJobKeyCategoryメソッドを指定する場合は，ジョブ検索キーの分類に対応する検索キーの値を必ずsetJobKeyDataメソッドに入力してください。このとき，配列の要素数は同じにしてください。配列の要素数が異なると，setSpoolFileAttributeメソッド実行時にエラーになります。また，ジョブ検索キーを入力しない場合は，setJobKeyCategoryメソッドとsetJobKeyDataメソッドのどちらも指定しないでください。どちらかの指定があると対応する情報がないため，setSpoolFileAttributeメソッド実行時にエラーになります。
  • ジョブ検索キーは，任意文字列を指定できます。指定するときは，次のことに注意してください。
    • 文字列は，80バイト以内で指定してください。
    • 文字列に「,」を含めないでください。
  • setJobKeyCategoryメソッドは，setSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，setJobKeyCategoryメソッドを指定しても無視されます。

引数

JobKeyCategory

ジョブ検索キーとする分類の配列

戻り値

なし

例外処理

引数にnullが指定された場合，または引数のString配列の要素値にnullが指定された場合は，エラー（KEEY702-E）のEURPMLSException例外がスローされます。


setJobKeyDataメソッド

setJobKeyDataメソッド

スプールデータのジョブ検索キーの値を指定します。

形式

public String setJobKeyData ( String[] JobKeyData) throws EURPMLSException

解説

  • ジョブ検索キーを入力する場合は，1～10個の配列で指定してください。また，setJobKeyCategoryメソッドを指定する場合は，検索キーの分類に対応する検索キーの値を必ずsetJobKeyDataメソッドに入力してください。このとき，配列の要素数は同じにしてください。配列の要素数が異なると，setSpoolFileAttributeメソッド実行時にエラーになります。また，検索キーを指定しない場合は，setJobKeyCategoryメソッドとsetJobKeyDataメソッドのどちらも指定しないでください。どちらかの指定があると対応する情報がないため，setSpoolFileAttributeメソッド実行時にエラーになります。
  • 値は，任意文字列を指定できます。指定するときは，次のことに注意してください。
    • 文字列は，80バイト以内で指定してください。
    • 文字列に「,」を含めないでください。
  • setJobKeyDataメソッドは，setSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，setJobKeyDataメソッドを指定しても無視されます。

引数

JobKeyData

ジョブ検索キーとする値の配列

戻り値

String

例外処理

引数にnullが指定された場合，または引数のString配列の要素値にnullが指定された場合は，エラー（KEEY702-E）のEURPMLSException例外がスローされます。


setMaxPrintCountメソッド

setMaxPrintCountメソッド

スプールデータの印刷上限回数を指定します。

形式

public void setMaxPrintCount (int MaxPrintCount)

解説

  • 印刷上限回数に指定できる値は，-1～65,536です。
    • 印刷回数の上限を無限にする場合は，-1を指定してください。
    • 印刷を禁止する場合は，0を指定してください。
    setSpoolFileAttributeメソッド実行時に，-1，0，または1～65,536以外の値が入力されていたときは，エラーになります。
  • setMaxPrintCountメソッドは，setSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，setMaxPrintCountメソッドを指定しても無視されます。

引数

MaxPrintCount

スプールデータの印刷上限回数

戻り値

なし


setOutputFileNameメソッド

setOutputFileNameメソッド

スプールデータから取得した，EPF形式ファイル名を指定します。

形式

public void setOutputFileName (String OutputFileName) throws EURPMLSException

解説

  • EPF形式ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • setOutputFileNameメソッドを省略した場合，ファイル名は次のようになります。
    • ジョブIDを一つだけ指定しているとき
      指定したジョブIDのスプールデータに格納されているEPF形式ファイルのファイル名
    • ジョブIDを複数指定しているとき
      最初に指定したジョブIDのスプールデータに格納されているEPF形式ファイルのファイル名
  • setOutputFileNameメソッドは，getSpoolFileメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，setOutputFileNameメソッドを指定しても無視されます。

引数

OutputFileName

スプールデータから取得したEPF形式ファイル名

戻り値

なし

例外処理

引数にnullが指定された場合は，エラー（KEEY702-E）のEURPMLSException例外がスローされます。


setOutputFilePathメソッド

setOutputFilePathメソッド

スプールデータからEPF形式ファイルを取得するとき，取得するフォルダのパスを指定します。

形式

public void setOutputFilePath (String OutputFilePath) throws EURPMLSException

解説

  • EUR Server - Spool Service Adapterの環境設定ファイル（EURPMLSADP.ini）で，PATHセクションにOUTPUTFILEキーを指定することで，デフォルトのスプールデータ取得フォルダを指定することもできます。
  • getSpoolFileメソッドを実行した場合，setOutputFilePathメソッド，または環境設定ファイルのどちらも指定されていないときは，エラーになります。
  • フォルダのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。
  • setOutputFilePathメソッドは，getSpoolFileメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，setOutputFilePathメソッドを指定しても無視されます。

引数

OutputFilePath

スプールデータを取得するフォルダのパス

戻り値

なし

例外処理

引数にnullが指定された場合は，エラー（KEEY702-E）のEURPMLSException例外がスローされます。


setPaperOrientationメソッド

setPaperOrientationメソッド

用紙の向きを指定します。

形式

public void setPaperOrientation (int PaperOrientation)

解説

指定できる値を次に示します。

  • 0：EPF形式ファイルを蓄積したときのページごとの属性に従います。
  • 1：用紙の向きを縦にして出力します。
  • 2：用紙の向きを横にして出力します。

setPaperOrientationメソッドを省略した場合，次のように動作します。

  • ジョブIDを一つだけ指定しているとき
    指定したジョブIDのスプールデータに格納されているEPF形式ファイルの属性情報に従います。
  • ジョブIDを複数指定しているとき
    EPF形式ファイルを蓄積したときのページごとの属性に従います。

setPaperOrientationメソッドは，getSpoolFileメソッド，およびmemgetSpoolFileメソッドでスプールデータを操作する場合，ならびにprintSpoolReportメソッドで印刷する場合に指定が有効になります。それ以外のメソッドでは，setPaperOrientationメソッドを指定しても無視されます。

引数

PaperOrientation

用紙の向き

戻り値

なし


setPrintCopiesメソッド

setPrintCopiesメソッド

印刷部数を指定します。

形式

public void setPrintCopies(int PrintCopies)

解説

指定できる値は，1～99です。setPrintCopiesメソッドを省略した場合，次の値が仮定されます。

  • ジョブIDを一つだけ指定しているとき
    指定したジョブIDのスプールデータに格納されているEPF形式ファイルの属性情報に設定されている値
  • ジョブIDを複数指定しているとき
    1

setPrintCopiesメソッドは，getSpoolFileメソッド，およびmemgetSpoolFileメソッドでスプールデータを操作する場合，ならびにprintSpoolReportメソッドで印刷する場合に指定が有効になります。それ以外のメソッドでは，setPrintCopiesメソッドを指定しても無視されます。

引数

PrintCopies

印刷部数

戻り値

なし


setPrintEndPageメソッド

setPrintEndPageメソッド

蓄積スプールサーバ印刷するときの終了ページを指定します。

形式

public void setPrintEndPage (int PrintEndPage)

解説

  • setPrintEndPageメソッドは，蓄積印刷方式が蓄積スプールサーバ印刷（setPrintMode=0）のとき，有効になります。蓄積クライアント印刷（setPrintMode=1）のときは，setPrintEndPageメソッドを指定しても無視されます。
  • 指定できる値は，1～999,999です。setPrintEndPageメソッドを省略した場合は，最終ページまで印刷されます。また，スプールデータに格納されているEPF形式ファイルの最終ページ数よりsetPrintEndPageメソッドに指定した値が大きい場合も，最終ページまで印刷されます。
  • setPrintEndPageメソッドは，printSpoolReportメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，setPrintEndPageメソッドを指定しても無視されます。

引数

PrintEndPage

蓄積スプールサーバ印刷するときの終了ページ

戻り値

なし


setPrinterClassNameメソッド

setPrinterClassNameメソッド

スプールデータのプリンタクラス名を指定します。

形式

public void setPrinterClassName (String PrinterClassName) throws EURPMLSException

解説

  • 蓄積スプールサーバ印刷する場合にプリンタ指定方式でプリンタクラス名指定（setPrinterSelectMode=0）を指定したとき，および蓄積クライアント印刷する場合にsetClientPrinterNameメソッドの指定がないときに，setPrinterClassNameメソッドで指定したプリンタクラスを出力先にします。setSpoolFileAttributeメソッドの呼び出しでプリンタクラス名を変更しても無視されます。
  • プリンタクラス名は，任意の文字列を指定できます。指定するときは，次のことに注意してください。
    • プリンタクラス名は，80バイト以内で指定してください。
    • プリンタクラス名に「"」および「,」を含めないでください。
  • setPrinterClassNameメソッドは，setSpoolFileAttributeメソッド，getSpoolFileメソッド，およびmemgetSpoolFileメソッドでスプールデータを操作する場合，ならびにprintSpoolReportメソッドで印刷する場合に指定が有効になります。それ以外のメソッドでは，setPrinterClassNameメソッドを指定しても無視されます。
  • 蓄積スプールサーバ印刷でプリンタ指定方式がプリンタクラス名指定（setPrinterSelectMode=0）の場合に，setPrinterClassNameメソッドの指定を省略したときや空文字を指定したときは，デフォルトのプリンタクラスで印刷します。
  • 蓄積クライアント印刷する場合，およびスプールデータを取得する場合にsetPrinterClassNameメソッドに空文字を指定したときは，プリンタクラス情報は未設定となります。
  • 蓄積クライアント印刷する場合，およびスプールデータを取得する場合にsetPrinterClassNameメソッドの指定を省略したときは，次のようになります。
    • ジョブIDを一つだけ指定しているとき
      指定したジョブIDのスプールデータの属性情報に設定されている値が仮定されます。
    • ジョブIDを複数指定しているとき
      プリンタクラス情報は未設定となります。

引数

PrinterClassName

スプールデータのプリンタクラス名

戻り値

なし

例外処理

引数にnullが指定された場合は，エラー（KEEY702-E）のEURPMLSException例外がスローされます。


setPrinterSelectModeメソッド

setPrinterSelectModeメソッド

蓄積スプールサーバ印刷するときのプリンタ指定方式を指定します。

形式

public void setPrinterSelectMode (int PrinterSelectMode)

解説

  • printSpoolReportメソッド実行時にsetPrinterSelectModeメソッドを指定する場合，帳票の出力先は次のプロパティの指定値によって決定します。
    • setPrinterClassNameメソッド
    • setServerPrinterNameメソッド
    • setServerTrayNameメソッド
    • setGroupNameメソッド
    どのメソッドが有効になるかは，setPrinterSelectModeメソッドの指定値によって異なります。また，指定を省略した場合は，そのメソッドの情報は未設定として扱われます。
  • printSpoolReportメソッド実行時にsetPrinterSelectModeメソッドの指定を省略する場合は，次の値が仮定されます。
    • ジョブIDを一つだけ指定しているとき
      指定したジョブIDのスプールデータの属性情報に設定されている値
    • ジョブIDを複数指定しているとき
      最初に指定したジョブIDのスプールデータの属性情報に設定されている値
  • 蓄積スプールサーバ印刷するときのプリンタ指定方式を次に示します。
    • 0：プリンタクラス名指定
    • 1：OS上のプリンタ名指定
    • 2：帳票名による自動振り分け
    setSpoolFileAttributeメソッド実行時に，0，1，または2以外の値が入力されていたときは，エラーになります。
  • setPrinterSelectModeメソッドは，setSpoolFileAttributeメソッドでスプールデータを操作する場合，およびprintSpoolReportメソッドで蓄積スプールサーバ印刷する場合に指定が有効になります。それ以外のメソッドでは，setPrinterSelectModeメソッドを指定しても無視されます。

引数

PrinterSelectMode

蓄積スプールサーバ印刷するときのプリンタ指定方式

戻り値

なし


setPrintModeメソッド

setPrintModeメソッド

蓄積したデータの印刷方式を指定します。

形式

public void setPrintMode (int PrintMode)

解説

  • 蓄積したデータの印刷方式を次に示します。setPrintModeメソッドを省略した場合は，0が仮定されます。
    • 0：蓄積スプールサーバ印刷
    • 1：蓄積クライアント印刷
    printSpoolReportメソッド実行時に，0，または1以外の値が入力されていたときは，エラーになります。
  • setPrintModeメソッドは，printSpoolReportメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，setPrintModeメソッドを指定しても無視されます。

引数

PrintMode

蓄積したデータの印刷方式

戻り値

なし


setPrintStartPageメソッド

setPrintStartPageメソッド

蓄積スプールサーバ印刷するときの開始ページを指定します。

形式

public void setPrintStartPage (int PrintStartPage)

解説

  • setPrintStartPageメソッドは，蓄積印刷方式が蓄積スプールサーバ印刷（setPrintMode=0）のとき，有効になります。蓄積クライアント印刷（setPrintMode=1）のときは，setPrintStartPageメソッドを指定しても無視されます。
  • 指定できる値は，1～999,999です。setPrintStartPageメソッドを省略した場合は，1ページから印刷されます。
  • setPrintStartPageメソッドに指定した値がスプールデータに格納されているEPF形式ファイルの最終ページ数より大きい場合は，EPF形式ファイルの最終ページだけ印刷されます。
  • setPrintStartPageメソッドは，printSpoolReportメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，setPrintStartPageメソッドを指定しても無視されます。

引数

PrintStartPage

蓄積スプールサーバ印刷するときの開始ページ

戻り値

なし


setSearchCreateTimeEndメソッド

setSearchCreateTimeEndメソッド

スプールデータを作成日時で検索するときに，検索終了日時を指定します。

setSearchCreateTimeEndメソッドを指定すると，メソッド実行速度が速くなることがあります。

形式

public void setSearchCreateTimeEnd (String SearchCreateTimeEnd) throws EURPMLSException

解説

  • 蓄積フォルダのファイル一覧を取得する場合，検索条件としてファイル作成日時を使用するときに，検索終了日時を「YYYYMMDDhhmmss」形式で入力します。指定できる文字列は，14バイトまでです。
    「YYYYMMDDhhmmss」形式の内容を次に示します。
    • YYYY：年（西暦）を4桁で示します。
    • MM：月（01～12）を2桁で示します。01～09は，ゼロ埋めします。
    • DD：日（01～31）を2桁で示します。01～09は，ゼロ埋めします。
    • hh：時（00～23）を2桁で示します。00～09は，ゼロ埋めします。
    • mm：分（00～59）を2桁で示します。00～09は，ゼロ埋めします。
    • ss：秒（00～59）を2桁で示します。00～09は，ゼロ埋めします。
    （指定例）
    2006年11月8日15:1:40　→　20061108150140
  • setSearchCreateTimeEndメソッドは，getSpoolFileOutlineメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，setSearchCreateTimeEndメソッドを指定しても無視されます。

引数

SearchCreateTimeEnd

ファイル作成日時でスプールデータを検索するときの検索終了日時

戻り値

なし

例外処理

引数にnullが指定された場合は，エラー（KEEY702-E）のEURPMLSException例外がスローされます。


setSearchCreateTimeStartメソッド

setSearchCreateTimeStartメソッド

スプールデータを作成日時で検索するときに，検索開始日時を指定します。

setSearchCreateTimeStartメソッドを指定すると，メソッド実行速度が速くなることがあります。

形式

public void setSearchCreateTimeStart (String SearchCreateTimeStart) throws EURPMLSException

解説

  • 蓄積フォルダのファイル一覧を取得する場合，検索条件としてファイル作成日時を使用するときに，検索開始日時を「YYYYMMDDhhmmss」形式で入力します。指定できる文字列は，14バイトまでです。
    「YYYYMMDDhhmmss」形式の内容を次に示します。
    • YYYY：年（西暦）を4桁で示します。
    • MM：月（01～12）を2桁で示します。01～09は，ゼロ埋めします。
    • DD：日（01～31）を2桁で示します。01～09は，ゼロ埋めします。
    • hh：時（00～23）を2桁で示します。00～09は，ゼロ埋めします。
    • mm：分（00～59）を2桁で示します。00～09は，ゼロ埋めします。
    • ss：秒（00～59）を2桁で示します。00～09は，ゼロ埋めします。
    （指定例）
    2006年5月23日9:56:30　→　20060523095630
  • setSearchCreateTimeStartメソッドは，getSpoolFileOutlineメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，setSearchCreateTimeStartメソッドを指定しても無視されます。

引数

SearchCreateTimeStart

ファイル作成日時でスプールデータを検索するときの検索開始日時

戻り値

なし

例外処理

引数にnullが指定された場合は，エラー（KEEY702-E）のEURPMLSException例外がスローされます。


setSearchJobIDメソッド

setSearchJobIDメソッド

スプールデータを検索するジョブIDを指定します。

形式

public void setSearchJobID (String SearchJobID) throws EURPMLSException

解説

  • ジョブIDに指定できる文字列は，36バイトまでです。
  • getSpoolFileAttributeメソッド，およびsetSpoolFileAttributeメソッドを呼び出す場合に使用するときは，必ずsetSearchJobIDメソッドを指定してください。
  • getSpoolFileOutlineメソッドを呼び出す場合に使用するときは，setSearchJobIDメソッドの指定は任意です。
  • getSpoolFileメソッド，memgetSpoolFileメソッド，およびprintSpoolReportメソッドを呼び出す場合に使用するときは，setSearchJobIDメソッドまたはsetSearchJobIDMultiメソッドのどちらかを必ず指定してください。
  • deleteSpoolFileメソッドを呼び出す場合に使用するときは，setDeleteKindメソッドの指定によって次のように異なります。
    • 指定したジョブIDのスプールデータの削除（setDeleteKind=0）のときは，setSearchJobIDメソッドまたはsetSearchJobIDMultiメソッドのどちらかを必ず指定してください。
    • 蓄積期限切れファイルの削除（setDeleteKind=1）のときは，指定する必要はありません。
  • setSearchJobIDメソッドとsetSearchJobIDMultiメソッドの両方を指定したときは，setSearchJobIDMultiメソッドの指定が優先されます。
  • setSearchJobIDメソッドは，getSpoolFileOutlineメソッド，getSpoolFileAttributeメソッド，setSpoolFileAttributeメソッド，printSpoolReportメソッド，getSpoolFileメソッド，memgetSpoolFileメソッド，およびdeleteSpoolFileメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，setSearchJobIDメソッドを指定しても無視されます。

引数

SearchJobID

スプールデータを検索するときのジョブID

戻り値

なし

例外処理

引数にnullが指定された場合は，エラー（KEEY702-E）のEURPMLSException例外がスローされます。


setSearchJobIDMultiメソッド

setSearchJobIDMultiメソッド

スプールデータを検索するジョブIDを配列で指定します。配列の要素順に検索されます。

形式

public void setSearchJobIDMulti(String[] multiJobID) throws EURPMLSException

解説

  • ジョブIDに指定できる文字列は，36バイトまでです。
  • getSpoolFileAttributeメソッド，およびsetSpoolFileAttributeメソッドを呼び出す場合に使用するときは，setSearchJobIDMultiメソッドではなく，setSearchJobIDメソッドを指定してください。
  • getSpoolFileOutlineメソッドを呼び出す場合に使用するときは，setSearchJobIDMultiメソッドの指定は任意です。
  • getSpoolFileメソッド，memgetSpoolFileメソッド，およびprintSpoolReportメソッドを呼び出す場合に使用するときは，setSearchJobIDメソッドまたはsetSearchJobIDMultiメソッドのどちらかを必ず指定してください。
  • deleteSpoolFileメソッドを呼び出す場合に使用するときは，setDeleteKindメソッドの指定によって次のように異なります。
    • 指定したジョブIDのスプールデータの削除（setDeleteKind=0）のときは，setSearchJobIDメソッドまたはsetSearchJobIDMultiメソッドのどちらかを必ず指定してください。
    • 蓄積期限切れファイルの削除（setDeleteKind=1）のときは，指定する必要はありません。
  • setSearchJobIDメソッドとsetSearchJobIDMultiメソッドの両方を指定したときは，setSearchJobIDMultiメソッドの指定が優先されます。
  • setSearchJobIDMultiメソッドは，getSpoolFileOutlineメソッド，printSpoolReportメソッド，getSpoolFileメソッド，memgetSpoolFileメソッド，およびdeleteSpoolFileメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，setSearchJobIDMultiメソッドを指定しても無視されます。

引数

multiJobID

スプールデータを検索するときのジョブIDの配列

戻り値

なし

例外処理

引数にnullが指定された場合，または引数のString配列の要素値にnullが指定された場合は，エラー（KEEY702-E）のEURPMLSException例外がスローされます。


setSearchJobKeyCategoryメソッド

setSearchJobKeyCategoryメソッド

スプールデータをジョブ検索キーで検索するときに，ジョブ検索キーの分類を指定します。

形式

public void setSearchJobKeyCategory (String[] SearchJobKeyCategory) throws EURPMLSException

解説

  • 蓄積フォルダのファイル一覧を取得する場合，検索条件としてsetSearchJobKeyCategoryメソッドで指定したジョブ検索キーの分類と，setSearchJobKeyDataメソッドで指定したジョブ検索キーの配列値の順番が一致するものを検索します。
  • ジョブ検索キーを指定する場合は，1～10個の配列で指定してください。また，setSearchJobKeyCategoryメソッドを指定する場合は，ジョブ検索キーの分類に対応する検索キーの値を必ずsetSearchJobKeyDataメソッドに指定してください。このとき，配列の要素数は同じにしてください。配列の要素数が異なると，エラーになります。
    ジョブ検索キーを指定しない場合，setSearchJobKeyCategoryメソッドとsetSearchJobKeyDataメソッドは，どちらも指定しないでください。どちらかの指定があると対応する情報がないため，エラーになります。
  • 分類は，任意文字列を指定できます。指定するときは，次のことに注意してください。
    • 文字列は，80バイト以内で指定してください。
    • 文字列に「,」を含めないでください。
    • 空文字列「""」は指定しないでください。
  • setSearchJobKeyCategoryメソッドは，getSpoolFileOutlineメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，setSearchJobKeyCategoryメソッドを指定しても無視されます。

引数

SearchJobKeyCategory

ジョブ検索キーの分類の配列

戻り値

なし

例外処理

引数にnullが指定された場合，または引数のString配列の要素値にnullが指定された場合は，エラー（KEEY702-E）のEURPMLSException例外がスローされます。


setSearchJobKeyDataメソッド

setSearchJobKeyDataメソッド

スプールデータをジョブ検索キーで検索するときに，ジョブ検索キーの値を指定します。

形式

public void setSearchJobKeyData (String[] SearchJobKeyData) throws EURPMLSException

解説

  • 蓄積フォルダのファイル一覧を取得する場合，検索条件としてsetSearchJobKeyCategoryメソッドで指定したジョブ検索キーの分類と，setSearchJobKeyDataメソッドで指定したジョブ検索キーの配列値の順番が一致するものを検索します。
  • ジョブ検索キーを指定する場合は，1～10個の配列で指定してください。また，setSearchJobKeyCategoryメソッドを指定する場合は，ジョブ検索キーの分類に対応する検索キーの値を必ずsetSearchJobKeyDataメソッドに指定してください。このとき，配列の要素数は同じにしてください。配列の要素数が異なると，エラーになります。
    ジョブ検索キーを指定しない場合，setSearchJobKeyCategoryメソッドとsetSearchJobKeyDataメソッドは，どちらも指定しないでください。どちらかの指定があると対応する情報がないため，エラーになります。
  • ジョブ検索キーの値は，任意文字列を指定できます。指定するときは，次のことに注意してください。
    • 文字列は，80バイト以内で指定してください。
    • 文字列に「,」を含めないでください。
  • setSearchJobKeyDataメソッドは，getSpoolFileOutlineメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，setSearchJobKeyDataメソッドを指定しても無視されます。

引数

SearchJobKeyData

ジョブ検索キーの値の配列

戻り値

なし

例外処理

引数にnullが指定された場合，または引数のString配列の要素値にnullが指定された場合は，エラー（KEEY702-E）のEURPMLSException例外がスローされます。


setSearchPrinterClassNameメソッド

setSearchPrinterClassNameメソッド

スプールデータをプリンタクラス名で検索するときに，プリンタクラス名を指定します。

形式

public void setSearchPrinterClassName (String SearchPrinterClassName) throws EURPMLSException

解説

  • プリンタクラス名は，任意の文字列を指定できます。指定するときは，次のことに注意してください。
    • プリンタクラス名は，80バイト以内で指定してください。
    • プリンタクラス名に「"」および「,」を含めないでください。
  • setSearchPrinterClassNameメソッドは，getSpoolFileOutlineメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，setSearchPrinterClassNameメソッドを指定しても無視されます。

引数

SearchPrinterClassName

プリンタクラス名で蓄積フォルダのファイル一覧を検索するときのプリンタクラス名

戻り値

なし

例外処理

引数にnullが指定された場合は，エラー（KEEY702-E）のEURPMLSException例外がスローされます。


setSearchReportAddressKeyCategoryメソッド

setSearchReportAddressKeyCategoryメソッド

スプールデータを宛先キーで検索するときに，宛先キーの分類を指定します。

形式

public void setReportAddressKeyCategory (String newKeyCategory) throws EURPMLSException

解説

  • 宛先キーの分類は，任意の文字列を指定できます。次のことに注意して指定してください。
    • 文字列は，1～80バイトで指定してください。
    • 文字列に，「"」，「,」および制御コード（0x00～0x1F，0x7F～0x9F）を含めないでください。
  • 蓄積フォルダのファイル一覧を取得する場合，setSearchReportAddressKeyCategoryメソッドで指定した宛先キーの分類と，setSearchReportAddressKeyDataメソッドで指定した宛先キーの値が一致するものを検索します。
  • setSearchReportAddressKeyDataメソッドが指定されていない場合，エラーになります。

引数

String

戻り値

なし


setSearchReportAddressKeyDataメソッド

setSearchReportAddressKeyDataメソッド

スプールデータを宛先キーで検索するときに，宛先キーの値を指定します。

形式

public void setReportAddressKeyData (String newKeyCategory) throws EURPMLSException

解説

  • 宛先キーの値は，任意の文字列を指定できます。次のことに注意して指定してください。
    • 文字列は，1～80バイトで指定してください。
    • 文字列に，「"」，「,」および制御コード（0x00～0x1F，0x7F～0x9F）を含めないでください。
  • 蓄積フォルダのファイル一覧を取得する場合，setSearchReportAddressKeyCategoryメソッドで指定した宛先キーの分類と，setSearchReportAddressKeyDataメソッドで指定した宛先キーの値が一致するものを検索します。
  • setSearchReportAddressKeyCategoryメソッドが指定されていない場合エラーになります。

引数

String

戻り値

なし


setSearchSpoolFileNameメソッド

setSearchSpoolFileNameメソッド

スプールデータをスプールデータに格納されているEPF形式ファイル名で検索するときに，EPF形式ファイル名を指定します。

形式

public void setSearchSpoolFileName (String SearchSpoolFileName) throws EURPMLSException

解説

  • 格納ファイル名は，255バイト以内になるように指定してください。
  • setSearchSpoolFileNameメソッドは，getSpoolFileOutlineメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，setSearchSpoolFileNameメソッドを指定しても無視されます。

引数

SearchSpoolFileName

格納ファイル名で蓄積フォルダのファイル一覧を検索するときの格納ファイル名

戻り値

なし

例外処理

引数にnullが指定された場合は，エラー（KEEY702-E）のEURPMLSException例外がスローされます。


setServerAddressメソッド

setServerAddressメソッド

スプールサーバのIPアドレスを指定します。

形式

public void setServerAddress(String ServerAddress) throws EURPMLSException

解説

  • スプールサーバのIPアドレスを「255.255.255.255」形式で指定します。指定できる文字列は，15バイトまでです。
  • setServerAddressメソッドの指定がない場合は，EUR Server - Spool Service Adapterの環境設定ファイル（EURPMLSADP.ini）のIPADDRESSセクションのEURPMLSキーに設定されているEUR Server - Spool Serviceが稼働するサーバのIPアドレスが仮定されます。EURPMLSキーが省略されているとき，または値が指定されていないときは，デフォルト値（127.0.0.1）が仮定されます。
  • setServerAddressメソッドは，次に示すメソッドで操作する場合，指定が有効になります。それ以外のメソッドでは，setServerAddressメソッドを指定しても無視されます。
    • getSpoolFileOutlineメソッド，getSpoolFileAttributeメソッド，setSpoolFileAttributeメソッド，printSpoolReportメソッド，getSpoolFileメソッド，deleteSpoolFileメソッドでスプールデータを操作するとき
    • getPrinterClassListメソッドでプリンタクラス一覧を取得するとき
    • getPrinterListメソッドでプリンタ一覧を取得するとき
    • getTrayListメソッドでトレイ一覧を取得するとき

引数

ServerAddress

スプールサーバのIPアドレス

戻り値

なし

例外処理

引数にnullが指定された場合は，エラー（KEEY702-E）のEURPMLSException例外がスローされます。


setServerPrinterNameメソッド

setServerPrinterNameメソッド

スプールサーバでのOS上のプリンタ名を指定します。

形式

public void setServerPrinterName (String ServerPrinterName) throws EURPMLSException

解説

  • getTrayListメソッドを呼び出す場合に使用するときは，必ずsetServerPrinterNameメソッドを指定してください。
  • setSpoolFileAttributeメソッド，およびprintSpoolReportメソッドを呼び出す場合に使用するときは，setServerPrinterNameメソッドの指定は任意です。
  • プリンタ名を指定するときは，次のことに注意してください。
    • プリンタ名は，80バイト以内で指定してください。
    • プリンタ名に「"」および「,」を含めないでください。
  • setServerPrinterNameメソッドは，setSpoolFileAttributeメソッドでスプールデータを操作する場合，printSpoolReportメソッドで蓄積スプールサーバ印刷する場合でプリンタ指定方式にOS上のプリンタ名指定（setPrinterSelectMode=1）を指定したとき，およびgetTrayListメソッドでトレイ一覧を取得する場合に指定が有効になります。それ以外のメソッドでは，setServerPrinterNameメソッドを指定しても無視されます。
  • 蓄積スプールサーバ印刷でsetServerPrinterNameメソッドの指定が有効な場合に，setServerPrinterNameメソッドの指定を省略したときや空文字を指定したときは，デフォルトのプリンタで印刷します。

引数

ServerPrinterName

スプールサーバでのOS上のプリンタ名

戻り値

なし

例外処理

引数にnullが指定された場合は，エラー（KEEY702-E）のEURPMLSException例外がスローされます。


setServerTrayNameメソッド

setServerTrayNameメソッド

スプールサーバでのOS上のプリンタのトレイ名を指定します。

形式

public void setServerTrayName (String ServerTrayName) throws EURPMLSException

解説

  • トレイ名を入力するときは，次のことに注意してください。
    • トレイ名は，80バイト以内で指定してください。
    • トレイ名には「"」および「,」を含めないでください。
  • setServerTrayNameメソッドは，setSpoolFileAttributeメソッドでスプールデータを操作する場合，およびprintSpoolReportメソッドで蓄積スプールサーバ印刷する場合でプリンタ指定方式にOS上のプリンタ名指定（setPrinterSelectMode=1）を指定したときに指定が有効になります。それ以外のメソッドでは，setServerTrayNameメソッドを指定しても無視されます。
  • 蓄積スプールサーバ印刷でsetServerTrayNameメソッドの指定が有効な場合に，setServerTrayNameメソッドの指定を省略したときや空文字を指定したときは，デフォルトのトレイから給紙されます。

引数

ServerTrayName

スプールサーバでのOS上のプリンタのトレイ名

戻り値

なし

例外処理

引数にnullが指定された場合は，エラー（KEEY702-E）のEURPMLSException例外がスローされます。


setSortPrintメソッド

setSortPrintメソッド

印刷部数の単位を指定します。

形式

public void setSortPrint(int SortPrint)

解説

指定できる値を次に示します。

  • 0：部単位で出力します。
  • 1：ページ単位で出力します。

setSortPrintメソッドを省略した場合，次の値が仮定されます。

  • ジョブIDを一つだけ指定しているとき
    指定したジョブIDのスプールデータに格納されているEPF形式ファイルの属性情報に設定されている値
  • ジョブIDを複数指定しているとき
    0

setSortPrintメソッドは，getSpoolFileメソッド，およびmemgetSpoolFileメソッドでスプールデータを操作する場合，ならびにprintSpoolReportメソッドで蓄積スプールサーバ印刷する場合に指定が有効になります。それ以外の場合は，setSortPrintメソッドを指定しても無視されます。

引数

SortPrint

印刷部数の単位

戻り値

なし


setSpoolFileAttributeメソッド

setSpoolFileAttributeメソッド

指定したジョブIDのスプールデータの属性情報を変更します。変更できるスプールデータの属性情報については，マニュアル「EUR 帳票出力 機能解説 EUR Server編」を参照してください。

形式

public void setSpoolFileAttribute() throws EURPMLSException

解説

  • setSpoolFileAttributeメソッドは，スプールサーバにあるスプールデータの属性情報の変更が終了した時点で呼び出し元に制御が戻ります。
  • setSpoolFileAttributeメソッドは，指定できるプロパティメソッドのうち，指定のあったプロパティメソッドだけを変更します。setSpoolFileAttributeメソッドで指定できるプロパティメソッドについては，「9.2.2　メソッド一覧」を参照してください。また，指定できるプロパティメソッドは，一つ以上指定してください。指定されていない場合は，エラー（KEEY528-E）になります。
  • 実行時にエラーが発生した場合，getErrorCodeメソッドに終了コード，getMessageメソッドにメッセージが設定されます。

引数

なし

戻り値

なし

例外処理

EURPMLSException

エラー発生時は，EURPMLSException例外がスローされます。


setSpoolLimitメソッド

setSpoolLimitメソッド

スプールデータの蓄積期限日を指定します。

形式

public void setSpoolLimit (String SpoolLimit) throws EURPMLSException

解説

  • スプールデータの蓄積期限日は「YYYYMMDD」形式で入力します。指定できる文字列は，8バイトまでです。
    「YYYYMMDD」形式の内容を次に示します。
    • YYYY：年（西暦）を4桁で示します。
    • MM：月（01～12）を2桁で示します。01～09は，ゼロ埋めします。
    • DD：日（01～31）を2桁で示します。01～09は，ゼロ埋めします。
    （指定例）
    2006年5月23日　→　20060523
  • setSpoolLimitメソッドは，setSpoolFileAttributeメソッドでスプールデータを操作する場合，指定が有効になります。それ以外のメソッドでは，setSpoolLimitメソッドを指定しても無視されます。

引数

SpoolLimit

スプールデータの蓄積期限日

戻り値

なし

例外処理

引数にnullが指定された場合は，エラー（KEEY702-E）のEURPMLSException例外がスローされます。


setSpoolTitleメソッド

setSpoolTitleメソッド

スプールタイトルを指定します。

形式

public void setSpoolTitle (String SpoolTitle) throws EURPMLSException

解説

  • スプールタイトルには，任意文字列を指定できます。次のことに注意して指定してください。
    • スプールタイトルは，255バイト以内で指定してください。
    • スプールタイトルには「"」および「,」を含めないでください。
    • 空文字を指定したときは，スプールタイトル情報は未設定となります。
  • setSpoolTitleメソッドは，getSpoolFileメソッド，およびmemgetSpoolFileメソッドでスプールデータを操作する場合，ならびにprintSpoolReportメソッドで印刷する場合に指定が有効になります。それ以外のメソッドでは，setSpoolTitleメソッドを指定しても無視されます。
  • setSpoolTitleメソッドの指定を省略した場合は，次のようになります。
    • ジョブIDを一つだけ指定しているとき
      指定したジョブIDのスプールデータに格納されているEPF形式ファイルの属性情報が設定されます。
    • ジョブIDを複数指定しているとき
      スプールタイトル情報は未設定となります。

引数

SpoolTitle

スプールタイトル

戻り値

なし


EURPMLSExceptionクラスのメソッド仕様

9.5　EURPMLSExceptionクラスのメソッド仕様

EURPMLSExceptionクラスで使用できるメソッドの詳細を説明します。

＜この節の構成＞
getErrorCodeメソッド
getErrorLevelメソッド
getKeyメソッド
getMessageメソッド
getOutputDataメソッド


getKeyメソッド

getKeyメソッド

エラーメッセージのキー文字列を取得します。

形式

public String getKey()

引数

なし

戻り値

エラーメッセージのキー文字列を返します。


getOutputDataメソッド

getOutputDataメソッド

例外発生時にエラー種別が警告の場合，次のEPF形式ファイルを取得します。

  • memgetSpoolFileメソッド呼び出し時：スプールデータのEPF形式ファイル

形式

public ByteBuffer getOutputData ()

引数

なし

戻り値

エラー種別が警告の場合だけ，EPF形式ファイルをバイナリデータで返します。

エラー種別がエラーまたはシステムエラーの場合は，空データを返します。


例外情報

9.6　例外情報

SS-Java起動部品を使用して実行している場合にエラーが発生したときは，例外を発生させます。ユーザプログラムは，EURPMLSExceptionオブジェクトによって例外情報を取得します。例外情報には，エラーコード（終了コード），エラーレベル，メッセージID，メッセージが含まれます。

＜この節の構成＞
9.6.1　SS-Java起動部品実行時の例外情報一覧
9.6.2　getErrorCodeメソッド（終了コード）
9.6.3　getErrorLevelメソッド（エラーレベル）
9.6.4　getKeyメソッド（メッセージID）
9.6.5　getMessageメソッド（メッセージ文）
9.6.6　getOutputDataメソッド


SS-Java起動部品実行時の例外情報一覧

9.6.1　SS-Java起動部品実行時の例外情報一覧

SS-Java起動部品実行時の例外情報の一覧を次に示します。

表9-5　 SS-Java起動部品実行時の例外情報の一覧

終了 コード | エラー レベル | メッセージ文 | メッセージID
501 | E | プロパティ(プロパティ名)の指定値に誤りがあります。 | KEEY501-E
502 | E | プロパティ(プロパティ名)が指定されていません。 | KEEY502-E
503 | E | 原因不明のエラーで処理が中断されました。EUR Spool Serviceの状態を確認してください。 | KEEY503-E
504 | E | 印刷開始ページの入力値が印刷終了ページの入力値より大きいです。 | KEEY504-E
505 | S | 環境設定ファイルに不正があります。詳細コード = [nnnnnn] | KEEY505-S
506 | S | ログファイルの書き込みに失敗しました。 | KEEY506-S
507 | E | EUR Spool Serviceへの接続に失敗しました。 | KEEY507-E
508 | I | ジョブを起動しました。 | KEEY508-I
509 | I | ジョブを終了しました。 | KEEY509-I
510 | S | メモリ不足が発生しました。 | KEEY510-S
511 | E | 通信タイムアウトが発生しました。 | KEEY511-E
512 | S | システムエラーが発生しました。 | KEEY512-S
513 | E | 蓄積ファイル一覧取得処理でエラーが発生しました。（nnn） | KEEY513-E
515 | E | プリンタクラス一覧取得処理でエラーが発生しました。（nnn） | KEEY515-E
516 | E | プリンタ一覧取得処理でエラーが発生しました。（nnn） | KEEY516-E
517 | E | トレイ一覧取得処理でエラーが発生しました。（nnn） | KEEY517-E
518 | E | 蓄積ファイルの取得処理でエラーが発生しました。（nnn） | KEEY518-E
519 | E | 蓄積ファイルの印刷処理でエラーが発生しました。（nnn） | KEEY519-E
520 | E | 蓄積ファイルの属性取得処理でエラーが発生しました。（nnn） | KEEY520-E
521 | E | 蓄積ファイルの属性設定処理でエラーが発生しました。（nnn） | KEEY521-E
522 | E | 蓄積ファイルの削除処理でエラーが発生しました。（nnn） | KEEY522-E
523 | E | 蓄積ファイルの初期化に失敗しました。 | KEEY523-E
524 | E | 蓄積ファイルの作成に失敗しました。 | KEEY524-E
525 | E | EUR Spool Serviceでコネクション数が限界値をオーバーしました。 | KEEY525-E
526 | S | レジストリに不正があります。詳細コード = [nnnnnn] | KEEY526-S
527 | E | 指定された蓄積ファイルはほかの人が使用中です。 | KEEY527-E
528 | E | 属性値設定プロパティが一つも指定されていません。 | KEEY528-E
529 | E | EUR Client Serviceでコネクション数が限界値をオーバーしました。 | KEEY529-E
531 | E | 蓄積ファイルのデータ取得処理でエラーが発生しました。（nnn） | KEEY531-E
532 | W | 蓄積ファイル一覧取得処理で警告が発生しました。（nnn） | KEEY532-W
533 | W | 蓄積ファイルの取得処理で警告が発生しました。（nnn） | KEEY533-W
534 | W | 蓄積ファイルの印刷処理で警告が発生しました。（nnn） | KEEY534-W
535 | W | 蓄積ファイルの属性取得処理で警告が発生しました。（nnn） | KEEY535-W
536 | W | 蓄積ファイルの属性設定処理で警告が発生しました。（nnn） | KEEY536-W
537 | W | 蓄積ファイルの削除処理で警告が発生しました。（nnn） | KEEY537-W
538 | E | 指定されたジョブID検索値の数が上限値を超えています。 | KEEY538-E
540 | S | An attempt to load string resource DLL has failed. Error:[nnn] | KEEY540-S
541 | E | EUR Spool Serviceのバージョンが不正です。 | KEEY541-E
542 | W | ユーザ認証に失敗しました。（nnn） | KEEY542-W
543 | E | 配送帳票取得処理でエラーが発生しました。（nnn） | KEEY543-E
544 | E | 帳票一覧取得処理でエラーが発生しました。（nnn） | KEEY544-E
545 | W | 蓄積ファイル一覧取得処理で警告が発生しました。（nnn） | KEEY545-W
546 | W | 蓄積ファイルの取得処理で警告が発生しました。（nnn） | KEEY546-W
547 | W | 蓄積ファイルの印刷処理で警告が発生しました。（nnn） | KEEY547-W
548 | W | 蓄積ファイルの属性取得処理で警告が発生しました。（nnn） | KEEY548-W
549 | W | 蓄積ファイルの属性設定処理で警告が発生しました。（nnn） | KEEY549-W
550 | W | 蓄積ファイルの削除処理で警告が発生しました。（nnn） | KEEY550-W
551 | E | ログイン処理でエラーが発生しました。（nnn） | KEEY551-E
552 | E | 監査ログファイルの切り替えに失敗しました。（nnn） | KEEY552-E
553 | W | 監査ログ切り替え機能で警告が発生しました。（nnn） | KEEY553-W


getErrorCodeメソッド（終了コード）

9.6.2　getErrorCodeメソッド（終了コード）

EURPMLSExceptionオブジェクトのgetErrorCodeメソッドは，終了コードを返します。終了コードとメッセージの一覧については，「9.6.1　SS-Java起動部品実行時の例外情報一覧」を参照してください。エラーの対処については，マニュアル「EUR メッセージ」を参照してください。


getErrorLevelメソッド（エラーレベル）

9.6.3　getErrorLevelメソッド（エラーレベル）

EURPMLSExceptionオブジェクトのgetErrorLevelメソッドは，メッセージのエラーレベルを返します。エラーレベルを次に示します。

  • W：Warning（軽いエラーに対する警告）
  • E：Error（エラー）
  • S：Error（システムエラー）


getKeyメソッド（メッセージID）

9.6.4　getKeyメソッド（メッセージID）

EURPMLSExceptionオブジェクトのgetKeyメソッドは，メッセージのメッセージIDを返します。終了コードとメッセージの一覧については，「9.6.1　SS-Java起動部品実行時の例外情報一覧」を参照してください。エラーの対処については，マニュアル「EUR メッセージ」を参照してください。


getMessageメソッド（メッセージ文）

9.6.5　getMessageメソッド（メッセージ文）

EURPMLSExceptionオブジェクトのgetMessageメソッドは，メッセージ文を返します。終了コードとメッセージの一覧については，「9.6.1　SS-Java起動部品実行時の例外情報一覧」を参照してください。エラーの対処については，マニュアル「EUR メッセージ」を参照してください。


getOutputDataメソッド

9.6.6　getOutputDataメソッド

EURPMLSExceptionオブジェクトのgetOutputDataメソッドは，例外発生時にエラー種別が警告の場合，次のEPF形式ファイルを取得します。

  • memgetSpoolFileメソッド呼び出し時：スプールデータのEPF形式ファイル


COBOL起動部品

10.　COBOL起動部品

この章では，EUR Server Serviceで提供するCOBOL起動部品を使用した帳票出力について説明します。

＜この章の構成＞
10.1　COBOL起動部品とは
10.2　関数一覧
10.3　関数仕様
10.4　エラー情報


COBOL起動部品とは

10.1　COBOL起動部品とは

サーバ側で動作するCOBOLプログラムから，EUR Server Serviceを起動して帳票出力できる部品を提供しています。これを，COBOL起動部品といいます。

COBOL起動部品は，帳票ファイル名などをパラメタに設定し，出力実行関数を呼び出して帳票を出力します。COBOL起動部品を利用することで，Web/APサーバ上のサーバアプリケーションから帳票を印刷したり，EPF形式ファイルに出力したりできます。

＜この節の構成＞
10.1.1　COBOL起動部品の構成
10.1.2　COBOL起動部品の呼び出し規約


COBOL起動部品の構成

10.1.1　COBOL起動部品の構成

COBOL起動部品は，次に示す17のファイルから構成されます。

表10-1　COBOL起動部品のファイル構成

項番 | ファイル名 | 説明
1
Windows環境の場合
EURPMADC.dll
UNIX／Linux環境の場合
libEURPMADC.so
 COBOL起動部品本体
2 | EURPMADC.lib | 業務アプリケーションとCOBOL起動部品のリンケージ用ファイル
3 | EURPMPARAM1.cbl | PrintReport関数，およびPrintReport2関数用インタフェース領域定義ファイル
4 | EURPMPARAM3.cbl | OutputPDFReport関数用インタフェース領域定義ファイル
5 | EURPMPARAM4.cbl | OutputEURReport関数用インタフェース領域定義ファイル
6 | EURPMPARAM5.cbl | OutputEPFReport関数用インタフェース領域定義ファイル
7 | EURPMPARAM6.cbl | OutputXLSXReport関数用インタフェース領域定義ファイル
8 | EURPMPARAM7.cbl | OutputMergeEPFReport関数用インタフェース領域定義ファイル
9 | EURPMPARAMJOBID.cbl | PrintReport2関数用インタフェース領域定義ファイル
10 | EURPMPARAMCLASS.cbl | GetPrinterClassList関数用インタフェース領域定義ファイル
11 | EURPMPARAMCLASS2.cbl | GetPrinterClassList2関数用インタフェース領域定義ファイル
GetPMPrinterClassList関数用インタフェース領域定義ファイル
12 | EURPMPARAMDEST.cbl | GetDestinationList関数用インタフェース領域定義ファイル
13 | EURPMPARAMDEST2.cbl | GetDestinationList2関数用インタフェース領域定義ファイル
14 | EURPMPARAMDESTNAME.cbl | GetPrinterClassList関数，GetPrinterClassList2関数，GetPrinterList関数，およびGetTrayClassList関数用インタフェース領域定義ファイル
15 | EURPMPARAMPRINTER.cbl | GetPrinterList関数用インタフェース領域定義ファイル
GetPMPrinterList関数用インタフェース領域定義ファイル
16 | EURPMPARAMPRINTERNAME.cbl | GetTrayList関数用インタフェース領域定義ファイル
GetPMTrayList関数用インタフェース領域定義ファイル
17 | EURPMPARAMTRAY.cbl | GetTrayList関数用インタフェース領域定義ファイル
GetPMTrayList関数用インタフェース領域定義ファイル

なお，Windows環境の場合はEURPMADC.dllのインストール先フォルダに，UNIX／Linux環境の場合はlibEURPMADC.soのインストール先ディレクトリに，パスを通す必要があります。

ファイルを格納するフォルダやCOBOL起動部品の設定については，次のマニュアルを参照してください。

  • COBOL2002の場合：COBOL2002 ユーザーズガイド


COBOL起動部品の呼び出し規約

10.1.2　COBOL起動部品の呼び出し規約

32ビットプログラムから呼び出すとき
COBOL起動部品での呼び出し規約は，すべてC（cdecl）となります。呼び出し元のCOBOLプログラムでは，EXTERNAL PROGRAM SECTIONのCALL-CONVENTION構文で，プログラムをcdecl呼び出し規約にしておく必要があります。
64ビットプログラムから呼び出すとき
COBOL起動部品での呼び出し規約は，すべてfastcallとなります。

COBOL起動部品の呼び出し規約の詳細については，次のマニュアルを参照してください。

  • COBOL2002の場合：COBOL2002 ユーザーズガイド


関数一覧

10.2　関数一覧

COBOL起動部品が提供する関数の一覧を次に示します。

オプションの指定値には，制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」は使用できません。これらの文字を指定した場合，帳票管理GUI，［EUR Server Service 構成定義］ダイアログ，［EUR Spool Service 構成定義］ダイアログ，および［EUR Client 構成定義］ダイアログを操作できないことがあります。

表10-2　 COBOL起動部品が提供する関数

関数 | 概要
GetDestinationList | 出力先（スプールサーバ）の一覧を取得します。
GetDestinationList2
GetPMPrinterClassList | 帳票サーバに登録されているプリンタクラスの一覧を取得します。
GetPMPrinterList ※1 | 帳票サーバのOSに登録されているプリンタの一覧を取得します。
GetPMTrayList ※1 | 帳票サーバのOSに登録されているプリンタのトレイ一覧を取得します。
GetPrinterClassList ※2 | 指定した出力先（スプールサーバ）に登録されているプリンタクラスの一覧を取得します。
GetPrinterClassList2 ※2
GetPrinterList ※2 | 指定した出力先（スプールサーバ）のOSに登録されているプリンタの一覧を取得します。
GetTrayList ※2 | 出力先（スプールサーバ）とOS上のプリンタを指定し，そのOS上のプリンタのトレイ一覧を取得します。
OutputEPFReport | EPF形式ファイルを出力します。
OutputEURReport | EUR形式ファイルを出力します。
OutputMergeEPFReport | 複数のEPF形式ファイルを一つのEPF形式ファイルに統合して出力します。
OutputPDFReport | PDF形式ファイルを出力します。
OutputXLSXReport | Excel形式ファイルを出力します。
PrintReport | 帳票を印刷または蓄積します。
PrintReport2
注※1
帳票サーバがUNIX／Linux環境の場合は指定できません。
注※2
対象となるスプールサーバがUNIX／Linux環境の場合は指定できません。


関数仕様

10.3　関数仕様

COBOL起動部品が提供する関数の詳細を説明します。

＜この節の構成＞
GetDestinationList関数
GetDestinationList2関数
GetPMPrinterClassList関数
GetPMPrinterList関数
GetPMTrayList関数
GetPrinterClassList関数
GetPrinterClassList2関数
GetPrinterList関数
GetTrayList関数
OutputEPFReport関数
OutputEURReport関数
OutputMergeEPFReport関数
OutputPDFReport関数
OutputXLSXReport関数
PrintReport関数
PrintReport2関数


GetDestinationList関数

GetDestinationList関数

出力先（スプールサーバ）の一覧を取得します。

形式

------------------宣言部------------------
01 EURPMPARAMDEST.
  02   DESTNUM          PIC  9(9) COMP-X VALUE n.
  02   DESTS            OCCURS n TIMES.
    03  DESTNAME        PIC  X(80) VALUE SPACE.
    03  FILLER          PIC  X(1) VALUE LOW-VALUE.
    03  SERVERADDR      PIC  X(15) VALUE SPACE.
    03  FILLER          PIC  X(1) VALUE LOW-VALUE.
    03  COMMENT         PIC  X(256) VALUE SPACE.
    03  FILLER          PIC  X(1) VALUE LOW-VALUE.
01 RTNCODE              PIC  S9(9) BINARY.

------------------実行部------------------
call 'GetDestinationList'  USING BY REFERENCE EURPMPARAMDEST
                          RETURNING RTNCODE.

パラメタ

DESTNUM

パラメタDESTSの繰り返し回数nを指定します。nには取得する一覧の最大数を指定してください。

出力先の数がn個を超える場合は，n個までの一覧が取得されます。

DESTS

取得した出力先の一覧が格納される領域を指定します。詳細は戻り値DESTSを参照してください。

nには取得する一覧の最大数を指定してください。

戻り値

RTNCODE

終了コードが設定されます。終了コードについては，「10.4.1　エラー情報一覧」を参照してください。

DESTNUM

取得された出力先の数が格納されます。

DESTS

パラメタDESTNUMに設定されたn個分の出力先情報を，戻り値DESTNAME，SERVERADDR，COMMENTに格納します。出力先情報の数がn個に満たない場合は，戻り値DESTNUMに取得された個数の出力先情報が返され，戻り値DESTNUM+1番目以降の領域は不定になります。出力先情報の数がn個より多い場合は，パラメタDESTNUMに指定したn個の出力先情報が返されます。

DESTNAME

出力先情報の出力先名が設定されます。

SERVERADDR

出力先情報のスプールサーバのIPアドレスが設定されます。

COMMENT

出力先情報の説明が設定されます。

呼び出し例

出力先の一覧を取得する，呼び出し例を次に示します。

------------------宣言部------------------
01 EURPMPARAMDEST.
  02  DESTNUM         PIC  9(9) COMP-X VALUE 120.
  02  DESTS           OCCURS 120 TIMES.
    03  DESTNAME      PIC X(80) VALUE SPACE.
    03  FILLER        PIC X(1) VALUE LOW-VALUE.
    03  SERVERADDR    PIC X(15) VALUE SPACE.
    03  FILLER        PIC X(1) VALUE LOW-VALUE.
    03  COMMENT       PIC X(256) VALUE SPACE.
    03  FILLER        PIC X(1) VALUE LOW-VALUE.
01 RTNCODE            PIC  S9(9) BINARY.
------------------実行部------------------
DISPLAY '＜出力先一覧(GetDestinationList)＞'
CALL 'GetDestinationList' USING BY REFERENCE EURPMPARAMDEST
                          RETURNING RTNCODE
DISPLAY RTNCODE
IF RTNCODE = ZERO
THEN
  DISPLAY '正常終了'
  DISPLAY DESTNUM
  PERFORM VARYING IX1 FROM 1 BY 1 UNTIL IX1 > DESTNUM
    DISPLAY DESTNAME(IX1)
    DISPLAY SERVERADDR(IX1)
    DISPLAY COMMENT(IX1)
  END-PERFORM
ELSE
  DISPLAY 'エラー発生'
END-IF


GetDestinationList2関数

GetDestinationList2関数

出力先（スプールサーバ）の一覧を取得します。エラー発生時にエラーメッセージを取得できます。

形式

------------------宣言部------------------
01 EURPMPARAMDEST2.
  02 FILLER        PIC  X(4) VALUE '0770'.
  02 FILLER        PIC  X(1) VALUE LOW-VALUE.
  02 ERRORMESSAGE  PIC  X(256) VALUE SPACE.
  02 FILLER        PIC  X(1) VALUE LOW-VALUE.
  02 FILLER        PIC  X(2) VALUE LOW-VALUE.
  02 DESTNUM       PIC  9(9) COMP-X VALUE n.
  02 DESTS         OCCURS n TIMES.
    03 DESTNAME    PIC  X(80) VALUE SPACE.
    03 FILLER      PIC  X(1) VALUE LOW-VALUE.
    03 SERVERADDR  PIC  X(15) VALUE SPACE.
    03 FILLER      PIC  X(1) VALUE LOW-VALUE.
    03 COMMENT     PIC  X(256) VALUE SPACE.
    03 FILLER      PIC  X(1) VALUE LOW-VALUE.
    03 FILLER      PIC  X(2) VALUE LOW-VALUE.
  02 PMSERVERADDR  PIC  X(15) VALUE SPACE.
  02 FILLER        PIC  X(1) VALUE LOW-VALUE.
  02 PMSERVERPORT  PIC  S9(9) COMP-5 VALUE -1.
01 RTNCODE         PIC  S9(9) BINARY.
------------------実行部------------------
call 'GetDestinationList2'  USING BY REFERENCE EURPMPARAMDEST2
                            RETURNING RTNCODE.

パラメタ

DESTNUM

パラメタDESTSの繰り返し回数nを指定します。nには取得する一覧の最大数を指定してください。

出力先の数がn個を超える場合は，n個までの一覧が取得されます。

DESTS

取得した出力先の一覧が格納される領域を指定します。詳細は戻り値DESTSを参照してください。

nには取得する一覧の最大数を指定してください。

PMSERVERADDR

帳票サーバのIPアドレスを255.255.255.255形式で指定します。

PMSERVERADDRパラメタを省略する場合は，空白を指定します。

PMSERVERPORT

帳票サーバのポート番号を指定します。

PMSERVERPORTパラメタを省略する場合は，-1を指定します。

戻り値

RTNCODE

終了コードが設定されます。終了コードについては，「10.4.1　エラー情報一覧」を参照してください。

ERRORMESSAGE

エラーが発生した場合，エラーメッセージとメッセージIDが設定されます。エラーメッセージについては，マニュアル「EUR メッセージ」を参照してください。

エラーが発生しなかった場合は，空白が設定されます。

DESTS

パラメタDESTNUMに設定されたn個分の出力先情報を，戻り値DESTNAME，SERVERADDR，COMMENTに格納します。出力先情報の数がn個に満たない場合は，戻り値DESTNUMに取得された個数の出力先情報が返され，戻り値DESTNUM+1番目以降の領域は不定になります。出力先情報の数がn個より多い場合は，パラメタDESTNUMに指定したn個の出力先情報が返されます。

DESTNAME

出力先情報の出力先名が設定されます。

SERVERADDR

出力先情報のスプールサーバのIPアドレスが設定されます。

COMMENT

出力先情報の説明が設定されます。

ERRORMESSAGE

エラーが発生した場合，エラーメッセージとメッセージIDが設定されます。エラーメッセージについては，マニュアル「EUR メッセージ」を参照してください。

エラーが発生しなかった場合は，空白が設定されます。

呼び出し例

出力先の一覧を取得する，呼び出し例を次に示します。

------------------宣言部------------------
01 EURPMPARAMDEST.
  02 FILLER         PIC  X(4) VALUE '0770'.
  02 FILLER         PIC  X(1) VALUE LOW-VALUE.
  02 ERRORMESSAGE   PIC  X(256) VALUE SPACE.
  02 FILLER         PIC  X(1) VALUE LOW-VALUE.
  02 FILLER         PIC  X(2) VALUE LOW-VALUE.
  02  DESTNUM       PIC  9(9) COMP-X VALUE 120.
  02  DESTS         OCCURS 120 TIMES.
    03  DESTNAME    PIC  X(80) VALUE SPACE.
    03  FILLER      PIC  X(1) VALUE LOW-VALUE.
    03  SERVERADDR  PIC  X(15) VALUE SPACE.
    03  FILLER      PIC  X(1) VALUE LOW-VALUE.
    03  COMMENT     PIC  X(256) VALUE SPACE.
    03  FILLER      PIC  X(1) VALUE LOW-VALUE.
    03 FILLER       PIC  X(2) VALUE LOW-VALUE.
  02 PMSERVERADDR   PIC  X(15) VALUE SPACE.
  02 FILLER         PIC  X(1) VALUE LOW-VALUE.
  02 PMSERVERPORT   PIC  S9(9) COMP-5 VALUE -1.
01 RTNCODE          PIC  S9(9) BINARY.
------------------実行部------------------
DISPLAY '＜出力先一覧(GetDestinationList2)＞'
CALL 'GetDestinationList2' USING BY REFERENCE EURPMPARAMDEST
                          RETURNING RTNCODE
DISPLAY RTNCODE
IF RTNCODE = ZERO
THEN
  DISPLAY '正常終了'
  DISPLAY DESTNUM
  PERFORM VARYING IX1 FROM 1 BY 1 UNTIL IX1 > DESTNUM
    DISPLAY DESTNAME(IX1)
    DISPLAY SERVERADDR(IX1)
    DISPLAY COMMENT(IX1)
  END-PERFORM
ELSE
  DISPLAY 'エラー発生'
  DISPLAY ERRORMESSAGE
END-IF


GetPMPrinterClassList関数

GetPMPrinterClassList関数

帳票サーバに登録されているプリンタクラスの一覧を取得します。

形式

------------------宣言部------------------
01 EURPMPARAMCLASS.
  02 FILLER        PIC  X(4) VALUE '0770'.
  02 FILLER        PIC  X(1) VALUE LOW-VALUE.
  02 ERRORMESSAGE  PIC  X(256) VALUE SPACE.
  02 FILLER        PIC  X(1) VALUE LOW-VALUE.
  02 FILLER        PIC  X(2) VALUE LOW-VALUE.
  02 CLASSNUM      PIC  9(9) COMP-X VALUE n.
  02 CLASSES       OCCURS n TIMES.
    03 CLASSNAME   PIC  X(80) VALUE SPACE.
    03 FILLER      PIC  X(1) VALUE LOW-VALUE.
    03 PRINTERNAME PIC  X(80) VALUE SPACE.
    03 FILLER      PIC  X(1) VALUE LOW-VALUE.
    03 TRAYNAME    PIC  X(80) VALUE SPACE.
    03 FILLER      PIC  X(1) VALUE LOW-VALUE.
    03 COMMENT     PIC  X(256) VALUE SPACE.
    03 FILLER      PIC  X(1) VALUE LOW-VALUE.
  02 PMSERVERADDR  PIC  X(15) VALUE SPACE.
  02 FILLER        PIC  X(1) VALUE LOW-VALUE.
  02 PMSERVERPORT  PIC  S9(9) COMP-5 VALUE -1.
01 RTNCODE         PIC  S9(9) BINARY.
------------------実行部------------------
call 'GetPMPrinterClassList'   USING BY REFERENCE EURPMPARAMCLASS
                               RETURNING RTNCODE.

パラメタ

CLASSNUM

パラメタCLASSESの繰り返し回数nを指定します。nには取得する一覧の最大数を指定してください。

プリンタクラスの数がn個を超える場合は，n個までの一覧が取得されます。

CLASSES

取得したプリンタクラスの一覧が格納される領域を指定します。詳細は戻り値CLASSESを参照してください。

nには取得する一覧の最大数を指定してください。

PMSERVERADDR

帳票サーバのIPアドレスを255.255.255.255形式で指定します。

PMSERVERADDRパラメタを省略する場合は，空白を指定します。

PMSERVERPORT

帳票サーバのポート番号を指定します。

PMSERVERPORTパラメタを省略する場合は，-1を指定します。

戻り値

RTNCODE

終了コードが設定されます。終了コードについては，「10.4.1　エラー情報一覧」を参照してください。

ERRORMESSAGE

エラーが発生した場合，エラーメッセージとメッセージIDが設定されます。エラーメッセージについては，マニュアル「EUR メッセージ」を参照してください。

エラーが発生しなかった場合は，空白が設定されます。

CLASSNUM

取得されたプリンタクラス数が設定されます。

CLASSES

パラメタCLASSNUMに設定されたn個分のプリンタクラス情報を，戻り値CLASSNAME，PRINTERNAME，TRAYNAME，COMMENTに格納します。取得したプリンタクラスの数がn個に満たない場合は，戻り値CLASSNUMに取得された個数のプリンタクラス情報が返され，戻り値CLASSNUM+1番目以降の領域は不定になります。取得したプリンタクラスの数がn個より多い場合は，パラメタCLASSNUMに指定したn個のプリンタクラス情報が返されます。

CLASSNAME

OS上のプリンタクラス名が設定されます。

PRINTERNAME

OS上のプリンタ名が設定されます。

TRAYNAME

OS上のプリンタクラスのトレイ名が設定されます。

COMMENT

OS上のプリンタクラスの説明が設定されます。

呼び出し例

帳票サーバのプリンタクラスの一覧を取得する，呼び出し例を次に示します。

------------------宣言部------------------
01 EURPMPARAMCLASS.
  02   FILLER       PIC  X(4) VALUE '0770'.
  02   FILLER       PIC  X(1) VALUE LOW-VALUE.
  02   ERRORMESSAGE PIC  X(256) VALUE SPACE.
  02   FILLER       PIC  X(1) VALUE LOW-VALUE.
  02   FILLER       PIC  X(2) VALUE LOW-VALUE.
  02   CLASSNUM     PIC  9(9) COMP-X VALUE 120.
  02   CLASSES      OCCURS 120 TIMES.
    03  CLASSNAME   PIC  X(80) VALUE SPACE.
    03  FILLER      PIC  X(1) VALUE LOW-VALUE.
    03  PRINTERNAME PIC  X(80) VALUE SPACE.
    03  FILLER      PIC  X(1) VALUE LOW-VALUE.
    03  TRAYNAME    PIC  X(80) VALUE SPACE.
    03  FILLER      PIC  X(1) VALUE LOW-VALUE.
    03  COMMENT     PIC  X(256) VALUE SPACE.
    03  FILLER      PIC  X(1) VALUE LOW-VALUE.
  02 PMSERVERADDR   PIC  X(15) VALUE SPACE.
  02 FILLER         PIC  X(1) VALUE LOW-VALUE.
  02 PMSERVERPORT   PIC  S9(9) COMP-5 VALUE -1.
01 RTNCODE          PIC  S9(9) BINARY.
------------------実行部------------------
DISPLAY '＜プリンタクラス一覧(GetPMPrinterClassList)＞'
CALL 'GetPMPrinterClassList' USING BY REFERENCE EURPMPARAMCLASS
                             RETURNING RTNCODE
DISPLAY RTNCODE
IF RTNCODE = ZERO
THEN
  DISPLAY '正常終了'
  DISPLAY CLASSNUM
  PERFORM VARYING IX1 FROM 1 BY 1 UNTIL IX1 > CLASSNUM
    DISPLAY CLASSNAME(IX1)
    DISPLAY PRINTERNAME(IX1)
    DISPLAY TRAYNAME(IX1)
    DISPLAY COMMENT(IX1)
  END-PERFORM
ELSE
  DISPLAY 'エラー発生'
END-IF


GetPMPrinterList関数

GetPMPrinterList関数

帳票サーバのOSに登録されているプリンタの一覧を取得します。

なお，帳票サーバがUNIX／Linux環境の場合，プリンタ一覧の取得はサポートしていません。UNIX／Linux環境のEUR Server - Spool Serviceに対して，プリンタ一覧の取得を実行した場合はエラーとなります。

形式

------------------宣言部------------------
01 EURPMPARAMPRINTER.
  02 FILLER         PIC  X(4) VALUE '0770'.
  02 FILLER         PIC  X(1) VALUE LOW-VALUE.
  02 ERRORMESSAGE   PIC  X(256) VALUE SPACE.
  02 FILLER         PIC  X(1) VALUE LOW-VALUE.
  02 FILLER         PIC  X(2) VALUE LOW-VALUE.
  02   PRINTERNUM   PIC  9(9) COMP-X VALUE n.
  02   PRINTERS     OCCURS n TIMES.
    03  PRINTERNAME PIC  X(80) VALUE SPACE.
    03  FILLER      PIC  X(1) VALUE LOW-VALUE.
    03  FILLER      PIC  X(3) VALUE LOW-VALUE.
  02 PMSERVERADDR   PIC  X(15) VALUE SPACE.
  02 FILLER         PIC  X(1) VALUE LOW-VALUE.
  02 PMSERVERPORT   PIC  S9(9) COMP-5 VALUE -1.
01 RTNCODE          PIC  S9(9) BINARY.
------------------実行部------------------
call 'GetPMPrinterList' USING BY REFERENCE EURPMPARAMPRINTER
                       RETURNING RTNCODE.

パラメタ

PRINTERNUM

パラメタPRINTERSの繰り返し回数nを指定します。nには取得する一覧の最大数を指定してください。

プリンタの数がn個を超える場合は，n個までの一覧が取得されます。

PRINTERS

取得したOS上のプリンタの一覧が格納される領域を指定します。nには取得する一覧の最大数を指定してください。詳細は戻り値PRINTERSを参照してください。

PMSERVERADDR

帳票サーバのIPアドレスを255.255.255.255形式で指定します。

PMSERVERADDRパラメタを省略する場合は，空白を指定します。

PMSERVERPORT

帳票サーバのポート番号を指定します。

PMSERVERPORTパラメタを省略する場合は，-1を指定します。

戻り値

RTNCODE

終了コードが設定されます。終了コードについては，「10.4.1　エラー情報一覧」を参照してください。

ERRORMESSAGE

エラーが発生した場合，エラーメッセージとメッセージIDが設定されます。エラーメッセージについては，マニュアル「EUR メッセージ」を参照してください。

エラーが発生しなかった場合は，空白が設定されます。

PRINTERNUM

取得されたプリンタ数が設定されます。

PRINTERS

パラメタPRINTERNUMに設定されたn個分のプリンタ情報を，戻り値PRINTERNAMEに格納します。取得したプリンタの数がn個に満たない場合は，戻り値PRINTERNUMに取得された個数のプリンタ情報が返され，戻り値PRINTERNUM + 1番目以降の領域は不定になります。取得したプリンタの数がn個より多い場合は，パラメタPRINTERNUMに指定したn個のプリンタ情報が返されます。

PRINTERNAME

OS上のプリンタ名が設定されます。

呼び出し例

帳票サーバに登録されたOS上のプリンタ一覧を取得する，呼び出し例を次に示します。

------------------宣言部------------------
01 EURPMPARAMPRINTER.
  02 FILLER         PIC  X(4) VALUE '0770'.
  02 FILLER         PIC  X(1) VALUE LOW-VALUE.
  02 ERRORMESSAGE   PIC  X(256) VALUE SPACE.
  02 FILLER         PIC  X(1) VALUE LOW-VALUE.
  02 FILLER         PIC  X(2) VALUE LOW-VALUE.
  02   PRINTERNUM   PIC  9(9) COMP-X VALUE 120.
  02   PRINTERS     OCCURS 120 TIMES.
    03  PRINTERNAME PIC  X(80) VALUE SPACE.
    03  FILLER      PIC  X(1) VALUE LOW-VALUE.
    03  FILLER      PIC  X(3) VALUE LOW-VALUE.
  02 PMSERVERADDR   PIC  X(15) VALUE SPACE.
  02 FILLER         PIC  X(1) VALUE LOW-VALUE.
  02 PMSERVERPORT   PIC  S9(9) COMP-5 VALUE -1.
01 RTNCODE          PIC  S9(9) BINARY.
------------------実行部------------------
DISPLAY '＜プリンタ一覧(GetPMPrinterList)＞'
CALL 'GetPMPrinterList' USING BY REFERENCE EURPMPARAMPRINTER
                       RETURNING RTNCODE
DISPLAY RTNCODE
IF RTNCODE = ZERO
THEN
  DISPLAY '正常終了'
  DISPLAY PRINTERNUM
  PERFORM VARYING IX1 FROM 1 BY 1 UNTIL IX1 > PRINTERNUM
    DISPLAY PRINTERNAME(IX1)
  END-PERFORM
ELSE
  DISPLAY 'エラー発生'
  DISPLAY ERRORMESSAGE
END-IF


GetPMTrayList関数

GetPMTrayList関数

帳票サーバのOSに登録されているプリンタのトレイ一覧を取得します。

なお，帳票サーバがUNIX／Linux環境の場合，トレイ一覧の取得はサポートしていません。UNIX／Linux環境のEUR Server - Spool Serviceに対して，トレイ一覧の取得を実行した場合はエラーとなります。

形式

------------------宣言部------------------
01 EURPMPARAMPRINTERNAME.
  02 PRINTERNAME    PIC  X(80) VALUE SPACE.
  02 FILLER         X(1) VALUE LOW-VALUE.
01 EURPMPARAMTRAY.
  02 FILLER         PIC  X(4) VALUE '0770'.
  02 FILLER         PIC  X(1) VALUE LOW-VALUE.
  02 ERRORMESSAGE   PIC  X(256) VALUE SPACE.
  02 FILLER         PIC  X(1) VALUE LOW-VALUE.
  02 FILLER         PIC  X(2) VALUE LOW-VALUE.
  02 TRAYNUM        PIC  9(9) COMP-X VALUE n.
  02 TRAYS          OCCURS n TIMES.
    03 TRAYNAME     PIC  X(80) VALUE SPACE.
    03 FILLER       PIC  X(1) VALUE LOW-VALUE.
    03  FILLER      PIC  X(3) VALUE LOW-VALUE.
  02 PMSERVERADDR   PIC  X(15) VALUE SPACE.
  02 FILLER         PIC  X(1) VALUE LOW-VALUE.
  02 PMSERVERPORT   PIC  S9(9) COMP-5 VALUE -1.
01 RTNCODE          PIC  S9(9) BINARY.
------------------実行部------------------
call 'GetPMTrayList' USING BY REFERENCE EURPMPARAMPRINTERNAME
                                       EURPMPARAMTRAY
                       RETURNING RTNCODE.

パラメタ

PRINTERNAME

トレイ一覧を取得するOS上のプリンタ名を，80バイトの文字列で指定します。プリンタ名が80バイトに満たない場合は，空白で埋めてください。

TRAYNUM

パラメタTRAYSの繰り返し回数nを指定します。nには取得する一覧の最大数を指定してください。

トレイの数がn個を超える場合は，n個までの一覧が取得されます。

TRAYS

取得したトレイ一覧が格納される領域を指定します。nには取得する一覧の最大数を指定してください。詳細は戻り値TRAYSを参照してください。

PMSERVERADDR

帳票サーバのIPアドレスを255.255.255.255形式で指定します。

PMSERVERADDRパラメタを省略する場合は，空白を指定します。

PMSERVERPORT

帳票サーバのポート番号を指定します。

PMSERVERPORTパラメタを省略する場合は，-1を指定します。

戻り値

RTNCODE

終了コードが設定されます。終了コードについては，「10.4.1　エラー情報一覧」を参照してください

ERRORMESSAGE

エラーが発生した場合，エラーメッセージとメッセージIDが設定されます。エラーメッセージについては，マニュアル「EUR メッセージ」を参照してください。

エラーが発生しなかった場合は，空白が設定されます。

TRAYNUM

取得されたプリンタのトレイ数が設定されます。

TRAYS

パラメタTRAYNUMに設定されたn個分のプリンタのトレイ情報を，戻り値TRAYNAMEに格納します。取得したプリンタのトレイ数がn個に満たない場合は，戻り値TRAYNUMに取得された個数のプリンタのトレイ情報が返され，戻り値TRAYNUM + 1番目以降の領域は不定になります。取得したプリンタのトレイ数がn個より多い場合は，パラメタTRAYNUMに指定したn個のプリンタのトレイ情報が返されます。

TRAYNAME

OS上のプリンタのトレイ名が設定されます。

呼び出し例

帳票サーバ上のプリンタを指定し，そのOS上のプリンタのトレイ一覧を取得します。

------------------宣言部------------------
01 EURPMPARAMPRINTERNAME.
  02 PRINTERNAME    PIC  X(80) VALUE SPACE.
  02 FILLER         X(1) VALUE LOW-VALUE.
01 EURPMPARAMTRAY.
  02 FILLER         PIC  X(4) VALUE '0770'.
  02 FILLER         PIC  X(1) VALUE LOW-VALUE.
  02 ERRORMESSAGE   PIC  X(256) VALUE SPACE.
  02 FILLER         PIC  X(1) VALUE LOW-VALUE.
  02 FILLER         PIC  X(2) VALUE LOW-VALUE.
  02 TRAYNUM        PIC  9(9) COMP-X VALUE 120.
  02 TRAYS          OCCURS 120 TIMES.
    03 TRAYNAME     PIC  X(80) VALUE SPACE.
    03 FILLER       PIC  X(1) VALUE LOW-VALUE.
    03  FILLER      PIC  X(3) VALUE LOW-VALUE.
  02 PMSERVERADDR   PIC  X(15) VALUE SPACE.
  02 FILLER         PIC  X(1) VALUE LOW-VALUE.
  02 PMSERVERPORT   PIC  S9(9) COMP-5 VALUE -1.
01 RTNCODE          PIC  S9(9) BINARY.
------------------実行部------------------
DISPLAY '＜トレイ一覧(GetPMTrayList)＞'
MOVE 'PRINTER1' TO PRINTERNAME
DISPLAY PRINTERNAME
CALL ' GetPMTrayList ' USING BY REFERENCE EURPMPARAMPRINTERNAME
                                      EURPMPARAMTRAY
                              RETURNING RTNCODE
DISPLAY RTNCODE
IF RTNCODE = ZERO
THEN
  DISPLAY '正常終了'
  DISPLAY TRAYNUM
  PERFORM VARYING IX1 FROM 1 BY 1 UNTIL IX1 > TRAYNUM
    DISPLAY TRAYNAME (IX1)
  END-PERFORM
ELSE
  DISPLAY 'エラー発生'
  DISPLAY ERRORMESSAGE
END-IF


GetPrinterClassList関数

GetPrinterClassList関数

指定した出力先（スプールサーバ）に登録されているプリンタクラスの一覧を取得します。出力先を指定していない場合は，デフォルトの出力先として登録されたスプールサーバに定義されているプリンタクラスの一覧を取得します。

なお，UNIX／Linux環境の場合，プリンタクラス一覧の取得はサポートしていません。UNIX／Linux環境のEUR Server - Spool Serviceに対して，プリンタクラス一覧の取得を実行した場合はエラーとなります。

形式

------------------宣言部------------------
01 EURPMPARAMDESTNAME.
  02 DESTNAME            PIC  X(80) VALUE SPACE.
  02 FILLER              PIC X(1) VALUE LOW-VALUE.
01 EURPMPARAMCLASS.
  02   CLASSNUM          PIC  9(9) COMP-X VALUE n.
  02   CLASSES           OCCURS n TIMES.
    03  CLASSNAME        PIC  X(80) VALUE SPACE.
    03  FILLER           PIC  X(1) VALUE LOW-VALUE.
    03  PRINTERNAME      PIC  X(80) VALUE SPACE.
    03  FILLER           PIC  X(1) VALUE LOW-VALUE.
    03  TRAYNAME         PIC  X(80) VALUE SPACE.
    03  FILLER           PIC  X(1) VALUE LOW-VALUE.
    03  COMMENT          PIC  X(256) VALUE SPACE.
    03  FILLER           PIC  X(1) VALUE LOW-VALUE.
01 RTNCODE                        PIC  S9(9) BINARY.
------------------実行部------------------
call 'GetPrinterClassList'   USING BY REFERENCE EURPMPARAMDESTNAME
                                               EURPMPARAMCLASS
                            RETURNING RTNCODE.

パラメタ

DESTNAME

拠点プリンタクラス一覧を取得するスプールサーバの出力先名を指定します。

CLASSNUM

パラメタCLASSESの繰り返し回数nを指定します。nには取得する一覧の最大数を指定してください。

プリンタクラスの数がn個を超える場合は，n個までの一覧が取得されます。

CLASSES

取得したプリンタクラスの一覧が格納される領域を指定します。詳細は戻り値CLASSESを参照してください。

nには取得する一覧の最大数を指定してください。

戻り値

RTNCODE

終了コードが設定されます。終了コードについては，「10.4.1　エラー情報一覧」を参照してください。

ERRORMESSAGE

エラーが発生した場合，エラーメッセージとメッセージIDが設定されます。エラーメッセージについては，マニュアル「EUR メッセージ」を参照してください。

エラーが発生しなかった場合は，空白が設定されます。

CLASSNUM

取得されたプリンタクラス数が格納されます。

CLASSES

パラメタCLASSNUMに設定されたn個分のプリンタクラス情報を，戻り値CLASSNAME，PRINTERNAME，TRAYNAME，COMMENTに格納します。拠点プリンタクラスの数がn個に満たない場合は，戻り値CLASSNUMに取得された個数の拠点プリンタクラス情報が返され，戻り値CLASSNUM+1番目以降の領域は不定になります。拠点プリンタクラスの数がn個より多い場合は，パラメタCLASSNUMに指定したn個のプリンタクラス情報が返されます。

CLASSNAME

拠点プリンタクラス情報の拠点プリンタクラス名が設定されます。

PRINTERNAME

拠点プリンタクラス情報のスプールサーバのプリンタ名が設定されます。

TRAYNAME

拠点プリンタクラス情報のスプールサーバのトレイ名が設定されます。

COMMENT

拠点プリンタクラス情報の説明が設定されます。

呼び出し例

指定した出力先の拠点プリンタクラスの一覧を取得する，呼び出し例を次に示します。

------------------宣言部------------------
01 EURPMPARAMDESTNAME.
  02 DESTNAME           PIC  X(80) VALUE SPACE.
  02 FILLER             PIC  X(1) VALUE LOW-VALUE.
01 EURPMPARAMCLASS.
  02  CLASSNUM          PIC  9(9) COMP-X VALUE 120.
  02  CLASSES           OCCURS 120 TIMES.
    03  CLASSNAME       PIC X(80) VALUE SPACE.
    03  FILLER          PIC X(1) VALUE LOW-VALUE.
    03  PRINTERNAME     PIC X(80) VALUE SPACE.
    03  FILLER          PIC X(1) VALUE LOW-VALUE.
    03  TRAYNAME        PIC X(80) VALUE SPACE.
    03  FILLER          PIC X(1) VALUE LOW-VALUE.
    03  COMMENT         PIC X(256) VALUE SPACE.
    03  FILLER          PIC X(1) VALUE LOW-VALUE.
01 RTNCODE              PIC  S9(9) BINARY.
------------------実行部------------------
          DISPLAY '＜プリンタクラス一覧(GetPrinterClassList)＞'
          MOVE 'SERVER1' TO DESTNAME
          CALL 'GetPrinterClassList' USING BY REFERENCE EURPMPARAMDESTNAME
                                                       EURPMPARAMCLASS
                                    RETURNING RTNCODE
          DISPLAY RTNCODE
          IF RTNCODE = ZERO
          THEN
            DISPLAY '正常終了'
            DISPLAY CLASSNUM
            PERFORM VARYING IX1 FROM 1 BY 1 UNTIL IX1 > CLASSNUM
              DISPLAY CLASSNAME(IX1)
              DISPLAY PRINTERNAME(IX1)
              DISPLAY TRAYNAME(IX1)
              DISPLAY COMMENT(IX1)
            END-PERFORM
          ELSE
            DISPLAY 'エラー発生'
          END-IF


GetPrinterClassList2関数

GetPrinterClassList2関数

指定した出力先（スプールサーバ）に登録されているプリンタクラスの一覧を取得します。出力先を指定していない場合は，デフォルトの出力先として登録されたスプールサーバに定義されているプリンタクラスの一覧を取得します。エラー発生時にエラーメッセージを取得できます。

なお，UNIX／Linux環境の場合，プリンタクラス一覧の取得はサポートしていません。UNIX／Linux環境のEUR Server - Spool Serviceに対して，プリンタクラス一覧の取得を実行した場合はエラーとなります。

形式

------------------宣言部------------------
01 EURPMPARAMDESTNAME.
  02 DESTNAME        PIC  X(80) VALUE SPACE.
  02 FILLER          PIC  X(1) VALUE LOW-VALUE.
01 EURPMPARAMCLASS2.
  02 FILLER          PIC  X(4) VALUE '0770'.
  02 FILLER          PIC  X(1) VALUE LOW-VALUE.
  02 ERRORMESSAGE    PIC  X(256) VALUE SPACE.
  02 FILLER          PIC  X(1) VALUE LOW-VALUE.
  02 FILLER          PIC  X(2) VALUE LOW-VALUE.
  02   CLASSNUM      PIC  9(9) COMP-X VALUE n.
  02   CLASSES       OCCURS n TIMES.
    03  CLASSNAME    PIC  X(80) VALUE SPACE.
    03  FILLER       PIC  X(1) VALUE LOW-VALUE.
    03  PRINTERNAME  PIC  X(80) VALUE SPACE.
    03  FILLER       PIC  X(1) VALUE LOW-VALUE.
    03  TRAYNAME     PIC  X(80) VALUE SPACE.
    03  FILLER       PIC  X(1) VALUE LOW-VALUE.
    03  COMMENT      PIC  X(256) VALUE SPACE.
    03  FILLER       PIC  X(1) VALUE LOW-VALUE.
  02 PMSERVERADDR    PIC  X(15) VALUE SPACE.
  02 FILLER          PIC  X(1) VALUE LOW-VALUE.
  02 PMSERVERPORT    PIC  S9(9) COMP-5 VALUE -1.
01 RTNCODE           PIC  S9(9) BINARY.
------------------実行部------------------
call 'GetPrinterClassList2'   USING BY REFERENCE EURPMPARAMDESTNAME
                                                EURPMPARAMCLASS2
                             RETURNING RTNCODE.

パラメタ

DESTNAME

拠点プリンタクラス一覧を取得するスプールサーバの出力先名を指定します。

CLASSNUM

パラメタCLASSESの繰り返し回数nを指定します。nには取得する一覧の最大数を指定してください。

プリンタクラスの数がn個を超える場合は，n個までの一覧が取得されます。

CLASSES

取得したプリンタクラスの一覧が格納される領域を指定します。詳細は戻り値CLASSESを参照してください。

nには取得する一覧の最大数を指定してください。

PMSERVERADDR

帳票サーバのIPアドレスを255.255.255.255形式で指定します。

PMSERVERADDRパラメタを省略する場合は，空白を指定します。

PMSERVERPORT

帳票サーバのポート番号を指定します。

PMSERVERPORTパラメタを省略する場合は，-1を指定します。

戻り値

RTNCODE

終了コードが設定されます。終了コードについては，「10.4.1　エラー情報一覧」を参照してください。

ERRORMESSAGE

エラーが発生した場合，エラーメッセージとメッセージIDが設定されます。エラーメッセージについては，マニュアル「EUR メッセージ」を参照してください。

エラーが発生しなかった場合は，空白が設定されます。

CLASSNUM

取得されたプリンタクラス数が格納されます。

CLASSES

パラメタCLASSNUMに設定されたn個分のプリンタクラス情報を，戻り値CLASSNAME，PRINTERNAME，TRAYNAME，COMMENTに格納します。拠点プリンタクラスの数がn個に満たない場合は，戻り値CLASSNUMに取得された個数の拠点プリンタクラス情報が返され，戻り値CLASSNUM+1番目以降の領域は不定になります。拠点プリンタクラスの数がn個より多い場合は，パラメタCLASSNUMに指定したn個のプリンタクラス情報が返されます。

CLASSNAME

拠点プリンタクラス情報の拠点プリンタクラス名が設定されます。

PRINTERNAME

拠点プリンタクラス情報のスプールサーバのプリンタ名が設定されます。

TRAYNAME

拠点プリンタクラス情報のスプールサーバのトレイ名が設定されます。

COMMENT

拠点プリンタクラス情報の説明が設定されます。

呼び出し例

指定した出力先の拠点プリンタクラスの一覧を取得する，呼び出し例を次に示します。

------------------宣言部------------------
01 EURPMPARAMDESTNAME.
  02 DESTNAME           PIC  X(80) VALUE SPACE.
  02 FILLER             PIC  X(1) VALUE LOW-VALUE.
01 EURPMPARAMCLASS.
  02 FILLER             PIC  X(4) VALUE '0770'.
  02 FILLER             PIC  X(1) VALUE LOW-VALUE.
  02 ERRORMESSAGE       PIC  X(256) VALUE SPACE.
  02 FILLER             PIC  X(1) VALUE LOW-VALUE.
  02 FILLER             PIC  X(2) VALUE LOW-VALUE.
  02  CLASSNUM          PIC  9(9) COMP-X VALUE 120.
  02  CLASSES           OCCURS 120 TIMES.
    03  CLASSNAME       PIC  X(80) VALUE SPACE.
    03  FILLER          PIC  X(1) VALUE LOW-VALUE.
    03  PRINTERNAME     PIC  X(80) VALUE SPACE.
    03  FILLER          PIC  X(1) VALUE LOW-VALUE.
    03  TRAYNAME        PIC  X(80) VALUE SPACE.
    03  FILLER          PIC  X(1) VALUE LOW-VALUE.
    03  COMMENT         PIC  X(256) VALUE SPACE.
    03  FILLER          PIC  X(1) VALUE LOW-VALUE.
  02 PMSERVERADDR       PIC  X(15) VALUE SPACE.
  02 FILLER             PIC  X(1) VALUE LOW-VALUE.
  02 PMSERVERPORT       PIC  S9(9) COMP-5 VALUE -1.
01 RTNCODE              PIC  S9(9) BINARY.
------------------実行部------------------
DISPLAY '＜プリンタクラス一覧(GetPrinterClassList2)＞'
MOVE 'SERVER1' TO DESTNAME
DISPLAY DESTNAME
CALL 'GetPrinterClassList2' USING BY REFERENCE EURPMPARAMDESTNAME
                                             EURPMPARAMCLASS
                            RETURNING RTNCODE
DISPLAY RTNCODE
IF RTNCODE = ZERO
THEN
  DISPLAY '正常終了'
  DISPLAY CLASSNUM
  PERFORM VARYING IX1 FROM 1 BY 1 UNTIL IX1 > CLASSNUM
    DISPLAY CLASSNAME(IX1)
    DISPLAY PRINTERNAME(IX1)
    DISPLAY TRAYNAME(IX1)
    DISPLAY COMMENT(IX1)
  END-PERFORM
ELSE
  DISPLAY 'エラー発生'
  DISPLAY ERRORMESSAGE
END-IF


GetPrinterList関数

GetPrinterList関数

指定した出力先（スプールサーバ）のOSに登録されているプリンタの一覧を取得します。出力先を指定していない場合は，デフォルトの出力先として登録されたスプールサーバのOS上のプリンタ一覧を取得します。

なお，UNIX／Linux環境の場合，プリンタ一覧の取得はサポートしていません。UNIX／Linux環境のEUR Server - Spool Serviceに対して，プリンタ一覧の取得を実行した場合はエラーとなります。

形式

------------------宣言部------------------
01 EURPMPARAMDESTNAME.
  02 DESTNAME       PIC  X(80) VALUE SPACE.
  02 FILLER         PIC  X(1) VALUE LOW-VALUE.
01 EURPMPARAMPRINTER.
  02 FILLER         PIC  X(4) VALUE '0770'.
  02 FILLER         PIC  X(1) VALUE LOW-VALUE.
  02 ERRORMESSAGE   PIC  X(256) VALUE SPACE.
  02 FILLER         PIC  X(1) VALUE LOW-VALUE.
  02 FILLER         PIC  X(2) VALUE LOW-VALUE.
  02   PRINTERNUM   PIC  9(9) COMP-X VALUE n.
  02   PRINTERS     OCCURS n TIMES.
    03  PRINTERNAME PIC  X(80) VALUE SPACE.
    03  FILLER      PIC  X(1) VALUE LOW-VALUE.
    03  FILLER      PIC  X(3) VALUE LOW-VALUE.
  02 PMSERVERADDR   PIC  X(15) VALUE SPACE.
  02 FILLER         PIC  X(1) VALUE LOW-VALUE.
  02 PMSERVERPORT   PIC  S9(9) COMP-5 VALUE -1.
01 RTNCODE          PIC  S9(9) BINARY.
------------------実行部------------------
call 'GetPrinterList' USING BY REFERENCE EURPMPARAMDESTNAME
                                        EURPMPARAMPRINTER
RETURNING RTNCODE.

パラメタ

DESTNAME

OS上のプリンタ一覧を取得するスプールサーバの出力先名を指定します。

PRINTERNUM

パラメタPRINTERSの繰り返し回数を指定します。nには取得する一覧の最大数を指定してください。

OS上のプリンタの数がn個を超える場合は，n個までの一覧が取得されます。

PRINTERS

取得したOS上のプリンタの一覧が格納される領域を指定します。nには取得する一覧の最大数を指定してください。詳細は戻り値PRINTERSを参照してください。

PMSERVERADDR

帳票サーバのIPアドレスを255.255.255.255形式で指定します。

PMSERVERADDRパラメタを省略する場合は，空白を指定します。

PMSERVERPORT

帳票サーバのポート番号を指定します。

PMSERVERPORTパラメタを省略する場合は，-1を指定します。

戻り値

RTNCODE

終了コードが設定されます。終了コードについては，「10.4.1　エラー情報一覧」を参照してください。

ERRORMESSAGE

エラーが発生した場合，エラーメッセージとメッセージIDが設定されます。エラーメッセージについては，マニュアル「EUR メッセージ」を参照してください。

エラーが発生しなかった場合は，空白が設定されます。

PRINTERNUM

取得されたOS上のプリンタ数が格納されます。

PRINTERS

パラメタPRINTERNUMに設定されたn個分のプリンタ情報を，戻り値PRINTERNAMEに格納します。OS上のプリンタの数がn個に満たない場合は，戻り値PRINTERNUMに取得された個数のプリンタ情報が返され，戻り値PRINTERNUM+1番目以降の領域は不定になります。OS上のプリンタの数がn個より多い場合は，パラメタPRINTERNUMに指定したn個のプリンタ情報が返されます。

PRINTERNAME

OS上のプリンタ名が設定されます。

呼び出し例

OS上のプリンタの一覧を取得する，呼び出し例を次に示します。

------------------宣言部------------------
01 EURPMPARAMDESTNAME.
  02 DESTNAME       PIC  X(80) VALUE SPACE.
  02 FILLER         PIC  X(1) VALUE LOW-VALUE.
01 EURPMPARAMPRINTER.
  02 FILLER         PIC  X(4) VALUE '0770'.
  02 FILLER         PIC  X(1) VALUE LOW-VALUE.
  02 ERRORMESSAGE   PIC  X(256) VALUE SPACE.
  02 FILLER         PIC  X(1) VALUE LOW-VALUE.
  02 FILLER         PIC  X(2) VALUE LOW-VALUE.
  02   PRINTERNUM   PIC  9(9) COMP-X VALUE 120.
  02   PRINTERS     OCCURS 120 TIMES.
    03  PRINTERNAME PIC  X(80) VALUE SPACE.
    03  FILLER      PIC  X(1) VALUE LOW-VALUE.
    03  FILLER      PIC  X(3) VALUE LOW-VALUE.
  02 PMSERVERADDR   PIC  X(15) VALUE SPACE.
  02 FILLER         PIC  X(1) VALUE LOW-VALUE.
  02 PMSERVERPORT   PIC  S9(9) COMP-5 VALUE -1.
01 RTNCODE          PIC  S9(9) BINARY.
------------------実行部------------------
DISPLAY '＜プリンタ一覧(GetPrinterList)＞'
MOVE 'SERVER1' TO DESTNAME
DISPLAY DESTNAME
CALL 'GetPrinterList' USING BY REFERENCE EURPMPARAMDESTNAME
                                         EURPMPARAMPRINTER
                    RETURNING RTNCODE
DISPLAY RTNCODE
IF RTNCODE = ZERO
THEN
  DISPLAY '正常終了'
  DISPLAY PRINTERNUM
  PERFORM VARYING IX1 FROM 1 BY 1 UNTIL IX1 > PRINTERNUM
    DISPLAY PRINTERNAME(IX1)
  END-PERFORM
ELSE
  DISPLAY 'エラー発生'
  DISPLAY ERRORMESSAGE
END-IF


GetTrayList関数

GetTrayList関数

出力先（スプールサーバ）とOS上のプリンタを指定し，そのプリンタのトレイ一覧を取得します。出力先を指定していない場合は，デフォルトの出力先として登録されたスプールサーバのOS上のプリンタのトレイ一覧を取得します。

なお，UNIX／Linux環境の場合，トレイ一覧の取得はサポートしていません。UNIX／Linux環境のEUR Server - Spool Serviceに対して，トレイ一覧の取得を実行した場合はエラーとなります。

形式

------------------宣言部------------------
01 EURPMPARAMDESTNAME.
  02 DESTNAME       PIC X(80) VALUE SPACE.
  02 FILLER         X(1) VALUE LOW-VALUE.
01 EURPMPARAMPRINTERNAME.
  02 PRINTERNAME    PIC X(80) VALUE SPACE.
  02 FILLER         X(1) VALUE LOW-VALUE.
01 EURPMPARAMTRAY.
  02 FILLER         PIC X(4) VALUE '0770'.
  02 FILLER         PIC X(1) VALUE LOW-VALUE.
  02 ERRORMESSAGE   PIC X(256) VALUE SPACE.
  02 FILLER         PIC X(1) VALUE LOW-VALUE.
  02 FILLER         PIC X(2) VALUE LOW-VALUE.
  02 TRAYNUM        PIC 9(9) COMP-X VALUE n.
  02 TRAYS          OCCURS n TIMES.
    03 TRAYNAME     PIC X(80) VALUE SPACE.
    03 FILLER       PIC X(1) VALUE LOW-VALUE.
    03 FILLER       PIC X(3) VALUE LOW-VALUE.
  02 PMSERVERADDR   PIC X(15) VALUE SPACE.
  02 FILLER         PIC X(1) VALUE LOW-VALUE.
  02 PMSERVERPORT   PIC S9(9) COMP-5 VALUE -1.
01 RTNCODE          PIC S9(9) BINARY.
------------------実行部------------------
call 'GetTrayList' USING BY REFERENCE EURPMPARAMDESTNAME
                                     EURPMPARAMPRINTERNAME
                                     EURPMPARAMTRAY
                           RETURNING RTNCODE.

パラメタ

DESTNAME

OS上のプリンタのトレイ一覧を取得するスプールサーバの出力先名を指定します。

PRINTERNAME

トレイ一覧を取得するOS上のプリンタ名を指定します。

TRAYNUM

パラメタTRAYSの繰り返し回数nを指定します。nには取得する一覧の最大数を指定してください。

トレイの数がn個を超える場合は，n個までの一覧が取得されます。

TRAYS

取得したトレイ一覧が格納される領域を指定します。nには取得する一覧の最大数を指定してください。詳細は戻り値TRAYSを参照してください。

PMSERVERADDR

帳票サーバのIPアドレスを255.255.255.255形式で指定します。

PMSERVERADDRパラメタを省略する場合は，空白を指定します。

PMSERVERPORT

帳票サーバのポート番号を指定します。

PMSERVERPORTパラメタを省略する場合は，-1を指定します。

戻り値

RTNCODE

終了コードが設定されます。終了コードについては，「10.4.1　エラー情報一覧」を参照してください。

ERRORMESSAGE

エラーが発生した場合，エラーメッセージとメッセージIDが設定されます。エラーメッセージについては，マニュアル「EUR メッセージ」を参照してください。

エラーが発生しなかった場合は，空白が設定されます。

TRAYNUM

取得されたトレイ数が格納されます。

TRAYS

パラメタTRAYNUMに設定されたn個分のトレイ情報を，戻り値TRAYNAMEに格納します。OS上のプリンタのトレイ数がn個に満たない場合は，戻り値TRAYNUMに取得された個数のトレイ情報が返され，戻り値TRAYNUM+1番目以降の領域は不定になります。OS上のプリンタのトレイ数がn個より多い場合は，パラメタTRAYNUMに指定したn個のトレイ情報が返されます。

TRAYNAME

OS上のプリンタのトレイ名が設定されます。

呼び出し例

OS上のプリンタのトレイ一覧を取得する，呼び出し例を次に示します。

------------------宣言部------------------
01 EURPMPARAMDESTNAME.
  02 DESTNAME       PIC X(80) VALUE SPACE.
  02 FILLER         X(1) VALUE LOW-VALUE.
01 EURPMPARAMPRINTERNAME.
  02 PRINTERNAME    PIC X(80) VALUE SPACE.
  02 FILLER         X(1) VALUE LOW-VALUE.
01 EURPMPARAMTRAY.
  02 FILLER         PIC X(4) VALUE '0770'.
  02 FILLER         PIC X(1) VALUE LOW-VALUE.
  02 ERRORMESSAGE   PIC X(256) VALUE SPACE.
  02 FILLER         PIC X(1) VALUE LOW-VALUE.
  02 FILLER         PIC X(2) VALUE LOW-VALUE.
  02 TRAYNUM        PIC 9(9) COMP-X VALUE 120.
  02 TRAYS          OCCURS 120 TIMES.
    03 TRAYNAME     PIC X(80) VALUE SPACE.
    03 FILLER       PIC X(1) VALUE LOW-VALUE.
    03 FILLER       PIC X(3) VALUE LOW-VALUE.
  02 PMSERVERADDR   PIC X(15) VALUE SPACE.
  02 FILLER         PIC X(1) VALUE LOW-VALUE.
  02 PMSERVERPORT   PIC S9(9) COMP-5 VALUE -1.
01 RTNCODE          PIC S9(9) BINARY.
------------------実行部------------------
DISPLAY '＜トレイ一覧(GetTrayList)＞'
MOVE 'SERVER1' TO DESTNAME
DISPLAY DESTNAME
MOVE 'PRINTER1' TO PRINTERNAME
DISPLAY PRINTERNAME
CALL ' GetTrayList ' USING BY REFERENCE EURPMPARAMDESTNAME
                                        EURPMPARAMPRINTERNAME
                                        EURPMPARAMTRAY
                     RETURNING RTNCODE
DISPLAY RTNCODE
IF RTNCODE = ZERO
THEN
  DISPLAY '正常終了'
  DISPLAY TRAYNUM
  PERFORM VARYING IX1 FROM 1 BY 1 UNTIL IX1 > TRAYNUM
    DISPLAY TRAYNAME (IX1)
  END-PERFORM
ELSE
  DISPLAY 'エラー発生'
  DISPLAY ERRORMESSAGE
END-IF


OutputEPFReport関数

OutputEPFReport関数

EPF形式ファイルを出力します。

EPF形式ファイルは，EUR Server - Adapter稼働マシンにEPFFILENAMEパラメタとEPFFILEPATHパラメタの指定値に従って出力されます。

出力先に指定したEPF形式ファイルがすでにある場合は，上書きされます。

形式

WORKING-STORAGE SECTION.
01 EURPMPARAM.
        02  FILLER                      PIC X(4) VALUE '0960'.
        02  PRINTSTARTPAGE              PIC 9(9) COMP-X.
        02  PRINTENDPAGE                PIC 9(9) COMP-X.
        02  REPORTSETFILE               PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  MULTIFORMINFO               PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  EPFFILENAME                 PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  REPORTSET.
          03  REPORTNAME                PIC X(256).
          03  FILLER                    PIC X(1) VALUE LOW-VALUE.
          03  MAPPINGDATA               PIC X(256).
          03  FILLER                    PIC X(1) VALUE LOW-VALUE.
          03  USERDEFDATA               PIC X(256).
          03  FILLER                    PIC X(1) VALUE LOW-VALUE.
        02  ERRORMESSAGE                PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  MAPPINGDATAPATH             PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  USERDEFDATAPATH             PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  REPORTSETFILEPATH           PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  REPORTFILEPATH              PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  MULTIFORMINFOPATH           PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  DOCINFOFILE                 PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  DOCINFOFILEPATH             PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  EPFFILEPATH                 PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  PAGENUMBERFORMAT            PIC X(80).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(3) VALUE LOW-VALUE.
        02  PRINTCOPIES                 PIC S9(9) COMP-5 VALUE -1.
        02  SORTPRINT                   PIC S9(9) COMP-5 VALUE -1.
        02  PAPERORIENTATION            PIC S9(9) COMP-5 VALUE -1.
        02  PRINTPAGENUMBER             PIC S9(9) COMP-5 VALUE -1.
        02  PAGENUMBERLOCATION          PIC S9(9) COMP-5 VALUE -1.
        02  FIRSTPAGENUMBER             PIC S9(9) COMP-5 VALUE -1.
        02  INITPAGENUMBER              PIC S9(9) COMP-5 VALUE -1.
        02  DBINFOFILENAME              PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  DBINFOFILEPATH              PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  PRINTERCLASSNAME            PIC X(80).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  REPLACEITEMCNTLFILENAME     PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  REPLACEITEMCNTLFILEPATH     PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(3) VALUE LOW-VALUE.
        02  PMSERVERADDR                PIC X(15) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  PMSERVERPORT                PIC S9(9) COMP-5 VALUE -1.
        02  PSENVFILENAME               PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  PSENVFILEPATH               PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(2) VALUE LOW-VALUE.
        02  PRINTDATEFILENAME           PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  PRINTDATEFILEPATH           PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(2) VALUE LOW-VALUE.
        02  SPOOLTITLE                  PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(3) VALUE LOW-VALUE.
01 RTNCODE                              PIC S9(9) BINARY.

call 'OutputEPFReport'  USING  EURPMPARAM
RETURNING  RTNCODE.

パラメタ

PRINTSTARTPAGE

出力開始ページを指定します。指定できる値は，0～999,999です。

PRINTSTARTPAGEパラメタを省略する場合は，0を指定します。PRINTSTARTPAGEパラメタの指定を省略した場合は，1ページから出力されます。

REPORTSETFILEパラメタを指定した場合，PRINTSTARTPAGEパラメタの指定は無視されます。

複数の帳票ファイルを指定した場合は，PRINTSTARTPAGEパラメタの指定に関係なく，指定した複数の帳票ファイルの全ページが出力されます。

PRINTENDPAGE

出力終了ページを指定します。指定できる値は，0～999,999です。

PRINTENDPAGEパラメタを省略する場合は，0を指定します。PRINTENDPAGEパラメタを省略した場合は，最終ページまで出力されます。

REPORTSETFILEパラメタを指定した場合，PRINTENDPAGEパラメタの指定は無視されます。

複数の帳票ファイルを指定した場合は，PRINTENDPAGEパラメタの指定に関係なく，指定した複数の帳票ファイルの全ページが出力されます。

REPORTSETFILE

帳票セット指定ファイル名を指定します。

REPORTSETFILEパラメタ，またはREPORTNAMEパラメタのどちらかは，必ず指定してください。

帳票セット指定ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

REPORTSETFILEパラメタを省略する場合は，空白を指定します。ただし，REPORTSETFILEパラメタを省略する場合は，REPORTSETパラメタは省略しないでください。

帳票セット指定ファイルは，EUR Server - Adapter稼働マシンに配置してください。

MULTIFORMINFO

複数様式情報定義ファイル名を指定します。複数様式で帳票を出力する場合は，必ず指定してください。

MULTIFORMINFOパラメタを省略する場合は，空白を指定します。

環境設定ファイル（EURPM.ini）でOPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，複数様式情報定義ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのMULTIキーで設定しているフォルダに格納しておいてください。

OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。パスは，MULTIFORMINFOPATHパラメタに指定することもできます。MULTIFORMINFOPATHパラメタにパスを指定しない場合は，次のことに注意してください。

  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのMULTIキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのMULTIキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのMULTIキーで設定しているフォルダにあるファイル名を指定してください。

複数様式情報定義ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

複数様式情報定義ファイルは，EUR Server Service稼働マシンに配置してください。

EPFFILENAME

出力するEPF形式ファイル名を指定します。EPF形式ファイルを出力する場合は，必ず指定してください。

EPF形式ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

EPF形式ファイルの拡張子は，*.epfです。EPF形式ファイル名は，拡張子を含めて指定してください。ただし，出力したEPF形式ファイルを使用してヘルパクライアント印刷するときは，次に示す拡張子でEPF形式ファイル名を指定してください。

  • EPF形式ファイルをプレビューする場合：*.epf
  • EPF形式ファイルをプリンタ印刷する場合：*.epp

REPORTSET

帳票セットの親項目です。

REPORTNAME

帳票ファイル名を指定します。帳票ファイル名（*.fms）を指定してください。

REPORTNAMEパラメタ，またはREPORTSETFILEパラメタのどちらかは，必ず指定してください。

REPORTNAMEパラメタを省略する場合は，空白を指定します。

環境設定ファイル（EURPM.ini）でOPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，帳票ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのFORMキーで設定しているフォルダに格納しておいてください。

OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。パスは，REPORTFILEPATHパラメタに指定することもできます。REPORTFILEPATHパラメタにパスを指定しない場合は，次のことに注意してください。

  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのFORMキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのFORMキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのFORMキーで設定しているフォルダにあるファイル名を指定してください。

帳票ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

帳票ファイルは，EUR Server Service稼働マシンに配置してください。

MAPPINGDATA

マッピングデータファイル名，または可変記号値定義ファイル名を指定します。

MAPPINGDATAパラメタには，REPORTNAMEパラメタで指定した帳票ファイルに対応するファイル名を指定します。なお，指定できるファイル名は，一つだけです。

MAPPINGDATAパラメタを省略する場合は，空白を指定します。

ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

マッピングデータファイルは，EUR Server - Adapter稼働マシンに配置してください。

USERDEFDATA

ユーザ定義データファイル名または可変記号値定義ファイル名を指定します。

USERDEFDATAパラメタには，REPORTNAMEパラメタで指定した帳票ファイルに対応するファイル名を指定します。指定するファイル名は，REPORTNAMEパラメタで指定したファイル名と同じ数を指定してください。

USERDEFDATAパラメタを省略する場合は，空白を指定します。

ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

ユーザ定義データファイルは，EUR Server - Adapter稼働マシンに配置してください。

MAPPINGDATAPATH

MAPPINGDATAパラメタまたは帳票セット指定ファイルで指定するマッピングデータファイルのパス，もしくは可変記号値定義ファイルのパスを指定します。

MAPPINGDATAパラメタをフルパスで指定した場合は，MAPPINGDATAPATHパラメタを指定する必要はありません。MAPPINGDATAPATHパラメタを省略する場合は，空白を指定します。

パスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

USERDEFDATAPATH

USERDEFDATAパラメタで指定するユーザ定義データファイルのパス，または可変記号値定義ファイルのパスを指定します。

USERDEFDATAパラメタをフルパスで指定した場合は，USERDEFDATAPATHパラメタを指定する必要はありません。USERDEFDATAPATHパラメタを省略する場合は，空白を指定します。

パスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

REPORTSETFILEPATH

REPORTSETFILEパラメタで指定する帳票セット指定ファイルのパスを指定します。

REPORTSETFILEパラメタをフルパスで指定した場合は，REPORTSETFILEPATHパラメタを指定する必要はありません。REPORTSETFILEPATHパラメタを省略する場合は，空白を指定します。

帳票セット指定ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

REPORTFILEPATH

REPORTNAMEパラメタで指定する帳票ファイルのパスを指定します。

REPORTNAMEパラメタをフルパスで指定した場合は，REPORTFILEPATHパラメタを指定する必要はありません。REPORTFILEPATHパラメタを省略する場合は，空白を指定します。

帳票ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

MULTIFORMINFOPATH

MULTIFORMINFOパラメタで指定する複数様式情報定義ファイルのパスを指定します。

MULTIFORMINFOパラメタをフルパスで指定した場合は，MULTIFORMINFOPATHパラメタを指定する必要はありません。MULTIFORMINFOPATHパラメタを省略する場合は，空白を指定します。

複数様式情報定義ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

DOCINFOFILE

文書情報設定ファイル名を指定します。

DOCINFOFILEパラメタを省略する場合は，空白を指定します。

環境設定ファイル（EURPM.ini）でOPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，文書情報設定ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのDOCINFOキーで設定しているフォルダに格納しておいてください。

OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。パスは，DOCINFOFILEPATHパラメタに指定することもできます。DOCINFOFILEPATHパラメタにパスを指定しない場合は，次のことに注意してください。

  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのDOCINFOキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのDOCINFOキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのDOCINFOキーで設定しているフォルダにあるファイル名を指定してください。

文書情報設定ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

文書情報設定ファイルは，EUR Server Service稼働マシンに配置してください。

DOCINFOFILEPATH

DOCINFOFILEパラメタで指定した文書情報設定ファイルのパスを指定します。

DOCINFOFILEパラメタをフルパスで指定した場合は，DOCINFOFILEPATHパラメタを指定する必要はありません。DOCINFOFILEPATHパラメタを省略する場合は，空白を指定します。

文書情報設定ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

EPFFILEPATH

EPFFILENAMEパラメタで指定したEPF形式ファイルのパスを指定します。

EPFFILENAMEパラメタをフルパスで指定した場合は，EPFFILEPATHパラメタを指定する必要はありません。EPFFILEPATHパラメタを省略する場合は，空白を指定します。

EPF形式ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

PAGENUMBERFORMAT

ページ番号のフォーマットを指定します。ページ番号を「*」，最終ページ番号を「$」で示して出力形式を指定します。

ページ番号および最終ページ番号を全角で表示したいときは全角の記号で，半角で表示したいときは半角の記号で指定します。

ページ番号のフォーマットが80バイトに満たない場合は，空白で埋めてください。

PAGENUMBERFORMATパラメタは，PRINTPAGENUMBERパラメタに1が指定されている場合だけ有効になります。ただし，MULTIFORMINFOパラメタを指定した場合は，PAGENUMBERFORMATパラメタの設定値は無視されます。

PAGENUMBERFORMATパラメタを省略する場合は，空白を指定します。

PRINTCOPIES

印刷部数を指定します。指定できる値は，1～99です。

PRINTCOPIESパラメタを省略する場合は，-1を指定します。PRINTCOPIESパラメタの指定を省略した場合は，1が仮定されます。

SORTPRINT

印刷部数の単位を指定します。

指定できる値を次に示します。

  • 0：部単位で出力します。
  • 1：ページ単位で出力します。

SORTPRINTパラメタを省略する場合は，-1を指定します。SORTPRINTパラメタの指定を省略した場合は，0が仮定されます。

複数帳票を出力する場合は，SORTPRINTパラメタの指定に関係なく0が仮定されます。

PAPERORIENTATION

用紙の向きを指定します。

指定できる値を次に示します。

  • 0：帳票を定義したときの情報に従います。
  • 1：用紙の向きを縦にして出力します。
  • 2：用紙の向きを横にして出力します。

PAPERORIENTATIONパラメタを省略する場合は，-1を指定します。PAPERORIENTATIONパラメタの指定を省略した場合は，0が仮定されます。

複数帳票を出力する場合は，PAPERORIENTATIONパラメタの指定に関係なく，0が仮定されます。

PRINTPAGENUMBER

余白へのページ番号印刷を指定します。

指定できる値を次に示します。

  • 0：余白へのページ番号は出力しません。
  • 1：余白へのページ番号を出力します。

PRINTPAGENUMBERパラメタを省略する場合は，-1を指定します。PRINTPAGENUMBERパラメタの指定を省略した場合は，0が仮定されます。

ただし，MULTIFORMINFOパラメタを指定した場合は，PRINTPAGENUMBERパラメタの設定値は無視されます。

PAGENUMBERLOCATION

余白へのページ番号の印刷位置を指定します。

PAGENUMBERLOCATIONパラメタは，PRINTPAGENUMBERパラメタに1が指定されている場合だけ有効になります。ただし，MULTIFORMINFOパラメタを指定した場合は，PAGENUMBERLOCATIONパラメタの設定値は無視されます。

指定できる値を次に示します。

  • 1：ページ番号を左上に出力します。
  • 2：ページ番号を中央上に出力します。
  • 3：ページ番号を右上に出力します。
  • 4：ページ番号を左下に出力します。
  • 5：ページ番号を中央下に出力します。
  • 6：ページ番号を右下に出力します。

PAGENUMBERLOCATIONパラメタを省略する場合は，-1を指定します。

FIRSTPAGENUMBER

ページ番号の初期値を指定します。指定できる値は，1～999,999です。

FIRSTPAGENUMBERパラメタは，PRINTPAGENUMBERパラメタに1が指定されている場合だけ有効になります。ただし，MULTIFORMINFOパラメタを指定した場合は，FIRSTPAGENUMBERパラメタの設定値は無視されます。

FIRSTPAGENUMBERパラメタを省略する場合は，-1を指定します。FIRSTPAGENUMBERパラメタの指定を省略した場合は，1が仮定されます。

INITPAGENUMBER

改ページのキーが設定されている場合，そのキーがブレイクするごとにページ番号の開始番号を初期化するかどうかを指定します。

指定できる値を次に示します。

  • 0：初期化しません。
  • 1：初期化します。

INITPAGENUMBERパラメタを省略する場合は，-1を指定します。INITPAGENUMBERパラメタの指定を省略した場合は，出力する帳票の属性に従います。帳票の属性の初期値は，0が仮定されます。

ただし，MULTIFORMINFOパラメタを指定した場合は，INITPAGENUMBERパラメタの設定値は無視されます。

DBINFOFILENAME

接続情報ファイル名を指定します。

DBINFOFILENAMEパラメタを省略する場合は，空白を指定します。

環境設定ファイル（EURPM.ini）でOPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，接続情報ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのDBINFOキーで設定しているフォルダに格納しておいてください。

OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。パスは，DBINFOFILEPATHパラメタに指定することもできます。DBINFOFILEPATHパラメタにパスを指定しない場合は，次のことに注意してください。

  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのDBINFOキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのDBINFOキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのDBINFOキーで設定しているフォルダにあるファイル名を指定してください。

接続情報ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

接続情報ファイルは，EUR Server Service稼働マシンに配置してください。

DBINFOFILEPATH

DBINFOFILENAMEパラメタで指定した接続情報ファイルのパスを指定します。

DBINFOFILENAMEパラメタをフルパスで指定した場合は，DBINFOFILEPATHパラメタを指定する必要はありません。DBINFOFILEPATHパラメタを省略する場合は，空白を指定します。

接続情報ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

PRINTERCLASSNAME

プリンタクラス名を指定します。

指定したプリンタクラス名情報は，出力するEPF形式ファイルに設定されます。

次のことに注意して，プリンタクラス名を指定してください。

  • 指定するプリンタクラス名が，80バイトに満たない場合は，空白で埋めてください。
  • プリンタクラス名には「"」および「,」を含めないでください。
  • プリンタクラス名に「EUR_DELIVERY_PRINT_OUTPUT_DEFAULT_PRINTER_CLASS_________________________________」は使用できません。

PRINTERCLASSNAMEパラメタを省略する場合は，空白を設定します。

PRINTERCLASSNAMEパラメタを省略したときは，EPF形式ファイルのプリンタクラス名情報は未設定となります。

REPLACEITEMCNTLFILENAME

置き換え表管理情報ファイル名を指定します。

環境設定ファイル（EURPM.ini）でOPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，置き換え表管理情報ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのREPLACEITEMキーで設定しているフォルダに格納しておいてください。

OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。パスは，REPLACEITEMCNTLFILEPATHパラメタに指定することもできます。REPLACEITEMCNTLFILEPATHパラメタにパスを指定しない場合は，次のことに注意してください。

  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのREPLACEITEMキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのREPLACEITEMキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのREPLACEITEMキーで設定しているフォルダにあるファイル名を指定してください。

置き換え表管理情報ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

REPLACEITEMCNTLFILENAMEパラメタを省略する場合は，空白を指定します。

置き換え表管理情報ファイルは，EUR Server Service稼働マシンに配置してください。

REPLACEITEMCNTLFILEPATH

REPLACEITEMCNTLFILENAMEパラメタで指定した置き換え表管理情報ファイルのパスを指定します。

REPLACEITEMCNTLFILENAMEパラメタをフルパスで指定した場合は，REPLACEITEMCNTLFILEPATHパラメタを指定する必要はありません。REPLACEITEMCNTLFILEPATHパラメタを省略する場合は，空白を指定します。

置き換え表管理情報ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

PMSERVERADDR

帳票サーバのIPアドレスを255.255.255.255形式で指定します。

PMSERVERADDRパラメタを省略する場合は，空白を指定します。

PMSERVERPORT

帳票サーバのポート番号を指定します。

PMSERVERPORTパラメタを省略する場合は，-1を指定します。

PSENVFILENAME

EUR Print Serviceの動作環境を印刷ジョブごとに変更する場合に，EUR Server Serviceの環境設定ファイル（EURPS_ENV）名を指定します。

EUR Server Serviceの環境設定ファイル（EURPM.ini）で，OPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，PSENVFILENAMEパラメタは，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのPSENVキーで設定しているフォルダに格納しておいてください。

OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。

パスは，PSENVFILEPATHパラメタに指定することもできます。PSENVFILEPATHパラメタにパスを指定しない場合は，次のことに注意してください。

  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPSENVキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPSENVキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPSENVキーで設定しているフォルダにあるファイル名を指定してください。

EUR Server Serviceの環境設定ファイル（EURPS_ENV）名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

PSENVFILENAMEパラメタを省略する場合は，空白を指定します。

EUR Server Serviceの環境設定ファイル（EURPS_ENV）は，EUR Server Service稼働マシンに配置してください。

PSENVFILEPATH

PSENVFILENAMEパラメタで指定したEUR Server Serviceの環境設定ファイル（EURPS_ENV）のパスを指定します。

PSENVFILENAMEパラメタをフルパスで指定した場合は，PSENVFILEPATHパラメタを指定する必要はありません。PSENVFILEPATHパラメタを省略する場合は，空白を指定します。

EUR Server Serviceの環境設定ファイル（EURPS_ENV）のパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

PRINTDATEFILENAME

印刷日時出力定義ファイル名を指定します。

EUR Server Serviceの環境設定ファイル（EURPM.ini）で，OPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，PRINTDATEFILENAMEパラメタは，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのPRINTDATEキーで設定しているフォルダに格納しておいてください。

OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。

パスは，PRINTDATEFILEPATHパラメタに指定することもできます。PRINTDATEFILEPATHパラメタにパスを指定しない場合は，次のことに注意してください。

  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPRINTDATEキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPRINTDATEキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPRINTDATEキーで設定しているフォルダにあるファイル名を指定してください。

印刷日時出力定義ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

PRINTDATEFILENAMEパラメタを省略する場合は，空白を指定します。

印刷日時出力定義ファイルは，EUR Server Service稼働マシンに配置してください。

PRINTDATEFILEPATH

PRINTDATEFILENAMEパラメタで指定した印刷日時出力定義ファイルのパスを指定します。

PRINTDATEFILENAMEパラメタをフルパスで指定した場合は，PRINTDATEFILEPATHパラメタを指定する必要はありません。PRINTDATEFILEPATHパラメタを省略する場合は，空白を指定します。

印刷日時出力定義ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

SPOOLTITLE

次のことに注意して，スプールタイトルを指定してください。

  • 指定するスプールタイトルが，256バイトに満たない場合は，空白で埋めてください。
  • スプールタイトルには「"」および「,」を含めないでください。

SPOOLTITLEパラメタを省略する場合は，空白を設定します。

SPOOLTITLEパラメタを省略したときは，印刷時のスプールタイトルには，文書情報設定ファイルのTITLEキーの指定値，または帳票ファイル名が出力されます。

戻り値

RTNCODE

終了コードが設定されます。終了コードについては，「10.4.1　エラー情報一覧」を参照してください。

ERRORMESSAGE

エラーが発生した場合，エラーメッセージとメッセージIDが設定されます。エラーメッセージについては，マニュアル「EUR メッセージ」を参照してください。

エラーが発生しなかった場合は，空白が設定されます。

エラーメッセージ

EUR Print Serviceと連携して使用するパラメタでエラーが発生した場合は，次のエラーメッセージが出力されます。メッセージが表示されたときは，EUR Print Serviceのイベントログ，またはeurpsログを参照してください。

メッセージID | メッセージ
KEEY225-E | EPF形式ファイル出力処理でエラーが発生しました。（337）


OutputEURReport関数

OutputEURReport関数

EUR形式ファイルを出力します。

EUR形式ファイルは，EUR Server - Adapter稼働マシンにEURFILENAMEパラメタとEURFILEPATHパラメタの指定値に従って出力されます。

出力先に指定したEUR形式ファイルがすでにある場合は，上書きされます。

形式

WORKING-STORAGE SECTION.
01 EURPMPARAM.
        02  FILLER                      PIC X(4) VALUE '0960'.
        02  REPORTSETFILE               PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  MULTIFORMINFO               PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  EURFILENAME                 PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  REPORTSET.
          03  REPORTNAME                PIC X(256).
          03  FILLER                    PIC X(1) VALUE LOW-VALUE.
          03  MAPPINGDATA               PIC X(256).
          03  FILLER                    PIC X(1) VALUE LOW-VALUE.
          03  USERDEFDATA               PIC X(256).
          03  FILLER                    PIC X(1) VALUE LOW-VALUE.
        02  ERRORMESSAGE                PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  MAPPINGDATAPATH             PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  USERDEFDATAPATH             PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  REPORTSETFILEPATH           PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  REPORTFILEPATH              PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  MULTIFORMINFOPATH           PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  DOCINFOFILE                 PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  DOCINFOFILEPATH             PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  EURFILEPATH                 PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  DBINFOFILENAME              PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  DBINFOFILEPATH              PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  REPLACEITEMCNTLFILENAME     PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  REPLACEITEMCNTLFILEPATH     PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  PMSERVERADDR                PIC X(15) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  PMSERVERPORT                PIC S9(9) COMP-5 VALUE -1.
        02  PSENVFILENAME               PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  PSENVFILEPATH               PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(2) VALUE LOW-VALUE.
        02  SPOOLTITLE                  PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(3) VALUE LOW-VALUE.
01 RTNCODE                              PIC S9(9) BINARY.

call 'OutputEURReport'  USING  EURPMPARAM
RETURNING  RTNCODE.

パラメタ

REPORTSETFILE

帳票セット指定ファイル名を指定します。

REPORTSETFILEパラメタ，またはREPORTNAMEパラメタのどちらかは，必ず指定してください。

帳票セット指定ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

REPORTSETFILEパラメタを省略する場合は，空白を指定します。ただし，REPORTSETFILEパラメタを省略する場合は，REPORTSETパラメタは省略しないでください。

帳票セット指定ファイルは，EUR Server - Adapter稼働マシンに配置してください。

MULTIFORMINFO

複数様式情報定義ファイル名を指定します。複数様式で帳票を出力する場合は，必ず指定してください。

MULTIFORMINFOパラメタを省略する場合は，空白を指定します。

環境設定ファイル（EURPM.ini）でOPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，複数様式情報定義ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのMULTIキーで設定しているフォルダに格納しておいてください。

OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。パスは，MULTIFORMINFOPATHパラメタに指定することもできます。MULTIFORMINFOPATHパラメタにパスを指定しない場合は，次のことに注意してください。

  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのMULTIキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのMULTIキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのMULTIキーで設定しているフォルダにあるファイル名を指定してください。

複数様式情報定義ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

複数様式情報定義ファイルは，EUR Server Service稼働マシンに配置してください。

EURFILENAME

出力するEUR形式ファイル名を指定します。EUR形式ファイルを出力する場合は，必ず指定してください。

EUR形式ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

REPORTSET

帳票セットの親項目です。

REPORTNAME

帳票ファイル名を指定します。帳票ファイル名（*.fms）を指定してください。

REPORTNAMEパラメタ，またはREPORTSETFILEパラメタのどちらかは，必ず指定してください。

REPORTNAMEパラメタを省略する場合は，空白を指定します。

環境設定ファイル（EURPM.ini）でOPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，帳票ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのFORMキーで設定しているフォルダに格納しておいてください。

OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。パスは，REPORTFILEPATHパラメタに指定することもできます。REPORTFILEPATHパラメタにパスを指定しない場合は，次のことに注意してください。

  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのFORMキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのFORMキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのFORMキーで設定しているフォルダにあるファイル名を指定してください。

帳票ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

帳票ファイルは，EUR Server Service稼働マシンに配置してください。

MAPPINGDATA

マッピングデータファイル名，または可変記号値定義ファイル名を指定します。

MAPPINGDATAパラメタには，REPORTNAMEパラメタで指定した帳票ファイルに対応するファイル名を指定します。なお，指定できるファイル名は，一つだけです。

MAPPINGDATAパラメタを省略する場合は，空白を指定します。

ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

マッピングデータファイルは，EUR Server - Adapter稼働マシンに配置してください。

USERDEFDATA

ユーザ定義データファイル名または可変記号値定義ファイル名を指定します。

USERDEFDATAパラメタには，REPORTNAMEパラメタで指定した帳票ファイルに対応するファイル名を指定します。指定するファイル名は，REPORTNAMEパラメタで指定したファイル名と同じ数を指定してください。

USERDEFDATAパラメタを省略する場合は，空白を指定します。

ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

ユーザ定義データファイルは，EUR Server - Adapter稼働マシンに配置してください。

MAPPINGDATAPATH

MAPPINGDATAパラメタまたは帳票セット指定ファイルで指定するマッピングデータファイルのパス，もしくは可変記号値定義ファイルのパスを指定します。

MAPPINGDATAパラメタをフルパスで指定した場合は，MAPPINGDATAPATHパラメタを指定する必要はありません。MAPPINGDATAPATHパラメタを省略する場合は，空白を指定します。

パスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

USERDEFDATAPATH

USERDEFDATAパラメタで指定するユーザ定義データファイルのパス，または可変記号値定義ファイルのパスを指定します。

USERDEFDATAパラメタをフルパスで指定した場合は，USERDEFDATAPATHパラメタを指定する必要はありません。USERDEFDATAPATHパラメタを省略する場合は，空白を指定します。

パスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

REPORTSETFILEPATH

REPORTSETFILEパラメタで指定する帳票セット指定ファイルのパスを指定します。

REPORTSETFILEパラメタをフルパスで指定した場合は，REPORTSETFILEPATHパラメタを指定する必要はありません。REPORTSETFILEPATHパラメタを省略する場合は，空白を指定します。

帳票セット指定ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

REPORTFILEPATH

REPORTNAMEパラメタで指定する帳票ファイルのパスを指定します。指定されたファイルのパスは，REPORTNAMEパラメタで指定したファイルのパスとなります。

REPORTNAMEパラメタをフルパスで指定した場合は，REPORTFILEPATHパラメタを指定する必要はありません。REPORTFILEPATHパラメタを省略する場合は，空白を指定します。

帳票ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

MULTIFORMINFOPATH

MULTIFORMINFOパラメタで指定する複数様式情報定義ファイルのパスを指定します。指定されたファイルのパスは，MULTIFORMINFOパラメタで指定したファイルのパスとなります。

MULTIFORMINFOパラメタをフルパスで指定した場合は，MULTIFORMINFOPATHパラメタを指定する必要はありません。MULTIFORMINFOPATHパラメタを省略する場合は，空白を指定します。

複数様式情報定義ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

DOCINFOFILE

文書情報設定ファイル名を指定します。

DOCINFOFILEパラメタを省略する場合は，空白を指定します。

環境設定ファイル（EURPM.ini）でOPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，文書情報設定ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのDOCINFOキーで設定しているフォルダに格納しておいてください。

OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。パスは，DOCINFOFILEPATHパラメタに指定することもできます。DOCINFOFILEPATHパラメタにパスを指定しない場合は，次のことに注意してください。

  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのDOCINFOキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのDOCINFOキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのDOCINFOキーで設定しているフォルダにあるファイル名を指定してください。

文書情報設定ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

文書情報設定ファイルは，EUR Server Service稼働マシンに配置してください。

DOCINFOFILEPATH

DOCINFOFILEパラメタで指定した文書情報設定ファイルのパスを指定します。指定されたファイルのパスは，DOCINFOFILEパラメタで指定したファイルのパスとなります。

DOCINFOFILEパラメタをフルパスで指定した場合は，DOCINFOFILEPATHパラメタを指定する必要はありません。DOCINFOFILEPATHパラメタを省略する場合は，空白を指定します。

文書情報設定ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

EURFILEPATH

EURFILENAMEパラメタで指定したEUR形式ファイルのパスを指定します。

EUR形式ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

EURFILENAMEパラメタをフルパスで指定した場合は，このパラメタを指定する必要はありません。このパラメタを省略する場合は，空白を指定します。

DBINFOFILENAME

接続情報ファイル名を指定します。

DBINFOFILENAMEパラメタを省略する場合は，空白を指定します。

環境設定ファイル（EURPM.ini）でOPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，接続情報ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのDBINFOキーで設定しているフォルダに格納しておいてください。

OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。パスは，DBINFOFILEPATHパラメタに指定することもできます。DBINFOFILEPATHパラメタにパスを指定しない場合は，次のことに注意してください。

  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのDBINFOキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのDBINFOキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのDBINFOキーで設定しているフォルダにあるファイル名を指定してください。

接続情報ファイル名

を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

接続情報ファイルは，EUR Server Service稼働マシンに配置してください。

DBINFOFILEPATH

DBINFOFILENAMEパラメタで指定した接続情報ファイルのパスを指定します。

DBINFOFILENAMEパラメタをフルパスで指定した場合は，DBINFOFILEPATHパラメタを指定する必要はありません。DBINFOFILEPATHパラメタを省略する場合は，空白を指定します。

接続情報ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

REPLACEITEMCNTLFILENAME

置き換え表管理情報ファイル名を指定します。

環境設定ファイル（EURPM.ini）でOPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，置き換え表管理情報ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのREPLACEITEMキーで設定しているフォルダに格納しておいてください。

OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。パスは，REPLACEITEMCNTLFILEPATHパラメタに指定することもできます。REPLACEITEMCNTLFILEPATHパラメタにパスを指定しない場合は，次のことに注意してください。

  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのREPLACEITEMキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのREPLACEITEMキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのREPLACEITEMキーで設定しているフォルダにあるファイル名を指定してください。

置き換え表管理情報ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

REPLACEITEMCNTLFILENAMEパラメタを省略する場合は，空白を指定します。

置き換え表管理情報ファイルは，EUR Server Service稼働マシンに配置してください。

REPLACEITEMCNTLFILEPATH

REPLACEITEMCNTLFILENAMEパラメタで指定した置き換え表管理情報ファイルのパスを指定します。

REPLACEITEMCNTLFILENAMEパラメタをフルパスで指定した場合は，REPLACEITEMCNTLFILEPATHパラメタを指定する必要はありません。REPLACEITEMCNTLFILEPATHパラメタを省略する場合は，空白を指定します。

置き換え表管理情報ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

PMSERVERADDR

帳票サーバのIPアドレスを255.255.255.255形式で指定します。

PMSERVERADDRパラメタを省略する場合は，空白を指定します。

PMSERVERPORT

帳票サーバのポート番号を指定します。

PMSERVERPORTパラメタを省略する場合は，-1を指定します。

PSENVFILENAME

EUR Print Serviceの動作環境を印刷ジョブごとに変更する場合に，EUR Server Serviceの環境設定ファイル（EURPS_ENV）名を指定します。

EUR Server Serviceの環境設定ファイル（EURPM.ini）で，OPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，PSENVFILENAMEパラメタは，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのPSENVキーで設定しているフォルダに格納しておいてください。

OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。

パスは，PSENVFILEPATHパラメタに指定することもできます。PSENVFILEPATHパラメタにパスを指定しない場合は，次のことに注意してください。

  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPSENVキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPSENVキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPSENVキーで設定しているフォルダにあるファイル名を指定してください。

EUR Server Serviceの環境設定ファイル（EURPS_ENV）名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

PSENVFILENAMEパラメタを省略する場合は，空白を指定します。

EUR Server Serviceの環境設定ファイル（EURPS_ENV）は，EUR Server Service稼働マシンに配置してください。

PSENVFILEPATH

PSENVFILENAMEパラメタで指定したEUR Server Serviceの環境設定ファイル（EURPS_ENV）のパスを指定します。

PSENVFILENAMEパラメタをフルパスで指定した場合は，PSENVFILEPATHパラメタを指定する必要はありません。PSENVFILEPATHパラメタを省略する場合は，空白を指定します。

EUR Server Serviceの環境設定ファイル（EURPS_ENV）のパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

SPOOLTITLE

次のことに注意して，スプールタイトルを指定してください。

  • 指定するスプールタイトルが，256バイトに満たない場合は，空白で埋めてください。
  • スプールタイトルには「"」および「,」を含めないでください。

SPOOLTITLEパラメタを省略する場合は，空白を設定します。

SPOOLTITLEパラメタを省略したときは，印刷時のスプールタイトルには，文書情報設定ファイルのTITLEキーの指定値が出力されます。TITILEキーを設定していないときは，次に示す表示形式で出力されます。

  • 単一様式帳票の場合
    「HITACHI Report - EUR形式ファイル名（拡張子なし）」
  • 複数の帳票セットを指定した帳票，または複数様式を指定した帳票の場合
    「EUR形式ファイル名（拡張子なし）」

戻り値

RTNCODE

終了コードが設定されます。終了コードについては，「10.4.1　エラー情報一覧」を参照してください。

ERRORMESSAGE

エラーが発生した場合，エラーメッセージとメッセージIDが設定されます。エラーメッセージについては，マニュアル「EUR メッセージ」を参照してください。

エラーが発生しなかった場合は，空白が設定されます。

エラーメッセージ

EUR Print Serviceと連携して使用するパラメタでエラーが発生した場合は，次のエラーメッセージが出力されます。メッセージが表示されたときは，EUR Print Serviceのイベントログ，またはeurpsログを参照してください。

メッセージID | メッセージ
KEEY243-E | EUR形式ファイル出力処理でエラーが発生しました。（337）


OutputMergeEPFReport関数

OutputMergeEPFReport関数

複数のEPF形式ファイルを一つのEPF形式ファイルに統合して出力します。

出力先に指定したEPF形式ファイルがすでにある場合は，上書きされます。

形式

WORKING-STORAGE SECTION.
01 EURPMPARAM.
        02  FILLER                      PIC X(4) VALUE '0810'.
        02  PRINTCOPIES                 PIC S9(9) COMP-5 VALUE -1.
        02  SORTPRINT                   PIC S9(9) COMP-5 VALUE -1.
        02  PAPERORIENTATION            PIC S9(9) COMP-5 VALUE -1.
        02  MERGEEPFFILEPATH            PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  EPFFILENAME                 PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  EPFFILEPATH                 PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  SPOOLTITLE                  PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  PRINTERCLASSNAME            PIC X(80).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  ERRORMESSAGE                PIC X(256) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  PMSERVERADDR                PIC X(15) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(2) VALUE LOW-VALUE.
        02  PMSERVERPORT                PIC S9(9) COMP-5 VALUE -1.
        02  EPFFILESSIZE                PIC S9(9) COMP-X VALUE n.
        02  EPFFILES                    OCCURS n TIMES.
          03  MERGEEPFFILENAME          PIC X(256).
          03  FILLER                    PIC X(1) VALUE LOW-VALUE.
          03  FILLER                    PIC X(3) VALUE LOW-VALUE.
01 RTNCODE                              PIC S9(9) BINARY.

call 'OutputMergeEPFReport'  USING  EURPMPARAM
RETURNING  RTNCODE.

パラメタ

PRINTCOPIES

印刷部数を指定します。指定できる値は，1～99です。

PRINTCOPIESパラメタを省略する場合は，-1を指定します。PRINTCOPIESパラメタの指定を省略した場合は，1が仮定されます。

SORTPRINT

印刷部数の単位を指定します。

指定できる値を次に示します。

  • 0：部単位で出力します。
  • 1：ページ単位で出力します。

SORTPRINTパラメタを省略する場合は，-1を指定します。SORTPRINTパラメタの指定を省略した場合は，0が仮定されます。

PAPERORIENTATION

用紙の向きを指定します。

指定できる値を次に示します。

  • 0：統合するEPF形式ファイルのページごとの属性に従います。
  • 1：用紙の向きを縦にして出力します。
  • 2：用紙の向きを横にして出力します。

PAPERORIENTATIONパラメタを省略する場合は，-1を指定します。PAPERORIENTATIONパラメタの指定を省略した場合は，0が仮定されます。

MERGEEPFFILEPATH

MERGEEPFFILENAMEパラメタで指定したEPF形式ファイルのパスを指定します。

MERGEEPFFILENAMEパラメタをフルパスで指定した場合は，MERGEEPFFILEPATHパラメタを指定する必要はありません。

MERGEEPFFILEPATHパラメタを省略したい場合は，空白を指定します。

EPF形式ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

EPFFILENAME

出力するEPF形式ファイル名を指定します。必ず指定してください。

EPF形式ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

EPF形式ファイルの拡張子は，*.epfです。EPF形式ファイル名は，拡張子を含めて指定してください。ただし，出力したEPF形式ファイルを使用してヘルパクライアント印刷するときは，次に示す拡張子でEPF形式ファイル名を指定してください。

  • EPF形式ファイルをプレビューする場合：*.epf
  • EPF形式ファイルをプリンタ印刷する場合：*.epp

EPFFILEPATH

EPFFILENAMEパラメタで指定したEPF形式ファイルのパスを指定します。指定されたファイルのパスは，EPFFILENAMEパラメタで指定したファイルのパスとなります。

EPFFILENAMEパラメタをフルパスで指定した場合は，EPFFILEPATHパラメタを指定する必要はありません。EPFFILEPATHパラメタを省略する場合は，空白を指定します。

EPF形式ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

SPOOLTITLE

次のことに注意して，スプールタイトルを指定してください。

  • 指定するスプールタイトルが，256バイトに満たない場合は，空白で埋めてください。
  • スプールタイトルには「"」および「,」を含めないでください。

SPOOLTITLEパラメタを省略する場合は，空白を設定します。

SPOOLTITLEパラメタを省略したときは，統合後のEPF形式ファイルのスプールタイトル情報は未設定となります。スプールタイトル情報が未設定の場合，印刷時のスプールタイトルには最初に指定するEPF形式ファイルの帳票ファイル名が出力されます。

PRINTERCLASSNAME

クライアントプリンタクラス定義ファイルに設定してあるクライアントプリンタクラス名を指定します。ただし，統合後のEPF形式ファイルをクライアントPCに配布して印刷する場合は指定しないでください。

指定したプリンタクラス名情報は，統合して出力するEPF形式ファイルに設定されます。

次のことに注意して，プリンタクラス名を指定してください。

  • 指定するプリンタクラス名が，80バイトに満たない場合は，空白で埋めてください。
  • プリンタクラス名には「"」および「,」を含めないでください。
  • プリンタクラス名に「EUR_DELIVERY_PRINT_OUTPUT_DEFAULT_PRINTER_CLASS_________________________________」は使用できません。

PRINTERCLASSNAMEパラメタを省略する場合は，空白を設定します。

PRINTERCLASSNAMEパラメタを省略したときは，統合対象のEPF形式ファイルにプリンタクラス名情報が設定されていても，統合後のEPF形式ファイルのプリンタクラス名情報は未設定となります。

PMSERVERADDR

帳票サーバのIPアドレスを255.255.255.255形式で指定します。

PMSERVERADDRパラメタを省略する場合は，空白を指定します。

PMSERVERPORT

帳票サーバのポート番号を指定します。

PMSERVERPORTパラメタを省略する場合は，-1を指定します。

EPFFILESSIZE

統合対象のEPF形式ファイルの最大数を，2～10,000の範囲で指定します。必ず指定してください。

なお，EPFFILESSIZEパラメタに指定した値と同じ値を，EPFFILESパラメタの配列数に設定してください。

EPFFILES

統合対象のEPF形式ファイル名情報を設定します。

EPFFILESパラメタの配列数nには，EPFFILESSIZEパラメタに指定した値と同じ値（統合対象のEPF形式ファイルの最大数）を設定してください。

MERGEEPFFILENAME

統合対象のEPF形式ファイル名を指定します。必ず指定してください。

EPF形式ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

EPF形式ファイルの拡張子は，*.epfです。EPF形式ファイル名は，拡張子を含めて指定してください。

戻り値

RTNCODE

終了コードが設定されます。終了コードについては，「10.4.1　エラー情報一覧」を参照してください。

ERRORMESSAGE

エラーが発生した場合，エラーメッセージとメッセージIDが設定されます。エラーメッセージについては，マニュアル「EUR メッセージ」を参照してください。

エラーが発生しなかった場合は，空白が設定されます。


OutputPDFReport関数

OutputPDFReport関数

PDF形式ファイルを出力します。

PDF形式ファイルは，EUR Server Service稼働マシンまたはEUR Server - Adapter稼働マシンに，FILEOUTPUTDESTINATIONパラメタ，PDFFILENAMEパラメタ，およびPDFFILEPATHパラメタの指定値に従って出力されます。

出力先に指定したファイルがすでにある場合は，上書きされます。

ただし，PDF仕分け定義ファイル（DISTRIBUTEFILENAMEパラメタ）が指定されている場合は，PDF仕分け定義ファイルに記述されている出力先ファイル名に従って，EUR Server Serviceが稼働するマシンにPDF形式ファイルを出力します。

PDF仕分け出力の場合，出力先のPDF形式ファイルがすでにある場合は上書きしないでエラーになります。

形式

WORKING-STORAGE SECTION.
01 EURPMPARAM.
        02  FILLER                      PIC X(4) VALUE '0830'.
        02  SERVERNAME                  PIC X(80).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(3) VALUE LOW-VALUE.
        02  PRINTSTARTPAGE              PIC 9(9) COMP-X.
        02  PRINTENDPAGE                PIC 9(9) COMP-X.
        02  REPORTSETFILE               PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  MULTIFORMINFO               PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  DOCBOOKMARKFILE             PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  PDFFILENAME                 PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  REPORTSET.
          03  REPORTNAME                PIC X(256).
          03  FILLER                    PIC X(1) VALUE LOW-VALUE.
          03  MAPPINGDATA               PIC X(256).
          03  FILLER                    PIC X(1) VALUE LOW-VALUE.
          03  USERDEFDATA               PIC X(256).
          03  FILLER                    PIC X(1) VALUE LOW-VALUE.
          03  BOOKMARKFILE              PIC X(256).
          03  FILLER                    PIC X(1) VALUE LOW-VALUE.
        02  ERRORMESSAGE                PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  MAPPINGDATAPATH             PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  USERDEFDATAPATH             PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  BOOKMARKFILEPATH            PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  REPORTSETFILEPATH           PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  CRYPTOFILENAME              PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  CRYPTOFILEPATH              PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  DOCINFOFILE                 PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  DOCINFOFILEPATH             PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  REPORTFILEPATH              PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  MULTIFORMINFOPATH           PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  PDFFILEPATH                 PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  PAGENUMBERFORMAT            PIC X(80).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(3) VALUE LOW-VALUE.
        02  PRINTPAGENUMBER             PIC S9(9) COMP-5 VALUE -1.
        02  PAGENUMBERLOCATION          PIC S9(9) COMP-5 VALUE -1.
        02  FIRSTPAGENUMBER             PIC S9(9) COMP-5 VALUE -1.
        02  INITPAGENUMBER              PIC S9(9) COMP-5 VALUE -1.
        02  CRYPTO                      PIC S9(9) COMP-5 VALUE -1.
        02  DBINFOFILENAME              PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  DBINFOFILEPATH              PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  ENCRYPTIONPASSWORDKEY       PIC X(32).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  REPLACEITEMCNTLFILENAME     PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  REPLACEITEMCNTLFILEPATH     PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  DISTRIBUTEFILENAME          PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  DISTRIBUTEFILEPATH          PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  SCRIPTCNTLFILENAME          PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  SCRIPTCNTLFILEPATH          PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  VIEWERPREFERENCEFILENAME    PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  VIEWERPREFERENCEFILEPATH    PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  PMSERVERADDR                PIC X(15) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  PMSERVERPORT                PIC S9(9) COMP-5 VALUE -1.
        02  PSENVFILENAME               PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  PSENVFILEPATH               PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(2) VALUE LOW-VALUE.
        02  FILEOUTPUTDESTINATION       PIC S9(9) COMP-X VALUE -1.
01 RTNCODE                              PIC S9(9) BINARY.

call 'OutputPDFReport'  USING  EURPMPARAM
RETURNING  RTNCODE.

パラメタ

SERVERNAME

指定しても無視されます。

PRINTSTARTPAGE

出力開始ページを指定します。指定できる値は，0～999,999です。

PRINTSTARTPAGEパラメタを省略する場合は，0を指定します。PRINTSTARTPAGEパラメタの指定を省略した場合は，1ページから出力されます。

REPORTSETFILEパラメタを指定した場合，PRINTSTARTPAGEパラメタの指定は無視されます。

複数の帳票ファイルを指定した場合は，PRINTSTARTPAGEパラメタの指定に関係なく，指定した複数の帳票ファイルの全ページが出力されます。

PRINTENDPAGE

出力終了ページを指定します。指定できる値は，0～999,999です。

PRINTENDPAGEパラメタを省略する場合は，0を指定します。PRINTENDPAGEパラメタを省略した場合は，最終ページまで出力されます。

REPORTSETFILEパラメタを指定した場合，PRINTENDPAGEパラメタの指定は無視されます。

複数の帳票ファイルを指定した場合は，PRINTENDPAGEパラメタの指定に関係なく，指定した複数の帳票ファイルの全ページが出力されます。

REPORTSETFILE

帳票セット指定ファイル名を指定します。

REPORTSETFILEパラメタ，またはREPORTNAMEパラメタのどちらかは，必ず指定してください。

帳票セット指定ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

REPORTSETFILEパラメタを省略する場合は，空白を指定します。ただし，REPORTSETFILEパラメタを省略する場合は，REPORTSETパラメタは省略しないでください。

帳票セット指定ファイルは，EUR Server - Adapter稼働マシンに配置してください。

MULTIFORMINFO

複数様式情報定義ファイル名を指定します。複数様式で帳票を出力する場合は，必ず指定してください。

MULTIFORMINFOパラメタを省略する場合は，空白を指定します。

環境設定ファイル（EURPM.ini）でOPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，複数様式情報定義ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのMULTIキーで設定しているフォルダに格納しておいてください。

OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。パスは，MULTIFORMINFOPATHパラメタに指定することもできます。MULTIFORMINFOPATHパラメタにパスを指定しない場合は，次のことに注意してください。

  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのMULTIキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのMULTIキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのMULTIキーで設定しているフォルダにあるファイル名を指定してください。

複数様式情報定義ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

複数様式情報定義ファイルは，EUR Server Service稼働マシンに配置してください。

DOCBOOKMARKFILE

文書しおり定義ファイル名を指定します。

文書しおり定義ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

このパラメタを省略する場合は，空白を指定します。

文書しおり定義ファイルは，EUR Server - Adapter稼働マシンに配置してください。

PDFFILENAME

出力するPDF形式ファイル名を指定します。

PDFFILENAMEパラメタ，またはDISTRIBUTEFILENAMEパラメタのどちらかは，必ず指定してください。PDFFILENAMEパラメタとDISTRIBUTEFILENAMEパラメタを同時に指定した場合は，PDFFILENAMEパラメタの指定は無視されます。

FILEOUTPUTDESTINATIONパラメタが1（PDF形式ファイルをEUR Server Service稼働マシンに出力する）の場合で，EUR Server Serviceの環境設定ファイル（EURPM.ini）でOPTIONセクションのPATHMODEキーに0（通常モード）を設定しているときは，PDFFILENAMEパラメタにはファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのPDFキーで設定しているフォルダに出力されます。

OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定しているときは，PDFFILENAMEパラメタはフルパス，相対パス，またはファイル名だけのどれかで指定してください。

パスは，PDFFILEPATHパラメタに指定することもできます。PDFFILEPATHパラメタにパスを指定しない場合のPDF形式ファイルの出力先を次に示します。

  • フルパスを指定する場合
    PDFFILENAMEパラメタで指定したパスに出力されます。なお，環境設定ファイル（EURPM.ini）のPATHセクションのPDFキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPDFキーで設定しているフォルダを起点とし，そこからPDFFILENAMEパラメタで指定したパスに出力されます。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPDFキーで設定しているフォルダに，PDFFILENAMEパラメタで指定したファイル名で出力されます。

PDF形式ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

REPORTSET

帳票セットの親項目です。

REPORTNAME

帳票ファイル名を指定します。帳票ファイル名（*.fms）を指定してください。

REPORTNAMEパラメタ，またはREPORTSETFILEパラメタのどちらかは，必ず指定してください。

REPORTNAMEパラメタを省略する場合は，空白を指定します。

環境設定ファイル（EURPM.ini）でOPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，帳票ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのFORMキーで設定しているフォルダに格納しておいてください。

OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。パスは，REPORTFILEPATHパラメタに指定することもできます。REPORTFILEPATHパラメタにパスを指定しない場合は，次のことに注意してください。

  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのFORMキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのFORMキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのFORMキーで設定しているフォルダにあるファイル名を指定してください。

帳票ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

帳票ファイルは，EUR Server Service稼働マシンに配置してください。

MAPPINGDATA

マッピングデータファイル名，または可変記号値定義ファイル名を指定します。

MAPPINGDATAパラメタには，REPORTNAMEパラメタで指定した帳票ファイルに対応するファイル名を指定します。なお，指定できるファイル名は，一つだけです。

MAPPINGDATAパラメタを省略する場合は，空白を指定します。

ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

マッピングデータファイルは，EUR Server - Adapter稼働マシンに配置してください。

USERDEFDATA

ユーザ定義データファイル名または可変記号値定義ファイル名を指定します。

USERDEFDATAパラメタには，REPORTNAMEパラメタで指定した帳票ファイルに対応するファイル名を指定します。指定するファイル名は，REPORTNAMEパラメタで指定したファイル名と同じ数を指定してください。

USERDEFDATAパラメタを省略する場合は，空白を指定します。

ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

ユーザ定義データファイルは，EUR Server - Adapter稼働マシンに配置してください。

BOOKMARKFILE

REPORTNAMEパラメタで指定した帳票ファイルに対応したしおり定義ファイル名を指定します。

しおり定義ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

このパラメタを省略する場合は，空白を指定します。

しおり定義ファイルは，EUR Server - Adapter稼働マシンに配置してください。

MAPPINGDATAPATH

MAPPINGDATAパラメタまたは帳票セット指定ファイルで指定するマッピングデータファイルのパス，もしくは可変記号値定義ファイルのパスを指定します。

MAPPINGDATAパラメタをフルパスで指定した場合は，MAPPINGDATAPATHパラメタを指定する必要はありません。MAPPINGDATAPATHパラメタを省略する場合は，空白を指定します。

パスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

USERDEFDATAPATH

USERDEFDATAパラメタで指定するユーザ定義データファイルのパス，または可変記号値定義ファイルのパスを指定します。

USERDEFDATAパラメタをフルパスで指定した場合は，USERDEFDATAPATHパラメタを指定する必要はありません。USERDEFDATAPATHパラメタを省略する場合は，空白を指定します。

パスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

BOOKMARKFILEPATH

BOOKMARKFILEパラメタで指定するしおり定義ファイルのパスを指定します。

しおり定義ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

BOOKMARKFILEパラメタをフルパスで指定した場合は，このパラメタを指定する必要はありません。このパラメタを省略する場合は，空白を指定します。

REPORTSETFILEPATH

REPORTSETFILEパラメタで指定する帳票セット指定ファイルのパスを指定します。

REPORTSETFILEパラメタをフルパスで指定した場合は，REPORTSETFILEPATHパラメタを指定する必要はありません。REPORTSETFILEPATHパラメタを省略する場合は，空白を指定します。

帳票セット指定ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

CRYPTOFILENAME

暗号化設定ファイル名を指定します。

CRYPTOFILENAMEパラメタを省略する場合は，空白を指定します。

暗号化設定ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

暗号化設定ファイルは，EUR Server - Adapter稼働マシンに配置してください。

CRYPTOFILEPATH

CRYPTOFILENAMEパラメタで指定する暗号化設定ファイルのパスを指定します。

CRYPTOFILENAMEパラメタをフルパスで指定した場合は，CRYPTOFILEPATHパラメタを指定する必要はありません。CRYPTOFILEPATHパラメタを省略する場合は，空白を指定します。

暗号化設定ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

DOCINFOFILE

文書情報設定ファイル名を指定します。

DOCINFOFILEパラメタを省略する場合は，空白を指定します。

環境設定ファイル（EURPM.ini）でOPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，文書情報設定ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのDOCINFOキーで設定しているフォルダに格納しておいてください。

OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。パスは，DOCINFOFILEPATHパラメタに指定することもできます。DOCINFOFILEPATHパラメタにパスを指定しない場合は，次のことに注意してください。

  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのDOCINFOキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのDOCINFOキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのDOCINFOキーで設定しているフォルダにあるファイル名を指定してください。

文書情報設定ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

文書情報設定ファイルは，EUR Server Service稼働マシンに配置してください。

DOCINFOFILEPATH

DOCINFOFILEパラメタで指定した文書情報設定ファイルのパスを指定します。DOCINFOFILEパラメタをフルパスで指定した場合は，DOCINFOFILEPATHパラメタを指定する必要はありません。DOCINFOFILEPATHパラメタを省略する場合は，空白を指定します。

指定されたファイルのパスは，DOCINFOFILEパラメタで指定したファイルのパスとなります。

文書情報設定ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

REPORTFILEPATH

REPORTNAMEパラメタで指定する帳票ファイルのパスを指定します。指定されたファイルのパスは，REPORTNAMEパラメタで指定したファイルのパスとなります。

REPORTNAMEパラメタをフルパスで指定した場合は，REPORTFILEPATHパラメタを指定する必要はありません。REPORTFILEPATHパラメタを省略する場合は，空白を指定します。

帳票ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

MULTIFORMINFOPATH

MULTIFORMINFOパラメタで指定する複数様式情報定義ファイルのパスを指定します。指定されたファイルのパスは，MULTIFORMINFOパラメタで指定したファイルのパスとなります。

MULTIFORMINFOパラメタをフルパスで指定した場合は，MULTIFORMINFOPATHパラメタを指定する必要はありません。MULTIFORMINFOPATHパラメタを省略する場合は，空白を指定します。

複数様式情報定義ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

PDFFILEPATH

PDFFILENAMEパラメタで指定したPDF形式ファイルのパスを指定します。

PDFFILENAMEパラメタをフルパスで指定した場合は，PDFFILEPATHパラメタを指定する必要はありません。PDFFILEPATHパラメタを省略する場合は，空白を指定します。

FILEOUTPUTDESTINATIONパラメタが1（PDF形式ファイルをEUR Server Service稼働マシンに出力する）の場合で，かつEUR Server Serviceの環境設定ファイル（EURPM.ini）のOPTIONセクションのPATHMODEキーに0（通常モード）を指定している場合は，PDFFILEPATHパラメタの指定は無視されます。

PDF形式ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

PAGENUMBERFORMAT

ページ番号のフォーマットを指定します。ページ番号を「*」，最終ページ番号を「$」で示して出力形式を指定します。

ページ番号および最終ページ番号を全角で表示したいときは全角の記号で，半角で表示したいときは半角の記号で指定します。

ページ番号のフォーマットが80バイトに満たない場合は，空白で埋めてください。

PAGENUMBERFORMATパラメタは，PRINTPAGENUMBERパラメタに1が指定されている場合だけ有効になります。ただし，MULTIFORMINFOパラメタを指定した場合は，PAGENUMBERFORMATパラメタの設定値は無視されます。

PAGENUMBERFORMATパラメタを省略する場合は，空白を指定します。

PRINTPAGENUMBER

余白へのページ番号印刷を指定します。

指定できる値を次に示します。

  • 0：余白へのページ番号は出力しません。
  • 1：余白へのページ番号を出力します。

PRINTPAGENUMBERパラメタを省略する場合は，-1を指定します。PRINTPAGENUMBERパラメタの指定を省略した場合は，0が仮定されます。

ただし，MULTIFORMINFOパラメタを指定した場合は，PRINTPAGENUMBERパラメタの設定値は無視されます。

PAGENUMBERLOCATION

余白へのページ番号の印刷位置を指定します。

PAGENUMBERLOCATIONパラメタは，PRINTPAGENUMBERパラメタに1が指定されている場合だけ有効になります。ただし，MULTIFORMINFOパラメタを指定した場合は，PAGENUMBERLOCATIONパラメタの設定値は無視されます。

指定できる値を次に示します。

  • 1：ページ番号を左上に出力します。
  • 2：ページ番号を中央上に出力します。
  • 3：ページ番号を右上に出力します。
  • 4：ページ番号を左下に出力します。
  • 5：ページ番号を中央下に出力します。
  • 6：ページ番号を右下に出力します。

PAGENUMBERLOCATIONパラメタを省略する場合は，-1を指定します。

FIRSTPAGENUMBER

ページ番号の初期値を指定します。指定できる値は，1～999,999です。

FIRSTPAGENUMBERパラメタは，PRINTPAGENUMBERパラメタに1が指定されている場合だけ有効になります。ただし，MULTIFORMINFOパラメタを指定した場合は，FIRSTPAGENUMBERパラメタの設定値は無視されます。

FIRSTPAGENUMBERパラメタを省略する場合は，-1を指定します。FIRSTPAGENUMBERパラメタの指定を省略した場合は，1が仮定されます。

INITPAGENUMBER

改ページのキーが設定されている場合，そのキーがブレイクするごとにページ番号の開始番号を初期化するかどうかを指定します。

指定できる値を次に示します。

  • 0：初期化しません。
  • 1：初期化します。

INITPAGENUMBERパラメタを省略する場合は，-1を指定します。INITPAGENUMBERパラメタの指定を省略した場合は，出力する帳票の属性に従います。帳票の属性の初期値は，0が仮定されます。

ただし，MULTIFORMINFOパラメタを指定した場合は，INITPAGENUMBERパラメタの設定値は無視されます。

CRYPTO

PDF形式ファイルを暗号化して出力するかどうかを指定します。

指定できる値を次に示します。

  • 0：PDF形式ファイルを暗号化しません。
  • 1：PDF形式ファイルを暗号化します。

CRYPTOパラメタを省略する場合は，-1を指定します。CRYPTOパラメタの指定を省略した場合は，0が仮定されます。

DBINFOFILENAME

接続情報ファイル名を指定します。

DBINFOFILENAMEパラメタを省略する場合は，空白を指定します。

環境設定ファイル（EURPM.ini）でOPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，接続情報ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのDBINFOキーで設定しているフォルダに格納しておいてください。

OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。パスは，DBINFOFILEPATHパラメタに指定することもできます。DBINFOFILEPATHパラメタにパスを指定しない場合は，次のことに注意してください。

  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのDBINFOキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのDBINFOキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのDBINFOキーで設定しているフォルダにあるファイル名を指定してください。

接続情報ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

接続情報ファイルは，EUR Server Service稼働マシンに配置してください。

DBINFOFILEPATH

DBINFOFILENAMEパラメタで指定した接続情報ファイルのパスを指定します。

DBINFOFILENAMEパラメタをフルパスで指定した場合は，DBINFOFILEPATHパラメタを指定する必要はありません。DBINFOFILEPATHパラメタを省略する場合は，空白を指定します。

接続情報ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

ENCRYPTIONPASSWORDKEY

オーナパスワードとユーザパスワードを暗号化した暗号化設定ファイルを使用して，暗号化したPDF形式ファイルを出力するときにパスワード暗号化鍵を指定します。

パスワード暗号化鍵に指定できる文字は，次のとおりです。

  • 半角数字
    0～9
  • 半角英字
    A～Z，a～z

指定できるパスワード暗号化鍵の長さは，32バイトまでです。32バイトに満たない場合は，空白で埋めてください。

ENCRYPTIONPASSWORDKEYパラメタを省略する場合は，空白を指定します。

REPLACEITEMCNTLFILENAME

置き換え表管理情報ファイル名を指定します。

環境設定ファイル（EURPM.ini）でOPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，置き換え表管理情報ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのREPLACEITEMキーで設定しているフォルダに格納しておいてください。

OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。パスは，REPLACEITEMCNTLFILEPATHパラメタに指定することもできます。REPLACEITEMCNTLFILEPATHパラメタにパスを指定しない場合は，次のことに注意してください。

  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのREPLACEITEMキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのREPLACEITEMキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのREPLACEITEMキーで設定しているフォルダにあるファイル名を指定してください。

置き換え表管理情報ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

REPLACEITEMCNTLFILENAMEパラメタを省略する場合は，空白を指定します。

置き換え表管理情報ファイルは，EUR Server Service稼働マシンに配置してください。

REPLACEITEMCNTLFILEPATH

REPLACEITEMCNTLFILENAMEパラメタで指定した置き換え表管理情報ファイルのパスを指定します。

REPLACEITEMCNTLFILENAMEパラメタをフルパスで指定した場合は，REPLACEITEMCNTLFILEPATHパラメタを指定する必要はありません。REPLACEITEMCNTLFILEPATHパラメタを省略する場合は，空白を指定します。

置き換え表管理情報ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

DISTRIBUTEFILENAME

PDF仕分け定義ファイル名を指定します。

PDFFILENAMEパラメタ，またはDISTRIBUTEFILENAMEパラメタのどちらかは，必ず指定してください。PDFFILENAMEパラメタとDISTRIBUTEFILENAMEパラメタを同時に指定した場合は，PDFFILENAMEパラメタの指定は無視されます。

DISTRIBUTEFILENAMEパラメタでPDF仕分け定義ファイルを指定した場合は，FILEOUTPUTDESTINATIONパラメタの指定は無視されます。この場合，PDF仕分け定義ファイルに記述されている出力先ファイル名に従って，EUR Server Serviceが稼働するマシンにPDF形式ファイルを出力します。

PDF仕分け定義ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

DISTRIBUTEFILENAMEパラメタを省略する場合は，空白を指定します。

PDF仕分け定義ファイルは，EUR Server - Adapter稼働マシンに配置してください。

DISTRIBUTEFILEPATH

DISTRIBUTEFILENAMEパラメタで指定したPDF仕分け定義ファイルのパスを指定します。

DISTRIBUTEFILENAMEパラメタをフルパスで指定した場合は，DISTRIBUTEFILEPATHパラメタを指定する必要はありません。DISTRIBUTEFILEPATHパラメタを省略する場合は，空白を指定します。

PDF仕分け定義ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

SCRIPTCNTLFILENAME

Acrobat JavaScript定義ファイル名を指定します。

環境設定ファイル（EURPM.ini）でOPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，Acrobat JavaScript定義ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのSCRIPTCNTキーで設定しているフォルダに格納しておいてください。

OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。パスは，SCRIPTCNTLFILEPATHパラメタに指定することもできます。SCRIPTCNTLFILEPATHパラメタにパスを指定しない場合は，次のことに注意してください。

  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのSCRIPTCNTキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのSCRIPTCNTキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのSCRIPTCNTキーで設定しているフォルダにあるファイル名を指定してください。

Acrobat JavaScript定義ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

SCRIPTCNTLFILENAMEパラメタを省略する場合は，空白を指定します。

Acrobat JavaScript定義ファイルは，EUR Server Service稼働マシンに配置してください。

SCRIPTCNTLFILEPATH

SCRIPTCNTLFILENAMEパラメタで指定したAcrobat JavaScript定義ファイルのパスを指定します。

SCRIPTCNTLFILENAMEパラメタをフルパスで指定した場合は，SCRIPTCNTLFILEPATHパラメタを指定する必要はありません。SCRIPTCNTLFILEPATHパラメタを省略する場合は，空白を指定します。

Acrobat JavaScript定義ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

VIEWERPREFERENCEFILENAME

ビューアプレファレンス定義ファイル名を指定します。

環境設定ファイル（EURPM.ini）でOPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，ビューアプレファレンス定義ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのPREFERENCEキーで設定しているフォルダに格納しておいてください。

OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。パスは，VIEWERPREFERENCEFILEPATHパラメタに指定することもできます。VIEWERPREFERENCEFILEPATHパラメタにパスを指定しない場合は，次のことに注意してください。

  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPREFERENCEキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPREFERENCEキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPREFERENCEキーで設定しているフォルダにあるファイル名を指定してください。

ビューアプレファレンス定義ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

VIEWERPREFERENCEFILENAMEパラメタを省略する場合は，空白を指定します。

ビューアプレファレンス定義ファイルは，EUR Server Service稼働マシンに配置してください。

VIEWERPREFERENCEFILEPATH

VIEWERPREFERENCEFILENAMEパラメタで指定したビューアプレファレンス定義ファイルのパスを指定します。

VIEWERPREFERENCEFILENAMEパラメタをフルパスで指定した場合は，VIEWERPREFERENCEFILEPATHパラメタを指定する必要はありません。VIEWERPREFERENCEFILEPATHパラメタを省略する場合は，空白を指定します。

ビューアプレファレンス定義ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

PMSERVERADDR

帳票サーバのIPアドレスを255.255.255.255形式で指定します。

PMSERVERADDRパラメタを省略する場合は，空白を指定します。

PMSERVERPORT

帳票サーバのポート番号を指定します。

PMSERVERPORTパラメタを省略する場合は，-1を指定します。

PSENVFILENAME

EUR Print Serviceの動作環境を印刷ジョブごとに変更する場合に，EUR Server Serviceの環境設定ファイル（EURPS_ENV）名を指定します。

EUR Server Serviceの環境設定ファイル（EURPM.ini）で，OPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，PSENVFILENAMEパラメタは，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのPSENVキーで設定しているフォルダに格納しておいてください。

OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。

パスは，PSENVFILEPATHパラメタに指定することもできます。PSENVFILEPATHパラメタにパスを指定しない場合は，次のことに注意してください。

  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPSENVキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPSENVキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPSENVキーで設定しているフォルダにあるファイル名を指定してください。

EUR Server Serviceの環境設定ファイル（EURPS_ENV）名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

PSENVFILENAMEパラメタを省略する場合は，空白を指定します。

EUR Server Serviceの環境設定ファイル（EURPS_ENV）は，EUR Server Service稼働マシンに配置してください。

PSENVFILEPATH

PSENVFILENAMEパラメタで指定したEUR Server Serviceの環境設定ファイル（EURPS_ENV）のパスを指定します。

PSENVFILENAMEパラメタをフルパスで指定した場合は，PSENVFILEPATHパラメタを指定する必要はありません。PSENVFILEPATHパラメタを省略する場合は，空白を指定します。

EUR Server Serviceの環境設定ファイル（EURPS_ENV）のパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

FILEOUTPUTDESTINATION

PDF形式ファイルの出力先を，EUR Server - Adapter稼働マシンにするか，またはEUR Server Service稼働マシンにするかのどちらかを指定します。

指定できる値を次に示します。

  • 0：EUR Server - Adapter稼働マシンに出力します。
  • 1：EUR Server Service稼働マシンに出力します。

FILEOUTPUTDESTINATIONパラメタを省略する場合は，-1を指定します。FILEOUTPUTDESTINATIONパラメタの指定を省略した場合は，0が仮定されます。

FILEOUTPUTDESTINATIONパラメタは，OutputPDFReport関数でPDF形式ファイルを出力する場合，指定が有効になります。それ以外の場合は，FILEOUTPUTDESTINATIONパラメタを指定しても無視されます。

DISTRIBUTEFILENAMEパラメタでPDF仕分け定義ファイルを指定した場合は，FILEOUTPUTDESTINATIONパラメタの指定は無視されます。この場合，PDF仕分け定義ファイルに記述されている出力先ファイル名に従って，EUR Server Serviceが稼働するマシンにPDF形式ファイルを出力します。

戻り値

RTNCODE

終了コードが設定されます。終了コードについては，「10.4.1　エラー情報一覧」を参照してください。

ERRORMESSAGE

エラーが発生した場合，エラーメッセージとメッセージIDが設定されます。エラーメッセージについては，マニュアル「EUR メッセージ」を参照してください。

エラーが発生しなかった場合は，空白が設定されます。

エラーメッセージ

EUR Print Serviceと連携して使用するパラメタでエラーが発生した場合は，次のエラーメッセージが出力されます。メッセージが表示されたときは，EUR Print Serviceのイベントログ，またはeurpsログを参照してください。

メッセージID | メッセージ
KEEY223-E | PDF形式ファイル出力処理でエラーが発生しました。（337）


OutputXLSXReport関数

OutputXLSXReport関数

Excel形式ファイルを出力します。Excel出力ファイルは，EUR Server - Adapter稼働マシンにXLSXFILENAMEパラメタとXLSXFILEPATHパラメタの指定値に従って出力されます。

出力先に指定したExcel形式ファイルがすでにある場合は，上書きされます。

形式

WORKING-STORAGE SECTION.
01 EURPMPARAM.
           02  FILLER                   PIC X(4) VALUE '0820'.
           02  ERRORMESSAGE             PIC X(256) VALUE SPACE.
           02  FILLER                   PIC X(1) VALUE LOW-VALUE.
           02  XLSXFILENAME             PIC X(256) VALUE SPACE.
           02  FILLER                   PIC X(1) VALUE LOW-VALUE.
           02  XLSXFILEPATH             PIC X(256) VALUE SPACE.
           02  FILLER                   PIC X(1) VALUE LOW-VALUE.
           02  REPORTNAME               PIC X(256) VALUE SPACE.
           02  FILLER                   PIC X(1) VALUE LOW-VALUE.
           02  REPORTFILEPATH           PIC X(256) VALUE SPACE.
           02  FILLER                   PIC X(1) VALUE LOW-VALUE.
           02  MAPPINGDATA              PIC X(256) VALUE SPACE..
           02  FILLER                   PIC X(1) VALUE LOW-VALUE.
           02  MAPPINGDATAPATH          PIC X(256) VALUE SPACE.
           02  FILLER                   PIC X(1) VALUE LOW-VALUE.
           02  USERDEFDATA              PIC X(256) VALUE SPACE.
           02  FILLER                   PIC X(1) VALUE LOW-VALUE.
           02  USERDEFDATAPATH          PIC X(256 VALUE SPACE.
           02  FILLER                   PIC X(1) VALUE LOW-VALUE.
           02  DBINFOFILENAME           PIC X(256) VALUE SPACE.
           02  FILLER                   PIC X(1) VALUE LOW-VALUE.
           02  DBINFOFILEPATH           PIC X(256) VALUE SPACE.
           02  FILLER                   PIC X(1) VALUE LOW-VALUE.
           02  REPLACEITEMCNTLFILENAME  PIC X(256) VALUE SPACE.
           02  FILLER                   PIC X(1) VALUE LOW-VALUE.
           02  REPLACEITEMCNTLFILEPATH  PIC X(256) VALUE SPACE.
           02  FILLER                   PIC X(1) VALUE LOW-VALUE.
           02  PMSERVERADDR             PIC X(15) VALUE SPACE.
           02  FILLER                   PIC X(1) VALUE LOW-VALUE.
           02  FILLER                   PIC X(3) VALUE LOW-VALUE.
           02  PMSERVERPORT             PIC S9(9) COMP-5 VALUE -1.
           02  PRINTSTARTPAGE           PIC 9(9) COMP-X.
           02  PRINTENDPAGE             PIC 9(9) COMP-X.
           02  PSENVFILENAME            PIC X(256).
           02  FILLER                   PIC X(1) VALUE LOW-VALUE.
           02  PSENVFILEPATH            PIC X(256).
           02  FILLER                   PIC X(1) VALUE LOW-VALUE.
           02  FILLER                   PIC X(2) VALUE LOW-VALUE.
01 RTNCODE                PIC S9(9) BINARY.

call 'OutputXLSXReport'  USING  EURPMPARAM
RETURNING  RTNCODE.

パラメタ

PRINTSTARTPAGE

出力開始ページを指定します。指定できる値は，0～999,999です。

PRINTSTARTPAGEパラメタを省略する場合は，0を指定します。PRINTSTARTPAGEパラメタの指定を省略した場合は，1ページから出力されます。

複数の帳票ファイルを指定した場合は，PRINTSTARTPAGEパラメタの指定に関係なく，指定した複数の帳票ファイルの全ページが出力されます。

PRINTENDPAGE

出力終了ページを指定します。指定できる値は，0～999,999です。

PRINTENDPAGEパラメタを省略する場合は，0を指定します。PRINTENDPAGEパラメタを省略した場合は，最終ページまで出力されます。

複数の帳票ファイルを指定した場合は，PRINTENDPAGEパラメタの指定に関係なく，指定した複数の帳票ファイルの全ページが出力されます。

XLSXFILENAME

出力するExcel形式ファイル名を指定します。Excel形式ファイルを出力する場合は，必ず指定してください。

Excel形式ファイルの拡張子は，*.xlsxです。Excel形式ファイル名は，拡張子を含めて指定してください。

Excel形式ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

XLSXFILEPATH

XLSXFILENAMEパラメタで指定したExcel形式ファイルのパスを指定します。

XLSXFILENAMEパラメタをフルパスで指定した場合は，XLSXFILEPATHパラメタを指定する必要はありません。XLSXFILEPATHパラメタを省略する場合は，空白を指定します。

Excel形式ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

REPORTNAME

帳票ファイル名を指定します。帳票ファイル名（*.fms）を指定してください。REPORTNAMEパラメタは必ず指定してください。

環境設定ファイル（EURPM.ini）でOPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，帳票ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのFORMキーで設定しているフォルダに格納しておいてください。

OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。パスは，REPORTFILEPATHパラメタに指定することもできます。REPORTFILEPATHパラメタにパスを指定しない場合は，次のことに注意してください。

  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのFORMキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのFORMキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのFORMキーで設定しているフォルダにあるファイル名を指定してください。

帳票ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

帳票ファイルは，EUR Server Service稼働マシンに配置してください。

REPORTFILEPATH

REPORTNAMEパラメタで指定する帳票ファイルのパスを指定します。指定されたファイルのパスは，REPORTNAMEパラメタで指定したファイルのパスとなります。

REPORTNAMEパラメタをフルパスで指定した場合は，REPORTFILEPATHパラメタを指定する必要はありません。REPORTFILEPATHパラメタを省略する場合は，空白を指定します。

帳票ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

MAPPINGDATA

マッピングデータファイル名，または可変記号値定義ファイル名を指定します。

MAPPINGDATAパラメタには，REPORTNAMEパラメタで指定した帳票ファイルに対応するファイル名を指定します。なお，指定できるファイル名は，一つだけです。

MAPPINGDATAパラメタを省略する場合は，空白を指定します。

ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

マッピングデータファイルは，EUR Server - Adapter稼働マシンに配置してください。

MAPPINGDATAPATH

MAPPINGDATAパラメタまたは帳票セット指定ファイルで指定するマッピングデータファイルのパス，または可変記号値定義ファイルのパスを指定します。

MAPPINGDATAパラメタをフルパスで指定した場合は，MAPPINGDATAPATHパラメタを指定する必要はありません。MAPPINGDATAPATHパラメタを省略する場合は，空白を指定します。

パスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

USERDEFDATA

ユーザ定義データファイル名または可変記号値定義ファイル名を指定します。

USERDEFDATAパラメタには，REPORTNAMEパラメタで指定した帳票ファイルに対応するファイル名を指定します。指定するファイル名は，REPORTNAMEパラメタで指定したファイル名と同じ数を指定してください。

USERDEFDATAパラメタを省略する場合は，空白を指定します。

ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

ユーザ定義データファイルは，EUR Server - Adapter稼働マシンに配置してください。

USERDEFDATAPATH

USERDEFDATAパラメタで指定するユーザ定義データファイルのパス，または可変記号値定義ファイルのパスを指定します。

USERDEFDATAパラメタをフルパスで指定した場合は，USERDEFDATAPATHパラメタを指定する必要はありません。USERDEFDATAPATHパラメタを省略する場合は，空白を指定します。

パスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

DBINFOFILENAME

接続情報ファイル名を指定します。

DBINFOFILENAMEパラメタを省略する場合は，空白を指定します。

環境設定ファイル（EURPM.ini）でOPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，接続情報ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのDBINFOキーで設定しているフォルダに格納しておいてください。

OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。パスは，DBINFOFILEPATHパラメタに指定することもできます。DBINFOFILEPATHパラメタにパスを指定しない場合は，次のことに注意してください。

  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのDBINFOキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのDBINFOキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのDBINFOキーで設定しているフォルダにあるファイル名を指定してください。

接続情報ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

接続情報ファイルは，EUR Server Service稼働マシンに配置してください。

DBINFOFILEPATH

接続情報ファイルのパスを指定します。

DBINFOFILENAMEパラメタをフルパスで指定した場合は，DBINFOFILEPATHパラメタを指定する必要はありません。DBINFOFILEPATHパラメタを省略する場合は，空白を指定します。

接続情報ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

REPLACEITEMCNTLFILENAME

置き換え表管理情報ファイル名を指定します。

環境設定ファイル（EURPM.ini）でOPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，置き換え表管理情報ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのREPLACEITEMキーで設定しているフォルダに格納しておいてください。

OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。パスは，REPLACEITEMCNTLFILEPATHパラメタに指定することもできます。REPLACEITEMCNTLFILEPATHパラメタにパスを指定しない場合は，次のことに注意してください。

  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのREPLACEITEMキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのREPLACEITEMキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのREPLACEITEMキーで設定しているフォルダにあるファイル名を指定してください。

置き換え表管理情報ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

REPLACEITEMCNTLFILENAMEパラメタを省略する場合は，空白を指定します。

置き換え表管理情報ファイルは，EUR Server Service稼働マシンに配置してください。

REPLACEITEMCNTLFILEPATH

置き換え表管理情報ファイルのパスを指定します。

REPLACEITEMCNTLFILENAMEパラメタをフルパスで指定した場合は，REPLACEITEMCNTLFILEPATHパラメタを指定する必要はありません。REPLACEITEMCNTLFILEPATHパラメタを省略する場合は，空白を指定します。

置き換え表管理情報ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

PMSERVERADDR

帳票サーバのIPアドレスを255.255.255.255形式で指定します。

PMSERVERADDRパラメタを省略する場合は，空白を指定します。

PMSERVERPORT

帳票サーバのポート番号を指定します。指定できる値は，0～65,535です。

PMSERVERPORTパラメタを省略する場合は，-1を指定します。

PSENVFILENAME

EUR Print Serviceの動作環境を印刷ジョブごとに変更する場合に，EUR Server Serviceの環境設定ファイル（EURPS_ENV）名を指定します。

EUR Server Serviceの環境設定ファイル（EURPM.ini）で，OPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，PSENVFILENAMEパラメタは，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのPSENVキーで設定しているフォルダに格納しておいてください。

OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。

パスは，PSENVFILEPATHパラメタに指定することもできます。PSENVFILEPATHパラメタにパスを指定しない場合は，次のことに注意してください。

  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPSENVキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPSENVキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPSENVキーで設定しているフォルダにあるファイル名を指定してください。

EUR Server Serviceの環境設定ファイル（EURPS_ENV）名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

PSENVFILENAMEパラメタを省略する場合は，空白を指定します。

EUR Server Serviceの環境設定ファイル（EURPS_ENV）は，EUR Server Service稼働マシンに配置してください。

PSENVFILEPATH

PSENVFILENAMEパラメタで指定したEUR Server Serviceの環境設定ファイル（EURPS_ENV）のパスを指定します。

PSENVFILENAMEパラメタをフルパスで指定した場合は，PSENVFILEPATHパラメタを指定する必要はありません。PSENVFILEPATHパラメタを省略する場合は，空白を指定します。

EUR Server Serviceの環境設定ファイル（EURPS_ENV）のパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

戻り値

RTNCODE

終了コードが設定されます。終了コードについては，「10.4.1　エラー情報一覧」を参照してください。

ERRORMESSAGE

エラーが発生した場合，エラーメッセージとメッセージIDが設定されます。エラーメッセージについては，マニュアル「EUR メッセージ」を参照してください。

エラーが発生しなかった場合は，空白が設定されます。

エラーメッセージ

EUR Print Serviceと連携して使用するパラメタでエラーが発生した場合は，次のエラーメッセージが出力されます。メッセージが表示されたときは，EUR Print Serviceのイベントログ，またはeurpsログを参照してください。

メッセージID | メッセージ
KEEY263-E | XLSX形式ファイル出力処理でエラーが発生しました。（337）


PrintReport関数

PrintReport関数

帳票の印刷，またはEPF形式ファイルの蓄積をします。

形式

01 EURPMPARAM.
        02  FILLER                      PIC X(4) VALUE '0960'.
        02  CLIENTADDR                  PIC X(15) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  SERVERNAME                  PIC X(80) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  PRINTERNAME                 PIC X(80) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  TRAYNAME                    PIC X(80) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  PRINTSTARTPAGE              PIC 9(9) COMP-X VALUE 0.
        02  PRINTENDPAGE                PIC 9(9) COMP-X VALUE 0.
        02  REPORTSETFILE               PIC X(256) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  MULTIFORMINFO               PIC X(256) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(2) VALUE LOW-VALUE.
        02  REPORTSET.
          03  REPORTNAME                PIC X(256) VALUE SPACE.
          03  FILLER                    PIC X(1) VALUE LOW-VALUE.
          03  MAPPINGDATA               PIC X(256) VALUE SPACE.
          03  FILLER                    PIC X(1) VALUE LOW-VALUE.
          03  USERDEFDATA               PIC X(256) VALUE SPACE.
          03  FILLER                    PIC X(1) VALUE LOW-VALUE.
        02  ERRORMESSAGE                PIC X(256) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  MAPPINGDATAPATH             PIC X(256) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  USERDEFDATAPATH             PIC X(256) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  REPORTSETFILEPATH           PIC X(256) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  CLIENTPRINTERNAME           PIC X(80) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  CLIENTTRAYNAME              PIC X(80) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  REPORTFILEPATH              PIC X(256) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  MULTIFORMINFOPATH           PIC X(256) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  DOCINFOFILE                 PIC X(256) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  DOCINFOFILEPATH             PIC X(256) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  PAGENUMBERFORMAT            PIC X(80) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(2) VALUE LOW-VALUE.
        02  PRINTCOPIES                 PIC S9(9) COMP-5 VALUE -1.
        02  SORTPRINT                   PIC S9(9) COMP-5 VALUE -1.
        02  PAPERORIENTATION            PIC S9(9) COMP-5 VALUE -1.
        02  PRINTPAGENUMBER             PIC S9(9) COMP-5 VALUE -1.
        02  PAGENUMBERLOCATION          PIC S9(9) COMP-5 VALUE -1.
        02  FIRSTPAGENUMBER             PIC S9(9) COMP-5 VALUE -1.
        02  INITPAGENUMBER              PIC S9(9) COMP-5 VALUE -1.
        02  DBINFOFILENAME              PIC X(256) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  DBINFOFILEPATH              PIC X(256) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(2) VALUE LOW-VALUE.
        02  PRINTMODE                   PIC S9(9) COMP-5 VALUE -1.
        02  PRINTKIND                   PIC S9(9) COMP-5 VALUE -1.
        02  SERVERSELECTMODE            PIC S9(9) COMP-5 VALUE -1.
        02  PRINTERSELECTMODE           PIC S9(9) COMP-5 VALUE -1.
        02  DISPPRINTDLG                PIC S9(9) COMP-5 VALUE -1.
        02  DESTNAME                    PIC X(80) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  SERVERADDR                  PIC X(80) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  PRINTERCLASSNAME            PIC X(80) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  SERVERPRINTERNAME           PIC X(80) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  SERVERTRAYNAME              PIC X(80) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  GROUPNAME                   PIC X(80) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  REPLACEITEMCNTLFILENAME     PIC X(256) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  REPLACEITEMCNTLFILEPATH     PIC X(256) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  SPOOLFILENAME               PIC X(256) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  SPOOLLIMIT                  PIC X(8) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(2) VALUE LOW-VALUE.
        02  EXECUTABLEPRINTMODE         PIC S9(9) COMP-5 VALUE -1.
        02  MAXPRINTCOUNT               PIC S9(9) COMP-5 VALUE -1.
        02  ENABLEGET                   PIC S9(9) COMP-5 VALUE -1.
        02  PRINTHOLDMODE               PIC S9(9) COMP-5 VALUE -1.
        02  JOBKEYNUM                   PIC S9(9) COMP-5 VALUE 5.
        02  JOBKEYS                     OCCURS 5 TIMES.
          03  JOBKEYCATEGORY            PIC  X(80) VALUE SPACE.
          03  FILLER                    PIC  X(1) VALUE LOW-VALUE.
          03  JOBKEYDATA                PIC  X(80) VALUE SPACE.
          03  FILLER                    PIC  X(1) VALUE LOW-VALUE.
        02  JOBID                       PIC X(36) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  PMSERVERADDR                PIC X(15) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  PMSERVERPORT                PIC S9(9) COMP-5 VALUE -1.
        02  EPFFILENAME                 PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  EPFFILEPATH                 PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(2) VALUE LOW-VALUE.
        02  JOBKEYNUM2                  PIC S9(9) COMP-5 VALUE 5.
        02  JOBKEYS2                    OCCURS 5 TIMES.
          03  JOBKEYCATEGORY2           PIC  X(80) VALUE SPACE.
          03  FILLER                    PIC  X(1) VALUE LOW-VALUE.
          03  JOBKEYDATA2               PIC  X(80) VALUE SPACE.
          03  FILLER                    PIC  X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(2) VALUE LOW-VALUE.
        02  PSENVFILENAME               PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  PSENVFILEPATH               PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(2) VALUE LOW-VALUE.
        02  PRINTDATEFILENAME           PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  PRINTDATEFILEPATH           PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(2) VALUE LOW-VALUE.
        02  SPLITMODE                   PIC S9(9) COMP-5 VALUE -1.
        02  SPLITFILENAME               PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  SPLITFILEPATH               PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(2) VALUE LOW-VALUE.
        02  REPORTADDRKEYCATEGORY       PIC X(80).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  REPORTADDRKEYDATA           PIC X(80).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(2) VALUE LOW-VALUE.
        02  SPOOLTITLE                  PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(3) VALUE LOW-VALUE.
01 RTNCODE                              PIC S9(9) BINARY.

call 'PrintReport'  USING  EURPMPARAM
RETURNING  RTNCODE.

パラメタ

CLIENTADDR

印刷を実行するクライアントPCのIPアドレス，または蓄積クライアント印刷実行を要求するクライアントPCのIPアドレスを指定します。

CLIENTADDRパラメタを省略した場合は，デフォルト値（127.0.0.1）が仮定されます。

PRINTMODEパラメタに2（印刷方式が蓄積）の場合，CLIENTADDRパラメタの指定は任意です。PRINTMODEパラメタに3（印刷方式がスプールサーバ印刷方式）またはPRINTMODEパラメタに4（印刷方式が帳票サーバ直接印刷方式）の場合は，CLIENTADDRパラメタを指定しても無視されます。

SERVERNAME

指定しても無視されます。

PRINTERNAME

指定しても無視されます。

TRAYNAME

指定しても無視されます。

PRINTSTARTPAGE

印刷開始ページを指定します。指定できる値は，0～999,999です。

PRINTSTARTPAGEパラメタを省略する場合は，0を指定します。PRINTSTARTPAGEパラメタの指定を省略した場合は，1ページから印刷されます。

REPORTSETFILEパラメタを指定した場合，PRINTSTARTPAGEパラメタの指定は無視されます。

複数の帳票ファイルを指定した場合は，PRINTSTARTPAGEパラメタの指定に関係なく，指定した複数の帳票ファイルの全ページが印刷されます。

PRINTENDPAGE

印刷終了ページを指定します。指定できる値は，0～999,999です。

PRINTENDPAGEパラメタを省略する場合は，0を指定します。PRINTENDPAGEパラメタを省略した場合は，最終ページまで印刷されます。

REPORTSETFILEパラメタを指定した場合，PRINTENDPAGEパラメタの指定は無視されます。

複数の帳票ファイルを指定した場合は，PRINTENDPAGEパラメタの指定に関係なく，指定した複数の帳票ファイルの全ページが印刷されます。

REPORTSETFILE

帳票セット指定ファイル名を指定します。

REPORTSETFILEパラメタ，またはREPORTNAMEパラメタのどちらかは，必ず指定してください。

帳票セット指定ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

REPORTSETFILEパラメタを省略する場合は，空白を指定します。ただし，REPORTSETFILEパラメタを省略する場合は，REPORTSETパラメタは省略しないでください。

帳票セット指定ファイルは，EUR Server - Adapter稼働マシンに配置してください。

MULTIFORMINFO

複数様式情報定義ファイル名を指定します。複数様式で帳票を出力する場合は，必ず指定してください。

MULTIFORMINFOパラメタを省略する場合は，空白を指定します。

環境設定ファイル（EURPM.ini）でOPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，複数様式情報定義ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのMULTIキーで設定しているフォルダに格納しておいてください。

OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。パスは，MULTIFORMINFOPATHパラメタに指定することもできます。MULTIFORMINFOPATHパラメタにパスを指定しない場合は，次のことに注意してください。

  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのMULTIキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのMULTIキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのMULTIキーで設定しているフォルダにあるファイル名を指定してください。

複数様式情報定義ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

複数様式情報定義ファイルは，EUR Server Service稼働マシンに配置してください。

REPORTSET

帳票セット指定ファイルを指定するためのパラメタの親項目です。

REPORTNAME

帳票ファイル名を指定します。帳票ファイル名（*.fms）を指定してください。

REPORTNAMEパラメタ，またはREPORTSETFILEパラメタのどちらかは，必ず指定してください。

REPORTNAMEパラメタを省略する場合は，空白を指定します。

環境設定ファイル（EURPM.ini）でOPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，帳票ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのFORMキーで設定しているフォルダに格納しておいてください。

OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。パスは，REPORTFILEPATHパラメタに指定することもできます。REPORTFILEPATHパラメタにパスを指定しない場合は，次のことに注意してください。

  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのFORMキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのFORMキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのFORMキーで設定しているフォルダにあるファイル名を指定してください。

帳票ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

帳票ファイルは，EUR Server Service稼働マシンに配置してください。

MAPPINGDATA

マッピングデータファイル名，または可変記号値定義ファイル名を指定します。

MAPPINGDATAパラメタには，REPORTNAMEパラメタで指定した帳票ファイルに対応するファイル名を指定します。なお，指定できるファイル名は，一つだけです。

MAPPINGDATAパラメタを省略する場合は，空白を指定します。

ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

マッピングデータファイルは，EUR Server - Adapter稼働マシンに配置してください。

USERDEFDATA

ユーザ定義データファイル名または可変記号値定義ファイル名を指定します。

USERDEFDATAパラメタには，REPORTNAMEパラメタで指定した帳票ファイルに対応するファイル名を指定します。指定するファイル名は，REPORTNAMEパラメタで指定したファイル名と同じ数を指定してください。

USERDEFDATAパラメタを省略する場合は，空白を指定します。

ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

ユーザ定義データファイルは，EUR Server - Adapter稼働マシンに配置してください。

MAPPINGDATAPATH

MAPPINGDATAパラメタまたは帳票セット指定ファイルで指定するマッピングデータファイルのパス，もしくは可変記号値定義ファイルのパスを指定します。

MAPPINGDATAパラメタをフルパスで指定した場合は，MAPPINGDATAPATHパラメタを指定する必要はありません。MAPPINGDATAPATHパラメタを省略する場合は，空白を指定します。

パスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

USERDEFDATAPATH

USERDEFDATAパラメタで指定するユーザ定義データファイルのパス，または可変記号値定義ファイルのパスを指定します。

USERDEFDATAパラメタをフルパスで指定した場合は，USERDEFDATAPATHパラメタを指定する必要はありません。USERDEFDATAPATHパラメタを省略する場合は，空白を指定します。

パスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

REPORTSETFILEPATH

REPORTSETFILEパラメタで指定する帳票セット指定ファイルのパスを指定します。

REPORTSETFILEパラメタをフルパスで指定した場合は，REPORTSETFILEPATHパラメタを指定する必要はありません。REPORTSETFILEPATHパラメタを省略する場合は，空白を指定します。

帳票セット指定ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

CLIENTPRINTERNAME

クライアントPCのOS上のプリンタ名を指定します。

CLIENTPRINTERNAMEパラメタは，PRINTMODEパラメタに1（印刷方式がクライアント印刷方式）の場合，およびPRINTMODEパラメタに2（印刷方式が蓄積）の場合に指定が有効になります。それ以外の場合は，CLIENTPRINTERNAMEパラメタを指定しても無視されます。

CLIENTPRINTERNAMEパラメタを指定した場合，対話型印刷はできません。

CLIENTPRINTERNAMEパラメタを省略する場合は，空白を指定します。

次のことに注意して，プリンタ名を指定してください。

  • 指定するプリンタ名が，80バイトに満たない場合は，空白で埋めてください。
  • プリンタ名には「"」および「,」を含めないでください。

CLIENTPRINTERNAMEパラメタを指定した場合，かつDISPPRINTDLGパラメタに0または2を指定した場合は，DISPPRINTDLGパラメタは強制的に1（ダイアログを表示しません）が仮定されます。

CLIENTPRINTERNAMEパラメタとPRINTERCLASSNAMEパラメタでは，CLIENTPRINTERNAMEパラメタの指定を優先します。

CLIENTTRAYNAME

クライアントプリンタのOS上のトレイ名を指定します。

CLIENTTRAYNAMEパラメタを指定する場合は，CLIENTPRINTERNAMEパラメタを必ず指定してください。

CLIENTTRAYNAMEパラメタを指定しない場合は，CLIENTPRINTERNAMEパラメタで指定したプリンタのデフォルトのトレイから出力されます。また，CLIENTTRAYNAMEパラメタに指定したトレイ名が，出力先のプリンタで使用できない場合は，CLIENTPRINTERNAMEパラメタで指定したプリンタのデフォルトのトレイから出力されます。

CLIENTTRAYNAMEパラメタは，PRINTMODEパラメタに1（印刷方式がクライアント印刷方式）の場合，およびPRINTMODEパラメタに2（印刷方式が蓄積）の場合に指定が有効になります。それ以外の場合は，CLIENTTRAYNAMEパラメタを指定しても無視されます。

次のことに注意して，トレイ名を指定してください。

  • 指定するトレイ名が，80バイトに満たない場合は，空白で埋めてください。
  • トレイ名には「"」および「,」を含めないでください。

このパラメタを省略する場合は，空白を指定します。

REPORTFILEPATH

REPORTNAMEパラメタで指定する帳票ファイルのパスを指定します。指定されたファイルのパスは，REPORTNAMEパラメタで指定したファイルのパスとなります。

REPORTNAMEパラメタをフルパスで指定した場合は，REPORTFILEPATHパラメタを指定する必要はありません。REPORTFILEPATHパラメタを省略する場合は，空白を指定します。

帳票ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

MULTIFORMINFOPATH

MULTIFORMINFOパラメタで指定する複数様式情報定義ファイルのパスを指定します。指定されたファイルのパスは，MULTIFORMINFOパラメタで指定したファイルのパスとなります。

MULTIFORMINFOパラメタをフルパスで指定した場合は，MULTIFORMINFOPATHパラメタを指定する必要はありません。MULTIFORMINFOPATHパラメタを省略する場合は，空白を指定します。

複数様式情報定義ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

DOCINFOFILE

文書情報設定ファイル名を指定します。

DOCINFOFILEパラメタを省略する場合は，空白を指定します。

環境設定ファイル（EURPM.ini）でOPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，文書情報設定ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのDOCINFOキーで設定しているフォルダに格納しておいてください。

OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。パスは，DOCINFOFILEPATHパラメタに指定することもできます。DOCINFOFILEPATHパラメタにパスを指定しない場合は，次のことに注意してください。

  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのDOCINFOキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのDOCINFOキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのDOCINFOキーで設定しているフォルダにあるファイル名を指定してください。

文書情報設定ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

文書情報設定ファイルは，EUR Server Service稼働マシンに配置してください。

DOCINFOFILEPATH

DOCINFOFILEパラメタで指定した文書情報設定ファイルのパスを指定します。指定されたファイルのパスは，DOCINFOFILEパラメタで指定したファイルのパスとなります。

DOCINFOFILEパラメタをフルパスで指定した場合は，DOCINFOFILEPATHパラメタを指定する必要はありません。DOCINFOFILEPATHパラメタを省略する場合は，空白を指定します。

文書情報設定ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

PAGENUMBERFORMAT

ページ番号のフォーマットを指定します。ページ番号を「*」，最終ページ番号を「$」で示して出力形式を指定します。

ページ番号および最終ページ番号を全角で表示したいときは全角の記号で，半角で表示したいときは半角の記号で指定します。

ページ番号のフォーマットが80バイトに満たない場合は，空白で埋めてください。

PAGENUMBERFORMATパラメタは，PRINTPAGENUMBERパラメタに1が指定されている場合だけ有効になります。ただし，MULTIFORMINFOパラメタを指定した場合は，PAGENUMBERFORMATパラメタの設定値は無視されます。

PAGENUMBERFORMATパラメタを省略する場合は，空白を指定します。

PRINTCOPIES

印刷部数を指定します。指定できる値は，1～99です。

PRINTCOPIESパラメタを省略する場合は，-1を指定します。PRINTCOPIESパラメタの指定を省略した場合は，1が仮定されます。

SORTPRINT

印刷部数の単位を指定します。

指定できる値を次に示します。

  • 0：部単位で出力します。
  • 1：ページ単位で出力します。

SORTPRINTパラメタを省略する場合は，-1を指定します。SORTPRINTパラメタの指定を省略した場合は，0が仮定されます。

複数帳票を出力する場合は，SORTPRINTパラメタの指定に関係なく0が仮定されます。

PAPERORIENTATION

用紙の向きを指定します。

指定できる値を次に示します。

  • 0：帳票を定義したときの情報に従います。
  • 1：用紙の向きを縦にして出力します。
  • 2：用紙の向きを横にして出力します。

PAPERORIENTATIONパラメタを省略する場合は，-1を指定します。PAPERORIENTATIONパラメタの指定を省略した場合は，0が仮定されます。

複数帳票を出力する場合は，PAPERORIENTATIONパラメタの指定に関係なく，0が仮定されます。

PRINTPAGENUMBER

余白へのページ番号印刷を指定します。

指定できる値を次に示します。

  • 0：余白へのページ番号は出力しません。
  • 1：余白へのページ番号を出力します。

PRINTPAGENUMBERパラメタを省略する場合は，-1を指定します。PRINTPAGENUMBERパラメタの指定を省略した場合は，0が仮定されます。

ただし，MULTIFORMINFOパラメタを指定した場合は，PRINTPAGENUMBERパラメタの設定値は無視されます。

PAGENUMBERLOCATION

余白へのページ番号の印刷位置を指定します。

PAGENUMBERLOCATIONパラメタは，PRINTPAGENUMBERパラメタに1が指定されている場合だけ有効になります。ただし，MULTIFORMINFOパラメタを指定した場合は，PAGENUMBERLOCATIONパラメタの設定値は無視されます。

指定できる値を次に示します。

  • 1：ページ番号を左上に出力します。
  • 2：ページ番号を中央上に出力します。
  • 3：ページ番号を右上に出力します。
  • 4：ページ番号を左下に出力します。
  • 5：ページ番号を中央下に出力します。
  • 6：ページ番号を右下に出力します。

PAGENUMBERLOCATIONパラメタを省略する場合は，-1を指定します。

FIRSTPAGENUMBER

ページ番号の初期値を指定します。指定できる値は，1～999,999です。

FIRSTPAGENUMBERパラメタは，PRINTPAGENUMBERパラメタに1が指定されている場合だけ有効になります。ただし，MULTIFORMINFOパラメタを指定した場合は，FIRSTPAGENUMBERパラメタの設定値は無視されます。

FIRSTPAGENUMBERパラメタを省略する場合は，-1を指定します。FIRSTPAGENUMBERパラメタの指定を省略した場合は，1が仮定されます。

INITPAGENUMBER

改ページのキーが設定されている場合，そのキーがブレイクするごとにページ番号の開始番号を初期化するかどうかを指定します。

指定できる値を次に示します。

  • 0：初期化しません。
  • 1：初期化します。

INITPAGENUMBERパラメタを省略する場合は，-1を指定します。INITPAGENUMBERパラメタの指定を省略した場合は，出力する帳票の属性に従います。帳票の属性の初期値は，0が仮定されます。

ただし，MULTIFORMINFOパラメタを指定した場合は，INITPAGENUMBERパラメタの設定値は無視されます。

DBINFOFILENAME

接続情報ファイル名を指定します。

DBINFOFILENAMEパラメタを省略する場合は，空白を指定します。

環境設定ファイル（EURPM.ini）でOPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，接続情報ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのDBINFOキーで設定しているフォルダに格納しておいてください。

OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。パスは，DBINFOFILEPATHパラメタに指定することもできます。DBINFOFILEPATHパラメタにパスを指定しない場合は，次のことに注意してください。

  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのDBINFOキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのDBINFOキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのDBINFOキーで設定しているフォルダにあるファイル名を指定してください。

接続情報ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

接続情報ファイルは，EUR Server Service稼働マシンに配置してください。

DBINFOFILEPATH

DBINFOFILENAMEパラメタで指定した接続情報ファイルのパスを指定します。

DBINFOFILENAMEパラメタをフルパスで指定した場合は，DBINFOFILEPATHパラメタを指定する必要はありません。DBINFOFILEPATHパラメタを省略する場合は，空白を指定します。

接続情報ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

PRINTMODE

印刷方式を選択します。

指定できる値を次に示します。

  • 0：デフォルト印刷方式 ※
  • 1：クライアント印刷方式
  • 2：蓄積
  • 3：スプールサーバ印刷方式
  • 4：帳票サーバ直接印刷方式
  • 5：クライアント配布印刷方式
    注※
    「0（デフォルト印刷方式）」を定義する場合は，EUR Server - Adapterの環境設定ファイル（EURPMADP.ini）でOPTIONセクションのDEFAULTPRINTMODEキーに値を設定してください。

0，1，2，3，4，5以外の値を指定した場合は，0が仮定されます。PRINTMODEパラメタを省略した場合は，環境設定ファイル（EURPMADP.ini）でOPTIONセクションのPRINTMODEキーに指定されている値をデフォルトとします。

PRINTMODEパラメタを省略する場合は，-1を指定します。

PRINTKIND

スプールサーバの印刷方法を選択します。

指定できる値を次に示します。

  • 0：EPF形式ファイルを印刷します。
  • 1：EUR形式ファイルを印刷します。

PRINTKINDパラメタは，PRINTMODEパラメタに3（印刷方式がスプールサーバ印刷方式）が指定されている場合だけ有効になります。

PRINTKINDパラメタを省略する場合は，-1を設定します。PRINTKINDパラメタの指定を省略した場合，または0，1以外の値を指定した場合は，0が仮定されます。

SERVERSELECTMODE

スプールサーバでの印刷を選択します。

指定できる値を次に示します。

  • 0：出力先名を指定します。
  • 1：スプールサーバのIPアドレスを指定します。

SERVERSELECTMODEパラメタは，PRINTMODEパラメタに2（印刷方式が蓄積），または3（印刷方式がスプールサーバ印刷方式）が指定されている場合だけ有効になります。

SERVERSELECTMODEパラメタを省略する場合は，-1を設定します。SERVERSELECTMODEパラメタの指定を省略した場合，または0，1以外の値を指定した場合は，0が仮定されます。

PRINTERSELECTMODE

プリンタの指定方法を選択します。

指定できる値を次に示します。

  • 0：プリンタクラス名を指定します。
  • 1：OS上のプリンタ名を指定します
  • 2：帳票振り分け定義を指定します

PRINTERSELECTMODEパラメタは，次の場合に指定が有効になります。

  • PRINTMODEパラメタに2（印刷方式が蓄積）が指定されている
  • PRINTMODEパラメタに3（印刷方式がスプールサーバ印刷方式）が指定されている
  • PRINTMODEパラメタに4（帳票サーバ直接印刷方式）が指定されている

PRINTERSELECTMODEパラメタを省略する場合は，-1を設定します。PRINTERSELECTMODEパラメタの指定を省略した場合，または0，1，2以外の値を指定した場合は，0が仮定されます。

また，帳票サーバによる直接印刷（PRINTMODEパラメタに4が指定）の場合，2の値を指定するとエラーになります。

DISPPRINTDLG

クライアントPCで印刷する場合，ダイアログを表示するかどうかを選択します。指定できる値と印刷時の動作を次に示します。

  • 0：印刷先指定ダイアログを表示します（対話型印刷）。
    プレビューボタンを選択すると，プレビューウィンドウが表示されます。
  • 1：直接印刷を実行します（自動印刷）。
    印刷実行中に印刷中のダイアログが表示されます。
  • 2：プレビューウィンドウを表示します（対話型印刷プレビュー表示）。
    印刷メニューまたは印刷ボタンを選択すると，印刷先指定ダイアログが表示されます。
  • 3：直接印刷を実行します（全自動印刷）。
    印刷実行中に印刷中のダイアログは表示されません。
  • 4：プレビューウィンドウを表示します（対話型印刷プレビュー表示限定）。
    印刷は実行できません。

DISPPRINTDLGパラメタを省略した場合，EUR Server - Adapterの環境設定ファイル（EURPMADP.ini）でOPTIONセクションのDISPPRINTDLGキーの設定値（0～4）が仮定されます。環境設定ファイルDISPPRINTDLGキーおよびDISPPRINTDLGパラメタとも省略した場合，0が仮定されます。CLIENTPRINTERNAMEパラメタを指定した場合，かつDISPPRINTDLGパラメタに0または2を指定した場合は，1が仮定されます。

DISPPRINTDLGパラメタは，PRINTMODEパラメタに1（印刷方式がクライアント印刷方式），または2（印刷方式が蓄積）が指定されている場合だけ有効になります。それ以外の場合は，DISPPRINTDLGパラメタを指定しても無視されます。

DESTNAME

出力先名を指定します。

なお，UNIX／Linux環境の場合，出力先（スプールサーバ）での印刷はサポートしていません。UNIX／Linux環境のEUR Server - Spool Serviceに対して，印刷を実行した場合はエラーとなります。

次のことに注意して，出力先名を指定してください。

  • 指定する出力先名が，80バイトに満たない場合は，空白で埋めてください。
  • 出力先名には「"」および「,」を含めないでください。

このパラメタを省略する場合は，空白を設定します。

DESTNAMEパラメタは，次に示すどちらかの指定がある場合有効になります。それ以外の場合は，DESTNAMEパラメタを指定しても無視されます。

  • PRINTMODEパラメタに3（印刷方式がスプールサーバ印刷方式），かつSERVERSELECTMODEパラメタに0（スプールサーバ指定方式が出力先名指定）のとき
  • PRINTMODEパラメタに2（印刷方式が蓄積），かつSERVERSELECTMODEパラメタに0（スプールサーバ指定方式が出力先名指定）のとき

SERVERADDR

スプールサーバのIPアドレスを255.255.255.255形式で指定します。

なお，UNIX／Linux環境の場合，スプールサーバでの印刷はサポートしていません。UNIX／Linux環境のEUR Server - Spool Serviceに対して，印刷を実行した場合はエラーとなります。

SERVERADDRパラメタを省略した場合は，デフォルト値（127.0.0.1）が仮定されます。

SERVERADDRパラメタは，次に示すどちらかの指定がある場合有効になります。それ以外の場合は，SERVERADDRパラメタを指定しても無視されます。

  • PRINTMODEパラメタに3（印刷方式がスプールサーバ印刷方式），かつSERVERSELECTMODEパラメタに1（スプールサーバ指定方式がIPアドレス指定）のとき
  • PRINTMODEパラメタに2（印刷方式が蓄積），かつSERVERSELECTMODEパラメタに1（スプールサーバ指定方式がIPアドレス指定）のとき

PRINTERCLASSNAME

プリンタクラス名を指定します。

次のことに注意して，プリンタクラス名を指定してください。

  • 指定するプリンタクラス名が，80バイトに満たない場合は，空白で埋めてください。
  • プリンタクラス名には「"」および「,」を含めないでください。
  • プリンタクラス名に「EUR_DELIVERY_PRINT_OUTPUT_DEFAULT_PRINTER_CLASS_________________________________」は使用できません。

印刷方法ごとに指定するパラメタを次に示します。パラメタの組み合わせが異なる場合，指定した値は無効となります。なお，クライアントPCへの配布印刷では，指定できません。

  • スプールサーバでの印刷を指定する場合
    PRINTMODEパラメタ：3
    PRINTERSELECTMODEパラメタ：0
    PRINTERCLASSNAMEパラメタ：拠点プリンタクラス名
  • クライアントPCでの対話型印刷を指定する場合
    PRINTMODEパラメタ：1
    DISPPRINTDLGパラメタ：0
    PRINTERCLASSNAMEパラメタ：帳票ジョブ名，およびEPF形式ファイルの属性情報に設定するプリンタクラス名
  • クライアントPCでの自動印刷を指定する場合
    PRINTMODEパラメタ：1
    DISPPRINTDLGパラメタ：1
    PRINTERCLASSNAMEパラメタ：クライアントプリンタクラス名
  • クライアントPCでの対話型印刷プレビューを指定する場合
    PRINTMODEパラメタ：1
    DISPPRINTDLGパラメタ：2
    PRINTERCLASSNAMEパラメタ：帳票ジョブ名，およびEPF形式ファイルの属性情報に設定するプリンタクラス名
  • クライアントPCでの全自動印刷を指定する場合
    PRINTMODEパラメタ：1
    DISPPRINTDLGパラメタ：3
    PRINTERCLASSNAMEパラメタ：クライアントプリンタクラス名
  • クライアントPCでの対話型印刷プレビュー表示限定
    PRINTMODEパラメタ：1
    DISPPRINTDLGパラメタ：4
    PRINTERCLASSNAMEパラメタ：EPF形式ファイルの属性情報に設定するプリンタクラス名
  • 帳票サーバでの印刷を指定する場合
    PRINTMODEパラメタ：4
    PRINTERSELECTMODEパラメタ：0
    PRINTERCLASSNAMEパラメタ：帳票サーバプリンタクラス名
  • スプールサーバでの蓄積を指定する場合（プリンタクラス名指定）
    PRINTMODEパラメタ：2
    PRINTERSELECTMODEパラメタ：0
    PRINTERCLASSNAMEパラメタ：拠点プリンタクラス名，または蓄積クライアント印刷方式のプリンタクラス名
  • スプールサーバでの蓄積を指定する場合（OS上のプリンタ名指定）
    PRINTMODEパラメタ：2
    PRINTERSELECTMODEパラメタ：1
    PRINTERCLASSNAMEパラメタ：EPF形式ファイルの属性情報に設定するプリンタクラス名
  • スプールサーバでの蓄積を指定する場合（帳票名による自動振り分け）
    PRINTMODEパラメタ：2
    PRINTERSELECTMODEパラメタ：2
    PRINTERCLASSNAMEパラメタ：EPF形式ファイルの属性情報に設定するプリンタクラス名

「クライアントPCでの自動印刷」と「蓄積クライアント印刷」の場合，CLIENTPRINTERNAMEパラメタとPRINTERCLASSNAMEパラメタでは，CLIENTPRINTERNAMEパラメタの設定を優先します。

PRINTERCLASSNAMEパラメタを省略する場合は，空白を設定します。

PRINTERCLASSNAMEパラメタを省略したときは，EPF形式ファイルのプリンタクラス名情報は未設定となります。

SERVERPRINTERNAME

サーバのプリンタ名を指定します。プリンタ名はOS上のプリンタ名を指定してください。

次のことに注意して，プリンタ名を指定してください。

  • 指定するプリンタ名が，80バイトに満たない場合は，空白で埋めてください。
  • プリンタ名には「"」および「,」を含めないでください。

SERVERPRINTERNAMEパラメタを省略する場合は，空白を設定します。

SERVERPRINTERNAMEパラメタは，次に示す指定がある場合有効になります。それ以外の場合は，SERVERPRINTERNAMEパラメタを指定しても無視されます。

  • PRINTMODEパラメタに3（印刷方式がスプールサーバ印刷方式），かつPRINTERSELECTMODEパラメタに1（プリンタ指定方式がOS上のプリンタ名指定）のとき
  • PRINTMODEパラメタに2（印刷方式が蓄積），かつPRINTERSELECTMODEパラメタに1（プリンタ指定方式がOS上のプリンタ名指定）のとき
  • PRINTMODEパラメタに4（帳票サーバ直接印刷方式），かつPRINTERSELECTMODEパラメタに1（プリンタ指定方式がOS上のプリンタ名指定）のとき

SERVERTRAYNAME

サーバのプリンタのトレイ名を指定します。トレイ名はOS上のプリンタ名を指定してください。

SERVERTRAYNAMEパラメタを指定するときは，SERVERPRINTERNAMEパラメタを必ず指定してください。

Windows環境の場合
次のことに注意して，トレイ名を指定してください。
  • 指定するトレイ名が，80バイトに満たない場合は，空白で埋めてください。
  • トレイ名には「"」および「,」を含めないでください。
SERVERTRAYNAMEパラメタを省略する場合は，空白を指定します。
SERVERTRAYNAMEパラメタを指定しない場合は，SERVERPRINTERNAMEパラメタで指定したプリンタのデフォルトのトレイから出力されます。また，SERVERTRAYNAMEパラメタに指定したトレイ名が，出力先のプリンタで使用できない場合は，SERVERPRINTERNAMEパラメタで指定したプリンタのデフォルトのトレイから出力されます。
SERVERTRAYNAMEパラメタは，次に示す指定がある場合有効になります。それ以外の場合は，SERVERTRAYNAMEパラメタを指定しても無視されます。
  • PRINTMODEパラメタに3（印刷方式がスプールサーバ印刷方式），かつPRINTERSELECTMODEパラメタに1（プリンタ指定方式がOS上のプリンタ名指定）のとき
  • PRINTMODEパラメタに2（印刷方式が蓄積），かつPRINTERSELECTMODEパラメタに1（プリンタ指定方式がOS上のプリンタ名指定）のとき
  • PRINTMODEパラメタに4（帳票サーバ直接印刷方式），かつPRINTERSELECTMODEパラメタに1（プリンタ指定方式がOS上のプリンタ名指定）のとき
UNIX／Linux環境の場合
  • 給紙トレイ情報を指定します。SERVERTRAYNAMEパラメタを指定しない場合は，プリンタ定義ファイルのキーワード（DefaultCassette）に指定されているデフォルトのトレイから給紙されます。
    プリンタ定義ファイルの詳細については，「11.5　プリンタ定義ファイル」を参照してください。
  • 指定する給紙トレイ情報を次に示します。
    指定内容 | 給紙トレイ
    auto | 印刷用紙を自動で給紙します。出力する帳票の用紙サイズから給紙トレイを自動選択します。
    manual | 手差しトレイから印刷用紙を給紙します。
    トレイ番号 トレイ番号の給紙トレイから印刷用紙を給紙します。トレイ番号は，1～n（nはプリンタ定義ファイルのキーワードCassettesで指定した値）で指定します。
    6以上の値を指定した場合は自動給紙となります。
    注意
    SERVERTRAYNAMEパラメタでは次に示す指定があった場合，プリンタのハードウェアによって動作が異なります。
    • manualが指定されたとき
    • トレイ番号が指定されたとき
    • autoが指定されたのに，プリンタのパネルで給紙トレイが選択されたとき
    また，帳票の用紙サイズと給紙される用紙のサイズが異なる場合も，プリンタのハードウェアによって動作が異なります。
    帳票の用紙サイズと給紙される用紙のサイズを合わせておくか，または帳票の用紙サイズと異なる用紙に出力する場合は，あらかじめ試し印刷を実施してプリンタの動作を確認してください。

GROUPNAME

帳票振り分け定義の振り分けグループ名を指定します。

次のことに注意して，振り分けグループ名を指定してください。

  • 指定する振り分けグループ名が，80バイトに満たない場合は，空白で埋めてください。
  • 振り分けグループ名には「"」および「,」を含めないでください。

GROUPNAMEパラメタを省略する場合は，空白を指定します。

GROUPNAMEパラメタは，次に示すどちらかの指定がある場合有効になります。それ以外の場合は，GROUPNAMEパラメタを指定しても無視されます。

  • PRINTMODEパラメタに3（印刷方式がスプールサーバ印刷方式），かつPRINTKINDパラメタに0（印刷モードがEPF形式ファイル印刷モード）のとき
  • PRINTMODEパラメタに2（印刷方式が蓄積），かつPRINTERSELECTMODEパラメタに2（プリンタ指定方式が帳票名による自動振り分け）のとき

REPLACEITEMCNTLFILENAME

置き換え表管理情報ファイル名を指定します。

環境設定ファイル（EURPM.ini）でOPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，置き換え表管理情報ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのREPLACEITEMキーで設定しているフォルダに格納しておいてください。

OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。パスは，REPLACEITEMCNTLFILEPATHパラメタに指定することもできます。REPLACEITEMCNTLFILEPATHパラメタにパスを指定しない場合は，次のことに注意してください。

  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのREPLACEITEMキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのREPLACEITEMキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのREPLACEITEMキーで設定しているフォルダにあるファイル名を指定してください。

置き換え表管理情報ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

REPLACEITEMCNTLFILENAMEパラメタを省略する場合は，空白を指定します。

REPLACEITEMCNTLFILENAMEパラメタは，次に示すどれかの指定がある場合，有効になります。PRINTMODEパラメタに3（印刷方式がスプールサーバ印刷方式），かつPRINTKINDパラメタに1（印刷モードがEUR形式ファイル印刷モード）の場合は，REPLACEITEMCNTLFILENAMEパラメタを指定しても無視されます。

  • PRINTMODEパラメタに3（印刷方式がスプールサーバ印刷方式），かつPRINTKINDパラメタに0（印刷モードがEPF形式ファイル印刷モード）のとき
  • PRINTMODEパラメタに1（印刷方式がクライアント印刷方式）のとき
  • PRINTMODEパラメタに2（印刷方式が蓄積）のとき

置き換え表管理情報ファイルは，EUR Server Service稼働マシンに配置してください。

REPLACEITEMCNTLFILEPATH

REPLACEITEMCNTLFILENAMEパラメタで指定した置き換え表管理情報ファイルのパスを指定します。

REPLACEITEMCNTLFILENAMEパラメタをフルパスで指定した場合は，REPLACEITEMCNTLFILEPATHパラメタを指定する必要はありません。REPLACEITEMCNTLFILEPATHパラメタを省略する場合は，空白を指定します。

置き換え表管理情報ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

REPLACEITEMCNTLFILENAMEパラメタは，次に示すどれかの指定がある場合，有効になります。PRINTMODEパラメタに3（印刷方式がスプールサーバ印刷方式），かつPRINTKINDパラメタに1（印刷モードがEUR形式ファイル印刷モード）の場合は，REPLACEITEMCNTLFILENAMEパラメタを指定しても無視されます。

  • PRINTMODEパラメタに3（印刷方式がスプールサーバ印刷方式），かつPRINTKINDパラメタに0（印刷モードがEPF形式ファイル印刷モード）のとき
  • PRINTMODEパラメタに1（印刷方式がクライアント印刷方式）のとき
  • PRINTMODEパラメタに2（印刷方式が蓄積）のとき

SPOOLFILENAME

スプールデータに格納するファイル名を指定します。格納ファイル名が256バイトに満たない場合は空白で埋めてください。そのほか，格納ファイルを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

「%N」を指定すると，00000001から始まる8桁の通し番号を設定できます。

SPOOLFILENAMEパラメタを省略する場合は，空白を指定します。

SPOOLFILENAMEパラメタを省略した場合は，自動的にファイル名が生成されます。自動的に生成されるファイル名は「ジョブID.epf」※です。

複数のスプールデータに同一ファイル名が指定されている場合，スプールデータ取得時に同一パスで取得されると，ファイルが上書きされます。同一パスで取得する可能性のあるファイルは，別の格納ファイル名に指定することをお勧めします。

SPOOLFILENAMEパラメタは，PRINTMODEパラメタに2（印刷方式が蓄積）が指定されている場合だけ有効になります。

注※
「ジョブID」の形式を次に示します。
EUR＋処理実行日時＋通番フォルダ番号+通し番号
処理実行日時（17桁）：YYYYMMDDhhmmssmmm
通番フォルダ番号（7桁）：0000001～2000000
通し番号（9桁）：000000001～999999999
通番フォルダ番号が2000000を超えた場合は，エラー（KEEY430-S）になります。
通し番号が999999999を超えた場合は，000000003に戻ります。

SPOOLLIMIT

スプールデータの蓄積期限日を指定します。

蓄積期限日は，日付または日数で指定してください。

日付で指定する場合
  • 「YYYYMMDD」の形式で指定してください。
  • 年（西暦）は4桁，月と日は2桁で入力します。
  • 月，または日が1～9の場合は，ゼロ埋めをして入力します。
  • 指定できる値の上限は，20380118（2038年1月18日）です。
  • 過去の日付は指定できません。
（指定例）20120521，20141008
日数で指定する場合
  • 「+XXX」の形式で指定してください。
  • 「XXX」には，蓄積実行時からの保管日数を指定します。指定できる値は000～999です。0を指定した場合は，翌日にスプールデータが削除されます。
  • 2038年1月18日を超える日数は指定できません。
（指定例）+030，+999

SPOOLLIMITパラメタを指定しない場合，蓄積期限日は蓄積を要求したEUR Server - Adapterの環境設定ファイルのOPTIONセクションのSPOOLLIMITキーの指定に従います。蓄積期限日を過ぎたスプールデータは蓄積期限切れファイル削除機能によって削除されます。

SPOOLLIMITパラメタは，PRINTMODEパラメタに2（印刷方式が蓄積）が指定されている場合だけ有効になります。

EXECUTABLEPRINTMODE

実行可能印刷方式を指定します。

指定できる値を次に示します。

  • 0：スプールサーバでの印刷
  • 1：スプールサーバでの印刷，またはクライアントPCでの印刷
  • 2：クライアントPCでの印刷

EXECUTABLEPRINTMODEパラメタを省略する場合は，-1を指定します。EXECUTABLEPRINTMODEパラメタの指定を省略した場合は，1が仮定されます。

EXECUTABLEPRINTMODEパラメタは，PRINTMODEパラメタに2（印刷方式が蓄積）が指定されている場合だけ有効になります。

MAXPRINTCOUNT

スプールデータの印刷回数の上限を指定します。指定できる値は，-1～65,536です。印刷回数の上限を無限にする場合は，-1を指定します。印刷を禁止する場合は，0を指定します。

MAXPRINTCOUNTパラメタを省略する場合は，-1を指定します。MAXPRINTCOUNTパラメタの指定を省略した場合は，-1が仮定されます。

MAXPRINTCOUNTパラメタは，PRINTMODEパラメタに2（印刷方式が蓄積）が指定されている場合だけ有効になります。

ENABLEGET

スプールデータを取得するかどうかを指定します。

指定できる値を次に示します。

  • 0：スプールデータを取得できません。
  • 1：スプールデータを取得できます。

ENABLEGETパラメタを省略する場合は，-1を指定します。

ENABLEGETパラメタは，PRINTMODEパラメタに2（印刷方式が蓄積）が指定されている場合だけ有効になります。

PRINTHOLDMODE

スプールデータを印刷する場合に，蓄積後に続けて印刷するかどうかを指定します。

指定できる値を次に示します。

  • 0：蓄積後に続けて印刷しません（印刷保留）。
  • 1：蓄積後に続けてスプールサーバで印刷します。
  • 2：蓄積後に続けてクライアントPCで印刷します。

PRINTHOLDMODEパラメタを省略する場合は，-1を指定します。PRINTHOLDMODEパラメタの指定を省略した場合は，REPORTADDRKEYCATEGORYパラメタおよびREPORTADDRKEYDATAパラメタの指定の有無によって次の値が仮定されます。

REPORTADDRKEYCATEGORYパラメタおよびREPORTADDRKEYDATAパラメタの指定がある場合
0が仮定されます。
REPORTADDRKEYCATEGORYパラメタおよびREPORTADDRKEYDATAパラメタの指定がない場合
1が仮定されます。

PRINTHOLDMODEパラメタは，PRINTMODEパラメタに2（印刷方式が蓄積）が指定されている場合だけ有効になります。

JOBKEYCATEGORY

スプールデータの検索キーの分類を指定します。

指定できる検索キーは，10個までです。ただし，検索キーの分類を6個以上指定する場合，6～10個の項目はJOBKEYS2構造体のJOBKEYCATEGORY2パラメタで指定してください。JOBKEYCATEGORYパラメタを指定する場合は，検索キーの分類に対応する検索キーの値を必ずJOBKEYDATAパラメタに指定してください。このとき，要素数が同じになるように指定してください。検索キーを指定しない場合，JOBKEYCATEGORYパラメタとJOBKEYDATAパラメタは，どちらも指定しないでください。どちらかの指定がある場合は，対応する情報がないため，エラーになります。

検索キーの分類は，任意文字列を指定できます。次のことに注意して指定してください。

  • 分類が80バイトに満たない場合は，空白で埋めてください。
  • 分類には「,」を含めないでください。

JOBKEYCATEGORYパラメタを省略する場合は，空白を指定します。

JOBKEYCATEGORYパラメタは，PRINTMODEパラメタに2（印刷方式が蓄積）が指定されている場合だけ有効になります。

JOBKEYDATA

スプールデータの検索キーの値を指定します。

指定できる検索キーは，10個までです。ただし，検索キーを6個以上指定する場合，6～10個の項目はJOBKEYS2構造体のJOBKEYDATA2パラメタで指定してください。JOBKEYCATEGORYパラメタを指定する場合は，検索キーの分類に対応する検索キーの値を必ずJOBKEYDATAパラメタに指定してください。このとき，要素数が同じになるように指定してください。検索キーを指定しない場合，JOBKEYCATEGORYパラメタとJOBKEYDATAパラメタは，どちらも指定しないでください。どちらかの指定がある場合は，対応する情報がないため，エラーになります。

検索キーの値は，任意文字列を指定できます。次のことに注意して指定してください。

  • 分類が80バイトに満たない場合は，空白で埋めてください。
  • 分類には「,」を含めないでください。

JOBKEYDATAパラメタを省略する場合は，空白を指定します。

JOBKEYDATAパラメタは，PRINTMODEパラメタに2（印刷方式が蓄積）が指定されている場合だけ有効になります。

PMSERVERADDR

帳票サーバのIPアドレスを255.255.255.255形式で指定します。

PMSERVERADDRパラメタを省略した場合はデフォルト値（127.0.0.1）が仮定されます。

PMSERVERPORT

帳票サーバのポート番号を指定します。

PMSERVERPORTパラメタを省略する場合は，-1を指定します。

EPFFILENAME

入力EPF形式ファイル名を指定します。

EPFFILENAMEパラメタを省略したい場合は，空白を指定します。

EPFFILEPATH

EPFFILENAMEパラメタで指定したEPF形式ファイルのパスを指定します。

EPFFILENAMEパラメタをフルパスで指定した場合は，EPFFILEPATHパラメタを指定する必要はありません。

EPFFILEPATHパラメタを省略したい場合は，空白を指定します。

JOBKEYCATEGORY2

スプールデータの検索キーの分類を指定します。

指定できる検索キーは，10個までです。ただし，指定する検索キーの分類が5個以下の場合，1～5個の項目はJOBKEYS構造体のJOBKEYCATEGORYパラメタで指定してください。JOBKEYCATEGORY2パラメタを指定する場合は，検索キーの分類に対応する検索キーの値を必ずJOBKEYDATA2パラメタに指定してください。このとき，要素数が同じになるように指定してください。検索キーを指定しない場合，JOBKEYCATEGORY2パラメタとJOBKEYDATA2パラメタは，どちらも指定しないでください。どちらかの指定がある場合は，対応する情報がないため，エラーになります。

検索キーの分類は，任意文字列を指定できます。次のことに注意して指定してください。

  • 分類が80バイトに満たない場合は，空白で埋めてください。
  • 分類には「,」を含めないでください。

JOBKEYCATEGORY2パラメタを省略する場合は，空白を指定します。

JOBKEYCATEGORY2パラメタは，PRINTMODEパラメタに2（印刷方式が蓄積）が指定されている場合だけ有効になります。

JOBKEYDATA2

スプールデータの検索キーの値を指定します。

指定できる検索キーは，10個までです。ただし，指定する検索キーが5個以下の場合，1～5個の項目はJOBKEYS構造体のJOBKEYDATAパラメタで指定してください。JOBKEYCATEGORY2パラメタを指定する場合は，検索キーの分類に対応する検索キーの値を必ずJOBKEYDATA2パラメタに指定してください。このとき，要素数が同じになるように指定してください。検索キーを指定しない場合，JOBKEYCATEGORY2パラメタとJOBKEYDATA2パラメタは，どちらも指定しないでください。どちらかの指定がある場合は，対応する情報がないため，エラーになります。

検索キーの値は，任意文字列を指定できます。次のことに注意して指定してください。

  • 分類が80バイトに満たない場合は，空白で埋めてください。
  • 分類には「,」を含めないでください。

JOBKEYDATA2パラメタを省略する場合は，空白を指定します。

JOBKEYDATA2パラメタは，PRINTMODEパラメタに2（印刷方式が蓄積）が指定されている場合だけ有効になります。

PSENVFILENAME

EUR Print Serviceの動作環境を印刷ジョブごとに変更する場合に，EUR Server Serviceの環境設定ファイル（EURPS_ENV）名を指定します。

EUR Server Serviceの環境設定ファイル（EURPM.ini）で，OPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，PSENVFILENAMEパラメタは，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのPSENVキーで設定しているフォルダに格納しておいてください。

OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。

パスは，PSENVFILEPATHパラメタに指定することもできます。PSENVFILEPATHパラメタにパスを指定しない場合は，次のことに注意してください。

  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPSENVキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPSENVキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPSENVキーで設定しているフォルダにあるファイル名を指定してください。

EUR Server Serviceの環境設定ファイル（EURPS_ENV）名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

PSENVFILENAMEパラメタを省略する場合は，空白を指定します。

EUR Server Serviceの環境設定ファイル（EURPS_ENV）は，EUR Server Service稼働マシンに配置してください。

PSENVFILEPATH

PSENVFILENAMEパラメタで指定したEUR Server Serviceの環境設定ファイル（EURPS_ENV）のパスを指定します。

PSENVFILENAMEパラメタをフルパスで指定した場合は，PSENVFILEPATHパラメタを指定する必要はありません。PSENVFILEPATHパラメタを省略する場合は，空白を指定します。

EUR Server Serviceの環境設定ファイル（EURPS_ENV）のパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

PRINTDATEFILENAME

印刷日時出力定義ファイル名を指定します。

EUR Server Serviceの環境設定ファイル（EURPM.ini）で，OPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，PRINTDATEFILENAMEパラメタは，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのPRINTDATEキーで設定しているフォルダに格納しておいてください。

OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。

パスは，PRINTDATEFILEPATHパラメタに指定することもできます。PRINTDATEFILEPATHパラメタにパスを指定しない場合は，次のことに注意してください。

  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPRINTDATEキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPRINTDATEキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPRINTDATEキーで設定しているフォルダにあるファイル名を指定してください。

印刷日時出力定義ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

PRINTDATEFILENAMEパラメタを省略する場合は，空白を指定します。

印刷日時出力定義ファイルは，EUR Server Service稼働マシンに配置してください。

PRINTDATEFILEPATH

PRINTDATEFILENAMEパラメタで指定した印刷日時出力定義ファイルのパスを指定します。

PRINTDATEFILENAMEパラメタをフルパスで指定した場合は，PRINTDATEFILEPATHパラメタを指定する必要はありません。PRINTDATEFILEPATHパラメタを省略する場合は，空白を指定します。

印刷日時出力定義ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

SPLITMODE

蓄積時に，帳票を分割または仕分けするかどうかを指定します。

指定できる値を次に示します。

  • 0：EUR Server Serviceの環境設定ファイルのOPTIONセクションのSPLITMODEキーの指定に従います。
  • 1：分割または仕分けしないで蓄積します。
  • 2：帳票を仕分けして蓄積します。
  • 3：帳票を分割して蓄積します。

SPLITMODEパラメタを省略する場合は，-1を指定します。

SPLITMODEパラメタは，PRINTMODEパラメタに2（印刷方式が蓄積）が指定されている場合だけ有効になります。

SPLITFILENAME

帳票を分割または仕分けして蓄積する場合に，分割定義ファイルまたは仕分け定義ファイルのファイル名を指定します。

ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

SPLITFILENAMEパラメタを省略する場合は，空白を指定します。

SPLITFILENAMEパラメタは，PRINTMODEパラメタに2（印刷方式が蓄積）が指定されている場合で，かつ次のどちらかの条件に当てはまるときに指定が有効になります。それ以外の場合は，SPLITFILENAMEパラメタを指定しても無視されます。

  • SPLITMODEパラメタに2（帳票を仕分けして蓄積）または3（帳票を分割して蓄積）を指定しているとき。
  • SPLITMODEパラメタに0（EUR Server Serviceの環境設定ファイルの指定に従う）を指定していて，かつEUR Server Serviceの環境設定ファイルのOPTIONセクションのSPLITMODEキーにPAGE（分割）またはKEY（仕分け）を指定しているとき。

分割定義ファイルまたは仕分け定義ファイルは，EUR Server - Adapter稼働マシンに配置してください。

SPLITFILEPATH

SPLITFILENAMEパラメタで指定した，分割定義ファイルまたは仕分け定義ファイルのパスを指定します。

SPLITFILENAMEパラメタをフルパスで指定した場合は，SPLITFILEPATHパラメタを指定する必要はありません。SPLITFILEPATHパラメタを省略する場合は，空白を指定します。

SPLITFILEPATHパラメタは，PRINTMODEパラメタに2（印刷方式が蓄積）が指定されている場合で，かつ次のどちらかの条件に当てはまるときに指定が有効になります。それ以外の場合は，SPLITFILEPATHパラメタを指定しても無視されます。

  • SPLITMODEパラメタに2（帳票を仕分けして蓄積）または3（帳票を分割して蓄積）を指定しているとき。
  • SPLITMODEパラメタに0（EUR Server Serviceの環境設定ファイルの指定に従う）を指定していて，かつEUR Server Serviceの環境設定ファイルのOPTIONセクションのSPLITMODEキーにPAGE（分割）またはKEY（仕分け）を指定しているとき。

パスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

REPORTADDRKEYCATEGORY

スプールデータの宛先キーの分類を指定します。

宛先キーの分類は，任意の文字列を指定できます。次のことに注意して指定してください。

  • 文字列が80バイトに満たない場合は，空白で埋めてください。
  • 文字列には「"」，「,」および制御コード（0x00～0x1F，0x7F～0x9F）を含めないでください。

REPORTADDRKEYCATEGORYパラメタを省略する場合は，空白を指定します。

REPORTADDRKEYCATEGORYパラメタは，PRINTMODEパラメタに2（印刷方式が蓄積）が指定されている場合だけ有効になります。それ以外のときは，REPORTADDRKEYCATEGORYパラメタを指定しても無視されます。また，REPORTADDRKEYDATAパラメタが指定されていない場合はエラーになります。

REPORTADDRKEYDATA

スプールデータの宛先キーの値を指定します。

宛先キーの値は，任意の文字列を指定できます。次のことに注意して指定してください。

  • 文字列が80バイトに満たない場合は，空白で埋めてください。
  • 文字列には「"」，「,」および制御コード（0x00～0x1F，0x7F～0x9F）を含めないでください。

REPORTADDRKEYDATAパラメタを省略する場合は，空白を指定します。

REPORTADDRKEYDATAパラメタは，PRINTMODEパラメタに2（印刷方式が蓄積）が指定されている場合だけ有効になります。それ以外のときは，REPORTADDRKEYDATAパラメタを指定しても無視されます。また，REPORTADDRKEYCATEGORYパラメタが指定されていない場合はエラーになります。

SPOOLTITLE

次のことに注意して，スプールタイトルを指定してください。

  • 指定するスプールタイトルが，256バイトに満たない場合は，空白で埋めてください。
  • スプールタイトルには「"」および「,」を含めないでください。

SPOOLTITLEパラメタを省略する場合は，空白を設定します。

SPOOLTITLEパラメタを省略したときは，印刷時のスプールタイトルには，文書情報設定ファイルのTITLEキーの指定値，または帳票ファイル名が出力されます。

戻り値

RTNCODE

終了コードが設定されます。終了コードについては，「10.4.1　エラー情報一覧」を参照してください。

ERRORMESSAGE

エラーが発生した場合，エラーメッセージとメッセージIDが設定されます。エラーメッセージについては，マニュアル「EUR メッセージ」を参照してください。

エラーが発生しなかった場合は，空白が設定されます。

JOBID

スプールデータのジョブIDが設定されます。PRINTMODEパラメタに2（印刷方式が蓄積）が指定されている場合だけ参照できます。

帳票を仕分けまたは分割して蓄積した場合など，直前に蓄積したスプールデータが複数ある場合は，最初に蓄積したスプールデータのジョブIDが参照できます。

エラーメッセージ

EUR Print Serviceと連携して使用するパラメタでエラーが発生した場合は，次のエラーメッセージが出力されます。メッセージが表示されたときは，EUR Print Serviceのイベントログ，またはeurpsログを参照してください。

メッセージID | メッセージ
KEEY221-E | 印刷処理でエラーが発生しました。（337）


PrintReport2関数

PrintReport2関数

帳票の印刷，またはEPF形式ファイルの蓄積をします。

また，PrintReport2関数では，蓄積したEPF形式ファイル（スプールデータ）のジョブIDを複数取得できます。

形式

01 EURPMPARAM.
        02  FILLER                      PIC X(4) VALUE '0960'.
        02  CLIENTADDR                  PIC X(15) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  SERVERNAME                  PIC X(80) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  PRINTERNAME                 PIC X(80) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  TRAYNAME                    PIC X(80) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  PRINTSTARTPAGE              PIC 9(9) COMP-X VALUE 0.
        02  PRINTENDPAGE                PIC 9(9) COMP-X VALUE 0.
        02  REPORTSETFILE               PIC X(256) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  MULTIFORMINFO               PIC X(256) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(2) VALUE LOW-VALUE.
        02  REPORTSET.
          03  REPORTNAME                PIC X(256) VALUE SPACE.
          03  FILLER                    PIC X(1) VALUE LOW-VALUE.
          03  MAPPINGDATA               PIC X(256) VALUE SPACE.
          03  FILLER                    PIC X(1) VALUE LOW-VALUE.
          03  USERDEFDATA               PIC X(256) VALUE SPACE.
          03  FILLER                    PIC X(1) VALUE LOW-VALUE.
        02  ERRORMESSAGE                PIC X(256) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  MAPPINGDATAPATH             PIC X(256) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  USERDEFDATAPATH             PIC X(256) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  REPORTSETFILEPATH           PIC X(256) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  CLIENTPRINTERNAME           PIC X(80) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  CLIENTTRAYNAME              PIC X(80) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  REPORTFILEPATH              PIC X(256) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  MULTIFORMINFOPATH           PIC X(256) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  DOCINFOFILE                 PIC X(256) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  DOCINFOFILEPATH             PIC X(256) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  PAGENUMBERFORMAT            PIC X(80) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(2) VALUE LOW-VALUE.
        02  PRINTCOPIES                 PIC S9(9) COMP-5 VALUE -1.
        02  SORTPRINT                   PIC S9(9) COMP-5 VALUE -1.
        02  PAPERORIENTATION            PIC S9(9) COMP-5 VALUE -1.
        02  PRINTPAGENUMBER             PIC S9(9) COMP-5 VALUE -1.
        02  PAGENUMBERLOCATION          PIC S9(9) COMP-5 VALUE -1.
        02  FIRSTPAGENUMBER             PIC S9(9) COMP-5 VALUE -1.
        02  INITPAGENUMBER              PIC S9(9) COMP-5 VALUE -1.
        02  DBINFOFILENAME              PIC X(256) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  DBINFOFILEPATH              PIC X(256) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(2) VALUE LOW-VALUE.
        02  PRINTMODE                   PIC S9(9) COMP-5 VALUE -1.
        02  PRINTKIND                   PIC S9(9) COMP-5 VALUE -1.
        02  SERVERSELECTMODE            PIC S9(9) COMP-5 VALUE -1.
        02  PRINTERSELECTMODE           PIC S9(9) COMP-5 VALUE -1.
        02  DISPPRINTDLG                PIC S9(9) COMP-5 VALUE -1.
        02  DESTNAME                    PIC X(80) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  SERVERADDR                  PIC X(80) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  PRINTERCLASSNAME            PIC X(80) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  SERVERPRINTERNAME           PIC X(80) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  SERVERTRAYNAME              PIC X(80) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  GROUPNAME                   PIC X(80) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  REPLACEITEMCNTLFILENAME     PIC X(256) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  REPLACEITEMCNTLFILEPATH     PIC X(256) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  SPOOLFILENAME               PIC X(256) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  SPOOLLIMIT                  PIC X(8) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(2) VALUE LOW-VALUE.
        02  EXECUTABLEPRINTMODE         PIC S9(9) COMP-5 VALUE -1.
        02  MAXPRINTCOUNT               PIC S9(9) COMP-5 VALUE -1.
        02  ENABLEGET                   PIC S9(9) COMP-5 VALUE -1.
        02  PRINTHOLDMODE               PIC S9(9) COMP-5 VALUE -1.
        02  JOBKEYNUM                   PIC S9(9) COMP-5 VALUE 5.
        02  JOBKEYS                     OCCURS 5 TIMES.
          03  JOBKEYCATEGORY            PIC  X(80) VALUE SPACE.
          03  FILLER                    PIC  X(1) VALUE LOW-VALUE.
          03  JOBKEYDATA                PIC  X(80) VALUE SPACE.
          03  FILLER                    PIC  X(1) VALUE LOW-VALUE.
        02  JOBID                       PIC X(36) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  PMSERVERADDR                PIC X(15) VALUE SPACE.
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  PMSERVERPORT                PIC S9(9) COMP-5 VALUE -1.
        02  EPFFILENAME                 PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  EPFFILEPATH                 PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(2) VALUE LOW-VALUE.
        02  JOBKEYNUM2                  PIC S9(9) COMP-5 VALUE 5.
        02  JOBKEYS2                    OCCURS 5 TIMES.
          03  JOBKEYCATEGORY2           PIC  X(80) VALUE SPACE.
          03  FILLER                    PIC  X(1) VALUE LOW-VALUE.
          03  JOBKEYDATA2               PIC  X(80) VALUE SPACE.
          03  FILLER                    PIC  X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(2) VALUE LOW-VALUE.
        02  PSENVFILENAME               PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  PSENVFILEPATH               PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(2) VALUE LOW-VALUE.
        02  PRINTDATEFILENAME           PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  PRINTDATEFILEPATH           PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(2) VALUE LOW-VALUE.
        02  SPLITMODE                   PIC S9(9) COMP-5 VALUE -1.
        02  SPLITFILENAME               PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  SPLITFILEPATH               PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(2) VALUE LOW-VALUE.
        02  REPORTADDRKEYCATEGORY       PIC X(80).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  REPORTADDRKEYDATA           PIC X(80).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(2) VALUE LOW-VALUE.
        02  SPOOLTITLE                  PIC X(256).
        02  FILLER                      PIC X(1) VALUE LOW-VALUE.
        02  FILLER                      PIC X(3) VALUE LOW-VALUE.
01 EURPMPARAMJOBID.
        02  JOBIDNUM                    PIC S9(9) COMP-5 VALUE n.
        02  JOBIDS                      OCCURS n TIMES.
          03  JOBID                     PIC  X(36) VALUE SPACE.
          03  FILLER                    PIC X(1) VALUE LOW-VALUE.
          03  FILLER                    PIC X(3) VALUE LOW-VALUE.
01 RTNCODE                                 PIC S9(9) BINARY.

call 'PrintReport2'  USING  EURPMPARAM
                     EURPMPARMJOBID
RETURNING  RTNCODE.

パラメタ

CLIENTADDR

印刷を実行するクライアントPCのIPアドレス，または蓄積クライアント印刷実行を要求するクライアントPCのIPアドレスを指定します。

CLIENTADDRパラメタを省略した場合は，デフォルト値（127.0.0.1）が仮定されます。

PRINTMODEパラメタに2（印刷方式が蓄積）の場合，CLIENTADDRパラメタの指定は任意です。PRINTMODEパラメタに3（印刷方式がスプールサーバ印刷方式）またはPRINTMODEパラメタに4（印刷方式が帳票サーバ直接印刷方式）の場合は，CLIENTADDRパラメタを指定しても無視されます。

SERVERNAME

指定しても無視されます。

PRINTERNAME

指定しても無視されます。

TRAYNAME

指定しても無視されます。

PRINTSTARTPAGE

印刷開始ページを指定します。指定できる値は，0～999,999です。

PRINTSTARTPAGEパラメタを省略する場合は，0を指定します。PRINTSTARTPAGEパラメタの指定を省略した場合は，1ページから印刷されます。

REPORTSETFILEパラメタを指定した場合，PRINTSTARTPAGEパラメタの指定は無視されます。

複数の帳票ファイルを指定した場合は，PRINTSTARTPAGEパラメタの指定に関係なく，指定した複数の帳票ファイルの全ページが印刷されます。

PRINTENDPAGE

印刷終了ページを指定します。指定できる値は，0～999,999です。

PRINTENDPAGEパラメタを省略する場合は，0を指定します。PRINTENDPAGEパラメタを省略した場合は，最終ページまで印刷されます。

REPORTSETFILEパラメタを指定した場合，PRINTENDPAGEパラメタの指定は無視されます。

複数の帳票ファイルを指定した場合は，PRINTENDPAGEパラメタの指定に関係なく，指定した複数の帳票ファイルの全ページが印刷されます。

REPORTSETFILE

帳票セット指定ファイル名を指定します。

REPORTSETFILEパラメタ，またはREPORTNAMEパラメタのどちらかは，必ず指定してください。

帳票セット指定ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

REPORTSETFILEパラメタを省略する場合は，空白を指定します。ただし，REPORTSETFILEパラメタを省略する場合は，REPORTSETパラメタは省略しないでください。

帳票セット指定ファイルは，EUR Server - Adapter稼働マシンに配置してください。

MULTIFORMINFO

複数様式情報定義ファイル名を指定します。複数様式で帳票を出力する場合は，必ず指定してください。

MULTIFORMINFOパラメタを省略する場合は，空白を指定します。

環境設定ファイル（EURPM.ini）でOPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，複数様式情報定義ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのMULTIキーで設定しているフォルダに格納しておいてください。

OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。パスは，MULTIFORMINFOPATHパラメタに指定することもできます。MULTIFORMINFOPATHパラメタにパスを指定しない場合は，次のことに注意してください。

  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのMULTIキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのMULTIキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのMULTIキーで設定しているフォルダにあるファイル名を指定してください。

複数様式情報定義ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

複数様式情報定義ファイルは，EUR Server Service稼働マシンに配置してください。

REPORTSET

帳票セット指定ファイルを指定するためのパラメタの親項目です。

REPORTNAME

帳票ファイル名を指定します。帳票ファイル名（*.fms）を指定してください。

REPORTNAMEパラメタ，またはREPORTSETFILEパラメタのどちらかは，必ず指定してください。

REPORTNAMEパラメタを省略する場合は，空白を指定します。

環境設定ファイル（EURPM.ini）でOPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，帳票ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのFORMキーで設定しているフォルダに格納しておいてください。

OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。パスは，REPORTFILEPATHパラメタに指定することもできます。REPORTFILEPATHパラメタにパスを指定しない場合は，次のことに注意してください。

  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのFORMキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのFORMキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのFORMキーで設定しているフォルダにあるファイル名を指定してください。

帳票ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

帳票ファイルは，EUR Server Service稼働マシンに配置してください。

MAPPINGDATA

マッピングデータファイル名，または可変記号値定義ファイル名を指定します。

MAPPINGDATAパラメタには，REPORTNAMEパラメタで指定した帳票ファイルに対応するファイル名を指定します。なお，指定できるファイル名は，一つだけです。

MAPPINGDATAパラメタを省略する場合は，空白を指定します。

ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

マッピングデータファイルは，EUR Server - Adapter稼働マシンに配置してください。

USERDEFDATA

ユーザ定義データファイル名または可変記号値定義ファイル名を指定します。

USERDEFDATAパラメタには，REPORTNAMEパラメタで指定した帳票ファイルに対応するファイル名を指定します。指定するファイル名は，REPORTNAMEパラメタで指定したファイル名と同じ数を指定してください。

USERDEFDATAパラメタを省略する場合は，空白を指定します。

ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

ユーザ定義データファイルは，EUR Server - Adapter稼働マシンに配置してください。

MAPPINGDATAPATH

MAPPINGDATAパラメタまたは帳票セット指定ファイルで指定するマッピングデータファイルのパス，もしくは可変記号値定義ファイルのパスを指定します。

MAPPINGDATAパラメタをフルパスで指定した場合は，MAPPINGDATAPATHパラメタを指定する必要はありません。MAPPINGDATAPATHパラメタを省略する場合は，空白を指定します。

パスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

USERDEFDATAPATH

USERDEFDATAパラメタで指定するユーザ定義データファイルのパス，または可変記号値定義ファイルのパスを指定します。

USERDEFDATAパラメタをフルパスで指定した場合は，USERDEFDATAPATHパラメタを指定する必要はありません。USERDEFDATAPATHパラメタを省略する場合は，空白を指定します。

パスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

REPORTSETFILEPATH

REPORTSETFILEパラメタで指定する帳票セット指定ファイルのパスを指定します。

REPORTSETFILEパラメタをフルパスで指定した場合は，REPORTSETFILEPATHパラメタを指定する必要はありません。REPORTSETFILEPATHパラメタを省略する場合は，空白を指定します。

帳票セット指定ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

CLIENTPRINTERNAME

クライアントPCのOS上のプリンタ名を指定します。

CLIENTPRINTERNAMEパラメタは，PRINTMODEパラメタに1（印刷方式がクライアント印刷方式）の場合，およびPRINTMODEパラメタに2（印刷方式が蓄積）の場合に指定が有効になります。それ以外の場合は，CLIENTPRINTERNAMEパラメタを指定しても無視されます。

CLIENTPRINTERNAMEパラメタを指定した場合，対話型印刷はできません。

CLIENTPRINTERNAMEパラメタを省略する場合は，空白を指定します。

次のことに注意して，プリンタ名を指定してください。

  • 指定するプリンタ名が，80バイトに満たない場合は，空白で埋めてください。
  • プリンタ名には「"」および「,」を含めないでください。

CLIENTPRINTERNAMEパラメタを指定した場合，かつDISPPRINTDLGパラメタに0または2を指定した場合は，DISPPRINTDLGパラメタは強制的に1（ダイアログを表示しません）が仮定されます。

CLIENTPRINTERNAMEパラメタとPRINTERCLASSNAMEパラメタでは，CLIENTPRINTERNAMEパラメタの指定を優先します。

CLIENTTRAYNAME

クライアントプリンタのOS上のトレイ名を指定します。

CLIENTTRAYNAMEパラメタを指定する場合は，CLIENTPRINTERNAMEパラメタを必ず指定してください。

CLIENTTRAYNAMEパラメタを指定しない場合は，CLIENTPRINTERNAMEパラメタで指定したプリンタのデフォルトのトレイから出力されます。また，CLIENTTRAYNAMEパラメタに指定したトレイ名が，出力先のプリンタで使用できない場合は，CLIENTPRINTERNAMEパラメタで指定したプリンタのデフォルトのトレイから出力されます。

CLIENTTRAYNAMEパラメタは，PRINTMODEパラメタに1（印刷方式がクライアント印刷方式）の場合，およびPRINTMODEパラメタに2（印刷方式が蓄積）の場合に指定が有効になります。それ以外の場合は，CLIENTTRAYNAMEパラメタを指定しても無視されます。

次のことに注意して，トレイ名を指定してください。

  • 指定するトレイ名が，80バイトに満たない場合は，空白で埋めてください。
  • トレイ名には「"」および「,」を含めないでください。

このパラメタを省略する場合は，空白を指定します。

REPORTFILEPATH

REPORTNAMEパラメタで指定する帳票ファイルのパスを指定します。指定されたファイルのパスは，REPORTNAMEパラメタで指定したファイルのパスとなります。

REPORTNAMEパラメタをフルパスで指定した場合は，REPORTFILEPATHパラメタを指定する必要はありません。REPORTFILEPATHパラメタを省略する場合は，空白を指定します。

帳票ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

MULTIFORMINFOPATH

MULTIFORMINFOパラメタで指定する複数様式情報定義ファイルのパスを指定します。指定されたファイルのパスは，MULTIFORMINFOパラメタで指定したファイルのパスとなります。

MULTIFORMINFOパラメタをフルパスで指定した場合は，MULTIFORMINFOPATHパラメタを指定する必要はありません。MULTIFORMINFOPATHパラメタを省略する場合は，空白を指定します。

複数様式情報定義ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

DOCINFOFILE

文書情報設定ファイル名を指定します。

DOCINFOFILEパラメタを省略する場合は，空白を指定します。

環境設定ファイル（EURPM.ini）でOPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，文書情報設定ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのDOCINFOキーで設定しているフォルダに格納しておいてください。

OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。パスは，DOCINFOFILEPATHパラメタに指定することもできます。DOCINFOFILEPATHパラメタにパスを指定しない場合は，次のことに注意してください。

  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのDOCINFOキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのDOCINFOキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのDOCINFOキーで設定しているフォルダにあるファイル名を指定してください。

文書情報設定ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

文書情報設定ファイルは，EUR Server Service稼働マシンに配置してください。

DOCINFOFILEPATH

DOCINFOFILEパラメタで指定した文書情報設定ファイルのパスを指定します。指定されたファイルのパスは，DOCINFOFILEパラメタで指定したファイルのパスとなります。

DOCINFOFILEパラメタをフルパスで指定した場合は，DOCINFOFILEPATHパラメタを指定する必要はありません。DOCINFOFILEPATHパラメタを省略する場合は，空白を指定します。

文書情報設定ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

PAGENUMBERFORMAT

ページ番号のフォーマットを指定します。ページ番号を「*」，最終ページ番号を「$」で示して出力形式を指定します。

ページ番号および最終ページ番号を全角で表示したいときは全角の記号で，半角で表示したいときは半角の記号で指定します。

ページ番号のフォーマットが80バイトに満たない場合は，空白で埋めてください。

PAGENUMBERFORMATパラメタは，PRINTPAGENUMBERパラメタに1が指定されている場合だけ有効になります。ただし，MULTIFORMINFOパラメタを指定した場合は，PAGENUMBERFORMATパラメタの設定値は無視されます。

PAGENUMBERFORMATパラメタを省略する場合は，空白を指定します。

PRINTCOPIES

印刷部数を指定します。指定できる値は，1～99です。

PRINTCOPIESパラメタを省略する場合は，-1を指定します。PRINTCOPIESパラメタの指定を省略した場合は，1が仮定されます。

SORTPRINT

印刷部数の単位を指定します。

指定できる値を次に示します。

  • 0：部単位で出力します。
  • 1：ページ単位で出力します。

SORTPRINTパラメタを省略する場合は，-1を指定します。SORTPRINTパラメタの指定を省略した場合は，0が仮定されます。

複数帳票を出力する場合は，SORTPRINTパラメタの指定に関係なく0が仮定されます。

PAPERORIENTATION

用紙の向きを指定します。

指定できる値を次に示します。

  • 0：帳票を定義したときの情報に従います。
  • 1：用紙の向きを縦にして出力します。
  • 2：用紙の向きを横にして出力します。

PAPERORIENTATIONパラメタを省略する場合は，-1を指定します。PAPERORIENTATIONパラメタの指定を省略した場合は，0が仮定されます。

複数帳票を出力する場合は，PAPERORIENTATIONパラメタの指定に関係なく，0が仮定されます。

PRINTPAGENUMBER

余白へのページ番号印刷を指定します。

指定できる値を次に示します。

  • 0：余白へのページ番号は出力しません。
  • 1：余白へのページ番号を出力します。

PRINTPAGENUMBERパラメタを省略する場合は，-1を指定します。PRINTPAGENUMBERパラメタの指定を省略した場合は，0が仮定されます。

ただし，MULTIFORMINFOパラメタを指定した場合は，PRINTPAGENUMBERパラメタの設定値は無視されます。

PAGENUMBERLOCATION

余白へのページ番号の印刷位置を指定します。

PAGENUMBERLOCATIONパラメタは，PRINTPAGENUMBERパラメタに1が指定されている場合だけ有効になります。ただし，MULTIFORMINFOパラメタを指定した場合は，PAGENUMBERLOCATIONパラメタの設定値は無視されます。

指定できる値を次に示します。

  • 1：ページ番号を左上に出力します。
  • 2：ページ番号を中央上に出力します。
  • 3：ページ番号を右上に出力します。
  • 4：ページ番号を左下に出力します。
  • 5：ページ番号を中央下に出力します。
  • 6：ページ番号を右下に出力します。

PAGENUMBERLOCATIONパラメタを省略する場合は，-1を指定します。

FIRSTPAGENUMBER

ページ番号の初期値を指定します。指定できる値は，1～999,999です。

FIRSTPAGENUMBERパラメタは，PRINTPAGENUMBERパラメタに1が指定されている場合だけ有効になります。ただし，MULTIFORMINFOパラメタを指定した場合は，FIRSTPAGENUMBERパラメタの設定値は無視されます。

FIRSTPAGENUMBERパラメタを省略する場合は，-1を指定します。FIRSTPAGENUMBERパラメタの指定を省略した場合は，1が仮定されます。

INITPAGENUMBER

改ページのキーが設定されている場合，そのキーがブレイクするごとにページ番号の開始番号を初期化するかどうかを指定します。

指定できる値を次に示します。

  • 0：初期化しません。
  • 1：初期化します。

INITPAGENUMBERパラメタを省略する場合は，-1を指定します。INITPAGENUMBERパラメタの指定を省略した場合は，出力する帳票の属性に従います。帳票の属性の初期値は，0が仮定されます。

ただし，MULTIFORMINFOパラメタを指定した場合は，INITPAGENUMBERパラメタの設定値は無視されます。

DBINFOFILENAME

接続情報ファイル名を指定します。

DBINFOFILENAMEパラメタを省略する場合は，空白を指定します。

環境設定ファイル（EURPM.ini）でOPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，接続情報ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのDBINFOキーで設定しているフォルダに格納しておいてください。

OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。パスは，DBINFOFILEPATHパラメタに指定することもできます。DBINFOFILEPATHパラメタにパスを指定しない場合は，次のことに注意してください。

  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのDBINFOキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのDBINFOキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのDBINFOキーで設定しているフォルダにあるファイル名を指定してください。

接続情報ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

接続情報ファイルは，EUR Server Service稼働マシンに配置してください。

DBINFOFILEPATH

DBINFOFILENAMEパラメタで指定した接続情報ファイルのパスを指定します。

DBINFOFILENAMEパラメタをフルパスで指定した場合は，DBINFOFILEPATHパラメタを指定する必要はありません。DBINFOFILEPATHパラメタを省略する場合は，空白を指定します。

接続情報ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

PRINTMODE

印刷方式を選択します。

指定できる値を次に示します。

  • 0：デフォルト印刷方式 ※
  • 1：クライアント印刷方式
  • 2：蓄積
  • 3：スプールサーバ印刷方式
  • 4：帳票サーバ直接印刷方式
  • 5：クライアント配布印刷方式
    注※
    「0（デフォルト印刷方式）」を定義する場合は，EUR Server - Adapterの環境設定ファイル（EURPMADP.ini）でOPTIONセクションのDEFAULTPRINTMODEキーに値を設定してください。

0，1，2，3，4，5以外の値を指定した場合は，0が仮定されます。PRINTMODEパラメタを省略した場合は，環境設定ファイル（EURPMADP.ini）でOPTIONセクションのPRINTMODEキーに指定されている値をデフォルトとします。

PRINTMODEパラメタを省略する場合は，-1を指定します。

PRINTKIND

スプールサーバの印刷方法を選択します。

指定できる値を次に示します。

  • 0：EPF形式ファイルを印刷します。
  • 1：EUR形式ファイルを印刷します。

PRINTKINDパラメタは，PRINTMODEパラメタに3（印刷方式がスプールサーバ印刷方式）が指定されている場合だけ有効になります。

PRINTKINDパラメタを省略する場合は，-1を設定します。PRINTKINDパラメタの指定を省略した場合，または0，1以外の値を指定した場合は，0が仮定されます。

SERVERSELECTMODE

スプールサーバでの印刷を選択します。

指定できる値を次に示します。

  • 0：出力先名を指定します。
  • 1：スプールサーバのIPアドレスを指定します。

SERVERSELECTMODEパラメタは，PRINTMODEパラメタに2（印刷方式が蓄積），または3（印刷方式がスプールサーバ印刷方式）が指定されている場合だけ有効になります。

SERVERSELECTMODEパラメタを省略する場合は，-1を設定します。SERVERSELECTMODEパラメタの指定を省略した場合，または0，1以外の値を指定した場合は，0が仮定されます。

PRINTERSELECTMODE

プリンタの指定方法を選択します。

指定できる値を次に示します。

  • 0：プリンタクラス名を指定します。
  • 1：OS上のプリンタ名を指定します
  • 2：帳票振り分け定義を指定します

PRINTERSELECTMODEパラメタは，次の場合に指定が有効になります。

  • PRINTMODEパラメタに2（印刷方式が蓄積）が指定されている
  • PRINTMODEパラメタに3（印刷方式がスプールサーバ印刷方式）が指定されている
  • PRINTMODEパラメタに4（帳票サーバ直接印刷方式）が指定されている

PRINTERSELECTMODEパラメタを省略する場合は，-1を設定します。PRINTERSELECTMODEパラメタの指定を省略した場合，または0，1，2以外の値を指定した場合は，0が仮定されます。

また，帳票サーバによる直接印刷（PRINTMODEパラメタに4が指定）の場合，2の値を指定するとエラーになります。

DISPPRINTDLG

クライアントPCで印刷する場合，ダイアログを表示するかどうかを選択します。指定できる値と印刷時の動作を次に示します。

  • 0：印刷先指定ダイアログを表示します（対話型印刷）。
    プレビューボタンを選択すると，プレビューウィンドウが表示されます。
  • 1：直接印刷を実行します（自動印刷）。
    印刷実行中に印刷中のダイアログが表示されます。
  • 2：プレビューウィンドウを表示します（対話型印刷プレビュー表示）。
    印刷メニューまたは印刷ボタンを選択すると，印刷先指定ダイアログが表示されます。
  • 3：直接印刷を実行します（全自動印刷）。
    印刷実行中に印刷中のダイアログは表示されません。
  • 4：プレビューウィンドウを表示します（対話型印刷プレビュー表示限定）。
    印刷は実行できません。

DISPPRINTDLGパラメタを省略した場合，EUR Server - Adapterの環境設定ファイル（EURPMADP.ini）でOPTIONセクションのDISPPRINTDLGキーの設定値（0～4）が仮定されます。環境設定ファイルDISPPRINTDLGキーおよびDISPPRINTDLGパラメタとも省略した場合，0が仮定されます。CLIENTPRINTERNAMEパラメタを指定した場合，かつDISPPRINTDLGパラメタに0または2を指定した場合は，1が仮定されます。

DISPPRINTDLGパラメタは，PRINTMODEパラメタに1（印刷方式がクライアント印刷方式），または2（印刷方式が蓄積）が指定されている場合だけ有効になります。それ以外の場合は，DISPPRINTDLGパラメタを指定しても無視されます。

DESTNAME

出力先名を指定します。

なお，UNIX／Linux環境の場合，出力先（スプールサーバ）での印刷はサポートしていません。UNIX／Linux環境のEUR Server - Spool Serviceに対して，印刷を実行した場合はエラーとなります。

次のことに注意して，出力先名を指定してください。

  • 指定する出力先名が，80バイトに満たない場合は，空白で埋めてください。
  • 出力先名には「"」および「,」を含めないでください。

このパラメタを省略する場合は，空白を設定します。

DESTNAMEパラメタは，次に示すどちらかの指定がある場合有効になります。それ以外の場合は，DESTNAMEパラメタを指定しても無視されます。

  • PRINTMODEパラメタに3（印刷方式がスプールサーバ印刷方式），かつSERVERSELECTMODEパラメタに0（スプールサーバ指定方式が出力先名指定）のとき
  • PRINTMODEパラメタに2（印刷方式が蓄積），かつSERVERSELECTMODEパラメタに0（スプールサーバ指定方式が出力先名指定）のとき

SERVERADDR

スプールサーバのIPアドレスを255.255.255.255形式で指定します。

なお，UNIX／Linux環境の場合，スプールサーバでの印刷はサポートしていません。UNIX／Linux環境のEUR Server - Spool Serviceに対して，印刷を実行した場合はエラーとなります。

SERVERADDRパラメタを省略した場合は，デフォルト値（127.0.0.1）が仮定されます。

SERVERADDRパラメタは，次に示すどちらかの指定がある場合有効になります。それ以外の場合は，SERVERADDRパラメタを指定しても無視されます。

  • PRINTMODEパラメタに3（印刷方式がスプールサーバ印刷方式），かつSERVERSELECTMODEパラメタに1（スプールサーバ指定方式がIPアドレス指定）のとき
  • PRINTMODEパラメタに2（印刷方式が蓄積），かつSERVERSELECTMODEパラメタに1（スプールサーバ指定方式がIPアドレス指定）のとき

PRINTERCLASSNAME

プリンタクラス名を指定します。

次のことに注意して，プリンタクラス名を指定してください。

  • 指定するプリンタクラス名が，80バイトに満たない場合は，空白で埋めてください。
  • プリンタクラス名には「"」および「,」を含めないでください。
  • プリンタクラス名に「EUR_DELIVERY_PRINT_OUTPUT_DEFAULT_PRINTER_CLASS_________________________________」は使用できません。

印刷方法ごとに指定するパラメタを次に示します。パラメタの組み合わせが異なる場合，指定した値は無効となります。なお，クライアントPCへの配布印刷では，指定できません。

  • スプールサーバでの印刷を指定する場合
    PRINTMODEパラメタ：3
    PRINTERSELECTMODEパラメタ：0
    PRINTERCLASSNAMEパラメタ：拠点プリンタクラス名
  • クライアントPCでの対話型印刷を指定する場合
    PRINTMODEパラメタ：1
    DISPPRINTDLGパラメタ：0
    PRINTERCLASSNAMEパラメタ：帳票ジョブ名，およびEPF形式ファイルの属性情報に設定するプリンタクラス名
  • クライアントPCでの自動印刷を指定する場合
    PRINTMODEパラメタ：1
    DISPPRINTDLGパラメタ：1
    PRINTERCLASSNAMEパラメタ：クライアントプリンタクラス名
  • クライアントPCでの対話型印刷プレビューを指定する場合
    PRINTMODEパラメタ：1
    DISPPRINTDLGパラメタ：2
    PRINTERCLASSNAMEパラメタ：帳票ジョブ名，およびEPF形式ファイルの属性情報に設定するプリンタクラス名
  • クライアントPCでの全自動印刷を指定する場合
    PRINTMODEパラメタ：1
    DISPPRINTDLGパラメタ：3
    PRINTERCLASSNAMEパラメタ：クライアントプリンタクラス名
  • クライアントPCでの対話型印刷プレビュー表示限定
    PRINTMODEパラメタ：1
    DISPPRINTDLGパラメタ：4
    PRINTERCLASSNAMEパラメタ：EPF形式ファイルの属性情報に設定するプリンタクラス名
  • 帳票サーバでの印刷を指定する場合
    PRINTMODEパラメタ：4
    PRINTERSELECTMODEパラメタ：0
    PRINTERCLASSNAMEパラメタ：帳票サーバプリンタクラス名
  • スプールサーバでの蓄積を指定する場合（プリンタクラス名指定）
    PRINTMODEパラメタ：2
    PRINTERSELECTMODEパラメタ：0
    PRINTERCLASSNAMEパラメタ：拠点プリンタクラス名，または蓄積クライアント印刷方式のプリンタクラス名
  • スプールサーバでの蓄積を指定する場合（OS上のプリンタ名指定）
    PRINTMODEパラメタ：2
    PRINTERSELECTMODEパラメタ：1
    PRINTERCLASSNAMEパラメタ：EPF形式ファイルの属性情報に設定するプリンタクラス名
  • スプールサーバでの蓄積を指定する場合（帳票名による自動振り分け）
    PRINTMODEパラメタ：2
    PRINTERSELECTMODEパラメタ：2
    PRINTERCLASSNAMEパラメタ：EPF形式ファイルの属性情報に設定するプリンタクラス名

「クライアントPCでの自動印刷」と「蓄積クライアント印刷」の場合，CLIENTPRINTERNAMEパラメタとPRINTERCLASSNAMEパラメタでは，CLIENTPRINTERNAMEパラメタの設定を優先します。

PRINTERCLASSNAMEパラメタを省略する場合は，空白を設定します。

PRINTERCLASSNAMEパラメタを省略したときは，EPF形式ファイルのプリンタクラス名情報は未設定となります。

SERVERPRINTERNAME

サーバのプリンタ名を指定します。プリンタ名はOS上のプリンタ名を指定してください。

次のことに注意して，プリンタ名を指定してください。

  • 指定するプリンタ名が，80バイトに満たない場合は，空白で埋めてください。
  • プリンタ名には「"」および「,」を含めないでください。

SERVERPRINTERNAMEパラメタを省略する場合は，空白を設定します。

SERVERPRINTERNAMEパラメタは，次に示す指定がある場合有効になります。それ以外の場合は，SERVERPRINTERNAMEパラメタを指定しても無視されます。

  • PRINTMODEパラメタに3（印刷方式がスプールサーバ印刷方式），かつPRINTERSELECTMODEパラメタに1（プリンタ指定方式がOS上のプリンタ名指定）のとき
  • PRINTMODEパラメタに2（印刷方式が蓄積），かつPRINTERSELECTMODEパラメタに1（プリンタ指定方式がOS上のプリンタ名指定）のとき
  • PRINTMODEパラメタに4（帳票サーバ直接印刷方式），かつPRINTERSELECTMODEパラメタに1（プリンタ指定方式がOS上のプリンタ名指定）のとき

SERVERTRAYNAME

サーバのプリンタのトレイ名を指定します。トレイ名はOS上のプリンタ名を指定してください。

SERVERTRAYNAMEパラメタを指定するときは，SERVERPRINTERNAMEパラメタを必ず指定してください。

Windows環境の場合
次のことに注意して，トレイ名を指定してください。
  • 指定するトレイ名が，80バイトに満たない場合は，空白で埋めてください。
  • トレイ名には「"」および「,」を含めないでください。
SERVERTRAYNAMEパラメタを省略する場合は，空白を指定します。
SERVERTRAYNAMEパラメタを指定しない場合は，SERVERPRINTERNAMEパラメタで指定したプリンタのデフォルトのトレイから出力されます。また，SERVERTRAYNAMEパラメタに指定したトレイ名が，出力先のプリンタで使用できない場合は，SERVERPRINTERNAMEパラメタで指定したプリンタのデフォルトのトレイから出力されます。
SERVERTRAYNAMEパラメタは，次に示す指定がある場合有効になります。それ以外の場合は，SERVERTRAYNAMEパラメタを指定しても無視されます。
  • PRINTMODEパラメタに3（印刷方式がスプールサーバ印刷方式），かつPRINTERSELECTMODEパラメタに1（プリンタ指定方式がOS上のプリンタ名指定）のとき
  • PRINTMODEパラメタに2（印刷方式が蓄積），かつPRINTERSELECTMODEパラメタに1（プリンタ指定方式がOS上のプリンタ名指定）のとき
  • PRINTMODEパラメタに4（帳票サーバ直接印刷方式），かつPRINTERSELECTMODEパラメタに1（プリンタ指定方式がOS上のプリンタ名指定）のとき
UNIX／Linux環境の場合
  • 給紙トレイ情報を指定します。SERVERTRAYNAMEパラメタを指定しない場合は，プリンタ定義ファイルのキーワード（DefaultCassette）に指定されているデフォルトのトレイから給紙されます。
    プリンタ定義ファイルの詳細については，「11.5　プリンタ定義ファイル」を参照してください。
  • 指定する給紙トレイ情報を次に示します。
    指定内容 | 給紙トレイ
    auto | 印刷用紙を自動で給紙します。出力する帳票の用紙サイズから給紙トレイを自動選択します。
    manual | 手差しトレイから印刷用紙を給紙します。
    トレイ番号 トレイ番号の給紙トレイから印刷用紙を給紙します。トレイ番号は，1～n（nはプリンタ定義ファイルのキーワードCassettesで指定した値）で指定します。
    6以上の値を指定した場合は自動給紙となります。
    注意
    SERVERTRAYNAMEパラメタでは次に示す指定があった場合，プリンタのハードウェアによって動作が異なります。
    • manualが指定されたとき
    • トレイ番号が指定されたとき
    • autoが指定されたのに，プリンタのパネルで給紙トレイが選択されたとき
    また，帳票の用紙サイズと給紙される用紙のサイズが異なる場合も，プリンタのハードウェアによって動作が異なります。
    帳票の用紙サイズと給紙される用紙のサイズを合わせておくか，または帳票の用紙サイズと異なる用紙に出力する場合は，あらかじめ試し印刷を実施してプリンタの動作を確認してください。

GROUPNAME

帳票振り分け定義の振り分けグループ名を指定します。

次のことに注意して，振り分けグループ名を指定してください。

  • 指定する振り分けグループ名が，80バイトに満たない場合は，空白で埋めてください。
  • 振り分けグループ名には「"」および「,」を含めないでください。

GROUPNAMEパラメタを省略する場合は，空白を指定します。

GROUPNAMEパラメタは，次に示すどちらかの指定がある場合有効になります。それ以外の場合は，GROUPNAMEパラメタを指定しても無視されます。

  • PRINTMODEパラメタに3（印刷方式がスプールサーバ印刷方式），かつPRINTKINDパラメタに0（印刷モードがEPF形式ファイル印刷モード）のとき
  • PRINTMODEパラメタに2（印刷方式が蓄積），かつPRINTERSELECTMODEパラメタに2（プリンタ指定方式が帳票名による自動振り分け）のとき

REPLACEITEMCNTLFILENAME

置き換え表管理情報ファイル名を指定します。

環境設定ファイル（EURPM.ini）でOPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，置き換え表管理情報ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのREPLACEITEMキーで設定しているフォルダに格納しておいてください。

OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。パスは，REPLACEITEMCNTLFILEPATHパラメタに指定することもできます。REPLACEITEMCNTLFILEPATHパラメタにパスを指定しない場合は，次のことに注意してください。

  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのREPLACEITEMキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのREPLACEITEMキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのREPLACEITEMキーで設定しているフォルダにあるファイル名を指定してください。

置き換え表管理情報ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

REPLACEITEMCNTLFILENAMEパラメタを省略する場合は，空白を指定します。

REPLACEITEMCNTLFILENAMEパラメタは，次に示すどれかの指定がある場合，有効になります。PRINTMODEパラメタに3（印刷方式がスプールサーバ印刷方式），かつPRINTKINDパラメタに1（印刷モードがEUR形式ファイル印刷モード）の場合は，REPLACEITEMCNTLFILENAMEパラメタを指定しても無視されます。

  • PRINTMODEパラメタに3（印刷方式がスプールサーバ印刷方式），かつPRINTKINDパラメタに0（印刷モードがEPF形式ファイル印刷モード）のとき
  • PRINTMODEパラメタに1（印刷方式がクライアント印刷方式）のとき
  • PRINTMODEパラメタに2（印刷方式が蓄積）のとき

置き換え表管理情報ファイルは，EUR Server Service稼働マシンに配置してください。

REPLACEITEMCNTLFILEPATH

REPLACEITEMCNTLFILENAMEパラメタで指定した置き換え表管理情報ファイルのパスを指定します。

REPLACEITEMCNTLFILENAMEパラメタをフルパスで指定した場合は，REPLACEITEMCNTLFILEPATHパラメタを指定する必要はありません。REPLACEITEMCNTLFILEPATHパラメタを省略する場合は，空白を指定します。

置き換え表管理情報ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

REPLACEITEMCNTLFILENAMEパラメタは，次に示すどれかの指定がある場合，有効になります。PRINTMODEパラメタに3（印刷方式がスプールサーバ印刷方式），かつPRINTKINDパラメタに1（印刷モードがEUR形式ファイル印刷モード）の場合は，REPLACEITEMCNTLFILENAMEパラメタを指定しても無視されます。

  • PRINTMODEパラメタに3（印刷方式がスプールサーバ印刷方式），かつPRINTKINDパラメタに0（印刷モードがEPF形式ファイル印刷モード）のとき
  • PRINTMODEパラメタに1（印刷方式がクライアント印刷方式）のとき
  • PRINTMODEパラメタに2（印刷方式が蓄積）のとき

SPOOLFILENAME

スプールデータに格納するファイル名を指定します。格納ファイル名が256バイトに満たない場合は空白で埋めてください。そのほか，格納ファイルを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

「%N」を指定すると，00000001から始まる8桁の通し番号を設定できます。

SPOOLFILENAMEパラメタを省略する場合は，空白を指定します。

SPOOLFILENAMEパラメタを省略した場合は，自動的にファイル名が生成されます。自動的に生成されるファイル名は「ジョブID.epf」※です。

複数のスプールデータに同一ファイル名が指定されている場合，スプールデータ取得時に同一パスで取得されると，ファイルが上書きされます。同一パスで取得する可能性のあるファイルは，別の格納ファイル名に指定することをお勧めします。

SPOOLFILENAMEパラメタは，PRINTMODEパラメタに2（印刷方式が蓄積）が指定されている場合だけ有効になります。

注※
「ジョブID」の形式を次に示します。
EUR＋処理実行日時＋通番フォルダ番号+通し番号
処理実行日時（17桁）：YYYYMMDDhhmmssmmm
通番フォルダ番号（7桁）：0000001～2000000
通し番号（9桁）：000000001～999999999
通番フォルダ番号が2000000を超えた場合は，エラー（KEEY430-S）になります。
通し番号が999999999を超えた場合は，000000003に戻ります。

SPOOLLIMIT

スプールデータの蓄積期限日を指定します。

蓄積期限日は，日付または日数で指定してください。

日付で指定する場合
  • 「YYYYMMDD」の形式で指定してください。
  • 年（西暦）は4桁，月と日は2桁で入力します。
  • 月，または日が1～9の場合は，ゼロ埋めをして入力します。
  • 指定できる値の上限は，20380118（2038年1月18日）です。
  • 過去の日付は指定できません。
（指定例）20120521，20141008
日数で指定する場合
  • 「+XXX」の形式で指定してください。
  • 「XXX」には，蓄積実行時からの保管日数を指定します。指定できる値は000～999です。0を指定した場合は，翌日にスプールデータが削除されます。
  • 2038年1月18日を超える日数は指定できません。
（指定例）+030，+999

SPOOLLIMITパラメタを指定しない場合，蓄積期限日は蓄積を要求したEUR Server - Adapterの環境設定ファイルのOPTIONセクションのSPOOLLIMITキーの指定に従います。蓄積期限日を過ぎたスプールデータは蓄積期限切れファイル削除機能によって削除されます。

SPOOLLIMITパラメタは，PRINTMODEパラメタに2（印刷方式が蓄積）が指定されている場合だけ有効になります。

EXECUTABLEPRINTMODE

実行可能印刷方式を指定します。

指定できる値を次に示します。

  • 0：スプールサーバでの印刷
  • 1：スプールサーバでの印刷，またはクライアントPCでの印刷
  • 2：クライアントPCでの印刷

EXECUTABLEPRINTMODEパラメタを省略する場合は，-1を指定します。EXECUTABLEPRINTMODEパラメタの指定を省略した場合は，1が仮定されます。

EXECUTABLEPRINTMODEパラメタは，PRINTMODEパラメタに2（印刷方式が蓄積）が指定されている場合だけ有効になります。

MAXPRINTCOUNT

スプールデータの印刷回数の上限を指定します。指定できる値は，-1～65,536です。印刷回数の上限を無限にする場合は，-1を指定します。印刷を禁止する場合は，0を指定します。

MAXPRINTCOUNTパラメタを省略する場合は，-1を指定します。MAXPRINTCOUNTパラメタの指定を省略した場合は，-1が仮定されます。

MAXPRINTCOUNTパラメタは，PRINTMODEパラメタに2（印刷方式が蓄積）が指定されている場合だけ有効になります。

ENABLEGET

スプールデータを取得するかどうかを指定します。

指定できる値を次に示します。

  • 0：スプールデータを取得できません。
  • 1：スプールデータを取得できます。

ENABLEGETパラメタを省略する場合は，-1を指定します。

ENABLEGETパラメタは，PRINTMODEパラメタに2（印刷方式が蓄積）が指定されている場合だけ有効になります。

PRINTHOLDMODE

スプールデータを印刷する場合に，蓄積後に続けて印刷するかどうかを指定します。

指定できる値を次に示します。

  • 0：蓄積後に続けて印刷しません（印刷保留）。
  • 1：蓄積後に続けてスプールサーバで印刷します。
  • 2：蓄積後に続けてクライアントPCで印刷します。

PRINTHOLDMODEパラメタを省略する場合は，-1を指定します。PRINTHOLDMODEパラメタの指定を省略した場合は，REPORTADDRKEYCATEGORYパラメタおよびREPORTADDRKEYDATAパラメタの指定の有無によって次の値が仮定されます。

REPORTADDRKEYCATEGORYパラメタおよびREPORTADDRKEYDATAパラメタの指定がある場合
0が仮定されます。
REPORTADDRKEYCATEGORYパラメタおよびREPORTADDRKEYDATAパラメタの指定がない場合
1が仮定されます。

PRINTHOLDMODEパラメタは，PRINTMODEパラメタに2（印刷方式が蓄積）が指定されている場合だけ有効になります。

JOBKEYCATEGORY

スプールデータの検索キーの分類を指定します。

指定できる検索キーは，10個までです。ただし，検索キーの分類を6個以上指定する場合，6～10個の項目はJOBKEYS2構造体のJOBKEYCATEGORY2パラメタで指定してください。JOBKEYCATEGORYパラメタを指定する場合は，検索キーの分類に対応する検索キーの値を必ずJOBKEYDATAパラメタに指定してください。このとき，要素数が同じになるように指定してください。検索キーを指定しない場合，JOBKEYCATEGORYパラメタとJOBKEYDATAパラメタは，どちらも指定しないでください。どちらかの指定がある場合は，対応する情報がないため，エラーになります。

検索キーの分類は，任意文字列を指定できます。次のことに注意して指定してください。

  • 分類が80バイトに満たない場合は，空白で埋めてください。
  • 分類には「,」を含めないでください。

JOBKEYCATEGORYパラメタを省略する場合は，空白を指定します。

JOBKEYCATEGORYパラメタは，PRINTMODEパラメタに2（印刷方式が蓄積）が指定されている場合だけ有効になります。

JOBKEYDATA

スプールデータの検索キーの値を指定します。

指定できる検索キーは，10個までです。ただし，検索キーを6個以上指定する場合，6～10個の項目はJOBKEYS2構造体のJOBKEYDATA2パラメタで指定してください。JOBKEYCATEGORYパラメタを指定する場合は，検索キーの分類に対応する検索キーの値を必ずJOBKEYDATAパラメタに指定してください。このとき，要素数が同じになるように指定してください。検索キーを指定しない場合，JOBKEYCATEGORYパラメタとJOBKEYDATAパラメタは，どちらも指定しないでください。どちらかの指定がある場合は，対応する情報がないため，エラーになります。

検索キーの値は，任意文字列を指定できます。次のことに注意して指定してください。

  • 分類が80バイトに満たない場合は，空白で埋めてください。
  • 分類には「,」を含めないでください。

JOBKEYDATAパラメタを省略する場合は，空白を指定します。

JOBKEYDATAパラメタは，PRINTMODEパラメタに2（印刷方式が蓄積）が指定されている場合だけ有効になります。

PMSERVERADDR

帳票サーバのIPアドレスを255.255.255.255形式で指定します。

PMSERVERADDRパラメタを省略した場合はデフォルト値（127.0.0.1）が仮定されます。

PMSERVERPORT

帳票サーバのポート番号を指定します。

PMSERVERPORTパラメタを省略する場合は，-1を指定します。

EPFFILENAME

入力EPF形式ファイル名を指定します。

EPFFILENAMEパラメタを省略したい場合は，空白を指定します。

EPFFILEPATH

EPFFILENAMEパラメタで指定したEPF形式ファイルのパスを指定します。

EPFFILENAMEパラメタをフルパスで指定した場合は，EPFFILEPATHパラメタを指定する必要はありません。

EPFFILEPATHパラメタを省略したい場合は，空白を指定します。

JOBKEYCATEGORY2

スプールデータの検索キーの分類を指定します。

指定できる検索キーは，10個までです。ただし，指定する検索キーの分類が5個以下の場合，1～5個の項目はJOBKEYS構造体のJOBKEYCATEGORYパラメタで指定してください。JOBKEYCATEGORY2パラメタを指定する場合は，検索キーの分類に対応する検索キーの値を必ずJOBKEYDATA2パラメタに指定してください。このとき，要素数が同じになるように指定してください。検索キーを指定しない場合，JOBKEYCATEGORY2パラメタとJOBKEYDATA2パラメタは，どちらも指定しないでください。どちらかの指定がある場合は，対応する情報がないため，エラーになります。

検索キーの分類は，任意文字列を指定できます。次のことに注意して指定してください。

  • 分類が80バイトに満たない場合は，空白で埋めてください。
  • 分類には「,」を含めないでください。

JOBKEYCATEGORY2パラメタを省略する場合は，空白を指定します。

JOBKEYCATEGORY2パラメタは，PRINTMODEパラメタに2（印刷方式が蓄積）が指定されている場合だけ有効になります。

JOBKEYDATA2

スプールデータの検索キーの値を指定します。

指定できる検索キーは，10個までです。ただし，指定する検索キーが5個以下の場合，1～5個の項目はJOBKEYS構造体のJOBKEYDATAパラメタで指定してください。JOBKEYCATEGORY2パラメタを指定する場合は，検索キーの分類に対応する検索キーの値を必ずJOBKEYDATA2パラメタに指定してください。このとき，要素数が同じになるように指定してください。検索キーを指定しない場合，JOBKEYCATEGORY2パラメタとJOBKEYDATA2パラメタは，どちらも指定しないでください。どちらかの指定がある場合は，対応する情報がないため，エラーになります。

検索キーの値は，任意文字列を指定できます。次のことに注意して指定してください。

  • 分類が80バイトに満たない場合は，空白で埋めてください。
  • 分類には「,」を含めないでください。

JOBKEYDATA2パラメタを省略する場合は，空白を指定します。

JOBKEYDATA2パラメタは，PRINTMODEパラメタに2（印刷方式が蓄積）が指定されている場合だけ有効になります。

PSENVFILENAME

EUR Print Serviceの動作環境を印刷ジョブごとに変更する場合に，EUR Server Serviceの環境設定ファイル（EURPS_ENV）名を指定します。

EUR Server Serviceの環境設定ファイル（EURPM.ini）で，OPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，PSENVFILENAMEパラメタは，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのPSENVキーで設定しているフォルダに格納しておいてください。

OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。

パスは，PSENVFILEPATHパラメタに指定することもできます。PSENVFILEPATHパラメタにパスを指定しない場合は，次のことに注意してください。

  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPSENVキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPSENVキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPSENVキーで設定しているフォルダにあるファイル名を指定してください。

EUR Server Serviceの環境設定ファイル（EURPS_ENV）名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

PSENVFILENAMEパラメタを省略する場合は，空白を指定します。

EUR Server Serviceの環境設定ファイル（EURPS_ENV）は，EUR Server Service稼働マシンに配置してください。

PSENVFILEPATH

PSENVFILENAMEパラメタで指定したEUR Server Serviceの環境設定ファイル（EURPS_ENV）のパスを指定します。

PSENVFILENAMEパラメタをフルパスで指定した場合は，PSENVFILEPATHパラメタを指定する必要はありません。PSENVFILEPATHパラメタを省略する場合は，空白を指定します。

EUR Server Serviceの環境設定ファイル（EURPS_ENV）のパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

PRINTDATEFILENAME

印刷日時出力定義ファイル名を指定します。

EUR Server Serviceの環境設定ファイル（EURPM.ini）で，OPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，PRINTDATEFILENAMEパラメタは，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのPRINTDATEキーで設定しているフォルダに格納しておいてください。

OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。

パスは，PRINTDATEFILEPATHパラメタに指定することもできます。PRINTDATEFILEPATHパラメタにパスを指定しない場合は，次のことに注意してください。

  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPRINTDATEキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPRINTDATEキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPRINTDATEキーで設定しているフォルダにあるファイル名を指定してください。

印刷日時出力定義ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

PRINTDATEFILENAMEパラメタを省略する場合は，空白を指定します。

印刷日時出力定義ファイルは，EUR Server Service稼働マシンに配置してください。

PRINTDATEFILEPATH

PRINTDATEFILENAMEパラメタで指定した印刷日時出力定義ファイルのパスを指定します。

PRINTDATEFILENAMEパラメタをフルパスで指定した場合は，PRINTDATEFILEPATHパラメタを指定する必要はありません。PRINTDATEFILEPATHパラメタを省略する場合は，空白を指定します。

印刷日時出力定義ファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

SPLITMODE

蓄積時に，帳票を分割または仕分けするかどうかを指定します。

指定できる値を次に示します。

  • 0：EUR Server Serviceの環境設定ファイルのOPTIONセクションのSPLITMODEキーの指定に従います。
  • 1：分割または仕分けしないで蓄積します。
  • 2：帳票を仕分けして蓄積します。
  • 3：帳票を分割して蓄積します。

SPLITMODEパラメタを省略する場合は，-1を指定します。

SPLITMODEパラメタは，PRINTMODEパラメタに2（印刷方式が蓄積）が指定されている場合だけ有効になります。

SPLITFILENAME

帳票を分割または仕分けして蓄積する場合に，分割定義ファイルまたは仕分け定義ファイルのファイル名を指定します。

ファイル名を指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

SPLITFILENAMEパラメタを省略する場合は，空白を指定します。

SPLITFILENAMEパラメタは，PRINTMODEパラメタに2（印刷方式が蓄積）が指定されている場合で，かつ次のどちらかの条件に当てはまるときに指定が有効になります。それ以外の場合は，SPLITFILENAMEパラメタを指定しても無視されます。

  • SPLITMODEパラメタに2（帳票を仕分けして蓄積）または3（帳票を分割して蓄積）を指定しているとき。
  • SPLITMODEパラメタに0（EUR Server Serviceの環境設定ファイルの指定に従う）を指定していて，かつEUR Server Serviceの環境設定ファイルのOPTIONセクションのSPLITMODEキーにPAGE（分割）またはKEY（仕分け）を指定しているとき。

分割定義ファイルまたは仕分け定義ファイルは，EUR Server - Adapter稼働マシンに配置してください。

SPLITFILEPATH

SPLITFILENAMEパラメタで指定した，分割定義ファイルまたは仕分け定義ファイルのパスを指定します。

SPLITFILENAMEパラメタをフルパスで指定した場合は，SPLITFILEPATHパラメタを指定する必要はありません。SPLITFILEPATHパラメタを省略する場合は，空白を指定します。

SPLITFILEPATHパラメタは，PRINTMODEパラメタに2（印刷方式が蓄積）が指定されている場合で，かつ次のどちらかの条件に当てはまるときに指定が有効になります。それ以外の場合は，SPLITFILEPATHパラメタを指定しても無視されます。

  • SPLITMODEパラメタに2（帳票を仕分けして蓄積）または3（帳票を分割して蓄積）を指定しているとき。
  • SPLITMODEパラメタに0（EUR Server Serviceの環境設定ファイルの指定に従う）を指定していて，かつEUR Server Serviceの環境設定ファイルのOPTIONセクションのSPLITMODEキーにPAGE（分割）またはKEY（仕分け）を指定しているとき。

パスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

JOBIDNUM

JOBIDSパラメタの繰り返し回数nを指定します。nには取得するスプールデータのジョブIDの最大数を指定してください。

スプールデータの数がnを超える場合は，n個までのジョブIDが取得されます。

JOBIDS

取得したジョブIDの一覧が格納される領域を指定します。詳細は，戻り値JOBIDSを参照してください。

nには取得するスプールデータのジョブIDの最大数を指定してください。

SPOOLTITLE

次のことに注意して，スプールタイトルを指定してください。

  • 指定するスプールタイトルが，256バイトに満たない場合は，空白で埋めてください。
  • スプールタイトルには「"」および「,」を含めないでください。

SPOOLTITLEパラメタを省略する場合は，空白を設定します。

SPOOLTITLEパラメタを省略したときは，印刷時のスプールタイトルには，文書情報設定ファイルのTITLEキーの指定値，または帳票ファイル名が出力されます。

戻り値

RTNCODE

終了コードが設定されます。終了コードについては，「10.4.1　エラー情報一覧」を参照してください。

ERRORMESSAGE

エラーが発生した場合，エラーメッセージとメッセージIDが設定されます。エラーメッセージについては，マニュアル「EUR メッセージ」を参照してください。

エラーが発生しなかった場合は，空白が設定されます。

JOBID

スプールデータのジョブIDが設定されます。PRINTMODEパラメタに2（印刷方式が蓄積）が指定されている場合だけ参照できます。

帳票を分割または仕分けして蓄積した場合など，蓄積したスプールデータが複数あるときは，最初に蓄積したスプールデータのジョブIDを参照できます。

JOBIDNUM

スプールデータのジョブIDの数が設定されます。最大値は，JOBIDNUMパラメタの指定値です。PRINTMODEパラメタに2（印刷方式が蓄積）が指定されている場合で，エラーが発生していないときだけ取得できます。PRINTMODEパラメタに2以外が指定されている場合やエラーが発生した場合は，JOBIDNUMパラメタに指定した値がそのまま設定されます。

蓄積処理中に警告（KEEY387-W）が発生した場合，配列要素の末尾に設定される文字列「Error」も一つとしてカウントされます。

JOBIDS

スプールデータのジョブIDが設定されます。PRINTMODEパラメタに2（印刷方式が蓄積）が指定されている場合で，エラーが発生していないときだけ取得できます。

帳票を分割または仕分けして蓄積した場合など，蓄積したスプールデータが複数あるときは，一つのジョブIDが一つの配列要素に設定されます。また，蓄積処理中に警告（KEEY387-W）が発生した場合，配列要素の末尾に文字列「Error」が設定されます。

蓄積したスプールデータの数がJOBIDNUMパラメタで指定した数よりも少ない場合は，戻り値JOBIDNUMの数だけジョブIDの情報が返され，それ以外の領域は不定となります。

蓄積したスプールデータの数がJOBIDNUMパラメタで指定した数よりも多い場合は，ジョブIDの情報がファイルの蓄積順にJOBIDNUMパラメタで指定した数だけ返されます。

エラーメッセージ

EUR Print Serviceと連携して使用するパラメタでエラーが発生した場合は，次のエラーメッセージが出力されます。メッセージが表示されたときは，EUR Print Serviceのイベントログ，またはeurpsログを参照してください。

メッセージID | メッセージ
KEEY221-E | 印刷処理でエラーが発生しました。（337）


エラー情報

10.4　エラー情報

COBOL起動部品を使用して実行している場合にエラーが発生したときは，引数RTNCODEに終了コード，引数ERRORMESSAGEにメッセージが設定されます。

＜この節の構成＞
10.4.1　エラー情報一覧
10.4.2　RTNCODE（終了コード）
10.4.3　ERRORMESSAGE（メッセージ）


エラー情報一覧

10.4.1　エラー情報一覧

COBOL起動部品実行時のエラー情報の一覧を次に示します。

表10-3　 COBOL起動部品実行時のエラー情報の一覧

終了コード | メッセージ文
201 | プロパティ(プロパティ名)の指定値に誤りがあります。
202 | プロパティ(プロパティ名)が指定されていません。
203 | マッピングデータファイルの読み込みに失敗しました。
204 | ユーザ定義データファイルの読み込みに失敗しました。
205 | パラメタに誤りがあります。
206 | 必須パラメタの指定がありません。
207 | サーバプリンタ名の指定がありません。
208 | 原因不明のエラーで処理が中断されました。EUR Server Serviceの状態を確認してください。
209 | 印刷処理で警告が発生しました。(nnn)
210 | 環境設定ファイルに不正があります。詳細コード = [nnnnnn]※
211 | ログファイルの書き込みに失敗しました。
212 | EUR Server Serviceへの接続に失敗しました。
213 | ジョブを起動しました。
214 | ジョブを終了しました。
215 | メモリ不足が発生しました。
216 | 通信タイムアウトが発生しました。
217 | システムエラーが発生しました。
218 | 出力先一覧取得処理でエラーが発生しました。（nnn）
219 | プリンタクラス一覧取得処理でエラーが発生しました。（nnn）
221 | 印刷処理でエラーが発生しました。（nnn）
222 | クライアントプリンタ名の指定がありません。
223 | PDF形式ファイル出力処理でエラーが発生しました。(nnn)
224 | PDF形式ファイル出力処理で警告が発生しました。(nnn)
225 | EPF形式ファイル出力処理でエラーが発生しました。(nnn)
226 | EPF形式ファイル出力処理で警告が発生しました。(nnn)
227 | PDF形式ファイルの初期化に失敗しました。
228 | EPF形式ファイルの初期化に失敗しました。
229 | PDF形式ファイルの作成に失敗しました。
230 | EPF形式ファイルの作成に失敗しました。
231 | 指定されたPDF形式ファイルはほかの人が使用中です。
232 | 指定されたEPF形式ファイルはほかの人が使用中です。
233 | 帳票セット指定ファイルのフォーマットが不正です。
234 | 帳票セット指定ファイルの読み込みに失敗しました。
235 | しおり定義ファイルの読み込みに失敗しました。
236 | 文書しおり定義ファイルの読み込みに失敗しました。
237 | EUR Server Serviceでコネクション数が限界値をオーバーしました。
238 | EUR Spool Serviceでコネクション数が限界値をオーバーしました。
239 | EUR Client Serviceでコネクション数が限界値をオーバーしました。
241 | 指定されたEUR形式ファイルはほかの人が使用中です。
242 | EUR形式ファイルの初期化に失敗しました。
243 | EUR形式ファイル出力処理でエラーが発生しました。(nnn)
244 | EUR形式ファイル出力処理で警告が発生しました。(nnn)
245 | EUR形式ファイルの作成に失敗しました。
246 | EUR Server Serviceのバージョンが不正です。
247 | レジストリに不正があります。詳細コード = [nnnnnn]※
248 | 暗号化設定ファイルの読み込みに失敗しました。
249 | 指定されたマッピングデータファイルが存在しません。
250 | 指定されたユーザ定義データファイルが存在しません。
251 | 指定されたしおり定義ファイルが存在しません。
252 | 指定された文書しおり定義ファイルが存在しません。
253 | 指定された暗号化設定ファイルが存在しません。
255 | プリンタ一覧取得処理でエラーが発生しました。（nnn）
256 | トレイ一覧取得処理でエラーが発生しました。（nnn）
257 | 蓄積処理でエラーが発生しました。（nnn）
258 | 蓄積処理で警告が発生しました。（nnn）
259 | PDF仕分け定義ファイルの読み込みに失敗しました。
260 | 指定されたPDF仕分け定義ファイルが存在しません。
261 | EPF形式ファイルの読み込みに失敗しました。
262 | 指定されたEPF形式ファイルが存在しません。
263 | XLSX形式ファイル出力処理でエラーが発生しました。(nnn)
264 | XLSX形式ファイル出力処理で警告が発生しました。(nnn)
265 | 指定されたXLSX形式ファイルはほかの人が使用中です。
266 | XLSX形式ファイルの初期化に失敗しました。
267 | XLSX形式ファイルの作成に失敗しました。
269 | 統合対象EPF形式ファイルの指定数が有効範囲外です。
270 | 複数EPF形式ファイルの統合処理でエラーが発生しました。（nnn）
271 | 統合対象EPF形式ファイルの読み込みに失敗しました。
272 | 指定された統合対象EPF形式ファイルが存在しません。
273 | An attempt to load string resource DLL has failed. Error:[nnn]
274 | 仕分け/分割定義ファイルの読み込みに失敗しました。
275 | 出力すべき帳票セットがありません。(950)
注※
環境設定ファイル，およびレジストリに不正がある場合，エラーメッセージに詳細コードが出力されます。詳細コードについては，マニュアル「EUR メッセージ」を参照してください。


RTNCODE（終了コード）

10.4.2　RTNCODE（終了コード）

引数RTNCODEは，終了コードを返します。終了コードとメッセージの一覧については，「10.4.1　エラー情報一覧」を参照してください。エラーの対処については，マニュアル「EUR メッセージ」を参照してください。


ERRORMESSAGE（メッセージ）

10.4.3　ERRORMESSAGE（メッセージ）

引数ERRORMESSAGEは，メッセージ文を返します。終了コードとメッセージの一覧については，「10.4.1　エラー情報一覧」を参照してください。エラーの対処については，マニュアル「EUR メッセージ」を参照してください。


帳票サーバに準備するファイル

11.　帳票サーバに準備するファイル

この章では，EUR サーバ帳票出力機能で扱えるファイルのうち，帳票サーバに準備するファイルの種類と形式について説明します。

＜この章の構成＞
11.1　帳票サーバに準備するファイルの一覧
11.2　帳票ファイル
11.3　画像ファイル
11.4　文書情報設定ファイル
11.5　プリンタ定義ファイル
11.6　複数様式情報定義ファイル
11.7　接続情報ファイル
11.8　置き換え表管理情報ファイル
11.9　置き換え表ファイル
11.10　Acrobat JavaScript定義ファイル
11.11　Acrobat JavaScriptファイル
11.12　ビューアプレファレンス定義ファイル
11.13　テスト印刷設定ファイル
11.14　印刷日時出力定義ファイル
11.15　EURフォントファイル


帳票サーバに準備するファイルの一覧

11.1　帳票サーバに準備するファイルの一覧

帳票サーバに準備するファイルの概要を次の表に示します。

表11-1　帳票サーバに準備するファイルの一覧

ファイル名 | 説明
帳票ファイル | EUR 帳票作成機能で作成した帳票ファイルです。
画像ファイル | 帳票に表示する画像ファイルです。
文書情報設定ファイル | 出力先に表示する帳票名や，PDF文書情報を指定したファイルです。
プリンタ定義ファイル | 印刷位置補正情報や，印刷で使用するプリンタの情報などを定義したファイルです。
複数様式情報定義ファイル | 複数の帳票ファイルを組み合わせて一つの帳票のように入力するための情報を定義したファイルです。
接続情報ファイル | データベースと接続するために必要な情報を定義したファイルです。
置き換え表管理情報ファイル | 帳票を設計した時に設定された置き換え表名と，置き換え表ファイルの対応を定義したファイルです。
置き換え表ファイル | アイテムのデータを置き換えて出力する場合に，1フィールドごとの置き換え対象のデータと，置き換えて出力するデータを定義したファイルです。
Acrobat JavaScript定義ファイル | PDF形式ファイルに埋め込むAcrobat JavaScriptファイル名を指定したファイルです。
Acrobat JavaScriptファイル | PDF形式ファイルに埋め込むJavaScriptプログラムを指定したファイルです。
ビューアプレファレンス定義ファイル | 出力したPDF形式ファイルを開いたときに実行するビューアプレファレンスを指定するファイルです。
テスト印刷設定ファイル | テスト印刷用の文字列を重ねて出力するための情報を指定したファイルです。
印刷日時出力定義ファイル | プリンタでの印刷実行時の日時情報を帳票に出力するために必要な情報を定義するファイルです。
EURフォントファイル | Windows環境で作成した外字をUNIX／Linux環境で出力できるように変換したファイルです。


帳票ファイル

11.2　帳票ファイル

＜この節の構成＞
(1)　概要
(2)　扱える帳票ファイルの形式

(1)　概要

帳票ファイルとは，EUR 帳票作成機能で作成したファイルです。

帳票ファイルの作成については，マニュアル「EUR 帳票作成 操作ガイド」を参照してください。

(2)　扱える帳票ファイルの形式

フォームシートファイル形式（*.fms）だけ扱えます。


画像ファイル

11.3　画像ファイル

＜この節の構成＞
(1)　概要
(2)　扱える画像データの詳細形式
(3)　注意事項

(1)　概要

EUR サーバ帳票出力機能では，次の画像データを扱うことができます。

  • Windows BITMAP
  • JPEG
  • GIF（GIF GIF87a，GIF GIF89a）
  • TIFF（TIFF 6.0）
  • PNG

(2)　扱える画像データの詳細形式

扱える画像データの詳細形式を，次に示します。

表11-2　 EUR サーバ帳票出力機能で扱える画像データの形式

画像データの形式 詳細形式
Windows BITMAP（*.bmp）

           2色モノクロ
16色パレットカラー
256色パレットカラー
24ビットフルカラー
16色RLE圧縮
Windows環境のプリンタ印刷では出力できますが，次に示す場合には出力できません。
  • Windows環境でのPDF形式ファイル出力
  • UNIX／Linux環境でのプリンタ印刷，PDLファイル出力，およびPDF形式ファイル出力
256色RLE圧縮
Windows環境のプリンタ印刷では出力できますが，次に示す場合には出力できません。
  • Windows環境でのPDF形式ファイル出力
  • UNIX／Linux環境でのプリンタ印刷，PDLファイル出力，およびPDF形式ファイル出力
Windows 3.0以前のビットマップ形式
JPEG（*.jpg / *.jpe / *.jpeg）
           JFIFフォーマット基本DCT（ベースライン）フルカラー
JFIFフォーマット基本DCT（ベースライン）256色グレイスケール
GIF GIF87a（*.gif）

           2色モノクロ ノンインタレース
2色モノクロ インタレース
4色パレットカラー ノンインタレース
4色パレットカラー インタレース
16色パレットカラー ノンインタレース
16色パレットカラー インタレース
256色パレットカラー ノンインタレース
256色パレットカラー インタレース
GIF GIF89a（*.gif）

           2色モノクロ ノンインタレース
2色モノクロ インタレース
4色パレットカラー ノンインタレース
4色パレットカラー インタレース
16色パレットカラー ノンインタレース
16色パレットカラー インタレース
256色パレットカラー ノンインタレース
256色パレットカラー インタレース
透明色指定
上記の8フォーマット（色4種×インタレース2種）それぞれで透明色の有無の指定ができます。ただし，透明部分は，GIF画像中の背景色が使用されます。
アニメーション
上記の8フォーマット（色4種×インタレース2種）それぞれでアニメーションの有無の指定ができます。ただし，先頭の1枚目だけが使用されます。
TIFF 6.0（*.tif / *.tiff）

           2色モノクロ 非圧縮
2色モノクロ ハフマン圧縮
2色モノクロ G3/G4 Fax互換圧縮
16色 非圧縮
256色 非圧縮
24ビット色 非圧縮
グレイスケール 非圧縮
カラー：RGB指定
カラー：YCbCr指定
複数画像（ただし，先頭の1枚だけを対象とします）
ストリップ形式（カラーTIFFのストリップも使用できます）
PNG（*.png）

           2色パレットカラー ノンインタレース
2色パレットカラー インタレース
4色パレットカラー ノンインタレース
4色パレットカラー インタレース
16色パレットカラー ノンインタレース
16色パレットカラー インタレース
256色パレットカラー ノンインタレース
256色パレットカラー インタレース
2色グレイスケール ノンインタレース
2色グレイスケール インタレース
4色グレイスケール ノンインタレース
4色グレイスケール インタレース
16色グレイスケール ノンインタレース
16色グレイスケール インタレース
256色グレイスケール ノンインタレース
256色グレイスケール インタレース
65536色グレイスケール ノンインタレース（ただし，256色グレイスケールに減色されます）
65536色グレイスケール インタレース（ただし，256色グレイスケールに減色されます）
24ビットフルカラー ノンインタレース
24ビットフルカラー インタレース
48ビットフルカラー ノンインタレース（ただし，24ビットフルカラーに減色されます）
48ビットフルカラー インタレース（ただし，24ビットフルカラーに減色されます）
透明色指定
上記の22フォーマット（色11種×インタレース2種）それぞれで透明色の有無の指定ができます。ただし，透明部分は，PNG画像中の背景色が使用されます。
アニメーション
上記の22フォーマット（色11種×インタレース2種）でアニメーション有の指定はできません。
αチャネル指定
αチャネルは指定しても無効になります。

(3)　注意事項

■画像が正しく出力されない場合の注意
画像データの内容に問題があることがあります。このような場合は，画像を作成したソフトウェアとは別のソフトウェアで，画像を保存し直すことをお勧めします。
■画像のある帳票を出力するときの注意
  • TIFF形式のモノクロ画像，GIF形式のモノクロ画像，およびEUR形式はカラープリンタがサポートしていない画像形式のため印刷できないことがあります（エラーにはなりません）。
  • 256色以上のカラー画像を帳票上に貼り付けた場合，画像の色が実際の色と異なることがありますが，プリンタ出力では画像データで設定されている色に従って印刷されます。
■固定画像のある帳票を出力するときの注意
固定画像が定義されている帳票を出力する場合は，次に示す注意が必要です。
Windows環境，UNIX／Linux環境共通の注意
  • バージョン5以降のEUR 帳票作成機能では，「フォームシートファイル（*.fms）」の中に画像データを保存しますが，バージョン5より前のEUR 帳票作成機能では，画像ファイル名だけを保存します。そのため，バージョン5より前のEUR 帳票作成機能で設計した帳票を出力する場合は，帳票サーバに「フォームシートファイル（*.fms）」と固定画像用の「画像ファイル」が必要です。
UNIX／Linux環境の注意
ファイル名の大文字小文字を区別するため，次に示す注意が必要です。
  • バージョン04-02以降，かつバージョン5より前のEUR 帳票作成機能で設計した帳票を出力する場合
    帳票に固定画像が貼り付けられている場合は，そのままの画像ファイル名で保存されます。帳票を出力する場合は，使用する画像ファイルをそのまま転送してください。
  • バージョン04-01以前のEUR 帳票作成機能で設計した帳票を出力する場合
    帳票に固定画像が貼り付けられている場合，画像ファイル名に半角英大文字が使用されているときは，すべて半角英小文字に変換した画像ファイル名が保存されます。帳票を出力する場合は，画像ファイル名をすべて半角英小文字に直してから画像ファイルを転送してください。
  • バージョン04-01以前のEUR 帳票作成機能で帳票を設計する場合
    帳票に固定画像を貼り付ける場合，画像ファイル名に半角英大文字が使用されているときは，すべて半角英小文字に直してから，帳票を設計してください。


文書情報設定ファイル

11.4　文書情報設定ファイル

＜この節の構成＞
(1)　概要
(2)　形式
(3)　キーワード
(4)　指定例

(1)　概要

帳票をプリンタ出力，PDF形式ファイル出力，およびEUR形式ファイル出力する場合，出力先に表示する帳票名を指定したり，PDF文書情報を指定したりできます。

帳票名やPDF文書情報は，文書情報設定ファイルに設定します。

文書情報設定ファイルは，メモ帳など，テキストファイルが編集できるエディタを起動して編集します。任意の拡張子のファイルを使用できます。

(2)　形式

キーワード=値
キーワードに指定できる値を次に示します。

表11-3　 文書情報設定ファイルのキーワードに指定できる値と対応するプリンタ

キーワード 値 プリンタ出力 PDF形式ファイル出力 EUR形式ファイル出力
TITLE 出力先に表示する帳票名，またはPDF文書情報に表示するタイトルの文字列を指定します。 ○ ○ ○
SUBTITLE サブタイトルの文字列を指定します。 × ○ ×
AUTHOR ファイルの作成者を指定します。 × ○ ×
KEYWORD キーワードを指定します。 × ○ ×
（凡例）
○：指定は有効です。
×：指定は無視されます。

(3)　キーワード

文書情報設定ファイルに指定するキーワードは，大文字で指定します。大文字と小文字を混在させたり，小文字で指定したりした場合は，指定が無視されます。

また，キーワードを複数指定した場合は，最初に指定した情報が有効になります。

(a)　TITLE

プリンタ出力とEUR形式ファイル出力の場合は，出力先に表示する帳票名の文字列を指定します。

PDF形式ファイル出力の場合は，PDF文書情報に表示するタイトルの文字列を指定します。

■キーワードTITLEの形式
TITLE="文字列"
文字列
帳票名，またはPDF文書情報に表示するタイトルを「"」で囲んで指定します。「"」で囲まれていない場合，または「""」のように空の文字列で指定されている場合は，指定を無効と見なします。
文字列中に「"」を指定したい場合は，「"」を二つ続けて記述して，文字列の両端を「"」で囲んでください。例えば，「E"UR」とする場合は，「"E""UR"」と指定します。
ただし，EUR形式ファイルでは文字列中に「"」を指定できません。
  • 文字列に使用できる文字コード
    文字列に使用できる文字コードについては，マニュアル「EUR システム設計ガイド」を参照してください。
    文字列は，任意の文字列で指定できますが，制御文字，ベンダ定義文字（IBM拡張文字とNEC選定IBM拡張文字），および外字は指定できません。ベンダ定義文字を使用する場合は，Windows特殊文字（0x8740～0x87FC）を使用してください。
  • 指定できる文字列の長さ
    指定できる文字列の長さは，出力方法によって異なります。
    プリンタ出力の場合
    指定できる文字列の長さに制限はありません。指定された文字列はプリンタスプールのジョブ名になります。しかし，プリンタスプールのジョブ名に表示される文字列は，259文字までです。ただし，プリンタドライバによっては，指定した文字列が259文字以下でも，正常に印刷できないことがあります。指定できる文字列長の最大値は，プリンタによって異なりますのでご注意ください。
    PDF形式ファイル出力の場合
    指定できる文字列の長さに制限はありません。指定された文字列はすべて保存されます。ただし，指定した文字列がすべて表示されるかどうかは，Adobe Readerによって異なります。指定した文字列をすべて表示したい場合は，Adobe Readerで表示できる長さを確認してから，文字列を指定されることをお勧めします。
    EUR形式ファイル出力の場合
    指定できる文字列の長さに制限はありませんが，259文字までの文字列しか保存したり，表示したりされません。
(b)　SUBTITLE

PDF形式ファイル出力の場合，PDF文書情報に表示するサブタイトルの文字列を指定できます。プリンタ出力とEUR形式ファイル出力の場合は，キーワードSUBTITLEを指定しても無視されます。

■キーワードSUBTITLEの形式
SUBTITLE="文字列"
文字列
PDF文書情報に表示するサブタイトルを「"」で囲んで指定します。「"」で囲まれていない場合，または「""」のように空の文字列で指定されている場合は，指定を無効と見なします。
文字列中に「"」を指定したい場合は，「"」を二つ続けて記述して，文字列の両端を「"」で囲んでください。例えば，「E"UR」とする場合は，「"E""UR"」と指定します。
  • 文字列に使用できる文字コード
    文字列に使用できる文字コードについては，マニュアル「EUR システム設計ガイド」を参照してください。
    文字列は，任意の文字列（日本語も含む）で指定できますが，制御文字，ベンダ定義文字（IBM拡張文字とNEC選定IBM拡張文字），および外字は指定できません。ベンダ定義文字を使用する場合は，Windows特殊文字（0x8740～0x87FC）を使用してください。
  • 指定できる文字列の長さ
    指定できる文字列の長さに制限はありません。指定された文字列はすべて保存されます。ただし，指定した文字列がすべて表示されるかどうかは，Adobe Readerによって異なります。指定した文字列をすべて表示したい場合は，Adobe Readerで表示できる長さを確認してから，文字列を指定されることをお勧めします。
(c)　AUTHOR

PDF形式ファイル出力の場合，PDF文書情報に表示するファイルの作成者を指定できます。プリンタ出力とEUR形式ファイル出力の場合は，キーワードAUTHORを指定しても無視されます。

■キーワードAUTHORの形式
AUTHOR="文字列"
文字列
PDF文書情報に表示するファイルの作成者を「"」で囲んで指定します。「"」で囲まれていない場合，または「""」のように空の文字列で指定されている場合は，指定を無効と見なします。
文字列中に「"」を指定したい場合は，「"」を二つ続けて記述して，文字列の両端を「"」で囲んでください。例えば，「E"UR」とする場合は，「"E""UR"」と指定します。
  • 文字列に使用できる文字コード
    文字列に使用できる文字コードについては，マニュアル「EUR システム設計ガイド」を参照してください。
    文字列は，任意の文字列（日本語も含む）で指定できますが，制御文字，ベンダ定義文字（IBM拡張文字とNEC選定IBM拡張文字），および外字は指定できません。ベンダ定義文字を使用する場合は，Windows特殊文字（0x8740～0x87FC）を使用してください。
  • 指定できる文字列の長さ
    指定できる文字列の長さに制限はありません。指定された文字列はすべて保存されます。ただし，指定した文字列がすべて表示されるかどうかは，Adobe Readerによって異なります。指定した文字列をすべて表示したい場合は，Adobe Readerで表示できる長さを確認してから，文字列を指定されることをお勧めします。
(d)　KEYWORD

PDF形式ファイル出力の場合，PDF文書情報に表示するキーワードを指定できます。プリンタ出力とEUR形式ファイル出力の場合は，キーワードKEYWORDを指定しても無視されます。

■キーワードKEYWORDの形式
KEYWORD="文字列"
文字列
PDF文書情報に表示するキーワードを「"」で囲んで指定します。「"」で囲まれていない場合，または「""」のように空の文字列で指定されている場合は，指定を無効と見なします。
文字列中に「"」を指定したい場合は，「"」を二つ続けて記述して，文字列の両端を「"」で囲んでください。例えば，「E"UR」とする場合は，「"E""UR"」と指定します。
  • 文字列に使用できる文字コード
    文字列に使用できる文字コードについては，マニュアル「EUR システム設計ガイド」を参照してください。
    文字列は，任意の文字列（日本語も含む）で指定できますが，制御文字，ベンダ定義文字（IBM拡張文字とNEC選定IBM拡張文字），および外字は指定できません。ベンダ定義文字を使用する場合は，Windows特殊文字（0x8740～0x87FC）を使用してください。
  • 指定できる文字列の長さ
    指定できる文字列の長さに制限はありません。指定された文字列はすべて保存されます。ただし，指定した文字列がすべて表示されるかどうかは，Adobe Readerによって異なります。指定した文字列をすべて表示したい場合は，Adobe Readerで表示できる長さを確認してから，文字列を指定されることをお勧めします。

(4)　指定例

文書情報設定ファイルの指定例を次に示します。

  • プリンタ出力，およびEUR形式ファイル出力の場合
    TITLE="横浜支社の人事管理"

  • PDF形式ファイル出力の場合
    TITLE="人事管理"
SUBTITLE="TOKYO-Area"
AUTHOR="Jinji1"
KEYWORD="Jinji,TOKYO,YOKOHAMA,CHIBA"


プリンタ定義ファイル

11.5　プリンタ定義ファイル

＜この節の構成＞
(1)　概要
(2)　形式
(3)　キーワード
(4)　指定例

(1)　概要

プリンタ定義ファイルのファイル名は「printerinf」固定です。格納先については「15.3.30　EURPS_PRINTERINFPATH」を参照してください。

プリンタ定義ファイルには，次に示す情報を定義します。

  • 印刷位置補正情報
  • 印刷で使用するプリンタの情報
  • PDF形式ファイルを印刷するときの解像度情報
  • CODE39/GS1-128（UCC/EAN-128）/CODE128バーコードのバーコード補正情報
  • QRコードのセルサイズ
  • バーコードの描画方法
  • PDF形式ファイルへのフォント埋め込み
印刷位置補正情報
帳票印刷時に印刷位置を補正するために，水平方向と垂直方向のシフト量をプリンタ定義ファイルに定義します。
例えば，プレプリント用紙を使用した場合，出力先プリンタのハードの給紙精度によって印刷位置がずれることがあります。プリンタごとの補正情報をプリンタ定義ファイルに定義しておくことで，印刷位置がずれることなく印刷できます。
印刷位置を補正できるのは，帳票サーバでの印刷，およびPDF形式ファイル出力の場合です。
印刷で使用するプリンタの情報
両面印刷の指定や，UNIX／Linux環境での印刷で使用するプリンタ情報をプリンタ定義ファイルに定義します。
プリンタ定義ファイルは，Windows環境でのプリンタアイコンの代わりになるものです。プリンタのハード情報（PDL言語，解像度，マージンなど）や，プリンタアイコンのプロパティで指定できる内容（給紙トレイ，両面印刷など）を定義します。
一つのプリンタ定義ファイルに，複数のプリンタ情報を登録できます。
PDF形式ファイルを印刷するときの解像度情報
PDF形式ファイルは，使用するプリンタの解像度に合わせて印刷されます。PDF形式ファイルと解像度が異なるプリンタで印刷されたバーコードは，バーコードリーダで正しく読み取れないときがあります。
プリンタ定義ファイルに使用するプリンタの解像度を指定することで，プリンタの解像度に合わせたPDF形式ファイルを出力できます。バーコードのあるPDF形式ファイルを印刷する場合は，必ず指定することをお勧めします。
CODE39/GS1-128（UCC/EAN-128）/CODE128バーコードのバーコード補正情報
CODE39バーコード，CODE128バーコードおよびGS1-128（UCC/EAN-128）バーコードのエレメントやバーの幅を指定できます。これによって，バーコードの印字精度を使用するプリンタに合わせてカスタマイズできます。
QRコードのセルサイズ
QRコードのセルサイズを指定できます。QRコードのセルサイズを指定することによって，QRコードのサイズを自由に変えられるので，作成した帳票に合わせたQRコードのカスタマイズができます。
バーコードの描画方法
バーコードの描画方法を変更できます。QRバーコードまたはカスタマバーコードがにじんだり周囲に線が表示されたりする場合に指定すると，出力結果が改善することがあります。
PDF形式ファイルへのフォント埋め込み
PDF形式ファイルにフォントを埋め込んで出力できます。フォントを埋め込むと，出力したマシンと同じフォントがインストールされていないマシンでも，PDF形式ファイルをプレビューしたり印刷したりできるようになります。

(2)　形式

[エントリ名]
キーワード=値

プリンタ定義ファイルに記述する項目の内容を次に示します。

表11-4　 プリンタ定義ファイルに記述する項目

項目 | 説明
エントリ名
  • 「印刷位置補正情報」，または「UNIXでの印刷で使用するプリンタの情報」を設定する場合は，次に示すプリンタ名を指定します。
    Windows環境の場合：Windowsで登録されているプリンタ名
    UNIX／Linux環境の場合：任意のプリンタ名
    起動部品，コマンドまたは構成定義ファイルで定義したプリンタ名と同じです。
    半角空白を含むプリンタ名を指定する場合は，プリンタ名を「"」で囲んで指定してください。半角空白を含むプリンタ名を「"」で囲まないで指定した場合は，エラー（KEEU103-E）になります。
  • 「PDF形式ファイルを印刷するときの解像度情報」を設定する場合は，半角英字の大文字で「PDF」と指定します。
キーワード=値 | プリンタ情報を「キーワード=値」の形式で記述します。
プリンタ定義ファイルの記述に空白を指定する場合の注意
空白（△）を指定する場合は，次のように指定してください。
△1[エントリ名]△2
△1キーワード△1=△1値△1
空白（△）の説明
△1：0個以上のタブ，半角空白，または全角空白を示します。
△2：これ以降，改行コード（\r\n，または\n）までを無視します。

(3)　キーワード

プリンタ定義ファイルに記述するキーワード一覧を次に示します。プリンタ定義ファイルのキーワードは，大文字，小文字の区別をしません。

表11-5　 プリンタ定義ファイルのキーワード一覧

エントリ名 | キーワード | 説明 | 指定の有効／無効
 |  |  | Windows | UNIX／Linux
プリンタ名 | PDLType | プリンタがサポートしているPDLの種類を指定します。 | × | ◎
 | XDPI | プリンタの横解像度を指定します。 | × | ◎
 | YDPI | プリンタの縦解像度を指定します。 | × | ◎
 | Margin | プリンタのハードマージンを指定します。 | × | ○
 | Duplex | 両面印刷するかどうかを指定します。 | ○ | ○
 | DuplexBinding | 両面印刷する場合に，用紙のとじ代の方向を指定します。 | ○ | ○
 | BindingAdjust | 両面印刷する場合，偶数ページを印刷するときに用紙の余白の位置を入れ替えるかどうかを指定します。 | ○ | ○
 | Cassettes | プリンタにセットされている給紙トレイの数を指定します。 | × | ○
 | DefaultCassette | 使用する給紙トレイを指定します。 | × | ○
 | Color | カラー印刷するかどうかを指定します。 | × | ○
 | Command | 生成したPDLファイルを出力するコマンドを指定します。 | × | ○
 | PaperShiftX | 横方向の印刷位置補正値を指定します。 | ○ | ○
 | PaperShiftY | 縦方向の印刷位置補正値を指定します。 | ○ | ○
 | Font | フォントの置き換え情報を指定します（PostScript対応プリンタに出力する場合）。 | × | ○
 | CODE39PARAM | CODE39バーコードのバーコード補正情報を指定します。 | ○ | ○
 | CODE128PARAM | CODE128バーコードのバーコード補正情報を指定します。 | ○ | ○
 | CODE128PATTERN | GS1-128（UCC/EAN-128）バーコードチューニングのパターンファイル名を指定します。 | ○ | ○
 | QRCellSizeD | 生成されるQRコードのセルサイズをドット単位で指定します。 | ○ | ○
 | QRCellSizeM | 生成されるQRコードのセルサイズを100分の1ミリメートル単位で指定します。 | ○ | ○
 | GenTextMode | PostScript対応プリンタでUnicodeを出力するために，PostScript対応プリンタとデバイスフォントに対応したPS2形式ファイルを作成します。 | × | ○
 | BarcodeImageSize | QRバーコードまたはカスタマバーコードの出力データのサイズを小さくする場合に指定します。 | ○ | ○
 | DrawBarStyle | バーコードの描画方法を変更します。 | ○ | ×
PDF | YDPI | PDF形式ファイルを印刷するプリンタの解像度を指定します。 | ○ | ○
 | PaperShiftX | PDF出力時の横方向の位置補正値を指定します。 | ○ | ○
 | PaperShiftY | PDF出力時の縦方向の位置補正値を指定します。 | ○ | ○
 | CODE39PARAM | CODE39バーコードのバーコード補正情報を指定します。 | ○ | ○
 | CODE128PATTERN | GS1-128（UCC/EAN-128）バーコードチューニングのパターンファイル名を指定します。 | ○ | ○
 | EmbedCount | 埋め込むフォントの数を指定します。 | ○ | ○
 | Embed1，Embed2，…EmbedN | 書体名と，それに対応するフォントファイル名を指定します。 | ○ | ○
 | QRCellSizeD | 生成されるQRコードのセルサイズをドット単位で指定します。 | ○ | ○
 | QRCellSizeM | 生成されるQRコードのセルサイズを100分の1ミリメートル単位で指定します。 | ○ | ○
 | BarcodeImageSize | QRバーコードまたはカスタマバーコードの出力データのサイズを小さくする場合に指定します。 | ○ | ○
 | DrawBarStyle | バーコードの描画方法を変更します。 | × | ×
（凡例）
◎：有効（省略できません）
○：有効（省略できます）
×：無効

(a)　PDLType

プリンタがサポートしているPDLの種類を指定します。

表11-6　 PDLTypeの指定値

指定値 | 説 明
LIPS3 | LIPSIII対応プリンタを使用します。
PS2 | PostScript対応プリンタを使用します。
ESCP | ESC/Pプリンタを使用します。

「LIPS3」，「PS2」と「ESCP」は，大文字，小文字を区別しません

LIPSIII対応プリンタに，PostScript対応プリンタを示す「PS2」を指定した場合など，プリンタがサポートしているPDLと異なるPDLを指定した場合は，印刷結果を保証しません。

(b)　XDPI

プリンタの横解像度を指定します。単位は，dpiです。

(c)　YDPI
  • エントリ名がプリンタ名の場合
    プリンタの縦解像度を指定します。単位は，dpiです。
  • エントリ名がPDFの場合
    PDF形式ファイル出力の縦解像度を指定します。単位は，dpiです。指定できる値は「300」，「600」，および「720」です。省略した場合は，「720」が仮定されます。
(d)　Margin

プリンタのハードマージンを指定します。単位は，mm（ミリメートル）です。ハードマージンは，上下左右の順に「:」で区切って指定します。省略した場合は，「0:0:0:0」が仮定されます。

指定値は，LIPSIII対応プリンタの場合に有効となります。ESC/Pプリンタの場合は，印刷ライブラリでハードマージンを「0:0:0:0」で固定しているため，指定しても無視されます。

（例）上下左右のハードマージンを5mmとする場合
Margin=5:5:5:5
(e)　Duplex

両面印刷するかどうかを指定します。

表11-7　 Duplexの指定値

指定値 | 説 明
true | 両面印刷します。
false | 両面印刷しません。

「true」と「false」は，大文字，小文字を区別しません。

Windows環境で「true」，「false」以外の値を指定したり，指定を省略したりした場合は，プリンタの印刷設定に従います。

UNIX／Linux環境で「true」，「false」以外の値を指定したり，指定を省略したりした場合は，「false（両面印刷しません）」が仮定されます。

注意
  • Windows環境の場合，両面印刷ができないプリンタに対してもキーワードDuplexを設定できますが，出力結果は保証しません。
  • UNIX／Linux環境でPDLファイルに出力する場合，ESC/P対応プリンタ，またはLIPS対応プリンタでもキーワードDuplexを設定できますが，両面印刷はできません。
    両面印刷ができないプリンタに「true」を指定した場合，出力結果は保証しません。
(f)　DuplexBinding

両面印刷する場合の，用紙のとじ代の方向を指定します。キーワードDuplexで「true」を指定した場合，またはプリンタの印刷設定が両面印刷になっている場合に有効です。

表11-8　DuplexBindingの指定値

指定値 | 説 明
Short | 用紙の短辺にとじ代を設定します。
Long | 用紙の長辺にとじ代を設定します。

「Short」と「Long」は，大文字，小文字を区別しません。

Windows環境で「Short」，「Long」以外の値を指定したり，指定を省略したりした場合は，キーワードDuplexの設定，およびプリンタの印刷設定によって次のように仮定されます。

Duplexが「true」かつ，プリンタ設定が両面印刷の場合
プリンタで指定されたとじ代の方向が仮定されます。
Duplexが「true」かつ，プリンタ設定が片面印刷の場合
「Long（用紙の長辺にとじ代を設定します）」が仮定されます。
Duplexの値が省略されている場合
プリンタで指定されたとじ代の方向が仮定されます。

UNIX／Linux環境で「Short」，「Long」以外の値を指定したり，指定を省略したりした場合は，「Long（用紙の長辺にとじ代を設定します）」が仮定されます。

印刷結果は，DuplexBindingの指定値と，用紙の印刷の向きとの組み合わせによって次のように異なります。

図11-1　DuplexBindingの指定値と用紙の印刷の向きとの組み合わせでの印刷結果の違い

注意
PostScript対応プリンタで出力する場合，バージョン08-30以前では用紙の短辺にとじ代を設定していた帳票が，バージョン08-50以降では用紙の長辺にとじ代を設定されることがあります。このとき，キーワードDuplexBindingに「Short（用紙の短辺にとじ代を設定します）」を指定してください。
(g)　BindingAdjust

両面印刷を行う場合，偶数ページを印刷するときに用紙の余白の位置を入れ替えるかどうかを指定します。

表11-9　BindingAdjustの指定値

指定値 | 説 明
true | 余白を入れ替えます。
false | 余白を入れ替えません。

「true」と「false」は，大文字，小文字を区別しません。

指定を省略した場合は「false」が仮定されます。

余白の位置を入れ替えると，とじ代が必要な帳票を両面印刷する場合に，とじ代を含んだ余白を帳票の左右または上下のどちらかだけに設定して印刷できます。左右または上下のどちらの余白を入れ替えるかは，BindingAdjustの指定値と，とじ代の方向（キーワードDuplexBindingまたはプリンタで設定）との組み合わせで次のように異なります。

図11-2　とじ代を含む余白の設定例

注意
キーワードBindingAdjustを指定すると，最初に印刷されるページを奇数ページ，次に印刷されるページを偶数ページとして扱います。
例えば，起動部品やコマンドの指定によって帳票の2ページ目から印刷を開始しても，最初に印刷されるページ（2ページ目）は奇数ページ，次に印刷されるページ（3ページ目）は偶数ページとして扱います。
(h)　Cassettes

プリンタにセットされている給紙トレイの数を指定します。省略した場合は，「1」が仮定されます。

（例）2段給紙トレイのプリンタの場合
Cassettes=2
(i)　DefaultCassette

印刷時に使用する給紙トレイを指定します。省略した場合は，「Auto（自動給紙をします）」が仮定されます。

表11-10　 DefaultCassetteの指定値

指定値 | 説　　明
Auto 自動給紙します。
自動給紙を設定した場合は，次のように動作します。ただし，プリンタハードごとに動作が異なるため，試し印刷で動作確認されることをお勧めします。
  • プリンタのプロパティで給紙方法に自動給紙を設定されている場合は，出力する帳票の用紙サイズと同じ用紙サイズの給紙トレイを自動選択します。
  • プリンタのプロパティで給紙方法に給紙トレイを設定されている場合は，その給紙トレイから給紙します。
Manual | 手差しトレイから給紙します。
1～n | トレイ番号の給紙トレイから給紙します。トレイ番号は，1～n（nは，キーワードCassettesで指定した値）で指定します。6以上の値を指定した場合は，自動給紙となります。

「Auto」と「Manual」は，大文字，小文字を区別しません。

起動部品やコマンドで給紙トレイが指定されている場合は，起動部品やコマンドの指定が優先されます。

注意
帳票の用紙サイズと給紙される用紙サイズが異なる場合，プリンタによって動作が異なります。使用するプリンタのマニュアルで確認してください。
(j)　Color

カラー印刷するか，またはモノクロ印刷するかのどちらかを指定します。省略した場合は，「false（モノクロ印刷をします）」が仮定されます。

表11-11　 Colorの指定値

指定値 | 説 明
true | カラー印刷をします。
false | モノクロ印刷をします。

「true」と「false」は，大文字，小文字を区別しません。

PostScript対応カラープリンタに「true」を指定した場合は，カラー印刷されます。

PostScript対応カラープリンタに「false」を指定した場合は，モノクロ印刷されます。

PostScript対応モノクロプリンタ，LIPSIII対応プリンタ，およびESC/P対応プリンタに「true」を指定した場合は，モノクロ印刷されます。

モノクロ印刷をする場合，帳票の色指定されたアイテムは，モノクロ2値に変換して出力されます。

(k)　Command

キーワードPDLTypeで指定したPDL種別で作成されたファイルを，実際にプリンタへ出力して印刷を実行する場合に，その出力コマンドを指定します。

  • プリンタへ印刷する場合
    lp出力コマンドで，次に示す形式で指定します。
    /usr/bin/lp -d出力先プリンタ名
    出力先プリンタ名には，動作するOS上で定義したプリンタ名を指定します。
    （例）
    Command=/usr/bin/lp -dPR1
(l)　PaperShiftX

横方向の出力位置補正値を，小数点以下1桁（nn.n形式）で指定します。出力位置の補正値は，0.1mm単位で-10.0～10.0で指定します。省略した場合は，「0.0」が仮定されます。

出力位置を左方向にシフトする場合は負数，右方向にシフトする場合は正数を指定します。

  • エントリ名がプリンタ名の場合
    出力位置を補正しても，ハードマージンには印刷できません。
    また，プリンタハードによっては，出力位置を補正することで，一部のオブジェクトがハードマージンに掛かってしまった場合，印刷が欠けることがあります。試し印刷で動作確認することをお勧めします。
  • エントリ名がPDFの場合
    出力印刷位置を補正することで，一部のオブジェクトが用紙の外にはみ出した場合，出力結果が欠けることがあります。事前に出力内容を確認することをお勧めします。
(m)　PaperShiftY

縦方向の出力位置補正値を，小数点以下1桁（nn.n形式）で指定します。出力位置の補正値は，0.1mm単位で-10.0～10.0で指定します。省略した場合は，「0.0」が仮定されます。

出力位置を上方向にシフトする場合は負数，下方向にシフトする場合は正数を指定します。

  • エントリ名がプリンタ名の場合
    出力位置を補正しても，ハードマージンには印刷できません。
    また，プリンタハードによっては，出力位置を補正することで，一部のオブジェクトがハードマージンに掛かってしまった場合，印刷が欠けることがあります。試し印刷で動作確認することをお勧めします。
  • エントリ名がPDFの場合
    出力印刷位置を補正することで，一部のオブジェクトが用紙の外にはみ出した場合，出力結果が欠けることがあります。事前に出力内容を確認することをお勧めします。
(n)　Font

PostScript対応プリンタは，リュウミンL-KL，または中ゴシックBBBでしか印刷できません。設計した帳票に使用されているフォントのまま，PostScript対応プリンタで帳票を印刷する場合は，置き換えるフォント情報を，次に示す形式で指定します。複数指定する場合は，コンマ「,」で区切ります。なお，置き換えができるフォントは，EURが日本語フォントとして認識しているフォントだけです。

Font=置き換え前フォント名:置き換え後フォント名
     〔〔,置き換え前フォント名:置き換え後フォント名〕…〕
置き換え前フォント名
EUR 帳票作成機能で帳票を設計した時に，［アイテムのプロパティ］ダイアログの［フォント］ページに設定したフォント名を指定します。
置き換え後フォント名
プリンタに搭載されているPostScriptフォント名をそのまま指定します。
日本語のフォントを指定する場合は，「Ryumin-Light-90ms-RKSJ-H」のように，文字セット，エンコード，および縦横指定を含んだPostScriptフォント名にしてください。
置き換え前フォントが，縦横指定のあるフォント（末尾が-H，または-V）の場合は，置き換え後フォントも合わせて，縦横指定のあるフォントで指定してください。
置き換え後フォントに欧文フォントを指定する場合は，次に示すように，EUR 帳票作成機能で帳票を設計してください。
  • 欧文フォントなど，縦横比が2:1ではないフォントを指定すると，文字がアイテム枠からはみ出して印刷されます。帳票を正しく印刷するには，あらかじめアイテム枠を大きめに定義してください。
  • ［アイテムのプロパティ］ダイアログの［文字配置］タブで設定する［文字の方向］は，「上向きで，左から右へ」，「左向きで，下から上へ」，または「右向きで，上から下へ」のどれかで指定してください。「上向きで，上から下へ」と「左向きで，左から右へ」を指定すると，正しく印刷されません。

キーワードFontの指定を省略した場合，帳票に使用されているフォントは，次のように置き換えて印刷されます。

表11-12　 帳票フォントの置き換え

帳票に使用されているフォント | 出力時のフォント
ＭＳ 明朝 | リュウミンL-KL
MS Mincho
HG行書体
HG教科書体
HG明朝B
HG明朝E
ＭＳ ゴシック | 中ゴシックBBB
MS Gothic
HGゴシックE
HGゴシックM
HG創英角ポップ体
HG創英プレゼンスEB
HG創英角ゴシックUB

注　表にないフォントを使用している場合，「リュウミンL-KL」に置き換えて出力します。

指定できるフォント名の長さは128文字までです。128文字よりも長い名称を指定すると，エラー（KEEU102-E）になります。

(o)　CODE39PARAM

CODE39バーコードのバーコード補正情報を指定します。次に示す形式で指定します。

type〔,〔エレメント幅比〕,〔Param〕〕
type
エレメント幅の求め方を指定します。

表11-13　CODE39PARAMの指定値

指定値 | 説明
0 細エレメントのサイズから計算された1文字の幅から，細エレメント，太エレメントを計算します。
計算の結果，発生したずれはすべてキャラクタ間ギャップに追加されるため，サイズは自由に調整できます。
1 細エレメントのサイズをドット単位に変換した値と，細エレメント，太エレメント，キャラクタ間ギャップの比から，各バーの太さを計算します。
各バーの太さはドットで計算されるため，サイズの調整は段階的になります。
2 | 1を指定した場合の計算方法に加えて，バーコードの線の太さを補正します。
省略した場合，または0～2以外の値を指定した場合は，「0」が仮定されます。
エレメント幅比
細エレメント，太エレメント，およびキャラクタ間ギャップの比率を指定します。次に示す形式で指定します。

細エレメント：太エレメント：キャラクタ間ギャップ

細エレメントには，1以上の値を指定してください。
太エレメントには，細エレメントの2.0～3.0倍の値を指定してください。
キャラクタ間ギャップには，細エレメントの値以上の値を指定してください。
エレメント幅比を正しく指定していない場合，エレメント幅はtypeに0が指定されたときの方法で計算されます。
Param
typeに2を指定した場合，バーコードの線の太さを細く補正する幅をミリメートル単位で指定します。指定した値をドット単位に変換した計算値の小数第一位を四捨五入した値が補正されます。計算されたドット数の分だけ黒バーが細く，白バーが太くなります。
バーコードの線の太さは，補正するドット数の計算結果が1以上の場合に補正されます。
Paramに指定した値をドット単位に変換する計算式を次に示します。
計算値（ドット） = Paramに指定する値 ÷ 25.4 ×解像度（dpi）
解像度300dpiの場合，補正するドット数の計算結果を次に示します。

表11-14　解像度300dpiの場合に補正するドット数

Paramに指定する値（ミリメートル） | 補正するドット数（ドット） | 計算値（ドット）
0.04 | 0 | 0.472441
0.041 | 0 | 0.484252
0.042 | 0 | 0.496063
0.043 | 1 | 0.507874
0.044 | 1 | 0.519685
0.045 | 1 | 0.531496
0.046 | 1 | 0.543307
解像度600dpiの場合，補正するドット数の計算結果を次に示します。

表11-15　解像度600dpiの場合に補正するドット数

Paramに指定する値（ミリメートル） | 補正するドット数（ドット） | 計算値（ドット）
0.02 | 0 | 0.472441
0.021 | 0 | 0.496063
0.022 | 1 | 0.519685
0.023 | 1 | 0.543307
0.024 | 1 | 0.566929
0.025 | 1 | 0.590551
0.026 | 1 | 0.614173
Paramには1モジュール以上のドット数の幅は指定できません。Paramに指定した値が1モジュール以上のドット数になる場合は，1ドットが指定されます。
typeに2を指定しても，Paramを指定していない場合，エレメント幅はtypeに1が指定されたときの方法で計算されます。エレメント幅比を正しく指定していない場合，エレメント幅はtypeに0が指定されたときの方法で計算されます。

CODE39PARAMは，バージョン05-06以降で指定できます。05-05以前のバージョンでは，自動的にtypeに0が指定された場合と同じ計算方法でエレメント幅が決定します。CODE39バーコードのバーコード補正情報の指定例を次に示します。

（例）CODE39バーコードの細エレメント，太エレメント，キャラクタ間ギャップの幅の比を1対2.5対1に変更し，黒バーの太さを0.04mm細く補正する場合
CODE39PARAM=2,1:2.5:1,0.04

注意
CODE39バーコードのバーコード補正情報は，プリンタ定義ファイルのほかに，環境変数でも指定できます。プリンタ定義ファイルと環境変数のどちらも指定された場合は，プリンタ定義ファイルの内容が優先されます。
(p)　CODE128PARAM

CODE128バーコードのバーコード補正情報を指定します。次に示す形式で指定します。

type〔,〔Param1〕,〔Param2〕〕

環境変数EURPS_CODE128_PARAMとプリンタ定義ファイルのキーワードCODE128PARAMが同時に指定された場合は，プリンタ定義ファイルの指定が有効になります。

type
バーコードの描画方式を指定します。

表11-16　CODE128PARAMの指定値

指定値 | 説明
0 | ミリメートル（mm）で指定したモジュールサイズからバーキャラクタサイズを計算します。モジュールサイズ×11（mm）を超えないドット数でバーキャラクタを描画します。ストップキャラクタは，モジュールサイズ×13（mm）を超えないドット数で描画します。1を指定した場合と比べて，サイズを細かく指定できますが，バーコードの質は落ちます。
1 | ミリメートル（mm）で指定したモジュールサイズを超えないドット数を求め，その11倍をバーキャラクタのサイズにします。1ドットの大きさを超えるまではバーコードの大きさは変わりません。プリンタ解像度によって補正するドット数が変わります。
2 1を指定した場合の計算方法に加えて，Param1で指定した幅に相当するドット数分だけ黒バーを細く，白バーを太くします。
Param2を指定した場合は，Param1で指定した値で補正した状態のスタートキャラクタとストップキャラクタにParam2で指定した値でさらに補正します。
省略した場合，または0，1，2以外の値を指定した場合は，0が仮定されます。指定値が0の場合，Param1，およびParam2に指定した値は無視されます。
Param1
typeに2を指定した場合，バーを調整する幅をミリメートルで指定します。指定した値をドット単位に変換した計算値の小数第一位を四捨五入した値が補正されます。補正するドット数の計算結果が1以上の場合だけ補正されます。
Param1に指定した値をドット単位に変換する計算式を次に示します。
計算値（ドット） = Param1に指定する値 ÷ 25.4 ×解像度（dpi）
解像度300dpiの場合，補正するドット数の計算結果を次に示します。

表11-17　解像度300dpiの場合に補正するドット数

Param1またはParam2に指定する値（ミリメートル） | 補正するドット数（ドット） | 計算値（ドット）
0.04 | 0 | 0.472441
0.041 | 0 | 0.484252
0.042 | 0 | 0.496063
0.043 | 1 | 0.507874
0.044 | 1 | 0.519685
0.045 | 1 | 0.531496
0.046 | 1 | 0.543307
解像度600dpiの場合，補正するドット数の計算結果を次に示します。

表11-18　解像度600dpiの場合に補正するドット数

Param1またはParam2に指定する値（ミリメートル） | 補正するドット数（ドット） | 計算値（ドット）
0.02 | 0 | 0.472441
0.021 | 0 | 0.496063
0.022 | 1 | 0.519685
0.023 | 1 | 0.543307
0.024 | 1 | 0.566929
0.025 | 1 | 0.590551
0.026 | 1 | 0.614173
Param2
typeに2を指定した場合，Param1で指定した値で補正したスタートキャラクタとストップキャラクタを調整する幅をミリメートルで指定します。指定した値をドット単位に変換した計算値の小数第一位を四捨五入した値が補正されます。補正するドット数の計算結果が1以上の場合だけ補正されます。Param2に指定した値をドット単位に変換する計算式はParam1の場合と同じです。
解像度別の補正するドット数については，表11-17，表11-18を参照してください。

注意
  • バーの幅を超える値を指定した場合は，バーの幅を1ドットに設定します。
  • typeに1を指定した場合でも，Param1に数値を指定して，Param2を省略したときは0が仮定されます。
  • typeに2を指定した場合でも，次のときは0が仮定されます。
    ・Param1を指定しなかったとき
    ・Param1が数値以外，または0以下だったとき
  • typeに2を指定した場合でも，Param1に0より大きい値，Param2に0以下の値を指定したときはParam2は無視されます。
(q)　CODE128PATTERN

バーコードパターンファイル名をフルパスで指定します。CODE128PARAMまたは環境変数EURPS_CODE128_PARAMと同時に指定した場合は，CODE128PATTERNキーワードで指定されたパターンファイルを使用してチューニングされます。

CODE128PATTERN=バーコードパターンファイル名
(r)　EmbedCount

PDF形式ファイルに埋め込むフォントの数を指定します。1以上の数値を指定します。1以上の数値以外が指定された場合，フォントを埋め込みません。

（例）埋め込むフォントが三つの場合
EmbedCount=3
(s)　Embed1，Embed2，… EmbedN

PDF形式ファイルに埋め込むフォントの書体名と，書体名に対応するフォントファイル名を指定します。EmbedNの「N」には，1からEmbedCountで指定した数値までを指定します。書体名とフォントファイル名はコロン（:）で区切ります。

Embed1=書体名1:フォントファイル名1
Embed2=書体名2:フォントファイル名2
  ：
EmbedN=書体名N:フォントファイル名N
書体名
帳票定義に指定している書体名です。EUR 帳票作成機能の［アイテムのプロパティ］ダイアログに表示される名称を指定します。
フォントファイル名
TrueTypeフォントファイル，TrueTypeコレクションフォントファイル，またはTrueTypeのOpenTypeフォントファイルをフルパスで指定します。

1からEmbedCountで指定した数値の間の定義だけが有効となり，それ以外が指定された場合，指定は無視されます。

（例）EmbedCount=3の場合（Embed2が指定されていないとき）
次の指定は有効です。
Embed1=書体名1:フォントファイル名1
Embed3=書体名3:フォントファイル名3
この場合，指定した二つのフォントを埋め込みます。
（例）EmbedCount=3の場合（Embed4が指定されいるとき）
次の指定はEmbed4が無効です。
Embed1=書体名1:フォントファイル名1
Embed3=書体名3:フォントファイル名3
Embed4=書体名4:フォントファイル名4
注意事項
使用するフォントや文字によって，埋め込みができない場合があります。埋め込みに使用するフォントは，次の点を確認してから使用してください。
  • フォントファイルの属性に埋め込みが許可されているか
  • フォントの埋め込みについてライセンス許諾があるか
  • フォントを埋め込んだPDF形式ファイルを配布する場合，フォントの再配布についてライセンス許諾があるか
(t)　QRCellSizeD

生成されるQRコードのセルサイズ（1セル当たりの大きさ）をドット単位で指定します。

表11-19　 QRCellSizeDの指定値

指定値 | 説明
0 | セルサイズはアイテムの大きさとバージョンから自動的に決定されます。
5～10 | 指定した値がセルサイズになります。

0または5～10以外の値を指定した場合，またはQRCellSizeDに何も指定しなかった場合は，「0」が仮定されます。

QRCellSizeDとQRCellSizeMを同時に指定した場合は，QRCellSizeMの指定値が有効となります。

プリンタ定義ファイルのキーワードQRCellSizeDと環境変数EURPS_QR_CELL_SIZE_Dでセルサイズを同時に指定した場合は，プリンタ定義ファイルのキーワードQRCellSizeDの指定値が有効となります。

(u)　QRCellSizeM

生成されるQRコードのセルサイズ（1セル当たりの大きさ）を100分の1ミリメートル単位で指定します。

表11-20　 QRCellSizeMの指定値

指定値 | 説明
0 | セルサイズはアイテムの大きさとバージョンから自動的に決定されます。
21～126 | 指定した値がセルサイズになります。

0または21～126以外の値を指定した場合，またはQRCellSizeMに何も指定しなかった場合は，「0」が仮定されます。

QRCellSizeMとQRCellSizeDを同時に指定した場合は，QRCellSizeMの指定値が有効となります。

プリンタ定義ファイルのキーワードQRCellSizeMと環境変数EURPS_QR_CELL_SIZE_Mでセルサイズを同時に指定した場合は，プリンタ定義ファイルのキーワードQRCellSizeMの指定値が有効となります。

(v)　GenTextMode

日立のJISX0213:2004フォントを搭載したPostScript対応プリンタで，JISX0213:2004の文字集合の文字を出力するために，PostScript対応プリンタとデバイスフォントに対応したPS2形式ファイルを作成します。

GenTextModeの指定は，PDLTypeに「PS2」を指定した時だけ有効です。

表11-21　GenTextModeの指定値

指定値 | 文字コード
RPS2004M-UTF16 | UTF-16エンコーディングの文字を出力します。 PostScript対応プリンタで出力するJIS2004字形は，ＭＳ 明朝・ＭＳ ゴシックVer.5.0の字形に準拠しています。
(w)　BarcodeImageSize

QRバーコードまたはカスタマバーコードの出力データのサイズを指定します。

表11-22　BarcodeImageSizeの指定値

指定値 | 説明
normal | 通常の方法で出力します。
minimize | QRバーコード，またはカスタマバーコードの描画データを最小化します。

印刷時のスプールサイズや帳票ファイルのサイズを小さくしたい場合，または実行時間を短縮したい場合にはminimizeを指定します。

minimizeを指定すると，プリンタによっては，QRバーコードまたはカスタマバーコードがにじんだり周囲に線が表示されたりする場合があります。PDF形式ファイルに出力して印刷したときにも発生します。

このような場合は，DrawBarStyleを使用すると正しく表示できることがあります。

(x)　DrawBarStyle

バーコードの描画方法を変更します。

表11-23　DrawBarStyleの指定値

指定値 | 説明
SRCCOPY | 通常の方法で描画します。
NOTSRCCOPY | バーコードがにじんだり周囲に線が表示されたりする場合に，描画方法を変更します。

バーコードがにじんだり周囲に線が表示されたりする場合に，NOTSRCCPYを指定すると改善されることがあります。

なお，プリンタによっては，NOTSRCCPYを指定するとバーコードが白黒反転して描画されることがあります。

(4)　指定例

(a)　印刷位置補正情報を設定する場合
  • Windows環境，UNIX／Linux環境共通
    印刷位置を，右方向に5.0（mm）シフトするプリンタ定義ファイルの指定例を次に示します。
    [Printer1]
  PaperShiftX=5.0
  PaperShiftY=0.0
(b)　PDF形式ファイルにフォントを埋め込む場合

PDF形式ファイルに，二つのフォントを埋め込み，ＭＳ 明朝およびＭＳ ゴシックを指定する場合の，プリンタ定義ファイルの指定例を次に示します。

  • Windows環境の場合
    [PDF]
  EmbedCount=2
  Embed1=ＭＳ 明朝:c:\windows\fonts\msmincho.ttc
  Embed2=ＭＳ ゴシック:c:\windows\fonts\msgothic.ttc
(c)　PDF形式ファイルを印刷するときの解像度情報を設定する場合
  • UNIX／Linux環境の場合
    PDF形式ファイルを印刷するプリンタの解像度が600（dpi）の場合の，プリンタ定義ファイルの指定例を次に示します。
    [PDF]
  YDPI=600
(d)　CODE39バーコードのバーコード補正情報を設定する場合

CODE39バーコードの細エレメント，太エレメント，キャラクタ間ギャップの幅の比を1対2.5対1に変更し，黒バーの太さを0.04mm補正するプリンタ定義ファイルの指定例を次に示します。

  • Windows環境の場合
    [Printer1]
  CODE39PARAM=2,1:2.5:1,0.04
  • UNIX／Linux環境の場合
    [LIPSPR1]
  CODE39PARAM=2,1:2.5:1,0.04
(e)　QRコードのセルサイズをドット単位で設定する場合

QRコードのセルサイズを7ドットにするプリンタ定義ファイルの指定例を次に示します。

  • Windows環境の場合
    [Printer1]
  QRCellSizeD=7
  • UNIX／Linux環境の場合
    [LIPSPR1]
  QRCellSizeD=7
(f)　QRコードのセルサイズを100分の1ミリメートル単位で設定する場合

QRコードのセルサイズを0.7ミリメートルにするプリンタ定義ファイルの指定例を次に示します。

  • Windows環境の場合
    [Printer1]
  QRCellSizeM=70
  • UNIX／Linux環境の場合
    [LIPSPR1]
  QRCellSizeM=70
(g)　PostScript対応プリンタでJISX0213:2004の文字集合の文字を出力する場合

日立のJISX0213:2004フォントを搭載したPostScript対応プリンタで，JISX0213:2004の文字集合の文字を出力するプリンタ定義ファイルの指定例を次に示します。

  • UNIX／Linux環境の場合
    [PSPR2]
  PDLType=PS2
  XDPI=720
  YDPI=720

GenTextMode=RPS2004M-UTF16


複数様式情報定義ファイル

11.6　複数様式情報定義ファイル

＜この節の構成＞
(1)　概要
(2)　形式
(3)　キーワード

(1)　概要

帳票セット，または帳票セット指定ファイルを指定した帳票出力は，指定されている帳票ファイルが順に出力されますが，複数様式情報定義ファイルを指定することで，複数の帳票ファイルを組み合わせて一つの帳票のように入力できます。例えば，データ中のキーごとに複数の異なる様式をセットで出力したり，表紙のページと次のページの様式を変えたりして出力できます。これを「複数様式で帳票を出力する」といいます。

複数様式情報定義ファイルは，様式（帳票フォーマット）や読み込むデータを切り替える条件と，切り替え時の動作を定義しておくファイルです。

同じデータファイルから出力する様式のまとまりを様式グループといいます。様式グループの中にも様式グループを定義することができます。これをサブ様式グループといいます。サブ様式グループを定義すると，様式グループのデータを細かく切り分けて，それぞれ異なるフォーマットの帳票に出力できます。

サブ様式グループを定義した帳票の出力例を次に示します。

図11-3　 サブ様式グループを定義した帳票の出力例

この出力例では，日立家のデータをすべて出力してから，戸塚家のデータを出力します。一家族分のデータからは，まず家族全員の総計を出力してから，個人の明細を出力します。

(2)　形式

複数様式情報定義ファイルは，メモ帳など，テキストファイルが編集できるエディタを起動して編集します。任意の拡張子のファイルを使用できます。

複数様式情報定義ファイルに指定するキーワードとオプションは，大文字，小文字の区別をしません。

複数様式情報定義ファイルの形式を次に示します。

group 様式グループ番号 {
  〔grouptransfercondition {              …様式グループ遷移条件
      transfercondition={KBNF|EOFN}
      〔fieldname="フィールド名"〕
   }〕
  〔formtransfercondition {               …様式間遷移条件
      keybreaktopform={ON|OFF}
      〔fieldname="フィールド名"〕
   }〕
  〔formfilename "帳票ファイル名" {         …様式遷移情報
      transfercondition={NPNF|KBNF|EOFN}
      printnewpaper={ON|OFF}
      resetpagenumber={ON|OFF}
      〔traycode=給紙トレイ番号〕
   }〕
  〔subgroup サブ様式グループ番号 {          …サブ様式グループ
      grouptransfercondition {
        transfercondition=KBNF
        fieldname="フィールド名"
      }
     〔formtransfercondition {
        keybreaktopform={ON|OFF}
       〔fieldname="フィールド名"〕
      }〕
      formfilename "帳票ファイル名" {
        transfercondition={NPNF|KBNF}
        printnewpaper={ON|OFF}
        resetpagenumber={ON|OFF}
       〔traycode=給紙トレイ番号〕
      }
  }〕
}
               :

(3)　キーワード

複数様式情報定義ファイルで指定するキーワードは，次のとおりです。

表11-24　複数様式情報定義ファイルのキーワード

キーワード | 説明 | キーワードの省略可否
group | グルーピングした出力様式（様式グループ）を識別する番号を指定します。 | ×
grouptransfercondition | グループごとに様式を切り替える条件（様式グループ遷移条件）を指定します。 | ○
formtransfercondition | フィールドごとに様式を切り替える条件（様式間遷移条件）を指定します。 | ○
formfilename | 様式遷移情報を指定します。 ここでは，様式を切り替える条件，両面印刷時の白紙挿入の条件，ページ番号の指定方法などを設定します。 | ○
subgroup | サブ様式グループを識別する番号を指定します。 | ○
（凡例）
○：指定を省略できるキーワードです
×：必ず指定するキーワードです

注意
  • サブ様式グループは，先頭の様式グループには指定できません。先頭の様式グループに指定してもエラーにはなりませんが，帳票は正しく出力されません。
  • 様式グループ，またはサブ様式グループの先頭に定義した様式の帳票は，必ず出力されるように設定する必要があります。様式グループ，またはサブ様式グループの先頭に定義した様式の帳票が出力されない場合，帳票は正しく出力されません。
(a)　group

様式グループを識別する番号を指定します。

■groupの形式
group 様式グループ番号
様式グループ番号
様式グループ番号を1以上の整数で指定します。様式グループ番号は，様式グループ間で同じ番号がないように指定してください。同じ様式グループ番号がある場合，または様式グループ番号が昇順で指定されていない場合は，エラー（KEEU038-E）になります。

様式グループは，次に示すように，読み込むデータファイルごとに作成します。

図11-4　 複数様式情報定義ファイルとデータファイルの例（様式グループを読み込むデータファイルごとに作成する場合）

連票形式の帳票のように，一つのデータファイルを3様式で共有していても，様式ごとに1レコードのデータを読み込む場合は，様式グループは三つになります。

図11-5　 複数様式情報定義ファイルとデータファイルの例（様式ごとに1レコードのデータを読み込む場合）

(b)　grouptransfercondition

様式グループを切り替える条件を指定します。grouptransferconditionは，指定を省略できます。

■grouptransferconditionの形式
〔grouptransfercondition {
transfercondition={KBNF|EOFN}
〔fieldname="フィールド名"〕
}〕
■キーワードtransferconditionの形式
transfercondition={KBNF|EOFN}
KBNF | EOFN
様式グループを次の様式グループに切り替える条件を指定します。複数様式のPDF形式ファイルを仕分け出力する場合は，KBNFを指定してください。
サブ様式グループを切り替える場合は，KBNFを指定します。
  • KBNF
    キーブレイクのタイミングで次の様式グループに切り替えます。KBNFを指定した場合は，キーワードfieldnameで，キーブレイクするフィールド名を指定してください。
    KBNFを指定する場合は，様式グループのformfilenameに指定する帳票を設計するとき，フィールド名とフィールド属性が同じになるように指定しておいてください。
  • EOFN
    様式グループのformfilenameに指定されているすべての帳票ファイルを印刷したあと，次の様式グループに切り替えます。

    図11-6　 transferconditionの値による様式グループ切り分けタイミングの違い

■キーワードfieldnameの形式
fieldname="フィールド名"
フィールド名
キーブレイクの対象となるフィールド名を「"」で囲んで指定します。
キーワードtransferconditionにKBNFを指定した場合は，フィールド名を指定してください。
各様式グループに指定されたフィールドが同じ名称でない場合は，エラー（KEEU047-E）になります。また，同じフィールド属性でない場合は，エラー（KEEU049-E）になります。
様式グループとサブ様式グループに指定されたフィールド名が同じ名称の場合は，エラー（KEEU038-E）になります。
(c)　formtransfercondition

grouptransferconditionは，キーブレイクの対象となるフィールドのデータが変わった時点で次の様式グループに切り替えますが，formtransferconditionは，キーブレイクの対象となるフィールドのデータが変わった時点で先頭の様式に切り替えるかどうかを指定します。

例えば，請求書のように，次のような条件で帳票出力する場合，formtransferconditionを指定します。

  • 様式1は必ず出力します。
  • 様式1に納まらないデータがある場合，続きのデータを様式2に出力して，請求先のデータが変わった時点で，様式1に戻るようにします。
  • 様式1の出力で請求先のデータが変わった場合は，様式1に戻ります。

    図11-7　 formtransferconditionの指定例

このように，先頭の様式を出力したあと，次の様式に続きのデータを出力しなくて済む場合は，formtransferconditionを指定しておくと便利です。

formtransferconditionを指定した場合，同じ様式グループ内にsubgroupは指定できません。formtransferconditionとsubgroupを同時に指定した場合は，エラー（KEEU038-E）になります。

■formtransferconditionの形式
〔formtransfercondition {
keybreaktopform={ON|OFF}
〔fieldname="フィールド名"〕
}〕
■キーワードkeybreaktopformの形式
keybreaktopform={ON|OFF}
ON | OFF
先頭の様式に切り替えるかどうかを指定します。
  • ON
    キーブレイクのタイミングで先頭の様式に切り替えます。ONを指定した場合は，キーワードfieldnameで，キーブレイクするフィールド名を指定してください。
    先頭の様式を出力する場合，ページ番号の開始番号を初期化するときは，先頭の様式の遷移条件でキーワードformfilenameのresetpagenumberにONを指定しておいてください。
  • OFF
    先頭への様式には切り替えません。キーワードformfilenameのtransferconditionで指定されている各様式の遷移条件での動作になります。
■補足説明
キーワードtransferconditionでNPNFが設定されている場合，先頭の様式でページ番号の開始番号を初期化するときは，キーワードkeybreaktopformにONを指定しておいてください。OFFが指定されている場合は，ページ番号が初期化されません。

図11-8　 keybreaktopformの値による様式切り替えの違い

■キーワードfieldnameの形式
fieldname="フィールド名"
フィールド名
キーブレイク対象フィールド名を「"」で囲んで指定します。
キーワードkeybreaktopformにONを指定した場合は，フィールド名を指定してください。指定されていない場合は，エラー（KEEU038-E）になります。
(d)　formfilename

様式を次の様式に切り替える条件を指定します。

formfilenameを指定した場合，同じ様式グループ内にsubgroupは指定できません。formfilenameとsubgroupを両方指定した場合，またはどちらも指定しなかった場合は，エラー（KEEU038-E）になります。

formfilenameは，様式グループ内に指定する様式の数分を繰り返し指定します。

■formfilenameの形式
formfilename "帳票ファイル名" {
transfercondition={NPNF|KBNF|EOFN}
printnewpaper={ON|OFF}
resetpagenumber={ON|OFF}
[traycode=給紙トレイ番号]
}
帳票ファイル名
帳票ファイル名を「"」で囲んで指定します。パスの指定は要りません。
指定する帳票ファイル名は，様式グループ間で同じ名称がないように指定してください。同じ名称の帳票ファイルがある場合，または帳票ファイル名をパス指定された場合は，エラー（KEEU038-E）になります。
複数様式で出力する場合は，一組にする帳票すべてに同じキーフィールドで改ページするように設計しておいてください。
帳票ヘッダのある帳票は，複数様式では出力できません。
■キーワードtransferconditionの形式
transfercondition={NPNF|KBNF|EOFN}
NPNF | KBNF | EOFN
様式を切り替える条件を指定します。
サブ様式グループの様式を切り替える場合は，NPNFとKBNFが指定できます。
  • NPNF（ページエンド改ページ）
    キーブレイク以外の改ページのタイミングで，次の様式に切り替えます。
  • KBNF（キーブレイク改ページ）
    キーブレイクのタイミングで，次の様式に切り替えます。
    KBNFを指定した場合，grouptransferconditionもしくはformtransferconditionのキーワードfieldnameに指定されているキーブレイク対象フィールド，または帳票に設定されている改ページのキーフィールドによって様式を切り替えます。
    KBNFを指定する場合は，帳票ファイル名に指定する帳票を設計するとき，フィールド名とフィールド属性が同じになるように指定しておいてください。
  • EOFN（ファイル終端）
    すべての様式のデータを印刷したあと，次の様式に切り替えます。
■キーワードprintnewpaperの形式
printnewpaper={ON|OFF}
ON | OFF
プリンタの印刷設定で「両面」が設定されている場合，キーワードprintnewpaperを指定した様式が常に用紙の表面になるように空白ページを挿入するかどうかを指定します。
  • ON
    様式が常に用紙の表面になるように，空白ページを挿入します。

    図11-9　 printnewpaperがONの場合の例

  • OFF
    印刷している様式に偶数ページがない場合，次の様式を続けて印刷します。

    図11-10　 printnewpaperがOFFの場合の例

■キーワードresetpagenumberの形式
resetpagenumber={ON|OFF}
ON | OFF
キーとなるフィールドのデータが変わった時点で，ページ番号の開始番号を初期化するかどうかを指定します。
  • ON
    キーとなるフィールドのデータが変わった時点で，ページ番号を初期化します。

    図11-11　 resetpagenumberがONの場合の例

  • OFF
    ページ番号は初期化しません。通し番号になります。

    図11-12　 resetpagenumberがOFFの場合の例

■補足説明
複数様式の帳票の場合，帳票設計時の改ページの設定ではページ番号を初期化するかどうかは有効になりません。キーワードresetpagenumberの設定だけが有効になります。
■キーワードtraycodeの形式
給紙トレイ番号を指定します。/tcオプションを同時に指定した場合，traycodeの指定が優先されます。
traycode=給紙トレイ番号
給紙トレイ番号
この様式を印刷する場合の給紙トレイ番号を指定します。
  • Windows環境の場合
    給紙トレイ番号は，トレイコード表示ツールで表示されるトレイコードを指定してください。省略した場合は，デフォルトの給紙トレイから給紙されます。
  • UNIX／Linux環境の場合
    給紙トレイの給紙トレイ番号を指定してください。給紙トレイ番号は，1～n（nは，プリンタに設定されている給紙トレイ番号）で指定します。6以上の値を指定した場合は，自動給紙となります。省略した場合は，プリンタ定義ファイルのDefaultCassetteキーで指定された方法で給紙します。
    プリンタ定義ファイルの詳細については，「11.5　プリンタ定義ファイル」を参照してください。
(e)　subgroup

サブ様式グループを識別する番号を指定します。

subgroupとformfilenameは，どちらかを指定してください。subgroupとformfilenameを両方指定した場合，またはどちらも指定しなかった場合は，エラー（KEEU038-E）になります。

subgroupを指定すると，formtransferconditionは指定できません。subgroupとformtransferconditionを同時に指定した場合は，エラー（KEEU038-E）になります。

group文とsubgroup文の様式グループ遷移条件（grouptransfercondition）のフィールド名（fieldname）には異なる文字列を指定してください。同じ文字列を指定すると，エラー（KEEU038-E）になります。

■subgroupの形式
subgroup サブ様式グループ番号
サブ様式グループ番号
サブ様式グループ番号を1以上の整数で指定します。サブ様式グループは，様式グループの中にだけ指定できます。様式グループの中以外に指定した場合は，エラー（KEEU038-E）になります。
また，サブ様式グループ番号は，サブ様式グループ間で同じ番号がないように指定してください。同じサブ様式グループ番号がある場合，またはサブ様式グループ番号が昇順で指定されていない場合は，エラー（KEEU038-E）になります。
サブ様式グループを定義した場合，どのように帳票が出力されるかを次に示します。

図11-13　サブ様式グループを定義した場合の帳票の出力例

注意
サブ様式グループを定義したファイルは，次に示すバージョンの製品で読み込んでください。
製品 | バージョン
EUR Server Standard | 09-00以降
EUR Server Enterprise | 09-00以降
EUR Server Print Edition | 09-00以降
EUR Designer | 08-00以降
EUR Developer | 08-00以降
EUR Print Service Enterprise | 08-00以降
EUR Professional Edition | 05-06以降
EUR Print Service | 05-06以降
バージョン05-05以前のEURまたはEUR Print Serviceで読み込んだ場合はエラー（KEEU038-E）になります。


接続情報ファイル

11.7　接続情報ファイル

接続情報ファイルは，データベースと接続するために必要な情報を定義するファイルです。入力データをデータベースから読み込んで帳票を出力する場合に，接続するデータベースの情報を接続情報ファイルに定義します。

接続情報ファイルは，一つの接続先について一つ作成します。EUR サーバ帳票出力機能の実行時には，接続情報ファイルを一つだけ指定できます。詳細については，マニュアル「EUR データベース連携ガイド」を参照してください。


置き換え表管理情報ファイル

11.8　置き換え表管理情報ファイル

＜この節の構成＞
(1)　概要
(2)　形式
(3)　キーワード

(1)　概要

EURでは，アイテムのデータを指定したデータに置き換えて，出力できます。

置き換え表管理情報ファイルは，帳票を設計した時に設定された置き換え表名と，置き換え表ファイルの対応を定義したファイルです。

(2)　形式

置き換え表管理情報ファイルは，CSV形式で作成します。形式を次に示します。

置き換え表名,置き換え表ファイル名▼
置き換え表名,置き換え表ファイル名▼
            ：
（凡例）
▼：改行コードを示します。

(3)　キーワード

■置き換え表名
置き換え表ファイルを区別するために付けた名称を指定します。指定できる置き換え表名の数は，50個までです。同一の置き換え表名が指定された場合，最初に記述した置き換え表名が有効となり，2番目以降の記述は無視されます。
置き換え表名に，空白，コンマ（,）を使用している場合は，その文字を引用符（"）で囲んで指定してください。引用符（"）を使用している場合は，引用符（"）を続けて二つ指定してください。
■置き換え表ファイル名
置き換え表名に対応する置き換え表ファイル名を指定します。フルパス，相対パスは指定できません。ファイル名の文字列長は，Windows環境の場合は256文字までです。UNIX／Linux環境の場合は1,023バイトまでです。


置き換え表ファイル

11.9　置き換え表ファイル

＜この節の構成＞
(1)　概要
(2)　形式
(3)　キーワード
(4)　注意事項

(1)　概要

EURでは，アイテムのデータを指定したデータに置き換えて，出力できます。

置き換え表ファイルは，アイテムのデータを置き換えて出力する場合に，1フィールドごとの置き換え対象のデータと，置き換えて出力するデータを定義したファイルです。CSV形式で作成します。

(2)　形式

置き換え表ファイルは，CSV形式で作成します。形式を次に示します。

キーデータ,置き換えデータ▼
キーデータ,置き換えデータ▼
            ：
（凡例）
▼：改行コードを示します。

(3)　キーワード

■キーデータ
置き換えの対象とする文字列を指定します。指定できる文字列長は，256文字までです。同一のキーデータが指定された場合，最初に記述したキーデータが有効となり，2番目以降の記述は無視されます。
文字列に，空白，コンマ（,）を使用している場合は，その文字を引用符（"）で囲んで指定してください。引用符（"）を使用している場合は，引用符（"）を続けて二つ指定してください。
■置き換えデータ
置き換えて出力する文字列を指定します。指定できる文字列長は，256文字までです。
文字列に，空白，コンマ（,）を使用している場合は，その文字を引用符（"）で囲んで指定してください。引用符（"）を使用している場合は，引用符（"）を続けて二つ指定してください。

空データの置き換えもできます。空データは次のように指定します。

  • 空データを文字列に置き換える場合
    ,"置き換え空データ1"　　または
    "","置き換え空データ2"
  • 文字列を空データに置き換える場合
    "置き換えキーデータ1",　　または
    "置き換えキーデータ2",""

(4)　注意事項

  • 置き換え表ファイルには，キーデータおよび置き換えデータを一つ以上指定してください。データを指定しない場合は，エラー（KEEU300-W）になります。
  • キーデータと置き換えデータは，置き換え対象の1フィールドのデータ中にある文字列ごとに指定してください。置き換え対象に，キーデータに指定されていないデータがある場合は，エラー（KEEU300-W）になります。


Acrobat JavaScript定義ファイル

11.10　Acrobat JavaScript定義ファイル

＜この節の構成＞
(1)　概要
(2)　形式
(3)　キーワード
(4)　注意事項

(1)　概要

PDF形式ファイルに埋め込むAcrobat JavaScriptファイル名を指定します。

Acrobat JavaScriptファイルを埋め込むと，Adobe Readerの「ページを開く」などのメニューを操作した時に，エラーを出したり，メールを送信したりするなど，Acrobat JavaScriptで指定した機能を実行できます。

Acrobat JavaScript定義ファイルの文字コードを次に示します。

表11-25　 Acrobat JavaScript定義ファイルの文字コード

Windows環境の場合 | UNIX／Linux環境の場合
UTF-8 UTF-16 ロケールの文字コード | UTF-16 ロケールの文字コード

(2)　形式

Acrobat JavaScript定義ファイルは，CSV形式で作成します。形式を次に示します。

イベント名，Acrobat JavaScriptファイル名▼
イベント名，Acrobat JavaScriptファイル名▼
            ：
（凡例）
▼：改行コードを示します。

(3)　キーワード

■イベント名
Acrobat JavaScriptファイル名に対応するイベント名を指定します。指定したイベントを実行した場合，対応するJavaScriptを実行します。指定できるイベント名と対応する操作を次に示します。

表11-26　イベント名と対応する操作

項番 | イベント名 | 操作
1 | O | 「ページを開く」操作をした場合
2 | C | 「ページを閉じる」操作をした場合
3 | WC | 「文書を閉じる」操作をした場合
4 | WS | 「文書を保存する」操作をした場合
5 | DS | 「文書を保存した」操作をした場合
6 | WP | 「文書を印刷する」操作をした場合
7 | DP | 「文書を印刷した」操作をした場合
■Acrobat JavaScriptファイル名
PDF形式ファイルに埋め込むAcrobat JavaScriptファイル名を指定します。同じ名称のAcrobat JavaScriptファイルを複数指定できます。指定できるファイル名は，Windows環境の場合，フルパスで256文字，相対パスまたはファイル名は255文字までです。UNIX／Linux環境の場合，フルパスで1,023バイトまでです。

(4)　注意事項

  • データに，空白およびコンマ「,」が含まれる場合は，「"」で囲んでください。
  • イベント名が重複している場合，および指定したAcrobat JavaScriptファイルの指定がない場合は，エラーとなります。
  • Acrobat JavaScript定義ファイルの1行に三つ以上のデータを指定していた場合，最初の二つがデータとして入力されます。
  • イベント名を「"」で囲んだ場合は，エラーとなります。
  • イベント名WS，およびDSは，Adobe Acrobatで「保存」を実行した場合にAcrobat JavaScriptが実行されます。Adobe Readerで「コピーを保存」を実行しても実行されません。


Acrobat JavaScriptファイル

11.11　Acrobat JavaScriptファイル

＜この節の構成＞
(1)　概要
(2)　形式

(1)　概要

Acrobat JavaScriptファイルは，PDF形式ファイルに埋め込むJavaScriptプログラムを指定したファイルです。Acrobat JavaScriptファイルを使用すると，Adobe Readerの「ページを開く」などのメニューを操作した時に，エラーを出力したり，メールを送信したりするなどの機能が設定できます。

Acrobat JavaScriptファイルをPDF形式ファイルに埋め込むには，Acrobat JavaScript定義ファイルが必要です。

Acrobat JavaScriptファイルは，メモ帳など，テキストファイルが編集できるエディタを起動して編集します。任意の拡張子のファイルを使用できます。

Acrobat JavaScriptファイルの文字コードを次に示します。

表11-27　 Acrobat JavaScriptファイルの文字コード

Windows環境の場合 | UNIX／Linux環境の場合
UTF-8 UTF-16 ロケールの文字コード | UTF-16 ロケールの文字コード

(2)　形式

Acrobat JavaScriptファイルの記述形式については，Adobeのマニュアルを参照してください。


ビューアプレファレンス定義ファイル

11.12　ビューアプレファレンス定義ファイル

＜この節の構成＞
(1)　概要
(2)　形式
(3)　キーワード
(4)　注意事項

(1)　概要

ビューアプレファレンス定義ファイルは，出力したPDF形式ファイルを開いた時に実行するビューアプレファレンスを指定するファイルです。

ビューアプレファレンスを使用すると，Adobe ReaderでPDF形式ファイルを開いた時，「ツールバー」や「メニューバー」などのAdobe ReaderのGUIを制御できます。

ビューアプレファレンス定義ファイルの文字コードを次に示します。

表11-28　 ビューアプレファレンス定義ファイルの文字コード

Windows環境の場合 | UNIX／Linux環境の場合
UTF-8 UTF-16 ロケールの文字コード | UTF-16 ロケールの文字コード

(2)　形式

ビューアプレファレンス定義ファイルは，CSV形式で作成します。形式を次に示します。

キー名，設定値▼
キー名，設定値▼
      ：
（凡例）
▼：改行コードを示します。
■キー名・設定値

ビューアプレファレンスのキーと設定値を指定します。

(3)　キーワード

キー名と設定値を次に示します。

表11-29　ビューアプレファレンスのキーと設定値

キー名 | 設定値 | 内容
HIDETOOLBAR | YES | ツールバーを非表示に設定します。
 | NO | ツールバーを表示します。
HIDEMENUBAR | YES | メニューバーを非表示に設定します。
 | NO | メニューバーを表示します。
HIDEWINDOWUI | YES | ウィンドウコントロールを非表示に設定します。
 | NO | ウィンドウコントロールを表示します。
FITWINDOW | YES | ページにウィンドウサイズを合わせます。
 | NO | ページにウィンドウサイズを合わせません。
CENTERWINDOW | YES | ウィンドウを画面中央に配置します。
 | NO | ウィンドウを画面中央に配置しません。
PAGEMODE | OUTLINE | ウィンドウコントロールにしおりを表示します。
 | THUMB | ウィンドウコントロールにサムネイルを表示します。
 | PAGE | ページだけ表示します。
 | FULLSCREEN | 全画面表示にします。
PRINTSCALING | NONE | ページの拡大/縮小を「なし」に設定します。
 | DEFAULT | Adobe Readerの設定に従います。
PICKTRAYBYPDFSIZE | YES | 「PDFのページサイズに合わせて用紙を選択」チェックボックスを「オン」に設定します。
 | NO | Adobe Readerの設定に従います。

(4)　注意事項

  • キーを指定しなかった場合は，Adobe Readerの設定に従います。
  • 設定値以外を指定した場合は，エラーとなります。
  • 同じキーを複数指定した場合はエラーとなります。
  • ビューアプレファレンス定義ファイルの1行に三つ以上のキーや設定値を指定した場合，最初の二つが入力されます。キーと設定値は，1行に一つずつ指定してください。
  • キー名および設定値を「"」で囲んだ場合は，エラーとなります。


テスト印刷設定ファイル

11.13　テスト印刷設定ファイル

＜この節の構成＞
(1)　概要
(2)　形式
(3)　キーワード
(4)　注意事項

(1)　概要

テスト印刷設定ファイルは，テスト印刷で出力した帳票の不正使用を防ぐ目的で，テスト印刷用の文字列を重ねて出力するための情報を指定したファイルです。

テスト印刷用の文字列を重ねて出力した帳票のイメージを次に示します。

テスト印刷設定ファイルでは，テスト印刷用の文字列についての次の内容を設定できます。

  • 文字列の内容
  • 文字のフォント名
  • 文字の大きさ
  • 文字列の出力位置
  • 文字の色
  • 日付／時刻の書式
テスト印刷用の文字とほかのアイテムの重なりについて
帳票上にテスト印刷用の文字列を出力した場合，線アイテムと文字アイテムはテスト印刷用の文字列よりも上に出力されるため，テスト印刷用の文字列に隠れることはありません。図形と画像はテスト印刷用の文字列に隠れます。これは，異なる種別のアイテムの重なりの順序に決まりがあり，テスト印刷用の文字列は図形アイテムと線アイテムの中間に出力されるためです。アイテムの重なりの詳細については，マニュアル「EUR 帳票作成 操作ガイド」を参照してください。

テスト印刷設定ファイルの文字コードを次に示します。

表11-30　テスト印刷設定ファイルの文字コード

Windows環境の場合 | UNIX／Linux環境の場合
ロケールのエンコード UTF-8 UTF-16 | ロケールのエンコード UTF-16

(2)　形式

テスト印刷設定ファイルは，メモ帳など，テキストファイルが編集できるエディタを起動して編集します。任意の拡張子のファイルを使用できます。形式を次に示します。

[TESTPRINT]
SECTIONS=セクション名1,セクション名2, …
[セクション名1]
キー=値
  ：
[セクション名2]
キー=値
  ：

テスト印刷設定ファイルに指定できる属性は次のとおりです。

表11-31　テスト印刷設定ファイルに指定する属性

属性 | セクション名 | 説明 | 省略
TESTPRINT | TESTPRINT | TEST属性のセクション名を指定します。 | ◎※1
TEST | SECTIONSキーで指定したセクション名 | テスト印刷の内容を設定します。 SECTIONSキーで指定したセクション名を指定します。 | ◎※2
（凡例）
◎：必ず指定するキーワードです。

注※1　TESTPRINTセクションを省略した場合，エラー（KEEU087-E）となります。

注※2　SECTIONSキーで指定したセクション名をTEST属性のセクションに記載しなかった場合，エラー（KEEU089-E）となります。

また，属性に設定する内容については，次の注意事項があります。

  • セクション名の大文字・小文字は区別されません。
  • TESTPRINT属性で指定していないセクション名を指定した場合，そのセクションの設定内容は無視されます。
  • 同じセクションを複数記載した場合，先に記載した内容が有効となります。

テスト印刷設定ファイルで指定するキーワードの内容を次に示します。

表11-32　テスト印刷設定ファイルで指定するキーワード

属性 | キー | 内容 | 省略
TESTPRINT | SECTIONS | TEST属性のセクション名を指定します。 | ◎
TEST | TEXT | テスト印刷用に出力する文字列を指定します。 | ◎
 | FONT | 文字のフォント名を指定します。 | ○
 | SIZE | 文字の大きさを指定します。（単位：ポイント） | ○
 | POS | テスト印刷用の文字列を出力する時の出力位置を指定します。 | ○
 | COLOR | 文字の色を指定します。 | ○
 | DATETIMEFORMAT | TEXTキーで「%d（日付）」が指定された時，「%d」の書式を指定します。 | ○
（凡例）
◎：必ず指定するキーワードです。
○：指定を省略できるキーワードです。

必ず指定するキーワードを指定しなかった場合は，エラー（KEEU088-E）となります。

(3)　キーワード

(a)　SECTIONS

TEST属性のセクション名を指定します。

■キーワードSECTIONSの形式
SECTIONS=セクション名
セクション名
セクション名を32文字以下の文字で指定します。
「セクション名1,セクション名2,…」のようにコンマで区切って複数のセクション名を指定できます。
32文字を超えた場合，SECTIONSキーの値に何も指定しなかった場合，またはコンマの両隣にセクション名を指定しなかった場合は，エラー（KEEU086-E）になります。
(b)　TEXT

テスト印刷用の文字として帳票上に表示される文字列を指定します。

■キーワードTEXTの形式
TEXT=文字列
文字列
テスト印刷用の文字列を指定します。259文字までの文字列が有効となります。260文字以上の文字を指定してもエラーにはなりませんが，260文字目以降の文字列は無視されます。
指定した文字はそのまま出力されます。
ただし，「%d」「%m」「%文字」は次のように変換して出力されます。
  • %d
    テスト印刷実行時の日付/時刻に変換されます。DATETIMEFORMATキーで指定した書式で変換されます。
  • %m
    テスト印刷実行時のマシン名に変換されます。
  • %文字（「d」および「m」以外）
    文字が出力されます。
帳票には，変換後の文字列で512文字まで出力されます。512文字を超えた場合，513文字目以降の文字列は出力されません。
TEXTキーの値に何も指定しなかった場合，エラー（KEEU086-E）となります。
(c)　FONT

テスト印刷用の文字列のフォントを指定します。

■キーワードFONTの形式
FONT=フォント名
フォント名
フォント名を指定します。31文字までの文字列が有効となります。32文字以上の文字を指定してもエラーにはなりませんが，32文字目以降の文字列は無視されます。
指定できるフォント名は，文字アイテムのフォントで指定できるものと同じです。
また，出力形式によっては指定したフォントが対応していない場合があります。この場合は，別のフォントに置き換えて出力されます。
FONTキーの記載がない場合，またはFONTキーに何も指定しなかった場合は，「ＭＳ ゴシック」が仮定されます。
(d)　SIZE

テスト印刷用の文字の大きさを指定します。

■キーワードSIZEの形式
SIZE=フォントサイズ
フォントサイズ
文字の大きさを指定します。単位は，ポイントです。
3～256の整数値を指定できます。小数値や範囲外の値を指定した場合は，エラー（KEEU086-E）になります。
SIZEキーの記載がない場合，またはSIZEキーに何も指定しなかった場合，12ポイントが仮定されます。
(e)　POS

テスト印刷用の文字列を出力する場合の出力位置を指定します。

■キーワードPOSの形式
POS=〔topl | topc | topr | botl | botc | botr | cenl | cenc | cenr | X,Y〕
topl
テスト印刷用の文字列を貼付域の左上に出力します。
topc
テスト印刷用の文字列を貼付域の中央上に出力します。
topr
テスト印刷用の文字列を貼付域の右上に出力します。
botl
テスト印刷用の文字列を貼付域の左下に出力します。
botc
テスト印刷用の文字列を貼付域の中央下に出力します。
botr
テスト印刷用文字列を貼付域の右下に出力します。
cenl
テスト印刷用文字列を貼付域の中央左に出力します。
cenc
テスト印刷用文字列を貼付域の中央に出力します。
cenr
テスト印刷用文字列を貼付域の中央右に出力します。
X,Y
テスト印刷用の文字列を，貼付域の左上を原点としたX座標値，Y座標値で指定した位置に出力します。
0～999の整数値を指定できます。単位は，ミリメートルです。
0～999以外の値を指定した場合，エラー（KEEU086-E）となります。

「topl」「topc」「topr」「botl」「botc」「botr」「cenl」「cenc」「cenr」「X,Y」以外の値を指定した場合は，エラー（KEEU086-E）になります。

(f)　COLOR

テスト印刷用の文字列の色を指定します。

■キーワードCOLORの形式
COLOR=色
色
文字色を16進数の6桁の数値で指定します。
1～2桁は赤色の明度，3～4桁は緑色の明度，5～6桁は青色の明度を表します。
（例）
  000000：黒色
  FF0000：赤色
16進数の6桁以外を指定した場合，エラー（KEEU086-E）となります。
COLORキーの記載がない場合，またはCOLORキーに何も指定しなかった場合，「薄いグレー(A3A3A3)」が仮定されます。
なお，出力形式によっては指定した色とは別の色で出力されることがあります。
(g)　DATETIMEFORMAT

TEXTキーで「%d」（日付）が指定された場合に，「%d」に適用する書式を指定します。

■キーワードDATETIMEFORMATの形式
DATETIMEFORMAT=日付の書式
日付の書式
日付の書式を，レポートファイル形式の表示形式で指定します。259文字までの文字列が有効となります。260文字以上の文字を指定してもエラーにはなりませんが，260文字目以降の文字列は無視されます。
DATETIMEFORMATキーの記載がない場合，またはDATETIMEFORMATキーに何も指定しなかった場合，「%Y/%M/%D△%h:%m:%s」が仮定されます（「△」は，半角空白を意味します）。
レポートファイル形式の詳細については，マニュアル「EUR 帳票作成 操作ガイド」を参照してください。

(4)　注意事項

  • テスト印刷用の文字列が貼付域をはみ出る場合の注意
    テスト印刷用の文字列が貼付域をはみ出る場合，はみ出た分の文字列は切れてしまい，出力されません。ただし，文字列の先頭が貼付け領域の左端を超えることはないため，「topr」「botr」「cenr」を指定していても，必ず文字列の後ろ（右端）が切れます。この場合，エラーメッセージやワーニングメッセージは出力されません。
    例えば，キーワード「POS」に「topr」を指定した帳票で，テスト印刷用の文字列が貼付域をはみ出た場合は次のように印刷されます。

  • テスト印刷用の文字列の文字幅
    テスト印刷用の文字列は縦横比が2：1の固定ピッチで出力されます。静的モードで縦横比が2：1のフォントは固定アイテムと同じように出力されますが，縦横比が2：1のフォント以外は文字と文字の間が広くなったり，文字同士が重なったりすることがあります。


印刷日時出力定義ファイル

11.14　印刷日時出力定義ファイル

＜この節の構成＞
(1)　概要
(2)　形式
(3)　キーワード
(4)　注意事項
(5)　指定例

(1)　概要

印刷日時出力定義ファイルは，プリンタでの印刷実行時の日時情報を帳票に出力するために必要な情報を定義するファイルです。

印刷日時出力定義ファイルでは，日時情報として出力する文字列について，次の内容を設定できます。

  • 文字列の内容
  • 文字のフォント名
  • 文字の大きさ
  • 文字列の出力位置
  • 文字の色

(2)　形式

印刷日時出力定義ファイルの形式を次に示します。

[PRINTDATETIME]
キー=値
  ：

(3)　キーワード

印刷日時出力定義ファイルの設定項目を次の表に示します。

表11-33　印刷日時出力定義ファイルの設定項目

セクション | キー | 指定できる値 | 省略値 | 説明
PRINTDATETIME TEXT 文字列 － 日時情報として出力する文字列を259文字以内で指定します。指定を省略した場合は，エラーとなります。
なお，TEXTキーには，印刷時の日時に合わせて変換できる書式指定コードを指定できます。詳細は，表11-34を参照してください。
FONT | 文字列 | ＭＳ ゴシック | 文字のフォント名を31文字以内で指定します。
SIZE 3～256 12 文字の大きさを指定します。
（単位：ポイント）
POS
  • topl
  • topc
  • topr
  • botl
  • botc
  • botr
 topl 文字列の出力位置を指定します。指定できる値とその意味は次のとおりです。
  • topl
    印刷領域※の左上に出力します。
  • topc
    印刷領域※の中央上に出力します。
  • topr
    印刷領域※の右上に出力します。
  • botl
    印刷領域※の左下に出力します。
  • botc
    印刷領域※の中央下に出力します。
  • botr
    印刷領域※の右下に出力します。
COLOR 000000～FFFFFF 000000 文字の色を6桁の16進数で指定します。
1～2桁は赤色の明度，3～4桁は緑色の明度，5～6桁は青色の明度を表します。例えば，「000000」は黒色，「FF0000」は赤色を表します。
（凡例）
－：省略値はありません。
注※
印刷領域とは，印刷用紙からプリンタのハードマージンを除いた領域のことです。印刷領域と文字列の出力位置との関係を，次の図に示します。

また，TEXTキーに指定できる書式指定コードを次の表に示します。

表11-34　TEXTキーに指定できる書式指定コード

項番 | 書式指定コード | 説明 | 変換後の値の例 | 備考
1 %a 曜日（省略形）
日本語環境
日
英語環境
Sun
 －
2 %A 曜日
日本語環境
日曜日
英語環境
Sunday
 －
3 %b 月（省略形）
日本語環境
1
英語環境
Jan
 －
4 %B 月
日本語環境
1月
英語環境
January
 －
5 %c 日付と時刻
日本語環境
2010/08/24 10:48:30
英語環境
08/24/10 10:48:30
 「%x %X」を指定した場合と同じです。
6 %#c 日付※1と時刻
日本語環境
2010年8月24日 10:48:30
英語環境
Tuesday, August 24, 2010 10:48:30
 「%#x %X」を指定した場合と同じです。
7 %d 日 01 －
8 %#d 日※2 1 －
9 %H 時間（24時間表記） 01 －
10 %#H 時間（24時間表記）※2 1 －
11 %I 時間（12時間表記） 01 －
12 %#I 時間（12時間表記）※2 1 －
13 %m 月（10進数） 01 －
14 %#m 月（10進数）※2 1 －
15 %M 分（10進数） 01 －
16 %#M 分（10進数）※2 1 －
17 %p 午前または午後
日本語環境
午前
英語環境
AM
 －
18 %S 秒（10進数） 01 －
19 %#S 秒（10進数）※2 1 －
20 %x 日付
日本語環境
2010/08/24
英語環境
08/24/10
日本語環境
「%y/%m/%d」を指定した場合と同じです。
英語環境
「%m/%d/%y」を指定した場合と同じです。
21 %#x 日付※1
日本語環境
2010年8月24日
英語環境
Tuesday, August 24, 2010
日本語環境
「%Y年%B%#d日」を指定した場合と同じです。
英語環境
「%A, %B %d, %Y」を指定した場合と同じです。
22 | %X | 時刻 | 10:48:30 | 「%H:%M:%S」を指定した場合と同じです。
23 %y 西暦（下2桁） 05 －
24 %#y 西暦（下2桁）※2 5 －
25 %Y 西暦（4桁） 0794 －
26 %#Y 西暦（4桁）※2 794 －
27 %% パーセント記号 % －
注※1
英語環境の場合は，曜日の情報を含みます。
注※2
値が1桁になる場合，頭に「0」を付けません。

(4)　注意事項

  • 設定項目の大文字・小文字は区別しません。
  • 表11-34に記載されていないセクションやキーを指定した場合は，設定内容は無視されます。
  • PRINTDATETIMEセクションを複数指定した場合や，同じキーを複数指定した場合は，先に指定した内容が有効となります。
  • 「#」以降の改行またはEOFまでの内容はコメントとして扱われます。「#」を含む値を指定する場合は，値の前後を「"」で囲んで指定してください。

(5)　指定例

印刷日時出力定義ファイルの指定例を次に示します。

[PRINTDATETIME]
TEXT=%c
FONT=ＭＳ ゴシック
SIZE=12
POS=topr
COLOR=000000


EURフォントファイル

11.15　EURフォントファイル

＜この節の構成＞
(1)　概要
(2)　形式
(3)　オプション
(4)　指定例

(1)　概要

EURフォントファイル（*.edf）は，Windows環境で作成した外字をUNIX／Linux環境で出力できるように変換したものです。EURフォントファイルの作成時には，指定した文字が画像として収録されます。

EURフォントファイルの作成には，EURフォントファイル作成ツール（expedf32コマンド）を使用します。

EURフォントファイル作成ツールを同梱している製品
EUR Designer，EUR Developer，およびWindows版のEUR Server製品（EUR Server Print Edition，EUR Server Standard，EUR Server Enterprise）に同梱されています。
ツールのインストール先
インストール先フォルダ\Tool\Program\下にインストールされます。

外字ファイルに登録された外字をEURフォントファイルに収録して，UNIX／Linux環境で出力する場合のイメージを次の図に示します。なお，図中では例としてEUR DesignerのEURフォントファイル作成ツールを使用しています。

図11-14　EURフォントファイルを使用した外字の出力

(2)　形式

EURフォントファイル作成ツールは，コマンドラインで起動して使用します。

expedf32.exe
       /eudc 外字ファイル名 │ /base ベースフォント名
       /size ピクセルサイズ
       /out EURフォントファイル名

(3)　オプション

EURフォントファイル作成ツールで指定するオプションを説明します。オプションの文字列は，大文字，小文字を区別しません。

(a)　/eudcオプション

外字ファイル（*.tte）を指定します。

/eudcオプションを指定した場合は，フォントであらかじめ定義されている符号位置にも，外字ファイルで定義した文字が収録されます。

(b)　/baseオプション

外字ファイル（*.tte）を指定する代わりに，Windowsの外字エディタでの外字登録時に「指定したフォントにリンクする」として選択したフォント名（「ＭＳ 明朝」や「ＭＳ ゴシック」など）を指定します。指定したフォントにリンクする外字がEURフォントファイルに収録されます。

不正なフォント名称を指定した場合，Windowsによってデフォルトフォントが仮定されます。このとき，エラー（KEEU F0601-W）を出力して仮定したフォント名が通知されます。

なお，指定するフォントによっては，登録した外字が収録されない場合があります。

(c)　/sizeオプション

8から96までの8の整数倍の値を指定します。

指定したサイズが大きいほど，鮮明な文字を出力できますが，ファイルの容量が大きくなり，処理も遅くなるのでご注意ください。

(d)　/outオプション

作成するEURフォントファイル名を指定します。フォントの出力時に区別しやすいように，明朝体として作成したファイルか，ゴシック体として作成したファイルかがわかるようなファイル名にしておくと便利です。

(4)　指定例

指定内容および指定例を次に示します。

(a)　Windowsの外字ファイルから，明朝体として使用するEURフォントファイルを作成する場合
指定内容
外字ファイル名 ：C:\WINDOWS\Fonts\EUDC.TTE
サイズ ：24ピクセル
EURフォントファイル名 ：msmin24.edf
指定例

インストール先フォルダ\Tool\Program\expedf32.exe
                       /eudc C:\WINDOWS\Fonts\EUDC.TTE
                       /size 24
                       /out C:\TEMP\msmin24.edf
(b)　ＭＳ 明朝にリンクされた外字から，明朝体として使用するEURフォントファイルを作成する場合
指定内容
ベースフォントファイル ：ＭＳ 明朝
サイズ ：24ピクセル
EURフォントファイル名 ：msmin24.edf
指定例

インストール先フォルダ\Tool\Program\expedf32.exe
                       /base "ＭＳ 明朝"
                       /size 24
                       /out C:\TEMP\msmin24.edf


アプリケーションサーバに準備するファイル

12.　アプリケーションサーバに準備するファイル

この章では，EUR サーバ帳票出力機能で扱えるファイルのうち，アプリケーションサーバに準備するファイルの種類と形式について説明します。

＜この章の構成＞
12.1　アプリケーションサーバに準備するファイルの一覧
12.2　データファイル
12.3　可変記号値定義ファイル
12.4　帳票セット指定ファイル
12.5　文書しおり定義ファイル
12.6　しおり定義ファイル
12.7　暗号化設定ファイル
12.8　PDF仕分け定義ファイル
12.9　制御情報付データファイル
12.10　起動パラメタファイル
12.11　EUR Web Plug-In情報ファイル


アプリケーションサーバに準備するファイルの一覧

12.1　アプリケーションサーバに準備するファイルの一覧

アプリケーションサーバに準備するファイルの概要を次の表に示します。

表12-1　アプリケーションサーバに準備するファイルの一覧

ファイル名 | 説明
データファイル | 帳票に出力するデータです。
可変記号値定義ファイル | 条件に合ったデータを抽出するときに必要な，検索条件の可変記号とその値を定義するためのファイルです。
帳票セット指定ファイル | 複数の帳票ファイルを統合する順番と帳票に読み込むデータファイルを指定しておくファイルです。
文書しおり定義ファイル | しおりとして表示する文字列と，しおりをクリックしたときのページの表示方法を設定したファイルです。
しおり定義ファイル 次に示すしおりの文字列とPDF形式ファイルのページの表示方法を設定したファイルです。
  • 「PDF形式ファイルを構成するサブ文書（帳票）を示すしおり」
  • 「（帳票に出力する）データのまとまりを表す項目のしおり」
暗号化設定ファイル | PDF形式ファイルを暗号化するためのセキュリティ属性を設定するファイルです。
PDF仕分け定義ファイル | PDF形式ファイルを仕分け出力するための情報を定義したファイルです。
制御情報付データファイル BSP-RM連携機能および上位主導型で帳票自動出力機能を使用するときに準備するファイルです。
マッピングデータに帳票の出力に関する制御情報を付加したデータファイルです。
起動パラメタファイル | BSP-RM連携コマンド（eursmprコマンド）およびファイル監視サービス（事前定義型の場合）から呼び出すことができるeurpmcコマンドのオプションを定義するファイルです。
EUR Web Plug-In情報ファイル | EUR Server - AdapterまたはEUR Client Serviceが，EUR Web Plug-InのクラスIDおよびバージョン情報を取得するときに参照するファイルです。


データファイル

12.2　データファイル

EURが入力時に使用するデータファイルには，マッピングデータファイルとユーザ定義データファイルがあります。

また，マッピングデータファイルの内容（マッピングデータ）に帳票の出力方法や出力先などの情報を付加した制御情報付データファイルがあります。制御情報付データファイルについては「12.9　制御情報付データファイル」を参照してください。

＜この節の構成＞
(1)　概要
(2)　扱えるデータファイルの形式

(1)　概要

EUR サーバ帳票出力機能で扱えるデータファイルは，CSV形式（*.csv），DAT形式（*.dat），およびFIX形式（*.fix）があります。

■注意
  • データファイルのフィールドの区切り方法やフィールド定義などは，EUR 帳票作成機能で帳票を設計する時に指定してください。
  • データファイル中のタブコードは，半角空白一つと見なして読み込まれます。ただし，データファイルの1行目をフィールド名として扱う場合は，1行目のタブコードはそのままタブコードとして読み込まれます。
  • EUR サーバ帳票出力機能では，DAT形式ファイルはCSV形式ファイルと同じと見なします。

(2)　扱えるデータファイルの形式

CSV形式（DAT形式）のデータファイルは，フィールドとフィールドの間を区切り記号で区切ったファイルです。区切り記号は，EUR 帳票作成機能で帳票設計する時に，データのプロパティで指定できます。区切り記号のデフォルトは「,（コンマ）」です。指定した区切り文字は，帳票ファイル中に保存されます。

CSV形式（DAT形式）のデータファイルのファイルサイズ，およびレコードの上限値を，次に示します。

表12-2　 CSV形式（DAT形式）データファイルの上限値

項目 | 上限値
ファイルサイズ | 2GBを上限とします。
レコード数 | 上限はありません。
レコード長 | 上限はありません。
フィールド数 | 上限はありません。
1フィールドの長さ | 上限はありません。
フィールド名の長さ | マッピングデータのフィールド名：510桁を上限とします。ユーザ定義データのフィールド名：499桁を上限とします。

次に，ファイル形式を示します。

FIX形式のデータファイルは，レコード中に区切り文字がなく，すべてのレコードの，フィールドの開始位置とデータ長が固定である形式を持つファイルです。フィールドの区切り位置と長さは，EUR 帳票作成機能のデータのプロパティで指定した情報を使います。指定した区切り位置と長さは，帳票ファイル中に保存されます。

FIX形式のデータファイルのファイルサイズ，およびレコードの上限値を，次に示します。

表12-3　 FIX形式データファイルの上限値

項目 | 上限値
ファイルサイズ | 2GBを上限とします。
レコード数 | 上限はありません。
レコード長 | 改行を含めないで100,000バイトを上限とします。
フィールド数 | 1レコードの上限が100,000バイトなので，その範囲内では制限なしと見なします。
1フィールドの長さ | 100,000バイトを上限とします。
フィールド名の長さ | マッピングデータのフィールド名：510桁を上限とします。ユーザ定義データのフィールド名：499桁を上限とします。

次に，ファイル形式を示します。


可変記号値定義ファイル

12.3　可変記号値定義ファイル

データベースから抽出したデータを使って帳票を出力したい場合は，データファイルを指定するプロパティ，オプションなどに可変記号値定義ファイルを指定します。詳細については，マニュアル「EUR データベース連携ガイド」を参照してください。

可変記号値定義ファイルは，データベースからデータを検索し，条件に合ったデータを抽出する時に必要な，検索条件の可変記号とその値（可変記号値）を定義するためのファイルです。可変記号は，条件式の条件値だけを変更する場合に使います。

帳票を設計した時に設定された可変記号に，可変記号値を定義することで，条件に合った抽出データで帳票を出力できます。接続情報ファイルと組み合わせて使用します。

可変記号値定義ファイルは，データの種類ごとに作成します。マッピングデータとユーザ定義データの両方で可変記号値を使用する場合は，それぞれに可変記号値定義ファイルが必要になります。


帳票セット指定ファイル

12.4　帳票セット指定ファイル

＜この節の構成＞
(1)　概要
(2)　形式
(3)　サンプルの内容

(1)　概要

EUR サーバ帳票出力機能では，複数の帳票ファイルを帳票セットで指定することもできますが，帳票セットで指定する場合は，個数の上限はなくても，コマンドやシステム関数の引数に指定する文字数に制限があります。帳票セットの個数やファイルに指定できる文字数の上限に関係なく指定したい場合は，帳票セットを帳票セット指定ファイルに指定することをお勧めします。

帳票セット指定ファイルは，次のように複数の帳票ファイルを統合する順番と帳票に読み込むデータファイルを指定しておくファイルです。

図12-1　帳票セット指定ファイル

(2)　形式

帳票セット指定ファイルは，メモ帳などのテキストエディタを起動して作成，または編集してください。任意の拡張子のファイルを使用できます。

帳票セット指定ファイルの形式を次に示します。

帳票セット1 △1〔△2
  〔帳票セット2 △1〕〕〔△2
         ：
  〔帳票セットn △1〕〕
（凡例）
△1：0個以上のタブ，または半角空白を示します。
△2：改行コード（\n）を示します。

帳票セット指定ファイルの編集方法を説明します。

■帳票セットの形式
帳票ファイル名△n〔,〔マッピングデータ△n〕〔,〔ユーザ定義データ△n〕〔,〔しおり定義ファイル名〕〕〕〕
「マッピングデータ」と「ユーザ定義データ」に指定するファイル情報は，帳票を設計する時に使用したデータによって，次のように異なります。
  • データファイルから読み込んだデータの場合
    データファイル名を指定します。省略した場合は，帳票設計時に指定したデータファイル名が仮定されます。帳票設計時に指定したデータファイル名は，EUR 帳票作成機能の［データのプロパティ］ダイアログの［データ情報］タブで確認できます。
  • データベースアクセス定義で抽出したデータを読み込んだ場合
    可変記号値定義ファイル名を指定します。データベースアクセス定義で可変記号を設定しなかった場合，または可変記号の初期値で実行する場合は，可変記号値定義ファイル名の指定を省略できます。
    なお，データベースに接続して帳票にデータを読み込む場合は，起動部品やコマンドで接続情報ファイルを指定してください。接続情報ファイルが指定されていない場合は，可変記号値定義ファイルを指定してもデータファイルと見なされます。
●帳票セットの指定方法
  • 帳票セットは，一つ以上指定してください。一つ以上の帳票セットが指定されていない場合は，エラー（KEEU036-E）になります。指定できる帳票セットの上限はありません。
  • 帳票セットは，「"」で囲まないでください。帳票セットを「"」で囲んだ場合は，すべてのファイルを帳票ファイルと見なします。
  • 「△n」は，ファイル名を区切るコンマ「,」の前に，0個以上の半角空白，または0個以上の改行コード（\t）が指定できることを示します。
  • 帳票ファイルは必ず指定してください。帳票ファイルが指定されていない場合は，エラー（KEEU036-E）になります。
●ファイルの指定のしかた
  • ファイル名は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。ファイル名を相対パス，またはファイル名だけで指定した場合，コマンド，起動部品，または環境変数で指定したフォルダから読み込まれます。
  • ファイル名に空白が含まれている場合は，個々のファイルを「"」で囲んでください。例えば，帳票ファイル名に空白が含まれている場合は，「"Report 1.fms",Mapdata.csv」のように指定します。

(3)　サンプルの内容

EUR 帳票作成機能で提供されている帳票セット指定ファイルのサンプル例を示します。

(a)　サンプル帳票「請求書」の場合

サンプル帳票「請求書」を出力する時に指定する，サンプル帳票セット指定ファイル（formset01（複数様式帳票例１）.txt）の指定例を示します。

一つのデータファイルを二つの異なる様式（帳票）で共有しています。

■サンプル帳票セット指定ファイル（formset01（複数様式帳票例１）.txt）の内容
表紙次紙形式の帳票＿表紙（複数様式帳票例１）.fms,表紙次紙形式の帳票＿表紙（複数様式帳票例１）.csv
表紙次紙形式の帳票＿次紙（複数様式帳票例１）.fms,表紙次紙形式の帳票＿表紙（複数様式帳票例１）.csv
(b)　サンプル帳票「従業員勤務歴カード」の場合

サンプル帳票「従業員勤務歴カード」を出力する時に指定する，サンプル帳票セット指定ファイル（formset02（複数様式帳票例２）.txt）の指定例を示します。

二つのデータファイルと三つの異なる様式（帳票）を使用しています。

■サンプル帳票セット指定ファイル（formset02（複数様式帳票例２）.txt）の内容
従業員勤務歴１（複数様式帳票例２）.fms,従業員勤務歴１（複数様式帳票例２）.csv
従業員勤務歴１－次紙（複数様式帳票例２）.fms,従業員勤務歴１（複数様式帳票例２）.csv
従業員勤務歴２（複数様式帳票例２）.fms,従業員勤務歴２（複数様式帳票例２）.csv
(c)　サンプル帳票「保険申込書」の場合

サンプル帳票「保険申込書」を出力する時に指定する，サンプル帳票セット指定ファイル（formset03（複数様式帳票例３）.txt）の指定例を示します。

一つのデータファイルを三つの異なる様式（帳票）で共有しています。

■サンプル帳票セット指定ファイル（formset03（複数様式帳票例３）.txt）の内容
保険申込書（複数様式帳票例３）.fms,保険申込書（複数様式帳票例３）.csv
保険申込書＿代理店控（複数様式帳票例３）.fms,保険申込書（複数様式帳票例３）.csv
保険申込書＿契約者控（複数様式帳票例３）.fms,保険申込書（複数様式帳票例３）.csv


文書しおり定義ファイル

12.5　文書しおり定義ファイル

＜この節の構成＞
(1)　概要
(2)　形式
(3)　キーワード

(1)　概要

EUR サーバ帳票出力機能では，PDF形式ファイルにしおりを付けられます。

しおりを付けると，PDF形式ファイルを開いたときに表示されるしおりをクリックして，特定のページに移動できるようになります。

しおりは階層構造で，「PDF形式ファイルを示すしおり」と「サブ文書の情報を示すしおり」があり，「PDF形式ファイルを示すしおり」は文書しおり定義ファイルで定義します。

「PDF形式ファイルを示すしおり」はPDF形式ファイルごとに一つ作成できます。

「PDF形式ファイルを示すしおり」を付けると，PDF形式ファイルを開いた場合，次のように表示されます。

「PDF形式ファイルを示すしおり」を付ける場合，しおりとして表示する文字列と，しおりをクリックしたときのページの表示方法を文書しおり定義ファイルで指定します。

(2)　形式

キーワード=値
キーワードに指定できる値を次に示します。

表12-4　 文書しおり定義ファイルのキーワードに指定できる値

キーワード | 値
TITLE | 「PDF形式ファイルを示すしおり」の文字列を指定します。
SCALE | ページの表示方法を指定します。
BOOKMARK | しおりを開いた状態で表示するか，閉じた状態で表示するかを指定します。

(3)　キーワード

文書しおり定義ファイルに指定するキーワードTITLE，SCALE，およびBOOKMARKは，出力するPDF形式ファイルごとに1組だけ指定します。一つのPDF形式ファイルに複数組のキーワードを指定した場合は，エラー（KEEU028-E）になります。

文書しおり定義ファイルに指定するキーワードとオプションは，大文字，小文字の区別をしません。

(a)　TITLE

「PDF形式ファイルを示すしおり」の文字列を指定します。「PDF形式ファイルを示すしおり」は，文書情報設定ファイルに設定したタイトルをそのまま利用することもできますし，任意の文字列を設定することもできます。

■キーワードTITLEの形式
TITLE={docinfotitle | "文字列"}
docinfotitle
文書情報設定ファイルのキーワードTITLEに指定されている文字列を，PDF形式ファイルを示すタイトルとします。
オプションdocinfotitleを指定したのに文書情報設定ファイルのキーワードTITLEに文字列が指定されていない場合は，しおりパレットにはタイトルを表示しません。文書情報設定ファイルについては，「11.4　文書情報設定ファイル」を参照してください。
文字列
「PDF形式ファイルを示すしおり」に任意の文字列を指定する場合は，文字列を「"」で囲んで指定します。文字列が「"」で囲まれていない場合，または「""」のように空の文字列で指定されている場合は，エラー（KEEU028-E）になります。
文字列中に「"」を指定したい場合は，「"」を二つ続けて記述して，文字列の両端を「"」で囲んでください。例えば，「E"UR」とする場合は，「"E""UR"」と指定します。
  • 文字列に使用できる文字コード
    文字列に使用できる文字コードについては，マニュアル「EUR システム設計ガイド」を参照してください。
    文字列に制御文字は指定できません。文字列に制御文字を指定した場合は，半角空白に置き換えて出力されます。
  • 指定できる文字列の長さ
    指定できる文字列の長さに制限はありません。
(b)　SCALE

ページの表示方法を指定します。キーワードSCALEの指定を省略した場合は，倍率100（%）で表示されます。

ページの表示位置は，Adobe Readerの仕様と同じです。

■キーワードSCALEの形式
SCALE=〔倍率 | fit | fith〕
倍率
表示するページの倍率を，10～1,600（%）の整数で指定します。
fit
ページ全体が，表示ウィンドウに収まるサイズで表示されます。
オプションfitを「"」で囲んで指定すると，エラー（KEEU028-E）になります。
fith
ページの横幅が，表示ウィンドウの横幅と一致するように表示されます。
オプションfithを「"」で囲んで指定すると，エラー（KEEU028-E）になります。
(c)　BOOKMARK

しおりを開いた状態で表示するか，閉じた状態で表示するかを指定します。省略した場合は，openが仮定されます。open，close以外を指定した場合，およびオプションを「"」で囲んだ場合はエラー（KEEU028-E）となります。open，closeは半角文字で指定してください。

■キーワードBOOKMARKの形式
BOOKMARK =〔open | close〕
open
しおりが開いた状態で表示されます。
close
しおりが閉じた状態で表示されます。


しおり定義ファイル

12.6　しおり定義ファイル

＜この節の構成＞
(1)　概要
(2)　形式
(3)　キーワード

(1)　概要

EUR サーバ帳票出力機能では，PDF形式ファイルにしおりを付けられます。

しおりには，「PDF形式ファイルを示すしおり」と「サブ文書の情報を示すしおり」があります。

「サブ文書の情報を示すしおり」を付ける場合，しおり定義ファイルに，しおりの文字列とPDF形式ファイルのページの表示方法を設定します。

「サブ文書の情報を示すしおり」を指定すると，PDF形式ファイルを開いた場合，次のように表示されます。

サブ文書の情報には，「PDF形式ファイルを構成するサブ文書（帳票）を示すしおり」と「（帳票に出力する）データのまとまりを表す項目のしおり」があります。

  • 「PDF形式ファイルを構成するサブ文書（帳票）を示すしおり」の文字列
  • 「（帳票に出力する）データのまとまりを表す項目のしおり」の文字列
  • PDF形式ファイルのページの表示方法

しおり定義ファイルは，メモ帳など，テキストファイルが編集できるエディタを起動して編集します。任意の拡張子のファイルを使用できます。

(2)　形式

キーワード=値
キーワードに指定できる値を次に示します。

表12-5　 しおり定義ファイルのキーワードに指定できる値

キーワード | 値
NAME | 「PDF形式ファイルを構成するサブ文書（帳票）を示すしおり」を指定します。
BREAKFLD | 「（帳票に出力する）データのまとまりを表す項目のしおり」を指定します。

(3)　キーワード

しおり定義ファイルに指定するキーワードとオプションは，大文字，小文字の区別をしません。

(a)　NAME

「PDF形式ファイルを構成するサブ文書（帳票）を示すしおり」の文字列（帳票名）を指定します。NAMEキーワードは，出力する帳票ファイルごとに一つだけ指定します。一つの帳票ファイルに複数のNAMEキーワードを指定した場合は，エラー（KEEU027-E）になります。

■キーワードNAMEの形式
NAME="文字列"〔,倍率 | ,fit | ,fith〕
文字列
「PDF形式ファイルを構成するサブ文書（帳票）を示すしおり」の文字列（帳票名）を「"」で囲んで指定します。文字列が「"」で囲まれていない場合，または「""」のように空の文字列で指定されている場合は，エラー（KEEU027-E）になります。
文字列中に「"」を指定したい場合は，「"」を二つ続けて記述して，文字列の両端を「"」で囲んでください。例えば，「E"UR」とする場合は，「"E""UR"」と指定します。
  • 文字列に使用できる文字コード
    文字列に使用できる文字コードについては，マニュアル「EUR システム設計ガイド」を参照してください。
    文字列は，任意の文字列で指定できますが，制御文字は指定できません。文字列に制御文字を指定した場合は，半角空白に置き換えて出力されます。
  • 指定できる文字列の長さ
    指定できる文字列の長さに制限はありません。
倍率 | fit | fith
ページの表示方法を指定します。指定を省略した場合は，100（%）で表示されます。
ページの表示位置は，Adobe Readerの仕様と同じです。
倍率
表示するページの倍率を，10～1,600（%）の整数で指定します。
fit
ページ全体が，表示ウィンドウに収まるサイズで表示されます。
オプションfitを「"」で囲んで指定すると，エラー（KEEU027-E）になります。
fith
ページの横幅が，表示ウィンドウの横幅と一致するように表示されます。
オプションfithを「"」で囲んで指定すると，エラー（KEEU027-E）になります。
(b)　BREAKFLD

「（帳票に出力する）データのまとまりを表す項目のしおり」のキーとなるフィールド名を指定します。

キーワードBREAKFLDは，5行まで（5階層表示）指定できます。6行以上指定した場合は，エラー（KEEU027-E）になります。階層は，キーワードBREAKFLDに指定したフィールド順です。キーワードBREAKFLDに指定したフィールド中のデータが直前のデータと異なる値の場合（一番目のデータも含む），その値が階層の中を分類する文字列として表示されます。

■キーワードBREAKFLDの形式
BREAKFLD="フィールド名1"〔,倍率1 | ,fit | ,fith〕
BREAKFLD="フィールド名2"〔,倍率2 | ,fit | ,fith〕
                      ：
BREAKFLD="フィールド名5"〔,倍率5 | ,fit | ,fith〕
フィールド名
「（帳票に出力する）データのまとまりを表す項目のしおり」のキーとなるフィールド名を「"」で囲んで指定します。フィールド名が「"」で囲まれていない場合は，エラー（KEEU027-E）になります。
キーとなるフィールド名には，出力するデータのどのフィールドを指定してもかまいませんが，帳票を設計した時に設定された改ページや改ブロックのキーとなるフィールドと同じフィールド名を指定すると，帳票を設計した時と同じ情報の帳票を表示できます。どのフィールドが改ページや改ブロックのキーとなるフィールドに設定されているかを知るには，EUR 帳票作成機能で確認してください。
指定したフィールドのデータが画像データの場合は，画像ファイル名がしおりとして表示されます。
また，指定したフィールドのデータが空データだった場合は，「（空データ）」がしおりとして表示されます。
次に示すフィールド名をキーワードBREAKFLDに指定した場合，エラーにはなりませんが，指定したn番目のしおりは出力されません。
  • 帳票を設計した時にフィールド定義されていないフィールド名
  • 帳票に貼り付けられていないフィールド名
倍率 | fit | fith
ページの表示方法を指定します。指定を省略した場合は，100（%）で表示されます。
実際の大きさで表示する場合は，表示方法の指定を省略するか，または「100」を指定してください。
ページの表示位置は，Adobe Readerの仕様と同じです。
倍率
表示するページの倍率を，10～1,600（%）の整数で指定します。
fit
ページ全体が，表示ウィンドウに収まるサイズで表示されます。
オプションfitを「"」で囲んで指定すると，エラー（KEEU027-E）になります。
fith
ページの横幅が，表示ウィンドウの横幅と一致するように表示されます。
オプションfithを「"」で囲んで指定すると，エラー（KEEU027-E）になります。


暗号化設定ファイル

12.7　暗号化設定ファイル

＜この節の構成＞
(1)　概要
(2)　形式
(3)　キーワード

(1)　概要

PDF形式ファイルの改ざん，および情報の漏えいを防ぐために，PDF形式ファイルを暗号化できます。

PDF形式ファイルを暗号化するには，セキュリティ属性を暗号化設定ファイルに設定します。

暗号化設定ファイルには，次に示すセキュリティ属性を設定できます。

  • ユーザパスワード
    PDF形式ファイルを閲覧する時に入力するパスワードを指定します。ユーザパスワードが指定されていると，PDF形式ファイルを閲覧する時に，パスワード入力が要求されます。
  • オーナパスワード
    セキュリティ属性を設定，または変更したり，PDFに権限を設定したりする時に入力するパスワードを指定します。
    Adobe Reader 7の，「マスタパスワード」に該当するものです。
  • 印刷
    PDFから印刷することを禁止します。
  • 文書の変更
    PDF文書情報の変更を禁止します。
  • 内容のコピー，または抽出
    内容のコピー，または抽出を禁止します。
  • 注釈とフォームフィールドの作成
    注釈とフォームフィールドの作成を禁止します。

(2)　形式

キーワード=値
セキュリティ属性を，「キーワード=値」の形式で記述します。キーワードに指定できる値を次に示します。

表12-6　 暗号化設定ファイルのキーワードに指定できる値

キーワード | 値
OwnerPassword | PDFに，セキュリティ属性と権限を設定する時のパスワードを指定します。
DisablePrint | PDFからの印刷を禁止するかどうかを指定します。
DisableChange | PDF文書情報の変更を禁止するかどうかを指定します。
DisableCopy | PDF中の内容のコピー，または抽出を禁止するかどうかを指定します。
DisableAdd | 注釈とフォームフィールドの作成を禁止するかどうかを指定します。
UserPassword | PDF形式ファイルを閲覧する時のパスワードを指定します。
EncryptionMode | PDF形式ファイルを暗号化する時の暗号化モードを指定します。

キーワードの指定は，PDF形式ファイルを暗号化出力する場合と，PDF形式ファイルを暗号化仕分け出力する場合とで異なります。キーワードと対応する出力方法について，次に示します。

表12-7　 キーワードと対応する出力方法

キーワード | PDF形式ファイルを暗号化出力する場合 | PDF形式ファイルを暗号化仕分け出力する場合
OwnerPassword | ○ | ◎ ※1
DisablePrint | ○ | ○
DisableChange | ○ | ○
DisableCopy | ○ | ○
DisableAdd | ○ | ○
UserPassword | ○ | ○ ※2
EncryptionMode | ○ | ○
（凡例）
◎：必ず指定するキーワードです。
○：指定を省略できるキーワードです。
注※1
PDF形式ファイルを暗号化仕分け出力する場合，暗号化設定ファイルの指定は省略できますが，暗号化設定ファイルを指定するときは，キーワードOwnerPasswordを必ず指定してください。省略した場合は，エラー（KEEU030-E）になります。
注※2
PDF形式ファイルを暗号化仕分け出力する場合は，PDF仕分け定義ファイルでユーザパスワードを指定します。そのため，暗号化設定ファイルのキーワードUserPasswordは，指定されていても無視されます。

(3)　キーワード

暗号化設定ファイルに指定するキーワードは，大文字，小文字の区別をしません。

(a)　OwnerPassword

PDFに，セキュリティ属性と権限を設定する場合のパスワードを指定します。暗号化したパスワードも指定できます。パスワードを複数指定した場合は，エラー（KEEU030-E）になります。

PDF形式ファイルを暗号化出力する場合，パスワードは，キーワードOwnerPassword，またはキーワードUserPasswordのどちらかを指定してください。どちらも指定していない場合は，エラー（KEEU033-E）になります。

また，キーワードOwnerPasswordとキーワードUserPasswordには，異なるパスワードを指定してください。同じパスワードを指定した場合は，エラー（KEEU034-E）になります。

■キーワードOwnerPasswordの形式
OwnerPassword=文字列
文字列
パスワード文字列を指定します。
文字列に指定できる文字は，次のとおりです。指定できない文字を使用した場合は，エラー（KEEU030-E）になります。
  • 半角数字
    0～9
  • 半角英字
    A～Z，a～z
  • 半角記号
    ! " # $ % & ' ( ) * + , - . / : ; < = > ? @ [ \ ] ^ _ ` { | } ~
  • 半角空白
指定できる文字列の長さは，Shift JISコードで32バイトまでです。32バイトを超えた場合は，エラー（KEEU030-E）になります。

パスワードの暗号化については，マニュアル「EUR 帳票出力 機能解説 EUR Server編」を参照してください。

(b)　DisablePrint

PDFからの印刷を禁止するかどうかを指定します。複数指定した場合は，エラー（KEEU030-E）になります。

■キーワードDisablePrintの形式
DisablePrint=〔Yes | No〕
Yes | No
Yesを指定すると，PDFからの印刷を禁止します。ただし，キーワードOwnerPasswordが設定されていない場合は，エラー（KEEU030-E）になります。
Noを指定すると，PDFからの印刷を許可します。
オプションは，大文字と小文字を区別しています。「Yes」または「No」で指定してください。正しく指定されていない場合は，エラー（KEEU030-E）になります。
(c)　DisableChange

PDF文書情報の変更を禁止するかどうかを指定します。複数指定した場合は，エラー（KEEU030-E）になります。

■キーワードDisableChangeの形式
DisableChange=〔Yes | No〕
Yes | No
Yesを指定すると，PDF文書情報の変更を禁止します。ただし，キーワードOwnerPasswordが設定されていない場合は，エラー（KEEU030-E）になります。
Noを指定すると，PDF文書情報の変更を許可します。
オプションは，大文字と小文字を区別しています。「Yes」または「No」で指定してください。正しく指定されていない場合は，エラー（KEEU030-E）になります。
(d)　DisableCopy

PDF中の内容のコピー，または抽出を禁止するかどうかを指定します。複数指定した場合は，エラー（KEEU030-E）になります。

■キーワードDisableCopyの形式
DisableCopy=〔Yes | No〕
Yes | No
Yesを指定すると，PDF中の内容のコピー，または抽出を禁止します。ただし，キーワードOwnerPasswordが設定されていない場合は，エラー（KEEU030-E）になります。
Noを指定すると，PDF中の内容のコピー，または抽出を許可します。
オプションは，大文字と小文字を区別しています。「Yes」または「No」で指定してください。正しく指定されていない場合は，エラー（KEEU030-E）になります。
(e)　DisableAdd

注釈とフォームフィールドの作成を禁止するかどうかを指定します。複数指定した場合は，エラー（KEEU030-E）になります。

■キーワードDisableAddの形式
DisableAdd=〔Yes | No〕
Yes | No
Yesを指定すると，注釈とフォームフィールドの作成を禁止します。ただし，キーワードOwnerPasswordが設定されていない場合は，エラー（KEEU030-E）になります。
Noを指定すると，注釈とフォームフィールドの作成を許可します。
オプションは，大文字と小文字を区別しています。「Yes」または「No」で指定してください。正しく指定されていない場合は，エラー（KEEU030-E）になります。
(f)　UserPassword

PDF形式ファイルを閲覧する時のパスワードを指定します。パスワードには，暗号化したパスワードも指定できます。パスワードを複数指定した場合は，エラー（KEEU030-E）になります。

  • PDF形式ファイルを暗号化出力する場合
    PDF形式ファイルを暗号化出力する場合，パスワードは，暗号化設定ファイルのキーワードOwnerPassword，またはキーワードUserPasswordのどちらかを指定してください。どちらも指定していない場合は，エラー（KEEU033-E）になります。
    また，キーワードOwnerPasswordとキーワードUserPasswordには，異なるパスワードを指定してください。同じパスワードを指定した場合は，エラー（KEEU034-E）になります。
  • PDF形式ファイルを暗号化仕分け出力する場合
    PDF形式ファイルを暗号化仕分け出力する場合は，ユーザパスワードをPDF仕分け定義ファイルのuserpasswordで指定します。そのため，暗号化設定ファイルのキーワードUserPasswordの指定は要りません。指定されていても無視されます。
    パスワードは，暗号化設定ファイルのキーワードOwnerPassword，またはPDF仕分け定義ファイルのuserpasswordのどちらかを指定してください。どちらも指定していない場合は，エラー（KEEU033-E）になります。
    また，暗号化設定ファイルのキーワードOwnerPasswordとPDF仕分け定義ファイルのuserpasswordには，異なるパスワードを指定してください。同じパスワードを指定した場合は，エラー（KEEU034-E）になります。
    PDF仕分け定義ファイルについては，「12.8.2　PDF形式ファイルを暗号化仕分け出力する場合」を参照してください。
■キーワードUserPasswordの形式
UserPassword=文字列
文字列
パスワードの文字列を指定します。
文字列に指定できる文字は，次のとおりです。指定できない文字を使用した場合は，エラー（KEEU030-E）になります。
  • 半角数字
    0～9
  • 半角英字
    A～Z，a～z
  • 半角記号
    ! " # $ % & ' ( ) * + , - . / : ; < = > ? @ [ \ ] ^ _ ` { | } ~
  • 半角空白
指定できる文字列の長さは，Shift JISコードで32バイトまでです。32バイトを超えた場合は，エラー（KEEU030-E）になります。

パスワードの暗号化については，マニュアル「EUR 帳票出力 機能解説 EUR Server編」を参照してください。

(g)　EncryptionMode

PDF形式ファイルを暗号化する場合の暗号化モードを指定します。

■キーワードEncryptionModeの形式
EncryptionMode=〔1 | 2〕
1 | 2
暗号化モードを設定します。
指定値とその説明を次に示します。

表12-8　 キーワードEncryptionModeの指定値

指定値 | 鍵長 | 作成されるPDF形式ファイルのバージョン | 暗号強度
1 | 40ビット | バージョン1.2 | 弱い
2 | 128ビット | バージョン1.4 | 強い
キーワードEncryptionModeの指定を省略した場合は，128ビットの鍵長でPDF形式ファイルを暗号化します。
指定できる文字は，半角数字の「1」または「2」です。指定できない文字を使用した場合は，エラー（KEEU030-E）になります。


PDF仕分け定義ファイル

12.8　PDF仕分け定義ファイル

PDF形式ファイルを仕分け出力できます。

PDF形式ファイルの仕分け出力とは，データ中のキーとなるフィールドの値ごとに，異なるPDF形式ファイルに分類して出力することです。

PDF形式ファイルを仕分け出力するには，PDF仕分け定義ファイルが必要です。

PDF仕分け定義ファイルは，PDF形式ファイルを仕分け出力する場合とPDF形式ファイルを暗号化仕分け出力する場合とで定義内容が異なります。

＜この節の構成＞
12.8.1　PDF形式ファイルを仕分け出力する場合
12.8.2　PDF形式ファイルを暗号化仕分け出力する場合
12.8.3　注意事項


PDF形式ファイルを仕分け出力する場合

12.8.1　PDF形式ファイルを仕分け出力する場合

＜この項の構成＞
(1)　概要
(2)　形式
(3)　キーワード

(1)　概要

PDF形式ファイルを仕分け出力する場合，仕分けするキーの数やフィールド名をPDF仕分け定義ファイルに指定します。

(2)　形式

PDF仕分け定義ファイルは，メモ帳など，テキストファイルが編集できるエディタを起動して編集します。任意の拡張子のファイルを使用できます。

PDF形式ファイルを仕分け出力する場合のPDF仕分け定義ファイルの形式を次に示します。項目は，コンマ「,」で区切って記述します。

(3)　キーワード

PDF仕分け定義ファイルに指定するキーワードは，大文字，小文字の区別をしません。

(a)　KEYFIELD行

KEYFIELD行は，必ず1行目に指定してください。1行目がKEYFIELD行でなかったり，KEYFIELD行が複数指定されていたりした場合は，エラー（KEEU020-E）になります。

■KEYFIELD行の形式
KEYFIELD,キー数,仕分けキーフィールド名1〔〔,仕分けキーフィールド名2〕,…〕
KEYFIELD
キーワードKEYFIELDを指定します。指定を省略した場合は，エラー（KEEU020-E）になります。
キー数
仕分けするキーの数を，1以上の整数で指定します。0を指定した場合，または指定を省略した場合は，エラー（KEEU020-E）になります。
仕分けキーフィールド名
仕分けするキーフィールド名を，「キー数」で指定した数だけコンマ「,」で区切って指定します。指定を省略した場合は，エラー（KEEU020-E）になります。
また，指定されたフィールド名の数と「キー数」で指定した数が合わなかったり，仕分けキーフィールド名に同じフィールド名を複数指定したりした場合も，エラー（KEEU020-E）になります。
指定した仕分けキーフィールド名に一致するフィールドがない場合は，エラー（KEEU019-E）になります。
(b)　TOTAL行

PDF仕分け定義ファイルのTOTAL行は，省略できます。ただし，総集計ページがある場合や，総集計ページを別ファイルにする場合は，指定してください。

TOTAL行が複数指定されている場合は，エラー（KEEU020-E）になります。

■TOTAL行の形式
〔TOTAL,出力先ファイル名〕
TOTAL
キーワードTOTALを指定します。指定を省略した場合は，エラー（KEEU020-E）になります。
出力先ファイル名
総集計ページを出力するPDF形式ファイル名を指定します。指定を省略した場合は，エラー（KEEU020-E）になります。
(c)　DATA行

複数の行で「仕分けキーフィールドのデータ」に指定したデータがすべて同じ場合は，エラー（KEEU020-E）になります。

■DATA行の形式
DATA,出力先ファイル名,仕分けキーフィールド名1のデータ1〔〔,仕分けキーフィールド名2のデータ1〕…〕
〔DATA,出力先ファイル名,仕分けキーフィールド名1のデータ2〔〔,仕分けキーフィールド名2のデータ2〕…〕〕
                          ：
DATA
キーワードDATAを指定します。指定を省略した場合は，エラー（KEEU020-E）になります。
出力先ファイル名
仕分けするページを出力するPDF形式ファイル名を指定します。指定を省略した場合は，エラー（KEEU020-E）になります。
仕分けキーフィールド名のデータ
KEYFIELD行の「仕分けキーフィールド名」に対応するデータを，「キー数」で指定した数だけコンマ「,」で区切って指定します。指定されたすべてのデータで，マッピングデータファイルと照合して仕分けされます。指定を省略した場合は，エラー（KEEU020-E）になります。
また，指定した「仕分けキーフィールドのデータ」の数と「キー数」で指定した数が合わなかった場合も，エラー（KEEU020-E）になります。
●データの指定のしかた
  • データの文字列は，そのまま記述するか，または「"」で囲みます。
  • データ中に「"」が使用されている場合は，「"」を二つ続けて記述し，データの両端を「"」で囲んでください。
    「E"UR」とする場合は，「"E""UR"」と指定します。
  • データ中に区切り文字が使用されている場合は，文字列の両端を「"」で囲んでください。
    「,」が区切り文字の場合，「EU,R」とするときは，「"EU,R"」と指定します。


PDF形式ファイルを暗号化仕分け出力する場合

12.8.2　PDF形式ファイルを暗号化仕分け出力する場合

＜この項の構成＞
(1)　概要
(2)　形式
(3)　キーワード

(1)　概要

PDF形式ファイルを暗号化仕分け出力する場合，仕分けするキーの数やフィールド名をPDF仕分け定義ファイルに指定します。

(2)　形式

PDF仕分け定義ファイルは，メモ帳など，テキストファイルが編集できるエディタを起動して編集します。

PDF形式ファイルを暗号化仕分け出力する場合のPDF仕分け定義ファイルの形式を次に示します。項目は，コンマ「,」で区切って記述します。

(3)　キーワード

PDF仕分け定義ファイルに指定するキーワードは，大文字，小文字の区別をしません。

(a)　KEYFIELD行

KEYFIELD行は，必ず1行目に指定してください。1行目がKEYFIELD行でなかったり，KEYFIELD行が複数指定されていたりした場合は，エラー（KEEU020-E）になります。

■KEYFIELD行の形式
KEYFIELD,キー数,仕分けキーフィールド名1〔〔,仕分けキーフィールド名2〕,…〕
KEYFIELD
キーワードKEYFIELDを指定します。指定を省略した場合は，エラー（KEEU020-E）になります。
キー数
仕分けするキーの数を，1以上の整数で指定します。0を指定した場合，または指定を省略した場合は，エラー（KEEU020-E）になります。
仕分けキーフィールド名
仕分けするキーフィールド名を，「キー数」で指定した数だけコンマ「,」で区切って指定します。指定を省略した場合は，エラー（KEEU020-E）になります。
また，指定されたフィールド名の数と「キー数」で指定した数が合わなかったり，仕分けキーフィールド名に同じフィールド名を複数指定したりした場合も，エラー（KEEU020-E）になります。
指定した仕分けキーフィールド名に一致するフィールドがない場合は，エラー（KEEU019-E）になります。
(b)　TOTAL行

TOTAL行は，省略できます。ただし，総集計ページがある場合や，総集計ページを別ファイルにする場合は，指定してください。

TOTAL行を複数指定されている場合は，エラー（KEEU020-E）になります。

■TOTAL行の形式
〔TOTAL,出力先ファイル名〔,userpassword〕〕
TOTAL
キーワードTOTALを指定します。指定を省略した場合は，エラー（KEEU020-E）になります。
出力先ファイル名
総集計ページを出力するPDF形式ファイル名を指定します。指定を省略した場合は，エラー（KEEU020-E）になります。
userpassword
「出力先ファイル名」で指定したPDF形式ファイルに対するユーザパスワードを指定します。暗号化したパスワードも指定できます。パスワードの暗号化については，マニュアル「EUR 帳票出力 機能解説 EUR Server編」を参照してください。
「userpassword」の指定は省略できます。指定を省略する場合は，「userpassword」の直前のコンマ「,」も省略できます。
●ユーザパスワードの文字列に指定できる文字
文字列に指定できる文字は，次のとおりです。指定できない文字を使用した場合は，エラー（KEEU020-E）になります。
  • 半角数字
    0～9
  • 半角英字
    A～Z，a～z
  • 半角記号
    ! " # $ % & ' ( ) * + , - . / : ; < = > ? @ [ \ ] ^ _ ` { | } ~
文字列にコンマ「,」を指定する場合は，コンマ「,」を「"」で囲んでください。
  • 半角空白
●ユーザパスワードの文字列長
指定できる文字列の長さは，Shift JISコードで32バイトまでです。32バイトを超えた場合は，エラー（KEEU020-E）になります。
(c)　DATA行

DATA行に指定した「仕分けキーフィールド名のデータ」とすべて同じ行が複数指定されている場合は，エラー（KEEU020-E）になります。

■DATA行の形式
DATA,出力先ファイル名,仕分けキーフィールド名1のデータ1〔〔,仕分けキーフィールド名2のデータ1〕…〕〔,userpassword〕
〔DATA,出力先ファイル名,仕分けキーフィールド名1のデータ2〔〔,仕分けキーフィールド名2のデータ2〕…〕〔,userpassword〕〕
                            ：
DATA
キーワードDATAを指定します。指定を省略した場合は，エラー（KEEU020-E）になります。
出力先ファイル名
仕分けするページを出力するPDF形式ファイル名を指定します。指定を省略した場合は，エラー（KEEU020-E）になります。
仕分けキーフィールド名のデータ
KEYFIELD行の「仕分けキーフィールド名」に対応するデータを，「キー数」で指定した数だけコンマ「,」で区切って指定します。指定されたすべてのデータで，マッピングデータファイルと照合して仕分けされます。指定を省略した場合は，エラー（KEEU020-E）になります。
また，指定された仕分けキーフィールド名のデータ数と「キー数」で指定した数が合わなかった場合も，エラー（KEEU020-E）になります。
●データの指定のしかた
  • データの文字列は，そのまま記述するか，または「"」で囲みます。
  • データ中に「"」が使用されている場合は，「"」を二つ続けて記述し，データの両端を「"」で囲んでください。
    「E"UR」とする場合は，「"E""UR"」と指定します。
  • データ中に区切り文字が使用されている場合は，文字列の両端を「"」で囲んでください。
    「,」が区切り文字の場合，「EU,R」とするときは，「"EU,R"」と指定します。
userpassword
「出力先ファイル名」で指定した，仕分けするページを出力するPDF形式ファイルに対するユーザパスワードを指定します。暗号化したパスワードも指定できます。パスワードの暗号化については，マニュアル「EUR 帳票出力 機能解説 EUR Server編」を参照してください。
「userpassword」の指定は省略できます。指定を省略する場合は，「userpassword」の直前のコンマ「,」も省略できます。
●ユーザパスワードの文字列に指定できる文字
文字列に指定できる文字は，次のとおりです。指定できない文字を使用した場合は，エラー（KEEU020-E）になります。
  • 半角数字
    0～9
  • 半角英字
    A～Z，a～z
  • 半角記号
    ! " # $ % & ' ( ) * + , - . / : ; < = > ? @ [ \ ] ^ _ ` { | } ~
  • 半角空白
文字列にコンマ「,」を指定する場合は，コンマ「,」を「"」で囲んでください。
●ユーザパスワードの文字列長
指定できる文字列の長さは，Shift JISコードで32バイトまでです。32バイトを超えた場合は，エラー（KEEU020-E）になります。


注意事項

12.8.3　注意事項

仕分けキーフィールドの指定は，ページごとにキーフィールドのデータと仕分け情報を比較して，仕分けされます。次のような帳票の場合は，仕分けをするときに注意してください。

  • 1ページ中に仕分けキーフィールドのデータが，複数繰り返して表示されている帳票の場合
    仕分け出力は，ページ単位に仕分けをします。そのため，1ページ中に仕分けキーフィールドのデータが複数繰り返して出力されている場合は，そのページの最初のデータが仕分けの判定対象になります。例えば，1ページに東京と横浜のデータが繰り返して出力されていると，東京で仕分けしたPDF形式ファイルに横浜のデータも一緒に出力されます。
    キーフィールドのデータごとにPDF形式ファイルを仕分ける場合は，仕分けをする前に帳票作成機能でキーフィールドに改ページを設定して，仕分けキーフィールドのデータが1ページに一つだけ出力されるように設計してください。
  • 集計ページのある帳票の場合
    集計ページは，前ページの最後のデータを仕分けの判定対象にします。
    例えば，前ページが横浜のデータであれば，集計ページも横浜に配布されます。
    キー集計と総集計の集計ページがある場合，前ページが横浜のデータであれば，総集計の集計ページは横浜だけに配布されます。総集計のデータを配布先すべてに出力する場合は，帳票作成機能ですべてのキー集計の集計ページに集計アイテムの総集計を貼り付けてください。


制御情報付データファイル

12.9　制御情報付データファイル

＜この節の構成＞
(1)　概要
(2)　形式
(3)　キーワード
(4)　注意事項

(1)　概要

制御情報付データファイルは，BSP-RM連携機能，および上位主導型で帳票自動出力機能を使用するときに準備するファイルです。マッピングデータに帳票の出力方法や出力先などの制御情報を付加したデータファイルです。

制御情報付データファイルには，次に示す要素を必須で定義します。帳票ファイル名，ユーザ定義データファイル名，しおり定義ファイル名※，およびマッピングデータは複数指定できます。

  • eurpmcコマンドを実行するときのオプション※
  • 帳票ファイル名，ユーザ定義データファイル名，しおり定義ファイル名※
  • マッピングデータ
注※
上位主導型の帳票自動出力機能で使用する制御情報付データファイルに定義する要素です。BSP-RM連携機能で使用する制御情報付データファイルではサポートしていません。

(2)　形式

制御情報付データファイルは，メモ帳など，テキストファイルが編集できるエディタを起動して編集します。任意の拡張子のファイルを使用できます。

制御情報付データファイルの形式を次に示します。

BSP-RM連携機能で使用する制御情報付データファイルの形式

△1<!eur_control start>△1△2
△1eur_fms△1=△1帳票ファイル名1△1〔,△1〔ユーザ定義データファイル名1△1〕〕△2
△1<!eur_control end>△1△2
〔マッピングデータ1〕
〔△1<!eur_control start>△1△2
△1eur_fms△1=△1帳票ファイル名2△1〔,△1〔ユーザ定義データファイル名2△1〕〕△2
△<!eur_control end>△1△2
〔マッピングデータ2〕〕
    ：
    ：
（凡例）
△1：0個以上のタブ，半角空白，または全角空白を示します。
△2：改行コード（\n），または（\r\n）を示します。

上位主導型の帳票自動出力機能で使用する制御情報付データファイルの形式

△1<!eur_option start>△1△2
△1eur_option△1=△1eurpmcコマンドのオプション文字列△2
△<!eur_option end>△1△2
△1<!eur_control start>△1△2
△1〔eur_fms△1=△1帳票ファイル名1△1〔,△1〔ユーザ定義データファイル名1△1〕〔,△1〔しおり定義ファイル名1△1〕〕〕〕△2
△1<!eur_control end>△1△2
〔マッピングデータ1〕
〔△1<!eur_control start>△1△2
△1〔eur_fms△1=△1帳票ファイル名2△1〔,△1〔ユーザ定義データファイル名2△1〕〔,△1〔しおり定義ファイル名2△1〕〕〕〕△2
△<!eur_control end>△1△2
〔マッピングデータ2〕〕
    ：
    ：
（凡例）
△1：0個以上のタブ，半角空白，または全角空白を示します。
△2：改行コード（\n），または（\r\n）を示します。

(3)　キーワード

制御情報付データファイルに指定するキーワードは，大文字，小文字を区別します。

(a)　eurpmcコマンドを実行するときのオプションの定義領域

上位主導型の帳票自動出力機能で使用する制御情報付データファイルの場合に，ファイル監視サービスから呼び出すeurpmcコマンドに実行するときのオプションを定義する領域です。

●<!eur_option start>行
<!eur_option start>
オプションの開始行を示すキーワードです。半角小文字で指定します。
必ず指定してください。
●eur_option行
eur_option
オプションの指定行を示すキーワードです。半角小文字で指定します。
必ず指定してください。
キーワードeur_optionは，<!eur_option start>行と<!eur_option end>行の間に一つだけ定義できます。
次に示す場合は，エラー（KEEU1514-E）になります。
  • キーワードeur_optionが複数存在する場合
  • キーワードeur_option以外の行が存在する場合
eurpmcコマンドのオプション文字列
eurpmcコマンドを実行するときのオプションを文字列で指定します。
オプションの指定値に半角空白を含む場合は，指定値全体を「"」で囲んで指定します。
また，eurpmcコマンドのオプションの指定には，ファイル名変数を使用することができます。
指定できるオプション，オプションの形式，およびファイル名変数については，「12.10　起動パラメタファイル」を参照してください。
eur_option行に帳票ファイル名（/rfオプション）を指定する場合は，帳票ファイル名の指定数がマッピングデータの定義領域の指定数と同じになるようにしてください。帳票ファイル名の指定数がマッピングデータの定義領域の指定数より少ないときは，エラー（KEEU1514-EまたはKEEU3014-E）になります。
●<!eur_option end>行
<!eur_option end>
オプションの終了行を示すキーワードです。半角小文字で指定します。
必ず指定してください。指定していない場合は，エラー（KEEU1514-E）になります。
(b)　帳票ファイル名，ユーザ定義データファイル名，しおり定義ファイル名の定義領域
●<!eur_control start>行
<!eur_control start>
帳票セットの開始行を示すキーワードです。半角小文字で指定します。
必ず指定してください。
帳票セットの開始行から，次の帳票セットの開始行，またはファイルの終端までを一つの帳票セットとして認識します。
帳票セットの指定がない場合は，エラー（KEEU1514-EまたはKEEU3014-E）になります。
●eur_fms行
eur_fms
帳票セットの指定行を示すキーワードです。半角小文字で指定します。
キーワードeur_fmsは，<!eur_control start>行と<!eur_control end>行の間に一つだけ定義できます。
BSP-RM連携機能に使用する制御情報付データファイルの場合は，必ず指定してください。
次に示す場合は，エラー（KEEU1514-EまたはKEEU3014-E）になります。
  • eur_fms行が複数存在する場合
  • eur_fms行以外の行が存在する場合
  • eur_fms行が一つ目の<!eur_control start>行の前に存在する場合
帳票ファイル名※1
帳票ファイル名を指定します。絶対パスまたは相対パスで指定できます。
BSP-RM連携機能に使用する制御情報付データファイルの場合，またはキーワードeur_fmsを定義した場合は，必ず指定してください。
上位主導型の帳票自動出力機能で使用する制御情報付データファイルの場合，eur_fms行に帳票ファイル名を指定するときは，必ずすべてのeur_fms行に帳票ファイル名を指定してください。指定していない場合（省略した場合を含む）は，エラー（KEEU1514-E）になります。
帳票ファイル名のパスの指定については，「15.2.21　PATHMODE」を参照してください。

ユーザ定義データファイル名※1
ユーザ定義データファイル名を指定します。絶対パスまたは相対パスで指定できます。

しおり定義ファイル名※1 ※2
しおり定義ファイル名を指定します。絶対パスまたは相対パスで指定できます。

注※1
上位主導型の帳票自動出力機能で使用する制御情報付データファイルの場合は，eurpmcコマンドを実行するときのオプションの定義領域のeur_option行に帳票セットを指定することもできます（eur_fms行の指定は省略します）。ただし，帳票セットをeur_fms行とeur_option行の両方に指定した場合は，eur_fms行の指定が有効となります。なお，eur_fms行のユーザ定義データファイル名およびしおり定義ファイル名に「""」を指定した場合は，各ファイル名は指定なしとして扱われます（eur_option行に各ファイル名を指定しても無効になります）。
注※2
上位主導型の帳票自動出力機能で使用する制御情報付データファイルに定義する要素です。BSP-RM連携機能で使用する制御情報付データファイルではサポートしていません。
●<!eur_control end>行
<!eur_control end>
帳票セットの終了行を示すキーワードです。半角小文字で指定します。
必ず指定してください。
<!eur_control end>行が一つ目の<!eur_control start>行の前に存在する場合は，エラー（KEEU1514-EまたはKEEU3014-E）になります。
(c)　マッピングデータの定義領域

マッピングデータを指定します。

帳票セットの終了行の直後の行から，次の帳票セットの開始行の直前の行，またはファイルの終端までを一つのマッピングデータとして認識します。

マッピングデータの指定を省略した場合は，マッピングデータファイルは生成されません。空のマッピングデータを指定する場合は，空行を1行指定します。

注意
<!eur_control start>行の文字列を，マッピングデータの単なる文字列として使用する場合は，文字列の両端を「"」で囲むなどで，<!eur_control start>行として認識されないように編集してください。

(4)　注意事項

  • ジョブ実行プログラムが読み込む制御情報付データファイルの形式が不正の場合は，ジョブ実行プログラムがエラーメッセージをログに出力し，エラーで終了します。
  • ジョブ実行プログラムが読み込む制御情報付データファイルのeur_fms行またはeur_option行，および起動パラメタファイルのどれにも帳票ファイル名の指定がない場合は，ジョブ実行プログラムがエラーメッセージをログに出力し，エラーで終了します。
  • キーワードeur_optionに指定できないオプションまたはオプションの指定値を指定した場合は，エラーとなります。また，同じオプションを複数定義した場合は，最後に定義したオプションの指定値が有効になります。


起動パラメタファイル

12.10　起動パラメタファイル

＜この節の構成＞
(1)　概要
(2)　形式
(3)　指定できるオプション
(4)　注意事項

(1)　概要

起動パラメタファイルは，BSP-RM連携コマンド（eursmprコマンド）および事前定義型でファイル監視サービスを使用するときに準備するファイルです。BSP-RM連携コマンドおよびファイル監視サービスからeurpmcコマンドを実行するときのオプションを定義します。

eurpmcコマンドの詳細については，「1.2　eurpmcコマンドが提供するオプション」を参照してください。

(2)　形式

起動パラメタファイルは，メモ帳など，テキストファイルが編集できるエディタを起動して編集します。任意の拡張子のファイルを使用できます。

起動パラメタファイルには，eurpmcコマンドの一つ以上のオプションを1行または複数行の文字列で指定します。複数行で指定した場合は，改行コード（\nまたは\r\n）を半角空白に置き換えた文字列がeurpmcコマンドのオプションの文字列として使用されます。

なお，オプションの指定値に半角空白を含む場合は，指定値全体を「"」で囲んで指定します。

起動パラメタファイルの形式を次に示します。

〔△1〕オプション△1オプションの指定値〔〔△1オプション△1オプションの指定値〕･･･〕〔オプション△1オプションの指定値〔〔△1オプション△1オプションの指定値〕･･･〕〕〔△1〕△2〕
  ：
（凡例）
△1：1個以上の半角空白を示します。
△2：改行コード（\nまたは\r\n）示します。

事前定義型のファイル監視サービスで使用する起動パラメタファイルには，eurpmcコマンドのオプションの指定にファイル名変数を使用することができます。

■ファイル名変数
ファイル名の「_」で区切った文字列を，eurpmcコマンドのオプションを指定する文字列の一部に動的に使用できる機能です。ファイル名変数の形式は「%00～%99」および「%~n」です。
「_」で区切った文字列のうち何番目の文字列を使用するかを，ファイル名変数の%01～%99で指定できます。
また，ファイル名全体はファイル名変数%00，ファイル名から拡張子以降（ピリオドを含む）を除外した文字列はファイル名変数%~n（nは半角英小文字で指定した場合のみ有効）で指定できます。なお，%~Ｎを指定した場合は単なる文字列として扱われます。
ファイル名から文字列を切り出す対象となるファイル，およびファイル名変数を使用できるファイルを次に示します。
事前定義型のファイル監視サービスを使用する場合
  • ファイル名から文字列を切り出す対象となるファイル
    マッピングデータファイル
  • ファイル名変数を使用できるファイル
    起動パラメタファイル（eurpmcコマンドのオプションの指定値）
上位主導型のファイル監視サービスを使用する場合
  • ファイル名から文字列を切り出す対象となるファイル
    制御情報付データファイル
  • ファイル名変数を使用できるファイル
    制御情報付データファイル（eurpmcコマンドのオプションの指定値）

事前定義型のファイル監視サービスで使用するマッピングデータファイルのファイル名が「請求書_20120911_部署A_.csv」の場合の，ファイル名変数の使用例を次に示します。
  1. マッピングデータファイルのファイル名を，切り出したい文字列ごとに「_」で区切ります。
  2. 「_」で区切られた文字列が先頭から順に，ファイル名変数の%01から%99に格納されます。なお，ファイル名変数%00にはファイル名全体の文字列，ファイル名変数%~nにはファイル名から拡張子以降（ピリオドを含む）を除外した文字列が格納されます。
    請求書_20120911_部署A_.csv

    %01：請求書
    %02：20120911
    %03：部署A
    %04：.csv
    %00：請求書_20120911_部署A_.csv
    %~ｎ：請求書_20120911_部署A_
  3. ファイル名変数の%03と%05を使用して，起動パラメタファイルのオプションの指定値を指定します。
    /m pdf /rf 請求書.fms /pdfn 請求書_%03.pdf /bm しおり_%05.txt
  4. ファイル名変数の%03が「部署A」の文字列に，ファイル名変数の%05が空文字に置き換わります。
    /m pdf /rf 請求書.fms /pdfn 請求書_部署A.pdf /bm しおり_.txt

ファイル名変数の注意事項を次に示します。
  • ファイル名変数で置き換える文字列に半角空白が含まれる場合は，ファイル名変数を含むオプションの指定値全体を「"」で囲んでください。例えば，ファイル名「請求書_20120911_部署A△_.csv」から切り出す文字列が「部署A△」の場合，/pdfnオプションの指定値にファイル名変数「%03」を使用するときは，「/pdfn "請求書_%03.pdf"」のように指定します。
    （凡例）
        △：半角空白を示します。
  • eurpmcコマンドのオプションの指定値として「%nn」（nは数値）および「%~n」は使用できません。例えば「/rac %20121231%」と指定した場合，「%20」が変数の値に置き換わります。ファイル名変数「%20」が「部署A」の場合は，「/rac 部署A121231%」となります。

(3)　指定できるオプション

起動パラメタファイルには，eurpmcコマンドのメソッドオプションとプロパティオプションを指定できます。メソッドオプションの指定は必須です。

(a)　メソッドオプション（必須）

起動パラメタファイルには，eurpmcコマンドのメソッドオプションを/mオプションで次のように指定します。

/m ｛epf | eur | pdf | print | xlsx｝

起動パラメタファイルに指定できる/mオプションの指定値を次に示します。それ以外の指定値を指定した場合はエラーになります。

表12-9　起動パラメタファイルに指定できる/mオプションの指定値

種類 /mオプションの指定値 内容
出力 epf
BSP-RM連携コマンド（eursmprコマンド）で使用する起動パラメタファイルの場合
出力対象の制御情報付データファイルに定義されているマッピングデータと帳票ファイル名に従って，/epfnオプションに指定したファイル名のEPF形式ファイルを出力します。
事前定義型のファイル監視サービスで使用する起動パラメタファイルの場合
出力対象のマッピングデータファイルと/rfオプションに指定した帳票ファイル名に従って，/epfnオプションに指定したファイル名のEPF形式ファイルを出力します。

/mオプションの指定値にepfを指定する場合は，/epfnオプションを必ず指定してください。事前定義型のファイル監視サービスで使用する起動パラメタファイルの場合は，/rfオプションも必ず指定してください。
eur
BSP-RM連携コマンド（eursmprコマンド）で使用する起動パラメタファイルの場合
出力対象の制御情報付データファイルに定義されているマッピングデータと帳票ファイル名に従って，/eurnオプションに指定したファイル名のEUR形式ファイルを出力します。
事前定義型のファイル監視サービスで使用する起動パラメタファイルの場合
出力対象のマッピングデータファイルと/rfオプションに指定した帳票ファイル名に従って，/eurnオプションに指定したファイル名のEUR形式ファイルを出力します。

/mオプションの指定値にeurを指定する場合は，/eurnオプションを必ず指定してください。事前定義型のファイル監視サービスで使用する起動パラメタファイルの場合は，/rfオプションも必ず指定してください。
pdf
BSP-RM連携コマンド（eursmprコマンド）で使用する起動パラメタファイルの場合
出力対象の制御情報付データファイルに定義されているマッピングデータと帳票ファイル名に従って，/pdfnオプションまたは/dsfオプションに指定したファイル名のPDF形式ファイルを出力します。
事前定義型のファイル監視サービスで使用する起動パラメタファイルの場合
出力対象のマッピングデータファイルと/rfオプションに指定した帳票ファイル名に従って，/pdfnオプションまたは/dsfオプションに指定したファイル名のPDF形式ファイルを出力します。

/mオプションの指定値にpdfを指定する場合は，/pdfnオプションまたは/dsfオプションのどちらかを必ず指定してください。事前定義型のファイル監視サービスで使用する起動パラメタファイルの場合は，/rfオプションも必ず指定してください。
print
BSP-RM連携コマンド（eursmprコマンド）で使用する起動パラメタファイルの場合
出力対象の制御情報付データファイルに定義されているマッピングデータと帳票ファイル名に従って，/pmオプションに指定した印刷方式で帳票を出力します。
事前定義型のファイル監視サービスで使用する起動パラメタファイルの場合
出力対象のマッピングデータファイルと/rfオプションの帳票ファイル名に従って，/pmオプションに指定した印刷方式で帳票を出力します。

事前定義型のファイル監視サービスで使用する起動パラメタファイルの場合は，/rfオプションも必ず指定してください。
xlsx
BSP-RM連携コマンド（eursmprコマンド）で使用する起動パラメタファイルの場合
出力対象の制御情報付データファイルに定義されているマッピングデータと帳票ファイル名に従って，/xlfnオプションに指定したファイル名のExcel形式ファイルを出力します。
事前定義型のファイル監視サービスで使用する起動パラメタファイルの場合
出力対象のマッピングデータファイルと/rfオプションに指定した帳票ファイル名に従って，/xlfnオプションに指定したファイル名のExcel形式ファイルを出力します。

/mオプションの指定値にxlsxを指定する場合は，/xlfnオプションを必ず指定してください。事前定義型のファイル監視サービスで使用する起動パラメタファイルの場合は，/rfオプションも必ず指定してください。なお，/mオプションの指定値にxlsxを指定する場合は，/rfオプションの指定値に単数のファイルしか指定できません。
(b)　プロパティオプション

起動パラメタファイルに指定できるプロパティオプションと指定値を次に示します。

表12-10　起動パラメタファイルに指定できるプロパティオプションと指定値

プロパティオプション 内容
（指定値）
/bm しおり定義ファイル名 ※
（255バイト以内の文字列）

しおり定義ファイル名を指定します。
複数のファイルを指定できます。複数のファイルを指定する場合は，コンマ（,）で区切ってください。
BSP-RM連携コマンド（eursmprコマンド）で使用する起動パラメタファイルの場合
指定するファイル名は，制御情報付データファイルのeur_fms行で指定する帳票ファイル名と同じ数を指定してください。
事前定義型のファイル監視サービスで使用する起動パラメタファイルの場合
指定するファイル名は，/rfオプションで指定する帳票ファイル名と同じ数を指定してください。

/bmオプションは，/mオプションの指定値にpdfを指定している場合に有効となります。
しおり定義ファイルは，EUR Server - Adapter稼働マシンに配置してください。
/bmf 文書しおり定義ファイル名 ※
（255バイト以内の文字列）

文書しおり定義ファイル名を指定します。

/bmfオプションは，/mオプションの指定値にpdfを指定している場合に有効となります。
文書しおり定義ファイルは，EUR Server - Adapter稼働マシンに配置してください。
/bmp 文書しおり定義ファイルまたはしおり定義ファイルのパス ※
（255バイト以内の文字列）

/bmfオプションで指定した文書しおり定義ファイルのパス，または/bmオプションで指定したしおり定義ファイルのパスを指定します。
指定されたファイルのパスは/bmfオプションで指定する文書しおり定義ファイルと，/bmオプションで指定するしおり定義ファイルのデフォルトの場所になります。

/bmpオプションは，/mオプションの指定値にpdfを指定している場合に有効となります。
文書しおり定義ファイルまたはしおり定義ファイルを配置しているEUR Server - Adapter稼働マシンのパスを指定してください。
/c 印刷部数
（1～99）

印刷部数を指定します。
/cオプションを省略した場合は，1が仮定されます。

/cオプションは，/mオプションの指定値にprintまたはepfのどちらかを指定している場合に有効となります。
/client クライアントPCのIPアドレス
（255.255.255.255形式）

印刷を実行するクライアントPCのIPアドレス，または蓄積クライアント印刷実行を要求するクライアントPCのIPアドレスを指定します。
/clientオプションを省略した場合は，デフォルト値（127.0.0.1）が仮定されます。

/clientオプションは，/mオプションの指定値にprint，かつ/pmオプションの指定値にclまたはsplのどちらかを指定している場合に有効となります。
/cry PDF形式ファイルの暗号化出力の有無
  • 1：PDF形式ファイルを暗号化する
  • 0：PDF形式ファイルを暗号化しない

PDF形式ファイルを暗号化して出力するかどうかを指定します。
/cryオプションを省略した場合は，0が仮定されます。

/cryオプションは，/mオプションの指定値にpdfを指定している場合に有効となります。
/cryf 暗号化設定ファイル名 ※
（255バイト以内の文字列）

暗号化設定ファイル名を指定します。

/cryfオプションは，/mオプションの指定値にpdfを指定している場合に有効となります。
暗号化設定ファイルは，EUR Server - Adapter稼働マシンに配置してください。
/cfyfp 暗号化設定ファイルのパス ※
（255バイト以内の文字列）

/cryfオプションで指定した暗号化設定ファイルのパスを指定します。

/cfyfpオプションは，/mオプションの指定値にpdfを指定している場合に有効となります。
暗号化設定ファイルを配置しているEUR Server - Adapter稼働マシンのパスを指定してください。
/dest 出力先名
（80バイト以内の文字列）

スプールサーバの出力先名を指定します。
出力先名には「"」および「,」を含めないでください。

/destオプションは，次に示すどちらかの指定がある場合に有効です。
  • /mオプションの指定値にprint，かつ/pmオプションの指定値にsv，かつ/srmオプションの指定値にdestを指定している場合
  • /mオプションの指定値にprint，かつ/pmオプションの指定値にspl，かつ/srmオプションの指定値にsvを指定している場合
/df 文書情報設定ファイル名 ※
（255バイト以内の文字列）

文書情報設定ファイル名を指定します。
EUR Server Serviceの環境設定ファイル（EURPM.ini）で，OPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，文書情報ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのDOCINFOキーで設定しているフォルダに格納しておいてください。
OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。
パスは，/dfpオプションに指定することもできます。/dfpオプションにパスを指定しない場合は，次のことに注意してください。
  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのDOCINFOキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのDOCINFOキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのDOCINFOキーで設定しているフォルダにあるファイル名を指定してください。

文書情報設定ファイルは，EUR Server Service稼働マシンに配置してください。
/dfp 文書情報設定ファイルのパス ※
（255バイト以内の文字列）

/dfオプションで指定した文書情報設定ファイルのパスを指定します。

文書情報設定ファイルを配置しているEUR Server Service稼働マシンのパスを指定してください。
/dialog ダイアログの表示モード
  • dialog：印刷先指定ダイアログを表示する（対話型印刷）
  • auto：直接印刷を実行する（自動印刷）
  • preview：プレビューウィンドウを表示する（対話型印刷プレビュー表示）
  • fullauto：直接印刷を実行する（全自動印刷）
  • pvonly：印刷を実行できないプレビューウィンドウを表示する（対話型印刷プレビュー表示限定）

クライアントPCで印刷する場合，ダイアログの表示モードを選択します。
/dialogオプションを省略した場合は，EUR Server - Adapterの環境設定ファイル（EURPMADP.ini）でOPTIONセクションのDISPPRINTDLGキーの設定値（0～4）が仮定されます。/dialogオプションと環境設定ファイルのDISPPRINTDLGキーをどちらも省略した場合は，0が仮定されます。/pオプションを指定している場合，かつ/dialogオプションに0または2を指定している場合は，1が仮定されます。

/dialogオプションは，/mオプションの指定値にprint，かつ/pmオプションの指定値にclまたはsplのどちらかを指定している場合に有効となります。
/dsf PDF仕分け定義ファイル名 ※
（255バイト以内の文字列）

PDF仕分け定義ファイル名を指定します。
/mオプションの指定値にpdfを指定する場合は，/dsfオプションまたは/pdfnオプションのどちらかを必ず指定してください。/dsfオプションと/pdfnオプションを同時に指定した場合は，/pdfnオプションは無視されます。
/mオプションの指定値にpdf以外を指定した場合は，/dsfオプションを指定しても無視されます。

/dsfオプションを指定している場合は，/foutdestオプションは無効となります。この場合，PDF仕分け定義ファイルに記述されている出力先ファイル名に従って，EUR Server Service稼働マシンにPDF形式ファイルを出力します。
PDF仕分け定義ファイルは，EUR Server - Adapter稼働マシンに配置してください。
/dsfp PDF仕分け定義ファイルのパス ※
（255バイト以内の文字列）

/dsfオプションで指定したPDF仕分け定義ファイルのパスを指定します。
指定されたファイルのパスは，/dsfオプションで指定するPDF仕分け定義ファイルのデフォルトの場所になります。

/dsfpオプションは，/mオプションの指定値にpdfを指定している場合に有効となります。
PDF仕分け定義ファイルを配置しているEUR Server - Adapter稼働マシンのパスを指定してください。
/enc パスワード暗号化鍵
（32バイト以内の文字列）

オーナーパスワードとユーザパスワードを暗号化した暗号化設定ファイルを使用して，暗号化したPDF形式ファイルを出力するときにパスワード暗号化鍵を指定します。
パスワード暗号化鍵に指定できる文字は，次のとおりです。
  • 半角文字
    0～9
  • 半角英字
    A～Z，a～z

/encオプションは，/mオプションの指定値にpdfを指定している場合に有効となります。
/ep 印刷終了ページ
（0～999,999）

印刷終了ページを指定します。
/epオプションを省略した場合，または指定した値が0の場合は，最終ページまで印刷されます。

/epオプションは，/mオプションの指定値にprint，pdf，epf，またはxlsxのどれかを指定している場合に有効となります。
/mfdオプションで複数様式を指定している場合は，/epオプションは無効となります。
制御情報付データファイル，または/rfオプションで複数の帳票ファイルを指定している場合は，/epオプションは無効となります。
/epfn EPF形式ファイル名 ※
（255バイト以内の文字列）

入力または出力するEFP形式ファイル名を指定します。
EPF形式ファイルの拡張子は，*.epfです。EPF形式ファイル名は，拡張子を含めて指定してください。ただし，出力したEPF形式ファイルを使用してヘルパクライアント印刷するときは，次に示す拡張子でEPF形式ファイル名を指定してください。
  • EPF形式ファイルをプレビューする場合：*.epf
  • EPF形式ファイルをプリンタ印刷する場合：*.epp
/mオプションの指定値にepfを指定する場合は，/epfnオプションを必ず指定してください。指定を省略した場合は，eurpmcコマンドでエラーになります。/mオプションの指定値にepf以外を指定した場合は，/epfnオプションを指定しても無視されます。
/epfnp EPF形式ファイルのパス ※
（255バイト以内の文字列）

/epfnオプションで指定したEPF形式ファイルのパスを指定します。
指定されたファイルのパスは，/epfnオプションで指定するEPF形式ファイルのデフォルトの場所になります。

/epfnpオプションは，/mオプションの指定値にepfを指定している場合に有効となります。
/eurn 出力EUR形式ファイル名 ※
（255バイト以内の文字列）

出力するEUR形式ファイル名を指定します。
/mオプションの指定値にeurを指定する場合は，/eurnオプションを必ず指定してください。指定を省略した場合は，eurpmcコマンドでエラーになります。/mオプションの指定値にeur以外を指定した場合は，/eurnオプションを指定しても無視されます。
/eurnp 出力EUR形式ファイルのパス ※
（255バイト以内の文字列）

/eurnオプションで指定したEUR形式ファイルのパスを指定します。
指定されたファイルのパスは，/eurnで指定するEUR形式ファイルのデフォルトの場所になります。

/eurnpオプションは，/mオプションの指定値にeurを指定している場合に有効となります。
/exp 実行可能印刷方式
  • sv：スプールサーバで印刷する
  • svcl：スプールサーバでの印刷，またはクライアントで印刷する
  • cl：クライアントで印刷する

実行可能印刷方式を指定します。
sv,svcl,およびcl以外の値を指定した場合は，svが仮定されます。

/expオプションは，/mオプションの指定値にprint，かつ/pmオプションの指定値にsplを指定している場合に有効となります。
/fc スプールデータの検索キーの分類
（80バイト以内の文字列を10個まで指定できる）

スプールデータの検索キーの分類を指定します。
指定する文字列には「,」を含めないでください。
/fcオプションを指定する場合は，検索キーの分類に対応する検索キーの値を必ず/fdオプションに指定してください。/fcオプションに指定する要素数と/fdオプションに指定する要素数は同じにしてください。指定する要素数が異なると，エラーになります。
検索キーを指定しない場合は，/fcオプションと/fdオプションは，どちらも指定しないでください。どちらか一つだけの指定している場合はエラーになります。

/fcオプションは，/mオプションの指定値にprint，かつ/pmオプションの指定値にsplを指定している場合に有効となります。
/fd スプールデータの検索キーの値
（80バイト以内の文字列を10個まで指定できる）

スプールデータの検索キーの値を指定します。
指定する文字列には「,」を含めないでください。
/fcオプションを指定する場合は，検索キーの分類に対応する検索キーの値を必ず/fdオプションに指定してください。/fcオプションに指定する要素数と/fdオプションに指定する要素数は同じにしてください。指定する要素数が異なると，エラーになります。

/fdオプションは，/mオプションの指定値にprint，かつ/pmオプションの指定値にsplを指定している場合に有効となります。
/foutdest PDF形式ファイルの出力先
  • adp：EUR Server - Adapter稼働マシンに出力する
  • pm：EUR Server Service稼働マシンに出力する

PDF形式ファイルの出力先を，EUR Server - Adapter稼働マシンにするか，またはEUR Server Service稼働マシンにするかのどちらかを指定します。
/foutdestオプションを省略した場合は，EUR Server - Adapterの環境設定ファイル（EURPMADP.ini）のOPTIONセクションのFILEOUTPUTDESTINATIONキーが仮定されます。
また，adp，pm以外の値を指定した場合は，adpが仮定されます。

/foutdestオプションは，/mオプションの指定値にpdfを指定している場合に有効となります。
/dsfオプション（PDF仕分け定義ファイル名）を指定している場合は，/foutdestオプションは無効となります。この場合，PDF仕分け定義ファイルに記述されている出力先ファイル名に従って，EUR Server Service稼働マシンにPDF形式ファイルを出力します。
/fp ページ番号の初期値
（1～999,999）

ページ番号の初期値を指定します。
/fpオプションを省略した場合は，1が仮定されます。

/fpオプションは，/mオプションの指定値にprint，pdf，またはepfのどれかを指定している場合，かつ/pnオプションを指定している場合に有効となります。
/mfdオプションで複数様式を指定している場合は，/fpオプションは無効となります。
/g スプールデータの取得可否
  • get：スプールデータの取得を許可する
  • noget：スプールデータの取得を許可しない

スプールデータの取得を許可するかどうかを指定します。
/gオプションを省略した場合は，getが仮定されます。

/gオプションは，/mオプションの指定値にprint，かつ/pmオプションの指定値にsplを指定している場合に有効となります。
/group 帳票振り分け定義の振り分けグループ名
（80バイト以内の文字列）

帳票振り分け定義の振り分けグループ名を指定します。
振り分けグループ名には「"」および「,」を含めないでください。

/groupオプションは，次に示すどちらかの指定がある場合に有効です。
  • /mオプションの指定値にprint，かつ/pmオプションの指定値にsv，かつ/pkオプションの指定値にepf，かつ/smオプションの指定値にgroupを指定している場合
  • /mオプションの指定値にprint，かつ/pmオプションの指定値にspl，かつ/smオプションの指定値にgroupを指定している場合
/ip ページ番号の開始番号の初期化
  • reset：初期化する
  • normal：初期化しない

改ページのキーが設定されている場合，そのキーがブレイクするごとにページ番号の開始番号を初期化するかどうかを指定します。
/ipオプションを省略した場合は，出力する帳票の属性に従います。帳票の属性の初期値は，normalが仮定されます。

/mfdオプションで複数様式を指定している場合は，/ipオプションは無効となります。
/jsc Acrobat JavaScript定義ファイル名 ※
（255バイト以内の文字列）

Acrobat Java Script定義ファイル名を指定します。
EUR Server Serviceの環境設定ファイル（EURPM.ini）で，OPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，Acrobat Java Script定義ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのSCRIPTCNTキーで設定しているフォルダに格納しておいてください。
OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。
パスは，/jscpオプションに指定することもできます。/jscpオプションにパスを指定しない場合は，次のことに注意してください。
  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのSCRIPTCNTキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのSCRIPTCNTキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのSCRIPTCNTキーで設定しているフォルダにあるファイル名を指定してください。

/jscオプションは，/mオプションの指定値にpdfを指定している場合に有効となります。
文書情報設定ファイルは，EUR Server Service稼働マシンに配置してください。
/jscp Acrobat JavaScript定義ファイルのパス ※
（255バイト以内の文字列）

/jscオプションで指定したAbrobat JavaScript定義ファイルのパスを指定します。

/jscpオプションは，/mオプションの指定値にpdfを指定している場合に有効となります。
Abrobat JavaScript定義ファイルを配置しているEUR Server Service稼働マシンのパスを指定してください。
/lm スプールデータの蓄積期限日
  • 日付で指定する場合
    YYYYMMDD形式
  • 日数で指定する場合
    +XXX形式

スプールデータの蓄積期限日を指定します。
蓄積期限日は，日付または日数で指定してください。
  • 日付で指定する場合
    ・年（西暦）は4桁，月と日は2桁で入力します。
    ・月，または日が1～9の場合は，ゼロ埋めをして入力します。
    ・指定できる値の上限は，20380118（2038年1月18日）です。
    ・過去の日付は指定できません。
    （指定例）20120521，20141008
  • 日数で指定する場合
    ・「XXX」には，蓄積実行時からの保管日数を指定します。
    ・指定できる値は000～999です。0を指定した場合は，翌日にスプールデータが削除されます。
    ・2038年1月18日を超える日数は指定できません。
    （指定例）+030，+999
/lmオプションの指定を省略した場合，蓄積期限日は蓄積を要求したEUR Server - Adapterの環境設定ファイル（EURPMADP.ini）のOPTIONセクションのSPOOLLIMITキーの指定に従います。

/lmオプションは，/mオプションの指定値にprint，かつ/pmオプションの指定値にsplを指定している場合に有効となります。
/lsp 印刷先サーバプリンタ名
（80バイト以内の文字列）

サーバのプリンタ名を指定します。
プリンタ名は，OS上のプリンタ名を指定してください。
プリンタ名には「"」および「,」を含めないでください。

/lspオプションは，次に示す指定がある場合に有効です。
  • /mオプションの指定値にprint，かつ/pmオプションの指定値にsv，かつ/smオプションの指定値にprinterを指定している場合
  • /mオプションの指定値にprint，かつ/pmオプションの指定値にspl，かつ/smオプションの指定値にprinterを指定している場合
  • /mオプションの指定値にprint，かつ/pmオプションの指定値にpm，かつ/smオプションの指定値にprinterを指定している場合
/lst 印刷先サーバプリンタのトレイ名
（80バイト以内の文字列）

サーバのプリンタのトレイ名を指定します。
トレイ名は，OS上のプリンタのトレイ名を指定してください。
トレイ名には「"」および「,」を含めないでください。
/lstオプションを省略した場合は，オプションで指定したプリンタのデフォルトのトレイから給紙されます。
/lstオプションに指定したトレイ名が，出力先のプリンタで使用できない場合は，デフォルトのトレイから給紙されます。

/lstオプションは，次に示す指定がある場合に有効です。
  • /mオプションの指定値にprint，かつ/pmオプションの指定値にsv，かつ/smオプションの指定値にprinterを指定している場合
  • /mオプションの指定値にprint，かつ/pmオプションの指定値にspl，かつ/smオプションの指定値にprinterを指定している場合
  • /mオプションの指定値にprint，かつ/pmオプションの指定値にpm，かつ/smオプションの指定値にprinterを指定している場合
/message | エラーメッセージを出力する
/mfd 複数様式情報定義ファイル名 ※
（255バイト以内の文字列）

複数様式情報定義ファイル名を指定します。
複数様式を指定する場合は，/mfdオプションを必ず指定してください。
/mfdオプションを省略した場合は，制御情報付データファイル，または/rfオプションで指定した複数の帳票ファイルが順に出力されます。

複数様式情報定義ファイルは，EUR Server Service稼働マシンに配置してください。
/mfdp 複数様式情報定義ファイルのパス ※1
（255バイト以内の文字列）

/mfdオプションで指定した複数様式情報定義ファイルのパスを指定します。

複数様式情報定義ファイルを配置しているEUR Server Service稼働マシンのパスを指定してください。
/nomessage | エラーメッセージを出力しない
/num 印刷部数の単位
  • sort：部単位
  • stack：ページ単位

印刷部数の単位を指定します。
/numオプションを省略した場合は，sortが仮定されます。

/numオプションは，/mオプションの指定値にprintまたはepfを指定している場合に有効となります。
/mfdオプションで複数様式を指定している場合は，/numオプションは無効となります。
制御情報付データファイル，または/rfオプションで複数の帳票ファイルを指定している場合は，/numオプションは無効となります。
/p 印刷先クライアントプリンタ名
（80バイト以内の文字列）

クライアントPCのプリンタ名をOS上のプリンタ名で指定します。
/pオプションを指定している場合，対話型印刷は使用できません。
プリンタ名には「"」および「,」を含めないでください。
/pオプションが指定されると，/dialogオプションは強制的に「auto（直接印刷を実行する（自動印刷））」を仮定します。

/prcオプションを同時に指定した場合は，/pオプションの指定を優先します。
/pオプションは，/mオプションの指定値にprint，かつ/pmオプションの指定値にclまたはsplのどちらかを指定している場合に有効となります。
/pdfn 出力PDF形式ファイル名 ※
（255バイト以内の文字列）

出力するPDF形式ファイル名を指定します。
/foutdestオプションの指定値にpm（PDF形式ファイルをEUR Server Service稼働マシンに出力する）を指定している場合で，EUR Server Serviceの環境設定ファイル（EURPM.ini）でOPTIONセクションのPATHMODEキーに0（通常モード）を設定しているときは，/pdfnオプションにはファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのPDFキーで設定しているフォルダに出力されます。
OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定しているときは，フルパス，相対パス，またはファイル名だけのどれかで指定してください。
パスは，/pdfnpオプションに指定することもできます。/pdfnpオプションにパスを指定しない場合のPDF形式ファイルの出力先を次に示します。
  • フルパスを指定する場合
    /pdfnオプションで指定したパスに出力されます。なお，環境設定ファイル（EURPM.ini）のPATHセクションのPDFキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPDFキーで設定しているフォルダを起点とし，そこから/pdfnオプションで指定したパスが出力されます。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPDFキーで設定しているフォルダに，/pdfnオプションで指定したファイル名で出力されます。
/mオプションの指定値にpdfを指定する場合は，/pdfnオプションまたは/dsfオプションのどちらかを必ず指定してください。指定を省略した場合は，eurpmcコマンドでエラーになります。/pdfnオプションと/dspオプションを同時に指定した場合は，/pdfnオプションは無視されます。
/mオプションの指定値にpdf以外を指定した場合は，/pdfnオプションを指定しても無視されます。

/dsfオプションでPDF仕分け定義ファイル名を指定している場合は，/pdfnオプションの指定を省略できます。
/pdfnp 出力PDF形式ファイルのパス ※
（255バイト以内の文字列）

/pdfnオプションで指定したPDF形式ファイルのパスを指定します。
指定されたファイルのパスは，/pdfnオプションで指定するPDF形式ファイルのデフォルトの場所になります。

/pdfnpオプションは，/mオプションの指定値にpdfを指定している場合に有効となります。ただし，次の場合は/pdfnpオプションを指定しても無視されます。
  • /mオプションの指定値にpdf以外を指定している場合
  • /foutdestオプションの指定値にpm（PDF形式ファイルをEUR Server Service稼働マシンに出力する）を指定している場合で，かつEUR Server Serviceの環境設定ファイル（EURPM.ini）でOPTIONセクションのPATHMODEキーに0（通常モード）を指定している場合
/pf ページ番号のフォーマット
（任意のフォーマット文字列）

ページ番号のフォーマットを指定します。
ページ番号を「*」，最終ページ番号を「$」で示して出力形式を指定します。
ページ番号および最終ページ番号を全角で表示したいときは全角の記号で，半角で表示したいときは半角の記号で指定します。

/pfオプションを指定しても，/pnオプションを省略した場合は無効となります。ただし，/mfdオプションをで複数様式を指定している場合は，/pfオプションを指定しても無視されます。
/pfオプションは，/mオプションの指定値にprint，pdf，またはepfのどれかを指定している場合に有効となります。
/pk スプールサーバ印刷方式の印刷モード
  • epf：EPF形式ファイルでの印刷
  • eur：EUR形式ファイルでの印刷
  •
  • スプールサーバ印刷方式の印刷モードを指定します。
  •
/pkオプションを省略した場合，または/pkオプションの指定値にepf，eur以外の値を指定した場合は，epfが仮定されます。
/pkオプションは，/mオプションの指定値にprint，かつ/pmオプションの指定値にsvを指定している場合に有効となります。
/pl 余白へのページ番号の印刷位置
  • topl：ページ番号を左上に出力する
  • topc：ページ番号を中央上に出力する
  • topr：ページ番号を右上に出力する
  • btml：ページ番号を左下に出力する
  • btmc：ページ番号を中央下に出力する
  • btmr：ページ番号を右下に出力する

余白へのページ番号の印刷位置を指定します。

/plオプションを指定しても，/pnオプションを省略した場合は無効となります。ただし，/mfdオプションで複数様式を指定している場合は，/plオプションを指定しても無視されます。
/plオプションは，/mオプションの指定値にprint，pdf，またはepfのどれかを指定している場合に有効となります。
/pm 出力メソッド（/mオプションの指定値print）の印刷方式
  • default：EUR Server - Adapterの環境設定ファイル（EURPMADP.ini）に設定したデフォルト印刷方式で印刷する
  • cl：クライアントPCで印刷する
  • spl：蓄積する
  • sv：スプールサーバで印刷する
  • pm：帳票サーバで直接印刷する
  • clds：クライアントPCへの配布印刷をする

出力メソッド（/mオプションの指定値print）の印刷方式を指定します。
/pmオプションの指定値にdefaultを指定する場合は，EUR Server - Adapterの環境設定ファイル（EURPMADP.ini）でOPTIONセクションのDEFAULTPRINTMODEキーに値を設定してください。
/pmオプションの指定値にdefault，cl，spl，sv，pm，clds以外を指定した場合は，defaultが仮定されます。
/pmオプションを省略した場合は，環境設定ファイル（EURPMADP.ini）でOPTIONセクションのPRINTMODEキーに指定されている値をデフォルトにします。
/mオプションの指定値にprintを指定する場合は，/pmオプションを必ず指定してください。/mオプションの指定値にprint以外を指定した場合は，/pmオプションを指定しても無視されます。
/pmip 接続する帳票サーバのIPアドレス
（255.255.255.255形式）

接続する帳票サーバのIPアドレスを指定します。
帳票サーバが複数台起動されている場合に，/pmipオプションを指定すると，接続する帳票サーバを振り分けられます。

/pmipオプションを省略した場合は，EUR Server - Adapterの環境設定ファイル（EURPMADP.ini）のIPADDRESSセクションのEURPMキーが仮定されます。EURPMキーの指定が省略されているとき，または値が指定されていないときは，デフォルト値（127.0.0.1）が仮定されます。
/pmpn 帳票サーバのポート番号
（1～65,535）

帳票サーバのポート番号を指定します。
EUR Server Serviceが複数起動されている場合に，/pmpnオプションを指定すると，接続するポートを振り分けられます。

/pmpnオプションを省略した場合は，EUR Server - Adapterの環境設定ファイル（EURPMADP.ini）のPORTセクションのEURPMキーが仮定されます。
/pmpnオプションを省略した場合，および環境設定ファイル（EURPMADP.ini）のPORTセクションのEURPMキーが指定されていない場合は，環境設定ファイルの省略時の値が仮定されます。
/pn 余白へのページ番号印刷の有無
  • on：余白へのページ番号を出力する
  • off：余白へのページ番号を出力しない

余白へのページ番号印刷を指定します。

/pnオプションを省略した場合は，offが仮定されます。ただし，/mfdオプションで複数様式を指定している場合は，/pnオプションを指定しても無視されます。
/pnオプションは，/mオプションの指定値にprint，pdf，またはepfのどれかを指定している場合に有効となります。
/po 用紙の向き
  • portrait：用紙の向きを縦にして印刷する
  • landscape：用紙の向きを横にして印刷する

用紙の向きを指定します。

/poオプションを省略した場合は，帳票を定義したときの情報に従います。
制御情報付データファイル，または/rfオプションで複数の帳票ファイルを指定している場合は，/poオプションの指定に関係なく，帳票を定義したときの情報に従います。
/mfdオプションで複数様式を指定している場合は，/poオプションを指定しても無視されます。
/poオプションは，/mオプションの指定値にprintまたはepfのどちらかを指定している場合に有効となります。
/prc プリンタクラス名
（80バイト以内の文字列）

プリンタクラス名を指定します。
プリンタクラス名には「"」および「,」を含めないでください。
プリンタクラス名に「EUR_DELIVERY_PRINT_OUTPUT_DEFAULT_PRINTER_CLASS_________________________________」は使用できません。
印刷方法ごとに指定するオプションを次に示します。
  • スプールサーバでの印刷
    /pmオプション：指定値sv
    /smオプション：指定値class
    /prcオプション：拠点プリンタクラス名
  • クライアントPCでの対話型印刷
    /pmオプション：指定値cl
    /dialogオプション：指定値dialog
    /prcオプション：帳票ジョブ名，およびEPF形式ファイルの属性情報に設定するプリンタクラス名
  • クライアントPCでの自動印刷
    /pmオプション：指定値cl
    /dialogオプション：指定値auto
    /prcオプション：クライアントプリンタクラス名
  • クライアントPCでの対話型印刷プレビュー表示
    /pmオプション：指定値cl
    /dialogオプション：指定値preview
    /prcオプション：帳票ジョブ名，およびEPF形式ファイルの属性情報に設定するプリンタクラス名
  • クライアントPCでの全自動印刷
    /pmオプション：指定値cl
    /dialogオプション：指定値fullauto
    /prcオプション：クライアントプリンタクラス名
  • クライアントPCでの対話型印刷プレビュー表示限定
    /pmオプション：指定値cl
    /dialogオプション：指定値pvonly
    /prcオプション：EPF形式ファイルの属性情報に設定するプリンタクラス名
  • 帳票サーバでの印刷
    /pmオプション：指定値pm
    /smオプション：指定値class
    /prcオプション：帳票サーバプリンタクラス名
  • 蓄積（プリンタクラス名指定）
    /pmオプション：指定値spl
    /smオプション：指定値class
    /prcオプション：拠点プリンタクラス名，または蓄積クライアント印刷方式のプリンタクラス名
  • 蓄積（OS上のプリンタ名指定）
    /pmオプション：指定値spl
    /smオプション：指定値printer
    /prcオプション：EPF形式ファイルの属性情報に設定するプリンタクラス名
  • 蓄積（帳票名による自動振り分け）
    /pmオプション：指定値spl
    /smオプション：指定値group
    /prcオプション：EPF形式ファイルの属性情報に設定するプリンタクラス名

「クライアントPCでの自動印刷」と「蓄積クライアント印刷」の場合，/pオプションを同時に指定したときは，/pオプションの指定を優先します。

EPF形式ファイルを出力する場合は，/prcオプションにEPF形式ファイルの属性情報に設定するプリンタクラス名を指定します。
EPF形式ファイルを出力する場合に，/prcオプションの指定を省略したときは，EPF形式ファイルのプリンタクラス名情報は未設定となります。

クライアントPCへの配布印刷では，指定できません。
/prdatef 印刷日時出力定義ファイル名 ※
（255バイト以内の文字列）

印刷日時出力定義ファイル名を指定します。

EUR Server Serviceの環境設定ファイル（EURPM.ini）で，OPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，印刷日時出力定義ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのPRINTDATEキーで設定しているフォルダに格納しておいてください。
OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。
パスは，/prdatefpオプションに指定することもできます。/prdatefpオプションにパスを指定しない場合は，次のことに注意してください。
  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPRINTDATEキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPRINTDATEキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPRINTDATEキーで設定しているフォルダにあるファイル名を指定してください。

/prdatefオプションは，/mオプションの指定値にprintまたはepfのどちらかを指定している場合に有効となります。
印刷日時出力定義ファイルは，EUR Server Service稼働マシンに配置してください。
/prdatefp 印刷日時出力定義ファイルのパス ※
（255バイト以内の文字列）

/prdatefオプションで指定した印刷日時出力定義ファイルのパスを指定します。
指定されたファイルのパスは，/prdatefオプションで指定する印刷日時出力定義ファイルのデフォルトの場所になります。

/prdatefpオプションは，/mオプションの指定値にprintまたはepfのどちらかを指定している場合に有効となります。
印刷日時出力定義ファイルを配置しているEUR Server Service稼働マシンのパスを指定してください。
/prh 蓄積後に続けて印刷するかどうか
  • hold：続けて印刷しない（印刷保留）
  • sv：続けてスプールサーバで印刷する
  • cl：続けてクライアントPCで印刷する

蓄積印刷方式で，蓄積後に続けて印刷するかどうかを選択します。
/prhオプションを省略した場合，または/prhオプションの指定値にhold，sv，cl以外の値を指定した場合は，/racオプションおよび/radオプションの指定の有無によって次の値が仮定されます。
  • /racオプションおよび/radオプションの指定がある場合
    holdが仮定されます。
  • /racオプションおよび/radオプションの指定がない場合
    svが仮定されます。

/prhオプションは，/mオプションの指定値にprint，かつ/pmオプションの指定値にsplを指定している場合に有効となります。
/psenvf 環境設定ファイル名 ※
（255バイト以内の文字列）

EUR Print Serviceの動作環境を印刷ジョブごとに変更する場合に，EUR Server Serviceの環境設定ファイル（EURPS_ENV）名を指定します。
EUR Server Serviceの環境設定ファイル（EURPM.ini）で，OPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，環境設定ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのPSENVキーで設定しているフォルダに格納しておいてください。
OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。
パスは，/psenvfpオプションに指定することもできます。/psenvfpオプションにパスを指定しない場合は，次のことに注意してください。
  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPSENVキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPSENVキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPSENVキーで設定しているフォルダにあるファイル名を指定してください。

/psenvfオプションは，/mオプションの指定値にprint，pdf，epf，eurまたはxlsxのどれかを指定している場合に有効となります。
環境設定ファイル（EURPS_ENV）は，EUR Server Service稼働マシンに配置してください。
/psenvfp 環境設定ファイルのパス ※
（255バイト以内の文字列）

/psenvfオプションで指定したEUR Server Serviceの環境設定ファイル（EURPS_ENV）のパスを指定します。
指定されたファイルのパスは，/psenvfオプションで指定する環境設定ファイル（EURPS_ENV）のデフォルトの場所になります。

/psenvfpオプションは，/mオプションの指定値にprint，pdf，epf，eurまたはxlsxのどれかを指定している場合に有効となります。
環境設定ファイル（EURPS_ENV）を配置しているEUR Server Service稼働マシンのパスを指定してください。
/pvp ビューアプレファレンス定義ファイル名 ※
（255バイト以内の文字列）

ビューアプレファレンス定義ファイル名を指定します。
EUR Server Serviceの環境設定ファイル（EURPM.ini）で，OPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，ビューアプレファレンス定義ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのPREFERENCEキーで設定しているフォルダに格納しておいてください。
OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。
パスは，/pvppオプションに指定することもできます。/pvppオプションにパスを指定しない場合は，次のことに注意してください。
  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPREFERENCEキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPREFERENCEキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPREFERENCEキーで設定しているフォルダにあるファイル名を指定してください。

/pvpオプションは，/mオプションの指定値にpdfを指定している場合に有効となります。
ビューアプレファレンス定義ファイルは，EUR Server Service稼働マシンに配置してください。
/pvpp ビューアプレファレンス定義ファイルのパス ※
（255バイト以内の文字列）

/pvpオプションで指定したビューアプレファレンス定義ファイルのパスを指定します。
指定されたファイルのパスは，/pvpオプションで指定するビューアプレファレンス定義ファイルのデフォルトの場所になります。

/pvppオプションは，/mオプションの指定値にpdfを指定している場合に有効となります。
ビューアプレファレンス定義ファイルを配置しているEUR Server Service稼働マシンのパスを指定してください。
/rac スプールデータの宛先キーの分類
（1～80バイトの文字列）

スプールデータの宛先キーの分類を指定します。
指定する文字列には「"」，「,」および制御コード（0x00～0x1F，0x7F～0x9F）を含めないでください。
/racオプションを指定する場合は，/radオプションも必ず指定してください。/radオプションが指定されていない場合はeurpmcコマンドでエラーになります。

/racオプションは，/mオプションの指定値にprint，かつ/pmオプションの指定値にsplを指定している場合に有効となります。
/rad スプールデータの宛先キーの値
（1～80バイトの文字列）

スプールデータの宛先キーの値を指定します。
指定する文字列には「"」，「,」および制御コード（0x00～0x1F，0x7F～0x9F）を含めないでください。
/radオプションを指定する場合は，/racオプションも必ず指定してください。/racオプションが指定されていない場合はeurpmcコマンドでエラーになります。

/radオプションは，/mオプションの指定値にprint，かつ/pmオプションの指定値にsplを指定している場合に有効となります。
/rf 帳票ファイル名 ※
（255バイト以内の文字列）

帳票ファイル名（*.fms）を指定します。
複数のファイルを指定できます。複数のファイルを指定する場合は，コンマ（,）で区切ってください。
事前定義型のファイル監視サービスで使用する起動パラメタファイルの場合は，/rfオプションを必ず指定してください。
EUR Server Serviceの環境設定ファイル（EURPM.ini）で，OPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，帳票ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのFORMキーで設定しているフォルダに格納しておいてください。
OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。
パスは，/rfpオプションに指定することもできます。/rfpオプションにパスを指定しない場合は，次のことに注意してください。
  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのFORMキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのFORMキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのFORMキーで設定しているフォルダにあるファイル名を指定してください。

BSP-RM連携コマンド（eursmprコマンド）で使用する起動パラメタファイルの場合は，/rfオプションを指定してもeurpmcコマンドでは無視されます。
帳票ファイルは，EUR Server Service稼働マシンに配置してください。
/rfp 帳票ファイルのパス ※
（255バイト以内の文字列）

/rfオプションで指定した帳票ファイルのパスを指定します。
UNIX／Linux環境のEUR Server Service稼働マシンのパスを指定する場合，パスのフォルダ名の最終文字が「\」のときは，パスの終端に「/」を付加して指定してください。

帳票ファイルを配置しているEUR Server Service稼働マシンのパスを指定してください。
/rif 置き換え表管理情報ファイル名 ※
（255バイト以内の文字列）

置き換え表管理情報ファイル名を指定します。
EUR Server Serviceの環境設定ファイル（EURPM.ini）で，OPTIONセクションのPATHMODEキーに0（通常モード）を設定している場合，置き換え表管理情報ファイル名は，ファイル名だけを指定してください。このとき，指定するファイルは，PATHセクションのREPLACEITEMキーで設定しているフォルダに格納しておいてください。
OPTIONセクションのPATHMODEキーに1（フルパスモード）を設定している場合は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。
パスは，/rifpオプションに指定することもできます。/rfpオプションにパスを指定しない場合は，次のことに注意してください。
  • フルパスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのREPLACEITEMキーには指定が要りません。
  • 相対パスを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのREPLACEITEMキーで設定している起点フォルダ下にあるファイル名を指定してください。
  • ファイル名だけを指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのREPLACEITEMキーで設定しているフォルダにあるファイル名を指定してください。

/rifオプションは，次に示すどれかの指定がある場合に有効です。
  • /mオプションの指定値にprint，かつ/pmオプションの指定値にsv，かつ/pkオプションの指定値にepfを指定している場合
  • /mオプションの指定値にprint，かつ/pmオプションの指定値にclを指定している場合
  • /mオプションの指定値にprint，かつ/pmオプションの指定値にsplを指定している場合
  • /mオプションの指定値にpdf，epf，eur，またはxlsxのどれかが指定されている場合
置き換え表管理情報ファイルは，EUR Server Service稼働マシンに配置してください。
/rifp 置き換え表管理情報ファイルのパス ※
（255バイト以内の文字列）

/rifオプションで指定した置き換え表管理情報ファイルのパスを指定します。

/rifpオプションは，次に示すどれかの指定がある場合に有効です。
  • /mオプションの指定値にprint，かつ/pmオプションの指定値にsv，かつ/pkオプションの指定値にepfを指定している場合
  • /mオプションの指定値にprint，かつ/pmオプションの指定値にclを指定している場合
  • /mオプションの指定値にprint，かつ/pmオプションの指定値にsplを指定している場合
  • /mオプションの指定値にpdf，epf，eur，またはxlsxのどれかが指定されている場合
置き換え表管理情報ファイルを配置しているEUR Server Service稼働マシンのパスを指定してください。
/sf スプールデータに格納する印刷データ（EPF形式ファイル）のファイル名 ※1
（255バイト以内の文字列）

スプールデータに格納するファイルのファイル名を指定します。
「%N」を指定すると，00000001から始まる8桁の通し番号を設定できます。
/sfオプションを省略した場合は，自動的にファイル名が生成されます。自動的に生成されるファイル名は「ジョブID.epf」です。
複数のスプールデータに同一ファイル名が指定されている場合，スプールデータ取得時に同一パスで取得されると，ファイルが上書きされます。同一パスで取得する可能性のあるファイルは，別の格納ファイル名に指定することをお勧めします。

/sfオプションは，/mオプションの指定値にprint，かつ/pmオプションの指定値にsplを指定している場合に有効となります。

「ジョブID」の形式を次に示します。
E＋ESFID＋処理実行日時＋通番フォルダ番号＋通し番号
ESFID（2桁）：EURPMLS.iniのキーワードESFIDに指定された値（0～99）
処理実行日時（17桁）：YYYYMMDDhhmmssmmm
通番フォルダ番号（7桁）：0000001～2000000
通し番号（9桁）：000000001～999999999
通番フォルダ番号が2000000を超えた場合は，エラー（KEEY430-S）になります。
通し番号が999999999を超えた場合は，000000003に戻ります。
/sm プリンタの指定方法
  • class：プリンタクラス名を指定する
  • printer：OS上のプリンタ名を指定する
  • group：帳票名による自動振り分けを行う

プリンタの指定方法を選択します。
/smオプションを省略した場合，またはclass，printer，group以外の値を指定した場合は，classが仮定されます。

/smオプションは，次に示すどれかの指定がある場合に有効です。
  • /mオプションの指定値にprint，かつ/pmオプションの指定値にsvを指定している場合
  • /mオプションの指定値にprint，かつ/pmオプションの指定値にsplを指定している場合
  • /mオプションの指定値にprint，かつ/pmオプションの指定値にpmを指定している場合
なお，/mオプションの指定値にprint，かつ/pmオプションの指定値にpmを指定している場合は，/smオプションの指定値にgroupを指定するとエラーになります。
/sp 印刷開始ページ
（0～999,999）

印刷開始ページを指定します。
/spオプションを省略した場合，または指定した値が0の場合は，1ページから印刷されます。

/spオプションは，/mオプションの指定値にprint，pdf，epf，またはxlsxのどれかを指定している場合に有効となります。
/mfdオプションで複数様式を指定している場合は，/spオプションは無効となります。
制御情報付データファイル，または/rfオプションで複数の帳票ファイルを指定している場合は，/spオプションは無効となります。
/split 帳票を分割または仕分けして蓄積するかどうか
  • default：EUR Server Serviceの環境設定ファイル（EURPM.ini）の設定に従う
  • no：分割または仕分けしない
  • key：仕分けする
  • page：分割する

帳票を蓄積する場合，帳票を分割または仕分けするかどうかを指定します。
/splitオプションを省略した場合は，defaultが仮定されます。

/splitオプションは，/mオプションの指定値にprint，/pmオプションの指定値にsplを指定している場合に有効となります。
/splitf 分割定義ファイル名または仕分け定義ファイル名 ※
（255バイト以内の文字列）

帳票を分割または仕分けして蓄積する場合に，分割定義ファイルまたは仕分け定義ファイルのファイル名を指定します。

/splitfオプションは，/mオプションの指定値にprint，/pmオプションの指定値にsplを指定している場合で，かつ次のどちらかの条件に当てはまるときに有効となります。
  • /splitオプションの指定値がpageまたはkeyのとき
  • /splitオプションの指定値がdefault，かつEUR Server Serviceの環境設定ファイルのOPTIONセクションのSPLITMODEキーにPAGE（分割）またはKEY（仕分け）を指定しているとき
分割定義ファイルまたは仕分け定義ファイルは，EUR Server - Adapter稼働マシンに配置してください。
/splitfp 分割定義ファイルまたは仕分け定義ファイルのパス ※
（255バイト以内の文字列）

/splitfオプションで指定した，分割定義ファイルまたは仕分け定義ファイルのパスを指定します。
指定されたファイルのパスは，/splitfオプションで指定する分割定義ファイルまたは仕分け定義ファイルのデフォルトの場所になります。

/splitfpオプションは，/mオプションの指定値にprint，/pmオプションの指定値にsplを指定している場合で，かつ次のどちらかの条件に当てはまるときに有効となります。
  • /splitオプションの指定値がpageまたはkeyのとき
  • /splitオプションの指定値がdefault，かつEUR Server Serviceの環境設定ファイルのOPTIONセクションのSPLITMODEキーにPAGE（分割）またはKEY（仕分け）を指定しているとき
分割定義ファイルまたは仕分け定義ファイルを配置しているEUR Server - Adapter稼働マシンのパスを指定してください。
/sptl スプールタイトル
（255バイト以内の文字列）

スプールタイトルを指定します。
スプールタイトルには「"」および「,」を含めないでください。
/sptlオプションは，次に示す指定がある場合に有効です。
  • /mオプションの指定値にprint，かつ/pmオプションの指定値にcl，spl，pm，またはsvのどれかを指定している場合
  • /mオプションの指定値にepfまたはeurを指定している場合
/sptlオプションを省略した場合は，スプールタイトル情報は未設定となります。スプールタイトル情報が未設定の場合，印刷時のスプールタイトルに出力される内容は次のとおりです。
  • /mオプションの指定値にprintまたはepfを指定している場合
    文書情報設定ファイル（/dfオプション）でTITLEキーを設定しているときは，TITLEキーの指定値が出力されます。TITLEキーを設定していないときは，「HITACHI Report - 帳票ファイル名」が出力されます。
  • /mオプションの指定値にeurを指定している場合
    文書情報設定ファイル（/dfオプション）でTITLEキーを設定しているときは，TITLEキーの指定値が出力されます。TITLEキーを設定していないときは，次に示す表示形式で出力されます。
    ・単一様式帳票の場合
      「HITACHI Report - EUR形式ファイル名（拡張子なし）」
    ・複数の帳票セットを指定した帳票，または複数様式を指定した帳票の場合
      「EUR形式ファイル名（拡張子なし）」
/srm スプールサーバの指定方法
  • dest：出力先名を指定する
  • sv：スプールサーバIPアドレスを指定する

スプールサーバの指定方法を選択します。
/srmオプションを省略した場合，またはdest，sv以外の値を指定した場合は，destが仮定されます。

/srmオプションは，/mオプションの指定値がprint，かつ/pmオプションの指定値がsvまたはsplの場合に有効となります。
/svr スプールサーバのIPアドレス
（255.255.255.255形式）

スプールサーバのIPアドレスを「255.255.255.255」形式で指定します。
/svrオプションを省略した場合は，デフォルト値（127.0.0.1）が仮定されます。

/svrオプションは，/mオプションの指定値がprint，かつ/pmオプションの指定値がsvまたはspl，かつ/srmオプションの指定値がsvの場合に有効となります。
/t 印刷先クライアントプリンタのトレイ名
（80バイト以内の文字列）

クライアントプリンタのトレイ名を指定します。クライアントプリンタは，OS上のプリンタを指します。
トレイ名には「"」および「,」を含めないでください。
/tオプションを指定する場合は，/pオプションを必ず指定してください。
/tオプションに指定したトレイ名が，/pオプションで指定したプリンタで使用できない場合は，/pオプションで指定したプリンタのデフォルトのトレイから給紙されます。
/tオプションを省略した場合は，/pオプションで指定したプリンタのデフォルトのトレイから給紙されます。

/tオプションは，/mオプションの指定値がprint，かつ/pmオプションの指定値がclまたはsplの場合に有効となります。
/usr, ユーザ定義データファイル名 ※
（255バイト以内の文字列）

ユーザ定義データファイル名または可変記号値定義ファイル名を指定します。
複数のファイルを指定できます。複数のファイルを指定する場合は，コンマ（,）で区切ってください。指定するファイル名は，/rfオプションで指定したファイル名と同じ数を指定してください。
/usrオプションは，事前定義型のファイル監視サービスで使用する起動パラメタファイルの場合に指定できます。

BSP-RM連携コマンド（eursmprコマンド）で使用する起動パラメタファイルの場合は，/usrオプションを指定してもeurpmcコマンドでは無視されます。
ユーザ定義データファイルは，EUR Server - Adapter稼働マシンに配置してください。
/usrp ユーザ定義データファイルのパス ※
（255バイト以内の文字列）

/usrオプションで指定した，ユーザ定義データファイルまたは可変記号値定義ファイルのパスを指定します。

ユーザ定義データファイルまたは可変記号値定義ファイルを配置しているEUR Server - Adapter稼働マシンのパスを指定してください。
/xlfn 出力Excel形式ファイル名 ※
（255バイト以内の文字列）

出力するExcel形式ファイル名を指定します。
/mオプションの指定値にxlsxを指定する場合は，/xlfnオプションを必ず指定してください。指定を省略した場合は，eurpmcコマンドでエラーになります。/mオプションの指定値にxlsx以外を指定した場合は，/xlfnオプションを指定しても無視されます。
/xlfnp 出力Excel形式ファイルのパス ※
（255バイト以内の文字列）

/xlfnオプションで指定したExcel形式ファイルのパスを指定します。
指定されたファイルのパスは，/xlfnオプションで指定する出力Excel形式ファイルのデフォルトの場所になります。

/xlfnオプションは，/mオプションの指定値がxlsの場合に有効となります。
/xp スプールデータの上限印刷回数
  • -1：無限に印刷できる
  • 0：印刷を禁止する
  • 1～65,536：印刷回数の上限を指定する

スプールデータの上限印刷回数を指定します。
/xpオプションを省略した場合，または1～65,536以外の値を指定した場合は，-1が仮定されます。

/xpオプションは，/mオプションの指定値がprint，かつ/pmオプションの指定値がsplの場合に有効となります。
注※
ファイル名，およびファイルのパスを指定するときの規則，および注意については，「付録A.1　ファイル名，およびファイルのパスを指定するときの注意」を参照してください。

(4)　注意事項

  • 同一のオプションが複数定義されている場合は，最後に定義されているものが有効となります。


EUR Web Plug-In情報ファイル

12.11　EUR Web Plug-In情報ファイル

＜この節の構成＞
(1)　概要
(2)　形式

(1)　概要

EUR Web Plug-In情報ファイルは，ActiveX起動部品またはJava起動部品でEUR Web Plug-InのクラスIDおよびバージョン情報を取得するときに参照するファイルです。

EUR Web Plug-In（印刷用）のEURPMPrintAX.infと，EUR Web Plug-In（プレビュー用）のEURPMPreViewAX.infの2種類のファイルがあります。

ActiveX起動部品またはJava起動部品で指定したメソッドによって，EUR Web Plug-In情報ファイルに定義された次の情報を取得します。

表12-11　ActiveX起動部品で指定したメソッドによって取得する情報

メソッド名 | 取得する情報
GetPrintAXVersionメソッド | EUR Web Plug-In（印刷用）のバージョン
GetPrintAXClassIDメソッド | EUR Web Plug-In（印刷用）のクラスID
GetPreviewAXVersionメソッド | EUR Web Plug-In（プレビュー用）のバージョン
GetPreviewAXClassIDメソッド | EUR Web Plug-In（プレビュー用）のクラスID

表12-12　Java起動部品のEURPMAdapterForJavaクラスで指定したメソッドによって取得する情報

メソッド名 | 取得する情報
getPrintAXVersionメソッド | EUR Web Plug-In（印刷用）のバージョン
getPrintAXClassIDメソッド | EUR Web Plug-In（印刷用）のクラスID
getPreviewAXVersionメソッド | EUR Web Plug-In（プレビュー用）のバージョン
getPreviewAXClassIDメソッド | EUR Web Plug-In（プレビュー用）のクラスID

各メソッドの詳細については，「6.3　ActiveX起動部品のメソッド仕様」および「8.4　EURPMAdapterForJavaクラスのメソッド仕様」を参照してください。

(2)　形式

EUR Web Plug-In情報ファイルの形式を次に示します。

[CABINFO]
CLASSID=EUR Web Plug-InのクラスID
VERSION=EUR Web Plug-Inのバージョン

CABINFOセクションのCLASSIDキー，およびVERSIONキーの値は編集できません。製品バージョンに応じたEUR Web Plug-In情報ファイルを使用してください。


運用に応じて格納先を決めるファイル

13.　運用に応じて格納先を決めるファイル

この章では，EUR サーバ帳票出力機能で扱えるファイルのうち，運用に応じて格納先を決めるファイルの種類と形式について説明します。

＜この章の構成＞
13.1　運用に応じて格納先を決めるファイルの一覧
13.2　分割定義ファイル
13.3　仕分け定義ファイル


運用に応じて格納先を決めるファイルの一覧

13.1　運用に応じて格納先を決めるファイルの一覧

運用に応じて格納先を決めるファイルの概要を次の表に示します。

表13-1　運用に応じて格納先を決めるファイルの一覧

ファイル名 | 説明
分割定義ファイル | 帳票を分割するときのページ数や分割後のEPF形式ファイルの印刷先などを定義するファイルです。
仕分け定義ファイル | 帳票を仕分けするときのキーワードやキーワードに対応する印刷先などを定義するファイルです。


分割定義ファイル

13.2　分割定義ファイル

＜この節の構成＞
(1)　概要
(2)　形式
(3)　キーワード
(4)　サンプルの内容

(1)　概要

分割定義ファイルは，帳票を分割して蓄積するときの分割ページ数や分割後の印刷先などを定義するファイルです。

(2)　形式

分割定義ファイルの形式を次に示します。

[SPLIT]
キー=値
  ：

(3)　キーワード

分割定義ファイルのキーワードを次の表に示します。

表13-2　分割定義ファイルのキーワード

セクション キー 指定できる値 指定 省略値 説明
SPLIT PAGENUMBER 1～999,999 必須 － 分割ページ数を指定します。
PRINTDESTNUMBER 1～1,024 必須 － 印刷先の数を指定します。
PRINTDESTn※1 文字列（255バイト） 必須 － 印刷先を指定します。
なお，印刷先は印刷先定義ファイルで定義します。印刷先定義ファイルの詳細については，「14.4　印刷先定義ファイル」を参照してください。
DISTRIBUTEMETHOD
  • PAGE
  • ORDER
 任意 PAGE 印刷先が複数ある場合の配布方法を指定します。
  • PAGE
    ページ方式※2で配布します。
  • ORDER
    順次方式※3で配布します。
（凡例）
－：省略値はありません。

注※1
nの範囲は，「1～印刷先の数（PRINTDESTNUMBERキーの値）」です。
注※2
各印刷先で帳票のページ番号が連続するように，EPF形式ファイルを配布する方法です。ページ方式で配布するときの配布イメージを次の図に示します。

注※3
分割された順にEPF形式ファイルを配布する方法です。
順次方式で配布するときの配布イメージを次の図に示します。

(4)　サンプルの内容

分割定義ファイル（PMPageSplit.txt）の指定例を示します。

このサンプルでは，指定した帳票を500ページごとに分割し，印刷先「TOKYO_RS_SPOOL_UserA」と「TOKYO_RS_SPOOL_UserB」にページ配布方式で配布することを想定しています。

サンプルの内容を次に示します。

[SPLIT]
PAGENUMBER=500
PRINTDESTNUMBER=2
DISTRIBUTEMETHOD=PAGE
PRINTDEST1="TOKYO_RS_SPOOL_UserA"
PRINTDEST2="TOKYO_RS_SPOOL_UserB"


仕分け定義ファイル

13.3　仕分け定義ファイル

＜この節の構成＞
(1)　概要
(2)　形式
(3)　キーワード
(4)　サンプルの内容

(1)　概要

仕分け定義ファイルは，帳票をデータで仕分けして蓄積するときの仕分けキーフィールドや仕分け後の印刷先などを定義するファイルです。

(2)　形式

仕分け定義ファイルの形式を次に示します。

(3)　キーワード

仕分け定義ファイルのキーワードを次に示します。

(a)　KEYFIELD行

必ず1行目に指定してください。KEYFIELD行の指定を省略したり，KEYFIELD行を複数指定したりした場合はエラーになります。

KEYFIELD
KEYFIELDを指定します。大文字と小文字は区別しません。
キー数
仕分けするキーの数を指定します。
1以上の整数で指定してください。
仕分けキーフィールド名
仕分けするマッピングデータのフィールド名を指定します。
「キー数」で指定した数だけコンマ（,）で区切って指定してください。ただし，同じフィールドを複数指定できません。
(b)　UNDEFDEST行

UNDEFDEST行は，DATA行で指定したキーワードと一致しないページ（不一致ページ），および総集計ページの印刷先を指定する場合に指定します。指定する場合は，必ず2行目に指定してください。UNDEFDEST行の指定を省略した場合は，不一致ページおよび総集計ページを出力しません。

UNDEFDEST
UNDEFDESTを指定します。大文字と小文字は区別しません。
印刷先名
不一致ページおよび総集計ページの印刷先を指定します。
なお，印刷先は印刷先定義ファイルで定義します。印刷先定義ファイルの詳細については，「14.4　印刷先定義ファイル」を参照してください。
(c)　DATA行

DATA行には，印刷先とキーワードの組み合わせを指定します。必ず指定してください。

DATA
DATAを指定します。大文字と小文字は区別しません。
印刷先名
「仕分けキーフィールド名のデータ」で指定したデータと一致するページの印刷先を指定します。
なお，印刷先は印刷先定義ファイルで定義します。印刷先定義ファイルの詳細については，「14.4　印刷先定義ファイル」を参照してください。
仕分けキーフィールドのデータ
キーワードを指定します。
KEYFIELD行の「仕分けキーフィールド名」に対応するデータを，「キー数」で指定した数だけコンマ（,）で区切って指定してください。
なお，指定するときには次の点に注意してください。
  • データに「"」が含まれている場合は，「"」を二つ続けて記述し，データの両端を「"」で囲んで指定してください。
    「E"UR」とする場合は，「"E""UR"」と指定します。
  • データに区切り文字が含まれている場合は，データの両端を「"」で囲んで指定してください。
    「,」が区切り文字の場合，「EU,R」とするときは，「"EU,R"」と指定します。

(4)　サンプルの内容

サンプル仕分け定義ファイル（PMDistribute.txt）の指定例を示します。

このサンプルでは，次のルールで帳票を仕分けして出力することを想定しています。

  • マッピングデータファイルの「Office」フィールドの値が「HeadOffice」のページは，印刷先「TOKYO_RS_PRINT」に出力する。
  • マッピングデータファイルの「Office」フィールドの値が「BranchOsaka」のページは，印刷先「OSAKA_RS_PRINT」に出力する。
  • 上記のどちらにも当てはまらないページは，印刷先「OSAKA_CL_PRINT」に出力する。

サンプルの内容を次に示します。

KEYFIELD,1,"Office"
UNDEFDEST, "OSAKA_CL_PRINT"
DATA,"TOKYO_RS_PRINT","HeadOffice"
DATA,"OSAKA_RS_PRINT","BranchOsaka"


構成定義ファイル

14.　構成定義ファイル

この章では，EUR Server Serviceの構成定義ファイルについて説明します。なお，構成定義ファイルを更新した場合は，EUR Server Serviceを再起動してください。

＜この章の構成＞
14.1　構成定義ファイルの一覧
14.2　出力先定義ファイル
14.3　帳票サーバプリンタクラス定義ファイル
14.4　印刷先定義ファイル
14.5　拠点プリンタクラス定義ファイル
14.6　帳票振り分け定義ファイル
14.7　ユーザ管理ファイル
14.8　クライアントプリンタクラス定義ファイル
14.9　宛先定義ファイル
14.10　監視定義ファイル


構成定義ファイルの一覧

14.1　構成定義ファイルの一覧

構成定義ファイルの概要を次の表に示します。

表14-1　構成定義ファイルの一覧

ファイル名 | 説明
出力先定義ファイル | スプールサーバの出力先名と，IPアドレスの対応を定義するためのファイルです。
帳票サーバプリンタクラス定義ファイル | 帳票サーバによる直接印刷方式で，プリンタクラスを定義するためのファイルです。
印刷先定義ファイル | 蓄積時に指定する帳票の蓄積先やスプールデータの格納ファイル名などの情報を，印刷先として定義するためのファイルです。
拠点プリンタクラス定義ファイル | スプールサーバのプリンタとトレイの組み合わせを定義するためのファイルです。
帳票振り分け定義ファイル | 帳票名ごとにプリンタを定義したファイルです。
ユーザ管理ファイル | ユーザの認証情報，およびスプールデータへのアクセス制限情報が定義されたファイルです。
クライアントプリンタクラス定義ファイル | クライアントPCのプリンタとトレイの組み合わせを定義するためのファイルです。
宛先定義ファイル | 配送印刷を使用するユーザと，対応する宛先を定義するためのファイルです。
監視定義ファイル | 事前定義型で帳票自動出力機能を使用する場合に，着信監視するマッピングデータファイルに対応する起動パラメタファイルを定義するためのファイルです。


出力先定義ファイル

14.2　出力先定義ファイル

＜この節の構成＞
(1)　概要
(2)　格納先
(3)　形式
(4)　サンプルの内容

(1)　概要

出力先定義ファイル（Destination.conf）は，スプールサーバの出力先名と，IPアドレスの対応を定義するためのファイルです。帳票を出力するスプールサーバを，出力先名で指定するときに使用します。

なお，EURのインストール時には，次に示すデフォルト値が記述されている定義ファイルがインストールされます。

,127.0.0.1,DEFAULT_Server

この設定値をそのまま使用する場合，EUR Server Serviceで設定を変更する必要はありません。格納先を次に示します。

Windows環境の場合
  • インストール先フォルダ\Server\Confフォルダ
UNIX／Linux環境の場合
  • /var/opt/eur/server/Confディレクトリ
(a)　Windows環境の場合

出力先定義ファイルは，EUR Server Serviceの［EUR Server Service 構成定義］ダイアログで設定します。出力先の設定については，マニュアル「EUR システム設計ガイド」を参照してください。

(b)　UNIX／Linux環境の場合

出力先定義ファイルは次の手順で設定します。

  1. /opt/eur/sample/ServerService下にある出力先定義ファイル（Destination.conf）のサンプルを任意の場所に保存する。
  2. 出力先定義ファイルを編集する。
    出力先定義ファイルは，マシンのロケールに応じたエンコードで編集してください。
  3. 必要な内容を設定した出力先定義ファイルを，同じファイル名（Destination.conf）で次の場所に格納する。

(2)　格納先

Windows環境の場合
出力先定義ファイルの格納先は，次のどちらかです。
  • インストール先フォルダ\Server\Confフォルダ（デフォルト）
  • EUR Server Serviceの環境設定ファイル（EURPM.ini）のPATHセクションのCONFキーで指定したフォルダ下
UNIX／Linux環境の場合
次のどちらかに格納してください。
  • /var/opt/eur/server/Confディレクトリ（デフォルト）
  • EUR Server Serviceの環境設定ファイル（EURPM.ini）のPATHセクションのCONFキーで指定したディレクトリ下
出力先定義ファイルの格納先には，EUR Server Serviceを利用するユーザが読み書きできるようにアクセス権を設定してください。

(3)　形式

出力先名,IPアドレス,説明

出力先名
出力先名を入力します。出力先名を指定しない場合は，デフォルトの出力先として登録されます。
IPアドレス
出力先名と対応するスプールサーバのIPアドレスを255.255.255.255形式で入力します。
説明
出力先の説明を入力します。

(4)　サンプルの内容

TOKYO,192.168.0.1,TOKYO_Server
OSAKA,192.168.0.2,OSAKA_Server
NAGOYA,192.168.0.3,NAGOYA_Server
SENDAI,192.168.0.4,SENDAI_Server
FUKUOKA,192.168.0.5,FUKUOKA_Server
,192.168.0.6,DEFAULT_Server


帳票サーバプリンタクラス定義ファイル

14.3　帳票サーバプリンタクラス定義ファイル

＜この節の構成＞
(1)　概要
(2)　格納先
(3)　形式
(4)　サンプルの内容

(1)　概要

帳票サーバプリンタクラス定義ファイル（PMPrinterClass.conf）は，帳票サーバによる直接印刷方式で，プリンタクラスを定義するためのファイルです。帳票サーバの帳票の出力先プリンタを，プリンタクラス名で指定するときに使用します。

(a)　Windows環境の場合

帳票サーバプリンタクラス定義ファイルは，EUR Server Serviceの［EUR Server Service 構成定義］ダイアログで設定します。プリンタクラスの設定については，マニュアル「EUR システム構築ガイド」を参照してください。

(b)　UNIX／Linux環境の場合

帳票サーバプリンタクラス定義ファイルは次の手順で設定します。

  1. /opt/eur/sample/ServerService下にある帳票サーバプリンタクラス定義ファイル（PMPrinterClass.conf）のサンプルを任意の場所に保存する。
  2. 帳票サーバプリンタクラス定義ファイルを編集する。
    帳票サーバプリンタクラス定義ファイルは，マシンのロケールに応じたエンコードで編集してください。
  3. 必要な内容を設定した帳票サーバプリンタクラス定義ファイルを，同じファイル名（PMPrinterClass.conf）で格納する。

(2)　格納先

Windows環境の場合
帳票サーバプリンタクラス定義ファイルの格納先は，次のどちらかです。
  • インストール先フォルダ\Server\Confフォルダ（デフォルト）
  • EUR Server Serviceの環境設定ファイル（EURPM.ini）のPATHセクションのCONFキーで指定したフォルダ下
UNIX／Linux環境の場合
次のどちらかに格納してください。
  • /var/opt/eur/server/Confディレクトリ（デフォルト）
  • EUR Server Serviceの環境設定ファイル（EURPM.ini）のPATHセクションのCONFキーで指定したディレクトリ下
帳票サーバプリンタクラス定義ファイルの格納先には，EUR Server Serviceを利用するユーザが読み書きできるようにアクセス権を設定してください。

(3)　形式

プリンタクラス名,プリンタ名,トレイ名,説明

プリンタクラス名
プリンタクラス名を入力します。プリンタクラス名を指定しない場合は，デフォルトのプリンタクラス名として登録されます。
プリンタ名
プリンタクラス名と対応する帳票サーバのプリンタ名を入力します。
トレイ名
プリンタクラス名と対応する帳票サーバのプリンタのトレイ名を入力します。
説明
プリンタクラスの説明を入力します。

(4)　サンプルの内容

standard,OSPrinter1,,standardFMS
color,OSPrinter2,,colorFMS
A3,OSPrinter3,2,A3FMS
Red,OSPrinter1,1,RedPaper
Blue,OSPrinter1,3,BluePaper
manual,OSPrinter1,manual,
AUTO,OSPrinter1,auto,


印刷先定義ファイル

14.4　印刷先定義ファイル

＜この節の構成＞
(1)　概要
(2)　格納先
(3)　形式
(4)　注意事項
(5)　サンプルの内容

(1)　概要

印刷先定義ファイル（PrintDest.conf）は，蓄積時に指定する帳票の蓄積先やスプールデータの格納ファイル名などの情報を，印刷先として定義するためのファイルです。EPF形式ファイルを分割または仕分けして蓄積する場合に使用します。印刷先を定義しておくことで，蓄積先や格納ファイル名などの情報をEPF形式ファイルごとに個別に指定できます。

印刷先定義ファイルは次の手順で設定します。

  1. 印刷先定義ファイル（PrintDest.conf）のサンプルを任意の場所に保存する。
  2. 印刷先定義ファイルを編集する。
    印刷先定義ファイルは，マシンのロケールに応じたエンコードで編集してください。
  3. 必要な内容を設定した印刷先定義ファイルを，同じファイル名（PrintDest.conf）で格納する。

(2)　格納先

Windows環境の場合
次のどちらかに格納してください。
  • インストール先フォルダ\Server\Confフォルダ（デフォルト）
  • EUR Server Serviceの環境設定ファイル（EURPM.ini）のPATHセクションのCONFキーで指定したフォルダ下
UNIX／Linux環境の場合
次のどちらかに格納してください。
  • /var/opt/eur/server/Confディレクトリ（デフォルト）
  • EUR Server Serviceの環境設定ファイル（EURPM.ini）のPATHセクションのCONFキーで指定したディレクトリ下
印刷先定義ファイルの格納先には，EUR Server Serviceを利用するユーザが読み書きできるようにアクセス権を設定してください。

(3)　形式

[セクション]
キー=値

印刷先定義ファイルの設定項目を次の表に示します。

キーは大文字と小文字を区別しません。

表14-2　印刷先定義ファイルの設定項目

セクション キー 指定できる値 指定 属性情報 説明
Common PrintDestNumber 1～1,024 必須 － 印刷先定義数を指定します。
Destn※1 PrintDestName 文字列（255バイト）※2 必須 － 印刷先名を指定します。
ServerSelectMode
  • 0
  • 1
 任意 － スプールサーバの指定方法を指定します。
  • 0
    出力先名を指定します。
  • 1
    IPアドレスを指定します。
DestinationName 文字列（80バイト）※2 任意 － 出力先名を指定します。
ServerAddress 255.255.255.255形式 任意 － スプールサーバのIPアドレスを指定します。
PrintHoldMode※3
  • 0
  • 1
  • 2
 任意 ○ 蓄積後に続けて印刷するかどうかを指定します。
  • 0
    印刷しません。
  • 1
    スプールサーバで印刷します。
  • 2
    クライアントPCで印刷します。
PrinterClassName 文字列（80バイト）※2 任意 ○ プリンタクラス名を指定します。
PrinterSelectMode
  • 0
  • 1
  • 2
 任意 ○ プリンタの指定方法を指定します。
  • 0
    プリンタクラス名で指定します。
  • 1
    プリンタ名で指定します。
  • 2
    帳票振り分け定義で指定します。
ServerPrinterName 文字列（80バイト）※2 任意 ○ 帳票を印刷するサーバのプリンタ名を指定します。
ServerTrayName 文字列（80バイト）※2 任意 ○ 帳票を印刷するサーバのトレイ名を指定します。
GroupName 文字列（80バイト）※2 任意 ○ 帳票振り分け定義の振り分けグループ名を指定します。
ClientAddress 255.255.255.255形式 任意 ○ 帳票を印刷するクライアントPCのIPアドレスを指定します。
ClientPrinterName 文字列（80バイト）※2 任意 ○ 帳票を印刷するクライアントPCのプリンタ名を指定します。
ClientTrayName 文字列（80バイト）※2 任意 ○ 帳票を印刷するクライアントPCのトレイ名を指定します。
DispPrintDlg
  • 0
  • 1
  • 2
  • 3
  • 4
 任意 ○ クライアントPCで帳票を印刷するときのダイアログ表示モードを指定します。
  • 0
    印刷先指定ダイアログを表示します（対話型印刷）。
  • 1
    印刷中にダイアログを表示します（自動印刷）。
  • 2
    プレビューウィンドウを表示します（対話型プレビュー表示）。
  • 3
    ダイアログを表示しないで印刷します（全自動印刷）。
  • 4
    プレビューウィンドウを表示します。印刷は実行できません（対話型プレビュー表示限定）。
SpoolFileName 文字列（255バイト）※4 任意 ○ スプールデータの格納ファイル名を指定します。
JobKeyCategoryn※5 文字列（80バイト）※6 任意 ○ スプールデータのジョブ検索キーの分類を指定します。
指定した場合，起動部品で指定したジョブ検索キーの分類はすべて無効になります。
JobKeyDatan※5 文字列（80バイト）※6 任意 ○ スプールデータのジョブ検索キーの値を指定します。
指定した場合，起動部品で指定したジョブ検索キーの値はすべて無効になります。
ExecutablePrintMode
  • 0
  • 1
  • 2
 任意 ○ 実行可能印刷方式を指定します。
  • 0
    スプールサーバで印刷します。
  • 1
    スプールサーバ，またはクライアントPCで印刷します。
  • 2
    クライアントPCで印刷します。
MaxPrintCount -1～65,536 任意 ○ スプールデータの印刷上限回数を指定します。
  • -1
    無限に印刷できます。
  • 0
    印刷を禁止します。
  • 1～65,536
    指定した回数印刷できます。
EnableGet
  • 0
  • 1
 任意 ○ スプールデータの取得可否を指定します。
  • 0
    取得できません。
  • 1
    取得できます。
ReportAddressKeyCategory 文字列（80バイト）※2 任意 ○ スプールデータの宛先キーの分類を指定します。ReportAddressKeyDataキーが指定されている場合だけ有効になります。
ReportAddressKeyData 文字列（80バイト）※2 任意 ○ スプールデータの宛先キーの値を指定します。ReportAddressKeyCategoryキーが指定されている場合だけ有効になります。
SpoolTitle 文字列（255バイト）※2 任意 － EPF形式ファイルに埋め込むスプールタイトルを指定します。
（凡例）
○：属性情報として設定されます。
－：属性情報として設定されません。
注※1
nの範囲は，「1～印刷先定義数（CommonセクションのPrintDestNumberキーの値）」です。
注※2
「"」，「,」および制御コード（0x00～0x1F，0x7F～0x9F）は指定できません。
注※3
ReportAddressKeyCategoryキーおよびReportAddressKeyDataキーが指定されている場合，PrintHoldModeキーのデフォルト値は0が仮定されます。
注※4
ファイル名に指定できない文字，「"」，「,」，および制御コード（0x00～0x1F，0x7F～0x9F）は指定できません。
また，「%N」を指定すると，00000001から始まる8桁の通し番号を設定できます。
（指定例）UserA_%N.epf
注※5
nの範囲は，「1～10」です。連続した番号で指定してください。nが指定されていない場合は，n以降の指定内容は無視されます。
例えば，次のように指定した場合は「JobKeyCategory1」および「JobKeyData1」だけが有効になります。
JobKeyCategory1="Country"
JobKeyData1="Japan"
JobKeyCategory2=""
JobKeyData2="Tokyo"
JobKeyCategory3="Branch"
JobKeyData3="Kanazawa"
注※6
「,」および制御コード（0x00～0x1F，0x7F～0x9F）は指定できません。

(4)　注意事項

  • 値の指定がない場合，そのキーの指定は無視されます。
  • 同じ印刷先名を複数の印刷先に指定した場合は，先に定義した印刷先（Destnセクションのnが小さい方の印刷先）の設定内容が有効となります。

(5)　サンプルの内容

このサンプルでは，次の運用を想定しています。

印刷先名 | 内容
TOKYO_RS_PRINT | 蓄積後，スプールサーバ「TOKYO」のプリンタクラス「Printer2」で帳票を印刷します。
OSAKA_RS_PRINT | 蓄積後，スプールサーバ「OSAKA」のプリンタクラス「Printer1」で帳票を印刷します。
OSAKA_CL_PRINT | 蓄積後，スプールサーバ「OSAKA」からクライアントPC（IPアドレス：111.111.111.111）に帳票を転送して直接印刷します。プリンタは蓄積時の起動部品の指定に従います。起動部品の指定がない場合は，デフォルトのプリンタで印刷します。
OSAKA_CL_DIALOG | 蓄積後，スプールサーバ「OSAKA」からクライアントPC（IPアドレス：111.111.111.111）に帳票を転送して対話型印刷します。
TOKYO_RS_SPOOL_UserA | スプールサーバ「TOKYO」に帳票を蓄積します。スプールデータには次の属性情報を設定※します。 ジョブ検索キーの分類：User ジョブ検索キーの値：UserA また，スプールデータの格納ファイル名には通し番号を設定します。
TOKYO_RS_SPOOL_UserB | スプールサーバ「TOKYO」に帳票を蓄積します。スプールデータには次の属性情報を設定※します。 ジョブ検索キーの分類：User ジョブ検索キーの値：UserB また，スプールデータの格納ファイル名には通し番号を設定します。
注
出力先名「TOKYO」および「OSAKA」は，EUR Server Serviceの［EUR Server Service 構成定義］ダイアログまたは出力先定義ファイルで定義してください。
また，プリンタクラス名はそれぞれのスプールサーバで定義してください。EUR Server - Spool Serviceの［EUR Spool Service 構成定義］ダイアログまたは拠点プリンタクラス定義ファイルで定義できます。
注※
設定した属性情報（ジョブ検索キーの分類と値）を，ユーザ名，および確認キーとして利用することで，スプールデータにアクセスできるユーザを制御することもできます。詳細については，マニュアル「EUR システム構築ガイド」を参照してください。

サンプルの内容を次に示します。

//Set Print Destination Number
[Common]
PrintDestNumber=6

//TOKYO Server Spool & Server Print
[Dest1]
PrintDestName="TOKYO_RS_PRINT"
ServerSelectMode=0
PrinterSelectMode=0
DestinationName="TOKYO"
PrintHoldMode=1
PrinterClassName="Printer2"

//OSAKA Server Spool & Server Print
[Dest2]
PrintDestName="OSAKA_RS_PRINT"
ServerSelectMode=0
PrinterSelectMode=0
DestinationName="OSAKA"
PrintHoldMode=1
PrinterClassName ="Printer1"

//OSAKA Server Spool & Client Auto Print
[Dest3]
PrintDestName="OSAKA_CL_PRINT"
ServerSelectMode=0
DestinationName="OSAKA"
PrintHoldMode=2
ClientAddress="111.111.111.111"
DispPrintDlg=1

//OSAKA Server Spool & Client Dialog Print
[Dest4]
PrintDestName="OSAKA_CL_DIALOG"
ServerSelectMode=0
DestinationName="OSAKA"
PrintHoldMode=2
ClientAddress="111.111.111.222"
DispPrintDlg=0

//TOKYO Server Spool Only for UserA
[Dest5]
PrintDestName="TOKYO_RS_SPOOL_UserA"
ServerSelectMode=0
DestinationName="TOKYO"
PrintHoldMode=0
JobKeyCategory1="User"
JobKeyData1="UserA"
SpoolFileName="%N.epf"

//TOKYO Server Spool Only for UserB
[Dest6]
PrintDestName="TOKYO_RS_SPOOL_UserB"
ServerSelectMode=0
DestinationName="TOKYO"
PrintHoldMode=0
JobKeyCategory1="User"
JobKeyData1="UserB"
SpoolFileName="%N.epf"


拠点プリンタクラス定義ファイル

14.5　拠点プリンタクラス定義ファイル

＜この節の構成＞
(1)　概要
(2)　格納先

(1)　概要

拠点プリンタクラス定義ファイル（ServerPrinterClass.conf）は，スプールサーバのプリンタとトレイの組み合わせを定義するためのファイルです。複数のプリンタやトレイを効率良く管理したいときに使用します。

拠点プリンタクラス定義ファイルは，EUR Server - Spool Serviceの［EUR Spool Service 構成定義］ダイアログの［プリンタクラス］タブで設定します。拠点プリンタクラスの設定については，マニュアル「EUR システム構築ガイド」を参照してください。

(2)　格納先

拠点プリンタクラス定義ファイルの格納先は，次のどちらかです。

  • インストール先フォルダ\Spool\Confフォルダ（デフォルト）
  • EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）のPATHセクションのCONFキーで指定したフォルダ下


帳票振り分け定義ファイル

14.6　帳票振り分け定義ファイル

＜この節の構成＞
(1)　概要
(2)　格納先

(1)　概要

帳票振り分け定義ファイル（Distribution.conf）は，帳票名ごとにプリンタを定義したファイルです。帳票振り分け定義を指定すると，帳票名ごとに自動的にプリンタを指定でき，同じ名前の帳票を別のプリンタで印刷できます。

帳票振り分け定義ファイルは，EUR Server - Spool Serviceの［EUR Spool Service 構成定義］ダイアログの［帳票振り分け］タブで設定します。帳票振り分け定義の設定については，マニュアル「EUR システム構築ガイド」を参照してください。

(2)　格納先

帳票振り分け定義ファイルの格納先は，次のどちらかです。

  • インストール先フォルダ\Spool\Confフォルダ（デフォルト）
  • EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）のPATHセクションのCONFキーで指定したフォルダ下


ユーザ管理ファイル

14.7　ユーザ管理ファイル

＜この節の構成＞
(1)　概要
(2)　格納先
(3)　形式
(4)　サンプルの内容

(1)　概要

ユーザ管理ファイル（userdef.conf）は，ユーザの認証情報，およびスプールデータへのアクセス制限情報が定義されたファイルです。スプールデータにアクセスするユーザを管理できます。

ユーザについては，マニュアル「EUR システム構築ガイド」を参照してください。

(a)　Windows環境の場合

ユーザ管理ファイルは，［EUR Spool Service 構成定義］ダイアログの［ユーザ定義］タブで定義します。ユーザの設定については，マニュアル「EUR システム構築ガイド」を参照してください。

ユーザ管理ファイルの格納先は，次のどちらかです。

  • インストール先フォルダ\Spool\Confフォルダ（デフォルト）
  • EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）のPATHセクションのCONFキーで指定したフォルダ下
(b)　UNIX／Linux環境の場合

ユーザ管理ファイルは，/opt/eur/sample/SpoolService下にあるサンプルファイルを基に設定します。ユーザの設定については，マニュアル「EUR システム構築ガイド」を参照してください。

(2)　格納先

ユーザ管理ファイルの格納先は，次のどちらかです。

  • /var/opt/eur/spool/Confディレクトリ（デフォルト）
  • EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）のPATHセクションのCONFキーで指定したフォルダ下

(3)　形式

[セクション]
キー=値

ユーザ管理ファイルの設定項目を次の表に示します。

キーは大文字と小文字を区別しません。ユーザの設定については，マニュアル「EUR システム構築ガイド」を参照してください。また，ユーザを設定する場合の注意事項については，マニュアル「EUR システム設計ガイド」を参照してください。

表14-3　ユーザ管理ファイルの設定項目

セクション | キー | 指定できる値 | 省略値 | 説明
Common | GroupCategoryConfNum | 0～100,000 | 0 | ユーザ数を指定します。デフォルト値は1です。なお，デフォルトユーザは数に含めません。
GroupCategory 文字列 － ユーザ名に使用するジョブ検索キーの分類名を指定します。
GroupCategoryConfn※1 GroupKey 文字列 － ユーザ名を指定します。
CheckString 文字列 － ユーザの確認キーを指定します。
GroupFilter
  • NONE
  • ALL
  • CATEGORY
 NONE スプールデータのアクセス制限方式を指定します。指定できる値とその意味は次のとおりです。
  • NONE
    すべてのスプールデータを表示します。
  • ALL
    すべてのスプールデータを表示しません。
  • CATEGORY
    GroupFilterNameキーで指定したジョブ検索キーの分類名を持つスプールデータを表示します。
GroupFilterName 文字列 － アクセス許可に使用するジョブ検索キーの分類名を指定します。GroupFilterキーにCATEGORYを指定した場合に指定します。
GroupFilterKeyNum | 0～1,024 | 0 | アクセスを許可するジョブ検索キーの数を指定します。
GroupFilterKeyn※2 文字列 － アクセスを許可するジョブ検索キーを指定します。
GroupFilterKeyNull
  • ENABLE
  • DISENABLE
 ENABLE GroupFilterKeyキーを指定していないスプールデータにアクセスするかどうかを指定します。指定できる値とその意味は次のとおりです。
  • ENABLE
    アクセスします。
  • DISENABLE
    アクセスしません。
GroupFilterKeyOwner
  • ENABLE
  • DISENABLE
 DISENABLE GroupKeyキーで指定したユーザ名がGroupCategoryキーに指定したジョブ検索キーの分類名と一致する場合，スプールデータにアクセスするかどうかを指定します。指定できる値とその意味は次のとおりです。
  • ENABLE
    アクセスします。
  • DISENABLE
    アクセスしません。
Default GroupFilter
  • NONE
  • ALL
  • CATEGORY
 NONE スプールデータのアクセス制限方式を指定します。指定できる値とその意味は次のとおりです。
  • NONE
    すべてのスプールデータを表示します。
  • ALL
    すべてのスプールデータを表示しません。
  • CATEGORY
    GroupFilterNameキーで指定したジョブ検索キーの分類名を持つスプールデータを表示します。
GroupFilterName 文字列 － アクセス許可に使用するジョブ検索キーの分類名を指定します。GroupFilterキーにCATEGORYを指定した場合に指定します。
GroupFilterKeyNum | 0～1,024 | 0 | アクセスを許可するジョブ検索キーの数を指定します。
GroupFilterKeyn※2 文字列 － アクセスを許可するジョブ検索キーを指定します。
GroupFilterKeyNull
  • ENABLE
  • DISENABLE
 DISENABLE GroupFilterNameキーのジョブ検索キーを持たないスプールデータにアクセスするかどうかを指定します。指定できる値とその意味は次のとおりです。
  • ENABLE
    アクセスします。
  • DISENABLE
    アクセスしません。
GroupFilterKeyOwner
  • ENABLE
  • DISENABLE
 ENABLE GroupCategoryキーのジョブ検索キーを持たないスプールデータにアクセスするかどうかを指定します。指定できる値とその意味は次のとおりです。
  • ENABLE
    アクセスします。
  • DISENABLE
    アクセスしません。
（凡例）
－：省略値はありません。
注※1
nの範囲は，「1～ユーザ数（CommonセクションのGroupCategoryConfNumキーの値）」です。
注※2
nの範囲は，「1～アクセス許可するジョブ検索キーの数（GroupCategoryConfセクションのGroupFilterKeyNumキーの値）」です。

(4)　サンプルの内容

このサンプルでは，次の5種類の帳票を管理する場合を想定しています。

帳票 | 説明
部署Ａの管理資料 | 部署Ａのリーダがアクセスできる帳票です。
部署Ａの公開資料 | 部署Ａに所属するユーザがアクセスできる帳票です。また，部署Ｂのリーダもアクセスできます。
部署Ｂの管理資料 | 部署Ｂのリーダがアクセスできる帳票です。
部署Ｂの公開資料 | 部署Ｂに所属するユーザがアクセスできる帳票です。また，部署Ａのリーダもアクセスできます。
公開先の情報を持たない資料 | 公開先を設定していない帳票です。

サンプルの内容を次に示します。

[Common]
GroupCategoryConfNum=5
GroupCategory="ユーザ"

[GroupCategoryConf1]
GroupKey="システム管理者"
CheckString="pwadmin"
GroupFilter=NONE

[GroupCategoryConf2]
GroupKey="部署Ａ＿リーダ"
CheckString="pwleader"
GroupFilter=CATEGORY
GroupFilterName="公開先"
GroupFilterKeyNum=3
GroupFilterKey1="部署Ａ＿管理"
GroupFilterKey2="部署Ａ＿公開"
GroupFilterKey3="部署Ｂ＿公開"
GroupFilterKeyNull=ENABLE
GroupFilterKeyOwner=ENABLE

[GroupCategoryConf3]
GroupKey="部署Ａ＿一般"
CheckString="pwsub"
GroupFilter=CATEGORY
GroupFilterName="公開先"
GroupFilterKeyNum=1
GroupFilterKey1="部署Ａ＿公開"
GroupFilterKeyNull=DISENABLE
GroupFilterKeyOwner=ENABLE

[GroupCategoryConf4]
GroupKey="部署Ｂ＿リーダ"
CheckString="pwleader"
GroupFilter=CATEGORY
GroupFilterName="公開先"
GroupFilterKeyNum=3
GroupFilterKey1="部署Ｂ＿管理"
GroupFilterKey2="部署Ｂ＿公開"
GroupFilterKey3="部署Ａ＿公開"
GroupFilterKeyNull=ENABLE
GroupFilterKeyOwner=ENABLE

[GroupCategoryConf5]
GroupKey="部署Ｂ＿一般"
CheckString="pwsub"
GroupFilter=CATEGORY
GroupFilterName="公開先"
GroupFilterKeyNum=1
GroupFilterKey1="部署Ｂ＿公開"
GroupFilterKeyNull=DISENABLE
GroupFilterKeyOwner=DISENABLE

[Default]
GroupFilter=ALL
GroupFilterKeyOwner=DISENABLE

この内容でユーザ定義として定義する場合，各ユーザの帳票へのアクセス可否は次のようになります。

帳票 | 属性 |  | ユーザ
 | ユーザ | 公開先 | システム管理者 | 部署A＿リーダ | 部署A＿一般 | 部署B＿リーダ | 部署B＿一般 | デフォルトユーザ
01 | 部署Ａ＿リーダ | 部署Ａ＿管理 | ○ | ○ | × | × | × | ×
02 | 部署Ａ＿リーダ | 部署Ａ＿公開 | ○ | ○ | ○ | ○ | × | ×
03 | 部署Ａ＿一般 | 部署Ａ＿管理 | ○ | ○ | ○ | × | × | ×
04 | 部署Ａ＿一般 | 部署Ａ＿公開 | ○ | ○ | ○ | ○ | × | ×
05 | 部署Ｂ＿リーダ | 部署Ｂ＿管理 | ○ | × | × | ○ | × | ×
06 | 部署Ｂ＿リーダ | 部署Ｂ＿公開 | ○ | ○ | × | ○ | ○ | ×
07 | 部署Ｂ＿一般 | 部署Ｂ＿管理 | ○ | × | × | ○ | × | ×
08 | 部署Ｂ＿一般 | 部署Ｂ＿公開 | ○ | ○ | × | ○ | ○ | ×
09 | － | － | ○ | ○ | × | ○ | × | ×
10 | 部署Ａ＿リーダ | 部署Ｂ＿管理 | ○ | ○ | × | ○ | × | ×
11 | 部署Ａ＿リーダ | 部署Ｂ＿公開 | ○ | ○ | × | ○ | ○ | ×
12 | 部署Ａ＿一般 | 部署Ｂ＿管理 | ○ | × | ○ | ○ | × | ×
13 | 部署Ａ＿一般 | 部署Ｂ＿公開 | ○ | ○ | ○ | ○ | ○ | ×
14 | 部署Ｂ＿リーダ | 部署Ａ＿管理 | ○ | ○ | × | ○ | × | ×
15 | 部署Ｂ＿リーダ | 部署Ａ＿公開 | ○ | ○ | ○ | ○ | × | ×
16 | 部署Ｂ＿一般 | 部署Ａ＿管理 | ○ | ○ | × | × | × | ×
17 | 部署Ｂ＿一般 | 部署Ａ＿公開 | ○ | ○ | ○ | ○ | × | ×
（凡例）
－：属性情報がありません。
○：アクセスできます。
×：アクセスできません。


クライアントプリンタクラス定義ファイル

14.8　クライアントプリンタクラス定義ファイル

＜この節の構成＞
(1)　概要
(2)　格納先

(1)　概要

クライアントプリンタクラス定義ファイル（ClientPrinterClass.conf）は，クライアントPCのプリンタとトレイの組み合わせを定義するためのファイルです。複数のプリンタやトレイを効率良く管理したいときに使用します。

クライアントプリンタクラス定義ファイルは，EUR Clientの［EUR Client 構成定義］ダイアログで設定します。クライアントプリンタクラスの設定については，マニュアル「EUR システム設計ガイド」を参照してください。

(2)　格納先

クライアントプリンタクラス定義ファイルの格納先は，次のどちらかです。

  • インストール先フォルダ\Client\Confフォルダ（デフォルト）
  • EUR Clientの環境設定ファイル（EURPMCL.ini）のPATHセクションのCONFキーで指定したフォルダ下


宛先定義ファイル

14.9　宛先定義ファイル

＜この節の構成＞
(1)　概要
(2)　格納先
(3)　形式
(4)　注意事項
(5)　サンプルの内容

(1)　概要

宛先定義ファイル（addrdef.conf※）は，配送印刷を使用するユーザと，対応する宛先を定義するためのファイルです。宛先定義ファイルで指定したユーザが配送印刷を使用できます。

注※
addrdef.confは，宛先定義ファイルのデフォルトの名称です。宛先定義ファイルの名称はEUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）のCONFセクションのADDRDEFFILENAMEキーで変更できます。詳細については「15.5.31　ADDRDEFFILENAME」を参照してください。

ユーザについては，マニュアル「EUR システム構築ガイド」を参照してください。

(2)　格納先

Windows環境の場合
宛先定義ファイルの格納先は，次のどちらかです。
  • インストール先フォルダ\Spool\Confフォルダ（デフォルト）
  • EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）のPATHセクションのCONFキーで指定したフォルダ下
UNIX／Linux環境の場合
宛先定義ファイルの格納先は，次のどちらかです。
  • /var/opt/eur/spool/Confディレクトリ（デフォルト）
  • EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）のPATHセクションのCONFキーで指定したフォルダ下

(3)　形式

宛先キーの分類,宛先キーの値,ユーザ

宛先定義ファイルの設定項目を次の表に示します。

表14-4　宛先定義ファイルの設定項目

キー | 指定できる値 | 説明
宛先キーの分類 | 文字列（1～80バイト） | 宛先キーの分類を指定します。宛先キーの分類を指定する場合，宛先キーの値も必ず指定してください。
宛先キーの値 | 文字列（1～80バイト） | 宛先キーの値を指定します。宛先キーの値を指定する場合，宛先キーの分類も必ず指定してください。
ユーザ | 文字列（1～80バイト） | ユーザを指定します。LDAP認証を使用する場合，ユーザにはLDAPのユーザIDを宛先に定義してください。

宛先定義ファイルは，次のフォーマットで指定してください。

  • キーは，タブまたは「,」で区切ってください。タブと「,」を混在させるとエラーになります。
  • 改行コードは，\nまたは\r\nを指定してください。
  • 各キー内で，「"」，「,」および制御コード（0x00～0x1F，0x7F～0x9F）を使用しないでください。「"」は各キーの先頭または末尾にだけ使用してください。
  • 宛先キーとユーザ名は1行ずつ定義してください。なお，指定する行は100,000以内，1行に指定するユーザ数は100以内にしてください。

定義例を次に示します。

宛先キーの分類1,宛先キーの値1,ユーザ1,ユーザ2,ユーザ3,…
宛先キーの分類2,宛先キーの値2,ユーザA,ユーザB,ユーザC,…

(4)　注意事項

  • 複数の宛先およびユーザを指定したときは，情報量に応じた処理時間が掛かります。このため，指定する行数，および1行に指定するユーザは次の値の範囲内で設定してください。
    • 行数：100,000行以内
    • 1行に定義できるユーザ数：100ユーザ以内
  • 一つの宛先に複数のユーザを指定した場合，配送印刷の対象となるのは指定したユーザのうちどれか一つです。配送印刷の対象になるユーザは，ユーザがログインするタイミングや監視間隔のタイミングによって変わります。

(5)　サンプルの内容

サンプルの内容を次に示します。

部署,部署A,日立太郎,日立次郎
部署,部署A,戸塚花子
部署,部署B,戸塚一郎
役職,リーダ,日立太郎,戸塚一郎
プリンタ,連続紙,日立太郎,日立次郎
サークル,テニス,戸塚花子

このサンプルでは，次に示す運用を想定しています。

宛先キーの値

宛先キーの分類 | 宛先キーの値
部署 | 部署Aまたは部署B
役職 | リーダ
プリンタ | 連続紙
サークル | テニス

各部署の帳票の内容

部署 | 帳票 | 説明
部署A | 部署Aの資料 | 部署Aのユーザが配送印刷できる帳票です。
部署B | 部署Bの資料 | 部署Bのユーザが配送印刷できる帳票です。
役職 | 部署のリーダへの連絡 | 部署のリーダが配送印刷できる帳票です。
プリンタ | 連続紙プリンタ用の資料 | 連続紙プリンタがある部署のユーザが配送印刷できる帳票です。
サークル | テニスサークルの連絡 | テニスサークルに所属するユーザが配送印刷できる帳票です。

ユーザの立場

ユーザ | 立場
日立太郎 | 部署Aのリーダ
日立次郎 | 部署Aのユーザ
戸塚一郎 | 部署Bのリーダ
戸塚花子
  • 部署Aのユーザ
  • テニスサークル所属

部署のプリンタ

部署 | プリンタ
部署A | 連続紙プリンタ

この内容で配送印刷を定義する場合，各ユーザの配送印刷の可否は次のようになります。なお，一つの宛先に複数のユーザを指定している場合，配送印刷の対象となるのは指定したユーザのうちどれか一つです。

配送印刷 | 日立太郎 | 日立次郎 | 戸塚一郎 | 戸塚花子
部署Aの資料 | ○ | ○ | × | ○
部署Bの資料 | × | × | ○ | ×
リーダへの連絡 | ○ | × | ○ | ×
連続紙プリンタ用の資料 | ○ | ○ | × | ×
テニスサークルの連絡 | × | × | × | ○
（凡例）
○：配送印刷できる
×：配送印刷できない


監視定義ファイル

14.10　監視定義ファイル

＜この節の構成＞
(1)　概要
(2)　格納先
(3)　形式
(4)　注意事項

(1)　概要

監視定義ファイル（monitordef.conf）は，事前定義型で帳票自動出力機能を使用するときに，着信監視するマッピングデータファイルに対応する起動パラメタファイルを定義するファイルです。

(2)　格納先

監視定義ファイルの格納先は，次のどちらかです。

  • インストール先フォルダ\FileMonitor\conf（デフォルト）
  • ファイル監視サービスの環境設定ファイル（eurfm.ini）のPATHセクションのCONFキーで指定したフォルダ下

(3)　形式

照合パターンID，照合パターン，起動パラメタファイル名

監視定義ファイルの設定項目を次の表に示します。

表14-5　監視定義ファイルの設定項目

項目 | 指定できる値 | 説明
照合パターンID | 文字列（1～80バイト） | 照合パターンを識別するためのIDを指定します。
照合パターン | 文字列（1～255バイト） | 監視対象のマッピングデータファイルのファイル名を特定するための照合パターンを指定します。 監視フォルダに着信したファイルはこの照合パターンを使用して識別されます。 照合パターンには，半角文字の「*」および「?」のワイルドカードを使用できます。 半角文字「*」は0文字以上の任意の文字列を示します。半角文字「?」は1文字の任意の文字列を示します。
起動パラメタファイル名 | 文字列（1～255バイト） | 照合パターンに一致したマッピングデータファイルに対して使用する起動パラメタファイルのファイル名を指定します。

監視定義ファイルは，次のフォーマットで指定してください。

  • 1つの照合パターンを1行で定義します。各照合パターンには，すべての項目を必ず1つずつ指定してください。
  • 同一の照合パターンが複数定義されている場合は先に定義されているものが有効となります。
  • 定義できる照合パターンの数は最大100です。
  • 各項目は，タブまたは「,」で区切ってください。タブと「,」を混在させるとエラーになります。
  • 改行コードは，\nまたは\r\nを指定してください。
  • 各項目内で，「"」，「,」および制御コード（0x00～0x1F，0x7F～0x9F）を使用しないでください。「"」は各項目の先頭または末尾にだけ使用してください。
  • 空行は無視されます。

定義例を次に示します。

001,請求書_*_部署A.csv,請求書A.conf
002,請求書_*_部署B.csv,請求書B.conf

(4)　注意事項

  • 照合パターンに各項目が1つずつ指定されていない場合はエラーになります。
  • 照合パターンIDが重複している場合はエラーになります。
  • 定義している照合パターンの数が100を超えている場合はエラーになります。


環境設定ファイル

15.　環境設定ファイル

この章では，環境設定ファイルを使った実行環境の設定方法について説明します。

＜この章の構成＞
15.1　環境設定ファイルの一覧
15.2　環境設定ファイル（EURPM.ini）
15.3　環境設定ファイル（EURPS_ENV）
15.4　EUR Server - Adapterの環境設定ファイル（EURPMADP.ini）
15.5　EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）
15.6　EUR Server - Spool Service Adapterの環境設定ファイル（EURPMLSADP.ini）
15.7　帳票管理GUIの環境設定ファイル（EURPMRSGUI.ini）
15.8　EUR Client Serviceの環境設定ファイル（EURPMCL.ini）
15.9　Server Service制御コマンドの環境設定ファイル（EURPMCTRL.ini）
15.10　Spool Service制御コマンドの環境設定ファイル（EURPMLSCTRL.ini）
15.11　BSP-RM連携コマンドの環境設定ファイル（eursmpr.ini）
15.12　ファイル監視サービスの環境設定ファイル（eurfm.ini）
15.13　ジョブ実行プログラムの環境設定ファイル（eurivk.ini）


環境設定ファイルの一覧

15.1　環境設定ファイルの一覧

環境設定ファイルの概要を次の表に示します。

表15-1　環境設定ファイルの一覧

ファイル名 | 説明
EURPM.ini | EUR Server Serviceの動作環境を設定するファイルです。
EURPS_ENV
EURPMADP.ini | EUR Server - Adapterの動作環境を設定するファイルです。
EURPMLS.ini | EUR Server - Spool Serviceの動作環境を設定するファイルです。
EURPMLSADP.ini | EUR Server - Spool Service Adapterの動作環境を設定するファイルです。
EURPMRSGUI.ini | 帳票管理GUIの動作環境を設定するファイルです。
EURPMCL.ini | EUR Client Serviceの動作環境を設定するファイルです。
EURPMCTRL.ini | Server Service制御コマンド（eurpmctrlコマンド）の動作環境を設定するファイルです。
EURPMLSCTRL.ini | Spool Service制御コマンド（eurpmlsctrlコマンド）の動作環境を設定するファイルです。
eursmpr.ini | BSP-RM連携コマンド（eursmprコマンド）の動作環境を設定するファイルです。
eurfm.ini | ファイル監視サービスの動作環境を設定するファイルです。
eurivk.ini | ジョブ実行プログラムの動作環境を設定するファイルです。


環境設定ファイル（EURPM.ini）

15.2　環境設定ファイル（EURPM.ini）

対象コンポーネントまたは機能
EUR Server Service
設定内容
EUR Server Serviceの動作環境は，環境設定ファイル（EURPM.ini）で設定します。
環境設定ファイルを変更した場合は，EUR Server Serviceを再起動してください。
環境設定ファイルの格納場所
  • Windows環境の場合
    環境設定ファイル（EURPM.ini）は，インストール先フォルダ\Server下に作成されます。
    ファイルの内容を追加，変更する場合は，メモ帳などのテキスト編集エディタを起動して編集したあと，上書き保存してから使用してください。
  • UNIX／Linux環境の場合
    次に示す環境設定ファイル（EURPM.ini）のサンプルを，/opt/eur/sample/ServerService下に提供しています。必要な内容を設定したあと，同じファイル名で/var/opt/eur/server下に格納してください。
    なお，/var/opt/eur/serverには，EUR Server Serviceを利用するユーザが読み書きできるようにアクセス権を設定してください。
＜環境設定ファイル（EURPM.ini）のサンプルの内容＞
[PORT]

[PATH]

[ERROR]

[OPTION]
SOCKBUFFSIZE=64

[THREAD]
MERGE=1

[TIMEOUT]

[ENV]

[FILE]

＜環境設定ファイル（EURPM.ini）の設定手順＞
環境設定ファイルは次の手順で設定します。
  1. /opt/eur/sample下にある環境設定ファイル（EURPM.ini）のサンプルを任意の場所に保存する。
  2. 環境設定ファイルを編集する。
    環境設定ファイルは，マシンのロケールに応じたエンコードで編集してください。
  3. 必要な内容を設定した環境設定ファイルを，サンプルと同じファイル名（EURPM.ini）で/var/opt/eur/server下に格納する。
    /var/opt/eur/serverには，EUR Server Serviceを利用するユーザが読み書きできるようにアクセス権を設定してください。
環境設定ファイルの構文

変数名=値

環境設定ファイルに指定する情報は，「"」で囲まないでください。
環境設定ファイルの指定例（Windows環境の場合）

[PORT]
EURPM=22314
EURPMLS=22313
EURPMCL=23035

[PATH]
FORM=C:\EURPM\Form
CONF=C:\EURPM\Conf
TEMP=C:\EURPM\Temp
MULTI=C:\EURPM\Multi
DOCINFO=C:\EURPM\DocInfo
DBINFO=C:\EURPM\DBInfo
REPLACEITEM=C:\EURPM\ReplaceItem
SCRIPTCNT=C:\EURPM\ScriptCnt
PREFERENCE=C:\EURPM\Preference
PSENV=C:\EURPM\PSEnv
PDF=C:\EURPM\PDF
PRINTDATE=C:\EURPM\PrintDate
SPLIT=C:\EURPM\Split

[ERROR]
LOGFILE=C:\EURPM\Log
LOGLEVEL=4
LOGSIZE=750

[OPTION]
PATHMODE=0
TEMPFILEDEL=1
SOCKBUFFSIZE=64
SPLITMODE=PAGE
RMDIRRETRYCOUNT=1
RMDIRINTERVALTIME=200

[THREAD]
GENERAL=200
EURPS=1
MERGE=0

[TIMEOUT]
CONNECT=300
ERRIGNORE=300

[ENV]
PSENVFILENAME=EURPS_ENV

[FILE]
PRINTDATE=PRINTDATETIME.txt
SPLIT=PMPageSplit.txt
＜この節の構成＞
15.2.1　設定項目一覧
15.2.2　EURPM
15.2.3　EURPMLS
15.2.4　EURPMCL
15.2.5　FORM
15.2.6　CONF
15.2.7　TEMP
15.2.8　MULTI
15.2.9　DOCINFO
15.2.10　DBINFO
15.2.11　REPLACEITEM
15.2.12　SCRIPTCNT
15.2.13　PREFERENCE
15.2.14　PSENV
15.2.15　PDF
15.2.16　PRINTDATE
15.2.17　SPLIT
15.2.18　LOGFILE
15.2.19　LOGLEVEL
15.2.20　LOGSIZE
15.2.21　PATHMODE
15.2.22　TEMPFILEDEL
15.2.23　SOCKBUFFSIZE
15.2.24　SPLITMODE
15.2.25　RMDIRRETRYCOUNT
15.2.26　RMDIRINTERVALTIME
15.2.27　GENERAL
15.2.28　EURPS
15.2.29　MERGE
15.2.30　CONNECT
15.2.31　ERRIGNORE
15.2.32　PSENVFILENAME
15.2.33　PRINTDATE
15.2.34　SPLIT


設定項目一覧

15.2.1　設定項目一覧

EUR Server Serviceの環境設定ファイル（EURPM.ini）で指定できる内容を次の表に示します。

表15-2　EUR Server Serviceの環境設定ファイル（EURPM.ini）で指定できる内容

セクション | キー | 説明
PORT | EURPM | EUR Server Serviceのポート番号を指定します。
 | EURPMLS | EUR Server - Spool Serviceのポート番号を指定します。
 | EURPMCL | EUR Client Serviceのポート番号を指定します。
PATH | FORM | 帳票ファイルを格納したフォルダを指定します。
 | CONF | 構成定義ファイルを格納したフォルダを指定します。
 | TEMP | EUR Server Serviceの作業フォルダを指定します。
 | MULTI | 複数様式情報定義ファイルを格納したフォルダを指定します。
 | DOCINFO | 文書情報設定ファイルを格納したフォルダを指定します。
 | DBINFO | 接続情報ファイルを格納したフォルダを指定します。
 | REPLACEITEM | 置き換え表管理情報ファイルを格納したフォルダを指定します。
 | SCRIPTCNT | Acrobat JavaScript定義ファイルを格納したフォルダを指定します。
 | PREFERENCE | ビューアプレファレンス定義ファイルを格納したフォルダを指定します。
 | PSENV | EUR Server Serviceのサービスごとに環境設定ファイル（EURPS_ENV）を指定する場合，環境設定ファイル（EURPS_ENV）を格納したフォルダを指定します。
 | PDF | EUR Server Service稼働マシンにPDF形式ファイルを出力する場合の，デフォルトの出力先フォルダを指定します。
 | PRINTDATE | 印刷日時出力定義ファイルを格納したフォルダを指定します。
 | SPLIT | 分割定義ファイル，または仕分け定義ファイルを格納したフォルダを指定します。
ERROR | LOGFILE | ログファイル（EURPM.log）の出力先フォルダを指定します。
 | LOGLEVEL | 実行ログの出力レベルを指定します。
 | LOGSIZE | ログファイル（EURPM.log）のファイルサイズの上限を指定します。
OPTION | PATHMODE | 帳票サーバに置くファイルのパスモードを指定します。
 | TEMPFILEDEL | 印刷実行時に生成した一時ファイルを削除するかどうかを指定します。
 | SOCKBUFFSIZE | ソケット通信に使用する通信バッファサイズの上限を指定します。
 | SPLITMODE | 蓄積時に，帳票を分割または仕分けするかどうかを指定します。
 | RMDIRRETRYCOUNT | EUR Server Serviceで作業用一時ディレクトリの削除に失敗した場合，リトライする回数を指定します。
 | RMDIRINTERVALTIME | EUR Server Serviceで作業用一時ディレクトリの削除に失敗した場合，リトライするまでの待機時間を指定します。
THREAD | GENERAL | EUR Server Serviceの並列処理数を指定します。
 | EURPS | EUR Print Serviceの並列処理数を指定します。
 | MERGE | 複数のEPF形式ファイルを統合して出力する場合の並列処理数を指定します。
TIMEOUT | CONNECT | 意図しない接続元が，データ通信を行わないでEUR Server Serviceと接続したままの状態になった場合，切断するまでの時間を指定します（タイムアウト監視）。
 | ERRIGNORE | ソケットを接続してデータを通信しないで切断する処理（生死監視）が実行された場合に，切断を検知してもエラーを出力しない時間を指定します。
ENV | PSENVFILENAME | EUR Server Serviceのサービスごとに環境設定ファイル（EURPS_ENV）を指定する場合，環境設定ファイル（EURPS_ENV）のファイル名を指定します。
FILE | PRINTDATE | 印刷日時出力定義ファイル名を指定します。
 | SPLIT | 分割定義ファイルまたは仕分け定義ファイル名を指定します。


EURPM

15.2.2　EURPM

セクション
[PORT]
設定内容
EUR Server Serviceのポート番号を指定します。
指定値
指定できる値は0～65535です。
省略値
EURPMキーを省略した場合は，「22314」が仮定されます。


EURPMLS

15.2.3　EURPMLS

セクション
[PORT]
設定内容
EUR Server - Spool Serviceのポート番号を指定します。
指定値
指定できる値は0～65535です。
省略値
EURPMLSキーを省略した場合は，「22313」が仮定されます。


EURPMCL

15.2.4　EURPMCL

セクション
[PORT]
設定内容
EUR Client Serviceのポート番号を指定します。
指定値
指定できる値は0～65535です。
省略値
EURPMCLキーを省略した場合は，「23035」が仮定されます。


FORM

15.2.5　FORM

セクション
[PATH]
設定内容
帳票ファイルを格納したフォルダを指定します。
指定値
フルパスで指定します。
省略値
FORMキーを省略した場合は，次のフォルダが仮定されます。
  • Windows環境のとき
    インストール先フォルダ\Server\Formフォルダ
  • UNIX／Linux環境のとき
    /var/opt/eur/server/Form


CONF

15.2.6　CONF

セクション
[PATH]
設定内容
構成定義ファイルを格納したフォルダを指定します。
指定値
フルパスで指定します。
省略値
CONFキーを省略した場合は，次のフォルダが仮定されます。
  • Windows環境のとき
    インストール先フォルダ\Server\Confフォルダ
  • UNIX／Linux環境のとき
    /var/opt/eur/server/Conf


TEMP

15.2.7　TEMP

セクション
[PATH]
設定内容
EUR Server Serviceの作業フォルダを指定します。
指定値
フルパスで指定します。
省略値
TEMPキーを省略した場合は，次のフォルダが仮定されます。
  • Windows環境のとき
    インストール先フォルダ\Server\Tempフォルダ
  • UNIX／Linux環境のとき
    /var/opt/eur/server/Temp


MULTI

15.2.8　MULTI

セクション
[PATH]
設定内容
複数様式情報定義ファイルを格納したフォルダを指定します。
指定値
フルパスで指定します。
省略値
MULTIキーを省略した場合は，次のフォルダが仮定されます。
  • Windows環境のとき
    インストール先フォルダ\Server\Multiフォルダ
  • UNIX／Linux環境のとき
    /var/opt/eur/server/Multi


DOCINFO

15.2.9　DOCINFO

セクション
[PATH]
設定内容
文書情報設定ファイルを格納したフォルダを指定します。
指定値
フルパスで指定します。
省略値
DOCINFOキーを省略した場合は，次のフォルダが仮定されます。
  • Windows環境のとき
    インストール先フォルダ\Server\DocInfoフォルダ
  • UNIX／Linux環境のとき
    /var/opt/eur/server/DocInfo


DBINFO

15.2.10　DBINFO

セクション
[PATH]
設定内容
接続情報ファイルを格納したフォルダを指定します。
指定値
フルパスで指定します。
省略値
DBINFOキーを省略した場合は，次のフォルダが仮定されます。
  • Windows環境のとき
    インストール先フォルダ\Server\DBInfoフォルダ
  • UNIX／Linux環境のとき
    /var/opt/eur/server/DBInfo


REPLACEITEM

15.2.11　REPLACEITEM

セクション
[PATH]
設定内容
置き換え表管理情報ファイルを格納したフォルダを指定します。
指定値
フルパスで指定します。
省略値
REPLACEITEMキーを省略した場合は，次のフォルダが仮定されます。
  • Windows環境のとき
    インストール先フォルダ\Server\ReplaceItemフォルダ
  • UNIX／Linux環境のとき
    /var/opt/eur/server/ReplaceItem


SCRIPTCNT

15.2.12　SCRIPTCNT

セクション
[PATH]
設定内容
Acrobat JavaScript定義ファイルを格納したフォルダを指定します。
指定値
フルパスで指定します。
省略値
SCRIPTCNTキーを省略した場合は，次のフォルダが仮定されます。
  • Windows環境のとき
    インストール先フォルダ\Server\ScriptCntフォルダ
  • UNIX／Linux環境のとき
    /var/opt/eur/server/ScriptCnt


PREFERENCE

15.2.13　PREFERENCE

セクション
[PATH]
設定内容
ビューアプレファレンス定義ファイルを格納したフォルダを指定します。
指定値
フルパスで指定します。
省略値
PREFERENCEキーを省略した場合は，次のフォルダが仮定されます。
  • Windows環境のとき
    インストール先フォルダ\Server\Preferenceフォルダ
  • UNIX／Linux環境のとき
    /var/opt/eur/server/Preference


PSENV

15.2.14　PSENV

セクション
[PATH]
設定内容
EUR Server Serviceのサービスごとに環境設定ファイル（EURPS_ENV）を指定する場合，環境設定ファイル（EURPS_ENV）を格納したフォルダを指定します。
指定値
フルパスで指定します。
省略値
PSENVキーを省略した場合は，次のフォルダが仮定されます。
  • Windows環境のとき
    インストール先フォルダ\Server\PSEnvフォルダ
  • UNIX／Linux環境のとき
    /var/opt/eur/server/PSEnv


PDF

15.2.15　PDF

セクション
[PATH]
設定内容
EUR Server Service稼働マシンにPDF形式ファイルを出力する場合の，デフォルトの出力先フォルダを指定します。
指定値
フルパスで指定します。
省略値
PDFキーを省略した場合は，次のフォルダが仮定されます。
  • Windows環境のとき
    インストール先フォルダ\Server\PDFフォルダ
  • UNIX／Linux環境のとき
    /var/opt/eur/server/PDF
注意事項
指定するフォルダには，必ず書き込み権限を設定してください。


PRINTDATE

15.2.16　PRINTDATE

セクション
[PATH]
設定内容
印刷日時出力定義ファイルを格納したフォルダを指定します。
指定値
フルパスで指定します。
省略値
PRINTDATEキーを省略した場合は，次のフォルダが仮定されます。
  • Windows環境のとき
    インストール先フォルダ\Server\PrintDateフォルダ
  • UNIX／Linux環境のとき
    /var/opt/eur/server/PrintDate


SPLIT

15.2.17　SPLIT

セクション
[PATH]
設定内容
分割定義ファイル，または仕分け定義ファイルを格納したフォルダを指定します。
指定値
フルパスで指定します。
省略値
SPLITキーを省略した場合は，次のフォルダが仮定されます。
  • Windows環境のとき
    インストール先フォルダ\Server\Splitフォルダ
  • UNIX／Linux環境のとき
    /var/opt/eur/server/Split


LOGFILE

15.2.18　LOGFILE

セクション
[ERROR]
設定内容
ログファイル（EURPM.log）の出力先フォルダを指定します。
指定値
フルパスで指定します。
省略値
LOGFILEキーを省略した場合は，次のフォルダが仮定されます。
  • Windows環境のとき
    インストール先フォルダ\Logフォルダ
  • UNIX／Linux環境のとき
    /var/opt/eur/log
注意事項
EUR Server Serviceが複数起動している場合は，ログファイル名が「EURPM_<識別名>.log」になります。


LOGLEVEL

15.2.19　LOGLEVEL

セクション
[ERROR]
設定内容
実行ログの出力レベルを指定します。
指定値
指定できる値を次に示します。
  • 0：ログ出力しません。
  • 4：起動，終了，実行時パラメタ，エラーを出力します。
  • 8：起動，終了，実行時パラメタ，エラー，警告を出力します。
  • 16：起動，終了，実行時パラメタ，エラー，警告，情報を出力します。
省略値
LOGLEVELキーを省略した場合は，「8」が仮定されます。
注意事項
出力レベルに「16」を指定すると，トレース情報が大量に出力されるため，性能が落ちるおそれがあります。障害調査時以外には指定しないでください。


LOGSIZE

15.2.20　LOGSIZE

セクション
[ERROR]
設定内容
ログファイル（EURPM.log）のファイルサイズの上限を指定します。
指定値
指定できる値は750～2,000,000です。単位はKBです。
指定できない値を指定した場合は，省略値と同じ値が仮定されます。
省略値
LOGSIZEキーを省略した場合は，「750」が仮定されます。
注意事項
EUR Server Serviceが複数起動している場合は，ログファイル名が「EURPM_<識別名>.log」になります。


PATHMODE

15.2.21　PATHMODE

セクション
[OPTION]
設定内容
帳票サーバに格納するファイルのパスモードを指定します。
指定値
指定できる値を次に示します。
  • 0：通常パスモードを指定します。
  • 1：フルパスモードを指定します。
0，1以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
PATHMODEキーを省略した場合は，「0」が仮定されます。
注意事項
PATHMODEキーを指定するときの注意事項を次に示します。
「0（通常パスモード）」を指定する場合
  • 帳票出力時には，パスを指定しないでファイル名だけを指定してください。
  • 帳票出力時に指定するファイルは，次の表に示すように，EUR Server Serviceの環境設定ファイル（EURPM.ini）で設定しているフォルダに格納しておいてください。

    表15-3　帳票出力時に指定するファイルとファイルの格納先を設定するEUR Server Serviceの環境設定ファイルのキー

    帳票出力時に指定するファイル | EUR Server Serviceの環境設定ファイルのPATHセクションのキー
    接続情報ファイル | DBINFO
    文書情報設定ファイル | DOCINFO
    帳票ファイル | FORM
    複数様式情報定義ファイル | MULTI
    ビューアプレファレンス定義ファイル | PREFERENCE
    印刷日時出力定義ファイル | PRINTDATE
    環境設定ファイル（EURPS_ENV） | PSENV
    置き換え表管理情報ファイル | REPLACEITEM
    Acrobat JavaScript定義ファイル | SCRIPTCNT
    分割定義ファイル，または仕分け定義ファイル | SPLIT
  • PDF形式ファイルの出力先をEUR Server Service稼働マシンにしているときは，EUR Server Serviceの環境設定ファイル（EURPM.ini）のPDFキーで設定しているフォルダにファイルが出力されます。
    PDFキーの詳細については，「15.2.15　PDF」を参照してください。
「1（フルパスモード）」を指定する場合
  • 帳票出力時には，フルパス，相対パス，またはファイル名だけのどれかで指定してください。指定方法は次のとおりです。
    フルパスで指定する場合
    ファイル名をフルパスで指定します。なお，表15-3に示したEUR Server Serviceの環境設定ファイルの設定は無視されます。
    相対パスで指定する場合
    表15-3に示したEUR Server Serviceの環境設定ファイルのキーに設定している起点フォルダ下にあるファイル名を指定します。
    ファイル名だけで指定する場合
    表15-3に示したEUR Server Serviceの環境設定ファイルのキーに設定しているフォルダにあるファイル名を指定します。

  • PDF形式ファイルの出力先をEUR Server Service稼働マシンにしているとき，ファイルの出力先は，次のようになります。
    ファイル名をフルパスで指定する場合
    起動部品で指定したパスに出力されます。なお，環境設定ファイル（EURPM.ini）のPATHセクションのPDFキーには指定が要りません。
    ファイル名を相対パスで指定する場合
    環境設定ファイル（EURPM.ini）のPATHセクションのPDFキーで設定しているフォルダを起点とし，そこから起動部品で指定したパスに出力されます。
    ファイル名だけを指定する場合
    EUR Server Serviceの環境設定ファイル（EURPM.ini）のPATHセクションのPDFキーで設定しているフォルダに出力されます。
PDFキーの詳細については，「15.2.15　PDF」を参照してください。


TEMPFILEDEL

15.2.22　TEMPFILEDEL

セクション
[OPTION]
設定内容
印刷実行時に生成した一時ファイルを削除するかどうかを指定します。
EUR Server Serviceは，印刷実行時にはTEMPキーで設定した作業フォルダに一時ファイルを生成できます。一時ファイルは，障害対策のために使用します。
指定値
指定できる値を次に示します。
  • 0：常に削除します。
  • 1：正常終了時は削除します。異常終了時は削除しません。
  • 2：常に削除しません。
0，1，2以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
TEMPFILEDELキーを省略した場合は，「1」が仮定されます。


SOCKBUFFSIZE

15.2.23　SOCKBUFFSIZE

セクション
[OPTION]
設定内容
ソケット通信に使用する通信バッファサイズの上限を指定します。
指定値
指定できる値は，1～2,000,000です。単位はKBです。
通信バッファサイズの上限を無制限にしたい場合は，「0」を指定してください。
0～2,000,000以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
SOCKBUFFSIZEキーを省略した場合は，「64」が仮定されます。
注意事項
KEEY316-E，KEEY317-E，KEEY318-E，KEEY330-E，またはKEEY335-Eの通信エラーが発生し，かつEURPMログのエラー詳細情報に「errno=10055」が出力されているときは，指定した通信バッファサイズを確保するためのシステムのバッファ領域が不足していることを示しています。エラーが発生したときは，SOCKBUFFSIZEキーに指定されている値を小さく（8～64）して再試行してください。
なお，指定した値によっては，通信性能が変わることがあります。通信性能が劣化する場合は値を変更してチューニングしてください。


SPLITMODE

15.2.24　SPLITMODE

セクション
[OPTION]
設定内容
蓄積時に，帳票を分割または仕分けするかどうかを指定します。
指定値
指定できる値を次に示します。
  • NO：分割または仕分けしないで蓄積します。
  • KEY：帳票を仕分けして蓄積します。
  • PAGE：帳票を分割して蓄積します。
NO，KEY，PAGE以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
SPLITMODEキーを省略した場合は，「NO」が仮定されます。
注意事項
起動部品で帳票を分割または仕分けするかどうかを指定している場合は，起動部品の指定が優先されます。帳票を分割または仕分けするかどうかを指定する起動部品のプロパティ，メソッド，パラメタ，およびコマンドのオプションを次に示します。
  • ActiveX起動部品：SplitModeプロパティ
  • Java起動部品：setSplitModeメソッド
  • COBOL起動部品：SPLITMODEパラメタ
  • コマンド：eurpmcコマンドの/splitオプション
なお，蓄積時に起動部品で分割または仕分けの設定をしていない場合は，SPLITMODEキーに「KEY」または「PAGE」を指定すると，すべての帳票が分割または仕分けして出力されます。


RMDIRRETRYCOUNT

15.2.25　RMDIRRETRYCOUNT

セクション
[OPTION]
設定内容
EUR Server Serviceで作業用一時フォルダの削除に失敗した場合，リトライする回数を指定します。
指定値
指定できる値は0～20です。
「0」を指定した場合，作業用一時フォルダの削除はリトライされません。
0～20以外の値，もしくは数値以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
RMDIRRETRYCOUNTキーを省略した場合は，「0」が仮定されます。


RMDIRINTERVALTIME

15.2.26　RMDIRINTERVALTIME

セクション
[OPTION]
設定内容
EUR Server Serviceで作業用一時フォルダの削除に失敗した場合，リトライするまでの待機時間を指定します。
指定値
指定できる値は100～1,000です。単位はミリ秒です。
100～1,000以外の値，もしくは数値以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
RMDIRINTERVALTIMEキーを省略した場合は，「200」が仮定されます。


GENERAL

15.2.27　GENERAL

セクション
[THREAD]
設定内容
EUR Server Serviceの並列処理数を指定します。
指定値
指定できる値は1～5,000です。
1～5,000以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
GENERALキーを省略した場合は，「200」が仮定されます。
注意事項
GENERALキーに正しい値を設定しても，マシン環境およびほかのプログラムの実行環境によって，設定したとおりの動作をしない場合があります。


EURPS

15.2.28　EURPS

セクション
[THREAD]
設定内容
EUR Print Serviceの並列処理数を指定します。
CPU数に応じてEURPSキーを設定すると，高い並列処理効果が得られます。
指定値
指定できる値は1～5,000です。
1～5,000以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
EURPSキーを省略した場合は，「1」が仮定されます。
注意事項
  • EURPSキーに正しい値を設定しても，マシン環境およびほかのプログラムの実行環境によって，設定したとおりの動作をしない場合があります。
  • EUR Print Serviceを実行するときは，CPU使用率が非常に高くなります。


MERGE

15.2.29　MERGE

セクション
[THREAD]
設定内容
複数のEPF形式ファイルを統合して出力する場合の並列処理数を指定します。
CPU数に応じてMERGEキーを設定すると，高い並列処理効果が得られます。
指定値
指定できる値は0～5,000です。
「0」を指定した場合は，並列処理数を制御しません。
MERGEキーの値は，稼働するEUR Server Serviceのサービスごとに有効になります。
0～5,000以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
MERGEキーを省略した場合は，「0」が仮定されます。
注意事項
  • MERGEキーに正しい値を設定しても，マシン環境およびほかのプログラムの実行環境によって，設定したとおりの動作をしない場合があります。
  • 複数のEPF形式ファイルを統合して出力するときは，CPU使用率が非常に高くなります。


CONNECT

15.2.30　CONNECT

セクション
[TIMEOUT]
設定内容
意図しない接続元が，データ通信を行わないでEUR Server Serviceと接続したままの状態になった場合，切断するまでの時間を指定します（タイムアウト監視）。
指定値
指定できる値は，0～3,600です。単位は秒です。
CONNECTキーに0を指定した場合は，タイムアウト監視はしません。
0～3,600以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
CONNECTキーを省略した場合は，「600（10分）」が仮定されます。
注意事項
通信に時間が掛かり，タイムアウトで切断されてしまう場合は，CONNECTキーの値（タイムアウトの監視時間）を大きくして再試行してください。
なお，指定した値によっては，意図しない接続を切断するのに時間が掛かり，その間ジョブを受け付けられなくなったり，EUR Server Service を停止できなくなったりします。その場合は，値を変更してチューニングしてください。


ERRIGNORE

15.2.31　ERRIGNORE

セクション
[TIMEOUT]
設定内容
ソケットを接続してデータを通信しないで切断する処理（生死監視）が実行された場合に，切断を検知してもエラーを出力しない時間を指定します。
なお，何らかのデータを通信したあとに切断を検知した場合は，エラーが出力されます。
指定値
指定できる値は，0～3,600です。単位は秒です。
ERRIGNOREキーに「0」を指定した場合は，切断を検知すると必ずエラーが出力されます。
0～3,600以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
ERRIGNOREキーを省略した場合は，「3」が仮定されます。
注意事項
通信ポートの監視を実行する場合で，KEEY316-Eのエラーが発生したときは，ERRIGNOREキーの値（切断を検知した場合にエラーを出力しない時間）を大きくして再試行してください。
なお，指定した値によっては，EUR Server - Adapterとの接続が何らかの不具合により切断された場合に，切断を検知できなくなることがあります。その場合は，値を変更してチューニングしてください。


PSENVFILENAME

15.2.32　PSENVFILENAME

セクション
[ENV]
設定内容
EUR Server Serviceのサービスごとに環境設定ファイル（EURPS_ENV）を指定する場合，環境設定ファイル（EURPS_ENV）のファイル名を指定します。
指定値
PSENVFILENAMEキーの指定方法は，PATHMODEキーの設定によって異なります。PATHMODEキーの詳細については，「15.2.21　PATHMODE」を参照してください。PSENVFILENAMEキーの指定方法を次に示します。
  • PATHMODEキーに「0（通常パスモード）」を設定する場合
    ファイル名だけを指定します。
    環境設定ファイル（EURPS_ENV）は，PSENVキーで設定したフォルダに格納してください。
  • PATHMODEキーに「1（フルパスモード）」を設定する場合
    フルパス，相対パス，またはファイル名だけのどれかで指定します。
  • フルパスで指定する場合
    ファイル名をフルパスで指定します。なお，PSENVキーには指定が要りません。
  • 相対パスで指定する場合
    PSENVキーで設定しているフォルダを起点とし，そのフォルダ下にあるファイル名を指定します。
  • ファイル名だけで指定する場合
    PSENVキーで設定しているフォルダにあるファイル名を指定します。
省略値
PSENVFILENAMEキーを省略した場合は，EUR Server Serviceから環境設定ファイル（EURPS_ENV）を指定しないことになります。
注意事項
起動部品で環境設定ファイル（EURPS_ENV）を指定している場合は，起動部品の指定が優先されます。環境設定ファイル（EURPS_ENV）を指定する起動部品のプロパティ，メソッド，パラメタ，およびコマンドのオプションを次に示します。
  • ActiveX起動部品：PSEnvFileNameプロパティ
  • Java起動部品：setPSEnvFileNameメソッド
  • COBOL起動部品：PSENVFILENAMEパラメタ
  • コマンド：eurpmcコマンドの/psenvfオプション


PRINTDATE

15.2.33　PRINTDATE

セクション
[FILE]
設定内容
印刷日時出力定義ファイル名を指定します。
指定値
PRINTDATEキーの指定方法は，PATHMODEキーの設定によって異なります。PATHMODEキーの詳細については，「15.2.21　PATHMODE」を参照してください。PRINTDATEキーの指定方法を次に示します。
  • PATHMODEキーに「0（通常パスモード）」を設定する場合
    ファイル名だけを指定します。
    印刷日時出力定義ファイルは，PATHセクションのPRINTDATEキーで設定したフォルダに格納してください。
  • PATHMODEキーに「1（フルパスモード）」を設定する場合
    フルパス，相対パス，またはファイル名だけのどれかで指定します。
  • フルパスで指定する場合
    ファイル名をフルパスで指定します。なお，PATHセクションのPRINTDATEキーには指定が要りません。
  • 相対パスで指定する場合
    PATHセクションのPRINTDATEキーで設定しているフォルダを起点とし，そのフォルダ下にあるファイル名を指定します。
  • ファイル名だけで指定する場合
    PATHセクションのPRINTDATEキーで設定しているフォルダにあるファイル名を指定します。
省略値
FILEセクションのPRINTDATEキーを省略した場合は，EUR Server Serviceから印刷日時出力定義ファイルを指定しないことになります。この場合，印刷実行時の日時情報を帳票に出力しません。
注意事項
起動部品で印刷日時出力定義ファイルを指定している場合は，起動部品の指定が優先されます。印刷日時出力定義ファイルを指定する起動部品のプロパティ，メソッド，パラメタ，およびコマンドのオプションを次に示します。
  • ActiveX起動部品：PrintDateFileNameプロパティ
  • Java起動部品：setPrintDateFileNameメソッド
  • COBOL起動部品：PRINTDATEFILENAMEパラメタ
  • コマンド：eurpmcコマンドの/prdatefオプション


SPLIT

15.2.34　SPLIT

セクション
[FILE]
設定内容
分割定義ファイルまたは仕分け定義ファイル名を指定します。
指定値
SPLITキーの指定方法は，PATHMODEキーの設定によって異なります。PATHMODEキーの詳細については，「15.2.21　PATHMODE」を参照してください。SPLITキーの指定方法を次に示します。
  • PATHMODEキーに「0（通常パスモード）」を設定する場合
    ファイル名だけを指定します。
    分割定義ファイルまたは仕分け定義ファイルは，PATHセクションのSPLITキーで設定したフォルダに格納してください。
  • PATHMODEキーに「1（フルパスモード）」を設定する場合
    フルパス，相対パス，またはファイル名だけのどれかで指定します。
  • フルパスで指定する場合
    ファイル名をフルパスで指定します。なお，PATHセクションのSPLITキーには指定が要りません。
  • 相対パスで指定する場合
    PATHセクションのSPLITキーで設定しているフォルダを起点とし，そのフォルダ下にあるファイル名を指定します。
  • ファイル名だけで指定する場合
    PATHセクションのSPLITキーで設定しているフォルダにあるファイル名を指定します。
省略値
FILEセクションのSPLITキーを省略した場合は，EUR Server Serviceから分割定義ファイルまたは仕分け定義ファイルを指定しないことになります。
注意事項
起動部品で分割定義ファイルまたは仕分け定義ファイルを指定している場合は，起動部品の指定が優先されます。分割定義ファイルまたは仕分け定義ファイルを指定する起動部品のプロパティ，メソッド，パラメタ，およびコマンドのオプションを次に示します。
  • ActiveX起動部品：SplitFileNameプロパティ
  • Java起動部品：setSplitFileNameメソッド
  • COBOL起動部品：SPLITFILENAMEパラメタ
  • コマンド：eurpmcコマンドの/splitfオプション


環境設定ファイル（EURPS_ENV）

15.3　環境設定ファイル（EURPS_ENV）

対象コンポーネントまたは機能
EUR Server Service
設定内容
EUR Server Serviceでの帳票出力時の動作環境は，環境設定ファイル（EURPS_ENV）でも設定します。
環境設定ファイルの格納場所
環境設定ファイル（EURPS_ENV）は，ユーザの利用目的に応じて指定できます。環境設定ファイル（EURPS_ENV）の指定方法と格納場所を次の表に示します。

表15-4　環境設定ファイル（EURPS_ENV）の指定方法と格納場所

項番 | 指定方法 | ファイル名 | 格納場所
1 印刷ジョブごとにファイルを指定する場合 起動部品で指定したファイル名
  • ActiveX起動部品：PSEnvFileNameプロパティ
  • Java起動部品：setPSEnvFileNameメソッド
  • COBOL起動部品：PSENVFILENAMEパラメタ
  • コマンド：eurpmcコマンドの/psenvfオプション
 起動部品で指定したパス
  • ActiveX起動部品：PSEnvFilePathプロパティ
  • Java起動部品：setPSEnvFilePathメソッド
  • COBOL起動部品：PSENVFILEPATHパラメタ
  • コマンド：eurpmcコマンドの/psenvfオプション
2 | EUR Server Serviceのサービスごとにファイルを指定する場合 | EUR Server Serviceの環境設定ファイル（EURPM.ini）で指定したファイル名 | EUR Server Serviceの環境設定ファイル（EURPM.ini）で指定したディレクトリ
3 | EUR Print Serviceの実行ユーザごとにファイルを指定する場合 | 環境変数 EURPS_ENVFILE で指定したパス | 環境変数EURPS_ENVFILE で指定したパス
4 デフォルト
Windows環境の場合
EURPS_ENV
UNIX／Linux環境の場合
eurps_env
Windows環境の場合
インストール先フォルダ\Print
UNIX／Linux環境の場合
/etc/opt/eur下
環境設定ファイルは複数指定することもできます。複数の環境設定ファイルを指定した場合で，同じ環境変数に異なる値を指定したときは，次の優先順位で設定内容が適用されます。
  1. 起動部品で指定した環境設定ファイルの内容
  2. EUR Server Serviceの環境設定ファイル（EURPM.ini）で指定した環境設定ファイルの内容
  3. 環境変数EURPS_ENVFILEで指定した環境設定ファイルの内容
  4. デフォルトのディレクトリに格納した環境設定ファイルの内容
EUR Server Serviceの環境設定ファイル（EURPM.ini）については，「15.2　環境設定ファイル（EURPM.ini）」を参照してください。
環境設定ファイルの設定手順
環境設定ファイル（EURPS_ENV）の指定方法がデフォルトの場合を例に説明します。
  • Windows環境の場合
    環境設定ファイル（EURPS_ENV）は，インストール先フォルダ\Print下に作成してください。
    ファイルの内容を追加，変更する場合は，メモ帳などのテキスト編集エディタを起動して編集したあと，上書き保存してから使用してください。
  • UNIX／Linux環境の場合
    次に示す環境設定ファイル（eurps_env）のサンプルを，/opt/eur/sample下に提供しています。必要な内容を設定したあと，同じファイル名で/etc/opt/eur下に格納してください。
    なお，/etc/opt/eurには，EUR Server Serviceの実行ユーザが読み書きできるようにアクセス権を設定してください。
＜環境設定ファイル（eurps_env）の設定手順＞
環境設定ファイルは次の手順で設定します。
  1. /opt/eur/sample下にある環境設定ファイル（eurps_env）のサンプルを任意の場所に保存する。
  2. 環境設定ファイルを編集する。
    環境設定ファイルは，マシンのロケールに応じたエンコードで編集してください。
  3. 必要な内容を設定した環境設定ファイルを，サンプルと同じファイル名（eurps_env）で/etc/opt/eur下に格納する。
    /etc/opt/eurには，EUR Server Serviceの実行ユーザが読み書きできるようにアクセス権を設定してください。
環境設定ファイルの構文

変数名=値

環境設定ファイルに指定する情報は，「"」で囲まないでください。
環境設定ファイルの指定例

EURPS_EPFDPI=600
EURPS_EPF_IMAGE_COMPRESS=ON
注意
Windows環境の場合，環境設定ファイル（EURPS_ENV）は，EUR Developer，またはEUR Server製品（EUR Server Print Edition，EUR Server Standard，EUR Server Enterprise）のアンインストールを実行しても削除されません。環境設定ファイルを削除する場合は，エクスプローラなどから直接環境設定ファイルを削除してください。
UNIX，およびLinux対応のEUR Server製品（EUR Server Print Edition，EUR Server Standard，EUR Server Enterprise）のアンインストールについては，製品に添付されているリリースノートを参照してください。
＜この節の構成＞
15.3.1　環境変数一覧
15.3.2　EURPS_LOGFILEPATH
15.3.3　EURPS_LOGSIZE
15.3.4　EURPS_LOGFILELEVEL
15.3.5　EURPS_IMAGEPATH
15.3.6　EURPS_REPORT_WARNING
15.3.7　EURPS_GAIJIFONT
15.3.8　EURPS_PDF_OUTPUT
15.3.9　EURPS_PDF_SAMEIMAGE
15.3.10　EURPS_PDF_IMAGE_OPTIMIZEMEM
15.3.11　EURPS_CSV_PRINT_PERIOD
15.3.12　EURPS_TMPPATH
15.3.13　EURPS_PDL_EXMINFONTPATH
15.3.14　EURPS_PDL_EXGOTFONTPATH
15.3.15　EURPS_TRACE
15.3.16　EURPS_TRACE_DRAWAPI
15.3.17　EURPS_REPORT_LOGERROR
15.3.18　EURPS_REPLACEITEMPATH
15.3.19　EURPS_SKIP_OUTPUTSPACE
15.3.20　EURPS_PRINT
15.3.21　EURPS_CODE39_PARAM
15.3.22　EURPS_CODE128_PARAM
15.3.23　EURPS_QR_CORRECTION_LEVEL
15.3.24　EURPS_QR_VERSION
15.3.25　EURPS_NOSKIP_OUTPUTSPACE
15.3.26　EURPS_QR_CELL_SIZE_D
15.3.27　EURPS_QR_CELL_SIZE_M
15.3.28　EURPS_SCRIPTFILEPATH
15.3.29　EURPS_FIXOPT
15.3.30　EURPS_PRINTERINFPATH
15.3.31　EURPS_USE_05_06_FONT_LANG
15.3.32　EURPS_OUTPUTPDF_VER
15.3.33　EURPS_USE_05_06_FONT_REPLACE
15.3.34　EURPS_FONT_WIDTH_MODE
15.3.35　EURPS_EXCELLOGFILELEVEL
15.3.36　EURPS_EXCELTMPPATH
15.3.37　EURPS_TESTPRINTFILE
15.3.38　EURPS_FONT_ROUNDDOWN
15.3.39　EURPS_MAX_SPOOL_PAGES
15.3.40　EURPS_DONT_PRINT_IF_DB_RESULT_EMPTY
15.3.41　EURPS_PDF_BUFSIZE
15.3.42　EURPS_PDF_IMAGEDRAWUNIT
15.3.43　EURPS_EPFDPI
15.3.44　EURPS_EPF_IMAGE_COMPRESS
15.3.45　EURPS_UPC_BARCODE
15.3.46　EURPS_OUTPUTPATH
15.3.47　EURPS_EXCEL_REPEAT_MODE
15.3.48　ESC/P対応プリンタ出力用の環境変数
15.3.49　環境設定ファイルの指定例


環境変数一覧

15.3.1　環境変数一覧

この項では，次項以降で説明する環境変数を用途別に一覧表で示します。それぞれの表の環境変数はアルファベット順で記載しています。

＜この項の構成＞
(1)　共通で使用する環境変数
(2)　PDF形式ファイルに出力する場合に使用する環境変数
(3)　EPF形式ファイルに出力する場合に使用する環境変数
(4)　Excel形式ファイルに出力する場合に使用する環境変数

(1)　共通で使用する環境変数

共通で使用する環境変数を次に示します。

表15-5　共通で使用する環境変数

環境変数 | 説明
EURPS_CODE128_PARAM | CODE128バーコードのバーコード補正情報を指定します。
EURPS_CODE39_PARAM | CODE39バーコードのバーコード補正情報を指定します。
EURPS_CSV_PRINT_PERIOD | 小数点文字が設定されていない帳票ファイルをCSV形式ファイルに出力する場合，小数点文字を「.」で出力するかどうかを指定します。
EURPS_DONT_PRINT_IF_DB_RESULT_EMPTY | データベースからの抽出件数が0の場合に，帳票を出力しないようにします。
EURPS_FIXOPT | データファイル（FIX形式）の区切り位置をバイトで区切るか，桁で区切るかを指定します。
EURPS_FONT_ROUNDDOWN | 帳票印刷時に使用するフォントサイズについて，帳票設計時に指定された数値の小数部を切り捨てるかどうかを指定します。
EURPS_FONT_WIDTH_MODE | 文字幅の計算方法を指定します。
EURPS_GAIJIFONT | フォントファイルのファイル名を指定します。
EURPS_IMAGEPATH | 画像ファイルのある場所を指定します。
EURPS_J84GA16 ※1※2 | ゴシック体アンク8×16ドットのフォントファイルのファイル名を指定します。
EURPS_J84GA24 ※1※2 | ゴシック体アンク12×24ドットのフォントファイルのファイル名を指定します。
EURPS_J84GA48 ※1 | ゴシック体アンク24×48ドットのフォントファイルのファイル名を指定します。
EURPS_J84GA72 ※1 | ゴシック体アンク36×72ドットのフォントファイルのファイル名を指定します。
EURPS_J84GA96 ※1 | ゴシック体アンク48×96ドットのフォントファイルのファイル名を指定します。
EURPS_J84GK16 ※1※2 | ゴシック体漢字16×16ドットのフォントファイルのファイル名を指定します。
EURPS_J84GK24 ※1※2 | ゴシック体漢字24×24ドットのフォントファイルのファイル名を指定します。
EURPS_J84GK48 ※1 | ゴシック体漢字48×48ドットのフォントファイルのファイル名を指定します。
EURPS_J84GK72 ※1 | ゴシック体漢字72×72ドットのフォントファイルのファイル名を指定します。
EURPS_J84GK96 ※1 | ゴシック体漢字96×96ドットのフォントファイルのファイル名を指定します。
EURPS_J84MA16 ※1※2 | 明朝体アンク8×16ドットのフォントファイルのファイル名を指定します。
EURPS_J84MA24 ※1※2 | 明朝体アンク12×24ドットのフォントファイルのファイル名を指定します。
EURPS_J84MA48 ※1 | 明朝体アンク24×48ドットのフォントファイルのファイル名を指定します。
EURPS_J84MA72 ※1 | 明朝体アンク36×72ドットのフォントファイルのファイル名を指定します。
EURPS_J84MA96 ※1 | 明朝体アンク48×96ドットのフォントファイルのファイル名を指定します。
EURPS_J84MK16 ※1※2 | 明朝体漢字16×16ドットのフォントファイルのファイル名を指定します。
EURPS_J84MK24 ※1※2 | 明朝体漢字24×24ドットのフォントファイルのファイル名を指定します。
EURPS_J84MK48 ※1 | 明朝体漢字48×48ドットのフォントファイルのファイル名を指定します。
EURPS_J84MK72 ※1 | 明朝体漢字72×72ドットのフォントファイルのファイル名を指定します。
EURPS_J84MK96 ※1 | 明朝体漢字96×96ドットのフォントファイルのファイル名を指定します。
EURPS_LOGFILELEVEL | ログファイルへのメッセージ出力レベルを指定します。
EURPS_LOGFILEPATH | ログファイルの出力先の場所を指定します。
EURPS_LOGSIZE | ログファイルのファイルサイズを指定します。
EURPS_MAX_SPOOL_PAGES | 印刷ジョブの最大ページ数を指定します。
EURPS_NOSKIP_OUTPUTSPACE | LIPSIII，およびPostScript対応プリンタへ出力する場合に，空白をスキップするかどうかを指定します。
EURPS_PDL_EXGOTFONTPATH | ゴシック体のEURフォントファイルのファイル名を指定します。
EURPS_PDL_EXMINFONTPATH | 明朝体のEURフォントファイルのファイル名を指定します。
EURPS_PRINT | 出力ページ情報ファイルを出力する場合に，帳票出力をするかどうかを指定します。
EURPS_PRINTERINFPATH | プリンタ定義ファイルのパスを指定します。
EURPS_QR_CELL_SIZE_D | 生成されるQRコードのセルサイズをドット単位で指定します。
EURPS_QR_CELL_SIZE_M | 生成されるQRコードのセルサイズを100分の1ミリメートル単位で指定します。
EURPS_QR_CORRECTION_LEVEL | QRコードの訂正レベルを指定します。
EURPS_QR_VERSION | 生成されるQRコードの最低のバージョンを指定します。
EURPS_REPLACEITEMPATH | 置き換え表ファイルのある場所を指定します。
EURPS_REPORT_LOGERROR | eurpsログを出力できなかった場合に，イベントログやsyslogにメッセージを出力するかどうかを指定します。
EURPS_REPORT_WARNING | 警告要因を記録するかどうかを指定します。
EURPS_TESTPRINTFILE | テスト印刷設定ファイル名を指定します。
EURPS_TMPPATH | 一時ファイル出力先フォルダをフルパスで指定します。
EURPS_TRACE | トレースファイルを出力するかどうかを指定します。
EURPS_TRACE_DRAWAPI | 描画系APIのトレースファイルを出力するかどうかを指定します。
EURPS_UPC_BARCODE | UPCバーコードの出力を有効にするかどうかを指定します。
EURPS_USE_05_06_FONT_LANG | フォントの半角全角判定を文字コードごとにするか，フォントごとにするどうかを指定します。
EURPS_USE_05_06_FONT_REPLACE | 「フォント縦横比を補正する」が設定されていて，文字列アイテムのフォントがMSゴシックでない場合，バージョン05-06以前の動作にするかどうかを指定します。
注※1
ESC/P対応プリンタ出力用の環境変数です。
注※2
ESC/P対応プリンタに出力する場合は，必ず設定してください。

(2)　PDF形式ファイルに出力する場合に使用する環境変数

PDF形式ファイルに出力する場合の環境変数を次に示します。

表15-6　 PDF形式ファイルに出力する場合の環境変数

環境変数 | 説明
EURPS_OUTPUTPATH | PDF形式ファイルを仕分けして出力する場合に，EUR Server Service稼働マシンの出力先フォルダを指定します。
EURPS_OUTPUTPDF_VER | 出力するPDF形式ファイルのバージョンを指定します。
EURPS_PDF_BUFSIZE | PDF形式ファイルを出力するときに使用されるIOバッファサイズを指定します。
EURPS_PDF_IMAGE_OPTIMIZEMEM | 複数の画像アイテムを貼り付けた帳票，または複数のバーコードアイテムを貼り付けた帳票をPDF形式ファイルに出力する場合，メモリリソースを最適化するかどうかを指定します。
EURPS_PDF_IMAGEDRAWUNIT | PDF形式ファイルに画像を出力する場合の位置やサイズの単位を指定します。
EURPS_PDF_OUTPUT | PDF形式ファイルを印刷する場合，ファイルサイズと印刷スピードのどちらを優先するかを指定します。
EURPS_PDF_SAMEIMAGE | 同一の画像アイテムを複数貼り付けた帳票をPDF形式ファイルに出力する場合，ファイルサイズを最適化するかどうかを指定します。
EURPS_SCRIPTFILEPATH | Acrobat JavaScriptファイルのある場所を指定します。
EURPS_SKIP_OUTPUTSPACE | PDF形式ファイルへ出力する場合に，空白をスキップするかどうかを指定します。

(3)　EPF形式ファイルに出力する場合に使用する環境変数

EPF形式ファイルに出力する場合の環境変数を次に示します。

表15-7　EUR形式ファイルに出力する場合の環境変数

環境変数 | 説明
EURPS_EPFDPI | EPF形式ファイルを出力する場合に，解像度（DPI値）を指定します。
EURPS_EPF_IMAGE_COMPRESS | EPF形式ファイルを出力する場合に，画像アイテムやバーコードアイテムなどの画像データを圧縮するかどうかを指定します。

(4)　Excel形式ファイルに出力する場合に使用する環境変数

Excel形式ファイルに出力する場合の環境変数を次に示します。

表15-8　Excel形式ファイルに出力する場合の環境変数

環境変数 | 説明
EURPS_EXCELLOGFILELEVEL | Excel形式ファイルへ出力する場合に，ログファイルへのメッセージ出力レベルを指定します。
EURPS_EXCELTMPPATH | Excel形式ファイルへ出力する場合の，一時フォルダの場所を指定します。
EURPS_EXCEL_REPEAT_MODE | Excel形式ファイルへ出力する場合に，ページ単位でシートを分けるかどうかを指定します。


EURPS_LOGFILEPATH

15.3.2　EURPS_LOGFILEPATH

設定内容
ログファイル（eurps.logおよびEPS-XLSXログ）の出力先フォルダを指定します。
指定値
フルパスで指定します。
環境変数EURPS_LOGFILEPATHに指定したフォルダが存在しない場合は，指定したフォルダが自動的に作成されます。
出力先フォルダの作成については，マニュアル「EUR システム設計ガイド」を参照してください。
省略値
環境変数EURPS_LOGFILEPATHの指定を省略した場合は，次に示す順にファイルを検索します。
  • Windows環境のとき
    インストール先フォルダ\Log
  • UNIX／Linux環境のとき
    /var/opt/eur/logディレクトリ
注意事項
Windows環境の場合は，環境変数EURPS_LOGFILEPATHを設定したあとに，次の事項を確認してください。
  • 指定した出力先フォルダに，実行，および書き込み権限があるかどうかを確認
    出力先フォルダには，書き込み権限を与えてください。
  • 指定した出力先フォルダに既存のログファイルがある場合，そのログファイルに書き込み権限があるかどうかを確認
    既存のログファイルに上書きする場合は，書き込み権限を与えてください。


EURPS_LOGSIZE

15.3.3　EURPS_LOGSIZE

設定内容
ログファイル（eurps.log）のファイルサイズを指定します。
指定値
指定できるファイルサイズは，3,000～2,000,000です。単位はKBです。
指定できるファイルサイズの範囲外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
環境変数EURPS_LOGSIZEの指定を省略した場合は，「3,000」が仮定されます。
注意事項
ログファイルのファイルサイズは，印刷ページ総数量ではなく，印刷要求数（印刷ジョブ数）に依存してログの採取量が変わります。そのため，業務システム上の一日当たりの印刷要求数などを目安にしたり，システム保守上，保存できる期限も考慮したりして，ログファイルのファイルサイズを見積もってください。
例えば，印刷要求数の一日平均を1,000回，1回の実行で出力するファイル容量を1.5KBとした場合，5日間分のログを記録するためには，
「1.5（KB）×1,000（回）×5（日）＝7,500（KB）」のファイルサイズが必要になります。


EURPS_LOGFILELEVEL

15.3.4　EURPS_LOGFILELEVEL

設定内容
ログファイル（eurps.log）へのメッセージ出力レベルを指定します。
指定値
次に示す2種類のメッセージ出力レベルを指定することで，出力されるメッセージの内容を選択できます。

表15-9　 メッセージ出力レベル

環境変数の設定値 | 出力されるメッセージの内容
INFO | エラーレベル（Error（Err））と情報レベル（Information（Inf））のログを出力します（デフォルト）。
ERROR | エラーレベル（Error（Err））だけを出力します。
警告発生時のエラー（Warning（War））を出力する場合は，「INFO」を指定します。
省略値
環境変数EURPS_LOGFILELEVELの指定を省略した場合は，「INFO」が仮定されます。


EURPS_IMAGEPATH

15.3.5　EURPS_IMAGEPATH

設定内容
画像ファイルのデフォルトの読み込みフォルダを指定します。
なお，データファイルに記載する画像ファイル名は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。
  • ファイル名をフルパスで指定した場合
    設定されているフォルダから画像ファイルを読み込みます。
  • ファイル名を相対パスで指定した場合
    環境変数EURPS_IMAGEPATHに設定されているフォルダからの相対パスとして画像ファイルを読み込みます。
  • ファイル名だけ指定した場合
    環境変数EURPS_IMAGEPATHに設定されているフォルダ下の画像ファイルを読み込みます。
指定値
画像ファイルのデフォルトの読み込みフォルダを，フルパスで指定します。
省略値
環境変数EURPS_IMAGEPATHの指定を省略した場合は，次に示す順にファイルを検索します。
  • Windows環境のとき
  • 環境設定ファイル（EURPS_ENV）中の変数EURPS_IMAGEPATHに設定されているフォルダ
  • EUR Developer，EUR Server Enterprise，EUR Server Standard，またはEUR Server Print Editionのインストール先フォルダ\Print
  • UNIX／Linux環境のとき
  • 環境設定ファイル（eurps_env）中の変数EURPS_IMAGEPATHに設定されているディレクトリ
  • ホームディレクトリ（環境変数HOMEで指定）
  • /var/opt/eurディレクトリ


EURPS_REPORT_WARNING

15.3.6　EURPS_REPORT_WARNING

設定内容
警告要因を記録するかどうかを指定します。
EUR サーバ帳票出力機能では，コマンドを実行した時に警告要因があっても，終了コード4を返してコマンドは正しく終了し，帳票出力も正常に行われます。そのため，環境変数EURPS_REPORT_WARNINGは，警告要因を知らせる必要がある場合だけ，終了コード4を返すように設定できます。終了コードについては，マニュアル「EUR システム設計ガイド」を参照してください。
指定値
環境変数の設定値は，すべて半角英大文字で指定します。

表15-10　 EURPS_REPORT_WARNINGの設定値

環境変数の設定値 | 警告発生時の状況
YES | 警告要因がある場合，終了コード4を返して終了します（デフォルト）。終了コード4を返すことで，何らかのエラー要因があったことを示します。
NO | 警告要因があっても，終了コード0を返して終了します。
YES，NO以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
環境変数EURPS_REPORT_WARNINGの指定を省略した場合は，「YES」が仮定されます。
注意事項
環境変数EURPS_REPORT_WARNINGの設定は，プリンタに出力する場合，およびPDF形式ファイルへ出力する場合に効果があります。EUR形式ファイルへ出力する場合は，環境変数EURPS_REPORT_WARNINGに「YES」を指定しても，終了コード0を返して終了します。


EURPS_GAIJIFONT

15.3.7　EURPS_GAIJIFONT

設定内容
Windows環境，HP-UX環境，またはAIX環境の場合，外字を定義したファイルを指定します。
指定値
  • Windows環境の場合
    外字ファイル（*.tte）をフルパス，相対パス，またはファイル名で指定します。ファイル名をフルパスで指定しなかった場合は，カレントディレクトリを起点としてファイルを検索します。
  • HP-UX環境の場合
    HP-UX外字ツールを使用して作成したフォントファイル（*.pcf）をフルパスで指定します。
  • AIX環境の場合
    AIX外字ツールを使用して登録したフォントファイル（*.pcf）をフルパスで指定します。フォントファイルは圧縮形式ファイルです。そのため，EUR サーバ帳票出力機能で使用できるように，非圧縮形式ファイルに解凍してから環境変数「EURPS_GAIJIFONT」に設定します。
省略値
環境変数EURPS_GAIJIFONTの指定を省略した場合は，未指定となります。
注意事項
EUR Clientなどのビューアが存在する製品と連携している場合は，環境変数EURPS_GAIJIFONTの指定が無効になります。ビューアの存在する環境に外字を定義したファイルを用意してください。


EURPS_PDF_OUTPUT

15.3.8　EURPS_PDF_OUTPUT

設定内容
PDF形式ファイルを印刷する場合，ファイルサイズと印刷スピードのどちらを優先するかを指定します。
図形（網掛け）のある帳票をPDF形式ファイルに出力し，非PostScriptプリンタから印刷する場合，印刷に時間が掛かることがあります。このような場合，環境変数EURPS_PDF_OUTPUTに「PRINT_SPEED」を設定しておくことで，印刷時間を短縮できます。
指定値
環境変数の設定値は，すべて半角英大文字で指定します。

表15-11　 EURPS_PDF_OUTPUTの設定値

環境変数の設定値 | 説　　明
FILE_SIZE | ファイルサイズを優先します（デフォルト）。
PRINT_SPEED | 印刷スピードを優先します。ただし，「FILE_SIZE」を指定した時よりファイルサイズが大きくなることがあります。
FILE_SIZE，PRINT_SPEED以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
環境変数EURPS_PDF_OUTPUTの指定を省略した場合は，「FILE_SIZE」が仮定されます。
注意事項
図形（網掛け）のある帳票をPDF形式ファイルに出力しても，次に示す場合は，環境変数EURPS_PDF_OUTPUTの設定内容は有効になりませんのでご注意ください。
  • Adobe Readerで閲覧するだけの場合
  • PostScript対応プリンタに出力する場合


EURPS_PDF_SAMEIMAGE

15.3.9　EURPS_PDF_SAMEIMAGE

設定内容
同一の画像アイテムを複数貼り付けた帳票をPDF形式ファイルに出力する場合，ファイルサイズを最適化するかどうかを指定します。
指定値
環境変数の設定値は，すべて半角英大文字で指定します。

表15-12　 EURPS_PDF_SAMEIMAGEの設定値

環境変数の設定値 | 説　　明
OPTIMIZE | 帳票に同一の画像データが貼り付けてある場合，ファイルサイズを最適化します。
NO | 帳票に同一の画像データが貼り付けてある場合，ファイルサイズを最適化しません。
OPTIMIZE，NO以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
環境変数EURPS_PDF_SAMEIMAGEの指定を省略した場合は，「OPTIMIZE」が仮定されます。
注意事項
  • 同一の画像アイテムを複数貼り付けた帳票をPDF形式ファイルに出力する場合は，複数分の画像データをPDF形式ファイルに出力するため，ファイルサイズが大きくなります。そのため，環境変数EURPS_PDF_SAMEIMAGEに「OPTIMIZE」を設定すると，一つ分の画像データだけをPDF形式ファイルに出力するので，ファイルサイズが小さくなります。
    ただし，別々の画像アイテムを画像データに貼り付けた帳票をPDF形式ファイルに出力する場合は，環境変数EURPS_PDF_SAMEIMAGEに「NO」を設定したときに比べて，PDF形式ファイルの出力時間が遅くなるときがあります。
  • Adobe Readerで閲覧する場合や，プリンタに出力する場合には，環境変数EURPS_PDF_SAMEIMAGEへの設定は，何も影響がありません。


EURPS_PDF_IMAGE_OPTIMIZEMEM

15.3.10　EURPS_PDF_IMAGE_OPTIMIZEMEM

設定内容
複数の画像アイテムを貼り付けた帳票，または複数のバーコードアイテムを貼り付けた帳票をPDF形式ファイルに出力する場合，メモリリソースを最適化するかどうかを指定します。
指定値
環境変数の設定値は，すべて半角英大文字で指定します。

表15-13　 EURPS_PDF_IMAGE_OPTIMIZEMEMの設定値

環境変数の設定値 | 説　　明
YES | 複数の画像アイテムを貼り付けた帳票，または複数のバーコードアイテムを貼り付けた帳票をPDF形式ファイルに出力する時，メモリリソースを最適化にします。
YES以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
環境変数EURPS_PDF_IMAGE_OPTIMIZEMEMの指定を省略した場合は，メモリリソースの最適化はしません。
注意事項
  • 複数の画像アイテムを貼り付けた帳票，または複数のバーコードアイテムを貼り付けた帳票をPDF形式ファイルに出力する場合，メモリ上に複数分の画像データ，またはバーコードデータを確保してPDF形式ファイルを出力するため，メモリリソースを圧迫します。そのため，環境変数EURPS_PDF_IMAGE_OPTIMIZEMEMに「YES」を設定しておくと，メモリリソースの圧迫を回避できます。
    ただし，メモリリソースの最適化処理を行う場合，一時ファイル（Windows環境の場合はSystemTemp，UNIX／Linux環境の場合は/tmp）を使用するため，環境変数EURPS_PDF_IMAGE_OPTIMIZEMEMに「YES」を設定しないときに比べて，PDF形式ファイルの出力時間が遅くなります。
  • Adobe Readerで閲覧する場合や，プリンタに出力する場合には，環境変数EURPS_PDF_IMAGE_OPTIMIZEMEMへの設定は，何も影響がありません。
  • 環境変数EURPS_PDF_IMAGE_OPTIMIZEMEMは，1ページの帳票には効果がありません。2ページ以上の帳票をPDF形式ファイルに出力する場合に，効果があります。


EURPS_CSV_PRINT_PERIOD

15.3.11　EURPS_CSV_PRINT_PERIOD

設定内容
数値データの修飾で，小数点文字に何も指定されていない帳票をCSV形式ファイルに出力する場合に，小数点文字を「.」で出力するかどうかを指定します。
指定値
環境変数の設定値は，すべて半角英大文字で指定します。

表15-14　 EURPS_CSV_PRINT_PERIODの設定値

環境変数の設定値 | 説　　明
YES | 数値データの修飾で，小数点文字に何も指定されていない帳票をCSV形式ファイルに出力する場合，小数点文字を「.」で出力します。
YES以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
環境変数EURPS_CSV_PRINT_PERIODの指定を省略した場合は，小数点文字は出力されません。
注意事項
  • 数値データの修飾で，小数点文字に何も指定されていない帳票を，プリンタから印刷した場合は，「nnn△n（△は半角空白）」のように，小数点文字を半角空白に置き換えられます。しかし，CSV形式ファイルに出力した場合は，小数点文字の部分を詰めて出力されるため，整数部分と小数部分が区別できません。そのため，環境変数EURPS_CSV_PRINT_PERIODに「YES」を設定しておくと，小数点文字を「.」で出力できます。
  • 数値データの修飾で，小数点文字が指定されている場合は，環境変数EURPS_CSV_PRINT_PERIODの指定に関係なく，指定されている小数点文字でCSV形式ファイルに出力されます。また，プリンタ出力，PDF形式ファイル出力，およびEUR形式ファイル出力する場合は，環境変数EURPS_CSV_PRINT_PERIODの指定は無視されます。
  • 環境変数EURPS_CSV_PRINT_PERIODに「YES」を指定して，CSV形式ファイルに出力する場合，アイテム枠から文字列がはみ出して出力されることがあります。例えば，小数点文字を指定しないで，6桁のデータが出力されるようにアイテム枠の幅を設定している場合，環境変数EURPS_CSV_PRINT_PERIODに「YES」を指定してCSV形式ファイルに出力すると，「123.456」のデータは，小数点文字「.」を含んだ7桁と見なされるため，アイテム枠からはみ出て出力されます。なお，アイテム枠から文字列がはみ出しても，アイテム枠の高さによって，折り曲げて表示したり，「******」で出力したりしないで，そのまま「123.456」がCSV形式ファイルに出力されます。
    また，数値データに桁数が指定されている場合，指定された桁数を超えてしまっても，指定されている桁数を無視してCSV形式ファイルに出力されます。
    どちらの場合も，EUR Print Serviceは正常終了と見なして，終了コード0を返します。


EURPS_TMPPATH

15.3.12　EURPS_TMPPATH

設定内容
一時ファイルの出力先フォルダを指定します。
指定値
フルパスで指定します。
省略値
環境変数EURPS_TMPPATHの指定を省略した場合のデフォルトの一時フォルダは，システムの一時フォルダです。
注意事項
次に示す場合，環境変数EURPS_TMPPATHに設定されているフォルダに，一時ファイルが出力されます。
  • 画像ファイルまたはバーコードを含むPDF形式ファイルを出力する場合
  • データベースと連携してファイル出力する場合
  • EUR Server Serviceと連携してファイル出力する場合
  • UNIX／Linux環境でのPDF出力で，環境変数EURPS_PDF_IMAGE_OPTIMIZEMEMに「YES」を指定した場合


EURPS_PDL_EXMINFONTPATH

15.3.13　EURPS_PDL_EXMINFONTPATH

設定内容
帳票出力で出力できない文字（外字）がある場合に，出力できない文字を収録した明朝体のEURフォントファイル（*.edf）を指定します。
指定値
フルパスで指定します。
省略値
環境変数EURPS_PDL_EXMINFONTPATHの指定を省略した場合は，未指定となります。
注意事項
  • EURフォントファイルを指定すると，出力できない文字の文字イメージがEURフォントファイルから取得され，画像データとして出力されます。該当する文字パターンが収録されていない場合は，空白が出力されます。
  • EURフォントファイルは，EURフォントファイル作成ツールを使用して作成します。EURフォントファイルの作成については，「11.15　EURフォントファイル」を参照してください。


EURPS_PDL_EXGOTFONTPATH

15.3.14　EURPS_PDL_EXGOTFONTPATH

設定内容
帳票出力で出力できない文字（外字）がある場合に，出力できない文字を収録したゴシック体のEURフォントファイル（*.edf）を指定します。
指定値
フルパスで指定します。
省略値
環境変数URPS_PDL_EXGOTFONTPATHの指定を省略した場合は，未指定となります。
注意事項
  • EURフォントファイルを指定すると，出力できない文字の文字イメージがEURフォントファイルから取得され，画像データとして出力されます。該当する文字パターンが収録されていない場合は，空白が出力されます。
  • EURフォントファイルは，EURフォントファイル作成ツールを使用して作成します。EURフォントファイルの作成については，「11.15　EURフォントファイル」を参照してください。


EURPS_TRACE

15.3.15　EURPS_TRACE

設定内容
トレースファイルを出力するかどうかを指定します。
トレースファイルについては，マニュアル「EUR システム設計ガイド」を参照してください。
指定値
環境変数の設定値は，すべて半角英大文字で指定します。

表15-15　 EURPS_TRACEの設定値

環境変数の設定値 | 説明
YES | トレースファイルを出力します。
NO | トレースファイルを出力しません。
YES，NO以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
環境変数EURPS_TRACEの指定を省略した場合は，「YES」が仮定されます。


EURPS_TRACE_DRAWAPI

15.3.16　EURPS_TRACE_DRAWAPI

設定内容
描画系APIのトレースファイルを出力するかどうかを指定します。
トレースファイルについては，マニュアル「EUR システム設計ガイド」を参照してください。
指定値
環境変数の設定値は，すべて半角英大文字で指定します。

表15-16　 EURPS_TRACE_DRAWAPIの設定値

環境変数の設定値 | 説明
YES | 描画系APIのトレースファイルを出力します。
NO | 描画系APIのトレースファイルを出力しません。
YES，NO以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
環境変数EURPS_TRACE_DRAWAPIの指定を省略した場合は，「NO」が仮定されます。


EURPS_REPORT_LOGERROR

15.3.17　EURPS_REPORT_LOGERROR

設定内容
eurpsログを出力できなかった場合に，Windows環境のときはイベントログ，UNIX／Linux環境のときはsyslogに，メッセージを出力するかどうかを指定します。
eurpsログについては，マニュアル「EUR システム設計ガイド」を参照してください。
指定値
環境変数の設定値は，すべて半角英大文字で指定します。

表15-17　 EURPS_REPORT_LOGERRORの設定値

環境変数の設定値 | 説明
YES | イベントログにメッセージを出力します。
NO | イベントログにメッセージを出力しません。
YES，NO以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
環境変数EURPS_REPORT_LOGERRORの指定を省略した場合は，「YES」が仮定されます。


EURPS_REPLACEITEMPATH

15.3.18　EURPS_REPLACEITEMPATH

設定内容
置き換え表ファイルのデフォルトの読み込みフォルダを指定します。
なお，置き換え表管理情報ファイルに記載する置き換え表ファイル名は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。
  • ファイル名をフルパスで指定した場合
    設定されているフォルダから置き換え表ファイルを読み込みます。
  • ファイル名を相対パスで指定した場合
    環境変数EURPS_REPLACEITEMPATHに設定されているフォルダからの相対パスとして置き換え表ファイルを読み込みます。
  • ファイル名だけ指定した場合
    環境変数EURPS_REPLACEITEMPATHに設定されているフォルダ下の置き換え表ファイルを読み込みます。
指定値
置き換え表ファイルのデフォルトの読み込みフォルダを，フルパスで指定します。
省略値
環境変数EURPS_REPLACEITEMPATHの指定を省略した場合は，次に示す順にファイルを検索します。
  • Windows環境のとき
  • 環境設定ファイル（EURPS_ENV）中の変数EURPS_REPLACEITEMPATHに設定されているフォルダ
  • EUR Developer，EUR Server Enterprise，EUR Server Standard，またはEUR Server Print Editionのインストール先フォルダ\Print
  • UNIX／Linux環境のとき
  • 環境設定ファイル（eurps_env）中の変数EURPS_REPLACEITEMPATHに設定されているディレクトリ
  • ホームディレクトリ（環境変数HOMEで指定）
  • /var/opt/eurディレクトリ
注意事項
環境変数EURPS_REPLACEITEMPATHに設定されているフォルダが存在しない場合は，エラー（KEEU060-E）になります。


EURPS_SKIP_OUTPUTSPACE

15.3.19　EURPS_SKIP_OUTPUTSPACE

設定内容
帳票をPDF形式ファイルに出力する場合，空白をスキップするかどうかを指定します。
環境変数EURPS_SKIP_OUTPUTSPACEは，桁数指定またはCPI指定があるアイテムにだけ有効な指定です。
指定値
環境変数の設定値は，すべて半角英大文字で指定します。

表15-18　 EURPS_SKIP_OUTPUTSPACEの設定値

環境変数の設定値 | 説明
YES | 空白をスキップします。
NO | 空白をスキップしません。
「YES」を指定すると不要な空白が削除されるため，PDF形式ファイルに出力する速度が上がります。また，ファイルサイズも小さくなります。
YES，NO以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
環境変数EURPS_SKIP_OUTPUTSPACEの指定を省略した場合は，「YES」が仮定されます。


EURPS_PRINT

15.3.20　EURPS_PRINT

設定内容
出力ページ情報ファイル出力時に帳票出力を行うかどうかを指定します。
指定値

表15-19　 EURPS_PRINTの設定値

環境変数の設定値 | 説明
YES | 出力ページ情報ファイル出力時に帳票出力を行います。
NO | 出力ページ情報ファイル出力時に帳票出力を行いません。
YES，NO以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
環境変数EURPS_PRINTの指定を省略した場合は，「YES」が仮定されます。
注意事項
出力ページ情報ファイル出力の指定がない場合は，環境変数EURPS_PRINTの指定は無効となり，帳票出力が行われます。


EURPS_CODE39_PARAM

15.3.21　EURPS_CODE39_PARAM

設定内容
CODE39バーコードのバーコード補正情報を指定します。
次に示す形式で指定します。
type〔,〔エレメント幅比〕,〔Param〕〕
環境変数EURPS_CODE39_PARAMとプリンタ定義ファイルのキーワードCODE39PARAMが同時に指定された場合は，プリンタ定義ファイルの指定が有効になります。
プリンタ定義ファイルの詳細については，「11.5　プリンタ定義ファイル」を参照してください。
指定値
type
エレメント幅の求め方を指定します。
指定値 | 説明
0 細エレメントのサイズから計算された1文字の幅から，細エレメント，太エレメントを計算します。
計算の結果発生したずれはすべてキャラクタ間ギャップに追加されるため，サイズは自由に調整できます。
1 細エレメントのサイズをドット単位に変換した値と，細エレメント，太エレメント，キャラクタ間ギャップの比から，各バーの太さを計算します。
各バーの太さはドットで計算されるため，サイズの調整は段階的になります。
2 | 1を指定した場合の計算方法に加えて，バーコードの線の太さを補正します。
0，1，2以外の値を指定した場合は，省略値と同じ値が仮定されます。
エレメント幅比
細エレメント，太エレメント，およびキャラクタ間ギャップの比率を指定します。次に示す形式で指定します。

細エレメント：太エレメント：キャラクタ間ギャップ
細エレメントには，1以上の値を指定してください。
太エレメントには，細エレメントの2.0～3.0倍の値を指定してください。
キャラクタ間ギャップには，細エレメントの値以上の値を指定してください。
エレメント幅比を正しく指定していない場合は，省略値と同じ値が仮定されます。
Param
typeに「2」を指定した場合，バーコードの線の太さを細く補正する幅をミリメートル単位で指定します。指定した値をドット単位に変換した計算値の小数第一位を四捨五入した値が補正されます。計算されたドット数の分だけ黒バーが細く，白バーが太くなります。
バーコードの線の太さは，補正するドット数の計算結果が1以上の場合に補正されます。
Paramに指定した値をドット単位に変換する計算式を次に示します。
計算値（ドット） = Paramに指定する値 ÷ 25.4 ×解像度（dpi）
解像度300dpiの場合，補正するドット数の計算結果を次に示します。

表15-20　解像度300dpiの場合に補正するドット数

Paramに指定する値（ミリメートル） | 補正するドット数（ドット） | 計算値（ドット）
0.04 | 0 | 0.472441
0.041 | 0 | 0.484252
0.042 | 0 | 0.496063
0.043 | 1 | 0.507874
0.044 | 1 | 0.519685
0.045 | 1 | 0.531496
0.046 | 1 | 0.543307
解像度600dpiの場合，補正するドット数の計算結果を次に示します。

表15-21　解像度600dpiの場合に補正するドット数

Paramに指定する値（ミリメートル） | 補正するドット数（ドット） | 計算値（ドット）
0.02 | 0 | 0.472441
0.021 | 0 | 0.496063
0.022 | 1 | 0.519685
0.023 | 1 | 0.543307
0.024 | 1 | 0.566929
0.025 | 1 | 0.590551
0.026 | 1 | 0.614173
Paramには1モジュール以上のドット数の幅は指定できません。Paramに指定した値が1モジュール以上のドット数になる場合は，1ドットが指定されます。
省略値
  • typeの指定を省略した場合，typeの値は「0」が仮定されます。
  • エレメント幅比の指定を省略した場合は，エレメント幅はtypeに「0」が指定されたときの方法で計算されます。
  • Paramの指定を省略した場合は，未指定となります。
注意事項
  • typeに「2」を指定した場合でも，Paramを指定しなかったときは，エレメント幅はtypeに「1」が指定されたときの方法で計算されます。
  • 環境変数EURPS_CODE39_PARAMは，バージョン05-06以降で指定できます。05-05以前のバージョンでは，自動的にtypeに「0」が指定された場合と同じ計算方法でエレメント幅が決定します。


EURPS_CODE128_PARAM

15.3.22　EURPS_CODE128_PARAM

設定内容
CODE128バーコードのバーコード補正情報を指定します。
次に示す形式で指定します。
type〔,〔Param1〕,〔Param2〕〕
環境変数EURPS_CODE128_PARAMとプリンタ定義ファイルのキーワードCODE128PARAMが同時に指定された場合は，プリンタ定義ファイルの指定が有効になります。
プリンタ定義ファイルの詳細については，「11.5　プリンタ定義ファイル」を参照してください。
指定値
type
バーコードの描画方式を指定します。
指定値 | 説明
0 | ミリメートル（mm）で指定したモジュールサイズからバーキャラクタサイズを計算します。モジュールサイズ×11（mm）を超えないドット数でバーキャラクタを描画します。ストップキャラクタは，モジュールサイズ×13（mm）を超えないドット数で描画します。1を指定した場合と比べて，サイズを細かく指定できますが，バーコードの質は落ちます。
1 | ミリメートル（mm）で指定したモジュールサイズを超えないドット数を求め，その11倍をバーキャラクタのサイズにします。1ドットの大きさを超えるまではバーコードの大きさは変わりません。プリンタ解像度によって補正するドット数が変わります。
2 1を指定した場合の計算方法に加えて，Param1で指定した幅に相当するドット数分だけ黒バーを細く，白バーを太くします。
Param2を指定した場合は，Param1で指定した値で補正した状態のスタートキャラクタとストップキャラクタにParam2で指定した値でさらに補正します。
0，1，2以外の値を指定した場合は，省略値と同じ値が仮定されます。
typeに「0」を指定した場合，Param1，およびParam2に指定した値は無視されます。
Param1
typeに「2」を指定した場合，バーを調整する幅をミリメートルで指定します。指定した値をドット単位に変換した計算値の小数第一位を四捨五入した値が補正されます。補正するドット数の計算結果が1以上の場合だけ補正されます。
Param1に指定した値をドット単位に変換する計算式を次に示します。
計算値（ドット） = Param1に指定する値 ÷ 25.4 ×解像度（dpi）
解像度300dpiの場合，補正するドット数の計算結果を次に示します。

表15-22　解像度300dpiの場合に補正するドット数

Param1またはParam2に指定する値（ミリメートル） | 補正するドット数（ドット） | 計算値（ドット）
0.04 | 0 | 0.472441
0.041 | 0 | 0.484252
0.042 | 0 | 0.496063
0.043 | 1 | 0.507874
0.044 | 1 | 0.519685
0.045 | 1 | 0.531496
0.046 | 1 | 0.543307
解像度600dpiの場合，補正するドット数の計算結果を次に示します。

表15-23　解像度600dpiの場合に補正するドット数

Param1またはParam2に指定する値（ミリメートル） | 補正するドット数（ドット） | 計算値（ドット）
0.02 | 0 | 0.472441
0.021 | 0 | 0.496063
0.022 | 1 | 0.519685
0.023 | 1 | 0.543307
0.024 | 1 | 0.566929
0.025 | 1 | 0.590551
0.026 | 1 | 0.614173
Param2
typeに「2」を指定した場合，Param1で指定した値で補正したスタートキャラクタとストップキャラクタを調整する幅をミリメートルで指定します。指定した値をドット単位に変換した計算値の小数第一位を四捨五入した値が補正されます。補正するドット数の計算結果が1以上の場合だけ補正されます。Param2に指定した値をドット単位に変換する計算式はParam1の場合と同じです。
解像度別の補正するドット数については，Param1の表を参照してください。
省略値
typeの指定を省略した場合，typeの値は「0」が仮定されます。
注意事項
バーの幅を超える値を指定した場合は，バーの幅を1ドットに設定します。
typeに「1」を指定した場合でも，Param1に数値を指定して，Param2を省略したときは0が仮定されます。
typeに「2」を指定した場合でも，次のときは0が仮定されます。
  • Param1を指定しなかったとき
  • Param1が数値以外，または0以下だったとき
typeに「2」を指定した場合でも，Param1に0より大きい値，Param2に0以下の値を指定したときはParam2は無視されます。


EURPS_QR_CORRECTION_LEVEL

15.3.23　EURPS_QR_CORRECTION_LEVEL

設定内容
QRコードの訂正レベルを指定します。
指定値

表15-24　 EURPS_QR_CORRECTION_LEVELの設定値

環境変数の設定値 | 説明
M | 訂正レベルMでQRコードを生成します。
Q | 訂正レベルQでQRコードを生成します。
M，Q以外の値を指定した場合は，「M」が仮定されます。
省略値
環境変数EURPS_QR_CORRECTION_LEVELの指定を省略した場合は，「M」が仮定されます。


EURPS_QR_VERSION

15.3.24　EURPS_QR_VERSION

設定内容
生成されるQRコードの最低のバージョンを指定します。
指定値

表15-25　 EURPS_QR_VERSIONの設定値

環境変数の設定値 | 説明
0 | 最低のバージョンは入力データから自動的に決定されます。
1～40 | 指定した値が最低のバージョンになります。
0，または1～40以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
環境変数EURPS_QR_VERSIONの指定を省略した場合は，「0」が仮定されます。


EURPS_NOSKIP_OUTPUTSPACE

15.3.25　EURPS_NOSKIP_OUTPUTSPACE

設定内容
LIPSIII，およびPostScript対応プリンタへ出力する場合に，空白をスキップするかどうかを指定します。
指定値

表15-26　 EURPS_NOSKIP_OUTPUTSPACEの設定値

環境変数の設定値 | 説明
YES | LIPSIII，およびPostScript対応プリンタへ出力する場合に，空白をスキップしません。
NO | LIPSIII，およびPostScript対応プリンタへ出力する場合に，空白をスキップします。
「YES」を指定すると不要な空白が削除されるため，LIPSIII，およびPostScript対応プリンタに出力する速度が上がります。また，UNIX／Linux環境で出力する場合は，ファイルサイズが小さくなります。
YES，NO以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
環境変数EURPS_NOSKIP_OUTPUTSPACEの指定を省略した場合は，「YES」が仮定されます。


EURPS_QR_CELL_SIZE_D

15.3.26　EURPS_QR_CELL_SIZE_D

設定内容
生成されるQRコードのセルサイズ（1セル当たりの大きさ）をドット単位で指定します。
指定値

表15-27　 EURPS_QR_CELL_SIZE_Dの設定値

環境変数の設定値 | 説明
0 | セルサイズはアイテムの大きさとバージョンから自動的に決定されます。
5～10 | 指定した値がセルサイズになります。
0，または5～10以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
環境変数EURPS_QR_CELL_SIZE_Dの指定を省略した場合は，「0」が仮定されます。
注意事項
  • 環境変数EURPS_QR_CELL_SIZE_Dと環境変数EURPS_QR_CELL_SIZE_Mを同時に指定した場合は，環境変数EURPS_QR_CELL_SIZE_Mの指定値が有効となります。
  • 環境変数EURPS_QR_CELL_SIZE_Dとプリンタ定義ファイルのキーワードQRCellSizeDでセルサイズを同時に指定した場合は，プリンタ定義ファイルのキーワードQRCellSizeDの指定値が有効となります。
    プリンタ定義ファイルの詳細については，「11.5　プリンタ定義ファイル」を参照してください。


EURPS_QR_CELL_SIZE_M

15.3.27　EURPS_QR_CELL_SIZE_M

設定内容
生成されるQRコードのセルサイズ（1セル当たりの大きさ）を100分の1ミリメートル単位で指定します。
指定値

表15-28　 EURPS_QR_CELL_SIZE_Mの設定値

環境変数の設定値 | 説明
0 | セルサイズはアイテムの大きさとバージョンから自動的に決定されます。
21～126 | 指定した値がセルサイズになります。
0，または21～126以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
環境変数EURPS_QR_CELL_SIZE_Mの指定を省略した場合は，「0」が仮定されます。
注意事項
  • 環境変数EURPS_QR_CELL_SIZE_Mと環境変数EURPS_QR_CELL_SIZE_Dを同時に指定した場合は，環境変数EURPS_QR_CELL_SIZE_Mの指定値が有効となります。
  • 環境変数EURPS_QR_CELL_SIZE_Mとプリンタ定義ファイルのキーワードQRCellSizeMでセルサイズを同時に指定した場合は，プリンタ定義ファイルのキーワードQRCellSizeMの指定値が有効となります。
    プリンタ定義ファイルの詳細については，「11.5　プリンタ定義ファイル」を参照してください。


EURPS_SCRIPTFILEPATH

15.3.28　EURPS_SCRIPTFILEPATH

設定内容
Acrobat JavaScriptファイルのデフォルトの読み込みフォルダを指定します。
なお，Acrobat JavaScript 定義ファイルに記載するAcrobat JavaScriptファイル名は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。
  • ファイル名をフルパスで指定した場合
    設定されているフォルダからAcrobat JavaScriptファイルを読み込みます。
  • ファイル名を相対パスで指定した場合
    環境変数EURPS_SCRIPTFILEPATHに設定されているフォルダからの相対パスとしてAcrobat JavaScriptファイルを読み込みます。
  • ファイル名だけ指定した場合
    環境変数EURPS_SCRIPTFILEPATHに設定されているフォルダ下のAcrobat JavaScriptファイルを読み込みます。
指定値
Acrobat JavaScriptファイルのデフォルトの読み込みフォルダを，フルパスで指定します。
省略値
環境変数EURPS_SCRIPTFILEPATHの指定を省略した場合は，次に示すフォルダの順に読み込みます。
  • Windows環境のとき
  • 環境設定ファイル（EURPS_ENV）中の変数EURPS_SCRIPTFILEPATHに設定されているフォルダ
  • EUR Developer，EUR Server Enterprise，EUR Server Standard，またはEUR Server Print Editionのインストール先フォルダ\Print
  • UNIX／Linux環境の場合
  • 環境設定ファイル（eurps_env）中の変数EURPS_SCRIPTFILEPATHに設定されているディレクトリ
  • ホームディレクトリ（環境変数HOMEで指定）
  • /var/opt/eurディレクトリ
注意事項
環境変数EURPS_SCRIPTFILEPATHに設定されているフォルダが存在しない場合は，エラー（KEEU066-E）になります。


EURPS_FIXOPT

15.3.29　EURPS_FIXOPT

設定内容
データファイル（FIX形式）の場合，区切り位置をバイトで区切るか，桁で区切るかを指定します。
指定値

表15-29　 EURPS_FIXOPTの設定値

環境変数の設定値 | 説明
BYTE | 区切り位置をバイトで区切ります。
COLUMN | 区切り位置を桁で区切ります。
環境変数の設定値は，大文字，小文字の区別をしません。
省略値
環境変数EURPS_FIXOPTの指定を省略した場合は，「BYTE」が仮定されます。
注意事項
環境変数EURPS_FIXOPTは，EUR 帳票作成機能でUTF-16のデータファイルを使用して作成したフォームシートを使用する場合に有効になります。
フォームシートの作成時に環境変数EUR_FIXOPTを指定した場合は，環境変数EURPS_FIXOPTに同じ値を指定してください。


EURPS_PRINTERINFPATH

15.3.30　EURPS_PRINTERINFPATH

設定内容
プリンタ定義ファイルのデフォルトの読み込みフォルダを指定します。
指定値
フルパスで指定します。
省略値
環境変数EURPS_PRINTERINFPATHの指定を省略した場合は，次に示すフォルダの順に読み込みます。
  • Windows環境のとき
  • 環境設定ファイル（EURPS_ENV）中の変数EURPS_PRINTERINFPATHに設定されているフォルダ
  • EUR Developer，EUR Server Enterprise，EUR Server Standard，またはEUR Server Print Editionのインストール先フォルダ\Print
  • UNIX／Linux環境のとき
  • 環境設定ファイル（eurps_env）中の変数EURPS_PRINTERINFPATHに設定されているディレクトリ
  • /var/opt/eurディレクトリ
注意事項
環境変数EURPS_PRINTERINFPATHに設定されているフォルダが存在しない場合は，エラー（KEEU078-E）になります。


EURPS_USE_05_06_FONT_LANG

15.3.31　EURPS_USE_05_06_FONT_LANG

設定内容
フォントの半角全角判定を文字コードごとにするか，フォントごとにするどうかを指定します。
EUR サーバ帳票出力機能で出力されるフォントの詳細については，マニュアル「EUR システム設計ガイド」を参照してください。
指定値

表15-30　 EURPS_USE_05_06_FONT_LANGの設定値

環境変数の設定値 | 説明
YES | 文字コードごとに半角全角判定をします（05-06以前の方式）。
NO | フォントごとに半角全角判定をします。
YES，NO以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
環境変数EURPS_USE_05_06_FONT_LANGの指定を省略した場合は，「NO」が仮定されます。
注意事項
  • 文字コードごとに半角全角判定をすると，欧文フォントではラテン基本文字と同じ幅の文字（記号，ギリシャ文字，キリル文字などJISX0208に含まれる文字）が，全角（ラテン基本文字の2倍の文字幅）で出力されます。また，日本語で半角の文字が中国語（簡体字）では正しく出力できない場合があります。欧文フォント，簡体字中国語フォントを使用する場合は，NOを指定することをお勧めします。
  • 半角全角判定の文字幅は，英語フォントではCourier，簡体字中国語フォントでは新宋体，繁体字中国語フォントでは細明体，日本語フォントではＭＳ 明朝の文字幅が適用されます。フォントの言語を判定できない場合は，中国語（簡体字）ロケールでは新宋体，日本語ロケールではＭＳ 明朝，その他のロケールではCourierの文字幅が適用されます。
  • バージョン05-06の帳票をバージョン05-08以降で開いた場合，環境変数EURPS_USE_05_06_FONT_LANGに「YES」以外の値を指定すると，帳票の見た目が異なって表示されることがあります。
  • バージョン08-00以降の場合，環境変数EURPS_USE_05_06_FONT_LANGは次に示す条件で帳票を出力した場合にフォントの文字幅計算に適用されます。

    表15-31　 バージョン08-00以降でEURPS_USE_05_06_FONT_LANGが文字幅計算に適用される出力

    出力環境 出力形式 帳票アイテムの
    フォント     		文字幅計算方法
    の指定
    Windows環境 プリンタ出力 固定ピッチフォント 静的，または指定なし
    PDF出力
    （フォント埋め込みなし）※
    UNIX／Linux環境 PDF出力
    （フォント埋め込みなし）※
    注※
    フォントの埋め込みの詳細については，マニュアル「EUR 帳票出力 機能解説 EUR Server編」を参照してください。


EURPS_OUTPUTPDF_VER

15.3.32　EURPS_OUTPUTPDF_VER

設定内容
PDF形式ファイルで，最初の行のヘッダに記述されているPDFバージョン番号を指定します。PDFバージョン番号は，PDF形式ファイルをテキストで開いた時に，最初の行「%PDF-1.x」で確認できます。
指定値

表15-32　 EURPS_OUTPUTPDF_VERの設定値

環境変数の設定値 | 説明
1.2 | PDFバージョン番号を1.2で出力します。
1.3 | PDFバージョン番号を1.3で出力します。
1.4 | PDFバージョン番号を1.4で出力します。
1.5 | PDFバージョン番号を1.5で出力します。
1.6 | PDFバージョン番号を1.6で出力します。
1.7 | PDFバージョン番号を1.7で出力します。
1.2，1.3，1.4，1.5，1.6，1.7以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
環境変数EURPS_OUTPUTPDF_VERの指定を省略した場合は，「1.6」が仮定されます。
注意事項
環境変数EURPS_OUTPUTPDF_VERで作成したPDF形式ファイルより下位バージョンのPDFバージョン番号を指定しても，ファイル内で使用している上位バージョンの機能が制限されることはありません。


EURPS_USE_05_06_FONT_REPLACE

15.3.33　EURPS_USE_05_06_FONT_REPLACE

設定内容
「フォント縦横比を補正する」が設定されていて，文字列アイテムのフォントがＭＳ ゴシックでない場合，バージョン05-06以前の動作（リュウミンL-KLに置き換える）にするかどうかを指定します。
指定値

表15-33　 EURPS_USE_05_06_FONT_REPLACEの設定値

環境変数の設定値 | 説明
YES | 「フォント縦横比を補正する」が設定されていて，文字列アイテムのフォントがＭＳ ゴシックでない場合に，リュウミンL-KLに置き換えます（05-06以前の方式）。
NO | 置き換えをしません。
YES，NO以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
環境変数EURPS_USE_05_06_FONT_REPLACEの指定を省略した場合は，「NO」が仮定されます。


EURPS_FONT_WIDTH_MODE

15.3.34　EURPS_FONT_WIDTH_MODE

設定内容
文字幅の計算方法を指定します。
指定値
環境変数の設定値は，すべて半角英大文字で指定します。

表15-34　 EURPS_FONT_WIDTH_MODEの設定値

環境変数の設定値 | 説明
STATIC | 固定ピッチフォントを出力する場合，固定値で文字幅を計算します。（静的モード）
DYNAMIC | 固定ピッチフォントを出力する場合，使用するフォントに合わせて文字幅を計算します。（動的モード）
STATIC，DYNAMIC以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
環境変数EURPS_FONT_WIDTH_MODEの指定を省略した場合は，「STATIC」が仮定されます。


EURPS_EXCELLOGFILELEVEL

15.3.35　EURPS_EXCELLOGFILELEVEL

設定内容
Excel形式ファイルに出力する場合，ログファイル（EPS-XLSXログ）へのメッセージ出力レベルを指定します。
指定値
次に示す2種類のメッセージ出力レベルを指定することで，出力されるメッセージの内容を選択できます。
メッセージ出力レベルの設定の詳細についてはマニュアル「EUR システム設計ガイド」を参照してください。

表15-35　メッセージ出力レベル

環境変数の設定値 | 出力されるメッセージの内容
INFO | エラーレベル（Error（Err））とワーニングレベル（Warning（War））のログを出力します（デフォルト）。
ERROR | エラーレベル（Error（Err））だけを出力します。
INFO，ERROR以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
環境変数EURPS_EXCELLOGFILELEVELの指定を省略した場合は，「INFO」が仮定されます。


EURPS_EXCELTMPPATH

15.3.36　EURPS_EXCELTMPPATH

設定内容
Excel形式ファイルに出力する場合に使用する一時フォルダのパスを指定します。
指定値
指定できる値を次に示します。
  • パス名は，ASCII文字だけで構成されたパスを指定してください。
  • 存在するファイルのパスを指定してください。
  • フルパスで指定してください。
  • パス名に指定できる文字数は，次のとおりです。指定できる文字数を超えた場合は，エラー（KEEU125-E）になります。
  • Windows環境のとき
    フルパスで半角199文字以内
  • UNIX／Linux環境のとき
    フルパスで67バイト以内
省略値
環境変数EURPS_EXCELTMPPATHの指定を省略した場合のデフォルトの一時フォルダは，システムの一時フォルダです。
注意事項
  • 指定できる文字数を超えた場合は，エラー（KEEU125-E）になります。
  • ネットワークパスは指定できません。ネットワークパスを指定した場合は，エラー（KEEU125-E）になります。


EURPS_TESTPRINTFILE

15.3.37　EURPS_TESTPRINTFILE

設定内容
テスト印刷設定ファイル名を指定します。
指定値
ファイル名は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。相対パスで指定した場合，カレントディレクトリからの相対パスとしてテスト印刷設定ファイルを読み込みます。
省略値
環境変数EURPS_TESTPRINTFILEの指定を省略した場合は，未指定となります。


EURPS_FONT_ROUNDDOWN

15.3.38　EURPS_FONT_ROUNDDOWN

設定内容
帳票印刷時に使用するフォントサイズについて，帳票設計時に指定された数値の小数部を切り捨てるかどうかを指定します。
指定値
指定できる値を次に示します。

表15-36　EURPS_FONT_ROUNDDOWNの設定値

環境変数の設定値 | 説明
YES | 帳票設計時に指定された数値の小数部を切り捨てたフォントサイズで印刷します。文字間隔は，帳票設計時のフォントサイズで印刷した場合と変わりません。
NO | 帳票設計時に指定された数値のフォントサイズを使用して印刷します。
省略値
環境変数EURPS_FONT_ROUNDDOWNの指定を省略した場合は，帳票設計時に指定された数値のフォントサイズを使用して印刷します。


EURPS_MAX_SPOOL_PAGES

15.3.39　EURPS_MAX_SPOOL_PAGES

設定内容
印刷ジョブの最大ページ数を指定します。
この環境変数は，プリンタでの印刷で使用できます。
指定値
印刷ジョブの最大ページ数を1～2,147,483,646の範囲で指定します。印刷ジョブはこの環境変数に指定したページ数ごとに分割され，複数の印刷ジョブとなって出力されます。
指定値として次の値を指定した場合は，省略値と同じ動作となります。
  • 範囲外の値を指定した場合
  • 半角数字以外の文字を指定した場合
  • 0を指定した場合
省略値
環境変数EURPS_MAX_SPOOL_PAGESの指定を省略した場合は，印刷ジョブの分割は実施されません。
注意事項
  • 環境変数EURPS_MAX_SPOOL_PAGESを指定した場合，印刷ジョブ名はOSの環境によって次のように異なります。
  • Windows環境で印刷するとき
    印刷ジョブ名の末尾に「.n」（nは1から始まる連番）が付加されます。印刷ジョブの分割が発生しなかった場合も「.1」が付加されます。
    次に示す優先順位で設定される値+「.n」の先頭の259文字分が印刷ジョブ名になります。
    1. 起動部品で指定したスプールタイトルの指定値
        ・ActiveX起動部品：SpoolTitleプロパティ
        ・Java起動部品：setSpoolTitleメソッド
        ・COBOL起動部品：SPOOLTITLEパラメタ
        ・コマンド起動部品（eurpmcコマンド）：/sptlオプション
    2. 文書情報設定ファイルのTITLEキーの指定値
    3. 「帳票ファイル名」

    また，環境変数EURPS_MAX_SPOOL_PAGESを設定する場合，印刷ジョブ名を決定する起動部品で指定するスプールタイトルや文書情報設定ファイルのTITLEキーに，書式開始文字%から始まる次の書式を設定しておくと，印刷ジョブ名に付く連番の表示形式を変更できます。
    %j
        「1」から始まる連番を出力します。
    %j以外
        「%」のあとに指定された文字を出力し，末尾に連番「.n」を付与します。

    文書情報設定ファイルのTITLEキーに書式開始文字%から始まる書式を指定したときの印刷ジョブ名の例を次に示します。
    指定例
    キーワードTITLEの指定内容 | 印刷ジョブ名の例
    TITLE="EUR帳票%j" | EUR帳票1
    TITLE="EUR帳票%x" | EUR帳票x.1
    文書情報設定ファイルの作成方法の詳細については，「11.4　文書情報設定ファイル」を参照してください。

  • UNIX／Linux環境で印刷するとき
    EURでは印刷ジョブ名を設定しません。分割されたジョブごとに，プリンタ定義ファイルのキーワードCommandで指定された出力コマンドが実行されます。プリンタ定義ファイルの詳細については，「11.5　プリンタ定義ファイル」を参照してください。

  • 部数を指定して印刷した場合，出力枚数ではなく印刷ジョブのページ数が分割されます。また，プリンタに部数機能があるかどうかによって次のように結果が異なります。
  • プリンタに部数機能があるとき
    印刷ジョブの出力ページ数は，環境変数EURPS_MAX_SPOOL_PAGESで指定した印刷ジョブ最大ページ数×部数となります。
  • プリンタに部数機能がないとき
    印刷ジョブには帳票が指定部数の数だけ繰り返し出力されますが，環境変数EURPS_MAX_SPOOL_PAGESで指定された印刷ジョブ最大ページ数は印刷ジョブに対して作用するため，部をまたがって区切られます。
  • 複数様式帳票の場合，printnewpaper=ONの指定によって生成された空白ページを枚数として数えます。
  • 印刷ジョブ最大ページ数に奇数値を指定して両面印刷すると，分割されたページ以降は，表面と裏面のページが逆となって印刷されます。表面と裏面を区別する帳票のときは，印刷ジョブ最大ページ数に偶数値を指定するなど注意してください。


EURPS_DONT_PRINT_IF_DB_RESULT_EMPTY

15.3.40　EURPS_DONT_PRINT_IF_DB_RESULT_EMPTY

設定内容
データベースからの抽出件数が0の場合に，帳票を出力しないようにします。
指定値
指定できる値を次に示します。

表15-37　EURPS_DONT_PRINT_IF_DB_RESULT_EMPTYの設定値

環境変数の設定値 | 説明
YES | データベースからデータを抽出して帳票を出力する場合，データベースの抽出結果が0件であったときは，帳票を出力しないようにします。
環境変数の設定値は，大文字，小文字の区別をします。「YES」以外の値を指定した場合は，省略値と同じ値が仮定されます。
環境変数EURPS_DONT_PRINT_IF_DB_RESULT_EMPTYに「YES」を指定して，データベースの抽出結果が0件だった場合の出力内容は，帳票の様式によって異なります。詳細を次の表に示します。

表15-38　出力する帳票の種類とデータベース抽出結果ごとの出力内容（EURPS_DONT_PRINT_IF_DB_RESULT_EMPTYにYES指定時）

出力する帳票の種類 | データベース抽出結果 | 出力内容 | 出力ページ情報ファイル
単一様式の帳票 | 0件以外 | 抽出したデータを入力して帳票を出力します。 | 出力します。
0件 | エラー（KEEU351-W，KEEU352-W，またはKEEY909-W）を出力して処理を終了します。 | 出力しません。
複数帳票の一括出力 | 帳票セットのどれかが0件 | 0件だった帳票セットについては，エラー（KEEU351-W）を出力して処理を続行します。 | 指定された帳票セットのうち，出力されなかった帳票セットは出力ページ情報ファイルに記録しません。
すべて0件 | エラー（KEEU352-W，またはKEEY909-W）を出力して処理を終了します。 | 出力しません。
複数様式の帳票 | 先頭の様式グループが0件 | エラー（KEEU351-W，KEEU352-W，またはKEEY909-W）を出力して処理を終了します。 | 出力しません。
先頭の様式グループ以外が0件 | グループのデータを0件として，エラー（KEEU351-W）を出力して処理を続行します。 | 出力します。
省略値
環境変数EURPS_DONT_PRINT_IF_DB_RESULT_EMPTYの指定を省略した場合は，抽出結果が0件の場合も帳票を出力します。


EURPS_PDF_BUFSIZE

15.3.41　EURPS_PDF_BUFSIZE

設定内容
PDF形式ファイルを出力するときに使用されるIOバッファサイズを指定します。PDF形式ファイルを出力するときだけ有効です。
指定値
指定できる値は，2～2,147,483,647です。単位はバイトです。
2～2,147,483,647以外の値を指定した場合，または半角数字以外の文字を指定した場合は，省略値と同じ値が仮定されます。
省略値
環境変数EURPS_PDF_BUFSIZEの指定を省略した場合は，「4096」が仮定されます。
注意事項
PDF形式ファイルの出力先にNASなどの出力デバイスを指定する場合は，環境変数EURPS_PDF_BUFSIZEでIOバッファサイズを大きくすることで，出力時間が早くなることがあります。


EURPS_PDF_IMAGEDRAWUNIT

15.3.42　EURPS_PDF_IMAGEDRAWUNIT

設定内容
PDF形式ファイルに画像を出力する場合に，位置やサイズの単位を指定します。
PDF形式ファイルを出力するときだけ有効です。画像のうち，モノクロのビットマップやバーコードは対象ではありません。
指定値
指定できる値を次に示します。

表15-39　EURPS_PDF_IMAGEDRAWUNITの設定値

環境変数の設定値 | 説明
INTEGER | PDF形式ファイルに画像を出力するときの位置，サイズを整数のポイント単位とします。
「INTEGER」以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
環境変数EURPS_PDF_IMAGEDRAWUNITの指定を省略した場合は，PDF形式ファイルに画像を出力するときの位置，サイズを小数点以下3桁のポイント単位とします。


EURPS_EPFDPI

15.3.43　EURPS_EPFDPI

設定内容
EPF形式ファイルを出力する場合に，解像度（DPI値）を指定します。
指定値
指定できる値は，1～2,147,483,647です。単位はdpiです。
1～2,147,483,647以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
環境変数EURPS_EPFDPIの指定を省略した場合は，「1440」が仮定されます。
注意事項
  • 帳票にバーコードアイテムが含まれる場合，1440よりも小さい値を指定すると，出力されるEPF形式ファイルのサイズが小さくなり，プレビュー表示速度や印刷速度が向上します。
  • 出力するプリンタの解像度と同じ値を指定することをお勧めします。解像度が異なる環境で生成したEPF形式ファイルを統合して出力しようとするとエラーとなります。また，解像度が異なる環境で蓄積したEPF形式ファイルを，一つのEPF形式ファイルとして取得または印刷しようとするとエラーとなります。


EURPS_EPF_IMAGE_COMPRESS

15.3.44　EURPS_EPF_IMAGE_COMPRESS

設定内容
EPF形式ファイルを出力する場合に，画像アイテムやバーコードアイテムなどの画像データを圧縮するかどうかを指定します。
画像データが含まれている帳票の場合にON（またはon）を指定すると，中間ファイルやEPF形式ファイルのサイズが小さくなり，プレビュー表示速度や印刷速度が向上します。
指定値
指定できる値を次に示します。
  • ON（またはon）：画像データを圧縮します。
  • OFF（またはoff）：画像データを圧縮しません。
ON（またはon），OFF（またはoff）以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
環境変数EURPS_EPF_IMAGE_COMPRESSの指定を省略した場合は，「OFF（またはoff）」が仮定されます。
注意事項
  • 環境変数EURPS_EPF_IMAGE_COMPRESSにON（またはon）を指定して出力したEPF形式ファイルをプレビュー表示や印刷する場合は，EUR Print Manager - Report Server 08-10以降，EUR Server Enterprise 09-00以降，EUR Print Manager - Client 08-10以降，またはEUR Client 09-00以降を使用してください。
    08-10よりも前のバージョンのEUR Print Manager - Report ServerまたはEUR Print Manager - Clientを使用した場合は，画像データの表示や印刷ができません。プレビュー表示や印刷に08-10よりも前のバージョンのEUR Print Manager - Report ServerまたはEUR Print Manager - Clientを使用する場合は，必ず環境変数EURPS_EPF_IMAGE_COMPRESSに「OFF（またはoff）」を指定してください。
  • EUR Print Service 08-30以降，EUR Server Standard 09-00以降，EUR Server Enterprise 09-00以降，EUR Server Print Edition 09-00以降を使用して帳票を出力する場合で，帳票に含まれる画像データが次の3種類のバーコードだけのときは，バーコードの回転角度と環境変数EURPS_EPF_IMAGE_COMPRESSの設定によって，出力されるEPF形式ファイルのファイルサイズが変わります。
  • NW-7バーコード
  • CODE39バーコード
  • CODE128バーコード
バーコードの回転角度が0°の場合
環境変数EURPS_EPF_IMAGE_COMPRESSに「OFF（またはoff）」を指定する方が，出力されるEPF形式ファイルのファイルサイズが小さくなります。
バーコードの回転角度が90°または270°の場合
環境変数EURPS_EPF_IMAGE_COMPRESSに「ON（またはon）」を指定する方が，出力されるEPF形式ファイルのファイルサイズが小さくなります。


EURPS_UPC_BARCODE

15.3.45　EURPS_UPC_BARCODE

設定内容
UPCバーコードの出力を有効にするかどうかを指定します。
指定値
指定できる値を次に示します。
  • ENABLE：UPCバーコードの出力を有効にします。
  • DISABLE：UPCバーコードの出力を無効にします。
ENABLE，DISABLE以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
環境変数EURPS_UPC_BARCODEの指定を省略した場合は，「ENABLE」が仮定されます。
注意事項
JAN短縮バーコードに「0」で始まるデータを指定する場合は，環境変数EURPS_UPC_BARCODEに「DISABLE」を設定してください。


EURPS_OUTPUTPATH

15.3.46　EURPS_OUTPUTPATH

設定内容
PDF形式ファイルを仕分けして出力する場合のEUR Server Service稼働マシンの出力先フォルダを指定します。
なお，PDF形式の出力で使用する起動部品に指定するPDF形式ファイル名は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。
  • ファイル名をフルパスで指定した場合
    設定されているフォルダにPDF形式ファイルを出力します。
  • ファイル名を相対パスで指定した場合
    環境変数EURPS_OUTPUTPATHに設定されているフォルダからの相対パスとしてPDF形式ファイルを出力します。
  • ファイル名だけ指定した場合
    環境変数EURPS_OUTPUTPATHに設定されているフォルダ下にPDF形式ファイルを出力します。
指定値
EUR Server Service稼働マシンの出力先フォルダを，フルパスで指定します。
省略値
環境変数EURPS_OUTPUTPATHの指定を省略した場合は，次に示す順にファイルを検索します。
  • Windows環境のとき
  • 環境設定ファイル（EURPS_ENV）中の変数EURPS_OUTPUTPATHに設定されているフォルダ
  • 環境変数TMPに設定されているフォルダ
  • UNIX／Linux環境のとき
  • 環境設定ファイル（eurps_env）中の変数EURPS_OUTPUTPATHに設定されているディレクトリ
  • ホームディレクトリ（環境変数HOMEで指定）
  • /var/opt/eurディレクトリ


EURPS_EXCEL_REPEAT_MODE

15.3.47　EURPS_EXCEL_REPEAT_MODE

設定内容
Excel形式ファイルへ出力する場合に，ページ単位でシートを分けるかどうかを指定します。
指定値
指定できる値を次に示します。
  • EXTEND：ページ単位でシートを分けません。キーブレイクによる改ページごとにシートを分け，縦方向の繰り返しを1シート内で出力します。
  • NORMAL：ページ単位でシートを分けます。
EXTEND，NORMAL以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
環境変数EURPS_EXCEL_REPEAT_MODEの指定を省略した場合は，「NORMAL」が仮定されます。


ESC/P対応プリンタ出力用の環境変数

15.3.48　ESC/P対応プリンタ出力用の環境変数

設定内容
ESC/P対応プリンタで使用するフォントファイルを指定します。
指定値
フルパスで指定します。
ESC/P対応プリンタ出力用の環境変数と指定値を次に示します。

表15-40　 ESC/P対応プリンタ出力用の環境変数と指定値

環境変数 | 指定値
EURPS_J84MA16 | 明朝体アンク8×16ドットのフォントファイル(*.pcf)をフルパスで指定します。
EURPS_J84MA24 | 明朝体アンク12×24ドットのフォントファイル(*.pcf)をフルパスで指定します。
EURPS_J84MA48 | 明朝体アンク24×48ドットのフォントファイル(*.pcf)をフルパスで指定します。
EURPS_J84MA72 | 明朝体アンク36×72ドットのフォントファイル(*.pcf)をフルパスで指定します。
EURPS_J84MA96 | 明朝体アンク48×96ドットのフォントファイル(*.pcf)をフルパスで指定します。
EURPS_J84MK16 | 明朝体漢字16×16ドットのフォントファイル(*.pcf)をフルパスで指定します。
EURPS_J84MK24 | 明朝体漢字24×24ドットのフォントファイル(*.pcf)をフルパスで指定します。
EURPS_J84MK48 | 明朝体漢字48×48ドットのフォントファイル(*.pcf)をフルパスで指定します。
EURPS_J84MK72 | 明朝体漢字72×72ドットのフォントファイル(*.pcf)をフルパスで指定します。
EURPS_J84MK96 | 明朝体漢字96×96ドットのフォントファイル(*.pcf)をフルパスで指定します。
EURPS_J84GA16 | ゴシック体アンク8×16ドットのフォントファイル(*.pcf)をフルパスで指定します。
EURPS_J84GA24 | ゴシック体アンク12×24ドットのフォントファイル(*.pcf)をフルパスで指定します。
EURPS_J84GA48 | ゴシック体アンク24×48ドットのフォントファイル(*.pcf)をフルパスで指定します。
EURPS_J84GA72 | ゴシック体アンク36×72ドットのフォントファイル(*.pcf)をフルパスで指定します。
EURPS_J84GA96 | ゴシック体アンク48×96ドットのフォントファイル(*.pcf)をフルパスで指定します。
EURPS_J84GK16 | ゴシック体漢字16×16ドットのフォントファイル(*.pcf)をフルパスで指定します。
EURPS_J84GK24 | ゴシック体漢字24×24ドットのフォントファイル(*.pcf)をフルパスで指定します。
EURPS_J84GK48 | ゴシック体漢字48×48ドットのフォントファイル(*.pcf)をフルパスで指定します。
EURPS_J84GK72 | ゴシック体漢字72×72ドットのフォントファイル(*.pcf)をフルパスで指定します。
EURPS_J84GK96 | ゴシック体漢字96×96ドットのフォントファイル(*.pcf)をフルパスで指定します。
省略値
環境変数や環境設定ファイル（eurps_env）中にフォントファイルの指定がない場合は，指定されたフォントサイズに最も近い，次のデフォルトフォントを拡大・縮小して印刷します。

  • HP-UXの場合
  • 明朝体アンク　8×16　：　/usr/openwin/lib/X11/hitachi/8x16rk.pcf
  • 明朝体アンク　12×24　：　/usr/openwin/lib/X11/hitachi/12x24rk.pcf
  • 明朝体漢字　16×16　：　/usr/openwin/lib/X11/hitachi/jiskan16.pcf
  • 明朝体漢字　24×24　：　/usr/openwin/lib/X11/hitachi/jiskan24.pcf
  • ゴシック体アンク　8×16　：　/usr/openwin/lib/X11/hitachi/8x16rk.pcf
  • ゴシック体アンク　12×24　：　/usr/openwin/lib/X11/hitachi/12x24rk.pcf
  • ゴシック体漢字　16×16　：　/usr/openwin/lib/X11/hitachi/jiskan16.pcf
  • ゴシック体漢字　24×24　：　/usr/openwin/lib/X11/hitachi/jiskan24.pcf

  • AIXの場合
  • 明朝体アンク　8×16　：　/usr/lib/X11/hitachi/RomanKn12S.pcf
  • 明朝体アンク　12×24　：　/usr/lib/X11/hitachi/RomanKn17S.pcf
  • 明朝体漢字　16×16　：　/usr/lib/X11/hitachi/Kanji12S.pcf
  • 明朝体漢字　24×24　：　/usr/lib/X11/hitachi/Kanji17S.pcf
  • ゴシック体アンク　8×16　：　/usr/lib/X11/hitachi/RomanKn12S.pcf
  • ゴシック体アンク　12×24　：　/usr/lib/X11/hitachi/RomanKn17S.pcf
  • ゴシック体漢字　16×16　：　/usr/lib/X11/hitachi/Kanji12S.pcf
  • ゴシック体漢字　24×24　：　/usr/lib/X11/hitachi/Kanji17S.pcf

  • Linuxの場合
  • 明朝体アンク　8×16　：　/usr/lib/X11/fonts/hitachi/8x16rk.pcf
  • 明朝体アンク　12×24　：　/usr/lib/X11/fonts/hitachi/12x24rk.pcf
  • 明朝体漢字　16×16　：　/usr/lib/X11/fonts/hitachi/jiskan16.pcf
  • 明朝体漢字　24×24　：　/usr/lib/X11/fonts/hitachi/jiskan24.pcf
  • ゴシック体アンク　8×16　：　/usr/lib/X11/fonts/hitachi/8x16rk.pcf
  • ゴシック体アンク　12×24　：　/usr/lib/X11/fonts/hitachi/12x24rk.pcf
  • ゴシック体漢字　16×16　：　/usr/lib/X11/fonts/hitachi/jiskan16.pcf
  • ゴシック体漢字　24×24　：　/usr/lib/X11/fonts/hitachi/jiskan24.pcf
注意事項
指定されたフルパスが1,023バイトを超えた場合は，エラー（KEEU009-E）になります。また，指定したファイルが読み込めない場合も，エラー（KEEU024-E）になります。
＜この項の構成＞
(1)　デフォルトフォントファイルの解凍手順

(1)　デフォルトフォントファイルの解凍手順

AIX，およびLinux環境で使用するデフォルトフォントは，圧縮形式で提供しています。フォントファイル用のディレクトリを作成し，デフォルトフォントファイルを複写して，解凍してください。解凍する手順を次に示します。

(a)　AIX環境の場合
  1. デフォルトフォントディレクトリの作成
    # mkdir /usr/lib/X11/fonts/hitachi
  2. デフォルトフォントファイル（圧縮形式）の複写
    # cd /usr/lib/X11/fonts
# cp RomanKn12S.pcf.Z  /usr/lib/X11/fonts/hitachi/RomanKn12S.pcf.Z
# cp RomanKn17S.pcf.Z  /usr/lib/X11/fonts/hitachi/RomanKn17S.pcf.Z
# cp Kanji12S.pcf.Z  /usr/lib/X11/fonts/hitachi/Kanji12S.pcf.Z
# cp Kanji17S.pcf.Z  /usr/lib/X11/fonts/hitachi/Kanji17S.pcf.Z
  3. デフォルトフォントファイルの解凍
    # cd /usr/openwin/lib/X11/fonts/hitachi
# uncompress RomanKn12S.pcf.Z
# uncompress RomanKn17S.pcf.Z
# uncompress Kanji12S.pcf.Z
# uncompress Kanji17S.pcf.Z
(b)　Linux環境の場合
  1. デフォルトフォントディレクトリの作成
    # mkdir /usr/lib/X11/fonts/hitachi
  2. デフォルトフォントファイル（圧縮形式）の複写
    # cd /usr/lib/X11/fonts/misc※
# cp 8x16rk.pcf.gz  /usr/lib/X11/fonts/hitachi/8x16rk.pcf.gz
# cp jiskan16.pcf.gz  /usr/lib/X11/fonts/hitachi/jiskan16.pcf.gz
# cp 12x24rk.pcf.gz  /usr/lib/X11/fonts/hitachi/12x24rk.pcf.gz
# cp jiskan24.pcf.gz  /usr/lib/X11/fonts/hitachi/jiskan24.pcf.gz
    注※
    /usr/lib/X11/fonts/miscにデフォルトフォントがない場合は，/usr/share/X11/fonts/miscを指定してください。
  3. デフォルトフォントファイルの解凍
    # cd /usr/lib/X11/fonts/hitachi
# gunzip 8x16rk.pcf.gz
# gunzip jiskan16.pcf.gz
# gunzip 12x24rk.pcf.gz
# gunzip jiskan24.pcf.gz


環境設定ファイルの指定例

15.3.49　環境設定ファイルの指定例

＜この項の構成＞
(1)　Windows環境の場合
(2)　HP-UX環境の場合
(3)　AIX環境の場合
(4)　Linux環境の場合

(1)　Windows環境の場合

EURPS_LOGFILEPATH=C:\PROGRAM FILES\EURLOG
EURPS_LOGSIZE=3000
EURPS_LOGFILELEVEL=INFO
EURPS_IMAGEPATH=C:\PROGRAM FILES\EUR\IMAGE
EURPS_REPORT_WARNING=NO
EURPS_GAIJIFONT=C:\PROGRAM FILES\EUR\EUDC.TTE
EURPS_PDF_OUTPUT=FILE_SIZE
EURPS_PDF_SAMEIMAGE=OPTIMIZE
EURPS_PDF_IMAGE_OPTIMIZEMEM=YES
EURPS_CSV_PRINT_PERIOD=YES
EURPS_TRACE=YES
EURPS_TRACE_DRAWAPI=NO
EURPS_REPORT_LOGERROR=YES
EURPS_REPLACEITEMPATH=C:\PROGRAM FILES\EUR\REPLACEITEM
EURPS_SKIP_OUTPUTSPACE=YES
EURPS_PRINT=NO
EURPS_CODE39_PARAM=1,1:2.5:1,0.04
EURPS_CODE128_PARAM=2,0.04,0.04
EURPS_QR_CORRECTION_LEVEL=Q
EURPS_QR_VERSION=15
EURPS_NOSKIP_OUTPUTSPACE=YES
EURPS_QR_CELL_SIZE_D=7
EURPS_QR_CELL_SIZE_M=30
EURPS_SCRIPTFILEPATH=C:\PROGRAM FILES\EUR\SCRIPT
EURPS_FIXOPT=BYTE
EURPS_USE_05_06_FONT_LANG=YES
EURPS_OUTPUTPDF_VER=1.6
EURPS_PRINTERINFPATH=C:\PROGRAM FILES\EUR\PRINTER.INF
EURPS_USE_05_06_FONT_REPLACE=YES
EURPS_FONT_WIDTH_MODE=STATIC
EURPS_TESTPRINTFILE=C:\EUR\TESTPRINTFILE\TESTPRINTFILE.txt
EURPS_FONT_ROUNDDOWN=NO
EURPS_MAX_SPOOL_PAGES=2000
EURPS_DONT_PRINT_IF_DB_RESULT_EMPTY=YES
EURPS_PDF_BUFSIZE=2
EURPS_PDF_IMAGEDRAWUNIT=INTEGER
EURPS_EPFDPI=1
EURPS_EPF_IMAGE_COMPRESS=ON
EURPS_UPC_BARCODE=ENABLE

(2)　HP-UX環境の場合

EURPS_LOGFILEPATH=/var/opt/EUR/Log
EURPS_LOGSIZE=3000
EURPS_LOGFILELEVEL=INFO
EURPS_IMAGEPATH=/home/eur/image
EURPS_REPORT_WARNING=NO
EURPS_GAIJIFONT=/home/eur/gaijifont/udc24.pcf
EURPS_PDF_OUTPUT=FILE_SIZE
EURPS_PDF_SAMEIMAGE=OPTIMIZE
EURPS_PDF_IMAGE_OPTIMIZEMEM=YES
EURPS_CSV_PRINT_PERIOD=YES
EURPS_TRACE=YES
EURPS_TRACE_DRAWAPI=NO
EURPS_REPORT_LOGERROR=YES
EURPS_REPLACEITEMPATH=/home/eur/replaceitem
EURPS_SKIP_OUTPUTSPACE=YES
EURPS_PRINT=NO
EURPS_CODE39_PARAM=1,1:2.5:1,0.03
EURPS_CODE128_PARAM=2,0.04,0.04
EURPS_QR_CORRECTION_LEVEL=Q
EURPS_QR_VERSION=15
EURPS_NOSKIP_OUTPUTSPACE=YES
EURPS_QR_CELL_SIZE_D=7
EURPS_QR_CELL_SIZE_M=30
EURPS_SCRIPTFILEPATH=/home/eur/script
EURPS_FIXOPT=BYTE
EURPS_USE_05_06_FONT_LANG=YES
EURPS_OUTPUTPDF_VER=1.6
EURPS_J84MA16=/usr/openwin/lib/X11/hitachi/min16a.pcf
EURPS_J84MA24=/usr/openwin/lib/X11/hitachi/min24a.pcf
EURPS_J84MA48=/usr/openwin/lib/X11/hitachi/min48a.pcf
EURPS_J84MA72=/usr/openwin/lib/X11/hitachi/min72a.pcf
EURPS_J84MA96=/usr/openwin/lib/X11/hitachi/min96a.pcf
EURPS_J84MK16=/usr/openwin/lib/X11/hitachi/min16k.pcf
EURPS_J84MK24=/usr/openwin/lib/X11/hitachi/min24k.pcf
EURPS_J84MK48=/usr/openwin/lib/X11/hitachi/min48k.pcf
EURPS_J84MK72=/usr/openwin/lib/X11/hitachi/min72k.pcf
EURPS_J84MK96=/usr/openwin/lib/X11/hitachi/min96k.pcf
EURPS_J84GA16=/usr/openwin/lib/X11/hitachi/got16a.pcf
EURPS_J84GA24=/usr/openwin/lib/X11/hitachi/got24a.pcf
EURPS_J84GA48=/usr/openwin/lib/X11/hitachi/got48a.pcf
EURPS_J84GA72=/usr/openwin/lib/X11/hitachi/got72a.pcf
EURPS_J84GA96=/usr/openwin/lib/X11/hitachi/got96a.pcf
EURPS_J84GK16=/usr/openwin/lib/X11/hitachi/got16k.pcf
EURPS_J84GK24=/usr/openwin/lib/X11/hitachi/got24k.pcf
EURPS_J84GK48=/usr/openwin/lib/X11/hitachi/got48k.pcf
EURPS_J84GK72=/usr/openwin/lib/X11/hitachi/got72k.pcf
EURPS_J84GK96=/usr/openwin/lib/X11/hitachi/got96k.pcf
EURPS_PRINTERINFPATH=/home/eur/printerinf
EURPS_USE_05_06_FONT_REPLACE=YES
EURPS_FONT_WIDTH_MODE=STATIC
EURPS_TESTPRINTFILE=/home/eur/testprintfile/testprintfile.txt
EURPS_FONT_ROUNDDOWN=NO
EURPS_MAX_SPOOL_PAGES=2000
EURPS_DONT_PRINT_IF_DB_RESULT_EMPTY=YES
EURPS_PDF_BUFSIZE=2
EURPS_PDF_IMAGEDRAWUNIT=INTEGER
EURPS_EPFDPI=1
EURPS_EPF_IMAGE_COMPRESS=ON
EURPS_UPC_BARCODE=ENABLE

(3)　AIX環境の場合

EURPS_LOGFILEPATH=/var/opt/EUR/Log
EURPS_LOGSIZE=3000
EURPS_LOGFILELEVEL=INFO
EURPS_IMAGEPATH=/home/eur/image
EURPS_REPORT_WARNING=NO
EURPS_GAIJIFONT=/usr/lib/X11/fonts/hitachi/IBM_JPN17C.pcf
EURPS_PDF_OUTPUT=FILE_SIZE
EURPS_PDF_SAMEIMAGE=OPTIMIZE
EURPS_PDF_IMAGE_OPTIMIZEMEM=YES
EURPS_CSV_PRINT_PERIOD=YES
EURPS_TRACE=YES
EURPS_TRACE_DRAWAPI=NO
EURPS_REPORT_LOGERROR=YES
EURPS_REPLACEITEMPATH=/home/eur/replaceitem
EURPS_SKIP_OUTPUTSPACE=YES
EURPS_PRINT=NO
EURPS_CODE39_PARAM=1,1:2.5:1,0.03
EURPS_CODE128_PARAM=2,0.04,0.04
EURPS_QR_CORRECTION_LEVEL=Q
EURPS_QR_VERSION=15
EURPS_NOSKIP_OUTPUTSPACE=YES
EURPS_QR_CELL_SIZE_D=7
EURPS_QR_CELL_SIZE_M=30
EURPS_SCRIPTFILEPATH=/home/eur/script
EURPS_FIXOPT=BYTE
EURPS_USE_05_06_FONT_LANG=YES
EURPS_OUTPUTPDF_VER=1.6
EURPS_J84MA16=/usr/lib/X11/hitachi/min16a.pcf
EURPS_J84MA24=/usr/lib/X11/hitachi/min24a.pcf
EURPS_J84MA48=/usr/lib/X11/hitachi/min48a.pcf
EURPS_J84MA72=/usr/lib/X11/hitachi/min72a.pcf
EURPS_J84MA96=/usr/lib/X11/hitachi/min96a.pcf
EURPS_J84MK16=/usr/lib/X11/hitachi/min16k.pcf
EURPS_J84MK24=/usr/lib/X11/hitachi/min24k.pcf
EURPS_J84MK48=/usr/lib/X11/hitachi/min48k.pcf
EURPS_J84MK72=/usr/lib/X11/hitachi/min72k.pcf
EURPS_J84MK96=/usr/lib/X11/hitachi/min96k.pcf
EURPS_J84GA16=/usr/lib/X11/hitachi/got16a.pcf
EURPS_J84GA24=/usr/lib/X11/hitachi/got24a.pcf
EURPS_J84GA48=/usr/lib/X11/hitachi/got48a.pcf
EURPS_J84GA72=/usr/lib/X11/hitachi/got72a.pcf
EURPS_J84GA96=/usr/lib/X11/hitachi/got96a.pcf
EURPS_J84GK16=/usr/lib/X11/hitachi/got16k.pcf
EURPS_J84GK24=/usr/lib/X11/hitachi/got24k.pcf
EURPS_J84GK48=/usr/lib/X11/hitachi/got48k.pcf
EURPS_J84GK72=/usr/lib/X11/hitachi/got72k.pcf
EURPS_J84GK96=/usr/lib/X11/hitachi/got96k.pcf
EURPS_PRINTERINFPATH=/home/eur/printerinf
EURPS_USE_05_06_FONT_REPLACE=YES
EURPS_FONT_WIDTH_MODE=STATIC
EURPS_TESTPRINTFILE=/home/eur/testprintfile/testprintfile.txt
EURPS_FONT_ROUNDDOWN=NO
EURPS_MAX_SPOOL_PAGES=2000
EURPS_DONT_PRINT_IF_DB_RESULT_EMPTY=YES
EURPS_PDF_BUFSIZE=2
EURPS_PDF_IMAGEDRAWUNIT=INTEGER
EURPS_EPFDPI=1
EURPS_EPF_IMAGE_COMPRESS=ON
EURPS_UPC_BARCODE=ENABLE

(4)　Linux環境の場合

EURPS_LOGFILEPATH=/var/opt/EUR/Log
EURPS_LOGSIZE=3000
EURPS_LOGFILELEVEL=INFO
EURPS_IMAGEPATH=/home/eur/image
EURPS_REPORT_WARNING=NO
EURPS_PDF_OUTPUT=FILE_SIZE
EURPS_PDF_SAMEIMAGE=OPTIMIZE
EURPS_PDF_IMAGE_OPTIMIZEMEM=YES
EURPS_CSV_PRINT_PERIOD=YES
EURPS_TRACE=YES
EURPS_TRACE_DRAWAPI=NO
EURPS_REPORT_LOGERROR=YES
EURPS_REPLACEITEMPATH=/home/eur/replaceitem
EURPS_SKIP_OUTPUTSPACE=YES
EURPS_PRINT=NO
EURPS_CODE39_PARAM=1,1:2.5:1,0.03
EURPS_CODE128_PARAM=2,0.04,0.04
EURPS_QR_CORRECTION_LEVEL=Q
EURPS_QR_VERSION=15
EURPS_NOSKIP_OUTPUTSPACE=YES
EURPS_QR_CELL_SIZE_D=7
EURPS_QR_CELL_SIZE_M=30
EURPS_SCRIPTFILEPATH=/home/eur/script
EURPS_FIXOPT=BYTE
EURPS_USE_05_06_FONT_LANG=YES
EURPS_OUTPUTPDF_VER=1.6
EURPS_J84MA16=/usr/lib/X11/fonts/hitachi/min16a.pcf
EURPS_J84MA24=/usr/lib/X11/fonts/hitachi/min24a.pcf
EURPS_J84MA48=/usr/lib/X11/fonts/hitachi/min48a.pcf
EURPS_J84MA72=/usr/lib/X11/fonts/hitachi/min72a.pcf
EURPS_J84MA96=/usr/lib/X11/fonts/hitachi/min96a.pcf
EURPS_J84MK16=/usr/lib/X11/fonts/hitachi/min16k.pcf
EURPS_J84MK24=/usr/lib/X11/fonts/hitachi/min24k.pcf
EURPS_J84MK48=/usr/lib/X11/fonts/hitachi/min48k.pcf
EURPS_J84MK72=/usr/lib/X11/fonts/hitachi/min72k.pcf
EURPS_J84MK96=/usr/lib/X11/fonts/hitachi/min96k.pcf
EURPS_J84GA16=/usr/lib/X11/fonts/hitachi/got16a.pcf
EURPS_J84GA24=/usr/lib/X11/fonts/hitachi/got24a.pcf
EURPS_J84GA48=/usr/lib/X11/fonts/hitachi/got48a.pcf
EURPS_J84GA72=/usr/lib/X11/fonts/hitachi/got72a.pcf
EURPS_J84GA96=/usr/lib/X11/fonts/hitachi/got96a.pcf
EURPS_J84GK16=/usr/lib/X11/fonts/hitachi/got16k.pcf
EURPS_J84GK24=/usr/lib/X11/fonts/hitachi/got24k.pcf
EURPS_J84GK48=/usr/lib/X11/fonts/hitachi/got48k.pcf
EURPS_J84GK72=/usr/lib/X11/fonts/hitachi/got72k.pcf
EURPS_J84GK96=/usr/lib/X11/fonts/hitachi/got96k.pcf
EURPS_PRINTERINFPATH=/home/eur/printerinf
EURPS_USE_05_06_FONT_REPLACE=YES
EURPS_FONT_WIDTH_MODE=STATIC
EURPS_TESTPRINTFILE=/home/eur/testprintfile/testprintfile.txt
EURPS_FONT_ROUNDDOWN=NO
EURPS_MAX_SPOOL_PAGES=2000
EURPS_DONT_PRINT_IF_DB_RESULT_EMPTY=YES
EURPS_PDF_BUFSIZE=2
EURPS_PDF_IMAGEDRAWUNIT=INTEGER
EURPS_EPFDPI=1
EURPS_EPF_IMAGE_COMPRESS=ON
EURPS_UPC_BARCODE=ENABLE


EUR Server - Adapterの環境設定ファイル（EURPMADP.ini）

15.4　EUR Server - Adapterの環境設定ファイル（EURPMADP.ini）

対象コンポーネントまたは機能
EUR Server - Adapter
設定内容
EUR Server - Adapterの動作環境は，環境設定ファイル（EURPMADP.ini）で設定します。
環境設定ファイルを変更した場合は，EUR Server - Adapterを使用しているプログラムを再起動してください。
環境設定ファイルの格納場所
  • Windows環境の場合
    環境設定ファイル（EURPMADP.ini）は，インストール先フォルダ\Adapter下に作成されます。
    ファイルの内容を追加，変更する場合は，メモ帳などのテキスト編集エディタを起動して編集したあと，上書き保存してから使用してください。
  • UNIX／Linux環境の場合
    次に示す環境設定ファイル（EURPMADP.ini）のサンプルを，/opt/eur/sample/ServerAdapter下に提供しています。必要な内容を設定したあと，同じファイル名で/var/opt/eur/adapter下に格納してください。
    なお，/var/opt/eur/adapterには，EUR Server - Adapterを利用するユーザが読み書きできるようにアクセス権を設定してください。
＜環境設定ファイル（EURPMADP.ini）のサンプルの内容＞
[PORT]

[IPADDRESS]
EURPM=

[ERROR]

[OPTION]
SOCKBUFFSIZE=64
DISPPRINTDLG=2

[TIMEOUT]

環境設定ファイルの構文

変数名=値

環境設定ファイルに指定する情報は，「"」で囲まないでください。
環境設定ファイルの指定例（Windows環境の場合）

[PORT]
EURPM=22314

[IPADDRESS]
EURPM=127.0.0.1

[ERROR]
LOGFILE=C:\EURPMADP\Log
LOGLEVEL=4
LOGSIZE=750
DBZEROEXITCODE=4

[OPTION]
PRINTMODE=0
DEFAULTPRINTMODE=3
SOCKBUFFSIZE=64
DATABUFFSIZE=100
DISPPRINTDLG=2
FILEOUTPUTDESTINATION=0
SPOOLLIMIT=20120521

[TIMEOUT]
OUTPUT=300
EPFOUTPUT=300
EUROUTPUT=300
PDFOUTPUT=300
DESTLIST=300
PRTCLSLIST=300
XLSXOUTPUT=300
MERGEOUTPUT=300
＜この節の構成＞
15.4.1　設定項目一覧
15.4.2　EURPM
15.4.3　EURPM
15.4.4　LOGFILE
15.4.5　LOGLEVEL
15.4.6　LOGSIZE
15.4.7　DBZEROEXITCODE
15.4.8　PRINTMODE
15.4.9　DEFAULTPRINTMODE
15.4.10　SOCKBUFFSIZE
15.4.11　DATABUFFSIZE
15.4.12　DISPPRINTDLG
15.4.13　FILEOUTPUTDESTINATION
15.4.14　SPOOLLIMIT
15.4.15　OUTPUT
15.4.16　EPFOUTPUT
15.4.17　EUROUTPUT
15.4.18　PDFOUTPUT
15.4.19　DESTLIST
15.4.20　PRTCLSLIST
15.4.21　XLSXOUTPUT
15.4.22　MERGEOUTPUT


設定項目一覧

15.4.1　設定項目一覧

EUR Server - Adapterの環境設定ファイル（EURPMADP.ini）で指定できる内容を次の表に示します。

表15-41　EUR Server - Adapterの環境設定ファイル（EURPMADP.ini）で指定できる内容

セクション | キー | 説明
PORT | EURPM | EUR Server Serviceのポート番号を指定します。
IPADDRESS | EURPM | EUR Server Serviceが稼働するサーバのIPアドレスを指定します。
ERROR | LOGFILE | ログファイル（EURPMADP.log）の出力先フォルダを指定します。
 | LOGLEVEL | 実行ログの出力レベルを指定します。
 | LOGSIZE | ログファイル（EURPMADP.log）のファイルサイズの上限を指定します。
 | DBZEROEXITCODE | 環境変数EURPS_DONT_PRINT_IF_DB_RESULT_EMPTYにYESを指定し，データベースからのデータ抽出結果が0件のときに，EUR Server - Adapterから返却される終了コードを指定します。
OPTION | PRINTMODE | 印刷方法が未指定の場合の印刷方法を指定します。
 | DEFAULTPRINTMODE | デフォルト印刷方式を指定します。
 | SOCKBUFFSIZE | ソケット通信に使用する通信バッファサイズの上限を指定します。
 | DATABUFFSIZE | ファイルを転送するときの分割転送のサイズを指定します。
 | DISPPRINTDLG | クライアントPCで印刷する場合のダイアログの表示モードを指定します。
 | FILEOUTPUTDESTINATION | PDF形式ファイルの出力先を，EUR Server - Adapter稼働マシンにするか，またはEUR Server Service稼働マシンにするかのどちらかを指定します。
 | SPOOLLIMIT | スプールデータの蓄積期限日を指定します。
TIMEOUT | OUTPUT | 印刷または蓄積を要求するときの通信タイムアウト監視時間を指定します。
 | EPFOUTPUT | EPF形式ファイル生成を要求するときの通信タイムアウト監視時間を指定します。
 | EUROUTPUT | EUR形式ファイル生成を要求するときの通信タイムアウト監視時間を指定します。
 | PDFOUTPUT | PDF形式ファイル生成を要求するときの通信タイムアウト監視時間を指定します。
 | DESTLIST | 出力先一覧を取得するときの通信タイムアウト監視時間を指定します。
 | PRTCLSLIST | プリンタクラス一覧，プリンタ一覧，またはトレイ一覧を取得するときの通信タイムアウト監視時間を指定します。
 | XLSXOUTPUT | Excel形式ファイル生成を要求するときの通信タイムアウト監視時間を指定します。
 | MERGEOUTPUT | 複数のEPF形式ファイルの統合を要求するときの通信タイムアウト監視時間を指定します。


EURPM

15.4.2　EURPM

セクション
[PORT]
設定内容
EUR Server Serviceのポート番号を指定します。
指定値
指定できる値は0～65535です。
省略値
EURPMキーを省略した場合は，「22314」が仮定されます。
注意事項
起動部品で帳票サーバのポート番号を指定している場合は，起動部品の指定が優先されます。帳票サーバのポート番号を指定する起動部品のプロパティ，メソッド，パラメタ，およびコマンドのオプションを次に示します。
  • ActiveX起動部品：PMServerPortプロパティ
  • Java起動部品：setPMServerPortメソッド
  • COBOL起動部品：PMSERVERPORTパラメタ
  • コマンド：eurpmcコマンドの/pmpnオプション


EURPM

15.4.3　EURPM

セクション
[IPADDRESS]
設定内容
EUR Server Serviceが稼働するサーバのIPアドレスを指定します。
指定値
255.255.255.255形式で指定します。
省略値
起動部品の帳票サーバのIPアドレスが省略されているときに，EURPMキーの指定を省略すると，デフォルト値（127.0.0.1）が仮定されます。
注意事項
  • EUR Server ServiceとEUR Server - Adapterが同じマシンで稼働する場合，EUR Server ServiceとEUR Server - Adapter間のファイル転送時間を短縮できます。ファイル転送時間を短縮する場合は，マニュアル「EUR システム設計ガイド」を参照してください。
  • 起動部品で帳票サーバのIPアドレスを指定している場合は，起動部品の指定が優先されます。帳票サーバのIPアドレスを指定する起動部品のプロパティ，メソッド，パラメタ，およびコマンドのオプションを次に示します。
  • ActiveX起動部品：PMServerAddressプロパティ
  • Java起動部品：setPMServerAddressメソッド
  • COBOL起動部品：PMSERVERADDRパラメタ
  • コマンド：eurpmcコマンドの/pmipオプション


LOGFILE

15.4.4　LOGFILE

セクション
[ERROR]
設定内容
ログファイル（EURPMADP.log）の出力先フォルダを指定します。
指定値
フルパスで指定します。
省略値
LOGFILEキーを省略した場合は，次のフォルダが仮定されます。
  • Windows環境のとき
    インストール先フォルダ\Logフォルダ
  • UNIX／Linux環境のとき
    /var/opt/eur/log


LOGLEVEL

15.4.5　LOGLEVEL

セクション
[ERROR]
設定内容
実行ログの出力レベルを指定します。
指定値
指定できる値を次に示します。
  • 0：ログ出力しません。
  • 4：起動，終了，実行時パラメタ，エラーを出力します。
  • 8：起動，終了，実行時パラメタ，エラー，警告を出力します。
  • 16：起動，終了，実行時パラメタ，エラー，警告，情報を出力します。
省略値
LOGLEVELキーを省略した場合は，「8」が仮定されます。
注意事項
出力レベルに「16」を指定すると，トレース情報が大量に出力されるため，性能が落ちるおそれがあります。障害調査時以外には指定しないでください。


LOGSIZE

15.4.6　LOGSIZE

セクション
[ERROR]
設定内容
ログファイル（EURPMADP.log）のファイルサイズの上限を指定します。
指定値
指定できる値は750～2,000,000です。単位はKBです。
指定できない値を指定した場合は，省略値と同じ値が仮定されます。
省略値
LOGSIZEキーを省略した場合は，「750」が仮定されます。


DBZEROEXITCODE

15.4.7　DBZEROEXITCODE

セクション
[ERROR]
設定内容
環境変数EURPS_DONT_PRINT_IF_DB_RESULT_EMPTYにYESを指定し，データベースからのデータ抽出結果が0件のときに，EUR Server - Adapterから返却される終了コードを指定します。
指定値
指定できる値は0～127です。
指定できない値を指定した場合は，省略値と同じ値が仮定されます。
省略値
DBZEROEXITCODEキーを省略した場合は，「4」が仮定されます。


PRINTMODE

15.4.8　PRINTMODE

セクション
[OPTION]
設定内容
印刷方法が未指定の場合の印刷方法を指定します。
指定値
指定できる値を次に示します。
  • 0：デフォルト印刷方式※で印刷します。
  • 1：クライアントPCで印刷します。
  • 2：蓄積します。
  • 3：スプールサーバで印刷します。
  • 4：帳票サーバ直接印刷方式で印刷します。
  • 5：クライアントPCで配布印刷します。
0，1，2，3，4，5以外の値を指定した場合は，省略値と同じ値が仮定されます。
注※
「0（デフォルト印刷方式）」を定義する場合は，環境設定ファイル（EURPMADP.ini）でOPTIONセクションのDEFAULTPRINTMODEキーに値を設定してください。
省略値
PRINTMODEキーを省略した場合は，「0」が仮定されます。
注意事項
起動部品で印刷方法を指定している場合は，起動部品の指定が優先されます。印刷方法を指定する起動部品のプロパティ，メソッド，パラメタ，およびコマンドのオプションを次に示します。
  • ActiveX起動部品：PrintModeプロパティ
  • Java起動部品：setPrintModeメソッド
  • COBOL起動部品：PrintReport関数（PRINTMODEパラメタ）
  • コマンド：eurpmcコマンドの/pmオプション


DEFAULTPRINTMODE

15.4.9　DEFAULTPRINTMODE

セクション
[OPTION]
設定内容
デフォルト印刷方式を指定します。
指定値
指定できる値を次に示します。
  • 1：クライアントPCで印刷します。
  • 2：蓄積します。
  • 3：スプールサーバで印刷します。
  • 4：帳票サーバ直接印刷方式で印刷します。
  • 5：クライアントPCで配布印刷します。
1，2，3，4，5以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
DEFAULTPRINTMODEキーを省略した場合は，「3」が仮定されます。


SOCKBUFFSIZE

15.4.10　SOCKBUFFSIZE

セクション
[OPTION]
設定内容
ソケット通信に使用する通信バッファサイズの上限を指定します。
指定値
指定できる値は，1～2,000,000です。単位はKBです。
通信バッファサイズの上限を無制限にしたい場合は，「0」を指定してください。
0～2,000,000以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
SOCKBUFFSIZEキーを省略した場合は，「64」が仮定されます。
注意事項
KEEY208-Eの通信エラーが発生し，かつEURPMログのエラー詳細情報に「errno=10055」が出力されているときは，指定した通信バッファサイズを確保するためのシステムのバッファ領域が不足していることを示しています。エラーが発生したときは，SOCKBUFFSIZEキーに指定されている値を小さく（8～64）して再試行してください。
なお，指定した値によっては，通信性能が変わることがあります。通信性能が劣化する場合は値を変更してチューニングしてください。


DATABUFFSIZE

15.4.11　DATABUFFSIZE

セクション
[OPTION]
設定内容
ファイルを転送するときの分割転送のサイズを指定します。
指定値
指定できる値は，1～10,000です。単位はKBです。
1～10,000以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
DATABUFFSIZEキーを省略した場合は，「100」が仮定されます。
注意事項
  • EUR Server - Adapterでファイル転送が実行されるプロパティ（ファイル）を指定したジョブを実行する場合，ファイル転送されるファイルごとに，指定したサイズの10～15倍のメモリがEUR Server - Adapter，およびEUR Server Service稼働マシンの両方に必要となります。
  • PDF形式ファイル出力のとき：約15倍
  • PDF形式ファイル以外のファイル出力，および印刷実行のとき：約10倍
転送の対象になるファイルを次に示します。
  • マッピングデータファイル（可変値記号ファイル）
  • ユーザ定義データファイル（可変値記号ファイル）
  • 文書しおり定義ファイル
  • しおり定義ファイル
  • PDF仕分け定義ファイル
  • 暗号化設定ファイル
  • 分割定義ファイルまたは仕分け定義ファイル
  • 帳票セット指定ファイルで指定したマッピングデータファイル，ユーザ定義データファイル，しおり定義ファイル
  • EPF形式ファイル
  • EUR Server Serviceの印刷およびファイル出力実行時に，KEEY314-Sのメモリ不足エラーが発生した場合は，DATABUFFSIZEキーの値（ファイル転送時の分割転送サイズ）を小さくして再試行してください。
    なお，指定した値によっては，通信性能が変わることがあります。通信性能が劣化する場合は値を変更してチューニングしてください。
  • EUR Server - Adapterの印刷およびファイル出力実行時に，KEEY215-SまたはKEEY906-Eのメモリ不足エラー，もしくはKEEY217-Sのシステムエラーが発生した場合は，DATABUFFSIZEキーの値（ファイル転送時の分割転送サイズ）を小さくして再試行してください。
    なお，指定した値によっては，通信性能が変わることがあります。通信性能が劣化する場合は値を変更してチューニングしてください。


DISPPRINTDLG

15.4.12　DISPPRINTDLG

セクション
[OPTION]
設定内容
クライアントPCで印刷する場合のダイアログの表示モードを指定します。
指定値
指定できる値と印刷時の動作を次に示します。
  • 0：印刷先指定ダイアログを表示します（対話型印刷）。
    プレビューボタンを選択すると，プレビューウィンドウが表示されます。
  • 1：直接印刷を実行します（自動印刷）。
    印刷実行中に印刷中のダイアログを表示します。
  • 2：プレビューウィンドウを表示します（対話型印刷プレビュー表示）。
    印刷メニューまたは印刷ボタンを選択すると，印刷先指定ダイアログが表示されます。
  • 3：直接印刷を実行します（全自動印刷）。
    印刷実行中に印刷中のダイアログを表示しません。
  • 4：プレビューウィンドウを表示します（対話型印刷プレビュー表示限定）。
    印刷は実行できません。
0，1，2，3，4以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
DISPPRINTDLGキーを省略した場合は，「0」が仮定されます。
注意事項
起動部品でダイアログの表示モードを指定している場合は，起動部品の指定が優先されます。ダイアログの表示モードを指定する起動部品のプロパティ，メソッド，パラメタ，およびコマンドのオプションを次に示します。
  • ActiveX起動部品：DispPrintDlgプロパティ
  • Java起動部品：setDispPrintDlgメソッド
  • COBOL起動部品：PrintReport関数（DISPPRINTDLGパラメタ）
  • コマンド：eurpmcコマンドの/dialogオプション


FILEOUTPUTDESTINATION

15.4.13　FILEOUTPUTDESTINATION

セクション
[OPTION]
設定内容
EUR Server Service稼働マシンで生成したPDF形式ファイルの出力処理を，EUR Server - Adapter稼働マシン，またはEUR Server Service稼働マシンのどちらで行うかを指定します。
指定値
指定できる値を次に示します。
  • 0：EUR Server - Adapter稼働マシンで，ファイル出力処理を行います。
  • 1：EUR Server Service稼働マシンで，ファイル出力処理を行います。
0，1以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
FILEOUTPUTDESTINATIONキーを省略した場合は，「0」が仮定されます。
注意事項
  • 起動部品でPDF形式ファイルの出力先を指定している場合は，起動部品の指定が優先されます。PDF形式ファイルの出力先を指定する起動部品のプロパティ，メソッド，パラメタ，およびコマンドのオプションを次に示します。
  • ActiveX起動部品：FileOutputDestinationプロパティ
  • Java起動部品：setFileOutputDestinationメソッド
  • COBOL起動部品：FILEOUTPUTDESTINATIONパラメタ
  • コマンド：eurpmcコマンドの/foutdestオプション
  • EUR Server Service稼働マシンにPDF形式ファイルを出力する場合，PDFの出力先フォルダは，起動部品の指定値だけでなく，EUR Server Serviceの環境設定ファイルのPATHMODEキーおよびPDFキーの設定値によって決まります。PATHMODEキーの詳細については「15.2.21　PATHMODE」を，PDFキーの詳細については「15.2.15　PDF」を参照してください。
  • Java起動部品のsetDistributeFileDataメソッドでPDF仕分け定義データを指定した場合は，FILEOUTPUTDESTINATIONキーの指定は無視されます。この場合，PDF仕分け定義データに記述されている出力先ファイル名に従って，EUR Server Service稼働マシンにPDF形式ファイルを出力します。
  • 起動部品でPDF仕分け定義ファイル名を指定した場合は，FILEOUTPUTDESTINATIONキーの指定は無視されます。この場合，PDF仕分け定義ファイルに記述されている出力先ファイル名に従って，EUR Server Service稼働マシンにPDF形式ファイルを出力します。PDF仕分け定義ファイル名を指定する起動部品のプロパティ，メソッド，パラメタ，およびコマンドのオプションを次に示します。
  • ActiveX起動部品：DistributeFileNameプロパティ
  • Java起動部品：setDistributeFileNameメソッド
  • COBOL起動部品：DISTRIBUTEFILENAMEパラメタ
  • コマンド：eurpmcコマンドの/dsfオプション


SPOOLLIMIT

15.4.14　SPOOLLIMIT

セクション
[OPTION]
設定内容
スプールデータの蓄積期限日を指定します。日付または日数で指定してください。
日付処理には，協定世界時（UTC）を使用します。
指定値
指定できる値を次に示します。
日付で指定する場合
  • 「YYYYMMDD」の形式で指定してください。
  • 年（西暦）は4桁，月と日は2桁で入力します。
  • 月，または日が1～9の場合は，ゼロ埋めをして入力します。
  • 指定できる値の上限は，20380118（2038年1月18日）です。
  • （指定例）20120521，20141008
日数で指定する場合
  • 「+XXX」の形式で指定してください。
  • 「XXX」には，蓄積実行時からの保管日数を指定します。指定できる値は000～999です。0を指定した場合は，翌日にスプールデータが削除されます。
  • 2038年1月18日を超える日数は指定できません。
    （指定例）+030，+999
指定できない値を指定した場合は，省略値と同じ値が仮定されます。
省略値
SPOOLLIMITキーを省略した場合は，蓄積時から30日後が蓄積期限日として設定されます。
注意事項
起動部品でスプールデータの蓄積期限日を指定している場合は，起動部品の指定が優先されます。蓄積期限日を指定する起動部品のプロパティ，メソッド，パラメタ，およびコマンドのオプションを次に示します。
  • ActiveX起動部品：SpoolLimitプロパティ
  • Java起動部品：setSpoolLimitメソッド
  • COBOL起動部品：PrintReport関数（SPOOLLIMITパラメタ）
  • コマンド：eurpmcコマンドの/lmオプション


OUTPUT

15.4.15　OUTPUT

セクション
[TIMEOUT]
設定内容
印刷または蓄積を要求するときの通信タイムアウト監視時間を指定します。
指定値
指定できる値は，0～86,400（24時間）です。単位は秒です。
0を指定した場合は，タイムアウト監視はしません。
0～86,400以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
OUTPUTキーを省略した場合は，「0」が仮定されます。


EPFOUTPUT

15.4.16　EPFOUTPUT

セクション
[TIMEOUT]
設定内容
EPF形式ファイル生成を要求するときの通信タイムアウト監視時間を指定します。
指定値
指定できる値は，0～86,400（24時間）です。単位は秒です。
0を指定した場合は，タイムアウト監視はしません。
0～86,400以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
EPFOUTPUTキーを省略した場合は，「0」が仮定されます。


EUROUTPUT

15.4.17　EUROUTPUT

セクション
[TIMEOUT]
設定内容
EUR形式ファイル生成を要求するときの通信タイムアウト監視時間を指定します。
指定値
指定できる値は，0～86,400（24時間）です。単位は秒です。
0を指定した場合は，タイムアウト監視はしません。
0～86,400以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
EUROUTPUTキーを省略した場合は，「0」が仮定されます。


PDFOUTPUT

15.4.18　PDFOUTPUT

セクション
[TIMEOUT]
設定内容
PDF形式ファイル生成を要求するときの通信タイムアウト監視時間を指定します。
指定値
指定できる値は，0～86,400（24時間）です。単位は秒です。
0を指定した場合は，タイムアウト監視はしません。
0～86,400以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
PDFOUTPUTキーを省略した場合は，「0」が仮定されます。


DESTLIST

15.4.19　DESTLIST

セクション
[TIMEOUT]
設定内容
出力先一覧を取得するときの通信タイムアウト監視時間を指定します。
指定値
指定できる値は，0～86,400（24時間）です。単位は秒です。
0を指定した場合は，タイムアウト監視はしません。
0～86,400以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
DESTLISTキーを省略した場合は，「0」が仮定されます。


PRTCLSLIST

15.4.20　PRTCLSLIST

セクション
[TIMEOUT]
設定内容
プリンタクラス一覧，プリンタ一覧，またはトレイ一覧を取得するときの通信タイムアウト監視時間を指定します。
指定値
指定できる値は，0～86,400（24時間）です。単位は秒です。
0を指定した場合は，タイムアウト監視はしません。
0～86,400以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
PRTCLSLISTキーを省略した場合は，「0」が仮定されます。


XLSXOUTPUT

15.4.21　XLSXOUTPUT

セクション
[TIMEOUT]
設定内容
Excel形式ファイル生成を要求するときの通信タイムアウト監視時間を指定します。
指定値
指定できる値は，0～86,400（24時間）です。単位は秒です。
0を指定した場合は，タイムアウト監視はしません。
0～86,400以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
XLSXOUTPUTキーを省略した場合は，「0」が仮定されます。


MERGEOUTPUT

15.4.22　MERGEOUTPUT

セクション
[TIMEOUT]
設定内容
複数のEPF形式ファイルの統合を要求するときの通信タイムアウト監視時間を指定します。
指定値
指定できる値は，0～86,400（24時間）です。単位は秒です。
0を指定した場合は，タイムアウト監視はしません。
0～86,400以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
MERGEOUTPUTキーを省略した場合は，「0」が仮定されます。


EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）

15.5　EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）

対象コンポーネントまたは機能
EUR Server - Spool Service
設定内容
EUR Server - Spool Serviceの動作環境は，環境設定ファイル（EURPMLS.ini）で設定します。
環境設定ファイルを変更した場合は，EUR Server - Spool Serviceを再起動してください。
環境設定ファイルの格納場所
  • Windows環境の場合
    環境設定ファイル（EURPMLS.ini）は，インストール先フォルダ\Spool下に作成されます。
    ファイルの内容を追加，変更する場合は，メモ帳などのテキスト編集エディタを起動して編集したあと，上書き保存してから使用してください。
  • UNIX／Linux環境の場合
    次に示す環境設定ファイル（EURPMLS.ini）のサンプルを，/opt/eur/sample/SpoolService下に提供しています。必要な内容を設定したあと，同じファイル名で/var/opt/eur/spool下に格納してください。
    なお，/var/opt/eur/spoolには，EUR Server - Spool Serviceを利用するユーザが読み書きできるようにアクセス権を設定してください。
＜環境設定ファイル（EURPMLS.ini）のサンプルの内容＞
[PORT]

[PATH]

[ERROR]

[OPTION]
SOCKBUFFSIZE=64
PERSONALCATEGORY=personal
STANDARDTIME=1

[CONF]

[THREAD]
MERGE=1

[TIMEOUT]

[AUDIT]
SPOOLAUDITLOG=1
#SPOOLLOGSIZE=3000
#SPOOLLOG=
#SPOOLLOGDATE=
#SPOOLLOGNUM=10
#SPOOLLOGMODE=0
環境設定ファイルの構文

変数名=値

環境設定ファイルに指定する情報は，「"」で囲まないでください。
環境設定ファイルの指定例

[PORT]
EURPMLS=22313
EURPMCL=23035

[PATH]
CONF=C:\EURPMLS\Conf
TEMP=C:\EURPMLS\Temp
ESF=C:\EURPMLS\ESF
POB=C:\EURPMLS\POB

[ERROR]
LOGFILE=C:\EURPMLS\Log
LOGLEVEL=4
LOGSIZE=750

[OPTION]
TEMPFILEDEL=1
ESFAUTODEL=1
SOCKBUFFSIZE=64
SPLOUTLINELIMIT=0
ESFID=0
AUTHENTICATION=1
INTERVAL=300
PERSONALCATEGORY=EURCATEGORY
APSAUTO=1
LDAPSERVER1=127.0.0.1:389
LDAPBINDDN=CN=Administrator,CN=Users,DC=hitachi,DC=eur,DC=jp
LDAPPASSWORD=LDAPPASSWORD
LDAPBASEDN=OU=Hokuriku,DC=hitachi,DC=eur,DC=jp
LDAPUIDATTR=sAMAccountName
LDAPTLS=YES
ENCRYPTPASSWORD=TRUE
RMDIRRETRYCOUNT=1
RMDIRINTERVALTIME=200
LDAPPASSWORDEMPTYCHECK=YES
STANDARDTIME=0

[CONF]
ADDRDEFFILENAME=addrdef.txt

[THREAD]
GENERAL=200
EURPS=1
MERGE=0

[TIMEOUT]
CONNECT=300
ERRIGNORE=300
WAITINGLIMIT=7
PRINTINGLIMIT=7
PRINTEDLIMIT=30
ERRORLIMIT=30
LDAPCONNECT=1
＜この節の構成＞
15.5.1　設定項目一覧
15.5.2　EURPMLS
15.5.3　EURPMCL
15.5.4　CONF
15.5.5　TEMP
15.5.6　ESF
15.5.7　POB
15.5.8　LOGFILE
15.5.9　LOGLEVEL
15.5.10　LOGSIZE
15.5.11　TEMPFILEDEL
15.5.12　ESFAUTODEL
15.5.13　SOCKBUFFSIZE
15.5.14　SPLOUTLINELIMIT
15.5.15　ESFID
15.5.16　AUTHENTICATION
15.5.17　INTERVAL
15.5.18　PERSONALCATEGORY
15.5.19　APSAUTO
15.5.20　LDAPSERVER
15.5.21　LDAPBINDDN
15.5.22　LDAPPASSWORD
15.5.23　LDAPBASEDN
15.5.24　LDAPUIDATTR
15.5.25　LDAPTLS
15.5.26　ENCRYPTPASSWORD
15.5.27　RMDIRRETRYCOUNT
15.5.28　RMDIRINTERVALTIME
15.5.29　LDAPPASSWORDEMPTYCHECK
15.5.30　STANDARDTIME
15.5.31　ADDRDEFFILENAME
15.5.32　GENERAL
15.5.33　EURPS
15.5.34　MERGE
15.5.35　CONNECT
15.5.36　ERRIGNORE
15.5.37　WAITINGLIMIT
15.5.38　PRINTINGLIMIT
15.5.39　PRINTEDLIMIT
15.5.40　ERRORLIMIT
15.5.41　LDAPCONNECT
15.5.42　SPOOLAUDITLOG
15.5.43　SPOOLLOG
15.5.44　SPOOLLOGSIZE
15.5.45　SPOOLLOGDATE
15.5.46　SPOOLLOGNUM
15.5.47　SPOOLLOGMODE


設定項目一覧

15.5.1　設定項目一覧

EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）で指定できる内容を次の表に示します。

表15-42　EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）で指定できる内容

セクション | キー | 説明
PORT | EURPMLS | EUR Server - Spool Serviceのポート番号を指定します。
 | EURPMCL | EUR Client Serviceのポート番号を指定します。
PATH | CONF | 構成定義ファイルがあるフォルダを指定します。
 | TEMP | EUR Server - Spool Serviceの作業フォルダを指定します。
 | ESF | EUR Server - Spool Serviceの蓄積フォルダを絶対パスで指定します。
 | POB | EUR Server - Spool Serviceの私書箱フォルダを絶対パスで指定します。
ERROR | LOGFILE | ログファイル（EURPMLS.log）の出力先フォルダを指定します。
 | LOGLEVEL | 実行ログの出力レベルを指定します。
 | LOGSIZE | ログファイル（EURPMLS.log）のファイルサイズの上限を指定します。
OPTION | TEMPFILEDEL | 印刷実行時に生成した一時ファイルを削除するかどうかを指定します。
 | ESFAUTODEL | 期限が切れたスプールデータを自動削除するかどうかを指定します。
 | SOCKBUFFSIZE | ソケット通信に使用する通信バッファサイズの上限を指定します。
 | SPLOUTLINELIMIT | スプールデータの一覧を取得する場合の上限時間を指定します。
 | ESFID | 複数のEUR Server - Spool Serviceが蓄積フォルダを共有する場合の管理IDを指定します。
 | AUTHENTICATION | 配送印刷および帳票管理GUIの認証方式を指定します。
 | INTERVAL | 配送印刷時のポーリング間隔を指定します。
 | PERSONALCATEGORY | ユーザの自分宛て帳票を取得するかどうかを指定します。
 | APSAUTO | EUR Application Serviceを自動起動するかどうかを指定します。
 | LDAPSERVER | LDAP認証を行う場合に，LDAPサーバのサーバ名およびポート番号を指定します。
 | LDAPBINDDN | LDAP認証を行う場合に，LDAPサーバでユーザ検索できる権限を持つユーザのIDを指定します。
 | LDAPPASSWORD | LDAP認証を行う場合に，LDAPサーバでユーザ検索できる権限を持つユーザのパスワードを指定します。指定したパスワードはLDAP接続情報暗号化ツールを使用して暗号化できます。
 | LDAPBASEDN | LDAP認証を行う場合に，LDAPサーバの検索ベースDNを指定します。
 | LDAPUIDATTR | LDAP認証を行う場合に，ログイン画面で入力されたログオンユーザの属性名を指定します。
 | LDAPTLS | LDAP認証を行う場合に，LDAPサーバとの通信をTLS通信で行うかどうかを指定します。
 | ENCRYPTPASSWORD | キーワードLDAPPASSWORDで指定したパスワードを暗号化したときに自動で指定されます。
 | RMDIRRETRYCOUNT | EUR Server - Spool Serviceで作業用一時ディレクトリの削除に失敗した場合，リトライする回数を指定します。
 | RMDIRINTERVALTIME | EUR Server - Spool Serviceで作業用一時ディレクトリの削除に失敗した場合，リトライするまでの待機時間を指定します。
 | LDAPPASSWORDEMPTYCHECK | LDAP認証を行う場合に，特定のキーまたはパスワードの必須チェックの有無を指定します。
 | STANDARDTIME | EUR Server - Spool Serviceが稼働するマシンの日付が変わったあと，EUR Server - Spool Serviceに対して最初の要求があったときに，蓄積期限が切れたスプールデータの削除，および保持期限が切れた宛先情報の状態変更（状態が「印刷済み」または「エラー」の場合は削除）を自動的に実行する処理において，日付変更の契機にローカルタイムと協定世界時（UTC）のどちらを使用するかを指定します。
CONF | ADDRDEFFILENAME | 宛先定義ファイルの名称に「addrdef.conf」以外のファイル名またはファイル形式を使用したい場合に，ファイルの名称を指定します。
THREAD | GENERAL | EUR Server - Spool Serviceの並列処理数を指定します。
 | EURPS | EUR Print Serviceの並列処理数を指定します。
 | MERGE | 複数のスプールデータのジョブIDを指定して蓄積操作（印刷および取得）を実行する場合の並列処理数を指定します。
TIMEOUT | CONNECT | 意図しない接続元が，データ通信を行わないでEUR Server - Spool Serviceと接続したままの状態になった場合，切断するまでの時間を指定します（タイムアウト監視）。
 | ERRIGNORE | ソケットを接続してデータを通信しないで切断する処理（生死監視）が実行された場合に，切断を検知してもエラーを出力しない時間を指定します。
 | WAITINGLIMIT | 配送印刷した帳票の状態が「印刷待ち」のときに，印刷待ちのままにしておく期限を指定します。
 | PRINTINGLIMIT | 配送印刷した帳票の状態が「印刷中」のときに，印刷中のままにしておく期限を指定します。
 | PRINTEDLIMIT | 配送印刷した帳票の状態が「印刷済み」のときに，スプールサーバから帳票を削除するまでの期限を指定します。
 | ERRORLIMIT | 配送印刷した帳票の状態が「エラー」のときに，スプールサーバから帳票を削除するまでの期限を指定します。
 | LDAPCONNECT | LDAPサーバ接続時の通信タイムアウト監視時間を指定します。
AUDIT | SPOOLAUDITLOG | 監査ログを出力するかどうかを指定します。
 | SPOOLLOG | 監査ログファイル（eur_spool_audit.log）の出力先フォルダを指定します。
 | SPOOLLOGSIZE | 監査ログファイル（eur_spool_audit.log）のファイルサイズの上限を指定します。
 | SPOOLLOGDATE | 監査ログファイル（eur_spool_audit.log）のバックアップファイルの作成時刻を指定します。
 | SPOOLLOGNUM | 監査ログファイル（eur_spool_audit.log）のバックアップファイルの保持数を指定します。
 | SPOOLLOGMODE | 監査ログに出力する情報量のモードを指定します。


EURPMLS

15.5.2　EURPMLS

セクション
[PORT]
設定内容
EUR Server - Spool Serviceのポート番号を指定します。
指定値
指定できる値は0～65535です。
省略値
EURPMLSキーを省略した場合は，「22313」が仮定されます。


EURPMCL

15.5.3　EURPMCL

セクション
[PORT]
設定内容
EUR Client Serviceのポート番号を指定します。
指定値
指定できる値は0～65535です。
省略値
EURPMCLキーを省略した場合は，「23035」が仮定されます。


CONF

15.5.4　CONF

セクション
[PATH]
設定内容
構成定義ファイルがあるフォルダを指定します。
指定値
フルパスで指定します。
省略値
CONFキーを省略した場合は，次のフォルダが仮定されます。
  • Windows環境のとき
    インストール先フォルダ\Spool\Confフォルダ
  • UNIX／Linux環境のとき
    /var/opt/eur/spool/Conf


TEMP

15.5.5　TEMP

セクション
[PATH]
設定内容
EUR Server - Spool Serviceの作業フォルダを指定します。
指定値
フルパスで指定します。
省略値
TEMPキーを省略した場合は，次のフォルダが仮定されます。
  • Windows環境のとき
    インストール先フォルダ\Spool\Temp\フォルダ
  • UNIX／Linux環境のとき
    /var/opt/eur/spool/Temp


ESF

15.5.6　ESF

セクション
[PATH]
設定内容
EUR Server - Spool Serviceの蓄積フォルダを指定します。
指定値
フルパスで指定します。
省略値
ESFキーを省略した場合は，次のフォルダが仮定されます。
  • Windows環境のとき
    インストール先フォルダ\Spool\ESFフォルダ
  • UNIX／Linux環境のとき
    /var/opt/eur/spool/ESF
注意事項
  • 指定する蓄積フォルダはEUR Server - Spool Serviceサービスのアカウントが書き込める必要があります。
  • 蓄積フォルダには蓄積するたびにスプールデータが格納されるので，蓄積専用のディスクを用意して，ESFキーに指定することをお勧めします。


POB

15.5.7　POB

セクション
[PATH]
設定内容
EUR Server - Spool Serviceの私書箱フォルダを指定します。
指定値
フルパスで指定します。
省略値
POBキーを省略した場合は，次のフォルダが仮定されます。
  • Windows環境のとき
    インストール先フォルダ\Spool\POBフォルダ
  • UNIX／Linux環境のとき
    /var/opt/eur/spool/POB
注意事項
指定する私書箱フォルダはEUR Server - Spool Serviceサービスのアカウントが書き込める必要があります。


LOGFILE

15.5.8　LOGFILE

セクション
[ERROR]
設定内容
ログファイル（EURPMLS.log）の出力先フォルダを指定します。
指定値
フルパスで指定します。
省略値
LOGFILEキーを省略した場合は，次のフォルダが仮定されます。
  • Windows環境のとき
    インストール先フォルダ\Logフォルダ
  • UNIX／Linux環境のとき
    /var/opt/eur/log


LOGLEVEL

15.5.9　LOGLEVEL

セクション
[ERROR]
設定内容
実行ログの出力レベルを指定します。
指定値
指定できる値を次に示します。
  • 0：ログ出力しません。
  • 4：起動，終了，実行時パラメタ，エラーを出力します。
  • 8：起動，終了，実行時パラメタ，エラー，警告を出力します。
  • 16：起動，終了，実行時パラメタ，エラー，警告，情報を出力します。
省略値
LOGLEVELキーを省略した場合は，「8」が仮定されます。
注意事項
出力レベルに「16」を指定すると，トレース情報が大量に出力されるため，性能が落ちるおそれがあります。障害調査時以外には指定しないでください。


LOGSIZE

15.5.10　LOGSIZE

セクション
[ERROR]
設定内容
ログファイル（EURPMLS.log）のファイルサイズの上限を指定します。
指定値
指定できる値は750～2,000,000です。単位はKBです。
750～2,000,000以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
LOGSIZEキーを省略した場合は，「750」が仮定されます。


TEMPFILEDEL

15.5.11　TEMPFILEDEL

セクション
[OPTION]
設定内容
印刷実行時に生成した一時ファイルを削除するかどうかを指定します。
EUR Server - Spool Serviceは，印刷実行時にはTEMPキーで設定した作業フォルダに一時ファイルを生成できます。一時ファイルは，障害対策のために使用します。
指定値
指定できる値を次に示します。
  • 0：常に削除します。
  • 1：正常終了時は削除します。異常終了時は削除しません。
  • 2：常に削除しません。
0，1，2以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
TEMPFILEDELキーを省略した場合は，「1」が仮定されます。


ESFAUTODEL

15.5.12　ESFAUTODEL

セクション
[OPTION]
設定内容
期限が切れたスプールデータを自動削除するかどうかを指定します。
指定値
指定できる値を次に示します。
  • 0：自動削除しません。
  • 1：自動削除します。
0，1以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
ESFAUTODELキーを省略した場合は，「1」が仮定されます。


SOCKBUFFSIZE

15.5.13　SOCKBUFFSIZE

セクション
[OPTION]
設定内容
ソケット通信に使用する通信バッファサイズの上限を指定します。
指定値
指定できる値は，1～2,000,000です。単位はKBです。
通信バッファサイズの上限を無制限にしたい場合は，「0」を指定してください。
0～2,000,000以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
SOCKBUFFSIZEキーを省略した場合は，「64」が仮定されます。
注意事項
  • KEEY426-E，KEEY459-E，またはKEEY462-Eの通信エラーが発生し，かつEURPMログのエラー詳細情報に「errno=10055」が出力されているときは，指定した通信バッファサイズを確保するためのシステムのバッファ領域が不足していることを示しています。エラーが発生したときは，SOCKBUFFSIZEキーに指定されている値を小さく（8～64）して再試行してください。
  • 指定した値によっては，通信性能が変わることがあります。通信性能が劣化する場合は値を変更してチューニングしてください。


SPLOUTLINELIMIT

15.5.14　SPLOUTLINELIMIT

セクション
[OPTION]
設定内容
スプールデータの一覧を取得する場合の上限時間を指定します。指定した時間を経過すると，一覧を取得できなくなります。
指定値
指定できる値は，0または60～3,600です。単位は秒です。
取得時間を制限しない場合は，「0」を指定してください。
60～3,600以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
SPLOUTLINELIMITキーを省略した場合は，「0」が仮定されます。


ESFID

15.5.15　ESFID

セクション
[OPTION]
設定内容
複数のEUR Server - Spool Serviceが蓄積フォルダを共有する場合の管理IDを指定します。
指定値
指定できる値は，0～99です。
0～99以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
ESFIDキーを省略した場合は，「0」が仮定されます。
注意事項
管理IDにはEUR Server - Spool Serviceごとに異なる値を指定してください。同じ値を指定した場合，蓄積フォルダを正常に操作できません。


AUTHENTICATION

15.5.16　AUTHENTICATION

セクション
[OPTION]
設定内容
配送印刷および帳票管理GUIの認証方式を指定します。
指定値
指定できる値を次に示します。
  • 0：ユーザ管理ファイルによる認証
  • 1：LDAP認証
なお，AUTHENTICATIONキーで1（LDAP認証）を指定する場合は，次に示すキーを必ず指定してください。
  • LDAPSERVERキー
  • LDAPBINDDNキー
  • LDAPBASEDNキー
  • LDAPUIDATTRキー
0，1以外の値，もしくは数値以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
AUTHENTICATIONキーを省略した場合は，「0」が仮定されます。


INTERVAL

15.5.17　INTERVAL

セクション
[OPTION]
設定内容
配送印刷時のポーリング間隔を指定します。
指定値
指定できる値は0～86,400（24時間）です。単位は秒です。
ログイン時だけ配送印刷を実行したい場合は，「0」を指定してください。
0～86,400以外の値，もしくは数値以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
INTERVALキーを省略した場合は，「300（5分）」が仮定されます。


PERSONALCATEGORY

15.5.18　PERSONALCATEGORY

セクション
[OPTION]
設定内容
ユーザの自分宛ての帳票を取得するかどうかを指定します。
指定値
自分宛ての帳票を取得する場合は，宛先定義ファイルで定義された宛先キー分類と同じ値を指定してください。
配送印刷で自分宛ての帳票を取得するとき，PERSONALCATEGORYキーで指定した値を，宛先キー分類として使用します。
省略値
PERSONALCATEGORYキーを省略した場合は，配送印刷で自分宛ての帳票を取得できません。


APSAUTO

15.5.19　APSAUTO

セクション
[OPTION]
設定内容
EUR Application Serviceを自動起動するかどうかを指定します。
指定値
指定できる値を次に示します。
  • 0：自動起動しません。
  • 1：自動起動します。
0，1以外の値，もしくは数値以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
APSAUTOキーを省略した場合は，「1」が仮定されます。


LDAPSERVER

15.5.20　LDAPSERVER

セクション
[OPTION]
設定内容
LDAP認証を行う場合に，LDAPサーバのサーバ名およびポート番号を指定します。LDAPSERVERキーは，AUTHENTICATIONキーで1（LDAP認証）が指定されているときに有効になります。
指定値
指定できるサーバ名を次に示します。
  • LDAPSERVER1
  • LDAPSERVER2
  • LDAPSERVER3
  • LDAPSERVER4
  • LDAPSERVER5
複数のサーバ名を指定した場合は，LDAPSERVER1から順番で接続されます。また，五つのサーバ名をすべて指定する必要はありません。
サーバ名とポート番号は「:」で区切って指定してください。
記述例を次に示します。
[OPTION]
LDAPSERVER1=XXX.XXX.XX.XX:YYYY
LDAPSERVER2=XXX.XXX.XX.XX:YYYY
LDAPSERVER3=XXX.XXX.XX.XX:YYYY
LDAPSERVER4=XXX.XXX.XX.XX:YYYY
LDAPSERVER5=XXX.XXX.XX.XX:YYYY
（凡例）
LDAPSERVER1～5：キー名（固定値）
XXX.XXX.XX.XX：LDAPサーバ名
YYYY：ポート番号

省略値
LDAPSERVERキーを省略した場合は，未指定となります。


LDAPBINDDN

15.5.21　LDAPBINDDN

セクション
[OPTION]
設定内容
LDAP認証を行う場合に，LDAPサーバでユーザ検索できる権限を持つユーザのIDを指定します。
指定値
ユーザIDの文字列を指定します。
省略値
LDAPBINDDNキーを省略した場合は，未指定となります。


LDAPPASSWORD

15.5.22　LDAPPASSWORD

セクション
[OPTION]
設定内容
LDAP認証を行う場合に，LDAPサーバでユーザ検索できる権限を持つユーザのパスワードを指定します。
LDAPPASSWORDキーに指定したパスワードは，LDAP接続情報暗号化ツールを使用して暗号化できます。パスワードを暗号化すると，ENCRYPTPASSWORDキーに「TRUE」が自動で設定されます。
指定値
パスワードの文字列を指定します。
省略値
LDAPPASSWORDキーを省略した場合は，未指定となります。
注意事項
セキュリティ上，パスワードを平文で指定するのは危険であるため，LDAP接続情報暗号化ツールを使用して，パスワードを暗号化してください。
LDAPPASSWORDキーに指定したパスワードをLDAP接続情報暗号化ツールで暗号化する方法と出力されるファイルを次に示します。なお，LDAP接続情報暗号化ツールはWindows環境だけで使用できます。
パスワードを暗号化する方法
EUR Server - Spool Serviceの環境設定ファイル（EURPMLS.ini）のパスワードの暗号化は，LDAP接続情報暗号化ツール（eurssecdコマンド）で行います。LDAP接続情報暗号化ツールは，EUR Developer，EUR Server Enterprise，およびEUR Server - Spool Serviceの再配布パッケージに同梱されています。
  • ファイル名
    ファイル名：eurssecd.exe
    格納先：EUR Developer，EUR Server Enterprise，およびEUR Server - Spool Serviceの再配布パッケージのインストール先フォルダ\Spool\Program
  • コマンドの構文
    eurssecd〔.exe〕
        /if 暗号化対象ファイルパス
        /of 出力先ファイルパス
  • /ifオプション
    パスワードを暗号化するEUR Server - Spool Serviceの環境設定ファイル名（EURPMLS.ini）のフルパスを，259文字以内で指定します。
  • /ofオプション
    パスワードを暗号化したデータを出力するファイルのフルパスを，259文字以内で指定します。
出力されるファイル
LDAP接続情報暗号化ツール（eurssecdコマンド）を実行すると，EUR Server - Spool Serviceの環境設定ファイルのLDAPPASSWORDキーに指定されているパスワードを暗号化し，ENCRYPTPASSWORDキーに「TRUE」を設定したファイルが出力されます。暗号化前のファイルへの上書きはできません。


LDAPBASEDN

15.5.23　LDAPBASEDN

セクション
[OPTION]
設定内容
LDAP認証を行う場合に，LDAPサーバの検索ベースDNを指定します。
指定値
検索ベースDNの文字列を指定します。
省略値
LDAPBASEDNキーを省略した場合は，未指定となります。


LDAPUIDATTR

15.5.24　LDAPUIDATTR

セクション
[OPTION]
設定内容
LDAP認証を行う場合に，ログイン画面で入力されたログインユーザの属性名を指定します。
指定値
ログインユーザの属性名の文字列を指定します。
省略値
LDAPUIDATTRキーを省略した場合は，未指定となります。


LDAPTLS

15.5.25　LDAPTLS

セクション
[OPTION]
設定内容
LDAP認証を行う場合に，LDAPサーバとの通信をTLS通信で行うかどうかを指定します。
指定値
指定できる値を次に示します。
  • YES：TLS通信します。
  • NO：TLS通信しません。
YES，NO以外の文字を指定した場合は，省略値と同じ値が仮定されます。
省略値
LDAPTLSキーを省略した場合は，「NO」が仮定されます。


ENCRYPTPASSWORD

15.5.26　ENCRYPTPASSWORD

セクション
[OPTION]
設定内容
LDAPPASSWORDキーで指定したパスワードをLDAP接続情報暗号化ツールで暗号化したときに，自動で指定されます。
指定値
指定される値を次に示します。
  • TRUE：暗号化されています。
  • FALSE：暗号化されていません。
省略値
ENCRYPTPASSWORDキーを省略した場合は，未指定となります。
注意事項
ENCRYPTPASSWORDキーの指定値は，変更しないでください。


RMDIRRETRYCOUNT

15.5.27　RMDIRRETRYCOUNT

セクション
[OPTION]
設定内容
EUR Server - Spool Serviceで作業用一時フォルダの削除に失敗した場合，リトライする回数を指定します。
指定値
指定できる値は0～20です。
0を指定した場合，作業用一時フォルダの削除はリトライされません。
0～20以外の値，もしくは数値以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
RMDIRRETRYCOUNTキーを省略した場合は，「0」が仮定されます。


RMDIRINTERVALTIME

15.5.28　RMDIRINTERVALTIME

セクション
[OPTION]
設定内容
EUR Server - Spool Serviceで作業用一時フォルダの削除に失敗した場合，リトライするまでの待機時間を指定します。
指定値
指定できる値は100～1,000です。単位はミリ秒です。
100～1,000以外の値，もしくは数値以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
RMDIRINTERVALTIMEキーを省略した場合は，「200」が仮定されます。


LDAPPASSWORDEMPTYCHECK

15.5.29　LDAPPASSWORDEMPTYCHECK

セクション
[OPTION]
設定内容
LDAP認証を行う場合に，次に示すキーまたはパスワードの必須チェックの有無を指定します。
  • OPTIONセクションのLDAPPASSWORDキーの値
  • 帳票管理GUIで入力する確認キー
  • ログイン画面で入力するパスワード
指定値
指定できる値を次に示します。
  • YES：LDAPパスワードの必須チェックをします。
  • NO：LDAPパスワードの必須チェックをしません。
  • SPACE：LDAPパスワードが空文字の場合，半角空白を付加します。
YES，NO，SPACE以外の文字を指定した場合は，省略値と同じ値が仮定されます。
省略値
LDAPPASSWORDEMPTYCHECKキーを省略した場合は，「YES」が仮定されます。


STANDARDTIME

15.5.30　STANDARDTIME

セクション
[OPTION]
設定内容
EUR Server - Spool Serviceが稼働するマシンの日付が変わったあと，EUR Server - Spool Serviceに対して最初の要求があったときに，蓄積期限が切れたスプールデータの削除，および保持期限が切れた宛先情報の状態変更（状態が「印刷済み」または「エラー」の場合は削除）を自動的に実行する処理において，日付変更の契機にローカルタイムと協定世界時（UTC）のどちらを使用するかを指定します。
STANDARDTIMEキーが関係する設定項目を次に示します。
  • スプールデータの蓄積期限日（環境設定ファイル（EURPMADP.ini）のOPTIONセクションのSPOOLLIMITキー）
  • 配送印刷した帳票の状態が「印刷待ち」のときに，印刷待ちのままにしておく期限（環境設定ファイル（EURPMLS.ini）のTIMEOUTセクションのWAITINGLIMITキー）
  • 配送印刷した帳票の状態が「印刷中」のときに，印刷中のままにしておく期限（環境設定ファイル（EURPMLS.ini）のTIMEOUTセクションのPRINTINGLIMITキー）
  • 配送印刷した帳票の状態が「印刷済み」のときに，スプールサーバから帳票を削除するまでの期限（環境設定ファイル（EURPMLS.ini）のTIMEOUTセクションのPRINTEDLIMITキー）
  • 配送印刷した帳票の状態が「エラー」のときに，スプールサーバから帳票を削除するまでの期限（環境設定ファイル（EURPMLS.ini）のTIMEOUTセクションのERRORLIMITキー）
指定値
指定できる値を次に示します。
  • 0：ローカルタイム
  • 1：協定世界時（UTC）
指定できない値を指定した場合は，省略値と同じ値が仮定されます。
省略値
STANDARDTIMEキーを省略した場合は，「0」が仮定されます。


ADDRDEFFILENAME

15.5.31　ADDRDEFFILENAME

セクション
[CONF]
設定内容
宛先定義ファイルの名称に「addrdef.conf」以外のファイル名またはファイル形式を使用したい場合に，ファイルの名称を指定します。
指定値
ファイル名称を指定します。
省略値
ADDRDEFFILENAMEキーを省略した場合は，addrdef.confが仮定されます。


GENERAL

15.5.32　GENERAL

セクション
[THREAD]
設定内容
EUR Server - Spool Serviceの並列処理数を指定します。
指定値
指定できる値は1～5,000です。
1～5,000以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
GENERALキーを省略した場合は，「200」が仮定されます。
注意事項
GENERALキーに正しい値を設定しても，マシン環境およびほかのプログラムの実行環境によって，設定したとおりの動作をしない場合があります。


EURPS

15.5.33　EURPS

セクション
[THREAD]
設定内容
EUR Print Serviceの並列処理数を指定します。
CPU数に応じてEURPSキーを設定すると，高い並列処理効果が得られます。
指定値
指定できる値は1～5,000です。
1～5,000以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
EURPSキーを省略した場合は，「1」が仮定されます。
注意事項
  • EURPSキーに正しい値を設定しても，マシン環境およびほかのプログラムの実行環境によって，設定したとおりの動作をしない場合があります。
  • EUR Print Serviceを実行するときは，CPU使用率が非常に高くなります。


MERGE

15.5.34　MERGE

セクション
[THREAD]
設定内容
複数のスプールデータのジョブIDを指定して蓄積操作（印刷および取得）を実行する場合の並列処理数を指定します。
CPU数に応じてMERGEキーを設定すると，高い並列処理効果が得られます。
指定値
指定できる値は0～5,000です。
0を指定した場合は，並列処理数を制御しません。
0～5,000以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
MERGEキーを省略した場合は，「0」が仮定されます。
注意事項
MERGEキーに正しい値を設定しても，マシン環境およびほかのプログラムの実行環境によって，設定したとおりの動作をしない場合があります。


CONNECT

15.5.35　CONNECT

セクション
[TIMEOUT]
設定内容
意図しない接続元が，データ通信を行わないでEUR Server - Spool Serviceと接続したままの状態になった場合，切断するまでの時間を指定します（タイムアウト監視）。
指定値
指定できる値は，0～3,600です。単位は秒です。
CONNECTキーに「0」を指定した場合は，タイムアウト監視はしません。
0～3,600以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
CONNECTキーを省略した場合は，「600（10分）」が仮定されます。
注意事項
  • 通信に時間が掛かり，タイムアウトで切断されてしまう場合は，CONNECTキーの値（タイムアウトの監視時間）を大きくして再試行してください。
  • 指定した値によっては，意図しない接続を切断するのに時間が掛かり，その間ジョブを受け付けられなくなったり，EUR Server - Spool Serviceを停止できなくなったりします。その場合は，値を変更してチューニングしてください。


ERRIGNORE

15.5.36　ERRIGNORE

セクション
[TIMEOUT]
設定内容
ソケットを接続してデータを通信しないで切断する処理（生死監視）が実行された場合に，切断を検知してもエラーを出力しない時間を指定します。
なお，何らかのデータを通信したあとに切断を検知した場合は，エラーが出力されます。
指定値
指定できる値は，0～3,600です。単位は秒です。
ERRIGNOREキーに0を指定した場合，切断を検知したとき必ずエラーが出力されます。
0～3,600以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
ERRIGNOREキーを省略した場合は，「3」が仮定されます。
注意事項
  • 通信ポートの監視を実行する場合，KEEY426-Eのエラーが発生したときは，ERRIGNOREキーの値（切断を検知した場合にエラーを出力しない時間）を大きくして再試行してください。
  • 指定した値によっては，EUR Server Service および EUR Server - Spool Service Adapterとの接続が何らかの不具合により切断された場合に，切断を検知できなくなることがあります。その場合は，値を変更してチューニングしてください。


WAITINGLIMIT

15.5.37　WAITINGLIMIT

セクション
[TIMEOUT]
設定内容
配送印刷した帳票の状態が「印刷待ち」のときに，印刷待ちのままにしておく期限を日数で指定します。指定した期限を過ぎた場合，配送帳票の状態はエラーに変更されます。
日付処理には，協定世界時（UTC）を使用します。
指定値
指定できる値は0～999です。単位は日です。
0を指定した場合は，翌日に配送帳票の状態がエラーに変更されます。
0～999以外の値，もしくは数値以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
WAITINGLIMITキーを省略した場合は，「7」が仮定されます。


PRINTINGLIMIT

15.5.38　PRINTINGLIMIT

セクション
[TIMEOUT]
設定内容
配送印刷した帳票の状態が「印刷中」のときに，印刷中のままにしておく期限を日数で指定します。指定した期限を過ぎた場合，配送帳票の状態はエラーに変更されます。
日付処理には，協定世界時（UTC）を使用します。
指定値
指定できる値は0～999です。単位は日です。0を指定した場合は，翌日に配送帳票の状態がエラーに削除されます。
0～999以外の値，もしくは数値以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
PRINTINGLIMITキーを省略した場合は，「7」が仮定されます。


PRINTEDLIMIT

15.5.39　PRINTEDLIMIT

セクション
[TIMEOUT]
設定内容
配送印刷した帳票の状態が「印刷済み」のときに，スプールサーバから帳票を削除するまでの期限を日数で指定します。指定した期限を過ぎた場合，配送帳票は削除されます。
日付処理には，協定世界時（UTC）を使用します。
指定値
指定できる値は0～999です。単位は日です。
0を指定した場合は，翌日に配送帳票が削除されます。
0～999以外の値，もしくは数値以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
PRINTEDLIMITキーを省略した場合は，「30」が仮定されます。


ERRORLIMIT

15.5.40　ERRORLIMIT

セクション
[TIMEOUT]
設定内容
配送印刷した帳票の状態が「エラー」のときに，スプールサーバから帳票を削除するまでの期限を日数で指定します。指定した期限を過ぎた場合，配送帳票は削除されます。
日付処理には，協定世界時（UTC）を使用します。
指定値
指定できる値は0～999です。単位は日です。
0を指定した場合は，翌日に配送帳票が削除されます。
0～999以外の値，もしくは数値以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
ERRORLIMITキーを省略した場合は，「30」が仮定されます。


LDAPCONNECT

15.5.41　LDAPCONNECT

セクション
[TIMEOUT]
設定内容
LDAPサーバ接続時の通信タイムアウト監視時間を指定します。
指定値
指定できる値は，0～30です。単位は秒です。
0～30以外の値，もしくは数値以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
LDAPCONNECTキーを省略した場合は，「1」が仮定されます。
注意事項
OSやネットワークのタイムアウト時間など，環境によってはLDAPCONNECTキーの指定値より短い時間でタイムアウトする場合があります。


SPOOLAUDITLOG

15.5.42　SPOOLAUDITLOG

セクション
[AUDIT]
設定内容
監査ログを出力するかどうかを指定します。
指定値
指定できる値を次に示します。
  • 0：監査ログを出力しません。
  • 1：監査ログを出力します。
0，1以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
SPOOLAUDITLOGキーを省略した場合は，「0」が仮定されます。


SPOOLLOG

15.5.43　SPOOLLOG

セクション
[AUDIT]
設定内容
監査ログファイル（eur_spool_audit.log）の出力先フォルダを指定します。
指定値
フルパスで指定します。
存在しないフォルダを指定した場合は，指定したフォルダが自動的に作成されます。
省略値
SPOOLLOGキーを省略した場合は，次のフォルダが仮定されます。
  • Windows環境のとき
    インストール先フォルダ\Log
  • UNIX／Linux環境のとき
    /var/opt/eur/log
注意事項
  • 監査ログファイルに書き込み権限がない場合は，EUR Server - Spool Serviceのサービス起動時にKEEU858-Eエラーとなります。
  • 監査ログを出力する場合，EUR Server - Spool Serviceのサービス起動時に監査ログファイルにアクセスします。


SPOOLLOGSIZE

15.5.44　SPOOLLOGSIZE

セクション
[AUDIT]
設定内容
監査ログファイル（eur_spool_audit.log）のファイルサイズの上限を指定します。
指定値
指定できる値は，750～2,000,000です。単位はKBです。
750～2,000,000以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
LOGSIZEキーを省略した場合は，「3,000」が仮定されます。
注意事項
  • 監査ログファイルに出力する監査ログのデータサイズがSPOOLLOGSIZEキーの指定値を超える場合は，監査ログを出力する前にバックアップファイルを作成し，出力先を新規に作成した監査ログファイルに切り替えて，監査ログを出力します。
  • 監査ログファイルのフォーマットが不正な場合，またはSPOOLLOGSIZEキーの指定値に範囲外の値を指定した場合は，KEEY861-Eエラーとなります。


SPOOLLOGDATE

15.5.45　SPOOLLOGDATE

セクション
[AUDIT]
設定内容
監査ログファイル（eur_spool_audit.log）のバックアップファイルの作成時刻を「hh:mm」形式で指定します。
時刻処理には，ローカルタイムを使用します。
指定値
指定できる文字列は，5バイトまでです。
  • hh：時（00～23）を2桁で指定します。01～09は，ゼロ埋めします。
  • mm：分（00～59）を2桁で指定します。01～09は，ゼロ埋めします。
省略値
SPOOLLOGDATEキーを省略した場合は，時刻指定によるバックアップファイルの作成を行いません。
注意事項
SPOOLLOGDATEキーで監査ログファイルのバックアップ作成時刻を指定した場合，監査ログファイルのバックアップファイルは，バックアップ作成時刻を経過したあと，EUR Server - Spool Serviceがスプールデータの操作を実行したタイミングで作成されます（バックアップ作成時刻を経過しただけではバックアップファイルは作成されません）。


SPOOLLOGNUM

15.5.46　SPOOLLOGNUM

セクション
[AUDIT]
設定内容
監査ログファイル（eur_spool_audit.log）のバックアップファイルの保持数を指定します。
指定値
指定できる値は，1～31です。
1～31以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
SPOOLLOGNUMキーを省略した場合は，「10」が仮定されます。


SPOOLLOGMODE

15.5.47　SPOOLLOGMODE

セクション
[AUDIT]
設定内容
監査ログ出力モードを指定します。
監査ログ出力モードは，監査ログに出力する情報量を指定するモードです。
指定値
指定できる値を次に示します。
  • 0：監査証跡管理システム連携モード
    一般的に監査ログとして求められる「誰が」「いつ」「何を」「どうした」などの情報を出力するモードです。
  • 1：詳細情報モード
    監査証跡管理システム連携モードで出力する情報に加えて，EURの機能を実行するときに指定したプロパティや蓄積ファイルの属性情報を出力するモードです。
0，1以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
SPOOLLOGMODEキーを省略した場合は，「0」が仮定されます。
注意事項
監査証跡管理システム連携モードを指定した場合は，次の項目を出力しません。
  • オブジェクトロケーション情報の一部の項目
  • 変更前情報および変更後情報
監査証跡管理システム連携モードを指定した場合に出力しない項目の詳細については，マニュアル「EUR システム設計ガイド」を参照してください。


EUR Server - Spool Service Adapterの環境設定ファイル（EURPMLSADP.ini）

15.6　EUR Server - Spool Service Adapterの環境設定ファイル（EURPMLSADP.ini）

対象コンポーネントまたは機能
EUR Server - Spool Service Adapter
設定内容
EUR Server - Spool Service Adapterの動作環境は，環境設定ファイル（EURPMLSADP.ini）で設定します。
環境設定ファイルを変更した場合は，EUR Server - Spool Service Adapterを使用しているプログラムを再起動してください。
環境設定ファイルの格納場所
  • Windows環境の場合
    環境設定ファイル（EURPMLSADP.ini）は，インストール先フォルダ\Spool Adapter下に作成されます。
    ファイルの内容を追加，変更する場合は，メモ帳などのテキスト編集エディタを起動して編集したあと，上書き保存してから使用してください。
  • UNIX／Linux環境の場合
    次に示す環境設定ファイル（EURPMLSADP.ini）のサンプルを，/opt/eur/sample/SpoolAdapter下に提供しています。必要な内容を設定したあと，同じファイル名で/var/opt/eur/spool-adp下に格納してください。
    なお，/var/opt/eur/spool-adpには，EUR Server - Spool Service Adapterを利用するユーザが読み書きできるようにアクセス権を設定してください。
＜環境設定ファイル（EURPMLSADP.ini）のサンプルの内容＞
[PORT]

[IPADDRESS]
EURPMLS=

[ERROR]

[TIMEOUT]

[PATH]

[OPTION]
SOCKBUFFSIZE=64

環境設定ファイルの構文

変数名=値

環境設定ファイルに指定する情報は，「"」で囲まないでください。
環境設定ファイルの指定例（Windows環境の場合）

[PORT]
EURPMLS=22313

[IPADDRESS]
EURPMLS=127.0.0.1

[ERROR]
LOGFILE=C:\EURPMLSADP\Log
LOGLEVEL=4
LOGSIZE=750

[TIMEOUT]
PRINT=300
GETFILE=30
FILELIST=30
FILEOPERATE=30
DELETE=30
PRTCLSLIST=30
AUTHENTICATION=30
POLLINGREPORT=30
PRINTSTATE=30

[PATH]
OUTPUTFILE=C:\EURPMLSADP\OutputFile

[OPTION]
SOCKBUFFSIZE=64
USERNAME=EURUSER
CHECKSTRING=PASSWORD
＜この節の構成＞
15.6.1　設定項目一覧
15.6.2　EURPMLS
15.6.3　EURPMLS
15.6.4　LOGFILE
15.6.5　LOGLEVEL
15.6.6　LOGSIZE
15.6.7　PRINT
15.6.8　GETFILE
15.6.9　FILELIST
15.6.10　FILEOPERATE
15.6.11　DELETE
15.6.12　PRTCLSLIST
15.6.13　AUTHENTICATION
15.6.14　POLLINGREPORT
15.6.15　PRINTSTATE
15.6.16　CHANGEAUDITLOG
15.6.17　OUTPUTFILE
15.6.18　SOCKBUFFSIZE
15.6.19　USERNAME
15.6.20　CHECKSTRING


設定項目一覧

15.6.1　設定項目一覧

EUR Server - Spool Service Adapterの環境設定ファイル（EURPMLSADP.ini）で指定できる内容を次の表に示します。

表15-43　EUR Server - Spool Service Adapterの環境設定ファイル（EURPMLSADP.ini）で指定できる内容

セクション | キー | 説明
PORT | EURPMLS | EUR Server - Spool Serviceのポート番号を指定します。
IPADDRESS | EURPMLS | EUR Server - Spool Serviceが稼働するサーバのIPアドレスを指定します。
ERROR | LOGFILE | ログファイル（EURPMLSADP.log）の出力先フォルダを指定します。
 | LOGLEVEL | 実行ログの出力レベルを指定します。
 | LOGSIZE | ログファイル（EURPMLSADP.log）のファイルサイズの上限を指定します。
TIMEOUT | PRINT | EUR Server - Spool Serviceにスプールデータの印刷を要求するときの通信タイムアウト監視時間を指定します。
 | GETFILE | EUR Server - Spool Serviceにスプールデータの取得を要求するときの通信タイムアウト監視時間を指定します。
 | FILELIST | EUR Server - Spool Serviceからスプールデータ一覧を取得するときの通信タイムアウト監視時間を指定します。
 | FILEOPERATE | EUR Server - Spool Serviceからスプールデータの属性の取得・設定，およびスプールデータの削除をするときの通信タイムアウト監視時間を指定します。
 | DELETE | EUR Server - Spool Serviceに期限が切れたスプールデータ一括削除を要求するときの通信タイムアウト監視時間を指定します。
 | PRTCLSLIST | EUR Server - Spool Serviceからプリンタクラス一覧，プリンタ一覧，トレイ一覧を取得するときの通信タイムアウト監視時間を指定します。
 | AUTHENTICATION | EUR Server - Spool Serviceにログインするときの通信タイムアウト監視時間を指定します。
 | POLLINGREPORT | EUR Server - Spool Serviceに配送印刷する帳票の取得を要求するときの通信タイムアウト監視時間を指定します。
 | PRINTSTATE | EUR Server - Spool Serviceに帳票一覧の取得を要求するときの通信タイムアウト監視時間を指定します。
 | CHANGEAUDITLOG | EUR Server - Spool Serviceに監査ログの切り替えを要求するときの通信タイムアウト監視時間を指定します。
PATH | OUTPUTFILE | スプールデータを取得するフォルダを指定します。
OPTION | SOCKBUFFSIZE | ソケット通信に使用する通信バッファサイズの上限を指定します。
 | USERNAME | ユーザIDやパスワードが未指定のときに使用されるユーザIDを設定します。
 | CHECKSTRING | ユーザIDやパスワードが未指定のときに使用されるパスワードを設定します。


EURPMLS

15.6.2　EURPMLS

セクション
[PORT]
設定内容
EUR Server - Spool Serviceのポート番号を指定します。
指定値
指定できる値は，0～65535です。
省略値
EURPMLSキーを省略した場合は，「22313」が仮定されます。


EURPMLS

15.6.3　EURPMLS

セクション
[IPADDRESS]
設定内容
EUR Server - Spool Serviceが稼働するサーバのIPアドレスを255.255.255.255形式で指定します。ServerAddressプロパティを指定していた場合は，ServerAddressプロパティの設定が有効になります。
指定値
255.255.255.255形式で指定します。
省略値
ServerAddressプロパティが省略されているときに，EURPMLSキーの指定を省略すると，デフォルト値（127.0.0.1）が仮定されます。
注意事項
  • EUR Server - Spool ServiceとEUR Server - Spool Service Adapterが同じマシンで稼働する場合，EUR Server - Spool ServiceとEUR Server - Spool Service Adapter間のファイル転送時間を短縮できます。ファイル転送時間を短縮する場合は，マニュアル「EUR システム設計ガイド」を参照してください。
  • EURPMLSキーとSS-ActiveX起動部品のServerAddressプロパティ，またはSS-Java起動部品のsetServerAddressメソッドが設定されていないとき，次に示すメソッドのどれかを実行するとエラー（KEEY502-E）になります。
  • SS-ActiveX起動部品
    DeleteSpoolFileメソッド，GetPrinterClassListメソッド，GetPrinterListメソッド，GetSpoolFileメソッド，GetSpoolFileAttributeメソッド，GetSpoolFileOutlineメソッド，GetTrayListメソッド，PrintSpoolReportメソッド，SetSpoolFileAttributeメソッド
  • SS-Java起動部品
    deleteSpoolFileメソッド，getPrinterClassListメソッド，getPrinterListメソッド，getSpoolFileメソッド，getSpoolFileAttributeメソッド，getSpoolFileOutlineメソッド，getTrayListメソッド，printSpoolReportメソッド，setSpoolFileAttributeメソッド


LOGFILE

15.6.4　LOGFILE

セクション
[ERROR]
設定内容
ログファイル（EURPMLSADP.log）の出力先フォルダを指定します。
指定値
フルパスで指定します。
省略値
LOGFILEキーを省略した場合は，次のフォルダが仮定されます。
  • Windows環境のとき
    インストール先フォルダ\Logフォルダ
  • UNIX／Linux環境のとき
    /var/opt/eur/log


LOGLEVEL

15.6.5　LOGLEVEL

セクション
[ERROR]
設定内容
実行ログの出力レベルを指定します。
指定値
指定できる値を次に示します。
  • 0：ログ出力しません。
  • 4：起動，終了，実行時パラメタ，エラーを出力します。
  • 8：起動，終了，実行時パラメタ，エラー，警告を出力します。
  • 16：起動，終了，実行時パラメタ，エラー，警告，情報を出力します。
省略値
LOGLEVELキーを省略した場合は，「8」が仮定されます。
注意事項
出力レベルに「16」を指定すると，トレース情報が大量に出力されるため，性能が落ちるおそれがあります。障害調査時以外には指定しないでください。


LOGSIZE

15.6.6　LOGSIZE

セクション
[ERROR]
設定内容
ログファイル（EURPMLSADP.log）のファイルサイズの上限を指定します。
指定値
指定できる値は750～2,000,000です。単位はKBです。
750～2,000,000以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
LOGSIZEキーを省略した場合は，「750」が仮定されます。


PRINT

15.6.7　PRINT

セクション
[TIMEOUT]
設定内容
EUR Server - Spool Serviceにスプールデータの印刷を要求するときの通信タイムアウト監視時間を指定します。
指定値
指定できる値は，0～86,400（24時間）です。単位は秒です。
0を指定した場合は，タイムアウト監視はしません。
0～86,400以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
PRINTキーを省略した場合は，「0」が仮定されます。


GETFILE

15.6.8　GETFILE

セクション
[TIMEOUT]
設定内容
EUR Server - Spool Serviceにスプールデータの取得を要求するときの通信タイムアウト監視時間を指定します。
指定値
指定できる値は，0～600（10分）です。単位は秒です。
0を指定した場合，または0～600以外の値を指定した場合は，タイムアウト監視はしません。
省略値
GETFILEキーを省略した場合は，「30（秒）」が仮定されます。


FILELIST

15.6.9　FILELIST

セクション
[TIMEOUT]
設定内容
EUR Server - Spool Serviceからスプールデータ一覧を取得するときの通信タイムアウト監視時間を指定します。
指定値
指定できる値は，0～600（10分）です。単位は秒です。
0を指定した場合，または0～600以外の値を指定した場合は，タイムアウト監視はしません。
省略値
FILELISTキーを省略した場合は，「30（秒）」が仮定されます。


FILEOPERATE

15.6.10　FILEOPERATE

セクション
[TIMEOUT]
設定内容
EUR Server - Spool Serviceからスプールデータの属性の取得・設定，およびスプールデータの削除をするときの通信タイムアウト監視時間を指定します。
指定値
指定できる値は，0～600（10分）です。単位は秒です。
0を指定した場合，または0～600以外の値を指定した場合は，タイムアウト監視はしません。
省略値
FILEOPERATEキーを省略した場合は，「30（秒）」が仮定されます。


DELETE

15.6.11　DELETE

セクション
[TIMEOUT]
設定内容
EUR Server - Spool Serviceに期限が切れたスプールデータ一括削除を要求するときの通信タイムアウト監視時間を指定します。
指定値
指定できる値は，0～600（10分）です。単位は秒です。
0を指定した場合，または0～600以外の値を指定した場合は，タイムアウト監視はしません。
省略値
DELETEキーを省略した場合は，「30（秒）」が仮定されます。


PRTCLSLIST

15.6.12　PRTCLSLIST

セクション
[TIMEOUT]
設定内容
EUR Server - Spool Serviceからプリンタクラス一覧，プリンタ一覧，トレイ一覧を取得するときの通信タイムアウト監視時間を指定します。
指定値
指定できる値は，0～600（10分）です。単位は秒です。
0を指定した場合，または0～600以外の値を指定した場合は，タイムアウト監視はしません。
省略値
PRTCLSLISTキーを省略した場合は，「30（秒）」が仮定されます。


AUTHENTICATION

15.6.13　AUTHENTICATION

セクション
[TIMEOUT]
設定内容
EUR Server - Spool Serviceにログインするときの通信タイムアウト監視時間を指定します。
指定値
指定できる値は，0～600（10分）です。単位は秒です。
0を指定した場合，または0～600以外の値を指定した場合は，タイムアウト監視はしません。
省略値
AUTHENTICATIONキーを省略した場合は，「30（秒）」が仮定されます。


POLLINGREPORT

15.6.14　POLLINGREPORT

セクション
[TIMEOUT]
設定内容
EUR Server - Spool Serviceに配送印刷する帳票の取得を要求するときの通信タイムアウト監視時間を指定します。
指定値
指定できる値は，0～600（10分）です。単位は秒です。
0を指定した場合は，タイムアウト監視はしません。
0～86,400以外の値，もしくは数値以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
POLLINGREPORTキーを省略した場合は，「0」が仮定されます。


PRINTSTATE

15.6.15　PRINTSTATE

セクション
[TIMEOUT]
設定内容
EUR Server - Spool Serviceに帳票一覧の取得を要求するときの通信タイムアウト監視時間を指定します。
指定値
指定できる値は，0～600（10分）です。単位は秒です。
0を指定した場合，または0～600以外の値を指定した場合は，タイムアウト監視はしません。
数値以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
PRINTSTATEキーを省略した場合は，「30（秒）」が仮定されます。


CHANGEAUDITLOG

15.6.16　CHANGEAUDITLOG

セクション
[TIMEOUT]
設定内容
EUR Server - Spool Serviceに監査ログの切り替えを要求するときの通信タイムアウト監視時間を指定します。
指定値
指定できる値は，0～600（10分）です。単位は秒です。
0を指定した場合，または0～600以外の値を指定した場合は，タイムアウト監視はしません。
数値以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
CHANGEAUDITLOGキーを省略した場合は，「30（秒）」が仮定されます。


OUTPUTFILE

15.6.17　OUTPUTFILE

セクション
[PATH]
設定内容
スプールデータを取得するフォルダを指定します。SS-ActiveX起動部品のOutputFilePathプロパティ，またはSS-Java起動部品のsetOutputFilePathメソッドを指定していた場合は，OutputFilePathプロパティまたはsetOutputFilePathメソッドの設定が有効になります。
指定値
フルパスで指定します。
省略値
OUTPUTFILEキーを省略した場合は，未指定となります。
注意事項
OUTPUTFILEキーとSS-ActiveX起動部品のOutputFilePathプロパティ，またはSS-Java起動部品のsetOutputFilePathメソッドが設定されていないとき，次に示すメソッドを実行するとエラー（KEEY502-E）になります。
  • SS-ActiveX起動部品
    GetSpoolFileメソッド
  • SS-Java起動部品
    getSpoolFileメソッド


SOCKBUFFSIZE

15.6.18　SOCKBUFFSIZE

セクション
[OPTION]
設定内容
ソケット通信に使用する通信バッファサイズの上限を指定します。
指定値
指定できる値は，1～2,000,000です。単位はKBです。
通信バッファサイズの上限を無制限にしたい場合は，「0」を指定してください。
0～2,000,000以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
SOCKBUFFSIZEキーを省略した場合は，「64」が仮定されます。
注意事項
KEEY503-Eの通信エラーが発生し，かつEURPMログのエラー詳細情報に「errno=10055」が出力されているときは，指定した通信バッファサイズを確保するためのシステムのバッファ領域が不足していることを示しています。エラーが発生したときは，SOCKBUFFSIZEキーに指定されている値を小さく（8～64）して再試行してください。
なお，指定した値によっては，通信性能が変わることがあります。通信性能が劣化する場合は値を変更してチューニングしてください。


USERNAME

15.6.19　USERNAME

セクション
[OPTION]
設定内容
ユーザIDやパスワードが未指定のときに使用されるユーザIDを設定します。
指定値
ユーザIDの文字列を80バイト以内で指定します。
80バイトを超えた文字列を指定した場合は，EURのデフォルトユーザとしてスプールデータにアクセスします。
注意事項
  • 帳票管理GUIと業務アプリケーションを併用するシステムでは，APIでユーザIDとパスワードを指定できません。そのため，帳票へのアクセス権限があるユーザもデフォルトユーザとして認識され，目的の帳票にアクセスできなくなってしまいます。USERNAMEキーを指定しておけば，このような問題の発生を防ぐことができます。
  • 制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」は指定できません。


CHECKSTRING

15.6.20　CHECKSTRING

セクション
[OPTION]
設定内容
ユーザIDやパスワードが未指定のときに使用されるパスワードを設定します。
指定値
パスワードの文字列を80バイト以内で指定します。
80バイトを超えた文字列を指定した場合は，EURのデフォルトユーザとしてスプールデータにアクセスします。
注意事項
  • 帳票管理GUIと業務アプリケーションを併用するシステムでは，APIでユーザIDとパスワードを指定できません。そのため，帳票へのアクセス権限があるユーザもデフォルトユーザとして認識され，目的の帳票にアクセスできなくなってしまいます。CHECKSTRINGキーを指定しておけば，このような問題の発生を防ぐことができます。
  • 制御コード（0x00～0x1F，0x7F～0x9F），「"」，および「,」は指定できません。


帳票管理GUIの環境設定ファイル（EURPMRSGUI.ini）

15.7　帳票管理GUIの環境設定ファイル（EURPMRSGUI.ini）

対象コンポーネントまたは機能
帳票管理GUI
設定内容
帳票管理GUIの動作環境は，環境設定ファイル（EURPMRSGUI.ini）で設定します。
環境設定ファイルを変更した場合は，帳票管理GUIを再起動してください。
環境設定ファイルの格納場所
  • Windows環境の場合
    環境設定ファイル（EURPMRSGUI.ini）は，インストール先フォルダ\Spool Adapter下に作成されます。
    ファイルの内容を追加，変更する場合は，メモ帳などのテキスト編集エディタを起動して編集したあと，上書き保存してから使用してください。
  • UNIX／Linux環境の場合
    次に示す環境設定ファイル（EURPMRSGUI.ini）のサンプルを，/opt/eur/sample/SpoolAdapter下に提供しています。必要な内容を設定したあと，同じファイル名で/var/opt/eur/spool-adp下に格納してください。
    なお，/var/opt/eur/spool-adpには，EUR Server - Spool Service Adapterを利用するユーザが読み書きできるようにアクセス権を設定してください。
＜環境設定ファイル（EURPMRSGUI.ini）のサンプルの内容＞
[OPTION]
#PATH=/CAB/User/
#PATH=/CAB/Machine/
#PATH_MACHINE=/CAB/Machine/

冒頭に「#」が付いている行はコメントの扱いになっています。

環境設定ファイル（EURPMRSGUI.ini）のサンプルは，インストールする単位に応じて内容を設定すると使用できるようになります。それぞれの設定について次に説明します。

ユーザ単位インストールを使用する場合
  • ユーザ単位インストール用のダウンロードパッケージ（cabファイル）をWebサーバ上に配置する
  • 環境設定ファイル（EURPMRSGUI.ini）のサンプルの「#PATH=/CAB/User/」から「#」を削除し，PATHキーにユーザ単位インストール用のダウンロードパッケージ（cabファイル）の格納場所のURLを指定する
  • インストール先フォルダ\Component\Client\User\に格納されているユーザ単位インストール用のEUR Web Plug-In情報ファイルを次の場所に配置する
配置場所
  • Windows環境の場合
    インストール先フォルダ\Adapter
  • UNIX／Linux環境の場合
    /var/opt/eur/adapter
マシン単位インストールを使用する場合
  • マシン単位インストール用のダウンロードパッケージ（cabファイル）をWebサーバ上に配置する
  • 環境設定ファイル（EURPMRSGUI.ini）のサンプルの「#PATH=/CAB/Machine/」から「#」を削除し，PATHキーにマシン単位インストール用のダウンロードパッケージ（cabファイル）の格納場所のURLを指定する
  • インストール先フォルダ\Component\Client\に格納されているマシン単位インストール用のEUR Web Plug-In情報ファイルを次の場所に配置する
配置場所
  • Windows環境の場合
    インストール先フォルダ\Adapter
  • UNIX／Linux環境の場合
    /var/opt/eur/adapter
クライアントPCの環境によってユーザ単位インストールとマシン単位インストールを切り替えて使用する場合
  • ユーザ単位インストール用のダウンロードパッケージ（cabファイル）とマシン単位インストール用のダウンロードパッケージ（cabファイル）の両方をWebサーバ上に配置する
  • 環境設定ファイル（EURPMRSGUI.ini）のサンプルの「#PATH=/CAB/User/」および「#PATH_MACHINE=/CAB/Machine/」から「#」を削除し，PATHキーにユーザ単位インストール用のダウンロードパッケージ（cabファイル）の格納場所のURL，PATH_MACHINEキーにマシン単位インストール用のダウンロードパッケージ（cabファイル）の格納場所のURLを指定する
  • インストール先フォルダ\Component\Client\User\に格納されているユーザ単位インストール用のEUR Web Plug-In情報ファイルを次の場所に配置する（マシン単位インストール用のEUR Web Plug-In情報ファイルを配置しないでください）
配置場所
  • Windows環境の場合
    インストール先フォルダ\Adapter
  • UNIX／Linux環境の場合
    /var/opt/eur/adapter
環境設定ファイルの構文

変数名=値

環境設定ファイルに指定する情報は，「"」で囲まないでください。
環境設定ファイルの指定例（Windows環境の場合）

[OPTION]
PATH=http://192.168.1.1/EURPMRSGUI/USER/
PATH_MACHINE=http://192.168.1.1/EURPMRSGUI/MACHINE/
EPFDATAMAXSIZE=1000000
DEFAULTPRINTDLG=YES
＜この節の構成＞
15.7.1　設定項目一覧
15.7.2　PATH
15.7.3　PATH_MACHINE
15.7.4　EPFDATAMAXSIZE
15.7.5　DEFAULTPRINTDLG


設定項目一覧

15.7.1　設定項目一覧

帳票管理GUIの環境設定ファイル（EURPMRSGUI.ini）で指定できる内容を次の表に示します。

表15-44　帳票管理GUIの環境設定ファイル（EURPMRSGUI.ini）で指定できる内容

セクション | キー | 説明
OPTION | PATH | EUR Web Plug-Inをダウンロードパッケージからインストールする場合に，ダウンロードパッケージ（cabファイル）の格納場所のURLを指定します。
 | PATH_MACHINE | EUR Web Plug-Inをダウンロードパッケージからインストールする場合で，クライアントPCの環境によってマシン単位でのインストールとユーザ単位でのインストールを切り替えるときに，マシン単位インストール用のダウンロードパッケージ（cabファイル）の格納場所のURLを指定します。
 | EPFDATAMAXSIZE | ダウンロードするEPF形式ファイルのファイルサイズの上限を指定します。
 | DEFAULTPRINTDLG | ［このマシンで印刷］を選択して印刷する場合に表示されるダイアログを，EUR Server Serviceのプリンタ選択ダイアログにするか，またはOSの印刷ダイアログにするかのどちらかを指定します。


PATH

15.7.2　PATH

セクション
[OPTION]
設定内容
EUR Web Plug-Inをダウンロードパッケージからインストールする場合に，ダウンロードパッケージ（cabファイル）の格納場所のURLを指定します。
指定値
URLの文字列を指定します。
インストールする単位に応じて，次のように設定します。

ユーザ単位インストールを使用する場合
  • PATHキーにユーザ単位インストール用のダウンロードパッケージ（cabファイル）の格納場所のURLを指定します。
  • インストール先フォルダ\Component\Client\User\に格納されているユーザ単位インストール用のEUR Web Plug-In情報ファイルを次の場所に配置します。
配置場所
    ・Windows環境の場合
        インストール先フォルダ\Adapter
    ・UNIX／Linux環境の場合
        /var/opt/eur/adapter

マシン単位インストールを使用する場合
  • PATHキーにマシン単位インストール用のダウンロードパッケージ（cabファイル）の格納場所のURLを指定します。
  • インストール先フォルダ\Component\Client\に格納されているマシン単位インストール用のEUR Web Plug-In情報ファイルを次の場所に配置します。
配置場所
    ・Windows環境の場合
        インストール先フォルダ\Adapter
    ・UNIX／Linux環境の場合
        /var/opt/eur/adapter

クライアントPCの環境によってユーザ単位インストールとマシン単位インストールを切り替えて使用する場合
  • PATHキーにユーザ単位インストール用のダウンロードパッケージ（cabファイル）の格納場所のURL，PATH_MACHINEキーにマシン単位インストール用のダウンロードパッケージ（cabファイル）の格納場所のURLを指定します。
  • インストール先フォルダ\Component\Client\User\に格納されているユーザ単位インストール用のEUR Web Plug-In情報ファイルを次の場所に配置します。
配置場所
    ・Windows環境の場合
        インストール先フォルダ\Adapter
    ・UNIX／Linux環境の場合
        /var/opt/eur/adapter

配布用パッケージによってインストールする場合は，cabファイルの格納場所を指定する必要はありません。
省略値
PATHキーを省略した場合は，ダウンロードパッケージによるインストールは実施されません。


PATH_MACHINE

15.7.3　PATH_MACHINE

セクション
[OPTION]
設定内容
EUR Web Plug-Inをダウンロードパッケージからインストールする場合で，クライアントPCの環境によってマシン単位でのインストールとユーザ単位でのインストールを切り替えるときに，マシン単位インストール用のダウンロードパッケージ（cabファイル）の格納場所のURLを指定します。
指定値
URLの文字列を指定します。
省略値
PATH_MACHINEキーを省略した場合は未指定となり，PATHキーの指定内容だけが有効になります。
注意事項
  • PATH_MACHINEキーを指定した場合，PATHキーにはユーザ単位インストール用のダウンロードパッケージの格納場所のURLを必ず指定してください。PATHキーを省略した場合は，PATH_MACHINEキーを指定していても，ダウンロードパッケージによるインストールは実施されません。
  • 配布用パッケージによってインストールする場合，およびインストール方法の切り替えが不要な場合は，PATH_MACHINEキーを指定する必要はありません。


EPFDATAMAXSIZE

15.7.4　EPFDATAMAXSIZE

セクション
[OPTION]
設定内容
ダウンロードするEPF形式ファイルのファイルサイズの上限を指定します。
指定値
指定できる値は750～2,000,000です。単位はKBです。
750～2,000,000以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
EPFDATAMAXSIZEキーを省略した場合は，「2,000,000」が仮定されます。


DEFAULTPRINTDLG

15.7.5　DEFAULTPRINTDLG

セクション
[OPTION]
設定内容
［このマシンで印刷］を選択して印刷する場合に表示されるダイアログを，EUR Server Serviceのプリンタ選択ダイアログにするか，またはOSの印刷ダイアログにするかのどちらかを指定します。
設定内容
指定できる値を次に示します。
  • YES：印刷実行時，OSの印刷ダイアログを表示します。
  • NO：印刷実行時，EUR Server Serviceのプリンタ選択ダイアログを表示します。
指定できる値以外の文字を指定した場合は，省略値と同じ値が仮定されます。
省略値
DEFAULTPRINTDLGキーを省略した場合は，「YES」が仮定されます。
注意事項
OSの印刷ダイアログでは，印刷開始ページおよび印刷終了ページに65,534より大きい値を指定できません。65,534より大きい値を指定するとエラーが表示されるか，または指定していないページが印刷されます。
大量ページの帳票を印刷する場合には，EUR Server Serviceのプリンタ選択ダイアログを使用してください。


EUR Client Serviceの環境設定ファイル（EURPMCL.ini）

15.8　EUR Client Serviceの環境設定ファイル（EURPMCL.ini）

対象コンポーネントまたは機能
EUR Client Service
設定内容
EUR Client Serviceの動作環境は，環境設定ファイル（EURPMCL.ini）で設定します。
環境設定ファイルを変更した場合は，EUR Client Serviceを再起動してください。
環境設定ファイルの格納場所
環境設定ファイル（EURPMCL.ini）は，インストール先フォルダ\Client下に作成されます。
ファイルの内容を追加，変更する場合は，メモ帳などのテキスト編集エディタを起動して編集したあと，上書き保存してから使用してください。
＜環境設定ファイル（EURPMCL.ini）のサンプルの内容＞
[PORT]

[PATH]
#DELISERVICE=http://127.0.0.1:23100/eurssdeli/

[ERROR]

[OPTION]
SOCKBUFFSIZE=64

[TIMEOUT]

冒頭に「#」が付いている行はコメントの扱いになっています。EUR DeveloperまたはEUR Server Enterpriseをインストールして，配送サービスをローカルのマシンから使用するときは「#DELISERVICE」の冒頭の「#」を削除すれば使用できます。
環境設定ファイルの構文

変数名=値

環境設定ファイルに指定する情報は，「"」で囲まないでください。
環境設定ファイルの指定例

[PORT]
EURPMCL=23035

[PATH]
CONF=C:\EURPMCL\Conf
TEMP=C:\EURPMCL\Temp
DELISERVICE=http://XXX.XXX.XX.XX:YYYY/eurssdeli/

[ERROR]
LOGFILE=C:\EURPMCL\Log
LOGLEVEL=4
LOGSIZE=750
EVENTLOGLEVEL=0

[OPTION]
TEMPFILEDEL=1
SOCKBUFFSIZE=64
FIRSTDELIVERY=0
RMDIRRETRYCOUNT=1
RMDIRINTERVALTIME=200
SELECTDISPLAYPRINTER=0

[TIMEOUT]
CONNECT=300
ERRIGNORE=300
HTTPDATARECEIVE=600
＜この節の構成＞
15.8.1　設定項目一覧
15.8.2　EURPMCL
15.8.3　CONF
15.8.4　TEMP
15.8.5　DELISERVICE
15.8.6　LOGFILE
15.8.7　LOGLEVEL
15.8.8　LOGSIZE
15.8.9　EVENTLOGLEVEL
15.8.10　TEMPFILEDEL
15.8.11　SOCKBUFFSIZE
15.8.12　FIRSTDELIVERY
15.8.13　RMDIRRETRYCOUNT
15.8.14　RMDIRINTERVALTIME
15.8.15　SELECTDISPLAYPRINTER
15.8.16　CONNECT
15.8.17　ERRIGNORE
15.8.18　HTTPDATARECEIVE


設定項目一覧

15.8.1　設定項目一覧

EUR Client Serviceの環境設定ファイル（EURPMCL.ini）で指定できる内容を次の表に示します。

表15-45　EUR Client Serviceの環境設定ファイル（EURPMCL.ini）で指定できる内容

セクション | キー | 説明
PORT | EURPMCL | EUR Client Serviceのポート番号を指定します。
PATH | CONF | 構成定義ファイルがあるフォルダを指定します。
 | TEMP | EUR Client Serviceの作業フォルダを指定します。
 | DELISERVICE | 配送サービスのURLを指定します。
ERROR | LOGFILE | ログファイル（EURPMCL.log）の出力先フォルダを指定します。
 | LOGLEVEL | 実行ログの出力レベルを指定します。
 | LOGSIZE | ログファイル（EURPMCL.log）のファイルサイズの上限を指定します。
 | EVENTLOGLEVEL | イベントログの出力レベルを指定します。
OPTION | TEMPFILEDEL | 印刷実行時に生成した一時ファイルを削除するかどうかを指定します。
 | SOCKBUFFSIZE | ソケット通信に使用する通信バッファサイズの上限を指定します。
 | FIRSTDELIVERY | ログイン直後に配送印刷するかどうかを指定します。
 | RMDIRRETRYCOUNT | EUR Client Serviceで作業用一時ディレクトリの削除に失敗した場合，リトライする回数を指定します。
 | RMDIRINTERVALTIME | EUR Client Serviceで作業用一時ディレクトリの削除に失敗した場合，リトライするまでの待機時間を指定します。
 | SELECTDISPLAYPRINTER | 印刷ダイアログに初期表示するプリンタ名の表示モードを指定します。
TIMEOUT | CONNECT | 意図しない接続元が，データ通信を行わないでEUR Client Serviceと接続したままの状態になった場合，切断するまでの時間を指定します（タイムアウト監視）。
 | ERRIGNORE | ソケットを接続してデータを通信しないで切断する処理（生死監視）が実行された場合に，切断を検知してもエラーを出力しない時間を指定します。
 | HTTPDATARECEIVE | 配送印刷全般のHTTP通信で，データの受け取りのタイムアウト時間を指定します。


EURPMCL

15.8.2　EURPMCL

セクション
[PORT]
設定内容
EUR Client Serviceのポート番号を指定します。
指定値
指定できる値は，0～65535です。
省略値
EURPMCLキーを省略した場合は，「23035」が仮定されます。


CONF

15.8.3　CONF

セクション
[PATH]
設定内容
構成定義ファイルがあるフォルダを指定します。
指定値
フルパスで指定します。
省略値
CONFキーを省略した場合は，インストール先フォルダ\Client\Confフォルダが仮定されます。


TEMP

15.8.4　TEMP

セクション
[PATH]
設定内容
EUR Client Serviceの作業フォルダを指定します。
指定値
フルパスで指定します。
省略値
TEMPキーを省略した場合は，C:\Users\<ログインユーザ>\AppData\Roaming\Hitachi\EURフォルダが仮定されます。


DELISERVICE

15.8.5　DELISERVICE

セクション
[PATH]
設定内容
配送サービスのURLを指定します。
指定値
URLの文字列を指定します。
DELISERVICEキーを指定すると，配送印刷機能が有効になります。
記述例を次に示します。
[PATH]
DELISERVICE=http://XXX.XXX.XX.XX:YYYY/eurssdeli/
（凡例）
DELISERVICE：キー名（固定値）
http://XXX.XXX.XX.XX:YYYY/：接続先サーバのURL
eurssdeli/：サービス名（固定値）
省略値
DELISERVICEキーを省略すると，配送印刷機能は無効になります。


LOGFILE

15.8.6　LOGFILE

セクション
[ERROR]
設定内容
ログファイル（EURPMCL.log）の出力先フォルダを指定します。
指定値
フルパスで指定します。
省略値
LOGFILEキーを省略した場合は，C:\Users\<ログインユーザ>\AppData\Roaming\Hitachi\EURフォルダが仮定されます。


LOGLEVEL

15.8.7　LOGLEVEL

セクション
[ERROR]
設定内容
実行ログの出力レベルを指定します。
指定値
指定できる値を次に示します。
  • 0：ログ出力しません。
  • 4：起動，終了，実行時パラメタ，エラーを出力します。
  • 8：起動，終了，実行時パラメタ，エラー，警告を出力します。
  • 16：起動，終了，実行時パラメタ，エラー，警告，情報を出力します。
省略値
LOGLEVELキーを省略した場合は，「8」が仮定されます。
注意事項
出力レベルに「16」を指定すると，トレース情報が大量に出力されるため，性能が落ちるおそれがあります。障害調査時以外には指定しないでください。


LOGSIZE

15.8.8　LOGSIZE

セクション
[ERROR]
設定内容
ログファイル（EURPMCL.log）のファイルサイズの上限を指定します。
指定値
指定できる値は750～2,000,000です。単位はKBです。
750～2,000,000以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
LOGSIZEキーを省略した場合は，「750」が仮定されます。


EVENTLOGLEVEL

15.8.9　EVENTLOGLEVEL

セクション
[ERROR]
設定内容
イベントログの出力レベルを指定します。
指定値
指定できる値を次に示します。
  • 0：プログラムの起動，プログラムの終了，およびエラーを出力します。
  • 1：プログラムの起動，プログラムの終了，エラー，ジョブの起動，ジョブの終了，および印刷の正常終了を出力します。
0，1以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
EVENTLOGLEVELキーを省略した場合は，「0」が仮定されます。


TEMPFILEDEL

15.8.10　TEMPFILEDEL

セクション
[OPTION]
設定内容
印刷実行時に生成した一時ファイルを削除するかどうかを指定します。
EUR Client Serviceは，印刷実行時にはTEMPキーで設定した作業フォルダに一時ファイルを生成できます。一時ファイルは，障害対策のために使用します。
指定値
指定できる値を次に示します。
  • 0：常に削除します。
  • 1：正常終了時は削除します。異常終了時は削除しません。
  • 2：常に削除しません。
0，1，2以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
TEMPFILEDELキーを省略した場合は，「0」が仮定されます。


SOCKBUFFSIZE

15.8.11　SOCKBUFFSIZE

セクション
[OPTION]
設定内容
ソケット通信に使用する通信バッファサイズの上限を指定します。
指定値
指定できる値は，1～2,000,000です。単位はKBです。
通信バッファサイズの上限を無制限にしたい場合は，「0」を指定してください。
0～2,000,000以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
SOCKBUFFSIZEキーを省略した場合は，「64」が仮定されます。
注意事項
KEEY115-Eの通信エラーが発生し，かつEURPMログのエラー詳細情報に「errno=10055」が出力されているときは，指定した通信バッファサイズを確保するためのシステムのバッファ領域が不足していることを示しています。エラーが発生したときは，SOCKBUFFSIZEキーに指定されている値を小さく（8～64）して再試行してください。
なお，指定した値によっては，通信性能が変わることがあります。通信性能が劣化する場合は値を変更してチューニングしてください。


FIRSTDELIVERY

15.8.12　FIRSTDELIVERY

セクション
[OPTION]
設定内容
ログイン成功直後，配送印刷を開始するかどうかを指定します。
指定値
指定できる値を次に示します。
  • 0：ログイン成功後，INTERVALキーで指定した配送印刷時のポーリング間隔を経過してから配送印刷を開始します。
  • 1：ログイン成功直後に配送印刷を開始します。
0，1以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
FIRSTDELIVERYキーを省略した場合は，「1」が仮定されます。
注意事項
大量のユーザが同時にログインする環境の場合，Webサーバの混雑が予想されるため「0」を指定してください。


RMDIRRETRYCOUNT

15.8.13　RMDIRRETRYCOUNT

セクション
[OPTION]
設定内容
EUR Client Serviceで作業用一時フォルダの削除に失敗した場合，リトライする回数を指定します。
指定値
指定できる値は0～20です。
0を指定した場合，作業用一時フォルダの削除はリトライされません。
0～20以外の値，もしくは数値以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
RMDIRRETRYCOUNTキーを省略した場合は，「0」が仮定されます。


RMDIRINTERVALTIME

15.8.14　RMDIRINTERVALTIME

セクション
[OPTION]
設定内容
EUR Client Serviceで作業用一時フォルダの削除に失敗した場合，リトライするまでの待機時間を指定します。
指定値
指定できる値は100～1,000です。単位はミリ秒です。
100～1,000以外の値，もしくは数値以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
RMDIRINTERVALTIMEキーを省略した場合は，「200」が仮定されます。


SELECTDISPLAYPRINTER

15.8.15　SELECTDISPLAYPRINTER

セクション
[OPTION]
設定内容
印刷ダイアログに初期表示するプリンタ名の表示モードを指定します。
指定値
指定できる値を次に示します。

0：標準モード
  • 初めて印刷する帳票ジョブを受信した場合
    プリンタ名は表示されません。
  • 印刷したことがある帳票ジョブを受信した場合
    前回の受信時に設定したプリンタ名が表示されます。※
1：通常使うプリンタ初期表示モード
  • 初めて印刷する帳票ジョブを受信した場合
    通常使うプリンタのプリンタ名が表示されます。
  • 印刷したことがある帳票ジョブを受信した場合
    通常使うプリンタのプリンタ名が表示されます。

0，1以外の値を指定した場合は，省略値と同じ値が仮定されます。
注※
前回の受信時に設定したプリンタ名のプリンタが存在しない場合，プリンタ名は表示されません。
省略値
SELECTDISPLAYPRINTERキーを省略した場合は，「0」が仮定されます。


CONNECT

15.8.16　CONNECT

セクション
[TIMEOUT]
設定内容
意図しない接続元が，データ通信を行わないでEUR Client Serviceと接続したままの状態になった場合，切断するまでの時間を指定します（タイムアウト監視）。
指定値
指定できる値は，0～3,600です。単位は秒です。
0を指定した場合は，タイムアウト監視はしません。
0～3,600以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
CONNECTキーを省略した場合は，「600（10分）」が仮定されます。
注意事項
通信に時間が掛かり，タイムアウトで切断されてしまう場合は，CONNECTキーの値（タイムアウトの監視時間）を大きくして再試行してください。
なお，指定した値によっては，意図しない接続を切断するのに時間が掛かり，その間ジョブを受け付けられなくなったり，EUR Client Serviceを停止できなくなったりします。その場合は，値を変更してチューニングしてください。


ERRIGNORE

15.8.17　ERRIGNORE

セクション
[TIMEOUT]
設定内容
ソケットを接続してデータを通信しないで切断する処理（生死監視）が実行された場合に，切断を検知してもエラーを出力しない時間を指定します。
なお，何らかのデータを通信したあとに切断を検知した場合は，エラーが出力されます。
指定値
指定できる値は，0～3,600です。単位は秒です。
ERRIGNOREキーに「0」を指定した場合，切断を検知したとき必ずエラーが出力されます。
0～3,600以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
ERRIGNOREキーを省略した場合は，「3」が仮定されます。
注意事項
通信ポートの監視を実行する場合，KEEY115-Eのエラーが発生したときは，ERRIGNOREキーの値（切断を検知した場合にエラーを出力しない時間）を大きくして再試行してください。
なお，指定した値によっては，EUR Server Service および EUR Server - Spool Serviceとの接続が何らかの不具合により切断された場合に，切断を検知できなくなることがあります。その場合は，値を変更してチューニングしてください。


HTTPDATARECEIVE

15.8.18　HTTPDATARECEIVE

セクション
[TIMEOUT]
設定内容
配送印刷全般のHTTP通信で，データの受け取りのタイムアウト時間を指定します。
指定値
指定できる値は，1～86,400（24時間）です。単位は秒です。
1～86,400以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
HTTPDATARECEIVEキーを省略した場合は，「600」が仮定されます。


Server Service制御コマンドの環境設定ファイル（EURPMCTRL.ini）

15.9　Server Service制御コマンドの環境設定ファイル（EURPMCTRL.ini）

対象コンポーネントまたは機能
Server Service制御コマンド（eurpmctrlコマンド）
設定内容
Server Service制御コマンド（eurpmctrlコマンド）の動作環境は，環境設定ファイル（EURPMCTRL.ini）で設定します。
Server Service制御コマンドの環境設定ファイルを変更した場合は，次にServer Service制御コマンドを実行したときから有効になります。
環境設定ファイルのサンプルの格納場所
環境設定ファイル（EURPMCTRL.ini）のサンプルを次の場所に格納しています。
  • Windows環境の場合
    インストール先フォルダ\Sample\ServerService\下
  • UNIX／Linux環境の場合
    /opt/eur/sample/ServerService下
環境設定ファイル（EURPMCTRL.ini）のサンプルの内容を次に示します。
＜環境設定ファイル（EURPMCTRL.ini）のサンプルの内容＞
[PATH]

[ERROR]

[TIMEOUT]

環境設定ファイル（EURPMCTRL.ini）の設定手順
環境設定ファイルの設定手順を次に示します。
  1. 環境設定ファイル（EURPMCTRL.ini）のサンプルを任意の場所に保存します。
  2. 環境設定ファイルを編集します。
    環境設定ファイルは，マシンのロケールに応じたエンコードで編集してください。
  3. 必要な内容を設定した環境設定ファイルを，サンプルと同じファイル名（EURPMCTRL.ini）で次に格納します。
  • Windows環境の場合
    インストール先フォルダ\Server下
  • UNIX／Linux環境の場合
    /var/opt/eur/server下
なお，格納場所には，EUR Server Serviceを利用するユーザが読み書きできるようにアクセス権を設定してください。
環境設定ファイルの構文

変数名=値

環境設定ファイルに指定する情報は，「"」で囲まないでください。
環境設定ファイルの指定例

[PATH]
TEMP=/tmp

[ERROR]
LOGFILE=/var/opt/EUR/Log
LOGLEVEL=4
LOGSIZE=750

[TIMEOUT]
START=300
STOP=120
注意事項
EUR Server Serviceを複数起動している場合は，環境設定ファイル（EURPMCTRL.ini）のPATHセクションのTEMPキーの値は変更できません。変更したときには，Server Service制御コマンドの機能が使用できなくなります。
＜この節の構成＞
15.9.1　設定項目一覧
15.9.2　TEMP
15.9.3　LOGFILE
15.9.4　LOGLEVEL
15.9.5　LOGSIZE
15.9.6　START
15.9.7　STOP


設定項目一覧

15.9.1　設定項目一覧

Server Service制御コマンド（eurpmctrlコマンド）の環境設定ファイル（EURPMCTRL.ini）で指定できる内容を次の表に示します。

表15-46　Server Service制御コマンド（eurpmctrlコマンド）の環境設定ファイル（EURPMCTRL.ini）で指定できる内容

セクション | キー | 説明
PATH | TEMP | Server Service制御コマンドの作業フォルダを指定します。
ERROR | LOGFILE | ログファイル（EURPMCTRL.log）の出力先フォルダを指定します。
 | LOGLEVEL | 実行ログの出力レベルを指定します。
 | LOGSIZE | ログファイル（EURPMCTRL.log）のファイルサイズの上限を指定します。
TIMEOUT | START | EUR Server Serviceを起動するときの通信タイムアウト監視時間を指定します。
 | STOP | EUR Server Serviceを停止するときの通信タイムアウト監視時間を指定します。


TEMP

15.9.2　TEMP

セクション
[PATH]
設定内容
Server Service制御コマンド（eurpmctrlコマンド）の作業フォルダを指定します。
指定値
フルパスで指定します。
省略値
TEMPキーを省略した場合は，次のフォルダが仮定されます。
  • Windows環境のとき
    インストール先フォルダ\Server\Tempフォルダ
  • UNIX／Linux環境のとき
    /var/opt/eur/server/Temp


LOGFILE

15.9.3　LOGFILE

セクション
[ERROR]
設定内容
ログファイル（EURPMCTRL.log）の出力先フォルダを指定します。
指定値
フルパスで指定します。
省略値
LOGFILEキーを省略した場合は，次のフォルダが仮定されます。
  • Windows環境のとき
    インストール先フォルダ\Logフォルダ
  • UNIX／Linux環境のとき
    /var/opt/eur/log


LOGLEVEL

15.9.4　LOGLEVEL

セクション
[ERROR]
設定内容
実行ログの出力レベルを指定します。
指定値
指定できる値を次に示します。
  • 0：ログ出力しません。
  • 4：起動，終了，実行時パラメタ，エラーを出力します。
  • 8：起動，終了，実行時パラメタ，エラー，警告を出力します。
  • 16：起動，終了，実行時パラメタ，エラー，警告，情報を出力します。
省略値
LOGLEVELキーを省略した場合は，「8」が仮定されます。
注意事項
出力レベルに「16」を指定すると，トレース情報が大量に出力されるため，性能が落ちるおそれがあります。障害調査時以外には指定しないでください。


LOGSIZE

15.9.5　LOGSIZE

セクション
[ERROR]
設定内容
ログファイル（EURPMCTRL.log）のファイルサイズの上限を指定します。
指定値
指定できる値は750～2,000,000です。単位はKBです。
指定できない値を指定した場合は，省略値と同じ値が仮定されます。
省略値
LOGSIZEキーを省略した場合は，「750」が仮定されます。


START

15.9.6　START

セクション
[TIMEOUT]
設定内容
EUR Server Serviceを起動するときの通信タイムアウト監視時間を指定します。
指定値
指定できる値は，0～600（10分）です。単位は秒です。
0を指定した場合，または0～600以外の値を指定した場合は，タイムアウト監視はしません。
省略値
STARTキーを省略した場合は，「120」が仮定されます。


STOP

15.9.7　STOP

セクション
[TIMEOUT]
設定内容
EUR Server Serviceを停止するときの通信タイムアウト監視時間を指定します。
指定値
指定できる値は，0～600（10分）です。単位は秒です。
0を指定した場合，または0～600以外の値を指定した場合は，タイムアウト監視はしません。
省略値
STOPキーを省略した場合は，「120」が仮定されます。


Spool Service制御コマンドの環境設定ファイル（EURPMLSCTRL.ini）

15.10　Spool Service制御コマンドの環境設定ファイル（EURPMLSCTRL.ini）

対象コンポーネントまたは機能
Spool Service制御コマンド（eurpmlsctrlコマンド）
設定内容
Spool Service制御コマンド（eurpmlsctrlコマンド）の動作環境は，環境設定ファイル（EURPMLSCTRL.ini）で設定します。
Spool Service制御コマンドの環境設定ファイルを変更した場合は，次にSpool Service制御コマンドを実行したときから有効になります。
なお，Spool Service制御コマンドはUNIX／Linux環境の場合だけサポートしています。
環境設定ファイルのサンプルの格納場所
環境設定ファイル（EURPMLSCTRL.ini）のサンプルを次の場所に格納しています。
/opt/eur/sample/SpoolService下
環境設定ファイル（EURPMLSCTRL.ini）のサンプルの内容を次に示します。
＜環境設定ファイル（EURPMLSCTRL.ini）のサンプルの内容＞
[PATH]

[ERROR]

[TIMEOUT]

環境設定ファイル（EURPMLSCTRL.ini）の設定手順
環境設定ファイルの設定手順を次に示します。
  1. 環境設定ファイル（EURPMLSCTRL.ini）のサンプルを任意の場所に保存します。
  2. 環境設定ファイルを編集します。
    環境設定ファイルは，マシンのロケールに応じたエンコードで編集してください。
  3. 必要な内容を設定した環境設定ファイルを，サンプルと同じファイル名（EURPMLSCTRL.ini）で次に格納します。
    /var/opt/eur/spool下
なお，格納場所には，EUR Server - Spool Serviceを利用するユーザが読み書きできるようにアクセス権を設定してください。
環境設定ファイルの構文

変数名=値

環境設定ファイルに指定する情報は，「"」で囲まないでください。
環境設定ファイルの指定例

[PATH]
TEMP=/tmp

[ERROR]
LOGFILE=/var/opt/EUR/Log
LOGLEVEL=4
LOGSIZE=750

[TIMEOUT]
START=300
STOP=120
＜この節の構成＞
15.10.1　設定項目一覧
15.10.2　TEMP
15.10.3　LOGFILE
15.10.4　LOGLEVEL
15.10.5　LOGSIZE
15.10.6　START
15.10.7　STOP


設定項目一覧

15.10.1　設定項目一覧

Spool Service制御コマンド（eurpmlsctrlコマンド）の環境設定ファイル（EURPMLSCTRL.ini）で指定できる内容を次の表に示します。

表15-47　Spool Service制御コマンド（eurpmlsctrlコマンド）の環境設定ファイル（EURPMLSCTRL.ini）で指定できる内容

セクション | キー | 説明
PATH | TEMP | Spool Service制御コマンドの作業フォルダを指定します。
ERROR | LOGFILE | ログファイル（EURPMLSCTRL.log）の出力先フォルダを指定します。
 | LOGLEVEL | 実行ログの出力レベルを指定します。
 | LOGSIZE | ログファイル（EURPMLSCTRL.log）のファイルサイズの上限を指定します。
TIMEOUT | START | EUR Server - Spool Serviceを起動するときの通信タイムアウト監視時間を指定します。
 | STOP | EUR Server - Spool Serviceを停止するときの通信タイムアウト監視時間を指定します。


TEMP

15.10.2　TEMP

セクション
[PATH]
設定内容
Spool Service制御コマンド（eurpmlsctrlコマンド）の作業フォルダを指定します。
指定値
フルパスで指定します。
省略値
TEMPキーを省略した場合は，次のフォルダが仮定されます。
/var/opt/eur/spool/Temp


LOGFILE

15.10.3　LOGFILE

セクション
[ERROR]
設定内容
ログファイル（EURPMLSCTRL.log）の出力先フォルダを指定します。
指定値
フルパスで指定します。
省略値
LOGFILEキーを省略した場合は，次のフォルダが仮定されます。
/var/opt/eur/log


LOGLEVEL

15.10.4　LOGLEVEL

セクション
[ERROR]
設定内容
実行ログの出力レベルを指定します。
指定値
指定できる値を次に示します。
  • 0：ログ出力しません。
  • 4：起動，終了，実行時パラメタ，エラーを出力します。
  • 8：起動，終了，実行時パラメタ，エラー，警告を出力します。
  • 16：起動，終了，実行時パラメタ，エラー，警告，情報を出力します。
指定できない値を指定した場合は，省略値と同じ値が仮定されます。
省略値
LOGLEVELキーを省略した場合は，「8」が仮定されます。
注意事項
出力レベルに「16」を指定すると，トレース情報が大量に出力されるため，性能が落ちるおそれがあります。障害調査時以外には指定しないでください。


LOGSIZE

15.10.5　LOGSIZE

セクション
[ERROR]
設定内容
ログファイル（EURPMLSCTRL.log）のファイルサイズの上限を指定します。
指定値
指定できる値は750～2,000,000です。単位はKBです。
指定できない値を指定した場合は，省略値と同じ値が仮定されます。
省略値
LOGSIZEキーを省略した場合は，「750」が仮定されます。


START

15.10.6　START

セクション
[TIMEOUT]
設定内容
EUR Server - Spool Serviceを起動するときの通信タイムアウト監視時間を指定します。
指定値
指定できる値は，0～600（10分）です。単位は秒です。
0を指定した場合，または0～600以外の値を指定した場合は，タイムアウト監視はしません。
数値以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
STARTキーを省略した場合は，「120」が仮定されます。


STOP

15.10.7　STOP

セクション
[TIMEOUT]
設定内容
EUR Server - Spool Serviceを停止するときの通信タイムアウト監視時間を指定します。
指定値
指定できる値は，0～600（10分）です。単位は秒です。
0を指定した場合，または0～600以外の値を指定した場合は，タイムアウト監視はしません。
数値以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
STOPキーを省略した場合は，「120」が仮定されます。


BSP-RM連携コマンドの環境設定ファイル（eursmpr.ini）

15.11　BSP-RM連携コマンドの環境設定ファイル（eursmpr.ini）

対象コンポーネントまたは機能
BSP-RM連携コマンド（eursmprコマンド）
設定内容
BSP-RM連携コマンド（eursmprコマンド）の動作環境は，環境設定ファイル（eursmpr.ini）で設定します。
BSP-RM連携コマンドの環境設定ファイルを変更した場合は，次にBSP-RM連携コマンドを実行したときから有効になります。
なお，BSP-RM連携コマンドはWindows環境の場合だけサポートしています。
環境設定ファイルのサンプルの格納場所
環境設定ファイル（eursmpr.ini）のサンプルを次の場所に格納しています。
インストール先フォルダ\Eursmpr\下

環境設定ファイル（eursmpr.ini）のサンプルの内容を次に示します。
＜環境設定ファイル（eursmpr.ini）のサンプルの内容＞
[PATH]

[ERROR]

[OPTION]

環境設定ファイル（eursmpr.ini）の設定手順
環境設定ファイルの設定手順を次に示します。
  1. 環境設定ファイル（eursmpr.ini）のサンプルを任意の場所に保存します。
  2. 環境設定ファイルを編集します。
    環境設定ファイルは，マシンのロケールに応じたエンコードで編集してください。
  3. 必要な内容を設定した環境設定ファイルを，サンプルと同じファイル名（eursmpr.ini）で次に格納します。
    インストール先フォルダ\Eursmpr\下
なお，格納場所には，BSP-RM連携コマンドを利用するユーザが読み書きできるようにアクセス権を設定してください。
環境設定ファイルの構文
変数名=値

環境設定ファイルに指定する情報は，「"」で囲まないでください。
環境設定ファイルの指定例

[PATH]
TEMP=C:\EUR\Eursmpr\temp
DIVDATA=C:\EUR\Eursmpr\divdata
RUNPARAM=C:\EUR\Eursmpr\runparam

[ERROR]
LOGFILE=C:\EUR\Log
LOGLEVEL=8
LOGSIZE=750

[OPTION]
REMAINFLAG=1
＜この節の構成＞
15.11.1　設定項目一覧
15.11.2　環境変数一覧
15.11.3　TEMP
15.11.4　DIVDATA
15.11.5　RUNPARAM
15.11.6　REMAINFLAG
15.11.7　ERRORREMAIN
15.11.8　LOGFILE
15.11.9　LOGLEVEL
15.11.10　LOGSIZE


設定項目一覧

15.11.1　設定項目一覧

BSP-RM連携コマンド（eursmprコマンド）の環境設定ファイル（eursmpr.ini）で指定できる内容を次の表に示します。

表15-48　BSP-RM連携コマンド（eursmprコマンド）の環境設定ファイル（eursmpr.ini）で指定できる内容

セクション | キー | 説明
PATH | TEMP | BSP-RM連携コマンドの作業フォルダを指定します。
 | DIVDATA | 制御情報付データファイルがあるフォルダを指定します。
 | RUNPARAM | 起動パラメタファイルがあるフォルダを指定します。
OPTION | REMAINFLAG | BSP-RM連携コマンドで生成した帳票セット指定ファイルおよびマッピングデータファイルを，BSP-RMコマンドの実行後に残す場合に指定します。
 | ERRORREMAIN | BSP-RM連携コマンドから呼び出すeurpmcコマンドでエラーが発生した場合に，BSP-RM連携コマンドが生成する一時ファイルを削除するかどうかを指定します。
ERROR | LOGFILE | ログファイル（eursmpr.log）の出力先フォルダを指定します。
 | LOGLEVEL | 実行ログの出力レベルを指定します。
 | LOGSIZE | ログファイル（eursmpr.log）のファイルサイズの上限を指定します。


環境変数一覧

15.11.2　環境変数一覧

BSP-RM連携コマンド（eursmprコマンド）の動作環境は，環境設定ファイル（eursmpr.ini）の代わりに環境変数でも設定できます。

次項以降で説明する環境設定ファイル（eursmpr.ini）のキーに対応する環境変数を次の表に示します。環境変数に指定できる値は，対応する環境設定ファイル（eusmpr.ini）のキーに指定できる値と同じです。

なお，環境設定ファイル（eursmpr.ini）のキーと環境変数が同時に指定された場合は，環境変数の指定が有効になります。

表15-49　環境設定ファイル（eursmpr.ini）のキーと環境変数の対応

環境設定ファイルのキー | 環境変数 | 説明
TEMP | EURSMPR_OUTPUTPATH | BSP-RM連携コマンドの作業フォルダを指定します。
DIVDATA | EURSMPR_DATAPATH | 制御情報付データファイルの格納先フォルダを指定します。
RUNPARAM | EURSMPR_PARAMPATH | 起動パラメタファイルの格納先フォルダを指定します。
REMAINFLAG | EURSMPR_REMAINFLAG | BSP-RM連携コマンドが生成する一時ファイルを保存する条件を指定します。


TEMP

15.11.3　TEMP

セクション
[PATH]
設定内容
BSP-RM連携コマンド（eursmprコマンド）の作業フォルダを指定します。
指定値
フルパスで指定します。
省略値
TEMPキーを省略した場合，またはTEMPキーに値を指定していない場合は，次のフォルダが仮定されます。
インストール先フォルダ\Eursmpr\temp
注意事項
指定したフォルダが存在しない場合，または指定したフォルダにアクセスできない場合は，エラー（KEEU3019-E）になります。


DIVDATA

15.11.4　DIVDATA

セクション
[PATH]
設定内容
制御情報付データファイルの格納先フォルダを指定します。
指定値
フルパスで指定します。
省略値
DIVDATAキーを省略した場合，またはDIVDATAキーに値を指定していない場合は，次のフォルダが仮定されます。
インストール先フォルダ\Eursmpr\divdata


RUNPARAM

15.11.5　RUNPARAM

セクション
[PATH]
設定内容
起動パラメタファイルの格納先フォルダを指定します。
指定値
フルパスで指定します。
省略値
RUNPARAMキーを省略した場合，またはRUNPARAMキーに値を指定していない場合は，次のフォルダが仮定されます。
インストール先フォルダ\Eursmpr\runparam


REMAINFLAG

15.11.6　REMAINFLAG

セクション
[OPTION]
設定内容
BSP-RM連携コマンド（eursmprコマンド）が生成する一時ファイルを保存する条件を指定します。
BSP-RM連携コマンドが一時ファイルとして生成する帳票セット指定ファイルおよびマッピングデータファイルを保守情報として採取する場合に指定します。
指定値
指定できる値と条件を次に示します。また，各条件の値を足し合わせることによって，条件を組み合わせて指定することもできます。
  • 1：BSP-RM連携コマンドから呼び出すeurpmcコマンドの実行中に警告が発生した場合（BSP-RM連携コマンドの終了コードが4の場合）に一時ファイルを保存します。
  • 2：BSP-RM連携コマンドが異常終了した場合（BSP-RM連携コマンドの終了コードが3008または3032の場合）に一時ファイルを保存します。
  • 4：BSP-RM連携コマンドが正常終了した場合（BSP-RM連携コマンドの終了コードが0の場合）に一時ファイルを保存します。
なお，BSP-RM連携コマンドから呼び出すeurpmcコマンドでエラーが発生した場合（BSP-RM連携コマンドの終了コードが8の場合）はデフォルトで一時ファイルが保存されます。eurpmcコマンドでエラーが発生した場合に一時ファイルを削除する場合は，ERRORREMAINキーの指定値に0を設定する必要があります。ERRORREMAINキーの詳細については，「15.11.7　ERRORREMAIN」を参照してください。
REMAINFLAGキーの指定値の組み合わせと一時ファイルを保存するかどうかの動作を次の表に示します。

表15-50　REMAINFLAGキーの指定値の組み合わせと一時ファイルを保存するかどうかの動作

指定値 | BSP-RM連携コマンド（eursmprコマンド）の終了コード
0（正常終了） | 4（eurpmcコマンドで警告が発生） | 8（eurpmcコマンドでエラーが発生） | 3008または3032（異常終了）
1 × ○ △ ×
2 × × △ ○
3 × ○ △ ○
4 ○ × △ ×
5 ○ ○ △ ×
6 ○ × △ ○
7 ○ ○ △ ○
（凡例）
○：一時ファイルを保存します。
×：一時ファイルを削除します。
△：ERRORREMAINキーを省略している場合，またはERRORREMAINキーの指定値に1を設定している場合は一時ファイルを保存します。

指定値に数値以外の値を指定した場合は，REMAINFLAGキーの指定なしと仮定されます。
指定値に1～7以外の数値を指定した場合は，指定値を2進数のビットパターンで判定し，1桁目が1のときは値1の条件，2桁目が1のときは値2の条件，および3桁目が1のときは値4の条件が指定されているものとして動作します。
省略値
REMAINFLAGキーを省略した場合は，未指定となります。
注意事項
業務システムでeurpmcコマンドの警告を判別していない場合は，REMAINFLAGキーの指定値に1を含む条件を設定する運用を推奨します。eurpmcコマンドの警告発生時に警告要因を調査するときは，保存されている一時ファイルを保守情報として採取します。


ERRORREMAIN

15.11.7　ERRORREMAIN

セクション
[OPTION]
設定内容
BSP-RM連携コマンド（eursmprコマンド）から呼び出すeurpmcコマンドでエラーが発生した場合（BSP-RM連携コマンドの終了コードが8の場合）にBSP-RM連携コマンドが生成する一時ファイルを削除するかどうかを指定します。
指定値
指定できる値を次に示します。
  • 0：eurpmcコマンドでエラーが発生した場合に一時ファイルを削除します。
  • 1：eurpmcコマンドでエラーが発生した場合に一時ファイルを削除しません。
0，1以外の値を指定した場合は，省略値と同じ値が仮定されます。
省略値
ERRORREMAINキーを省略した場合は，「1」が仮定されます。


LOGFILE

15.11.8　LOGFILE

セクション
[ERROR]
設定内容
ログファイル（eursmpr.log）の出力先フォルダを指定します。
指定値
フルパスで指定します。
省略値
LOGFILEキーを省略した場合は，次のフォルダが仮定されます。
インストールフォルダ\Log


LOGLEVEL

15.11.9　LOGLEVEL

セクション
[ERROR]
設定内容
実行ログの出力レベルを指定します。
指定値
指定できる値を次に示します。
  • 0：ログ出力しません。
  • 4：起動，終了，実行時パラメタ，エラーを出力します。
  • 8：起動，終了，実行時パラメタ，エラー，警告を出力します。
  • 16：起動，終了，実行時パラメタ，エラー，警告，情報を出力します。
指定できない値を指定した場合は，省略値と同じ値が仮定されます。
省略値
LOGLEVELキーを省略した場合は，「8」が仮定されます。


LOGSIZE

15.11.10　LOGSIZE

セクション
[ERROR]
設定内容
ログファイル（eursmpr.log）のファイルサイズの上限を指定します。
指定値
指定できる値は750～2,000,000です。単位はKBです。
指定できない値を指定した場合は，省略値と同じ値が仮定されます。
省略値
LOGSIZEキーを省略した場合は，「750」が仮定されます。


ファイル監視サービスの環境設定ファイル（eurfm.ini）

15.12　ファイル監視サービスの環境設定ファイル（eurfm.ini）

対象コンポーネントまたは機能
ファイル監視サービス
設定内容
ファイル監視サービスの動作環境は，環境設定ファイル（eurfm.ini）で設定します。
環境設定ファイルを変更した場合は，ファイル監視サービスを再起動してください。
なお，ファイル監視サービスはWindows環境の場合だけサポートしています。
環境設定ファイルのサンプルの格納場所
環境設定ファイル（eurfm.ini）のサンプルを次の場所に格納しています。
インストール先フォルダ\FileMonitor\下

環境設定ファイル（eurfm.ini）のサンプルの内容を次に示します。
＜環境設定ファイル（eurfm.ini）のサンプルの内容＞
[PATH]
#FMC=
#CONF=
#RUNPARAM=

[ERROR]

[OPTION]
#INTERVAL=10
STANDARDTIME=1

[TIMEOUT]
#DATALIMIT=30

[THREAD]
#GENERAL=10

環境設定ファイル（eurfm.ini）の設定手順
環境設定ファイルの設定手順を次に示します。
  1. 環境設定ファイル（eurfm.ini）のサンプルを任意の場所に保存します。
  2. 環境設定ファイルを編集します。
    環境設定ファイルは，マシンのロケールに応じたエンコードで編集してください。
  3. 必要な内容を設定した環境設定ファイルを，サンプルと同じファイル名（eurfm.ini）で次に格納します。
    インストール先フォルダ\FileMonitor\下
なお，格納場所には，ファイル監視サービスを利用するユーザが読み書きできるようにアクセス権を設定してください。
環境設定ファイルの構文
変数名=値

環境設定ファイルに指定する情報は，「"」で囲まないでください。
環境設定ファイルの指定例

[PATH]
FMC=C:\EUR\FileMonitor\fmc
CONF=C:\EUR\FileMonitor\conf
RUNPARAM=C:\EUR\FileMonitor\runparam

[ERROR]
LOGFILE=C:\EUR\Log
LOGLEVEL=8
LOGSIZE=750

[OPTION]
INTERVAL=10
STANDARDTIME=0

[TIMEOUT]
DATALIMIT=30

[THREAD]
GENERAL=10
＜この節の構成＞
15.12.1　設定項目一覧
15.12.2　FMC
15.12.3　CONF
15.12.4　RUNPARAM
15.12.5　LOGFILE
15.12.6　LOGLEVEL
15.12.7　LOGSIZE
15.12.8　INTERVAL
15.12.9　STANDARDTIME
15.12.10　DATALIMIT
15.12.11　GENERAL


設定項目一覧

15.12.1　設定項目一覧

ファイル監視サービスの環境設定ファイル（eurfm.ini）で指定できる内容を次の表に示します。

表15-51　ファイル監視サービスの環境設定ファイル（eurfm.ini）で指定できる内容

セクション | キー | 説明
PATH | FMC | 監視管理フォルダを指定します。
 | CONF | 構成定義ファイルがあるフォルダを指定します。
 | RUNPARAM | 起動パラメタファイルがあるフォルダを指定します。
ERROR | LOGFILE | ログファイル（eurfm.log）の出力先フォルダを指定します。
 | LOGLEVEL | 実行ログの出力レベルを指定します。
 | LOGSIZE | ログファイル（eurfm.log）のファイルサイズの上限を指定します。
OPTION | INTERVAL | ファイル着信の監視間隔を指定します。
 | STANDARDTIME | ファイル監視サービスが稼働するマシンの日付が変わったあと，ファイル監視サービスが最初のジョブを実行するときに，完了フォルダに格納されているファイルを保持しておく期限が切れたファイルを自動的に削除する処理において，日付変更の契機にローカルタイムと協定世界時（UTC）のどちらを使用するかを指定します。
TIMEOUT | DATALIMIT | 完了フォルダに格納されているファイルを保持する期限を指定します。
THREAD | GENERAL | ファイル監視サービスによる印刷およびファイル出力の並列処理数を指定します。


FMC

15.12.2　FMC

セクション
[PATH]
設定内容
ファイル監視サービスの監視管理フォルダを指定します。
指定値
フルパスで指定します。
省略値
FMCキーを省略した場合は，次のフォルダが仮定されます。
インストール先フォルダ\FileMonitor\fmc
注意事項
  • 指定したフォルダが存在しない場合は，ファイル監視サービスの起動時にKEEU1027-Eエラーになります。
  • ネットワークドライブ上のフォルダは指定できません。


CONF

15.12.3　CONF

セクション
[PATH]
設定内容
構成定義ファイルがあるフォルダを指定します。
指定値
フルパスで指定します。
省略値
CONFキーを省略した場合は，次のフォルダが仮定されます。
インストール先フォルダ\FileMonitor\conf
注意事項
ネットワークドライブ上のフォルダは指定できません。


RUNPARAM

15.12.4　RUNPARAM

セクション
[PATH]
設定内容
起動パラメタファイルの格納先フォルダを指定します。
指定値
フルパスで指定します。
省略値
RUNPARAMキーを省略した場合は，次のフォルダが仮定されます。
インストール先フォルダ\FileMonitor\runparam
注意事項
ネットワークドライブ上のフォルダは指定できません。


LOGFILE

15.12.5　LOGFILE

セクション
[ERROR]
設定内容
ログファイル（eurfm.log）の出力先フォルダを指定します。
指定値
フルパスで指定します。
省略値
LOGFILEキーを省略した場合は，次のフォルダが仮定されます。
インストール先フォルダ\Log


LOGLEVEL

15.12.6　LOGLEVEL

セクション
[ERROR]
設定内容
実行ログの出力レベルを指定します。
指定値
指定できる値を次に示します。
  • 0：ログ出力しません。
  • 4：起動，終了，実行時パラメタ，エラーを出力します。
  • 8：起動，終了，実行時パラメタ，エラー，警告を出力します。
  • 16：起動，終了，実行時パラメタ，エラー，警告，情報を出力します。
指定できない値を指定した場合は，省略値と同じ値が仮定されます。
省略値
LOGLEVELキーを省略した場合は，「8」が仮定されます。


LOGSIZE

15.12.7　LOGSIZE

セクション
[ERROR]
設定内容
ログファイル（eurfm.log）のファイルサイズの上限を指定します。
指定値
指定できる値は750～2,000,000です。単位はKBです。
指定できない値を指定した場合は，省略値と同じ値が仮定されます。
省略値
LOGSIZEキーを省略した場合は，「750」が仮定されます。


INTERVAL

15.12.8　INTERVAL

セクション
[OPTION]
設定内容
ファイル監視サービスがファイルの着信を監視する間隔を指定します。
指定値
指定できる値は1～3,600です。単位は秒です。
指定できない値を指定した場合は，省略値と同じ値が仮定されます。
省略値
INTERVALキーを省略した場合は，「10」が仮定されます。


STANDARDTIME

15.12.9　STANDARDTIME

セクション
[OPTION]
設定内容
ファイル監視サービスが稼働するマシンの日付が変わったあと，ファイル監視サービスが最初のジョブを実行するときに，完了フォルダに格納されているファイルを保持しておく期限（環境設定ファイル（eurfm.ini）のTIMEOUTセクションのDATALIMITキー）が切れたファイルを自動的に削除する処理において，日付変更の契機にローカルタイムと協定世界時（UTC）のどちらを使用するかを指定します。
指定値
指定できる値を次に示します。
  • 0：ローカルタイム
  • 1：協定世界時（UTC）
指定できない値を指定した場合は，省略値と同じ値が仮定されます。
省略値
STANDARDTIMEキーを省略した場合は，「0」が仮定されます。


DATALIMIT

15.12.10　DATALIMIT

セクション
[TIMEOUT]
設定内容
完了フォルダに格納されているファイルを保持しておく期限を日数で指定します。指定した期限を過ぎると，実行ジョブIDフォルダとファイルを削除します。
日付処理には，協定世界時（UTC）を使用します。
指定値
指定できる値は0～999です。単位は日です。
0を指定した場合は，翌日に実行ジョブIDとファイルが削除されます。
指定できない値を指定した場合は，省略値と同じ値が仮定されます。
省略値
DATALIMITキーを省略した場合は，「30」が仮定されます。


GENERAL

15.12.11　GENERAL

セクション
[THREAD]
設定内容
ファイル監視サービスの並列処理数を指定します。
指定値
指定できる値は1～50です。
指定できない値を指定した場合は，省略値と同じ値が仮定されます。
省略値
GENERALキーを省略した場合は，「10」が仮定されます。
注意事項
GENERALキーに正しい値を設定しても，マシン環境およびほかのプログラムの実行環境によって，設定したとおりの動作をしない場合があります。


ジョブ実行プログラムの環境設定ファイル（eurivk.ini）

15.13　ジョブ実行プログラムの環境設定ファイル（eurivk.ini）

対象コンポーネントまたは機能
ジョブ実行プログラム
設定内容
ジョブ実行プログラムの動作環境は，環境設定ファイル（eurivk.ini）で設定します。
ジョブ実行プログラムの環境設定ファイルを変更した場合は，次にファイル監視サービスを起動したときから有効になります。
なお，ジョブ実行プログラムはWindows環境の場合だけサポートしています。
環境設定ファイルのサンプルの格納場所
環境設定ファイル（eurivk.ini）のサンプルを次の場所に格納しています。
インストール先フォルダ\FileMonitor\下

環境設定ファイル（eurivk.ini）のサンプルの内容を次に示します。
＜環境設定ファイル（eurivk.ini）のサンプルの内容＞
[ERROR]

環境設定ファイル（eurivk.ini）の設定手順
環境設定ファイルの設定手順を次に示します。
  1. 環境設定ファイル（eurivk.ini）のサンプルを任意の場所に保存します。
  2. 環境設定ファイルを編集します。
    環境設定ファイルは，マシンのロケールに応じたエンコードで編集してください。
  3. 必要な内容を設定した環境設定ファイルを，サンプルと同じファイル名（eurivk.ini）で次に格納します。
    インストール先フォルダ\FileMonitor\下
なお，格納場所には，ファイル監視サービスを利用するユーザが読み書きできるようにアクセス権を設定してください。
環境設定ファイルの構文
変数名=値

環境設定ファイルに指定する情報は，「"」で囲まないでください。
環境設定ファイルの指定例
[ERROR]
LOGFILE=C:\EUR\Log
LOGLEVEL=8
LOGSIZE=750
＜この節の構成＞
15.13.1　設定項目一覧
15.13.2　LOGFILE
15.13.3　LOGLEVEL
15.13.4　LOGSIZE


設定項目一覧

15.13.1　設定項目一覧

ジョブ実行プログラムの環境設定ファイル（eurivk.ini）で指定できる内容を次の表に示します。

表15-52　ジョブ実行プログラムの環境設定ファイル（eurivk.ini）で指定できる内容

セクション | キー | 説明
ERROR | LOGFILE | ログファイル（eurivk.log）の出力先フォルダを指定します。
 | LOGLEVEL | 実行ログの出力レベルを指定します。
 | LOGSIZE | ログファイル（eurivk.log）のファイルサイズの上限を指定します。


LOGFILE

15.13.2　LOGFILE

セクション
[ERROR]
設定内容
ログファイル（eurivk.log）の出力先フォルダを指定します。
指定値
フルパスで指定します。
省略値
LOGFILEキーを省略した場合は，次のフォルダが仮定されます。
インストール先フォルダ\Log


LOGLEVEL

15.13.3　LOGLEVEL

セクション
[ERROR]
設定内容
実行ログの出力レベルを指定します。
指定値
指定できる値を次に示します。
  • 0：ログ出力しません。
  • 4：起動，終了，実行時パラメタ，エラーを出力します。
  • 8：起動，終了，実行時パラメタ，エラー，警告を出力します。
  • 16：起動，終了，実行時パラメタ，エラー，警告，情報を出力します。
指定できない値を指定した場合は，省略値と同じ値が仮定されます。
省略値
LOGLEVELキーを省略した場合は，「8」が仮定されます。


LOGSIZE

15.13.4　LOGSIZE

セクション
[ERROR]
設定内容
ログファイル（eurivk.log）のファイルサイズの上限を指定します。
指定値
指定できる値は750～2,000,000です。単位はKBです。
指定できない値を指定した場合は，省略値と同じ値が仮定されます。
省略値
LOGSIZEキーを省略した場合は，「750」が仮定されます。


付録

＜この付録の構成＞
付録A　コマンドやAPIを使用するときの注意
付録B　このマニュアルの参考情報


コマンドやAPIを使用するときの注意

付録A　コマンドやAPIを使用するときの注意

コマンドやAPIを使用するときの注意事項を次に示します。

＜この節の構成＞
付録A.1　ファイル名，およびファイルのパスを指定するときの注意
付録A.2　環境設定ファイルとの関係


ファイル名，およびファイルのパスを指定するときの注意

付録A.1　ファイル名，およびファイルのパスを指定するときの注意

ファイル名に指定できる文字数（フルパス）を，次に示します。

表A-1　ファイル名に指定できる文字数

適用OS | ファイル名に指定できる文字数
Windows | 259文字以内※
HP-UX | 1,023バイト以内
AIX | 1,023バイト以内
Linux | 1,023バイト以内
注※
Windows環境で相対パス，またはファイル名だけを指定する場合は，255文字以内です。

ファイル名は，EUR サーバ帳票出力機能が稼働するOSのファイルシステムのファイル名称規則に従って指定してください。なお，EUR サーバ帳票出力機能を実行するUNIX環境の文字ロケールがShift JISの場合，NEC選定IBM特殊文字（89区～92区）の文字を使用したファイル名のファイルは，使用できません。

ほかのOSから転送した帳票ファイルやデータファイルを使用する場合は，使用できる文字数やファイル名称規則が異なるので注意してください。

EUR Server Serviceで扱えるファイル名，およびファイルのパスを指定するときの注意を次に示します。

  • ファイル名，およびファイルのパスは，EUR Server Serviceが稼働するOSのファイルシステムのファイル名称規則に従って，使用できる文字で指定してください。
    なお，EUR Server Serviceでは，構成定義ファイルで「"」と「,」を区切り文字に使用しているため，「"」と「,」は使用できません。
  • COBOL起動部品でファイル名，およびファイルのパスを指定する場合，256バイトに満たないときは，半角空白で埋めてください。
  • ファイル名，およびファイルのパスを指定するときの大文字・小文字の区別を次に示します。
    • Windows環境の場合
      大文字・小文字は区別されません。
    • UNIX／Linux環境の場合
      大文字・小文字は区別されます。
  • 印刷定義ファイル，ユーザデータファイル，構成定義ファイル，EUR Web Plug-In情報ファイル，および環境設定ファイルを指定するときは，次に示す規則に従ってください。
    • ファイル名を指定するときは，存在するファイルまたは読み込み権限のあるファイルを指定してください。
    • ファイルのパスを指定するときは，存在するフォルダまたは読み込み権限のあるフォルダを指定してください。


環境設定ファイルとの関係

付録A.2　環境設定ファイルとの関係

ActiveX起動部品の場合は，ActiveX起動部品で指定するファイルのデフォルトの読み込みフォルダなどを，環境設定ファイル（EURPMADP.ini）に指定できます。

SS-ActiveX起動部品の場合は，SS-ActiveX起動部品で指定するサーバマシンのIPアドレスなどを，環境設定ファイル（EURPMLSADP.ini）に指定できます。

Java起動部品の場合は，Java起動部品で指定するファイルのデフォルトの読み込みフォルダなどを，環境設定ファイル（EURPMADP.ini）に指定できます。

SS-Java起動部品の場合は，SS-Java起動部品で指定するポート番号，クライアントマシンのIPアドレスなどを，環境設定ファイル（EURPMLSADP.ini）に指定できます。

COBOL起動部品で指定するファイルのデフォルトの読み込みフォルダなどを，環境設定ファイル（EURPMADP.ini）に指定できます。

eurpmcコマンドの場合は，コマンドで指定するポート番号，サーバマシンのIPアドレスなどを，環境設定ファイル（EURPMADP.ini）に指定できます。

eurpmlscコマンドの場合は，コマンドで指定するポート番号，サーバマシンのIPアドレスなどを，環境設定ファイル（EURPMLSADP.ini）に指定できます。

eurpmlscコマンドの場合は，コマンドで指定するポート番号，サーバマシンのIPアドレスなどを，環境設定ファイル（EURPMLSADP.ini）に指定できます。

BSP-RM連携コマンド（eursmprコマンド）の場合は，制御情報付データファイルおよび起動パラメタファイルの格納先などを，環境設定ファイル（eursmpr.ini）に指定できます。

ファイル監視サービスの場合は，監視管理フォルダ，構成定義ファイルおよび起動パラメタファイルの格納先，ファイルの着信を監視する間隔などを，環境設定ファイル（eurfm.ini）に指定できます。

ジョブ実行プログラムの場合は，出力するログの情報などを，ファイル環境設定ファイル（eurivk.ini）に指定できます。

各環境設定ファイルについては，「15.　環境設定ファイル」を参照してください。


このマニュアルの参考情報

付録B　このマニュアルの参考情報

このマニュアルを読むに当たっての参考情報を示します。

＜この節の構成＞
付録B.1　関連マニュアル
付録B.2　EUR バージョン9での製品体系の変更
付録B.3　EUR バージョン9でのマニュアル体系の変更
付録B.4　このマニュアルでの表記
付録B.5　このマニュアルで使用する略語
付録B.6　KB（キロバイト）などの単位表記について


関連マニュアル

付録B.1　関連マニュアル

関連マニュアルを次に示します。必要に応じてお読みください。

＜この項の構成＞
(1)　EURのマニュアル
(2)　関連ソフトウェアのマニュアル
(3)　このマニュアルでのマニュアル名表記

(1)　EURのマニュアル

EURの関連マニュアルを次に示します。

  • はじめての帳票作成（3020-7-532）※
    EUR 帳票作成機能をまだ使用したことのない人向けに，簡単な帳票を作成する方法について説明しています。
  • uCosminexus EUR システム設計ガイド（3020-7-702）
    EURを使用した帳票システムの計画・設計時に検討が必要な内容について説明しています。
  • uCosminexus EUR システム構築ガイド（3020-7-703）
    EURを使用した帳票システムを構築する手順について説明しています。
  • uCosminexus EUR 帳票作成 操作ガイド（3020-7-704）
    EUR 帳票作成機能を使用して帳票を作成する方法について説明しています。
  • uCosminexus EUR 帳票作成 画面リファレンス（3020-7-705）
    EUR 帳票作成機能で表示されるダイアログの内容について説明しています。
  • uCosminexus EUR 帳票設計（EUR Form帳票）（3020-7-534）※
    EUR Form帳票作成機能を使用してEUR Form帳票を作成する方法について説明しています。
  • uCosminexus EUR 帳票出力 EUR Designer/EUR Viewer編（3020-7-707）
    EUR DesignerまたはEUR Viewerを使用して，クライアント環境で帳票を出力する方法について説明しています。
  • uCosminexus EUR クライアント帳票出力（3020-7-535）※
    EUR クライアント帳票出力機能のV8互換機能を使用して，クライアント環境で帳票を出力する方法について説明しています。
  • uCosminexus EUR 帳票出力 機能解説 EUR Server編（3020-7-708）
    EUR サーバ帳票出力機能を使って帳票を出力する方法について説明しています。
  • uCosminexus EUR サーバ帳票出力（3020-7-536）※
    EUR ServerのV8互換機能を使用して，サーバ環境で帳票を出力する方法について説明しています。
  • uCosminexus EUR データベース連携ガイド（3020-7-713）
    データベースから抽出したデータを使って帳票を作成および出力する方法ならびにEUR 帳票作成機能のデータベースアクセス定義ウィンドウを使用する方法について説明しています。また，データベースの操作時に出力されるメッセージについても説明しています。
  • uCosminexus EUR メッセージ（3020-7-714）
    EURを使用しているときに出力されるメッセージについて説明しています。
  • uCosminexus EUR 用語集（3020-7-715）
    EURシリーズマニュアル内で使用する用語について説明しています。なお，この用語集は日立ソフトウェアマニュアル公開サイト，または製品同梱のヘルプ（Windows版）だけで参照できます。
注※
バージョン8のマニュアルを提供しています。バージョン9の製品に置き換えて参照してください。

(2)　関連ソフトウェアのマニュアル

関連ソフトウェアのマニュアルを次に示します。

  • TPBroker ユーザーズガイド（3000-3-660）
  • TPBroker Developer's Kit - Extension for C++ プログラマーズガイド（3000-3-680）
  • TPBroker Object Transaction Monitor ユーザーズガイド（3000-3-689）
  • COBOL2002　使用の手引　手引編（3000-3-D42）
  • COBOL2002　使用の手引　操作編（3000-3-D43）
  • COBOL2002　操作ガイド（3020-3-D47）
  • COBOL2002　ユーザーズガイド（Web公開限定）（3020-3-D48）
  • SEWB+/REPOSITORY 辞書設計ガイド（3020-3-698）
  • SEWB+/REPOSITORY 辞書設計ガイド（3020-3-N82）
  • DBPARTNER2 Client　操作ガイド（3020-6-027）
  • DABroker（3020-6-031）
  • HiRDB Version 8 UAP開発ガイド（3020-6-356）
  • HiRDB Version 8 メッセージ（3020-6-358）
  • HiRDB Version 9 UAP開発ガイド（3020-6-456）
  • HiRDB Version 9 メッセージ（3020-6-458）
  • JP1 Version 10 JP1/Audit Management - Manager 構築・運用ガイド（3021-3-165）

(3)　このマニュアルでのマニュアル名表記

このマニュアルでは，マニュアル名について，次のように表記しています。

マニュアル名 | 表記
uCosminexus EUR システム設計ガイド | EUR システム設計ガイド
uCosminexus EUR システム構築ガイド | EUR システム構築ガイド
uCosminexus EUR 帳票作成 操作ガイド | EUR 帳票作成 操作ガイド
uCosminexus EUR 帳票作成 画面リファレンス | EUR 帳票作成 画面リファレンス
uCosminexus EUR 帳票出力 EUR Designer/EUR Viewer編 | EUR 帳票出力 EUR Designer/EUR Viewer編
uCosminexus EUR 帳票出力 機能解説 EUR Server編 | EUR 帳票出力 機能解説 EUR Server編
uCosminexus EUR 帳票出力 リファレンス EUR Server編 | EUR 帳票出力 リファレンス EUR Server編
uCosminexus EUR データベース連携ガイド | EUR データベース連携ガイド
uCosminexus EUR メッセージ | EUR メッセージ
uCosminexus EUR 用語集 | EUR 用語集
uCosminexus EUR 概説 | EUR 概説
uCosminexus EUR 帳票設計 | EUR 帳票設計
uCosminexus EUR 帳票設計（EUR Form帳票） | EUR 帳票設計（EUR Form帳票）
uCosminexus EUR クライアント帳票出力 | EUR クライアント帳票出力
uCosminexus EUR サーバ帳票出力 | EUR サーバ帳票出力
uCosminexus EUR Print Manager 帳票出力 | EUR Print Manager 帳票出力
uCosminexus EUR Print Manager メッセージ | EUR Print Manager メッセージ
HiRDB Version 8 UAP開発ガイド HiRDB Version 9 UAP開発ガイド | HiRDB UAP開発ガイド
HiRDB Version 8 メッセージ HiRDB Version 9 メッセージ | HiRDB メッセージ
JP1 Version 10 JP1/Audit Management - Manager 構築・運用ガイド | JP1/Audit Management - Manager 構築・運用ガイド


EUR バージョン9での製品体系の変更

付録B.2　EUR バージョン9での製品体系の変更

EUR バージョン9での製品体系の変更について，次の図に示します。


EUR バージョン9でのマニュアル体系の変更

付録B.3　EUR バージョン9でのマニュアル体系の変更

EUR バージョン9では，マニュアル体系を次の表に示す各使用目的に合わせて次のとおり変更しました。

EUR バージョン8 | EUR バージョン9
次のマニュアルの，システム計画・設計に関連する部分
  • EUR 概説
  • EUR 帳票設計
  • EUR クライアント帳票出力
  • EUR サーバ帳票出力
  • EUR Print Manager 帳票出力
 EUR システム設計ガイド
次のマニュアルの，システム構築に関連する部分
  • EUR 帳票設計
  • EUR クライアント帳票出力
  • EUR サーバ帳票出力
  • EUR Print Manager 帳票出力
 EUR システム構築ガイド
EUR 帳票設計（第1編～第4編） | EUR 帳票作成 操作ガイド
EUR 帳票設計（第5編） | EUR 帳票作成 画面リファレンス
次のマニュアルの，機能概要を説明している部分，およびコーディング例
  • EUR サーバ帳票出力
  • EUR Print Manager 帳票出力
 EUR 帳票出力 機能解説 EUR Server編
次のマニュアルの，各APIや入力ファイルの設定値を説明している部分
  • EUR サーバ帳票出力（7章のリファレンス部分）
  • EUR Print Manager 帳票出力（8章～15章）
 EUR 帳票出力 リファレンス EUR Server編
次のマニュアルの，機能概要，各APIや入力ファイルの設定値を説明している部分
  • EUR クライアント帳票出力
 EUR 帳票出力 EUR Designer/EUR Viewer編
次のマニュアルの，データベースから抽出したデータを使って帳票を作成および出力する方法を説明している部分
  • EUR 帳票設計
  • EUR クライアント帳票出力
  • EUR サーバ帳票出力
  • EUR メッセージ
 EUR データベース連携ガイド

  • EUR メッセージ
  • EUR Print Manager メッセージ
 EUR メッセージ

  • EUR 概説（付録A）
  • EUR Print Manager 帳票出力（付録H）
 EUR 用語集

EUR ServerのV8互換機能を使用する場合は，バージョン8対応のマニュアル「EUR サーバ帳票出力」を参照してください。Windows環境では，インストール先フォルダ\Print\1041\Help\eurps.chmに統合ヘルプが格納されています。

クライアント帳票出力機能のV8互換機能を使用する場合は，バージョン8対応のマニュアル「EUR クライアント帳票出力」を参照してください。Windows環境では，次のフォルダにヘルプが格納されています。

  • EUR Designerの場合
    EUR Designerのインストール先フォルダ\Designer\1041\Help\euroutp.chm
  • EUR Viewerの場合
    EUR Viewerのインストール先フォルダ\1041\Help\euroutp.chm


このマニュアルでの表記

付録B.4　このマニュアルでの表記

このマニュアルでは，uCosminexus EURの各製品について，次のように表記しています。

表記 |  | 製品名称
EUR Designer |  | uCosminexus EUR Designer
EUR Developer |  | uCosminexus EUR Developer
EUR Viewer |  | uCosminexus EUR Viewer
EUR Server | EUR Server Enterprise | uCosminexus EUR Server Enterprise
 | EUR Server Standard | uCosminexus EUR Server Standard
 | EUR Server Print Edition | uCosminexus EUR Server Print Edition
EUR Server - Cipher option |  | uCosminexus EUR Server - Cipher option
EUR Form | EUR Form Service | uCosminexus EUR Form Service
EUR Form Service - Data Store option |  | uCosminexus EUR Form Service - Data Store option

uCosminexus EUR以外の製品名称などについては，次のように表記しています。

表記 |  | 製品名称
BSP-RM |  | BSP-RM(R)
COBOL |  | COBOL2002
DABroker |  | DABroker 03-17以降 DABroker 03-21以降 DABroker(64) 03-20以降 DABroker(64) 03-21以降
HiRDB |  | HiRDB/Run Time Version 8 08-00 以降 HiRDB/Developer's Kit Version 8 08-00 以降 HiRDB/Run Time Version 8(64) 08-00 以降 HiRDB/Developer's Kit Version 8(64) 08-00 以降 HiRDB/Run Time Version 9 09-00以降 HiRDB/Developer's Kit Version 9 09-00以降 HiRDB/Developer's Suite Version 9 09-00以降 HiRDB/Run Time Version 9(64) 09-00以降 HiRDB/Developer's Kit Version 9(64) 09-00以降 HiRDB Server Version 9 09-00以降 HiRDB Server with Additional Function Version 9 09-00以降
IPF |  | Itanium(R) Processor Family
Linux | Linux(R) | Red Hat Enterprise Linux(R) Server 6 (64-bit x86_64)
Oracle | Oracle 10g | Oracle 10g 10.1.0 Oracle 10g 10.2.0
 | Oracle 11g | Oracle Database 11g 11.1.0 Oracle Database 11g R2 11.2.0
SEWB+ |  | Software Engineering Workbench+
uCosminexus Application Server |  | uCosminexus Application Server Enterprise
 |  | uCosminexus Application Server Standard
UNIX | AIX | AIX V6.1 AIX V7.1
 | HP-UX | HP-UX 11i V3(IPF)

このほか，このマニュアルでは，次に示す表記を使用しています。

  • EURの各製品を区別する必要がない場合は，総称してEURと表記します。
  • EUR Designer，EUR Developerの帳票作成機能を「EUR 帳票作成機能」と表記します。
  • EUR DeveloperのEUR Form帳票作成機能を「EUR 帳票作成機能（EUR Form帳票）」と表記します。
  • EUR Designer，EUR Developer，EUR Viewerのクライアント環境での帳票出力機能を「EUR クライアント帳票出力機能」と表記します。
  • EUR Developer，EUR Server Enterprise，EUR Server Standard，EUR Server Print Editionのサーバ環境での帳票出力機能を「EUR サーバ帳票出力機能」と表記します。


このマニュアルで使用する略語

付録B.5　このマニュアルで使用する略語

このマニュアルで使用する英略語を次に示します。

英略語 | 英字での表記
API | Application Programming Interface
ASP | Active Server Pages
BOM | Byte Order Mark
COBOL | COmmon Business Oriented Language
CPI | Characters Per Inch
CSV | Comma Separated Value
DLL | Dynamic Linking Library
DPI | Dot Per Inch
EAN | European Article Number
EJB | Enterprise JavaBeans
EMF | Enhanced Metafile
EOF | End Of File
EUR | End-User Reporting
GIF | Graphics Interchange Format
GUI | Graphical User Interface
HTTP | Hyper Text Transfer Protocol
ID | IDentifier
ISO | International Organization for Standardization
JAN | Japanese Article Number
JDK | Java Development Kit
JIS | Japanese Industrial Standards
JPEG | Joint Photographic Experts Group
JSP | Java Server Pages
LAN | Local Area Network
LDAP | Lightweight Directory Access Protocol
LIPS | LBP Image Processing System
LPI | Lines Per Inch
MFC | Microsoft Foundation Class
MIME | Multipurpose Internet Mail Extension
MSI | Microsoft Windows Installer
MUI | Multi User Interface
OCR | Optical Character Reader
OCX | OLE Custom Control (OLE Control eXtension)
ODBC | Open Database Connectivity
OLE | Object Linking and Embedding
PCF | Portable Compiled Format
PDF | Portable Document Format
PDL | Page Description Language
PNG | Portable Network Graphics
RPM | RPM Package Manager
SSL | Secure Sockets Layer
TIFF | Tagged Image File Format
TLS | Transport Layer Security
UAP | User Application Program
UPC | Universal Product Code
UTC | Coordinated Universal Time
WAN | Wide Area Network
XML | eXtensible Mark-up Language


KB（キロバイト）などの単位表記について

付録B.6　KB（キロバイト）などの単位表記について

1KB（キロバイト），1MB（メガバイト），1GB（ギガバイト），1TB（テラバイト）はそれぞれ1,024バイト，1,0242バイト，1,0243バイト，1,0244バイトです。


索引

[Ａ][Ｂ][Ｃ][Ｄ][Ｅ][Ｆ][Ｇ][Ｈ][Ｉ][Ｊ][Ｋ][Ｌ][Ｍ][Ｎ][Ｏ][Ｐ][Ｑ][Ｒ][Ｓ][Ｔ][Ｕ][Ｖ][Ｗ][Ｘ][Ｙ][Ｚ]
[ア行][カ行][サ行][タ行][ナ行][ハ行][ヤ行][ラ行]

(英字)

(Ａ)
Acrobat JavaScript定義ファイル
Acrobat JavaScriptファイル
ActiveX起動部品
Err.Descriptionプロパティ
Err.Numberプロパティ
実行時のエラー情報一覧
提供するクラス
ファイル名
プログラムIDとコントロール名
ActiveX起動部品が提供するプロパティ一覧〔出力メソッド〕
ActiveX起動部品が提供するプロパティ一覧〔情報取得メソッド〕
ActiveX起動部品が提供するメソッド一覧
ActiveX起動部品の構文
ActiveX起動部品を構築する場合
EURPMADPLib.EURPMAdapterクラスを生成する場合
ActiveX部品
ADDRDEFFILENAME〔EUR Server - Spool Serviceの環境設定ファイル〕
APSAUTO〔EUR Server - Spool Serviceの環境設定ファイル〕
AUTHENTICATION〔EUR Server - Spool Service Adapterの環境設定ファイル〕
AUTHENTICATION〔EUR Server - Spool Serviceの環境設定ファイル〕
AUTHOR〔文書情報設定ファイルのキーワード〕
(Ｂ)
BindingAdjust〔プリンタ定義ファイルのキーワード〕
BOOKMARK〔文書しおり定義ファイルのキーワード〕
BOOKMARKFILE〔OutputPDFReport関数（COBOL起動部品）〕
BookmarkFileNameプロパティ〔ActiveX起動部品〕
BOOKMARKFILEPATH〔OutputPDFReport関数（COBOL起動部品）〕
BookmarkFilePathプロパティ〔ActiveX起動部品〕
BREAKFLD〔しおり定義ファイルのキーワード〕
BSP-RM連携コマンド
エラー情報
ファイル名
BSP-RM連携コマンドの構文
BSP-RM連携コマンドの終了コード
(Ｃ)
Cassettes〔プリンタ定義ファイルのキーワード〕
CHANGEAUDITLOG〔EUR Server - Spool Service Adapterの環境設定ファイル〕
ChangeAuditLogメソッド〔SS-ActiveX起動部品〕
changeAuditLogメソッド〔SS-Java起動部品〕
CHECKSTRING〔EUR Server - Spool Service Adapterの環境設定ファイル〕
CLASSES〔GetPrinterClassList2関数（COBOL起動部品）〕
CLASSES〔GetPrinterClassList関数（COBOL起動部品）〕
CLASSNUM〔GetPMPrinterClassList関数（COBOL起動部品）〕
CLASSNUM〔GetPrinterClassList2関数（COBOL起動部品）〕
CLASSNUM〔GetPrinterClassList関数（COBOL起動部品）〕
CLIENTADDR〔PrintReport2関数（COBOL起動部品）〕
CLIENTADDR〔PrintReport関数（COBOL起動部品）〕
ClientAddressプロパティ〔ActiveX起動部品〕
ClientAddressプロパティ〔SS-ActiveX起動部品〕
CLIENTPRINTERNAME〔PrintReport2関数（COBOL起動部品）〕
CLIENTPRINTERNAME〔PrintReport関数（COBOL起動部品）〕
ClientPrinterNameプロパティ〔ActiveX起動部品〕
ClientPrinterNameプロパティ〔SS-ActiveX起動部品〕
CLIENTTRAYNAME〔PrintReport2関数（COBOL起動部品）〕
CLIENTTRAYNAME〔PrintReport関数（COBOL起動部品）〕
ClientTrayNameプロパティ〔ActiveX起動部品〕
ClientTrayNameプロパティ〔SS-ActiveX起動部品〕
COBOL起動部品
エラー情報一覧
実行時のエラー情報の一覧
提供する関数
ファイル構成
呼び出し規約
CODE128PARAM〔プリンタ定義ファイルのキーワード〕
CODE128PATTERN〔プリンタ定義ファイルのキーワード〕
CODE39PARAM〔プリンタ定義ファイルのキーワード〕
Color〔プリンタ定義ファイルのキーワード〕
Command〔プリンタ定義ファイルのキーワード〕
CONF〔EUR Client Serviceの環境設定ファイル〕
CONF〔EUR Server - Spool Serviceの環境設定ファイル〕
CONF〔EUR Server Serviceの環境設定ファイル〕
CONF〔ファイル監視サービスの環境設定ファイル〕
CONNECT〔EUR Client Serviceの環境設定ファイル〕
CONNECT〔EUR Server - Spool Serviceの環境設定ファイル〕
CONNECT〔EUR Server Serviceの環境設定ファイル〕
CreateIPAddressプロパティ〔SS-ActiveX起動部品〕
CreateLSVersionプロパティ〔SS-ActiveX起動部品〕
CreateTimeプロパティ〔SS-ActiveX起動部品〕
CRYPTO〔OutputPDFReport関数（COBOL起動部品）〕
CRYPTOFILENAME〔OutputPDFReport関数（COBOL起動部品）〕
CryptoFileNameプロパティ〔ActiveX起動部品〕
CRYPTOFILEPATH〔OutputPDFReport関数（COBOL起動部品）〕
CryptoFilePathプロパティ〔ActiveX起動部品〕
Cryptoプロパティ〔ActiveX起動部品〕
CurrentPageプロパティ〔EUR Web Plug-In〕
(Ｄ)
DATABUFFSIZE〔EUR Server - Adapterの環境設定ファイル〕
DataFileNameプロパティ〔ActiveX起動部品〕
DataFilePathプロパティ〔ActiveX起動部品〕
DATALIMIT〔ファイル監視サービスの環境設定ファイル〕
DATA行〔PDF形式ファイルを暗号化仕分け出力する場合のPDF仕分け定義ファイル〕
DATA行〔PDF形式ファイルを仕分け出力する場合のPDF仕分け定義ファイル〕
DBINFO〔EUR Server Serviceの環境設定ファイル〕
DBINFOFILENAME〔OutputEPFReport関数（COBOL起動部品）〕
DBINFOFILENAME〔OutputEURReport関数（COBOL起動部品）〕
DBINFOFILENAME〔OutputPDFReport関数（COBOL起動部品）〕
DBINFOFILENAME〔OutputXLSXReport関数（COBOL起動部品）〕
DBINFOFILENAME〔PrintReport2関数（COBOL起動部品）〕
DBINFOFILENAME〔PrintReport関数（COBOL起動部品）〕
DBInfoFileNameプロパティ〔ActiveX起動部品〕
DBINFOFILEPATH〔OutputEPFReport関数（COBOL起動部品）〕
DBINFOFILEPATH〔OutputEURReport関数（COBOL起動部品）〕
DBINFOFILEPATH〔OutputPDFReport関数（COBOL起動部品）〕
DBINFOFILEPATH〔OutputXLSXReport関数（COBOL起動部品）〕
DBINFOFILEPATH〔PrintReport2関数（COBOL起動部品）〕
DBINFOFILEPATH〔PrintReport関数（COBOL起動部品）〕
DBInfoFilePathプロパティ〔ActiveX起動部品〕
DBZEROEXITCODE〔EUR Server - Adapterの環境設定ファイル〕
DefaultCassette〔プリンタ定義ファイルのキーワード〕
DEFAULTPRINTDLG〔帳票管理GUIの環境設定ファイル〕
DefaultPrintDlgパラメタ〔EUR Web Plug-In〕
DEFAULTPRINTMODE〔EUR Server - Adapterの環境設定ファイル〕
DELETE〔EUR Server - Spool Service Adapterの環境設定ファイル〕
DeleteKindプロパティ〔SS-ActiveX起動部品〕
DeleteSpoolFileメソッド〔SS-ActiveX起動部品〕
deleteSpoolFileメソッド〔SS-Java起動部品〕
DELISERVICE〔EUR Client Serviceの環境設定ファイル〕
DestinationNameプロパティ〔ActiveX起動部品〕
DESTLIST〔EUR Server - Adapterの環境設定ファイル〕
DESTNAME〔GetPrinterClassList2関数（COBOL起動部品）〕
DESTNAME〔GetPrinterClassList関数（COBOL起動部品）〕
DESTNAME〔GetPrinterList関数（COBOL起動部品）〕
DESTNAME〔GetTrayList関数（COBOL起動部品）〕
DESTNAME〔PrintReport2関数（COBOL起動部品）〕
DESTNAME〔PrintReport関数（COBOL起動部品）〕
DESTNUM〔GetDestinationList2関数（COBOL起動部品）〕
DESTNUM〔GetDestinationList関数（COBOL起動部品）〕
DESTS〔GetDestinationList2関数（COBOL起動部品）〕
DESTS〔GetDestinationList関数（COBOL起動部品）〕
DisableAdd〔暗号化設定ファイルのキーワード〕
DisableChange〔暗号化設定ファイルのキーワード〕
DisableCopy〔暗号化設定ファイルのキーワード〕
DisablePrint〔暗号化設定ファイルのキーワード〕
DISPPRINTDLG〔EUR Server - Adapterの環境設定ファイル〕
DISPPRINTDLG〔PrintReport2関数（COBOL起動部品）〕
DISPPRINTDLG〔PrintReport関数（COBOL起動部品）〕
DispPrintDlgプロパティ〔ActiveX起動部品〕
DispPrintDlgプロパティ〔SS-ActiveX起動部品〕
DISTRIBUTEFILENAME〔OutputPDFReport関数（COBOL起動部品）〕
DistributeFileNameプロパティ〔ActiveX起動部品〕
DISTRIBUTEFILEPATH〔OutputPDFReport関数（COBOL起動部品）〕
DistributeFilePathプロパティ〔ActiveX起動部品〕
DIVDATA〔BSP-RM連携コマンドの環境設定ファイル〕
DOCBOOKMARKFILE〔OutputPDFReport関数（COBOL起動部品）〕
DocBookmarkFileNameプロパティ〔ActiveX起動部品〕
DOCINFO〔EUR Server Serviceの環境設定ファイル〕
DOCINFOFILE〔OutputEPFReport関数（COBOL起動部品）〕
DOCINFOFILE〔OutputEURReport関数（COBOL起動部品）〕
DOCINFOFILE〔OutputPDFReport関数（COBOL起動部品）〕
DOCINFOFILE〔PrintReport2関数（COBOL起動部品）〕
DOCINFOFILE〔PrintReport関数（COBOL起動部品）〕
DocInfoFileNameプロパティ〔ActiveX起動部品〕
DOCINFOFILEPATH〔OutputEPFReport関数（COBOL起動部品）〕
DOCINFOFILEPATH〔OutputEURReport関数（COBOL起動部品）〕
DOCINFOFILEPATH〔OutputPDFReport関数（COBOL起動部品）〕
DOCINFOFILEPATH〔PrintReport2関数（COBOL起動部品）〕
DOCINFOFILEPATH〔PrintReport関数（COBOL起動部品）〕
DocInfoFilePathプロパティ〔ActiveX起動部品〕
Duplex〔プリンタ定義ファイルのキーワード〕
DuplexBinding〔プリンタ定義ファイルのキーワード〕
(Ｅ)
EmbedCount〔プリンタ定義ファイルのキーワード〕
EmbedN〔プリンタ定義ファイルのキーワード〕
ENABLEGET〔PrintReport2関数（COBOL起動部品）〕
ENABLEGET〔PrintReport関数（COBOL起動部品）〕
EnableGetプロパティ〔ActiveX起動部品〕
EnableGetプロパティ〔SS-ActiveX起動部品〕
EncryptionMode〔暗号化設定ファイルのキーワード〕
ENCRYPTIONPASSWORDKEY〔OutputPDFReport関数（COBOL起動部品）〕
EncryptionPasswordKeyプロパティ〔ActiveX起動部品〕
ENCRYPTPASSWORD〔EUR Server - Spool Serviceの環境設定ファイル〕
EPFDATAMAXSIZE〔帳票管理GUIの環境設定ファイル〕
EPFDataMaxSizeパラメタ〔EUR Web Plug-In〕
EPFFILENAME〔OutputEPFReport関数（COBOL起動部品）〕
EPFFILENAME〔OutputMergeEPFReport関数（COBOL起動部品）〕
EPFFILENAME〔PrintReport2関数（COBOL起動部品）〕
EPFFILENAME〔PrintReport関数（COBOL起動部品）〕
EPFFileNameプロパティ〔ActiveX起動部品〕
EPFFILEPATH〔OutputEPFReport関数（COBOL起動部品）〕
EPFFILEPATH〔OutputMergeEPFReport関数（COBOL起動部品）〕
EPFFILEPATH〔PrintReport2関数（COBOL起動部品）〕
EPFFILEPATH〔PrintReport関数（COBOL起動部品）〕
EPFFilePathプロパティ〔ActiveX起動部品〕
EPFFILES〔OutputMergeEPFReport関数（COBOL起動部品）〕
EPFFILESSIZE〔OutputMergeEPFReport関数（COBOL起動部品）〕
EPFFileURLパラメタ〔EUR Web Plug-In〕
EPFOUTPUT〔EUR Server - Adapterの環境設定ファイル〕
EPFTempDataModeパラメタ〔EUR Web Plug-In〕
ERRIGNORE〔EUR Client Serviceの環境設定ファイル〕
ERRIGNORE〔EUR Server - Spool Serviceの環境設定ファイル〕
ERRIGNORE〔EUR Server Serviceの環境設定ファイル〕
ERRORLIMIT〔EUR Server - Spool Serviceの環境設定ファイル〕
ERRORREMAIN〔BSP-RM連携コマンドの環境設定ファイル〕
ESC/P対応プリンタ出力用の環境変数
ESF〔EUR Server - Spool Serviceの環境設定ファイル〕
ESFAUTODEL〔EUR Server - Spool Serviceの環境設定ファイル〕
ESFID〔EUR Server - Spool Serviceの環境設定ファイル〕
EURFILENAME〔OutputEURReport関数（COBOL起動部品）〕
EURFileNameプロパティ〔ActiveX起動部品〕
EURFILEPATH〔OutputEURReport関数（COBOL起動部品）〕
EURFilePathプロパティ〔ActiveX起動部品〕
eurfm.ini〔ファイル監視サービスの環境設定ファイル〕
eurivk.ini〔ジョブ実行プログラムの環境設定ファイル〕
EUROUTPUT〔EUR Server - Adapterの環境設定ファイル〕
EURPM.Exec
EURPM.ini〔EUR Server Serviceの環境設定ファイル〕
EURPM（PORTセクション）〔EUR Server Serviceの環境設定ファイル〕
EURPM〔EUR Server - Adapterの環境設定ファイル〕 ,[2]
EURPMAdapterForJavaクラス
コンストラクタ
メソッド一覧
EURPMADP.ini〔EUR Server - Adapterの環境設定ファイル〕
EURPMADP.ocx
eurpmc
EURPMC.exe
EURPMCEPFViewer.exe
eurpmcepfviewerコマンド
エラー情報
ファイル名
eurpmcepfviewerコマンドのオプション一覧
eurpmcepfviewerコマンドの構文
帳票を自動印刷する場合
帳票をプレビュー表示する場合
EURPMCL.ini〔EUR Client Serviceの環境設定ファイル〕
EURPMCL〔EUR Client Serviceの環境設定ファイル〕
EURPMCL〔EUR Server - Spool Serviceの環境設定ファイル〕
EURPMCL〔EUR Server Serviceの環境設定ファイル〕
EURPMCTRL.ini〔Server Service制御コマンドの環境設定ファイル〕
eurpmcコマンド
エラー情報
オプションを指定するときの注意
ファイル名
eurpmcコマンドが提供するオプション
eurpmcコマンドの構文
EPF形式ファイルを出力する場合
EUR形式ファイルを出力する場合
Excel形式ファイルを出力する場合
PDF形式ファイルを出力する場合
出力先一覧を取得する場合
スプールデータを出力する場合
帳票サーバプリンタ一覧を取得する場合
帳票サーバプリンタクラス一覧を取得する場合
帳票サーバプリンタのトレイ一覧を取得する場合
トレイ一覧を取得する場合
複数のEPF形式ファイルを統合して出力する場合
プリンタ一覧を取得する場合
プリンタクラス一覧を取得する場合
プリンタに出力する場合
eurpmcコマンドの終了コード
EURPMExceptionクラス
メソッド一覧
EURPMLS.Exec
EURPMLS.ini〔EUR Server - Spool Serviceの環境設定ファイル〕
EURPMLS〔EUR Server - Spool Service Adapterの環境設定ファイル〕 ,[2]
EURPMLS〔EUR Server - Spool Serviceの環境設定ファイル〕
EURPMLS〔EUR Server Serviceの環境設定ファイル〕
EURPMLSAdapterForJavaクラス
コンストラクタ
メソッド一覧
EURPMLSADP.ini〔EUR Server - Spool Service Adapterの環境設定ファイル〕
EURPMLSADP.ocx
eurpmlsc
EURPMLSC.exe
EURPMLSCTRL.ini〔Spool Service制御コマンドの環境設定ファイル〕
eurpmlscコマンド
エラー情報
オプションを指定するときの注意
ファイル名
eurpmlscコマンドが提供するオプション
eurpmlscコマンドの構文
監査ログを切り替える場合
スプールデータの一覧を取得する場合
スプールデータの属性値を取得する場合
スプールデータの属性値を変更する場合
スプールデータを削除する場合
スプールデータを取得する場合
スプールデータを蓄積データ印刷する場合
トレイ一覧を取得する場合
プリンタ一覧を取得する場合
プリンタクラス一覧を取得する場合
eurpmlscコマンドの終了コード
EURPMLSExceptionクラス
メソッド一覧
EURPMPreViewAX9.ocx
EURPMPrintAX9.ocx
EURPMRSGUI.ini〔帳票管理GUIの環境設定ファイル〕
EURPS_CODE128_PARAM〔環境設定ファイルの環境変数〕
EURPS_CODE39_PARAM〔環境設定ファイルの環境変数〕
EURPS_CSV_PRINT_PERIOD〔環境設定ファイルの環境変数〕
EURPS_DONT_PRINT_IF_DB_RESULT_EMPTY〔環境設定ファイルの環境変数〕
EURPS_EPF_IMAGE_COMPRESS〔環境設定ファイルの環境変数〕
EURPS_EPFDPI〔環境設定ファイルの環境変数〕
EURPS_EXCEL_REPEAT_MODE〔環境設定ファイルの環境変数〕
EURPS_EXCELLOGFILELEVEL〔環境設定ファイルの環境変数〕
EURPS_EXCELTMPPATH〔環境設定ファイルの環境変数〕
EURPS_FIXOPT〔環境設定ファイルの環境変数〕
EURPS_FONT_ROUNDDOWN〔環境設定ファイルの環境変数〕
EURPS_FONT_WIDTH_MODE〔環境設定ファイルの環境変数〕
EURPS_GAIJIFONT〔AIX環境の場合〕
EURPS_GAIJIFONT〔HP-UX環境の場合〕
EURPS_GAIJIFONT〔Windows環境の場合〕
EURPS_GAIJIFONT〔環境設定ファイルの環境変数〕
EURPS_IMAGEPATH〔環境設定ファイルの環境変数〕
EURPS_J84GA16〔環境設定ファイルの環境変数〕
EURPS_J84GA24〔環境設定ファイルの環境変数〕
EURPS_J84GA48〔環境設定ファイルの環境変数〕
EURPS_J84GA72〔環境設定ファイルの環境変数〕
EURPS_J84GA96〔環境設定ファイルの環境変数〕
EURPS_J84GK16〔環境設定ファイルの環境変数〕
EURPS_J84GK24〔環境設定ファイルの環境変数〕
EURPS_J84GK48〔環境設定ファイルの環境変数〕
EURPS_J84GK72〔環境設定ファイルの環境変数〕
EURPS_J84GK96〔環境設定ファイルの環境変数〕
EURPS_J84MA16〔環境設定ファイルの環境変数〕
EURPS_J84MA24〔環境設定ファイルの環境変数〕
EURPS_J84MA48〔環境設定ファイルの環境変数〕
EURPS_J84MA72〔環境設定ファイルの環境変数〕
EURPS_J84MA96〔環境設定ファイルの環境変数〕
EURPS_J84MK16〔環境設定ファイルの環境変数〕
EURPS_J84MK24〔環境設定ファイルの環境変数〕
EURPS_J84MK48〔環境設定ファイルの環境変数〕
EURPS_J84MK72〔環境設定ファイルの環境変数〕
EURPS_J84MK96〔環境設定ファイルの環境変数〕
EURPS_LOGFILELEVEL〔環境設定ファイルの環境変数〕
EURPS_LOGFILEPATH〔環境設定ファイルの環境変数〕
EURPS_LOGSIZE〔環境設定ファイルの環境変数〕
EURPS_MAX_SPOOL_PAGES〔環境設定ファイルの環境変数〕
EURPS_NOSKIP_OUTPUTSPACE〔環境設定ファイルの環境変数〕
EURPS_OUTPUTPATH〔環境設定ファイルの環境変数〕
EURPS_OUTPUTPDF_VER〔環境設定ファイルの環境変数〕
EURPS_PDF_BUFSIZE〔環境設定ファイルの環境変数〕
EURPS_PDF_IMAGE_OPTIMIZEMEM〔環境設定ファイルの環境変数〕
EURPS_PDF_IMAGEDRAWUNIT〔環境設定ファイルの環境変数〕
EURPS_PDF_OUTPUT〔環境設定ファイルの環境変数〕
EURPS_PDF_SAMEIMAGE〔環境設定ファイルの環境変数〕
EURPS_PDL_EXGOTFONTPATH〔環境設定ファイルの環境変数〕
EURPS_PDL_EXMINFONTPATH〔環境設定ファイルの環境変数〕
EURPS_PRINT〔環境設定ファイルの環境変数〕
EURPS_PRINTERINFPATH〔環境設定ファイルの環境変数〕
EURPS_QR_CELL_SIZE_D〔環境設定ファイルの環境変数〕
EURPS_QR_CELL_SIZE_M〔環境設定ファイルの環境変数〕
EURPS_QR_CORRECTION_LEVEL〔環境設定ファイルの環境変数〕
EURPS_QR_VERSION〔環境設定ファイルの環境変数〕
EURPS_REPLACEITEMPATH〔環境設定ファイルの環境変数〕
EURPS_REPORT_LOGERROR〔環境設定ファイルの環境変数〕
EURPS_REPORT_WARNING〔環境設定ファイルの環境変数〕
EURPS_SCRIPTFILEPATH〔環境設定ファイルの環境変数〕
EURPS_SKIP_OUTPUTSPACE〔環境設定ファイルの環境変数〕
EURPS_TESTPRINTFILE〔環境設定ファイルの環境変数〕
EURPS_TMPPATH〔環境設定ファイルの環境変数〕
EURPS_TRACE〔環境設定ファイルの環境変数〕
EURPS_TRACE_DRAWAPI〔環境設定ファイルの環境変数〕
EURPS_UPC_BARCODE〔環境設定ファイルの環境変数〕
EURPS_USE_05_06_FONT_LANG〔環境設定ファイルの環境変数〕
EURPS_USE_05_06_FONT_REPLACE〔環境設定ファイルの環境変数〕
EURPS〔EUR Server - Spool Serviceの環境設定ファイル〕
EURPS〔EUR Server Serviceの環境設定ファイル〕
eursmpr.exe
eursmpr.ini〔BSP-RM連携コマンドの環境設定ファイル〕
EURSMPR_DATAPATH〔BSP-RM連携コマンドの環境変数〕
EURSMPR_OUTPUTPATH〔BSP-RM連携コマンドの環境変数〕
EURSMPR_PARAMPATH〔BSP-RM連携コマンドの環境変数〕
EURSMPR_REMAINFLAG〔BSP-RM連携コマンドの環境変数〕
EUR Web Plug-In
タグの記述例
ファイル名
EUR Web Plug-In（印刷用）
クラスID〔MSIインストーラによるインストールの場合〕
クラスID〔クライアントインストールの場合〕
クラスID〔ダウンロードパッケージでのインストールの場合〕
EUR Web Plug-In（プレビュー用）
クラスID〔MSIインストーラによるインストールの場合〕
クラスID〔クライアントインストールの場合〕
クラスID〔ダウンロードパッケージでのインストールの場合〕
EUR Web Plug-In情報ファイル
EUR Web Plug-In情報ファイルの形式
EUR Web Plug-Inのイベント一覧
EUR Web Plug-Inのパラメタ一覧
EUR Web Plug-Inのプロパティ一覧
EUR Web Plug-Inのメソッド一覧
EUR形式ファイルに出力する場合の環境変数
EUR サーバ帳票出力機能で扱えるデータファイル
EURフォントファイル
EVENTLOGLEVEL〔EUR Client Serviceの環境設定ファイル〕
Excel形式ファイルに出力する場合の環境変数
ExclusionPrinterDriverプロパティ〔EUR Web Plug-In〕
ExclusionPrinterNameプロパティ〔EUR Web Plug-In〕
ExecPrintCountプロパティ〔SS-ActiveX起動部品〕
EXECUTABLEPRINTMODE〔PrintReport2関数（COBOL起動部品）〕
EXECUTABLEPRINTMODE〔PrintReport関数（COBOL起動部品）〕
ExecutablePrintModeプロパティ〔ActiveX起動部品〕
ExecutablePrintModeプロパティ〔SS-ActiveX起動部品〕
(Ｆ)
fieldname〔複数様式情報定義ファイルのキーワード（formtransfercondition）〕
fieldname〔複数様式情報定義ファイルのキーワード（grouptransfercondition）〕
FILELIST〔EUR Server - Spool Service Adapterの環境設定ファイル〕
FILEOPERATE〔EUR Server - Spool Service Adapterの環境設定ファイル〕
FILEOUTPUTDESTINATION〔EUR Server - Adapterの環境設定ファイル〕
FILEOUTPUTDESTINATION〔OutputPDFReport関数（COBOL起動部品）〕
FileOutputDestinationプロパティ〔ActiveX起動部品〕
FindNextメソッド〔EUR Web Plug-In〕
Findメソッド〔EUR Web Plug-In〕
FIRSTDELIVERY〔EUR Client Serviceの環境設定ファイル〕
FIRSTPAGENUMBER〔OutputEPFReport関数（COBOL起動部品）〕
FIRSTPAGENUMBER〔OutputPDFReport関数（COBOL起動部品）〕
FIRSTPAGENUMBER〔PrintReport2関数（COBOL起動部品）〕
FIRSTPAGENUMBER〔PrintReport関数（COBOL起動部品）〕
FirstPageNumberプロパティ〔ActiveX起動部品〕
FMC〔ファイル監視サービスの環境設定ファイル〕
Font〔プリンタ定義ファイルのキーワード〕
FORM〔EUR Server Serviceの環境設定ファイル〕
formfilename〔複数様式情報定義ファイルのキーワード〕
formfilenameの形式〔複数様式情報定義ファイル〕
formtransfercondition〔複数様式情報定義ファイルのキーワード〕
formtransferconditionの形式〔複数様式情報定義ファイル〕
(Ｇ)
GENERAL〔EUR Server - Spool Serviceの環境設定ファイル〕
GENERAL〔EUR Server Serviceの環境設定ファイル〕
GENERAL〔ファイル監視サービスの環境設定ファイル〕
GenTextMode〔プリンタ定義ファイルのキーワード〕
getClientAddressメソッド〔SS-Java起動部品〕
getClientPrinterNameメソッド〔SS-Java起動部品〕
getClientTrayNameメソッド〔SS-Java起動部品〕
getCreateIPAddressメソッド〔SS-Java起動部品〕
getCreateLSVersionメソッド〔SS-Java起動部品〕
getCreateTimeMultiメソッド〔SS-Java起動部品〕
getCreateTimeメソッド〔SS-Java起動部品〕
GetDestinationList2関数〔COBOL起動部品〕
GetDestinationList関数〔COBOL起動部品〕
GetDestinationListメソッド〔ActiveX起動部品〕
getDestinationListメソッド〔Java起動部品〕
getDispPrintDlgメソッド〔SS-Java起動部品〕
getEnableGetメソッド〔SS-Java起動部品〕
getEPFReportメソッド〔Java起動部品〕
getErrorCodeメソッド〔Java起動部品〕
getErrorCodeメソッド〔SS-Java起動部品〕
getErrorLevelメソッド〔Java起動部品〕
getErrorLevelメソッド〔SS-Java起動部品〕
getEURReportメソッド〔Java起動部品〕
getExecPrintCountメソッド〔SS-Java起動部品〕
getExecutablePrintModeメソッド〔SS-Java起動部品〕
GETFILE〔EUR Server - Spool Service Adapterの環境設定ファイル〕
getGroupNameメソッド〔SS-Java起動部品〕
GetJobIDListメソッド〔ActiveX起動部品〕
getJobIDListメソッド〔Java起動部品〕
GetJobIDメソッド〔ActiveX起動部品〕
getJobIDメソッド〔Java起動部品〕
getJobIDメソッド〔SS-Java起動部品〕
getJobKeyCategoryメソッド〔SS-Java起動部品〕
getJobKeyDataメソッド〔SS-Java起動部品〕
getKeyメソッド〔Java起動部品〕
getKeyメソッド〔SS-Java起動部品〕
getMaxPrintCountメソッド〔SS-Java起動部品〕
getMergeEPFReportメソッド 〔Java起動部品〕
getMessageメソッド〔Java起動部品〕
getMessageメソッド〔SS-Java起動部品〕
getOutputDataメソッド〔Java起動部品〕
getOutputDataメソッド〔SS-Java起動部品〕
getPageNumMultiメソッド〔SS-Java起動部品〕
getPageNumメソッド〔SS-Java起動部品〕
getPDFReportメソッド〔Java起動部品〕
GetPMPrinterClassList関数〔COBOL起動部品〕
GetPMPrinterClassListメソッド〔ActiveX起動部品〕
getPMPrinterClassListメソッド〔Java起動部品〕
GetPMPrinterList関数〔COBOL起動部品〕
GetPMPrinterListメソッド〔ActiveX起動部品〕
getPMPrinterListメソッド〔Java起動部品〕
GetPMTrayList関数〔COBOL起動部品〕
GetPMTrayListメソッド〔ActiveX起動部品〕
getPMTrayListメソッド〔Java起動部品〕
GetPreviewAXClassIDメソッド〔ActiveX起動部品〕
getPreviewAXClassIDメソッド〔Java起動部品〕
GetPreviewAXVersionメソッド〔ActiveX起動部品〕
getPreviewAXVersionメソッド〔Java起動部品〕
GetPrintAXClassIDメソッド〔ActiveX起動部品〕
getPrintAXClassIDメソッド〔Java起動部品〕
GetPrintAXVersionメソッド〔ActiveX起動部品〕
getPrintAXVersionメソッド〔Java起動部品〕
GetPrinterClassList2関数〔COBOL起動部品〕
GetPrinterClassList関数〔COBOL起動部品〕
GetPrinterClassListメソッド〔ActiveX起動部品〕
getPrinterClassListメソッド〔Java起動部品〕
GetPrinterClassListメソッド〔SS-ActiveX起動部品〕
getPrinterClassListメソッド〔SS-Java起動部品〕
getPrinterClassNameMultiメソッド〔SS-Java起動部品〕
getPrinterClassNameメソッド〔SS-Java起動部品〕
GetPrinterList関数〔COBOL起動部品〕
GetPrinterListメソッド〔ActiveX起動部品〕
getPrinterListメソッド〔Java起動部品〕
GetPrinterListメソッド〔SS-ActiveX起動部品〕
getPrinterListメソッド〔SS-Java起動部品〕
getPrinterSelectModeメソッド〔SS-Java起動部品〕
getPrintResultMultiメソッド〔SS-Java起動部品〕
getPrintResultメソッド〔SS-Java起動部品〕
getPrintTimeメソッド〔SS-Java起動部品〕
getReportAddressKeyCategoryメソッド〔SS-Java起動部品〕
getReportAddressKeyDataメソッド〔SS-Java起動部品〕
getServerPrinterNameメソッド〔SS-Java起動部品〕
getServerTrayNameメソッド〔SS-Java起動部品〕
GetSpoolFileAttributeメソッド〔SS-ActiveX起動部品〕
getSpoolFileAttributeメソッド〔SS-Java起動部品〕
getSpoolFileNameMultiメソッド〔SS-Java起動部品〕
getSpoolFileNameメソッド〔SS-Java起動部品〕
GetSpoolFileOutlineメソッド〔SS-ActiveX起動部品〕
getSpoolFileOutlineメソッド〔SS-Java起動部品〕
getSpoolFileSizeメソッド〔SS-Java起動部品〕
GetSpoolFileメソッド〔SS-ActiveX起動部品〕
getSpoolFileメソッド〔SS-Java起動部品〕
getSpoolHistoryメソッド〔SS-Java起動部品〕
getSpoolLimitメソッド〔SS-Java起動部品〕
getSpoolPathMultiメソッド〔SS-Java起動部品〕
getSpoolPathメソッド〔SS-Java起動部品〕
GetTrayList関数〔COBOL起動部品〕
GetTrayListメソッド〔ActiveX起動部品〕
getTrayListメソッド〔Java起動部品〕
GetTrayListメソッド〔SS-ActiveX起動部品〕
getTrayListメソッド〔SS-Java起動部品〕
getXLSXReportメソッド〔Java起動部品〕
group〔複数様式情報定義ファイルのキーワード〕
GROUPNAME〔PrintReport2関数（COBOL起動部品）〕
GROUPNAME〔PrintReport関数（COBOL起動部品）〕
GroupNameプロパティ〔ActiveX起動部品〕
GroupNameプロパティ〔SS-ActiveX起動部品〕
grouptransfercondition〔複数様式情報定義ファイルのキーワード〕
grouptransferconditionの形式〔複数様式情報定義ファイル〕
groupの形式〔複数様式情報定義ファイル〕
(Ｈ)
HScrollメソッド〔EUR Web Plug-In〕
HTTPDATARECEIVE〔EUR Client Serviceの環境設定ファイル〕
(Ｉ)
Initializeメソッド〔SS-ActiveX起動部品〕
initializeメソッド〔SS-Java起動部品〕
INITPAGENUMBER〔OutputEPFReport関数（COBOL起動部品）〕
INITPAGENUMBER〔OutputPDFReport関数（COBOL起動部品）〕
INITPAGENUMBER〔PrintReport2関数（COBOL起動部品）〕
INITPAGENUMBER〔PrintReport関数（COBOL起動部品）〕
InitPageNumberプロパティ〔ActiveX起動部品〕
INTERVAL〔EUR Server - Spool Serviceの環境設定ファイル〕
INTERVAL〔ファイル監視サービスの環境設定ファイル〕
(Ｊ)
Java起動部品
EURPMAdapterForJavaクラス
EURPMExceptionクラス
JDKバージョン
実行時の例外情報一覧
パッケージ
ファイル名
JOBIDNUM〔PrintReport2関数（COBOL起動部品）〕
JOBIDS〔PrintReport2関数（COBOL起動部品）〕
JobIDプロパティ〔SS-ActiveX起動部品〕
JOBKEYCATEGORY〔PrintReport2関数（COBOL起動部品）〕
JOBKEYCATEGORY〔PrintReport関数（COBOL起動部品）〕
JOBKEYCATEGORY2〔PrintReport2関数（COBOL起動部品）〕
JOBKEYCATEGORY2〔PrintReport関数（COBOL起動部品）〕
JobKeyCategoryプロパティ〔ActiveX起動部品〕
JobKeyCategoryプロパティ〔SS-ActiveX起動部品〕
JOBKEYDATA〔PrintReport2関数（COBOL起動部品）〕
JOBKEYDATA〔PrintReport関数（COBOL起動部品）〕
JOBKEYDATA2〔PrintReport2関数（COBOL起動部品）〕
JOBKEYDATA2〔PrintReport関数（COBOL起動部品）〕
JobKeyDataプロパティ〔ActiveX起動部品〕
JobKeyDataプロパティ〔SS-ActiveX起動部品〕
(Ｋ)
keybreaktopform〔複数様式情報定義ファイルのキーワード〕
KEYFIELD行〔PDF形式ファイルを暗号化仕分け出力する場合のPDF仕分け定義ファイル〕
KEYFIELD行〔PDF形式ファイルを仕分け出力する場合のPDF仕分け定義ファイル〕
KEYWORD〔文書情報設定ファイルのキーワード〕
(Ｌ)
LDAPBASEDN〔EUR Server - Spool Serviceの環境設定ファイル〕
LDAPBINDDN〔EUR Server - Spool Serviceの環境設定ファイル〕
LDAPCONNECT〔EUR Server - Spool Serviceの環境設定ファイル〕
LDAPPASSWORD〔EUR Server - Spool Serviceの環境設定ファイル〕
LDAPPASSWORDEMPTYCHECK〔EUR Server - Spool Serviceの環境設定ファイル〕
LDAPSERVER〔EUR Server - Spool Serviceの環境設定ファイル〕
LDAPTLS〔EUR Server - Spool Serviceの環境設定ファイル〕
LDAPUIDATTR〔EUR Server - Spool Serviceの環境設定ファイル〕
LDAP接続情報暗号化ツール（eurssecdコマンド）
ファイル名
LDAP接続情報暗号化ツール（eurssecdコマンド）のコマンドの構文
LOGFILE〔BSP-RM連携コマンドの環境設定ファイル〕
LOGFILE〔EUR Client Serviceの環境設定ファイル〕
LOGFILE〔EUR Server - Adapterの環境設定ファイル〕
LOGFILE〔EUR Server - Spool Service Adapterの環境設定ファイル〕
LOGFILE〔EUR Server - Spool Serviceの環境設定ファイル〕
LOGFILE〔EUR Server Serviceの環境設定ファイル〕
LOGFILE〔Server Service制御コマンドの環境設定ファイル〕
LOGFILE〔Spool Service制御コマンドの環境設定ファイル〕
LOGFILE〔ジョブ実行プログラムの環境設定ファイル〕
LOGFILE〔ファイル監視サービスの環境設定ファイル〕
LogFileパラメタ〔EUR Web Plug-In〕
LOGLEVEL〔BSP-RM連携コマンドの環境設定ファイル〕
LOGLEVEL〔EUR Client Serviceの環境設定ファイル〕
LOGLEVEL〔EUR Server - Adapterの環境設定ファイル〕
LOGLEVEL〔EUR Server - Spool Service Adapterの環境設定ファイル〕
LOGLEVEL〔EUR Server - Spool Serviceの環境設定ファイル〕
LOGLEVEL〔EUR Server Serviceの環境設定ファイル〕
LOGLEVEL〔Server Service制御コマンドの環境設定ファイル〕
LOGLEVEL〔Spool Service制御コマンドの環境設定ファイル〕
LOGLEVEL〔ジョブ実行プログラムの環境設定ファイル〕
LOGLEVEL〔ファイル監視サービスの環境設定ファイル〕
LogLevelパラメタ〔EUR Web Plug-In〕
LOGSIZE〔BSP-RM連携コマンドの環境設定ファイル〕
LOGSIZE〔EUR Client Serviceの環境設定ファイル〕
LOGSIZE〔EUR Server - Adapterの環境設定ファイル〕
LOGSIZE〔EUR Server - Spool Service Adapterの環境設定ファイル〕
LOGSIZE〔EUR Server - Spool Serviceの環境設定ファイル〕
LOGSIZE〔EUR Server Serviceの環境設定ファイル〕
LOGSIZE〔Server Service制御コマンドの環境設定ファイル〕
LOGSIZE〔Spool Service制御コマンドの環境設定ファイル〕
LOGSIZE〔ジョブ実行プログラムの環境設定ファイル〕
LOGSIZE〔ファイル監視サービスの環境設定ファイル〕
LogSizeパラメタ〔EUR Web Plug-In〕
(Ｍ)
MAPPINGDATA〔OutputEPFReport関数（COBOL起動部品）〕
MAPPINGDATA〔OutputEURReport関数（COBOL起動部品）〕
MAPPINGDATA〔OutputPDFReport関数（COBOL起動部品）〕
MAPPINGDATA〔OutputXLSXReport関数（COBOL起動部品）〕
MAPPINGDATA〔PrintReport2関数（COBOL起動部品）〕
MAPPINGDATA〔PrintReport関数（COBOL起動部品）〕
MAPPINGDATAPATH〔OutputEPFReport関数（COBOL起動部品）〕
MAPPINGDATAPATH〔OutputEURReport関数（COBOL起動部品）〕
MAPPINGDATAPATH〔OutputPDFReport関数（COBOL起動部品）〕
MAPPINGDATAPATH〔OutputXLSXReport関数（COBOL起動部品）〕
MAPPINGDATAPATH〔PrintReport2関数（COBOL起動部品）〕
MAPPINGDATAPATH〔PrintReport関数（COBOL起動部品）〕
Margin〔プリンタ定義ファイルのキーワード〕
MAXPRINTCOUNT〔PrintReport2関数（COBOL起動部品）〕
MAXPRINTCOUNT〔PrintReport関数（COBOL起動部品）〕
MaxPrintCountプロパティ〔ActiveX起動部品〕
MaxPrintCountプロパティ〔SS-ActiveX起動部品〕
memgetSpoolFileメソッド〔SS-Java起動部品〕
MERGE〔EUR Server - Spool Serviceの環境設定ファイル〕
MERGE〔EUR Server Serviceの環境設定ファイル〕
MERGEEPFFILENAME〔OutputMergeEPFReport関数（COBOL起動部品）〕
MergeEPFFileNameプロパティ〔ActiveX起動部品〕
MERGEEPFFILEPATH〔OutputMergeEPFReport関数（COBOL起動部品）〕
MergeEPFFilePathプロパティ〔ActiveX起動部品〕
MERGEOUTPUT〔EUR Server - Adapterの環境設定ファイル〕
MULTI〔EUR Server Serviceの環境設定ファイル〕
MULTIFORMINFO〔OutputEPFReport関数（COBOL起動部品）〕
MULTIFORMINFO〔OutputEURReport関数（COBOL起動部品）〕
MULTIFORMINFO〔OutputPDFReport関数（COBOL起動部品）〕
MULTIFORMINFO〔PrintReport2関数（COBOL起動部品）〕
MULTIFORMINFO〔PrintReport関数（COBOL起動部品）〕
MultiFormInfoDefFileNameプロパティ〔ActiveX起動部品〕
MultiFormInfoDefFilePathプロパティ〔ActiveX起動部品〕
MULTIFORMINFOPATH〔OutputEPFReport関数（COBOL起動部品）〕
MULTIFORMINFOPATH〔OutputEURReport関数（COBOL起動部品）〕
MULTIFORMINFOPATH〔OutputPDFReport関数（COBOL起動部品）〕
MULTIFORMINFOPATH〔PrintReport2関数（COBOL起動部品）〕
MULTIFORMINFOPATH〔PrintReport関数（COBOL起動部品）〕
MultiReportSetFileNameプロパティ〔ActiveX起動部品〕
MultiReportSetFilePathプロパティ〔ActiveX起動部品〕
(Ｎ)
NAME〔しおり定義ファイルのキーワード〕
NoPrintパラメタ〔EUR Web Plug-In〕
NoSetPrinterDlgパラメタ〔EUR Web Plug-In〕
(Ｏ)
OUTPUT〔EUR Server - Adapterの環境設定ファイル〕
OutputEPFReport関数〔COBOL起動部品〕
OutputEPFReportメソッド〔ActiveX起動部品〕
outputEPFReportメソッド〔Java起動部品〕
OutputEURReport関数〔COBOL起動部品〕
OutputEURReportメソッド〔ActiveX起動部品〕
outputEURReportメソッド〔Java起動部品〕
OUTPUTFILE〔EUR Server - Spool Service Adapterの環境設定ファイル〕
OutputFileNameプロパティ〔SS-ActiveX起動部品〕
OutputFilePathプロパティ〔SS-ActiveX起動部品〕
OutputMergeEPFReport関数〔COBOL起動部品〕
OutputMergeEPFReportメソッド〔ActiveX起動部品〕
outputMergeEPFReportメソッド〔Java起動部品〕
OutputPDFReport関数〔COBOL起動部品〕
OutputPDFReportメソッド〔ActiveX起動部品〕
outputPDFReportメソッド〔Java起動部品〕
OutputXLSXReport関数〔COBOL起動部品〕
OutputXLSXReportメソッド〔ActiveX起動部品〕
outputXLSXReportメソッド〔Java起動部品〕
OwnerPassword〔暗号化設定ファイルのキーワード〕
(Ｐ)
PageChangedイベント〔EUR Web Plug-In〕
PAGENUMBERFORMAT〔OutputEPFReport関数（COBOL起動部品）〕
PAGENUMBERFORMAT〔OutputPDFReport関数（COBOL起動部品）〕
PAGENUMBERFORMAT〔PrintReport2関数（COBOL起動部品）〕
PAGENUMBERFORMAT〔PrintReport関数（COBOL起動部品）〕
PageNumberFormatプロパティ〔ActiveX起動部品〕
PAGENUMBERLOCATION〔OutputEPFReport関数（COBOL起動部品）〕
PAGENUMBERLOCATION〔OutputPDFReport関数（COBOL起動部品）〕
PAGENUMBERLOCATION〔PrintReport2関数（COBOL起動部品）〕
PAGENUMBERLOCATION〔PrintReport関数（COBOL起動部品）〕
PageNumberLocationプロパティ〔ActiveX起動部品〕
PageNumプロパティ〔SS-ActiveX起動部品〕
PAPERORIENTATION〔OutputEPFReport関数（COBOL起動部品）〕
PAPERORIENTATION〔OutputMergeEPFReport関数（COBOL起動部品）〕
PAPERORIENTATION〔PrintReport2関数（COBOL起動部品）〕
PAPERORIENTATION〔PrintReport関数（COBOL起動部品）〕
PaperOrientationプロパティ〔ActiveX起動部品〕
PaperOrientationプロパティ〔SS-ActiveX起動部品〕
PaperShiftX〔プリンタ定義ファイルのキーワード〕
PaperShiftY〔プリンタ定義ファイルのキーワード〕
PATH_MACHINE〔帳票管理GUIの環境設定ファイル〕
PATH〔帳票管理GUIの環境設定ファイル〕
PATHMODE〔EUR Server Serviceの環境設定ファイル〕
PDF〔EUR Server Serviceの環境設定ファイル〕
PDFFILENAME〔OutputPDFReport関数（COBOL起動部品）〕
PDFFileNameプロパティ〔ActiveX起動部品〕
PDFFILEPATH〔OutputPDFReport関数（COBOL起動部品）〕
PDFFilePathプロパティ〔ActiveX起動部品〕
PDFOUTPUT〔EUR Server - Adapterの環境設定ファイル〕
PDF形式ファイルに出力する場合の環境変数
PDF仕分け定義ファイル
PDF仕分け定義ファイルのキーワード〔PDF形式ファイルを暗号化仕分け出力する場合〕
PDF仕分け定義ファイルのキーワード〔PDF形式ファイルを仕分け出力する場合〕
PDF仕分け定義ファイルの形式〔PDF形式ファイルを暗号化仕分け出力する場合〕
PDF仕分け定義ファイルの形式〔PDF形式ファイルを仕分け出力する場合〕
PDF仕分け定義ファイルの編集〔PDF形式ファイルを暗号化仕分け出力する場合〕
PDF仕分け定義ファイルの編集〔PDF形式ファイルを仕分け出力する場合〕
PDF仕分けをするときの注意
PDLType〔プリンタ定義ファイルのキーワード〕
PermissionPrinterDriverプロパティ〔EUR Web Plug-In〕
PermissionPrinterNameプロパティ〔EUR Web Plug-In〕
PERSONALCATEGORY〔EUR Server - Spool Serviceの環境設定ファイル〕
PMSERVERADDR〔GetDestinationList2関数（COBOL起動部品）〕
PMSERVERADDR〔GetPMPrinterClassList関数（COBOL起動部品）〕
PMSERVERADDR〔GetPMPrinterList関数（COBOL起動部品）〕
PMSERVERADDR〔GetPMTrayList関数（COBOL起動部品）〕
PMSERVERADDR〔GetPrinterClassList2関数（COBOL起動部品）〕
PMSERVERADDR〔GetPrinterList関数（COBOL起動部品）〕
PMSERVERADDR〔GetTrayList関数（COBOL起動部品）〕
PMSERVERADDR〔OutputEPFReport関数（COBOL起動部品）〕
PMSERVERADDR〔OutputEURReport関数（COBOL起動部品）〕
PMSERVERADDR〔OutputMergeEPFReport関数（COBOL起動部品）〕
PMSERVERADDR〔OutputPDFReport関数（COBOL起動部品）〕
PMSERVERADDR〔OutputXLSXReport関数（COBOL起動部品）〕
PMSERVERADDR〔PrintReport2関数（COBOL起動部品）〕
PMSERVERADDR〔PrintReport関数（COBOL起動部品）〕
PMServerAddressプロパティ〔ActiveX起動部品〕
PMSERVERPORT〔GetDestinationList2関数（COBOL起動部品）〕
PMSERVERPORT〔GetPMPrinterClassList関数（COBOL起動部品）〕
PMSERVERPORT〔GetPMPrinterList関数（COBOL起動部品）〕
PMSERVERPORT〔GetPMTrayList関数（COBOL起動部品）〕
PMSERVERPORT〔GetPrinterClassList2関数（COBOL起動部品）〕
PMSERVERPORT〔GetPrinterList関数（COBOL起動部品）〕
PMSERVERPORT〔GetTrayList関数（COBOL起動部品）〕
PMSERVERPORT〔OutputEPFReport関数（COBOL起動部品）〕
PMSERVERPORT〔OutputEURReport関数（COBOL起動部品）〕
PMSERVERPORT〔OutputMergeEPFReport関数（COBOL起動部品）〕
PMSERVERPORT〔OutputPDFReport関数（COBOL起動部品）〕
PMSERVERPORT〔OutputXLSXReport関数（COBOL起動部品）〕
PMSERVERPORT〔PrintReport2関数（COBOL起動部品）〕
PMSERVERPORT〔PrintReport関数（COBOL起動部品）〕
PMServerPortプロパティ〔ActiveX起動部品〕
POB〔EUR Server - Spool Serviceの環境設定ファイル〕
POLLINGREPORT〔EUR Server - Spool Service Adapterの環境設定ファイル〕
PREFERENCE〔EUR Server Serviceの環境設定ファイル〕
PRINT〔EUR Server - Spool Service Adapterの環境設定ファイル〕
PRINTCOPIES〔OutputEPFReport関数（COBOL起動部品）〕
PRINTCOPIES〔OutputMergeEPFReport関数（COBOL起動部品）〕
PRINTCOPIES〔PrintReport2関数（COBOL起動部品）〕
PRINTCOPIES〔PrintReport関数（COBOL起動部品）〕
PrintCopiesプロパティ〔ActiveX起動部品〕
PrintCopiesプロパティ〔SS-ActiveX起動部品〕
PRINTDATE〔EUR Server Serviceの環境設定ファイル〕 ,[2]
PRINTDATEFILENAME〔OutputEPFReport関数（COBOL起動部品）〕
PRINTDATEFILENAME〔PrintReport2関数（COBOL起動部品）〕
PRINTDATEFILENAME〔PrintReport関数（COBOL起動部品）〕
PrintDateFileNameプロパティ〔ActiveX起動部品〕
PRINTDATEFILEPATH〔OutputEPFReport関数（COBOL起動部品）〕
PRINTDATEFILEPATH〔PrintReport2関数（COBOL起動部品）〕
PRINTDATEFILEPATH〔PrintReport関数（COBOL起動部品）〕
PrintDateFilePathプロパティ〔ActiveX起動部品〕
PRINTEDLIMIT〔EUR Server - Spool Serviceの環境設定ファイル〕
PRINTENDPAGE〔OutputEPFReport関数（COBOL起動部品）〕
PRINTENDPAGE〔OutputPDFReport関数（COBOL起動部品）〕
PRINTENDPAGE〔OutputXLSXReport関数（COBOL起動部品）〕
PRINTENDPAGE〔PrintReport2関数（COBOL起動部品）〕
PRINTENDPAGE〔PrintReport関数（COBOL起動部品）〕
PrintEndPageパラメタ〔EUR Web Plug-In〕
PrintEndPageプロパティ〔ActiveX起動部品〕
PrintEndPageプロパティ〔SS-ActiveX起動部品〕
PrintEPFメソッド〔EUR Web Plug-In〕
PrinterClassListプロパティ〔SS-ActiveX起動部品〕
PRINTERCLASSNAME〔OutputEPFReport関数（COBOL起動部品）〕
PRINTERCLASSNAME〔OutputMergeEPFReport関数（COBOL起動部品）〕
PRINTERCLASSNAME〔PrintReport2関数（COBOL起動部品）〕
PRINTERCLASSNAME〔PrintReport関数（COBOL起動部品）〕
PrinterClassNameプロパティ〔ActiveX起動部品〕
PrinterClassNameプロパティ〔SS-ActiveX起動部品〕
PRINTERNAME〔GetTrayList関数（COBOL起動部品）〕
PRINTERNAME〔PrintReport2関数（COBOL起動部品）〕
PRINTERNAME〔PrintReport関数（COBOL起動部品）〕
PrinterNameパラメタ〔EUR Web Plug-In〕
PRINTERNUM〔GetPrinterList関数（COBOL起動部品）〕
PRINTERS〔GetPrinterList関数（COBOL起動部品）〕
PRINTERSELECTMODE〔PrintReport2関数（COBOL起動部品）〕
PRINTERSELECTMODE〔PrintReport関数（COBOL起動部品）〕
PrinterSelectModeプロパティ〔ActiveX起動部品〕
PrinterSelectModeプロパティ〔SS-ActiveX起動部品〕
PRINTHOLDMODE〔PrintReport2関数（COBOL起動部品）〕
PRINTHOLDMODE〔PrintReport関数（COBOL起動部品）〕
PrintHoldModeプロパティ〔ActiveX起動部品〕
PRINTINGLIMIT〔EUR Server - Spool Serviceの環境設定ファイル〕
PRINTKIND〔PrintReport2関数（COBOL起動部品）〕
PRINTKIND〔PrintReport関数（COBOL起動部品）〕
PrintKindプロパティ〔ActiveX起動部品〕
PRINTMODE〔EUR Server - Adapterの環境設定ファイル〕
PRINTMODE〔PrintReport2関数（COBOL起動部品）〕
PRINTMODE〔PrintReport関数（COBOL起動部品）〕
PrintModeプロパティ〔ActiveX起動部品〕
PrintModeプロパティ〔SS-ActiveX起動部品〕
printnewpaper〔複数様式情報定義ファイルのキーワード〕
PRINTPAGENUMBER〔OutputEPFReport関数（COBOL起動部品）〕
PRINTPAGENUMBER〔OutputPDFReport関数（COBOL起動部品）〕
PRINTPAGENUMBER〔PrintReport2関数（COBOL起動部品）〕
PRINTPAGENUMBER〔PrintReport関数（COBOL起動部品）〕
PrintPageNumberプロパティ〔ActiveX起動部品〕
PrintPMReportメソッド〔ActiveX起動部品〕
PrintReport2関数〔COBOL起動部品〕
PrintReport関数〔COBOL起動部品〕
printReportメソッド〔Java起動部品〕
PrintResultプロパティ〔SS-ActiveX起動部品〕
PrintSpoolReportメソッド〔SS-ActiveX起動部品〕
printSpoolReportメソッド〔SS-Java起動部品〕
PRINTSTARTPAGE〔OutputEPFReport関数（COBOL起動部品）〕
PRINTSTARTPAGE〔OutputPDFReport関数（COBOL起動部品）〕
PRINTSTARTPAGE〔OutputXLSXReport関数（COBOL起動部品）〕
PRINTSTARTPAGE〔PrintReport2関数（COBOL起動部品）〕
PRINTSTARTPAGE〔PrintReport関数（COBOL起動部品）〕
PrintStartPageパラメタ〔EUR Web Plug-In〕
PrintStartPageプロパティ〔ActiveX起動部品〕
PrintStartPageプロパティ〔SS-ActiveX起動部品〕
PRINTSTATE〔EUR Server - Spool Service Adapterの環境設定ファイル〕
PrintTimeプロパティ〔SS-ActiveX起動部品〕
PRTCLSLIST〔EUR Server - Adapterの環境設定ファイル〕
PRTCLSLIST〔EUR Server - Spool Service Adapterの環境設定ファイル〕
PSENV〔EUR Server Serviceの環境設定ファイル〕
PSENVFILENAME〔EUR Server Serviceの環境設定ファイル〕
PSENVFILENAME〔OutputEPFReport関数（COBOL起動部品）〕
PSENVFILENAME〔OutputEURReport関数（COBOL起動部品）〕
PSENVFILENAME〔OutputPDFReport関数（COBOL起動部品）〕
PSENVFILENAME〔OutputXLSXReport関数（COBOL起動部品）〕
PSENVFILENAME〔PrintReport2関数（COBOL起動部品）〕
PSENVFILENAME〔PrintReport関数（COBOL起動部品）〕
PSEnvFileNameプロパティ〔ActiveX起動部品〕
PSENVFILEPATH〔OutputEPFReport関数（COBOL起動部品）〕
PSENVFILEPATH〔OutputEURReport関数（COBOL起動部品）〕
PSENVFILEPATH〔OutputPDFReport関数（COBOL起動部品）〕
PSENVFILEPATH〔OutputXLSXReport関数（COBOL起動部品）〕
PSENVFILEPATH〔PrintReport2関数（COBOL起動部品）〕
PSENVFILEPATH〔PrintReport関数（COBOL起動部品）〕
PSEnvFilePathプロパティ〔ActiveX起動部品〕
(Ｑ)
QRCellSizeD〔プリンタ定義ファイルのキーワード〕
QRCellSizeM〔プリンタ定義ファイルのキーワード〕
(Ｒ)
REMAINFLAG〔BSP-RM連携コマンドの環境設定ファイル〕
REPLACEITEM〔EUR Server Serviceの環境設定ファイル〕
REPLACEITEMCNTLFILENAME〔OutputEPFReport関数（COBOL起動部品）〕
REPLACEITEMCNTLFILENAME〔OutputEURReport関数（COBOL起動部品）〕
REPLACEITEMCNTLFILENAME〔OutputPDFReport関数（COBOL起動部品）〕
REPLACEITEMCNTLFILENAME〔OutputXLSXReport関数（COBOL起動部品）〕
REPLACEITEMCNTLFILENAME〔PrintReport2関数（COBOL起動部品）〕
REPLACEITEMCNTLFILENAME〔PrintReport関数（COBOL起動部品）〕
ReplaceItemCntlFileNameプロパティ〔ActiveX起動部品〕
REPLACEITEMCNTLFILEPATH〔OutputEPFReport関数（COBOL起動部品）〕
REPLACEITEMCNTLFILEPATH〔OutputEURReport関数（COBOL起動部品）〕
REPLACEITEMCNTLFILEPATH〔OutputPDFReport関数（COBOL起動部品）〕
REPLACEITEMCNTLFILEPATH〔OutputXLSXReport関数（COBOL起動部品）〕
REPLACEITEMCNTLFILEPATH〔PrintReport2関数（COBOL起動部品）〕
REPLACEITEMCNTLFILEPATH〔PrintReport関数（COBOL起動部品）〕
ReplaceItemCntlFilePathプロパティ〔ActiveX起動部品〕
ReportAddressKeyCategoryプロパティ〔ActiveX起動部品〕
ReportAddressKeyCategoryプロパティ〔SS-ActiveX起動部品〕
ReportAddressKeyDataプロパティ〔ActiveX起動部品〕
ReportAddressKeyDataプロパティ〔SS-ActiveX起動部品〕
REPORTADDRKEYCATEGORY〔PrintReport関数（COBOL起動部品）〕
REPORTADDRKEYDATA〔PrintReport関数（COBOL起動部品）〕
ReportFileNameプロパティ〔ActiveX起動部品〕
REPORTFILEPATH〔OutputEPFReport関数（COBOL起動部品）〕
REPORTFILEPATH〔OutputEURReport関数（COBOL起動部品）〕
REPORTFILEPATH〔OutputPDFReport関数（COBOL起動部品）〕
REPORTFILEPATH〔OutputXLSXReport関数（COBOL起動部品）〕
REPORTFILEPATH〔PrintReport2関数（COBOL起動部品）〕
REPORTFILEPATH〔PrintReport関数（COBOL起動部品）〕
ReportFilePathプロパティ〔ActiveX起動部品〕
REPORTNAME〔OutputEPFReport関数（COBOL起動部品）〕
REPORTNAME〔OutputEURReport関数（COBOL起動部品）〕
REPORTNAME〔OutputPDFReport関数（COBOL起動部品）〕
REPORTNAME〔OutputXLSXReport関数（COBOL起動部品）〕
REPORTNAME〔PrintReport2関数（COBOL起動部品）〕
REPORTNAME〔PrintReport関数（COBOL起動部品）〕
REPORTSET〔OutputEPFReport関数（COBOL起動部品）〕
REPORTSET〔OutputEURReport関数（COBOL起動部品）〕
REPORTSET〔OutputPDFReport関数（COBOL起動部品）〕
REPORTSET〔PrintReport2関数（COBOL起動部品）〕
REPORTSET〔PrintReport関数（COBOL起動部品）〕
REPORTSETFILE〔OutputEPFReport関数（COBOL起動部品）〕
REPORTSETFILE〔OutputEURReport関数（COBOL起動部品）〕
REPORTSETFILE〔OutputPDFReport関数（COBOL起動部品）〕
REPORTSETFILE〔PrintReport2関数（COBOL起動部品）〕
REPORTSETFILE〔PrintReport関数（COBOL起動部品）〕
REPORTSETFILEPATH〔OutputEPFReport関数（COBOL起動部品）〕
REPORTSETFILEPATH〔OutputEURReport関数（COBOL起動部品）〕
REPORTSETFILEPATH〔OutputPDFReport関数（COBOL起動部品）〕
REPORTSETFILEPATH〔PrintReport2関数（COBOL起動部品）〕
REPORTSETFILEPATH〔PrintReport関数（COBOL起動部品）〕
resetpagenumber〔複数様式情報定義ファイルのキーワード〕
RMDIRINTERVALTIME〔EUR Client Serviceの環境設定ファイル〕
RMDIRINTERVALTIME〔EUR Server - Spool Serviceの環境設定ファイル〕
RMDIRINTERVALTIME〔EUR Server Serviceの環境設定ファイル〕
RMDIRRETRYCOUNT〔EUR Client Serviceの環境設定ファイル〕
RMDIRRETRYCOUNT〔EUR Server - Spool Serviceの環境設定ファイル〕
RMDIRRETRYCOUNT〔EUR Server Serviceの環境設定ファイル〕
RUNPARAM〔BSP-RM連携コマンドの環境設定ファイル〕
RUNPARAM〔ファイル監視サービスの環境設定ファイル〕
(Ｓ)
SCALE〔文書しおり定義ファイルのキーワード〕
SCRIPTCNT〔EUR Server Serviceの環境設定ファイル〕
SCRIPTCNTLFILENAME〔OutputPDFReport関数（COBOL起動部品）〕
ScriptCntlFileNameプロパティ〔ActiveX起動部品〕
SCRIPTCNTLFILEPATH〔OutputPDFReport関数（COBOL起動部品）〕
ScriptCntlFilePathプロパティ〔ActiveX起動部品〕
SearchCreateTimeEndプロパティ〔SS-ActiveX起動部品〕
SearchCreateTimeStartプロパティ〔SS-ActiveX起動部品〕
SearchJobIDプロパティ〔SS-ActiveX起動部品〕
SearchJobKeyCategoryプロパティ〔SS-ActiveX起動部品〕
SearchJobKeyDataプロパティ〔SS-ActiveX起動部品〕
SearchPrinterClassNameプロパティ〔SS-ActiveX起動部品〕
SearchReportAddressKeyCategoryプロパティ〔SS-ActiveX起動部品〕
SearchReportAddressKeyDataプロパティ〔SS-ActiveX起動部品〕
SearchSpoolFileNameプロパティ〔SS-ActiveX起動部品〕
SELECTDISPLAYPRINTER〔EUR Client Serviceの環境設定ファイル〕
SelectDisplayPrinterパラメタ〔EUR Web Plug-In〕
SelectDisplayPrinterプロパティ〔EUR Web Plug-In〕
SendResultURLパラメタ〔EUR Web Plug-In〕
SERVERADDR〔PrintReport2関数（COBOL起動部品）〕
SERVERADDR〔PrintReport関数（COBOL起動部品）〕
ServerAddressプロパティ〔ActiveX起動部品〕
ServerAddressプロパティ〔SS-ActiveX起動部品〕
SERVERNAME〔OutputPDFReport関数（COBOL起動部品）〕
SERVERNAME〔PrintReport2関数（COBOL起動部品）〕
SERVERNAME〔PrintReport関数（COBOL起動部品）〕
ServerPrinterListプロパティ〔SS-ActiveX起動部品〕
SERVERPRINTERNAME〔PrintReport2関数（COBOL起動部品）〕
SERVERPRINTERNAME〔PrintReport関数（COBOL起動部品）〕
ServerPrinterNameプロパティ〔ActiveX起動部品〕
ServerPrinterNameプロパティ〔SS-ActiveX起動部品〕
SERVERSELECTMODE〔PrintReport2関数（COBOL起動部品）〕
SERVERSELECTMODE〔PrintReport関数（COBOL起動部品）〕
ServerSelectModeプロパティ〔ActiveX起動部品〕
ServerTrayListプロパティ〔SS-ActiveX起動部品〕
SERVERTRAYNAME〔PrintReport2関数（COBOL起動部品）〕
SERVERTRAYNAME〔PrintReport関数（COBOL起動部品）〕
ServerTrayNameプロパティ〔ActiveX起動部品〕
ServerTrayNameプロパティ〔SS-ActiveX起動部品〕
setBookmarkFileDataメソッド〔Java起動部品〕
setBookmarkFileNameメソッド〔Java起動部品〕
setBookmarkFilePathメソッド〔Java起動部品〕
setClientAddressメソッド〔Java起動部品〕
setClientAddressメソッド〔SS-Java起動部品〕
setClientPrinterNameメソッド〔Java起動部品〕
setClientPrinterNameメソッド〔SS-Java起動部品〕
setClientTrayNameメソッド〔Java起動部品〕
setClientTrayNameメソッド〔SS-Java起動部品〕
setCryptoFileDataメソッド〔Java起動部品〕
setCryptoFileNameメソッド〔Java起動部品〕
setCryptoFilePathメソッド〔Java起動部品〕
setCryptoメソッド〔Java起動部品〕
setDataFileDataメソッド〔Java起動部品〕
setDataFileNameメソッド〔Java起動部品〕
setDataFilePathメソッド〔Java起動部品〕
setDBInfoFileNameメソッド〔Java起動部品〕
setDBInfoFilePathメソッド〔Java起動部品〕
setDeleteKindメソッド〔SS-Java起動部品〕
setDestinationNameメソッド〔Java起動部品〕
setDispPrintDlgメソッド〔Java起動部品〕
setDispPrintDlgメソッド〔SS-Java起動部品〕
setDistributeFileDataメソッド〔Java起動部品〕
setDistributeFileNameメソッド〔Java起動部品〕
setDistributeFilePathメソッド〔Java起動部品〕
setDocBookmarkFileDataメソッド〔Java起動部品〕
setDocBookmarkFileNameメソッド〔Java起動部品〕
setDocInfoFileNameメソッド〔Java起動部品〕
setDocInfoFilePathメソッド〔Java起動部品〕
setEnableGetメソッド〔Java起動部品〕
setEnableGetメソッド〔SS-Java起動部品〕
setEncryptionPasswordKeyメソッド〔Java起動部品〕
setEPFFileDataメソッド〔Java起動部品〕
setEPFFileNameメソッド〔Java起動部品〕
setEPFFilePathメソッド〔Java起動部品〕
setEURFileNameメソッド〔Java起動部品〕
setEURFilePathメソッド〔Java起動部品〕
setExecutablePrintModeメソッド〔Java起動部品〕
setExecutablePrintModeメソッド〔SS-Java起動部品〕
setFileOutputDestinationメソッド〔Java起動部品〕
setFirstPageNumberメソッド〔Java起動部品〕
setGroupNameメソッド〔Java起動部品〕
setGroupNameメソッド〔SS-Java起動部品〕
setInitPageNumberメソッド〔Java起動部品〕
setJobKeyCategoryメソッド〔Java起動部品〕
setJobKeyCategoryメソッド〔SS-Java起動部品〕
setJobKeyDataメソッド〔Java起動部品〕
setJobKeyDataメソッド〔SS-Java起動部品〕
setMaxPrintCountメソッド〔Java起動部品〕
setMaxPrintCountメソッド〔SS-Java起動部品〕
setMergeEPFFileNameメソッド〔Java起動部品〕
setMergeEPFFilePathメソッド〔Java起動部品〕
setMultiBookmarkFileNameメソッド〔Java起動部品〕
setMultiDataFileNameメソッド〔Java起動部品〕
setMultiFormInfoDefFileNameメソッド〔Java起動部品〕
setMultiFormInfoDefFilePathメソッド〔Java起動部品〕
setMultiReportFileNameメソッド〔Java起動部品〕
setMultiReportSetFileNameメソッド〔Java起動部品〕
setMultiReportSetFilePathメソッド〔Java起動部品〕
setMultiUserDataFileNameメソッド〔Java起動部品〕
setOutputFileNameメソッド〔SS-Java起動部品〕
setOutputFilePathメソッド〔SS-Java起動部品〕
setPageNumberFormatメソッド〔Java起動部品〕
setPageNumberLocationメソッド〔Java起動部品〕
setPaperOrientationメソッド〔Java起動部品〕
setPaperOrientationメソッド〔SS-Java起動部品〕
setPDFFileNameメソッド〔Java起動部品〕
setPDFFilePathメソッド〔Java起動部品〕
setPMServerAddressメソッド〔Java起動部品〕
setPMServerPortメソッド〔Java起動部品〕
setPrintCopiesメソッド〔Java起動部品〕
setPrintCopiesメソッド〔SS-Java起動部品〕
setPrintDateFileNameメソッド〔Java起動部品〕
setPrintDateFilePathメソッド〔Java起動部品〕
setPrintEndPageメソッド〔Java起動部品〕
setPrintEndPageメソッド〔SS-Java起動部品〕
setPrinterClassNameメソッド〔Java起動部品〕
setPrinterClassNameメソッド〔SS-Java起動部品〕
setPrinterSelectModeメソッド〔Java起動部品〕
setPrinterSelectModeメソッド〔SS-Java起動部品〕
setPrintHoldModeメソッド〔Java起動部品〕
setPrintKindメソッド〔Java起動部品〕
setPrintModeメソッド〔Java起動部品〕
setPrintModeメソッド〔SS-Java起動部品〕
setPrintPageNumberメソッド〔Java起動部品〕
setPrintStartPageメソッド〔Java起動部品〕
setPrintStartPageメソッド〔SS-Java起動部品〕
setPSEnvFileNameメソッド〔Java起動部品〕
setPSEnvFilePathメソッド〔Java起動部品〕
setReplaceItemCntlFileNameメソッド〔Java起動部品〕
setReplaceItemCntlFilePathメソッド〔Java起動部品〕
setReportAddressKeyCategoryメソッド〔Java起動部品〕
setReportAddressKeyDataメソッド〔Java起動部品〕
setReportFileNameメソッド〔Java起動部品〕
setReportFilePathメソッド〔Java起動部品〕
setScriptCntlFileNameメソッド〔Java起動部品〕
setScriptCntlFilePathメソッド〔Java起動部品〕
setSearchCreateTimeEndメソッド〔SS-Java起動部品〕
setSearchCreateTimeStartメソッド〔SS-Java起動部品〕
setSearchJobIDMultiメソッド〔SS-Java起動部品〕
setSearchJobIDメソッド〔SS-Java起動部品〕
setSearchJobKeyCategoryメソッド〔SS-Java起動部品〕
setSearchJobKeyDataメソッド〔SS-Java起動部品〕
setSearchPrinterClassNameメソッド〔SS-Java起動部品〕
setSearchReportAddressKeyCategoryメソッド〔SS-Java起動部品〕
setSearchReportAddressKeyDataメソッド〔SS-Java起動部品〕
setSearchSpoolFileNameメソッド〔SS-Java起動部品〕
setServerAddressメソッド〔Java起動部品〕
setServerAddressメソッド〔SS-Java起動部品〕
setServerPrinterNameメソッド〔Java起動部品〕
setServerPrinterNameメソッド〔SS-Java起動部品〕
setServerSelectModeメソッド〔Java起動部品〕
setServerTrayNameメソッド〔Java起動部品〕
setServerTrayNameメソッド〔SS-Java起動部品〕
setSortPrintメソッド〔Java起動部品〕
setSortPrintメソッド〔SS-Java起動部品〕
setSplitFileDataメソッド〔Java起動部品〕
setSplitFileNameメソッド〔Java起動部品〕
setSplitFilePathメソッド〔Java起動部品〕
setSplitModeメソッド〔Java起動部品〕
SetSpoolFileAttributeメソッド〔SS-ActiveX起動部品〕
setSpoolFileAttributeメソッド〔SS-Java起動部品〕
setSpoolFileNameメソッド〔Java起動部品〕
setSpoolLimitメソッド〔Java起動部品〕
setSpoolLimitメソッド〔SS-Java起動部品〕
setSpoolTitleメソッド〔Java起動部品〕
setSpoolTitleメソッド〔SS-Java起動部品〕
setUserDataFileDataメソッド〔Java起動部品〕
setUserDataFileNameメソッド〔Java起動部品〕
setUserDataFilePathメソッド〔Java起動部品〕
setViewerPreferenceFileNameメソッド〔Java起動部品〕
setViewerPreferenceFilePathメソッド〔Java起動部品〕
setXLSXFileNameメソッド〔Java起動部品〕
setXLSXFilePathメソッド〔Java起動部品〕
ShowScrollBarパラメタ〔EUR Web Plug-In〕
SOCKBUFFSIZE〔EUR Client Serviceの環境設定ファイル〕
SOCKBUFFSIZE〔EUR Server - Adapterの環境設定ファイル〕
SOCKBUFFSIZE〔EUR Server - Spool Service Adapterの環境設定ファイル〕
SOCKBUFFSIZE〔EUR Server - Spool Serviceの環境設定ファイル〕
SOCKBUFFSIZE〔EUR Server Serviceの環境設定ファイル〕
SORTPRINT〔OutputEPFReport関数（COBOL起動部品）〕
SORTPRINT〔OutputMergeEPFReport関数（COBOL起動部品）〕
SORTPRINT〔PrintReport2関数（COBOL起動部品）〕
SORTPRINT〔PrintReport関数（COBOL起動部品）〕
SortPrintプロパティ〔ActiveX起動部品〕
SortPrintプロパティ〔SS-ActiveX起動部品〕
SPLIT〔EUR Server Serviceの環境設定ファイル〕 ,[2]
SPLITFILENAME〔PrintReport2関数（COBOL起動部品）〕
SPLITFILENAME〔PrintReport関数（COBOL起動部品）〕
SplitFileNameプロパティ〔ActiveX起動部品〕
SPLITFILEPATH〔PrintReport2関数（COBOL起動部品）〕
SPLITFILEPATH〔PrintReport関数（COBOL起動部品）〕
SplitFilePathプロパティ〔ActiveX起動部品〕
SPLITMODE〔EUR Server Serviceの環境設定ファイル〕
SPLITMODE〔PrintReport2関数（COBOL起動部品）〕
SPLITMODE〔PrintReport関数（COBOL起動部品）〕
SplitModeプロパティ〔ActiveX起動部品〕
SPLOUTLINELIMIT〔EUR Server - Spool Serviceの環境設定ファイル〕
SPOOLAUDITLOG〔EUR Server - Spool Serviceの環境設定ファイル〕
SPOOLFILENAME〔PrintReport2関数（COBOL起動部品）〕
SPOOLFILENAME〔PrintReport関数（COBOL起動部品）〕
SpoolFileNameプロパティ〔ActiveX起動部品〕
SpoolFileNameプロパティ〔SS-ActiveX起動部品〕
SpoolFileSizeプロパティ〔SS-ActiveX起動部品〕
SpoolHistoryプロパティ〔SS-ActiveX起動部品〕
SPOOLLIMIT〔EUR Server - Adapterの環境設定ファイル〕
SPOOLLIMIT〔PrintReport2関数（COBOL起動部品）〕
SPOOLLIMIT〔PrintReport関数（COBOL起動部品）〕
SpoolLimitプロパティ〔ActiveX起動部品〕
SpoolLimitプロパティ〔SS-ActiveX起動部品〕
SPOOLLOG〔EUR Server - Spool Serviceの環境設定ファイル〕
SPOOLLOGSIZE〔EUR Server - Spool Serviceの環境設定ファイル〕
SPOOLLOGMODE〔EUR Server - Spool Serviceの環境設定ファイル〕
SPOOLLOGNUM〔EUR Server - Spool Serviceの環境設定ファイル〕
SPOOLLOGSIZE〔EUR Server - Spool Serviceの環境設定ファイル〕
SpoolPathプロパティ〔SS-ActiveX起動部品〕
SPOOLTITLE〔OutputEPFReport関数（COBOL起動部品）
SPOOLTITLE〔OutputEURReport関数（COBOL起動部品）
SPOOLTITLE〔OutputMergeEPFReport関数（COBOL起動部品）〕
SPOOLTITLE〔PrintReport2関数（COBOL起動部品）
SPOOLTITLE〔PrintReport関数（COBOL起動部品）
SpoolTitleプロパティ〔ActiveX起動部品〕
SpoolTitleプロパティ〔SS-ActiveX起動部品〕
SS-ActiveX起動部品
Err.Descriptionプロパティ
Err.Numberプロパティ
実行時のエラー情報一覧
提供するクラス
ファイル名
プログラムIDとコントロール名
SS-ActiveX起動部品が提供するプロパティ一覧
SS-ActiveX起動部品が提供するメソッド一覧
SS-ActiveX起動部品の構文
EURPMLSADPLib.EURPMLSAdapterクラスを生成する場合
SS-ActiveX起動部品を構築する場合
SS-Java起動部品
EURPMLSAdapterForJavaクラス
EURPMLSExceptionクラス
JDKバージョン
実行時の例外情報一覧
パッケージ
ファイル名
STANDARDTIME〔EUR Server - Spool Serviceの環境設定ファイル〕
STANDARDTIME〔ファイル監視サービスの環境設定ファイル〕
START〔Server Service制御コマンドの環境設定ファイル〕
START〔Spool Service制御コマンドの環境設定ファイル〕
STOP〔Server Service制御コマンドの環境設定ファイル〕
STOP〔Spool Service制御コマンドの環境設定ファイル〕
subgroup〔複数様式情報定義ファイルのキーワード〕
subgroupの形式〔複数様式情報定義ファイル〕
SUBTITLE〔文書情報設定ファイルのキーワード〕
(Ｔ)
TEMP〔BSP-RM連携コマンドの環境設定ファイル〕
TEMP〔EUR Client Serviceの環境設定ファイル〕
TEMP〔EUR Server - Spool Serviceの環境設定ファイル〕
TEMP〔EUR Server Serviceの環境設定ファイル〕
TEMP〔Server Service制御コマンドの環境設定ファイル〕
TEMP〔Spool Service制御コマンドの環境設定ファイル〕
TEMPFILEDEL〔EUR Client Serviceの環境設定ファイル〕
TEMPFILEDEL〔EUR Server - Spool Serviceの環境設定ファイル〕
TEMPFILEDEL〔EUR Server Serviceの環境設定ファイル〕
TempFileDelパラメタ〔EUR Web Plug-In〕
TITLE〔文書しおり定義ファイルのキーワード〕
TITLE〔文書情報設定ファイルのキーワード〕
TotalPageプロパティ〔EUR Web Plug-In〕
TOTAL行〔PDF形式ファイルを暗号化仕分け出力する場合のPDF仕分け定義ファイル〕
TOTAL行〔PDF形式ファイルを仕分け出力する場合のPDF仕分け定義ファイル〕
traycode〔複数様式情報定義ファイルのキーワード〕
TRAYNAME〔PrintReport2関数（COBOL起動部品）〕
TRAYNAME〔PrintReport関数（COBOL起動部品）〕
TrayNameパラメタ〔EUR Web Plug-In〕
TRAYNUM〔GetTrayList関数（COBOL起動部品）〕
TRAYS〔GetTrayList関数（COBOL起動部品）〕
TurnPageメソッド〔EUR Web Plug-In〕
(Ｕ)
UserDataFileNameプロパティ〔ActiveX起動部品〕
UserDataFilePathプロパティ〔ActiveX起動部品〕
USERDEFDATA〔OutputEPFReport関数（COBOL起動部品）〕
USERDEFDATA〔OutputEURReport関数（COBOL起動部品）〕
USERDEFDATA〔OutputPDFReport関数（COBOL起動部品）〕
USERDEFDATA〔OutputXLSXReport関数（COBOL起動部品）〕
USERDEFDATA〔PrintReport2関数（COBOL起動部品）〕
USERDEFDATA〔PrintReport関数（COBOL起動部品）〕
USERDEFDATAPATH〔OutputEPFReport関数（COBOL起動部品）〕
USERDEFDATAPATH〔OutputEURReport関数（COBOL起動部品）〕
USERDEFDATAPATH〔OutputPDFReport関数（COBOL起動部品）〕
USERDEFDATAPATH〔OutputXLSXReport関数（COBOL起動部品）〕
USERDEFDATAPATH〔PrintReport2関数（COBOL起動部品）〕
USERDEFDATAPATH〔PrintReport関数（COBOL起動部品）〕
USERNAME〔EUR Server - Spool Service Adapterの環境設定ファイル〕
UserParamパラメタ〔EUR Web Plug-In〕
UserPassword〔暗号化設定ファイルのキーワード〕
(Ｖ)
VIEWERPREFERENCEFILENAME〔OutputPDFReport関数（COBOL起動部品）〕
ViewerPreferenceFileNameプロパティ〔ActiveX起動部品〕
VIEWERPREFERENCEFILEPATH〔OutputPDFReport関数（COBOL起動部品）〕
ViewerPreferenceFilePathプロパティ〔ActiveX起動部品〕
VScrollメソッド〔EUR Web Plug-In〕
(Ｗ)
WAITINGLIMIT〔EUR Server - Spool Serviceの環境設定ファイル〕
(Ｘ)
XDPI〔プリンタ定義ファイルのキーワード〕
XLSXFILENAME〔OutputXLSXReport関数（COBOL起動部品）〕
XLSXFileNameプロパティ〔ActiveX起動部品〕
XLSXFILEPATH〔OutputXLSXReport関数（COBOL起動部品）〕
XLSXFilePathプロパティ〔ActiveX起動部品〕
XLSXOUTPUT〔EUR Server - Adapterの環境設定ファイル〕
(Ｙ)
YDPI〔プリンタ定義ファイルのキーワード〕
(Ｚ)
Zoomパラメタ〔EUR Web Plug-In〕
Zoomメソッド〔EUR Web Plug-In〕

(ア行)

(あ)
宛先定義ファイル
アプリケーションサーバに準備するファイルの一覧
暗号化設定ファイル
暗号化設定ファイルに指定するキーワード〔PDF形式ファイルを暗号化出力する場合〕
暗号化設定ファイルに指定するキーワード〔PDF形式ファイルを暗号化仕分け出力する場合〕
暗号化設定ファイルのキーワード
暗号化設定ファイルの形式
(い)
印刷〔暗号化設定ファイルのセキュリティ属性〕
印刷先定義ファイル
印刷日時出力定義ファイル
(う)
運用に応じて格納先を決めるファイルの一覧
(え)
エラー情報一覧〔ActiveX起動部品〕
エラー情報一覧〔SS-ActiveX起動部品〕
(お)
オーナパスワード〔暗号化設定ファイルのセキュリティ属性〕
置き換え表管理情報ファイル
置き換え表ファイル

(カ行)

(か)
画像ファイル
可変記号値
可変記号値定義ファイル
環境設定ファイル（BSP-RM連携コマンド）
構文
指定例
設定項目一覧
設定手順
環境設定ファイル（EUR Client Service）
格納場所
構文
指定例
設定項目一覧
環境設定ファイル（EURPS_ENV）
格納場所
構文
指定例
設定手順
環境設定ファイル（EUR Server - Adapter）
格納場所
構文
指定例
環境設定ファイル（EUR Server - Spool Service）
格納場所
構文
指定例
環境設定ファイル（EUR Server - Spool Service Adapter）
格納場所
構文
指定例
環境設定ファイル（EUR Server - Adapter）
設定項目一覧
環境設定ファイル（EUR Server Service）
格納場所
構文
指定例
設定項目一覧
環境設定ファイル（EUR Server - Spool Service）
設定項目一覧
環境設定ファイル（EUR Server - Spool Service Adapter）
設定項目一覧
環境設定ファイル（Server Service制御コマンド）
構文
指定例
設定項目一覧
設定手順
環境設定ファイル（Spool Service制御コマンド）
構文
指定例
設定項目一覧
設定手順
環境設定ファイル（ジョブ実行プログラム）
構文
指定例
設定項目一覧
設定手順
環境設定ファイル（帳票管理GUI）
格納場所
構文
指定例
設定項目一覧
環境設定ファイル（ファイル監視サービス）
構文
指定例
設定項目一覧
設定手順
環境設定ファイルの一覧
環境設定ファイルの指定例
環境変数
BSP-RM連携コマンドの環境変数
EPF形式ファイルに出力する場合に使用する環境変数〔EURPS_ENV〕
Excel形式ファイルに出力する場合に使用する環境変数〔EURPS_ENV〕
PDF形式ファイルに出力する場合に使用する環境変数〔EURPS_ENV〕
共通で使用する環境変数〔EURPS_ENV〕
環境変数一覧 ,[2]
監視定義ファイル
(き)
起動パラメタファイル
起動パラメタファイルの形式
拠点プリンタクラス定義ファイル
(く)
クライアントプリンタクラス定義ファイル
(け)
形式〔暗号化設定ファイルのキーワードDisableAdd〕
形式〔暗号化設定ファイルのキーワードDisableChange〕
形式〔暗号化設定ファイルのキーワードDisableCopy〕
形式〔暗号化設定ファイルのキーワードDisablePrint〕
形式〔暗号化設定ファイルのキーワードOwnerPassword〕
形式〔暗号化設定ファイルのキーワードUserPassword〕
形式〔しおり定義ファイルのキーワードBREAKFLD〕
形式〔しおり定義ファイルのキーワードNAME〕
形式〔文書しおり定義ファイルのキーワードSCALE〕
形式〔文書しおり定義ファイルのキーワードTITLE〕
形式〔文書情報設定ファイルのキーワードAUTHOR〕
形式〔文書情報設定ファイルのキーワードKEYWORD〕
形式〔文書情報設定ファイルのキーワードSUBTITLE〕
形式〔文書情報設定ファイルのキーワードTITLE〕
(こ)
構成定義ファイルの一覧

(サ行)

(さ)
サブ様式グループ
サブ様式グループ番号〔複数様式情報定義ファイル〕
(し)
しおり定義ファイル
しおり定義ファイルのキーワード
しおり定義ファイルの形式
出力先定義ファイル
仕分け定義ファイル
(せ)
制御情報付データファイル
接続情報ファイル

(タ行)

(た)
ダウンロードパッケージ
(ち)
注釈とフォームフィールドの作成〔暗号化設定ファイルのセキュリティ属性〕
帳票サーバに準備するファイルの一覧
帳票サーバプリンタクラス定義ファイル
帳票セット指定ファイル
帳票セット指定ファイルの形式
帳票セットの形式
帳票ファイル
帳票振り分け定義ファイル
(て)
データファイル
テスト印刷設定ファイル

(ナ行)

(な)
内容のコピー，または抽出〔暗号化設定ファイルのセキュリティ属性〕

(ハ行)

(は)
配布用パッケージによるインストールでの使用方法
EUR Web Plug-In
(ひ)
ビューアプレファレンス定義ファイル
(ふ)
ファイルサイズの上限値〔CSV形式（DAT形式）〕
ファイルサイズの上限値〔FIX形式〕
ファイル名に指定できる文字数
ファイル名変数 ,[2]
複数様式情報定義ファイル
複数様式情報定義ファイルのキーワード
プリンタ定義ファイル
プリンタ定義ファイルのキーワード
プリンタ定義ファイルのキーワード一覧
分割定義ファイル
文書しおり定義ファイル
文書しおり定義ファイルのキーワード
文書しおり定義ファイルの形式
文書情報設定ファイル
文書情報設定ファイルのキーワード
文書の変更〔暗号化設定ファイルのセキュリティ属性〕

(ヤ行)

(ゆ)
ユーザ管理ファイル
ユーザパスワード〔暗号化設定ファイルのセキュリティ属性〕
(よ)
様式グループ
様式グループ番号〔複数様式情報定義ファイル〕

(ラ行)

(れ)
レコードの上限値〔CSV形式（DAT形式）〕
レコードの上限値〔FIX形式〕