uCosminexus EUR 帳票出力 EUR Designer/EUR Viewer編 - 目次

uCosminexus EUR 帳票出力 EUR Designer/EUR Viewer編

文法・操作書

3020-7-707

目　　次

前書き
はじめに
1.　帳票出力の概要
1.1　EUR クライアント帳票出力機能とは
1.2　帳票を出力するには
1.2.1　帳票を出力するための準備
1.2.2　帳票をプリンタ出力するには
1.2.3　設計した帳票を印刷するには（EUR Designer）
1.2.4　完成した帳票を印刷するには（EUR Viewer）
1.2.5　帳票をEUR形式ファイルに出力するには
1.3　複数様式で帳票を出力するには
1.3.1　複数様式での帳票出力例
1.4　データベースからデータを入力するには
1.4.1　接続情報ファイル
1.4.2　可変記号値定義ファイル
1.5　帳票出力で使用できるインターフェース
2.　コマンドを使用した帳票出力
2.1　apgrptコマンドから帳票を印刷するには
2.1.1　apgrptコマンドで指定できること
2.1.2　apgrptコマンドからの印刷
2.1.3　apgrptコマンドの形式
2.1.4　オプション記述ファイルの指定
2.1.5　記述例
2.2　eurerコマンドから帳票を印刷するには（Webアプリケーションからの帳票印刷）
2.2.1　eurerコマンドで指定できること
2.2.2　eurerコマンドの実行形態
2.2.3　eurerコマンドの形式
2.2.4　EUR形式ファイルのプロパティ表示
2.3　COBOL言語プログラムから帳票を印刷するには
2.3.1　COBOL言語で帳票を印刷するアプリケーションの開発手順
2.3.2　オプション記述ファイルの指定
2.3.3　COBOL言語のプログラムからの印刷実行
3.　OLEオートメーションを使用した帳票出力
3.1　OLEオートメーションからEURを実行するには
3.1.1　OLEオートメーションで指定できること
3.1.2　EURをOLEオートメーションオブジェクトとして実行するには
3.1.3　OLEオートメーションからの印刷
3.2　OLEオートメーションで使用できるEURのオブジェクト階層
3.3　OLEオートメーションで使用できるプロパティ，メソッド一覧
3.3.1　OLEオートメーションで使用できるプロパティ一覧
3.3.2　OLEオートメーションで使用できるメソッド一覧
3.4　OLEオートメーションで使用できるプロパティ仕様
Applicationプロパティ
CurrentPageプロパティ
DataFileNameプロパティ
DataFileプロパティ
DBInfoFileNameプロパティ
DBInfoFilePathプロパティ
Documentプロパティ
Editableプロパティ
FirstPageNumberプロパティ
FitToWindowプロパティ
FontWidthModeプロパティ
FrontSubWindowプロパティ
FullNameプロパティ
Heightプロパティ
ImageBasePathプロパティ
InitPageNumberプロパティ
LastPageプロパティ
Leftプロパティ
MainWindowStatusプロパティ
MapDataBasePathプロパティ
MappingDataプロパティ
MultiFormInfoDefBasePathプロパティ
MultiFormInfoDefFileプロパティ
MultiReportSetBasePathプロパティ
MultiReportSetFileプロパティ
Nameプロパティ
PageNumberFormatプロパティ
PageNumberLocationプロパティ
PageSetupプロパティ
PaperOrientationプロパティ
Parentプロパティ
Pathプロパティ
PrinterNameプロパティ
PrintFileNameプロパティ
PrintFileOutプロパティ
PrintPageNumberプロパティ
PrintStatusプロパティ
ReportBasePathプロパティ
ReplaceItemCntlFileプロパティ
ReplaceItemCntlFilePathプロパティ
ReplaceItemFilePathプロパティ
ReportTitleプロパティ
Sortingプロパティ
SubWindowStatusプロパティ
Topプロパティ
TrayCodeプロパティ
TraySelectionプロパティ
UserDataBasePathプロパティ
UserDefineDataプロパティ
VarDataFileプロパティ
Visibleプロパティ
Widthプロパティ
WindowStyleプロパティ
Zoomプロパティ
3.5　OLEオートメーションで使用できるメソッド仕様
Activateメソッド
CreateDateメソッド
Importメソッド
Openメソッド
Printメソッド
PrintOutメソッド
Quitメソッド
4.　スタートメニューからのプレビューと出力
4.1　［EURクライアント帳票出力機能］ダイアログを使用したプレビューと帳票出力
4.1.1　データファイルを使用する場合
4.1.2　データベースを使用する場合
4.2　帳票ファイルのダブルクリックによるプレビューと出力
5.　帳票出力で使用するファイル
5.1　ファイルに使用できる文字
5.1.1　ファイル名の制約
5.1.2　入力ファイルに対するエンコーディング
5.1.3　EURで使用できる外字
5.2　帳票ファイル
5.3　データファイル
5.3.1　CSV形式（DAT形式）のデータ形式
5.3.2　FIX形式のデータ形式
5.4　画像ファイル
5.5　プリンタ定義ファイル
5.5.1　プリンタ定義ファイルの作成
5.5.2　プリンタ定義ファイルの構文
5.5.3　プリンタ定義ファイルのキーワード
5.5.4　プリンタ定義ファイルの指定例
5.6　帳票セット指定ファイル
5.6.1　帳票セット指定ファイルの作成
5.6.2　帳票セット指定ファイルの指定例
5.7　複数様式情報定義ファイル
5.7.1　複数様式情報定義ファイルの編集
5.7.2　複数様式情報定義ファイルの指定例
5.8　接続情報ファイル
5.9　可変記号値定義ファイル
5.10　置き換え表管理情報ファイル
5.10.1　置き換え表管理情報ファイルの作成
5.11　置き換え表ファイル
5.11.1　置き換え表ファイルの作成
5.12　オプション記述ファイル
5.12.1　オプション記述ファイルのキーワード
5.12.2　オプション記述ファイルの記述例
5.13　環境設定ファイル
5.13.1　環境設定ファイルの構文
5.13.2　環境設定ファイルの変数
5.13.3　環境設定ファイルの指定例
5.13.4　環境設定ファイルに設定できない変数
6.　帳票出力の互換性
6.1　帳票を出力する場合の注意事項
6.1.1　レポートファイル（*.agr）の扱い
6.1.2　OLE埋め込みオブジェクトが貼り付けられたフォームシートファイルの扱い
6.1.3　データベース連携での帳票出力インターフェース
6.1.4　ディクショナリファイルの扱い
6.2　コマンド構文の互換性
6.2.1　Windows版 EUR旧製品からの互換性
6.2.2　UNIX版 EUR旧製品からの互換性
7.　帳票出力での使用上の注意
7.1　印刷に関する注意
7.1.1　帳票の印刷範囲について
7.1.2　印刷時に使用するデータファイルの注意
7.1.3　出力ページ数の上限値
7.1.4　最上位結合項目を利用する帳票を印刷する場合の注意
7.1.5　バーコードの注意
7.1.6　コマンドに指定したデータの優先順位
7.1.7　データファイルのサイズに関する注意
7.1.8　ユーザ定義サイズを設定した帳票を印刷する場合の注意
7.1.9　帳票設計で使用できるフォント
7.1.10　光学式読み取り装置で帳票を読み取る場合の注意
7.1.11　複数様式の帳票を印刷する場合の注意
7.1.12　データベースからデータを入力する場合に使用できる文字
7.1.13　サービス起動で印刷する場合の注意
7.1.14　日付データ・時刻データを使用するときの注意
7.1.15　非Unicodeアプリケーションを使用する場合の注意
7.1.16　一時フォルダに関する注意
7.2　インストール，アンインストール時の注意
7.2.1　インストール時の注意
7.2.2　アンインストール時の注意
7.2.3　リモートインストール
8.　EUR クライアント帳票出力機能が表示するダイアログ
8.1　［ズーム］ダイアログ
8.2　［オプション］ダイアログ
8.2.1　［表示］タブ
8.2.2　［ファイル］タブ
8.3　［EURログオプションの設定］ダイアログ
8.4　［EURログメンテナンスツール］ダイアログ
8.5　［EURユーザ環境削除］ダイアログ
8.6　［EURクライアント帳票出力機能］ダイアログ
付録
付録A　インストール，アンインストール
付録A.1　インストールの手順
付録A.2　インストール後に作成されるフォルダ
付録A.3　アンインストールの手順
付録B　EURが提供するツール
付録B.1　給紙トレイ一覧ツール
付録B.2　EURログオプション設定ツール
付録B.3　EURログメンテナンスツール
付録B.4　EURユーザ環境削除ツール
付録C　作業環境の言語との対応
付録C.1　表示言語の切り替え
付録C.2　入力ファイルのエンコーディング
付録D　このマニュアルの参考情報
付録D.1　関連マニュアル
付録D.2　EUR バージョン9での製品体系の変更
付録D.3　EUR バージョン9でのマニュアル体系の変更
付録D.4　このマニュアルでの表記
付録D.5　このマニュアルで使用する略語
付録D.6　KB（キロバイト）などの単位表記について
索引

[他社商品名称に関する表示]

All Rights Reserved. Copyright (C) 2014, Hitachi, Ltd.
All Rights Reserved. Copyright (C) 2014, Hitachi Solutions, Ltd.


前書き

■ 対象製品

●適用OS：Windows XP Professional，Windows 7 x86，Windows 7 x64※1，Windows 8 x86※2，Windows 8 x64※1※2

P-2CD2-5694　 uCosminexus EUR Designer　 09-60
P-2CD2-5394　 uCosminexus EUR Viewer　 09-60

注※1
WOW64（Windows On Windows 64）環境だけで使用できます。
注※2
Windows 8 Modern UI designには対応していません。

■ 輸出時の注意

本製品を輸出される場合には、外国為替及び外国貿易法の規制並びに米国輸出管理規則など外国の輸出関連法規をご確認の上、必要な手続きをお取りください。
なお、不明な場合は、弊社担当営業にお問い合わせください。

■ 商標類

Acrobatは，Adobe Systems Incorporated（アドビシステムズ社）の商標です。
AIXは，米国およびその他の国におけるInternational Business Machines Corporationの商標です。
GIFは，米国CompuServe Inc.が開発したフォーマットの名称です。
HP-UXは，Hewlett-Packard Development Company, L.P.のオペレーティングシステムの名称です。
JFIFは，C-Cube Microsystems 社が規定したフォーマットの名称です。
Linuxは，Linus Torvalds氏の日本およびその他の国における登録商標または商標です。
MicrosoftおよびMS-DOSは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
MicrosoftおよびVisual Basicは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
MicrosoftおよびVisual C++は，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
MicrosoftおよびExcelは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
Microsoft Officeは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
Microsoft OfficeおよびExcelは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
Microsoft Office Wordは，米国 Microsoft Corporation の商品名称です。
Microsoft Wordは，米国Microsoft Corporationの商品名称です。
ODBCは，米国Microsoft Corporationが提唱するデータベースアクセス機構です。
OLEは，米国Microsoft Corporationが開発したソフトウェア名称です。
OracleとJavaは，Oracle Corporation 及びその子会社，関連会社の米国及びその他の国における登録商標です。
QRコードは，株式会社デンソーウェーブの登録商標です。
TrueTypeは，米国Apple Computer, Inc.の商品名称です。
UNIXは，The Open Groupの米国ならびに他の国における登録商標です。
Windowsは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

■ マイクロソフト製品の表記について

このマニュアルでは，マイクロソフト製品の名称を次のように表記しています。
表記 | 製品名称
Excel Microsoft(R) Excel Version 2002
Microsoft(R) Office Excel 2003
Microsoft(R) Office Excel 2007
Microsoft(R) Office Excel 2010
SQL Server Microsoft(R) SQL Server 2005
Microsoft(R) SQL Server 2008
Microsoft(R) SQL Server 2008 R2
Microsoft(R) SQL Server 2012
Visual Basic | Microsoft(R) Visual Basic(R)
Visual C++ | Microsoft(R) Visual C++(R)
Windows Windows 7 Windows 7 x86 Microsoft(R) Windows(R) 7 Professional(32ビット版)
Microsoft(R) Windows(R) 7 Enterprise(32ビット版)
Microsoft(R) Windows(R) 7 Ultimate(32ビット版)
Windows 7 x64 Microsoft(R) Windows(R) 7 Professional(64ビット版)
Microsoft(R) Windows(R) 7 Enterprise(64ビット版)
Microsoft(R) Windows(R) 7 Ultimate(64ビット版)
Windows 8 Windows 8 x86 Windows(R) 8 Pro(32ビット版)
Windows(R) 8 Enterprise(32ビット版)
Windows 8 x64 Windows(R) 8 Pro(64ビット版)
Windows(R) 8 Enterprise(64ビット版)
Windows XP | Microsoft(R) Windows(R) XP Professional Operating System
Word Microsoft(R) Word Version 2002
Microsoft(R) Office Word 2003
Microsoft(R) Office Word 2007
Microsoft(R) Office Word 2010

■ 発行

2014年1月　3020-7-707

■ 著作権

All Rights Reserved. Copyright (C) 2014, Hitachi, Ltd.
All Rights Reserved. Copyright (C) 2014, Hitachi Solutions, Ltd.

[目次][前へ][次へ]


他社商品名称に関する表示

■ 商標類

Acrobatは，Adobe Systems Incorporated（アドビシステムズ社）の商標です。
AIXは，米国およびその他の国におけるInternational Business Machines Corporationの商標です。
GIFは，米国CompuServe Inc.が開発したフォーマットの名称です。
HP-UXは，Hewlett-Packard Development Company, L.P.のオペレーティングシステムの名称です。
JFIFは，C-Cube Microsystems 社が規定したフォーマットの名称です。
Linuxは，Linus Torvalds氏の日本およびその他の国における登録商標または商標です。
MicrosoftおよびMS-DOSは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
MicrosoftおよびVisual Basicは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
MicrosoftおよびVisual C++は，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
MicrosoftおよびExcelは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
Microsoft Officeは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
Microsoft OfficeおよびExcelは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
Microsoft Office Wordは，米国 Microsoft Corporation の商品名称です。
Microsoft Wordは，米国Microsoft Corporationの商品名称です。
ODBCは，米国Microsoft Corporationが提唱するデータベースアクセス機構です。
OLEは，米国Microsoft Corporationが開発したソフトウェア名称です。
OracleとJavaは，Oracle Corporation 及びその子会社，関連会社の米国及びその他の国における登録商標です。
QRコードは，株式会社デンソーウェーブの登録商標です。
TrueTypeは，米国Apple Computer, Inc.の商品名称です。
UNIXは，The Open Groupの米国ならびに他の国における登録商標です。
Windowsは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

[目次]


はじめに

このマニュアルは，次に示すプログラムプロダクトを使用して，Windows(R)環境で設計した帳票を出力する方法について説明したものです。

  • uCosminexus EUR Designer
  • uCosminexus EUR Viewer
＜はじめにの構成＞
対象読者
このマニュアルで使用する記号

対象読者

このマニュアルは，Windows環境で設計した帳票を，プログラムから出力する方を対象としています。

また，次に示す内容を理解されていることを前提としています。

  • Windowsの基本操作
  • マニュアル「uCosminexus EUR システム設計ガイド」に示すEURの製品の特徴および使用目的

このマニュアルで使用する記号

このマニュアルで使用する記号について，次に示します。

記号 意　　味
｜ 横に並べられた複数の項目に対する項目間の区切りを示し，「または」を意味します。
（例）A｜B
「A，またはBを指定する」ことを示します。
｛　｝ この記号で囲まれている複数の項目のうちから一つを選択することを示します。項目が横に並べられ，記号｜で区切られている場合は，そのうちの一つを選択します。
（例）｛A｜B｜C｝
「A，B，またはCのどれかを指定する」ことを示します。
〔　〕 この記号で囲まれている項目は省略してもよいことを示します。複数の項目が横に並べて記述されている場合には，すべてを省略するか，記号｛　｝と同じくどれか一つを選択します。
（例）〔A〕
「何も指定しない」か「Aと指定する」ことを示します。
（例）〔B｜C〕
「何も指定しない」か「B，またはCのどちらかを指定する」ことを示します。
＿ 括弧で囲まれた複数項目のうち1項目に対し使用され，括弧内のすべてを省略したときシステムがとる標準値を示します。
（例）〔A｜B｜C〕
「A，B，Cのどれも指定しなかった場合，システムはCが指定されたときと同じ処理をする」ことを示します。


帳票出力の概要

1.　帳票出力の概要

この章では，EUR クライアント帳票出力機能の概要について説明します。

また，EUR クライアント帳票出力機能で帳票を出力する流れについても説明します。

＜この章の構成＞
1.1　EUR クライアント帳票出力機能とは
1.2　帳票を出力するには
1.3　複数様式で帳票を出力するには
1.4　データベースからデータを入力するには
1.5　帳票出力で使用できるインターフェース


EUR クライアント帳票出力機能とは

1.1　EUR クライアント帳票出力機能とは

EUR クライアント帳票出力機能は，EUR 帳票作成機能で設計した帳票ファイルと，帳票出力に必要なデータファイルから，帳票を設計した環境およびクライアント環境で帳票を出力する機能です。帳票のデータは，各環境で準備したデータと入れ替えて出力できます。

EUR 帳票作成機能で設計した帳票をプリンタに出力できます
帳票を出力する場合は，帳票の内容を画面で確認することもできます。この形式で出力する場合は，帳票を設計するEUR 帳票作成機能や，帳票を表示・印刷するEUR クライアント帳票出力機能を使用します。
また，EUR サーバ帳票出力機能で出力されたEUR形式ファイル（EURの独自形式の印刷データファイル）を表示・印刷する場合は，EUR クライアント帳票出力機能を使用します。

EUR サーバ帳票出力機能を使用したサーバ環境での帳票出力方法については，マニュアル「EUR 帳票出力 機能解説 EUR Server編」およびマニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。


帳票を出力するには

1.2　帳票を出力するには

EUR クライアント帳票出力機能で帳票を出力するための手順を示します。

＜この節の構成＞
1.2.1　帳票を出力するための準備
1.2.2　帳票をプリンタ出力するには
1.2.3　設計した帳票を印刷するには（EUR Designer）
1.2.4　完成した帳票を印刷するには（EUR Viewer）
1.2.5　帳票をEUR形式ファイルに出力するには


帳票を出力するための準備

1.2.1　帳票を出力するための準備

EUR クライアント帳票出力機能を使うと，クライアントPCのプリンタで印刷できます。

なお，一つの帳票に複数の様式を使用する場合は，準備作業が必要になります。帳票様式を決定するまでの流れを次に示します。

（凡例）
[図データ] ：帳票様式に応じて，コマンドまたは業務アプリケーションで設定する機能を示します。
注※
複数様式の出力については，「5.7　複数様式情報定義ファイル」を参照してください。

このフローで決定した機能を使って帳票を出力するには，コマンドまたは業務アプリケーションを使用します。使用できるコマンドまたは業務アプリケーションを次の表に示します。

表1-1　帳票を出力する方法

帳票出力の方法 | 説明 | 参照先
apgrptコマンドからの帳票出力 | アプリケーションなどの運用ツールから実行する場合，コマンドインターフェースを使用できます。 | 「2. コマンドを使用した帳票出力」
OLEオートメーションを使用した帳票出力 | OLEオートメーションを使用して帳票を出力できます。 | 「3. OLEオートメーションを使用した帳票出力」


帳票をプリンタ出力するには

1.2.2　帳票をプリンタ出力するには

EUR クライアント帳票出力機能での帳票出力は，プリンタなどと組み合わせられます。また，異なる様式の帳票や出力データが異なる帳票を，1セットとして出力する「複数様式出力」などができます。

帳票を出力する手順を次に示します。

図1-1　帳票をプリンタ出力するときの処理の流れ

注※1
EUR 帳票作成機能で設計した帳票を印刷する方法については，「1.2.3　設計した帳票を印刷するには（EUR Designer）」を参照してください。
注※2
完成した帳票を印刷する方法については，「1.2.4　完成した帳票を印刷するには（EUR Viewer）」を参照してください。
  1. 帳票ファイルの準備（帳票設計）
    EUR 帳票作成機能で帳票を設計して，帳票ファイル（*.fms）に保存します。
    設計中の帳票を印刷する場合や画面に表示された帳票を印刷する場合は，EUR 帳票作成機能の印刷機能で出力します。
  2. 業務を実行するクライアント環境への帳票ファイルの配布
    帳票を使用するクライアントに帳票ファイルを配布します。
  3. データファイルの準備
    帳票として出力するデータを，CSV形式（DAT形式）またはFIX形式のファイルで準備します。
  4. 帳票出力
    配布された帳票ファイルに準備したデータファイルを読み込んで，帳票を出力します。


設計した帳票を印刷するには（EUR Designer）

1.2.3　設計した帳票を印刷するには（EUR Designer）

EUR DesignerのEUR クライアント帳票出力機能では，次に示す帳票出力ができます。

  • 設計中の帳票を出力する
  • 帳票のデータを入れ替えて出力する
  • ほかのアプリケーションからEUR DesignerのEUR クライアント帳票出力機能を呼び出して帳票を出力する

設計中の帳票を印刷する場合や画面に表示された帳票を印刷する場合は，［ファイル］メニューの［印刷］を選択します。

ほかのアプリケーション（Visual Basic，Excel，Visual C++，COBOLなど）からEUR DesignerのEUR クライアント帳票出力機能を呼び出すには，EURで提供している次のインターフェースを使用します。設計した帳票のデータの入れ替えから表示，出力までの作業をアプリケーションプログラムで作成すると，効率の良い帳票出力ができます。

  • apgrptコマンド
  • OLEオートメーション

EUR DesignerのEUR 帳票作成機能およびEUR クライアント帳票出力機能を使用したアプリケーションの運用例を次に示します。この運用例は，EUR Designerとプリンタで構成する基本的なものです。

図1-2　EUR Designerを使用したアプリケーションの運用例

  1. 帳票ファイルの準備
    EUR クライアント帳票出力機能で帳票を設計して，帳票ファイル（*.fms）に保存します。
  2. データファイルの準備
    帳票として出力するデータのデータファイルを準備します。データファイルの形式は，「5.3　データファイル」を参照してください。データベースから直接データを読み込む方法については，マニュアル「EUR データベース連携ガイド」を参照してください。
  3. 帳票出力
    帳票ファイルと準備したデータファイルを指定して，帳票出力を実行します。設計中の帳票を印刷する場合や画面に表示された帳票を印刷する場合は，［ファイル］メニューの［印刷］を選択します。


完成した帳票を印刷するには（EUR Viewer）

1.2.4　完成した帳票を印刷するには（EUR Viewer）

EUR ViewerのEUR クライアント帳票出力機能では，次に示す帳票出力ができます。

  • 帳票のデータを入れ替えて出力する
  • ほかのアプリケーションからEUR ViewerのEUR クライアント帳票出力機能を呼び出して帳票を出力する

ほかのアプリケーション（Visual Basic，Excel，Visual C++，COBOLなど）からEUR ViewerのEUR クライアント帳票出力機能を呼び出すには，EURで提供している次のインターフェースを使用します。設計した帳票のデータの入れ替えから表示，出力までの作業をアプリケーションプログラムで作成すると，効率の良い帳票出力ができます。

  • apgrptコマンド
  • OLEオートメーション

EUR ViewerのEUR クライアント帳票出力機能を使用したアプリケーションの運用例を次に示します。

図1-3　EUR ViewerのEUR クライアント帳票出力機能を使用したアプリケーションの運用例

  1. 帳票ファイルの準備
    EUR 帳票作成機能で帳票を設計して，帳票ファイル（*.fms）に保存します。
  2. 帳票ファイルの配布
    帳票ファイルを，業務を実行するクライアントのPCに配布します。帳票を印刷する環境をそろえたい場合は，帳票ファイルのほかに，オプション記述ファイルおよびプリンタ定義ファイルも配布します。
  3. データファイルの準備
    帳票として出力するデータのデータファイルを準備します。データファイルの形式は，「5.3　データファイル」を参照してください。データベースから直接データを読み込む方法については，マニュアル「EUR データベース連携ガイド」を参照してください。
  4. 帳票出力
    出力する帳票の帳票ファイルと準備したデータファイルを指定して，帳票出力を実行します。


帳票をEUR形式ファイルに出力するには

1.2.5　帳票をEUR形式ファイルに出力するには

EUR形式ファイルは，EURの独自形式の印刷データファイルです。帳票定義ファイルとデータファイル（マッピングデータファイル，ユーザ定義データファイル，および画像ファイル）を一つのパッケージにしたファイルで，PDF形式よりもサイズが小さく，ネットワーク負荷を軽減できます。1ファイルにまとめているので，Webシステムなどで帳票を利用するときに便利です。

EUR形式ファイルは，EUR Server EnterpriseまたはEUR Server StandardのEUR サーバ帳票出力機能で出力します。出力したEUR形式ファイルを表示・印刷するには，EUR クライアント帳票出力機能を使用します。

EUR クライアント帳票出力機能を起動して帳票を表示するには，次の2とおりの方法があります。

  • eurerコマンド
    EUR形式ファイルを指定して実行すると，EUR クライアント帳票出力機能が起動されて帳票が表示されます。Webクライアント環境では，EUR クライアント帳票出力機能をブラウザのヘルパアプリケーションとして実行します。
  • EUR形式ファイルをダブルクリックして起動
    エクスプローラでEUR形式ファイルをダブルクリックすると，EUR クライアント帳票出力機能が起動して帳票が表示されます。

帳票をEUR形式ファイルへ出力することによるアプリケーションの運用例を次に示します。

図1-4　帳票をEUR形式ファイルに出力するときの流れ

  1. 帳票ファイルの準備
    EUR 帳票作成機能で帳票を設計して，帳票ファイル（*.fms）に保存します。
  2. 帳票ファイルの転送
    帳票ファイルを，EUR Server EnterpriseまたはEUR Server Standardが組み込まれているアプリケーションサーバに転送します。
  3. データファイルの準備
    帳票として出力するデータのデータファイルを準備します。データファイルの形式は，「5.3　データファイル」を参照してください。データベースから直接データを読み込む方法については，マニュアル「EUR データベース連携ガイド」を参照してください。
  4. EUR形式ファイルへの出力
    出力する帳票の帳票ファイルと準備したデータファイルを指定して，EUR形式ファイルへの出力を実行します。EUR形式ファイルへの出力方法については，マニュアル「EUR 帳票出力 機能解説 EUR Server編」およびマニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。
  5. EUR形式ファイルの表示・印刷
    EUR形式ファイルは，クライアントPC上のEUR クライアント帳票出力機能で表示・印刷します。


複数様式で帳票を出力するには

1.3　複数様式で帳票を出力するには

EUR クライアント帳票出力機能では，複数の異なる様式（帳票）を一つの帳票として出力できます。これを「複数様式で帳票を出力する」といいます。

複数様式で帳票を出力するときは，複数の帳票ファイル，帳票セット指定ファイルおよび複数様式情報定義ファイルを準備します。

複数様式で帳票を出力する流れを次に示します。

図1-5　複数様式で帳票を出力するときの処理の流れ

  1. 帳票ファイルの作成
    帳票を設計して，フォームシートファイル（*.fms）で保存します。
    複数様式で帳票を出力できるファイルの種類は，フォームシートファイル（*.fms）です。
    複数様式で出力するときの帳票は，一組にする帳票すべてを同じキーフィールドで改ページするように設定してください。ただし，帳票ヘッダのある帳票は，複数様式では出力できません。
  2. データファイルの準備
    出力するデータファイルを準備します。
    n様式とn様式を組み合わせて一組の帳票に出力するときは，n様式ごとのデータファイルを準備します。
  3. 帳票セット指定ファイルの作成
    帳票セット指定ファイルは，複数の帳票ファイルを統合する順番と帳票に読み込むデータファイルを指定しておくファイルです。帳票セット指定ファイルについては，「5.6　帳票セット指定ファイル」を参照してください。
  4. 複数様式情報定義ファイルの作成
    複数様式情報定義ファイルには，異なった様式（帳票）をグルーピングした様式グループを切り替える条件と，切り替え時の動作を指定します。一つの様式グループの中でさらに様式（帳票）をグルーピングする（サブ様式グループ）こともできます。
    複数様式情報定義ファイルについては，「5.7　複数様式情報定義ファイル」を参照してください。
  5. 帳票出力
    複数様式で帳票を出力するためのインターフェースは次のとおりです。
    インターフェース 指定方法 参照先
    apgrptコマンド apgrptコマンドのオプションに次のどちらかを指定
    • /mrsオプションおよび/mfdオプション
    • /kオプション（オプション記述ファイルにキーワードMultiReportSetFileおよびキーワードMultiFormInfoDefFileを指定）
             「2.1.3　apgrptコマンドの形式」
    OLEオートメーション Applicationオブジェクトに次のプロパティを指定
    • MultiReportSetFileプロパティ
    • MultiFormInfoDefFileプロパティ
             「3.4　OLEオートメーションで使用できるプロパティ仕様」
＜この節の構成＞
1.3.1　複数様式での帳票出力例


複数様式での帳票出力例

1.3.1　複数様式での帳票出力例

EURで提供しているサンプルを使用して，複数様式での帳票出力例を示します。

サンプルは，次に示すフォルダに格納されています。

  • サンプル帳票（フォームシートファイル（*.fms）とCSV形式のデータファイル（*.csv））が格納されているフォルダ

EUR Designerのインストール先フォルダ\Sample\Reports

  • サンプル帳票セット指定ファイル（*.txt）およびサンプル複数様式情報定義ファイル（*.txt）が格納されているフォルダ

EUR Designerのインストール先フォルダ\Sample\Reports\Multiform

＜この項の構成＞
(1)　サンプル帳票「請求書」の場合
(2)　サンプル帳票「従業員勤務歴カード」の場合
(3)　サンプル帳票「保険申込書」の場合

(1)　サンプル帳票「請求書」の場合

「請求書」は，「表紙次紙形式の帳票＿表紙」と「表紙次紙形式の帳票＿次紙」の2様式を一組にして出力します。

サンプル帳票「請求書」を出力したときの一組の出力例を次に示します。

図1-6　サンプル帳票「請求書.fms」の出力例（1ページ目）

図1-7　サンプル帳票「請求書.fms」の出力例（2ページ目）

「表紙次紙形式の帳票＿表紙」は必ず出力しますが，「表紙次紙形式の帳票＿次紙」は，「表紙次紙形式の帳票＿表紙」に納まらなかったデータを出力します。請求先のデータが変わるまで「表紙次紙形式の帳票＿次紙」に出力します。請求先のデータが変わった時点で「表紙次紙形式の帳票＿表紙」に戻ります。

ページ番号は，2様式を通して請求先ごとのページ番号（n/m形式）を出力します。請求先のデータが変わった時点で，「表紙次紙形式の帳票＿表紙」は「1/m」に初期化されます。

(a)　サンプル帳票「請求書」を出力する手順

サンプル帳票「請求書」を出力する手順を次に示します。

  1. 帳票ファイルの作成
    帳票ファイルは，「表紙次紙形式の帳票＿表紙」と「表紙次紙形式の帳票＿次紙」の2様式を作成して，フォームシートファイル（*.fms）で保存します。

    二つの帳票は，フィールド「請求書番号」をキーにして改ページするように設定します。
    改ページの設定では，キーとなるフィールドのデータが変わった時点で，ページ番号を開始番号に初期化するか，またはキーとなるフィールドのデータが変わっても，通し番号でページ番号を印刷するかを設定できますが，この設定はどちらでもかまいません。ページ番号を初期化するかどうかは，複数様式情報定義ファイルのページ番号リセット属性（resetpagenumber）の設定が優先されます。
  2. データファイルの準備
    「表紙次紙形式の帳票＿表紙（複数様式帳票例１）.csv」を「表紙次紙形式の帳票＿表紙」と「表紙次紙形式の帳票＿次紙」で共有します。

  3. 帳票セット指定ファイルの作成
    サンプル帳票セット指定ファイル（formset01（複数様式帳票例１）.txt）の内容を次に示します。
    表紙次紙形式の帳票＿表紙（複数様式帳票例１）.fms,表紙次紙形式の帳票＿表紙（複数様式帳票例１）.csv
    表紙次紙形式の帳票＿次紙（複数様式帳票例１）.fms,表紙次紙形式の帳票＿表紙（複数様式帳票例１）.csv
  4. 複数様式情報定義ファイルの作成
    様式グループが一つなので，様式グループ遷移条件（grouptransfercondition）は省略します。
    「表紙次紙形式の帳票＿表紙」は必ず出力します。「表紙次紙形式の帳票＿次紙」は，「表紙次紙形式の帳票＿表紙」に納まらなかったデータがあるときに出力します。様式間遷移条件（formtransfercondition）で，フィールド「請求書番号」がキーブレイクしたら「表紙次紙形式の帳票＿表紙」に戻るように指定します。
    サンプル複数様式情報定義ファイル（formdef01（複数様式帳票例１）.txt）の内容を次に示します。

group 1 {
 formtransfercondition {
   keybreaktopform=ON        …フィールド「請求書番号」が
                               キーブレイクしたら，
                               先頭の様式（表紙）に戻ります
                               このとき，ページ番号を
                               初期化します
   fieldname="請求書番号"
 }
 formfilename "表紙次紙形式の帳票＿表紙（複数様式帳票例１）.fms" {
   transfercondition=NPNF        …表紙を1ページ出力すると
                                   次紙に移ります
   printnewpaper=OFF  ※
   resetpagenumber=ON        …次紙から表紙に戻ったとき，
                               ページ番号を初期化します
 }
 formfilename "表紙次紙形式の帳票＿次紙（複数様式帳票例１）.fms" {
   transfercondition=KBNF      …キーブレイクしたら，
                                 表紙に戻るようにします
   printnewpaper=OFF
   resetpagenumber=OFF         …表紙からの続きのページ番号を
                                 出力します
 }
}
    注※
    両面印刷する場合，「表紙次紙形式の帳票＿表紙」を必ず表面に印刷したいときは，次のように指定してください。「表紙次紙形式の帳票＿次紙」に出力するデータがない場合は，裏面を白紙にします。
    printnewpaper = ON
    サンプル「請求書」を両面印刷したときの，出力例を次に示します。

    図1-8　サンプル帳票「請求書.fms」の両面印刷時の出力例

  5. 帳票出力
    apgrptコマンド構文の例を示します。

apgrpt /l print
       /mrs "C:\TEMP\formset01（複数様式帳票例１）.txt"
       /mfd "C:\TEMP\formdef01（複数様式帳票例１）.txt"
■補足説明
複数様式で出力する「表紙次紙形式の帳票」は，「表紙」と「次紙」を異なる二つの様式を一組の帳票として出力できます。
帳票ヘッダ領域のある「表紙のある帳票」は，「表紙ページ」と「次紙ページ」で一つの様式の帳票です。そのため，表紙ページの繰り返し領域に貼り付けたデータの続きを次紙ページに出力できますが，次紙ページのページ上端やページ下端にアイテムを作成したり，貼り付けたりすることはできません。

(2)　サンプル帳票「従業員勤務歴カード」の場合

「従業員勤務歴カード」は，「従業員勤務歴カード［I］」と「従業員勤務歴カード［I］（続き）」の2様式と，「従業員勤務歴カード［II］」の1様式を合わせて一組にして出力します。

サンプル帳票「従業員勤務歴カード」を出力したときの一組の出力例を次に示します。

図1-9　サンプル帳票「従業員勤務歴カード［I］」の出力例

図1-10　サンプル帳票「従業員勤務歴カード［I］（続き）」の出力例

図1-11　サンプル帳票「従業員勤務歴カード［II］」の出力例

サンプル帳票「従業員勤務歴カード」は，従業員番号ごとに一組の帳票を出力します。

「従業員勤務歴カード［I］」は必ず出力しますが，「従業員勤務歴カード［I］（続き）」は，「従業員勤務歴カード［I］」に納まらなかったデータを出力します。従業員番号のデータが変わったとき，「従業員勤務歴カード［II］」の様式に移るようにします。「従業員勤務歴カード［II］」の出力で従業員番号のデータが変わった時点で「従業員勤務歴カード［I］」に戻ります。

ページ番号は，3様式を通して従業員番号ごとのページ番号（n/m形式）を出力します。従業員番号のデータが変わった時点で，「従業員勤務歴カード［I］」は「1/m」に初期化されます。

(a)　サンプル帳票「従業員勤務歴カード」を出力する手順

サンプル帳票「従業員勤務歴カード」を出力する手順を次に示します。

  1. 帳票ファイルの作成
    帳票ファイルは，「従業員勤務歴カード［I］」，「従業員勤務歴カード［I］（続き）」，および「従業員勤務歴カード［II］」の3様式を作成して，フォームシートファイル（*.fms）で保存します。

    図1-12　従業員勤務歴１（複数様式帳票例２）.fmsの出力例

    図1-13　従業員勤務歴１－次紙（複数様式帳票例２）.fmsの出力例

    図1-14　従業員勤務歴２（複数様式帳票例２）.fmsの出力例

    三つの帳票は，フィールド「従業員番号」をキーにして改ページするように設定します。
    改ページの設定では，キーとなるフィールドのデータが変わった時点で，ページ番号を開始番号に初期化するか，またはキーとなるフィールドのデータが変わっても，通し番号でページ番号を印刷するかを設定できますが，この設定はどちらでもかまいません。ページ番号を初期化するかどうかは，複数様式情報定義ファイルのページ番号リセット属性（resetpagenumber）の設定が優先されます。
  2. データファイルの準備
    n様式とn様式を組み合わせて一組の帳票に出力するには，n様式ごとのデータファイルを準備します。
    「従業員勤務歴１（複数様式帳票例２）.csv」は，「従業員勤務歴カード［I］」と「従業員勤務歴カード［I］（続き）」で共有します。

    「従業員勤務歴２（複数様式帳票例２）.csv」は，「従業員勤務歴カード［II］」で使用します。

  3. 帳票セット指定ファイルの作成
    サンプル帳票セット指定ファイル（formset02（複数様式帳票例２）.txt）の内容を次に示します。
    従業員勤務歴１（複数様式帳票例２）.fms,従業員勤務歴１（複数様式帳票例２）.csv
    従業員勤務歴１－次紙（複数様式帳票例２）.fms,従業員勤務歴１（複数様式帳票例２）.csv
    従業員勤務歴２（複数様式帳票例２）.fms,従業員勤務歴２（複数様式帳票例２）.csv
  4. 複数様式情報定義ファイルの作成
    「従業員勤務歴カード［I］」と「従業員勤務歴カード［I］（続き）」の2様式で一つの様式グループ，「従業員勤務歴カード［II］」の1様式で一つの様式グループにします。
    「従業員勤務歴カード［I］」と「従業員勤務歴カード［I］（続き）」の様式グループと，「従業員勤務歴カード［II］」の様式グループを順に出力するので，様式間遷移条件（formtransfercondition）の指定は省略します。
    様式グループ間は，フィールド「従業員番号」がキーブレイクしたら，様式グループに指定されている様式（帳票）が出力されるように，様式グループ遷移条件（grouptransfercondition）に「transfercondition=KBNF」を指定します。
    この指定によって，次のように帳票が出力されます。

    図1-15　サンプル帳票「従業員勤務歴カード」を印刷した場合の出力例

    サンプル複数様式情報定義ファイル（formdef02（複数様式帳票例２）.txt）の内容を次に示します。

group 1 {           …「従業員勤務歴カード［I］」と，
                      「従業員勤務歴カード［I］（続き）」の
                      様式グループです
 grouptransfercondition {
    transfercondition=KBNF      …二つの様式は，
                                  フィールド「従業員番号」が
                                  キーブレイクしたら，
                                  様式を切り替えます
    fieldname="従業員番号"
 }
 formfilename "従業員勤務歴１（複数様式帳票例２）.fms" {
   transfercondition=NPNF
                         …従業員勤務歴１が出力されると
                           次紙に移ります
                           次紙を出力しないで済む場合は
                           group 2の従業員勤務歴２に移ります
   printnewpaper=OFF  ※
   resetpagenumber=ON        …従業員勤務歴１を出力するときは，
                               ページ番号を初期化します
 }
 formfilename "従業員勤務歴１－次紙（複数様式帳票例２）.fms" {
   transfercondition=KBNF      …フィールド「従業員番号」が
                                 キーブレイクしたら，
                                 従業員勤務歴２に移ります
   printnewpaper=OFF
   resetpagenumber=OFF       …従業員勤務歴１からの
                               続きのページ番号を出力します
 }
}
group 2 {                   …「従業員勤務歴カード［II］」の
                              様式グループです
 grouptransfercondition {
    transfercondition=KBNF   …フィールド「従業員番号」が
                               キーブレイクしたら，group 1の
                               従業員勤務歴１に戻ります
    fieldname="従業員番号"
 }
 formfilename "従業員勤務歴２（複数様式帳票例２）.fms" {
   transfercondition=KBNF
   printnewpaper=OFF
   resetpagenumber=OFF     …従業員勤務歴１，または次紙からの
                             続きのページ番号を出力します
 }
}
    注※
    両面印刷する場合，「従業員勤務歴カード［I］」を必ず表面に印刷したいときは，次のように指定してください。
    printnewpaper = ON
    サンプル「従業員勤務歴カード」を両面印刷したときの，出力例を次に示します。

    図1-16　サンプル帳票「従業員勤務歴カード」を両面印刷した場合の出力例

  5. 帳票出力
    apgrptコマンド構文の例を示します。

apgrpt /l print
       /mrs "C:\TEMP\formset02（複数様式帳票例２）.txt"
       /mfd "C:\TEMP\formdef02（複数様式帳票例２）.txt"

(3)　サンプル帳票「保険申込書」の場合

「保険申込書」は，「保険申込書」，「保険申込書＿代理店控」，および「保険申込書＿契約者控」の3様式を一組の連票形式にして出力します。

サンプル帳票「保険申込書」を出力したときの一組の出力例を次に示します。

図1-17　サンプル帳票「保険申込書」の出力例

図1-18　サンプル帳票「保険申込書＿代理店控」の出力例

図1-19　サンプル帳票「保険申込書＿契約者控」の出力例

サンプル帳票「保険申込書」は，契約者ごとに一組の帳票を出力します。「保険申込書」，「保険申込書＿代理店控」，「保険申込書＿契約者控」の順に一組の帳票を出力したあと，次の契約者の帳票を出力します。

ページ番号は，3様式を通して契約者ごとのページ番号（n/m形式）を出力します。契約者のデータが変わった時点で，「保険申込書」は「1/3」に初期化されます。

(a)　サンプル帳票「保険申込書」を出力する手順

サンプル帳票「保険申込書」を出力する手順を次に示します。

  1. 帳票ファイルの作成
    帳票ファイルは，「保険申込書」，「保険申込書＿代理店控」，および「保険申込書＿契約者控」の3様式を作成して，フォームシートファイル（*.fms）で保存します。

    図1-20　保険申込書（複数様式帳票例3）.fmsの出力例

    図1-21　保険申込書＿代理店控（複数様式帳票例3）.fmsの出力例

    図1-22　保険申込書＿契約者控（複数様式帳票例3）.fmsの出力例

    三つの帳票は，フィールド「契約者管理ID」をキーにして改ページするように設定します。
    改ページの設定では，ページ番号について次の2種類のうちどちらかを設定できます。どちらを設定してもかまいません。
    • キーとなるフィールドのデータが変わった時点で，ページ番号を開始番号に初期化する
    • キーとなるフィールドのデータが変わっても，通し番号でページ番号を印刷する
    ページ番号を初期化するかどうかは，複数様式情報定義ファイルのページ番号リセット属性（resetpagenumber）の設定が優先されます。
  2. データファイルの準備
    「保険申込書（複数様式帳票例３）.csv」を，「保険申込書」，「保険申込書＿代理店控」，および「保険申込書＿契約者控」で共有します。
    1レコードが1契約者のデータになっています。

  3. 帳票セット指定ファイルの作成
    サンプル帳票セット指定ファイル（formset03（複数様式帳票例３）.txt）の内容を次に示します。
    保険申込書（複数様式帳票例３）.fms,保険申込書（複数様式帳票例３）.csv
    保険申込書＿代理店控（複数様式帳票例３）.fms,保険申込書（複数様式帳票例３）.csv
    保険申込書＿契約者控（複数様式帳票例３）.fms,保険申込書（複数様式帳票例３）.csv
  4. 複数様式情報定義ファイルの作成
    「保険申込書」は，「保険申込書」，「保険申込書＿代理店控」，および「保険申込書＿契約者控」の３様式を一組の連票形式にして出力します。
    データファイルは一つですが，様式ごとにレコードのデータを読み込むので，様式グループは三つになります。
    様式グループは三つですが，3様式を必ず出力するので，様式グループ遷移条件（grouptransfercondition）の指定は省略します。
    1様式グループ1様式であることと，フィールド「契約者管理ID」がキーブレイクしたら次の様式グループに移るように指定するので，様式間遷移条件（formtransfercondition）の指定は省略します。
    サンプル複数様式情報定義ファイル（formdef03（複数様式帳票例３）.txt）の内容を次に示します。

group 1 {
 formfilename "保険申込書（複数様式帳票例３）.fms" {
   transfercondition=KBNF     …キーブレイクしたら，
                                group 2の代理店控に移ります
   printnewpaper=OFF
   resetpagenumber=ON        …保険申込書を出力するときは，
                               ページ番号を初期化します
 }
}
group 2 {
 formfilename "保険申込書＿代理店控（複数様式帳票例３）.fms" {
   transfercondition=KBNF    …キーブレイクしたら，
                               group 3の契約者控に移ります
   printnewpaper=OFF
   resetpagenumber=OFF     …前の様式からの続きのページ番号を
                             出力します
 }
}
group 3 {
 formfilename "保険申込書＿契約者控（複数様式帳票例３）.fms" {
   transfercondition=KBNF   …キーブレイクしたら，
                              group 1の保険申込書に戻ります
   printnewpaper=OFF
   resetpagenumber=OFF     …前の様式からの続きのページ番号を
                             出力します
 }
}
  5. 帳票出力
    apgrptコマンド構文の例を示します。

apgrpt /l print
       /mrs "C:\TEMP\formset03（複数様式帳票例３）.txt"
       /mfd "C:\TEMP\formdef03（複数様式帳票例３）.txt"


データベースからデータを入力するには

1.4　データベースからデータを入力するには

EURで帳票を出力する際，データベースからデータを入力できます。

EUR DesignerのEUR 帳票作成機能と，EUR ViewerのEUR クライアント帳票出力機能とでは，データベースへの接続方法が異なります。この節では，EUR クライアント帳票出力機能からデータベースに接続する方法について説明します。EUR 帳票作成機能から接続する方法については，マニュアル「EUR データベース連携ガイド」を参照してください。

EURからアクセスできるデータベースと，英語，中国語ロケールでの使用可否を次に示します。

データベース | 英語，中国語ロケールでの使用可否
HiRDB | ×
Oracle | ○
SQL Server | ×
（凡例）
○：使用できます
×：使用できません

システム管理者は，DABroker※を使用して，データベースに接続するためのデータソースや，データベースに初めて接続する前に，接続に必要な環境を設定します。データベースの接続設定については，マニュアル「EUR データベース連携ガイド」を参照してください。

注※
DABrokerは，EUR DesignerおよびEUR Viewerに同梱されていません。別途購入が必要です。

データベースからデータを入力する手順を次に示します。

図1-23　データベースからデータを入力する手順

  1. 帳票ファイルの配布
    帳票を使用するクライアントに帳票ファイルを配布します。
  2. データベースの接続
    データベースに接続します。EUR クライアント帳票出力機能の1回の実行で接続できるデータベースは一つだけです。
  3. データの抽出
    データベースからデータを抽出します。
  4. 帳票出力
    配布された帳票ファイルに抽出したデータを読み込んで，帳票を出力します。

データの入力元としてCSV形式のデータファイルを使用する場合とは異なり，データベースに接続してデータを取得します。データベースからデータを入力するには，次に示す両方のファイルの指定が必要です。

  • 接続情報ファイル
  • 可変記号値定義ファイル

ただし，すべての帳票セットのマッピングデータおよびユーザ定義データの入力元として指定できるデータベースは，一つだけです。

＜この節の構成＞
1.4.1　接続情報ファイル
1.4.2　可変記号値定義ファイル


接続情報ファイル

1.4.1　接続情報ファイル

接続情報ファイルには，次の項目を指定します。接続情報ファイルの詳細については「5.8　接続情報ファイル」を参照してください。

  • DABrokerのホスト名またはIPアドレス
  • データベースの種別（HiRDB，Oracle，またはSQL Server）
  • 送受信領域サイズ
  • 応答監視時間
  • データベースホスト名
  • データベース識別子
  • ユーザID
  • パスワード
  • 排他オプション


可変記号値定義ファイル

1.4.2　可変記号値定義ファイル

可変記号値定義ファイルには，データベースからデータを検索し，条件に合ったデータを抽出するときに必要な，検索条件の可変記号とその値（可変記号値）を定義します。可変記号値定義ファイルの詳細については「5.9　可変記号値定義ファイル」を参照してください。


帳票出力で使用できるインターフェース

1.5　帳票出力で使用できるインターフェース

アプリケーションプログラムから，EURを呼び出して帳票を出力できます。アプリケーションプログラムからEURを呼び出すために，次のインターフェースを提供しています。

表1-2　EURを呼び出すインターフェースの種類

インターフェース 説明 参照先
apgrptコマンド Visual Basic，Visual C++，およびCOBOLで作成したアプリケーション，バッチファイルなどから使用できます。
  • apgrptコマンドの概要
    「2.1　apgrptコマンドから帳票を印刷するには」
  • COBOLで作成したアプリケーションから出力する方法
    「2.3　COBOL言語プログラムから帳票を印刷するには」
eurerコマンド（EUR形式ファイルの出力） EUR形式ファイルをEUR クライアント帳票出力機能を使用してプレビュー，または印刷するためのコマンドです。
Visual Basic，Visual C++，およびCOBOLで作成したアプリケーション，バッチファイルなどから使用できます。
  • eurerコマンドの概要
    「2.2　eurerコマンドから帳票を印刷するには（Webアプリケーションからの帳票印刷）」
  • COBOLで作成したアプリケーションから出力する方法
    「2.3　COBOL言語プログラムから帳票を印刷するには」
OLEオートメーション Visual Basicなどで作成したアプリケーションから呼び出せるように，OLEオートメーションとのインターフェースを提供しています。
  • OLEオートメーションの概要
    「3.1　OLEオートメーションからEURを実行するには」
  • OLEオートメーションの詳細
    「3.　OLEオートメーションを使用した帳票出力」


コマンドを使用した帳票出力

2.　コマンドを使用した帳票出力

この章では，コマンドから帳票出力する方法について説明します。

＜この章の構成＞
2.1　apgrptコマンドから帳票を印刷するには
2.2　eurerコマンドから帳票を印刷するには（Webアプリケーションからの帳票印刷）
2.3　COBOL言語プログラムから帳票を印刷するには


apgrptコマンドから帳票を印刷するには

2.1　apgrptコマンドから帳票を印刷するには

apgrptコマンドを使用して，帳票を印刷できます。apgrptコマンドは，Visual Basic，Visual C++，およびCOBOLで作成したアプリケーション，MS-DOS(R)のバッチファイルなどから使用できます。アプリケーションと非同期に印刷できるので，アプリケーションは，EURの実行を待たなくても次の操作に移れます。

＜この節の構成＞
2.1.1　apgrptコマンドで指定できること
2.1.2　apgrptコマンドからの印刷
2.1.3　apgrptコマンドの形式
2.1.4　オプション記述ファイルの指定
2.1.5　記述例


apgrptコマンドで指定できること

2.1.1　apgrptコマンドで指定できること

apgrptコマンドで指定できる設定と，apgrptコマンドでは指定できない設定について説明します。

＜この項の構成＞
(1)　apgrptコマンドで指定できる内容
(2)　apgrptコマンドで指定できない内容

(1)　apgrptコマンドで指定できる内容

apgrptコマンドで指定できる内容を次に示します。

  • 印刷に使用する帳票ファイル
  • 帳票に読み込むデータ
  • 印刷するプリンタ
  • 印刷する用紙の向き，印刷開始ページ，印刷終了ページ，および印刷部数
  • 帳票の余白にページ番号を印刷するかどうか，ページ番号の印刷形式，印刷位置，改ページごとの初期化，ページ番号の開始値
  • EUR起動時に表示するウィンドウスタイル
  • 給紙トレイの指定
  • 出力先での帳票名表示
  • 複数様式での帳票出力
  • 置き換え表管理情報ファイルの指定
  • ユーザ操作とメッセージダイアログの表示の抑止

(2)　apgrptコマンドで指定できない内容

apgrptコマンドでは指定できない内容を次に示します。

  • ウィンドウを表示する位置，大きさ，ウィンドウのアクティブ状態
  • ウィンドウの表示/非表示
  • EURの終了


apgrptコマンドからの印刷

2.1.2　apgrptコマンドからの印刷

apgrptコマンドをショートカットキーとして登録することで，データファイルのデータ，データベースから抽出したデータなどから，帳票の印刷またはプレビューができます。

apgrptコマンドには，帳票の定義情報を保存してある帳票ファイル名（レポートファイル名，またはフォームシートファイル名），印刷先プリンタ名などのオプションを直接指定できます。しかし，アプリケーションを配布した場合など，動作環境に応じてプリンタ名などを変更する必要があります。そのため，帳票を印刷するときに使用するデータは，オプション記述ファイルに設定しておくと便利です。オプション記述ファイルの指定方法については，「5.12.1　オプション記述ファイルのキーワード」を参照してください。

＜この項の構成＞
(1)　apgrptコマンドの実行パス
(2)　印刷の実行

(1)　apgrptコマンドの実行パス

apgrptコマンドの実行パスは次のとおりです。

  • EUR Designerの場合
    EUR Designerのインストール先フォルダ\Designer\Program\apgrpt.exe
  • EUR Viewerの場合
    EUR Viewerのインストール先フォルダ\Program\apgrpt.exe

(2)　印刷の実行

apgrptコマンドで印刷を実行するには，次のオプションを指定します。

  • /pオプション
    帳票の即時印刷を実行するには，apgrptコマンドの/pオプションに，印刷するプリンタ名を指定します。
  • /lオプション
    EURのウィンドウを起動してから印刷を実行する場合は，表示するウィンドウを/lオプションに次の値で指定します。EURのウィンドウは，次に示す三つがあります。
    指定値 | 説　　明
    edit | レポート編集ウィンドウが表示されます。
    view | レポート確認ウィンドウが表示されます。印刷指示やプリンタの選択をメニューから設定します。帳票の編集はできませんが，ほかの帳票を開いたり，印刷したりできます。
    print | レポート印刷ウィンドウが表示されます。印刷指示やプリンタの選択をメニューから設定します。帳票の編集をしたり，ほかの帳票を開いたりできません。
  • /kオプション
    オプション記述ファイルは，/kオプションで指定します。


apgrptコマンドの形式

2.1.3　apgrptコマンドの形式

apgrptコマンドの形式とオプションについて説明します。

＜この項の構成＞
(1)　形式
(2)　apgrptコマンドのオプションの説明
(3)　補足説明

(1)　形式

apgrpt〔.exe〕〔帳票ファイル名〕
              〔/l {edit | view | print}〕
              〔/z ズーム倍率 | as〕
              〔/p 〔プリンタ名〕〕
              〔/pf 印刷出力ファイル名〕
              〔/rc〕
              〔/rt 帳票名〕
              〔/mfd 複数様式情報定義ファイル名〕
              〔/mrs 帳票セット指定ファイル名〕
              〔/rif 置き換え表管理情報ファイル名〕
              〔/k オプション記述ファイル名〕

(2)　apgrptコマンドのオプションの説明

apgrptコマンドで指定するオプションを説明します。オプションの文字列は，大文字，小文字を区別しません。

帳票ファイル名
レポートファイル名（*.agr），またはフォームシートファイル名（*.fms）を指定します。ファイルのパスは，オプション記述ファイルで指定できますが，ファイルのパスを含めて指定することもできます。帳票ファイル名は，第1オペランドで指定してください。第1オペランドで指定しない場合は，エラーになります。
帳票ファイル名を指定しても，指定した帳票がない場合は，新規作成とみなされます。
なお，複数様式で帳票を出力する場合は，/mrsオプションに指定する帳票セット指定ファイルにフォームシートファイル名を指定するので，帳票ファイル名の指定は省略できます。
/l { edit | view | print }
EURを起動するときに表示するウィンドウを指定します。省略した場合は，editが仮定されます。
複数様式で帳票を出力する場合は，/lオプションの指定値に「print」を指定してください。/lオプションの指定を省略したり，「print」以外の値を指定したりしたときは，エラーになります。
指定値 | 説　　明
edit | レポート編集ウィンドウが表示されます。
view | レポート確認ウィンドウが表示されます。
print | レポート印刷ウィンドウが表示されます。
  • レポート編集ウィンドウ
    レポート編集ウィンドウは，帳票ファイル名を指定しないで起動した場合，帳票ウィンドウを「重ねて表示」実行時のウィンドウの位置，ウィンドウサイズで最前面に表示し，その後ろにマッピングデータウィンドウを表示します。ユーザ定義データウィンドウは表示されていません。既存の帳票ファイル名を指定して起動した場合は，前回レポート編集ウィンドウでEURを終了したときのウィンドウの位置，ウィンドウサイズで，帳票ウィンドウ，マッピングデータウィンドウ，およびユーザ定義データウィンドウが表示されます。
  • レポート確認ウィンドウ
    レポート確認ウィンドウは，メインウィンドウに帳票ウィンドウを最大表示します。マッピングデータウィンドウとユーザ定義データウィンドウは表示されません。レポート確認ウィンドウでは，帳票の編集はできませんが，ほかの帳票を開いたり，印刷したりできます。
  • レポート印刷ウィンドウ
    レポート印刷ウィンドウは，メインウィンドウに帳票ウィンドウを最大表示します。マッピングデータウィンドウとユーザ定義データウィンドウは表示されません。レポート印刷ウィンドウでは，帳票の編集をしたり，ほかの帳票を開いたりできません。
/z ズーム倍率 | as
EURを起動したとき，レポート編集ウィンドウとレポート確認ウィンドウに表示する帳票のズーム倍率を指定します。指定できる値は，標準のサイズを100とした百分率で10～800です。また，「as」を指定すると，帳票全体が帳票ウィンドウに入る大きさで表示されます。省略した場合は，標準のサイズ（100）が仮定されます。
/p 〔プリンタ名〕
帳票を即時印刷する場合，帳票を印刷するプリンタ名を指定します。プリンタ名を省略した場合は，Windowsで通常使うプリンタとして指定してあるプリンタに印刷します。帳票ファイル名を省略した場合は，指定を無視します。
/pf 印刷出力ファイル名
帳票をプリンタに出力する代わりに，指定されたドライブの新規ファイルへ出力します。印刷出力ファイル名は，ドライブ名とフォルダ名を含むフルパスで指定します。フルパスで指定しない場合は，EURのインストール先フォルダからの相対パスが仮定されます。
/pfオプションを指定した場合は，/pオプションで指定したプリンタがどの出力ポートを選択していても，指定したファイルに出力されます。
/pオプションを省略した場合は，/pfオプションの指定を無視します。
/rc
ユーザ応答抑止オプションを指定します。/rcオプションを指定してEURを起動した場合，ユーザ操作とメッセージダイアログの表示を抑止します。
/rcオプションを指定して起動したEURで，処理中にエラーが発生した場合は，エラーコードをプロセスのリターンコードとして返します。エラーコードについては，マニュアル「EUR メッセージ」を参照してください。
/rcオプションを指定する場合は，帳票ファイル名を必ず指定してください。また，/pオプションで印刷要求をしなかった場合は，指定された帳票を開いたあと，EURは正常終了します。
/rt 帳票名
プリンタの印刷待ち状態を確認する一覧ウィンドウの「ドキュメント名」，およびタイトルバーに表示する帳票名を「"」で囲んで指定します。/rtオプションの指定がなければ，「HITACHI Report - 帳票ファイル名」が表示されます。
帳票名は，255文字までの文字列で指定します。指定された帳票名が255文字を超えた場合は，255文字までを帳票名とします。
/mfd 複数様式情報定義ファイル名
複数様式情報定義ファイル名を指定します。複数様式情報定義ファイルは，様式（帳票フォーマット）や読み込むデータを切り替える条件と，切り替え時の動作を定義しておくファイルです。
複数様式情報定義ファイルについては，「5.7　複数様式情報定義ファイル」を参照してください。
/mrs 帳票セット指定ファイル名
帳票セット指定ファイル名を指定します。帳票セット指定ファイルは，複数の帳票ファイルを統合する順番と帳票に読み込むデータファイルを指定しておくファイルです。
帳票セット指定ファイルについては，「5.6　帳票セット指定ファイル」を参照してください。
/rif 置き換え表管理情報ファイル名
置き換え表管理情報ファイル名を指定します。置き換え表管理情報ファイルは，表示データの置き換え表ファイルを管理するファイルです。置き換え表管理情報ファイルについては，「5.10　置き換え表管理情報ファイル」を参照してください。
/k オプション記述ファイル名
EURを起動するときの起動オプションを記述したファイル名を指定します。オプション記述ファイル名をフルパス名で指定しなかった場合は，EURのインストール先フォルダからの相対パスが仮定されます。オプション記述ファイルについては，「5.12　オプション記述ファイル」を参照してください。
/kオプションとほかのオプションを一緒に指定した場合（指定が重なった場合）は，起動オプションに指定したオプションが有効となり，オプション記述ファイル中の該当する指定は無視されます。オプション記述ファイルの中で指定が重ならないものはそのまま有効となります。

(3)　補足説明

  • ファイル名，およびプリンタ名に空白を含む名称を指定する場合は，「"」で囲んでください。
  • 帳票ファイル名を指定するとき，エクスプローラなどで，ファイルを一つ選択したあと，ポップアップメニューから［プロパティ］を選択すると，ファイルのプロパティを表示できます。［EURのプロパティ］タブで，帳票ファイルを設計したEUR製品のプログラムプロダクト情報を確認することで，帳票ファイルを参照，または印刷できるEUR製品のプログラムプロダクト情報を特定できます。


オプション記述ファイルの指定

2.1.4　オプション記述ファイルの指定

apgrptコマンドの実行時にオプション記述ファイルを入力します。オプション記述ファイルのキーワードと記述例については，「5.12.1　オプション記述ファイルのキーワード」を参照してください。


記述例

2.1.5　記述例

Visual Basicでの記述例を次に示します。

＜この項の構成＞
(1)　印刷を実行する場合
(2)　印刷プレビューを実行する場合

(1)　印刷を実行する場合

Private Sub Command1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Command1.Click
    Dim strExeFileName As String
    Dim strRptFileName As String
    Dim strExeOption As String
    Dim lngTaskID As Integer

    strExeFileName = "C:\Program Files\HITACHI\EUR\" & "Designer\Program\" & "apgrpt.exe"
                                          'EUR実行ファイルを指定
    strRptFileName = "納品書.fms"         '帳票ファイルを指定
    strExeOption = "/P"                   '起動オプションに帳票プリンタ印刷を指定
    lngTaskID = Shell(strExeFileName & Chr(&H20S) & Chr(&H22S) & strRptFileName & _
              Chr(&H22S) & Chr(&H20S) & strExeOption, AppWinStyle.Hide)
'EUR実行ファイルを起動
    End Sub

(2)　印刷プレビューを実行する場合

Private Sub Command2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Command2.Click
    Dim strExeFileName As String
    Dim strRptFileName As String
    Dim strExeOption As String
    Dim lngTaskID As Integer

    strExeFileName = "C:\Program Files\HITACHI\EUR\" & "Designer\Program\apgrpt.exe"
                                                   'EUR実行ファイルを指定
    strRptFileName = "納品書.fms"                  '帳票ファイルを指定
    strExeOption = "/l print /z 75"
                         '起動オプションに帳票印刷ウィンドウ表示とズーム倍率を指定
    lngTaskID = Shell(strExeFileName & Chr(&H20S) & Chr(&H22S) & strRptFileName & _
              Chr(&H22S) & Chr(&H20S) & strExeOption, AppWinStyle.NormalFocus)
                                                   'EUR実行ファイルを起動
    End Sub


eurerコマンドから帳票を印刷するには（Webアプリケーションからの帳票印刷）

2.2　eurerコマンドから帳票を印刷するには（Webアプリケーションからの帳票印刷）

Webアプリケーションから帳票を出力するには，EURで設計した帳票をEUR形式ファイルにしておく必要があります。

EUR形式ファイルは，EUR Server EnterpriseまたはEUR Server Standardをインストールしているサーバ上で出力できます。また，EUR Developerは帳票の設計から出力結果の確認まで実施できる機能を持っているため，EUR Developerを使えばクライアント環境でもEUR形式ファイルの出力イメージを確認できます。

EUR形式ファイルは，フォームシートファイル，マッピングデータファイル，ユーザ定義データファイル，および画像ファイルを結合して1ファイルにしたものです。

Webクライアント環境にEUR Designer，EUR DeveloperまたはEUR Viewerをインストールしておくことで，サーバ上で出力されたEUR形式ファイルをプレビュー，または印刷できます。

EUR形式ファイル出力については，マニュアル「EUR 帳票出力 機能解説 EUR Server編」およびマニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。

＜この節の構成＞
2.2.1　eurerコマンドで指定できること
2.2.2　eurerコマンドの実行形態
2.2.3　eurerコマンドの形式
2.2.4　EUR形式ファイルのプロパティ表示


eurerコマンドで指定できること

2.2.1　eurerコマンドで指定できること

eurerコマンドで指定できる内容を次に示します。

  • EUR形式ファイルのプレビュー
  • EUR形式ファイルのプリンタ印刷

なお，eurerコマンドでは，EUR形式ファイルのプレビュー，またはプリンタ印刷の指定以外に，指定できる項目はありません。

eurerコマンドの指定形式については，「2.2.3　eurerコマンドの形式」を参照してください。


eurerコマンドの実行形態

2.2.2　eurerコマンドの実行形態

eurerコマンドの実行形態には次の三つがあります。実行形態ごとにEUR形式ファイルをプレビューまたはプリンタ印刷する方法を説明します。

＜この項の構成＞
(1)　Webブラウザのヘルパアプリケーションとして実行
(2)　EUR形式ファイルをダブルクリックして実行
(3)　eurerコマンドでの実行

(1)　Webブラウザのヘルパアプリケーションとして実行

Webクライアント環境では，eurerコマンドは，ブラウザのヘルパアプリケーションとして実行されます。次に示すようにMIMEタイプに関連づけられます。

  • MIMEタイプがapplication/vnd.hitachi.eur-viewの場合
    EUR形式ファイルをプレビューします。
  • MIMEタイプがapplication/vnd.hitachi.eur-printの場合
    EUR形式ファイルをプリンタ印刷します。

(2)　EUR形式ファイルをダブルクリックして実行

EUR形式ファイルとeurerコマンドは，ファイルの拡張子で関連づけられます。そのため，エクスプローラなどからEUR形式ファイルをダブルクリックするだけで，プレビューしたり，印刷したりできます。

  • ファイルの拡張子が*.euvの場合
    EUR形式ファイルをプレビューします。
  • ファイルの拡張子が*.eupの場合
    EUR形式ファイルをプリンタ印刷します。

(3)　eurerコマンドでの実行

eurerコマンドに任意のオプションを組み合わせて実行します。eurerコマンドの指定形式については，「2.2.3　eurerコマンドの形式」を参照してください。

  • /pオプションを指定しない場合
    ファイルの拡張子に関係なく，EUR形式ファイルをプレビューします。
  • /pオプションを指定する場合
    ファイルの拡張子に関係なく，EUR形式ファイルをプリンタ印刷します。


eurerコマンドの形式

2.2.3　eurerコマンドの形式

eurerコマンドの形式と指定できるオプションについて説明します。

＜この項の構成＞
(1)　形式
(2)　eurerコマンドのオプションの説明
(3)　eurerコマンドの終了コード
(4)　eurerコマンドの指定例

(1)　形式

Eurer〔.exe〕 EUR形式ファイル名
             〔/nomessage〕
             〔/p 〔プリンタ名〕〕

(2)　eurerコマンドのオプションの説明

eurerコマンドで指定するオプションを説明します。オプションの文字列は，大文字，小文字を区別します。

EUR形式ファイル名
EUR Developer，EUR Server EnterpriseまたはEUR Server StandardのEUR サーバ帳票出力機能で出力したEUR形式ファイル名をフルパスで指定します。EUR形式ファイル名は省略できません。相対パスで指定した場合は，カレントフォルダからの相対パスと見なします。
EUR形式ファイル名を指定するときは，次に示す拡張子を付けてください。
  • *.euv
    クライアント側のEUR クライアント帳票出力機能でプレビューする場合
  • *.eup
    クライアント側のEUR クライアント帳票出力機能でプリンタに直接印刷する場合
指定できるEUR形式ファイル名は，255文字以内です。指定するEUR形式ファイル名に半角空白がある場合は，「"」で囲んで指定してください。
EUR Developer，EUR Server EnterpriseまたはEUR Server StandardのEUR サーバ帳票出力機能で，複数の帳票セット（帳票ファイルとデータファイルの一まとまり）を指定して出力されたEUR形式ファイルの場合は，「*.eup」だけ指定できます。「*.euv」のEUR形式ファイルを指定した場合は，エラーになります。
EUR Developer，EUR Server EnterpriseまたはEUR Server StandardのEUR サーバ帳票出力機能で，複数様式で出力されたEUR形式ファイルの場合，および置き換え表管理情報ファイルが定義されている帳票ファイルから出力されたEUR形式ファイルの場合は，「*.euv」も「*.eup」も指定できます。
/nomessage
エラーが発生しても，メッセージダイアログを表示しない場合に指定します。指定を省略した場合は，メッセージダイアログが表示されます。
/p
EUR形式ファイルを印刷する場合に指定します。/pオプションを省略した場合は，EUR形式ファイルをプレビュー表示します。
/pオプションを複数指定した場合，または/pオプション以外の指定をした場合は，エラーになります。
/pオプションを指定した場合
EUR クライアント帳票出力機能を使用してバックグラウンド印刷されるので，EUR クライアント帳票出力機能のウィンドウは表示されません。
/pオプションを指定した場合は，EUR形式ファイルの拡張子が「*.euv」であっても，拡張子に関係なく印刷されます。
  • プリンタ名
    出力先プリンタは，「プリンタ名」に指定します。「プリンタ名」を省略した場合は，通常使うプリンタに出力されます。
    指定できるプリンタ名は，259文字以内です。指定するプリンタ名に半角空白がある場合は，「"」で囲んで指定してください。
    指定したプリンタがない場合，または通常使うプリンタが設定されていない場合は，エラーになります。
印刷を実行すると，EUR形式ファイルを作成するときに指定した帳票名が，印刷待ち一覧のウィンドウの［ドキュメント名］に表示されます。
帳票名に設定される値は，起動部品で指定したスプールタイトルの指定値，または文書情報設定ファイルのTITLEキーの指定値です。
指定内容の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。
EUR形式ファイルを作成するときに帳票名を指定していない場合の表示形式は次のとおりです。
  • 単一様式の帳票の場合
    「HITACHI Report - EUR形式ファイル名（拡張子なし）」
  • 複数の帳票セットを指定した帳票，または複数様式を指定した帳票の場合
    「EUR形式ファイル名（拡張子なし）」
/pオプションを省略した場合
EUR クライアント帳票出力機能を使用してプレビューします。ただし，EUR Developer，EUR Server EnterpriseまたはEUR Server StandardのEUR サーバ帳票出力機能で，複数の帳票セットを指定して出力されたEUR形式ファイル（*.euv）は，プレビューできません。エラーになります。なお，複数様式を指定して出力されたEUR形式ファイルはプレビューできます。
プレビューウィンドウからは，［ファイル］メニューの［印刷］を選択することで，印刷することもできます。
/pオプションを省略した場合は，EUR形式ファイルの拡張子が「*.eup」であっても，拡張子に関係なくプレビューされます。
プレビューすると，EUR形式ファイルを作成するときに指定した帳票名が，ウィンドウのタイトルバーに表示されます。
帳票名に設定される値は，起動部品で指定したスプールタイトルの指定値，または文書情報設定ファイルのTITLEキーの指定値です。
指定内容の詳細については，マニュアル「EUR 帳票出力 リファレンス EUR Server編」を参照してください。
EUR形式ファイルを作成するときに帳票名を指定していない場合の表示形式は次のとおりです。
  • 単一様式の帳票の場合
    「HITACHI Report - EUR形式ファイル名（拡張子なし）」
  • 複数様式を指定した帳票の場合
    「EUR形式ファイル名（拡張子なし）」

(3)　eurerコマンドの終了コード

eurerコマンドを実行すると，終了コードが返されます。終了コード一覧を次に示します。eurerコマンドの呼び出し側プログラムは，eurerコマンドの終了コードを参照して，エラーチェックしてください。

表2-1　eurerコマンド実行時の終了コード一覧

終了コード | 意味 | 要因 | 対処
0 eurerコマンドが正常に終了しました。 － －
4 | 警告が発生しました。 | 指定したEUR形式ファイルは，上位バージョンのEUR Developer，EUR Server EnterpriseまたはEUR Server Standardで出力されています。実行バージョンの機能範囲で出力しました。 | EUR形式ファイルを出力した製品（EUR Developer，EUR Server EnterpriseまたはEUR Server Standard）と同じか，またはそれより上位バージョンの製品（EUR Designer，EUR DeveloperまたはEUR Viewer）で実行してください。
8

           システムエラーが発生しました。

           EUR形式ファイルが読み込めません。
  • 存在するEUR形式ファイルを指定してください。
  • EUR形式ファイルに読み込み権限を与えてください。
一時ファイルが作成できません。
  • テンポラリフォルダの書き込み権限，またはディスク容量を確認してください。
  • テンポラリフォルダに残されたフォルダ（フォルダ名はtmpxxx）を削除してください。フォルダ名 tmpxxx の xxx は，1桁以上の数値です。
  • システム環境変数TMP，またはTEMPの設定を確認して，存在するテンポラリフォルダを指定してください。
システムのリソース不足のため，EUR Designer，EUR DeveloperまたはEUR Viewerが起動できません。 | ほかのアプリケーションを終了させるなどして，リソースを確保してください。
実行中にメモリ不足が発生しました。 | ほかのアプリケーションを終了させるなどして，実行に必要なメモリを確保してください。
12
           データエラーが発生しました。
           指定したEUR形式ファイルが，上位バージョンのEUR Developer，EUR Server EnterpriseまたはEUR Server Standardで作成されたものであったため，読み込みできません。 EUR形式ファイルを出力した製品（EUR Developer，EUR Server EnterpriseまたはEUR Server Standard）と同じか，またはそれより上位バージョンの製品（EUR Designer，EUR DeveloperまたはEUR Viewer）で実行してください。
不正なフォーマットのEUR形式ファイルが指定されました。 | 正しいEUR形式ファイルを指定してください。
16

           コマンド文法にエラーがあります。

           EUR形式ファイル名が指定されていません。 EUR形式ファイル名を指定してから，eurerコマンドを実行してください。
指定されたEUR形式ファイル名が不正です。 | EUR形式ファイル名を255文字以内で指定し直したあと，再度実行してください。
指定されたオプションが不正です。 | eurerコマンドに指定したオプションの指定を見直したあと，再度実行してください。
指定されたプリンタ名が不正です。 | プリンタ名を259文字以内で指定し直したあと，再度実行してください。
32 | 上記以外のエラーが発生しました。 | 前提プログラムのEUR Designer，EUR DeveloperまたはEUR Viewerがインストールされていません。 | EUR Designer，EUR DeveloperまたはEUR Viewerをインストールしてください。
1005～1135，4503～4518，4521～4534，4545～4560，4561～4580，4581～4600，4601～4649，4650～4690 | EUR帳票出力中に，エラーが発生しました。 | 起動されたEUR ViewerまたはEUR Designerでエラーが発生した場合，この終了コードが返されます。 | 終了コードについては，マニュアル「EUR メッセージ」を参照してください。
（凡例）
－：該当する項目はありません

(4)　eurerコマンドの指定例

eurerコマンドの指定例を次に示します。

EUR形式ファイルをプレビューする場合
EUR Viewerのインストール先フォルダ\Program\Eurer〔.exe〕 output1.euv
EUR形式ファイルを印刷する場合
EUR Viewerのインストール先フォルダ\Program\Eurer〔.exe〕 /p output2.eup
EUR形式ファイルをプリンタ名（printer1）に印刷する場合
EUR Viewerのインストール先フォルダ\Program\Eurer〔.exe〕 /p printer1 output3.eup


EUR形式ファイルのプロパティ表示

2.2.4　EUR形式ファイルのプロパティ表示

EUR形式ファイルのファイルバージョン，作成日付などを［プロパティ］ダイアログの［EURのプロパティ］タブに表示できます。プロパティの情報は，EUR形式ファイルを参照するときに必要な情報となります。

＜この項の構成＞
(1)　プロパティ表示の方法
(2)　表示される内容

(1)　プロパティ表示の方法

*.euv，または*.eupの拡張子を持つEUR形式ファイルを一つ選択し，右クリックします。ポップアップメニューから［プロパティ］を選択すると，［EURのプロパティ］タブを持つ［プロパティ］ダイアログが表示されます。

ただし，次の場合は，［プロパティ］ダイアログに［EURのプロパティ］タブは表示されません。

  • 複数のEUR形式ファイルを選択した場合
  • 「*.euv」「*.eup」以外の拡張子に変更されているEUR形式ファイルである場合
  • EUR形式ファイル以外のファイルに，「*.euv」「*.eup」の拡張子が付けられている場合

(2)　表示される内容

［プロパティ］ダイアログの［EURのプロパティ］タブを次に示します。

ファイルバージョン
次に示す書式で，ファイルバージョンを表示します。
V1.R1.S1.Z1.V2.R2.S2.Z2
（凡例）
  V：バージョン
  R：リビジョン
  S：任意の情報
  Z：「0」固定
EUR Developer，EUR Server EnterpriseまたはEUR Server StandardのEUR サーバ帳票出力機能で出力した，次に示すEUR形式ファイルの場合，EUR クライアント帳票出力機能ですべての情報を表示できる最新のファイルバージョンが表示されます。
  • 複数の帳票セットを指定して出力されたEUR形式ファイル
  • 複数様式で出力されたEUR形式ファイル
ファイルバージョンでは，次に示す情報を確認できます。
  • V1.R1.S1.Z1
    EUR形式ファイルを出力したEUR Developer，EUR Server EnterpriseまたはEUR Server Standardのバージョン情報を示します。
  • V2.R2.S2.Z2
    EUR形式ファイルに出力する帳票ファイルを設計したEUR 帳票作成機能のバージョン情報を示します。
フォームシートファイルの作成
帳票ファイルを設計したEUR 帳票作成機能の製品形名，製品名，バージョンを表示します。ただし，次に示す帳票ファイルの場合は表示内容が異なります。
帳票ファイルの種類 | 表示内容
バージョン04-01以前のEUR 帳票作成機能で設計した帳票ファイルの場合 | 「EUR バージョン3」と表示されます。
EUR Developer，EUR Server EnterpriseまたはEUR Server StandardのEUR サーバ帳票出力機能で出力した，次に示すEUR形式ファイルの場合
  • 複数の帳票セットを指定して出力されたEUR形式ファイル
  • 複数様式で出力されたEUR形式ファイル
 EUR クライアント帳票出力機能ですべての情報を表示できる最新のファイルバージョンが表示されます。
EUR形式ファイルの出力
EUR形式ファイルを出力したEUR サーバ帳票出力機能の製品形名，製品名※，バージョンを表示します。
注※
製品名には「EUR Server」と表示されます。
作成日時
EUR形式ファイルを作成した日付を「yyyy/mm/dd hh:mm:ss」で表示します。
帳票数
EUR Developer，EUR Server EnterpriseまたはEUR Server StandardのEUR サーバ帳票出力機能で，複数の帳票セットを指定して出力したEUR形式ファイルの場合は，帳票ファイルの総数を表示します。
帳票形態
EUR Developer，EUR Server EnterpriseまたはEUR Server StandardのEUR サーバ帳票出力機能で，複数様式で出力されたEUR形式ファイルの場合は，様式数を表示します。


COBOL言語プログラムから帳票を印刷するには

2.3　COBOL言語プログラムから帳票を印刷するには

COBOL言語で作成したアプリケーションから，EURを起動して帳票を印刷できます。eurerコマンドと連携した帳票出力もできます。また，COBOL言語でプログラムを開発することで，SEWB+/REPOSITORYの最上位結合項目を入力して編集した帳票も印刷できます。

最上位結合項目を入力して編集した帳票を印刷するときに使用するCSV形式ファイルを生成するプログラムの作成には，SEWB+/CONSTRUCTIONの機能を利用できます。SEWB+/CONSTRUCTIONでは，帳票を編集したときと同じ最上位結合項目を入力してプログラム開発に利用できるデータ定義ができます。最上位結合項目を入力して編集した帳票を印刷するまでの流れを，次に示します。

図2-1　帳票出力の流れ（最上位結合項目を含む帳票の場合）

注意
SEWB+/REPOSITORYは，英語ロケール，および中国語ロケールでは使用できません。
＜この節の構成＞
2.3.1　COBOL言語で帳票を印刷するアプリケーションの開発手順
2.3.2　オプション記述ファイルの指定
2.3.3　COBOL言語のプログラムからの印刷実行


COBOL言語で帳票を印刷するアプリケーションの開発手順

2.3.1　COBOL言語で帳票を印刷するアプリケーションの開発手順

COBOL言語で作成したアプリケーションから帳票を印刷するには，CALL文でapgrptコマンドを引数として記述します。

なお，apgrptコマンドからEURを起動した場合，EURのウィンドウは必ず表示されるので，注意してください。

apgrptコマンドには，帳票の定義情報を保存してある帳票ファイル名（レポートファイル名，またはフォームシートファイル名），印刷先プリンタ名などのオプションを直接指定できます。しかし，アプリケーションを配布した場合など，動作環境に応じてプリンタ名などを変更する必要があります。そのため，帳票を印刷するときに使用するデータは，オプション記述ファイルに設定しておくと便利です。

コーディング例（日立COBOLの場合）
データファイル（Table.csv）を指定して，フォームシートファイル（Table.fms）を印刷する場合のコーディング例を次に示します。

IDENTIFICATION DIVISION.
    PROGRAM-ID.EUR.
DATA DIVISION.
    WORKING-STORAGE SECTION.
    01  EXEC-NAME    PIC X(100)
        VALUE 'EURインストール先フォルダ' &
        '\Designer\Program\apgrpt.exe table.fms /k c:\tmp\Table.txt'.
PROCEDURE DIVISION.
    CALL EXEC-NAME.
STOP RUN.
オプション記述ファイル（c:\tmp\Table.txt）の記述例
[Hitachi EUR]
PrinterName=
MappingDataFile=Table.csv

COBOL言語によって記述方法が異なります。使用されているCOBOL言語のマニュアル，またはヘルプを参照してください。


オプション記述ファイルの指定

2.3.2　オプション記述ファイルの指定

オプション記述ファイルで指定できるキーワードについては，「5.12　オプション記述ファイル」を参照してください。


COBOL言語のプログラムからの印刷実行

2.3.3　COBOL言語のプログラムからの印刷実行

帳票の即時印刷を実行するには，apgrptコマンドの/pオプションに，印刷するプリンタ名を指定します。また，EURのウィンドウを起動してから印刷を実行する場合は，/lオプションに表示するウィンドウを指定します。EURのウィンドウには，次に示す三つがあります。

指定値 | 説 明
edit | レポート編集ウィンドウが表示されます。
view | レポート確認ウィンドウが表示されます。印刷指示やプリンタの選択をメニューから設定します。帳票の編集はできませんが，ほかの帳票を開いたり，印刷したりできます。
print | レポート印刷ウィンドウが表示されます。印刷指示やプリンタの選択をメニューから設定します。帳票の編集をしたり，ほかの帳票を開いたりできません。

オプション記述ファイルは，/kオプションで指定します。


OLEオートメーションを使用した帳票出力

3.　OLEオートメーションを使用した帳票出力

この章では，EURが提供するOLEオートメーションで使用できるオブジェクトのオブジェクト階層，およびプロパティとメソッドの仕様について説明します。

＜この章の構成＞
3.1　OLEオートメーションからEURを実行するには
3.2　OLEオートメーションで使用できるEURのオブジェクト階層
3.3　OLEオートメーションで使用できるプロパティ，メソッド一覧
3.4　OLEオートメーションで使用できるプロパティ仕様
3.5　OLEオートメーションで使用できるメソッド仕様


OLEオートメーションからEURを実行するには

3.1　OLEオートメーションからEURを実行するには

EURは，OLEオートメーションとのインターフェースを提供しています。そのため，Visual Basicで作成したアプリケーションで使用できます。OLEオートメーションを使用すると，アプリケーションと同期を取って印刷できます。

EURで提供するOLEオートメーションのプロパティ，およびメソッドについては，「3.3　OLEオートメーションで使用できるプロパティ，メソッド一覧」を参照してください。

＜この節の構成＞
3.1.1　OLEオートメーションで指定できること
3.1.2　EURをOLEオートメーションオブジェクトとして実行するには
3.1.3　OLEオートメーションからの印刷


OLEオートメーションで指定できること

3.1.1　OLEオートメーションで指定できること

プロパティ，およびメソッドの記述方法は，各アプリケーションで異なります。各アプリケーションでのOLEオートメーションの記述方法に従ってください。

OLEオートメーションで指定できる内容を次に示します。

  • 印刷に使用する帳票ファイルの指定
  • 帳票ファイルの作成日付の取得
  • EUR起動時に表示する，ウィンドウスタイルの指定
  • ウィンドウの表示/非表示の指定
  • 帳票に読み込むデータの指定
  • 印刷するプリンタの指定
  • ページ番号印刷に関する指定（帳票の余白にページ番号を印刷するかどうか，ページ番号の印刷形式，印刷位置，改ページごとの初期化，ぺージ番号の開始値の指定）
  • ユーザ操作とメッセージダイアログの表示の抑止
  • 印刷する用紙の向き，印刷開始ページ，印刷終了ページ，および印刷部数の指定
  • 印刷時に［印刷中］ダイアログを表示するかどうかの指定
  • ウィンドウを表示する位置，大きさ，ウィンドウのアクティブ状態の指定
  • 給紙トレイの指定
  • 出力先での帳票名表示の指定
  • 複数様式での帳票出力の指定
  • 置き換え表管理情報ファイルの指定
  • 固定ピッチフォントの文字幅計算方法の指定
  • EURの終了


EURをOLEオートメーションオブジェクトとして実行するには

3.1.2　EURをOLEオートメーションオブジェクトとして実行するには

Visual BasicのVBAが提供しているCreateObject関数やGetObject関数を使用して，EURをOLEオートメーションオブジェクトとして起動できます。

EUR以外の製品のプログラムIDについては，各製品のマニュアル，またはヘルプを参照してください。また，CreateObject関数，およびGetObject関数については，各開発環境製品のマニュアル，またはヘルプを参照してください。

＜この項の構成＞
(1)　CreateObject関数による起動
(2)　GetObject関数による起動

(1)　CreateObject関数による起動

EURを新しいOLEオートメーションオブジェクトとして作成します。

CreateObject関数の形式を次に示します。

CreateObject ("プログラムID")
EURのプログラムIDは，"APGRPT.Report"（バージョン非依存），または"APGRPT.Report.3"（バージョン依存）です。バージョンを特定しない場合は，バージョン非依存のプログラムID"APGRPT.Report"を指定してください。
バージョン5以降に特定する場合は，バージョン依存のプログラムID"APGRPT.Report.3"を指定してください。ただし，バージョン依存のプログラムIDは，バージョン5以降で変更されることもあります。その場合，アプリケーションプログラムに指定されているプログラムIDの変更が必要になります。

EURをOLEオートメーションオブジェクトとして新規に作成するには，CreateObject関数の戻り値をオブジェクト変数に代入します。記述例を次に示します。

（記述例）
Set Rpt = CreateObject("APGRPT.Report")

(2)　GetObject関数による起動

指定した帳票ファイルの参照を取得します。GetObject関数の形式を次に示します。

GetObject (〔"パス名"〕 , 〔"プログラムID"〕)
パス名には，取得したいオブジェクトが含まれているファイルのパス名，および帳票ファイル名を指定します。EURのプログラムIDは，"APGRPT.Report"（バージョン非依存），または"APGRPT.Report.3"（バージョン依存）です。バージョンを特定しない場合は，バージョン非依存のプログラムID"APGRPT.Report"を指定してください。
バージョン5以降に特定する場合は，バージョン依存のプログラムID"APGRPT.Report.3"を指定してください。ただし，バージョン依存のプログラムIDは，バージョン5以降で変更されることもあります。その場合，アプリケーションプログラムに指定されているプログラムIDの変更が必要になります。

既存の帳票ファイルを開くには，GetObject関数の戻り値をオブジェクト変数に代入します。記述例を次に示します。

（記述例）
Set Rpt = GetObject("c:\eur\table.agr")


OLEオートメーションからの印刷

3.1.3　OLEオートメーションからの印刷

OLEオートメーションから印刷する場合に使用するプロパティとメソッドを次に示します。

指定項目 | 指定するプロパティとメソッド
帳票ファイル 帳票の定義情報を保存してあるレポートファイル名，またはフォームシートファイル名をApplicationオブジェクトのOpenメソッドの引数で指定します。
帳票ファイルの作成日付を取得するには，DocumentオブジェクトのCreateDateメソッドを使用します。
帳票の印刷時に表示するウィンドウの指定 ApplicationオブジェクトのWindowStyleプロパティで指定します。
ウィンドウの表示，非表示を制御する場合は，Visibleプロパティを使用します。
印刷に使用するデータの指定 印刷に使用するデータは，アプリケーションで作成済みのデータファイル，またはデータベースから読み込めます。
  • 作成済みのデータファイルからデータを読み込む場合
    MappingDataオブジェクトのDataFileNameプロパティとImportメソッドを使用します。
  • データベースからデータを読み込む場合
    ApplicationオブジェクトのDBInfoFileNameプロパティ，MappingDataオブジェクトのDataFileNameプロパティ，およびImportメソッドを使用します。
印刷するプリンタの指定 印刷プリンタは，印刷の実行を指定する前に，ApplicationオブジェクトのPrinterNameプロパティで指定します。
PrinterNameプロパティを指定しない場合は，Windowsで設定している通常使用するプリンタへ印刷されます。
ページ番号印刷に関する指定 帳票の余白にページ番号を印刷したり，ページ番号の開始値を指定したりできます。
  • 帳票の余白にページ番号を印刷する場合
    帳票の余白にページ番号を印刷する指定は，PrintPageNumberプロパティを使用します。
    ページ番号の印刷形式の指定は，PageNumberFormatプロパティを使用します。
    ページ番号の印刷位置の指定は，PageNumberLocationプロパティを使用します。
    改ページごとにページ番号を初期化する指定は，InitPageNumberプロパティを使用します。
  • ページ番号の開始値を指定する場合
    帳票設計時に設定したページ番号と，帳票の余白に印刷するページ番号の開始値は，FirstPageNumberプロパティで指定します。
印刷の実行 | DocumentオブジェクトのPrintメソッドで指定します。Printメソッドの引数で，印刷開始ページ，印刷終了ページ，および印刷部数を指定します。
印刷時の［印刷中］ダイアログの表示指定 | ApplicationオブジェクトのPrintStatusプロパティで指定します。
給紙トレイの指定 | 給紙トレイ選択機能を使用する場合は，ApplicationオブジェクトのTraySelectionプロパティを指定したあと，プリンタの給紙トレイコードをApplicationオブジェクトのTrayCodeプロパティで指定します。
出力先での帳票名表示の指定 | ApplicationオブジェクトのReportTitleプロパティで指定します。
複数様式での帳票出力の指定 複数の帳票ファイルを統合する順番と帳票に読み込むデータファイルを指定しておく帳票セット指定ファイルは，ApplicationオブジェクトのMultiReportSetFileプロパティで指定します。
様式（帳票フォーマット）や読み込むデータを切り替える条件と，切り替え時の動作を定義しておく複数様式情報定義ファイルは，ApplicationオブジェクトのMultiFormInfoDefFileプロパティで指定します。
置き換え表管理情報ファイルの指定 | 置き換え表管理情報ファイル名は，ApplicationオブジェクトのReplaceItemCntlFileプロパティで指定します。
固定ピッチフォントの文字幅計算方法の指定 | 固定ピッチフォントの文字幅計算方法は，ApplicationオブジェクトのFontWidthModeプロパティで指定します。


OLEオートメーションで使用できるEURのオブジェクト階層

3.2　OLEオートメーションで使用できるEURのオブジェクト階層

EURが提供するOLEオートメーションで使用できるオブジェクト階層を，次に示します。

表3-1　EURのオブジェクト階層

オブジェクト | 概 要
Application | 最上位のオブジェクトです。
Document | 指定した帳票の印刷，データおよび表示倍率に関する属性を変更するオブジェクトです。
MappingData | マッピングデータのデータ情報を変更するオブジェクトです。
PageSetup | ページ番号の属性の変更，保持および印刷時の用紙の向きを変更するオブジェクトです。
UserDefineData | ユーザ定義データのデータ情報を変更するオブジェクトです。


OLEオートメーションで使用できるプロパティ，メソッド一覧

3.3　OLEオートメーションで使用できるプロパティ，メソッド一覧

各オブジェクトのプロパティとメソッドの概要を説明します。

＜この節の構成＞
3.3.1　OLEオートメーションで使用できるプロパティ一覧
3.3.2　OLEオートメーションで使用できるメソッド一覧


OLEオートメーションで使用できるプロパティ一覧

3.3.1　OLEオートメーションで使用できるプロパティ一覧

次の表に，OLEオートメーションで使用できるプロパティをアルファベット順で記載します。

表3-2　OLEオートメーションで使用できるプロパティ

オブジェクト | プロパティ | 概要
Application | Application［R］ | Applicationオブジェクトの参照を取得します。
 | DBInfoFileName | 接続情報ファイル名を指定，または取得します。
 | DBInfoFilePath | 接続情報ファイルのある場所を指定，または取得します。
 | Document［R］ | Documentオブジェクトの参照を取得します。
 | Editable | 帳票を編集するかしないかを指定，または取得します。
 | FontWidthMode | 固定ピッチフォントの文字幅計算方法を指定，または取得します。
 | FrontSubWindow | 最前面のサブウィンドウを指定，または取得します。
 | FullName［R］ | 帳票の実行ファイルのパス名を含むファイル名を取得します。
 | Height | メインウィンドウの上端から下端までの距離を指定，または取得します。
 | ImageBasePath | 画像データファイルのある場所を指定，または取得します。
 | Left | ディスプレイの左端からメインウィンドウまでの距離を指定，または取得します。
 | MainWindowStatus | メインウィンドウの表示状態を指定，または取得します。
 | MapDataBasePath | マッピングデータ用のファイルのある場所を指定，または取得します。
 | MultiFormInfoDefBasePath | 複数様式で帳票を出力するための複数様式情報定義ファイルのある場所を指定，または取得します。
 | MultiFormInfoDefFile | 複数様式で帳票を出力するための複数様式情報定義ファイル名を指定，または取得します。
 | MultiReportSetBasePath | 複数様式で帳票を出力するための帳票セット指定ファイルのある場所を指定，または取得します。
 | MultiReportSetFile | 複数様式で帳票を出力するための帳票セット指定ファイル名を指定，または取得します。
 | Name［R］ | EUR部品の名称を取得します。
 | Parent［R］ | 親オブジェクト（Applicationオブジェクト）の参照を取得します。
 | PrinterName | 帳票を出力するプリンタ名を指定，または取得します。
 | PrintFileName | 帳票を出力するファイル名を指定，または取得します。
 | PrintFileOut | DocumentオブジェクトのPrint，またはPrintOutメソッドを実行したとき，PrintFileNameプロパティで指定したファイルに帳票を出力するかどうかを指定，または取得します。
 | PrintStatus | 印刷時に，［印刷中］ダイアログを表示するかどうかを指定，または取得します。
 | ReplaceItemCntlFile | 置き換え表ファイルを管理するための置き換え表管理情報ファイル名を指定，または取得します。
 | ReplaceItemCntlFilePath | 置き換え表管理情報ファイルのある場所を指定，または取得します。
 | ReplaceItemFilePath | 置き換え表ファイルのある場所を指定，または取得します。
 | ReportBasePath | 帳票ファイル（レポートファイル，またはフォームシートファイル）のある場所を指定，または取得します。
 | ReportTitle | プリンタの印刷待ち状態を確認する一覧ウィンドウの「ドキュメント名」，およびタイトルバーに表示する帳票名を指定，または取得します。
 | SubWindowStatus | サブウィンドウの表示状態を指定，または取得します。
 | Top | ディスプレイの上端からメインウィンドウまでの距離を指定，または取得します。
 | TrayCode | TraySelectionプロパティを指定して，給紙トレイ選択機能を使用する場合，プリンタの給紙トレイコードを指定，または取得します。
 | TraySelection | 給紙トレイ選択機能を使用するかどうかを指定，または取得します。
 | UserDataBasePath | ユーザ定義データ用のファイルのある場所を指定，または取得します。
 | Visible | メインウィンドウを表示するかどうかを指定，または取得します。
 | Width | メインウィンドウの右端から左端までの距離を指定，または取得します。
 | WindowStyle | 表示するメインウィンドウのスタイルを指定，または取得します。
Document | Application［R］ | Applicationオブジェクトの参照を取得します。
 | CurrentPage | 現在開いている帳票のページを指定，または取得します。
 | DataFile | マッピングデータ用のデータファイル名を指定，または取得します。
 | FitToWindow | 帳票のページ全体を帳票ウィンドウに入る大きさで表示するかしないかを指定，または取得します。
 | FullName［R］ | 帳票ファイル（レポートファイル，またはフォームシートファイル）のパス名を含むファイル名を取得します。
 | LastPage［R］ | 現在開いている帳票の最終ページ数を取得します。
 | MappingData［R］ | MappingDataオブジェクトの参照を取得します。
 | Name［R］ | 帳票ファイル（レポートファイル，またはフォームシートファイル）のパスを含まないファイル名を取得します。
 | PageSetup［R］ | PageSetupオブジェクトの参照を取得します。
 | Parent［R］ | 親オブジェクト（Applicationオブジェクト）の参照を取得します。
 | Path［R］ | 帳票ファイル（レポートファイル，またはフォームシートファイル）のファイル名を含まないパス名を取得します。
 | UserDefineData［R］ | UserDefineDataオブジェクトの参照を取得します。
 | VarDataFile | ユーザ定義データ用のデータファイル名を指定，または取得します。
 | Zoom | 帳票のズーム倍率を指定，または取得します。
MappingData | Application［R］ | Applicationオブジェクトの参照を取得します。
 | DataFileName | データファイル名，または可変記号値定義ファイル名を指定，または取得します。
 | Parent［R］ | 親オブジェクト（Documentオブジェクト）の参照を取得します。
PageSetup | Application［R］ | Applicationオブジェクトの参照を取得します。
 | FirstPageNumber | ページ番号を印刷するときの印刷開始値を指定，または取得します。
 | InitPageNumber | 改ページごとにページ番号を開始番号に初期化（FirstPageNumberの値）するかしないかを指定，または取得します。
 | PageNumberFormat | 余白のページ番号の印刷形式を指定，または取得します。
 | PageNumberLocation | 余白のページ番号の印刷位置を指定，または取得します。
 | PaperOrientation | 印刷するときの用紙の向きを指定，または取得します。
 | Parent［R］ | 親オブジェクト（Documentオブジェクト）の参照を取得します。
 | PrintPageNumber | 余白へページ番号を印刷するかしないかを指定，または取得します。
 | Sorting | 2部以上印刷する場合の印刷単位（部単位，ページ単位）を指定，または取得します。
UserDefineData | Application［R］ | Applicationオブジェクトの参照を取得します。
 | DataFileName | データファイル名，または可変記号値定義ファイル名を指定，または取得します。
 | Parent［R］ | 親オブジェクト（Documentオブジェクト）の参照を取得します。
（凡例）
［R］：参照だけできるプロパティを示します


OLEオートメーションで使用できるメソッド一覧

3.3.2　OLEオートメーションで使用できるメソッド一覧

次の表に，OLEオートメーションで使用できるメソッドをアルファベット順で記載します。

表3-3　OLEオートメーションで使用できるメソッド

オブジェクト | メソッド | 概要
Application | Open | レポートファイル名（*.agr）またはフォームシートファイル名（*.fms）を指定して帳票ファイルを開きます。
 | Quit | EURを終了します。
Document | Activate | 指定したドキュメントのメインウィンドウをアクティブにします。
 | CreateDate | 帳票の作成日付を取得します。
 | Print | 帳票を印刷します。
 | PrintOut | 印刷開始終了ページと印刷部数を指示します。
MappingData | Import | プロパティに設定されている条件で，マッピングデータウィンドウにデータを入力します。
UserDefineData | Import | プロパティに設定されている条件で，ユーザ定義データウィンドウにデータを入力します。


OLEオートメーションで使用できるプロパティ仕様

3.4　OLEオートメーションで使用できるプロパティ仕様

EURが提供するOLEオートメーションで使用できるプロパティの詳細を説明します。

＜この節の構成＞
Applicationプロパティ
CurrentPageプロパティ
DataFileNameプロパティ
DataFileプロパティ
DBInfoFileNameプロパティ
DBInfoFilePathプロパティ
Documentプロパティ
Editableプロパティ
FirstPageNumberプロパティ
FitToWindowプロパティ
FontWidthModeプロパティ
FrontSubWindowプロパティ
FullNameプロパティ
Heightプロパティ
ImageBasePathプロパティ
InitPageNumberプロパティ
LastPageプロパティ
Leftプロパティ
MainWindowStatusプロパティ
MapDataBasePathプロパティ
MappingDataプロパティ
MultiFormInfoDefBasePathプロパティ
MultiFormInfoDefFileプロパティ
MultiReportSetBasePathプロパティ
MultiReportSetFileプロパティ
Nameプロパティ
PageNumberFormatプロパティ
PageNumberLocationプロパティ
PageSetupプロパティ
PaperOrientationプロパティ
Parentプロパティ
Pathプロパティ
PrinterNameプロパティ
PrintFileNameプロパティ
PrintFileOutプロパティ
PrintPageNumberプロパティ
PrintStatusプロパティ
ReportBasePathプロパティ
ReplaceItemCntlFileプロパティ
ReplaceItemCntlFilePathプロパティ
ReplaceItemFilePathプロパティ
ReportTitleプロパティ
Sortingプロパティ
SubWindowStatusプロパティ
Topプロパティ
TrayCodeプロパティ
TraySelectionプロパティ
UserDataBasePathプロパティ
UserDefineDataプロパティ
VarDataFileプロパティ
Visibleプロパティ
Widthプロパティ
WindowStyleプロパティ
Zoomプロパティ


Applicationプロパティ

Applicationプロパティ

Applicationオブジェクトの参照を取得します。

対象

Application，Document，PageSetup，MappingData，UserDefineData

解説

Applicationオブジェクトのプロパティやメソッドを使用する場合に，Applicationプロパティで値を取得します。

データ型

Object

記述例

オブジェクト型変数rptで参照しているDocumentオブジェクトからApplicationオブジェクトの参照を取得し，オブジェクト型変数appに代入します。

Set app = rpt.Application


CurrentPageプロパティ

CurrentPageプロパティ

現在開いている帳票のページを指定，または取得します。

対象

Document

解説

現在開いている帳票の最終ページ数を超える値を設定した場合は，最終ページが表示されます。また，値を取得する場合は，最終ページ数を返します。

データ型

Integer

記述例

現在開いている帳票の2ページ目が表示されます。

rpt.CurrentPage = 2


DataFileNameプロパティ

DataFileNameプロパティ

データファイル名，または可変記号値定義ファイル名を指定，または取得します。

対象

MappingData，UserDefineData

解説

データファイルからデータを入力する場合，またはデータベースからデータを入力する場合，DataFileNameプロパティを指定します。実際にデータを入力する場合は，Importメソッドを呼び出す必要があります。DataFileNameプロパティを設定したあと，Openメソッド，または［ファイルを開く］ダイアログで帳票ファイルを開くと，ファイルの指定は無効になります。ファイル名をフルパスで指定しなかった場合，ファイル名には，［オプション］ダイアログの［ファイル］タブで指定されているマッピングデータファイル，ユーザ定義データファイル，または可変記号値定義ファイルのパス名が付きます。ただし，次に示す操作をしたときは，変更後のパス名が付きます。

  • 前回，DataFileNameプロパティで指定したファイルのパス名
  • ［データファイルの指定］ダイアログで，データファイルを指定したときのパス名

上記以外のフォルダにあるファイルを指定したい場合は，フルパスで指定してください。

ファイルの参照は，ファイル名をフルパスで取得します。指定したファイルがない場合や，ファイルの記述に誤りがある場合は，エラーになります。

複数様式帳票指定時のプロパティの扱い
  • DataFileNameプロパティを設定したあと，Openメソッドの実行によって複数様式帳票が開かれたときは，指定された値は無効になります。
  • Openメソッドの実行によって複数様式帳票が開かれているときにDataFileNameプロパティを指定しても，値は無効になります。
  • DataFileNameプロパティを指定して値を取得するときは，NULL文字列を返します。

データ型

String

記述例

オブジェクト型変数rptで参照している帳票にデータファイルを指定，または取得します。可変記号値定義ファイルの記述のしかたも同じです。

  • 対象が，MappingDataオブジェクトの場合
    • データファイルをファイル名で指定する場合
      rpt.MappingData.DataFileName = "tbl.dat"
    • データファイルをフルパスで指定する場合
      rpt.MappingData.DataFileName = "c:\eur\tbl.dat"
    • データファイルを参照し，文字列型変数filenameに代入する場合
      filename = rpt.MappingData.DataFileName
  • 対象が，UserDefineDataオブジェクトの場合
    • データファイルをファイル名で指定する場合
      rpt.UserDefineData.DataFileName = "tbl.dat"
    • データファイルをフルパスで指定する場合
      rpt.UserDefineData.DataFileName = "c:\eur\tbl.dat"
    • データファイルを参照し，文字列型変数filenameに代入する場合
      filename = rpt.UserDefineData.DataFileName

エラーメッセージ

コード | メッセージ
1005 | メモリ不足が発生しました。
1134 | 処理中にエラーが発生しました。
1135 | Windowsでエラーが発生しました。
4506 | データファイル（データファイル名）が見つかりません。
4508 | データファイル名（データファイル名）が正しくありません。
4518 | データファイル名が指定されていません。
4529 | データファイル（データファイル名）：n行目 記述に誤りがあります。
4531 | データファイル（データファイル名）がオープンできません。
4553 | データファイル（データファイル名）には読み込み権限がありません。
4638 | 不正なファイル名（ファイル名）が指定されました。
4653 | マッピングデータ用の可変記号値定義ファイル（可変記号値定義ファイル名）が見つかりません。
4654 | マッピングデータ用の可変記号値定義ファイル（可変記号値定義ファイル名）をオープンできませんでした。
4655 | マッピングデータ用の可変記号値定義ファイル（可変記号値定義ファイル名）には読み込み権限がありません。
4658 | 指定したマッピングデータ用の可変記号値定義ファイル（可変記号値定義ファイル名）の内容が不正です。（エラーコード：変数名）
4667 | ユーザ定義データ用の可変記号値定義ファイル（可変記号値定義ファイル名）が見つかりません。
4668 | ユーザ定義データ用の可変記号値定義ファイル（可変記号値定義ファイル名）をオープンできませんでした。
4669 | ユーザ定義データ用の可変記号値定義ファイル（可変記号値定義ファイル名）には読み込み権限がありません。
4672 | 指定したユーザ定義データ用の可変記号値定義ファイル（可変記号値定義ファイル名）の内容が不正です。（エラーコード：変数名）


DataFileプロパティ

DataFileプロパティ

マッピングデータ用のデータファイル名を指定，または取得します。

対象

Document

解説

既存の帳票のフォーマットを利用して，別のデータを帳票に表示する場合に，DataFileプロパティでデータファイル名を指定します。DataFileプロパティを設定したあと，Openメソッド，または［ファイルを開く］ダイアログで帳票ファイルを開くと，データファイルの指定は無効になります。データファイル名をフルパスで指定しなかった場合，ファイル名には，［オプション］ダイアログの［ファイル］タブで指定されているマッピングデータファイルのパス名が付きます。ただし，次に示す操作をしたときは，変更後のパス名が付きます。

  • 前回，DataFileプロパティで指定したファイルのパス名
  • ［データファイルの指定］ダイアログで，データファイルを指定したときのパス名

上記以外のフォルダにあるデータファイルを指定したい場合は，フルパスで指定してください。

データファイルの参照は，ファイル名をフルパスで取得します。指定したデータファイルがない場合や，データファイルの記述に誤りがある場合は，エラーになります。

なお，データファイル名を指定する場合は，DataFileプロパティよりも，MappingDataオブジェクトのDataFileNameプロパティを使用されることをお勧めします。

複数様式帳票指定時のプロパティの扱い
  • DataFileプロパティを設定したあと，Openメソッドの実行によって複数様式帳票が開かれたときは，指定された値は無効になります。
  • Openメソッドの実行によって複数様式帳票が開かれているときにDataFileプロパティを指定しても，値は無効になります。
  • DataFileプロパティを指定して値を取得するときは，NULL文字列を返します。

データ型

String

記述例

オブジェクト型変数rptで参照している帳票にデータファイルを指定，または取得します。

  • データファイルをファイル名で指定する場合
    rpt.DataFile = "tbl.dat"
  • データファイルをフルパスで指定する場合
    rpt.DataFile = "c:\eur\tbl.dat"
  • データファイルを参照し，文字列型変数filenameに代入する場合
    filename = rpt.DataFile

エラーメッセージ

コード | メッセージ
1005 | メモリ不足が発生しました。
1134 | 処理中にエラーが発生しました。
1135 | Windowsでエラーが発生しました。
4506 | データファイル（データファイル名）が見つかりません。
4508 | データファイル名（データファイル名）が正しくありません。
4518 | データファイル名が指定されていません。
4529 | データファイル（データファイル名）：n行目 記述に誤りがあります。
4531 | データファイル（データファイル名）がオープンできません。
4553 | データファイル（データファイル名）には読み込み権限がありません。


DBInfoFileNameプロパティ

DBInfoFileNameプロパティ

接続情報ファイル名を指定，または取得します。

対象

Application

解説

接続情報ファイル名を指定します。接続情報ファイル名は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。ファイル名をフルパスで指定しなかった場合は，次に示す順にファイルを検索します。

  1. DBInfoFilePathプロパティに指定されているフォルダ
  2. ［オプション］ダイアログの［ファイル］タブで，「接続情報ファイル」に指定されているフォルダ
複数様式帳票指定時のプロパティの扱い
DBInfoFileNameプロパティは，複数様式帳票の出力に対応していません。
複数の帳票セットを指定して出力する場合は，MultiReportSetFileプロパティで帳票セット指定ファイルに指定してください。

データ型

String

記述例

オブジェクト型変数rptで参照している帳票に接続情報ファイルを指定，または取得します。

  • 接続情報ファイルをファイル名で指定する場合
    rpt.Application.DBInfoFileName = "dbinfo.txt"
  • 接続情報ファイルをフルパスで指定する場合
    rpt.Application.DBInfoFileName = "c:\eur\dbinfo.txt"
  • 接続情報ファイルを参照し，文字列型変数filenameに代入する場合
    filename = rpt.Application.DBInfoFileName

エラーメッセージ

コード | メッセージ
4638 | 不正なファイル名（ファイル名）が指定されました。
4647 | 接続情報ファイル（接続情報ファイル名）をオープンできませんでした。
4648 | 接続情報ファイル（接続情報ファイル名）には読み込み権限がありません。
4651 | 指定した接続情報ファイル（接続情報ファイル名）の内容が不正です。（エラーコード：キーワード）
4676 | 接続情報ファイル（接続情報ファイル名）が見つかりません。


DBInfoFilePathプロパティ

DBInfoFilePathプロパティ

接続情報ファイルのある場所を指定，または取得します。

対象

Application

解説

指定されたフォルダは，DBInfoFileNameプロパティで指定するファイルのデフォルトになります。また，DBInfoFilePathプロパティは，現在指定されている接続情報ファイルのパスを取得することもできます。例えば，「c:\eur\file\dbinfo\」や「c:\」のように，文字列の最後に「\」の付いた形式で，ファイルのパスを取得できます。

データ型

String

記述例

接続情報ファイルのデフォルトパスを指定します。

rpt.Application.DBInfoFilePath = "c:\eur\file\dbinfo"

エラーメッセージ

コード | メッセージ
4649 | 接続情報ファイルの場所にパス名が指定されていません。
4650 | 接続情報ファイルの場所に指定されたパス（パス名）が見つかりません。


Documentプロパティ

Documentプロパティ

Documentオブジェクトの参照を取得します。

対象

Application

解説

Documentオブジェクトのプロパティやメソッドを使用する場合に，Documentプロパティで値を取得します。

データ型

Object

記述例

オブジェクト型変数rptで参照している帳票のApplicationオブジェクトからDocumentオブジェクトの参照を取得し，オブジェクト型変数docに代入します。

Set doc = rpt.Application.Document


Editableプロパティ

Editableプロパティ

帳票を編集するかどうかを指定，または取得します。

指定値 | 説 明
True | 編集します。
False | 編集しません。ただし，表示と印刷はできます。

省略した場合は，Trueが仮定されます。

対象

Application

解説

Editableプロパティは，WindowStyleプロパティの機能と似た機能を提供していますが，表示するウィンドウを指定する場合は，WindowStyleプロパティを使用されることをお勧めします。

なお，EditableプロパティでTrueを指定した場合は，WindowStyleプロパティの値が1に変更されます。EditableプロパティでFalseを指定した場合は，WindowStyleプロパティの値が2に変更されます。

複数様式帳票指定時のプロパティの扱い
  • Openメソッドの実行によって複数様式帳票が開かれているときにEditableプロパティを指定しても，値は無効になります。

データ型

Boolean

記述例

オブジェクト型変数rptで参照している帳票を編集するかどうかを指定します。

  • 帳票を編集する場合
    rpt.Application.Editable = True
  • 帳票のレイアウトを確認する（編集しない）場合
    rpt.Application.Editable = False

エラーメッセージ

コード | メッセージ
1130 | 画面描画処理中にエラーが発生しました。
1134 | 処理中にエラーが発生しました。
1135 | Windowsでエラーが発生しました。


FirstPageNumberプロパティ

FirstPageNumberプロパティ

ページ番号を印刷するときの印刷開始値を指定，または取得します。

対象

PageSetup

解説

印刷開始値として指定できる値は，1～32,767です。1～32,767の範囲外の値を指定した場合は，エラーになります。省略した場合は，［レポートのプロパティ］ダイアログの［レポートの構成］タブで指定されている値が仮定されます。初期値は1です。

複数様式帳票指定時のプロパティの扱い
  • FirstPageNumberプロパティを設定したあと，Openメソッドの実行によって複数様式帳票が開かれたときは，指定された値は無効になります。
  • Openメソッドの実行によって複数様式帳票が開かれているときにFirstPageNumberプロパティを指定しても，値は無効になります。
  • FirstPageNumberプロパティを指定して値を取得するときは，1を返します。

データ型

Integer

記述例

オブジェクト型変数rptで参照している帳票のページ番号の印刷開始値を5とします。

rpt.PageSetup.FirstPageNumber = 5

エラーメッセージ

コード | メッセージ
1134 | 処理中にエラーが発生しました。
1135 | Windowsでエラーが発生しました。
4516 | 印刷開始番号は1～32767の値で設定してください。


FitToWindowプロパティ

FitToWindowプロパティ

帳票のページ全体を帳票ウィンドウに表示できるように，帳票の表示倍率を変更するかしないかを指定，または取得します。

指定値 | 説 明
True | 変更します。Zoomプロパティに0を指定したときに有効です。
False | 変更しません。Zoomプロパティに指定した大きさで表示されます。

省略した場合は，Falseが仮定されます。

対象

Document

データ型

Boolean

記述例

オブジェクト型変数rptで参照している帳票の表示倍率を，帳票のページ全体を帳票ウィンドウに表示できるように変更します。

rpt.Zoom = 0

rpt.FitToWindow = True

エラーメッセージ

コード | メッセージ
1134 | 処理中にエラーが発生しました。
1135 | Windowsでエラーが発生しました。


FontWidthModeプロパティ

FontWidthModeプロパティ

固定ピッチフォントの文字幅計算方法を指定，または取得します。EUR 帳票作成機能での固定ピッチフォントの文字幅計算方法の詳細については，マニュアル「EUR 帳票作成 操作ガイド」を参照してください。EUR サーバ帳票出力機能での固定ピッチフォントの文字幅計算方法の詳細については，マニュアル「EUR システム設計ガイド」を参照してください。

指定値 | 説 明
0 | 固定ピッチフォントの文字幅は固定値になります。 半角文字はアイテムのフォント幅，全角文字はアイテムのフォント幅の2倍になります。
1 | 固定ピッチフォントの文字幅は，使用するフォントに合わせて決定されます。

指定を省略した場合は，帳票ウィンドウの［オプション］ダイアログの［表示］タブにある，［文字幅計算方法］グループボックスの設定値が適用されます。

対象

Application

データ型

Integer

記述例

オブジェクト型変数rptで参照している帳票を印刷するときに，固定ピッチフォントの文字幅を固定値にします。

rpt.Application.FontWidthMode = 0

エラーメッセージ

コード | メッセージ
4696 | 文字幅計算方法の指定に誤りがあります。


FrontSubWindowプロパティ

FrontSubWindowプロパティ

最前面のサブウィンドウを指定，または取得します。

指定値 | 説 明
1 | 帳票ウィンドウが表示されます。
2 | マッピングデータウィンドウが表示されます。
3 | ユーザ定義データウィンドウが表示されます。

省略した場合は，1が仮定されます。上記以外の値を指定した場合は，エラーになります。

対象

Application

データ型

Integer

記述例

オブジェクト型変数rptで参照しているウィンドウでは，帳票ウィンドウが最前面に表示されます。

rpt.Application.FrontSubWindow = 1

エラーメッセージ

コード | メッセージ
4603 | FrontSubWindowプロパティの指定値が不正です。


FullNameプロパティ

FullNameプロパティ

  • 対象が，Applicationオブジェクトの場合
    帳票の実行ファイルのパス名を含むファイル名を取得します。
  • 対象が，Documentオブジェクトの場合
    帳票ファイル（レポートファイル，またはフォームシートファイル）のパス名を含むファイル名を取得します。

対象

Application，Document

解説

複数様式帳票指定時のプロパティの扱い
  • 対象が，Applicationオブジェクトの場合
    同時に指定しても，値は有効です。
  • 対象が，Documentオブジェクトの場合
    Openメソッドの実行によって複数様式帳票が開かれている場合にFullNameプロパティを指定したときは，NULLを返します。

データ型

String

記述例

  • 対象が，Applicationオブジェクトの場合
    オブジェクト型変数rptで参照している帳票の実行ファイル名を取得し，文字列型変数rptexeに代入します。
    rptexe = rpt.Application.FullName
  • 対象が，Documentオブジェクトの場合
    オブジェクト型変数rptで参照している帳票の帳票ファイル名（レポートファイル名，またはフォームシートファイル名）を取得し，文字列型変数rptnameに代入します。
    rptname = rpt.FullName

エラーメッセージ

コード | メッセージ
1005 | メモリ不足が発生しました。
1134 | 処理中にエラーが発生しました。
1135 | Windowsでエラーが発生しました。


Heightプロパティ

Heightプロパティ

メインウィンドウの上端から下端までの距離を指定，または取得します。

対象

Application

データ型

Integer

記述例

オブジェクト型変数rptで参照しているメインウィンドウの高さを500ピクセルにします。

rpt.Application.Height = 500


ImageBasePathプロパティ

ImageBasePathプロパティ

画像データファイルのある場所を指定，または取得します。指定されたファイルのパスは，画像データファイルを開くときのデフォルトになります。

対象

Application

解説

画像を挿入するときにファイルのパスを変更すると，それ以降は，変更後のファイルのパスがデフォルトになります。また，ImageBasePathプロパティは，現在指定されている画像ファイルのパスを取得することもできます。例えば，「c:\eur\file\image\」や「c:\」のように，文字列の最後に「\」の付いた形式で，ファイルのパスを取得できます。

データ型

String

記述例

画像データファイルのデフォルトパスを指定します。

rpt.Application.ImageBasePath = "c:\eur\file\image"

エラーメッセージ

コード | メッセージ
4580 | 画像ファイルの場所にパス名が指定されていません。
4581 | 画像ファイルの場所に指定されたパス（パス名）が見つかりません。


InitPageNumberプロパティ

InitPageNumberプロパティ

改ページごとに，ページ番号の開始番号を初期化するかどうかを指定，または取得します。

指定値 | 説 明
True | 初期化します。
False | 初期化しません。

対象

PageSetup

解説

省略した場合は，［レポートのプロパティ］ダイアログの［レポートの構成］タブで指定されている値が仮定されます。初期値は，Falseです。

なお，［アイテムのプロパティ］ダイアログの［表示形式（ページ番号）］タブで［バージョン3形式］が選択されている場合は，InitPageNumberプロパティの指定は無視されます。

複数様式帳票指定時のプロパティの扱い
  • InitPageNumberプロパティを設定したあと，Openメソッドの実行によって複数様式帳票が開かれたときは，指定された値は無効になります。
  • Openメソッドの実行によって複数様式帳票が開かれているときにInitPageNumberプロパティを指定しても，値は無効になります。
  • InitPageNumberプロパティを指定して値を取得するときは，Falseを返します。

データ型

Boolean

記述例

オブジェクト型変数rptで参照している帳票を印刷するときに，改ページごとにページ番号を1から振り直します。

rpt.PageSetup.FirstPageNumber = 1

rpt.PageSetup.InitPageNumber = True


LastPageプロパティ

LastPageプロパティ

現在開いている帳票の最終ページ数を取得します。

対象

Document

データ型

Integer

記述例

現在開いている帳票の最終ページを，変数MaxPageに取得します。

MaxPage = rpt.LastPage


Leftプロパティ

Leftプロパティ

ディスプレイの左端からメインウィンドウまでの距離を指定，または取得します。

対象

Application

データ型

Integer

記述例

オブジェクト型変数rptで参照しているメインウィンドウをディスプレイの左端から50ピクセルの位置に表示します。

rpt.Application.Left = 50


MainWindowStatusプロパティ

MainWindowStatusプロパティ

メインウィンドウの表示状態を指定，または取得します。

指定値 | 説 明
1 | フォーカスを持った，通常のウィンドウが表示されます。
2 | フォーカスを持ち，アイコン化されているウィンドウで表示されます。
3 | フォーカスを持ち，最大表示されているウィンドウで表示されます。

省略した場合は，1が仮定されます。上記以外の値を指定した場合は，エラーになります。

対象

Application

データ型

Integer

記述例

オブジェクト型変数rptで参照しているウィンドウを最大表示にします。

rpt.Application.MainWindowStatus = 3

エラーメッセージ

コード | メッセージ
4601 | MainWindowStatusプロパティの指定値が不正です。


MapDataBasePathプロパティ

MapDataBasePathプロパティ

マッピングデータ用のファイルのある場所を指定，または取得します。指定されたファイルのパスは，MappingDataオブジェクトのDataFileNameプロパティで指定するデータファイル，もしくは可変記号値定義ファイル，またはDocumentオブジェクトのDataFileプロパティで指定するマッピングデータファイルのデフォルトになります。

対象

Application

解説

DataFileNameプロパティでファイル名をフルパスで指定するか，または別のフォルダにあるファイル名を開いた場合は，それ以降，変更後のファイルのパスがデフォルトになります。また，MapDataBasePathプロパティは，現在指定されているファイルのパスを取得することもできます。例えば，「c:\eur\file\mapdata\」や「c:\」のように，文字列の最後に「\」の付いた形式で，ファイルのパスを取得できます。

データ型

String

記述例

データファイルのデフォルトパスを指定してデータファイルを開きます。可変記号値定義ファイルも記述のしかたは同じです。

rpt.Application.MapDataBasePath = "c:\eur\file\mapdata"

rpt.MappingData.DataFileName = "data.dat"

エラーメッセージ

コード | メッセージ
4568 | マッピングデータファイルの場所にパス名が指定されていません。
4569 | マッピングデータファイルの場所に指定されたパス（パス名）が見つかりません。
4656 | マッピングデータ用の可変記号値定義ファイルの場所にパス名が指定されていません。
4657 | マッピングデータ用の可変記号値定義ファイルの場所に指定されたパス（パス名）が見つかりません。


MappingDataプロパティ

MappingDataプロパティ

MappingDataオブジェクトの参照を取得します。

対象

Document

解説

MappingDataオブジェクトのプロパティやメソッドを使用する場合に，MappingDataプロパティで値を取得します。

複数様式帳票指定時のプロパティの扱い
  • MappingDataプロパティを指定して値を取得するときは，NULLを返します。

データ型

Object

記述例

MappingDataプロパティでMappingDataオブジェクトの参照を取得し，オブジェクト型変数mapdataに代入します。

Set mapdata = rpt.MappingData


MultiFormInfoDefBasePathプロパティ

MultiFormInfoDefBasePathプロパティ

複数様式で帳票を出力するための複数様式情報定義ファイルのある場所を指定，または取得します。指定されたファイルのパスは，ApplicationオブジェクトのMultiFormInfoDefFileプロパティで指定する複数様式情報定義ファイルのデフォルトになります。

対象

Application

解説

MultiFormInfoDefFileプロパティで複数様式情報定義ファイル名をフルパスで指定するか，または別のフォルダにある複数様式情報定義ファイルを指定した場合は，それ以降，変更後のファイルのパスがデフォルトになります。また，MultiFormInfoDefBasePathプロパティは，現在指定されている複数様式情報定義ファイルのパスを取得することもできます。例えば，「c:\eur\file\multiform\」や「c:\」のように，文字列の最後に「\」の付いた形式で，ファイルのパスを取得できます。

データ型

String

記述例

複数様式情報定義ファイルのデフォルトパスを指定して，複数様式で帳票を出力します。

rpt.Application.MultiFormInfoDefBasePath = "c:\eur\file\multiform"

rpt.Application.MultiFormInfoDefFile = "multiform.txt"

rpt.Application.MultiReportSetBasePath = "c:\eur\file\reportset"

rpt.Application.MultiReportSetFile = "reportset.txt"

rpt.Application.Open("report.fms")

エラーメッセージ

コード | メッセージ
4629 | 複数様式情報定義ファイルの場所にパス名が指定されていません。
4630 | 複数様式情報定義ファイルの場所に指定されたパス（パス名）が見つかりません。


MultiFormInfoDefFileプロパティ

MultiFormInfoDefFileプロパティ

複数様式で帳票を出力するための複数様式情報定義ファイル名を指定，または取得します。

対象

Application

解説

複数様式情報定義ファイルは，様式（帳票フォーマット）や読み込むデータを切り替える条件と，切り替え時の動作を定義しておくファイルです。複数様式情報定義ファイルについては，「5.7　複数様式情報定義ファイル」を参照してください。

データ型

String

記述例

複数様式情報定義ファイル名を指定して，複数様式で帳票を出力します。

rpt.Application.MultiFormInfoDefFile = "c:\eur\file\multiform\multiform.txt"

rpt.Application.MultiReportSetBasePath = "c:\eur\file\reportset"

rpt.Application.MultiReportSetFile = "reportset.txt"

rpt.Application.Open("report.fms")

エラーメッセージ

コード | メッセージ
4630 | 複数様式情報定義ファイルの場所に指定されたパス（パス名）が見つかりません。


MultiReportSetBasePathプロパティ

MultiReportSetBasePathプロパティ

複数様式で帳票を出力するための帳票セット指定ファイルのある場所を指定，または取得します。指定されたファイルのパスは，ApplicationオブジェクトのMultiReportSetFileプロパティで指定する帳票セット指定ファイルのデフォルトになります。

対象

Application

解説

MultiReportSetFileプロパティで帳票セット指定ファイル名をフルパスで指定するか，または別のフォルダにある帳票セット指定ファイルを指定した場合は，それ以降，変更後のファイルのパスがデフォルトになります。また，MultiReportSetBasePathプロパティは，現在指定されている帳票セット指定ファイルのパスを取得することもできます。例えば，「c:\eur\file\reportset\」や「c:\」のように，文字列の最後に「\」の付いた形式で，ファイルのパスを取得できます。

データ型

String

記述例

帳票セット指定ファイルのデフォルトパスを指定して，複数様式で帳票を出力します。

rpt.Application.MultiReportSetBasePath = "c:\eur\file\reportset"

rpt.Application.MultiReportSetFile = "reportset.txt"

rpt.Application.MultiFormInfoDefBasePath = "c:\eur\file\multiform"

rpt.Application.MultiFormInfoDefFile = "multiform.txt"

rpt.Application.Open("report.fms")

エラーメッセージ

コード | メッセージ
4624 | 帳票セット指定ファイルの場所にパス名が指定されていません。
4625 | 帳票セット指定ファイルの場所に指定されたパス（パス名）が見つかりません。


MultiReportSetFileプロパティ

MultiReportSetFileプロパティ

複数様式で帳票を出力するための帳票セット指定ファイルを指定，または取得します。

対象

Application

解説

帳票セット指定ファイルは，複数の帳票ファイルを統合する順番と帳票に読み込むデータファイルを指定しておくファイルです。帳票セット指定ファイルについては，「5.6　帳票セット指定ファイル」を参照してください。

データ型

String

記述例

帳票セット指定ファイル名を指定して，複数様式で帳票を出力します。

rpt.Application.MultiReportSetBasePath = "c:\eur\file\reportset"

rpt.Application.MultiReportSetFile = "reportset.txt"

rpt.Application.MultiFormInfoDefBasePath = "c:\eur\file\multiform"

rpt.Application.MultiFormInfoDefFile = "multiform.txt"

rpt.Application.Open("report.fms")

エラーメッセージ

コード | メッセージ
4625 | 帳票セット指定ファイルの場所に指定されたパス（パス名）が見つかりません。


Nameプロパティ

Nameプロパティ

  • 対象が，Applicationオブジェクトの場合
    レポートオブジェクトの名称を取得します。
  • 対象が，Documentオブジェクトの場合
    帳票ファイル（レポートファイル，またはフォームシートファイル）のパスを含まないファイル名を取得します。

対象

Application，Document

解説

複数様式帳票指定時のプロパティの扱い
  • 対象が，Applicationオブジェクトの場合
    同時に指定しても，値は有効です。
  • 対象が，Documentオブジェクトの場合
    Openメソッドの実行によって複数様式帳票が開かれている場合にDictionaryFileプロパティを指定したときは，NULLを返します。

データ型

String

記述例

  • 対象が，Applicationオブジェクトの場合
    オブジェクト型変数rptで参照しているレポートオブジェクトの名称を取得し，文字列型変数rptobjに代入します。
    rptobj = rpt.Application.Name
  • 対象が，Documentオブジェクトの場合
    オブジェクト型変数rptで参照している帳票の帳票ファイル名（レポートファイル名，またはフォームシートファイル名）を取得し，文字列型変数rptnameに代入します。
    rptname = rpt.Name


PageNumberFormatプロパティ

PageNumberFormatプロパティ

余白のページ番号の印刷形式を指定，または取得します。

対象

PageSetup

解説

余白のページ番号を「*」，最終ページ番号を「$」で示して印刷形式を指定します。ページ番号および最終ページ番号を全角で表示したいときは全角の記号，半角で表示したいときは半角の記号を指定します。省略した場合は，［レポートのプロパティ］ダイアログの［レポートの構成］タブで指定されている値が仮定されます。初期値は「-*-」です。ページ番号の指定例を次に示します。

表3-4　ページ番号の指定例とその出力結果

ページ番号の指定例 | 出力結果
* | 1
-*- | -1-
-*/$- | -1/5-
(*) | (1)

PageNumberFormatプロパティに指定できる文字列は，510文字以内です。510文字を超える長さの文字列を指定した場合は，エラーになります。

複数様式帳票指定時のプロパティの扱い
  • PageNumberFormatプロパティを設定したあと，Openメソッドの実行によって複数様式帳票が開かれたときは，指定された値は無効になります。
  • Openメソッドの実行によって複数様式帳票が開かれているときにPageNumberFormatプロパティを指定しても，値は無効になります。
  • PageNumberFormatプロパティを指定して値を取得するときは，NULL文字列を返します。

データ型

String

記述例

オブジェクト型変数rptで参照している帳票を印刷するときのページ番号の印刷形式を指定します。

rpt.PageSetup.PageNumberFormat = "-*/$-"

エラーメッセージ

コード | メッセージ
1133 | ページ番号の設定でエラーが発生しました。
1134 | 処理中にエラーが発生しました。
1135 | Windowsでエラーが発生しました。
4546 | ページ番号印刷形式は510文字以内で指定してください。


PageNumberLocationプロパティ

PageNumberLocationプロパティ

余白のページ番号の印刷位置を指定，または取得します。

指定値 | 説 明
1 | ページ番号を左上に印刷します。
2 | ページ番号を中央上に印刷します。
3 | ページ番号を右上に印刷します。
4 | ページ番号を左下に印刷します。
5 | ページ番号を中央下に印刷します。
6 | ページ番号を右下に印刷します。

省略した場合は，［レポートのプロパティ］ダイアログの［レポートの構成］タブで指定されている値が仮定されます。

対象

PageSetup

解説

複数様式帳票指定時のプロパティの扱い
  • PageNumberLocationプロパティを設定したあと，Openメソッドの実行によって複数様式帳票が開かれたときは，指定された値は無効になります。
  • Openメソッドの実行によって複数様式帳票が開かれているときにPageNumberLocationプロパティを指定しても，値は無効になります。
  • PageNumberLocationプロパティを指定して値を取得するときは，5（中央下）を返します。

データ型

Integer

記述例

オブジェクト型変数rptで参照している帳票を印刷するときのページ番号の印刷位置を中央上に指定します。

rpt.PageSetup.PageNumberLocation = 2

エラーメッセージ

コード | メッセージ
1134 | 処理中にエラーが発生しました。
1135 | Windowsでエラーが発生しました。
4551 | ページ番号印刷位置の指定に誤りがあります。


PageSetupプロパティ

PageSetupプロパティ

PageSetupオブジェクトの参照を取得します。

対象

Document

解説

PageSetupオブジェクトのプロパティやメソッドを使用する場合に，PageSetupプロパティで値を取得します。

データ型

Object

記述例

PageSetupプロパティでPageSetupオブジェクトの参照を取得し，オブジェクト型変数pageに代入します。

Set page = rpt.PageSetup


PaperOrientationプロパティ

PaperOrientationプロパティ

印刷するときの用紙の向きを指定，または取得します。

指定値 | 説 明
0 | 用紙の向きは帳票に従います。
1 | 用紙の向きは縦方向に印刷します。
2 | 用紙の向きは横方向に印刷します。

省略した場合は，0が仮定されます。上記以外の値を指定した場合は，エラーになります。

対象

PageSetup

解説

指定された値が帳票の属性と異なる場合，帳票の一部が表示されないことがあります。次に出力結果の例を示します。

図3-1　A4縦向きで作成されたフォームシートをA4用紙に印刷した場合の出力結果

図3-2　A4横向きで作成されたフォームシートをA4用紙に印刷した場合の出力結果

複数様式帳票指定時のプロパティの扱い
  • PaperOrientationプロパティを設定したあと，Openメソッドの実行によって複数様式帳票が開かれたときは，指定された値は無効になり，0が仮定されます。

データ型

Integer

記述例

オブジェクト型変数rptで参照している帳票を印刷するときに，用紙の向きを縦に印刷します。

rpt.PageSetup.PaperOrientation = 1

エラーメッセージ

コード | メッセージ
4565 | 用紙の向きの指定に誤りがあります。


Parentプロパティ

Parentプロパティ

親オブジェクトの参照を取得します。

対象

Application，Document，PageSetup，MappingData，UserDefineData

解説

  • 対象が，ApplicationオブジェクトおよびDocumentオブジェクトの場合
    Applicationオブジェクトの参照を取得します。
  • 対象が，PageSetupオブジェクト，MappingDataオブジェクトおよびUserDefineDataオブジェクトの場合
    Documentオブジェクトの参照を取得します。

データ型

Object

記述例

親オブジェクトの参照を取得してオブジェクト型変数parentに代入します。

  • 対象がApplicationオブジェクトの場合
    Set parent = rpt.Application.Parent
  • 対象がDocumentオブジェクトの場合
    Set parent = rpt.Parent
  • 対象がPageSetupオブジェクトの場合
    Set parent = rpt.PageSetup.Parent
  • 対象がMappingDataオブジェクトの場合
    Set parent = rpt.MappingData.Parent
  • 対象がUserDefineDataオブジェクトの場合
    Set parent = rpt.UserDefineData.Parent


Pathプロパティ

Pathプロパティ

帳票ファイル（レポートファイル，またはフォームシートファイル）のファイル名を含まないパス名を取得します。

対象

Document

解説

例えば，現在開いているファイルが「c:\eur\report1.agr」の場合，Pathプロパティで，パス名「c:\eur\」を取得します。また，「c:\report2.agr」の場合，パス名「c:\」を取得します。

複数様式帳票指定時のプロパティの扱い
  • Openメソッドの実行によって複数様式帳票が開かれている場合にPathプロパティを指定したときは，NULL文字列を返します。

データ型

String

記述例

オブジェクト型変数rptで参照している帳票のパス名を取得し，文字列型変数pathnameに代入します。

pathname = rpt.Path


PrinterNameプロパティ

PrinterNameプロパティ

帳票を出力するプリンタ名を指定，または取得します。

対象

Application

解説

PrinterNameプロパティを指定しないで，DocumentオブジェクトのPrint/PrintOutメソッドを実行すると，Windowsで通常使うプリンタとして指定してあるプリンタに印刷されます。

データ型

String

記述例

帳票を出力するプリンタ名を指定します。

rpt.Application.PrinterName = "Printer name"


PrintFileNameプロパティ

PrintFileNameプロパティ

帳票を出力するファイル名を，ドライブ名とフォルダ名を含むフルパスで指定，または取得します。フルパスで指定しない場合は，EURのインストール先フォルダからの相対パスが仮定されます。

対象

Application

解説

帳票をプリンタに出力する代わりに，指定されたファイルへ出力します。印刷出力ファイル名は，ドライブ名とフォルダ名を含むフルパスで指定します。フルパスで指定しない場合は，EURのインストール先フォルダからの相対パスが仮定されます。

PrintFileOutプロパティがTrueのときに，PrintFileNameプロパティを指定した場合は，PrinterNameプロパティで指定したプリンタがどの出力ポートを選択していても，指定したファイルに出力されます。

データ型

String

記述例

帳票を出力するファイルを指定します。

rpt.Application.PrintFileName = "c:\eur\print\file1"

rpt.Application.PrintFileOut = True

エラーメッセージ

コード | メッセージ
4600 | 指定した出力ファイルに書き込めませんでした。


PrintFileOutプロパティ

PrintFileOutプロパティ

DocumentオブジェクトのPrint，またはPrintOutメソッドを実行したとき，PrintFileNameプロパティで指定したファイルに帳票を出力するかどうかを指定，または取得します。

指定値 | 説 明
True | ファイルに出力します。
False | ファイルに出力しません。プリンタの出力先ポートの指定に従います。

省略した場合は，Falseが仮定されます。

対象

Application

解説

PrintFileOutプロパティでTrueを指定する場合は，PrintFileNameプロパティの指定が必要です。PrintFileNameプロパティで印刷出力ファイル名が指定されていないときは，エラーコード 1020を返します。

データ型

Boolean

記述例

帳票をファイルに出力します。

rpt.Application.PrintFileName = "c:\eur\print\file1"

rpt.Application.PrintFileOut = True

エラーメッセージ

コード | メッセージ
1020 | 印刷中にエラーが発生しました。


PrintPageNumberプロパティ

PrintPageNumberプロパティ

余白へページ番号を印刷するかしないかを指定，または取得します。

指定値 | 説 明
True | ページ番号を印刷します。
False | ページ番号を印刷しません。

省略した場合は，［レポートのプロパティ］ダイアログの［レポートの構成］タブで指定されている値が仮定されます。初期値はFalseです。

対象

PageSetup

解説

複数様式帳票指定時のプロパティの扱い
  • PrintPageNumberプロパティを設定したあと，Openメソッドの実行によって複数様式帳票が開かれたときは，指定された値は無効になります。
  • Openメソッドの実行によって複数様式帳票が開かれているときにPrintPageNumberプロパティを指定しても，値は無効になります。
  • PrintPageNumberプロパティを指定して値を取得するときは，Falseを返します。

データ型

Boolean

記述例

オブジェクト型変数rptで参照している帳票を印刷するときに，ページ番号を印刷します。

rpt.PageSetup.PrintPageNumber = True


PrintStatusプロパティ

PrintStatusプロパティ

印刷時に，［印刷中］ダイアログを表示するかどうかを指定，または取得します。

指定値 | 説 明
True | ［印刷中］ダイアログが表示されます。
False | ［印刷中］ダイアログは表示されません。

省略した場合は，Falseが仮定されます。

対象

Application

データ型

Boolean

記述例

帳票を印刷するときに，［印刷中］ダイアログが表示されます。

rpt.Application.PrintStatus = True


ReportBasePathプロパティ

ReportBasePathプロパティ

帳票ファイル（レポートファイル，またはフォームシートファイル）のある場所を指定，または取得します。指定されたファイルのパスは，Openメソッドで指定する帳票ファイルのデフォルトになります。

対象

Application

解説

Openメソッドで帳票ファイル名をフルパスで指定するか，または別のフォルダにある帳票ファイルを開いた場合，それ以降，変更後のファイルのパスがデフォルトになります。また，ReportBasePathプロパティは，現在指定されている帳票ファイルのパスを取得することもできます。例えば，「c:\eur\file\repofile\」や「c:\」のように，文字列の最後に「\」の付いた形式で，ファイルのパスを取得できます。

データ型

String

記述例

帳票のデフォルトパスを指定して帳票を開きます。

rpt.Application.ReportBasePath = "c:\eur\file\repofile"

rpt.Application.Open("repo1.agr")

エラーメッセージ

コード | メッセージ
4566 | レポートファイルの場所にパス名が指定されていません。
4567 | レポートファイルの場所に指定されたパス（パス名）が見つかりません。


ReplaceItemCntlFileプロパティ

ReplaceItemCntlFileプロパティ

置き換え表管理情報ファイル名を指定します。

対象

Application

解説

置き換え表管理情報ファイル名を指定します。置き換え表管理情報ファイル名は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。ファイル名をフルパスで指定しなかった場合は，次に示す順にファイルを検索します。

  1. ReplaceItemCntlFilePathプロパティに指定されているフォルダ
  2. ［オプション］ダイアログの［ファイル］タブで，「置き換え表管理情報ファイル」に指定されているフォルダ

データ型

String

記述例

オブジェクト型変数rptで参照している帳票に置き換え表管理情報ファイルを指定，または取得します。

  • 置き換え表管理情報ファイルをファイル名で指定する場合
    rpt.Application.ReplaceItemCntlFile = "Index.csv"
  • 置き換え表管理情報ファイルをフルパスで指定する場合
    rpt.Application.ReplaceItemCntlFile = "c:\data\Index.csv"
  • 置き換え表管理情報ファイルを参照し，文字列型変数filenameに代入する場合
    filename = rpt.Application.ReplaceItemCntlFile

エラーメッセージ

コード | メッセージ
4638 | 不正なファイル名（ファイル名）が指定されました。
4683 | 指定した置き換え表管理情報ファイル（ファイル名）の内容が不正です。
4685 | 置き換え表管理情報ファイル（ファイル名）には読み込み権限がありません。
4687 | 置き換え表管理情報ファイル（ファイル名）が見つかりません。
4689 | 置き換え表管理情報ファイル（ファイル名）がオープンできませんでした。


ReplaceItemCntlFilePathプロパティ

ReplaceItemCntlFilePathプロパティ

置き換え表管理情報ファイルのある場所を指定，または取得します。

対象

Application

解説

指定されたフォルダは，ReplaceItemCntlFileプロパティで指定するファイルのデフォルトになります。また，ReplaceItemCntlFilePathプロパティは，現在指定されている置き換え表管理情報ファイルのパスを取得することもできます。例えば，「c:\eur\file\data\」や「c:\」のように，文字列の最後に「\」の付いた形式で，ファイルのパスを取得できます。

データ型

String

記述例

置き換え表管理情報ファイルのデフォルトパスを指定します。

rpt.Application.ReplaceItemCntlFilePath = "c:\data\Index"

エラーメッセージ

コード | メッセージ
4683 | 指定した置き換え表管理情報ファイル（ファイル名）の内容が不正です。
4684 | 指定した置き換え表ファイル（ファイル名）の内容が不正です。
4685 | 置き換え表管理情報ファイル（ファイル名）には読み込み権限がありません。
4687 | 置き換え表管理情報ファイル（ファイル名）が見つかりません。
4689 | 置き換え表管理情報ファイル（ファイル名）をオープンできませんでした。


ReplaceItemFilePathプロパティ

ReplaceItemFilePathプロパティ

置き換え表ファイルのある場所を指定，または取得します。

対象

Application

解説

指定されたフォルダは，ReplaceItemCntlFileプロパティで指定する置き換え表管理情報ファイルに定義されている置き換え表ファイルのデフォルトになります。また，ReplaceItemFilePathプロパティは，現在指定されている置き換え表ファイルのパスを取得することもできます。例えば，「c:\eur\file\data\」や「c:\」のように，文字列の最後に「\」の付いた形式で，ファイルのパスを取得できます。

データ型

String

記述例

置き換え表ファイルのデフォルトパスを指定します。

rpt.Application.ReplaceItemFilePath = "c:\data\Index"

エラーメッセージ

コード | メッセージ
4684 | 指定した置き換え表ファイル（ファイル名）の内容が不正です。
4686 | 置き換え表ファイル（ファイル名）には読み込み権限がありません。
4688 | 置き換え表ファイル（ファイル名）が見つかりません。
4690 | 置き換え表ファイル（ファイル名）をオープンできませんでした。


ReportTitleプロパティ

ReportTitleプロパティ

プリンタの印刷待ち状態を確認する一覧ウィンドウの「ドキュメント名」，およびタイトルバーに表示する帳票名を「"」で囲んで指定します。

対象

Application

解説

ReportTitleプロパティの指定がなければ，「HITACHI Report - 帳票ファイル名」が表示されます。

帳票名は，255文字までの文字列で指定します。指定された帳票名が255文字を超えた場合は，255文字までを帳票名とします。

データ型

String

記述例

オブジェクト型変数rptで参照している帳票の帳票名を指定します。

rpt.Application.ReportTitle = "請求書No.012-3456"


Sortingプロパティ

Sortingプロパティ

2部以上印刷する場合の印刷単位を指定，または取得します。

指定値 | 説 明
True | 部単位で印刷します。
False | ページ単位で印刷します。

省略した場合は，Trueが仮定されます。

対象

PageSetup

解説

複数様式帳票指定時のプロパティの扱い
  • Sortingプロパティを設定したあと，Openメソッドの実行によって複数様式帳票が開かれたときは，指定された値は無効になります。
  • Openメソッドの実行によって複数様式帳票が開かれているときにSortingプロパティを指定しても，値は無効になります。
  • Sortingプロパティを指定して値を取得するときは，Trueを返します。

データ型

Boolean

記述例

オブジェクト型変数rptで参照している帳票をページ単位で印刷します。

rpt.PageSetup.Sorting = False


SubWindowStatusプロパティ

SubWindowStatusプロパティ

サブウィンドウの表示状態を指定，または取得します。

指定値 | 説 明
1 | フォーカスを持った，通常のウィンドウが表示されます。
2 | フォーカスを持ち，アイコン化されているウィンドウが表示されます。
3 | フォーカスを持ち，最大表示されているウィンドウが表示されます。

省略した場合は，1が仮定されます。上記以外の値を指定した場合は，エラーになります。

対象

Application

データ型

Integer

記述例

オブジェクト型変数rptで参照しているウィンドウのサブウィンドウを最大表示にします。

rpt.Application.SubWindowStatus = 3

エラーメッセージ

コード | メッセージ
4602 | SubWindowStatusプロパティの指定値が不正です。


Topプロパティ

Topプロパティ

ディスプレイの上端からメインウィンドウまでの距離を指定，または取得します。

対象

Application

データ型

Integer

記述例

オブジェクト型変数rptで参照しているメインウィンドウをディスプレイの上端に表示します。

rpt.Application.Top = 0


TrayCodeプロパティ

TrayCodeプロパティ

TraySelectionプロパティを指定して，給紙トレイ選択機能を使用する場合，プリンタの給紙トレイコードを指定，または取得します。省略した場合は，給紙トレイコード「1」が仮定されます。指定した値が，プリンタによって使用できない場合は，TraySelectionプロパティの指定に従って処理されます。

Windowsで規定されている，給紙トレイコードを次に示します。給紙トレイコードの256以上は，各デバイス固有コードを割り当てられます。

表3-5　給紙トレイコード一覧（Windows規定に準ずる）

給紙トレイ（対象給紙装置） | 給紙トレイコード
上段用紙トレイ | 1
単一給紙ソース | 1
下段用紙トレイ | 2
中段用紙トレイ | 3
手差し用紙フィーダ | 4
封筒フィーダ | 5
手差し封筒フィーダ | 6
用紙サイズを基に自動的に給紙装置を選択 | 7
トラクタフィーダ | 8
小型用紙ソース | 9
大型用紙ソース | 10
大容量用紙トレイ | 11
用紙カセット | 14

給紙トレイコードを指定するとき，プリンタの製造会社や機種によって，Windowsで規定されている給紙トレイコードと異なる場合があります。また，Windowsで規定されている給紙トレイコードであっても，プリンタドライバによって，給紙トレイ名と給紙トレイコードを独自に割り当てていると，期待したトレイから給紙されない場合があります。このような場合，出力先プリンタに対応した給紙トレイコードを，EURで提供している［給紙トレイ一覧］ツールで確認されることをお勧めします。

［給紙トレイ一覧］ツールは，出力先プリンタをリストボックスから選択すると，そのプリンタの給紙トレイ名と，対応する給紙トレイコードの一覧が表示されます。

表示された給紙トレイコードを指定することで，期待したトレイから給紙できます。

［給紙トレイ一覧］ツール（Eurtyl.exe）は，次に示すフォルダに格納されています。

  • EUR Designerの場合
    EUR Designerのインストール先フォルダ\Designer --+-- Program -- Eurtyl.exe
  • EUR Viewerの場合
    EUR Viewerのインストール先フォルダ --+-- Program -- Eurtyl.exe

対象

Application

解説

TrayCodeプロパティは，PrinterNameプロパティとTraySelectionプロパティが指定されているとき，有効になります。

データ型

Integer

記述例

オブジェクト型変数rptで参照している帳票を，給紙トレイ選択機能を使用して，プリンタの下段用紙トレイを指定します。

rpt.Application.PrinterName = "Printer name"

rpt.Application.TraySelection = 1

rpt.Application.TrayCode = 2


TraySelectionプロパティ

TraySelectionプロパティ

給紙トレイ選択機能を使用するかどうかを指定，または取得します。省略した場合は，「0（給紙トレイ選択機能を使わない）」が仮定されます。

指定値 | 説 明
0 | 給紙トレイ選択機能を使いません。出力先プリンタのデフォルトのトレイに印刷されます。
1 | 給紙トレイ選択機能を使います。ただし，「TrayCode」で指定されたコードが，出力先プリンタにない場合は，エラーになります。
2 | 給紙トレイ選択機能を使います。ただし，「TrayCode」で指定されたコードが，出力先プリンタにない場合は，プリンタの既存値で印刷されます。

対象

Application

解説

TraySelectionプロパティは，PrinterNameプロパティが指定されているとき，有効になります。

データ型

Integer

記述例

オブジェクト型変数rptで参照している帳票を，給紙トレイ選択機能を使用して出力します。

rpt.Application.PrinterName = "Printer name"

rpt.Application.TraySelection = 1

エラーメッセージ

コード | メッセージ
4613 | 給紙トレイ選択オプションの指定に誤りがあります。


UserDataBasePathプロパティ

UserDataBasePathプロパティ

ユーザ定義データ用のファイルのある場所を指定，または取得します。指定されたファイルのパスは，UserDefineDataオブジェクトのDataFileNameプロパティで指定するデータファイル，もしくは可変記号値定義ファイル，またはDocumentオブジェクトのVarDataFileプロパティで指定するユーザ定義データ用のファイルのデフォルトになります。

対象

Application

解説

DataFileNameプロパティでファイル名をフルパスで指定するか，または別のフォルダにあるファイルを開いた場合は，それ以降，変更後のファイルのパスがデフォルトになります。また，UserDataBasePathプロパティは，現在指定されているファイルのパスを取得することもできます。例えば，「c:\eur\file\userdata\」や「c:\」のように，文字列の最後に「\」の付いた形式で，ファイルのパスを取得できます。

データ型

String

記述例

データファイルのデフォルトパスを指定してデータファイルを開きます。可変記号値定義ファイルも記述のしかたは同じです。

rpt.Application.UserDataBasePath = "c:\eur\file\userdata"

rpt.UserDefineData.DataFileName = "data.dat"

エラーメッセージ

コード | メッセージ
4574 | ユーザ定義データファイルの場所にパス名が指定されていません。
4575 | ユーザ定義データファイルの場所に指定されたパス（パス名）が見つかりません。
4670 | ユーザ定義データ用の可変記号値定義ファイルの場所にパス名が指定されていません。
4671 | ユーザ定義データ用の可変記号値定義ファイルの場所に指定されたパス（パス名）が見つかりません。


UserDefineDataプロパティ

UserDefineDataプロパティ

UserDefineDataオブジェクトの参照を取得します。

対象

Document

解説

UserDefineDataオブジェクトのプロパティやメソッドを使用する場合に，UserDefineDataプロパティで値を取得します。

複数様式帳票指定時のプロパティの扱い
  • Openメソッドの実行によって複数様式帳票が開かれている場合にUserDefineDataプロパティを指定したときは，NULLを返します。

データ型

Object

記述例

UserDefineDataプロパティでUserDefineDataオブジェクトの参照を取得し，オブジェクト型変数userdataに代入します。

Set userdata = rpt.UserDefineData


VarDataFileプロパティ

VarDataFileプロパティ

ユーザ定義データ用のデータファイル名を指定，または取得します。

対象

Document

解説

既存の帳票のユーザ定義データを変更して帳票に表示する場合に，VarDataFileプロパティでユーザ定義データ用のデータファイル名を指定します。VarDataFileプロパティを設定したあと，Openメソッドまたは［ファイルを開く］ダイアログで帳票ファイルを開くと，データファイルの指定は無効になります。データファイル名をフルパスで指定しなかった場合，ファイル名には，［オプション］ダイアログの［ファイル］タブで指定されているユーザ定義データファイルのパス名が付きます。ただし，次に示す操作をしたときは，変更後のパス名が付きます。

  • 前回，VarDataFileプロパティで指定したファイルのパス名
  • ［データファイルの指定］ダイアログで，データファイルを指定したときのパス名

上記以外のフォルダにあるデータファイルを指定したい場合は，フルパスで指定してください。

ユーザ定義データファイルの参照は，ファイル名をフルパスで取得します。指定したユーザ定義データファイルがない場合や，ユーザ定義データファイルの記述に誤りがある場合は，エラーになります。

なお，データファイル名を指定する場合は，VarDataFileプロパティよりも，UserDefineDataオブジェクトのDataFileNameプロパティを使用されることをお勧めします。

複数様式帳票指定時のプロパティの扱い
  • VarDataFileプロパティを設定したあと，Openメソッドの実行によって複数様式帳票が開かれたときは，指定された値は無効になります。
  • Openメソッドの実行によって複数様式帳票が開かれているときにVarDataFileプロパティを指定しても，値は無効になります。
  • VarDataFileプロパティを指定して値を取得するときは，NULL文字列を返します。

データ型

String

記述例

オブジェクト型変数rptで参照している帳票にユーザ定義データファイルを指定，または取得します。

  • ユーザ定義データファイルをファイル名で指定する場合
    rpt.VarDataFile = "vartbl.dat"
  • ユーザ定義データファイルをフルパスで指定する場合
    rpt.VarDataFile = "c:\eur\vartbl.dat"
  • ユーザ定義データファイルを取得し，文字列型変数varfilenameに値を代入する場合
    varfilename = rpt.VarDataFile

エラーメッセージ

コード | メッセージ
1005 | メモリ不足が発生しました。
1134 | 処理中にエラーが発生しました。
1135 | Windowsでエラーが発生しました。
4506 | データファイル（データファイル名）が見つかりません。
4508 | データファイル名（データファイル名）が正しくありません。
4529 | データファイル（データファイル名）：n行目 記述に誤りがあります。
4531 | データファイル（データファイル名）がオープンできません。
4553 | データファイル（データファイル名）には読み込み権限がありません。


Visibleプロパティ

Visibleプロパティ

メインウィンドウを表示するかどうかを指定，または取得します。

指定値 | 説 明
True | メインウィンドウが表示されます。
False | メインウィンドウは表示されません。

省略した場合は，Falseが仮定されます。

対象

Application

データ型

Boolean

記述例

オブジェクト型変数rptで参照しているメインウィンドウが表示されます。

rpt.Application.Visible = True

エラーメッセージ

コード | メッセージ
1130 | 画面描画処理中にエラーが発生しました。
1134 | 処理中にエラーが発生しました。
1135 | Windowsでエラーが発生しました。


Widthプロパティ

Widthプロパティ

メインウィンドウの右端から左端までの距離を指定，または取得します。

対象

Application

データ型

Integer

記述例

オブジェクト型変数rptで参照しているメインウィンドウの幅を1,000ピクセルで表示します。

rpt.Application.Width = 1000


WindowStyleプロパティ

WindowStyleプロパティ

表示するメインウィンドウのスタイルを指定，または取得します。

指定値 | 説 明
1 | レポート編集ウィンドウが表示されます。
2 | レポート確認ウィンドウが表示されます。
3 | レポート印刷ウィンドウが表示されます。

省略した場合は，1が仮定されます。上記以外の値を指定した場合は，エラーになります。

対象

Application

解説

WindowStyleプロパティは，Editableプロパティの機能と似た機能を提供していますが，表示するウィンドウを指定する場合は，WindowStyleプロパティを使用されることをお勧めします。

なお，WindowStyleプロパティで1を指定した場合は，Editableプロパティの値がTrueに変更されます。WindowStyleプロパティで2または3を指定した場合は，Editableプロパティの値がFalseに変更されます。

複数様式帳票指定時のプロパティの扱い
  • Openメソッドの実行によって複数様式帳票が開かれているときにWindowStyleプロパティを指定しても，値は無効になります。

データ型

Integer

記述例

オブジェクト型変数rptで参照している帳票を，レポート編集ウィンドウに表示して編集します。

rpt.Application.WindowStyle = 1

エラーメッセージ

コード | メッセージ
4564 | 表示するエディタ画面の種類の指定に誤りがあります。


Zoomプロパティ

Zoomプロパティ

帳票ウィンドウに帳票を表示する場合の表示倍率を指定，または取得します。指定できる値は，標準サイズを100とした百分率で10～800です。

対象

Document

解説

0を指定した場合は，FitToWindowプロパティの指定が有効になります。省略した場合は，標準サイズで表示されます。

データ型

Integer

記述例

オブジェクト型変数rptで参照している帳票をレポート編集ウィンドウに表示倍率80%で表示します。

rpt.Zoom = 80

エラーメッセージ

コード | メッセージ
1134 | 処理中にエラーが発生しました。
1135 | Windowsでエラーが発生しました。
4513 | ズーム倍率は10～800の値で指定してください。


OLEオートメーションで使用できるメソッド仕様

3.5　OLEオートメーションで使用できるメソッド仕様

EURが提供するOLEオートメーションで使用できるメソッドの詳細を説明します。

＜この節の構成＞
Activateメソッド
CreateDateメソッド
Importメソッド
Openメソッド
Printメソッド
PrintOutメソッド
Quitメソッド


Activateメソッド

Activateメソッド

指定したドキュメントのメインウィンドウをアクティブにします。

対象

Document

形式

Activate

データ型

Empty

記述例

オブジェクト型変数rptで参照している帳票のメインウィンドウをアクティブにします。

rpt.Activate


CreateDateメソッド

CreateDateメソッド

Openメソッドで指定した帳票ファイルの作成日付（"YYYY/MM/DD hh:mm:ss"）を取得します。Openメソッドで複数様式帳票が指定されていた場合は，NULL文字列を返します。

対象

Document

形式

CreateDate

データ型

String

記述例

オブジェクト型変数rptで参照している帳票の作成日付を取得します。

rpt.CreateDate


Importメソッド

Importメソッド

MappingDataプロパティ，またはUserDefineDataプロパティに設定されている条件でデータウィンドウにデータを入力します。

対象

MappingData，UserDefineData

形式

Import(datatype)

引数

datatype〔Integer〕
実際に読み込むデータの種別を指定します。

解説

既存の帳票のフォーマットを利用して別のデータを表示する場合にImportメソッドを実行します。このメソッドは，MappingDataオブジェクト，またはUserDefineDataオブジェクトの各プロパティに設定されている条件でデータを入力して，帳票に反映します。データファイルからデータを入力する場合は引数に0を，データベースからデータを入力する場合は引数に1を指定します。

複数様式帳票指定時のプロパティの扱い
  • Openメソッドの実行によって複数様式帳票が開かれているときにImportメソッドを指定しても，値は無効になります。

データ型

String

記述例

オブジェクト型変数rptで参照した帳票にデータを入力します。

  • 対象が，MappingDataオブジェクトの場合
    • データファイルからデータを入力する場合
      rpt.MappingData.DataFileName = "tbl.dat"
      rpt.MappingData.Import(0)
    • データベースのデータを入力する場合
      rpt.Application.DBInfoFileName = "dbinfo.txt"
      rpt.MappingData.DataFileName = "dbvar.txt"
      rpt.MappingData.Import(1)
  • 対象が，UserDefineDataオブジェクトの場合
    • データファイルからデータを入力する場合
      rpt.UserDefineData.DataFileName = "tbl.dat"
      rpt.UserDefineData.Import(0)
    • データベースのデータを入力する場合
      rpt.Application.DBInfoFileName = "dbinfo.txt"
      rpt.UserDefineData.DataFileName = "userdbvar.txt"
      rpt.UserDefineData.Import(1)

エラーメッセージ

コード | メッセージ
1005 | メモリ不足が発生しました。
1134 | 処理中にエラーが発生しました。
1135 | Windowsでエラーが発生しました。
4506 | データファイル（データファイル名）が見つかりません。
4508 | データファイル名（データファイル名）が正しくありません。
4518 | データファイル名が指定されていません。
4529 | データファイル（データファイル名）：n行目 記述に誤りがあります。
4531 | データファイル（データファイル名）がオープンできません。
4553 | データファイル（データファイル名）には読み込み権限がありません。
4588 | データベースアクセス定義実行でエラーが発生しました。
4590 | 特殊編集レベルとして認識できないデータがありました。


Openメソッド

Openメソッド

レポートファイル名（*.agr），またはフォームシートファイル名（*.fms）を指定し，帳票ファイルを開きます。

対象

Application

形式

Open(report)

引数

report〔String〕
帳票ファイル名を指定します。

解説

帳票ファイル名をフルパスで指定しなかった場合，ファイル名には，［オプション］ダイアログの［ファイル］タブで指定されている帳票ファイルのパス名が付きます。

ただし，次に示す操作をしたときは，変更後のパス名が付きます。

  • Openメソッドで帳票ファイル名をフルパス指定した場合
  • ［ファイルを開く］ダイアログで帳票ファイルを開いた場合
  • ［名前を付けて保存］ダイアログで帳票ファイルを保存した場合

上記以外のフォルダにある帳票ファイルを開きたい場合は，フルパスで指定してください。

帳票ファイル名を指定するとき，エクスプローラなどで，ファイルを一つ選択したあと，ポップアップメニューから［プロパティ］を選択すると，ファイルのプロパティを表示できます。［EURのプロパティ］タブで，帳票ファイルを設計したEUR製品のプログラムプロダクト情報を確認することで，帳票ファイルを参照，または印刷できるEUR製品のプログラムプロダクト情報を特定できます。

複数様式帳票指定時のプロパティの扱い
  • Openメソッドで帳票ファイル名を指定しても，指定されたファイル名は無効になります。
  • Openメソッドの実行によって，MultiReportSetFileプロパティで指定した帳票セット指定ファイルとMultiFormInfoDefFileプロパティで指定した複数様式情報定義ファイルから，複数様式帳票を開きます。

データ型

Empty

記述例

オブジェクト型変数rptで参照している帳票のレポートファイルを開きます。

  • ファイル名だけを指定してレポートファイルを開く場合
    rpt.Application.Open("report1.agr")
  • ファイル名をフルパスで指定してレポートファイルを開く場合
    rpt.Application.Open("c:\eur\report1.agr")

エラーメッセージ

コード | メッセージ
1005 | メモリ不足が発生しました。
1134 | 処理中にエラーが発生しました。
1135 | Windowsでエラーが発生しました。
4503 | レポート（レポート名）が見つかりません。
4504 | レポート（レポート名）には読み込み権限がありません。
4507 | レポート名（レポート名）が正しくありません。
4517 | レポート名が指定されていません。
4534 | レポートが不完全です。
4552 | レポート（レポート名）をオープンできませんでした。


Printメソッド

Printメソッド

印刷開始終了ページと印刷部数を指示します。

対象

Document

形式

Print(from,to,copies)

引数

from〔Integer〕
印刷開始ページを指定します。指定できる値は0～32,767です。0を指定した場合は，印刷開始ページは1ページになります。0～32,767の範囲外の値，または印刷終了ページの値よりも大きい値を指定した場合は，エラーになります。
to〔Integer〕
印刷終了ページを指定します。指定できる値は0～32,767です。0を指定した場合は，印刷終了ページは全ページになります。0～32,767の範囲外の値を指定した場合は，エラーになります。
copies〔Integer〕
印刷部数を指定します。指定できる値は1～99です。1～99の範囲を超えた値を指定した場合は，エラーになります。

解説

プリンタが接続されていない場合や，スプールに必要なディスクスペースがない場合は，エラーになります。

画像アイテムを持つ帳票を印刷する場合，プリンタによって印刷されないことがあります。また，OLEオートメーション機能を使用しているプログラミングツールから帳票を印刷するとき，「Print」が予約語になっているためにEURのメソッドとして認識されない場合があります（Visual Basic Version 3.0など）。このような場合は，PrintOutメソッドを使用してください。

複数様式帳票指定時のプロパティの扱い
  • Openメソッドの実行によって複数様式帳票が開かれているときにPrintメソッドを指定しても値は無効になり，すべてのページを1部印刷します。

データ型

Empty

記述例

オブジェクト型変数rptで参照している帳票を印刷します。

  • 全ページを１部ずつ印刷する場合
    rpt.Print(0,0,1)
  • 3ページから5ページを2部ずつ印刷する場合
    rpt.Print(3,5,2)

エラーメッセージ

コード | メッセージ
1020 | 印刷中にエラーが発生しました。
1131 | 現在，スプールに必要なディスクスペースがありません。
1132 | スプールに必要なメモリが存在しません。
1134 | 処理中にエラーが発生しました。
1135 | Windowsでエラーが発生しました。
4514 | 指定されたページ数に誤りがあります。
4515 | 印刷部数は1～99の値で指定してください。
4521 | プリンタが存在しません。
4522 | 通常使うプリンタが設定されていません。
4523 | プリンタのハードマージンを取得できませんでした。
4524 | 印刷ジョブがキャンセルされたので印刷処理を中止します。
4545 | 印刷可能なページ数の上限値を超えています。
4593 | 印刷処理がキャンセルされました。
4614 | 指定したトレイコードはサポートされていません。


PrintOutメソッド

PrintOutメソッド

印刷開始終了ページと印刷部数を指示します。

対象

Document

形式

PrintOut(from,to,copies)

引数

from〔Integer〕
印刷開始ページを指定します。指定できる値は0～32,767です。0を指定した場合は，印刷開始ページは1ページになります。0～32,767の範囲外の値を指定した場合は，エラーになります。
to〔Integer〕
印刷終了ページを指定します。指定できる値は0～32,767です。0を指定した場合は，印刷終了ページは全ページになります。0～32,767の範囲外の値を指定した場合は，エラーになります。
copies〔Integer〕
印刷部数を指定します。指定できる値は1～99です。1～99の範囲外の値を指定した場合は，エラーになります。

解説

OLEオートメーション機能を使用しているプログラミングツールから帳票を印刷する場合，「Print」が予約語になっているときに使用します。プリンタが接続されていない場合や，スプールに必要なディスクスペースがない場合は，エラーになります。

複数様式帳票指定時のプロパティの扱い
  • Openメソッドの実行によって複数様式帳票が開かれているときにPrintOutメソッドを指定しても値は無効になり，すべてのページを1部印刷します。

データ型

Empty

記述例

オブジェクト型変数rptで参照している帳票を印刷します。

  • 全ページを１部ずつ印刷する場合
    rpt.PrintOut(0,0,1)
  • 3ページから5ページを2部ずつ印刷する場合
    rpt.PrintOut(3,5,2)

エラーメッセージ

コード | メッセージ
1020 | 印刷中にエラーが発生しました。
1131 | 現在，スプールに必要なディスクスペースがありません。
1132 | スプールに必要なメモリがありません。
1134 | 処理中にエラーが発生しました。
1135 | Windowsでエラーが発生しました。
4514 | 指定されたページ数に誤りがあります。
4515 | 印刷部数は1～99の値で指定してください。
4521 | プリンタがありません。
4522 | 通常使うプリンタが設定されていません。
4523 | プリンタのハードマージンを取得できませんでした。
4524 | 印刷ジョブがキャンセルされたので印刷処理を中止します。
4545 | 印刷可能なページ数の上限値を超えています。
4593 | 印刷処理がキャンセルされました。


Quitメソッド

Quitメソッド

EURを終了します。

対象

Application

形式

Quit

データ型

Empty

記述例

オブジェクト型変数rptで参照している帳票を終了します。

rpt.Application.Quit

エラーメッセージ

コード | メッセージ
1134 | 処理中にエラーが発生しました。
1135 | Windowsでエラーが発生しました。


スタートメニューからのプレビューと出力

4.　スタートメニューからのプレビューと出力

EUR クライアント帳票出力機能は，スタートメニューから直接起動することもできます。また，帳票をダブルクリックして起動することもできます。

この章では，EURクライアント帳票出力機能をスタートメニューから起動して帳票を出力する方法，および帳票をダブルクリックして起動する方法について説明します。

＜この章の構成＞
4.1　［EURクライアント帳票出力機能］ダイアログを使用したプレビューと帳票出力
4.2　帳票ファイルのダブルクリックによるプレビューと出力


［EURクライアント帳票出力機能］ダイアログを使用したプレビューと帳票出力

4.1　［EURクライアント帳票出力機能］ダイアログを使用したプレビューと帳票出力

EUR クライアント帳票出力機能をスタートメニューから起動すると，帳票ファイルとデータファイルの場所を［EURクライアント帳票出力機能］ダイアログで設定できます。

［EURクライアント帳票出力機能］ダイアログでファイルの場所を指定する手順を，データファイルを使用する場合とデータベースを使用する場合とに分けて説明します。

なお，［EURクライアント帳票出力機能］ダイアログの設定項目の詳細については，「8.6　［EURクライアント帳票出力機能］ダイアログ」を参照してください。

＜この節の構成＞
4.1.1　データファイルを使用する場合
4.1.2　データベースを使用する場合


データファイルを使用する場合

4.1.1　データファイルを使用する場合

データファイルを使用する場合の操作手順は次のとおりです。

  1. スタートメニューの［EUR Viewer］から［EUR クライアント帳票出力機能］を選択する。
    ［EURクライアント帳票出力機能］ダイアログの上に［ファイルの選択］ダイアログが開いた状態で表示されます。

    ［ファイルの選択］ダイアログに，［オプション］ダイアログの［ファイル］タブで設定したレポートファイルのフォルダが表示されます。フォルダが存在しない場合はEUR Viewerのインストールフォルダが表示されます。
  2. ［ファイルの選択］ダイアログで帳票ファイルを指定して，［開く］ボタンをクリックする。
    ［ファイルの選択］ダイアログが閉じ，指定した帳票ファイルが［EURクライアント帳票出力機能］ダイアログの［帳票ファイル］テキストボックスに表示されます。

    ［ファイルの選択］ダイアログで［キャンセル］ボタンをクリックした場合は，［帳票ファイル］テキストボックスは空欄になります。このときは，手順3で帳票ファイルを指定してください。
  3. マッピングデータファイル，およびユーザ定義データファイルを指定する。
    ［マッピングデータ］テキストボックスにマッピングデータを，［ユーザ定義データ］テキストボックスにユーザ定義データを指定できます。
    手順2.で帳票ファイルを指定しなかった場合は［帳票ファイル］テキストボックスに指定してください。また，指定した帳票ファイルを変更することもできます。
  4. 指定した内容を確認して，［OK］ボタンをクリックする。
    指定した内容で帳票が開きます。表示内容を確認して印刷します。

    そのまま印刷するときは [図データ] をクリックするか，［ファイル］メニューの［印刷］を選択してください。


データベースを使用する場合

4.1.2　データベースを使用する場合

データベースを使用する場合の操作手順は次のとおりです。

  1. スタートメニューの［EUR Viewer］から［EUR クライアント帳票出力機能］を選択する。
    ［EURクライアント帳票出力機能］ダイアログの上に［ファイルの選択］ダイアログが開いた状態で表示されます。
  2. ［ファイルの選択］ダイアログで帳票ファイルを指定して，［開く］ボタンをクリックする。
    ［ファイルの選択］ダイアログが閉じ，指定した帳票ファイルが［EURクライアント帳票出力機能］ダイアログの［帳票ファイル］テキストボックスに表示されます。
    ［ファイルの選択］ダイアログで［キャンセル］ボタンをクリックした場合は，［帳票ファイル］テキストボックスは空欄になります。このときは，手順3で帳票ファイルを指定してください。
  3. ［データベースから入力］チェックボックスをオンにして，接続情報ファイルを指定する。
    ［接続情報ファイル］テキストボックスは，［データベースから入力］チェックボックスをオンにすると入力できるようになります。
  4. 可変記号値定義ファイルを指定する。
    ［マッピングデータ］テキストボックス，および［ユーザ定義データ］テキストボックスに可変記号値定義ファイルを指定します。
    手順2.で帳票ファイルを指定しなかった場合は［帳票ファイル］テキストボックスに指定してください。また，指定した帳票ファイルを変更することもできます。
  5. 指定した内容を確認して，［OK］ボタンをクリックする。
    指定した内容で帳票が開きます。表示内容を確認して印刷します。
    そのまま印刷するときは [図データ] をクリックするか，［ファイル］メニューの［印刷］を選択してください。


帳票ファイルのダブルクリックによるプレビューと出力

4.2　帳票ファイルのダブルクリックによるプレビューと出力

帳票ファイルをダブルクリックすると，［EURクライアント帳票出力機能］ダイアログを表示しないで帳票を開くことができます。

このとき，［オプション］ダイアログの［ファイル］タブで設定されたフォルダにあるデータが表示されます。設定されているフォルダとは異なるフォルダにファイルを格納している場合は，エラーメッセージが表示されたあとに帳票は開きますが，データは表示されません。［オプション］ダイアログの［ファイル］タブで設定されているフォルダとは異なるフォルダにデータファイルを格納している場合は，設定を変更するか，［EURクライアント帳票出力機能］ダイアログでファイルを指定してください。

［ファイル］タブの設定内容の詳細については，「8.2.2　［ファイル］タブ」を参照してください。


帳票出力で使用するファイル

5.　帳票出力で使用するファイル

この章では，EURでの入力ファイルの種類とデータファイルの形式について説明します。

＜この章の構成＞
5.1　ファイルに使用できる文字
5.2　帳票ファイル
5.3　データファイル
5.4　画像ファイル
5.5　プリンタ定義ファイル
5.6　帳票セット指定ファイル
5.7　複数様式情報定義ファイル
5.8　接続情報ファイル
5.9　可変記号値定義ファイル
5.10　置き換え表管理情報ファイル
5.11　置き換え表ファイル
5.12　オプション記述ファイル
5.13　環境設定ファイル


ファイルに使用できる文字

5.1　ファイルに使用できる文字

EURで扱うファイルに使用できる文字について説明します。

＜この節の構成＞
5.1.1　ファイル名の制約
5.1.2　入力ファイルに対するエンコーディング
5.1.3　EURで使用できる外字


ファイル名の制約

5.1.1　ファイル名の制約

EURで指定できるファイル名には，次の規則があります。

＜この項の構成＞
(1)　EURで使用するファイル名の長さ
(2)　EURで使用するファイル名に指定できる文字

(1)　EURで使用するファイル名の長さ

EURで使用するファイル名の長さは，255文字以内です。

(2)　EURで使用するファイル名に指定できる文字

次に示す文字は，ファイル名には使用できません。

\　/　:　*　?　"　<　>　|

英数字は，大文字，小文字の区別はしません。また，空白，および「.」も使用できます。ファイル名に複数個の「.」を使用している場合は，最後の「.」を区切り文字として扱います。


入力ファイルに対するエンコーディング

5.1.2　入力ファイルに対するエンコーディング

EURでは，入力ファイルにUnicodeやShift JISが使用できます。

エンコーディングがUnicodeの場合は，実装水準1に対応しています。なお，実装水準1に結合文字は含まれません。

入力ファイルの文字は，次の表に示すエンコーディングを使用して変換します。入力ファイルに対するエンコーディングを間違えると，文字化けが起きたり空白が出力されたりする場合があります。

表5-1　入力ファイルに対して使用するエンコーディング

入力ファイル | 文字コード
帳票ファイル | Shift JIS，UTF-16
マッピングデータファイル | UTF-8，UTF-16，ロケールに対応する文字コード
ユーザ定義データファイル | UTF-8，UTF-16，ロケールに対応する文字コード
プリンタ定義ファイル | UTF-8，UTF-16，ロケールに対応する文字コード
画像ファイル | 文字コードなし（バイナリ）
複数様式情報定義ファイル | UTF-8，UTF-16，ロケールに対応する文字コード
帳票セット指定ファイル | UTF-8，UTF-16，ロケールに対応する文字コード
接続情報ファイル | UTF-8，UTF-16，ロケールに対応する文字コード
可変記号値定義ファイル | UTF-8，UTF-16，ロケールに対応する文字コード
置き換え表管理情報ファイル | UTF-8，UTF-16，ロケールに対応する文字コード
置き換え表ファイル | UTF-8，UTF-16，ロケールに対応する文字コード
オプション記述ファイル | UTF-8，UTF-16，ロケールに対応する文字コード
注1
BOM（Byte Order Mark）を付与したUTF-16エンコーディングで変換します。
注2
UTF-8で表現できる文字（1バイト～4バイト）の中に不正なコードが使用されている場合，文字の先頭から不正なコードまでを半角空白に置き換えます。
注3
ロケールに対応する文字コードについては，「付録C　作業環境の言語との対応」を参照してください。


EURで使用できる外字

5.1.3　EURで使用できる外字

EURではベンダ特殊文字のほかに，システムに登録された外字を使用できます。詳細は，マニュアル「EUR システム設計ガイド」を参照してください。


帳票ファイル

5.2　帳票ファイル

EURで扱える帳票ファイルは，レポートファイル（*.agr）とフォームシートファイル（*.fms）です。

帳票ファイルの作成については，マニュアル「EUR 帳票作成 操作ガイド」を参照してください。


データファイル

5.3　データファイル

EURでは帳票を設計するときにデータファイルの内容をデータウィンドウに読み込みます。EURでマッピングデータおよびユーザ定義データとして扱えるデータファイルの形式には，CSV形式（*.csv），DAT形式（*.dat），およびFIX形式（*.fix）があります。

EURで使用できるデータ形式については，マニュアル「EUR システム設計ガイド」を参照してください。

＜この節の構成＞
5.3.1　CSV形式（DAT形式）のデータ形式
5.3.2　FIX形式のデータ形式


CSV形式（DAT形式）のデータ形式

5.3.1　CSV形式（DAT形式）のデータ形式

CSV形式（DAT形式）のデータファイルは，フィールドとフィールドの間を区切り記号で区切ったファイルです。UNIX版 EUR旧製品で使用していたDAT形式も使えます。

CSV形式（DAT形式）のデータファイルのファイルサイズ，およびレコードの上限値は，次のとおりです。

表5-2　データファイルに記述する内容の上限値（CSV形式（DAT形式）の場合）

データファイルの記述項目 | 上限値
ファイルサイズ | 2GBを上限とします。
レコード数 | 上限はありません。
レコード長 | 上限はありません。
フィールド数 | 上限はありません。
1フィールドの長さ | 99,999バイトを上限とします。
フィールド名の長さ | マッピングデータのフィールド名：510桁を上限とします。 ユーザ定義データのフィールド名：499桁を上限とします。

CSV形式（DAT形式）のデータは，ディクショナリファイルを省略できます。その場合は，データファイルの1行目のデータ（1行目のデータをフィールド名として扱う場合は2行目のデータ）が「"」で囲まれている場合は文字列として，それ以外は数値データとしてフィールド定義情報が自動生成されます。

次に，ファイル形式を示します。

図5-1　データファイルの記述例（CSV形式（DAT形式）の場合）

＜この項の構成＞
(1)　数値データ
(2)　文字データ
(3)　画像データ
(4)　日付データ
(5)　バーコードデータ
(6)　特殊編集レベルデータ
(7)　区切り文字

(1)　数値データ

数値は，そのまま記述するか，または「"」で囲みます。

  • 先頭に一つ以上の半角空白のある数値データの両端を「"」で囲んで記述した場合，先頭の半角空白を除いたデータが，入力データとなります。
    （例）
    「"△126"」と記述した場合は，「126」が入力データとなります。
    「"△-126△"」と記述した場合は，「-126△」が入力データとなります。
  • 「"」で囲んでいない場合，前後の空白を除いたデータが，入力データとなります。
    （例）
    「△315△」と入力した場合は，「315」が入力データとなります。

(2)　文字データ

文字列を記述します。文字列は，そのまま記述するか，または「"」で囲みます。

  • 「"」を文字データとして使用する場合は，「"」を二つ続けて記述し，文字データの両端を「"」で囲んでください。
    （例）
    「E"UR」とする場合は，「"E""UR"」と指定します。
  • 「"」で囲んでいない場合，前後の空白を除いたデータが，入力データとなります。
    （例）
    「△EUR△」と入力した場合は，「EUR」が入力データとなります。
  • 区切り文字を文字データとして記述する場合は，文字列の両端を「"」で囲んでください。
    （例）
    「,」が区切り文字の場合，「EU,R」とするときは，「"EU,R"」と指定します。
  • 「"」で囲まれていない文字列の終端は，区切り文字，改行コード，または\0（Null：0x00）にしてください。
  • 「"」で囲まれている文字列の終端は，改行コード，または\0（Null：0x00）にしてください。
  • 文字列中のタブコードは，半角空白一つに変換されます。ただし，タブコードが区切り文字として使用されている場合は，区切り文字として扱われます。
  • 「"」で囲まれた文字列中の改行コードは，文字として扱われます。

(3)　画像データ

画像ファイル名をそのまま記述するか，「"」で囲みます。

指定できる画像データは，次のとおりです。

  • Windows BITMAP形式の画像データ
  • JPEG形式の画像データ
  • GIF形式の画像データ
  • TIFF形式の画像データ
  • PNG形式の画像データ

EURで扱える画像データについては，「5.4　画像ファイル」を参照してください。

■補足説明
一つの帳票で複数の画像ファイルを使用する場合は，使用する画像ファイルを同じフォルダに保存しておいてください。

(4)　日付データ

日付データは，西暦または和暦を数値で指定します。

日付データには，入力データの桁数と，指定したいデータ種別の桁数が一致するように入力データを指定してください。入力データの桁数とデータ種別の桁数が合っていないと，マッピングデータウィンドウに表示されないことがあります。

(a)　西暦

西暦を数値で記述します。指定できるデータの種別と桁数を次に示します。

データ種別 | 桁数 | 指定例 （「2004年5月23日12時10分05秒」の場合）
日付（年次） | 4桁 | 2004
日付（月次） | 6桁 | 200405
日付（日次） | 8桁 | 20040523
日付（日付・時刻）※ | 年：4桁 月：2桁 日：2桁 時：2桁 分：2桁 秒：2桁 | 2004/05/23 12:10:05
注※
日付は「/」で，時刻は「:」で区切り，日付と時刻の間は半角空白一つで区切ってください。

(b)　和暦

和暦を指定する場合，1桁目に元号を次の数値で指定します。英語ロケールおよび中国語ロケールでは，和暦は使用できません。

元号 | 指定値
平成 | 4
昭和 | 3
大正 | 2
明治 | 1

指定できるデータ種別と桁数を次に示します。

データ種別 | 桁数 | 指定例
 |  | 「平成21年1月1日」を表示させる場合 | 「昭和64年1月1日」を表示させる場合
和暦（年次） | 3桁 | 421 | 364
和暦（月次） | 5桁 | 42101 | 36401
和暦（日次） | 7桁 | 4210101 | 3640101

和暦日付は，「平成元年1月1日」のような架空の日付も表示できます。また，［アイテムのプロパティ］ダイアログの［表示形式］（日付・時刻データ）タブで，日付の表示形式を次のように設定することもできます。

  • 「平成1年」を「平成元年」と表示できます。
  • 「平成21年」を「H21」と表示できます。

［アイテムのプロパティ］ダイアログについては，マニュアル「EUR 帳票作成 操作ガイド」を参照してください。

(c)　日付データの補足説明

年号を表すデータは4桁で認識されます。そのため，［コントロールパネル］の［地域のオプション］の設定で，年号を2桁に設定している場合は，［日付］ページの［短い形式］のリストボックスから，年号を4桁で表示する形式「yyyy」に選択し直してください。［区切り記号］は，「/」を指定してください。また，Windowsの時刻表示を12時間制の形式に設定している場合は，［時刻］ページの［時間の形式］のリストボックスから，24時間制の形式に選択し直してください。このとき，午前，または午後を表す「t」の付く形式は設定しないでください。

(5)　バーコードデータ

バーコードで使用するデータを指定します。

バーコードで使用するデータは，バーコードの種類によって異なります。指定するデータの桁数が合っていないと，帳票ファイルに貼り付けたとき，バーコードが表示されないことがあります。バーコードのデータについては，マニュアル「EUR システム設計ガイド」を参照してください。

  • 「JAN標準バーコード」にする場合
    使用できるデータは，半角数字（0～9）です。
    データの桁数は，13文字（固定），または12文字（固定）です。
  • 「JAN短縮バーコード」にする場合
    使用できるデータは，半角数字（0～9）です。
    データの桁数は，8文字（固定），または7文字（固定）です。
  • 「ITFバーコード」にする場合
    使用できるデータは，半角数字（0～9）です。
    標準バージョンのデータの桁数は，14文字（固定），または13文字（固定）です。
    拡張バージョンのデータの桁数は，16文字（固定），または15文字（固定）です。
    アドオンバージョンのデータの桁数は，6文字（固定），または5文字（固定）です。
  • 「CODE39バーコード」にする場合
    使用できるデータは，半角数字（0～9），半角英字（A～Z），半角記号「- $ / + % .」，および半角空白です。
    データの桁数は，任意です。
  • 「CODE128バーコード」にする場合
    使用できるデータは，入力データ形式の指定によって異なります。
    • 入力データセットの指定が「コードセットB」の場合
      半角数字（0～9），半角英字（A～Z，a～z），半角記号「! " # $ % & ' ( ) * + , - . / : ; < = > ? @ [ \ ] ^ _ ` { | } ~」，および半角空白です。
      データの桁数は，任意です。
    • 入力データセットの指定が「コードセットC」の場合
      半角数字（0～9）です。
      データの桁数は，任意です。ただし，「コードセットC」の場合は，2桁の数字で一つのバーコードキャラクタを表すので，偶数になるように入力してください。
  • 「GS1-128（UCC/EAN-128）バーコード」にする場合
    使用できるデータは，半角数字（0～9），半角記号「( ) -」，および半角空白です。
    データの桁数は，44文字（固定）です。
  • 「NW-7バーコード」にする場合
    使用できるデータは，半角数字（0～9），および半角記号「- $ : / . +」です。
    データの桁数は，任意です。
  • 「QRコード」にする場合
    QRコードに指定できる入力データ文字は，入力データ形式によって異なります。QRコードに指定できる入力データ文字については，マニュアル「EUR システム設計ガイド」を参照してください。
    • 入力データセットの指定が「文字列」の場合
      使用しているロケールの文字コードに従って，データ（データキャラクタ）をデータファイルに指定します。
      データの桁数は，型番40までで表現できる桁数です。
    • 入力データセットの指定が「16進文字列」の場合
      使用しているロケールの文字コードに従って，データ（データキャラクタ）を16進文字列でデータファイルに指定します。
      データの桁数は，型番40までで表現できる桁数×2です。
    • 入力データセットの指定が「16進バイナリ」の場合
      8ビットバイナリエンコーディングに従って，データ（データキャラクタ）を16進文字列でデータファイルに指定します。
      データの桁数は，型番40までで表現できる桁数×2です。
  • 「カスタマバーコード」にする場合
    使用できるデータは，半角数字（0～9），半角英字（A～Z），および半角記号「-」です。
    データの桁数は，カスタマバーコードのデータ形式によって異なります。「郵便番号＋住所表示番号」のデータは7桁～20桁，「郵便番号＋住所表示番号＋チェックデジット＋制御コード」のデータは23桁です。
  • 「UPC-Aバーコード」にする場合
    使用できるデータは，半角数字（0～9）です。
    データの桁数は，12文字（固定），または11文字（固定）です。
  • 「UPC-Eバーコード」にする場合
    使用できるデータは，半角数字（0～9）です。
    データの桁数は，8文字（固定），または7文字（固定）です。

(6)　特殊編集レベルデータ

繰り返し機能で，帳票に読み込んだデータをレコード単位で任意に編集したい場合は，特殊編集レベルを1～99の範囲で記述します。

  • 記述したレベルは，データウィンドウのレコード番号の横に「（レベル：nn）」と表示されます。
  • 複数レコードに同一レベルを指定した場合，一つのレコードを編集すると，同一レベルのレコードすべてが編集されます。
  • 編集しない場合は，省略するか，または「0」もしくは空白を指定してください。

(7)　区切り文字

データを区切る区切り文字は，データのプロパティ，またはディクショナリファイルで指定します。

なお，「"」は，区切り文字には使用できません。ディクショナリファイルで区切り文字の指定を省略した場合，およびディクショナリファイルを指定しなかった場合は，区切り文字に「,」を使用します。

(a)　コンマを並べて指定した場合

コンマを並べて指定した場合，コンマの間が空データになります。

（例）
指定したデータ："あか","きいろ",,"あお"
入力されるデータ
一つ目のデータ：あか
二つ目のデータ：きいろ
三つ目のデータ：（空データ）
四つ目のデータ：あお
指定したデータ：,,,500
入力されるデータ
一つ目のデータ：（空データ）
二つ目のデータ：（空データ）
三つ目のデータ：（空データ）
四つ目のデータ：500
(b)　コンマの間に一つ以上の半角空白を指定した場合

コンマの間に一つ以上の半角空白を指定した場合，指定した半角空白の数に関係なくコンマの間が空データになります（△は半角空白を示します）。

（例）
指定したデータ："あか","きいろ",△△,"あお"
入力されるデータ
一つ目のデータ：あか
二つ目のデータ：きいろ
三つ目のデータ：（空データ）
四つ目のデータ：あお
指定したデータ：△△△,△△,△△△△,500
入力されるデータ
一つ目のデータ：（空データ）
二つ目のデータ：（空データ）
三つ目のデータ：（空データ）
四つ目のデータ：500
(c)　複数フィールドでn番目以降にコンマだけを並べて指定した場合

複数フィールドでn番目以降にコンマだけを並べて指定した場合，n番目以降のフィールドが空データになります。

（例）
指定したデータ："あか","きいろ",,,
入力されるデータ
一つ目のデータ：あか
二つ目のデータ：きいろ
三つ目のデータ：（空データ）
四つ目のデータ：（空データ）

このように，n番目以降にコンマだけを並べて指定する場合，帳票を定義するときに項目数を定義してあれば，コンマを省略することもできます。項目数を4とした場合，次のようになります。

（例）
指定したデータ："あか"
入力されるデータ
一つ目のデータ：あか
二つ目のデータ：（空データ）
三つ目のデータ：（空データ）
四つ目のデータ：（空データ）
指定したデータ：,500
入力されるデータ
一つ目のデータ：（空データ）
二つ目のデータ：500
三つ目のデータ：（空データ）
四つ目のデータ：（空データ）
(d)　1行すべてのフィールドを空データにする場合

1行すべてのフィールドを空データにする場合は，コンマだけを指定するか，または改行コードだけを指定します。

（例）
指定したデータ：,,,
入力されるデータ
一つ目のデータ：（空データ）
二つ目のデータ：（空データ）
三つ目のデータ：（空データ）
四つ目のデータ：（空データ）
指定したデータ：改行コード
入力されるデータ
一つ目のデータ：（空データ）
二つ目のデータ：（空データ）
三つ目のデータ：（空データ）
四つ目のデータ：（空データ）


FIX形式のデータ形式

5.3.2　FIX形式のデータ形式

FIX形式のデータファイルは，レコード中に区切り文字がなく，すべてのレコードの，フィールドの開始位置とデータ長が固定である形式を持つファイルです。

FIX形式のデータファイルのファイルサイズ，およびレコードの上限値は，次のとおりです。

表5-3　データファイルに記述する内容の上限値（FIX形式の場合）

データファイルの記述項目 | 上限値
ファイルサイズ | 2GBを上限とします。
レコード数 | 上限はありません。
レコード長 | 改行を含めないで32,767バイトを上限とします。
フィールド数 | 上限はありません。ただし，レコード長と1フィールド長の上限値によって制限されます。
1フィールドの長さ | 32,767バイトを上限とします。
フィールド名の長さ | マッピングデータのフィールド名：510桁を上限とします。 ユーザ定義データのフィールド名：499桁を上限とします。

FIX形式のデータは，ディクショナリファイルを省略できます。その場合は，すべてのデータを文字列として扱います。

次に，ファイル形式を示します。

図5-2　FIX形式ファイルの記述例

＜この項の構成＞
(1)　数値データ
(2)　文字データ
(3)　画像データ
(4)　日付データ
(5)　バーコードデータ
(6)　特殊編集レベルデータ
(7)　区切り文字

(1)　数値データ

数値をそのまま記述します。

(2)　文字データ

文字列をそのまま記述します。文字列中のタブコードは，半角空白一つに変換されます。

(3)　画像データ

画像ファイル名をそのまま記述します。

指定できる画像データは，次のとおりです。

  • Windows BITMAP形式の画像データ
  • JPEG形式の画像データ
  • GIF形式の画像データ
  • TIFF形式の画像データ
  • PNG形式の画像データ

EURで扱える画像データについては，「5.4　画像ファイル」を参照してください。

■補足説明
一つの帳票で複数の画像ファイルを使用する場合は，使用する画像ファイルを同じフォルダに保存しておいてください。

(4)　日付データ

日付データは，西暦または和暦を数値で指定します。

日付データには，入力データの桁数と，指定したいデータ種別の桁数が一致するように入力データを指定してください。入力データの桁数とデータ種別の桁数が合っていないと，マッピングデータウィンドウに表示されないことがあります。

(a)　西暦

西暦を数値で記述します。指定できるデータの種別と桁数を次に示します。

データ種別 | 桁数 | 指定例 （「2004年5月23日12時10分05秒」の場合）
日付（年次） | 4桁 | 2004
日付（月次） | 6桁 | 200405
日付（日次） | 8桁 | 20040523
日付（日付・時刻）※ | 年：4桁 月：2桁 日：2桁 時：2桁 分：2桁 秒：2桁 | 2004/05/23 12:10:05
注※
日付・時刻データの場合，日付は「/」で，時刻は「:」で区切り，日付と時刻の間は半角空白一つで区切ってください。

(b)　和暦

和暦を指定する場合，1桁目に元号を次の数値で指定します。英語ロケールおよび中国語ロケールでは，和暦は使用できません。

元号 | 指定値
平成 | 4
昭和 | 3
大正 | 2
明治 | 1

指定できるデータ種別と桁数を次に示します。

データ種別 | 桁数 | 指定例
 |  | 「平成21年1月1日」を表示させる場合 | 「昭和64年1月1日」を表示させる場合
和暦（年次） | 3桁 | 421 | 364
和暦（月次） | 5桁 | 42101 | 36401
和暦（日次） | 7桁 | 4210101 | 3640101

和暦日付は，「平成元年1月1日」のような架空の日付も表示できます。また，［アイテムのプロパティ］ダイアログの［表示形式］（日付・時刻データ）タブで，日付の表示形式を次のように設定することもできます。

  • 「平成1年」を「平成元年」と表示できます。
  • 「平成21年」を「H21」と表示できます。

［アイテムのプロパティ］ダイアログについては，マニュアル「EUR 帳票作成 操作ガイド」を参照してください。

(c)　日付データの補足説明

年号を表すデータは4桁で認識されます。そのため，［コントロールパネル］の［地域のオプション］の設定で，年号を2桁に設定している場合は，［日付］ページの［短い形式］のリストボックスから，年号を4桁で表示する形式「yyyy」に選択し直してください。［区切り記号］は，「/」を指定してください。また，Windowsの時刻表示を12時間制の形式に設定している場合は，［時刻］ページの［時間の形式］のリストボックスから，24時間制の形式に選択し直してください。このとき，午前，または午後を表す「t」の付く形式は設定しないでください。

(5)　バーコードデータ

バーコードで使用するデータを指定します。

バーコードで使用するデータは，バーコードの種類によって異なります。指定するデータの桁数が合っていないと，帳票ファイルに貼り付けたとき，バーコードが表示されないことがあります。バーコードのデータについては，マニュアル「EUR システム設計ガイド」を参照してください。

  • 「JAN標準バーコード」にする場合
    使用できるデータは，半角数字（0～9）です。
    データの桁数は，13文字（固定），または12文字（固定）です。
  • 「JAN短縮バーコード」にする場合
    使用できるデータは，半角数字（0～9）です。
    データの桁数は，8文字（固定），または7文字（固定）です。
  • 「ITFバーコード」にする場合
    使用できるデータは，半角数字（0～9）です。
    標準バージョンのデータの桁数は，14文字（固定），または13文字（固定）です。
    拡張バージョンのデータの桁数は，16文字（固定），または15文字（固定）です。
    アドオンバージョンのデータの桁数は，6文字（固定），または5文字（固定）です。
  • 「CODE39バーコード」にする場合
    使用できるデータは，半角数字（0～9），半角英字（A～Z），半角記号「- $ / + % .」，および半角空白です。
    データの桁数は，可変です。
  • 「CODE128バーコード」にする場合
    使用できるデータは，入力データ形式の指定によって異なります。
    • 入力データセットの指定が「コードセットB」の場合
      半角数字（0～9），半角英字（A～Z，a～z），半角記号「! " # $ % & ' ( ) * + , - . / : ; < = > ? @ [ \ ] ^ _ ` { | } ~」，および半角空白です。
      データの桁数は，任意です。
    • 入力データセットの指定が「コードセットC」の場合
      半角数字（0～9）です。
      データの桁数は，任意です。ただし，「コードセットC」の場合は，2桁の数字で一つのバーコードキャラクタを表すので，偶数になるように入力してください。
  • 「GS1-128（UCC/EAN-128）バーコード」にする場合
    使用できるデータは，半角数字（0～9），半角記号「( ) -」，および半角空白です。
    データの桁数は，44文字（固定）です。
  • 「NW-7バーコード」にする場合
    使用できるデータは，半角数字（0～9），および半角記号「- $ : / . +」です。
    データの桁数は，任意です。
  • 「QRコード」にする場合
    使用できるデータは，入力データ形式の指定によって異なります。
    • 入力データセットの指定が「文字列」の場合
      JIS X 0201に規定されている英数字，半角カタカナ，および記号（半角文字），ならびに漢字（JIS X 0208に規定されている文字）を使用して，データ（データキャラクタ）をデータファイルに指定します。
      データの桁数は，型番20までで表現できる桁数です。
    • 入力データセットの指定が「16進文字列」の場合
      半角数字（0～9），半角英大文字（A～F），および半角英小文字（a～f）を使用して，データ（データキャラクタ）をデータファイルに指定します。また，JIS X 0201に規定されている英数字，半角カタカナ，記号（半角文字），および制御コード，ならびに漢字（JIS X 0208に規定されている文字）は，16進コードで指定できます。
      データの桁数は，型番20までで表現できる桁数×2です。
    • 入力データセットの指定が「16進バイナリ」の場合
      8ビットバイナリエンコーディングに従って，データ（データキャラクタ）を16進文字列でデータファイルに指定します。
      データの桁数は，型番40までで表現できる桁数×2です。
  • 「カスタマバーコード」にする場合
    使用できるデータは，半角数字（0～9），半角英字（A～Z），および半角記号「-」です。
    データの桁数は，カスタマバーコードのデータ形式によって異なります。「郵便番号＋住所表示番号」のデータは7桁～20桁，「郵便番号＋住所表示番号＋チェックデジット＋制御コード」のデータは23桁です。
  • 「UPC-Aバーコード」にする場合
    使用できるデータは，半角数字（0～9）です。
    データの桁数は，12文字（固定），または11文字（固定）です。
  • 「UPC-Eバーコード」にする場合
    使用できるデータは，半角数字（0～9）です。
    データの桁数は，8文字（固定），または7文字（固定）です。

(6)　特殊編集レベルデータ

繰り返し機能で，帳票に読み込んだデータをレコード単位で任意に編集したい場合は，特殊編集レベルを1～99の範囲で記述します。

  • 記述したレベルは，データウィンドウのレコード番号の横に「（レベル：nn）」と表示されます。
  • 複数レコードに同一レベルを指定した場合，一つのレコードを編集すると，同一レベルのレコードすべてが編集されます。

編集しない場合は指定を省略するか，「0」または空白を指定してください。

(7)　区切り文字

データの区切りは，データの開始位置で決まるため，区切り文字は使用しません。

なお，データ中に「，」などを記述すると，データとして扱われます。

FIX形式のデータファイルに空データを指定する場合は，次のように指定します（△は半角空白を示します）。

(a)　あるフィールドのデータに，データ長分の半角空白を並べて指定した場合

あるフィールドのデータに，データ長分の半角空白を並べて指定した場合，そのフィールドは空データになります。データ長を4とした場合，次のようになります。

（例）
指定したデータ：あかしろ△△△△あお
入力されるデータ
一つ目のデータ：あか
二つ目のデータ：しろ
三つ目のデータ：（空データ）
四つ目のデータ：あお
指定したデータ：△△△△△△△△500△△△△△
入力されるデータ
一つ目のデータ：（空データ）
二つ目のデータ：（空データ）
三つ目のデータ：500
四つ目のデータ：（空データ）
(b)　n番目以降のデータに，データ長分の半角空白を並べて指定した場合

n番目以降のデータに，データ長分の半角空白を並べて指定した場合，n番目以降のフィールドがすべて空データになります。データ長を4とした場合，次のようになります。

（例）
指定したデータ：あかしろ△△△△△△△△
入力されるデータ
一つ目のデータ：あか
二つ目のデータ：しろ
三つ目のデータ：（空データ）
四つ目のデータ：（空データ）

このように，n番目以降のデータに，データ長分の半角空白を並べて指定する場合，半角空白は省略できます。

（例）
指定したデータ：500△1000
入力されるデータ
一つ目のデータ：500
二つ目のデータ：1000
三つ目のデータ：（空データ）
四つ目のデータ：（空データ）
(c)　1行すべてのフィールドを空データにする場合

1行すべてのフィールドを空データにする場合は，半角空白だけを指定するか，または改行コードだけを指定します。

（例）
データの指定：△△△△△△△△△△△△
入力されるデータ
一つ目のデータ：（空データ）
二つ目のデータ：（空データ）
三つ目のデータ：（空データ）
四つ目のデータ：（空データ）
指定したデータ：△△△△△△
入力されるデータ
一つ目のデータ：（空データ）
二つ目のデータ：（空データ）
三つ目のデータ：（空データ）
四つ目のデータ：（空データ）
指定したデータ：改行コード
入力されるデータ
一つ目のデータ：（空データ）
二つ目のデータ：（空データ）
三つ目のデータ：（空データ）
四つ目のデータ：（空データ）


画像ファイル

5.4　画像ファイル

EURで扱える画像データの形式は次のとおりです。

  • Windows BITMAP
  • JPEG
  • GIF（GIF GIF87a，GIF GIF89a）
  • TIFF（TIFF 6.0）
  • PNG

    表5-4　EURで扱える画像ファイルのデータ形式

    画像データの形式 詳細形式
    Windows BITMAP（*.bmp）

                   2色モノクロ
    16色パレットカラー
    256色パレットカラー
    24ビットフルカラー
    16色RLE圧縮
    EUR サーバ帳票出力機能で帳票を出力する場合，Windows環境のプリンタ印刷では出力できますが，次に示すときには出力できません。
    • Windows環境でのPDF形式ファイル出力
    • UNIX環境でのプリンタ印刷，PDLファイル出力，およびPDF形式ファイル出力
    256色RLE圧縮
    EUR サーバ帳票出力機能で帳票を出力する場合，Windows環境のプリンタ印刷では出力できますが，次に示すときには出力できません。
    • Windows環境でのPDF形式ファイル出力
    • UNIX環境でのプリンタ印刷，PDLファイル出力，およびPDF形式ファイル出力
    Windows 3.0以前のビットマップ形式
    JPEG（*.jpg / *.jpe / *.jpeg）
                   JFIFフォーマット基本DCT（ベースライン）フルカラー
    JFIFフォーマット基本DCT（ベースライン）256色グレイスケール
    GIF GIF87a（*.gif）

                   2色モノクロ ノンインタレース
    2色モノクロ インタレース
    4色パレットカラー ノンインタレース
    4色パレットカラー インタレース
    16色パレットカラー ノンインタレース
    16色パレットカラー インタレース
    256色パレットカラー ノンインタレース
    256色パレットカラー インタレース
    GIF GIF89a（*.gif）

                   2色モノクロ ノンインタレース
    2色モノクロ インタレース
    4色パレットカラー ノンインタレース
    4色パレットカラー インタレース
    16色パレットカラー ノンインタレース
    16色パレットカラー インタレース
    256色パレットカラー ノンインタレース
    256色パレットカラー インタレース
    透明色指定
    上記の8フォーマット（色4種×インタレース2種）それぞれで透明色の有無の指定ができます。ただし，透明部分は，GIF画像中の背景色が使用されます。
    アニメーション
    上記の8フォーマット（色4種×インタレース2種）それぞれでアニメーションの有無の指定ができます。ただし，先頭の1枚目だけが使用されます。
    TIFF 6.0（*.tif / *.tiff）

                   2色モノクロ 非圧縮
    2色モノクロ ハフマン圧縮
    2色モノクロ G3/G4 FAX互換圧縮
    16色 非圧縮
    256色 非圧縮
    24ビット色 非圧縮
    グレイスケール 非圧縮
    カラー：RGB指定
    カラー：YCbCr指定
    複数画像（ただし，先頭の1枚だけを対象とします）
    ストリップ形式（カラーTIFFのストリップも使用できます）
    PNG（*.png）

                   2色パレットカラー ノンインタレース
    2色パレットカラー インタレース
    4色パレットカラー ノンインタレース
    4色パレットカラー インタレース
    16色パレットカラー ノンインタレース
    16色パレットカラー インタレース
    256色パレットカラー ノンインタレース
    256色パレットカラー インタレース
    2色グレイスケール ノンインタレース
    2色グレイスケール インタレース
    4色グレイスケール ノンインタレース
    4色グレイスケール インタレース
    16色グレイスケール ノンインタレース
    16色グレイスケール インタレース
    256色グレイスケール ノンインタレース
    256色グレイスケール インタレース
    65536色グレイスケール ノンインタレース（ただし，256色グレイスケールに減色されます）
    65536色グレイスケール インタレース（ただし，256色グレイスケールに減色されます）
    24ビットフルカラー ノンインタレース
    24ビットフルカラー インタレース
    48ビットフルカラー ノンインタレース（ただし，24ビットフルカラーに減色されます）
    48ビットフルカラー インタレース（ただし，24ビットフルカラーに減色されます）
    透明色指定
    上記の22フォーマット（色11種×インタレース2種）それぞれで透明色の有無の指定ができます。ただし，透明部分は，PNG画像中の背景色が使用されます。
    アニメーション
    上記の22フォーマット（色11種×インタレース2種）でアニメーション有の指定はできません。
    αチャネル指定
    αチャネルは指定しても無効になります。
■注意
画像が正しく出力されない場合，画像データの内容に問題があることがあります。このような場合は，画像を作成したソフトウェアとは別のソフトウェアで，画像を保存し直すことをお勧めします。


プリンタ定義ファイル

5.5　プリンタ定義ファイル

帳票を印刷するとき，印刷位置を補正するために水平方向と垂直方向のシフト量やCODE128バーコードのバーの調整をプリンタ定義ファイルに定義します。

例えば，プレプリント用紙を使用した場合，出力先プリンタのハードの給紙精度によって印刷位置がずれることがあります。プリンタごとの補正情報をプリンタ定義ファイルに定義しておくことで，印刷位置がずれることなく印刷できます。

＜この節の構成＞
5.5.1　プリンタ定義ファイルの作成
5.5.2　プリンタ定義ファイルの構文
5.5.3　プリンタ定義ファイルのキーワード
5.5.4　プリンタ定義ファイルの指定例


プリンタ定義ファイルの作成

5.5.1　プリンタ定義ファイルの作成

プリンタ定義ファイルは，システム管理者が作成してください。

プリンタ定義ファイルは，テキストファイル形式です。メモ帳などのテキストエディタを開いて作成，または編集してください。

プリンタ定義ファイルは，次に示すフォルダに，ファイル名「printerinf」で保存してください。

  • EUR Designerの場合
    EUR Designerのインストール先フォルダ\Designer
  • EUR Viewerの場合
    EUR Viewerのインストール先フォルダ


プリンタ定義ファイルの構文

5.5.2　プリンタ定義ファイルの構文

[プリンタ名]

キーワード=値

指定項目 | 説明
プリンタ名 | Windowsで登録されているプリンタ名です。
キーワード=値 | プリンタ情報を「キーワード=値」の形式で記述します。
構文中に空白を指定する場合の注意
構文中に空白を指定する場合は，次のように指定してください。
△1[プリンタ名]△2
△1キーワード△1=△1値△1
空白（△）の説明
△1：0個以上のタブ，半角空白，または全角空白を示します。
△2：これ以降，改行コード（\r\n，または\n）までを無視します。


プリンタ定義ファイルのキーワード

5.5.3　プリンタ定義ファイルのキーワード

プリンタ定義ファイルに記述するキーワードを次に示します。プリンタ定義ファイルのキーワードは，大文字，小文字を区別しません。

＜この項の構成＞
(1)　PaperShiftX
(2)　PaperShiftY
(3)　CODE128PARAM
(4)　CODE128PATTERN
(5)　BarcodeImageSize
(6)　DrawBarStyle

(1)　PaperShiftX

横方向の印刷位置補正値を，小数点以下1桁（nn.n形式）で指定します。印刷位置の補正値は，0.1mm単位で-10.0～10.0で指定します。省略した場合は，「0.0」が仮定されます。

印刷位置を左方向にシフトする場合は負数，右方向にシフトする場合は正数を指定します。

注意
印刷位置を補正しても，ハードマージンには印刷できません。
また，プリンタハードによっては，印刷位置を補正することで，一部のオブジェクトがハードマージンに掛かってしまった場合，印刷が欠けることがあります。試し印刷で動作確認することをお勧めします。

(2)　PaperShiftY

縦方向の印刷位置補正値を，小数点以下1桁（nn.n形式）で指定します。印刷位置の補正値は，0.1mm単位で-10.0～10.0で指定します。省略した場合は，「0.0」が仮定されます。

印刷位置を上方向にシフトする場合は負数，下方向にシフトする場合は正数を指定します。

注意
印刷位置を補正しても，ハードマージンには印刷できません。
また，プリンタハードによっては，印刷位置を補正することで，一部のオブジェクトがハードマージンに掛かってしまった場合，印刷が欠けることがあります。試し印刷で動作確認することをお勧めします。

(3)　CODE128PARAM

CODE128バーコードのバーコード補正情報を指定します。次に示す形式で指定します。

type 〔,〔Param1〕,〔Param2〕〕

環境変数EUR_CODE128_PARAMとプリンタ定義ファイルのキーワードCODE128PARAMが同時に指定された場合は，プリンタ定義ファイルの指定が有効になります。

type
バーコードの描画方式を指定します。
指定値 | 説明
0 | ミリメートル（mm）で指定したモジュールサイズからバーキャラクタサイズを計算します。モジュールサイズ×11（mm）を超えないドット数でバーキャラクタを描画します。ストップキャラクタは，モジュールサイズ×13（mm）を超えないドット数で描画します。1を指定した場合と比べて，サイズを細かく指定できますが，バーコードの質は落ちます。
1 | ミリメートル（mm）で指定したモジュールサイズを超えないドット数を求め，その11倍をバーキャラクタのサイズにします。1ドットの大きさを超えるまではバーコードの大きさは変わりません。プリンタ解像度によって補正するドット数が変わります。
2 1を指定した場合の計算方法に加えて，Param1で指定した幅に相当するドット数分だけ黒バーを細く，白バーを太くします。
Param2を指定した場合は，Param1で指定した値で補正した状態のスタートキャラクタとストップキャラクタにParam2で指定した値でさらに補正します。
省略した場合，または0，1，2以外の値を指定した場合は，0が仮定されます。指定値が0の場合，Param1，およびParam2に指定した値は無視されます。
Param1
typeに2を指定した場合，バーを調整する幅をミリメートルで指定します。指定した値をドット単位に変換した計算値の小数第一位を四捨五入した値が補正されます。補正するドット数の計算結果が1以上の場合だけ補正されます。
Param1に指定した値をドット単位に変換する計算式を次に示します。
計算値（ドット） = Param1に指定する値 ÷ 25.4 ×解像度（dpi）
解像度300dpiの場合，補正するドット数の計算結果を次に示します。

表5-5　解像度300dpiの場合に補正するドット数

Param1またはParam2に指定する値（ミリメートル） | 補正するドット数（ドット） | 計算値（ドット）
0.04 | 0 | 0.472441
0.041 | 0 | 0.484252
0.042 | 0 | 0.496063
0.043 | 1 | 0.507874
0.044 | 1 | 0.519685
0.045 | 1 | 0.531496
0.046 | 1 | 0.543307
解像度600dpiの場合，補正するドット数の計算結果を次に示します。

表5-6　解像度600dpiの場合に補正するドット数

Param1またはParam2に指定する値（ミリメートル） | 補正するドット数（ドット） | 計算値（ドット）
0.02 | 0 | 0.472441
0.021 | 0 | 0.496063
0.022 | 1 | 0.519685
0.023 | 1 | 0.543307
0.024 | 1 | 0.566929
0.025 | 1 | 0.590551
0.026 | 1 | 0.614173
Param2
typeに2を指定した場合，Param1に指定した値で補正したバーコードのスタートキャラクタとストップキャラクタを調整する幅をミリメートルで指定します。指定した値をドット単位に変換した計算値の小数第一位を四捨五入した値が補正されます。補正するドット数の計算結果が1以上の場合だけ補正されます。Param2に指定した値をドット単位に変換する計算式はParam1の場合と同じです。
解像度別の補正するドット数については，表5-5，表5-6を参照してください。
注意
  • バーの幅を超える値を指定した場合は，バーの幅を1ドットに設定します。
  • typeに1を指定した場合でも，param1に数値を指定して，param2を省略したときは0が仮定されます。
  • typeに2を指定した場合でも，次のときは0が仮定されます。
    ・param1を指定しなかったとき
    ・param1が数値以外，または0以下だったとき
  • typeに2を指定した場合でも，param1に0より大きい値，param2に0以下の値を指定したときは，param2は無視されます。

(4)　CODE128PATTERN

バーコードパターンファイル名をフルパスで指定します。CODE128PARAMまたは環境変数EUR_CODE128_PARAMと同時に指定した場合は，CODE128PATTERNキーワードで指定されたパターンファイルを使用してチューニングされます。

CODE128PATTERN=バーコードパターンファイル名

(5)　BarcodeImageSize

QRバーコードまたはカスタマバーコードの出力データのサイズを指定します。

指定値 | 説明
normal | 通常の方法で出力します。
minimize | QRバーコード，またはカスタマバーコードの描画データを最小化します。

印刷時のスプールサイズや帳票ファイルのサイズを小さくしたい場合，または実行時間を短縮したい場合にはminimizeを指定します。

minimizeを指定すると，プリンタによっては，QRバーコードまたはカスタマバーコードがにじんだり周囲に線が表示されたりする場合があります。

このような場合は，DrawBarStyleを使用すると正しく表示できることがあります。

(6)　DrawBarStyle

バーコードの描画方法を変更します。

指定値 | 説明
SRCCOPY | 通常の方法で出力します。
NOTSRCCOPY | バーコードがにじんだり周囲に線が表示されたりする場合に，描画方法を変更します。

バーコードがにじんだり周囲に線が表示されたりする場合，NOTSRCCOPYを指定すると改善されることがあります。

なお，プリンタによっては，NOTSRCCOPYを指定するとバーコードが白黒反転して描画されることがあります。


プリンタ定義ファイルの指定例

5.5.4　プリンタ定義ファイルの指定例

2台のプリンタを使用した，プリンタ定義ファイルの指定例を次に示します。

  • Printer1の定義内容
    定義する項目 | 指定する値
    印刷位置（横方向） | 右に10.0mmシフト
    印刷位置（縦方向） | 下に5.0mmシフト
    CODE128バーコード バーの幅を0.08mmで調整
    スタートキャラクタとストップキャラクタを0.04mmで調整
  • Printer2の定義内容
    定義する項目 | 指定する値
    印刷位置（横方向） | 右に5.0mmシフト
    印刷位置（縦方向） | 下に10.0mmシフト
    CODE128バーコード バーの幅を0.06mmで調整
    スタートキャラクタとストップキャラクタを0.04mmで調整
[Printer1]
  PaperShiftX=10.0
  PaperShiftY=5.0
  CODE128PARAM=2,0.08,0.04

[Printer2]
  PaperShiftX=5.0
  PaperShiftY=10.0
  CODE128PARAM=2,0.06,0.04


帳票セット指定ファイル

5.6　帳票セット指定ファイル

EURでは，複数の異なる様式（帳票）を一つの帳票として印刷，および表示できます。これを，「複数様式で帳票を出力する」といいます。複数様式で帳票を出力するには，「帳票セット指定ファイル」と「複数様式情報定義ファイル」が必要です。

帳票セット指定ファイルは，複数の帳票ファイルを統合する順番と帳票に読み込むデータファイルを指定しておくファイルです。

図5-3　帳票セット指定ファイルの構成図

帳票ファイル（フォームシートファイル）とデータファイル（マッピングデータファイル，またはユーザ定義データファイル）の一まとまりを帳票セットといいます。

複数様式情報定義ファイルについては，「5.7　複数様式情報定義ファイル」を参照してください。

＜この節の構成＞
5.6.1　帳票セット指定ファイルの作成
5.6.2　帳票セット指定ファイルの指定例


帳票セット指定ファイルの作成

5.6.1　帳票セット指定ファイルの作成

帳票セット指定ファイルの形式と，作成する方法について説明します。

＜この項の構成＞
(1)　帳票セット指定ファイルの形式
(2)　帳票セット指定ファイルの編集

(1)　帳票セット指定ファイルの形式

帳票セット指定ファイルの形式を次に示します。

帳票セット1 △1〔△2
  〔帳票セット2 △1〕〕〔△2
         ：
  〔帳票セットn △1〕〕
（凡例）
△1：0個以上のタブ，または半角空白を示します。
△2：改行コード（\r\n，または\n）を示します。

(2)　帳票セット指定ファイルの編集

帳票セット指定ファイルは，メモ帳など，テキストファイルが編集できるエディタを起動して編集します。任意の拡張子のファイルを使用できます。

(a)　帳票セットの形式

帳票セットは，帳票ファイルと入力データを一まとまりにしたものです。

帳票ファイル名△n〔,〔マッピングデータ△n〕〔,〔ユーザ定義データ△n〕〕〕

（凡例）
△n：ファイル名を区切るコンマ「,」の前に，0個以上の半角空白，または0個以上の改行コード（\t）が指定できることを示します。

「マッピングデータ」と「ユーザ定義データ」に指定するファイル情報は，帳票を設計するときに使用したデータによって，次のように異なります。

  • データファイルから読み込んだデータの場合
    データファイル名を指定します。省略した場合は，帳票設計時に指定したデータファイル名が入力されます。帳票設計時に指定したデータファイル名は，EUR 帳票作成機能の［データのプロパティ］ダイアログの［データ情報］タブで確認できます。
  • データベースアクセス定義で抽出したデータを読み込んだ場合
    可変記号値定義ファイル名を指定します。データベースアクセス定義で可変記号を設定しなかったとき，または可変記号の初期値で実行するときは，可変記号値定義ファイル名の指定を省略できます。
    誤ってデータファイル名を指定した場合は，データファイル名が指定されたと見なされます。また，オプション記述ファイルのキーワード「DBInfoFileName」に接続情報ファイルが指定されていない場合は，可変記号値定義ファイルを指定しても，データファイルと見なされます。データベースに接続して帳票にデータを読み込む場合は，「DBInfoFileName」に接続情報ファイルを指定してください。
(b)　ファイルの指定のしかた
  • 帳票ファイルに指定できるファイルの種類は，フォームシートファイル（*.fms）です。フォームシートファイル名は必ず指定してください。フォームシートファイル名が指定されていない場合は，エラーコード4623を返します。
  • 帳票ファイル，マッピングデータファイル，ユーザ定義データファイル，および可変記号値定義ファイルは，フルパス，相対パス，またはファイル名だけのどれかで指定してください。ファイル名をフルパスで指定しなかった場合は，［オプション］ダイアログの［ファイル］タブで指定されているパスからの相対パス，またはファイルを読み込みます。
  • ファイル名に空白が含まれている場合は，個々のファイルを「"」で囲んでください。例えば，フォームシートファイル名に空白が含まれている場合は，「"Report 1.fms",Mapdata.csv」のように指定します。
(c)　帳票セットを指定する場合の注意
  • 帳票セットは，一つ以上指定してください。一つ以上の帳票セットが指定されていない場合は，エラーコード4623を返します。指定できる帳票セットの上限は，帳票セットの「マッピングデータ」と「ユーザ定義データ」に指定するファイル情報によって異なります。
    • データファイルからの場合
      2,147,483,647セットまで
    • データベースからの場合
      10セットまで
  • 帳票セットは，「"」で囲まないでください。帳票セットを「"」で囲んだ場合は，すべてのファイルを帳票ファイルと見なします。


帳票セット指定ファイルの指定例

5.6.2　帳票セット指定ファイルの指定例

EURが提供しているサンプル帳票セット指定ファイルの指定内容を示します。

＜この項の構成＞
(1)　サンプル帳票「請求書」の場合
(2)　サンプル帳票「従業員勤務歴カード」の場合
(3)　サンプル帳票「保険申込書」の場合

(1)　サンプル帳票「請求書」の場合

複数様式のサンプル帳票「請求書」を出力するときに指定する，サンプル帳票セット指定ファイル（formset01（複数様式帳票例１）.txt）の指定例を示します。

一つのデータファイルを二つの異なる様式（帳票）で共有しています。

■サンプル帳票セット指定ファイル（formset01（複数様式帳票例１）.txt）の内容
表紙次紙形式の帳票＿表紙（複数様式帳票例１）.fms,表紙次紙形式の帳票＿表紙（複数様式帳票例１）.csv
表紙次紙形式の帳票＿次紙（複数様式帳票例１）.fms,表紙次紙形式の帳票＿表紙（複数様式帳票例１）.csv

(2)　サンプル帳票「従業員勤務歴カード」の場合

複数様式のサンプル帳票「従業員勤務歴カード」を出力するときに指定する，サンプル帳票セット指定ファイル（formset02（複数様式帳票例２）.txt）の指定例を示します。

二つのデータファイルと三つの異なる様式（帳票）を使用しています。

■サンプル帳票セット指定ファイル（formset02（複数様式帳票例２）.txt）の内容
従業員勤務歴１（複数様式帳票例２）.fms,従業員勤務歴１（複数様式帳票例２）.csv
従業員勤務歴１－次紙（複数様式帳票例２）.fms,従業員勤務歴１（複数様式帳票例２）.csv
従業員勤務歴２（複数様式帳票例２）.fms,従業員勤務歴２（複数様式帳票例２）.csv

(3)　サンプル帳票「保険申込書」の場合

複数様式のサンプル帳票「保険申込書」を出力するときに指定する，サンプル帳票セット指定ファイル（formset03（複数様式帳票例３）.txt）の指定例を示します。

一つのデータファイルを三つの異なる様式（帳票）で共有しています。

■サンプル帳票セット指定ファイル（formset03（複数様式帳票例３）.txt）の内容
保険申込書（複数様式帳票例３）.fms,保険申込書（複数様式帳票例３）.csv
保険申込書＿代理店控（複数様式帳票例３）.fms,保険申込書（複数様式帳票例３）.csv
保険申込書＿契約者控（複数様式帳票例３）.fms,保険申込書（複数様式帳票例３）.csv


複数様式情報定義ファイル

5.7　複数様式情報定義ファイル

複数様式帳票は，複数の異なる様式（帳票）を一組の帳票として出力した帳票です。複数様式で帳票を出力する場合は，複数様式情報定義ファイルが必要です。

複数様式情報定義ファイルは，様式（帳票フォーマット）や読み込むデータを切り替える条件と，切り替え時の動作を定義しておくファイルです。

同じデータファイルから出力する様式のまとまりを様式グループといいます。様式グループの中にも様式グループを定義することができます。これをサブ様式グループといいます。サブ様式グループを定義すると，様式グループのデータを細かく切り分けて，それぞれ異なるフォーマットの帳票に出力できます。

サブ様式グループを定義した帳票の出力例を次に示します。

図5-4　サブ様式グループを定義した帳票の出力例

この出力例では，日立家のデータをすべて出力してから，戸塚家のデータを出力します。一家族分のデータからは，まず家族全員の総計を出力してから，個人の明細を出力します。

＜この節の構成＞
5.7.1　複数様式情報定義ファイルの編集
5.7.2　複数様式情報定義ファイルの指定例


複数様式情報定義ファイルの編集

5.7.1　複数様式情報定義ファイルの編集

複数様式情報定義ファイルは，メモ帳など，テキストファイルが編集できるエディタを起動して編集します。任意の拡張子のファイルを使用できます。

複数様式情報定義ファイルに指定するキーワードとオプションは，大文字，小文字の区別をしません。

複数様式情報定義ファイルの形式を次に示します。

group 様式グループ番号 {
  〔grouptransfercondition {              …様式グループ遷移条件
      transfercondition={KBNF|EOFN}
      〔fieldname="フィールド名"〕
   }〕
  〔formtransfercondition {               …様式間遷移条件
      keybreaktopform={ON|OFF}
      〔fieldname="フィールド名"〕
   }〕
  〔formfilename "帳票ファイル名" {       …様式遷移情報
      transfercondition={NPNF|KBNF|EOFN}
      printnewpaper={ON|OFF}
      resetpagenumber={ON|OFF}
      〔traycode=給紙トレイ番号〕
   }〕
  〔subgroup サブ様式グループ番号 {       …サブ様式グループ
      grouptransfercondition {
        transfercondition=KBNF
        fieldname="フィールド名"
      }
     〔formtransfercondition {
        keybreaktopform={ON|OFF}
       〔fieldname="フィールド名"〕
      }〕
      formfilename "帳票ファイル名" {
        transfercondition={NPNF|KBNF}
        printnewpaper={ON|OFF}
        resetpagenumber={ON|OFF}
       〔traycode=給紙トレイ番号〕
      }
  }〕
}
               :

複数様式情報定義ファイルで指定するキーワードは，次のとおりです。

表5-7　複数様式情報定義ファイルで指定するキーワード

キーワード | 説明 | キーワードの省略可否
group | グルーピングした出力様式（様式グループ）を識別する番号を指定します。 | ×
grouptransfercondition | グループごとに様式を切り替える条件（様式グループ遷移条件）を指定します。 | ○
formtransfercondition | フィールドごとに様式を切り替える条件（様式間遷移条件）を指定します。 | ○
formfilename | 様式遷移情報を指定します。 ここでは，様式を切り替える条件，両面印刷時の白紙挿入の条件，ページ番号の指定方法などを設定します。 | ○
subgroup | サブ様式グループを識別する番号を指定します。 | ○
（凡例）
○：指定を省略できるキーワードです。
×：必ず指定するキーワードです。

注意
  • サブ様式グループは，先頭の様式グループには指定できません。先頭の様式グループに指定してもエラーにはなりませんが，正しく帳票出力できません。
  • 様式グループまたはサブ様式グループの先頭に定義した様式の帳票は，必ず出力されるように指定してください。様式グループ，またはサブ様式グループの先頭に定義した様式の帳票が出力されない場合，帳票は正しく出力されません。
＜この項の構成＞
(1)　group
(2)　grouptransfercondition
(3)　formtransfercondition
(4)　formfilename
(5)　subgroup

(1)　group

様式グループを識別する番号を指定します。

■groupの形式
group 様式グループ番号
様式グループ番号
様式グループ番号を1以上の整数で指定します。様式グループ番号は，様式グループ間で同じ番号がないように指定してください。同じ様式グループ番号がある場合，または様式グループ番号が昇順で指定されていない場合は，エラーコード4631を返します。

様式グループは，次に示すように，読み込むデータファイルごとに作成します。

図5-5　複数様式情報定義ファイルとデータファイルの例（様式グループを読み込むデータファイルごとに作成する場合）

サンプル「保険申込書」のように，一つのデータファイルを3様式で共有していても，様式ごとに1レコードのデータを読み込む場合は，様式グループは三つになります。

図5-6　複数様式情報定義ファイルとデータファイルの例（様式ごとに1レコードのデータを読み込む場合）

(2)　grouptransfercondition

様式グループを切り替える条件（様式グループ遷移条件）を指定します。grouptransferconditionは，指定を省略できます。

■grouptransferconditionの形式
〔grouptransfercondition {
transfercondition={KBNF|EOFN}
〔fieldname="フィールド名"〕
}〕
■キーワードtransferconditionの構文
transfercondition={KBNF|EOFN}
KBNF | EOFN
様式グループを次の様式グループに切り替える条件を指定します。
サブ様式グループを切り替える場合は，KBNFを指定します。
  • KBNF
    キーブレイクのタイミングで次の様式グループに切り替えます。KBNFを指定した場合は，キーワードfieldnameで，キーブレイクするフィールド名を指定してください。
    KBNFを指定する場合は，様式グループのformfilenameに指定する帳票を設計するときに，フィールド名とフィールド属性が同じになるように指定してください。
  • EOFN
    様式グループのformfilenameに指定されているすべての帳票ファイルを印刷したあと，次の様式グループに切り替えます。

    図5-7　transferconditionの値による様式グループ切り分けタイミングの違い

■キーワードfieldnameの構文
fieldname="フィールド名"
フィールド名
キーブレイクの対象となるフィールド名を「"」で囲んで指定します。
キーワードtransferconditionにKBNFを指定した場合は，フィールド名を指定してください。
各様式グループに指定されたフィールドが同じ名称でない場合は，エラーコード4642を返します。また，同じフィールド属性でない場合は，エラーコード4644を返します。
様式グループとサブ様式グループに指定されたフィールド名が同じ名称の場合は，エラーコード4631を返します。

(3)　formtransfercondition

grouptransferconditionは，キーブレイクの対象となるフィールドのデータが変わった時点で次の様式グループに切り替えますが，formtransferconditionは，キーブレイクの対象となるフィールドのデータが変わった時点で先頭の様式に切り替えるかどうかを指定します。

例えば，請求書のように，次のような条件で帳票出力する場合，formtransferconditionを指定します。

  • 様式1は必ず出力します。
  • 様式1に納まらないデータがある場合，続きのデータを様式2に出力して，請求先のデータが変わった時点で，様式1に戻るようにします。
  • 様式1の出力で請求先のデータが変わった場合は，様式1に戻ります。

    図5-8　formtransferconditionの指定例

このように，先頭の様式を出力したあと，次の様式に続きのデータを出力しなくて済む場合は，formtransferconditionを指定しておくと便利です。

formtransferconditionを指定した場合，同じ様式グループ内にsubgroupは指定できません。formtransferconditionとsubgroupを同時に指定した場合は，エラーコード4631を返します。

■formtransferconditionの形式
〔formtransfercondition {
keybreaktopform={ON|OFF}
〔fieldname="フィールド名"〕
}〕
■キーワードkeybreaktopformの構文
keybreaktopform={ON|OFF}
ON | OFF
先頭の様式に切り替えるかどうかを指定します。
  • ON
    キーブレイクのタイミングで先頭の様式に切り替えます。
    ONを指定した場合は，キーワードfieldnameで，キーブレイクするフィールド名を指定してください。
    先頭の様式を出力する場合，ページ番号の開始番号を初期化するときは，キーワードformfilenameのresetpagenumberにONを指定しておいてください。
  • OFF
    先頭への様式には切り替えません。キーワードformfilenameのtransferconditionで指定されている各様式の遷移条件での動作になります。
■補足説明
キーワードtransferconditionでNPNFが設定されている場合，先頭の様式でページ番号の開始番号を初期化するときは，キーワードkeybreaktopformにONを指定しておいてください。OFFが指定されている場合は，ページ番号が初期化されません。

図5-9　keybreaktopformの値による様式切り替えの違い

■キーワードfieldnameの構文
fieldname="フィールド名"
フィールド名
キーブレイク対象フィールド名を「"」で囲んで指定します。
キーワードkeybreaktopformにONを指定した場合は，フィールド名を指定してください。指定されていない場合は，エラーコード4631を返します。

(4)　formfilename

様式を次の様式に切り替える条件を指定します。

formfilenameを指定した場合，同じ様式グループ内にsubgroupは指定できません。formfilenameとsubgroupを両方指定した場合，またはどちらも指定しなかった場合は，エラーコード4631を返します。

formfilenameは必ず指定してください。formfilenameが指定されていない場合は，エラーコード4631を返します。

formfilenameは，様式グループ内に指定する様式の数分を繰り返し指定します。

■formfilenameの形式
formfilename "帳票ファイル名" {
transfercondition={NPNF|KBNF|EOFN}
printnewpaper={ON|OFF}
resetpagenumber={ON|OFF}
〔traycode=給紙トレイ番号〕
}
帳票ファイル名
帳票ファイル名を「"」で囲んで指定します。パスの指定は要りません。
指定する帳票ファイル名は，様式グループ間で同じ名称がないように指定してください。同じ名称の帳票ファイルがある場合，または帳票ファイル名をパス指定された場合は，エラーコード4631を返します。
複数様式で出力する場合は，一組にする帳票すべてに同じキーフィールドで改ページするように設計しておいてください。
帳票ヘッダのある帳票は，複数様式では出力できません。
■キーワードtransferconditionの構文
transfercondition={NPNF|KBNF|EOFN}
NPNF | KBNF | EOFN
様式を切り替える条件を指定します。
サブ様式グループの様式を切り替える場合は，NPNFとKBNFが指定できます。
  • NPNF（ページエンド改ページ）
    キーブレイク以外の改ページのタイミングで，次の様式に切り替えます。
  • KBNF（キーブレイク改ページ）
    キーブレイクのタイミングで，次の様式に切り替えます。
    KBNFを指定した場合，grouptransferconditionもしくはformtransferconditionのキーワードfieldnameに指定されているキーブレイク対象フィールド，または帳票に設定されている改ページのキーフィールドによって様式を切り替えます。
    KBNFを指定する場合は，帳票ファイル名に指定する帳票を設計するときに，フィールド名とフィールド属性が同じになるように指定してください。
  • EOFN（ファイル終端）
    すべての様式のデータを印刷したあと，次の様式に切り替えます。
■キーワードprintnewpaperの構文
printnewpaper={ON|OFF}
ON | OFF
プリンタの印刷設定で「両面」が設定されている場合，キーワードprintnewpaperを指定した様式が常に用紙の表面になるように空白ページを挿入するかどうかを指定します。
  • ON
    様式が常に用紙の表面になるように，空白ページを挿入します。

    図5-10　printnewpaperがONの場合の例

  • OFF
    印刷している様式に偶数ページがない場合，次の様式を続けて印刷します。

    図5-11　printnewpaperがOFFの場合の例

■キーワードresetpagenumberの構文
resetpagenumber={ON|OFF}
ON | OFF
キーとなるフィールドのデータが変わった時点で，ページ番号の開始番号を初期化するかどうかを指定します。
  • ON
    キーとなるフィールドのデータが変わった時点で，ページ番号を初期化します。

    図5-12　resetpagenumberがONの場合の例

  • OFF
    ページ番号は初期化しません。通し番号になります。

    図5-13　resetpagenumberがOFFの場合の例

■補足説明
複数様式の帳票の場合，帳票設計時の改ページの設定ではページ番号を初期化するかどうかは有効になりません。キーワードresetpagenumberの設定だけが有効になります。
■キーワードtraycodeの構文
〔traycode=給紙トレイ番号〕
給紙トレイ番号
この様式を印刷するときのプリンタの給紙トレイコードを指定します。
指定する給紙トレイコードは，EURで提供している［給紙トレイ一覧］ツールで表示された，出力先プリンタに対応した給紙トレイコードを指定してください。キーワードtraycodeを省略した場合は，出力先プリンタのデフォルトの給紙トレイから給紙されます。［給紙トレイ一覧］ツールについては，「付録B.1　給紙トレイ一覧ツール」を参照してください。

(5)　subgroup

サブ様式グループを識別する番号を指定します。

subgroupとformfilenameは，どちらかを指定してください。subgroupとformfilenameを両方指定した場合，またはどちらも指定しなかった場合は，エラーコード4631になります。

subgroupを指定すると，formtransferconditionは指定できません。subgroupとformtransferconditionを同時に指定した場合は，エラーコード4631を返します。

group文とsubgroup文の様式グループ遷移条件（grouptransfercondition）のフィールド名（fieldname）には異なる文字列を指定してください。同じ文字列を指定すると，エラーコード4631を返します。

■subgroupの形式
subgroup サブ様式グループ番号
サブ様式グループ番号
サブ様式グループ番号を1以上の整数で指定します。サブ様式グループは，様式グループの中にだけ指定できます。様式グループの中以外に指定した場合は，エラーコード4631を返します。
また，サブ様式グループ番号は，サブ様式グループ間で同じ番号がないように指定してください。同じサブ様式グループ番号がある場合，またはサブ様式グループ番号が昇順で指定されていない場合は，エラーコード4631を返します。
サブ様式グループを定義した場合，どのように帳票が出力されるかを次に示します。

注意
サブ様式グループを定義したファイルは，次に示すバージョンの製品で読み込んでください。
製品 | バージョン
EUR Designer | 08-00以降
EUR Developer | 08-00以降
EUR Print Service Enterprise | 08-00以降
EUR Professional Edition | 05-06以降
EUR Print Service | 05-06以降
EUR Server Standard | 09-00以降
EUR Server Enterprise | 09-00以降
EUR Server Print Edition | 09-00以降
バージョン05-05以前のEUR，またはEUR Print Serviceで読み込んだ場合はエラーコード4631を返します。


複数様式情報定義ファイルの指定例

5.7.2　複数様式情報定義ファイルの指定例

EURが提供しているサンプル複数様式情報定義ファイルの指定例を示します。

＜この項の構成＞
(1)　サンプル帳票「請求書」の場合
(2)　サンプル帳票「従業員勤務歴カード」の場合
(3)　サンプル帳票「保険申込書」の場合
(4)　給紙トレイ番号を指定した場合
(5)　サブ様式グループを指定した場合

(1)　サンプル帳票「請求書」の場合

複数様式のサンプル帳票「請求書」を出力するときに指定する，サンプル複数様式情報定義ファイル（formdef01（複数様式帳票例１）.txt）の指定例を示します。

group 1 {
 formtransfercondition {
   keybreaktopform=ON        …フィールド「請求書番号」が
                               キーブレイクしたら，
                               先頭の様式（表紙）に戻ります
   fieldname="請求書番号"
 }
 formfilename "表紙次紙形式の帳票＿表紙（複数様式帳票例１）.fms" {
   transfercondition=NPNF        …表紙を1ページ出力すると
                                   次紙に移ります
   printnewpaper=OFF  ※
   resetpagenumber=ON        …次紙から表紙に戻ったとき，
                               ページ番号を初期化します
 }
 formfilename "表紙次紙形式の帳票＿次紙（複数様式帳票例１）.fms" {
   transfercondition=KBNF      …キーブレイクしたら，
                                 表紙に戻ります
   printnewpaper=OFF
   resetpagenumber=OFF         …表紙からの続きのページ番号を
                                 出力します
 }
}
注※
両面印刷する場合，「表紙次紙形式の帳票＿表紙」を表面に印刷したいときは，次のように指定してください。「表紙次紙形式の帳票＿次紙」に出力するデータがない場合は，裏面を白紙にします。
printnewpaper = ON

(2)　サンプル帳票「従業員勤務歴カード」の場合

複数様式のサンプル帳票「従業員勤務歴カード」を出力するときに指定する，サンプル複数様式情報定義ファイルの指定例（formdef02（複数様式帳票例２）.txt）を示します。

group 1 {               …「従業員勤務歴カード［I］」と，
                          「従業員勤務歴カード［I］（続き）」の
                          様式グループです
 grouptransfercondition {
    transfercondition=KBNF      …二つの様式は，
                                  フィールド「従業員番号」が
                                  キーブレイクしたら，
                                  様式を切り替えます
    fieldname="従業員番号"
 }
 formfilename "従業員勤務歴１（複数様式帳票例２）.fms" {
   transfercondition=NPNF   …従業員勤務歴１が出力されると
                              次紙に移ります
                              次紙を出力しないで済む場合は
                              group 2の従業員勤務歴２に移ります
   printnewpaper=OFF  ※
   resetpagenumber=ON        …従業員勤務歴１を出力するときは，
                               ページ番号を初期化します
 }
 formfilename "従業員勤務歴１－次紙（複数様式帳票例２）.fms" {
   transfercondition=KBNF      …フィールド「従業員番号」が
                                 キーブレイクしたら，
                                 従業員勤務歴２に移ります
   printnewpaper=OFF
   resetpagenumber=OFF       …従業員勤務歴１からの
                               続きのページ番号を出力します
 }
}
group 2 {                   …「従業員勤務歴カード［II］」の
                              様式グループです
 grouptransfercondition {
    transfercondition=KBNF   …フィールド「従業員番号」が
                               キーブレイクしたら，group 1の
                               従業員勤務歴１に戻ります
    fieldname="従業員番号"
 }
 formfilename "従業員勤務歴２（複数様式帳票例２）.fms" {
   transfercondition=KBNF
   printnewpaper=OFF
   resetpagenumber=OFF     …従業員勤務歴１，または次紙からの
                             続きのページ番号を出力します
 }
}
注※
両面印刷する場合，「従業員勤務歴カード［I］」を表面に印刷したいときは，次のように指定してください。
printnewpaper = ON

(3)　サンプル帳票「保険申込書」の場合

複数様式のサンプル帳票「保険申込書」を出力するときに指定する，サンプル複数様式情報定義ファイル（formdef03（複数様式帳票例３）.txt）の指定例を示します。

group 1 {
 formfilename "保険申込書（複数様式帳票例３）.fms" {
   transfercondition=KBNF     …キーブレイクしたら，
                                group 2の代理店控に移ります
   printnewpaper=OFF
   resetpagenumber=ON        …保険申込書を出力するときは，
                               ページ番号を初期化します
 }
}
group 2 {
 formfilename "保険申込書＿代理店控（複数様式帳票例３）.fms" {
   transfercondition=KBNF      …キーブレイクしたら，
                                 group 3の契約者控に移ります
   printnewpaper=OFF
   resetpagenumber=OFF     …前の様式からの続きのページ番号を
                             出力します
 }
}
group 3 {
 formfilename "保険申込書＿契約者控（複数様式帳票例３）.fms" {
   transfercondition=KBNF     …キーブレイクしたら，
                                group 1の保険申込書に戻ります
   printnewpaper=OFF
   resetpagenumber=OFF     …前の様式からの続きのページ番号を
                             出力します
 }
}

(4)　給紙トレイ番号を指定した場合

帳票「給与台帳」を出力するとき，フィールド「所属」がキーブレイクしたら，給紙トレイ番号10の仕分け紙を挿入する，複数様式情報定義ファイルの指定例を示します。

給紙トレイ番号を指定するときは，仕分け紙用のフォームシートファイルとデータが必要です。

group 1 {
 formfilename "仕分け紙.fms" {
   transfercondition=KBNF      …キーブレイクしたら，
                                 group 2の処理に移ります
   printnewpaper=OFF
   resetpagenumber=OFF
   traycode=10                 …仕分け紙をトレイ番号10から，
                                給紙します
 }
}
group 2 {
 formfilename "給与台帳.fms" {
   transfercondition=KBNF     …キーブレイクしたら，
                                group 1の処理に戻ります
   printnewpaper=OFF
   resetpagenumber=OFF
 }
}

(5)　サブ様式グループを指定した場合

サブ様式グループを指定した複数様式の帳票を出力するときに指定する，複数様式情報定義ファイルの指定例を示します。

group 1 {             …「sample1」の様式グループです
   grouptransfercondition {
       transfercondition=KBNF     …フィールド「A」がキーブレイクしたら，
                                    様式を切り替えます
       fieldname="A"
   }
   formfilename "sample1.fms" {
       transfercondition=NPNF        …sample1が出力されると
                                       subgroup 1のsample2に移ります
       printnewpaper=OFF
       resetpagenumber=ON     …sample1を出力するときは，
                                ページ番号を初期化します
   }
}
group 2 {             …「sample2」と「sample3」の様式グループです
   grouptransfercondition {
       transfercondition=KBNF     …フィールド「A」がキーブレイクしたら，
                                    group 1のsample1に戻ります。
       fieldname="A"
   }
   subgroup 1 {       …「sample2」のサブ様式グループです
       grouptransfercondition {
           transfercondition=KBNF    …フィールド「B」がキーブレイクしたら，
                                       様式を切り替えます
           fieldname="B"
       }
       formfilename "sample2.fms" {
           transfercondition=NPNF     …sample2が出力されると
                                        subgroup 2のsample3に移ります
           printnewpaper=OFF
           resetpagenumber=ON     …sample2を出力するときは，
                                    ページ番号を初期化します
       }
   }
   subgroup 2 {       …「sample3」のサブ様式グループです
       grouptransfercondition {
           transfercondition=KBNF    …フィールド「B」がキーブレイクしたら，
                                        group 1のsample1に戻ります
           fieldname="B"
       }
       formfilename "sample3.fms" {
           transfercondition=NPNF
           printnewpaper=OFF
           resetpagenumber=ON     …sample3を出力するときは，
                                    ページ番号を初期化します
       }
   }
}


接続情報ファイル

5.8　接続情報ファイル

接続情報ファイルは，データベースと接続するために必要な情報を定義するファイルです。入力データをデータベースから読み込んで帳票を出力するときに，接続するデータベースの情報を接続情報ファイルに定義します。

接続情報ファイルは，一つの接続先について一つ作成します。EURの実行時には，接続情報ファイルを一つだけ指定できます。

データベースからデータを読み込んで帳票を設計するときは，ODBC Driverで設定されたデータベースに接続します。

接続情報ファイルの作成については，マニュアル「EUR データベース連携ガイド」を参照してください。


可変記号値定義ファイル

5.9　可変記号値定義ファイル

データベースから抽出したデータを使って帳票を出力したい場合は，データファイルを指定するプロパティに可変記号値定義ファイルを指定します。

可変記号値定義ファイルは，データベースからデータを検索し，条件に合ったデータを抽出するときに必要な，検索条件の可変記号とその値（可変記号値）を定義するためのファイルです。可変記号は，条件式の条件値だけを変更するときに使います。

帳票を設計したときに設定された可変記号に，可変記号値を定義することで，条件に合った抽出データで帳票を出力できます。接続情報ファイルと組み合わせて使用します。

可変記号値定義ファイルは，一つの帳票ファイルに対して，マッピングデータ用とユーザ定義データ用にそれぞれ一つずつ作成します。

可変記号値定義ファイルの作成については，マニュアル「EUR データベース連携ガイド」を参照してください。


置き換え表管理情報ファイル

5.10　置き換え表管理情報ファイル

EURでは，アイテムのデータを指定したデータに置き換えて，出力できます。

置き換え表管理情報ファイルは，帳票を設計したときに設定された置き換え表名と，置き換え表ファイルの対応を定義したファイルです。

複数の帳票出力や複数様式での帳票出力をする場合は，共通の置き換え表管理情報ファイルが使用されます。

＜この節の構成＞
5.10.1　置き換え表管理情報ファイルの作成


置き換え表管理情報ファイルの作成

5.10.1　置き換え表管理情報ファイルの作成

置き換え表管理情報ファイルは，CSV形式データで作成します。

＜この項の構成＞
(1)　置き換え表管理情報ファイルの形式
(2)　置き換え表管理情報ファイルの保存場所

(1)　置き換え表管理情報ファイルの形式

置き換え表名,置き換え表ファイル名▼
置き換え表名,置き換え表ファイル名▼
            ：
（凡例）▼：改行コードを示します
■置き換え表名
置き換え表ファイルを区別するために付けた名称を指定します。指定できる置き換え表名の数は，50個までです。同一の置き換え表名が指定された場合，最初に記述した置き換え表名が有効となり，2番目以降の記述は無視されます。
置き換え表名に，空白，コンマ（，）を使用している場合は，その文字を引用符（“）で囲んで指定してください。引用符（“）を使用している場合は，引用符（“）を続けて二つ指定してください。
■置き換え表ファイル名
置き換え表名に対応する置き換え表ファイル名を指定します。フルパス，相対パスは指定できません。ファイル名は，256文字までです。

(2)　置き換え表管理情報ファイルの保存場所

置き換え表管理情報ファイルは，任意のフォルダに保存してください。デフォルトでは，［オプション］ダイアログ－［ファイル］タブで設定されたフォルダに格納されます。


置き換え表ファイル

5.11　置き換え表ファイル

EURでは，アイテムのデータを指定したデータに置き換えて，出力できます。

置き換え表ファイルは，アイテムのデータを置き換えて出力するときに，1フィールドごとの置き換え対象のデータと，置き換えて出力するデータを定義したファイルです。

＜この節の構成＞
5.11.1　置き換え表ファイルの作成


置き換え表ファイルの作成

5.11.1　置き換え表ファイルの作成

置き換え表ファイルは，CSV形式データで作成します。

＜この項の構成＞
(1)　置き換え表ファイルの形式
(2)　置き換え表ファイルの保存場所

(1)　置き換え表ファイルの形式

キーデータ,置き換えデータ▼
キーデータ,置き換えデータ▼
            ：
（凡例）▼：改行コードを示します
■キーデータ
置き換えの対象とする文字列を指定します。指定できる文字列長は，256文字までです。同一のキーデータが指定された場合，最初に記述したキーデータが有効となり，2番目以降の記述は無視されます。
文字列に，空白，コンマ（,）を使用している場合は，その文字を引用符（"）で囲んで指定してください。引用符（"）を使用している場合は，引用符（"）を続けて二つ指定してください。
■置き換えデータ
置き換えて出力する文字列を指定します。指定できる文字列長は，256文字までです。
文字列に，空白，コンマ（,）を使用している場合は，その文字を引用符（"）で囲んで指定してください。引用符（"）を使用している場合は，引用符（"）を続けて二つ指定してください。

空データの置き換えもできます。空データは次のように指定します。

  • 空データを文字列に置き換える場合
    ,"置き換え空データ1"　　または
    "","置き換え空データ2"
  • 文字列を空データに置き換える場合
    "キーデータ1",　　または
    "キーデータ2",""

(2)　置き換え表ファイルの保存場所

置き換え表ファイルは，任意のフォルダに保存してください。デフォルトでは，［オプション］ダイアログ－［ファイル］タブで設定されたフォルダに格納されます。


オプション記述ファイル

5.12　オプション記述ファイル

印刷先プリンタ名など，EURを起動するときの起動オプションをオプション記述ファイルで指定できます。アプリケーションを配布したときなど，動作環境に応じてプリンタ名などを変更する必要がある場合に便利です。オプション記述ファイルは，テキスト形式で作成します。

オプション記述ファイルのキーワードと，記述例について説明します。

＜この節の構成＞
5.12.1　オプション記述ファイルのキーワード
5.12.2　オプション記述ファイルの記述例


オプション記述ファイルのキーワード

5.12.1　オプション記述ファイルのキーワード

オプション記述ファイルは，apgrptコマンドの実行時に入力します。COBOL言語のプログラムから印刷する場合は，CALL文でapgrptコマンドを引数として記述します。

apgrptコマンドで指定できるオプション記述ファイルのキーワード一覧を次に示します。

表5-8　オプション記述ファイルのキーワード一覧

キーワード | 印刷する場合※ |  | 表示する場合
 | 単一様式 | 複数様式 | 単一様式 | 複数様式
DBInfoFileName | ○ | ○ | ○ | ○
DBInfoFilePath | ○ | ○ | ○ | ○
FileName | ○ | △ | ○ | △
FontWidthMode | ○ | ○ | ○ | ○
ImageFilePath | ○ | ○ | ○ | ○
MappingDataFile | ○ | △ | ○ | △
MappingDataPath | ○ | ○ | ○ | ○
MultiFormInfoDefFile | × | ○ | × | ○
MultiFormInfoDefPath | × | ○ | × | ○
MultiReportSetFile | × | ○ | × | ○
MultiReportSetPath | × | ○ | × | ○
Numbering | ○ | △ | △ | △
NumberingFormat | ○ | △ | △ | △
NumberingFrom | ○ | △ | △ | △
NumberingPos | ○ | △ | △ | △
NumberingReset | ○ | △ | △ | △
PaperOrientation | ○ | △ | △ | △
PrintEndPage | ○ | △ | △ | △
PrinterName | ○ | ○ | × | ×
PrintFileName | ○ | ○ | △ | △
PrintFinishing | ○ | △ | △ | △
PrintSet | ○ | △ | △ | △
PrintStartPage | ○ | △ | △ | △
ReplaceItemCntlFile | ○ | ○ | ○ | ○
ReplaceItemCntlFilePath | ○ | ○ | ○ | ○
ReplaceItemFilePath | ○ | ○ | ○ | ○
ReportFilePath | ○ | ○ | ○ | ○
ReportTitle | ○ | ○ | ○ | ○
TrayCode | ○ | ○ | △ | △
TraySelection | ○ | ○ | △ | △
UserDefDataFile | ○ | △ | ○ | △
UserDefDataPath | ○ | ○ | ○ | ○
WindowStyle | ○ | ○ | ○ | ○
ZoomRate | ○ | ○ | ○ | ○
（凡例）
○：指定できます
△：指定しても無効です
×：指定できません
注※
apgrptコマンドで/pオプションが指定されたとき，またはオプション記述ファイル（apgrptコマンドの/kオプション）でキーワードにPrinterNameが指定されたときのどちらかの場合です。

＜この項の構成＞
(1)　帳票の出力先の指定
(2)　帳票ファイル名の指定
(3)　EUR起動時のウィンドウの指定
(4)　ズーム倍率の指定
(5)　用紙の向きの指定
(6)　マッピングデータ用のファイルの指定
(7)　ユーザ定義データ用のファイルの指定
(8)　接続情報ファイルの指定
(9)　ファイルのパス指定
(10)　印刷ページの選択
(11)　ページ番号の印刷指定
(12)　給紙トレイの指定
(13)　出力先での帳票名表示の指定
(14)　複数様式での帳票出力の指定
(15)　置き換え表管理情報ファイル名の指定
(16)　固定ピッチフォントの文字幅計算方法の指定

(1)　帳票の出力先の指定

帳票を印刷するときの出力先を指定します。

(a)　PrinterName

帳票を即時印刷実行する場合，帳票を印刷するプリンタを指定します。半角空白を含むプリンタ名を指定する場合は，プリンタ名を「"」で囲んでください。半角空白を含むプリンタ名を「"」で囲まないで指定した場合は，エラーになります。プリンタ名を省略した場合は，Windows上で，通常使うプリンタとして指定してあるプリンタに印刷されます。帳票ファイル名を省略した場合は，指定を無視します。

(b)　PrintFileName

帳票をプリンタに出力する代わりに，指定されたドライブの新規ファイルへ出力します。印刷出力ファイル名は，ドライブ名とフォルダ名を含むフルパスで指定します。フルパスで指定しない場合は，EURのインストール先フォルダからの相対パスが仮定されます。

このオプションを指定した場合は，プリンタがどの出力ポートを選択していても，指定したファイルに出力されます。

(2)　帳票ファイル名の指定

(a)　FileName

レポートファイル名（*.agr）またはフォームシートファイル名（*.fms）を指定します。

複数様式で帳票を出力する場合は，「FileName」の指定は無効になります。

(3)　EUR起動時のウィンドウの指定

(a)　WindowStyle

EURを起動したときに表示するウィンドウを指定します。省略した場合は，editが仮定されます。

指定値 | 説 明
edit | レポート編集ウィンドウが表示されます。
view | レポート確認ウィンドウが表示されます。
print | レポート印刷ウィンドウが表示されます。
  • レポート編集ウィンドウ
    レポート編集ウィンドウは，帳票ファイル名を指定しないで起動した場合，帳票ウィンドウを「重ねて表示」実行時のウィンドウの位置，ウィンドウサイズで最前面に表示し，その後ろにマッピングデータウィンドウを表示します。ユーザ定義データウィンドウは表示されていません。既存の帳票ファイル名を指定して起動した場合は，前回レポート編集ウィンドウでEURを終了したときのウィンドウの位置，ウィンドウサイズで，帳票ウィンドウ，マッピングデータウィンドウ，およびユーザ定義データウィンドウが表示されます。
  • レポート確認ウィンドウ
    レポート確認ウィンドウは，メインウィンドウに帳票ウィンドウを最前面かつ最大表示します。マッピングデータウィンドウとユーザ定義データウィンドウは表示されません。レポート確認ウィンドウでは，帳票の編集はできませんが，ほかの帳票を開いたり，印刷したりできます。
  • レポート印刷ウィンドウ
    レポート印刷ウィンドウは，メインウィンドウに帳票ウィンドウを最前面かつ最大表示します。マッピングデータウィンドウとユーザ定義データウィンドウは表示されません。レポート印刷ウィンドウでは，帳票の編集をしたり，ほかの帳票を開いたりできません。

(4)　ズーム倍率の指定

(a)　ZoomRate

EURを起動したときに，レポート編集ウィンドウ，またはレポート確認ウィンドウに表示する帳票の表示倍率を指定します。指定できる値は，標準のサイズを100とした百分率で10～800です。また，「as」を指定すると，帳票全体が帳票ウィンドウに入る大きさで表示されます。省略した場合は，標準のサイズ（100）が仮定されます。

(5)　用紙の向きの指定

(a)　PaperOrientation

印刷するときの用紙の向きを指定します。「PrinterName」を省略した場合，この指定は無視されます。複数様式で帳票を出力する場合は，「PaperOrientation」の指定は無効になります。

指定値 | 説 明
portrait | 用紙の向きを縦にします。
landscape | 用紙の向きを横にします。

省略した場合は，帳票を定義したときの設定に従います。ここで指定された値が帳票定義時の属性と異なる場合は，帳票の一部が印刷されない場合があります。次にオプション指定の印刷結果の例を示します。

図5-14　A4縦向きの帳票をA4用紙に印刷した場合

図5-15　A4横向きの帳票をA4用紙に印刷した場合

(6)　マッピングデータ用のファイルの指定

帳票定義するときのマッピングデータ（帳票の表部分の入力データ）の入力ファイルを変更する場合に指定します。ファイルのパスを含めて指定することもできます。

(a)　MappingDataFile

マッピングデータ用のデータファイル，または可変記号値定義ファイルの名称を指定します。省略した場合は，帳票定義時に指定されたデータファイルを仮定します。仮定したデータファイルがない場合は，帳票上に定義された文字列，罫線，図形および画像だけを印刷します。

複数様式で帳票を出力する場合は，「MappingDataFile」の指定は無効になります。

(7)　ユーザ定義データ用のファイルの指定

帳票を定義するときのユーザ定義データ（帳票を定義するときのユーザ定義データウィンドウの入力データ）の入力ファイルを変更する場合に指定します。ファイルのパスを含めて指定することもできます。

(a)　UserDefDataFile

ユーザ定義データ用のデータファイル，または可変記号値定義ファイルの名称を指定します。省略した場合は，帳票定義時に指定されたデータファイルを仮定します。仮定したデータファイルがない場合は，帳票上に定義された文字列，罫線，および図形だけを印刷します。

複数様式で帳票を出力する場合は，「UserDefDataFile」の指定は無効になります。

(8)　接続情報ファイルの指定

(a)　DBInfoFileName

接続情報ファイル名を指定します。接続情報ファイル名は，フルパス，相対パス，またはファイル名だけのどれかで指定してください。ファイル名をフルパスで指定しなかった場合は，次に示す順にファイルを検索します。

  • 「DBInfoFilePath」に指定されているフォルダ
  • ［オプション］ダイアログの［ファイル］タブで，「接続情報ファイル」に指定されているフォルダ

(9)　ファイルのパス指定

定義した帳票を配布した先の環境（ファイルのパス）が，帳票を定義した環境と異なる場合，このオプションでファイルのパスを指定します。

(a)　ReportFilePath

帳票ファイル（レポートファイル，またはフォームシートファイル）のある場所を指定します。

(b)　ImageFilePath

画像データファイルのある場所を指定します。

(c)　MappingDataPath

マッピングデータ用のファイルのある場所を指定します。

(d)　UserDefDataPath

ユーザ定義データ用のファイルのある場所を指定します。

(e)　MultiReportSetPath

帳票セット指定ファイルのある場所を指定します。

(f)　MultiFormInfoDefPath

複数様式情報定義ファイルのある場所を指定します。

(g)　DBInfoFilePath

接続情報ファイルのある場所を指定します。指定されたフォルダは，「DBInfoFileName」で指定するファイルのデフォルトになります。

(h)　ReplaceItemCntlFilePath

置き換え表ファイルを管理している置き換え表管理情報ファイルのある場所を指定します。

(i)　ReplaceItemFilePath

置き換え表ファイルのある場所を指定します。

(10)　印刷ページの選択

ページ番号，および印刷部数を指定します。このオプション記述ファイルのキーワードは，「PrinterName」が指定されているとき，有効になります。

(a)　PrintStartPage

ページ番号を印刷するときの印刷開始ページを指定します。開始ページに指定できる値は，1以上の整数です。省略した場合は，前回印刷したときに指定したページが仮定されます。初期値は，「1」です。

「PrintEndPage」よりも大きい値を指定した場合は，エラーになります。

複数様式で帳票を出力する場合は，「PrintStartPage」の指定は無効になり，印刷開始ページは「1」です。

(b)　PrintEndPage

ページ番号を印刷するときの印刷終了ページを指定します。終了ページに指定できる値は，1～32,767です。省略した場合は，帳票の全ぺーシを印刷します。終了ページに，実際にない大きなページ数を指定した場合，帳票の最大ページまでが印刷されます。

複数様式で帳票を出力する場合は，「PrintEndPage」の指定は無効になり，終了ページまで印刷されます。

(c)　PrintSet

帳票を印刷する印刷部数を指定します。指定できる値は，1～99です。省略した場合は，「1」が仮定されます。

複数様式で帳票を出力する場合は，「PrintSet」の指定は無効になり，印刷部数は「1」です。

なお，［印刷］ダイアログから印刷する場合は，出力先のプリンタに部数指定の機能があるかどうかによって，次のように異なります。

  • 部数指定の機能があるとき
    ［印刷］ダイアログで印刷部数を指定できます。
  • 部数指定の機能がないとき
    ［印刷］ダイアログの印刷部数は淡色表示になり指定できません。1部印刷されます。
(d)　PrintFinishing

帳票を2部以上印刷する場合，部単位で印刷するか，またはページ単位で印刷するかを，次に示す値で指定します。省略した場合は，「sort」が仮定されます。

指定値 | 説 明
sort | 部単位で印刷します。
stack | ページ単位で印刷します。

複数様式で帳票を出力する場合は，「PrintSet」の指定は無効になり，印刷部数が「1」になります。そのため，「PrintFinishing」の指定も無効になります。

(11)　ページ番号の印刷指定

余白へのページ番号の印刷についての情報を指定します。このオプション記述ファイルのキーワードは，「PrinterName」が指定されているとき，有効になります。

(a)　Numbering

余白へのページ番号を印刷するかしないかを指定します。初期値は，「off」です。

指定値 | 説 明
on | ページ番号を印刷します。
off | ページ番号を印刷しません。

複数様式で帳票を出力する場合は，「Numbering」を指定しても無効になります。

余白へのページ番号は，［用紙の設定］ダイアログの［余白］で設定した領域に印刷されます。余白へのページ番号を出力する場合は，プリンタのハードマージンに掛からないように，用紙の余白は余裕を持って設定してください。

(b)　NumberingPos

ページ番号を余白に印刷するときの印刷位置を，次に示す値で指定します。「Numbering」を省略した場合は，この指定は無視されます。

初期値は，「btmc」です。

指定値 | 説 明
topr | ページ番号が右上に印刷されます。
topc | ページ番号が中央上に印刷されます。
topl | ページ番号が左上に印刷されます。
btmr | ページ番号が右下に印刷されます。
btmc | ページ番号が中央下に印刷されます。
btml | ページ番号が左下に印刷されます。

複数様式で帳票を出力する場合は，「Numbering」と「NumberingPos」を指定しても無効になります。

(c)　NumberingFormat

ページ番号の形式を指定します。ページ番号を「*」，最終ページ番号を「$」で示して印刷形式を指定します。ページ番号および最終ページ番号を全角で表示したいときは全角の記号で，半角で表示したいときは半角の記号で指定します。「Numbering」を省略した場合は，この指定は無視されます。

表5-9　NumberingFormatキーワードの指定値とその出力結果

指定した形式 | 出力結果
* | 1
-*- | -1-
-*/$- | -1/5-
(*) | (1)

複数様式で帳票を出力する場合は，「Numbering」と「NumberingFormat」を指定しても無効になります。

(d)　NumberingFrom

ページ番号の初期値を指定します。初期値として指定できる値は，1～32,767です。*/$の印刷形式の場合でも，指定できます。

複数様式で帳票を出力する場合は，「NumberingFrom」の指定は無効になります。

(e)　NumberingReset

改ページのキーが指定されている場合，そのキーがブレイクするごとにページ番号の開始番号を初期化（NumberingFromの値）するかしないかを指定します。省略した場合は，帳票の属性に従います。初期値は，「normal」です。

指定値 | 説 明
reset | 初期化します。
normal | 初期化しません。ページ番号の形式の「$」は，全体のページになります。

複数様式で帳票を出力する場合は，「NumberingReset」の指定は無効になり，「MultiFormInfoDefFile」の指定が有効になります。

注意
改ページを設定している帳票では，このオプション記述ファイルで指定するページ番号と帳票上に配置したページ番号アイテムには，ページ番号の初期化について次のような関係を持っています。
  • オプション記述ファイルで「NumberingReset」を指定しないと，ページ番号アイテムの形式にn/m形式，またはそれ以外の形式を設定しても，余白のページ番号は初期化されません。
  • オプション記述ファイルで「NumberingReset」に「reset」を指定すると，ページ番号アイテムのページ番号も初期化されます。n/m形式でない場合も，初期化されます。
  • ［アイテムのプロパティ］ダイアログの［表示形式（ページ番号）］タブで，［バージョン3形式］が選択されている場合は，「NumberingReset」の指定は無視されます。

(12)　給紙トレイの指定

給紙トレイを指定します。このオプション記述ファイルのキーワードは，「PrinterName」が指定されているとき，有効になります。

(a)　TraySelection

給紙トレイ選択機能を使用するかどうかを指定します。省略した場合は，「0（給紙トレイ選択機能を使わない）」が仮定されます。

指定値 | 説 明
0 | 給紙トレイ選択機能を使いません。出力先プリンタのデフォルトのトレイに印刷されます。
1 | 給紙トレイ選択機能を使います。ただし，「TrayCode」で指定されたコードが，出力先プリンタにない場合は，エラーになります。
2 | 給紙トレイ選択機能を使います。ただし，「TrayCode」で指定されたコードが，出力先プリンタにない場合は，プリンタの既存値で印刷されます。
(b)　TrayCode

「TraySelection」を指定して給紙トレイ選択機能を使用する場合，このオプションでプリンタの給紙トレイコードを指定します。省略した場合は，給紙トレイコード「1」が仮定されます。指定した値が，プリンタによって使用できない場合は，「TraySelection」の指定に従って処理されます。「TraySelection」を省略した場合は，この指定は無視されます。

Windowsで規定されている，給紙トレイコードを次に示します。給紙トレイコードの256以上は，各デバイス固有コードを割り当てられます。

表5-10　給紙トレイコード一覧（Windows規定に準ずる）

給紙トレイ（対象給紙装置） | 給紙トレイコード
上段用紙トレイ | 1
単一給紙ソース | 1
下段用紙トレイ | 2
中段用紙トレイ | 3
手差し用紙フィーダ | 4
封筒フィーダ | 5
手差し封筒フィーダ | 6
用紙サイズを基に自動的に給紙装置を選択 | 7
トラクタフィーダ | 8
小型用紙ソース | 9
大型用紙ソース | 10
大容量用紙トレイ | 11
用紙カセット | 14

給紙トレイコードを指定するとき，プリンタの製造会社や機種によって，Windowsで規定されている給紙トレイコードと異なる場合があります。また，Windowsで規定されている給紙トレイコードであっても，プリンタドライバによって，給紙トレイ名と給紙トレイコードを独自に割り当てていると，期待したトレイから給紙されない場合があります。この場合，出力先プリンタに対応した給紙トレイコードを，EURで提供している［給紙トレイ一覧］ツールで確認してください。

［給紙トレイ一覧］ダイアログでは，出力先プリンタをリストボックスから選択すると，そのプリンタの給紙トレイ名と，対応する給紙トレイコードの一覧が表示されます。

表示された給紙トレイコードを指定することで，期待したトレイから給紙できます。

［給紙トレイ一覧］ツールの実行ファイル「Eurtyl.exe」は，次に示すフォルダにあります。

  • EUR Designerの場合
    EUR Designerのインストール先フォルダ\Designer\Program\Eurtyl.exe
  • EUR Viewerの場合
    EUR Viewerのインストール先フォルダ\Program\Eurtyl.exe

(13)　出力先での帳票名表示の指定

(a)　ReportTitle

プリンタの印刷待ち状態を確認する一覧ウィンドウの「ドキュメント名」，およびタイトルバーに表示する帳票名を「"」で囲んで指定します。ReportTitleオプションの指定がなければ，「HITACHI Report - 帳票ファイル名」が表示されます。

帳票名は，255文字までの文字列で指定します。指定された帳票名が255文字を超えた場合は，255文字までを帳票名とします。

(14)　複数様式での帳票出力の指定

(a)　MultiReportSetFile

帳票セット指定ファイル名を指定します。帳票セット指定ファイルは，複数の帳票ファイルを統合する順番と帳票に読み込むデータファイルを指定しておくファイルです。

帳票セット指定ファイルについては，「5.6　帳票セット指定ファイル」を参照してください。

(b)　MultiFormInfoDefFile

複数様式情報定義ファイル名を指定します。複数様式情報定義ファイルは，様式（帳票フォーマット）や読み込むデータを切り替える条件と，切り替え時の動作を定義しておくファイルです。

複数様式情報定義ファイルについては，「5.7　複数様式情報定義ファイル」を参照してください。

(15)　置き換え表管理情報ファイル名の指定

(a)　ReplaceItemCntlFile

置き換え表管理情報ファイル名を指定します。置き換え表管理情報ファイルは，表示データの置き換え表ファイルを管理するファイルです。置き換え表管理情報ファイルについては，「5.10　置き換え表管理情報ファイル」を参照してください。

(16)　固定ピッチフォントの文字幅計算方法の指定

(a)　FontWidthMode

固定ピッチフォントの文字幅計算方法を指定します。EUR 帳票作成機能での固定ピッチフォントの文字幅計算方法の詳細については，マニュアル「EUR 帳票作成 操作ガイド」を参照してください。EUR サーバ帳票出力機能での固定ピッチフォントの文字幅計算方法の詳細については，マニュアル「EUR システム設計ガイド」を参照してください。

指定値は次のとおりです。指定を省略した場合は，帳票ウィンドウの［オプション］ダイアログの［表示］タブにある，［文字幅計算方法］グループボックスの設定値が適用されます。

指定値 | 説 明
static | 固定ピッチフォントの文字幅は固定値になります。 半角文字はアイテムのフォント幅，全角文字はアイテムのフォント幅の2倍になります。
dynamic | 固定ピッチフォントの文字幅は，使用するフォントに合わせて決定されます。


オプション記述ファイルの記述例

5.12.2　オプション記述ファイルの記述例

オプション記述ファイルは，セクションとエントリで構成されます。先頭行の［Hitachi EUR］は，固定です。

[Hitachi EUR]         /* セクション名 */
FileName=c:\eur\sample\report\table.agr
MappingDataFile=table.dat
UserDefDataFile=vartable.dat
ReportFilePath=c:\eur_rpt
MappingDataPath=c:\eur_map
UserDefDataPath=c:\eur_udf
ImageFilePath=c:\eur_img
WindowStyle=edit
PrinterName="Printer name"
PrintFileName=c:\eur\print\file1
Numbering=on
NumberingPos=btmc
NumberingFormat="- * -"
NumberingFrom=2
PrintStartPage=1
PrintEndPage=15
PrintSet=10
PrintFinishing=sort
NumberingReset=reset
PaperOrientation=portrait
ZoomRate=as
TraySelection=2
TrayCode=1
ReportTitle="請求書No.012-3456"
MultiReportSetPath=c:\eur\multireport
MultiReportSetFile=reportset.txt
MultiFormInfoDefPath=c:\eur\multiform
MultiFormInfoDefFile=multiform.txt
DBInfoFileName=dbinfo.txt
DBInfoFilePath=c:\eur\database
ReplaceItemCntlFile=c:\eur_rif\okikae.csv
ReplaceItemCntlFilePath=c:\eur_rif
ReplaceItemFilePath=c:\eur_rif
FontWidthMode=dynamic
注意
  • マッピングデータ用/ユーザ定義データ用のファイルがない場合は，帳票上に定義された文字列，罫線，および図形だけを印刷します。


環境設定ファイル

5.13　環境設定ファイル

環境設定ファイルを使用して，EURの環境変数を設定できます。環境設定ファイルにはWindowsの環境変数は設定できません。

環境設定ファイルは，メモ帳などのテキストエディタを開いて作成したあと，次のどちらかの方法で保存してください。

  • 規定の環境設定ファイル名で保存する場合
    環境設定ファイル名「EUR_ENV」で，次に示すフォルダに保存してください。
    • EUR Designerの場合
      EUR Designerのインストール先フォルダ\Designer
    • EUR Viewerの場合
      EUR Viewerのインストール先フォルダ
  • 任意のファイル名で任意のフォルダに保存する場合
    環境変数EUR_ENVFILEに，環境設定ファイル名をフルパスまたは相対パスで指定してください。例えば，環境設定ファイルを複数作成しておき，実行する業務ごとに環境変数EUR_ENVFILEの設定内容を切り替える運用ができます。
    環境変数EUR_ENVFILEに環境設定ファイル名を指定した場合は，インストール先フォルダ下の環境設定ファイルは使用されません。

なお，同じ内容を複数の環境設定ファイルや環境変数で設定した場合，次の優先順位で設定内容が適用されます。

  1. 環境変数EUR_ENVFILEに指定した環境設定ファイルの内容
  2. 環境変数の内容
  3. インストールパスの環境設定ファイルの内容

ただし，環境設定ファイルで指定できない変数は，環境変数で直接指定します。環境設定ファイルで指定できない変数については，「5.13.4　環境設定ファイルに設定できない変数」を参照してください。

＜この節の構成＞
5.13.1　環境設定ファイルの構文
5.13.2　環境設定ファイルの変数
5.13.3　環境設定ファイルの指定例
5.13.4　環境設定ファイルに設定できない変数


環境設定ファイルの構文

5.13.1　環境設定ファイルの構文

変数名=値
構文を設定するとき，環境設定ファイルに指定する変数名，および値は，「"」で囲まないでください。
同じ環境変数は複数指定できません。複数指定した場合は，あとに指定した環境変数が有効となります。


環境設定ファイルの変数

5.13.2　環境設定ファイルの変数

＜この項の構成＞
(1)　EUR_TMPPATH
(2)　EUR_CODE128_PARAM
(3)　EUR_FONT_ROUNDDOWN
(4)　EUR_UPC_BARCODE

(1)　EUR_TMPPATH

データベースと連携して帳票を出力するときに作成される，一時ファイルの出力先フォルダを指定します。

環境設定ファイルにEUR_TMPPATHが設定されていない場合は，［オプション］ダイアログの［ファイル］タブで設定されているフォルダを検索します。

(2)　EUR_CODE128_PARAM

CODE128バーコードのバーの幅を調整します。次に示す形式で指定します。

type 〔,〔Param1〕,〔Param2〕〕

環境変数EUR_CODE128_PARAMとプリンタ定義ファイルのキーワードCODE128PARAMが同時に指定された場合は，プリンタ定義ファイルの指定が有効になります。

type
バーコードの描画方式を指定します。
指定値 | 説明
0 | ミリメートル（mm）で指定したモジュールサイズからバーキャラクタサイズを計算します。モジュールサイズ×11（mm）を超えないドット数でバーキャラクタを描画します。ストップキャラクタは，モジュールサイズ×13（mm）を超えないドット数で描画します。1を指定した場合と比べて，サイズを細かく指定できますが，バーコードの質は落ちます。
1 | ミリメートル（mm）で指定したモジュールサイズを超えないドット数を求め，その11倍をバーキャラクタのサイズにします。1ドットの大きさを超えるまではバーコードの大きさは変わりません。プリンタ解像度によって補正するドット数が変わります。
2 1を指定した場合の計算方法に加えて，Param1で指定した幅に相当するドット数分だけ黒バーを細く，白バーを太くします。
Param2を指定した場合は，Param1で指定した値で補正した状態のスタートキャラクタとストップキャラクタにParam2で指定した値でさらに補正します。
省略した場合，または0，1，2以外の値を指定した場合は，0が仮定されます。指定値が0の場合，Param1，およびParam2に指定した値は無視されます。
Param1
typeに2を指定した場合，バーを調整する幅をミリメートルで指定します。指定した値をドット単位に変換した計算値の小数第一位を四捨五入した値が補正されます。補正するドット数の計算結果が1以上の場合だけ補正されます。
Param1に指定した値をドット単位に変換する計算式を次に示します。
計算値（ドット） = Param1に指定する値 ÷ 25.4 ×解像度（dpi）
解像度300dpiの場合，補正するドット数の計算結果を次に示します。

表5-11　解像度300dpiの場合に補正するドット数

Param1またはParam2に指定する値（ミリメートル） | 補正するドット数（ドット） | 計算値（ドット）
0.04 | 0 | 0.472441
0.041 | 0 | 0.484252
0.042 | 0 | 0.496063
0.043 | 1 | 0.507874
0.044 | 1 | 0.519685
0.045 | 1 | 0.531496
0.046 | 1 | 0.543307
解像度600dpiの場合，補正するドット数の計算結果を次に示します。

表5-12　解像度600dpiの場合に補正するドット数

Param1またはParam2に指定する値（ミリメートル） | 補正するドット数（ドット） | 計算値（ドット）
0.02 | 0 | 0.472441
0.021 | 0 | 0.496063
0.022 | 1 | 0.519685
0.023 | 1 | 0.543307
0.024 | 1 | 0.566929
0.025 | 1 | 0.590551
0.026 | 1 | 0.614173
Param2
typeに2を指定した場合，Param1で指定した値で補正したスタートキャラクタとストップキャラクタを調整する幅をミリメートルで指定します。指定した値をドット単位に変換した計算値の小数第一位を四捨五入した値が補正されます。補正するドット数の計算結果が1以上の場合だけ補正されます。Param2に指定した値をドット単位に変換する計算式はParam1の場合と同じです。
解像度別の補正するドット数については，Param1の表を参照してください。
注意
  • バーの幅を超える値を指定した場合は，バーの幅を1ドットに設定します。
  • typeに1を指定した場合でも，Param1に数値を指定して，Param2を省略したときは0が仮定されます。
  • typeに2を指定した場合でも，次のときは0が仮定されます。
    ・Param1を指定しなかったとき
    ・Param1が数値以外，または0以下だったとき
  • typeに2を指定した場合でも，Param1に0より大きい値，Param2に0以下の値を指定したときは，Param2は無視されます。

(3)　EUR_FONT_ROUNDDOWN

帳票印刷時に使用する文字のサイズについて，帳票設計時に指定された数値の小数部を切り捨てて印刷するかどうかを次に示す形式で指定します。

EUR_FONT_ROUNDDOWN =｛YES｜NO｝

指定できる値は次のとおりです。

指定値 | 説明
YES | 帳票設計時に指定された数値の小数部を切り捨てたフォントサイズで印刷します。文字間隔は，帳票設計時のフォントサイズで印刷した場合と変わりません。
NO | 帳票設計時に指定された数値のフォントサイズを使用して印刷します。

EUR_FONT_ROUNDDOWNを指定しない場合は，NOが仮定されます。

(4)　EUR_UPC_BARCODE

UPCバーコードの出力を有効にするかどうかを次に示す形式で指定します。

EUR_UPC_BARCODE =｛ENABLE｜DISABLE｝

指定できる値は次のとおりです。

指定値 | 説明
ENABLE | UPCバーコードの出力を有効にします。
DISABLE | UPCバーコードの出力を無効にします。

EUR_UPC_BARCODEを指定しない場合は，ENABLEが仮定されます。

注意
JAN短縮バーコードに「0」で始まるデータを指定する場合は，EUR_UPC_BARCODEに「DISABLE」を設定してください。


環境設定ファイルの指定例

5.13.3　環境設定ファイルの指定例

環境設定ファイルの指定例を次に示します。

EUR_TMPPATH=C:\EURTMP
EUR_CODE128_PARAM=2,0.04,0.04
EUR_FONT_ROUNDDOWN=YES
EUR_UPC_BARCODE=DISABLE


環境設定ファイルに設定できない変数

5.13.4　環境設定ファイルに設定できない変数

環境設定ファイルで設定できない変数は，環境変数で直接指定します。環境設定ファイルで設定できない変数は次のとおりです。

＜この項の構成＞
(1)　EUR_FIXOPT
(2)　EUR_ENVFILE

(1)　EUR_FIXOPT

データファイルがFIX形式の場合，バイト数で区切るか桁数で区切るかを指定します。

指定できる値は次のとおりです。

指定値 | 説明
BYTE | 区切り位置をバイトで区切ります。
COLUMN | 区切り位置を桁で区切ります。

指定するパラメタの文字列は，大文字，小文字を区別しません。

EUR_FIXOPTの指定を省略した場合は，BYTEが仮定されます。

データファイルがUTF-16の場合，区切り位置情報をバイトで出力します。ただし，環境変数EUR_FIXOPTにCOLUMNが指定されると，バージョン05-06以前に作成されたフォームシートと同じように，フォームシートの区切り位置情報を桁で出力します。また，フォームシートに設定されている区切り位置の情報には桁が設定されます。

(2)　EUR_ENVFILE

環境設定ファイル名を次に示す形式で指定します。

EUR_ENVFILE=環境設定ファイル名
環境設定ファイル名
環境設定ファイル名を指定します。
なお，同じ内容を複数の環境設定ファイルや環境変数で設定した場合，次の優先順位で設定内容が適用されます。
  1. 環境変数EUR_ENVFILEで指定した環境設定ファイルの内容
  2. 環境変数で指定した内容
  3. インストール先フォルダ直下の環境設定ファイルで指定した内容
環境変数EUR_ENVFILEに指定されたファイルが入力できない場合は，2.以降の優先順位の設定内容が適用されます。


帳票出力の互換性

6.　帳票出力の互換性

この章では，帳票出力での互換性について説明します。

＜この章の構成＞
6.1　帳票を出力する場合の注意事項
6.2　コマンド構文の互換性


帳票を出力する場合の注意事項

6.1　帳票を出力する場合の注意事項

EURで帳票出力する場合の注意事項を説明します。

＜この節の構成＞
6.1.1　レポートファイル（*.agr）の扱い
6.1.2　OLE埋め込みオブジェクトが貼り付けられたフォームシートファイルの扱い
6.1.3　データベース連携での帳票出力インターフェース
6.1.4　ディクショナリファイルの扱い


レポートファイル（*.agr）の扱い

6.1.1　レポートファイル（*.agr）の扱い

バージョン5以降のEURで保存できる帳票ファイルの種類は，「フォームシートファイル（.fms）」だけです。既存のレポートファイルは，表示したり，印刷したりできますが，上書き保存はできません。レポートファイルを開いた時は，同じファイル種別で保存できないことを示すメッセージが表示されます。また，データベースからデータを読み込んで設計された帳票は，「レポートファイル（*.agr）」で保存すると，次回開いた時に保存されたデータも表示されていましたが，バージョン5以降は，データを表示できません。帳票を開くと，サンプルデータで表示されます。

データベースからデータを読み込んで設計された帳票にデータを表示したい場合は，次のように操作し直してください。

この操作は，帳票を開くたびに行ってください。

  1. データベースからデータを読み込んで設計された帳票を開きます。
  2. データベースアクセス定義ウィンドウを開きます。
    ［データソースの選択］ダイアログに設定するデータソースは，接続が設定されているデータソースを選択してください。
    データベースアクセス定義ウィンドウは開くだけです。操作したり，定義したりしないでください。
  3. ［OK］ボタンをクリックします。
    帳票に貼り付けられていたマッピングアイテムにデータが表示されます。
＜この項の構成＞
(1)　データありのレポートファイル（*.agr）の扱い

(1)　データありのレポートファイル（*.agr）の扱い

バージョン5以降のEURでは，レポートファイルを開いた時，レポートファイルと一緒に保存されているデータは，表示できません。サンプルデータで出力されます。


OLE埋め込みオブジェクトが貼り付けられたフォームシートファイルの扱い

6.1.2　OLE埋め込みオブジェクトが貼り付けられたフォームシートファイルの扱い

バージョン5以降のEURでは，画像やExcelで作成したグラフをOLE埋め込みオブジェクトとして帳票に貼り付けられません。また，バージョン4以前で作成したOLE埋め込みオブジェクトが貼り付けられたレポートファイルを開いても，OLE埋め込みオブジェクトは，表示も印刷もできません。

OLE埋め込みオブジェクトが貼り付けられた帳票を表示したい場合は，次のように対処してください。対処は，OLE埋め込みオブジェクトを代用する場合も有効です。

OLE埋め込みオブジェクトとしていた対象物 | 対 処
画像 | EURの画像アイテムとして帳票に貼り付けます。
Excelのグラフ | サードパーティの製品で，作成したグラフを画像ファイルに保存したあと，EURの画像アイテムとして帳票に貼り付けます。


データベース連携での帳票出力インターフェース

6.1.3　データベース連携での帳票出力インターフェース

データベース連携で帳票を出力する場合のインターフェースが，次のように変わりました。

バージョン3，またはバージョン4 | バージョン5，またはバージョン7
クエリファイル ※，またはクエリ情報（データソース名，接続文字列，SQL文）を指定して実行します。 | 接続情報ファイルと可変記号値定義ファイルを指定して実行します。
注※
レポートファイル（*.agr）に保存されたクエリファイルも含まれます。

インターフェースの変更に伴い，UAPで使用していたオプション記述ファイルのキーワード，およびOLEオートメーションのプロパティを変更する必要があります。変更となるキーワード一覧，およびプロパティ一覧を次に示します。

表6-1　変更となるオプション記述ファイルのキーワード一覧

バージョン3，またはバージョン4 | バージョン5，またはバージョン7
MappingQueryFile，UserDefQueryFile，MappingQueryPath，UserDefQueryPath | DBInfoFileName，UserDBInfoFileName，DBVarFileName，UserDBVarFileName，DBInfoFilePath，UserDBInfoFilePath

表6-2　変更となるOLEオートメーションのプロパティ一覧

バージョン3，またはバージョン4 |  | バージョン5，またはバージョン7
オブジェクト | プロパティ | オブジェクト | プロパティ
Application | MapQueryBasePath，UserQueryBasePath | Application | DBInfoFilePath，UserDBInfoFilePath
MappingData | ConnectString，DataSource，Query，QueryFileName | MappingData | DBInfoFileName，DBVarFileName
UserDefineData | ConnectString，DataSource，Query，QueryFileName | UserDefineData | DBInfoFileName，DBVarFileName
注
DataSourceプロパティ，およびConnectStringプロパティに相当する情報は，接続情報ファイルに記述します。
QueryFileNameプロパティに検索条件ファイルを指定していた場合は，帳票定義時にデータベースアクセス定義を使用して再定義する必要があります。定義内容はフォームシートファイルに保存されるため，帳票出力時に指定する必要はありません。
SQLの直接指定はできません。QueryプロパティでSQLを指定していた場合は，SQLに相当する内容を帳票定義時に再定義する必要があります。
ユーザが指定した条件値を使用して検索条件を付けたSQLを組み立ててQueryプロパティに指定していた場合は，データベースアクセス定義で条件を指定する列に可変記号を設定し，指定した条件を可変記号値定義ファイルに指定するように変更してください。

バージョン5以降のEURで，クエリファイルを含むレポートファイル（*.agr）を開いても，クエリファイルは読み込まれません。また，バージョン5以降のEURでは，クエリファイルに代わるものは提供されません。クエリファイルを使用していたUAPは，接続情報ファイルと可変記号値定義ファイルを使用してください。


ディクショナリファイルの扱い

6.1.4　ディクショナリファイルの扱い

バージョン5以降のEURで帳票を出力する場合は，ディクショナリファイル（*.dic）の指定は要りません。そのため，ディクショナリファイルを指定するオプション記述ファイルのキーワード，およびOLEオートメーションのプロパティを，UAPから削除する必要があります。

削除するキーワード，およびプロパティを次に示します。

項目 削除対象
オプション記述ファイル キーワード
  • MappingDicFile
  • UserDefDicFile
  • MappingDicPath
  • UserDefDicPath
OLEオートメーション Applicationオブジェクト プロパティ
  • MapDictionaryBasePath
  • UserDictionaryBasePath
Documentオブジェクト プロパティ
  • DictionaryFileVarDictionaryFile
MappingDataオブジェクト プロパティ
  • DictionaryFileName
UserDefineDataオブジェクト プロパティ
  • DictionaryFileName

UAPからこれらの項目を削除しても帳票を出力できない場合は，次の手順で対処してください。

  1. バージョン5以降のEURで，UAPで使用している帳票ファイルと，ディクショナリファイルを読み込みます。
  2. フォームシートファイル（*.fms）に保存し直します。
  3. UAPを，保存し直したフォームシートファイルに変更して実行します。


コマンド構文の互換性

6.2　コマンド構文の互換性

Windows版 EUR旧製品，UNIX版 EUR旧製品の互換性について説明します。

＜この節の構成＞
6.2.1　Windows版 EUR旧製品からの互換性
6.2.2　UNIX版 EUR旧製品からの互換性


Windows版 EUR旧製品からの互換性

6.2.1　Windows版 EUR旧製品からの互換性

  • EUR バージョン2以降と互換性があります。他アプリケーションからEURを起動している場合，起動する実行ファイルの名称は同じです。
  • EUR バージョン1とは互換性がありません。バージョン1では，eured.exeとeurpr.exeの二つの実行ファイルを提供していましたが，バージョン2以降は，実行ファイルの名称がapgrpt.exeに変更されました。そのため，他アプリケーションからEURを起動している場合は，実行ファイル名の変更が必要です。
  • バージョン2以降，ファイル読み込み元フォルダの変更があります。バージョン1では，EURで扱うファイル（フォームシートファイル，レポートファイル，データファイル，画像データファイル，およびディクショナリファイル）の読み込み元フォルダは直前に使用したファイルによって変更されていました。バージョン2以降は，［オプション］ダイアログで明示的に変更しないかぎり変更されません。


UNIX版 EUR旧製品からの互換性

6.2.2　UNIX版 EUR旧製品からの互換性

UNIX版 EUR旧製品を使用したUAPについては，コマンド起動を使用することで移行性があります。ただし，コマンド構文が異なりますので，EUR 帳票作成機能のコマンド構文に合わせたUAPの修正が必要です。

ただし，EXCEED3/W-EURを使用したUAPの移行性はありません。

UNIX版 EUR旧製品は，次に示す製品を指します。

  • P-16D2-211/P-16D2-212　　EUR（HI-UX/WE2）
  • P-1691-141/P-1691-142　　EXCEED3/W-EUR（HI-UX/WE2）
  • P-1BD2-211　　EUR（HP-UX 11.x）
  • P-92D2-2111　　EUR（HP-UX 9.x）
  • P-9291-1411　　EXCEED3/W-EUR（HP-UX 9.x）
  • P-9DD2-1111　　EUR（Solaris）
  • P-91D2-1111　　EUR（AIX）
  • P-9191-1411　　EXCEED3/W-EUR（AIX）


帳票出力での使用上の注意

7.　帳票出力での使用上の注意

この章では，帳票を出力する場合の使用上の注意について説明します。

＜この章の構成＞
7.1　印刷に関する注意
7.2　インストール，アンインストール時の注意


印刷に関する注意

7.1　印刷に関する注意

帳票を印刷する場合は，次のことに注意して印刷してください。

＜この節の構成＞
7.1.1　帳票の印刷範囲について
7.1.2　印刷時に使用するデータファイルの注意
7.1.3　出力ページ数の上限値
7.1.4　最上位結合項目を利用する帳票を印刷する場合の注意
7.1.5　バーコードの注意
7.1.6　コマンドに指定したデータの優先順位
7.1.7　データファイルのサイズに関する注意
7.1.8　ユーザ定義サイズを設定した帳票を印刷する場合の注意
7.1.9　帳票設計で使用できるフォント
7.1.10　光学式読み取り装置で帳票を読み取る場合の注意
7.1.11　複数様式の帳票を印刷する場合の注意
7.1.12　データベースからデータを入力する場合に使用できる文字
7.1.13　サービス起動で印刷する場合の注意
7.1.14　日付データ・時刻データを使用するときの注意
7.1.15　非Unicodeアプリケーションを使用する場合の注意
7.1.16　一時フォルダに関する注意


帳票の印刷範囲について

7.1.1　帳票の印刷範囲について

EURの帳票は，［用紙の設定］で設定された余白に従って印刷します。このため，出力先プリンタによっては，帳票の一部がプリンタの印刷できる範囲からはみ出し，帳票の一部が欠ける場合があります。あらかじめ出力先プリンタの印刷できる範囲を調査したあと，帳票の余白を設定してください。

印刷の結果，帳票の一部が欠けてしまった場合は，［ファイル］メニューの［用紙の設定］を選択し，欠けた方向の余白を大きくして再度印刷してください。

なお，コマンドのオプション，または印刷ダイアログで，ページ番号の印刷を設定して印刷すると，ページ番号を帳票の余白の部分に印刷します。このため，ページ番号印刷位置の余白の外側5mmまでが，出力先プリンタの印刷できる範囲内でなければなりません。また，使用するプリンタとプリンタドライバの組み合わせによっては，プリンタのハード的な印刷できる範囲よりも小さくなる場合がありますので注意してください。


印刷時に使用するデータファイルの注意

7.1.2　印刷時に使用するデータファイルの注意

印刷時に使用するデータファイルのデータが0件の場合は，タイトルや見出しだけを印刷した帳票が出力されます。アプリケーションを設計するとき，データファイルのデータが0件の場合は印刷を実行しないように設定してください。


出力ページ数の上限値

7.1.3　出力ページ数の上限値

EURで出力できるページ数の上限を次に示します。

＜この項の構成＞
(1)　印刷ページ数の上限値
(2)　表示ページ数の上限値

(1)　印刷ページ数の上限値

EURで印刷できるページ数の上限を次に示します。

操作する場所 | 印刷できるページ数の上限
メニュー | 65,534ページ
apgrptコマンド | 32,767ページ
OLEオートメーション | 9,999ページ

印刷できるページ数を超えると，エラーになり，印刷処理を中止します。印刷開始ページと印刷終了ページ，または部数の指定を見直して，印刷できるページ数以内になるように修正したあと，プログラムを再度実行してください。必要ならば，数回に分けて印刷してください。

なお，印刷できるページ数の上限は，メモリ容量やスプールファイルの空き容量に依存されます。スプールファイルとは，印刷を実行する時，ユーザのハードディスク，またはネットワークプリンタが接続されているコンピュータのハードディスクに生成される，一時的なファイルです。

(2)　表示ページ数の上限値

EURで表示できるページ数の上限はありません。


最上位結合項目を利用する帳票を印刷する場合の注意

7.1.4　最上位結合項目を利用する帳票を印刷する場合の注意

最上位結合項目を利用する帳票を印刷する場合は，使用するデータファイルをCSV形式に，データの区切り文字を「，」（コンマ）にしてください。


バーコードの注意

7.1.5　バーコードの注意

＜この項の構成＞
(1)　バーコードのデータキャラクタの注意
(2)　CODE128バーコードのデータキャラクタの注意
(3)　プリンタ解像度ごとのバーコード最小サイズ
(4)　バーコードの印刷の注意

(1)　バーコードのデータキャラクタの注意

CODE128バーコードの場合は，［アイテムのプロパティ］ダイアログで指定したフォントでデータキャラクタを出力します。

CODE128バーコード以外の場合は，帳票上で指定したフォントでデータキャラクタを出力します。

(2)　CODE128バーコードのデータキャラクタの注意

コードセットBを使用してデータファイルに「\」を指定した場合，出力する時のフォント指定によって，「＼」に出力できます。

「\」を「＼」に出力する場合は，データキャラクタのフォントに，Arialなどの欧文フォントを指定してください。ＭＳ ゴシックなどの日本語フォントを指定した場合は，「\」のまま出力されます。

(3)　プリンタ解像度ごとのバーコード最小サイズ

プリンタの解像度によって出力できるバーコードの最小サイズを次に示します。

なお，最小サイズで出力したバーコードは，ご使用になるバーコードの読み込み装置によって，読み込めないこともあります。あらかじめ，出力したバーコードが読み取れるかどうかを確認されることをお勧めします。バーコードと出力するプリンタの解像度を次に示します。

表7-1　バーコードと出力するプリンタの解像度

バーコード | 出力するプリンタの解像度
 | 300dpi | 600dpi
JAN標準／UPC-A | 0.8倍 | 0.8倍
JAN短縮／UPC-E | 0.8倍 | 0.8倍
CODE39 | 0.15mm | 0.15mm
CODE128 | 0.20mm | 0.15mm
NW-7 | 0.20mm | 0.15mm
ITF | 0.25倍 | 0.25倍

カスタマバーコードとQRコードは，出力するプリンタに依存しません。

(4)　バーコードの印刷の注意

バーコードの周りには，次の余白部分が必要です。

  • JAN：マージン
  • カスタマバーコード：空白
  • 上記以外のバーコード：クワイエットゾーン

バーコードの余白部分にほかのアイテムが配置されていた場合，バーコードの余白部分を優先して印刷します。バーコードの余白部分にほかのアイテムを配置しないようにしてください。


コマンドに指定したデータの優先順位

7.1.6　コマンドに指定したデータの優先順位

コマンドをフルパスで指定されている場合は，そのパスが優先されます。

コマンドに実行時オプションがなければ，開発時のパス，フォームシートファイル（*.fms）に保存されているファイル名の順に読み込まれます。レポートファイル（*.agr）の場合は，サンプルデータが読み込まれます。


データファイルのサイズに関する注意

7.1.7　データファイルのサイズに関する注意

EURで扱えるデータファイルには，次のようなデータサイズに関する注意があります。

データファイルの記述項目 | CSV形式およびDAT形式 | FIX形式
ファイルサイズ | 2GBを上限とします。 | 2GBを上限とします。
レコード数 | 上限はありません。 | 上限はありません。
レコード長 | 上限はありません。 | 改行を含めないで32,767バイトを上限とします。
フィールド数 | 上限はありません。 | 上限はありません。ただし，レコード長と1フィールド長の上限値によって制限されます。
1フィールドの長さ | 99,999バイトを上限とします。 | 32,767バイトを上限とします。
フィールド名の長さ
  • マッピングデータのフィールド名
    510桁を上限とします。
  • ユーザ定義データのフィールド名
    499桁を上限とします。
  • マッピングデータのフィールド名
    510桁を上限とします。
  • ユーザ定義データのフィールド名
    499桁を上限とします。


ユーザ定義サイズを設定した帳票を印刷する場合の注意

7.1.8　ユーザ定義サイズを設定した帳票を印刷する場合の注意

［用紙の設定］ダイアログで，「ユーザ定義」を設定した帳票を印刷する場合は，設計した帳票と同じ印刷結果を得るため，プリンタのプロパティでも同じ用紙サイズを設定してください。この場合，［用紙の設定］で設定した用紙サイズの単位を合わせて設定すると便利です。


帳票設計で使用できるフォント

7.1.9　帳票設計で使用できるフォント

帳票設計で使用できるフォントは，固定ピッチおよび可変ピッチ（プロポーショナル）のTrueTypeフォントです。

OCRフォントを使用して帳票を定義することもできます。ただし，EURで出力された帳票を光学式文字読み取り装置で読み取る場合は，ご使用になる光学式文字読み取り装置で，文字が読み取れるかどうかを確認してください。

縦書きのないフォントと縦書き配置を組み合わせた場合，正しく表示されない場合があります。

メイリオフォントの場合，縦書き配置を指定すると文字の出力位置がずれるため，縦書き配置を指定しないでください。


光学式読み取り装置で帳票を読み取る場合の注意

7.1.10　光学式読み取り装置で帳票を読み取る場合の注意

EURで設計して出力した帳票を，光学式文字読み取り装置，バーコードの読み取り装置などの光学式読み取り装置で読み取る場合は，次に示す注意が必要です。

  • 帳票を出力する場合は，300dpi以上のレーザープリンタを使用されることをお勧めします。
  • 印刷ダイアログなどで，用紙サイズに合わせた縮小，または拡大の指定はしないでください。
  • 使用する光学式読み取り装置で，出力した帳票が読み取れるかどうかをあらかじめ確認することをお勧めします。


複数様式の帳票を印刷する場合の注意

7.1.11　複数様式の帳票を印刷する場合の注意

複数様式の帳票を両面印刷する場合は，［印刷］ダイアログのプロパティで，用紙の両面に印刷する指定をしてください。［印刷］ダイアログのプロパティの指定がなければ，複数様式情報定義ファイルのキーワードprintnewpaperを指定しても，有効になりません。複数様式情報定義ファイルのキーワードprintnewpaperについては，「5.7.1　複数様式情報定義ファイルの編集」を参照してください。

ページ範囲を指定して印刷する場合
ページ範囲を指定して印刷する場合は，印刷プレビューから［印刷］ダイアログの［ページ指定］で指定してください。
［ページ指定］は，次に示す帳票を印刷プレビューしている場合に選択できます。
  • 複数様式を含んだEUR形式ファイル
  • 複数様式情報定義ファイルを指定した帳票


データベースからデータを入力する場合に使用できる文字

7.1.12　データベースからデータを入力する場合に使用できる文字

データベースからデータを入力する場合に使用できる文字についての注意を次に示します。

  • HiRDBおよびOracleは，Shift JISとUTF-8に対応しています。SQL ServerはShift JISに対応しています。
    Shift JISデータベースの場合
    データベースに格納されているデータは，Shift JISコードで取り出してください。Shift JISコードの文字とは，次のような文字です。
    ・1バイト文字で0x20～0x7E，または0xA1～0xDF
    ・2バイト文字で1バイト目が，0x81～0x9F，または0xE0～0xFC
    ・2バイト文字で2バイト目が，0x40～0x7E，または0x80～0xFC
    例えば，CHAR属性の列に0x00が入っている場合は，0x00以降のデータは取り出されません。データを取り出す対象となる列に0x00から始まるデータが格納されている場合は，NULL値となります。
    データを取り出す対象となる列にバイナリデータが格納されている場合は，文字列として取り出されます。
    Unicodeデータベースの場合
    データベースに格納されているデータは，UTF-8で取り出してください。UTF-8は，次のような文字です。
    UTF-8 | 文字の種類
    1バイト目 | 2バイト目 | 3バイト目
    00-7F － － 制御コード
    ASCII文字
    C0-DF 80-BF － UCS-2マルチバイト文字（0x0080-0x07FF）
    E0-EF | 80-BF | 80-BF | UCS-2マルチバイト文字（0x0800-0xFFFF）

    （凡例）

      －：該当しません。

    サポート文字は，ASCII文字（X'20'～X'7E'），UCS-2マルチバイト文字（0x0080-0x07FF，0x0800-0xFFFF）の範囲です。サロゲートペアにも対応します。
    サポートしていない文字が指定されていた場合，データベースに格納されているデータと異なる文字で出力されることがあります。
  • 0バイト定数とNULL値を区別しないでください。0バイト定数とNULL値はどちらもNULL値として扱われ，区別されません。
  • Shift JISデータベースの場合，データはShift JISコードでデータベースに格納してください。
  • 表名や列名に引用符（"）が含まれている場合は，正しく動作しません。
  • 上記以外の文字コードを含むデータを抽出した場合の動作は保証しません。


サービス起動で印刷する場合の注意

7.1.13　サービス起動で印刷する場合の注意

EUR クライアント帳票出力機能では，サービス起動（Windowsログインなし）での印刷はできません。サービス起動（Windowsログインなし）での印刷をする場合は，EUR サーバ帳票出力機能を使用してください。


日付データ・時刻データを使用するときの注意

7.1.14　日付データ・時刻データを使用するときの注意

日付データ・時刻データを帳票設計時と異なるロケールで出力する場合，次のことに注意してください。

  • 次の変換記号はロケールに応じて変換されるため，帳票を定義したロケールと表示または印刷するロケールが異なる場合，出力結果が異なります。
    レポートファイル形式：2n（月），2N（省略形の曜日），3N（曜日），2a（午前/午後）
  • 元号表記や元年表示など日本語特有の変換記号や，フォームシートファイル形式の変換記号は，実行するロケールに関係なく日本語に変換されます。


非Unicodeアプリケーションを使用する場合の注意

7.1.15　非Unicodeアプリケーションを使用する場合の注意

非Unicodeアプリケーションの言語で使用できないエンコーディングは，画像フォルダおよび一時ファイルフォルダに使用できません。


一時フォルダに関する注意

7.1.16　一時フォルダに関する注意

EURが使用する一時フォルダの注意事項を次に示します。

  • EURの実行中に一時フォルダを操作しないでください。操作した場合，予期しないエラーが発生するおそれがあります。
  • EURがデフォルトで使用する一時フォルダは，システムの一時フォルダです。一時フォルダにそれ以外のフォルダを設定したい場合は，環境変数EUR_TMPPATHで指定するか，［オプション］ダイアログの［ファイル］タブから設定してください。
    参考
    システムの一時フォルダについては，［システムのプロパティ］ダイアログで環境変数TMPまたはTEMPの設定を確認してください。
    なお，出力先は環境変数TMPまたはTEMPの設定によって次の順に決定されます。
    1. 環境変数TMPで指定されているフォルダ
    2. 環境変数TMPが指定されていない場合，環境変数TEMPで指定されているフォルダ
    3. 環境変数TMPとTEMPがどちらも指定されていない場合，Windowsのフォルダ


インストール，アンインストール時の注意

7.2　インストール，アンインストール時の注意

インストール，アンインストール時の注意について説明します。インストール，アンインストールの手順とフォルダ構成については，「付録A　インストール，アンインストール」を参照してください。

＜この節の構成＞
7.2.1　インストール時の注意
7.2.2　アンインストール時の注意
7.2.3　リモートインストール


インストール時の注意

7.2.1　インストール時の注意

  • 管理者グループまたはAdministratorsグループに属するユーザでインストールしてください。
  • 上書きインストールをする場合は，前回インストールしたロケールと同じロケールで上書きインストールしてください。異なるロケールで上書きインストールした場合，正常にインストールできないことがあります。
  • スタートメニューのアイコンは，新規にインストールした場合だけ置き換えられます。バージョン5以前の製品からバージョンアップした場合には，古いアイコンが残ります。
  • 一つのマシンに，EUR Designer，EUR DeveloperおよびEUR Viewerを複数組み合わせてインストールすることはできません。この中から別の製品をインストールしたい場合は，インストールされている製品を事前にアンインストールする必要があります。
  • バージョン8以前の製品がマシンにインストールされている場合は，インストールしようとするバージョン9製品に関連する製品がアンインストールされます。
    インストール時にアンインストールされるバージョン8以前の製品を次の表に示します。なお，表中では，各製品の名称を次のように省略して表記します。
    • DSN：EUR Designer
    • DEV：EUR Developer
    • VIEW：EUR Viewer
    • PRO：EUR Professional Edition
    • VIEWE：EUR Viewer - EUR report option

    表7-2　インストール時にアンインストールされるバージョン8以前の製品

    インストールする製品 | マシンにインストールされているバージョン8以前の製品
    DSN | DEV | VIEW | PRO | VIEWE
    バージョン8の場合 | バージョン7以前の場合
    EUR Designer ○ × × △ △ △
    EUR Viewer × × ○ △ △ △
    （凡例）
    ○：自動的に旧バージョンの製品がアンインストールされます。
    △：警告メッセージが表示され，アンインストールを選択した場合は，旧バージョンの製品がアンインストールされます。
    ×：旧バージョンの製品はアンインストールされません。手動でアンインストールする必要があります。


アンインストール時の注意

7.2.2　アンインストール時の注意

  • アンインストールは，すべてのEURを終了させたあとに実行してください。
  • 管理者グループまたはAdministratorsグループに属するユーザで，半角英数字のログインユーザ名でアンインストールしてください。
  • インストール後にユーザが作成できるファイル（環境設定ファイル「EUR_ENV」など）は，アンインストールを実行しても削除されません。ファイルを削除する場合は，エクスプローラなどから直接削除してください。
  • ユーザが設定した環境は，アンインストールしても削除されません。ユーザ情報が残っていてもシステム上問題はありません。設定した環境を削除したい場合は，アンインストールする前に，スタートメニューから［EURユーザ環境削除］を選択してユーザ環境を削除してください。EURユーザ環境削除ツールについては，「付録B.4　EURユーザ環境削除ツール」を参照してください。
  • インストールしたロケールと同じロケールでアンインストールしてください。異なるロケールでアンインストールした場合，正常にアンインストールできないことがあります。


リモートインストール

7.2.3　リモートインストール

EUR DesignerおよびEUR Viewerは，JP1/NETM/DMおよびGroupmax Remote Installationのリモートインストールに対応しています。

次のリモートインストールが利用できます。操作・運用方法については，JP1/NETM/DMまたはGroupmax Remote Installationのマニュアルを参照ください。

＜この項の構成＞
(1)　更新インストール
(2)　新規インストール

(1)　更新インストール

インストール済みのEURと同じフォルダにインストールします。EURがインストールされていない場合は，更新インストールはできません。

(2)　新規インストール

(a)　デフォルト値を使用した場合

システムがインストールされているドライブに，次に示すフォルダを作成してインストールします。

  • EUR Designerの場合
    \Program Files\HITACHI\EUR
  • EUR Viewerの場合
    \Program Files\HIATCHI\EUR Viewer
(b)　ドライブを指定した場合

指定したドライブに，次に示すフォルダを作成してインストールします。

  • EUR Designerの場合
    \Program Files\HITACHI\EUR
  • EUR Viewerの場合
    \Program Files\HIATCHI\EUR Viewer
(c)　パスを指定した場合

指定したパスにインストールします。すでにEURがインストールされている場合でも，指定されたところにインストールされます。


EUR クライアント帳票出力機能が表示するダイアログ

8.　EUR クライアント帳票出力機能が表示するダイアログ

この章では，EUR ViewerのEUR クライアント帳票出力機能が表示するダイアログについて説明します。

＜この章の構成＞
8.1　［ズーム］ダイアログ
8.2　［オプション］ダイアログ
8.3　［EURログオプションの設定］ダイアログ
8.4　［EURログメンテナンスツール］ダイアログ
8.5　［EURユーザ環境削除］ダイアログ
8.6　［EURクライアント帳票出力機能］ダイアログ


［ズーム］ダイアログ

8.1　［ズーム］ダイアログ

帳票の表示倍率を変更するダイアログです。

＜この節の構成＞
(1)　［ズーム］ダイアログで設定できる項目
(2)　画面図

(1)　［ズーム］ダイアログで設定できる項目

表示倍率オプションボタン
帳票の表示倍率を指定します。
［800%］オプションボタン：帳票を800%の倍率で表示します。
［400%］オプションボタン：帳票を400%の倍率で表示します。
［200%］オプションボタン：帳票を200%の倍率で表示します。
［150%］オプションボタン：帳票を150%の倍率で表示します。
［100%］オプションボタン：帳票を100%の倍率で表示します。
［75%］オプションボタン：帳票を75%の倍率で表示します。
［50%］オプションボタン：帳票を50%の倍率で表示します。
［10%］オプションボタン：帳票を10%の倍率で表示します。
［ページ全体を表示］オプションボタン
帳票ウィンドウの大きさに合わせて帳票全体を表示します。表示されている帳票ウィンドウに対してだけ有効です。ただし，表示されている帳票ウィンドウが帳票の10%より小さい場合，帳票を10%の倍率で表示します。
［指定］スピンボックス
任意の表示倍率を設定します。表示倍率は，テキストボックスに直接入力するか，またはアップダウンコントロールをクリックして設定します。設定できる値は，10～800です。800，400，200，150，100，75，50，または10の値を設定した場合は，該当するオプションボタンが選択状態になります。

(2)　画面図

[目次][前へ][次へ]

[他社商品名称に関する表示]

All Rights Reserved. Copyright (C) 2014, Hitachi, Ltd.
All Rights Reserved. Copyright (C) 2014, Hitachi Solutions, Ltd.


［オプション］ダイアログ

8.2　［オプション］ダイアログ

［オプション］ダイアログでは，次に示すタブが表示されます。

  • ［表示］タブ
  • ［ファイル］タブ

このダイアログで設定したオプションは，次回起動した時も有効です。

＜この節の構成＞
8.2.1　［表示］タブ
8.2.2　［ファイル］タブ


［表示］タブ

8.2.1　［表示］タブ

表示オプションを設定します。［表示］タブで設定した内容は，レポート確認ウィンドウの表示形態のデフォルトになります。

＜この項の構成＞
(1)　［表示］タブで設定できる項目
(2)　画面図

(1)　［表示］タブで設定できる項目

［ウィンドウ］
レポート確認ウィンドウに，ステータスバーを表示するかどうかを設定します。
［ステータスバー］チェックボックス
ステータスバーを表示するかどうかを設定します。デフォルトは，「オン（表示する）」です。
［文字幅計算方法］グループボックス
帳票を出力する時の固定ピッチフォントの文字幅計算方法を設定します。デフォルトは「静的（フォントの文字幅を固定値として計算する）」です。ただし，可変ピッチフォント（プロポーショナルフォント）の場合は，［静的］と［動的］のどちらを選択しても，使用するフォントに合わせて文字幅を計算します（「動的モード」といいます）。
［静的］オプションボタン
固定ピッチフォントの文字幅を，固定値として計算します（「静的モード」といいます）。半角の場合はアイテムのフォント幅，全角の場合はアイテムのフォント幅の2倍で計算します。
［動的］オプションボタン
固定ピッチフォントの文字幅を，使用するフォントに合わせて計算します（動的モード）。

(2)　画面図

[目次][前へ][次へ]

[他社商品名称に関する表示]

All Rights Reserved. Copyright (C) 2014, Hitachi, Ltd.
All Rights Reserved. Copyright (C) 2014, Hitachi Solutions, Ltd.


［ファイル］タブ

8.2.2　［ファイル］タブ

ファイルオプションを設定します。

＜この項の構成＞
(1)　［ファイル］タブで設定できる項目
(2)　画面図

(1)　［ファイル］タブで設定できる項目

［ファイルの種類］
レポートファイル
帳票ファイル（レポートファイル，またはフォームシートファイル）があるフォルダ名を設定します。フォルダを設定しない場合は，デフォルトとしてEUR Viewerのインストール先フォルダが設定されます。
マッピングデータファイル
マッピングデータファイル，または可変記号値定義ファイルがあるフォルダ名を設定します。フォルダを設定しない場合は，デフォルトとしてEUR Viewerのインストール先フォルダが設定されます。
マッピングディクショナリファイル
マッピングデータ用のディクショナリファイルがあるフォルダ名を設定します。フォルダを設定しない場合は，デフォルトとしてEUR Viewerのインストール先フォルダが設定されます。ただし，英語ロケール，中国語ロケールでは設定できません。
ユーザ定義データファイル
ユーザ定義データファイル，または可変記号値定義ファイルがあるフォルダ名を設定します。フォルダを設定しない場合は，デフォルトとしてEUR Viewerのインストール先フォルダが設定されます。
ユーザ定義ディクショナリファイル
ユーザ定義データ用のディクショナリファイルがあるフォルダ名を設定します。フォルダを設定しない場合は，デフォルトとしてEUR Viewerのインストール先フォルダが設定されます。ただし，英語ロケール，中国語ロケールでは設定できません。
画像ファイル
画像データがあるフォルダ名を設定します。フォルダを設定しない場合は，デフォルトとしてEUR Viewerのインストール先フォルダが設定されます。
接続情報ファイル
接続情報ファイルがあるフォルダ名を設定します。フォルダを設定しない場合は，デフォルトとしてEUR Viewerのインストール先フォルダが設定されます。
一時ファイル
データベースと連携して帳票を出力する時に作成される，一時ファイルの出力先を設定します。フォルダを設定しない場合は，デフォルトとしてシステム環境変数TMP，またはTEMPで指定されるフォルダが設定されます。
置き換え表管理情報ファイル
置き換え表管理情報ファイルがあるフォルダを設定します。フォルダを設定しない場合は，デフォルトとしてEUR Viewerのインストール先フォルダが設定されます。
置き換え表ファイル
置き換え表ファイルがあるフォルダを設定します。フォルダを設定しない場合は，デフォルトとしてEUR Viewerのインストール先フォルダが設定されます。
［変更］ボタン
［フォルダの参照］ダイアログが表示されます。［フォルダの参照］ダイアログは，［ファイルの種類］の一覧からファイルを選択したあと，［変更］ボタンをクリックすると表示されます。
［フォルダの参照］ダイアログに表示されるコメントは，［ファイルの種類］の一覧から選択したファイルによって異なります。次に示す［フォルダの参照］ダイアログは，［ファイルの種類］の一覧からレポートファイルを選択した場合の表示例です。

(2)　画面図

[目次][前へ][次へ]

[他社商品名称に関する表示]

All Rights Reserved. Copyright (C) 2014, Hitachi, Ltd.
All Rights Reserved. Copyright (C) 2014, Hitachi Solutions, Ltd.


［EURログオプションの設定］ダイアログ

8.3　［EURログオプションの設定］ダイアログ

ログオプション（ログ採取レベル，ログ出力ファイル名，およびログメンテナンス方法）を設定するダイアログです。

＜この節の構成＞
(1)　［EURログオプションの設定］ダイアログで設定できる項目
(2)　画面図

(1)　［EURログオプションの設定］ダイアログで設定できる項目

［ログ採取レベル］リストボックス
ログ採取レベルを設定します。ログ採取レベルは，次に示す5種類です。EURをインストールした直後は，「起動履歴」が設定されています。
  • エラー履歴
    EURの処理でエラーが発生した時，終了コード（RTNCODE=0）以外のエラーを出力します。
  • 起動履歴
    次に示す情報を出力します。
    EUR起動時の情報（起動履歴，起動方法，起動時の指定パラメタ）
    EUR終了時の情報（終了履歴）
    ドキュメントオープン時の情報（処理対象の帳票ファイル名，データファイル名）
    印刷処理開始時の情報（出力先プリンタの情報）
    各ページ印刷開始時の情報（印刷ページ数）
    ユーザが操作した内容
  • 要求履歴
    ユーザが操作した内容（プロパティ・ユーザ操作の履歴）を出力します。
  • 処理履歴
    EURの内部関数の処理履歴（入力パラメタ，出力パラメタ，リターンコード）を出力します。
  • システム履歴
    システム関数（OS提供の関数）の処理履歴（入力パラメタ，出力パラメタ，リターンコード）を出力します。
ログ採取のレベルは，エラー履歴＜起動履歴＜要求履歴＜処理履歴＜システム履歴の順に，採取する情報量が多くなります。そのため，上位レベルになるほど，ファイル容量が増加するので，プログラムへの性能に影響が及ぶこともあります。ログ採取のレベルは，下位レベルで採取されることをお勧めします。
［ログを出力するファイル］テキストボックス
ログを出力するファイル名をフルパスで指定します。既存の書き込み権限を持つフォルダを指定してください。EURをインストールした直後は，システムの一時フォルダにファイル名「HIEUR.LOG」が自動生成されています。システムの一時フォルダについては，［システムのプロパティ］ダイアログで環境変数TMPまたはTEMPの設定を確認してください。なお，出力先は環境変数TMPまたはTEMPの設定によって次の順に決定されます。
  1. 環境変数TMPで指定されているフォルダ
  2. 環境変数TMPが指定されていない場合，環境変数TEMPで指定されているフォルダ
  3. 環境変数TMPとTEMPがどちらも指定されていない場合，Windowsのフォルダ
［自動ログメンテナンスを行う］チェックボックス
自動ログメンテナンスするかどうかを設定します。EURをインストールした直後は，「オン（自動ログメンテナンスを行う）」が設定されています。
「自動ログメンテナンスを行う」のチェックボックスをオンにすると，［メンテナンス実行契機］と［メンテナンス方法］が設定できます。
［メンテナンス実行契機］グループボックス

自動メンテナンスする契機を，オプションボタンで設定します。EURをインストールした直後は，「マシン起動時に実行」，実行する日時には「毎日」が設定されています。
指定した曜日にマシンを起動した場合，ログファイルがメンテナンスされます。曜日は，「毎日」か，日曜～土曜のどれかを選択します。
指定時刻に実行する場合は，曜日のほか，実行する時刻を指定します。時刻は，テキストボックスに直接入力するか，またはリストボックスから選択してください。直接入力する場合は，24時間表示の時刻（分単位）で指定します。
［メンテナンス方法］グループボックス

ログファイルのメンテナンス方法を，オプションボタンで設定します。EURをインストールした直後は，「経過日数によりログ情報を削除」で，経過日数は「7（日）」です。
  • 経過日数によりログ情報を削除
    指定した日数を経過したログ情報を，ログファイル内から削除します。経過日数は，1～100の整数で指定します。
  • 上限容量を超えた場合に削除
    指定したログファイルの上限容量を超えた場合，無条件にログファイルの容量が1/2に削除されます。ログファイルの上限容量は，1～1,000の整数で指定します。単位は，MBです。
    なお，［上限容量を超えた場合に削除］を選択した場合，ログ採取のレベルと指定したログファイルの上限容量によっては，1回の処理でログファイルの上限容量を超える場合があります。
［オプション読込］ボタン
保存されているEURログオプションファイルを読み込めます。［オプション読込］ボタンをクリックすると，［ファイルの読み込み］ダイアログが表示されます。［ファイルの読み込み］ダイアログで，読み込むファイルの保存されている場所とファイル名を設定すると，［EURログオプションの設定］ダイアログに情報が反映されます。
EURログオプションファイルを読み込む時は，ファイルの妥当性とバージョンがチェックされます。上位バージョンで作成されたEURログオプションファイル，または保存されている内容が異なるEURログオプションファイルが指定された場合はメッセージが表示され，オプションの情報はダイアログに反映されません。
［オプション保存］ボタン
［EURログオプションの設定］ダイアログで設定したオプションを，EURログオプションファイルに保存できます。［オプション保存］ボタンをクリックすると，［ファイルへ保存］ダイアログが表示されます。EURログオプションファイルの拡張子は，「.eurlgo」です。保存される情報は，採取したログのほか，使用したEURの製品名，PP形名，およびバージョンです。

(2)　画面図

[目次][前へ][次へ]

[他社商品名称に関する表示]

All Rights Reserved. Copyright (C) 2014, Hitachi, Ltd.
All Rights Reserved. Copyright (C) 2014, Hitachi Solutions, Ltd.


［EURログメンテナンスツール］ダイアログ

8.4　［EURログメンテナンスツール］ダイアログ

［EURログオプションの設定］ダイアログで設定されている，ログメンテナンス情報が表示されます。また，ログメンテナンスやオプション設定ツールを実行したり，停止したりできます。

＜この節の構成＞
(1)　［EURログメンテナンスツール］ダイアログで設定できる項目
(2)　画面図

(1)　［EURログメンテナンスツール］ダイアログで設定できる項目

［ログメンテナンス契機］
［EURログオプションの設定］ダイアログの［メンテナンス実行契機］で設定した情報が表示されます。
［ログメンテナンス方法］
［EURログオプションの設定］ダイアログの［メンテナンス方法］で設定した情報が表示されます。
［メンテナンス実行］ボタン
設定されているログファイルのメンテナンス方法を実行します。EURログメンテナンスツールが実行状態の場合に［メンテナンス実行］ボタンをクリックすると，［ログメンテナンス方法］の表示領域の下部に「ログメンテナンス実行中」と表示されます。
［オプション設定］ボタン
EURログオプション設定ツールを起動します。［オプション設定］ボタンをクリックしたとき，すでにログオプション設定ツールが起動されている場合は，起動されているログオプション設定ツールをアクティブにします。
［無効にする］ボタン
ログメンテナンス情報の設定に関係なく，EURログメンテナンスツールを強制終了して，［EURログメンテナンスツール］ダイアログを閉じます。そのため，［ログメンテナンス方法］で指定時刻が設定されている場合は，指定された時刻になっても，自動ログメンテナンスは実行されません。

(2)　画面図

[目次][前へ][次へ]

[他社商品名称に関する表示]

All Rights Reserved. Copyright (C) 2014, Hitachi, Ltd.
All Rights Reserved. Copyright (C) 2014, Hitachi Solutions, Ltd.


［EURユーザ環境削除］ダイアログ

8.5　［EURユーザ環境削除］ダイアログ

設定されているユーザ環境を削除します。

＜この節の構成＞
(1)　［EURユーザ環境削除］ダイアログで設定できる項目
(2)　画面図

(1)　［EURユーザ環境削除］ダイアログで設定できる項目

［環境削除］ボタンをクリックしてください。

削除されるユーザ環境は，［オプション］ダイアログで指定した各種オプション情報，ツールバーの表示・非表示，［色の設定］ダイアログで登録した独自の色などです。

(2)　画面図

[目次][前へ][次へ]

[他社商品名称に関する表示]

All Rights Reserved. Copyright (C) 2014, Hitachi, Ltd.
All Rights Reserved. Copyright (C) 2014, Hitachi Solutions, Ltd.


［EURクライアント帳票出力機能］ダイアログ

8.6　［EURクライアント帳票出力機能］ダイアログ

［EURクライアント帳票出力機能］ダイアログでは，指定した帳票ファイルに関連づける，次のファイルの場所を指定できます（データ指定機能）。

  • マッピングデータファイル
  • ユーザ定義データファイル
  • 接続情報ファイル
  • 可変記号値定義ファイル

［EURクライアント帳票出力機能］ダイアログの各項目では，次のどの方法でもファイルを指定できます。

  • ［参照］ボタンをクリックし，［ファイルの選択］ダイアログで出力ファイルを選択します。
  • テキストボックスにファイルのパスをフルパスまたは相対パスで直接指定します。相対パスで指定する場合は，［オプション］ダイアログの［ファイル］タブに設定されているフォルダを起点としたパスを指定してください。
  • エクスプローラからテキストボックスへファイルをドラッグアンドドロップで指定します。
＜この節の構成＞
(1)　［EURクライアント帳票出力機能］ダイアログで設定できる項目
(2)　画面図

(1)　［EURクライアント帳票出力機能］ダイアログで設定できる項目

［帳票ファイル］テキストボックス
［ファイルの選択］ダイアログで指定した帳票ファイルの場所が表示されます。指定は省略できません。
［ファイルの選択］ダイアログで指定した帳票ファイルを指定し直すこともできます。
［マッピングデータ］テキストボックス
マッピングデータ名を指定します。
データベースからデータを入力する場合は，［データベースから入力］チェックボックスをオンにした上で，可変記号値定義ファイルを指定します。
［ユーザ定義データ］テキストボックス
ユーザ定義データ名を指定します。
データベースからデータを入力する場合は，［データベースから入力］チェックボックスをオンにした上で，可変記号値定義ファイルを指定します。
［データベースから入力］チェックボックス
データベースからデータを入力する場合，このチェックボックスをオンにします。デフォルトはオフ（データベースからデータを入力しない）です。
このチェックボックスをオンにした場合は，［接続情報ファイル］テキストボックスに接続情報ファイルを指定してください。また，［マッピングデータ］テキストボックスおよび［ユーザ定義データ］テキストボックスに可変記号値定義ファイルを指定してください。
［接続情報ファイル］テキストボックス
［データベースから入力］チェックボックスがオンになっている場合に，接続情報ファイルを指定します。指定は省略できません。
［データベースから入力］チェックボックスがオフになっている場合は指定できません。

(2)　画面図

[目次][前へ][次へ]

[他社商品名称に関する表示]

All Rights Reserved. Copyright (C) 2014, Hitachi, Ltd.
All Rights Reserved. Copyright (C) 2014, Hitachi Solutions, Ltd.


付録

＜この付録の構成＞
付録A　インストール，アンインストール
付録B　EURが提供するツール
付録C　作業環境の言語との対応
付録D　このマニュアルの参考情報


インストール，アンインストール

付録A　インストール，アンインストール

EURのインストール，アンインストールについて説明します。

＜この節の構成＞
付録A.1　インストールの手順
付録A.2　インストール後に作成されるフォルダ
付録A.3　アンインストールの手順


インストールの手順

付録A.1　インストールの手順

EUR DesignerまたはEUR Viewerをインストールする場合は，ほかのユーザアプリケーションプログラムを終了させてください。また，インストールする前に，インストール時に必要なディスク占有量を確認してください。

インストールする前に，インストール時に必要なディスク空き容量を確認してください。

管理者権限またはAdministrators権限を持つユーザでログインしてください。

EUR DesignerまたはEUR Viewerをシステムフォルダ（Program FilesまたはProgram Files (x86)）以下にインストールした場合，システムフォルダ内の設定ファイルなどを更新するときに，管理者権限が必要です。

EUR製品の統合CD-ROMをPCにセットすると，自動的に日立総合インストーラが起動されます。インストール画面は，インストール実行時のロケールに対応した言語で表示されます。ロケールが英語，中国語，日本語のどれでもない場合は英語で表示されます。ただし，サポートしていないロケールで実行した場合，EURの動作は保証されません。

日立総合インストーラのウィンドウから，インストールするEUR DesignerまたはEUR Viewerを選択してください。［インストール実行］ボタンをクリックすると，インストールが実行されます。

上書きインストールをする場合は，前回インストールしたロケールと同じロケールで上書きインストールしてください。異なるロケールで上書きインストールした場合，正常にインストールできないことがあります。


インストール後に作成されるフォルダ

付録A.2　インストール後に作成されるフォルダ

EUR DesingerおよびEUR Viewerのインストール後に作成されるフォルダについて説明します。

＜この項の構成＞
(1)　EUR Designerの場合
(2)　EUR Viewerの場合

(1)　EUR Designerの場合

表A-1　EUR Designerのインストール後に作成されるフォルダ

フォルダまたはファイル名 | 内容
%EUR% | EURのルートディレクトリ
Designer\ | EUR Designerのルートディレクトリ
1033\ | 英語リソースディレクトリ
1041\ | 日本語リソースディレクトリ
Help\ | ヘルプ格納ディレクトリ
eurds.chm | EUR 帳票作成ヘルプ（統合ヘルプ）
eursysd.chm | マニュアル「EUR システム設計ガイド」のヘルプ
eursysa.chm | マニュアル「EUR システム構築ガイド」のヘルプ
eurrpt.chm | マニュアル「EUR 帳票作成 操作ガイド」のヘルプ
eurdlg.chm | マニュアル「EUR 帳票作成 画面リファレンス」のヘルプ
eurvoutp.chm | マニュアル「EUR 帳票出力 EUR Designer/EUR Viewer編」のヘルプ
eurdb.chm | マニュアル「EUR データベース連携ガイド」のヘルプ
eurmes.chm | マニュアル「EUR メッセージ」のヘルプ
eurprim.chm | マニュアル「はじめての帳票設計」のヘルプ
euroutp.chm | マニュアル「EUR クライアント帳票出力」のヘルプ
2052\ | 中国語リソースディレクトリ
Include\ | ヘッダファイルディレクトリ
Lib\ | ライブラリディレクトリ
Program\ | 実行ファイル格納ディレクトリ
apgrpt.exe | EUR Designer実行ファイル
Eurer.exe | eurerコマンド
EurLgMnt.exe | ログメンテナンスツール
EurLgOpt.exe | ログメンテナンスオプション設定ツール
Eurtyl.exe | 給紙トレイ一覧ツール
eurcvtfm.exe | Word/Excel変換コマンド
eurusenv.exe | EUR ユーザ環境削除ツール
eurspcsv.exe | 帳票定義ファイルの入出力コマンド
TemplateFile\ | SEWB用テンプレートファイルディレクトリ
Tool\Program\ | 共通ツールディレクトリ
expedf32.exe | EURフォントファイル作成ツール
Sample\ | サンプル格納ディレクトリ
（凡例）
%EUR%：EUR Designerのインストール先フォルダを示します。
デフォルトは「C:\Program Files\HITACHI\EUR」です。

(2)　EUR Viewerの場合

表A-2　EUR Viewerのインストール後に作成されるフォルダ

フォルダまたはファイル名 | 内容
%EURVW% | EUR Viewerのルートディレクトリ
1033\ | 英語リソースディレクトリ
1041\ | 日本語リソースディレクトリ
Help\ | ヘルプ格納ディレクトリ
eurvwr.chm | EUR クライアント帳票出力ヘルプ（統合ヘルプ）
eurvoutp.chm | マニュアル「EUR 帳票出力 EUR Designer/EUR Viewer編」のヘルプ
eurdb.chm | マニュアル「EUR データベース連携ガイド」のヘルプ
eurmes.chm | マニュアル「EUR メッセージ」のヘルプ
euroutp.chm | マニュアル「EUR クライアント帳票出力」のヘルプ
2052\ | 中国語リソースディレクトリ
Program\ | 実行ファイル格納ディレクトリ
apgrpt.exe | EUR Viewer実行ファイル
Eurer.exe | eurerコマンド
EurLgMnt.exe | ログメンテナンスツール
EurLgOpt.exe | ログメンテナンスオプション設定ツール
eurvw.exe | EURクライアント出力機能ツール
Eurtyl.exe | 給紙トレイ一覧ツール
eurusenv.exe | EUR ユーザ環境削除ツール
（凡例）
%EURVW%：EUR Viewerのインストール先フォルダを示します。
デフォルトは「C:\Program Files\HITACHI\EUR Viewer」です。


アンインストールの手順

付録A.3　アンインストールの手順

起動中のEUR提供ツールを終了したあと，コントロールパネルの［アプリケーションの追加と削除］メニューから実行してください。

EURをアンインストールする場合は，管理者権限またはAdministrators権限を持つユーザで，かつ半角英数字のログインユーザ名で行ってください。

アンインストールを実行すると，次に示す情報が削除されます。

  • 対象製品関連ファイル（フォルダを含む）の削除
  • スタートメニューの削除
  • レジストリの削除
＜この項の構成＞
(1)　アンインストール時の注意

(1)　アンインストール時の注意

  • アンインストールは，すべてのEURを終了させたあとに実行してください。
  • 管理者グループまたはAdministratorsグループに属するユーザで，半角英数字のログインユーザ名でアンインストールしてください。
  • ユーザが設定した環境は，アンインストールしても削除されません。ユーザ情報が残っていてもシステム上問題はありません。設定した環境を削除したい場合は，アンインストールする前に，スタートメニューから［EURユーザ環境削除］を選択してユーザ環境を削除してください。EURユーザ環境削除ツールについては，「付録B.4　EURユーザ環境削除ツール」を参照してください。
  • インストール後にユーザが作成できるファイル（環境設定ファイル「EUR_ENV」など）は，アンインストールを実行しても削除されません。ファイルを削除する場合は，エクスプローラなどから直接削除してください。
  • インストールしたロケールと同じロケールでアンインストールしてください。異なるロケールでアンインストールした場合，正常にアンインストールできないことがあります。


EURが提供するツール

付録B　EURが提供するツール

EURが提供するツールについて説明します。

＜この節の構成＞
付録B.1　給紙トレイ一覧ツール
付録B.2　EURログオプション設定ツール
付録B.3　EURログメンテナンスツール
付録B.4　EURユーザ環境削除ツール


給紙トレイ一覧ツール

付録B.1　給紙トレイ一覧ツール

給紙トレイ選択機能を使用する場合，プリンタの給紙トレイコードを指定します。

給紙トレイコードを指定するとき，プリンタの製造会社や機種によって，Windowsで規定されている給紙トレイコードと異なる場合があります。また，Windowsで規定されている給紙トレイコードであっても，プリンタドライバによって，給紙トレイ名と給紙トレイコードを独自に割り当てていると，期待したトレイから給紙されない場合があります。このような場合，出力先プリンタに対応した給紙トレイコードを，EURで提供している［給紙トレイ一覧］ツールで確認されることをお勧めします。

［給紙トレイ一覧］ツールの実行ファイル「Eurtyl.exe」は，次に示すフォルダに格納されています。ダブルクリックすると，［給紙トレイ一覧］ダイアログが表示されます。

  • EUR Designerの場合
    EUR Designerのインストール先フォルダ\Designer\Program\Eurtyl.exe
  • EUR Viewerの場合
    EUR Viewerのインストール先フォルダ\Program\Eurtyl.exe

［給紙トレイ一覧］ダイアログでは，出力先プリンタをリストボックスから選択すると，そのプリンタの給紙トレイ名と，対応する給紙トレイコードの一覧が表示されます。

表示された給紙トレイコードを指定することで，期待したトレイから給紙できます。給紙トレイの指定については，「5.12.1　オプション記述ファイルのキーワード」を参照してください。


EURログオプション設定ツール

付録B.2　EURログオプション設定ツール

ログ採取レベルを指定してログを採取する場合は，ログオプションを設定します。

ログオプションは，ログオプション設定ツールを起動して表示された，［EURログオプションの設定］ダイアログで設定します。

ログオプション設定ツールの実行ファイル「EurLgOpt.exe」は，EURの実行ファイル「apgrpt.exe」と同じフォルダに格納されている場合に起動できます。実行ファイル「EurLgOpt.exe」をダブルクリックして起動してください。

ログオプション設定ツールを起動すると，［EURログオプションの設定］ダイアログが表示されます。

なお，ログオプション設定ツールは複数起動しないでください。複数起動すると，起動中のツールが終了されます。

ログオプションの情報には，ログ採取のレベル，ログを出力するファイル，およびログメンテナンス方法を設定します。ログオプション設定ツールで設定したオプションをEURログオプションファイルへ保存することで，ログを採取できます。ログオプションの設定については，マニュアル「EUR システム設計ガイド」を参照してください。


EURログメンテナンスツール

付録B.3　EURログメンテナンスツール

ログ採取レベルを設定した場合，EURの処理が正常に終了してもログ情報が出力されるため，ログファイルの容量が増加します。そのため，EURログオプション設定ツールで指定されたオプションの情報に従って，ログファイルのメンテナンスを実行してください。

ログメンテナンスツールの起動には，次に示す方法があります。

  • スタートアップからの起動
    PCを起動すると，EURログメンテナンスツールが起動されます。
  • プログラムファイルからの起動
    EURログメンテナンスツールの実行ファイル名は，「eurlgmnt.exe」です。

ログメンテナンスツールの実行については，マニュアル「EUR システム設計ガイド」を参照してください。


EURユーザ環境削除ツール

付録B.4　EURユーザ環境削除ツール

ユーザ独自の環境を設定している場合，EURをアンインストールしても，ユーザ環境は削除されません。EURをアンインストールする前に，スタートメニューから［EUR ユーザ環境削除］を選択して，ユーザ環境を削除してください。

スタートメニューから［EUR ユーザ環境削除］を選択すると，［EURユーザ環境削除］ダイアログが表示されます。

［環境削除］ボタンをクリックしたあと，アンインストールを実行してください。ユーザ環境を設定していない場合は，［環境削除］は選択できません。


作業環境の言語との対応

付録C　作業環境の言語との対応

EURクライアント出力機能では，作業環境によって表示言語を切り替えたり，入力ファイルのエンコーディングを変更したりできます。ここでは，作業環境の言語と表示言語との対応，および作業環境の言語と入力ファイルのエンコーディング方式との対応について説明します。

＜この節の構成＞
付録C.1　表示言語の切り替え
付録C.2　入力ファイルのエンコーディング


表示言語の切り替え

付録C.1　表示言語の切り替え

EURクライアント出力機能では，次の表に示すように，システムの表示言語に適合した言語で表示します。

表C-1　Windows環境での表示言語の切り替え

システムの表示言語 | 言語ID | EURでの表示言語
日本語 | 1041 | 日本語
簡体中国語 | 2052 | 簡体中国語
英語 | 1033 | 英語
その他 | － | 英語
（凡例）
－：該当しません。


入力ファイルのエンコーディング

付録C.2　入力ファイルのエンコーディング

EURクライアント出力機能では，入力ファイルのデータの先頭にUnicode-BOMがある場合，Unicodeとして扱います。データの先頭にUnicode-BOMがない場合は，コードページに対応するシングルバイトまたはマルチバイトデータとして扱います。

＜この項の構成＞
(1)　BOMと対応するエンコーディング
(2)　BOMがない場合のエンコーディング

(1)　BOMと対応するエンコーディング

先頭に付与するBOMと対応するエンコーディング方式を次の表に示します。

表C-2　 Windows環境でのBOMと対応するエンコーディング方式

BOM | エンコーディング方式
FEFF | UTF-16（ビッグエンディアン）
FFFE | UTF-16（リトルエンディアン）
EFBBBF | UTF-8
なし | 対応する言語に従います。 詳細は，「付録C.2(2) BOMがない場合のエンコーディング」を参照してください。

(2)　BOMがない場合のエンコーディング

データの先頭にUnicode-BOMがない場合，入力ファイルのエンコーディングは，ファイルを入力するOS環境の言語によって決定されます。入力ファイルをOS環境の言語に対応したエンコーディングで変換した場合は，デフォルトのエンコーディングで変換されます。

デフォルトのエンコーディング方式は，次の表に示すように，コードページ別に設定されます。

表C-3　Windows環境でのコードページ別のエンコーディング方式

コードページ | 言語 | エンコーディング方式
1252 | 英語（US） | Windows：CP1252
936 | 簡体中国語 | GB-18030
932 | 日本語 | Windows-31J
その他 | － | ISO8859-1
（凡例）
－：該当しません。


このマニュアルの参考情報

付録D　このマニュアルの参考情報

このマニュアルを読むに当たっての参考情報を示します。

＜この節の構成＞
付録D.1　関連マニュアル
付録D.2　EUR バージョン9での製品体系の変更
付録D.3　EUR バージョン9でのマニュアル体系の変更
付録D.4　このマニュアルでの表記
付録D.5　このマニュアルで使用する略語
付録D.6　KB（キロバイト）などの単位表記について


関連マニュアル

付録D.1　関連マニュアル

関連マニュアルを次に示します。必要に応じてお読みください。

＜この項の構成＞
(1)　EURのマニュアル
(2)　関連ソフトウェアのマニュアル
(3)　このマニュアルでのマニュアル名表記

(1)　EURのマニュアル

EURの関連マニュアルを次に示します。

  • はじめての帳票作成（3020-7-532）※
    EUR 帳票作成機能をまだ使用したことのない人向けに，簡単な帳票を作成する方法について説明しています。
  • uCosminexus EUR システム設計ガイド（3020-7-702）
    EURを使用した帳票システムの計画・設計時に検討が必要な内容について説明しています。
  • uCosminexus EUR システム構築ガイド（3020-7-703）
    EURを使用した帳票システムを構築する手順について説明しています。
  • uCosminexus EUR 帳票作成 操作ガイド（3020-7-704）
    EUR帳票作成機能を使用して帳票を作成する方法について説明しています。
  • uCosminexus EUR 帳票作成 画面リファレンス（3020-7-705）
    EUR帳票作成機能で表示されるダイアログの内容について説明しています。
  • uCosminexus EUR 帳票設計（EUR Form帳票）（3020-7-534）※
    EUR Form帳票作成機能を使用してEUR Form帳票を作成する方法について説明しています。
  • uCosminexus EUR クライアント帳票出力（3020-7-535）※
    EUR クライアント帳票出力機能のV8互換機能を使用して，クライアント環境で帳票を出力する方法について説明しています。
  • uCosminexus EUR 帳票出力 機能解説 EUR Server編（3020-7-708）
    EUR サーバ帳票出力機能を使って帳票を出力する方法について説明しています。
  • uCosminexus EUR 帳票出力 リファレンス EUR Server編（3020-7-710）
    EUR サーバ帳票出力機能を使って帳票を出力するときに使用するAPIや入力ファイルの設定方法について説明しています。
  • uCosminexus EUR サーバ帳票出力（3020-7-536）※
    EUR ServerのV8互換機能を使用して，サーバ環境で帳票を出力する方法について説明しています。
  • uCosminexus EUR データベース連携ガイド（3020-7-713）
    データベースから抽出したデータを使って帳票を作成および出力する方法，およびEUR 帳票作成機能のデータベースアクセス定義ウィンドウを使用する方法について説明しています。また，データベースの操作時に出力されるメッセージについても説明しています。
  • uCosminexus EUR メッセージ（3020-7-714）
    EURを使用しているときに出力されるメッセージについて説明しています。
  • uCosminexus EUR 用語集（3020-7-715）
    EURシリーズマニュアル内で使用する用語について説明しています。なお，この用語集は日立ソフトウェアマニュアル公開サイト，または製品同梱のヘルプ（Windows版）だけで参照できます。
注※
バージョン8のマニュアルを提供しています。バージョン9の製品に置き換えて参照してください。

(2)　関連ソフトウェアのマニュアル

関連ソフトウェアのマニュアルを次に示します。

  • DABroker（3020-6-031）
  • DBPARTNER2 Client　操作ガイド（3020-6-027）
  • HiRDB Version 8 UAP開発ガイド（3020-6-356）
  • HiRDB Version 8 メッセージ（3020-6-358）
  • HiRDB Version 9 UAP開発ガイド（3020-6-456）
  • HiRDB Version 9 メッセージ（3020-6-458）
  • SEWB+/REPOSITORY 辞書設計ガイド（3020-3-698）
  • SEWB+/REPOSITORY 辞書設計ガイド（3020-3-N82）

(3)　このマニュアルでのマニュアル名表記

このマニュアルでは，マニュアル名について，次のように表記しています。

マニュアル名 | 表記
uCosminexus EUR システム設計ガイド | EUR システム設計ガイド
uCosminexus EUR システム構築ガイド | EUR システム構築ガイド
uCosminexus EUR 帳票作成 操作ガイド | EUR 帳票作成 操作ガイド
uCosminexus EUR 帳票作成 画面リファレンス | EUR 帳票作成 画面リファレンス
uCosminexus EUR 帳票出力 機能解説 EUR Server編 | EUR 帳票出力 機能解説 EUR Server編
uCosminexus EUR 帳票出力 リファレンス EUR Server編 | EUR 帳票出力 リファレンス EUR Server編
uCosminexus EUR 帳票出力 EUR Designer/EUR Viewer編 | EUR 帳票出力 EUR Designer/EUR Viewer編
uCosminexus EUR データベース連携ガイド | EUR データベース連携ガイド
uCosminexus EUR メッセージ | EUR メッセージ
uCosminexus EUR 用語集 | EUR 用語集
uCosminexus EUR 概説 | EUR 概説
uCosminexus EUR 帳票設計 | EUR 帳票設計
uCosminexus EUR 帳票設計（EUR Form帳票） | EUR 帳票設計（EUR Form帳票）
uCosminexus EUR クライアント帳票出力 | EUR クライアント帳票出力
uCosminexus EUR サーバ帳票出力 | EUR サーバ帳票出力
uCosminexus EUR Print Manager 帳票出力 | EUR Print Manager 帳票出力
uCosminexus EUR Print Manager メッセージ | EUR Print Manager メッセージ
HiRDB Version 8 UAP開発ガイド HiRDB Version 9 UAP開発ガイド | HiRDB UAP開発ガイド
HiRDB Version 8 メッセージ HiRDB Version 9 メッセージ | HiRDB メッセージ


EUR バージョン9での製品体系の変更

付録D.2　EUR バージョン9での製品体系の変更

EUR バージョン9での製品体系の変更について，次の図に示します。


EUR バージョン9でのマニュアル体系の変更

付録D.3　EUR バージョン9でのマニュアル体系の変更

EUR バージョン9では，マニュアル体系を次の表に示す各使用目的に合わせて次のとおり変更しました。

EUR バージョン8 | EUR バージョン9
次のマニュアルの，システム計画・設計に関連する部分
  • EUR 概説
  • EUR 帳票設計
  • EUR クライアント帳票出力
  • EUR サーバ帳票出力
  • EUR Print Manager 帳票出力
 EUR システム設計ガイド
次のマニュアルの，システム構築に関連する部分
  • EUR 帳票設計
  • EUR クライアント帳票出力
  • EUR サーバ帳票出力
  • EUR Print Manager 帳票出力
 EUR システム構築ガイド
EUR帳票設計（第1編～第4編） | EUR 帳票作成 操作ガイド
EUR 帳票設計（第5編） | EUR 帳票作成 画面リファレンス
次のマニュアルの，機能概要を説明している部分，およびコーディング例
  • EUR サーバ帳票出力
  • EUR Print Manager 帳票出力
 EUR 帳票出力 機能解説 EUR Server編
次のマニュアルの，各APIや入力ファイルの設定値を説明している部分
  • EUR サーバ帳票出力（7章のリファレンス部分）
  • EUR Print Manager 帳票出力（8章～15章）
 EUR 帳票出力 リファレンス EUR Server編
次のマニュアルの，機能概要，各APIや入力ファイルの設定値を説明している部分
  • EUR クライアント帳票出力
 EUR 帳票出力 EUR Designer/EUR Viewer編
次のマニュアルの，データベースから抽出したデータを使って帳票を作成および出力する方法を説明している部分
  • EUR 帳票設計
  • EUR クライアント帳票出力
  • EUR サーバ帳票出力
  • EUR メッセージ
 EUR データベース連携ガイド

  • EUR メッセージ
  • EUR Print Manager メッセージ
 EUR メッセージ

  • EUR 概説（付録A）
  • EUR Print Manager 帳票出力（付録H）
 EUR 用語集

EUR ServerのV8互換機能を使用する場合は，バージョン8対応のマニュアル「EUR サーバ帳票出力」を参照してください。Windows環境では，インストール先フォルダ\Print\1041\Help\eurps.chmに統合ヘルプが格納されています。

クライアント帳票出力機能のV8互換機能を使用する場合は，バージョン8対応のマニュアル「EUR クライアント帳票出力」を参照してください。Windows環境では，次のフォルダにヘルプが格納されています。

  • EUR Designerの場合
    EUR Designerのインストール先フォルダ\Designer\1041\Help\euroutp.chm
  • EUR Viewerの場合
    EUR Viewerのインストール先フォルダ\1041\Help\euroutp.chm


このマニュアルでの表記

付録D.4　このマニュアルでの表記

このマニュアルでは，uCosminexus EURの各製品について，次のように表記しています。

表記 |  | 製品名称
EUR Designer |  | uCosminexus EUR Designer
EUR Developer |  | uCosminexus EUR Developer
EUR Viewer |  | uCosminexus EUR Viewer
EUR Server | EUR Server Enterprise | uCosminexus EUR Server Enterprise
 | EUR Server Standard | uCosminexus EUR Server Standard
 | EUR Server Print Edition | uCosminexus EUR Server Print Edition
EUR Server - Cipher option |  | uCosminexus EUR Server - Cipher option
EUR Form | EUR Form Service | uCosminexus EUR Form Service
EUR Form Service - Data Store option |  | uCosminexus EUR Form Service - Data Store option

uCosminexus EUR以外の製品名称などについては，次のように表記しています。

表記 |  | 製品名称
COBOL |  | COBOL2002
DABroker |  | DABroker 03-17以降 DABroker 03-21以降 DABroker(64) 03-20以降 DABroker(64) 03-21以降
HiRDB |  | HiRDB/Run Time Version 8 08-00 以降 HiRDB/Developer's Kit Version 8 08-00 以降 HiRDB/Run Time Version 8(64) 08-00 以降 HiRDB/Developer's Kit Version 8(64) 08-00 以降 HiRDB/Run Time Version 9 09-00以降 HiRDB/Developer's Kit Version 9 09-00以降 HiRDB/Developer's Suite Version 9 09-00以降 HiRDB/Run Time Version 9(64) 09-00以降 HiRDB/Developer's Kit Version 9(64) 09-00以降 HiRDB Server Version 9 09-00以降 HiRDB Server with Additional Function Version 9 09-00以降
IPF |  | Itanium(R) Processor Family
Linux | Linux(R) | Red Hat Enterprise Linux Server 6 (64-bit x86_64)
ODBC Driver |  | EURODBC Driver
 |  | DBPARTNER ODBC Driver 01-11以降
Oracle | Oracle 10g | Oracle 10g 10.1.0 Oracle 10g 10.2.0
 | Oracle 11g | Oracle Database 11g 11.1.0 Oracle Database 11g R2 11.2.0
SEWB+ |  | Software Engineering Workbench+
UNIX | AIX | AIX V6.1 AIX V7.1
 | HP-UX | HP-UX 11i V3(IPF)

このほか，このマニュアルでは，次に示す表記を使用しています。

  • EURの各製品を区別する必要がない場合は，総称してEURと表記します。
  • EUR Designer，EUR Developerの帳票作成機能を「EUR 帳票作成機能」と表記します。
  • EUR DeveloperのEUR Form帳票作成機能を「EUR 帳票作成機能（EUR Form帳票）」と表記します。
  • EUR Designer，EUR Developer，EUR Viewerのクライアント環境での帳票出力機能を「EUR クライアント帳票出力機能」と表記します。
  • EUR Developer，EUR Print Service，EUR Print Service Enterpriseのサーバ環境での帳票出力機能を「EUR サーバ帳票出力機能」と表記します。
  • 25.4mm（参考値：1インチ）の倍数で帳票設計する場合に限り，その倍数を表す意味で，インチ，in，またはインチ（in）と表記します。
  • ダイアログのチェックボックスの操作で， [図データ] にすることを「オン」， [図データ] にすることを「オフ」と表記します。
  • 桁の数え方は，半角文字を1桁，全角文字を2桁と表記します。
  • メニュー項目，ダイアログ名，ダイアログのボタンなどは［］で，またキーボードのキーは＜＞で囲んで表記します。


このマニュアルで使用する略語

付録D.5　このマニュアルで使用する略語

このマニュアルで使用する英略語を次に示します。

英略語 | 英字での表記
API | Application Programming Interface
ASP | Active Server Pages
BOM | Byte Order Mark
COBOL | COmmon Business Oriented Language
CPI | Characters Per Inch
CSV | Comma Separated Value
DLL | Dynamic Linking Library
DPI | Dot Per Inch
EAN | European Article Number
EJB | Enterprise JavaBeans
EMF | Enhanced Metafile
EOF | End Of File
EUR | End-User Reporting
GIF | Graphics Interchange Format
GS1 | Global Standard 1
GUI | Graphical User Interface
HTTP | Hyper Text Transfer Protocol
ID | IDentifier
IPF | Itanium(R) Processor Family
ISO | International Organization for Standardization
JAN | Japanese Article Number
JDK | JavaTM Development Kit
JIS | Japanese Industrial Standards
JPEG | Joint Photographic Experts Group
JSP | Java Server Pages
LAN | Local Area Network
LDAP | Lightweight Directory Access Protocol
LIPS | LBP Image Processing System
LPI | Lines Per Inch
MFC | Microsoft Foundation Class
MIME | Multipurpose Internet Mail Extensions
MSI | Microsoft Windows Installer
MUI | Multi User Interface
OCR | Optical Character Reader
OCX | OLE Custom Control (OLE Control eXtension)
ODBC | Open Database Connectivity
OLE | Object Linking and Embedding
PCF | Portable Compiled Format
PDF | Portable Document Format
PDL | Page Description Language
PNG | Portable Network Graphics
RPM | RPM Package Manager
SSL | Secure Sockets Layer
TCP/IP | Transmission Control Protocol/Internet Protocol
TIFF | Tagged Image File Format
TLS | Transport Layer Security
UAP | User Application Program
UCC | Uniform Commercial Code
UCS | Universal multi-octet coded Character Set
UDC | User Defined Character
UPC | Universal Product Code
VBA | Visual Basic for Applications
WAN | Wide Area Network
XML | eXtensible Mark-up Language


KB（キロバイト）などの単位表記について

付録D.6　KB（キロバイト）などの単位表記について

1KB（キロバイト），1MB（メガバイト），1GB（ギガバイト），1TB（テラバイト）はそれぞれ1,024バイト，1,0242バイト，1,0243バイト，1,0244バイトです。


索引

[記号]
[Ａ][Ｂ][Ｃ][Ｄ][Ｅ][Ｆ][Ｇ][Ｈ][Ｉ][Ｊ][Ｋ][Ｌ][Ｍ][Ｎ][Ｏ][Ｐ][Ｑ][Ｒ][Ｓ][Ｔ][Ｕ][Ｖ][Ｗ][Ｚ]
[ア行][カ行][サ行][タ行][ナ行][ハ行][マ行][ヤ行][ラ行]

(記号)

.agr

(英字)

(Ａ)
Activateメソッド〔OLEオートメーション〕
APGRPT.Report〔EURのプログラムID〕
apgrptコマンドからの印刷
apgrptコマンドで指定できること
apgrptコマンドのオプションの説明
apgrptコマンドの形式
Applicationプロパティ〔OLEオートメーション〕
(Ｂ)
BarcodeImageSize〔プリンタ定義ファイルのキーワード〕
(Ｃ)
COBOL言語で帳票を印刷する
COBOL言語プログラム
CODE128PARAM〔プリンタ定義ファイルのキーワード〕
CODE128PATTERN〔プリンタ定義ファイルのキーワード〕
CODE128バーコード
CODE39バーコード
CreateDateメソッド〔OLEオートメーション〕
CreateObject関数による起動
CSV形式（DAT形式）のデータ形式〔EURで扱えるデータファイル〕
CurrentPageプロパティ〔OLEオートメーション〕
(Ｄ)
DataFileNameプロパティ〔OLEオートメーション〕
DataFileプロパティ〔OLEオートメーション〕
DBInfoFileName〔オプション記述ファイルのキーワード〕
DBInfoFileNameプロパティ〔OLEオートメーション〕
DBInfoFilePath〔オプション記述ファイルのキーワード〕
DBInfoFilePathプロパティ〔OLEオートメーション〕
Documentプロパティ〔OLEオートメーション〕
DrawBarStyle〔プリンタ定義ファイルのキーワード〕
(Ｅ)
Editableプロパティ〔OLEオートメーション〕
EUR_CODE128_PARAM〔環境設定ファイルに設定する変数〕
EUR_ENV
EUR_ENVFILE
EUR_ENVFILE〔環境設定ファイルで設定できない変数〕
EUR_FIXOPT〔環境設定ファイルで設定できない変数〕
EUR_FONT_ROUNDDOWN〔環境設定ファイルに設定する変数〕
EUR_TMPPATH〔環境設定ファイルに設定する変数〕
EUR_UPC_BARCODE〔環境設定ファイルに設定する変数〕
eurerコマンド実行時の終了コード一覧
eurerコマンドで指定できること
eurerコマンドのオプションの説明
eurerコマンドの形式
eurerコマンドの実行形態
EurLgOpt.exe〔EURログオプション設定ツール〕
Eurtyl.exe〔給紙トレイ一覧ツール〕
EUR起動時のウィンドウの指定〔オプション記述ファイル〕
EUR クライアント帳票出力機能
［EURクライアント帳票出力機能］ダイアログ
［EURクライアント帳票出力機能］ダイアログを使用したプレビューと帳票出力
EUR形式ファイル
EURで扱える画像データ
EURで扱える帳票ファイル
EURで扱えるデータファイル
EURのオブジェクト階層〔OLEオートメーション〕
EURのプログラムID〔APGRPT.Report〕
［EURユーザ環境削除］ダイアログ
EURユーザ環境削除ツール
EURログオプション設定ツール
［EURログオプションの設定］ダイアログ
EURログメンテナンスツール
［EURログメンテナンスツール］ダイアログ
(Ｆ)
fieldname〔複数様式情報定義ファイルのキーワードformtransfercondition〕
fieldname〔複数様式情報定義ファイルのキーワードgrouptransfercondition〕
FileName〔オプション記述ファイルのキーワード〕
FirstPageNumberプロパティ〔OLEオートメーション〕
FitToWindowプロパティ〔OLEオートメーション〕
FIX形式のデータ形式〔EURで扱えるデータファイル〕
FontWidthMode〔オプション記述ファイルのキーワード〕
FontWidthModeプロパティ〔OLEオートメーション〕
formfilename〔複数様式情報定義ファイルのキーワード〕
formfilenameの形式〔複数様式情報定義ファイル〕
formtransfercondition〔複数様式情報定義ファイルのキーワード〕
formtransferconditionの形式〔複数様式情報定義ファイル〕
FrontSubWindowプロパティ〔OLEオートメーション〕
FullNameプロパティ〔OLEオートメーション〕
(Ｇ)
GetObject関数
group〔複数様式情報定義ファイル〕
grouptransfercondition〔複数様式情報定義ファイル〕
grouptransferconditionの形式〔複数様式情報定義ファイル〕
groupの形式〔複数様式情報定義ファイル〕
GS1-128（UCC/EAN-128）バーコード
(Ｈ)
Heightプロパティ〔OLEオートメーション〕
(Ｉ)
ImageBasePathプロパティ〔OLEオートメーション〕
ImageFilePath〔オプション記述ファイルのキーワード〕
Importメソッド〔OLEオートメーション〕
InitPageNumberプロパティ〔OLEオートメーション〕
ITFバーコード
(Ｊ)
JAN短縮バーコード
JAN標準バーコード
(Ｋ)
keybreaktopform〔複数様式情報定義ファイルのキーワード〕
(Ｌ)
LastPageプロパティ〔OLEオートメーション〕
Leftプロパティ〔OLEオートメーション〕
(Ｍ)
MainWindowStatusプロパティ〔OLEオートメーション〕
MapDataBasePathプロパティ〔OLEオートメーション〕
MappingDataFile〔オプション記述ファイルのキーワード〕
MappingDataPath〔オプション記述ファイルのキーワード〕
MappingDataプロパティ〔OLEオートメーション〕
MultiFormInfoDefBasePathプロパティ〔OLEオートメーション〕
MultiFormInfoDefFile〔オプション記述ファイルのキーワード〕
MultiFormInfoDefFileプロパティ〔OLEオートメーション〕
MultiFormInfoDefPath〔オプション記述ファイルのキーワード〕
MultiReportSetBasePathプロパティ〔OLEオートメーション〕
MultiReportSetFile〔オプション記述ファイルのキーワード〕
MultiReportSetFileプロパティ〔OLEオートメーション〕
MultiReportSetPath〔オプション記述ファイルのキーワード〕
(Ｎ)
Nameプロパティ〔OLEオートメーション〕
Numbering〔オプション記述ファイルのキーワード〕
NumberingFormat〔オプション記述ファイルのキーワード〕
NumberingFrom〔オプション記述ファイルのキーワード〕
NumberingPos〔オプション記述ファイルのキーワード〕
NumberingReset〔オプション記述ファイルのキーワード〕
NW-7バーコード
(Ｏ)
OLEオートメーションからの印刷
OLEオートメーションで指定できること
OLEオートメーションで使用できるプロパティ一覧
OLEオートメーションで使用できるメソッド一覧
Openメソッド〔OLEオートメーション〕
(Ｐ)
PageNumberFormatプロパティ
PageNumberLocationプロパティ〔OLEオートメーション〕
PageSetupプロパティ〔OLEオートメーション〕
PaperOrientation〔オプション記述ファイルのキーワード〕
PaperOrientationプロパティ〔OLEオートメーション〕
PaperShiftX〔プリンタ定義ファイルのキーワード〕
PaperShiftY〔プリンタ定義ファイルのキーワード〕
Parentプロパティ〔OLEオートメーション〕
Pathプロパティ〔OLEオートメーション〕
PrintEndPage〔オプション記述ファイルのキーワード〕
PrinterName〔オプション記述ファイルのキーワード〕
PrinterNameプロパティ〔OLEオートメーション〕
PrintFileName〔オプション記述ファイルのキーワード〕
PrintFileNameプロパティ〔OLEオートメーション〕
PrintFileOutプロパティ〔OLEオートメーション〕
PrintFinishing〔オプション記述ファイルのキーワード〕
printnewpaper〔複数様式情報定義ファイルのキーワード〕
PrintOutメソッド〔OLEオートメーション〕
PrintPageNumberプロパティ〔OLEオートメーション〕
PrintSet〔オプション記述ファイルのキーワード〕
PrintStartPage〔オプション記述ファイルのキーワード〕
PrintStatusプロパティ〔OLEオートメーション〕
Printメソッド〔OLEオートメーション〕
(Ｑ)
QRコード
Quitメソッド〔OLEオートメーション〕
(Ｒ)
ReplaceItemCntlFile〔オプション記述ファイルのキーワード〕
ReplaceItemCntlFilePath〔オプション記述ファイルのキーワード〕
ReplaceItemCntlFilePathプロパティ〔OLEオートメーション〕
ReplaceItemCntlFileプロパティ〔OLEオートメーション〕
ReplaceItemFilePath〔オプション記述ファイルのキーワード〕
ReplaceItemFilePathプロパティ〔OLEオートメーション〕
ReportBasePathプロパティ〔OLEオートメーション〕
ReportFilePath〔オプション記述ファイルのキーワード〕
ReportTitle〔オプション記述ファイルのキーワード〕
ReportTitleプロパティ〔OLEオートメーション〕
resetpagenumber〔複数様式情報定義ファイルのキーワード〕
(Ｓ)
Sortingプロパティ〔OLEオートメーション〕
subgroup〔複数様式情報定義ファイルのキーワード〕
subgroupの形式〔複数様式情報定義ファイル〕
SubWindowStatusプロパティ〔OLEオートメーション〕
(Ｔ)
Topプロパティ〔OLEオートメーション〕
transfercondition〔複数様式情報定義ファイルのキーワード〕 ,[2]
TrayCode〔オプション記述ファイルのキーワード〕
traycode〔複数様式情報定義ファイルのキーワード〕
TrayCodeプロパティ〔OLEオートメーション〕
TraySelection〔オプション記述ファイルのキーワード〕
TraySelectionプロパティ〔OLEオートメーション〕
(Ｕ)
UPC-Aバーコード
UPC-Eバーコード
UserDataBasePathプロパティ〔OLEオートメーション〕
UserDefDataFile〔オプション記述ファイルのキーワード〕
UserDefDataPath〔オプション記述ファイルのキーワード〕
UserDefineDataプロパティ〔OLEオートメーション〕
(Ｖ)
VarDataFileプロパティ〔OLEオートメーション〕
Visibleプロパティ〔OLEオートメーション〕
(Ｗ)
Widthプロパティ〔OLEオートメーション〕
WindowStyle〔オプション記述ファイルのキーワード〕
WindowStyleプロパティ〔OLEオートメーション〕
(Ｚ)
ZoomRate〔オプション記述ファイルのキーワード〕
Zoomプロパティ〔OLEオートメーション〕

(ア行)

(あ)
アンインストール
アンインストール時の注意
(い)
印刷時に使用するデータファイルの注意
印刷に関する注意
印刷ページの選択〔オプション記述ファイル〕
インストール
インストール，アンインストール時の注意
インストール時の注意
(お)
置き換え表管理情報ファイル
置き換え表管理情報ファイルの作成
置き換え表管理情報ファイルの保存場所
置き換え表管理情報ファイル名の指定〔オプション記述ファイル〕
置き換え表ファイル
置き換え表ファイルの作成
置き換え表ファイルの保存場所
オプション記述ファイル
オプション記述ファイルのキーワード
オプション記述ファイルの記述例
［オプション］ダイアログ

(カ行)

(か)
カスタマバーコード
画像ファイル
可変記号値
可変記号値定義ファイル
環境設定ファイル
環境設定ファイルの構文
環境設定ファイルの指定例
環境設定ファイルの変数
(き)
給紙トレイ一覧ツール
給紙トレイの指定〔オプション記述ファイル〕
(こ)
光学式読み取り装置で帳票を読み取る場合の注意
固定ピッチフォントの文字幅計算方法の指定〔オプション記述ファイル〕
コマンドに指定したデータの優先順位

(サ行)

(さ)
サービス起動で印刷する場合の注意
最上位結合項目を利用する帳票を印刷する場合の注意
作業環境の言語との対応
サブ様式グループ
サブ様式グループ番号〔複数様式情報定義ファイル〕
(し)
出力先での帳票名表示の指定〔オプション記述ファイル〕
出力できるバーコードの最小サイズ
出力ページ数の上限値
使用するエンコーディング
(す)
［ズーム］ダイアログ
ズーム倍率の指定〔オプション記述ファイル〕
(せ)
接続情報ファイル
接続情報ファイルの指定〔オプション記述ファイル〕

(タ行)

(ち)
帳票出力で使用できるインターフェース
帳票設計で使用できるフォント
帳票セット
帳票セット指定ファイル
帳票セット指定ファイルの形式
帳票セット指定ファイルの指定例
帳票セット指定ファイルの編集
帳票セットの形式
帳票の印刷範囲
帳票の出力先の指定〔オプション記述ファイル〕
帳票ファイルのダブルクリックによるプレビューと出力
帳票ファイル名の指定〔オプション記述ファイル〕
(て)
ディクショナリファイル
データファイルのサイズに関する注意
データファイルを使用する場合
データベースからデータを入力する場合に使用できる文字
データベースを使用する場合

(ナ行)

(に)
入力ファイルに対するエンコーディング

(ハ行)

(は)
バーコードの印刷の注意
バーコードの注意
(ひ)
［表示］タブ
(ふ)
ファイルサイズの上限値〔CSV形式（DAT形式）〕
ファイルサイズの上限値〔FIX形式〕
［ファイル］タブ
ファイルのパス指定〔オプション記述ファイル〕
ファイル名に指定できる文字〔EURで使用するファイル名〕
ファイル名の制約
ファイル名の長さ〔EURで使用するファイル名〕
複数様式情報定義ファイル
複数様式情報定義ファイルの指定例
複数様式で帳票を出力
複数様式での帳票出力の指定〔オプション記述ファイル〕
複数様式の帳票を印刷する場合の注意
プリンタ解像度ごとのバーコード最小サイズ
プリンタ定義ファイル
プリンタ定義ファイルのキーワード
プリンタ定義ファイルの構文
プリンタ定義ファイルの作成
(へ)
ページ番号の印刷指定〔オプション記述ファイル〕

(マ行)

(ま)
マッピングデータ用のファイルの指定〔オプション記述ファイル〕

(ヤ行)

(ゆ)
ユーザ定義サイズを設定した帳票を印刷する場合の注意
ユーザ定義データ用のファイルの指定〔オプション記述ファイル〕
(よ)
様式グループ
様式グループ番号〔複数様式情報定義ファイル〕
用紙の向きの指定〔オプション記述ファイル〕

(ラ行)

(り)
リモートインストール
(れ)
レコードの上限値〔FIX形式〕
レポートファイル