HiRDB構築支援ツール HiRDB Configuration Assistant - 目次

HiRDB構築支援ツール

HiRDB Configuration Assistant

ヘルプ

3020-6-45E-70

目　　次

前書き
変更内容
はじめに

1.　HiRDB Configuration Assistantとは
1.1　機能概要
1.1.1　HiRDBの設計情報入力補助
1.1.2　既存HiRDBの構成情報取り込み
1.1.3　HiRDBの環境構築支援
1.1.4　HiRDBの設計ドキュメント出力
1.2　前提環境
1.2.1　推奨システム環境
1.2.2　システム構築・メンテナンス対象のHiRDB
1.3　前提知識

2.　インストール・アンインストール
2.1　プログラムの構成
2.1.1　フォルダ構成
2.1.2　レジストリ情報
2.2　インストール手順
2.2.1　新規インストール
2.2.2　修復インストール
2.3　アンインストール手順

3.　基本説明
3.1　HiRDB構成情報
3.2　構成要素
3.2.1　構成要素とは
3.2.2　構成要素の表示形式
3.2.3　構成要素の親子関係
3.2.4　構成要素の状態
3.2.5　構成要素の操作
3.2.6　構成要素と構成要素定義情報の関係
3.2.7　構成要素定義情報のオペランド
3.3　画面構成
3.3.1　基本画面
3.3.2　構成情報ビュー
3.3.3　詳細ダイアログ
3.3.4　HiRDB構成初期情報ダイアログ
3.4　基本操作
3.4.1　構成要素の追加
3.4.2　構成要素の削除
3.4.3　構成要素の移動
3.4.4　構成要素の複写
3.4.5　構成要素の情報参照
3.4.6　構成要素の情報更新

4.　HiRDB構築手順
4.1　新しくHiRDBを構築する
4.1.1　HiRDBの構成を定義する
4.1.2　HiRDB構成情報ファイルを保存する
4.1.3　システム定義のチェックを行う
4.1.4　メモリ・ディスクサイズのチェックを行う
4.1.5　定義ファイル，環境構築用バッチファイルを出力する
4.1.6　定義ファイル，環境構築用バッチファイルの内容を確認する
4.1.7　定義ファイル，環境構築用バッチファイルをHiRDBを構築するマシンに配置する
4.1.8　定義ファイルの構文チェックを行う
4.1.9　HiRDBファイルシステム領域を作成する
4.1.10　システムファイルを作成する
4.1.11　システムファイルの定義を含む定義ファイルのチェックを行う
4.1.12　HiRDBを開始する
4.1.13　データベースを初期化する
4.1.14　レジストリ用RDエリア，およびデータディクショナリ用RDエリア（再編成時期予測用）を追加する
4.1.15　構築中にエラーが発生した場合の対処方法
4.2　既存HiRDBの構成を取り込んで，構成変更する
4.2.1　構築済みのHiRDB環境から，HiRDB構成情報を取り込む（確定状態取り込み）
4.2.2　HiRDBの構成を変更する
4.2.3　HiRDB構成情報ファイルを保存する
4.2.4　システム定義のチェックを行う
4.2.5　メモリ・ディスクサイズのチェックを行う
4.2.6　定義ファイル，環境構築用バッチファイルを出力する
4.2.7　定義ファイル，環境構築用バッチファイルの内容を確認する
4.2.8　HiRDBを停止する
4.2.9　定義ファイル，環境構築用バッチファイルを構成変更対象のHiRDBを構成するマシンに配置する
4.2.10　定義ファイルの構文チェックを行う
4.2.11　HiRDBファイルシステム領域を追加する
4.2.12　システムファイルの定義を含む定義ファイルのチェックを行う
4.2.13　HiRDBシステムファイルを変更する
4.2.14　HiRDBを開始する
4.2.15　RDエリアを変更する
4.2.16　HiRDBファイルシステム領域を削除する
4.2.17　構築中にエラーが発生した場合の対処方法
4.3　既存HiRDBの構成を参考に，新しくHiRDBを構築する
4.3.1　構築済みのHiRDB環境から，HiRDB構成情報を取り込む（新規状態取り込み）
4.3.2　新しいHiRDBの環境に合わせて，HiRDBの構成を変更する
4.3.3　HiRDB構成情報ファイルを保存する
4.3.4　システム定義のチェックを行う
4.3.5　メモリ・ディスクサイズのチェックを行う
4.3.6　定義ファイル，環境構築用バッチファイルを出力する
4.3.7　定義ファイル，環境構築用バッチファイルの内容を確認する
4.3.8　定義ファイル，環境構築用バッチファイルをHiRDBを構築するマシンに配置する
4.3.9　定義ファイルの構文チェックを行う
4.3.10　HiRDBファイルシステム領域を作成する
4.3.11　システムファイルを作成する
4.3.12　システムファイルの定義を含む定義ファイルのチェックを行う
4.3.13　HiRDBを開始する
4.3.14　データベースを初期化する
4.3.15　レジストリ用RDエリア，およびデータディクショナリ用RDエリア（再編成時期予測用）を追加する
4.3.16　構築中にエラーが発生した場合の対処方法
4.4　HiRDBの構成に関するドキュメントを出力する
4.4.1　出力できるドキュメントと形式
4.4.2　設計ドキュメントを出力する
4.4.3　設計ドキュメントの利用例

付録
付録A　メッセージ
付録A.1　メッセージの出力形式
付録A.2　メッセージの記述形式
付録A.3　メッセージ一覧
付録B　定義ファイル
付録B.1　定義ファイルの一覧
付録B.2　定義ファイルの詳細
付録C　環境構築用バッチファイル
付録C.1　環境構築用バッチファイルの一覧
付録C.2　環境構築用バッチファイルの詳細
付録C.3　環境構築用バッチファイル実行時の注意事項
付録D　構成要素と，出力する定義ファイル，および環境構築用バッチファイルの対応関係
付録E　文字コード変換要否判定
付録F　HiRDB構成情報の指定内容の詳細
付録G　環境構築例
付録G.1　系切り替え構成の構築
付録H　サンプルファイル
付録H.1　サンプルファイルの格納場所
付録H.2　サンプルファイルのHiRDB構成
付録H.3　サンプルファイルの構成要素の状態
付録I　用語解説

[他社商品名称に関する表示]

All Rights Reserved. Copyright (C) 2011, 2019, Hitachi, Ltd.
All Rights Reserved. Copyright (C) 2011, 2019, Hitachi Solutions West Japan, Ltd.


前書き

■ 対象製品

R-15435-114　 HiRDB Configuration Assistant　 01-07　（適用OS：Windows 7，Windows 8，Windows 8.1，Windows 10，Windows Server 2008，Windows Server 2008 R2，Windows Server 2012，Windows Server 2012 R2，Windows Server 2016，Windows Server 2019）

  ※　ただし，システム定義のチェックを行う場合は，
      Windows Subsystem for UNIX-based Applications（SUA）をサポートしているOSをご使用ください。

■ 輸出時の注意

本製品を輸出される場合には，外国為替および外国貿易法ならびに米国の輸出管理関連法規などの規制をご確認の上，必要な手続きをお取りください。
なお，ご不明な場合は，弊社担当営業にお問い合わせください。

■ 商標類

HITACHI，HiRDBは，株式会社 日立製作所の商標または登録商標です。
Microsoftは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
Excelは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
Windowsは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
Windows Serverは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
IBM，AIXは，世界の多くの国で登録されたInternational Business Machines Corporationの商標です。
Linuxは，Linus Torvalds氏の日本およびその他の国における登録商標または商標です。
OracleとJavaは，Oracle Corporation 及びその子会社，関連会社の米国及びその他の国における登録商標です。
UNIXは，The Open Groupの米国ならびに他の国における登録商標です。
その他記載の会社名，製品名などは，それぞれの会社の商標もしくは登録商標です。

■ マイクロソフト製品のスクリーンショットの使用について

Microsoft Corporationのガイドラインにしたがって画面写真を使用しています。

■ 発行

2019年3月

■ 著作権

All Rights Reserved. Copyright (C) 2011, 2019, Hitachi, Ltd.
All Rights Reserved. Copyright (C) 2011, 2019, Hitachi Solutions West Japan, Ltd.

[目次][前へ][次へ]


他社商品名称に関する表示

HiRDB構築支援ツール　HiRDB Configuration Assistant

■ 商標類

HITACHI，HiRDBは，株式会社 日立製作所の商標または登録商標です。
Microsoftは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
Excelは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
Windowsは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
Windows Serverは，米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。
AIXは，世界の多くの国で登録されたInternational Business Machines Corporationの商標です。
Linuxは，Linus Torvalds氏の日本およびその他の国における登録商標または商標です。
OracleとJavaは，Oracle Corporation 及びその子会社，関連会社の米国及びその他の国における登録商標です。
UNIXは，The Open Groupの米国ならびに他の国における登録商標です。
その他記載の会社名，製品名などは，それぞれの会社の商標もしくは登録商標です。

[目次]


変更内容

変更内容　HiRDB Configuration Assistant 01-07

追加・変更内容 | 変更箇所
HiRDB Version 10 10-01に対応しました。 | 1.2.2 表H-1

単なる誤字・脱字等はお断りなく変更しました。

変更内容　HiRDB Configuration Assistant 01-06

追加・変更内容 | 変更箇所
HiRDB Version 10 10-00に対応しました。 | 1.2.2 表3-6 duplicated_file_system 表H-1
HiRDB構成情報の取り込み手順を修正しました。 | 表4-21

変更内容　HiRDB Configuration Assistant 01-05

追加・変更内容 | 変更箇所
HiRDB Version 9 09-66に対応しました。 | 1.2.2 表H-1

変更内容　HiRDB Configuration Assistant 01-04

追加・変更内容 | 変更箇所
HiRDB Version 9 09-65に対応しました。 | 1.2.2 表H-1

変更内容　HiRDB Configuration Assistant 01-03

追加・変更内容 | 変更箇所
HiRDB構成情報をウィザード形式で作成できるようになりました。 | 1.1.1 3.3.1(1) 4.1.1(1) 付録F
HiRDBの推奨値のチェックを行うようになりました。 | 3.3.1 3.3.2 4.4.1(1)

変更内容　HiRDB Configuration Assistant 01-02

追加・変更内容 | 変更箇所
システム定義のチェックが行えるようになりました。 | 3.3.1(1) 4.1 4.1.3 4.2 4.2.4 4.3 4.3.4 付録A 付録I
メモリ・ディスクサイズのチェックが行えるようになりました。 | 3.3.1(1) 4.1 4.1.4 4.2 4.2.5 4.3 4.3.5 付録A 付録I

変更内容　HiRDB Configuration Assistant 01-01

追加・変更内容 | 変更箇所
新規定義取り込みを行えるようになりました。 | 3.1 3.2.4 3.3.1 3.3.3(1) 3.3.4 3.4 4.2.1 4.2.7 4.3 付録H 付録I
HiRDB構成情報をまとめて置換できるようになりました。 | 3.3.1(1) 3.4 3.4.1 3.4.3 3.4.4 3.4.6(1) 3.4.6(2) 3.4.6(6) 4.3.2 付録A
環境構築用バッチファイルの先頭部に，バッチファイル情報（バッチファイルをHiRDB Configuration Assistantを使用して作成したこと，作成日付，操作対象のHiRDB識別子）を出力するようにしました。 | 付録C.2
HiRDB Configuration Assistant固有のオペランドに，temporaty_table（当該RDエリアを一時表用RDエリアとして使用するかどうか）を追加しました。 | 3.2.7(1) 3.4

変更内容　HiRDB Configuration Assistant 01-00-01

追加・変更内容 | 変更箇所
HiRDB構成情報の取り込みを，HiRDB Configuration Assistantが提供するHiRDB構成情報取り込みツールを使用して行えるようになりました。 | 2.1.1 4.2.1


はじめに

このヘルプはHiRDB Configuration Assistantの操作方法について説明したものです。

対象読者

HiRDB Configuration Assistantを使って，次の作業をする方を対象としています。

  • HiRDBの構築，メンテナンスをする方

また，HiRDBの構築に関する基本的な知識をお持ちの方を前提としています。HiRDBの仕様に関しては，HiRDBのマニュアルをご参照ください。

マニュアルの構成

このマニュアルは，次に示す章と付録から構成されています。

第１章　HiRDB Configuration Assistantとは
HiRDB Configuration Assistantの機能概要，および前提環境について説明しています。

第２章　インストール・アンインストール
HiRDB Configuration Assistantの構成と，インストール手順，およびアンインストール手順について説明しています。

第３章　基本説明
HiRDB Configuration Assistantを操作するために知っておく必要がある基本的な項目（HiRDB構成情報，構成要素，画面構成，および基本操作）について説明しています。

第４章　HiRDB構築手順
HiRDB Configuration Assistantを使ったHiRDB構築手順を，利用用途に応じて説明しています。

付録A　メッセージ
HiRDB Configuration Assistantが出力するエラーメッセージと，その対処方法について説明しています。

付録B　定義ファイル
HiRDB Configuration Assistantが出力する定義ファイルの一覧，およびその詳細を説明しています。

付録C　環境構築用バッチファイル
HiRDB Configuration Assistantが出力する環境構築用バッチファイルの一覧，およびその詳細を説明しています。

付録D　構成要素と，出力する定義ファイル，および環境構築用バッチファイルの対応関係
HiRDB Configuration Assistantで行う構成要素に対する操作と，出力する定義ファイル，および環境構築用バッチファイルの対応関係について説明しています。

付録E　文字コード変換要否判定
HiRDB Configuration Assistantが出力する定義ファイル，および環境構築用バッチファイルをHiRDBの環境に配置するとき，文字コードの変換が必要かどうか判定する方法を説明しています。

付録F　HiRDB構成情報の指定内容の詳細
HiRDB Configuration Assistantで，ウィザード形式でHiRDB構成情報を新規作成する場合の，指定内容の詳細を説明しています。

付録G　環境構築例
HiRDB Configuration Assistantを使用してHiRDBの環境を構築する例を示します。

付録H　サンプルファイル
HiRDB Configuration Assistantが提供するサンプルファイルの詳細を説明しています。

付録I　用語解説
このヘルプで使用する用語の意味を説明しています。

読書手順

このヘルプは，利用目的に合わせて章を選択してお読みいただけます。次に示す表を参考にして，お読みになる章を選択してください。

ヘルプを読む目的 | 記述個所
HiRDB Configuration Assistantの機能や前提環境を知りたい | １章
HiRDB Configuration Assistantのインストールやアンインストール方法を知りたい | ２章
HiRDB Configuration Assistantを操作するための基本的な項目（HiRDB構成情報，構成要素，画面構成，および基本操作）が知りたい | ３章
HiRDB Configuration Assistantを使ったHiRDB構築手順を，シーンに応じて知りたい | ４章
HiRDB Configuration Assistantが出力するメッセージとその対処方法を知りたい | 付録A
HiRDB Configuration Assistantが出力する定義ファイルの詳細が知りたい | 付録B
HiRDB Configuration Assistantが出力する環境構築用バッチファイルの詳細が知りたい | 付録C
HiRDB Configuration Assistant上での操作と，HiRDB Configuration Assistantが出力するファイルの対応を知りたい | 付録D
HiRDB Configuration Assistantが出力する定義ファイル，および環境構築用バッチファイルの文字コード変換が必要かどうか知りたい | 付録E
HiRDB Configuration Assistantで，ウィザード形式でHiRDB構成情報を新規作成する場合に，指定した内容の詳細が知りたい | 付録F
HiRDB Configuration Assistantを使用してHiRDBの環境を構築する例を参考にしたい | 付録G
HiRDB Configuration Assistantが提供するサンプルファイルの詳細が知りたい | 付録H
ヘルプ内で使用されている用語を調べたい | 付録I

このヘルプでの記号について

このヘルプで使用する記号を次のように定義しています。

記号 | 意味
「 」 | 画面に表示される項目を示します。
［ ］ | 画面の名称，メニュータイトル，メニュー項目，ボタン，およびアイコンの名称を示します。 例：［ファイル］メニュー ［OK］ボタン ［Enter］キー など。
［ ］－［ ］ | 最初に示したメニューからコマンドを選択することを示します。 例：［ファイル］－［開く］ ［ファイル］メニューから［開く］コマンドを選択することを示します。

KB（キロバイト）などの単位表記について

1KB（キロバイト），1MB（メガバイト），1GB（ギガバイト），1TB（テラバイト）はそれぞれ1,024バイト，1,0242バイト，1,0243バイト，1,0244バイトです。

略称説明について

本資料では，

HP-UX 11i V2 (IPF)および
HP-UX 11i V3 (IPF)を
HP-UXに，
AIX 5L V5.2および
AIX 5L V5.3および
AIX V6.1および
AIX V7.1を
AIXに，
Linux(R)および
Red Hat Enterprise Linux(R) AS 4(AMD64 & Intel EM64T)および
Red Hat Enterprise Linux(R) AS 4(x86)および
Red Hat Enterprise Linux(R) ES 4(AMD64 & Intel EM64T)および
Red Hat Enterprise Linux(R) ES 4(x86)および
Red Hat Enterprise Linux(R) 5 Advanced Platform (x86)および
Red Hat Enterprise Linux(R) 5 (x86)および
Red Hat Enterprise Linux(R) 5 Advanced Platform (AMD/Intel 64)および
Red Hat Enterprise Linux(R) 5 (AMD/Intel 64)および
Red Hat Enterprise Linux(R) 6 (32-bit x86)および
Red Hat Enterprise Linux(R) 6 (64-bit x86_64)および
Red Hat Enterprise Linux(R) 7 (64-bit x86_64)および
Red Hat Enterprise Linux(R) AS 4(AMD64 & Intel EM64T)および
Red Hat Enterprise Linux(R) ES 4(AMD64 & Intel EM64T)および
Red Hat Enterprise Linux(R) 5 Advanced Platform (AMD/Intel 64)および
Red Hat Enterprise Linux(R) 5 (AMD/Intel 64)および
Red Hat Enterprise Linux(R) 6 (64-bit x86_64)および
Red Hat Enterprise Linux(R) 5 Advanced Platform (x86)および
Red Hat Enterprise Linux(R) 5 (x86)および
Red Hat Enterprise Linux(R) 5 Advanced Platform (AMD/Intel 64)および
Red Hat Enterprise Linux(R) 5 (AMD/Intel 64)および
Red Hat Enterprise Linux(R) 6 (32-bit x86)および
Red Hat Enterprise Linux(R) 6 (64-bit x86_64)および
Red Hat Enterprise Linux(R) 7 (64-bit x86_64)を
Linuxに，
Microsoft(R) Windows Server(R) 2008 Standard Edition (32bit)および
Microsoft(R) Windows Server(R) 2008 Enterprise Edition (32bit)および
Microsoft(R) Windows Server(R) 2008 Standard Edition (x64)および
Microsoft(R) Windows Server(R) 2008 Enterprise Edition (x64)および
Microsoft(R) Windows Server(R) 2008 Standard Edition (x64)および
Microsoft(R) Windows Server(R) 2008 Enterprise Edition (x64)を
Windows Server 2008に，
Microsoft(R) Windows Server(R) 2008 R2, Standard Edition (x64)および
Microsoft(R) Windows Server(R) 2008 R2, Enterprise Edition (x64)および
Microsoft(R) Windows Server(R) 2008 R2, Datacenter Edition (x64)を
Windows Server 2008 R2に，
Microsoft(R) Windows(R) 7 Professionalおよび
Microsoft(R) Windows(R) 7 Enterpriseおよび
Microsoft(R) Windows(R) 7 Ultimateおよび
Microsoft(R) Windows(R) 7 Professional(x64)および
Microsoft(R) Windows(R) 7 Enterprise(x64)および
Microsoft(R) Windows(R) 7 Ultimate(x64)を
Windows 7に，
Microsoft(R) Windows Server(R) 2012 Standardおよび
Microsoft(R) Windows Server(R) 2012 Datacenterを
Windows Server 2012に，
Microsoft(R) Windows(R) 8 Proおよび
Microsoft(R) Windows(R) 8 Enterpriseおよび
Microsoft(R) Windows(R) 8 Pro(x64)および
Microsoft(R) Windows(R) 8 Enterprise(x64)を
Windows 8に，
Microsoft(R) Windows Server(R) 2012 R2 Standardおよび
Microsoft(R) Windows Server(R) 2012 R2 Datacenterを
Windows Server 2012 R2に，
Microsoft(R) Windows(R) 8.1 Proおよび
Microsoft(R) Windows(R) 8.1 Enterpriseおよび
Microsoft(R) Windows(R) 8.1 Pro(x64)および
Microsoft(R) Windows(R) 8.1 Enterprise(x64)を
Windows 8.1に，
Microsoft(R) Windows(R) 10 Proおよび
Microsoft(R) Windows(R) 10 Enterpriseおよび
Microsoft(R) Windows(R) 10 Pro(x64)および
Microsoft(R) Windows(R) 10 Enterprise(x64)を
Windows 10に，
Microsoft(R) Windows Server(R) 2016 Standardおよび
Microsoft(R) Windows Server(R) 2016 Datacenterを
Windows Server 2016に，
Microsoft(R) Windows Server(R) 2019 Standardおよび
Microsoft(R) Windows Server(R) 2019 Datacenterを
Windows Server 2019に，略称いたします。
また，Windows 7，Windows 8，Windows 8.1，Windows10，Windows Server 2008，Windows Server 2008 R2，Windows Server 2012，Windows Server 2012 R2，Windows Server 2016，およびWindows Server 2019を総称してWindowsに，
HP-UX，AIX，およびLinuxを総称してUNIXと表記します。


HiRDB Configuration Assistantとは

1.　HiRDB Configuration Assistantとは

HiRDB Configuration Assistantの機能概要，および前提環境について説明します。

＜この章の構成＞
1.1　機能概要
1.2　前提環境
1.3　前提知識


機能概要

1.1　機能概要

HiRDB Configuration Assistantは，ユーザによるHiRDBの構築，メンテナンスを補助する製品です。

HiRDB Configuration Assistantを使ってできることの概要を，以下に示します。

図1-1　 HiRDB Configuration Assistantでできること

＜この節の構成＞
1.1.1　HiRDBの設計情報入力補助
1.1.2　既存HiRDBの構成情報取り込み
1.1.3　HiRDBの環境構築支援
1.1.4　HiRDBの設計ドキュメント出力


HiRDBの設計情報入力補助

1.1.1　HiRDBの設計情報入力補助

HiRDB Configuration Assistantでは，GUIでマシン，ユニット，サーバ，RDエリア等のHiRDBの構成要素を視覚的に表現することができます。ユーザは，HiRDB Configuration Assistantを使用することで，設計の内容を，実際に目に見える形で確認しながら，HiRDBの設計情報を入力することができます。

HiRDB Configuration Assistantでは，ウィザード形式でHiRDBが動作する環境の情報を入力することで，その環境に合わせたHiRDBの構成を自動的に作成することもできます。

HiRDB Configuration Assistant上に表現したHiRDBの構成は，HiRDB構成情報としてファイルに保存することができます。

HiRDBの構成要素の操作方法については，「3.　基本操作説明」を参照してください。

HiRDB Configuration Assistantを使用した，HiRDB構成情報の作成手順の詳細は，「4.1.1　HiRDBの構成を定義する」を参照してください。


既存HiRDBの構成情報取り込み

1.1.2　既存HiRDBの構成情報取り込み

HiRDB Configuration Assistantでは，既存のHiRDBから収集した情報を，HiRDB構成情報として取り込んで，HiRDBの構成をGUIで参照したり，編集することができます。

これにより，HiRDBの構成を視覚化することができ，HiRDBの構成に関するメンテナンスが容易にできるようになります。

既存HiRDBから，HiRDB構成情報を取り込む手順の詳細は，「4.2.1　構築済みのHiRDB環境から，HiRDB構成情報を取り込む」「4.3.1　構築済みのHiRDB環境から，HiRDB構成情報を取り込む」を参照してください。


HiRDBの環境構築支援

1.1.3　HiRDBの環境構築支援

HiRDB Configuration Assistantでは，「1.1.1　HiRDBの設計情報入力補助」で入力，もしくは「1.1.2　既存HiRDBの構成情報取り込み」で取り込んで，変更を加えたHiRDB構成情報から，定義ファイルや環境構築用バッチファイルを作成することができます。また，構築対象のHiRDBがV09-50以降の場合，HiRDBの推奨値チェックを行います。

作成した定義ファイルや環境構築用バッチファイルを，HiRDBがインストールされたマシン上に転送し，バッチファイルを実行することで，新規HiRDBの構築や，既存HiRDBの変更を行うことができます。

この機能を活用することにより，従来，ユーザが手作業で行っていた，定義ファイルを作成し，HiRDBがインストールされたマシンに反映させる作業を，自動化することができ，作業効率の向上や，手作業によるミスを防止することができます。

HiRDB構成情報から，定義ファイルや環境構築用バッチファイルを作成して，利用する手順の詳細は，「4.1.5　定義ファイル，環境構築用バッチファイルを出力する」「4.2.6　定義ファイル，環境構築用バッチファイルを出力する」「4.3.6　定義ファイル，環境構築用バッチファイルを出力する」を参照してください。

定義ファイルの詳細については，「付録B　定義ファイル」を参照してください。

環境構築用バッチファイルの詳細については，「付録C　環境構築用バッチファイル」を参照してください。


HiRDBの設計ドキュメント出力

1.1.4　HiRDBの設計ドキュメント出力

HiRDB Configuration Assistantでは，「1.1.1　HiRDBの設計情報入力補助」で入力，もしくは「1.1.2　既存HiRDBの構成情報取り込み」で取り込んで，変更を加えたHiRDB構成情報から，以下に示す設計ドキュメントを出力することができます。

表1-1　HiRDB Configuratin Assistantが出力できる設計ドキュメント

ドキュメント種別 |  | 説明
定数一覧 | システム共通定義 | システム定義中のオペランドとその指定値を一覧で出力します。
 | ユニット制御情報定義
 | サーバ共通定義
 | シングルサーバ定義
 | フロントエンドサーバ定義
 | ディクショナリサーバ定義
 | バックエンドサーバ定義
RDエリア一覧 |  | RDエリアの一覧を出力します。 各RDエリアの配置先サーバや，サイズ等の情報もあわせて出力します。
HiRDBファイルシステム領域一覧 |  | HiRDBファイルシステム領域の一覧を出力します。 各HiRDBファイルシステム領域に格納するHiRDBファイルの情報もあわせて出力します。
ユニット・サーバ一覧 |  | HiRDBのマシン・ユニット・サーバ構成の一覧を出力します。
グローバルバッファ一覧 |  | グローバルバッファの一覧を出力します。 グローバルバッファのサイズや，割り当てられているRDエリア等の情報もあわせて出力します。
構成図 |  | HiRDB Configuration Assistantの構成図に表示されている，HiRDBの構成図を出力します。

これらの設計ドキュメントは，CSV形式，Windows拡張メタファイルといった，様々なアプリケーションで扱うことができる形式で出力しますので，ユーザの設計ドキュメントに取り込んで使用することができます。

この機能を活用することにより，ユーザは，設計ドキュメントの作成工数を削減することができます。

設計ドキュメント出力の形式と手順の詳細は，「4.4　HiRDBの構成に関するドキュメントを出力する」を参照してください。


前提環境

1.2　前提環境

HiRDB Configuration Assisitantをご利用になるための前提環境を説明します。

＜この節の構成＞
1.2.1　推奨システム環境
1.2.2　システム構築・メンテナンス対象のHiRDB


推奨システム環境

1.2.1　推奨システム環境

HiRDB Configuration Assistantをご利用になるための推奨システム環境を以下に示します。

表1-2　推奨システム環境

OS | 以下に示すいずれかのOS Windows 7 Windows 8 Windows 8.1 Windows 10 Windows Server 2008 Windows Server 2008 R2 Windows Server 2012 Windows Server 2012 R2 Windows Server 2016 Windows Server 2019
OSのアドレッシングモード | 以下に示すいずれかのアドレッシングモード 32bit 64bit
ハードディスク | 250MB以上（インストールで使用）
ディスプレイ | 画面解像度1,600×900ピクセル以上


システム構築・メンテナンス対象のHiRDB

1.2.2　システム構築・メンテナンス対象のHiRDB

HiRDB Configuration Assistantでシステム構築・メンテナンスが実行可能なHiRDBのプラットフォームとバージョンは以下の通りです。

表1-3　HiRDB Configuration Assistantでシステム構築・メンテナンスが可能なHiRDB

HiRDB製品 プラットフォーム バージョン
HiRDB/シングルサーバ
HiRDB/パラレルサーバ 		Windows
  • HiRDB Version 8（08-00 ～ 08-05）
  • HiRDB Version 9（09-00 ～ 09-66）
  • HiRDB Version 10（10-00 ～ 10-01）
※ HiRDB Version 9 09-50以降ではSolarisは未サポート
AIX
Linux
HP-UX
Solaris

HiRDB Configuration Assistantでは，1つのHiRDB構成情報ファイルで1つのHiRDBしか扱うことができません。マルチHiRDB構成のHiRDBシステムを扱う場合には，各HiRDBごとにHiRDB構成情報ファイルを作成する必要があります。

HiRDB Configuration Assistantでは，以下に示す，HiRDBの一部の機能に対応していません。

  • インナレプリカ機能
  • 監査証跡機能
  • 1:1スタンバイレス型系切り替え機能
  • リアルタイムSANレプリケーション（ディザスタリカバリ）
  • インメモリデータ処理
  • ディレクトリサーバ連携機能
  • HiRDB External Data Access機能
  • HiRDBのプラグイン
  • Windowsのキャッシュを使用しないユティリティ用HiRDBファイルシステム領域
  • ユティリティ専用ユニット
  • 構造型データベース機能

HiRDB Configuration Assistantで，これらの機能を使用したHiRDBを扱うことはできません。


前提知識

1.3　前提知識

HiRDB Configuration Assistantは，HiRDBの構築，メンテナンスを補助するための製品です。本製品を使用するためには，HiRDBの構築に関する基本的な知識が必要となります。HiRDBの仕様に関しては，HiRDBのマニュアルをご参照ください。


インストール・アンインストール

2.　インストール・アンインストール

HiRDB Configuration Assistantの構成と，インストール手順，およびアンインストール手順について説明します。

＜この章の構成＞
2.1　プログラムの構成
2.2　インストール手順
2.3　アンインストール手順


プログラムの構成

2.1　プログラムの構成

HiRDB Configuration Assistantの構成（フォルダ構成，レジストリ情報）を説明します。

＜この節の構成＞
2.1.1　フォルダ構成
2.1.2　レジストリ情報


フォルダ構成

2.1.1　フォルダ構成

HiRDB Configuration Assistantをインストールしたときに作成するフォルダ構成は次のとおりです。

表2-1　インストールしたときのフォルダ構成

フォルダ | 格納するファイル
（インストールフォルダ）\bin | 実行形式のファイル，共有ライブラリ
（インストールフォルダ）\help | ヘルプファイル
（インストールフォルダ）\sample | サンプルのHiRDB構成情報ファイル
（インストールフォルダ）\temp | HiRDB Configuration Assistantが動作中に利用する一時的な作業ファイル
（インストールフォルダ）\tool | HiRDB構成情報取り込みツールで使用するコマンド，取扱説明書
（インストールフォルダ）\tool\pdcltdef\UNIX | HiRDBサーバ構成情報収集コマンド（UNIX用）
（インストールフォルダ）\tool\pdcltdef\Windows | HiRDBサーバ構成情報収集コマンド（Windows用）
（インストールフォルダ）\tool\pdcltdic\UNIX | HiRDBディクショナリ情報収集コマンド（UNIX用）
（インストールフォルダ）\tool\pdcltdic\Windows | HiRDBディクショナリ情報収集コマンド（Windows用）

(インストールフォルダ)\sampleに格納されているサンプルファイルの詳細については，「付録H　サンプルファイル」を参照してください。

HiRDB構成情報取り込みツールの詳細については，以下に格納されている「HiRDB構成情報取り込みツール取扱説明書」を参照してください。

(インストールフォルダ)\tool\HiRDB_Import_readme.pdf


レジストリ情報

2.1.2　レジストリ情報

HiRDB Configuration Assistantをインストールしたときに，以下のレジストリのフォルダが作成されます。HiRDB Configuration Assistantに関係するレジストリ情報は，「HiRDB Configuration Assistant」フォルダ以下に登録されます。


インストール手順

2.2　インストール手順

HiRDB Configuration Assistantをインストールする方法について説明します。インストール時の注意事項を以下に示します。

  • インストールは，Administrators権限を持つユーザが，管理者として実行する必要があります。
  • Windows上で動作しているすべてのアプリケーションを終了してから，インストールを始めてください。
＜この節の構成＞
2.2.1　新規インストール
2.2.2　修復インストール


新規インストール

2.2.1　新規インストール

HiRDB Configuration Assistantの新規インストールの方法を，以下に示します。

  1. HiRDB Configuration Assistantのインストーラを起動します。

    ［HiRDB Configuration Assistant用のInstallShield ウィザードへようこそ］ダイアログが表示されます。
  2. ダイアログの内容を確認して，［次へ(N)］ボタンをクリックします。

    ［ユーザ情報］ダイアログが表示されます。
  3. 「ユーザ名(U)」および「所属(O)」を入力します。
  4. 「このコンピュータを使用するすべてのユーザ(A)」か「このユーザのみ(M)」のいずれかを選択します。
    HiRDB Configuration Assistantを利用するユーザーに合わせて，いずれかを選択してください。
  5. ［ユーザ情報］ダイアログで，［次へ(N)］ボタンをクリックします。

    ［インストール先のフォルダ］ダイアログが表示されます。
  6. インストール先のフォルダを指定します。
    デフォルトのインストール先は，「<OSインストールドライブ>\Program Files\HITACHI\HiRDB Configuration Assistant」です。インストール先を変更したい場合は，［変更(C)］ボタンをクリックして，インストール先を変更してください。
    • インストール先は128バイト以内で指定してください。
    • インストール先は，以下に示す文字を使用して指定してください。
      半角英字（A～Z，a～z），アンダーバー（_），半角数字（0～9），\，丸括弧，@，半角スペース，ピリオド（.），コロン（:）
  7. ［インストール先のフォルダ］ダイアログで，［次へ(N)］ボタンをクリックします。

    ［プログラムをインストールする準備ができました］ダイアログが表示されます。
  8. ダイアログの内容を確認して，［インストール(I)］ボタンをクリックします。

    ［HiRDB Configuration Assistantをインストールしています］ダイアログが表示され，インストールが開始されます。インストールの進捗状況は，ダイアログ上のプログレスバーで表示されます。途中でインストールを中止したい場合は，［キャンセル］ボタンをクリックします。
    インストールが完了すると，［InstallShield ウィザードを完了しました。］ダイアログが表示されます。

  9. ［完了(F)］ボタンをクリックします。
    インストールが完了します。


修復インストール

2.2.2　修復インストール

HiRDB Configuration Assistantが正常に動作しなくなった場合に，修復インストールを行うことで，HiRDB Configuration Assistantの修復をすることができます。

修復インストールの方法は，次のとおりです。

  1. HiRDB Configuration Assistantのインストーラを起動します。

    ［HiRDB Configuration Assistant用のInstallShield ウィザードへようこそ］ダイアログが表示されます。
  2. ダイアログの内容を確認して，［次へ(N)］ボタンをクリックします。

    ［プログラムの保守］ダイアログが表示されます。
  3. 「修復(P)」を選択して，［次へ(N)］ボタンをクリックします。

    ［プログラムを修復する準備ができました］ダイアログが表示されます。
  4. ダイアログの内容を確認して，［インストール(I)］ボタンをクリックします。

    ［HiRDB Configuration Assistantをインストールしています］ダイアログが表示され，修復インストールが開始されます。修復インストールの進捗状況は，ダイアログ上のプログレスバーで表示されます。途中で修復インストールを中止したい場合は，［キャンセル］ボタンをクリックします。
    修復インストールが完了すると，「インストールが完了しました。」ダイアログが表示されます。

  5. ［完了(F)］ボタンをクリックします。
    修復インストールが完了します。


アンインストール手順

2.3　アンインストール手順

HiRDB Configuration Assistantをアンインストールする方法について説明します。アンインストール時の注意事項を以下に示します。

  • アンインストールは，Administrators権限を持つユーザが，管理者として実行する必要があります。
  • Windows上で動作しているすべてのアプリケーションを終了してから，アンインストールを始めてください。
  • HiRDB Configuration Assistantのアンインストール時，インストールフォルダのtempフォルダ下にファイル・フォルダが残っていた場合，そのファイル・フォルダは削除されず残ったままとなりますので，アンインストール完了後に手動で削除してください。

以下，HiRDB Cofiguration Assistantのインストーラを使用したアンインストール方法を説明します。この方法以外にも，Windowsの「プログラムの追加と削除」，または「アプリケーションの追加と削除」から，HiRDB Configuration Assistantを削除することもできます。

  1. HiRDB Configuration Assistantのインストーラを起動します。

    ［HiRDB Configuration Assistant用のInstallShield ウィザードへようこそ］ダイアログが表示されます。
  2. ダイアログの内容を確認して，［次へ(N)］ボタンをクリックします。

    ［プログラムの保守］ダイアログが表示されます。
  3. 「削除(R)」を選択して，［次へ(N)］ボタンをクリックします。

    ［プログラムを削除する準備ができました］ダイアログが表示されます。
  4. ダイアログの内容を確認して，［削除(R)］ボタンをクリックします。

    ［HiRDB Configuration Assistantをアンインストールしています］ダイアログが表示され，アンインストールが開始されます。アンインストールの進捗状況は，ダイアログ上のプログレスバーで表示されます。途中でアンインストールを中止したい場合は，［キャンセル］ボタンをクリックします。
    アンインストールが完了すると，「アンインストールが完了しました。」ダイアログが表示されます。

  5. ［完了(F)］ボタンをクリックします。
    アンインストールが完了します。


基本説明

3.　基本説明

HiRDB Configuration Assistantを操作するために知っておく必要がある基本的な項目（HiRDB構成情報，構成要素，画面構成，および基本操作）について説明します。

＜この章の構成＞
3.1　HiRDB構成情報
3.2　構成要素
3.3　画面構成
3.4　基本操作


HiRDB構成情報

3.1　HiRDB構成情報

HiRDB構成情報とは，HiRDB Configuration Assistant上で表現される，HiRDBの構成の情報を示します。HiRDB構成情報は，構成要素の集まりとして表現され，構成要素に対して操作を行うことにより，編集することができます。構成要素の詳細については，「3.2　構成要素」を参照してください。

HiRDB構成情報をファイル形式で保存したものを，「HiRDB構成情報ファイル」と呼びます。HiRDB構成情報ファイルは，その作成方法によって2つの種別があります。

表3-1　HiRDB構成情報ファイルの種別

HiRDB構成情報ファイルの種別 | 説明 | 作成方法 | 構成要素の状態※1 |  | 定義出力の可否※2
 |  |  | 既存HiRDBから取り込んだ構成要素 | 新規に追加する構成要素 | 新規定義出力 | 変更定義出力
新規状態ファイル | HiRDBを新規に構築するためのHiRDB構成情報ファイルです。 | HiRDB構成情報ファイルを新規作成します。 詳細は，「4.1.1 HiRDBの構成を定義する」を参照してください。 | なし | 新規状態 | ○ | ×
 |  | 新規状態取り込みを行い，既存HiRDBの情報を，すべて新規状態※1でHiRDB構成情報として取り込みます。 詳細は，「4.3.1 構築済みのHiRDB環境から，HiRDB構成情報を取り込む（新規状態取り込み）」を参照してください。 | 新規状態
確定状態ファイル※3 | 構築済みのHiRDB環境に対して構成変更を行うためのHiRDB構成情報ファイルです。 | 確定状態取り込みで，既存HiRDBの情報を，すべて確定状態※1でHiRDB構成情報として取り込みます。 詳細は，「4.2.1 構築済みのHiRDB環境から，HiRDB構成情報を取り込む（確定状態取り込み）」を参照してください。 | 確定状態 | 新規状態 | × | ○

※1 構成要素の状態（確定状態，新規状態）の詳細については，「3.2.4　構成要素の状態」を参照してください。

※2 ○は，定義出力が実行可能なことを示します。×は，定義出力が実行できないことを示します。

※3 確定状態ファイルの全ての構成要素を削除した場合，新規状態ファイルと同じ扱いとなります。


構成要素

3.2　構成要素

HiRDB Configuration Assistantの構成要素について説明します。

＜この節の構成＞
3.2.1　構成要素とは
3.2.2　構成要素の表示形式
3.2.3　構成要素の親子関係
3.2.4　構成要素の状態
3.2.5　構成要素の操作
3.2.6　構成要素と構成要素定義情報の関係
3.2.7　構成要素定義情報のオペランド


構成要素とは

3.2.1　構成要素とは

構成要素とは，HiRDBを構成する物理的，または論理的な要素のことを示します。HiRDB Configuration Assistantでは，以下の構成要素を操作することができます。

表3-2　HiRDB Configuration Assistantが扱うことのできる構成要素

HiRDB
マシン
ユニット | ユニット
 | 待機系ユニット
サーバ | マネージャサーバ
 | ディクショナリサーバ
 | フロントエンドサーバ
 | バックエンドサーバ
 | シングルサーバ
RDエリア | ユーザ用RDエリア
 | LOB用RDエリア
 | リスト用RDエリア
 | 共用RDエリア
 | レジストリ用RDエリア
 | レジストリLOB用RDエリア
 | マスタディレクトリ用RDエリア
 | データディレクトリ用RDエリア
 | データディクショナリ用RDエリア
 | データディクショナリ用RDエリア（ルーチン用）
 | データディクショナリLOB用RDエリア
 | データディクショナリ用RDエリア（再編成時期予測用）
グローバルバッファ | データ用グローバルバッファ
 | LOB用グローバルバッファ
 | インデクス用グローバルバッファ
 | その他用グローバルバッファ
HiRDBファイルシステム領域 | DB用ファイルシステム領域
 | SDB用ファイルシステム領域
 | SYS用ファイルシステム領域
 | SVR用ファイルシステム領域
 | WORK用ファイルシステム領域
 | UTL用ファイルシステム領域
システムファイル | システムログファイル
 | シンクポイントダンプファイル
 | ユニット用ステータスファイル
 | サーバ用ステータスファイル
HAグループ


構成要素の表示形式

3.2.2　構成要素の表示形式

HiRDB Configuration Assistant上での，構成要素の表示形式を以下に示します。

表3-3　構成要素の表示形式

構成要素 |  | 構成図上の表示 | ツリービュー上の表示 | アイテムボックス上の表示
HiRDB |  | － | [図データ] | －
マシン |  | [図データ] | [図データ] | [図データ]
ユニット | ユニット | [図データ] | [図データ] | [図データ]
 | 待機系ユニット
サーバ | マネージャサーバ | [図データ] | [図データ] | [図データ]
 | ディクショナリサーバ |  | [図データ] | [図データ]
 | フロントエンドサーバ |  | [図データ] | [図データ]
 | バックエンドサーバ |  | [図データ] | [図データ]
 | シングルサーバ |  | [図データ] | [図データ]
RDエリア | ユーザ用RDエリア | － | [図データ] | [図データ]
 | LOB用RDエリア
 | リスト用RDエリア
 | 共用RDエリア
 | レジストリ用RDエリア
 | レジストリLOB用RDエリア
 | マスタディレクトリ用RDエリア
 | データディレクトリ用RDエリア
 | データディクショナリ用RDエリア
 | データディクショナリ用RDエリア（ルーチン用）
 | データディクショナリLOB用RDエリア
 | データディクショナリ用RDエリア（再編成時期予測用）
グローバルバッファ | データ用グローバルバッファ | － | [図データ] | [図データ]
 | LOB用グローバルバッファ
 | インデクス用グローバルバッファ
 | その他用グローバルバッファ
HiRDBファイルシステム領域 | DB用ファイルシステム領域 | [図データ] | [図データ] | [図データ]
 | SDB用ファイルシステム領域
 | SYS用ファイルシステム領域
 | SVR用ファイルシステム領域
 | WORK用ファイルシステム領域
 | UTL用ファイルシステム領域
システムファイル | システムログファイル | － | [図データ] | －
 | シンクポイントダンプファイル
 | ユニットステータスファイル
 | サーバステータスファイル
HAグループ |  | － | [図データ] | [図データ]
  • －：その構成要素は，アイテムボックス，構成図，またはツリービュー上で表示しないことを示します。
  • 構成図の詳細については，「3.3.1(3)　構成図」を参照してください。
  • ツリービューの詳細については，「3.3.1(4)　ツリービュー」を参照してください。
  • アイテムボックスの詳細については，「3.3.1(6)　アイテムボックス」を参照してください。


構成要素の親子関係

3.2.3　構成要素の親子関係

HiRDBの構成要素には，以下に示すような親子関係があります。ある構成要素に対して子となる構成要素を追加しようとした時，この親子関係にしたがった構成要素しか追加することはできません。

図3-1　構成要素の親子関係（パラレルサーバの場合）

図3-2　構成要素の親子関係（シングルサーバの場合）


構成要素の状態

3.2.4　構成要素の状態

構成要素は，その作成方法によって確定状態，または新規状態のいずれかの状態をとります。それぞれの状態について以下に説明します。

表3-4　構成要素の状態

構成要素の状態 説明 その状態をとる構成要素の一覧
確定状態 構築済みのHiRDB環境に対して構成変更を行う時に，すでにHiRDBに存在している構成要素がとる状態です。
構築済みのHiRDB環境を壊すことのないように，確定状態の構成要素に対する操作は制限されます※1。
  • 確定状態取り込みで取り込んだ構成要素
新規状態 以下に示す構成要素がとる状態です。
  • 構築済みのHiRDB環境に対して構成変更を行う時に，新たに追加する構成要素
  • 新たにHiRDB環境を構築する時の全ての構成要素
新規状態の構成要素に対する操作の制限はありません※1。
  • 新規状態取り込みで取り込んだ構成要素
  • 追加した構成要素
  • 複写した構成要素

※1 構成要素の状態によって，その構成要素に対して実行可能な基本操作が異なります。詳細については，「3.4　基本操作」を参照してください。


構成要素の操作

3.2.5　構成要素の操作

構成要素は，HiRDB Configuration Assistant上で操作（追加，移動，複写，削除，情報参照，情報更新）することができます。構成要素を操作する方法については，「3.4　基本操作」を参照してください。


構成要素と構成要素定義情報の関係

3.2.6　構成要素と構成要素定義情報の関係

HiRDB Configuration Assistantは構成要素に対して構成要素定義情報を生成します。構成要素と構成要素定義情報の関係を以下に示します。

表3-5　構成要素と構成要素定義情報一覧

構成要素 | 構成要素定義情報
HiRDB | システム共通定義
マシン | マシン設定情報
ユニット | ユニット制御情報定義
 | サーバ共通定義
ユニット用ステータスファイル | ユニット用ステータスファイル設定情報
マネージャサーバ | －
フロントエンドサーバ | フロントエンドサーバ定義
ディクショナリサーバ | ディクショナリサーバ定義
バックエンドサーバ | バックエンドサーバ定義
シングルサーバ | シングルサーバ定義
RDエリア | RDエリア設定情報
グローバルバッファ | グローバルバッファ設定情報
システムログファイル | システムログファイル設定情報
シンクポイントダンプファイル | シンクポイントダンプ設定情報
サーバ用ステータスファイル | サーバ用ステータスファイル設定情報
HiRDBファイルシステム領域 | HiRDBファイルシステム領域設定情報


構成要素定義情報のオペランド

3.2.7　構成要素定義情報のオペランド

構成要素定義情報には，構成要素に関連したオペランドを指定することができます。

HiRDB Configuration Assistantは，オペランドの指定値にしたがい，定義ファイルと環境構築用バッチファイルを作成します。

HiRDB Configuration Assistantで指定するオペランドには，以下の2種類があります。

  • HiRDB Configuration Assistant固有のオペランド
  • HiRDBのオペランド

それぞれについて，以下に説明します。

＜この項の構成＞
(1)　HiRDB Configuration Assistant固有のオペランド
(2)　HiRDBのオペランド

(1)　HiRDB Configuration Assistant固有のオペランド

HiRDB Configuration Assistant固有のオペランドを以下に示します。

表3-6　HiRDB Configuration Assistant固有オペランド一覧

構成要素 定義情報 | オペランド名 | オペランドに指定する内容 | 設定した情報の展開先
マシン設定情報 | ip_address | 当該マシンのIPアドレス | なし※1
 | alias_hostname | 当該マシンのエイリアスマシン名 | なし※1
 | Alias_ip_address | 当該マシンのエイリアスマシンのIPアドレス | なし※1
 | maximum_memory_size | 当該マシンで使用可能な仮想メモリサイズの上限値 | なし※1
 | maximum_disk_size | 当該マシンで使用可能なDisk容量の上限値 | なし※1
ユニット制御情報定義 | PDDIR | 操作対象のHiRDBの各ユニット毎のPDDIR | 各バッチファイル中の環境変数PDDIR
 | HiRDB_port | HiRDBのポート番号 | pdunitコマンドの-pオプション
 | scd_process_port | スケジューラプロセスのポート番号 | pdunitコマンドの-sオプション
 | trn_process_port | トランザクションサーバプロセスのポート番号 | pdunitコマンドの-tオプション
 | mlg_process_port | メッセージログサーバプロセスのポート番号 | pdunitコマンドの-mオプション
 | alv_process_port | ユニット監視プロセスのポート番号 | pdunitコマンドの-aオプション
ユニット用ステータスファイル設定情報 | file_name_A | ユニット用ステータスファイルのA系に使用する物理ファイル名 | pdstsinitコマンドの-fオプション，及びユニット制御情報定義のpd_syssts_file_name_1～7の”A系ステータスファイル名”
 | records_num_A | ユニット用ステータスファイルのA系HiRDBファイルのレコード数 | pdstsinitコマンドの-cオプション
 | records_size_A | ユニット用ステータスファイルのA系HiRDBファイルのレコード長 | pdstsinitコマンドの-lオプション
 | file_name_B | ユニット用ステータスファイルのB系に使用する物理ファイル名 | pdstsinitコマンドの-fオプション，及びユニット制御情報定義のpd_syssts_file_name_1～7の”B系ステータスファイル名”
 | records_num_B | ユニット用ステータスファイルのB系HiRDBファイルのレコード数 | pdstsinitコマンドの-cオプション
 | records_size_B | ユニット用ステータスファイルのB系HiRDBファイルのレコード長 | pdstsinitコマンドの-lオプション
フロントエンドサーバ定義 | multi_connection | マルチコネクションアドレス機能を使用する場合の，HiRDBクライアントが接続するHiRDB/シングルサーバのホスト名 | システム共通定義のpdstartコマンドの-mオプション
 | multi_connection_standby | マルチコネクションアドレス機能を使用する場合の，HiRDBクライアントが接続するHiRDB/シングルサーバのホスト名 | システム共通定義のpdstartコマンドの-nオプション
 | HiRDB_Now_Recover_FES | 回復不要FESの使用有無 | システム共通定義のpdstartの'-k'オプション
バックエンドサーバ定義 | substitute_bes_name | 1:1スタンバイレス型系切り替え機能する場合の，バックエンドサーバの代替BES名 | システム共通定義のpdstartの'-c'オプション
シングルサーバ定義 | multi_connection | マルチコネクションアドレス機能を使用する場合の，HiRDBクライアントが接続するHiRDB/シングルサーバのホスト名 | pdstartコマンドの-mオプション
 | multi_connection_standby | マルチコネクションアドレス機能を使用する場合の，HiRDBクライアントが接続するHiRDB/シングルサーバのホスト名 | pdstartコマンドの-nオプション
RDエリア設定情報 | open_attribute | RDエリアのオープン契機 | RDエリアの制御文中のopen attributeオペランド
 | grantee | ユーザ用RDエリアを使用できるユーザの認可識別子 | RDエリアの制御文中の認可識別子
 | page_size | RDエリアを構成するHiRDBファイルのページ長 | RDエリアの制御文中のpageオペランド
 | segment_size | 1セグメントの大きさ | RDエリアの制御文中のstorage control segmentオペランド
 | extension | 増分セグメント数 | RDエリアの制御文中のextensionオペランド
 | file_name_1 ～ file_name_16 | RDエリアに対して割り当てる，HiRDBファイルシステム領域の名称とHiRDBファイルの名称 | RDエリアの制御文中のfile nameオペランド
 | initial_segments_1 ～ initial_segments_16 | HiRDBファイルのセグメント数 | RDエリアの制御文中のinitialオペランド
 | max_entries | リスト用RDエリアに作成できるリストの最大数 | RDエリアの制御文中のmax entriesオペランド
 | temp_globalbuffer | 当該RDエリアの追加時に割り当てる一時的なグローバルバッファ | RDエリアの制御文中のglobalbufferオペランド
 | temporary_table | 当該RDエリアを一時表用RDエリアとして使用するかどうか | RDエリアの制御文中のtemporary tableオペランド
HiRDBファイルシステム領域設定情報 | user_area_capacity | HiRDBファイルシステム領域として割り当てる容量 | pdfmkfsコマンドの-ｎオプション
 | file_count | HiRDBファイルシステム領域内に作成するHiRDBファイル数の上限 | pdfmkfsコマンドの-ｌオプション
 | available_expand_count | HiRDBファイルの自動増分回数の上限値 | pdfmkfsコマンドの-eオプション
 | sector_size | HiRDBファイルシステム領域としてキャラクタ型スペシャルファイルを使用する場合の，最小入出力単位 | pdfmkfsコマンドの-sオプション
 | initialize_option | HiRDBファイルシステム領域サイズ分の領域を最初から初期化するかどうか | pdfmkfsコマンドの-iオプション
 | message_output_option | 通常ファイルの初期設定の場合に，確認メッセージを表示しないで初期設定するかどうか | pdfmkfsコマンドの-rオプション
 | area_auto_expand | HiRDBファイルシステム領域を自動的に拡張するかどうか | pdfmkfsコマンドの-aオプション
 | duplicated_file_system | 複製ディスク機能用のHiRDBファイルシステム領域を作成するかどうか | pdfmkfsコマンドの-mオプション
グローバルバッファ設定情報 | index_name | インデクスをグローバルバッファに割り当てる場合の，認可識別子．インデクス識別子 | pdbufferコマンドの-iオプション
 | buffer_number | グローバルバッファのバッファ面数 | pdbufferコマンドの-nオプション
 | buffer_size | グローバルバッファのバッファサイズ | pdbufferコマンドの-lオプション
 | maximum_prefetches | グローバルバッファの同時実行最大プリフェッチ数 | pdbufferコマンドの-mオプション
 | batch_maximum_pages | グローバルバッファの一括入力最大ページ数 | pdbufferコマンドの-pオプション
 | output_ratio_of_defered-write-trigger | グローバルバッファのデファードライトトリガ時の更新ページ出力比率 | pdbufferコマンドの-wオプション
 | buffer_number_of_defered-write-trigger | グローバルバッファのデファードライトトリガ時の更新ページ出力比率 | pdbufferコマンドの-yオプション
 | standbyless | 1:1スタンバイレスの適用有無 | pdbufferコマンドの-cオプション
システムログファイル設定情報 | file_name_A | システムログファイルのA系に使用する物理ファイル名 | pdloginit -d sysコマンドの-fオプション，及びサーバ定義のpdlogadpf -d sysの-aオプション
 | records_num_A | システムログファイルのA系HiRDBファイルのレコード数 | pdloginit -d sysコマンドの-nオプション
 | records_size_A | システムログファイルのA系HiRDBファイルのレコード長 | pdloginit -d sysコマンドの-lオプション
 | file_name_B | システムログファイルのB系に使用する物理ファイル名 | pdloginit -d sysコマンドの-fオプション，及びサーバ定義のpdlogadpf -d sysの-bオプション
 | records_num_B | システムログファイルのB系HiRDBファイルのレコード数 | pdloginit -d sysコマンドの-nオプション
 | records_size_B | システムログファイルのB系HiRDBファイルのレコード長 | pdloginit -d sysコマンドの-lオプション
 | ONL | 当該ファイルグループをHiRDBの稼働時の使用可否 | サーバ定義のpdlogadfg -d sysコマンドのONLオペランド
シンクポイントダンプ設定情報 | file_name_A | シンクポイントダンプのA系に使用する物理ファイル名 | pdloginit -d spdコマンドの-fオプション，及びサーバ定義のpdlogadpf -d spdの-aオプション
 | records_num_A | シンクポイントダンプのA系HiRDBファイルのレコード数 | pdloginit -d spdコマンドの-nオプション
 | file_name_B | シンクポイントダンプのB系に使用する物理ファイル名 | pdloginit -d spdコマンドの-fオプション，及びサーバ定義のpdlogadpf -d spdの-bオプション
 | records_num_B | シンクポイントダンプのB系HiRDBファイルのレコード数 | pdloginit -d spdコマンドの-nオプション
 | ONL | 当該ファイルグループをHiRDBの稼働時の使用可否 | サーバ定義のpdlogadfg -d spdコマンドのONLオペランド
サーバ用ステータスファイル設定情報 | file_name_A | サーバ用ステータスファイルのA系に使用する物理ファイル名 | pdstsinitコマンドの-fオプション，及びサーバ定義のpd_sts_file_name_1～7の"A系ステータスファイル名"
 | records_num_A | サーバ用ステータスファイルのA系HiRDBファイルのレコード数 | pdstsinitコマンドの-cオプション
 | records_size_A | サーバ用ステータスファイルのA系HiRDBファイルのレコード長 | pdstsinitコマンドの-lオプション
 | file_name_B | サーバ用ステータスファイルのB系に使用する物理ファイル名 | pdstsinitコマンドの-fオプション，及びサーバ定義のpd_sts_file_name_1～7の"B系ステータスファイル名"
 | records_num_B | サーバ用ステータスファイルのB系HiRDBファイルのレコード数 | pdstsinitコマンドの-cオプション
 | records_size_B | サーバ用ステータスファイルのB系HiRDBファイルのレコード長 | pdstsinitコマンドの-lオプション
共通 | comment ※2 | システム定義中のコメント | システム定義中のコメント

※1 定義ファイル，および環境構築用バッチファイルを出力する際に使用されないことを示します。

※2 commentオペランドは編集することはできません。

(2)　HiRDBのオペランド

HiRDBのオペランドの詳細についてはHiRDBのマニュアルを参照してください。

なお，以下に示すオペランド，構成要素名については，HiRDB Configuration Assistantがデフォルト値を設定しますので，環境に合わせて修正してください。

表3-7　HiRDB Configuration Assistantが設定するデフォルト値

構成要素 | オペランド，構成要素名 | デフォルト値
 |  | Windows | Windows以外
ユニット | pd_cwatitime_report_dir | C:\HiRDB_DIR\REPORT | /HiRDB_DIR/REPORT
 | pd_tmp_directory | C:\HiRDB_DIR\TMP | /HiRDB_DIR/TMP
サーバ | pd_log_auto_unload_path | C:\HiRDB_DIR\UNLOAD | /HiRDB_DIR/UNLOAD
HiRDBファイルシステム領域 | 構成要素名 | C:\HiRDB_DIR\DB\<ファイル名> | /HiRDB_DIR/DB/<ファイル名>


画面構成

3.3　画面構成

HiRDB Configuration Assistantの画面構成について説明します。

＜この節の構成＞
3.3.1　基本画面
3.3.2　構成情報ビュー
3.3.3　詳細ダイアログ
3.3.4　HiRDB構成初期情報ダイアログ


基本画面

3.3.1　基本画面

HiRDB Configuration Assistantは，複数の基本画面から構成されます。ここでは，すべての基本画面について，その役割と機能を説明します。

基本画面の一覧を以下に示します。

表3-8　HiRDB Configuration Assistantの基本画面一覧

図中の番号 | 画面の名称 | 概要 | 詳細説明
① | メニューバー | 各種操作コマンドをメニュー形式で表示します。 | 3.2.1(1)
② | ツールバー | 各種操作のショートカットを表示します。 | 3.2.1(2)
③ | 構成図 | HiRDBの構成を図で表示します。 | 3.2.1(3)
④ | ツリービュー | HiRDBの構成をツリー形式で表示します。 | 3.2.1(4)
⑤ | 構成情報ビュー | 構成図やツリービューで選択した構成要素の情報を表示します。 | 3.2.1(5)
⑥ | アイテムボックス | HiRDBの構成要素をアイコン形式で一覧表示します。 | 3.2.1(6)
⑦ | ステータスバー | HiRDB Configuration Assistantの状態に関する情報を表示します。 | 3.2.1(7)
＜この項の構成＞
(1)　メニューバー
(2)　ツールバー
(3)　構成図
(4)　ツリービュー
(5)　構成情報ビュー
(6)　アイテムボックス
(7)　ステータスバー

(1)　メニューバー

各種操作コマンドをメニュー形式で表示します。メニューバーから実行できる操作コマンドを以下に示します。

表3-9　メニューバーから実行できる操作コマンド一覧

操作コマンド |  |  | 機能・内容
ファイル(F) | 新規作成(N) |  | HiRDB構成情報ファイルを新しく作成します。
 | ウィザードによる新規作成 |  | ウィザードによりHiRDBの構成情報ファイルを作成します。
 | 構成情報ファイルを開く(O) |  | 既存のHiRDB構成情報ファイルを開きます。
 | 上書き保存(S) |  | HiRDB構成情報ファイルを上書き保存します。
 | 名前を付けて保存(A) |  | HiRDB構成情報を，指定した名前のファイルに保存します。
 | 構成図ファイル出力(M) |  | 構成図を，印刷可能なファイル形式（Windows拡張メタファイル，拡張子はemf）のファイルに出力します。
 | CSV出力(W) | 定数一覧 | 定数一覧をCSV形式でファイルに出力します。
 |  | ユニット・サーバ一覧 | ユニット・サーバ一覧をCSV形式でファイルに出力します。
 |  | RDエリア一覧 | RDエリア一覧をCSV形式でファイルに出力します。
 |  | HiRDBファイルシステム領域一覧 | HiRDBファイルシステム領域一覧をCSV形式でファイルに出力します。
 |  | グローバルバッファ一覧 | グローバルバッファ一覧をCSV形式でファイルに出力します。
 | アプリケーションの終了(X) |  | HiRDB Configuration Assistantを終了します。
編集(E) | 切り取り(X) |  | 選択した構成要素を切り取ってクリップボードに保存します。
 | コピー(C) |  | 選択した構成要素をコピーしてクリップボードに保存します。
 | 貼り付け(V) |  | クリップボードに保存した構成要素を貼り付けます。
 | 削除(D) |  | 選択した構成要素を削除します。
 | 名称の変更(R) |  | 選択されている対象の表示名を変更します。
 | 置換 |  | 選択されている構成要素，およびその配下のHiRDB構成情報を一括して置換します。
表示(V) | ツールバーと ドッキングウィンドウ(T) | ツールバー | ツールバーの表示・非表示を切り替えます。チェックが付いている時，ツールバーが表示されます。
 |  | ツリービュー | ツリービューの表示・非表示を切り替えます。チェックが付いている時，ツリービューが表示されます。
 |  | アイテムボックス | アイテムボックスの表示・非表示を切り替えます。チェックが付いている時，アイテムボックスが表示されます。
 | ステータスバー(S) |  | ステータスバーの表示・非表示を切り替えます。チェックが付いている時，ステータスバーが表示されます。
 | 構成図内の表示 | ユニットの表示 | 構成図上のユニットの表示・非表示を切り替えます。チェック状態の時，ユニットを表示します。
 |  | サーバの表示 | 構成図上のサーバの表示・非表示を切り替えます。チェック状態の時，サーバを表示します。
 |  | HIRDBファイルシステム領域の表示 | 構成図上のHiRDBファイルシステム領域の表示・非表示を切り替えます。チェック状態のとき，HiRDBファイルシステム領域を表示します。
 | 構成図の拡大表示 |  | 構成図の表示を拡大します。
 | 構成図の縮小表示 |  | 構成図の表示を縮小します。
 | 構成初期情報 |  | ［HiRDB構成初期情報ダイアログ］を表示します。
ツール(T) | 定義出力 | 新規定義出力 | 新規環境を構築するための定義ファイル，および環境構築用バッチファイルを出力します。
 |  | 新規定義出力(推奨変換) | 新規環境を構築するための定義ファイル，および環境構築用バッチファイルを出力する際，HiRDBの推奨値以外を指定しているオペランドをコメントにして出力します。
 |  | 変更定義出力 | 既存の環境を変更するための定義ファイル，および環境構築用バッチファイルを出力します。
 | 定義取り込み | 確定状態取り込み | 構築済みのHiRDB環境に対して，構成要素やオペランドの変更を行うために，HiRDB構成情報を確定状態で取り込みます。
 |  | 新規状態取り込み | 構築済みのHiRDB環境を参考に，新しいHiRDB環境を作成するために，HiRDB構成情報を新規状態で取り込みます。
 | システム定義のチェック |  | HiRDB Configuration Assistantが動作するマシンから，HiRDBを構築するマシンに定義ファイルを送信し，pdconfchkコマンドを実行することで，HiRDB構成情報に不整合がないかチェックします。
 | 容量計算 |  | HiRDB構成情報をもとに，HiRDBが必要とするメモリ・ディスクの容量を計算します。
ヘルプ(H) | ヘルプ(H) |  | HiRDB Configuration Assistantのヘルプファイルを表示します。
 | バージョン情報(A) |  | HiRDB Configuration Assistantのプログラム情報，バージョン，著作権を表示します。

(2)　ツールバー

各種操作のショートカットを表示します。

表3-10　ツールバーで実行できる操作の一覧

操作 | ショートカットアイコン | 説明
新規作成 | [図データ] | 新しいHiRDB構成情報ファイルを作成します。
切り取り | [図データ] | 選択した構成要素を切り取ってクリップボードに保存します。
コピー | [図データ] | 選択した構成要素をコピーしてクリップボードに保存します。
貼り付け | [図データ] | クリップボードに保存した構成要素を貼り付けます。
ユニットの表示 | [図データ] / [図データ] | 構成図上のユニットの表示・非表示を切り替えます。チェック状態の時，ユニットを表示します。
サーバの表示 | [図データ] / [図データ] | 構成図上のサーバの表示・非表示を切り替えます。チェック状態の時，サーバを表示します。
HiRDBファイルシステム領域の表示 | [図データ] / [図データ] | 構成図上のHiRDBファイルシステム領域の表示・非表示を切り替えます。チェック状態のとき，HiRDBファイルシステム領域を表示します。
構成図の拡大表示 | [図データ] | 構成図の表示を拡大します。
構成図の縮小表示 | [図データ] | 構成図の表示を縮小します。
バージョン情報の表示 | [図データ] | HiRDB Configuration Assistantのプログラム情報，バージョン，著作権を表示します。

(3)　構成図

HiRDBの構成を図で表示します。アイテムボックスからドラッグアンドドロップで構成要素を追加することができます。また，構成要素を移動・複写・削除することができます。

構成図上における構成要素の表示内容は，「表3-3　構成要素の表示形式」を参照してください。

また，構成要素の操作（追加，移動，複写，削除，情報参照，情報更新）の方法については，「3.4　基本操作」を参照してください。

(4)　ツリービュー

HiRDBの構成をツリー形式で表示します。

ツリービューにおける構成要素の表示内容は，「表3-3　構成要素の表示形式」を参照してください。

また，構成要素の操作（追加，移動，複写，削除，情報参照，情報更新）の方法については，「3.4　基本操作」を参照してください。

(5)　構成情報ビュー

構成図やツリービューで選択した構成要素の情報を表示し編集することができます。構成情報ビューにはタブがあり，タブを選択することにより，表示する情報を切り替えることができます。構成情報ビュー上のタブの一覧を以下に示します。

表3-11　構成情報ビューのタブ一覧

タブ名 表示，編集できる情報
構成要素一覧
  • 構成図やツリービューで選択した構成要素と，その構成要素に属する構成要素の一覧
RDエリア 以下のいずれかを表示
  • 構成図やツリービューで選択した構成要素に属するRDエリア
  • ツリービューで選択したグローバルバッファと関連付けられたRDエリア
グローバルバッファ 以下のいずれかを表示
  • 構成図やツリービューで選択した構成要素に属するグローバルバッファ
  • 構成図やツリービューで選択した構成要素に属するRDエリアと関連付けられたグローバルバッファ
システムログ
  • 構成図やツリービューで選択した構成要素に属するシステムログファイル
シンクポイントダンプ
  • 構成図やツリービューで選択した構成要素に属するシンクポイントダンプファイル
ステータスファイル
  • 構成図やツリービューで選択した構成要素に属するステータスファイル
HAグループ
  • ツリービューで選択したHAグループに登録されているユニット

構成情報ビューの各タブの詳細については，「3.3.2　構成情報ビュー」を参照してください。

(6)　アイテムボックス

HiRDBの構成要素をアイコン形式で一覧表示します。

この画面から，構成要素を示すアイコンを構成図にドラッグアンドドロップすることで，構成要素を追加することができます。

アイテムボックス上における構成要素の表示内容は，「表3-3　構成要素の表示形式」を参照してください。

(7)　ステータスバー

HiRDB Configuration Assistantの状態に関する情報を表示します。

ステータスバーの表示内容を以下に示します。

表3-12　ステータスバーの表示内容

ステータスバー |  | 内容
① | メニュー説明 | メニューバーで選択しているコマンドの説明を表示します。
② | 構成要素チェック結果表示 | 構成要素の警告，及びエラー件数を表示します。 警告件数については，構築対象のHiRDBが09-50以降の場合に表示します。構築対象のHiRDBが09-04以前の場合は０件で表示します。
③ | Caps Lock状態表示 | キーボードの「Caps Lock」の状態を示します。「CAP」が黒色で表示している場合，「Caps Lock」が有効です。
④ | Num Lock状態表示 | キーボードの「Num Lock」の状態を示します。「NUM」が黒色で表示している場合，「Num Lock」が有効です。
⑤ | Scroll Lock状態表示 | キーボードの「Scroll Lock」の状態を示します。「SCRL」が黒色で表示している場合，「Scroll Lock」が有効です。


構成情報ビュー

3.3.2　構成情報ビュー

構成情報ビューのタブの詳細を以下で説明します。

＜この項の構成＞
(1)　構成要素一覧タブ
(2)　RDエリア一覧タブ
(3)　グローバルバッファタブ
(4)　システムログタブ
(5)　シンクポイントダンプタブ
(6)　ステータスファイルタブ
(7)　HAグループタブ

(1)　構成要素一覧タブ

構成図やツリービューで選択した構成要素と，その構成要素に属する構成要素の一覧表示するためのタブです。

表3-13　構成要素一覧タブの内容

構成要素一覧タブ | 内容
① | 表示対象の構成要素 | 選択した構成要素の名称を表示します。
② 構成要素一覧 選択した構成要素と，その構成要素に属する構成要素の情報を一覧表示します。
  • 構成要素名
    構成要素の名称を表示します。
  • 構成要素種別
    構成要素の種別を表示します。構成要素の種別の詳細については，「3.2.1　構成要素とは」を参照してください。
  • 構成要素定義情報
    構成要素に対応する構成要素定義情報を表示します。構成要素定義情報の詳細については，「3.2.6　構成要素と構成要素定義情報の関係」を参照してください。
③ オペランド詳細表示ボタン 選択した構成要素定義情報のオペランド詳細を表示，編集する場合に使用します。
構成要素定義情報のオペランド詳細は，［オペランド詳細ダイアログ］に表示されます。ダイアログの詳細は，「3.3.3(1)　オペランド詳細ダイアログ」を参照してください。
構成要素定義情報のオペランド詳細表示，および編集方法は，「3.4.5　構成要素の情報参照」「3.4.6　構成要素の情報更新」を参照してください。
④ 警告件数・エラー件数 構成要素の警告，及びエラー件数を表示します。
警告件数については，構築対象のHiRDBが09-50以降の場合に表示します。構築対象のHiRDBが09-04以前の場合は０件で表示します。

なお，構成要素定義情報中に値が正しく設定されていないオペランドが含まれる場合，その構成要素の項目の背景が赤色になります。

(2)　RDエリア一覧タブ

構成図やツリービューで選択した構成要素に属するRDエリアの一覧，またはツリービューで選択したグローバルバッファと関連付けられたRDエリアの一覧を表示，編集するためのタブです。

表3-14　RDエリアタブの内容

RDエリアタブ | 内容
① | 表示対象の構成要素 | 選択した構成要素の名称を表示します。
② RDエリア一覧 選択した構成要素により，いずれかの情報を表示します。
  • 構成図やツリービューで選択した構成要素に属するRDエリアの一覧
  • ツリービューで選択したグローバルバッファと関連付けられたRDエリアの一覧
表示内容の詳細は，「表3-15　RDエリア一覧の表示内容」を参照してください。
③ RDエリア詳細
表示ボタン 		RDエリア一覧で選択したRDエリアの詳細を表示，編集する場合に使用します。
RDエリアの詳細情報は，［RDエリア詳細ダイアログ］に表示されます。ダイアログの詳細は，「3.3.3(2)　RDエリア詳細ダイアログ」を参照してください。
④ RDエリア
削除ボタン 		RDエリア一覧で選択したRDエリアを削除する場合に使用します。

表3-15　 RDエリア一覧の表示内容

選択した構成要素 |  |  | 表示内容
HiRDB |  |  | 選択した構成要素に属するRDエリアの一覧※1を表示します。
マシン
ユニット
サーバ
グローバルバッファ | RDAREA |  | 選択したグローバルバッファを割り当てたRDエリアの一覧※1を表示します。
 | BLOB
 | OTHER | 1個目※2 | データ用グローバルバッファを割り当てていないRDエリアの一覧※1を表示します。
 |  | 2個目以降※2 | 何も表示しません。
 | INDEX |  | 何も表示しません。
上記以外 |  |  | 何も表示しません。

※1 RDエリアの一覧として，以下の項目が表示されます。

  • RDエリア名
  • RDエリア種別
  • 対応サーバ名
  • 対応データ用グローバルバッファ名（データ用グローバルバッファが割り当てられていない場合，空欄となります）
  • 対応LOB用グローバルバッファ名（LOB用グローバルバッファが割り当てられていない場合，空欄となります）

※2 「1個目」は，複数のその他用グローバルバッファが定義されているときに有効となる，先頭のその他用グローバルバッファを示します。「2個目以降」は，それ以外の有効とならないその他用グローバルバッファを示します。

(3)　グローバルバッファタブ

構成図やツリービューで選択した構成要素に属するグローバルバッファ，または構成図やツリービューで選択した構成要素に属するRDエリアと関連付けられたグローバルバッファを表示，編集するためのタブです。グローバルバッファタブの内容を以下に示します。

表3-16　グローバルバッファタブの内容

グローバルバッファタブ | 内容
① | 表示対象の構成要素 | 選択した構成要素の名称を表示します。
② グローバルバッファ一覧 選択した構成要素により，いずれかの情報を表示します。
  • 構成図やツリービューで選択した構成要素に属するグローバルバッファ
  • 構成図やツリービューで選択した構成要素に属するRDエリアと関連付けられたグローバルバッファ
表示内容の詳細は，「表3-17　グローバルバッファ一覧の表示内容」を参照してください。
③ グローバルバッファ詳細表示ボタン グローバルバッファ一覧で選択したグローバルバッファの詳細を表示，編集する場合に使用します。
グローバルバッファの詳細情報は，［オペランド詳細ダイアログ］に表示されます。ダイアログの詳細は，「3.3.3(1)　オペランド詳細ダイアログ」を参照してください。

表3-17　グローバルバッファ一覧の表示内容

選択した構成要素 | 表示内容 | 表示項目
 |  | グローバルバッファ名 | グローバルバッファ種別 | 対応サーバ名※1 | 対応RDエリア数/インデクス名※2,※3
HiRDB | HiRDBに属するグローバルバッファの一覧を表示します。 | ○ | ○ | × | ○
マシン | 選択した構成要素に属するRDエリアに割り当てられたグローバルバッファを表示します。 データ用グローバルバッファが割り当てられていないRDエリアがある場合は，その他用RDエリアが割り当てられているものとして表示します。 詳細な表示条件は，「表3-18 グローバルバッファ一覧の表示条件」を参照してください。 | ○ | ○ | ○ | ○
ユニット
サーバ
RDエリア | RDエリアに割り当てられたグローバルバッファを表示します。 グローバルバッファが割り当てられていない場合は，何も表示されません。 | ○ | ○ | ○ | ○
上記以外 | 何も表示されません。 | × | × | × | ×

○：項目に内容が表示されることを示します。

×：項目に内容が表示されないことを示します。

※1 グローバルバッファが属するサーバ名を表示します。同じグローバルバッファが複数のサーバに属している場合は，属するサーバの数だけの行数が表示されます。

※2 グローバルバッファを割り当てたRDエリアの数を表示します。インデクス用グローバルバッファの場合は，インデクス名を表示します。

※3 グローバルバッファを割り当てたRDエリアの数が0，またはインデクスを割り当てていない場合，この項目の背景が赤色になります。

表3-18　グローバルバッファ一覧の表示条件

選択した構成要素に属するRDエリアのグローバルバッファ割り当て状態 |  | その他用グローバルバッファの作成状態 | グローバルバッファ一覧への表示内容
データ用 | LOB用 |  | データ用 | LOB用
未割り当て | 未割り当て | 未作成 | × | ×
 |  | 作成済み | △ | ×
 | 割り当て済み | 未作成 | × | ○
 |  | 作成済み | △ | ○
割り当て済み | 未割り当て | － | ○ | ×
 | 割り当て済み | － | ○ | ○

○：割り当て済みのグローバルバッファが表示されることを示します。

△：その他用のグローバルバッファが表示されることを示します。

×：何も表示されないことを示します。

－：その他用グローバルバッファの作成状態は関係ないことを示します。

(4)　システムログタブ

構成図やツリービューで選択した構成要素に属するシステムログファイルを表示，編集するためのタブです。システムログタブの内容を以下に示します。

表3-19　システムログタブの内容

システムログタブ |  |  | 内容
① | 表示対象の構成要素 |  | 選択した構成要素の名称を表示します。
② | システムログ一覧 | システムログ名 | 選択した構成要素に属するシステムログファイルの名称を表示します。
 |  | 対応サーバ名 | 表示したシステムログファイルに対応するサーバの名称を表示します。
③ | システムログ追加ボタン |  | 選択した構成要素にシステムログファイルを追加する場合に使用します。システムログファイルの追加方法は，「3.4.1(7) システムログファイルの追加」を参照してください。
④ | システムログ詳細表示ボタン |  | 選択した構成要素に属するシステムログファイルの詳細を表示，編集する場合に使用します。 システムログファイルの詳細情報は，［オペランド詳細ダイアログ］に表示されます。ダイアログの詳細は，「3.3.3(1) オペランド詳細ダイアログ」を参照してください。
⑤ | システムログ削除ボタン |  | 選択した構成要素に属するシステムログファイルを削除する場合に使用します。 「システムログ削除ボタン」を使用した，システムログファイルの削除方法は，「3.4.2 構成要素の削除」を参照してください。

(5)　シンクポイントダンプタブ

構成図やツリービューで選択した構成要素に属するシンクポイントダンプファイルを表示，編集するためのタブです。シンクポイントダンプタブの内容を以下に示します。

表3-20　シンクポイントダンプタブの内容

シンクポイントダンプタブ |  |  | 内容
① | 表示対象の構成要素 |  | 選択した構成要素の名称を表示します。
② | シンクポイントダンプファイル一覧 | シンクポイントダンプファイル名 | 選択した構成要素に属するシンクポイントダンプファイルの名称を表示します。
 |  | 対応サーバ名 | 表示したシンクポイントダンプファイルに対応するサーバの名称を表示します。シンクポイントダンプファイルの追加方法は，「3.4.1(8) シンクポイントダンプファイルの追加」を参照してください。
③ | シンクポイントダンプファイル追加ボタン |  | 選択した構成要素にシンクポイントダンプファイルを追加する場合に使用します。
④ | シンクポイントダンプファイル詳細表示ボタン |  | 選択した構成要素に属するシンクポイントダンプファイルの詳細を表示，編集する場合に使用します。 シンクポイントダンプファイルの詳細情報は，［オペランド詳細ダイアログ］に表示されます。ダイアログの詳細は，「3.3.3(1) オペランド詳細ダイアログ」を参照してください。
⑤ | シンクポイントダンプファイル削除ボタン |  | 選択した構成要素に属するシンクポイントダンプファイルを削除する場合に使用します。 「シンクポイントダンプファイル削除ボタン」を使用した，シンクポイントダンプファイルの削除方法は，「3.4.2 構成要素の削除」を参照してください。

(6)　ステータスファイルタブ

構成図やツリービューで選択した構成要素に属するステータスファイルを表示，編集するためのタブです。ステータスファイルタブの内容を以下に示します。

表3-21　ステータスファイルタブの内容

ステータスファイルタブ |  |  | 内容
① | 表示対象の構成要素 |  | 選択した構成要素の名称を表示します。
② | ステータスファイル一覧 | ステータスファイル名 | 選択した構成要素に属するステータスファイルの名称を表示します。
 |  | 対応ユニット／サーバ名 | 表示したステータスファイルに対応するユニット，またはサーバの名称を表示します。
③ | ステータスファイル追加ボタン |  | 選択した構成要素にステータスファイルを追加する場合に使用します。ステータスファイルの追加方法は，「3.4.1(9) ステータスファイルの追加」を参照してください。
④ | ステータスファイル詳細表示ボタン |  | 選択した構成要素に属するステータスファイルの詳細を表示，編集する場合に使用します。 ステータスファイルの詳細情報は，［オペランド詳細ダイアログ］に表示されます。ダイアログの詳細は，「3.3.3(1) オペランド詳細ダイアログ」を参照してください。
⑤ | ステータスファイル削除ボタン |  | 選択した構成要素に属するステータスファイルを削除する場合に使用します。 「ステータスファイル削除ボタン」を使用した，ステータスファイルの削除方法は，「3.4.2 構成要素の削除」を参照してください。

(7)　HAグループタブ

ツリービューで選択したHAグループに登録されているユニットを表示，編集するためのタブです。HAグループタブの内容を以下に示します。

表3-22　HAグループタブの内容

HAグループタブ |  | 内容
① | 表示対象の構成要素 | 選択した構成要素の名称を表示します。
② | 登録ユニット一覧 | 選択した構成要素がHAグループの場合，そのHAグループに登録されているユニットの名称を表示します。
③ | 登録ユニット削除ボタン | 選択した構成要素に登録されているユニットを削除する場合に使用します。 「登録ユニット削除ボタン」を使用した，ユニットの削除方法は，「3.4.6(5) HAグループの属性変更」を参照してください。


詳細ダイアログ

3.3.3　詳細ダイアログ

［構成情報ビュー］の［詳細］ボタンをクリックしたときに表示される［オペランド詳細ダイアログ］，および［RDエリア詳細ダイアログ］について説明します。

＜この項の構成＞
(1)　オペランド詳細ダイアログ
(2)　RDエリア詳細ダイアログ

(1)　オペランド詳細ダイアログ

構成要素定義情報に関連するオペランドの詳細を表示するダイアログです。オペランド詳細ダイアログの内容を以下に示します。

表3-23　オペランド詳細ダイアログの内容

オペランド詳細ダイアログ | 内容
① | オペランド名 | ［詳細］ボタンをクリックした際に選択していた構成要素定義情報に関連するオペランドが一覧表示されます。
② オペランド状態 ①のオペランドの値が，オペランドで規定された最小値と最大値の間に正しく設定されているかどうかを表示します。
「○」は，オペランドの値が正しく設定されていることを示します。
「△」は，オペランドの値がHiRDBの推奨値ではないことを示します。警告への対処は，HiRDBのマニュアル「システム定義」の「1.5　バージョンによって省略値が異なるオペランド，及び指定不要になったオペランド」の章を参照してください。
「×」はオペランドの値が正しく設定されていないことを示します。指定可能な範囲の値を設定してください。
「？」は，オペランドの値が未チェックであることを示します。指定可能な範囲の値を設定してください。
③ | オペランド情報 | オペランド名 | ①で選択したオペランドの名称を表示します。
④ | 値の型 | ①で選択したオペランドの値の型を表示します。
⑤ | 値の最小値 | ①で選択したオペランドの値の最小値を表示します。
⑥ | 値の最大値 | ①で選択したオペランドの値の最大値を表示します。
⑦ 値 ①で選択したオペランドの値を指定します。
  • 値に入力可能な文字と最大文字数については，HiRDBの仕様にしたがいます。
  • 入力値に空白を含む場合でも，引用符(")で囲まずに入力してください。
  • HiRDB Configuration Assistantが対応していないオペランドを既存HiRDBから取り込んだ場合，オペランドの値は空欄になります。
⑧ コメント ①で選択したオペランドのコメントを指定します。コメントの長さは79文字以内で指定してください。80文字目以降のコメントは，定義出力時に切り捨てられます。
なお，コメントは，以下の場合のみ編集可能となり，それ以外の場合は編集することができません。
  • 新しく追加したオペランドのコメント
  • 既存HiRDBから確定状態取り込みで取り込んだオペランドで，取り込み時から値を変更したオペランドのコメント
  • 既存HiRDBから新規状態取り込みで取り込んだオペランドのコメント
⑨ | 開始位置 | ①で選択したオペランドのコメントの開始位置を指定します。開始位置には，79（バイト）以下の数字を指定してください。開始位置を省略した場合，コメントは，オペランドの1行上に出力されます。
⑩ | オペランド解説 | ①で選択したオペランドの解説を表示します。
⑪ | オペランド追加ボタン | 新たにオペランドを追加する時にクリックします。
⑫ | オプション追加ボタン | ①で選択したオペランドに新たにオプションを追加する時にクリックします。
⑬ | 削除ボタン | ①で選択したオペランド，またはオプションを削除する時にクリックします。
⑭ | OKボタン | オペランド詳細ダイアログを閉じたい時，クリックします。

オペランド詳細ダイアログで表示されるオペランドについては，「3.2.7　構成要素定義情報のオペランド」を参照してください。

(2)　RDエリア詳細ダイアログ

RDエリアの詳細を表示するダイアログです。RDエリア詳細ダイアログの内容を以下に示します。

表3-24　RDエリア詳細ダイアログの内容

RDエリア詳細ダイアログ |  | 内容
① | RDエリア名 | RDエリアの名称を指定します。 RDエリア名を変更する方法は，「3.4.6(3) RDエリアの属性変更」を参照してください。
② | 対応サーバ名 | RDエリアが属するサーバの名称を指定します。 RDエリアが属するサーバを変更する方法は，「3.4.6(3) RDエリアの属性変更」を参照してください。
③ | 配置するHiRDBファイルシステム領域 | RDエリアを配置するHiRDBファイルシステム領域を指定します。 RDエリアを配置するHiRDBファイルシステム領域を変更する方法は，「3.4.6(3) RDエリアの属性変更」を参照してください。
④ | グローバルバッファ情報 | RDエリアをグローバルバッファに配置するかどうかを指定します。 グローバルバッファに配置する場合，［グローバルバッファに配置する］チェックボックスを有効にすることで，［グローバルバッファ名］，［LOB用グローバルバッファ名］でグローバルバッファの名称が指定できます。 RDエリアを配置するグローバルバッファを変更する方法は，「3.4.6(4) グローバルバッファの属性変更」を参照してください。
⑤ | OKボタン | RDエリア詳細ダイアログで設定した内容を有効にしたいとき，クリックします。RDエリア詳細ダイアログは閉じられます。
⑥ | キャンセルボタン | RDエリア詳細ダイアログで設定した内容を無効にしたいとき，クリックします。RDエリア詳細ダイアログは閉じられます。


HiRDB構成初期情報ダイアログ

3.3.4　HiRDB構成初期情報ダイアログ

HiRDB構成初期情報ダイアログは，HiRDB Configuration AssistantでHiRDBの構成に関する情報を入力，表示するためのダイアログです。

HiRDB構成初期情報ダイアログは，以下に示すタイミングで表示されます。

  • HiRDB構成情報の新規作成で，はじめてマシン，グローバルバッファ，またはHAグループを追加した時
  • 新規状態取り込み実行時
  • 確定状態取り込み実行時
  • メニューバーの［表示(V)］－［構成初期情報］実行時

HiRDB構成初期情報ダイアログの内容と更新可否を以下に示します。

表3-25　HiRDB構成初期情報ダイアログの内容と更新可否

設定項目 | 内容 | 更新可否※1
新規状態ファイル | 確定状態ファイル
初回※2 | メニュー※4 | 初回※3 | メニュー※4
① HiRDBバージョン 構築対象のHiRDBのバージョンを選択します。 ○※6,7,9 × ○※6,7,9 ×
② HiRDB種別 構築対象のHiRDBの種別を選択します。 ○※6,8,9 × × ×
③ HiRDBアドレッシングモード 構築対象のHiRDBのアドレッシングモードを選択します。 ○※6,9 × × ×
④ OS種別 構築対象のHiRDBのOS種別を選択します。 ○※6,9,10,11 × × ×
⑤ HiRDB運用ディレクトリ HiRDBが使用する環境変数PDDIRの値を指定します。
このダイアログで指定したPDDIRがシングルサーバの場合のPDDIRとなり，パラレルサーバの場合，各ユニットに指定するPDDIRの初期値となります。 		○ ○※5 × ×
⑥ ファイルの状態 HiRDB構成情報ファイルの種別を表示します。
  • 新規状態（新規構築用）
  • 確定状態（構成変更用）
 × × × ×

※1 ○は，設定項目が更新できることを示します。×は，設定項目が更新できないこと（参照のみ）を示します。

※2 HiRDB構成情報の新規作成で，はじめてマシン，グローバルバッファ，またはHAグループを追加した時，または新規定義取り込み時にHiRDB構成初期情報ダイアログが表示された場合を示します。

※3 確定定義取り込み時にHiRDB構成初期情報ダイアログが表示された場合を示します。

※4 メニューバーの［表示(V)］－［構成初期情報］からHiRDB構成初期情報ダイアログを表示させた場合を示します。

※5 一つも構成要素が存在しない新規状態ファイルの場合，［表示(V)］－［構成初期情報］からHiRDB構成初期情報ダイアログを表示させても更新できません。

※6 新規状態取り込み，または確定状態取り込み時に，取り込み対象のHiRDBからHiRDBバージョン，HiRDB種別，HiRDBアドレッシングモード，OS種別を変更した場合，取り込み対象のHiRDBで定義されていたオペランドが変更後のHiRDBで未サポートの無効なオペランドとなることがあります。無効なオペランドはHiRDB Configuration Assistantで参照・更新することはできません。また，定義出力時には無効なオペランドが定義ファイルに出力されますので，定義ファイルから削除してください。

※7 HiRDB構成情報の新規作成，新規状態取り込み，または確定状態取り込み時に，取り込み対象のHiRDBからHiRDBバージョンを下位バージョンに変更した場合，HiRDB Configuration Assistantで正しい定義ファイル，環境構築用バッチファイルが出力できない可能性がありますので，HiRDBのバージョンダウンとなる変更をしないでください。

※8 新規状態取り込み時に，取り込み対象のHiRDBからHiRDB種別を変更した場合，HiRDB Configuration Assistantで正しい定義ファイル，環境構築用バッチファイルが出力できない可能性がありますので，HiRDB種別を変更しないでください。

※9 新規状態取り込み，または確定状態取り込み時に，取り込み対象のHiRDBからHiRDBバージョン，HiRDB種別，HiRDBアドレッシングモード，OS種別を変更する場合，実際に存在しないHiRDBの組み合わせとなっていないことを確認してください。

※10 新規状態取り込み時に，取り込み対象のHiRDBからOS種別を変更する場合，HiRDB構成初期情報ダイアログに指定されたHiRDB運用ディレクトリのパスは変更後のOS種別に応じた文字でチェックします。そのため，新規定義取り込み時には，変更後のOSに合わせてHiRDB運用ディレクトリのパスを変更するようにしてください。

※11 新規状態取り込み時に，OS種別をWindows以外からWindowsに変更する場合，取り込み対象のHiRDBのHiRDBファイルシステム領域の名称が大文字，小文字の区別なく重複（例：DB1とdb1）していないことを事前に確認してください。WindowsではそれらのHiRDBファイルシステム領域の名称は同一名称として扱われてしまうため，新規状態取り込み実行前に入力ファイルを編集して重複が無くなるよう名称を変更してください。


基本操作

3.4　基本操作

構成要素に対する基本的な操作方法を説明します。

ここでは，構成要素に対する基本的な操作を，以下の6つに分けて説明しています。

表3-26　構成要素に対する基本的な操作

基本的な操作 | 対応するマニュアルの項目
追加 | 3.4.1 構成要素の追加
削除 | 3.4.2 構成要素の削除
移動 | 3.4.3 構成要素の移動
複写 | 3.4.4 構成要素の複写
情報参照 | 3.4.5 構成要素の情報参照
情報更新（名称変更，属性変更） | 3.4.6 構成要素の情報更新

各構成要素に対して実行可能な操作を構成要素の状態ごとに以下に示します。構成要素の状態（新規状態，または確定状態）の詳細については，「3.2.4　構成要素の状態」を参照してください。

表3-27　新規状態の構成要素に対して実行可能な操作

構成要素 |  | 新規状態の構成要素に対する操作
 |  | 追加 | 削除 | 移動 | 複写 | 情報参照 | 情報更新
 |  |  |  |  |  |  | 名称変更 | 属性変更
HiRDB |  | × | × | × | × | ○ | ○ | ○
マシン |  | ○ | ○ | ○※4 | ○※4 | ○ | ○ | ○
HiRDBファイルシステム領域 | DB用HiRDBファイルシステム領域 | ○ | ○※1 | ○※1 | ○ | ○ | ○※6 | ○※6
 | SDB用HiRDBファイルシステム領域 | ○ | ○※1 | ○※1 | ○ | ○ | ○※6 | ○※6
 | SYS用HiRDBファイルシステム領域 | ○ | ○※1 | ○※1 | ○ | ○ | ○※6 | ○※6
 | WORK用HiRDBファイルシステム領域 | ○ | ○※1 | ○※1 | ○ | ○ | ○※6 | ○※6
 | UTL用HiRDBファイルシステム領域 | ○ | ○ | ○ | ○ | ○ | ○※6 | ○※6
 | SVR用HiRDBファイルシステム領域 | ○ | ○※1 | ○※1 | ○ | ○ | ○※6 | ○※6
ユニット | ユニット | ○ | ○※3 | ○※2,3 | ○※2 | ○ | ○ | ○※6
 | 待機系ユニット | ○ | ○ | × | × | × | × | ×
サーバ | マネージャサーバ | ○ | ○ | ○※2 | ○※2 | × | ○ | ×
 | ディクショナリサーバ | ○ | ○ | ○※2 | ○※2 | ○ | ○ | ○※6
 | フロントエンドサーバ | ○ | ○ | ○※2 | ○※2 | ○ | ○ | ○※6
 | バックエンドサーバ | ○ | ○ | ○※2 | ○※2 | ○ | ○ | ○※6
 | シングルサーバ | ○ | ○ | ○※2 | ○※2 | ○ | ○ | ○※6
RDエリア | ユーザ用RDエリア | ○ | ○ | ○※2 | ○※2 | ○ | ○ | ○※6
 | LOB用RDエリア | ○ | ○ | ○※2 | ○※2 | ○ | ○ | ○※6
 | リスト用RDエリア | ○ | ○ | ○※2 | ○※2 | ○ | ○ | ○※6
 | 共用RDエリア | ○ | ○ | ○※2 | ○※2 | ○ | ○ | ○※6
 | レジストリ用RDエリア | ○ | ○ | ○※2 | ○※2 | ○ | ○ | ○※6
 | レジストリLOB用RDエリア | ○ | ○ | ○※2 | ○※2 | ○ | ○ | ○※6
 | マスタディレクトリ用RDエリア | ○ | ○ | ○※2 | ○※2 | ○ | ○ | ○※6
 | データディレクトリ用RDエリア | ○ | ○ | ○※2 | ○※2 | ○ | ○ | ○※6
 | データディクショナリ用RDエリア | ○ | ○ | ○※2 | ○※2 | ○ | ○ | ○※6
 | データディクショナリ用RDエリア（ルーチン用） | ○ | ○ | ○※2 | ○※2 | ○ | ○ | ○※6
 | データディクショナリLOB用RDエリア | ○ | ○ | ○※2 | ○※2 | ○ | ○ | ○※6
 | データディクショナリ用RDエリア（再編成時期予測用） | ○ | ○ | ○※2 | ○※2 | ○ | ○ | ○※6
グローバルバッファ | データ用グローバルバッファ | ○ | ○ | × | ○ | ○ | ○ | ○※6
 | LOB用グローバルバッファ | ○ | ○ | × | ○ | ○ | ○ | ○※6
 | インデクス用グローバルバッファ | ○ | ○ | × | ○ | ○ | ○ | ○※6
 | その他用グローバルバッファ | ○ | ○ | × | ○ | ○ | ○ | ○※6
システムファイル | システムログファイル | ○ | ○ | ○※2 | ○※2 | ○ | ○ | ○※6
 | シンクポイントダンプファイル | ○ | ○ | ○※2 | ○※2 | ○ | ○ | ○※6
 | ユニット用ステータスファイル | ○ | ○ | ○※2 | ○※2 | ○ | ○ | ○※6
 | サーバ用ステータスファイル | ○ | ○ | ○※2 | ○※2 | ○ | ○ | ○※6
HAグループ |  | ○ | ○ | × | × | ○ | ○ | ×

表3-28　確定状態の構成要素に対して実行可能な操作

構成要素 |  | 確定状態の構成要素に対する操作
 |  | 追加 | 削除 | 移動 | 複写 | 情報参照 | 情報更新※7
 |  |  |  |  |  |  | 名称変更 | 属性変更
HiRDB |  | × | × | × | × | ○ | × | ○
マシン |  | ○ | ○ | × | ○※4 | ○ | × | ○
HiRDBファイルシステム領域 | DB用HiRDBファイルシステム領域 | ○ | ○※1 | × | ○ | ○ | × | ×
 | SDB用HiRDBファイルシステム領域 | ○ | ○※1 | × | ○ | ○ | × | ×
 | SYS用HiRDBファイルシステム領域 | ○ | ○※1 | × | ○ | ○ | × | ×
 | WORK用HiRDBファイルシステム領域 | ○ | ○※1 | × | ○ | ○ | × | ×
 | UTL用HiRDBファイルシステム領域 | ○ | ○ | × | ○ | ○ | × | ×
 | SVR用HiRDBファイルシステム領域 | ○ | ○※1 | × | ○ | ○ | × | ×
ユニット | ユニット | ○ | ○※3 | × | ○※2 | ○ | × | ○
 | 待機系ユニット | ○ | ○ | × | × | × | × | ×
サーバ | マネージャサーバ | ○ | ○ | × | ○※2 | × | × | ×
 | ディクショナリサーバ | ○ | ○ | × | ○※2 | ○ | × | ○
 | フロントエンドサーバ | ○ | ○ | × | ○※2 | ○ | × | ○
 | バックエンドサーバ | ○ | ○ | × | ○※2 | ○ | × | ○
 | シングルサーバ | ○ | ○ | × | ○※2 | ○ | × | ○
RDエリア | ユーザ用RDエリア | ○ | ○ | × | ○※2 | ○ | × | ○※5
 | LOB用RDエリア | ○ | ○ | × | ○※2 | ○ | × | ○※5
 | リスト用RDエリア | ○ | ○ | × | ○※2 | ○ | × | ○※5
 | 共用RDエリア | ○ | ○ | × | ○※2 | ○ | × | ○※5
 | レジストリ用RDエリア | ○ | ○ | × | ○※2 | ○ | × | ○※5
 | レジストリLOB用RDエリア | ○ | ○ | × | ○※2 | ○ | × | ○※5
 | マスタディレクトリ用RDエリア | ○ | ○ | × | ○※2 | ○ | × | ○※5
 | データディレクトリ用RDエリア | ○ | ○ | × | ○※2 | ○ | × | ○※5
 | データディクショナリ用RDエリア | ○ | ○ | × | ○※2 | ○ | × | ○※5
 | データディクショナリ用RDエリア（ルーチン用） | ○ | ○ | × | ○※2 | ○ | × | ○※5
 | データディクショナリLOB用RDエリア | ○ | ○ | × | ○※2 | ○ | × | ○※5
 | データディクショナリ用RDエリア（再編成時期予測用） | ○ | ○ | × | ○※2 | ○ | × | ○※5
グローバルバッファ | データ用グローバルバッファ | ○ | ○ | × | ○ | ○ | × | ○
 | LOB用グローバルバッファ | ○ | ○ | × | ○ | ○ | × | ○
 | インデクス用グローバルバッファ | ○ | ○ | × | ○ | ○ | × | ○
 | その他用グローバルバッファ | ○ | ○ | × | ○ | ○ | × | ○
システムファイル | システムログファイル | ○ | ○ | × | ○※2 | ○ | × | ×
 | シンクポイントダンプファイル | ○ | ○ | × | ○※2 | ○ | × | ×
 | ユニット用ステータスファイル | ○ | ○ | × | ○※2 | ○ | × | ×
 | サーバ用ステータスファイル | ○ | ○ | × | ○※2 | ○ | × | ×
HAグループ |  | ○ | ○ | × | × | ○ | × | ×

○は，操作可能なことを示します。

×は，操作できないことを示します。

※1 操作対象のHiRDBファイルシステム領域に割り当てているHiRDBファイルが存在した場合，操作対象のHiRDBファイルシステム領域との関連が失われ，HiRDBファイルの格納先が無くなるため，HiRDBファイルの格納先を変更する必要があります。

※2 構成要素の移動・複写先に，HiRDBファイルの格納先となるHIRDBファイルシステム領域が存在しない場合には，HiRDBファイルシステム領域との関連が失われ，HiRDBファイルの格納先が無くなります。そのため，構成要素の移動・複写後に，以下のいずれかの対処を行ってください。

  • 関連するHiRDBファイルシステム領域を，構成要素の移動・複写先に移動・複写する。
  • 関連するHiRDBファイルシステム領域と同じ名前のHiRDBファイルシステム領域を，構成要素の移動・複写先に新規作成する。
  • HiRDBファイルの格納先を変更する。

※3 操作対象のユニットと関連した待機系ユニットも同時に削除されます。

※4 操作対象のマシンに属する待機系ユニットは複写されません。必要に応じて，複写したマシン上に新たに待機系ユニットを追加してください。

※5 一部のオペランドのみ，更新することができます。更新可否を以下に示します。

表3-29　確定状態のRDエリアに対する属性変更（オペランド更新）実行可否

オペランド名 | 属性変更（オペランド更新）の内容
 | 定義されていないオペランドの追加 | 定義済みのオペランドの変更 | 定義済みのオペランドの削除
open_attribute | × | × | ×
grantee | × | × | ×
page_size | × | × | ×
segment_size | × | × | ×
extension | ○ | ○ | ×
file_name_1 | × | × | ×
file_name_2 ～ file_name_16 | ○ | × | ×
initial_segments_1 | × | × | ×
initial_segments_2 ～ initial_segments_16 | ○ | × | ×
max_entries | × | × | ×
temp_globalbuffer | × | × | ×
globalbuffer | ○ | ○ | ○
globalbuffer_for_lob | ○ | ○ | ○
temporary_table | × | × | ×

※6 置換対象としてHiRDB，またはマシン以外を選択してパス名の置換を行った場合，HiRDBファイルシステム領域との関連が失われ，HiRDBファイルの格納先が無くなることがあります。そのため，置換の対象としてHiRDB，またはマシンを選択することを推奨します。もし，HiRDB，またはマシン以外を選択してパス名の置換を行った場合は，置換実行後にオペランド値を確認し，必要に応じて設定し直してください。

※7 HiRDB構成情報の置換によって，確定状態の構成要素の情報更新を行うことはできません。

注意
構成要素を削除・移動・複写した場合，削除・移動・複写対象の構成要素の子となる構成要素も同時に削除・移動・複写されます。
また，HiRDBファイルシステム領域とRDエリアのように，関連があっても親子関係でない構成要素は，同時に削除・移動・複写されません。
構成要素の親子関係は，「3.2.3　構成要素の親子関係」を参照してください。

＜この節の構成＞
3.4.1　構成要素の追加
3.4.2　構成要素の削除
3.4.3　構成要素の移動
3.4.4　構成要素の複写
3.4.5　構成要素の情報参照
3.4.6　構成要素の情報更新


構成要素の追加

3.4.1　構成要素の追加

HiRDBに構成要素を追加する方法について，説明します。

追加が可能な構成要素の種別，および追加時の注意事項については，「3.4　基本操作」の説明，および以下の注意事項を参照してください。

  • アイテムボックスから構成図，またはツリービュー上に構成要素をドラッグアンドドロップするときには，「3.2.3　構成要素の親子関係」にしたがった場所にしかドロップすることはできません。それ以外の場所では，マウスカーソルが進入禁止マークとなり，ドロップできなくなります。
  • 追加した構成要素には，名称が自動的に与えられます。構成要素を追加した後，必要に応じて名称を変更してください。構成要素の名称を変更する方法は，「3.4.6(1)　構成要素の名称変更」を参照してください。
  • 追加した構成要素のオペランドのうち，「表3-7　HiRDB Configuration Assistantが設定するデフォルト値」に示したオペランドはHiRDB Configuration Assistantがデフォルト値を設定します。このデフォルト値を一括して置換したい場合，「3.4.6(6)　HiRDB構成情報の置換」を参照してください。

以下に，構成要素の種別ごとの追加方法を説明します。

＜この項の構成＞
(1)　マシンの追加
(2)　ユニットの追加
(3)　サーバの追加
(4)　HiRDBファイルシステムの追加
(5)　グローバルバッファの追加
(6)　RDエリアの追加
(7)　システムログファイルの追加
(8)　シンクポイントダンプファイルの追加
(9)　ステータスファイルの追加
(10)　HAグループの追加

(1)　マシンの追加

  1. アイテムボックスからマシンを選択し，構成図，またはツリービューの何もないところにドラッグアンドドロップします。

    この操作により，マシンが追加されます。
    はじめてマシンを追加した場合，［HiRDB構成初期情報ダイアログ］が表示されます。
    ［HiRDB構成初期情報ダイアログ］の詳細は，「3.3.4　HiRDB構成初期情報ダイアログ」を参照してください。
  2. 「HiRDBバージョン」，「HiRDB種別」，「HiRDBアドレッシングモード」，および「OS種別」を，HiRDBの環境に合わせてプルダウンメニューから選択します。
  3. 「HiRDB運用ディレクトリ」をHiRDBの環境に合わせて入力します。
  4. ［OK］ボタンをクリックします。

(2)　ユニットの追加

  1. アイテムボックスの中から配置したいユニットを選択し，構成図，またはツリービューのマシン上にドラッグアンドドロップします。

    ユニットが追加されます。
    待機系ユニットを追加した場合，「スタンバイ型系切り替え詳細ダイアログ」が表示されます。

    待機系ユニットに対応するユニットをプルダウンメニューから選択して，［OK］ボタンをクリックしてください。
    系切り替え構成の構築例は，「付録G.1　系切り替え構成の構築」を参照してください。

(3)　サーバの追加

  1. アイテムボックスの中から配置したいサーバを選択し，構成図，またはツリービューのユニット上にドラッグアンドドロップします。

    サーバが追加されます。

(4)　HiRDBファイルシステムの追加

  1. アイテムボックスから配置したいHiRDBファイルシステムを選択し，構成図，またはツリービューのマシン上にドラッグアンドドロップします。

    HiRDBファイルシステムが追加されます。

(5)　グローバルバッファの追加

  1. アイテムボックスから配置したいグローバルバッファを選択し，構成図の白地部分，ツリービューのHiRDB，ツリービューのRDエリア上にドラッグアンドドロップします。

    グローバルバッファが追加されます。
    ツリービューのRDエリア上にドラッグアンドドロップしてグローバルバッファを追加した場合，グローバルバッファを追加すると同時に，ドラッグアンドドロップしたRDエリアに対して，追加したグローバルバッファを割り当てることができます。
    グローバルバッファを追加した後で，RDエリアに対してグローバルバッファを割り当てる方法については，「3.4.6(4)　グローバルバッファの属性変更」を参照してください。

(6)　RDエリアの追加

  1. 配置したいRDエリアをアイテムボックスの中から選択し，構成図，またはツリービューのサーバ，またはHiRDBファイルシステム領域上にドラッグアンドドロップします。

  2. RDエリアをサーバにドロップすると［RDエリア詳細ダイアログ］が表示されます。

  3. 「RDエリア名」を入力します。
  4. 「対応サーバ名」をプルダウンメニューから選択します。
    配置したいRDエリアを，サーバ上にドラッグアンドドロップした場合，「対応サーバ名」にはドラッグアンドドロップ先のサーバ名が設定されますので，選択する必要はありません。
  5. 「配置するHiRDBファイルシステム領域」をプルダウンメニューから選択します。
    HiRDBファイルシステム領域は，1個から16個まで指定することができます。
    • 1個だけ指定する場合には，一番上の（必須）と記載されたプルダウンメニューから選択してください。
    • 2個以上指定する場合には，一番上の（必須）と記載されたプルダウンメニューと，その下にある（任意）と記載されたプルダウンメニューから選択してください。
    なお，配置したいRDエリアを，HiRDBファイルシステム領域上にドラッグアンドドロップした場合，1個目の「配置するHiRDBファイルシステム領域」にはドラッグアンドドロップ先のHiRDBファイルシステム領域名が設定されますので，選択する必要はありません。
  6. 追加するRDエリアをグローバルバッファに配置する場合，「グローバルバッファに配置する」チェックボックスをクリックして，チェックを入れます。その後，「グローバルバッファ名」と「LOB用グローバルバッファ名」をプルダウンメニューから選択します。
    なお，「LOB用グローバルバッファ名」は，追加するRDエリアの種類が以下に示す場合のみ，選択できます。
    • LOB用RDエリア
    • データディクショナリLOB用RDエリア
    • レジストリLOB用RDエリア
  7. ［OK］ボタンをクリックします。
    RDエリアが追加されます。

RDエリア追加時の注意事項を以下に説明します。

  • RDエリアを追加するためには，RDエリアを格納するHiRDBファイルシステム領域を用意しておく必要があります。

(7)　システムログファイルの追加

  1. 構成図，またはツリービューのサーバをクリックで選択します。

  2. 構成情報ビューの［システムログ］タブをクリックで選択します。

  3. ［追加］ボタンをクリックします。

    ［HiRDBファイルシステム領域選択ダイアログ］が表示されます。
  4. システムログファイルを設定するHiRDBファイルシステム領域を「A系」と「B系」のそれぞれ，ドロップダウンリストから選択します。
    「A系」と「B系」の両方を選択するためには，pd_log_dualに"Y"を指定する必要があります。"N"を指定している場合には，「B系」を選択することはできません。
  5. ［OK］ボタンをクリックします。
    システムログファイルが追加されます。

システムログファイル追加時の注意事項を以下に説明します。

  • システムログファイルを追加するためには，システムログファイルを格納するHiRDBファイルシステム領域を用意しておく必要があります。

(8)　シンクポイントダンプファイルの追加

  1. 構成図，またはツリービュー上のサーバをクリックで選択します。

  2. 構成情報ビューの［シンクポイントダンプ］タブをクリックで選択します。

  3. ［追加］ボタンをクリックします。

    ［HiRDBファイルシステム領域選択ダイアログ］が表示されます。
  4. シンクポイントダンプファイルを設定するHiRDBファイルシステム領域を「A系」と「B系」のそれぞれ，ドロップダウンリストから選択します。
    「A系」と「B系」の両方を選択するためには，pd_spd_dualに"Y"を指定する必要があります。"N"を指定している場合には，「B系」を選択することはできません。
  5. ［OK］ボタンをクリックします。
    シンクポイントダンプファイルが追加されます。

シンクポイントダンプファイル追加時の注意事項を以下に説明します。

  • シンクポイントダンプファイルを追加するためには，シンクポイントダンプファイルを格納するHiRDBファイルシステム領域を用意しておく必要があります。

(9)　ステータスファイルの追加

  1. 構成図，またはツリービュー上のステータスファイルを追加したいユニット，またはサーバをクリックで選択します。

  2. 構成情報ビューの［ステータスファイル］タブをクリックで選択します。

  3. ［追加］ボタンをクリックします。

    ［HiRDBファイルシステム領域選択ダイアログ］が表示されます。
  4. ステータスファイルを設定するHiRDBファイルシステム領域を「A系」と「B系」のそれぞれ，ドロップダウンリストから選択します。
  5. ［OK］ボタンをクリックします。
    ステータスファイルが追加されます。

ステータスファイル追加時の注意事項を以下に説明します。

  • ステータスファイルを追加するためには，ステータスファイルを格納するHiRDBファイルシステム領域を用意しておく必要があります。

(10)　HAグループの追加

  1. アイテムボックスから構成要素「HAグループ」を選択し，構成図，またはツリービューの何もないところにドラッグアンドドロップします。

    HAグループが追加されます。


構成要素の削除

3.4.2　構成要素の削除

HiRDBの構成要素を削除する方法について，説明します。

削除が可能な構成要素の種別，および削除時の注意事項については，「3.4　基本操作」の説明，および以下の注意事項を参照してください。

  • 構成要素を削除した場合，削除対象の構成要素の子となる構成要素も同時に削除されます。
    また，HiRDBファイルシステム領域とRDエリアのように，関連があっても親子関係でない構成要素は，同時に削除されません。
    構成要素の親子関係は，「3.2.3　構成要素の親子関係」を参照してください。

構成要素を削除する方法として，以下に示す2つの方法があります。

  • 構成図，またはツリービューを使用した構成要素の削除
  • 構成情報ビューを使用した構成要素の削除

それぞれの方法について，以下に説明します。

＜この項の構成＞
(1)　構成図，またはツリービューを使用した構成要素の削除
(2)　構成情報ビューを使用した構成要素の削除

(1)　構成図，またはツリービューを使用した構成要素の削除

  1. 構成図，またはツリービュー上の削除したい構成要素をクリックで選択します。

  2. 右クリックで表示されるコンテキストメニューから，［削除(D)］を選択します。
    コンテキストメニューによる操作以外にも，以下の操作を行うことで，構成要素の削除を行うことができます。
    • Deleteキーの押下
    • ショートカットキーによる切り取り（CTRL+x）
    • メニューバーのコマンド呼び出しによる切り取り（［編集(E)］－［切り取り(X)］）
  3. 削除の実行を確認するダイアログが表示されますので，［OK］ボタンをクリックします。
    構成要素と，その構成要素に属する構成要素が全て削除されます。

(2)　構成情報ビューを使用した構成要素の削除

以下に示す構成要素については，構成図，またはツリービュー上での操作に加えて，構成情報ビュー上で削除を実行することができます。

  • RDエリア
  • システムログファイル
  • シンクポイントダンプファイル
  • ステータスファイル
  1. 構成情報ビューのタブから，削除したい構成要素に該当するタブを選択して，クリックします。

    構成要素の一覧が表示されます。
  2. 構成要素の一覧から，削除したい構成要素をクリックで選択します。

    選択した構成要素が反転表示されます。
  3. 構成情報ビュー上の［削除］ボタンをクリックします。

  4. 削除の実行を確認するダイアログが表示されますので，［OK］ボタンをクリックします。
    選択した構成要素が削除されます。


構成要素の移動

3.4.3　構成要素の移動

HiRDBの構成要素を移動させる方法について，説明します。

移動が可能な構成要素の種別，および移動時の注意事項については，「3.4　基本操作」の説明，および以下の注意事項を参照してください。

  • 構成要素を移動した場合，移動対象の構成要素の子となる構成要素も同時に移動します。
    また，HiRDBファイルシステム領域とRDエリアのように，関連があっても親子関係でない構成要素は，同時に移動しません。
    構成要素の親子関係は，「3.2.3　構成要素の親子関係」を参照してください。
  • RDエリアを移動させた場合，「3.4.1(6)　RDエリアの追加」と同様に，［RDエリア詳細ダイアログ］が表示されますので，RDエリアに関する設定を再度行ってください。
  • 移動した構成要素，および移動対象の構成要素の子となる構成要素のオペランドを一括して置換したい場合，「3.4.6(6)　HiRDB構成情報の置換」を参照してください。

構成要素を移動させる方法として，以下に示す2つの方法があります。

  • ドラッグアンドドロップによる構成要素の移動
  • 切り取りと貼り付けによる構成要素の移動

それぞれの方法について，以下に説明します。

＜この項の構成＞
(1)　ドラッグアンドドロップによる構成要素の移動
(2)　切り取りと貼り付けによる構成要素の移動

(1)　ドラッグアンドドロップによる構成要素の移動

  1. 構成図，またはツリービュー上で，移動させたい構成要素を，移動先の構成要素上にドラッグアンドドロップします。

    構成要素が移動します。
    構成要素をドラッグアンドドロップするときには，「3.2.3　構成要素の親子関係」にしたがった場所にしかドロップすることはできません。それ以外の場所では，マウスカーソルが進入禁止マークとなり，ドロップできなくなります。

(2)　切り取りと貼り付けによる構成要素の移動

  1. 構成図，またはツリービュー上で，移動したい構成要素をクリックで選択します。

  2. 右クリックで表示されるコンテキストメニューから，［切り取り(T)］を選択します。
    移動したい構成要素が切り取られます。
    コンテキストメニューによる操作以外にも，以下の操作を行うことで，構成要素の切り取りを行うことができます。
    • ショートカットキーによる切り取り（CTRL+x）
    • メニューバーのコマンド呼び出しによる切り取り（［編集(E)］－［切り取り(X)］）
  3. 構成図，またはツリービュー上で，構成要素の移動先の構成要素をクリックで選択します。
  4. 右クリックで表示されるコンテキストメニューから，［貼り付け(P)］を選択します。
    構成要素が移動します。
    構成要素の貼り付け先は，「3.2.3　構成要素の親子関係」にしたがった場所でなければなりません。
    コンテキストメニューによる操作以外にも，以下の操作を行うことで，構成要素の貼り付けを行うことができます。
    • ショートカットキーによる貼り付け（CTRL+v）
    • メニューバーのコマンド呼び出しによる貼り付け（［編集(E)］－［貼り付け(P)］）


構成要素の複写

3.4.4　構成要素の複写

HiRDBの構成要素を複写する方法について，説明します。

複写が可能な構成要素の種別，および複写時の注意事項については，「3.4　基本操作」の説明，および以下の注意事項を参照してください。

  • 構成要素を複写した場合，複写対象の構成要素の子となる構成要素も同時に複写します。
    また，HiRDBファイルシステム領域とRDエリアのように，関連があっても親子関係でない構成要素は，同時に複写しません。
    構成要素の親子関係は，「3.2.3　構成要素の親子関係」を参照してください。
  • RDエリアを複写した場合，「3.4.1(6)　RDエリアの追加」と同様に，［RDエリア詳細ダイアログ］が表示されますので，RDエリアに関する設定を行ってください。
  • 複写した構成要素，および複写対象の構成要素の子となる構成要素のオペランドを一括して置換したい場合，「3.4.6(6)　HiRDB構成情報の置換」を参照してください。

構成要素を複写する方法として，以下に示す2つの方法があります。

  • ドラッグアンドドロップによる構成要素の複写
  • コピーと貼り付けによる構成要素の複写

それぞれの方法について，以下に説明します。

＜この項の構成＞
(1)　ドラッグアンドドロップによる構成要素の複写
(2)　コピーと貼り付けによる構成要素の複写

(1)　ドラッグアンドドロップによる構成要素の複写

  1. 構成図，またはツリービュー上で，移動させたい構成要素を，CTRLキーを押しながら移動先の構成要素上にドラッグアンドドロップします。

    構成要素が複写されます。
    構成要素をドラッグアンドドロップするときには，「3.2.3　構成要素の親子関係」にしたがった場所にしかドロップすることはできません。それ以外の場所では，マウスカーソルが進入禁止マークとなり，ドロップできなくなります。

(2)　コピーと貼り付けによる構成要素の複写

  1. 構成図，またはツリービュー上で，複写したい構成要素をクリックで選択します。

  2. 右クリックで表示されるコンテキストメニューから，［コピー(C)］を選択します。
    コンテキストメニューによる操作以外にも，以下の操作を行うことで，構成要素のコピーを行うことができます。
    • ショートカットキーによるコピー（CTRL+c）
    • メニューバーのコマンド呼び出しによるコピー（［編集(E)］－［コピー(C)］）
  3. 構成図，またはツリービュー上の，構成要素をクリックで選択します。
  4. 右クリックで表示されるコンテキストメニューから，［貼り付け(P)］を選択します。
    構成要素が複写されます。
    構成要素の貼り付け先は，「3.2.3　構成要素の親子関係」にしたがった場所でなければなりません。
    コンテキストメニューによる操作以外にも，以下の操作を行うことで，構成要素の貼り付けを行うことができます。
    • ショートカットキーによる貼り付け（CTRL+v）
    • メニューバーのコマンド呼び出しによる貼り付け（［編集(E)］－［貼り付け(P)］）


構成要素の情報参照

3.4.5　構成要素の情報参照

構成要素に関連する情報を参照する方法について，説明します。

＜この項の構成＞
(1)　オペランド詳細参照
(2)　RDエリアの一覧参照
(3)　グローバルバッファの一覧参照
(4)　システムログファイルの一覧参照
(5)　シンクポイントダンプファイルの一覧参照
(6)　ステータスファイルの一覧参照
(7)　HAグループの一覧参照

(1)　オペランド詳細参照

  1. 構成図，またはツリービュー上で，構成要素をクリックします。
  2. 構成情報ビューの「構成要素一覧」タブをクリックします。
    選択した構成要素と，その構成要素に対応する構成要素定義情報が一覧表示されます。
  3. オペランド詳細を表示したい構成要素定義情報をクリックで選択します。

  4. ［詳細］ボタンをクリックします。
    ［オペランド詳細ダイアログ］が開き，構成要素定義情報に関連したオペランドが一覧表示されます。
  5. 詳細を参照したいオペランドをクリックで選択します。

    オペランドの詳細情報（「値の型」「値の最小値」「値の最大値」「値」「コメント」「開始位置」「オペランドの説明」）が表示されます。

(2)　RDエリアの一覧参照

構成要素に属するRDエリアの一覧，またはグローバルバッファと関連付けられたRDエリアの一覧を参照する方法を説明します。

  1. 構成図，またはツリービュー上で，RDエリア一覧を参照したい構成要素をクリックで選択します。
  2. 詳細情報ビューの［RDエリア］タブをクリックで選択します。

    構成要素に属するRDエリアの一覧，またはグローバルバッファと関連付けられたRDエリアの一覧が表示されます。
    表示される情報の詳細は，「3.3.2(2)　RDエリア一覧タブ」を参照してください。

(3)　グローバルバッファの一覧参照

構成要素に属するグローバルバッファ，または構成要素に属するRDエリアと関連付けられたグローバルバッファの一覧を参照する方法を説明します。

  1. 構成図，またはツリービュー上で，グローバルバッファ一覧を参照したい構成要素をクリックで選択します。
  2. 詳細情報ビューの［グローバルバッファ］タブをクリックで選択します。

    構成要素に属するグローバルバッファ，または構成要素に属するRDエリアと関連付けられたグローバルバッファが一覧で表示されます。
    表示される情報の詳細は，「3.3.2(3)　グローバルバッファタブ」を参照してください。

(4)　システムログファイルの一覧参照

構成要素に属するシステムログファイルの一覧を参照する方法を説明します。

  1. 構成図，またはツリービュー上で，システムログファイル一覧を参照したい構成要素をクリックで選択します。
  2. 詳細情報ビューの［システムログ］タブをクリックで選択します。

    構成要素に属するシステムログファイルが一覧で表示されます。

(5)　シンクポイントダンプファイルの一覧参照

構成要素に属するシンクポイントダンプファイルの一覧を参照する方法を説明します。

  1. 構成図，またはツリービュー上で，シンクポイントダンプファイル一覧を参照したい構成要素をクリックで選択します。
  2. 詳細情報ビューの［シンクポイントダンプ］タブをクリックで選択します。

    構成要素に属するシンクポイントダンプファイルが一覧で表示されます。

(6)　ステータスファイルの一覧参照

構成要素に属するステータスファイルの一覧を参照する方法を説明します。

  1. 構成図，またはツリービュー上で，ステータスファイル一覧を参照したい構成要素をクリックで選択します。
  2. 詳細情報ビューの［ステータスファイル］タブをクリックで選択します。

    構成要素に属するステータスファイルが一覧で表示されます。

(7)　HAグループの一覧参照

HAグループに登録されたユニットの一覧を参照する方法を説明します。

  1. ツリービュー上で，登録されたユニットの一覧を参照したいHAグループを，クリックで選択します。

  2. 構成情報ビューの「HAグループ」タブをクリックします。

    HAグループに登録されているユニットの一覧が表示されます。


構成要素の情報更新

3.4.6　構成要素の情報更新

構成要素の情報を更新する方法について説明します。

＜この項の構成＞
(1)　構成要素の名称変更
(2)　構成要素の属性変更（オペランド更新）
(3)　RDエリアの属性変更
(4)　グローバルバッファの属性変更
(5)　HAグループの属性変更
(6)　HiRDB構成情報の置換

(1)　構成要素の名称変更

構成要素の名称を変更する方法を以下で説明します。

  1. 構成図，またはツリービュー上で，名称を変更したい構成要素をクリックで選択します。
  2. 右クリックで表示されるコンテキストメニューから，［名称の変更(R)］を選択します。

    ［名称変更ダイアログ］が表示されます。
    コンテキストメニューによる操作以外にも，以下の操作を行うことで，構成要素の名称変更を行うことができます。
    • ショートカットキーによる名称変更（F2）
    • メニューバーのコマンド呼び出しによる名称変更（［編集(E)］－［名称の変更(R)］）
  3. ［名称変更ダイアログ］に変更後の名称を入力して，［OK］ボタンをクリックします。
    構成要素の名称が変更されます。

構成要素の名称変更時の注意事項を以下に示します。

  • 以下に示す構成要素の名称を変更する場合，HiRDB内で大文字，小文字の区別なく重複しない名称に変更するようにしてください。
    • マシン
    • ユニット
    • サーバ
    例えば，マシンの名称を変更する時，すでにHiRDB内に"host1"というマシンが存在する場合，"Host1"，"HOST1"等の名称には変更しないでください。
  • 構成要素の名称（HiRDBファイルシステム領域名）をまとめて変更（置換）したい場合は，「3.4.6(6)　HiRDB構成情報の置換」を参照してください。

(2)　構成要素の属性変更（オペランド更新）

構成要素定義情報に関連するオペランドを追加・編集・削除する方法を以下で説明します。オペランドの詳細については，「3.2.7　構成要素定義情報のオペランド」を参照してください。

(a)　オペランドの追加
  1. 構成図，またはツリービュー上で，構成要素をクリックで選択します。
  2. 詳細情報ビューの［構成要素一覧］タブをクリックで選択します。
    選択した構成要素と，その構成要素に対応する構成要素定義情報が一覧表示されます。
  3. オペランドを追加したい構成要素定義情報をクリックで選択し，［詳細］ボタンをクリックします。

    ［オペランド詳細ダイアログ］が開きます。
  4. ［オペランド追加］ボタンをクリックします。

    「オペランド追加ダイアログ」が表示されます。
  5. 追加したいオペランドのチェックボックスをクリックして選択します。
  6. ［追加］ボタンをクリックします。

    選択したオペランドが，［オペランド詳細ダイアログ］の一覧に追加されます。
    追加したオペランドの「値」「コメント」「開始位置」の設定方法は，「3.4.6(2)(c)　オペランド・オプションの編集」を参照してください。
(b)　オプションの追加
  1. 構成図，またはツリービュー上で，構成要素をクリックで選択します。
  2. 詳細情報ビューの［構成要素一覧］タブをクリックで選択します。
    選択した構成要素と，その構成要素に対応する構成要素定義情報が一覧表示されます。
  3. オプションを追加したい構成要素定義情報をクリックで選択し，［詳細］ボタンをクリックします。

    ［オペランド詳細ダイアログ］が開きます。
  4. オプションを追加したいオペランドをクリックで選択し，［オプション追加］ボタンをクリックします。

    「オプション追加ダイアログ」が表示されます。
    なお，選択したオペランドにオプションを追加できない場合には，［オプション追加］ボタンをクリックすることはできません。
  5. 追加したいオプションのチェックボックスをクリックして選択します。

  6. ［追加］ボタンをクリックします。
    選択したオプションが，［オペランド詳細ダイアログ］の一覧に追加されます。
    追加したオプションの「値」「コメント」「開始位置」の設定方法は，「3.4.6(2)(c)　オペランド・オプションの編集」を参照してください。
(c)　オペランド・オプションの編集
  1. 構成図，またはツリービュー上で，構成要素をクリックで選択します。
  2. 詳細情報ビューの［構成要素一覧］タブをクリックで選択します。
    選択した構成要素と，その構成要素に対応する構成要素定義情報が一覧表示されます。
  3. オペランド，またはオプションを編集する構成要素定義情報をクリックで選択し，［詳細］ボタンをクリックします。

    ［オペランド詳細ダイアログ］が開きます。
  4. 編集したいオペランド，またはオプションをクリックで選択します。
    オペランド，またはオプションの詳細情報（「値の型」「値の最小値」「値の最大値」「値」「コメント」「開始位置」「オペランドの説明」）が表示されます。
  5. オペランド，またはオプションの詳細情報（「値」「コメント」「開始位置」）を編集します。

    各詳細情報の設定内容については，「3.3.3(1)　オペランド詳細ダイアログ」を参照してください。
    オペランド，またはオプションの情報が設定されます。

構成要素のオペランド，またはオプションをまとめて変更（置換）したい場合は，「3.4.6(6)　HiRDB構成情報の置換」を参照してください。

(d)　オペランド・オプションの削除
  1. 構成図，またはツリービュー上で，構成要素をクリックで選択します。
  2. 詳細情報ビューの［構成要素一覧］タブをクリックで選択します。
    選択した構成要素と，その構成要素に対応する構成要素定義情報が一覧表示されます。
  3. オペランド，またはオプションを削除する構成要素定義情報をクリックで選択し，［詳細］ボタンをクリックします。

    ［オペランド詳細ダイアログ］が開きます。
  4. 削除したいオペランド，またはオプションをクリックで選択します。
  5. ［削除］ボタンをクリックします。

  6. 削除の実行を確認するダイアログが表示されますので，［OK］ボタンをクリックします。
    選択したオペランド，またはオプションが削除されます。

(3)　RDエリアの属性変更

  1. 情報を更新したいRDエリアが属する構成要素をクリックで選択します。
  2. 構成情報ビューの［RDエリア］タブをクリックで選択します。
    構成要素に属するRDエリアが一覧表示されます。
  3. 情報を更新したいRDエリアをクリックで選択し，［詳細］ボタンをクリックします。

    ［RDエリア詳細ダイアログ］が表示されます。
  4. RDエリアの詳細情報（「RDエリア名」，「対応サーバ名」，「配置するHiRDBファイルシステム領域」，「グローバルバッファ情報」）が表示されますので，その値を更新します。

    各詳細情報の設定内容は，「3.3.3(2)　RDエリア詳細ダイアログ」「3.4.6(4)　グローバルバッファの属性変更」を参照してください。
  5. ［OK］ボタンをクリックします。
    RDエリアの詳細情報が更新されます。

(4)　グローバルバッファの属性変更

グローバルバッファをRDエリアに割り当てる，または割り当てを解除する方法を以下に説明します。

(a)　ツリービューを使用したグローバルバッファの割り当て
  1. ツリービュー上で，以下に示すいずれかの操作を行います。
    • RDエリアを，割り当てたいグローバルバッファにドラッグアンドドロップ

    • 割り当てたいグローバルバッファを，RDエリアにドラッグアンドドロップ

    RDエリアにグローバルバッファが割り当てられます。
(b)　RDエリア詳細ダイアログを使用したグローバルバッファの割り当て・割り当て解除
  1. グローバルバッファの割り当て，または割り当て解除をしたいRDエリアが属する構成要素をクリックで選択します。
  2. 構成情報ビューの［RDエリア］タブをクリックで選択します。
    構成要素に属するRDエリアが一覧表示されます。
  3. グローバルバッファの割り当て，または割り当て解除をしたい情報を更新したいRDエリアをクリックで選択し，［詳細］ボタンをクリックします。

    ［RDエリア詳細ダイアログ］が表示されます。
  4. RDエリアの詳細情報が表示されますので，グローバルバッファ情報の内容を以下にしたがい設定します。

    表3-30　グローバルバッファ情報の設定内容

    グローバルバッファ情報の更新内容 | RDエリア詳細ダイアログのグローバルバッファ情報への設定内容
    「グローバルバッファに配置する」チェックボックス | グローバルバッファ名 | LOB用グローバルバッファ名
    グローバルバッファを割り当てたい | チェックを入れる | 割り当てたいグローバルバッファを，ドロップダウンリストより選択
    グローバルバッファの割り当てを解除したい | チェックを外す | 設定不要（「グローバルバッファに配置する」チェックボックスのチェックを外すことにより，内容がクリアされます）
  5. ［OK］ボタンをクリックします。
    グローバルバッファの割り当て，または割り当て解除が完了します。

(5)　HAグループの属性変更

(a)　登録ユニットの追加
  1. ツリービュー上で，HAグループに登録したいユニットを，HAグループ上にドラッグアンドドロップします。

    HAグループにドロップしたユニットが登録されます。
(b)　登録ユニットの削除
  1. ツリービュー上で，情報を参照したいHAグループを，クリックで選択します。
  2. 構成情報ビューの「HAグループ」タブをクリックします。
    HAグループに登録されたユニットの一覧が表示されます。
  3. HAグループから登録を削除したいユニットをクリックで選択します。
  4. ［削除］ボタンをクリックします。

  5. 削除の実行を確認するダイアログが表示されますので，［OK］ボタンをクリックします。
    選択したユニットが，HAグループから削除されます。

(6)　HiRDB構成情報の置換

HiRDB Configuration Assistantでは，以下に示すHiRDB構成情報をまとめて置換することができます。

  • パス名
    以下に該当するパス名を置換します。

    表3-31　置換するパス名の一覧

    種別 | 構成要素 | 構成要素定義情報 | 置換するパス名
    構成要素の名称 | HiRDBファイルシステム領域 | HiRDBファイルシステム領域設定情報 | HiRDBファイルシステム領域名称
    オペランドの値 HiRDB システム共通定義 pd_cwaittime_report_dir
    pd_uap_exerror_log_dir
    pd_rpc_trace_name
    pd_aud_file_name
    pd_java_archive_directory
    pd_java_classpath
    pd_java_runtimepath
    pd_java_libpath
    pd_java_stdout_file
    pd_c_library_directory
    pd_ekey
    ユニット ユニット制御情報定義 pd_cwaittime_report_dir
    pd_uap_exerror_log_dir
    pd_rpc_trace_name
    pd_aud_file_name
    pd_ha_restart_failure
    pd_rpl_hdepath
    pd_java_archive_directory
    pd_java_classpath
    pd_java_runtimepath
    pd_java_libpath
    pd_java_stdout_file
    pd_c_library_directory
    pd_tmp_directory
    pd_prf_output_directory
    pd_ekey
    PDCONFPATH
    PDDIR
    サーバ共通定義 pd_rpc_trace_name
    pd_java_stdout_file
    ディクショナリサーバ ディクショナリサーバ定義 pd_rpc_trace_name
    pd_java_stdout_file
    pd_log_auto_unload_path
    pdwork -v
    フロントエンドサーバ フロントエンドサーバ定義 pd_rpc_trace_name
    pd_java_stdout_file
    pd_log_auto_unload_path
    バックエンドサーバ バックエンドサーバ定義 pd_rpc_trace_name
    pd_plugin_ixmk_dir
    pd_java_stdout_file
    pd_log_auto_unload_path
    pdwork -v
    シングルサーバ シングルサーバ定義 pd_rpc_trace_name
    pd_plugin_ixmk_dir
    pd_java_stdout_file
    pd_log_auto_unload_path
    pdwork -v
    RDエリア | RDエリア設定情報 | file_name_1～16
    システムログファイル システムログファイル設定情報 file_name_A
    file_name_B
    シンクポイントダンプファイル シンクポイントダンプ設定情報 file_name_A
    file_name_B
    ユニット用ステータスファイル ユニット用ステータスファイル設定情報 file_name_A
    file_name_B
    サーバ用ステータスファイル サーバ用ステータスファイル設定情報 file_name_A
    file_name_B

置換の対象は，置換の対象として選択した構成要素と，その下位の構成要素のうち，新規状態の構成要素となります。置換の対象となる構成要素の例を，以下に示します。

図3-3　置換の対象となる構成要素の例

注意
置換対象としてHiRDB，またはマシン以外を選択してパス名の置換を行った場合，HiRDBファイルシステム領域との関連が失われ，HiRDBファイルの格納先が無くなることがあります。そのため，置換の対象としてHiRDB，またはマシンを選択することを推奨します。もし，HiRDB，またはマシン以外を選択してパス名の置換を行う場合は，置換実行後にオペランド値を確認し，必要に応じて設定し直してください。

HiRDB構成情報を置換する方法を，以下に説明します。

  1. ［ファイル(F)］－［名前を付けて保存(A)］，または［上書き保存(S)］を実行し，HiRDB構成情報をバックアップします。
    注意
    HiRDB Configuration Assistantでは，検索文字列や置換文字列が間違った状態で置換を実行しても，その結果をもとに戻すことはできません。また，置換が失敗した場合，HiRDB構成情報の整合性が保たれないことがあります。そのため，かならず置換の実行前にHiRDB構成情報ファイルのバックアップを取るようにしてください。

  2. 構成図，またはツリービューから，置換の対象となる構成要素をクリックで選択します。

  3. 右クリックで表示されるコンテキストメニューから，［置換］を選択します。
    ［置換ダイアログ］が表示されます。

    コンテキストメニューによる操作以外にも，以下の操作を行うことで，置換を行うことができます。
    • メニューバーのコマンド呼び出しによる置換（［編集(E)］－［置換］）
  4. 置換に関する情報を入力します。

    表3-32　置換に関する入力情報

    入力項目 | 説明
    検索文字列 置換対象となる文字列を入力します。
    • 1～1024文字で入力してください。
    • 検索文字列は大文字と小文字を区別します。
    • 置換対象がパス名の場合，パス名に使用できる文字を入力してください。パス名に使用できる文字は，HiRDBのマニュアルを参照してください。
    置換文字列 置換対象と置き換える文字列を入力します。
    • 0～1024文字で入力してください。
    • 置換文字列は大文字と小文字を区別します。
    • 置換対象がパス名の場合，HiRDBを構築するOS上でパス名に使用できる文字を入力してください。パス名に使用できる文字は，HiRDBのマニュアルを参照してください。
    • 置換文字列を入力しない場合，置換対象となる文字列を削除する置換を実行します。
    検索対象 | 置換の対象となる構成要素が表示されます。
    置換対象 置換対象が表示されます。
    • パス名
  5. ［置換］ボタンをクリックします。
    以下の場合，［置換］ボタンを押すことができません。
    • 「検索文字列」と「置換文字列」が正しく設定されていない
    • 「検索文字列」と「置換文字列」に同じ文字列が設定されている
  6. 置換の実行を確認するダイアログが表示されますので，［OK］ボタンをクリックします。
    置換が実行され，メッセージダイアログ，および［置換ダイアログ］に実行結果が表示されます。

    置換が失敗した場合には，システム共通定義に置換失敗を示すcommentオペランドが追加されます。commentオペランドの形式は，「付録A.3(1)　HiRDB Configuration Assistantのメッセージ一覧」のHICA2013-E，HICA2014-Eを参照してください。
    注意
    置換が失敗した（HICA2013-E，またはHICA2014-Eが表示された）場合，かならず置換の実行前に取得したバックアップを開きなおして，作業を再開してください。
    置換の失敗後に操作を続けた場合，HiRDB Configuration Assistantの動作，およびHiRDB構成情報の内容は保証されません。


HiRDB構築手順

4.　HiRDB構築手順

HiRDB Configuration Assistantを使ったHiRDB構築手順を，利用用途に応じて説明します。

＜この章の構成＞
4.1　新しくHiRDBを構築する
4.2　既存HiRDBの構成を取り込んで，構成変更する
4.3　既存HiRDBの構成を参考に，新しくHiRDBを構築する
4.4　HiRDBの構成に関するドキュメントを出力する


新しくHiRDBを構築する

4.1　新しくHiRDBを構築する

ここでは，HiRDB Configuration Assistantを使用した，HiRDBの環境構築手順を示します。HiRDBを新しく構築するにあたって，以下の項目が完了している必要があります。

  • 構築するHiRDBの構成の設計が完了していること
  • HiRDBを構築するマシンに，HiRDBがインストールされていること
  • HiRDBを構築するマシンのOSのパラメタ設定が済んでいること

HiRDBのを構築する手順の流れと，その詳細を説明する項番の対応を以下に示します。

図4-1　新しくHiRDBを構築する手順

なお，上記の構築作業中にエラーが発生した場合は，「4.1.15　構築中にエラーが発生した場合の対処法」にしたがい，作業を再実行してください。

＜この節の構成＞
4.1.1　HiRDBの構成を定義する
4.1.2　HiRDB構成情報ファイルを保存する
4.1.3　システム定義のチェックを行う
4.1.4　メモリ・ディスクサイズのチェックを行う
4.1.5　定義ファイル，環境構築用バッチファイルを出力する
4.1.6　定義ファイル，環境構築用バッチファイルの内容を確認する
4.1.7　定義ファイル，環境構築用バッチファイルをHiRDBを構築するマシンに配置する
4.1.8　定義ファイルの構文チェックを行う
4.1.9　HiRDBファイルシステム領域を作成する
4.1.10　システムファイルを作成する
4.1.11　システムファイルの定義を含む定義ファイルのチェックを行う
4.1.12　HiRDBを開始する
4.1.13　データベースを初期化する
4.1.14　レジストリ用RDエリア，およびデータディクショナリ用RDエリア（再編成時期予測用）を追加する
4.1.15　構築中にエラーが発生した場合の対処方法


HiRDBの構成を定義する

4.1.1　HiRDBの構成を定義する

HiRDB Configuration Assistantを使用して，設計したHiRDBの構成を定義します。

HiRDBの構成定義は，以下2つの方法により行うことができます。

表4-1　 HiRDB構成定義の作成方法

HiRDB構成定義の作成方法 | 前提条件 | 対象ユーザ | 適用シーン
ウィザードによる新規作成
  • 構築対象のHiRDBのアドレッシングモードが64bitであること
  • 構築対象のHiRDBの種別がシングルサーバであること
  • データベースがある程度動作すれば良く，データベース設計に時間をかけることができない
  • 今までHiRDB以外のデータベースを使用した経験はあるが，HiRDBを使用するのは初めてである
  • 新規にデータベースを構築する場合
  • Oracle等，他データベースからHiRDBのリプレイスを行う場合
ウィザードを使用しない新規作成 | なし | 上記以外の場合 | 上記以外の場合

ウィザードによる新規作成が使用できる環境であれば，使用されることを推奨します。ご利用になられる環境に合わせて構成定義を作成することができます。

HiRDBの構成定義の例が「付録G　環境構築例」にありますので，参考にしてください。

また，HiRDB Configuration AssistantではHiRDB構成情報のサンプルファイルを用意しています。詳細は「付録H　サンプルファイル」で説明していますので，参考にしてください。

＜この項の構成＞
(1)　ウィザードによる新規作成
(2)　ウィザードを使用しない新規作成

(1)　ウィザードによる新規作成

HiRDBの構成定義をウィザードにより新規に作成します。ウィザードによりHiRDBの構成定義を新規作成するにあたり，以下の情報をあらかじめ決定しておく必要があります。

表4-2　 ウィザードにより構成定義を新規作成する場合の入力情報

項目※1 | 説明
データベース規模の決定 | 同時接続数 | HiRDBに同時に接続する最大クライアント数を決定します。
表数及び表に格納するデータの容量 アクセス頻度の高い表と低い表について，それぞれ以下の役割を果たす表の表数及び表に格納するデータの容量を決定します。
  • 履歴データの管理など，主にデータの蓄積を行う表
  • マスタデータの管理など，主にデータの参照を行う表
  • ワークフロー業務など，主にデータの登録/更新/削除のサイクルを繰り返し行う表
  • 主にデータの更新を繰り返し行う表
データベースのトランザクションログ量 | データベースのトランザクションログ量を決定します。3日分以上のトランザクションログを格納可能なディスクを用意することを推奨します。
通信環境の設定 | ポート番号 | HiRDBが使用するポート番号を2つ決定します。
セットアップ先の決定 | HiRDBのセットアップ先パス | HiRDBのセットアップ先のパスを決定します。
ディスクの割り当て※2 ディスク数 データベースに割り当てるディスク数を決定します。ディスク数を決定するにあたり，以下の4つのパスについては異なるディスクに配置することを推奨します。
  • トランザクションログを配置するパス
  • アクセス頻度の高い表のデータ/インデクスを配置するパス
  • アクセス頻度の低い表のデータ/インデクスを配置するパス
  • トランザクションログのバックアップ先のパス（障害時におけるデータベースの回復範囲で，最新の状態までの回復を行う，を選択した場合のみ）
使用する機能の決定 | 可用性の向上 | 系切り替え構成の適用有無を決定します。適用する場合は切り替え先のマシン名も決定します。系切り替え構成については，HiRDBのマニュアルを参照してください。
障害運用 障害時におけるデータベースの回復範囲を以下から選択します。
  • 最新の状態までの回復を行う
  • バックアップ取得時点までの回復を行う
最新の状態までの回復を行う，を選択した場合，トランザクションログのバックアップ先のパスを決定する必要があります。
セキュリティの強化 | 監査証跡の取得有無を決定します。監査証跡については，HiRDBのマニュアルを参照してください。

※1 HiRDB Configuration Assistantで設定する項目は，RDエリア，ステータスファイル，システムログファイル，シンクポイントダンプファイルの容量のみのため，OSのカーネルパラメタ，排他制御用プールサイズ，SQLオブジェクト用バッファ長など，SQL実行に関連するオペランドの設定値については，ユーザ側で見積もる必要があります。

※2 ディスクは，可能な限りHiRDBが占有して使用できるディスクを用意して下さい。占有できない場合，I/O競合により，データベースの性能に影響を与える場合があります。

ウィザードにより構成定義を新規作成する手順の流れを，以下に示します。

図4-2　ウィザードにより構成定義を新規作成する手順

(a)　構成情報ファイルを新規作成する

［ファイル(F)］－［新規作成(N)］からHiRDBの構成情報ファイルを新規に作成します。

(b)　ウィザードによるHiRDB構成情報の自動生成

ウィザードによりHiRDBの構成情報ファイルを作成する手順を，以下に示します。

  1. ［ファイル(F)］－［ウィザードによる新規作成］を選択します。
    ［HiRDBの新規構築　データベースの要件（１／４）］ダイアログが表示されます。

    ダイアログの内容を以下に示します。

    表4-3　 HiRDBの新規構築　データベースの要件（１／４）ダイアログの詳細

    図中の番号 | HiRDBの新規構築　データベースの要件（１／４）ダイアログ | 内容
    ① | 構築するHiRDB種別 | HiRDBバージョン | 構築するHiRDBのバージョンを指定します。
    OS種別 | HiRDBを構築するマシンのOSを指定します。
    HiRDB種別※1 | 構築するHiRDBの種別を指定します。
    アドレッシングモード※1 | HiRDBを構築するマシンのアドレッシングモードを指定します。
    ② | 同時接続数 | HiRDBに同時に接続する最大クライアント数を指定します。
    ③ | 構築するHiRDBの要件 | 可用性 | 系切り替え構成 | 系切り替え構成の適用有無を指定します。系切り替え構成については，HiRDBのマニュアルを参照してください。
    回復 回復範囲 障害時におけるデータベースの回復範囲について，以下のいずれかを指定します。
    • 最新の状態まで回復する
    • バックアップ時点まで回復する
    セキュリティ | 監査証跡 | 監査証跡の取得有無を指定します。監査証跡については，HiRDBのマニュアルを参照してください。
    構築するHiRDBのイメージ | 構築するHiRDBをイメージ表示しています。

    ※1 HiRDB種別，アドレッシングモードは変更できません。

  2. 設定が完了したら，［次へ(N)］をクリックします。
    ［HiRDBの新規構築　データベースの物理配置（２／４）］ダイアログが表示されます。

    ダイアログの内容を以下に示します。

    表4-4　 HiRDBの新規構築　データベースの物理配置（２／４）ダイアログの詳細

    図中の番号 | HiRDBの新規構築　データベースの物理配置（２／４）ダイアログ | 内容
    ① | HiRDBをセットアップするマシン名 | 現用系 | HiRDBをセットアップする現用系マシン名を指定します。
    予備系 | HiRDBをセットアップする予備系マシン名を指定します。この項目は系切り替え構成を適用する場合にのみ有効となります。
    ② | HiRDBのセットアップ先のパス | HiRDBのセットアップ先のパスを指定します。
    ③ | HiRDBが使用できるメモリサイズ | HiRDBが使用可能なメモリサイズをメガバイト単位で指定します（SQL実行時に必要なメモリ所要量は含みません）。
    ④ | HiRDBに割り当てるポート番号 | HiRDBが使用するポート番号を2つ指定します。
    ⑤ | 割り当てるパス | パス数 | 割り当てるパス数を指定します。
    トランザクションログを配置するパス | トランザクションログを配置するパスを指定します。
    アクセス頻度の高い表のデータ/インデクスを配置するパス | アクセス頻度の高い表のデータ/インデクスを配置するパスを指定します。割り当てるパス数により，1～9つのパスを指定することができます。
    トランザクションログのバックアップ先のパス | トランザクションログのバックアップ先のパスを指定します。この項目はデータベースの回復範囲で，最新の状態まで回復する，を指定した場合にのみ有効となります。
    アクセス頻度の低い表のデータ/インデクスを配置するパス | アクセス頻度の低い表のデータ/インデクスを配置するパスを指定します。
  3. 設定が完了したら，［次へ(N)］をクリックします。
    ［HiRDBの新規構築　業務用件（３／４）］ダイアログが表示されます。

    ダイアログの内容を以下に示します。

    表4-5　 HiRDBの新規構築　業務用件（３／４）ダイアログの詳細

    図中の番号 | HiRDBの新規構築　業務用件（３／４）ダイアログ | 内容
    ① | アクセス頻度の高い表に関する情報 | 履歴データの管理など，主にデータの蓄積を行う表 | データ蓄積用の表に関する情報を指定します。指定内容については，「表4-6　表の指定値の内容」を参照してください。
    マスタデータの管理など，主にデータの参照を行う表 | データ参照用の表に関する情報を指定します。指定内容については，「表4-6　表の指定値の内容」を参照してください。
    ワークフロー業務など，主にデータの登録/更新/削除のサイクルを繰り返し行う表 | データ登録/更新/削除用の表に関する情報を指定します。指定内容については，「表4-6　表の指定値の内容」を参照してください。
    主にデータの更新を繰り返し行う表 | データ更新用の表に関する情報を指定します。指定内容については，「表4-6　表の指定値の内容」を参照してください。
    ② | アクセス頻度の低い表に関する情報 | アクセス頻度の低い表に関する情報を指定します。指定内容については，①を参照してください。
    ③ | トランザクションログを格納するディスク容量 | データベースのトランザクションログ用に割り当てるディスクの容量を指定します。

    表4-6　 表の指定値の内容

    項目 | 内容
    表数 | HiRDBに作成する表数を0～128の範囲で指定します。
    容量※1 | 表の合計データ容量を1024～1048000の範囲で指定します。
    自動増分※2 | 格納するデータ量が，最初に割り当てたRDエリアの容量より多くなった場合，RDエリアの自動増分を行うかどうかを指定します。自動増分指定を行った場合，HiRDB Configration Assistantが生成するRDエリアに1セグメントの自動増分用のHiRDBファイルを割り当てます。また，生成するRDエリア１つに付き，HiRDBファイルシステム領域に最大６４ギガバイトの予備領域を確保しますので，ディスクサイズが大幅に増加する場合があります。ご使用前に必ずディスクサイズを確認してください。

    ※1 インデクスを含まないデータ容量を指定してください。

    ※2 自動増分指定を行った場合，決定したセグメント数の1/10を増分セグメント数として設定します。

  4. 設定が完了したら，［次へ(N)］をクリックします。
    ［HiRDBの新規構築　指定内容の確認（４／４）］ダイアログが表示されます。

    ダイアログの内容を以下に示します。

    表4-7　 HiRDBの新規構築　指定内容の確認（４／４）ダイアログの詳細

    図中の番号 | HiRDBの新規構築　指定内容の確認（４／４）ダイアログ | 内容
    ① | 構築するHiRDBの構成 | 指定内容 | 4.1.1(1)(b)の1～3の手順で設定した情報を確認する場合に指定します。
    構築内容の詳細 | 4.1.1(1)(b)の1～3の手順で設定した情報と，設定した情報をもとに構築されるデータベースの情報を確認する場合に指定します。
    ② | 指定内容・構築内容の詳細 | 指定内容・構築内容の詳細を表示します。表示内容は①の指定値により切り替わります。4.1.1(1)(b)の1～3の手順で設定した情報に誤りがある場合は，何も表示されません。表示内容の詳細については，「付録F　HiRDB構成情報の指定内容の詳細」を参照してください。
    ③ | ファイル出力 | ①で[構築内容の詳細]を指定した場合に表示される内容をファイルに出力します（ファイル名：hirdb_summary.txt）。出力したファイルは，フォント：MSゴシック，タブ幅：8で参照することを推奨します。

以上の手順により作成されるHiRDBファイルシステム領域の配置図を，以下に示します。

図4-3　 HiRDBファイルシステム領域の配置

表4-8　 HiRDBファイルシステム領域一覧

HiRDBファイルシステム領域名 | 格納しているHiRDBファイル
STS_1，STS_2，・・・ | ユニットステータスファイル，サーバステータスファイル
LOG_1，LOG_2，・・・ | システムログファイル，シンクポイントダンプファイル
DATA_H1_1，DATA_H1_2，・・・ | アクセス頻度の高い表を格納するRDエリア
INDX_H1_1，INDX_H1_2，・・・ | アクセス頻度の高い表のインデクスを格納するRDエリア
DATA_L_1，DATA_L_2，・・・ | アクセス頻度の低い表を格納するRDエリア
INDX_L_1，INDX_L_2，・・・ | アクセス頻度の低い表のインデクスを格納するRDエリア
DIC | マスタディレクトリ，データディレクトリ，データディクショナリ用のRDエリア
WORK_1 | 作業表用ファイル
AUD_1 | 監査証跡ファイル
(c)　HiRDB構成情報の見直し

ウィザードによりHiRDBの構成情報ファイルを作成した後，適用するシステムに合わせて，以下の項目の見直しを行います。各項目の変更方法については，HiRDBのマニュアルを参照してください。

表4-9　 ウィザードによるHiRDB構成情報ファイル作成後の見直し項目一覧

見直しのタイミング | カテゴリ | 項目 | 内容
HiRDB構成定義ファイル作成後 | SQL実行 | システム共通定義 | pd_max_access_tables※1 | 1トランザクションで同時にアクセスする表数と順序数生成子数をシステム要件に合わせて変更します。
pd_assurance_index_no※1 | メモリに管理情報を常駐化させるインデクス数をシステム要件に合わせて変更します。
サーバ共通定義 | pd_lck_pool_size※1 | サーバ当たりの排他制御用プールサイズをシステム要件に合わせて変更します。もしくは，メモリ不足が発生する場合にも変更します。
pd_work_buff_size※1 | 作業表用バッファ長をシステム要件に合わせて変更します。
pd_sql_object_cache_size※1 | SQLオブジェクト用バッファ長をシステム要件に合わせて変更します。
RDエリア構成 | LOB用RDエリア※1 | LOB用RDエリアが必要な場合，RDエリアを追加します。RDエリアの追加に伴い，グローバルバッファの配置も検討します。
HiRDB環境構築後 | 表/インデクス作成 | CREATE TABLE文 | SEGMENT REUSE | データの登録/更新/削除を繰り返し行う表，もしくはデータの更新を繰り返し行う表を定義する場合に適用を検討します。SEGMENT REUSEオプションについては，HiRDBのマニュアルを参照してください。
セキュリティ 監査証跡 監査証跡を取得する場合，以下のオブジェクトをユーザ側で作成する必要があります。※2
  • 監査人
  • 監査証跡表
  • 監査証跡表を格納するRDエリアおよびHiRDBファイルシステム領域
各オブジェクトを作成するための制御文については，HiRDBのマニュアルを参照してください。

※1 設定値を大きく変更した場合，メモリ所要量に影響するため，再度メモリ所要量を見積もる必要があります。

※2 監査証跡ログの出力設定と，監査証跡ログの出力先であるHiRDBファイルについては，HiRDB Configuration Assistantが用意します。

(2)　ウィザードを使用しない新規作成

(a)　構成情報ファイルを新規作成する

［ファイル(F)］－［新規作成(N)］からHiRDBの構成情報ファイルを新規に作成します。

(b)　構成要素の追加

設計したHiRDBの構成に合わせて，構成要素を追加してください。構成要素の追加方法は，「3.4　基本操作」を参照してください。

(c)　システム定義の設定

各構成要素について設計したHiRDBの構成に合わせてシステム定義の設定を行います。システム定義の設定方法は，「3.4.6(2)　構成要素の属性変更（オペランド更新）」を参照してください。


HiRDB構成情報ファイルを保存する

4.1.2　HiRDB構成情報ファイルを保存する

［ファイル(F)］－［名前を付けて保存(A)］を選択し，設計したHiRDBの構成情報を，HiRDB構成情報ファイルに保存してください。

HiRDB構成情報ファイル保存時の注意事項を以下に示します。

  • 同一名称のHiRDB構成情報ファイルが既に存在する場合，そのHiRDB構成情報を新しいHiRDB構成情報ファイルで上書きします。
  • HiRDB構成情報ファイルを出力するフォルダには，HiRDB Configuration AssistantがHiRDB構成情報ファイルを出力できるように，フォルダの読み込み権限，書き込み権限を与えてください。
  • 同一名称のHiRDB構成情報ファイルが既に存在する場合，HiRDB Configuration Assistantが上書きできるように，既存のHiRDB構成情報ファイルの読み込み権限，書き込み権限を与えてください。
  • 同一名称のHiRDB構成情報ファイルが既に存在する場合，HiRDB Configuration Assistantが上書きできるように，他のプログラムで既存のHiRDB構成情報ファイルを開かないようにしてください。


システム定義のチェックを行う

4.1.3　システム定義のチェックを行う

HiRDB Configuration Assistantで定義したHiRDB構成情報から出力されるシステム定義のチェックを行います。

システム定義のチェックは，HiRDB Configuration Assistantが動作するマシンから，HiRDBを構築するマシンに定義ファイルを送信し，pdconfchkコマンドを実行することで，HiRDB構成情報に不整合がないかチェックします。

システム定義のチェックを行うためには，以下に示す前提条件を満たす必要があります。

表4-10　システム定義のチェックを行うための前提条件

前提条件の区分 前提条件の内容
HiRDBを構築するすべてのマシン Windowsの場合
  • HiRDB/Single Serverの場合，リモート系コマンドが使用できる状態（pdntenvコマンドの出力結果が「Rsh Online = on」）になっていること。※１
  • HiRDBのサービスが起動中であること。
  • HiRDBの文字コードに関して以下のいずれかを満たすこと。
    ・HiRDBの文字コードはsjisである。
    ・HiRDBの文字コードはsjis以外であるが，定義ファイル中にマルチバイト文字が含まれていない。
UNIX系の場合
  • rshサービスが動作していること。
  • HiRDB Configuration Assistantを実行するマシンから，HiRDB管理者として登録したユーザIDでrsh及びrcpコマンドが実行できること。
  • HiRDB管理者のユーザIDが，「表4-12　システム定義のチェックに関する入力情報」に示す規則にしたがっていること。
  • 文字コード変換コマンドiconvが使用できること。
  • HiRDBの文字コードに関して以下のいずれかを満たすこと。
    ・HiRDBの文字コードはsjis，ujis，utf-8のいずれかである。
    ・HiRDBの文字コードは上記以外であるが，定義ファイル中にマルチバイト文字が含まれていない。
  • csh，またはtcshを使用する場合，.cshrc，または.tcshrcの中で標準出力，標準エラー出力に対して出力を行っていないこと。
HiRDB Configuration Assistantを実行するマシン HiRDBを構築するマシンがWindowsの場合
  • HiRDB Configuration Assistantを実行するユーザ名・パスワードは，HiRDBを構築するマシンのHiRDBサービスのユーザ名・パスワードと一致していること。
  • HiRDB Configuration Assistantは，Administrator権限を持つユーザが，管理者として実行すること。
  • %windir%\system32\drivers\etc\SERVICESファイルに，システム定義のチェック対象とするHiRDBのリモート系コマンドで使用するポート番号が記載されていること（サービス名は任意。サービス名として使用可能な文字は「表4-12　システム定義のチェックに関する入力情報」を参照してください）。
  • HiRDBを構築するマシンの標準ホスト名（コンピューター名）が，%windir%\system32\drivers\etc\hostsファイル，またはDNSなどに登録されており，名前解決可能であること。
HiRDBを構築するマシンがUNIX系の場合
  • rsh及びrcpコマンドが使用できること。※2
  • HiRDB Configuration Assistantを実行するユーザは，User権限を持っていること。
共通
  • HiRDBを構築するマシンのマシン名が，%windir%\system32\drivers\etc\hostsファイル，またはDNSなどに登録されており，名前解決可能であること。
  • 系切り替え環境の場合，%windir%\system32\drivers\etc\hostsファイル，またはDNSなどに指定する各接続先のマシンのIPアドレスは，現用系HiRDBのIPアドレスを指定していること。
  • HiRDB Configuration Assistantを実行するマシンとHiRDBを構築するマシンとの間にファイアウォールを設置している場合，「表4-11　ファイアウォールに設定する透過指定の内容」に示す情報について設定していること。
システム定義のチェック対象となるHiRDB構成情報
  • HiRDB種別がシングルサーバの場合，シングルサーバが構成要素として定義されていること。
  • HiRDB種別がパラレルサーバの場合，マネージャサーバが構成要素として定義されていること。

※1 「Rsh Online = off」の場合は，pdntenvコマンド（-roオプションにonを指定）でリモート系コマンドを使用する設定を行ってください。その後，HiRDBサービスを再起動してください。

※2 HiRDB Configuration Assistantを実行するマシンでは，rshサービスを利用するためにWindows Subsystem for UNIX-based Applications（SUA）をインストールする必要があります。ただし，Windows Subsystem for UNIX-based Applications（SUA）をインストールできるのは以下のOSです。

  • Windows Server 2008
  • Windows Server 2008 R2
  • Windows Server 2012
  • Windows 7（Ultimate，Enterprizeのみ）
  • Windows 8（Enterprizeのみ）

表4-11　ファイアウォールに設定する透過指定の内容

HiRDBを構築するマシンのOS | HiRDB Configuration Assistantを実行するマシンのOS | 透過指定の内容
プログラム名の場合 | ポート番号の場合
Windows 任意
  • (HiRDB Configuration Assistantのインストールフォルダ)\bin\pdcrsh.exe
  • (HiRDB Configuration Assistantのインストールフォルダ)\bin\pdcrcp..exe
 リモート系コマンドのサービスポートに割り当てたポート番号
UNIX系 Windows 7
Windows 8
Windows Server 2008
Windows Server 2008 R2
Windows Server 2012 		%SystemRoot%\system32\psxss.exe 514

上記の前提条件を満たすことができない場合はHiRDB Configuration Assistantのシステム定義のチェック機能を使用することはできませんので，定義ファイルを，HiRDBを構築するマシンに転送した後でチェックを実行してください。詳細は「4.1.8　定義ファイルの構文チェックを行う」を参照してください。

システム定義のチェックの手順を以下に示します。

  1. ［ファイル(F)］－［名前を付けて保存(A)］，または［上書き保存(S)］を実行し，HiRDB構成情報をバックアップします。
    注意
    マシン環境の状態によっては，システム定義のチェックが終了せず，HiRDB Configuration Assistantが応答なしの状態になってしまう可能性があります。そのため，必ずシステム定義のチェックを実行する前に，HiRDB構成情報ファイルを保存するようにしてください。

  2. ［ツール(T)］－［システム定義のチェック］をクリックします。

    ［接続ダイアログ］が表示されます。
  3. システム定義のチェックに関する情報を入力します。

    表4-12　システム定義のチェックに関する入力情報

    入力項目 説明
    ユーザID HiRDBを構築するマシンにログインするためのユーザIDを入力します。
    HiRDBを構築するマシンがWindowsの場合，入力不要です。
    • HiRDB管理者のユーザIDを入力してください。
    • 1～8文字で入力してください。
    • 1文字目には，以下に示す文字を使用して入力してください。
      半角英字（A～Z，a～z）
    • 2文字目以降には，以下に示す文字を使用して入力してください。
      半角英字（A～Z，a～z），数字（0～9）
    • ダブルクォート（"）を入力することはできません（HiRDB Configuration Assistantは，マシンへの接続時にユーザIDに指定された文字列をダブルクォートで括って使用します）。
    • 入力したユーザIDは，全てのHiRDBを構築するマシンで共通となります。
    チェック結果出力先 システム定義のチェックの結果を格納するフォルダを指定します。［出力先選択］ボタンをクリックし，フォルダを選択するか，直接入力してください。
    • 1～128文字で入力してください。
    • 以下に示す文字を使用して入力してください。
      半角英字（A～Z，a～z），アンダーバー（_），数字（0～9），\，丸括弧，半角スペース，#，@，ピリオド（.），コロン（:）
    • チェック結果出力先で指定するフォルダには，HiRDB Configuration Assistantがファイルを出力できるように，フォルダの読み込み権限，書き込み権限を与えてください。
    転送先文字コード HiRDBの文字コードに合わせて転送先（HiRDBを構築するマシン）の文字コードを選択します。
    • HiRDBのOS種別がWindowsの場合，sjisのみ選択できます。
    • HiRDBのOS種別がUNIX系の場合，sjis，ujis，utf-8の中から選択できます。
    • HiRDBの文字コードが上記以外で，なおかつ定義ファイル中でマルチバイト文字を使用していない場合，sjisを選択してください。
    サービス名 HiRDBを構築するマシンがWindowsの場合，システム定義のチェック対象とするHiRDBのリモート系コマンドで使用するポート番号を指定したサービス名を入力してください。
    HiRDBを構築するマシンがWindowsでない場合，入力不要です。
    • 1～255文字で入力してください。
    • 以下に示す文字を使用して入力してください。
      半角英字（A～Z，a～z），アンダーバー（_），数字（0～9）
    • %windir%\system32\drivers\etc\SERVICESファイルに記載されたサービス名を入力してください。
    ［接続ダイアログ］に設定した入力情報は，［接続ダイアログ］の［接続］ボタンをクリックしたときに保存され，システム定義のチェックを再度実行する時に利用できます。入力情報は，以下に示す操作を行うまで保持されます。
    • HiRDB構成情報ファイルを新規作成する
    • 別のHiRDB構成情報ファイルを開く
    • 定義取り込みを実行する
    • HiRDB Configuration Assistantを終了する
  4. ［接続］ボタンをクリックします。
    システム定義のチェックを実行します。
    注意
    HiRDBを構築するマシンのOSがUNIX系で，かつHiRDB Configuration Assistantを実行するマシンとHiRDBを構築するマシンとの間にファイアウォールを設置している場合，システム定義のチェックの実行に長時間（数分～数十分）かかることがあります。この理由として，サーバからAuth/IDENT（発信元を特定するためのプロトコル）が返されている可能性が考えられます。
    ファイアウォールにて，ポート番号113を透過するように定義することで，この現象を回避できる場合があります。

  5. システム定義のチェックの終了，もしくはエラーによる異常終了を示すメッセージダイアログが表示されます。
    システム定義のチェックが終了した場合に［接続ダイアログ］で指定したチェック結果出力先フォルダへ格納されるフォルダおよびファイル一覧と，フォルダの階層構成を以下に示します。

    図4-4　チェック結果出力先フォルダの階層構成

    表4-13　チェック結果出力先フォルダ以下のフォルダおよびファイル一覧

    フォルダの種別 | フォルダの個数 | フォルダの名称 | フォルダに格納されるファイル
    チェック結果出力先フォルダ | 1個 | ［接続ダイアログ］で指定した名称 | なし
    チェック結果格納フォルダ 1個 "hirdbca_yyyymmddhhmmss"
    • チェック結果ファイル（exec_result_yyyymmddhhmmss.txt）
    • 操作処理実行結果ファイル（exec_log_yyyymmddhhmmss.txt）
    • 標準入力ファイル（exec_stdin_yyyymmddhhmmss.txt）
    • 標準出力ファイル（stdout.txt）
    • 標準エラー出力ファイル（stderr.txt）
    マシンフォルダ | マシン数 | マシン名 | なし
    ユニットフォルダ | ユニット数 | ユニット名 | なし
    HiRDBファイルシステム領域用バッチファイル格納フォルダ | 1つのマシンにつき1個 | "hirdb_file_batch" | HiRDBファイルシステム領域用バッチファイル格納フォルダに格納されたファイルは，システム定義のチェックでは使用しません。
    RDエリア用バッチファイル格納用フォルダ | 1つのユニットにつき1個 | "rdarea_batch" | RDエリア用バッチファイル格納用フォルダに格納されたファイルは，システム定義のチェックでは使用しません。
    confフォルダ 1つのユニットにつき1個 "conf"
    • ユニットに必要な各種定義ファイル
    • RDエリア生成用バッチファイルが入力する制御文ファイル（システム定義のチェックでは使用しません）
    • チェック用バッチファイル（HiRDB Configuration Assistantが使用します）
    • チェック結果格納フォルダ，チェック結果ファイル，および操作処理実行結果ファイルの名称中のyyyymmddhhmmssには，システム定義のチェックを実行したタイムスタンプを設定します。
    • 標準入力ファイル，標準出力ファイル，および標準エラー出力ファイルは，システム定義のチェックがエラーとなった場合に出力されることがあります。
    • サーバ名称が，大文字，小文字の区別なく重複する場合（例：BES1とbes1），confフォルダに出力されるサーバ定義ファイルの名称も重複するため，先に出力されたサーバ定義ファイルの内容が削除され，後から出力されたサーバ定義ファイルにより上書きされます。
    • ユニット制御情報定義PDCONFPATHオペランドの値は，PDDIRオペランドの値，またはHiRDB構成初期情報ダイアログのHiRDB運用ディレクトリの値に書き換えてシステム定義のチェックを実行します。そのため，HiRDB構成情報で設定されているPDCONFPATHオペランドの値はシステム定義のチェックの対象となりませんので注意してください。
    • 定義ファイルpdsysはユニット下のフォルダに出力されます。
    • 定義ファイルの詳細については，「付録B　定義ファイル」を参照してください。

  6. メッセージダイアログに記載されたメッセージにしたがい，システム定義のチェック結果を確認します。
    • HICA7001-Iメッセージが出力された場合，システム定義のチェックが正常終了し，HiRDB Configuration Assistantで定義されたHiRDB構成情報から出力されたシステム定義に問題ないことを示しています。
    • HICA7002-Wメッセージが出力された場合，システム定義のチェックは終了しましたが，pdconfchkの詳細メッセージが出力されています。
      システム定義に問題がある可能性がありますので，チェック結果出力先フォルダに出力されたチェック結果ファイルを開いて詳細メッセージの内容を確認してください。
      チェック結果出力先フォルダに出力されたpdconfchkのメッセージの詳細については，HiRDBのマニュアルを参照してください。
    • HICA7003-Eメッセージが出力された場合，システム定義のチェックが異常終了したことを示しています。
      チェック結果出力先フォルダに出力された操作処理実行結果ファイルを開いてシステム定義のチェックが異常終了した原因を確認してください。
      操作処理実行結果ファイルへの出力内容と，考えられる異常終了の原因を以下に示します。

      表4-14　操作処理実行結果ファイルへの出力内容と，考えられる異常終了の原因

      HiRDBを構築するマシンのOS 操作処理実行結果ファイルで，HICA7014-Eメッセージの直前に出力された内容 考えられる異常終了の原因
      Windows HICA9001-Eメッセージ（エラーが発生したシステムコール名称：gethostbyname，システムコールのエラー番号：11001，または11004）が出力された
      • HiRDB構成情報に登録したマシン名が%windir%\system32\drivers\etc\hostsファイル，またはDNSなどに登録されていない
      HICA9001-Eメッセージ（エラーが発生したシステムコール名称：connect，システムコールのエラー番号：10060，または10061）が出力された
      • 指定したサービス名に割り当てたポート番号が，システム定義のチェック対象とするHiRDBに割り当てているリモートコマンド用のポート番号と一致しない
      • %windir%\system32\drivers\etc\hostsファイル，またはDNSなどに登録したマシン名が誤っている
      • システム定義のチェック対象とするHiRDBで，pdntenvコマンドで割り当てているリモートコマンド用のサービス名を変更した後，HiRDBサービスを再起動していない
      • システム定義のチェック対象とするHiRDBのサービスを起動していない
      • システム定義のチェック対象とするHiRDBで，リモート系コマンドが使用できない状態（pdntenvコマンドの出力結果が「Rsh Online = off」）になっている
      • HiRDB構成情報に登録したマシン名に指定したIPアドレスが誤っている
      • HiRDB構成情報に登録したマシンが起動していない，あるいは経路上のネットワークに障害が発生している
      HICA9001-Eメッセージ（エラーが発生したシステムコール名称：CreateFile，システムコールのエラー番号：1326）が出力された
      • HiRDB Configuration Assistantを実行するユーザのユーザID/パスワードが，システム定義のチェック対象とするHiRDBのHiRDB管理者のユーザID/パスワードと異なっている
      HICA9007-Eメッセージが出力された
      • PDDIRオペランドで指定したHiRDB運用ディレクトリの直下にtmpディレクトリが存在しない
      HICA7012-IメッセージとHICA7014-Eメッセージの間に"1"が出力された
      • PDDIRオペランドで指定したHiRDB運用ディレクトリが存在しない
      • PDDIRオペランドで指定したHiRDB運用ディレクトリに対するアクセス権限がない
      HICA9001-Eメッセージ（エラーが発生したシステムコール名称：AdjustTokenPrivileges，システムコールのエラー番号：1300）が出力された
      • HiRDB Configuration Assistantを起動する際，「管理者として実行」により起動していない
      HICA9001-Eメッセージ（エラーが発生したシステムコール名称：CreateFile，システムコールのエラー番号：53）が出力された
      • HiRDB構成情報に登録した標準ホスト名（コンピューター名）が%windir%\system32\drivers\etc\hostsファイル，またはDNSなどに登録されていない
      UNIX系 以下のメッセージが出力された
      • （接続先マシン名）: 不明なホストです
        rsh: can't establish connection
      • HiRDB構成情報に登録したマシン名が%windir%\system32\drivers\etc\hostsファイル，またはDNSなどに登録されていない
      以下のいずれかのメッセージが出力された
      • （接続先マシン名）: Permission denied.
        rsh: can't establish connection
      • （接続先マシン名）: Login incorrect.
        rsh: can't establish connection
      • （接続先マシン名）: permission denied.
        rsh: can't establish connection
      • （接続先マシン名）: remshd: Login incorrect.
        rsh: can't establish connection
      • 改行のみ（メッセージなし）
      • 接続先マシンに登録されていないユーザIDを指定した
      • 接続するユーザIDの.rhostに，HiRDB Configuration Assistantを実行しているマシン，もしくはユーザIDを登録していない。あるいは，指定したIPアドレス，もしくはユーザIDが誤っている
      以下のいずれかのメッセージが出力された
      • rsh: can't establish connection
        > （接続先マシン名）:接続がタイムアウトしました
      • （接続先マシン名）: Operation timed out
      • HiRDB構成情報に登録したマシン名に指定したIPアドレスが誤っている
      • HiRDB構成情報に登録したマシンが起動していない，あるいは経路上のネットワークに障害が発生している
      以下のいずれかのメッセージが出力された
      • ls: cannot access （ユニット制御情報定義のPDDIRオペランドに指定したパス名）: No such file or directory
      • （ユニット制御情報定義のPDDIRオペランドに指定したパス名） not found
      • （ユニット制御情報定義のPDDIRオペランドに指定したパス名）: No such file or directory
      • PDDIRオペランドで指定したHiRDB運用ディレクトリが存在しない
      以下のいずれかのメッセージが出力された
      • rcp: （ユニット制御情報定義のPDDIRオペランドに指定したパス名）/tmp/pdca_env_U001_（yyyymmddhhmmss）.sh: No such file or directory
      • rcp: （ユニット制御情報定義のPDDIRオペランドに指定したパス名）/tmp/pdca_env_un01_（yyyymmddhhmmss）.sh: このパス名のファイルまたは※1,2
      • rcp: （ユニット制御情報定義のPDDIRオペランドに指定したパス名）/tmp/pdca_env_un01_（yyyymmddhhmmss）.sh: ファイルもディレクトリもありません。※1
      • rcp: （ユニット制御情報定義のPDDIRオペランドに指定したパス名）/tmp/pdca_env_un01_（yyyymmddhhmmss）.sh: No such file or directory
      • PDDIRオペランドで指定したHiRDB運用ディレクトリの直下にtmpディレクトリが存在しない
      以下のいずれかのメッセージが出力された
      • ls: cannot open directory （ユニット制御情報定義のPDDIRオペランドに指定したパス名）: Permission denied
      • ls: （ユニット制御情報定義のPDDIRオペランドに指定したパス名）: Permission denied
      • （ユニット制御情報定義のPDDIRオペランドに指定したパス名） unreadable
      • PDDIRオペランドで指定したHiRDB運用ディレクトリに対するアクセス権限がない
      以下のメッセージが出力された
      • 'posix.exe' は，内部コマンドまたは外部コマンド，操作可能なプログラムまたはバッチファイルとして認識されていません。
      • Windows Subsystem for UNIX-based Applications（SUA）がインストールされていない

      ※1 rcpの結果は，接続マシンの文字コードで出力されます。

      ※2 コマンドが出力しているメッセージは途中で切れています（「または」以降）ので，ご注意ください。

      原因を取り除いた後，再度システム定義のチェックを実行してください。
      操作処理実行結果ファイルの詳細については，「付録A.1(3)　操作処理実行結果ファイルの出力形式」を参照してください。

注意
HiRDB Configuration Assistantは，システム定義のチェックの実行時にHiRDBを構築するマシンの$PDDIR/tmp下にチェック結果格納フォルダ（hirdbca_yyyymmddhhmmss）と同名のフォルダを作成し，その下に一時的な作業ファイルを作成します（システム定義のチェック終了時には削除します）。
  • $PDDIRの値は，HiRDB構成情報中の各ユニットのPDDIRオペランドで指定された値を使用します。ユニットにPDDIRオペランドが定義されていない場合，［HiRDB初期構成情報ダイアログ］の「HiRDB運用ディレクトリ」の値を使用します。
  • システム定義のチェックが異常終了した場合，上記のフォルダ・ファイルが削除されずに残ってしまうことがあります。その場合，ユーザ自身で残ったフォルダ・ファイルを削除するようにしてください。

注意
HiRDB Configuration Assistantが応答なしの状態になってしまった場合，以下の手順にしたがい，システム定義のチェックを終了させてください。
  1. タスクマネージャのアプリケーションタブ，またはタスクバーにて，次のウィンドウタイトルのコマンドプロンプトが実行中であることを確認してください。
    ・[HiRDB Configuration Assistant] exec_filetransfer
    ・[HiRDB Configuration Assistant] exec_changecharset
    ・[HiRDB Configuration Assistant] exec_check
    ・[HiRDB Configuration Assistant] exec_deletecheckfile
  2. 上記のコマンドプロンプトをすべて終了させてください。
その後，以下の手順にしたがいシステム定義のチェックが終了しない原因を調査して取り除いた後，システム定義のチェックを再度実行してください。

図4-5　システム定義のチェックが終了しない原因を調査する手順

操作処理実行結果ファイルの詳細については，「付録A.1(3)　操作処理実行結果ファイルの出力形式」を参照してください。


メモリ・ディスクサイズのチェックを行う

4.1.4　メモリ・ディスクサイズのチェックを行う

HiRDB Configuration Assistantで定義したHiRDB構成情報をもとに，HiRDBが使用するメモリ・ディスクサイズのチェックを行います。メモリ・ディスクサイズのチェックは，HiRDB Cofiguration Assistantの容量計算機能を使用します。

メモリ・ディスクサイズのチェックを行うためには，以下の前提条件をみたす必要があります。

  • システム定義のチェックが完了していること。システム定義のチェックの詳細は，「4.1.3　システム定義のチェックを行う」を参照してください。
  • 構築対象のHiRDBのバージョンが09-03以降であること。
  • HiRDB構成情報の内容が，以下を満たしていること。
    • RDエリアの総数が200個以下
    • サーバの総数が200個以下
    • グローバルバッファの総数が200個以下
    • HAグループの総数が1個以下
    • 1つのHAグループの登録ユニット数が25個以下
    • オペランドの指定値に，-2147483648（-2G）～2147483647（2G-1）の範囲を超える値が指定されていない
  • HiRDB Configuration Assistantがインストールされているフォルダ（配下のフォルダ，ファイルを含む）に適切なアクセス権が設定されていること（HiRDB Configuration AssistantをAdministrator権限で動作させる場合，「管理者から実行」により起動すること）。

上記の前提条件を満たすことができない場合はHiRDB Configuration Assistantの容量計算機能を使用することはできません。HiRDBのマニュアル（HiRDB Version 9の場合，「HiRDB Version 9 システム導入・設計ガイド」）にしたがってメモリ・ディスクサイズの計算を行い，HiRDBの構成を変更するマシンでメモリ・ディスクの不足が発生しないことを確認してください。

＜この項の構成＞
(1)　メモリ・ディスクサイズのチェックの出力内容
(2)　メモリ・ディスクサイズのチェックの手順

(1)　メモリ・ディスクサイズのチェックの出力内容

メモリ・ディスクサイズのチェックは，HiRDB Cofiguration Assistantの容量計算機能を使用します。容量計算機能で計算する各サイズの詳細について，以下に説明します。

(a)　メモリサイズ

容量計算機能では，以下に示すメモリサイズを計算します。容量計算機能でメモリサイズを計算しない項目については，HiRDBのマニュアル（HiRDB Version 9の場合，「HiRDB Version 9 システム導入・設計ガイド」）を参照して計算を行ってください。
なお，メモリサイズの計算にはHiRDBのシステム定義オペランドの省略値として「推奨モード」適用時の値を使用しています。「推奨モード」については，HiRDBのマニュアル（HiRDB Version 9の場合，「HiRDB Version 9 システム導入・設計ガイド」）を参照してください。

表4-15　容量計算機能でメモリサイズを計算する項目

HiRDBのメモリ所要量算出項目 |  | HiRDB Configuration Assistantが計算する項目
 |  | Single Serverの場合 | Parallel Serverの場合
プロセス固有領域 | ユニットコントローラ全プロセスが使用するプロセス固有領域 | × | ×
 | シングルサーバプロセスが使用するプロセス固有 | × | －
 | フロントエンドサーバプロセスが使用するプロセス固有 | － | ×
 | ディクショナリサーバプロセスが使用するプロセス固有 | － | ×
 | バックエンドサーバプロセスが使用するプロセス固有 | － | ×
共用メモリ | ユニットコントローラ用共用メモリ中，ユニットコントローラが使用する領域 | ○ | ○
 | ユニットコントローラ用共用メモリ中，各サーバが使用する領域 | ○ | ○
 | グローバルバッファ用共用メモリ | ○ | ○
 | インメモリデータ処理用共用メモリ | × | ×
 | ユティリティ用共用メモリ | × | ×
 | セキュリティ監査情報用バッファ用共用メモリ | × | ×
 | プロセス間メモリ通信用共用メモリ | × | ×
  • ○は，容量計算機能でメモリサイズを計算することを示します。
  • ×は，容量計算機能でメモリサイズを計算しないことを示します。
  • －は，該当するHiRDB種別では計算対象とならないことを示します。

(b)　ディスクサイズ

容量計算機能では，HiRDB Configuration Assistantで定義したHiRDBファイルシステム領域のHiRDBファイルシステム領域サイズの合計値を計算します。

(2)　メモリ・ディスクサイズのチェックの手順

メモリ・ディスクサイズのチェックの手順を以下に示します。

  1. ［ツール(T)］－［容量計算］をクリックします。

    ［容量計算結果ダイアログ］が表示されます。
    ダイアログの表示内容を以下に示します。

    表4-16　容量計算結果ダイアログの表示内容

    項目 | 説明
    マシン名 | マシンの名称を表示します。
    ユニット名 | マシンに定義されているユニットの名称を表示します。
    メモリ所要量（MB） HiRDBの起動時にユニットが必要とする最小限のメモリサイズを表示します。単位はメガバイト（MB）です。
    小数点以下の数値は切り上げて表示します。
    ディスクパス
    • OS種別がWindowsの場合，ドライブレター
    • OS種別がUNIX系の場合，先頭のディレクトリを表示します。
    ディスク所要量（MB） | HiRDBファイルシステムが使用するディスクサイズを表示します。単位はメガバイト（MB）です。
    ［容量計算結果ダイアログ］に表示されたメモリ所要量，およびディスク所要量を合算することで，
    • HiRDBの起動に必要なメモリサイズ
    • HiRDBが使用するディスクサイズ
    を計算することができます。
  2. ［OK］ボタンをクリックします。
    ［容量計算結果ダイアログ］を閉じます。

注意
HiRDB Configuration Assistantは，容量計算の実行時，"（HiRDB Configuration Assistantのインストールフォルダ）\temp"フォルダ下に，一時的な作業フォルダ・ファイルを作成します（容量計算の終了時には削除します）。
容量計算の実行時にHiRDB Configuration Assitantが異常終了した場合，上記フォルダ下に一時的な作業フォルダ・ファイルが残ったままになってしまうことがあります。その場合，以下の手順にしたがい，一時的な作業フォルダ・ファイルを削除してください。
  1. HiRDB Configuration Assistantが起動していないことを確認してください。起動している場合は，すべて終了させてください。
  2. "（HiRDB Configuration Assistantのインストールフォルダ）\temp"フォルダの内容をエクスプローラ等で確認し，存在するフォルダ・ファイルをすべて削除してください。


定義ファイル，環境構築用バッチファイルを出力する

4.1.5　定義ファイル，環境構築用バッチファイルを出力する

HiRDB Configuration Assistantで定義したHiRDBを構築するための，定義ファイル，および環境構築用バッチファイルを出力します。

  1. ［ファイル(F)］－［構成情報ファイルを開く(O)］から，「4.1.2 HiRDB構成情報ファイルを保存する」で保存したHiRDB構成情報ファイルを開きます。
  2. ［ツール(T)］－［定義出力］－［新規定義出力］を選択します。
    注意
      構築対象のHiRDBがV0950以降で，オペランドに非推奨値が指定されている場合（警告件数が１以上となっている場合）は［新規定義出力(推奨変換)］を選択するようにしてください。非推奨値をそのまま適用する場合は，［新規定義出力］を選択してください。

  3. ［フォルダの参照］ダイアログが表示されますので，出力先フォルダを選択し，［OK］ボタンをクリックします。
    指定した出力先フォルダ以下に，HiRDBの環境を構築するための定義ファイルと環境構築用バッチファイルが格納されます。出力先フォルダ以下に格納されるフォルダおよびファイル一覧と，フォルダの階層構成を以下に示します。

    図4-6　 出力先フォルダの階層構成

    表4-17　 出力先フォルダ以下のフォルダおよびファイル一覧

    フォルダの種別 | フォルダの個数 | フォルダの名称 | フォルダに格納されるファイル
    出力先フォルダ | 1個 | 任意 | なし
    マシンフォルダ | マシン数 | マシン名 | なし
    ユニットフォルダ | ユニット数 | ユニット名 | なし
    HiRDBファイルシステム領域用バッチファイル格納フォルダ 1つのマシンにつき1個 "hirdb_file_batch"
    • HiRDBファイルシステム領域初期化用の統合バッチファイル，及びHiRDBファイル初期化用の統合バッチファイル
    • 上記バッチファイルより実行される各種コマンド実行バッチファイル
    RDエリア用バッチファイル格納用フォルダ 1つのユニットにつき1個 "rdarea_batch"
    • HiRDB初期起動時に必要なRDエリア作成用の統合バッチファイル
    • 上記バッチファイルより実行されるRDエリア作成コマンド実行バッチファイル
    • HiRDB起動後に必要なRDエリア追加用の統合バッチファイル(任意)
    • 上記バッチファイルより実行されるRDエリア追加コマンド実行バッチファイル(任意)
    confフォルダ 1つのユニットにつき1個 "conf"
    • ユニットに必要な各種定義ファイル
    • RDエリア生成用バッチファイルが入力する制御文ファイル

定義ファイル，および環境構築用バッチファイル作成時の注意事項を以下に示します。

  • 同一名称の定義ファイル，および環境構築用バッチファイルが既に存在する場合，その定義ファイル，および環境構築用バッチファイルを新しい定義ファイル，および環境構築用バッチファイルで上書きします。
  • 定義ファイル，および環境構築用バッチファイルを出力するフォルダには，HiRDB Configuration Assistantが定義ファイル，および環境構築用バッチファイルを出力できるように，フォルダの読み込み権限，書き込み権限を与えてください。
  • 同一名称の定義ファイル，および環境構築用バッチファイルが既に存在する場合，HiRDB Configuration Assistantが上書きできるように，既存の定義ファイル，および環境構築用バッチファイルの読み込み権限，書き込み権限を与えてください。
  • 同一名称の定義ファイル，および環境構築用バッチファイルが既に存在する場合，HiRDB Configuration Assistantが上書きできるように，他のプログラムで既存の定義ファイル，および環境構築用バッチファイルを開かないようにしてください。
  • HiRDBの構成の内容によっては，「表4-17　出力先フォルダ以下のフォルダおよびファイル一覧」に示した「フォルダに格納されるファイル」のうち，作成されないファイルもあります。
  • サーバ名称が，大文字，小文字の区別なく重複する場合（例：BES1とbes1），confフォルダに出力されるサーバ定義ファイルの名称も重複するため，先に出力されたサーバ定義ファイルの内容が削除され，後から出力されたサーバ定義ファイルにより上書きされます。
  • 定義ファイルpdsysはユニット下のフォルダに出力されます。そのため，定義ファイルpdsysを出力する場合は必ずユニットを作成してください。
  • 定義ファイルの詳細については，「付録B　定義ファイル」を参照してください。
  • 環境構築用バッチファイルの詳細については，「付録C　環境構築用バッチファイル」を参照してください。
  • 系切り替え先となるマシン名のフォルダへの定義ファイルの出力は行いません。そのため，スタンバイ型系切り替えの待機系ユニット，もしくは影響分散型系切り替えのゲストBESへの定義ファイルの転送は手動で行ってください。


定義ファイル，環境構築用バッチファイルの内容を確認する

4.1.6　定義ファイル，環境構築用バッチファイルの内容を確認する

「4.1.5　定義ファイル，環境構築用バッチファイルを出力する」で出力した定義ファイル，環境構築用バッチファイルの内容を確認して，新たに構築するHiRDBの設計の意図通りに定義ファイル，環境構築用バッチファイルが出力されているか，確認してください。

定義ファイルの詳細については，「付録B　定義ファイル」を参照してください。

環境構築用バッチファイルの詳細については，「付録C　環境構築用バッチファイル」を参照してください。

構築した内容に対応してHiRDB Configuration Assistantが出力する定義ファイル，および環境構築用バッチファイルについては，「付録D　構成要素と，出力する定義ファイル，および環境構築用バッチファイルの対応関係」を参照してください。


定義ファイル，環境構築用バッチファイルをHiRDBを構築するマシンに配置する

4.1.7　定義ファイル，環境構築用バッチファイルをHiRDBを構築するマシンに配置する

「4.1.5　定義ファイル，環境構築用バッチファイルを出力する」で出力した新規構築用の定義ファイルと環境構築用バッチファイルを， HiRDBを構築するマシンに配置する手順を以下に示します。

＜この項の構成＞
(1)　定義ファイル，環境構築用バッチファイルを各マシンに配置する
(2)　定義ファイル，環境構築用バッチファイルの文字コードを変換する

(1)　定義ファイル，環境構築用バッチファイルを各マシンに配置する

「表4-17　出力先フォルダ以下のフォルダおよびファイル一覧」に示したフォルダに，定義ファイル，および環境構築用バッチファイルが格納されています。それらを，以下に示すように，各マシンの所定のフォルダに配置してください。

表4-18　定義ファイル，および環境構築用バッチファイルの配置先

配置する定義ファイル，および環境構築用ファイル | 配置先フォルダ | 注意事項
格納フォルダ | ファイル
HiRDBファイルシステム領域用バッチファイルフォルダ HiRDBファイルシステム領域初期化用バッチファイル 上位フォルダのマシンフォルダが示すマシンの，任意のフォルダ
  • 配置先のファイルの所有者は，HiRDB管理者にしてください。
  • 配置先のファイルの権限として，実行権を与えてください。
HiRDBファイル初期化用バッチファイル
confフォルダ 定義ファイル 上位フォルダのマシンフォルダが示すマシンの，$PDDIR\confフォルダ
  • 配置先のファイルの所有者は，HiRDB管理者にしてください。
  • 配置先のファイルの権限として，読み込み権限を与えてください。
RDエリア作成用の制御文ファイル
RDエリア追加用の制御文ファイル
RDエリア用バッチファイルフォルダ RDエリア作成用の統合バッチファイル，およびコマンド実行バッチファイル 上位フォルダのマシンフォルダが示すマシンの，任意のフォルダ
  • 配置先のファイルの所有者は，HiRDB管理者にしてください。
  • 配置先のファイルの権限として，実行権を与えてください。
RDエリア追加用の統合バッチファイル，およびコマンド実行バッチファイル

(2)　定義ファイル，環境構築用バッチファイルの文字コードを変換する

「付録E　文字コード変換要否判定」にしたがい，文字コードの変換が必要と判断された場合，HiRDBが使用する文字コードに合わせて，定義ファイル，および環境構築用バッチファイルの文字コードを変換してください。


定義ファイルの構文チェックを行う

4.1.8　定義ファイルの構文チェックを行う

「4.1.3　システム定義のチェックを行う」を実行していない場合，HiRDBコマンドのpdconfchkを使用して，定義ファイルの構文チェックを行います。定義ファイルの構文チェックは，以下のコマンドを実行します。

pdconfchk -n

定義ファイルの構文チェックは，以下のマシン上で実行してください。

  • HiRDBパラレルサーバの場合，マネージャサーバが属するマシン
  • HiRDBシングルサーバの場合，シングルサーバが属するマシン


HiRDBファイルシステム領域を作成する

4.1.9　HiRDBファイルシステム領域を作成する

HiRDBを起動していない状態で，以下のバッチファイルが出力されているすべてのマシン上でバッチファイルを実行してください。

  • add_hfs_command.bat（Windows以外の場合，拡張子はsh）

このバッチファイルを実行することにより，HiRDBファイルシステム領域が新規に作成されます。

注意
必ず，バッチファイル実行前に「付録C　環境構築用バッチファイル」を参照し，バッチファイルの内容，および実行時の注意事項を確認の上，バッチファイルを実行してください。


システムファイルを作成する

4.1.10　システムファイルを作成する

HiRDBを起動していない状態で，以下のバッチファイルが出力されているすべてのマシン上でバッチファイルを実行してください。

  • init_systemfile_command.bat（Windows以外の場合，拡張子はsh）

このバッチファイルを実行することにより，HiRDBシステムファイルを新規に作成します。

注意
必ず，バッチファイル実行前に「付録C　環境構築用バッチファイル」を参照し，バッチファイルの内容，および実行時の注意事項を確認の上，バッチファイルを実行してください。


システムファイルの定義を含む定義ファイルのチェックを行う

4.1.11　システムファイルの定義を含む定義ファイルのチェックを行う

HiRDBコマンドのpdconfchkを使用して，システムファイルの定義を含む定義ファイルのチェックを行います。定義ファイルのチェックは，以下のコマンドを実行します。

pdconfchk

定義ファイルのチェックは，以下のマシン上で実行してください。

  • HiRDBパラレルサーバの場合，マネージャサーバが属するマシン
  • HiRDBシングルサーバの場合，シングルサーバが属するマシン


HiRDBを開始する

4.1.12　HiRDBを開始する

HiRDBを開始させてください。Windows版の場合，HiRDB開始の前提として，HiRDBのサービスの開始が必要です。


データベースを初期化する

4.1.13　データベースを初期化する

HiRDBの開始中，データベース初期設定ユティリティの開始待ち（KFPS05201-Qメッセージを出力して停止した状態）で，以下のバッチファイルが出力されているすべてのマシン上でバッチファイルを実行してください。

  • init_rdarea_dic_command.bat（Windows以外の場合，拡張子はsh）

このバッチファイルを実行することにより，HiRDBのデータベースが初期化されます。

注意
必ず，バッチファイル実行前に「付録C　環境構築用バッチファイル」を参照し，バッチファイルの内容，および実行時の注意事項を確認の上，バッチファイルを実行してください。


レジストリ用RDエリア，およびデータディクショナリ用RDエリア（再編成時期予測用）を追加する

4.1.14　レジストリ用RDエリア，およびデータディクショナリ用RDエリア（再編成時期予測用）を追加する

「4.1.5　定義ファイル，環境構築用バッチファイルを出力する」時に，RDエリア初期化用バッチファイルが出力されている場合，以下の処理を実行してください。

データベースの初期化が正常に終了（KFPS05210-Iメッセージを出力）した後，以下のバッチファイルが出力されているすべてのマシン上でバッチファイルを実行してください。

  • init_rdarea_command.bat（Windows以外の場合，拡張子はsh）

このバッチファイルを実行することにより，HiRDBのデータベースにレジストリ用RDエリア，およびデータディクショナリ用RDエリア（再編成時期予測用）が追加されます。

注意
必ず，バッチファイル実行前に「付録C　環境構築用バッチファイル」を参照し，バッチファイルの内容，および実行時の注意事項を確認の上，バッチファイルを実行してください。


構築中にエラーが発生した場合の対処方法

4.1.15　構築中にエラーが発生した場合の対処方法

新しくHiRDBを構築する作業中にエラー，または警告が発生した場合は，HiRDB Configuration Assistantのマニュアル，及びHiRDBのマニュアルを参照して対処してください。

定義ファイル，環境構築用バッチファイルの修正が必要な場合は「4.1.1　HiRDB Configuration Assistantを使用してHiRDBの構成を定義する」から作業を再実行してください。再実行する前に，以下の作業を実施してHiRDB構築前に環境を戻してください。

  • HiRDBを構築するマシンに新規構築用の定義ファイル，および環境構築用バッチファイルを配置している場合，配置したファイルを削除してください。
  • HiRDBファイルシステム領域初期化バッチファイル（init_hfs_command.bat，Windows以外の場合，拡張子はsh）を実行した場合は，作成したHiRDBファイルシステム領域を削除してください。


既存HiRDBの構成を取り込んで，構成変更する

4.2　既存HiRDBの構成を取り込んで，構成変更する

ここでは，HiRDB Configuration Assistantを使用して，構築済みのHiRDBの構成を変更するための手順を示します。手順の流れと，その詳細を説明する項番の対応を以下に示します。

構築済みのHiRDBの構成を変更するためには，以下の項目が完了している必要があります。

  • 構成変更対象のHiRDBは，定義にエラーがなく，動作実績のあるHiRDBであること。
  • HiRDBの構成変更の内容が決定していること。
  • HiRDBの構成変更に伴い，変更される定義ファイル，およびHiRDBの資源がバックアップされていること。
    構成変更に伴いバックアップが必要となるHiRDBの資源については，HiRDBのマニュアルを参照してください。

注意
構成変更対象のHiRDBは，定義にエラーがなく，動作実績のあるHiRDBであることを必ず確認の上，HiRDB Configuration Assistantに取り込んでください。そうでない場合，正しく定義ファイル，および環境構築用バッチファイルを出力できず，HiRDBの構成変更が失敗する可能性があります。

図4-7　既存HiRDBの構成変更手順

なお，上記の構成変更作業中にエラーが発生した場合は，「4.2.17　構築中にエラーが発生した場合の対処法」にしたがい，作業を再実行してください。

＜この節の構成＞
4.2.1　構築済みのHiRDB環境から，HiRDB構成情報を取り込む（確定状態取り込み）
4.2.2　HiRDBの構成を変更する
4.2.3　HiRDB構成情報ファイルを保存する
4.2.4　システム定義のチェックを行う
4.2.5　メモリ・ディスクサイズのチェックを行う
4.2.6　定義ファイル，環境構築用バッチファイルを出力する
4.2.7　定義ファイル，環境構築用バッチファイルの内容を確認する
4.2.8　HiRDBを停止する
4.2.9　定義ファイル，環境構築用バッチファイルを構成変更対象のHiRDBを構成するマシンに配置する
4.2.10　定義ファイルの構文チェックを行う
4.2.11　HiRDBファイルシステム領域を追加する
4.2.12　システムファイルの定義を含む定義ファイルのチェックを行う
4.2.13　HiRDBシステムファイルを変更する
4.2.14　HiRDBを開始する
4.2.15　RDエリアを変更する
4.2.16　HiRDBファイルシステム領域を削除する
4.2.17　構築中にエラーが発生した場合の対処方法


構築済みのHiRDB環境から，HiRDB構成情報を取り込む（確定状態取り込み）

4.2.1　構築済みのHiRDB環境から，HiRDB構成情報を取り込む（確定状態取り込み）

まずはじめに，構築済みのHiRDB環境から，入力ファイルを介して，HiRDB構成情報をHiRDB Configuration Assistantに取り込むまでの手順を以下で説明します。

参考
「4.2.1(1)　入力ファイルを格納するためのフォルダ作成」，および「4.2.1(2)　入力ファイル取得，格納」については，HiRDB Configuration Assistantが提供する，HiRDB構成情報取り込みツールを使用して行うことができます。HiRDB構成情報取り込みツールの使用方法については，以下に格納されている「HiRDB構成情報取り込みツール取扱説明書」をご参照ください。
(インストールフォルダ)\tool\HiRDB_Import_readme.pdf
HiRDB構成情報取り込みツールで使用するコマンドの格納場所については，「2.1.1　フォルダ構成」をご参照ください。

制限事項
HiRDBが複製ディスク機能を用いた系切り替え構成の場合，以下の制限事項があります。
  • プライマリパスにpd_duplicated_fs_suffixオペランドに指定しているサフィックスを含んでいないこと。

＜この項の構成＞
(1)　入力ファイルを格納するためのフォルダ作成
(2)　入力ファイル取得，格納
(3)　HiRDB Configuration Assistantへの取り込み

(1)　入力ファイルを格納するためのフォルダ作成

HiRDB Configuration Assistantがインストールされたマシンから参照可能なドライブ上に，構築済みのHiRDB環境の構成情報を含む入力ファイルを格納するためのフォルダを作成します。

入力ファイルを格納するためのフォルダとして，以下に示す4種類を，構築済みのHiRDB環境に合わせて，以下のように階層的に作成してください。

図4-8　入力ファイル格納用フォルダの階層

表4-19　入力ファイルを格納するためのフォルダの一覧

フォルダの種別 | 説明 | フォルダの個数 | フォルダの名称
入力ファイル格納用フォルダ | 入力ファイル格納用のフォルダです。 | 1個作成します。 | 任意の名称を指定します。
マシンフォルダ | HiRDBを構成するマシンに対応するフォルダです。 | 構築済みのHiRDB環境に存在するマシンの数作成します。 | マシン名称を指定します。
ユニットフォルダ | HiRDBを構成するユニットに対応するフォルダです。 | 構築済みのHiRDB環境に存在するユニットの数作成します。 | ユニット名称を指定します。
confフォルダ | 定義ファイルを格納するフォルダです。 | 1つのユニットフォルダにつき1個作成します。 | "conf"

フォルダに関する注意事項を以下に示します。

  • 全てのフォルダに対して，HiRDB Configuration Assistantが読み込めるよう，読み込み権限を与えてください。
  • マシン名称，またはユニット名称が，大文字，小文字の区別なく重複する場合（例：HOST1とhost1），フォルダの名称が重複するため，フォルダを作成することができません。そのため，マシン名称，またはユニット名称を大文字，小文字の区別なく重複しない名称に変更してフォルダを作成するようにしてください。
  • 上記に示したフォルダ以外は作成してはいけません。作成した場合，HiRDB構成情報の取り込みが失敗したり，正しく取り込まれないことがあります。

(2)　入力ファイル取得，格納

「4.2.1(1)　入力ファイルを格納するためのフォルダ作成」で作成したフォルダに，以下に示す入力ファイルを構築済みのHiRDB環境から転送し，格納します。

表4-20　入力ファイルの一覧

入力ファイル | ファイル名称 | 格納フォルダ | 取得方法
定義ファイル | システム共通定義 | pdsys | 定義ファイルに対応するユニットのconfフォルダ | 各サーバから取得してください。
ユニット制御情報定義 | pdutsys
サーバ共通定義 | pdsvrc
フロントエンドサーバ定義 | (FESサーバ名)
ディクショナリサーバ定義 | (DICサーバ名)
バックエンドサーバ定義 | (BESサーバ名)
シングルサーバ定義 | (SDSサーバ名)
ディクショナリ検索結果ファイル | MASTER.SQL_PHISICAL_FILES表の検索結果 | SQL_PHYSICAL_FILES.csv | 入力ファイル格納用フォルダ | "select * from MASTER.SQL_PHYSICAL_FILES order by PHYSICAL_FILE_ID without lock nowait"の実行結果をcsv形式で保存してください。
MASTER.SQL_RDAREAS表の検索結果 | SQL_RDAREAS.csv | "select * from MASTER.SQL_RDAREAS without lock nowait"の実行結果をcsv形式で保存してください。
MASTER.SQL_RDAREA_PRIVILEGES
表の検索結果 		SQL_RDAREA_PRIVILEGES.csv "select * from MASTER.SQL_RDAREA_PRIVILEGES without lock nowait"の実行結果をcsv形式で保存してください。
MASTER.SQL_TABLES表の検索結果 SQL_RDAREAS_FOR_RTN.csv "select RDAREA_NAME,count(*) from MASTER.SQL_TABLES where RDAREA_NAME = (select RDAREA_NAME from MASTER.SQL_TABLES where TABLE_SCHEMA='HiRDB' and TABLE_NAME='SQL_ROUTINES') group by RDAREA_NAME without lock nowait"
の実行結果をcsv形式で保存してください。
SQL_RDAREAS_FOR_DBM.csv | "select RDAREA_NAME from MASTER.SQL_TABLES where TABLE_SCHEMA='HiRDB' and TABLE_NAME='SQL_DB_MANAGEMENT' without lock nowait"の実行結果をcsv形式で保存してください。
RDエリア状態表示結果ファイル pddblsコマンドの実行結果 pddbls.csv "pddbls -x -r all"の実行結果をcsv形式でファイルに保存してください。
pdmodコマンドでRDエリアのopen attributeをDEFERもしくはSCHEDULEで追加している場合，HiRDBを再起動した後，pddblsを実行してください。
HiRDBの再起動を行わずpddblsを実行した場合，open attributeをINITIALとして取り込みます。
HiRDBファイルシステム領域状態表示結果ファイル | pdfstatfsコマンドの実行結果 | (任意の名称)_pdfstatfs.txt | マシンフォルダ | 「表4-21　pdfstatfsコマンドの実行方法」を参照してください。
pdflsコマンドの実行結果 | (任意の名称)_pdfls.txt | 「表4-22　pdflsコマンドの実行方法」を参照してください。
HiRDBのバージョン情報 pdadmvr.txt 入力ファイル格納用フォルダ "pdadmvr -s"の実行結果をファイルに保存してください。
  • pdadmvrコマンドの実行結果の判定方法を以下に示します。
  • pdadmvr.txtの先頭の文字列が以下のいずれかである必要があります。
  • parallel△
  • single△
※△は半角スペースを示します。
OS種別 os_kind.txt 以下に示す，いずれかのキーワードを記入してください。
  • AIX
  • Linux
  • HP-UX
  • Solaris
HiRDBのOS種別がWindowsの場合は，本ファイルは不要です。

「表4-20　入力ファイルの一覧」中の，pdfstatfsコマンド，およびpdflsコマンドの実行方法を以下に示します。

表4-21　pdfstatfsコマンドの実行方法

構築済みのHiRDB環境のプラットフォーム 実行方法 実行時の注意事項
AIX 以下に示すコマンドを実行してください。
/usr/bin/sh -x -c 'pdfstatfs -x -A (HiRDBファイルシステム領域名(絶対パス))' 1>  (任意の名称)_pdfstatfs.txt 2>&1
  • Bシェル環境で実行してください。
  • 実行前に，$PDDIR/binがPATH環境変数に追加されていることを確認してください。
  • pdfstatfsコマンドの引数の順序は変えないでください。
HP-UX
Solaris 以下に示すコマンドを実行してください。
/usr/xpg4/bin/sh -x -c 'pdfstatfs -x -A (HiRDBファイルシステム領域名(絶対パス))' 1> (任意の名称)_pdfstatfs.txt 2>&1
Linux 以下に示すコマンドを実行してください。
/bin/sh -x -c 'pdfstatfs -x -A (HiRDBファイルシステム領域名(絶対パス))' 1> (任意の名称)_pdfstatfs.txt 2>&1
Windows 以下に示す2つのコマンドを順番に実行してください。
echo + pdfstatfs -x -A (HiRDBファイルシステム領域名(絶対パス)) > (任意の名称)_pdfstatfs.txt
pdfstatfs -x -A (HiRDBファイルシステム領域名(絶対パス)) >> (任意の名称)_pdfstatfs.txt
  • 実行前に，%PDDIR%\binがPATH環境変数に追加されていることを確認してください。
  • pdfstatfsコマンドの引数の順序は変えないでください。

表4-22　pdflsコマンドの実行方法

構築済みのHiRDB環境のプラットフォーム 実行方法 実行時の注意事項
AIX 以下に示すコマンドを実行してください。
/usr/bin/sh -x -c 'pdfls (HiRDBファイルシステム領域名(絶対パス))' 1> (任意の名称)_pdfls.txt 2>&1
  • Bシェル環境で実行してください。
  • 実行前に，$PDDIR/binがPATH環境変数に追加されていることを確認してください。
HP-UX
Solaris 以下に示すコマンドを実行してください。
/usr/xpg4/bin/sh -x -c 'pdfls (HiRDBファイルシステム領域名(絶対パス))' 1> (任意の名称)_pdfls.txt 2>&1
Linux 以下に示すコマンドを実行してください。
/bin/sh -x -c 'pdfls (HiRDBファイルシステム領域名(絶対パス))' 1> (任意の名称)_pdfls.txt 2>&1
Windows 以下に示す2つのコマンドを順番に実行してください。
echo + pdfls (HiRDBファイルシステム領域名(絶対パス)) > (任意の名称)_pdfls.txt
pdfls (HiRDBファイルシステム領域名(絶対パス)) >> (任意の名称)_pdfls.txt
 実行前に，%PDDIR%\binがPATH環境変数に追加されていることを確認してください。

入力ファイル取得，格納時の注意事項を以下に示します。

  • 「表4-20　入力ファイルの一覧」に示した入力ファイルは，かならず全て取得するようにしてください。入力ファイルが不足している場合，入力した情報の範囲で参照する事はできますが，その状態では正しい定義ファイル，および環境構築用バッチファイルを生成する事はできません。
  • 入力ファイルを取得する際に発行するコマンド，およびSQL文の実行は，HiRDBのマニュアルにある使用方法，注意事項を参照の上実行してください。
  • 構築済みのHiRDB環境から入力ファイルを転送する際には，アスキーコードとして転送してください。
  • 構築済みのHiRDB環境で使用する文字コードがShift-JIS以外の場合，転送し，格納したファイルの文字コードをShift-JISに変換してください。
  • 定義ファイルのコメント，およびインデクス名称でマルチバイト文字を使用している場合，文字コードの変換により，文字化けが発生する可能性があります。文字化けが発生した場合には，文字化けしない文字に変更してください。
  • 上記に示した入力ファイル以外を，入力ファイルを格納するためのフォルダに格納しないようにしてください。格納した場合，HiRDB構成情報の取り込みが失敗したり，正しく取り込まれないことがあります。
  • 入力ファイルは，上記に指定した格納フォルダに正しく格納してください。誤ったフォルダに格納した場合，HiRDB構成情報の取り込みが失敗したり，正しく取り込まれないことがあります。
  • サーバ名称が，大文字，小文字の区別なく重複する場合（例：BES1とbes1），入力するサーバ定義ファイルの名称が重複するため，ファイルを配置することができません。そのため，サーバ名称を大文字，小文字の区別なく重複しない名称に変更して入力ファイルを配置するようにしてください。
  • 入力ファイルには，不要な空行を入れないようにしてください。HiRDB構成情報の取り込みが失敗したり，正しく取り込まれないことがあります。
  • ディクショナリ表の検索は，システムへの負荷を考慮して，システムのトラフィックが低い時間帯で実行してください。
  • ディクショナリ表の検索により，取得した値がnullの列であった場合は，各csvファイルの該当箇所に以下の内容にしたがい値を設定する必要があります。
    • 列のデータ型が数値型である場合，「,*,」を設定します。
    • 列のデータ型が文字列型である場合，「,,」を設定します。
    HiRDB SQL EXECUTERのPUTFILEコマンドのDAT形式，または拡張DAT形式を使用することにより，上記に示す設定内容で出力することができます。
    なお，PUTFILEコマンドを使用する場合は，環境変数PDUAPPTFNULLにOFFを設定するか，当該環境変数を設定しないでください。

(3)　HiRDB Configuration Assistantへの取り込み

「4.2.1(2)　入力ファイル取得，格納」で取得，格納した入力ファイルをHiRDB Configuration Assistantに取り込みます。

  1. HiRDB Configuration Assistantを起動します。
  2. ［ツール(T)］－［定義取り込み］－［確定状態取り込み］を選択します。
    注意
    既存HiRDBの構成を取り込んで構成変更するためには［確定状態取り込み］を選択し，構成要素をすべて確定状態で取り込む必要があります。誤って［新規状態取り込み］を選択しないよう注意してください。

  3. ［フォルダの参照］ダイアログが表示されますので，「4.2.1(1)　入力ファイルを格納するためのフォルダ作成」で作成した入力ファイル格納用フォルダを選択し，［OK］ボタンをクリックします。
  4. ［HiRDB構成初期情報ダイアログ］が表示されますので，構築対象のHiRDBに合わせて値を入力し，［OK］ボタンをクリックします。
    HiRDB Configuration Assistantに構築済みのHiRDB環境が取り込まれます。
    • 取り込み対象のHiRDBからHiRDBバージョンを変更した場合，取り込み対象のHiRDBで定義されていたオペランドが変更後のHiRDBで未サポートの無効なオペランドとなることがあります。無効なオペランドはHiRDB Configuration Assistantで参照・更新することはできません。また，定義出力時には無効なオペランドが定義ファイルに出力されますので，定義ファイルから削除してください。
    • 取り込み対象のHiRDBからHiRDBバージョンを下位バージョンに変更した場合，HiRDB Configuration Assistantで正しい定義ファイル，環境構築用バッチファイルが出力できない可能性がありますので，HiRDBのバージョンダウンとなる変更をしないでください。
    • 取り込み対象のHiRDBからHiRDBバージョンを変更する場合，実際に存在しないHiRDBの組み合わせとなっていないことを確認してください。
    ［HiRDB構成初期情報ダイアログ］の詳細は，「3.3.4　HiRDB構成初期情報ダイアログ」を参照してください。

HiRDB Configuration Assistantへの取り込み時に，「パラメータが間違っています。」というエラーメッセージのダイアログが出力され，取り込みが失敗することがあります。失敗の要因として，以下の3点が考えられますので，これらを見直して対応し，再度取り込みを行ってください。

表4-23　HiRDB Configuration Assistantへの取り込みが失敗する要因

要因 | 対処法
入力ファイルの定義に文法誤りがある。 | 構築済みのHiRDB環境上でpdconfchkを実行し，入力ファイルの文法誤りを取り除いてください。
構築済みのHiRDB環境で使用する文字コードがShift-JIS以外であるにもかかわらず，入力ファイルの文字コードをShift-JISに変換していない。 | 入力ファイルの文字コードをShift-JISに変換してください。
pdflsコマンドの実行結果に空行が含まれている。 | 空行を取り除いてください。


HiRDBの構成を変更する

4.2.2　HiRDBの構成を変更する

「4.2.1　構築済みのHiRDB環境から，HiRDB構成情報を取り込む（確定状態取り込み）」に示した手順で取り込んだHiRDB構成情報を，HiRDB Configuration Assistantで変更してください。

HiRDB Configuration Assistant上での構成変更の操作方法は，「3.4　基本操作」を参照してください。


HiRDB構成情報ファイルを保存する

4.2.3　HiRDB構成情報ファイルを保存する

HiRDBの構成を変更した後，［ファイル(F)］－［名前を付けて保存(A)］を選択し，構成変更したHiRDBの構成情報を，HiRDB構成情報ファイルに保存してください。

HiRDB構成情報ファイル保存時の注意事項を以下に示します。

  • 同一名称のHiRDB構成情報ファイルが既に存在する場合，そのHiRDB構成情報を新しいHiRDB構成情報ファイルで上書きします。
  • HiRDB構成情報ファイルを出力するフォルダには，HiRDB Configuration AssistantがHiRDB構成情報ファイルを出力できるように，フォルダの読み込み権限，書き込み権限を与えてください。
  • 同一名称のHiRDB構成情報ファイルが既に存在する場合，HiRDB Configuration Assistantが上書きできるように，既存のHiRDB構成情報ファイルの読み込み権限，書き込み権限を与えてください。
  • 同一名称のHiRDB構成情報ファイルが既に存在する場合，HiRDB Configuration Assistantが上書きできるように，他のプログラムで既存のHiRDB構成情報ファイルを開かないようにしてください。


システム定義のチェックを行う

4.2.4　システム定義のチェックを行う

HiRDB Configuration Assistantで定義したHiRDB構成情報から出力されるシステム定義のチェックを行います。

システム定義のチェックは，HiRDB Configuration Assistantが動作するマシンから，HiRDBを構築するマシンに定義ファイルを送信し，pdconfchkコマンドを実行することにより行います。

システム定義のチェックを行うための前提条件，および手順は「4.1.3　システム定義のチェック」を参照してください。

前提条件を満たすことができない場合はHiRDB Configuration Assistantのシステム定義のチェック機能を使用することはできませんので，定義ファイルを，HiRDBを構築するマシンに転送した後でチェックを実行してください。詳細は「4.2.10　定義ファイルの構文チェックを行う」を参照してください。


メモリ・ディスクサイズのチェックを行う

4.2.5　メモリ・ディスクサイズのチェックを行う

HiRDB Configuration Assistantで定義したHiRDB構成情報をもとに，HiRDBが使用するメモリ・ディスクサイズのチェックを行います。

メモリ・ディスクサイズのチェックは，HiRDB Cofiguration Assistantの容量計算機能を使用します。容量計算機能により，以下の容量を計算することができます。

  • HiRDBの起動に必要なメモリサイズ
  • HiRDBが使用するディスクサイズ

メモリ・ディスクサイズのチェックの詳細，前提条件，および手順は「4.1.4　メモリ・ディスクサイズのチェックを行う」を参照してください。

前提条件を満たすことができない場合はHiRDB Configuration Assistantの容量計算機能を使用することはできません。HiRDBのマニュアルにしたがってメモリ・ディスクサイズの計算を行い，HiRDBの構成を変更するマシンでメモリ・ディスクの不足が発生しないことを確認してください。


定義ファイル，環境構築用バッチファイルを出力する

4.2.6　定義ファイル，環境構築用バッチファイルを出力する

構成変更の内容を既存のHiRDB環境に反映するための，定義ファイル，および環境構築用バッチファイルを出力します。

  1. ［ファイル(F)］－［構成情報ファイルを開く(O)］から，「4.2.3　HiRDBの構成情報ファイルを保存する」で作成したHiRDB構成情報ファイルを開きます。
  2. ［ツール(T)］－［定義出力］－［変更定義出力］を選択します。
  3. ［フォルダの参照］ダイアログが表示されますので，フォルダダイアログで出力先フォルダを選択し，［OK］ボタンをクリックします。
    指定した出力先フォルダに，定義ファイル，および環境構築用バッチファイルを格納するためのフォルダが作成され，その下に，定義ファイル，および環境構築用バッチファイルが格納されます。出力先フォルダ以下のフォルダの一覧と，その階層構成を以下に示します。

    図4-9　出力先フォルダの階層構成

    表4-24　出力先フォルダ以下のフォルダおよびファイル一覧

    フォルダの種別 | フォルダの個数 | フォルダの名称 | フォルダに格納されるファイル
    出力先フォルダ | 1個 | 任意 | なし
    マシンフォルダ | マシン数 | マシン名 | なし
    ユニットフォルダ | ユニット数 | ユニット名 | なし
    HiRDBファイルシステム領域用バッチファイル格納フォルダ 1つのマシンにつき1個 "hirdb_file_batch"
    • HiRDBファイルシステム領域変更用バッチファイル
    • HiRDBファイル変更用バッチファイル
    confフォルダ 1つのユニットにつき1個 "conf"
    • 定義ファイル
    • ディクショナリ用RDエリア変更用の制御文ファイル
    • RDエリア変更用の制御文ファイル
    RDエリア用バッチファイル格納フォルダ 1つのユニットにつき1個 "rdarea_batch"
    • RDエリア変更用の統合バッチファイル，およびコマンド実行バッチファイル

定義ファイル，および環境構築用バッチファイル作成時の注意事項を以下に示します。

  • 同一名称の定義ファイル，および環境構築用バッチファイルが既に存在する場合，その定義ファイル，および環境構築用バッチファイルを新しい定義ファイル，および環境構築用バッチファイルで上書きします。
  • 定義ファイル，および環境構築用バッチファイルを出力するフォルダには，HiRDB Configuration Assistantが定義ファイル，および環境構築用バッチファイルを出力できるように，フォルダの読み込み権限，書き込み権限を与えてください。
  • 同一名称の定義ファイル，および環境構築用バッチファイルが既に存在する場合，HiRDB Configuration Assistantが上書きできるように，既存の定義ファイル，および環境構築用バッチファイルの読み込み権限，書き込み権限を与えてください。
  • 同一名称の定義ファイル，および環境構築用バッチファイルが既に存在する場合，HiRDB Configuration Assistantが上書きできるように，他のプログラムで既存の定義ファイル，および環境構築用バッチファイルを開かないようにしてください。
  • サーバ名称が，大文字，小文字の区別なく重複する場合（例：BES1とbes1），confフォルダに出力されるサーバ定義ファイルの名称も重複するため，先に出力されたサーバ定義ファイルの内容が削除され，後から出力されたサーバ定義ファイルにより上書きされます。
  • 構成要素のオペランド値を変更した場合，定義ファイルに出力されるオペランドは，HiRDBシステム定義のフォーマットに変換して出力します。
  • HiRDBの構成変更の内容によっては，「表4-24　出力先フォルダ以下のフォルダおよびファイル一覧」に示した「フォルダに格納されるファイル」のうち，作成されないファイルもあります。
  • HiRDBの構成変更の内容によって，ひとつも「フォルダに格納されるファイル」が作成されない場合でも，フォルダは必ず作成されます。
  • 定義ファイルpdsysはユニット下のフォルダに出力されます。そのため，定義ファイルpdsysを出力する場合は必ずユニットを作成してください。
  • 定義ファイルの詳細については，「付録B　定義ファイル」を参照してください。
  • 環境構築用バッチファイルの詳細については，「付録C　環境構築用バッチファイル」を参照してください。
  • 系切り替え先となるマシン名のフォルダへの定義ファイルの出力は行いません。そのため，スタンバイ型系切り替えの待機系ユニット，もしくは影響分散型系切り替えのゲストBESへの定義ファイルの転送は手動で行ってください。


定義ファイル，環境構築用バッチファイルの内容を確認する

4.2.7　定義ファイル，環境構築用バッチファイルの内容を確認する

「4.2.6　定義ファイル，環境構築用バッチファイルを出力する」で出力した定義ファイル，環境構築用バッチファイルの内容を確認して，構成変更の内容が反映されているか，確認してください。

定義ファイルの詳細については，「付録B　定義ファイル」を参照してください。

環境構築用バッチファイルの詳細については，「付録C　環境構築用バッチファイル」を参照してください。

変更した内容に対応して，HiRDB Configuration Assistantが出力する定義ファイル，および環境構築用バッチファイルについては，「付録D　構成要素と，出力する定義ファイル，およびバッチファイルの対応関係」を参照してください。

「4.2.1(3)　HiRDB Configuration Assistantへの取り込み」時に，取り込み対象のHiRDBからHiRDBバージョンを変更した場合，取り込み対象のHiRDBで定義されていたオペランドが変更後のHiRDBで未サポートの無効なオペランドとなることがあります。無効なオペランドは定義ファイルに出力されますので，定義ファイルから削除してください。


HiRDBを停止する

4.2.8　HiRDBを停止する

構成変更対象のHiRDBを停止させてください。

以降，「4.2.9　定義ファイル，環境構築用バッチファイルを構成変更対象のHiRDBを構成するマシンに配置する」から，「4.2.13　HiRDBシステムファイルを変更する」までは，HiRDBを停止した状態で作業を行ってください。


定義ファイル，環境構築用バッチファイルを構成変更対象のHiRDBを構成するマシンに配置する

4.2.9　定義ファイル，環境構築用バッチファイルを構成変更対象のHiRDBを構成するマシンに配置する

「4.2.6　定義ファイル，環境構築用バッチファイルを出力する」で出力した構成変更用の定義ファイルと環境構築用バッチファイルを，構成変更対象のHiRDBを構成するマシンに配置する手順を以下に示します。

＜この項の構成＞
(1)　定義ファイル，環境構築用バッチファイルを各マシンに配置する
(2)　定義ファイル，環境構築用バッチファイルの文字コードを変換する

(1)　定義ファイル，環境構築用バッチファイルを各マシンに配置する

「表4-24　出力先フォルダ以下のフォルダおよびファイル一覧」に示すフォルダに，定義ファイル，および環境構築用バッチファイルが格納されています。それらを，以下に示すように，各マシンの所定のフォルダに転送してください。

表4-25　定義ファイル，および環境構築用バッチファイルの転送先

配置する定義ファイル，および環境構築用ファイル | 配置先フォルダ | 注意事項
格納フォルダ | ファイル
HiRDBファイルシステム領域用バッチファイルフォルダ HiRDBファイルシステム領域変更用バッチファイル 上位フォルダのマシンフォルダが示すマシンの，任意のフォルダ
  • 配置先のファイルの所有者は，HiRDB管理者にしてください。
  • 配置先のファイルの権限として，実行権を与えてください。
HiRDBファイル変更用バッチファイル
confフォルダ 定義ファイル 上位フォルダのマシンフォルダが示すマシンの，$PDDIR\conf\(subdir)フォルダ
  • 配置先のファイルの所有者は，HiRDB管理者にしてください。
  • 配置先のファイルの権限として，読み込み権限を与えてください。
  • (subdir)は，すべてのユニットで共通の，任意の名称を設定してください。
RDエリア変更用の制御文ファイル
RDエリア用バッチファイルフォルダ RDエリア変更用の統合バッチファイル，およびコマンド実行バッチファイル 上位フォルダのマシンフォルダが示すマシンの，任意のフォルダ
  • 配置先のファイルの所有者は，HiRDB管理者にしてください。
  • 配置先のファイルの権限として，実行権を与えてください。

(2)　定義ファイル，環境構築用バッチファイルの文字コードを変換する

「付録E　文字コード変換要否判定」にしたがい，文字コードの変換が必要と判断された場合，HiRDBが使用する文字コードに合わせて，定義ファイル，および環境構築用バッチファイルの文字コードを変換してください。


定義ファイルの構文チェックを行う

4.2.10　定義ファイルの構文チェックを行う

「4.2.4　システム定義のチェックを行う」を実行していない場合，HiRDBコマンドのpdconfchkを使用して，定義ファイルの構文チェックを行います。定義ファイルの構文チェックは，以下のコマンドを実行します。

pdconfchk -d (subdir) -n

subdirは，「表4-25　定義ファイル，および環境構築用バッチファイルの転送先」に示したフォルダです。

定義ファイルの構文チェックは，以下のマシン上で実行してください。

  • HiRDBパラレルサーバの場合，マネージャサーバが属するマシン
  • HiRDBシングルサーバの場合，シングルサーバが属するマシン


HiRDBファイルシステム領域を追加する

4.2.11　HiRDBファイルシステム領域を追加する

「4.2.6　定義ファイル，環境構築用バッチファイルを出力する」時に，HiRDBファイルシステム領域を追加するためのHiRDBファイルシステム領域変更用バッチファイルが出力されている場合，以下の処理を実行してください。

以下のバッチファイルが出力されているすべてのマシン上でバッチファイルを実行してください。

  • add_hfs_command.bat（Windows以外の場合，拡張子はsh）

このバッチファイルを実行することにより，既存HiRDBのHiRDBファイルシステム領域が追加されます。

注意
このバッチファイルの実行は，既存HiRDBの環境に変更を加えるため，必ず，バッチファイル実行前に「付録C　環境構築用バッチファイル」を参照し，バッチファイルの内容，および実行時の注意事項を確認の上，バッチファイルを実行してください。


システムファイルの定義を含む定義ファイルのチェックを行う

4.2.12　システムファイルの定義を含む定義ファイルのチェックを行う

HiRDBコマンドのpdconfchkを使用して，システムファイルの定義を含む定義ファイルのチェックを行います。定義ファイルのチェックは，以下のコマンドを実行します。

pdconfchk -d (subdir)

subdirは，「表4-25　定義ファイル，および環境構築用バッチファイルの転送先」に示したフォルダです。

定義ファイルのチェックは，以下のマシン上で実行してください。

  • HiRDBパラレルサーバの場合，マネージャサーバが属するマシン
  • HiRDBシングルサーバの場合，シングルサーバが属するマシン

pdconfchkのリタンコードが0であれば，$PDDIR/conf/subdir下のファイルを$PDDIR/confに上書きしてください。


HiRDBシステムファイルを変更する

4.2.13　HiRDBシステムファイルを変更する

「4.2.6　定義ファイル，環境構築用バッチファイルを出力する」時に，HiRDBファイル変更用バッチファイルが出力されている場合，以下の処理を実行してください。

以下のバッチファイルが出力されているすべてのマシン上でバッチファイルを実行してください。

  • change_systemfile_command.bat（Windows以外の場合，拡張子はsh）

このバッチファイルを実行することにより，既存HiRDBのHiRDBシステムファイルが変更されます。

注意
このバッチファイルの実行は，既存HiRDBの環境に変更を加えるため，必ず，バッチファイル実行前に「付録C　環境構築用バッチファイル」を参照し，バッチファイルの内容，および実行時の注意事項を確認の上，バッチファイルを実行してください。


HiRDBを開始する

4.2.14　HiRDBを開始する

HiRDBを開始させてください。Windows版の場合，HiRDB開始の前提として，HiRDBのサービスの開始が必要です。

以降，「4.2.15　RDエリアを変更する」と，「4.2.16　HiRDBファイルシステム領域を削除する」は，HiRDBの開始が完了した状態で作業を行ってください。


RDエリアを変更する

4.2.15　RDエリアを変更する

「4.2.6　定義ファイル，環境構築用バッチファイルを出力する」時に，RDエリア変更用バッチファイルが出力されている場合，以下の処理を実行してください。

以下のバッチファイルが出力されているすべてのマシン上でバッチファイルを実行してください。

  • change_rdarea_command.bat（Windows以外の場合，拡張子はsh）

このバッチファイルを実行することにより，既存HiRDBのRDエリアが変更されます。

注意
このバッチファイルの実行は，既存HiRDBの環境に変更を加えるため，必ず，バッチファイル実行前に「付録C　環境構築用バッチファイル」を参照し，バッチファイルの内容，および実行時の注意事項を確認の上，バッチファイルを実行してください。


HiRDBファイルシステム領域を削除する

4.2.16　HiRDBファイルシステム領域を削除する

「4.2.6　定義ファイル，環境構築用バッチファイルを出力する」時に，HiRDBファイルシステム領域を削除するためのHiRDBファイルシステム領域変更用バッチファイルが出力されている場合，以下の処理を実行してください。

以下のバッチファイルが出力されているすべてのマシン上でバッチファイルを実行してください。

  • del_hfs_command.bat（Windows以外の場合，拡張子はsh）

このバッチファイルを実行することにより，既存HiRDBのHiRDBファイルシステム領域が削除されます。

注意
このバッチファイルの実行は，既存HiRDBの環境に変更を加えるため，必ず，バッチファイル実行前に「付録C　環境構築用バッチファイル」を参照し，バッチファイルの内容，および実行時の注意事項を確認の上，バッチファイルを実行してください。


構築中にエラーが発生した場合の対処方法

4.2.17　構築中にエラーが発生した場合の対処方法

既存HiRDBの構築を取りこんで，構成変更する作業中にエラー，または警告が発生した場合は，HiRDB Configuration Assistantのマニュアル，及びHiRDBのマニュアルを参照して対処してください。

定義ファイル，環境構築用バッチファイルの修正が必要な場合は「4.2.2　HiRDBの構成を変更する」から作業を再実行してください。再実行前には，以下の作業を実施して，既存HiRDBの環境を，構成変更作業前に戻してください。

  • 既存HiRDBの定義ファイルを，HiRDB Configuration Assistantで作成した定義ファイルで上書きしている場合，バックアップを使用して，定義ファイルを構成変更作業前に戻してください。
  • 既存HiRDBに環境構築用バッチファイルを転送している場合，削除してください。
  • 以下のバッチファイルを実行した場合は，バックアップを使用して，HiRDBファイルシステム領域を構成変更作業前に戻してください。
    • HiRDBファイルシステム領域変更バッチファイル（change_hfs_command.bat，Windows以外の場合，拡張子はsh）
    • HiRDBファイル変更バッチファイル（change_systemfile_command.bat，Windows以外の場合，拡張子はsh）
    • RDエリア変更バッチファイル（change_rdarea_command.bat，Windows以外の場合，拡張子はsh）


既存HiRDBの構成を参考に，新しくHiRDBを構築する

4.3　既存HiRDBの構成を参考に，新しくHiRDBを構築する

ここでは，HiRDB Configuration Assistantを使用して，構築済みのHiRDBの構成を参考に，新しくHiRDBの環境を構築するための手順を示します。手順の流れと，その詳細を説明する項番の対応を以下に示します。

構築済みのHiRDBの構成を参考に，新しくHiRDBの環境を構築するためには，以下の項目が完了している必要があります。

  • 構築するHiRDBの構成の設計が完了していること。
  • HiRDBを構築するマシンに，HiRDBがインストールされていること。
  • HiRDBを構築するマシンのOSのパラメタ設定が済んでいること。
  • 構成を参考にするHiRDBは，定義にエラーがなく，動作実績のあるHiRDBであること。

注意
構成を参考にするHiRDBは，定義にエラーがなく，動作実績のあるHiRDBであることを必ず確認の上，HiRDB Configuration Assistantに取り込んでください。そうでない場合，正しく定義ファイル，および環境構築用バッチファイルを出力できず，新しいHiRDBの環境構築が失敗する可能性があります。

図4-10　既存HiRDBの構成を参考にして，新しくHiRDBを構築する手順

なお，上記の構築作業中にエラーが発生した場合は，「4.3.16　構築中にエラーが発生した場合の対処法」にしたがい，作業を再実行してください。

＜この節の構成＞
4.3.1　構築済みのHiRDB環境から，HiRDB構成情報を取り込む（新規状態取り込み）
4.3.2　新しいHiRDBの環境に合わせて，HiRDBの構成を変更する
4.3.3　HiRDB構成情報ファイルを保存する
4.3.4　システム定義のチェックを行う
4.3.5　メモリ・ディスクサイズのチェックを行う
4.3.6　定義ファイル，環境構築用バッチファイルを出力する
4.3.7　定義ファイル，環境構築用バッチファイルの内容を確認する
4.3.8　定義ファイル，環境構築用バッチファイルをHiRDBを構築するマシンに配置する
4.3.9　定義ファイルの構文チェックを行う
4.3.10　HiRDBファイルシステム領域を作成する
4.3.11　システムファイルを作成する
4.3.12　システムファイルの定義を含む定義ファイルのチェックを行う
4.3.13　HiRDBを開始する
4.3.14　データベースを初期化する
4.3.15　レジストリ用RDエリア，およびデータディクショナリ用RDエリア（再編成時期予測用）を追加する
4.3.16　構築中にエラーが発生した場合の対処方法


構築済みのHiRDB環境から，HiRDB構成情報を取り込む（新規状態取り込み）

4.3.1　構築済みのHiRDB環境から，HiRDB構成情報を取り込む（新規状態取り込み）

まずはじめに，構成を参考にする構築済みのHiRDB環境から，HiRDB構成情報を入力ファイルを介してHiRDB Configuration Assistantに取り込むまでの手順を以下で説明します。

参考
「4.3.1(1)　入力ファイルを格納するためのフォルダ作成」，および「4.3.1(2)　入力ファイル取得，格納」については，HiRDB Configuration Assistantが提供する，HiRDB構成情報取り込みツールを使用して行うことができます。HiRDB構成情報取り込みツールの使用方法については，以下に格納されている「HiRDB構成情報取り込みツール取扱説明書」をご参照ください。
(インストールフォルダ)\tool\HiRDB_Import_readme.pdf
HiRDB構成情報取り込みツールで使用するコマンドの格納場所については，「2.1.1　フォルダ構成」をご参照ください。

参考
構築済みのHiRDB環境として，HiRDB Configuration Assistantが提供するサンプルファイルを使用することもできます。サンプルファイルを使用する場合，「4.3.2　新しいHiRDBの環境に合わせて，HiRDBの構成を変更する」から作業を行ってください。サンプルファイルの詳細については，「付録H　サンプルファイル」を参照してください。

制限事項
HiRDBが複製ディスク機能を用いた系切り替え構成の場合，以下の制限事項があります。
  • プライマリパスにpd_duplicated_fs_suffixオペランドに指定しているサフィックスを含んでいないこと。

＜この項の構成＞
(1)　入力ファイルを格納するためのフォルダ作成
(2)　入力ファイル取得，格納
(3)　HiRDB Configuration Assistantへの取り込み

(1)　入力ファイルを格納するためのフォルダ作成

HiRDB Configuration Assistantがインストールされたマシンから参照可能なドライブ上に，構築済みのHiRDB環境の構成情報を含む入力ファイルを格納するためのフォルダを作成します。

フォルダの作成は，「4.2.1(1)　入力ファイルを格納するためのフォルダ作成」にしたがい行ってください。

(2)　入力ファイル取得，格納

「4.3.1(1)　入力ファイルを格納するためのフォルダ作成」で作成したフォルダに，以下に示す入力ファイルを構築済みのHiRDB環境から転送し，格納します。

入力ファイルの転送，格納は，「4.2.1(2)　入力ファイル取得，格納」にしたがい行ってください。

(3)　HiRDB Configuration Assistantへの取り込み

「4.3.1(2)　入力ファイル取得，格納」で取得，格納した入力ファイルをHiRDB Configuration Assistantに取り込みます。

  1. HiRDB Configuration Assistantを起動します。
  2. ［ツール(T)］－［定義取り込み］－［新規状態取り込み］を選択します。
    注意
    既存HiRDBの構成を参考に，新しくHiRDBを構築するためには［新規状態取り込み］を選択し，構成要素をすべて新規状態で取り込む必要があります。誤って［確定状態取り込み］を選択しないよう注意してください。

  3. ［フォルダの参照］ダイアログが表示されますので，「4.3.1(1)　入力ファイルを格納するためのフォルダ作成」で作成した入力ファイル格納用フォルダを選択し，［OK］ボタンをクリックします。
  4. ［HiRDB構成初期情報ダイアログ］が表示されますので，構築対象のHiRDBに合わせて値を入力し，［OK］ボタンをクリックします。
    HiRDB Configuration Assistantに構築済みのHiRDB環境が取り込まれます。
    • 取り込み対象のHiRDBからHiRDBバージョン，HiRDB種別，HiRDBアドレッシングモード，OS種別を変更した場合，取り込み対象のHiRDBで定義されていたオペランドが無効となることがあります。無効となったオペランドは，HiRDB Configuration Assistantで参照・編集することはできません。また，定義出力時には，取り込んだままのオペランドが定義ファイルに出力されますので，必要に応じて定義ファイルを編集してください。
    • 取り込み対象のHiRDBからHiRDBバージョンを下位バージョンに変更した場合，HiRDB Configuration Assistantで正しい定義ファイル，環境構築用バッチファイルが出力できない可能性がありますので，HiRDBのバージョンダウンとなる変更をしないでください。
    • 取り込み対象のHiRDBからHiRDB種別を変更した場合，HiRDB Configuration Assistantで正しい定義ファイル，環境構築用バッチファイルが出力できない可能性がありますので，HiRDB種別を変更しないでください。
    • 取り込み対象のHiRDBからHiRDBバージョン，HiRDB種別，HiRDBアドレッシングモード，OS種別を変更する場合，実際に存在しないHiRDBの組み合わせとなっていないことを確認してください。
    • 取り込み対象のHiRDBからOS種別を変更する場合，HiRDB構成初期情報ダイアログに指定されたHiRDB運用ディレクトリのパスは変更後のOS種別に応じた文字でチェックします。そのため，変更後のOSに合わせてHiRDB運用ディレクトリのパスを変更するようにしてください。
    • OS種別をWindows以外からWindowsに変更する場合，取り込み対象のHiRDBのHiRDBファイルシステム領域の名称が大文字，小文字の区別なく重複（例：DB1とdb1）していないことを事前に確認してください。WindowsではそれらのHiRDBファイルシステム領域の名称は同一名称として扱われてしまうため，新規状態取り込み実行前に入力ファイルを編集して重複が無くなるよう名称を変更してください。
    ［HiRDB構成初期情報ダイアログ］の詳細は，「3.3.4　HiRDB構成初期情報ダイアログ」を参照してください。

HiRDB Configuration Assistantへの取り込み時に，「パラメータが間違っています。」というエラーメッセージのダイアログが出力され，取り込みが失敗することがあります。失敗の要因として，以下の3点が考えられますので，これらを見直して対応し，再度取り込みを行ってください。

表4-26　HiRDB Configuration Assistantへの取り込みが失敗する要因

要因 | 対処法
入力ファイルの定義に文法誤りがある。 | 構築済みのHiRDB環境上でpdconfchkを実行し，入力ファイルの文法誤りを取り除いてください。
構築済みのHiRDB環境で使用する文字コードがShift-JIS以外であるにもかかわらず，入力ファイルの文字コードをShift-JISに変換していない。 | 入力ファイルの文字コードをShift-JISに変換してください。
pdflsコマンドの実行結果に空行が含まれている。 | 空行を取り除いてください。


新しいHiRDBの環境に合わせて，HiRDBの構成を変更する

4.3.2　新しいHiRDBの環境に合わせて，HiRDBの構成を変更する

「4.3.1　構築済みのHiRDB環境から，HiRDB構成情報を取り込む（新規定義取り込み）」に示した手順で取り込んだHiRDB構成情報を，新しいHiRDBの構成に合わせてHiRDB Configuration Assistantで変更してください。

HiRDB Configuration Assistant上での構成変更の操作方法は，「3.4　基本操作」を参照してください。

また，パス名やHiRDBファイルシステム領域名など，HiRDB構成情報中のパスを一括して置換したい場合は，HiRDB Configuration Assisitantの機能を使用して行うことができます。使用方法は，「3.4.6(6)　HiRDB構成情報の置換」を参照してください。


HiRDB構成情報ファイルを保存する

4.3.3　HiRDB構成情報ファイルを保存する

HiRDBの構成を変更した後，［ファイル(F)］－［名前を付けて保存(A)］を選択し，構成変更したHiRDBの構成情報を，HiRDB構成情報ファイルに保存してください。

HiRDB構成情報ファイル保存時の注意事項を以下に示します。

  • 同一名称のHiRDB構成情報ファイルが既に存在する場合，そのHiRDB構成情報を新しいHiRDB構成情報ファイルで上書きします。
  • HiRDB構成情報ファイルを出力するフォルダには，HiRDB Configuration AssistantがHiRDB構成情報ファイルを出力できるように，フォルダの読み込み権限，書き込み権限を与えてください。
  • 同一名称のHiRDB構成情報ファイルが既に存在する場合，HiRDB Configuration Assistantが上書きできるように，既存のHiRDB構成情報ファイルの読み込み権限，書き込み権限を与えてください。
  • 同一名称のHiRDB構成情報ファイルが既に存在する場合，HiRDB Configuration Assistantが上書きできるように，他のプログラムで既存のHiRDB構成情報ファイルを開かないようにしてください。


システム定義のチェックを行う

4.3.4　システム定義のチェックを行う

HiRDB Configuration Assistantで定義したHiRDB構成情報から出力されるシステム定義のチェックを行います。

システム定義のチェックは，HiRDB Configuration Assistantが動作するマシンから，HiRDBを構築するマシンに定義ファイルを送信し，pdconfchkコマンドを実行することにより行います。

システム定義のチェックを行うための前提条件，および手順は「4.1.3　システム定義のチェック」を参照してください。

前提条件を満たすことができない場合はHiRDB Configuration Assistantのシステム定義のチェック機能を使用することはできませんので，定義ファイルを，HiRDBを構築するマシンに転送した後でチェックを実行してください。詳細は「4.3.9　定義ファイルの構文チェックを行う」を参照してください。


メモリ・ディスクサイズのチェックを行う

4.3.5　メモリ・ディスクサイズのチェックを行う

HiRDB Configuration Assistantで定義したHiRDB構成情報をもとに，HiRDBが使用するメモリ・ディスクサイズのチェックを行います。

メモリ・ディスクサイズのチェックは，HiRDB Cofiguration Assistantの容量計算機能を使用します。容量計算機能により，以下の容量を計算することができます。

  • HiRDBの起動に必要なメモリサイズ
  • HiRDBが使用するディスクサイズ

メモリ・ディスクサイズのチェックの詳細，前提条件，および手順は「4.1.4　メモリ・ディスクサイズのチェックを行う」を参照してください。

前提条件を満たすことができない場合はHiRDB Configuration Assistantの容量計算機能を使用することはできません。HiRDBのマニュアルにしたがってメモリ・ディスクサイズの計算を行い，新しくHiRDBを構築するマシンでメモリ・ディスクの不足が発生しないことを確認してください。


定義ファイル，環境構築用バッチファイルを出力する

4.3.6　定義ファイル，環境構築用バッチファイルを出力する

HiRDB Configuration Assistantで既存HiRDBの構成を参考に新しく定義したHiRDBを構築するための，新規構築用の定義ファイル，および環境構築用バッチファイルを出力します。

新規構築用の定義ファイル，および環境構築用バッチファイルの出力は，「4.1.5　定義ファイル，環境構築用バッチファイルを出力する」にしたがい行ってください。


定義ファイル，環境構築用バッチファイルの内容を確認する

4.3.7　定義ファイル，環境構築用バッチファイルの内容を確認する

「4.3.6　定義ファイル，環境構築用バッチファイルを出力する」で出力した定義ファイル，環境構築用バッチファイルの内容を確認して，新たに構築するHiRDBの設計の意図通りに定義ファイル，環境構築用バッチファイルが出力されているか，確認してください。

定義ファイルの詳細については，「付録B　定義ファイル」を参照してください。

環境構築用バッチファイルの詳細については，「付録C　環境構築用バッチファイル」を参照してください。

構築した内容に対応してHiRDB Configuration Assistantが出力する定義ファイル，および環境構築用バッチファイルについては，「付録D　構成要素と，出力する定義ファイル，および環境構築用バッチファイルの対応関係」を参照してください。

「4.3.1(3)　HiRDB Configuration Assistantへの取り込み」時に，取り込み対象のHiRDBからHiRDBバージョン，HiRDB種別，HiRDBアドレッシングモード，OS種別を変更した場合，取り込み対象のHiRDBで定義されていたオペランドが変更後のHiRDBで未サポートの無効なオペランドとなることがあります。無効なオペランドはHiRDB Configuration Assistantで参照・更新することはできません。また，定義出力時には無効なオペランドが定義ファイルに出力されますので，定義ファイルから削除してください。


定義ファイル，環境構築用バッチファイルをHiRDBを構築するマシンに配置する

4.3.8　定義ファイル，環境構築用バッチファイルをHiRDBを構築するマシンに配置する

「4.3.6　定義ファイル，環境構築用バッチファイルを出力する」で出力した新規構築用の定義ファイルと環境構築用バッチファイルを，HiRDBを構築するマシンに配置します。

新規構築用の定義ファイルと環境構築用バッチファイルの配置は，「4.1.7　定義ファイル，環境構築用バッチファイルをHiRDBを構築するマシンに配置する」にしたがい行ってください。


定義ファイルの構文チェックを行う

4.3.9　定義ファイルの構文チェックを行う

「4.3.4　システム定義のチェックを行う」を実行していない場合，HiRDBコマンドのpdconfchkを使用して，定義ファイルの構文チェックを行います。定義ファイルの構文チェックは，以下のコマンドを実行します。

pdconfchk -n

定義ファイルの構文チェックは，以下のマシン上で実行してください。

  • HiRDBパラレルサーバの場合，マネージャサーバが属するマシン
  • HiRDBシングルサーバの場合，シングルサーバが属するマシン


HiRDBファイルシステム領域を作成する

4.3.10　HiRDBファイルシステム領域を作成する

HiRDBを起動していない状態で，以下のバッチファイルが出力されているすべてのマシン上でバッチファイルを実行してください。

  • add_hfs_command.bat（Windows以外の場合，拡張子はsh）

このバッチファイルを実行することにより，HiRDBファイルシステム領域が新規に作成されます。

注意
必ず，バッチファイル実行前に「付録C　環境構築用バッチファイル」を参照し，バッチファイルの内容，および実行時の注意事項を確認の上，バッチファイルを実行してください。


システムファイルを作成する

4.3.11　システムファイルを作成する

HiRDBを起動していない状態で，以下のバッチファイルが出力されているすべてのマシン上でバッチファイルを実行してください。

  • init_systemfile_command.bat（Windows以外の場合，拡張子はsh）

このバッチファイルを実行することにより，HiRDBシステムファイルを新規に作成します。

注意
必ず，バッチファイル実行前に「付録C　環境構築用バッチファイル」を参照し，バッチファイルの内容，および実行時の注意事項を確認の上，バッチファイルを実行してください。


システムファイルの定義を含む定義ファイルのチェックを行う

4.3.12　システムファイルの定義を含む定義ファイルのチェックを行う

HiRDBコマンドのpdconfchkを使用して，システムファイルの定義を含む定義ファイルのチェックを行います。定義ファイルのチェックは，以下のコマンドを実行します。

pdconfchk

定義ファイルのチェックは，以下のマシン上で実行してください。

  • HiRDBパラレルサーバの場合，マネージャサーバが属するマシン
  • HiRDBシングルサーバの場合，シングルサーバが属するマシン


HiRDBを開始する

4.3.13　HiRDBを開始する

HiRDBを開始させてください。Windows版の場合，HiRDB開始の前提として，HiRDBのサービスの開始が必要です。


データベースを初期化する

4.3.14　データベースを初期化する

HiRDBの開始中，データベース初期設定ユティリティの開始待ち（KFPS05201-Qメッセージを出力して停止した状態）で，以下のバッチファイルが出力されているすべてのマシン上でバッチファイルを実行してください。

  • init_rdarea_dic_command.bat（Windows以外の場合，拡張子はsh）

このバッチファイルを実行することにより，HiRDBのデータベースが初期化されます。

注意
必ず，バッチファイル実行前に「付録C　環境構築用バッチファイル」を参照し，バッチファイルの内容，および実行時の注意事項を確認の上，バッチファイルを実行してください。


レジストリ用RDエリア，およびデータディクショナリ用RDエリア（再編成時期予測用）を追加する

4.3.15　レジストリ用RDエリア，およびデータディクショナリ用RDエリア（再編成時期予測用）を追加する

「4.3.6　定義ファイル，環境構築用バッチファイルを出力する」時に，RDエリア初期化用バッチファイルが出力されている場合，以下の処理を実行してください。

データベースの初期化が正常に終了（KFPS05210-Iメッセージを出力）した後，以下のバッチファイルが出力されているすべてのマシン上でバッチファイルを実行してください。

  • init_rdarea_command.bat（Windows以外の場合，拡張子はsh）

このバッチファイルを実行することにより，HiRDBのデータベースにレジストリ用RDエリア，およびデータディクショナリ用RDエリア（再編成時期予測用）が追加されます。

注意
必ず，バッチファイル実行前に「付録C　環境構築用バッチファイル」を参照し，バッチファイルの内容，および実行時の注意事項を確認の上，バッチファイルを実行してください。


構築中にエラーが発生した場合の対処方法

4.3.16　構築中にエラーが発生した場合の対処方法

既存HiRDBの構成を参考に新しくHiRDBを構築する作業中にエラー，または警告が発生した場合は，HiRDB Configuration Assistantのマニュアル，及びHiRDBのマニュアルを参照して対処してください。

定義ファイル，環境構築用バッチファイルの修正が必要な場合は「4.3.2　新しいHiRDBの環境に合わせて，HiRDBの構成を変更する」から作業を再実行してください。再実行する前に，以下の作業を実施してHiRDB構築前に環境を戻してください。

  • HiRDBを構築するマシンに新規構築用の定義ファイル，および環境構築用バッチファイルを配置している場合，配置したファイルを削除してください。
  • HiRDBファイルシステム領域初期化バッチファイル（init_hfs_command.bat，Windows以外の場合，拡張子はsh）を実行した場合は，作成したHiRDBファイルシステム領域を削除してください。


HiRDBの構成に関するドキュメントを出力する

4.4　HiRDBの構成に関するドキュメントを出力する

ここでは，HiRDB Configuration Assistantを使用して，HiRDBの構成に関するドキュメントを出力する手順を示します。

＜この節の構成＞
4.4.1　出力できるドキュメントと形式
4.4.2　設計ドキュメントを出力する
4.4.3　設計ドキュメントの利用例


出力できるドキュメントと形式

4.4.1　出力できるドキュメントと形式

HiRDB Configuration Assistantでは，以下に示すHiRDBの構成に関するドキュメントを出力することができます。

表4-27　HiRDB Configuration Assistantが出力できるドキュメント

ドキュメント種別 |  | 出力形式
定数一覧 | システム共通定義 | CSV形式
 | ユニット制御情報定義
 | サーバ共通定義
 | シングルサーバ定義
 | フロントエンドサーバ定義
 | ディクショナリサーバ定義
 | バックエンドサーバ定義
RDエリア一覧
HiRDBファイルシステム領域一覧
ユニット・サーバ一覧
グローバルバッファ一覧
構成図 |  | Windows拡張メタファイル(emf)
  • CSV形式ファイルは，ヘッダ部とデータ部からなります。

    図4-11　CSV形式フォーマット

  • CSV形式ファイル中の値は，文字データ，数値データに関わらず，必ず"で囲みます。
  • CSV形式ファイルの文字コードはShift-JISとなります。
  • CSV形式ファイルの改行コードは，"\r\n(0x0D0A)"となります。
  • CSV形式ファイル中の値に"（引用符）が含まれている場合，""（引用符2文字）に変換して出力します。

各ドキュメントの詳細について，以下に説明します。

＜この項の構成＞
(1)　定数一覧
(2)　RDエリア一覧
(3)　HiRDBファイルシステム領域一覧
(4)　ユニット・サーバ一覧
(5)　グローバルバッファ一覧
(6)　構成図

(1)　定数一覧

HiRDBに定義された定数の一覧を，CSV形式で出力することができます。

出力するファイルの名称とその個数は，以下のようになります。

表4-28　定数一覧として出力するファイル

ドキュメント種別 |  | 出力ファイル名称 | 出力ファイル個数
定数一覧 | システム共通定義 | pdsys.csv | 1個
 | ユニット制御情報定義 | pdutsys_(ユニット名).csv | HiRDBに定義されたユニットにつき1個
 | サーバ共通定義 | pdsvrc_(ユニット名).csv
 | シングルサーバ定義 | (SDSサーバ名).csv | HiRDBに定義されたサーバにつき1個
 | フロントエンドサーバ定義 | (FESサーバ名).csv
 | ディクショナリサーバ定義 | (DICサーバ名).csv
 | バックエンドサーバ定義 | (BESサーバ名).csv

各ファイルごとの，ヘッダ部，データ部の出力内容を以下に示します。

表4-29　定数一覧の出力内容

種別 行数 出力内容
ヘッダ部 1行
"オペランド名","オペランド指定値","コメント","オペランドチェック結果"
データ部 定義ファイル内の定数1個につき1行
"値1","値2","値3","値4"
 値1 オペランド名
値2 オペランド指定値
1つの定数に対してオペランド指定値が複数ある場合，値2の中に，カンマ区切りでまとめて出力します。
値3 コメント
指定がない定数の場合，""
値4 オペランドのチェック結果
出力内容については，「表3-23　オペランド詳細ダイアログの内容」の「オペランド状態」を参照してください。

定数一覧の出力例を以下に示します。

"オペランド名","オペランド指定値","コメント","オペランドチェック結果"
"pd_system_id","HRD1","顧客管理DB","○"
"pd_master_file_name","c:\hirdb_p\custam\db\sys01\mast1","","○"
"pd_optimize_level","""FORCE_NEST_JOIN"",""SELECT_APSL"",""FLTS_INC_DATA_BES""","ネストループジョイン強制を適用","○"
"pdunit","-x host1 -u unt1 -d ""d:\hirdb_p\unt1\pddir"" -c host2","unt1定義","○"
"SHMMAX","1024","見積もりの1.3倍","○"

(2)　RDエリア一覧

HiRDBに定義されたRDエリア一覧をCSV形式で出力することができます。

出力するファイルの名称とその個数は，以下のようになります。

表4-30　RDエリア一覧として出力するファイル

ドキュメント種別 | 出力ファイル名称 | 出力ファイル個数
RDエリア一覧 | RDAREA_LIST.csv | 1個

ヘッダ部，データ部の出力内容を以下に示します。

表4-31　RDエリア一覧の出力内容

種別 | 行数 | 出力内容
ヘッダ部 1行
"RDエリア名","RDエリア種別","サーバ名","グローバルバッファ名",
"ページサイズ","セグメントサイズ","HiRDBファイル",
"ファイル内セグメントサイズ","RDエリアのオープン契機",
"増分セグメント数","最大リスト登録数","一時表用RDエリアの属性"
データ部 RDエリア中のHiRDBファイル1個に対して1行 "値1","値2","値3",
"値4","値5","値6",
"値7","値8","値9",
"値10","値11","値12" 		値1 RDエリア名
値2 RDエリア種別
  • masterdirectory（マスタディレクトリ用RDエリア）
  • datadirectory（データディレクトリ用RDエリア）
  • datadictionary（データディクショナリ用RDエリア）
  • datadictionary of routines（ストアドプロシジャ，ストアドファンクション，及びトリガに関するディクショナリ表）
  • user（ユーザ用RDエリア）
  • lob（ユーザLOB用RDエリア）
  • lob used by HiRDB（データディクショナリLOB用RDエリア）
  • list（リスト用RDエリア）
  • datadictionary of dbmanagement（再編成時期予測用RDエリア）
  • registory（レジストリ用RDエリア）
  • LOB used by HiRDB(SQL_REGISTRY)（レジストリLOB用RDエリア）
値3 | サーバ名
値4 グローバルバッファ名
指定がないRDエリアの場合，"other"
値5 | ページサイズ
値6 | セグメントサイズ
値7 | RDエリアが属するHiRDBファイル名
値8 | ファイル内セグメントサイズ
値9 RDエリアのオープン契機
指定がないRDエリアの場合，"INITIAL"
値10 増分セグメント数
指定がないRDエリアの場合，"nouse"
値11 最大リスト登録数
指定がないリスト用RDエリアの場合，"500"
値12 一時表用RDエリアの属性
  • shared（一時表用RDエリアとして使用し，SQLセッション間共有属性とする）
  • occupied（一時表用RDエリアとして使用し，特定SQLセッション占有属性とする）
  • nouse（一時表用RDエリアとして使用しない）

RDエリア一覧の出力例を以下に示します。

"RDエリア名","RDエリア種別","サーバ名","グローバルバッファ名","ページサイズ","セグメントサイズ","HiRDBファイル","ファイル内セグメントサイズ","RDエリアのオープン契機","増分セグメント数","最大リスト登録数","一時表用RDエリアの属性"
"RDDATA10","user","BES1","other","8192","10","/HiRDB_P/CUSTAM/DB/DB01/RDDATA10","100","INITIAL","40","0","nouse"
"RDDATA11","user","BES1","gbuf1","4096","10","/HiRDB_P/CUSTAM/DB/DB01/RDDATA11_1","100","INITIAL","40","0","shared"
"RDDATA11","user","BES1","gbuf1","4096","10","/HiRDB_P/CUSTAM/DB/DB01/RDDATA11_2","100","INITIAL","40","0","occupied"
"RDDATA11","user","BES1","gbuf1","4096","10","/HiRDB_P/CUSTAM/DB/DB01/RDDATA11_3","100","INITIAL","40","0","nouse"

(3)　HiRDBファイルシステム領域一覧

HiRDBに定義されたファイルシステム領域一覧をCSV形式で出力することができます。

出力するファイルの名称とその個数は，以下のようになります。

表4-32　HiRDBファイルシステム領域一覧として出力するファイル

ドキュメント種別 | 出力ファイル名称 | 出力ファイル個数
HiRDBファイルシステム領域一覧 | HiRDB_File_System_LIST.csv | 1個

ヘッダ部，データ部の出力内容を以下に示します。

表4-33　HiRDBファイルシステム領域一覧の出力内容

種別 | 行数 | 出力内容
ヘッダ部 1行
"HiRDBファイルシステム領域名","HiRDBファイル名",
"HiRDBファイル種別","マシン名","使用目的","最大ファイル数",
"最大増分回数","自動拡張指定の有無"
データ部 HiRDBに定義されたHiRDBファイルシステム領域1個に対して1行
"値1","値2","値3",
"値4","値5","値6",
"値7","値8"
 値1 HiRDBファイルシステム領域名
値2 | HiRDBファイル名
値3 HiRDBファイル種別
  • RDAREA（RDエリア）
  • SYSTEMLOG（システムログファイル）
  • SPD（シンクポイントダンプファイル）
  • UNIT STATUS（ユニット用ステータスファイル）
  • SERVER STATUS（サーバ用ステータスファイル）
値4 | HiRDBファイルシステム領域が属するマシン名
値5 使用目的
  • DB（RDエリア用）
  • SDB（HiRDBファイルシステム用）
  • SYS（共用RDエリア用）
  • WORK（リスト用RDエリア，または作業表用）
  • UTL（ユティリティ用）
  • SVR（上記にあてはまらない，それ以外の用途）
値6 HiRDBファイルシステム領域の最大ファイル数
指定のない場合，""
値7 HiRDBファイルシステム領域の最大増分回数
指定のない場合，""
値8 自動拡張指定の有無
  • "1"（自動拡張指定有り）
  • "0"（自動拡張指定無し）

HiRDBファイルシステム領域一覧の出力例を以下に示します。

"HiRDBファイルシステム領域名","HiRDBファイル名","マシン名","使用目的","最大ファイル数","最大増分回数","自動拡張指定の有無"
"/HiRDB_P/CUSTOM/DB/DB01","rddata10","host1","DB","50","","0"
"/HiRDB_P/CUSTOM/DB/DB01","rddata20_1","host1","DB","50","","0"
"/HiRDB_P/CUSTOM/DB/DB01","rddata20_2","host1","DB","50","","0"
"/HiRDB_P/CUSTOM/DB/DB01","rddata20_3","host1","DB","50","","0"
"/HiRDB_P/CUSTOM/SYS/LOG01","bes1log01","host2","DB","50","","0"
"/HiRDB_P/CUSTOM/SYS/LOG01","bes1log02","host2","DB","50","","0"
"/HiRDB_P/CUSTOM/SYS/LOG01","bes1log02","host2","DB","50","","0"

(4)　ユニット・サーバ一覧

HiRDBに定義されたユニット・サーバ一覧をCSV形式で出力することができます。

出力するファイルの名称とその個数は，以下のようになります。

表4-34　ユニット・サーバ一覧として出力するファイル

ドキュメント種別 | 出力ファイル名称 | 出力ファイル個数
ユニット・サーバ一覧 | HiRDB_SERVER_LIST.csv | 1個

ヘッダ部，データ部の出力内容を以下に示します。

表4-35　ユニット・サーバ一覧の出力内容

種別 | 行数 | 出力内容
ヘッダ部 1行
"マシン名","ユニット名","サーバ種別","サーバ名"
データ部 ユニットに配置されたサーバ1個に対して1行※1
"値1","値2","値3","値4"
 値1 サーバが属するマシン名
値2 | サーバが属するユニット名※2
値3 サーバ種別※3
  • MGR（マネージャサーバ）
  • DIC（ディクショナリサーバ）
  • FES（フロントエンドサーバ，または回復不要FES）
  • BES（バックエンドサーバ，またはフロータブルサーバ）
  • SDS（シングルサーバ）
値4 | サーバ名※3

※1 ユニットが1個も割り当てられていないマシン，およびサーバが1個も割り当てられていないユニットに対しても，それぞれ1行ずつ出力されます。

※2 ユニットが1個も割り当てられていないマシンの場合，""（空の値）を出力します。

※3 ユニットが1個も割り当てられていないマシン，およびサーバが1個も割り当てられていないユニットの場合，""（空の値）を出力します。

ユニット・サーバ一覧の出力例を以下に示します。マシン名が"host3"の行はサーバが1個も割り当てられていないユニット，ユニット名が"host4"のユニットが1個も割り当てられていないマシンの出力例となります。

"マシン名","ユニット名","サーバ種別","サーバ名"
"host1","unt1","MGR","MGR"
"host1","unt1","DIC","DIC1"
"host1","unt1","FES","FES1"
"host1","unt1","BES","BES1"
"host2","unt2","BES","BES2"
"host2","unt2","BES","BES3"
"host3","unt3","",""
"host4","","",""

(5)　グローバルバッファ一覧

HiRDBに定義されたグローバルバッファの一覧をCSV形式で出力することができます。

出力するファイルの名称とその個数は，以下のようになります。

表4-36　グローバルバッファ一覧として出力するファイル

ドキュメント種別 | 出力ファイル名称 | 出力ファイル個数
グローバルバッファ一覧 | globalbuffer_LIST.csv | 1個

ヘッダ部，データ部の出力内容を以下に示します。

表4-37　グローバルバッファ一覧の出力内容

種別 | 行数 | 出力内容
ヘッダ部 1行
"グローバルバッファ名","サーバ名","使用目的","バッファサイズ" ,
 "バッファ面数","デファードライトトリガ時の更新ページ出力比率",
"デファードライトトリガ契機の更新バッファ面数",
"RDエリア名／インデクス名", "同時実行最大プリフェッチ数" ,
"一括入力最大ページ数"
データ部 「表4-38　データ部を出力するグローバルバッファの種別と，出力する値」参照のこと "値1","値2","値3",
"値4","値5","値6",
"値7","値8","値9",
"値10" 		値1 グローバルバッファ名
値2 | サーバ名
値3 使用目的
  • rdarea（RDエリア）
  • blob（BLOB用RDエリア）
  • index（インデクス）
  • other（その他用）
値4 | バッファサイズ
値5 バッファ面数
指定がない場合，""
値6 デファードライトトリガ時の更新ページ出力比率
指定がない場合，""
値7 デファードライトトリガ契機の更新バッファ面数
指定がない場合，""
値8 | RDエリア名，もしくはインデクス名
値9 同時実行最大プリフェッチ数
指定が無い場合，"0"
値10 一括入力最大ページ数
指定が無い場合，"32"（デフォルト値）

データ部の出力対象となるグローバルバッファの種別と，出力する値を，以下に示します。この表に該当する種別につき，1行のデータ部が出力されます。

表4-38　データ部を出力するグローバルバッファの種別と，出力する値

データ部を出力するグローバルバッファの種別 |  |  | 出力する値
 |  |  | 値1 | 値2 | 値3 | 値4 | 値5 | 値6 | 値7 | 値8 | 値9 | 値10
RDAREA BLOB | RDエリアの割り当てあり |  | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
 | RDエリアの割り当てなし※1 |  | ○ | × | ○ | ○ | ○ | ○ | ○ | × | ○ | ○
INDEX | RDエリアの割り当てあり |  | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
 | RDエリアの割り当てなし※1 |  | ○ | × | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
OTHER | 1個目※3 | RDエリアの割り当て※2あり | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○ | ○
 |  | RDエリアの割り当て※2なし | ○ | × | ○ | ○ | ○ | ○ | ○ | × | ○ | ○
 | 2個目以降※1※3 |  | ○ | × | ○ | ○ | ○ | ○ | ○ | × | ○ | ○

○は，値を出力することを示します。

×は，値を出力しないことを示します。

※1は，定義出力の対象とならない，不正なグローバルバッファ要素も含みます。

※2は，RDAREA型のグローバルバッファが割り当てられているかどうかを示します。

※3に示す「1個目」は，複数のその他用グローバルバッファが定義されているときに有効となる，先頭のその他用グローバルバッファを示します。「2個目以降」は，それ以外の有効とならないその他用グローバルバッファを示します。

グローバルバッファ一覧の出力例を以下に示します。最後の行（"gbuf03"）は，RDエリアが割り当てられていないグローバルバッファの出力例となります。

"グローバルバッファ名","サーバ名","使用目的","バッファサイズ","バッファ面数","デファードライトトリガ時の更新ページ出力比率","デファードライトトリガ契機の更新バッファ面数","RDエリア名／インデクス名","同時実行最大プリフェッチ数","一括入力最大ページ数"
"gbuf01","bes1","rdarea","4096","10","20","100","RDDATA01","10","10"
"gbuf01","bes1","rdarea","8192","10","20","100","RDDATA02","10","10"
"gbuf02","bes1","index","4096","10","20","100","INDEX01","10","10"
"gbuf03","bes1","index","4096","10","20","100","INDEX02","10","10"
"gbuf01","bes2","rdarea","8192","10","20","100","RDDATA03","10","10"
"gbuf02","bes2","rdarea","4096","10","20","100","RDDATA04","10","10"
"gbuf03","","rdarea","4096","10","20","100","","10","10"

(6)　構成図

HiRDB Configuration Assistantの構成図に示された内容を，Windows拡張メタファイル(emf)形式で出力することができます。

出力するファイルの名称と個数は，以下のようになります。

表4-39　構成図として出力するファイル

ドキュメント種別 出力ファイル名称 出力ファイル個数
構成図 Figure_yyyymmddHHMMSS.emf
  • yyyy:メタファイルを出力した時刻の西暦4桁
  • mm:メタファイルを出力した時刻の月2桁
  • dd:メタファイルを出力した時刻の日2桁
  • HH:メタファイルを出力した時刻の時2桁
  • MM:メタファイルを出力した時刻の分2桁
  • SS:メタファイルを出力した時刻の秒2桁
 1個


設計ドキュメントを出力する

4.4.2　設計ドキュメントを出力する

HiRDB Configuration Assistantを使用して設計ドキュメントを出力する方法を説明します。

＜この項の構成＞
(1)　一覧の出力
(2)　構成図の出力

(1)　一覧の出力

  1. ［ファイル(F)］－［構成情報ファイルを開く(O)］から，一覧を出力したいHiRDB構成情報ファイルを開きます。
  2. ［ファイル(F)］－［CSV出力(W)］から，一覧出力したい項目を選択します。
    • 定数一覧
    • RDエリア一覧
    • HiRDBファイルシステム領域一覧
    • ユニット・サーバ一覧
    • グローバルバッファ一覧
  3. ［フォルダの参照］ダイアログが表示されますので，出力先のフォルダを選択し，［OK］ボタンをクリックします。
    出力先のフォルダに，選択した一覧情報を格納した一覧ファイルが出力され，出力が完了したことを通知するダイアログが表示されます。
    出力先のフォルダに同一名称の一覧ファイルが既に存在していた場合，その一覧ファイルを新しく作成する一覧ファイルで上書きします。
  4. ［OK］ボタンをクリックします。
    一覧の出力が完了します。

一覧出力時の注意事項を以下に示します。

  • 一覧ファイルを出力するフォルダには，HiRDB Configuration Assistantが一覧ファイルを出力できるように，フォルダの読み込み権限，書き込み権限を与えてください。
  • 同一名称の一覧ファイルが既に存在する場合，HiRDB Configuration Assistantが上書きできるように，既存の一覧ファイルの読み込み権限，書き込み権限を与えてください。
  • 同一名称の一覧ファイルが既に存在する場合，HiRDB Configuration Assistantが上書きできるように，他のプログラムで既存の一覧ファイルを開かないようにしてください。

(2)　構成図の出力

  1. ［ファイル(F)］－［構成情報ファイルを開く(O)］から，構成図を出力したいHiRDB構成情報ファイルを開きます。
  2. ［ファイル(F)］－［構成図ファイル出力(M)］を選択します。
  3. ［フォルダの参照］ダイアログが表示されますので，出力先のフォルダを選択し，［OK］ボタンをクリックします。
    出力先のフォルダに，Windows拡張メタファイル形式の構成図ファイルが出力されます。
    出力先のフォルダに同一名称の構成図ファイルが既に存在していた場合，その構成図ファイルを新しく作成する構成図ファイルで上書きします。
  4. ［OK］ボタンをクリックします。
    構成図の出力が完了します。

構成図出力時の注意事項を以下に示します。

  • 構成図ファイルを出力するフォルダには，HiRDB Configuration Assistantが構成図ファイルを出力できるように，フォルダの読み込み権限，書き込み権限を与えてください。
  • 同一名称の構成図ファイルが既に存在する場合，HiRDB Configuration Assistantが上書きできるように，既存の構成図ファイルの読み込み権限，書き込み権限を与えてください。
  • 同一名称の構成図ファイルが既に存在する場合，HiRDB Configuration Assistantが上書きできるように，他のプログラムで既存の構成図ファイルを開かないようにしてください。


設計ドキュメントの利用例

4.4.3　設計ドキュメントの利用例

HiRDB Configuration Assistantで出力した設計ドキュメントを，Microsoft Officeを利用して取り込む例を以下に示します。

＜この項の構成＞
(1)　一覧の利用例
(2)　構成図の利用例

(1)　一覧の利用例

「4.4.2(1)　一覧の出力」で出力したcsv形式のファイルを，Microsoft Office Excel形式のファイルに取り込んで，設計ドキュメント内のデータとして利用する例を以下に示します。ここでは，Microsoft Office Excelを利用します。

  1. 一覧を取り込むExcelのファイルを開きます。
  2. リボンの［データ］タブ－［テキストファイル］を選択します。
  3. ［テキストファイルのインポート］ダイアログが表示されますので，取り込みたい一覧ファイルを選択します。
  4. ［テキスト　ファイル　ウィザード］ダイアログが表示されますので，必要事項を入力して，［完了(F)］ボタンをクリックします。
    • 「元のデータの形式」は，「カンマやタブなどの区切り文字によってフィールドごとに区切られたデータ(D)」を選択します。
    • 「取り込み開始行」は，ユーザが取り込みを開始したい行数を入力します。
    • 文字コードは，「932：日本語（シフトJIS）」を選択します。
    • 「区切り文字」は，「カンマ(C)」のみ選択します。
    • 「連続した区切り文字は1文字として扱う(R)」にチェックを入れます。
    • 「文字列の引用符(Q)」は，「"」（ダブルクォーテーション）を選択します。
    • 値に合わせて「列のデータ形式」を選択します。HiRDB Configuration Assistantが出力する一覧の値には，「-」（ハイフン）が含まれる場合があります。この場合には，「列のデータ形式」として「文字列(T)」を選択しないと，数値として判断されて正しく取り込めない場合がありますので注意してください。
  5. ［データの取り込み］が表示されますので，データを返す先を選択して，［OK］ボタンをクリックしてください。

一覧がExcelに取り込まれます。

※ 手順はMicrosoft Office Excelのバージョンにより異なる場合があります。ご利用のMicrosoft Office Excelのcsv形式のファイル取り込み手順をご確認ください。

(2)　構成図の利用例

「4.4.2(2)　構成図の出力」で出力したWindows拡張メタファイル(emf)を，Microsoft Office Word形式のファイルに取り込んで，設計ドキュメント内の構成図として利用する例を以下に示します。ここでは，Microsoft Office Wordを利用します。

  1. 構成図を取り込むWordのファイルを開きます。
  2. リボンの［挿入］タブ－［画像］を選択します。
  3. ［図の挿入］ダイアログが表示されますので，取り込みたい構成図（Windows拡張メタファイル）を選択します。

構成図がWordに取り込まれます。

※ 手順はMicrosoft Office Wordのバージョンにより異なる場合があります。ご利用のMicrosoft Office WordのWindows拡張メタファイル取り込み手順をご確認ください。


付録

＜この付録の構成＞
付録A　メッセージ
付録B　定義ファイル
付録C　環境構築用バッチファイル
付録D　構成要素と，出力する定義ファイル，および環境構築用バッチファイルの対応関係
付録E　文字コード変換要否判定
付録F　HiRDB構成情報の指定内容の詳細
付録G　環境構築例
付録H　サンプルファイル
付録I　用語解説


メッセージ

付録A　メッセージ

HiRDB Configuration Assistantが出力するエラーメッセージの形式，内容，および対処方法について説明しています。

＜この節の構成＞
付録A.1　メッセージの出力形式
付録A.2　メッセージの記述形式
付録A.3　メッセージ一覧


メッセージの出力形式

付録A.1　メッセージの出力形式

HiRDB Configuration Assistantのメッセージの出力形式は，次のとおりです。

＜この項の構成＞
(1)　メッセージダイアログのメッセージ出力形式
(2)　置換ダイアログのメッセージ出力形式
(3)　操作処理実行結果ファイルの出力形式

(1)　メッセージダイアログのメッセージ出力形式

メッセージダイアログの出力形式を以下に示します。

図A-1　メッセージダイアログの出力形式

それぞれの項目の出力内容を以下に示します。

(a)　メッセージのカテゴリを示すアイコン

メッセージのカテゴリを示すアイコンは，以下に示す4種類のアイコンがあります。

表A-1　メッセージのカテゴリを示すアイコンの一覧

アイコン | 対応するメッセージのカテゴリ
[図データ] | 障害が発生したので，処理を中止します。
[図データ] | 警告を出力し，処理を完了・続行します。
[図データ] | HiRDB Configuration Assistantの動作を通知します。
[図データ] | ユーザへの問い合わせを示します。
(b)　メッセージID

メッセージを一意に識別するID（XXXXnnnn-i）を出力します。

(c)　メッセージテキスト

メッセージの内容を説明するテキストを出力します。

(d)　詳細情報

メッセージに関する詳細情報を出力します。

(e)　ユーザが実施する対策

ユーザが実施する対策を示します。

(2)　置換ダイアログのメッセージ出力形式

置換ダイアログの出力形式を以下に示します。

図A-2　置換ダイアログの出力形式

置換ダイアログには，以下に示すメッセージの詳細情報が出力されます。

  • HICA2012-I
  • HICA2013-E
  • HICA2014-E

詳細情報以外の情報（メッセージID，メッセージテキスト，ユーザが実施する対策）は出力されません。

出力内容を以下に示します。

(a)　詳細情報

メッセージに関する詳細情報を出力します。

(3)　操作処理実行結果ファイルの出力形式

操作処理実行結果ファイルの出力形式を以下に示します。

図A-3　操作処理実行結果ファイルの出力形式

操作処理実行結果ファイルには，以下に示す項目が1行につき1つ出力されます。

  • HiRDB Configuration Assistantのメッセージ
  • HiRDB Configuration Assistantが呼び出したコマンドが出力するOSメッセージ
  • HiRDB Configuration Assistantが呼び出したコマンドのリタンコード

HiRDB Configuration Assistantのメッセージは，メッセージID，メッセージテキスト，詳細情報が1行で出力されます。ユーザが実施する対策は出力されません。

出力内容を以下に示します。

(a)　メッセージID

メッセージを一意に識別するID（XXXXnnnn-i）を出力します。

(b)　メッセージテキスト

メッセージの内容を説明するテキストを出力します。

(c)　詳細情報

メッセージに関する詳細情報を出力します。

(d)　OSが出力するメッセージ

システム定義のチェックの延長でOSが出力したメッセージをそのままリダイレクトします。


メッセージの記述形式

付録A.2　メッセージの記述形式

このヘルプでの，メッセージダイアログに関するメッセージの記述形式を以下に示します。

XXXXnnnn-i ＜Y＞

メッセージテキスト

メッセージの説明
（S）
HiRDB Configuration Assistantの動作または処理を示します。
（O）
ユーザが実施する対策を示します。なお，（S）または（O）での「保守員に連絡してください」とは，購入時の契約に基づいて，ユーザが弊社問い合わせ窓口へ連絡することを示します。
XXXX
メッセージを出力したプログラムを表します。
  • HICA：HiRDB Configuration Assistant
nnnn
メッセージの通し番号です。それぞれのメッセージに，4けたの固有の通し番号が付いています。
i
メッセージの種類を表します。
  • E：障害が発生したので，処理を中止します。
  • W：警告を出力し，処理を完了・続行します。
  • I：HiRDB Configuration Assistantの動作を通知します。
  • Q：ユーザへの問い合わせを示します。
＜Y＞
メッセージの出力先を示します。
  • Ｍ：メッセージダイアログ
  • Ｒ：置換ダイアログ
  • Ｓ：操作処理実行結果ファイル


メッセージ一覧

付録A.3　メッセージ一覧

HiRDB Configuration Assistantが出力するメッセージと，その対処方法を説明します。

＜この項の構成＞
(1)　HiRDB Configuration Assistantのメッセージ一覧
(2)　Windowsが出力するメッセージ一覧

(1)　HiRDB Configuration Assistantのメッセージ一覧

HICA0001-E ＜M＞

メモリ不足が発生しました。

メモリ不足が発生したため，HiRDB Configuration Assistantの処理を続行できません。
（S）
実行中の処理を中断します。
（O）
同時に実行している他アプリケーションを終了させるなどして，空きメモリを確保した後，再度処理を実行してください。

HICA0002-E ＜M＞

ファイルの書き込みに失敗しました。
ファイル名：aa...a
エラー情報：bb...b

ファイルの書き込みに失敗したため，HiRDB Configuration Assistantの処理を続行できません。
aa...a
書き込みが失敗したファイル名を表示します。
bb...b
書き込みが失敗した理由を表示します。
（S）
実行中の処理を中断します。
（O）
エラー情報に表示された原因を取り除いた後，再度処理を実行してください。

HICA0003-E ＜M＞

ファイルの読み込みに失敗しました。
ファイル名：aa...a
エラー情報：bb...b

ファイルの読み込みに失敗したため，HiRDB Configuration Assistantの処理を続行できません。
aa...a
読み込みが失敗したファイル名を表示します。
bb...b
読み込みが失敗した理由を表示します。
（S）
実行中の処理を中断します。
（O）
エラー情報に表示された原因を取り除いた後，再度処理を実行してください。

HICA0004-E ＜M＞

ファイルのOPEN処理でエラーが発生しました。
ファイル名：aa...a
エラー情報：bb...b

ファイルのOPEN処理でエラーが発生したため，HiRDB Configuration Assistantの処理を続行できません。
aa...a
エラーが発生したファイル名を表示します。
bb...b
エラーが発生した理由を表示します。
（S）
実行中の処理を中断します。
（O）
エラー情報に表示された原因を取り除いた後，再度処理を実行してください。

HICA0005-E ＜M＞

ファイルの削除処理でエラーが発生しました。
ファイル名：aa...a
エラー情報：bb...b

ファイルの削除処理でエラーが発生したため，HiRDB Configuration Assistantの処理を続行できません。
aa...a
エラーが発生したファイル名を表示します。
bb...b
エラーが発生した理由を表示します。
（S）
実行中の処理を中断します。
（O）
エラー情報に表示された原因を取り除いた後，再度処理を実行してください。

HICA0006-E ＜M＞

フォルダの作成処理でエラーが発生しました。
フォルダ名：aa...a
エラー情報：bb...b

フォルダの作成処理でエラーが発生したため，HiRDB Configuration Assistantの処理を続行できません。
aa...a
エラーが発生したフォルダ名を表示します。
bb...b
エラーが発生した理由を表示します。
（S）
実行中の処理を中断します。
（O）
エラー情報に表示された原因を取り除いた後，再度処理を実行してください。

HICA0007-E ＜M＞

フォルダの削除処理でエラーが発生しました。
フォルダ名：aa...a
エラー情報：bb...b

フォルダの削除処理でエラーが発生したため，HiRDB Configuration Assistantの処理を続行できません。
aa...a
エラーが発生したフォルダ名を表示します。
bb...b
エラーが発生した理由を表示します。
（S）
実行中の処理を中断します。
（O）
エラー情報に表示された原因を取り除いた後，再度処理を実行してください。

HICA0008-E ＜M＞

メモリ不足が発生しました。
確保しようとしたサイズ：aa...a
エラー情報：bb...b

メモリ不足が発生したため，HiRDB Configuration Assistantの処理を続行できません。
aa...a
確保しようとしたメモリサイズを表示します（単位：バイト）
bb...b
エラーが発生した理由を表示します。
（S）
実行中の処理を中断します。
（O）
エラー情報に表示された原因を取り除いた後，再度処理を実行してください。

HICA0009-E ＜M＞

ファイルの作成処理でエラーが発生しました。
ファイル名：aa...a
エラー情報：bb...b

ファイルの作成処理でエラーが発生したため，HiRDB Configuration Assistantの処理を続行できません。
aa...a
エラーが発生したファイル名を表示します。
bb...b
エラーが発生した理由を表示します。
（S）
実行中の処理を中断します。
（O）
エラー情報に表示された原因を取り除いた後，再度処理を実行してください。

HICA1001-E ＜M＞

構成情報ファイルの内容が不正です。
ファイル名：aa...a

HiRDB構成情報ファイルの内容が不正なため，HiRDB Configuration Assistantで開くことができません。
HiRDB構成情報ファイルの中身が破壊されている可能性があります。
aa...a
開こうとしたHiRDB構成情報ファイル名
（S）
実行中の処理を中断します。
（O）
バックアップのHiRDB構成情報ファイルを開くか，再度構築し直してください。

HICA1002-E ＜M＞

構成要素のドロップ先が見つかりません。

構成要素を，構成図上，またはツリービュー上でドロップできない場所にドロップしようとしています。
（S）
実行中の処理を中断します。
（O）
ドロップできる場所にドロップしてください。

HICA1003-E ＜M＞

内部矛盾を検知しました。
内部コード：aa...a

内部矛盾を検知したため，処理を実行できませんでした。
aa...a
内部コード番号
必要に応じて出力します。
（S）
実行中の処理を中断します。
（O）
保守員に連絡してください。

HICA2001-Q ＜M＞

削除しますか？

ユーザの削除要求を実行してよいか確認しています。
  • ［OK］ボタンをクリックすると，削除を実行します。
  • ［キャンセル］ボタンをクリックすると，削除処理を取りやめます。

HICA2002-E ＜M＞

貼り付けた内容が不正でした。

クリップボードから貼り付けようとした内容が不正なため，貼り付けを実行できませんでした。
（S）
実行中の処理を中断します。
（O）
貼り付け対象の内容を確認して，再度実行してください。

HICA2003-E ＜M＞

入力値の内容が不正です。

入力値の内容が指定可能な範囲を超えているため，入力できません。
（S）
実行中の処理を中断します。
（O）
入力値の指定可能範囲を確認して，再度入力してください。

HICA2004-E ＜M＞

HAグループは貼り付けられません。

HAグループは貼り付けることができません。
（S）
実行中の処理を中断します。
（O）
HAグループは，アイテムボックスから追加してください。

HICA2005-E ＜M＞

貼り付けられない場所に貼り付けようとしています。

構成要素を，貼り付けられない場所に貼り付けようとしています。
（S）
実行中の処理を中断します。
（O）
構成要素の親子関係にしたがって，貼り付けてください。

HICA2006-E ＜M＞

ステータスファイルの上限数を超えました。

１ユニット，または1サーバあたりのステータスファイルの上限数を超えて追加しようとしています。
（S）
実行中の処理を中断します。
（O）
定義に誤りがないか見直してください。

HICA2007-E ＜M＞

名称が重複しています。

変更しようとした名称が，既に使われています。
（S）
実行中の処理を中断します。
（O）
他の名称を使用してください。

HICA2008-Q ＜M＞

既にファイルが存在します。上書きしますか？
ファイル名：aa...a

出力ファイルと同じ名称のファイルが既に存在します。ファイルを上書きして処理を続行してよいか確認しています。
  • ［OK］ボタンをクリックすると，ファイルを上書きして処理を続行します。
  • ［キャンセル］ボタンをクリックすると，処理を取りやめます。
aa...a
上書きしようとしているファイルの名称

HICA2009-Q ＜M＞

既にフォルダが存在します。上書きしますか？

指定したフォルダが既に存在します。フォルダを上書きして処理を続行してよいか確認しています。
  • ［OK］ボタンをクリックすると，フォルダ下の全てのファイルを削除して処理を続行します。
  • ［キャンセル］ボタンをクリックすると，処理を取りやめます。

HICA2010-E ＜M＞

定義取り込みした構成要素は移動できません。

確定状態取り込みで取り込んだ，確定状態の構成要素は移動させることができません。
（S）
実行中の処理を中断します。
（O）
定義に誤りがないか見直してください。該当の構成要素を移動させる必要がある場合，確定状態取り込みではなく，新規状態取り込みで取り込んでください。

HICA2011-Q ＜M＞

入力した内容で置換しますか？
検索文字列：aa...a
置換文字列：bb...b
検索範囲：cc...c
置換範囲：dd...d

置換を実行する前に，置換に関する情報を表示します。置換の処理を続行して良いか確認しています。
  • ［置換］ボタンをクリックすると，置換の処理を続行します。
  • ［キャンセル］ボタンをクリックすると，置換の処理を取りやめます。
aa...a
置換で用いる検索文字列
bb...b
置換で用いる置換文字列
cc...c
置換対象の構成要素の名称
dd...d
置換の範囲
  • パス名

HICA2012-I ＜M,R＞

置換が終了しました。
aa...a件置換しました。

置換が終了しました。
aa...a
置換された文字列の件数

HICA2013-E ＜M,R＞

置換処理中にエラーが発生したため置換を中止します。
置換対象の構成要素名：aa...a
オペランド名：bb...b
理由：cc...c

置換処理中にエラーが発生したため置換を中止します。
aa...a
置換が失敗した構成要素名，または置換が失敗したオペランドが含まれる構成要素名
bb...b
置換が失敗したオペランド
置換の失敗が構成要素名で発生している場合は，「-」を表示
cc...c
置換が失敗した理由
  • 置換後のオペランドの値が上限文字数を超える条件が指定されました。
  • 置換後の構成要素名が上限文字数を超える条件が指定されました。
  • 置換後の構成要素名が未入力状態になる条件が指定されました。
（S）
実行中の処理を中断し，システム共通定義に以下の形式のcommentオペランドを追加します。
[HiRDB Configuration Assistant] Replacement error. [YYYY/MM/DD hh:mm:ss]
YYYY/MM/DD hh:mm:ssには，置換失敗時の日付が入ります。
本メッセージの出力後に操作を続けた場合，HiRDB Configuration Assistantの動作，およびHiRDB構成情報の内容は保証されません。
（O）
置換ダイアログで指定した「検索文字列」と「置換文字列」を見直し，バックアップのHiRDB構成情報を開いて再度実行してください。

HICA2014-E ＜M,R＞

置換処理中にエラーが発生したため置換を中止します。
置換前構成要素名：aa...a
置換後構成要素名：bb...b
理由：cc...c

置換対象の構成要素名が他にも存在しているため置換できません。
aa...a
置換を実行する前の構成要素名
bb...b
置換を実行した後の構成要素名
cc...c
置換が失敗した理由
  • 置換対象の構成要素名が他にも存在しているため置換できません。
（S）
実行中の処理を中断し，システム共通定義に以下の形式のcommentオペランドを追加します。
[HiRDB Configuration Assistant] Replacement error. [YYYY/MM/DD hh:mm:ss]
YYYY/MM/DD hh:mm:ssには，置換失敗時の日付が入ります。
本メッセージの出力後に操作を続けた場合，HiRDB Configuration Assistantの動作，およびHiRDB構成情報の内容は保証されません。
（O）
置換ダイアログで指定した「検索文字列」と「置換文字列」を見直し，バックアップのHiRDB構成情報を開いて再度実行してください。

HICA3002-I ＜M＞

定義ファイル出力が終了しました。

定義ファイル出力が終了しました。

HICA4002-I ＜M＞

ドキュメント出力が終了しました。

ドキュメント出力が終了しました。

HICA5003-E ＜M＞

不正なファイルを入力しました。
ファイル名：aa...a

入力ファイル中に不正なファイルがあったため，定義取り込みを続行できません。
aa...a
不正なファイルの名称
（S）
実行中の処理を中断します。
（O）
ファイルの内容を確認し，定義取り込みを再度実行してください。

HICA5004-E ＜M＞

指定された場所にはpdsysが見つかりませんでした。
フォルダ名：aa...a
エラー情報：bb...b

定義取り込みで指定された場所にpdsysが見つからないため，処理を続行できません。
aa...a
指定したフォルダ名
（S）
実行中の処理を中断します。
（O）
フォルダの内容を確認し，定義取り込みを再度実行してください。

HICA5005-E ＜M＞

定義取り込みに失敗しました。
フォルダ名：aa...a

入力ファイル中に不正な内容があったため，定義取り込みを続行できません。
aa...a
指定したフォルダ名
（S）
実行中の処理を中断します。
（O）
次の内容を確認し，定義取り込みを再度実行してください。
  • 定義取り込みの手順やフォルダ構成，入力ファイルに誤りがないか確認してください。
    確認内容については，以下のいずれかを参照してください。
      「4.2.1　構築済みのHiRDB環境から，HiRDB構成情報を取り込む（確定状態取り込み）」
      「4.3.1　構築済みのHiRDB環境から，HiRDB構成情報を取り込む（新規状態取り込み）」
  • 定義ファイルの各オペランドに文法誤りがないか確認してください。
    確認対象の定義ファイルについては，「付録B.1　定義ファイルの一覧」を参照してください。

HICA7001-I ＜M＞

システム定義のチェックが正常終了しました。

システム定義のチェックが正常終了しました。

HICA7002-W ＜M＞

システム定義のチェックが終了しました。
詳細メッセージが出力されています。
チェック結果ファイル：aa...a

システム定義のチェックが終了しましたが，詳細メッセージが出力されています。
aa...a
チェック結果ファイル名
（O）
定義に誤りがないかチェック結果ファイルの内容から見直し，再度システム定義のチェックを実行してください。

HICA7003-E ＜M＞

システム定義のチェックが異常終了しました
操作処理実行結果ファイル：aa...a

システム定義のチェックが異常終了しました。
aa...a
操作処理実行結果ファイル名
（S）
実行中の処理を中断します。
（O）
操作処理実行結果ファイルに出力された内容から，エラーとなった原因を取り除き，再度システム定義のチェックを実行してください。

HICA7012-I ＜S＞

バッチファイルを実行します。
マシン名：aa...a
実行している機能：bb...b

バッチファイルを実行します。
aa...a
マシン名
bb...b
実行している機能名
  • チェック用ファイル転送機能
  • チェック用ファイル文字コード変換機能
  • チェック用ファイル削除機能

HICA7013-I ＜S＞

バッチファイルが終了しました。
マシン名：aa...a
実行している機能：bb...b

バッチファイルが終了しました。
aa...a
マシン名
bb...b
実行している機能名
  • チェック用ファイル転送機能
  • チェック用ファイル文字コード変換機能
  • チェック用ファイル削除機能

HICA7014-E ＜S＞

バッチファイルが異常終了しました。
マシン名：aa...a
実行している機能：bb...b
終了コード（cc...c，dd...d）

バッチファイルが異常終了しました。
aa...a
マシン名
bb...b
実行している機能名
  • チェック用ファイル転送機能
  • チェック用ファイル文字コード変換機能
  • チェック用ファイル削除機能
cc...c
内部コード
dd...d
内部コード
（S）
実行中の処理を中断します。
（O）
当メッセージの前に出力されているOSメッセージとエラーになったマシン環境を確認して，エラーになった原因を取り除き再度システム定義のチェックを実行してください。

HICA7015-I ＜S＞

バッチファイルを実行します。
実行している機能：aa...a

バッチファイルを実行します。
aa...a
実行している機能名
  • pdconfchk実行機能

HICA7016-I ＜S＞

バッチファイルが終了しました。
実行している機能：aa...a

バッチファイルが終了しました。
aa...a
実行している機能名
  • pdconfchk実行機能

HICA7017-E ＜S＞

バッチファイルが異常終了しました。
実行している機能：aa...a

バッチファイルが異常終了しました。
aa...a
実行している機能名
  • pdconfchk実行機能
（S）
実行中の処理を中断します。
（O）
当メッセージの前に出力されているOSメッセージとエラーになったマシン環境を確認して，エラーになった原因を取り除き再度システム定義のチェックを実行してください。

HICA7018-E ＜M＞

システム定義のチェックを行うのに必要な構成要素が定義されていませんでした。
定義されていない構成要素：aa...a
詳細種別：bb...b

必要な構成要素が定義されていないため，システム定義のチェックを実行できません。
aa...a
定義されていない構成要素
  • サーバ
bb...b
定義されていない構成要素の詳細種別
（S）
実行中の処理を中断します。
（O）
必要な構成要素を定義して，再度システム定義のチェックを実行してください。

HICA7019-E ＜M＞

サービス名がservicesファイルに登録されていませんでした。
登録されていないサービス名：aa...a

サービス名がservicesファイルに登録されていないため，システム定義のチェックを実行できません。
aa...a
登録されていないサービス名
（S）
実行中の処理を中断します。
（O）
サービス名をservicesファイルに設定して，再度システム定義のチェックを実行してください。

HICA8001-E ＜M＞

容量計算を実行するために必要な構成要素が定義されていませんでした。
定義されていない構成要素：aa...a
詳細種別：bb...b

容量計算を実行するために必要な構成要素が定義されていないため，容量計算を実行できません。
aa...a
構成要素種別名
bb...b
詳細種別名
（S）
実行中の処理を中断します。
（O）
必要な構成要素を定義して，システム定義のチェックで正常結果を確認後，容量計算を実行してください。

HICA8002-E ＜M＞

容量計算を実行可能な状態で構成要素が定義されていませんでした。
構成要素：aa...a
理由：bb...b

容量計算を実行可能な状態で構成要素が定義されていないため，容量計算を実行できません。
aa...a
構成要素種別名
bb...b
理由
  • シングルサーバが複数定義されています
  • マネージャサーバが複数定義されています
  • ディクショナリサーバが複数定義されています
（S）
実行中の処理を中断します。
（O）
理由を確認して，エラーになった原因を取り除きシステム定義のチェックで正常結果を確認後，容量計算を実行してください。

HICA8003-E ＜M＞

容量計算を実行可能な状態で構成要素が定義されていませんでした。
構成要素名：aa...a
理由：bb...b

容量計算を実行可能な状態で構成要素が定義されていないため，容量計算を実行できません。
aa...a
構成要素名
bb...b
理由
  • ユニットが定義されていないマシンがあります
  • HiRDBファイルシステム領域が定義されていないマシンがあります
  • 1マシン内に複数のユニットが定義されています
  • 容量計算に必要なオペランドが設定されていません
  • 容量計算に必要なオペランドの入力値が不正です
（S）
実行中の処理を中断します。
（O）
理由を確認して，エラーになった原因を取り除きシステム定義のチェックで正常結果を確認後，容量計算を実行してください。

HICA8004-E ＜M＞

容量計算を実行可能なHiRDBバージョンではありませんでした。
構築中のHiRDBバージョン：aa...a

容量計算を実行可能なHiRDBバージョンではないため，容量計算を実行できません。
aa...a
HiRDBバージョン
（S）
実行中の処理を中断します。
（O）
当該バージョンの容量計算は実行できないため，HiRDBのマニュアルにしたがってメモリ・ディスクサイズの計算を行ってください。

HICA8005-E ＜M＞

容量計算の制限に該当する構成要素を検出しました。
構成要素：aa...a
理由：bb...b

容量計算の制限に該当する構成要素を検出したため，容量計算を実行できません。
aa...a
構成要素種別名
bb...b
理由
  • RDエリアが201以上定義されています
  • サーバが201以上定義されています
  • グローバルバッファが201以上定義されています
  • HAグループが2以上定義されています
  • HAグループにユニットが26以上定義されています
（S）
実行中の処理を中断します。
（O）
容量計算の制限に該当し，容量計算は実行できないため，HiRDBのマニュアルにしたがってメモリ・ディスクサイズの計算を行ってください。

HICA8006-E ＜M＞

容量計算の制限に該当するオペランドを検出しました。
構成要素名：aa...a
オペランド名：bb...b
理由：cc...c

容量計算の制限に該当するオペランドを検出したため，容量計算を実行できません。
aa...a
構成要素名
bb...b
オペランド名
cc...c
理由
  • オペランドに-2147483648より小さい，もしくは2147483647より大きい数値を指定しています
（S）
実行中の処理を中断します。
（O）
容量計算の制限に該当し，容量計算は実行できないため，HiRDBのマニュアルにしたがってメモリ・ディスクサイズの計算を行ってください。

HICA9001-E ＜S＞

System call error occurred.(aa...a,error=bb...b)

システムコールのエラーが発生したため，システム定義のチェックを実行できません。
aa...a
エラーが発生したシステムコール名称
bb...b
システムコールのエラー番号（GetLastError関数により取得）
（S）
実行中の処理を中断します。
（O）
エラー番号を参照し，エラーになった原因を取り除いた後，システム定義チェック機能を再実行してください。

HICA9002-E ＜S＞

Arguments in command line were invalid.

リモートコマンドの引数が不正なため，システム定義のチェックを実行できません。
（S）
実行中の処理を中断します。
（O）
保守員に連絡してください。

HICA9003-E ＜S＞

Time over occurred. No response from aa...a process.

タイムオーバーが発生したため，システム定義のチェックを実行できません。
aa...a
タイムオーバーとなったコマンド名
（S）
実行中の処理を中断します。
（O）
ファイル転送元，もしくはファイル転送先のマシン，もしくはネットワークに負荷が掛かっている可能性があります。転送先のマシン，もしくはネットワークの負荷が収まった後，システム定義チェック機能を再実行してください。

HICA9004-E ＜S＞

Specified file name was not found.

リモートコマンドに指定したファイル名が存在しないため，システム定義のチェックを実行できません。
（S）
実行中の処理を中断します。
（O）
保守員に連絡してください。

HICA9005-E ＜S＞

Initialize error occurred in HiRDB Service.(aa...a,bb...b)

チェック対象のHiRDBのサービスでエラーが発生したため，システム定義のチェックを実行できません。
aa...a
内部コード1
bb...b
内部コード2
（S）
実行中の処理を中断します。
（O）
チェック対象のHiRDBのサービスでエラーが発生しています。HiRDBのメッセージを確認してください。

HICA9006-E ＜S＞

Data read error occurred in HiRDB Service.(aa...a)

データの読み込みでエラーが発生したため，システム定義のチェックを実行できません。
aa...a
内部コード1
（S）
実行中の処理を中断します。
（O）
ユニット制御情報定義のPDDIRオペランドの設定値が誤っている可能性があります。設定値を見直した後，システム定義チェック機能を再実行してください。
PDDIRオペランドの指定値が正しい場合は，保守員に連絡してください。

HICA9007-E ＜S＞

Data write error occurred in HiRDB Service.(aa...a)

データの書き込みでエラーが発生したため，システム定義のチェックを実行できません。
aa...a
内部コード1
（S）
実行中の処理を中断します。
（O）
ユニット制御情報定義のPDDIRオペランドの設定値が誤っている可能性があります。設定値を見直した後，システム定義チェック機能を再実行してください。
PDDIRオペランドの指定値が正しい場合は，保守員に連絡してください。

(2)　Windowsが出力するメッセージ一覧

HiRDB Configuration Assistantを実行中に，「付録A.3(1)　HiRDB Configuration Assistantのメッセージ一覧」に含まれない，Windowsのメッセージが出力されることがあります。出力される可能性があるWindowsのメッセージと，その対処法を以下に説明します。

表A-2　Windowsのメッセージと対処法

Windowsのメッセージ | Windowsメッセージの種別 | 想定される事象 | 対処法
%1 が見つかりませんでした。（%1はパス名＋ファイル名） エラー
  • 指定された構成情報ファイルが削除されているため，構成情報ファイルが見つかりません。
  • 指定された構成情報ファイルのファイル名が変更されているため，構成情報ファイルが見つかりません。
 指定した構成情報ファイルがディスク上に保存されているか確認してください。
%1 に正しくないパスが含まれています。（%1はパス名＋ファイル名） エラー
  • 指定されたパス情報が削除されているため，パスが見つかりません。
  • 指定されたパス情報が変更されているため，パスが見つかりません。
 指定したパスが存在するか確認してください。
%1 への変更を保存しますか？（%1はパス名＋ファイル名） | 確認 | 構成情報ファイルが未保存の状態で新規作成等が選択されました。 | 保存して処理を続行する場合は「はい」，保存せずに処理を続行する場合は「いいえ」，処理をキャンセルする場合は「キャンセル」を押してください。
%1 は既に存在します。上書きしますか？（%1はパス名＋ファイル名） | 警告 | 既に存在している構成情報ファイル名と同名の構成情報ファイル名が指定されました。 | 構成情報ファイルを上書きする場合は「はい」，上書きせずに構成情報ファイル名を指定し直す場合は「いいえ」を押してください。
%1 へのアクセスは拒否されました。（%1はパス名＋ファイル名） | エラー | 指定された構成情報ファイルに書き込み権限がないため，構成情報ファイルに書き込めませんでした。 | 指定した構成情報ファイルに書き込み権限があるか確認するか，別名で保存してください。
パラメータが間違っています。 エラー 定義取り込み時に，以下のいずれかの状態を検知しました。
  • 定義ファイルに設定された定義が誤っている。
  • 定義ファイルの文字コードがShift-JIS以外
  • pdflsコマンドの実行結果に不要な空行がある。
  • 定義ファイルに設定されている定義に間違いがないか確認してください。
  • 定義ファイルの文字コードがShift-JISになっているか確認してください。
  • pdflsコマンドの実行結果に不要な空行がないか確認してください。


定義ファイル

付録B　定義ファイル

HiRDB Configuration Assistantが出力する定義ファイルの一覧，およびその詳細について解説します。

＜この節の構成＞
付録B.1　定義ファイルの一覧
付録B.2　定義ファイルの詳細


定義ファイルの一覧

付録B.1　定義ファイルの一覧

HiRDB Configuration Assistantが出力する定義ファイルの一覧を以下に示します。

表B-1　定義ファイルの一覧

出力する定義ファイル |  | 出力個数 | 出力有無
種別 | ファイル名 |  | 新しくHiRDBを構築する場合 | 既存HiRDBの構成を取り込んで構成変更する場合
システム共通定義 | pdsys | ユニットに対して1ファイル | ○ | ▲
ユニット制御情報定義 | pdutsys |  | ○ | ▲
サーバ共通定義 | pdsvrc |  | ○ | ▲
ディクショナリサーバ定義 | (DICサーバと同名) | サーバに対して1ファイル | △ | ▲
フロントエンドサーバ定義 | (FESサーバと同名) |  | △ | ▲
バックエンドサーバ定義 | (BESサーバと同名) |  | △ | ▲
シングルサーバ定義 | (SDSサーバと同名) |  | △ | ▲
  • ○：必ず出力します。
  • △：対応するサーバが定義されている場合，出力します。
  • ▲：構成変更に関連する定義ファイルのみ出力されます。


定義ファイルの詳細

付録B.2　定義ファイルの詳細

HiRDB Configuration Assistantが出力する定義ファイルの詳細を説明します。

＜この項の構成＞
(1)　定義ファイルの文字コード
(2)　定義ファイルの改行コード

(1)　定義ファイルの文字コード

HiRDB Configuration Assistantが出力する定義ファイルの文字コードは，構築対象となるHiRDBが使用する文字コードにかかわらず，Shift-JISとなります。

そのため，「付録E　文字コード変換要否判定」にしたがい，文字コードの変換が必要と判断された場合，HiRDBが使用する文字コードに合わせて，定義ファイルの文字コードを変換して，HiRDBが動作するマシンに転送するようにしてください。

文字コードの変換には，iconvなどのコマンドを使用してください。

(2)　定義ファイルの改行コード

構築対象となるHiRDBのプラットフォームにより，HiRDB Configuration Assistantが出力する定義ファイルの改行コードは以下のように設定されます。

表B-2　定義ファイルの改行コード

構築対象となるHiRDBのプラットフォーム | 改行コード
Windows | CR+LF
AIX | LF
Linux
HP-UX
Solaris


環境構築用バッチファイル

付録C　環境構築用バッチファイル

HiRDB Configuration Assistantが出力する環境構築用バッチファイルの一覧，およびその詳細について解説します。

＜この節の構成＞
付録C.1　環境構築用バッチファイルの一覧
付録C.2　環境構築用バッチファイルの詳細
付録C.3　環境構築用バッチファイル実行時の注意事項


環境構築用バッチファイルの一覧

付録C.1　環境構築用バッチファイルの一覧

HiRDB Configuration Assistantが出力する環境構築用バッチファイルの一覧を以下に示します。

以下の一覧では，拡張子を.batで記載しています。HiRDBのプラットフォームがWindows以外の場合，一覧の拡張子を.shに読み替えてください。

表C-1　環境構築用バッチファイルの一覧（新規HiRDB構築用）

バッチファイル種別 | 目的 | バッチファイルの フォーマット | バッチ ファイル名 | 対応する 構成要素 | 構成 要素 への 操作 | 実行 する コマ ンド
HiRDBファイルシステム領域初期化用バッチファイル | HiRDB Configuration Assistant上で定義したHiRDBファイルシステム領域を作成するために実行します。 | コマンド実行バッチファイル | add_hfs_command.bat | HiRDBファイルシステム領域 | 追加 | pdfmkfs
HiRDBファイル初期化用バッチファイル | HiRDB Configuration Assistant上で定義したステータスファイル，システムログファイル，シンクポイントダンプファイルを作成するために実行します。 | 統合バッチファイル | init_systemfile_command.bat | なし | なし | なし
 |  | コマンド実行バッチファイル | add_status_unit_command.bat | ユニット用ステータスファイル | 追加 | pdstsinit
 |  |  | add_status_svr_command.bat | サーバ用ステータスファイル | 追加
 |  |  | add_systemlog_command.bat | システムログファイル | 追加 | pdloginit
 |  |  | add_sysc_command.bat | シンクポイントダンプファイル | 追加 | pdloginit
RDエリア作成用バッチファイル | ディクショナリを初期化するために実行します。 | 統合バッチファイル | init_rdarea_dic_command.bat | なし | なし | なし
 |  | コマンド実行バッチファイル | add_rdarea_command.bat | なし | なし | pdinit
 |  | 制御文ファイル | add_rdarea_control.txt | RDエリア | 追加 | create rdarea
RDエリア追加用バッチファイル | HiRDB Configuration Assistant上で定義したレジストリ用RDエリア，およびデータディクショナリ用RDエリア（再編成時期予測用）を登録するために実行します。 | 統合バッチファイル | init_rdarea_command.bat | なし | なし | なし
 |  | コマンド実行バッチファイル | add_rdarea_dbm_command.bat | なし | なし | pdmod
 |  | 制御文ファイル | add_rdarea_dbm_control.txt | RDエリア | 追加 | create rdarea
 |  | コマンド実行バッチファイル | add_rdarea_reg_command.bat | なし | なし | pdreginit
 |  | 制御文ファイル | add_rdarea_reg_control.txt | RDエリア | 追加 | create rdarea

表C-2　環境構築用バッチファイルの一覧（既存HiRDBの構成変更用）

バッチファイル種別 | 目的 | バッチファイルのフォーマット | バッチファイル名 | 対応する構成要素 | 構成要素への操作 | 実行するコマンド
HiRDBファイルシステム領域変更用バッチファイル | HiRDB Configuration Assistant上でのHiRDBファイルシステム領域への変更を反映するために実行します。 | コマンド実行バッチファイル | add_hfs_command.bat | HiRDBファイルシステム領域 | 追加 | pdfmkfs
 |  |  | del_hfs_command.bat |  | 削除 | rm（OSの削除コマンド）
HiRDBファイル変更用バッチファイル | HiRDB Configuration Assistant上のステータスファイル，システムログファイル，シンクポイントダンプファイルへの変更を反映するために実行します。 | 統合バッチファイル | change_systemfile_command.bat | なし | なし | なし
 |  | コマンド実行バッチファイル | add_systemlog_command.bat | システムログファイル | 追加 | pdloginit
 |  |  | chg_systemlog_command.bat |  | 変更 | pdlogrm， pdloginit
 |  |  | del_systemlog_command.bat |  | 削除 | pdlogrm
 |  |  | add_sync_command.bat | シンクポイントダンプファイル | 追加 | pdloginit
 |  |  | chg_sync_command.bat |  | 変更 | pdlogrm， pdloginit
 |  |  | del_sync_command.bat |  | 削除 | pdlogrm
 |  |  | add_status_unit_command.bat | ユニット用ステータスファイル | 追加 | pdstsinit
 |  |  | chg_status_unit_command.bat |  | 変更 | pdstsrm， pdstsinit
 |  |  | del_status_unit_command.bat |  | 削除 | pdstsrm
 |  |  | add_status_svr_command.bat | サーバ用ステータスファイル | 追加 | pdstsinit
 |  |  | chg_status_svr_command.bat |  | 変更 | pdstsrm， pdstsinit
 |  |  | del_status_svr_command.bat |  | 削除 | pdstsrm
RDエリア変更用バッチファイル | HiRDB Configuration Assistant上のRDエリアへの変更を反映するために実行します。 | 統合バッチファイル | change_rdarea_command.bat | なし | なし | なし
 |  | コマンド実行バッチファイル | add_rdarea_command.bat | なし | なし | pdmod
 |  | 制御文ファイル | add_rdarea_control.txt | RDエリア（レジストリ用RDエリア，およびデータディクショナリ用RDエリア（再編成時期予測用）を除く） | 追加 | create rdarea
 |  | コマンド実行バッチファイル | chg_rdarea_command.bat | なし | なし | pdmod
 |  | 制御文ファイル | chg_rdarea_control.txt | RDエリア | 変更 | alter rdarea
 |  | コマンド実行バッチファイル | del_rdarea_command.bat | なし | なし | pdmod
 |  | 制御文ファイル | del_rdarea_control.txt | RDエリア（レジストリ用RDエリア，およびデータディクショナリ用RDエリア（再編成時期予測用）を除く） | 削除 | remove rdarea
 |  | コマンド実行バッチファイル | add_rdarea_dbm_command.bat | なし | なし | pdmod
 |  | 制御文ファイル | add_rdarea_dbm_control.txt | データディクショナリ用RDエリア（再編成時期予測用） | 追加 | create rdarea
 |  | コマンド実行バッチファイル | chg_rdarea_dbm_command.bat | なし | なし | pdmod
 |  | 制御文ファイル | chg_rdarea_dbm_control.txt | データディクショナリ用RDエリア（再編成時期予測用） | 変更 | alter rdarea
 |  | コマンド実行バッチファイル | add_rdarea_reg_command.bat | なし | なし | pdmod
 |  | 制御文ファイル | add_rdarea_reg_control.txt | レジストリ用RDエリア | 追加 | create rdarea
 |  | コマンド実行バッチファイル | chg_rdarea_dbm_command.bat | なし | なし | pdmod
 |  | 制御文ファイル | chg_rdarea_dbm_control.txt | レジストリ用RDエリア | 変更 | alter rdarea


環境構築用バッチファイルの詳細

付録C.2　環境構築用バッチファイルの詳細

HiRDB Configuration Assistantが出力する環境構築用バッチファイルの詳細を説明します。

＜この項の構成＞
(1)　環境構築用バッチファイルの文字コード
(2)　環境構築用バッチファイルの改行コード
(3)　環境構築用バッチファイルの拡張子
(4)　環境構築用バッチファイルのフォーマット

(1)　環境構築用バッチファイルの文字コード

HiRDB Configuration Assistantが出力する環境構築用バッチファイルの文字コードは，構築対象となるHiRDBが使用する文字コードにかかわらず，Shift-JISとなります。

そのため，「付録E　文字コード変換要否判定」にしたがい，文字コードの変換が必要と判断された場合，HiRDBが使用する文字コードに合わせて，環境構築用バッチファイルの文字コードを変換して，HiRDBが動作するマシンに転送するようにしてください。

文字コードの変換には，iconvなどのコマンドを使用してください。

(2)　環境構築用バッチファイルの改行コード

構築対象となるHiRDBのプラットフォームにより，HiRDB Configuration Assistantが出力する環境構築用バッチファイルの拡張子は以下のように設定されます。

表C-3　環境構築用バッチファイルの拡張子

構築対象となるHiRDBのプラットフォーム | 改行コード
Windows | CR+LF
AIX | LF
Linux
HP-UX
Solaris

(3)　環境構築用バッチファイルの拡張子

統合バッチファイル，およびコマンド実行バッチファイルの拡張子は，構築対象のHiRDBのプラットフォームにより，以下のように設定されます。

表C-4　環境構築用バッチファイルの拡張子

HiRDBのプラットフォーム | 統合バッチファイル，およびコマンド実行バッチファイルの拡張子
Windows | .bat
AIX | .sh
Linux
HP-UX
Solaris

(4)　環境構築用バッチファイルのフォーマット

環境構築用バッチファイルには，以下に示す3種類のフォーマットがあります。

表C-5　環境構築用バッチファイルのフォーマット

フォーマット | 機能
統合バッチファイル | コマンド実行バッチファイルを呼び出します。
コマンド実行ファイル | HiRDBのコマンドを実行します。
制御文ファイル | コマンド実行ファイルで実行するHiRDBコマンドpdinit，pdmod，およびpdregintで使用する制御文を記述しています。

それぞれのフォーマットについて，以下で詳細を説明します。なお，詳細説明の中では，Windows版の環境構築用バッチファイルを例として使用します。

(a)　統合バッチファイル

統合バッチファイルは各コマンド実行ファイルを呼び出すためのバッチファイルです。以下に統合バッチファイルの構造とリタンコードについて説明します。

●バッチファイルの構造

統合バッチファイルの構造について説明します。

統合バッチファイルは，以下に示すように，1つの「①バッチファイル情報」，1つの「②バッチファイルを実行設定するための環境設定」と，1つ以上の「③コマンド実行バッチファイルの実行とエラー判定」から構成されています。

図C-1　統合バッチファイルの構造

①バッチファイル情報
バッチファイルの情報をコメント中に記載しています。
コメントの冒頭には，バッチファイルがHiRDB構築用に作成されたファイルであることと，バッチファイル作成のためにHiRDB Configuration Assistantを使用したことが記載されます。
YYYY/MM/DD hh:mm:ssには，定義出力によりバッチファイルを作成した時の日時が記載されます。
XXXXには，操作対象のHiRDB識別子が記載されます。

②バッチファイルを実行するための環境設定
エコー機能を無効にします。
バッチファイル内の環境変数のローカライズを開始します。
バッチファイルのリタンコードを初期化します。
環境変数PDDIRを設定します。
バッチファイルを格納しているフォルダに移動します。

③コマンド実行バッチファイルの実行とエラー判定
コマンド実行バッチファイルを実行します。
コマンド実行バッチファイルの実行結果を判定します。コマンド実行バッチファイルの実行がエラーの場合は，統合バッチファイルの実行を中断します。
コマンド実行バッチファイルの実行が正常に終了した場合は，次の「③コマンド実行バッチファイルの実行とエラー判定」を処理します。
●リタンコード

統合バッチファイルが返すリタンコードについて説明します。

表C-6　統合バッチファイルのリタンコード

リタンコード | 意味
0 | 正常に統合バッチファイルの実行が終了しました。
12 | コマンド実行ファイルの実行でエラーが発生したため，統合バッチファイルを中断しました。
(b)　コマンド実行バッチファイル

コマンド実行ファイルはHiRDBのコマンドを実行するためのバッチファイルです。

以下にコマンドバッチファイルの構造とリタンコードについて説明します。

●バッチファイルの構造

コマンド実行バッチファイルの構造について説明します。

コマンド実行バッチファイルは，以下に示すように，1つの「①バッチファイル情報」，1つの「②バッチファイルを実行設定するための環境設定」と，1つ以上の「③HiRDBコマンドの実行とエラー判定」から構成されています。

図C-2　コマンド実行バッチファイル構造

①バッチファイル情報
バッチファイルの情報をコメント中に記載しています。
コメントの冒頭には，バッチファイルがHiRDB構築用に作成されたファイルであることと，バッチファイル作成のためにHiRDB Configuration Assistantを使用したことが記載されます。
YYYY/MM/DD hh:mm:ssには，定義出力によりバッチファイルを作成した時の日時が記載されます。
XXXXには，操作対象のHiRDB識別子が記載されます。

②バッチファイルを実行するための環境設定
エコー機能を無効にします。
バッチファイルのリタンコードを初期化します。
バッチファイル内の環境変数のローカライズを開始します。
環境変数PDDIRを設定します。

③HiRDBコマンドの実行とエラー判定
HiRDBコマンドの実行開始をエコーします。
HiRDBコマンド実行します。
HiRDBコマンドの実行結果を判定します。HiRDBコマンドの実行がエラーの場合は，コマンド実行バッチファイルの実行を中断します。
HiRDBコマンドのの実行が正常に終了した場合は，次の「③HiRDBコマンドの実行とエラー判定」を処理します。
●リタンコード

コマンド実行バッチファイルが返すリタンコードについて説明します。

表C-7　コマンド実行バッチファイルのリタンコード

リタンコード | 意味
0 | 正常にコマンド実行バッチファイルの実行が終了しました。
4 | 一部のコマンドの実行で警告が発生しましたが，正常にコマンド実行バッチファイルの実行が終了しました。
12 | コマンド実行ファイルの実行でエラーが発生したため，統合バッチファイルを中断しました。 出力されたエラーメッセージを参照し，原因を取り除いてください。
(c)　制御文ファイル

制御文ファイルは，コマンド実行ファイルで実行するHiRDBコマンドpdinit，pdmod，およびpdregintで使用する制御文を記述したファイルです。

制御文は，RDエリアの操作に応じて出力されます。RDエリアの操作と，対応して展開する制御文の関係を以下に示します。

表C-8　RDエリアに対する操作に対して展開する制御文

RDエリアに対する操作 |  | 展開する制御文
追加 |  | create rdarea文
変更 | RDエリアの自動増分 | alter rdarea文
 | HiRDBファイルの追加 | expand rdarea文
 | RDエリアの種別 | remove rdarea文と，create rdarea文※1
 | サーバ名
削除 |  | remove rdarea文

※1 RDエリアの種別，サーバ名を変更した場合には，変更対象のRDエリアを削除して，新たにRDエリアを追加する形で制御文が出力されます。

制御文ファイル中のパスには，"DICサーバが所属するユニットのPDDIRオペランド値\conf"が設定されます。DICサーバが属するユニットのPDDIRオペランドが省略されている場合には，HiRDB構成初期情報ダイアログで指定した，HiRDB運用ディレクトリの値を代わりに使用します。


環境構築用バッチファイル実行時の注意事項

付録C.3　環境構築用バッチファイル実行時の注意事項

環境構築用バッチファイル実行時の注意事項を以下に説明します。

  • 環境構築用バッチファイルの実行は，HiRDB管理者が行ってください。
  • 環境構築用バッチファイルの実行により，新たにHiRDBを構築するマシンや，既存のHiRDBの環境に影響を与えることになるため，各バッチファイルの内容を確認し，適切なバックアップを取得した上で，バッチファイルを実行するようにしてください。


構成要素と，出力する定義ファイル，および環境構築用バッチファイルの対応関係

付録D　構成要素と，出力する定義ファイル，および環境構築用バッチファイルの対応関係

HiRDB Configuration Assistant上で構成要素に対する操作を行った場合に，対応して出力する定義ファイル，および環境構築用バッチファイルを示します。出力する定義ファイル，および環境構築用バッチファイルは，新規定義出力時と変更定義出力時で異なります。新規定義出力時，変更定義出力時のそれぞれについて，構成要素と出力ファイルの対応関係を以下に表で示します。

表D-1　構成要素と出力ファイルの対応関係（新規定義出力時）

構成要素 出力ファイル
HiRDB
  • pdsys
マシン
  • pdsys
ユニット ユニット
  • pdsys
  • pdutsys
  • pdsvrc
待機系ユニット
  • pdsys
サーバ マネージャサーバ
  • pdsys

  • ディクショナリサーバ
  • フロントエンドサーバ
  • バックエンドサーバ
  • シングルサーバ
  • pdsys
  • サーバ名と同名のファイル
RDエリア
  • ユーザ用RDエリア
  • LOB用RDエリア
  • リスト用RDエリア
  • 共用RDエリア
  • マスタディレクトリ用RDエリア
  • データディレクトリ用Dエリア
  • データディクショナリ用RDエリア
  • データディクショナリ用RDエリア（ルーチン用）
  • データディクショナリLOB用RDエリア
  • init_rdarea_dic_command.bat
  • add_rdarea_dic_command.bat
  • add_rdarea_control.txt
  • pdsys（グローバルバッファ（一時グローバルバッファを除く）を割り当てている場合）
データディクショナリ用RDエリア（再編成時期予測用）
  • init_rdarea_command.bat
  • add_rdarea_dbm_command.bat
  • add_rdarea_dbm_control.txt
  • pdsys（グローバルバッファ（一時グローバルバッファを除く）を割り当てている場合）

  • レジストリ用RDエリア
  • レジストリLOB用RDエリア
  • init_rdarea_command.bat
  • add_rdarea_reg_command.bat
  • add_rdarea_reg_control.txt
  • pdsys（グローバルバッファ(一時グローバルバッファを除く)を割り当てている場合）
グローバルバッファ
  • グローバルバッファ
  • LOB用グローバルバッファ
  • インデクス用グローバルバッファ
  • その他用グローバルバッファ
  • pdsys
HiRDBファイルシステム領域
  • DB用ファイルシステム領域
  • SDB用ファイルシステム領域
  • SYS用ファイルシステム領域
  • SVR用ファイルシステム領域
  • WORK用ファイルシステム領域
  • UTL用ファイルシステム領域
  • init_hfs_command.bat
  • add_hfs_command.bat
システムファイル システムログ
  • システムログファイルが属するサーバと同名のファイル
  • init_systemfile_command.bat
  • add_systemlog_command.bat
シンクポイントダンプファイル
  • シンクポイントダンプファイルが属するサーバと同名のファイル
  • init_systemfile_command.bat
  • add_sync_command.bat
ユニット用ステータスファイル
  • pdutsys
  • init_systemfile_command.bat
  • add_status_unit_command.bat
サーバ用ステータスファイル
  • サーバ用ステータスファイルが属するサーバと同名のファイル
  • init_systemfile_command.bat
  • add_status_svr_command.bat
HAグループ
  • pdsys

表D-2　構成要素と出力ファイルの対応関係（変更定義出力時）

構成要素 | 構成要素に対して行った操作 | 出力ファイル
HiRDB 属性変更（オペランド更新）
  • pdsys
マシン 追加
  • pdsys
削除
  • pdsys
複写
  • pdsys
名称変更
  • pdsys
属性変更（オペランド更新） | なし
ユニット ユニット 追加
  • pdsys
  • pdutsys
  • pdsvrc
削除
  • pdsys
移動
  • pdsys
  • pdutsys
  • pdsvrc
複写
  • pdsys
  • pdutsys
  • pdsvrc
名称変更
  • pdsys
  • pdutsys
  • pdsvrc
属性変更（オペランド更新）
  • pdutsys
  • pdsvrc
待機系ユニット 追加
  • pdsys
削除
サーバ マネージャサーバ 追加
  • pdsys
削除
移動
複写
名称変更

  • ディクショナリサーバ
  • フロントエンドサーバ
  • バックエンドサーバ
  • シングルサーバ
 追加
  • pdsys
  • サーバ名と同名のファイル
削除
  • pdsys
移動
  • pdsys
  • サーバ名と同名のファイル
複写
  • pdsys
  • サーバ名と同名のファイル
名称変更
  • pdsys
  • サーバ名と同名のファイル
属性変更（オペランド更新）
  • サーバ名と同名のファイル
RDエリア
  • ユーザ用RDエリア
  • LOB用RDエリア
  • リスト用RDエリア
  • 共用RDエリア
  • マスタディレクトリ用RDエリア
  • データディレクトリ用Dエリア
  • データディクショナリ用RDエリア
  • データディクショナリ用RDエリア（ルーチン用）
  • データディクショナリLOB用RDエリア
 追加
  • change_rdarea_command.bat
  • add_rdarea_command.bat
  • add_rdarea_control.txt
  • pdsys（グローバルバッファ（一時グローバルバッファを除く）を割り当てた場合
削除
  • change_rdarea_command.bat
  • del_rdarea_command.bat
  • del_rdarea_control.txt
  • pdsys（グローバルバッファ（一時グローバルバッファを除く）を割り当てていた場合
移動
  • change_rdarea_command.bat
  • del_rdarea_command.bat
  • del_rdarea_control.txt
  • add_rdarea_command.bat
  • add_rdarea_control.txt
  • pdsys（グローバルバッファ（一時グローバルバッファを除く）を割り当てた場合
複写
  • change_rdarea_command.bat
  • add_rdarea_command.bat
  • add_rdarea_control.txt
  • pdsys（グローバルバッファ（一時グローバルバッファを除く）を割り当てた場合
名称変更
  • change_rdarea_command.bat
  • chg_rdarea_command.bat
  • chg_rdarea_control.txt
属性変更（オペランド更新）
データディクショナリ用RDエリア（再編成時期予測用） 追加
  • change_rdarea_command.bat
  • add_rdarea_dbm_command.bat
  • add_rdarea_dbm_control.txt
  • pdsys（グローバルバッファ（一時グローバルバッファを除く）を割り当てた場合
削除
  • change_rdarea_command.bat
  • del_rdarea_dbm_command.bat
  • del_rdarea_dbm_control.txt
  • pdsys（グローバルバッファ（一時グローバルバッファを除く）を割り当てた場合
移動
  • change_rdarea_command.bat
  • del_rdarea_dbm_command.bat
  • del_rdarea_dbm_control.txt
  • add_rdarea_dbm_command.bat
  • add_rdarea_dbm_control.txt
  • pdsys（グローバルバッファ（一時グローバルバッファを除く）を割り当てた場合
複写
  • change_rdarea_command.bat
  • add_rdarea_dbm_command.bat
  • add_rdarea_dbm_control.txt
  • pdsys（グローバルバッファ（一時グローバルバッファを除く）を割り当てた場合
名称変更
  • change_rdarea_command.bat
  • chg_rdarea_dbm_command.bat
  • chg_rdarea_dbm_control.txt
属性変更（オペランド更新）

  • レジストリ用RDエリア
  • レジストリLOB用RDエリア
 追加
  • change_rdarea_command.bat
  • add_rdarea_reg_command.bat
  • add_rdarea_reg_control.txt
  • pdsys（グローバルバッファ（一時グローバルバッファを除く）を割り当てた場合
削除
  • change_rdarea_command.bat
  • del_rdarea_reg_command.bat
  • del_rdarea_reg_control.txt
  • pdsys（グローバルバッファ（一時グローバルバッファを除く）を割り当てた場合
移動
  • change_rdarea_command.bat
  • del_rdarea_reg_command.bat
  • del_rdarea_reg_control.txt
  • add_rdarea_reg_command.bat
  • add_rdarea_reg_control.txt
  • pdsys（グローバルバッファ（一時グローバルバッファを除く）を割り当てた場合
複写
  • change_rdarea_command.bat
  • add_rdarea_reg_command.bat
  • add_rdarea_reg_control.txt
  • pdsys（グローバルバッファ（一時グローバルバッファを除く）を割り当てた場合
名称変更
  • change_rdarea_command.bat
  • chg_rdarea_reg_command.bat
  • chg_rdarea_reg_control.txt
属性変更（オペランド更新）
グローバルバッファ
  • グローバルバッファ
  • LOB用グローバルバッファ
  • インデクス用グローバルバッファ
  • その他用グローバルバッファ
 追加
  • pdsys
削除
複写
名称変更
属性変更（オペランド更新）
HiRDBファイルシステム領域
  • DB用ファイルシステム領域
  • SDB用ファイルシステム領域
  • SYS用ファイルシステム領域
  • SVR用ファイルシステム領域
  • WORK用ファイルシステム領域
  • UTL用ファイルシステム領域
 追加
  • add_hfs_command.bat
削除
  • del_hfs_command.bat
移動
  • del_hfs_command.bat
  • add_hfs_command.bat
複写
  • add_hfs_command.bat
名称変更
  • del_hfs_command.bat
  • add_hfs_command.bat
属性変更（オペランド更新）
  • del_hfs_command.bat
  • add_hfs_command.bat
システムファイル システムログファイル 追加
  • システムログファイルを追加したサーバと同名のファイル
  • change_systemfile_command.bat
  • add_systemlog_command.bat
削除
  • システムログファイルを削除したサーバと同名のファイル
  • change_systemfile_command.bat
  • del_systemlog_command.bat
移動
  • システムログファイル移動元のサーバと同名のファイル
  • システムログファイル移動先のサーバと同名のファイル
  • change_systemfile_command.bat
  • del_systemlog_command.bat
  • add_systemlog_command.bat
複写
  • システムログファイル複写先のサーバと同名のファイル
  • change_systemfile_command.bat
  • add_systemlog_command.bat
名称変更
  • 変更したシステムログファイルを配置しているサーバと同名のファイル
  • change_systemfile_command.bat
  • chg_systemlog_command.bat
属性変更（オペランド更新）
シンクポイントダンプファイル 追加
  • シンクポイントダンプファイルを追加したサーバと同名のファイル
  • change_systemfile_command.bat
  • add_sync_command.bat
削除
  • シンクポイントダンプファイルを削除したサーバと同名のファイル
  • change_systemfile_command.bat
  • del_sync_command.bat
移動
  • シンクポイントダンプファイル移動元のサーバと同名のファイル
  • シンクポイントダンプファイル移動先のサーバと同名のファイル
  • change_systemfile_command.bat
  • del_sync_command.bat
  • add_sync_command.bat
複写
  • シンクポイントダンプファイル複写先のサーバと同名のファイル
  • change_systemfile_command.bat
  • add_systemlog_command.bat
名称変更
  • 変更したシンクポイントダンプファイルを配置しているサーバと同名のファイル
  • change_systemfile_command.bat
  • chg_sync_command.bat
属性変更（オペランド更新）
ユニット用ステータスファイル 追加
  • pdutsys
  • change_systemfile_command.bat
  • add_status_unit_command.bat
削除
  • pdutsys
  • change_systemfile_command.bat
  • del_status_unit_command.bat
移動
  • 移動元のpdutsys
  • 移動先のpdutsys
  • change_systemfile_command.bat
  • del_status_unit_command.bat
  • add_status_unit_command.bat
複写
  • pdutsys
  • change_systemfile_command.bat
  • add_status_unit_command.bat
名称変更
  • pdutsys
  • change_systemfile_command.bat
  • chg_status_unit_command.bat
属性変更（オペランド更新）
サーバ用ステータスファイル 追加
  • サーバ用ステータスファイルを追加したサーバと同名のファイル
  • change_systemfile_command.bat
  • add_status_svr_command.bat
削除
  • サーバ用ステータスファイルを削除したサーバと同名のファイル
  • change_systemfile_command.bat
  • del_status_svr_command.bat
移動
  • サーバ用ステータスファイル移動元のサーバと同名のファイル
  • サーバ用ステータスファイル移動先のサーバと同名のファイル
  • change_systemfile_command.bat
  • add_status_svr_command.bat
  • del_status_svr_command.bat
複写
  • サーバ用ステータスファイル複写先のサーバと同名のファイル
  • change_systemfile_command.bat
  • add_status_svr_command.bat
名称変更
  • 変更したサーバ用ステータスファイルを配置しているサーバと同名のファイル
  • change_systemfile_command.bat
  • chg_status_svr_command.bat
属性変更（オペランド更新）
HAグループ 追加
  • pdsys
削除
名称変更


文字コード変換要否判定

付録E　文字コード変換要否判定

HiRDB Configuration Assistantが出力する定義ファイル，および環境構築用バッチファイルをHiRDBの環境に配置するときには，以下の判定表を用いて，文字コードの変換が必要かどうか判定してください。

表E-1　文字コード変換要否判定表

判定条件 |  |  | 文字コードの変換要否
構築対象となるHiRDBが使用する文字コード | 定義ファイル中でのマルチバイト文字の使用 | RDエリア名でのマルチバイト文字の使用
Shift-JIS | － | － | 不要
Shift-JIS以外 | 使用 | － | 必要
 | 未使用 | 使用 | 必要
 |  | 未使用 | 不要
  • －：その条件は判定不要であることを示します。


HiRDB構成情報の指定内容の詳細

付録F　HiRDB構成情報の指定内容の詳細

HiRDB Configuration Assistantで，ウィザードによりHiRDB構成情報を新規作成する場合に，「HiRDBの新規構築　指定内容の確認（４／４）ダイアログ」に表示される内容の詳細を以下に示します。

図F-1　 HiRDB構成情報の表示形式

表F-1　 HiRDB構成情報の表示内容の詳細

図中の番号 | 項目 |  |  | 内容
① | HiRDBが稼働するマシン名 |  |  | HiRDBが稼働するマシン名を表示します。
② | HiRDBのセットアップパス |  |  | HiRDBのセットアップパスを表示します。
③ | クライアント環境変数※1 |  |  | ユーザ側で設定が必要なクライアント環境変数を表示します。
④ | 同時接続数 |  |  | HiRDBに同時に接続する最大クライアント数を表示します。
⑤ | HiRDBが使用可能なメモリ量※2 |  |  | ユーザが指定したHiRDB使用可能メモリ量を表示します。
 | メモリ所要量見積もりサイズ※2 |  |  | HiRDB Configuration Assistantが算出した，HiRDBを運用するために必要なメモリサイズを表示します。
⑥ | アクセス頻度の高い表を格納するRDエリア構成 | (a) 主に蓄積を行う表を格納するRDエリア | 格納表数 | HiRDBに作成する表数を表示します。
 |  |  | データ容量 | 表の合計データ容量を表示します。
 |  |  | 自動増分指定 | RDエリアを自動増分するかどうかを表示します。
 |  |  | 用意するRDエリア名(データ用)※3 | データ用RDエリア名を表示します。
 |  |  | ページ長※3 | データ用RDエリアのページ長を表示します。
 |  |  | セグメントサイズ※3 | データ用RDエリアのセグメントサイズを表示します。
 |  |  | セグメント数※3 | データ用RDエリアのセグメント数を表示します。
 |  |  | 増分セグメント数※3 | データ用RDエリアの増分セグメント数を表示します。
 |  |  | グローバルバッファ※3 | データ用RDエリアのグローバルバッファ名を表示します。
 |  |  | グローバルバッファの面数※3 | データ用RDエリアのグローバルバッファ面数を表示します。
 |  |  | 用意するRDエリア名(インデクス用)※3 | インデクス用RDエリア名を表示します。
 |  |  | ページ長※3 | インデクス用RDエリアのページ長を表示します。
 |  |  | セグメントサイズ※3 | インデクス用RDエリアのセグメントサイズを表示します。
 |  |  | セグメント数※3 | インデクス用RDエリアのセグメント数を表示します。
 |  |  | 増分セグメント数※3 | インデクス用RDエリアの増分セグメント数を表示します。
 |  |  | グローバルバッファ※3 | インデクス用RDエリアのグローバルバッファ名を表示します。
 |  |  | グローバルバッファの面数※3 | インデクス用RDエリアのグローバルバッファ面数を表示します。
 |  | (b) 主に参照を行う表を格納するRDエリア |  | データ参照用の表を格納するRDエリアの情報を表示します。表示項目の詳細については，⑥(a)を参照してください。
 |  | (c) 主に登録/更新/削除を行う表を格納するRDエリア |  | データ登録/更新/削除用の表を格納するRDエリアの情報を表示します。表示項目の詳細については，⑥(a)を参照してください。
 |  | (d) 主に更新を行う表を格納するRDエリア |  | データ更新用の表を格納するRDエリアの情報を表示します。表示項目の詳細については，⑥(a)を参照してください。
⑦ | アクセス頻度の低い表を格納するRDエリア構成 |  |  | アクセス頻度の低い表を格納するRDエリアの構成情報を表示します。表示項目の詳細については，⑥を参照してください。
⑧ | アクセス頻度の高い表のデータ/インデクスを配置するパス | 格納パス |  | アクセス頻度の高い表のデータ/インデクスを配置するパスを表示します。
 |  | 必要ディスクサイズ |  | アクセス頻度の高い表のデータ/インデクスを配置するディスクに必要なサイズを表示します。
⑨ | アクセス頻度の低い表のデータ/インデクスを配置するパス | 格納パス |  | アクセス頻度の低い表のデータ/インデクスを配置するパスを表示します。
 |  | 必要ディスクサイズ |  | アクセス頻度の低い表のデータ/インデクスを配置するディスクに必要なサイズを表示します。
⑩ | トランザクションログを配置するパス | 格納パス |  | トランザクションログを配置するパスを表示します。
 |  | 必要ディスクサイズ |  | トランザクションログを配置するディスクに必要なサイズを表示します。
⑪ | トランザクションログのバックアップ先のパス | 格納パス |  | トランザクションログのバックアップ先のパスを表示します。
⑫ | 選択した機能 | (a) 系切り替え |  | 系切り替え構成の適用有無を表示します。系切り替え構成を適用する場合，予備系マシン名も表示されます。
 |  | (b) データベースの回復範囲 |  | 障害時におけるデータベースの回復範囲を表示します。
 |  | (c) 監査証跡の取得 |  | 監査証跡の取得有無を表示します。
⑬ | 見直し対象オペランド |  |  | ウィザードによる新規作成が完了した後に，適用するシステムに合わせて変更するオペランドを表示します。

※1 「指定内容」を指定した場合，以下の2つの環境変数は表示されません。

  • PDHOST
  • PDSERVICEGRP

※2 （HiRDBが使用可能なメモリ量）＜（メモリ所要量見積もりサイズ）の場合，以下のいずれかの方法で（HiRDBが使用可能なメモリ量）＞（メモリ所要量見積もりサイズ）とする必要があります。

  • HiRDBが使用可能なメモリ量の指定値を大きくする
  • 使用する表数，データ容量を小さくする

※3 「指定内容」を指定した場合には表示されません。


環境構築例

付録G　環境構築例

HiRDB Configuration Assisitantを使用してHiRDBの環境を構築する例を示します。

＜この節の構成＞
付録G.1　系切り替え構成の構築


系切り替え構成の構築

付録G.1　系切り替え構成の構築

HiRDBを系切り替え構成とする場合，以下に示す手順で，系切り替え構成を構築します。

＜この項の構成＞
(1)　スタンバイ型系切り替えの場合
(2)　影響分散スタンバイレス型切り替えの場合
(3)　相互系切り替え構成の場合

(1)　スタンバイ型系切り替えの場合

スタンバイ型系切り替えの場合の手順を以下に説明します。

  1. 実行系ユニットの追加
    実行系のマシン（HOST_A）に対して，実行系のユニット（U001）を追加します。

    参考
    「3.4.1(2)　ユニットの追加」

  2. 待機系ユニットの追加
    続いて，待機系のマシン（HOST_B）を追加し，そのマシンに待機系のユニットを追加します。

    参考
    「3.4.1(2)　ユニットの追加」

  3. 実行系ユニットと待機系ユニットの関連付け
    待機系ユニットを追加すると，［スタンバイ型系切り替え詳細ダイアログ］が表示されます。このダイアログで，待機系ユニットをどの実行系ユニットの待機系とするのかを選択します。

    ［ユニット］から実行系のユニット（U001）を選択して［OK］ボタンをクリックします。

    待機系のマシン（HOST_B）に，"U001(Standby)"という名称で，待機系ユニットが追加されます。

(2)　影響分散スタンバイレス型切り替えの場合

影響分散スタンバイレス型系切り替えの場合の手順を以下に説明します。

  1. HAグループの追加
    HiRDBにHAグループ（HA001）を追加します。

    参考
    「3.4.1(10)　HAグループの追加」

  2. HAグループへのユニット配置
    続いて，HAグループにユニットを配置します。例では，U001，U002の2個のユニットを，HAグループ（HA001）に配置します。

    参考
    「3.4.6(5)　HAグループの属性変更」

    構成図上では，HAグループに配置したユニットの右上部にHAグループ名（HA001）が表示されます。

    ツリービュー上でHAグループ（HA001）を選択すると，構成情報ビューの［HAグループ］タブに，HAグループに配置されたユニットが一覧表示されます。

    参考
    「3.4.5(7)　HAグループの一覧参照」

(3)　相互系切り替え構成の場合

相互系切り替え構成の場合の手順を以下に説明します。

ここでは，以下に示す構成を構築します。

表G-1　ユニットに対応するマシン

ユニット | マシン
Unt1 | Host1
Unt1（待機系） | Host2A（Host2のエイリアス）
Unt2 | Host2
Unt2（待機系） | Host1A（Host1のエイリアス）

HiRDB Configuration Assistant上で，上記に示した相互系切り替え構成を定義する場合，以下のような構成で定義してください。

参考
マシン，ユニットの追加方法に関しては，「3.4.1(1)　マシンの追加」「3.4.1(2)　ユニットの追加」を参考にしてください。


サンプルファイル

付録H　サンプルファイル

HiRDB Configuration Assistantが提供するサンプルファイルの詳細を説明します。

＜この節の構成＞
付録H.1　サンプルファイルの格納場所
付録H.2　サンプルファイルのHiRDB構成
付録H.3　サンプルファイルの構成要素の状態


サンプルファイルの格納場所

付録H.1　サンプルファイルの格納場所

サンプルファイルは，以下のパスに格納されています。

(インストールフォルダ)\sample\sample.xml

このサンプルファイルを直接開かず，任意の場所にコピーしてご使用ください。


サンプルファイルのHiRDB構成

付録H.2　サンプルファイルのHiRDB構成

サンプルファイルのHiRDB構成を以下に示します。

表H-1　サンプルファイルのHiRDB構成

項目 | 値
HiRDBバージョン | 10-01
HiRDB種別 | Single Server
HiRDBアドレッシングモード | 64bit
OS種別 | Windows
HiRDB運用ディレクトリ | C:\win32app\hitachi\hirdb_s
DB容量（ディスク容量）
  • システムファイル用 2GB
  • RDエリア用 4.1GB
  • 共用メモリ用 1.7GB
  • その他 1GB
メモリ容量 | 2GB以上
HiRDBファイルシステム領域（DB用）
  • D:\hirdb_s\area\rddb002
  • D:\hirdb_s\area\rddb003
  • D:\hirdb_s\area\rddb004
  • D:\hirdb_s\area\rddb005
  • D:\hirdb_s\area\rddb006
HiRDBファイルシステム領域（SYS用）
  • C:\win32app\hitachi\hirdb_s\area\rdsys011
  • C:\win32app\hitachi\hirdb_s\area\rdsys012
  • C:\win32app\hitachi\hirdb_s\area\rdsys013
  • C:\win32app\hitachi\hirdb_s\area\rdsys014
  • C:\win32app\hitachi\hirdb_s\area\rdsys015
  • C:\win32app\hitachi\hirdb_s\area\rdsys016
  • C:\win32app\hitachi\hirdb_s\area\rdsysl11
  • C:\win32app\hitachi\hirdb_s\area\rdsysl12
  • C:\win32app\hitachi\hirdb_s\area\rdsysl13
  • C:\win32app\hitachi\hirdb_s\area\rdsysl14
  • C:\win32app\hitachi\hirdb_s\area\rdsysl15
  • C:\win32app\hitachi\hirdb_s\area\rdsysl16
  • C:\win32app\hitachi\hirdb_s\area\rdsys017
  • C:\win32app\hitachi\hirdb_s\area\rdsys018
  • C:\win32app\hitachi\hirdb_s\area\rdsys019
  • C:\win32app\hitachi\hirdb_s\area\rdsys020
  • C:\win32app\hitachi\hirdb_s\area\rdsysl17
  • C:\win32app\hitachi\hirdb_s\area\rdsysl18
  • C:\win32app\hitachi\hirdb_s\area\rdsysl19
  • C:\win32app\hitachi\hirdb_s\area\rdsysl20
RDエリア
  • RDMAST(マスタディレクトリ用RDエリア)
  • RDDIRT(データディレクトリ用RDエリア)
  • RDDICT(データディクショナリ用RDエリア)
  • DIC_RTN_SRC(データディクショナリ用RDエリア(ルーチン用))
  • DIC_RTN_OBJ(データディクショナリ用RDエリア(ルーチン用))
  • RDDATA10(ユーザ用RDエリア)
  • RDINDX10(ユーザ用RDエリア)
  • RLOB1(LOB用RDエリア)
グローバルバッファ | 6個（gbuf01～gbuf06）
システムログ | 10個（log1～log10）
シンクポイントダンプ | 7個（spd1～spd7）
ユニットステータスファイル | 5個（utsts1～utsts5）
サーバステータスファイル | 5個（sts1～sts5）


サンプルファイルの構成要素の状態

付録H.3　サンプルファイルの構成要素の状態

サンプルファイルの構成要素は，すべて新規状態となります。


用語解説

付録I　用語解説

HiRDB Confituration Assistantで使用する用語について解説します。

<カ行>

確定状態
構成要素の状態の1つです。確定状態取り込みで取り込んだ構成要素を「確定状態の構成要素」と呼びます。確定状態の構成要素は，既存HiRDBにすでに存在する構成要素を示しているため，その構成要素に対する操作は制限されます。
確定状態取り込み
既存HiRDBの情報を，すべて確定状態で取り込む機能です。構築済みのHiRDB環境に対して構成変更を行う際に使用します。
確定状態ファイル
構築済みのHiRDB環境に対して構成変更を行うためのHiRDB構成情報ファイルです。確定状態取り込みで作成します。
環境構築用バッチファイル
HiRDB Configuration Assistantの定義出力機能で生成される，HiRDBの定義ファイルを，HiRDBを構築するマシンに適用するためのバッチファイルです。
クリック
マウスの左ボタンを押すことを指します。
構成図
HiRDBの構成情報をイメージ表示する画面です。
構成要素
HiRDB Configuration Assistantで操作可能な，HiRDBを構成する物理的，または論理的な要素です。HiRDB Configuration Assistantでは以下の構成要素を扱うことができます。
  • マシン
  • ユニット
  • サーバ
  • RDエリア
  • グローバルバッファ
  • HiRDBファイルシステム領域
  • システムファイル
  • HAグループ

<サ行>

サンプルファイル
HiRDBを使用する用途に合わせてHiRDB Configuration Assistantで作成した構成情報ファイルです。
実行系ユニット
系切り替え構成の実行系に配置するユニットです。
新規状態
構成要素の状態の1つです。新規状態取り込みで取り込んだ，またはHiRDB Configuration Assistant内で新たに追加した構成要素を「新規状態の構成要素」と呼びます。新規状態の構成要素は，自由に操作することができます。
新規状態取り込み
既存HiRDBの情報を，すべて新規状態で取り込む機能です。構築済みのHiRDBの環境を参考に，新しいHiRDB環境を作成する際に使用します。
新規状態ファイル
HiRDBを新規に構築するためのHiRDB構成情報ファイルです。新規作成，または新規状態取り込みで作成します。

<タ行>

待機系ユニット
系切り替え構成の待機系に配置するユニットです。
チェック用バッチファイル
HiRDB Configuration Assistantのシステム定義のチェック機能で作成するバッチファイルです。HiRDB Configuration Assistantがシステム定義のチェックを実行するために使用します。
ツリービュー
HiRDBの構成情報をツリー構造で表示する画面です。
定義出力
HiRDB Configuration Assistantで定義したHiRDBの構成をHiRDBを構築するマシン上に構築するための定義ファイル，および環境構築用バッチファイルを生成する機能です。新規にHiRDBの環境を構築する場合と，既存のHiRDBの環境を変更する場合とで出力されるファイルが異なります。
定義取り込み
既存のHiRDBの情報をHiRDB Configuration Assistantに取り込む機能です。取り込んだ情報は，HiRDB Configuration Assistant上で編集することができます。定義取り込み機能には，「確定状態取り込み機能」と「新規状態取り込み機能」の2種類があります。
定義ファイル
HiRDB Configuration Assistantの定義出力機能で生成する，HiRDBのシステム定義ファイルです。
  • システム共通定義
  • ユニット制御情報定義
  • サーバ共通定義
  • シングルサーバ定義
  • フロントエンドサーバ定義
  • ディクショナリサーバ定義
  • バックエンドサーバ定義

<ハ行>

HiRDB構成情報ファイル
HiRDB Configuration Assistantで管理するHiRDBの構成を記述したファイルです。HiRDB構成情報ファイルには，「新規状態ファイル」，「確定状態ファイル」の2つの種別があります。
HiRDB構成情報
HiRDB Configuration Assisitant上で表現される，HiRDBの構成を指します。
バッチファイル
Windowsのbat拡張子付きのファイル，およびUNIXのシェルスクリプトファイルの総称です。

<マ行>

右クリック
マウスの右ボタンを押すことを指します。
メッセージボックス
本製品がメッセージを出力するウィンドウです。Windowsが提供するメッセージダイアログの形式で出力します。

<ヤ行>

ユニット
非系切り替え構成におけるユニット，および系切り替え構成における実行系ユニットと，待機系ユニットの総称です。
容量計算
HiRDB構成情報をもとに，以下の容量を計算する機能です。
  • HiRDBの起動に必要なメモリサイズ
  • HiRDBが使用するディスクサイズ