HiRDB SQL Executerの概要

HiRDB SQL Executerとは

HiRDB SQL Executerのメニュー

環境設定ダイアログ


HiRDB SQL Executerとは

●機能概要

HiRDB SQL Executer（ＧＵＩ版）は、HiRDBデータベースに対して会話形式でSQLを実行させることができる会話型SQL実行プログラムです。

ＧＵＩ版とは、HiRDB SQL Executer専用の入力ウインドウやファイルからSQL・pdsqlコマンドを入力し、その実行結果をHiRDB SQL Executer専用の出力ウインドウやファイルに出力するインタフェースを提供します。

またSQLを入力しなくとも画面操作により、ユーザデータの検索や、ディクショナリの情報を見ることができます。提供対象のプラットフォームは、Windowsのみです。

SJIS版のプログラムとUnicode版のプログラムがあります。SJIS版とUnicode版の違いについては、「 SJIS版とUnicode版の違い」を参照してください。

●実行者

HiRDBの接続権限を持つユーザが実行できます。

ただし、実行するSQLによっては、さらに上位の権限が必要になります。

●規則

・ | 本プログラムは、HiRDBが稼働中のときだけ実行できます。
・ | 本プログラムの実行結果をファイルに出力するには、リダイレクションによって標準出力の出力先をファイルに変更して出力します。 (例) pdsql > outfile また、検索結果のみをファイルに出力する場合は、PUTFILEコマンドを使用してください。
・ | 小文字で入力したSQLは大文字に変換されます。小文字を使用する場合は、小文字を引用符( " ) で囲んでください。 (例) INSERT INTO "t1" VALUES(1000);
・ | 実行できるSQL文・pdsqlコマンドの長さは最大2,000,000バイト(Unicode版の場合は2,000,000文字)です。
・ | 一行の表示結果又はファイル出力結果が2097152バイトを超える検索はできません。
・ | セミコロン又は END_PROC ;, END_FUNC ;, END_TYPE ; END_TRIG ; が行の最後に記述してある場合は、SQL文中の引用符号 ( " ) で囲まれたセミコロン又は END_PROC ;, END_FUNC ;, END_TYPE ; END_TRIG ; であってもＳＱＬ文の終了とみなされます。
・ | ファイル／ディレクトリ名に円記号以外の記号文字または空白文字を含む場合は、ファイル／ディレクトリ名を引用符( " ) で囲んでください。（Windowsのみの仕様）
・ | ＳＱＬ文中のコメントは接続するサーババージョンによって処理が異なります。
 | ・ | サーババージョンが06-01以前のとき、コメントを１つの空白に置き換えてＳＱＬ文をサーバ側に送信します。コメントの終了記号が存在しないときは、行末までをコメントとして置き換えます。
 | ・ | サーババージョンが06-02以降のとき、コメントを編集せずにＳＱＬ文をサーバ側に送信します。
・ | 次の場所にはコメント「/*～*/」を記述できません。
 | ・ | pdsqlコマンドの中(※1)。
 | ・ | CREATE PROCEDUREのCREATEとPROCEDUREの間。
 | ・ | CREATE FUNCTIONのCREATEとFUNCTIONの間。
 | ・ | CREATE TYPEのCREATEとTYPEの間。
 | ・ | CREATE TRIGGERのCREATEとTRIGGERの間。
 | ・ | END_PROC;、END_FUNC;、END_TYPE;およびEND_TRIG;と同じ行の中。
※1：pdsqlコマンドの前(改行とpdsqlコマンドの間)と後ろ(セミコロン( ; )と改行の間)にはコメントを記述できます。
・ | SQL文の区切り文字には，次の文字を指定できます。
 | ・ | 空白（X'20'）
 | ・ | TAB（X'09'）
 | ・ | コメント(※2)
 | ・ | 全角空白(※2)
※2：コメントと全角空白は次の場所に記述できません。
 | ・ | CREATE PROCEDUREのCREATEとPROCEDUREの間。
 | ・ | CREATE FUNCTIONのCREATEとFUNCTIONの間。
 | ・ | CREATE TYPEのCREATEとTYPEの間。
 | ・ | CREATE TRIGGERのCREATEとTRIGGERの間。
 | ・ | END_PROC;、END_FUNC;、END_TYPE;およびEND_TRIG;と同じ行の中。
・ | pdsqlコマンドの区切り文字には，次の文字を指定できます。
 | ・ | 空白（X'20'）
 | ・ | TAB（X'09'）
・ | 次の改行コードはSQL・pdsqlコマンドの任意の位置に挿入できます。
 | ・ | NL（X'0a'）
 | ・ | CR（X'0d'）
 | SQL・pdsqlコマンドに指定された改行コードはSQL・pdsqlコマンドを実行する前に全て除去されます。したがって、
 | ・ | 文字列定数の途中に改行コードを挿入することにより、長い文字列定数を複数行に分けて記述することができます。改行コードは文字列定数の値から除去されます。
 | ・ | 改行コードを区切り文字として使用できません(※3)。
※3：END_PROC;、END_FUNC;、END_TYPE;およびEND_TRIG;の直前の改行コードだけは例外的に区切り文字として処理します。
・ | XDM/RD E2 に接続している場合にナル値の規定値設定機能を使用する場合は、 XDM/RD E2のRD環境定数のDEFAULT NULL VALUE OPTION句でナル値の既定値を設定すると同時に、 環境変数PDDFLNVAL=USE を設定してください。
・ | 検索結果中に、BINARY/BLOB/CLOB型を含む場合、以下の動作となります。 SJIS版SQL Executerでは、HiRDBサーバが使用する文字コード種別がシフトJISコード以外のとき、 ASCIIコード以外の文字が含まれていると文字化け及びカラムずれが発生します。 Unicode版SQL Executerでは、HiRDBサーバが使用する文字コード種別がUnicode(UTF-8)以外のとき、 ASCIIコード以外の文字が含まれていると文字化け及びカラムずれが発生します。


HiRDB SQL Executerのメニュー

HiRDBとの接続処理後、 HiRDB SQL Executerメインウインドウが表示されます。

メインウインドウに表示されるウインドウは次のとおりです。

［SQL入力］ウインドウ | SQL又はpdsqlコマンドを入力するウインドウです。
［出力］ウインドウ | SQL又はpdsqlコマンドを実行した結果及び、データディクショナリビューウインドウ上でビューや手続きの定義情報を表示する操作を行った結果を表示するウインドウです。
［ﾃﾞｨｸｼｮﾅﾘﾋﾞｭｰ］ウインドウ | 現在接続をしているデータベースのディクショナリ情報を表示するウインドウです。
［ﾃﾞｨｸｼｮﾅﾘ詳細］ウインドウ | ディクショナリビューウインドウにて選択された項目の詳細を表示するウインドウです。

  また、接続状態のときメインウインドウのタイトルバーに、接続先ホストのコンピュータ名（もしくはホスト名で指定した値）、ポート番号、認可識別子をコロンで区切り表示します。

メインウインドウに表示されるメニューの項目は次のとおりです。

［ファイル(F)］ | ［ＳＱＬ入力(I)］ | SQL入力ウインドウを作成、表示します。 SQL入力ウインドウは最大４ウインドウまで表示できます。
 | ［ファイルから実行(E)...］ | ファイル中に記述されたSQL、コマンドを読み込み、実行します。
 | ［接続(C)...］ | HiRDBに接続します。 接続状態のときは選択不可となります。(*1)
 | ［切り離し(D)］ | HiRDBから切り離します。 非接続状態のときは選択不可となります。(*1)
 | ［終了(X)］ | HiRDB SQL Executerを終了します。
［編集(E)］ | ［元に戻す(U)］ | 前回の編集操作を取り消します。
 | ［やり直し(R)］ | 前回の編集操作をやり直します。
 | ［切り取り(T)］ | 選択範囲を切り取ってクリップボードにコピーします。
 | ［コピー(C)］ | 選択範囲をクリップボードにコピーします。
 | ［貼り付け(P)］ | クリップボードの内容をカーソル位置に貼り付けます。
 | ［削除(E)］ | 選択範囲を削除します。
 | ［すべて選択(A)］ | アクティブウインドウの内容をすべて選択します。
 | ［すべて削除(D)］ | アクティブウインドウの内容をすべて削除します。
 | ［検索(F)...］ | 検索ダイアログを表示します。
 | ［次を検索(N)］ | アクティブウインドウ内にある指定された文字列を検索または置換します。検索または置換は、前回の操作によって切り替わります。
 | ［置換(L)］ | 置換ダイアログを表示します。
 | ［高度な操作(V)］ | ［大文字に変換(U)］ | 選択範囲の半角英小文字を 半角英大文字に変換します。
 |  | ［小文字に変換(L)］ | 選択範囲の半角英大文字を 半角英小文字に変換します。
［表示(V)］ | ［ツールバー］ | ツールバーの表示／非表示を切り替えます。
 | ［ステータスバー］ | ステータスバーの表示／非表示を切り替えます。
 | ［ディクショナリビュー ウインドウ］ | ディクショナリビューウインドウの表示／非表示を切り替えます。
 | ［ディクショナリ詳細 ウインドウ］ | ディクショナリ詳細ウインドウの表示／非表示を切り替えます。
 | ［出力の切り替え］ | 出力ウインドウの表示内容を切り替えます。（結果⇔データ）
［操作(C)］ | ［SQL実行(E)］ | 入力したSQL・pdsqlコマンドを実行します。
 | ［SQL履歴(H)...］ | 実行したSQL・pdsqlコマンドの履歴を表示します。
 | ［インポート(I)］ | ファイルから選択している表にデータを取り込みます。 入力するデータの形式は、拡張DAT形式(*2)としてください。
 | ［エクスポート(X)］ | 選択している表からファイルにデータを出力します。 出力するデータの形式は、拡張DAT形式(*2)です。
［設定(S)］ | ［フォント(F)...］ | アクティブウインドウのフォントを設定します。
 | ［環境設定(V)...］ | 実行環境を設定するダイアログを表示します。
［ウインドウ(W)］ | ［重ねて表示(C)］ | ウインドウを重ねて表示します。(*3)
 | ［上下に並べて表示(H)］ | ウインドウを上下に並べて表示します。(*3)
 | ［左右に並べて表示(T)］ | ウインドウを左右に並べて表示します。(*3)
 | ［アイコンの整列(A)］ | 最小化されているウインドウのアイコンを整列します。(*3)
［ヘルプ(H)］ | ［トピック検索(H)...］ | ヘルプを表示します。
 | ［バージョン情報(V)...］ | バージョン情報を表示します。

*1：HiRDBサーバが切断した場合（監視時間による切断など）非接続状態となっていても選択可否の状態が接続状態のままとなることがあります。再接続を行うには、[切り離し]を選択し、[接続]を選択してください。

*2：拡張DAT形式については、HiRDBコマンドリファレンス:データベース作成ユティリティ(pdload)を参照してください。

*3：常に選択できません。

  メインウインドウに表示されるツールバーの項目は次のとおりです。

アイコン図 | 名称(カーソルを置いたときに表示される名称) | 説明
* | 切り取り | 選択範囲を切り取ってクリップボードにコピーします。
* | コピー | 選択範囲をクリップボードにコピーします。
* | 貼り付け | クリップボードの内容をカーソル位置に貼り付けます。
* | 元に戻す | 前回の編集操作を取り消します。
* | やり直し | 前回の編集操作をやり直します。
* | 検索 | 左側のコンボボックスに入力された文字列を検索します。
* | ディクショナリビューウインドウ | ディクショナリビューウインドウの表示／非表示を切り替えます。
* | ディクショナリ詳細ウインドウ | ディクショナリ詳細ウインドウの表示／非表示を切り替えます。
* | ＳＱＬ実行 | 入力したSQL・pdsqlコマンドを実行します。
 | ＳＱＬ履歴 | 実行したSQL・pdsqlコマンドの履歴を表示します。
 | インポート | ファイルから選択している表にデータを取り込みます。 入力するデータの形式は、拡張DAT形式としてください。
 | エクスポート | 選択している表からファイルにデータを出力します。 出力するデータの形式は、拡張DAT形式です。
* | バージョン情報 | バージョン情報を表示します。


環境設定ダイアログ

  メニューより[ファイル(F)] － [環境設定(V)...]を選択すると、環境設定ダイアログを表示します。

項目 | 内容
[入力バッファ]テキストボックス | SQL入力ウインドウにて入力できる文字の文字数を指定します。 指定可能な範囲：６４０００～３００００００(*1) 初期値 ：２０００００
[結果画面]テキストボックス | 出力ウインドウの[結果]タブに出力できる行数を指定します。 出力できる行数を超えて出力するときは、一番古い行から削除されます。 指定可能な範囲：１０００～２００００ 初期値 ：１０００
[データ画面]テキストボックス | 出力ウインドウの[データ]タブに出力できる行数を指定します。 出力できる行数を超えるデータは出力されません。全て出力できなかった旨のメッセージおよび、全件データ数は、ステータスバー領域に表示されます。必要に応じて、ファイルへのエクスポートや、抽出条件の絞込みをしてください。 指定可能な範囲：１００～２００００ 初期値：１００
[履歴格納]テキストボックス | ＳＱＬ、コマンド入力の履歴をおこなう数を指定します。 指定可能な範囲：１００～２０００ 初期値：１００
[改行入力でのＳＱＬ実行]ラジオボタン | 「する」を選択： 文の終端（セミコロン）の存在を確認し、コマンド・SQLを実行します。 「しない」を選択： 文の終端を確認せずに、改行だけを行います。 注）「しない」を選択したときは、F5キーの入力またはメニュー［操作(C)］―［SQL実行(E)］を選択するとコマンド・ＳＱＬの実行を行います。

*1：改行文字を考慮し、HiRDBのSQL最大長(２００００００)より十分に大きな値を確保できるようにしています。

●留意事項

  本設定は、次回起動時に引き継がれます。


使い方

HiRDBと接続する

SQL･pdsqlコマンドを実行する

SQL･pdsqlコマンドの履歴を表示する

ディクショナリビューウインドウ／ディクショナリ詳細ウインドウを閲覧する

文字列を検索／置換する

実行できるSQL

実行できるpdsqlコマンド

トラブルシュート


HiRDBと接続する

本プログラムを起動すると、HiRDBとの接続処理が実行されます。接続は次の手順でおこなわれます。

●HIRDB.INIまたは環境変数にPDUSER,PDHOST,PDNAMEPORTが設定されている場合

設定されているPDUSERは認可識別子／パスワード、PDHOST,PDNAMEPORTをそれぞれホスト名、ポート番号の値としてHiRDBに接続します。両方に設定されている場合は、環境変数の設定値を使用します。

●HIRDB.INIおよび環境変数にPDUSER,PDHOST,PDNAMEPORTが設定されていない場合

本プログラム起動後に、次の図のようなCONNECTウインドウが表示され、認可識別子／パスワード、ホスト名、ポート番号を入力します。

[認可識別子(I)]/[パスワード(P)]/[ホスト名(H)]/[ポート番号(N)]テキストボックス：

認可識別子およびパスワードを引用符(")で囲んだ場合は、英大文字と英小文字が区別されます。引用符で囲まない場合は、すべて英大文字として扱われます。

また、本プログラム起動時の引数に"-u 認可識別子"、"-h ホスト名"、"-n ポート番号"をそれぞれ指定しておくと、CONNECTウインドウに認可識別子、ホスト名、ポート番号がデフォルト値として表示されます。ただし、"-u 認可識別子/パスワード"を指定した場合は、指定した値をそれぞれ認可識別子とパスワードとして使用しHiRDBに接続するためCONNECTウインドウは表示されません。引数はショートカットアイコンのプロパティのリンク先などで設定します。スタートメニューには起動用バッチファイルへのショートカットが登録されます。

＜例＞ c:￥Program files￥hitachi￥pdsql￥pdsqlw.exe -u hirdb
（注）認可識別子を引用符付きで表示したい場合は￥"…￥"で囲みます。
 | c:￥Program files￥hitachi￥pdsql￥pdsqlw.exe -u ￥"root￥"
 |  | pdsqlw.exe はSJIS版のプログラムです。
 |  | Unicode版を起動する場合はpdsqlw.exeをpdsqlwu.exeに変更します。
 |  | 起動用バッチファイルを使用する場合はpdsqlw.exeをpdsqlwx.batに変更します。

最大入力長は、認可識別子が１０文字、パスワードが３２文字、ホスト名が２５６文字、ポート番号が１０文字です。

[認可識別子/[パスワードを記憶する(R)]チェックボックス：

  チェックを外すと、次回の接続処理にて本ウインドウで入力された認可識別子／パスワードを引き継いで使用しません。インストール直後の規定値は、チェック状態です。

[OK]ボタン：

  HiRDBに接続します。パスワードを空欄としたときは、認可識別子の入力値をパスワードに仮定し接続します。接続が成功したときは、SJIS版またはUnicode版HiRDB SQL Executerメインウインドウを表示します。接続が失敗したときは、メッセージ出力した後、入力された情報を残した状態で再度CONNECTウインドウを表示します。

[ｷｬﾝｾﾙ]ボタン：

  接続処理を行わずに、SJIS版またはUnicode版HiRDB SQL Executerメインウインドウへ画面遷移します。

ダイアログに表示されるホスト名、ポート番号の一覧を削除したい場合、レジストリ情報のpdsqlcon.envエントリを削除して下さい。

HiRDBとの接続処理後、次の図のようなHiRDB SQL Executerメインウインドウが表示されます。


SQL･pdsqlコマンドを実行する

SQL入力ウインドウに実行したいSQL・pdsqlコマンドを入力し、メニューより［操作］―［実行］を選択するとSQL・pdsqlコマンドが実行されます。実行結果は、次の図のように出力ウインドウに表示します。

また、ファイルにあらかじめ実行したいSQL・pdsqlコマンドを作成しておきメニューより［ファイル］―［ファイルからの実行］を選択することにより実行することもできます。

出力ウインドウの［結果］タブでは検索結果や、pdsqlコマンドの実行結果、メッセージなどを表示します。

[データ]タブでは直前に実行した検索結果(*1)(*2)を行・列の区切り線がある表形式で表示します。

検索ＳＱＬ又は検索コマンドを実行しデータが存在したときは、[データ]タブに切替り表示します。(*3)その他の場合は、[結果]タブにて切替り表示します。

*1：BINARY/BLOB/CLOB型はサポートしていません。常に空白表示となります。

*2：以下のコマンドを実行しても[データ]タブ上の検索結果には有効となりません。

[結果] タブ上の出力には有効となります。

     ・SET ARRAY DISPLAY MODE NUM ：常にDATA

・SET DUMPMODE ON ：常にOFF

*3：SET TBLMODEコマンドにより、「検索結果をリスト形式で表示」としていた場合は、切り替えを行いません。

SQL入力ウインドウ上のテキスト編集領域にて右クリックすると次のメニューが表示され、操作が行えます。

［元に戻す(U)］ | 編集した操作を直前の状態に戻します。
［やり直し(R)］ | 編集した操作をやり直します。
［切り取り(T)］ | 選択範囲のデータを切り取ってクリップボードにコピーします。
［コピー(C)］ | 選択範囲のデータをクリップボードにコピーします。
［貼り付け(P)］ | クリップボードの内容をカーソル位置に貼り付けます。
［すべて選択(A)］ | すべてのセルを選択します。
［検索(F)...］ | 検索ダイアログを表示します。

出力ウインドウの[結果]タブ上のテキスト領域にて右クリックすると次のメニューが表示され、操作が行えます。

［コピー(C)］ | 選択範囲のデータをクリップボードにコピーします。
［すべて選択(A)］ | すべてのテキストを選択します。
［すべて削除(D)］ | すべてのテキストを削除します。
［検索(F)...］ | 検索ダイアログを表示します。

出力ウインドウの[データ]タブ上の表領域にて右クリックすると次のメニューが表示され、操作が行えます。

［コピー(C)］ | 選択範囲のデータをクリップボードにコピーします。
［すべて選択(A)］ | すべてのセルを選択します。
［検索(F)...］ | 検索ダイアログを表示します。
［表示ﾃﾞｰﾀをｴｸｽﾎﾟｰﾄ］ | 画面出力しているデータを拡張DAT形式にて指定したファイルに出力します。(*1)

*1：NULL値の場合、表示されている内容が出力されます。


SQL･pdsqlコマンドの履歴を表示する

メニュー[操作(V)] ―[SQL履歴(H)...]を選択、又はツールバー[SQL履歴]ボタンを押下、又は？パラメタ入力ダイアログの「入力履歴」ボタンを押した時、既に実行したSQL・pdsqlコマンドの一覧および？パラメタの値が表示できます。

表示されたSQL・pdsqlコマンドおよび？パラメタの値を、「SQL入力ウインドウ」、又は？パラメタ入力ダイアログの「値編集領域」に取り込んで利用することができます。以下にSQL履歴ウインドウを示します。

①

● SQL履歴ウインドウの操作

SQL履歴ウインドウは、SQL及び？パラメタの値をツリー形式で表示します（注２）。SQLは、実行した順序でツリーの下に追加されていきます。

各ボタンの機能は、次のとおりです。

「取込み」 | 選択されているSQL又は？パラメタの値を、「SQL入力ウインドウ」又は？パラメタ入力ダイアログの「値編集領域」にコピーします。マウスの左ダブルクリックでもこの操作が行えます。
「一括取込み」 | 選択されているSQLの？パラメタの値を、一括して？パラメタ入力ダイアログの「要求パラメタリスト」に取り込みます。実行しようとしているSQLと同じSQLでない場合、エラーとなります。
「削除」 | 選択されているSQLを履歴から削除します。(*3)
「全て削除」 | 履歴を全て削除します。（*3）
「ﾌｧｲﾙに保存」 | 履歴をファイルに保存します。(*1)
「閉じる」 | SQL履歴ウィンドウを閉じます。
「履歴ツリー」(上図の①) | SQL及び？パラメタの値をツリー形式で表示します。(*2) SQLを実行した順にツリーの下に追加されていきます。

*1：ファイルから実行できる形式で保存します。

*2：SQLおよび？パラメタに、改行文字(0x0d0a)及びタブ文字が含まれていても表示はされません。

*3：？パラメタ入力ダイアログが表示されているときは実行できません。

●留意事項

・「Tab」キーを押すごとにコントロールのフォーカスが、左上から右下に向かって移動します。

・HiRDB SQL Executerを終了しても履歴は保持されます。

●履歴のログについて

＜履歴ログファイル＞

・Executer起動時に前回終了時の履歴を履歴ログファイルから読み込みます。

・Executerを正常に終了させた場合、履歴を履歴ログファイルに出力します。

・Executerインストールディレクトリに次のファイルが作成されます。

    PDSQLWの場合：_History.log

    PDSQLWUの場合：_HistoryU.log

＜留意事項＞

・履歴ログファイルのサイズおよび履歴量（SQL・pdsqlコマンド数＋？パラメタ数）が多くなると、Executerの起動・終了に時間がかかることがあります。起動・終了時間が気になる場合は、Executerの終了前にSQL履歴ウインドウから長大なSQL・pdsqlコマンド、？パラメタ数の多いSQL・pdsqlコマンドを削除する、または、Executer起動前に履歴ログファイルを削除してください。


ディクショナリビューウインドウ／ディクショナリ詳細ウインドウを閲覧する

ディクショナリビューウインドウおよび、ディクショナリ詳細ウインドウは接続しているデータベースのディクショナリ情報を表示し、ユーザがＳＱＬを入力する操作を補助します。

以下に、ディレクショナリビューウインドウの画面内容と、ディクショナリ詳細ウインドウの画面内容をそれぞれ示します。

ディクショナリビューウインドウに表示する情報は、次に示す階層形式で表示します。

接続データベース名(*1)

┣スキーマ名

┃ ┣テーブル

┃ ┃ ┣表名

┃ ┃ ┗・・・

┃ ┣ビュー

┃ ┃ ┣ビュー表名

┃ ┃ ┗・・・

┃ ┣インデクス

┃ ┃ ┣インデクス名

┃ ┃ ┗・・・

┃ ┗手続き

┃ ┣手続き名/関数名/トリガ名

┃ ┗・・・

┣ＲＤエリア

┃ ┣ＲＤエリア名

┃ ┗・・・

┣ユーザ

┃ ┣認可識別子

┃ ┗・・・

┗外部サーバ

┣外部サーバ名

┗・・・

(*1)HiRDBに接続した場合、固定文字列[HiRDB]とバージョン番号(VV-RR形式)を表示します。

XDM/RDに接続した場合、固定文字列[XDM/RD]とバージョン番号(VV-RR形式)を表示します。

項目を選択すると、ディクショナリ詳細ウインドウに項目の情報を表示します。

項目をダブルクリックすると、項目名をＳＱＬ入力画面のカーソル位置に挿入します。

項目を選択し右クリックすると、次のメニューが表示され、操作が行えます。

［データを開く］ | 編集した操作を直前の状態に戻します。表を検索して検索結果を出力ウインドウに出力します。(*2) （表名を選択時にメニューが選択可となります。）
［エクスポート］ | 表を検索して検索結果を拡張DAT形式にて指定したファイルに出力します。(*2) （表名を選択時にメニューが選択可となります。）
［インポート］ | 指定したファイルから表へデータの入力を行います。 （表名を選択時にメニューが選択可となります。）
［定義ソースを表示］ | 選択されているオブジェクトの定義ソースを出力ウインドウに出力します。 （ビュー、手続きを選択時にメニューが選択可となります。）
［オブジェクト名をコピー］ | 選択されているオブジェクトの名称と項目名をＳＱＬ入力画面のカーソル位置に挿入します。
［最新の情報に更新］ | ＤＢサーバにアクセスし、選択されているオブジェクトの表示内容を 最新の情報に変更します。

(*2)検索結果のソート指定を行っていないため、行の並びは保証しません。

ディクショナリビューウインドウで選択されている項目名を、ディクショナリ詳細ウインドウの上部に表示します。

ディクショナリビューウインドウで選択された項目によって、ディクショナリ詳細ウインドウで表示する情報に差異があります。以下に、各項目選択時に表示する情報を記します。

[表名]選択時に表示する情報：

表示されるタブ | タブ選択時の表示項目 | 備考
プロパティ | [スキーマ名] [表名] [表ＩＤ] [構成列数] [合計長] [表作成時間] [インデクス定義数] [表識別子の種別](*1) [分割情報](*1) [ＲＤエリア] [外部サーバ名称] [表オプション情報](*1) | 表の定義情報。表示項目を行として表示。
構成列 | [列ＩＤ] [列名] [データ型](*1) [長さ] (*1) [その他属性] (*1) | 表を構成する列情報。
ビュー | [スキーマ名] [ビュー表名] | 表を参照しているビュー表の一覧情報。
インデクス | [インデクスＩＤ] [インデクス名] [表名] [ユニークタイプ] (*2) [繰返し列](*3) [構成列数] | 表を参照しているインデクスの一覧情報。 （INDEXESコマンドの項目と同じ） (*2)SQL_INDEXES表のUNIQUE_TYPE列。 (*3)繰返し列が含まれる場合：’M’、その他の場合：’△’。
手続き | [ルーチン名] [特定名称] [ルーチン種別] (*4) [パラメタ数] [定義ソースサイズ] [作成時刻] | 表を参照している手続き、関数、トリガの一覧情報。（ROUTINESコマンドの項目と同じ） (*4)手続き・トリガ：’P’、関数：’F’。
制約 | [制約情報](*1) | 表を参照している制約判定情報および参照制約情報の一覧情報。

[ビュー表名]選択時に表示する情報：

表示されるタブ | タブ選択時の表示項目 | 備考
プロパティ | [スキーマ名] [表名] [表ＩＤ] [表識別子の種別](*1) | ビュー表の定義情報。表示項目を行として表示。
構成列 | [列ＩＤ] [列名] [データ型](*1) [長さ] (*1) [その他属性] (*1) | ビュー表を構成する列情報。
参照先の表 | [スキーマ名] [表名] | ビュー表が参照する表の一覧情報。

[インデクス名]選択時に表示する情報：

表示されるタブ | タブ選択時の表示項目 | 備考
プロパティ | [スキーマ名] [表名] [インデクス名] [インデクスID] [構成列数] [インデクス種別](*1) [RDエリア] [インデクスオプション情報](*1) [プラグイン] | インデクスの定義情報。表示項目を行として表示。
構成列 | [インデクス定義順] [列ID] [列名] [データ型] [繰返し列数] [昇順/降順](*5) | インデクスを構成する列情報。 (*5)昇順：’ASC’、降順：’DESC’。

[手続き名/関数名/トリガ名]選択時に表示する情報：

表示されるタブ | タブ選択時の表示項目 | 備考
プロパティ | [種別](*6) [スキーマ名] [手続き名] [特定名称] [パラメタ数] [トリガ動作契機](*6-2) [トリガ契機](*6-2) [トリガ動作](*6-2) | 手続きの定義情報。表示項目を行として表示。 (*6)手続き名：’procedure’、関数名：’function’、トリガ名：’trigger’。 (*6-2)選択された項目が、トリガのときに表示します。出力する内容は、TABLEINFコマンドの出力形式を参照してください。
パラメタ | [パラメタ指定順序] [入出力](*7) [パラメタ名] [データ型](*7-2) [データ長] | 手続きのパラメタ情報。 （PRPARAMSコマンドの項目と同じ） (*7)入力：’IN’、出力：’OUT’、入出力：’INOUT’、その他：’NONE’。 (*7-2)SQL_ROUTINE_PARAMS表のDATA_TYPE列。

[RDエリア名]選択時に表示する情報：

表示されるタブ | タブ選択時の表示項目 | 備考
プロパティ | [ＲＤエリアＩＤ] [ＲＤエリア名] [サーバ名] [ＲＤエリアタイプ](*8) [ページ長] [セグメントサイズ] [初期割り当てセグメント数] [増分セグメント数](*9) [ファイル数] [格納表数] [格納インデクス数] | ＲＤエリアの定義および利用情報。表示項目を行として表示。 (*8)SQL_RDAREAS表のRDAREA_TYPE列。 (*9)RDエリアの増分指定がない場合は’*’表示となります。
使用 | [種別](*10) [スキーマ名] [オブジェクト名] [利用表名] | ＲＤエリアに割り当てられているオブジェクト情報。 （RDAREAINFコマンドの項目と同じ） (*10)テーブル：’TABLE’、インデクス：’INDEX’、長大データ列：’BLOB’。 [利用表名]には、[種別]がINDEX又はBLOBのときに元となる表名を表示します。

[認可識別子]選択時に表示する情報：

表示されるタブ | タブ選択時の表示項目 | 備考
プロパティ | [ユーザＩＤ] [ＤＢＡ権限](*11) [スキーマ定義権限](*12) [スキーマ作成時間] [パスワード制限違反者種別コード](*13)] | 認可識別子の情報。表示項目を行として表示。 （USERSコマンドの項目と同じ） (*11)SQL_USERS表の DBA_PRIVILEGE列。 (*12)SQL_USERS表のSCHEMA_PRIVILEGE列。 (*13)SQL_USERS表のPASSWORD_TEST列。接続サーバがHiRDB 07-02以降でない場合は、空白を表示。

[外部サーバ名]選択時に表示する情報：

表示されるタブ | タブ選択時の表示項目 | 備考
プロパティ | [外部サーバＩＤ] [外部サーバ名] [外部サーバにアクセスするＢＥＳ名称] [サーバ種別](*14) [サーババージョン] [定義表の数] [ユーザ名称] | 外部サーバの情報。表示項目を行として表示。 （SERVERSコマンドの項目と同じ） (*14)SQL_FOREIGN_SERVERS表の FOREIGN_SERVER_TYPE列。

項目を選択し右クリックすると、次のメニューが表示され、操作が行えます。

[コピー(C)] | 選択範囲のデータをクリップボードにコピーします。
[すべて選択(A)] | すべてのセルを選択します。

(*1)出力する内容は、TABLEINFコマンドの出力形式を参照してください。


文字列を検索／置換する

メニュー[編集(E)] － [検索(F)...]を選択すると、検索ダイアログをモードレス表示します。メニュー[編集(E)] － [置換(R)...選択すると、置換ダイアログをモーダル表示します。

本ダイアログにより、アクティブウインドウ内の文字列の検索または置換ができます。

検索対象および置換後の文字列指定にて、正規表現は対応しておりません。

以下に、検索ダイアログと置換ダイアログをそれぞれ示します。

ウインドウの入力項目に関する詳細は以下のとおりです。

[検索する文字列(N)]チェックボックス：

検索する文字列を入力します。最大入力長は３２７６７文字です。

[置換後の文字列(E)]チェックボックス：

「検索する文字列」を置き換える文字列を入力します。最大入力長は３２７６７文字です。

[単語単位で探す(W)]チェックボックス：

チェックすると「検索する文字列」を単語単位で、検索/置換します。

[完全に同一なセルだけを検索する(O)]チェックボックス：

チェックすると「検索する文字列」とセルの内容が一致するもののみを、検索/置換します。

SQL入力ウインドウ、出力ウインドウの[結果]タブ、ﾃﾞｨｸｼｮﾅﾘﾂﾘｰﾋﾞｭｰウインドウが

アクティブウインドウの場合は、選択不可となります。

[大文字と小文字を区別する(C)]チェックボックス：

チェックすると「検索する文字列」に入力された文字列を、大文字と小文字を区別して検索/置換します。

[次を検索(F)]ボタン：

アクティブウインドウのカーソル位置以降を検索します。

該当文字列が見つかった場合、対象の文字列を反転表示します。(*1)

[閉じる]ボタン：

本ダイアログを閉じます。

[置換(R)]ボタン：

アクティブウインドウのカーソル位置以降を検索し、該当文字列が見つかった場合、

対象の文字列を「置換後の文字列」に置き換え、文字列を反転表示します。(*1)

[すべて置換(A)]ボタン：

アクティブウインドウ内を検索し、すべての該当文字列に対して「置換後の文字列」に置き換えます。(*1)

*1：該当文字列が見つからなかった場合、「検索文字列が見つかりませんでした」というメッセージを

出力します。継続して検索／置換のボタンを押下したときは処理開始位置が先頭となります。


実行できるSQL

●SQL入力ウインドウからのSQL・pdsqlコマンドの指定

SQL入力ウインドウから１回に実行できるSQL・pdsqlコマンドは１つで、SQL・pdsqlコマンドの最後にはセミコロン（；）が必要です。複数のSQL・pdsqlコマンドを１度に実行することはできません。

１行の長さは32,760（約32K）文字以内である必要があります。

また、１つのSQL・pdsqlコマンドの長さは、環境設定ダイアログで指定したサイズ以内である必要があります。

●ファイルからのSQL・pdsqlコマンドの指定

ファイルから実行する場合、１度に複数のSQL・pdsqlコマンドを実行することができます。また、１つのSQL・pdsqlコマンドを複数行に記述することもできます。また、ファイルから実行する場合は１つのSQL・pdsqlコマンドの最後にはセミコロン（；）が必要です。セミコロンがない場合は、その行は次の行に継続しているものとして扱われます。１行の長さは32,760（約32K）バイト以内、１つのSQL・pdsqlコマンドの長さは2,000,000バイト(Unicodeの場合2,000,000文字)以内である必要があります。

＜ファイルでの指定例＞

SELECT C1,C2 FROM T1;

SELECT C3,C4

FROM T2;

●本プログラムで実行できるSQL

SQLの文法については、マニュアル「HiRDB SQLリファレンス」を参照してください。

XDM/RD E2接続では実行できるSQLが異なります。XDM/RD E2接続を参照してください。

＜定義系SQL＞

実行できるSQL |  | 内容
スキーマの定義 | CREATE SCHEMA | スキーマを定義します。
 | DROP SCHEMA | スキーマを削除します。
表の定義 | CREATE TABLE | 表を定義します。
 | DROP TABLE | 表を削除します。
表定義の変更 | ALTER TABLE | 表定義を変更します。
ビューの定義 | CREATE VIEW | ビュー表を定義します。
 | DROP VIEW | ビュー表を削除します。
インデクスの定義 | CREATE INDEX | インデクスを定義します。
 | DROP INDEX | インデクスを削除します。
手続きの定義 | CREATE PROCEDURE(*1)(*10) | 手続きを定義します。
 | DROP PROCEDURE | 手続きを削除します。
手続きの変更 | ALTER PROCEDURE | 手続きを変更します。
別名の定義 | CREATE ALIAS | 別名を定義します。
 | DROP ALIAS | 別名を削除します。
関数の変更 | ALTER ROUTINE | 関数・手続きを変更します。
関数の定義 | CREATE FUNCTION(*2)(*10) | 関数を定義します。
 | DROP FUNCTION | 関数を削除します。
インデクス型の定義 | CREATE INDEX TYPE | インデクス型を定義します。
 | DROP INDEX TYPE | インデクス型を削除します。
型の定義 | CREATE TYPE(*3)(*10) | 型を定義します。
ユーザ定義型の削除 | DROP DATA TYPE | 抽象データ型、個別型、名前付き行型を削除します。
トリガの再作成 | ALTER TRIGGER | トリガのSQLオブジェクトを再作成します。
トリガの定義 | CREATE TRIGGER(*4)(*10) | トリガを定義します。
トリガの削除 | DROP TRRIGER | トリガを削除します。
セキュリティ 監査対象定義 | CREATE AUDIT | 監査証跡として記録する監査事象、 およびその対象を定義します。
セキュリティ 監査対象除外 | DROP AUDIT | 定義されている監査対象を除外します。
CONNECT関連セキュリティ 機能の定義 | CREATE CONNECTION SECURITY | CONNECT関連セキュリティ機能に関するセキュリティ項目を定義します。
CONNECT関連セキュリティ 機能の削除 | DROP CONNECTION SECURITY | CONNECT関連セキュリティ機能に関するセキュリティ項目を削除します。
権限の定義 DBA権限 | GRANT DBA | DBA権限を与えます。
 | REVOKE DBA | DBA権限を取り消します。
権限の定義 スキーマ定義権限 | GRANT SCHEMA | スキーマ定義権限を与えます。
 | REVOKE SCHEMA | スキーマ定義権限を取り消します。
権限の定義 CONNECT権限 | GRANT CONNECT | CONNECT権限を与えます。
 | REVOKE CONNECT | CONNECT権限を取り消します。
権限の定義 アクセス権限 | GRANT アクセス権限 | アクセス権限を与えます。
 | REVOKE アクセス権限 | アクセス権限を取り消します。
権限の定義 RDエリア利用権限 | GRANT RDAREA | RDエリア利用権限を与えます。
 | REVOKE RDAREA | RDエリア利用権限を取り消します。
注釈の付加 | COMMENT | 表及び列に注釈を付けます。

＜操作系SQL＞

実行できるSQL |  | 内容
リストの作成 | ASSIGN LIST | リストを作成します。
手続きの呼び出し | CALL(*4) | 手続きを呼び出します。
行の削除 | DELETE | 行を削除します。
リストの削除 | DROP LIST | リストを削除します。
行の挿入 | INSERT | 行を挿入します。
全行の削除 | PURGE TABLE | 全行を削除します。
検索 | SELECT(*6) | 表のデータを検索します。
行の更新 | UPDATE | 表のデータを更新します。

＜制御系＞

実行できるSQL |  | 内容
トランザクションの終了 | COMMIT | トランザクションを終了させます。
表の排他制御 | LOCK | 表に排他制御をします。
トランザクションの取り消し | ROLLBACK | トランザクションを取り消します。
実行ユーザの変更 | SET SESSION AUTHORIZATION(*7) | 接続中のユーザを変更します。

＜その他＞

実行できるSQL |  | 内容
診断情報取得 | GET DIAGNOSTICS(*8) | 診断情報を取得します。
運行コマンド／ユティリティ実行 | CALL COMMAND(*9) | コマンド・ユティリティを実行します。

*1：CREATE PROCEDUREを指定する場合は１行の最後に END_PROC を付加します。

(例)

CREATE PROCEDURE P1() BEGIN INSERT INTO T1 (C1) VALUES(10) ;

UPDATE T1 SET C1 = 0 WHERE C1 < 10 ; END END_PROC;

*2：CREATE FUNCTIONを指定する場合は１行の最後に END_FUNC を付加します。

(例)

CREATE FUNCTION FUNC1( NUM1 INTEGER,NUM2 INTEGER )

RETURNS INTEGER

BEGIN

DECLARE SUM1 INTEGER;

SET SUM1 = NUM1 + NUM2;

RETURN SUM1;

END

END_FUNC;

*3：CREATE TYPEを指定する場合は１行の最後に END_TYPE を付加します。

(例)

CREATE TYPE TEL( NAME VARCHAR(15),TEL_NO INTEGER )

END_TYPE;

*4：CREATE TRIGGERを指定する場合は１行の最後にEND_TRIGを付加します。

(例)

CREATE TRIGGER TRIG1

AFTER INSERT ON T0

FOR EACH ROW

INSERT INTO T1 VALUSE(10, “ABC”)

END_TRIG;

*5：CALL文で呼び出す手続きの引数が入力パラメタの場合、値式または“？”を指定できます。手続きの引数が出力パラメタまたは入出力パラメタの場合、手続きの引数に“？”を指定してください。

CALL文を入力後、入力パラメタまたは入出力パラメタに対し「？パラメタ入力ダイアログ」が表示されるので対応した値を指定してください。

「？パラメタ入力ダイアログ」での入力を行った後、CALL文が実行され正常終了した際に、出力パラメタまたは入出力パラメタの結果を表示します。

また、手続き内にて結果集合のカーソルを開いた状態で終了している場合は、 該当する結果集合の内容を表示します。

(例)

  手続き：

CREATE PROCEDURE ORDERED_EMPS(IN REGION INTEGER,OUT CNT INTEGER)

DYNAMIC RESULT SETS 2

BEGIN

DECLARE CUR1 CURSOR WITH RETURN

FOR SELECT id_no, name FROM emps_1

WHERE id_no < REGION ORDER BY id_no;

DECLARE CUR2 CURSOR WITH RETURN

FOR SELECT id_no, name FROM emps_2

WHERE id_no < REGION ORDER BY id_no;

OPEN CUR1;

OPEN CUR2;

SET CNT = 2;

END

END_PROC;

  CALL文の実行例：

call ORDERED_EMPS(?,?);

  CALL文の実行結果：

CNT

------------

2

KFPA12120-I Processing of SQL completed, dynamic result set returned

ID_NO NAME

------------ --------------------------------

3001 Mishima

4001 Shimizu

4201 Yoshida

4501 Iwata

5301 Kawasaki

5401 Matsuda

KFPA12121-I Processing of SQL completed, additional result set returned

ID_NO NAME

------------ --------------------------------

1301 Ibaragi

1901 Kagawa

2501 Matsue

KFPA12100-I No rows satisfying search condition

*6：指定できるのは動的SELECTのみです。

*7：SET SESSION AUTHORIZATION文使用時の埋め込み変数１の部分には、認可識別子、埋め込み変数２の部分にはパスワードを直接記述してください｡

(例) SET SESSION AUTHORIZATION USER0001 IDENTIFIED BY PASS0002;

*8：GET DIAGNOSTICS文使用時の埋め込み変数部分には“？”を指定してください｡

(例) GET DIAGNOSTICS ?=NUMBER;

    また、条件番号を指定する場合も“？”を指定してください。

    GET DIAGNOSTICS文実行後、「？パラメタ入力ダイアログ」が表示されるので対応する値を指定してください。

(例) GET DIAGNOSTICS EXCEPTION ? ?=RETURNED_SQLCODE;

    GET DIAGNOSTICS文で指定可能な条件情報項目名を示します。

    その他の条件情報項目名を指定するとSQL Executerがエラーを返します。

＜条件情報項目名＞

RETURNED_SQLCODE

ERROR_POSITION

ERROR_SQL_NO

ERROR_SQL

ROUTINE_TYPE

ROUTINE_SCHEMA

ROUTINE_NAME

TRIGGER_SCHEMA (注1)

TRIGGER_NAME (注1)

CONSTRAINT_SCHEMA (注1)

CONSTRAINT_NAME (注1)

MESSAGE_TEXT

QUERY_NAME

CONDITION_IDENTIFIER (注1)

注1：SQL Executer 02-07以降にて新しく指定できる項目名です。

*9：CALL COMMAND文使用時の埋め込み変数部分が入力パラメタの場合は

値式または“？”を指定できます。埋め込み変数部分が出力パラメタ

の場合は“？”を指定してください。

埋め込み変数部分が入力パラメタの句：

・CALL COMMAND

・WITH

・INPUT

・ENVIRONMENT

・SERVER

埋め込み変数部分が出力パラメタの句：

・OUTPUT TO

・ERROR TO

・RETURN CODE TO

CALL COMMAND文実行後、入力パラメタに対し“？”を指定した数分の

応答要求があるので対応した値を指定してください。

すべての入力応答を行った後、CALL COMMAND文が実行され正常終了し

た際に、出力パラメタの結果を表示します。

なお、OUTPUT TO 句、 ERROR TO 句で返却されるデータ型が、

BLOB(2G)となっておりますのでSET BLOB LIMITコマンドにより最大長を

適切な値に設定した後に、実行することをお奨めします。

(例)

CALL COMMAND文の実行例：

CALL COMMAND 'pddef' INPUT ?

OUTPUT TO ? RETURN CODE TO ?

ENVIRONMENT 'PDUSER=SAS1/SAS1';

*10：SQL Executer 02-06以前のGUI版では複合文の終了（END_PROC,END_FUNC

,END_TRIG,END_TYPE）前にセミコロンまたは空白が必要でした。

SQL Executer 02-07以降のGUI版にて、セミコロンの存在を任意とし、空白または改行を必要とします。


実行できるpdsqlコマンド

  本プログラムの起動後は、SQL文だけではなく、SQL文の入力・実行を容易にしたり、実行結果の形式を指定するなどのpdsqlコマンドを入力することができます。

●本プログラムから指定できるpdsqlコマンド

  指定できるpdsqlコマンドは，「pdsqlコマンドの表記方法」および「pdsqlコマンド一覧」を参照してください。


pdsqlコマンドの表記方法

<文法記号の説明>

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

文法記述記号 意 味

───────────────────────────────────

[ ] この記号で囲まれた項目は省略できます。

（例）REPEAT [ 繰り返し回数 ]

繰り返し回数は省略することができます。

| この記号で仕切られた項目は選択できます。

{ } この記号で囲まれている複数の項目のうちから一つを選択

します。

（例）SET AUTO COMMIT { ON | OFF }

ON、又はOFFのどちらかを選択して記述します。

この記号で示す項目は、省略時の仮定値です

(下線) （例）CHANGE [ HOLD | NOHOLD ]

NOHOLDが仮定されます。

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

<属性表示記号の説明>

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

属性表示記号 意 味

───────────────────────────────────

～ この記号の後にユーザ指定値の属性を示します。

<< >> ユーザが指定しなかった場合に、仮定される値を示します。

< > ユーザ指定値の構成要素記号を示します。

( ) ユーザ指定値の指定範囲を示します。

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

<構成要素記号の説明>

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

構成要素記号 意 味

───────────────────────────────────

英字 アルファベット（Ａ～Ｚ、ａ～ｚ）と＿（下線）

英字記号 アルファベット（Ａ～Ｚ、ａ～ｚ）と＃、＠、￥

英数字 英字と数字（０～９）

英数字記号 英字記号と数字（０～９）

符号なし整数 数字

１６進文字 数字と（Ａ～Ｆ、ａ～ｆ）

識別子 先頭がアルファベットの英数字

（ＲＤエリア名の場合は、英数字に空白も含まれます。）

記号名称 先頭が英字記号の英数字記号

文字列 任意の文字列

パス名 記号名称、／、．（ピリオド）、‘(’、及び‘)’

      ファイル名称　OSの規則に従ったファイルの名前

      ファイル名　　「ファイル名称」　、「”ファイル名称”」、

「パス名\ファイル名称」、

「“パス名\ファイル名称”」及び

（ファイル名に空白、‘(’、及び‘)’を含む場合は

””で囲った形式にして下さい。）

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━


pdsqlコマンド一覧

＜本プログラムから実行可能なpdsqlコマンド＞

項番 | コマンド | 機能概要
1 | BLOCK/ITERATE | コマンドの繰り返し(注１)
2 | CHANGE | 文字列の変更(注１)
3 | COLUMNS | 表の列一覧の表示
4 | CONNECT | HiRDBに接続
5 | CONSTRAINTS | 制約名一覧の表示
6 | DESCRIPTORS | 抽象データ型の属性の表示
7 | DISCONNECT | HiRDBとの切り離し
8 | FILES | ＲＤエリアのファイル情報表示
9 | GETFILE | ファイルからのパラメタ入力
10 | HELP | ヘルプの表示
11 | INDEXCLM | インデクスの列を表示
12 | INDEXES | インデクス一覧の表示
13 | ITERATE | コマンドの繰り返し終了(注１)
14 | LOBS | ＬＯＢ用ＲＤエリアの表示
15 | PRPARAMS | パラメタの表示
16 | PUTFILE | 結果のファイル出力
17 | RDAREAINF | RDエリアの情報の表示
18 | RDAREAS | ＲＤエリアの表示
19 | REPEAT | ＳＱＬの繰返し実行
20 | ROUTINES | 手続き一覧の表示
21 | SERVERS | 外部サーバ一覧の表示
22 | SET ARRAY DISPLAY MODE | 繰返し列情報の切り替え
23 | SET ARRAY LIMIT | 最大要素数の制限
24 | SET ARRAY NOVALUE | 繰返し列値なし要素表示文字の設定
25 | SET AUTO COMMIT | COMMITの自動発行
26 | SET BINARY LIMIT | BINARY型の長さ制限
27 | SET BLOB LIMIT | BLOB型の長さ制限
28 | SET CHAR LIMIT | CHAR型の長さ制限
29 | SET CLOB LIMIT | CLOB型の長さ制限
30 | SET CMDBUF | サーバコマンド実行結果の出力長制限
31 | SET CONVSPACE | 制御文字コードの空白変換
32 | SET DISPLAY | 出力形式の変更
33 | SET DUMPMODE | １６進形式でも表示
34 | SET ECHOBACK | コマンドのエコー表示
35 | SET FETCH LIMIT | 検索行の制限
36 | SET NCHAR LIMIT | NCHAR型の長さ制限
37 | SET NULL CHARACTER | ナル値表示文字の設定
38 | SET PADDING CHAR | 埋め文字の変更
39 | SET RESULT FILEOUT | 実行結果のファイル出力
40 | SET SPLIT SIZE | 長大データの分割取得指定
41 | SET TBLMODE | 表形式での表示
42 | SOURCE | 定義ソースの表示
43 | STATUS | 動作状態の表示
44 | TABLEINF | 表の情報表示
45 | TABLES | 表一覧の表示
46 | TRIGGERS | トリガ一覧の表示
47 | TYPES | 抽象データ型の表示
48 | USERS | ユーザ一覧の表示
49 | /* | 注釈行(注１)
50 | : | サーバコマンドの実行

(注１) ファイル中に記述しファイルから実行する場合のみ指定可能です。

＜留意事項＞

  XDM/RD E2接続では一部制限があります。XDM/RD E2接続も合わせて参照してください。

  SQL予約語削除機能を使用すると、機能の実行ができないコマンドがあります。「ＳＱＬ予約語削除機能による影響 」も合わせて参照してください。


トラブルシュート

  SQL および HiRDBサーバから情報を取得するために SQL を発行するpdsql コマンドで障害が発生した場合は、HiRDBクライアントのトラブルシュート機能を使用して、障害要因を調査できます。

  HiRDBクライアントのトラブルシュート機能については、HiRDBのマニュアル「ＵＡＰ開発ガイド」の「UAPの障害対策」を参照してください。


エラーメッセージ

メッセージの見方

メッセージ一覧

メッセージ本文

ＨｉＲＤＢメッセージ


メッセージの見方

１．メッセージの出力形式

  メッセージは実行結果ウインドウ、メッセージダイアログ等に出力されます。

（例）

  KFPX27000-E xx....xx

    KFPX27000-E : メッセージＩＤ

    xx....xx : メッセージテキスト

２．メッセージの記述形式

[HiRDB SQL Executerのメッセージヘルプ形式]

  KFPX27nnn-i

  メッセージテキスト

  メッセージの意味を説明しています。

  (S)：メッセージ出力後の、本プログラムの動作を示します。

  (P)：メッセージ出力後に、ユーザがとる処置を示します。

      nnn : メッセージ番号を示します。

      i : メッセージの重要度を示します。

            E : エラーメッセージ

            I : 情報メッセージ

[HiRDBサーバのメッセージヘルプ形式]

  KFPxnnnnn-i

  メッセージテキスト　　（y）

  メッセージの意味を説明しています。

(Ｓ)メッセージを出力した後に，HiRDBがする処置を示します。

(Ｐ)メッセージを受け取ったプログラマが取る処置を示します。

(Ｏ)メッセージを受け取ったオペレータが取る処置を示します。

[対策]メッセージを受け取ったHiRDBの管理者が取る処置を示します。

※注：メッセージ中で使用する「保守員に連絡してください。」とは，当社社員， 又は当社営業担当部署に連絡することを示します。

  x：メッセージの管理元を識別するコードです。

      A：SQL文についてのメッセージ

      B：分散データベース関連のメッセージ

      C：Windows NT HiRDB固有のメッセージ

      D：ディクショナリサーバのメッセージ

      H：データベース関連のメッセージ

      I：HiRDBファイルシステムのメッセージ

      J：JDBCドライバ関連のメッセージ

      K：ユティリティ関連のメッセージ（統計解析又は状態解析）

      L：ユティリティ関連のメッセージ（作成又は再編成）

      M：MIB関連のメッセージ

      N：ユティリティ関連のメッセージ（最適化）

      O：OSライブラリのメッセージ

      R：ユティリティ関連のメッセージ（回復）

      S：システムマネジャのメッセージ

      T：更新可能なオンライン再編成のメッセージ

      U：ユティリティ関連のメッセージ（共通）

      X：ユティリティ関連のメッセージ（環境定義）

      Y：プラグイン関連のメッセージ

      Z：クライアントのメッセージ

  nnnnn：メッセージ番号を示します。

  i：メッセージの重要度を示します。

      E：エラーメッセージ（機能が働かない障害が発生したことを示しています）

      W：警告メッセージ

（リソースの使用状況などについての警告を示します。又はコマンドの指定誤りはありましたが，値を仮定して処理を続行することを示します）

      I：インフォメーションメッセージ

（上記E，及びWに該当しない単純な動作状況を示します）

      Q：応答待ちメッセージ

（出力したメッセージに対するユーザの応答を待っていることを示します）

  y：メッセージの出力先種別を示します。

  一つのメッセージが複数の出力先種別を持つ場合は，出力される可能性のある種別を，'＋'でつないで記述します。

  pdcatコマンド，及びリアルタイム出力機能での標準出力への出力の場合は，'L'となります。

  なお，KFPJメッセージは，JDBCドライバのSQLExceptionオブジェクトのgetMessage()に取得されます。

      E：標準エラー出力

      S：標準出力

      L：メッセージログファイル及びWindows NTのイベントログ※

      R：エラーログファイル

      S：SQLCA（SQL連絡領域）

      D：メッセージダイアログ

      J：JP1のイベントデータベース

注※：次の場合，メッセージが出力されない，又はメッセージ出力元ユニットがあるホストのWindows NTのイベントログに出力されることがあります。

・シングルサーバ，又はシステムマネジャがあるユニットの障害発生時

・メッセージログサーバの異常終了後，再起動前

・待機系システム


メッセージ一覧

   KFPX27001-I

   KFPX27010-I

   KFPX27011-E

   KFPX27012-E

   KFPX27013-E

   KFPX27014-E

   KFPX27015-E

   KFPX27016-E

   KFPX27017-E

   KFPX27018-E

   KFPX27021-E

   KFPX27032-I

   KFPX27033-I

   KFPX27040-E

   KFPX27041-E

   KFPX27042-E

   KFPX27043-E

   KFPX27045-E

   KFPX27047-E

   KFPX27050-E

   KFPX27051-E

   KFPX27052-E

   KFPX27053-E

   KFPX27054-E

   KFPX27055-E

   KFPX27056-E

   KFPX27057-E

   KFPX27058-E

   KFPX27059-E

   KFPX27060-E

   KFPX27062-E

   KFPX27063-E

   KFPX27064-E

   KFPX27065-E

   KFPX27066-E

   KFPX27067-E

   KFPX27068-E

   KFPX27069-E

   KFPX27070-E

   KFPX27072-E

   KFPX27073-E

   KFPX27074-E

   KFPX27075-E

   KFPX27076-E

   KFPX27077-E

   KFPX27078-E

   KFPX27079-E

   KFPX27080-E

   KFPX27086-E

   KFPX27087-E

   KFPX27090-E

   KFPX27091-E

   KFPX27092-I

   KFPX27093-E

   KFPX27094-E

   KFPX27097-I

   KFPX27098-I

   KFPX27901-I

   KFPX27903-W

   KFPX27904-I

   KFPX27905-E

   KFPX27906-E

   KFPX27907-E

   KFPX27909-E

   KFPX27910-E

   KFPX27911-E

   KFPX27912-E

   KFPX27913-E

   KFPX27914-E

   KFPX27915-E

   KFPX27916-E

   KFPX27917-E


メッセージ本文

KFPX27001-I
Processing of SQL completed
SQL文の実行が完了しました。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：次のＳＱＬ、pdsqlコマンを入力してください。
KFPX27010-I
nnnn rows xxxx
SQL文の処理は正常に終了し、nnn件のデータがxxxxされました。
xxxx :
selected : 検索されました。
updated : 更新されました。
inserted : 挿入されました。
deleted : 削除されました。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：次のＳＱＬ、pdsqlコマンを入力してください。
KFPX27011-E
PDSQLW2.EXE not found
PDSQLW2.EXEが見つかりませんでした。
(S)：本アプリケーションを終了します。
(P)：本プログラムを正しくインストールしてください。
KFPX27012-E
CODECONV.DLL not found
CODECONV.DLLが見つかりませんでした。
(S)：本アプリケーションを終了します。
(P)：コード変換ランタイムを正しくインストールし、環境設定を行ってください。
KFPX27013-E
KanjiLink XKP not found
KanjiLink XKPが見つかりませんでした。
(S)：本アプリケーションを終了します。
(P)：KanjiLink XKP実行時ライブラリを正しくインストールし、環境設定を行ってください。
KFPX27014-E
FILE I/O Error ( XXXXX )
ファイルへの入出力に失敗しました。( XXXXX ）
(S)：本アプリケーションを終了します。
(P)：エラー要因を取り除いてから、再度実行してください
XXXXX : エラーコード
KFPX27015-E
Shared Memory access Error ( XXXXX )
共有メモリ処理に失敗しました。( XXXXX )
(S)：
起動処理中に発生した場合は本アプリケーションを終了します。
それ以外の場合は、ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：十分なメモリを確保し、再度起動もしくは、実行してください。
XXXXX : エラーコード
KFPX27016-E
Error occured on Code Convert Process ( RetCode=XXXXX, SysErr=YYYYY )
コード変換ランタイム環境に誤りがあります。( コードエラー変換コード=XXXXX, エラーコード=YYYYY ）
(S)：本アプリケーションを終了します。
(P)：コード変換ランタイムの環境を見直し、必要ならば再インストールをしてください。
KFPX27017-E
Invalid character code in Input data ( RetCode=XXXXX )
入力したデータに不正な文字コードが存在します。( コード変換エラーコード=XXXXX ）
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：正しいデータに直して再実行してください。
KFPX27018-E
nnn rows convert is failed, Line no. = XXXXX, YYYYY, ZZZZZ, ...
nnn行変換に失敗しました。行番号 = XXXXX, YYYYY, ZZZZZ, ... です。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：次のＳＱＬ、pdsqlコマンドを入力してください。
KFPX27021-E
More than 2097152 output length
出力長が２，０９７，１５２バイトを超えています｡
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：出力長が２，０９７，１５２バイト以下になるように修正し、再度実行してください。
KFPX27032-I
1 character changed
1 個の文字列を変更しました。
(S)：引き続き実行するＳＱＬがあれば、そのまま実行します。
(P)：引き続き実行するＳＱＬがなければ、次のＳＱＬ、pdsqlコマンドを入力してください。
KFPX27033-I
n characters changed
n 個の文字列を変更しました。
(S)：引き続き実行するＳＱＬがあれば、そのまま実行します。
(P)：引き続き実行するＳＱＬがなければ、次のＳＱＬ、pdsqlコマンドを入力してください。
KFPX27040-E
Invalid xxxx
xxxxが不正です。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：正しい、xxxxを指定し再度実行してください。
KFPX27041-E
Incomplete pdsql command
コマンドが未完成です。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：正しい、コマンドを指定し再度実行してください。
KFPX27042-E
More than nn
nnより大きい値です。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：nnより小さい値を指定し再度実行してください。
KFPX27043-E
Not found before data
変更前文字列が存在しません。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：正しいデータを指定し、再度実行してください。
KFPX27045-E
Number of variables invalid or number of parameters exceeds max parameters
無効な変数またはパラメタの数が、パラメタの最大値を上回って指定されました。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：正しい変数またはパラメタの数が、パラメタの最大値を上回らない様に指定し、再度実行してください。
KFPX27047-E
Inconvertible data type of input variable
入力した変数のデータ型は、変換できません。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：正しい変数を入力し、再度実行してください。
KFPX27050-E
More then 32,000 characters in character string literal
指定した文字列が３２，０００バイトを超えています。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：３２，０００バイト以下の文字列を指定し、再度実行してください。
KFPX27051-E
Invalid floating point numeric literal
指定された浮動小数点は無効です。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：正しい値を指定し、再度実行してください。
KFPX27052-E
More then 30 characters in kanji identifier
日本語文字列が３０文字を超えています。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：３０文字以下の漢字を指定し、再度実行してください。
KFPX27053-E
More then 255 characters in identifier
２５５文字を超えています。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：２５５文字以下の文字を指定し、再度実行してください。
KFPX27054-E
Invalid national character string literal
指定された各国文字列は無効です。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：正しい文字列を指定し、再度実行してください。
KFPX27055-E
more then 16,000 characters in national character string literal
各国文字列が１６，０００文字を超えて指定されています。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：１６，０００文字以下の正しい文字列を指定し、再度実行してください。
KFPX27056-E
Invalid kanji identifier
指定された日本語文字列は無効です。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：正しい日本語文字列を指定し、再度実行してください。
KFPX27057-E
Numeric literal out of range
範囲外の数値を指定しています。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：数値を範囲内に変更し、再度実行してください。
KFPX27058-E
Invalid numeric literal
指定された数値は無効です。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：正しい数値を指定し、再度実行してください。
KFPX27059-E
Input data too large for column
入力データは、列定義の長さまたは繰り返しの最大要素数を超えています。または、領域の大きさを変更するコマンド（SET ARRAY LIMIT,SET BINARY LIMIT,SET BLOB LIMIT,SET CHAR LIMIT,SET NCHAR LIMIT等）で指定したを超えています。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：
入力データを列定義または領域の大きさに収まるように指定し、再度実行してください。
または、領域の大きさを変更するコマンドを実行してください。
KFPX27060-E
Insufficient memory on PROCESS
PROCESS上でメモリ不足が発生しました。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：
十分なメモリを確保し、再度実行してください。
？パラメタを用いたＳＱＬで発生した場合は、パラメタ領域が大きすぎるので、対象列を絞り込んだＳＱＬに変更するか、領域の大きさを変更するコマンドを実行して必要とする入力パラメタ領域を小さくしてください。
検索ＳＱＬにおいて、取得する列データの最大長が大きすぎる可能性があります。
抽出列に BINARY/BLOB/CLOB型を含んでいる場合は、SET SPLIT SIZEコマンドを実行して分割取得する設定を行ってください。
KFPX27062-E
Invalid data type of operand
無効なオペランドのデータタイプが指定されました。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：正しいオペランドのデータタイプを指定し、再度実行してください。
KFPX27063-E
Invalid precision or scale in scalar function
スカラ関数に、無効な制度または、スケールが指定されました。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：正しい値を指定し、再度実行してください。
KFPX27064-E
Overflow in scalar function
スカラ関数の範囲を超えました。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：範囲内で正しいスカラ関数を指定し、再度実行してください。
KFPX27065-E
Block/iterate cannot nest
Block/iterate文中にblock文の指定はできません。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：block文の指定を無くし、再度実行してください。
KFPX27066-E
Invalid character expression for data type date
日付属性に指定した文字列は誤っています。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：正しい文字列を指定し、再度実行してください。
KFPX27067-E
Invalid token of operand
オペランドの構文が不正です。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：正しいオペランドの構文を指定し、再度実行してください。
KFPX27068-E
Not found variable identifier
指定された変数は見つかりません。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：正しい変数を指定し、再度実行してください。
KFPX27069-E
More than 50 block items, Enter ITERATE command
Block/iterate文中に指定されたＳＱＬ、pdsqlコマンドが５０文を超えています。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：ITERATEコマンドを入力してください。
KFPX27070-E
Command "<" cannot nest
読み込みファイル中に"<"コマンドは指定できません。
(S)：当該文をスキップし、次の文を読み込みます｡
(P)：ファイル中から"<"コマンドを取り除き、再度実行してください。
KFPX27072-E
Command error, Table not found
指定したテーブルは見つかりません。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：エラー要因を取り除いてから、再度実行してください。
KFPX27073-E
System call error, func=aa..aa, errno=bbb
aa....aaで示すシステムコールでエラーが発生しました。
aa..aa ： エラーの発生したシステムコール名称
bbb ： システムコールの返したエラー番号
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：エラー番号（errno：エラー状態を示す外部変数）を基に，errno.h及び該当する関数の記載されたOSのリファレンスマニュアルを参照して、エラー原因を取り除いてから、再度実行してください。
KFPX27074-E
ioctl error, errno=xx
ioctlエラー。 詳細エラーコード＝xx。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：エラー番号（errno：エラー状態を示す外部変数）を基に、errno.h及びioctlのリファレンスマニュアルを参照して，エラー原因を取り除いてから、再度実行してください。
KFPX27075-E
fdopen error, errno=xx
fdopenエラー。 詳細エラーコード＝xx。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：エラー番号（errno：エラー状態を示す外部変数）を基に、errno.h及びfdopenのリファレンスマニュアルを参照して，エラー原因を取り除いてから、再度実行してください。
KFPX27076-E
fclose error, errno=xx
fcloseエラー。 詳細エラーコード＝xx。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：エラー番号（errno：エラー状態を示す外部変数）を基に、errno.h及びfcloseのリファレンスマニュアルを参照して，エラー原因を取り除いてから、再度実行してください。
KFPX27077-E
fflush error, errno=xx
fflushエラー。 詳細エラーコード＝xx。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：エラー番号（errno：エラー状態を示す外部変数）を基に，errno.h及びfflushのリファレンスマニュアルを参照して，エラー原因を取り除いてから、再度実行してください。
KFPX27078-E
open error, errno=xx
openエラー。 詳細エラーコード＝xx。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：エラー番号（errno：エラー状態を示す外部変数）を基に、errno.h及びopenのリファレンスマニュアルを参照して、エラー原因を取り除いてから、再度実行してください。
KFPX27079-E
fgets error, errno=xx
fgetsエラー。 詳細エラーコード＝xx。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：エラー番号（errno：エラー状態を示す外部変数）を基に、errno.h及びfgetsのリファレンスマニュアルを参照して、エラー原因を取り除いてから、再度実行してください。
KFPX27080-E
Inconvertible data type in comparison predicate
比較部分で、変換できないデータ型が指定されました。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：正しいデータ型を指定し、再度実行してください。
KFPX27086-E
fputs error, errno=xx
fputsエラー。 詳細エラーコード＝xx。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：エラー番号（errno：エラー状態を示す外部変数）を基に、errno.h及びfputsのリファレンスマニュアルを参照して、エラー原因を取り除いてから、再度実行してください。
KFPX27087-E
write error, errno=xx
writeエラー。 詳細エラーコード＝xx。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：エラー番号（errno：エラー状態を示す外部変数）を基に、errno.h及びwriteのリファレンスマニュアルを参照して、エラー原因を取り除いてから、再度実行してください。
KFPX27090-E
GUI MODE cannot "XXXXX" command
GUI上では、XXXXXで示すコマンドは使用できません。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：ファイルに指定するか、他のコマンドを指定し、再度実行してください。
KFPX27091-E
Not found ";" after command
ＳＱＬ、pdsqlコマンドの最後にセミコロン(";")がありません。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：セミコロンをつけて再実行してください。
KFPX27092-I
Processing of SET XXXXX command completed
pdsqlコマンドの SET XXXXX コマンドの実行が完了しました。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：次のＳＱＬ、pdsqlコマンドを入力してください。
KFPX27093-E
GUI MODE cannot "?" parameter
GUI上で"?" パラメタは使用できません。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)："?" パラメタを使用せず、ＳＱＬ、pdsqlコマンドを実行してください。
KFPX27094-E
Error occurred on HiRDB. SQLCODE = xx
ＨｉＲＤＢでエラーが発生しました。 ＳＱＬコード = xx
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：正しいデータ型を指定し、再度実行してください。
KFPX27097-I
Auto commit ( XXX -> YYY )
Auto Commit状態が、XXXからYYYに変わりました。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：次のＳＱＬ、pdsqlコマンドを入力してください。
KFPX27098-I
Auto rollback ( XXX -> YYY )
Auto Rollback状態が、XXXからYYYに変わりました。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：次のＳＱＬ、pdsqlコマンドを入力してください。
KFPX27901-I
Processing of XXXXX command completed
pdsqlコマンドの XXXXX コマンドの実行が完了しました。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：次のＳＱＬ、pdsqlコマンドを入力してください。
KFPX27903-W
Invalid environment definition, variable= XXXXX
環境変数 XXXXX が無効です。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：
次のＳＱＬ、pdsqlコマンドを入力してください。
もしくは、pdsqlを停止した後、正しい値を指定し、再度実行してください。
KFPX27904-I
Execute server command, return code = xx
サーバコマンドを投入しました。
xx：KFPZ02470-E又はKFPZ02471-Eメッセージと共に出力された場合は、COMMAND EXECUTE文のリターンコードを示します。
その他の場合は、COMMAND EXECUTE文の実行コマンドリターンコードを示します。
いずれの場合も、マニュアル「HiRDB SQLリファレンス」のCOMMAND EXECUTEを参照してください。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：次のＳＱＬ、pdsqlコマンドを入力してください。
KFPX27905-E
Invalid HiRDB Client Library Installed
無効なHiRDBクライアントライブラリがインストールされています。
(S)：ＳＱＬ、pdsqlコマンドの入力を待ちます。
(P)：次のＳＱＬ、pdsqlコマンドを入力してください。
下記に機能に対するHiRDBクライアントライブラリの前提バージョンを記します。
・サーバコマンドの実行：バージョン06-00以降
・結果集合の表示：バージョン07-02以降
次の事項を確認し、適切な対策をしてください。
・環境変数PATHが示すディレクトリ上に古いクライアントライブラリが残っていない。
KFPX27906-E
Number of datas in input file not equal to questions, line = xx
格納する？パラメタ数と一致しません。
入力データの行＝xx。
(S)：次のデータ行を処理します。
(P)：入力データファイルの該当する行番号のデータを修正してください。
KFPX27907-E
Unable to specify XXXX operand with YYYY operand
出力形式がpdload用バイナリ形式や固定長データ形式を指定しているときはXXXXオペランドは指定できません。
(S)：SQL、pdsqlコマンドの入力を待ちます。
(P)：オペランドの組み合わせを正しく指定し、再度実行してください。
KFPX27909-E
Command "QUIT" can be used only under BLOCK/ITERATE or ? paramete input exception
"QUIT"コマンドはBLOCK文中か？パラメタの入力中しか使えません。
(S)：SQL、pdsqlコマンドの入力を待ちます。
(P)：次のSQL、pdsqlコマンドを入力してください。
KFPX27910-E
Sum of columns length exceeds 4GB
検索データ長及び入出力パラメタ長が4GBを超えました。
(S)：SQL、pdsqlコマンドの入力を待ちます。
(P)：
検索データ長及び入出力パラメータ長を4GB以下の長さにして、再度実行してください。
検索ＳＱＬにおいて、取得する列データの最大長が大きすぎる可能性があります。
抽出列に BINARY/BLOB/CLOB型を含んでいる場合は、SET SPLIT SIZEコマンドを実行して分割取得する設定を行ってください。
KFPX27911-E
Invalid data type of retrieval item XX
XX番目の検索項目のデータ型が不正です。
(S)：SQL、pdsqlコマンドの入力を待ちます。
(P)：次のSQL、pdsqlコマンドを入力してください。
KFPX27912-E
Invalid data type of “?” parameter XX
XX番目の”?”パラメタのデータ型が不正です。
(S)：SQL、pdsqlコマンドの入力を待ちます。
(P)：次のSQL、pdsqlコマンドを入力してください。
KFPX27913-E
Invalid BOM in Unicode file
Unicodeのファイルに無効なBOM(Byte Order Mark)があります。
BOMがビッグエンディアンになっています。
(S)：SQL、pdsqlコマンドの入力を待ちます。
(P)：リトルエンディアンのファイルを指定して、再度実行してください。
KFPX27914-E
Selected SQL not equal to the SQL to be executed
選択されたSQLと実行するSQLが一致していません。
(S)：「OK」ボタンの入力を待ちます。
(P)：実行するSQLと同じSQLを選択してください。
KFPX27915-E
XXXX Error code=YY name=ZZZZ
AAAA
API種別=XXXX 詳細エラーコード=YY API名=ZZZZ エラー内容=AAAA
API種別 ::= { WIN32API | Method }
API名でエラーが発生しました。
(S)：処理を中断します。
(P)：エラーの原因を取り除いてから、再度実行してください
KFPX27916-E
More than 2000000 input length
SQL、pdsqlコマンドの入力が2000000文字を超えています。
(S)：処理を中断します。
(P)：2000000文字以下のSQL、pdsqlコマンドを入力してください。
KFPX27917-E
More than 32760 input line length
1行の入力文字列が32760文字を超えています。
(S)：処理を中断します。
(P)：1行が32760文字以下に収まるよう編集してください。


ＨｉＲＤＢメッセージ

  HiRDBメッセージは、「HiRDB V7 07-02」を収録しています。これ以外のHiRDBのバージョンに関しては、該当バージョンのマニュアル「HiRDB メッセージ」を参照してください。

  なお、これ以外のメッセージ内容については、マニュアル「ＨｉＲＤＢ　メッセージ」又は「XDM E2系メッセージ（XDM/RD E2）」を参照してください。

・HiRDB KFPAメッセージ

・HiRDB KFPBメッセージ

・HiRDB KFPCメッセージ

・HiRDB KFPDメッセージ

・HiRDB KFPHメッセージ

・HiRDB KFPIメッセージ

・HiRDB KFPJメッセージ

・HiRDB KFPKメッセージ

・HiRDB KFPLメッセージ

・HiRDB KFPMメッセージ

・HiRDB KFPNメッセージ

・HiRDB KFPOメッセージ

・HiRDB KFPRメッセージ

・HiRDB KFPSメッセージ

・HiRDB KFPTメッセージ

・HiRDB KFPUメッセージ

・HiRDB KFPWメッセージ

・HiRDB KFPXメッセージ

・HiRDB KFPYメッセージ

・HiRDB KFPZメッセージ


KFPAメッセージ

KFPA11101-E
More than 255 nested operations, or implementation restriction exists　　（Ａ）
演算のネストの深さが255を超えています。又は，システムの処理上の制限によってSQL文が実行できません。
(Ｓ)このSQL文を無視します。
(Ｐ)次のどちらかの処置をしてください。
・演算のネストの深さを255以下に修正し，再度実行してください。なお，名前付きの導出表を指定しているSQLの場合，そのSQL中では255を超えていないことがあります。この場合，そのSQL中，又は名前付き導出表を導出する問合せ中の演算の数を減らしてください。
・SQL文を簡単にする（表数又は列数を減らすなど）か，又は該当するSQL文で参照している表のインデクス数を減らして，再度実行してください。
KFPA11102-E
More than aa....aa bytes in character string literal　　（Ａ）
次に示す数が，指定できる最大数（aa....aa）を超えています。
・文字列定数に指定したバイト数
・文字列定数同士の連結演算の結果のバイト数
・引数に定数を指定したスカラ関数（HEX）の結果のバイト数
最大数を次に示します。
・SQLSTATE値に指定した場合：5
・CREATE TABLE，又はALTER TABLEの境界値及び格納条件に指定した場合：255
・そのほかの場合：32000
aa....aa：｛5｜255｜32000｝
(Ｓ)このSQL文を無視します。
(Ｐ)文字列定数をaa....aaバイト以下に修正し，再度実行してください。
KFPA11103-E
Invalid floating point numeric literal aa....aa　　（Ａ）
指定した浮動小数点数定数の形式に誤りがあります。
aa....aa：不正な浮動小数点数定数
(Ｓ)このSQL文を無視します。
(Ｐ)浮動小数点数定数を修正し，再度実行してください。
KFPA11104-E
Invalid part "aa....aa" in SQL　　（Ａ）
SQL文に次のような誤りがあります。
・SQL文の後ろに余分な文字列があります。
・構文上許されない文字，又はキーワードがあります。
・SQL文の最初のキーワードが誤っています。
・名前が英字で始まっていません。
aa....aa：SQL文中に誤りがある部分。
構成の規則で指定できない文字がある場合，その文字とその文字の16進表示を括弧で囲んで表示します。
(Ｓ)このSQL文を無視します。
(Ｐ)誤りを修正し，再度実行してください。
KFPA11105-E
Invalid token "bb....bb" after token "aa....aa"　　（Ａ）
SQL文中のaa....aaの後ろには，構文上bb....bbは指定できません。
aa....aa：構文を満たした最後の文字
bb....bb：構文を満たさない誤った文字
(Ｓ)このSQL文を無視します。
(Ｐ)次に示すような誤りが考えられます。このため，SQL文を修正し，再度実行してください。
・構文の規則どおりに指定されていません。
・句の指定順序に誤りがあります。
KFPA11106-E
Incomplete SQL　　（Ａ）
SQL文が完成していません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を完成させ，再度実行してください。
KFPA11107-E
More than 30 characters in identifier "aa....aa"　　（Ａ）
名前の長さが30文字を超えています。
aa....aa：長さが30文字を超えた名前
{認可識別子｜パスワード｜表識別子｜列名｜インデクス識別子｜相関名｜RDエリア名｜ルーチン識別子｜カーソル名｜RDノード名｜SQLパラメタ名｜文ラベル｜SQL変数名｜外部サーバ名｜グループID｜リスト名｜属性名｜データ型識別子｜インデクス型識別子｜条件名｜トリガ識別子｜制約名｜ループ変数名｜拡張文名｜拡張カーソル名}
(Ｓ)このSQL文を無視します。
(Ｐ)名前の長さを30文字以下に修正し，再度実行してください。ただし，認可識別子の長さは8文字以下に修正してください。
KFPA11112-E
Invalid argument of set function "aa....aa"　　（Ａ）
集合関数aa....aaの引数の指定に，次のどれかの誤りがあります。
・引数中に列指定がありません。
・集合関数MAX，MIN以外の引数に，FLAT指定を指定しています。
・集合関数MAX，MINのFLAT指定に繰返し列以外の列を指定しています。
・列指定以外の値式を指定したGROUP BY句の問合せ指定に，FLAT指定を引数に指定した集合関数を指定しています。
aa....aa：集合関数の種別
{AVG | COUNT | MAX | MIN | SUM}
(Ｓ)このSQL文を無視します。
(Ｐ)集合関数の引数の指定を構文の規則どおりに修正し，再度実行してください。
KFPA11113-E
Set function "aa....aa" is specified in argument of set function, query-no=bbb　　（Ａ）
集合関数の引数に集合関数aa....aaを指定しています。
aa....aa：集合関数の種別
{AVG | COUNT | MAX | MIN | SUM}
bbb：問合せの番号
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11114-E
Invalid specification in predicate "aaaaaaa",query-no=bbb　　（Ａ）
NULL述語，LIKE述語，XLIKE述語，BETWEEN述語，又は論理述語の指定に誤りがあります。
・NULL述語に，項目指定以外を指定しています。
・LIKE述語，XLIKE述語の値式，及びBETWEEN述語の行値構成子１に，定数，USER，CURRENT_DATE，CURRENT_TIME，CURRENT_TIMESTAMP，？パラメタ，埋込み変数を指定しています。
・LIKE述語，XLIKE述語，及び論理述語の値式に，行値構成子を指定しています。
aaaaaaa：オペランドが不正な述語
{NULL | LIKE | XLIKE | BETWEEN | BOOL}
bbb：その述語を指定した問合せの番号
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11116-E
Invalid search condition in "HAVING" clause, query-no=aaa　　（Ａ）
次のどちらかの誤りがあります。
・HAVING句中の探索条件に，誤ったLIKE述語，XLIKE述語，又はNULL述語を指定しています。
・HAVING句の探索条件に構造化繰返し述語を指定しています。
aaa：その述語を指定した問合せの番号
(Ｓ)このSQL文を無視します。
(Ｐ)HAVING句中の探索条件を修正し，再度実行してください。
KFPA11117-E
Number of aa....aa not equal to number of bb....bb　　（Ａ）
aa....aaの数とbb....bbの数が一致していません。
aa....aa：｛insert values｜update values specified by subquery｜left side row value constructor elements｜derived column list｝
bb....bb：｛insert columns｜update columns｜right side row value constructor elements｜derived columns｝
(Ｓ)このSQL文を無視します。ただし，定義系SQLの場合はロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11118-E
Invalid use of update table in update value　　（Ａ）
更新対象表の使用方法に次の誤りがあります。
・UPDATE文のSET句，又はADD句に指定した副問合せのFROM句に，更新する表を指定し，かつ更新する表の列を外への参照をして指定した場合，副問合せの選択式に次の属性の値式は指定できません。
・BLOB
・最大長が32,001バイト以上のBINARY
・繰返し列
・抽象データ型
・カーソルを使用したUPDATE文の場合，更新対象表をFROM句に指定した副問合せは，SET句中に指定できません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11119-E
Column "aa....aa" in bb....bb clause must be either group column or within set function, query-no=(ccc,ddd)　　（Ａ）
GROUP BY句又は集合関数の指定がある問合せでは，そのSELECT句，HAVING句，又はORDER BY句の列指定は，次のどちらかの条件を満たす必要があります。
・列指定はグループ化列です。
・列指定は集合関数の引数に指定しています。
GROUP BY句に列指定以外の値式を指定した場合，その問合せの選択式に指定したスカラ副問合せ中からグループ化列を参照できません。
aa....aa：列指定に誤りがある列の名前
bb....bb：aa....aaが指定されている句の名前
{ SELECT | HAVING | ORDER BY | subquery in SELECT}
ccc：その列を指定している最も内側の問合せの番号
ddd：その句を指定している問合せの番号
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11120-E
Cannot specify set function in cc....cc, query-no=(aaa,bbb)　　（Ａ）
集合関数は，次に示す句，又は文には指定できません。
・WHERE句
・SET句
・ADD句
・GROUP BY句
・FROM句中のON探索条件
・IF文の探索条件
・WHILE文の探索条件
・SET文
・RETURN文
・VALUES句
・CALL文
・WRITE LINE文
aaa：集合関数を指定した問合せの番号
bbb：その句又は文を指定した問合せの番号
cc....cc：集合関数の指定されている句又は文の名前
{"WHERE" clause | "SET" clause | "ADD"clause
| "ON" clause | "GROUP BY" clause | "IF" statement
| "WHILE" statement | "SET" statement
| "RETURN" statement | "VALUES" clause
| "CALL" statement | "WRITE LINE" statement }
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11121-E
Duplicate update items or insert columns　　（Ａ）
INSERT文では，挿入する列として，同じ列を2回以上指定しないでください。
UPDATE文では，更新する列又は更新属性として，同じ列又は同じ属性を２回以上指定しないでください。また，繰返し列の同じ要素を2回以上指定しないでください。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11122-E
More than 255 value expressions in "GROUP BY" clause　　（Ａ）
GROUP BY句中に指定した値式の数が255個を超えています。
(Ｓ)このSQL文を無視します。
(Ｐ)GROUP BY句中の値式の数を255個以下に修正し，再度実行してください。
KFPA11123-E
Duplicate columns "aa....aa" in "bb....bb" clause　　（Ａ）
GROUP BY句，ORDER BY句，FOR UPDATE句，又は導出列リストに，同じ列を2回以上指定しないでください。
aa....aa：2回以上指定している列の名前，又はソート項目指定番号
bb....bb：aa....aaが指定されている句の名前
｛GROUP BY｜ORDER BY｜FOR UPDATE OF｜derived column list｝
(Ｓ)このSQL文を無視します。
(Ｐ)指定した列名に誤りがある場合，列名を修正し，再度実行してください。
指定した列名に誤りがない場合，誤った指定を削除し再度実行してください。
KFPA11124-E
More than 255 columns in "ORDER BY" clause　　（Ａ）
ORDER BY句中に指定した列の数が255個を超えています。
(Ｓ)このSQL文を無視します。
(Ｐ)ORDER BY句中の列の数を255以下に修正し，再度実行してください。
KFPA11125-E
Invalid integer aa....aa in "ORDER BY" clause　　（Ａ）
ORDER BY句に指定したソート項目指定番号に次の誤りがあります。
・ソート項目指定番号が導出列の数を超えています。
aa....aa：誤ったソート項目指定番号
(Ｓ)このSQL文を無視します。
(Ｐ)ソート項目指定番号に，選択式のSELECT句中での導出列の位置を示す番号を指定して，再度実行してください。
KFPA11126-E
"ROW" can not be specified in "ORDER BY" clause using sort item number　　（Ａ）
ROW指定のあるSQL文中には，ORDER BY ソート項目指定番号の指定はできません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11127-E
Keyword "DISTINCT" already specified in query specification, query-no=aaa　　（Ａ）
一つの問合せ指定中に，DISTINCTを2回以上指定しないでください。
aaa：DISTINCTを2回以上指定している問合せの番号
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11128-E
Invalid use of keyword "NULL", query-no=aaa　　（Ａ）
NULLの使用方法に，次に示すどれかの誤りがあります。
・探索条件で，NULL述語以外に値として指定しています。
・SELECT句に指定しています。
・算術演算，又は連結演算の対象として指定しています。
・スカラ関数の引数として指定しています。
aaa：NULLを指定した問合せの番号
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11129-E
More than aa....aa bb....bb　　（Ａ）
SQL文中に指定したbb....bbの数が，指定できる最大数aa....aaを超えています。
aa....aa：指定できる最大数
(16|64|65|255|1023|30000)
bb....bb：最大数を超えた指定
{tables | select columns | update columns
| columns in "INTO" clause
| variables or parameters
| columns in "FOR UPDATE OF" clause
| insert columns | values in "VALUES" clause
| view columns | "WITH" query columns
| "java.sql.ResultSet[]" in EXTERNAL NAME clause
| attributes in type definition | data types
| function invocation
| multi-value columns in column name list of ARRAY predicate
| SQL variables and SQL parameters
| row value constructor elements｜derived columns｜correlation names }
(Ｓ)このSQL文を無視します。
(Ｐ)指定したbb....bbの数をaa....aa以下に修正し，再度実行してください。
KFPA11131-E
Invalid precision or scale in scalar function "DECIMAL"　　（Ａ）
スカラ関数DECIMALで指定した精度，位取りの値に誤りがあります。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11132-E
Invalid use of aa....aa dd....dd "bb....bb", query-no=ccc　　（Ａ）
aa....aa型の列，SQL変数又はSQLパラメタを不正に使用しています。
又は，aa....aa型の属性を不正に使用しています。又は，関数の戻り値のデータ型にaa....aa型の関数呼出しを不正に使用しています。
aa....aa：不正に利用されたデータ型{ BLOB | BINARY | abstract | BOOLEAN }
bb....bb：不正に利用された列，SQL変数，SQLパラメタ，属性，又は関数の名称
ccc：不正に利用された列，SQL変数，SQLパラメタ，属性，又は関数を指定している最も内側の問合せの番号
dd....dd：不正に利用された名称の種別
{ column，SQL variable or SQL parameter
| attribute | function invocation }
(Ｓ)このSQL文を無視します。ただし，このSQL文が定義系SQLの場合，ロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11133-E
Invalid specification of update value for aa....aa column or attribute　　（Ａ）
抽象データ型の列又は属性を更新・挿入するときは，挿入値・更新値として埋込み変数及び?パラメタは指定できません。
aa....aa：不正なデータ型（abstract）
(Ｓ)このSQL文を無視します。ただし，このSQL文が定義系SQLの場合，ロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11134-E
Invalid use of long data cc....cc "aa....aa", query-no=bbb　　（Ａ）
次のどれかの不正な使用をしています。
・長データの列，SQL変数，SQLパラメタを不正に使用しています。
・長データの属性を不正に使用しています。
・関数の戻り値のデータ型が長データの関数呼出しを不正に使用しています。
長データとは次のデータ型を示します。
・定義長が256バイト以上のCHAR，VARCHAR，MCHAR，MVARCHAR，及びBINARY
・定義長が128文字以上のNCHAR及びNVARCHAR
aa....aa：不正に使用された列，SQL変数，SQLパラメタ，属性，又は関数の名前
bbb：不正に使用された列，SQL変数，SQLパラメタ，属性，又は関数を指定している最も内側の問合せの番号
cc....cc：不正に使用された名前の種別
{ column，SQL variable or SQL parameter
| attribute | function invocation }
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11136-E
Invalid use of ? parameter in aa....aa statement　　（Ａ）
手続き定義，型定義の手続き本体，関数定義，又は型定義変更の関数本体中に？パラメタを使用しています。
aa....aa：CREATE PROCEDURE，PROCEDURE definition in CREATE TYPE，CREATE FUNCTION，FUNCTION definition in CREATE TYPE
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11137-E
More than 255 aa....aa in bb....bb　　（Ａ）
bb....bbに示す記述中に指定した項目数が，指定できる最大数（255）を超えています。
aa....aa：{ value expressions | row value constructors }
bb....bb：誤りがあるSQL文の指定
{"IN" predicate
| scalar function "VALUE"
| case abbreviation "COALESCE" }
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11138-E
Invalid use of derived table　　（Ａ）
導出表に対する相関名を指定していません。導出表に対する相関名は，最も外側の問合せに次の形式で指定した場合だけ省略できます。
・SELECT COUNT(*) FROM 導出表
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11139-E
More than 30000 elements in multi-value specification　　（Ａ）
繰返し値式中の要素の値が，最大値（30000）を超えています。繰返し値式とは，ARRAY［要素の値，…］のことを示します。
(Ｓ)このSQL文を無視します。ただし，定義系SQLの場合は，ロールバックします。
(Ｐ)要素の値の個数を減らして，再度実行してください。
KFPA11140-E
Invalid national character string literal　　（Ａ）
各国文字列定数の指定に構文誤りがあります。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文中の各国文字列定数を修正して，再度実行してください。
KFPA11141-E
More than aa....aa characters in national character string literal　　（Ａ）
次に示す数が，指定できる最大数（aa....aa）を超えています。
・各国文字列定数に指定した文字数
・各国文字列定数同士の連結演算の結果の文字数
最大数を次に示します。
・CREATE TABLE，又はALTER TABLEの境界値及び格納条件に指定した場合：127
・そのほかの場合：16000
aa....aa：16000，又は127
(Ｓ)このSQL文を無視します。
(Ｐ)各国文字列定数をaa....aa文字以下になるように修正し，再度実行してください。
KFPA11144-E
Invalid aa....aa string literal　　（Ａ）
16進文字列定数の指定に，次の構文上の誤りがあります。
aa....aa：｛usage of hex｜hex｝
usage of hexの場合：
次の箇所に16進文字列定数を指定しています。
・COMMENT文
・プラグインオプション
・CREATE TABLE，又はALTER TABLEの境界値及び格納条件
hexの場合：
・16進文字列定数に指定した16進文字の長さが2の倍数ではありません。
・16進文字列定数に指定した16進文字の中に，0～9，a～f，及びA～F以外の文字があります。
(Ｓ)このSQL文を無視します。
(Ｐ)
aa....aaがusage of hexの場合：
16進文字列定数ではなく，文字列定数を使用してください。
aa....aaがhexの場合：
次のどちらかの対策をした後，再度実行してください。
・16進文字列定数の16進文字の長さを2の倍数にしてください。
・16進文字列定数に指定した16進文字から，0～9，a～f，及びA～F以外の文字を削除してください。
KFPA11145-E
More than 64000 bytes in hex string literal　　（Ａ）
16進文字列定数に指定した16進文字の長さが，64,000文字を超えています。
(Ｓ)このSQL文を無視します。
(Ｐ)16進文字列定数の16進文字の長さを64,000文字以下にして，再度実行してください。
KFPA11146-E
More than 255 compound(BEGIN) statements and FOR statement nested　　（Ａ）
複合文，及びFOR文のネストの深さが255を超えています。
(Ｓ)このSQL文を無視します。
(Ｐ)複合文，及びFOR文のネストの深さを255以下に修正し，再度実行してください。
KFPA11148-E
Invalid use of holdable cursor　　（Ａ）
ホールダブルカーソルの指定に次のような誤りがあります。
・ホールダブルカーソルを指定した場合，次の指定はできません。
・他RDノードの表（リモートデータベースアクセスの場合）
・１行検索には指定できません。
・プラグインが提供している抽象データ型の列を含む表を指定した検索には指定できません。
・プラグインが提供している関数呼出しを指定した検索には指定できません。
・プラグインが提供している関数呼出しを指定して導出した，名前付き導出表に対する検索には指定できません。
・リストを用いた検索には指定できません。
・外部表，又は外部表を基表とするビュー表を使用した検索には指定できません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11149-E
Invalid use of keyword "ROW"　　（Ａ）
ROWの使用方法で，次に示す誤りがあります。
・GROUP BY句，HAVING句，及び集合関数を指定した問合せには，ROWを指定できません。
・副問合せ（FROM句の導出表も含む）の中では，ROWを指定できません。
・UNIONを使用した問合せでは，ROWを指定できません。
・ビュー定義の問合せ中，及びWITH句中ではROWを指定できません。
・FOR文のカーソル指定の導出表にはROWを指定できません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11154-E
Invalid use of SQL parameter or SQL variable "aa....aa"　　（Ａ）
CREATE PROCEDURE，CREATE TRIGGER，CREATE FUNCTION，又はCREATE TYPE文以外のSQL文に，SQLパラメタ又はSQL変数を指定しています。
aa....aa：指定されたSQL変数名又はSQLパラメタ名
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11155-E
Invalid use of "aa....aa" clause　　（Ａ）
カーソル宣言以外で，FOR UPDATE OF，又はFOR READ ONLY句は指定できません。
aa....aa：誤った指定をしている句の名称
{FOR UPDATE OF | FOR READ ONLY}
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文又は更新オプションを修正し，再度実行してください。
KFPA11156-E
Invalid query for "UPDATE" or "DELETE" statement with cursor　　（Ａ）
カーソルを使用した更新，削除のための問合せ，又は，FOR UPDATE句を指定した問合せでは，次の指定はできません。
・表の結合
・FROM句の導出表
・グループ分け
・集合関数
・重複排除
・最も外側の問合せ指定のFROM句で指定した表を，副問合せのFROM句に指定
・読み込み専用のビュー表
・UNION [ALL]又はEXCEPT [ALL]
・WITHOUT LOCK NOWAIT
・WITH句を指定した問合せ式本体の最も外側の問合せ指定のFROM句に，問合せ名を指定
・外部表，又は外部表を基表とするビュー表
・手続きから返却された結果集合
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11157-E
Invalid use of "UPDATE" or "DELETE" statement with cursor　　（Ａ）
カーソルを使用したUPDATE文，又はDELETE文に，次のどれかの誤りがあります。
・静的に宣言するカーソルを使用したUPDATE文，又はDELETE文は，PREPARE文で前処理できません。
・前処理できるカーソルを使用したUPDATE文，又はDELETE文は，静的に実行できません。
・カーソルが正しく宣言されていないか，又は割り当てられていません。
(Ｓ)このSQL文を無視します。
(Ｐ)次のどれかの処置をしてください。
・SQLを動的実行する場合は，SQL文を前処理できるカーソルを使用したUPDATE文，又はDELETE文に修正し，再度実行してください。
・SQLを静的実行する場合は，SQL文を静的に宣言するカーソルを使用したUPDATE文，又はDELETE文に修正し，再度実行してください。
・カーソルの宣言又は割り当てを修正して，再度実行してください。
KFPA11158-E
Invalid SQL statement for pddef utility　　（Ｓ）
データベース定義ユティリティ（pddef）では，実行できないSQL文を指定しています。
(Ｓ)このSQL文を無視します。
(Ｐ)データベース定義ユティリティで実行できるSQL文に修正し，再度実行してください。
KFPA11159-E
Unable to specify aa....aa in bb....bb SQL　　（Ａ）
ASSIGN LIST文，DROP LIST文，及びリストを使用した検索は，直接ホストプログラムに埋め込んで実行できません。また，GET DIAGNOSTICSは動的に実行できません。
aa....aa：｛ASSIGN LIST｜DROP LIST｜query using LIST
｜GET DIAGNOSTICS｝
bb....bb：｛dynamic｜static｝
(Ｓ)このSQL文を無視します。
(Ｐ)次のどれかの処置をしてください。
・ASSIGN LIST文及びDROP LIST文は，PREPARE文又はEXECUTE IMMEDIATE文に指定してください。
・リストを使用した検索はPREPARE文に指定してください。
・GET DIAGNOSTICSは，PREPARE文又はEXECUTE IMMEDIATE文には指定しないでください。
KFPA11161-E
Zero divisor specified　　（Ａ）
除数として0が指定されました。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11162-E
Ending label name must be the same name us beginning label name, beginning-label=aa....aa,ending-label=bb....bb　　（Ａ）
開始ラベルと終了ラベルの名称が一致していません。
aa....aa：指定した開始ラベル
bb....bb：指定した終了ラベル
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11163-E
Invalid search condition in IF statement or WHILE statement　　（Ａ）
IF文又はWHILE文の探索条件中に次の誤りがあります。
・副問合せを指定しています。
・構造化繰返し述語を指定しています。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11164-E
Missing cursor name after "where current of"　　（Ａ）
カーソルを使用したUPDATE文又はDELETE文に，カーソル名又は拡張カーソル名の指定がありません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11165-E
Invalid value "aa....aa" of cc....cc "bb....bb"　　（Ａ）
SQL文に次のどれかの誤りがあります。
・指定したコンパイルオプションの値又は識別子に誤りがあります。
・CREATE FOREIGN TABLEに指定したオプション値に誤りがあります。
・CREATE SERVERに指定したOPTIONSのオプション値に誤りがあります。
・CREATE USER MAPPINGに指定したOPTIONSのオプション値に誤りがあります。
・CREATE USER MAPPINGのOPTIONSにUSERを指定していません。
aa....aa：指定したコンパイルオプション又はオプションの値，識別子
30文字以上の場合は，先頭から30文字を表示します。また，オプション値が空文字列の場合は********となります。
bb....bb：誤りのあるコンパイルオプション又はオプション
｛ISOLATION｜OPTIMIZE LEVEL｜ADD OPTIMIZE LEVEL｜COLLATING_SEQUENCE｜TRAILING_SPACE｜NULLABLE＿SCHEMA｜TABLE｜USING_BES｜USER｜PASSWD｝
cc....cc：誤りのある箇所
｛compile option｜OPTIONS｝
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11167-E
More than 255 WHEN clauses in CASE expression, query_no=aaa　　（Ａ）
一つのCASE式で指定されたWHENの数，又は最も外側のCASE式及びそのCASE式にネストして書かれたCASE式に含まれるすべてのWHENの総和が，255個を超えています。
aaa：CASE式を指定した問合せの番号
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11168-E
Invalid search condition in CASE expression, query_no=aaa　　（Ａ）
CASE式の探索条件に，次の誤りがあります。
・構造化繰返し述語を指定しています。
aaa：CASE式を指定した問合せの番号
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11169-E
Unable to specify joined table in view definition, "WITH" query or query expression body with "WITH" clause　　（Ａ）
ビュー定義の導出問合せ式，WITH句の導出問合せ式，及びWITH句指定のある問合せ式の問合せ式本体では，結合表は指定できません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11170-E
Unable to specify national character or mixed character in environment using single-byte character code set or Unicode (UTF-8) character code set　　（Ａ）
単一バイト文字コードを使用している場合に，次の誤りがあります。
・各国文字／混在文字列定数を使用しています。
・各国文字／混在文字データ型の列を定義しています。
Unicode（UTF-8）を使用している場合に，次の誤りがあります。
・各国文字定数を使用しています。
・各国文字データ型の列を定義しています。
(Ｓ)このSQLを無視します。
(Ｐ)SQL文を修正して，再実行してください。
KFPA11171-E
Duplicate value expressions in "GROUP BY" clause　　（Ａ）
GROUP BY句に同じ形式の値式を2回以上指定できません。
(Ｓ)このSQLを無視します。
(Ｐ)SQL文を修正して，再実行してください。
KFPA11172-E
Unable to specify outer reference "aa....aa"."bb....bb" in query with grouping by expression, query-no=ccc　　（Ａ）
副問合せ中のGROUP BY句に列指定以外の値式を指定している場合，その副問合せのWHERE句又はON句には外へ参照する列を指定できません。
aa....aa：表識別子，又は相関名
bb....bb：外へ参照している列名
ccc：外へ参照する列を指定した問合せの番号
(Ｓ)このSQLを無視します。
(Ｐ)SQL文を修正して，再実行してください。
KFPA11173-E
Invalid value expression in "GROUP BY" clause,query-no=aaa　　（Ａ）
GROUP BY句の指定に次の誤りがあります。
・ビュー定義中，又はWITH句の導出問合せ式中のGROUP BY句に，列指定以外の値式を指定しています。
・GROUP BY句に列指定以外の値式を指定した問合せ指定の，WHERE句の副問合せのGROUP BY句に，列指定以外の値式を指定しています。
・GROUP BY句の値式中に，?パラメタ，埋込み変数を指定しています。
・GROUP BY句の値式中に，コンポネント指定を指定しています。
・GROUP BY句の値式中に，副問合せを指定しています。
aaa：誤りのあるGROUP BY句を指定した問合せの番号
(Ｓ)このSQLを無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11174-E
RETURN statement not specified in function definition　　（Ａ）
関数定義中にRETURN文を指定していません。
(Ｓ)このSQLを無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11175-E
Unable to specify component specification in derived table　　（Ａ）
コンポネント指定は，導出表中に指定できません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11176-E
Specify only routine control statement in function except FOR statement definition　　（Ａ）
関数定義中には，FOR文を除くルーチン制御SQLだけを指定してください。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11177-E
Invalid specification of argument in aa....aa　　（Ａ）
関数呼出しの引数の指定に次に示す誤りがあります。
・"ASデータ型"を指定しないで，引数に？パラメタ又は埋込み変数を指定しています。
・"ASデータ型"のデータ型に既定義型以外を指定しています。
・？パラメタ又は埋込み変数以外の引数に"ASデータ型"を指定しています。
・？パラメタ又は埋込み変数を使用した単項演算を引数に指定しています。
・スカラ関数（LENGTH，SUBSTR，POSITION）の引数，又は代入文の代入値にASデータ型を指定した場合の記述
・埋込み文字
スカラ関数（LENGTH，SUBSTR，POSITION）の引数に指定した値式，又は代入文の代入値の指定に以下の誤りがあります。
・"ASデータ型"を指定しないで，引数に？パラメタ又は埋込み変数を指定しています。
・"ASデータ型"のデータ型にBLOB又はBINARY以外のデータ型を指定しています。
・？パラメタ又は埋込み変数以外の値式に"ASデータ型"を指定しています
・？パラメタ又は埋込み変数を用いた単項演算を引数に指定しています
(Ｓ)このSQLを無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11179-E
Unable to specify aa....aa in search condition of ARRAY predicate, query-no=bbb　　（Ａ）
構造化繰返し述語の探索条件には，次の指定はできません。
・構造化繰返し述語を指定しています。
・副問合せを指定しています。
・ARRAY（繰返し列〔，繰返し列〕…）で指定した列以外の列を指定しています。
・述語の比較条件に，次に示す指定をしています。
・システム定義スカラ関数，関数呼出し，及びIS_USER_CONTAINED_IN_HDS_GROUPを含む述語
・列指定を含まない述語
aa....aa：｛ARRAY predicate｜subquery
｜except columns in column-name list of ARRAY predicate
｜function invocation | predicate without column｝
bbb：述語を指定した問合せの番号
(Ｓ)このSQLを無視します。ただし，定義系SQLの場合は，ロールバックします。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11180-E
Subscript specified for single-value column, SQL variable or SQL parameter "aa....aa", query-no=bbb　　（Ａ）
繰返し列でない列，SQL変数，又はSQLパラメタ"aa....aa"に対して，添字は指定できません。
aa....aa：誤って添字を指定した項目
bbb：aa....aaを指定している最も内側の問合せの番号
(Ｓ)このSQL文を無視します。ただし，定義系SQLの場合は，ロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11181-E
Invalid use of multi-value column "aa....aa" without subscript, query-no=bbb　　（Ａ）
添字を省略した繰返し列を，指定できない場所に指定しています。
aa....aa：添字を省略した繰返し列の列名
bbb：aa....aaを指定している最も内側の問合せの番号
(Ｓ)このSQL文を無視します。ただし，定義系SQLの場合は，ロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11182-E
Invalid use of multi-value column "aa....aa" with subscript, query-no=bbb　　（Ａ）
添字指定の繰返し列を，指定できない場所に指定しています。
aa....aa：添字指定の繰返し列の列名
bbb：aa....aaを指定している最も内側の問合せの番号
(Ｓ)このSQL文を無視します。ただし，定義系SQLの場合は，ロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11183-E
Invalid use of multi-value column "aa....aa", query-no=bbb　　（Ａ）
繰返し列を，指定できない場所に指定しています。
aa....aa：誤って指定した列名。ただし，不正に指定している列が，繰返し列を引数に持つ集合関数から導出された名前付き導出表の列の場合，該当する名前付き導出表の基表の列名が表示されます。
bbb：aa....aaを指定している最も内側の問合せの番号
(Ｓ)このSQL文を無視します。ただし，定義系SQLの場合は，ロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11184-E
Subscript of multi-value column "aa....aa" exceeds maximum number of elements, query-no=bbb　　（Ａ）
指定した繰返し列の添字が，最大要素数を超えています。
aa....aa：繰返し列の列名
bbb：aa....aaを指定している最も内側の問合せの番号
(Ｓ)このSQL文を無視します。ただし，定義系SQLの場合は，ロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11185-E
Invalid specification of update or insert value for column "aa....aa"　　（Ａ）
挿入値又は更新値に，次のどれかの誤りがあります。
挿入値の場合：
・添字を省略した繰返し列に対して，NULL以外の単純構造の値を指定しています。
・単純構造の列に対して，繰り返し構造の値を指定しています。
SET句の更新値の場合：
・添字を省略した繰返し列に対して，NULL以外の単純構造の値を指定しています。
・コンポネント指定，単純構造の列，添字指定の繰返し列に対して，繰返し構造の値を指定しています。
ADD句の更新値の場合：
・単純構造の値を指定しています。
・繰返し列の要素の値に副問合せを指定しています。
aa....aa：挿入値又は更新値の指定に誤りがあった列名，又はコンポネント指定の列名
(Ｓ)このSQL文を無視します。ただし，定義系SQLの場合は，ロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11186-E
Invalid subscript for multi-value column "aa....aa", query-no=bbb　　（Ａ）
繰返し列に指定した添字に誤りがあります。
aa....aa：繰返し列の列名
bbb：aa....aaを指定している最も内側の問合せの番号
(Ｓ)このSQL文を無視します。ただし，定義系SQLの場合は，ロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11187-E
DISTINCT specified for multi-value column, query-no=aaa　　（Ａ）
繰返し列に対してDISTINCTは指定できません。
aaa：繰返し列を指定している最も内側の問合せの番号
(Ｓ)このSQL文を無視します。ただし，定義系SQLの場合は，ロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11189-E
Invalid subscript for multi-value column "aa....aa"　　（Ａ）
CREATE TABLE，又はALTER TABLEで指定した，繰返し列aa....aaの最大要素数に誤りがあります。
aa....aa：繰返し列の列名
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11191-E
Subquery specified in ASSIGN LIST statement　　（Ａ）
ASSIGN LIST文に副問合せ（NOT指定のないIN述語中での，外への参照のない副問合せを除く）を指定しています。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11192-E
Two or more selection items specified in scalar subquery, query-no=aaa　　（Ａ）
スカラ副問合せ，検索項目を二つ以上指定しています。
aaa：検索項目を二つ以上指定している副問合せの番号
(Ｓ)このSQL文を無視します。
(Ｐ)検索項目の数が，一つになるようにSQL文を修正して，再度実行してください。
KFPA11194-E
Unable to specify qualified column name in ORDER BY clause in query using set operation　　（Ａ）
集合演算を用いた問合せのORDER BY句に修飾子付き列名を指定しています。
(Ｓ)このSQL文を無視します。
(Ｐ)次のようにSQLを修正して，再度実行してください。
・最初の問合せ指定のSELECT句にAS 列名を指定した場合，AS 列名で指定した列名を指定してください。
・AS 列名を指定していない場合は，表指定を削除してください。
・ソート項目指定番号を指定してください。
・ソートをしない場合は，ORDER BY句を削除してください。
KFPA11195-E
Derived tables for SET operation must have same number of columns　　（Ａ）
集合演算の指定時に，導出列の数が一致していません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11196-E
Precision exceeds 29 in aa....aa, result data type decimal, column-no=bbbbb, query-no=ccc　　（Ａ）
スカラ関数VALUEを実行した結果のデータ型，CASE式の結果のデータ型，集合演算を実行した結果のデータ型，又は関数呼出しの結果のデータ型がDECIMALデータ型になります。また，その精度が29を超えました。
aa....aa：誤りがあるSQL文の指定
{ scalar function | SET operation
| CASE expression
| function invocation }
bbbbb：導出表の何番目の精度が29を超えたかを示す列番号（0の場合は，スカラ関数，CASE式，又は関数呼出しであることを示します）
ccc：エラーとなったスカラ関数，CASE式，集合演算，又は関数呼出しを指定した問合せの番号
(Ｓ)このSQL文を無視します。ただし，このSQL文が定義系の場合ロールバックします。
(Ｐ)スカラ関数VALUE，CASE式，又は集合演算に指定した10進数データを修正し，再度実行してください。関数呼出しの場合は，関数定義中のRETURNS句のデータ型を修正し，再度実行してください。
KFPA11197-E
Inconvertible data type in SET operation, column-no=aaaaa, query-no=bbb　　（Ａ）
集合演算の指定時に，対応する列のデータ型が変換できないデータ型です。
aaaaa：導出表の何番目の列がエラーとなったかを示す列番号
bbb：エラーとなった問合せの番号
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11198-E
Invalid specification of SET clause in UPDATE statement　　（Ａ）
UPDATE文の指定に，次の誤りがあります。
・SET句の代入先に更新対象の項目を一つだけ指定する場合は，更新対象の項目を括弧で囲まないでください。
・SET句の代入先に更新対象の項目を複数指定する場合は，更新対象の項目全体を括弧で囲んでください。また，その場合には，代入元には副問合せを指定してください。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11200-E
Invalid table specification in CREATE ALIAS statement　　（Ａ）
CREATE ALIAS文の表指定に誤りがあります。
CREATE ALIAS文の表指定は，RDノード名称．認可識別子．表識別子の形を指定してください。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11201-E
Invalid item specification, authorization identifier aa....aa, table identifier aa....aa, table identifier, correlation name, query name, statement label or routine identifier "bb....bb", query-no=ccc　　（Ａ）
列名を修飾する表指定が，SQL文に指定された有効な名称ではありません。又は，SQLパラメタ若しくはSQL変数の修飾が，SQL文に指定された有効な名前ではありません。
不正な修飾子は，aa....aa.bb....bb，又はbb....bbです。
aa....aa：表指定中で指定した認可識別子
bb....bb：表識別子，相関名，問合せ名，文ラベル名，又はルーチン名
ccc：不正な修飾子を指定している最も内側の問合せの番号
(Ｓ)このSQL文を無視します。ただし，このSQL文が定義系SQLの場合，ロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11202-E
Column, SQL variable or SQL parameter "aa....aa" not found in any tables, query names, statement labels or routines, query-no=bbb　　（Ａ）
列aa....aaは，SQL文若しくは問合せ指定の表，又は問合せ名にありません。又は，SQL変数若しくはSQLパラメタaa....aaは，ルーチン中に宣言されていません。
aa....aa：SQL文中にないSQL変数，SQLパラメタ，又は列名
bbb：列，SQL変数，又はSQLパラメタを指定した問合せの番号
(Ｓ)このSQL文を無視します。ただし，このSQL文が定義系SQLの場合，ロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11203-E
Column "aa....aa" ambiguous, query-no=bbb　　（Ａ）
列aa....aaが，この問合せ中の二つ以上の表又は問合せ名の中にあります。このため，列aa....aaがどの表又は問合せ名の列であるか決定できません。
aa....aa：問合せ中に二つ以上ある列名
bbb：その列を指定した問合せの番号
(Ｓ)このSQL文を無視します。
(Ｐ)表名，相関名又は問合せ名で列名を修飾して，再度を実行してください。
KFPA11204-E
Table/index/trigger aa....aa."bb....bb" not found in system　　（Ａ）
表，表別名，インデクス，又はトリガaa....aa.bb....bbが，HiRDBシステムにありません。
WITH句が指定されている操作系SQLの場合，表aa....aa.bb....bbがHiRDBシステムにありません。
又は，問合せ名bb....bbがWITH句中にありません。
aa....aa：認可識別子
bb....bb：表識別子，表別名，インデクス識別子，問合せ名，又はトリガ識別子
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11205-E
Column "aa....aa" not found in table bb....bb."cc....cc"　　（Ａ）
表bb....bb."cc....cc"に，又はFROM句の導出表の相関名若しくはWITH句の問合せの問合せ名"cc....cc"に，列"aa....aa"がありません。
aa....aa：列名
bb....bb：認可識別子
cc....cc：表識別子（導出表の場合は相関名），又は問合せ名
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11206-E
Invalid aa....aa type　　（Ａ）
表又はインデクスの指定に，次の誤りがあります。
表の場合：
・DROP TABLEでは，ビュー表及び外部表定義を削除できません。
・DROP VIEWでは，実表及び外部表定義を削除できません。
・DROP FOREIGN TABLEでは，実表及びビュー表を削除できません。
インデクスの場合：
・DROP INDEXでは，外部インデクス定義を削除できません。
・DROP FOREIGN INDEXでは，インデクス定義を削除できません。
aa....aa：｛table｜index｝
(Ｓ)このSQL文を無視します。
(Ｐ)
表の場合：
DROP TABLE実行時は実表を，DROP VIEW実行時はビュー表，DROP FOREIGN TABLE実行時には外部表を指定して，再度実行してください。
インデクスの場合：
DROP INDEX実行時はインデクスを，DROP FOREIGN INDEX実行時は外部インデクスを指定して，再度実行してください。
KFPA11207-E
cc....cc not found in table aa....aa."bb....bb"　　（Ａ）
表aa....aa."bb....bb"には，cc....ccが定義されていません。
aa....aa：認可識別子
bb....bb：表識別子
cc....cc：｛CLUSTER KEY | PRIMARY KEY | PRIMARY CLUSTER KEY｝
(Ｓ)このSQL文を無視します。
(Ｐ)このSQL文を削除してください。
KFPA11208-E
Sort column "aa....aa" must be selected column　　（Ａ）
ORDER BY句に指定した列aa....aaが最も外側の問合せのSELECT句に列指定されていません。
aa....aa：ソート列の列名
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11209-E
Column cannot be updated　　（Ａ）
更新できない列を更新しようとしました。更新しようとした列は，次に示す列です。
・格納条件を指定した列
・クラスタキーを指定した列
・インデクスを指定したWITHOUT ROLLBACK指定の表の列
(Ｓ)このトランザクションを無効にします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11210-E
"NOT NULL" constraint violation　　（Ａ）
ナル値が設定できない列，又はJavaストアドプロシジャの呼び出し時の引数にナル値を設定しようとしています。
・NOT NULLを指定して定義した列には，ナル値を設定できません。
・FIX属性の表の列，又はROWにはナル値を設定できません。
・クラスタキー又は主キーを構成するにはナル値を設定できません。
・Javaストアドプロシジャの定義時に，外部ルーチンとして指定するJavaメソッドの引数のデータ型がナル値を設定できない場合，そのJavaストアドプロシジャ呼び出し時に対応する引数にナル値を設定できません。
(Ｓ)このSQL文を無視します。
(Ｐ)ナル値が設定できない列，又はJavaストアドプロシジャの引数に，ナル値以外の値を設定し，再度実行してください。又は，Javaメソッドの引数をナル値が設定できるデータ型に変更して，Javaストアドプロシジャを定義し直し，再度実行してください。
KFPA11211-E
Duplicate identifier "aa....aa" in "FROM" clause, query-no=bbb　　（Ａ）
FROM句中の名前aa....aaが重複しています。同じ名前の相関名を二つ以上の表に対して使用しないでください。又は，表識別子若しくは問合せ名と同じ名前の相関名を使用しないでください。
aa....aa：名前
bbb：重複している名前を指定している問合せの番号
(Ｓ)このSQL文を無視します。ただし，このSQL文が定義系の場合，ロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11212-E
"NULL" predicate cannot be specified in column "aa....aa" with "NOT NULL", query-no=bbb　　（Ａ）
ナル値が指定できない列に対してNULL述語を指定しました。
・NOT NULLを指定して定義した列にNULL述語は指定できません。
・FIX属性の列又はROWにNULL述語は指定できません。
・クラスタキーの構成列にNULL述語は指定できません。
aa....aa：不正にNULL述語が指定された列名
bbb：不正な列を指定している最も内側の問合せの番号
(Ｓ)このSQL文を無視します。
(Ｐ)探索条件を修正し，再度実行してください。
KFPA11213-E
"ROW" specification ambiguous　　（Ａ）
ROWを指定した問合せ中に，該当する表が二つ以上あります。
このため，ROW指定は，どの表に対応する指定かが決定できません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11214-E
"ROW" can be specified only for "FIX" table　　（Ａ）
FIX属性の表以外には，ROWを指定できません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11215-E
Invalid update VALUE for "ROW" specification　　（Ａ）
ROWを指定してデータの挿入又は更新をする場合，更新値として埋込み変数，?パラメタ，SQL変数，又はSQLパラメタを指定してください。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11216-E
"ROW" cannot be specified for inner table　　（Ａ）
結合表の外結合に指定した内側表に対して，ROWは指定できません。
(Ｓ)このSQL文を無視します。ただし，このSQL文が定義系SQLの場合，ロールバックします。
(Ｐ)SQL文を修正して，再実行してください。
KFPA11217-E
Invalid use of SQLCODE or SQLCOUNT　　（Ａ）
SQLCODE又はSQLCOUNTを，IF文又はWHILE文の条件，SET文の代入値，及びRETURN文の戻り値以外で使用しています。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11218-E
Duplicate column "aa....aa" in derived table　　（Ａ）
FROM句の導出表中に，列"aa....aa"が複数あります。
aa....aa：重複した列名
(Ｓ)このSQL文を無視します。ただし，このSQL文が定義系SQLの場合，ロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11220-E
Sort column "aa....aa" found more than once in derived table　　（Ａ）
問合せの結果導出される表に，ORDER BY句に指定した列aa....aaが2個以上あります。
aa....aa：ORDER BY句に指定した列名
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11223-E
Invalid type, aa....aa must be specified　　（Ａ）
指定したデータ型の種別が誤っています。
aa....aaが"abstract data"の場合，under句にプラグインが提供するデータ型を指定して，サブタイプを定義できません。
aa....aa：指定する必要があるデータ型の種別
abstract data：抽象データ型
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11224-E
aa....aa type "bb....bb"."cc....cc" not found in system　　（Ａ）
種別aa....aaのユーザ定義型"bb....bb"."cc....cc"がHiRDBシステムにありません。
aa....aa：型の種別 { Data | Index }
bb....bb：認可識別子（型の所有者）
cc....cc：データ型識別子，又はインデクス型識別子
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11227-E
Column "aa....aa" in "ON" condition not found in any tables, query-no=bbb　　（Ａ）
ON条件中に指定した列名aa....aaは，次に示すどの表にもありません。
・そのON条件を含む結合表で結合する表
・外への参照ができる表
aa....aa：列名
bbb：問合せの番号
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11228-E
Attribute "aa....aa" not found in data type "bb....bb"."cc....cc"　　（Ａ）
データ型"bb....bb"."cc....cc"に，属性"aa....aa"がありません。
aa....aa：属性名
bb....bb：認可識別子（ユーザ定義型の所有者）
cc....cc：データ型識別子
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11230-E
Unable to specify other RDNODE in "CREATE PROCEDURE" or "ALTER PROCEDURE"　　（Ａ）
CREATE PROCEDURE文では，ほかのRDノードをアクセスするSQLは指定できません。又は，ALTER PROCEDURE文で再作成する手続きから，ほかのRDノードをアクセスするSQLがあります。
(Ｓ)このSQL文を無視します。
(Ｐ)
〈CREATE PROCEDURE文を実行した場合〉
ほかのRDノードをアクセスしないように定義文を修正し，再度実行してください。
〈ALTER PROCEDURE文を実行した場合〉
DROP PROCEDURE文を実行してから，定義文を，ほかのRDノードをアクセスしないように修正して，再度CREATE PROCEDURE文で作成してください。又は，DROP PROCEDURE文を実行した後で，この手続きを使わないように，UAPを修正してください。
KFPA11231-E
SQL variable "aa....aa" already defined　　（Ａ）
指定したSQL変数aa....aaは既に定義されています。
aa....aa：SQL変数
(Ｓ)このSQL文を無視してロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11232-E
Cursor "aa....aa" already defined　　（Ａ）
指定したカーソルは既に定義されています。
aa....aa：カーソル名
(Ｓ)このSQL文を無視してロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11233-E
DECLARE CURSOR statement missing for cursor "aa....aa"　　（Ａ）
指定したカーソルaa....aaは，カーソル宣言がされていません。
aa....aa：カーソル名
(Ｓ)このSQL文を無視してロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11234-E
Invalid statement label "aa....aa" in LEAVE statement　　（Ａ）
LEAVE文の文ラベル名"aa....aa"に，次のどれかの誤りがあります。
1. LEAVE文に指定されている文ラベル名がありません。
2. LEAVE文に指定された文ラベル名が，そのLEAVE文を含む複合文又はWHILE文の文ラベルではありません。
3. ラベル名を省略したLEAVE文が，複合文又はWHILE文に含まれていません。
4. ハンドラ動作を抜けるLEAVE文は，ハンドラ動作中には指定できません。
5. FOR文のループ変数名は指定できません。
aa....aa：文ラベル名（ラベル名を省略している場合は********）
(Ｓ)このSQL文を無視してロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11235-E
Number of call parameters not equal to number of SQL parameters　　（Ａ）
CALL文で指定した引数の数と，呼び出すプロシジャのSQLパラメタの数が一致しません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11236-E
Invalid use of SQL parameter or column "aa....aa", due to in/out parameter mode or qualification by old row value correlation　　（Ａ）
SQLパラメタ，又は旧値相関名で修飾した列aa....aaの使用方法について，次のどれかの誤りがあります。
・入力パラメタ又は旧値相関名で修飾した列をFETCH文，1行SELECTのINTO句，又は代入文の代入先に指定しています。
・CALL文の対象となるルーチンの引数定義が，OUT又はINOUTの引数に，入力パラメタ又は旧値相関名で修飾した列を指定しています。
・出力パラメタをFETCH文，1行SELECTのINTO句，代入文の代入先，又はWRITE LINE文の値式以外に指定しています。
・CALL文の対象となるルーチンの引数定義の，INの引数に出力パラメタを指定しています。
aa....aa：SQLパラメタ
(Ｓ)このSQL文を無視してロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11237-E
Unable to specified column "aa....aa", query-no=bbb　　（Ａ）
列aa....aaを指定できない場所に指定しています。
指定できない場所とは，次の場所です。
・LIKE文のパターン文字列，エスケープ文字
・IN述語の右側の値指定中
aa....aa：不正に指定している列
bbb：不正に指定している列の問合せの番号
(Ｓ)このSQL文を無視します。ただし，このSQL文が定義系SQLの場合は，ロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
SQL文中の表に，SQL変数又はSQLパラメタと同じ列名がある場合，SQL変数又はSQLパラメタをそれぞれの文ラベル名，手続き名で修飾してください。
KFPA11238-E
Invalid parameter mode of argument in call statement for SQL parameter definition of procedure　　（Ａ）
CALL文で指定した引数の指定（IN，OUT，INOUT）が，呼び出すプロシジャのSQLパラメタの指定（IN，OUT，INOUT）と一致していません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11240-E
Duplicate statement label or loop variable "aa....aa" appeared in the scope of statement label or loop variable　　（Ａ）
複合文，WHILE文，又はFOR文中に含まれる，ほかの文の文ラベル又はループ変数名に，同じ名称の文ラベル又はループ変数があります。
aa....aa：文ラベル名，又はループ変数名
(Ｓ)このSQL文を無視してロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11241-E
Invalid table specification, as qualifier, authorization identifier aa....aa, table identifier, correlation name or query name "bb....bb", query-no=ccc　　（Ａ）
列名，*又はROWを修飾する表指定が，SQL文に指定された有効な名前ではありません。
不正な修飾は，aa....aa.bb....bb，又はbb....bbです。
aa....aa：表指定中で指定した認可識別子
bb....bb：表識別子，相関名，又は問合せ名
ccc：不正な修飾を指定している最も内側の問合せの番号
(Ｓ)このSQL文を無視します。ただし，このSQL文が定義系SQLの場合，ロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11242-E
Column "aa....aa" not found in any tables or query names, query-no=bbb　　（Ａ）
列aa....aaは，SQL文，問合せ指定の表，又は問合せ名のどれにもありません。
aa....aa：SQL文中の表，又は問合せ名にない列名
bbb：表にない列名を指定した問合せの番号
(Ｓ)このSQL文を無視します。ただし，このSQL文が定義系SQLの場合，ロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11243-E
Table aa....aa. "bb....bb" with multi-value column in joined table　　（Ａ）
次の表は結合表に指定できません。
・繰返し列を含む表
・繰返し列を含む表から導出した表
aa....aa：繰返し列を含む表，又は繰返し列を含む表から導出した表の認可識別子
bb....bb：繰返し列を含む表，又は繰返し列を含む表から導出した表の表識別子
(Ｓ)このSQL文を無視します。ただし，このSQL文が定義系SQLの場合，ロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11245-E
Invalid part "aa....aa" in EXTERNAL NAME　　（Ａ）
外部ルーチン名に，次の誤りがあります。
・後ろに余分な文字列があります。
・構文上許されない文字又はキーワードがあります。
・JARファイル名又はクラス名が英字で始まっていません。
・JARファイル名の長さが255バイトを超えています。
・パッケージ名を含むクラス名の長さが255バイトを超えています。
・メソッド名の長さが255バイトを超えています。
aa....aa：外部ルーチン名に誤りがある部分。構成の規則で指定できない文字がある場合，その文字とその文字の16進表示を括弧で囲んで表示します。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11246-E
Incomplete EXTERNAL NAME　　（Ａ）
外部ルーチン名が完成していません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11247-E
Invalid Java method argument "aa....aa" in EXTERNAL NAME　　（Ａ）
外部ルーチン名のJavaTMメソッドの引数に，次の誤りがあります。
・java.sql.ResultSet型以降に，ほかのデータ型を指定しています。
・java.sql.ResultSet型を配列で指定していません。
・java.sql.ResultSet型に2次元以上の配列を指定しています。
・byte型を配列で指定していません。
・byte型に3次元以上の配列を指定しています。
・byte型でないデータ型に，2次元以上の配列を指定しています。
・CREATE FUNCTION中にjava.sql.ResultSet型を指定しています。
aa....aa：誤りがあるJavaメソッドの引数部分
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11248-E
Invalid Java method return data type "aa....aa" in EXTERNAL NAME　　（Ａ）
外部ルーチン名のJavaメソッドのreturn部分に，次の誤りがあります。
・java.sql.ResultSet型を指定しています。
・byte型でないデータ型に配列を指定しています。
・byte型を配列で指定していません。
・byte型に2次元以上の配列を指定しています。
aa....aa：誤りがあるJavaメソッドのreturn部分
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11249-E
Invalid specification of style in PARAMETER STYLE　　（Ａ）
パラメタスタイルに次の誤りがあります。
・LANGUAGE句にJAVAを指定していて，PARAMETER STYLE句にJAVA以外のパラメタスタイルを指定しています。
・LANGUAGE句にSQLを指定していて，PARAMETER STYLE句にSQL以外のパラメタスタイルを指定しています。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11250-E
Invalid number of DYNAMIC RESULT SETS　　（Ａ）
次のどれかの誤りがあります。
・DYNAMIC RESULT SETS句に指定した結果集合数の値が，負の値，又は最大値を超えています。
・DYNAMIC RESULT SETS句に指定した結果集合数の値に，外部ルーチン指定のJavaシグネチャに指定した結果集合数より小さい値を指定しています。
・SQL手続き中でWITH RETURNを指定したカーソルを宣言している場合に，DYNAMIC RESULT SETS句に0を指定しているか，又はDYNAMIC RESULT SETS句を指定していません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11251-E
Invalid item specification, authorization identifier aa....aa, statement label or routine identifier or loop variable "bb....bb", query-no=ccc　　（Ａ）
SQLパラメタ，SQL変数の修飾がSQL文に指定された有効な名前ではありません。又は，指定できない箇所に列指定を指定しています。
不正な修飾はaa....aa.bb....bb，又はbb....bbです。
aa....aa：項目指定中で指定した認可識別子
bb....bb：文ラベル名，ルーチン名，ループ変数名，又は表識別子
ccc：不正な修飾を指定している最も内側の問合せの番号
(Ｓ)このSQL文を無視します。ただし，このSQL文が定義系SQLの場合，ロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11252-E
SQL variable or SQL parameter "aa....aa" not found in any statement label or routine, query-no=bbb　　（Ａ）
SQL変数，又はSQLパラメタaa....aaは，ルーチン中に宣言されていません。又は，指定できない箇所に列名を指定しています。
aa....aa：ルーチン中にないSQL変数，SQLパラメタ，又は列名
bbb：ルーチン中にないSQL変数，SQLパラメタ，又は列名を指定している最も内側の問合せの番号
(Ｓ)このSQL文を無視します。ただし，このSQL文が定義系SQLの場合，ロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11254-E
Invalid specification aa....aa-th argument in CALL statement, reason=parameter mode "bb....bb"　　（Ａ）
CALL文のaa....aa番目の引数に，次のどちらかの誤りがあります。
・引数が値式であるが，IN以外のパラメタモードを指定しています。
・引数が値式であるが，呼び出す手続きがIN以外のパラメタモードになっています。
aa....aa：誤りがある引数の番号
bb....bb：CALL文の引数のパラメタモード，又は呼び出す手続きのパラメタモード
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11255-E
SQL variable "aa....aa" not found in statement label or loop variable "bb....bb"　　（Ａ）
SQL変数aa....aaは，文ラベル又はループ変数bb....bb中にありません。
aa....aa：存在しないSQL変数
bb....bb：文ラベル名，又はループ変数名
(Ｓ)このSQL文を無視します。ただし，このSQL文が定義系SQLの場合，ロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11256-E
SQL parameter "aa....aa" not found in routine bb....bb."cc....cc"　　（Ａ）
SQLパラメタaa....aaは，ルーチンbb....bb.cc....cc中にありません。
aa....aa：存在しないSQLパラメタ
bb....bb：認可識別子
cc....cc：ルーチン名
(Ｓ)このSQL文を無視します。ただし，このSQL文が定義系SQLの場合，ロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11259-E
Unable to specify invocation of aa....aa "bb....bb"."cc....cc" in definition of dd....dd with same name　　（Ａ）
ルーチン定義中には，現在定義しようとしている関数，又は手続きと認可識別子，ルーチン識別子，引数の数が一致するルーチン"bb....bb"."cc....cc"は指定できません。
aa....aa：｛function|procedure｝
bb....bb：認可識別子
cc....cc：ルーチン識別子
dd....dd：｛function|procedure｝
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11260-E
Attribute "aa....aa" not defined in abstract data bb....bb "cc....cc"　　（Ａ）
抽象データ型の列，SQL変数，SQLパラメタ，又は属性であるcc....ccの属性としてaa....aaは定義されていません。
aa....aa：定義されていない属性名称
bb....bb：{column，SQL variable or SQL parameter | attribute}
cc....cc：aa....aaを属性として指定している列，SQL変数，SQLパラメタ，又は属性の名称
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11262-E
aa....aa "bb....bb" not defined as abstract data　　（Ａ）
コンポネント指定中の修飾子であるbb....bbの列，SQL変数，SQLパラメタ，又は属性は，抽象データ型として定義されていません。
aa....aa：{ Column，SQL variable or SQL parameter | Attribute }
bb....bb：列，SQL変数，SQLパラメタ，又は属性の名称
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11263-E
Unable to access attribute "aa....aa" because of encapsulation level bb....bb　　（Ａ）
〈bb....bbがPRIVATEの場合〉
属性aa....aaは，隠蔽レベルがPRIVATEであるため，この属性を定義しているCREATE TYPE中でしかアクセスできません。
〈bb....bbがPROTECTEDの場合〉
属性aa....aaは，隠蔽レベルがPROTECTEDであるため，この属性を定義しているCREATE TYPE中か，そのサブタイプのCREATE TYPE中でしかアクセスできません。
aa....aa：属性名称
bb....bb：隠蔽レベル { PRIVATE | PROTECTED }
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11266-E
Unable to specify component specification in argument of set function　　（Ａ）
コンポネント指定は，集合関数の引数に指定できません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11267-E
Unable to specify component specification in "SELECT" clause in INSERT statement　　（Ａ）
コンポネント指定は，INSERT文のSELECT句に指定できません（副問合せのSELECT句は除きます）。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11273-E
Invalid use of WRITE specification　　（Ａ）
WRITE指定の使用方法で，次のどれかの誤りがあります。
・WRITE指定を指定した問合せには，重複排除を指定できません。
・WRITE指定はソートキーにできません。
・WRITE指定の出力BLOB値にBLOB列を指定した場合，選択式に同じ列を単独で指定，又はほかのWRITE指定の出力BLOB値に指定できません。
・WRITE指定の出力BLOB値が列以外の場合，その問合せにはFOR READ ONLYを指定できません。
・ルーチン中には指定できません。
・WRITE指定を指定した問合せには，集合演算を指定できません。
・INSERT文の問合せ指定の選択式にWRITE指定は指定できません。
・副問合せ（FROM句の導出表も含む）中の選択式にWRITE指定は指定できません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11274-E
Invalid use of GET_JAVA_STORED_ROUTINE_SOURCE specification　　（Ａ）
GET_JAVA_STORED_ROUTINE_SOURCE指定の使用方法で，次のどれかの誤りがあります。
・GET_JAVA_STORED_ROUTINE_SOURCE指定を指定した問合せには，重複排除を指定できません。
・GET_JAVA_STORED_ROUTINE_SOURCE指定はソートキーに指定できません。
・GET_JAVA_STORED_ROUTINE_SOURCE指定を指定した場合，その問合せにはFOR READ ONLYを指定できません。
・GET_JAVA_STORED_ROUTINE_SOURCE指定を指定した問合せには，集合演算を指定できません。
・INSERT文の問合せ指定の選択式には，GET_JAVA_STORED_ROUTINE_SOURCE指定は指定できません。
・副問合せ（FROM句の導出表も含む）中の選択式にGET_JAVA_STORED_ROUTINE_SOURCE指定は指定できません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11276-E
Unable to specify outer reference column of abstract data type　　（Ａ）
外への参照列である抽象データ型の列は指定できません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11277-E
Unable to specify outer reference column of BLOB data type in argument of function invocation　　（Ａ）
外への参照列であるBLOB列は，ユーザ定義関数の引数に指定できません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11280-E
PLUGIN not installed for abstract data type "aa....aa"."bb....bb"　　（Ａ）
抽象データ型aa....aa.bb....bbに対するプラグインがインストールされていません。
aa....aa：認可識別子
bb....bb：抽象データ型名
(Ｓ)このSQL文を無視します。
(Ｐ)必要なプラグインのインストールを管理者に依頼してください。
[対策]必要なプラグインをインストールしてください。
KFPA11281-E
PLUGIN "aa....aa" not installed　　（Ａ）
プラグインaa....aaがインストールされていません。
aa....aa：プラグイン名
(Ｓ)このSQL文を無視します。
(Ｐ)必要なプラグインのインストールを管理者に依頼してください。
[対策]必要なプラグインをインストールしてください。
KFPA11282-E
Receiving function for inter-function value passing can be specified only in "SELECT" or "SET" clause　　（Ａ）
受渡し値受信関数は，SELECT句，又はSET句の更新値にだけ指定できます（ルーチン制御文には指定できません）。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11283-E
Sending function for inter-function value passing can be specified only in "WHERE" clause or "ON" condition in query specification without view or "WITH" clause　　（Ａ）
受渡し値送信関数は，WHERE句又はON 探索条件にだけ指定できます（ルーチン制御文には指定できません）。ただし，外結合を指定した結合表のON探索条件に受渡し値送信関数を指定する場合，第1引数には外表の列を指定できません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11284-E
Sending function for inter-function value passing cannot be specified in "OR" condition　　（Ａ）
受渡し値送信関数は，インデクスを利用できる場合にだけOR条件に指定できます（NOT条件以下については，OR条件はAND条件に，AND条件はOR条件に変換されます）。
次の条件をすべて満たす場合にインデクスを利用できます。
・受渡し値送信関数の第1引数に，プラグインインデクスを定義している。
・受渡し値送信関数の第1引数が，外への参照列を除く実表の列指定である。
・受渡し値送信関数の第1引数を除く引数に，次の値式を含む引数を指定していない。
・外への参照列を除く列指定
・列に対するコンポネント指定
・受渡し値送信関数に対して，IS FALSE，IS UNKNOWN，及び否定（NOT）が含まれる述語を指定していない。
・CAST指定中に受渡し値送信関数を指定していない。
・FROM句に2表以上の指定がある場合，受渡し値送信関数の第1引数の列と異なる表の列を，ORのオペランドの探索条件中に指定していない。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11285-E
Function for inter-function value passing cannot be specified in "CASE" expression or scalar function "VALUE"　　（Ａ）
受渡し値受信・送信関数は，CASE式，スカラ関数VALUEに指定できません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11286-E
Receiving function for inter-function value passing without sending function　　（Ａ）
受渡し値受信関数は，同じ問合せ指定中に対応する受渡し値送信関数がない場合，指定できません。対応する受渡し値送信関数については，プラグインのマニュアルを参照してください。又は，リストを介した表の検索で，受渡し値受信関数がリストからの受渡し値の取得に対応していません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。リストを介した表の検索の場合は，プラグインのバージョンが古いため，受渡し値受信関数がリストからの受渡し値の取得に対応していないことがあります。その場合は，HiRDB管理者に連絡してください。
[対策]リストを介した表の検索の場合には，プラグインのバージョンを確認して，対応するバージョンのマニュアルを参照してください。受渡し値受信関数がリストからの受渡し値の取得に対応しているかを確認し，必要に応じてプラグインをバージョンアップしてください。
KFPA11287-E
Invalid specification of first argument in receiving function for inter-function value passing　　（Ａ）
受渡し値受信関数の第１引数が不正です。
受渡し値受信関数の第１引数は，次の条件を満たす必要があります。
・データ型が抽象データ型である必要があります。
・列指定，SQLパラメタ，又はSQL変数による指定である必要があります。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11288-E
Unable to specify receiving function for inter-function value passing except in set function in query with grouping or set function　　（Ａ）
受渡し値受信関数は，GROUP BY句，HAVING句，又は集合関数指定のある問合せで，集合関数の引数中以外では指定できません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11289-E
More than one sending function for inter-function value passing with same first arguments　　（Ａ）
第１引数が等しい受渡し値送信関数は，二つ以上指定できません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11291-E
No available index for ARRAY predicate　　（Ａ）
構造化繰返し述語を評価できるインデクスがありません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正するか，又はインデクスの定義を見直して，再度実行してください。
KFPA11292-E
Unable to specify ARRAY predicate in operand of boolean operator "NOT"　　（Ａ）
構造化繰返し述語をNOTで否定できません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11294-E
Unable to specify ARRAY predicate with columns of aa....aa of outer join in bb....bb, query-no=ccc　　（Ａ）
次に示す列に対して構造化繰返し述語は指定できません。
・外結合を含む問合せ指定のON検索条件中の外表の列
・外結合を含む問合せ指定のWHERE句中の内表の列
aa....aa：表の種類
inner table：内表
outer table：外表
bb....bb：条件の種類
"ON" condition：ON検索条件中
"WHERE" clause：WHERE句中
ccc：その述語を指定した問合せ番号
(Ｓ)このSQL文を無視して処理を続行します。ただし，定義系SQLの場合，ロールバックします。
(Ｐ)SQL文を次のように修正して，再実行してください。
・外結合を含む問合せ指定に，結合表の外表の列に対する構造化繰返し述語を指定する場合は，WHERE句中に指定してください。
・外結合を含む問合せ指定に，結合表の内表の列に対する構造化繰返し述語を指定する場合は，ON 検索条件中に指定してください。
KFPA11295-E
Unable to aa....aa rebalancing table bb....bb."cc....cc" with unique constraint　　（Ａ）
UNIQUE指定のインデクスを定義している表bb....bb."cc....cc"がリバランス中の場合，その表に対してaa....aa文は実行できません。
aa....aa：｛INSERT INTO | UPDATE｝
bb....bb：認可識別子
cc....cc：表識別子
(Ｓ)このSQL文を無視します。
(Ｐ)リバランスが終了してから再度実行してください。
KFPA11296-E
Unable to aa....aa shared table without LOCK TABLE IN EXCLUSIVE MODE　　（Ａ）
IN EXCLUSIVE MODE指定のLOCK文を実行しないで，共用表に対して次のSQLは実行できません。
・INSERT文
・インデクス更新を伴うUPDATE文
・USING BES指定のDEFAULT句を定義したTIMESTAMP列への，更新値にDEFAULTを指定したUPDATE文
・DELETE文
aa....aa：｛INSERT | UPDATE | DELETE｝
(Ｓ)このSQL文を無視します。
(Ｐ)挿入，更新，又は削除対象表にIN EXCLUSIVE MODE指定のLOCK文を実行し，SQLを再度実行してください。
KFPA11299-E
Duplicate LIST name "aa....aa" in ASSIGN LIST statement　　（Ａ）
ASSIGN LIST文に指定したリスト名”aa....aa”が重複しています。同じリスト名をASSIGN LIST文に指定できません。
aa....aa：重複したリスト名
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11301-E
Inconvertible data type of input variable aa....aa　　（Ａ）
aa....aa番目の入力変数のデータ型が，変換できるデータ型ではありません。又は，入力変数の構造（単純構造又は繰返し構造）が一致していません。
aa....aa：入力変数の順序番号
(Ｓ)このSQL文を無視します。
(Ｐ)入力変数を，変換できるデータ型及び正しい構造に変更し，再度実行してください。
KFPA11302-E
Input data too large for column or assignment target aa....aa　　（Ａ）
次のどれかの誤りがあります。
・入力データが，列のデータ型の値の範囲を超えています。
・入力データの要素数が繰返し列の最大要素数より大きいです。
・ユーザ定義関数又はシステム定義スカラ関数の呼び出しで，入力引数がパラメタのデータ型の値の範囲を超えています。
・スカラ関数VALUEの入力変数の引数が，データ型の値の範囲を超えています。
aa....aa：次のどちらかの文字
・in variable 変数の順序番号
入力変数を単独で指定している場合，又はスカラ関数VALUEの引数に入力変数を単独で指定している場合
・1バイトの空白
上記以外の場合
(Ｓ)このSQL文を無視します。
(Ｐ)入力データに誤りがあれば，修正して，再度実行してください。
KFPA11303-E
Inconvertible data type of output variable aa....aa　　（Ａ）
aa....aa番目の出力変数のデータ型が，変換できるデータ型ではありません。又は，入力変数の構造（単純構造又は繰返し構造）が一致していません。
aa....aa：出力変数の順序番号
(Ｓ)このSQL文を無視します。
(Ｐ)出力変数を，変換できるデータ型及び正しい構造に変更し，再度実行してください。
KFPA11304-E
Output data too large for variable aa....aa　　（Ａ）
出力するデータ長が変数の属性を超えています。
aa....aa：不正な出力変数の順序番号
(Ｓ)このSQL文を無視します。
(Ｐ)変数の属性を変更し，再度実行してください。
KFPA11305-E
Indicator must be specified for null value in variable aa....aa　　（Ａ）
標識変数が指定されていません。このため，ナル値の出力データが返せません。
aa....aa：不正な出力変数の順序番号
(Ｓ)処理を終了します。
(Ｐ)標識変数を指定し，再度UAPを実行してください。
KFPA11306-E
Invalid data aa....aa variable bbbbb　　（Ａ）
次のデータに誤りがあります（データの長さが奇数バイトの可能性があります）。
・bbbbb番目の入力変数中のデータ，又はbbbbb番目の出力変数に設定するデータ
・パラメタモードがOUT又はINOUTの，bbbbb番目のSQLパラメタに設定するデータ
・関数の戻り値として返却するデータ
aa....aa：変数の種類｛in input｜to output｝
bbbbb：次のどちらかの順序番号
・入力変数又は出力変数の順序番号
・パラメタモードがOUT又はINOUTのSQLパラメタの順序番号
なお，関数の戻り値の場合は*****となります。
(Ｓ)このSQLを無視します。
(Ｐ)データを修正して，再実行してください。
KFPA11307-E
No RDAREA for specified divided Key VALUEs　　（Ａ）
指定された値を格納するためのRDエリアが，表定義で指定されていません。
(Ｓ)このSQL文を無視します。
(Ｐ)指定した値が，格納条件を満足する値になるように変更してください。又は，格納条件の指定が正しいかどうか見直してください。
KFPA11308-E
Unexpected request, SQLNAME or TYPE option necessary in PREPARE　　（Ａ）
次の理由でDESCRIBE文又はDESCRIBE TYPE文は実行できません。
1. PREPARE文でWITH SQLNAME OPTIONを指定しないで，DESCRIBE文又はDESCRIBE TYPE文に列名又は属性名の受け取り（列名記述領域）を指定しています。
2. PREPARE文でWITH TYPE OPTIONを指定しないで，DESCRIBE文にユーザ定義型のデータ型名の受け取り（型名記述領域）を指定しています。
3. PREPARE文でWITH ALL TYPE OPTIONを指定しないで，DESCRIBE TYPE文を指定しています。
(Ｓ)このSQL文を無視します。
(Ｐ)
1. PREPARE文にWITH SQLNAME OPTIONを指定し，再度実行してください。又は，DESCRIBE文又はDESCRIBE TYPE文で列名記述領域を指定しないで，再度実行してください。
2. PREPARE文にWITH TYPE OPTIONを指定し，再度実行してください。又は，DESCRIBE文で型名記述領域を指定しないで，再度実行してください。
3. PREPARE文にWITH ALL TYPE OPTIONを指定し，再度実行してください。又は，DESCRIBE TYPE文で型名記述領域を指定しないで，再度実行してください。
KFPA11310-E
Invalid number of variables　　（Ａ）
SQL記述領域に指定したSQLN，又はSQLDの値が誤っています。
(Ｓ)このSQL文を無視します。
(Ｐ)SQLN又はSQLDの指定値を，0≦SQLD≦30000，及びSQLD≦SQLN≦30000を満たすように修正して，再度UAPを実行してください。
KFPA11311-E
Invalid data type or length of variable aa....aa　　（Ａ）
aa....aa番目の埋込み変数，又はパラメタの変数宣言が誤っています。又は，SQL記述領域に設定したaa....aa番目の変数の最大要素数，データ型，若しくは長さが誤っています。
aa....aa：変数の順序番号
(Ｓ)このSQL文を無視します。
(Ｐ)埋込み変数，又はパラメタの変数宣言を修正し，再度実行してください。又は，SQL記述領域中の最大要素数，データ型，若しくは長さの設定値を修正し，再度実行してください。また，文字コードにUTF-8を使用している場合，埋込み変数に各国文字データ以外のデータ型を指定して，再度実行してください。
KFPA11312-E
Sum of aa....aa variable length exceeds 2GB　　（Ａ）
aa....aaで示す変数の合計長が2ギガバイト（GB）を超えています。
aa....aa：エラーが発生した変数
INPUT：入力変数
OUTPUT：出力変数
(Ｓ)このSQL文を無視します。
(Ｐ)SQL記述領域の指定内容を修正し，再度実行してください。
KFPA11313-E
Number of variables not equal to number of parameters　　（Ａ）
DECLARE CURSOR文中の埋込み変数又はパラメタの数が，OPEN文で指定した埋込み変数又はOPEN文の手続き（SQL記述領域）で指定したパラメタの数と一致しません。又は，SQL文中の?パラメタの数とSQL記述領域のSQLDに指定した数が一致しません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL記述領域又はSQL文を修正し，埋込み変数又はパラメタの数を一致させ，再度実行してください。又は，SQL記述領域の設定値を修正し，再度実行してください。
KFPA11314-E
Invalid data type name specified in DESCRIBE TYPE　　（Ａ）
PREPARE文で前処理したSQL文と関連しないデータ型名（所有者名及びデータ型識別子）がDESCRIBE TYPE文で指定されました。PREPARE文で前処理したSQL文の選択項目に指定したユーザ定義型のデータ型名だけ指定できます。
(Ｓ)このSQL文を無視します。
(Ｐ)指定したデータ型名の指定を修正し，再度実行してください。
KFPA11315-E
Unable to use multi value columns on this client library or application　　（Ａ）
繰返し列をサポートしていないバージョンのクライアントライブラリ，又はアプリケーションプログラムを利用して，繰返し列を参照・更新しようとしています。
(Ｓ)処理を続行します。
(Ｐ)繰返し列を使用しない場合は，SQL記述領域のSQLXDIMに明示的に1を設定するように修正してください。繰返し列を使用する場合は，繰返し列をサポートしているバージョンのプリプロセサとライブラリを使用して，再度プリプロセス，及び実行をしてください。
KFPA11316-E
Invalid number of elements of array variable　　（Ｒ＋Ａ）
配列のサイズの指定が0，負の値，又は最大値を超えています。
(Ｓ)このSQL文を無視します。
(Ｐ)配列を使用したFETCH，又は配列を使用したINSERTの動的サイズ指定の値に，最大値より小さい正の値を指定するようにプログラムを修正して，再度実行してください。
KFPA11326-E
Length, precision or number of elements of input variable "aa....aa" conflicts with SQLDA　　（Ａ）
aa....aa番目の入力変数中のデータが，埋込み変数，パラメタの変数宣言，又はSQL記述領域の指定内容と矛盾しています。
・入力変数が可変長データの場合は，入力変数の長さが最大長を超えているか，又は入力変数の長さが0以下です。
・入力変数が10進データの場合は，このデータの形式が誤っているか，又は精度が異なっています。
・入力変数が繰返し列の場合は，入力変数の要素数が最大要素数を超えているか，又は入力変数の要素数が0以下となっています。
aa....aa：入力変数の順序番号
(Ｓ)このSQL文を無視します。
(Ｐ)入力データ，変数宣言，又はSQL記述領域の指定内容を修正し，再度実行してください。
KFPA11329-E
Invalid SQL for query in "aa....aa"　　（Ａ）
次のどれかの誤りがあります。
・カーソル宣言で指定した問合せに対して，カーソルを使用したSQL文が不正です。
・カーソルの割り当てで指定した問合せに対して，カーソルを使用したSQL文が不正です。
・表を指定した問合せに対しては，表に対するUPDATE文及びDELETE文でなければ実行できません。
aa....aa：｛DECLARE CURSOR｜ALLOCATE CURSOR｝
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度モジュールをコンパイルして実行してください。
KFPA11330-E
CURSOR not opened or not positioned on any ROW　　（Ａ）
次に示す誤りがあります。
・カーソルが開かれていません。
・行の取り出しがされていません。
このため，カーソルを使用した行の更新又は削除はできません。
(Ｓ)このSQL文を無視します。
(Ｐ)カーソルを定義し，開いてから行を取り出した後，行の更新又は削除ができるようにＵＡＰを修正してください。その後，再度実行してください。
KFPA11331-E
Specified table different from that in cursor specification　　（Ａ）
カーソル指定で指定した表と，このSQL文で指定した表が異なります。そのため，カーソルを使用したUPDATE文又はDELETE文が実行できません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11332-E
Fetch of all ROWs completed, or an error occurred during fetch　　（Ａ）
行の取り出しをすべて終了したか，又は行の取り出し時にエラーが発生した状態です。このため，UPDATE文又はDELETE文で指定したカーソルは実行できません。
(Ｓ)このSQL文を無視します。
(Ｐ)UAPを修正し，再度実行してください。
KFPA11340-E
Invalid address for variable aaaaa in SQLDATA or SQLIND　　（Ａ）
SQL記述領域のSQLDATA，又はSQLINDに指定された値が誤っているか，又は設定されていません。
aaaaa：変数の順序番号
(Ｓ)このSQL文を無視します。
(Ｐ)変数を正しく設定し，再度実行してください。
KFPA11342-E
Insufficient data area in client, size=aa....aa　　（Ａ）
クライアントにデータを転送するための出力バッファ長が小さいため，検索結果をクライアントに転送できていません。
aa....aa：クライアント側が要求したデータ領域の長さ
（単位：バイト）
データ領域の大きさにはSQL記述領域の長さも含めます。
(Ｓ)このSQL文を無視します。
(Ｐ)
1. 検索結果を受け取る埋込み変数の型が，該当する列のデータ型に正しく対応しているか調べてください。
2. SQL記述領域を直接使用している場合は，SQLLENの値が対応する列のデータ型に従って正しく設定されているか調べてください。
3. 標識変数を使用している場合は，受け取る領域の長さが正しいか調べてください。
4. 列名記述領域又は型名記述領域を使用している場合は，受け取る領域の長さが正しいか調べてください。
KFPA11343-E
Invalid condition number in "GET DIAGNOSTICS" statement　　（Ａ）
条件番号として，次に示す値を指定できません。
・0以下の値
・診断領域中のエラーの数を超える値
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11351-E
Unable to specify column or value expression for update value of ADD clause in UPDATE statement with cursor　　（Ａ）
カーソルを使用したUPDATE文のADD句の更新値に，次に示すものは指定できません。
・列
・スカラ演算
・コンポネント指定
・関数呼出し
(Ｓ)このSQL文を無視します。ただし，このSQL文が定義系SQLの場合，ロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11355-E
Unable to FETCH from LIST using arrays　　（Ａ）
リストを介した検索には，配列を使用したFETCHは使用できません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11356-E
File "aa....aa" bb....bb error occurred in processing for WRITE specification,code=cc....cc　　（Ａ）
WRITE指定処理中のファイル操作でエラーが発生しました。
aa....aa：エラーの発生したファイル名
ファイル名称が126バイト以下の場合，ファイル名称全体を表示します。126バイトを超える場合，超える分は切り捨てて先頭126バイトに続いて2バイトのピリオド（..）を付けて表示します。
bb....bb：エラーの発生した操作
OPEN：BLOBデータファイルのopenシステムコールでエラー
CLOSE：BLOBデータファイルのcloseシステムコールでエラー
WRITE：BLOBデータファイルのwriteシステムコールでエラー
cc....cc：システム関連エラーの詳細コード
「システム関連エラーの詳細コード」を参照してください。
(Ｓ)このSQL文を無視します。
(Ｐ)エラーの要因を取り除いて，SQL文を再度実行してください。
KFPA11358-E
RDAREA aa....aa freezed　　（Ａ）
RDエリアaa....aaは更新凍結状態です。
aa....aa：RDエリア名
(Ｓ)このSQL文を無視します。
[対策]次の手順で対策してください。
1. 更新凍結状態のRDエリアに対して，誤って更新要求が発生していないか業務を見直してください。
2. pddbfrz -dコマンドでRDエリアの更新凍結状態を解除して，再度実行してください。この場合，RDエリアのメンテナンス実行後，RDエリア全体のバックアップを取得し直してください。
KFPA11359-E
Unable to delete row in delete prohibition period　　（Ａ）
改竄防止表の行削除禁止期間内の行は削除できません。
(Ｓ)
・カーソルでの削除の場合
カーソルが指す行は削除しないで処理を続行します。
・上記以外の場合
このSQL文を無視して，ロールバックします。
(Ｐ)削除条件を修正し，再度実行してください。
KFPA11360-E
Invalid format specification in scalar function "aa....aa", pos=bbb, query-no=ccc, format="dd....dd"　　（Ａ）
スカラ関数aa....aaで指定した書式に誤りがあります。
aa....aa：誤った書式を指定したスカラ関数の名称
｛VARCHAR_FORMAT｜DATE｜TIME｜TIMESTAMP_FORMAT｝
bbb：エラーを検出した位置（bbbバイト目）
ccc：問合せの番号
dd....dd：誤った書式
長さが100バイトを超える場合は，100バイト目に'#'が表示されます。
(Ｓ)このSQL文を無視します。ただし，定義系SQL文の場合はロールバックします。
(Ｐ)書式に指定できる書式要素を確認し，書式を修正して，再度実行してください。
KFPA11361-E
Character representation unmatch specified format in scalar function "aa....aa", pos=bbb, query-no=ccc, format="dd....dd"　　（Ａ）
スカラ関数aa....aaの文字列表現が，指定した書式と一致していません。
aa....aa：書式と一致しない値式を指定したスカラ関数
｛DATE｜TIME｜TIMESTAMP_FORMAT｝
bbb：一致していない位置（書式のbbbバイト目）
ccc：問合せの番号
dd....dd：指定した書式
長さが100バイトを超える場合は，100バイト目に'#'が表示されます。また，値式を定数以外で，かつ書式を定数で指定した場合，文字列と区切り文字以外の書式要素部分は，次の文字列で表示されます。
年：YYYY
月：MM
月の省略名：MON，Mon，又はmon※
月の名前：MONTH，Month，又はmonth※
日：DD
時：HH
分：MI
秒：SS
小数秒：NN...N（指定したけた数）
注※　書式に記述した大文字小文字の指定（1，2文字目の指定）に従います。
(Ｓ)このSQL文を無視します。ただし，定義系SQL文の場合はロールバックします。
(Ｐ)指定した書式と文字列を一致させるか，又は書式を修正して，再度実行してください。
KFPA11362-E
No format element aa....aa in format specification in scalar function "bb....bb", query-no=ccc　　（Ａ）
スカラ関数bb....bbで指定した書式に，必要な書式要素aa....aaがありません。
aa....aa：不足している書式要素
｛DD｜HH｜MI｜MM, MON or MONTH｜SS｜YYYY｝
bb....bb：スカラ関数｛DATE｜TIME｜TIMESTAMP_FORMAT｝
ccc：問合せの番号
(Ｓ)このSQL文を無視します。ただし，定義系SQL文の場合はロールバックします。
(Ｐ)スカラ関数と，必要な書式要素の対応を確認し，書式に必要な書式要素を追加して，再度実行してください。
KFPA11364-E
Invalid LOCATOR specified, pos=aaaaa　　（Ａ）
無効な位置付け子が指定されました。
aaaaa：埋込み変数又は?パラメタの順序番号
(Ｓ)次のどちらかの処理をします。
・FREE LOCATOR文の場合
有効な位置付け子はすべて無効にします。
・それ以外の場合
このSQL文を無視します。
(Ｐ)有効な位置付け子を指定するようにSQLを修正し，再度実行してください。
KFPA11366-E
Indicator must be specified for null value assigned to LOCATOR in variable aa....aa　　（Ａ）
位置付け子に割り当てられたデータ値がナル値であるのに，標識変数がありません。
aa....aa：埋込み変数，又は?パラメタの順序番号
(Ｓ)このSQL文を無視します。
(Ｐ)位置付け子に標識変数を指定し，再度UAPを実行してください。
KFPA11367-E
Unable to update non null valued column with "UPDATE ONLY FROM NULL"　　（Ａ）
UPDATE ONLY FROM NULLを指定した列に格納されている値がナル値ではないため，その列に対する更新を実行できません。
(Ｓ)このSQL文を無視します。
(Ｐ)ナル値ではない値が格納されているUPDATE ONLY FROM NULL指定の列を更新しないようにUAPを修正して，再度実行してください。
KFPA11369-E
Unable to specify RDNODE name "aa....aa" for table specification in bb....bb statement　　（Ａ）
手続き定義，又は型定義の手続き本体中に，RDノード名による修飾があります。
手続き中から分散データベース機能を使用したリモートアクセスはできません。
aa....aa：指定したRDノード名
bb....bb：｛CREATE PROCEDURE｜CREATE TRIGGER｜PROCEDURE definition in CREATE TYPE｝
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11371-E
Invalid RDNODE name aa....aa　　（Ａ）
RDノード名称が不正です。
aa....aa：RDノード名称
(Ｓ)このSQL文を無視します。又は，このトランザクションを無効にします。
(Ｐ)サーバシステムがDB2/6000でない場合は，HiRDBで指定したRDノード名称，DF/UXの環境定義で指定したRDノード名称を修正してください。サーバシステムがDB2/6000の場合は，HiRDBで指定したRDノード名称，DF/UX Extension分散定義で指定したRDB名称(RDノード名称)を修正してください。
KFPA11381-E
Overflow in converting floating point numeric, type=aa....aa　　（Ａ）
浮動小数点データへ変換するときに，オーバフローが発生しました。
aa....aa：エラーの要因
{ INPUT | OUTPUT }
(Ｓ)このSQL文を無視します。
(Ｐ)オーバフローが発生しないようにデータ型を変更してください。
KFPA11382-E
Invalid use of "CURRENT OF" clause　　（Ａ）
一括検索中にCURRENT OFカーソル名又は拡張カーソル名を指定しました。
(Ｓ)このSQL文を無視します。
(Ｐ)CURRENT OFカーソル名又は拡張カーソル名を指定しないようにSQL文を修正してください。又は，一括検索をしないように環境定義を修正してください。
KFPA11383-E
Failure occurred in remote access, reason code=aa, process ID=bb....bb, connection ID=cc....cc, RMID=dd....dd　　（Ａ）
リモートアクセス処理中に障害が発生しました。
aa：理由コード
bb....bb：シングルサーバ又はフロントエンドサーバのプロセスID
cc....cc：HiRDBとDF/UXとのコネクションID
表示できないときは，'*'を表示します。
dd....dd：HiRDBからDF/UXに渡すRMID
表示できないときは，'*'を表示します。
(Ｓ)このSQL文を無視します。
[対策]理由コードに従って対策してください。
理由
コード
意味
対策
1
DF/UXが未起動，又はダウン中
未起動の場合は，DF/UXを起動してから再度UAPを実行してください。
ダウン中の場合は，DF/UXが出力したメッセージを参照して，DF/UXが異常終了した原因を調査してください。
詳細は，マニュアル「分散データベース DF/UX」を参照してください。
不明な場合は保守員に連絡してください。
2
DF/UXの最大ユーザ数を超過
同時に使用するユーザ数を減らしてください。
又は，DF/UXの最大ユーザ数を変更してください。
詳細は，マニュアル「分散データベース DF/UX」を参照してください。
3
DF/UXがタイムアウトを検出
UAPを再度実行してください。
又は，DF/UXの打ち切り時間を変更してください。
詳細は，マニュアル「分散データベース DF/UX」を参照してください。
4
DF/UXが通信障害を検出
DF/UXが出力したメッセージを参照して，通信障害の原因を調査してください。原因が判明した場合は，原因を取り除いた後再度UAPを実行してください。
詳細は，マニュアル「分散データベース DF/UX」を参照してください。
不明な場合は保守員に連絡してください。
5
DF/UXのバージョンが不正
DF/UXのバージョンを調べて，前提バージョンと異なる場合は，DF/UXを入れ替えてください。
31
DF/UXの環境定義のdfux_extension_func句にNOUSEが設定されている。又は，DF/UX Extensionが導入されていない。
DF/UX Extensionを導入して，DF/UXの環境定義のdfux_extension_func句にUSEを設定してください。
KFPA11384-E
Invalid response from server system in remote access, reason code=aa　　（Ａ）
リモートアクセスで，サーバの応答不正を検出しました。
aa：理由コード
(Ｓ)このSQL文を無視します。
[対策]保守員に連絡してください。
理由コード
意味
01
応答情報のデータ型が不正です。
02
エラー応答情報のエラー種別が不正です。
03
FETCH文以外のSQL文で，SQL DBL RESULT VALUES数に，1以外の値が返されました。
KFPA11388-E
DF/UX error detected in remote access, process ID=aa....aa, connection ID=bb....bb, RMID=cc....cc, dd....dd　　（Ａ）
リモートアクセス処理中に，DF/UXで異常が発生しました。
aa....aa：シングルサーバ又はフロントエンドサーバのプロセスID
bb....bb：HiRDBとDF/UXとのコネクションID
表示できないときは，'*'を表示します。
cc....cc：HiRDBからDF/UXに渡すRMID
表示できないときは，'*'を表示します。
dd....dd：保守情報
(Ｓ)このSQL文を無視します。
[対策]DF/UXのメッセージが出力されている場合は，そのメッセージを参照してエラーの原因を調査してください。ユーザが判断できないエラーが発生している場合，保守員に連絡してください。
KFPA11390-E
Permanent error occurred in remote access　　（Ａ）
リモートアクセス処理中に障害が発生し，リモートアクセスができない状態になりました。
(Ｓ)このSQL文を無視します。
[対策]このメッセージよりも前に出力されているHiRDBのメッセージ，又はDF/UXが出力したメッセージを参照して障害の原因を取り除いた後，UAPを再度実行してください。DF/UXのメッセージについては，マニュアル「分散データベース DF/UX」を参照してください。
KFPA11395-E
Unable to execute SQL for foreign server aa....aa (b), reason=cc....cc　　（Ａ）
cc....ccの理由で，外部サーバに対してSQLを実行できません。
aa....aa：外部サーバ名
b：サーバ種別
P：HiRDB
R：XDM/RD E2
O：ORACLE
I：DB2
cc....cc：理由
COMMUNICATION ERROR：通信エラー
TIME OVER：タイムアウト
MEMORY EXCEEDS THE LIMIT：メモリ使用量超過
(Ｓ)処理を終了します。SQLの実行でこのメッセージが出力された場合は，SQLの実行を中止します。
(Ｐ)理由コードに対応する処置をしてください。
MEMORY EXCEEDS THE LIMITの場合
外部表を検索する検索対象の列長の総和や外部サーバ情報定義のpd_hb_ary_fec_numオペランド（外部サーバに対する配列FETCH数）の指定値を小さくするなどして，再度SQLを実行してください。外部表に対するSQL実行時に必要なメモリ所要量については，マニュアル「HiRDB Version 7 システム導入・設計ガイド」を参照してください。
上記以外の場合
処理対象の外部サーバに対して，直前に実行したSQLのエラー内容を確認し，そのエラーに対する処置をしてください。
KFPA11396-E
Unable to access foreign server because External Data Access is reduced mode　　（Ａ）
HiRDB External Data Access機能が縮退しているため，外部サーバにアクセスできません。
(Ｓ)処理を終了します。
[対策]ディクショナリサーバ開始時にKFPW05039-Eメッセージが出力されている場合，そのメッセージに従って対策してください。出力されていない場合は，HiRDBをいったん正常終了させて，その後正常開始してください。再度このメッセージが出力されて，かつKFPW05039-Eメッセージが出力されない場合には，保守員に連絡してください。
KFPA11401-E
Inconvertible data type in "aa....aa" predicate, query-no=bbb　　（Ａ）
述語aa....aaの両側に指定したオペランドのデータ型が，比較変換できるデータ型ではありません。
aa....aa：比較変換できないデータ型を指定した述語
{COMPARISON | IN | LIKE | BETWEEN | XLIKE}
bbb：その述語を指定している問合せの番号
(Ｓ)このSQL文を無視します。
(Ｐ)述語の指定を修正し，再度実行してください。
KFPA11402-E
Argument of "AVG" or "SUM" must be numeric, query-no=aaa　　（Ａ）
集合関数（AVG，又はSUM）の引数のデータ型が数値データではありません。
aaa：集合関数が指定してある問合せの番号
(Ｓ)このSQL文を無視します。
(Ｐ)集合関数の指定を修正し，再度実行してください。
KFPA11403-E
Unable to specify "aa....aa"."bb....bb" in SET function "cc....cc", query-no=ddd　　（Ａ）
集合関数の引数が列指定だけでない場合，引数には外へ参照する列を含んではいけません。
aa....aa：表識別子，又は相関名
bb....bb：外へ参照している列名
cc....cc：集合関数の名称
ddd：問合せの番号
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11404-E
Input data too long for column or assignment target aa....aa　　（Ａ）
次のどれかの誤りがあります。
・入力データの列が定義した列よりも長くなっています。
・SET文の代入値データが代入先よりも長くなっています。
・ユーザ定義関数又はシステム定義スカラ関数の呼び出しで，パラメタの長さに対して引数が長過ぎます。
・スカラ関数VALUEの結果のデータ長に対して，引数が長過ぎます。
・SQL変数宣言のDEFAULT句に指定した既定値がSQL変数に対して長過ぎます。
・AS データ型の指定に対して，入力データが長過ぎます。
aa....aa：次のどちらかの文字
・in variable 変数の順序番号
入力変数を単独で指定している場合，又はスカラ関数VALUEの引数に入力変数を単独で指定している場合
・1バイトの空白
上記以外の場合
(Ｓ)このSQL文を無視します。
(Ｐ)入力データを修正し，再度実行してください。
KFPA11405-E
Numeric literal out of range　　（Ａ）
指定した数定数の値が次に示す指定できる値の範囲を超えています。
整数定数：-2,147,483,648～+2,147,483,647
10進数定数：±1029～±(1030-1)
浮動小数点数定数：±4.9E-324～±1.7E+308
ラベル付き間隔に指定した整数定数
YEAR(S)：-9,998～+9,998
MONTH(S)：-119,987～+119,987
DAY(S)：-3,652,058～+3,652,058
HOUR(S)：-23～+23
MINUTE(S)：-1,439～+1,439
SECOND(S)：-86,399～+86,399
LIMIT句のリミット行数に指定した整数定数：-1～+2,147,483,647
LIMIT句のオフセット行数に指定した整数定数：0～+2,147,483,647
(Ｓ)このSQL文を無視します。
(Ｐ)数定数の指定を修正し，再度実行してください。
KFPA11406-E
Arithmetic operation cannot be specified for string,binary,timestamp,abstract or boolean data, query-no=aaa　　（Ａ）
文字列データ，各国文字列データ，混在文字データ，長大データ（BLOB），バイナリデータ（BINARY），時刻印データ，抽象データ，又は論理データ（BOOLEAN）に対して算術演算は指定できません。
aaa：文字列データ，各国文字列データ，混在文字データ，長大データ，バイナリデータ，時刻印データ，抽象データ，又は論理データを指定している問合せの番号
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11407-E
Like predicate can be specified for string data only, query-no=aaa　　（A）
次に示すデータ型にLIKE述語又はXLIKE述語を指定できません。
・数値データ
・日付データ
・日間隔データ
・時刻データ
・時間隔データ
・時刻印データ
・長大データ
・バイナリデータ（ただし，LIKE述語中には最大長32,000バイトまでのバイナリデータは指定できます）
aaa：不正なLIKE述語又はXLIKE述語を指定した問合せの番号
(Ｓ)このSQL文を無視します。
(Ｐ)LIKE述語又はXLIKE述語の指定を修正し，再度実行してください。
KFPA11408-E
Inconvertible data type for update or insert value　　（Ａ）
更新値，又は挿入値のデータ型が，変換できるデータ型ではありません。
抽象データ型に対する挿入，更新の場合，挿入値，更新値はそれぞれ挿入対象，更新対象と同じ抽象データ型，又は挿入対象，更新対象のサブタイプである必要があります。
(Ｓ)このSQL文を無視します。
(Ｐ)更新値又は挿入値を修正し，再度実行してください。
KFPA11410-E
Invalid numeric literal aa....aa　　（Ａ）
数定数の指定に文法誤りがあります。
aa....aa：誤りのある数定数
(Ｓ)このSQL文を無視します。
(Ｐ)数定数を修正し，再度実行してください。
KFPA11411-E
Inconvertible data type in concatenation operation, query-no=aaa　　（Ａ）
連結演算の両側で指定したオペランドのデータ型が比較変換できないデータ型です。
aaa：変換できないデータ型を連結演算のデータ型に指定している問合せの番号
(Ｓ)このSQL文を無視します。
(Ｐ)連結演算の指定を修正し，再度実行してください。
KFPA11412-E
Concatenation operation can be specified for string data except large object, query-no=aaa　　（Ａ）
連結演算には，次に示すデータ型を指定できません。
・数値データ
・日付データ
・日間隔データ
・時刻データ
・時間隔データ
・時刻印データ
・長大データ（BLOB）
・抽象データ
・論理データ（BOOLEAN）
ただし，UPDATE文の更新値には長大データ（BLOB）の連結演算を指定できます。
aaa：不正なデータ型を指定している問合せの番号
(Ｓ)このSQL文を無視します。
(Ｐ)連結演算子の指定を修正し，再度実行してください。
KFPA11413-E
Invalid operation specified in date/time arithmetic operation, query-no=aaa　　（Ａ）
日付，又は時刻の演算では指定できないデータ型を四則演算子と組み合わせ（日付データ＋日付データ，日間隔データ-整数データなど）て指定しています。又は，日付データ，時刻データ，又はラベル付き間隔に対して単項演算をしています。
aaa：不正な日付又は時刻の演算を指定した問合せの番号
(Ｓ)このSQL文を無視します。
(Ｐ)四則演算の指定を修正し，再度実行してください。
KFPA11414-E
Invalid use of labeled duration, query-no=aaa　　（Ａ）
ラベル付き間隔は，日付データ又は時刻データに対する加減算のオペランドにだけ指定できます。
aaa：不正なラベル付き間隔を指定した問合せの番号
(Ｓ)このSQL文を無視します。
(Ｐ)ラベル付き間隔の指定を修正し，再度実行してください。
KFPA11415-E
aa....aa can be specified for integer or smallint data only, query-no=bbb　　（Ａ）
aa....aaには，INTEGER又はSMALLINTのデータ型だけ指定できます。
aa....aa：エラーとなった値式又は句
｛Labeled duration｜Row count in "LIMIT" clause｝
bbb：問合せ番号
(Ｓ)このSQL文を無視します。
(Ｐ)ラベル付き間隔の場合，ラベル付き間隔に指定した値式を修正し，再度実行してください。LIMITの場合，リミット行数，又はオフセット行数に指定した行数を修正し，再度実行してください。
KFPA11416-E
Invalid character representation for data type aa....aa　　（Ａ）
aa....aaに示すデータ型の文字列表現に，次のような誤りがあります。
・日付データの文字列表現中に，数字及びハイフン（-）以外の文字があります。
・日付データの文字列表現中，又は時刻印データの文字列表現中に，3個以上のハイフン（-）があります。
・日付データの文字列表現，又は時刻印データの文字列表現が次の条件に合いません。
0001　≦　年　≦　9999
01　　≦　月　≦　12
01　　≦　日　≦　月の最終日
・時刻データの文字列表現中に数字及びコロン（：）以外の文字があります。
・時刻データの文字列表現中に，3個以上のコロン（：）があります。
・時刻データの文字列表現，又は時刻印データの文字列表現が次の条件に合いません。
00　≦　時　≦　23
00　≦　分　≦　59
00　≦　秒　≦　59
・時刻印データの文字列表現中に，数字，ハイフン（-），コロン（：），空白，及びピリオド（.）以外の文字があります。
・時刻印データの文字列表現中に，2個以上の空白又はピリオド（.）があります。
・時刻印データの文字列表現が次の条件に合いません。
000000　≦　小数秒　≦　999999
・時刻印データの文字列表現中の小数秒精度に，0，2，4，及び6以外のけた数を指定しています。
・整数の文字列表現中に，符号（＋又は－），及び数字以外の文字があります。
・10進数の文字列表現中に，符号（＋又は－），小数点（.），及び数字以外の文字があります。
・10進数の文字列表現中に，小数点（.）がありません。
・浮動小数点数の文字列表現中に，符号（＋又は－），数字，「E」，及び「e」以外の文字があります。
・浮動小数点数の文字列表現中に，「E」又は「e」がありません。
aa....aa：誤った文字列表現を指定したデータ
｛TIME｜DATE｜TIMESTAMP｜INTEGER｜DECIMAL｜FLOAT｝
(Ｓ)このSQL文を無視します。
(Ｐ)文字列表現のデータを修正し，再度実行してください。
KFPA11417-E
Value specifications cannot be specified for both operands of compare operation or left-hand side operand in predicate "IN", query-no=aaa　　（Ａ）
比較述語の両側，又はIN述語の左側のオペランドに値指定（定数，USER，CURRENT_DATE，CURRENT_TIME，CURRENT_TIMESTAMP，及び?パラメタ）はできません。
aaa：その比較述語，又はIN述語を指定している問合せの番号
(Ｓ)このSQL文を無視します。
(Ｐ)比較述語，又はIN述語の指定を修正し，再度実行してください。
KFPA11418-E
Parameter cannot be specified in "SELECT" clause, query-no=aaa　　（Ａ）
SELECT句に?パラメタは指定できません。
aaa：その?パラメタを指定している問合せの番号
(Ｓ)このSQL文を無視します。
(Ｐ)SELECT句を修正し，再度実行してください。
KFPA11419-E
Parameters cannot be specified for both operands of arithmetic operation or concatenation operation, query-no=aaa　　（Ａ）
四則演算子又は連結演算子の両側のオペランドには，?パラメタを指定できません。
aaa：四則演算又は連結演算を指定している問合せの番号
(Ｓ)このSQL文を無視します。
(Ｐ)四則演算又は連結演算の指定を修正し，再度実行してください。
KFPA11420-E
Result string of aa....aa too long or result type invalid, query-no=bbb　　（Ａ）
次のどれかの誤りがあります。
・aa....aaの値式の結果の文字列長が，次の最大長を超えています。
CHAR，VARCHAR，MCHAR，及びMVARCHARの場合は32,000バイト
NCHAR及びNVARCHARの場合は16,000文字
BINARYの場合は32,000バイト
・aa....aaの値式の結果の文字列長が次の最大長を超えているため，スカラ関数HEXの値式には指定できません。
CHAR，VARCHAR，MCHAR，及びMVARCHARの場合は16,000バイト
NCHAR及びNVARCHARの場合は8,000文字
BINARYの場合は16,000バイト
BOOLEAN
BLOB
・aa....aaの値式の結果が次のデータ型のため，述語，及び集合関数の値式には指定できません。ただし，BOOLEAN型は論理述語には指定できます。
BOOLEAN
BLOB
32,001バイト以上のBINARY
・aa....aaの値式の結果のデータ型がBLOB，又は32,001バイト以上のBINARYのため，CALL文，関数呼出し，及びシステム定義スカラ関数の引数に指定できません。
aa....aa ：演算名称
{ concatenation | scalar function "SUBSTR"
|scalar function "HEX" | scalar function "UPPER"
|scalar function "LOWER" | scalar function "VALUE"
|scalar function "IS_USER_CONTAINED_IN HDS_GROUP"
|scaler function "BIT_AND_TEST"
|simple CASE | searched CASE | case abbreviation
|cast specification | scalar subquery }
bbb：aa....aaの演算を指定している問合せの番号
(Ｓ)このSQL文を無視します。ただし，このSQL文が定義系SQLの場合，ロールバックします。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11421-E
Invalid operation specified for arithmetic operation or concatenation operation, query-no=aaa　　（Ａ）
四則演算中に連結演算が指定されました。又は，連結演算中に四則演算が指定されました。
aaa：不正な連結演算，又は四則演算を指定している問合せの番号
(Ｓ)このSQL文を無視します。
(Ｐ)連結演算又は四則演算を修正し，再度実行してください。
KFPA11422-E
Variable or parameter cannot be specified for concatenation operation or date/time arithmetic operation, query-no=aaa　　（Ａ）
次に示す演算には，埋込み変数及び?パラメタは指定できません。
・連結演算
・日付又は時刻の演算
aaa：埋込み変数又は?パラメタを指定している問合せの番号
(Ｓ)このSQL文を無視します。
(Ｐ)埋込み変数，又は?パラメタで指定した連結演算，日付又は時刻演算を修正し，再度実行してください。
KFPA11424-E
Invalid aa....aa in LIKE predicate　　（Ａ）
LIKE述語に指定したaa....aaに誤りがあります。
aa....aa：誤りがあるSQL文の指定
PATTERN：パターン文字列中でエスケープ文字の次の文字が_（下線），％（パーセント），又はエスケープ文字ではありません。
ESCAPE CHARACTER：エスケープ文字の長さが1文字ではありません。
(Ｓ)このSQL文を無視します。ただし，このSQL文が定義系SQLの場合，ロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11425-E
Invalid data type for operand aaa in scalar function "bb....bb", query-no=ccc　　（Ａ）
スカラ関数bb....bbのaaa番目に指定された値式のデータ型，又は形式に誤りがあります。
aaa：誤りのある値式の番号
bb....bb：スカラ関数の名称
{ ABS | CHARACTER | DATE | DAY | DAYS | DECIMAL | DIGITS
| FLOAT | HEX | HOUR | INTEGER | LENGTH | LOWER | MINUTE
| MOD | MONTH | SECOND | SUBSTR | TIME | TIMESTAMP | UPPER
| VALUE | YEAR | VARCHAR_FORMAT | TIMESTAMP_FORMAT
| IS_USER_CONTAINED_IN_HDS_GROUP | BIT_AND_TEST
| MICROSECOND | POSITION}
ccc：問合せの番号
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11426-E
Operand aaa incompatible with first operand in bb....bb, query-no=ccc　　（Ａ）
スカラ関数（VALUE，BIT_AND_TEST，POSITION），又はCASE略式（NULLIF，COALESCE）の，1番目の値式とaaa番目の値式との間にデータ型の互換性がありません。
aaa：1番目の値式とデータ型の互換性がない値式の番号
bb....bb：エラーとなった関数又は式
{ scalar function "VALUE"
| scalar function "BIT_AND_TEST"
| scalar function "POSITION"
| case abbreviation "NULLIF"
| case abbreviation "COALESCE" }
ccc：問合せの番号
(Ｓ)このSQL文を無視します。ただし，このSQL文が定義系SQLの場合，ロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11427-E
Operand a out of range in scalar function "bb....bb", query-no=ccc　　（Ａ）
スカラ関数bb....bbの値式aが，次に示す条件に合いません。
スカラ関数SUBSTRの場合
・1　≦　値式2　≦　値式1の長さ
・0　≦　値式3　≦　値式1の長さ－値式2＋1
ただし，定数に0は指定できません。
スカラ関数POSITIONの場合
・1　≦　値式3　≦　値式2の長さ
a：値式の番号{2 | 3}
bb....bb：スカラ関数の名称{SUBSTR | POSITION}
ccc：問合せの番号
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11428-E
Variable or parameter cannot be specified in aa....aa, query-no=bbb　　（Ａ）
スカラ関数（VALUE，HEX，又はBIT_AND_TEST），又はCASE式中の埋込み変数又は？パラメタの指定に，次に示す誤りがあります。
・スカラ関数(VALUE)の一番目のオペランドに埋込み変数又は？パラメタを指定しています。
・スカラ関数(HEX)の値式の中に，埋込み変数又は？パラメタを指定しています。
・スカラ関数(BIT_AND_TEST)の両方のオペランドに，埋込み変数又は？パラメタを指定しています。
・CASE略式(COALESCE)の一番目のオペランドに埋込み変数又は？パラメタを指定しています。
・CASE略式(NULLIF)の両方のオペランドに埋込み変数又は？パラメタを指定しています。
・単純CASE式の最初のWHENに埋込み変数又は？パラメタを指定しています。
・単純CASE式又は探索CASE式のTHEN又はELSEに，埋込み変数又は？パラメタを指定しています。
・単純CASE式のCASEに，埋込み変数又は？パラメタを指定しています。
aa....aa：エラーとなった関数又は式
{ scalar function "VALUE" | scalar function "HEX"
| case abbreviation "COALESCE"
| case abbreviation "NULLIF"
| simple CASE | searched CASE
| scaler function "BIT_AND_TEST" }
bbb：問合せの番号
(Ｓ)このSQL文を無視します。ただし，このSQL文が定義系SQLの場合，ロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11430-E
Invalid data type specified in select list　　（Ａ）
選択式のデータ型が不正です。不正なデータ型は次のとおりです。
・BOOLEAN
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11431-E
aa....aa error occurred, code=bbbb　　（Ａ）
システム内内部関数の実行時にエラーが発生しました。
aa....aa：エラーの発生した内部関数名
bbbb：詳細エラーコード
(Ｓ)このSQL文を無視します。
(Ｐ)HiRDB管理者に連絡してください。
[対策]保守員に連絡してください。
KFPA11432-E
Unable to specify local RDNODE name in CONNECT,DISCONNECT or SET CONNECTION statement　　（Ａ）
CONNECT文，DISCONNECT文，及びSET CONNECTION文では既定RDノードのRDノード名称を指定できません。
(Ｓ)このSQL文を無視します。
(Ｐ)
1. 既定RDノードのHiRDBに接続する場合は，RDノードを指定しないCONNECT文を使用してください。
2. 既定RDノードのHiRDBからUAPを切り離す場合は，RDノードを指定しないDISCONNECT文を使用してください。
3. 既定RDノードを現行RDノードにする場合は，SET CONNECTION文でDEFAULTを指定してください。
KFPA11440-E
Inconvertible data type in assignment statement　　（Ａ）
SET文の代入先のデータ型と代入値のデータ型が，変換できるデータ型ではありません。
抽象データ型の場合は，代入元と代入先の抽象データ型が同じ，又は代入元の抽象データ型が代入先の抽象データ型のサブタイプである必要があります。
(Ｓ)このSQL文を無視して，ロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11441-E
Invalid use of data type in "SELECT" clause, select-list-no=aaaaa, query-no=bbb　　（Ａ）
選択式に指定された定数，演算，コンポネント指定，又は関数呼出しの結果が次に示すデータ型の場合，FOR READ ONLY句の指定，ビュー表の定義，及び問合せ名の導出はできません。
・BLOB
・抽象データ型
・BOOLEAN
選択式に指定されたスカラ副問合せの結果が次に示すデータ型の場合，ビュー表の定義又は問合せ名の導出はできません。
・BLOB
・32,001バイト以上のBINARY
FROM句の導出表の選択式には，演算結果が次のデータ型の演算は指定できません。
・BLOB
・最大長が32,001バイト以上のBINARY
aaaaa：選択式のデータ型・データ長が不正な選択式の番号
bbb：問合せの番号
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11442-E
Invalid use of BLOB in scalar function "LENGTH", query-no=aa　　（Ａ）
BLOBデータの列を指定したスカラ関数LENGTHの使用方法に誤りがあります。BLOBデータの列を指定したスカラ関数LENGTHは，選択式又は更新値に単体のLENGTH関数としてだけ指定できます。
aa：使用できないLENGTH関数を指定した問合せの番号
(Ｓ)このSQL文を無視します。ただし，このSQL文が定義系SQLの場合，ロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11443-E
Inconvertible data type of target specification "aa....aa" in FETCH or SELECT statement　　（Ａ）
FETCH文，又は１行SELECT文の相手指定が，変換できるデータ型ではありません。
抽象データ型の場合は，次のどれかの条件を満たしている必要があります。
・FETCH文とFETCH文の相手指定が同じ抽象データ型
・1行SELECT文と1行SELECT文の相手指定が同じ抽象データ型
・FETCH文の抽象データ型がFETCH文の相手指定の抽象データ型のサブタイプ
・1行SELECT文の抽象データ型が1行SELECT文の相手指定の抽象データ型のサブタイプ
aa....aa：相手指定の名称
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11444-E
Invalid data type for operand aaa in bb....bb, query-no=ccc　　（Ａ）
CASE式に指定された値式のデータ型，又は形式に，次に示す誤りがあります。
・値式の結果が，BLOB型，最大長が32,001バイト以上のBINARY，抽象データ型，BOOLEAN型です。
該当する値式の指定箇所は次のとおりです。
・CASE略式のaaa番目の値式
・単純CASE式のaaa番目のCASE,WHEN,THEN,又はELSEの値式
・探索CASE式のaaa番目のTHEN,又はELSEの値式
aaa：エラーとなった値式が指定されているオペランド，又はエラーとなった値式の番号
bb....bb：エラーとなったCASE式，又はエラーとなったCASE式のオペランド
{ case abbreviation "COALESCE"
| case abbreviation "NULLIF"
| "CASE" in simple CASE | "WHEN" in simple CASE
| "THEN" in simple CASE | "ELSE" in simple CASE
| "THEN" in searched CASE
| "ELSE" in searched CASE}
ccc：問合せの番号
(Ｓ)このSQL文を無視します。ただし，このSQL文が定義系SQLの場合，ロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11445-E
Variables or parameters cannot be specified in argument of set function "aa....aa", query-no=bbb　　（Ａ）
集合関数の引数に，埋込み変数，SQLパラメタ，SQL変数又は?パラメタは指定できません。
aa....aa：引数に埋込み変数又は?パラメタを指定している集合関数の名称
bbb：問合せの番号
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11446-E
CASE operand is incompatible with WHEN operand aaa in simple CASE, query-no=bbb　　（Ａ）
単純CASE式のCASEの値式とWHENのaaa番目の値式との間にデータ型の互換性がありません。
aaa：CASEの値式とデータ型の互換性がないWHENの値式の番号
bbb：問合せの番号
(Ｓ)このSQL文を無視します。ただし，このSQL文が定義系SQLの場合，ロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11447-E
THEN operand aaa is incompatible with THEN or ELSE operand bbb in simple CASE or searched CASE, query-no=ccc　　（Ａ）
単純CASE式及び探索CASE式のaaa番目のTHENの値式と，bbb番目のTHEN又はELSEの値式との間にデータ型の互換性がありません。
aaa：データ型の互換性のチェックの基となる値式の番号
bbb：aaa番目の値式とデータ型の互換性がない値式の番号
ccc：問合せの番号
(Ｓ)このSQL文を無視します。ただし，このSQL文が定義系SQLの場合，ロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11448-E
At least one THEN operand in simple CASE or searched CASE must be value expression, query-no=aaa　　（Ａ）
すべてのTHENオペランドにNULLを指定しています。単純CASE式，及び探索CASE式の少なくとも一つのTHENオペランドには値式を指定する必要があります。
aaa：問合せの番号
(Ｓ)このSQL文を無視します。ただし，このSQL文が定義系SQLの場合，ロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11449-E
Cardinality violation in single row select　　（Ａ）
1行SELECT文の検索結果が2行以上になります。
(Ｓ)このSQL文を無視します。
(Ｐ)検索したい場合は，検索結果が1行以下となる問合せを指定するか，又はカーソルを用いて検索するように変更してください。
KFPA11450-E
Cardinality violation at aaa-th subquery.Two or more rows found　　（Ａ）
次の副問合せの結果，得られる行数が2行以上あります。
・比較述語，又はUPDATE文のSET句で指定したスカラ副問合せ
・行副問合せ
aaa：基数違反となった副問合せの先頭からの位置を示します。
ただし，エラーの原因がビュー表の定義内容の場合，そのビュー表を指定した問合せの番号となります。
(Ｓ)このSQL文を無視します。
(Ｐ)副問合せの結果が1行以下になるようにSQL文を修正し，再度実行してください。
KFPA11451-E
aa....aa constraint "bb....bb" violation at cc....cc 　　（Ａ）
参照制約，又は検査制約に違反しています。
aa....aa：制約の種類
{Referential｜Check}
bb....bb：制約違反となった制約名
cc....cc：制約違反となったSQL
{ INSERT｜UPDATE｜DELETE }
aa....aa：Referential（参照制約違反の場合）
・被参照表の主キー更新時，更新前の主キー構成列の値と等しい外部キー構成列の値を持つ行が参照表にあります。
・被参照表の主キー削除時，削除する行の主キー構成列の値と等しい外部キー構成列の値を持つ行が参照表にあります。
・参照表の外部キー挿入時，挿入する行の外部キー構成列の値と等しい主キー構成列の値を持つ行が被参照表中にありません。
・参照表の外部キー更新時，更新後の外部キー構成列の値と等しい主キー構成列の値を持つ行が被参照表中にありません。
・一つの表中に同じ主キーを参照し，参照制約動作にON UPDATE CASCADE指定を含む参照制約が複数定義されています。
aa....aa：Check（検査制約違反の場合）
・更新値，又は挿入値が検査制約で定義した条件を満たしていません。
・一つの表中に同じ主キーを参照し，参照制約動作にON UPDATE CASCADE指定を含む参照制約が複数定義されています。
(Ｓ)このSQL文を無視します。定義系SQLの場合，ロールバックします。
(Ｐ)
aa....aa：Referential
・被参照表に対するUPDATE文の場合，次のどちらかの処置をします。
・更新条件を変更
・更新前の主キーの値と等しい外部キーの値を持つ行を参照表から削除，又は参照表の外部キーの値を被参照表にあるほかの主キーの値に更新
・被参照表に対するDELETE文の場合，次のどちらかの処置をします。
・削除条件を変更
・削除する主キーの値と等しい外部キーの値を持つ行を参照表から削除，又は参照表の外部キーの値を被参照表にあるほかの主キーの値に更新
・参照表に対するINSERT文の場合，次のどちらかの処置をします。
・挿入する外部キーの値を適正な値に変更
・被参照表に参照表の外部キーの挿入値を主キーに持つ行を追加
・参照表に対するUPDATE文の場合，次のどれかの処置をします。
・更新条件を変更
・外部キーの更新値を適正な値に変更
・被参照表に参照表の外部キーの更新値を主キーに持つ行を追加
上記の処置をしてもエラーになる場合は同じ主キーを参照し，参照制約動作にON UPDATE CASCADE指定を含む参照制約が一つになるように変更し，表を再定義してください。
aa....aa：Check
・更新値，又は挿入値が検査制約定義の条件を満たすように修正します。
上記の処置をしてもエラーになる場合は同じ主キーを参照し，参照制約動作にON UPDATE CASCADE指定を含む参照制約が一つになるように変更し，表を再定義してください。
KFPA11453-E
CAST error occurred, reason=aa....aa, query-no=bbb　　（Ａ）
CAST指定の指定方法，又はデータ内容に誤りがあります。
aa....aa：エラーの要因
COMBINATION：
値式の結果のデータ型，及びデータ長と，変換後のデータ型，及びデータ長の組み合わせに誤りがあります。
(例) CAST(TIME型 AS INT)
FORMAT：
変換元データの文字列定数の書式に誤りがあります。
(例) CAST('ABC' AS INT)
VALUE：
変換元データの値に誤りがあります。
(例) CAST('1999-99-99' AS DATE)
TRUNCATION ：
文字の切り捨てが発生しました。
(例) CAST(DATE型 AS CHAR(1))
OVERFLOW：
オーバフローが発生しました。
(例) CAST(99999 AS DEC(1,1))
INVALID CAST OPERAND：
変換元の指定に誤りがあります。
(例) CAST(BLOB型 AS データ型)
DATA TYPE：
使用できないデータ型を変換データ型として指定しています。
(例) CAST(C1 AS BLOB)
bbb：エラー要因となったCAST指定を指定している問合せの番号
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11455-E
Unable to specify aa....aa in view definition or in "WITH" query　　（Ａ）
ビュー定義，又はWITH句の問合せの導出問合せ式中には，抽象データ型の値式を指定できません。また，最も外側の問合せの選択式にCASE式を指定した場合，その探索条件には繰返し列を指定できません。
aa....aa：｛abstract data｜multi-value column in search condition of CASE expression｝
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11456-E
Outer reference specified for column derived from set function with argument of operation　　（Ａ）
ビュー定義の選択式又はWITH句の問合せ中の導出問合せ式の選択式で，演算を引数とした集合関数を指定した場合，該当する列を外への参照列として，副問合せ中に指定できません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11458-E
Duplicate query name "aa....aa" in "WITH" clause　　（Ａ）
"WITH"句の問合せ名aa....aaが重複しています。WITH句には，同じ問合せ名を二つ以上指定できません。
aa....aa：重複していた問合せ名
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11459-E
Duplicate column name "aa....aa" in derived table "bb....bb" in view definition or "WITH" query　　（Ａ）
ビュー表，又はWITH句の問合せ名bb....bbの列名aa....aaが重複しています。ビュー表，又はWITH句中の一つの問合せ名に対して，同じ列名を二つ以上指定できません。
aa....aa：重複していた列名
bb....bb：重複した列名のあるビュー表の名前又は問合せ名
(Ｓ)このSQL文を無視します。
(Ｐ)
・列名を指定している場合は，重複しないように列名を変更してください。
・列名を省略している場合は，問合せの選択式の列名が重複しているため，ビュー表又はWITH句の問合せの列名がそれらの重複した名前となるので，列名を省略しないで，かつ重複しない列名を指定してください。
KFPA11460-E
No name for derived column in view definition or "WITH" query　　（Ａ）
ビュー定義，又はWITH句の導出問合せ式によって導出された表が，名前のない列を含む場合は，ビュー表の名前，又は問合せ名に対して列名を省略できません。
(Ｓ)このSQL文を無視します。
(Ｐ)列名を指定してください。
KFPA11461-E
Unable to derive internal table for view or "WITH" query having long data column or multi-value column　　（Ａ）
次のどれかを選択式に指定して導出した名前付きの導出表に対して，内部導出表を作成する問合せは指定できません。
・BLOB
・32,001バイト以上のBINARY
・繰返し列
内部導出表を作成する条件は次のとおりです。
1. SELECT DISTINCTを指定して導出した，名前付きの導出表に対する問合せで，名前付きの導出表が副問合せ中に含まれるか，又は次のどれかを直接含む。
・GROUP BY句，HAVING句，又は集合関数
・SELECT DISTINCT
・表の結合（外結合，内結合を含む）
・選択式に列指定以外の値式を指定
・選択式に，FROM句で指定した名前付きの導出表の全列を一回ずつ指定していない
2. GROUP BY句，HAVING句，又は集合関数を指定して導出した，名前付きの導出表に対する問合せに，次のどれかを直接含む。
・GROUP BY句
・HAVING句
・集合関数
・表の結合（外結合，内結合を含む）
3. 選択式として列指定以外の値式を指定して導出した，名前付きの導出表に対する問合せに，次のどれかを直接含む。
・GROUP BY句
・HAVING句
・集合関数
・結合表
4. DISTINCT指定の集合関数を指定して導出した，名前付きの導出表に対する問合せに，SELECT DISTINCTの指定を直接含む。
5. 表の結合（外結合，内結合を含む）を指定して導出した，名前付きの導出表に対する問合せに，表の結合（外結合，内結合を含む）を直接含んで，かつ指定した表の結合のどれかが結合表の指定である。
6. 選択式としてスカラ副問合せを指定して，導出した名前付きの導出表に対する問合せである。
7. 集合演算によって導出した名前付きの導出表に対する問合せで，次のどちらかを満たしている。
・集合演算の演算項のどれかに，内部導出表の問合せ，導出表を指定した問合せ，又は選択式に副問合せを指定した問合せを含んでいる。
・集合演算の演算項のどれかと，名前付きの導出表に対する問合せが，1.～6.に示したどれかの条件を満たしている。
8. UNION ALL以外を含む集合演算によって導出した，名前付きの導出表に対する問合せで，次のどれかを直接含む。
・GROUP BY句，HAVING句，又は集合関数
・SELECT DISTINCT
・表の結合（外結合，内結合を含む）
・WHERE句
・副問合せ
・選択式に列指定以外の値式
・選択式に，FROM句に指定した名前付きの導出表の列を１回ずつ指定していない
9. UNION ALLだけの集合演算によって導出した，名前付きの導出表に対する問合せで，次のどれかを直接含む。
・GROUP BY句，HAVING句，又は集合関数
・表の結合（外結合，内結合を含む）
・WHERE句，又は副問合せ（ただし，副問合せ，集合演算の演算項，又はINSERT文の問合せだけ）
・関数呼出し又はシステム定義スカラ関数
・コンポネント指定
・WRITE指定
・GET_JAVA_STORED_ROUTINE_SOURCE指定
・選択式にない項目でのソート指定
・集合演算によって導出した名前付きの導出表をFROM句に指定した副問合せ
・導出表を指定した副問合せ
・GROUP BY句に列指定以外の値式を指定した副問合せ
・選択式に指定したSQL変数，及びSQLパラメタのうち，データ型が次のどれかになるもの
BLOB型
32,001バイト以上のBINARY型
抽象データ型
BOOLEAN型
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11462-E
Unable to specify "aa....aa" "bb....bb" in view definition or "WITH" clause or "WITH" query expression body　　（Ａ）
ビュー定義文の導出問合せ式，又はWITH句問合せ式中の導出問合せ式及び問合せ式本体には，他RDノード中の表をアクセスするために定義した表別名又は，他RDノードで修飾した表名は指定できません。
aa....aa：ALIAS又はOTHER RDNODE
bb....bb：表別名又は他RDノード名
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11463-E
Unable to specify long, large object, abstract or boolean data in "bb....bb" clause, query-no=aaa　　（Ａ）
GROUP BY句の値式，又はORDER BY句のソートのキーには，結果が抽象データ，BOOLEANデータ，BLOBデータ，又は最大長が32,001バイト以上のBINARYデータとなる値式は指定できません。
aaa：問合せの番号
bb....bb：｛GROUP BY｜ORDER BY｝
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11465-E
Data type must be BOOLEAN in "BOOLEAN" predicate, query-no=aaa　　（Ａ）
論理述語には，BOOLEAN型のデータ以外は指定できません。
aaa：不正なデータ型を指定した論理述語の問合せの番号
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11467-E
Unable to specify aa....aa in view definition or in "WITH" query　　（Ａ）
ビュー定義，又はWITH句の問合せの問合せ指定中には，次に示す指定はできません。
・コンポネント指定
・プラグインが提供する関数
・論理述語
・WRITE指定
・GET_JAVA_STORED_ROUTINE_SOURCE指定
aa....aa：
{ component specification
| PLUGIN function
| boolean predicate
| WRITE specification
| GET_JAVA_STORED_ROUTINE_SOURCE specification}
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11468-E
Inconvertible data type in "RETURN" statement with "RETURNS" clause　　（Ａ）
RETURN文とRETURNS句のデータ型が変換できるデータ型ではありません。
抽象データ型の場合は，RETURNS句とRETURN文の抽象データ型が同じ，又はRETURN文の抽象データ型がRETURNS句の抽象データ型のサブタイプである必要があります。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11469-E
Return data in "RETURN" statement too long for "RETURNS" clause　　（Ａ）
RETURNS句に対して，RETURN文中の戻り値データ長が長過ぎます。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11470-E
Unable to specify aa....aa in column-name list of ARRAY predicate, query-no=bbb　　（Ａ）
構造化繰返し述語の列指定に次のどれかの誤りがあります。
・繰返し列名は同一表の列，又は同一表から導出した列ではありません。
・繰返し列が外への参照列となっています。
・繰返し列に同じ列を指定しています。
・繰返し列でない列，SQL変数，又はSQLパラメタを指定しています。
aa....aa：
｛columns in different tables｜outer reference column
｜same columns｜single-value column, SQL variable or SQL parameter｜derived columns from different tables｝
bbb：その述語を指定した問合せの番号
(Ｓ)このSQL文を無視します。ただし，このSQL文が定義系SQLの場合，ロールバックします。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11471-E
Unable to specify columns in different tables in OR condition includes ARRAY predicate　　（Ａ）
次に示す列（外への参照列は除く）は，構造化繰返し述語を含むORのオペランドの探索条件には指定できません。
・異なる表の列
・異なる表から導出した列
ただし，異なる表とは，実表が同じで相関名が異なるものも含みます。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11472-E
Unable to specify both DISTINCT for selected row or distinct view and set operation in view definition or "WITH" query　　（Ａ）
ビュー定義，又はWITH句の問合せの導出問合せ式に集合演算（UNION ALL）を指定した場合，集合演算の対象となる問合せ指定には次の指定はできません。
・SELECT DISTINCT
・最も外側の問合せ指定にSELECT DISTINCTを指定して定義したビュー表
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11473-E
Unable to specify "aa....aa" in query for table derived from set operation　　（Ａ）
集合演算（UNION ALL）を指定して導出した表に対する問合せでは，次の指定はできません。
・GROUP BY句，HAVING句，又は集合関数
・表の結合
・集合演算
・結合表を指定した副問合せ
・GROUP BY句に列指定以外の値式を指定した副問合せ
・ソートのキーに，選択項目にない列を指定した問合せ
・関数呼出し
・コンポネント指定
aa....aa：｛grouping or set function｜join｜set operation｜subquery with joined table｜subquery with grouping by expression｜sorting by unselected column｜function invocation｜component specification｝
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11474-E
Unable to specify table derived from "bb....bb" in "aa....aa"　　（Ａ）
次のどれかの誤りがあります。
・集合演算（UNION ALL）を指定して導出した表は，次に示す問合せ指定のFROM句には指定できません。
・INSERT文の問合せ指定
・副問合せ
・ビュー定義中の導出問合せ式
・WITH句を用いた問合せの導出問合せ式
・結合表を指定して導出した表は，次の問合せ指定のFROM句には指定できません。
・ビュー定義中の導出問合せ式
・WITH句を用いた問合せの導出問合せ式
・集合演算（UNION ALL）の対象となる問合せに結合表を指定して導出した表は，副問合せを指定した問合せのFROM句に指定できません。
aa....aa：｛subquery｜INSERT statement｜view definition｜"WITH" query｜query in "FROM" clause｜query with subquery｝
bb....bb：｛set operation｜joined table｜set operation with joined table｝
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11475-E
Invalid a-th operand in bb....bb specification　　（Ａ）
bb....bb指定のa番目に指定したオペランドに誤りがあります。
・指定できない値式を指定しています。
・指定できないデータ型を指定しています。
a：誤りのあるオペランドの番号
bb....bb：誤りのある指定の名称
｛WRITE｜GET_JAVA_STORED_ROUTINE_SOURCE｝
(Ｓ)このSQL文を無視します。ただし，このSQL文が定義系SQLの場合，ロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11476-E
Error occurred during execution of system defined scalar function in aa....aa, query-no=bbb, detail="cc....cc"　　（Ａ）
システム定義スカラ関数の実行中にエラーが発生しました。
aa....aa：関数を指定している句又は文の名前
｛"WHERE" clause｜"SET" clause｜"ADD" clause
｜"SELECT" clause｜"ON" condition｜"GROUP BY" clause
｜"HAVING" clause｜"ORDER BY" clause｜"IF" statement
｜"WHILE" statement｜"SET" statement｜"RETURN" statement
｜"VALUES" statement｜"CALL" statement
｜"WRITE LINE" statement｜triggered action condition｝
bbb：句又は文を指定した問合せの番号
cc....cc：エラー詳細メッセージ
(Ｓ)このSQL文を無視します。
(Ｐ)エラー詳細メッセージの対策に従って，対処してください。
エラー詳細メッセージ（cc....cc）
関数名
説明
対策
Invalid value of 1st argument for function 関数名
ADD_INTERNAL，
DATETIME，
DAYNAME，
DAYOFWEEK，
DAYOFYEAR，
INTERVAL_DATETIMES，
ISDIGITS，
LAST_DAY，
MONTHNAME，
MONTHS_BETWEEN，
NEXT_DAY，
STRTONUM，
YEARSBETWEEN，
TRUNCYEAR，
ROUNDMONTH，
QUARTER，
HALF，
WEEK，
WEEKOFMONTH，
CENTURY，
MIDNIGHTSECONDES，
STRTONUM
引数1の値が不正です。
次の点に注意し，SQLを変更してください。
・引数に日付，時刻，日時の文字列表現を指定する場合，形式が正しいか
・引数に数値の文字列表現を指定する場合，形式が正しいか
・引数のデータ型が可変長文字列の場合，長さは適当か
引数の指定については，マニュアル「HiRDB Version 7 SQLリファレンス」の該当するスカラ関数を参照してください。
Invalid value of 2nd argument for function 関数名
DATETIME，
INTERVAL_DATETIMES，
LTRIM，
MONTHS_BETWEEN，
NEXT_DAY，
NUMEDIT，
REPLACE，
REPLACE_LONG，
ROUND，RTRIM，
TRUNC，
YEARSBETWEEN，
INSERTSTR，
INSERTSTR_LONG，
LEFTSTR，
RIGHTSTR，
TRUNCYEAR，
ROUNDMONTH，
QUARTER，
HALF
引数2の値が不正です。
Invalid value of 3nd argument for function 関数名
REPLACE，
REPLACE_LONG，
ROUND，
INSERTSTR，
INSERTSTR_LONG，
POSSTR，
TRUNCYEAR，
QUARTER，
HALF
引数3の値が不正です。
Invalid value of 4th argument for function 関数名
POSSTR，
TRANSL，
TRANSL_LONG
引数4の値が不正です。
Result data too long for returned data type in function 関数名
REPLACE，
REPLACE_LONG，
INSERTSTR，
INSERTSTR_LONG，
TRANSL，
TRANSL_LONG
結果の長さが，結果のデータ型の最大長を超えました。
結果の長さが，結果のデータ型の最大長を超えないようにしてください。
結果のデータ型のデータ長については，マニュアル「HiRDB Version 7 SQLリファレンス」の該当するスカラ関数を参照してください。
Domain error in function 関数名
ACOS，
ASIN，
LN，
LOG10，
SQRT
関数の定義域にない値が渡されました。
関数の定義域にない値を渡さないようにしてください。
関数の定義域については，マニュアル「HiRDB Version 7 SQLリファレンス」の該当するスカラ関数を参照してください。
Division by zero in function 関数名
POWER
0での除算が発生しました。
0での除算が発生しないようにしてください。
エラーが発生する条件については，マニュアル「HiRDB Version 7 SQLリファレンス」の該当するスカラ関数を参照してください。
Overflow error in function 関数名
ADD_INTERNAL，
CEIL，
COSH，
DEGREES，
EXP，
FLOOR，
GREATEST，
LEAST，
NEXT_DAY，
NUMEDIT，
POWER，
ROUND，
ROUNDMONTH，
SINH，
STRTONUM，
TAN，
TRUNCYEAR
オーバフローが発生しました。
関数の結果が，結果のデータ型で表現できるようにしてください。
KFPA11477-E
Data type of aa....aa -th argument in CALL statement inconvertible with parameter data type "bb....bb"　　（Ａ）
CALL文のaa....aa番目の引数のデータ型と，呼び出す手続きのbb....bb番目のパラメタのデータ型が変換できるデータ型ではありません。
aa....aa：変換できるデータ型でない引数の番号
bb....bb：手続きの対応するパラメタのデータ型
｛INTEGER｜SMALLINT｜DECIMAL(m,n)｜FLOAT
｜SMALLFLT｜CHARACTER(l)｜VARCHAR(l)｜NCHAR(l)
｜NVARCHAR(l)｜MCHAR(l)｜MVARCHAR(l)｜DATE
｜TIME｜TIMESTAMP(p)
｜INTERVAL YEAR TO DAY
｜INTERVAL HOUR TO SECOND
｜BLOB(l)|BINARY(l)|ABSTRACT DATA TYPE｝
m，nはそれぞれDECIMALの精度，位取りです。lは文字列の長さです。pは小数秒精度です。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11478-E
Invalid aa....aa 'bb....bb'　　（Ａ）
CREATE SERVERのサーバ種別又はサーババージョンで次のどれかの誤りがあります。
・サーバ種別の指定が30文字を超えています。
・サーババージョンの指定が30文字を超えています。
・アクセスできるサーバ種別を指定していません。
・アクセスできるサーババージョンを指定していません。
aa....aa：｛TYPE｜VERSION｝
bb....bb：誤りがあるサーバ種別又はサーババージョン
30文字以上の場合は先頭から30文字を表示します。
(Ｓ)このSQL文を無視します。
(Ｐ)bb....bbが誤っている場合は，SQL文を修正して，再度実行してください。bb....bbが正しい場合は，HiRDB管理者に連絡してください。
[対策]
aa....aaがTYPEで，かつbb....bbが正しい場合：
bb....bbに対応するHiRDB External Data Access Adapterがインストールされていません。インストールされているHiRDB External Data Access Adapterを確認してください。
aa....aaがVERSIONで，かつbb....bbが正しい場合：
HiRDB External Data Access Adapterが，bb....bbのサーババージョンをサポートしていません。インストールされているHiRDB External Data Access Adapterを確認してください。
KFPA11479-E
Invalid concatenation operation for "aa....aa" in UPDATE statement　　（Ａ）
連結演算を使用したBLOB列又は32,001バイト以上のBINARY列の更新で，次のどれかの誤りがあります。
・連結演算の第1演算項に列以外を指定しています。
・連結演算の第2演算項に埋込み変数，？パラメタ，SQL変数，及びSQLパラメタ以外を指定しています。
・更新対象列と連結演算の第1演算項の列が異なります。
・連結演算の結果に対して，連結演算を指定しています。
・検査制約の探索条件に指定したBLOB列又は定義長が32,001バイト以上のBINARY列を更新対象列に指定しています。
aa....aa：｛BLOB｜BINARY｝
(Ｓ)このSQL文を無視します。ただし，このSQL文が定義系SQLの場合，ロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11481-E
Error occurred in foreign server aa....aa (b), SQLCODE=cc....cc, inf=dd....dd　　（Ａ＋Ｌ）
HiRDB External Data Access機能を使用している場合に，外部サーバからエラーが返却されました。
aa....aa：外部サーバ名
b：サーバ種別
P：HiRDB
R：XDM/RD E2
O：ORACLE
I：DB2
cc....cc：外部サーバから返却されたSQLCODE
dd....dd：外部サーバから返却されたメッセージ
76文字以上の場合は，先頭から74文字目に2バイトのピリオド（..）を付けて出力します。
(Ｓ)処理を終了します。SQL文の実行でこのメッセージが出力された場合は，SQL文の実行を中止します。
(Ｐ)外部サーバのサーバ種別を確認し，該当するDBMSのマニュアルを基にSQLCODE及びエラーメッセージを参照してください。エラーの要因を取り除いたら，UAPを再度実行してください。
KFPA11482-E
Error occurred in External Data Access Adapter aa....aa (b), kind=cc, inf=dd....dd　　（Ａ＋Ｌ）
HiRDB External Data Access機能を使用している場合に，HiRDB External Data Access Adapterからエラーが返却されました。
aa....aa：外部サーバ名
b：サーバ種別
P：HiRDB
R：XDM/RD E2
O：ORACLE
I：DB2
cc：HiRDB External Data Access Adapterから返却されたエラー種別
dd....dd：HiRDB External Data Access Adapterから返却されたメッセージ
76文字以上の場合は，先頭から74文字目に2バイトのピリオド（..）を付けて出力します。
(Ｓ)処理を終了します。SQL文の実行でこのメッセージが出力された場合は，SQL文の実行を中止します。
(Ｐ)
エラー種別
cc
内容
対策
1
DBクライアントの初期化エラーです。
DBクライアントが動作する環境かどうか見直して，UAPを再度実行してください。
2
データがナル値であるのに，標識変数がありません。
CREATE FOREIGN TABLEで，エラーが発生した列に列一般オプションNULLABLE 'YES'を指定してください。
3
DECIMAL型への出力形式変換時にオーバフローが発生しました。
CREATE FOREIGN TABLEで指定しているデータ型を見直してください。
4
使用できないデータ型を指定しました。
5
データ変換エラーです。
上記以外
該当しません。
保守員に連絡してください。
KFPA11483-E
External Data Access Adapter not installed for foreign server aa....aa, type=bb....bb, version=cc....cc　　（Ａ＋Ｌ）
HiRDB External Data Access機能を使用している場合に，外部サーバに対応するHiRDB External Data Access Adapterがインストールされていません。
aa....aa：外部サーバ名
bb....bb：サーバ種別（CREATE SERVERで指定したサーバ種別）
cc....cc：サーババージョン（CREATE SERVERで指定したサーババージョン）
(Ｓ)処理を終了します。SQL文の実行でこのメッセージが出力された場合は，SQL文の実行を中止します。
(Ｐ)CREATE SERVERで指定したサーバ種別とサーババージョンに対応する，HiRDB External Data Access Adapterのインストールを，HiRDB管理者に依頼してください。
[対策]CREATE SERVERで指定したサーバ種別とサーババージョンに対応する，HiRDB External Data Access Adapterをインストールしてください。
KFPA11484-E
Fail to load External Data Access Adapter.　　（Ａ＋Ｌ）
HiRDB External Data Access Adapterのロードに失敗しました。
(Ｓ)処理を終了します。
[対策]このメッセージの前に出力されている，KFPWメッセージに従って対策してください。
KFPA11485-E
Fail to get symbol External Data Access Adapter.　　（Ａ＋Ｌ）
HiRDB External Data Access Adapterの共用ライブラリのシンボルの取得に失敗しました。
(Ｓ)処理を終了します。
[対策]このメッセージの前に出力されている，KFPWメッセージに従って対策してください。
KFPA11486-E
Unable to connect foreign server aa....aa (b), reason=cc....cc　　（Ａ＋Ｌ）
HiRDB External Data Access機能を使用している場合に，次の理由で外部サーバに接続できません。
・外部サーバに対するユーザマッピングが定義されていません。
aa....aa：外部サーバ名
b：サーバ種別
P：HiRDB
R：XDM/RD E2
O：ORACLE
I：DB2
cc....cc：理由（USER_MAPPING）
(Ｓ)処理を終了します。SQL文の実行でこのメッセージが出力された場合は，SQL文の実行を中止，又はトランザクションを無効にします。
(Ｏ)外部サーバに対するユーザマッピングを定義して，UAPを再度実行してください。
KFPA11487-E
Status of dynamic result set invalid　　（Ａ）
次の理由で，不正な動的結果集合としてのオブジェクトが返されました。
・Javaストアドプロシジャとして定義したメソッドから動的結果集合として返しているオブジェクトは，問合せで結果集合を求めたオブジェクトではありません。
(Ｓ)トランザクションを無効にします。
(Ｐ)Javaストアドプロシジャとして定義したメソッドで動的結果集合として返すオブジェクトは，問合せをするオブジェクトを指定してください（JDBCのprepareStatementメソッドで指定するSQL文をSELECT文にしてください）。また，このオブジェクトの問合せを実行してください（JDBCのexecuteQueryメソッドを実行してください）。
KFPA11488-E
Duplicate dynamic result set　　（Ａ）
Javaストアドプロシジャとして定義したメソッドから動的結果集合として返しているオブジェクトを，複数のパラメタで指定しています。
(Ｓ)トランザクションを無効にします。
(Ｐ)Javaストアドプロシジャとして定義したメソッドから動的結果集合として返しているオブジェクトを，複数のパラメタで設定しないようにメソッドを修正してください。
KFPA11489-E
System function dd....dd error, code=ee....ee, in copying JAR file "aa....aa" to "bb....bb" for cc....cc　　（Ａ）
JARファイルの登録，再登録，又は削除中にシステム関数でエラーが発生しました。
aa....aa：JARファイル名（80文字を超える場合は，先頭から80文字を表示）
bb....bb：テンポラリファイル名
cc....cc：{ install | replace | remove }
dd....dd：システム関数名
ee....ee：システム関連エラーの詳細コード
「システム関連エラーの詳細コード」を参照してください。
(Ｓ)トランザクションを無効にします。
(Ｐ)エラーの要因を取り除いて，再度実行してください。
KFPA11490-E
aa....aa JAR "bb....bb" failed, because cc....cc　　（Ａ）
JARファイルの登録，再登録，又は削除に失敗しました。
aa....aa：{ install | replace | remove }
bb....bb：JARファイル名（80文字を超える場合は，先頭から80文字を表示）
cc....cc：理由
transaction already begin：
トランザクションは既に開始していします。
JAR file already installed：
JARファイルは既に登録されています。
JAR file not found：
JARファイルがありません。
JAR file synchronization failed：
pdjarsyncコマンドでエラーが発生しました。
(Ｓ)トランザクションを無効にします。
(Ｐ)
・cc....ccがtransaction already beginの場合
登録，再登録，又は削除をする前に，トランザクションを決着させてください（COMMIT又はROLLBACKをしてください）。
・cc....ccがJAR file already installedの場合
既にあるJARファイルを上書きしてもよい場合は，REPLACE JARを実行してください。
・cc....ccがJAR file not foundの場合
指定したJARファイル名を修正して，再度実行してください。
・cc....ccがJAR file synchronization failedの場合
pdjarsyncコマンドでJARファイルの一覧表示を実行して，内容を確認してください。必要であれば，pdjarsyncコマンドで登録，再登録，又は削除を再度実行してください。
KFPA11491-E
Error occurred on JavaVM, message=aa....aa　　（Ａ）
Java仮想マシン上でエラーが発生しました。
aa....aa：エラーの内容，種別
INIT：
起動時にエラーが発生しました。
例外，エラーメッセージ：
起動時以外にエラーが発生しました。文字数が208文字を超える場合は，208文字目に#が表示されます。
******：
JavaVMに異常が発生しています。
(Ｓ)このSQL文を無視します。
(Ｐ)再度Javaストアドプロシジャ，Javaストアドファンクションを実行してください。それでも同様のエラーが発生する場合は，HiRDB管理者に連絡してください。
(Ｏ)
・aa....aaがINITの場合
次のシステム定義のオペランドが正しく設定されているかを確認してください。
pd_java_option，pd_java_archive_directory，pd_java_classpath，pd_java_libpath，pd_java_stdout_file
・aa....aaが例外，エラーメッセージの場合
JDKのドキュメントを参照して対処してください。
・aa....aaが******の場合
HiRDBサーバを再開始してください。
KFPA11492-E
Exception raised, in java method=cc....cc for ROUTINE aa....aa."bb....bb", message=dd....dd　　（Ａ）
Javaストアドプロシジャ，Javaストアドファンクションとして定義したJavaメソッド実行中に，例外・エラーが発生しました。
aa....aa：所有者名
bb....bb：Javaストアドプロシジャ，Javaストアドファンクションの名称
cc....cc：Javaメソッド名（64文字を超える場合は，64文字目に#が表示されます）
dd....dd：次のどちらかの内容が表示されます（65文字を超える場合は，65文字目に#を表示します）。
・Javaメソッドで発生した例外・エラーオブジェクトに設定されている詳細メッセージ
・例外・エラーオブジェクトのクラス名（上記の詳細メッセージが設定されていない場合に表示されます）
(Ｓ)このSQL文を無視します。
(Ｐ)次のどちらかの処置をしてください。
・例外・エラーメッセージを参考に，Javaメソッドを再作成してください。
・システム定義のpd_java_stdout_fileオペランドで指定したファイルに出力される，Javaメソッドからの標準出力，標準エラー出力を参考に，例外・エラー発生原因を取り除いてください。
(Ｏ)Javaメソッドからの標準出力，標準エラー出力を取得できるようにするため，システム定義のpd_java_stdout_fileオペランドを指定してください。
KFPA11493-E
Unable to execute Java method for ROUTINE aa....aa."bb....bb", reason_code=cc, message=dd....dd　　（Ａ）
ccの理由で，Javaストアドプロシジャ，Javaストアドファンクションが実行できませんでした。
aa....aa：所有者名
bb....bb：Javaストアドプロシジャ，Javaストアドファンクションの名称
cc：理由コード
02：指定したメソッドがありません。
03：クラスロードに失敗しました。
04：指定したメソッドでセキュリティ違反の例外が発生しました。
05：JARファイルの入出力処理に失敗しました。
06：指定したJARファイルがありません。
07：指定したクラスがありません。
08：指定したメソッドにstatic修飾子がありません。
09：Javaストアドプロシジャ，Javaストアドファンクション定義時の"EXTERNAL NAME"で指定した戻り値の型と，Javaメソッドの戻り値の型が異なります。
dd....dd：メッセージ（109文字を超える場合は，109文字目に#が表示されます）
ccが02，04，及び08の場合はメソッド名
ccが03及び07の場合はクラス名
ccが05及び06の場合はJARファイル名
ccが09の場合は，"EXTERNAL NAME"で指定した戻り値の型名とJavaメソッドの戻り値の型名
(Ｓ)このSQL文を無視します。
(Ｐ)次のどちらかの処置をしてください。
・Javaストアドプロシジャ，Javaストアドファンクション定義時のEXTERNAL NAMEの，次の指定箇所を見直してください。
ccが02及び04の場合はメソッド名
ccが03及び07の場合はクラス名
ccが05及び06の場合はJARファイル名
ccが08の場合はJavaクラスのソースファイル（メソッドのstatic修飾子の有無）
ccが09の場合は戻り値の型とJavaメソッドの戻り値の型
・指定したJARファイルが，正常に登録されているかを確認してください。
KFPA11494-E
Unable to use JAVA procedure or function　　（Ａ）
次の理由で，Javaストアドプロシジャ，Javaストアドファンクションは使用できません。
・使用しているHiRDBは，POSIXライブラリ版ではありません。
(Ｓ)このSQL文を無視します。ただし，定義系SQLの場合は，トランザクションを無効にします。
[対策]Javaストアドプロシジャ，Javaストアドファンクションを使用する場合は，pdsetup -lコマンドを実行してください。
KFPA11495-E
Unable to execute SQL in function aa....aa."bb....bb" (cc....cc)　　（Ａ）
関数aa....aa."bb....bb"から，データベース操作をするSQL文を実行しています。
aa....aa：所有者名
bb....bb：関数名
cc....cc：特定名
(Ｓ)このSQL文を無視します。
(Ｐ)関数aa....aa."bb....bb"からSQL文を実行しないように修正して，再度実行してください。
関数本体がJavaメソッドの場合，Javaメソッドでデータベース操作をしないように修正して，再度実行してください。
KFPA11496-E
Unable to specify subquery in SQL using foreign table　　（Ａ）
外部表をアクセスするSQLに，副問合せは指定できません。また，副問合せを含むビュー表は外部表と混在して指定できません。
(Ｓ)このSQL文を無視します。ただし，このSQL文が定義系SQLの場合，ロールバックします。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11500-E
Unable to open holdable cursor　　（Ａ）
次の理由で，ホールダブルカーソルは開けません。
・サーバ共通定義，バックエンドサーバ定義，ディクショナリサーバ定義，又はシングルサーバ定義のpd_max_open_holdable_cursorsオペランドで指定したUNTIL DISCONNECT指定LOCK文非実行時のホールダブルカーソルの最大同時オープン数を超えました。
(Ｓ)このSQL文を無視します。
(Ｐ)UAP又はSQLを修正して，再度実行してください。
[対策]サーバ共通定義，バックエンドサーバ定義，ディクショナリサーバ定義，又はシングルサーバ定義のpd_max_open_holdable_cursorsオペランドで指定するUNTIL DISCONNECT指定LOCK文非実行時のホールダブルカーソルの最大同時オープン数を見直して，必要があれば指定値を変更し，HiRDBを再開始してください。
KFPA11501-E
Cursor not opened　　（Ａ）
FETCH文，又はCLOSE文で指定したカーソルが開かれていません。
(Ｓ)このSQL文を無視します。
(Ｐ)カーソルを開いてから行を取り出し，カーソルを閉じるようにUAPを修正し，再度実行してください。
KFPA11502-E
Cursor already opened　　（Ａ）
既に開いた状態のカーソルを開こうとしています。
(Ｓ)このSQL文を無視します。
(Ｐ)カーソルを閉じてから，再び開くようにUAPを修正し，再度実行してください。
KFPA11504-E
Invalid data type specified in routine definition　　（Ａ）
ルーチン定義中のデータ型の指定に，次のどれかの誤りがあります。
・LANGUAGE句にJavaを指定したルーチンのパラメタのデータ型と，EXTERNAL NAME句に指定したデータ型が，変換できるデータ型ではありません。
・LANGUAGE句にJavaを指定したルーチンのRETURN句のデータ型と，EXTERNAL NAME句に指定した戻り値のデータ型が，変換できるデータ型ではありません。
・LANGUAGE句にJavaを指定したルーチンのパラメタのデータ型と，EXTERNAL NAME句に指定したデータ型の数が異なります。
・パラメタのデータ型のデータ長又は戻り値のデータ型のデータ長に，*を指定しています。
・LANGUAGE句にJavaを指定した手続きのEXTERNAL NAME句のreturns 型名にvoid以外を指定しています。
(Ｓ)このSQL文を無視します。
(Ｐ)SQLを修正し，再度実行してください。
KFPA11505-E
aa....aa requested for query with opened cursor　　（Ａ）
カーソルが開いている問合せに対して，前処理若しくは前処理の無効化を要求しています。又は，ほかのカーソルが参照して開いている問合せに対して，前処理若しくは前処理の無効化を要求しています。
aa....aa：実行要求したSQL文
PREPARE：前処理を要求しました。
DEALLOCATE PREPARE：前処理の無効化を要求しました。
(Ｓ)このSQL文を無視します。
(Ｐ)カーソルを閉じてから前処理若しくは前処理の無効化をするようにUAPを修正し，再度実行してください。又は，参照しているほかのカーソルを閉じてから前処理若しくは前処理の無効化をするようにUAPを修正し，再度実行してください。
KFPA11506-E
Invalid request for executing of query　　（Ａ）
PREPARE文で前処理をした問合せは，EXECUTE文で実行できません。又は，EXECUTE IMMEDIATE文では，問合せを実行できません。
(Ｓ)このSQL文を無視します。
(Ｐ)次に示す順序でSQLを実行するようにUAPを修正して，再度実行してください。
1　カーソルの宣言，又はカーソルの割り当て
2　OPEN文
3　FETCH文
4　CLOSE文
KFPA11507-E
aa....aa cursor for SQL except query　　（Ａ）
aa....aaがDeclareの場合：
問合せ以外のSQL文に対して，カーソルの宣言（DECLARE CURSOR）をしています。
aa....aaがAllocateの場合：
問合せ以外のSQL文に対して，カーソルの割り当て（ALLOCATE CURSOR文）をしています。
aa....aa：｛Declare｜Allocate｝
(Ｓ)このSQL文を無視します。
(Ｐ)
aa....aaがDeclareの場合：
カーソル宣言をしたSQL文を問合せに変更するか，又は問合せ以外のSQL文に対するカーソル宣言を削除するようにUAPを修正して，再度実行してください。
aa....aaがAllocateの場合：
カーソル割り当てをしたSQL文を問合せに変更するか，又は問合せ以外のSQL文に対するカーソル割り当てを削除するようにUAPを修正して，再度実行してください。
KFPA11508-E
Invalid use of "aa....aa" statement　　（Ａ）
INTO句のあるEXECUTE文，又はEXECUTE IMMEDIATE文で，CALL文及び1行SELECT文以外のSQLを実行しようとしています。
aa....aa：｛EXECUTE｜EXECUTE IMMEDIATE｝
(Ｓ)このSQL文を無視します。
(Ｐ)EXECUTE文，又はEXECUTE IMMEDIATE文の使用方法を修正し，再度実行してください。CALL文及び1行SELECT文以外のSQLを，EXECUTE文，又はEXECUTE IMMEDIATE文で実行する場合は，INTO句のないEXECUTE文，又はEXECUTE IMMEDIATE文に修正し，再度実行してください。
KFPA11511-E
Unmatched RDAREA status or generation number between number "aa" of "bbbbb" RDAREA "cc....cc" and number "dd" of table RDAREA "ee....ee"　　（Ａ）
bbbbb格納用RDエリアcc....ccと表格納用RDエリアee....eeは，状態が一致していない，又は世代aaと世代ddが一致していません。
aa：ユーザLOB用RDエリア又はインデクス格納用RDエリアの世代番号
bbbbb：RDエリアの格納データ種別
｛INDEX｜LOB｝
cc....cc：ユーザLOB用オリジナルRDエリア又はインデクス格納用オリジナルRDエリアの名称
dd：表格納用RDエリアの世代番号
ee....ee：表格納用オリジナルRDエリアの名称
(Ｓ)トランザクションを無効にします。
(Ｏ)HiRDB管理者に連絡してください。
[対策]次のどれかの処置をしてください。
・カレントアクセス時，表格納用RDエリアとユーザLOB用RDエリア，インデクス格納用RDエリアの世代が一致していない場合
pddbchgコマンドを実行し，ユーザLOB用RDエリア又はインデクス格納用RDエリアの世代番号と表格納用RDエリアの世代番号を合わせてください。
・該当するRDエリアに，指定した世代のレプリカRDエリアが作成されていない場合
pdmodでレプリカRDエリアを作成してください。
・表格納用RDエリアとユーザLOB用RDエリアの世代が一致している場合
表格納用RDエリアとユーザLOB用RDエリアの状態が一致していません。pddbchgコマンドを実行し，表格納用RDエリアとユーザLOB用RDエリアの状態を，カレント又はカレント以外の状態にしてください。
KFPA11512-E
Invalid request for executing of SQL except query　　（Ａ）
PREPARE文で前処理をした問合せ以外のSQL文は，OPEN文，FETCH文，及びCLOSE文では実行できません。
(Ｓ)このSQL文を無視します。
(Ｐ)EXECUTE文で実行するようにUAPを修正し，再度実行してください。また，指定したカーソルに誤りがあれば，カーソル名を修正し，再度実行してください。
KFPA11513-E
Unable to execute definition SQL due to aa....aa bb....bb. "cc....cc" using replicated RDAREA dd....dd　　（Ａ）
表又はインデクスを格納しているRDエリアは，インナレプリカ機能を使用しているため，次の定義系SQLは実行できません。
・ALTER TABLE
・CREATE INDEX
・DROP INDEX
・DROP SCHEMA
・DROP TABLE
aa....aa：｛TABLE｜INDEX｝
bb....bb：認可識別子
cc....cc：aa....aaがTABLEの場合は表識別子，aa....aaがINDEXの場合はインデクス識別子
dd....dd：RDエリア名
(Ｓ)このSQL文を無視します。
(Ｐ)インナレプリカ機能の適用を解除して，再度実行してください。
KFPA11514-E
Unable to execute "SET SESSION AUTHORIZATION" statement, due to aa....aa　　（Ａ）
次の理由で，ユーザは変更できません。
・トランザクションが既に開始されています。
・ホールダブルカーソルが開いています。
・LOCK文でUNTIL DISCONNECT指定の排他を掛けています。
・分散RDノードに接続しています。
・トランザクション内で最初に実行していません。
aa....aa：次のどれかです。
｛ACTIVE TRANSACTION｜HOLDABLE CURSOR｜LOCK WITH UNTIL DISCONNECT｜DISTRIBUTED DATABASE ACCESS｜NON-FIRST EXECUTION｝
(Ｓ)このSQL文を無視します。
(Ｐ)UAPを修正し，再度実行してください。
KFPA11528-E
aa....aa bb....bb.cc....cc(dd....dd) not executable due to invalid SQL OBJECT　　（Ａ）
SQLオブジェクトが無効になっています。このため，このルーチンは実行できません。
aa....aa：ルーチン種別{ Procedure | Function }
bb....bb：認可識別子
cc....cc：ルーチン識別子
dd....dd：特定名
(Ｓ)このSQL文を無視します。又は，トランザクションを無効にします。
(Ｐ)無効になった原因（表の変更，インデクスの変更，又は定義内容の変更）を取り除いて，ルーチンを定義し直した後，再度SQLを実行してください。
KFPA11529-E
aa....aa bb....bb.cc....cc invokable for specified arguments not found in system　　（Ａ）
次に示すSQL文で指定したルーチンは，HiRDBシステムにはありません。又は，呼び出せるルーチンがありません。
・DROP PROCEDURE
・DROP FUNCTION
・ALTER PROCEDURE
・CALL文
・関数呼出し（ユーザ定義関数，システム定義関数）
・CREATE INDEX TYPE
・ALTER INDEX TYPE
なお，CALL文及び関数呼出しでは，隠蔽されたルーチンを呼び出せません。
CALL文及び関数呼出しの引数の数が，ルーチンのパラメタ数と一致しないルーチンは呼び出せません。関数呼出しの場合，引数のデータ型より優先度の高いデータ型を対応するパラメタに持つ関数は呼び出せません。
呼び出す関数の決定規則については，マニュアル「HiRDB Version 7 SQLリファレンス」を参照してください。
CALL文の場合，引数のデータ型とパラメタのデータ型に互換性がないときは，呼び出せません。
aa....aa：ルーチン種別{ Procedure | Function }
bb....bb：認可識別子
cc....cc：ルーチン識別子
(Ｓ)このSQL文を無視します。又は，トランザクションを無効にします。
(Ｐ)
〈CALL文の実行時，又は関数呼出し時（ユーザ定義関数）〉
次に示す指定に誤りがないか確認してください。誤りがない場合，それぞれCREATE PROCEDURE，CREATE FUNCTIONで手続きを定義し直して，再度SQLを実行してください。
・認可識別子
・ルーチン識別子
・引数の数
・引数のデータ型
また，ルーチン定義時の隠蔽レベルに誤りがある場合は，CREATE TYPEでルーチンを再定義し，再度SQLを実行してください。
〈関数呼出し時（システム定義関数）〉
次に示す指定に誤りがないか確認してください。
・認可識別子
・ルーチン識別子
・引数の数
・引数のデータ型
〈DROP PROCEDUREの実行時〉
指定した認可識別子，及びルーチン識別子に誤りがないかどうか確認してください。
〈ALTER PROCEDUREの実行時〉
指定した認可識別子，及びルーチン識別子に誤りがないかどうか確認してください。誤りがない場合，CREATE PROCEDUREで手続きを定義し直してください。
〈DROP FUNCTIONの実行時〉
指定した認可識別子，ルーチン識別子，引数の数，及び引数のデータ型に誤りがないかどうか確認してください。
〈CREATE INDEX TYPE，又はALTER INDEX TYPE実行時〉
次に示す指定に誤りがないか確認してください。誤りがない場合，それぞれCREATE FUNCTION，CREATE DATA TYPEで関数を定義し直してください。
・認可識別子
・ルーチン識別子
・引数の数
・引数のデータ型
KFPA11530-E
SQL OBJECT not executable aa....aa ,size=bb....bb　　（Ａ）
SQLオブジェクト転送サイズが，1メガバイトを超えたため，実行できません。
aa....aa：実行できない理由
TRANSFER MAX SIZE：SQLオブジェクト最大転送サイズ
bb....bb：1メガバイトを超えたサイズ
(Ｓ)トランザクションを無効にします。
(Ｐ)SQLオブジェクト転送サイズが1メガバイトを超えないようにSQLを修正して，再度実行してください。
KFPA11531-E
SQL OBJECT CACHE currently full, server=aa....aa, info=bb....bb　　（Ａ）
SQLオブジェクト用バッファに十分な空きがないため，このSQLオブジェクトは実行できません。
aa....aa：不足したサーバ名
bb....bb：不足したリソース情報
｛数値，"SQL OBJECT MANAGEMENT"，"ACTIVE LIST"｝
(Ｓ)このSQLオブジェクトを実行しません。又は，トランザクションを無効にします。
(Ｐ)管理者に連絡して該当サーバのpd_sql_object_cache_sizeの値を増やしてください。又は，不足したリソース情報を基に次の対策をしてください。
〈リソース情報が数値の場合〉
SQLオブジェクト用バッファ長よりもSQLオブジェクト長が小さくなるように，SQLを修正してください（手続き，関数を呼び出している場合は，その手続き，関数のSQLオブジェクト長が小さくなるように手続き，関数を再作成してください）。
〈リソース情報が"SQL OBJECT MANAGEMENT"の場合〉
同時に実行するUAPを減らしてください。又は，一つのトランザクションで実行するSQL，手続き，関数の数を減らしてください。
〈リソース情報が"ACTIVE LIST"の場合〉
一つのトランザクションで実行するSQL，手続き，関数の数を減らしてください。又は，pd_max_access_tablesの値を増やしてください。
[対策]再度，SQLオブジェクト用バッファ長を見積もった後，該当サーバ又はシステムのpd_sql_object_cache_sizeの値を増やしてください。
KFPA11537-E
Unable to execute specified ROUTINE due to invalid SQL OBJECT　　（Ａ）
指定されたルーチンには，プラグインインデクスの遅延一括作成に必要な情報がありません。このため，プラグインインデクスの遅延一括作成ができません。
(Ｓ)トランザクションを無効にします。
(Ｐ)プラグインインデクスの遅延一括作成をしない場合は，クライアント環境定義にPDPLGIXMK＝NOを指定してください。
[対策]プラグインインデクスの遅延一括作成をする場合は，プラグインインデクスを更新するすべてのルーチンに対して，ALTER ROUTINE又はALTER PROCEDUREを実行してください。
KFPA11546-E
Unable to assign LIST due to executing "pdmod"　　（Ａ）
作成しようとするリストの基表が格納されているRDエリアは，データベース構成変更ユティリティで初期化中のため，リストの作成，及び検索ができません。
(Ｓ)このSQL文を無視します。
(Ｏ)データベース構成変更ユティリティの処理が終了してから再度実行してください。
KFPA11547-E
Unable to define view from "SQL_USERS"　　（Ａ）
ディクショナリ表のSQL_USERS表を基として，ビュー表を定義できません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11548-E
Unable to execute aa....aa：no dd....dd privilege for table bb....bb.cc....cc　　（Ａ）
該当する表のdd....dd権限がないため，aa....aaのSQL文を実行できません。
また，ディレクトリサーバ連携機能を使用していて，aa....aaにCREATE VIEWが表示された場合は，ビュー表の基表のSELECT権限がないためCREATE VIEWを実行できません。自分が属するグループ又はロールにSELECT権限があっても，その権限を使用してビュー表を定義できません。
aa....aa：実行しようとしたSQL文
bb....bb：認可識別子
cc....cc：表識別子
dd....dd：必要なアクセス権限
ただし，EXCLUSIVE指定でLOCK TABLEを実行しているときは，表に対してDELETE，INSERT，又はUPDATEの，どの権限もない場合，dd....ddにUPDATEと表示されます。
(Ｓ)このSQL文を無視します。
(Ｐ)必要なアクセス権限を得てから実行してください。
ディレクトリサーバ連携機能を使用していて，aa....aaにCREATE VIEWが表示された場合は，ビュー表の基表の所有者から，基表のSELECT権限を与えてもらってください。
KFPA11549-E
Invalid authorization identifier aa....aa　　（Ａ）
PUBLIC，MASTER，HiRDB，ALLを認可識別子，グループID，又はロール名に指定しています。誤った使用方法として，次のような使用方法が考えられます。
・これらの文字列を認可識別子に指定してHiRDBサーバと接続しようとしています。
・これらの文字列の認可識別子の実表，又はビュー表を作成（又は削除）しようとしています。
・これらの文字列の認可識別子の表のインデクスを削除しようとしています。
・これらの文字列の認可識別子の表を更新しようとしています。
・これらの文字列の認可識別子の手続き，又は関数を作成（又は削除）しようとしています。
・これらの文字列の認可識別子の手続き，又は関数を再作成しようとしています。
・これらの文字列の認可識別子のデータ型，又はインデクス型を作成（又は削除）しようとしています。
・これらの文字列の認可識別子のデータ型，又はインデクス型を変更しようとしています。
・認可識別子がHiRDBの表を検索しようとしています。
・（GRANT）権限定義，又は（REVOKE）権限削除でユーザの認可識別子としてこれらの文字列の認可識別子を指定しています。
aa....aa：PUBLIC，MASTER，HiRDB，又はALL
(Ｓ)このSQL文を無視します。
(Ｐ)認可識別子を修正し，再度実行してください。
KFPA11550-E
Unable to access MASTER.aa....aa without DBA or Auditor privilege　　（Ａ）
ディクショナリ表aa....aaは，DBA権限又は監査権限がないとアクセスできません。
aa....aa：アクセスしようとしたディクショナリ表の表識別子
(Ｓ)このSQL文を無視します。
(Ｐ)アクセスしようとしたディクショナリの表識別子に誤りがないか調べてください。誤りがある場合は，誤りを修正して再度実行してください。誤りがない場合は，HiRDB管理者に連絡して，必要に応じてDBA権限又は監査権限を与えてもらってください。
KFPA11551-E
Unable to execute aa....aa due to lack of privilege for the table bb....bb."cc....cc"　　（Ａ）
実行者が表所有者ではありません。このため，aa....aaに示すSQL文は実行できません。
又は，実行者に与えられていない権限をほかのユーザに与えられません。
aa....aa：実行できないSQL文
・grant table access privilege：表に対するアクセス権限定義
・revoke table access privilege：表に対するアクセス権限削除
bb....bb：認可識別子
cc....cc：表識別子
(Ｓ)このSQL文を無視します。
[対策]GRANT文，又はREVOKE文の場合は，自分の所有する表に対してこのSQL文を実行してください。また，読み込み専用のビュー表に対しては，SELECT権限だけを与えるように，SQL文を変更して実行してください。
KFPA11552-E
Unable to execute "aa....aa" due to lack of privilege　　（Ａ）
DBA権限がないため，"aa....aa"に表示したSQL文を実行できません。
又は，DBA権限保持者のパスワードをHiRDBに登録していないため，"aa....aa"に表示したSQL文を実行できません。
aa....aa：実行できないSQL文
・CREATE ALIAS
・DROP ALIAS
・GRANT DBA
・GRANT CONNECT
・GRANT RDAREA
・GRANT SCHEMA
・REVOKE DBA
・REVOKE CONNECT
・REVOKE RDAREA
・REVOKE SCHEMA
・CREATE SERVER
・CREATE USER MAPPING
・DROP SERVER
・DROP USER MAPPING
(Ｓ)このSQL文を無視します。
(Ｐ)DBA権限を取得してからこのSQL文を実行してください。
又は，DBA権限保持者のパスワードをHiRDBに登録してから，このSQL文を実行してください。
KFPA11553-E
Unable to execute function IS_USER_CONTAINED_IN_HDS_GROUP　　（Ａ）
スカラ関数IS_USER_CONTAINED_IN_HDS_GROUPが実行できません。次に示す要因が考えられます。
・値式中に列指定をする場合は，ディクショナリ表以外の列を指定できません。
・値式に複数の表の列を指定しています。このスカラ関数を指定した述語をOR演算する場合は，OR演算中に複数の表の列を指定できません。ここではAND演算をNOTで否定した場合もOR演算とみなします。
・リストを使用した検索中にこのスカラ関数は指定できません。
・選択式，又はHAVING句にこのスカラ関数を指定できません。
・外結合の結合表のON探索条件に指定する場合は，値式に外表の列を指定できません。
・FROM句に外結合の結合表を指定し，かつWHERE句にこのスカラ関数を指定する場合は，外結合の内表の列を指定できません。
・値式中にディクショナリ表の列を指定しない場合は，次の指定ができません。
・FROM句に複数の表を指定
・ORDER BY指定
・DISTINCT指定
・GROUP BY指定
・集合関数指定
・FOR UPDATE指定
・FOR READ ONLY指定
・FROM句にはディクショナリ表を一つ以上指定してください。
・グループID又はロール名の長さが制限を超えています。
(Ｓ)このSQL文を無視します。
(Ｐ)前記の要因に該当していないかどうかを確認して，該当する場合はSQL文を修正して再度実行してください。
KFPA11554-E
Unable to grant privilege to yourself　　（Ａ）
権限を自分自身に対して与えられません。
(Ｓ)このSQL文を無視します。
[対策]TO句で指定した自分の認可識別子を変更し，再度実行してください。
KFPA11555-E
Unable to revoke privilege from yourself　　（Ａ）
自分自身が持つ権限は，自分自身で削除できません。
(Ｓ)このSQL文を無視します。
[対策]FROM句で指定した自分の認可識別子を変更し，再度実行してください。
KFPA11556-E
Unable to execute aa....aa table access privilege bb....bb table owner　　（Ａ）
GRANT文（権限定義），又はREVOKE文（権限削除）で指定した認可識別子の並びに，表所有者の認可識別子があります。
aa....aa：誤りがあるSQL文{GRANT | REVOKE}
bb....bb：誤りがあるSQL文の指定{TO | FROM}
(Ｓ)このSQL文を無視します。
[対策]表所有者への権限定義，又は表所有者からの権限削除は，実行できません。このため，TO句又はFROM句で指定した表所有者の認可識別子を削除し，再度実行してください。
KFPA11558-E
pdvrup command not executed　　（Ａ）
HiRDBのバージョンアップを試みましたが，pdvrupコマンドを実行していないため，UAPやユティリティは実行できません。
(Ｓ)このSQL文をエラーにします。
(Ｏ)pdvrupコマンドを実行してください。
KFPA11559-E
Unable to grant privileges to unauthorized user aa....aa　　（Ａ）
CONNECT権限を持たないユーザにスキーマ定義権限を与えられません。
ディレクトリサーバ連携機能を使用している場合は，ディレクトリサーバに登録していないユーザにDBA権限又はスキーマ定義権限を与えられません。
aa....aa：
・CONNECT権限を持たないユーザの認可識別子
・ディレクトリサーバに登録していないユーザの認可識別子
(Ｓ)このSQL文を無視します。
[対策]
指定した認可識別子aa....aaに誤りがないかを確認してください。誤りがあれば，認可識別子を修正して再度実行してください。
誤りがない場合，認可識別子aa....aaに対してCONNECT権限を与えて再度実行してください。ディレクトリサーバ連携機能を使用している場合は，ディレクトリサーバに認可識別子aa....aaのユーザを登録して再度実行してください。
KFPA11560-E
Invalid password for authorization identifier aa....aa　　（Ａ）
指定したパスワードは，認可識別子aa....aaのパスワードと異なります。
ディレクトリサーバ連携機能を使用している場合，指定したパスワードがディレクトリサーバに登録されているパスワードと異なるか，又はパスワードが期限切れになっています。表のアクセス時にこのメッセージが出力された場合は，ユーザがHiRDBに接続した時点から今までの間にディレクトリサーバのユーザ情報のパスワード属性が変更されたか，又はパスワードの期限が切れました。
aa....aa：異なるパスワードを指定した認可識別子
(Ｓ)このSQL文を無視します。
ただし，ユティリティを実行している場合，処理を終了します。
(Ｐ)HiRDBへの接続時にこのメッセージが出力された場合は，正しいパスワードを指定して再度実行してください。
Windows NTの場合，「-u 認可識別子」という指定のあるユティリティを実行する場合は，次の点も確認してください。
・パスワードを応答する形で入力する場合，文字列を「￥」で囲んで入力する必要はありません。コマンドラインでは「￥」で囲む指定方法は正しいのですが，応答形式では必要ありません。
ディレクトリサーバに登録したパスワードが期限切れの場合は，ディレクトリサーバにパスワードを再設定した後に再度実行してください。
表のアクセス時にこのメッセージが出力された場合は，いったんHiRDBと切り離してください。その後，ディレクトリサーバに登録している現時点の認可識別子とパスワードを指定してHiRDBに再接続して，再度実行してください。
KFPA11561-E
Specified authorization identifier aa....aa has no connect privilege　　（Ａ）
指定した認可識別子aa....aaにはCONNECT権限がありません。
ディレクトリサーバ連携機能を使用している場合，ディレクトリサーバにユーザが登録されていません。表のアクセス時にこのメッセージが出力された場合は，ユーザがHiRDBに接続した時点から今までの間にディレクトリサーバのユーザ情報が削除されました。
aa....aa：CONNECT権限がない認可識別子
(Ｓ)このSQL文を無視します。
ただし，ユティリティを実行している場合，処理を終了します。
[対策]
ユーザ権限管理者（DBA権限保持者）にCONNECT権限を与えてもらい，再度実行してください。
「-u 認可識別子」という指定のあるユティリティを実行する場合は，次の点も確認してください。
・-uを省略していて，かつ環境変数PDUSERも省略している場合は，ログインした時のユーザIDが認可識別子として仮定されます。このユーザIDの値に問題はないか確認してください。
・ユティリティ及びコマンドのオプションを指定するときに，認可識別子やパスワードを小文字で指定する場合，引用符（“）で囲んでください。この場合，シェルなどの解釈によってユティリティが指定値を受け取る前に引用符が削除されないように，「\」や「’」を付ける必要があります。
例：pddbst -u \"hitachi\" -p \"hitachi\"
pddbst -u '"hitachi\"' -p '"hitachi'"
ディレクトリサーバ連携機能を使用している場合は，ディレクトリサーバのシステム管理者にユーザ登録をしてもらってください。
KFPA11562-E
Unable to bb....bb connect privilege due to aa....aa　　（Ａ）
aa....aaがあるため，CONNECT権限を削除できません。
ディレクトリサーバ連携機能を使用している場合はCONNECT権限を与えられません。
aa....aa：
DBA privilege：DBA権限
schema：スキーマ
using directory server：ディレクトリサーバ連携機能
bb....bb：revoke又はgrant
(Ｓ)このSQL文を無視します。
[対策]次に示すどちらかの処置をしてください。
・bb....bbがrevokeの場合
DBA権限又はスキーマを削除して，再度実行してください。
・bb....bbがgrantの場合
ディレクトリサーバにユーザを登録してください。
KFPA11563-E
Unable to execute SQL before CONNECT　　（Ａ）
CONNECT文を実行する前にほかのSQL文を実行しました。
(Ｓ)処理を終了します。
(Ｐ)プログラムを見直してください。SQL文の発行順序に誤りがないか確認し，修正後，再度実行してください。
KFPA11564-E
Invalid authorization identifier aa....aa　　（Ａ）
認可識別子aa....aaに構文上の誤りがあります。又は，認可識別子の長さが8文字を超えています。
なお，指定した認可識別子に非表示文字が含まれる場合，認可識別子aa....aaが正しく表示されないことがあります。
aa....aa：構文上の誤りがある認可識別子，又は長さが8文字を超えている認可識別子
(Ｓ)このSQL文を無視します。
(Ｐ)認可識別子を修正して，再度実行してください。
Windows NTの場合，「-u 認可識別子」という指定のあるユティリティを実行する場合は，次の点も確認してください。
・-uを省略していて，かつユティリティを実行しているプロンプト上で環境変数PDUSERも省略している場合は，Windows NTにログインした時のユーザIDが認可識別子として仮定されます。このユーザIDの値に問題はないか確認してください。
KFPA11565-E
aa....aa bbbb call parameter cc....cc　　（Ａ）
aa....aaがInvalidの場合：
オペレーションコードbbbbで要求された処理に必要なcc....ccが正しく設定されていません。
aa....aaがUnexpectedの場合：
パラメタcc....ccが指す領域に，要求されたデータを返せません。
前処理コール時に要求しなければDESCRIBEコールで要求できません。また，前処理がDESCRIBEコールで既に返した場合でも返せません。
aa....aa：前処理の種別{Invalid | Unexpected}
bbbb：オペレーションコード（4文字以内）
出力されるオペレーションコードを次に示します。
{SET | DESC | AUXI | AUI2 | OPN2 | FETC}
cc....cc：SQL記述領域のフィールド名
(Ｓ)この要求を無視します。
(Ｐ)
〈aa....aaがInvalidの場合〉
次の対策をした後，再度UAPを実行してください。
・cc....ccがSQLIASDA又はsqliasdaの場合
オペレーションコード(bbbb)の値に従って，次の対策をしてください。
オペレーションコード(bbbb)
対策
FETC，又はRSFT
検索結果を受け取るために必要な情報を設定した，SQL記述領域名を指定します。
DESC，DEST，HVAR，又はRSDC
情報を受け取るSQL記述領域名を指定します。
OPEN，OPNR，AUX，AUXI，又はAUXO
入力?パラメタの情報を設定した，SQL記述領域名を指定します。
・cc....ccがSQLIASDA2の場合
出力?パラメタ，又は検索結果を受け取るために必要な情報を設定した，SQL記述領域名を指定してください。
〈aa....aaがUnexpectedの場合〉
データが必要な場合，前処理コールで要求するように変更してください。取得済みの場合，SQL記述領域cc....ccに0を設定し，再度UAPを実行してください。
KFPA11569-E
Directory server error occurred on aa....aa, func=bb....bb errno=cc....cc, dd....dd　　（Ａ）
aa....aa処理中にディレクトリサーバ連携機能で使用するACLib API又はHiRDB LDAP Option APIからエラーが返されました。
aa....aa：エラーが発生したときの処理名
bb....bb：エラーが発生したときのAPI名
日立ディレクトリサーバ連携機能の場合：HdrAclxxxxxx
Sun Java System Directory Server連携機能の場合：xxxxxxxxxxxx
cc....cc：詳細エラーコード
・日立ディレクトリサーバ連携機能の場合
16：予期せぬエラー
17：ACLibの動作環境が不正
18：データ不正
19：日立ディレクトリサーバにユーザ名が重複登録されている
20：日立ディレクトリサーバに登録したグループのルールIDが重複している
32：ACLib APIによるメモリ確保に失敗した
33：APIコール時のパラメタ不正
37：LDAP APIでエラーが発生した
38：日立ディレクトリサーバが起動していない
39：LDAP操作で無通信タイムアウトが発生した
43：グループIDに対応するルールがない
・Sun Java System Directory Server連携機能の場合
10：ユーザが登録されていない
11：Sun Java System Directory Serverにユーザ名が重複登録されている
20：ロール名が登録されていない
21：Sun Java System Directory Serverにロール名が重複登録されている
30：指定したユーザは指定したロールに属さない
40：HiRDB LDAP Option環境定義ファイルがない
41：HiRDB LDAP Option環境定義ファイルのアクセス権がない
42：HiRDB LDAP Option環境定義ファイルのオープン又はクローズに失敗した（詳細はKFPD00027-Eメッセージを参照）
43：HiRDB LDAP Option環境定義ファイルの読み込みエラーが発生した（詳細はKFPD00027-Eメッセージを参照）
44：HiRDB LDAP Option環境定義で指定が必要なオペランドの指定がない
50：指定したパスにRuntimeのライブラリがない
51：Runtimeのライブラリのローディング中にエラーが発生した（詳細はKFPD00027-Eメッセージを参照）
60：メモリ不足
90：HiRDB LDAP Option環境定義のNETWORKTIMELIMITオペランドの値（最大待ち時間）を超えた
92：予期せぬエラー
99：そのほかのエラー（詳細はKFPD00027-Eメッセージを参照）
dd....dd：グループID又はロール名
・bb....bbがHdrAclIsMatchRuleByIDの場合はエラーとなったグループIDを出力します。
groupid＝グループID
・bb....bbがp_f_dic_ismatchrulebyidの場合はエラーとなったロール名を出力します。
roleid＝ロール名
・これら以外の場合は出力しません。
(Ｓ)このSQL文を無視します。
(Ｐ)詳細エラーコードに対応する次に示す処置をしてください。
・日立ディレクトリサーバ連携機能の場合
詳細エラーコードが33：
日立ディレクトリサーバのユーザエントリにパスワード属性が設定されているか確認してください。
詳細エラーコードが43：
HiRDBに登録しているグループID，又はスカラ関数IS_USER_CONTAINED_IN_HDS_GROUPに指定したグループIDに誤りがないか確認してください。
上記以外の場合：
システム管理者に処置を依頼して，対策後に再度実行してください。
・Sun Java System Directory Server連携機能の場合
この場合は，KFPD00027-Eメッセージを参照してください。
[対策]次に示す対策をしてください。
・日立ディレクトリサーバ連携機能の場合
ACLibのマニュアルを参照して，詳細エラーコードに対応する処置をしてください。ただし，詳細エラーコードが37の場合は，KFPD00025-Eメッセージを参照して原因を取り除いてください。
・Sun Java System Directory Server連携機能の場合
API名称がldp_xxxxxxの場合はSun Java System Directory Serverのドキュメントを参照して，詳細エラーコードに対応する対策をしてください。
詳細エラーコードが42，43，51，60，99の場合はKFPD00027-Eメッセージの対策に従ってください。
詳細エラーコードが92の場合は保守員に連絡してください。
KFPA11570-E
More than 1600 authorization identifiers in "aa....aa" statement　　（Ａ）
GRANT文（権限定義），又はREVOKE文（権限削除）の中で指定した認可識別子の数が1600個を超えています。GRANT文，又はREVOKE文に指定できる認可識別子の数は1600個までです。
aa....aa：誤りがあるSQL文{GRANT | REVOKE}
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11571-E
Password not specified for aa....aa　　（Ａ）
DBA権限が与えられる認可識別子にパスワードが指定されていません。又はDBA権限が与えられている認可識別子のパスワードをパスワードなしに変更しようとしています。
aa....aa：パスワードが指定されていない認可識別子，又はパスワードなしに変更しようとしている認可識別子
(Ｓ)このSQL文を無視します。
(Ｐ)パスワードを指定し，再度実行してください。
KFPA11572-E
Duplicate access privilege "aaaaaa" in "bb....bb" statement　　（Ａ）
GRANT文又はREVOKE文の中で指定したアクセス権限が重複しています。
aaaaaa：重複しているアクセス権限
{SELECT | UPDATE | INSERT | DELETE}
bb....bb：実行しようとしたSQL文{GRANT | REVOKE}
(Ｓ)このSQL文を無視します。
(Ｐ)重複しているアクセス権限を削除し，再度実行してください。
KFPA11573-E
Privilege error　　（Ａ）
次に示す理由で，ほかのユーザに対してスキーマの作成，スキーマの削除，又は手続きの再作成はできません。
・実行ユーザがDBA権限を持っていません。
・スキーマを作成するユーザがDBA権限又はCONNECT権限を持っていません。
・DBA権限保持者のパスワードがHiRDBに登録されていません。
(Ｓ)このSQL文を無視します。
[対策]次に示すどれかの処置をしてください。
・DBA権限を持つユーザにDBA権限を与えてもらい，再度実行してください。
・スキーマを作成するユーザにDBA権限又はCONNECT権限を与え，再度実行してください。
・DBA権限保持者のパスワードをHiRDBに登録してください。
KFPA11574-E
Duplicate RDAREA "aa....aa"　　（Ａ）
次のどれかの誤りがあります。
・CREATE TABLEの主キー定義，クラスタキー定義，表格納用RDエリア，LOB列格納用RDエリア，又はLOB属性格納用RDエリアで，同じRDエリア名を複数回指定しています。
・CREATE INDEXで同じRDエリア名を複数回指定しています。
・ALTER TABLEで，既にこの表が格納されているRDエリアを追加しようとしています。
・ALTER TABLE ADD RDAREAで，既にこの表を定義しているインデクス，主キー，又はクラスタキーを格納しているRDエリアを追加しようとしています。
aa....aa：重複しているRDエリア名
(Ｓ)このSQL文を無視します。
(Ｐ)重複したRDエリア名を削除，又は修正して，再度実行してください。
また，ALTER　TABLEの場合，ほかのRDエリア名を指定して，再度実行してください。
KFPA11576-E
Unable to revoke RDAREA use privilege for "aa....aa" due to bbbbb cc....cc."dd....dd"　　（Ａ）
指定したRDエリアには表又はインデクスがあるので，RDエリア利用権限は削除できません。
aa....aa：RDエリア名
bbbbb：処理対象{table | index}
cc....cc：RDエリアにある表又はインデクスの認可識別子
dd....dd：RDエリアにある表識別子又はインデクス識別子
(Ｓ)このSQL文を無視します。
[対策]RDエリアにある表又はインデクスを削除し，再度実行してください。
KFPA11577-E
Unable to revoke schema privilege due to table/routine existence　　（Ａ）
スキーマ内に表又はルーチンが定義されています。このため，スキーマ定義権限を削除できません。
(Ｓ)このSQL文を無視します。
(Ｐ)表，ルーチン又はスキーマを削除し，再度実行してください。
KFPA11578-E
Unable to have two attributes(public,private) for RDAREA "aa....aa"　　（Ａ）
GRANT RDAREAによって，一つのRDエリアが公用・私用の両方の属性を持つように変更しようとしています。
aa....aa：エラーとなったRDエリア名
(Ｓ)このSQL文を無視します。
[対策]公用RDエリアを私用RDエリアにするには，REVOKE RDAREA RDエリア名 FROM PUBLICを実行してから，再度実行してください。
また，私用RDエリアを公用RDエリアにするには，REVOKE RDAREA RDエリア名 FROM 認可識別子を実行してから，再度実行してください。
KFPA11579-E
Unable to create aa....aa without schema privilege　　（Ａ）
スキーマ定義権限がないため，スキーマ又は表別名を定義できません。
aa....aa：誤りがあるSQL文{ schema | alias }
(Ｓ)このSQL文を無視します。
(Ｐ)DBA権限を持つユーザにスキーマ定義権限を与えてもらい，再度実行してください。
KFPA11580-E
Unable to drop aa....aa."bb....bb"　　（Ａ）
ルーチンaa....aa."bb....bb"はcreate type文中で定義されているため，単独での削除はできません。
aa....aa：認可識別子
bb....bb：ルーチン識別子
(Ｓ)このSQL文を無視します。
(Ｐ)ルーチンの指定に誤りがある場合には，それを修正し，再度実行してください。又は，指定ルーチンを含む抽象データ型定義を削除するSQLを実行してください。
KFPA11583-E
Specified ROUTINE aa....aa."bb....bb" not available for index　　（Ａ）
ルーチンaa....aa."bb....bb"にプラグインインデクスを適用できません。プラグインインデクスが適用できる関数は，プラグインで実装されているプラグイン関数で，プラグインIDLのオペレーション修飾子にSCAN TYPEが指定されている必要があります。
aa....aa：認可識別子
bb....bb：ルーチン識別子
(Ｓ)このSQL文を無視します。
(Ｐ)適用関数（FOR句）の指定を修正し，再度インデクス定義文を実行してください。
KFPA11584-E
aa....aa "bb....bb" not available for index　　（Ａ）
インデクス対象に指定したaa....aa "bb....bb"はインデクス型に合いません。
aa....aa：対象項目の種別｛COLUMN｝
bb....bb：列名，又は属性名
(Ｓ)このSQL文を無視します。
(Ｐ)対象列の指定を変更するか，又は利用するインデクス型の指定を変更して，両者が正しく対応するようにSQL文を修正した後，再度実行してください。
KFPA11585-E
More than 16 RDAREAs in "aa....aa" RDAREA statement　　（Ａ）
GRANT RDAREA文，又はREVOKE RDAREA文中に指定したRDエリア名の数が16個を超えています。
GRANT RDAREA文，又はREVOKE RDAREA文中に指定できるRDエリア名の数は最大16個です。
aa....aa：誤りがあるSQL文{GRANT | REVOKE}
(Ｓ)このSQL文を無視します。
[対策]SQL文を修正し，再度実行してください。
KFPA11590-E
Number of specified authorization identifiers not equal to number of password in "GRANT" statement　　（Ａ）
GRANT文の中で指定した認可識別子の数とパスワードの数が一致しません。
(Ｓ)このSQL文を無視します。
[対策]SQL文を修正し，再度実行してください。
KFPA11591-E
Unable to specify "NULL" for "FIX" table　　（Ａ）
FIX指定された表の列定義では，NULLは指定できません。
(Ｓ)このSQL文を無視します。
[対策]FIX指定，又は列定義のNULL指定のどちらかを削除し，再度実行してください。
KFPA11592-E
Unable to specify "NULL" for cluster key column or primary key column　　（Ａ）
単一列，又は複数列一意性制約定義を指定された列の列定義では，NULLは指定できません。
(Ｓ)このSQL文を無視します。
[対策]単一列，又は複数列一意性制約定義からNULLを指定した列を削除するか，又は列定義のNULL指定のどちらかを削除し，再度実行してください。
KFPA11595-E
Duplicate parameter name "aa....aa"　　（Ａ）
CREATE PROCEDURE，CREATE FUNCTION，CREATE TYPE，ALTER TYPE中に指定したパラメタ名が重複しています。
aa....aa：エラーになったパラメタ名
(Ｓ)このトランザクションを無効にします。
(Ｐ)パラメタ名を変更してから，再度実行してください。
KFPA11596-E
No RDAREA for routine definition　　（Ａ）
データディクショナリLOB用RDエリアが定義されていません。このため，次に示すSQLを実行できません。
・ALTER PROCEDURE
・ALTER ROUTINE
・ALTER TRIGGER
・ALTER TYPE
・CALL文
・CREATE FUNCTION
・CREATE PROCEDURE
・CREATE TRIGGER
・CREATE TYPE
・DROP FUNCTION
・DROP PROCEDURE
・関数呼出し
(Ｓ)このSQL文を無視します。
(Ｐ)データベース初期設定ユティリティ（pdinit）又はデータベース構成変更ユティリティ（pdmod）で，データディクショナリLOB用RDエリアを割り当ててから，再度SQLを実行してください。
KFPA11597-E
Unable to alter table for "aa....aa" column　　（Ａ）
ALTER TABLEでは，データ型に"aa....aa"を指定した列の追加，削除，変更はできません。
aa....aa：
・BLOB
・abstract data（抽象データ型）
(Ｓ)このSQL文を無視します。
(Ｐ)該当する表の定義内容を変更する場合，DROP TABLEで表を削除した後，CREATE TABLEで作成してください。
KFPA11599-E
Specified RDAREA not for "LOB"　　（Ａ）
指定したRDエリアは，ユーザLOB用RDエリアではありません。
(Ｓ)このSQL文を無視します。
(Ｐ)ユーザLOB用RDエリアを指定して，再度実行してください。
KFPA11600-E
Routine aa....aa."bb....bb" already specified for another index　　（Ａ）
ルーチンaa....aa."bb....bb"には，既にほかのプラグインインデクスが適用されています。
aa....aa：認可識別子
bb....bb：ルーチン識別子
(Ｓ)このSQL文を無視します。
(Ｐ)適用関数の指定を変更するか，又は目的とする関数を指定して定義されているインデクスを削除した後，再度実行してください。
KFPA11601-E
Duplicate aa....aa bb....bb."cc....cc"　　（Ａ）
次に示すSQL文で指定した表識別子，インデクス識別子，ルーチン識別子，トリガ識別子，制約名，データ型識別子，インデクス型識別子，又は表別名は，既に定義されています。
・ALTER INDEX TYPE
・ALTER TABLE
・ALTER TYPE
・CREATE ALIAS
・CREATE FOREIGN INDEX
・CREATE FOREIGN TABLE
・CREATE FUNCTION
・CREATE INDEX
・CREATE INDEX TYPE
・CREATE PROCEDURE
・CREATE TABLE
・CREATE TRIGGER
・CREATE TYPE
・CREATE VIEW
aa....aa：実行しようとしたSQL文
｛alias｜constraint｜datatype｜index｜indextype｜routine｜table｜trigger｝
bb....bb：認可識別子
cc....cc：表識別子，インデクス識別子，ルーチン識別子，表別名，トリガ識別子，制約名，データ型識別子，インデクス型識別子
(Ｓ)このSQL文を無視します。
(Ｐ)表識別子，インデクス識別子，ルーチン識別子，表別名，トリガ識別子，制約名，データ型識別子，又はインデクス型識別子を変更して，再度実行してください。
KFPA11602-E
Over 30000 columns in table　　（Ａ）
一つの表の列の合計数が指定できる列数の最大値（30000）を超えました。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文に誤りがあれば修正し，再度実行してください。また，表を設計し直して30000列以下にしてください。
KFPA11603-E
Duplicate key value detected in unique index while creating index　　（Ａ）
UNIQUE指定のインデクスを作成しようとしましたが，表中のデータに重複した列値があります。
(Ｓ)このトランザクションを無効にします。
(Ｐ)重複している表の列値を修正して，UNIQUE指定のインデクスを再度作成してください。
又は，UNIQUE指定を削除できる場合，UNIQUE指定を削除してインデクスを一括作成してください。
KFPA11604-E
Invalid length, precision or scale in aa....aa "bb....bb" cc....cc　　（Ａ）
次に示す箇所に指定したデータ型の長さ，精度，又は位取りに誤りがあります。
・列，SQLパラメタ，SQL変数，又は属性定義中
・DROP FUNCTION中の関数指定中
・CREATE FUNCTION中のRETURNS句
・関数呼出しの引数のAS句
・CAST指定のAS句
・CURRENT_TIMESTAMP
・?パラメタ，又は埋込み変数に対して指定したAS句
aa....aa：次に示します。
bb....bb：次に示します。
cc....cc：次に示します。
(Ｓ)このSQL文を無視します。
(Ｐ)指定した長さ，精度，又は位取りの値を修正し，再度実行してください。
・不正なデータ型指定箇所とaa....aa，bb....bb，cc....ccの対応を次に示します。
データ型指定箇所
aa....aa
bb....bb
cc....cc
列定義
definition of column
列名
－
SQLパラメタ宣言
declaration of SQL parameter
SQLパラメタ名
－
SQL変数宣言
declaration of SQL variable
SQL変数名
－
属性定義
definition of attribute
属性名
－
DROP FUNCTION関数指定中
function specification
関数名
（引数番号th argument）
関数本体のRETURNS句
RETURNS clause in function definition
関数名
－
関数呼出しの引数のAS句
function invocation
関数名
（引数番号th argument）
CAST指定のAS句
AS clause in CAST specification
********
－
CURRENT_TIMESTAMP
CURRENT_TIMESTAMP
********
－
?パラメタ，又は埋込み変数に対して指定したAS句
AS clause for ? parameter or embedded variable
********
－
（凡例）－：該当しません。
KFPA11605-E
Unable to specify "SUPPRESS" for "FIX" table　　（Ａ）
FIX属性の表に対して，"SUPPRESS"は指定できません。
(Ｓ)このSQL文を無視します。
(Ｐ)"SUPPRESS"の指定，又は"FIX"の指定を削除して，再度実行してください。
KFPA11606-E
Unable to specify ALIAS for table in local RDNODE　　（Ａ）
自RDノード内の表名，又はビュー名に対する表別名は定義できません。
(Ｓ)このSQL文を無視します。
(Ｐ)RDノード名を変更した後，再度実行してください。
KFPA11607-E
Unable to use definition SQL on other user's aa....aa　　（Ａ）
次に示す処理は，実行できません。
・ほかのユーザを所有者とする実表，ビュー表，外部表，インデクス，及び外部インデクスの作成
・ほかのユーザを所有者とする実表，ビュー表，及びインデクスの削除
・ほかのユーザを所有者とする実表の表定義変更
・ほかのユーザを所有者とする実表，ビュー表，及び外部表への注釈の追加
・ほかのユーザを所有者とする手続きの作成，又は削除
・ほかのユーザを所有者とする外部サーバ上への外部表の作成
・ほかのユーザを所有者とする関数の作成，又は削除
・ほかのユーザを所有者とするデータ型の作成，又は削除
・ほかのユーザを所有者とするインデクス型の作成，又は削除
・ほかのユーザを所有者とするデータ型の変更
・ほかのユーザを所有者とするインデクス型の変更
・ほかのユーザを所有者とするトリガの定義，又は削除
Windows NTの場合，定義系SQL文の中で，表に指定した認可識別子が，connectしたときの認可識別子と異なっている場合にも出力されます。また，データベース定義ユティリティ(pddef)のように，connect時に認可識別子を指定しない場合，クライアント環境定義(hirdb.ini)のPDUSERの指定値を確認する必要があります。PDUSERの指定値は，全体を「'」で囲む必要があります。
（例）PDUSER='"root"/"root"'
aa....aa：｛table｜index｜procedure｜foreign server｜trigger｜function｜datatype｜indextype｝
なお，HiRDB Object Optionが組み込まれていないシステムでは，aa....aaには常にtable，index，又はprocedureが設定されます。
(Ｓ)このSQL文を無視します。
(Ｐ)このSQL文を削除してください。
KFPA11608-E
Unable to create table/index without privilege for specified RDAREA "aa....aa"　　（Ａ）
指定したRDエリアに対する利用者権限がありません。このため表又はインデクスを作成できません。
aa....aa：RDエリア名
(Ｓ)このSQL文を無視します。
(Ｐ)利用者権限があるRDエリアを指定するか，該当するRDエリアに対して利用者権限を与えてもらい，再度実行してください。
KFPA11609-E
Unable to define aa....aa column in "FIX" table　　（Ａ）
FIX属性の表に対して，aa....aaの列は定義できません。
aa....aa：
variable length：可変長
user data type：ユーザ定義型
multi-value：繰返し列
(Ｓ)このSQL文を無視します。
(Ｐ)CREATE TABLEの場合，可変長列，ユーザ定義型列，及び繰返し列の指定を変更するか，又は，FIX属性の指定を削除して，再度実行してください。ALTER TABLEの場合，可変長列，ユーザ定義型列，及び繰返し列を指定しないで，再度実行してください。
KFPA11610-E
No more available public user RDAREA　　（Ａ）
使用できる公用RDエリアがありません。又は，公用RDエリアがあっても，次の理由で使用できないため，表が定義できません。なお，HiRDB/パラレルサーバで非共用表を定義する場合は非共用RDエリア，共用表を定義する場合は共用RDエリアが必要です。HiRDB/シングルサーバで非共用表又は共用表を定義する場合は非共用RDエリアが必要です。
・RDエリア当たりの表定義数が，定義できる最大数（500）に達しています。
・主キー又はクラスタキーを指定している場合，RDエリア当たりのインデクス定義数が定義できる最大数（500）に達しています。
・表がFIX属性の場合，行長に対してページ長が不足しています。
・RDエリアが閉塞しています。
・リバランス機能を使用している表を定義しています（非公用表を定義する場合にだけ該当します）。
・RDエリアにインナレプリカ機能を適用しています。
・クラスタキー又は主キーを指定している場合，RDエリアのページ長に対するインデクスのキー長が最大長を超えています。計算式を次に示します。
キー長≦MIN（（インデクス格納用RDエリアのページ長÷2）－1242，4036）
キー長の計算式については，マニュアル「HiRDB Version 7 SQLリファレンス」のCREATE INDEXを参照してください。
(Ｓ)このSQL文を無視します。
(Ｐ)使用できる公用RDエリアを定義し，再度実行してください。又は，使用できる私用RDエリアを指定し，再度実行してください。使用できるRDエリアとは，前記の使用できないRDエリアの条件に合致しないRDエリアのことです。
KFPA11611-E
Unable to aa....aa bb....bb　　（Ａ）
ハッシュ分割表でないため，ハッシュ関数名の変更又はRDエリアの追加はできません。
aa....aa：実行しようとした処理{ change | add }
bb....bb：操作対象{ HASH | RDAREA }
(Ｓ)このSQL文を無視します。
(Ｐ)このSQL文を削除してください。
KFPA11612-E
Duplicate column name "aa....aa"　　（Ａ）
一つの表の中に，同じ列名の列は定義できません。
aa....aa：エラーとなった列名
(Ｓ)このSQL文を無視します。
(Ｐ)列名が重複しないようにSQL文を修正し，再度実行してください。
KFPA11613-E
Unable to aa....aa for not empty table　　（Ａ）
データが格納されている表に対して，aa....aaに示す操作はできません。
aa....aa：誤った指定
add column：NOT NULL指定，若しくはDEFAULT句指定のある列の追加，又はFIX表に対する列の追加
add rdarea：リバランス機能を使用していないFIXハッシュ分割表に対するRDエリアの追加
change no split又はchange split：ノースプリットオプションの変更
change set default：既定値の設定，又は変更
change drop default：既定値の削除
change cluster key：クラスタキーの属性変更
change hash：FIXハッシュ分割表に対するハッシュ関数の変更
drop column：列の削除
change insert only：非改竄防止表を改竄防止表へ変更
(Ｓ)そのSQL文を無視します。
(Ｐ)データが格納されていない表に対して再度実行してください。又は，PURGE TABLE文で表中のすべてのデータを削除して，再度実行してください。なお，PURGE TABLE文を実行するときは，障害に備えあらかじめバックアップを取得してください。
KFPA11614-E
Unable to bb....bb on column "aa....aa"　　（Ａ）
bb....bbがcreate index，又はdefine foreign keyの場合：
次に示すデータ型の列は，インデクス，主キー，クラスタキー，又は外部キーを構成する列に指定できません。
・20けた以上のDECIMAL
・BLOB
・ユーザ定義型
・BINARY
bb....bbがcreate foreign indexの場合：
BINARY型の列は，外部インデクスを構成する列には指定できません。
aa....aa：エラーとなったデータ型の列名
bb....bb：｛create index｜define foreign key｜create foreign index｝
(Ｓ)このSQL文を無視します。
(Ｐ)このSQL文を削除してください。
KFPA11615-E
Unable to create multi column index on column "aa....aa"　　（Ａ）
次に示すデータ型の列は，複数列インデクス，複数列主キー，又は複数列クラスタキーに指定できません。
・FLOAT
・
・SMALLFLT
・
aa....aa：エラーとなったデータ型の列名
(Ｓ)このSQL文を無視します。
(Ｐ)このSQL文を削除してください。
KFPA11616-E
Index key length is too long　　（Ａ）
インデクスのキー長が，最大長を超えています。キー長の計算式を次に示します。
キー長≦MIN（（インデクス格納用RDエリアのページ長÷2）－1242，4036）
キー長の計算式については，マニュアル「HiRDB Version 7 SQLリファレンス」のCREATE INDEXを参照してください。
(Ｓ)このSQL文を無視します。
(Ｐ)単一列インデクスの場合は，このSQL文を実行できないので削除してください。
複数列インデクスの場合は，キー長を最大長以下に修正し，再度実行してください。
KFPA11617-E
More than 16 columns specified for index　　（Ａ）
CREATE INDEX，CREATE FOREIGN INDEXの列の数，又は除外キー値を構成する値の数が，指定できる最大数16を超えています。
(Ｓ)このSQL文を無視します。
(Ｐ)インデクスを構成する列の数，又は除外キー値を構成する値の数を16個以下に修正し，再度実行してください。
KFPA11619-E
Duplicate column name "aa....aa" in constructed index columns　　（Ａ）
CREATE INDEX又はCREATE FOREIGN INDEXで指定した列名，主キーを構成する列名，又はクラスタキーを構成する列名が重複しています。
aa....aa：重複している列名
(Ｓ)このSQL文を無視します。
(Ｐ)インデクスを構成する列名が重複しないようにSQL文を修正し，再度実行してください。
KFPA11620-E
Unable to specify "aa....aa" for flexible HASH partitioning table　　（Ａ）
フレキシブルハッシュ分割表，又はフレキシブルハッシュ分割を使用しているマトリクス分割表に対して，"UNIQUE"又は"PRIMARY KEY"は指定できません。
aa....aa：
UNIQUE：ユニーク
PRIMARY KEY：主キー
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度ジョブを実行してください。
KFPA11621-E
Unable to define unique index for multi-value column "aa....aa"　　（Ａ）
繰返し列"aa....aa"に対して，UNIQUE指定のインデクスは定義できません。
aa....aa：繰返し列の列名
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正するか，又はこのSQL文を削除して，再度実行してください。
KFPA11622-E
Invalid HASH function "aa....aa"　　（Ａ）
ハッシュ関数名に次の誤りがあります。
・指定したハッシュ関数名はありません。
・指定したハッシュ関数のキー長よりも，ハッシュ分割キーの列長が短いです。
ハッシュ関数とそれぞれのキー長を次に示します。
・HASH3：2バイト以上
・HASH4：4バイト以上
・HASH5：3バイト以上
・HASHC：2バイト以上
・HASHD：4バイト以上
・HASHE：3バイト以上
・リバランス機能を使用しない表のハッシュ関数をHASHA，HASHB，HASHC，HASHD，HASHE又はHASHFに変更することはできません。
・リバランス機能を使用する表のハッシュ関数をHASH1，HASH2，HASH3，HASH4，HASH5又はHASH6に変更することはできません。
・クラスタキー又は主キーを定義する表のハッシュ関数にHASHA，HASHB，HASHC，HASHD，HASHE又はHASHFは指定できません。
・HASHA，HASHB，HASHC，HASHD，HASHE又はHASHFをハッシュ関数に指定した表に対して，SEGMENT REUSEオプションは指定（SEGMENT REUSE NO指定は除く）できません。
aa....aa：ハッシュ関数名
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度ジョブを実行してください。
KFPA11624-E
aa....aa bb....bb "cc....cc" not found in system　　（Ａ）
表別名bb....bb "cc....cc"がHiRDBにありません。又は，外部サーバ"cc....cc"がHiRDBにありません。
aa....aa：｛ALIAS｜FOREIGN SERVER｝
bb....bb：認可識別子（aa....aaがFOREIGN SERVERの場合は表示されません）
cc....cc：｛表別名｜外部サーバ名｝
(Ｓ)このSQL文を無視します。
(Ｐ)指定した表別名又は外部サーバ名に誤りがないか確認し，誤りがあれば修正して再度実行してください。誤りがなければ，このSQL文を削除してください。
KFPA11625-E
Unable to define "aa....aa" on multi-value column　　（Ａ）
繰返し列に対して，aa....aaの表制約定義は指定できません。
aa....aa：
CLUSTER KEY：クラスタキー
PRIMARY KEY：主キー
FOREIGN KEY：外部キー
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11628-E
Unable to define "NOT NULL" constraint for multi-value column　　（Ａ）
表定義時，又は表定義変更時には，繰返し列に対して"NOT NULL"（非ナル値制約）は指定できません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11631-E
Unable to aaaaaa "bb....bb" column　　（Ａ）
"bb....bb"がabstract data以外の場合は，"bb....bb"に対して，aaaaaaは処理できません。
"bb....bb"がabstract dataの場合は，"bb....bb"を含む表に対して，aaaaaaは処理できません。
aaaaaa：実行できない処理
{ change | drop }
bb....bb：列の種別
CLUSTER KEY：クラスタキーを構成する列
FOREIGN KEY：外部キーを構成する列
PRIMARY KEY：主キーを構成する列
PARTITION KEY：分割キーを構成する列
REFERENCED PRIMARY KEY：被参照表の主キーを構成する列
TRIGGER：トリガ定義中，新旧値相関名で修飾され，参照されている列
CHECK：検査制約定義
abstract data：抽象データ型
(Ｓ)このSQL文を無視します。
(Ｐ)このSQL文を削除してください。
KFPA11632-E
Unable to drop column from single column table　　（Ａ）
削除する列は，表中に1列しかありません。このため，列を削除できません。
(Ｓ)このSQL文を無視します。
(Ｐ)ALTER TABLEではなく，DROP TABLE文を実行してください。
KFPA11633-E
Column for divided key must be "NOT NULL"　　（Ａ）
格納条件列，境界値分割列，又はハッシュ分割キー列が，NOT NULL属性ではありません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11634-E
More than aaaa partitions or bbbb RDAREA specifications in storage for cc....cc　　（Ａ）
cc....ccの分割数がaaaaを超えています。又は，cc....ccの格納用RDエリア名の指定がbbbbを超えています。
aaaa：｛1｜1024｝
bbbb：｛1｜3000｝
cc....cc：格納処理の種別
｛TABLE｜COLUMN｜CLUSTER KEY｜PRIMARY KEY｜INDEX｝
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。aaaa及びbbbbの値が1の場合は，HiRDB/Workgroup Serverの機能制限（表の横分割機能）によって発生するため，表の横分割をしないようにSQL文を修正し，再度実行してください。
KFPA11636-E
More than 1024 constants in partitioning condition　　（Ａ）
表の分割条件に指定した定数の総数が，1024を超えています。
(Ｓ)このSQL文を無視します。
(Ｐ)格納条件中の定数指定が1024以下になるように，SQL文を修正し再度実行してください。
KFPA11637-E
More than 30000 SQL parameters defined in aa....aa definition　　（Ａ）
aa....aa定義中のSQLパラメタの定義数が30000を超えています。
aa....aa：{ FUNCTION | PROCEDURE}
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11638-E
Unable to specify self-join for view or "WITH" query which derives internal table　　（Ａ）
内部導出表を作成する問合せ指定で，同じ表同士の結合を指定しています。
内部導出表を作成する条件は次のとおりです。
1. SELECT DISTINCTを指定して導出した，名前付きの導出表に対する問合せで，名前付きの導出表が副問合せ中に含まれるか，又は次のどれかを直接含む。
・GROUP BY句，HAVING句，又は集合関数
・SELECT DISTINCT
・表の結合（外結合，内結合を含む）
・選択式に列指定以外の値式を指定
・選択式に，FROM句で指定した名前付きの導出表の全列を一回ずつ指定していない
2. GROUP BY句，HAVING句，又は集合関数を指定して導出した，名前付きの導出表に対する問合せに，次のどれかを直接含む。
・GROUP BY句
・HAVING句
・集合関数
・表の結合（外結合，内結合を含む）
3. 選択式として列指定以外の値式を指定して導出した，名前付きの導出表に対する問合せに，次のどれかを直接含む。
・GROUP BY句
・HAVING句
・集合関数
・結合表
4. DISTINCT指定の集合関数を指定して導出した，名前付きの導出表に対する問合せに，SELECT DISTINCTの指定を直接含む。
5. 表の結合（外結合，内結合を含む）を指定して導出した，名前付きの導出表に対する問合せに，表の結合（外結合，内結合を含む）を直接含んで，かつ指定した表の結合のどれかが結合表の指定である。
6. 選択式としてスカラ副問合せを指定して，導出した名前付きの導出表に対する問合せである。
7. 集合演算によって導出した名前付きの導出表に対する問合せで，次のどちらかを満たしている。
・集合演算の演算項のどれかに，内部導出表の問合せ，導出表を指定した問合せ，又は選択式に副問合せを指定した問合せかを含んでいる。
・集合演算の演算項のどれかと，名前付きの導出表に対する問合せが，1.～6.に示したどれかの条件を満たしている。
8. UNION ALL以外を含む集合演算によって導出した，名前付きの導出表に対する問合せで，次のどれかを直接含む。
・GROUP BY句，HAVING句，又は集合関数
・SELECT DISTINCT
・表の結合（外結合，内結合を含む）
・WHERE句
・副問合せ
・選択式に列指定以外の値式
・選択式に，FROM句に指定した名前付きの導出表の列を１回ずつ指定していない
9. UNION ALLだけの集合演算によって導出した，名前付きの導出表に対する問合せで，次のどれかを直接含む。
・GROUP BY句，HAVING句，又は集合関数
・表の結合（外結合，内結合を含む）
・WHERE句，又は副問合せ（ただし，副問合せ，集合演算の演算項，又はINSERT文の問合せだけ）
・関数呼出し又はシステム定義スカラ関数
・コンポネント指定
・WRITE指定
・GET_JAVA_STORED_ROUTINE_SOURCE指定
・選択式にない項目でのソート指定
・集合演算によって導出した名前付きの導出表をFROM句に指定した副問合せ
・導出表を指定した副問合せ
・GROUP BY句に列指定以外の値式を指定した副問合せ
・選択式に指定したSQL変数，及びSQLパラメタのうち，データ型が次のどれかになるもの
BLOB型
32,001バイト以上のBINARY型
抽象データ型
BOOLEAN型
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11639-E
Distinct view specified in "FROM" clause of subquery in view definition, in "WITH" query, or in query with grouping by expression　　（Ａ）
ビュー定義又はWITH句の問合せ中の導出問合せ式，又はGROUP BY句に値式（値式が列指定の場合を除く）を指定した問合せで，副問合せのFROM句に，重複排除を指定して導出した名前付きの導出表を指定しています。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11640-E
Outer reference specified for column derived from "COUNT(*)" in view or "WITH" query　　（Ａ）
次に示す列に対して，外への参照をしています。
・COUNT（*）から定義したビュー表の列
・WITH句中の導出問合せ式の選択式に指定したCOUNT(*)によって導出される列
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11641-E
Unable to specify derived table in joined table　　（Ａ）
次に示す条件で導出した名前付きの導出表は，結合表には指定できません。
・集合演算を指定して導出した名前付きの導出表
また，次に示す条件で定義したビュー表，又はビュー表を構成する基の表が次に示す条件で定義したビュー表は，導出問合せ式中の結合表には指定できません。
・副問合せを指定して定義したビュー表
・表の結合，SELECT DISTINCT，GROUP BY句，又はHAVING句を指定して定義したビュー表
・SELECT句に列指定以外の値式を指定して定義したビュー表。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11642-E
Grouping specified for derived table having derived column in view definition,in "WITH" query, or in query with grouping by expression　　（Ａ）
列指定以外の値式で導出した列を持つ，名前付きの導出表に対して，ビュー定義の問合せ，WITH句の問合せの導出問合せ式中，又はGROUP BY句に値式（値式が列指定の場合を除く）を指定した問合せで，GROUP BY句，HAVING句，集合関数を指定しています。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11643-E
Join specified for group view in view definition, in "WITH" query, or in query with grouping by expression　　（Ａ）
GROUP BY句，HAVING句，又は集合関数を指定した問合せで導出した名前付きの導出表に対して，ビュー定義，WITH句の問合せの導出問合せ式中，又はGROUP BY句に値式（値式が列指定の場合を除く）を指定した問合せで表の結合を指定しています。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11644-E
Grouping specified for group view in view definition, in "WITH" query, or in query with grouping by expression　　（Ａ）
GROUP BY句，HAVING句，又は集合関数を指定した問合せで導出した名前付きの導出表に対して，ビュー定義又はWITH句の問合せの導出問合せ式中か，又はGROUP BY句に値式（値式が列指定である場合を除く）を指定した問合せで，次に示す指定をしています。
・GROUP BY句
・HAVING句
・集合関数
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11645-E
Constant or value expression in "SELECT" clause specified for distinct view in view definition or "WITH" query　　（Ａ）
重複排除（DISTINCT）を指定したビュー表に対して，ビュー定義又はWITH句の問合せの導出問合せ式中のSELECT句に，列指定以外の値式を指定しています。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11646-E
Join specified for distinct view in view definition or "WITH" query　　（Ａ）
重複排除（DISTINCT）を指定したビュー表に対して，ビュー定義又はWITH句の問合せの導出問合せ式に，表の結合を指定して検索しています。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11647-E
Distinct specified for distinct view in view definition, in "WITH" query, or in query with grouping by expression　　（Ａ）
重複排除（DISTINCT）を指定して導出した名前付きの導出表に対して，ビュー定義又はWITH句の問合せの導出問合せ式中，又はGROUP BY句に値式（値式が列指定の場合を除く）を指定した問合せで，重複排除を指定しています。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11648-E
Unable to derive internal table in query or in where subquery with grouping by expression　　（Ａ）
次の問合せには，内部導出表を作成する問合せは指定できません。
・GROUP BY句に列指定以外の値式を指定した問合せ
・GROUP BY句に列指定以外の値式を指定した問合せのWHERE句の副問合せ
内部導出表を作成する条件を次に示します。
1. SELECT DISTINCTを指定して導出した，名前付きの導出表に対する問合せで，名前付きの導出表が副問合せ中に含まれるか，又は次のどれかを直接含む。
・GROUP BY句，HAVING句，又は集合関数
・SELECT DISTINCT
・表の結合（外結合，内結合を含む）
・選択式に列指定以外の値式を指定
・選択式に，FROM句で指定した名前付きの導出表の全列を一回ずつ指定していない
2. GROUP BY句，HAVING句，又は集合関数を指定して導出した，名前付きの導出表に対する問合せに，次のどれかを直接含む。
・GROUP BY句
・HAVING句
・集合関数
・表の結合（外結合，内結合を含む）
3. 選択式として列指定以外の値式を指定して導出した，名前付きの導出表に対する問合せに，次のどれかを直接含む。
・GROUP BY句
・HAVING句
・集合関数
・結合表
4. DISTINCT指定の集合関数を指定して導出した，名前付きの導出表に対する問合せに，SELECT DISTINCTの指定を直接含む。
5. 結合表を指定して導出した，名前付きの導出表に対する問合せに，次のどちらかを直接含む。
・表の結合（外結合，内結合を含む）
・副問合せ
6. 表の結合，又は副問合せを指定して導出した，名前付きの導出表に対する問合せに，結合表の指定を直接含む。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11649-E
Grouping specified for distinct view in view definition, in "WITH" query, or in query with grouping by expression　　（Ａ）
重複排除（DISTINCT）を指定して導出した名前付きの導出表に対して，ビュー定義又はWITH句の問合せの導出問合せ式中，又はGROUP BY句に値式（値式が列指定である場合を除く）を指定した問合せで，次に示すどれかを指定しています。
・GROUP BY句
・HAVING句
・集合関数
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11650-E
Number of view columns or "WITH" query columns not equal to number of select columns　　（Ａ）
SELECT句中の検索項目の数が，次に示す数と一致しません。
・ビュー表を構成する列の数
・WITH句の問合せ名で指定した表の列の数
(Ｓ)このSQL文を無視します。
(Ｐ)ビュー表を構成する列の数，又は問合せ名として導出される表の列の数と，SELECT句中の検索項目の数を一致させて，再度実行してください。
KFPA11651-E
Unable to specify aa....aa in view definition　　（Ａ）
ビュー定義中には，次の指定はできません。
・？パラメタ，埋込み変数
・構造化繰返し述語
aa....aa：｛? parameter or embedded variable｜ARRAY predicate｝
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11652-E
Specified RDAREA "aa....aa" not defined　　（Ａ）
次に示すSQL文で指定したRDエリアがありません。
・ALTER TABLE
・CREATE INDEX
・CREATE TABLE
・GRANT RDAREA
aa....aa：RDエリア名
(Ｓ)このSQL文を無視します。
(Ｐ)定義されているユーザ用RDエリアを指定するか，又は指定したRDエリア名を修正し，再度実行してください。
KFPA11653-E
Specified RDAREA aa....aa bb....bb　　（Ａ）
次のどれかの誤りがあります。
bb....bbがnot for userの場合：
aa....aaがユーザ用ではありません。
bb....bbがreplicated rdareaの場合：
aa....aaがレプリカRDエリアです。
bb....bbがused by inner replica facilityの場合：
インナレプリカ機能を適用しているRDエリアaa....aaは，改竄防止表に適用できません。
これらの理由によって，次のSQL文が実行できません。
・ALTER TABLE
・CREATE INDEX
・CREATE TABLE
・GRANT RDAREA
・DROP INDEX
・DROP TABLE
・DROP SCHEMA
aa....aa：RDエリア名
bb....bb：｛not for user｜replicated rdarea｜used by inner replica facility｝
(Ｓ)このSQL文を無視します。
(Ｐ)
aa....aaがnot for userの場合：
ユーザ用RDエリアを指定して，再度実行してください。
aa....aaがreplicated rdareaの場合：
オリジナルRDエリアを指定して，再度実行してください。
aa....aaがused by inner replica facilityの場合：
インナレプリカ機能を適用していないRDエリアを指定して，再度実行してください。又は，インナレプリカ機能の適用を解除して，再度実行してください。
KFPA11654-E
Number of aa....aa exceeds bbb　　（Ａ）
RDエリア内の表数又はインデクスが，指定できる最大数を超えました。
RDエリア内に指定できる表数又はインデクス数の最大値は500です。
aa....aa：処理対象{ tables | indexes }
bbb：500
(Ｓ)このSQL文を無視します。
(Ｐ)ほかのRDエリアを指定し，再度実行してください。
KFPA11656-E
No schema for aa....aa　　（Ａ）
スキーマがありません。このため，次に示すSQLが実行できません。
・ALTER INDEX TYPE
・ALTER PROCEDURE
・ALTER ROUTINE
・ALTER TRIGGER
・ALTER TYPE
・CREATE FUNCTION
・CREATE PROCEDURE
・CREATE TABLE
・CREATE TRIGGER
・CREATE TYPE
・DROP SCHEMA
aa....aa：スキーマがないユーザの認可識別子
(Ｓ)このSQL文を無視します。
(Ｐ)CREATE FUNCTION，CREATE PROCEDURE，CREATE TABLE，CREATE TRIGGER，又はCREATE TYPEを実行する場合は，CREATE SCHEMAでスキーマを作成した後で実行してください。DROP SCHEMA，ALTER INDEX TYPE，ALTER PROCEDURE，ALTER ROUTINE，ALTER TRIGGER，又はALTER TYPEの場合は，スキーマが定義されていないため，実行する必要がありません。
KFPA11657-E
Too small page size aa....aa for row length bb....bb　　（Ａ）
指定したRDエリアは，ページ長が不足しています。
aa....aa：指定したRDエリアのページ長
bb....bb：行の長さ（単位：バイト）
データが各国文字データの場合，メッセージ中の値は，指定した値の2倍の値が表示されます。
(Ｓ)このSQL文を無視します。
(Ｐ)次に示す計算式を満たす値をRDエリアに指定するか，又は行長を短くして再度実行してください。
〈計算式〉
行長≦↓RDエリアのページ長／1000↓×1000
注：「↓↓」は小数点以下を切り下げてください。
KFPA11658-E
Unable to specify "ALL" as table identifier　　（Ａ）
表識別子にALLは使用できません。
(Ｓ)このSQL文を無視します。
(Ｐ)表識別子を変更して，再度実行してください。
KFPA11659-E
Invalid data type or data length　　（Ａ）
CHANGE句で指定したデータ型，及びデータ長に次のような誤りがあります。
・データ長を短くしようとしています。
・固定長データのデータ長を変更しようとしています。
・変更できないデータ型を変更しようとしています。
(Ｓ)このSQL文を無視します。
(Ｐ)誤りを修正して，再度実行してください。
KFPA11660-E
Unable to aa....aa on the bb....bb　　（Ａ）
表に対しての操作に次のどれかの誤りがあります。
・ビュー表に対してはインデクスの作成，トリガの作成，及び表定義の変更ができません。
・監査証跡表に対しては表定義の変更ができません。
・実表に対しては外部インデクスを作成できません。
・外部表に対してはインデクスの作成，トリガの作成，及び表定義の変更ができません。
aa....aa：次に示すどれかが表示されます。
・alter table
・create foreign index
・create index
・create trigger
bb....bb：次に示すどれかが表示されます。
・view
・table
・foreign table
・audit trail table
(Ｓ)このSQL文を無視します。
(Ｐ)このSQL文を削除してください。
KFPA11661-E
Identical structure index aa....aa."bb....bb" already exists　　（Ａ）
同じ構成のインデクスaa....aa."bb....bb"があります。
aa....aa：認可識別子
bb....bb：インデクス識別子
(Ｓ)このSQL文を無視します。
(Ｐ)このSQL文を削除してください。
KFPA11662-E
Unable to cc....cc because of key length of index aa....aa."bb....bb" too long　　（Ａ）
インデクスaa....aa."bb....bb"のキー長が，指定できる最大長を超えているため，cc....ccができません。キー長の計算式を次に示します。
キー長≦MIN（（インデクス格納用RDエリアのページ長÷2）－1242，4036）
キー長の計算式については，マニュアル「HiRDB Version 7 SQLリファレンス」のCREATE INDEXを参照してください。
aa....aa：認可識別子
bb....bb：インデクス識別子
cc....cc：｛change data length｜add rdarea｝
(Ｓ)このSQL文を無視します。
(Ｐ)
・cc....ccがchange data lengthの場合
インデクスのキー長が最大長を超えないようにALTER TABLEを変更するか，又はインデクスを削除して，再度実行してください。
・cc....ccがadd rdareaの場合
インデクスを格納するRDエリアを変更してください。
KFPA11663-E
Unable to drop server "aa....aa" due to defined bb....bb　　（Ａ）
外部サーバ"aa....aa"にはbb....bbが定義されているため，外部サーバの削除はできません。
aa....aa：外部サーバ名
bb....bb：｛foreign table｜user mapping｝
(Ｓ)このSQL文を無視します。
(Ｐ)指定した外部サーバのユーザマッピング定義及び外部表を削除してから，再度実行してください。
KFPA11664-E
Specified aa....aa bb....bb already exists　　（Ａ）
指定したスキーマ又は外部サーバは，既に定義されています。
aa....aa：｛schema｜foreign server｝
bb....bb：｛認可識別子｜外部サーバ名｝
(Ｓ)このSQL文を無視します。
(Ｐ)このSQL文を削除してください。
KFPA11665-E
No available parameter found for "ALTER TABLE"　　（Ａ）
ALTER TABLEのCHANGE句で指定した内容（繰返し列の最大要素数，データ型，データ長，既定値（WITH DEFAULT， SET DEFAULT句，又はDROP DEFAULT句），又は可変長文字データの格納方式）は，変更前の内容と変わっていません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11667-E
Invalid maximum number of elements for "ALTER TABLE"　　（Ａ）
ALTER TABLEのCHANGE句で指定した最大要素数に，次のどれかの誤りがあります。
・最大要素数を小さくしようとしています。
・繰返し列を繰返し列でない列に，又は繰返し列でない列を繰返し列に変更しようとしています。
・最大要素数を変更しない場合に*を指定していません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11669-E
Invalid table name in view definition　　（Ａ）
ビュー表の基になる表名，又はビュー表名が誤っています。
又は，ビュー表の基になる表名とビュー表名が同じです。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11670-E
"UPDATE" specified for aa....aa　　（Ａ）
読み込み専用のビュー表，外部表，改竄防止表，又は監査証跡表に対する更新処理にaa....aaに示す誤りがあります。
aa....aa：｛read only view｜foreign table｜view table derived from foreign table｜INSERT ONLY table｜view table derived from INSERT ONLY table｜UPDATE ONLY FROM NULL column｜AUDIT TRAIL TABLE｝
read only view：
読み込み専用のビュー表に対してINSERT，UPDATE，又はDELETEを実行しています。
foreign table，又はview table derived from foreign table：
外部表，又は外部表を基表とするビュー表に対してINSERT，UPDATE，又はDELETEを実行しています。
INSERT ONLY table，又はview table derived from INSERT ONLY table：
・改竄防止表，又は改竄防止表を基表とするビュー表に対して，更新可能列以外の列のUPDATEを実行しています。
・改竄防止表，又は改竄防止表を基表とするビュー表に対して，ROWを指定したUPDATEを実行しています。
・行削除禁止期間を指定していない改竄防止表，又は行削除禁止期間を指定していない改竄防止表を基表とするビュー表に対してDELETEを実行しています。
UPDATE ONLY FROM NULL column：
・UPDATE ONLY FROM NULL属性の繰返し列に対して，添字を用いたUPDATE（要素の更新，追加，又は削除）を実行しています。
・UPDATE ONLY FROM NULL属性の抽象データ型の列に対して，コンポネント指定を用いたUPDATEを実行しています。
AUDIT TRAIL TABLE：
監査証跡表に対してINSERT文又はUPDATE文を実行しています。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11671-E
As a result of changing data length invalid use of variable length column occurred in view definition　　（Ａ）
ビュー定義中の次に示す列は，定義長を32,001バイト以上のBINARYに変更できません。
・比較述語，限定述語，IN述語，BETWEEN述語，NULL述語，及びLIKE述語中に指定した列
・比較述語，限定述語，及びIN述語の副問合せ中に指定した列
・重複排除に指定した実表の列
・集合演算の対象となる問合せ指定の選択式に指定した列
・グループ分け，及び集合関数に指定した実表の列
・内部導出表を作成する条件のどれかを満たす問合せ指定中で，内部導出表として展開されるビュー表を定義する場合に指定した列
内部導出表を作成する条件は次のとおりです。
7. SELECT DISTINCTを指定して導出した，名前付きの導出表に対する問合せで，名前付きの導出表が副問合せ中に含まれるか，又は次のどれかを直接含む。
・GROUP BY句，HAVING句，又は集合関数
・SELECT DISTINCT
・表の結合（外結合，内結合を含む）
・選択式に列指定以外の値式を指定
・選択式に，FROM句で指定した名前付きの導出表の全列を一回ずつ指定していない
8. GROUP BY句，HAVING句，又は集合関数を指定して導出した，名前付きの導出表に対する問合せに，次のどれかを直接含む。
・GROUP BY句
・HAVING句
・集合関数
・表の結合（外結合，内結合を含む）
9. 選択式として列指定以外の値式を指定して導出した，名前付きの導出表に対する問合せに，次のどれかを直接含む。
・GROUP BY句
・HAVING句
・集合関数
・結合表
10. DISTINCT指定の集合関数を指定して導出した，名前付きの導出表に対する問合せに，SELECT DISTINCTの指定を直接含む。
11. 表の結合（外結合，内結合を含む）を指定して導出した，名前付きの導出表に対する問合せに，表の結合（外結合，内結合を含む）を直接含んで，かつ指定した表の結合のどれかが結合表の指定である。
12. 選択式としてスカラ副問合せを指定して，導出した名前付きの導出表に対する問合せである。
13. 集合演算によって導出した名前付きの導出表に対する問合せで，次のどちらかを満たしている。
・集合演算の演算項のどれかに，内部導出表の問合せ，導出表を指定した問合せ，又は選択式に副問合せを指定した問合せかを含んでいる。
・集合演算の演算項のどれかと，名前付きの導出表に対する問合せが，1.～6.に示したどれかの条件を満たしている。
14. UNION ALL以外を含む集合演算によって導出した，名前付きの導出表に対する問合せで，次のどれかを直接含む。
・GROUP BY句，HAVING句，又は集合関数
・SELECT DISTINCT
・表の結合（外結合，内結合を含む）
・WHERE句
・副問合せ
・選択式に列指定以外の値式
・選択式に，FROM句に指定した名前付きの導出表の列を１回ずつ指定していない
15. UNION ALLだけの集合演算によって導出した，名前付きの導出表に対する問合せで，次のどれかを直接含む。
・GROUP BY句，HAVING句，又は集合関数
・表の結合（外結合，内結合を含む）
・WHERE句，又は副問合せ（ただし，副問合せ，集合演算の演算項，又はINSERT文の問合せだけ）
・関数呼出し又はシステム定義スカラ関数
・コンポネント指定
・WRITE指定
・GET_JAVA_STORED_ROUTINE_SOURCE指定
・選択式にない項目でのソート指定
・集合演算によって導出した名前付きの導出表をFROM句に指定した副問合せ
・導出表を指定した副問合せ
・GROUP BY句に列指定以外の値式を指定した副問合せ
・選択式に指定したSQL変数，及びSQLパラメタのうち，データ型が次のどれかになるもの
BLOB型
32,001バイト以上のBINARY型
抽象データ型
BOOLEAN型
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正するか，又はビュー表を削除した後，再度実行してください。
KFPA11672-E
Each column of distinct view can be specified only once in "SELECT" clause in view definition, or in "WITH" query　　（Ａ）
重複排除（DISTINCT）を指定して定義したビュー表に対する，ビュー定義又はWITH句の導出問合せ式中のSELECT句に，ビュー表を構成するすべての列を一つずつ指定していません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11673-E
Duplicate "aa....aa" in bb....bb statement　　（Ａ）
bb....bb中でaa....aaを2回以上指定しています。
aa....aa：2回以上指定した項目
｛CLUSTER KEY｜PRIMARY KEY｜PCTFREE｜SUPPRESS
｜LOCK ROW/PAGE｜WITHOUT ROLLBACK｜UNBALANCED SPLIT
｜EMPTY｜EXCEPT VALUES｜INDEXLOCK｜ISOLATION LEVEL
｜OPTIMIZE LEVEL｜ADD OPTIMIZE LEVEL
｜SEGMENT REUSE｜INSERT ONLY｜NOT NULL｜CONNECT
｜PASSWORD
｜OPTIONS SCHEMA｜OPTIONS TABLE｜
｜OPTIONS COLLATING_SEQUENCE｜OPTIONS TRAILING_SPACE
｜OPTIONS NULLABLE｜OPTIONS USING_BES｜OPTIONS_USER
｜OPTIONS PASSWD｝
bb....bb：指定した文の種類
｛CREATE TABLE｜CREATE INDEX｜CREATE PROCEDURE
｜CREATE FOREIGN TABLE｜CREATE SERVER
｜CREATE USER MAPPING
｜PROCEDURE definition in CREATE TYPE｜ALTER TABLE
｜ALTER PROCEDURE｜ALTER ROUTINE
｜CREATE TRIGGER｜ALTER TRIGGER
｜CREATE CONNECTION SECURITY｜DROP CONNECTION SECURITY｝
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11674-E
Unable to specify more than 16 columns for "aa....aa"　　（Ａ）
CREATE TABLE文の中のaa....aaの列数が，指定できる最大数（16）を超えています。
aa....aa：最大列数を超えて指定している箇所
CLUSTER KEY：クラスタキー
FOREIGN KEY：主キー
HASH KEY：複数列ハッシュ分割の分割に指定した列
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11676-E
"aa....aa" cannot be specified in ALTER TABLE statement　　（Ａ）
ALTER TABLE文では，追加又は変更をする列に対して， aa....aaは指定できません。
aa....aa：エラーの内容
{ CLUSTER KEY | NOT NULL }
ただし，ADD句にはNOT NULLを指定できます。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11677-E
Unable to purge aa....aa　　（Ａ）
ビュー表，外部表，又は改竄防止表に対して，PURGE TABLE文は実行できません。
aa....aa：｛viewed table｜foreign table｜INSERT ONLY table｝
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11678-E
No Column-definition in "CREATE TABLE" statement　　（Ａ）
CREATE TABLE文中で，列定義が一つも指定されていません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11680-E
Unable to aa....aa LIST due to executing same user bb....bb　　（Ａ）
同じユーザ名bb....bbがリストを処理中のため，リストをaa....aaすることができません。
aa....aa：リスト処理の種別
｛assign｜select｜drop｝
bb....bb：認可識別子
(Ｓ)このSQL文を無視します。
(Ｐ)実行中のトランザクションが終了してから再度実行してください。
KFPA11690-E
Unable to drop referenced table　　（Ａ）
参照制約の被参照表は削除できません。
(Ｓ)このSQL文を無視します。
(Ｐ)参照表をすべて削除してから，再度実行してください。
KFPA11692-E
Unable to execute due to table aa....aa."bb....bb" in use　　（Ａ）
表aa....aa."bb....bb"は，ほかのユーザが使用中です。このため，このSQL文又は運用コマンドは実行できません。
aa....aa：認可識別子
bb....bb：表識別子
(Ｓ)このSQL文を無視します。
(Ｐ)実行しようとしたSQLの操作が，正しいかどうか確認してください。問題がない場合，ほかのユーザが該当する表の使用を終了した後，このSQL文又は運用コマンドを実行してください。なお，ほかのユーザが該当する表の使用を終了したかどうかは，次のコマンドで確認してください。
pdls -d lck -a
KFPA11693-E
Unable to define same columns construction for primary key and cluster key　　（Ａ）
同じ列構成のクラスタキー句と主キー句は，同時に指定できません。
(Ｓ)このSQL文を無視します。
(Ｐ)同じ列構成のクラスタキー，及び主キーを定義する場合は，PRIMARY CLUSTER KEY句で定義してください。
KFPA11694-E
Unable to change cluster key because of invalid key attribute　　（Ａ）
クラスタキーの属性を変更する場合に，次に示す誤りがあります。
・UNIQUE指定のあるクラスタキーをUNIQUEに変更しようとしています。又はUNIQUE指定のないクラスタキーを非UNIQUEに変更しようとしています。
・フレキシブルハッシュ分割表，又はフレキシブルハッシュ分割を使用しているマトリクス分割表のクラスタキーをUNIQUEに変更しようとしています。
(Ｓ)このSQL文を無視します。
(Ｐ)このSQL文を削除してください。
KFPA11697-E
Unable to specify "WITH DEFAULT" except for "NOT NULL"　　（Ａ）
表の定義時又は表の定義変更時には，非ナル値制約のない列に対して"WITH DEFAULT"を指定できません。
(Ｓ)このSQL文を無視します。
(Ｐ)"NOT NULL"を指定して，再度実行してください。
KFPA11698-E
Unable to specify "bb....bb" for "aa....aa" column　　（Ａ）
"aa....aa"を構成する列に対して，"bb....bb"は指定できません。
aa....aa：abstract data（抽象データ型）
bb....bb：NOT NULL
(Ｓ)このSQL文を無視します。
(Ｐ)このSQL文を削除してください。
KFPA11699-E
Unable to specify "WITH DEFAULT" because of column already "WITH DEFAULT"　　（Ａ）
指定した列は，既にWITH DEFAULTが指定されています。
(Ｓ)このSQL文を無視します。
(Ｐ)このSQL文を削除してください。
KFPA11702-E
Unable to create unique index, because unique key not include all partitioning key columns　　（Ａ）
次の理由で，UNIQUE指定のインデクスは定義できません。
・複数のバックエンドサーバ間で横分割した表で，表の分割キーとして指定したすべての列が，インデクス構成列に含まれていません。
・シングルサーバ内，又は1バックエンドサーバ内でのFIXハッシュ分割のリバランス表で，表の分割キーとして指定したすべての列が，インデクス構成列に含まれていません。
(Ｓ)このSQL文を無視します。
(Ｐ)表の分割キーとして指定したすべての列を，インデクス構成列に含むように修正して（順不同），再度実行してください。
KFPA11703-E
Unable to partition table more than 1024 servers　　（Ａ）
一つの表を1,025以上のバックエンドサーバに分割して定義できません。
(Ｓ)このSQL文を無視します。
(Ｐ)分割するバックエンドサーバ数を1,024以下にして，再度実行してください。
KFPA11704-E
Unable to specify aa....aa for bb....bb　　（Ａ）
bb....bbに対して，aa....aaは指定できません。
bb....bbが"FIX" tableの場合：
FIX属性の表に対して，データ型BLOB又はBINARYは指定できません。
bb....bbがforeign tableの場合：
外部表に対して，次のデータ型は指定できません。
・256バイト以上のCHAR，VARCHAR，MCHAR，及びMVARCHAR
・128文字以上のNCHAR及びNVARCHAR
・256バイト以上のBINARY
aa....aa：｛"BLOB"｜"BINARY"｜long data｝
bb....bb：｛"FIX" table｜foreign table｝
(Ｓ)このSQL文を無視します。
(Ｐ)
bb....bbが"FIX" tableの場合：
データ型BLOB若しくはBINARYを指定しないようにするか，又はFIX属性の指定を削除して，再度実行してください。
bb....bbがforeign tableの場合：
データ型を指定し直して再度実行してください。
KFPA11705-E
Invalid option "aa....aa" number cc....cc in "bb....bb" statement　　（Ａ）
"bb....bb"文の"aa....aa"オプションの値が，指定できる最大値を超えています。
aa....aa：誤りがあるオプション名
｛PCTFREE｜SEGMENT REUSE｝
bb....bb：誤りがあるSQL文
｛CREATE TABLE｜CREATE INDEX｜ALTER TABLE｝
cc....cc：誤りがある指定値
(Ｓ)このSQL文を無視します。
(Ｐ)オプションの指定を変更して，再度実行してください。
KFPA11706-E
Number of defined indexes on table aa....aa."bb....bb" exceeds 255　　（Ａ）
一つの表に指定できるインデクスの数が最大数（255）を超えました。
aa....aa：認可識別子
bb....bb：表識別子
(Ｓ)このSQL文を無視します。
(Ｐ)このSQL文を実行したい場合は，インデクスを削除してください。
SQL文を実行する必要がない場合は，このSQL文を削除してください。
KFPA11707-E
Invalid "LOB" RDAREA for table partitions　　（Ａ）
表の境界値分割時，複数の境界値に同じ表RDエリアの指定がある場合に，表格納RDエリアの指定と，次に示す項目の指定が一致していません。
・LOB列格納用RDエリア
・LOB属性格納用RDエリア
(Ｓ)このSQL文を無視します。
(Ｐ)LOB列格納用RDエリア又はLOB属性格納用RDエリアを，対応する表RDエリアに一致させて，再度実行してください。
KFPA11708-E
Not specified "LOB" RDAREA "aa....aa" in same server as table RDAREA　　（Ａ）
指定したLOB用RDエリアは，表格納用RDエリアと同じサーバではありません。
aa....aa：LOB用RDエリア名
(Ｓ)このSQL文を無視します。
(Ｐ)対応する表格納用RDエリアと同じサーバのLOB用RDエリアを指定してください。
KFPA11709-E
Specified RDAREA "aa....aa" already used　　（Ａ）
指定したLOB用RDエリアは，既にほかの表で使用されています。
aa....aa：LOB用RDエリア名
(Ｓ)このSQL文を無視します。
(Ｐ)ほかの表で使用していないLOB用RDエリアを指定してください。
KFPA11710-E
Specific name for aa....aa."bb....bb" conflict with another routine　　（Ａ）
ルーチンaa....aa."bb....bb"の特定名が別のルーチンと競合しています。
aa....aa：認可識別子
bb....bb：ルーチン識別子
(Ｓ)このSQL文を無視します。
(Ｐ)ルーチン識別子を変更して，再度実行してください。
KFPA11711-E
Invalid update in execution of query with cursor　　（Ａ）
次のどれかの誤りがあります。
1. FOR UPDATE句を指定しないで宣言又は割り当てたカーソルを使用し，検索中の表に更新，削除，又は挿入をしています。
2. FOR UPDATE OFを指定して宣言又は割り当てたカーソルを使用し，検索中の表に，削除又は挿入をしています。
3. FOR UPDATE OFを指定して宣言又は割り当てたカーソルを使用し，検索中の表に，FOR UPDATE OFで指定していない列の更新をしています。
4. FOR READ ONLYを指定して宣言又は割り当てたカーソルを指定し，更新又は削除をしています。
(Ｓ)このSQL文を無視します。
(Ｐ)UAPを修正し，再度実行してください。
KFPA11712-E
Duplicate attribute name "aa....aa"　　（Ａ）
一つのデータ型を構成する属性の名称は，継承関係にあるすべての抽象データ型内で一意である必要があります。
aa....aa：重複している属性名
(Ｓ)このSQL文を無視します。
(Ｐ)一意になるように属性名を修正して，SQL文を再度実行してください。
KFPA11713-E
Unable to aaaaaa work file due to insufficient HiRDB file system area bb....bb　　（Ａ）
内部処理で作業表用ファイルを作成する際，サーバ定義のpdworkで指定されたHiRDBファイルシステム領域に容量不足が発生しました。
aaaaaa：作業表用HiRDBファイルに対する操作
create：作業表用HiRDBファイルの作成
expand：作業表用HiRDBファイルの拡張
bb....bb：容量不足が発生したHiRDBファイルシステム領域の名称
HiRDBファイルシステム領域のパス名が118文字以上の場合は，HiRDBファイルシステム領域のパス名の後ろから117文字を出力します。
(Ｓ)このトランザクションを無効にします。
(Ｐ)HiRDB管理者に連絡してください。
[対策]〈作業表用HiRDBファイルに対する操作がcreateの場合〉
サーバ定義のpdworkオペランドでHiRDBファイルシステム領域を追加してください。又は，pdworkオペランドで指定したHiRDBファイルシステム領域の領域長を増やして，サーバを開始してください。
〈作業表用HiRDBファイルに対する操作がexpandの場合〉
サーバ定義のpdworkオペランドで指定したHiRDBファイルシステム領域の領域長を増やして，サーバを開始してください。
KFPA11714-E
Number of "aa....aa" exceeds bbbbb　　（Ａ）
"aa....aa"の値がシステムの上限値bbbbbを超えました。
aa....aa：該当項目
｛ADT LEVEL（抽象データ型の世代数）｝
bbbbb：システムの上限値｛30000｝
(Ｓ)このSQL文を無視します。
(Ｐ)システムの限界によって対処できません。このSQLは実行できません。SQLの誤りに起因する場合には，それを修正し，再度実行してください。
KFPA11716-E
Unable to change definition of column specified in aa....aa operand in view definition　　（Ａ）
ビュー定義で次のどれかの項目に指定した実表の列は，データ型，及び定義長の変更はできません。
・連結演算
・スカラ関数
・CASE式
・CAST指定
・関数呼出し
また，ビュー定義文中で次に示す機能のうちのどれかを指定している場合，そのビュー定義で使用した列は，データ型及び定義長を変更できません。
・行副問合せ
・集合演算を指定したスカラ副問合せ
・集合演算を指定した表副問合せ
・EXISTS述語以外で結果の列数が2以上の表副問合せ
・選択式中のスカラ副問合せ
・比較述語，IN述語，及び限定述語の左側の行値構成子中のスカラ副問合せ
・BETWEEN述語，LIKE述語，及びXLIKE述語中のスカラ副問合せ
aa....aa：エラーの内容
{ concatenation | scaler function | CASE expression | function invocation | CAST specification subquery }
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正してください。又は，ビュー表を削除してから，再度実行してください。
KFPA11717-E
Unable to rename aaaaaa name on "bb....bb" due to cc....cc　　（Ａ）
次に示す理由で，表，又は列の名称が変更できません。
・変更対象の表を基にビュー表が作成されています。
・変更対象の表にトリガが定義されています。
・変更対象の表に検査制約が定義されています。
・変更対象の列は検査制約の探索条件中で使用されています。
・変更対象の表に参照制約（外部キー）が定義されています。
・変更対象の列は外部キー構成列です。
・変更対象の表は参照制約の被参照表です。
・変更対象の列は参照制約の被参照表の主キー構成列です。
・変更対象の表が，ストアドプロシジャ，又はトリガSQL文に指定されています。
・ビュー表の列名称を変更しようとしました。
・トリガの実行契機で指定している列名称を変更しようとしました。
・トリガ動作の探索条件中で新旧値相関名を使用して参照している列の名称を変更しようとしました。
・トリガSQL文中で新旧値相関名を使用して参照している列の名称を変更しようとしました。
・改竄防止表の表名又は列名を変更しようとしました。
aaaaaa：変更対象種別
COLUMN：列名称の変更
TABLE：表名称の変更
bb....bb：表，ビュー表
cc....cc：エラーの種別
used on view：ビューが定義されています。
used on trigger：トリガが定義されています。
check constraint：検査制約が定義されています。
check column：検査制約の探索条件中で使用している列名称です。
referential constraint：参照制約（外部キー）が定義されている表です。
foreign key column：外部キー構成列の列名称です。
referenced table：参照制約の被参照表です。
referenced primary key：参照制約の被参照表の主キー構成列です。
used on stored procedure：ストアドプロシジャ，又はトリガSQL文で使用されています。
view's column：変更しようとした列名称がビュー表の列名称です。
trigger column：変更しようとした列名称がトリガの実行契機で指定されています。
triggered action condition：変更しようとした列名称が，トリガ動作の探索条件中で新旧値相関名を使用して参照している列名称です。
triggered SQL statement：変更しようとした列名称が，トリガSQL文中で新旧値相関名を使用して参照している列名称です。
INSERT ONLY table：変更しようとした表は改竄防止表です。
(Ｓ)このSQL文を無視します。
(Ｐ)〈cc....ccがused on stored procedure又はused on viewの場合〉
変更対象の表を使用しているビュー表，ストアドプロシジャ，又はトリガを削除し，ALTER TABLEを再実行してください。その後，ビュー表，ストアドプロシジャ，又はトリガを再作成してください。
〈cc....ccがview's columnの場合〉
DROP VIEWを実行した後，新しい列名でCREATE VIEWを実行し，列名称を変更してください。
〈cc....ccがused on triggerの場合〉
変更対象の表に定義しているトリガを削除し，ALTER TABLEを再実行してください。その後，トリガを再作成してください。
〈cc....ccがcheck constraintの場合）
表名称を見直し，再実行してください。
〈cc....ccがcheck columnの場合）
列名称を見直し，再実行してください。
〈cc....ccがreferential constraintの場合）
表名称を見直し，再実行してください。
〈cc....ccがforeign key columnの場合）
列名称を見直し，再実行してください。
〈cc....ccがreferenced tableの場合）
表名称を見直し，再実行してください。
〈cc....ccがreferenced primary keyの場合）
列名称を見直し，再実行してください。
〈cc....ccがtrigger column，triggered action condition，及びtriggered SQL statementの場合〉
列名を変更しようとした列を使用しているトリガを削除し，ALTER TABLEを再実行してください。その後，トリガを再作成してください。
〈cc....ccがINSERT ONLY tableの場合〉
改竄防止表は表名及び列名の変更はできません。表名称を見直し，再実行してください。
KFPA11718-E
Invalid use of column suppress specification　　（Ａ）
列データ抑制の定義に，次に示す誤りがあります。
・FIX表に対して指定しています。
・CHAR，MCHAR，NCHAR以外のデータ型の列に対して指定しています。
・繰返し列に対して指定しています。
(Ｓ)このSQL文を無視して，トランザクションを終了します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11720-E
Error occurred in HiRDB/client, inf1=aa....aa, inf2=bbbb　　（Ｌ＋Ａ）
HiRDBシステムのクライアントライブラリで内部矛盾が発生しました。
aa....aa：エラーを検出したソースファイルの名称
bbbb：エラーを検出した位置（行番号）
(Ｓ)処理を終了します。
[対策]pdstartコマンドで指定するホスト及びPDHOSTで指定するホストとクライアント側のシステムが，ネットワークで通信できない状態になっているか，又は，通信の負荷が高くなっている場合が考えられます。また，OLTP環境下でX/Openに従ったUAPを実行している場合には，tx_begin関数によってトランザクションを開始していない場合が考えられます。上記に該当しない場合は，エラーが出力されたエラーログファイルのバックアップを取得して保守員に連絡してください。
KFPA11721-E
User mapping for aa....aa on foreign server "bb....bb" cc....cc　　（Ａ）
次の理由によって，外部サーバ"bb....bb"に対するaa....aaのユーザマッピング定義の作成又は削除ができません。
・cc....ccがalready existsの場合，指定したユーザマッピング定義は既に定義されています。
・cc....ccがnot found in systemの場合，指定したユーザマッピング定義はHiRDBにありません。
aa....aa：｛認可識別子｜PUBLIC｝
bb....bb：外部サーバ名
cc....cc：｛already exists｜not found in system｝
(Ｓ)このSQL文を無視します。
[対策]このSQL文を実行する必要はありません。
KFPA11722-E
Communication error occurred, reason=aa....aa　　（Ａ）
SQLの処理中に続行できない通信エラーが発生しました。
aa....aa：エラーの内容
INVALID DATA：サーバから不当なデータを受信しました。
SERVER PROCESS DOWN：サーバプロセスが停止しました。
(Ｓ)処理を終了します。また，サーバとの接続が切断されます。
(Ｐ)HiRDB管理者に連絡してください。
[対策]
〈SERVER PROCESS DOWNの場合〉
サーバプロセスの停止原因を調べ，障害を取り除いた後，再度UAPを実行してください。
なお，高速接続機能(クライアント環境定義のPDSERVICEPORT)を使用している場合，PDSERVICEPORTの指定値が誤っているおそれがあります。HiRDB開始時にKFPS00860-Wのメッセージが出力されていないか，又はPDSERVICEPORTの値がpd_service_port(システム共通定義，又はユニット制御情報定義)の値と異なっていないかを確認し，該当する場合はPDSERVICEPORTの指定値を正しく変更した後，再度UAPを実行してください。
〈INVALID DATAの場合〉
エラーログファイルのバックアップを取得して，保守員に連絡してください。
KFPA11723-E
Communication error occurred, reason=aa....aa　　（Ｌ＋Ａ）
HiRDBシステム又はHiRDBサーバとの通信でエラーが発生しました。又は，HiRDBシステム又はHiRDBサーバがダウンしています。
aa....aa：障害の内容を示す文字列
CLIENT MEMORY：クライアントライブラリでメモリ不足が発生しました。
FES （SDS） CLOSE：サーバ（HiRDB/シングルサーバ（SDS），又はHiRDB/パラレルサーバ（FES））の終了処理中です。
FES (SDS) NOT UP：サーバ（HiRDB/シングルサーバ（SDS），又はHiRDB/パラレルサーバ（FES））が稼働していません。又は，開始中です。
HiRDB BUSY：HiRDB（サーバ）がBUSYなため，コネクトできません。
HiRDB DATA ERROR：HiRDBシステム又はHiRDBサーバからの通信データが不正です。
HiRDB INITIALIZE：HiRDBシステム又はHiRDBサーバの初期化処理中です。
HiRDB NOT UP：HiRDBシステム又はHiRDBサーバが稼働していません。又は，HiRDBサーバ側でListenキューが不足しています。
HiRDB SYSTEM ERROR：HiRDBシステム又はHiRDBサーバでシステムエラーを検出しました。
HiRDB MEMORY：HiRDBシステム又はHiRDBサーバでメモリ不足が発生しました。
INIT ERROR：通信の初期化処理でエラーが発生しました。
INVALID SERVER TYPE：HiRDB（サーバ）のサーバ種別が，PDSRVTYPE（クライアント環境定義）と異なります。
NETWORK：ネットワークに障害が発生しました。又は，HiRDBサーバが異常終了してコネクションが切断されました。
(Ｓ)処理を終了します。
(Ｐ)〈aa....aaがHiRDB BUSYの場合〉
時間をおいて再度実行してください。再度このメッセージが出力されたときは，HiRDB管理者へ連絡してください。
〈aa....aaがHiRDB BUSY以外の場合〉
HiRDB管理者に障害の内容を連絡し，障害を取り除いた後再度実行してください。
[対策]HiRDBクライアントが出力するエラーログファイル（PDCLTPATHの下又はカレントディレクトリに作成される）から障害の原因を調べ，原因を取り除いて再度実行してください。
接続対象のHiRDBが開始しているのに，UAP起動時にこのメッセージ（aa....aaが"HiRDB NOT UP"）が出力され続ける場合は，クライアント環境定義のPDHOST及びPDNAMEPORTオペランドの値を見直してください。また，HiRDBサーバで障害が発生していないか，syslogfile（Windows NTの場合はイベントログ）で確認してください。
PDHOST及びPDNAMEPORTオペランドの値が正しくて，エラーログファイルにKFPZ02444-Eメッセージ（func=connectでerrnoの示す値がETIMEDOUT又はECONNREFUSED）が出力されている場合は，HiRDBサーバに対する接続要求が多過ぎる可能性があります。この場合，時間をおいて再度実行するか，又はListenキューの指定値を大きくしてください。Listenキューについては，マニュアル「HiRDB Version 7 システム導入・設計ガイド」を参照してください。
KFPA11724-E
Environment definition error, variable=aa....aa, reason=bb....bb, identifier="cc....cc"　　（Ｌ＋Ａ）
環境変数の指定に誤りがあります。
aa....aa：誤りのあった環境変数名
PDPLUGINで始まる環境変数の場合，プラグイン用の環境変数の長さが長過ぎるか，環境変数の個数が多過ぎて，バッファに格納できる範囲を超えています。
bb....bb：エラーの理由
INVALID CHAR：指定できない文字があります。
NET ENVIRONMENT：指定内容がネットワーク環境と一致しません。
NO VALUE：指定値がありません。
OUT OF RANGE：指定値が範囲外です。
NOT ENVIRONMENT GROUP：レジストリ中に指定した環境変数グループがありません。
INVALID IDENTIFIER：識別子が不正です。
cc....cc：不正な識別子（30バイトを超える場合は，先頭30バイトを表示）
理由がINVALID IDENTIFIERの場合に表示されます。それ以外の場合は表示されません。
(Ｓ)処理を終了します。
(Ｐ)環境変数の指定を正しくして，再度実行してください。
KFPA11725-E
Other SQL executing cannot execute next SQL　　（Ｌ＋Ａ）
前のSQLの処理が終わる前に，次のSQLを実行しています。又は，マルチスレッドのUAPで，複数のスレッドから同一の接続ハンドルを使用しているか，若しくは接続ハンドルなしでSQLを実行しています。
(Ｓ)処理を終了します。
(Ｏ)前のSQLの処理が終了するのを待って，次のSQLを実行してください。
KFPA11727-E
Unable to execute SQL, for termination process HiRDB　　（Ｌ＋Ａ）
HiRDBシステム又はサーバが終了処理中のため，SQL文の実行ができません。
(Ｓ)処理を終了します。
(Ｐ)HiRDBシステム又はサーバの開始を確認した後，再度UAPを実行してください。
KFPA11728-E
Error occurred in HiRDB, reason=aa....aa　　（Ｌ＋Ａ）
HiRDBシステム又はサーバがエラーリターンしました。
aa....aa：理由を示す文字列
FALSE：リソースのロックに失敗しました
NO FES（SDS）：使用できるサーバ（HiRDB/シングルサーバ（SDS），又はHiRDB/パラレルサーバ（FES））がありません。
SHUTDOWN：HiRDBシステムが停止処理中です。
(Ｓ)処理を終了します。
(Ｐ)理由コードがNO FES（SDS），SHUTDOWNの場合は，HiRDBシステム又はサーバの開始を確認してから再度実行してください。FALSEの場合はリトライしてください。
KFPA11729-E
Insufficient memory on aa....aa, size=bbbbb　　（Ａ）
SQL文を実行するためのメモリが不足しています。
aa....aa：確保しようとした領域の種別を示す文字列
DYNAMIC_SHMPOOL：動的共用メモリ
PROCESS：プロセス固有領域
STATIC_SHMPOOL：静的共用メモリ
bbbbb：確保しようとした領域のサイズ（単位：バイト）
(Ｓ)処理を終了します。
[対策]実行に必要なメモリを確保し，再度実行してください。
KFPA11731-E
System call error, func=aa....aa, errno=bbb　　（Ｌ＋Ａ）
aa....aaで示すシステムコールでエラーが発生しました。
aa....aa：エラーの発生したシステムコール名称
bbb：システムコールの返したエラー番号
(Ｓ)処理を終了します。
(Ｐ)エラーインジケータの値を調査し，errno.h及びユーザが使用しているOSのマニュアルを参照して，エラーの原因を取り除き，再度実行してください。
KFPA11732-E
Time over, no response from HiRDB　　（Ｌ＋Ａ）
HiRDBサーバが停止しました。又は，HiRDBサーバの処理がタイマ監視時間よりも長く掛かりました。
このため，HiRDBサーバへの問合せができません。
(Ｓ)処理を終了します。
(Ｐ)HiRDBサーバが停止した場合は，HiRDBサーバの開始を確認し，再度実行してください。
HiRDBサーバが停止していない場合は，環境変数（PDCWAITTIME）でタイマ監視時間を大きくして，再度UAPを実行してください。
クライアント環境定義のPDCLTRCVADDRに不正なIPアドレス（HiRDBサーバからアクセスできないアドレス），又はホスト名を設定した場合に，このエラーとなることがあります。HiRDBサーバのシングルサーバ又はフロントエンドサーバがあるホストから，PDCLTRCVADDRで指定したIPアドレスがpingコマンドで送信できるかどうか確認してください。
PDCLTRCVADDRに設定したホスト名に対応するアドレスが，HiRDBサーバがあるホストとUAPがあるホストとで異なっている場合に，このエラーとなることがあります。PDCLTRCVADDRに設定したホスト名に対応しているアドレスが同じかどうか確認してください。
KFPA11733-E
Error occurred in HiRDB, inf1=aa....aa, inf2=bbbb　　（Ｌ＋Ａ）
HiRDBサーバから不正なデータを受け取りました。
aa....aa：エラーを検出したソースファイルの名称
bbbb：エラーを検出した位置（行番号）
(Ｓ)処理を終了します。
[対策]エラーログファイルが出力されている場合は，エラーログファイルのバックアップを取得してください。その後，サーバ側の障害対策をして保守員に連絡してください。
KFPA11734-E
Unable to get IPaddr of FES(SDS) host, hostname=aa....aa　　（Ｌ）
HiRDB/シングルサーバ（SDS），又はHiRDB/パラレルサーバ（FES）があるホスト名称のIPアドレスが取得できません。
aa....aa：IPアドレスを取得しようとしたホスト名称
(Ｓ)処理を終了します。
(Ｐ)UAPを実行したホストのhostsファイルの内容を参照し，メッセージ中に表示されたホスト名称の定義を追加して，再度UAPを実行してください。
KFPA11735-E
FES(SDS) canceled　　（Ｌ）
UAPからSQLのキャンセルを要求されたので，SQLの実行を取り消しました。これ以上の処理は続行できません。
(Ｓ)処理を終了します。
(Ｐ)要求した処理が取り消されたので，必要ならば再度UAPを実行してください。
KFPA11736-E
aa....aa bb....bb."cc....cc" not convert to 64-bit　　（Ａ）
指定したaa....aa bb....bb."cc....cc"は64ビットモード対応になっていません。
aa....aa：種別
View：ビュー表
Routine：ルーチン
Trigger：トリガ
bb....bb：認可識別子
cc....cc：表識別子，ルーチン識別子，又はトリガ識別子
(Ｓ)このSQL文を無視します。
[対策]SQLオブジェクト移行ユティリティでビュー表又はルーチンを64ビットモード対応にしてください。その後，SQL文を再度実行してください。
KFPA11737-E
RDAREA for specified aa....aa already removed, server=bb....bb　　（Ａ）
SQL文で指定しているaa....aaを格納した，サーバbb....bbのRDエリアはデータベース構成変更ユティリティ(pdmod)で削除されています。
aa....aa：LIST … リスト
bb....bb：サーバ名
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文で指定しているリストを，削除後，再作成してから実行してください。
KFPA11738-E
No RDAREA for aa....aa, server=bb....bb　　（Ａ）
サーバbb....bbにaa....aa用RDエリアがないため，SQL文を実行できません。
又は，サーバbb....bbのaa....aa用RDエリアがすべて閉塞中のため，SQL文を実行できません。
aa....aa：LIST … リスト
bb....bb：サーバ名
(Ｓ)このSQL文を無視します。
(Ｐ)データベース構成変更ユティリティ(pdmod)でRDエリアを割り当ててから，再度実行してください。
又は，RDエリアの障害を取り除いて閉塞状態を解除してから，再度実行してください。
KFPA11740-E
Unable to execute SQL for definition due to cc....cc aa....aa."bb....bb"　　（Ａ）
・削除又は変更されるリソースを使用するSQLオブジェクトのルーチンaa....aa.bb....bbがあるため，SQLオブジェクトを無効にする次の定義系SQLは実行できません。又は，削除若しくは変更されるリソースを使用するSQLオブジェクトのルーチンaa....aa.bb....bbを実行中のため，次の定義系SQLは実行できません。
・ALTER TABLE（表定義の変更）
・CREATE TABLE（表の定義）
・CREATE TRIGGER（トリガの定義）
・CREATE TYPE（データ型（サブタイプ）の定義）
・DROP DATA TYPE（データ型の削除）
・DROP FOREIGN TABLE（外部表削除）
・DROP FUNCTION（関数の削除）
・DROP INDEX（インデクスの削除）
・DROP PROCEDURE（手続きの削除）
・DROP SCHEMA（スキーマの削除）
・DROP TABLE（表の削除）
・DROP TRIGGER（トリガの削除）
・DROP VIEW（ビューの削除）
・REVOKE アクセス権限（アクセス権限の削除）
・削除されるリソースを使用するビュー表aa....aa.bb....bbがあるため，次の定義系SQLは実行できません。
・DROP FUNCTION（関数の削除）
・DROP DATA TYPE（データ型の削除）
・DROP SCHEMA（スキーマ削除）
・削除される関数をトリガ動作の探索条件中で使用するトリガaa....aa.bb....bbがあるため，次の定義系SQLは実行できません。
・DROP FUNCTION（関数の削除）
・DROP SCHEMA（スキーマ削除）
aa....aa：認可識別子
bb....bb：ルーチン識別子，表識別子，又はトリガ識別子
cc....cc：｛ROUTINE｜TABLE｜TRIGGER｝
(Ｓ)このトランザクションを無効にします。
(Ｐ)〈cc....ccがROUTINEの場合〉
SQLオブジェクトを削除してもよい場合は，WITH PROGRAMを指定して，再度実行してください。実行中のルーチンがある場合は，ルーチンが終了してから再度実行してください。
〈cc....ccがTABLEの場合〉
ビュー表aa....aa.bb....bbを削除してから再度実行してください。
〈cc....ccがTRIGGERの場合〉
トリガaa....aa.bb....bbを削除してから再度実行してください。また，DROP FUNCTIONの場合，トリガを無効にしてもよい場合は，WITH PROGRAMを指定して，再度実行してください。
KFPA11741-E
Unable to drop datatype due to used by aa....aa bb....bb."cc....cc"　　（Ａ）
指定したデータ型はaa....aaのbb....bb."cc....cc"が使用しているため削除できません。
aa....aa：データ型を利用している資源
｛TABLE，INDEX，DATATYPE，INDEXTYPE｝
bb....bb：認可識別子（利用している資源の所有者）
cc....cc：利用している資源の名称
(Ｓ)このSQL文を無視します。
(Ｐ)利用している資源の定義を削除してよいか確認してください。削除できる場合は，それを削除した後，このSQL文を再度実行してください。
KFPA11743-E
Foreign key aa....aa."bb....bb" mismatch primary key code=cc(dd....dd)　　（Ａ）
外部キーaa....aa.bb....bbと，外部キーが参照する主キーとが，不整合です。
aa....aa：認可識別子
bb....bb：制約名
cc：理由コード
dd....dd：エラーに対する付加情報
(Ｓ)このSQL文を無視します。
(Ｐ)理由コード及びエラーに対する付加情報について次に示します。エラーの要因を取り除いて，SQL文を再度実行してください。
理由コード（cc）
エラーに対する付加情報（dd....dd）
意味
01
number of columns
外部キーと主キーの構成列数が異なります。
02
data types
外部キーと主キーの対応する列のデータ型が異なります。
03
data length
外部キーと主キーの対応する列のデータ長が異なります。
KFPA11744-E
Unable to define referential constraint aa....aa."bb....bb" for ee....ee."ff....ff" code=cc(dd....dd)　　（Ａ）
ee....ee.ff....ffを被参照表とする参照制約定義aa....aa.bb....bbが，ccに示す理由のため，定義できません。
aa....aa：認可識別子
bb....bb：制約名
cc：理由コード
dd....dd：エラーに対する付加情報
ee....ee：認可識別子
ff....ff：表識別子
(Ｓ)このSQL文を無視します。
(Ｐ)理由コード及びエラーコードに対する付加情報について次に示します。SQL文を修正し，再度実行してください。
理由コード（cc）
エラーに対する付加情報（dd....dd）
意味
01
foreign table，view，又はalias
被参照表に，外部表，ビュー表，及び表別名は指定できません。
02
Primary key not defined
被参照表に主キーがありません。
03
WITHOUT ROLLBACK table
被参照表にWITHOUT ROLLBACK指定の表は指定できません。
04
own table
被参照表に自表は指定できません。
05
another user's table
被参照表にほかの所有者の表は指定できません。
KFPA11745-E
Unable to specify partitioning key on column "aa....aa"　　（Ａ）
次に示す属性の列に格納条件を指定できません。又は，ハッシュ分割キーに指定できません。
・定義長256バイト以上のCHAR，VARCHAR，MCHAR，MVARCHAR
・定義長128文字以上のNCHAR，NVARCHAR
・単一列分割の場合，クラスタキーを構成する列の先頭の列以外。
複数列分割，又はマトリクス分割の場合，分割キーに指定する列の順序がクラスタキーに指定する列の順序と異なる列
・BLOB
・複数列分割，又はマトリクス分割の分割キーに重複した列
・繰返し列
・BINARY
・小数秒精度が0より大きいTIMESTAMP
・既定値にCURRENT_TIMESTAMP USING BESを指定した列
aa....aa：エラーとなった列名
(Ｓ)このSQL文を無視します。
(Ｐ)分割条件を指定できる属性の列に分割条件を指定して，再実行してください。
クラスタキーを指定する場合，クラスタキーに指定する列を，分割キーに指定する列の先頭から同じ順序ですべて含むように指定して，再実行してください。
KFPA11746-E
Incompatible data type specified at partitioning condition aaaa for column "bb....bb"　　（Ａ）
bb....bb列に指定したaaaa番目の格納条件の条件値に，次のような誤りがあります。
・条件値のデータ型が，格納条件に指定した列のデータ型に変換できません。
・条件値のデータ長が，格納条件に指定した列のデータ長を超えています。
・条件値が論理的に不適格です。
・条件値のデータ内容が不正です。
aaaa：格納条件の順序番号
bb....bb：エラー要因となった格納条件値を指定した列名
(Ｓ)このSQL文を無視します。
(Ｐ)格納条件値を変換できるデータ型に変更して，再度実行してください。
KFPA11747-E
Invalid partitioning condition aaaa for column "bb....bb"　　（Ａ）
分割キーbb....bbに指定したaaaa番目の格納条件に，次のような誤りがあります。
・格納条件を指定順に評価した結果，aaaa番目の格納条件に従って格納する行がありません。
・二つ以上の列に格納条件が指定されました。
・格納条件の文字列の長さが0です。
aaaa：格納条件の順序番号
bb....bb：エラーとなった格納条件値を指定した列名（分割条件を指定した列名が特定できない場合は********が表示されます）
(Ｓ)このSQL文を無視します。
(Ｐ)格納条件として指定した値を修正して，再度実行してください。
KFPA11748-E
Number of defined foreign keys referencing primary key in a table exceeds 255,table=aa....aa."bb....bb"　　（Ａ）
被参照表aa....aa.bb....bbの主キーを参照する外部キーの数が最大数（255）を超えました。
aa....aa：認可識別子
bb....bb：表識別子
(Ｓ)このSQL文を無視します。
(Ｐ)外部キーを定義した表を削除してから，SQL文を再度実行してください。
KFPA11749-E
Duplicate column name "aa....aa" in foreign key bb....bb."cc....cc"　　（Ａ）
外部キーbb....bb.cc....ccの構成列で列名aa....aaが重複しています。
aa....aa：外部キーを構成する列名
bb....bb：認可識別子
cc....cc：制約名
(Ｓ)このSQL文を無視します。
(Ｐ)外部キーを構成する列名が重複しないように修正して，再度実行してください。
KFPA11750-E
Invalid ALLOCATE clause for column "aa....aa"　　（Ａ）
aa....aa列に指定したALLOCATE句に誤りがあります。
列のデータ型が抽象データ型の場合，抽象データ型に含まれるすべてのBLOB属性に対して，それぞれ別のLOB格納用RDエリアを指定する必要があります。又は，指定した抽象データ型のスーパタイプにBLOB属性が定義されています。
aa....aa：ALLOCATE句を指定した列名
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文のALLOCATE句を修正して，再度実行してください。ただし，指定した抽象データ型のスーパタイプにBLOB属性が定義されている場合は，このSQL文は実行できません。
KFPA11752-E
Already connected　　（Ｌ＋Ａ）
既にCONNECT文は発行されています。HiRDBシステムとの接続後に再度CONNECT文は発行できません。
(Ｓ)処理を終了します。
(Ｐ)プログラムを見直し，SQL文の発行順序に誤りがないか確認してください。必要があればこのCONNECT文を削除するか又はこのCONNECT文の前にDISCONNECT文を追加してください。
KFPA11753-E
Invalid option specified for column "aa....aa"　　（Ａ）
aa....aa列のオプション指定に誤りがあります。
・抽象データ型列に対してwith defaultは指定できません。
・プラグイン開発者が提供する抽象データ型の列以外に"PLUGIN"は指定できません。
aa....aa：誤ったオプションが指定された列名
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文中の列定義の指定を修正し，再度実行してください。
KFPA11754-E
Duplicate routine name aa....aa."bb....bb"　　（Ａ）
CREATE INDEXのFOR句で指定したルーチン名が重複しています。
aa....aa：認可識別子
bb....bb：ルーチン識別子
(Ｓ)このSQL文を無視します。
(Ｐ)ルーチン名を修正し，再度実行してください。
KFPA11756-E
No available pages in RDAREA, RDAREA=aa....aa　　（Ａ）
RDエリアのページが不足しました。
aa....aa：空き領域が不足したRDエリア名
(Ｓ)このトランザクションを無効にします。
[対策]次のどれかの対処をしてから，このトランザクション中のSQL文を再度実行してください。
・RDエリアの拡張
pdmodで，不足したRDエリアの容量を拡張してください。
・表の再編成，又はインデクスの一括作成
pdrorgで，該当するRDエリアに格納されている表を再編成してください。又は，インデクスの一括作成を実行してください。
・空きページの解放
pddbstで，該当するRDエリアの状態を解析して，必要であればインデクスに対してpdreclaimを実行してください。また，定義長が256バイト以上の可変長文字列型，BINARY型，及び抽象データ型のデータ，並びに繰返し列の分岐行が格納される場合は，必要であれば表に対してpdreclaimを実行してください。
pdload，又はpdrorgの実行中にこのメッセージが出力された場合，次に示す処理のどれかを実行し，コマンドを再度実行してください。
4. RDエリアの拡張
データベース構成変更ユティリティを使用して，不足したRDエリアの容量を拡張してください。
5. 可変長文字列データの格納方式変更
定義長が256バイト以上のVARCHAR，NVARCHAR，MVARCHARの列がある表で，ノースプリットオプションの指定ができる場合はCREATE TABLEで表を再定義してください。データ格納に必要なページ数が削減できます。
6. 未使用領域比率又は空きページ比率の変更（すぐにRDエリアの拡張ができない場合の対処）
次のどちらかの方法で変更してください。
・CREATE TABLE及びCREATE INDEXに指定したPCTFREEオペランドの指定値を小さくして，表やインデクスを再定義してください。
・データベース作成ユティリティ（pdload），又はデータベース再編成ユティリティ（pdrorg）のoption制御文にtblfree，又はidxfreeオペランドを指定し，指定値をPCTFREEオペランドの指定値よりも小さい値に変更してください。
KFPA11758-E
Invalid "EXCEPT VALUES" for aa....aa　　（Ａ）
指定したインデクスの除外キー値に，次の誤りがあります。
・非ナル値制約の列に対して，除外キー値を構成する値としてNULLを指定しています。
・繰返し列のインデクスに対して，除外キー値を指定しています。
aa....aa：｛CREATE INDEX｜CREATE FOREIGN INDEX｝
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11761-E
PLUGIN for aa....aa."bb....bb" not registered　　（Ａ）
プラグインが登録されていないため，そのSQLは実行できません。
プラグインインデクス定義で指定したインデクス型には，プラグインが登録されている必要があります。
aa....aa：認可識別子
bb....bb：データ型又はインデクス型の識別子
(Ｓ)このSQL文を無視します。
(Ｐ)プラグインを登録した後，再度実行してください。
KFPA11764-E
Number of index columns unequals to number of "EXCEPT VALUES" columns　　（Ａ）
インデクスを構成する列の数と，除外キー値を構成する値の数が一致していません。
(Ｓ)このSQL文を無視します。
(Ｐ)インデクスを構成する列の数と，除外キー値を構成する値の数を同じにして，再度実行してください。
KFPA11766-E
Unable to define aa....aa cc....cc "bb....bb" for specified data type　　（Ａ）
列"bb....bb"にaa....aaは定義できません。
●aa....aaがmulti-valueの場合，次の列は指定できません。
・BLOBの列
・抽象データ型の列
・BINARY型の列
●aa....aaがno-split又はsplitの場合，次の列は指定できません。
・VARCHAR，MVARCHAR，及びNVARCHAR以外の列
●aa....aaがcollating-sequenceの場合，次の列は指定できません。
・CHAR，VARCHAR，MCHAR，MVARCHAR，NCHAR，及びNVARCHAR以外の列
●aa....aaがtrailing-spaceの場合，次の列は指定できません。
・VARCHAR，MVARCHAR，及びNVARCHAR以外の列
aa....aa：次のどれかです。
multi-value：繰返し列
no-split：ノースプリットオプション指定ありの列
split：ノースプリットオプション指定なしの列
collating-sequence：COLLATING-SEQUENCEオプション指定の列
trailing-space：TRAILING-SPACEオプション指定の列
bb....bb：列名
cc....cc：次のどちらかです。
column：列名
attribute：属性
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11769-E
Unable to lock system table　　（Ａ）
システム表，又はシステム表を元の表とするビュー表に対して，LOCK文は実行できません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11770-I
aa....aa [bb....bb cc....cc] currently in use, resource id=dd....dd　　（Ａ）
リソースID　dd....ddで示される資源は，ほかのトランザクションによって占有されています。このため，SQL文又はユティリティが実行できません。
aa....aa：資源種別名
bb....bb：資源名称1
cc....cc：資源名称2
dd....dd：資源情報
資源種別名，資源名称，及び資源情報については，マニュアル「HiRDB Version 7 システム運用ガイド」を参照してください。
(Ｓ)〈SQL文の場合〉
排他オプションにNO WAITを指定している場合はこのSQL文を無視して処理を続行します。それ以外の場合はトランザクションを取り消して無効にします。ただし，NO WAITを指定していてもトランザクションを取り消して無効にすることがあります。詳細については，マニュアル「HiRDB Version 7 SQLリファレンス」のNO WAITオペランドの説明を参照してください。
〈ユティリティの場合〉
処理を終了します。
(Ｐ)SQL文でこのメッセージが頻繁に出力される場合，SQLの排他オプションやUAPの排他制御の見直しを検討してください。詳細については，マニュアル「HiRDB Version 7 SQLリファレンス」の排他オプションの説明や，マニュアル「HiRDB Version 7 UAP開発ガイド」のUAPの設計の説明を参照してください。
(Ｏ)
再度実行してください。タイミングによっては成功することがあります。詳細については，マニュアル「HiRDB Version 7 システム運用ガイド」のデッドロック情報及びタイムアウト情報への対処方法の説明を参照してください。
HiRDB/パラレルサーバで共用表を使用している場合，更新可能バックエンドサーバが開始しているか確認してください。開始していないときは再開始後，再度実行してください。
[対策]排他オプションにNO WAIT及びWITH ROLLBACKを指定していないSQL文に対してこのメッセージが頻繁に出力される場合，pd_lck_wait_timeoutオペランドの指定値の変更を検討してください。
KFPA11771-E
Not specified index RDAREA in same server as table RDAREA　　（Ａ）
指定したインデクス格納用RDエリアは，表格納用RDエリアがあるサーバにはありません。インデクス格納用RDエリアには，クラスタキーのインデクス格納用RDエリア，及び主キーのインデクス格納用RDエリアを含みます。
(Ｓ)このSQL文を無視します。
(Ｐ)表格納用RDエリアがあるサーバのインデクス格納用RDエリアを指定して，再度実行してください。
KFPA11773-E
Invalid specification of base tables for LIST　　（Ａ）
作成しようとするリストの基になる表の指定に，次のような誤りがあります。
・ビュー表を指定している。
・表別名を指定している。
・他RDノードの表を指定している。
・外部表を指定している。
・共用表を指定している。
・WITHOUT ROLLBACKを指定した表を指定している。
(Ｓ)このSQL文を無視します。
(Ｐ)リストの基になる表の指定を修正して，再度実行してください。
KFPA11774-E
Base tables for LIST conflict　　（Ａ）
ASSIGN LIST文で集合演算をする一方のリストの基表が，他方のリストの基表と異なります。
(Ｓ)このSQL文を無視します。
(Ｐ)指定したリストの名前に誤りがあれば，修正して再度実行してください。
KFPA11775-E
Unable to define function "aa....aa"."bb....bb" because of same signature as system function　　（Ａ）
指定した関数"aa....aa"."bb....bb"は，システムが提供する関数と同じ名称であり，かつ同じSQLパラメタの構成のため定義できません。
aa....aa：認可識別子
bb....bb：ルーチン識別子
(Ｓ)このSQL文を無視します。
(Ｐ)ルーチン識別子を変更して，このSQL文を再度実行してください。
KFPA11776-E
Invalid specification in ASSIGN LIST statement　　（Ａ）
ASSIGN LIST文中の指定に次のような誤りがあります。
・探索条件中に四則演算，日付演算，連結演算，スカラ関数，CASE式，CAST指定，又はコンポネント指定を指定しています。
・探索条件中の列を，表名又は相関名で修飾しています。
・探索条件中の比較演算子の両辺に列を指定しています。
・探索条件中のBETWEEN述語の値式２，又は値式３に列を指定しています。
・探索条件中の比較演算子の両辺に，定数，USER，CURRENT_DATE，CURRENT_TIME，又はCURRENT_TIMESTAMPを指定しています。
・探索条件中のIN述語の左辺に，定数，USER，CURRENT_DATE，CURRENT_TIME，又はCURRENT_TIMESTAMPを指定しています。
・探索条件中のBETWEEN述語の値式1に，定数，USER，CURRENT_DATE，CURRENT_TIME，又はCURRENT_TIMESTAMPを指定しています。
・探索条件中のLIKE述語，又はXLIKE述語の左辺に，定数，USER，CURRENT_DATE，CURRENT_TIME，又はCURRENT_TIMESTAMPを指定しています。
・インデクスを使用するロジックを実装したプラグイン関数以外のユーザ定義関数を指定しています。
・探索条件中の繰返し列に，添字ANYを指定していません。
・繰返し列に対する述語を，NOTで否定しています。
・ANDNOTを指定した条件式を，NOTで否定しています。
・IS FALSE，IS UNKNOWNの論理述語を指定しています。
・副問合せを指定したIN述語をNOTで否定しています。
・論理述語をNOTで否定しています。
・リストに，受渡し値を格納できる受渡し値送信関数を二つ以上指定しています。
・受渡し値を格納したリストの集合演算ができません（受渡し値を格納したリストの集合演算については，マニュアル「HiRDB Version 7 UAP開発ガイド」を参照してください）。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11777-E
Unable to execute due to type aa....aa."bb....bb" in use　　（Ａ）
抽象データ型aa....aa."bb....bb"は，ほかのユーザが使用中です。このため，SQL文は実行できません。
aa....aa：認可識別子
bb....bb：データ型識別子
(Ｓ)このSQL文を無視します。
(Ｐ)このSQL文を再度実行してください。
KFPA11778-E
Invalid specification in query with LIST　　（Ａ）
リストを使用した問合せ中の指定に，次のような誤りがあります。
・最も外側の問合せのSELECT句に集合関数を指定しています。
・最も外側の問合せのSELECT句にROWを指定しています。
・最も外側の問合せのSELECT句に表指定.*を指定しています。
・最も外側の問合せのSELECT句に，表修飾ありの列指定を指定しています。
・基表の列に対して外への参照を指定しています。
・ORDER BY句に修飾子付き列名を指定しています。
・受渡し値の格納されていないリストに対して，射影列に受渡し値受信関数を指定しています。
・リストに格納された受渡し値の数より，射影列に受渡し値受信関数を多く指定しています。
(Ｓ)このSQL文を無視します。
(Ｐ)リストを使用したSELECT文を修正して，再度実行してください。
KFPA11780-E
No appropriate index on table aa....aa."bb....bb"　　（Ａ）
ASSIGN LIST文を実行する場合，表aa....aa.”bb....bb”に次のインデクスが定義されていなければなりません。
・探索条件中に指定した列には，インデクス（除外キー値を持つインデクスを除く）が必要です。
・探索条件中に構造化繰返し述語を指定した場合には，構造化繰返し述語の探索条件中に指定した列をすべて構成列に含むインデクスが必要です。
・副問合せを指定したIN述語の列には，単一列インデクスが必要です。
・繰返し列と繰返し列以外の列の両方を構成列に含むインデクスを使用して，繰返し列でない列の述語を評価する場合，繰返し列のどれかの列に条件を指定していればインデクスは使用できます。
・副問合せを指定したIN述語中の列には，次のどちらかのインデクスが定義されていなければなりません。なお，(b)はSQL最適化モードがコストベース最適化モード2の場合に限ります。
(a) 単一列インデクス
(b) 副問合せを指定したIN述語中の列を先頭とする複数列インデクス
副問合せを指定したIN述語中の列が複数列インデクスの先頭でない場合でも，この列より前のインデクス構成列に，比較述語（＝），NULL述語（IS NULL），又は右辺が値指定のIN述語（IN）のどれかが指定されていればかまいません。ただし，繰返し列をインデクス構成列に含むインデクスは除きます。また，右辺が値指定のIN述語（IN）の場合は，値指定の個数が次のどちらかの条件を満たしている必要があります。
・INが1列だけの場合，値指定の個数は5以下
・INが2列以上の場合，それぞれの列に指定した値指定の個数の積が5以下
・探索条件を指定していなければ，その表の任意の列（繰返し列を除く）にインデクス（除外キー値を持つインデクス，及びプラグインインデクスを除く）が必要です。
aa....aa：認可識別子
bb....bb：表識別子
(Ｓ)このSQL文を無視します。
(Ｐ)必要なインデクスを作成した後，ASSIGN LIST文を再度実行してください。
KFPA11781-E
Authorization indentifier unable to specified for LIST　　（Ａ）
リストに対して認可識別子は指定できません。
(Ｓ)このSQL文を無視します。
(Ｐ)リストに指定した認可識別子を削除して，再度実行してください。
KFPA11782-E
Column qualified with table specification in ASSIGN LIST statement　　（Ａ）
ASSIGN LIST文の探索条件中の列名は，表名，又は相関名で修飾できません。
(Ｓ)このSQL文を無視します。
(Ｐ)列名を表名，又は相関名で修飾しないように修正して，再度実行してください。
KFPA11783-E
LIST aa....aa not found in system　　（Ａ）
指定したリストaa....aaがありません。
aa....aa：リストの名前
(Ｓ)このSQL文を無視します。
(Ｐ)リスト名に誤りがあれば，修正して再度実行してください。
リスト名に誤りがなければ，そのリストは作成されていないことになります。この場合，リストを作成した後で，再度実行してください。
KFPA11785-E
List already dropped or altered　　（Ａ）
SQL文中で参照されているリストは既に削除されているか，又は作り直されているため，このSQL文は実行できません。
(Ｓ)このSQL文を無視します。
(Ｐ)参照しているリストが削除される前，又は作り直しの前に，このSQL文を実行するように順序を変更して再度実行してください。順序を変更する必要がなければ，改めて前処理をして，再度実行してください。
KFPA11787-E
Unable to execute "aa....aa" due to existence of bb....bb's LIST "cc....cc" based on the table　　（Ａ）
bb....bbが所有するリスト”cc....cc”の基表に対する操作のため，”aa....aa”を実行できません。
aa....aa：｛DROP TABLE｜ALTER TABLE｜DROP SCHEMA｝
bb....bb：認可識別子
cc....cc：リスト名
(Ｓ)このSQL文を無視します。
(Ｐ)該当する表がユーザ自身のリストとして使用されている場合は，該当する表を基にしているリストをすべて削除した後，再度実行してください。
KFPA11791-E
Number of RDAREAs not equal to that of table partitions　　（Ａ）
指定したインデクス格納RDエリアの数に，次の誤りがあります。
・分割キーインデクスの場合は，横分割表を格納するRDエリアと同じ数のインデクス格納RDエリアを指定してください。
・非分割キーインデクスの場合は，横分割表を格納するRDエリアと同じ数のインデクス格納RDエリアを指定してください。又は，バックエンドサーバ数と同じ数のインデクス格納RDエリアを指定してください。
・TYPEを指定した場合（形式2）は，表格納RDエリアと同じ数のインデクス格納RDエリアを指定してください。
・マトリクス分割表の場合は，マトリクス分割表を格納するRDエリアと同じ数のインデクス格納RDエリアを指定してください。

又は，BLOB型を指定した列及びLOB属性のLOB列格納用RDエリアの数に誤りがあります。
(Ｓ)このSQL文を無視します。
(Ｐ)インデクス格納RDエリア，又はLOB列格納用RDエリアの指定数を一致させて，再度実行してください。
KFPA11793-E
Invalid RDAREA "aa....aa" for index　　（Ａ）
分割指定のインデクス定義時のRDエリア"aa....aa"が，境界値分割した表のRDエリアと対応していません。
aa....aa：対応していないインデクスの格納用RDエリア名
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度ジョブを実行してください。
KFPA11795-E
Number of partitioning aa....aa exceed bbbb　　（Ａ）
表又はインデクスの分割時に指定できる重複排除したRDエリアの数が，最大数を超えました。
aa....aa：処理対象{ table | index }
bbbb：重複排除したRDエリアの最大数（1024）
(Ｓ)このSQL文を無視します。
(Ｐ)重複排除した場合のRDエリアの数を最大値以下に修正して，再度実行してください。
KFPA11796-E
Unable to specify same RDAREA "aa....aa"　　（Ａ）
一つ前の格納RDエリアと同じRDエリアは指定できません。
aa....aa：表格納用RDエリア
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度ジョブを実行してください。
KFPA11797-E
Invalid specification for "WITHOUT ROLLBACK" table　　（Ａ）
WITHOUT ROLLBACKは，次の表に指定できません。
・FIX表でない表
・LOB列を含む表
・LOCK PAGEを指定した表
・外部キーを定義する表
また，WITHOUT ROLLBACKを指定した表に対して，次の指定はできません。
・ALTER TABLEのCHANGE LOCK PAGE
(Ｓ)トランザクションを無効にします。
(Ｐ)実行したSQLがCREATE TABLEの場合，SQL文を修正して再度実行してください。実行したSQLがALTER TABLEの場合，SQL文を削除してください。
KFPA11798-E
Invalid usage of DEFAULT clause for column or SQL variable "aa....aa", code=bb　　（Ａ）
次に示す場合のDEFAULT句の指定が不正です。
・表定義時
・表定義更新時（DEFAULT句設定時，又はDEFAULT句削除時）
・ルーチン定義のSQL変数宣言時
aa....aa：列名
bb：理由コード
01：DEFAULT句とWITH DEFAULTは同時に指定できません。
02：繰返し列にDEFAULT句は指定できません。
06：DEFAULT句として指定できない次の値を指定しています。
・指定された列又はSQL変数のデータ型に変換できない値
・指定された列又はSQL変数の定義長を超える値
・上位有効けたが無効となるような値
07：USERは，CHAR，MCAHR，VARCHAR，及びMVARCHAR以外のデータ型の列又はSQL変数に指定できません。
08：CURRENT_DATE値関数は，DATE又はCHAR(10)以外のデータ型の列又はSQL変数に指定できません。
09：CURRENT_TIME値関数は，TIME又はCHAR(8)以外のデータ型の列又はSQL変数に指定できません。
10：NULLは，非ナル値制約のある列に指定できません。
12：次に示すデータ型の列又はSQL変数にDEFAULT句は指定できません。
・BLOB
・抽象データ型
・32,001バイト以上のBINARY
14：CURRENT_TIMESTAMP値関数は，TIMESTAMP，CHAR(19)，CHAR(22)，CHAR(24)，及びCHAR(26)以外のデータ型の列又はSQL変数に指定できません。
31：DEFAULT句の指定のない列にDROP DEFAULTは指定できません。
32：DEFAULT句の指定のある列にWITH DEFAULTは指定できません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください（理由コードが31及び32の場合，そのSQL文を削除してください）。
KFPA11800-E
Zero diviser in arithmetic operation for aa....aa data type　　（Ａ）
データ型aa....aaの算術演算中に，0による除算が発生しました。
aa....aa：0による除算が発生したデータ型
{ INTEGER | DECIMAL | SMALLFLT | FLOAT | INTERVAL YEAR TO DAY | INTERVAL HOUR TO SECOND | SMALLINT }
(Ｓ)このSQL文を無視します。
(Ｐ)0による除算が発生しないように算術式を変更し，再度実行してください。
KFPA11801-E
Overflow in aa....aa for bb....bb data type　　（Ａ）
データ型bb....bbの演算aa....aaでオーバフローが発生しました。
aa....aa：オーバフローの発生した演算の種類
{ addition | subtraction | division | multiplication | sign inversion | scalar function "INTEGER" | scalar function "DECIMAL" | scalar function "DAYS" | scalar function "DATE" | correction | scalar function "ABS" | scalar function "MOD" | java routine }
bb....bb：オーバフローの発生したデータ型
{ integer | smallint | decimal | smallflt | float | date | interval year to day | time | interval hour to second }
(Ｓ)このSQL文を無視します。
(Ｐ)オーバフローが発生しないように算術式を変更し，再度実行してください。
KFPA11802-E
Overflow in SET FUNCTION "aa....aa" for bb....bb data type　　（Ａ）
列のデータ型がbb....bbである集合関数aa....aaの処理中にオーバフローが発生しました。
・COUNTの場合は，対象データの件数が2147483647を超えました。
・SUM又はAVGの場合は，対象データの加算時にオーバフローが発生しました。
aa....aa：関数の種類
{ SUM | AVG | COUNT }
bb....bb：オーバフローが発生したデータ型
{ integer | smallint | decimal | smallflt | float }
(Ｓ)このSQL文を無視します。
(Ｐ)演算対象のデータ件数を少なくするなど，オーバフローが発生する原因を取り除き，再度実行してください。
KFPA11803-E
Duplicate key value in unique index id=aa....aa　　（Ａ）
UNIQUE指定のインデクス，又は主キーに対して，重複した列値を追加しようとしました。又は，重複した値に列値を更新しようとしました。
aa....aa：インデクス番号
(Ｓ)このSQL文を無視します。
(Ｐ)重複する列値を修正した後，再度SQL文を実行してください。
KFPA11804-E
Invalid operation code aaaa　　（Ａ）
クライアントからのRPCインタフェースが不正です。
・存在しないオペレーションコードを指定しました。
・存在しないシステムタイプを指定しました。
aaaa：オペレーションコード
(Ｓ)この要求を無視します。
(Ｐ)UAPのプリプロセス，コンパイル，又はリンクに誤りがないか確認してください。誤りがなければ，HiRDB管理者に連絡してください。
[対策]保守員に連絡してください。
KFPA11805-E
Invalid section number　　（Ａ）
セクション番号が1～4095の範囲ではありません。
(Ｓ)この要求を無視します。
(Ｐ)UAPのプリプロセス，コンパイル，又はリンクに誤りがないか確認してください。誤りがなければ，HiRDB管理者に連絡してください。
[対策]保守員に連絡してください。
KFPA11806-E
Current number of elements exceeds aa....aa, columnid=bb....bb　　（Ａ）
UPDATE文のADD句で追加した列の要素数が，最大要素数を超えています。
aa....aa：最大要素数
bb....bb：更新対象表の何番目の列がエラーとなったかを示す列番号
(Ｓ)このトランザクションを無効にします。
[対策]ALTER TABLEで列の最大要素数を増やして，再度実行してください。
KFPA11807-E
Invalid update option　　（Ａ）
DECLARE CURSORの更新オプションが不正です。
(Ｓ)この要求を無視します。
(Ｐ)UAPのプリプロセス，コンパイル，又はリンクに誤りがないか確認してください。誤りがなければ，HiRDB管理者に連絡してください。
[対策]保守員に連絡してください。
KFPA11808-E
Row length for work list bbbbbbb exceeds maximum list row length aaaaa　　（Ａ）
行長bbbbbbbが，作業表として格納できる最大行長aaaaaを超えています。
aaaaa：格納できる最大行長
bbbbbbb：格納しようとした行長
(Ｓ)このトランザクションを無効にします。
(Ｐ)SELECT文で指定した列数及び列サイズを見直して，作業表の最大行長を超えないようにしてください。
KFPA11809-I
Row length bb....bb exceeds aa....aa in RDAREA cc....cc　　（Ａ）
INSERT若しくはUPDATE SETを指定した行，又はデータロードしようとした行の格納行長bb....bbが最大行長aa....aaを超えています。
aa....aa：格納できる最大行長
bb....bb：格納しようとした行長
cc....cc：RDエリア名
(Ｓ)このトランザクションを無効にします。
[対策]
〈SQL文で発生した場合〉
表をアンロードした後，ページ長が大きなRDエリアに表を再定義して，リロードしてください。
〈データベース作成ユティリティ（pdload）で発生した場合〉
データベース構成変更ユティリティ（pdmod）でRDエリアの再初期化（ページ長を変更）をしてから，コマンドを再度実行してください。
KFPA11810-E
Duplicate key value detected in unique index while loading index index id=aa....aa　　（Ａ）
UNIQUE指定のインデクス，又は主キーに対してのインデクス作成処理で，重複したキー値を検出しました。
aa....aa：インデクス識別子
(Ｓ)このトランザクションを無効にします。
(Ｐ)インデクスを削除し，重複しているキー値を修正した後，CREATE INDEXを実行してください。表にCLUSTER KEY又はPRIMARY KEYを指定している場合は，pdload実行前に取得しておいたバックアップからRDエリアを回復し，入力データ中の重複している列値を修正した後，再度pdloadを実行してください。
KFPA11811-E
MASTER DIRECTORY RDAREA full　　（Ａ）
マスタディレクトリ用RDエリアに，RDエリア，表，インデクス，及びビュー表を定義できる空き領域がありません。
(Ｓ)処理を無効にして，異常終了します。
[対策]データベース構成変更ユティリティで，マスタディレクトリ用RDエリアを拡張してください。
又は，不要な表又はインデクスを削除した後，再度実行してください。
KFPA11812-E
Number of aaaaa exceeds bbbb in RDAREA "cc....cc"dd....dd　　（Ａ）
指定した表又はインデクスの定義情報が，RDエリアcc....ccに定義できる最大数bbbbを超えています。
又は，リストの定義情報が，閉塞していないリスト用RDエリア（サーバ名dd....dd）に定義できる最大数bbbbを超えています。
aaaaa：定義情報の種別｛TABLE｜INDEX｜LIST｝
bbbb：定義できる最大数
cc....cc：RDエリア名
リスト用RDエリアの場合は********と表示されます。
dd....dd：サーバ名
リスト用RDエリアの場合に，次のように表示されます。
server=サーバ名
(Ｓ)この処理を無効にします。
(Ｐ)次のどちらかの処置をしてください。
・表，又はインデクスを定義しようとした場合
表，若しくはインデクスを，ほかのRDエリアに定義するか，又は該当するRDエリアに定義されている表，若しくはインデクスを削除してください。
・リストを定義しようとした場合
該当するサーバに定義されている不要なリストを削除してください。不要なリストを削除しても同じエラーになる場合は，HiRDB管理者に連絡してください。
[対策]
・リストを定義しようとした場合
データベース構成変更ユティリティ（pdmod）で，該当するサーバにリスト用RDエリアを追加してください。また，リスト用RDエリアが閉塞している場合は，RDエリアの障害を取り除いて，閉塞を解除してください。
なお，リスト用RDエリアに作成できるリスト数に余裕がない場合，次の条件を満たすと一時的にKFPA11812-Eエラーとなることがあります。
・サーバプロセスがプロセスダウンし，クライアントにKFPA11722-Eエラーでリターンした場合の回復処理完了前に，同一ユーザで再接続しASSIGN LIST文を実行した。
KFPA11814-E
DATE DIRECTORY RDAREA full　　（Ａ）
データディレクトリ用RDエリアに，横分割表又はインデクスの管理情報を格納できる空き領域がありません。
(Ｓ)処理を無効にして，異常終了します。
[対策]データベース構成変更ユティリティで，データディレクトリ用RDエリアを拡張してください。
又は，不要なインデクス又は複数のRDエリアに分割格納する表を削除した後，再度実行してください。
KFPA11815-E
aaaaaID not found in DIRECTORY data, RDAREA = "bb....bb" ID = cc....cc　　（Ａ）
処理対象の表，インデクス，又はリストの定義情報が，bb....bbのRDエリア内にありません。
aaaaa：表，インデクス，リストの種別｛TABLE｜INDEX｜LIST｝
bb....bb：RDエリア名
cc....cc：表，インデクス，又はリスト番号
(Ｓ)異常終了します。
[対策]次のどちらかの処置をしてください。
・表，又はインデクスの場合
bb....bbで示すRDエリアについて，運用方法に誤りがないか確認し，RDエリアを回復してください。
・リストの場合
SQL文で指定したリストを再作成してください。
KFPA11821-E
More than aa....aa or invalid length in SQL　　（Ａ）
SQL文の長さがaa....aaバイトを超えています。又は，長さが不正です。
aa....aa：SQL文の長さ
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文の長さを修正し，再度実行してください。
KFPA11823-E
Unable to execute SQL for definition "aa....aa".bb....bb used by pdrbal　　（Ａ）
リバランスユティリティを実行中のため，次のSQLは実行できません。
・ALTER TABLE
・CREATE INDEX（表格納用RDエリアとインデクス格納用RDエリアの数が一致しないインデクスは定義できません）
aa....aa：認可識別子
bb....bb：表識別子
(Ｓ)このSQL文を無視します。
(Ｐ)リバランスユティリティの実行終了後に，再度SQLを実行してください。
KFPA11824-E
Environment group file access error occurred,file name=aa....aa, func=bb....bb, errno=cccc　　（Ａ＋Ｌ）
環境変数グループファイルaa....aaの読み込み処理に失敗しました。
aa....aa：環境変数グループファイル名（ただし，ファイル名が100バイト以上の場合は，後ろから100バイトを出力します）
bb....bb：エラーとなった関数名
fopen：オープン処理
fgets：読み込み処理
stat：ステータス取得処理
cccc：エラーコード（errno）
(Ｓ)処理を終了します。
(Ｐ)エラーコードを基にエラーの原因を取り除いて，操作を再実行してください。
KFPA11827-E
No available LOB DIRECTORY in RDAREA,RDAREA=aa....aa　　（Ａ）
LOB用RDエリアのデータ件数が，RDエリアの管理できるデータ件数を超えました。RDエリアの容量見積もりに，長さ0のデータ容量を加えていない場合に発生することがあります。
aa....aa：該当するRDエリア名
(Ｓ)このSQL文を無視します。
[対策]LOB用RDエリアのデータ管理領域を十分に割り当てるため，該当するRDエリアを見積もり直して，RDエリアを拡張してください。
RDエリアの容量見積もりについては，マニュアル「HiRDB Version 7 システム導入・設計ガイド」を参照してください。
KFPA11828-E
Unable to set non null value at BLOB attribute of sub type because its allocation is not defined, column no=aa....aa, type id=bb....bb, attribute no=cc....cc　　（Ａ）
表定義時にLOB用RDエリア名を指定していないBLOB属性を含む抽象データ型の値は，抽象データ型の列又は抽象データ型の属性に格納できません。
aa....aa：更新対象の表の，何番目の列がエラーとなったかを示す列番号
bb....bb：格納できないBLOB属性を含む抽象データ型の型ID
cc....cc：格納できないBLOB属性が，抽象データ型の何番目の属性かを示す属性番号
(Ｓ)このトランザクションを無効にします。
(Ｐ)エラーとなった列又は属性に対する挿入値又は更新値として，表定義時にLOB用RDエリア名を指定していないBLOB属性を含む抽象データ型の値を，指定しないようにしてください。又は，エラーとなった列の表定義のデータ型を見直してください。
KFPA11829-E
Invalid use of ALIAS aa....aa."bb....bb"　　（Ａ）
表別名aa....aa."bb....bb"の指定方法に，次の誤りがあります。
・自RDノード内の表を基に生成した表別名を指定しています。
aa....aa：認可識別子
bb....bb：表別名
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11836-E
Specified tables must exist in same RDNODE　　（Ａ）
一つのSQL文中に指定する表は，同一のRDノード中にある表を指定します。また，CREATE INDEX中のインデクスは，表と同一のRDノード中に定義します。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA11838-E
Unable to specify "aa....aa" in LOCK TABLE with "UNTIL DISCONNECT"　　（Ａ）
UNTIL DISCONNECTを指定したLOCK文には，他RDノードの表，外部表，及び外部表を基表とするビュー表を指定できません。
aa....aa：｛table on other RDNODE｜foreign table｜view table derived from foreign table｝
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA11839-E
RDNODE name cannot be specified in table specification without specifying local RDNODE name　　（Ａ）
RDノード名を用いて修飾した表名は，自ノードのRDノード名がないため，指定できません。
(Ｓ)このSQL文を無視します。
(Ｐ)RDノード名を用いて修飾している表名のRDノード名を削除してください。又は，システム共通定義に自ノードのRDエリア名を設定してもらうように管理者に連絡し，再度実行してください。
KFPA11841-E
Unable to nest remote access　　（Ａ）
分散データベースアクセスで，分散サーバ側のHiRDBから更に他RDノードへの分散データベースアクセスの要求が発生しました。原因として，分散サーバ側のHiRDBで，SQL文中の表名と同じ名称の表別名が定義されていることが考えられます。
なお，表別名については，マニュアル「HiRDB Version 7 SQLリファレンス」を参照してください。
(Ｓ)このSQL文を無視します。トランザクションが発生している場合にはロールバックします。
(Ｐ)操作対象の表があるRDノードにアクセスするようにUAPを修正してください。
また，分散クライアントがHiRDBの場合，エラーになったSQL文中のRDノード名称を修正するか，エラーになったSQL文中で参照している表別名の定義を修正してください。
KFPA11842-E
Unable to load shared libraries of aa....aa, inf=bb....bb　　（Ａ）
分散データベース機能の前提プログラムの共用ライブラリが読めません。
aa....aa：前提プログラムの名称と共用ライブラリの名称
bb....bb：保守情報
(Ｓ)このSQL文を無視します。
[対策]エラーの原因を次に示します。
（1）関連プログラムの共用ライブラリがない。
（2）関連プログラムの共用ライブラリの内容が不正。
（3）関連プログラムの読み取り，又は実行パーミッションが拒否された。
（4）関連プログラムの共用ライブラリをロードするのに十分なメモリの空き領域がない。
関連プログラムが正しくインストールされているか確認してください。
〈正しくインストールされていない場合〉
UAPを停止してインストールした後，UAPを再度実行してください。
〈正しくインストールされている場合〉
システムの負荷を軽減してUAPを再度実行してください。
〈エラーが繰り返し発生する場合〉
保守員に連絡してください。
KFPA11843-E
Unable to connect to DF/UX, reason code=aa....aa　　（Ａ）
クライアント機能が，DF/UXと接続できません。
aa....aa：DF/UXの理由コード
(Ｓ)このSQL文を無視します。
(Ｐ)DF/UXの理由コードを参照して，対策してください。DF/UXの理由コードについてはマニュアル「分散データベース　DF/UX」を参照してください。
KFPA11845-E
Invalid use of RDAREA "aa....aa" error code=b　　（Ａ）
次のどれかの誤りがあります。
・error code=1の場合
指定したユーザ用RDエリアには，リバランス表が格納されているため，ほかの表及びインデクスは格納できません。
・error code=2の場合
指定したユーザ用RDエリアには，既にほかの表又はインデクスが格納されているため，リバランス表は格納できません。
・error code=3の場合
リバランス表にインデクスを定義する場合，インデクス格納用RDエリアの指定は省略できません。
aa....aa：RDエリア名
b：エラーコード
(Ｓ)このSQL文を無視します。
(Ｐ)
・error code=1及び2の場合
指定したRDエリア名を変更して，再度SQLを実行してください。
・error code=3の場合
インデクス格納用RDエリアを指定して，再度SQLを実行してください。
KFPA11848-E
specified RDNODE not connected　　（Ａ）
RDノード指定DISCONNECT文又はSET CONNECTION文で指定したRDノードは接続されていません。
(Ｓ)このSQL文を無視します。
(Ｐ)RDノード名称に誤りがないか確認してください。RDノード名称が正しい場合，プログラムを見直して，次のように修正してください。
〈RDノード指定DISCONNECT文の場合〉
不要なRDノード指定DISCONNECT文を削除してください。
〈SET CONNECTION文の場合〉
SET CONNECTION文を発行する前に，そのRDノードに接続するRDノード指定CONNECT文を発行してください。
SQLCODE=-849
SQLCODE=-849に対応するHiRDBのメッセージはありません。
このSQLCODEは，分散サーバ側のHiRDBが返したものではありません。
このSQLCODEは，分散クライアントがORACLEの場合に，分散クライアント側のDF/UXでエラーが発生したことを示します。
DF/UXでは，SQLCODEコードとともに，エラーの原因を示す理由コードを出力します。詳細については，マニュアル「分散データベース　DF/UX」を参照してください。
KFPA11850-E
SQLDA was modified after first blocked fetch　　（Ａ）
一括検索を指定したFETCH文を複数回実行する場合は，FETCH文のパラメタに指定するSQL記述領域の内容を変更しないでください。
(Ｓ)このSQL文を無視します。
(Ｐ)一括検索を指定して複数回FETCH文を実行するときは，同じSQL記述領域の内容を繰り返すように修正してください。
KFPA11855-E
Unable to execute remote access SQL, REASON=aa....aa　　（Ａ）
aa....aaに示す理由のため，リモートアクセスできません。
aa....aa：理由の詳細
MAX RDNODE：
同時に接続できる分散サーバの最大数を超えています。
CHARACTER SET NOT SUPPORTED：
自システムの現在の文字コード種別ではリモートアクセスできません。
DF NOT SUPPORTED：
このHiRDBでは分散データベース機能を使用できません。
(Ｓ)このSQL文を無視します。
(Ｐ)次に示す処置をしてください。
・MAX RDNODEの場合
同時に接続する分散サーバの数が，同時に接続できる分散サーバの最大数を超えないようにしてください。HiRDB分散クライアント機能では，一つのUAPが同時に接続できる分散サーバは一つに限定されます。
・CHARACTER SET NOT SUPPORTED
リモートアクセスをしないようにしてください。
・DF NOT SUPPORTED
リモートアクセスをしないでください。
[対策]次に示す処置をしてください。
・CHARACTER SET NOT SUPPORTED又はDF NOT SUPPORTED
分散データベース機能は使用できないため，シングルサーバ定義又はフロントエンドサーバ定義のpd_node_nameオペランドを削除してください。
KFPA11856-E
Invalid number of variables from server system, reason code=aa　　（Ａ）
一括検索を使用したリモートアクセスでサーバシステムから渡された検索結果に不正があります。このため，該当する処理ができません。
aa：理由コード
(Ｓ)このSQL文を無視します。
[対策]サーバに接続できる状態かどうかを調査してください。ユーザが判断できない場合，保守員に連絡してください。
理由コード
意味
00
SQL DBL RESULT VALUES数が1未満です。
又は，クライアントが指定したRepetitioncountを超えています。
01
SQL VALUES数がクライアントの指定した検索項目数と一致しません。
02
サーバシステムで，繰り返し処理中にSQLエラーが発生したにもかかわらず，FETCH処理を打ち切っていません。
03
サーバからSQLCODE=0が返されたにもかかわらず，検索結果が返されていません。
KFPA11857-E
Data aa....aa of variable bb....bb is not supported in remote access　　（Ａ）
次のどれかの誤りがあります。
・SQL文中の変数にリモートアクセスでサポートされていないデータ型が指定されています。
・サーバ側のシステムでサポートされていないデータ型又はデータ長が指定されています。
・繰返し構造の変数が指定されています。
aa....aa：エラーの種別
type：データ型がサポートされていません。
length：データ長がサポートされていません。
structure：データ構造（繰返し構造）がサポートされていません。
bb....bb：変数の順序番号
(Ｓ)このSQL文を無視します。
(Ｐ)次のどれかの処置をしてください。
・SQL文中で使用している変数のデータ型を見直し，リモートアクセスでサポートされているデータ型の変数を指定してください。
・サーバ側のシステムでサポートされているデータ型又はデータ長を指定してください。
・繰返し構造の変数は使用しないようにしてください。
KFPA11858-E
Unable to use aa....aa in remote access　　（Ａ）
リモートアクセスでは，aa....aaは使用できません。
aa....aa：WRITE specification
(Ｓ)このSQL文を無視します。
(Ｐ)このSQL文を修正し，再度実行してください。
KFPA11860-E
Negative SQLCODE received from server during remote access, SQLCODE=aa....aa, SQLSTATE=bb....bb, server= cc....cc, process ID= dd....dd, connection ID= ee....ee, RMID= ff....ff　　（Ａ）
リモートデータベースアクセスで，分散サーバ側のシステム又は分散クライアント側のDF/UX Extensionから負のSQLコードが返されました。
aa....aa：分散サーバ側のシステム又は分散クライアント側のDF/UX Extensionから返されたSQLコード。分散サーバ側のシステムから返されたSQLCODEの場合，SQLCODEの意味はサーバシステムに従います。
bb....bb：分散サーバ側のシステム又は分散クライアント側のDF/UX Extensionから返されたSQLSTATE。分散サーバ側のシステムから返されたSQLSTATEの場合，SQLSTATEの意味はサーバシステムに従います。
cc....cc：分散サーバのDBMS種別を示す文字列。内容は分散サーバ側のシステムが設定します。表示できないときはアスタリスク’*’（1文字）を表示します。
dd....dd：シングルサーバ又はフロントエンドサーバのプロセスID
ee....ee：HiRDBとDF/UXとのコネクションID
表示できないときは，アスタリスク’*’（1文字）を表示します。
ff....ff：HiRDBからDF/UXに渡すRMID
表示できないときは，アスタリスク’*’（1文字）を表示します。
(Ｓ)このSQL文を無視します。
(Ｏ)マニュアル「DF/UXプロトコル拡張機能 DF/UX Extension」を参照して，DF/UX Extensionが設定したSQLCODEかどうかを確認してください。
〈DF/UX Extensionが設定したSQLCODEの場合〉
マニュアル「DF/UXプロトコル拡張機能 DF/UX Extension」を参照してエラーの原因を取り除いた後，再度実行してください。
〈DF/UX Extensionが設定したSQLCODEでない場合〉
分散サーバ側のシステムのマニュアルを参照してエラーの原因を取り除いた後，再度実行してください。
KFPA11861-E
Negative SQLCODE received from server during remote access,SQLCODE=aa....aa,error text=bb....bb　　（Ａ）
リモートアクセスで，サーバ側のシステムから負のSQLコードが返されました。
aa....aa：サーバ側のシステムから返されたSQLコード，SQLCODEの意味はサーバシステムに従います。
bb....bb：ERROR TEXT. SQLコードの内容を補足する情報で，内容はサーバシステムが任意に設定します。
〈ERROR TEXTがない場合〉
アスタリスク’*’（1文字）を表示します。
〈文字数が104文字を超える場合〉
104文字目にシャープ’＃’（1文字）を表示します。
サーバシステムがHiRDBの場合は，メッセージの可変部が設定されます。可変部が複数ある場合は，可変部1 可変部2・・・の形式で表示します。サーバシステムがXDM/RDの場合には，以下の情報を設定します。各情報の詳細は，マニュアル「VOS3 データマネジメントシステム XDM E2系 XDM/RD E2　SQLリファレンス」を参照してください。
SQLERRMC：XDM/RDからのリターンコードに対応する詳細情報（XDM/RDのSQLCA内情報）
ただし，サーバシステムがXDM/RD E2 01-02以降のときは，マニュアル「VOS3 データマネジメントシステム XDM E2系　メッセージ（XDM/RD E2）」を参照してください。
サーバシステムがORACLEの場合には，マニュアル「分散データベース　SQLゲートウェイ　DF/SQL for ORACLE」を参照してください。
サーバシステムがRDB1 E2の場合には，マニュアル「VOS1 データマネジメントシステム RDB1 E2 使用の手引」を参照してください。
サーバシステムがSQL/Kの場合には，マニュアル「VOSK/FS SQL/K」及び，SQL/Kの取扱説明書を参照してください。
(Ｓ)このSQL文を無視します。
(Ｏ)SQL連絡領域（SQLDA）内のSQLCAIDEの内容を参照し，サーバシステム種別を確認してください。
なお，該当するサーバシステムのマニュアルを基に，SQLコードを参照し，エラーの原因を取り除いた後，再度実行してください。
KFPA11862-E
Remote access error occurred, OSI-RDA service code=aaa, reason code=bbb, text=cc....cc, process ID=dd....dd, connection ID=ee....ee, RMID=ff....ff　　（Ａ）
OSI-RDAリモートアクセスでRDAエラーが発生しました。
aaa：RDAのサービスコード
RDAのサービスコードを次に示します。
サービスコード
エラーの発生したRDAサービス
0
R-initialize
1
R-Terminate
2
R-Begin　Transaction
3
R-Commit
4
R-Rollback
5
R-Cancel
6
R-Status
7
R-Open
8
R-Close
9
R-ExecuteDBL
10
R-DefineDBL
11
R-InvokeDBL
12
R-DropDBL
bbb：理由コード
理由コードと意味を次に示します。
理由コード
意味
0
Access Control Violation:アクセス制御の違反
1
Bad Repetition Count:繰り返し回数の不正
2
Command Handle Unknown:コマンドハンドルが不明
3
Control Authentication Failure:制御サービスの認証失敗
4
Control Service Not Allowed:制御サービスの未許可
5
Data Resource Already Open:データ資源オープン済み
6
Deta Resource Handle Not Specified:データ資源ハンドルの未設定
7
Data Resource Handle Unknown:データ資源ハンドルが不明
8
Data Resource Name Not Specified:データ資源名の未設定
9
Data Resource Not Available:データ資源の利用不可
10
Data Resource Unknown:データ資源が不明
11
Dialogue ID Unknown:ダイアログ識別子が不明
12
Duplicate Command Handle：コマンドハンドルの重複
13
Duplicate Data Resource Handle：データ資源ハンドルの重複
14
Duplicate Dialogue ID：ダイアログ識別子の重複
15
Duplicate Operation ID：オペレーション識別子の重複
16
Invalid Sequence：順序不正
17
No Data Resoruce Available：全データ資源の利用不可
18
Operation Aborted：オペレーションの中断
19
Operation Cancelled：オペレーションのキャンセル
20
Service Not Negotiated：サービス非折衝
21
Transaction Rolled Back：トランザクションのロールバック
22
User Authentication Failure：利用者の認証失敗
23
Host Identifier Error：ホスト変数の誤り
24
Invalid SQL Conformance Level：SQLコンフォーマンスレベルの誤り
25
RDA Transaction Not Open：RDAトランザクション未オープン
26
RDA Transaction Open：RDAトランザクションオープン済み
27
SQL Access Control Violation：SQLアクセス制御違反
28
SQL Database Resource Already Open：SQLデータベース資源オープン済み
29
SQL DBA ArgumentCount Mismatch：SQL引数・数不一致
30
SQL DBA Argument Type Mismatch：SQL引数・型不一致
31
SQL DBA NO Char Set：Char Setなし
32
SQL DBA Transaction Statement Not Allowed：SQLトランザクション文未許可
33
SQL Usage Mode Violation：SQL使用モード違反
cc....cc：可変部
理由コードbbbに対応するサーバのメッセージの可変部です。
〈可変部がない場合〉
アスタリスク’*’を表示します。
〈可変部が複数ある場合〉
可変部1 可変部2の形式で表示します。
〈文字数が75文字を超えた場合〉
75文字目にシャープ’＃’を表示します。
理由コードbbbに対応するメッセージの可変部の詳細を次に示します。
理由
コード
可変部1
可変部2
5
RDノード名称
－
16
Invalid Sequenceの発生理由を次に示すコードで補足説明します。
なお，出力されないときは，’*’を表示します。
1…dialogue Not Active
2…dialogue Initializing
3…dialogue Already Active
4…transaction Not Open
5…Transaction Open
6…transaction terminating
7…dialogue terminating
－
9
18
21
エラーが一時的か永久的かを示します。
TRANSIENT：一時的エラー
PERMANENT：永久的エラー
diagnostic Information（エラーの発生理由を補足説明するメッセージ）を出力します。内容は，サーバシステムが設定したものです。
なお，出力されない場合，’*’を表示します。
また，サーバが次に示すDBMSの場合，それぞれのマニュアルを参照してください。
〈サーバシステムがXDM/RDの場合〉
マニュアル「VOS3 データマネジメントシステム XDM E2系 プログラム作成の手引（XDM/RD E2）」，又は「VOS3 データマネジメントシステム XDM E2系　メッセージ（XDM/RD E2）」を参照してください。
〈サーバシステムがORACLEの場合〉
マニュアル「分散データベース　SQLゲートウェイ　DF/SQL　for　ORACLE」を参照してください。
そのほか
*
－
（凡例）－：該当しません。
dd....dd：シングルサーバ又はフロントエンドサーバのプロセスID
ee....ee：HiRDBとDF/UXとのコネクションID
表示できないときは，’*’を表示します。
ff....ff：HiRDBからDF/UXに渡すRMID
表示できないときは，’*’を表示します。
(Ｓ)このSQL文を無視します。
(Ｐ)理由コードに従って対処してください。
理由
コード
サーバがHiRDBの場合の処置
サーバがHiRDB以外の場合の処置
21
diagnostic Informationに，次のメッセージが設定されます。
HITACHI HiRDB
MSGID=aa....aa,
TEXT=bb....bb
aa....aa：HiRDBのメッセージID
bb....bb：メッセージの可変部
（可変部がない場合，*が設定されます）
MSGIDとTEXTで示されるメッセージを参照して，エラーの原因を取り除くか，HiRDB管理者に連絡してください。
HiRDB管理者に連絡してください。
〈サーバシステムがXDM/RDの場合〉
diagnostic Informationに次のメッセージが設定されます。
HITACHI　XDM/RD　SQLICODE=aaaaa SQLERRM=bb....bb
aaaaa：SQLICODE（XDM/RDからのリターンコード（XDM/RDの SQLIOA内情報））
bb....bb：SQLERRMC（XDM/RDからのリターンコードに対応する詳細情報（XDM/RDの SQLCA内情報））
各情報の詳細は，「VOS3 データマネジメントシステム XDM E2系 XDM/RD E2　SQLリファレンス」を参照してください。
〈サーバシステムがORACLEの場合〉
diagnostic Informationに次に示すメッセージが設定されます。
ORACLE SQLCODE=aa....aa bb....bb
aa....aa：ORACLEの SQLCODEを示します。
bb....bb：ORACLEのエラーメッセージを示します。なお，最終文字が’＄’であった場合，エラーメッセージの切り捨てが発生したことを示します。
ORACLEのSQLCODE，エラーメッセージについては，ORACLEのマニュアルを参照してください。
22
HiRDB管理者に連絡してください。
クライアントで指定した認可識別子又はパスワードがサーバシステムに登録されていません。認可識別子又はパスワードを修正するか，又はHiRDB管理者に連絡して，サーバシステムに認可識別子とパスワードを登録してください。
上記以外
HiRDB管理者に連絡してください。
(Ｏ)理由コードに従って対策してください。
理由
コード
サーバがHiRDBの場合の処置
サーバがHiRDB以外の場合の処置
9
UAPを再度実行してください。繰り返しこのメッセージが出力される場合，HiRDB管理者に連絡してください。
HiRDB管理者に連絡してください。
21
diagnostic　Informationのメッセージを参照して，プログラマ又はHiRDB管理者に連絡してください。
22
プログラマに連絡してください。
上記以外
HiRDB管理者に連絡してください。
[対策]理由コードに従って対策してください。
理由
コード
サーバがHiRDBの場合の処置
サーバがHiRDB以外の場合の処置
1
繰り返し回数にゼロ又は負の値が指定されています。保守員に連絡してください。
保守員に連絡してください。
21
diagnostic Informationのメッセージを参照して，エラーの原因を調査してください。又は，保守員に連絡してください。
22
必要があればサーバシステムの管理者に認可識別子とパスワードを登録するように依頼してください。
上記以外
保守員に連絡してください。
KFPA11863-E
Specified application context in DF/UX not supported　　（Ａ）
DF/UXで指定した応用コンテキストによるリモートアクセスはできません。
(Ｓ)このSQL文を無視します。
[対策]DF/UXで指定する応用コンテキストをサポートされているものに修正してください。DF/UXで指定する応用コンテキストについては，マニュアル「分散データベースDF/UX」を参照してください。
KFPA11864-E
Error occurred in remote access, reason code=aaa, bb....bb　　（Ａ）
リモートデータベースアクセス処理中にエラーが発生しました。
aaa：理由コード
bb....bb：理由コードaaaに対応する詳細情報。詳細情報がないときは，アスタリスク*を表示します。
理由コードと意味，詳細情報を次に示します。
理由
コード
意味
詳細情報
１
UAPで使用しているセクション数（実行するSQL文の数）が，DF/UX Extensionの最大セクション数を超えています。
DF/UX Extensionの最大セクション数
２
UAPで使用しているカーソル数が，DF/UX Extensionの最大カーソル数を超えています。
DF/UX Extensionの最大カーソル数
３
出力領域不足が発生しました。
必要な出力領域長
(Ｓ)このSQL文を無視します。
(Ｐ)理由コードに従って対処してください。
理由
コード
プログラマの処置
１
UAPで使用するセクション数を減らして，再度実行してください。
２
UAPで使用するカーソル数を減らして，再度実行してください。
３
検索データの列数，データ型，データ長が誤っていることが考えられます。
修正してから再度実行してください。
KFPA11865-E
Negotiation failed due to aa....aa　　（Ａ）
リモートアクセスで，サーバシステムとの折衝に失敗しました。このため，リモートアクセスができません。
aa....aa：リモートアクセスができない理由
(1)IMMEDIATE-DBL：
サーバシステムが即時実行型DBLを受け付けません。
(2)INVALID SQLCONFORMANCE LEVEL：
クライアントHiRDBのサポートしていないSQL CONFORMANCE LEVELが返されました。
(3)NO SQLCONFORMANCE LEVEL：
SQLCONFORMANCE LEVELが返されないため，リモートアクセスはできません。
(4)SQLCONFORMANCE LEVEL：
(2)又は(3)のエラーが返されたにもかかわらず，再度リモートアクセスを試みました。
(5)CHARSET NOT SUPPORTED （CLIENT）：
サーバから要求されたCHARSET（文字コード）は，クライアントでは使用できません。
(6)CHARSET NOT SUPPORTED （SERVER）：
クライアントから要求されたCHARSET（文字コード）は，サーバでは使用できません。
(7)CHARSET NOT SUPPORTED：
(5)又は(6)のエラーが返されたにもかかわらず，再度リモートアクセスを試みました。
(Ｓ)このSQL文を無視します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]サーバがHiRDBと接続できるシステムかどうかを確認してください。
KFPA11866-E
Invalid data received from server system reason code=aaa, No=bb....bb, inf=cc....cc　　（Ａ）
リモートアクセスで，サーバシステムから返された検索結果に不正があります
aaa：理由コード
理由コード一覧を次に示します。
理由
コード
意味
1
サーバから返されたデータのデータ型が，クライアントが要求したデータ型と異なります。
2
サーバから返されたデータの個数が，クライアントの要求したデータの個数と異なります。
3
サーバから返されたデータ型が不正です。
4
サーバから返されたデータの値が不正です。
5
サーバから返されたデータ長が不正です。
6
サーバから返された標識変数の値が不正です。
7
サーバ側から未サポートのデータ型が返されました。
8
サーバ側から許容範囲外のデータの値が返されました。
9
データがありません。
bb....bb：エラーの発生した出力変数の列番号
ただし，エラーコードが2の場合は，サーバから返されたデータの個数を表示します。
cc....cc：保守情報
(Ｓ)このSQL文を無視します。
[対策]サーバシステム側のデータが検索できるかどうかを確認してください。
KFPA11867-E
Unable to execute specified SQL in remote access　　（Ａ）
指定したSQL文は，次に示す理由でリモートアクセスが実行できません。
・分散データベース機能でサポートされていない種類のSQLです。
・ほかのRDノードへ問合せ指定をした一つの動的SELECT文に対して，複数のカーソルを宣言又は割り当ててオープンしました。
・ホールダブルカーソルを使用しました。
(Ｓ)このSQL文を無視します。
(Ｐ)リモートアクセスで実行できるSQL文を使用してください。又は，一つの動的SELECT文に対するカーソル宣言又はカーソル割り当てが一つになるようにUAPを修正してください。ホールダブルカーソルを使用している場合は，ホールダブルカーソルを使用しないようにUAPを修正してください。
KFPA11875-E
Specified index already created　　（Ａ）
既に作成したインデクスに対して，インデクス一括作成を実行しようとしています。
(Ｓ)指定したインデクスに対するインデクス一括作成を無視して，処理を続行します。
[対策]インデクス一括作成を実行する必要はありません。
KFPA11876-E
Unable to assign index information file due to not defined “pd_plugin_ixmk_dir",server name=aa....aa　　（Ａ）
プラグインインデクスの遅延一括作成をする指定をしているのに，インデクス情報ファイルを作成するディレクトリ名称又はHiRDBファイルシステム領域を，aa....aaのサーバ定義のpd_plugin_ixmk_dirオペランドに指定していません。このため，インデクス情報ファイルが作成できません。
aa....aa：サーバ名称
(Ｓ)トランザクションを無効にします。
(Ｐ)プラグインインデクスの遅延一括作成をしない場合は，クライアント環境定義にPDPLGIXMK＝NOを指定してください。
[対策]プラグインインデクスの遅延一括作成をする場合は，aa....aaのサーバ定義のpd_plugin_ixmk_dirオペランドにインデクス情報ファイル作成用のディレクトリ名称又はHiRDBファイルシステム領域を指定してください。
KFPA11877-E
Unable to assign index information file due to no such directory,server name=aa....aa,directory name=bb....bb　　（Ａ）
aa....aaのサーバ定義のpd_plugin_ixmk_dirオペランドに指定したインデクス情報ファイル用のディレクトリ又はHiRDBファイルシステム領域（bb....bb）が作成されていません。このため，インデクス情報ファイルが作成できません。
aa....aa：サーバ名称
bb....bb：pd_plugin_ixmk_dirオペランドに指定したインデクス情報ファイル用のディレクトリ又はHiRDBファイルシステム領域の名称
(Ｓ)トランザクションを無効にします。
(Ｐ)プラグインインデクスの遅延一括作成をしない場合は，クライアント環境定義にPDPLGIXMK＝NOを指定してください。
[対策]プラグインインデクスの遅延一括作成をする場合は，aa....aaのサーバ定義のpd_plugin_ixmk_dirオペランドに指定した，インデクス情報ファイル作成用のディレクトリ又はHiRDBファイルシステム領域を作成してください。
又は，aa....aaのサーバ定義のpd_plugin_ixmk_dirオペランドにインデクス情報ファイル作成用のディレクトリ又はHiRDBファイルシステム領域の名称を指定してください。
KFPA11878-E
Index information file not available,file=aa....aa,server name=bb....bb　　（Ａ）
ファイル名aa....aaのインデクス情報ファイルの内容とデータベースの状態が不整合になっています。
aa....aa：インデクス情報ファイル名称
インデクス情報ファイル名称が81文字以上の場合は，ファイル名称の後ろから80文字を出力します。
bb....bb：サーバ名称
(Ｓ)トランザクションを無効にします。
[対策]
ユティリティの場合：
同時に同じインデクス情報ファイルを使用しているユティリティがないかどうか確認し，データベース作成ユティリティ，データベース再編成ユティリティ，又はリバランスユティリティを再度実行してください。
UAPの場合：
インデクス情報ファイルが，プラグインインデクスの一括作成ができない状態になっているため，データベース再編成ユティリティ（pdrorg -k ixrcコマンド）で，プラグインインデクスを再作成してください。
KFPA11879-E
Index aa....aa in cc....cc must be bb....bb to access table　　（Ａ）
RDエリアcc....ccに格納されているインデクスaa....aaが，一括作成されていません。
又は，インデクスが使用できない状態（インデクス未完状態）のため，表へのアクセスができません。
aa....aa：アクセスしたインデクス番号
bb....bb：インデクス一括作成を示すコード
{ loaded }
cc....cc：インデクスを格納するRDエリア名称
(Ｓ)このSQL文を無視します。又は，トランザクションを無効にします。
[対策]インデクス一括作成（pdrorg　-k　ixmk　-t　表名　制御情報ファイル名）を実行した後，このトランザクション中のSQL文を再度実行してください。
KFPA11880-E
Index information file open error,file name =aa....aa errno=bb....bb　　（Ａ）
インデクス情報ファイルの作成時，インデクス情報ファイルのオープンに失敗しました。
aa....aa：インデクス情報ファイル名称
bb....bb：エラーコード
HiRDBファイルシステム領域でエラーが発生した場合は，HiRDBファイルシステム領域のエラーコードが表示されます。HiRDBファイルシステム領域のエラーコードについては，「HiRDBファイルシステムに対するアクセス要求から返されるエラーコード」を参照してください。
(Ｓ)このユティリティを無効にします。
[対策]エラーコード（エラーの状態を表す外部整数変数）を基に，errno.h及びOSのマニュアルを参照してエラーの要因を調査し，次のエラー要因一覧に従って対策してください。その後，再度データベース作成ユティリティ，データベース再編成ユティリティ，リバランスユティリティ，又はUAPを実行してください。
エラーの要因
意味
対策
ENOENT,ENAMETOOLONG
ファイル名称不正
正しいインデクス情報ファイル名称及びパスを指定してください。
EMFILE
1プロセス当たりのファイルオープン数の上限に達しました。
OSパラメタの1プロセス当たりのファイルオープン数の見積もりを見直すか，又はインデクス作成方法をインデクス更新モード（-i　s）にして，再度実行してください。
KFPA11881-E
Index information file aa....aa error, file name=bb....bb errno=cc....cc　　（Ａ）
インデクス情報ファイルの作成時，インデクス情報ファイルに対する処理aa....aaに失敗しました。
aa....aa：エラー種別
bb....bb：インデクス情報ファイル名称
cc....cc：エラーコード
HiRDBファイルシステム領域でエラーが発生した場合は，HiRDBファイルシステム領域のエラーコードが表示されます。HiRDBファイルシステム領域のエラーコードについては，「HiRDBファイルシステムに対するアクセス要求から返されるエラーコード」を参照してください。
(Ｓ)このユティリティ，又はUAPを無効にします。
[対策]エラーコード（エラーの状態を表す外部整数変数）を基に，errno.h及びOSのマニュアルを参照してエラーの要因を調査し，次のエラー要因一覧に従って対策してください。
●その後の処置
ユティリティの場合：
再度データベース作成ユティリティ，データベース再編成ユティリティ，又はリバランスユティリティを実行して，新しいインデクス情報ファイルを作成し，インデクスを作成してください。
UAPの場合：
エラーコードがEIOの場合は，インデクスを再作成してください。それ以外の場合は，再度UAPを実行してください。
エラーの要因
意味
対策
ENOSPC
インデクス情報ファイルがあるディレクトリに空きがなくなりました。
該当するディレクトリから不要なファイルを削除してください。
KFPA11882-E
System call error func=aa....aa, errno=bb....bb　　（Ａ）
インデクス情報ファイル作成時，システムコールエラーが発生しました。
aa....aa：システムコール種別
bb....bb：エラーコード
(Ｓ)このユティリティを無効にします。
[対策]エラーコード（エラーの状態を表す外部整数変数）を調査し，errno.h及びユーザが使用するOSのマニュアルを参照してエラーの要因を取り除き，再度データベース作成ユティリティ又はデータベース再編成ユティリティを実行してください。
KFPA11883-E
Unable to use index records in aa....aa for bb....bb. cc....cc　　（Ａ）
指定したインデクス情報ファイルの内容が表中のデータと一致しません。このため，インデクス情報ファイルを使用したインデクス一括作成ができません。
aa....aa：インデクス情報ファイルの名称
bb....bb：認可識別子
cc....cc：表識別子
(Ｓ)指定したインデクスに対するインデクス一括作成を無視して，処理を続行します。
[対策]インデクス一括作成を指定したインデクスが必要な場合は，表の再編成（pdrorg　-k　rorg　-t　表名　制御情報ファイル名）を実行してください。
KFPA11884-E
Index information file used by other job filename=aa....aa　　（Ａ）
ほかのプロセスでアクセス中のファイルaa....aaをインデクス情報ファイルに指定して，データベース作成ユティリティ，データベース再編成ユティリティ，又はリバランスユティリティを実行しようとしました。
aa....aa：インデクス情報ファイル名称
(Ｓ)このユティリティを無効にします。
[対策]インデクス情報ファイル名称を変更し，再度データベース作成ユティリティ，データベース再編成ユティリティ，又はリバランスユティリティを実行してください。
KFPA11886-E
Multi-value columns in multi-column index must have same number of elements [, indexid=aa....aa]　　（Ａ）
インデクスを構成する複数の繰返し列の，各要素の数が一致しないため，次のSQL文及びユティリティが実行できません。
・CREATE INDEX
・INSERT文
・UPDATE文
・データベース作成ユティリティ（pdload）
(Ｓ)このトランザクションを無効にします。
(Ｐ)インデクスを構成する複数の繰返し列の，各要素の数が一致するように修正して，再度実行してください。
KFPA11890-E
Unable to call PLUGIN aa....aa, reason code="bb....bb"　　（Ａ）
プラグインaa....aaはbb....bbの理由で呼び出せませんでした。
aa....aa：プラグイン名
bb....bb：理由コード
UNAVAILABLE：プラグインaa....aaは利用できません。
UNDEFINED：プラグインaa....aaに対するpdpluginが定義されていません。又は，プラグインの初期化処理でエラーが発生しました。
(Ｓ)SQLの実行によって，このエラーが発生した場合は，SQLの実行を中止します。
[対策]
〈理由コードが"UNAVAILABLE"の場合〉
このメッセージの前に出力されているKFPYnnnnn（nnnnn：5けたのメッセージ番号）のメッセージに従って対策してください。又は，プラグインaa....aaが不要なSQL文だけを実行してください。
〈理由コードが"UNDEFINED"の場合〉
HiRDBを停止し，システム共通定義にプラグインaa....aaの利用宣言（pdpluginオペランド）を記述して，HiRDBを開始してください。
それ以外のときは，このメッセージの前に出力されているKFPYnnnnn（nnnnn：5けたのメッセージ番号）のメッセージに従って対策してください。
又は，プラグインaa....aaが不要なSQL文だけを実行してください。
KFPA11891-E
Unable to access LOB RDAREA, RDAREA name=aa....aa, tableID=bb....bb, reason code=c　　（Ａ）
表IDbb....bbのLOB用RDエリアaa....aaは理由コードcのためにアクセスできません。
aa....aa：アクセスしたRDエリア名称
bb....bb：アクセスした表番号
c：LOB用RDエリアの状態を示す理由コード
1：LOB用RDエリア初期化状態
3：LOB用RDエリアがデータ未完状態
(Ｓ)このトランザクションを無効にします。
(Ｏ)理由コードが1の場合は，PURGE TABLE文，pdload（-d指定），又はLOB用RDエリアに対応する表格納RDエリアの再初期化のどれかを実行し，使用できる状態にしてください。理由コードが3の場合は，バックアップからLOB用RDエリアを回復して，使用できる状態にしてください。
KFPA11892-E
Too many duplicate element values within row in index on Multi-value column, index id=aa....aa　　（Ａ）
繰返し列中の同一行内の重複要素数が，繰返し列のインデクスのキー重複数の上限を超えました。
aa....aa：
操作系SQLを実行した場合：インデクスID
CREATE INDEX又はインデクス一括作成を実行した場合：CREATE
(Ｓ)このトランザクションを無効にします。
(Ｐ)操作系SQLを実行した場合：
インデクスを定義している繰返し列に指定したデータを見直し，1行当たりの要素の重複数が次の計算式の値を超えないようにしてください。
重複数＝↓(↓インデクス格納RDエリアのページサイズ×0.95↓－82)÷4↓－1
(Ｏ)CREATE INDEX又はインデクス一括作成を実行した場合：
インデクスを定義しようとした繰返し列のデータを見直して，1行当たりの要素の重複数が次の計算式で求めた値を超えないようにしてください。
重複数＝↓(↓インデクス格納RDエリアのページサイズ×0.95↓－82)÷4↓－1
KFPA11893-E
RDAREA not specified for aa....aa bb....bb　　（Ａ）
ALTER TABLE ADD RDAREAのインデクス，主キー，クラスタキー，又は列に対して，格納用のRDエリア名を指定していません。
aa....aa：｛INDEX | CLUSTER KEY | PRIMARY KEY | COLUMN｝
bb....bb：
・aa....aaがINDEXの場合
"インデクス識別子"
・aa....aaがCOLUMNの場合
"列名"
・aa....aaがCLUSTER KEY又はPRIMARY KEYの場合
何も出力されません。
(Ｓ)このSQL文を無視します。
(Ｏ)格納用のRDエリアを指定して，再度実行してください。
KFPA11894-E
Duplicate aa....aa "bb....bb" specified　　（Ａ）
ALTER TABLE ADD RDAREAで，同じ列名又はインデクス名を2回以上指定しています。
aa....aa：｛INDEX | COLUMN｝
bb....bb：
・aa....aaがINDEXの場合
"インデクス識別子"
・aa....aaがCOLUMNの場合
"列名"
(Ｓ)このSQL文を無視します。
(Ｏ)2回以上指定している同じ列名又はインデクス名を一つにして，再度実行してください。
KFPA11895-E
Failed to load PLUGIN, shared library=aa....aa, external function=bb....bb, reason=cc....cc　　（Ａ）
プラグインのロードに失敗しました。
aa....aa：共用ライブラリ名称※
bb....bb：外部ルーチン名称※
注※
共用ライブラリ名称，外部ルーチン名称が64バイト以下の場合は，名称全体を出力し，64バイトを超える場合は，先頭62バイトに2バイトのピリオド（..）を付けて出力します。
cc....cc：エラーの理由
NO LIBRARY：指定したライブラリがありません。
NO FUNCTION：指定した外部ルーチンがありません。
NO PERMISSION：ライブラリに対するアクセス権がありません。
NO SPACE：ライブラリをロードする領域がないか，メモリ不足が発生しました。
BROKEN：ライブラリでないファイルを指定しているか，ライブラリが壊れています。
(Ｓ)このSQL文を無視します。又は，トランザクションを無効にします。
[対策]
〈cc....ccがNO LIBRARYの場合〉
存在するライブラリ名を指定して，再度実行してください。
〈cc....ccがNO FUNCTIONの場合〉
存在する外部ルーチン名を指定して，再度実行してください。
〈cc....ccがNO PERMISSIONの場合〉
アクセス権を与えて，再度実行してください。
〈cc....ccがNO SPACEの場合〉
UAPを再度実行してください。再度このエラーが発生する場合は，HiRDB管理者に連絡してください。
〈cc....ccがBROKENの場合〉
正しいライブラリを指定して，再度実行してください。
KFPA11896-E
Invalid return information for PLUGIN function, shared library=aa....aa, external function=bb....bb　　（Ｅ＋Ｌ）
プラグイン実装関数からの返却情報が不正です。
aa....aa：プラグインの共用ライブラリ名称※
bb....bb：プラグイン実装関数名（外部ルーチン名称）※
注※
共用ライブラリ名称，プラグイン実装関数名が64バイト以下の場合は，名称全体を出力し，64バイトを超える場合は，先頭62バイトに2バイトのピリオド（..）を付けて出力します。
(Ｓ)異常終了します。
(Ｐ)HiRDB管理者に連絡してください。
[対策]保守員に連絡してください。
KFPA11897-E
Registry access error,code=a　　（Ａ）
code=１の場合は，参照しているレジストリ情報が更新されたため，処理が続行できません。
code=２の場合は，ほかのプロセスで参照しているレジストリ情報を更新しようとしました。
ａ：エラーコード
(Ｓ)処理を終了します。
(Ｐ)code=1の場合は再度SQLを実行してください。code=2の場合はエラーとなったコマンドを再度実行してください。
KFPA11898-E
Unable to add RDAREA for column "bb....bb"　　（Ａ）
ALTER TABLEで指定した列に，次のどれかの誤りがあります。
・BLOB型以外の列，又は抽象データ型以外の列です。
・BLOB型にALLOCATE句を指定しています。
・抽象データ型の列にALLOCATE句を指定しないで，格納用のRDエリアを指定しています。
aa....aa：誤りがある列名
(Ｓ)このSQL文を無視します。
(Ｐ)誤りがある列の指定を修正し，再度実行してください。
KFPA11900-E
Thread lock error occurs in management for LIST　　（Ａ）
リスト管理で排他制御エラーが発生しました。
(Ｓ)次のどちらかの処理をします。
・SQL文の場合
このSQL文を無視します。
・pdmodの場合
処理を続行します。
(Ｐ)次のどちらかの処置をしてください。
・SQL文の場合
再度SQLを実行してください。
・pdmodの場合
リストを再作成してください。
KFPA11901-E
Execution or reference of SQL requested without normal preparation　　（Ａ）
動的に実行するSQL文の前処理が正常に終了する前に，そのSQL文の実行が要求されました。
又は，カーソル宣言（形式1）で指定した問合せに対するFETCH文若しくはCLOSE文を，カーソルオープン時の前処理が正常終了する前に実行しました。
(Ｓ)このSQL文を無視します。
(Ｐ)前処理を正常終了させて，再度UAPを実行してください。
KFPA11902-E
Unable to grant access privileges except SELECT privilege on audit trail table　　（Ａ）
監査人以外のユーザに対して，監査証跡表又は監査証跡表を基にしたビュー表のINSERT権限，UPDATE権限，及びDELETE権限を与えられません。
(Ｓ)このSQL文を無視します。
(Ｐ)監査人以外のユーザに対して与える監査証跡表，又は監査証跡表を基にしたビュー表の権限をSELECT権限だけとし，再度実行してください。
KFPA11903-E
Unable to grant DBA or connect privilege to auditor aa....aa　　（Ａ）
監査人aa....aaにはDBA権限を与えられません。又は，監査人aa....aaのパスワードはGRANT CONNECTで変更できません。
aa....aa：監査人の認可識別子
(Ｓ)このSQL文を無視します。
(Ｐ)DBA権限を与えるユーザは監査人以外としてください。又は，監査人のパスワードはGRANT AUDITで変更してください。
KFPA11904-E
Unable to grant RDAREA use privileges for RDAREA "aa....aa" because only auditor has privilege to use this RDAREA　　（Ａ）
監査人だけが監査証跡表を格納するRDエリアの利用権限を持てます。監査人以外のユーザには監査証跡表を格納するRDエリアの利用権限を与えられません。
aa....aa：RDエリア名
(Ｓ)このSQL文を無視します。
(Ｐ)ほかのRDエリアの利用権限を与えてください。
KFPA11905-E
Unable to execute aa....aa due to lack of audit privilege　　（Ａ）
監査権限がないためaa....aaの操作を実行できません。
aa....aa：次に示すどれかが表示されます。
・"CREATE AUDIT"
・"DROP AUDIT"
・"GRANT AUDIT"
・"DROP TABLE" for audit trail table
(Ｓ)このSQL文を無視します。
(Ｐ)この操作は監査人が実行してください。
KFPA11906-E
Unable to execute "DROP SCHEMA" due to audit trail table existence　　（Ａ）
監査証跡表があるため監査人のスキーマを削除できません。
(Ｓ)このSQL文を無視します。
(Ｐ)監査人のスキーマを削除する場合は，監査証跡表を削除した後に実行してください。
KFPA11907-E
Unable to revoke schema or connect privilege of auditor　　（Ａ）
監査人のスキーマ定義権限及びCONNECT権限は削除できません。
(Ｓ)このSQL文を無視します。
(Ｐ)権限の削除対象者が正しいか確認してください。監査人の権限を削除する場合はほかの権限を削除してください。
KFPA11908-E
Duplicate audit for "aa....aa" whenever "bb....bb" audittype "cc....cc"　　（Ａ）
CREATE AUDITで指定した監査対象イベントは既に定義されています。
aa....aa：操作種別及びイベント種別
<TBLATT POSITION="1" SCALE="126.5">
操作種別
イベント種別
ANY
該当しません。
SESSION
CONNECT
AUTHORIZATION
ANY
PRIVILEGE
GRANT
REVOKE
ANY
DEFINITION
CREATE
DROP
ALTER
ANY
ACCESS
SELECT
INSERT
UPDATE
DELETE
PURGE
ASSIGN
CALL
LOCK
ANY
UTILITY
PDLOAD
PDRORG
PDEXP
ANY
注　操作種別とイベント種別の間にはスペースが表示されます。
bb....bb：WHENEVER句で指定した値
ANY
SUCCESSFUL
UNSUCCESSFUL
cc....cc：AUDITTYPE句で指定した値
ANY
PRIVILEGE
EVENT
(Ｓ)このSQL文を無視します。
(Ｐ)監査対象イベントを変更して再実行してください。
KFPA11909-E
Specified audit for "aa....aa" whenever "bb....bb" audittype "cc....cc" not defined　　（Ａ）
DROP AUDITで指定した監査対象イベントは定義されていません。
aa....aa：操作種別及びイベント種別
<TBLATT POSITION="1" SCALE="126.5">
操作種別
イベント種別
ANY
該当しません。
SESSION
CONNECT
AUTHORIZATION
ANY
PRIVILEGE
GRANT
REVOKE
ANY
DEFINITION
CREATE
DROP
ALTER
ANY
ACCESS
SELECT
INSERT
UPDATE
DELETE
PURGE
ASSIGN
CALL
LOCK
ANY
UTILITY
PDLOAD
PDRORG
PDEXP
ANY
注　操作種別とイベント種別の間にはスペースが表示されます。
bb....bb：WHENEVER句で指定した値
ANY
SUCCESSFUL
UNSUCCESSFUL
cc....cc：AUDITTYPE句で指定した値
ANY
PRIVILEGE
EVENT
(Ｓ)このSQL文を無視します。
(Ｐ)監査対象イベントを変更して再実行してください。
KFPA11911-E
Deadlock occurred on aa....aa resource id=bb....bb　　（Ａ）
デッドロックが発生しました。
aa....aa：資源種別名
bb....bb：資源情報
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を再度実行してください。
KFPA11912-E
Insufficient memory for DB exclusive control　　（Ａ）
排他制御のための作業領域が不足しました。
(Ｓ)このSQL文を無視します。又は，ユティリティの処理を打ち切ります。
(Ｐ)
〈SQLの実行で発生した場合〉
（1）現状のリソース排他状況を調べてください。負荷が低くなるまで待ってから再度実行してください。
（2）(1)と同様のエラーが発生する場合
クライアント環境定義のPDLOCKLIMITを指定している場合，許容できる範囲で指定値を増やしてください。
又は，設定しないで再度実行してください。
この場合，再度このエラーメッセージが出力されるときは，(3)の処理をしてください。
（3）次に示す観点でプログラムを見直してください。
1. LOCK文を指定できないか，検討してください。なお，更新系のSQL文の場合，EXCLUSIVEを指定してください。
2. WITHOUT LOCK NOWAITを指定できないか，検討してください。プログラムを修正できる場合は，修正して実行してください。そのほかの場合，HiRDB管理者に連絡してください。
〈pdload，pdrorg，又はpdrbalの実行で発生した場合〉
（1）現状のリソース排他状況を調べてください。負荷が低くなるまで待ってから再度実行してください。
（2）負荷が低い状態でも発生する場合は，該当表をユティリティで処理するだけの排他資源管理テーブルが確保できない状態となっています。pd_lck_pool_sizeオペランド，又はpd_lck_until_disconnect_cntオペランドの指定値を増やす必要があるため，HiRDB管理者に依頼してください。指定値については，マニュアル「HiRDB Version 7 コマンドリファレンス」の「データベース作成ユティリティ実行中に必要となるサーバ当たりの排他資源」又は「データベース再編成ユティリティ実行中に必要となるサーバ当たりの排他資源」を参照してください。
[対策]syslogfile（Windows NTの場合はイベントログ），又はメッセージログファイルに出力されるKFPS00443-I，KFPS00444-Iメッセージに従って対処してください。
なお，KFPS00443-I，KFPS00444-Iメッセージが出力されていない場合は，表排他用資源が不足しています。システム共通定義のpd_max_access_tablesオペランドの指定値を増やして，HiRDBを開始してください。
KFPA11913-E
DB exclusive control error occurred on aa....aa resource id=bb....bb code=cc....cc　　（Ａ）
排他制御中にエラーが発生しました。
aa....aa：資源種別名
bb....bb：資源情報
cc....cc：エラーコード
(Ｓ)このSQL文を無視します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]保守員に連絡してください。
KFPA11914-E
Insufficient memory on DYNAMIC_SHMPOOL for DB exclusive control　　（Ａ）
排他制御で使用する共用メモリが不足しました。
(Ｓ)このSQL文を無視します。
(Ｐ)LOCK TABLEのUNTIL DISCONNECT指定を削除できないか検討してください。
[対策]サーバ定義中のpd_lck_until_disconnect_cntの値が不適切です。見直しをして，現状の値よりも大きくしてから，システムを再度開始してください。
KFPA11917-E
Closed RDAREA "aa....aa"　　（Ａ）
RDエリアがクローズ状態です。
aa....aa：RDエリア名
(Ｓ)処理を終了します。
(Ｐ)HiRDB管理者に連絡してください。
[対策]pdopenコマンドでRDエリアをオープン状態にしてください。
KFPA11918-E
Global buffer pool undefined, RDAREA="aa....aa"　　（Ａ）
グローバルバッファプールが定義されていません。
aa....aa：RDエリア名
(Ｓ)処理を終了します。
(Ｐ)HiRDB管理者に連絡してください。
[対策]システム共通定義のpdbufferオペランドで，該当するRDエリアにグローバルバッファプールを割り当ててください。
KFPA11919-E
Insufficient global buffer, global buffer pool=aa....aa　　（Ａ）
グローバルバッファ面数が不足しています。
aa....aa：グローバルバッファプール名称
(Ｓ)処理を終了します。
(Ｐ)UAPを再度実行してください。再度このエラーが発生する場合，HiRDB管理者に連絡してください。
[対策]バッファ面数の見積もりを見直して，システム共通定義のpdbufferオペランドでバッファ面数を変更してください。
KFPA11920-E
RDAREA "aa....aa" held　　（Ａ）
RDエリアが閉塞されています。又は，障害発生のため閉塞しました。
aa....aa：RDエリア名
(Ｓ)処理を終了します。
(Ｐ)HiRDB管理者に連絡してください。RDエリア閉塞を解除した後，再度UAPを実行してください。
[対策]障害閉塞の場合は，RDエリアをデータベース回復ユティリティで回復した後，pdrelsコマンドで閉塞状態を解除してください。コマンド閉塞の場合は，pdrelsコマンドで閉塞状態を解除してください。
KFPA11928-I
RDAREA aa....aa held pdhold command in process　　（Ｌ）
指定したRDエリアaa....aaは，pdholdコマンドによって閉塞処理中です。
aa....aa：RDエリア名
(Ｓ)このトランザクションを無効にします。
[対策]RDエリアを回復し，再度このトランザクションを実行してください。
KFPA11929-E
Insufficient work pool, size=aa....aa, pool size=bb....bb　　（Ａ）
SQL文を処理するために必要なメモリプール枠のサイズが不足しています。
aa....aa：確保しようとした領域の大きさ（単位：バイト）
bb....bb：メモリプール枠の大きさ（単位：バイト）
(Ｓ)このSQL文を無視します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]保守員に連絡してください。
KFPA11930-E
Insufficient memory on aa....aa, size=bb....bb　　（Ａ）
SQL文を処理するためのメモリが不足しています。
aa....aa：領域の種別を示す文字列
PROCESS：プロセス固有領域
SHARED：共有メモリ
bb....bb：確保しようとした領域の大きさ（単位：バイト）
領域の大きさが特定できない場合，********となります。
(Ｓ)このSQL文を無視します。サーバプロセスが起動中の場合，プロセスの起動を中止します。
(Ｐ)UAPを再度実行してください。再度このエラーが発生する場合は，HiRDB管理者に連絡してください。
[対策]次の方法で，使用できるメモリに余裕を持たせてください。
・同時実行しているプロセス数を減らしてください。
・スワップ領域を増やしてください。
・実メモリを増設してください。
・サーバ定義のpd_work_buff_sizeオペランドの指定値が大きい場合，指定値を減らしてください。
サーバプロセスの起動時に，このメッセージが出力される場合は，サーバの常駐プロセス数pd_process_countを少なくしてください。
KFPA11931-E
Insufficient pd_max_access_tables,resource id=aa....aa,resource count=bb....bb　　（Ａ）
システム共通定義で指定したpd_max_access_tablesオペランドの値（同時アクセス可能実表数）を超えて，表をアクセスしました。
aa....aa：保守情報
bb....bb：保守情報
(Ｓ)処理中のトランザクションを無効にします。
(Ｐ)commit文の発行回数を増やして，再度実行してください。再度このメッセージが出力される場合，HiRDB管理者に連絡してください。
[対策]システム共通定義のpd_max_access_tablesオペランドの指定値を超える前に，COMMIT文を発行しているか確認してください。又は，pd_max_access_tablesオペランドの値が，システム全体で適切かどうか見直してください。
KFPA11932-E
Number of connect users exceeded max users　　（Ａ）
HiRDBサーバへの接続数が最大同時接続数を超えました。又は，pdchprcコマンドで起動サーバ数が0に変更されています。
(Ｓ)このSQL文を無視します。ただし，ユティリティを実行している場合，処理を終了します。
(Ｐ)ほかのユーザの終了を待って，再度UAP，ユティリティを実行します。ユーザの接続状態は，pdls -d actコマンドで確認できます。
[対策]
HiRDBが稼働中の場合の処置：
次の手順で対策してください。
1. SDS又はFESの最大起動プロセス数（pdchprcコマンドで確認できます）を大きくできる場合，pdchprcコマンドでの最大起動プロセス数を，同時に実行するUAP，ユティリティ，及び追い付き反映処理のプロセス※の総数以上に設定してください。
注※
追い付き反映処理のプロセスの，総数の算出式を次に示します。
n
a=Σ((pdorend -sのサーバ数)×(pdorend -mの指定値))
i=1
n：pdorendコマンドの同時実行数
2. SDS又はFESの最大起動プロセス数が，同時に実行するUAP，ユティリティ，及び追い付き反映処理のプロセスの総数未満の場合，次の対策を実施してください。
(1) UAP又はユティリティの実行でこのメッセージが出力された場合
同時に実行するUAP及びユティリティの数を減らしてください。
(2) pdorendコマンドの実行でこのメッセージが出力された場合（このメッセージ出力後にKFPH27043-E, code=-52が出力された場合）
次の対策を実施してください。
(a) pdorendコマンドの同時実行数を減らしてください。
(b) pdorendコマンドの各実行時での，同時実行サーバ数（-sオプションに指定したサーバ数）を減らしてください。
(c) pdorendコマンドの各実行時での，反映プロセス多重度（-mオプションの指定値）を小さくしてください。
次回正常開始前の処置：
・UAP又はユティリティの実行でこのメッセージが出力された場合
できるのであれば，pd_max_usersオペランドの指定値を大きくしてください。
特に接続を保証したいUAP又はユティリティ（pddefだけ該当）に対しては，システム定義のpdcltgrpオペランドを指定してください。
・pdorendコマンドの実行でこのメッセージが出力された場合（このメッセージ出力後にKFPH27043-E, code=-52が出力された場合）
システム定義のpd_max_reflect_process_countオペランドの指定値を大きくしてください。
KFPA11934-E
Insufficient memory on communication header, size=aa....aa or communication buffer, size=bb....bb　　（Ａ）
通信用バッファのメモリが不足しました。
aa....aa：確保しようとした通信用ヘッダサイズ
bb....bb：確保しようとした通信用バッファサイズ
(Ｓ)このトランザクションを無効にします。
(Ｐ)再度UAPを実行してください。再度このエラーが発生する場合は，HiRDB管理者に連絡してください。
[対策]保守員に連絡してください。
KFPA11935-E
Unable to execute definition SQL for executing data processing SQL　　（Ａ）
操作系SQLを発行したトランザクション内で，定義系SQLは発行できません。
(Ｓ)このSQL文を無視します。
(Ｐ)操作系SQLを発行した後，定義系SQLを発行したい場合は，コミット（COMMIT）文を記述した後，定義系SQLを記述してください。
KFPA11937-E
Unable to execute this SQL in XA environment　　（Ａ）
XA環境では，このSQL文を実行できません。
(Ｓ)このSQL文を無視します。
(Ｐ)このSQL文を削除してください。
KFPA11938-E
Unable to modify attributes of abstract data type which value is NULL　　（Ａ）
ナル値である抽象データ型は，コンストラクタ関数によって値が生成されていないため，その属性を更新できません。
(Ｓ)このSQL文を無視します。
(Ｐ)コンストラクタ関数によって値を生成した後に，抽象データ型の属性を更新してください。
KFPA11939-E
Total length of attributes of abstract data type too long　　（Ａ）
定義した抽象データ型の属性の合計長が大き過ぎます。
(Ｓ)このSQL文を無視します。
(Ｐ)属性の数を減らすなどして属性の合計長を小さくし，再度SQL文を実行してください。合計長の見積もり式，及び合計長の最大値については，マニュアル「HiRDB Version 7 SQLリファレンス」の「CREATE TYPEの共通規則」を参照してください。
KFPA11940-E
Connect command ignored, HiRDB is initializing or terminating　　（Ａ）
HiRDBが開始処理中又は終了処理中のため，HiRDBに接続できません。
(Ｓ)このSQL文を無視します。
(Ｏ)HiRDBが開始処理中のときは，開始処理終了後に再度UAPを実行してください。
HiRDBが終了処理中のときは，再度HiRDBを開始後にUAPを実行してください。
KFPA11941-E
HiRDB is under termination process　　（Ａ）
HiRDB終了処理中に，実行要求をしています。
(Ｓ)HiRDBから切り離します。
(Ｐ)UAPを終了してください。
(Ｏ)再度HiRDBを開始後に，UAPを実行してください。
KFPA11945-E
Unable to expand stack area for thread. size=aa....aa　　（Ａ）
スレッドのスタック領域をaa....aaバイト拡張しようとしましたが，拡張できませんでした。
aa....aa：拡張しようとした大きさ（単位：バイト）
領域の大きさが特定できない場合，********となります。
(Ｓ)このSQL文を無視します。又は，トランザクションを無効にします。
(Ｐ)HiRDB管理者に連絡してください。
(Ｏ)HiRDB管理者に連絡してください。
[対策]システム共通定義中のスレッドスタックサイズ上限オプション"pd_thread_max_stack_size"の上限値を増やしてください。
KFPA11948-E
Unable to aa....aa bb....bb without cc....cc　　（Ａ）
cc....ccが組み込まれていないため，bb....bbはaa....aaできません。
bb....bbがroutine，procedure，functionの場合，HiRDB Object Optionが組み込まれていないため，CREATE TYPE中で定義されているbb....bbはaa....aaできません。
bb....bbがroutine using foreign tableの場合，HiRDB External Data Accessが組み込まれていないため，外部表に定義されているルーチンは呼び出せません。
bb....bbが"PARTITIONED BY MULTIDIM"の場合，HiRDB Advanced Partitioning Optionが組み込まれていないため，マトリクス分割表を定義できません。
aa....aa：｛specify｝｛use｝｛invoke｜alter｜drop｝
bb....bb：｛"ALTER TYPE" statement｜"CREATE TYPE" statement
｜"DROP DATA TYPE" statement
｜"ALTER INDEX TYPE" statement
｜"CREATE INDEX TYPE" statement
｜"DROP INDEX TYPE" statement
｜"PARTITIONED BY MULTIDIM"
｜"ALTER TABLE CHANGE RDAREA" statement
｜"CREATE SERVER" statement
｜"DROP SERVER" statement
｜"CREATE FOREIGN TABLE"statement
｜"DROP FOREIGN TABLE" statement
｜"CREATE FOREIGN INDEX" statement
｜"DROP FOREIGN INDEX" statement
｜"CREATE USER MAPPING" statement
｜"DROP USER MAPPING" statement｝
｛PLUGIN｜user data type｜foreign table｝
｛procedure｜routine｜function｜routine using foreign table｝
cc....cc：｛Object Option｜External Data Access｜Advanced Partitioning Option｝
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を削除してください。又はcc....ccのオプション（HiRDB Object Option，HiRDB External Data Access又はHiRDB Advanced Partitioning Option）を組み込んだ後，SQL文を再度実行してください。aa....aaがdropで，bb....bbがprocedure，functionの場合，このSQL文を削除するか，HiRDB Object Optionを組み込んだ後，指定ルーチンを含む抽象データ型の定義を削除するSQL文を実行してください。
KFPA11950-E
Unable to aa....aa due to using bb....bb without cc....cc　　（Ａ）
cc....ccがObject Optionの場合：
HiRDB Object Optionが組み込まれていないため，次のことができません。
・bb....bbを使用したaa....aaはできません。
・bb....bbを使用している表又はインデクスを対象としたaa....aaはできません。
cc....ccがdirectory serverの場合：
ディレクトリサーバと連携していないため，bb....bbを使用したaa....aaはできません。
cc....ccがExternal Data Accessの場合：
HiRDB External Data Accessが組み込まれていないため，bb....bbを使用したaa....aaはできません。
aa....aa：｛create table｜create index｜create trigger｜drop table｜drop index｜drop schema｜drop trigger｜alter table｜use table｜invoke routine｜grant access｜revoke access｝
bb....bb：｛user data type｜indextype｜group｜foreign table｝
cc....cc：｛Object Option｜directory server｜External Data Access｝
(Ｓ)このSQL文を無視します。
(Ｐ)次に示すどれかの処置をしてください。
・cc....ccがObject Optionの場合
SQL文を削除してください。又はHiRDB Object Optionを組み込んだ後にSQL文を再度実行してください。
・cc....ccがdirectory serverの場合
ディレクトリサーバと連携させた後にSQL文を再度実行してください。
・cc....ccがExternal Data Accessの場合
SQL文を削除してください。又はHiRDB External Data Accessを組み込んだ後にSQL文を再度実行してください。
KFPA11952-E
Unable to aa....aa due to insufficient bb....bb　　（Ａ）
aa....aaで定義した値を超えて，次の処理をしようとしました。
・リストの作成
・外部サーバの定義
aa....aa：｛assign LIST｜create server｝
bb....bb：定義オペランド名｛pd_max_list_users｜pd_max_list_count｜pd_max_foreign_server｝
(Ｓ)このSQL文を無視します。
(Ｐ)
bb....bbがpd_max_list_usersの場合：
このSQL文は実行できません。このSQL文を実行したい場合は，pd_max_list_usersオペランドの指定値を大きくしてください。
bb....bbがpd_max_list_countの場合：
不要なリストを削除して再度実行するか，又はpd_max_list_countオペランドの指定値を大きくして再度実行してください。
bb....bbがpd_max_foreign_serverの場合：
このSQL文は実行できないため，削除してください。
[対策]システム定義のbb....bbの値が適切かどうかを見直してください。
KFPA11953-E
Unable to execute aa....aa due to bb....bb,cc....cc　　（Ａ＋Ｌ）
理由bb....bbで，処理aa....aaは実行できません。
aa....aa：処理（[対策]を参照してください）
bb....bb：理由（[対策]を参照してください）
cc....cc：付加情報（[対策]を参照してください）
(Ｓ)このトランザクションを取り消します。
[対策]
処理(aa....aa)
理由(bb....bb)
付加情報(cc....cc)
対策
HASH JOIN
ハッシュジョイン，副問合せのハッシュ実行
insufficient work buffer
作業表用バッファ不足
size=dd....dd,server=ee....ee
dd....dd：不足したサイズ（単位：キロバイト）
ee....ee：サーバ名
なお，不足サイズに表示されるのは，最初に不足を検知した箇所の不足サイズであり，全体の不足サイズではありません。
次のどちらかの対策をしてください。
・pd_work_buf_sizeオペランド又はpd_work_buff_expand_limitオペランドの指定値を増やしてください。又は，クライアント環境定義のPDHASHTBLSIZE若しくはpd_hash_table_sizeオペランドの指定値を減らしてください。
・クライアント環境定義のPDADDITIONALOPTLVL又はpd_additional_optimize_levelオペランドで，「ハッシュジョイン，副問合せのハッシュ実行」を選択しないようにしてください。また，SQL文中に結合方式のSQL最適化指定，及び副問合せ実行方式のSQL最適化指定に「HASH」を指定していないようにしてください。
invalid work buffer mode
作業表用バッファの確保方式不正
server=dd....dd
dd....dd：サーバ名
次のどちらかの対策をしてください。
・pd_work_buf_modeオペランドにpoolを指定してください。
・クライアント環境定義のPDADDITIONALOPTLVL又はpd_additional_optimize_levelオペランドで，「ハッシュジョイン，副問合せのハッシュ実行」を選択しないようにしてください。また，SQL文中に結合方式のSQL最適化指定，及び副問合せ実行方式のSQL最適化指定に「HASH」を指定していないようにしてください。
insufficient memory
プロセス固有領域不足
size=dd..dd,server=ee..ee,pid=ff..ff
dd..dd：該当プロセスでの作業表用バッファ総サイズ（単位：キロバイト）
ee..ee：サーバ名
ff..ff：プロセスID
pd_work_buff_expand_limitオペランドの指定に従って作業表用バッファを増分確保しようとしたが，プロセス固有領域が不足したためできませんでした。次のどれかの対策をして，使用できるメモリに余裕を持たせてください。
・同時実行しているプロセス数を減らしてください。
・スワップ領域を増やしてください。
・実メモリを増設してください。
又は，次のどちらかの対策をして，作業表用バッファの使用量を減らしてください。
・クライアント環境定義のPDHASHTBLSIZEオペランド又はpd_hash_table_sizeオペランドの値を減らしてください。
・クライアント環境定義のPDADDITIONALOPTLVLオペランド，pd_additional_optimize_levelオペランド，及びSQLコンパイルオプションのADD OPTIMIZE LEVELで「ハッシュジョイン，副問合せのハッシュ実行の適用」を使用しないようにするとともに，SQL文中に結合方式のSQL最適化指定，及び副問合せ実行方式のSQL最適化指定に「HASH」を指定しないようにしてください。
KFPA11958-E
No work HiRDB file system area　　（Ａ）
使用できる作業表格納用のHiRDBファイルシステム領域が指定されていません。
(Ｓ)このトランザクションを無効にします。
[対策]〈データベース初期設定ユティリティ実行時の場合〉
ディクショナリサーバ定義又はシングルサーバ定義に，pdworkオペランドで作業表格納用のHiRDBファイルシステム領域を設定し，再度データベース初期設定ユティリティを実行してください。
〈サーバ開始時の場合〉
サーバ定義に，pdworkオペランドで作業表格納用のHiRDBファイルシステム領域を設定し，再度サーバを開始してください。
KFPA11959-E
HiRDB file "aa....aa" failed, return code=bbbbb,HiRDB file name=cc....cc　　（Ａ）
HiRDBファイルcc....ccに対するaa....aaがリターンコードbbbbbで終了しました。
aa....aa：HiRDBファイルシステムの機能
close：HiRDBファイルのクローズ
create：HiRDBファイルの作成
expand：HiRDBファイルの拡張
open：HiRDBファイルのオープン
read：HiRDBファイルからの読み込み
write：HiRDBファイルへの書き込み
bbbbb：リターンコード
cc....cc：HiRDBファイルシステム領域名/HiRDBファイル名称
HiRDBファイルのパス名が144文字以上の場合は，HiRDBファイルのパス名の後ろから143文字を出力します。
(Ｓ)このトランザクションを無効にします。
(Ｐ)HiRDB管理者に連絡してください。
[対策]
〈データベース初期設定ユティリティ実行時，aa....aaがexpandの場合〉
サーバ定義のpdworkオペランドに増分指定のないHiRDBファイルシステム領域を指定しているときは，増分指定をしたHiRDBファイルシステム領域を指定して，再度データベース初期設定ユティリティを実行してください。増分指定をしたHiRDBファイルシステム領域を指定しているにもかかわらずこのメッセージが出力される場合は，サーバ定義のpdworkオペランドに増分回数を増やしたHiRDBファイルシステム領域か，又は領域長を増やしたHiRDBファイルシステム領域を指定して，再度データベース初期設定ユティリティを実行してください。
〈データベース初期設定ユティリティ以外で，aa....aaがexpandの場合〉
サーバ定義のpdworkオペランドに増分指定のないHiRDBファイルシステム領域を指定しているときは，増分指定をしたHiRDBファイルシステム領域を指定して，再度サーバを開始してください。増分指定をしたHiRDBファイルシステム領域を指定しているにもかかわらずこのメッセージが出力される場合は，サーバ定義のpdworkオペランドに増分回数を増やしたHiRDBファイルシステム領域か，又は領域長を増やしたHiRDBファイルシステム領域を指定して，再度サーバを開始してください。
〈そのほかの場合〉
「HiRDBファイルシステムに対するアクセス要求から返されるエラーコード」を参照し，エラーの原因を取り除いてください。
KFPA11964-E
HiRDB file aa....aa error, errno=bb....bb, HiRDB file name=cc....cc　　（Ａ）
HiRDBファイルのオープン又はクローズに失敗しました。
aa....aa：HiRDBファイルシステム機能
{ open | close }
bb....bb：HiRDBファイルシステムのエラーコード
cc....cc：HiRDBファイルシステム領域名/HiRDBファイル名称
HiRDBファイルシステム領域名が132文字以上の場合は，HiRDBファイルシステム領域名の後ろから131文字を出力します。
(Ｓ)処理を終了します。
(Ｐ)HiRDB管理者に連絡してください。エラー要因の対策後，再度UAPを実行してください。
[対策]「HiRDBファイルシステムに対するアクセス要求から返されるエラーコード」を参照し，エラーの要因を取り除いてください。
KFPA11966-E
Error occured on transaction transfer, inf1=aa....aa, inf2=bbbb　　（Ａ＋Ｌ）
X/Open XAインタフェースのトランザクション処理でエラーが発生しました。
aa....aa：エラーとなった処理の名称
Connect：HiRDBとの再接続
bbbb：エラーとなった処理のSQLコード
(Ｓ)処理を終了します。
(Ｐ)エラーとなった処理のSQLコード，及びエラーログトレース（"pderrプロセス番号-*.trc"）を基にエラー要因を取り除いて，再度実行してください。
KFPA11970-E
Invalid SQL, code=aa, SQL="bb....bb"　　（Ａ）
OSI-RDAリモートアクセスで，SQL文に誤りがあります。
aa：理由コード
01：OSI-RDAリモートアクセスで実行できないSQL文を指定しています。
02：OSI-RDAリモートアクセスで実行できないSQL文をPREPARE文で指定しています。
03：SQL文の長さが0です。
04：SQL文の長さが20,000を超えています。
05：構文上に不正のある文字，又はキーワードがあります。
06：OSI-RDAリモートアクセスで実行できないSQL文をEXECUTE　IMMEDIATE文で指定しています。
bb....bb：エラーとなったSQL文
ただし，分散クライアント，又は分散サーバのシステムがSQL文を変更する場合があるため，必ずしもUAPが発行したSQL文とは一致しません。また，理由コードが03及び04の場合は出力されません。
(Ｓ)このSQL文を無視します。
(Ｐ)分散クライアントUAPの誤りを修正して，再度実行してください。
KFPA11971-E
Invalid identifier in SQL, code=aa　　（Ａ）
OSI-RDAリモートアクセスで，SQL文中のカーソル名，又はSQL文識別子に誤りがあります。
aa：理由コード
01：SQL文中のカーソル名の形式に誤りがあります。
02：SQL文中のSQL文識別子の形式に誤りがあります。
03：カーソル名の個数が1,024を超えています。
04：DECLARE CURSOR文に直接指定したカーソル指定の数とSQL文識別子の個数の合計が4,095を超えています。
05：宣言されていないカーソル名を使用して，SQL文を実行する指定をしています。
06：宣言されていないSQL文識別子を使用して，SQL文を実行する指定をしています。
07：DECLARE CURSOR文で，既に宣言されているカーソル名を指定しています。
08：DECLARE CURSOR文で，既に別のカーソルで使用されているSQL文識別子を指定しています。
(Ｓ)このSQL文を無視します。
(Ｐ)分散クライアントUAPの誤りを修正して，再度実行してください。
KFPA11972-E
Inconvertible data for aa....aa variable bb....bb of data type cc....cc　　（Ａ）
OSI-RDAリモートアクセスで，RDAサーバ側での変数値の変換ができません。
変換できない理由を次に示します。
・データ型がREAL又はDOUBLE PRECISIONの場合
オーバフローします。
・データ型がDATEの場合
値がYYYY-MM-DDの形式になっていません。
aa....aa：入力変数と出力変数の区分
{ input | output }
bb....bb：入力変数，又は出力変数の順序番号
cc....cc：データ型
(Ｓ)このSQL文を無視します。
(Ｐ)次に示す内容を確認し，対策してください。
データ型
内容
REAL
結果値を受け取る変数のデータ型が，DOUBLE PRECISIONになるようにクライアントUAPを修正して，再度実行してください。
DOUBLE PRECISION
OSI-RDAリモートアクセスで，この結果値を受け取ることはできません。
DATE
分散クライアントUAPの誤りを修正し，再度実行してください。
KFPA11973-E
Invalid data type of aa....aa variable bb....bb　　（Ａ）
OSI-RDAリモートアクセスで，変数に対して指定できないデータ型を指定しています。又は，データ長に誤りがあります。
aa....aa：入力変数と出力変数の区分
{ input | output }
bb....bb：入力変数，又は出力変数の順序番号
(Ｓ)このSQL文を無視します。
(Ｐ)分散クライアントUAPの誤りを修正して，再度実行してください。
KFPA11974-E
Unexecutable request, code=aa　　（Ａ）
OSI-RDAリモートアクセスで，R-Execute-DBLのサービスパラメタに誤りがあるため，処理できません。
aa：理由コード
(Ｓ)このSQL文を無視します。
(Ｐ)HiRDB管理者に連絡してください。
[対策]保守員に連絡してください。
理由コード
内容
01
FETCH以外のSQL文の実行要求で，Repetition countが2以上の値を指定しています。
02
List of Argumentを指定しています。
03
R-open時，又はR-Execute-DBL時のCharsetのオブジェクト識別子が，未サポートのオブジェクト識別子です。
04
引数の指定できないSQL文に対して，引数の指定があります。
05
結果値のないSQL文に結果指定があります。
06
結果値の必要なSQL文に結果指定がありません。
KFPA11975-E
Invalid "DESCRIBE" statement　　（Ａ）
OSI-RDAリモートアクセスで，DESCRIBE文に次の誤りがあります。
・SQLNAMEの要求に誤りがあります。
・SQLNの値がナル値です。
・不当な引数指定，又は結果指定があります。
(Ｓ)このSQL文を無視します。
(Ｐ)分散クライアントUAPで，SQLN（検索列数の最大値）を指定していない場合は，UAPを修正して再度実行してください。そのほかの場合は，HiRDB管理者に連絡してください。
[対策]保守員に連絡してください。
KFPA11976-E
More than 30000 variables　　（Ａ）
OSI-RDAリモートアクセスで，変数の数が30000を超えています。
このため，処理ができません。
(Ｓ)このSQL文を無視します。
(Ｐ)分散クライアントUAPの誤りを修正して，再度実行してください。
KFPA11977-E
Number of variables not equal to number of retrieval-columns　　（Ａ）
OSI-RDAリモートアクセスで，検索結果の列の数とその検索結果を受け取る変数の数が一致していません。
(Ｓ)このSQL文を無視します。
(Ｐ)分散クライアントUAPの誤りを修正して，再度実行してください。
KFPA11980-E
Transaction branch already determined　　（Ａ）
このトランザクションブランチは，ほかのトランザクションブランチから決着処理要求を受けていて，既に決着しています。
(Ｓ)このSQL文を無視します。
(Ｐ)このトランザクションブランチでは，SQLを実行できません。トランザクションブランチを終了させてください。
(Ｏ)このトランザクションブランチ実行中に決着要求が発生しているため，トランザクションマネジャで障害が発生している可能性があります。トランザクションマネジャのログ情報を参照してください。
KFPA11981-E
Communication error occurred from aa....aa to bb....bb event cc....cc dd....dd ee....ee　　（Ａ）
通信処理中に，処理を続行できないエラーが発生しました。
aa....aa：サーバ名称（送信側）
サーバ名が特定できない場合は，********が表示されます。
bb....bb：サーバ名称（受信側）
サーバ名が特定できない場合は，********が表示されます。
cc....cc：発生事象
Init：サーバ初期化中
Netdown：ネットワーク障害が発生
System：システムエラーが発生
Termin：サーバ停止処理中
Timeout：タイムアウトが発生
dd....dd：デバッグ情報1（エラーを検知した関数の名称）
ee....ee：デバッグ情報2（エラーを検知した関数のリターンコード)
(Ｓ)このSQL文を無視します。又は，トランザクションを無効にします。
(Ｐ)発生事象ごとの対策方法を次に示します。
Init：HiRDB管理者に連絡してサーバを開始した後，再度実行してください。
Termin：サーバを開始した後，再度実行してください。
上記以外：HiRDB管理者に連絡してください。
[対策]発生事象ごとの対策方法を次に示します。
Init：サーバを開始してください。
Netdown：通信障害の原因を取り除いてください。
Termin：サーバを開始してください。
Timeout：システム定義で指定した通信時間監視値（pd_watch_time）を修正してください。
System：
受信側のサーバ名称がディクショナリサーバで，デバッグ情報2の値が-330の場合は，ディクショナリサーバ又はバックエンドサーバのプロセス数が不足しています。この場合，pd_max_dic_process又はpd_max_bes_processオペランドの値を大きくしてください。特にマルチフロントエンドサーバ環境下で，各フロントエンドサーバがディクショナリサーバから定義情報を取得するときに，定義情報を取得しようとするフロントエンドサーバのプロセス数に比べて，ディクショナリサーバのプロセス数が少ないと，このエラーが発生します。

デバッグ情報2の値が-310の場合は，受信側のサーバが停止している可能性があります。pdlsコマンドで停止しているサーバを確認し，受信側のサーバを開始した後，再度実行してください。
上記以外：保守員に連絡してください。
KFPA11984-E
Client version incompatible,HiRDB version=aa....aa, client version=bb....bb　　（Ａ）
HiRDBクライアントのバージョンが不正です。
・HiRDBシステムが対応していないHiRDBクライアントを使用しました。
aa....aa：HiRDBシステムのバージョン
bb....bb：HiRDBクライアントのバージョン
(Ｓ)この要求を無視します。
(Ｐ)UAPのプリプロセス，コンパイル又はリンクに誤りがないか確認してください。誤りがなければ，HiRDB管理者に連絡してください。
[対策]保守員に連絡してください。
KFPA11986-E
Function "aa....aa"."bb....bb"(cc....cc) executed no "RETURN" statement　　（Ａ）
関数"aa....aa"."bb....bb"の実行が，RETURN文で終了しませんでした。
aa....aa：認可識別子
bb....bb：ルーチン識別子
cc....cc：特定名
(Ｓ)このSQL文を無視します。又は，トランザクションを無効にします。
(Ｐ)関数を定義し直して，再度実行してください。
KFPA11987-E
Unable to execute SQL except for rollback and disconnect　　（Ａ）
ROLLBACKとDISCONNECT以外のSQLは，実行できません。
(Ｓ)このSQL文を無視します。
(Ｐ)ROLLBACK文，又はDISCONNECT文を実行してください。
KFPA11988-E
Required function [aa....aa] is not supported　　（Ａ）
要求された機能aa....aaはサポートされていません。
aa....aa：要求されたサポートされていない機能（クライアント側で検出された場合だけ出力されます）
DESCRIBE TYPE：DESCRIBE TYPE文
TYPE OPTION：PREPARE文でのTYPE OPTIONの指定
XA INTERFACE：XDM/RD E2接続機能でのXAインタフェースの使用
ARRAY INSERT：配列を使用したインサート機能
SET SESSION AUTHORIZATION：SET SESSION AUTHORIZATION文
JAR：INSTALL JAR，REPLACE JAR，又はREMOVE JAR
SET：SET文（代入文）
SINGLE ROW SELECT：動的一行検索
ALLOCATE CURSOR：ALLOCATE CURSOR文
DEALLOCATE PREPARE：DEALLOCATE PREPARE文
DESCRIBE：PREPARE文でのDESCRIBE情報取得
EXTENDED STATEMENT NAME：拡張文名指定
EXTENDED CURSOR NAME：拡張カーソル名指定
(Ｓ)このSQL文を無視します。
(Ｐ)aa....aaの機能を使用しない場合は，この機能の使用箇所を削除してください。aa....aaの機能を使用するためにHiRDB又はXDM/RD E2のバージョンアップをする場合は，HiRDB管理者又はXDM/RD E2のシステム管理者に連絡してください。
(Ｏ)UAPにリンクしているクライアントライブラリと，サーバのバージョンを確認してください。
[対策]UAPにリンクしているクライアントライブラリと，サーバのバージョンを確認してください。aa....aaに対応する機能を使用する場合には，HiRDB又はXDM/RD E2をバージョンアップしてください。
KFPA11989-E
Commit error　　（Ａ）
コミット処理中にエラーが発生しました。
(Ｓ)このトランザクションを無効にします。
(Ｏ)メッセージKFPS00900-I又はKFPS00972-Iを参照して障害の原因を取り除き，再度UAPを実行してください。
KFPA11990-E
Incompatible character code set,HiRDB=aa....aa,client=bb....bb　　（Ａ）
HiRDBシステムとクライアントの文字コード種別が不一致です。
aa....aa：HiRDBシステムの文字コード種別
bb....bb：HiRDBクライアントの文字コード種別
CHINESE：EUC中国語漢字コード
LANG-C：単一バイト文字コード
SJIS：シフトJISコード
UJIS：EUC日本語漢字コード
UTF-8：Unicode
********：サポートしていない文字コード
(Ｓ)HiRDBとの接続を拒否します。
(Ｏ)UAPコンパイル時の環境変数（PDCLTLANG，又はLANG），及び実行時の環境変数（LANG又はPDLANG）が，HiRDBサーバに対応した文字コード種別になっているか確認してください。誤りがない場合には，HiRDB管理者に連絡してください。
KFPA11992-E
More than 32M bytes SQL OBJECT, size=aa....aa　　（Ａ）
SQLオブジェクトのサイズが32メガバイトを超えました。
aa....aa：作成しようとしたSQLオブジェクトのサイズ（単位：バイト）
(Ｓ)このトランザクションを無効にします。
(Ｐ)SQLオブジェクトが32メガバイトを超えないようにSQL文を修正して，再度実行してください。
KFPA11993-E
Input data length too short for HASH function　　（Ａ）
表定義で指定したハッシュ関数に対する分割列の入力データ長が短いです。
(Ｓ)このSQL文を無視します。
(Ｐ)入力しようとしたデータ長が，表定義で指定したハッシュ関数の分割キーの条件に合っているかを確認してください。誤りがある場合，入力データを修正してください。
又は，表定義で指定したハッシュ関数が正しいかを確認してください。誤りがある場合，表定義を修正してください。
KFPA11994-E
Unable to execute definition SQL for holdable cursor opened　　（Ａ）
ホールダブルカーソルが開いているため，定義系SQLは発行できません。
(Ｓ)このSQL文を無視します。
(Ｐ)ホールダブルカーソルをすべて閉じた後，定義系SQLを発行してください。
KFPA11997-E
Error occurred during execution of PLUGIN function, "aa....aa"　　（Ａ）
プラグイン（実装）関数実行中にエラーが発生しました。
aa....aa：エラー詳細メッセージ
(Ｓ)このSQL文を無視します。又は，トランザクションを無効にします。
(Ｐ)対応するプラグインのマニュアルを参照し，エラー詳細メッセージの問題を解決した後，再度SQLを実行してください。
KFPA11998-E
Unable to manipulate LIST yet, because transaction determination uncomplete　　（Ａ）
以前のトランザクションが未決着状態でリストの作成，削除，又は検索をしようとしました。シングルサーバ，又はバックエンドサーバがプロセスダウンした場合の回復処理が完了する前に，再コネクトしリスト操作をした場合に発生します。
(Ｓ)次のどちらかの処理をします。
・SQL文の場合
このSQL文を無視します。
・pdmodの場合
処理を続行します。
(Ｐ)次のどちらかの処置をしてください。
・SQL文の場合
トランザクションの決着を待つか，又はトランザクションの決着待ち状態を手動で決着してから，再度SQLを実行してください。
・pdmodの場合
トランザクションの決着を待つか，又はトランザクションの決着待ち状態を手動で決着してから，リストの再作成，又は削除をしてください。
KFPA12000-I
Processing of SQL completed　　（Ａ）
SQL文の実行が完了しました。
(Ｓ)処理を実行します。
KFPA12100-I
No rows satisfying search condition　　（Ａ）
条件に合う行がありません。又は，行の取り出しを終了しました。
(Ｓ)処理を続行します。
KFPA12110-I
Row already deleted or updated　　（Ａ）
リストを使用した検索で取り出そうとした行は，既に削除されています。又は，属性値が削除，更新されています。
(Ｓ)処理を続行します。
KFPA12120-I
Processing of SQL completed, dynamic result set returned　　（Ａ）
SQL文の実行が完了しました。動的結果集合の結果があります。
(Ｓ)処理を続行します。
KFPA12121-I
Processing of SQL completed, additional result set returned　　（Ａ）
SQL文の実行が完了しました。なお，追加の結果集合があります。
(Ｓ)処理を続行します。
KFPA12300-I
RDAREA usage aaa%, RDAREA = "bb....bb"cc....cc　　（Ａ）
状況によるメッセージの意味を，次に示します。
〈システム定義pd_rdarea_warning_pointを指定していない場合〉
ユーザ用RDエリア，ユーザLOB用RDエリア：
RDエリアbb....bbの，最終ファイルのセグメントのうち，相対位置aaa％目に当たるセグメントを使用し始めました。
〈システム定義pd_rdarea_warning_pointを指定している場合〉
ユーザ用RDエリア：
RDエリアbb....bbの，RDエリア全体のセグメントのうち，使用率aaa％目となるセグメントを使用し始めました。現在の，未使用セグメントの数は，cc....ccです。
ユーザLOB用RDエリア：
RDエリアbb....bbの，RDエリア全体のセグメントのうち，相対位置aaa％目となるセグメントを使用し始めました。有効性能※を維持できる残りのセグメントの数は，cc....ccです。
注※有効性能：
ユーザLOB用RDエリアは，データベース領域を一度も最後まで使用していない時が，最も処理能力が高くなります。有効性能とは，この処理能力が高い状態のことです。データベースを一度でも，最後まで使用した場合は，処理能力が劣化するため，事前にデータベースの再編成をするなどの処置が必要になります。
aaa：次のうち，どれかが出力されます。
・RDエリアの最終ファイルの使用セグメント相対位置
・RDエリア全体のセグメント使用率
・RDエリア全体の使用セグメント相対位置
bb....bb：該当するRDエリア名称
cc....cc：セグメント使用率追加情報, dd....dd segments unused
（dd....dd 残りセグメント数）
(Ｓ)処理を続行します。
このメッセージの対象となるRDエリアは，容量不足で新しいセグメントを割り当てできなくても，追加，更新などをしている既存のセグメントに空きがあれば，そのセグメントを利用して処理を続行します。
なお，このメッセージは，表示の対象となったセグメントが，表の削除，表の再編成などによって解放されて，その後，同じセグメントを使用すると，再度表示されます。
(Ｐ)HiRDB管理者に連絡してください。
[対策]次のコマンド又はユティリティを使って，RDエリアに残っている容量を調査し，表に示すような処置を取ってください。
〈残り容量を調査するためのコマンド〉
・データベースの状態表示コマンド（pddbls）
-aオプションを指定すると，RDエリアの使用状況が表示できます。すべてのRDに使用できます。
・データベース状態解析ユティリティ（pddbst）
物理的解析，又は論理的解析で，RDエリアの使用状況が分かります。データディクショナリ，ユーザ，LOB用のRDエリアに使用できます。
〈処置〉処置を次の表に示します。
RDエリア
システム定義pd_rdarea_warning_pointを指定していない場合
システム定義pd_rdarea_warning_pointを指定している場合
ユーザ用RDエリア
・データベースの状態表示コマンド（pddbls）又はデータベース状態解析ユティリティ（pddbst）で，対象となるRDエリアの使用状況を調べます。
・使用状況に応じて，RDエリアの表の再編成をしてください。又はRDエリアを拡張してください。
・データベースの状態表示コマンド（pddbls）又はデータベース状態解析ユティリティ（pddbst）で，又は，メッセージに出力されたセグメント使用率追加情報を参照して，対象となるRDエリアの使用状況を調べます。
・使用状況に応じて，表のRDエリア単位の再編成又は表単位の再編成をしてください。又は，RDエリアを拡張してください。
ユーザLOB用RDエリア
・データベースの状態表示コマンド（pddbls）又はデータベース状態解析ユティリティ（pddbst）で，対象となるRDエリアの使用状況を調べます。
・使用状況に応じて，ユーザLOB用エリア単位の再編成又は表単位の再編成をしてください。又は，RDエリアを拡張してください。
・データベースの状態表示コマンド（pddbls）又はデータベース状態解析ユティリティ（pddbst）で，又は，メッセージに出力されたセグメント使用率追加情報を参照して，対象となるRDエリアの使用状況を調べます。
・使用状況に応じて，ユーザLOB用RDエリア単位の再編成又は表単位の再編成をしてください。又は，RDエリアを拡張してください。
KFPA12601-I
Positive SQLCODE other than ＋100 received from server, SQLCODE=aa....aa　　（Ａ）
リモートアクセスで，＋100以外の正のSQLコードがサーバ側のシステムから返されました。
aa....aa：サーバシステムから返されたSQLコード
(Ｓ)処理を続行します。
(Ｏ)SQL連絡領域（SQLCA）内のSQLCAIDEの内容を参照し，サーバシステム種別を確認してください。なお，該当するサーバシステムのマニュアルを基にSQLコードを参照してください。
KFPA12603-I
Retrieved string data length is 0,the data is converted to a blank　　（Ａ）
リモートアクセスで，実長が0の文字列，各国文字列，又は混在文字列データを検索しました。分散クライアントは実長が0の文字列，各国文字列，又は混在文字列データをサポートしていないので，このデータを１文字の空白に変換しました。
(Ｓ)処理を続行します。
(Ｐ)実長が0の文字列，各国文字列，及び混在文字列データが1文字の空白に変換されることが，UAPの処理に不都合な場合は，実長が0のデータが検索されないように，探索条件を変更してください。
KFPA12900-W
Warning occurred in foreign server aa....aa (b), SQLCODE=cc....cc, inf=dd....dd　　（Ａ＋Ｌ）
HiRDB External Data Access機能を使用している場合に，外部サーバから警告が返却されました。
aa....aa：外部サーバ名
b：サーバ種別
P：HiRDB
R：XDM/RD E2
O：ORACLE
I：DB2
cc....cc：外部サーバから返却されたSQLCODE
dd....dd：外部サーバから返却されたメッセージ
76文字以上の場合は，先頭から74文字目に2バイトのピリオド（..）を付けて出力します。メッセージがない場合は，*が表示されます。
(Ｓ)処理を続行します。
(Ｐ)外部サーバのサーバ種別を確認して，該当するDBMSのマニュアルを基に，SQLCODE，警告メッセージを参照してください。dd....ddが*の場合は，SQL連絡領域のSQLWARN0～SQLWARNFを確認してください。SQLWARNDに'W'が設定されている場合は，外部表定義で定義した列の長さが，実表の列の長さより短いことがあるため，外部表定義を見直してください。
KFPA19101-E
Invalid SQL optimization specification for aa....aa　　（Ａ）
SQL最適化指定に次の誤りがあります。
・述語中の副問合せ以外の副問合せに，副問合せ実行方式のSQL最適化指定を指定しています。
aa....aa：subquery
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA19102-E
Invalid file name "aa....aa" specified in client environment definition PDDELRSVWDFILE　　（Ａ）
クライアント環境定義PDDELRSVWDFILEの指定値に次の誤りがあります。
・システム共通定義のpd_delete_reserve_word_fileオペランドで指定したファイル名以外を指定しています。
aa....aa：クライアント環境定義PDDELRSVWDFILEに指定したファイル名
(Ｓ)HiRDBとの接続を拒否します。
(Ｐ)クライアント環境定義PDDELRSVWDFILEの指定値を，システム共通定義のpd_delete_reserve_word_fileオペランドに指定したファイル名と同じにしてください。
KFPA19110-E
Unable to specify "aa....aa" statement in FOR statement because cursor is not holdable　　（Ａ）
FOR文でホールダブルカーソルを宣言していない場合，FOR文中のSQL手続き文にCOMMIT文，ROLLBACK文，又はPURGE TABLE文を指定できません。
aa....aa：指定できないSQL
｛COMMIT｜ROLLBACK｜PURGE TABLE｝
(Ｓ)このSQL文を無視してロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA19111-E
Table name missing except preparable dynamic "aa....aa" statement:positioned.　　（Ａ）
カーソルを使用したUPDATE文，又はカーソルを使用したDELETE文の前処理時以外に，表名を省略しています。
aa....aa：エラーとなったSQL
｛UPDATE｜DELETE｝
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA19150-E
Unable to specify data type other than DATE or TIME type for column "aa....aa" with "SYSTEM GENERATED"　　（Ａ）
SYSTEM GENERATEDを指定した列のデータ型がDATE型，TIME型以外です。
aa....aa：誤って指定された列名
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA19200-E
Unable to specify referential constraint or check constraint without specifying "pd_check_pending" operand　　（Ａ）
システム共通定義pd_check_pendingの指定がないため，参照制約，又は検査制約の定義はできません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文から参照制約，又は検査制約の定義構文の部分を削除し，再度実行してください。又は，システム共通定義pd_check_pendingの追加をHiRDB管理者に依頼してください。
KFPA19212-E
Unable to specify expression except embedded variable or ? parameter in assignment statement for embedded SQL　　（Ａ）
代入文の代入先，又は代入値の指定に次のどれかの誤りがあります。
・代入先に埋込み変数，及び?パラメタ以外の値式を指定しています。
・代入値に埋込み変数，?パラメタ，スカラ関数LENGTH，スカラ関数SUBSTR，及びスカラ関数POSITION以外の値式を指定しています。
・代入値に指定したスカラ関数LENGTHの値式，スカラ関数SUBSTRの値式1，又はスカラ関数POSITIONの値式2に，埋込み変数及び?パラメタ以外の項目を指定しています。
・代入値に次にどちらかを指定しています。
・列指定を含む値式
・抽象データ型列の属性を示したコンポネント指定を含む値式
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA19220-E
Invalid cursor name "aa....aa" in "bb....bb" statement　　（Ａ）
FOR文で宣言したカーソル名はOPEN文，CLOSE文，又はFETCH文で指定できません。
aa....aa：カーソル名
bb....bb：指定できないSQL
｛OPEN｜CLOSE｜FETCH｝
(Ｓ)このSQL文を無視してロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA19221-E
Invalid cursor specification in FOR statement.　　（Ａ）
FOR文で指定したカーソル指定に，次のどれかの誤りがあります。
・導出列に名前のない列を指定しています。
・導出列のFROM句に，平坦化の指定がない添字なし繰返し列を指定しています。
・導出列の導出列名が重複しています。
(Ｓ)このSQL文を無視してロールバックします。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA19254-E
Subquery specified in aa....aa　　（Ａ）
指定できない箇所に副問合せを指定しています。
aa....aa：{ set function | assignment statement | RETURN statement | CALL statement | WRITE specification | WRITE LINE statement}
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA19290-E
Unable to specify aa....aa in bb....bb　　（Ａ）
検査制約定義の探索条件，及びトリガ動作条件に次の指定はできません。
検査制約中の探索条件の場合
・副問合せ
・集合関数
・繰返し列
・埋込み変数，及び?パラメタ
・USER
・CURRENT DATE，又はCURRENT_DATE
・CURRENT TIME，又はCURRENT_TIME
・CURREMT TIMESTAMP，又はCURRENT_TIMESTAMP
・表定義中で定義されていない列
・単一列検査制約の場合，その列指定で定義している列以外の列
・抽象データ型の値式
・ユーザ関数
・構造化繰返し述語
・TIMEからTIMESTAMPへの変換を指定したCAST指定
・値式にTIMEを指定したスカラ関数VARCHAR_FORMAT
・スカラ関数IS_USER_CONTAINED_IN_HDS_GROUP
トリガ動作条件の場合
・副問合せ
・集合関数
・繰返し列
・埋込み変数，及び?パラメタ
・新旧値相関名で修飾していない列
・抽象データ型の値式
・プラグイン関数
・Javaストアドファンクション
・構造化繰返し述語
aa....aa：エラーとなった条件
｛subquery｜set function｜array column｜variable or parameter
｜column "列名" unqualified by old or new values correlation name
｜value expression of abstract data type｜PLUGIN function｜JAVA function
｜ARRAY predicate｜function invocation｜USER｜CURRENT_DATE
｜CURRENT_TIME｜CURRENT_TIMESTAMP｜column "列名"
｜CURRENT_DATE implied by scalar function VARCHAR_FORMAT or cast specification
｜scalar function IS_USER_CONTAINED_IN_HDS_GROUP｝
bb....bb：｛triggered action condition｜check constraint definition｝
(Ｓ)このSQL文を無視し，ロールバックします。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA19291-E
Invalid use of "LIMIT" clause　　（Ａ）
LIMIT句の使用方法に次のとちらかの誤りがあります。
・リミット行数，又はオフセット行数に，新旧値相関名で修飾した列を指定しています。
・リミット行数とオフセット行数に指定できる値の合計が，2,147,483,647を超えています。
(Ｓ)このSQL文を無視します。ただし，定義系SQL文の場合はロールバックします。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA19292-E
Unable to specify outer reference column "aa....aa" with data type "BINARY", query-no=bbb　　（Ａ）
BINARY型は外への参照列には指定できません。
aa....aa：外への参照列名
ただし，不正に指定している列が名前付き導出表の列の場合は，該当する名前付き導出表の基表の列名が表示されます。
bbb：外への参照列を指定した問合せの番号
(Ｓ)このSQL文を無視します。ただし，定義系SQL文の場合はロールバックします。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA19293-E
Invalid handler declaration or condition declaration code=aa(bb....bb)　　（Ａ）
条件宣言，又はハンドラ宣言に誤りがあります。
aa：理由コード
bb....bb：エラーに対する付加情報
各理由コードと，それに対応する付加情報及び意味を次に示します。
理由コード
(aa)
付加情報(bb....bb)
意味
01
Condition name "cc....cc" already declared
条件宣言に指定した条件名cc....ccは，既に定義されています。
02
SQLCODE value "dd....dd" in condition "cc....cc" already declared in other condition declaration
条件宣言cc....ccに指定したSQLCODE値dd....ddは，既にほかの条件宣言のSQLCODE値として定義されています。
03
Condition name "cc....cc" in handler declaration not found
ハンドラ宣言に指定した条件名cc....ccがありません。
04
Unable to specify SQLCODE value or condition name together with "SQLERROR" or "NOT FOUND"
ハンドラ宣言に指定した条件値にSQLERROR，又はNOT FOUNDのどちらかを指定した場合，同じハンドラ宣言にはSQLCODE値，又は条件名を指定できません。
05
Duplicate condition value
ハンドラ宣言の条件値に，同じSQLCODE値，又は条件名を重複して指定できません。また，SQLCODE値と同じSQLCODEを表す条件名も指定できません。
06
Unable to specify same condition as condition in other handler declaration
ほかのハンドラ宣言に，同じ条件を表す条件値を指定できません。
07
Zero specified in SQLCODE value
条件宣言，又はハンドラ宣言のSQLCODE値に0を指定しています。
(Ｓ)このSQL文を無視し，ロールバックします。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA19294-E
Invalid signal value aa....aa　　（Ａ）
信号値に次のどちらかの誤りがあります。
(1) 信号値に指定した条件名aa....aaがありません。
(2) 信号値に指定したSQLSTATE値aa....aaに，次のどれかの誤りがあります。
・長さが5けた未満の文字定数以外の定数を指定しています。
・A～Zの大文字，及び0～9の数字以外の値を指定しています。
・最初の1文字に0～5，A～I，又はRを指定しています。
aa....aa：｛"条件名"｜SQLSTATE "SQLSTATE値"｝
(Ｓ)このSQL文を無視し，ロールバックします。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA19295-E
Invalid specification in UPDATE statement with update trigger　　（Ａ）
UPDATEを契機とするトリガが定義されている表に対して，次の操作はできません。
・新値相関名を指定したUPDATEを契機とするトリガを定義した表に対して，コンポネント指定を用いた更新
・UPDATEを契機とするトリガを定義した表に対して，連結演算を用いたBLOB型又は定義長が32,001バイト以上のBINARY型の更新
(Ｓ)このSQL文を無視します。ただし，定義系SQL文の場合はロールバックします。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA19400-E
aa....aa statement executed, signal value=bb....bb　　（Ａ）
aa....aa文によってエラーが発生しました。
aa....aa：SQL文の種別｛SIGNAL｜RESIGNAL｝
bb....bb：SIGNAL文又はRESIGNAL文に指定した信号値
信号値に条件名を指定した場合：
条件名
信号値にSQLSTATEを指定した場合：
SQLSTATE:XXXXX（XXXXXはSQLSTATE値）
(Ｓ)このSQL文を無視します。又は，このトランザクションを無効にします。
(Ｐ)SQL手続き，又はトリガの定義を参照し，SIGNAL文又はRESIGNAL文が実行された原因を確認してください。RESIGNAL文が実行された場合は，GET DIAGNOSTICSの診断情報からエラー情報の履歴を確認できます。
KFPA19403-E
No error occurred before executing RESIGNAL statement　　（Ａ）
RESIGNAL文を実行する前にエラーとなったSQL手続き文はありません。
(Ｓ)このSQL文を無視します。又は，このトランザクションを無効にします。
(Ｐ)SQL手続き，又はトリガの定義を修正して，再度実行してください。エラーとならないSQL手続き文の実行後にエラーを発生させたい場合は，SIGNAL文を使用してください。
KFPA19404-E
Handler raised recursively　　（Ａ）
同一のハンドラが再帰的に呼び出されました。
(Ｓ)このSQL文を無視します。又は，このトランザクションを無効にします。
(Ｐ)ハンドラ動作の延長で再度同じハンドラが呼び出されないように，SQLルーチン又はトリガを定義し直してから，再度SQLを実行してください。
KFPA19405-E
Invalid aa....aa of parameter in "LIMIT"clause.　　（Ａ）
LIMIT句に指定した変数の値，又はデータ型が不正です。
aa....aa：不正の種別
data type：データ型がINTEGER及びSMALLINTではありません。
value：変数の値が1～32,767の範囲ではありません。又は，ナル値です。
(Ｓ)このSQL文を無視します。
(Ｐ)aa....aaがdata typeの場合は，LIMIT句に指定する変数のデータ型をINTEGER又はSMALLINTに修正して，再度実行してください。aa....aaがvalueの場合は，LIMIT句に指定する変数の値を1～32,767の範囲に修正して，再度実行してください。
KFPA19406-E
Unable to specify condition name associated with SQLCODE value in aa....aa statement, condition name=bb....bb　　（Ａ）
SQLCODE値と対応付けられた条件名は，SIGNAL文及びRESIGNAL文に指定できません。
aa....aa：SQL文の種別｛SIGNAL｜RESIGNAL｝
bb....bb：SIGNAL文又はRESIGNAL文の信号値として指定した条件名
(Ｓ)このSQL文を無視します。又は，このトランザクションを無効にします。
(Ｐ)SQL手続き又はトリガの定義を見直して，SIGNAL文又はRESIGNAL文にSQLCODE値に対応付けられた条件名を指定していないか確認してください。SIGNAL文又はRESIGNAL文に条件名を指定する場合は，条件宣言でSQLCODE値を指定しないようにしてください。
KFPA19407-E
Invalid specification in aaaaaaa statement with bbb clause　　（Ａ）
FOR句を指定したINSERT文，UPDATE文，若しくはDELETE文，又はBY句を指定したEXECUTE文の形式が不正です。
aaaaaaa：SQL文の種別｛INSERT｜UPDATE｜DELETE｜EXECUTE｝
bbb：句の名称｛FOR｜BY｝
(Ｓ)このSQL文を無視します。
(Ｐ)次のようにSQL文又はUAPを修正し，再度実行してください。
・埋込み変数配列を指定して，表に列単位で複数行を挿入する場合
FOR ：埋込み変数
INSERT INTO 〔認可識別子.〕表識別子 〔(列名 〔,列名〕…)〕
VALUES (：埋込み変数配列〔：標識変数配列〕
〔,：埋込み変数配列〔：標識変数配列〕〕…)
〔WITH ROLLBACK〕
・埋込み変数配列を指定して，FIX属性の表に行単位で複数行を挿入する場合
FOR ：埋込み変数
INSERT INTO 〔認可識別子.〕表識別子(ROW)
VALUES(：埋込み変数配列〔：標識変数配列〕)
〔WITH ROLLBACK〕
・SQL（INSERT文）を前処理して，EXECUTE文で実行する場合
(前処理するSQL)
INSERT INTO 〔認可識別子.〕表識別子 〔(列名 〔,列名〕…)〕
VALUES (？パラメタ 〔,？パラメタ〕…)
〔WITH ROLLBACK〕
INSERT INTO 〔認可識別子.〕表識別子 (ROW)
VALUES (？パラメタ)
〔WITH ROLLBACK〕
KFPA19408-E
Unable to execute SQL except INSERT, UPDATE or DELETE using EXECUTE statement with BY clause　　（Ａ）
BY句を指定したEXECUTE文では，INSERT文，UPDATE文，又はDELETE文以外のSQLは実行できません。
(Ｓ)このSQL文を無視します。
(Ｐ)EXECUTE文でINSERT文，UPDATE文，又はDELETE文以外のSQLを実行する場合，BY句の指定を取り除くようにSQL文又はUAPを修正し，再度実行してください。
KFPA19409-E
Unable to insert into aa....aa using bb....bb statement with cc....cc clause　　（Ａ）
FOR句を指定したINSERT文，又はBY句を指定したEXECUTE文を使用する場合，次の挿入はできません。
・定義長が32,001バイト以上のBINARY型の列に対する挿入
・WITH DEFAULT指定の定義長32,001バイト以上のBINARY列がある表に対する挿入
・BLOB型の列に対する挿入
・WITH DEFAULT指定のBLOB列がある表に対する挿入
・抽象データ型の列に対する挿入
aa....aa：挿入対象
｛column of BINARY data type (length over 32000)｜table which has BINARY data type (length over 32000) column with WITH DEFAULT｜column of BLOB data type｜table which has BLOB data type column with WITH DEFAULT｜column of abstract data type｝
bb....bb：SQL文の種別｛INSERT｜EXECUTE｝
cc....cc：句の名称｛FOR｜BY｝
(Ｓ)このSQL文を無視します。
(Ｐ)FOR句を指定したINSERT文，又はBY句を指定したEXECUTE文を実行する場合，次のようにSQL文又はUAPを修正し，再度実行してください。
・定義長が32,001バイト以上のBINARY型の列に対する挿入をしない。
・WITH DEFAULT指定の定義長32,001バイト以上のBINARY列がある表に対する挿入をしない。
・BLOB型の列に対する挿入をしない（挿入値にはナル値も指定しない）。
・WITH DEFAULT指定のBLOB列がある表への挿入をしない。
・抽象データ型の列に対する挿入をしない。
KFPA19411-E
Unable to lock shared table in RDAREA which containing table used by cursor　　（Ａ）
カーソルをオープンしている共用表が格納されているRDエリア，ほかの共用表に対して，EXCLUSIVE指定でLOCK文を実行しようとしています。
(Ｓ)このSQL文を無視します。
(Ｐ)共用表に対してEXCLUSIVE指定でLOCK文を実行する場合，対象となる共用表を格納しているRDエリアの，ほかの共用表のオープンしているカーソルを閉じてからLOCK文を実行するようにしてください。
KFPA19450-E
Invalid trigger definition code=aa(bb....bb)　　（Ａ）
トリガの定義に誤りがあります。
aa：理由コード
bb....bb：エラーに対する付加情報
理由コード（aa）
付加情報（bb....bb）
意味
01
Another user's table
トリガは他ユーザの表に対して定義できません。
02
Non base table cc....cc
トリガは実表以外には定義できません。
cc....cc：｛view table｜foreign table｜ALIAS｝
03
Table not found
トリガを定義する表が存在しません。
04
Duplicate "OLD ROW" or "NEW ROW"
OLD ROW，NEW ROWは新旧値別名リストにそれぞれ1度しか指定できません。
05
"OLD ROW" in insert trigger
トリガの実行契機にINSERTを指定した場合，OLD ROWは指定できません。
06
"NEW ROW" in delete trigger
トリガの実行契機にDELETEを指定した場合，NEW ROWは指定できません。
07
Duplicate name in old or new values alias
OLD ROW又はNEW ROWに同じ名前は指定できません。
08
"OLD ROW" or "NEW ROW" in "STATEMENT TRIGGER"
FOR EACH STATEMENTを指定した場合，NEW ROW，及びOLD ROWは指定できません。
09
Num of trigger columns exceed 30000
トリガの実行契機で指定している列が30,000を超えています。
10
Duplicate trigger columns "dd....dd"
トリガの実行契機で指定している列名称が重複しています。
dd....dd：列名
11
Trigger column "dd....dd" not found in table
トリガの実行契機で指定している列がトリガを定義する表にありません。
dd....dd：列名
12
SQL data change statement in "BEFORE TRIGGER"
トリガ動作時期にBEFOREを指定したトリガ定義では，トリガSQL文に更新のSQL文（INSERT，UPDATE，又はDELETE文）は指定できません。
13
Invalid column reference "dd....dd"
繰返し列及び抽象データ型の列は，新旧値相関名で参照できません。
dd....dd：列名
14
Invalid triggered SQL statement
トリガSQL文にはPURGE TABLE文，COMMIT文，及びROLLBACK文は指定できません。
15
Trigger table in triggered SQL statement
トリガを定義する表はトリガSQL文中に指定できません。
16
SQL function invocation in "BEFORE TRIGGER"
トリガ動作時期にBEFOREを指定したトリガ定義では，トリガSQL文にデフォルトコンストラクタ以外の関数呼出しは指定できません。
17
ROW for old or new values alias
新旧値相関名でROWを指定できません。
18
Foreign table in triggered SQL statement
トリガSQL文には外部表の表名は指定できません。
19
Unqualified column of trigger table in triggered action
トリガ動作の探索条件，又はトリガSQL文にトリガ定義に指定した表の列名を指定する場合，新旧値相関名で修飾しないと指定できません。
20
Invalid use of ? parameter
トリガSQL文には?パラメタは指定できません。
21
Call statement in "BEFORE TRIGGER"
トリガ動作時期にBEFOREを指定したトリガ定義では，トリガSQL文中にCALL文は指定できません。
22
Invalid use of JAVA procedure or function
トリガSQL文にはJavaストアドプロシジャ，及びJavaストアドファンクションは指定できません。
23
Invalid use of GET_JAVA_STORED_ROUTINE_SOURCE specification
トリガSQL文にはGET_JAVA_STORED_ROUTINE_SOURCEは指定できません。
24
Invalid use of default specification
既定値がUSING BES指定のCURRENT_TIMESTAMPの列を，代入文の代入先に指定した場合，代入値にはDEFAULTを指定できません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA19451-E
Unable to execute trigger aa....aa.bb....bb due to cc....cc　　（Ａ）
トリガaa....aa.bb....bbは，cc....ccに示す制限によって実行できません。
aa....aa：認可識別子
bb....bb：トリガ識別子
cc....cc：制限事項
more than 16 nest：トリガ実行時のネストが16を超えました。
COMMIT/ROLLBACK/PURGE TABLE statement：
COMMIT，ROLLBACK，及びPURGE TABLE文はトリガ中から実行できません。
Java routine：トリガ中からJavaルーチンは実行できません。
(Ｓ)このトランザクションを無効にします。
(Ｐ)制限事項ごとの対策を次に示します。
more than 16 nestの場合
トリガのネストが16以下になるようにトリガの定義を修正し，再度実行してください。
COMMIT/ROLLBACK/PURGE TABLE statementの場合
トリガ中からCALL文で呼び出されるSQLストアドプロシジャでCOMMIT，又はROLLBACKを実行しないように修正し，再度実行してください。
Java routineの場合
トリガ中からJavaルーチンの実行をしないように修正し，再度実行してください。
KFPA19452-E
Unable to specify SQL optimization specification for "aaaaa" in query for table derived from "bb....bb"　　（Ａ）
表の結合（結合表を含む）をして導出した表に対する，問合せ又は集合演算を指定して導出した表に対する問合せでは，次のSQL最適化指定は指定できません。
・使用インデクスのSQL最適化指定
・結合方式のSQL最適化指定（内部導出表を生成する名前付きの導出表に対しては，結合方式のSQL最適化指定を指定できます）
内部導出表を作成する条件を次に示します。
1. SELECT DISTINCTを指定して導出した，名前付きの導出表に対する問合せで，名前付きの導出表が副問合せ中に含まれるか，又は次のどれかを直接含む。
・GROUP BY句，HAVING句，又は集合関数
・SELECT DISTINCT
・表の結合（外結合，内結合を含む）
・選択式に列指定以外の値式を指定
・選択式に，FROM句で指定した名前付きの導出表の全列を一回ずつ指定していない
2. GROUP BY句，HAVING句，又は集合関数を指定して導出した，名前付きの導出表に対する問合せに，次のどれかを直接含む。
・GROUP BY句
・HAVING句
・集合関数
・表の結合（外結合，内結合を含む）
3. 選択式として列指定以外の値式を指定して導出した，名前付きの導出表に対する問合せに，次のどれかを直接含む。
・GROUP BY句
・HAVING句
・集合関数
・結合表
4. DISTINCT指定の集合関数を指定して導出した，名前付きの導出表に対する問合せに，SELECT DISTINCTの指定を直接含む。
5. 表の結合（外結合，内結合を含む）を指定して導出した，名前付きの導出表に対する問合せに，表の結合（外結合，内結合を含む）を直接含んで，かつ指定した表の結合のどれかが結合表の指定である。
6. 選択式としてスカラ副問合せを指定して，導出した名前付きの導出表に対する問合せである。
7. 集合演算によって導出した名前付きの導出表に対する問合せで，次のどちらかを満たしている。
・集合演算の演算項のどれかに，内部導出表の問合せ，導出表を指定した問合せ，又は選択式に副問合せを指定した問合せかを含んでいる。
・集合演算の演算項のどれかと，名前付きの導出表に対する問合せが，1.～6.に示したどれかの条件を満たしている。
8. UNION ALL以外を含む集合演算によって導出した，名前付きの導出表に対する問合せで，次のどれかを直接含む。
・GROUP BY句，HAVING句，又は集合関数
・SELECT DISTINCT
・表の結合（外結合，内結合を含む）
・WHERE句
・副問合せ
・選択式に列指定以外の値式
・選択式に，FROM句に指定した名前付きの導出表の列を１回ずつ指定していない
9. UNION ALLだけの集合演算によって導出した，名前付きの導出表に対する問合せで，次のどれかを直接含む。
・GROUP BY句，HAVING句，又は集合関数
・表の結合（外結合，内結合を含む）
・WHERE句，又は副問合せ（ただし，副問合せ，集合演算の演算項，又はINSERT文の問合せだけ）
・関数呼出し又はシステム定義スカラ関数
・コンポネント指定
・WRITE指定
・GET_JAVA_STORED_ROUTINE_SOURCE指定
・選択式にない項目でのソート指定
・集合演算によって導出した名前付きの導出表をFROM句に指定した副問合せ
・導出表を指定した副問合せ
・GROUP BY句に列指定以外の値式を指定した副問合せ
・選択式に指定したSQL変数，及びSQLパラメタのうち，データ型が次のどれかになるもの
BLOB型
32,001バイト以上のBINARY型
抽象データ型
BOOLEAN型
aaaaa：｛index｜join｝
bb....bb：｛join｜set operation｝
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA19453-E
Unable to specify SQL optimization specification for index to view or "WITH" query which derives internal table　　（Ａ）
内部導出表を作成する問合せでは，使用インデクスのSQL最適化指定は指定できません。
内部導出表を作成する条件を次に示します。
1. SELECT DISTINCTを指定して導出した，名前付きの導出表に対する問合せで，名前付きの導出表が副問合せ中に含まれるか，又は次のどれかを直接含む。
・GROUP BY句，HAVING句，又は集合関数
・SELECT DISTINCT
・表の結合（外結合，内結合を含む）
・選択式に列指定以外の値式を指定
・選択式に，FROM句で指定した名前付きの導出表の全列を一回ずつ指定していない
2. GROUP BY句，HAVING句，又は集合関数を指定して導出した，名前付きの導出表に対する問合せに，次のどれかを直接含む。
・GROUP BY句
・HAVING句
・集合関数
・表の結合（外結合，内結合を含む）
3. 選択式として列指定以外の値式を指定して導出した，名前付きの導出表に対する問合せに，次のどれかを直接含む。
・GROUP BY句
・HAVING句
・集合関数
・結合表
4. DISTINCT指定の集合関数を指定して導出した，名前付きの導出表に対する問合せに，SELECT DISTINCTの指定を直接含む。
5. 表の結合（外結合，内結合を含む）を指定して導出した，名前付きの導出表に対する問合せに，表の結合（外結合，内結合を含む）を直接含んで，かつ指定した表の結合のどれかが結合表の指定である。
6. 選択式としてスカラ副問合せを指定して，導出した名前付きの導出表に対する問合せである。
7. 集合演算によって導出した名前付きの導出表に対する問合せで，次のどちらかを満たしている。
・集合演算の演算項のどれかに，内部導出表の問合せ，導出表を指定した問合せ，又は選択式に副問合せを指定した問合せかを含んでいる。
・集合演算の演算項のどれかと，名前付きの導出表に対する問合せが，1.～6.に示したどれかの条件を満たしている。
8. UNION ALL以外を含む集合演算によって導出した，名前付きの導出表に対する問合せで，次のどれかを直接含む。
・GROUP BY句，HAVING句，又は集合関数
・SELECT DISTINCT
・表の結合（外結合，内結合を含む）
・WHERE句
・副問合せ
・選択式に列指定以外の値式
・選択式に，FROM句に指定した名前付きの導出表の列を１回ずつ指定していない
9. UNION ALLだけの集合演算によって導出した，名前付きの導出表に対する問合せで，次のどれかを直接含む。
・GROUP BY句，HAVING句，又は集合関数
・表の結合（外結合，内結合を含む）
・WHERE句，又は副問合せ（ただし，副問合せ，集合演算の演算項，又はINSERT文の問合せだけ）
・関数呼出し又はシステム定義スカラ関数
・コンポネント指定
・WRITE指定
・GET_JAVA_STORED_ROUTINE_SOURCE指定
・選択式にない項目でのソート指定
・集合演算によって導出した名前付きの導出表をFROM句に指定した副問合せ
・導出表を指定した副問合せ
・GROUP BY句に列指定以外の値式を指定した副問合せ
・選択式に指定したSQL変数，及びSQLパラメタのうち，データ型が次のどれかになるもの
BLOB型
32,001バイト以上のBINARY型
抽象データ型
BOOLEAN型
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA19454-E
Unable to insert using aa....aa statement with bb....bb clause into table with row-level trigger　　（Ａ）
行単位トリガを定義した表に対して，次に示すSQL文を使って複数行分一括して挿入できません。
・FOR句を指定したINSERT文
・BY句を指定したEXECUTE文
aa....aa：｛INSERT｜EXECUTE｝
bb....bb：｛FOR｜BY｝
(Ｓ)このSQL文を無視します。
(Ｐ)1行ずつ行を挿入するようにSQL文，又はUAPを修正して，再度実行してください。
KFPA19455-E
Unable to update specified column using new values correlation name in BEFORE trigger　　（Ａ）
トリガ動作時期にBEFOREを指定したトリガ定義（BEFOREトリガ）では，次の列を新値相関名で修飾して更新できません。
・SYSTEM GENERATEDを指定した列
また，トリガの実行契機がINSERTのBEFOREトリガでは，次の列を新値相関名で修飾して更新できません。
・分割表（フレキシブルハッシュ分割表を除く）の分割キーに指定した列
(Ｓ)このトランザクションを無効にします。
(Ｐ)SYSTEM GENERATEDを指定した列，及び分割キーに指定した列を新値相関名で修飾して更新しないようにトリガの定義を修正し，再度実行してください。
KFPA19456-E
Unable to execute SQL in 64bit version, because check constraint "aa....aa" in bb....bb."cc....cc" created in 32bit version 　　（Ａ）
32ビットモードのHiRDBで検査制約を定義した表bb....bb.cc....ccに対して，64ビットモードのHiRDBではSQLを実行できません。
aa....aa：検査制約の制約名
bb....bb：検査制約を定義した表の認可識別子
cc....cc：検査制約を定義した表の表識別子
(Ｓ)このSQL文を無視します。定義系SQLの場合，ロールバックします。
(Ｐ)64ビットモードでHiRDBを再開始後，検査制約を再定義してください。検査制約を定義した表の64ビットモードへの移行については，マニュアル「HiRDB Version 7 システム導入・設計ガイド」を参照してください。
KFPA19502-E
Error occurred in UAP environment file aa....aa, operand=bb....bb,reason code=cc....cc　　（Ａ）
UAP環境定義ファイルでエラーが発生しました。
aa....aa：UAP環境定義ファイル名
bb....bb：エラーが発生したオペランド名
オペランドが特定できない場合はアスタリスク（＊）1文字を表示します。
cc....cc：理由コード
(Ｓ)このSQL文を無視します。
(Ｐ)出力された理由コードに対応する処置をしてください。
[対策]出力された理由コードに対応する処置をしてください。
理由
コード
説明
プログラマ
の処置
HiRDB管理者の処置
1
メモリ不足が発生しました。
UAPを再実行してください。再実行しても同じエラーになる場合はHiRDB管理者に連絡してください。
次に示すどれかの処置をして使用できるメモリに余裕を持たせてください。
・同時実行しているプロセス数を減らしてください。
・スワップ領域を増やしてください。
・実メモリを増やしてください。
2
ディクショナリサーバへの通信で障害が発生しました。
ディクショナリサーバが正常に開始されているか確認してください。
3
ディクショナリの検索に失敗しました。
なし。
データディクショナリ用RDエリアの状態を正しくしてください。
99
HiRDBの内部エラーが発生しました。
$PDDIR/spool，$PDDIR/lib/sysconf，及び$PDDIR/lib/sysdef下のファイルを保存して保守員に連絡してください。
100
UAP環境定義ファイルのオープンに失敗しました。
UAP環境定義ファイルがあるか，HiRDB管理者がこのファイルをオープンできるか（$PDCONFPATH/pduapenvディレクトリ及びUAP環境定義ファイルの権限の設定など）を確認してください。
101
定義不正です。
接続先のHiRDBサーバのサーバマシンのsyslogfileに出力されているエラーメッセージに従って対策してください。
300
pdlbufferオペランドに指定したRDエリアの種別に誤りがあります。
UAP環境定義のpdlbufferオペランドに指定したRDエリア名を修正してください。
301
pdlbufferオペランドに必要なオプションがありません。又は，指定できないオプションを指定しています。
UAP環境定義のpdlbufferオペランドのオプションの指定を修正してください。
302
pdlbufferオペランドに指定したローカルバッファ名，RDエリア名，又はインデクス名が重複しています。又は，インデクス名に誤りがあります。
UAP環境定義のpdlbufferオペランドのローカルバッファ名，RDエリア名，又はインデクス名を修正してください。
303
ローカルバッファ数が上限値を超えました。
UAP環境定義のpdlbufferオペランドの指定数を100以下にしてください。HiRDB/パラレルサーバの場合は1サーバ当たり100以下にしてください。
KFPA19503-E
Unable to begin transaction during maintenance of HiRDB　　（Ａ）
pdchgconfコマンド実行中，又はpdprgrenewコマンド実行中です。このため，ストアドプロシジャ，ALTER PROCEDURE，ALTER ROUTINE，又はALTER TRIGGER実行中のトランザクションの開始はできません。
(Ｓ)このSQL文を無視，又は中断します。
(Ｐ)pdchgconfコマンド，又はpdprgrenewコマンドの完了後に，UAPを再度実行してください。
KFPA19506-E
Extended statement name value "aa....aa" already defined　　（Ａ）
aa....aaを値に持つ拡張文名は，ほかのSQL文を識別しています。
aa....aa：拡張文名の値であるSQL文識別子
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA19507-E
PREPARE statment missing for extended statement name value "aa....aa"　　（Ａ）
aa....aaを値に持つ拡張文名の，SQL文に対応するPREPARE文が定義されていません。
aa....aa：拡張文名の値であるSQL文識別子
(Ｓ)このSQL文を無視します。
(Ｐ)拡張文名のSQL文に対応するPREPARE文を定義してください。
KFPA19508-E
Open cursor assosiated with prepared statement identified by "aa....aa" exists　　（Ａ）
関連付けられたカーソルが開いているため，拡張文名の値aa....aaに対するSQL文の割り当てを解放できません。
aa....aa：拡張文名の値であるSQL文識別子
(Ｓ)このSQL文を無視します。
(Ｐ)DEALLOCATE PREPARE文の実行前に，関連付けられたカーソルを閉じてから，再度実行してください。
KFPA19509-E
ALLOCATE CURSOR statement missing for cursor "aa....aa"　　（Ａ）
指定したカーソルaa....aaは，カーソル割り当てがされていません。
aa....aa：カーソル名
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA19510-E
Procedure aa....aa."bb....bb" not invoked　　（Ａ）
手続きaa....aa."bb....bb"が，同一SQLセッションで呼び出されていません。
aa....aa：認可識別子
bb....bb：ルーチン識別子
(Ｓ)このSQL文を無視します。
(Ｐ)ALLOCATE CURSOR実行前に，ALLOCATE CURSORで指定する手続きを同一SQLセッション内でCALLするように修正し，再度実行してください。
KFPA19511-E
Another cursor already allocated for procedure aa....aa."bb....bb"　　（Ａ）
手続きaa....aa."bb....bb"には，既にカーソルが割り当てられています。
aa....aa：認可識別子
bb....bb：ルーチン識別子
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA19512-E
Preparation for requested SQL became invalid　　（Ａ）
実行要求したSQL文の前処理は無効になっています。
(Ｓ)このSQL文を無視します。
(Ｐ)再度，SQL文をPREPARE文で前処理し，そのSQL文の実行を要求してください。
KFPA19513-E
Number of aa....aa exceeds bbbb　　（Ａ）
aa....aaの数が最大値bbbbを超えました。
・aa....aaが"exteneded statement name"の場合
前処理されたSQL文を識別している拡張文名の数が4095個を超えました。
・aa....aaが"extended cursor name"の場合
ALLOCATE CURSORで割り当てたカーソルを識別している拡張カーソル名の数が4095個を超えました。
aa....aa：｛extended statement name｜extended cursor name｝
bbbb：4095
(Ｓ)このSQL文を無視します。
(Ｐ)aa....aaの数が最大値以下になるようにUAPを修正してください。拡張文名や拡張カーソル名は，DEALLOCATE PREPARE文を実行することで，SQL文やカーソルを識別しなくなります。
KFPA19575-E
Invalid shared table/index definition code=aa(bb....bb)　　（Ａ）
共用表，又は共用インデクスの定義に誤りがあります。
aa：理由コード
bb....bb：エラーに対する付加情報
(Ｓ)このSQL文を無視します。
(Ｐ)理由コード及びエラー対する付加情報について次に示します。SQL文を修正し，ジョブを再度実行してください。
理由コード
エラーに対する付加情報
意味
01
Invalid specification for partitioning table
共用表は，分割格納できません。
02
Invalid specification for "WITHOUT ROLLBACK" table
共用表には，WITHOUT ROLLBACKを指定できません。
03
Specified RDAREA cc....cc for table not shared rdarea
HiRDB/パラレルサーバで共用表を定義する場合，共用表は共用RDエリア以外のRDエリアには格納できません。
cc....cc：RDエリア名
04
Specified RDAREA cc....cc for index not shared rdarea
HiRDB/パラレルサーバで共用インデクスを定義する場合，共用インデクスは共用RDエリア以外のRDエリアには格納できません。
cc....cc：RDエリア名
KFPA19576-E
Specify RDAREA aa....aa is shared RDAREA　　（Ａ）
指定したRDエリアは共用RDエリアのため，次の操作はできません。
・共用表以外の表定義
・共用インデクス以外のインデクス定義
・RDエリア追加
・分割格納条件の変更
aa....aa：RDエリア名
(Ｓ)このSQL文を無視します。
(Ｐ)共用RDエリアではないRDエリアを指定して，再度実行します。
KFPA19581-E
Invalid constraint definition for table aa....aa."bb....bb" code=cc(dd....dd) 　　（Ａ）
表aa....aa. bb....bbの参照制約定義，又は検査制約定義に誤りがあります。
aa....aa：認可識別子
bb....bb：表識別子
cc：理由コード
dd....dd：エラーに対する付加情報
(Ｓ)このSQL文を無視します。
(Ｐ)理由コード及びエラーに対する付加情報について次に示します。SQL文を修正して，ジョブを再度実行してください。
理由コード
エラーに対する付加情報
意味
01
shared table
共用表に参照制約は定義できません。
02
INSERT ONLY table
改竄防止表に参照制約及び検査制約は定義できません。
KFPA19582-E
Unable to drop column on aa....aa."bb....bb" due to cc....cc　　（Ａ）
次の理由で列が削除できません。
・列削除対象の表に検査制約が定義されています。
・列削除対象の表に参照制約（外部キー）が定義されています。
・列削除対象の表が参照制約の被参照表です。
aa....aa：認可識別子
bb....bb：表識別子
cc....cc：
check constraint：検査制約が定義されています。
referential constraint：参照制約（外部キー）が定義されています。
referenced table：参照制約の被参照表です。
(Ｓ)このSQL文を無視します。
(Ｐ)表名称を見直して，再度実行してください。
KFPA19583-E
Number of defined foreign keys on table aa....aa.”bb....bb” exceeds 255　　（Ａ）
一つの表に指定できる外部キーの数が最大数（255）を超えました。
aa....aa：認可識別子
bb....bb：表識別子
(Ｓ)このSQL文を無視します。
(Ｐ)CREATE TABLEの外部キーの数を見直して，再度実行してください。
KFPA19584-E
More than 254 check constraint limits in aa....aa."bb....bb"　　（Ａ）
表中に定義できる検査制約制限値（検査制約の探索条件中で指定した論理演算子の数（CASE式のWHEN探索条件中のANDとORを除いたANDとORの数）の合計と検査制約数の合計）が最大値（254）を超えたため，検査制約を定義できません。
aa....aa：認可識別子
bb....bb：表識別子
(Ｓ)このSQL文を無視します。
(Ｐ)検査制約制限値を254以下にして，再度実行してください。
KFPA19602-E
Unable to define referential constraint aa....aa."bb....bb" due to duplicated constraint　　（Ａ）
参照制約で，同じ列の集合（並びが同じでなくてもよい）から，同じ被参照表の主キーは参照できません。
aa....aa：認可識別子
bb....bb：制約名
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正して，再度実行してください。
KFPA19603-E
Unable to alter table,due to aa....aa　　（Ａ）
次に示す理由によって列の変更ができません。
・該当する列は，トリガ動作の探索条件で新旧値相関名を使用して参照しています。この列の変更，削除はできません。
・該当する列は，トリガSQL文で新旧値相関名を使用して参照しています。この列の変更，削除はできません。
aa....aa：
triggered action condition：
変更しようとした列は，トリガ動作の探索条件中で使用している列です。
triggered SQL statement：
変更しようとした列は，トリガSQL文で使用している列です。
(Ｓ)このSQL文を無視します。
(Ｐ)SQLオブジェクトを無効にしてもよい場合は，WITH PROGRAMを指定して，ジョブを再度実行してください。
KFPA19612-E
Invalid usage of MULTIDIM partitioning table code=aa,reason=bb....bb cc....cc dd....dd　　（Ａ）
マトリクス分割表の指定に誤りがあります。
aa：理由コード
bb....bb：エラー情報
理由コード（aa）とエラー情報（bb....bb）を次に示します。
理由コード（aa）
エラー情報（bb....bb）
説明
01
only one RDAREA
RDエリアを一つしか指定していません。
02
same RDAREA
全RDエリアに同じRDエリア名を指定しています。
03
baundary values over
指定した境界値の数の積が3,000を超えています。
04
value and RDAREA unmatch
境界値の数とRDエリアの数が不一致です。
05
RDAREA specification
RDエリアの指定に誤りがあります。次の原因が考えられます。
・表を格納するRDエリアの指定と，BLOB又はインデクスを格納するRDエリアの指定が不一致
・ALTER TABLE，CREATE INDEXの場合は表定義時の指定と不一致
・非分割キーインデクスの格納用RDエリアを指定していない
06
RDAREA LIST unmatch
マトリクス分割用RDエリアリストごとのRDエリア数が不一致です。
07
duplicated RDAREA exists in RDAREA LIST
マトリクス分割用RDエリアリストに同じRDエリア名を複数指定しています。
08
invalid hash name
ハッシュ関数の指定に次のどちらかの誤りがあります。
・ハッシュ関数名が不正
・分割キーの列長が不正
09
more than 15 columns for HASH KEY
ハッシュ分割の分割キーに指定する列が15を超えています。
cc....cc：エラー要因となったRDエリア指定箇所
table：表
column：列
index：インデクス
cluster key：クラスタキー
primary key：主キー
上記以外の場合は出力しません。
dd....dd：エラー要因となったRDエリアを指定した表名，列名，又はインデクス名
cc....ccがクラスタキー，主キーの場合は出力しません。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。
KFPA19615-E
Unable to aa....aa because INSERT ONLY table bb....bb."cc....cc" not empty　　（Ａ）
データが格納されている改竄防止表bb....bb.cc....ccに対して定義系SQL aa....aaは実行できません。
aa....aa：定義系SQL
DROP TABLE：表の削除
DROP SCHEMA：スキーマの削除
bb....bb：認可識別子
cc....cc：表名称
(Ｓ)このSQL文を無視します。
(Ｐ)データが格納されている改竄防止表は削除できません。表名称を見直し，再実行してください。
KFPA19616-E
Unable to drop insertion history column on INSERT ONLY table　　（Ａ）
改竄防止表の行削除禁止期間に指定した挿入履歴保持列は削除できません。
(Ｓ)このSQL文を無視します。
KFPA19617-E
Only DATE type column with "SYSTEM GENERATED" can be specified for insertion history column on INSERT ONLY table　　（Ａ）
改竄防止表の挿入履歴保持列にはSYSTEM GENERATED指定のDATE型の列以外は指定できません。
(Ｓ)このSQL文を無視します。
(Ｐ)挿入履歴保持列にSYSTEM GENERATED指定のDATE型の列を指定して，再度実行してください。
KFPA19620-E
Invalid delete prohibition interval for INSERT ONLY table　　（Ａ）
改竄防止表の行削除禁止期間の指定に誤りがあります。
(Ｓ)このSQL文を無視します。
(Ｐ)行削除禁止期間の指定を修正し，再度実行してください。
・日間隔データ指定の場合
0000年00月01日間～9999年11月99日間の範囲の10進数表現（YYYYMMDD.）で指定してください。
・ラベル付き間隔指定の場合
値式に次の範囲で指定してください。
YEAR〔S〕：1～9,998
MONTH〔S〕：1～119,987
DAY〔S〕：1～3,652,058
KFPA19625-E
Invalid usage on ALTER TABLE CHANGE RDAREA,code=aa(bb....bb)　（Ａ）
ALTER TABLE CHANGE RDAREAの指定が誤っています。
aa：理由コード
bb....bb：エラーに対する付加情報
(Ｓ)このSQL文を無視します。
(Ｐ)理由コード及びエラーに対する付加情報について次に示します。SQL文を修正して，ジョブを再度実行してください。
理由コード
エラーに対する付加情報
意味
01
Non partition divided table
境界値分割以外の表を指定しています。
02
Insert only table
改竄防止表を指定しています。
03
Not divided index exist on table
サーバ内横分割していて，非分割キーインデクスの格納RDエリアを横分割していません。又は，サーバ内横分割がない場合に，複数の分割格納条件を同じRDエリアに格納し，非分割キーインデクスを定義しています。
04
Invalid partition value
指定した境界値に次のような誤りがあります。
・境界値の文字列長が0です。
・境界値データ型が，分割格納条件に指定した列のデータ型に変換できません。
・境界値のデータ長が，分割格納条件に指定した列のデータ長を超えています。
・境界値が論理的に不適格です。
・境界値のデータ内容が不正です。
・変更対象の境界値が既存の定義中にありません。
・変更対象の境界値が昇順でありません。
・変更対象の境界値が連続していません。
・変更後の境界値が昇順でありません。
・変更後の境界値が重複指定されています。
・変更後の境界値の指定範囲に誤りがあります。
05
Invalid result
分割，又は統合した結果，次のようになりました。
・使用するRDエリアが一つになりました。
・総分割RDエリア数が1,024を超えました。
・総境界値の上限数（OTHERを含む）が3000を超えました。
06
Index not found on table
指定したインデクス，主キー，又はクラスタキーが該当表には定義されていません。
07
Not specify all index
すべてのインデクスに対して，FOR INDEX，FOR PRIMARY KEY，又はFOR CLUSTER KEYを指定していません。
08
Unmatch number of RDAREA
「変更後境界値分割指定」と，「変更後インデクス格納用RDエリア名リスト」又は「LOB列格納用RDエリア変更指定」に指定するRDエリアの数が異なっています。
09
Invalid RDAREA for index or "LOB"
表とインデクス，又は表とBLOB列を格納するRDエリアの対応関係に次のどれかの誤りがあります。
・重複するRDエリアを指定した位置が，「変更後境界値分割指定」と，「変更後インデクス格納用RDエリア名リスト」，又は「LOB列格納用RDエリア変更指定」で異なります。
・新規のRDエリアを指定した位置が，「変更後境界値分割指定」と，「変更後インデクス格納用RDエリア名リスト」，又は「LOB列格納用RDエリア変更指定」で異なります。
・既存のRDエリアを指定する位置が，「変更後境界値分割指定」と，「変更後インデクス格納用RDエリア名リスト」，又は「LOB列格納用RDエリア変更指定」で異なります。
11
Duplicate RDAREA
異なるLOB列を格納するRDエリアに，同じRDエリアを複数指定しているか，又は既に格納されているRDエリアを追加しようとしています。
13
Invalid usage WITHOUT PURGE
WITHOUT PURGEの指定に誤りがあります。
・WITHOUT PURGEを指定しているが，変更後のRDエリアに変更前のRDエリアを指定していません。
14
Invalid RDAREA
「変更後境界値分割指定」，「変更後インデクス格納用RDエリア名リスト」，又は「LOB列格納用RDエリア変更指定」に次のどれかの誤りがあります。
・存在しないRDエリアを指定しています。
・分割時，連続した複数の境界値を同一のRDエリアに指定しています（変更後境界値分割指定だけ該当）。
・統合時，指定したRDエリアが前後の格納範囲のRDエリアと同一です（変更後境界値分割指定だけ該当）。
15
FOR COLUMN clause invalid
指定した列に誤りがあります。
・BLOB列ではありません。
16
Duplicate INDEX name
インデクス名が重複して指定されています。
17
Invalid index type
FOR PRIMARY，FOR CLUSTER，又はFOR INDEX句に指定したインデクスの種別が不正です。
18
Duplicate column name
列名が重複して指定されています。
19
Not specify all "LOB"
すべてのLOB列に対して，FOR COLUMN句を指定していません。
51
Too many number of value
指定した境界値の数が変更できる数を超えています。
・分割時：変更対象は最大1，変更後は最大16です。
・統合時：変更対象は最大16，変更後は1です。
52
Too many specify "FOR INDEX"
FOR INDEX を256回以上指定しています。
53
Too many specify "FOR PRIMARY" or "FOR CLUSTER"
FOR PRIMARY又はFOR CLUSTERを2回以上指定しています。
99
User data type or matrix table
次の分割表の分割格納条件は変更できません。
・抽象データ型の列を使用している横分割表
・マトリクス分割表
KFPA19631-E
Definition for INSERT ONLY table aa....aa."bb....bb" failed, code=cc(dd....dd)　　（Ａ）
改竄防止表関連の定義でエラーが発生しました。
aa....aa：認可識別子
bb....bb：表識別子
cc：理由コード
dd....dd：エラーに対する付加情報
(Ｓ)このSQL文を無視します。
(Ｐ)理由コード及びエラーに対する付加情報について次に示します。SQL文を修正して，ジョブを再度実行してください。
理由コード
エラーに対する付加情報
意味
対策
01
INSERT ONLY table
次のどちらかの原因が考えられます。
・改竄防止表に対してINSERT ONLYオプションを指定しました。
・改竄防止表に対して更新可能列属性を指定しました。
指定した表名称を見直してください。
02
referential constraint
参照制約を定義した表は改竄防止表にできません。
03
check constraint
検査制約を定義した表は改竄防止表にできません。
04
data type
次のデータ型にはUPDATE ONLY FROM NULLを指定できません。
・BLOB列
・BINARY型の32,001バイト以上の列
指定した列名称を見直してください。
05
already defined
次のどちらかの原因が考えられます。
・更新可能列に更新可能列属性を指定しました。
・データ型がBINARY型で32,001バイト以上の列に，更新可能列属性を指定しました。
06
SYSTEM GENERATED
SYSTEM GENERATEDを指定した列に更新可能列属性は指定できません。
07
NOT NULL
非ナル値属性の列にUPDATE ONLY FROM NULLは指定できません。
08
can not update
次のどちらかの原因が考えられます。
・クラスタキーに更新可能列属性を指定しました。
・分割キー構成列に更新可能列属性を指定しました。ただし，フレキシブルハッシュ分割の分割キー構成列の場合，UPDATE指定だけは可能です。
09
only UPDATE columns
次のどちらかの原因が考えられます。
・すべての列に更新可能列属性を指定した表を改竄防止表にしようとしました。
・改竄防止表を操作した結果，すべての列が更新可能列となる指定はできません。
・CREATE TABLE実行時の場合
更新可能列属性以外の列を1列以上定義してください。
・ALTER TABLE CHANGE INSERT ONLY 実行時の場合
更新可能列属性以外の列を追加してください。
・ALTER TABLE DROP 列名 実行時
列名称を見直してください。
KFPA19632-E
User aa....aa unable to execute CONNECT　　（Ａ）
認可識別子aa....aaのユーザはHiRDBに接続（CONNECT）できません。
aa....aa：認可識別子
(Ｓ)このSQL文を無視します。
(Ｐ)要因と対策を次に示します。
要因
対策
・CONNECT権限がありません。
・ディレクトリサーバ連携機能を使用している場合，ディレクトリサーバにユーザが登録されていません。
・表のアクセス時にこのメッセージが出力された場合は，ユーザがHiRDBに接続した時点から今までの間にディレクトリサーバのユーザ情報が削除されています。
・DBA権限保持者に依頼して，CONNECT権限を付与してもらい，再度実行してください。
・ディレクトリサーバ連携機能を使用している場合は，システム管理者に依頼して，ディレクトリサーバにユーザ登録をしてもらってください。
・指定したパスワードに誤りがあります。
・ディレクトリサーバ連携機能を使用している場合は，指定したパスワードがディレクトリサーバに登録されているパスワードと異なるか，又はパスワードが期限切れになっています。
・表のアクセス時にこのメッセージが出力された場合は，ユーザがHiRDBに接続した時点から今までの間にディレクトリサーバのユーザ情報のパスワード属性が変更されたか，又はパスワードの期限が切れました。
・HiRDBへの接続時にこのメッセージが出力された場合は，正しいパスワードを指定して，再度実行してください。
・ディレクトリサーバに登録したパスワードが期限切れの場合は，ディレクトリサーバにパスワードを再設定した後に，再度実行してください。
・表のアクセス時にこのメッセージが出力された場合は，一度HiRDBとの接続を解除した後に，ディレクトリサーバに登録している現時点の認可識別子とパスワードを指定してください。その後，HiRDBに再接続して，再度実行してください。
連続認証失敗アカウントロック状態です。
DBA権限保持者に自分が連続認証失敗アカウントロック状態になっているかを確認してください。連続認証失敗アカウントロック状態の場合は，HiRDB管理者に連続認証失敗アカウントロック状態を解除してもらった後に，再度実行してください。
パスワード無効アカウントロック状態です。
DBA権限保持者に自分がパスワード無効アカウントロック状態になっているかを確認してください。
パスワード無効アカウントロック状態の場合は，DBA権限保持者にパスワードの文字列制限を満たすパスワードに変更してもらった後に，再度実行してください。
KFPA19633-E
Unable to execute SQL for connection security,code=aa(bb....bb)　　（Ａ）
aaの理由によってCONNECT関連セキュリティ機能のSQLは実行できません。
aa：理由コード
bb....bb：エラーに対する付加情報
(Ｓ)このSQL文を無視します。
(Ｐ)出力された理由コード及びエラーに対する付加情報から原因を取り除き，再度SQLを実行してください。
理由
コード
エラーに対する付加情報
意味
01
Lack of privilege
DBA権限がないため実行できません。又は，DBA権限保持者のパスワードをHiRDBに登録していないため実行できません。
02
Specified value for "PASSWORD MIN LENGTH" out of range
パスワードの最小許容バイト数の指定値が範囲外です。
03
Specified value for "CONNECT PERMISSION COUNT" out of range
連続認証失敗許容回数の指定値が範囲外です。
04
Specified value for "CONNECT LOCK" out of range
アカウントロック期間の指定値が範囲外です。
05
Invalid Password of DBA or auditor
DBA権限保持者，又は監査人のパスワードがパスワードの文字列制限に違反しています。
06
Already defined
指定したCONNECT関連セキュリティ機能は既に定義されています。
07
Undefined
指定したCONNECT関連セキュリティ機能は定義されていません。
08
Using directory server
ディレクトリサーバ連携機能を使用している場合は実行できません。
KFPA19634-E
Unable to execute "GRANT aa....aa" to bb....bb due to invalid password (cc....cc)　　（Ａ）
パスワードが次に示すどれかの制限に違反しているため，GRANT文を実行できません。
・最小許容バイト数
・認可識別子の指定禁止
・単一文字種の指定禁止
aa....aa：DBA
AUDIT
CONNECT
bb....bb：認可識別子
cc....cc：min length
user identifier
similar
(Ｓ)このSQL文を無視します。
(Ｐ)パスワードの文字列制限を満たすパスワードに変更し，再度SQLを実行してください。
KFPA19635-E
Unable to execute "GRANT DBA" to aa....aa for password account locked　　（Ａ）
ユーザaa....aaはパスワード無効アカウントロック状態のため，GRANT DBA文でDBA権限の付与，又はパスワードの変更ができません。
aa....aa：認可識別子
(Ｓ)このSQL文を無視します。
(Ｐ)パスワード無効アカウントロック状態を解除してからGRANT DBA文を実行してください。パスワード無効アカウントロック状態を解除する方法については，マニュアル「HiRDB Version 7 システム運用ガイド」を参照してください。
KFPA19680-E
Invalid event type aa....aa bb....bb for specified audit definition　　（Ａ）
監査対象イベント定義で，aa...aaで示す操作種別とbb...bbで示すイベント種別と，AUDITTYPEの指定の組み合わせが不正です。
aa....aa：操作種別
bb....bb：イベント種別
操作種別及びイベント種別を次に示します。
<TBLATT POSITION="1" SCALE="126.5">
操作種別
イベント種別
ANY
***（該当しない）
SESSION
CONNECT
AUTHORIZATION
ANY
PRIVILEGE
GRANT
REVOKE
ANY
DEFINITION
CREATE
DROP
ALTER
ANY
ACCESS
SELECT
INSERT
UPDATE
DELETE
PURGE
ASSIGN
CALL
LOCK
ANY
UTILITY
PDLOAD
PDRORG
PDEXP
ANY
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度実行してください。操作種別及びイベント種別とAUDITTYPEの指定の組み合わせ可否については，マニュアル「HiRDB Version 7 SQLリファレンス」のCREATE AUDITを参照してください。
KFPA19681-E
Unable to specify aa....aa."bb....bb" in PUBLIC VIEW definition　　（Ａ）
パブリックビュー定義に，次の表は指定できません。
・ほかのユーザを所有者とする実表ビュー表，又は外部表
・ほかのユーザを定義者とするパブリックビュー表
・ほかのユーザを所有者とする実表ビュー表，又は外部表を基表とする，ビュー表，又は外部表
・ほかのユーザを定義者とするパブリックビュー表を基表とする，ビュー表，又は外部表
aa....aa：認可識別子
bb....bb：実表，ビュー表パブリックビュー表，又は外部表の表識別子
(Ｓ)このSQL文を無視します。
(Ｐ)パブリックビューの基表を見直してください。
KFPA19700-E
HiRDB is under maintenance code=a　　（Ａ）
pdchgconfコマンド実行中，又はpdprgrenewコマンド実行中です。そのため，クライアントの接続，及びトランザクションの開始はできません。
a：内部コード
(Ｓ)HiRDBからクライアントを切り離します。
(Ｐ)UAPを終了してください。
(Ｏ)
クライアントライブラリがバージョン07-00以降の場合：
pdchgconfコマンド，又はpdprgrenewコマンドが失敗している可能性があります。HiRDB管理者にHiRDBの状態の確認を依頼してください。HiRDBが開始されたら，UAPを再度実行してください。
クライアントライブラリがバージョン07-00より前の場合：
pdchgconfコマンド，又はpdprgrenewコマンドの完了後に，UAPを再度実行してください。
KFPA19701-E
Unable to execute required SQL in Online DB Reorganization, RDAREA = aa....aa　　（Ａ）
更新可能なオンライン再編成実行中は，要求されたSQLを実行できません。
aa....aa：RDエリア名
(Ｓ)該当するトランザクションを無効にします。
(Ｏ)HiRDB管理者に連絡してください。
[対策]該当するRDエリアの更新可能なオンライン再編成が解除されてから，再度実行してください。
解除しないで再度実行する場合，次の項目について検討してください。
3. ログレス環境で実行している場合は，クライアント環境変数PDDBLOGをALLに変更できないか検討してください。
4. 更新可能なオンライン再編成中は，UAPでオリジナルRDエリアを操作できません。操作を行いたい場合はクライアント環境定義PDDBORGUAPにYESを指定してください。オンライン再編成閉塞中のオリジナルRDエリアの運用については，マニュアル「HiRDB Staticizer option Version 7」を参照してください。また，更新可能なオンライン再編成のコマンドについては，マニュアル「HiRDB Version 7 コマンドリファレンス」を参照してください。
KFPA19702-E
Unable to execute SQL for definition,RDAREA name=aa....aa,tableID=bb....bb,reason code=c　　（Ａ）
cの理由によって，定義系SQLが実行できません。
aa....aa：不正状態を検知したRDエリア名
理由コードが1及び3の場合は********が表示されます。
bb....bb：定義系SQLの対象表の番号，又は定義系SQLの対象インデクスが定義されている表の番号
表定義（CREATE TABLE）の場合は********が表示されます。
c：理由コード
1：インナレプリカ機能適用時の定義系SQL実行条件を満たしていません。
2：表番号bb....bbに関連するRDエリアaa....aaが更新可能なオンライン再編成を実行中です。
3：表番号bb....bbに関連するRDエリアに，コマンド閉塞かつクローズ状態と，それ以外の状態が混在しています。
(Ｓ)このSQLを無視します。
[対策]
理由コードが1の場合：
pdrdreflsコマンドを実行して，該当する表に関連するRDエリアを確認してください。そして，pddblsコマンドを実行して，該当する表に関連するRDエリアが次の条件をすべて満たしているか確認してください。
・インナレプリカ機能を適用しているRDエリアと，適用していないRDエリアは混在して指定していない。
・レプリカRDエリアの定義数が一致している。
・レプリカRDエリア定義の世代番号がそろっている。
条件を満たしてから，再度定義系SQLを実行してください。
理由コードが2の場合：
更新可能なオンライン再編成を完了させてから，再度定義系SQLを実行してください。
理由コードが3の場合：
pdrdreflsコマンドとpddblsコマンドを実行して，該当する表に関連するRDエリアの状態が，コマンド閉塞かつクローズ状態かを確認してください。
KFPA19703-E
Error occurred during execution of transaction aa....aa, reason=bb....bb, code=cc....cc, server=dd....dd　　（Ａ）
トランザクションの制御処理中にエラーが発生しました。
aa....aa：トランザクション制御処理
begin：トランザクションの開始処理
branch：トランザクションのブランチ処理
bb....bb：発生事象
cc....cc：理由コード
dd....dd：エラーが発生したサーバ名
エラーが発生したサーバ名が特定できない場合は"********"と表示されます。
(Ｓ)このSQL文を無視します。又はトランザクションを無効にします。
(Ｏ)HiRDB管理者に連絡し，原因を取り除いた後，処理を再度実行してください。
[対策]発生事象及び理由コードに対応する処置に従ってください。
制御処理
（aa....aa）
発生事象
（bb....bb）
理由コード
（cc....cc）
説明
HiRDB管理者の処置
begin
TRNPAUSE
－948
サーバ（dd....dd）が新規トランザクションのスケジューリング抑止状態です。
このメッセージの出力時刻前後に，システムマネジャのユニットのsyslogfile（Windows NTの場合はイベントログ）にKFPS01160-Eメッセージが出力されている場合は，KFPS01160-Eメッセージの対策に従って原因を取り除いてください。
上記以外の場合で，スタンバイレス型系切り替え機能を適用したユニットが系の切り戻し中のときは，系の切り戻しが完了するまで待ってください。
STLSFES
－944
回復不要FES（dd....dd）にX/Open XAインタフェースを使用しているUAPから接続しています。
回復不要FESではないフロントエンドサーバに接続して再度実行してください。
branch
TRNPAUSE
－376
サーバ（dd....dd）が新規トランザクションのスケジューリング抑止状態です。
このメッセージの出力時刻前後に，システムマネジャのユニットのsyslogfile（Windows NTの場合はイベントログ）にKFPS01160-Eメッセージが出力されている場合は，KFPS01160-Eメッセージの対策に従って原因を取り除いてください。
上記以外の場合で，スタンバイレス型系切り替え機能を適用したユニットが系の切り戻し中のときは，系の切り戻しが完了するまで待ってください。
KFPA19705-E
Failed to allocate local buffer pool,error=aa　　（Ａ）
ローカルバッファの割り当てに失敗しました。
aa：エラー要因コード
(Ｓ)HiRDB/シングルサーバの場合はこのSQL文を無視します。HiRDB/パラレルサーバの場合はロールバックします。
(Ｐ)HiRDB管理者に連絡してください。
[対策]エラー要因コードに対応する対策をしてください。
エラー要因
コード
原因
対策
20
メモリ不足が発生しました。
次に示すどれかの処置をしてください。
・スワップ領域を増やす
・プロセス数を減らす
・ユニット内サーバ数を減らす
32
ローカルバッファ用のプロセス固有メモリのサイズ計算でけたあふれが発生しました。
ローカルバッファ用のプロセス固有メモリのサイズ計算でけたあふれが発生しました。エラーが発生したサーバのローカルバッファ数又はバッファ面数を減らして，ローカルバッファ用のプロセス固有メモリサイズが231－1以下（64ビットモードの場合は263－1以下）になるようにしてください。
KFPA19706-E
Please reorganize Table,due to LOB DIRECTORY overflow,RDAREA name=aa....aa,tableID=bb....bb　　（Ａ）
LOB用RDエリア内の管理情報が上限値を超えました。
aa....aa：RDエリア名
bb....bb：表番号
(Ｓ)このSQL文を無視します。
[対策]該当するRDエリアに対応する処置をしてください。
・ユーザLOB用RDエリアの場合
aa....aaに格納されているLOB列，又はLOB属性を定義している表を再編成してください。
・データディクショナリLOB用RDエリアの場合
ストアドプロシジャ，及びストアドファンクションに関するディクショナリ表を再編成してください。
・レジストリLOB用RDエリアの場合
レジストリ表を再編成してください。
KFPA19800-E
Output file aa....aa error occurred in EXECUTE UTL statment, errno=bb....bb　　（Ａ）
EXECUTE UTLの結果ファイル出力処理でエラーが発生しました。
aa....aa：ファイル操作内容
open：ファイルのオープン
write：ファイルへの書き込み
bb....bb：エラーコード
(Ｓ)処理を終了します。
(Ｐ)エラーコードの値を調査し，errno.h及びユーザが使用するOSのマニュアルを参照して，エラーの原因を取り除き，再実行してください。
KFPA19801-E
Invalid value of aa....aa　　（Ａ）
aa....aaの値に，次のどちらかの誤りがあります。
・長さが0又は負の値である。
・使用できない文字がある。
aa....aa：｛extended statement name｜extended cursor name｝
(Ｓ)このSQL文を無視します。
(Ｐ)次のどちらかの対処をしてください。
・aa....aaに1以上の値を設定してください。
・aa....aaに使用できる文字を指定してください。
KFPA20000-E
System function error occurred. name=aa....aa, code=bbbb　　（Ａ）
システム内関数でエラーが発生しました。
aa....aa：エラーの発生した関数名
bbbb：システムコールのerrno
(Ｓ)異常終了します。
(Ｏ)システムコールのerrnoからエラーになった原因を調査し，対策した後，再度UAP又はコマンドを実行してください。
KFPA20001-E
Communication buffer allocation error occurred, code=aaaa　　（Ｌ）
通信用バッファの割り当てに失敗しました。
aaaa：エラーコード
(Ｓ)異常終了します。
(Ｏ)このメッセージが出力されたサーバの常駐プロセス数（pd_process_count）を減らしてください。
KFPA20002-E
Communication error,abort=aa....aa, code=bbbbb　　（Ｌ）
通信処理でエラーが発生しました。
aa....aa：アボートコード
bbbbb：エラー詳細コード
(Ｓ)処理を終了します。
(Ｏ)「エラー詳細コード一覧」を参照してエラーの原因を取り除き，再度UAP又はコマンドを実行してください。なお，オペレータが対処できないエラーが発生している場合は，HiRDB管理者に連絡してください。
[対策]保守員に連絡してください。
KFPA20003-E
Insufficient aa....aa memory, server=bb....bb, size=cc....cc　　（Ｌ）
HiRDBシステムが処理するために必要なメモリが不足しています。
aa....aa：メモリ不足が発生した領域の種別
SHARED：共用メモリ
PROCESS：プロセス固有領域
bb....bb：エラーの発生したサーバ名
cc....cc：不足したサイズ（単位：バイト）
(Ｓ)〈サーバ開始時〉
サーバの開始を中断します。
〈トランザクション入力時〉
該当するトランザクションを処理しようとしたプロセスを異常終了させます。
[対策]共用メモリが不足したサーバの共用メモリサイズを増やし，エラーが発生したサーバを再度開始してください。共用メモリサイズの大きさは次に示すオペランドで指定します。
・pd_sds_shmpool_size（シングルサーバ定義）
・pd_dic_shmpool_size（ディクショナリサーバ定義）
・pd_bes_shmpool_size（バックエンドサーバ定義）
プロセス固有領域が不足した場合は，次に示す方法で，使用するメモリに余裕を持たせてください。
・同時実行しているプロセスを減らしてください。
・スワップ領域を増やしてください。
・実メモリを増やしてください。
・サーバ定義のpd_work_buff_sizeオペランドの指定値が大きい場合，指定値を減らしてください。
・サーバ常駐プロセス数（pd_process_countオペランドの値）を少なくしてください。
KFPA20004-I
BES aa....aa used as floatable server for FES bb....bb(cc....cc/dd....dd)　　（Ｌ）
フロントエンドサーバbb....bbで受け付けるSQL処理にフロータブルサーバを使用するときは，バックエンドサーバaa....aaの中から使用します。
なお，フロータブルサーバとして使用するバックエンドサーバが13以上の場合，このメッセージは分割して出力されます。
aa....aa：フロータブルサーバとして使用するバックエンドサーバのサーバ名のリスト
bb....bb：フロントエンドサーバのサーバ名
cc....cc：このメッセージの分割番号
dd....dd：このメッセージの分割数
(Ｓ)処理を続行します。
(Ｏ)フロントエンドサーバ定義に，pd_floatable_bes指定とpd_non_floatable_bes指定を同時にしている場合は，pd_floatable_besが優先されます。メッセージに表示されたフロータブルサーバとして使用するサーバのリストから，フロントエンドサーバ定義の指定が正しいか確認してください。誤っている場合は，フロントエンドサーバを停止後，フロントエンドサーバ定義を修正して再度開始してください。
なお，メッセージが複数に分割して出力される場合には，要求順に連続して出力されない場合があるので注意してください。
KFPA20005-E
Invalid value bb....bb specified for operand aa....aa　　（Ｅ＋Ｌ）
システム定義に指定したaa....aaオペランドの指定値（識別子又は符号なし整数）に誤りがあります。
aa....aa：オペランド名
bb....bb：オペランドの指定値（30バイトを超える場合は，先頭から30バイトを表示）
(Ｓ)HiRDBの開始処理を中断します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]システム定義に指定したaa....aaオペランドの指定値を修正し，HiRDBを再度開始してください。
KFPA20006-E
aa....aa in FES definition bb....bb, file=cc....cc, pos=dd....dd　　（Ｅ＋Ｌ）
フロントエンドサーバ定義のbb....bbオペランドがaa....aaエラーとなりました。
aa....aa：エラーの要因
Invalid option：オプションが不正です。
Invalid value：オプション値が不正です。
Duplicate options：同一オプションのオペランドが既にあります。
bb....bb：エラーとなったオペランド名
cc....cc：定義ファイル名（30バイトを超える場合は先頭30バイトを表示）
dd....dd：エラーとなったオペランドの位置（定義の何番目のオペランドでエラーとなったかを示す情報）
(Ｓ)エラーとなった定義のオペランドを無視します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]dd....dd番目のbb....bbオペランドを指定し直して，HiRDBを再開始してください。
KFPA20007-E
Java VM library not found at aa....aa, server=bb....bb, errno=ccc　　（Ｌ）
Java仮想マシンのライブラリがありません。
aa....aa：Java仮想マシンのライブラリのパス名（160文字を超える場合は，160文字目に#を表示）
bb....bb：Java仮想マシンを実行するサーバ名
ccc：OSからのエラーコード
(Ｓ)処理を終了します。
[対策]errno.h及びOSのマニュアルを参照して，エラーコードcccの要因を取り除いてから，HiRDBを再開始してください。
aa....aaのファイルがない場合，HiRDB管理者に読み込み権限及び実行権限を与えてください。また，システム定義のpd_java_runtimepathオペランド及びpd_java_libpathオペランドの設定を見直してください。
KFPA20008-W
External Data Access optimization definition file not found, foreign server=aa....aa　　（Ｌ）
外部サーバaa....aaに対応するHub最適化情報定義ファイルがありません。該当する外部サーバのHub最適化情報定義ファイルで指定するオペランドには，すべてデフォルト値を仮定しました。
aa....aa：外部サーバ名
(Ｓ)処理を終了します。
[対策]
Hub最適化情報定義ファイルを指定している場合：
ファイル名に誤りがないか確認してください。
Hub最適化情報定義ファイルを指定していない場合：
外部サーバをアクセスする場合，Hub最適化情報定義ファイルを指定することで性能が向上する可能性があるため，作成することを検討してください。なお，該当する外部サーバのHiRDB External Data Access Adapterに，推奨値が入っているHub最適化情報定義ファイルがあります。そのHub最適化情報定義ファイルをそのまま利用することをお勧めします。
KFPA20009-W
SQL inf(aa) bb....bb cc....cc dd....dd ee....ee ff....ff　　（Ｌ）
UAPの強制終了などでサーバプロセスが強制終了したときのSQLの情報を表示します（理由コードが00の場合）。
SQL実行時間警告出力機能による警告を受けたSQLの情報を表示します（理由コードが01の場合）。
aa：理由コード
00：UAPの強制終了などでサーバプロセスが異常終了して処理が中断されました。
01：SQLの実行時間がSQL実行時間警告出力機能で設定した時間以上になりました。
bb....bb：サーバ情報（次のどちらかの形式で出力します）
シングルサーバ名称，コネクト通番
フロントエンドサーバ名称，コネクト通番
cc....cc：クライアント情報（次の形式で出力します）
UAP名称 UAPのプロセスID （UAPのIPアドレス）
dd....dd：実行したSQLの情報（次の形式で出力します）
オペレーションコード　SQLカウンタ　SQLCODE
・オペレーションコード
オペレーションコードについては，マニュアル「HiRDB Version 7 UAP開発ガイド」を参照してください。理由コードが00の場合，オペレーションコードを設定できないことがあります。設定できない場合は＊を表示します。
・SQLカウンタ
SQL文を受け付けるごとにカウントしている値を表示します。SQLカウンタを設定できない場合は＊を表示します。
・SQLCODE
SQL文を実行した結果のSQLCODEを表示します。理由コードが00の場合，SQLCODEを設定できないことがあります。設定できない場合は＊を表示します。
ee....ee：SQLの実行時間（次のどれかの形式で出力します）
・最大待ち時間に対する比率を符号なし整数で指定した場合
SQL実行開始時間－SQL実行終了時間
hh:mm:ssの形式で表示します（hh：時，mm：分，ss：秒）。
理由コードが00の場合，SQL実行開始時間を設定できないことがあります。設定できない場合は＊を表示します。また，SQL実行終了時間にはSQLが中断した時間を表示します。
・最大待ち時間に対する比率を符号なし10進数で指定した場合，及び出力契機の時間を指定した場合
SQL実行開始時間－SQL実行終了時間
hh:mm:ss.xxxxの形式で表示します（hh：時，mm：分，ss：秒，xxxx：マイクロ秒）。
理由コードが00の場合，SQL実行開始時間を設定できないことがあります。設定できない場合は＊を表示します。また，SQL実行終了時間にはSQLが中断した時間を表示します。
ff....ff：実行を終了又は中断したSQL文
設定できない場合は＊を表示します。
SQL文の長さによってはSQL文の表示を途中で打ち切ります。打ち切りが発生した場合は，メッセージの終端に#が付加されます。
(Ｓ)処理を続行します。
[対策]次に示すどちらかの対処をしてください。
・理由コードが00の場合
計画的でないサーバプロセスの強制終了の場合は，ほかのメッセージも参照して原因を取り除いてください。
・理由コードが01の場合
SQL実行時間警告情報ファイルを参照して，次に示す対処をしてください。
・排他競合が発生しているかを見直す
・ネットワーク障害が発生していないかを見直す
・SQLをチューニングする
・PDCWAITTIMEオペランドの指定値を大きくする
・データ件数の増加によってSQLの実行時間が長くなっていないかを確認する
SQL実行時間警告出力機能，及びSQL実行時間警告情報ファイルについては，マニュアル「HiRDB Version 7 システム運用ガイド」を参照してください。
KFPA20010-W
Invalid pd_delete_reserved_word_file operand　　（C）
システム共通定義pd_delete_reserved_word_fileオペランドの指定に次の誤りがあります。
・指定したSQL予約語削除ファイルがありません。
・指定したSQL予約語削除ファイルが重複しています。
(Ｓ)処理を続行します。
[対策]システム共通定義pd_delete_reserved_word_fileオペランドの指定が正しいか確認してください。誤っている場合は，HiRDBを停止後，システム共通定義pd_delete_reserved_word_fileオペランドの指定を修正して再度開始してください。
KFPA20011-W
Invalid "SQL_reserved_word_delete_file", file=aa....aa　　（C）
SQL予約語削除ファイルに，削除できない予約語を指定しています。
aa....aa：誤りがあるSQL予約語削除ファイルの名称
(Ｓ)処理を続行します。
[対策]SQL予約語削除ファイルの内容が正しいか確認してください。誤っている場合は，HiRDBを停止後，SQL予約語削除ファイルを修正して再度開始してください。


KFPBメッセージ

KFPB00101-E
DF/UX server (process ID=aa....aa) killed, code=bbbbbbb, file=cc....cc, line=dd....dd　　（Ｅ＋Ｌ）
DF/UXサーバプロセス内のHiRDBライブラリで異常が発生しました。このため，DF/UXサーバプロセスが異常終了しました。
aa....aa：アボートプロセスのプロセスID
bbbbbbb：アボートコード
cc....cc：エラーを検出したソースファイルの名称
dd....dd：エラーを検出した位置
(Ｓ)異常終了します。
(Ｐ)HiRDB管理者に連絡してください。
(Ｏ)HiRDB管理者に連絡してください。
[対策]保守員に連絡してください。
KFPB10383-E
Failure occurred in remote access, reason code=aa, process ID=bb....bb, connection ID=cc....cc, RMID=dd....dd　　（Ｅ＋Ｌ）
リモートデータベースアクセス処理中に障害が発生しました。
aa：理由コード
bb....bb：シングルサーバ又はフロントエンドサーバのプロセスID
cc....cc：HiRDBとDF/UXとのコネクションID
表示できないときは，’*’を表示します。
dd....dd：HiRDBからDF/UXに渡すRMID
表示できないときは，’*’を表示します。
(Ｓ)このトランザクションを無効にします。
[対策]理由コードに従って対策してください。
理由コ―ド
意味
対策
1
DF/UXが起動していません。又は異常終了中
未起動の場合は，DF/UXを起動してから再度UAPを実行してください。
異常終了中の場合は，DF/UXが出力したメッセージを参照して，DF/UXが異常終了した原因を調査してください。
詳細は，マニュアル「分散データベース　DF/UX」を参照してください。
不明な場合は保守員に連絡してください。
2
DF/UXの最大ユーザ数を超過
同時に使用するユーザ数を減らしてください。
又は，DF/UXの最大ユーザ数を変更してください。
詳細は，マニュアル「分散データベースDF/UX」を参照してください。
3
DF/UXがタイムアウト検出
UAPを再実行してください。
又は，DF/UXのリモートデータベースアクセス処理の打ち切り時間を変更してください。
詳細は，マニュアル「分散データベース　DF/UX」を参照してください。
4
DF/UXが通信障害を検出
DF/UXが出力したメッセージを参照して，通信障害の原因を調査してください。原因が判明した場合は，原因を取り除いた後再度UAPを実行してください。
詳細は，マニュアル「分散データベース　DF/UX」を参照してください。
不明な場合は保守員に連絡してください。
5
DF/UXのバージョンが不正
DF/UXのバージョンを調べて，前提バージョンと異なる場合は，DF/UXを入れ替えてください。
KFPB10388-E
DF/UX error detected in remote access, process ID=aa....aa, connection ID=bb....bb, RMID=cc....cc, dd....dd　　（Ｅ＋Ｌ）
リモートデータベースアクセス処理中に，DF/UXで異常が発生しました。
aa....aa：シングルサーバ又はフロントエンドサーバのプロセスID
bb....bb：HiRDBとDF/UXとのコネクションID
表示できないときは，’*’を表示します。
cc....cc：HiRDBからDF/UXに渡すRMID
表示できないときは，’*’を表示します。
dd....dd：保守情報
(Ｓ)このSQL文を無視します。
[対策]DF/UXのメッセージが出力されている場合，そのメッセージを基に原因を調査してください。なお，エラーの要因が判断できない場合，保守員に連絡してください。
KFPB20001-E
Library version incompatible, library version=aa....aa, HiRDB version=bb....bb　　（Ｌ）
リモートデータベースアクセスで，DF/UXのサーバ機能実行ファイルにリンクされているHiRDBのライブラリのバージョンとHiRDBのバージョンが一致しません。
aa....aa：ライブラリのバージョン番号
bb....bb：HiRDBのバージョン番号
(Ｓ)分散クライアントとのアソシエーションを解放します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]DF/UXのサーバ機能実行可能ファイルを再度作成してください。作成方法については，マニュアル「HiRDB Version 7 システム運用ガイド」を参照してください。
KFPB20002-E
Communication error, user=aa....aa, code=bb, inf=cc....cc　　（Ｌ）
リモートデータベースアクセスで，DF/UXのサーバ機能実行ファイルにリンクしたHiRDBのプログラムが，HiRDBサーバとの通信に失敗しました。
aa....aa：分散クライアントが指定したユーザID
分散クライアントがHiRDBの場合は，UAPが指定した認可識別子と一致します。
bb：理由コード
cc....cc：保守用情報
(Ｓ)分散クライアントとのアソシエーションを解放します。
(Ｏ)理由コードの内容に従って対策してください。
理由コード
意味
対策
01
通信障害が発生しました。
通信エラーログファイルに出力されているHiRDBクライアントライブラリのメッセージを参照してください。
02
HiRDBサーバで通信用のバッファ領域を確保できません。
このエラーが多発する場合，保守員に連絡してください。
03
送受信データの内容に矛盾があります。
保守員に連絡してください。
04
分散データベース機能を使用できません。
分散データベース機能を使用する場合は，フロントエンドサーバ定義又はシングルサーバ定義にpd_node_nameオペランドを指定してください。
分散データベース機能を使用しない場合は，DF/UXを停止してください。
KFPB20003-E
Insufficient memory, user=aa....aa, size=bb....bb, inf=cc....cc　　（Ｌ）
OSI-RDAリモートデータベースアクセスで，DF/UXサーバ機能の実行ファイルにリンクしたHiRDBのプログラムでメモリ不足が発生しました。
aa....aa：分散クライアントが指定したユーザID
分散クライアントがHiRDBの場合は，UAPが指定した認可識別子と一致します。
bb....bb：確保しようとしたメモリの大きさ
cc....cc：保守用情報
(Ｓ)分散クライアントとのアソシエーションを解放します。
(Ｏ)ユーザIDが正しく表示されている場合，クライアントシステムのプログラマに次の指示をしてください。
1. 操作する引数，変数の数を減らしてください。
2. 操作するデータの長さを短くしてください。
3. カーソル宣言，PREPARE文の数を減らしてください。このメッセージが多発する場合，保守員に連絡してください。
KFPB20005-E
Error occurred in library, user=aa....aa, inf=bb....bb　　（Ｌ）
DF/UXサーバ機能実行ファイルにリンクしたHiRDBのプログラムで，障害が発生しました。
障害が発生した原因には，次の内容が考えられます。
・DF/UXサーバ機能実行ファイルを作成するdfsvplinkコマンドの引数の指定に誤りがあります。
aa....aa：分散クライアントが指定したユーザID
分散クライアントがHiRDBの場合は，UAPが指定した認可識別子と一致します。
bb....bb：保守用情報
(Ｓ)処理を終了します。
(Ｏ)dfsvplinkの引数の指定を見直してください。
〈指定に誤りがある場合〉
正しい値を指定して，DF/UXのサーバ機能実行可能ファイルを再度作成してください。作成方法については，マニュアル「HiRDB Version 7 システム運用ガイド」を参照してください。
〈指定に誤りがない場合，又はWindows NTの場合〉
保守員に連絡してください。
KFPB20006-E
DF/UX error detected, user=aa....aa, inf=bb....bb　　（Ｌ）
DF/UXサーバ機能の障害を検知しました。
aa....aa：分散クライアントが指定したユーザID
分散クライアントがHiRDBの場合は，UAPが指定した認可識別子と一致します。
bb....bb：保守用情報
(Ｓ)分散クライアントとのアソシエーションを解放します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]DF/UXのバージョンを調べて，前提バージョンと異なる場合は，DF/UXを入れ替えてください。DF/UXのバージョンに問題がなければ，保守員に連絡してください。
Windows NTの場合は保守員に連絡してください。
KFPB21001-E
Insufficient data area in DF/UX server process, user=aa....aa, size=bb....bb　　（Ｌ）
リモートデータベースアクセスで，DF/UXサーバプロセスにデータを転送するための出力バッファ長が不足しています。このため，検索結果を転送できません。
この出力バッファ長は，DF/UXサーバ機能の実行ファイルにリンクしたHiRDBのプログラムが指定したものです。
aa....aa：分散クライアントが指定したユーザID
分散クライアントがHiRDBの場合は，UAPが指定した認可識別子と一致します。
bb....bb：出力バッファ長（単位：バイト）
(Ｓ)分散クライアントとのアソシエーションを解放します。
(Ｏ)保守員に連絡してください。


KFPCメッセージ

KFPC00101-I
Setup for aa....aa complete　　（Ｌ＋Ｓ）
HiRDBの環境設定をしました。
aa....aa：環境設定をした機能名称
DatHardCompress：DATアクセス時のハードウェア圧縮機能
RshPortName：リモートコマンド用サービスポート名称
ServiceComplete：HiRDBサービスの起動完了時期
CharacterCode：HiRDBの文字コード種別
(Ｓ)処理を終了します。
KFPC00102-E
Invalid option specified with this command　　（Ｌ＋Ｓ）
該当するコマンドでは指定できないオプションを指定しています。又は，オプションの引数が正しく指定されていません。
(Ｓ)処理を終了します。
[対策]正しいオプション又は引数を指定して，再度コマンドを実行してください。
KFPC00103-I
Usage: pdntenv [{-hc {on|off} | -pn service_port_name | -a | -sc {auto|manual} | -c{sjis|lang-c|utf-8} | -ro {on|off}}]　　（Ｌ＋Ｓ）
pdntenvコマンドのオプションの指定形式が誤っています。
(Ｓ)処理を終了します。
[対策]正しいオプションを指定して，再度コマンドを実行してください。
KFPC00104-E
Pdntenv error occurred,reason=aa....aa,value=bb....bb　　（Ｌ＋Ｓ）
pdntenvコマンドでエラーが発生しました。
aa....aa：理由コード
REGKEY_GET_FAILED：レジストリ情報の取得に失敗しました。
REGKEY_SET_FAILED：レジストリ情報の設定に失敗しました。
OPTION_ERROR：指定できないオプションを指定しています。
SERVICE_GET_FAILED：サービス状態の取得に失敗しました。
SERVICE_ONLINE：HiRDBのサービスが稼働中です。
PDDIR_NOT_FOUND：PDDIR環境変数が見付かりません。
FILE_COPY_FAILED：ファイルのコピー処理に失敗しました。
bb....bb：詳細情報
(Ｓ)処理を終了します。
[対策]
〈理由コードがREGKEY_GET_FAILED又はREGKEY_SET_FAILEDの場合〉
HiRDBがレジストリに登録されているか，又はレジストリ操作上の問題がないかを調査し，障害を取り除いた後再度実行してください。
〈理由コードがOPTION_ERRORの場合〉
HiRDB/パラレルサーバで指定できるオプションかどうかを確認してください。
KFPC00201-E
Invalid environment,valiable=aa....aa(S)
環境変数の値が不正です。
aa....aa：不正な環境設定名
PDDIR：環境変数PDDIRが設定されていません。
PDUXPLDIR：環境変数PDUXPLDIRが設定されていません。又は環境変数PDDIRとPDUXPLDIRの値が統一されていません。
(Ｓ)処理を終了します。
[対策]環境変数に正しい値を設定して，再度実行してください。環境変数PDUXPLDIRは$PDDIR/UXPLDIRである必要があります。統一されていない場合は修正してください。
KFPC00301-E
Error occurred in HiRDB service.reason code=aa....aa-bb....bb(L)
HiRDBのサービス開始処理でエラーが発生しました。
aa....aa：エラー情報
ACCESS：インストール時に作成したファイルやレジストリ情報にアクセスできません。
DUPLICATE：サービスポート番号が既に使用されています。
NOT_FOUND：連絡用ポートのサービス名，又はサービスポート番号がSERVICESファイルに設定されていません。
番号：そのほかのエラーが発生しました。
bb....bb：内部情報
(Ｓ)異常終了します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]
ACCESSの場合：
サービスを開始するユーザにAdministrators権限があることを確認してください。この場合，連絡用ポートのサービス名称が表示されません。
DUPLICATEの場合：
ほかのプログラムが使用中の可能性があるので，サービスポートの番号の設定を見直してください。
NOT_FOUNDの場合：
HiRDBシステムで同一のサービス名，単一サーバで一意な連絡用ポートのサービス名，及びサービスポート番号をSERVICESファイルに設定してください。
番号の場合：
保守員に連絡してください。


KFPDメッセージ

KFPD00001-E
System initialization error occurred aa....aa　　（Ｓ）
システムの初期化中にエラーが発生しました。
aa....aa：次の文字列が設定されます。
illegal MASTERDIR：
マスタディレクトリ用RDエリアの内容が不正です。
(Ｓ)異常終了します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]保守員に連絡してください。
KFPD00003-E
File I/O error on aa....aa func=bb....bb errno=cc....cc　　（Ｓ）
ファイルへの入出力処理中にエラーが発生しました。
aa....aa：サーバ名称
bb....bb：エラーが発生した関数名称
cc....cc：errnoの値
(Ｓ)異常終了します。
(Ｏ)エラーが発生した関数名称，及びerrnoの値から入出力エラーの原因を調査し，対策してください。
KFPD00004-E
System call error occurred on aa....aa func=bb....bb errno=cc....cc　　（Ｓ）
システムコールでエラーが発生しました。
aa....aa：エラーが発生したときの処理名称
bb....bb：エラーが発生した関数名称
cc....cc：errnoの値
(Ｓ)エラーが発生した処理名称が，code convertの場合，処理を続行します。それ以外の場合は，異常終了します。
(Ｏ)エラーが発生した関数名称，及びerrnoの値から原因を調査し，対策してください。
[対策]
〈エラーが発生した処理名称がpdi_olk_thdlockでerrnoの値が-20023の場合〉
システムが同時にオープンできるファイル数を超えて，ファイルをオープンしようとしました。システムが同時にオープンできるファイル数の上限値を大きくしてください。UNIX版HiRDBの場合，OSのマニュアル及びマニュアル「HiRDB Version 7 システム運用ガイド」の「OSのオペレーティングシステムパラメタの見積もり」を参照してください。Windows NT版HiRDBの場合，メモリを増やしてください。
〈エラーが発生した処理名称がpdi_olk_thdlockでerrnoの値が-20024の場合〉
プロセスが同時にオープンできるファイル数を超えて，ファイルをオープンしようとしました。プロセスが同時にオープンできるファイル数の上限値を大きくしてください。UNIX版HiRDBの場合，OSのマニュアル及びマニュアル「HiRDB Version 7 システム運用ガイド」の「OSのオペレーティングシステムパラメタの見積もり」を参照してください。Windows版HiRDBの場合，メモリを増やしてください。
KFPD00005-E
Server initialization error occurred on aa....aa func=bb....bb return code=cc....cc　　（Ｓ）
サーバの起動中にエラーが発生しました。
aa....aa：エラーとなったサーバ名称
bb....bb：エラーとなった処理名称
cc....cc：エラーコード
(Ｓ)異常終了します。
[対策]
〈エラーとなった処理名称が"pdi_omm_mget"でエラーコードが-142の場合〉
表定義情報バッファ長（pd_table_def_cache_size），ユーザ権限情報用バッファ長（pd_auth_cache_size）及びビュー解析情報用バッファ長（pd_view_def_cache_size）の指定値を減らしてください。
〈エラーとなった処理名称が"pdi_omm_mget"でエラーコードが-143の場合〉
エラーとなったサーバのサーバ定義の共用メモリサイズ（pd_sds_shmpool_size，pd_dic_shmpool_size，又はpd_bes_shmpool_sizeオペランド）の指定値を見直してください。値を指定し直してから，該当するサーバを再度開始してください。
〈エラーとなった処理名称が，"pdi_adm_pddicinf"又は"pdi_adm_pdbesinf"で，エラーコードが-1807の場合〉
プロセス固有メモリが不足しています。ほかのプロセスが終了するのを待って再度実行するか，又はスワップ領域を増やしてください。
〈上記以外の場合〉
保守員に連絡してください。
KFPD00008-E
Internal inconsistency occurred on aa....aa (bb....bb,cc....cc,dd....dd)　　（Ｓ）
内部処理で矛盾が発生しました。
aa....aa：エラーが発生したサーバ名称
bb....bb：保守情報1
cc....cc：保守情報2
dd....dd：保守情報3
(Ｓ)異常終了します。
[対策]保守員に連絡してください。ただし，次の場合はこのメッセージを無視してください。
・正常終了中又は計画停止中にこのメッセージが出力され，メッセージ中のbb....bbがdicsfenv.cであり，かつcc....ccが－949の場合
KFPD00011-E
Process initialization error occurred on aa....aa, func=bb....bb return code=cc....cc　　（Ｌ）
プロセス開始処理中にエラーが発生しました。
aa....aa：エラーが発生したサーバ名
bb....bb：エラーとなった処理名
cc....cc：エラーコード
(Ｓ)異常終了します。
[対策]エラーとなった処理名称がp_f_dic_hds_startの場合，このメッセージより前に出力されているKFPD00026-Eメッセージを参照して対策してください。これ以外の場合は保守員に連絡してください。
KFPD00012-E
Transaction initialization error occurred on aa....aa, func=bb....bb return code=cc....cc　　（Ｌ）
トランザクションの開始処理中にエラーが発生しました。
aa....aa：エラーが発生したサーバ名称
bb....bb：エラーが発生した処理名称
cc....cc：エラーコード
(Ｓ)異常終了します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]
〈エラーが発生した処理名称が"pdi_omm_mget"でエラーコードが-143の場合〉
エラーが発生したサーバのサーバ定義の共用メモリサイズ（pd_sds_shmpool_size，pd_dic_shmpool_size，又はpd_bes_shmpool_sizeオペランド）の指定値を見直してください。値を指定し直してから，該当するサーバを再度開始してください。
〈エラーが発生した処理名称が"pdi_adm_pddicinf"又は"pdi_adm_pdbesinf"で，エラーコードが-1807の場合〉
プロセス固有メモリが不足しています。ほかのプロセスが終了するのを待って再度実行するか，又はスワップ領域を増やしてください。
〈上記以外の場合〉
保守員に連絡してください。
KFPD00013-E
Transaction termination error occurred on aa....aa, func=bb....bb return code=cc....cc　　（Ｌ）
トランザクションの終了処理中にエラーが発生しました。
aa....aa：エラーが発生したサーバ名称
bb....bb：エラーが発生した処理名称
cc....cc：エラーコード
(Ｓ)異常終了します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]
〈エラーとなった処理名称が"p_f_dic_hds_release_userinfo"の場合〉
このメッセージより前に出力されているKFPD00026-Eメッセージを参照して対策してください。
〈エラーとなった処理名称が"p_f_sqa_rcomb_close"の場合〉
combuf通信でエラーが発生しました。OSのマニュアルを参照し，エラーの原因を取り除いてください。
〈エラーとなった処理名称が"pdi_com_combuf_disconnect"又は"pdi_com_combuf_process_end"で，エラーコードが-300～-399の場合〉
「RPC関連エラーの詳細コード」を参照して対策してください。
〈上記以外の場合〉
保守員に連絡してください。
KFPD00014-E
Process termination error occurred on aa....aa, func=bb....bb return code=cc....cc　　（Ｌ）
プロセス終了処理中にエラーが発生しました。
aa....aa：エラーが発生したサーバ名
bb....bb：エラーとなった処理名
cc....cc：エラーコード
(Ｓ)異常終了します。
[対策]エラーとなった処理名称が"p_f_dic_hds_end"の場合，このメッセージより前に出力されているKFPD00026-Eメッセージを参照して対策してください。これ以外の場合は保守員に連絡してください。
KFPD00015-E
Server termination error occurred on aa....aa func=bb....bb return code=cc....cc　　（Ｓ）
サーバの終了処理中にエラーが発生しました。
aa....aa：エラーが発生したサーバ名称
bb....bb：保守情報1
cc....cc：保守情報2
(Ｓ)処理を続行します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]保守員に連絡してください。
KFPD00016-E
Transaction termination error occurred on aa....aa func=bb....bb return code=cc....cc　　（Ｓ）
トランザクションの終了処理中にエラーが発生しました。
aa....aa：エラーが発生したサーバ名称
bb....bb：保守情報1
cc....cc：保守情報2
(Ｓ)異常終了します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]保守員に連絡してください。
KFPD00017-E
Message output error occurred func=aa....aa return code=bb....bb message no=cc....cc　　（Ｓ）
メッセージの出力中にエラーが発生しました。
aa....aa：保守情報1
bb....bb：保守情報2
cc....cc：メッセージ番号
(Ｓ)処理を続行します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]
〈保守情報2が-1902の場合〉
エラーとなったプロセスのプロセス固有メモリ不足が発生しました。スワップ領域サイズを見直してください。
〈保守情報2が-1909の場合〉
$PDDIR/lib/msgtxtが見付かりません。HiRDB終了後，pdsetupコマンドで再セットアップしてください。
〈保守情報2が-1910の場合〉
$PDDIR/lib/msgtxtのI/Oエラーが発生しました。HiRDB終了後，pdsetupコマンドで再セットアップしてください。
〈保守情報2が-1911の場合〉
$PDDIR/lib/msgtxtがアクセスできません。$PDDIR/lib/msgtxtのアクセス権限を見直してください。
〈上記以外の場合〉
保守員に連絡してください。
KFPD00020-E
bbb initialization error occurred errorinf=aa....aa　　（Ｌ）
aa....aaに示す原因で，bbbの初期化エラーが発生しました。
aa....aa：初期化エラーの原因を示すエラーメッセージ
bbb：初期化エラーとなったサーバの種類
FES：フロントエンドサーバ
SDS：シングルサーバ
(Ｓ)
・フロントエンドサーバがエラーになった場合
フロントエンドサーバの状態をSUSPEND状態にします。ただし，エラーとなった原因が’Insufficient pd_max_rdarea_no’の場合は，異常終了します。
・シングルサーバがエラーになった場合
異常終了します。
[対策]
・フロントエンドサーバがエラーになった場合
障害の原因を取り除いた後，フロントエンドサーバのSUSPEND状態を解除してください。
SUSPEND状態の解除方法については，マニュアル「HiRDB Version 7 システム運用ガイド」を参照してください。
エラーの原因が ’Insufficient pd_max_rdarea_no’の場合，システム共通定義のpd_max_rdarea_noオペランドの指定値を増やした後，フロントエンドサーバがあるユニットを再開始してください。
・シングルサーバがエラーになった場合
障害の原因を取り除いた後，HiRDBを再開始してください。
KFPD00021-E
Insufficient aa....aa memory,server=bb....bb,size=cc....cc　　（Ｌ）
共用メモリ不足又はプロセス固有メモリ不足が発生しました。
aa....aa：メモリ不足が発生した領域の種別
SHARED：共用メモリ
PROCESS：プロセス固有メモリ
bb....bb：エラーが発生したサーバ名
cc....cc：不足したメモリサイズ（単位：バイト）
(Ｓ)サーバ起動時の場合はサーバの起動を中断します。トランザクション入力時の場合は，該当するトランザクションを処理しようとしたプロセスを異常終了させます。
[対策]次に示すどちらかの対処をしてください。
・メモリ不足が発生した領域の種別がSHAREDの場合
共用メモリ不足が発生したサーバのサーバ定義（pd_sds_shmpool_size，pd_dic_shmpool_size，又はpd_bes_shmpool_sizeオペランド）の共用メモリサイズの指定値を増やし，エラーが発生したサーバを再度起動してください。
・メモリ不足が発生した領域の種別がPROCESSの場合
ほかのプロセスが終了するのを待って再度実行するか，又はスワップ領域のサイズを増やしてください。
KFPD00022-E
Not specified definition aa....aa　　（Ｅ）
aa....aaが定義されていません。
aa....aa：定義オペランド名｛pd_max_list_users｜pd_max_list_count｝
(Ｓ)処理を終了します。
(Ｐ)aa....aaに0以外の値を指定してください。
KFPD00024-W
Unable to use directory server on current kind of HiRDB　　（Ｌ）
このHiRDBではディレクトリサーバ連携機能を使用できません。
(Ｓ)pd_directory_serverオペランドの指定を無視して，ディレクトリサーバ連携機能を使用しないで動作します。
[対策]ディレクトリサーバ連携機能を使用するには，次に示す条件を満たす必要があります。
・日立ディレクトリサーバ連携機能はHP-UX 11.0版限定の機能です。また，HiRDBは32ビットモードで，かつPOSIXライブラリ版であることが必要です。
・Sun Java System Directory Server連携機能はHP-UX版，Solaris 8版，及びAIX 5L版限定の機能です。また，HiRDBは32ビットモードで，かつPOSIXライブラリ版であることが必要です。
ディレクトリサーバ連携機能を使用する場合は，前記の条件を満たすHiRDBの環境設定をしてください。ディレクトリサーバ連携機能を使用しない場合は，pd_directory_serverオペランドを削除してください。
KFPD00025-E
LDAP API error occurred, errno=aa....aa, LDAP message=bb....bb, LDAP extension message=cc....cc　　（Ｌ）
ディレクトリサーバ連携機能で使用するACLib API又はHiRDB LDAP Option APIでLDAP APIエラーが発生しました。
aa....aa：LDAPのエラーコード
bb....bb：LDAPのエラーメッセージ
cc....cc：LDAPの拡張エラーメッセージ
拡張エラーメッセージがない場合は，'********'を表示します。
(Ｓ)このSQL文を無視します。
(Ｐ)システム管理者に対策を依頼して，対策後に再度実行してください。
[対策]LDAPのエラーコード及びエラーメッセージを参照して原因を取り除いてください。
KFPD00026-E
Directory server error occurred on aa....aa, func=bb....bb errno=cc....cc　　（Ｌ）
aa....aaの処理中に，ディレクトリサーバ連携機能で使用するACLib API又はHiRDB LDAP Option APIからエラーが返されました。
aa....aa：エラーが発生したときの処理名
bb....bb：エラーが発生したときのACLib API名
HdrAclxxxxxx
cc....cc：詳細エラーコード
・日立ディレクトリサーバ連携機能の場合
16：予期せぬエラー
17：ACLibの動作環境が不正
18：データ不正
20：日立ディレクトリサーバに登録したグループのルールIDが重複している
22：シンボルロードの失敗
32：ACLib APIによるメモリ確保に失敗した
33：APIコール時のパラメタ不正
34：ACLib環境設定ファイルがない
35：ACLib環境設定ファイルのアクセス権限がない
36：ACLib環境設定ファイルの入出力エラーが発生した
37：LDAP APIでエラーが発生した
38：日立ディレクトリサーバが起動していない
39：LDAP操作で無通信タイムアウトが発生した
40：パスワードの不正
41：パスワードの期限切れ
42：BIND DNの不正
・Sun Java System Directory Server連携機能の場合
10：ユーザが登録されていない
11：Sun Java System Directory Serverにユーザ名が重複登録されている
20：ロール名が登録されていない
21：Sun Java System Directory Serverにロール名が重複登録されている
30：指定したユーザは指定したロールに属さない
40：HiRDB LDAP Option環境定義ファイルがない
41：HiRDB LDAP Option環境定義ファイルのアクセス権がない
42：HiRDB LDAP Option環境定義ファイルのオープン又はクローズに失敗した（詳細はKFPD00027-Eメッセージを参照）
43：HiRDB LDAP Option環境定義ファイルの読み込みエラーが発生した（詳細はKFPD00027-Eメッセージを参照）
44：HiRDB LDAP Option環境定義で指定が必要なオペランドの指定がない
49：パスワードの不正
50：指定したパスにRuntimeのライブラリがない
51：Runtimeのライブラリのローディング中にエラーが発生した（詳細はKFPD00027-Eメッセージを参照）
60：メモリ不足（詳細はKFPD00027-Eメッセージを参照）
90：LDAPセションの初期化に失敗した
91：HiRDB LDAP Option環境定義のNETWORKTIMELIMITオペランドの指定時間を経過した
92：予期せぬエラー（詳細はKFPD00027-Eメッセージを参照）
99：そのほかのエラー（詳細はKFPD00027-Eメッセージを参照）
(Ｓ)処理を終了します。
[対策]次に示す対策をしてください。
・日立ディレクトリサーバ連携機能の場合
ACLibのマニュアルを参照して，詳細エラーコードに対応する処置をしてください。ただし，詳細エラーコードが37の場合は，KFPD00025-Eメッセージを参照して原因を取り除いてください。
・Sun Java System Directory Server連携機能の場合
API名称がldp_xxxxxxの場合はSun Java System Directory Serverのドキュメントを参照して，詳細エラーコードに対応する対策をしてください。
詳細エラーコードが42，43，51，60，99の場合はKFPD00027-Eメッセージの対策に従ってください。
詳細エラーコードが92の場合は保守員に連絡してください。
KFPD00027-E
Error occurred in HiRDB LDAP Option, errno=aa....aa, func=bb....bb, message=cc....cc　　（Ｌ）
ディレクトリサーバ連携機能で使用するAPIでエラーが発生しました。
aa....aa：詳細エラーコード
bb....bb：API名称
cc....cc：詳細情報
詳細情報がない場合は********を表示します。
(Ｓ)このSQL文を無視します。
[対策]API名称がldp_xxxxxxの場合はSun Java System Directory Serverのドキュメントを参照して詳細エラーコードに対応する対策をしてください。代表的な詳細情報を次に示します。
32：No such object：指定したDNがLDAPサーバ上に存在しない
48：Inappropriate authentication：ユーザエントリにパスワード属性がない
49：Invalid credentials：パスワードの不正
53：DSA is unwilling to perform：無効なユーザ
87：Bad search filter：検索フィルタの不正
91：Can't connect to the LDAP server：LDAPサーバに接続できない
上記以外はSun Java System Directory Serverのドキュメントを参照してください。API名称がldp_xxxxxx以外の場合はOSのエラーコードを参照して対策してください。
KFPD00028-E
Version incompatible with HiRDB, func=aa....aa　　（Ｌ）
HiRDBと付加PPaa....aaのバージョンが異なります。
aa....aa：付加PP名
(Ｓ)HiRDBを異常終了します。
[対策]HiRDBのバージョンに対応した付加PPをインストールしてください。
KFPD00029-W
No RDAREA for db management　　（Ｌ）
datadictionary of dbmanagementを指定したデータディクショナリ用RDエリアが定義されていません。このため，次の機能を使用できません。
・再編成時期予測機能
(Ｓ)処理を続行します。
[対策]再編成時期予測機能を使用する場合は，pdmodでdatadictionary of dbmanagementを指定したデータディクショナリ用RDエリアを作成してください。再編成時期予測機能を使用しない場合は，システム定義のpd_rorg_predictオペランドの指定を変更してください。
KFPD00030-W
Unable to make an entry SQL_DB_MANAGEMENT, RDID=aa....aa, OBJID=bb....bb, code=cc....cc　　（Ｌ）
運用履歴表の登録に失敗したため，再編成時期予測結果が不正となります。
aa....aa：RDエリアID
bb....bb：表，又はインデクスID
cc....cc：エラー要因のSQLコード
(Ｓ)処理を終了します。
(Ｏ)エラー要因のSQLコードcc....ccを参照して，エラー原因を取り除いてください。
KFPD01001-E
SQL error occurred, SQLCODE=aa....aa　　（Ｅ）
コマンド内で実行しているSQLの処理で続行できないエラーが発生しました。
aa....aa：SQLCODE
(Ｓ)処理を終了します。
[対策]直前に出力されたメッセージから障害の原因を調査し，障害要因を取り除いた後，再度実行してください。
KFPD01002-E
REGISTRY CONTEXT already catalogued　　（Ｅ）
同一名称のコンテキストが既にレジストリに登録されています。
(Ｓ)処理を終了します。
[対策]コンテキスト名に誤りがないか確認し，誤っている場合は訂正して再度実行してください。
KFPD01003-E
Invalid REGISTRY ACCESS PASSWORD　　（Ｅ）
レジストリのコンテキストに対するアクセスパスワードが誤っています。
(Ｓ)処理を終了します。
[対策]正しいアクセスパスワードを指定し，再度実行してください。
KFPD01004-E
REGISTRY CONTEXT not found　　（Ｅ）
指定したコンテキストはレジストリに登録されていません。
(Ｓ)処理を終了します。
[対策]正しいコンテキスト名称を指定し，再度実行してください。
KFPD01005-E
REGISTRY KEY not found　　（Ｅ）
指定したキーはレジストリに登録されていません。
(Ｓ)処理を終了します。
[対策]正しいキー名称を指定し，再度実行してください。
KFPD01006-E
REGISTRY KEY already catalogued　　（Ｅ）
指定したキーは既にレジストリに登録されています。
(Ｓ)処理を終了します。
[対策]指定したキー名が誤っていないか確認し，誤っている場合は訂正して再度実行してください。誤っていない場合は，既に登録されているキーを削除して再度登録するか，ほかの名称で登録してください。
KFPD01007-E
Invalid value in lock_wait option　　（Ｅ）
lock_waitオプションの指定が誤っています（システム内部エラー）。
(Ｓ)処理を終了します。
[対策]lock_waitオプションには，'Y'，'N'，又は'y'，'n'だけが指定できます。正しい値を指定して，再度実行してください。プラグインが提供しているコマンドを実行中にこのエラーが発生した場合は，プラグイン提供元に連絡してください。
KFPD01008-E
Invalid value in lock_mode option　　（Ｅ）
lock_modeオプションの指定が誤っています（システム内部エラー）。
(Ｓ)処理を終了します。
[対策]lock_modeオプションには，'R'，'W'，又は'r'，'w'だけが指定できます。正しい値を指定して，再度実行してください。プラグインが提供しているコマンドを実行中にこのエラーが発生した場合は，プラグイン提供元に連絡してください。
KFPD01009-E
REGISTRY KEY catalogued by long format　　（Ｅ）
キー値はレジストリに長形式（長いキー値）で登録されています（システム内部エラー）。
(Ｓ)処理を終了します。
[対策]保守員に連絡してください。
KFPD01010-E
REGISTRY KEY catalogued by short format　　（Ｅ）
キー値はレジストリに短形式（短いキー値）で登録されています（システム内部エラー）。
(Ｓ)処理を終了します。
[対策]保守員に連絡してください。
KFPD01011-E
Over 2147483647 in REGISTRY CONTEXT　　（Ｅ）
レジストリのコンテキストの最大登録数を超えました。
(Ｓ)処理を終了します。
[対策]既に登録されているコンテキストのうち不要なものをpdregrmcontコマンドで削除した後，再度実行してください。
KFPD01012-E
REGISTRY CONTEXT NAME length is 0 byte　　（Ｅ）
指定したレジストリのコンテキスト名称の長さが0バイトです。
(Ｓ)処理を終了します。
[対策]コンテキスト名称を有効長（1～240バイト）の範囲で指定し，再度実行してください。プラグインが提供しているコマンドを実行中にこのエラーが発生した場合は，プラグイン提供元に連絡してください。
KFPD01013-E
REGISTRY ACCESS PASSWORD length is 0 byte　　（Ｅ）
指定したレジストリのアクセスパスワードの長さが0バイトです。
(Ｓ)処理を終了します。
[対策]アクセスパスワードを有効長（1～100バイト）の範囲で指定し，再度実行してください。プラグインが提供しているコマンドを実行中にこのエラーが発生した場合は，プラグイン提供元に連絡してください。
KFPD01014-E
REGISTRY KEY NAME length is 0 byte　　（Ｅ）
指定したレジストリのキー名称の長さが0バイトです。
(Ｓ)処理を終了します。
[対策]キー名称を有効長（1～240バイト）の範囲で指定し，再度実行してください。プラグインが提供しているコマンドを実行中にこのエラーが発生した場合は，プラグイン提供元に連絡してください。
KFPD01015-I
Usage: aa....aa　　（Ｅ）
コマンドの形式に誤りがあります。
aa....aa：コマンドの形式
(Ｓ)処理を終了します。
[対策]コマンドの形式を修正し，再度実行してください。プラグインが提供しているコマンドを実行中にこのエラーが発生した場合は，プラグイン提供元に連絡してください。
KFPD01016-E
Insufficient memory, size=aa....aa　　（Ｅ）
メモリ不足が発生しました。
aa....aa：確保しようとしたサイズ（バイト）
(Ｓ)処理を終了します。
[対策]ほかのプロセスが終了するのを待ってから再度実行するか，又はスワップ領域のサイズを増やしてください。
KFPD01017-E
REGISTRY CONTEXT NAME length exceeds 240 bytes　　（Ｅ）
指定したレジストリのコンテキスト名称の長さが上限値を超えています。
(Ｓ)処理を終了します。
[対策]コンテキスト名称を有効長（1～240バイト）の範囲で指定し，再度実行してください。プラグインが提供しているコマンドを実行中にこのエラーが発生した場合は，プラグイン提供元に連絡してください。
KFPD01018-E
REGISTRY ACCESS PASSWORD length exceeds 100 bytes　　（Ｅ）
指定したレジストリのアクセスパスワードの長さが上限値を超えています。
(Ｓ)処理を終了します。
[対策]アクセスパスワードを有効長（1～100バイト）の範囲で指定し，再度実行してください。プラグインが提供しているコマンドを実行中にこのエラーが発生した場合は，プラグイン提供元に連絡してください。
KFPD01019-E
REGISTRY KEY NAME length exceeds 240 bytes　　（Ｅ）
指定したレジストリのキー名称の長さが上限値を超えています。
(Ｓ)処理を終了します。
[対策]キー名称を有効長（1～240バイト）の範囲で指定し，再度実行してください。プラグインが提供しているコマンドを実行中にこのエラーが発生した場合は，プラグイン提供元に連絡してください。
KFPD01020-E
Read error occurred on file, file name=aa....aa　　（Ｅ）
指定した名称のファイルからの読み込みに失敗しました。又は，指定した名称のファイルがありません。
aa....aa：指定したファイル名称
(Ｓ)処理を終了します。
[対策]エラーの原因を取り除き，再度実行してください。
KFPD01021-E
System error occurred, return code=aaa　　（Ｅ）
システム内部エラーが発生しました。
aaa：リターンコード
-10：SQLエラー
-30：インタフェース不正
(Ｓ)処理を終了します。
[対策]保守員に連絡してください。
KFPD01022-E
Object Option required　　（Ｅ）
HiRDB Object Optionが必要です。
(Ｓ)処理を終了します。
[対策]このコマンドを実行するには，HiRDB Object Optionが必要です。HiRDB Object Optionを組み込んでください。
KFPD01023-I
Usage: pdlistls [-d {1 | 2}] [-u list user name] [-t base table owner.base table name]　　（Ｅ）
pdlistlsコマンドのオプションの形式を表示します。
(Ｓ)処理を終了します。
[対策]コマンドの使用方法に従って，再度実行してください。
KFPD01024-E
Usage: pddef [-e] [-s] [-R] 　　（Ｅ）
データベース定義ユティリティのオプションの形式を表示します。
(Ｓ)処理を終了します。
[対策]ユティリティの使用方法に従って，再度実行してください。
KFPD01025-E
Invalid option for pddef　　（Ｅ）
データベース定義ユティリティのオプションの指定に誤りがあります。
(Ｓ)処理を終了します。
[対策]正しいオプションを指定して，再度実行してください。
KFPD01026-E
Argument of aa option is invalid　　（Ｅ）
オプションの引数が不正か，又は指定値が誤っています。
aa：オプション名
(Ｓ)処理を終了します。
[対策]正しいオプションを指定して，再度実行してください。
KFPD01100-I
Usage: aa....aa　　（Ｅ）
コマンドの指定方法を示します。
aa....aa：指定方法
・pdgrprfl
・pdusrchk［-k ｛usr｜rdp｜tbp｝］
・pdacunlck｛auth_id［,auth_id］...｜ALL｝
(Ｓ)処理を終了します。
[対策]コマンドの形式を確認して，再度実行してください。
KFPD01101-I
Pdgrprfl command started　　（Ｌ＋Ｓ）
pdgrprflコマンドの処理を開始しました。
(Ｓ)処理を続行します。
KFPD01102-I
Pdgrprfl command ended, return code=aa　　（Ｌ＋Ｓ）
pdgrprflコマンドがリターンコードaaで終了しました。
aa：リターンコード
０：正常終了しました。
８：異常終了しました。
(Ｓ)処理を終了します。
[対策]リターンコードが8の場合，ユーザ，グループ，又はロールの情報のリフレッシュに失敗しました。ほかのメッセージを参照してエラーとなった原因を取り除いてから，再度pdgrprflコマンドを実行してください。
KFPD01103-E
Invalid option for aa....aa　　（Ｅ）
コマンドのオプションの指定形式に誤りがあります。
aa....aa：コマンド名
・pdgrprfl
・pdusrchk
・pdacunlck
(Ｓ)処理を終了します。
[対策]コマンドの形式を確認してから再度実行してください。
KFPD01104-E
Insufficient memory on PROCESS, size=aa....aa　　（Ｅ＋Ｌ）
プロセス固有領域が不足しているため，コマンドの実行に必要な作業領域が確保できませんでした。
aa....aa：確保しようとした領域サイズ（単位：バイト）
(Ｓ)処理を終了します。
[対策]次に示すどれかの方法でプロセス固有領域を大きくして使用できるメモリに余裕を持たせてください。その後，pdgrprflコマンドを再度実行してください。
・同時実行しているプロセス数を減らしてください。
・スワップ領域を増やしてください。
・実メモリを増設してください。
KFPD01105-E
Internal function error, func=aa....aa, return code=bb....bb　　（Ｅ＋Ｌ）
コマンドの内部処理でエラーが発生しました。
aa....aa：エラーが発生した関数名称
bb....bb：システム関連エラーの詳細コード
(Ｓ)処理を終了します。
[対策]「システム関連エラーの詳細コード」を参照してエラーの原因を取り除き，コマンドを再度実行してください。ただし，エラー詳細コードが－310の場合，通信先のサーバが起動されていないと考えられます。なお，HiRDB管理者が対処できないエラーが発生している場合は，保守員に連絡してください。
KFPD01106-E
Invalid execution node　　（Ｅ＋Ｌ）
このサーバマシンからはコマンドを実行できません。
(Ｓ)処理を終了します。
[対策]環境変数（PDHOST，PDNAMEPORT，PDDIR，PDCONFPATHなど）の指定内容を確認してください。指定内容に誤りがある場合は，誤りを修正してコマンドを再度実行してください。指定内容に誤りがない場合は，システムマネジャ（MGR）があるサーバマシンからコマンドを再度実行してください。
KFPD01107-E
Unable to execute aa....aa command without directory server　　（Ｅ＋Ｌ）
ディレクトリサーバ連携機能を使用していないため，aa....aaコマンドを実行できません。
aa....aa：コマンド名
・pdgrprfl
・pdusrchk
(Ｓ)処理を終了します。
[対策]このコマンドはディレクトリサーバ連携機能使用時に実行できるコマンドです。ディレクトリサーバ連携機能を使用していない場合は，このコマンドを実行できません。ディレクトリサーバ連携機能については，マニュアル「HiRDB Version 7 システム運用ガイド」を参照してください。
KFPD01108-E
Hostname=aa....aa, unable to execute cc....cc command, unit bbbb state not ONLINE　　（Ｅ＋Ｌ）
ホスト名aa....aaのユニットbbbbが稼働中でないため，コマンドを実行できません。
aa....aa：コマンドを実行できなかったホスト名
bbbb：ユニット識別子
cc....cc：コマンド名
・pdgrprfl
・pdlistls
・pdusrchk
・pdacunlck
(Ｓ)処理を終了します。
[対策]HiRDB又はユニットを開始した後にコマンドを再度実行してください。
KFPD01109-E
Server aa....aa not running　　（Ｅ＋Ｌ）
サーバが稼働中でないため，コマンドを実行できません。
aa....aa：HiRDBのサーバ名
(Ｓ)処理を終了します。
[対策]サーバを開始した後にコマンドを再度実行してください。
KFPD01110-E
Server down detected　　（Ｅ＋Ｌ）
サーバの異常終了を検知しました。
(Ｓ)処理を終了します。
[対策]サーバが異常終了した原因をメッセージ及びアボートコードから調査してください。原因を取り除いた後にコマンドを再度実行してください。
KFPD01111-I
Pdgrprfl command skipped processing for server aa....aa because server not running　　（Ｌ＋Ｓ）
稼働中でないサーバaa....aaに対してpdgrprflコマンドの処理をスキップしました。
aa....aa：サーバ名称
(Ｓ)処理を続行します。
KFPD01112-E
Unable to execute "pdacunlck" command, code=aa(bb....bb)　　（Ｅ＋Ｌ）
pdacunlckコマンドを実行できません。
aa：理由コード
bb....bb：エラーに対する付加情報
cc....cc：認可識別子
(Ｓ)このSQL文を無視する。
[対策]出力された理由コードとエラーに対する付加情報から，原因を取り除いて再度コマンドを実行してください。
理由
コード
エラーに対する付加情報
意味
01
Using directory server
ディレクトリサーバ連携機能を使用している場合，このコマンドは実行できません。
02
Not found authorization identifier cc....cc
pdacunlckコマンドに指定した認可識別子が存在しません。
03
Duplicate authorization identifier cc....cc
pdacunlckコマンドに指定した認可識別子が重複しています。
04
Number of authorization identifier exceeds 128
認可識別子の指定数が129以上になっています。
KFPD01113-I
"pdacunlck" command ended, return code=a　　（Ｌ＋Ｓ）
pdacunlckコマンドがリターンコードaで終了しました。
a：リターンコード
0：正常終了
8：異常終了
(Ｓ)このSQL文を無視する。
[対策]リターンコードが8の場合，出力されたメッセージを参照してエラーとなった原因を取り除いてから，pdacunlckコマンドを実行してください。


KFPHメッセージ

KFPH00031-E
RDAREA "aa....aa" not initialized, file=bb....bb，reason code=cc　　（Ｌ）
RDエリアaa....aaのHiRDBファイルbb....bbは，初期化されていません。
aa....aa：RDエリア名称
bb....bb：HiRDBファイルシステム領域名/HiRDBファイル名
HiRDBファイルのパス名が132文字以上の場合は，HiRDBファイルのパス名の後ろから131文字を出力します。
cc：理由コード
1：RDエリアの再初期化が未完了
2：RDエリアの削除が未完了
3：RDエリアの統合が未完了
10～19：RDエリアの管理情報が未設定
(Ｓ)〈ユーザ用RDエリアの場合〉
該当するRDエリアを閉塞して処理を続行します。
〈ユーザ用RDエリア以外の場合〉
処理を終了します。
ただし，HiRDBのコマンドを実行中に，このメッセージが出力されたときは，該当するRDエリアを障害閉塞し，コマンド処理を続行します。
[対策]次に示す原因のうち，どの原因でメッセージが出力されたかを調査し，RDエリアを正常にして再度処理を実行してください。
1. データベース構成変更ユティリティの次に示す処理が正常終了していないため，このRDエリアは使用できません。
・RDエリアの再初期化
・RDエリアの削除
・RDエリアの統合
2. RDエリアの回復に失敗しました。
3. HiRDBファイルシステム領域が不整合です。
4. マスタディレクトリ用RDエリア，又はデータディクショナリ用RDエリアと，エラーが発生したRDエリアを格納するHiRDBファイルシステム領域との同期が取れていません。
5. RDエリアの内容が破壊されています。
なお，1～5の原因に該当しないときは，保守員に連絡してください。
KFPH00035-W
Global buffer pool not allocated for RDAREA aa....aa　　（Ｌ）
RDエリアにグローバルバッファプールが割り当てられていません。
aa....aa：RDエリア名
(Ｓ)RDエリアをクローズ状態にして，処理を続行します。
[対策]システム共通定義のpdbufferオペランドで，該当するRDエリアにグローバルバッファプールを割り当ててください。
KFPH00110-I
aa....aa command completed　　（Ｌ）
HiRDBのコマンドaa....aaの処理が終了しました。
aa....aa：コマンド名称
(Ｓ)処理を終了します。
KFPH00115-I
aa....aa command failed　　（Ｌ＋Ｓ）
HiRDBのコマンドaa....aaは，処理できません。
aa....aa：コマンドの名称
(Ｓ)入力されたコマンドを無視して，処理を終了します。
ただし，pdholdコマンドの-cオプション又はpdrelsコマンドの-oオプションを指定していた場合は，コマンドの処理が途中まで実行されていることがあります。
KFPH00130-I
RDAREA aa....aa,RDAREA = bb....bb　　（Ｌ＋Ｓ）
指定したRDエリアを閉塞，閉塞解除，オープン，クローズ，更新凍結，又は更新凍結解除しました。
aa....aa：RDエリアに対する処理の内容
held：RDエリアの閉塞（アクセス禁止）
held（inq）：RDエリアの閉塞（参照可）
held(bu i)：参照可能バックアップ閉塞
held(bu iw)：参照可能バックアップ閉塞（更新WAITモード）
held(bu)：更新可能バックアップ閉塞
held(bu w)：更新可能バックアップ閉塞（WAITモード）
held(sync)：同期化閉塞
held(org)：オンライン再編成閉塞
released：RDエリアの閉塞解除
opened：RDエリアのオープン
closed：RDエリアのクローズ
freezed：RDエリアの更新凍結
unfreezed：RDエリアの更新凍結解除
bb....bb：RDエリア名称
(Ｓ)処理を続行します。
KFPH00131-E
pdhold command failed due to RDAREA already held, RDAREA=aa....aa　　（Ｌ）
指定したRDエリアは既に障害閉塞しているため，コマンドでの閉塞はできません。
aa....aa：RDエリア名称
(Ｓ)該当するRDエリアの処理を無視して，処理を実行します。
(Ｏ)pddblsコマンドで，RDエリアの状態を確認してください。
障害閉塞になった原因を取り除いて閉塞解除した後，再度コマンドを実行してください。
KFPH00132-E
aa....aa command failed due to HiRDB error, bb....bb = cc....cc code = ddd[, server = ee....ee]　　（Ｌ＋Ｓ）
HiRDBサーバでエラーが発生したため，HiRDBのコマンドaa....aaは処理できません。
aa....aa：コマンド名称
bb....bb：誤りがあった指定（次に示すどれかが表示されます）
・RDAREA
・server
・buffer pool
・index
cc....cc：RDエリア名，サーバ名，グローバルバッファ名，又はインデクス名（名称が取得できなかった場合は*****が表示されます）
ddd：エラーコード
-2：データディクショナリ用RDエリアへのアクセスエラー
-4：通信先でメモリ不足発生
-7：RPC通信エラー
-20：RDエリアの再初期化が未完了
-21：RDエリアの削除が未完了
-22：ページ長がバッファ長よりも大きい
-24：該当するRDエリアにデータ未完状態の改竄防止表が存在
ee....ee：共用RDエリアの実行サーバ名称
共用RDエリアでエラーが発生した場合に表示されます。
(Ｓ)RDエリアの場合は該当するRDエリアの処理を無効にして処理を続行します。
サーバの場合はエラーがあったサーバの処理を無効にして処理を続行します。
グローバルバッファの場合は該当するグローバルバッファの処理を無効にして処理を続行します。
インデクスの場合は該当するインデクスの処理を無効にして処理を続行します。
(Ｏ)〈エラーコードが-24の場合〉
データベース再編成ユティリティ（pdrorg）でデータ未完状態の改竄防止表のリロードを完了させてください。その後，pdrelsコマンドで閉塞を解除し，業務を再開してください。
〈エラーコードが-24以外の場合〉
メッセージログファイルに出力されているメッセージを参照して，エラーの原因を取り除き，再度コマンドを実行してください。
〈共用RDエリア使用時にサーバ名が表示されている場合〉
メッセージログファイルに出力されているメッセージを参照して，該当するサーバのエラーの原因を取り除き，再度コマンドを実行してください。
KFPH00133-E
RDAREA release failed due to not recoverd, RDAREA=aa....aa　　（Ｌ）
障害閉塞したRDエリアaa....aaを回復していないため，障害閉塞を解除できません。又は，同期化閉塞したRDエリアaa....aaに整合性のあるデータを反映していないため，閉塞解除できません。
aa....aa：RDエリア名称
(Ｓ)このRDエリアに対するコマンド処理を無効にして，処理を続行します。
[対策]pddblsコマンドでRDエリアの状態を確認してください。RDエリアが障害閉塞している場合は，次に示すどちらかの処置をしてRDエリアの障害閉塞を解除してください。
・pdrstrコマンドでRDエリアを回復してください。
・pdmodコマンドでRDエリアを再初期化してください。ただし，この場合，RDエリア内のデータが削除されます。
インナレプリカ機能使用時の同期化閉塞は，インナレプリカグループ内で整合性のある複製RDエリアのデータを反映した後に再度コマンドを実行してください。
KFPH00134-I
aa....aa command completed, server = bb....bb　　（Ｌ＋Ｓ）
サーバbb....bbで，運用コマンドaa....aaの処理が完了しました。
aa....aa：コマンド名
bb....bb：サーバ名
(Ｓ)処理を続行します。
KFPH00135-E
aa....aa command failed, server = bb....bb　　（Ｌ＋Ｓ）
サーバbb....bbで，運用コマンドaa....aaの処理ができませんでした。
aa....aa：コマンド名
bb....bb：サーバ名
(Ｓ)エラーがあったサーバの処理を無効にして処理を続行します。
[対策]出力されているメッセージを参照してエラーの原因を取り除いた後に，コマンドを再度実行してください。
KFPH00141-E
aa....aa command failed due to specified name invalid, RDAREA = bb....bb　　（Ｌ）
指定されたRDエリア名が誤っているため，HiRDBのコマンドaa....aaの処理ができません。
マスタディレクトリ用RDエリアに対して，コマンドaa....aaは実行できません。又は，ユーザLOB用RDエリア以外のRDエリアに対して，pddbfrzコマンドは実行できません。
aa....aa：コマンド名
bb....bb：RDエリア名
(Ｓ)該当するRDエリアの処理を無効にし，処理を続行します。
(Ｏ)正しいRDエリア名を指定して，再度コマンドを実行してください。又は，RDエリア一括指定のパターン文字列中に「%」，「_」を含んでいる場合は，「%」，「_」を削除してから再度コマンドを実行してください。
KFPH00142-E
aa....aa command failed due to specified name not found, bb....bb = cc....cc[, server = dd....dd]　　（Ｌ＋Ｓ）
指定されたRDエリア名，サーバ名，バッファプール名，又は表名が見付かりません。このため，HiRDBのコマンドaa....aaの処理ができません。
aa....aa：コマンド名称
bb....bb：誤りがあった指定{ RDAREA | server | buffer pool | table }
cc....cc：RDエリア名，サーバ名，バッファプール名，又は表名
dd....dd：共用RDエリアの実行サーバ名
pddblsコマンド実行時に共用RDエリアでエラーが発生した場合に表示されます。
(Ｓ)cc....ccに対応した次の処理をします。
・RDエリア名の場合，該当するRDエリアの処理を無効にし，処理を続行します。
・サーバの場合，エラーがあったサーバの処理を無効にして，処理を続行します。
・バッファプールの場合，該当バッファプールの処理を無効にして，処理を続行します。
・表名の場合は，処理を中断します。
(Ｏ)正しいRDエリア名，サーバ名，バッファプール名，又は表名を指定して，再度コマンドを実行してください。
KFPH00145-E
aa....aa command failed due to HiRDB error, code = bbb[, server = cc....cc]　　（Ｌ＋Ｓ）
HiRDBシステムでエラーが発生しました。このため，HiRDBのコマンドaa....aaの処理ができません。
aa....aa：コマンド名称
bbb：エラーコード
-4：メモリ不足
-5：排他エラー
-6：排他解除エラー
-8：RDエリア情報管理ブロックのメンテナンスエラー
-9：トランザクション開始エラー
-10：HiRDBファイルシステム領域の情報取得エラー
-11：オブジェクトキャッシュの未解放
-12：オブジェクトキャッシュのロックができません。
-13：オブジェクトキャッシュのアンロックができません。
cc....cc：共用RDエリアの実行サーバ名
共用RDエリアでエラーが発生した場合に表示されます。
(Ｓ)処理を終了します。
(Ｏ)メッセージログファイルに出力されているメッセージを参照して，エラーの原因を取り除き，再度コマンドを実行してください。
・サーバ名が表示されている場合
メッセージログファイルに出力されているメッセージを参照して，該当するサーバのエラーの原因を取り除き，コマンドを再度実行してください。
・pdorbegin -uコマンドを実行する場合
RDエリアがオンライン再編成閉塞を解除できる状態かどうかを確認してください。
KFPH00153-E
aa....aa command failed due to RDAREA status invalid, RDAREA = bb....bb　　（Ｌ＋Ｓ）
RDエリアの状態が不正です。このため，HiRDBのコマンドaa....aaの処理ができません。
aa....aa：コマンド名称
bb....bb：RDエリア名
(Ｓ)該当するRDエリアの処理を無効にして，処理を続行します。
(Ｏ)pddblsコマンドでRDエリアの状態を確認して，正しい状態に修正して，再度コマンドを実行してください。
共用RDエリア使用時は，pddbls -mコマンドでサーバごとの共用RDエリアの状態を確認して，全共用RDエリアを正しい状態に修正してください。その後，コマンドを再度実行してください。
一時的にオンライン再編成閉塞から参照可能閉塞となっている場合，そのRDエリアはバックアップ閉塞にはできません。参照可能閉塞をpdrelsコマンドで閉塞解除し，更にpdorchgコマンド実行前の場合はpdorbeginコマンド，pdorchgコマンド実行後の場合はpdorendコマンドでオンライン再編成閉塞を解除し，その後にコマンドを再度実行してください。また，オンライン再編成閉塞となっているRDエリアがある場合，pddbchgコマンドは実行できません。pdorchgコマンド実行前はpdorbeginコマンド，pdorchgコマンド実行後はpdorendコマンドでオンライン再編成閉塞を解除し，その後にコマンドを再度実行してください。
KFPH00154-E
RDAREA open failed due to not recovered, RDAREA=aa....aa　　（Ｌ）
障害閉塞したRDエリアaa....aaを回復していないため，オープンできません。
aa....aa：RDエリア名
(Ｓ)このRDエリアに対するコマンドを無効にし，処理を続行します。
[対策]RDエリアが閉塞した原因を取り除き，pdrelsコマンドでRDエリアの閉塞状態を解除してください。
KFPH00155-W
RDAREA status changed, though not recovered, RDAREA=aa....aa　　（Ｌ）
障害閉塞したRDエリアaa....aaを回復していませんが，RDエリアの状態を変更しました。又は，同期化閉塞したRDエリアaa....aaに整合性のあるデータを反映しないでRDエリアの状態を変更しました。
aa....aa：RDエリア名
(Ｓ)処理を続行します。
[対策]RDエリアが閉塞した原因を調査し，運用に支障があれば，閉塞の原因を取り除いてください。
KFPH00156-E
Backup hold canceled due to deadlock occurred,RDAREA = "aa....aa"[, server = bb....bb]　　（Ｌ＋Ｓ）
デッドロックが発生したのでバックアップ閉塞を無効にしました。
aa....aa：RDエリア名
bb....bb：共用RDエリアの実行サーバ名
共用RDエリアでエラーが発生した場合に表示されます。
(Ｓ)処理を終了します。
(Ｏ)
更新WAITモードの参照可能バックアップ閉塞又は更新可能バックアップ閉塞中のRDエリアがある場合，デッドロック情報（共用RDエリアの場合はサーバのデッドロック情報）を参照してバックアップ閉塞RDエリア（資源種別0602）の排他を確保しているRDエリアを探してください。その後，そのRDエリアの閉塞をpdrelsコマンドで解除して，再度pdholdコマンドを実行してください。
それ以外の場合は時間を空けて再度pdholdコマンドを実行してください。デッドロック情報については，マニュアル「HiRDB Version 7 システム運用ガイド」を参照ください。
KFPH00157-W
Unable to recover without log file because of update in backup hold, RDAREA=aa....aa　　（Ｌ＋Ｓ）
更新可能バックアップ閉塞（WAITモード）中にRDエリアaa....aaに更新処理がありました。このバックアップを使用してデータベースを回復する場合は，バックアップ取得直前のシンクポイントからのシステムログをアンロードしたアンロードログファイルが必要になります。
aa....aa：RDエリア名
(Ｓ)処理を続行します。
[対策]RDエリアを回復する場合は，バックアップファイル及びアンロードログファイルを使用してください。
KFPH00210-I
Clustering disordered, table id = aa....aa　　（Ｌ）
クラスタリング指定の表で，行が所定のセグメントに格納できなくなり，クラスタリング効果がなくなり始めました。
aa....aa：表番号
(Ｓ)処理を続行します。
(Ｏ)該当する表を再編成してください。
KFPH00211-I
RDAREA usage aaa%, RDAREA = "bb....bb"cc....cc　　（Ｌ）
状況によるメッセージの意味を，次に示します。
〈システム定義pd_rdarea_warning_pointを指定していない場合〉
マスタディレクトリ用，データディレクトリ用RDエリア：
メッセージは出力されません。
データディクショナリ用，ユーザ用，ユーザLOB用，レジストリ用，レジストリLOB用RDエリア：
RDエリアbb....bbの，最終ファイルのセグメントのうち，相対位置aaa％目に当たるセグメントを使用し始めました。
〈システム定義pd_rdarea_warning_pointを指定している場合〉
マスタディレクトリ用，データディレクトリ用，データディクショナリ用，ユーザ用，レジストリ用RDエリア：
RDエリアbb....bbの，RDエリア全体のセグメントのうち，使用率aaa％目となるセグメントを使用し始めました。現在の，未使用セグメントの数は，cc....ccです。
ユーザLOB用，レジストリLOB用RDエリア：
RDエリアbb....bbの，RDエリア全体のセグメントのうち，相対位置aaa％目となるセグメントを使用し始めました。有効性能※を維持できる残りのセグメントの数は，cc....ccです。
注※有効性能：
ユーザLOB用RDエリアは，データベース領域を一度も最後まで使用していない時が，最も処理能力が高くなります。有効性能とは，この処理能力が高い状態のことです。データベースを一度でも，最後まで使用した場合は，処理能力が劣化するため，事前にデータベースの再編成をするなどの処置が必要になります。
aaa：次のうち，どれかが出力されます。
・RDエリアの最終ファイルの使用セグメント相対位置
・RDエリア全体のセグメント使用率
・RDエリア全体の使用セグメント相対位置
bb....bb：該当するRDエリア名称
cc....cc：セグメント使用率追加情報, dd....dd segments unused
（dd....dd 残りセグメント数）
(Ｓ)処理を続行します。
このメッセージの対象となるRDエリアは，容量不足で新しいセグメントを割り当てできなくても，追加，更新などをしている既存のセグメントに空きがあれば，そのセグメントを利用して処理を続行します。
なお，このメッセージは，表示の対象となったセグメントが，表の削除，表の再編成などによって解放されて，その後，同じセグメントを使用すると，再度表示されます。
(Ｐ)HiRDB管理者に連絡してください。
[対策]次のコマンド又はユティリティを使って，RDエリアに残っている容量を調査し，表に示すような処置を取ってください。
〈残り容量を調査するためのコマンド〉
・データベースの状態表示コマンド（pddbls）
-aオプションを指定すると，RDエリアの使用状況が表示できます。すべてのRDに使用できます。
・データベース状態解析ユティリティ（pddbst）
物理的解析，又は論理的解析で，RDエリアの使用状況が分かります。データディクショナリ，ユーザ，LOB用，レジストリ用，レジストリLOB用のRDエリアに使用できます。
〈処置〉処置を次の表に示します。
RDエリアの種別
システム定義pd_rdarea_warning_pointを指定していない場合
システム定義pd_rdarea_warning_pointを指定している場合
マスタ・データディレクトリ用RDエリア
メッセージは出力されません。
・データベースの状態表示コマンド（pddbls）又は，メッセージに出力されたセグメント使用率追加情報を参照して，対象となるRDエリアの使用状況を調べます。
・使用状況に応じて，RDエリアを拡張してください。
・データベース状態解析ユティリティ（pddbst）は，このRDエリアには使用できません。また，このRDエリアの再編成はできません。
データディクショナリ用RDエリア
・データベースの状態表示コマンド（pddbls）又はデータベース状態解析ユティリティ（pddbst）で，対象となるRDエリアの使用状況を調べます。
・使用状況に応じて，RDエリアを拡張してください。
・データベースの状態表示コマンド（pddbls）又はデータベース状態解析ユティリティ（pddbst）で，又は，メッセージに出力されたセグメント使用率追加情報を参照して，対象となるRDエリアの使用状況を調べます。
・使用状況に応じて，RDエリアを拡張してください。
・このRDエリアの再編成はできません。
ユーザ用RDエリア
・データベースの状態表示コマンド（pddbls）又はデータベース状態解析ユティリティ（pddbst）で，対象となるRDエリアの使用状況を調べます。
・使用状況に応じて，RDエリアの表の再編成をしてください。又はRDエリアを拡張してください。
・データベースの状態表示コマンド（pddbls）又はデータベース状態解析ユティリティ（pddbst）で，又は，メッセージに出力されたセグメント使用率追加情報を参照して，対象となるRDエリアの使用状況を調べます。
・使用状況に応じて，表のRDエリア単位の再編成又は表単位の再編成をしてください。又は，RDエリアを拡張してください。
LOB用RDエリア
・データベースの状態表示コマンド（pddbls）又はデータベース状態解析ユティリティ（pddbst）で，対象となるRDエリアの使用状況を調べます。
・使用状況に応じて，ユーザLOB用エリア単位の再編成又は表単位の再編成をしてください。又は，RDエリアを拡張してください。
・データベースの状態表示コマンド（pddbls）又はデータベース状態解析ユティリティ（pddbst）で，又は，メッセージに出力されたセグメント使用率追加情報を参照して，対象となるRDエリアの使用状況を調べます。
・使用状況に応じて，ユーザLOB用RDエリア単位の再編成又は表単位の再編成をしてください。又は，RDエリアを拡張してください。
KFPH00212-I
Table should be reorganized,RDAREA="aa....aa",AUTHID=bb....bb,TABLE=cc....cc　　（Ｌ）
表の再編成が必要な状態になりました。
aa....aa：RDエリア名
bb....bb：認可識別子
cc....cc：表識別子
(Ｓ)処理を続行します。
[対策]データベース再編成ユティリティ（pdrorg）で，表を再編成してください。ただし，次に示す場合は，RDエリアの容量を拡張する必要があります。
・同一のRDエリアの表に対してこのメッセージが頻繁に出力される場合
・表の再編成中，又は表の再編成直後にこのメッセージが出力される場合
KFPH00213-W
All segments in RDAREA "aa....aa" allocated　　（Ｌ）
表，又はインデクスに対して新規セグメントを確保しようとしましたが，RDエリアaa....aaの全セグメントが使用されています。
このメッセージは，データディクショナリ用RDエリア，データディクショナリLOB用RDエリア，ユーザ用RDエリア，及びユーザLOB用RDエリアに対して出力されます。また，このメッセージはサーバの起動後1RDエリアごとに1度だけ出力され，次の契機で警告メッセージ出力済み状態が解除されます。
・HiRDBサーバの起動
・RDエリアの閉塞解除
・運用コマンドによるRDエリアのオープン
・RDエリアの拡張
aa....aa：RDエリア名
(Ｓ)処理を続行します。
このメッセージの対象となるRDエリアが容量不足で新しいセグメントを割り当てできなくても，追加又は更新などをしている既存のセグメントに空きがあれば，そのセグメントを利用して処理を続行します。
なお，このメッセージの表示対象となったセグメントが，表の削除や再編成などによって解放され，その後，同じセグメントを使用すると，このメッセージが再度表示されます。
[対策]KFPH00211-Iメッセージの対策を参照して処置してください。
KFPH00306-E
RDAREA aa....aa held due to bb....bb　　（Ｌ）
RDエリアaa....aaをbb....bbの理由で障害閉塞しました。
aa....aa：RDエリア名
bb....bb：閉塞した理由
LIST RDAREA error：
リスト用RDエリアの異常を検知しました。
error occurred in log less utility：
ログを取得しないユティリティの処理で異常を検知しました。RDエリアを閉塞します。
error occurred in log less uap：
ログを取得しないUAPの処理で異常を検知しました。RDエリアを閉塞します。
error occurred in table of RECOVERY NO option at BLOB column：
BLOB列がRECOVERY NOオプションです。RDエリアを閉塞します。
I/O error occurred：
入出力エラーが発生しました。
open error occurred：
オープンエラーが発生しました。
page corrupted：
ページ内の内部矛盾を検知しました。
rollback failed：
ロールバックに失敗しました。
time stamp invalid：
ページ内タイムスタンプの不一致を検知しました。
object ID invalid：
ページ内オブジェクトIDの不一致を検知しました。
(Ｓ)RDエリアからの入力中の場合（ただし，データベース回復ユティリティ，リラン，ロールバック時を除く），処理を中断してロールバックします。それ以外の場合，処理を続行します。
［対策］
LIST RDAREA errorの場合：
リスト用RDエリアが障害閉塞した後，RDエリアを回復しないで強制的に閉塞解除した状態でHiRDBを起動した場合に出力されます。リスト用RDエリアの再初期化をしてからpdrelsコマンドで閉塞を解除し，業務を再開してください。
error occurred in log less utility，error occurred in log less uap，及びerror occurred in table of RECOVERY NO option at BLOB columnの場合：
RDエリアをデータベース回復ユティリティで回復した後にpdrelsコマンドで閉塞を解除し，業務を再開してください。
I/O error occurredの場合：
直前に出力されるKFPH22003-E又はKFPH23100-Eを参照し，入出力エラーの要因を取り除いてください。RDエリアをデータベース回復ユティリティで回復した後にpdrelsコマンドで閉塞を解除し，業務を再開してください。
open error occurredの場合：
直前に出力されるKFPH22003-E又はKFPH23100-Eを参照し，オープンエラーの要因を取り除いてください。RDエリアをデータベース回復ユティリティで回復した後にpdrelsコマンドで閉塞を解除し，業務を再開してください。
time stamp invalidの場合：
保守員に連絡してください。$PDDIR/spool下に簡易ダンプが出力されるので保管しておいてください。RDエリアをデータベース回復ユティリティで回復した後にpdrelsコマンドで閉塞を解除し，業務を再開してください。
そのほかの場合：
RDエリアの回復に失敗している可能性があります。次の項目を調べてください。
・過去にそのRDエリアが障害閉塞していて，RDエリアを回復していない，又はデータベース回復ユティリティが失敗している状態で強制的にRDエリアを閉塞解除して運用している。
・HiRDBを強制開始して運用している。
・HiRDBを強制終了又はHiRDBが異常終了している状態で，ステータスファイル及びログファイルを初期化した後，HiRDBを再起動して運用している。
・過去にバックアップからRDエリアを回復するとき，回復したRDエリアに関連するすべてのRDエリアをバックアップから回復していない。
・HiRDBを強制終了又はHiRDBが異常終了している状態で，バックアップをリストアし，HiRDBを再起動している。
上記の項目に該当する場合は，RDエリアをデータベース回復ユティリティで回復した後にpdrelsコマンドで閉塞を解除し，業務を再開してください。
上記の項目に該当しない場合，保守員に連絡してください。$PDDIR/spool下に簡易ダンプが出力されるので保管しておいてください。RDエリアをデータベース回復ユティリティで回復した後にpdrelsコマンドで閉塞を解除し，業務を再開してください。
KFPH00307-E
RDAREA "aa....aa" HELD(CMD) due to bb....bb　　（Ｌ）
RDエリアaa....aaをbb....bbの理由でコマンド閉塞しました。
aa....aa：RDエリア名
bb....bb：閉塞した理由
time stamp invalid：
ページ内タイムスタンプの不一致を検知しました。
I/O error occurred：
入出力エラーが発生しました。
open error occurred：
オープンエラーが発生しました。
object ID invalid：
ページ内オブジェクトIDの不一致を検知しました。
page corrupted：
ページ内の内部矛盾を検知しました。
data unfinished：
データ未完状態の改竄防止表を検出しました。
LIST RDAREA error：
リスト用RDエリアの異常を検知しました。
rollback failed：
ロールバックに失敗しました。
error occurred in log less utility：
ログを取得しないユティリティの処理で異常を検知しました。
error occurred in log less uap：
ログを取得しないUAPの処理で異常を検知しました。
error occurred in table of RECOVERY NO option at BLOB column：
LOB列がRECOVERY NOオプション指定でした。
(Ｓ)該当するRDエリアをコマンド閉塞して，ロールバックします。
[対策]
time stamp invalidの場合：
保守員に連絡してください。$PDDIR/spool下に簡易ダンプが出力されるので保管しておいてください。該当するRDエリアに対してKFPH00306-Eメッセージが出力されていなければ，pdrelsコマンドで閉塞を解除し，業務を再開できます。KFPH00306-Eメッセージが出力されている場合は，RDエリアの回復が必要です。KFPH00306-Eに対する処置をしてください。
I/O error occurredの場合：
該当するRDエリアに対してKFPH00306-Eメッセージが出力されていなければ，直前に出力されるKFPH22003-E又はKFPH23100-Eを参照し，入出力エラーの要因を取り除いてください。その後，pdrelsコマンドで閉塞を解除し，業務を再開してください。
なお，KFPH00306-Eメッセージが出力されている場合は，RDエリアの回復が必要です。KFPH00306-Eに対する処置をしてください。
open error occurredの場合：
該当するRDエリアに対してKFPH00306-Eメッセージが出力されている場合は，RDエリアの回復が必要です。KFPH00306-Eに対する処置をしてください。
なお，KFPH00306-Eメッセージが出力されていなければ，直前に出力されるKFPH22003-E又はKFPH23100-Eを参照し，オープンエラーの要因を取り除いてください。その後，pdrelsコマンドで閉塞を解除し，業務を再開してください。
data unfinishedの場合：
該当するRDエリアにデータ未完状態の改竄防止表があります。データベース再編成ユティリティ（pdrorg）でデータ未完状態の改竄防止表のリロードを完了させてください。その後，pdrelsコマンドで閉塞を解除し，業務を再開してください。
LIST RDAREA errorの場合：
リスト用RDエリアが障害閉塞しましたが，RDエリアを回復しないで強制的に閉塞解除した状態でHiRDBを開始した場合に出力されます。リスト用RDエリアを再初期化してからpdrelsコマンドで閉塞を解除し，業務を再開してください。
error occurred in log less utility，error occurred in log less uap，error occurred in table of RECOVERY NO option at BLOB columnの場合：
RDエリアをデータベース回復ユティリティで回復した後でpdrelsコマンドで閉塞を解除し，業務を再開してください。
そのほかの場合：
RDエリアの回復に失敗している可能性があります。次の項目を調べてください。
・過去にそのRDエリアが障害閉塞していて，RDエリアを回復していない，又はデータベース回復ユティリティが失敗している状態で強制的にRDエリアを閉塞解除して運用している。
・HiRDBを強制開始して運用している。
・HiRDBを強制終了又はHiRDBが異常終了している状態で，ステータスファイル及びログファイルを初期化した後，HiRDBを再起動して運用している。
・過去にバックアップからRDエリアを回復するとき，回復したRDエリアに関連するすべてのRDエリアをバックアップから回復していない。
上記の項目に該当する場合は，RDエリアをデータベース回復ユティリティで回復した後にpdrelsコマンドで閉塞を解除し，業務を再開してください。
上記の項目に該当しない場合，保守員に連絡してください。$PDDIR/spool下に簡易ダンプが出力されるので保管しておいてください。該当RDエリアに対してKFPH00306-Eメッセージが出力されている場合は，RDエリアの回復が必要です。KFPH00306-Eに対する処置をしてください。KFPH00306-Eメッセージが出力されていなければ，pdrelsコマンドで閉塞を解除し，業務を再開できます。
KFPH00308-E
Page corrupted, RDAREA = "aa....aa", file name = bb....bb, offset = cc....cc　　（Ｌ）
ページ破壊を検知しました。
aa....aa：RDエリア名
bb....bb：HiRDBファイルシステム領域名/HiRDBファイル名
HiRDBファイルのパス名が132文字以上の場合は，HiRDBファイルのパス名の後ろから131文字を出力します。
cc....cc：HiRDBファイルの先頭からの相対バイト位置です。ページ破壊の箇所を10進数で示しています。
(Ｓ)このRDエリアを閉塞します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]保守員に連絡してください。閉塞したRDエリアはデータベース回復ユティリティで回復してください。
KFPH00309-E
DB error inf1=(file=aa....aa,offset=bb....bb,pno=cc....cc,fno=dd)　　（Ｌ）
データベースエラー時の保守情報を出力します。
aa....aa：HiRDBファイルシステム領域名/HiRDBファイル名
HiRDBファイルのパス名が132文字以上の場合は，HiRDBファイルのパス名の後ろから131文字を出力します。
不明の場合は******が表示されます。
bb....bb：エラーを検出したページの，HiRDBファイルの先頭からのオフセット
（不明の場合は******が表示されます）
cc....cc：ページ番号
dd：ファイル番号
(Ｓ)処理を続行します。
[対策]このメッセージの後に出力されるKFPH00306-E又はKFPH00307-Eメッセージ，及びアボートコードの処置に従ってください。
KFPH00310-E
DB error inf2=(func=aa....aa,line=bbbbb,RDAREA="cc....cc",RDID=dd....dd,ptype=e,
TBLID=ff....ff,IDXID=gg....gg,LSTID=hh....hh,opcode=iiiii,stype=jj)　　（Ｌ）
データベースエラー時の保守情報を出力します。
aa....aa：エラーが検出された関数の名称
bbbbb：エラーが検出された行番号
cc....cc：RDエリア名（不明の場合は******が表示されます）
dd....dd：RDエリアID
e：検出ページ種別
I：インデクス
T：データ
D：ディレクトリ
L：リスト
B：LOB
ff....ff：該当する表のID（不明の場合は******が表示されます）
gg....gg：該当するインデクスのID（不明の場合は******が表示されます）
hh....hh：該当するリストのID（不明の場合は******が表示されます）
iiiii：オペレーションコード（不明の場合は***が表示されます）
jj：スキャンタイプ（不明の場合は**が表示されます）
(Ｓ)処理を続行します。
[対策]このメッセージの後に出力されるKFPH00306-E又はKFPH00307-Eメッセージ，及びアボートコードの処置に従ってください。
KFPH00372-I
RDAREA "aa....aa" not recovered from hold status　　（Ｌ）
回復していない障害閉塞RDエリアがあります。
aa....aa：RDエリア名
(Ｓ)処理を続行します。
[対策]該当するRDエリアを回復した後，閉塞状態を解除してください。
KFPH20001-E
Invalid HiRDB ID for database, HiRDB ID=aaaa, database initialize HiRDB ID=bbbb　　（Ｌ）
起動したHiRDB識別子aaaaは，データベースを初期設定したHiRDBのHiRDB識別子bbbbと異なります。
aaaa：起動したHiRDBのHiRDB識別子
bbbb：初期設定したHiRDBのHiRDB識別子
(Ｓ)異常終了します。
[対策]システム共通定義のpd_system_idオペランドに指定したHiRDB識別子を次に示すHiRDB識別子に修正して，再度実行してください。
・データベースを初期設定したHiRDBのHiRDB識別子
又は，データベース初期設定ユティリティを実行してください。
KFPH20003-E
Server aa....aa initialization failes, function=bb....bb, return code=cccc　　（Ｌ）
サーバaa....aa開始時，bb....bbでコードccccのエラーが発生しました。
aa....aa：サーバ名
bb....bb：エラーの発生した関数
cccc：リターンコード
(Ｓ)サーバの処理を終了します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]
bb....bb
cccc
処置
malloc
－
プロセス固有領域が不足しています。このため，次の方法で，使用できるメモリに余裕を持たせてください。
・同時実行しているプロセス数を減らしてください。
・スワップ領域を増やしてください。
・実メモリを増設してください。
p_f_dbh_buf_defmk
-150
システム共通定義のpdbuffer文が不正なため，pdbuffer文を正しく修正してください。
上記以外
このメッセージの前に出力されているメッセージを参照してエラーの原因を取り除き，サーバを再度起動してください。メッセージが出力されていない場合は保守員に連絡してください。
p_f_dbh_hba_mmap_copy
-100
実行系からのHiRDBデータベース環境情報ファイルの取得処理に失敗しました。実行系に出力されているメッセージを参照してエラーの原因を取り除き，待機系HiRDBを再度開始してください。メッセージが出力されていない場合は保守員に連絡してください。
-110
-120
実行系からのrcpコマンドの失敗，実行系HiRDBでタイムアウトの発生，又は実行系の起動失敗が発生しました。実行系に出力されているメッセージを参照してエラーの原因を取り除き，待機系HiRDBを再度開始してください。メッセージが出力されていない場合は保守員に連絡してください。
-140
実行系に対するrshコマンドの失敗です。リモートシェルを実行できる環境にしてから，待機系HiRDBを再度開始してください。
上記以外
実行系に出力されているメッセージを参照してエラーの原因を取り除き，待機系HiRDBを再度開始してください。メッセージが出力されていない場合は保守員に連絡してください。
p_f_dbh_dint_rblk_set
-160
・高速系切り替え機能使用時，実行系HiRDBでデータベース構成変更ユティリティを実行したが，待機系HiRDBを再度開始していません。このため，系の切り替えに失敗しました。待機系HiRDBを再度開始してください。
・スタンバイレス型系切り替え機能使用時，データベース構成変更ユティリティを実行したが，代替部の待機状態を一度解除してから再度待機状態にしていません。又は，代替中にデータベース構成変更ユティリティを実行したが，正規BESユニットを再度開始していません。このため，系の切り替えに失敗しました。HiRDB/パラレルサーバを正常終了後，再度開始してください。
-161
・高速系切り替え機能使用時，マスタディレクトリ用RDエリアの更新後にディクショナリサーバを単独で正常終了して再度開始したが，待機系HiRDBを再度開始していません。このため，系の切り替えに失敗しました。待機系HiRDBを再度開始してください。
・スタンバイレス型系切り替え機能使用時，マスタディレクトリ用RDエリアの更新後にディクショナリサーバを単独で正常終了して再度開始したが，代替部の待機状態を一度解除してから再度待機状態にしていません。又は，代替中にマスタディレクトリ用RDエリアの更新後にディクショナリサーバを単独で正常終了して再度開始したが，正規BESユニットを再度開始していません。このため，系の切り替えに失敗しました。HiRDB/パラレルサーバを正常終了後，再度開始してください。
-162
・高速系切り替え機能使用時，HiRDBシステム定義の変更後に実行系のサーバを単独で正常終了して再度開始したが，待機系HiRDBを再度開始していません。このため，系の切り替えに失敗しました。待機系HiRDBを再度開始してください。
・スタンバイレス型系切り替え機能使用時，HiRDBシステム定義の変更後に正規BESユニットを単独で正常終了して再度開始したが，代替部の待機状態を一度解除してから再度待機状態にしていません。このため，系の切り替えに失敗しました。又は，代替中にHiRDBシステム定義の変更後に代替BESユニットを単独で正常終了して再度開始したが，正規BESユニットを再度開始していません。このため，系の切り替えに失敗しました。HiRDB/パラレルサーバを正常終了後，再度開始してください。
上記以外
このメッセージの前に出力されているメッセージを参照してエラーの原因を取り除き，HiRDBを再度開始してください。メッセージが出力されていない場合は保守員に連絡してください。
pdi_omm_mget
-143
-147
(1)次のサーバ定義のうち該当するサーバの指定値を増やしてください。
・pd_sds_shmpool_size（シングルサーバ定義）
・pd_bes_shmpool_size（バックエンドサーバ定義）
・pd_dic_shmpool_size（ディクショナリサーバ定義）
(2)上記定義を省略している場合，次に示すシステム共通定義の値を指定してください。
・pd_assurance_table_noオペランド
102＋空き領域の再利用機能を使用している表数※以上
・pd_assurance_index_noオペランド
シングルサーバの場合：
（130＋定義インデクス数※）×1.2以上
パラレルサーバの場合：
（定義インデクス数※）×1.2以上
注※
表数及び定義インデクス数については，マニュアル「HiRDB Version 7 システム定義」を参照してください。
上記以外
このメッセージの前に出力されているメッセージを参照してエラーの原因を取り除き，サーバを再度起動してください。メッセージが出力されていない場合は保守員に連絡してください。
上記以外
－
このメッセージの前に出力されているメッセージを参照してエラーの原因を取り除き，サーバを再度起動してください。メッセージが出力されていない場合は保守員に連絡してください。
KFPH20004-E
Server aa....aa termination failed, function=bb....bb, return code=cccc　　（Ｌ）
サーバaa....aaの停止処理時，bb....bbでコードccccのエラーが発生しました。
aa....aa：サーバ名
bb....bb：エラーの発生した関数
cccc：リターンコード
(Ｓ)サーバの停止処理を終了します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]このメッセージの前に出力されているメッセージを基にエラーの原因を取り除き，再度サーバを停止してください。メッセージが出力されていない場合，保守員に連絡してください。
KFPH20005-E
Failed to aa....aa 1st file in MASTER DIRECTORY, return code=bbbb　　（Ｌ）
マスタディレクトリ用RDエリアの先頭のHiRDBファイルに対して，aa....aaの失敗をしました。
aa....aa：理由を示す内容
close：マスタディレクトリ用RDエリアの先頭のファイルに対するクローズ処理
open：マスタディレクトリ用RDエリアの先頭のファイルに対するオープン処理
read：マスタディレクトリ用RDエリアの先頭のファイルからの読み込み
bbbb：リターンコード
(Ｓ)HiRDBの起動処理を中止して，異常終了します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]「HiRDBファイルシステムに対するアクセス要求から返されるエラーコード」を参照して，エラーの原因を取り除き，再度HiRDBを起動してください。
KFPH20006-W
Unable to use work HiRDB file system area, return code=bbbbb, HiRDB file system area name=aa....aa　　（Ｌ）
作業表用ファイルとして指定したHiRDBファイルシステム領域aa....aaは使用できません。
aa....aa：HiRDBファイルシステム領域名
HiRDBファイルシステム領域名が118文字以上の場合は，HiRDBファイルシステム領域名の後ろから117文字を出力します。
bbbbb：リターンコード
(Ｓ)処理を続行します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]〈データベース初期設定ユティリティ実行時の場合〉
データベース初期設定ユティリティが正常に終了していなければ，「HiRDBファイルシステムに対するアクセス要求から返されるエラーコード」を参照して，エラーの原因を取り除き，再度データベース初期設定ユティリティを実行してください。
〈サーバ起動時の場合〉
「HiRDBファイルシステムに対するアクセス要求から返されるエラーコード」を参照して，エラーの原因を取り除き，必要があれば再度サーバを起動してください。
KFPH20007-W
Work HiRDB file system area not specified expansion, HiRDB file system area name=aa....aa　　（Ｌ）
作業表用ファイルとして指定したHiRDBファイルシステム領域aa....aaには，増分指定がありません。
aa....aa：HiRDBファイルシステム領域名
HiRDBファイルシステム領域名が118文字以上の場合は，HiRDBファイルシステム領域名の後ろから117文字を出力します。
(Ｓ)処理を続行します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]〈データベース初期設定ユティリティ実行時の場合〉
データベース初期設定ユティリティ実行時にKFPA11959-Eが出力された場合は，増分指定をしたHiRDBファイルシステム領域を指定し，再度データベース初期設定ユティリティを実行してください。
〈サーバ起動時の場合〉
増分指定をしたHiRDBファイルシステム領域を指定し，必要があれば再度サーバを起動してください。
KFPH20008-W
No work HiRDB file system area　　（Ｌ）
作業表用ファイルとして使用できる領域が，HiRDBファイルシステム領域にありません。
(Ｓ)処理を続行します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]〈データベース初期設定ユティリティ実行時の場合〉
・ディクショナリサーバ定義又はシングルサーバ定義に，pdworkオペランドの指定がない場合，データベース初期設定ユティリティが正常に終了しないときは，HiRDBファイルシステム領域を設定し，再度データベース初期設定ユティリティを実行してください。
・ディクショナリサーバ定義又はシングルサーバ定義に，pdworkオペランドの指定がある場合，データベース初期設定ユティリティが正常に終了しないときは，このメッセージの前に出力されるKFPH20006-Wのメッセージを基にエラーの原因を取り除き，再度データベース初期設定ユティリティを実行してください。
〈サーバ起動時の場合〉
・サーバ定義にpdworkオペランドの指定がない場合，必要があればHiRDBファイルシステム領域を指定し，サーバを再度起動してください。
・サーバ定義にpdworkオペランドの指定がある場合，このメッセージの前に出力されるKFPH20006-Wのメッセージを基にエラーの原因を取り除き，必要があればサーバを再度起動してください。
KFPH20009-W
Duplicate work HiRDB file system area aa....aa　　（Ｌ）
作業表用ファイルとして指定したHiRDBファイルシステム領域は，既に指定されています。
aa....aa：重複しているHiRDBファイルシステム領域名
HiRDBファイルシステム領域名が118文字以上の場合は，HiRDBファイルシステム領域名の後ろから117文字を出力します。
(Ｓ)2回目以降に指定したHiRDBファイルシステム領域名を無視して，処理を続行します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]〈データベース初期設定ユティリティ実行時の場合〉
データベース初期設定ユティリティが正常に終了していなければ，ディクショナリサーバ定義又はシングルサーバ定義のpdworkオペランドに指定した，作業表格納用のHiRDBファイルシステム領域名が重複しないように修正し，再度データベース初期設定ユティリティを実行してください。
〈サーバ起動時の場合〉
サーバ定義のpdworkオペランドに指定した，作業表格納用のHiRDBファイルシステム領域名が重複しないように修正し，再度サーバを起動してください。
KFPH20010-W
Number of work HiRDB file system area exceeds 16　　（Ｌ）
作業表用ファイルとして指定したHiRDBファイルシステム領域の数が最大値（16）を超えています。
(Ｓ)17個目以降に指定したHiRDBファイルシステム領域の名称を無視して，処理を続行します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]〈データベース初期設定ユティリティ実行時の場合〉
データベース初期設定ユティリティが正常に終了していなければ，ディクショナリサーバ定義又はシングルサーバ定義のpdworkオペランドに指定した，作業表格納用のHiRDBファイルシステム領域名の数を16個以下に修正し，再度データベース初期設定ユティリティを実行してください。
〈サーバ起動時の場合〉
サーバ定義のpdworkオペランドに指定した，作業表格納用のHiRDBファイルシステム領域名の数を16個以下に修正し，再度サーバを起動してください。
KFPH20011-E
Incompatible character code set for database, character code set=aa....aa, database initialize character code set=bb....bb　　（Ｌ）
起動したHiRDBの文字コード種別aa....aaは，データベースの初期設定をしたHiRDBの文字コード種別bb....bbと異なります。
aa....aa：起動したHiRDBの文字コード種別
bb....bb：初期設定をしたHiRDBの文字コード種別
CHINESE：EUC中国語漢字コード
LANG-C：単一バイト文字コード
SJIS：シフトJISコード
UJIS：EUC日本語漢字コード
UTF-8：Unicode
(Ｓ)異常終了します。
[対策]〈文字コード種別をaa....aaにする場合〉
データベース初期設定ユティリティを実行して，データベースを作り直してください。
〈文字コード種別をbb....bbにする場合〉
pdsetup　-cコマンドを再度実行してください。
KFPH20012-E
Incompatible HiRDB version for database, HiRDB version=aaaaa, database version=bb....bb　　（Ｌ）
HiRDBのバージョンが不正です。
・データベースを作成したHiRDBのバージョンは，使用しているHiRDBのバージョンよりも新しいため，データベースをアクセスできません。
・データベースを作成したHiRDBのバージョンから，使用しているHiRDBのバージョンへのデータベースの移行はできません。
aaaaa：起動したHiRDBのバージョン
bb....bb：データベースのバージョンを示す内部情報
(Ｓ)〈HiRDB/シングルサーバ，HiRDB/パラレルサーバで1ユニットの構成の場合〉
アボートコード"PsadsA8"で異常終了します。
〈HiRDB/パラレルサーバで複数ユニットの構成の場合〉
ディクショナリサーバがあるユニットは"PsadsA8"で異常終了します。そのほかのユニットは強制終了します。
[対策]
次のどちらかの対策をしてください。
・データベースのバージョンをaa....aaにする場合は，pdstart -iコマンドでHiRDBを起動し，KFPS05201-Qメッセージが出力された後に，データベース初期設定ユティリティ（pdinit）を実行してください。
・データベースのバージョンをbb....bbのままで使用する場合は，HiRDBを旧バージョンに戻してください。
HiRDBを旧バージョンに戻す場合については，マニュアル「HiRDB Version 7 システム導入・設計ガイド」を参照してください。
KFPH20013-E
Incompatible database format with HiRDB, database data model=64-bit, HiRDB data model=32-bit　　（Ｌ）
・64ビットモードのHiRDBで作成したデータベースを，32ビットモードのHiRDBでアクセスできません。
・64ビットモードのHiRDBから，32ビットモードのHiRDBへの移行はできません。
(Ｓ)アボートコードPsadsA8で異常終了します。
[対策]HiRDBを64ビットモードにしてください。移行方法については，マニュアル「HiRDB Version 7 システム導入・設計ガイド」を参照してください。
KFPH20015-I
Copying HiRDB database environment information files necessary for server aa....aa initialization from online unit　　（Ｌ）
サーバaa....aaの待機起動に必要なHiRDBデータベース環境情報を実行系ユニットから取得します。
aa....aa：サーバ名
(Ｓ)処理を続行します。
KFPH21001-E
Error occurred at aa....aa code=bbbb on cc....cc　　（Ｌ）
サーバcc....ccの開始時，コードbbbbのaa....aaエラーが発生しました。
aa....aa：エラーの内容
{ Process Communication | Get Work Area | Define pd_rdarea_list_no_wrn_pnt
| Get Control Area(rerun ctrl) | Call hbuf_ucbint| Call adm_complete
| Call p_f_pls_call_by_timing | Get Environment| Get Control Area| Get Log Area
| Init. SQA | Init. DBH | Init. DIC | Call plugin(start process)
| Call plugin(terminate process) | Call adm_rerun_end }
bbbb：エラーコード（aa....aaがDefine pd_rdarea_list_no_wrn_pntの場合，-1を表示します）
cc....cc：サーバ名（サーバ名の取得に失敗した場合は，********が表示されます）
(Ｓ)サーバプロセスの開始処理を終了します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]
〈aa....aaがProcess Communicationの場合〉
bbbbのコードを「RPC関連エラーの詳細コード」を参照して対策してください。
〈aa....aaがGet Work Area，Get Log Areaの場合〉
次の方法などで，プロセス固有領域を大きくし，使用できるメモリに余裕を持たせて，再度実行してください。
・同時実行しているプロセス数を減らしてください。
・スワップ領域を増やしてください。
・実メモリを増設してください。
〈aa....aaがDefine pd_rdarea_list_no_wrn_pntの場合〉
システム定義のpd_rdarea_list_no_wrn_pntオペランドを，指定範囲内の値に設定し直して再度HiRDBを開始してください。
〈そのほかの場合〉
このメッセージの前に出力されているメッセージを基にエラーの原因を取り除き，再度サーバを起動してください。メッセージが出力されていない場合は，保守員に連絡してください。
KFPH22001-E
Invalid DIRECTORY data in RDAREA "aa....aa",reason code = b　　（Ｌ）
RDエリアaa....aa内でRDエリアの制御情報に矛盾を検知しました。
aa....aa：RDエリア名
b：理由コード
(Ｓ)異常終了します。該当するRDエリアを閉塞状態にして，処理を無効にします。
[対策]このRDエリアに対する運用に誤りがないか調査して，RDエリアを回復後，再度処理を実行してください。
運用に誤りがない場合は，保守員に連絡してください。
理由コード
説明
1
2
3
4
該当するRDエリアのセグメント，又はページを管理するディレクトリに矛盾があります。
5
6
該当するRDエリアのディレクトリと，マスタディレクトリ用RDエリアの内容が一致しません。
7
8
LOB用RDエリアに，不整合状態を検出しました。
9
該当するRDエリアの，セグメントを管理するディレクトリに矛盾があります。
KFPH22002-E
Insufficient memory on PROCESS, size = aa....aa　　（Ｌ）
プロセス固有領域のメモリ不足が発生しました。
aa....aa：確保しようとした領域サイズ（単位：バイト）
(Ｓ)異常終了します。
[対策]メモリの見積もりに誤りがないか調査し，十分なメモリを確保して，再度実行してください。
KFPH22003-E
HiRDB file "aa....aa" failed, return code=bb....bb, RDAREA="cc....cc", file=dd....dd　　（Ｌ）
HiRDBファイルdd....ddに対するaa....aaがリターンコードbb....bbで終了しました。
aa....aa：HiRDBファイルシステムの機能
{ open | close | lseek | read | write| fstat }
bb....bb：リターンコード
cc....cc：RDエリア名
*MASTER*：マスタディレクトリ用RDエリアを示します。
dd....dd：HiRDBファイルシステム領域名/HiRDBファイル名
HiRDBファイルのパス名が123文字以上の場合は，HiRDBファイルのパス名の後ろから122文字を出力します。
(Ｓ)〈マスタディレクトリ用RDエリアを構成するHiRDBファイルの場合〉
処理を中断します。
〈それ以外のHiRDBファイルの場合〉
該当するRDエリアを閉塞し，処理を続行します。
[対策]「HiRDBファイルシステムに対するアクセス要求から返されるエラーコード」を参照し，エラーの原因を取り除いた後，再度実行してください。マスタディレクトリ用RDエリアの障害の場合，pdstart -rコマンドを指定してHiRDBを起動し，データベース回復ユティリティでマスタディレクトリ用RDエリアを回復してください。
KFPH22004-W
aa....aa reserve Number bb....bb exceeds assurance Number cc....cc, server=dd....dd　　（Ｌ）
aa....aaの予約数bb....bbが最低保証値cc....ccを超えました。発生したサーバはdd....ddです。
aa....aa：｛Table｜Index｝
bb....bb：aa....aaの予約数
cc....cc：pd_assurance_table_noオペランド又はpd_assurance_index_noオペランドの指定値
dd....dd：サーバ名
(Ｓ)処理を続行します。
[対策]このメッセージが出力された後，共用メモリプール不足でサーバが開始しない場合は，次に示す対策をしてください。
pd_sds_shmpool_size，pd_dic_shmpool_size，及びpd_bes_shmpool_sizeオペランド省略時：
pd_assurance_table_noオペランド又はpd_assurance_index_noオペランドにcc....cc以上の値を指定して，再度実行してください。
pd_sds_shmpool_size，pd_dic_shmpool_size，又はpd_bes_shmpool_sizeオペランド指定時：
pd_sds_shmpool_size，pd_dic_shmpool_size，又はpd_bes_shmpool_sizeオペランドの値を大きくして，再度実行してください。
KFPH22005-E
Number of aa....aa exceeds limit bb....bb, current=cc....cc, server=dd....dd　　（Ｌ）
ユーザが定義aa....aaで指定した最大数bb....bbよりも，多くの実体があります。実体の数はcc....cc，発生サーバはdd....ddです。
aa....aa：指定したオペランド
{ pd_max_rdarea_no | pd_max_file_no }
bb....bb：aa....aaで指定した最大数
cc....cc：実体の数
dd....dd：サーバ名
(Ｓ)開始処理を中断します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]実在のRDエリア数が最大値を超えた場合は，システム共通定義のpd_max_rdarea_noオペランドの値を増やして，再度実行してください(pd_max_rdarea_noオペランドの値を増やした場合には，ステータスファイルの容量の見直しが必要です）。
実在のRDエリア構成ファイル数が最大値を超えた場合は，システム共通定義のpd_max_file_noオペランドの値を増やして，再度実行してください。
KFPH22006-E
UNIX file "aa....aa" failed, return code=bb....bb, file=cc....cc　　（Ｌ）
内部作業用のファイルcc....ccに対するaa....aaがリターンコードbb....bbで終了しました。
aa....aa：HiRDBファイルシステムの機能
{ open | close | lseek | read | write }
bb....bb：リターンコード
cc....cc：作業用のファイル名称
$PDDIR：HiRDB運用ディレクトリ
なお，作業用のファイルのパス名が131文字を超えると，HiRDB運用ディレクトリ名を「$PDDIR」に変換して出力します。
(Ｓ)処理を中断します。
[対策]「システム関連エラーの詳細コード」を参照して，エラーの原因を取り除き，再度実行してください。
なお，エラーの原因が判断できないときは，保守員に連絡してください。
KFPH22007-E
HiRDB System "aa....aa" failed, return code=bb....bb　　（Ｌ）
シングルサーバ（HiRDB/シングルサーバ），又はシステムマネジャ（HiRDB/パラレルサーバ）の機能aa....aaを実行するときに，リターンコードbb....bbで終了しました。
aa....aa：HiRDBシステムの機能
bb....bb：リターンコード
(Ｓ)処理を中断します。
[対策]「システム関連エラーの詳細コード」を参照し，エラーの原因を取り除き，再度実行してください。
なお，エラーの原因が判断できないときは，保守員に連絡してください。
KFPH22008-E
SORT program error occurred, code=aa....aa　　（Ｌ）
ソートプログラムでエラーが発生しました。
aa....aa：エラーコード
(Ｓ)処理を中断します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]マニュアル「ソートマージ」を参照し，エラーの原因を取り除き再度コマンドを実行してください。
KFPH22009-E
Unknown server name found in system, server=aa....aa, RDAREA="bb....bb"　　（Ｌ）
サーバ定義にないサーバ名aa....aaを発見しました。不当なサーバ名を検知したRDエリアはbb....bbです。
aa....aa：サーバ名
bb....bb：RDエリア名
(Ｓ)処理を中断します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]システム共通定義のpdstart　-tコマンドでサーバ種別を正しい構成に合わせてください。
KFPH22010-E
System call error occurred, func="aa....aa", errno=bb....bb　　（Ｌ）
システムコール中にエラーが発生しました。
aa....aa：システムコール名
****：システムコールを特定できません。
bb....bb：エラーコード
(Ｓ)リラン，ロールバック中の場合は処理を続行します。それ以外の場合は異常終了します。
[対策]エラーコード（errno：エラーの状態を表す外部整数変数）を調査し，errno.h又はユーザが使用するOSのマニュアルを参照してエラーの原因を取り除き，再度実行してください。
KFPH22011-E
System call error occurred, func="system", cmd="aa....aa", code=bb....bb, inf="cc....cc"　　（Ｌ）
system関数によって実行したコマンドで，エラーが発生しました。
aa....aa：コマンド名
bb....bb：シェル（Windows NTの場合はコマンド）の終了コード
cc....cc：コマンドのエラー出力情報
(Ｓ)異常終了します。
[対策]エラー出力情報とシェル（又はコマンド）の終了コードを基にユーザが使用しているOSのマニュアルを参照して，エラーの原因を取り除き，再度実行してください。
Windows NTの場合は，"cc....cc"に"*****"が表示されたときは，次に示すどちらかのファイルの内容からエラーの原因を取り除き，再度実行してください。
・$PDDIR/spool/pdrshs1.log
・$PDDIR/spool/pdrshs2.log
KFPH22012-W
Ignore number of aa....aa, assumed limit bb....bb, server=cc....cc　　（Ｌ）
HiRDBシステム定義のaa....aaオペランドを変更したが，HiRDBが再開始中のため，変更前の指定値bb....bbを仮定します。対象サーバはcc....ccです。
aa....aa：変更したオペランド
{ pd_max_rdarea_no | pd_max_file_no ｜ pd_inner_replica_control }
bb....bb：変更前の指定値
cc....cc：HiRDBサーバ名
(Ｓ)処理を続けます。これらのオペランドの変更値は次のHiRDB正常開始時に有効になります。
KFPH22013-E
RPC "aa....aa" failed, return code=bb....bb, server=cc....cc　　（Ｌ）
サーバcc....ccから発行したRPCの機能aa....aaが，エラーコードbb....bbで終了しました。
aa....aa：RPCの機能
bb....bb：エラーコード
cc....cc：サーバ識別子
(Ｓ)処理を終了します。
[対策]「RPC関連エラーの詳細コード」を参照して，エラーの原因を取り除き，再度実行してください。
KFPH22014-E
RDAREA "aa....aa" not found in dictionary server　　（Ｌ）
ディクショナリサーバに必要なRDエリアaa....aaがありません。
aa....aa：RDエリア名
*masterdirectory*：マスタディレクトリ
*datadirectory*：データディレクトリ
*datadictionary*：データディクショナリ
(Ｓ)異常終了します。
[対策]システム共通定義のディクショナリサーバを定義するpdstart文を正しい構成に合わせてください。該当するRDエリアが破壊されている場合，データを回復した後，再度実行してください。
KFPH22015-E
HiRDB file system area aa....aa not found, RDAREA="bb....bb"　　（Ｌ）
RDエリアbb....bbのHiRDBファイルシステム領域aa....aaがシステムにありません。
aa....aa：HiRDBファイルシステム領域名
HiRDBファイルシステム領域のパス名が118文字以上の場合は，HiRDBファイルシステム領域のパス名の後ろから117文字を出力します。
bb....bb：RDエリア名
(Ｓ)処理を終了します。
[対策]エラーがあったHiRDBファイルシステム領域を作成し，RDエリアを回復した後，再度RDエリアをオープンしてください。
KFPH22016-E
MASTER DIRECTORY RDAREA was already used　　（Ｌ）
マスタディレクトリ用RDエリアが他HiRDBシステムで既に使用中です。
(Ｓ)異常終了します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]システム共通定義での，マスタディレクトリ用RDエリアの先頭のHiRDBファイル名称が同じHiRDBシステムを同時に起動できません。システム共通定義を再度確認して再起動してください。
KFPH22017-I
Table should be reorganized, RDAREA="aa....aa", AUTHID=bb....bb, TABLE=cc....cc because disordered LOB DIRECTORY　　（Ｌ）
LOB用RDエリア内の管理情報が乱れ始めました。
aa....aa：RDエリア名
bb....bb：認可識別子
cc....cc：表識別子
(Ｓ)処理を続行します。
[対策]
〈該当するRDエリアがユーザLOB用RDエリアの場合〉
LOBデータに対する検索性能が劣化することがあります。メッセージに出力されたユーザLOB用RDエリアを再編成してください。
〈該当するRDエリアがデータディクショナリLOB用RDエリアの場合〉
ストアドプロシジャ，及びストアドファンクションに関するディクショナリ表を再編成してください。
〈該当するRDエリアがレジストリLOB用RDエリアの場合〉
レジストリ表を再編成してください。
KFPH22018-W
Status file "aa....aa" failed, return code=bb....bb, server=cc....cc　　（Ｌ）
サーバcc....ccのステータスファイルに対するaa....aaがリターンコードbb....bbで終了しました。
aa....aa：ファイルアクセス機能
{ alloc | dealloc | read | write }
bb....bb：エラーコード
cc....cc：サーバ識別子
(Ｓ)ステータスファイルを使用して済ませる処理を暫定的にディクショナリサーバへ問合せて，処理を続行します。なお，ディクショナリサーバへ問い合わせるため，ステータスファイルを使用するときよりも開始処理の性能が低下します。
[対策]今後の運用に備え，ステータスファイルを正常化しておく必要があります。「システム関連エラーの詳細コード」を参照し，エラーの原因を取り除いてください。なお，原因が分からない場合，保守員に連絡してください。
KFPH22019-I
Information type=aa....aa detail="bb....bb" code=cc....cc　　（Ｌ）
種別aa....aa，詳細bb....bb，リターンコードcc....cc，の事象が発生しました。
aa....aa：情報の種別
bb....bb：内部情報
cc....cc：内部コード
(Ｓ)エラーが発生しましたが，システム内で対応できるため，処理を続行します。
KFPH22020-W
Server aa....aa waiting until dictionary server start　　（Ｌ）
バックエンドサーバaa....aaの開始処理にディクショナリサーバが必要です。このため，ディクショナリサーバが起動されるのを待ちます。
aa....aa：サーバ識別子
(Ｓ)ディクショナリサーバの状態を監視します。
〈起動された場合〉
処理を続行します。
〈一定時間内に起動の確認ができない場合〉
ディクショナリサーバの起動を確認しないで，処理を続行します。
[対策]
（1）　ディクショナリサーバ又はディクショナリサーバがあるサーバマシンを起動してください。
（2）　ネットワーク障害が考えられる場合は，障害の要因を取り除いてください。
KFPH22021-W
Number of index exceeds reserved number, current reserved number=aa....aa, server=bb....bb　　（Ｌ）
インデクス定義数が，インデクス予約数を超えました。現在のインデクス予約数はaa....aa，発生サーバはbb....bbです。
aa....aa：現在のインデクス予約数
bb....bb：サーバ名称
(Ｓ)処理を続行します。ただし，このメッセージ出力以降は，インデクスによっては，次に示す運用上有利な効果が生じなくなります。
・インデクス管理情報のメモリ常駐化による性能の向上
・インデクスに関する統計情報の取得
・既報済みのメッセージの重複出力の抑止
[対策](Ｓ)に示した効果が必要な場合は，システムを再度起動してください。
また，必要に応じて次に示す処置をしてください。
〈現在定義済みのインデクス数に次回のサーバの正常開始から終了までの間に定義するインデクスの数を加えた値が，現在定義済みのインデクス数の1.2倍を超える場合〉
システム共通定義のpd_assurance_index_noの値を変更，又は設定する必要があります。
〈メッセージのaa....aa(現在のインデクス予約数)が既にpd_assurance_index_noの指定値を超えている場合〉
インデクス予約数は既に自動的に増加した値となっているため，pd_assurance_index_noに指定する値は，aa....aa(現在のインデクス予約数)を超える値にする必要があります。
KFPH22022-E
RDAREA information build failed, reason code = Time out.　　（Ｌ）
バックエンドサーバの開始処理でRDエリアの情報取得時，タイムアウトが発生しました。
ディクショナリサーバが起動していないか，又はディクショナリサーバの負荷が高いため，RDエリア情報の取得に時間が掛かっているおそれがあります。
(Ｓ)異常終了します。
[対策]次のどちらかの対策をしてください。
・ディクショナリサーバが起動していない場合，ディクショナリサーバを起動した後，再度このサーバを起動してください。
・ディクショナリサーバの負荷が高い場合，ディクショナリサーバの負荷が下がった後，再度このサーバを起動してください。
KFPH22023-W
Using resource for "aa....aa" reached bb....bb%, cc....cc　　（Ｌ）
aa....aaの使用率がbb....bb％に達しました
aa....aa：リソースの種別
rdarea-list-no：サーバ内のリスト作成可能数
bb....bb：警告値
cc....cc：付加情報
次の形式で出力されます。
サーバ内のリスト作成数／サーバ内のリスト作成可能数，server=サーバ名
(Ｓ)処理を続行します。
[対策]不要なリストを削除するか，又はリスト用RDエリアを追加してください。
KFPH22024-I
Extension completed in RDAREA "aa....aa",FILE "bb....bb",ccccc(dd....dd) segments created　　（Ｌ）
RDエリアaa....aaのHiRDBファイルbb....bbをcccccセグメント増分しました。総セグメント数はdd....ddです。
aa....aa：RDエリア名
bb....bb：HiRDBファイルシステム領域名/HiRDBファイル名
HiRDBファイルのパス名が113文字以上の場合は，HiRDBファイルのパス名の後ろから112文字を出力します。
ccccc：増分したセグメント数
dd....dd：総セグメント数
(Ｓ)処理を続行します。
KFPH22025-E
Error occurred while Extension,RDAREA "aa....aa",FILE "bb....bb",reason code ccccc　　（Ｌ）
RDエリアaa....aaのHiRDBファイルbb....bbの自動増分処理中にエラーが発生しました。理由コードはcccccです。
aa....aa：RDエリア名
bb....bb：HiRDBファイルシステム領域名/HiRDBファイル名
HiRDBファイルのパス名が122文字以上の場合は，HiRDBファイルのパス名の後ろから121文字を出力します。
ccccc：理由コード
(Ｓ)処理を続行します。
[対策]「HiRDBファイルシステムに対するアクセス要求から返されるエラーコード」を参照して，エラーの原因を取り除いてください。
KFPH22026-E
Auto extend function suppressed,RDAREA "aa....aa",FILE "bb....bb",reason code ccccc　　（Ｌ）
RDエリアaa....aaのHiRDBファイルbb....bbの自動増分機能を抑止します。理由コードはcccccです。
aa....aa：RDエリア名
bb....bb：HiRDBファイルシステム領域名/HiRDBファイル名
HiRDBファイルのパス名が120文字以上の場合は，HiRDBファイルのパス名の後ろから119文字を出力します。
ccccc：理由コード
-1556：HiRDBファイルのエクステントが上限値を超えました。
1：RDエリアaa....aaが更新可能バックアップ閉塞状態です。
上記以外：増分セグメント部分の初期設定でエラーが発生しました。
(Ｓ)次の契機まで，該当するRDエリアの自動増分機能は抑止されます。
・HiRDB起動時
・RDエリアの閉塞解除コマンド実行時
・RDエリアのオープンコマンド実行時
・データベース構成変更ユティリティのRDエリアの再初期化実行時，又はRDエリアの拡張実行時
[対策]理由コードを参照してエラーの原因を取り除き，RDエリアの自動増分機能の抑止を解除してください。
理由コード-1556の場合：
次のどちらかの方法で対策します。
・該当するHiRDBファイルがあるHiRDBファイルシステム領域のエクステントを統合する。
・データベース構成変更ユティリティでRDエリアを拡張する。
理由コード1の場合：
該当するRDエリアに対して，pdrelsコマンドを実行してください。
上記以外の理由コードの場合：
「HiRDBファイルシステムに対するアクセス要求から返されるエラーコード」を参照して，エラーの原因を取り除いてください。
KFPH22027-E
Number of aa....aa exceeds limit bb....bb,current=cc....cc,server=dd....dd　　（Ｌ）
インナレプリカグループの数が，システム定義のaa....aaオペランドで指定した値bb....bbを超えています。インナレプリカグループの数はcc....cc，発生元のHiRDBサーバはdd....ddです。
aa....aa：HiRDBシステム定義のオペランド名
・pd_inner_replica_control
bb....bb：aa....aaオペランドの値
cc....cc：現在のインナレプリカグループ数
dd....dd：HiRDBサーバ名
(Ｓ)HiRDBの開始処理を中断します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]pd_inner_replica_controlオペランドに現在のインナレプリカグループ数以上の値を指定して，HiRDBを開始してください。
KFPH22028-E
Staticizer Option required　　（Ｌ）
インナレプリカ機能を使用するにはHiRDB Staticizer Optionが必要です。
(Ｓ)処理を終了します。
[対策]インナレプリカ機能を使用する場合は，HiRDB Staticizer Optionをインストールしてください。
KFPH22029-E
RDAREA aa....aa last file freezed, file=bb....bb fileNO=cc　　（Ｌ）
RDエリアaa....aaの最終HiRDBファイルbb....bb，ファイル番号ccが更新凍結状態のため，RDエリアの自動増分は指定できません。
aa....aa：RDエリア名
bb....bb：HiRDBファイルシステム領域名/HiRDBファイル名
HiRDBファイルのパス名が132文字以上の場合は，HiRDBファイルのパス名の後ろから131文字を出力します。
cc：HiRDBファイル番号
(Ｓ)処理を終了します。
[対策]容量を拡張する場合は，RDエリアの拡張をしてください。
KFPH22030-W
Number of table exceeds reserved number,current reserved number=aa....aa,server=bb....bb,RDAREA="cc....cc",AUTHID="dd....dd",TABLE="ee....ee"　　（Ｌ）
サーバbb....bbのRDエリアcc....ccの認可識別子dd....dd，表ee....eeの処理で，表定義数が表予約数を超えました。
このメッセージ出力以降は，表によっては空き領域の再利用機能が有効に適用されない場合があります。
aa....aa：現在の表予約数
bb....bb：サーバ名称
cc....cc：RDエリア名称
dd....dd：認可識別子
ee....ee：表名称
(Ｓ)処理を続行します。
(Ｐ)次のどちらかの処置をしてください。
・空き領域の再利用機能適用中の表から，空き領域の再利用が不要な表はALTER TABLE文でSEGMENT REUSE NOを指定して空き領域の再利用を中止してください。
・HiRDBを停止させ，システム共通定義のpd_assurance_table_noの値を変更，又は設定してから再起動してください。
KFPH22031-W
No reuse area,RDAREA="aa....aa",AUTHID="bb....bb",TABLE="cc....cc"　　（Ｌ）
RDエリアaa....aaの認可識別子bb....bb，表cc....ccで空き領域の再利用機能を実行しましたが，空き領域がありませんでした。
aa....aa：RDエリア名称
bb....bb：認可識別子
cc....cc：表名称
(Ｓ)処理を続行します。
(Ｐ)次のどれかの処置をしてください。
・DELETEを実行して空き領域を作成してください。
・ALTER TABLE文のSEGMENT REUSE指定でセグメント数を定義し直してください。
・ALTER TABLE文でSEGMENT REUSE NOを指定して空き領域の再利用を中止してください。
KFPH22032-W
Processing of SQL skipped,tableID=aa....aa,generation number=bb,server=cc....cc　　（Ｌ＋Ｓ）
世代番号bb，サーバcc....ccの処理対象RDエリアがすべてコマンド閉塞かつクローズ状態のため，定義更新処理をスキップしました。
aa....aa：定義系SQLの対象表の番号，又は定義系SQLの対象インデクスが定義されている表の番号
表定義（CREATE TABLE）の場合は********が表示されます。
bb：世代番号
cc....cc：サーバ名
(Ｓ)処理を続行します。
[対策]定義系SQLが正常に終了している場合，定義系SQLの更新処理がスキップされたRDエリアを，オリジナルRDエリアのある世代（世代番号0），又はカレントRDエリアのある世代から複製し直してください。
KFPH22033-E
Not available without specification of aa....aa operand　　（Ｌ）
共用RDエリアを使用している場合，aa....aaオペランドの値をYにしてください。
aa....aa：pd_shared_rdarea_use
(Ｓ)開始処理を中断します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]システム共通定義のpd_shared_rdarea_useオペランドにYを指定して，再度実行してください。
KFPH23001-E
No "pdbuffer" statements　　（Ｌ）
システム共通定義にpdbufferオペランドがありません。
(Ｓ)異常終了します。
[対策]システム共通定義にpdbufferオペランドを追加してください。
KFPH23002-E
Invalid "pdbuffer" statement due to aa....aa bb....bb　　（Ｌ）
pdbufferオペランドの不正を検出しました。
aa....aa：エラーの要因
duplicate buffer pool name：バッファプール名称が重複しています。
duplicate RDAREA：RDエリアが重複しています。
invalid index name：インデクス名称が不正です。
bb....bb：RDエリア名，インデクス名，又はバッファプール名
(Ｓ)異常終了します。
[対策]システム共通定義のpdbufferオペランドを修正してください。
KFPH23003-E
Insufficient memory on PROCESS, size=aa....aa　　（Ｌ）
サーバの起動時に，プロセス固有領域のメモリが不足しました。
aa....aa：確保しようとした領域サイズ（単位：バイト）
(Ｓ)異常終了します。
[対策]プロセス数などを見直して，再度HiRDBを起動してください。又はスワップ領域を大きくしてください。
KFPH23004-E
Insufficient memory on DYNAMIC_SHMPOOL for global buffer pool,size=aa....aa　　（Ｌ）
グローバルバッファプールを使用するための共用メモリが不足しています。
aa....aa：確保しようとした領域サイズ（単位：バイト）
(Ｓ)異常終了します。
[対策]swapinfoで仮想メモリの状態を調べて，不足の場合はスワップ領域を大きくするか，又はグローバルバッファプール数若しくはバッファ面数を減らします。不足していない場合はOSのsamコマンドでshmmniを大きくして，OSをリブートします。
Windows NTの場合，HiRDBをインストールしたドライブに十分な空き容量があるかを確認してください。空き容量が少ない場合は，不要なファイルを削除するなどの対処をして，空き容量を増やしてください。十分空きがある場合は，仮想メモリの指定値及び実メモリが不足する状態ではないかどうかを確認してください。又は，起動しているが必要のないプログラムを終了させてください。もし，仮想メモリに拡張が必要であれば，拡張してください。この時，仮想メモリの指定値は，初期値と最大値を同じに指定してください。
KFPH23005-E
Failed to allocate global buffer pool, errno=aa....aa　　（Ｌ）
グローバルバッファの割り当てに失敗しました。
aa....aa：エラーの要因コード
4：共用メモリのページ固定に失敗しました。
8：HiRDBの内部資源不足が発生しました。
16：共用メモリセグメント数が上限値を超えました。
20：メモリ不足が発生しました。
24：共用メモリのセグメントサイズが上限値を超えました。
28：グローバルバッファ数が上限値を超えました。
32：共用メモリサイズの計算でけたあふれが発生しました。
36：共用メモリ識別子の数が上限値を超えました。
(Ｓ)異常終了します。
[対策]エラーの要因コードに従って，処置してください。
４：共用メモリセグメントをページ固定するための実メモリが不足しています。
エラーが発生したサーバのsyslogfile（Windows NTの場合はイベントログ）を参照して次に示すどちらかの処置をしてください。
・KFPO00107-E "shmctl(ommfixed)" failed errno=1が出力されている場合
$PDDIR/bin下にあるコマンドが不当にモード変更されている可能性があります。いったんpdsetup -dコマンドでHiRDBをOSから削除した後，再度pdsetupコマンドを実行してください。
Windows NTの場合，%PDDIR%\bin下にあるコマンドが不当にモード変更されている可能性があります。関連するメッセージを調査して，エラーの要因を取り除いてから，HiRDBを再度起動してください。
・KFPO00107-E "shmctl(ommfixed)" failed errno=12が出力されている場合
共用メモリをページ固定したい場合は，次に示すどちらかの処置をしてください。
・実メモリを増やしてください。
・エラーが発生したサーバに定義したグローバルバッファ数又はバッファ面数を減らして，共用メモリサイズを小さくしてください。
共用メモリをページ固定する必要がない場合は，pd_dbbuff_attribute=freeを指定してください。
ただし，pdasyncコマンドで並列入出力機能を使用している場合は，無条件にページ固定するのでpdasyncコマンドで並列入出力機能を止める必要があります。
８：HiRDBが管理できる共用メモリセグメント数は最大16ですが，これを超えています。次に示すどちらかの処置をしてください。
・システム共通定義又はユニット制御情報定義のSHMMAXオペランドの指定値を大きくしてください。
この場合，OSのsamコマンドでOSのオペレーティングシステムパラメタ（カーネルパラメタ）のshmmaxの値をSHMMAXオペランドの指定値以上にしてください。shmmaxの変更後はOSのリブートが必要です。
・エラーが発生したサーバに定義したグローバルバッファ数又はバッファ面数を減らして，共用メモリセグメント数が16以下になるようにしてください。
16：OSのsamコマンドでOSのオペレーティングシステムパラメタ（カーネルパラメタ）のshmsegの値を大きくしてください。shmsegの変更後はOSのリブートが必要です。
20：スワップ領域を増やすか，プロセス数又はユニット内サーバ数などを減らしてください。
24：グローバルバッファ用共用メモリサイズがOSのオペレーティングシステムパラメタのshmmax指定値を超えたか，又はシステム定義のSHMMAXオペランドの指定値を超えました。shmmax指定値，及びシステム定義のSHMMAXオペランドの指定値を，見積もったグローバルバッファ用共用メモリサイズ以上の値となるように設定してください。shmmaxの指定値は，OSのsamコマンドで変更できます。また，shmmaxを変更した後は，OSのリブートが必要です。
Windows NT版の場合，グローバルバッファ用共用メモリサイズがシステム定義のSHMMAXオペランドの指定値を超えました。システム定義のSHMMAXオペランドの指定値を，見積もったグローバルバッファ用共用メモリサイズ以上の値となるように設定してください。SHMMAXオペランドの指定値を超えていない場合は，HiRDB稼働中にHiRDBのインストールディレクトリ下の作業ファイルを削除した可能性があります。この場合，HiRDBのサービスを再度起動してください。
28：対策は次のとおりです。
・32ビットモードの場合
１サーバ内で定義できるグローバルバッファ数の上限値は500ですが，この上限値を超えています。グローバルバッファ数を減らしてください。
・64ビットモードの場合
１サーバ内で定義できるグローバルバッファ数の上限値は1000ですが，この上限値を超えています。グローバルバッファ数を減らしてください。
32：対策は次のとおりです。
・32ビットモードの場合
共用メモリのサイズ計算でけたあふれが発生しました。エラーが発生したサーバに定義しているグローバルバッファ数又はバッファ面数を減らし，共用メモリサイズが231－１以下になるようにしてください。
・64ビットモードの場合
共用メモリのサイズ計算でけたあふれが発生しました。エラーが発生したサーバに定義しているグローバルバッファ数又はバッファ面数を減らし，共用メモリサイズが263－１以下になるようにしてください。
36：OSのsamコマンドでOSのオペレーティングシステムパラメタ（カーネルパラメタ）のshmmniの値を大きくしてください。shmmniの変更後はOSのリブートが必要です。
KFPH23006-E
Failed to allocate semaphore, errno=aa....aa　　（Ｌ）
セマフォ資源の割り当てに失敗しました。
aa....aa：エラーの要因コード
4：1セマフォ識別子当たりのセマフォ数がシステムの上限値を超えました。
8：システム全体で使用しているセマフォ数又はセマフォ識別子数がシステムの上限値を超えました。
(Ｓ)異常終了します。
[対策]エラーの要因コードに従って対処してください。
４：オペレーティングシステムパラメタの1セマフォ識別子当たりのセマフォ数上限値（Solarisの場合はseminfo_semmsl，Linuxの場合はSEMMSL）を64以上に設定してください。
８：次に示すどれかの処置をしてください。
・システム内セマフォ数上限値（HP-UXの場合はsemmns，Solarisの場合はseminfo_semmns，Linuxの場合はSEMMNS）を大きくしてください。
・セマフォ識別子数の上限値（HP-UXの場合はsemmni，Solarisの場合はseminfo_semmni，Linuxの場合はSEMMNI，Windows NTの場合はPDUXPLSEMMAX）を大きくしてください。
・pdbufferオペランドの指定数を減らしてください。
・pd_max_usersオペランドの値を小さくしてください。
KFPH23007-E
File aa....aa bb....bb error　　（Ｌ）
ファイルのアクセスに失敗しました。
aa....aa：ファイル名
ファイル名は絶対パスで表示し，160文字以上の場合はファイルパス名の後ろから159文字を出力します。
bb....bb：ファイルアクセス機能
close：ファイルのクローズ
create：ファイルの作成
open：ファイルのオープン
read：ファイルからの読み込み
write：ファイルへの書き込み
(Ｓ)異常終了します。
[対策]このメッセージの直前に出力されたKFPO00107-Eメッセージに従って，処置してください。
KFPH23008-W
No file "pdbufenv"　　（Ｌ）
シングルサーバ（HiRDB/シングルサーバ），又はディクショナリサーバ（HiRDB/パラレルサーバ）の起動時に作成した"pdbufenv"ファイルがありません。
(Ｓ)処理を続行します。
[対策]pdbufferオペランドの指定に従って，システムが該当するファイルを再作成します。したがって，バッファ構成が前回と異なる場合，リラン回復対象RDエリアに，バッファが割り当たらない指定であると，該当するRDエリアは，閉塞状態になります。この場合，データベース回復ユティリティを使用してRDエリアを回復してください。
KFPH23009-E
System call error func=aa....aa, errno=bb....bb　　（Ｌ）
システムコールでエラーが発生しました。
aa....aa：システムコール名
bb....bb：errnoにセットされたエラー番号
(Ｓ)異常終了します。
[対策]errno（エラーの状態を表す外部整数関数）を調査して，errno.h及びユーザが使用しているOSのマニュアルを参照して，エラーの原因を取り除き，再度HiRDBを起動してください。
KFPH23010-E
Insufficient memory on PROCESS for work I/O buffer, size=aa....aa　　（Ｌ）
プロセス固有領域が不足したため，一括入出力用バッファが確保できません。
aa....aa：確保しようとした領域サイズ（単位：バイト）
(Ｓ)処理を終了します。
[対策]一括入出力ページ数を小さくしてから，再度データベース作成ユティリティ又はデータベース再編成ユティリティを実行してください。
KFPH23011-W
Invalid SHMMAX statement due to aa....aa bb....bb　　（Ｌ）
システム共通定義，又はユニット制御情報定義のSHMMAXオペランドが不正です。
aa....aa：エラーの要因
out of range：指定値の範囲外です。
no value：数値ではありません。
bb....bb：指定値（先頭から30文字まで表示します）
(Ｓ)共用メモリのセグメントサイズの上限を6MB（メガバイト）として処理を続行します。
[対策]サーバ内のグローバルバッファプールサイズの総和が6MBを超える場合は，共用メモリのセグメントを複数確保するのでスループット低下の原因となります。
SHMMAXオペランドを正しく設定し直してください。
KFPH23012-E
No necessary option for "pdbuffer" aa....aa　　（Ｌ）
pdbufferオペランドの指定に，必要なオプション指定がありません。
aa....aa：必要なオプション名
(Ｓ)異常終了します。
[対策]必要なオプションを指定し，再度HiRDBを起動してください。
KFPH23013-W
Failed to allocate index buffer pool aa....aa due to DATA DICTIONARY search failed SQLCODE = bbbb　　（Ｌ）
ディクショナリの検索に失敗したため，インデクス専用のグローバルバッファプールを割り当てられません。
aa....aa：バッファプール名称
bbbb：SQLコード
(Ｓ)インデクス専用のグローバルバッファプールを作らないで処理を続行します。そのインデクス格納RDエリアにバッファプール定義があれば，そのバッファプールを使用します。バッファプール定義がない場合は，OTHER用（pdbuffer -o指定）バッファプールの定義があれば，そのバッファプールを使用します。
[対策]インデクス専用のグローバルバッファプールが必要な場合は，直前に出力されたSQLメッセージに従って処置し，再度HiRDBを起動してください。
KFPH23014-W
Failed to allocate index buffer pool aa....aa due to no index bb....bb　　（Ｌ）
pdbufferオペランドで指定したインデクスがないため，インデクス専用のグローバルバッファプールを割り当てられません。
aa....aa：バッファプール名称
bb....bb：インデクス名称
(Ｓ)インデクス専用のグローバルバッファプールを作成しないで，処理を続行します。そのインデクス格納RDエリアにバッファプール定義があれば，そのバッファプールを使用します。バッファプール定義がない場合は，OTHER用（pdbuffer -o指定）バッファプールの定義があれば，そのバッファプールを使用します。
[対策]指定したインデクスが削除されている場合は，該当するインデクスに対応する定義をpdbufferオペランドから削除してください。指定したインデクス名が誤っている場合は，pdbufferオペランドを正しく修正し，再度HiRDBを起動してください。
KFPH23015-E
System error, func "aa....aa", code=bbbbbb　　（Ｌ）
HiRDBの関数でエラーが発生しました。
aa....aa：関数名称
bbbbbb：エラーコード
(Ｓ)異常終了します。
[対策]syslogfile（Windows NT版の場合はイベントログ），又はメッセージログファイルから，このメッセージの前後に出力されているメッセージがあるか確認してください。メッセージがある場合は，そのメッセージの処置に従ってください。メッセージがない場合は，bbbbbbを「システム関連エラーの詳細コード」から探して，エラーの原因を取り除き，再度HiRDBを開始してください。なお，エラーの原因が判断できないときは，保守員に連絡してください。
KFPH23016-E
Invalid "pdbuffer" statement due to operand combination error, global buffer pool name = aa....aa　　（Ｌ）
pdbufferオペランドで背反するオプションを指定しています。
aa....aa：バッファプール名称
(Ｓ)異常終了します。
[対策]システム共通定義に指定したpdbufferオペランドで背反するオプション（-r，-i，-o）を一つのpdbufferオペランドの中に指定しています。-r，-i，及び-oは，それぞれ別のpdbufferオペランドで指定するように変更してください。
KFPH23017-W
Invalid "pdbuffer" statement due to no RDAREA aa....aa　　（Ｌ）
pdbufferオペランドの-rで指定したRDエリアが，HiRDBシステムにありません。
aa....aa：RDエリア名
(Ｓ)処理を続行します。
[対策]システム共通定義のpdbufferオペランドを正しく修正してください。
KFPH23018-W
Failed to allocate global buffer pool aa....aa due to page size exceeds buffer size for RDAREA bb....bb　　（Ｌ）
グローバルバッファのサイズよりRDエリアのページサイズが大きいため，グローバルバッファプールを割り当てることができません。
aa....aa：グローバルバッファプール名称
bb....bb：RDエリア名称
(Ｓ)このRDエリアに対するグローバルバッファプールを割り当てないで，処理を続行します。
(Ｏ)このRDエリアにアクセスしたい場合は，システム共通定義のpdbuffer文の-lオプションで指定するバッファサイズを大きくするか，又は-lオプションを削除した後，HiRDBを再度起動します。
KFPH23019-W
Global buffer pool shared memory fixed due to parallel I/O function included　　（Ｌ）
並列入出力機能を組み込んでいるため，グローバルバッファプールの共用メモリをページ固定にしました（システム共通定義又はユニット制御情報定義のpd_dbbuff_attribute=free指定を無視します）。
(Ｓ)処理を続行します。
(Ｏ)グローバルバッファプールの共用メモリをページ固定にしたくない場合は，pdasyncコマンドで並列入出力機能を削除してください。削除後，OSをリブートして，再度HiRDBを起動してください。
KFPH23020-E
Failed to allocate LOB buffer pool aa....aa due to invalid RDAREA type bb....bb　　（Ｅ）
LOB用RDエリア以外に，LOB用グローバルバッファを割り当てられません。
aa....aa：グローバルバッファプール名称
bb....bb：RDエリア名称
(Ｓ)異常終了します。
[対策]システム共通定義のpdbufferオペランドにLOB用RDエリアを指定してください。
KFPH23021-E
Unmatched global buffer definition(standby=aa....aa,current=bb....bb)　　（Ｌ）
グローバルバッファの定義が待機系と実行系で不一致です。このメッセージは次に示す条件をすべて満たす場合に出力されます。
・待機系が待機状態のときに実行系のグローバルバッファの定義を変更した
・実行系の単独停止再開始後，待機系を再起動しないで実行系に切り替わった
aa....aa：保守情報1
bb....bb：保守情報2
(Ｓ)異常終了します。
[対策]HiRDBを再度開始してください。
KFPH23022-E
Global buffer pool undefined in standby server,RDAREA="aa....aa" standby unit=bbbb standby server=cc....cc　　（Ｌ）
代替BESのRDエリアにグローバルバッファが定義されていません。
aa....aa：RDエリア名
bbbb：代替BESユニットのユニット識別子
cc....cc：代替BES名
(Ｓ)異常終了します。
[対策]pdbufferオペランドの-cオプション又は-oオプションで代替BESが使用するグローバルバッファを割り当ててください。その後，HiRDBを開始してください。
KFPH23023-I
Unit is down because pd_db_io_error_action=unitdown　　（Ｌ）
pd_db_io_error_actionオペランドにunitdownを指定している場合に，RDエリアの入出力エラーが発生したため，HiRDB（HiRDB/パラレルサーバの場合はユニット）を異常終了します。
(Ｓ)異常終了します。
[対策]直前に出力されるKFPH22003-E又はKFPH23100-Eメッセージを参照して入出力エラーの要因を取り除いてください。
KFPH23024-I
pd_db_io_error_action=unitdown is ineffective　　（Ｌ）
pd_db_io_error_actionオペランドにunitdownを指定している場合に，HiRDB（HiRDB/パラレルサーバの場合はユニット）の異常終了後に再度入出力エラーが発生したため，そのRDエリアを障害閉塞します。
(Ｓ)処理を続行します。
KFPH23025-E
Insufficient memory on PROCESS for work I/O buffer,size=aa....aa　　（Ｌ）
プロセス固有領域が不足したため，ランダムアクセス用ローカルバッファが確保できませんでした。
aa....aa：確保しようとした領域サイズ（単位：バイト）
(Ｓ)処理を終了します。
[対策]ランダムアクセス用ローカルバッファ面数を小さくしてから，再度pdload又はpdrorgを実行してください。
KFPH23026-E
Insufficient memory on PROCESS,size=aa....aa　　（Ｌ）
ローカルバッファ環境作成時に，プロセス固有領域のメモリが不足しました。
aa....aa：確保しようとした領域サイズ（単位：バイト）
(Ｓ)処理を終了します。
[対策]プロセス数などを見直して，再度pdload又はpdrorgを実行してください。
KFPH23027-W
Undefined global buffer pool with '-c' option,RDAREA="aa....aa"　　（Ｌ）
-cオプション指定のグローバルバッファプールが定義されていません。
aa....aa：RDエリア名
(Ｓ)RDエリアをクローズ状態にして処理を続行します。
[対策]影響分散スタンバイレス型系切り替え機能の適用ユニットのRDエリアには-cオプション指定のグローバルバッファを割り当てる必要があります。システム共通定義のpdbufferオペランドに-cオプションを指定し，未割り当てのRDエリアにグローバルバッファプールを割り当ててください。
KFPH23028-W
Too small '-o' option global buffer size,added RDAREA="aa....aa",global buffer size=bbbbb,page size=ccccc　　（Ｌ）
-oオプション指定のグローバルバッファのバッファサイズbb...bbが，追加したRDエリアaa....aaのページ長cc...ccより小さいです。
aa....aa：RDエリア名
bbbbb：グローバルバッファのバッファサイズ
ccccc：追加したRDエリアのページ長
(Ｓ)処理を続行します。
(Ｏ)RDエリアaa....aaに-oオプション指定のグローバルバッファを割り当てる場合は，必ずpdstopコマンドでHiRDBを正常停止又は計画停止してからHiRDBを再開始してグローバルバッファを割り当ててください。pdstop -uコマンドでユニットを停止してから再開始してグローバルバッファを割り当てた場合，ほかのユニットの-oオプション指定のグローバルバッファと，バッファサイズが異なるため，系切り替え時にRDエリア閉塞となることがあるので注意してください。
KFPH23100-E
HiRDB file aa....aa error,errno=bb....bb, HiRDB file name=cc....cc　　（Ｌ）
HiRDBファイルに対するアクセスでエラーが発生しました。
aa....aa：HiRDBファイル機能
close：HiRDBファイルクローズ
open：HiRDBファイルオープン
read：HiRDBファイルからの読み込み
write：HiRDBファイルへの書き込み
bb....bb：HiRDBシステムのエラーコード
cc....cc：HiRDBファイルシステム領域名/HiRDBファイル名
HiRDBファイルシステム領域名が132文字以上の場合は，HiRDBファイルシステム領域名の後ろから131文字を出力します。
(Ｓ)処理を終了します。
[対策]「HiRDBファイルシステムに対するアクセス要求から返されるエラーコード」を参照し，エラーの原因を取り除いてください。RDエリアが閉塞しているときは，データベース回復ユティリティで，該当するRDエリアを回復してください。
KFPH23101-E
DB destruction information, requst=(rdid=aa....aa, pgid=bb....bb, pgno=cc....cc, fno=dd....dd), buff=(pgid=ee....ee, pgno=ff....ff, fno=gg....gg)　　（Ｌ）
バッファ不正時の保守情報を出力します。
aa....aa：要求先のRDエリアID
bb....bb：要求先の表番号又はインデクス番号
cc....cc：要求先ページ番号
dd....dd：要求先ファイル番号
ee....ee：バッファ内の表番号又はインデクス番号
ff....ff：バッファ内のページ番号
gg....gg：バッファ内のファイル番号
(Ｓ)RDエリアを閉塞します。
[対策]保守員に連絡してください。閉塞したRDエリアはデータベース回復ユティリティで回復してください。
KFPH23200-W
Unable to use parallel I/O function aa....aa, code=bbbbb　　（Ｌ）
並列入出力機能が利用できません。このため，デファードライト処理のディスク並列書き込みができません。
なお，HI-UX/WE2版以外のHiRDBを御使用の場合は，並列入出力機能がないため，このメッセージが出力されます。HiRDBが並列入出力機能を使用しないだけなので，特に問題はありません。
aa....aa：利用できない状況
at some buffer pool：一部のグローバルバッファプールで並列入出力機能を利用できません。
at all buffer pool：すべてのグローバルバッファプールで並列入出力機能を利用できません。
bbbbb：エラーコード
-1530：ノード内で利用できる最大数を超えました。
-1540：並列入出力機能を利用できる権限がありません。
-1558：並列入出力機能が組み込まれていません。
(Ｓ)処理を続行します。
[対策]エラーコードに従って対策してください。
-1530：サーバ数を減らしてください。又は，システム共通定義のpdbufferオペランドでバッファ面数を減らしてください。
-1540，-1558：並列入出力機能を利用する場合は，HiRDBを停止させた後，pdasyncコマンドを実行してください。その後，OSを起動してHiRDBを起動してください。なお，並列入出力機能をインストールするには，32Mバイト以上の実メモリが必要です。
KFPH23201-W
HiRDB file open retry due to insufficient open resource, code=aaaaa　　（Ｌ）
HiRDBファイルのオープン処理で資源不足となったため，HiRDBファイルのオープンを再試行します。
aaaaa：HiRDBシステムのエラーコード
(Ｓ)処理を続行します。
[対策]「HiRDBファイルシステムに対するアクセス要求から返されるエラーコード」を参照し，エラーの原因を取り除いてください。
KFPH23202-W
HiRDB DB read retry due to time stamp invalid, RDAREA name=aa....aa, file name=bb....bb, offset=cc....cc　　（Ｌ）
ページ内タイムスタンプが不正であるため，データベースからの読み込みを再試行します。
aa....aa：RDエリア名
bb....bb：HiRDBファイル名
HiRDBファイル名が92文字以上の場合は，HiRDBファイル名の後ろから91文字を出力します。
cc....cc：タイムスタンプが不正であるページの，HiRDBファイルの先頭からの相対バイト位置。10進数で表示します。
(Ｓ)処理を続行します。
(Ｏ)このメッセージが出力された直後，RDエリアが閉塞した場合は保守員に連絡してください。$PDDIR/spool下に簡易ダンプが出力されるので，それを保管してください。
このメッセージが出力された直後，RDエリアが閉塞しない場合は，一時的なディスクI/O障害が発生しています。メッセージ中に表示されたHiRDBファイルがあるディスクを調査してください。
[対策]保守員に連絡してください。$PDDIR/spool下に簡易ダンプが出力されるので資料を保管してください。
KFPH24003-E
Invalid "pd_plugin_ixmk_dir" statement, errno=aaaaa, directory or HiRDB file system=bb....bb　　（Ｌ）
システム定義のpd_plugin_ixmk_dirオペランドに指定した内容でエラーが発生しました。
aaaaa：HiRDBファイルシステムのエラーコード
bb....bb：pd_plugin_ixmk_dirオペランドに指定した内容
121文字以上の場合は，後ろから120文字を出力します。
(Ｓ)処理を続行します。
(O)HiRDB管理者に連絡してください。
[対策]HiRDBを正常停止してください。その後，「HiRDBファイルシステムに対するアクセス要求から返されるエラーコード」を参照し，エラーの要因を取り除いてHiRDBを開始してください。
エラーコードが－1538の場合，HiRDBファイルシステム領域ではない通常ファイル，又はキャラクタ型スペシャルファイルを指定しています。この場合，HiRDBファイルシステム領域，又はディレクトリ名を指定してください。
KFPH24004-I
pd_redo_allpage_put information=(Server=aa....aa,SKIP=bb....bb,APPLY=cc....cc,WRITE=dd....dd,BFPUT=ee....ee)　　（Ｌ）
pd_redo_allpage_putオペランドを指定したときの，サーバaa....aaでの全面回復処理のデータベース書き出しに関する内部情報を表示します。
aa....aa：サーバ名
bb....bb：データベースに書き出し済みのため，ロールフォワードをスキップした更新ログ数
cc....cc：データベースに未書き出しのため，ロールフォワードした更新ログ数
dd....dd：全面回復処理中に発生した実WRITE回数
ee....ee：内部情報
(Ｓ)処理を続行します。
KFPH25000-E
Error occurred on aa....aa(bbbb), code=ccccc(dd....dd)　　（Ｌ）
aa....aa（bbbb）で，コードcccccのエラーが発生しました。
aa....aa：エラーが発生した処理
bbbb：エラーが発生した処理の詳細コード
ccccc：エラーのコード
dd....dd：エラーの詳細コード
(Ｓ)〈HiRDB再開始時〉
処理を続行します。
〈トランザクションのロールバック時〉
異常終了します。
[対策]このメッセージの後に出力されるKFPH00306-Eメッセージ（閉塞メッセージ）に示されたRDエリアをデータベース回復ユティリティで回復し，埋め込み文字の内容を保守員に連絡してください。
KFPH25001-E
Error occured on aa....aa(bbbb), code=cc(dd....dd)　　（Ｌ）
aa....aa（bbbb）でコードccのエラーが発生しました。
aa....aa：エラーを発生した処理
bbbb：エラーを発生した処理の詳細コード
cc：エラーのコード
dd....dd：エラーの詳細コード
(Ｓ)異常終了します。
[対策]このメッセージの後に出力されるKFPH00306-Eメッセージに示されたRDエリアをデータベース回復ユティリティで回復し，埋め込み文字の内容を保守員に連絡してください。
KFPH25002-E
Transaction wait time over,RDAREA=aa....aa,INDEX=bb....bb　　（Ｌ）
インデクスの空きページの解放処理中に，同時実行トランザクション決着待ち時間に指定した待ち時間を超えました。
aa....aa：RDエリア名
bb....bb：インデクス名
(Ｓ)処理を終了します。
(Ｐ)空きページ解放ユティリティ（pdreclaim）を再度実行してください。長時間アクセスするトランザクションがある場合，そのトランザクションが終了してから，再度実行してください。又は，同時実行トランザクション決着待ち時間を大きくしてください。
KFPH25100-I
Index information file assigned,file=aa....aa,index=bb....bb.cc....cc,RDAREA=dd....dd　　（Ｌ）
RDエリアdd....ddに格納されているインデクスbb....bb.cc....ccのインデクス情報ファイルを作成しました。ファイル名称はaa....aaです。
aa....aa：インデクス情報ファイル名
bb....bb：認可識別子
cc....cc：プラグインインデクスのインデクス識別子
dd....dd：次に示すどちらかの情報が表示されます。
・プラグインインデクス格納RDエリア名
・プラグインインデクス格納RDエリア名（レプリカRDエリア世代番号）
HiRDB Staticizer Optionを使用している場合，プラグインインデクス格納RDエリアがレプリカRDエリアのときは，プラグインインデクス格納オリジナルRDエリア名とレプリカRDエリアの世代番号を出力します。
(Ｓ)処理を続行します。
KFPH25101-E
Index information file aa....aa error, file name=bb....bb kind=cc....cc index inf=dd....dd errno=ee....ee　　（Ｌ）
インデクス情報ファイルの作成又は更新時に，インデクス情報ファイルに対する処理aa....aaに失敗しました。
aa....aa：エラー種別
bb....bb：インデクス情報ファイルの名称
インデクス情報ファイルの名称が100文字を超えている場合，ファイル名称の後ろから100文字を出力します。
cc....cc：エラー情報｛0｜1｜2｝
dd....dd：インデクス情報｛0｜1｝
ee....ee：エラーコード
HiRDBファイルシステム領域でエラーが発生した場合は，HiRDBファイルシステム領域のエラーコードが表示されます。HiRDBファイルシステム領域のエラーコードについては，「HiRDBファイルシステムに対するアクセス要求から返されるエラーコード」を参照してください。この場合，cc....ccで表示されたエラー情報は無効になります。
(Ｓ)ロールバック中の場合は処理を続行します。ロールバック中でない場合は，トランザクションを無効にします。
[対策]エラー情報，インデクス情報の順に対策してください。
●エラー情報
0の場合：
エラーコード（エラーの状態を表す外部整数変数）を基に，errno.h及びOSのマニュアルを参照してエラーの要因を調査し，次のエラー要因に従って対策してください。
エラーの要因
意味
対策
ENOSPC
インデクス情報ファイルがあるディレクトリに空きがなくなりました。
該当するディレクトリから不要なファイルを削除してください。
1の場合：
インデクス情報ファイルがあるディレクトリに空きがなくなりました。該当するディレクトリから不要なファイルを削除してください。
2の場合：
レコードの途中まで読み込みました。保守員に連絡してください。
●インデクス情報
0の場合：
UAPを再実行してください。
1の場合：
インデクスを再作成してください。
KFPH26000-E
Error occurred on aa....aa(bbbb),code=ccccccc(dddddddd)　　（Ｌ）
aa....aa（bbbb）でコードcccccccのエラーを検知しました。
aa....aa：エラーを検知した処理
bbbb：エラーを検知した処理の詳細コード
ccccccc：エラーのコード
dddddddd：エラーの詳細コード
(Ｓ)異常終了します。
[対策]エラーの内容を保守員に連絡してください。
KFPH26001-I
Information=aa....aa　　（Ｌ）
内部情報aa....aaを出力します。
aa....aa：内部情報
(Ｓ)処理を続行します。
[対策]このメッセージが出力された後，システムが異常終了したときは，保守員に連絡してください。
KFPH26010-I
Start to assign used page, because pdload used up new pages in RDAREA "aa....aa", table_id="bb....bb"　　（Ｌ）
表IDbb....bbのデータロードでRDエリアaa....aaの新規ページを使い切ったため，未使用領域へのデータの格納を開始します。
aa....aa：RDエリア名称
bb....bb：表ID
(Ｓ)処理を続行します。
(Ｏ)表のデータ件数からRDエリアの容量を見直して，データベース再編成ユティリティ（pdrorg）で表の再編成をしてください。
KFPH27000-E
System error, func "aa....aa", code = bbbb　　（Ｌ）
HiRDBシステムの関数で，エラーが発生しました。
aa....aa：関数名称
bbbb：エラーコード
(Ｓ)処理を終了します。
[対策]「システム関連エラーの詳細コード」を参照して，エラーの原因を取り除き，再度コマンドを実行してください。なお，エラーの原因が判断できないときは，保守員に連絡してください。
KFPH27003-E
System call error, func = aaaaaa, errno = bbbb　　（Ｌ）
HI-UX/WE2のシステム関数でエラーが発生しました。
aaaaaa：システム関数名
bbbb：errnoの値
(Ｓ)処理を終了します。
[対策]errnoの値を基に，エラーの原因を取り除き，再度コマンドを実行してください。
KFPH27004-E
Work file open failed, aa....aa　　（Ｌ）
作業用ファイルのオープンエラーが発生しました。
aa....aa：エラーの原因
errno = bbbb：エラーコードbbbbが発生しました。
no such file：ファイルがありません。
permission denied：ディレクトリに書き込み権限がありません。
(Ｓ)処理を終了します。
[対策]$PDDIR/tmp下に作成されるファイルを参照して，エラーの原因を取り除き，再度コマンドを実行してください。
KFPH27005-E
Insufficient memory on PROCESS, size = aa....aa　　（Ｌ）
プロセス固有領域を確保しようとしました。しかし，メモリが不足したため，確保できません。
aa....aa：確保しようとした領域サイズ
(Ｓ)処理を終了します。
(Ｏ)プロセス数を見直して，再度コマンドを実行してください。
KFPH27006-E
DATA DICTIONARY RDAREA information get error　　（Ｌ）
データディクショナリ用RDエリアの情報を取得するときに，エラーが発生しました。
(Ｓ)処理を終了します。
(Ｏ)このメッセージの前後に出力されるメッセージログを参照して，エラーの要因を取り除き，再度コマンドを実行してください。
KFPH27007-E
HiRDB file system information get error, code = aaaaa, area = bb....bb　　（Ｌ）
HiRDBファイルシステム領域の情報を取得するときに，エラーが発生しました。
aaaaa：エラーコード
bb....bb：HiRDBファイルシステム領域名
HiRDBファイルシステム領域のパス名が118文字以上の場合は，HiRDBファイルシステム領域のパス名の後ろから117文字を出力します。
(Ｓ)該当するRDエリアの処理を無効にして，処理を続行します。
[対策]「HiRDBファイルシステムに対するアクセス要求から返されるエラーコード」を参照してエラーの原因を取り除き，再度コマンドを実行してください。
KFPH27008-E
aa....aa command failed due to DATA DICTIONQRY RDAREA(bb....bb) status invalid, RDAREA = cc....cc　　（Ｌ＋Ｓ）
データディクショナリ用RDエリアbb....bbを参照できないため，指定されたRDエリアcc....ccのデータベース運用コマンドaa....aaが処理できません。
aa....aa：コマンド名称
bb....bb：データディクショナリ用RDエリア名称
cc....cc：RDエリア名称（RDエリア名称が取得できない場合は*****が表示されます）
(Ｓ)該当するRDエリアの処理を無効にして，処理を続行します。
(Ｏ)データディクショナリ用RDエリアの状態を正しくしてから，再度コマンドを実行してください。
KFPH27009-E
SORT program error occurred, code = aaaa　　（Ｌ）
ソートプログラムでエラーが発生しました。
aaaa：エラーコード
(Ｓ)処理を終了します。
[対策]マニュアル「ソートマージ」を参照して，エラーの原因を取り除き，再度コマンドを実行してください。
KFPH27010-E
Unable to send message from aa....aa to bb....bb　　（Ｌ）
ホストaa....aaとホストbb....bb間で，通信エラーが発生しました。
aa....aa：送信元ホスト名
bb....bb：送信先ホスト名
系切り替え機能を使用している場合は，現用系のホスト名となります。
(Ｓ)処理を終了します。
[対策]このメッセージの前に出力されたKFPH27000-Eメッセージの処置に従ってください。ただし，物理的な通信エラーが発生していない場合は，システム定義でホスト間の関係に矛盾があると考えられます。このため，エラーが発生したホスト間の定義を見直して再度実行してください。
KFPH27011-E
aa....aa command failed due to data dictionary RDAREA(bb....bb) status invalid, buffer pool = cc....cc　　（Ｌ）
データディクショナリ用RDエリアbb....bbが参照できないため，指定されたバッファプールcc....ccのコマンドaa....aaの処理ができません。
aa....aa：コマンド名称
bb....bb：データディクショナリ用RDエリア名称
cc....cc：バッファプール名
(Ｓ)バッファプール名の場合は，該当するバッファプールの処理を無効にして，処理を続行します。
[対策]データディクショナリ用RDエリアが障害閉塞中の場合は，障害の要因を取り除いて，再度コマンドを実行します。クローズ中の場合は，クローズを解除してから再度コマンドを実行してください。
KFPH27012-I
Usage: pdbufls [-k sts|def|all] [-d]
{[-s server_name[,server_name]...]|[-a buffer_pool_name[,buffer_pool_name]...]}　　（Ｓ）
グローバルバッファプールの状態を表示するコマンド(pdbufls)の使用方法を示します。コマンドオプション，又は引数が誤っている場合に出力します。
(Ｓ)処理を終了します。
[対策]コマンドの形式を修正してコマンドを再度実行してください。
KFPH27013-I
Usage: pddbchg -q n {-r ORIGINAL_RDAREA [, ORIGINAL_RDAREA ]|-r ALL} [-w]　　（Ｓ）
カレントRDエリアを変更するpddbchgコマンドの使用方法を示します。このメッセージはコマンドオプション，又は引数が誤っている場合に出力されます。
(Ｓ)処理を終了します。
[対策]コマンドの形式を修正してコマンドを再度実行してください。
KFPH27014-E
No original rdarea named aa....aa[, server = bb....bb]　　（Ｌ＋Ｓ）
指定したRDエリアはオリジナル用RDエリアではありません。
aa....aa：RDエリア名
bb....bb：共用RDエリアの実行サーバ名
共用RDエリアでエラーが発生した場合に表示されます。
(Ｓ)次に示すどれかの処理をします。
・pddbchgコマンドの場合は，指定されたすべてのRDエリアに対する処理をしないでコマンドを終了します。
・pddblsコマンドの場合は，該当RDエリアに対する処理を無効にして処理を続行します。
・pdorbeginコマンドの場合
・-r RDエリア名一括指定の場合は，該当RDエリアに対する処理を無効にし，処理を続行します。
・-r RDエリア名称指定の場合は，指定されたすべてのRDエリアに対する処理をしないで，処理を終了します。
[対策]オリジナルRDエリア名を指定して，コマンドを再度実行してください。
KFPH27015-E
aa....aa command failed, RDAREA = bb....bb,code = ccc[, server = dd....dd]　　（Ｌ＋Ｓ）
pddbchgコマンドの処理ができません。
aa....aa：コマンド名
bb....bb：RDエリア名
ccc：エラーコード
－30：指定されたRDエリアに排他を掛けられません。
－31：ディクリョナリ表とバックエンドサーバのメモリの情報が一致しません。
－32：マスタディレクトリの情報を更新できません。
－33：ディクショナリ表を更新できません。
－34：システム関数でエラーが発生しました。
dd....dd：共用RDエリアの実行サーバ名
共用RDエリアでエラーが発生した場合に表示されます。
(Ｓ)処理を終了します。
[対策]エラーコードに従って対策してください。
・－30の場合
ほかのトランザクション（サーバ名が表示されている場合は，該当するサーバでのほかのトランザクション）の終了後にコマンドを再度実行してください。又はインナレプリカ内の対象RDエリアをすべて閉塞した後にコマンドを再度実行してください。また，オンライン再編成閉塞となっているRDエリアがある場合，pddbchgコマンドは実行できません。pdorchgコマンド実行前はpdorbeginコマンド，pdorchgコマンド実行後はpdorendコマンドでオンライン再編成閉塞を解除し，その後にコマンドを再度実行してください。
・－31の場合
システム用RDエリアの運用に誤りがないか確認してください。誤りがない場合は保守員に連絡してください。
・上記以外の場合
このメッセージの前に出力されているメッセージを確認して原因を取り除いてください。サーバ名が表示されている場合は，このメッセージの前に出力されているメッセージを確認して該当するサーバでの原因を取り除いてください。原因が不明な場合は保守員に連絡してください。
KFPH27016-E
No specified generation RDAREA=aa....aa　　（Ｌ＋Ｓ）
指定した世代のRDエリアがありません。
aa....aa：RDエリア名
(Ｓ)処理を終了します。
[対策]データベース構成変更ユティリティのreplicate rdarea文で世代指定のRDエリアを作成した後にコマンドを再度実行してください。
KFPH27017-W
replica status changed though MASTER DIRECTORY invalid　　（Ｌ＋Ｓ）
マスタディレクトリ用RDエリアのカレント情報が不正ですが，レプリカステータスを更新しました。
(Ｓ)処理を続行します。
KFPH27018-W
pddbchg command not available without Staticizer Option　　（Ｌ＋Ｓ）
pddbchgコマンドを実行するにはHiRDB Staticizer Optionが必要です。
(Ｓ)処理を終了します。
[対策]HiRDB Staticizer Optionが利用できる環境か確認してください。必要であれば，HiRDB Staticizer Optionをインストールしてください。
KFPH27023-E
specified option not available without Staticizer Option　　（Ｌ＋Ｓ）
指定したオプションにはHiRDB Staticizer Optionが必要です。
(Ｓ)処理を終了します。
[対策]HiRDB Staticizer Optionが利用できる環境か確認してください。必要であれば，HiRDB Staticizer Optionをインストールしてください。
KFPH27024-I
HiRDB file freezed, file=aa....aa　　（Ｌ＋Ｓ）
HiRDBファイルaa....aaを更新凍結状態にしました。
aa....aa：HiRDBファイル名
(Ｓ)処理を終了します。
KFPH27025-I
Usage:pddbfrz [-d] {-r RDAREA[,RDAREA]|-r ALL} [-q generation_number]　　（Ｓ）
pddbfrzコマンドの形式を示します。このメッセージは，コマンドの指定方法が誤っている場合に出力されます。
(Ｓ)処理を終了します。
[対策]コマンドの指定を修正して，再度実行してください。
KFPH27026-I
HiRDB file freeze skipped, file=aa....aa, reason=bb....bb　　（Ｌ＋Ｓ）
HiRDBファイルaa....aaの更新凍結処理は，bb....bbの理由によってスキップされました。
aa....aa：HiRDBファイル名
bb....bb：理由コード
topfile：RDエリアを構成する先頭ファイルです。
already：既に更新凍結状態です。
plug-in：プラグインの論理ファイルがあります。
unused：未割り当てセグメントがあります。
(Ｓ)処理を続行します。
KFPH27027-E
RDAREA freeze failed, RDAREA=aa....aa　　（Ｌ）
指定したRDエリアは，プラグインインデクスを格納しているRDエリア，又は未使用のRDエリアのため，更新凍結できません。
aa....aa：RDエリア名
(Ｓ)該当するRDエリアの処理を無効にして，処理を続行します。
[対策]RDエリアを指定し直して，再度実行してください。
KFPH27028-E
File copy failed, server name = aa....aa, return code = bbbb　　（Ｌ）
高速系切り替え機能使用時，実行系から待機系へのHiRDBのデータベース環境情報ファイルのコピーに失敗しました。
aa....aa：サーバ名
bbbb：リターンコード
(Ｓ)処理を終了します。
[対策]リターンコードに対応する対策をしてください。
リターン
コード
原因と対策
100
リモートシェルを実行できる環境ではありません。リモートシェルを実行できる環境であるか確認してください。
IPアドレスを引き継がない系切り替え構成で，HAモニタ（又はHitachi Toolkit Extension）のserver定義文中にlan_updownが指定されていません。また，/opt/hitachi/HAmon/etc/ディレクトリ下にHAモニタ（又はHitachi Toolkit Extension）のservers定義文で指定したサーバ識別名と同じ名称の「サーバ識別名.up」及び「サーバ識別名.down」というネットワークのup/downシェルがあるため，待機系サーバの起動時にネットワークがダウンしました。
IPアドレスを引き継がない系切り替え構成のユニットの場合には，「サーバ識別名.up」及び「サーバ識別名.down」シェルを削除してください。
101
タイムアウトが発生しました。pd_system_complete_wait_timeオペランドの値を見直した後に待機系ユニットを開始してください。
102
予備系で起動中の待機系ユニットからHiRDBデータベース環境情報ファイルをコピーしようとしました。実行系ユニットが正常に起動しているか確認してください。実行系ユニットが正常に起動していない場合は，Hitachi HA Toolkit Extensionのサービスプロセスが起動していることを確認し，現用系と予備系のどちらかを実行系ユニットとして起動してください。実行系ユニットが起動完了した後に待機系ユニットを起動してください。実行系ユニットが正常に起動している場合は保守員に連絡してください。
上記以外
保守員に連絡してください。
KFPH27030-E
pdhold command required specification of -q option　　（Ｌ＋Ｓ）
pdholdコマンドで-r ALL及び-sオプションを指定した場合，-qオプションも指定する必要があります。
(Ｓ)処理を終了します。
[対策]コマンドの形式を修正して，再度実行してください。
KFPH27031-E
Failed to allocate global buffer pool,server=aa....aa,size=bb....bb,errno=cc　　（Ｌ+Ｓ）
グローバルバッファの割り当てに失敗しました。
aa....aa：サーバ名
bb....bb：確保しようとした領域サイズ（計算でけたあふれの場合は0が表示されます）
cc：エラー要因コード
(Ｓ)処理を終了します。
[対策]エラー要因コードに従って対策してください。対策後にpdbufmodコマンドを再実行してください。
エラー
要因
コード
エラーの内容
対策
4
共用メモリのページ固定に失敗しました。
共用メモリセグメントをページ固定するための実メモリが不足しています。不要なグローバルバッファがある場合は削除してください。
8
共用メモリセグメント数がHiRDBの上限値を超えました。
HiRDBで追加可能な共用メモリセグメント数は1サーバ当たり500個（64ビットモードの場合は1,000個）です。この上限値を超えています。不要なグローバルバッファがある場合は削除してください。また，動的変更したグローバルバッファの定義をpdbufferオペランドに反映してください。これによって，HiRDBが管理する共用メモリセグメント数を減らせます。
16
共用メモリセグメント数がOSの上限値を超えました。
プロセスで追加できる共用メモリセグメント数がOSのオペレーティングシステムパラメタshmsegの値を超えました。不要なグローバルバッファがある場合は削除してください。
20
メモリ不足が発生しました。
グローバルバッファのバッファ面数を減らせる場合は減らしてください。不要なグローバルバッファがある場合は削除してください。
24
共用メモリのセグメントサイズが上限値を超えました。
グローバルバッファ用の共用メモリサイズがOSのオペレーティングシステムパラメタshmmaxの値を超えたか，又はSHMMAXオペランドの値を超えました。グローバルバッファのバッファ面数を減らせる場合は減らしてください。
28
グローバルバッファ数が上限値を超えました。
１サーバ内に定義できるグローバルバッファ数の上限は500個（64ビットモードの場合は1,000個）です。この上限値を超えています。不要なグローバルバッファがある場合は削除してください。
32
共用メモリサイズの計算でけたあふれが発生しました。
グローバルバッファのバッファ面数を減らして共用メモリサイズが231－1（64ビットモードの場合は263－1）以下になるようにしてください。
36
共用メモリ識別子数が上限値を超えました。
共用メモリ識別子の数がOSのオペレーティングシステムパラメタshmmniの値を超えました。不要なグローバルバッファがある場合は削除してください。
KFPH27032-E
Global buffer pool already allocated,global buffer pool name=aa....aa　　（Ｌ+Ｓ）
グローバルバッファは割り当て済みです。
aa....aa：グローバルバッファ名
(Ｓ)処理を終了します。
[対策]既に使用されているグローバルバッファ名をpdbufls -k defコマンドで確認してください。ユニークなグローバルバッファ名を指定してpdbufmodコマンドを再実行してください。
KFPH27033-I
Usage: pdbufmod -k {add|del|upd} -a pool name [{-r RDAREA[,RDAREA ...]|-b RDAREA[,RDAREA ...]|-i ID.INDEXNAME|-o}] [-n NUM [-l SIZE]] [-m PRMAX] [-p PRNUM] [-w WRATIO]　　（Ｓ）
pdbufmodコマンドの使用方法を示します。コマンドオプション又は引数が間違っている場合にこのメッセージを出力します。
(Ｓ)処理を終了します。
[対策]指定形式を修正してコマンドを再実行してください。
KFPH27034-E
Unable to execute pdbufmod command, server=aa....aa　　（Ｌ+Ｓ）
次に示す理由のためpdbufmodコマンドを実行できません。
・高速系切り替え機能を使用している
・スタンバイレス型系切り替え機能を使用している
・pd_dbbuff_modifyオペランドを省略しているか，又はNを指定している
aa....aa：サーバ名
(Ｓ)処理を続行します。
[対策]高速系切り替え機能又はスタンバイレス型系切り替え機能を使用している場合は，オンライン中のシステム構成変更機能を使用してpdbufferオペランドの指定を変更してください（グローバルバッファの定義を変更してください）。
高速系切り替え機能又はスタンバイレス型系切り替え機能を使用していない場合は，pd_dbbuff_modifyオペランドにYを指定してください。
KFPH27035-I
Usage: pdorbegin {-r ORIGINAL_RDARERA[,ORIGINAL_RDARERA...] ｜-t [AUTHID.]TABLE[-s server[,server...]]}　[-w LOCK_WAIT_TIME] [-q GENERATION_NUMBER] [-u]
pdorbegin {-r ORIGINAL_RDARERA[,ORIGINAL_RDARERA...] ｜-t [AUTHID.]TABLE} [-s server[,server...]] [-w LOCK_WAIT_TIME] [-q GENERATION_NUMBER] -u　　（Ｌ＋Ｓ）
pdorbeginコマンドの指定形式です。
(Ｓ)処理を終了します。
[対策]指定形式及び対象RDエリアを129個以上指定していないかを確認し，再度実行してください。
KFPH27036-I
Usage: pdorchg [-s server[,server...]]　　（Ｌ＋Ｓ）
pdorchgコマンドの指定形式です。
(Ｓ)処理を終了します。
[対策]指定形式を確認し，再度実行してください。
KFPH27037-I
Usage: pdorend [-s server[,server...]] {[-n RETRY_COUNT] [-w MAX_REFLECT_WAIT_TIME] [-t MAX_TRN_WAIT_TIME] [-m REF_PROCESS_CNT] [-z] [-f reflection control file]| [-u]}　　（Ｌ＋Ｓ）
pdorendコマンドの指定形式です。
(Ｓ)処理を終了します。
[対策]指定形式を確認し，再度実行してください。
KFPH27038-E
Not available without aa....aa option, command = bb....bb　　（Ｌ＋Ｓ）
aa....aaオプションが組み込まれていないため，bb....bbコマンドを実行できません。
aa....aa：オプションの名称
Staticizer
bb....bb：コマンドの名称
｛pdorbegin｜pdorchg｜pdorend｝
(Ｓ)処理を終了します。
[対策]オプションを組み込んでから，再度実行してください。
KFPH27039-E
Not available without specification of aa....aa operand, command = bb....bb　　（Ｌ＋Ｓ）
システム定義のaa....aaオペランドを指定していないため，bb....bbコマンドを実行できません。
aa....aa：システム定義のオペランド名
｛pd_inner_replica_control｜pd_max_reflect_process_count｝
bb....bb：コマンドの名称
｛pdorbegin｜pdorchg｜pdorend｝
(Ｓ)処理を終了します。
[対策]HiRDBを終了して，システム定義のaa....aaオペランドを追加してから，HiRDBを再開始してください。その後，コマンドを再度実行してください。
KFPH27040-I
Reflection completed, server = aa....aa　　（Ｌ＋Ｓ）
該当するサーバの追い付き反映処理が完了しました。
aa....aa：サーバ名
(Ｓ)処理を続行します。
KFPH27041-W
Reflection retry, server = aa....aa, count = bb, code = cccc, wait_time = dddd　　（Ｌ＋Ｓ）
サーバaa....aaで追い付き反映処理をリトライします。
aa....aa：サーバ名
bb：リトライ回数
cccc：理由コード
lock：排他を掛けるときのタイムアウト
sync：排他を掛けた後の追い付き反映処理のタイムアウト
dddd：排他待ち時間（秒）
(Ｓ)処理を続行します。
(Ｏ)追い付き反映処理が繰り返しリトライとなって異常終了する場合は，次のどれかの対策をして，再度pdorendコマンドを実行してください。
・-nオプションの指定値を大きくする。
・-wオプションの指定値を大きくする。
・-tオプションの指定値を大きくする。
上記の対策をしても異常終了する場合は，トランザクション処理量を抑えてpdorendコマンドを実行してください。
KFPH27042-W
No held(org) RDAREA, command = aa....aa　　（Ｌ＋Ｓ）
更新可能なオンライン再編成ができるRDエリアがありません。
aa....aa：コマンド名
｛pdorchg｜pdorend｝
(Ｓ)処理を終了します。
(Ｏ)更新可能なオンライン再編成の運用手順を確認してから，再度コマンドを実行してください。更新可能なオンライン再編成の運用手順については，マニュアル「インナレプリカ機能 HiRDB Staticizer Option Version 7」を参照してください。
KFPH27043-E
aa....aa command failed, server = bb....bb, code = ccc　　（Ｌ＋Ｓ）
aa....aaコマンドが，サーバbb....bbで失敗しました。
aa....aa：コマンド名
bb....bb：サーバ名
ccc：エラーコード
-50：追い付き反映処理の最大待ち時間を超えました。
-51：リトライ回数が指定値を超えました。
-52：オンライン再編成反映プロセスでエラーが発生しました。
-53：通信エラーが発生しました。
-54：該当するサーバは更新可能なオンライン再編成実行中です。
-55：更新可能なオンライン再編成のコマンドの実行順序が不正です。
-56：pdorchgコマンドが完了していない可能性があります。
-57：指定したオプション，又はRDエリア（表）が不正です。
(Ｓ)処理を終了します。
(Ｏ)
エラーコードが-50の場合：
追い付き反映処理の最大待ち時間の指定値を大きくするか，又はレプリカRDエリアに対するトランザクション量を抑えてから，再度コマンドを実行してください。
エラーコードが-51の場合：
次のどれかの対策をしてから，再度コマンドを実行してください。
・トランザクションの最大待ち時間の指定値を大きくする。
・リトライ回数を大きくする。
・レプリカRDエリアに対するトランザクション量を抑える。
エラーコードが-52の場合：
次のどちらかの対策をしてください。
・pdorendコマンドに-uオプションを指定していない場合，直前のエラーメッセージに従って対処してください。
・pdorendコマンドに-uオプションを指定している場合，該当するサーバ内の全RDエリアのオンライン再編成閉塞が解除されていれば，コマンドの再実行は不要です。RDエリアのステータスは，pddblsコマンドで確認できます。該当するサーバ内にオンライン再編成閉塞のRDエリアが一つでもある場合は，マニュアル「インナレプリカ機能 HiRDB Staticizer Option Version 7」の障害対策を参照して対処してください。
エラーコードが-54の場合：
先に実行したpdorendコマンドの終了を待ってから，再度コマンドを実行してください。
エラーコードが-55の場合：
pdorbegin，pdorchg，及びpdorendコマンドの実行順序を確認してください。実行順序が正しい場合は，pddblsコマンドでRDエリアのステータスが正しいか確認してください。
エラーコードが-56の場合：
正常終了していない場合は，対策してpdorchgコマンドを正常終了させてからpdorendコマンドを再度実行してください。正常終了している場合は，pdorendコマンド実行時に，pddbchgコマンド又はデータベース構成変更ユティリティが同時に実行された可能性があります。この場合は，pdorendコマンドを再度実行してください。
エラーコードが-57の場合：
・-uオプション指定なしの場合
処理対象のRDエリアがあるサーバに，既にオンライン再編成閉塞となっているRDエリア，又は表がないか確認してください。
・-uオプション指定ありの場合
-rオプションを指定している場合，オンライン再編成閉塞にしたときの-rオプションで指定したRDエリアの中から，解除するRDエリアを指定してください。
-tオプションを指定している場合，オンライン再編成閉塞にしたときの-tオプションで指定した表を指定してください。
エラーコードが上記以外の場合：
このメッセージの前に出力されているメッセージを確認し，エラー原因を取り除いて再度コマンドを実行してください。原因が分からない場合は保守員に連絡してください。
KFPH27044-I
aa....aa command started　　（Ｌ＋Ｓ）
aa....aaコマンドを開始しました。
aa....aa：コマンド名
｛pdorbegin｜pdorchg｜pdorend｝
(Ｓ)処理を続行します。
KFPH27045-I
aa....aa command ended, return code = bb　　（Ｌ＋Ｓ）
aa....aaコマンドが終了しました。
aa....aa：コマンド名
｛pdorbegin｜pdorchg｜pdorend｝
bb：リターンコード
0：正常終了
4：警告終了
8及び12：異常終了
(Ｓ)処理を終了します。
[対策]リターンコードが0以外の場合は，直前に出力されているメッセージの内容に従って対処してください。
KFPH27046-E
Refrection management table not found, command = aa....aa　　（Ｌ＋Ｓ）
追い付き状態管理表がありません。
aa....aa：コマンド名
｛pdorbegin｜pdorchg｜pdorend｝
(Ｓ)処理を終了します。
[対策]pdorcreateコマンドで追い付き状態管理表を作成してから，再度コマンドを実行してください。
KFPH27047-E
Reflection management table existed in RDAREA to hold(org), RDAREA = aa....aa　　（Ｌ＋Ｓ）
追い付き状態管理表が，更新可能なオンライン再編成で使用するRDエリアにあります。
aa....aa：RDエリア名
(Ｓ)処理を終了します。
[対策]追い付き状態管理表を削除して，新たに別のRDエリアに作成してください。
KFPH27048-E
Enter aa....aa command, due to incomplete operation, RDAREA = bb....bb, SERVER = cc....cc　　（Ｌ）
処理が完了していない運用コマンドがあります。
aa....aa：コマンド名｛pdorbegin｜pdorend｝
bb....bb：オリジナルRDエリア名（pdorendの場合は********が表示されます）
cc....cc：サーバ名（pdorbeginの場合は********が表示されます）
(Ｓ)処理を続行します。
[対策]表示されたRDエリア又はサーバを指定し，pdorbegin又はpdorendコマンドを再度実行してください。
KFPH27049-E
Another RDAREA of the same server already held(org),command = aa....aa,SERVER = bb....bb　　（Ｌ）
同一サーバ内のほかのRDエリアが既にオンライン再編成閉塞のため，コマンドが実行できません。
aa....aa：コマンド名（pdorbegin）
bb....bb：サーバ名
(Ｓ)処理を終了します。
[対策]同一サーバ内に更新可能なオンライン再編成状態のRDエリアを追加したい場合は，次の操作をしてください。
・pdorchgコマンド実行していない場合
既に更新可能なオンライン再編成閉塞状態となっているRDエリアに対して，pdorbeginコマンド(-u)を実行し，更新可能なオンライン再編成閉塞状態解除後に，再度pdorbeginコマンドを実行してください。
・pdorchgコマンド実行している場合
既に更新可能なオンライン再編成閉塞状態となっているRDエリアに対して，pdorendコマンド(-u)を実行し，更新可能なオンライン再編成閉塞状態を解除し，pddbchgコマンドでカレントRDエリア変更後に，再度pdorbeginコマンドを実行してください。
詳細については，マニュアル「インナレプリカ機能 HiRDB Staticizer Option Version 7」を参照してください。
KFPH27050-E
Unable to execute aa....aa command,RDAREA = bb....bb,reason = cc....cc　　（Ｌ）
cc....ccの理由によって，aa....aaコマンドが実行できません。
aa....aa：コマンド名（pdorbegin）
bb....bb：RDエリア名
cc....cc：理由
invalid RECOVERY type：LOB列格納用RDエリアの列回復制約がALLではありません。
(Ｓ)該当するRDエリアがあるサーバの処理を終了します。
[対策]次のどちらかの対処をしてから，再度実行してください。
・LOB列格納用RDエリアを，オンライン再編成閉塞にしない表格納用RDエリアに定義し直してください。
・LOB列格納用RDエリアのLOB列を含む表定義を削除してから，LOB列の列回復制約をすべてALLにして再度表定義をしてください。
KFPH27051-E
Number of RDAREA exceeds maximum value　　（Ｌ＋Ｓ）
処理できるRDエリアの上限値を超えました。
(Ｓ)処理を終了します。
[対策]pdorbeginコマンドで処理できるRDエリアの上限値は4,096個です。-rオプションで指定しているRDエリア一括指定を見直し，再度コマンドを実行してください。
KFPH27052-W
Shared RDAREA released hold(org), specified option "-s", server = aa....aa, RDAREA = bb....bb　　（Ｌ＋Ｓ）
共用RDエリアに対し，サーバaa....aaを指定してオンライン再編成閉塞を解除しています。
aa....aa：サーバ名
bb....bb：RDエリア名
(Ｓ)処理を続行します。
[対策]全バックエンドサーバを一括で処理できない要因を取り除いて，pddbls -mコマンドで全バックエンドサーバの共用RDエリアの閉塞状態を確認してください。その後，全バックエンドサーバの共用RDエリアのオンライン再編成閉塞を解除してください。
KFPH27053-E
Unable to use specified command option aa for bb....bb, command = cc....cc 　　（Ｌ＋Ｓ）
bb....bbに対して，コマンドcc....cc，オプションaaは指定できません。
aa：オプション名
-s
bb....bb：エラーの要因
shared RDAREA：共用RDエリア
RDAREA：共用RDエリア以外のRDエリア
shared table：共用表
cc....cc：RDエリア名
｛pdorbegin｜pdorchg｜pdorend｝
(Ｓ)処理を終了します。
[対策]エラーの要因に対応する次の処置をしてください。
エラーの要因がshared RDAREA，又はRDAREAの場合
・cc....ccがpdorbeginコマンドのとき
共用RDエリアと共用RDエリア以外のRDエリアを別々に実行してください。共用RDエリアは，-rオプションに共用RDエリアだけを指定し，コマンドを実行してください。共用RDエリア以外のRDエリアは，-rオプションに共用RDエリア以外のRDエリアを指定し，-sオプションを削除してコマンドを実行してください。RDエリアの共用種別はpddblsコマンドで確認してください。
・cc....ccがpdorchg，及びpdorendコマンドのとき
-sオプションを削除して，コマンドを実行してください。
エラーの要因がshared tableの場合
-sオプションを削除して，コマンドを再度実行してください。
KFPH27054-E
Transaction may not determine commit or rollback command=aa....aa 　　（Ｌ＋Ｓ）
トランザクションが通信障害などの障害発生のため，システムでコミット，又はロールバックができていない可能性があります。
aa.... aa：コマンド名
(Ｓ)処理を終了します。
[対策]実行したコマンドのトランザクションが残っていないことをpdls -d prcコマンドとpdls -d trnコマンドで確認してください。トランザクションが完結していない場合は，pdcancelコマンドでキャンセルした後再度コマンドを実行してください。
KFPH27055-E
aa....aa command failed,reason=bb....bb 　　（Ｌ＋Ｓ）
aa....aaコマンド実行中にエラーが発生しました。
aa.... aa：コマンド名
bb....bb：理由
ANALYZE FAILED：追い付き反映制御ファイルの解析処理でエラーが発生しました。
ANY BES FAILED：一つ以上のバックエンドサーバの処理でエラーが発生しました。
Auth_id INVALID：-tオプションの認可識別子の省略値が不正です。
SPECIFIED SERVER INVALID：-tオプションで指定した表に関連がないサーバを，-sオプションに指定しています。
(Ｓ)処理を終了します。
[対策]
bb....bbがAuth_id INVALIDの場合：環境変数PDUSERを設定，又は修正した後，再度コマンドを実行してください。
bb....bbがSPECIFIED SERVER INVALIDの場合：-tオプションで指定した表名に関連するサーバを-sオプションに指定して，再度コマンドを実行してください。表に関連するサーバはpdrdreflsコマンドで確認してください。
bb....bbがANY BES FAILEDの場合：
＜直前のKFPH00132-Eメッセージで，処理対象外サーバが表示されている場合＞
オンライン再編成処理を続行したい場合は，次のどちらかの処理を実行してください。
・KFPH00132-Eメッセージに表示されているサーバのエラー要因を取り除いて，再度コマンドを実行してください。
・pdorbeginコマンドを-ｔオプション指定（指定した表が共用表の場合は除く）で開始している場合には，処理対象サーバを-sオプションで指定して再度コマンドを実行してください。
＜上記以外の場合＞
直前に出力されているメッセージの内容に従って対策した後，再度コマンドを実行してください。
bb....bbが上記以外の場合：直前に出力されているメッセージの内容に従って対策した後，再度コマンドを実行してください。
KFPH27056-E
Warning occurred in reflect service,server=aa....aa　　（Ｌ＋Ｓ）
反映サービスから警告が返されました。
aa....aa：サーバ名
(Ｓ)処理を続行します。
[対策]このメッセージの前に出力されているKFPT01010-Wメッセージに従って対策してください。
KFPH27058-E
Unable to use specified command option aa for bb....bb, command=cc....cc, RDAREA name="dd....dd"　　（Ｌ＋Ｓ）
コマンドcc....ccの場合，bb....bbに対してaaオプションを指定できません。
aa：オプション名
-u
bb....bb：エラーの要因
shared RDAREA：共用RDエリア
cc....cc：コマンド名
pdhold
dd....dd：RDエリア名
(Ｓ)RDエリアdd....ddの処理を無効にして，処理を続行します。
[対策]aaオプションを削除して，コマンドを再度実行してください。
KFPH27100-E
Unable to aaaaaa global buffer pool due to bb....bb, RDAREA="cc....cc"　　（Ｌ＋Ｓ）
bb....bbの理由によってグローバルバッファを追加又は削除できません。
aaaaaa：処理内容
add：追加
delete：削除
bb....bb：理由
invalid RDAREA type：RDエリアの種別が不正
RDAREA cannot specified：RDエリア指定不可
cc....cc：RDエリア名
(Ｓ)処理を終了します。
[対策]RDエリアの種別不正の場合は，LOB用のグローバルバッファにLOB用以外のRDエリアを指定しています。正しいRDエリアを指定してpdbufmodコマンドを再実行してください。
RDエリア指定不可の場合は，インデクス用のグローバルバッファにRDエリアを指定しています。インデクス用のグローバルバッファにはRDエリアを指定できません。RDエリアを指定しないでpdbufmodコマンドを再実行してください。
KFPH27101-E
Too small buffer size, buffer size=aaaaa,RDAREA="bb....bb", page size=ccccc　　（Ｌ+Ｓ）
バッファサイズが小さいため，RDエリアbb....bbにグローバルバッファを割り当てられません。
aaaaa：バッファサイズ
bb....bb：RDエリア名
ccccc：RDエリアのページ長
(Ｓ)処理を終了します。
[対策]バッファサイズはRDエリアのページ長以上である必要があります。この条件を満たすようにグローバルバッファを割り当ててください。
KFPH27102-E
Invalid option is specified, reason code=aa　　（Ｌ+Ｓ）
pdbufmodコマンドのオプションの組み合わせに誤りがあります。
aa：理由コード
1：指定した変更種別では指定できないオプションを指定しています。
10：変更種別が追加（-k add）なのに，-r，-b，-i，又は-oオプションを指定していません。
11：変更種別が追加（-k add）で-nオプションを指定していないのに，-l，-m，-p，又は-wオプションを指定しています。
12：変更種別が追加（-k add）で-i又は-oオプションを指定しているのに，-nオプションを指定していません。
22：変更種別が変更（-k upd）なのに，変更するオプションが指定されていません。又は，同時実行最大プリフェッチ数が0の場合に-pオプションだけを指定しています。
40：LOB用グローバルバッファに-rオプションを指定しています。
41：LOB用グローバルバッファ以外のRDエリアに-bオプションを指定しています。
(Ｓ)処理を終了します。
[対策]正しいオプションを指定してpdbufmodコマンドを再度実行してください。
KFPH27103-I
Global buffer pool aaaaaaa,global buffer pool name=bb....bb, server=cc....cc　　（Ｌ+Ｓ）
指定したグローバルバッファを追加，削除，又は変更しました。
aaaaaaa：処理内容
added：グローバルバッファの追加
deleted：グローバルバッファの削除
updated：グローバルバッファの更新
bb....bb：グローバルバッファ名
cc....cc：サーバ名
(Ｓ)処理を続行します。
KFPH27104-I
RDAREA "aa....aa" bb....bb,global buffer pool name=cc....cc, server=dd....dd　　（Ｌ+Ｓ）
指定したRDエリアをグローバルバッファに割り当てました。又は指定したRDエリアをグローバルバッファから削除しました。
aa....aa：RDエリア名
bb....bb：処理内容
added：グローバルバッファへの割り当て
deleted：グローバルバッファからの削除
cc....cc：グローバルバッファ名
dd....dd：サーバ名
(Ｓ)処理を続行します。
KFPH27105-E
Unable to execute aa....aa command due to command in process　　（Ｌ+Ｓ）
aa....aaコマンドは処理中のため実行できません。
aa....aa：コマンド名（pdbufmod）
(Ｓ)処理を終了します。
[対策]実行中のコマンドの終了後にpdbufmodコマンドを再実行してください。
KFPH27106-E
Unable to execute aa....aa commnad due to specified index name not found　　（Ｌ+Ｓ）
指定したインデクスがないためaa....aaコマンドを実行できません。
aa....aa：コマンド名（pdbufmod）
(Ｓ)処理を終了します。
[対策]正しいインデクス名を指定してpdbufmodコマンドを再実行してください。
KFPH27107-E
aa....aa command failed due to DATA DICTIONARY RDAREA(bb....bb) status invalid, index = cc....cc　　（Ｌ+Ｓ）
データディクショナリ用RDエリアbb....bbを参照できないため，指定したインデクスcc....ccにaa....aaコマンドを実行できません。
aa....aa：コマンド名（pdbufmod）
bb....bb：データディクショナリ用RDエリア名
cc....cc：インデクス名
(Ｓ)この操作を無効にして処理を続行します。
[対策]データディクショナリ用RDエリアの状態が正常になった後にpdbufmodコマンドを再実行してください。
KFPH27108-E
Failed to allocate semaphore　　（Ｌ+Ｓ）
セマフォ資源の割り当てに失敗しました。
(Ｓ)処理を終了します。
[対策]次に示すことをしてから，pdbufmodコマンドを再実行してください。
・システム内セマフォ数の上限値（HP-UXの場合はsemmns，Solarisの場合はseminfo_semmns，Linuxの場合はSEMMNS）を大きくしてください。
・セマフォ識別子数の上限値（HP-UXの場合はsemmni，Solarisの場合はseminfo_semmni，Linuxの場合はSEMMNI，Windows NTの場合はPDUXPLSEMMAX）を大きくしてください。
・不要なグローバルバッファがある場合は削除してください。
KFPH27109-E
Unable to add aa....aa global buffer pool due to already allocated, global buffer pool name=bb....bb　　（Ｌ+Ｓ）
追加しようとしたグローバルバッファは使用中のため，インデクス用又は-oオプションのグローバルバッファを追加できませんでした。
aa....aa：グローバルバッファの種類
index：インデクス用グローバルバッファ
other：-oオプションのグローバルバッファ
bb....bb：グローバルバッファ名
(Ｓ)処理を終了します。
[対策]pdbufls -k defコマンドで使用中のグローバルバッファを確認して，必要に応じてコマンドを再実行してください。
KFPH27110-E
Unable to add global buffer pool due to no RDAREA　　（Ｌ+Ｓ）
割り当てるRDエリアがないため，グローバルバッファを追加できません。
(Ｓ)処理を終了します。
[対策]pdbufls -k defコマンドで使用中のグローバルバッファを確認して，必要に応じてコマンドを再実行してください。
KFPH27111-E
Unable to delete due to no RDAREA ”aa....aa”, global buffer pool name=bb...bb　　（Ｌ+Ｓ）
RDエリアaa....aaが割り当てられていないため，グローバルバッファbb....bbを削除できません。
aa....aa：RDエリア名
bb....bb：グローバルバッファ名
(Ｓ)処理を続行します。
[対策]pdbufls -k defコマンドで使用中のグローバルバッファを確認し，RDエリアを指定し直してコマンドを再実行してください。
KFPH27112-E
pdbufmod command failed due to specified name not found, global buffer pool name=aa....aa, server=bb....bb　　（Ｌ+Ｓ）
指定したグローバルバッファaa....aaはサーバbb....bbに定義されていません。このため，pdbufmodコマンドが実行できません。
aa....aa：グローバルバッファ名
bb....bb：サーバ名
(Ｓ)処理を続行します。
[対策]pdbufls -k defコマンドで使用中のグローバルバッファを確認して，必要に応じてコマンドを再実行してください。
KFPH27113-E
Unable to execute pdbufmod command due to HiRDB Advanced High Availability not setup　　（Ｌ+Ｓ）
HiRDB Advanced High Availabilityがセットアップされていないため，pdbufmodコマンドを実行できません。
(Ｓ)処理を終了します。
[対策]HiRDB Advanced High Availabilityをセットアップしてからコマンドを再実行してください。
KFPH28001-E
Insufficient memory on DYNAMIC_SHMPOOL for DB exclusive control, server=aa....aa　　（Ｌ）
サーバaa....aaで，排他制御に使用する共用メモリが不足しました。
aa....aa：サーバ名称
(Ｓ)トランザクションを無効にします。
(Ｐ)
・クライアント環境定義PDDBLOGにNOを指定して共用表を更新するトランザクションを実行している場合
PDDBLOGをYESに変更することを検討してください。
・トランザクションで複数の共用表に対してIN EXCLUSIVE MODE指定のLOCK文を実行している場合
共用表の数を減らすことを検討してください。
・トランザクションでUNTIL DISCONNECT指定のLOCK文を共用表でない表に実行している場合
UNTIL DISCONNECT指定を削除することを検討してください。
[対策]pd_lck_until_disconnect_cntオペランドの値が不適切です。見直して，指定値を大きくしてからHiRDBを再開始してください。
KFPH29005-W
Unable to check work HiRDB file system area, return code=aa....aa, file system=bb....bb (cc....cc)　　（Ｌ）
作業表用HiRDBファイルシステム領域に対する使用率チェックでエラーが発生しました。
aa....aa：リターンコード
bb....bb：HiRDBファイルシステム領域の名称
HiRDBファイルシステム領域のパス名が118文字以上の場合は，HiRDBファイルシステム領域のパス名の後ろから117文字を出力します。
cc....cc：サーバ名称
(Ｓ)該当する作業表用HiRDBファイルシステム領域に対する使用率チェックを一時的にスキップして処理を続行します。ただし，その後の使用率チェックが打ち切られることはありません。なお，同一領域に対する使用率チェックで同一エラーが繰り返し発生する場合には，最初のエラー発生時にこのメッセージを出力して，同一エラーが続く間はこのメッセージを出力しません。
(Ｏ)HiRDB管理者に連絡してください。
[対策]「HiRDBファイルシステムに対するアクセス要求から返されるエラーコード」を参照してエラーの原因を取り除いてください。
注　作業表用HiRDBファイルシステム領域に対する使用率チェックは，pd_watch_resource，又はpdwork_wrn_pntの指定に従っています。
KFPH29006-W
HiRDB file "aa....aa" information, return code=bbbbb, HiRDB file name=cc....cc　　（Ｌ）
HiRDBファイルcc....ccに対するaa....aaが，エラーコードbb....bbで終了しました。
aa....aa：HiRDBファイルに対する機能
create：HiRDBファイルの作成
delete：HiRDBファイルの削除
bbbbb：エラーコード
cc....cc：HiRDBファイルシステム領域名/HiRDBファイル名
HiRDBファイルのパス名が149文字以上の場合は，HiRDBファイルのパス名の後ろから148文字を出力します。
(Ｓ)処理を続行します。
[対策]「HiRDBファイルシステムに対するアクセス要求から返されるエラーコード」を参照して，エラーの要因を取り除いてください。ただし，aa....aaがcreateでエラーコードが-1541の場合には，作成しようとしたHiRDBファイルは既に定義されているが，先にこのHiRDBファイルの削除に失敗していることが考えられます。この場合，このメッセージより前に出力されているKFPH29006-Wメッセージでaa....aaがdeleteのエラーコードを「HiRDBファイルシステムに対するアクセス要求から返されるエラーコード」で調べて，エラーの原因を取り除いてください。
KFPH29008-I
Work buffer expanded, server=aa....aa, process ID=bb....bb　　（Ｌ）
システム定義のpd_work_buff_sizeオペランドに指定した作業表用バッファサイズが不足しましたが，pd_work_buff_expand_limitオペランドを指定しているため，作業表用バッファの増分確保をしました。
aa....aa：サーバ名
bb....bb：プロセスID
(Ｓ)処理を続行します。
[対策]
作業表用バッファの増分確保がされることを前提とした運用をしている場合：
このメッセージの出力を抑止したい場合，pd_work_table_optionオペランドで「作業表用バッファ長の自動増分時のメッセージ出力抑止」を指定してください。
作業表用バッファの増分確保がされることを前提としない運用をしている場合：
作業表用バッファの増分確保が不要となるようにpd_work_buff_sizeオペランドの指定値を見直してください。
注
作業表用バッファを増分確保した場合，該当するサーバプロセスでの作業表使用数が0になった時点で，増分確保した作業表用バッファを解放します。次の場合に，作業表使用数が0になります。
・使用中のカーソルをすべてクローズした場合（ただし，内部処理上，作業表使用数が0にならないこともあります）
・ホールダブルカーソルを使用していない場合，トランザクションを正常終了したとき，又はトランザクションを取り消したとき
・ホールダブルカーソルを使用している場合，UAPをHiRDBから切り離したとき
なお，Linux版及びWindows NT版のHiRDB以外の場合，作業表用バッファを増分確保したときには，メモリ解放のため，常駐プロセスであっても次の契機でプロセスを終了させます。
HiRDB/シングルサーバの場合：
UAPをHiRDBから切り離す場合，シングルサーバプロセスを終了させます。
HiRDB/パラレルサーバの場合：
ホールダブルカーソルを使用していない場合，トランザクションの正常終了時，又はトランザクションの取り消し時に，バックエンドサーバプロセス又はディクショナリサーバプロセスを終了させます。
ホールダブルカーソルを使用している場合，UAPをHiRDBから切り離すときに，バックエンドサーバプロセス又はディクショナリサーバプロセスを終了させます。
KFPH29009-W
Unable to expand work buffer due to insufficient memory, server=aa....aa,process ID=bb....bb,size=cc....cc　　（Ｌ）
pd_work_buff_expand_limitオペランドの指定に従って作業表用バッファを増分確保しようとしたが，プロセス固有領域が不足したためできませんでした。
aa....aa：サーバ名
bb....bb：プロセスID
cc....cc：該当プロセスでの作業表用バッファ総サイズ（単位：キロバイト）
(Ｓ)処理を続行します。
[対策]
作業表用バッファの増分確保がされることを前提とした運用をしている場合：
pd_work_buff_expand_limitオペランドの指定値をcc....cc以下に減らしてください。
作業表用バッファの増分確保がされることを前提としない運用をしている場合：
pd_work_buff_expand_limitオペランドを指定しないでください。


KFPIメッセージ

KFPI21501-I
Usage: pdfbkup [-y] [-r] [-i] [-{c|l|f}] HiRDB_file_system_area_name[/file_name] backup_file　　（Ｅ）
指定されたHiRDBファイルシステムをファイル上に退避するコマンド（pdfbkup）の使用方法を示します。コマンドオプション，又は引数が誤っている場合に出力します。
(Ｓ)処理を終了します。
(Ｏ)コマンドの形式を修正して，再度実行してください。
KFPI21502-I
Usage: pdfrstr [-y] [-q] [-{t|o|r}] backup_file [/file_name] HiRDB_file_system_area_name　　（Ｅ）
退避したファイルから，HiRDBファイルシステムを格納（リストア）するコマンド（pdfrstr）の使用方法を示します。コマンドオプション，又は引数が誤っている場合に出力します。
(Ｓ)処理を終了します。
(Ｏ)コマンドの形式を修正して，再度実行してください。
KFPI21503-I
Usage: pdfls [-[H] [{L|S}] [{t|u}]] HiRDB_file_system_area_name [/file_name]
pdfls [-x] HiRDB_file_system_area_name[/file_name]　　（Ｅ）
HiRDBファイル一覧表示コマンド（pdfls）の使用方法を示します。コマンドオプション，又は引数が誤っている場合に出力します。
(Ｓ)処理を終了します。
(Ｏ)コマンドの形式を修正して，再度実行してください。
KFPI21505-I
Usage: pdfmkfs -n capacity -l file_count [-e expand_count] [-i] [-k area_kind] [-s sector_size] character_special_file pdfmkfs [-r] -n capacity -l file_count [-e expand_count] [-i] [-k area_kind] UNIX_regular_file　　（Ｅ）
HiRDBファイルシステム領域を初期設定するコマンド（pdfmkfs）の使用方法を示します。コマンドオプション，又は引数が誤っている場合に出力します。
(Ｓ)処理を終了します。
(Ｏ)HiRDB/シングルサーバのコマンドの形式を修正して，再度実行してください。
KFPI21510-E
Backup file open error, filename = aa....aa errno = bbb　　（Ｅ）
退避ファイルaa....aaは，エラー番号bbbでオープンに失敗しました。
aa....aa：退避ファイル名
退避ファイル名が149文字以上の場合は，退避ファイル名の後ろから148文字を出力します。
bbb：エラー番号
(Ｓ)処理を終了します。
(Ｏ)エラー番号を参照して，対処してください。エラー番号と対処を表に示します。
エラー
番号
内容
対処
2
ファイル又はディレクトリがありません。
・指定したファイル又はディレクトリを見直し，再度実行してください。
5
入出力エラーが発生しました。
・ほかのメッセージを確認してください。
・ファイル名を変更して，再度実行してください。
11
ほかのプロセスでロックしています。
・ロックしているプロセスの終了を待って再度実行してください。
・ファイル名を変更して，再度実行してください。
13
指定したファイルに対してアクセス権限がありません。
・アクセス権限のあるユーザで再度実行してください。
・ファイルの所有者でアクセス権を変更した後，再度実行してください。
・ファイル名を変更し，再度実行してください。
17
指定したファイルがあります。
・ファイル名を変更し，再度実行してください。
・removeオプションのあるコマンドはオプションを指定し，再度実行してください。
20
パス名で指定したディレクトリがありません。
指定したパス名を修正し，再度実行してください。
21
指定したファイルはディレクトリです。
指定したファイル名を修正し，再度実行してください。
23
ファイルテーブルが一杯です。
・不要なプロセスを終了させ，再度実行してください。
・samシステムコマンドのKernel Configurationでnfileの値を変更し，システムを再構築した後，再度実行してください。
24
オープンファイル数がシステムの定義値を超えています。
・
28
ファイルシステムが満杯です。
不要なファイルを削除し，再度実行してください。
その他
－
保守員に連絡してください。
（凡例）－：該当しません。
KFPI21511-E
Backup file aa....aa already exist　　（Ｅ）
退避ファイルaa....aaは，既にあります。
aa....aa：退避ファイル名
退避ファイル名が149文字以上の場合は，退避ファイル名の後ろから148文字を出力します。
(Ｓ)処理を終了します。
(Ｏ)-rオプションを指定してください。又は，退避ファイル名を変更して，再度実行してください。
KFPI21512-W
HiRDB file create error, HiRDB file system area=aa....aa, file name=bb....bb, errno=ccccc　　（Ｅ）
HiRDBファイルbb....bbはHiRDBファイルシステム領域aa....aaにエラー番号cccccのため作成できません。
aa....aa：HiRDBファイルシステム領域名
HiRDBファイルシステム領域名が115文字以上の場合は，HiRDBファイルシステム領域名の後ろから114文字を出力します。
bb....bb：HiRDBファイル名
ccccc：エラーコード
(Ｓ)処理を続行します。
(Ｏ)「HiRDBファイルシステムに対するアクセス要求から返されるエラーコード」を参照して，エラーの原因を取り除き，再度コマンドを実行してください。
KFPI21513-Q
HiRDB file system area aa....aa restore from bb....bb. [G:continue, T:terminate]　　（Ｓ）
退避したファイルbb....bbから，指定したHiRDBファイルシステム領域aa....aaに格納してもよいか，オペレータに応答を求めます。
aa....aa：HiRDBファイルシステム領域名
HiRDBファイルシステム領域名が77文字以上の場合は，HiRDBファイルシステム領域名の後ろから76文字を出力します。
bb....bb：バックアップファイル名
バックアップファイル名が77文字以上の場合は，バックアップファイル名の後ろから76文字を出力します。
(Ｓ)応答を待ちます。
(Ｏ)次のどちらかを応答してください。
G：処理を続行します。
T：処理を終了します。
KFPI21514-Q
HiRDB file system area aa....aa backup to bb....bb. [G:continue, T:terminate]　　（Ｓ）
指定したHiRDBファイルシステム領域aa....aaを退避ファイルbb....bbに退避してもよいか，オペレータに応答を求めます。
aa....aa：HiRDBファイルシステム領域名
HiRDBファイルシステム領域名が79文字以上の場合は，HiRDBファイルシステム領域名の後ろから78文字を出力します。
bb....bb：バックアップファイル名
バックアップファイル名が79文字以上の場合は，バックアップファイル名の後ろから78文字を出力します。
(Ｓ)応答を待ちます。
(Ｏ)次のどちらかを応答してください。
G：処理を続行します。
T：処理を終了します。
KFPI21515-E
Unable to restore because sector size boundary unmatched, file name=aa....aa, HiRDB file record size=bb....bb, HiRDB file system area sector size=cc....cc　　（Ｅ）
HiRDBファイルのレコード長とHiRDBファイルシステム領域のセクタ長が一致しないため，HiRDBファイルaa....aaを格納できません。HiRDBファイルのレコード長はbb....bb，HiRDBファイルシステム領域のセクタ長はcc....ccです。
aa....aa：HiRDBファイル名
bb....bb：HiRDBファイルのレコード長
cc....cc：HiRDBファイルシステム領域のセクタ長
(Ｓ)処理を続行します。
[対策]HiRDBファイルシステム領域を初期化して再度実行してください。HiRDBファイルシステム領域を初期化するとき，レコード長がセクタ長の整数倍となるようにセクタ長を指定してください。
KFPI21516-E
Unable to aa....aa : Not owner　　（Ｅ）
実行ユーザがスーパユーザ，又はHiRDBファイルシステム領域の所有者ではありません。このため，HiRDBファイルシステム領域を退避，又は格納できません。
aa....aa：処理の種別｛ backup | restore ｝
(Ｓ)処理を終了します。
(Ｏ)スーパユーザ又はHiRDBファイルシステム領域の所有者で，再度実行してください。
KFPI21517-W
Unable to backup becose I/O error occurred, file name=aa....aa　　（Ｅ）
入出力障害が発生したため，HiRDBファイルaa....aaは，退避されていません。
aa....aa：HiRDBファイル名
(Ｓ)処理を終了します。
(Ｏ)退避処理中のエラーメッセージに対する処置を終了した後，再度，退避又は回復コマンドを実行してください。
KFPI21518-E
File aa....aa not backup file　　（Ｅ）
指定したファイルaa....aaは，退避ファイルではありません。
aa....aa：バックアップファイル名
バックアップファイル名が149文字以上の場合は，バックアップファイル名の後ろから148文字を出力します。
(Ｓ)処理を終了します。
(Ｏ)正しい退避ファイルを指定して，再度コマンドを実行してください。
KFPI21519-E
HiRDB file aa....aa not found in backup file　　（Ｅ）
指定したHiRDBファイルaa....aaは，退避ファイル中にありません。
aa....aa：HiRDBファイル名
(Ｓ)処理を終了します。
(Ｏ)HiRDBファイル名称，又は退避ファイル名称を確認して，再度コマンドを実行してください。
KFPI21527-E
HiRDB file system area aa....aa locked in other process, pid=bb....bb　　（Ｅ）
HiRDBファイルシステム領域が，ほかのプロセスで使用しているため，初期設定できません。
aa....aa：HiRDBファイルシステム領域名
HiRDBファイルシステム領域名が118文字以上の場合は，HiRDBファイルシステム領域名の後ろから117文字を出力します。
bb....bb：HiRDBファイルシステム領域をロックしているプロセスID
HiRDBサーバがUNIX版の場合は，ロックしているプロセスID又は-1が表示されます。HiRDBサーバがWindows NT版の場合は-1が表示されます。
-1が表示された場合は，ロックしているプロセスは存在するがプロセスIDの取得ができなかったことを意味します。
(Ｓ)異常終了します。
[対策]次に示すどれかの処置をしてください。
・HiRDBファイルシステム領域を使用しているプロセスの終了を待って，再度実行してください。
・HiRDBが稼働中の場合はHiRDBを一度終了して再度開始してください。HiRDBが停止中の場合は，このHiRDBファイルシステム領域中のHiRDBファイルを操作しているほかのコマンドの終了を待って，再度実行してください。
KFPI21528-E
HiRDB file system area aa....aa locked by other process, PID=bb....bb　　（Ｅ）
HiRDBファイルシステム領域aa....aaは，ほかのプロセス（bb....bb）でロックされています。このため，退避又は格納ができません。
aa....aa：HiRDBファイルシステム領域名
HiRDBファイルシステム領域名が149文字以上の場合は，HiRDBファイルシステム領域名の後ろから148文字を出力します。
bb....bb：HiRDBファイルシステム領域をロックしているプロセスID
HiRDBサーバがUNIX版の場合は，ロックしているプロセスID又は-1が表示されます。HiRDBサーバがWindows NT版の場合は-1が表示されます。
-1が表示された場合は，ロックしているプロセスは存在するがプロセスIDの取得ができなかったことを意味します。
(Ｓ)処理を終了します。
(Ｏ)HiRDBファイルシステム領域をロックしているプロセスの終了を待って，再度実行してください。
〈格納コマンドの場合〉
HiRDBが稼働中のときは，HiRDBを停止させて再度実行してください。また，HiRDBが停止中のときは，HiRDBファイルシステム領域を操作しているほかのコマンドの終了を待って，再度実行してください。
〈退避コマンドの場合〉
-fオプションを指定して，再度実行してください。
KFPI21529-W
HiRDB file aa....aa locked by other process, PID=bb....bb　　（Ｅ）
HiRDBファイルaa....aaは，ほかのプロセス（bb....bb）でロックしているため，退避できません。
aa....aa：HiRDBファイル名
bb....bb：HiRDBファイルをロックしているプロセスID
HiRDBサーバがUNIX版の場合は，ロックしているプロセスID又は-1が表示されます。HiRDBサーバがWindows NT版の場合は-1が表示されます。
-1が表示された場合は，ロックしているプロセスは存在するがプロセスIDの取得ができなかったことを意味します。
(Ｓ)処理を続行します。
(Ｏ)HiRDBファイルをロックしているプロセスの終了を待って，再度実行してください。
〈格納コマンドの場合〉
HiRDBが稼働中のときは，HiRDBを停止させて，再度実行してください。HiRDBが停止中のときは，HiRDBファイルを操作しているほかのコマンドの終了を待って，再度実行してください。
〈退避コマンドの場合〉
-fオプションを指定して，再度実行してください。
KFPI21530-Q
HiRDB file system area aa....aa already exist. [g:continue, t:terminate]　　（Ｓ）
指定したHiRDBファイルシステムの領域を初期化してもよいかオペレータに応答を求めます。
aa....aa：HiRDBファイルシステム領域名
HiRDBファイルシステム領域名が118文字以上の場合は，HiRDBファイルシステム領域名の後ろから117文字を出力します。
(Ｓ)応答を待ちます。
(Ｏ)次のどちらかを応答してください。
g：処理を続行します。
t：処理を終了します。
KFPI21531-E
No more space or partition size over in HiRDB file system area aa....aa　　（Ｅ）
通常ファイルの場合，-nオプションで指定した容量を確保できません。
キャラクタ型スペシャルファイルの場合，-nオプションで指定した容量が指定されたHiRDBファイルシステム領域を超えています。
aa....aa：HiRDBファイルシステム領域名
HiRDBファイルシステム領域名が118文字以上の場合は，HiRDBファイルシステム領域名の後ろから117文字を出力します。
(Ｓ)処理を終了します。
(Ｏ)次の項目について検討して，再度実行してください。
・初期化する容量を減らしてください。
・容量を満たすキャラクタ型スペシャルファイルを指定してください。
・OSのファイルシステム中にある，ほかのファイルを削除してください。
KFPI21532-E
Unable to initialized : Not owner　　（Ｅ）
実行ユーザがスーパユーザ又はHiRDBファイルシステム領域の所有者ではありません。このため，HiRDBファイルシステムの領域を初期設定できません。
(Ｓ)処理を終了します。
(Ｏ)スーパユーザ又はHiRDBファイルシステム領域の所有者で，再度実行してください。
KFPI21533-E
File name aa....aa not found　　（Ｅ）
指定したHiRDBファイルがHiRDBファイルシステム領域にありません。
aa....aa：HiRDBファイル名
(Ｓ)処理を終了します。
[対策]HiRDBファイル名を確認して，再度実行してください。
KFPI21534-E
Invalid argument for aa operand in bb....bb command　　（Ｅ）
bb....bbコマンドの，aaオペランドに指定した引数が不正です。
aa：オペランド名
bb....bb：コマンド名
(Ｓ)処理を終了します。
(Ｏ)オペランドの引数を修正して，再度実行してください。
pdfmkfsコマンドの場合
-kオプションを省略したのに-kオプションが不正と表示されることがあります。-kオプションを省略するとSVRが仮定されるため，次に示す理由で-kオプションの指定エラーとなります。
・Linux版の場合，キャラクタ型スペシャルファイル上のHiRDBファイルシステム領域に-k SVRを指定できません。
・Windows NT版の場合，ダイレクトディスクアクセス（raw I/O）上のHiRDBファイルシステム領域に-k SVRを指定できません。
KFPI21536-E
Mandatory argument missing　　（Ｅ）
オペランドに対する引数がありません。又は，指定できる引数の個数よりも多くの引数を指定しました。
(Ｓ)処理を終了します。
(Ｏ)このメッセージの直後に出力される使用方法に従って，オペランドを修正し，再度実行してください。
KFPI21537-E
Invalid operand combination　　（Ｅ）
必要なオペランドが指定されていません。又は，オペランドの組み合わせが不正です。
(Ｓ)処理を終了します。
(Ｏ)このメッセージの直後に出力される使用方法に従って，オペランドを修正し，再度実行してください。
KFPI21538-E
Area_kind aaaa is not supported character_special_file in bb....bb command,HiRDB file system area=cc....cc　　（Ｅ）
bb....bbコマンドに指定したHiRDBファイルシステム領域cc....ccはキャラクタ型スペシャルファイルです。使用目的aaaaのHiRDBファイルシステム領域はキャラクタ型スペシャルファイル上に作成できません。
aaaa：HiRDBファイルシステム領域の使用目的
bb....bb：コマンド名
cc....cc：HiRDBファイルシステム領域名
HiRDBファイルシステム領域名が118文字以上の場合は，HiRDBファイルシステム領域名の後ろから117文字を出力します。
(Ｓ)処理を終了します。
[対策]HiRDBファイルシステム領域を通常ファイル上に作成してください。又は，使用目的が正しいか確認してください。
KFPI21547-I
aa....aa command terminated normally　　（Ｅ）
aa....aaコマンドが，正常終了しました。
aa....aa：コマンド名｛ "pdfbkup" | "pdfrstr" ｝
(Ｓ)処理を続行します。
KFPI21548-W
aa....aa command terminated with warning　　（Ｅ）
aa....aaコマンドが，警告終了しました。
aa....aa：コマンド名｛ "pdfbkup" | "pdfrstr" ｝
(Ｓ)処理を続行します。
(Ｏ)このメッセージの前に出力されたメッセージを調査してください。問題があれば，該当するメッセージに対する処理を終了した後，再度実行してください。
KFPI21549-E
aa....aa command terminated with error　　（Ｅ）
aa....aaコマンドがエラー終了しました。又は，KFPI21514-Qメッセージの問い合わせに対して，ユーザが中止を応答しました。
aa....aa：コマンド名｛ "pdfbkup" | "pdfrstr" ｝
(Ｓ)処理を終了します。
(Ｏ)ユーザの中止応答でない場合は，このメッセージの前に出力されたメッセージに対する処理を終了した後，再度実行してください。
KFPI21550-I
Usage: pdfrm [-i] HiRDB_file_system_area_name/file_name　　（Ｅ）
HiRDBファイルシステムの削除コマンド（pdfrm）の使用方法を示します。このコマンドのオプション指定又は引数に誤りがあります。
(Ｓ)処理を終了します。
(Ｏ)コマンドの形式を修正して，再度実行してください。
KFPI21551-I
Usage: pdfstatfs [ -c | d ] [ -S ] HiRDB_file_system_area_name　　（Ｅ）
HiRDBファイルシステム領域の状態表示コマンド（pdfstatfs）の使用方法を示します。このコマンドのオプション指定又は引数に誤りがあります。
(Ｓ)処理を終了します。
(Ｏ)コマンドの形式を修正して，再度実行してください。
KFPI21552-Q
aa....aa : ? (y/n)　　（Ｓ）
HiRDBファイルaa....aaを削除してもよいかオペレータに応答を求めています。
aa....aa：HiRDBファイル名
(Ｓ)応答を待ちます。
(Ｏ)次のどちらかを応答してください。
y：削除します。
n：削除しません。
KFPI21553-W
File not restored, target HiRDB file was updated after backup, use -r option to force restore, HiRDB file name=aa....aa　　（Ｅ）
退避ファイル中のHiRDBファイルと同じ名称のファイルがあります。格納先のHiRDBファイルは，pdfbkupコマンドで退避された後，更新されているため格納しません。しかし，-rオプションで格納できます。
aa....aa：HiRDBファイル名
(Ｓ)処理を続行します。
(Ｏ)HiRDBファイル名を確認し，格納する必要がある場合には，-rオプションを指定し，再度実行してください。
KFPI21554-W
File not restored, HiRDB file already exists, HiRDB file name=aa....aa　　（Ｅ）
格納先のHiRDBファイルシステム領域に同一ファイル名があるため，格納できません。
aa....aa：HiRDBファイル名
(Ｓ)処理を続行します。
(Ｏ)退避ファイルと格納先ファイルを確認した後，格納してもよい場合は-rオプションを指定し，再度実行してください。
KFPI21555-E
No HiRDB file in HiRDB file system area aa....aa　　（Ｅ）
HiRDBファイルシステム領域aa....aaにはHiRDBファイルがありません。HiRDBファイルの有無は，pdflsコマンド又はpdfstatfsコマンドで確認できます。
aa....aa：HiRDBファイルシステム領域名
HiRDBファイルシステム領域名が118文字以上の場合は，HiRDBファイルシステム領域名の後ろから117文字を出力します。
(Ｓ)処理を終了します。
(Ｏ)指定したHiRDBファイルシステム領域を確認し，再度実行してください。
KFPI21556-E
Invalid or too long backup file name aa....aa　　（Ｅ）
指定した退避ファイルの名称に不正な文字が含まれています。又は，退避ファイルの名称の長さが制限を超えています。
指定できる文字については，マニュアル「HiRDB Version 7 コマンドリファレンス」を参照してください。
aa....aa：退避ファイル名
退避ファイル名が149文字以上の場合は，退避ファイル名の後ろから148文字を出力します。
(Ｓ)処理を終了します。
(Ｏ)正しい退避ファイル名を指定して，再度実行してください。
KFPI21570-E
Version unmatch in HiRDB file systemarea aa....aa, version : bbbbbbb　　（Ｅ）
HiRDBファイルシステム領域のバージョンが，HiRDBのバージョンよりも新しい状態です。
aa....aa：HiRDBファイルシステム領域名
HiRDBファイルシステム領域名が118文字文字以上の場合は，HiRDBファイルシステム領域名の後ろから117文字を出力します。
bbbbbbb：HiRDBファイルシステム領域内のバージョン番号
(Ｓ)処理を終了します。
[対策]HiRDBが正しく組み込まれているかを確認し，再度実行してください。又は，HiRDBの実行パスが正しいかどうかを確認し，再度実行してください。
KFPI21571-E
HiRDB file system area aa....aa permission denied　　（Ｅ）
HiRDBファイルシステム領域aa....aaに対するアクセス権（OSのchmodコマンドで設定した権限）がありません。
aa....aa：HiRDBファイルシステム領域名
HiRDBファイルシステム領域名が118文字文字以上の場合は，HiRDBファイルシステム領域名の後ろから117文字を出力します。
(Ｓ)処理を終了します。
[対策]HiRDBファイルシステム領域のアクセス権をOSのシステムコマンドchmod（Windows NTの場合はファイルのプロパティ）で変更してください。又は，アクセス権のあるユーザで再度実行してください。
KFPI21572-E
Too many open files on HiRDB file system area aa....aa　　（Ｅ）
HiRDBファイルシステム領域aa....aaのオープン処理で，システムでオープンできるファイル数の上限値を超えました。
aa....aa：HiRDBファイルシステム領域名
HiRDBファイルシステム領域名が118文字文字以上の場合は，HiRDBファイルシステム領域名の後ろから117文字を出力します。
(Ｓ)処理を終了します。
[対策]ほかのプロセスの終了を待って，再度実行してください。又は，samシステムコマンドのkernel Configurationでファイルオープンの上限（nfiles）を変更して，システムを構築し直し，再度実行してください。
KFPI21573-E
HiRDB file system area aa....aa not found　　（Ｅ）
指定したHiRDBファイルシステム領域がありません。又は，HiRDBファイルシステム領域名が不正です。
aa....aa：HiRDBファイルシステム領域名
HiRDBファイルシステム領域名が118文字文字以上の場合は，HiRDBファイルシステム領域名の後ろから117文字を出力します。
(Ｓ)処理を終了します。
(Ｏ)正しいHiRDBファイルシステム領域名を指定して，再度実行してください。
KFPI21574-E
Invalid or too long HiRDB file system area name aa....aa　　（Ｅ）
指定したHiRDBファイルシステム領域名に不正な文字が含まれています。又は，HiRDBファイルシステム領域名が長過ぎます。
aa....aa：HiRDBファイルシステム領域名
HiRDBファイルシステム領域名が118文字文字以上の場合は，HiRDBファイルシステム領域名の後ろから117文字を出力します。
指定できる文字については，マニュアル「HiRDB Version 7 コマンドリファレンス」を参照してください。
(Ｓ)処理を終了します。
(Ｏ)正しいHiRDBファイルシステム領域名を指定して，再度実行してください。
KFPI21575-E
Invalid file type in aa....aa　　（Ｅ）
指定したファイルaa....aaは，キャラクタ型スペシャルファイル又は通常ファイルではありません。
aa....aa：HiRDBファイルシステム領域名
HiRDBファイルシステム領域名が118文字文字以上の場合は，HiRDBファイルシステム領域名の後ろから117文字を出力します。
(Ｓ)処理を終了します。
(Ｏ)正しいキャラクタ型スペシャルファイル又は通常ファイルを指定して，再度実行してください。
KFPI21576-E
File aa....aa not HiRDB file system area　　（Ｅ）
指定したファイルaa....aaは，HiRDBファイルシステム領域ではありません。
aa....aa：指定したファイル名
指定したファイル名が118文字文字以上の場合は，ファイル名の後ろから117文字を出力します。
(Ｓ)処理を終了します。
(Ｏ)正しいHiRDBファイルシステム領域を指定して，再度実行してください。
KFPI21578-E
Insufficient lock segment for HiRDB file system area　　（Ｅ）
HiRDBファイルシステム領域のロック処理で使用するfcntlシステムコールは，ロックの上限値を超えました。
(Ｓ)処理を終了します。
(Ｏ)samシステムコマンドのkarnel Configurationで，nflocksを変更して，システムを構築し直した後，再度実行してください。又は，ロックを使用しているほかのプロセスの終了を待って，再度実行してください。
KFPI21580-E
Control black was destroyed, HiRDB file system area=aa....aa　　（Ｅ）
HiRDBファイルシステム領域の管理情報が破壊されています。
aa....aa：HiRDBファイルシステム領域名
HiRDBファイルシステム領域名が118文字文字以上の場合は，HiRDBファイルシステム領域名の後ろから117文字を出力します。
(Ｓ)処理を終了します。
(Ｏ)HiRDBファイルシステム領域をバックアップから回復した後，再度実行してください。
KFPI21581-E
I/O error occurred, file_name=aa....aa　　（Ｅ）
ファイルaa....aaで入出力エラーが発生しました。
aa....aa：HiRDBファイル名，又はバックアップファイル名
HiRDBファイル名はHiRDBファイル名だけ，バックアップファイル名は絶対パスのバックアップファイル名を出力します。なお，ファイル名が149文字以上の場合は，ファイル名の後ろから148文字を出力します。
(Ｓ)処理を終了します。
(Ｏ)このメッセージの前に出力されるKFPO00107-Eのerrnoを参照して対処してください。KFPO00107-Eが出力されていない場合，ファイルの出力先の容量が不足しています。
KFPI21582-E
Insufficient memory on PROCESS, size=aaaaa　　（Ｅ＋Ｌ）
プロセス固有領域が不足しました。
aaaaa：要求バイト数（単位：バイト）
(Ｓ)処理を終了します。
[対策]不要なプロセスを終了させて，再度実行してください。
KFPI21583-E
I/O error occured, HiRDB file system : aa....aa　　（Ｅ）
HiRDBファイルシステム領域aa....aaの管理領域で，入出力エラーが発生しました。
aa....aa：HiRDBファイルシステム領域名
HiRDBファイルシステム領域名が118文字文字以上の場合は，HiRDBファイルシステム領域名の後ろから117文字を出力します。
(Ｓ)処理を終了します。
(Ｏ)このメッセージの前に出力されるKFPO00107-Eのerrnoを参照して対処してください。
KFPI21584-E
Specification of aa option required in bb....bb command　　（Ｅ）
bb....bbコマンドを実行するにはaaオプションを指定してください。
aa：オプション名
bb....bb：コマンド名
(Ｓ)処理を終了します。
[対策]aaオプションを指定して再度実行してください。
KFPI21599-E
Logical inconsistency occurred in aa....aa:bb....bb　　（Ｅ）
HiRDBファイルシステムで内部矛盾が発生しました。
aa....aa：矛盾が発生したファイル名
bb....bb：矛盾が発生したシーケンス番号
(Ｓ)処理を終了します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]保守員に連絡してください。


KFPJメッセージ

KFPJ00001-E
System call error occurred. [aa....aa code:bb....bb]
システムコール関数でエラーが発生しました。
aa....aa：エラーが発生した関数の名称
bb....bb：GetLastError関数で返ってきたエラーコード
(Ｓ)処理を終了します。
[対策]シャットダウンさせて，再度実行してください。なお，このエラーが繰り返し発生する場合は，保守員に連絡してください。
KFPJ00002-E
An abnormality occurred. [aa....aa Line:bb....bb]
Javaアプリケーション実行中に異常が発生しました。
aa....aa：エラーが発生したソースファイルの名称
bb....bb：エラーが発生した行番号
(Ｓ)処理を終了します。
[対策]保守員に連絡してください。
KFPJ00003-E
Memory became insufficient.
Javaアプリケーション実行中にメモリ不足が発生しました。
(Ｓ)処理を終了します。
[対策]ほかのアプリケーションプログラムを終了して，再度実行してください。
KFPJ00004-E
Incorrect environment. Re-install.
動作環境が不正です。次のどれかの原因が考えられます。
・インストールが正常に終了していません。
・環境変数（レジストリ）が不正です。
・ファイルがないか，又は破壊されています。
(Ｓ)処理を終了します。
[対策]JDBCドライバをインストールし直して，再度実行してください。
KFPJ00005-E
An error occurred during initialization.
初期化中にエラーが発生しました。
(Ｓ)処理を終了します。
[対策]定義エラーの原因を特定できない場合は，該当する定義ファイルを削除してください。
KFPJ00201-E
The directory is invalid.
ディレクトリが正しくありません。次のどちらかの原因が考えられます。
・ディレクトリ名の指定に誤りがある。
・存在しないディレクトリを指定している。
(Ｓ)処理を終了します。
[対策]ディレクトリ名を正しく指定して，再度実行してください。
KFPJ00202-E
The numerical data is outside the range.
範囲外の数値データが入力されました。次のどれかの原因が考えられます。
・数値データ以外の文字を入力しています。
・全角文字を入力しています。
・指定できる範囲外の数値データを入力しています。
(Ｓ)処理を終了します。
[対策]指定できるデータの範囲を確認してから，データを再入力してください。
KFPJ01001-E
Memory became insufficient. [aa....aa]
処理に必要な領域を確保するとき，メモリ不足が発生しました。
aa....aa：保守用情報
(Ｓ)処理を終了します。
[対策]実行中のほかの処理を終了してから，再度実行してください。
KFPJ01002-E
Sequence error occurred. [aa....aa]
ユーザからのデータベースに対する要求シーケンスが誤っています。
aa....aa：保守用情報
(Ｓ)ユーザからの要求を受け付けません。
[対策]データベースに対する要求シーケンスを見直してください。
KFPJ01003-E
System call error occurred. [aa....aa]
システムコールでエラーが発生しました。
aa....aa：保守用情報
(Ｓ)処理を終了します。
[対策]操作を再度実行してください。なお，繰り返し発生する場合は，保守員に連絡してください。
KFPJ01004-I
DBMS processing was canceled.
データベースに対する処理を中断しました。
(Ｓ)データベースに対する処理を中断します。
[対策]必要に応じて再度実行してください。
KFPJ01005-E
A data attribute that is not supported was found. [aa....aa]
指定した表の列の属性aa....aaは，使用できません。
aa....aa：使用できない表の列の属性コード（16進数表示）
(Ｓ)ユーザからの要求を受け付けません。
[対策]列の属性を修正して，ユーザからの要求を再度実行してください。また，列の属性コードについては，接続先のデータベースのマニュアルを参照してください。
KFPJ01007-E
Not support tables containing multivalue columns and array columns.
繰返し列及び配列列を含む表は使用できません。
(Ｓ)ユーザからの要求を受け付けません。
[対策]列の属性を修正して，ユーザからの要求を再度実行してください。
KFPJ01013-E
The permission identifier, password or DBMS information specified by the user exceeded 32 bytes.
ユーザが指定した認可識別子，パスワード，又はデータベース情報のどれかが32バイトを超えています。
(Ｓ)ユーザからの要求を受け付けません。
[対策]認可識別子，パスワード，又はデータベース情報を32バイト以内で指定してください。
KFPJ01014-E
An error occurred in the distributed server. nodename= aa....aa error text=
分散サーバでエラーが発生しました。
aa....aa：RDノード名称
(Ｓ)ユーザからの要求を受け付けません。
[対策]エラーが発生したシステムのマニュアルを参照してください。
KFPJ01017-E
Incorrect table attribute. [aa....aa]
表属性の指定が誤っています。
aa....aa：エラーコード
(Ｓ)ユーザからの要求を受け付けません。
[対策]表属性を正しく指定してから，再度実行してください。なお，出力されたエラーコードによって，次の内容を見直してください。
・エラーコードが1の場合，表属性の前後が「`」で囲まれているか確認してください。
・エラーコードが2の場合，指定している表属性が誤っていないか確認してください。
・エラーコードが3の場合，複数の表属性を指定したときの，区切り文字の指定が誤っていないかを確認してください。
KFPJ01018-E
Incorrect input parameter. [aa....aa]
入力パラメタの指定が誤っています。
aa....aa：保守用情報
(Ｓ)ユーザからの要求を受け付けません。
[対策]入力パラメタを正しく指定して，再度実行してください。
KFPJ01019-E
Incorrect output parameter. [aa....aa]
出力パラメタの指定が誤っています。
aa....aa：保守用情報
(Ｓ)ユーザからの要求を受け付けません。
[対策]出力パラメタを正しく指定して，再度実行してください。
KFPJ01020-E
Incorrect version of the DBMS. [aa....aa]
データベースが，接続できるバージョンではありません。
aa....aa：保守用情報
(Ｓ)ユーザからの要求を受け付けません。
[対策]システム管理者にデータベースのバージョンを確認してください。
KFPJ01021-E
Incorrect multiple SQL execution. [aa....aa]
複数のSQLを実行するときの指定が誤っています。
aa....aa：保守用情報
(Ｓ)ユーザからの要求を受け付けません。
[対策]複数のSQLを実行するときの指定を修正して，再度実行してください。
KFPJ01025-E
Not prepared to connect to HiRDB. [aa....aa]
HiRDBに対する接続環境が整っていません。
aa....aa：保守用情報
(Ｓ)ユーザからの要求を受け付けません。
[対策]OTSの初期化完了後にアクセスを要求しているか，アプリケーションを確認してください。
KFPJ01060-E
An XA request error occurred.
XA要求でエラーが発生しました。
(Ｓ)ユーザからの要求を受け付けません。
[対策]接続しているデータベースのマニュアルを参照してください。
KFPJ01070-E
Object is null. (aa....aa) [function: bb....bb]
オブジェクトが生成されていません。
aa....aa：エラーが発生したオブジェクトのクラス名
bb....bb：エラーが発生した関数の名称
(Ｓ)jdbInternalExceptionをthrowします。
[対策]オブジェクトを生成して，再度実行してください。
KFPJ01071-E
Object is not instance of aa....aa. [function: bb....bb]
オブジェクトが，クラス名で示されたクラスのインスタンスではありません。
aa....aa：エラーが発生したオブジェクトのクラス名
bb....bb：エラーが発生した関数の名称
(Ｓ)jdbInternalExceptionをthrowします。
[対策]適切なクラスのインスタンスを生成して，再度実行してください。
KFPJ01072-E
Array length is too short. (aa....aa) [function: bb....bb]
必要な数の配列の要素が生成されていません。
aa....aa：エラーが発生した配列の名称
bb....bb：エラーが発生した関数の名称
(Ｓ)jdbInternalExceptionをthrowします。
[対策]必要な数の配列の要素を生成して，再度実行してください。
KFPJ01073-E
Array is null. (aa....aa) [function: bb....bb]
配列が生成されていません。
aa....aa：エラーが発生した配列の名称
bb....bb：エラーが発生した関数の名称
(Ｓ)jdbInternalExceptionをthrowします。
[対策]配列を生成して，再度実行してください。
KFPJ01074-W
A warning is occurred. [aa....aa]
接続先データベースで，ワーニングが発生しました。
aa....aa：ワーニングコード（ワーニングコードは論理和で設定されます）
0x00000001：
ワーニングが発生しました。
0x00000002：
文字データの検索で，データを受け取る埋込み変数の長さが短かったため，切り捨てられた値を受け取りました。
0x00000004：
集合関数の処理でナル値を無視しました。
0x00000008：
検索結果の列の数とその検索結果を受け取る埋込み変数の数が一致しません。
0x00000010：
WHERE句がないUPDATE文及びDELETE文を実行しました。
0x00000040：
暗黙的にトランザクションが取り消されました。
0x00000080：
UPDATE文のSET句又はDELETE句に添字付きの繰返し列を指定していますが，更新する行に要素がないため，その更新は無視されました。
0x00000400：
日付演算の結果が存在しない日付になったため，その月の最終日に修正しました。
0x00000800：
SQL実行時の演算途中でオーバフロー又は0除算が発生したため，その演算結果をナル値にしました。
0x00001000：
日付演算の結果で，日間隔中の日の部分が00～99の範囲外となりました。
(Ｓ)SQLWarningを設定します。
[対策]ワーニング要因に対処してから，再度実行してください。
KFPJ02001-E
Not found environment definition file. [aa....aa]
動作環境定義ファイルがHiRDB運用ディレクトリにありません。
aa....aa：動作環境定義ファイル名
(Ｓ)処理を終了します。
[対策]HiRDB運用ディレクトリに動作環境定義ファイルを作成してください。
KFPJ02002-E
Incorrect environment definition. [aa....aa]
動作環境定義ファイルに設定した環境変数の値に誤りがあります。
aa....aa：環境変数名
(Ｓ)処理を終了します。
[対策]動作環境定義ファイルの環境変数の値を修正してください。
KFPJ02003-E
Incorrect environment definition. LINE= aa....aa [bb....bb]
次のどちらかの誤りがあります。
・動作環境定義ファイルの構文に誤りがあります。
・動作環境定義ファイルに設定した環境変数の値に誤りがあります。
aa....aa：エラーが発生した行
bb....bb：エラーが発生した定義
(Ｓ)処理を終了します。
[対策]動作環境定義ファイルを修正してください。
KFPJ02004-E
Not installed.
次のどちらかの誤りがあります。
・JDBCドライバがインストールされていません。
・JDBCドライバのインストール環境が不正です。
(Ｓ)処理を中断します。
[対策]JDBCドライバを再インストールしてください。
KFPJ02005-E
System call error occurred. [aa....aa]
システムコールでエラーが発生しました。
aa....aa：保守用情報
(Ｓ)処理を中断します。
[対策]エラーコード（errno）から要因が分かる場合は，その要因を取り除いてください。分からない場合は保守員に連絡してください。
KFPJ02006-E
System call error occurred. [aa....aa]
システムコールエラーが発生しました。
aa....aa：保守用情報
(Ｓ)処理を中断します。
[対策]エラーコード（errno）から要因が分かる場合は，要因を取り除いてください。分からない場合は保守員に連絡してください。
KFPJ02007-E
Unable to open message file. [aa....aa]
メッセージログファイルがオープンできません。
aa....aa：保守用情報
(Ｓ)処理を続行します。このメッセージ出力以降は，メッセージIDだけを出力します。
[対策]動作環境が破壊されています。HiRDBの環境設定をし直してください。
KFPJ02008-E
System call error occurred during output of aa....aa. [bb....bb]
メッセージログ出力中にシステムコールエラーが発生しました。
aa....aa：メッセージログファイルの名称
bb....bb：保守用情報
(Ｓ)処理を続行します。
[対策]このエラーが繰り返し発生する場合は，保守員に連絡してください。
KFPJ02009-E
Memory became insufficient. [aa....aa]
動作に必要なメモリが不足しています。
aa....aa：保守用情報
(Ｓ)処理を終了します。
[対策]しばらく時間を空けてから，再度実行してください。なお，このエラーが繰り返し発生する場合は，保守員に連絡してください。
KFPJ02010-E
Incorrect connection database definition. LINE= aa....aa [bb....bb]
次のどちらかの誤りがあります。
・接続先データベース定義ファイルの構文に誤りがあります。
・接続先データベース定義ファイルに設定した値に誤りがあります。
aa....aa：エラーが発生した行
bb....bb：エラーが発生した定義
(Ｓ)処理を終了します。
[対策]接続先データベース定義ファイルを修正してください。
KFPJ02011-E
Not have authority to access the environment definition file. [aa....aa]
動作環境定義ファイルに対するアクセス権限がありません。
aa....aa：動作環境定義ファイルの名称
(Ｓ)処理を終了します。
[対策]動作環境定義ファイルにリード権限があるかどうか調べてください。リード権限がない場合は，リード権限を付けてください。なお，このエラーが繰り返し発生する場合は，保守員に連絡してください。
KFPJ02012-E
Not have authority to access the connection database definition file. [aa....aa]
接続先データベース定義ファイルに対するアクセス権限がありません。
aa....aa：接続先データベース定義ファイルの名称
(Ｓ)処理を終了します。
[対策]接続先データベース定義ファイルにリード権限があるかどうか調べてください。リード権限がない場合は，リード権限を付けてください。なお，このエラーが繰り返し発生する場合は，保守員に連絡してください。
KFPJ02013-E
The database-type-name is duplicated. LINE= aa....aa [bb....bb]
接続先データベース定義ファイル中のデータベース種別名が重複しています。
aa....aa：エラーが発生した行
bb....bb：エラーが発生したブロック名称
(Ｓ)処理を終了します。
[対策]接続先データベース定義ファイルの値を修正してください。
KFPJ02014-E
The database-name is duplicated. LINE= aa....aa [bb....bb]
接続先データベース定義ファイル中のデータベース名が重複しています。
aa....aa：エラーが発生した行
bb....bb：エラーが発生したブロック名称
(Ｓ)処理を終了します。
[対策]接続先データベース定義ファイルの値を修正してください。
KFPJ02015-E
The [aa....aa] was not found. [bb....bb]
接続先データベース定義ファイルのブロック中に，必要な定義がありません。
aa....aa：必要な定義の名称
bb....bb：定義のブロック名称
(Ｓ)処理を終了します。
[対策]テキストエディタなどを使用して，接続先データベース定義ファイルの値を修正してください。
KFPJ02016-E
Incorrect Connection-Multi definition. LINE= aa....aa [bb....bb]
次のどちらかの誤りがあります。
・コネクションマルチ定義ファイルの構文に誤りがあります。
・コネクションマルチ定義ファイルに設定した値に誤りがあります。
aa....aa：エラーが発生した行
bb....bb：エラーが発生した定義
(Ｓ)処理を終了します。
[対策]コネクションマルチ定義ファイルを修正してください。
KFPJ02017-E
Not have authority to access the Connection-Multi definition file. [aa....aa]
コネクションマルチ定義ファイルに対するアクセス権限がありません。
aa....aa：コネクションマルチ定義ファイルの名称
(Ｓ)処理を終了します。
[対策]コネクションマルチ定義ファイルに対するアクセス権限があるかどうか調べてください。アクセス権限がない場合は，アクセス権限を与えてください。なお，このエラーが繰り返し発生する場合は，保守員に連絡してください。
KFPJ02018-E
The Connection-Multi-name is duplicated. LINE= aa....aa [bb....bb]
コネクションマルチ定義ファイル中のコネクションマルチ名が重複しています。
aa....aa：エラーが発生した行
bb....bb：エラーが発生したブロック名称
(Ｓ)処理を終了します。
[対策]コネクションマルチ定義ファイルの値を修正してください。
KFPJ02019-E
The directory was not found. Use the default directory. [aa....aa]
次のどちらかの誤りがあります。
・動作環境定義ファイルで環境変数に設定したディレクトリがないか，又は使用できません。
・ユーザが環境変数に設定したディレクトリがないか，又は使用できません。
aa....aa：環境変数名
(Ｓ)環境変数に指定したディレクトリを無視して，デフォルトのディレクトリを使用します。
[対策]次のどれかの対処をしてください。
・環境変数に設定したディレクトリを作成してください。
・動作環境定義ファイルの環境変数の値を修正してください。
・ユーザが設定した環境変数の値を修正してください。
・環境設定ユティリティを使用して，正しいディレクトリを指定してください。
KFPJ02020-E
The directory was not found. [aa....aa]
次のどちらかの誤りがあります。
・動作環境定義ファイルで環境変数に設定したディレクトリがないか，又は使用できません。
・ユーザが環境変数に設定したディレクトリがないか，又は使用できません。
aa....aa：環境変数名
(Ｓ)処理を終了します。
[対策]次のどれかの対処をしてください。
・環境変数に設定したディレクトリを作成してください。
・動作環境定義ファイルの環境変数の値を修正してください。
・ユーザが設定した環境変数の値を修正してください。
KFPJ04099-E
Error occurred. (aa....aa)[bb....bb][cc....cc][dd....dd][ee....ee]
エラーが発生しました。
aa....aa：メッセージID
bb....bb：メッセージの可変情報0
cc....cc：メッセージの可変情報1
dd....dd：メッセージの可変情報2
ee....ee：メッセージの可変情報3
(Ｓ)処理を終了します。
[対策]保守員に連絡してください。
KFPJ20002-E
Statement is closed.
Statementインスタンスが既にクローズされているため，処理を受け付けられません。
(Ｓ)SQLExceptionをthrowします。
[対策]Statementインスタンスを生成し直して，再度実行してください。
KFPJ20003-E
Failed character convert.
文字データのUnicode変換でエラーが発生しました。
(Ｓ)SQLExceptionをthrowします。
[対策]Java実行環境の文字列変換ライブラリに問題がある可能性があります。JDKのバージョンなど，Java実行環境に問題がないか確認してください。
KFPJ20004-E
Unable to read stream.
入力ストリームからの読み込みに失敗しました。
(Ｓ)SQLExceptionをthrowします。
[対策]PreparedStatementクラスのsetXXXメソッドで指定した，入力ストリームの内容を見直してください。
KFPJ20005-E
Unable to write stream.
出力ストリームへの書き込みに失敗しました。
(Ｓ)SQLExceptionをthrowします。
[対策]メモリ不足の可能性があるため，ほかのアプリケーションを終了させてから，UAPを再度実行してください。
KFPJ20006-E
Connection is closed.
Connectionインスタンスが既にクローズされているため，処理を受け付けられません。
(Ｓ)SQLExceptionをthrowします。
[対策]Connectionインスタンスを生成し直して，再度実行してください。
KFPJ20007-E
Number format exception.
データベースから取得したデータが数値でないため，使用したResultSetクラスのgetXXXメソッドではデータを取得できません。
(Ｓ)SQLExceptionをthrowします。
[対策]データ型に対応するResultSetクラスのgetXXXメソッドを使用してください。
KFPJ20008-E
Set number is overflow to server.
PreparedStatementクラスのsetDoubleメソッドで指定したデータの，メインフレーム形式への変換でオーバフローが発生しました。
(Ｓ)SQLExceptionをthrowします。
[対策]PreparedStatementクラスのsetDoubleメソッドで指定したデータの内容を見直してください。
KFPJ20009-E
Not support method. METHOD:aa....aa
aa....aaのメソッドは使用できません。
aa....aa：メソッド名称
(Ｓ)SQLExceptionをthrowします。
[対策]aa....aaのメソッド呼び出しをしないようにしてください。
KFPJ20010-E
Unable to execute BACTH SQL returned ResultSet or OUT parameters. SQL:aa....aa
aa....aaのSQLは結果セット又は出力パラメタを返却するため，バッチ処理では実行できません。
aa....aa：SQL文
(Ｓ)BatchUpdateExceptionをthrowします。
[対策]指定したSQL文を見直してください。
KFPJ20011-E
Not support fetch direction. DIRECTION:aa....aa
setFetchDirectionメソッドで指定したaa....aaは無効です（ResultSet.FETCH_FORWARD以外の検索方向は使用できません）。
aa....aa：setFetchDirectionメソッドで指定した値
(Ｓ)SQLExceptionをthrowします。
[対策]ResultSet.FETCH_FORWARDを指定してください。
KFPJ20012-E
Invalid fetch size. SIZE:aa....aa
setFetchSizeメソッドで指定した引数の内容aa....aaに，次のどちらかの誤りがあります。
・引数が0未満です。
・setMaxRowsメソッドの指定値が1以上の場合に，setFetchSizeメソッドの指定値がsetMaxRowsメソッドの指定値よりも大きいです。
aa....aa：setFetchSizeメソッドで指定した引数の内容
(Ｓ)SQLExceptionをthrowします。
[対策]指定した引数の内容を見直してください。
KFPJ20013-E
DBAccess version unmatch. VERSION-ID:aa....aa
アクセスしているデータベースのバージョンが古いです。
aa....aa：アクセスしているデータベースのバージョンコード
(Ｓ)SQLExceptionをthrowします。
[対策]保守員に連絡してください。
KFPJ20014-E
Invalid HiRDB_for_Java_SQL_IN_NUM. VALUE:aa....aa
プロパティのHiRDB_for_Java_SQL_IN_NUMの内容が不正です。
aa....aa：HiRDB_for_Java_SQL_IN_NUMで指定した内容
(Ｓ)SQLExceptionをthrowします。
[対策]次の指定値を見直してください。
・DB接続時に指定したプロパティのHiRDB_for_Java_SQL_IN_NUMの指定値
・Java起動時に指定したシステムプロパティのHiRDB_for_Java_SQL_IN_NUMの指定値
・接続情報設定メソッドのsetSQLInNumの指定値
KFPJ20015-E
Invalid HiRDB_for_Java_SQL_OUT_NUM. VALUE:aa....aa
プロパティのHiRDB_for_Java_SQL_OUT_NUMの内容が不正です。
aa....aa：HiRDB_for_Java_SQL_OUT_NUMで指定した内容
(Ｓ)SQLExceptionをthrowします。
[対策]次の指定値を見直してください。
・DB接続時に指定したプロパティのHiRDB_for_Java_SQL_OUT_NUMの指定値
・Java起動時に指定したシステムプロパティのHiRDB_for_Java_SQL_OUT_NUMの指定値
・接続情報設定メソッドのsetSQLOutNumの指定値
KFPJ20016-E
Invalid HiRDB_for_Java_SQLWARNING_LEVEL. VALUE:aa....aa
プロパティのHiRDB_for_Java_SQLWARNING_LEVELの内容が不正です。
aa....aa：HiRDB_for_Java_SQLWARNING_LEVELで指定した内容
(Ｓ)SQLExceptionをthrowします。
[対策]次の指定値を見直してください。
・DB接続時に指定したプロパティのHiRDB_for_Java_SQLWARNING_LEVELの指定値
・接続情報設定メソッドのsetSQLWarningLevelの指定値
KFPJ20017-E
Invalid HiRDB_for_Java_CLEAR_ENV VALUE:aa....aa
プロパティのHiRDB_for_Java_CLEAR_ENVの内容が不正です。
aa....aa：HiRDB_for_Java_CLEAR_ENVで指定した内容
(Ｓ)SQLExceptionをthrowします。
[対策]次の指定値を見直してください。
・DB接続時に指定したプロパティのHiRDB_for_Java_CLEAR_ENVの指定値
・URL内のCLEAR_ENVの指定値
KFPJ20101-E
Unable to register driver.
ドライバマネジャへの登録に失敗しました。
(Ｓ)SQLExceptionをthrowします。
[対策]Java実行環境のJDBCインタフェースライブラリに問題がある可能性があります。JDKのバージョンなど，Java実行環境に問題がないか確認してください。
KFPJ20102-E
Invalid protocol name.
URLで指定したプロトコル名称が不正です。
(Ｓ)SQLExceptionをthrowします。
[対策]URLで指定したプロトコル名称を見直してください。
KFPJ20103-E
Invalid subprotocol name.
URLで指定したサブプロトコル名称が不正です。
(Ｓ)SQLExceptionをthrowします。
[対策]URLで指定したサブプロトコル名称を見直してください。
KFPJ20104-E
Invalid host name.
URLで指定したホスト名が不正です。
(Ｓ)SQLExceptionをthrowします。
[対策]URLで指定したホスト名を見直してください。
KFPJ20105-E
Invalid port number.
URLで指定したポート番号が不正です。
(Ｓ)SQLExceptionをthrowします。
[対策]URLで指定したポート番号を見直してください。
KFPJ20106-E
Invalid DB.
URLで指定したデータベース種別が不正です。
(Ｓ)SQLExceptionをthrowします。
[対策]URLで指定したデータベース種別を見直してください。
KFPJ20107-E
Invalid DBID.
URLで指定した接続付加情報が不正です。
(Ｓ)SQLExceptionをthrowします。
[対策]URLで指定した接続付加情報を見直してください。
KFPJ20108-E
Invalid DBENV.
URLで指定したデータベース定義情報が不正です。
(Ｓ)SQLExceptionをthrowします。
[対策]URLで指定した接続先データベース定義情報を見直してください。
KFPJ20202-E
Not support LangID. LangID:aa....aa
HiRDBクライアントから渡された言語モードは使用できません。
aa....aa：言語モード名
(Ｓ)SQLExceptionをthrowします。
[対策]HiRDBクライアントの言語モードを見直してください。
KFPJ20204-E
Active statement over.
一度にオープンできるステートメントの上限を超えました。
(Ｓ)SQLExceptionをthrowします。
[対策]使用しているStatement又はResultSetのインスタンスをクローズして，再度実行してください。
KFPJ20205-E
Current Connection is XA mode.
The method is invalid. METHOD:aa....aa
現在のコネクションがXAモードのため，aa....aaのメソッド呼び出しは無効です。
aa....aa：メソッド名
(Ｓ)SQLExceptionをthrowします。
[対策]aa....aaのメソッド呼び出しをしないようにしてください。
KFPJ20206-W
Not support TYPE_SCROLL_SENSITIVE ResultSet type.Changed ResultSet type:aa....aa
更新内容が反映されてスクロールができる結果セットのタイプは使用できないため，aa....aaのタイプの結果セットに変更しました。
aa....aa：変更後の結果セットのタイプ
(Ｓ)SQLWarningを設定します。
KFPJ20207-W
Not support CONCUR_UPDATABLE ResultSet concurrency.
Changed ResultSet concurrency:aa....aa
更新できる結果セットは使用できないため，aa....aaの結果セットに変更しました。
aa....aa：変更後の結果セット
(Ｓ)SQLWarningを設定します。
KFPJ20208-E
Invalid ResultSet type. TYPE:aa....aa
指定した結果セットのスクロールタイプaa....aaが不正です。
aa....aa：結果セットのスクロールタイプ
(Ｓ)SQLExceptionをthrowします。
[対策]結果セットのスクロールタイプを見直してください。
KFPJ20209-E
Invalid ResultSet concurrency. CONCURRENCY:aa....aa
指定した結果セットの並行処理タイプaa....aaが不正です。
aa....aa：結果セットの並行処理タイプ
(Ｓ)SQLExceptionをthrowします。
[対策]結果セットの並行処理タイプを見直してください。
KFPJ20210-E
Invalid Escape Syntax.
指定されたSQLのエスケープ句が不正です。
(Ｓ)SQLExceptionをthrowします。
[対策]正しいSQLを指定してください。
KFPJ20211-E
Not User Id.
ユーザIDを指定していません。
(Ｓ)SQLExceptionをthrowします。
[対策]ユーザIDを指定してください。
KFPJ20301-E
Not support cancel.
現在接続しているデータベースは，非同期キャンセルが使用できません。
(Ｓ)SQLExceptionをthrowします。
[対策]非同期キャンセルを使用しないでください。
KFPJ20302-E
Invalid max rows. MAX ROWS:aa....aa
setMaxRowsで指定した最大検索行数の値aa....aaが不正です。
aa....aa：setMaxRowsで指定した最大検索行数の値
(Ｓ)SQLExceptionをthrowします。
[対策]最大検索行数の値を見直してください。
KFPJ20303-E
Invalid SQL statement.
指定したSQLはnull又は長さが0です
(Ｓ)SQLExceptionをthrowします。
[対策]正しいSQLを指定してください。
KFPJ20304-E
Unable to set timeout.
タイムアウト値の設定に失敗しました。
(Ｓ)SQLExceptionをthrowします。
[対策]タイムアウト値を見直してください。
KFPJ20305-E
Unable to set max field size.
最大フィールド長の設定に失敗しました。
(Ｓ)SQLExceptionをthrowします。
[対策]最大フィールド長を見直してください。
KFPJ20401-E
Not support boolean(SQL BIT) parameter.
boolean型（SQL BIT型）のパラメタは使用できません。
(Ｓ)SQLExceptionをthrowします。
[対策]boolean型（SQL BIT型）のパラメタを使用しないでください。
KFPJ20402-E
Not support byte(SQL TINYINT) parameter.
byte型（SQL TINYINT型）のパラメタは使用できません。
(Ｓ)SQLExceptionをthrowします。
[対策]byte型（SQL TINYINT型）のパラメタを使用しないでください。
KFPJ20403-E
Not support long(SQL BIGINT) parameter.
long型（SQL BIGINT型）パラメタは使用できません。
(Ｓ)SQLExceptionをthrowします。
[対策]long型（SQL BIGINT型）パラメタを使用しないでください。
KFPJ20405-E
Not support Object parameter.
Object型のパラメタは使用できません。
(Ｓ)SQLExceptionをthrowします。
[対策]Object型のパラメタを使用しないでください。
KFPJ20406-E
Not support Ref(SQL REF) parameter.
Ref型（SQL REF型）のパラメタは使用できません。
(Ｓ)SQLExceptionをthrowします。
[対策]Ref型（SQL REF型）のパラメタを使用しないでください。
KFPJ20407-E
Not support Array(SQL ARRAY) parameter.
Array型（SQL ARRAY型）のパラメタは使用できません。
(Ｓ)SQLExceptionをthrowします。
[対策]Array型（SQL ARRAY型）のパラメタを使用しないでください。
KFPJ20408-E
Not support NULL parameter for SQL STRUCT.
SQL STRUCT型に対するNULLパラメタは使用できません。
(Ｓ)SQLExceptionをthrowします。
[対策]SQL STRUCT型にはNULLパラメタを使用しないでください。
KFPJ20409-E
Unable to execute bacth update.
複数行の？パラメタは使用できないため，バッチ更新は実行できません。
(Ｓ)BatchUpdateExceptionをthrowします。
[対策]バッチ更新をする場合，複数行の？パラメタは使用しないでください。
KFPJ20410-E
Not support this SQL type. TYPE:aa....aa
aa....aaのデータ型のパラメタは設定できません。
aa....aa：データ型
(Ｓ)SQLExceptionをthrowします。
[対策]aa....aaのデータ型のパラメタを設定しないでください。
KFPJ20411-E
Not set parameter. INDEX:aa....aa
aa....aa番目のパラメタが設定されていません。
aa....aa：パラメタの列番号
(Ｓ)SQLExceptionをthrowします。
[対策]aa....aa番目のパラメタの設定をしてください。
KFPJ20412-E
Invalid parameter.
パラメタの内容が不正です。
(Ｓ)SQLExceptionをthrowします。
[対策]パラメタの内容を見直してください。
KFPJ20413-E
Invalid parameter index. INDEX:aa....aa
パラメタインデクスの内容が不正です。
aa....aa：パラメタインデクスの内容
(Ｓ)SQLExceptionをthrowします。
[対策]パラメタインデクスの内容を見直してください。
KFPJ20414-E
Not set parameters for batch.
addBatchメソッドの呼び出しで，バッチ実行用のパラメタが設定されていません。
(Ｓ)SQLExceptionをthrowします。
[対策]setXXXメソッドでバッチ実行用のパラメタを設定してから，addBatchメソッドを呼び出すように修正してください。
KFPJ20415-E
Not support Blob(SQL BLOB) parameter.
Blob型（SQL BLOB型）のパラメタは使用できません。
(Ｓ)SQLExceptionをthrowします。
[対策]Blob型（SQL BLOB型）のパラメタを使用しないでください。
KFPJ20416-E
Not support Clob(SQL CLOB) parameter.
Clob型（SQL CLOB型）のパラメタは使用できません。
(Ｓ)SQLExceptionをthrowします。
[対策]Clob型（SQL CLOB型）のパラメタを使用しないでください。
KFPJ20417-E
Model of the JAVA_OBJECT is not able to be transformed to SQL type.
JAVA_OBJECTを指定したSQLタイプに変換できません。
(Ｓ)SQLExceptionをthrowします。
[対策]変換できるSQLタイプを指定してください。又は，SQLタイプに対応したJAVA_OBJECTを指定してください。
KFPJ20418-E
Invalid object type of value of an array parameter.
繰返し列のパラメタに指定した，値のオブジェクトタイプが不正です。
(Ｓ)SQLExceptionをthrowします。
[対策]変換できるSQLタイプを指定してください。又は，SQLタイプに対応したJAVA_OBJECTを指定してください。
KFPJ20419-E
Invalid precision of value of an array parameter.
繰返し列のパラメタに指定した，値の精度が不正です。
(Ｓ)SQLExceptionをthrowします。
[対策]値の精度を正しくしてください。
KFPJ20420-E
Invalid value of an array parameter.
繰返し列のパラメタに指定した値が不正です。
(Ｓ)SQLExceptionをthrowします。
[対策]値を正しくしてください。
KFPJ20421-E
When determining precision or scale of value specified to be an array parameter, the arithmetic operation exception occurred.
繰返し列のパラメタに指定した値の，精度と位取りを調整したときに算術演算例外が発生しました。
(Ｓ)SQLExceptionをthrowします。
[対策]値を正しくしてください。
KFPJ20422-E
When get data from array object, a throw of the java.sql.SQLException was carried out. TraceInfo = aa....aa
Arrayオブジェクトからデータを取得するときに，java.sql.SQLExceptionがthrowされました。
aa....aa：スタックトレース
(Ｓ)SQLExceptionをthrowします。
[対策]スタックトレースから原因を特定し，対策してください。
KFPJ20423-E
Value of getBaseType method in Array object and object type of getArray method in Array object is not agreement.
Arrayオブジェクトが返す配列要素のタイプと，配列要素のオブジェクトの形式が不一致です。
(Ｓ)SQLExceptionをthrowします。
[対策]Arrayオブジェクトが返す配列要素のタイプと，配列要素のオブジェクトの形式を一致させてください。
KFPJ20424-E
Value of getBaseType method in Array object is not support.
Arrayオブジェクトが返す配列要素のタイプはサポートしていません。
(Ｓ)SQLExceptionをthrowします。
[対策]サポートしている配列要素のタイプを使用してください。
KFPJ20425-E
Specified column is not an array column, so a getArray method of ResultSet class cannot be used.
指定した列は繰返し列でないため，ResultSetクラスのgetArrayメソッドでは取得できません。
(Ｓ)SQLExceptionをthrowします。
[対策]列のデータ型に対応するResultSetクラスのgetXXXメソッドを指定してください。
KFPJ20426-E
Invalid number of index.
java.sql.Array.getArray，又はjava.sql.Array.getResultSetで指定したインデクスが不正です。
(Ｓ)SQLExceptionをthrowします。
[対策]java.sql.Array.getArray，又はjava.sql.Array.getResultSetで指定したインデクスを正しくしてください。
KFPJ20427-E
Invalid number of start position.
java.sql.Blob.getBytes，又はjava.sql.Blob.positionで指定した開始位置の値が不正です。
(Ｓ)SQLExceptionをthrowします。
[対策]java.sql.Blob.getBytes，又はjava.sql.Blob.positionで指定した開始位置の値を正しくしてください。
KFPJ20428-E
Invalid number of length.
java.sql.Blob.getBytesで指定した，操作対象となる長さの値が不正です。
(Ｓ)SQLExceptionをthrowします。
[対策]java.sql.Blob.getBytesで指定した，操作対象となる長さの値を正しくしてください。
KFPJ20429-E
Max length over of pattern data.
java.sql.Blob.positionで指定した，検索対象のバイト配列の大きさが最大値を超えました。
(Ｓ)SQLExceptionをthrowします。
[対策]java.sql.Blob.positionで指定した，検索対象のバイト配列の大きさを正しくしてください。
KFPJ20430-E
When decimal data were adapt table definition, the omission of data occurred.
DECIMAL型のデータを表定義の属性に合わせるときに，データの切り捨てが発生しました。
(Ｓ)SQLExceptionをthrowします。
[対策]DECIMAL型のデータを見直してください。
KFPJ20431-E
Data is the value besides the range of a column attribute or the form which cannot be used. DataType:aa....aa
データが列属性の範囲外の値であるか，又は使用できない形式となっています。
aa....aa：表定義の属性
(Ｓ)SQLExceptionをthrowします。
[対策]データを見直してください。
KFPJ20501-E
CallableStatement is closed.
CallableStatementインスタンスが既にクローズされているため，処理を受け付けられません。
(Ｓ)SQLExceptionをthrowします。
[対策]CallableStatement インスタンスを生成し直して，再度実行してください。
KFPJ20502-E
Unable to get data aa....aa
指定した列のデータは，CallableStatementクラスのgetXXXメソッドでは取得できません。
aa....aa：指定した列のデータ
(Ｓ)SQLExceptionをthrowします。
[対策]列のデータ型に対応するCallableStatementクラスのgetXXXメソッドを指定してください。
KFPJ20503-E
Invalid number of get scale.
CallableStatementクラスのgetBigDecimalメソッドで指定したscaleの内容が不正です。
(Ｓ)SQLExceptionをthrowします。
[対策]scaleの内容を見直してください。
KFPJ20504-E
Invalid parameter index. INDEX:aa....aa
パラメタインデクスの内容が不正です。
aa....aa：パラメタインデクスの内容
(Ｓ)SQLExceptionをthrowします。
[対策]パラメタインデクスの内容を見直してください。
KFPJ20505-E
Attribute that designated it with IN and OUT differs.
パラメタに指定したINとOUTの属性が異なります。
(Ｓ)SQLExceptionをthrowします。
[対策]属性を見直してください。
KFPJ20506-E
Output attribute is not able to acquire information because it does not exist in a parameter.
パラメタにOUT指定がないため，情報は取得できません。
(Ｓ)SQLExceptionをthrowします。
[対策]次の点を確認してください。
・実行するJavaストアドプロシジャにOUT指定のパラメタがあるかどうか確認してください。OUT指定のパラメタが必要な場合，OUT指定のパラメタを追加して，Javaストアドプロシジャを再作成してください。
・実行するJavaストアドプロシジャが誤っていないか確認してください。意図したJavaストアドプロシジャを実行するようにUAPを修正してください。
・UAPの処理の流れに誤りがないか確認してください。正しい処理の流れになるようにUAPを修正してください。
KFPJ20601-E
Unable to get number of result columns.
ResultSetクラスのgetXXXメソッドで指定した列名の内容が不正です。
(Ｓ)SQLExceptionをthrowします。
[対策]列名の内容を見直してください。
KFPJ20604-E
Unable to get data string.
指定した列のデータは，ResultSetクラスのgetStringメソッドでは取得できません。
(Ｓ)SQLExceptionをthrowします。
[対策]列のデータ型に対応するResultSetクラスのgetXXXメソッドを指定してください。
KFPJ20605-E
Unable to get data boolean.
指定した列のデータは，ResultSetクラスのgetBooleanメソッドでは取得できません。
(Ｓ)SQLExceptionをthrowします。
[対策]列のデータ型に対応するResultSetクラスのgetXXXメソッドを指定してください。
KFPJ20606-E
Unable to get data byte.
指定した列のデータは，ResultSetクラスのgetByteメソッドでは取得できません。
(Ｓ)SQLExceptionをthrowします。
[対策]列のデータ型に対応するResultSetクラスのgetXXXメソッドを指定してください。
KFPJ20607-E
Unable to get data short.
指定した列のデータは，ResultSetクラスのgetShortメソッドでは取得できません。
(Ｓ)SQLExceptionをthrowします。
[対策]列のデータ型に対応するResultSetクラスのgetXXXメソッドを指定してください。
KFPJ20608-E
Unable to get data int.
指定した列のデータは，ResultSetクラスのgetIntメソッドでは取得できません。
(Ｓ)SQLExceptionをthrowします。
[対策]列のデータ型に対応するResultSetクラスのgetXXXメソッドを指定してください。
KFPJ20609-E
Unable to get data long.
指定した列のデータは，ResultSetクラスのgetLongメソッドでは取得できません。
(Ｓ)SQLExceptionをthrowします。
[対策]列のデータ型に対応するResultSetクラスのgetXXXメソッドを指定してください。
KFPJ20610-E
Unable to get data float.
指定した列のデータは，ResultSetクラスのgetFloatメソッドでは取得できません。
(Ｓ)SQLExceptionをthrowします。
[対策]列のデータ型に対応するResultSetクラスのgetXXXメソッドを指定してください。
KFPJ20611-E
Unable to get data double.
指定した列のデータは，ResultSetクラスのgetDoubleメソッドでは取得できません。
(Ｓ)SQLExceptionをthrowします。
[対策]列のデータ型に対応するResultSetクラスのgetXXXメソッドを指定してください。
KFPJ20612-E
Unable to get data BigDecimal.
指定した列のデータは，ResultSetクラスのgetBigDecimalメソッドでは取得できません。
(Ｓ)SQLExceptionをthrowします。
[対策]列のデータ型に対応するResultSetクラスのgetXXXメソッドを指定してください。
KFPJ20613-E
Unable to get data bytes.
指定した列のデータは，ResultSetクラスのgetBytesメソッドでは取得できません。
(Ｓ)SQLExceptionをthrowします。
[対策]列のデータ型に対応するResultSetクラスのgetXXXメソッドを指定してください。
KFPJ20614-E
Unable to get data Date.
指定した列のデータは，ResultSetクラスのgetDateメソッドでは取得できません。
(Ｓ)SQLExceptionをthrowします。
[対策]列のデータ型に対応するResultSetクラスのgetXXXメソッドを指定してください。
KFPJ20615-E
Unable to get data Time.
指定した列のデータは，ResultSetクラスのgetTimeメソッドでは取得できません。
(Ｓ)SQLExceptionをthrowします。
[対策]列のデータ型に対応するResultSetクラスのgetXXXメソッドを指定してください。
KFPJ20616-E
Unable to get data Timestamp.
指定した列のデータは，ResultSetクラスのgetTimestampメソッドでは取得できません。
(Ｓ)SQLExceptionをthrowします。
[対策]列のデータ型に対応するResultSetクラスのgetXXXメソッドを指定してください。
KFPJ20617-E
Unable to get ascii stream.
指定した列のデータは，ResultSetクラスのgetAsciiStreamメソッドでは取得できません。
(Ｓ)SQLExceptionをthrowします。
[対策]列のデータ型に対応するResultSetクラスのgetXXXメソッドを指定してください。
KFPJ20618-E
Unable to get unicode stream.
指定した列のデータは，ResultSetクラスのgetUnicodeStreamメソッドでは取得できません。
(Ｓ)SQLExceptionをthrowします。
[対策]列のデータ型に対応するResultSetクラスのgetXXXメソッドを指定してください。
KFPJ20619-E
Unable to get binary stream.
指定した列のデータは，ResultSetクラスのgetBinaryStreamメソッドでは取得できません。
(Ｓ)SQLExceptionをthrowします。
[対策]列のデータ型に対応するResultSetクラスのgetXXXメソッドを指定してください。
KFPJ20621-E
ResultSet or Statement is closed.
ResultSet又はStatementインスタンスが既にクローズされているため，処理を受け付けられません。
(Ｓ)SQLExceptionをthrowします。
[対策]ResultSetインスタンスを生成し直して，再度実行してください。
KFPJ20622-E
Unable to get character stream.
指定した列のデータは，ResultSetクラスのgetCharacterStreamメソッドでは取得できません。
(Ｓ)SQLExceptionをthrowします。
[対策]列のデータ型に対応するResultSetクラスのgetXXXメソッドを指定してください。
KFPJ20627-E
Invalid number of get column index.
ResultSetクラスのgetXXXメソッドで指定したインデクス又はカラムの名称が不正です。
(Ｓ)SQLExceptionをthrowします。
[対策]インデクス又はカラムの名称を見直してください。
KFPJ20629-E
Invalid number of get scale.
ResultSetクラスのgetBigDecimalメソッドで指定したscaleの内容が不正です。
(Ｓ)SQLExceptionをthrowします。
[対策]scaleの内容を見直してください。
KFPJ20630-E
Date format exception.
データベースから取得したデータが日付データの形式に合わないため，使用したResultSetクラスのgetXXXメソッドではデータを取得できません。
(Ｓ)SQLExceptionをthrowします。
[対策]データ型に対応するResultSetクラスのgetXXXメソッドを指定してください。
KFPJ20631-E
Time format exception.
データベースから取得したデータが時間データの形式に合わないため，使用したResultSetクラスのgetXXXメソッドではデータを取得できません。
(Ｓ)SQLExceptionをthrowします。
[対策]データ型に対応するResultSetクラスのgetXXXメソッドを指定してください。
KFPJ20632-E
Timestamp format exception.
データベースから取得したデータがTimestampデータの形式に合わないため，使用したResultSetクラスのgetXXXメソッドではデータを取得できません。
(Ｓ)SQLExceptionをthrowします。
[対策]データ型に対応するResultSetクラスのgetXXXメソッドを指定してください。
KFPJ20633-E
Current ResultSet is TYPE_FORWARD_ONLY.The method is invalid. METHOD:aa....aa
現在の結果セットは順方向専用型であるため，aa....aaのメソッド呼び出しは無効となります。
aa....aa：メソッド名称
(Ｓ)SQLExceptionをthrowします。
[対策]aa....aaのメソッド呼び出しをしないでください。
KFPJ20634-E
Not support CONCUR_UPDATABLE ResultSet concurrency.The method is invalid. METHOD:aa....aa
更新する結果セットは使用できないため，aa....aaのメソッド呼び出しは無効となります。
aa....aa：メソッド名称
(Ｓ)SQLExceptionをthrowします。
[対策]aa....aaのメソッド呼び出しをしないでください。
KFPJ20635-E
Zero is designated to the row.
rowに0を指定しています。
(Ｓ)SQLExceptionをthrowします。
[対策]rowに0を指定しないでください。
KFPJ20636-E
Row that was designated without existing.
行がない結果セットに対して操作をしました。
(Ｓ)SQLExceptionをthrowします。
[対策]行がない結果セットに対しては，操作しないでください。
KFPJ20637-E
Unable to get data BLOB.
指定した列のデータは，ResultSetクラスのgetBlobメソッドでは取得できません。
(Ｓ)SQLExceptionをthrowします。
[対策]列のデータ型に対応したResultSetクラスのgetXXXメソッドを使用してください。
KFPJ20701-E
Invalid column index. INDEX:aa....aa
ResultSetMetaDataクラスのgetXXXメソッドで指定したインデクスの内容が不正です。
aa....aa：インデクスの内容
(Ｓ)SQLExceptionをthrowします。
[対策]SQLExceptionを見直してエラーの原因を取り除いてください。
KFPJ31002-E
Not found native library.
ネイティブライブラリのロードに失敗しました。
(Ｓ)SQLExceptionをthrowします。
[対策]ネイティブライブラリがシステム標準のライブラリディレクトリにあるか確認してください。
KFPJ50001-E
Argument is null.
接続情報設定用メソッドに指定した引数の内容がナル値になっています。
(Ｓ)SQLExceptionをthrowします。
[対策]引数の内容を見直してください。
KFPJ50002-E
Mandatory property no set. PROPERTY:aa....aa
必要な接続情報aa....aaが設定されていません。
aa....aa：接続情報
(Ｓ)SQLExceptionをthrowします。
[対策]aa....aaの接続情報を設定してください。
KFPJ50003-E
Invalid LoginTimeout. VALUE:aa....aa
setLoginTimeoutメソッドの指定値aa....aaが不正です。
aa....aa：setLoginTimeoutメソッドの指定値
(Ｓ)SQLExceptionをthrowします。
[対策]指定値を見直してください。
KFPJ50004-E
Invalid NetworkProtocol. VALUE:aa....aa
setNetworkProtocolメソッドの指定値aa....aaが不正です。
aa....aa：setNetworkProtocolメソッドの指定値
(Ｓ)SQLExceptionをthrowします。
[対策]指定値を見直してください。
KFPJ50005-E
Invalid PortNumber. VALUE:aa....aa
setPortNumberメソッドの指定値aa....aaが不正です。
aa....aa：setPortNumberメソッドの指定値
(Ｓ)SQLExceptionをthrowします。
[対策]指定値を見直してください。
KFPJ50006-E
Invalid DatabaseName. VALUE:aa....aa
setDatabaseNameメソッドの指定値aa....aaが不正です。
aa....aa：setDatabaseNameメソッドの指定値
(Ｓ)SQLExceptionをthrowします。
[対策]指定値を見直してください。
KFPJ50007-E
Invalid DBEnv. VALUE:aa....aa
setDBEnvメソッドの指定値aa....aaが不正です。
aa....aa：setDBEnvメソッドの指定値
(Ｓ)SQLExceptionをthrowします。
[対策]指定値を見直してください。
KFPJ50008-E
Encoding Lang is null.
エンコードが指定されていません。
(Ｓ)SQLExceptionをthrowします。
[対策]エンコード文字列を見直してください。
KFPJ50009-E
Invalid Description. VALUE:aa....aa
setDescriptionメソッドの指定値aa....aaが不正です。
aa....aa：setDescriptionメソッドの指定値
(Ｓ)SQLExceptionをthrowする。
[対策]指定値を見直してください。
KFPJ55001-E
Current connection is not XA mode.The getXAResource method is invalid.
コネクションがXAモードではないため，getXAResourceメソッド呼び出しは無効となります。
(Ｓ)SQLExceptionをthrowします。
[対策]getXAResourceメソッドの呼び出しをしないでください。
KFPJ55002-E
Current NetworkProtocol is not NativeLibrary mode.The getXAResource method is invalid.
接続種別がネイティブライブラリ接続ではないため，getXAResourceメソッド呼び出しは無効となります。
(Ｓ)SQLExceptionをthrowします。
[対策]接続種別をネイティブライブラリ接続に変更してください。
KFPJ56001-E
XA Session is closed.
XAセッションがクローズされているため，XA処理を受け付けられません。
(Ｓ)XAExceptionをthrowします。
[対策]再度XAConnectionインスタンスを生成して，getXAResourceメソッドでXAResourceインスタンスを取得し直してから，再度実行してください。
KFPJ56002-E
XID is null.
XID引数の内容がナル値です。
(Ｓ)XAException をthrowします。
[対策]XID引数の内容を見直してください。
KFPJ70001-I
SQL process is canceled.
SQL処理をキャンセルしました。
(Ｓ)SQLExceptionをthrowします。
KFPJ70002-E
Transaction is completed.
既にトランザクションがコミット又はロールバックされているため，処理を受け付けられません。
(Ｓ)SQLExceptionをthrowします。
[対策]ResultSetインスタンスをクローズして，再度実行してください。
KFPJ70003-E
Not support SQL type exist in result. TYPE:aa....aa
SQLの実行結果に使用できないデータ型があります。
aa....aa：使用できないデータ型
(Ｓ)SQLExceptionをthrowします。
[対策]SQL，及び検索対象となる表中のデータ型を見直してください。
KFPJ99001-E
DBA Internal Error. Return Code = aa....aa, Detail Code = bb....bb,Message = cc....cc
データベースアクセスセクションで内部エラーが発生しました。
aa....aa：データベースアクセスセクション内のリターンコード
bb....bb：データベースアクセスセクション内の詳細コード
cc....cc：データベースアクセスセクション内のメッセージ
(Ｓ)SQLExceptionをthrowします。
[対策]保守員に連絡してください。


KFPKメッセージ

KFPK00001-E
aaaaaaaa: file not found, file_kind:bb....bb file_name:cc....cc　　（Ｅ）
指定したファイル又はユティリティが一時的に作成したファイルがありません。指定したディレクトリ下に解析できるファイルがありません。
aaaaaaaa：ユティリティ種別
Pdstedit：統計解析ユティリティ
bb....bb：ファイル種別
control file：制御文ファイル
sort data file：ソート用ワークファイル
unload log file：アンロードログファイル
cc....cc：ファイル名，又はディレクトリ名
(Ｓ)処理を終了します。
(Ｏ)ファイル種別によって，次に示す処置をしてください。
〈unload log file，及びcontrol fileの場合〉
ファイル名を確認してコマンドを再度入力してください。file_nameがディレクトリ名の場合は，ディレクトリ下のファイルを確認して，コマンドを再度入力してください。
〈sort data fileの場合〉
ユティリティが自動生成した一時ファイルを誤って削除していないか，確認してください。
KFPK00002-E
aa....aa: file open failed, file_kind:bb....bb file_name:cc....cc errno=dd....dd　　（Ｄ＋Ｅ）
指定したファイル又はユティリティが一時的に作成したファイルをオープンできません。
aa....aa：ユティリティ種別
Pddbst：データベース状態解析ユティリティ
Pdstedit：統計解析ユティリティ
bb....bb：ファイル種別
control file：制御文ファイル
edit work file：ワーク用ファイル
sort data file：ソート用ワークファイル
unload log file：アンロードログファイル
DAT file：DAT形式ファイル
predict csv file：CSV出力ファイル
cc....cc：ファイル名
dd....dd：openシステムコールから返却されたerrno
(Ｓ)〈標準エラー出力に出力された場合〉
処理を終了します。
〈エラーメッセージダイアログに出力された場合〉
エラーが発生する直前の画面に戻ります。
(Ｏ)〈統計解析ユティリティの場合〉
errnoを基に，errno.h及びユーザが使用するOSのマニュアルを参照してエラーの原因を取り除き，再度コマンドを実行してください。
errnoに***が表示されている場合は，直前に出力されたエラーメッセージを基に原因を調査してください。
〈データベース状態解析ユティリティの場合〉
errnoを基に，errno.h及びユーザが使用するOSのマニュアルを参照してエラーの原因を取り除き，再度コマンドを実行してください。
KFPK00003-E
aa....aa: file close failed, file_kind:bb....bb file_name:cc....cc errno=dd....dd　　（Ｄ＋Ｅ）
ファイルをクローズできません。
aa....aa：ユティリティ種別
Pddbst：データベース状態解析ユティリティ
Pdstedit：統計解析ユティリティ
bb....bb：ファイル種別
control file：制御文ファイル
edit work file：ワーク用ファイル
sort data file：ソート用ワークファイル
unload log file：アンロードログファイル
predict csv file：CSV出力ファイル
cc....cc：ファイル名
dd....dd：closeシステムコールから返却されたerrno
(Ｓ)〈標準エラー出力に出力された場合〉
処理を終了します。
〈エラーメッセージダイアログに出力された場合〉
エラーが発生する直前の画面に戻ります。
(Ｏ)〈統計解析ユティリティの場合〉
errnoを基に，errno.h及びユーザが使用するOSのマニュアルを参照してエラーの原因を取り除き，再度コマンドを実行してください。
errnoに***が表示されている場合は，直前に出力されたエラーメッセージを基に原因を調査してください。
〈データベース状態解析ユティリティの場合〉
errnoを基に，errno.h及びユーザが使用するOSのマニュアルを参照してエラーの原因を取り除き，再度コマンドを実行してください。
KFPK00004-E
aa....aa: I/O error, cause:bb....bb file_name:cc....cc errno=dd....dd　　（Ｄ＋Ｅ）
入出力エラーが発生しました。
aa....aa：ユティリティ種別
Pddbst ：データベース状態解析ユティリティ
Pdstedit：統計解析ユティリティ
bb....bb：エラーが発生したシステムコール種別
LSEEK：lseekシステムコール
READ：readシステムコール
WRITE：writeシステムコール
cc....cc：ファイル名
dd....dd：システムコールから返却されたerrno
(Ｓ)
〈標準エラー出力に出力された場合〉
処理を終了します。
〈エラーメッセージダイアログに出力された場合〉
エラーが発生する直前の画面に戻ります。
(Ｏ)
〈統計解析ユティリティの場合〉
errnoを基に，errno.h及びユーザが使用するOSのマニュアルを参照してエラーの原因を取り除き，再度コマンドを実行してください。
errnoに***が表示されている場合は，直前に出力されたエラーメッセージを基に原因を調査してください。
〈データベース状態解析ユティリティの場合〉
errnoを基に，errno.h及びユーザが使用するOSのマニュアルを参照してエラーの原因を取り除き，再度コマンドを実行してください。
KFPK00005-E
aa....aa: system call error, func=bb....bb, errno=cc....cc　　（Ｄ＋Ｅ）
システムコール（関数）でエラーが発生しました。
aa....aa：ユティリティ種別
Pddbst：データベース状態解析ユティリティ
Pdstedit：統計解析ユティリティ
bb....bb：エラーが発生したシステムコール名
cc....cc：システムコールから返却されたerrno
(Ｓ)
〈標準エラー出力に出力された場合〉
処理を終了します。
〈エラーメッセージダイアログに出力された場合〉
エラーが発生する直前の画面に戻ります。
(Ｏ)エラー番号（errno：エラー状態を表す外部整数変数）を調査し，errno.h及びユーザが使用するOSのマニュアルを参照してエラーの原因を取り除き，再度コマンドを実行してください。
KFPK00006-E
aa....aa: unrecovable error, func=bb....bb, errno=ccc　　（Ｄ＋Ｅ）
回復不能なエラーが発生しました。
aa....aa：ユティリティ種別
Pddbst：データベース状態解析ユティリティ
Pdstedit：統計解析ユティリティ
bb....bb：エラーが発生したシステムコール種別
CLOSEDIR：closedirシステムコール
CREATE：createシステムコール
DELETE：unlinkシステムコール
OPENDIR：opendirシステムコール
READDIR：readdirシステムコール
ccc：システムコールから返却されたerrno
(Ｓ)
〈標準エラー出力に出力された場合〉
処理を終了します。
〈エラーメッセージダイアログに出力された場合〉
エラーが発生する直前の画面に戻ります。
(Ｏ)エラー番号（errno：エラー状態を表す外部整数変数）を調査し，errno.h及び該当する関数が記載されているマニュアルを参照してエラーの原因を取り除き，再度コマンドを実行してください。エラー番号が***の場合は，直前に出力されているエラーメッセージを基に原因を調査してください。
KFPK00007-W
aa....aa error occurred in log element file, server_name:bb....bb file_name:cc....cc system A/B:d reason=(eee,fffff)　　（Ｅ）
システムログファイルにエラーが発生しました。
aa....aa：エラーが発生したコード
Close：クローズ処理
Open：オープン処理
Read：読み込み処理
bb....bb：ファイルグループに対応したサーバ名
cc....cc：ファイルグループ名
d：障害が発生した系
eee：理由コード
fffff：詳細コード
(Ｓ)他系のログファイルにエラーが発生していない場合，他系のログファイルを使用して処理を続行します。
(Ｏ)理由コードごとに，対策してください。理由コードと対策を次に示します。
理由
コード
意味
対策
-40
-41
-42
-43
入出力エラーが発生しました。
詳細コードと「HiRDBファイルシステムに対するアクセス要求から返されるエラーコード」のエラーコードを対応させて，エラーの原因を取り除いてください。
-50
-51
-52
-53
ファイルの内容が不正です。
次に示す原因のうち，どの原因でメッセージが出力されたを調査し，エラーの原因を取り除いて，再度コマンドを実行してください。
(1) 現用グループが指定されています。
(2) 初期化後，未使用のファイルグループが指定されています。
(3) システムログではないファイルグループが指定されています。
(4) ログファイルが破壊された可能性があります。ログファイルに関する定義の変更，初期設定，及び不正なステータスを変更していないか調査してください。
詳細コードはシステムの保守情報です。
KFPK00008-E
aa....aa error occurred in log element file, server_name:bb....bb file_name:cc....cc system A/B:d reason=(eee,fffff)　　（Ｅ）
システムログファイルにエラーが発生しました。
aa....aa：エラーが発生したコード
Close：クローズ処理
Open：オープン処理
Read：読み込み処理
bb....bb：ファイルグループに対応したサーバ名
cc....cc：ファイルグループ名
d：障害が発生した系
eee：理由コード
fffff：詳細コード
(Ｓ)処理を終了します。
(Ｏ)理由コードごとに，対策してください。
理由コードと対策を次に示します。
理由コード
意味
対策
-40
-41
-42
-43
入出力エラーが発生しました。
詳細コードと「HiRDBファイルシステムに対するアクセス要求から返されるエラーコード」のエラーコードを対応させて，エラーの原因を取り除いてください。
-50
-51
-52
-53
ファイルの内容が不正です。
ログファイルが破壊された可能性があります。ログファイルに関する定義の変更，初期設定，及び不正なステータスを変更していないか調査してください。
詳細コードはシステムの保守情報です。
KFPK00009-E
aaaaa error occurred, file=bb....bb　　（Ｅ）
ファイル入出力エラーが発生しました。
aaaaa：エラーが発生した処理
Open：オープン処理
Read：リード処理
Close：クローズ処理
bb....bb：ファイル名称
(Ｓ)処理を終了します。
(Ｏ)このメッセージに続いて出力されるメッセージを参照し，エラーの要因を取り除いて，再度実行してください。
KFPK00010-E
File I/O error occurred, reason=aa....aa, func=bb....bb, errno=cc....cc, (dd....dd)　　（Ｅ）
ファイル入出力中にエラーが発生しました。
aa....aa：エラーの原因
Invalid-parameter：指定したパラメタの組み合わせが不正です。
Invalid-permission：ファイルに対するアクセス権限がありません。
Invalid-device：ファイルのエントリタイプ（属性）が不正です。ファイル名を指定する必要がある箇所にディレクトリ名を指定したり（又はその逆），キャラクタ型スペシャルファイルが使用できないファイルにキャラクタ型スペシャルファイルを割り当てたりしている可能性があります。
File-format：ファイルフォーマットが異なります。指定したファイル名が誤っているか，又はコマンドラインや制御文に指定したファイルの形式と内容が一致していない可能性があります。
Invalid-file：正しく作成していないファイルを指定しました。
File-lock：該当するファイルは，ほかのユーザが使用しています。コマンドラインや制御文に指定したファイル名が，別のジョブで使用中のファイル名と重複しているか，又はOSのカーネルパラメタのファイルロック用資源が不足している可能性があります。
No-file：ファイルがありません。
Invalid-deviceの場合は，指定したファイルのエントリタイプが識別できるときは，英字を括弧内に入れてデバイス種別を表示します。内容はOSのls -lコマンドで表示されるモードのエントリと同じです。
bb....bb：エラーが発生した関数名
・OSがエラーを検知した場合はシステム関数名
・HiRDBファイルシステムでエラーを検知した場合はp_f_iosで始まるHiRDBファイルシステムの関数名
・上記以外の場合は「***」
cc....cc：エラーコード
・OSがエラーを検知した場合はシステム関数が返却したエラー番号（errno：エラー状態を表す外部参照変数）
・HiRDBファイルシステムでエラーを検知した場合はHiRDBファイルシステムのエラーコード（HiRDBファイルシステムのエラーコードについては，「HiRDBファイルシステムに対するアクセス要求から返されるエラーコード」を参照してください）
・上記以外のエラー要因の場合は「0」
dd....dd：トラブルシュート情報（障害を検知したソースファイル名と行番号）です。なお，これは保守員が確認する情報です。
(Ｓ)処理を終了します。
(Ｏ)エラーの理由，関数名，及びエラーコードから，errno.h，ユーザが使用するOSのマニュアル，及び「HiRDBファイルシステムに対するアクセス要求から返されるエラーコード」を参照してエラーの原因を取り除き，再度実行してください。
KFPK00011-E
HiRDB file aa....aa error, errno=bb....bb, HiRDB file name=cc....cc　　（Ｅ）
HiRDBファイルに対するアクセスエラーが発生しました。
aa....aa：アクセスエラーとなった処理
open：HiRDBファイルのオープン処理
read：HiRDBファイルからの読み込み処理
close：HiRDBファイルのクローズ処理
bb....bb：HiRDBファイルシステムのエラーコード
cc....cc：HiRDBファイル名
(Ｓ)処理を終了します。
(Ｏ)bb....bbが-1562の場合は，該当するHiRDBファイルシステム領域の種別がUTLでない可能性があります。入力に指定したHiRDBファイルシステム領域が正しいかどうか確認してください。
bb....bbが-1562以外の場合は，「HiRDBファイルシステムに対するアクセス要求から返されるエラーコード」を参照し，エラー要因を取り除いて，再度実行してください。
KFPK00012-E
aa....aa: File already exist, file_kind=bb....bb, file_name=cc....cc　　（Ｅ）
ユティリティが一時的に作成するワークファイルが既にあります。
aa....aa：ユティリティ種別
Pdstedit：統計解析ユティリティ
bb....bb：ファイル種別
sort data file：ワーク用一時ファイル
cc....cc：ファイル名
(Ｓ)処理を終了します。
(Ｏ)同じコマンドを同時に実行していないことを確認してから，cc....ccのファイルを削除し，再度コマンドを実行してください。
KFPK00013-E
aa....aa: system call error, func=bb....bb, file_name=cc....cc, errno=dd....dd　　（Ｄ＋Ｅ）
ファイルアクセスをするシステムコール（関数）でエラーが発生しました。
aa....aa：ユティリティ種別
Pdstedit：統計解析ユティリティ
Pddbst：データベース状態解析ユティリティ
bb....bb：エラーが発生したシステムコール名
cc....cc：ファイル名
dd....dd：errnoに設定したエラー番号
(Ｓ)標準エラー出力に出力された場合，処理を終了します。メッセージダイアログに出力された場合，エラー発生直前の画面に戻ります。
(Ｏ)エラー番号（errno：エラー状態を表す外部整数変数）を調査し，errno.h及び該当する関数が記載されているマニュアルを参照してエラーの原因を取り除き，再度コマンドを実行してください。
KFPK00050-E
aa....aa: insufficient memory, size=bb....bb　　（Ｄ＋Ｅ）
メモリ不足が発生しました。
aa....aa：ユティリティ種別
Pddbst：データベース状態解析ユティリティ
Pdstedit：統計解析ユティリティ
bb....bb：確保しようとしたメモリサイズ（単位：バイト）
(Ｓ)
〈標準エラー出力に出力された場合〉
処理を終了します。
〈エラーメッセージダイアログに出力された場合〉
エラーが発生する直前の画面に戻ります。
(Ｏ)大量にメモリを使用するプロセスがほかにあるか確認してください。
〈大量にメモリを使用するプロセスがある場合〉
該当するプロセスの終了を待って，再度コマンドを実行してください。
〈大量にメモリを使用するプロセスがない場合〉
次のどれかの方法で，使用できるメモリに余裕を持たせてください。
・同時実行しているプロセスの数を減らしてください。
・スワップ領域を増やしてください。
・実メモリを増設してください。
KFPK00100-E
aa....aa: interface error, func:bb....bb, return code=cccc　　（Ｄ＋Ｅ）
プログラム内の関数間でインタフェースエラーが発生しました。
aa....aa：ユティリティ種別
Pddbst：データベース状態解析ユティリティ
Pdstedit：統計解析ユティリティ
bb....bb：不正なコードを返却した関数名
cccc：詳細コード
(Ｓ)
〈標準エラー出力に出力された場合〉
処理を終了します。
〈エラーメッセージダイアログに出力された場合〉
エラーが発生する直前の画面に戻ります。
(Ｏ)HiRDB管理者へ連絡してください。
[対策]保守員へ連絡してください。
KFPK00200-I
Usage: pdstedit [-k edit_item[,edit_item]...][-m interval][-t [start_time][,end_time]][-u uap_name[,uap_name]...][-x host_name[,host_name]...][-s server_name[,server_name]...][-o dat_dir][-i unload_log][-w work_dir][-d control_file][-b] [-e extended_format[,extended_format]]　　（Ｅ）
統計解析ユティリティ（pdstedit）の使用方法を次に示します。
-b：DAT形式ファイルにタイトルバーを出力する場合に指定します。
-d：制御文ファイル名称を指定します。
-e：拡張フォーマット指定値を指定します。
-i：アンロードファイル，又はアンロードファイル格納ディレクトリを指定します。
-k：統計解析の情報種別を指定します。複数の情報種別を繰り返し指定できます。
-m：編集時間間隔を指定します。分単位で1440まで指定できます。
-o：DAT形式ファイル出力先ディレクトリ名称を指定します。
-s：サーバ名称を指定します。32個まで繰り返し指定できます。
-t：編集開始時間，又は編集終了時間を指定します。開始時間，終了時間の両方を同時に省略できません。
-u：UAP名称を指定します。16個まで繰り返し指定できます。
-x：ホスト名称を指定します。32個まで繰り返し指定できます。
-w：ワーク用ファイル作成ディレクトリ名称を指定します。
(Ｓ)処理を終了します。
(Ｏ)pdsteditのパラメタの入力が誤っていないか，確認してください。
KFPK00201-E
aa....aa: invalid parameter　　（Ｅ）
ユティリティ起動コマンドのパラメタの指定が誤っています。このメッセージは次の場合に出力します。
(1) 不正なオプションが指定されています。
aa....aa：ユティリティ種別
Pddbst：データベース状態解析ユティリティ
Pdstedit：統計解析ユティリティ
(Ｓ)処理を終了します。
(Ｏ)各ユティリティ実行時のパラメタの入力が誤っていないか，確認してください。
KFPK00202-E
aa....aa: invalid combination of options　　（Ｅ）
ユティリティ起動コマンドのオプションの組み合わせが不当です。又は，オプションと制御文の組み合わせが不正です。
aa....aa：ユティリティ種別
Pddbst：データベース状態解析ユティリティ
Pdstedit：統計解析ユティリティ
(Ｓ)処理を終了します。
(Ｏ)各ユティリティ実行時のパラメタ（コマンドライン，及び制御文）の指定値が誤っていないか，確認してください。
KFPK00203-E
aa....aa: invalid bb option　　（Ｅ）
ユティリティ起動コマンドのbbオプションの指定に誤りがあります。このメッセージは次のどれかの場合に出力します。
(1) オプションにキーが指定されていません。
(2) オプションに不正な形式でキーが指定されています。
(3) オプションに繰り返し制限を超えるキーが指定されています。
(4) オプションに制限値を超えるキーが指定されています。
(5) HiRDB Staticizer Optionの利用できない環境で-Gオプションを指定しています。
(6) 再編成時期予測機能を使用（システム定義のpd_rorg_predictオペランドにYを指定）していないのに，-e，-k pred，-m，-R，-c，又は-vオプションを指定しています。
aa....aa：ユティリティ種別
Pddbst：データベース状態解析ユティリティ
Pdstedit：統計解析ユティリティ
bb：指定誤りのオプション名
(Ｓ)処理を終了します。
(Ｏ)各ユティリティ実行時のパラメタの入力が誤っていないか，確認してください。
KFPK00204-E
Invalid attribute exists in Control file, line=aa....aa　　（Ｌ＋Ｅ）
-vオプションで指定した制御文ファイル中のaa....aa行目に不正な値を検出しました。
aa....aa：制御文の行番号
(Ｓ)処理を終了します。
(Ｏ)
pddbst実行の場合：
再編成時期予測機能を実行する場合（-k predを指定する場合），制御文の指定を確認し，指定誤りを訂正してください。その後，pddbstを再度実行してください。
上記以外の場合に-vオプションを指定しているときは，-vオプションの指定を削除して再度実行してください。
HiRDB CM実行の場合：
HiRDB管理者に連絡してください。
[対策]HiRDB CM実行中に出力された場合は保守員に連絡してください。
KFPK00205-E
Length of unload log file name exceeds bytes　　（Ｅ）
統計解析ユティリティ(pdstedit)のファイル名の指定に誤りがあります。
(Ｓ)処理を終了します。
(Ｏ)統計解析ユティリティ(pdstedit)のパラメタの入力が誤っていないか，確認してください。
KFPK00206-E
aaaaaaaa: invalid directory name, kind=bb....bb　　（Ｅ）
各ユティリティ起動コマンドで指定された各種ファイル作成ディレクトリ名称が，次に示す理由で誤っています。
1. 指定されたディレクトリがありません。
2. 指定されたディレクトリに該当するコマンド実行者の書き込み権限がありません。
3. 指定されたディレクトリ名称に値するものがディレクトリ属性を持っていません。
4. 指定されたディレクトリ名称長が128バイトを超えています。
aaaaaaaa：ユティリティ種別
Pdstedit：統計解析ユティリティ
bb....bb：ディレクトリ用途種別
DAT data file：DAT形式ファイル作成用
sort data file：ソート用ワークファイル作成用
(Ｓ)処理を終了します。
(Ｏ)各ユティリティ実行時のパラメタの入力が誤っていないか，確認してください。
KFPK00207-E
aaaaaa: unable to assume user id　　（Ｅ）
次に示す理由で，ユーザIDの省略値を仮定できません。
1. 環境変数PDUSERが定義されていません。
2. 環境変数PDUSERに定義されたユーザID，又はパスワードの長さが制限長を超えています。
3. 環境変数PDUSERに定義されたユーザID，又はパスワードに対し，引用符（"）が対になっていません。
4. 環境変数PDUSERにユーザIDが指定されていません。
aaaaaa：ユティリティ種別
Pddbst：データベース状態解析ユティリティ
(Ｓ)処理を終了します。
(Ｏ)コマンド実行時に-uオプションを省略する場合は，環境変数PDUSERに正しいユーザID，又はパスワードが指定されているか確認後，再度コマンドを実行してください。
Windows NTの場合，-uオプションを省略するときは，コマンドプロンプト上で認可識別子やパスワードを指定する文字列を「‘」で囲んでいないか，確認してください。
正しい指定例：PDUSER="root"/"root"
注　ただし，クライアント環境定義(hirdb.ini)の中では，「‘」で囲むのが正しい指定方法です。
KFPK00208-E
Invalid attribute exists in Base value file, line=aa....aa　　（Ｅ）
-cオプションで指定した基準値定義ファイル中のaa....aa行目に，次のどれかの誤りがあります。
・基準値の項目名の誤り
・解析対象指定の誤り
・指定値の記述誤り，範囲不正
aa....aa：制御文の行番号
(Ｓ)処理を終了します。
(Ｏ)基準値定義ファイルの内容を確認し，指定の誤りを訂正してから，再度実行してください。
KFPK00250-W
Invalid unload log file, file_name:aa....aa　　（Ｅ）
統計解析ユティリティ（pdsteditコマンド）の入力ファイルに誤りがあります。
●統計解析ユティリティの統計入力アンロードファイルの入力指定が，ファイル名の場合
・解析対象外のファイルタイプのファイル名が指定されています。
・アンロード統計ログファイル又はアンロードログファイル以外のファイル名が指定されています。
・パイプファイルを指定して，アンロード統計ログファイル以外のデータを書き込みました。
・32ビットモードのHiRDBに，64ビットモードのHiRDBで取得したアンロード統計ログファイル名が指定されています。
●統計解析ユティリティの統計入力アンロードファイルの入力指定が，ディレクトリ名の場合
・指定ディレクトリ下にあるファイル（aa....aa）のファイルタイプが解析対象外です。
・指定ディレクトリ下にあるファイル（aa....aa）がアンロード統計ログファイル又はアンロードログファイル以外のファイルです。
・指定ディレクトリ下にあるHiRDBファイルシステム領域内のHiRDBファイル（aa....aa）は，アンロードログファイル以外のファイルです。
・指定ディレクトリ下にあるファイル（aa....aa）が64ビットモードのHiRDBで取得したアンロード統計ログファイルです。32ビットモードのHiRDBに入力できません。
●統計解析ユティリティの統計入力アンロードファイルの入力指定が，HiRDBファイルシステム領域名の場合
・HiRDBファイルシステム領域aa....aa内にHiRDBファイルがありません。
・指定したHiRDBファイルシステム領域内にあるHiRDBファイルaa....aaは，アンロードログファイル以外のファイルです。
・指定したHiRDBファイルシステム領域のHiRDBファイルaa....aaはアンロード中です。
・指定したHiRDBファイルシステム領域に対して，read権限及びwrite権限がありません。
aa....aa：ファイル名
(Ｓ)処理を続行します。不正なファイルは編集対象外として無視します。
(Ｏ)pdsteditコマンドのオプションの指定が誤っていないかを確認してください。また，指定したHiRDBファイルシステム領域に対して，必要な権限がない場合は，read権限及びwrite権限を与えてください。
KFPK00251-E
Invalid log record, record_number:aa....aa　　（Ｅ）
ログレコードに不正があります。
aa....aa：ログレコード通番
(Ｓ)処理を終了します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]アンロードログファイル内，又はアンロード統計ログファイル内のデータが壊れていないか確認してください。
KFPK00252-E
Invalid sort data file, cause:aa....aa file_name:bb....bb　　（Ｅ）
ソート用ワークファイルが不正です。
aa....aa：エラーの理由
corrupt record：レコードが壊れています。
invalid type：ソート用ワークファイルではありません。
bb....bb：不正なソート用ワークファイル
(Ｓ)処理を終了します。
(Ｏ)pdsteditが内部的に作成するソート用ワークファイルを誤って変更していないか確認してください。
KFPK00253-E
Invalid log block, block_number:aa....aa　　（Ｅ）
ログブロックに不正があります。
aa....aa：ログブロック通番
(Ｓ)処理を終了します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]アンロードログファイル内のデータが壊れていないか確認してください。
KFPK00254-E
aa....aa : Invalid contents in file, file_kind : bb....bb file_name : cc....cc record_length=dd....dd read_length=ee....ee　　（Ｅ）
入力したファイルの内容が不正です。ファイルの内容が破壊されている可能性があります。
aa....aa：ユティリティ種別
Pdstedit：統計解析ユティリティ
bb....bb：ファイル種別
unload log file：アンロードログファイル
unload stj log file：アンロード統計ログファイル
sort data file：ソート用入出力ファイル
cc....cc：ファイル名
dd....dd：読み込もうとしたレコード長（保守情報）
ee....ee：読み込みに成功したデータ長（保守情報）
(Ｓ)処理を終了します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]
ファイル種別がunload log file，又はunload stj log fileの場合：
次の観点を基に，アンロードファイル内のデータが壊れていないか確認してください。
・ftpなどで転送する場合，アンロードファイル内のデータが壊れていないか。
・アンロードファイルを不正に更新していないか。
ファイル種別がunload log fileの場合：
cc....ccのアンロード前の統計ログファイル（OSのcpコマンド，又はpdstjacmシェルスクリプトを使用してアンロードする前の，$PDDIR/spool下に出力されたpdstj1又はpdstj2という名称の統計ログファイル）が残っている場合，cc....ccとアンロード前のファイルの内容をcmpコマンドなどによって比較し，同一であることを確認してください。
ファイル種別がunload stj log fileの場合：
cc....ccがpdlogunldコマンドで退避したアンロードログファイルの場合で，かつそのファイルに対応するpdlogunldコマンドで取得した直後のアンロードログファイルが残っている場合，その両者のファイルの内容をcmp（Windows NTの場合はfc）コマンドなどで比較し，同一であることを確認してください。
ファイル種別がsort data fileの場合：
統計解析ユティリティが内部的に作成するソート用の入出力ファイルを誤って変更していないか，次の観点を基に確認してください。
・統計解析ユティリティ実行中に，$PDDIR/tmp下，又は/usr/tmp下のファイルを削除，又は不正に更新していないか。
上記に該当しない場合，保守員に連絡してください。
KFPK00255-W
aaaaaaaa:Invalid contents in file, file_kind:bb....bb file_name:cc....cc record_length=dd....dd read_length=ee....ee　　（Ｅ）
入力したファイルの内容が不正です。ファイル内容が破壊されている可能性があります。不正レコードを検知した時点までに入力したレコードを用いて，編集処理をしてください。
aa....aa：ユティリティ種別
Pdstedit：統計解析ユティリティ
bb....bb：ファイル種別
unload log file：アンロードログファイル
unload stj log file：アンロード統計ログファイル
cc.....cc：ファイル名
dd....dd：読み込もうとしたレコード長（保守情報）
ee....ee：読み込みに成功したデータ長（保守情報）
(Ｓ)処理を続行します。
(Ｏ)HiRDB管理者に連絡してください。入力に成功したログレコードの取得時間は，入力ログファイルサマリ情報のFIRST，LASTを参照してください。
[対策]
ファイル種別がunload log file又はunload stj log fileの場合：
次の観点からアンロードログファイル内のデータが壊れていないか確認してください。
・ftpなどで転送する場合，binaryモードで転送したか確認してください。
・アンロードログファイルを不正に更新していないか確認してください。
ファイル種別がunload stj log fileの場合：
1. cc....ccのアンロード前の統計ログファイルの取得中に，統計ログファイルの出力先（$PDDIR/spool）のディスクが満杯になっていないか確認してください。
2. cc....ccのアンロード前の統計ログファイル（OSのcpコマンド又はpdstjacmシェルスクリプトを用いたアンロードをする前の，＄PDDIR/spool下にpdstjl又はpdstj2という名称で出力された統計ログファイル）が残っている場合，cc....ccとアンロード前のファイル内容をcmpコマンドなどで比較し，同一であることを確認してください。
ファイル種別がunload log fileの場合：
pdlogunldコマンドを用いて取得したアンロードログファイルを退避したものがcc....ccで，かつそのファイルに対応する，pdlogunldコマンドを用いて取得した直後のアンロードログファイルが残っている場合，その両者のファイルの内容をcmp（Windows NTの場合はfc）コマンドなどで比較し，同一であることを確認してください。
上記の項目に該当しない場合，保守員に連絡してください。
KFPK00300-I
Pdstedit terminated, return code=aa....aa　　（Ｅ）
統計解析ユティリティの実行が終了しました。
aa....aa：リターンコード
0：正常に終了しました
4：正常に終了したが警告メッセージを出力しました
8：エラーが発生したため処理を打ち切りました
12：割り込み（シグナル発生）のため処理を打ち切りました
(Ｓ)処理を終了します。
(Ｏ)
〈リターンコードが4の場合〉
処理中に出力されたメッセージの種類が，Ｗのメッセージを基に調査してください。
〈リターンコードが8の場合〉
処理中に出力されたメッセージの種類が，Eのメッセージを基に調査してください。
KFPK00301-I
Stdin assumed as input　　（Ｅ）
-iオプションが省略されたため，標準入力を利用して処理を続行しました。又は，-iオプションが省略されたため，標準入力に対する入力待ちが発生しました。このため，入力として標準入力を仮定しました。
(Ｓ)処理を続行します。
(Ｏ)標準入力を仮定して，処理を続行してもよいかどうか確認してください。処理を続行したくない場合は，次に示す方法でユティリティを終了させてください。
〈入力待ちが発生している場合〉
再度リターンキーを入力してください。
〈そのほかの場合〉
プロセスIDを指定して，killコマンド（Windows NTの場合はpdkillコマンド）を入力してください。
KFPK00400-E
Sort program error　　（Ｅ）
ソートプログラムでエラーが発生しました。
(Ｓ)処理を終了します。
(Ｏ)直前に出力されたソートプログラムのエラーメッセージを基に，原因を調査してください。エラーの原因が判断できない場合，HiRDB管理者に連絡してください。
[対策]障害を取り除いて，再度実行してください。
KFPK00901-E
Unable to make an entry SQL_DB_STATE_ANALYZED　　（Ｅ）
運用履歴表に状態解析の結果を登録できなかったため，最新のデータベース状態で再編成時期予測ができません。
(Ｓ)処理を終了します。
(Ｏ)このメッセージの前に出力されたエラーメッセージ※を参照してエラー原因を取り除いた後，再度pddbstを実行し，運用履歴表に状態解析の結果を登録してください。その後，再編成時期予測機能を実行してください。
注※
エラーメッセージがKFPA11204-Eの場合は，pdmodで解析情報表及び運用履歴表を格納するデータディクショナリ用RDエリアを作成する必要があります。
KFPK00999-E
HiRDB Control Manager interface file I/O error occurred, reason=aa....aa　　（Ｌ＋Ｅ）
HiRDB CMとのインタフェースをとるファイルでエラーが発生しました。
aa....aa：エラーの理由
PATH_NAME：ファイルパス名が長過ぎます。
FILE_OPEN：ファイルオープンに失敗しました。
FILE_WRITE：ファイルの書き込みに失敗しました。
FILE_CLOSE：ファイルクローズに失敗しました。
(Ｓ)処理を終了します。
(Ｏ)
・aa....aaがPATH_NAMEの場合，HiRDB CMのマニュアルを参照して，ファイル出力先を変更してください。
・aa....aaがFILE_OPEN，FILE_WRITE，又はFILE_CLOSEの場合，pdlog，又はsyslogfileに出力されるKFPK00005-E，又はKFPK00010-Eエラーメッセージを参照して，エラーの原因を取り除いてください。
KFPK05200-E
Invalid format exists in control file, line=aa....aa　　（Ｅ）
統計解析ユティリティの-dオプションで指定した制御文ファイル中のaa....aa行目の形式が誤っています。
aa....aa：解析時にエラーになった行番号
(Ｓ)処理を終了します。
(Ｐ)制御文ファイル中の該当する行番号を修正して，再度コマンドを実行してください。
KFPK05201-E
Invalid attribute exists in control file, line=aa....aa　　（Ｅ）
統計解析ユティリティの-dオプションで指定した制御文ファイル中のaa....aa行目の値が誤っています。
aa....aa：解析時にエラーになった行番号
(Ｓ)処理を終了します。
(Ｐ)制御文ファイル中の該当する行番号を修正して，再度コマンドを実行してください。
KFPK05202-E
Line of file_group sentence in control file exceeds the limit　　（Ｅ）
統計解析ユティリティの-dオプションで指定した制御文ファイル中のfile_group文の数が最大値を超えています。
(Ｓ)処理を終了します。
(Ｐ)file_group文の指定数が34個を超えないように制御文ファイルを修正して，再度コマンドを実行してください。
KFPK05203-E
Server name specified twice in control file, server_name:aa....aa　　（Ｅ）
統計解析ユティリティの-ｄオプションで指定した制御文ファイル中のサーバ名の指定が重複しています。
aa....aa：重複しているサーバ名
(Ｓ)処理を終了します。
(Ｐ)サーバ名が重複しないように制御文ファイルを修正して，再度コマンドを実行してください。
KFPK05204-E
Error occurred in log file group, server_name:aa....aa
file_name:bb....bb reason=(cc....cc, dd....dd)　　（Ｅ）
統計解析ユティリティの制御文で指定したログファイルグループにエラーが発生しました。
aa....aa：ファイルグループに対応したサーバ名
bb....bb：ファイルグループ名
cc....cc：理由コード
dd....dd：詳細コード
(Ｓ)処理を終了します。
[対策]理由コードと対策を次に示します。
理由コード
意味
対策
-1
引数が誤っています。
保守員に連絡してください。
-2
致命的，又は予期しないエラーが発生しました。
-30
ログファイルに関する定義解析関数エラー
このメッセージの前に出力されたエラーメッセージを参照してエラーの原因を取り除いてください。詳細コードはシステムの保守情報です。
-31
ログファイルに関する定義解析エラー
ログファイルに関する定義が誤って変更されています。詳細コードを参照し，元に戻してください。
詳細コードを次に示します。
詳細コード
意味
-1
定義のファイルグループ名が誤っています。
-2
定義のＡ系ファイル名が誤っています。
-3
定義のＢ系ファイル名が誤っています。
上記以外
保守情報
KFPK05300-I
No data in log file, record_kind=aaa, reason=bb....bb　　（Ｅ）
全解析対象ログファイル中に，解析対象のレコードがありませんでした。
aaa：レコード種別
sop：SQL静的最適化情報ログレコード
dop：SQL動的最適化情報ログレコード
pcd：SQLオブジェクト実行情報ログレコード
obj：SQLオブジェクト転送情報ログレコード
cnc：connect/disconnect情報ログレコード
sqh：SQL文情報ログレコード
plg：プラグイン統計情報ログレコード
bb....bb：理由
NOOPT：
-dオプションを指定していない場合
・全解析対象ログファイル内で，該当する編集項目レコードがない。
-dオプションを指定している場合
・全解析対象ログファイル内で，該当する編集項目レコードがない。
・-sオプションで指定したサーバを，-dオプションで指定する制御文ファイルに定義していない。
HOST：-xオプションで指定したホストから出力された統計ログレコードがない。
SERVER：-sオプションで指定したサーバから出力された統計ログレコードがない。
UAP：-uオプションで指定したUAPから出力された統計ログレコードがない。
TIME：-tオプションで指定した編集時間範囲内に出力された統計ログレコードがない。
(Ｓ)処理を続行します。
[対策]マニュアル「HiRDB Version 7 コマンドリファレンス」の統計解析ユティリティの編集データがないときの表示内容を確認し，対処してください。
KFPK10012-E
Transaction start error on aa....aa, func=bb....bb return code=cc....cc　　（Ｄ＋Ｅ）
トランザクション開始処理中にエラーが発生しました。
aa....aa：エラーが発生したサーバ名称
bb....bb：エラー発生処理名称
cc....cc：エラーコード
(Ｓ)〈標準エラー出力に出力された場合〉
処理を終了します。
〈エラーメッセージダイアログに出力された場合〉
エラーが発生する直前の画面に戻ります。
(Ｏ)HiRDB管理者に連絡してください。
[対策]「エラー詳細コード一覧」を参照して，エラーの原因を取り除き，再度コマンドを実行してください。対処できない場合は，保守員に連絡してください。
KFPK10013-E
Transaction termination error on aa....aa, func=bb....bb return code=cc....cc　　（Ｄ＋Ｅ）
トランザクション終了処理中にエラーが発生しました。
aa....aa：エラーが発生したサーバ名称
bb....bb：エラー発生処理名称
cc....cc：エラーコード
(Ｓ)〈標準エラー出力に出力された場合〉
処理を終了します。
〈エラーメッセージダイアログに出力された場合〉
エラーが発生する直前の画面に戻ります。
(Ｏ)HiRDB管理者に連絡してください。
[対策]「エラー詳細コード一覧」を参照して，エラーの原因を取り除き，再度コマンドを実行してください。対処できない場合は，保守員に連絡してください。
KFPK10014-E
aa....aa lock request failed, name=[bb....bb.]"cc....cc"　　（Ｄ＋Ｅ）
資源の排他制御に失敗しました。
aa....aa：種別名
Index：インデクス
RDAREA：RDエリア
Table：表
bb....bb：認可識別子（aa....aaがIndex,Tableの場合だけに出力されます）
cc....cc：資源情報
(Ｓ)〈標準エラー出力に出力された場合〉
処理を終了します。
〈エラーメッセージダイアログに出力された場合〉
エラーが発生する直前の画面に戻ります。
(Ｏ)対象となる資源を占有しているユーザの処理が終了するのを待って，再度コマンドを実行してください。又は，このメッセージの前に出力されているメッセージを参照し，エラーの原因を取り除いて，再度コマンドを実行してください。
KFPK10015-E
Directory access error, server=aa....aa　　（Ｄ＋Ｅ）
ディレクトリへのアクセス処理中にエラーが発生しました。
aa....aa：サーバ名
(Ｓ)〈標準エラー出力に出力された場合〉
処理を終了します。
〈エラーメッセージダイアログに出力された場合〉
エラーが発生する直前の画面に戻ります。
(Ｏ)ログファイルに出力されているメッセージを基にエラーの原因を取り除き，再度コマンドを実行してください。
KFPK10016-E
Insufficient memory in message buffer pool due to concurrent execution of "pddbst"　　（Ｄ＋Ｅ）
pddbstを同時実行したため，ユティリティサーバ用のメッセージ格納バッファプールのメモリが，一時的に不足しました。なお，該当するエラーの発生に伴って，KFPS00854-Wが出力されることがあります。しかし，この場合は，サーバ障害ではありません。
(Ｓ)〈標準エラー出力に出力された場合〉
処理を終了します。
〈メッセージダイアログに出力された場合〉
エラーが発生する直前の画面に戻ります。
(Ｏ)現在実行中のpddbstの実行完了後，再度実行してください。
KFPK10017-E
Unable to send message from aa....aa to bb....bb　　（Ｄ＋Ｅ）
通信エラーが発生したため，ホストaa....aaからホストbb....bbへデータを送れません。
aa....aa：送信元ホスト名※
bb....bb：送信先ホスト名※
注※　系切り替え機能を使用している場合は，現用系のホスト名となります。
(Ｓ)〈標準エラー出力に出力された場合〉
処理を終了します。
〈メッセージダイアログに出力された場合〉
エラーが発生する直前の画面に戻ります。
[対策]このメッセージの前に出力されたKFPK10100-Eメッセージの処置に従ってください。ただし，物理的な通信エラーが発生していない場合は，システム定義でホスト間の関係に矛盾があると考えられます。このため，エラーが発生したホスト間の定義を見直して再度実行してください。
KFPK10018-E
Dynamic load error occurred, shared library=aa....aa　　（Ｅ）
処理に必要な共用ライブラリの動的ロードでエラーが発生しました。
aa....aa：共用ライブラリの絶対パス名
(Ｓ)処理を終了します。
(Ｏ)このメッセージの前に出力されたKFPK00005-Eを参照し，次に示す内容を確認してエラーの原因を取り除き，再度実行してください。
〈GUI機能を使用する場合〉
X Window System及び日立Motifが正しくインストールできているか確認してください。
〈GUI機能を使用しない場合〉
解析結果を標準出力に出力する指定で実行しているか確認してください。
KFPK10019-E
HiRDB file error, func=aa....aa return code=bb....bb filename=cc....cc　　（Ｅ＋Ｄ）
ファイルcc....ccに対して，ファイルアクセス関数aa....aaでエラーコードbb....bbのエラーが発生しました。
aa....aa：関数名称
bb....bb：エラーコード
cc....cc：HiRDBファイル名称
(Ｓ)処理を終了します。
[対策]「HiRDBファイルシステムに対するアクセス要求から返されるエラーコード」を参照して，エラーの原因を取り除いてください。その後，再実行してください。
KFPK10020-E
RDAREA "aa....aa" not found　　（Ｄ＋Ｅ）
RDエリアaa....aaがありません。
次の要因が考えられます。
・ユティリティ実行中に処理対象のRDエリアを削除した。
aa....aa：RDエリア名
(Ｓ)処理を終了します。
(Ｏ)ユティリティ実行中に処理対象RDエリアを削除している場合は，ユティリティを実行できる環境に再構築して，再度実行してください。RDエリアを削除していない場合は，保守員に連絡してください。
KFPK10050-E
Combuf communication error occurred, func=aa....aa code=bbbbb　　（Ｄ＋Ｅ）
直接プロセス間通信の通信関連処理で，エラーが発生しました。
aa....aa：エラーとなった処理
bbbbb：エラー詳細コード
(Ｓ)処理を終了します。
(Ｐ)「エラー詳細コード一覧」を参照してエラーの原因を取り除き，再度コマンドを実行してください。なお，HiRDB管理者が対処できない場合は，保守員に連絡してください。
KFPK10100-E
RPC(system) error, func=aa....aa return code =bbbbb　　（Ｄ＋Ｅ）
RPC関連エラー，又はシステム関連エラーが発生しました。
aa....aa：エラーが発生した関数名称
bbbbb：エラー詳細コード
(Ｓ)〈標準エラー出力に出力された場合〉
処理を終了します。
〈エラーメッセージダイアログに出力された場合〉
エラーが発生する直前の画面に戻ります。
(Ｏ)「エラー詳細コード一覧」を参照してエラーの原因を取り除き，再度コマンドを実行してください。なお，HiRDB管理者が対処できない場合は，保守員に連絡してください。
KFPK10101-E
Unable to start pddbst　　（Ｅ）
データベース状態解析ユティリティが次に示すどちらかの理由で起動できません。
(1) HiRDBシステム全体としての最大同時実行ユティリティ数を超えています。
(2) HiRDB本体が終了処理中です。
(Ｓ)処理を終了します。
(Ｏ)エラーの原因を取り除き，再度起動してください。
KFPK10102-W
Specified value not found in system
aa....aa="bb....bb"　　（Ｄ＋Ｅ）
指定されたRDエリア名，表識別子，又はインデクス識別子はありません（aa....aaがtableの場合は，表別名で指定した表の可能性があります）。又は，-qオプションで指定した世代に，レプリカRDエリアがありません。
aa....aa：識別子の種別
index：インデクス識別子
RDAREA：RDエリア名
table：表識別子
bb....bb：指定された識別子名称
(Ｓ)処理を続行します。
(Ｏ)指定した名称がシステム内にあるかどうか確認後，正しい名称を指定し，再度開始してください。
KFPK10103-W
Unable to get status information
aa....aa="bb....bb" [server=ee....ee]
cc....cc="dd....dd" [server=ff....ff]　　（Ｄ＋Ｅ）
指定されたRDエリア名，又は表識別子に対し，次の理由で情報が取得できません。
1. 解析対象のサーバが稼働中でありません。
2. 解析対象のRDエリアが次の状態であるため解析できません。
●RDエリア属性がINITIALの場合
RDエリアが次に示すどれかの状態になっていません。
・閉塞なしオープン状態
・参照可能な閉塞状態でかつオープン状態
・参照可能バックアップ閉塞
・更新可能バックアップ閉塞
●RDエリア属性がDEFER又はSCHEDULEの場合
RDエリアが次に示すどれかの状態になっていません。
・閉塞なしオープン状態
・閉塞なしクローズ状態
・参照可能な閉塞状態でかつオープン状態
・参照可能な閉塞状態でかつクローズ状態
・参照可能バックアップ閉塞
・更新可能バックアップ閉塞
aa....aa：識別子の種別
index：インデクス識別子
RDAREA：RDエリア名
table：表識別子
bb....bb：指定された識別子名称
cc....cc：識別子の種別
index：インデクス識別子
RDAREA：RDエリア名
table：表識別子
dd....dd：指定された識別子名称
ee....ee：サーバ名
ff....ff：サーバ名
(Ｓ)処理を続行します。
(Ｏ)情報を取得できなかった原因を取り除いた後，再度開始してください。
KFPK10104-W
No select privilege for authorization id
aa....aa="bb....bb" [server=ee....ee]
cc....cc="dd....dd" [server=ff....ff]　　（Ｄ＋Ｅ）
指定された表，又はインデクスの認可識別子に対し，SELECT権限がありません。
aa....aa：識別子の種別
index：インデクス識別子
RDAREA：RDエリア名称
table：表識別子
bb....bb：指定された識別子名称
cc....cc：識別子の種別
index：インデクス識別子
RDAREA：RDエリア名称
table：表識別子
dd....dd：指定された識別子名称
ee....ee：サーバ名
ff....ff：サーバ名
(Ｓ)処理を続行します。
(Ｏ)解析対象の表やインデクスの認可識別子に対してSELECT権限があるかどうか確認後，SELECT権限のあるものを解析対象として，再度コマンドを実行してください。
KFPK10105-E
Unable to connect to HiRDB, user=aa....aa　　（Ｄ＋Ｅ）
HiRDBにCONNECTできません。
aa....aa：ユーザID
(Ｓ)
〈標準エラー出力に出力された場合〉
処理を終了します。
〈エラーメッセージダイアログに出力された場合〉
エラーが発生する直前の画面に戻ります。
(Ｏ)
〈このメッセージの前に，SQL文に関するメッセージが出力されている場合〉
メッセージが示すエラーの原因を取り除き，再度コマンドを実行してください。
〈SQL文に関するメッセージが出力されていない場合〉
HiRDBシステムに対して，DBA権限があるかどうか確認後，再度コマンドを実行してください。
KFPK10106-W
Unable to analyze
aa....aa="bb....bb" kind=cc....cc　　（Ｄ＋Ｅ）
指定したRDエリア，表識別子，又はインデクス識別子は解析できません。
aa....aa：解析対象
RDAREA：RDエリア名
table：表識別子
index：インデクス識別子
bb....bb：名称
cc....cc：種別
〈aa....aaがRDAREAの場合〉
master directory：マスタディレクトリ用
data directory：データディレクトリ用
list：リスト用RDエリア
other：上記以外
〈aa....aaがtableの場合〉
view table：ビュー表
foreign table：外部表
cluster：クラスタキーが定義されていない表
other：上記以外
〈aa....aaがindexの場合〉
foreign index：外部インデクス
other：上記以外
(Ｓ)〈標準エラー出力に出力された場合〉
処理を終了します。
〈エラーメッセージダイアログに出力された場合〉
エラーが発生する直前の画面に戻ります。
(Ｏ)指定した資源が解析対象であるか，確認してください。解析対象以外を指定しているときは，指定を修正して，再度実行してください。
KFPK10107-W
No data
RDAREA="aa....aa" server=bb....bb　　（Ｄ＋Ｅ）
指定されたRDエリア中に，表又はインデクスが一つもありません。このため，状態を表示できません。
aa....aa：RDエリア名
bb....bb：サーバ名
(Ｓ)〈標準エラー出力に出力された場合〉
処理を終了します。
〈エラーメッセージダイアログに出力された場合〉
エラーが発生する直前の画面に戻ります。
KFPK10108-W
No original RDAREA
RDAREA="aa....aa"　　（Ｄ＋Ｅ）
指定したRDエリアは，オリジナルRDエリアではありません。再編成時期予測機能を使用する場合は，オリジナルRDエリアが対象となります。
aa....aa：RDエリア名
(Ｓ)処理を続行します。
(Ｏ)指定したRDエリアがオリジナルRDエリアかどうか確認してください。オリジナルRDエリアでない場合は，オリジナルRDエリアを指定して再度実行してください。また，指定したレプリカRDエリアの状態解析をしたい場合は，-qオプションを削除して再度実行してください。
KFPK10200-I
Usage: pddbst [-u user_id[-p password]] [-b]| -r rdarea_name [-k logi] [-d] [-q generation_number] [-u user_id[-p password]] [-b] | -r rdarea_name[,rdarea_name]... -k phys [-f] [-a [-h]] [-q generation_number] [-u user_id[-p password]] [-b] |-t [auth_id.]table_name [-s] [-d] [-q generation_number] [-u user_id[-p password]] [-b] | -t [auth_id.]table_name -k clus [-q generation_number] [-u user_id[-p password]] [-b] | -i [auth_id.]index_name [-d] [-q generation_number] [-u user_id[-p password]] [-b] | -r {rdarea_name | ALL} -k logi -e predict_level [-u user_id[-p password]] [-b] | [-r ALL] -k pred [-m] -e predict_level [-R watch_time[,maitenance_extension_time]] [-c base_value_file_name] [-u user_id[-p password]] [-b] [-v control_file]　　（Ｅ）
データベース状態解析ユティリティ(pddbst)の使用方法を示します。
-u：ユーザIDを指定します。
-p：パスワードを指定します。-uオプションと対で指定してください。
-b：pddbst実行によるアプリケーションへのオンライン性能劣化を防ぐ場合に指定します。
-r：RDエリア名を指定します。RDエリア単位の解析をする場合に指定してください。-ｋ physを指定した場合，RDエリア名を繰り返し指定できます。-k pred，又は -k logi -eを指定した場合，-r allを指定できます。
-k：RDエリア単位の解析種別を指定します。logi，phys，clus又はpredを指定してください。なお，logi及びphysは-rオプションと対で指定してください。clusは-tオプションと対で指定してください。predは再編成時期予測機能を使用する場合に指定してください。
-d：ページの詳細情報を表示する場合に指定します。
-q：レプリカRDエリアがある場合に，解析したい世代を指定します。
-f：HiRDBファイルの情報を表示する場合に指定します。
-a：DAT形式で表示する場合に指定します。-k physと同時に指定します。
-h：DAT形式で表示する場合，タイトルバーを出力するときに指定します。-aと同時に指定します。
-t：〔認可識別子．〕表識別子を指定します。表単位の解析をする場合に指定してください。
-s：表単位の解析で，格納行数を表示する場合に指定してください。なお，このオプションは，-tオプションが指定されている場合に指定できます。ただし，-kオプションが指定されている場合は指定できません。
-i：インデクス識別子を指定します。インデクス単位の解析をする場合に指定してください。なお，-rオプション，-tオプション，及び-iオプションは，同時に指定できません。
-e：状態解析結果蓄積機能，又は再編成時期予測機能を実行する場合，予測レベルを指定します。-k logi又はpredと同時にと同時に指定します。
-m：-k pred -e 1を指定した場合，詳細解析まで実行するときに指定します。
-R：監視時間とメンテナンス延長期間を指定します。-k predと同時に指定します。
-c：基準値定義ファイル名を指定します。-k predと同時に指定します。
-v：再編成時期予測機能の結果をCSV形式で出力する場合，出力先のファイルを指定した制御文ファイルを指定します。-k predと同時に指定します。
(Ｓ)処理を終了します。
(Ｏ)データベース状態解析ユティリティ(pddbst)のパラメタの入力が誤っていないか確認してください。
KFPK10201-W
No parameter in input area　　（Ｄ）
画面の入力エリアに対して，何も指定されていません。
(Ｓ)エラーの発生した入力画面に戻ります。
(Ｐ)入力エリアに必要な値を設定した後，再度実行してください。
KFPK10202-W
Length of parameter is too long　　（Ｄ）
画面の入力エリアの指定値が制限長を超えています。
(Ｓ)エラーの発生した入力画面に戻ります。
(Ｐ)入力エリアに正しい値を指定した後，再度実行してください。
KFPK10203-W
Value of aa....aa is not specified　　（Ｄ）
指定画面の指定値に誤りがあります。このメッセージは，次のどれかの場合に出力します。
1. 表識別子又はインデクス識別子の先頭に"．"が指定してあるため，認可識別子が認識できません。
2. 表識別子又はインデクス識別子の最後に"．"が指定してあるため，表名又はインデクス名を認識できません。
3. 指定した世代番号に誤りがあります。
aa....aa：不正な指定値の種別
authid：認可識別子
table name：表名
index name：インデクス名
generation number：世代番号
(Ｓ)エラーの発生した入力画面に戻ります。
(Ｏ)入力エリアに正しい値を指定後，再度実行してください。
KFPK10204-W
Number of RDAREA names exceeds 128　　（Ｄ）
RDエリア名の指定数が128を超えています。
(Ｓ)エラーの発生した入力画面に戻ります。
(Ｏ)入力エリアに正しい値を指定後，再度実行してください。
KFPK10250-E
User RDAREA inconsistent with dictionary, aaaaa=bb....bb."cc....cc"　　（Ｄ＋Ｅ）
解析対象に指定された表，インデクスはディクショナリにはありますが，ユーザ用RDエリアにはありません。ディクショナリとユーザ用RDエリア又はユーザLOB用RDエリアで不整合が発生しています。
aaaaa：識別子の種別
table：表識別子
index：インデクス識別子
bb....bb：認可識別子
cc....cc：指定された識別子
(Ｓ)エラーが発生した表又はインデクスの処理をスキップして，処理を続行します。
(Ｏ)次に示すような原因がないかどうかを確認してください。
＜データディクショナリ，マスタディレクトリ，データディレクトリをバックアップから回復している場合に，同期が取れていませんでした。＞
対処：同期を取って回復してください。バックアップを取得した時点で同期が取れていない場合は，すべてのデータベースを，データベース再編成ユティリティなどでアンロードして，データベースの初期設定を再度実行し，データベースを再作成してください。
＜HiRDBを正常終了しないで，システムステータスファイルを初期化して再開始しています。又は，pdstart -dbdestroyで強制正常開始をしています。＞
対処：データベースの初期設定を再度実行して，データベースを再作成してください。
これらの原因に当てはまらない場合は，保守員に連絡してください。
KFPK10251-W
Unable to get status information, cause cluster index incomplete
RDAREA="aa....aa"　　（Ｅ）
解析対象に指定されたクラスタインデクスが未作成状態のため，正しい情報が取得できませんでした。
aa....aa：RDエリア名称
(Ｓ)処理を続行します。
(Ｏ)クラスタインデクスの作成が終了してから，コマンドを再度実行してください。
KFPK10300-I
Pddbst started　　（Ｅ）
データベース状態解析ユティリティの実行を開始しました。
(Ｓ)処理を続行します。
KFPK10301-I
Pddbst terminated, return code=aa....aa　　（Ｅ）
データベース状態解析ユティリティの実行が終了しました。
aa....aa：リターンコード
0：正常に終了しました
4：正常に終了したが警告メッセージを出力しました
8：エラー発生のため処理を打ち切りました
(Ｓ)処理を終了します。
(Ｏ)〈リターンコードが4の場合〉
処理中に出力されたメッセージの種類が，Wのメッセージを基に調査してください。
〈リターンコードが8の場合〉
処理中に出力されたメッセージの種類が，Ｅのメッセージを基に調査してください。
KFPK10311-I
Applied objects nothing　　（Ｅ）
再編成時期予測機能を実行した結果，日数範囲指定内にメンテナンスが必要になるリソースはありませんでした。
(Ｓ)処理を続行します。
KFPK10312-I
Number of saved data a few, RDAREA aa....aa　　（Ｅ）
再編成時期予測機能の予測に必要なデータ数が不足しているため，予測対象の予測処理をスキップしました。予測に必要なデータ数については，マニュアル「HiRDB Version 7 コマンドリファレンス」の再編成時期予測機能を参照してください。
aa....aa：RDエリア名
(Ｓ)処理を続行します。
[対策]解析対象のRDエリアに対して状態解析結果蓄積機能を実行し，4件以上登録した後に再度実行してください。
KFPK10313-I
No data in SQL_DB_STATE_ANALYZED　　（Ｅ）
再編成時期予測機能の予測に必要なデータが，状態解析表（SQL_DB_STATE_ANALYZED）に1件もありません。
(Ｓ)処理を続行します。
[対策]解析対象のRDエリアに対してpddbstを実行して，状態解析表に4件以上の状態解析結果を登録してください。その後，再度実行してください。
KFPK10314-I
aaaaa bb....bb."cc....cc" not found, in dd....dd　（Ｅ）
再編成時期予測機能実行中に，RDエリア内リソースが削除されました。
aa....aa：RDエリア内リソース種別
TABLE：表
INDEX：インデクス
bb....bb：認可識別子
cc....cc：表識別子，又はインデクス識別子
dd....dd：RDエリア名
(Ｓ)処理を続行します。
[対策]状態解析結果蓄積機能で状態解析結果を登録し，再編成時期予測機能を再実行してください。
KFPK10400-E
Sort program error -aa....aa　　（Ｄ＋Ｅ）
ソートプログラムでエラーが発生しました。
aa....aa：エラー要因
destroyed file,file_name：ファイル破壊となったファイル名
incorrect version：バージョン不正
insufficient memory：メモリ不足
I/O error,file_name：入出力エラーとなったファイル名
logical error（保守コード）：論理エラー
(Ｓ)〈標準エラー出力に出力された場合〉
処理を終了します。
〈エラーメッセージダイアログに出力された場合〉
エラーが発生する直前の画面に戻ります。
(Ｏ)エラー要因を基に原因を調査し，問題を取り除いた後，再度実行してください。ただし，論理エラーの場合は，保守員に連絡してください。
KFPK10450-E
Pddbst must be executed at unit defined as manager　　（Ｅ）
データベース状態解析ユティリティは，システムマネジャ（MGR）が定義されているユニットから実行しなければなりません。
(Ｓ)処理を終了します。
(Ｏ)システムマネジャ（MGR）が定義されているユニットから再度実行してください。
KFPK10451-E
Unable to analyze with -e option, aa....aa　　（Ｅ）
次の理由によって，-eオプション指定の状態解析処理が実行できません。
1. システム定義のpd_rorg_predictオペランドがYでない。
2. 解析情報表及び運用履歴表を格納するデータディクショナリ用RDエリアが作成されていない。
3. -qオプションでレプリカRDエリアを指定している。
aa....aa：｛not predict mode 'Y'｜not found datadictionary of dbmanagement｜on replica RDAREA｝
(Ｓ)処理を終了します。
[対策]再編成時期予測機能を使用する場合，次の対処をしてください。
1. システム定義のpd_rorg_predictオペランドにYを指定して，HiRDBを再度開始してください。その後，再編成時期予測機能を実行してください。
2. pdmodで解析情報表及び運用履歴表を格納するデータディクショナリ用RDエリアを作成してから，再編成時期予測機能を実行してください。
3. -qオプションの指定を削除してから，再編成時期予測機能を実行してください。


KFPLメッセージ

KFPL00700-I
Retry reopen aa-time of bb after cc-minute, host=dd....dd, file=ee....ee, reason=ff....ff　　（Ｅ＋Ｌ）
マルチボリュームファイルの再オープン処理をcc分後にします。リトライの最大数はbbで，次回はaa回目です。ホスト名dd....ddのファイル名ee....eeです。
aa：次回のリトライ回数
bb：最大リトライ回数
cc：リトライ間隔
dd....dd：ホスト名称
ee....ee：ファイル名称
ファイル名称の長さが105文字以上の場合は，ファイル名称の後ろから104文字を出力します。
ff....ff：リトライする理由
No-file：ファイルがセットされていません。
Same-file：再オープン前と同じファイルがセットされています。
(Ｓ)処理を続行します
(Ｏ)リトライ処理中に，次のファイルをセットしてください。
KFPL00701-I
File swapping started, file=aa....aa, reason=bb....bb　　（Ｅ＋Ｌ）
マルチボリュームファイルの2巻目以降のファイルaa....aaの処理を開始しました。
aa....aa：ファイル名称
ファイル名称の長さが151文字以上の場合は，ファイル名称の後ろから150文字を出力します。
bb....bb：理由コード
ENOSPC：デバイスの容量がなくなりました。
EOV：ボリュームの最後を検出しました。
(Ｓ)処理を続行します。
KFPL00702-I
Pdload started, table=aa....aa.bb....bb, cc....cc, dd....dd　　（Ｌ）
データロード又はファイル分割（分割入力データファイルの作成）を開始しました。
aa....aa：認可識別子
bb....bb：表識別子
cc....cc：全角空白変換レベル（spacelvl=空白変換レベル）
システム共通定義のpd_space_levelオペランド，又はデータベース作成ユティリティのoption文のspacelvlオペランドで空白変換レベルを指定している場合は，spacelvl=空白変換レベルを表示します。なお，空白変換処理をしない場合，spacelvl=空白変換レベルは表示しません。
dd....dd：
データロードの場合：
generation=世代番号を表示します。ただし，HiRDB Staticizer Optionが組み込まれている場合に限ります。
ファイル分割の場合：
mode=splitを表示します。
(Ｓ)処理を続行します。
KFPL00703-I
aa....aa rows loaded　　（Ｌ）
aa....aa行を格納しました。
aa....aa：格納した行数
(Ｓ)処理を続行します。
KFPL00704-I
Pdload terminated, return code=aa　　（Ｌ＋Ｓ）
データベース作成ユティリティ（pdload）の処理が終了しました。
aa：リターンコード
データロードの場合：
0：データロードは正常に終了しました。
4：データロードは正常に終了しました。ただし，処理に関係ない警告レベルのエラーが発生しています。又は，入力データのエラーを検知しました。このため，一部のデータを格納しないで処理しました。
8：データロードは異常終了しました。なお，入力データエラーの場合でも，dataerr=rollbackオペランド指定時及び-i cオプション（インデクス一括作成モード）指定時のキー重複エラーのときはこのリターンコードが出力されます。
ファイル分割（分割入力データファイルの作成）の場合：
0：入力データファイル中のすべてのデータを分割入力データファイルに出力しました。
4：入力データファイル中の正常なデータは分割入力データファイルに出力しました。ただし，エラーのデータは分割入力データファイルに出力していません。
8：分割入力データファイルの作成は異常終了しました。
(Ｓ)処理を終了します。
(Ｏ)
〈リターンコードが8の場合〉
標準エラー出力又はメッセージログファイルに出力されたエラーメッセージを参照してエラーの原因を取り除いた後，再度コマンドを実行してください。なお，データロードの場合に，ログレスモードでRDエリアがログレス閉塞，又はインデクス一括作成中にキー重複エラーを検知して表とインデクスが不整合な状態になったときは，データベースをデータベース作成ユティリティ（pdload）の実行前の状態に戻してから再度実行してください。
〈リターンコードが4の場合〉
エラー情報ファイルを参照してエラーとなったデータがあるかを確認してください。エラーとなったデータがあれば，データロードの場合は修正したデータだけを再度データロードしてください。ファイル分割の場合はデータを修正後，再度データベース作成ユティリティを実行してください。
KFPL00705-I
aa....aa rows processing　　（Ｌ）
aa....aa行目を処理しています。
aa....aa：行数
(Ｓ)処理を続行します。
KFPL00707-I
LOB load started, RDAREA=aa....aa　　（Ｌ）
LOB用RDエリアaa....aaへのLOBデータのデータロードを開始しました。
aa....aa：RDエリア名
(Ｓ)処理を続行します。
KFPL00708-I
LOB load ended, RDAREA=aa....aa, return code=bb　　（Ｌ）
LOB用RDエリアaa....aaへの，LOBデータのデータロードがリターンコードbbで終了しました。
aa....aa：RDエリア名
bb：リターンコード
0：LOBデータのデータロードは正常終了しました。
8：LOBデータのデータロードは異常終了しました。
(Ｓ)リターンコードが0の場合，処理を続行します。リターンコードが8の場合，処理を終了します。
(Ｏ)リターンコードが8の場合，標準エラー出力，メッセージログファイル，又はエラー情報ファイルに出力されたエラーメッセージを参照してエラーの原因を取り除いてください。その後，LOB中間ファイルを使用してエラーとなったLOB用RDエリア及び処理が実行されなかったLOB用RDエリアだけを対象にデータロードを再度実行してください。
KFPL00709-I
aa....aa file was created, file=bb....bb　　（Ｌ）
エラー情報ファイル，又はLOB中間ファイルの指定が省略されているため，bb....bbのファイルを作成しました。
aa....aa：ファイル種別
Error information：エラー情報ファイル
Lobmid：LOB中間ファイル
bb....bb：システム内で取得した一意なファイル名称
ファイル名称の長さが151文字以上の場合は，ファイル名称の後ろから150文字を出力します。
(Ｓ)処理を続行します。
KFPL00710-I
Index information file assigned, index=aa....aa.bb....bb, RDAREA=cc....cc，　file=dd....dd　　（Ｌ）
インデクスaa....aa.bb....bbのRDエリアcc....ccのインデクス情報をdd....ddに出力しました。
aa....aa：認可識別子
bb....bb：インデクス識別子
cc....cc：RDエリア名
dd....dd：ファイル名称
ファイル名称の長さが次の計算式で求めた値を超える場合は，ファイル名称の後ろから計算式で求めた値分の文字数を出力します。
150－認可識別子長－インデクス名称長－RDエリア名称長
(Ｓ)処理を続行します。
KFPL00712-I
aa....aa started, table=bb....bb.cc....cc, server=dd....dd,spacelvl=e, generation=ff　　（Ｌ）
サーバdd....ddの表bb....bb.cc....ccに対するアンロード，又はリロード処理を開始しました。
データベース再編成ユティリティのoption文のspacelvlオペランドで空白変換レベルを指定している場合は，”spacelvl=e”を表示します。ただし，ユティリティが空白変換処理をしない場合は，”spacelvl=e”は表示されません。
インナレプリカ機能を使用している場合は，generation=ffが出力されます。
aa....aa：実行した処理
｛LOB reload｜LOB unload｜Reload｜Unload ｝
bb....bb：認可識別子
cc....cc：表識別子
dd....dd：サーバ名
e：空白変換レベル
ff：世代番号
(Ｓ)処理を続行します。
KFPL00713-I
aa....aa rows bbbbbb, table=cc....cc.dd....dd, server=ee....ee　　（Ｌ）
サーバee....eeの表cc....cc.dd....ddに対してaa....aa行のアンロード，又はリロード処理をしました。
aa....aa：処理した行数
bbbbbb：実行した処理｛unloaded｜reloaded｝
cc....cc：認可識別子
dd....dd：表識別子
ee....ee：サーバ名称
(Ｓ)処理を続行します。
KFPL00714-I
aa....aa ended, table=bb....bb.cc....cc, server=dd....dd, return code=ee　　（Ｌ）
サーバdd....ddの表bb....bb.cc....ccに対するアンロード処理，リロード処理，使用中空きページ解放処理，又は使用中ページの読み込み処理が終了しました。
aa....aa：実行した処理
｛Unload｜Reload｜LOB unload｜LOB reload｜Reclaim｜Page read｝
bb....bb：認可識別子
cc....cc：表識別子
dd....dd：サーバ名
ee：リターンコード
(Ｓ)0又は4の場合，処理を続行します。また，0又は4以外の場合，処理を終了します。
(Ｏ)リターンコードが0又は4以外の場合はメッセージログファイルに出力されたエラーメッセージを参照してエラーの原因を取り除いた後，再度コマンドを実行してください。
KFPL00715-I
Index load started at aa....aa, index=bb....bb."cc....cc", RDAREA=dd....dd, generation=ee　　（Ｌ）
インデクスロードの処理を開始しました。
インナレプリカ機能を使用している場合は，generation=eeが出力されます。
aa....aa：サーバ名
bb....bb：認可識別子
cc....cc：インデクス識別子
dd....dd：RDエリア名
ee：世代番号
(Ｓ)処理を続行します。
KFPL00716-I
Index load ended at aa....aa, index=bb....bb, RDAREA=cc....cc, return code=dd　　（Ｌ）
インデクスロード処理がリターンコードddで終了しました。
aa....aa：サーバ名
bb....bb：インデクス識別子
cc....cc：RDエリア名
dd：リターンコード
0：正常終了
8：異常終了
(Ｓ)処理を続行します。
(Ｏ)異常終了の場合は，このメッセージの前に出力したエラーメッセージを参照して，エラーの原因を取り除いてください。
KFPL00717-I
Pdrorg started, func=aaaa　　（Ｌ）
データベース再編成ユティリティの処理aaaaを開始しました。
aaaa：処理内容
rorg：表の再編成
unld：表のアンロード
reld：表のリロード
ixmk：インデクスの一括作成
ixrc：インデクスの再作成
ixor：インデクスの再編成
rclm：使用中空きページ解放処理
bfon：ページ読み込み処理
(Ｓ)処理を続行します。
KFPL00719-I
Pdrorg terminated, return code=aa　　（Ｅ＋Ｌ）
データベース再編成ユティリティ(pdrorg)の処理が終了しました。
aa：リターンコード
0：正常終了しました。
4：正常終了しました。ただし，処理に関係ない警告レベルのエラーが発生しました。
8：異常終了しました。
(Ｓ)処理を終了します。
(Ｏ)リターンコードが0又は4以外の場合，標準出力又はメッセージログファイルに出力されたエラーメッセージを参照してエラーの原因を取り除き，再度コマンドを実行してください。
KFPL00720-I
aaaaa file bb....bb, server=cc....cc, file=dd....dd　　（Ｌ）
インデクス情報ファイルを削除しました。
aaaaa：Index
bb....bb：deleted
cc....cc：サーバ名
dd....dd：ファイル名称
ファイル名称の長さが151文字以上の場合は，ファイル名称の後ろから150文字を出力します。
(Ｓ)処理を続行します。
KFPL00721-I
aa....aa in table bb....bb.cc....cc deleted, RDAREA=dd....dd　　（Ｌ）
表bb....bb.cc....ccのRDエリアdd....ddの行データ又はLOBデータを削除しました。
aa....aa：削除したデータ
Data：行データ
LOB data：LOBデータ
bb....bb：認可識別子
cc....cc：表識別子
dd....dd：RDエリア名
(Ｓ)処理を続行します。
KFPL00722-I
Unload file output completely, server=aa....aa, file=bb....bb　　（Ｌ）
サーバaa....aaの，アンロードデータファイルへの出力処理が終了しました。
aa....aa：サーバ名
bb....bb：アンロードデータファイル名称
アンロードデータファイル名称の長さが151文字以上の場合は，アンロードデータファイル名称の後ろから150文字を出力します。
(Ｓ)処理を続行します。
KFPL00723-I
aa....aa rows bb....bb, table=cc....cc.dd....dd, RDAREA=ee....ee　　（Ｌ）
表cc....cc.dd....ddのRDエリアee....eeに対してaa....aa行のbb....bb処理をしました。
aa....aa：処理行数
bb....bb：処理種別 { loaded | unloaded | reloaded }
cc....cc：認可識別子
dd....dd：表識別子
ee....ee：RDエリア名
(Ｓ)処理を続行します。
KFPL00724-I
Index not created, index=aa....aa.bb....bb, RDAREA=cc....cc　　（Ｌ）
インデクスaa....aa.bb....bbのRDエリアcc....ccは，非分割インデクスの一部です。このため，インデクスは未完状態のままです。
aa....aa：認可識別子
bb....bb：インデクス識別子
cc....cc：RDエリア名
(Ｓ)処理を続行します。
(Ｏ)インデクス全体のインデクス情報ファイルを使用して，インデクスを作成してください。
KFPL00725-I
Index aa....aa started at bb....bb, index=cc....cc."dd....dd",RDAREA="ee....ee",source=ff....ff, generation=gg　　（Ｌ）
インデクス情報のアンロード処理を開始しました。
インナレプリカ機能を使用している場合は，generation=ggが出力されます。
aa....aa：unload
bb....bb：サーバ名称
cc....cc：認可識別子
dd....dd：インデクス識別子
ee....ee：RDエリア名称
インデクス単位（idxname文指定）のインデクスの再作成，及びインデクスの再編成の場合は，RDエリア名称に******を表示します。
ff....ff：アンロードするデータ
row：表データ
key：インデクスキー
gg：世代番号
(Ｓ)処理を続行します。
KFPL00726-I
Index aa....aa ended at bb....bb, index=cc....cc."dd....dd", RDAREA="ee....ee", return code=ff....ff　　（Ｌ）
インデクス情報のアンロード処理が終了しました。
aa....aa：unload
bb....bb：サーバ名称
cc....cc：認可識別子
dd....dd：インデクス識別子
ee....ee：RDエリア名称
インデクス単位（idxname文指定）のインデクスの再作成，及びインデクスの再編成の場合は，RDエリア名称に******を表示します。
ff....ff：リターンコード（0：正常終了，8：異常終了）
(Ｓ)処理を続行します。
(Ｏ)異常終了の場合は，このメッセージの前に出力されたエラーメッセージを参照し，エラーの原因を取り除いて，コマンドを再度実行してください。
KFPL00727-I
aa....aa keys processed, index=bb....bb. "cc....cc", RDAREA="dd....dd"　　（Ｌ）
aa....aa件プラグインインデクスの一括作成処理をしました。
aa....aa：レコード数
bb....bb：認可識別子
cc....cc：インデクス識別子
dd....dd：RDエリア名称
(Ｓ)処理を続行します。
KFPL00728-I
Index not reorganized,PLUGIN index aa....aa."bb....bb"　　（Ｌ）
再編成対象のインデクスにプラグインインデクスaa....aa."bb....bb"があります。プラグインインデクスはインデクスの再編成の適用対象外であるため，プラグインインデクスに対する再編成処理をスキップしました。
aa....aa：認可識別子
bb....bb：インデクス識別子
(Ｓ)処理を続行します。
(Ｏ)プラグインインデクスを再作成する必要がある場合は，次に示すどちらかの操作をしてください。
・プラグインインデクスを定義した表の再編成
・プラグインインデクスの再作成
KFPL00732-I
aa....aa started, table=bb....bb.cc....cc, spacelvl=d, generation=ee　　（Ｌ）
表bb....bb.cc....ccに対するアンロード又はリロード処理を開始しました。
データベース再編成ユティリティのoption文のspacelvlオペランドで空白変換レベルを指定している場合は，”spacelvl=d”を表示します。ただし，ユティリティが空白変換処理をしない場合は，”spacelvl=d”は表示されません。
インナレプリカ機能を使用している場合は，generation=eeが出力されます。
aa....aa：実行した処理
{ LOB reload | LOB unload | Reload | Unload }
bb....bb：認可識別子
cc....cc：表識別子
d：空白変換レベル
ee：世代番号
(Ｓ)処理を続行します。
KFPL00733-I
aa....aa rows bb....bb, table=cc....cc.dd....dd　　（Ｌ）
表cc....cc.dd....ddに対して，aa....aa行のアンロード又はリロード処理をしました。
aa....aa：処理した行数
bb....bb：処理内容
unloaded：アンロード
reloaded：リロード
cc....cc：認可識別子
dd....dd：表識別子
(Ｓ)処理を続行します。
KFPL00734-I
aa....aa ended, table=bb....bb.cc....cc, return code=dd　　（Ｌ）
表bb....bb.cc....ccに対するアンロード又はリロード処理が終了しました。
aa....aa：処理内容
Unload：アンロード
Reload：リロード
LOB unload：LOBデータのアンロード
LOB reload：LOBデータのリロード
bb....bb：認可識別子
cc....cc：表識別子
dd：リターンコード
(Ｓ)
〈リターンコードが0又は4の場合〉
処理を続行します。
〈リターンコードが0又は4以外の場合〉
処理を終了します。
(Ｏ)〈リターンコードが0又は4以外の場合〉
ログファイルに出力されたエラーメッセージを参照して，エラーの原因を取り除いた後，再度コマンドを実行してください。
KFPL00735-I
Unload file output completed, file=aa....aa　　（Ｌ）
アンロードデータファイルの出力処理が終了しました。
aa....aa：アンロードデータファイル名
アンロードデータファイル名の長さが151文字以上の場合は，アンロードデータファイル名の後ろから150文字を出力します。
(Ｓ)処理を続行します。
KFPL00736-I
Pdrorg restarted, at aa....aa,table=bb....bb."cc....cc"dd....dd　　（Ｌ）
表の再編成処理をaa....aaから再開始しました。
aa....aa：処理の種別
unload：アンロード処理
delete：データ削除処理
reload：リロード処理
ixrc：インデクス再作成処理
status clear：ステータスクリア処理
bb....bb：認可識別子
cc....cc：表識別子
dd....dd：", server=サーバ名"が表示されます。-gオプションを指定していない場合に表示されます。
(Ｓ)処理を続行します。
KFPL00738-I
Pdpgbfon terminated, return code=aa 　　（Ｌ）
グローバルバッファ常駐化ユティリティ（pdpgbfon）の処理がリターンコードaaで終了しました。
aa：リターンコード
0：正常終了（グローバルバッファへの読み込み完了）
4：バッファフラッシュ発生（グローバルバッファへ全ページを読み込めなかった）
8：異常終了（グローバルバッファへの読み込み失敗）
12：異常終了（pdrorg起動できない，又は異常終了した）
(Ｓ)処理を終了します。
(Ｏ)
・リターンコードが4の場合
表及びインデクスページをすべてグローバルバッファに読み込む必要がある場合は，グローバルバッファ面数の拡張を検討してください。
・リターンコードが8の場合
このメッセージの前に出力されたメッセージを参照してエラーの原因を取り除いた後，再実行してください。
・リターンコードが12の場合
pdpgbfonの延長で動作するpdrorgの実行に失敗しました。標準エラー出力，メッセージログファイル，又はsyslogfile（Windowsの場合はイベントログ）を参照してpdrorgが異常終了した原因を取り除いた後，再実行してください。pdrorgの実行に失敗した要因を知るためのsystem関数の戻り値は，このメッセージの直前に出力されるKFPL22000-Eメッセージを参照してください。
KFPL00739-I
Pdreclaim terminated, return code=aaa　　（Ｌ）
空きページ解放ユティリティ（pdreclaim）の処理がリターンコードaaaで終了しました。
aaa：リターンコード
0：正常終了（使用中空きページ解放完了）
4：タイムアウト発生（使用中空きページ解放途中）
8：異常終了（使用中空きページ解放失敗）
上記以外の値：異常終了（pdrorgが起動できない，又はpdrorgが異常終了）
(Ｓ)処理を終了します。
(Ｏ)
・リターンコードが4の場合
-wオプションに指定している待ち時間を長くしてください。又は，使用中空きページ解放の対象表をアクセスしているUAPの終了を待ってから再実行してください。
・リターンコードが8の場合
このメッセージの前に出力されたメッセージを参照し，エラーの原因を取り除いた後，再度実行してください。
・リターンコードが0，4，及び8以外の値の場合
pdreclaimの延長で動作するpdrorgの実行に失敗しています。値はシステム関数の戻り値です。標準エラー出力，メッセージログファイル，又はsyslogfileを参照して，pdrorgが異常終了した原因を取り除いた後，pdreclaimを再度実行してください。
KFPL00740-I
Error exists in command line, usage is as follows　　（Ｓ）
指定されたコマンドに誤りがあります。このメッセージの後に，コマンドの使用方法を出力します。
(Ｓ)処理を終了します。
(Ｏ)コマンドの誤りを修正して，再度実行しください。
KFPL00750-I
Audit trail aa....aa file load started(b,c,d), file=ee....ee　　（Ｌ）
監査証跡表へのデータロードを開始しました。
aa....aa：generation
b：c（現用）又はs（現用以外）
c：d（データロード待ち）又は－（データロード済み）
d：h（閉塞中）又は－（閉塞中でない）
ee....ee：絶対パスで表示された監査証跡ファイル名
ファイル名の長さが151文字以上の場合は，ファイル名の後ろから150文字を出力します。
(Ｓ)処理を続行します。
KFPL00751-I
Audit trail aa....aa file loaded, file=bb....bb　　（Ｌ）
監査証跡表へのデータロードを終了しました。
aa....aa：generation
bb....bb：絶対パスで表示された監査証跡ファイル名
ファイル名の長さが151文字以上の場合は，ファイル名の後ろから150文字を出力します。
(Ｓ)処理を続行します。
KFPL00800-I
Loading until aa....aath row committed　　（Ｅ＋Ｌ）
aa....aa行までの格納処理のトランザクションが完結しました。
aa....aa：入力データファイル又はアンロードファイルの先頭からの行数（再実行の場合も，先頭からの行数で表示されます）
(Ｓ)処理を続行します。
KFPL00810-I
aa....aa restart at bb....bbth row　　（Ｅ＋Ｌ）
ユティリティの処理をbb....bb行目から再開しました。
aa....aa：ユティリティ名
Pdload：データベース作成ユティリティ
Pdrorg：データベース再編成ユティリティ
bb....bb：入力データファイル又はアンロードデータファイルの先頭からの行数
(Ｓ)処理を続行します。
KFPL00900-I
Error detail, aa....aa　　（Ｌ）
エラー詳細情報です。
aa....aa：内部エラー情報
(Ｓ)上位に出力されたメッセージのシステムの処置になります。
KFPL10000-E
Command option '-i s' cannot be specified in this case　　（Ｌ）
非分割キーインデクスが定義された表にRDエリア単位で処理をする場合，インデクス作成方法に'-i s'（インデクス更新モード）指定はできません。
(Ｓ)処理を終了します。
(Ｏ)インデクス作成方法を'-i n'（インデクス情報出力モード）に変更して，再度コマンドを実行してください。
KFPL10001-E
Command option '-r' cannot be used when partitioning condition altered　　（Ｌ）
アンロードデータファイル中の表の分割条件とリロード対象表の分割条件が異なるため，アンロードデータファイル一本化指定（-gオプション指定）でのRDエリア単位の処理は指定できません。
(Ｓ)処理を終了します。
[対策]表の分割条件を変更する場合は，分割条件を変更する前の状態に回復して，対象表のバックアップを取得してください。その後，-gオプションを指定して表単位にアンロードしてください。表の分割格納条件を変更後，-gオプションを指定して表単位でリロードしてください。
KFPL10002-E
Command option 'aa....aa' cannot be specified in this case　　（Ｅ＋Ｌ）
aa....aaが-Wの場合：
・制御情報ファイル中にlobunld文を指定している場合（LOBデータのアンロード），-Wオプションは指定できません。
・制御情報ファイル中のunload文に(uoc)を指定している場合，-Wオプションは指定できません。
・抽象データ型の列がある表に対して，-Wオプションは指定できません。
aa....aaが-k unldの場合：
・LOB列が定義された表に対するアンロード処理はできません。ただし，次の場合を除きます。
・-Wオプションを指定して，アンロードする場合。
・-jを指定して，LOB列構成基表とLOBデータを同時にアンロードする場合。
・改竄防止表は，-Wオプションの指定がないアンロード処理はできません。
aa....aaが-gの場合：
LOB列が定義されたハッシュ分割表に対するLOB列構成基表の処理では，-gオプションは指定できません。
aa....aaが-jの場合：
-jオプションを指定する場合，-Wオプションは指定できません。
aa....aaが-k c，-fの場合：
これらのオプションは，抽象データ型を含む表に対して指定できません。
aa....aaが-bの場合：
-k f（省略時仮定値），又は-k c指定の場合は，BLOBを入力パラメタとする抽象データ型の列を持つ表に，バイナリ形式の入力データファイルは使用できません。
aa....aaが-i n，-i xの場合：
これらのオプションは，プラグインインデクスが定義されている表に対して指定できません。
aa....aaが-cの場合：
FIX表には，-c，及び-Wオプションを同時に指定できません。
aa....aaが-tの場合：
表単位のアンロードで作成したアンロードデータファイルで，スキーマ単位のリロードはできません。また，tblname文を表単位で指定している場合，スキーマ単位のリロードはできません。
aa....aaが-kの場合：
UOCを使用する場合，-kオプションにrorg及びunld以外は指定できません。
aa....aaが-c dicの場合：
UOCを使用する場合，-c dic指定（ディクショナリ表の場合の指定）はできません。
(Ｓ)処理を終了します。
(Ｏ)下記に従って，対策してください。
aa....aaが-Wの場合：
・アンロードの場合はunload文を指定するか，又はlobunld文を削除してください。
・UOCを利用してpdrorgでアンロードデータファイルを作成する場合は，unload文にアンロードデータファイルを指定してください。UOCでアンロードデータファイルを作成する場合は，-Wオプションを削除してください。
・データロードの場合は，-Wオプションを削除してください。
aa....aaが-k unldの場合：
表を再編成する場合は-k rorgを指定してください。アンロードする場合は-Wオプションを指定してください。
aa....aaが-gの場合：
-gオプションを外してください。
aa....aaが-jの場合：
LOB列構成基表データとLOBデータを同時にアンロードする場合は，-Wを外してください。行データだけをアンロードする場合は，-jを外してください。
aa....aaが-k c，-fの場合：
抽象データ型を含む表を指定する場合は，-k c，-fオプションを外してください。
aa....aaが-bの場合：
-k vオプションを指定してください。
aa....aaが-i n，-i xの場合：
プラグインインデクスが定義されている表を指定する場合は，-i n，-i xオプションを外してください。
aa....aaが-cの場合：
FIX表に対しては，-a，及び-Wオプションを指定して，列構成情報ファイルの内容を修正してください。
aa....aaが-tの場合：
-tオプションの指定を修正してください。
aa....aaが-kの場合：
UOCを使用する場合，-kオプションにはrorg又はunldを指定してください。また，UOCを使用しない場合には，unlduoc文を削除してください。
aa....aaが-c dicの場合：
UOCを使用する場合，ディクショナリ表に対しては処理できません。ユーザが定義した表を処理する場合には，-c userを指定してください。また，UOCを使用しない場合には，unlduoc文を削除してください。
KFPL10003-E
Unable to specified command option 'aa....aa' when bb....bb　　（Ｅ＋Ｌ）
bb....bbが"ADT column defined"の場合：
抽象データ型が定義されているため，aa....aaオプションは指定できません。
bb....bbが"unload_row(uoc)"の場合：
unload文に(uoc)を指定しているため，aa....aaオプションは指定できません。
bb....bbが"INSERT ONLY table"の場合：
改竄防止表に対してaa....aaオプションは指定できません。
bb....bbが"ORG status"の場合：
表が格納されているRDエリアがオンライン再編成閉塞のため，aa....aaオプションは指定できません。
aa....aa：｛-W｜-j｜-k rorg｜-f｜-d｝
bb....bb：｛ADT column defined｜unload_row(uoc)｜INSERT ONLY table｜ORG status｝
(Ｓ)処理を終了します。
(Ｏ)
bb....bbが"ADT column defined"の場合：
-Wの場合，該当する表からデータベース作成ユティリティ（pdload）の入力となるデータは，データベース再編成ユティリティ（pdrorg）で作成できません。このため，UAPでデータを作成してください。
-jの場合，-jオプションを削除して実行してください。
bb....bbが"unload_row(uoc)"の場合：
-Wの場合，-Wオプションを削除して実行してください。
-k rorgの場合，-k unldに変更して実行してください。
-fの場合，-fオプションを削除して実行してください。
bb....bbが"INSERT ONLY table"の場合：
aa....aaオプションを削除して実行してください。
bb....bbが"ORG status"の場合：
オンライン再編成閉塞を解除してから実行するか，又はaa....aaオプションを削除して実行してください。
KFPL10004-E
Unable to specified aa....aa in Control file when bb....bb　　（Ｅ＋Ｌ）
bb....bbが"ADT column defined"の場合：
抽象データ型が定義されているため，aa....aaは指定できません。
bb....bbが"INSERT ONLY table"の場合：
改竄防止表のため，aa....aaは指定できません。
bb....bbが" invalid condition "の場合：
指定条件が異なるためaa....aaは指定できません。
bb....bbが" Not divided table "の場合：
非分割表の場合，src_work制御文は指定できません。
aa....aa：制御文情報
｛tblname｜unlduoc option job｜option_row(diverskip)｜src_work｝
bb....bb：要因情報
｛ADT column defined｜INSERT ONLY table｜invalid condition｜Not divided table｝
(Ｓ)処理を終了します。
(Ｏ)
bb....bbが"ADT column defined"の場合：
該当する表へデータを移行できません。該当する表のデータを移行したい場合は，UAPで移行元の表からデータ生成して該当する表へ移行してください。
bb....bbが"INSERT ONLY table"の場合：
改竄防止表を移行する場合は-Wオプションを指定してアンロードし，データベース作成ユティリティ（pdload）で移行してください。また，aa....aaオプションは改竄防止表の場合は指定できないので削除して再実行してください。
bb....bbが" invalid condition "の場合：
制御文にoption diverskip=onを指定できません。削除して再実行するか，又は指定可能条件を確認してください。
bb....bbが" Not divided table "の場合：
分割入力データファイルの作成は分割表に対して実行できます。コマンドラインに指定した表が分割表かどうかを確認してください。
KFPL10005-E
Unable to execute aa....aa command by each RDAREA, RDAREA="bb....bb"　　（Ｌ）
次に示す理由によって，RDエリア単位のデータロード又はRDエリア単位の再編成ができません。
・追加したRDエリアを処理対象にしているが，そのRDエリアに対してリバランスユティリティを実行していません。
aa....aa：ユティリティ名称
pdload：データベース作成ユティリティ
pdrorg：データベース再編成ユティリティ
bb....bb：RDエリア名称
(Ｓ)処理を終了します。
(Ｏ)次に示すどちらかの処置をしてください。
・リバランスユティリティの実行後，RDエリア単位のデータロード又はRDエリア単位の再編成を実行してください。
・表単位のデータロード又は表単位の再編成を実行してください。
KFPL10006-E
Unable to execute aa....aa command, Table status=bb....bb, RDAREA=cc....cc, table=dd....dd."ee....ee"　　（Ｌ）
bb....bbが"DATA_UNFINISH"の場合
表がデータ未完状態のため，次のユティリティは実行できません。
・pdload
・pdrorg -k ｛rorg｜ixmk｜ixrc｜ixor｝
・pdrbal
bb....bbが"completed"の場合
表のリロードが完了している（表がデータ未完状態でない）ため，次のユティリティは実行できません。
・pdrorg -k reld
aa....aa：ユティリティ名
pdload：データベース作成ユティリティ
pdrorg：データベース再編成ユティリティ
pdrbal：リバランスユティリティ
bb....bb：表の状態
DATA_UNFINISH：データ未完状態
completed：リロードが完了した状態
cc....cc：RDエリア名
dd....dd：認可識別子
ee....ee：表識別子
(Ｓ)処理を終了します。
[対策]
bb....bbが"DATA_UNFINISH"の場合
データベース再編成ユティリティで表の再編成を完了してから，再度実行してください。
bb....bbが"completed"の場合
該当する表，又はRDエリアへの行の再登録はできません。
KFPL10007-E
Unable to execute aa....aa command on ORG status, RDAREA="bb....bb", reason=cc....cc　　（Ｌ）
RDエリアがオンライン再編成閉塞の場合，cc....ccの理由でaa....aaは実行できません。
aa....aa：ユティリティ名称
pdload：データベース作成ユティリティ
pdrorg：データベース再編成ユティリティ
pdreclaim：空きページ解放ユティリティ
bb....bb：RDエリア名称
cc....cc：理由
BLOB COLUMN defined：BLOB列が定義されています。
INSERT ONLY table：改竄防止表です。
replica RDAREA：RDエリアがレプリカRDエリアです。
current RDAREA：RDエリアがカレントRDエリアです。
(Ｓ)処理を終了します。
[対策]オンライン再編成閉塞を解除した後，再度実行してください。
KFPL11111-E
Time over, no response from utility server, time=(aa....aa, bb....bb)　　（Ｌ）
システム定義のpd_utl_exec_timeオペランド，又はユティリティのoption文に指定したユティリティ実行監視時間内に処理が終了しないため，無応答障害と判断しました。
aa....aa：ユティリティ実行監視時間として設定した値（単位：秒）
bb....bb：タイムアウト時の応答待ち時間（単位：秒）
(Ｓ)異常終了します。
(Ｏ)ユティリティの処理時間として設定したaa....aaの値が妥当でない場合，ユティリティのoption文のexectimeオペランドの指定値を変更して（ログレス閉塞などの障害を回復した後），再度実行してください。指定値が妥当な場合は，ログレス閉塞などの障害を回復した後，ユティリティを再度実行してください。再度実行しても，同様のエラーが発生する場合はHiRDB管理者に連絡してください。
[対策]ユティリティの処理時間として設定したaa....aaの値が妥当なのにタイムアウトした場合は，無応答障害の可能性があります。$PDDIR/spool/saveディレクトリ下と$PDDIR/tmp/コマンド名YYYYMMDDHHMMSSプロセスID.txtファイルを調査用資料として退避し，保守員に連絡してください。
KFPL11724-E
PLUGIN environment definition error, code=aaa　　（Ｅ＋Ｌ）
環境変数の指定に誤りがあります。
aaa：エラーの理由コード
-30：環境変数の格納領域が不正です。
-90：環境変数の指定値が指定できる最大長を超えています。
(Ｓ)処理を終了します。
(Ｏ)理由コードが-90の場合，環境変数の指定を正しくして，再度コマンドを実行してください。
[対策]理由コードが-30の場合，保守員に連絡してください。
KFPL15007-E
Dynamic load error occurred, shared library=aa....aa　　（Ｌ）
処理に必要な共用ライブラリの動的ロードでエラーが発生しました。
aa....aa：共用ライブラリの絶対パス名
(Ｓ)処理を終了します。
(Ｏ)このメッセージの前に出力されたKFPL22000-Eメッセージを参照して，次の観点で原因を取り除き，再度実行してください。
4. EasyMTを使用する場合，インストールが正しくできているか調べてください。
5. EasyMTを使用しない場合，制御情報ファイルを調べて，Easy MT使用の指定を削除してください。
KFPL15010-E
Invalid environment for aa....aa, reason=bb....bb　　（Ｅ＋Ｌ）
ユティリティaa....aaの実行に必要な環境が不正です。
aa....aa：ユティリティ名
bb....bb：理由コード
No-tty：実行環境に端末がありません。
(Ｓ)処理を終了します。
(Ｏ)エラーの理由を参照して，エラーの原因を取り除き，再度実行してください。
No-tty：環境変数PDUSERに認可識別子とパスワードを指定して，コマンドラインで-uを指定しないで，再度実行してください。
KFPL15027-E
Unable to execute pdload command without aa....aa privilege　　（Ｅ）
データロードの表に対するaa....aa権限がありません。このため，データベース作成ユティリティ(pdload)を実行できません。
aa....aa：権限種別
・insert：INSERT権限
・delete：DELETE権限
・audit：監査権限
(Ｓ)処理を終了します。
(Ｏ)データロード時に必要となる権限を与えた後に再度コマンドを実行してください。データロードの対象表が監査証跡表の場合は監査人がコマンドを実行してください。
KFPL15029-E
Table aa....aa. bb....bb not found in system　　（Ｅ）
コマンドラインに指定された表がありません。
bb....bbが*all*の場合は，指定したスキーマには表がありません。又は，ユティリティ実行中にスキーマ内の表が削除されました。
aa....aa：認可識別子
bb....bb：表識別子
(Ｓ)処理を終了します。
(Ｏ)コマンドラインに指定した認可識別子又は表識別子を修正して，再度コマンドを実行してください。また，ユティリティ実行中に表を削除しないでください。
KFPL15030-E
Table definition altered (aa....aa/bb....bb)　　（Ｌ）
ユティリティ実行中に，処理対象の表の定義が変更されました。
aa....aa：内部情報
bb....bb：内部情報
(Ｓ)処理を終了します。
(Ｏ)ユティリティ実行中に表の定義を変更しないでください。表の定義内容を確認し，再度実行してください。
KFPL15031-E
Unable to specify aa....aa table　　（Ｅ）
ビュー表又は外部表は，ユティリティの処理対象の表として指定できません。
aa....aa：表の種別
viewed：ビュー表
foreign：外部表
(Ｓ)処理を終了します。
(Ｏ)コマンドラインに指定した表名を実表の名称に変更した後，再度コマンドを実行してください。
KFPL15034-E
Specified RDAREA aa....aa not found　　（Ｅ）
指定したRDエリア名は，処理対象の表又はインデクスが格納されているRDエリアではありません。
aa....aa：RDエリア名
(Ｓ)処理を終了します。
(Ｏ)RDエリア名を修正して，再度コマンドを実行してください。
KFPL15035-E
Only one RDAREA name can be specified　　（Ｅ）
複数のRDエリア名を指定してデータベース作成ユティリティ(pdload)を実行しようとしましたが，該当する表は，横分割されていません。
(Ｓ)処理を終了します。
(Ｏ)制御情報ファイル内の不要な記述を削除した後，再度コマンドを実行してください。
KFPL15036-E
Specified RDAREA ID not found, ID=aa....aa　　（Ｅ＋Ｌ）
RDエリアID=aa....aaのRDエリアが見付からないため，該当するユティリティを実行できません（RDエリアを誤って削除している可能性があります）。
aa....aa：RDエリアID（実RDエリアID）
(Ｓ)処理を終了します。
(Ｏ)ユティリティ実行中のRDエリアを，ユーザが誤って削除してしまった場合，削除したRDエリアを作成してから，再度ユティリティを実行してください。又は，処理対象となるRDエリアの世代番号を指定して，再度ユティリティを実行してください。
KFPL15037-E
Changed aa....aa, RDAREA "bb....bb"　　（Ｌ）
aa....aaがcurrent generationの場合：
世代（-qオプション）を指定しないでユティリティを実行している場合に，bb....bbのRDエリアの世代がカレントから変更されました。
aa....aaがinner replica statusの場合：
世代（-qオプション）を指定してユティリティを実行している場合に，bb....bbのRDエリアのレプリカステータスが変更されました。
aa....aa：
current generation：カレント世代
inner replica statu：レプリカステータス
bb....bb：RDエリア名
(Ｓ)処理を終了します。
(Ｏ)
・aa....aaがcurrent generationの場合
世代を指定しないでユティリティを実行する場合は，実行中の表が格納されているRDエリアのカレントの世代を変更しないでください。
世代を指定しないで再度実行する場合は，aa....aaのRDエリアの世代を，ユティリティ実行時の世代に戻して再度実行してください。
・aa....aaがinner replica statusの場合
世代を指定してユティリティを実行する場合は，実行中にRDエリアのinner replica statusを変更しないでください。
KFPL15040-E
Insufficient memory on PROCESS　　（Ｅ＋Ｌ）
作業領域が不足しました。
(Ｓ)処理を終了します。
(Ｏ)大量にメモリを使用するプロセスがほかにあるか確認してください。
〈大量にメモリを使用するプロセスがある場合〉
該当するプロセスの終了を待って，再度コマンドを実行してください。
〈大量にメモリを使用するプロセスがない場合〉
次のどれかの方法で，使用できるメモリに余裕を持たせてください。
・同時実行しているプロセスの数を減らしてください。
・スワップ領域を増やしてください。
・実メモリを増設してください。
注　プラグインが提供するコマンド実行時に出力された場合は，出力先種別（L）にだけ出力されます。
KFPL15046-E
aaaaaa error occurred, file=bb....bb　　（Ｅ＋Ｌ）
ファイルへの入出力エラーが発生しました。
aaaaaa：エラーの発生した処理
{Open | Read | Write | Close | Reopen}
bb....bb：ファイル名称
(Ｓ)処理を終了します。なお，ファイルのCloseエラーのときは，処理を続行することがあります。
(Ｏ)このメッセージに続いて出力されるメッセージを参照してエラーの原因を取り除き，再度コマンドを実行してください。
KFPL15047-E
File I/O error occurred, reason=aa....aa, func=bb....bb, errno=cc....cc, (dd....dd)　　（Ｅ＋Ｌ）
ファイル入出力中にエラーが発生しました。
aa....aa：エラーの理由
Date-check：マウントされているテープの作成日付がvalidateオぺランド指定日より古いです。
Empty-file：指定されたファイルは空（0バイト）です。
File-format：指定した形式と実際のファイル形式が異なります。指定したファイル名が誤っているか，又はコマンドラインや制御文に指定したファイルの形式と内容が一致していない可能性があります。なお，DAT形式入力ファイルの場合，1行のデータ長が32キロバイトを超えているときは，source制御文にmaxreclenオペランドを指定する必要があります。
File-lock：該当するファイルは，ほかのユーザが使用しています。コマンドラインや制御文に指定したファイル名が，別のジョブで使用中のファイル名と重複しているか，又はOSのカーネルパラメタのファイルロック用資源が不足している可能性があります。
File-sequence：マルチボリュームのファイル順序が不正です。
Invalid-device：指定されたファイルのエントリタイプ（属性）が不正です。又は，MTguideを使用している場合，MTguideが起動されていません。エントリタイプが識別できる場合は英字1文字を括弧に入れて表示します。この文字は，OSのls -lコマンドで出力したモードのエントリと同じです。ファイル名を指定する必要がある箇所にディレクトリ名を指定したり（又はその逆），キャラクタ型スペシャルファイルを使用できないファイルにキャラクタ型スペシャルファイルを割り当てたりしている可能性があります。
Invalid-environment：unameシステムコールで得られる設定値が誤っているため，ストリーミングテープ装置が使用できません。OSが正しく組み込まれているか，又はOSのバージョンがHiRDBシステムや関連プログラムプロダクトの前提条件に合っているかどうかを確認してください。
Invalid-parameter：指定したパラメタの組み合わせが不正です。
Invalid-path：パス名が誤っています。
Invalid-permission：指定したファイルのパーミションが不正（アクセス権限エラー）です。HiRDB管理者にファイルアクセス権限を与えていないファイルを使用しているか，又はMTの場合はライトプロテクトが掛かっている可能性があります。
No-data：同期点で記憶されているデータ件数分のデータが，指定されたファイルにありません。
No-file：読み込み用のファイルがありません。又は，書き込み中のファイルが削除されました。
No-space：書き込むファイルに十分な容量がありません。ディスク容量が十分な状態でこのエラーになる場合は，HiRDBファイルシステム領域をラージファイルとして定義していないか，又はOSのカーネルパラメタの制限に該当している可能性があります。
No swap-file：マルチボリューム用のアンロードデータファイルがありません。
容量を見直してください。又は，マルチボリュームを指定してください。読み込み処理でこのエラーとなる場合，書き込み処理（アンロード処理など）が正常に終了していないファイルを使用している可能性があります。
Same-file：マルチボリュームのファイルとして，直前に処理したファイルと同じファイルを指定しています。又は，マルチボリュームへの書き込み時，現ボリューム以前のボリュームに上書きしようとしました。
Unmatch-entry：ヘッダがあるファイルに対して，ヘッダ中のエントリが制御情報ファイルの指定と一致しません。一致しないエントリ名称を（　）の中に表示します。
bb....bb：エラーが発生した関数名
・OSがエラーを検知した場合はシステム関数名
・HiRDBファイルシステムでエラーを検知した場合はp_f_iosで始まるHiRDBファイルシステムの関数名
・上記以外の場合は「***」
cc....cc：エラーコード
・OSがエラーを検知した場合はシステム関数が返却したエラー番号（errno：エラー状態を表す外部参照変数）。
・HiRDBファイルシステムでエラーを検知した場合はHiRDBファイルシステムのエラーコード。エラーコードについては，「HiRDBファイルシステムに対するアクセス要求から返されるエラーコード」を参照してください。考えられる主なエラー原因と対処を次に示します。
-1511：指定したファイルパス名がHiRDBファイルシステムのファイル名称規則に違反している可能性があります。領域名は117文字以内，ファイル名は30文字以内としてください。
-1532：指定したファイルパス名が誤っている可能性があります。ファイルパス名を修正してください。なお，HiRDBファイルシステム名だけ指定して，ファイル名まで指定していない場合，ファイル名まで指定してください。
-1534：指定したファイル名が別のジョブで使用中のファイル名と重複している可能性があります。ファイル名を変更してください。
-1535：容量不足です。なお，処理開始直後に容量不足となる場合は，コマンドラインや制御文に指定したファイルサイズの指定値が，HiRDBファイルシステムの制限値を超えていることが考えられます。pdfmkfsコマンドで容量の大きいHiRDBファイルシステムを作成するか，コマンドラインや制御文に指定した，初期容量サイズや増分容量サイズを見直してください。
-1538：pdfmkfsコマンドで初期化していないファイルを指定しています。pdfmkfsコマンドで初期化したファイルを使用してください。
-1540：HiRDBファイルシステム名へのアクセス権限がありません。HiRDB管理者に対してアクセス権限を与えてください。
-1562：pdfmkfs -k UTLコマンドで初期化されたHiRDBファイルシステムではありません。pdfmkfsコマンドの-kオプションにUTLを指定して初期化したファイルを指定してください。
・上記以外のエラー要因の場合は「0」。
dd....dd：トラブルシュート情報（障害を検知したソースファイル名と行番号）。なお，これは保守員が確認する情報です。
(Ｓ)処理を終了します。
(Ｏ)エラーの理由，関数名，及びエラーコードから，errno.h，ユーザが使用するOSのマニュアル，及び「HiRDBファイルシステムに対するアクセス要求から返されるエラーコード」を参照してエラーの原因を取り除き，再度実行してください。
KFPL15048-E
File operation was canceled by aa....aa　　（Ｅ＋Ｌ）
マルチボリュームファイルのファイル交換がキャンセルされました。
aa....aa：キャンセルの要因
system：システムによるキャンセル
user：ユーザによるキャンセル
(Ｓ)処理を終了します。
(Ｏ)キャンセルされた処理が必要な場合，再度実行してください。
KFPL15049-I
MT was created at aa....aa　　（Ｌ＋Ｓ）
入力データファイルに指定されたMTの作成日付はYYYY年MM月DD日です。
aa....aa：マウントされているMTのラベルに記述されている作成日付
（形式）YYYY-MM-DD
YYYY：年
MM：月
DD：日
(Ｓ)制御情報ファイルのvalidateオペランドに指定した日付以前・日数以上前に作成されたファイルの場合は処理を打ち切ります。オペランドに指定した日付以降・日数以内に作成されたファイルの場合は処理を続行します。
(Ｏ)処理が打ち切られた場合は，正しい作成日付のMTをマウントし直してから，再度実行してください。
KFPL15050-E
EasyMT error occurred, func=aa....aa, reason=bb....bb　　（Ｌ）
EasyMTを使用したファイル入出力処理で，エラーが発生しました。
aa....aa：エラーを検知した関数名
bb....bb：エラー詳細情報
(Ｓ)処理を終了します。
(Ｏ)エラー詳細情報を参考に，マニュアル「磁気テープ運用支援 JP1/Magnetic Tape Access」，又はマニュアル「磁気テープ簡易アクセス法 EasyMT」を参照して，エラー原因を取り除き再度実行してください。
KFPL15052-E
Invalid aa....aa statement bb....bb entry in Control file, value=cc....cc, reason=dd....dd　　（Ｌ）
制御情報ファイル中のaa....aa制御文のbb....bbエントリに指定してある値cc....ccが不正です。
aa....aa：制御文種別
bb....bb：エントリ名称
cc....cc：指定値
dd....dd：理由コード
Invalid-device：ファイル形式が不正です。
Invalid-permission：ファイルパーミッションが不正です。
No-directory：ディレクトリがありません。
Pathname-length：ファイルパス名の長さが不正です。
なお，制御情報ファイルで省略した項目については，省略時仮定値が表示されます。
(Ｓ)処理を終了します。
(Ｏ)制御情報ファイルの該当する項目を調査して，エラーの原因を取り除き，再度実行してください。
KFPL15059-E
aa....aa directory not found　　（Ｌ）
インデクス情報ファイル用ディレクトリとして指定された名称は，ディレクトリではありません。
aa....aa：制御情報ファイルに指定されたディレクトリ名称
(Ｓ)処理を終了します。
(Ｏ)制御情報ファイルに指定したディレクトリ名を修正して，再度コマンドを実行してください。
KFPL15060-E
Invalid file for index information file, file=aa....aa, reason=bb....bb　　（Ｌ）
インデクス情報ファイルとして指定したファイルaa....aaは，不正です。
aa....aa：指定したファイル名称
ファイル名称の長さが135文字以上の場合は，ファイル名称の後ろから134文字を出力します。
bb....bb：理由コード
Duplicated-entry：複数のファイルを指定したときに，同じファイルがあります。
Invalid-device：ファイルの形式が不正です。
Invalid-header：ヘッダIDがありません。
Invalid-permission：指定したファイルのパーミッションが不正です。
Invalid-record-length：複数のファイルを指定したときに，レコード長の異なるファイルがあります。
No-file：ファイルがありません。
No-header：ヘッダがありません。
(Ｓ)処理を終了します。
(Ｏ)インデクス情報ファイルに指定したファイルと理由コードを基に，エラーの原因を取り除き，再度実行してください。
KFPL15061-E
Imcomplete record found in index information file, file=aa....aa, reason=bb....bb　　（Ｌ）
インデクス情報ファイルaa....aa中のレコードに不正なレコードがあります。
aa....aa：指定したファイル名称
ファイル名称の長さが119文字以上の場合は，ファイル名称の後ろから118文字を出力します。
bb....bb：理由コード
Tally-length：固定長の総レコード長が整数倍ではありません。
Valiable-record：可変長のデータ部分長が不正です。
(Ｓ)処理を終了します。
(Ｏ)インデクス情報ファイルが壊れています。このため，インデクスを再作成して，再度実行してください。
KFPL15062-E
aa....aa error occurred, func=bb....bb, rc=cc....cc　　（Ｅ＋Ｌ）
aa....aaで示すプログラムプロダクトでエラーが発生しました。
aa....aa：プログラムプロダクトの名称
{ SORT | EasyMT }
bb....bb：エラーの発生した関数名
cc....cc：エラーの発生した関数のリターンコード
(Ｓ)処理を終了します。
(Ｏ)該当するマニュアルを参照してエラーの原因を調査し，対応してください。なお，マニュアルに，記載されていないとき，又は記載されている内容では対応できないときは，保守員に連絡してください。
SORT：主な原因と対処を次に示します。次に示す原因以外の場合は，マニュアル「ソートマージ」を参照してください。KBLSnnn-Eのnnnにエラーコードの絶対値をあてはめて原因を調査してください。
・-202：メモリ不足です。
sortオペランドに指定したワークバッファサイズを小さくしてください。
・-290：ワークバッファ不足です。
sortオペランドに指定したワークバッファサイズを大きくしてください。
・-210，-230：ソートワーク用ディスク不足です。
sortオペランドに十分な容量があるディスクを指定してください。
EasyMT：マニュアル「磁気テープ運用支援 JP1/Magnetic Tape Access」，又はマニュアル「磁気テープ簡易アクセス法 EasyMT」を参照してください。
KFPL15063-E
aa....aa failed, index=bb....bb, authid=cc....cc, file=dd....dd, RDAREA=ee....ee　　（Ｌ）
aa....aaの処理中にエラーが発生しました。
aa....aa：処理内容
Check-status：インデクス状態チェックの処理中
Commit：インデクスの作成終了中
Load-index：インデクスの作成中
Preparation：処理の準備
Purge-index：インデクスの削除処理中
Unfinish-index：インデクス未完状態の処理中
bb....bb：インデクス識別子
cc....cc：認可識別子
dd....dd：ファイル名称
ファイル名称の長さが53文字以上の場合は，ファイル名称の後ろから52文字を出力します。
ee....ee：RDエリア名
名称が特定できない場合は，'**....**'を表示します。
(Ｓ)処理を終了します。
(Ｏ)このメッセージの前に出力されたメッセージを参照して，エラーの原因を取り除いた後，再度実行してください。
KFPL15064-E
Specified index information file=aa....aa conflicted with command line specification, reason=bb....bb　　（Ｌ）
コマンドラインの指定とインデクス情報ファイルaa....aaの内容との間に，bb....bbの矛盾があります。
aa....aa：ファイル名称
ファイル名称の長さが96文字以上の場合は，ファイル名称の後ろから95文字を出力します。
bb....bb：理由コード
Invalid-table：認可識別子又は表識別子が異なります。
(Ｓ)処理を終了します。
(Ｏ)コマンドラインの認可識別子又は表識別子の指定とインデクス情報ファイルを調査し，エラーの原因を取り除いた後，再度実行してください。
KFPL15065-E
Index aa....aa on table bb....bb.cc....cc not found in server=dd....dd　　（Ｌ）
表bb....bb.cc....ccのインデクスaa....aaは，サーバdd....ddにありません。
aa....aa：インデクス名
bb....bb：認可識別子
cc....cc：表識別子
dd....dd：サーバ名
(Ｓ)処理を終了します。
(Ｏ)制御文又はコマンドラインに指定したサーバ名を修正して，再度実行してください。
KFPL15066-E
Index record in aa....aa not available for bb....bb.cc....cc, reason=dd....dd(system=ee....ee, file=ff....ff)　　（Ｌ）
インデクス情報ファイルのファイル名aa....aaは，インデクスbb....bb.cc....ccの最新のファイルではありません。
aa....aa：ファイル名称
ファイル名称の長さが次の計算式で求めた値を超える場合は，ファイル名称の後ろから計算式で求めた値分の文字数を出力します。
理由コードがTable-divisionの場合：
100－認可識別子長－インデクス識別子長
理由コードがUnload-timeの場合：
97－認可識別子長－インデクス識別子長
bb....bb：認可識別子
cc....cc：インデクス識別子
dd....dd：理由コード
Table-division：表の横分割で分割した数と一致しません。
Unload-time：インデクス情報ファイルを作成した日付が一致しません。最新のインデクス情報ファイルを作成(-i c又はn指定の場合）した，又はインデクスを無効とした(-i x指定の場合）とした日付がee....eeに，指定したインデクス情報ファイルの作成日付がff....ffに，%Y-%m-%d %H：%M：%Sの形式で出力されます。ただし，リロードが済んでいるときは，loadedが出力されます。
ee....ee：HiRDBシステムの値
ff....ff：インデクス情報ファイルの値
(Ｓ)処理を終了します。
(Ｏ)最新のインデクス情報ファイルで再度実行してください。
又は，インデクスを再作成してください。
KFPL15067-E
Unmatched number of index information file=aa....aa, table division=bb....bb at server=cc....cc, index=dd....dd　　（Ｌ）
制御情報ファイルのindex文で指定したインデクス情報ファイルの数がサーバ内の表の横分割数と異なっています。
aa....aa：制御情報ファイル内に指定したindex文の数
bb....bb：横分割表をサーバ内で分割した数
cc....cc：サーバ識別子
dd....dd：インデクス名称
(Ｓ)処理を終了します。
(Ｏ)制御情報ファイル中のindex文をサーバ内で分割されている数だけ指定して，再度実行してください。
KFPL15068-E
Specified index information file=aa....aa conflicted with Control file specification, reason=bb....bb　　（Ｌ）
制御情報ファイル内の指定とインデクス情報ファイルaa....aaの内容との間にbb....bbの矛盾があります。
aa....aa：ファイル名称
ファイル名称の長さが114文字以上の場合は，ファイル名称の後ろから113文字を出力します。
bb....bb：理由コード
Unload-condition：制御情報ファイルで分割表の非分割インデクスをRDAREA単位でアンロードしたファイルを指定したが，指定したファイル中には，表単位でアンロードしたインデクス情報ファイルがあります。
Invalid-index：インデクス名が異なります。
Invalid-RDAREA：RDエリア名が異なります。
Invalid-RDAREA-id：RDエリアの識別番号が異なります。
(Ｓ)処理を終了します。
(Ｏ)制御情報ファイルのindex文に指定したインデクス情報ファイルを調査し，エラーの原因を取り除いた後，再度実行してください。
KFPL15069-E
Unmatched index records, files=aa....aa,bb....bb　　（Ｌ）
aa....aaとbb....bbのインデクス情報ファイルのインデクス情報が同じものではありません。
aa....aa：インデクス情報ファイル名
bb....bb：インデクス情報ファイル名
ファイル名の長さが86文字以上の場合は，ファイル名の後ろから85文字を出力します。
(Ｓ)処理を終了します。
(Ｏ)制御情報ファイルを修正した後，再度実行してください。
KFPL15070-E
aa....aa failed, status=bb　　（Ｌ）
aa....aaの処理中にエラーが発生しました。
aa....aa：処理内容
Check-Status：インデクス状態チェック処理
bb：ステータス
1：インデクス情報ファイル作成後，次のユティリティの実行によって表の内容が変更されています。そのため，インデクス情報ファイルの内容と表の内容が異なっていて，インデクス情報ファイルが使用できません。
・RDエリア単位のpdload，pdrorgの実行
・インデクスがある表を格納したRDエリアの再初期化（pdmodの実行）
3及び4：インデクスが既に作成されています。
(Ｓ)処理を終了します。
(Ｏ)
・ステータスが1の場合
pdload，pdrorgで作成したインデクス情報ファイルを基にインデクスを作成してください。又は，pdrorgでインデクスの再作成（-k ixrc）をしてください。
・ステータスが3及び4の場合
作成するインデクスが正しいか確認してください。
KFPL15071-E
Unmatched generation number between number "aa" of bb....bb "cc....cc" and number "dd" of command line　　（Ｌ）
bb....bbの世代番号aaと，-qオプションの世代番号（-qオプションを指定していない場合はカレントの世代番号）ddが一致していません。
aa：bb....bbの世代番号
bb....bb：ファイルの種別
index-record-file：インデクス情報ファイル
Lobmid-file：LOB中間ファイル
unload-file：アンロードデータファイル
cc....cc：bb....bbのファイル名
dd：-qオプションで指定した世代番号（-qオプション省略時はカレントの世代番号）
(Ｓ)処理を終了します。
(Ｏ)
・ddが正しい場合
-qオプション指定の世代番号で作成したbb....bbを制御文に指定して，再度実行してください。
・ddが誤っている場合
bb....bbを作成した世代番号を-qオプションに指定して，再度実行してください。
KFPL15101-E
Specified column aa....aa not found　　（Ｅ）
列構成情報ファイルに指定した列名が表を構成する列名にありません。
aa....aa：列名
(Ｓ)処理を終了します。
(Ｏ)列構成情報ファイルに指定した列名を修正して，再度コマンドを実行してください。なお，列構成情報ファイルには，不要なタブや空白は指定できません。このため，列名を指定するときは不要なタブや空白を指定しないようにしてください。
KFPL15102-E
Column aa....aa is duplicated　　（Ｅ）
列構成情報ファイルに指定した列名が重複しています。
aa....aa：列名
(Ｓ)処理を終了します。
(Ｏ)誤って重複指定した列名を列構成情報ファイルから削除して，再度コマンドを実行してください。
KFPL15199-E
Logical inconsistency occurred in aa....aa, data=bb....bb　　（Ｌ）
プログラムに論理的な不整合が発生しました。
aa....aa：関数名称
bb....bb：不正なデータ
(Ｓ)処理を終了します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]保守員に連絡してください。
KFPL15224-E
Insert error occurred at aa....aaTH row, table=bb....bb.cc....cc　　（Ｌ）
aa....aa番目の行をリロードしたときにエラーが発生しました。
aa....aa：行番号
bb....bb：認可識別子
cc....cc：表識別子
(Ｓ)処理を終了します。
(Ｏ)このメッセージの前に，ログファイルに出力されたメッセージを基にエラーの原因を調査して，再度コマンドを実行してください。
KFPL15225-E
Rollback called　　（Ｌ）
このメッセージの前に出力されたメッセージログファイルに示す理由でロールバックしました。
(Ｓ)
〈-lオプションにnを指定した場合〉
異常終了します。なお，この場合のデータベース状態はエラー発生時のままです。
〈-lオプションにa又はpを指定した場合〉
処理を終了します。
(Ｏ)このメッセージの前に出力されたメッセージログファイルを調査し，ロールバックの原因を取り除いてください。-lオプションにnを指定している場合は，あらかじめ取得しておいたバックアップを使用して，このユティリティを実行する前の状態に回復してください。
KFPL15226-E
aa....aa request failed, table=bb....bb.cc....cc, server=dd....dd　　（Ｌ）
aa....aaの処理中に表でエラーが発生しました。
aa....aa：処理内容
Scan：行の検索処理
Delete：行の削除処理
Insert：行の挿入処理
LOB delete：LOBデータの削除処理
LOB insert：LOBデータの挿入処理
LOB scan：LOBデータの検索処理
Map purge：LOBデータの定義情報の削除処理
LOB length：LOBデータの長さを取得する処理
bb....bb：認可識別子
cc....cc：表識別子
dd....dd：サーバ名
(Ｓ)処理を終了します。
(Ｏ)このメッセージの前にメッセージログファイルに出力されているメッセージを参照して，エラーの原因を取り除いてください。
KFPL15227-E
Unable to aa....aa without bbbbbb privilege　　（Ｅ）
表のアクセス権限がないため，aa....aaコマンドは実行できません。
aa....aa：コマンド
pdrorg：データベース再編成ユティリティ
pdreclaim：データベース再編成ユティリティ
pdpgbfon：グローバルバッファ常駐化ユティリティ
bbbbbb：必要なアクセス権限
DBA：DBA権限
audit：監査権限
delete：DELETE権限
insert：INSERT権限
select：SELECT権限
(Ｓ)処理を終了します。
(Ｏ)表のアクセス権限を与えてもらった後に再度コマンドを実行してください。監査証跡表に対する処理の場合は監査人がコマンドを実行してください。
KFPL15229-E
Unable to get aa....aa information, table=bb....bb.cc....cc　　（Ｌ）
このメッセージの前に出力されているメッセージの内容が原因で，定義情報aa....aaを取得できません。
aa....aa：定義情報の種別
ADT：抽象データ型情報
AUDIT：監査事象の定義情報
cluster：クラスタキー情報
column：列情報
divide：分割情報
gen：世代番号
index：インデクス情報
LOB：LOB情報
multidim：マトリクス分割情報
privilege：アクセス権限情報
rdarea：RDエリア情報
schema：スキーマ情報
server：サーバ情報
table：表の情報
bb....bb：認可識別子
cc....cc：表識別子
名称が特定できない場合は，**....**を表示します。
スキーマ単位の場合は，*all*を表示します。
(Ｓ)処理を終了します。
(Ｏ)このメッセージの前に出力されたメッセージログファイルのメッセージを参照して，エラーの原因を取り除き，再度コマンドを実行してください。
注　プラグインが提供するコマンド実行時に出力された場合は，出力先種別（E＋L）に出力されます。
KFPL15231-E
cc....cc table aa....aa.bb....bb cannot be specified for table name　　（Ｌ）
指定された表は実表でないため，処理できません。
aa....aa：認可識別子
bb....bb：表識別子
cc....cc：表の種別
Viewed：ビュー表
Foreign：外部表
(Ｓ)処理を終了します。
(Ｏ)指定した表の名称を見直し，正しい実表の名称を指定した後，再度コマンドを実行してください。
注　プラグインが提供するコマンド実行時に出力された場合は，出力先種別（E＋L）に出力されます。
KFPL15234-E
Specified RDAREA aa....aa not found, table=bb....bb.cc....cc　　（Ｅ＋Ｌ）
-rオプションで指定したRDエリア名aa....aaは，表bb....bb.cc....ccを構成するRDエリアではありません。
aa....aa：RDエリア名
bb....bb：認可識別子
cc....cc：表識別子
(Ｓ)処理を終了します。
(Ｏ)指定したRDエリア名を修正した後，再度コマンドを実行してください。
KFPL15240-E
Insufficient memory on PROCESS, size=aa....aa,part=bb....bb, code=cc....cc　　（Ｌ）
メモリ不足が発生しました。
aa....aa：不足したメモリサイズ（単位：バイト）
ただし，確保しようとしたメモリサイズが2ギガバイトを超えていた場合，負の値で表示します。
bb....bb：パート番号
cc....cc：パートコード
(Ｓ)処理を終了します。
(Ｏ)大量にメモリを使用するプロセスがほかにあるか確認してください。
〈大量にメモリを使用するプロセスがある場合〉
該当するプロセスの終了を待って，再度コマンドを実行してください。
〈大量にメモリを使用するプロセスがない場合〉
次のどれかの方法で，使用できるメモリに余裕を持たせてください。
・同時実行しているプロセスの数を減らしてください。
・スワップ領域を増やしてください。
・実メモリを増設してください。
KFPL15246-E
aa....aa error occurred, file=bb....bb　　（Ｌ）
ファイルの削除に失敗しました。
aa....aa：{Unlink | EasyMT}
bb....bb：ファイル名称
ファイル名称の長さが151文字以上の場合は，ファイル名称の後ろから150文字を出力します。
(Ｓ)処理を続行します。
(Ｏ)Unlinkの場合，ファイルが削除されていないので，必要がないときはファイルを削除してください。
KFPL15281-E
No index on table aa....aa.bb....bb　　（Ｌ）
指定した表aa....aa.bb....bbにはインデクスが定義されていません。このため，インデクスを作成できません。
aa....aa：認可識別子
bb....bb：表識別子
(Ｓ)処理を終了します。
(Ｏ)指定した表の名称を見直し，インデクスが定義されている表の名称を指定した後，再度コマンドを実行してください。
KFPL15282-E
No LOB column on table aa....aa.bb....bb　　（Ｌ）
指定された表には，LOB列が定義されていません。このため，LOBの処理はできません。
aa....aa：認可識別子
bb....bb：表識別子
(Ｓ)処理を終了します。
(Ｏ)指定した表の名称を見直してください。LOBを処理する場合，LOB列が定義されている表の名称を指定して，再度コマンドを実行してください。
KFPL15283-E
Unable to execute pdrorg command, aa....aa not support　　（Ｌ）
aa..aaは現在のデータベース再編成ユティリティ（pdrorg）のバージョンではサポートされていないため実行できません。
aa....aa：
ADT column：抽象データ型の列
ADT return：抽象データ型を返却するコンストラクタパラメタ逆生成関数
(Ｓ)処理を終了します。
(Ｏ)aa....aaがADT returnの場合，-W指定のアンロードはできません。表の再編成，及び他表へのデータ移行をする場合は，-W指定なしでアンロードできないか検討してください。また，アンロードデータをUAPで参照する場合は，ほかの関数でアンロードするか，又はUAPでデータを抽出してください。
[対策]データベース再編成ユティリティ（pdrorg）の実行を中止してください。
KFPL15284-E
Unable to execute aa....aa, PLUGIN not support bb....bb function　　（Ｌ）
プラグインがbb....bb機能を提供していないため，aa....aa機能は実行できません。又はLOB用RDエリアを使用するプラグインに関してはbb....bb機能をサポートしていないためaa....aa機能は実行できません。
aa....aa：実行した機能
ixmk：インデクス一括作成
pdreclaim：空きページ解放ユティリティ
pdpgbfon：グローバルバッファ常駐化ユティリティ
bb....bb：プラグインが提供する機能
INDEX_LOAD：プラグインインデクスの一括作成部分回復機能
PAGE_FREE：使用中空きページの解放
PAGE_READ ：グローバルバッファへのデータ読み込み機能
(Ｓ)処理を終了します。
(Ｏ)プラグインインデクスを作成する場合は，インデクスの再作成（-k ixrc）を実行してください。また，pdpgbfonは，LOB用RDエリアに対して処理できません。コマンドの実行を中止してください。
KFPL15285-E
Unable to specified aa....aa option, PLUGIN not support bb....bb function　　（Ｌ）
プラグインがbb....bb機能をサポートしていないため，aa....aaオプションは指定できません。
aa....aa：オプション｛-i n：インデクス情報出力モード｝
bb....bb：実装機能｛INDEX_LOAD：プラグインインデクス一括作成部分回復機能｝
(Ｓ)処理を終了します。
(Ｏ)aa....aaが-i nの場合，インデクス作成モードを-i c（インデクス一括作成モード），又は-i s（インデクス更新モード）にしてください。
KFPL15286-E
Column "aa....aa" cannot be specified in bb....bb　　（Ｅ＋Ｌ）
列aa....aaは，BLOB属性を返却するコンストラクタパラメタ逆生成関数を持っていないので，bb....bbには指定できません。
aa....aa：列名
bb....bb：種別
blobtovarchar_row：blobtovarchar文の行
(Ｓ)処理を終了します。
(Ｏ)種別がblobtovarchar_rowの場合，コンストラクタパラメタ逆生成関数の返却値の型がBLOB型の抽象データ型を指定して，再度コマンドを実行してください。
KFPL15287-E
Unable to convert data, column=bb....bb, line=aa....aa　　（Ｅ＋Ｌ）
列aa....aaのbb....bb行目のデータは，データ変換できません。
aa....aa：列名
bb....bb：行番号
(Ｓ)処理を終了します。
(Ｏ)blobtovarchar文で指定した抽象データ型の，コンストラクタパラメタ逆生成関数が返却したBLOB型データに，32キロバイト以上のデータがあるか確認してください。ある場合は，そのデータを32キロバイトより小さくして再度実行してください。
KFPL15288-E
Unable to data copy, data size=aa....aa, limit=bb....bb, line=cc....cc　　（Ｅ＋Ｌ）
データ長aa....aaのcc....cc行目のBLOBデータは，メモリ確保量bb....bbよりも大きいため，データをコピーできません。
aa....aa：データ長
bb....bb：メモリ確保量
cc....cc：行番号
(Ｓ)処理を終了します。
(Ｏ)
・option文でloblimitオペランドを指定している場合，指定値をデータ長よりも大きくして，再度実行してください。
・option文でloblimitオペランドを指定していない場合，データ長よりも大きい値をoption文でloblimitオペランドに指定して，再度実行してください。
KFPL15300-E
Invalid unload file, file=aa....aa　　（Ｌ）
指定したアンロードデータファイルは，正常に作成されたものではありません。
aa....aa：アンロードデータファイル名称
アンロードデータファイル名称の長さが151文字以上の場合は，アンロードデータファイル名称の後ろから150文字を出力します。
(Ｓ)処理を終了します。
(Ｏ)アンロード処理で正常に作成されたアンロードデータファイルを指定し，再度コマンドを実行してください。
KFPL15301-E
Unable to reload file by aa....aa, file=bb....bb　　（Ｌ）
指定されたアンロードデータファイルは，ユーザ用RDエリア又はディクショナリ用RDエリアの表ごとにアンロードされたものではありません。このため，-cオプションで指定された単位にリロードできません。
aa....aa：リロード時の単位
{ user table | dictionary }
bb....bb：アンロードデータファイル名称
アンロードデータファイル名称の長さが151文字以上の場合は，アンロードデータファイル名称の後ろから150文字を出力します。
(Ｓ)処理を終了します。
(Ｏ)ユーザ用RDエリアの表ごとにアンロードデータファイルが作成されている場合，表ごとにリロードしてください。また，ディクショナリ用RDエリアの表単位にアンロードデータファイルが作成されている場合，ディクショナリ表単位にリロードしてください。
KFPL15302-E
Invalid aa....aa file, kind=bb....bb, file=cc....cc　　（Ｌ）
aa....aaに指定されたファイルは，bb....bbが格納されているファイルです。実行する処理とファイルの内容が一致しないため，使用できません
aa....aa：実行する処理 { lobunld | unload }
bb....bb：指定したファイルの内容
table：基表
LOB：LOBデータ
table（LOB）：基表とLOBデータ
cc....cc：アンロードデータファイル名称
アンロードデータファイル名称の長さが151文字以上の場合は，アンロードデータファイル名称の後ろから150文字を出力します。
(Ｓ)処理を終了します。
(Ｏ)実行する処理とファイルの内容を一致させて再度実行してください。
〈lobunld文を実行する場合〉
LOBデータをアンロードしたファイルを指定してください。
〈unload文を実行する場合〉
基表をアンロードしたファイルを指定してください。
また，基表とLOBデータを同時にアンロードしたファイルを使用する場合は，コマンドオプションに-jを指定してください。
KFPL15305-E
Table aa....aa.bb....bb not found in unload file, file=cc....cc　　（Ｌ）
指定した表aa....aa，bb....bbは，アンロードデータファイル中にありません。
aa....aa：認可識別子
bb....bb：表識別子
cc....cc：アンロードデータファイル名称
アンロードデータファイル名称の長さが次の計算式で求めた値を超える場合は，アンロードデータファイル名称の後ろから計算式で求めた値分の文字数を出力します。
169－認可識別子長－表識別子長
(Ｓ)処理を終了します。
(Ｏ)表が格納されているアンロードデータファイルを指定し，再度コマンドを実行してください。又は，指定した表名に誤りがあれば，表名を修正し，再度コマンドを実行してください。
KFPL15308-E
Number of aa....aa.bb....bb columns not equel to unload file, file=cc....cc　　（Ｌ）
アンロードデータファイル中の表aa....aa.bb....bbの列数とリロード先の表の列数が一致しません。
aa....aa：認可識別子
bb....bb：表識別子
cc....cc：アンロードデータファイル名称
アンロードデータファイル名称の長さが次の計算式で求めた値を超える場合は，アンロードデータファイル名称の後ろから計算式で求めた値分の文字数を出力します。
157－認可識別子長－表識別子長
(Ｓ)処理を終了します。
(Ｏ)指定した表のアンロードデータファイルを作成し，再度コマンドを実行してください。
KFPL15310-E
aa....aa information of bb....bb.cc....cc not equal to unload file, file=dd....dd　　（Ｌ）
アンロードデータファイル中の表aa....aa.bb....bbの定義（分割定義又はLOB列定義）とリロード表の定義が異なるため，リロードできません。また，LOBを処理する場合は，分割定義がアンロードデータファイルとリロード表定義で異なるときは，処理できません。
aa....aa：指定した表の定義内容
Divided：分割定義
LOB：LOB列定義
Divided（LOB）：分割定義（LOB処理）
bb....bb：認可識別子
cc....cc：表識別子
dd....dd：アンロードデータファイル名称
アンロードデータファイル名称の長さが次の計算式で求めた値を超える場合は，アンロードデータファイル名称の後ろから計算式で求めた値分の文字数を出力します。
147－認可識別子長－表識別子長
(Ｓ)処理を終了します。
(Ｏ)指定した表のアンロードデータファイルを作成して，リロードしてください。
KFPL15311-E
Table aa....aa.bb....bb definition altered RDAREA information not not equal to unload file, file=cc....cc　　（Ｌ）
表aa....aa.bb....bbは，アンロード時に定義していた表格納RDエリア情報と，リロード時に定義している表格納RDエリア情報が異なるため，リロードできません。
aa....aa：認可識別子
bb....bb：表識別子
cc....cc：アンロードデータファイル名称
アンロードデータファイル名称の長さが次の計算式で求めた値を超える場合は，アンロードデータファイル名称の後ろから計算式で求めた値分の文字数を出力します。
131－認可識別子長－表識別子長
(Ｓ)処理を終了します。
(Ｏ)アンロード時に定義していたRDエリアを追加して，再度コマンドを実行してください。
KFPL15312-E
Unable to reload divided method altered　　（Ｌ＋Ｅ）
アンロード時の表分割方法とリロード時の表分割方法とが異なるため，-gオプション指定のないリロードはできません。分割方法を変更したためにリロードできない例を次に示します。
・フレキシブルハッシュ分割表，FIXハッシュ分割表，非分割表からキーレンジ分割表へのリロード
・キーレンジ分割表，フレキシブルハッシュ分割表，非分割表からFIXハッシュ分割表へのリロード
・FIXハッシュ分割表からFIXハッシュ分割表へのリロードで分割条件を変更した場合
・キーレンジ分割表からキーレンジ分割表へのリロードで分割条件を変更した場合
なお，RDエリア単位の再編成で表分割方法が異なる表へのリロードはできません。
(Ｓ)処理を終了します。
(Ｏ)次に示す方法で分割方法を変更してください。
〈アンロードファイルを１本化できる場合〉
-gオプション指定でアンロードした後，表定義を変更して-gオプション指定のリロードをしてください。
〈アンロードファイルを１本化できない場合〉
-Wオプション指定でアンロードした後，表定義を変更してデータベース作成ユティリティでデータロードしてください。
KFPL15313-E
Abstract data type definition altered, table=aa....aa.“bb....bb“, COLUMN="cc....cc“, TYPE="dd....dd“, attribute=ee....ee　　（Ｌ）
アンロード時の抽象データ型定義と，リロード時の抽象データ型定義が異なるためリロードできません。詳細については，KFPL15314-Eメッセージを参照してください。
aa....aa：認可識別子
bb....bb：表識別子
cc....cc：列名称
dd....dd：抽象データ型名
ee....ee：アンロード時と異なる属性
TYPE_NAME：データ型の名称
PLUGIN_ID：プラグインID
DEF_ATTR_NUM：抽象データ型の属性数
DEF_ATTR_DTYPE：属性のデータ型
DEF_ATTR_DLEN：属性の定義長
DEF_ATTR：抽象データ型の属性定義
LOB_RDAREA_NUM：LOB列格納用RDエリア数
LOB_RDAREA：LOB属性のデータを格納するRDエリア
LOB_RDAREA_ID1～3：LOB列格納用RDエリアの属性1～3
LOB_RDAREA_ID：LOB列格納用RDエリアID
LOB_RDAREA_SERV：LOB列格納用RDエリアがあるサーバ名
ADT_NUMBER：抽象データ型列の定義数
UNLOAD_TYPE：抽象データ型のアンロード方法
FUNC_PARAM_NUM：関数パラメタ数
FUNC_PARAM_TYPE：関数パラメタのデータ型
FUNC_PARAM_LEN：関数パラメタのデータ長
(Ｓ)処理を終了します。
[対策]抽象データ型の定義を変更した表はリロードできません。UAPなどでデータを移行してください。又は，抽象データ型の定義をアンロード時と同じにして，その後リロードしてください。
該当する抽象データ型を提供するプラグインがコンストラクタパラメタ逆生成関数を持つ場合，バックアップから表の回復，又は抽象データ型の定義をアンロード時と同じに再定義して，リロードしてください。その後，制御情報ファイルにコンストラクタパラメタ逆生成関数（unld_func文）を指定してアンロードして，抽象データ型の属性を変更後，コンストラクタ関数（reld_func文）を指定してリロードしてください。
KFPL15314-E
Unload=aa....aa, Reload=bb....bb, position=cc....cc　　（Ｌ）
直前のKFPL15313-Eメッセージに対する詳細情報（アンロード時とリロード時の定義内容）を表示します。
aa....aa：アンロード時の定義内容
bb....bb：リロード時の定義内容
cc....cc：定義位置（位置が特定できない場合は0）
直前のKFPL15313-Eメッセージのee....eeと，このメッセージのaa....aa，bb....bb，及びcc....ccとの関係を次に示します。
直前のKFPL15313-Eのcc....cc
aa....aa，及びbb....bbの出力内容
出力形式
cc....cc
TYPE_NAME
"認可識別子"."抽象データ型名"
文字
－
PLUGIN_ID
プラグインID
10進数
DEF_ATTR_NUM
属性の数
10進数
DEF_ATTR_DTYPE
属性のデータ型
・INTEGER
・SMALLINT
・CHAR
・VARCHAR
・NCHAR
・NVARCHAR
・MCHAR
・MVARCHAR
・FLOAT
・SMALLFLT
・BLOB
文字
抽象データ型の属性定義の定義順番号
DEF_ATTR_DLEN
属性の定義長
10進数
DEF_ATTR
抽象データ型の型ID
10進数
LOB_RDAREA_NUM
LOB列格納用RDエリアの数
10進数
LOB定義順の番号
LOB_RDAREA
LOB列格納用RDエリアの名称
文字
LOB_RDAREA_ID1
LOB列格納用RDエリアの定義の順番
10進数
LOB_RDAREA_ID2
LOB列格納用RDエリアの格納の順番
10進数
LOB_RDAREA_ID3
LOB列格納用RDエリアに対応する表格納用RDエリアのRDエリアID
10進数
LOB_RDAREA_ID
LOB列格納用RDエリアのRDエリアID
10進数
LOB_RDAREA_SERV
LOB列格納用RDエリアがあるサーバ名
文字
ADT_NUMBER
表に定義された抽象データ型の列数
10進数
－
UNLOAD_TYPE
抽象データ型のアンロード，リロード方法
unload_func：
unld_func文を指定したアンロード
reld_func：
reld_func文を指定したリロード
instance：
unld_func文，及びUNLOAD機能以外でのアンロード
reld_func文，及びUNLOAD機能以外でのリロード
unload：
UNLOAD機能でのアンロード，又はリロード
文字
FUNC_PARAM_NUM
aa....aa：
unld_func文で指定した関数の数
bb....bb：
reld_func文で指定したパラメタの数
10進数
reld_func文の関数のパラメタの指定順番
FUNC_PARAM_TYPE
パラメタのデータ型（各データ型については，DEF_ATTR_DTYPEと同じです）
aa....aa：
unld_func文で指定した関数が返す値のデータ型
bb....bb：
reld_func文で指定した関数のパラメタのデータ型
文字
FUNC_PARAM_LEN
パラメタのデータ長
aa....aa：
unld_func文で指定した関数が返す値の定義長
bb....bb：
reld_func文で指定した関数のパラメタの定義長
10進数
（凡例）－：該当しません。
(Ｓ)処理を終了します。
(Ｏ)KFPL15313-Eメッセージの処置を参照してください。
KFPL15315-E
Unable to restart pdrorg, status unmatched, kind=aa....aa　　（Ｌ）
表のステータスが異なるため，表の再編成処理を再開始できません。
aa....aaがoption_controlの場合：
再開始時のオプション及び制御文の指定と，表の再編成失敗時のオプション及び制御文の指定が異なります。
aa....aaがserverの場合：
サーバ間横分割表の表テータスが異なります。
aa....aaがunload_timeの場合：
再開始時にunload文又はlobunld文に指定したアンロードデータファイルと，表の再編成失敗時に指定していたアンロードデータファイルが異なります。
aa....aaがrestart_infの場合：
再実行の情報が異なります。
aa....aaがschema又はtable_infの場合：
スキーマ内の表ごとに表ステータスが異なります。
aa....aa：ステータス種別
option_control：オプション及び制御文の指定
server：サーバ間ステータス
unload_time：アンロード時間
restart_inf：再実行情報
schema：スキーマ内の表ステータス
table_inf：表情報
(Ｓ)処理を終了します。
[対策]
aa....aaがoption_controlの場合：
オプション及び制御文の指定を変更して再実行した場合は，表の再編成失敗時のオプション及び制御文の指定に戻して再度実行してください。
aa....aaがserver_status又はunload_timeの場合：
次のどれかの対処をしてください。
1. 1部のRDエリアに対して，バックアップからの回復，又はRDエリアの再初期化をした場合は，再開始できません。すべての格納RDエリアをバックアップから回復し，表の再編成を実行してください（この場合，再開始にはなりません）。
2. 再開始前に該当する表を操作した場合は，再開始できません。バックアップから表を回復してください。
3. アンロードデータファイルの指定を変更して再実行した場合は，表の再編成失敗時のアンロードデータファイルに戻して再度実行してください。
なお，1～3の対処をしない場合は，表の再編成（pdrorg -k rorg）は実行できません。強制的に実行したい場合は，option文にtblstatus=clearを指定して，いったん表のステータスをクリアした後に，実行してください。
aa....aaがrestart_inf，schema，又はtable_infの場合：
該当する表（スキーマ内の表）に対してリロード処理をした場合は，再開始できません。この場合，リロード（pdrorg -k reld）を実行してリロード処理を完了させてください。
KFPL15316-E
Unable to reload table kind unmatched, kind=aa....aa　　（Ｌ）
アンロードファイルとリロードする表の表種別が異なるため，リロードできません。
aa....aaが"INSERT ONLY table"の場合
アンロードした表が非改竄防止表で，リロード先が改竄防止表の場合，リロードできません。また，アンロードした表が改竄防止表で，リロード先の別表（別システムの表）が改竄防止表の場合，リロードできません。
aa....aa：表の種類
INSERT ONLY table：改竄防止表
(Ｓ)処理を終了します。
[対策]正しいアンロードファイル又は表名称を指定して，再度実行してください。
KFPL15317-E
Table aa....aa.bb....bb not unloaded by cluster key sequence, file=cc....cc　　（Ｌ）
アンロードデータファイル中の表aa....aa.bb....bbは，リロード先の表のクラスタキー順に，アンロードされていません。
aa....aa：認可識別子
bb....bb：表識別子
cc....cc：アンロードデータファイル名称
アンロードデータファイル名称の長さが次の計算式で求めた値を超える場合は，アンロードデータファイル名称の後ろから計算式で求めた値分の文字数を出力します。
157－認可識別子長－表識別子長
(Ｓ)処理を終了します。
(Ｏ)クラスタキー順にアンロードデータファイルを作成して，再度コマンドを実行してください。
KFPL15318-E
Cluster information not equal to aa....aa.bb....bb on unload file, file=cc....cc　　（Ｌ）
アンロードデータファイル中の表aa....aa.bb....bbのクラスタキー定義とリロード先の表のクラスタキー定義が異なります。
aa....aa：認可識別子
bb....bb：表識別子
cc....cc：アンロードデータファイル名称
アンロードデータファイル名称の長さが次の計算式で求めた値を超える場合は，アンロードデータファイル名称の後ろから計算式で求めた値分の文字数を出力します。
152－認可識別子長－表識別子長
(Ｓ)処理を終了します。
(Ｏ)指定した表のアンロードデータファイルをクラスタキー順で作成し，再度コマンドを実行してください。
KFPL15319-E
Unable to unload order by physical, table=aa....aa.bb....bb　　（Ｌ）
表aa....aa.bb....bbは，クラスタキーが定義されています。このため，物理順での再編成はできません。
aa....aa：認可識別子
bb....bb：表識別子
(Ｓ)処理を終了します。
(Ｏ)クラスタキー順にアンロードして，再度コマンドを実行してください。
KFPL15321-E
Index aa....aa not found on table bb....bb.cc....cc　　（Ｅ＋Ｌ）
指定されたインデクスaa....aaは，表bb....bb.cc....ccには定義されていません。
aa....aa：インデクス識別子
bb....bb：認可識別子
cc....cc：表識別子
(Ｓ)処理を終了します。
(Ｏ)インデクス識別子が誤っている場合，インデクス識別子を修正して，再度コマンドを実行してください。
KFPL15322-E
aa....aa key not found on table bb....bb.cc....cc　　（Ｅ＋Ｌ）
aa....aaキーは，表bb....bb.cc....ccに定義されていません。
aa....aa：
Cluster：クラスタキー
Primary：主キー
bb....bb：認可識別子
cc....cc：表識別子
(Ｓ)処理を終了します。
(Ｏ)
〈指定した表名を見直して，誤っている場合〉
表名を修正して，再度コマンドを実行してください。
〈指定した表名が正しい場合〉
表にaa....aaキーが定義されているか確認し，定義がない場合はaa....aa以外をアンロード順に指定して，再度コマンドを実行してください。
KFPL15323-E
Unable to unload order by index, index=aa....aa.bb....bb　　（Ｅ＋Ｌ）
アンロードのアンロード順指定に指定したインデクスについて，次のどれかの誤りがあります。
・インデクスの構成列が複数で，かつ降順指定を指定した場合
指定したインデクスは構成列が複数なので，降順にアンロードできません。
・プラグインインデクスを指定した場合
指定したインデクスはプラグインインデクスなので，インデクスを指定したアンロードはできません。
・繰返し列のインデクスを指定した場合
指定したインデクスは繰返し列のインデクスなので，インデクスを指定したアンロードはできません。
aa....aa：認可識別子
bb....bb：インデクス識別子
(Ｓ)処理を終了します。
(Ｏ)次のどれかの処置をしてください。
・インデクスの構成列が複数で，かつ降順指定を指定した場合
インデクスのアンロード順を昇順にするか，又は物理順の指定をして，再度コマンドを実行してください。
・プラグインインデクスを指定した場合
プラグインインデクス以外のインデクスを指定するか，又は物理順の指定をして，再度コマンドを実行してください。
・繰返し列インデクスを指定した場合
繰返し列のインデクス以外のインデクスを指定するか，又は物理順の指定をして，再度コマンドを実行してください。
KFPL15326-E
Unable to unload due to specified index except values, index=aa....aa. "bb....bb"　　（Ｌ）
-bオプションで指定されたインデクスaa....aa. bb....bbには，インデクスの除外値が定義されているので，アンロードできません。
aa....aa：認可識別子
bb....bb：インデクス識別子
(Ｓ)処理を終了します。
(Ｏ)インデクスの除外値を定義していないインデクスを指定するか，又は-bオプションを指定しないで再度実行してください。
KFPL15331-E
aa....aa not held, RDAREA=bb....bb　　（Ｌ）
RDエリアbb....bbがコマンド閉塞状態になっていません。
aa....aa：｛Data dictionary｜USER RDAREA｝
bb....bb：RDエリア名
(Ｓ)処理を終了します。
(Ｏ)対象のRDエリアをコマンド閉塞した後，再度コマンドを実行してください。
KFPL15333-E
Data dictionary lock request failed　　（Ｌ）
データディクショナリ用RDエリアの排他制御ができません。
(Ｓ)処理を終了します。
(Ｏ)このメッセージの前に出力されたメッセージを参照し，エラーの原因を取り除いた後，再度コマンドを実行してください。
KFPL15334-E
Specified data dictionary table not found in system, table=aa....aa　　（Ｌ）
指定された表aa....aaは，ディクショナリ表の名称ではありません。
aa....aa：表識別子
(Ｓ)処理を終了します。
(Ｏ)指定した表名を修正して，再度コマンドを実行してください。
KFPL15335-E
Specified aa....aa file is many, max=bb....bb　　（Ｌ）
unload文，lobunld文，又はidxname文に指定されたファイルの数は，指定できる最大数bb....bbを超えています。
aa....aa：誤りのある指定 { unload | lobunld | idxname}
bb....bb：指定できるファイルの最大数
(Ｓ)処理を終了します。
(Ｏ)
・unload文，又はlobunld文の場合
指定した表の定義と，unload文，又はlobunld文の指定を見直して，unload文，又はlobunld文を修正してから再度実行してください。
-gオプションを指定していない場合，指定できるファイルの最大数は分割サーバ数となります。また，-gオプションを指定している場合は1となります。
・idxname文の場合
指定した表のインデクス定義とidxname文の指定を見直して，idxname文を修正してから再度実行してください。
指定できるファイルの最大数は，表に定義されたインデクス数となります。また，idxname文のnameオペランドにアスタリスク(*)を指定している場合は1となります。
KFPL15336-E
Specified aa....aa name bb....bb of cc....cc file not much　　（Ｅ＋Ｌ）
unload文，又はlobunld文で指定したサーバ名，又はidxname文のserverオペランドで指定したサーバ名は，表定義のサーバ名と異なります。
aa....aa：server
bb....bb：指定したサーバ名
cc....cc：実行しようとした処理 { unload | lobunld | idxname}
(Ｓ)処理を終了します。
(Ｏ)
・unload文，又はlobunld文の場合
unload文，又はlobunld文のサーバ名を修正して，再度実行してください。
・idxname文の場合
idxname文のserverオペランドで指定したサーバ名を修正して，再度実行してください。
KFPL15337-E
Specified aa....aa name bb....bb of index file not much　　（Ｅ＋Ｌ）
使用するファイル中のインデクス情報ファイル（index文）に指定したインデクス情報ファイル名又はRDエリア名は，対象とする表のインデクス定義と異なります。
aa....aa：指定した名称
{ RDAREA | index }
bb....bb：インデクス情報ファイル名又はRDエリア名
(Ｓ)処理を終了します。
(Ｏ)使用するファイル中のインデクス情報ファイルの指定で，インデクス情報ファイル名又はRDエリア名を修正して，再度コマンドを実行してください。
KFPL15338-E
Specified aa....aa name bb....bb of cc....cc directory not much　　（Ｌ）
制御情報ファイルに指定されたディレクトリのサーバ名称が，処理対象の表定義内容と異なります。
aa....aa：server
bb....bb：サーバ名
cc....cc：指定ディレクトリ種別｛index | sort｝
(Ｓ)処理を終了します。
(Ｏ)制御情報ファイルに指定したディレクトリのサーバ名称を修正して，再度コマンドを実行してください。
KFPL15339-E
Index file no specified, index=aa....aa.bb....bb, RDAREA=cc....cc　　（Ｌ）
インデクスaa....aa.bb....bbを構成するRDエリアcc....ccのインデクス情報ファイルが指定されていません。
aa....aa：認可識別子
bb....bb：インデクス識別子
cc....cc：RDエリア名
(Ｓ)処理を終了します。
(Ｏ)対象とするRDエリアのインデクス情報ファイルを指定して，再度コマンド実行してください。
KFPL15340-E
RDAREA name not specified in index file, index=aa....aa　　（Ｅ＋Ｌ）
使用するファイルに指定したインデクス情報ファイルのRDエリア名が省略されています。
aa....aa：指定したインデクス識別子
(Ｓ)処理を終了します。
(Ｏ)インデクス情報ファイルの指定にRDエリア名を追加して，再度コマンドを実行してください。
KFPL15341-E
Server name not specified in aa....aa　　（Ｌ）
制御情報ファイルに指定されたディレクトリ又はファイル名に対するサーバ名が省略されています。
aa....aa：誤りがある指定
{ unload file（アンロードファイル）
| index directory（インデクスディレクトリ）
| sort directory（ソートワークディレクトリ）
| lobunld file（LOBアンロードファイル）}
(Ｓ)処理を終了します。
(Ｏ)制御情報ファイルに指定したディレクトリ又はファイル名に，サーバ名を追加して，再度コマンドを実行してください。
KFPL15342-E
Specified aa....aa directory is many, max=bb....bb　　（Ｌ）
制御情報ファイルに指定されたディレクトリの指定数が，指定できる最大値bb....bbを超えています。
aa....aa：ディレクトリ種別{ index | sort work }
bb....bb：指定できる最大値
(Ｓ)処理を終了します。
(Ｏ)表の定義を見直して，ディレクトリの指定数を修正後，再度コマンドを実行してください。
KFPL15343-E
Index file duplicated, index=aa....aa.bb....bb. RDAREA=cc....cc　　（Ｌ）
使用するファイルで指定したインデクス名称又はRDエリア名が重複しています。
aa....aa：認可識別子
bb....bb：インデクス識別子
cc....cc：RDエリア名
(Ｓ)処理を終了します。
(Ｏ)使用するファイル中のインデクス情報ファイルに指定したインデクス情報ファイル名又はRDエリア名の重複を修正して，再度コマンドを実行してください。
KFPL15344-W
Control　character　found,　skip　row=aa....aa,　table=bb....bb."cc....cc"　　（Ｌ）
行データを出力する時に，行データ中にナル文字又は改行文字を発見したので，その行は出力しませんでした。
行データの中（文字データ，各国文字データ，混在文字データ）にナル文字又は改行文字が含まれる場合は，DAT形式で行データを出力できません。
aa....aa：出力しなかった行数
bb....bb：認可識別子
cc....cc：表識別子
(Ｓ)処理を続行します。
(Ｏ)必要であれば-Wオプションにbinを指定してバイナリ形式で出力してください。
KFPL15345-E
Unable to execute aa....aa for PLUGIN index bb....bb."cc....cc"　　（Ｅ＋Ｌ）
プラグインインデクスbb....bb."cc....cc"には，aa....aa機能を実行できません。
aa....aa：機能名
ixor：インデクスの再編成
pdreclaim：空きページ解放ユティリティ
pdpgbfon：グローバルバッファ常駐化ユティリティ
bb....bb：認可識別子
cc....cc：インデクス識別子
(Ｓ)処理を終了します。
(Ｏ)次に示す処置をしてください。
aa....aaがixorの場合：
・プラグインインデクスを再編成したい場合
プラグインインデクスの再編成の代わりの処理として，プラグインインデクスを定義した表の再編成をするか，又はプラグインインデクスの再作成をしてください。
・プラグインインデクスを再編成する必要がない場合
プラグインインデクスを指定したindex文，又はidxname文を削除してください。その後，インデクスの再編成を再実行してください。
aa....aaがpdreclaimの場合：
pdreclaimのidxname文にプラグインインデクスを指定している場合は，そのidxname文を削除してください。プラグインインデクスの使用中空きページ解放をする場合は，インデクスの再作成（pdrorg -k ixrc）をしてください。
aa....aaがpdpgbfonの場合：
pdpgbfonではプラグインインデクスは処理できませんので，コマンドの実行を中止してください。
KFPL15346-W
Table aa....aa."bb....bb" cc....cc skipped　　（Ｌ）
・cc....ccがreloadの場合
スキーマ単位でのリロード時に，表aa....aa."bb....bb"の情報がアンロードデータファイルにないため，リロード処理をスキップします。又は，表の再編成の再開始時に，表aa....aa."bb....bb"はリロードが完了しているため，リロード処理をスキップします。なお，異常終了のタイミングが表のステータスを「再編成中」に書き換える前の場合には，表のステータスが「初期状態」すなわち，リロードが完了している状態と同じになるため，アンロードが行われている表のリロード処理がスキップされます。この場合は，該当する表だけを-tオプションに指定して，再度リロード（-k reld）を実行してください。
・cc....ccがixrcの場合
表の再編成の再開始時に，表aa....aa."bb....bb"のインデクスの作成が完了しているため，インデクスの再作成処理をスキップします。
aa....aa：認可識別子
bb....bb：表識別子
cc....cc：処理の種別
reload：リロード処理
ixrc：インデクスの再作成処理
(Ｓ)処理を続行します。
KFPL15347-E
Unmatched aa....aa between bb....bb "cc....cc" of RDAREA "dd....dd" and bb....bb "ee....ee" of RDAREA "ff....ff"　　（Ｅ＋Ｌ）
ユティリティ実行時の処理対象となる，RDエリアdd....ddのaa....aa（cc....cc）と，RDエリアff....ffのaa....aa（ee....ee）が一致していません。
aa....aa：
generation number：世代番号
inner replica status：レプリカステータス
bb....bb：
number：番号
status：ステータス
cc....cc：世代番号
current：カレントRDエリア
not current：カレントRDエリア以外
dd....dd：RDエリア名
ee....ee：世代番号
current：カレントRDエリア
not current：カレントRDエリア以外
ff....ff：RDエリア名
(Ｓ)処理を終了します。
(Ｏ)
・aa....aaがgeneration numberの場合
世代指定（-qオプション）を省略してユティリティを実行する場合（カレントアクセス時）は，処理対象となるRDエリアの世代番号をpddbchgコマンドで合わせて再度実行してください。
・aa....aaがinner replica statusの場合
世代指定（-qオプション）を指定してユティリティを実行する場合，処理対象となるRDエリアのレプリカステータスを，すべてpddbchgコマンドで合わせて再度実行してください。
KFPL15348-E
No specified generation RDAREA="aa....aa", generation=bb　　（Ｅ＋Ｌ）
指定した世代bbのRDエリアaa....aaがありません。
aa....aa：RDエリア名（指定した世代のRDエリアがない場合は***が出力されます）
bb：世代番号（ユティリティ実行中に表やインデクスを削除した場合は，世代番号が特定できないため，-1が出力されます）
(Ｓ)処理を終了します。
(Ｏ)
指定した世代番号が正しい場合，処理対象のRDエリアのレプリカRDエリアを作成した後，再度ユティリティを実行してください。
指定した世代番号が誤っている場合，正しい世代番号を指定して，再度ユティリティを実行してください。
ユティリティ実行中の表に対して定義系SQLを実行した場合，ユティリティ実行中の表やインデクスに対して定義系SQLを実行しないでください。
KFPL16300-E
Invalid lobmid file, file=aa....aa　　（Ｌ）
指定したLOB中間ファイルは，正常に作成されたものではありません。
aa....aa：LOB中間ファイル名
LOB中間ファイル名の長さが151文字以上の場合は，LOB中間ファイル名の後ろから150文字を出力します。
(Ｓ)処理を終了します。
(Ｏ)LOB列構成基表の作成時に正常に出力されたLOB中間ファイルを指定し，再度コマンドを実行してください。
KFPL16310-E
Divided information of aa....aa.bb....bb not equal to lobmid file, file=cc....cc　　（Ｌ）
LOB中間ファイルの表aa....aa.bb....bbの分割定義と，LOB列のデータロードをする表の分割定義が異なるため，LOB列のデータロードができません。
aa....aa：認可識別子
bb....bb：表識別子
cc....cc：LOB中間ファイル名
LOB中間ファイル名の長さが次の計算式で求めた値を超える場合は，LOB中間ファイル名の後ろから計算式で求めた値分の文字数を出力します。
152－認可識別子長－表識別子長
(Ｓ)処理を終了します。
(Ｏ)指定した表のLOB中間ファイルを使用して，LOB列のデータロードをしてください。
KFPL16320-E
Unmatched LOB load type "a" in command line with LOB load type "b" of LOBMID file cc....cc　　（Ｌ）
LOB作成時にコマンドラインに指定された-kオプションの指定値aと，LOB列構成基表作成時にコマンドラインに指定された-kオプションの指定値bが一致しません。
a：LOB作成時に，-kオプションで指定されたLOB作成種別
f：LOBデータごとにファイルを用意する場合
c：列単位LOB入力ファイルを用意する場合
b：LOB列構成基表作成時に，-kオプションで指定されたLOB作成種別
f：LOBデータごとにファイルを用意する場合
c：列単位LOB入力ファイルを用意する場合
cc....cc：LOB中間ファイル名
LOB中間ファイル名の長さが67文字以上の場合は，LOB中間ファイル名の後ろから66文字を出力します。
(Ｓ)処理を終了します。
(Ｏ)LOB作成時は，LOB列構成基表作成時に-kオプションで指定したLOB作成種別と同じオプションを指定してください。
KFPL16321-E
Unmatched number of "lobcolumn" statements with aa....aa (number of LOB columns)　　（Ｌ）
制御情報ファイルのlobcolumn文の指定数がLOB列数と一致しません。
作成に必要なlobcolumn文の数は，aa....aaです。
aa....aa：必要なlobcolumn文の数
(Ｓ)処理を終了します。
(Ｏ)
〈LOB列構成基表の表単位又はRDエリア単位にLOBを作成する場合〉
作成する表のLOB列数分のlobcolumn文を指定してください。列構成情報ファイルを使用している場合，列構成情報ファイルに記述しているLOB列数分のlobcolumn文を指定してください。
〈LOBのRDエリア単位にLOBを作成する場合〉
lobcolumn文を一つ指定してください。
KFPL16322-E
LOB column "aa....aa" not found, table=bb....bb."cc....cc"　　（Ｌ）
指定されたLOB列aa....aaは表中にありません。
aa....aa：列名称
bb....bb：認可識別子
cc....cc：表識別子
(Ｓ)処理を終了します。
(Ｏ)表定義時に指定したLOB列名称を指定して，再度コマンドを実行してください。
KFPL16323-E
RDAREA "aa....aa" conflicted with LOB column "bb....bb"　　（Ｌ）
制御文の中のlobmid文で指定されたLOB用RDエリアaa....aaと，lobcolumn文で指定したLOB列bb....bbは指定内容が矛盾します。
aa....aa：LOB用RDエリア名称
bb....bb：列名称
(Ｓ)処理を終了します。
(Ｏ)制御文の中のlobmid文で指定したLOB用RDエリア名称と，表定義時に指定したLOB列名称の対応関係を確認して，再度コマンドを実行してください。
KFPL16324-E
Unable to continue LOB load, because of invalid LOB middle file, file=aa....aa　　（Ｌ）
LOB中間ファイルaa....aaが不正なため，LOBの作成ができません。
・LOB列構成基表作成時に同じ入力データファイルを使用したときのLOB中間ファイルの場合，LOB作成時のLOB中間ファイルの指定順が不正です。
・LOB列構成基表作成時に異なる入力データファイルを使用したときのLOB中間ファイルの場合，LOB作成時のLOB中間ファイルの指定が不正です。
aa....aa：LOB中間ファイル名
LOB中間ファイル名の長さが141文字以上の場合は，LOB中間ファイル名の後ろから140文字を出力します。
(Ｓ)処理を終了します。
(Ｏ)
〈LOB列構成基表作成時に同じ入力データファイルを使用したときのLOB中間ファイルの場合〉
LOB列構成基表の入力データファイルの行の順番と対応するようにLOB中間ファイルの指定順を指定して，コマンドを再度実行してください。
〈LOB列構成基表作成時に異なる入力データファイルを使用したときのLOB中間ファイルの場合〉
異なる入力データファイルを使用して出力されたLOB中間ファイルは，同時に指定できません。それぞれの入力データファイルに対応するLOB中間ファイルごとに別の制御文に指定して，それぞれ，コマンドを実行して，LOBデータを作成してください。
KFPL16325-W
LOBCOLUMN for "aa....aa" ignored, because of not specified LOB column in column structure information file　　（Ｌ）
列構成情報ファイルに指定されていないLOB列（LOB列構成基表の入力ファイル中に指定されていないLOB列）に対して，制御文でlobcolumn文が指定されたので，aa....aaに対するlobcolumn文の指定を無視します。
aa....aa：無視されたLOB列の列名称
(Ｓ)指定されたlobcolumn文の内容を無視して，処理を続行します。
KFPL16326-E
Unable to omit aa....aa in "bb....bb" statement　　（Ｅ）
制御情報ファイル中で指定したbb....bb文のaa....aaは省略できません。
aa....aa：指定内容
column name：列名称
bb....bb：制御文の種別
lobcolumn：lobcolumn文
(Ｓ)処理を終了します。
(Ｏ)制御情報ファイル中のbb....bb文にaa....aaの記述を追加して，再度コマンドを実行してください。
KFPL16327-E
Unable to continue LOB load, because invalid column structure information file　　（Ｅ＋Ｌ）
-cオプションで指定された列構成情報ファイルの指定内容に，次に示す誤りがあるため，LOBデータの作成ができません。
・LOB列構成基表作成時に入力データファイルに記述したLOB列に対して，LOB作成時には，入力データファイルに記述のないLOB列としています。
(Ｓ)処理を終了します。
(Ｏ)
〈LOB列構成基表の作成時に，-cオプションで列構成情報ファイルを指定していない場合〉
LOB作成時にも-cオプションで列構成情報ファイルを指定しないで，制御文にすべてのLOB列に対するlobcolumn文を指定して，LOBデータを作成してください。
〈LOB列構成基表の作成時に，-cオプションで列構成情報ファイルを指定している場合〉
LOB列構成基表の作成時に-cオプションで指定した列構成情報ファイルの指定内容と，LOB作成時に-cオプションで指定した列構成情報ファイルの指定内容を確認して，一致させてください。それから，対応するlobcolumn文を制御文に指定して，再度コマンドを実行してください。
KFPL16328-W
Unable to check LOB data count, because error data exist in input data file　　（Ｅ）
LOB列構成基表を作成するときに，LOB列構成基表の入力データファイル中にエラーデータがありました。-eオプションが指定されている場合は，LOB列構成基表に対するデータロードを中断するため，LOBデータ作成時に，列単位LOB入力ファイル中のLOBデータの件数を確認できません。
(Ｓ)処理を続行します。
KFPL17000-E
Unmatched aa....aa DB=bbbbbb, UTL=cccccc　　（Ｅ＋Ｌ）
次のどれかの誤りがあります。
・データベースが記憶している同期点情報のジョブ名と，ユティリティの制御文に指定したジョブ名が不一致です。
・データベースが記憶している同期点情報のインデクス作成方法と，ユティリティ実行時のインデクス作成方法が不一致です。
・データベースが記憶している同期点情報のユティリティ名と，実行したユティリティが不一致です。
aa....aa：不一致な情報の種類
job name：ジョブ名
index mode：インデクス作成方法
bbbbbb：
aa....aaがjob nameの場合：データベースが記憶しているジョブ名（括弧内の文字Lはpdload，Rはpdrorgを示します）
aa....aaがindex modeの場合：データベースが記憶しているインデクス作成方法（-iオプションの指定値）
cccccc：
aa....aaがjob nameの場合：ユティリティ実行時に指定したジョブ名（***が表示された場合，ジョブ名が指定されていないことを示します）
aa....aaがindex modeの場合：ユティリティ実行時に指定したインデクス作成方法（-iオプションの指定値）
(Ｓ)処理を終了します。
(Ｏ)
aa....aaがjob nameの場合：
異常終了したジョブ名のユティリティを先に実行した後で，再度実行してください。異常終了したジョブ名のユティリティを再実行する必要がない場合は，jobオペランドにCLRを指定して実行してください。
aa....aaがindex modeの場合：
インデクス作成方法（-iオプション）を変更しないで，異常終了したジョブ名のユティリティを再実行してください。異常終了したジョブ名のユティリティを再実行する必要がない場合は，jobオペランドにCLRを指定して実行してください。
KFPL17001-E
Unload file not available for aa....aa. bb....bb of RDAREA cc....cc, reason=dd....dd (system=ee....ee, file=ff....ff)　　（Ｌ）
アンロードデータファイルが最新でないため，使用できません。
aa....aa：認可識別子
bb....bb：表識別子
cc....cc：RDエリア名
dd....dd：理由（Unload-time：アンロードデータファイル作成日付）
ee....ee：DB側の日付
ff....ff：アンロードデータファイル側の日付
(Ｓ)処理を終了します。
(Ｏ)最新のアンロードデータファイル（該当表に対して最後に再編成（-k rorg）を実行したときのもの）を指定して再度実行してください。
KFPL17010-E
Unmatched row count RDAREA=aa....aa(bb....bb), RDAREA=cc....cc(dd....dd)　　（Ｅ＋Ｌ）
横分割した表の，各RDエリアが記憶している同期点行数が不一致です。
aa....aa：RDエリア名
bb....bb：行数
cc....cc：RDエリア名（インナレプリカ機能を使用している場合，RDエリア名が取得できないときは***が出力されます）
dd....dd：行数
(Ｓ)処理を終了します。
(Ｏ)次のどれかの処置をしてください。
・異常終了したRDエリア単位にユティリティを実行した後で，表単位のユティリティを再実行してください。
・RDエリア単位のユティリティを再実行する必要がない場合は，jobオペランドにCLRを指定して再実行してください。
・RDエリア名に***が出力されている場合，このメッセージの前に出力されているKFPL15036-Eメッセージを参照してください。
KFPL20000-E
Internal function (aa....aa) error occurred, code=bbbbb　　（Ｅ＋Ｌ）
ユティリティ処理の延長でHiRDBがエラーを検知しました。
aa....aa：エラーを検知した関数名
bbbbb：エラー詳細コード
(Ｓ)処理を終了します。
(Ｏ)エラー詳細コードを参照してエラーの原因を取り除き，コマンドを再実行してください。エラー詳細コードについては，「RPC関連エラーの詳細コード」，又は「システム関連エラーの詳細コード」を参照してください。オペレータが対処できないエラーが発生した場合はHiRDB管理者に連絡してください。主なエラー原因と対処を次に示します。
-307：タイムアウトが発生しました。pd_utl_exec_timeオペランド，又はoption文のexectimeオペランドに指定したユティリティ実行監視時間以内に処理が終了しなかった場合，KFPL11111-Eメッセージの処置に従ってください。
-310：通信先のユニット又はサーバが稼働していません。制御文，又はコマンドラインに指定したユニット又はサーバが停止中の場合は，該当ユニット又はサーバの開始をHiRDB管理者に依頼してください。なお，ユニット又はサーバを開始できない場合は，制御文，又はコマンドラインに指定したユニット名又はサーバ名を，稼働中のユニット名又はサーバ名に変更してください。
-314：ユティリティを実行するプロセス間で通信ができない状態となっています。次の要因が考えられます。
(1) pdcancelコマンドなどでユティリティのプロセスを強制終了した場合，このメッセージは無視してください。
(2) 標準出力へのメッセージが出力できない状態になり，通信バッファが出力できないメッセージで一杯になったため，受信できなくなった可能性があります。この場合，コマンドを実行した画面の標準出力に，メッセージを出力できる状態にしてください。
(3) 複数サーバでユティリティのプロセスを並行して実行中，又はあるサーバのプロセスでエラーが発生して処理を中断したために，処理継続中プロセスから送信した電文を受信するプロセスがなくなっている場合，最初にエラーが発生したサーバで出力されているエラーメッセージの対処をしてください。
-364：通信先のサーバでエラーが発生しました。このメッセージの前に出力されたエラーメッセージ要因によって，通信先のプロセスが強制終了している場合は，そのメッセージの処置に従ってください。
-5303：HiRDBが正常に開始されていません。
[対策]ユニットやサーバの停止が原因の場合は，ユニット又はサーバを再開始してください。ただし，ネットワーク障害などが原因で一時的に停止状態と認識された場合は，HiRDBが自動的に再開始していることがあります。この場合，再開始は不要です。自動的に再開始となる場合の詳細については，マニュアル「HiRDB Version 7 システム運用ガイド」を参照してください。
HiRDB管理者が対処できないエラーが発生した場合は保守員に連絡してください。
KFPL20001-E
Insufficient memory in message buffer pool due to concurrent execution of aa....aa　　（Ｌ）
pdload，pdrorg，pdrbal，又はプラグインが提供するコマンドを同時実行するときに，ユティリティサーバ用のメッセージ格納バッファプールのメモリが，一時的に不足しました。なお，該当するエラーの発生に伴って，KFPS00854-Wが出力されることがあります。しかし，この場合は，サーバ障害ではありません。
aa....aa：プログラム名
｛"pdload"｜"pdrorg"｜"pdrbal"｜"COMMAND"｝
(Ｓ)処理を終了します。
(Ｏ)現在実行中のpdload，pdrorg，pdrbal，又はプラグインが提供するコマンドの実行完了後，再度実行してください。
KFPL20003-E
Unable to send message from aa....aa to bb....bb　　（Ｌ）
サーバaa....aaとサーバbb....bb間で，通信エラーが発生しました。
aa....aa：送信元サーバ名
bb....bb：送信先サーバ名
(Ｓ)処理を終了します。
[対策]このメッセージの前に出力されたKFPL20000-E又はKFPL20100-Eメッセージの処置に従ってください。ただし，物理的な通信エラーが発生していない場合は，システム定義でサーバ間の関係に矛盾があると考えられます。このため，エラーが発生したサーバ間の定義を見直して再度実行してください。
KFPL20005-E
Server down detected　　（Ｌ）
サーバの異常終了を検知しました。又は，系切り替えが発生したため，処理を続行できません。
(Ｓ)処理を終了します。
(Ｏ)既に出力されているエラーメッセージを基にサーバが異常終了した原因を取り除き，再度コマンドを実行してください。なお，処理中に系切り替えが発生している場合，コマンドを実行するホストから，コマンド処理に必要なファイルを参照・更新できる状態にして，再度実行してください。
KFPL20010-E
aa....aa error occurred, code=bbbb　　（Ｅ）
HiRDBとの接続又は切り離しに失敗しました。
aa....aa：処理の種別
{ Connect | Disconnect }
bbbb：エラー詳細コード
(Ｓ)処理を終了します。
(Ｏ)「システム関連エラーの詳細コード」を参照して，エラーの原因を取り除き，再度コマンドを実行してください。
注　プラグインが提供するコマンド実行時に出力された場合は，出力先種別（L）にだけ出力されます。
KFPL20020-E
Transaction (aa....aa) error occurred, code=bbbbb　　（Ｌ）
トランザクションの開始又は決着に失敗しました。
aa....aa：トランザクションの種別
{ begin | commit | rollback }
bbbbb：エラー詳細コード
(Ｓ)処理を終了します。
(Ｏ)「エラー詳細コード一覧」を参照してエラーの原因を取り除いてください。pdrorgのアンロード以外の処理でコミット又はロールバックのエラーが発生した場合は，データベースをユティリティ実行前の状態に回復した後，再度コマンドを実行してください。なお，プログラマが対処できないエラーが発生しているときは，HiRDB管理者に連絡してください。
[対策]保守員に連絡してください。
KFPL20040-E
Object Option not setup　　（Ｅ＋Ｌ）
・データベース作成ユティリティ(pdload)，データベース再編成ユティリティ(pdrorg)，リバランスユティリティ(pdrbal)，及び空きページ解放ユティリティ(pdreclaim)の場合
実行対象の表にプラグインによって，実装されたデータ型を使用した列がありますが，HiRDB Object Optionが組み込まれていないため実行できません。
・プラグインが提供するコマンドの場合
HiRDB Object Optionが組み込まれていないため，実行できません。
(Ｓ)処理を終了します。
[対策]pdopsetupコマンドを使用して，HiRDB Object Optionを組み込んだ後，再度該当するコマンドを実行してください。
KFPL20041-E
Staticizer Option not setup　　（Ｅ＋Ｌ）
-qオプションは，HiRDB Staticizer Optionを組み込んでいないと使用できません。
(Ｓ)処理を終了します。
[対策]HiRDB Staticizer Optionを組み込んでから，再度実行してください。
KFPL20050-E
Invalid host name　　（Ｅ）
指定されたホスト名では，このユティリティは実行できません。
(Ｓ)処理を終了します。
(Ｏ)コマンドライン，又は制御情報ファイルに指定したホスト名を修正して，再度コマンドを実行してください。
KFPL20051-E
Invalid server name　　（Ｅ）
制御文又はコマンドラインに指定したサーバ名が不正です。
(Ｓ)処理を終了します。
(Ｏ)制御文又はコマンドラインに指定したサーバ名を修正した後，再度コマンドを実行してください。
KFPL20060-E
Security Audit inactive, status=aa....aa, reason=bbbbb　　（Ｅ＋Ｌ）
セキュリティ監査機能が停止中のため，このユティリティの履歴は監査証跡ファイルに出力されません。
aa....aa：セキュリティ監査機能の稼働状態
INACTIVE：セキュリティ監査機能は停止中
OTHER：そのほかの障害が発生
bbbbb：エラー詳細コード
(Ｓ)処理を続行します。
(Ｏ)監査証跡を取得する必要がある場合は，セキュリティ監査機能の稼働状態に従って次に示す処置をしてください。
・INACTIVE：セキュリティ監査機能を開始してください。
・OTHER：システム関連エラーの詳細コードを参照してください。システム関連エラーの詳細コードについては，「システム関連エラーの詳細コード」を参照してください。プログラマが対処できないエラーが発生した場合はHiRDB管理者に連絡してください。
[対策]HiRDB管理者が対処できないエラーが発生した場合は保守員に連絡してください。
KFPL20061-E
Audit trail generation file write error, reason=aaaaa　　（Ｅ＋Ｌ）
監査証跡ファイルへの出力時にエラーが発生したため，このユティリティの履歴は監査証跡ファイルに出力されません。
aaaaa：エラー詳細コード
(Ｓ)処理を続行します。
(Ｏ)ユティリティの再実行時に監査証跡を取得する必要がある場合は，エラー詳細コードを参照してエラーの原因を取り除いてください。システム関連エラーの詳細コードについては，「システム関連エラーの詳細コード」を参照してください。プログラマが対処できないエラーが発生した場合はHiRDB管理者に連絡してください。
[対策]HiRDB管理者が対処できないエラーが発生した場合は保守員に連絡してください。
KFPL20090-E
Unable to output message to aa....aa　　（Ｌ）
メッセージをaa....aaに出力できません。
aa....aa：出力先
{ stdout | stderr }
(Ｓ)処理を続行します。
[対策]原因については，このメッセージの前に出力されたメッセージを参照してください。
KFPL20091-E
Unable to output information to report file　　（Ｌ）
処理結果ファイルに情報を出力できません。
(Ｓ)処理を続行します。
[対策]原因と対策については，このメッセージの前に出力されたメッセージを参照してください。
KFPL20100-E
Communication (aa....aa) error occurred, code=bbbbb　　（Ｌ）
通信処理でエラーが発生しました。
aa....aa：通信の処理種別
bbbbb：エラー詳細コード
(Ｓ)処理を終了します。
(Ｏ)
「RPC関連エラーの詳細コード」を参照してエラーの原因を取り除き，コマンドを再実行してください。プログラマが対処できないエラーが発生した場合は，HiRDB管理者に連絡してください。
aa....aaが「p_f_sqa_rcomb_open」又は「p_f_sqa_rcomb_close」で，エラー詳細コードの値が8の場合は，メモリ不足です。そのほかのエラー詳細コードの値の場合は，combuf通信でエラーが発生しています。メモリが不足している場合は，再度メモリを見積もってください。また，不要なプロセスがある場合は停止してください。combuf通信でエラーが発生している場合は，OSのマニュアルを参照して，原因を取り除いてください。
なお，次のコードが出力された場合は，通信エラーでない可能性があります。該当する場合，次の対処に従ってください。
-307：pd_utl_exec_timeオペランド，又はoption文のexectimeオペランドに指定したユティリティ実行監視時間以内に処理が終了しなかった場合，KFPL11111-Eメッセージの処置に従ってください。
-314：ユティリティを実行するプロセス間で，通信ができない状態となりました。次の要因が考えられます。
(1) pdcancelコマンドなどでユティリティのプロセスを強制終了した場合，このメッセージは無視してください。
(2) 標準出力へのメッセージが出力できない状態になり，通信バッファが出力できないメッセージで一杯になったため，受信できなくなった可能性があります。この場合，コマンドを実行した画面の標準出力を，メッセージが出力できる状態にしてください。
(3) 複数サーバでユティリティのプロセスを並行して実行中，又はあるサーバのプロセスでエラーが発生して処理を中断したために，処理継続中プロセスから送信した電文を受信するプロセスがなくなっている場合，最初にエラーが発生したサーバで出力されているエラーメッセージの対処をしてください。
-364：このメッセージの前に出力されたエラーメッセージの要因によって，通信相手のプロセスが強制終了している場合，そのメッセージの処置に従ってください。
KFPL20200-E
Database access (aa....aa) error occurred, code=b　　（Ｌ）
データベースへの参照又は更新する処理の前後で，エラーが発生しました。
aa....aa：エラーの発生した処理
b：エラーコード
4：メモリの不足
8：入出力エラー
(Ｓ)処理を終了します。
(Ｏ)
〈エラーコードが4の場合〉
プロセスをメモリに割り当てられる状態にして，再度コマンドを実行してください。
〈エラーコードが8の場合〉
標準エラー出力，又は標準出力に出力されているメッセージを参照して，エラーの原因を取り除き，再度コマンドを実行してください。
KFPL21000-E
PLUGIN function error occurred, operation=aa....aa, code=bb....bb, line=cc....cc　　（Ｌ）
プラグイン関数で，エラーが発生しました。
aa....aa：オペレーション名
bb....bb：プラグイン関数から受け取ったリターンコード
cc....cc：エラーが発生したデータの行番号
(Ｓ)処理を終了します。
(Ｏ)このメッセージの前に出力されているエラーメッセージを参照して，エラーの原因を取り除き，再度コマンドを実行してください。
KFPL21111-E
Unable to make parameter, operation=aa....aa, code=bb....bb, line=cc....cc　　（Ｌ）
コンストラクタ関数に渡す引数を生成できません。
aa....aa：パラメタ生成処理種別
bb....bb：パラメタ生成処理関数からのリターンコード
cc....cc：エラーが発生した行番号
(Ｓ)処理を終了します。
(Ｏ)このメッセージの前に出力されているエラーメッセージを参照して，エラーの原因を取り除き，再度コマンドを実行してください。
なお，バイナリ形式の入力データファイルを使用したデータロードの場合で，このメッセージの前に出力されているエラーメッセージがKFPA11930-E（メモリ不足）で確保領域サイズが入力パラメタサイズと異なるときは，入力データファイルのフォーマット不正です。入力データファイルを見直してください。
KFPL21112-E
ADT operation error, operation=aa....aa, code=bb....bb　　（Ｌ）
抽象データ型の操作aa....aaでエラーが発生しました。
aa....aa：操作関数名
bb....bb：操作コード
(Ｓ)処理を終了します。
(Ｏ)このメッセージの前に出力されているエラーメッセージを参照して，エラーの原因を取り除き，再度コマンドを実行してください。エラーメッセージが出力されていない場合には，保守員に連絡してください。
KFPL22000-E
System call error, func=aa....aa, errno=bbb　　（Ｅ＋Ｌ）
システムコール（関数）でエラーが発生しました。
aa....aa：システムコール（関数）名
bbb：errnoにセットされたエラー番号
(Ｓ)処理を終了します。
(Ｏ)エラー番号（errno：エラー状態を表す外部整数変数）を，errno.h及びユーザが使用するOSのマニュアルを参照してエラーの原因を取り除き，再度コマンドを実行してください。
errno=0の場合は，このメッセージの前に出力されたKFPL22001-Eメッセージの内容に従って，エラーの原因を取り除き，再度コマンドを実行してください。
なお，プラグインが提供するコマンド実行時には，標準出力にメッセージが出力されない場合があります。
KFPL22001-E
aa....aa　　（Ｅ＋Ｌ）
システムコールで発生したエラーの情報を出力します。OSのシステムログ機能が日本語文字コードに対応していない場合，メッセージがシステムログに正しく出力されていないことがあります。この場合，HiRDBのメッセージログを参照してください。
aa....aa：エラー情報
(Ｓ)処理を終了します。
(Ｏ)エラー情報を参照してエラーの原因を取り除き，再度コマンドを実行してください。
KFPL22222-I
Max row length=aa....aa　　（Ｅ＋Ｌ）
DAT形式で出力したアンロードデータファイルの，行長の最大値はaa....aaバイトです。
aa....aa：行長の最大値
(Ｓ)処理を続行します。
(Ｏ)出力したアンロードデータファイルをpdloadの入力にする場合，このメッセージに表示された行長の最大値が32キロバイト以上のときは，行長の最大値をsource文のmaxreclenオペランドに指定してください。
KFPL22223-I
Delete row count=aa....aa, table=bb....bb. "cc....cc", file=dd....dd　　（Ｌ）
表bb....bb."cc....cc"のアンロード処理時に，UOCからの削除要求があったため，aa....aa行はアンロードデータファイルに出力しませんでした。
aa....aa：削除要求のあった行数
bb....bb：認可識別子
cc....cc：表識別子
dd....dd：アンロードデータファイル名
アンロードデータファイル名の長さが102文字以上の場合は，アンロードデータファイル名の後ろから101文字を出力します。
(Ｓ)処理を続行します。
KFPL23000-E
Error occurred on server=aa....aa　　（Ｌ）
サーバ側でエラーが発生しました。
aa....aa：サーバ名
(Ｓ)処理を終了します。
(Ｏ)このメッセージの直前に出力されているエラーメッセージを参照してエラーの原因を取り除き，再度コマンドを実行してください。なお，ログレスモードで処理している場合は，データベースをユティリティの実行前の状態に戻してから再度実行してください。
KFPL23001-E
Server aa....aa not running　　（Ｌ）
サーバが稼働中ではありません。
aa....aa：サーバ名
(Ｓ)処理を終了してください。
(Ｏ)メッセージに出力されたサーバを稼働状態にして，再度コマンドを実行してください。
KFPL23100-E
HiRDB file aa....aa error, errno=bb....bb, HiRDB file name=cc....cc　　（Ｅ＋Ｌ）
HiRDBファイルに対するアクセスでエラーが発生しました。
aa....aa：HiRDBファイル機能
close：HiRDBファイルクローズ
open：HiRDBファイルオープン
read：HiRDBファイルからの読み込み
write：HiRDBファイルへの書き込み
reopen：HiRDBファイル及びマルチボリュームの2番目のボリューム以降のオープン
bb....bb：HiRDBシステムのエラーコード
cc....cc：HiRDBファイル名
HiRDBファイル名の長さが151文字以上の場合は，HiRDBファイル名の後ろから150文字を出力します。
(Ｓ)処理を終了します。
[対策]「HiRDBファイルシステムに対するアクセス要求から返されるエラーコード」を参照し，エラーの原因を取り除いてください。
KFPL23201-W
Skip load process,audit trail aa....aa file status=(b,c,d),file=ee....ee　　（Ｌ）
指定した監査証跡ファイルの状態が適切でないため，データロードを中止しました。このメッセージは監査証跡ファイルごとに出力されます。複数のファイルが該当する場合，そのファイルの数だけメッセージが出力されます。
aa....aa：generation
b：c（現用）又はs（現用以外）
c：d（データロード待ち）又は－（データロード済み）
d：h（閉塞中）又は－（閉塞中でない）
ee....ee：絶対パス名で表示される監査証跡ファイル名
ファイル名の長さが145文字以上の場合は，ファイル名の後ろから144文字を出力します。
(Ｓ)ほかにデータロードできる監査証跡ファイルがある場合は処理を続行します（RC=0）。ほかにデータロードできる監査証跡ファイルがない場合は処理を終了します（RC=8）。
[対策]指定した監査証跡ファイルの状態を確認してください。監査証跡ファイル名を間違った場合は訂正して再実行してください。指定した監査証跡ファイルがデータロード済みの場合は，データロードする必要があるかどうかを確認し，必要ならば強制的にデータロードしてください。
KFPL23202-E
Error occurred at change audit trail aa....aa file status,file=bb....bb,reason code=ccccc　　（Ｅ＋Ｌ）
監査証跡ファイルをデータロード済みの状態に変更できません。
aa....aa：generation
bb....bb：絶対パス名で表示される監査証跡ファイル名
ファイル名の長さが129文字以上の場合は，ファイル名の後ろから128文字を出力します。
ccccc：エラー詳細コード
(Ｓ)処理を終了します。
[対策]指定した監査証跡ファイルのデータは，監査証跡表に登録済みとなっています。誤ってこの監査証跡ファイルを再度データロードすると，データを二重に登録することになるため，必要がない場合はpdaudrm -fコマンドで削除することをお勧めします。なお，監査証跡ファイルの状態を変更できなかった原因については，出力されたエラー詳細コードを参照してエラーの原因を取り除いてください。エラー詳細コードについては，「エラー詳細コード一覧」を参照してください。
KFPL23203-E
Table aa....aa.bb....bb cc....cc table　　（Ｅ＋Ｌ）
表aa....aa.bb....bbは監査証跡表でないのに監査証跡データ登録UOCを指定しています。又は，監査証跡表なのに監査証跡データ登録UOCを指定していません。
aa....aa：認可識別子
bb....bb：表識別子
cc....cc：表の種類
・not audit：監査証跡表以外
・audit：監査証跡表
(Ｓ)処理を終了します。
[対策]監査証跡表には監査証跡データ登録UOCを指定して，監査証跡表以外は監査証跡データ登録UOCを指定しないでコマンドを再実行してください。
KFPL23500-E
RDAREA aa....aa bb....bb　　（Ｌ）
RDエリアが閉塞状態（障害閉塞，ログレス閉塞，参照可能バックアップ閉塞，又は更新可能バックアップ閉塞），クローズ状態，更新凍結状態，又はオンライン再編成閉塞状態です。
aa....aa：RDエリア名
bb....bb：RDエリアの状態
held：閉塞
closed：クローズ
freezed：更新凍結
ORG：オンライン再編成閉塞
(Ｓ)処理を終了します。
(Ｏ)
・オンライン再編成閉塞以外の場合
RDエリアのオープン属性がINITIALのとき：
RDエリアをオープン状態，かつ閉塞解除，コマンド閉塞，参照可能閉塞，又は更新凍結解除のどれかの状態にして，再度コマンドを実行してください。
RDエリアのオープン属性がDEFER又はSCHEDULEのとき：
RDエリアの閉塞を解除するか，又は参照可能閉塞状態若しくは更新凍結解除状態にして再度コマンドを実行してください。
・オンライン再編成閉塞の場合
オンライン再編成閉塞を解除して，再度コマンドを実行してください。
KFPL24000-E
Unable to specify configuration file　　（Ｅ）
バイナリ形式の入力データファイルを入力として，列構成情報ファイルを指定できません。
(Ｓ)処理を終了します。
(Ｏ)バイナリ形式の入力データファイルの入力データ列と表の列データの属性を一致させ，列構成情報ファイルを指定する必要がない状態にして，再度コマンド実行してください。
KFPL24001-E
Unable to specify null-information file　　（Ｅ）
DAT形式の入力データファイルを入力として，ナル値情報ファイルを指定できません。
(Ｓ)処理を終了します。
(Ｏ)DAT形式の入力データファイルの入力でナル値を指定し，ナル値情報ファイルの指定を削除した後，再度コマンドを実行してください。
KFPL24100-E
Unable to convert data, column=aa....aa　　（Ｅ＋Ｌ）
列構成情報ファイルに指定した入力データファイルのデータ型では，表の列aa....aaのデータ型にデータを変更できません。
aa....aa：列名
(Ｓ)処理を終了します。
(Ｏ)列構成情報ファイルに指定したデータ型が誤っている場合は修正し，再度コマンドを実行してください。
KFPL24150-E
No aa....aa on table　　（Ｅ）
表にインデクスが定義されていないのに，インデクス情報ファイル又はソート用ワークディレクトリを指定しています。又は，表にLOBが定義されていないのに，LOB入力ファイルの情報又はLOB中間ファイルの情報を指定しています。
aa....aa：出力される文字列の意味を次に示します。
index：インデクス情報
LOB：LOB列
(Ｓ)処理を終了します。
(Ｏ)制御情報ファイルに指定した不要な記述を削除してください。又は，対象となる表の名称が誤っていないか確認した後，再度コマンドを実行してください。
KFPL24151-E
Cannot omit aa....aa name　　（Ｅ）
横分割表に対するファイル指定では，aa....aa名称を省略できません。
aa....aa：指定がない名称
RDAREA：RDエリア名
server：サーバ名
(Ｓ)処理を終了します。
(Ｏ)ファイル又はディレクトリを使用するRDエリア名，又はサーバ名を記述して，再度コマンドを実行してください。
KFPL24152-E
Index aa....aa not found, table=bb....bb.cc....cc　　（Ｅ＋Ｌ）
インデクスaa....aaは，表bb....bb.cc....ccに定義されていません。
aa....aa：インデクス識別子（idxname文にname=*を指定した場合，表に対象となるインデクスがないときは***が出力されます）
bb....bb：認可識別子
cc....cc：表識別子
(Ｓ)処理を終了します。
(Ｏ)制御情報ファイルに指定したインデクス名を修正して，再度コマンドを実行してください。インデクス識別子に***が出力されている場合は，表にインデクスがあるかどうかを確認してください。
KFPL24153-E
Index aa....aa not found in RDAREA bb....bb　　（Ｅ）
インデクスaa....aaは，RDエリアbb....bbにありません。
aa....aa：インデクス識別子
bb....bb：RDエリア名
(Ｓ)処理を終了します。
(Ｏ)制御情報ファイルに指定したRDエリア名を修正して，再度コマンドを実行してください。
KFPL24154-E
Unnecessary aa....aa directory specified　　（Ｅ）
インデクスが定義されていないサーバにインデクスファイル用，又はソート用ワークディレクトリを指定しています。
aa....aa：ディレクトリ種別{ index | sort work }
(Ｓ)処理を終了します。
(Ｏ)制御情報ファイルに指定したディレクトリのサーバ名を修正して，再度コマンドを実行してください。
KFPL24155-E
Function aa....aa."bb....bb" not found, column="cc....cc"　　（Ｅ）
列"cc....cc"の抽象データ型に，関数"bb....bb"が見付かりません。次に示す原因が考えられます。
・列構成情報ファイルで指定した関数（名称，パラメタが同じもの）が定義されていません。
・列構成情報ファイルで指定した関数の戻り値が列の抽象データ型ではありません。
aa....aa：認可識別子
bb....bb：関数名称
cc....cc：列名称
(Ｓ)処理を終了します。
(Ｏ)列構成情報ファイルに指定した関数情報を正しく指定し，コマンドを再度実行してください。
KFPL24156-E
Required function not specified　　（Ｅ）
抽象データ型の列に格納する，値を生成するために必要なコンストラクタ関数の指定がありません。又は，抽象データ型のデータ値を逆生成するコンストラクタパラメタ逆生成関数の指定がありません。次に示す原因が考えられます。
・コンストラクタ関数がプラグイン実装された関数ではありません。
・列構成情報ファイルを省略した場合に，抽象データ型にデータ型名と同一名称の関数が定義されていないか，又は，同一名称の関数が二つ以上定義されています。
・関数が定義されていない抽象データ型の列があります。
・制御情報ファイルにunld_func文の指定がありません。
(Ｓ)処理を終了します。
(Ｏ)列構成情報ファイルで，抽象データ型の列に格納する，値を生成するプラグイン実装のコンストラクタ関数を指定し，再度コマンドを実行してください。
又は，制御情報ファイルに抽象データ型のデータ値を逆生成するコンストラクタパラメタ逆生成関数を指定し，再度コマンドを実行してください。
KFPL24157-E
Function aa....aa."bb....bb" not found, type=cc....cc,"dd....dd", kind=ee....ee　　（Ｅ）
ee....eeで指定した関数bb....bbは，抽象データ型dd....ddに定義されていません。
aa....aa：関数の認可識別子
bb....bb：関数名
cc....cc：抽象データ型の認可識別子
dd....dd：抽象データ型名
ee....ee：種別
｛unld_func｜reld_func｝
(Ｓ)処理を終了します。
(Ｏ)該当する抽象データ型のプラグインのマニュアルを参照して，正しい関数を指定して再度実行してください。
KFPL24158-E
Specified type not found in this table, type=aa....aa."bb....bb"　　（Ｅ）
制御情報ファイル中のunld_func文のtypeオペランドで指定した抽象データ型aa....aa.bb....bbは，該当する表に定義されていません。
aa....aa：抽象データ型の認可識別子
bb....bb：抽象データ型名
(Ｓ)処理を終了します。
(Ｏ)表に定義されている抽象データ型名を指定して，再度実行してください。
KFPL24159-E
Function_row missing in Control file, column="aa....aa"　　（Ｅ）
列aa....aaに定義された抽象データ型に対するunld_func文が制御情報ファイルに指定していません。
aa....aa：列名
(Ｓ)処理を終了します。
(Ｏ)該当する列に定義された，抽象データ型を提供するプラグインのマニュアルを参照して，制御情報ファイルのunld_func文にコンストラクタパラメタ逆生成関数を指定し，再度実行してください。プラグインがコンストラクタパラメタ逆生成関数を実装していない場合，又は-jオプションを指定している場合は，-jオプションを削除して再度実行してください。
KFPL24500-E
Unable to continue pdload because of invalid aa....aa length, line=bb....bb　　（Ｅ＋Ｌ）
バイナリ形式の入力データファイル中の可変長データの長さ部，又は繰返し列の有効要素数に負の値を検知しました。又は，入力データの長さがmaxreclenで確保した領域を超えました。
aa....aa：データ型
{ VARCHAR | NVARCHAR | MVARCHAR | BINARY | BLOB | ARRAY}
bb....bb：行番号
(Ｓ)処理を終了します。
(Ｏ)可変長データの長さ部，又は繰返し列の有効要素数格納領域に不正な長さを指定していないか調査してください。又は，バイナリ形式の入力データファイルの列データに誤りがないか調査してください。誤りがあれば，ファイルの内容を修正して，再度コマンドを実行してください。
また，入力データの長さがmaxreclenで指定した値より大きい場合は，入力データの最大長を確認し，それより大きい値をmaxreclenに指定して再度実行してください。
KFPL24509-E
Insert error occurred, line=aa....aa　　（Ｌ）
aa....aa行目のデータ格納処理中にエラーが発生しました。
aa....aa：行番号
(Ｓ)処理を終了します。
(Ｏ)このメッセージの前に出力されているエラーメッセージを参照してエラーの原因を取り除き，再度コマンドを実行してください。
再実行時の注意事項：
同時にKFPL15225-Eメッセージ（ロールバック）が出力されている場合，1行目から再実行してください。出力されていない場合，-rオプションを指定して，このメッセージに出力されている行から再実行してください。
KFPL24510-E
Error data detected, process stopped, error code=aa　　（Ｌ）
pdload実行中に入力データエラーを検知したため，処理を終了します。
aa：論理エラー番号
論理エラー番号とその内容については，マニュアル「HiRDB Version 7 コマンドリファレンス」を参照してください。
(Ｓ)処理を終了します。
(Ｏ)
データロードの場合：
このメッセージと同時に出力されているKFPL24509-Eメッセージで出力された行番号のデータを修正します。
なお，KFPL15225-Eメッセージが出力されている場合は，すべてのデータベース格納処理が中止（rollback）されているため，入力ファイルの最初のデータから格納対象として，再度コマンドを実行します。また，ログレスモードで実行していたときは，バックアップからの回復が必要です。
また，KFPL15225-Eメッセージが出力されていない場合は，エラーデータ直前までのデータはデータベース格納処理が完了（commit）しているため，修正したデータ以降のデータを格納対象として（-rオプションを使用）再度コマンドを実行します。
ファイル分割（分割入力データファイルの作成）の場合：
エラー情報ファイルに出力されているエラーメッセージを参照して該当データを修正し，再度コマンドを実行してください。
KFPL24990-E
Only one aa....aa can be specified in Control file　　（Ｅ）
制御情報ファイルにaa....aaは，一つしか指定できません。
aa....aa：種別
source_row：source文の行
mtguide_row：mtguide文の行
emtdef_row：emtdef文の行
input_file：入力ファイル
unload_file：アンロードファイル
tblname_row：tblname文の行
lobmid_row：lobmid文の行
lobdata_row：lobdata文の行
idxname_row：idxname文の行
array_row：array文の行
option_row：option文の行
report_row：report文の行
blobtovarchar_row：blobtovarchar文の行
execstop_row：execstop文の行
extdat_row：extdat文の行
src_work_row：src_work文の行
fixtext_option_row：fixtext_option文の行
(Ｓ)処理を終了します。
(Ｏ)種別に出力された内容によって，次のように対策してください。
・source_row，mtguide_row，emtdef_row，lobmid_row，lobdata_row，array_row，又はblobtovarchar_rowが出力されたとき
制御情報ファイルの中のsource文，mtguide文，emtdef文，lobmid文，lobdata文，array文，又はblobtovarchar文の行を，それぞれ１行にして再度コマンドを実行してください。
・input_fileが出力されたとき
EasyMT情報を指定するときは，入力データファイルの指定を一つにして，再度コマンドを実行してください。
・unload_fileが出力されたとき
EasyMT情報を指定する時は，アンロードデータファイルの指定を一つにして，再度コマンドを実行してください。
・idxname_rowが出力されたとき
nameオペランドに*を指定している行以外の，ほかのidxname文を削除して，再度コマンドを実行してください。
・tblname_row又はfixtext_option_rowが出力されたとき
tblname文，fixtext_option文の指定を一つにして，再度コマンドを実行してください。
・option_row，report_row，execstop_row，extdat_row，又はsrc_work_rowが出力されたとき
制御情報ファイル中のoption文，report文，execstop文，extdat，又はsrc_work文の指定を一つにして，再度コマンドを実行してください。
KFPL24991-E
Specified aa....aa conflicted with command line specification　　（Ｅ）
制御情報ファイルで指定した内容は，コマンドラインで指定した内容と次に示すような矛盾があります。
データベース作成ユティリティの場合
・コマンドラインで-f easymtを指定していないのに，制御文にEasyMT情報又はvalidateオペランドを指定しています。
・コマンドラインで-f easymtを指定しているのに，制御文にUOCがファイル入力する指定となっています。
・コマンドラインで-k cを指定していないのに，制御文にlobcolumn文を指定しています。
・固定長データ形式ファイルを指定しているのに，制御文のarray文のtypeにvvを指定しています。
・DAT形式ファイルを指定しているのに，制御文のarray文のtypeにfvを指定しています。
・コマンドラインで-k dを指定しているのに，制御文中にsrcuoc文を指定しています。
・コマンドラインで-l n，-k f，-k v，又は-k cを指定しているのに，制御文中のoption文にjobオペランドを指定しています。
・コマンドラインで-nオプション，又は-i s以外を指定しているのに，option文でnowait=yesを指定しています。
・DAT形式ファイルを指定していないのに，extdat文を指定しています。
・DAT形式ファイルを指定していないのに，option文でnull_stringオペランドを指定しています。
・固定長データ形式以外の入力データファイルの場合に，option文にenclose_delオペランドを指定しています。
・コマンドラインに-bオプションを指定しているのに，src_work文を指定しています（バイナリ形式の入力データファイルの場合，分割入力データファイルの作成はできません）。
データベース再編成ユティリティの場合
・コマンドラインで-f easymtを指定していないのに，制御文にEasyMT情報を指定しています。
・コマンドラインで-f hirdbを指定していないのに，制御文にHiRDBファイル情報を指定しています。
・コマンドラインで-k reldを指定しているのに，制御文にfileno=ADDを指定しています。
・コマンドラインで-k reld -c dicを指定しているのに，制御文にtblname文を指定しています。
・コマンドラインで-k reldを指定しているのに，制御文にlobunld文とtblname文を指定しています。
・コマンドラインで-k ixrcを指定していないのに，制御文にidxname文を指定しています。
・コマンドラインで-l n，-k unld，-k ixrc，-k ixor，-k ixmk，又は-c dicを指定しているのに，制御文中のoption文にjobオペランドを指定しています。
・コマンドラインで-jオプションを指定しているのに，lobunld文を指定しています。
・コマンドラインで-W extdatを指定しているのに，unload文に複数のアンロードファイル名を指定しています。
空きページ解放ユティリティの場合
・対象資源が表の場合，ディクショナリ表を処理する場合，及びスキーマ単位に処理する場合は，idxname文は指定できません。
aa....aa：種別
easymt_information：EasyMT情報
emtdef_row：emtdef文
fileno：ファイル順序番号
hirdb_information：HiRDBファイル情報
tblname_row：tblname文
lobcolumn_row：lobcolumn文
array_row：array文
srcuoc_row：srcuoc文
idxname_row：idxname文
option_row(job)：option文のjobオペランド
option_row(nowait)：option文のnowaitオペランド
lobunld_row：lobunld文
extdat_row：extdat文
option_row(null_string)：option文のnull_stringオペランド
option_row(tblstatus)：option文のtblstatusオペランド
option_row(enclose_del)：option文のenclose_delオペランド
src_work_row：src_work文
unload_row：unload文
(Ｓ)処理を終了します。
(Ｏ)
〈aa....aaがeasymt_information，又はemtdef_rowの場合〉
・EasyMTを使用するとき
コマンドラインで，-f easymtの指定を追加し，再度コマンドを実行してください。
・EasyMTを使用しないとき
制御情報ファイルのsource行のEasyMT情報の指定，validateオペランドの指定，又はemtdef行を取り除き，再度コマンドを実行してください。
〈aa....aaがfilenoの場合〉
-k reld指定時は，fileno=ADDの指定を修正して，再度コマンドを実行してください。
〈aa....aaがhirdb_informationの場合〉
アンロードファイルとしてHiRDBファイルシステムを使用するときは，コマンドラインで-f hirdbを指定して，再度コマンドを実行してください。使用しないときは，制御ファイルのHiRDBファイル情報を取り除いて，再度コマンドを実行してください。
〈aa....aaがlobcolmn_rowの場合〉
列単位LOB入力ファイルを使用するときは，コマンドラインに-k cを指定して，再度コマンドを実行してください。使用しないときは，制御ファイルのlobcolumn文を削除して，再度コマンドを実行してください。
〈aa....aaがtblname_rowの場合〉
ディクショナリ表又はLOB列を定義した表に対しては，別表へのリロードはできません。コマンドラインのオプションか又はtblname文を見直し，必要な修正をして，再度コマンドを実行してください。
〈aa....aaがarray_rowの場合〉
入力データファイルが固定長データ形式の場合はff又はfvを，DAT形式の場合はff又はvvを指定して，再度コマンドを実行してください。
〈aa....aaがsrcuoc_rowの場合〉
-k dを指定する場合は，UOCを使用しないように変更してください。
〈aa....aaがidxname_rowの場合〉
データベース再編成ユティリティのとき：
インデクス単位にインデクス再作成をする場合は，-k ixrcを指定して再度コマンドを実行してください。
空きページ解放ユティリティのとき：
idxname文は，特定のインデクス，RDエリア，又はサーバだけインデクスの使用中空きページ解放をする場合に指定します。
〈aa....aaがoption_row(job)の場合〉
・pdloadの場合
option文でjobオペランドを指定する場合は，-l n，-k f，-k v，及び-k cを指定しないで再度コマンドを実行してください。
・pdrorgの場合
option文でjobオペランドを指定する場合は，-l n，-k unld，-k ixrc，-k ixor，-k ixmk，及び-c dicを指定しないで再度コマンドを実行してください。
〈aa....aaがoption_row(nowait)の場合〉
pdloadと同時にNOWAIT検索を実行する場合は，-nオプションを省略するか，又は-i sを指定してください。pdloadと同時にNOWAIT検索を実行しない場合は，option文にnowait=noを指定してください。
〈aa....aaがextdat_rowの場合〉
extdat文はDAT形式ファイルの場合だけ有効なため，固定長データ形式及びバイナリ形式のファイルのときはextdat文を削除して，再度実行してください。
〈aa....aaがoption_row(null_string)の場合〉
option文でnull_stringオペランドを指定する場合は，DAT形式のときだけ有効となります。バイナリ形式及び固定長データ形式の場合は，option文のnull_stringオペランドを削除してください。
〈aa....aaがoption_row(tblstatus)の場合〉
option文のtblstatusオペランドは，-k rorgの場合にだけ指定できます。したがって，tblstatusオペランドを削除するか，又は-k rorgに変更するかしてください。
〈aa....aaがoption_row(enclose_del)の場合〉
入力データファイルが固定長データ形式の場合は，-aオプションを指定してください。固定長データ形式でない場合は，enclose_delオペランドを削除してください。
〈aa....aaがlobunld_rowの場合〉
lobunld文を削除して，再度実行してください。
〈aa...aaがsrc_work_rowの場合〉
すべての列が固定長で構成されるバイナリ形式の入力データファイルの場合，固定長データ形式の入力データファイルとして扱うことで，分割入力データファイルの作成ができます。可変長の列を含む場合は，表単位のデータロードをするか，又はユーザが入力データファイルを分割するかを検討してください。
〈aa....aaがunload_rowの場合〉
-Wオプションにextdatを指定した場合は，アンロードファイル名の指定を1個にして，再度実行してください。
KFPL24992-E
Specified aa....aa conflicted with Control file specification　　（Ｅ）
制御情報ファイル内で指定した内容に，次に示す矛盾があります。
・マルチボリュームであるにもかかわらず，Mtguideを使用しないと指定しています。
・mtguide文，emtdef文を制御情報ファイルの先頭に指定していません。
・LOB列だけを作成するのに，必要のない制御文を指定しています。
・UOCを使うと宣言しているのに，srcuoc文，又はsource文が指定されていません。
・LOB列がある表に対して，表単位に処理する指定をしているのに，LOB列をRDエリア単位に処理しようとしています。
・LOB列構成基表だけを作成するためには，必要のない制御文を指定しています。又は，LOBの作成に必要な制御文がありません。
・バイナリ形式の入力データファイルで，可変長データ型の列に対する配列データ形式の指定が不正です。
・idxname文とindex文を同時に指定しています。
・-jオプションを指定していないのに，LOB属性を持つ抽象データ型に対してunld_func文，又はreld_func文を指定しています。
・-k rorgを指定しているのに，unld_func文とreld_func文を対で指定していません。
・option文のjobオペランドとlobunld文を同時に指定しています。
・option文にnowait=yesを指定している場合に，source文にRDエリア名を指定しています。
・UOCを使用する場合（unld_uoc文指定時）に，lobunld文を指定しています。
・UOCを使用する場合（unld_uoc文指定時）に，unload文に(UOC)を指定していません。
・UOCを使用しない場合（unld_uoc文未指定時）に，unload文に(uoc)又はUOC情報を指定しています。
・unload文に(uoc)を指定している場合に，HiRDB情報又はEasyMT情報を指定しています。
・非FIX表の場合に，unld_uoc文のfixrowに'Y'を指定しています。
・分割入力データファイルの作成時（src_work文指定時）に，source文にRDエリア名，又はreport文を指定しています。又は，source文を指定していません。
aa....aa：矛盾する内容
multi_volume：ボリューム名称
mtguide_row：mtguide文
emtdef_row：emtdef文
srcuoc_row：srcuoc文
idxwork_row：idxwork文
index_row：index文
sort_row：sort文
lobmid_row：lobmid文
source_row：source文
lobcolumn_row：lobcolumn文
array_row：array文
idxname_row：idxname文
func：unld_func文，又はreld_func文
option_row(job)：option文のjobオペランド
option_row(nowait)：option文のnowaitオペランド
lobunld_row：lobunld文
unload_row(hirdb)：unload文のHiRDB情報
unload_row(EASYMT)：unload文のEasyMT情報
unld_uoc_row：unld_uoc文のfixrow
lobunld_row(uoc)：unload文の(uoc)又はUOC情報
src_work_row：src_work文
(Ｓ)処理を終了します。
(Ｏ)出力された内容に応じた対応をした後，再度コマンドを実行してください。
〈multi_volumeの場合〉
マルチボリュームを指定するときは，mtguide useを指定します。
〈mtguide_row又はemtdef_rowの場合〉
mtguide文及びemtdef文は，source文又はunload文の前に指定します。
〈srcuoc_rowの場合〉
source文を指定します。又は，srcuoc文を削除します。
〈lobmid_rowの場合〉
lobmid文のRDエリア名を削除します。又は，source文にRDエリア名を追加します。
〈source_rowの場合〉
srcuoc文を指定します。又は，source文にファイル名を指定します。
〈lobcolumn_rowの場合〉
LOB列構成基表だけを作成するときは，lobcolumn文を削除します。
LOBデータを作成するときは，lobdata文を追加します。
〈array_rowの場合〉
配列データ形式の指定を修正します。
〈idxname_rowの場合〉
インデクス格納用RDエリア単位にインデクスを再作成する場合は，idxname文を削除してください。インデクス単位にインデクスを再作成する場合は，index文を削除してください。
pdreclaimの場合，nameオペランドだけにするか，又はserverオペランド指定のidxname文とrdareaオペランド指定のidxname文を混在させないようにするかしてください。
〈funcの場合〉
-k rorgでunld_func文とreld_func文を対で指定していない場合には，unld_func文とreld_func文を対で指定してください。
LOB属性を持つ抽象データ型に対してunld_func文，又はreld_func文を指定する場合には，同時に-jオプションを指定してください。
pdrbalの場合は，unld_func文とreld_func文は必ず対で指定してください。
〈option_row(job)の場合〉
同期点指定データロード，又は同期点指定リロードをする場合は，lobunld文を削除してください。
〈option_row(nowait)の場合〉
pdloadと同時にNOWAIT検索を実行する場合は，source文にRDエリア名を指定しないでください。pdloadと同時にNOWAIT検索を実行しない場合は，option文にnowait=noを指定してください。
〈lobunld_rowの場合〉
UOCを使用する場合（unlduoc文を指定した場合），lobunld文は指定できないため，削除してください。
〈unload_row(uoc)の場合〉
UOCを使用しない場合（unlduoc文を指定しない場合）は，unload文の(uoc)又はUOC情報を削除してください。
〈lobunld_row(hirdb)の場合〉
HiRDB情報を削除してください。
〈lobunld_row(ESAYMT)の場合〉
EasyMT情報を削除してください。
〈unld_uoc_row(fixrow)の場合〉
fixrowの指定を削除してください。
〈src_work_rowの場合〉
source文のRDエリア名の指定，又はreport文を削除してください。また，source文を指定していない場合は，source文を指定してください。
〈そのほかの場合〉
LOB作成に関係のない制御文を削除します。
KFPL24993-E
Invalid absolute pathname, file=aa....aa　　（Ｅ）
ファイルaa....aaの絶対パスが，絶対パスの長さの最大値1023を超えています。次のような場合があります。
・制御情報ファイルで指定するlobdata文のLOB入力ファイルのディレクトリ名と，lobcolumn文の列単位LOB入力ファイルの名称を合わせた絶対パスの長さが，最大値1023を超えています。
・制御情報ファイルで指定するlobcolumn文の列単位LOB入力ファイルの絶対パスの長さが，最大値1023を超えています。
aa....aa：lobcolumn文で指定した列単位LOB入力ファイル名称
LOB入力ファイル名称の長さが151文字以上の場合は，LOB入力ファイル名称の後ろから150文字を出力します。
(Ｓ)処理を終了します。
(Ｏ)制御情報ファイルで指定するlobdata文のLOB入力ファイルのディレクトリ，及びlobcolumn文で指定する列単位LOB入力ファイルの名称を見直して，誤っている場合は修正してください。指定が正しい場合は，絶対パスの長さが，1023を超えない箇所に列単位LOB入力ファイルを移動して，その絶対パスを制御文に指定し直して，再度コマンドを実行してください。
KFPL24999-E
aa....aa invalid　　（Ｅ）
ユティリティ実行時の-uオプションの指定値，又は環境変数で指定している認可識別子又はパスワードが不正です。又は，入力応答メッセージで入力されたパスワードが不正です。
aa....aa：エラーが発生した種別
Auth_id：認可識別子
Password：パスワード
(Ｓ)処理を終了します。
(Ｏ)
〈Auth_idが出力されたとき〉
コマンドラインの-uオプションを見直して，再度コマンドを実行してください。又は，環境変数PDUSERの内容を修正して，再度コマンドを実行してください。
〈Passwordが出力されたとき〉
環境変数PDUSERの内容を修正して，再度コマンドを実行してください。又は，入力応答メッセージに対してパスワードを入力したときは，再度コマンドを実行して，入力誤りがないようにしてください。
Windows NTの場合，-uオプションを省略する場合は，コマンドプロンプト上で認可識別子やパスワードを指定する文字列を，「‘」で囲んでいないか確認してください。
正しい指定例：PDUSER="root"/"root"
注　ただし，クライアント環境定義の中では，「‘」で囲むのが正しい指定方法です。
KFPL25000-E
Invalid format exists in command line　　（Ｅ）
ユティリティのコマンドラインの形式が誤っています。
(Ｓ)処理を終了します。
(Ｏ)コマンドラインを修正して，再度コマンドを実行してください。
KFPL25001-E
Invalid attribute exists in command line　　（Ｅ）
ユティリティのコマンドラインに不正な指定値があります。LANG環境変数が正しく設定されていない場合に，各国文字を使用した識別子を指定したときも，このメッセージが表示されます。
(Ｓ)処理を終了します。
(Ｏ)次のどちらかの処置をしてください。
・コマンドラインを修正して，再度コマンドを実行してください。
・LANG環境変数の値をpdsetupで指定した文字コードセットと合わせて，再度コマンドを実行してください。
KFPL25002-E
Inconsistent specification in command line　　（Ｅ）
ユティリティのコマンドラインに排他関係のオプションが同時に指定されています。
(Ｓ)処理を終了します。
(Ｏ)コマンドラインを修正して，再度コマンドを実行してください。
KFPL25003-E
Mandatory specification missing in command line　　（Ｅ）
ユティリティのコマンドラインに，必要なオプションが指定されていません。
(Ｓ)処理を終了します。
(Ｏ)コマンドラインに必要な項目を指定した後，再度コマンドを実行してください。
KFPL25004-E
Invalid format exists in Control file, line=aa....aa　　（Ｅ）
ユティリティの制御情報ファイルの，aa....aa行目の形式が誤っています。
aa....aa：解析時にエラーになった行番号
(Ｓ)処理を終了します。
(Ｏ)制御情報ファイル中の該当する行番号を修正して，再度コマンドを実行してください。
KFPL25005-E
Invalid attribute exists in Control file, line=aa....aa　　（Ｅ）
ユティリティの制御情報ファイルの，aa....aa行目の値が誤っています。
aa....aa：解析時にエラーになった行番号
(Ｓ)処理を終了します。
(Ｏ)制御情報ファイル中の該当する行番号を修正して，再度コマンドを実行してください。
KFPL25006-E
Mandatory specification missing in Control file, line=aa....aa　　（Ｅ）
ユティリティの制御情報ファイルの，aa....aa行目に必要な項目が指定されていません。
aa....aa：解析時にエラーになった行番号
(Ｓ)処理を終了します。
(Ｏ)制御情報ファイル中の該当する行番号に必要な項目を指定して，再度コマンドを実行してください。
KFPL25007-E
Duplicate attribute aa....aa exists in Control file　　（Ｅ）
ユティリティの制御情報ファイルのaa....aaが重複しています。
aa....aa：制御情報ファイル中で重複している内容
(Ｓ)処理を終了します。
(Ｏ)制御情報ファイル中の重複した内容に該当する指定内容を修正して，再度コマンドを実行してください。
KFPL25009-E
Mandatory specification not exist in Control file　　（Ｅ）
データベース作成ユティリティ(pdload)の，制御情報ファイルに必要な項目であるsource文がありません。
又は，LOB属性の入力パラメタを持つ関数を定義した抽象データ型を含む表を指定しましたが，制御情報ファイルにlobdata文がありません。
(Ｓ)処理を終了します。
(Ｏ)制御情報ファイルにsource文を指定して，再度コマンドを実行してください。LOB属性の入力パラメタを持つ関数を定義した抽象データ型を含む表を指定する場合は，制御情報ファイルにlobdata文を記述してください。
KFPL25010-E
HiRDB Dataextractor interface error occurred, code=aa, file=bb....bb [, contents='cc....cc' x]　　（Ｅ＋Ｌ）
HiRDB Dataextractor又はDataStageとデータベース作成ユティリティ（pdload）との間で，インタフェースエラーが発生しました。[, contents='cc....cc' x]は，aaが2の場合に出力されます。
aa：保守コード
1：
extractorinf句のfileオペランドで指定したファイルがパイプファイルではありません。
2：
extractorinf句のfileオペランドで指定したファイルの内容が，COMPLETEDではありません（COMPLETEDの後ろに改行記号などがある場合もエラーとなります）。
bb....bb：保守情報1
extractorinf句のfileオペランドで指定したファイル名です。
ファイル名の長さが111文字以上の場合は，ファイル名の後ろから110文字を出力します。
cc....cc：保守情報2
extractorinf句のfileオペランドで指定したファイルの内容（16進数表示）です。ファイルに何も指定していない場合は'' x ''が表示されます。
(Ｓ)処理を終了します。
(Ｏ)
HiRDB Dataextractor又はDataStageでエラーが発生した場合：
HiRDB Dataextractor又はDataStageが出力したメッセージを参照して，対処してください。
HiRDB Dataextractor又はDataStageをキャンセルした場合：
このメッセージは無視してください。
上記以外の場合：
保守員に連絡してください。
KFPL25040-E
Cannot allocate communication buffer, size=aaaaa, code=b　　（Ｌ）
通信用バッファが確保できません。
aaaaa：確保しようとした通信バッファサイズ
b：理由コード
4：領域不足
8：プロトコルエラー
(Ｓ)処理を終了します。
(Ｏ)
〈HS-Linkドライバ直接プロセス間通信機能を使用している場合〉
通信バッファを大量に使用するほかのプロセスの終了を待って，再度コマンドを実行してください。
〈HS-Linkドライバ直接プロセス間通信機能を使用していない場合〉
ユーザ空間を大量に使用するほかのプロセスの終了を待って，再度コマンドを実行してください。
〈サーバにわたった表の横分割をしている場合〉
表単位にコマンドを実行しているときはRDエリア単位のコマンドに変更して実行することを検討してください。必要となるバッファサイズは，サーバ数分の1に減少します。
[対策]システム共通定義で，ユティリティの通信用バッファ長（pd_utl_buff_size）の値を減らしてください。
KFPL25100-E
Column name missing in configuration file　　（Ｅ）
列構成情報ファイルにNOT NULL属性を定義した列名が指定されていません。又は，列名が一つも指定されていません。
(Ｓ)処理を終了します。
(Ｏ)列構成情報ファイルに必要な列名を指定して，再度コマンドを実行してください。
KFPL25101-E
Invalid format existed in dataload file　　（Ｅ）
入力データファイルの形式が不正です。
(Ｓ)処理を終了します。
(Ｏ)入力データファイルの内容を修正して，再度コマンドを実行してください。
KFPL25102-E
Invalid attribute in configuration/null-information file, line=aaaaa　　（Ｅ）
列構成情報ファイル，又はナル値情報ファイルの内容に誤りがあります。
aaaaa：誤りがある行番号
(Ｓ)処理を終了します。
(Ｏ)列構成情報ファイル又はナル値情報ファイルの内容を修正して，再度コマンドを実行してください。
KFPL25200-E
Unable to get utility definition　　（Ｌ）
システム共通定義の読み込みに失敗しました。実行する環境に省略値を仮定します。
(Ｓ)処理を続行します。
[対策]次回ユティリティの実行環境を省略値から変更するときは，システム共通定義ファイルの内容を確認してください。
KFPL25210-E
aa....aa must be executed at unit defined as manager　　（Ｌ）
aa....aaは，システムマネジャが定義されているユニットで実行してください。
aa....aa：実行しようとしたユティリティ又はコマンド
pdload：データベース作成ユティリティ
pdrorg：データベース再編成ユティリティ（pdreolaim，pdpgbfonを含む）
COMMAND：プラグインが提供するコマンド
pdrbal：リバランスユティリティ
(Ｓ)処理を終了します。
(Ｏ)システムマネジャ（MGR）が定義されているユニットにリモートログインして，再度コマンドを実行してください。
KFPL25211-E
Cannot specify input file at manager　　（Ｅ）
入力データファイルを指定できるサーバが，次に示すサーバではありません。
・フロントエンドサーバ
・バックエンドサーバ
・ディクショナリサーバ
(Ｓ)処理を終了します。
(Ｏ)入力データファイルの指定位置を変更して，再度コマンドを実行してください。
KFPL25212-E
Default value length too long, column="aa....aa"　　（Ｌ）
列構成情報ファイルの列名文を省略して列aa....aaに既定値を格納する指定をしていますが，既定値の長さが該当する列の長さよりも長いため，既定値を格納できません。
aa....aa：列名
(Ｓ)処理を終了します。
(Ｏ)列構成情報ファイルの列名文を指定するか，又は表定義の該当する列の長さを既定値が格納できる長さに変更するかして，再度実行してください。
KFPL25222-W
Unable to output aa....aa file, reason=bb....bb　　（Ｌ）
入力データのエラーを検知しましたが，bb....bbの理由によってエラーデータファイル又は分割入力データファイルにデータを出力できません。
なお，このメッセージはエラーデータファイル又は分割入力データファイルに出力されなかったデータ件数に関係なく，それぞれ一度しか出力されません。
aa....aa：ファイル種別
error data：エラーデータファイル
divided：分割入力データファイル
bb....bb：理由コード
ROW_LENGTH：エラーデータの行長が，32キロバイト又はsource文のmaxreclenオペランドの指定値を超えています。
UNIQUE_ERROR：ユニークキー又は主キーを指定したインデクスのキー値重複エラーを検知しましたが，エラーデータファイル編集バッファが不足しました。
PLUGIN_ERROR：プラグイン提供関数がエラーを検知しましたが，エラーデータファイル編集バッファが不足しました。
(Ｓ)処理を続行します。
(Ｏ)
エラーデータファイルの場合：
エラー情報ファイルに出力されているのに，エラーデータファイルには出力されていないデータがあります。そのため，エラーデータファイルではなく，入力データファイルから，該当するデータを検索して，修正してください。
バッファ不足が要因の場合は，次回のデータロード時にerrworkオペランドで十分なエラーデータファイル編集バッファサイズを指定してください。該当エラーを検知した場合でも，エラーデータファイルにデータが出力されます。
分割入力データファイルの場合：
maxreclenオペランドに最大行長を指定して，再度実行してください。
KFPL25338-E
Invalid RDAREA id found in unload file, RDAREA id=aa....aa, file=bb....bb　　（Ｌ）
アンロードした行を格納するRDエリアと，リロードする行を格納するRDエリアが異なります。-gオプションを指定している場合，リロードする表の表定義（分割格納条件）が変更されているので，RDエリアに行データが格納できません。
aa....aa：アンロードしたRDエリア名
bb....bb：アンロードデータファイル名
アンロードデータファイル名の長さが144文字以上の場合は，アンロードデータファイル名の後ろから143文字を出力します。
(Ｓ)処理を終了します。
(Ｏ)
〈-rオプションでRDエリア名を指定している場合〉
該当するRDエリアの行が出力されているアンロードデータファイルを指定して，再度コマンドを実行してください。
〈-rオプションを指定していない場合〉
アンロードデータファイルが異なるため，正しいアンロードデータファイルを指定して，再度コマンドを実行してください。又は，該当する表を回復した後，再編成処理（-k rorg）を指定して，再度コマンドを実行してください。
〈-gオプションを指定している場合〉
格納できない行データがアンロードファイル中にあるため，変更前の表定義を参照して，行を格納できるRDエリアを分割条件に加えて，表定義を変更してください。その後，リロード処理（-k reld）を指定して，再度コマンドを実行してください。
KFPL25339-E
Unable to get aa....aa information from unload file, file=bb....bb　　（Ｅ＋Ｌ）
アンロードデータファイル中のaa....aaの情報がありません。このため，リロードできません。
aa....aa：情報の種別
column：列情報
dictionary：ディクショナリ情報
divide：分割情報
hash：ハッシュ分割情報
index：インデクス情報
index rdarea：インデクス格納RDエリア情報
LOB：LOB情報
ADT：抽象データ型情報
multidim：マトリクス分割情報
bb....bb：アンロードデータファイル名
アンロードデータファイル名の長さが149文字以上の場合は，アンロードデータファイル名の後ろから148文字を出力します。
(Ｓ)処理を終了します。
(Ｏ)このメッセージの出力以前に出力されたメッセージログファイルのメッセージを参照してエラーの原因を取り除き，再度コマンドを実行してください。
KFPL25340-E
aa....aa information not exists on unload file, file=bb....bb　　（Ｌ）
アンロードデータファイル中のaa....aaの情報がありません。このため，リロードできません。
aa....aa：情報の種別
Column：列情報
Dictionary：ディクショナリ情報
Divide：分割情報
Hash：ハッシュ分割情報
Index：インデクス情報
Index rdarea：インデクス格納RDエリア情報
LOB：LOB情報
ADT：抽象データ型情報
multidim：マトリクス分割情報
bb....bb：アンロードデータファイル名
アンロードデータファイル名の長さが151文字以上の場合は，アンロードデータファイル名の後ろから150文字を出力します。
(Ｓ)処理を終了します。
(Ｏ)正常なアンロードデータファイルを指定して，再度コマンドを実行してください。
KFPL25341-E
aa....aa lock request failed, id=bb....bb　　（Ｌ）
資源aa....aaの排他制御に失敗しました。
aa....aa：資源名称
bb....bb：資源ID
(Ｓ)処理を終了します。
(Ｏ)対象となる資源を占有しているユーザの処理が終了するのを待って，再度コマンドを実行してください。
KFPL25342-E
Invalid EOF found in unload file, file=aa....aa　　（Ｌ）
アンロードデータファイルが不正です。
aa....aa：アンロードデータファイル名
アンロードデータファイル名の長さが151文字以上の場合は，アンロードデータファイル名の後ろから150文字を出力します。
(Ｓ)処理を終了します。
(Ｏ)正常なアンロードデータファイルを指定して，再度コマンドを実行してください。
KFPL25343-E
Different column information in unload file, table=aa....aa.bb....bb　　（Ｌ）
アンロードデータファイル中の表定義とリロードする表の表定義が異なります。このため，リロードできません。
aa....aa：認可識別子
bb....bb：表識別子
(Ｓ)処理を終了します。
(Ｏ)対象とする表をアンロード（-k unld）した後，再度コマンドを実行してください。又は，データベースを再編成（-k rorg）してください。
KFPL25344-E
Insufficient index file, index=aa....aa.bb....bb　　（Ｌ）
インデクスaa....aa.bb....bbに対するインデクス情報ファイルの指定数が不足しています。
aa....aa：認可識別子
bb....bb：インデクス識別子
(Ｓ)処理を終了します。
(Ｏ)不足したインデクス情報ファイルを指定して，再度コマンドを実行してください。
KFPL25347-E
No specified aa....aa in Control file　　（Ｌ）
アンロードデータファイル，LOBデータのアンロードファイル又はインデクス情報ファイルの指定がありません。又は，LOB列構成基表の入力データファイルに指定したLOB列に対する列単位LOB入力ファイルの指定がありません。
aa....aa：必要なファイルの種別
{ index（インデクス情報ファイル）
| unload（アンロードデータファイル）
| unload(lobunld)（アンロードデータファイル又はLOBデータのアンロードファイル）
| lobcolumn（列単位LOB入力ファイル）}
(Ｓ)処理を終了します。
(Ｏ)次のどれかの処置をしてください。
・アンロードデータファイル，LOBデータのアンロードファイル又はインデクス情報ファイルのどれかを指定して，再度コマンドを実行してください。
・LOB列構成基表の入力データファイルに指定したLOB列に対する列単位LOB入力ファイルをすべて指定して，再度コマンドを実行してください。
・インデクスの再作成（-k ixrc）の場合は，idxname文，又はindex文を指定して再度コマンドを実行してください。
KFPL25352-E
Insufficient unload file, table=aa....aa.bb....bb, server=cc....cc　　（Ｌ）
サーバcc....ccのアンロードデータファイルが指定されていません。
aa....aa：認可識別子
bb....bb：表識別子
cc....cc：サーバ名
(Ｓ)処理を終了します。
(Ｏ)アンロードデータファイルを指定して，再度コマンドを実行してください。
KFPL25353-E
Incompatible byte order between unload and reload system　　（Ｌ）
アンロードしたシステムとリロードするシステムのバイトオーダが異なるため，リロードできません。
(Ｓ)処理を終了します。
(Ｏ)同じバイトオーダのシステム間で，アンロード及びリロードをしてください。
KFPL25354-E
Incompatible character code set, HiRDB=aa....aa, unload file=bb....bb　　（Ｌ）
アンロードデータファイルの文字コード種別と，リロード先のHiRDBの文字コード種別が不一致です。
aa....aa：HiRDBの文字コード種別
CHINESE：EUC中国語漢字コード
LANG-C：単一バイト文字コード
SJIS：シフトJISコード
UJIS：EUC日本語漢字コード
UTF-8：Unicode（UTF-8）
bb....bb：アンロードデータファイルの文字コード種別
CHINESE：EUC中国語漢字コード
LANG-C：単一バイト文字コード
SJIS：シフトJISコード
UJIS：EUC日本語漢字コード
UTF-8：Unicode（UTF-8）
(Ｓ)処理を終了します。
(Ｏ)同じ文字コード種別のシステム間で，アンロード及びリロードをしてください。
KFPL25355-E
More than aa....aa bytes in bb....bb　　（Ｌ）
DAT形式，又は固定長データ形式に変更した後，1行の行長が最大長を超えました。
aa....aa：最大長
bb....bb：行長
(Ｓ)処理を終了します。
[対策]必要があれば，バイナリ形式（-W bin）指定に変更して，再度実行してください。
KFPL25356-E
Incompatible unload file version　　（Ｌ）
指定したアンロードデータファイルは，現在稼働しているHiRDBのバージョンと異なるため，使用できません。
(Ｓ)処理を終了します。
(Ｏ)アンロードデータファイルの指定が正しいかどうか確認してください。指定したアンロードデータファイルが異なる場合，正しいアンロードデータファイルを指定して，再度実行してください。
[対策]現在稼働しているHiRDBのバージョンよりも，古いバージョンで作成されたアンロードデータファイルが指定されているため，リロードできません。必要があれば，現在稼働しているHiRDBのバージョンで出力したアンロードデータファイルを指定して，再度実行してください。
KFPL25357-E
Invalid LOB data, RDAREA="aa....aa"　　（Ｌ）
LOBデータが不正です。
aa....aa：LOB格納RDエリア名
(Ｓ)処理を終了します。
(Ｏ)
〈pdrorgの場合〉
・表単位で実行するとき
処理対象の表に定義されたLOBデータ格納RDエリアを再初期化し，制御文にlobunld文だけ指定して表単位にリロードしてください。
・RDエリア単位で実行するとき
出力されたLOB用RDエリアを再初期化して，制御文にlobunld文だけ指定してRDエリア単位にリロードしてください。
〈pdloadの場合〉
・作成モードのとき
対象となるLOB用RDエリアを再初期化して，LOBデータをデータロードしてください。なお，再初期化するRDエリアは，pdrorgのときと同様です。
・追加モードのとき
バックアップによって表及びLOB用RDエリアを回復した後，再度データロードしてください。なお，表及びLOB用RDエリアの回復が完了するまで，UAPなどで表及びLOB用RDエリアの更新をしないでください。
KFPL25358-E
Invalid LOB data, RDAREA=aa....aa, line=bb....bb　　（Ｅ＋Ｌ）
bb....bb行目のLOBデータがユーザLOB用RDエリアaa....aaに格納できません。次の理由が考えられます。
1. LOB列へのデータロードが完了しているのに，再度LOB列へデータロードしようとした。
2. DB破壊状態となっているユーザLOB用RDエリアにデータロード（リロードも含む）しようとした。
aa....aa：ユーザLOB用RDエリア名
bb....bb：エラーを検知した行数
(Ｓ)処理を終了します。
(Ｏ)
1. ユーザLOB用RDエリア名，又はLOB中間ファイル名を修正して再度実行してください。
2. ユーザ用RDエリア，及びユーザLOB用RDエリアをバックアップから回復した後，再度実行してください。
KFPL25359-E
Unable to reload table or unload file due to aa....aa defined　　（Ｌ）
別表に行を再登録する場合，行を再登録する表又はアンロードデータファイルの表にLOB列が定義されているため，行の再登録ができません。
aa....aa：LOB column
(Ｓ)処理を終了します。
(Ｏ)アンロードした表又は行を別表へ再登録する場合，その表にLOB列が定義されているときは，再登録できません。データベース作成ユティリティ又はUAPで，別表を作成してください。
KFPL25700-I
UOC information, message=aa....aa, code=bb　　（Ｌ）
UOCからメッセージの出力要求がありました。
aa....aa：UOCから出力要求があったメッセージの内容
bb：UOCからのリターンコード
(Ｓ)UOCからのリターンコードが４の場合は，処理を続行します。それ以外のコードの場合は，処理を終了します。
(Ｏ)処理が打ち切られた場合は，UOCで出力したメッセージの内容を参照して，エラーの原因を取り除いてから，再度コマンドを実行してください。
KFPL25710-E
Invalid value in UOC interface area, code=aa,line=bb....bb　　（Ｌ）
UOCインタフェース領域に，UOCが設定した値が不正です。
aa：エラー詳細コード
10：UOCで編集したデータのアドレスが設定されていません。
20：バイナリ形式の入力データファイルの場合，UOCで編集したデータの長さが表定義と一致しません。拡張DAT形式の入力データファイルの場合，UOCで編集したデータの長さに負の値が設定されています。
30：UOCが設定したリターンコードが規定値ではありません。又は，リターンコードが設定されていません。
40：ユティリティが入力したデータを格納する入力バッファのデータを，データ長を超えて更新しています。又は，UOCインタフェース領域を破壊しています。
50：DAT形式の入力データファイルの末尾に改行記号がありません。データベース再編成ユティリティが出力した-W指定のバイナリ形式の入力データファイルの場合，入力データにBLOBデータがあります。
51：可変長文字列型又は長大データ型のデータ値が不正です。
52：パック形式の符号部のデータが不正です。
53：パック形式でのパックデータ値，又はパックデータの指定範囲が不正です。
54：繰返し列の実長が，返却されたデータと不一致です。
55：繰返し列の繰り返し数が不正です。
56：繰返し列のナル値フラグが不正です。
57：NOT NULL列へのナル値の設定が不正です。
60：格納フラグの設定値が規定値外です。
70：監査証跡データ登録UOCのパラメタが不正です。
bb....bb：エラーが発生した行番号
行番号が0の場合はUOC開始処理時にエラーが発生して1行も処理をしていない状態です。
(Ｓ)処理を終了します。ただし，エラー詳細コードが40の場合は，異常終了します。
(Ｏ)UOCインタフェース領域に設定した内容を見直して，プログラムを修正した後で，再度コマンドを実行してください。
KFPL25999-Ｗ
Unable to make an entry SQL_DB_MANAGEMENT, RDID=aa....aa, reason=bb...bb　　（Ｅ＋Ｌ）
運用履歴表に状態解析結果を登録できませんでした。そのため，RDエリアIDがaa....aaのRDエリアに1表，又は1インデクスだけを格納している場合※，再編成時期予測機能で表示するRDエリア枯渇時期予測日に誤差が発生する可能性があります（枯渇時期予測日が遅くなります）。
複数のRDエリアが処理対象の場合，最初にエラーを検知したRDエリアだけメッセージを出力します。
注※
1RDエリアに複数の表やインデクスが格納されている場合，RDエリア枯渇時期予測では運用履歴表を参照しません（理由：RDエリア内の一部の表又はインデクスを再編成しても，RDエリア全体が再編成されたことにはならないため，予測に反映しません）。
aa....aa：RDエリアID
bb....bb：エラー要因
MEMORY：メモリ不足です。
CONNECT：HiRDBの接続に失敗しました。
ACCESS：運用履歴表にアクセスできません。
HOLD：コマンド閉塞中のためアクセスできません。
SQL_ERR：運用履歴表が更新できません。
MESSAGE_SEND：通信障害です。
(Ｓ)処理を続行します。
(Ｏ)
このメッセージの前に出力されたエラーメッセージ※を参照してエラー原因を取り除いた後，pddbstを再度実行してください。その後，pddbstの実行結果を運用履歴表に反映して，再編成時期予測機能を実行すると，予測精度が向上します。なお，1RDエリアに複数の表やインデクスを定義している場合は，再実行の必要はありません。また，再実行しなくても，毎日状態解析結果蓄積機能を実行することで，予測誤差は最小限になります。
既にRDエリア枯渇時期予測日が表示されていて，かつ大まかな再編成時期が分かればよいという場合は，既に表示されているRDエリア枯渇時期予測日の数日前が予測日と判断してください。
注※
エラーメッセージがKFPA11204-Eの場合は，pdmodで解析情報表及び運用履歴表を格納するデータディクショナリ用RDエリアを作成する必要があります。
KFPL26339-E
Unable to get aa....aa information from lobmid file, file=bb....bb　　（Ｌ）
LOB中間ファイルからaa....aaの情報が取得できません。
aa....aa：情報の種別
Column：列情報
LOB：LOB情報
bb....bb：LOB中間ファイル名
LOB中間ファイル名の長さが151文字以上の場合は，LOB中間ファイル名の後ろから150文字を出力します。
(Ｓ)処理を終了します。
(Ｏ)このメッセージの前に出力されたエラーログファイルを参照して，エラーの原因を取り除き，再度コマンドを実行してください。
KFPL26340-E
aa....aa information not exists on lobmid file, file=bb....bb　　（Ｌ）
LOB中間ファイル中のaa....aaの情報がありません。このため，LOB列のデータロードができません。
aa....aa：情報の種別
Column：列情報
LOB：LOB情報
bb....bb：LOB中間ファイル名
LOB中間ファイル名の長さが151文字以上の場合は，LOB中間ファイル名の後ろから150文字を出力します。
(Ｓ)処理を終了します。
(Ｏ)正常なLOB中間ファイルを指定して，再度コマンドを実行してください。
KFPL26342-E
Invalid EOF found in lobmid file, file=aa....aa　　（Ｌ）
LOB中間ファイルが不正です。
aa....aa：LOB中間ファイル名
LOB中間ファイル名の長さが151文字以上の場合は，LOB中間ファイル名の後ろから150文字を出力します。
(Ｓ)処理を終了します。
(Ｏ)正常なLOB中間ファイルを指定して，再度コマンドを実行してください。
KFPL27100-E
Unable to get UOC aa....aa information, name=bb....bb, errno=ccc　　（Ｌ）
UOCの以下の情報が取得できません。
library：UOC格納ライブラリ
function：UOCの関数
aa....aa：UOC情報の種別
library：共用ライブラリ名
function：関数名
bb....bb：UOC情報の名称
ccc：errnoにセットされたエラー番号
(Ｓ)処理を終了します。
(Ｏ)errno（エラー状態を表す外部整数変数）について，errno.h及びOSのマニュアルを参照し，エラーの原因を判断して，制御情報ファイルに指定した名称を修正します。又は，指定したライブラリが共用ライブラリになっているか，アクセスパーミッションがあるかなどを見直します。その後，再度コマンドを実行してください。errno=0の場合は，このメッセージの前に出力されたKFPL22001-Eメッセージの内容に従って，エラーの原因を取り除き，再度コマンドを実行してください。
KFPL27500-E
Transaction wait time over,index=aa....aa."bb....bb",RDAREA=cc....cc　　（Ｌ）
pdreclaim（インデクスの使用中空きページの解放）を実行しましたが，-wオプションの指定値の時間を過ぎました（-wオプションの時間内に，該当するインデクスをアクセスするUAPのトランザクションが決着しなかったため）。
aa....aa：認可識別子
bb....bb：インデクス識別子
cc....cc：RDエリア名
(Ｓ)処理を終了します。
(Ｏ)pdreclaimを再度実行する場合は，次のどちらかの対処をしてください。
・長大トランザクションのUAPの終了を待ってから再度実行してください。
・-wオプションの指定値を大きくしてから再度実行してください。
KFPL28000-E
Internal error occurred, code=aaa(bb....bb)　　（Ｅ＋Ｌ）
内部エラーが発生しました。
aaa：保守コード（保守コードとその意味を表に示します）
bb....bb：保守情報（保守情報を表に示します）
(Ｓ)処理を終了します。
(Ｏ)
コマンドを提供するプラグインの，前提バージョン以降のHiRDBでこのコマンドを実行してください。
HiRDBのバージョンがプラグインの前提バージョンと一致していない場合，HiRDBをバージョンアップしてください。バージョンが一致している場合は保守員に連絡してください。
保守コードと保守情報を次に示します。
保守
コード
意味
保守情報
1
実行コマンドラインの形式が誤っています。
－
2
実行コマンドラインに必要なオプションが指定されていません。
－
100
制御情報ファイルで，保守情報で示した制御文が重複しています。
制御文
101
制御情報ファイルに，プラグイン種別（index文）の指定がありません。
－
102
制御情報ファイルで，プラグイン種別（index文）の指定が矛盾しています。
－
104
制御情報ファイルで指定した保守情報で示すエラーになった行番号の情報の種別の形式が誤っています。
情報の種別，エラーになった行番号
・情報の種別
library_name：ライブラリ名称
function_name：関数名称
option_string：オプション文字列
mode_kind：モード種別
lock_kind：ロック種別
table_access_kind：テーブルアクセス種別
105
制御情報ファイルの，modecheck文の数が最大指定数を超えて指定されています。
－
107
制御情報ファイルの保守情報で示すエラーとなった行番号の形式が誤っています。
エラーになった行番号
108
制御情報ファイルに必要な項目である，func文，又はfunc_type文がありません。
－
109
保守情報で示す制御情報ファイルへの入力エラーが発生しました。
制御情報ファイル名
200
指定した外部ルーチン名は登録されていません。
詳細コード
  1：ライブラリ名称
  2：プラグイン関数
201
ユティリティ契機ではありません。
指定した外部ルーチンの契機コード
（凡例）－：該当しません。
KFPL28002-E
Invalid HiRDB connect aa....aa　　（Ｅ＋Ｌ）
環境変数PDUSERが指定されていない，又は環境変数PDUSERで指定されているユーザID又はパスワードが不正です。
aa....aa：エラーが発生した種別
user_id：HiRDB接続ユーザID
password： HiRDB接続パスワード
(Ｓ)処理を終了します。
(Ｏ)環境変数PDUSERの内容を修正して，再度コマンドを実行してください。
正しい指定例：PDUSER＝"root"／"root"
注　ただし，クライアント環境定義の中では，「'」で囲むのが正しい指定方法です。
KFPL28101-E
Table aa....aa."bb....bb" not found　　（Ｅ＋Ｌ）
処理対象の表aa....aa.bb....bbはありません。
aa....aa：認可識別子
bb....bb：表識別子
(Ｓ)処理を終了します。
(Ｏ)処理対象の表の認可識別子，及び表識別子を見直し修正した後，再度コマンドを実行してください。
KFPL28102-E
Index aa....aa."bb....bb" not found　　（Ｅ＋Ｌ）
処理対象のインデクスaa....aa.bb....bbはありません。
aa....aa：認可識別子
bb....bb：インデクス識別子
(Ｓ)処理を終了します。
(Ｏ)処理対象のインデクスの認可識別子，及びインデクス識別子を見直し修正した後，再度コマンドを実行してください。
KFPL28103-E
Column "aa....aa" not found in table bb....bb."cc....cc"　　（Ｅ＋Ｌ）
列名aa....aaは表bb....bb.cc....ccにありません。
aa....aa：列名称
bb....bb：認可識別子
cc....cc：表識別子
(Ｓ)処理を終了します。
(Ｏ)列名を修正して，再度コマンドを実行してください。
KFPL28104-E
Privilege not satisfy　　（Ｅ＋Ｌ）
権限がないためコマンドを実行できません。
(Ｓ)処理を終了します。
(Ｏ)権限が正しいかどうかを確認し，誤っている場合は権限を変更し，再度コマンドを実行してください。
権限が正しい場合には，管理者又は表の所有者に，対象となる表への権限を与えてもらい，再度コマンドを実行してください。
[対策]プログラマが権限の付与を要求した場合，要求が妥当なときは，権限を与えてください。
KFPL28105-E
Column "aa....aa" not ADT　　（Ｅ＋Ｌ）
列名aa....aaは抽象データ型（ADT）ではありません。
aa....aa：列名称
(Ｓ)処理を終了します。
(Ｏ)抽象データ型の列を指定して，再度コマンドを実行してください。
KFPL28108-E
PLUGIN not defined in column "aa....aa"　　（Ｅ＋Ｌ）
指定した列aa....aaの型には，プラグインが定義されていません。
aa....aa：列名称
(Ｓ)処理を終了します。
(Ｏ)列の型をプラグインで定義されている型に修正して，再度コマンドを実行してください。
KFPL28109-E
PLUGIN not defined in index "aa....aa"　　（Ｅ＋Ｌ）
インデクスaa....aaは，プラグインインデクスではありません。
aa....aa：インデクス識別子
(Ｓ)処理を終了します。
(Ｏ)実行対象となるインデクス名をプラグインインデクス名に修正して，再度実行してください。
KFPL28900-I
Pdplgexe started, generation=aa　　（Ｌ）
プラグイン実行ユティリティ（pdplgexe)を開始しました。
インナレプリカ機能を使用している場合は，generation=aaが表示されます。
aa：世代番号
(Ｓ)処理を続行します。
KFPL28901-I
Pdplgexe terminated, return code=aa　　（Ｌ）
プラグイン実行ユティリティ（pdplgexe）が終了しました。
aa：リターンコード
0：正常終了しました。
8：プラグイン関数でエラーが発生しました。
12：プラグイン関数以外でエラーが発生しました。
(Ｓ)処理を終了します。
(Ｏ)リターンコードが0以外の場合，標準出力又はメッセージログファイルに出力されたエラーメッセージを参照してエラーの原因を取り除いた後，再度コマンドを実行してください。
KFPL28904-I
Transaction commit　　（Ｅ＋Ｌ）
トランザクションをコミットしました。
(Ｓ)処理を続行します。
KFPL28905-E
Transaction rollback　　（Ｅ＋Ｌ）
このメッセージの前に出力されたメッセージログファイルに示す理由のため，ロールバックしました。
(Ｓ)処理を終了します。
(Ｏ)このメッセージの前に出力されたメッセージログファイルを調査し，ロールバックの原因を取り除いてください。
KFPL30000-I
aa....aa name=bb....bb　　（Ｒ）
サーバ又はRDエリアbb....bbに挿入しようとしたデータに関するメッセージの始まりを示します。
aa....aa：
Server：サーバ名
RDAREA：RDエリア名
bb....bb：識別子
(Ｓ)エラー情報ファイルにインフォメーションメッセージを出力して処理を終了します。
KFPL30001-I
Rows successfully loaded=aa....aa　　（Ｒ）
aa....aa行数分のデータロードに成功しました。
aa....aa：行数
(Ｓ)エラー情報ファイルにインフォメーションメッセージを出力して処理を終了します。
KFPL30002-I
aa....aa rows outputed, RDAREA=bb....bb　　（Ｒ）
RDエリアbb....bbに格納するデータをaa....aa行出力しました。
aa....aa：行数
bb....bb：RDエリア名称
(Ｓ)エラー情報ファイルにインフォメーションメッセージを出力して処理を終了します。
KFPL31001-E
Invalid input data byte, line=aa....aa, column=bb....bb [, element=cc....cc]　　（Ｒ）
line=aa....aa，column=bb....bb（element=が出力されている場合は繰返し列の要素cc....cc）の入力データ長が不正です。
aa....aa：行番号
bb....bb：列番号
入力データファイル中のデータの先頭からの位置を示します。したがって，skipdata文で入力対象外とした列やコンストラクタ関数の引数の数を含めた値を表示します。
cc....cc：要素番号
(Ｓ)エラー情報ファイルにエラーメッセージを出力します。
(Ｏ)入力データファイルで該当する行番号のデータを修正してください。
KFPL31002-E
Invalid pack format value, line=aa....aa, column=bb....bb [, element=cc....cc]　　（Ｒ）
line=aa....aa，column=bb....bb（element=が出力されている場合は繰返し列の要素cc....cc）のパック形式データが不正です。
aa....aa：行番号
bb....bb：列番号
入力データファイル中のデータの先頭からの位置を示します。したがって，skipdata文で入力対象外とした列やコンストラクタ関数の引数の数を含めた値を表示します。
cc....cc：要素番号
(Ｓ)エラー情報ファイルにエラーメッセージを出力します。
(Ｏ)入力データファイルの該当する行番号のパック形式データを修正してください。
KFPL31003-E
Invalid varchar length, line=aa....aa, column=bb....bb [, element=cc....cc]　　（Ｒ）
line=aa....aa，column=bb....bb（element=が出力されている場合は繰返し列の要素cc....cc）の可変長データの長さ部が不正です。
aa....aa：行番号
bb....bb：列番号
入力データファイル中のデータの先頭からの位置を示します。したがって，skipdata文で入力対象外とした列やコンストラクタ関数の引数の数を含めた値を表示します。
cc....cc：要素番号
(Ｓ)エラー情報ファイルにエラーメッセージを出力します。
(Ｏ)入力データファイルで該当する行番号のデータを修正してください。
KFPL31004-E
Data conversion error occurred, line=aa....aa, column=bb....bb [, element=cc....cc]　　（Ｒ）
line=aa....aa，column=bb....bb（element=が出力されている場合は繰返し列の要素cc....cc）の入力データの変換処理中にエラーが発生しました。
aa....aa：行番号
bb....bb：列番号
入力データファイル中のデータの先頭からの位置を示します。したがって，skipdata文で入力対象外とした列やコンストラクタ関数の引数の数を含めた値を表示します。
cc....cc：要素番号
(Ｓ)エラー情報ファイルにエラーメッセージを出力します。
(Ｏ)入力データファイルの該当する行番号のデータを修正してください。
KFPL31005-E
Number of columns in input file not equal to table columns, line=aa....aa　　（Ｒ）
line=aa....aaの入力データの列数が，格納する列数と一致しません。
aa....aa：行番号
(Ｓ)エラー情報ファイルにエラーメッセージを出力します。
(Ｏ)入力データファイルの該当する行番号のデータを修正してください。
データ中に「(00)16」が含まれている場合，テキストエディタで参照すると空白に見えるため，正しいデータに見えますが，HiRDBは「(00)16」の位置でデータの終わりと判断し，列数不一致と扱っていることがあります。バイナリエディタでデータの内容を確認してください。
KFPL31006-E
Invalid null value, line=aa....aa, column=bb....bb　　（Ｒ）
line=aa....aa，column=bb....bbの入力データに不当にナル値を指定しました。
aa....aa：行番号
bb....bb：列番号
入力データファイル中のデータの先頭からの位置を示します。したがって，skipdata文で入力対象外とした列やコンストラクタ関数の引数の数を含めた値を表示します。
(Ｓ)エラー情報ファイルにエラーメッセージを出力します。
(Ｏ)入力データファイルの該当する行番号のデータを修正してください。
KFPL31007-E
Invalid input record for cluster key sequence, line=aa....aa　　（Ｒ）
line=aa....aaの入力レコードがクラスタキー順に並んでいません。
aa....aa：行番号
(Ｓ)エラー情報ファイルにエラーメッセージを出力します。
(Ｏ)入力データファイルの該当する行番号のデータを修正してください。
なお，クラスタキー順にデータを並べ替えることが困難な場合は，-xオプションを指定することで順序チェックをしないでデータを格納できます。ただし，この格納方法の場合はクラスタキーの効果はありません。
KFPL31008-E
Key duplication error ocurred, line=aa....aa [bb....bb]　　（Ｒ）
line=aa....aaの入力データのキー値が重複しています。(No output for error data)が出力されている場合は，エラーデータファイル作成用ワークバッファが不足しています。
aa....aa：行番号
bb....bb：(No output for error data)
(Ｓ)エラー情報ファイルにエラーメッセージを出力し，処理を続行します。
(Ｏ)入力データファイルの該当する行番号のデータを修正して，再度実行してください。
(No output for error data)が出力されている場合はエラーデータファイルにエラーデータが出力されていません。エラーデータファイル作成用ワークバッファサイズに十分な値を指定して再実行すると，エラーデータファイルにエラーデータが出力されます。
KFPL31009-E
Invalid partitioning key value, line=aa....aa　　（Ｒ）
line=aa....aaの入力データに，作成する表の横分割の格納条件と一致しない列値があります。
aa....aa：行番号
(Ｓ)エラー情報ファイルにエラーメッセージを出力します。
(Ｏ)入力データファイルの該当する行番号のデータを修正してください。
KFPL31010-E
Invalid row length, line=aa....aa　　（Ｒ）
入力ファイル中の行番号aa....aaの行データの長さが不正です。
・バイナリ形式ファイルの場合
pdrorgが出力したバイナリ形式ファイルの行長，又は列オフセットの値が不正です。
・固定長データ形式ファイルの場合
列構成情報ファイルに指定された行長でデータを入力できません。
aa....aa：行番号
(Ｓ)エラー情報ファイルにエラーメッセージ出力後，処理を終了します。
(Ｏ)
〈バイナリ形式ファイルの場合〉
行データ中の行長，又は列オフセットが格納されている位置の不正な値を修正してください。
〈固定長データ形式ファイルの場合〉
列構成情報ファイルに指定した列情報が入力データの長さと一致するように修正してください。
なお，どちらの形式のファイルの場合も，入力ファイルに指定したファイルの中身が，意図したファイルの内容と異なるおそれがあります。その場合は，正しいファイルを指定して再度コマンドを実行してください。
KFPL31011-E
Invalid LOB format, line=aa....aa, column=bb....bb　　（Ｒ）
line=aa....aa，column=bb....bbのLOB列に対する指定形式が不正です。
・LOB列構成基表の入力ファイルに指定したLOB入力ファイル名称の長さが不正です。
・列単位LOB入力ファイルに指定したLOBデータ長が不正です。
・列単位LOB入力ファイルからLOBデータ長4バイト取得時，又は指定されたLOBデータ取得時に不正なEOFを検知しました。
aa....aa：行番号
入力データファイルの何行目かを示す番号です。列単位LOB入力ファイルを使用する場合は，列単位LOB入力ファイルの中の，エラーとなったデータの番号です。
bb....bb：列番号
入力データファイル中のデータの先頭からの位置を示します。したがって，skipdata文で入力対象外とした列やコンストラクタ関数の引数の数を含めた値を表示します。
(Ｓ)エラー情報ファイルに出力し，処理を終了します。
(Ｏ)
〈LOBデータごとにファイルを用意する場合〉
LOB列構成基表の入力データファイルの行番号に対応するLOB入力ファイルのファイル名称長が，0＜ファイル名称長≦1023であることを確認して，誤っている場合は修正してください。ファイル名称の長さが正しい場合は，絶対パス名での指定に修正してください。
EasyMTを使用する場合は，ファイル名称長が，0＜ファイル名称長≦17であるかを確認して，不正な場合は修正してください。
〈列単位LOB入力ファイルを用意する場合〉
LOB列構成基表の入力データファイルの行番号に対応する，列単位LOB入力ファイル中のLOBデータ長が，0＜LOBデータ長≦定義長であること，また，指定したLOBデータがあることを確認して，不正な場合は修正してください。
KFPL31012-E
Specified LOB file not found, line=aa....aa　　（Ｒ）
aa....aa行で指定したLOB入力ファイルがありません。
aa....aa：行番号
(Ｓ)エラー情報ファイルに出力し，処理を終了します。
(Ｏ)LOB入力ファイルが，指定したパスにあるかどうか確認してください。
KFPL31013-E
LOB data too long, line=aa....aa　　（Ｒ）
aa....aa行のLOBデータ長が表定義時に指定したLOB列の定義長を超えています。
〈LOBデータごとにファイルを用意する場合〉
LOB列構成基表の入力データファイルのaa....aa行で指定したLOB入力ファイルのデータが定義長を超えています。
〈列単位LOB入力ファイルを用意する場合〉
LOB列構成基表の入力データファイルのaa....aa行に対応する列単位LOB入力ファイルの中のLOBデータが定義長を超えています。
aa....aa：行番号
入力データファイルの何行目かを示す番号です。列単位LOB入力ファイルを使用する場合は，列単位LOB入力ファイルの中の，エラーとなったデータの番号です。
(Ｓ)エラー情報ファイルに出力し，処理を終了します。
(Ｏ)
〈LOBデータごとにファイルを用意する場合〉
行番号に対応する，LOB列構成基表の入力データファイルで指定したLOB入力ファイルを修正してください。
〈列単位LOB入力ファイルを用意する場合〉
行番号に対応する，列単位LOB入力ファイル中のLOBデータを修正してください。
KFPL31014-E
LOBMID file conflicted with LOB data file, line=aa....aa　　（Ｒ）
LOB中間ファイル（LOBMIDファイル）から取得したLOB列構成基表の指定内容は，列単位LOB入力ファイルの指定内容と矛盾します。
・LOB列構成基表のナル値指定に対して，列単位LOB入力ファイルに1バイト以上のデータを記述しています。
・LOB列構成基表のデフォルト値指定に対して，列単位LOB入力ファイルに1バイト以上のデータを記述しています。
aa....aa：行番号
入力データファイルの何行目かを示す番号です。
(Ｓ)エラー情報ファイルに出力し，処理を終了します。
(Ｏ)LOB列構成基表の入力データファイルの行番号のLOB列に対する指定内容を確認して，指定内容に対応するように列単位LOB入力ファイルのエラーのあった行番号のLOBデータを修正して，再度コマンドを実行してください。
KFPL31015-E
Unmatched LOB data count, line=aa....aa　　（Ｒ）
LOB列構成基表の入力データファイルのデータ件数と，列単位LOB入力ファイル中のLOBデータ件数aa....aaが一致しません。
aa....aa：行番号
列単位LOB入力ファイル中のエラーとなったデータの番号
(Ｓ)エラー情報ファイルにエラーメッセージを出力します。
(Ｏ)列単位LOB入力ファイルを使用する場合，その列単位LOB入力ファイル中にLOB列構成基表の入力データファイルの行数分のデータ件数が必要です。LOB列構成基表作成時に出力される作成件数を，KFPL00703-Iメッセージを基に確認して，その作成件数とこのメッセージのデータの番号から，列単位LOB入力ファイルのデータ件数が多いか，少ないかを判断してください。LOB列構成基表の入力データファイルのデータ件数と列単位LOB入力ファイル中のLOBデータ件数の対応を確認して，データ件数を一致させてから，再度コマンドを実行してください。
KFPL31016-E
Invalid parameter, line=aa....aa, column=bb...bb, code=cc [dd....dd]　　（Ｒ）
抽象データ型の列に格納する値を生成するコンストラクタ関数への入力パラメタが不正です。(No output for error data)が出力されている場合は，入力データファイルの最終行データのデータ長が不足しています。
aa....aa：行番号
bb....bb：列番号
入力データファイル中のデータの先頭からの位置を示します。したがって，skipdata文で入力対象外とした列やコンストラクタ関数の引数の数を含めた値を表示します。
cc：論理エラー番号
論理エラー番号については，マニュアル「HiRDB Version 7 コマンドリファレンス」を参照してください。
dd....dd：(No output for error data)
(Ｓ)エラー情報ファイルにエラーメッセージを出力し，処理を続行します。
(Ｏ)論理エラー番号を参照し，関数の入力パラメタとして指定した入力データ中の該当データを修正して，再度実行してください。
(No output for error data)が出力されている場合はエラーデータファイルにエラーデータが途中までしか出力されていません。入力データファイルの最終行のデータを修正して再実行すると，エラーデータファイルにエラーデータが出力されます。
KFPL31017-E
Specified LOB file permission denied, line=aa....aa　　（Ｒ）
aa....aa行目のデータ中に指定した，LOB入力ファイルに対するアクセス権限がありません。
aa....aa：行番号
(Ｓ)エラー情報ファイルにエラーメッセージを出力し，処理を続行します。
(Ｏ)HiRDB管理者が読み込みできるように，LOB入力ファイルに対してアクセス権限を付与してください。
KFPL31018-E
PLUGIN function error occurred, line=aa....aa, reason="bb....bb", column="cc....cc" [dd....dd]　　（Ｒ）
抽象データ型の列に対して，プラグイン提供関数を使用して格納する値が不正です。(No output for error data)が出力されている場合は，エラーデータファイル作成用ワークバッファが不足しています。
aa....aa：行番号
bb....bb：プラグイン提供関数が検知したエラーの内容
cc...cc：列名
dd...dd：(No output for error data)
(Ｓ)エラー情報ファイルにエラーメッセージを出力し，処理を続行します。
(Ｏ)エラーメッセージを参照し，入力データファイルの該当するデータを修正して，再度実行してください。
(No output for error data)が出力されている場合はエラーデータファイルにエラーデータが出力されていません。エラーデータファイル作成用ワークバッファサイズに十分な値を指定して再実行すると，エラーデータファイルにエラーデータが出力されます。
KFPL31019-E
Invalid number of element, line=aa....aa, column=bb....bb　　（Ｒ）
line=aa....aa，column=bb....bbの繰返し列に対する要素数の指定に誤りがあります。
aa....aa：行番号
bb....bb：列番号
入力データファイル中のデータの先頭からの位置を示します。したがって，skipdata文で入力対象外とした列やコンストラクタ関数の引数の数を含めた値を表示します。
(Ｓ)エラー情報ファイルにエラーメッセージを出力し，処理を続行します。
(Ｏ)繰返し列の要素数が正しいかどうか調査してください。又は，入力データファイルの列データに誤りがないかどうかを確認してください。要素数が正しくない場合，又は列データに誤りがある場合は，ファイルの内容を修正して，再度コマンドを実行してください。
KFPL31020-E
Invalid enclose character detected, line=aa....aa, offset=bb....bb　　（Ｒ）
aa....aa行目のデータの，先頭からbb....bbバイト目に不正な囲み文字を検出しました。
aa....aa：行番号
bb....bb：不正な囲み文字を検出した位置
(Ｓ)エラー情報ファイルにエラーメッセージを出力し，処理を終了します。
(Ｏ)拡張DAT形式の入力データファイルの場合，囲み文字と同じ値をデータと扱うときには，2個連続で指定してください。
KFPL31090-W/E
Input data too long, line=aa....aa, column=bb....bb [,element=cc....cc]　　（Ｒ）
line=aa....aa, column=bb...bb（elementが出力されている場合は，繰返し列の要素cc...cc）の入力データ長が表定義時の列定義長を超えています。
lengoverオペランド指定がない場合…KFPL31090-W
・データロードの場合
定義長を超えているデータ部分を切り捨てて，データを格納します。
・ファイル分割（分割入力データファイルの作成）の場合
分割入力データファイルにデータを出力します。
lengoverオペランド指定がある場合…KFPL31090-E
・データロードの場合
エラーデータと扱いデータを格納しません。
・ファイル分割の場合
分割入力データファイルにデータを出力しません。
aa....aa：行番号
bb....bb：列番号
cc....cc：要素番号
(Ｓ)エラー情報ファイルにエラーメッセージを出力し，処理を続行します。
(Ｏ)
・lengoverオペランド指定がない場合
メッセージを参照して該当データの定義長データを超えたものを切り捨てて問題ないか確認してください。
・lengoverオペランド指定がある場合
メッセージを参照して定義長を超えた該当データを修正して，再度pdloadを実行してください。
KFPL33000-l
Pdrbal started, table=aa....aa."bb....bb", execmode=cc....cc　　（Ｌ）
表aa....aa."bb....bb"のリバランス処理を開始しました。
aa....aa：認可識別子
bb....bb：表識別子
cc....cc：動作モード
share：共用モード
exclusive：占有モード
(Ｓ)処理を続行します。
KFPL33001-l
Pdrbal terminated, return code=aa　　（Ｅ＋Ｌ）
pdrbalの処理が，リターンコードaaで終了しました。
aa：リターンコード
0：正常終了（すべてのデータをリバランスしました）
4：正常終了（未リバランスデータが残っています）
8：異常終了
(Ｓ)処理を終了します。
(Ｏ)
・リターンコードが4の場合
再度pdrbalを実行してください。
・リターンコードが8の場合
標準出力又はメッセージログファイルに出力されたエラーメッセージを参照して，エラー要因を取り除いてから再度pdrbalを実行してください。
KFPL33002-l
Report file aa....aa assigned　　（Ｌ）
処理結果ファイルaa....aaを作成しました。
aa...aa：処理結果ファイル名
実行結果ファイル名の長さが130文字以上の場合は，実行結果ファイル名の後ろから129文字を出力します。
(Ｓ)処理を続行します。
KFPL33003-l
Activation of dictionary information completed, status=aa....aa　　（Ｅ＋Ｌ）
ディクショナリ情報が有効となりました。
aa...aa：ディクショナリ情報の有効化のタイミング
START：
リバランス開始時
このメッセージ出力以降にエラーが発生した場合，pdrbalの実行状態はリバランス中となります。
END：
リバランス終了時
このメッセージ出力以降にエラーが発生した場合，リバランス処理は終了しているので，pdrbalは再実行する必要はありません。
(Ｓ)処理を続行します。
KFPL33004-l
aa....aa rows bb....bb, table=cc....cc."dd....dd"　　（Ｌ）
表cc....cc."dd....dd"のリバランス処理でaa....aa行処理しました。
aa....aa：行数
bb....bb：
processing：処理しました。
cc....cc：認可識別子
dd....dd：表識別子
(Ｓ)処理を続行します。
KFPL33005-l
Pdrbal stopped at execstop, table=aa....aa."bb....bb"　　（Ｌ）
execstop文の指定によって，表aa....aa."bb....bb"のリバランス処理を停止しました。
aa....aa：認可識別子
bb....bb：表識別子
(Ｓ)処理を終了します。
KFPL33500-E
Unable to specify "aa....aa" in this case　　（Ｅ＋Ｌ）
コマンドラインにaa....aaを指定した場合は，制御情報ファイルに次の制御文は指定できません。
aa....aaが-k shareの場合：
・index文
・idxwork文
・sort文
aa....aaが-k exclusiveの場合：
・option文（check_itvオペランド）
aa....aa：オプション名（-k share又は-k exclusive）
(Ｓ)処理を終了します。
(Ｏ)
aa....aaが-k shareの場合：
コマンドライン又は制御情報ファイルを指定し直して再度実行してください。
aa....aaが-k exclusiveの場合：
check_itvオペランドを削除するか，又はコマンドラインを-k shareに変更して再度実行してください。
KFPL33501-E
Unable to execute pdrbal due to aa....aa table　　（Ｅ＋Ｌ）
表aa....aaに対してpdrbalは実行できません。
aa....aa：表の種別
non base：
実表以外の表
non rebalance：
リバランス表以外の表
ADT：
次の抽象データ型を定義している表
・ユーザ定義型
・プラグインが提供する抽象データ型で，次のどれかに該当する場合
・スーパタイプがある
・属性に抽象データ型がある
・属性がBLOB型ではあるが，アンロード機能がない
(Ｓ)処理を終了します。
(Ｏ)pdrbalの実行を中止してください。
KFPL33502-E
Unable to execute pdrbal without aa....aa privilege　　（Ｅ＋Ｌ）
処理対象の表に対するアクセス権限aa....aaがありません。
aa....aa：アクセス権限の種別
select：SELECT権限
insert：INSERT権限
delete：DELETE権限
(Ｓ)処理を終了します。
(Ｏ)表の所有者が実行者に対して，処理対象の表のアクセス権限を与え，再度pdrbalを実行してください。
KFPL33503-E
Unable to execute pdrbal command without addition of RDAREA, table=aa....aa."bb....bb"　　（Ｅ＋Ｌ）
RDエリアを追加していないので，pdrbalは実行できません。
aa....aa：認可識別子
bb....bb：表識別子
(Ｓ)処理を終了します。
(Ｏ)リバランスをする表の名称が誤っていないか確認してください。誤っていない場合は，リバランス表にRDエリアを追加してから，再度pdrbalを実行してください。
KFPL33504-E
Table aa....aa during execution of pdrbal, table_name=bb....bb."cc....cc"　　（Ｅ＋Ｌ）
pdrbal実行中に，リバランス表の削除，又は表定義が変更されました。
aa....aa：理由コード
dropped：リバランス表が削除されました。
changed：リバランス表の定義が変更（又は削除，作成）されました。
bb....bb：認可識別子
cc....cc：表識別子
(Ｓ)処理を終了します。
(Ｏ)理由コードを基に，対象となる表の定義内容を確認してください。
KFPL33505-E
Activation of dictionary information failed　　（Ｅ＋Ｌ）
ディクショナリ情報の有効化に失敗しました。
(Ｓ)処理を終了します。
(Ｏ)このメッセージの前に出力されているエラーメッセージを基にエラー要因を取り除いて，再度pdrbalを実行してください。
KFPL33506-E
Unable to execute pdrbal command because of NONDIV_IDX defined, index_name=aa....aa."bb....bb"　　（Ｅ＋Ｌ）
リバランス表に非分割キーインデクスが定義されているため，pdrbalを実行できません。
aa....aa：認可識別子
bb....bb：インデクス識別子
(Ｓ)処理を終了します。
(Ｏ)非分割キーインデクスを削除してから，再度pdrbalを実行してください。
KFPL33507-E
Unable to recompile routine, type=aa....aa, name="bb....bb"."cc....cc", error_sql_no=dd....dd, err_sql=ee....ee　　（Ｅ＋Ｌ）
ルーチンのリコンパイルに失敗しました。
aa....aa：ルーチン種別
PROCEDURE：手続き
FUNCTION：関数
bb....bb：スキーマ名
cc....cc：ルーチン識別子
dd....dd：ルーチン中のエラーとなったSQL手続き文を示す番号
SQL手続き文を示す番号については，マニュアル「HiRDB Version 7 SQLリファレンス」のGET DIAGNOSTICSのERR_SQL_NOを参照してください。
ee....ee：ルーチン中のエラーとなったSQL手続き文の種別
SQL手続き文の種別については，マニュアル「HiRDB Version 7 SQLリファレンス」のGET DIAGNOSTICSのERR_SQLを参照してください。
(Ｓ)処理を終了します。
(Ｏ)ERR_SQL_NO，ERR_SQL，及びこのメッセージの直前に出力されたメッセージに従って対処し，ALTER PROCEDURE又はALTER ROUTINEで手続き，関数をリコンパイルしてください（リバランスユティリティを再実行しても，手続き，関数のリコンパイルはされません）。
このメッセージの前に出力されているKFPL33003-IメッセージのSTATUSがSTARTの場合，上記の対策を実施した後にリバランスユティリティを再実行してください。STATUSがENDの場合は再実行する必要はありません（再実行するとエラー終了します）。
KFPL33508-E
Unable to execute pdrbal using replicated RDAREA, table=aa....aa. "bb....bb"　　（Ｌ）
対象となる表にレプリカRDエリアが定義されているため，pdrbalは実行できません。
aa....aa：認可識別子
bb....bb：表識別子
(Ｓ)処理を終了します。
(Ｏ)pdrbalを実行する場合は，対象となる表に定義されているすべてのレプリカRDエリアを削除してください。
KFPL90001-I
Process aa....aa started. yyyy/mm/dd,hh:mm:ss　　（Ｓ）
aa....aa処理を開始します。
aa....aa：処理種別
rorg：再編成
yyyy/mm/dd：実行開始年月日
hh:mm:ss：実行開始時間
(Ｓ)処理を続行します。
KFPL90002-I
Process aa....aa ended. return code=bb,yyyy/mm/dd,hh:mm:ss　　（Ｓ）
aa....aa処理を終了します。
aa....aa：処理種別
rorg：再編成
bb：リターンコード
０：正常終了。すべての表の再編成処理が終了しました。
４：正常終了。表の再編成途中です。
８：エラー終了。バックアップから回復しました。
１２：エラー終了。バックアップからの回復は失敗しました。
yyyy/mm/dd：実行終了年月日
hh:mm:ss：実行終了時間
(Ｓ)処理を終了します。
(Ｏ)
リターンコードが4の場合：
ワーニングメッセージKFPL91101-Wが出力されているとき，pdrorgの-mオプションで指定した時間が短いため，再編成処理をしていません。指定値を大きくして再実行してください。
リターンコードが8，12の場合：
エラーの詳細はKFPL90003-Eで示す実行情報ファイルの内容を確認してください。エラーの原因を取り除いた後，出力されたKFPL90021-I～KFPL90028-Iの経過メッセージから実行状態を考慮して，対処してください。
KFPL90003-E
Eliminationg the cause of the error, refer to executed information file="aa....aa"　　（Ｅ）
実行情報ファイルに示すエラーがあります。
aa....aa：実行情報ファイル名
(Ｓ)処理を終了します。
(Ｏ)実行情報ファイルの内容から，エラーの詳細を確認して，エラーの原因を取り除いてください。
KFPL90010-I
Process aa....aa bb....bb/cc....cc ended.table name=dd....dd　　（Ｓ）
cc....cc中，bb....bb番目のaa....aaの処理を終了しました。
aa....aa：処理種別
rorg：再編成
bb....bb：終了した処理数
cc....cc：全処理数
dd....dd：処理した表の名称
(Ｓ)処理を続行します。
KFPL90021-I
DB hold step ended　　（Ｓ）
データベースの閉塞処理を終了します。
(Ｓ)処理を続行します。
KFPL90022-I
Before backup step ended　　（Ｓ）
処理前のバックアップ処理を終了します。
(Ｓ)処理を続行します。
KFPL90023-I
aa....aa step started　　（Ｓ）
aa....aa処理を開始します。
aa....aa：処理種別
Reorganize：再編成
(Ｓ)処理を続行します。
KFPL90024-I
aa....aa step ended　　（Ｓ）
aa....aa処理を終了します。
aa....aa：処理種別
Reorganize：再編成
(Ｓ)処理を続行します。
KFPL90025-I
After backup step ended　　（Ｓ）
処理後のバックアップ処理を終了します。
(Ｓ)処理を続行します。
KFPL90026-I
DB release step ended　　（Ｓ）
データベースの閉塞解除処理を終了します。
(Ｓ)処理を続行します。
KFPL90027-I
DB stop process started　　（Ｓ）
エラー回復処理のため，データベースを停止します。
(Ｓ)処理を続行します。
KFPL90028-I
Recover step started on aa....aa error　　（Ｓ）
バックアップファイルからのデータベースの回復処理を開始します。
aa....aa：処理種別
rorg：再編成
(Ｓ)処理を続行します。
KFPL90029-I
Recover step ended on aa....aa error　　（Ｓ）
バックアップファイルからのデータベースの回復処理を終了します。
aa....aa：処理種別
rorg：再編成
(Ｓ)処理を続行します。
KFPL90030-I
DB started process ended　　（Ｓ）
データベースの開始処理を完了しました。
(Ｓ)処理を続行します。
KFPL90101-I
aa....aa　　（Ｒ）
HiRDBのコマンド実行時のコマンドラインを出力します。
aa....aa：pdrorg実行時のコマンドライン
(Ｓ)処理を続行します。
KFPL90102-I
aa....aa　　（Ｒ）
pdrorg実行時の制御文１行分を出力します。
aa....aa：pdrorg実行時の制御文
(Ｓ)処理を続行します。
KFPL91000-I
Usage:aa....aa [-m time] -k func_name　　（Ｅ）
コマンドaa....aaの指定形式を表示します。
aa....aa：実行コマンド名称
(Ｓ)処理を終了します。
(Ｏ)コマンドラインの指定の誤りを修正し，再度実行してください。
KFPL91001-E
Mandatory specification missing in command line　　（Ｅ）
コマンドラインに必要なオプションが指定されていません。
(Ｓ)処理を終了します。
(Ｏ)コマンドに必要なオプションを指定して，再度実行してください。
KFPL91002-E
Invalid aa....aa option　　（Ｅ）
オプションaa....aaは誤りです。
aa....aa：不正なオプション
(Ｓ)処理を終了します。
(Ｏ)正しいオプションを指定して，再度実行してください。
KFPL91003-E
Invalid value of aa....aa option　　（Ｅ）
オプションaa....aaの指定値は誤りです。
aa....aa：オプション
(Ｓ)処理を終了します。
(Ｏ)正しいオプションを指定して，再度実行してください。
KFPL91004-E
Invalid format exists in command line　　（Ｅ）
実行したユティリティのコマンドラインの形式が誤っています。
(Ｓ)処理を終了します。
(Ｏ)コマンドラインを修正して，再度実行してください。
KFPL91100-E
System call error, func=aa....aa, errno=bb....bb　　（Ｅ）
HiRDBシステム関数の処理中にエラーが発生しました。
aa....aa：HiRDBシステム関数の名称
bb....bb：エラーコード
(Ｓ)処理を終了します。
(Ｏ)このメッセージの前後に出力されるエラーメッセージと，このメッセージのエラーコードを基にエラー要因を取り除いてください。
KFPL91101-W
Unable to execute aa....aa due to little value of -m option　　（Ｅ）
-mオプションの指定値が小さいため，aa....aaの処理を実行できません。
aa....aa：処理種別
rorg：再編成
(Ｓ)処理を終了します。
(Ｏ)-mオプションに適切な値を設定して，再度実行してください。
KFPL91102-E
aa....aa process already executed　　（Ｅ）
コマンドaa....aaの処理は既に実行中です。
aa....aa：実行コマンド名
(Ｓ)処理を終了します。
(Ｏ)必要であれば，実行中のコマンドの終了を待って再度実行してください。
KFPL91103-E
Insufficient memory on PROCESS, size=aa....aa, part=bb....bb, code=cc....cc　　（Ｅ）
メモリ不足が発生しました。
aa....aa：不足したメモリサイズ（単位：バイト）
bb....bb：パート番号
cc....cc：パートコード
(Ｓ)処理を終了します。
(Ｏ)メモリを大量に占有するほかのプログラムの終了を待って，再度実行してください。
KFPL91104-E
Unable to aa....aa without bb....bb privilege　　（Ｅ）
処理aa....aaに対するbb....bbのアクセス権限がありません。
aa....aa：実行したコマンドの名称
bb....bb：アクセス権限
DBA：DBA権限
(Ｓ)処理を終了します。
(Ｏ)処理に必要なアクセス権限を取得してから，再度実行してください。
KFPL91105-E
aa....aa Invalid　　（Ｅ）
環境変数で指定している認可識別子又はパスワードが不正です。又は，入力応答メッセージで入力したパスワードが不正です。
aa....aa：エラーが発生した種別
Auth_id：認可識別子
Password：パスワード
(Ｓ)処理を終了します。
(Ｏ)エラーが発生した種別によって，次の対策をしてください。
＜Auth_idの場合＞
環境変数PDUSERを修正して，再度コマンドを実行してください。
＜Passwordの場合＞
環境変数PDUSERを修正して，再度コマンドを実行してください。又は，入力応答メッセージに対してパスワードを入力した場合は，再度コマンドを実行して，パスワードの入力誤りがないようにしてください。
Windows NTの場合，コマンドプロンプト上で認可識別子やパスワードを指定する文字列を，「’」で囲んでいないか確認してください。
正しい指定例：PDUSER="root"/"root"
KFPL91106-E
aa....aa error occured, file=bb....bb　　（Ｅ）
ファイルのアクセスエラーが発生しました。
aa....aa：エラーの発生した処理
Open：オープン処理
Read：読み込み処理
Write：書き込み処理
Delete：削除処理
Close：クローズ処理
Lock：ロック処理
bb....bb：ファイル名称（パス名の最後尾）
(Ｓ)処理を終了します。
(Ｏ)このメッセージの後に出力されるメッセージを基にエラー要因を取り除いて，再度実行してください。
KFPL91107-E
System call error, func=aa....aa, errno=bb....bb　　（Ｅ）
ファイルのアクセスエラーが発生しました。
aa....aa：エラーの発生したシステム関数の名称
bb....bb：システム関数が返却したエラー番号（errno）
(Ｓ)処理を終了します。ただし，Closeエラーの場合，処理を続行することがあります。
(Ｏ)errno.h及び該当する関数が記載されているリファレンスマニュアルのエラー番号（errno）を参照してエラー要因を取り除いて，再度実行してください。


KFPMメッセージ

KFPM20002-E
Invalid define information in pdmibtgt　　（Ｅ＋Ｓ）
MIBコマンド（pdmibcmd）のMIB環境定義ファイルpdmibtgtの設定内容に誤りがあります。
(Ｓ)処理を終了します。
[対策]HiRDBインストールディレクトリ/sample下にあるpdmibtgtファイルの定義情報に誤りがないか確認して，修正してください。その後，再度実行してください。
KFPM20003-E
System call error,func="aa....aa",errno=bbbb　　（Ｅ＋Ｓ）
システム関数aa....aaでエラーが発生しました。
aa....aa：システム関数名
bbbb：エラーコード
(Ｓ)処理を終了します。
[対策]「システム関連エラーの詳細コード」を参照して，エラーの原因を取り除いた後，再度コマンドを実行してください。エラーの原因が分からない場合は，$PDDIR/spool及び$PDDIR/tmp下のファイルを退避して，保守員に連絡してください。
KFPM20004-E
Command error, command=aa....aa, code=bbb　　（Ｅ＋Ｓ）
pdmibcmd内で実行するHiRDBのコマンドaa...aaが，リターンコードbbbで終了しました。
aa....aa：HiRDBのコマンド名
bbb：リターンコード
(Ｓ)処理を終了します。
[対策]syslogfileのこのメッセージより前に出力されたメッセージを参照して障害を取り除いた後，再度実行してください。
KFPM20005-E
Insufficient memory for PROCESS, size=aa....aa　　（Ｅ＋Ｓ）
プロセス固有領域のメモリ不足が発生しました。
aa....aa：確保しようとした領域サイズ
(Ｓ)処理を終了します。
[対策]プロセス固有メモリを増やしてから再度実行してください。
KFPM20006-E
System function error occurred,func="aa....aa",errno=bb....bb　　（Ｅ＋Ｓ）
HiRDBの関数でエラーが発生しました。
aa....aa：HiRDB関数名称
bb....bb：エラーコード
(Ｓ)処理を終了します。
[対策]syslogfileから，このメッセージの前後に出力されているメッセージがあるか確認してください。メッセージがある場合は，そのメッセージの処置に従ってください。メッセージがない場合は，「システム関連エラーの詳細コード」を参照して，エラーの原因を取り除いた後，再度コマンドを実行してください。エラーの原因が分からない場合は，$PDDIR/spool及び$PDDIR/tmp下のファイルを退避して，保守員に連絡してください。
KFPM20007-E
Make Directry error occurred, directory=aa....aa, errno=bbbb　　（Ｅ＋Ｓ）
作業用ディレクトリpdmibworkの作成に失敗しました。
aa....aa：作成しようとしたpdmibworkディレクトリパス名
bbbb：エラーコード
(Ｓ)処理を終了します。
[対策]「システム関連エラーの詳細コード」を参照して，エラーの原因を取り除いた後，再度コマンドを実行してください。
KFPM20008-E
MIB Data format error occurred　　（Ｅ＋Ｓ）
MIB情報の作成中にエラーが発生しました。
(Ｓ)処理を終了します。
[対策]syslogfileのこのメッセージより前に出力されたメッセージを参照して障害を取り除いた後，再度実行してください。原因が分からない場合は，$PDDIR/spool及び$PDDIR/tmp下のファイルを退避して，保守員に連絡してください。
KFPM20009-E
File I/O error occurred, func=aa....aa, file=bb....bb, errno=cc....cc　　（Ｅ＋Ｓ）
MIB作業用ファイルに対する入出力中にエラーが発生しました。
aa....aa：エラーが発生したシステム関数名
bb....bb：MIB作業用ファイル名
cc....cc：エラーコード
(Ｓ)処理を終了します。
[対策]「システム関連エラーの詳細コード」を参照して，エラーの原因を取り除いた後，再度コマンドを実行してください。
KFPM20010-E
Invalid command line,command="pdmibcmd"　　（Ｅ＋Ｓ）
MIBコマンド（pdmibcmd）のコマンド引数，オプション，又はオプションの値に誤りがあります。
(Ｓ)処理を終了します。
[対策]コマンドラインを修正して，再度実行してください。
KFPM20011-E
Invalid define information in pdmibenv, name="aa....aa",system="bbbb"　　（Ｅ＋Ｓ）
HiRDBシステムbbbbのpdmibenvファイルに定義した，aa....aaの定義内容に誤りがあります。又は，定義がされていません。
aa....aa：解析できなかった定義名
bbbb：解析できなかった監視対象HiRDBシステム名
(Ｓ)処理を終了します。
[対策]監視対象HiRDBシステムbbbbの運用ディレクトリ$PDDIR/conf下にあるpdmibenvファイルの定義情報のうち，aa....aaに関する値を正しく定義してください。その後，再度実行してください。
KFPM20013-E
System call error,func="putenv"　　（Ｅ＋Ｓ）
MIBコマンド（pdmibcmd）が環境変数を設定しようとしましたが，失敗しました。
(Ｓ)処理を終了します。
[対策]保守員に連絡してください。
KFPM20014-E
Not Active server　　（Ｅ＋Ｓ）
稼働中のサーバがないため，データが取得できませんでした。
(Ｓ)処理を終了します。
[対策]HiRDBのサーバを開始してから，再度コマンドを実行してください。
KFPM20015-E
Make MIB table error occurred, table kind=aaa　　（Ｅ＋Ｓ）
MIBコマンド（pdmibcmd）のテーブル作成に失敗しました。
aaa：テーブル種別
(Ｓ)処理を終了します。
[対策]$PDDIR/conf下にあるpdmibenvファイルの定義内容，及びHiRDBシステムの状態を確認してから，再度コマンドを実行してください。MIBパフォーマンス情報監視機能の運用については，マニュアル「HiRDB Version 7 システム運用ガイド」を参照してください。
KFPM20016-E
Failed MIB data exchanged DAT to CSV　　（Ｅ＋Ｓ）
MIBコマンド（pdmibcmd）のDAT形式からCSV形式への変換で，MIB情報の作成中にエラーが発生しました。
(Ｓ)処理を終了します。
[対策]$PDDIR/spool及び$PDDIR/tmp下のファイルを退避して，保守員に連絡してください。
KFPM20017-W
DATADICTIONARY search failed, RDAREA="aa....aa", SQLCODE=bb....bb　　（Ｅ＋Ｓ）
RDエリアaa....aaに対するディクショナリ検索が，SQLコードbb....bbで失敗しました。そのため，RDエリアaa....aaに対するMIB情報は取得できません。
aa....aa：RDエリア名
bb....bb：SQLコード
(Ｓ)処理を続行します（該当するRDエリアの情報を表示しません）。
[対策]データディクショナリRDエリアの閉塞状態，又は$PDDIR/conf下にあるpdmibenvファイルの定義情報とHiRDBが使用している環境定義が一致しているかどうかを確認してください。詳細は，表示されているSQLCODEの値を参照してください。誤りがある場合は訂正して，再度実行してください。


KFPNメッセージ

KFPN00001-E
Cannot allocate bb....bb byte-insufficient memory aaaaaaa　　（Ｅ＋Ｌ）
メモリ不足が発生しました。
aaaaaaa：領域種別
PROCESS：プロセス固有領域
bb....bb：確保しようとした領域サイズ（単位：バイト）
(Ｓ)処理を終了します。
[対策]大量にメモリを使用するプロセスがほかにないか確認してください。
＜大量にメモリを使用するプロセスがある場合＞
該当するプロセスの終了を待って，再度コマンドを実行してください。
＜大量にメモリを使用するプロセスがない場合＞
次のどれかの方法で，使用できるメモリに余裕を持たせてください。
・同時実行しているプロセスの数を減らしてください。
・スワップ領域を増やしてください。
・実メモリを増設してください。
KFPN00002-E
Internal error, func=aa....aa　　（Ｌ）
内部矛盾を検知しました。
aa....aa：エラーが発生したモジュール名
(Ｓ)処理を終了します。
[対策]保守員に連絡してください。
KFPN00003-E
System call error, func=aa....aa, errno=bb....bb　　（Ｅ＋Ｌ）
システムコール（関数）でエラーが発生しました。
aa....aa：システムコール（関数）名称
bb....bb：errnoにセットされたエラー番号
(Ｓ)処理を終了します。
[対策]エラー番号（errno：エラー状態を表す外部整数変数）を調査し，errno.h及びユーザが使用するOSのマニュアルを参照して，エラーの原因を取り除き，再度コマンドを実行してください。
KFPN00010-I
Processing completed, table="aa....aa"　　（Ｅ＋Ｌ）
対象表に関する最適化情報のディクショナリ表への格納処理が終了しました。
aa....aa：最適化情報収集対象である表識別子
(Ｓ)処理を続行します。
KFPN00011-I
Pdgetcst terminated, return code=aa....aa　　（Ｅ＋Ｌ）
最適化情報収集ユティリティ(pdgetcst)の実行が終了しました。
aa....aa：リターンコード
(Ｓ)処理を終了します。
KFPN00012-I
Pdgetcst started　　（Ｅ＋Ｌ）
最適化情報収集ユティリティ(pdgetcst)の実行を開始しました。
(Ｓ)処理を続行します。
KFPN00100-E
Usage: pdgetcst [-u user_id] [-a auth_id] [-p password] -t {table_name|ALL} [-l result_list_file_name] [[-d] | [-c {lvl1|lvl2}] [-G generation_number] | [[-v space_level] -s parameter_file_name]]　　（Ｅ）
最適化情報収集ユティリティ(pdgetcst)の使用方法を示します。
(Ｓ)処理を終了します。
(Ｏ)最適化情報収集ユティリティ(pdgetcst)のパラメタの入力が誤っていないか確認してください。
KFPN00101-E
Identifier "aa....aa" exceeds 30 characters　　（Ｅ）
コマンドラインに指定された，認可識別子，パスワード，表識別子のどれかが30文字を超えています。
aa....aa：30文字を超えたデータを30文字に切捨てした文字列
(Ｓ)処理を終了します。
(Ｏ)30文字を超えたデータを修正し，再度実行してください。
KFPN00102-E
Invalid file name　　（Ｅ）
-sオプションに指定されたファイル名称が不正です。次に示す原因が考えられます。
・ファイル名称が絶対パス名で指定されていません。
・指定された名称が通常ファイルではありません。
(Ｓ)処理を終了します。
(Ｏ)通常ファイルでないファイルが指定されていないか，また，相対パス名で指定されていないかを確認し，正しいファイル名を指定して，再度実行してください。
KFPN00103-E
Invalid aa....aa　　（Ｅ）
環境変数（PDUSER）で指定された認可識別子又はパスワードが誤っています。
aa....aa：エラー要因の種別
"user_id"：認可識別子
"password"：パスワード
(Ｓ)処理を終了します。
(Ｏ)環境変数（PDUSER）の設定値を修正して，再度実行してください。又は，-uオプション，若しくは-pオプションを指定して，再度実行してください。
Windows NTの場合，-uオプションを省略する場合は，コマンドプロンプト上で認可識別子やパスワードを指定する文字列を，「’」で囲んでいないか確認してください。
正しい指定例：PDUSER="root"/"root"
注　ただし，クライアント環境定義(hirdb.ini)の中では，「‘」で囲むのが正しい指定方法です。
KFPN00151-E
Error no：cc....cc-cannot aa....aa file bb....bb　　（Ｌ）
ファイルのアクセス処理でエラーが発生しました。
aa....aa：エラーが発生した処理コード
close：ファイルクローズ処理
open：ファイルオープン処理
read：読み込み処理
write：書き込み処理
bb....bb：ファイル名称
ファイル名称が126バイト以下の場合，ファイル名称全体を表示し，126バイトを超える場合は先頭126バイトに2バイトのピリオド（..）を付けて出力します。
cc....cc：システムコールが返すerrnoの値
(Ｓ)処理を終了します。
[対策]errnoを参照し，エラーとなる要因を取り除き再度実行してください。
KFPN00201-E
Invalid index name "aa....aa"　　（Ｌ）
指定されたインデクス名称が不正です。次に示す条件のどれかに該当します。
・指定されたインデクス名称は，定義されていません。
・指定されたインデクス名称は，ほかの表に対して定義されています。
・指定されたインデクスは，B-treeインデクスではありません。
aa....aa：指定されたインデクス名称
(Ｓ)処理を終了します。
(Ｏ)パラメタファイルに指定したインデクス名称を変更し，再度実行してください。
KFPN00202-E
Invalid table name "aa....aa"　　（Ｌ）
指定した表名が不正です。次に示す条件のどれかに該当します。
・指定した表はビュー表です。
・指定した表はディクショナリ表です。
・指定した表がありません。
・指定した表は表別名で定義された表です。
・指定した表はリバランス表です。
・指定した表は外部表です。
aa....aa：指定された表名
(Ｓ)処理を終了します。
[対策]指定した名称を確認し，再度実行してください。
KFPN00203-E
Inconsistent definition　　（Ｌ）
ユティリティの実行中に表，又はインデクスの定義が変更されました。又は，ディクショナリが破壊されています。
(Ｓ)処理を終了します。
[対策]表又はインデクス定義の変更処理が同時実行されたかどうか確認してください。
〈変更処理を実行中の場合〉
変更処理の終了を待って，再度実行してください。
〈変更処理が実行中でない場合〉
再度実行してください。なお，再度実行した後，このメッセージが出力されたときは，バックアップからデータベースを回復し，再度実行してください。これらの対策をしても，同じメッセージが出力される場合，保守員に連絡してください。
KFPN00204-E
Invalid RDAREA status, RDAREA="aa....aa"　　（Ｌ）
次のどちらかの理由でRDエリアが解析できません。
〈RDエリア属性がINITIALの場合〉
RDエリアが閉塞なしオープン状態，又は参照可能な閉塞状態でかつオープン状態になっていません。
〈RDエリア属性がDEFER又はSCHEDULEの場合〉
RDエリアが閉塞なしオープン状態，閉塞なしクローズ状態，参照可能な閉塞状態でかつオープン状態，参照可能な閉塞状態でかつクローズ状態のどの状態にもなっていません。
aa....aa：RDエリア名
(Ｓ)処理を終了します。
[対策]RDエリアの状態を確認し，再度コマンドを実行してください。
KFPN00206-E
Unable to operate table during pdgetcst executing　　（Ｌ）
データ更新（INSERT文，DELETE文，UPDATE文，PURGE TABLE文，LOCK文など）を目的とするUAP，又はユティリティの実行中の表に対して，最適化情報収集ユティリティ(pdgetcst)を実行しようとしました。
(Ｓ)処理を終了します。
(Ｏ)対象となる表に対して，更新目的でアクセスするUAP又はユティリティがないか確認してください。pdlsコマンドでトランザクションや排他の状態を参照すれば，該当するUAP又はユティリティの有無を確認できます。
〈該当するUAP又はユティリティがある場合〉
UAP又はユティリティの終了を待って，再度実行してください。
〈該当するUAP又はユティリティがない場合〉
該当するUAP又はユティリティのトランザクションがない状態で，排他だけが残っている場合は，保守員に連絡してください。
KFPN00207-W
Optimize information incompleted　　（Ｌ）
最適化情報収集ユティリティ(pdgetcst)実行中に，対象となる表に対して更新（INSERT文，DELETE文，UPDATE文，PURGE TABLE文など）がされたため，格納する最適化情報が実際の表の内容と異なります。
(Ｓ)処理を続行します。
(Ｏ)正確な最適化情報を取得したい場合は，表を更新するUAPが終了した後，再度実行してください。
KFPN00208-E
Invalid column name "aa....aa"　　（Ｌ）
指定された列名が不正です。次に示す条件のどれかに該当します。
・指定された列名が定義されていません。
・指定された列がBLOB型です。
・指定された列が抽象データ型です。
aa....aa：指定された列名
(Ｓ)処理を終了します。
[対策]最適化情報パラメタファイルに指定した列名称を変更し，再度実行してください。
KFPN00209-E
More than 30 characters in identifier "aa....aa"　　（Ｌ）
最適化情報パラメタファイルで指定した名称aa....aaが30バイトを超えています。
aa....aa：指定値（インデクス識別子，列名称）
30バイトを超える指定値のとき，先頭から30バイトまでを出力します。
(Ｓ)最適化情報パラメタファイル解析後，処理を終了します。
[対策]このメッセージの直前に出力されているKFPN00300-Eメッセージが示す行番号の指定値を修正し，再度実行してください。
KFPN00210-E
Already specified in parameter file, line=aa....aa　　（Ｌ）
一つのセクション内で，aa....aa行目の項目は既に指定されています。
aa....aa：行番号
(Ｓ)最適化情報パラメタファイル解析後，処理を終了します。
[対策]一つのセクション内で，この行の項目を二重に指定しないように修正し，再度実行してください。
KFPN00211-E
Invalid parameter, line=aa....aa　　（Ｌ）
aa....aa行目の項目の指定値に誤りがあります。次の要因が考えられます。
・項目の指定できる範囲外です。
・指定値が必すである項目の指定値がありません。
・数値の指定できる最大けた数を超えています。
aa....aa：行番号
(Ｓ)最適化情報パラメタファイル解析後，処理を終了します。
[対策]指定値を修正し，再度実行してください。
KFPN00212-E
Specified keyword before "INDEX" or "COLUMN" keyword, line=aa....aa　　（Ｌ）
aa....aa行目の項目は，INDEX又はCOLUMN指定よりも先に指定しています。
aa....aa：行番号
(Ｓ)最適化情報パラメタファイル解析後，処理を終了します。
[対策]
〈aa....aaで示す行番号の項目が，インデクスの最適化情報の場合〉
INDEX指定の後に指定するように修正し，再度実行してください。
〈aa....aaで示す行番号の項目が，カラムの最適化情報の場合〉
COLUMN指定の後に指定するように修正し，再度実行してください。
KFPN00214-E
aa....aa not supported, index name "bb....bb"　　（Ｌ）
aa....aaは最適化情報収集ユティリティでサポートされていないため，bb....bbの最適化情報の収集処理をスキップしました。
aa....aa：
Multi-value column：繰返し列
bb....bb：インデクス名
(Ｓ)処理を続行します。
KFPN00215-E
Table not found, schema="aa....aa"　　（Ｌ）
aa....aa内には，最適化情報の取得対象となる表はありません。
aa....aa：スキーマ名
(Ｓ)処理を終了します。
(Ｏ)最適化情報の取得対象となる表がaa....aaにあるか確認してください。ない場合は，最適化情報の取得対象となる表があるスキーマ名を，-aオプションに指定してください。
KFPN00216-E
Invalid aa option　　（Ｅ＋Ｌ）
aaオプションの指定に次のどちらかの誤りがあります。
・aaオプションの指定値に誤りがあります。
・aaが-qの場合は，HiRDB Staticizer Optionが利用できない環境で-qオプションを指定しています。
aa：オプション名
(Ｓ)処理を終了します。
(Ｏ)
・aaオプションの指定値に誤りがある場合
オプションの指定値を修正して，再度実行してください。
・aaが-qの場合
-qオプションの指定を削除して，再度実行してください。又は，HiRDB Staticizer Optionを利用できる環境で-qオプションを指定して，再度実行してください。
KFPN00217-E
Current RDAREA "aa....aa" analyze　　（Ｅ＋Ｌ）
指定した世代にはレプリカRDエリアがないため，RDエリアaa....aaをカレントRDエリアとしてユティリティの解析対象にします。
aa....aa：RDエリア名
(Ｓ)処理を続行します。
KFPN00300-E
Syntax error in parameter file, line=aa....aa　　（Ｌ）
最適化情報パラメタファイルの記述中に構文エラーがあります。次に示す原因が主に考えられます。
・項目名を1バイト目から記述していません。
・1行に複数の項目や値を記述しています。
・1行が81バイト以上です。
aa....aa：構文エラーがある行番号
(Ｓ)最適化情報パラメタファイル解析後，処理を終了します。
[対策]最適化情報パラメタファイルの記述を修正して，再度実行してください。
KFPN00301-E
Data conversion error, column type=aa....aa, line=bb....bb　　（Ｌ）
最適化情報パラメタファイルに記述された値を，aa....aaの型に変換できませんでした。次に示す原因が考えられます。
・数値を指定するところに文字を指定しています。
・最適化情報パラメタファイルで指定した列の型に，変換不可の値を指定しています。
・指定した値がオーバフローしています。
aa....aa：変換先の列型
bb....bb：変換エラーが発生した行番号
(Ｓ)最適化情報パラメタファイルを解析後，処理を終了します。
[対策]最適化情報パラメタファイル中のデータ変換不可のデータを修正して，再度実行してください。
KFPN00303-E
RDAREA not found, RDAREA id=aa....aa　　（Ｌ）
処理対象のRDエリアがありません。次の要因が考えられます。
・ユティリティ実行中に処理対象のRDエリアを削除した。
aa....aa：RDエリアID
(Ｓ)処理を終了します。
(Ｏ)ユティリティ実行中に処理対象RDエリアを削除している場合は，ユティリティを実行できる環境に再構築して，再度実行してください。処理対象RDエリアを削除していない場合は，保守員に連絡してください。
KFPN00400-E
RPC(system) error, func=aa....aa code=bb....bb　　（Ｅ＋Ｌ）
RPC関連エラー，又はシステム関連エラーが発生しました。
aa....aa：エラーの発生した関数名称
bb....bb：エラー詳細コード
(Ｓ)処理を終了します。
[対策]「エラー詳細コード一覧」を参照し，エラーとなる要因を取り除き再度実行してください。詳細コード参照しても，対処できないエラーが発生している場合，保守員に連絡してください。
KFPN00401-E
Error occurred on BES(SDS), server=aa....aa　　（Ｌ）
HiRDB/シングルサーバ，又はHiRDB/パラレルサーバのバックエンドサーバで，処理中にエラーが発生しました。
aa....aa：エラーが発生したサーバ名称
(Ｓ)処理を終了します。
[対策]標準エラー出力，又は標準出力に出力されるメッセージを参考にして，エラーとなる要因を取り除き再度実行してください。
KFPN00402-E
Pdgetcst must be executed at unit defined as manager　　（Ｅ）
最適化情報収集ユティリティ(pdgetcst)はシステムマネジャ（MGR）が定義されているユニットから実行してください。
(Ｓ)処理を終了します。
[対策]システムマネジャ（MGR）が定義されているユニットにリモートログインして，再度コマンドを実行してください。
KFPN00403-E
Directory access error　　（Ｌ）
データディレクトリに対するアクセス中に，エラーが発生しました。データディレクトリが破壊されている可能性があります。
(Ｓ)処理を終了します。
[対策]バックアップを基に，データベースを回復して，再度実行してください。なお，再度このメッセージが出力される場合，保守員に連絡してください。
KFPN00404-E
Insufficient memory in message buffer pool due to concurrent execution of "pdgetcst"　　（Ｅ＋Ｌ）
pdgetcstを同時実行したため，ユティリティサーバ用のメッセージ格納バッファプールのメモリが，一時的に不足しました。なお，該当するエラーの発生に伴って，KFPS00854-Wが出力されることがあります。しかし，この場合は，サーバ障害ではありません。
(Ｓ)処理を終了します。
(Ｏ)現在実行中のpdgetcstの実行完了後，再度実行してください。
KFPN00405-E
Unable to send message from aa....aa to bb....bb　　（Ｌ）
通信エラーが発生したため，ホストaa....aaからホストbb....bbへデータを送ることができません。
aa....aa：送信元ホスト名※
bb....bb：送信先ホスト名※
注※　系切り替え機能を使用している場合は，現用系のホスト名となります。
(Ｓ)処理を終了します。
(Ｏ)このメッセージの前に出力されたKFPN00400-Eメッセージの処置に従ってください。ただし，物理的な通信エラーが発生していない場合は，システム定義でホスト間の関係に矛盾があると考えられます。このため，エラーが発生したホスト間の定義を見直して再度実行してください。
KFPN00406-E
Current RDAREA changed　　（Ｅ）
ユティリティ実行中にカレントRDエリアを変更しました。
(Ｓ)処理を終了します。
(Ｏ)再度実行してください。このとき，ユティリティ実行中にカレントRDエリアを変更しないでください。
KFPN00450-I
Deleted optimize information for table "aa....aa"　　（Ｌ）
最適化情報をディクショナリ表から削除しました。
aa....aa：削除対象となった表識別子
(Ｓ)処理を続行します。
KFPN10000-E
Invalid directory name, option=aa　　（Ｅ）
pdgeterコマンドのaaオプションで指定したディレクトリ又はデバイス名が，次に示すどれかの理由で設定できません。
・指定したディレクトリ又はデバイスがありません。
・指定したディレクトリに，コマンド実行者に対する書き込み権限がありません。
・指定したディレクトリ名に値するものが，ディレクトリ属性を持っていません。
・指定したデバイス名に値するものがデバイス属性を持っていません。
・-wオプションに，デバイス名が指定されています。
aa：指定値が不正なオプション名
-o：出力先ディレクトリ名又はデバイス名
-w：ワーク用ディレクトリ名
(Ｓ)処理を終了します。
[対策]ディレクトリ名，又はデバイス名を確認して，コマンドを再度実行してください。
KFPN10050-E
Unable to set default, option=aa　　（Ｅ）
pdgeterコマンドのaaオプションの省略値仮定値が，次に示すどちらかの理由で設定できません。
・$PDDIR又は$PDDIR/erinfにこのコマンド実行者の書き込み権限がありません。
・省略時仮定値と同一名称のファイルがあります。
aa：省略時仮定値を設定できないオプション名
-o：出力先ディレクトリ名称
-w：ワークディレクトリ名称
(Ｓ)処理を終了します。
[対策]原因を取り除いて，コマンドを再度実行してください。
KFPN10051-E
Error information file already exists, directory=aa....aa　　（Ｅ）
pdgeterコマンドの出力先ディレクトリ又は一時的ワーク領域に，次に示す名称のディレクトリ又はファイルのどれかがあるため，障害情報を取得できません。
・PDDIR
・lib
・usr
・HiRDB
aa....aa：-oオプションで指定したディレクトリ，-wオプションで指定したディレクトリ又はこれらの省略時仮定値
(Ｓ)処理を終了します。
[対策]上記の名称のディレクトリ又はファイルが不要ならば，削除して，コマンドを再度実行してください。上記の名称のディレクトリ又はファイルが必要であれば，pdgeterコマンドが使用するディレクトリを変更して，コマンドを再度実行してください。
KFPN10100-E
Invalid parameter　　（Ｅ）
pdgeterコマンドのパラメタの指定に誤りがあります。
・不正なオプションが指定されています。
(Ｓ)処理を終了します。
[対策]pdgeterコマンドのパラメタを正しく指定して，コマンドを再度実行してください。
KFPN10101-E
Invalid aa option　　（Ｅ）
pdgeterコマンドのaaオプションの指定に，誤りがあります。
・コマンド引数が指定されていません。
aa：指定値が不正なオプション名
-o：出力先ディレクトリ名
-w：ワークディレクトリ名
-x：ホスト名
(Ｓ)処理を終了します。
[対策]pdgeterコマンドのパラメタの指定が誤っていないか確認してください。
KFPN10200-W
Unable to get HiRDB files　　（Ｅ）
pdgeterコマンドで，-aオプションが指定されましたが，マスタディレクトリ，データディレクトリ，及びデータディクショナリを取得できません。次に示す理由が考えられます。
・コマンド起動ホスト下に$PDDIR/conf/INITCONT（pdinit制御文ファイル）がありません。
・コマンド起動ホスト下に$PDDIR/conf/pdsys（システム共通定義）がありません。
・pdgeterコマンドの-xオプションにマスタディレクトリなどのあるホスト（シングルサーバ又はディクショナリサーバ）が指定されていません。
・システム共通定義に，pdstartオペランドがありません。
・$PDDIR/conf/INITCONT（pdinit制御文ファイル）に指定しているHiRDBファイルシステム領域が，マスタディレクトリなどのあるホスト（シングルサーバ又はディクショナリサーバ）にありません。
(Ｓ)処理を続行します。
KFPN10201-W
Unable to get HiRDB System information, host_name=aa....aa　　（Ｅ）
pdgeterコマンドで，ホスト名aa....aaの共用メモリダンプ情報及びシステム情報を取得できません。次に示す理由が考えられます。
・HiRDBが稼働中ではありません
aa....aa：共用メモリの内容及びシステム情報を取得できなかったホスト名
(Ｓ)処理を続行します。
KFPN10202-W
Unable to get error information, host_name=aa....aa　　（Ｅ）
pdgeterコマンドで，ホスト名aa....aaの障害情報が取得できません。次に示すどれかの理由が考えられます。
・指定したホスト名がありません。
・ネットワーク障害が発生しています。
・コマンド起動ホストの容量が不足しています。
・-oオプションで指定したディレクトリ又はデバイスが，pdgeterコマンド実行中に，何かの原因で削除された可能性があります。
・-wオプションで指定したディレクトリがpdgeterコマンドに実行中に，何らかの原因で削除された可能性があります。
・pdgeterコマンド内で発行するOSコマンドの実行結果の出力に失敗しました。この場合，host_nameには，コマンド起動ホストが埋め込まれます。
aa....aa：ホスト名
(Ｓ)処理を続行します。
[対策]エラーとなったホストの障害情報が必要ならば，再度，該当するホスト名を-xオプションに指定して，コマンドを実行してください。ネットワーク障害が発生している場合は，該当するホスト上でコマンドを実行する必要があります。
KFPN10203-E
HiRDB home directory not defined　　（Ｅ）
HiRDB運用ディレクトリ（$PDDIR）が設定されていないため，pdgeterコマンドが実行できません。
(Ｓ)処理を終了します。
[対策]HiRDB管理者のHiRDB運用ディレクトリ（$PDDIR）を設定した後，コマンドを再度実行してください。
KFPN10204-W
HiRDB home directory not defined, host_name=aa....aa　　（Ｅ）
pdgeterコマンドで指定したホスト名称aa....aaに，環境変数$PDDIRが設定されていないため，このホストの障害情報が取得できません。
aa....aa：ホスト名称
(Ｓ)処理を続行します。
[対策]対象ホストの，HiRDB管理者の環境変数$PDDIRを設定した後，コマンドを再度実行してください。
KFPN10300-I
Pdgeter started　　（Ｅ）
pdgeterコマンドの実行を開始しました。
(Ｓ)処理を続行します。
KFPN10301-I
Pdgeter terminated, return code=aa....aa　　（Ｅ）
pdgeterコマンドの実行が終了しました。
aa....aa：リターンコード（終了コード）
0：正常に終了しました。
4：正常に終了しましたが，警告メッセージを出力しました。
8：エラーが発生したため，処理を打ち切りました。
12：割り込み（シグナル発生）のため処理を打ち切りました。
(Ｓ)処理を終了します。
[対策]
〈リターンコードが4の場合〉
処理中に出力されたメッセージのうち，警告メッセージを参照して，原因を取り除いてください。
〈リターンコードが8の場合〉
処理中に出力されたメッセージのうち，エラーメッセージを参照して，原因を取り除いてください。
KFPN10302-I
Usage: pdgeter [-o dir_name | dev_name] [-w dir_name] [-x host_name [,host_name] ...] [-am]　　（Ｅ）
pdgeterコマンドの使用方法を示します。
-o：出力先ディレクトリ名称又はデバイス名称
-w：ワークディレクトリ名称
-x：ホスト名称
-a：全情報取得
-m：共用メモリダンプ及びシステム情報を取得しません
(Ｓ)処理を終了します。
[対策]pdgeterコマンドのパラメタを正しく指定して，再度実行してください。
KFPN11000-E
Invalid directory or file name, option=aa　　（Ｅ）
pddefrevコマンドのaaオプションで指定したディレクトリ又はファイル名が，次に示すどれかの理由で設定できません。
・指定したディレクトリ又はファイルがありません。
・指定したディレクトリに，コマンド実行者に対する書き込み権限がありません。
・指定したディレクトリ名に，ディレクトリ属性がありません（ディレクトリとして指定した名称は，ディレクトリではありません）。
・指定したファイルに，コマンド実行者に対する読み込み権限がありません。
aa：指定値が不正なオプション名
-o：定義系SQL出力ファイル
-w：ワークディレクトリ名
(Ｓ)処理を終了します。
[対策]ディレクトリ名又はファイル名を確認して，コマンドを再度実行してください。
KFPN11100-E
Invalid parameter　　（Ｅ）
pddefrevコマンドのパラメタの指定に次に示す誤りがあります。
・不正なオプションが指定されています。
(Ｓ)処理を終了します。
[対策]pddefrevコマンドのパラメタを正しく指定して，コマンドを再度実行してください。
KFPN11101-E
Invalid aa option　　（Ｅ）
pddefrevコマンドのaaオプションの指定に次に示す誤りがあります。
・コマンド引数が指定されていません。
・-oオプションの場合，絶対パスで指定されていません。
aa：指定値が不正なオプション名
-f：制御文ファイル名称
-o：定義系SQL出力ファイル名称
-w：ワークディレクトリ名称
(Ｓ)処理を終了します。
[対処]pddefrevコマンドのパラメタの指定が誤っていないか確認してください。
KFPN11302-I
Usage: pddefrev -f control_file_name -o output_file_name [-w work_dir_name]　　（Ｅ）
pddefrevコマンドの使用方法を示します。
-f：制御文ファイル名称
-o：定義系SQL出力ファイル名称
-w：ワークディレクトリ名称
(Ｓ)処理を終了します。
[対策]pddefrevコマンドのパラメタを正しく指定して，再度実行してください。
KFPN90001-E
Insufficient memory, required memory size=aa....aa, area type=bbbbbbb　　（Ｅ）
メモリ不足が発生しました。
aa....aa：確保しようとした領域サイズ（単位：バイト数）
bbbbbbb：領域種別
PROCESS：プロセス固有メモリ
(Ｓ)処理を終了します。
[対策]メモリを大量に使用するプロセスがあるか確認してください。
〈メモリを大量に使用するプロセスがある場合〉
プロセスの終了を待って，コマンドを再度実行してください。
〈メモリを大量に使用するプロセスがない場合〉
保守員に連絡してください。
KFPN90002-E
Internal error, func=aa....aa　　（Ｅ）
内部矛盾を検知しました。
aa....aa：エラーが発生したモジュール名
(Ｓ)処理を終了します。
[対策]保守員に連絡してください。
KFPN90003-E
System call error, func=aa....aa, errno=bb....bb　　（Ｅ）
システムコールでエラーが発生しました。
aa....aa：エラーが発生したシステムコール名
bb....bb：エラーが発生したシステムコールのerrnoの値
(Ｓ)処理を終了します。
[対策]エラーインジケータの値を調査して，errno.h及びユーザが使用しているOSのマニュアルを参照して，エラーの原因を取り除き，再度実行してください。
KFPN90004-E
Usage: pdvwopt [-d] filename　　（Ｅ）
pdvwoptコマンド（アクセスパス表示ユティリティ）の使用方法を示します。
(Ｓ)処理を終了します。
[対策]pdvwoptコマンドのパラメタの入力が誤っていないか確認してください。
KFPN90006-E
Access path file bb....bb error, file=cc....cc, errno=aa....aa　　（Ｅ）
ファイルのアクセス処理でエラーが発生しました。
aa....aa：システムコールが返すerrnoの値
bb....bb：エラーが発生した処理コード
close：ファイルクローズ処理
open：ファイルオープン処理
read：読み込み処理
write：書き込み処理
cc....cc：ファイル名称
ファイル名称が126バイト以下の場合，ファイル名称全体を表示します。126バイトを超える場合は先頭126バイトに2バイトのピリオド（..）を付けて出力します。
(Ｓ)処理を終了します。
[対策]エラーインジケータの値を調査して，errno.h及びユーザが使っているOSのマニュアルを参照して，エラーの原因を取り除き，再度実行してください。
KFPN90007-E
Command version incompatible, access path file version=aa....aa, command version=bb....bb　　（Ｅ）
アクセスパス情報ファイルのバージョンリビジョン番号が，コマンドのバージョンリビジョン番号と異なります。
aa....aa：アクセスパス情報ファイルのバージョンリビジョン番号
bb....bb：コマンドのバージョンリビジョン番号
(Ｓ)処理を終了します。
(Ｏ)アクセスパス情報ファイルのバージョンリビジョン番号と一致したバージョンリビジョン番号のコマンドを使用して，実行してください。
KFPN90008-E
Invalid format of access path file aa....aa　　（Ｅ）
指定したファイルaa....aaの形式が誤っています。
aa....aa：指定したファイル名
ファイル名称が126バイト以下の場合，ファイル名称全体を表示します。126バイトを超える場合は先頭126バイトに2バイトのピリオド（..）を付けて出力します。
(Ｓ)処理を終了します。
(Ｏ)指定したファイル名がアクセスパス情報ファイルかどうか確認してください。
KFPN91001-I
Usage: pdobils [-s server_name] [-r]　　（Ｓ）
pdobilsコマンドのオプション形式に誤りがあります。
(Ｓ)処理を終了します。
(Ｏ)コマンドの使用方法に従って，再度実行してください。
KFPN91002-E
Invalid server name aa....aa　　（Ｓ）
pdobilsコマンドに指定したサーバ名が不正です。
aa....aa：サーバ名
9文字以上指定した場合は，先頭9文字が表示されます。
(Ｓ)処理を終了します。
(Ｏ)pdobilsコマンドに指定したサーバ名を修正した後，再度コマンドを実行してください。
KFPN91003-E
Internal function error, func=aa....aa, return code=bb....bb　　（Ｓ）
pdobilsコマンド処理でエラーが発生しました。
aa....aa：エラーが発生した関数名
bb....bb：システム関連エラーの詳細コード
(Ｓ)処理を終了します。
(Ｏ)「システム関連エラーの詳細コード」を参照してエラーの原因を取り除き，再度コマンドを実行してください。
KFPN91004-E
Insufficient memory on PROCESS, size=aa....aa　　（Ｓ）
pdobilsコマンド実行時にプロセス固有領域を確保しようとしましたが，メモリが不足したため確保できませんでした。
aa....aa：確保しようとした領域サイズ（単位：バイト）
(Ｓ)処理を終了します。
(Ｏ)次の方法で，使用できるメモリに余裕を持たせてください。
・同時実行しているプロセス数を減らしてください。
・スワップ領域を増やしてください。
・実メモリを増設してください。
KFPN91005-E
Unable to execute pdobils command, because unit of hostname aa....aa not online 　　（Ｓ）
ホスト名aa....aaのユニットが開始していないため，pdobilsコマンドが実行できませんでした。
aa....aa：pdobilsコマンドが実行できなかったホスト名
(Ｓ)処理を終了します。
(Ｏ)システム，又はユニットのステータスがオンライン状態になるのを待って再度実行してください。
KFPN91006-E
Unable to execute pdobils command, because server aa....aa not active 　　（Ｓ）
サーバaa....aaが開始していないため，pdobilsコマンドが実行できませんでした。
aa....aa：pdobilsコマンドを実行できなかったHiRDBサーバ名
(Ｓ)処理を終了します。
(Ｏ) HiRDBサーバを開始し，再度実行してください。


KFPOメッセージ

KFPO00100-E
Error occurred in system call aa....aa. errno=bbb,function　name=cc....cc　　（Ｅ＋Ｌ）
HiRDBシステムが使用する関数内で発行したシステムコールにエラーが発生しました。
aa....aa：発行したシステムコール名
bbb：システムコールのリターンコード（errno）
cc....cc：エラーが発生した関数名
(Ｓ)処理を続行できる場合は続行します。そうでない場合は中断します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]次のどちらかの対処をしてください。
・このメッセージの前後に，エラーメッセージ又は警告メッセージが出力されている場合は，そのメッセージの対策に従ってください。
・「システムコールのリターンコード」を参照し，対策してください。
上記のどちらでも対処できない場合は，保守員に連絡してください。
KFPO00103-E
Shared memory pool damaged. location=0xaaaaaaaa (0xbbbbbbbb,0xcccccccc)　　（Ｅ）
共用メモリプールの先頭から0xaaaaaaaaのロケーションにあるセグメントが破壊されました。
aaaaaaaa：破壊されたセグメントの共用メモリプールの先頭からのロケーション
bbbbbbbb：破壊されたセグメントの先頭8バイトの内容
cccccccc：破壊されたセグメントの末尾8バイトの内容
表示できない場合は，"********"を表示します。
(Ｓ)システムを異常終了します。
(Ｏ)このメッセージで表示されたロケーション，及びセグメントの内容を記録し，HiRDB管理者に連絡してください。また，コアファイルが出力されている場合，そのコアファイルを保存して，保守員に連絡してください。
[対策]共用メモリプールが破壊された原因を調査してください。
KFPO00104-E
Shared memory subpool damaged. location=0xaaaaaaaa (0xbbbbbbbb,0xcccccccc)　　（Ｅ）
共用メモリサブプールの先頭から0xaaaaaaaaのロケーションにあるメモリブロックが破壊されました。
aaaaaaaa：破壊されたメモリブロックの共用メモリサブプールの先頭からのロケーション
bbbbbbbb：破壊されたメモリブロックの先頭8バイトの内容
cccccccc：破壊されたメモリブロックの末尾8バイトの内容
表示できない場合は，"********"を表示します。
(Ｓ)システムを異常終了します。
(Ｏ)このメッセージで表示されたロケーション，及びメモリブロックの内容を記録し，HiRDB管理者に連絡してください。また，コアファイルが出力されている場合，このコアファイルを保存して，保守員に連絡してください。
[対策]共用メモリサブプールが破壊された原因を調査してください。
KFPO00105-E
Server aa....aa (process ID=bb....bb) killed by code=cc....cc　　（Ｅ）
異常が発生したためHiRDBのサービスを停止しました。
aa....aa：異常終了したプロセスのサーバ名
サーバ名が特定できない場合は"********"を表示します。
bb....bb：異常終了したプロセスのプロセスID
cc....cc：アボートコード
アボートコードについては，「アボートコード一覧」を参照してください。
(Ｓ)システムサービスの処理中にサービスを停止した場合は，HiRDB（HiRDB/パラレルサーバの場合はユニット）を異常終了します。UAPの処理中にサービスを停止した場合は後処理を実行します。必要に応じてサービスを再度起動します。
(Ｏ)次に示すディレクトリ下のファイルを保存して，HiRDB管理者に連絡してください。
・$PDDIR/spool
・$PDDIR/tmp/home
[対策]出力されたアボートコードの対策に従ってください。
KFPO00106-E
{"Malloc(aa....aa)"|"Realloc(bb....bb,aa....aa)"|"Calloc(cc....cc,aa....aa)"}failed,process ID=dd....dd, type=0xee....ee　　（Ｅ）
C標準関数のmalloc，realloc，又はcallocにエラーが発生したため，プロセス固有領域を確保できません。
aa....aa：HiRDBシステム内部で発行したmalloc，realloc，又はcalloc関数に指定したサイズ
bb....bb：HiRDBシステム内部で発行したrealloc関数に指定した領域のアドレス
cc....cc：HiRDBシステム内部で発行したcalloc関数に指定した配列の要素数
dd....dd：malloc，realloc，又はcalloc関数を発行したプロセスのプロセスID
ee....ee：種別コード（HiRDBシステムの各コンポーネントで設定した識別情報）
(Ｓ)システムを継続して運用できる場合は，そのまま処理を続行します。継続できない場合は，HiRDBシステムを異常終了します。
(Ｏ)このメッセージの内容を記録し，HiRDB管理者に連絡してください。コアファイルにダンプが出力されている場合は，そのダンプを保存してください。
[対策]次のどれかの対策を実施してください。
・システムが継続して処理している場合，必要のないプロセスを停止させてください。
・pd_max_usersオペランドの値を見直してください。
・システムのスワップ領域を追加してください。
・主記憶装置を増設してください。
KFPO00107-E
"aa....aa(bb....bb)" failed. errno=cc....cc： dd....dd　　（Ｅ）
HiRDBシステム内で発行したシステムコールに，エラーが発生しました。
aa....aa：システムコール名
bb....bb：システムコールを呼び出したモジュール，又は関数名
cc....cc：システムコールエラー時のerrno値
dd....dd：システムコールエラーの内容
(Ｓ)障害の重要度によって，次に示すどれかの処置を取ります。
・処理を打ち切り，プロセスを異常終了させます。
・処理を打ち切り，実行中サービスの呼び出し元へ戻します。
・そのまま処理を続行します。
(Ｏ)システムコール名とerrno値を基に，ユーザが使用するOSのマニュアルで原因を調査してください。コアファイルにダンプが出力されている場合は，そのダンプを保存してHiRDB管理者に連絡してください。
[対策]システムコール名とerrno値を基に，ユーザが使用するOSのマニュアルで原因を調査し，UAPの修正，システム定義の変更，又はオペレーティングシステムを再度生成してください。
主な対策方法を次に示します。
システムコール名
呼び出しモジュール
errno
エラーの内容
対策方法
open
任意
23
ファイルのオープン数がシステムの上限を超えました。
HiRDBサーバがWindows NT版の場合，インストールドライブの容量不足によって，共用メモリ用の作業ファイルが確保できません。
OSのオペレーティングシステムパラメタ（カーネルパラメタ）のnfileの指定値を大きくしてください。また，不要なプロセスやウィンドウがある場合は停止してください。
HiRDBサーバがWindows NT版の場合，インストールドライブに，共用メモリサイズ以上の空き容量を確保してください。
24
該当するプロセスでオープンしているファイル数が多過ぎます。
HiRDBサーバがWindows NT版の場合，インストールドライブの容量不足によって，共用メモリ用の作業ファイルが確保できません。
HiRDBの運用コマンド，ユティリティ実行中に発生した場合，OSのオペレーティングシステムパラメタ（カーネルパラメタ）のmaxfilesの値を大きくしてください。
HiRDBサーバがWindows NT版の場合，インストールドライブに，共用メモリサイズ以上の空き容量を確保してください。
logblib.c
999
Windows NTの場合，HiRDBの作業ファイルが破壊されている可能性があります。
HiRDBが停止しているのを確認してから，次に示すファイルをすべて削除して回復してください。
ただし，4以降のファイルはないことがあります。
1. %PDDIR%\uxpldir\spool\system\filmng.dat
2. %PDDIR%\uxpldir\spool\system\flg.dat
3. %PDDIR%\uxpldir\spool\system\shmmng.dat
4. %PDDIR%\spool\～pdatmode
5. %PDDIR%\spool\～pdipcid
6. %PDDIR%\spool\oslmqid
7. %PDDIR%\spool\oslsmid
8. %PDDIR%\spool\pdprcsts
9. %PDDIR%\spool\scdqid1
10. %PDDIR%\spool\scdqid2
11. %PDDIR%\tmp\pdommenv
12. %PDDIR%\uxpldir\spool\shm下の全ファイル
13. %PDDIR%\uxpldir\spool\system\semmng.dat
14. %PDDIR%\uxpldir\spool\system\msgmng.dat
これらのファイルを削除した後にHiRDBを開始する場合，エクスプローラなどの他アプリケーションで%PDDIR%\tmpにアクセスしたままの状態で，HiRDBを開始しないでください。
write
uss_dump
uss_dump_h
uss_dump_d
usm_dump
usm_rmdump
usm_svdump
12
HiRDBの運用ディレクトリがあるファイルシステムが満杯状態です。
HiRDBの運用ディレクトリ下のトラブル情報を削除してください。
トラブル情報を削除するには，OSのrmコマンド（Windows NTの場合はdelコマンド）か，HiRDBのpdcspoolコマンドを使用してください。
shmat
ommalloc
ommrmalc
22
HiRDBの共用メモリがありません（HiRDBの共用メモリを削除した可能性があります）。
OS起動完了前にHiRDBのコマンドを入力した（/etc/localrcなどのOSの環境ファイルにHiRDBのコマンドを記述した場合も含む）ことが考えられます。
Windows NTの場合，HiRDB稼働中に，%PDDIR%下の作業ファイルを削除した可能性があります。
HiRDBの共用メモリを削除した場合は，保守員に連絡してください。
OS起動完了前にHiRDBのコマンドを実行した場合は，OSの起動完了を待って再度コマンドを実行してください。
OSの環境ファイル/etc/localrcにHiRDBのコマンドを記述した場合は，OSの起動完了前に実行されるため，エラーとなります。したがって，/etc/localrcにはHiRDBのコマンドを記述しないでください。
Windows NTの場合，HiRDBが異常終了していなければ，強制終了してください。その後，HiRDBのサービスを再開始してください。
ommrmalc
24
呼び出し元プロセスに接続される共用メモリ数がシステムの上限値を超えました。
次のオペレーティングパラメタに適切な値を設定してください。見積もり方法については，マニュアル「HiRDB Version 7 システム導入・設計ガイド」を参照してください。
・HP-UXの場合：shmseg
・Solarisの場合：shminfo_shmseg
・Linuxの場合：SHMSEG
AIX 5Lの場合はEXTSHM環境変数にONを設定してください。
shmctl
ommfixed
1
実行者がスーパユーザではありません。
$PDDIR/bin下のファイルの所有者が，不当に変更されたことが考えられます。
実行形式ファイル（$PDDIR/bin下にあるpdommfixed）の所有者及び所有者の実行権限を確認してください。
所有者がroot，所有者の実行権限がs（ファイルモードが-r-sr-xr-x）でない場合，pdsetupコマンド実行後に$PDDIR/bin下のファイルの所有者が変更されています。スーパユーザでpdsetup -dコマンドを実行し，メッセージに対してyを応答した後，pdsetupコマンドで再度HiRDBの実行環境を作成する必要があります。その後，HiRDBを再度開始してください。
semget
osysemg
12
Windows NTの場合，セマフォ識別子に空きがありません。
HiRDBが必要とするセマフォ識別子数を見積もって，それより大きい値をシステム環境変数PDUXPLSEMMAXに設定してください。設定後，HiRDBを終了してサービスを再開始してください。
セマフォ識別子数の見積もり方法については，マニュアル「HiRDB Version 7 システム導入・設計ガイド」を参照してください。
pdi_osm_get
999
そのほかの代表的なerrnoについては，「システムコールのリターンコード」を参照してください。
KFPO00109-E
Shared memory pool(shared memory ID aa....aa, server type=bb....bb)for HiRDB server damaged. location=0xcccccccc(0xdddddddd,0xeeeeeeee)　　（Ｌ）
ユーザサーバの使用する共用メモリプール（共用メモリID=aa....aa，サーバ識別子=bb....bb）が破壊されました。
aa....aa：破壊されたユーザサーバの使用する共用メモリプールの共用メモリ識別子
bb....bb：サーバ識別子
表示できない場合は"********"を表示します。
cccccccc：破壊されたセグメントの共用メモリプールの先頭からのロケーション
dddddddd：破壊されたセグメントの先頭8バイトの内容
eeeeeeee：破壊されたセグメントの末尾8バイトの内容
表示できない場合は"********"を表示します。
(Ｓ)異常終了します。
(Ｏ)このメッセージで表示されたロケーションとセグメントの内容を記録し，HiRDB管理者に連絡してください。また，コアファイルが出力されている場合は，そのコアファイルを保存してください。
[対策]保守員に連絡してください。
プログラムの修正，システム定義の変更，又はオペレーティングシステムを再度生成してください。
KFPO00111-E
Insufficient memory on aa....aa, size=bb....bb　　（Ｌ）
メモリ不足が発生しました。
aa....aa：定義変数名
bb....bb：確保しようとしたサイズ（単位：バイト）
(Ｓ)処理を終了します。
(Ｏ)HiRDB管理者に連絡し，原因を調査してください。
[対策]保守員に連絡してください。
KFPO00112-E
Getarea request error, size=aa....aa　　（Ｌ）
作業領域の不足が発生しました。
aa....aa：確保しようとしたサイズ（単位：バイト）
(Ｓ)異常終了します。
(Ｏ)HiRDB管理者に連絡し，原因を調査してください。
[対策]保守員に連絡してください。
KFPO00113-E
"shmget(manager)" failed. size=aa....aa, errno=bbb　　（Ｌ）
ユニットコントローラ用共用メモリを取得するために発行したshmgetシステムコールがエラーとなりました。
aa....aa：取得しようとした共用メモリのサイズ（単位：バイト）
bbb：shmgetシステムコールのerrno値
(Ｓ)異常終了します。
(Ｏ)「システムコールのリターンコード」のshmgetの箇所を参照して，対策してください。
KFPO00114-E
"shmget(aa....aa)" failed. size=bb....bb, errno=ccc　　（Ｌ）
サーバaa....aaが使用する共用メモリの取得時，shmgetシステムコールでエラーが発生しました。
aa....aa：サーバ識別子
bb....bb：取得しようとした共用メモリのサイズ（単位：バイト）
ccc：shmgetシステムコールのerrno値
(Ｓ)処理を終了します。
(Ｏ)shmgetシステムコールのerrno値によって，処置してください。
errno
要因
管理者の処置
12
共用メモリのサイズに相当するメモリがOSにありません。
共用メモリを使用している同一マシン上のほかの制御文を停止し，エラーの発生したサーバを再度開始してください。又は，HiRDBシステムを停止し，OSの実メモリを増やしてください。
22
共用メモリのサイズがOSの上限値を超えました。
HiRDBシステムを停止し，同一ユニット内に定義するサーバの数を減らしてください。又は，OSの共用メモリのセグメント最大サイズを増やしてカーネルを再度作成してください。
28
共用メモリ識別子の数がOSの上限値を超えました。
共用メモリを使用している同一マシン上のほかの制御文を停止し，エラーの発生したサーバを再度開始してください。又は，HiRDBシステムを停止し，OSの共用メモリ面数を減らすか，若しくは共用メモリ識別子の最大数を増やしてカーネルを再度作成してください。
上記以外
－
保守員に連絡してください。
（凡例）－：該当しません。


KFPRメッセージ

KFPR00754-I
Pdcopy started　　（Ｌ＋Ｓ）
データベース複写ユティリティ（pdcopy）の処理を開始しました。
(Ｓ)処理を続行します。
KFPR00756-I
Pdcopy terminated, return code=aa　　（Ｌ＋Ｓ）
データベース複写ユティリティ（pdcopy）の処理が次に示すリターンコードの内容で終了しました。
aa：データベース複写ユティリティ（pdcopy）のリターンコード
0：正常終了
8：異常終了（複写処理中にエラーが発生しましたが，バックアップの取得に成功したものもあります）
12：異常終了（複写処理はすべて失敗しました）
(Ｓ)処理を続行します。
[対策]異常終了の場合は，このメッセージの前に出力したエラーメッセージを参照して，エラーの原因を取り除いてください。
KFPR00757-I
Retry reopen aa-time of bb after cc-minute, host=dd....dd, file=ee....ee， reason=ff....ff　　（Ｅ＋Ｌ）
マルチボリュームファイルの再オープン処理をcc分後に実行します。リトライの最大数はbbで，次回はaa回目です。ホスト名dd....ddのファイル名ee....eeです。
aa：次回のリトライ回数
bb：最大リトライ回数
cc：リトライ間隔
dd....dd：ホスト名
ee....ee：ファイル名
ff....ff：リトライ理由
No-file：ファイルがセットされていません。
Same-file：再オープン前と同じファイルがセットされています。
(Ｓ)処理を続行します。
[対策]リトライ中に次のファイルをセットしてください。
KFPR00758-I
File swapping started, file=aa....aa, reason=bb....bb　　（Ｌ）
マルチボリュームファイルの2巻目以降のファイルaa....aaの処理を開始しました。
aa....aa：ファイル名
bb....bb：理由コード
ENOSPC：デバイスの容量がなくなりました。
EOV：ボリュームの最後を検出しました。
(Ｓ)処理を続行します。
KFPR00764-I
Pdrstr started　　（Ｌ＋Ｓ）
データベース回復ユティリティ（pdrstr）の処理を開始しました。
(Ｓ)処理を続行します。
KFPR00765-I
Pdrstr terminated, return code=aa　　（Ｌ＋Ｓ）
データベース回復ユティリティ（pdrstr）の処理が次に示すリターンコードの内容で終了しました。
aa：データベース回復ユティリティ（pdrstr）のリターンコード
0：正常終了
4：警告終了（バックアップファイル若しくはアンロードログファイルのクローズエラー，又はバックアップファイル中に回復対象のRDエリアのデータがありません）
8：異常終了（エラーが発生しましたが一つ以上回復に成功したRDエリアがあります）
12：異常終了（すべてのRDエリアの回復に失敗しました）
(Ｓ)処理を続行します。
[対策]異常終了の場合は，このメッセージの前に出力したエラーメッセージを参照して，エラーの原因を取り除いてください。
KFPR00766-I
Recovery of "aa....aa" ended bb....bb　　（Ｌ）
RDエリアaa....aaの回復処理が完了しました。
aa....aa：RDエリア名
bb....bb：完了状態
abnormally：回復に失敗しました。
normally：回復に成功しました。
(Ｓ)処理を続行します。
[対策]回復に失敗しているときは，このメッセージの前に出力されているメッセージを基にエラーの原因を取り除き，再度該当するRDエリアの回復を実行してください。
KFPR00767-I
Retry reopen aa-time of bb after cc-minute, host=dd....dd, file=ee....ee, reason=ff....ff　　（Ｅ＋Ｌ）
マルチボリュームファイルのリオープン処理をcc分後に実行します。リトライの最大数はbbで，次回はaa回目です。ホスト名dd....ddのファイル名ee....eeです。
aa：次回のリトライ回数
bb：最大リトライ回数
cc：リトライ間隔
dd....dd：ホスト名
ee....ee：ファイル名
ff....ff：リトライの理由
(Ｓ)処理を続行します。
[対策]リトライ中に次のファイルをセットしてください。
KFPR00768-I
File swapping started, file=aa....aa, reason=bb....bb　　（Ｌ）
マルチボリュームファイルの2巻目以降のファイルaa....aaの処理を開始しました。
aa....aa：ファイル名
bb....bb：理由コード
ENOSPC：デバイスの容量がなくなりました。
EOV：ボリュームの最後を検出しました。
(Ｓ)処理を続行します。
KFPR00786-I
Differential recovery by manual mode　　（Ｌ＋Ｓ）
差分バックアップ管理ファイルを使用しない回復処理を開始します。
(Ｓ)処理を続行します。
KFPR16003-E
aaaaaa error occurred, file=bb....bb　　（Ｅ＋Ｌ）
ファイルへの入出力エラーが発生しました。
aaaaaa：エラーの発生した処理
Close：クローズ処理
Open：オープン処理
Read：読み込み処理
Reopen：マルチボリュームファイルの2巻目以降のオープン処理
Write：書き込み処理
bb....bb：ファイル名称
(Ｓ)処理を終了します。ただし，ファイルのCloseエラーのときは処理を続行する場合があります。
[対策]このメッセージに続いて出力されるメッセージを参照して，エラーの原因を取り除き，再度コマンドを実行してください。
KFPR16005-E
Insufficient memory for PROCESS, size=aa....aa　　（Ｌ＋Ｓ）
データベース複写ユティリティ（pdcopy）の実行に必要な作業領域を確保しようとしましたが，プロセス固有領域が不足しているため確保できません。
aa....aa：確保しようとした領域長（単位：バイト）
(Ｓ)処理を終了します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]プロセス固有領域を増やして，再度実行してください。
KFPR16014-E
Pdcopy version aa....aa and HiRDB version bb....bb do not match　　（Ｌ＋Ｓ）
データベース複写ユティリティ（pdcopy）のバージョンがHiRDBのバージョンと異なります。
aa....aa：データベース複写ユティリティのバージョンリビジョン番号
bb....bb：HiRDBのバージョンリビジョン番号
(Ｓ)処理を終了します。
[対策]適切なバージョンリビジョン番号のHiRDB下で，HiRDBと同じバージョンリビジョン番号のデータベース複写ユティリティを実行してください。
KFPR16101-E
File I/O error occurred, reason=aa....aa, func=bb....bb, errno=cc....cc, (dd....dd)　　（Ｌ＋Ｓ）
ファイルへの入出力処理中にエラーが発生しました。
aa....aa：エラーの理由
File-format：指定した形式と実際のファイル形式が異なります。指定したファイル名が誤っているか，又はコマンドラインや制御文に指定したファイルの形式と内容が一致していない可能性があります。
File-lock：使用するファイルは，ほかのユティリティで排他制御されています。このため，ファイルの読み書きができません。コマンドラインや制御文に指定したファイル名が，別のジョブで使用中のファイル名と重複しているか，又はOSのカーネルパラメタのファイルロック用資源が不足している可能性があります。
File-sequence：マルチボリュームのファイルの順序が不正です。
Invalid-device：指定したファイルのエントリタイプ（属性）が不正です。又は，MTguideを使用している場合，MTguideが起動されていません。エントリタイプが識別できる場合は，英字1文字を括弧に入れて表示します。この文字は，OSのls -lコマンドで出力したモードのエントリと同じです。ファイル名を指定する必要がある箇所にディレクトリ名を指定したり（又はその逆），キャラクタ型スペシャルファイルを使用できないファイルにキャラクタ型スペシャルファイルを割り当てたりしている可能性があります。
Invalid-environment：unameシステムコールで得られる設定値が誤っているため，ストリーミングテープ装置が使用できません。OSが正しく組み込まれているか，又はOSのバージョンがHiRDBシステムや関連プログラムプロダクトの前提条件に合っているかどうかを確認してください。
Invalid-parameter：指定したパラメタの組み合わせが不正です。
Invalid-path：パス名が誤っています。
Invalid-permission：指定したファイルのパーミッションが不正（アクセス権限エラー）です。HiRDB管理者にファイルアクセス権限を与えていないファイルを使用しているか，又はMTの場合はライトプロテクトが掛かっている可能性があります。
No-file：読み込み用にオープンしようとしたファイルがありません。又は，書き込み中のファイルが消去されました。
No-space：書き込むファイルに十分な容量がありません。容量を見直すか，又はマルチボリュームを指定してください。
ディスク容量が十分な状態でこのエラーになる場合は，HiRDBファイルシステム領域をラージファイルとして定義していないか，又はOSのカーネルパラメタの制限に該当している可能性があります。
また，pdcopyの-Sオプションの値が，デフォルト又はバックアップデータよりも小さい値が設定されている可能性があります。エラーが発生したシステム関数名にOB2_WriteObjDataが出力された場合，JP1/OmniBackIIに設定しているバックアップデータ出力先の容量を確認してください。容量が十分な場合は，OmniBackIIから出力されているメッセージを確認し，原因を特定してください。エラーの原因が特定できない場合は，保守員に連絡してください。
No swap-file：マルチボリューム用のファイルがありません。容量を見直してください。又は，マルチボリュームを指定してください。
Same-file：マルチボリュームのファイルとして，直前に処理したファイルと同じファイルを指定しています（ファイルの交換忘れ）。又は，マルチボリュームへの書き込み時，同一ボリュームを再使用しようとしました。
Unmatch-entry：ヘッダがあるファイルに対して，ヘッダ中のエントリが制御情報ファイルの指定と一致しません。一致しないエントリ名称を括弧の中に表示します。
上記のエラーの理由を対策してもエラーとなる場合は，保守員に連絡してください。
bb....bb：エラーが発生した関数名
・HiRDBファイルシステムでエラーを検知した場合はp_f_iosで始まるHiRDBファイルシステムの関数名
・OmniBackIIでエラーを検知した場合は「OB2_WriteObjdata」
・関数使用時以外で検知したエラーの場合は「***」
・上記以外の場合はシステム関数名
cc....cc：関数が返却したエラー番号（errno）
・HiRDBファイルシステムでエラーを検知した場合はHiRDBファイルシステムのエラーコード
・関数以外，又はOmniBackIIでエラーを検知した場合は「0」
・OSがエラーを検知した場合はシステム関数が返却したエラー番号（errno：エラー状態を表す外部参照変数）
dd....dd：障害を検知したソースファイル名と行番号
(Ｓ)処理を終了します。
[対策]次の表に従い対策してください。
エラー要因
対策
HiRDBファイルシステムでエラーを検知した場合
「HiRDBファイルシステムに対するアクセス要求から返されるエラーコード」を参照してエラーの原因を取り除き，再度実行してください。
関数以外，又はOmniBackIIでエラーを検知した場合
aa....aaのエラー理由からエラーの原因を取り除き，再度実行してください。
OSがエラーを検知した場合
OSのマニュアルを参照してエラーの原因を取り除き，再度実行してください。
再度実行してもエラーとなる場合は，保守員に連絡してください。
KFPR16102-E
File operation was canceled by aa....aa　　（Ｅ＋Ｌ）
マルチボリュームファイルのファイル交換が取り消されました。
aa....aa：取り消された理由
system：システムによる処理の取消
user：ユーザによる処理の取消
(Ｓ)処理を終了します。
(Ｐ)取り消された処理が必要な場合，再度実行してください。
KFPR16104-E
Dynamic load error occurred, shared library=aa....aa　　（Ｌ＋Ｓ）
処理に必要な共用ライブラリの動的ロードでエラーが発生しました。
aa....aa：共用ライブラリの絶対パス名
(Ｓ)処理を終了します。
(Ｏ)このメッセージの前に出力されたKFPR26003-Eメッセージを参照して，次の観点で原因を取り除き再度実行してください。
〈EasyMTを使用する場合〉
インストールが正しくできているか調査してください。
〈EasyMTを使用しない場合〉
-kオプションフラグの指定を見直して，EasyMT又はMTguideを使用しない指定にしてください。
KFPR16108-E
Present directory information conflicts with directory information specified when the backup file was made, RDAREA name="aa....aa", code=b　　（Ｌ＋Ｓ）
前回のバックアップファイル作成時のディレクトリ情報と今回のディレクトリ情報の不一致を検知しました。前回のバックアップ取得時から現在までの間にRDエリアの構成変更をしていることが原因です。
aa....aa：不一致となったRDエリア名
b：エラーコード
1：ページサイズ不一致
2：RDエリア属性不一致
3：HiRDBファイル名不一致
4：RDエリア名不一致
5：セグメントサイズ不一致
6：RDエリアを構成するHiRDBファイル数不一致
7：RDエリアの初期化日付
(Ｓ)処理を終了します。
[対策]pdcopyコマンドでフルバックアップを取得してください。このとき，差分バックアップ管理ファイルを作成する指定をしてください（-gオプションに指定する差分バックアップグループ名に(S)を指定してください）。
KFPR16110-I
Unable to get a backup file aa....aa　　（Ｌ＋Ｓ）
データベースのバックアップファイルを取得できません。
aa....aa：バックアップファイル名
(Ｓ)ほかのバックアップファイルを指定している場合，そのバックアップ処理を続行します。ほかのバックアップファイルを指定していない場合，処理を終了します。
[対策]このメッセージの前に出力されたエラーメッセージを参照して，エラーの原因を取り除き，再度実行してください。
KFPR16126-E
Master RDAREA is not initialized　　（Ｌ＋Ｓ）
マスタディレクトリ用RDエリアを初期化していません。又は，マスタディレクトリ以外のファイルを指定しました。
エラーの原因を次に示します。
・データベース初期設定ユティリティ（pdinit）が正常終了していません。
・マスタディレクトリ用RDエリア以外のファイルを指定しました。
・マスタディレクトリ用RDエリアの内容が破壊されています。
(Ｓ)処理を終了します。
[対策]エラーの原因を取り除き，マスタディレクトリ用RDエリアを正常な状態にした後，再度実行してください。
KFPR16127-E
Page corrupted, RDAREA name="aa....aa", HiRDB file name=bb....bb, page no.=cc....cc　　（Ｌ＋Ｓ）
ページ破壊を検知しました。
aa....aa：RDエリア名
bb....bb：HiRDBファイル名
cc....cc：HiRDBファイルbb....bb中のページ番号
(Ｓ)該当するRDエリアのバックアップファイルの複写処理を中断します。ほかのバックアップファイルがあるときは，処理を続行します。
[対策]保守員に連絡してください。
KFPR16128-E
aa....aa error occurred, func=bb....bb, return code=cc....cc　　（Ｅ＋Ｌ）
ほかのプログラムプロダクトの機能で，エラーが発生しました。
aa....aa：プログラムプロダクトの名称
・SORT（ソートプログラム）
・EasyMT
・OmniBack II（JP1/OmniBack II）
bb....bb：エラーが発生した関数名
cc....cc：エラーが発生した関数のリターンコード
(Ｓ)処理を終了します。
ただし，OmniBack IIのリターンコードが1，2，4の場合は異常終了します。
[対策]次に示すマニュアルを参照して，エラーの原因を取り除き再度実行してください。
・SORT
マニュアル「ソートマージ」を参照してください。なお，KBLSnnn-Eのnnnにエラーコードの絶対値をあてはめて原因を調査してください。
・EasyMT
マニュアル「磁気テープ運用支援 JP1/Magnetic Tape Access」，又はマニュアル「磁気テープ簡易アクセス法 EasyMT」を参照してください。これらのマニュアルに記述されていない場合，又は記載されている情報では対処できない場合，保守員に連絡してください。
・OmniBack II
リターンコードに合わせて対策してください。
1，2，4の場合は，保守員に連絡してください。
3，5～7の場合は，エラーになったJP1/OmniBack IIのセッションIDからomnidb -sessionセッションID -reportをして，エラー原因を調査してください。又は，xomnimonitorを使ってエラー原因を調査してください。セッションIDは，omnidb -sessionで表示されるセッションIDの一覧から探してください。
エラーになった関数名がOB2_Initで，リターンコードが5の場合，JP1/OmniBack IIのバージョンが05-20か確認してください。ほかのバージョンの場合は05-20にしてください。
エラー原因の調査方法については，JP1/OmniBack IIのマニュアルを参照してください。リターンコード3，5～7の意味は次のとおりです。
リターンコード
意味
３
関数が現在の操作モードに該当しません。エラーになった関数名が OB2_Initの場合，バックグラウンドで動作しているJP1/OmniBack IIのセッションをomnistatコマンドで調査し，そのセッションが完了するまで待って再度実行してください。
５
JP1/OmniBack IIの内部エラーによって操作が失敗しました。
６
システムエラーによって操作が失敗しました。
７
JP1/OmniBack IIのサービスについての権限が不足しています。
エラーになった関数名がOB2_Initの場合，HiRDB管理者をJP1/OmniBack IIのユーザとしてadminユーザクラスに登録してください。
KFPR16129-E
EasyMT error occurred, func=aa....aa, reason=bb....bb　　（Ｌ＋Ｓ）
EasyMTを使用したファイル入出力処理でエラーが発生しました。
aa....aa：エラーを検知した関数
bb....bb：エラーの詳細情報
(Ｓ)処理を終了します。
[対策]エラーの詳細情報を参考に，マニュアル「磁気テープ運用支援 JP1/Magnetic Tape Access」，又はマニュアル「磁気テープ簡易アクセス法 EasyMT」を参照して，エラー原因を取り除き再度実行してください。
KFPR16203-E
aaaaaa error occurred, file=bb....bb　　（Ｌ＋Ｓ）
ファイルへの入出力エラーが発生しました。
aaaaaa：エラーが発生した処理
Close：クローズ処理
Open：オープン処理
Read：読み込み処理
Reopen：マルチボリュームファイルの2巻目以降のオープン処理
Write：書き込み処理
bb....bb：ファイル名称（システムログファイルの入出力エラーの場合は，ファイルグループ名称）
(Ｓ)処理を終了します。ただし，ファイルのCloseエラーのときは処理を続行する場合があります。
[対策]このメッセージに続いて出力されるメッセージを参照してエラーの原因を取り除き，再度コマンドを実行してください。ただし，システムログファイルの入出力エラーの場合，このメッセージの前に出力されるメッセージを参照してください。
KFPR16205-E
Insufficient memory for PROCESS, size=aa....aa　　（Ｌ＋Ｓ）
pdrstr，又はpdbkuplsコマンドの実行に必要な作業領域を確保しようとしましたが，プロセス固有領域が不足しているため確保できません。
aa....aa：確保しようとした領域長（単位：バイト）
(Ｓ)処理を終了します。
[対策]大量にメモリを使用するプロセスがないか確認してください。
大量にメモリを使用するプロセスがある場合：
該当するプロセスの終了を待って，再度コマンドを実行してください。
大量にメモリを使用するプロセスがない場合：
次のどれかの方法で，使用できるメモリに余裕を持たせてください。
・同時実行しているプロセスの数を減らしてください。
・スワップ領域を増やしてください。
・実メモリを増設してください。
KFPR16214-E
Pdrstr version aa....aa and HiRDB version bb....bb do not match　　（Ｌ＋Ｓ）
データベース回復ユティリティ（pdrstr）のバージョンがHiRDBのバージョンと異なります。
aa....aa：データベース回復ユティリティのバージョンリビジョン番号
bb....bb：HiRDBのバージョンリビジョン番号
(Ｓ)処理を終了します。
[対策]適切なバージョンリビジョン番号のHiRDB下で，HiRDBと同じバージョンリビジョン番号のデータベース回復ユティリティを実行してください。
KFPR16301-E
File I/O error occurred, reason=aa....aa, func=bb....bb, errno=cc....cc, (dd....dd)　　（Ｌ＋Ｓ）
ファイルへの入出力処理中に，エラーが発生しました。
aa....aa：エラーの理由
Empty-file：指定されたファイルは空（0バイト）です。
File-format：指定した形式と実際のファイル形式が異なります。指定したファイル名が誤っているか，又はコマンドラインや制御文に指定したファイルの形式と内容が一致していない可能性があります。
File-lock：使用するファイルは，ほかのユティリティで排他制御されています。このため，ファイルの読み書きができません。コマンドラインや制御文に指定したファイル名が，別のジョブで使用中のファイル名と重複しているか，又はOSのカーネルパラメタのファイルロック用資源が不足している可能性があります。
File-missing：アンロードログファイル又はバックアップファイルの指定に誤りがあります。また，前後のどちらかに出力されているKFPR26265-Iメッセージを参照してエラーの原因を取り除き，再度実行してください。
File-sequence：マルチボリュームのファイルの順序が不正です。
Invalid-device：指定したファイルのエントリタイプ（属性）が不正です。又は，MTguideを使用している場合，MTguideが起動されていません。エントリタイプが識別できる場合は，英字1文字を括弧に入れて表示します。この文字は，OSのls -lコマンドで出力したモードのエントリと同じです。ファイル名を指定する必要がある箇所にディレクトリ名を指定したり（又はその逆），キャラクタ型スペシャルファイルを使用できないファイルにキャラクタ型スペシャルファイルを割り当てたりしている可能性があります。
Invalid-environment：unameシステムコールで得られる設定値が誤っているため，ストリーミングテープ装置が使用できません。OSが正しく組み込まれているか，又はOSのバージョンがHiRDBシステムや関連プログラムプロダクトの前提条件に合っているかどうかを確認してください。
Invalid-file：正しく作成されていないファイルが指定されました。
Invalid-parameter：指定したパラメタの組み合わせが不正です。
Invalid-permission：指定したファイルのパーミッションが不正（アクセス権限エラー）です。HiRDB管理者にファイルアクセス権限を与えていないファイルを使用しているか，又はMTの場合はライトプロテクトが掛かっている可能性があります。
Invalid-path：パス名が誤っています。
No-file：読み込み用にオープンしようとしたファイルがありません。又は，書き込み中のファイルが消去されました。
No-space：書き込むファイルに十分な容量がありません。容量を見直すか，又はマルチボリュームを指定してください。ディスク容量が十分な状態でこのエラーになる場合は，HiRDBファイルシステム領域をラージファイルとして定義していないか，又はOSのカーネルパラメタの制限に該当している可能性があります。
No swap-file：マルチボリューム用のファイルがありません。容量を見直してください。又は，マルチボリュームを指定してください。
Same-file：マルチボリュームのファイルとして，直前に処理したファイルと同じファイルを指定しています（ファイルの交換忘れ）。又は，マルチボリュームへの書き込み時，同一ボリュームを再使用しようとしました。
Unmatch-entry：ヘッダがあるファイルに対して，ヘッダ中のエントリが制御情報ファイルの指定と一致しません。一致しないエントリ名称を括弧の中に表示します。
bb....bb：エラーが発生した関数名
・HiRDBファイルシステムでエラーを検知した場合はp_f_iosで始まるHiRDBファイルシステムの関数名
・関数使用時以外で検知したエラーの場合は「***」
・上記以外の場合はシステム関数名
cc....cc：関数が返却したエラー番号（errno）
・HiRDBファイルシステムでエラーを検知した場合はHiRDBファイルシステムのエラーコード
・関数以外でエラーを検知した場合は「0」
・OSがエラーを検知した場合はシステム関数が返却したエラー番号（errno：エラー状態を表す外部参照変数）
dd....dd：障害を検知したソースファイル名と行番号
(Ｓ)aa....aaがFile_missingの場合は，このメッセージの前後のどちらかに出力されているKFPR26265-Iメッセージに従って処理を続行します。それ以外の場合は，処理を終了します。
[対策]次の表に従い対策してください。
エラー要因
対策
HiRDBファイルシステムでエラーを検知した場合
「HiRDBファイルシステムに対するアクセス要求から返されるエラーコード」を参照してエラーの原因を取り除き，再度実行してください。
関数以外でエラーを検知した場合
aa....aaのエラー理由からエラーの原因を取り除き，再度実行してください。
OSがエラーを検知した場合
OSのマニュアルを参照してエラーの原因を取り除き，再度実行してください。
再度実行してもエラーとなる場合は，保守員に連絡してください。
KFPR16302-E
File operation was canceled by aa....aa　　（Ｅ＋Ｌ）
マルチボリュームファイルのファイル交換が取り消されました。
aa....aa：取り消された理由
system：システムによる処理の取り消し
user：ユーザによる処理の取り消し
(Ｓ)処理を終了します。
[対策]取り消された処理が必要な場合，再度実行してください。
KFPR16303-E
Invalid aa....aa log file, file=bb....bb　　（Ｌ＋Ｓ）
ログファイルbb....bbが不正です。次に示す内容を確認してください。
〈アンロードログファイルの場合〉
・不正なアンロードログファイルを指定していないか
・データベース初期設定前のアンロードログファイルと，データベース初期設定後のアンロードログファイルを混在して指定していないか
〈システムログファイルの場合〉
・バックアップ取得以降にデータベースの初期設定をしていないか
aa....aa：ログファイル種別
unload：アンロードログファイル
sys：システムログファイル
bb....bb：エラーを検知したログファイル名，又は初期設定されたことを検知したログファイル名
〈アンロードログファイルの場合〉
アンロードログファイル名
〈システムログファイルの場合〉
ファイルグループ名
(Ｓ)処理を終了します。
(Ｏ)
〈アンロードログファイルの場合〉
正しいアンロードログファイルを指定して，実行してください。データベース初期設定前後のアンロードログファイルを混在して指定しているときは，初期設定前，又は初期設定後のアンロードログファイルだけを指定して，再度実行してください。
〈システムログファイルの場合〉
データベース初期設定後のバックアップファイルを指定して，再度実行してください。
KFPR16304-E
Dynamic load error occurred, shared library=aa....aa　　（Ｌ＋Ｓ）
処理に必要な共用ライブラリの動的ロードでエラーが発生しました。
aa....aa：共用ライブラリの絶対パス名
(Ｓ)処理を終了します。
(Ｏ)このメッセージの前に出力されたKFPR26203-Eメッセージを参照して，次の観点で原因を取り除き再度実行してください。
〈EasyMTを使用する場合〉
インストールが正しくできているか調査してください。
〈EasyMTを使用しない場合〉
-kオプションフラグの指定を見直して，EasyMT又はMTguideを使用しない指定にしてください。
KFPR16308-E
Present directory information conflicts with directory information specified when the backup file was made, RDAREA name="aa....aa", code=b　　（Ｌ＋Ｓ）
バックアップファイルを作成するときのディレクトリ情報と，今回のディレクトリ情報の矛盾を検知しました。このため，該当する物理エリアの回復処理を中断します。
aa....aa：不一致となったRDエリア名
b：エラーコード
1：ページ長が一致しません。
2：RDエリアの属性が一致しません。
3：HiRDBファイル名称が一致しません。
4：RDエリア名が一致しません。
5：セグメントサイズが一致しません。
6：RDエリアの構成とHiRDBファイルの数が一致しません。
(Ｓ)矛盾を検知したRDエリアの回復処理をしないで，次のRDエリアを処理します。
[対策]正しいバックアップファイルに交換して，再度実行してください。又は，ディレクトリ若しくはファイルの変更後に取得したバックアップを使用して，再度実行してください。
KFPR16318-E
Backup data not found, RDAREA name="aa....aa"　　（Ｌ＋Ｓ）
指定されたバックアップファイルには，該当するRDエリアのバックアップはありません。
aa....aa：バックアップデータのないRDエリア名
(Ｓ)該当するRDエリアは，バックアップデータを使用しないで回復します。アンロードログファイルの指定があり，該当するRDエリアの更新ログがあれば，ログだけを使用して回復します。ただし，-Lオプションが指定されている場合，処理を中断します。
[対策]次の内容を確認して，誤りを修正して再度実行してください。
・データベース回復ユティリティを実行する前にこのRDエリアが回復できる状態になっているか確認してください。
・バックアップファイルを正しく指定しているか確認してください。
・-Lオプションを指定している場合，pdcopy実行時に，-zオプションを指定して作成したバックアップファイルに回復対象のRDエリアがあるか確認してください。
KFPR16328-E
aa....aa error occurred, func=bb....bb, return code=cc....cc　　（Ｅ＋Ｌ）
ほかのプログラムプロダクトの機能でエラーが発生しました。
aa....aa：プログラムプロダクトの名称
・SORT（ソートプログラム）
・EasyMT
・OmniBack II（JP1/OmniBack II）
bb....bb：エラーが発生した関数名
cc....cc：エラーが発生した関数のリターンコード
(Ｓ)処理を終了します。
ただし，OmniBack IIのリターンコードが1，2，4の場合は異常終了します。
[対策]次に示すマニュアルを参照して，エラーの原因を取り除き再度実行してください。
・SORT
マニュアル「ソートマージ」を参照してください。なお，KBLSnnn-Eのnnnにエラーコードの絶対値をあてはめて原因を調査してください。
・EasyMT
マニュアル「磁気テープ運用支援 JP1/Magnetic Tape Access」，又はマニュアル「磁気テープ簡易アクセス法 EasyMT」を参照してください。これらのマニュアルに記述されていない場合，又は記載されている情報では対処できない場合，保守員に連絡してください。
・OmniBack II
リターンコードに合わせて対策してください。
1，2，4の場合は，保守員に連絡してください。
3，5～7の場合は，エラーになったJP1/OmniBack IIのセッションIDからomnidb -sessionセッションID -reportをして，エラー原因を調査してください。又は，xomnimonitorを使ってエラー原因を調査してください。セッションIDは，omnidb -sessionで表示されるセッションIDの一覧から探してください。
エラー原因の調査方法については，JP1/OmniBack IIのマニュアルを参照してください。
リターンコード3，5～7の意味は次のとおりです。
リターンコード
意味
３
関数が現在の操作モードに該当しません。エラーになった関数名が OB2_Initの場合，バックグラウンドで動作しているJP1/OmniBack IIのセッションをomnistatコマンドで調査し，そのセッションが完了するまで待って再度実行してください。
５
JP1/OmniBack IIの内部エラーによって操作が失敗しました。
６
システムエラーによって操作が失敗しました。
７
JP1/OmniBack IIのサービスについての権限が不足しています。
エラーになった関数名がOB2_Initの場合，HiRDB管理者をJP1/OmniBack IIのユーザとしてadminユーザクラスに登録してください。
KFPR16329-E
EasyMT error occurred, func=aa....aa, reason=bb....bb　　（Ｌ＋Ｓ）
EasyMTを使用したファイル入出力処理でエラーが発生しました。
aa....aa：エラーを検知した関数
bb....bb：エラーの詳細情報
(Ｓ)処理を終了します。
[対策]エラーの詳細情報を参考に，マニュアル「磁気テープ運用支援 JP1/Magnetic Tape Access」，又はマニュアル「磁気テープ簡易アクセス法 EasyMT」を参照して，エラー原因を取り除き再度実行してください。
KFPR16330-E
Log was not found when backup aa....aa at bb....bb-cc....cc, server=dd....dd　　（Ｌ＋Ｓ）
バックアップモードに-M　sオプションを指定して取得したバックアップからの回復であるにもかかわらず，入力したログの回復に必要となる次のログレコードが含まれていません。
・最初のログレコード
・最後のログレコード
aa....aa：含まれていない日時
・started：複写取得開始時点
・ended：複写取得終了時点
bb....bb：ログレコード番号1
cc....cc：ログレコード番号2
dd....dd：回復対象のサーバ名称
(Ｓ)該当するサーバの回復処理を中断します。
[対策]回復に必要な最初のログレコード，又は最後のログレコードを含むログを指定した後，再度実行してください。
KFPR16333-E
RDAREA aa....aa at bb....bb, RDAREA name="cc....cc"　　（Ｌ＋Ｓ）
RDエリアcc....ccはaa....aaされています。このため，その日付よりも前に取得したバックアップからは，該当するRDエリアを回復できません。又は，バックアップファイルを指定していません。
aa....aa：RDエリアに対する操作
・added：RDエリアの追加
・deleted：RDエリアの削除
・extended：RDエリアの拡張
・initialized：再初期化
bb....bb：操作した日付及び時刻
cc....cc：操作したRDエリア名
(Ｓ)該当するRDエリアを回復しないで，次のRDエリアに対する回復処理を続行します。
[対策]操作後に取得した正しいバックアップファイルとログを使用してRDエリアを回復してください。操作後に取得したバックアップファイルがない場合は，-Ｔオプションの回復終了時刻にbb....bbより前の時刻を指定してRDエリアを回復してください。
KFPR16334-E
RDAREA was updated by logless process, RDAREA name="aa....aa", update time=bb....bb　　（Ｌ＋Ｓ）
該当するRDエリアは，bb....bbの時刻にシステムログを取得しないトランザクションで更新しています。このため，RDエリアを回復できません。
aa....aa：RDエリア名
bb....bb：更新時刻
(Ｓ)該当するRDエリアを回復しないで，次のRDエリアに対する回復処理を続行します。
[対策]システムログを取得しないトランザクションが終了後に取得したバックアップを指定して，再度実行してください。バックアップがない場合は，-Tオプションの回復終了時刻にbb....bbより前の時刻を指定してください。
KFPR16338-E
Master RDAREA is not initialized　　（Ｌ＋Ｓ）
マスタディレクトリ用RDエリアを初期化していません。又は，マスタディレクトリ以外のファイルを指定しました。エラーの原因を次に示します。
・データベース初期設定ユティリティ（pdinit）が正常終了していません。
・マスタディレクトリ以外のファイルを指定しました。
・マスタディレクトリの内容が破壊されています。
(Ｓ)処理を終了します。
[対策]エラーの原因を取り除き，マスタディレクトリ用RDエリアを正常な状態にした後，再度実行してください。
KFPR16339-E
Invalid backup file, file=aa....aa　　（Ｌ＋Ｓ）
指定されたバックファイルが不正です。次に示す内容を確認してください。
・マルチボリューム指定時に，正しいボリュームを指定しているか
・マルチファイル指定時に，正しいファイルを指定しているか
aa....aa：不正である内容
〈MTguideを使用している場合〉
装置記号名，又は装置グループ名
〈MTguideを使用していない場合〉
ファイル名
(Ｓ)処理を終了します。
[対策]正しいバックアップファイルを入力して，再度実行してください。
KFPR26001-E
Communication "aa....aa" error occurred, code=bbbbb　　（Ｌ＋Ｓ）
データベース複写ユティリティ（pdcopy）の実行中に通信エラーが発生しました。
aa....aa：エラーが発生したRPC関連関数の名称
bbbbb：エラーが発生したRPC関連関数のエラーコード
(Ｓ)処理を終了します。
[対策]「エラー詳細コード一覧」を参照してエラーの原因を取り除き，再度実行してください。なお，HiRDB管理者が対処できないエラーが発生している場合は，保守員に連絡してください。
KFPR26002-E
Unable to allocate COMBUF area, size=aaaaaa　　（Ｌ＋Ｓ）
通信用の領域がエリア不足のため確保できません。実メモリ，又は仮想メモリが不足しました。システム共通定義のpdsysファイルでpd_combuf_hardware=Nを指定した場合，又は指定を省略した場合は，仮想メモリが不足しています。
aaaaaa：確保しようとした通信用の領域サイズ（単位：キロバイト）
(Ｓ)処理を終了します。
[対策]
1. メモリを大量に使用するプロセスの終了を待って，再度コマンドを実行してください。
2. システム共通定義のバッファサイズ（pd_utl_buff_sizeオペランド）を32よりも大きい値を指定している場合は，32を指定して，再度コマンドを実行してください。
KFPR26003-E
System call error, func=aa....aa, errno=bbb　　（Ｌ＋Ｓ）
システムコールでエラーが発生しました。
aa....aa：エラーが発生したシステムコール名称
bbb：エラーが発生したシステムコールのerrno
(Ｓ)処理を終了します。
[対策]エラーインジケータの値を調査して，errno.h及びユーザが使用しているOSのマニュアルを参照してエラーの原因を取り除き，再度実行してください。
KFPR26004-I
Error exists in command line or control file, usage is as follows　　（Ｅ）
指定されたコマンド，又は制御文ファイルの指定に誤りがあります。このメッセージの後に使用方法を出力します。
(Ｓ)処理を終了します。
(Ｏ)コマンド，又は制御文ファイルの誤りを修正して，再度実行してください。
KFPR26005-E
Invalid option flag exists in command line　　（Ｌ＋Ｓ）
コマンドラインの中に不正なオプションフラグがあります。
(Ｓ)コマンドラインの解析終了後，処理を中断します。
[対策]コマンドラインの指定を修正し，再度実行してください。
KFPR26006-E
Invalid parameter aa....aa exists at -b option in command line　　（Ｌ＋Ｓ）
コマンドラインのオプション中に不正なパラメタがあります。リスト用RDエリアの場合は，複写・回復の対象になりません。
aa....aa：不正なパラメタ
b：オプション名
(Ｓ)コマンドラインの解析終了後，処理を中断します。ただし，次の条件をすべて満たす場合は処理を続行します。
・-Jオプション及び-rオプションを指定している。
・KFPR26061-Wメッセージが出力されている。
[対策]コマンドラインの指定を修正し，再度実行してください。
JP1/OmniBackIIと連携してデータベース複写ユティリティ（pdcopy）を使用する場合，不正なパラメタとして-k oが表示されたときは，pdsetupをし直してください。pdsetupでは，-pオプションにOmniBackパラメタを指定してください（pdsetup -p OmniBack）。
KFPR26007-E
Duplicate aa....aa at -b option in command line　　（Ｌ＋Ｓ）
コマンドラインのオプション中の指定が重複しています。
aa....aa：重複しているコマンド名称
b：オプション名
(Ｓ)コマンドラインの解析終了後，処理を終了します。
[対策]コマンドラインの指定を修正し，再度実行してください。
KFPR26008-E
Invalid combination of option flags(-a and -b) exists in command line　　（Ｌ＋Ｓ）
コマンドライン中に不正なオプションフラグの組み合わせがあります。
a：組み合わせが不正なオプションフラグ
b：組み合わせが不正なオプションフラグ
(Ｓ)コマンドラインの解析終了後，処理を終了します。
[対策]コマンドラインの指定を修正し，再度実行してください。
KFPR26009-E
Option flag -a is not specified in command line　　（Ｌ＋Ｓ）
コマンドライン中に必要なオプションフラグの指定がありません。
a：必要なオプションフラグ
(Ｓ)コマンドラインの解析終了後，処理を終了します。
[対策]コマンドラインの指定を修正し，再度実行してください。
KFPR26010-E
Too long parameter exists at -a option in command line　　（Ｅ＋Ｌ）
コマンドライン中のオプションで，パラメタの指定が長過ぎます。
a：オプション名
(Ｓ)コマンドラインの解析終了後，処理を終了します。
[対策]コマンドラインの指定を修正し，再度実行してください。
KFPR26011-E
Number of -a option flag in a control file exceeds bb　　（Ｅ＋Ｌ）
制御文ファイル中の-aオプションフラグの数が，上限値bbを超えています。
a：上限値を超えて指定したオプション名
bb：-aオプションフラグの上限値
(Ｓ)コマンドラインの解析終了後，処理を終了します。
[対策]コマンドラインの指定を修正し，再度実行してください。
KFPR26012-E
HiRDB file aa....aa error, errno=bb....bb, HiRDB file name=cc....cc　　（Ｌ＋Ｓ）
cc....ccで示すファイルに，aa....aaのエラーが発生しました。
aa....aa：エラーの内容
close：ファイルのクローズ
create：ファイルの作成
fstat：ファイル情報の取得
open：ファイルのオープン
read：ファイルの読み込み
write：ファイルの書き込み
expand：ファイルの拡張
reopen：マルチファイル時の二つ目のファイル以降のオープン
bb....bb：エラーコード
0：要求したサイズの読み出し又は書き込みができませんでした。
0以外：「HiRDBファイルシステムに対するアクセス要求から返されるエラーコード」を参照してください。
cc....cc：エラーの発生したファイル名
(Ｓ)バックアップ用のファイルの場合は，処理を中断します。ただし，ほかのバックアップファイルがある場合，又は次の条件をすべて満たす場合は処理を続行します。
・該当するファイルが，RDエリアを構成するHiRDBファイルである。
・-Jオプションを指定している。又は，RDエリアがレプリカRDエリアである。
・エラーの内容がopen又はcloseである。
・KFPR26061-Wメッセージが出力されている。
・ほかに処理されていないRDエリアがある。
[対策]
〈ファイルがデータベース用の場合〉
該当するRDエリアを回復して，再度実行してください。
〈ファイルがバックアップ用の場合〉
「HiRDBファイルシステムに対するアクセス要求から返されるエラーコード」を参照して，エラーの原因を取り除き，再度実行してください。
エラーコードが-1556又は-1562の場合は，次の要因が考えられます。
エラー
コード
要因
-1556
HiRDBファイルが初期割り当てサイズを超えたため，増分割り当てサイズで拡張しようとしたが失敗しました。
・該当するHiRDBファイルシステム領域の増分回数指定（pdfmkfs実行時-eを指定）を超えて拡張しようとしました。
・該当するHiRDBファイルが，上限（23回）を超えて拡張しようとしました。
-1562
該当するHiRDBファイルシステム領域の種別がUTLではありません。
原因が特定できない場合には，保守員に連絡してください。
KFPR26015-E
Unable to backup RDAREA at inactive server aa....aa　　（Ｌ＋Ｓ）
停止状態のサーバにあるRDエリアは，次の指定をした場合，バックアップは取得できません。
・-M sオプションを指定している場合
・-z指定がある場合
aa....aa：停止状態のサーバ名
(Ｓ)該当するサーバに含まれるRDエリアが複写対象の場合は，処理を終了します。ただし，ほかのバックアップファイルがある場合，又は次の条件をすべて満たす場合は処理を続行します。
・-Jオプションを指定している。
・KFPR26061-Wメッセージが出力されている。
・ほかに処理されていないRDエリアがある。
[対策]停止状態のサーバを開始して再度実行してください。又は，-M xオプションを指定してバックアップを取得してください。
KFPR26016-E
Too many backup RDAREAs for backup file aa....aa　　（Ｌ＋Ｓ）
バックアップファイルaa....aaに取得するRDエリアの数が多過ぎます。一つのバックアップに取得できるRDエリアは最大1120個です。
aa....aa：バックアップファイル名
(Ｓ)処理を終了します。
(Ｏ)該当するバックアップファイルに取得するRDエリア数を1120個以下にして，再度実行してください。
KFPR26017-E
Insufficient memory in message buffer pool due to concurrent execution of "pdcopy"　　（Ｌ＋Ｓ）
pdcopyを同時実行するときに，ユティリティサーバ用のメッセージ格納バッファプールのメモリが，一時的に不足しました。なお，該当するエラーの発生に伴って，KFPS00854-Wが出力されることがあります。しかし，この場合は，サーバ障害ではありません。
(Ｓ)処理を終了します。
(Ｏ)現在実行中のpdcopyの実行完了後，再度実行してください。
KFPR26018-E
Unable to send message from aa....aa to bb....bb　　（Ｌ＋Ｓ）
通信エラーが発生したため，ホストaa....aaからホストbb....bbへデータを送れません。
aa....aa：送信元ホスト名
系切り替え機能を使用している場合，現用系のホスト名です。
bb....bb：送信先ホスト名
系切り替え機能を使用している場合，現用系のホスト名です。
(Ｓ)通信エラーが発生したバックアップファイルの処理を中断します。
[対策]このメッセージの前に出力された，KFPR26001-Eメッセージの処置に従ってください。ただし，物理的な通信エラーが発生していないときは，システム定義で，ホスト間の関係に矛盾があると考えられます。このため，エラーが発生したホスト間の定義を見直して，再度実行してください。
KFPR26020-E
System manager "aa....aa" failed, return code=bb....bb　　（Ｌ＋Ｓ）
システム関連のaa....aa関数エラーが発生しました。
aa....aa：エラーが発生したシステム関連関数の名称
bb....bb：エラーが発生したシステム関連関数のエラーコード
(Ｓ)処理を終了します
[対策]「エラー詳細コード一覧」を参照してエラーの原因を取り除き，再度実行してください。なお，HiRDB管理者が対処できないエラーが発生している場合は，保守員に連絡してください。
KFPR26021-E
Unable to output result of pdcopy　　（Ｌ＋Ｓ）
このメッセージの前に出力されたエラーが原因で，データベース複写ユティリティ（pdcopy）の処理結果を出力できません。
(Ｓ)処理を終了します。
[対策]エラーの原因を取り除き，再度実行してください。ただし，ほかのエラーが発生していないときは，バックアップ処理は終了しています。このため，実行結果が不要の場合は再実行する必要はありません。
KFPR26022-I
Output result of pdcopy to aa....aa　　（Ｌ＋Ｓ）
データベース複写ユティリティ（pdcopy）の処理結果をファイルaa....aaに出力します。
aa....aa：出力するファイル名
(Ｓ)処理を終了します。
KFPR26023-I
Unable to output result of backup file aa....aa　　（Ｌ＋Ｓ）
このメッセージの前に出力されたエラーが原因で，バックアップファイルaa....aaの処理結果を出力できません。
aa....aa：バックアップファイル名
(Ｓ)処理を終了します。
[対策]エラーの原因を取り除き再度実行してください。ただし，バックアップファイルに対し，KFPR26109メッセージが出力されている場合は，バックアップ処理が終了しています。このため，実行結果が不要の場合は再実行する必要はありません。
KFPR26024-E
Unable to remove shared memory, key=aa....aa　　（Ｌ＋Ｓ）
共用メモリを削除できません。
aa....aa：共用メモリキー値
(Ｓ)処理を続行します。
[対策]処理終了後，コマンドで共用メモリを削除してください。
KFPR26025-E
No RDAREA to copy on aa....aa　　（Ｌ＋Ｓ）
バックアップファイルaa....aaには，複写の対象となるRDエリアがありません。
aa....aa：バックアップファイル名
(Ｓ)処理を終了します。ただし，次の条件をすべて満たす場合は処理を続行します。
・-Jオプションを指定している。
・制御文ファイル中に複数の行を指定している。
[対策]コマンドラインの指定を修正し，再度実行してください。
KFPR26026-E
Unable to copy RDAREA's of different servers with -z option　　（Ｌ＋Ｓ）
-zオプションを指定した場合，異なるサーバ下のRDエリアのバックアップを同時に取得できません。
(Ｓ)処理を終了します。
[対策]バックアップを取得するRDエリアを一つのサーバ下のものだけにして，再度実行してください。
KFPR26027-E
Unable to output Log point information　　（Ｌ＋Ｓ）
このメッセージの前に出力されたエラーが原因で，ログポイント情報を出力できません。
(Ｓ)処理を終了します。
[対策]エラーの原因を取り除き，pdrstrで今回作成したバックアップファイルを入力し，-zオプションを指定してログポイント情報ファイルを再作成してください。
KFPR26028-I
Output Log point information to aa....aa　　（Ｌ＋Ｓ）
ログポイント情報をログポイント情報ファイルaa....aaに出力しました。
(Ｓ)処理を続行します。
KFPR26029-I
Log point information, (aa...aa, bb....bb, ccc, dd....dd, ee....ee, ff....ff, gg....gg, hh....hh, ii....ii, jj....jj, kk....kk)　　（Ｌ＋Ｓ）
ログポイントを設定しました。
aa....aa：HiRDB識別子
bb....bb：ユニット識別子
ccc：ログファイル名
sys：システムログファイル
dd....dd：サーバ名
ee....ee：サーバランID（16進8けた）
ff....ff：ログサーバランID（16進8けた）
gg....gg：先頭ファイルグループ名
hh....hh：先頭ファイルグループ世代番号（16進8けた以内）
ii....ii：先頭ブロック番号（16進8けた以内）
jj....jj：ヘッダ更新回数（16進8けた以内）
kk....kk：使用開始時刻（16進8けた）
(Ｓ)処理を続行します。
KFPR26030-E
Unable to use -M s option to RDAREA for BLOB column with recovery partial or no, RDAREA name=aa....aa　　（Ｌ＋Ｓ）
該当するLOB列が格納されているRDエリアは，CREATE TABLEのLOB列の定義でrecovery partial又はrecovery noを指定しているため，-M sオプションは使用できません。
aa....aa：エラーの原因となったRDエリア名
(Ｓ)該当するRDエリアが複写対象の場合は，処理を終了します。ただし，ほかのバックアップファイルがある場合，又は次の条件をすべて満たす場合は処理を続行します。
・-Jオプションを指定している。
・KFPR26061-Wメッセージが出力されている。
・ほかに処理されていないRDエリアがある。
(Ｏ)-M x又は-M rを指定して再度実行してください。
KFPR26031-E
Unable to output message to standard output, host=aa....aa, file=bb....bb, func=cc....cc, errno=ddd　　（Ｌ）
システムコールでエラーが発生したため，メッセージを標準出力に出力できません。
aa....aa：エラーの原因となったファイルがあるホスト名
bb....bb：エラーの原因となったファイル名
エラーが発生したシステムコール名称がtempnamの場合，******が表示されます。
cc....cc：エラーが発生したシステムコール名称
systemの場合，括弧内に実行したシェルコマンド名を入れて表示されます。
ddd：エラーが発生したシステムコールのerrno
(Ｓ)処理を続行します。
(Ｏ)エラーインジケータの値を調査し，errno.h及びユーザが使用しているOSのマニュアルを参照して，エラーの原因を取り除いてください。
KFPR26032-E
Unable to remove temporary file, host=aa....aa, file=bb....bb　　（Ｌ）
このメッセージの前に出力されたエラーが原因で，一時ファイルを削除できません。
aa....aa：削除できないファイルがあるホスト名
bb....bb：削除できないファイル名
(Ｓ)処理を続行します。
(Ｏ)処理が終了した後，一時ファイルを削除してください。
KFPR26033-E
Pdcopy must be executed at unit defined as manager　　（Ｌ＋Ｓ）
データベース複写ユティリティ（pdcopy）は，システムマネジャが定義されているユニットで実行してください。
(Ｓ)処理を終了します。
(Ｏ)システムマネジャ（MGR）が定義されているユニットにリモートログインして，再度コマンドを実行してください。
KFPR26045-I
OmniBack II backup session id=aa....aa　　（Ｅ＋Ｌ）
セッションIDがaa....aaのセッションでバックアップを取得しました。
aa....aa：JP1/OmniBack IIのセッションID
(Ｓ)処理を続行します。
KFPR26047-I
OmniBackII Information = aa....aa　　（Ｅ＋Ｌ）
JP1/OmniBack IIのメッセージ情報を出力します。
aa....aa：JP1/OmniBack IIのメッセージ情報
メッセージ情報が180文字を超える場合は，先頭から180文字を出力します。
(Ｓ)処理を終了します。
[対策]JP1/OmniBack IIのメッセージ情報の内容については，JP1/OmniBack IIのマニュアルを参照してください。
KFPR26048-E
OmniBackII file not found,host=aa....aa file=bb....bb　　（Ｅ＋Ｌ）
ホストaa....aaにJP1/OmniBack IIのファイルbb....bbがありません。そのため，データベース複写ユティリティ（pdcopy）を実行できません。
aa....aa：ホスト名
bb....bb：ファイル名
(Ｓ)処理を終了します。
[対策]aa....aaのホストにJP1/OmniBack IIのディスクエージェントがインストールされているか確認してください。インストールされていない場合は，インストールしてください。インストールされている場合は，保守員に連絡してください。
KFPR26049-E
Unable to check OmniBackII file,host=aa....aa　　（Ｅ＋Ｌ）
このメッセージの前に出力されたメッセージを参照してください。そこで説明しているエラーが原因で，ホストaa....aaのJP1/OmniBack IIのファイルの確認に失敗しました。そのため，データベース複写ユティリティ（pdcopy）を実行できません。
aa....aa：ホスト名
(Ｓ)処理を終了します。
[対策]このメッセージの前に出力されたメッセージの対策を参照してエラーの原因を取り除いてください。その後，ユティリティを再度実行してください。
KFPR26051-E
Unable to output history of backup group=aa....aa　　（Ｌ＋Ｓ）
差分バックアップグループaa....aaの履歴情報を出力できませんでした。エラーの原因についてはこのメッセージの前に出力されたメッセージを参照してください。
aa....aa：差分バックアップグループ名
(Ｓ)処理を終了します。
[対策]エラーの原因を取り除いて再度実行してください。ただし，差分バックアップ管理ファイルに対してKFPR26053-I又はKFPR26058-Iメッセージが出力されている場合は，バックアップ処理が終了しているため，履歴情報が不要ならば再度実行する必要はありません。
KFPR26052-I
Output history of backup group=aa....aa to bb....bb　　（Ｌ＋Ｓ）
差分バックアップグループaa....aaの履歴情報ファイル（ファイル名：bb....bb）を出力します。
aa....aa：差分バックアップグループ名
bb....bb：差分バックアップの履歴情報ファイル名
(Ｓ)処理を続行します。
KFPR26053-I
Create management file=aa....aa　　（Ｌ＋Ｓ）
差分バックアップ管理ファイルaa....aaを作成しました。
aa....aa：差分バックアップ管理ファイル名
(Ｓ)処理を続行します。
KFPR26054-E
Unable to use management file, reason=aa....aa, name=bb....bb　　（Ｌ＋Ｓ）
差分バックアップ管理ファイルbb....bbを使用できません。
aa....aa：理由
unfinish maintenance：メンテナンスが未完了です。
no control block：差分バックアップ管理ファイルの制御情報がありません。
bb....bb：差分バックアップ管理ファイル名
(Ｓ)処理を終了します。
[対策]次に示すどちらかの処置をしてください。
・メンテナンスが未完了の場合
差分バックアップ管理ファイルのバックアップがある場合は，pdfrstrコマンドで差分バックアップ管理ファイルを回復して，再度実行してください。差分バックアップ管理ファイルのバックアップがない場合は，pdcopyコマンドでフルバックアップを取得してください。このとき，差分バックアップ管理ファイルを作成する指定をしてください（-gオプションに指定する差分バックアップグループ名に(S)を指定してください）。
・差分バックアップ管理ファイルの制御情報がない場合
pdcopyコマンドの-gオプションと-Kオプションの指定に誤りがあります。再度，差分バックアップを取得してください。
KFPR26055-E
Page corrupted, management file name=aa....aa, page number=bb....bb　　（Ｅ＋Ｌ）
差分バックアップ管理ファイルaa....aaのページ破壊を検知しました。
aa....aa：差分バックアップ管理ファイル名
bb....bb：ページ破壊を検知したページ番号
(Ｓ)処理を終了します。
[対策]差分バックアップ管理ファイルのバックアップがある場合は，pdfrstrコマンドで差分バックアップ管理ファイルを回復して，再度実行してください。差分バックアップ管理ファイルのバックアップがない場合は，pdcopyコマンドでフルバックアップを取得してください。このとき，差分バックアップ管理ファイルを作成する指定をしてください（-gオプションに指定する差分バックアップグループ名に(S)を指定してください）。
KFPR26056-E
SystemID of aa....aa is invalid　　（Ｌ＋Ｓ）
aa....aaのシステムIDが稼働中のHiRDBと一致しないため，このファイルを使用できません。
aa....aa：ファイル種別
management file：差分バックアップ管理ファイル
(Ｓ)処理を終了します。
[対策]pdcopyコマンドの-gオプションと-Kオプションの指定に誤りがあります。再度，差分バックアップを取得してください。
KFPR26057-I
Update start, management file=aa....aa　　（Ｌ＋Ｓ）
差分バックアップ管理ファイルaa....aaの更新を開始しました。
aa....aa：差分バックアップ管理ファイル名
(Ｓ)処理を続行します。
KFPR26058-I
Update complete, management file=aa....aa　　（Ｌ＋Ｓ）
差分バックアップ管理ファイルaa....aaの更新が終了しました。
aa....aa：差分バックアップ管理ファイル名
(Ｓ)処理を続行します。
KFPR26059-E
Too many lines for control file　　（Ｌ＋Ｓ）
制御文ファイル中のコマンドラインの数が多過ぎます。
(Ｓ)処理を終了します。
[対策]制御文ファイル中の記述を修正してください。差分バックアップ機能を使用している場合は，制御文ファイル中に記述するコマンドラインを1行にしてください。-a又は-qオプションを指定する場合は，制御文ファイル中に記述するコマンドラインを1行にしてください。
KFPR26060-I
Backup all used page, RDAREA name=aa....aa, LSN=bb....bb, differential base LSN=cc....cc　　（Ｌ＋Ｓ）
差分バックアップの差分管理情報を取得できなかったため，このRDエリアの全使用ページのバックアップを取得します。このバックアップはデータベースの回復時に使用できます。
aa....aa：RDエリア名
bb....bb：内部情報1
cc....cc：内部情報2
(Ｓ)処理を続行します。
KFPR26061-W
Unable to backup RDAREA. RDAREA name=aa....aa　　（Ｌ＋Ｓ）
aa....aaのバックアップを取得できませんでした。
aa....aa：RDエリア名
(Ｓ)処理を続行します。
[対策]aa....aaのRDエリアが複写対象外であれば，特に対策する必要はありません。複写対象であれば，このメッセージの前後に出力されているメッセージを基にエラー要因を取り除いて，再度実行してください。
KFPR26062-W
Unable to find RDAREA. RDAREA name=aa....aa, generation number=bb　　（Ｌ＋Ｓ）
指定した世代番号のRDエリアが見付かりません。このRDエリアのバックアップ取得処理をスキップします。
aa....aa：RDエリア名
bb：世代番号
(Ｓ)処理を続行します。
[対策]指定したRDエリア名称及び世代番号を見直してください。バックアップが必要の場合は，RDエリア名称及び世代番号を修正して再度実行してください。バックアップが必要ない場合はこのメッセージを無視してください。
KFPR26063-I
Buckup partially ended, file=aa....aa　　（Ｌ＋Ｓ）
バックアップファイルaa....aaが作成されました。バックアップ取得中にエラーとなったRDエリアはスキップしました。
aa....aa：バックアップファイル名
(Ｓ)処理を続行します。
[対策]処理をスキップしたRDエリアが，バックアップとして必要かどうかを確認してください。必要な場合は，エラー要因を取り除いて再度実行してください。
KFPR26066-E
Unable to use the "-k n" option because the JP1/VERITAS NetBackup Agent for HiRDB license not found　　（Ｌ＋Ｓ）
JP1/VERITAS NetBackup Agent for HiRDBのライセンスがないため，-k nは指定できません。
(Ｓ)処理を終了します。
[対策]JP1/VERITAS NetBackup Agent for HiRDBのライセンスを，NetBackupマスタサーバに登録してください。
KFPR26067-E
Dynamic load error occurred, shared library=aa....aa, host=bb....bb　　（Ｌ＋Ｓ）
ホストbb....bbにある共用ライブラリaa....aaの動的ローディングが失敗しました。
aa....aa：共用ライブラリのファイルパス名
bb....bb：ホスト名
(Ｓ)処理を終了します。
[対策]NetBackupクライアントがインストールされているかどうかを確認してください。インストールされている場合は，直前に出力されているKFPR26003-Eメッセージを参照しエラー原因を取り除いて，再度実行してください。
KFPR26069-E
NetBackup API error occurred, return code=aa....aa(bbbb), func=cc....cc, message=dd....dd　　（Ｌ＋Ｓ）
NetBackupのAPIでエラーが発生しました。
aa....aa：NetBackupのAPIリターンコードの名称
bbbb：NetBackupのAPIリターンコード（16進数）
cc....cc：NetBackupのAPI名
dd....dd：NetBackupのAPIエラーリターン直後に取得したメッセージ（100文字を超える場合は先頭から100文字を表示）
(Ｓ)処理を終了します。
[対策]
リターンコード（bbbb）
リターンコード名（aa....aa）
意味
処置
0x03
SYSTEM_ERROR
NetBackup内部エラー
NetBackup管理コンソールでエラー原因を調査し，対策した後に再度実行してください。
0x0D
FEATURE_NOT_LICENSED
ライセンスがない，又はライセンスが不正
ライセンスを取得してください。
0x4B
VERSION_NOT_SUPPORTED
NetBackupが未サポートバージョン
NetBackupのバージョンが正しいか確認してください。
0x4D
ACCESS_FAILURE
オブジェクトにアクセスできない
NetBackupマスタサーバ，又はNetBackupメディアサーバが停止していないか確認してください。停止していない場合は保守員に連絡してください※。
上記以外
－
－
保守員に連絡してください※。
（凡例）－：該当しません。
注※
保守員に連絡する場合，次の資料を取得しておいてください。
・シングルサーバ又はシステムマネジャがあるホスト，-bオプションで指定したホスト，及びユティリティ実行時に対象となるRDエリアがあるホストのシステムログファイル
・シングルサーバ又はシステムマネジャがあるホスト，-bオプションで指定したホスト，及びユティリティ実行時に対象となるRDエリアがあるホストの$PDDIR/spool下のファイル
・NetBackup管理コンソールからのエラー情報
・標準出力，標準エラー出力に出力されたメッセージ
・ユティリティ実行時の処理結果出力ファイル
KFPR26071-I
NetBackup information, policy=aa....aa, date=bb....bb, time=cc....cc　　（Ｌ＋Ｓ）
ポリシー名aa....aaでバックアップを取得します。
aa....aa：ポリシー名
bb....bb：日付（YYYY/MM/DD）
cc....cc：時刻（HH:MM:SS）
(Ｓ)処理を続行します。
KFPR26072-E
Invalid time stamp found, RDAREA name=aa....aa, file name=bb....bb, offset=cc....cc, time stamp=(dd....dd,ee....ee)　　（Ｌ＋Ｓ）
ページ内タイムスタンプが不正であるページを見付けました。
aa....aa：RDエリア名
bb....bb：HiRDBファイル名。後から64バイトを表示します。
cc....cc：タイムスタンプが不正であるページの，HiRDBファイルの先頭からの相対レコード位置。10進数で表示します。
dd....dd：ページ先頭にあるタイムスタンプ。日時形式YYYY/MM/DD HH:MM:SSに変換して表示します。
ee....ee：ページ後尾にあるタイムスタンプ。日時形式YYYY/MM/DD HH:MM:SSに変換して表示します。
(Ｓ)処理を終了します。
[対策]
〈参照更新可能モード（pdcopy -Ms）でバックアップを取得している場合〉
バックアップ対象ページが出力中のためバックアップ取得できません。次のどれかの対策を行ってください。
・pdlogsync -wコマンドを実行後，再度実行してください。
・更新可能バックアップ閉塞（pdhold -b -u）を行って，再度実行してください。
・参照可能モード（pdcopy -Mr）又は参照更新不可モード（pdcopy -Mx）で再度実行してください。
〈参照可能モード（pdcopy -Mr）／参照更新不可モード（pdcopy -Mx）でバックアップを取得している場合〉
表示されたRDエリアの領域が壊れています。前回取得したバックアップを使用して回復する必要があります。
KFPR26073-E
Unable to backup shared RDAREA with -M s option, RDAREA name="aa....aa"
共用RDエリアのバックアップはpdcopy -M s指定（更新可能モード）で取得できません。
aa....aa：RDエリア名
(Ｓ)処理を終了します。
[対策]一度に共用RDエリアを含む複数のRDエリアのバックアップを取得する場合，更新可能モード以外のバックアップ取得モードを指定して，コマンドを再度実行してください。
複数回に分けてバックアップを取得する場合は，共用RDエリア以外のRDエリアだけを指定してコマンドを再度実行してください。共用RDエリアは，更新可能モード以外のバックアップ取得モードを指定してコマンドを再度実行してください。
KFPR26109-I
Backup completed, file=aa....aa　　（Ｌ＋Ｓ）
バックアップファイルaa....aaのデータベースのバックアップ処理が完了しました。
aa....aa：バックアップファイル名称
(Ｓ)処理を続行します。
KFPR26110-E
Invalid RDAREA status, RDAREA name="aa....aa"　　（Ｌ＋Ｓ）
該当するRDエリアの状態が不正です。このため，バックアップを取得できません。エラーの原因を次に示します。
・-M x指定ですが，該当するRDエリアがclose状態ではありません。
・該当するRDエリアは，ほかのユーザが使用中です。
・-M s指定の場合，ほかのユーザがページ解放を引き起こすSQLを実行していると，資源種別0152又は0004で競合が発生して，トランザクションが終了するまで排他待ちになることがあります。ページ解放を引き起こすSQLを次に示します。
・DROP TABLE
・DROP INDEX
・PURGE TABLE
・インデクスのある列に対するINSERT文又はUPDATE文
・インデクスがある列（重複キーあり）に対するDELETE文
・LOCK文を実行した後の，DELETE文又は行長が変わるUPDATE文
・LOB列に対するINSERT文，DELETE文，又はUPDATE文
aa....aa：RDエリア名
(Ｓ)該当するRDエリアが複写対象の場合は，処理を終了します。ただし，ほかのバックアップファイルがある場合，又は次の条件をすべて満たす場合は処理を続行します。
・-Jオプションを指定している。
・KFPR26061-Wメッセージが出力されている。
・ほかに処理されていないRDエリアがある。
[対策]該当するRDエリアをpdcloseコマンドでclose状態にして，再度実行してください。又は，ほかのユーザの処理が終了した後，再度実行してください。
KFPR26111-E
To copy Master RDAREA with -M x option, pdstart should be executed with -r option　　（Ｌ＋Ｓ）
-M x指定でマスタRDエリアのバックアップ取得時に，HiRDBシステムをpdstart -rで開始してください。
(Ｓ)処理を終了します。ただし，次の条件をすべて満たす場合は処理を続行します。
・-Jオプションを指定している。
・KFPR26061-Wメッセージが出力されている。
・ほかに処理されていないRDエリアがある。
(Ｏ)HiRDBシステムをpdstopコマンドで終了させて，pdstart -rで開始し直した後，再度実行してください。
KFPR26201-E
Communication "aa....aa" error occurred, code=bbbbb　　（Ｌ＋Ｓ）
データベース回復ユティリティ（pdrstr）の実行中に通信エラーが発生しました。
aa....aa：エラーが発生したRPC関連関数の名称
bbbbb：エラーが発生したRPC関連関数のエラーコード
(Ｓ)処理を終了します。
[対策]「エラー詳細コード一覧」を参照してエラーの原因を取り除き，再度実行してください。なお，HiRDB管理者が対処できないエラーが発生している場合は，保守員に連絡してください。
KFPR26202-E
Unable to allocate COMBUF area, size=aaaaaa　　（Ｌ＋Ｓ）
通信用の領域がエリア不足のため確保できません。実メモリ，又は仮想メモリが不足しました。
aaaaaa：確保しようとした通信用の領域サイズ（単位：キロバイト）
(Ｓ)処理を終了します。
[対策]
1. メモリを大量に使用するプロセスの終了を待って，再度コマンドを実行してください。
2. システム共通定義のバッファサイズ（pd_utl_buff_sizeオペランド）を32よりも大きい値を指定している場合は，32を指定して，再度コマンドを実行してください。
KFPR26203-E
System call error, func=aa....aa, errno=bbb　　（Ｌ＋Ｓ）
システムコールでエラーが発生しました。
aa....aa：エラーが発生したシステムコール名称
bbb：エラーが発生したシステムコールのerrno
(Ｓ)処理を終了します。
[対策]エラーインジケータの値を調査し，errno.h及びユーザが使用しているOSのマニュアルを参照して，エラーの原因を取り除き，再度実行してください。
KFPR26204-I
Error exists in command line or control file, usage is as follows　　（Ｅ）
指定されたコマンド，又は制御文ファイルの指定に誤りがあります。このメッセージの後にコマンドの使用方法を出力します。
(Ｓ)処理を終了します。
(Ｏ)コマンド，又は制御文ファイルの誤りを修正して，再度実行してください。
KFPR26205-E
Invalid option flag exists in command line　　（Ｌ＋Ｓ）
コマンドラインの中に不正なオプションフラグがあります。
(Ｓ)コマンドラインの解析終了後，処理を終了します。
[対策]コマンドラインの指定を修正し，再度実行してください。
KFPR26206-E
Invalid parameter aa....aa exists at -b option in command line　　（Ｌ＋Ｓ）
コマンドラインのオプション中に不正なパラメタがあります。リスト用RDエリアの場合は，複写・回復の対象になりません。
aa....aa：不正なパラメタ
b：オプション名
(Ｓ)コマンドラインの解析終了後，処理を終了します。
[対策]コマンドラインの指定を修正し，再度実行してください。
JP1/OmniBackIIと連携してデータベース回復ユティリティ（pdrstr）を使用する場合，不正なオプションのパラメタとして-k oが表示されたときは，pdsetupをし直してください。pdsetupでは，-pオプションにOmniBackパラメタを指定してください（pdsetup -p OmniBack）。
KFPR26207-E
Duplicate aa....aa at -b option in command line　　（Ｌ＋Ｓ）
コマンドラインのオプション中の指定が重複しています。
aa....aa：重複している指定名称
b：オプション名
(Ｓ)コマンドラインの解析終了後，処理を終了します。
[対策]コマンドラインの指定を修正し，再度実行してください。
KFPR26208-E
Invalid combination of option flag (-a and -bb....bb) exists in command line　　（Ｌ＋Ｓ）
コマンドライン中に不正なオプションフラグの組み合わせがあります。
a：組み合わせが不正なオプションフラグ
bb....bb：組み合わせが不正なオプションフラグ
組み合わせが不正なオプションフラグの後に"(in control file)"が出力されている場合は，コマンドライン中のオプションフラグと，制御文中のオプションフラグに不正な組み合わせがあることを示しています。
(Ｓ)コマンドラインの解析を終了後，処理を終了します。
[対策]コマンドライン，又は制御文の指定を修正して，再度実行してください。
KFPR26209-E
Option flag -aa....aa is not specified in command line　　（Ｌ＋Ｓ）
コマンドライン中に必要なオプションフラグがありません。
aa....aa：必要なオプションフラグ
必要なオプションフラグが選択項目の場合，選択候補がすべて出力されます。
(Ｓ)コマンドラインの解析を終了後，処理を終了します。
[対策]コマンドラインの指定を修正して，再度実行してくださいる。
KFPR26210-E
Too long parameter exists at -a option in command line　　（Ｌ＋Ｓ）
コマンドライン中のオプションでパラメタの指定が長過ぎます。
a：オプション名
(Ｓ)コマンドラインの解析終了後，処理を終了します。
[対策]コマンドラインの指定を修正し，再度実行してください。
KFPR26212-E
HiRDB file aa....aa error, errno=bb....bb, HiRDB file name=cc....cc　　（Ｌ＋Ｓ）
cc....ccで示すファイルに，aa....aaのエラーが発生しました。
aa....aa：エラーの内容
close：ファイルのクローズ
create：ファイルの作成
fstat：ファイル情報の取得
open：ファイルのオープン
read：ファイルの読み込み
write：ファイルの書き込み
expand：ファイルの拡張
reopen：マルチファイル時の二つ目のファイル以降のオープン
bb....bb：エラーコード
0：要求したサイズの読み出し又は書き込みができませんでした。
0以外：「HiRDBファイルシステムに対するアクセス要求から返されるエラーコード」を参照してください。
cc....cc：エラーの発生したファイル名
(Ｓ)
〈ファイルがデータベース用の場合〉
該当するRDエリアの回復処理をスキップして，ほかのRDエリアの回復処理を続行します。
〈ファイルがバックアップ用の場合〉
回復処理を中断します。
[対策]
〈ファイルがデータベース用の場合〉
該当するRDエリアのHiRDBファイルシステム領域を別に用意して，再度実行してください。
〈ファイルがバックアップ用の場合〉
ほかのバックアップファイルを用いて，再度実行してください。
エラーの内容がwriteで，エラーコードが0の場合は，OSのファイルシステムの容量不足が考えられます。エラーの内容がreadで，エラーコードが0の場合は，pdfmkfsコマンドで-iオプションを指定しないで作成したHiRDBファイルシステム領域のRDエリアに対して，ログだけ回復したときに発生する可能性があります。
原因が特定できない場合は保守員に連絡してください。
KFPR26215-E
Unable to recover RDAREA at inactive server aa....aa　　（Ｌ＋Ｓ）
停止状態のサーバにあるRDエリアは，-l，-L，又は-d指定で回復できません。
aa....aa：停止状態のサーバ名
(Ｓ)該当するサーバ下のRDエリアの回復処理を中断します。
[対策]停止状態のサーバを開始してから，再度実行してください。
KFPR26216-E
Too many RDAREAs for recovery　　（Ｌ＋Ｓ）
一度に回復するRDエリアの数が多過ぎます。一度に回復できるRDエリアは，1サーバ当たり最大1120個です。
(Ｓ)処理を終了します。
(Ｏ)回復するRDエリア数を1120個以下にして，再度実行してください。
KFPR26217-E
Insufficient memory in message buffer pool due to concurrent execution of "pdrstr"　　（Ｌ＋Ｓ）
pdrstrを同時実行するときに，ユティリティサーバ用のメッセージ格納バッファプールのメモリが，一時的に不足しました。なお，該当するエラーの発生に伴って，KFPS00854-Wが出力されることがあります。しかし，この場合は，サーバ障害ではありません。
(Ｓ)処理を終了します。
(Ｏ)現在実行中のpdrstrの実行完了後，再度実行してください。
KFPR26218-E
Unable to send message from aa....aa to bb....bb　　（Ｌ＋Ｓ）
通信エラーが発生したため，ホストaa....aaからホストbb....bbへデータを送れません。
aa....aa：送信元ホスト名
系切り替え機能を使用している場合，現用系のホスト名です。
bb....bb：送信先ホスト名
系切り替え機能を使用している場合，現用系のホスト名です。
(Ｓ)処理を終了します。
[対策]このメッセージの前に出力された，KFPR26201-Eメッセージの処置に従ってください。ただし，物理的な通信エラーが発生していないときは，システム定義で，ホスト間の関係に矛盾があると考えられます。このため，エラーが発生したホスト間の定義を見直して，再度実行してください。
KFPR26220-E
System manager "aa....aa" failed, return code=bb....bb　　（Ｌ＋Ｓ）
システム関連のaa....aa関数エラーが発生しました。
aa....aa：エラーが発生したシステム関連関数の名称
bb....bb：エラーが発生したシステム関連関数のエラーコード
(Ｓ)処理を終了します。
[対策]
〈エラーが発生したシステム関数の名称がpdi_omm_attachで，そのエラーコードが-144の場合〉
次のどちらかのおそれが考えられます。-mオプションに正しいホスト名称を指定して，再度実行してください。
・-mオプションでホスト名称を省略していて，指定したマスタディレクトリ用RDエリアがpdrstrコマンドを入力したサーバマシンにない。
・-mオプションで指定したホスト名称のサーバマシンにマスタディレクトリ用RDエリアがない。
〈そのほかの場合〉
「エラー詳細コード一覧」を参照してエラーの原因を取り除き，再度実行してください。なお，HiRDB管理者が対処できないエラーが発生している場合は，保守員に連絡してください。
KFPR26221-E
Unable to output result of pdrstr　　（Ｌ＋Ｓ）
このメッセージの前に出力されたエラーが原因で，データベース回復ユティリティの処理結果を出力できません。
(Ｓ)処理を終了します。
[対策]エラーの原因を取り除き，再度実行してください。ただし，ほかのエラーが発生していないときは，回復処理が終了しているため，実行結果が不要な場合，再度実行する必要はありません。
KFPR26222-I
Output result of pdrstr to aa....aa　　（Ｌ＋Ｓ）
データベース回復ユティリティの処理結果をファイルaa....aaに出力します。
aa....aa：出力するファイル名称
(Ｓ)処理を続行します。
KFPR26224-E
Unable to remove shared memory, key=aa....aa　　（Ｌ＋Ｓ）
共用メモリを削除できません。
aa....aa：共用メモリのキー値
(Ｓ)処理を続行します。
[対策]処理を終了した後，コマンドで共用メモリを削除してください。
KFPR26225-E
No RDAREA to restore　　（Ｌ＋Ｓ）
回復の対象となるRDエリアがありません。
(Ｓ)処理を終了します。
[対策]コマンドラインを修正して，再度実行してください。
KFPR26226-E
SystemID of aa....aa is invalid　　（Ｌ＋Ｓ）
aa....aaのシステムIDが稼働中のHiRDBと一致していません。このため，データベースを回復できません。
aa....aa：ファイル種別
backup file：バックアップファイル
sys log file：システムログファイル
unload log file：アンロードログファイル
management file：差分バックアップ管理ファイル
(Ｓ)処理を終了します。
[対策]次に示すどれかの処置をしてください。
・バックアップファイル又はアンロードログファイルの場合
正しいファイルを指定して，再度実行してください。
・システムログファイルの場合
システムログが破壊された可能性があります。ログファイルに関する定義の変更，及び初期設定をしていないか調査してください。
・差分バックアップ管理ファイル
-gオプションと-Kオプションの指定に誤りがあります。正しい指定をしてpdrstrコマンドを再度実行してください。
KFPR26227-E
-l or -d option is not specified for backup file with -M s option　　（Ｌ＋Ｓ）
-M sオプションを指定して取得したバックアップファイルを使用して回復するときに，アンロードログファイルを指定していません。
(Ｓ)処理を終了します。
[対策]
-lを指定している場合：
アンロードログファイルを指定して，再度実行してください。
-dを指定している場合：
アンロードログファイルが格納されているディレクトリを指定して，再度実行してください。
KFPR26228-E
Invalid RDAREA status, RDAREA name="aa....aa"　　（Ｌ＋Ｓ）
該当するRDエリアは，hold状態又はclose状態ではありません。又は，ほかのユーザが使用中です。このため，RDエリアを回復できません。
aa....aa：RDエリア名
(Ｓ)該当するRDエリアの回復処理を中断し，ほかのRDエリアの回復処理を続行します。
[対策]RDエリアをhold状態又はclose状態にして，再度実行してください。又は，ほかのユーザの処理が終了した後，再度実行してください。
KFPR26229-E
To recover Master RDAREA, pdstart should be executed with -r option　　（Ｌ＋Ｓ）
マスタディレクトリ用RDエリアの回復時は，HiRDBシステムをpdstart　-rで開始してください。
(Ｓ)処理を終了します。
(Ｏ)HiRDBシステムをpdstopコマンドで終了させて，pdstart -rで開始し直した後，実行してください。
KFPR26230-E
Unable to use -c option, deleted RDAREA "aa....aa" exist in backup file　　（Ｌ＋Ｓ）
pdrstr実行時，-cオプションを指定していますが，指定されたバックアップファイル中のRDエリアaa....aaは，システム中にありません（バックアップ取得後に削除された可能性があります）。このため，該当するバックアップファイルについては，-cオプションを指定できません。
(Ｓ)処理を終了します。
(Ｏ)正しいバックアップファイルを指定して，再度実行してください。又は，回復したいRDエリアを-cオプション以外のオプションで指定し，再度実行してください。
KFPR26232-E
Unable to output Log point information　　（Ｌ＋Ｓ）
このメッセージの前に出力されたエラーが原因で，ログポイント情報を作成できません。
(Ｓ)処理を終了します。
[対策]エラーの原因を取り除き，再度実行してください。
KFPR26233-I
Output Log point information to aa....aa　　（Ｌ＋Ｓ）
ログポイント情報をログポイント情報ファイルaa....aaに出力しました。
aa....aa：ログポイント情報ファイル名
(Ｓ)処理を終了します。
KFPR26234-E
Log point information not found in backup　　（Ｌ＋Ｓ）
バックアップファイルにログポイント情報がありません。-L指定の回復，又はログポイント情報ファイルの再作成（-z）はできません。
(Ｓ)処理を終了します。
[対策]-z指定で取得したバックアップを指定して再度実行してください。
KFPR26235-E
System log file for recovery not swapped　　（Ｌ＋Ｓ）
データベースの回復に必要なシステムログファイルがスワップされていません。
(Ｓ)処理を終了します。
[対策]pdlogswapコマンドを使用し，システムログファイルをスワップしてから再度実行してください。
KFPR26236-E
Error occurred in log file group, file group=aa....aa,reason=(bbb,ccccc)　　（Ｌ＋Ｓ）
ログファイルグループにエラーが発生しました。
aa....aa：障害が発生したログファイルグループ名
bbb：理由コード
ccccc：詳細コード
(Ｓ)処理を終了します。
[対策]理由コードと対策を次に示します。
理由コード
意味
対策
-1
引数が誤っています。
保守員に連絡してください。
-2
致命的，又は予期しないエラーが発生しました。
-31
ログファイルに関する定義解析エラー
システムログファイルに関する定義が誤って変更されています。詳細コードを参照し，元に戻してください。
詳細コードを次に示します。
詳細コード
意味
-1
定義のファイルグループ名が誤っています。
-2
定義のA系ファイル名が誤っています。
-3
定義のB系ファイル名が誤っています。
KFPR26237-E
Error occurred in log element file, file group=aa....aa,system A/B：b, reason=(ccc,ddddd)　　（Ｌ＋Ｓ）
システムログファイルにエラーが発生しました。
aa....aa：障害が発生したファイルグループ名
b：障害が発生した系
ccc：理由コード
ddddd：詳細コード
(Ｓ)他系のログファイルにエラーが発生していない場合，他系のログファイルを使用して処理を続行します。
[対策]理由コードと対策を次に示します。次の理由コード以外が出力された場合，保守員に連絡してください。
理由コード
意味
対策
-40
-41
-42
-43
入出力エラーが発生しました。
詳細コードと「HiRDBファイルシステムに対するアクセス要求から返されるエラーコード」のエラーコードの原因を取り除いてください。
-50
-51
-52
-53
ファイルの内容が不正です。
ログファイルが破壊された可能性があります。ログファイルに関する定義の変更，初期設定，及び不正なステータスを変更していないか調査してください。
詳細コードはシステムの保守情報です。
KFPR26238-E
Log is out of -T option value, RDAREA name=aa....aa, bb....bb time=(cc....cc), dd....dd time=(ee....ee)　　（Ｌ＋Ｓ）
-Tオプションに指定した時刻がログの範囲外のため，回復できません。
aa....aa：RDエリア名
bb....bb：誤りがある時刻指定
"start"：-Tオプションに指定した回復開始時刻にログの終了時刻以降を指定しています。
"end"：-Tオプションに指定した回復終了時刻にログの開始時刻以前を指定しています。
cc....cc：-Tオプションに指定した回復開始又は終了時刻
dd....dd：最初又は最後のアンロードログファイルの出力時間
（ "first" | "last" ）
ee....ee：ログの開始又は終了時刻
(Ｓ)処理を終了します。
(Ｏ)-Tオプションの値を修正し，再度実行してください。
KFPR26239-E
Invalid aa....aa value in -T option for RDAREA name=bb....bb, transaction commited at cc....cc　　（Ｌ＋Ｓ）
RDエリアbb....bbに指定した-Tオプションの回復終了時刻が不正です。トランザクションが更新したRDエリアに指定する-Tオプションの回復終了時刻に，トランザクションの同期点の時刻よりも古いものと新しいものが混在しています。
aa....aa：該当するRDエリアの回復終了時刻
bb....bb：RDエリア名
cc....cc：トランザクションが同期点を迎えた時間
(Ｓ)処理を終了します。
(Ｏ)トランザクションが更新したRDエリアに指定する-Tオプションの回復終了時刻は，すべて同期点を含んでいるか，又は含んでいないかのどちらかにして，再度実行してください。
KFPR26240-E
Backup is out of aa....aa in -T option value, RDAREA name=bb....bb　　（Ｌ＋Ｓ）
RDエリアaa....aaに指定した-Tオプションの回復終了時刻が不正です。
aa....aa：該当するRDエリアの回復終了時刻
bb....bb：RDエリア名
(Ｓ)処理を終了します。
(Ｏ)-Tオプションの回復終了時刻にバックアップ取得時刻以降の時刻を指定して，再度実行してください。
KFPR26241-W
Transaction is running at recovery end time, RDAREA name=aa....aa, end time=(bb....bb), Transaction count=cc....cc　　（Ｌ＋Ｓ）
RDエリアaa....aaの回復に指定した回復終了時刻に，実行中のトランザクションが含まれます。回復終了時刻に実行中のトランザクションは回復できません。
aa....aa：RDエリア名
bb....bb：該当するRDエリアの回復終了時刻
cc....cc：実行中のトランザクション数
(Ｓ)処理を続行します。
(Ｏ)回復終了時刻に実行中のトランザクションを回復する場合，回復終了時刻にトランザクションの終了した時刻を指定して再度実行してください。
KFPR26242-E
Unable to output message to standard output, host=aa....aa, file=bb....bb, func=cc....cc, errno=ddd　　（Ｌ）
システムコールでエラーが発生したため，メッセージを標準出力に出力できません。
aa....aa：エラーの原因となったファイルがあるホスト名
bb....bb：エラーの原因となったファイル名
エラーが発生したシステムコール名称がtempnamの場合，******が表示されます。
cc....cc：エラーが発生したシステムコール名称
systemの場合，括弧内に実行したシェルコマンド名を入れて表示されます。
ddd：エラーが発生したシステムコールのerrno
(Ｓ)処理を続行します。
(Ｏ)エラーインジケータの値を調査し，errno.h及びユーザが使用しているOSのマニュアルを参照して，エラーの原因を取り除いてください。
KFPR26243-E
Unable to remove temporary file, host=aa....aa, file=bb....bb　　（Ｌ）
このメッセージの前に出力されたエラーが原因で，一時ファイルを削除できません。
aa....aa：削除できないファイルがあるホスト名
bb....bb：削除できないファイル名
(Ｓ)処理を続行します。
(Ｏ)処理が終了した後，一時ファイルを削除してください。
KFPR26244-E
Pdrstr must be executed at unit defined as manager　　（Ｌ＋Ｓ）
データベース複写ユティリティ（pdcopy）は，システムマネジャが定義されているユニットで実行する必要があります。
(Ｓ)処理を終了します。
(Ｏ)システムマネジャ（MGR）が定義されているユニットにリモートログインして，再度コマンドを実行してください。
KFPR26245-I
OmniBackII backup session id=aa....aa　　（Ｅ＋Ｌ）
セッションID（aa....aa）のオブジェクトをバックアップとして使用し，データベースを回復します。
aa....aa：JP1/OmniBack IIのセッションID
(Ｓ)処理を続行します。
KFPR26246-E
OmniBackII object not found　　（Ｅ＋Ｌ）
指定されたJP1/OmniBack IIのオブジェクトが見付かりません。
(Ｓ)処理を終了します。
[対策]-bオプションで指定したオブジェクトの名称が誤っています。正しい名称を指定して再度実行してください。JP1/OmniBack IIのomnidb -streamコマンドを実行すると，オブジェクト名の一覧が表示されます。
KFPR26247-I
OmniBackII Information = aa....aa 　　（Ｅ＋Ｌ）
JP1/OmniBack IIのメッセージ情報を出力します。
aa....aa：JP1/OmniBack IIのメッセージ情報
メッセージ情報が180文字を超える場合は，先頭から180文字を出力します。
(Ｓ)処理を終了します。
[対策]JP1/OmniBack IIのメッセージ情報の内容については，JP1/OmniBack IIのマニュアルを参照してください。
KFPR26248-E
OmniBackII file not found,host=aa....aa file=bb....bb　　（Ｅ＋Ｌ）
ホストaa....aaにJP1/OmniBack IIのファイルbb....bbがありません。そのため，データベース回復ユティリティ（pdrstr）を実行できません。
aa....aa：ホスト名
bb....bb：ファイル名
(Ｓ)処理を終了します。
[対策]aa....aaのホストにJP1/OmniBack IIのディスクエージェントがインストールされているか確認してください。インストールされていない場合は，インストールしてください。インストールされている場合は，保守員に連絡してください。
KFPR26249-E
Unable to check OmniBackII file,host=aa....aa　　（Ｅ＋Ｌ）
このメッセージの前に出力されたメッセージを参照してください。そこで説明しているエラーが原因で，ホストaa....aaのJP1/OmniBack IIのファイルの確認に失敗しました。そのため，データベース回復ユティリティ（pdrstr），又はpdbkuplsコマンドを実行できません。
aa....aa：ホスト名
(Ｓ)処理を終了します。
[対策]syslogfile中の該当メッセージの前に出力されているメッセージの対策を参照してエラー原因を取り除いて，再度実行してください。
KFPR26254-E
Unable to use management file, reason=aa....aa, name=bb....bb　　（Ｌ＋Ｓ）
差分バックアップ管理ファイルbb....bbを使用できません。
aa....aa：理由
unfinish maintenance：メンテナンスが未完了です。
no control block：差分バックアップ管理ファイルの制御情報がありません。
bb....bb：差分バックアップ管理ファイル名
(Ｓ)処理を終了します。
[対策]次に示すどちらかの処置をしてください。
・メンテナンスが未完了の場合
差分バックアップ管理ファイルのバックアップがある場合は，pdfrstrコマンドで差分バックアップ管理ファイルを回復してください。その後，pdrstrコマンドを再実行してください。
差分バックアップ管理ファイルのバックアップがない場合は，差分バックアップ管理ファイルを使用しない回復を行ってください。差分バックアップ管理ファイルがない場合の回復方法については，マニュアル「HiRDB Version 7 システム運用ガイド」を参照してください。
・差分バックアップ管理ファイルの制御情報がない場合
-gオプションと-Kオプションの指定に誤りがあります。正しい指定をしてpdrstrコマンドを再度実行してください。
KFPR26255-E
Page corrupted, management file name=aa....aa, page number=bb....bb　　（Ｅ＋Ｌ）
差分バックアップ管理ファイルaa....aaのページ破壊を検知しました。
aa....aa：差分バックアップ管理ファイル名
bb....bb：ページ破壊を検知したページ番号
(Ｓ)処理を終了します。
[対策]差分バックアップ管理ファイルのバックアップがある場合は，pdfrstrコマンドで差分バックアップ管理ファイルを回復してください。その後，pdrstrコマンドを再実行してください。
差分バックアップ管理ファイルのバックアップがない場合は，差分バックアップ管理ファイルを使用しない回復を行ってください。差分バックアップ管理ファイルがない場合の回復方法については，マニュアル「HiRDB Version 7 システム運用ガイド」を参照してください。
KFPR26257-I
Update start, management file=aa....aa　　（Ｌ＋Ｓ）
差分バックアップ管理ファイルaa....aaの更新を開始しました。
aa....aa：差分バックアップ管理ファイル名
(Ｓ)処理を続行します。
KFPR26258-I
Update complete, management file=aa....aa　　（Ｌ＋Ｓ）
差分バックアップ管理ファイルaa....aaの更新が終了しました。
aa....aa：差分バックアップ管理ファイル名
(Ｓ)処理を続行します。
KFPR26262-W
Unable to find RDAREA. RDAREA name=aa....aa, generation number=bb　　（Ｌ＋Ｓ）
指定した世代番号のRDエリアが見付かりません。このRDエリアの回復処理をスキップします。
aa....aa：RDエリア名
bb：世代番号
(Ｓ)処理を続行します。
[対策]指定したRDエリア名称及び世代番号を見直してください。RDエリアの回復が必要の場合は，RDエリア名称及び世代番号を修正して再度実行してください。RDエリアの回復が必要ない場合はこのメッセージを無視してください。
KFPR26263-E
Invalid log of RDAREA. RDAREA name=aa....aa(bb,cc), information=(dd....dd,ee....ee,ff....ff), (gg....gg,hh....hh,ii....ii)　　（Ｌ＋Ｓ）
RDエリアaa....aaの世代bbとccのログの読み込み中に，更新順序が後戻りするログを検出しました。これは，世代bbとログccに対する更新がお互いに同期をとらないで行われたことが原因と考えられます。
RDエリアaa....aaの回復は失敗しました。-xオプションを使った回復はできません。
aa....aa：RDエリア名称
bb：-qに指定した世代
cc：-xに指定した世代
dd....dd：一つ前のログの出力時刻（形式：YYYY/MM/DD HH:MM:SS）
ee....ee：内部情報
ff....ff：内部情報
gg....gg：更新順序が後戻りするログの出力時刻（形式：YYYY/MM/DD HH:MM:SS）
hh....hh：内部情報
ii....ii：内部情報
(Ｓ)処理を続行します。
[対策]2世代分のRDエリアのシステムログを利用した回復方法を採用できない場合（KFPR26263-Eメッセージが出力される場合）の対処方法については，マニュアル「インナレプリカ機能 HiRDB Staticizer Option Version 7」を参照してください。
KFPR26264-I
Backup generation differ from recovery generation. backup generation=aa recovery generation=bb　　（Ｌ＋Ｓ）
バックアップ取得時に指定した世代番号とデータベース回復時に指定した世代番号が異なります。aa世代のバックアップを使用してbb世代に回復します。
aa：バックアップ取得時に-ｑオプションに指定した世代番号
bb：回復時に-ｑオプションに指定した世代番号
(Ｓ)処理を続行します。
KFPR26265-I
File sequence error information, RDAREA name = aa....aa server name = bb....bb information = (cc....cc,dd....dd,ee....ee,ff....ff),(gg....gg,hh....hh,ii....ii,jj....jj)　　（Ｌ＋Ｓ）
エラーメッセージKFPR16301-E（reason=File-missing）に関する詳細情報を出力します。
aa....aa：RDエリア名
bb....bb：サーバ名
cc....cc：一つ前のログレコード出力時刻※
dd....dd：一つ前のログレコードが出力されたときのランID※
ee....ee：一つ前のログレコードが出力されたシステムログの世代番号※
ff....ff：システム内部情報
gg....gg：ログレコード出力時刻
hh....hh：ログレコードが出力されたときのランID
ii....ii：ログレコードが出力されたシステムログの世代番号
jj....jj：システム内部情報
注※
アンロードログファイルが抜けていない場合，**....**が出力されます。
(Ｓ)該当するサーバのすべてのRDエリアの回復処理を終了して，ほかに回復できるRDエリアがあるサーバがある場合，そのサーバの回復処理を続行します。
[対策]
cc....cc
管理者の処置
時刻
cc....ccからgg....ggの間に出力された，ログレコードが含まれるアンロードログファイルが抜けています。該当する時間帯に出力されたログレコードが含まれるアンロードログファイルをすべて指定し，再度実行してください。
**....**
次のどちらかの処置をしてください。
・各サーバで最初に指定しなければならないアンロードログファイルが抜けている可能性があります。gg....ggの時刻を参考にして，抜けているアンロードログファイルを指定してから，再度実行してください。
・gg....ggの時刻付近のアンロードログファイルをすべて指定している場合は，バックアップファイルがgg....ggの時刻付近に取得しているかを確認してください。バックアップファイルがgg....ggの時刻付近に取得していない場合，gg....ggの時刻付近に取得したバックアップファイルを指定して再度実行してください。
KFPR26266-E
Unable to use the "-k n" option because the JP1/VERITAS NetBackup Agent for HiRDB license not found　　（Ｌ＋Ｓ）
JP1/VERITAS NetBackup Agent for HiRDBのライセンスがないため，-k nは指定できません。
(Ｓ)処理を終了します。
[対策]JP1/VERITAS NetBackup Agent for HiRDBのライセンスを，NetBackupマスタサーバに登録してください。
KFPR26267-E
Dynamic load error occurred, shared library=aa....aa, host=bb....bb　　（Ｌ＋Ｓ）
ホストbb....bbにある共用ライブラリaa....aaの動的ローディングが失敗しました。
aa....aa：共用ライブラリのファイルパス名
bb....bb：ホスト名
(Ｓ)処理を終了します。
[対策]NetBackupクライアントがインストールされているかどうかを確認してください。インストールされている場合は，直前に出力されているKFPR26003-Eメッセージを参照しエラー原因を取り除いて，再度実行してください。
KFPR26268-E
NetBackup object not found, policy=aa....aa, from=bb....bb, to=cc....cc　　（Ｌ＋Ｓ）
bb....bb～cc....ccに取得したポリシー名aa....aaのバックアップは見付かりませんでした。
aa....aa：ポリシー名
bb....bb：-Uオプションのバックアップ検索条件開始日時（YYYY/MM/DD HH:MM:SS）。指定していない場合は****/**/** **:**:**が出力されます。
cc....cc：-Uオプションのバックアップ検索条件終了日時（YYYY/MM/DD HH:MM:SS）。指定していない場合は****/**/** **:**:**が出力されます。
(Ｓ)処理を終了します。
[対策]指定した期間のポリシーのバックアップがあるかどうかを確認し，ポリシー名及び指定期間を見直して再度実行してください。バックアップ検索条件開始日時が****/**/** **:**:**の場合は，バックアップ検索条件開始日時はポリシー作成日時になります。バックアップ検索条件終了日時が****/**/** **:**:**の場合は，バックアップ検索条件開始日時は現在の最新日時になります。
KFPR26269-E
NetBackup API error occurred, return code=aa....aa(bbbb), func=cc....cc, message=dd....dd　　（Ｌ＋Ｓ）
NetBackupのAPIでエラーが発生しました。
aa....aa：NetBackupのAPIリターンコードの名称
bbbb：NetBackupのAPIリターンコード（16進数）
cc....cc：NetBackupのAPI名
dd....dd：NetBackupのAPIエラーリターン直後に取得したメッセージ（100文字を超える場合は先頭から100文字を表示）
(Ｓ)処理を終了します。
[対策]
リターンコード（bbbb）
リターンコード名（aa....aa）
意味
処置
0x03
SYSTEM_ERROR
NetBackup内部エラー
NetBackup管理コンソールでエラー原因を調査し，対策した後に再度実行してください。
0x0D
FEATURE_NOT_LICENSED
ライセンスがない，又はライセンスが不正
ライセンスを取得してください。
0x4B
VERSION_NOT_SUPPORTED
NetBackupが未サポートバージョン
NetBackupのバージョンが正しいか確認してください。
0x4D
ACCESS_FAILURE
オブジェクトにアクセスできない
NetBackupマスタサーバ，又はNetBackupメディアサーバが停止していないか確認してください。停止していない場合は保守員に連絡してください※。
上記以外
－
－
保守員に連絡してください※。
（凡例）－：該当しません。
注※
保守員に連絡する場合，次の資料を取得しておいてください。
・シングルサーバ又はシステムマネジャがあるホスト，-bオプションで指定したホスト，及びユティリティ実行時に対象となるRDエリアがあるホストのシステムログファイル
・シングルサーバ又はシステムマネジャがあるホスト，-bオプションで指定したホスト，及びユティリティ実行時に対象となるRDエリアがあるホストの$PDDIR/spool下のファイル
・NetBackup管理コンソールからのエラー情報
・標準出力，標準エラー出力に出力されたメッセージ
・ユティリティ実行時の処理結果出力ファイル
KFPR26270-W
Log information，specified log Run ID=aa....aa Gen No=bb....bb，log Run ID=cc....cc Gen No=dd....dd in RDAREA name="ee....ee"　　（Ｌ）
pdrstrコマンドの-lオプションに，データベースの回復に必要なアンロードログファイルがすべて指定されていません。RDエリアに格納されているログ情報と，pdrstrコマンドの-lオプションで指定したアンロードログファイルのログ情報を表示します。
注意
次に示す方法でバックアップを取得した場合は，データベースの回復に必要なアンロードログファイルがすべて指定されていてもこの警告メッセージが出力されます。この場合，この警告メッセージを無視してください。
・HiRDBを正常終了した後にバックアップを取得した場合
次回の正常開始以降に使用したシステムログを格納した全アンロードログファイルを-lオプションに指定しても，この警告メッセージが出力されます。
・pdcloseコマンド入力後にシステムログファイルがスワップして，その後にバックアップを取得した場合
システムログファイルのスワップ以降に使用したシステムログを格納した全アンロードログファイルを-lオプションに指定しても，この警告メッセージが出力されます。
・参照可能バックアップ閉塞（更新WAITモード），又は更新可能バックアップ閉塞（WAITモード）後にシステムログファイルがスワップして，その後にバックアップを取得した場合
システムログファイルのスワップ以降に使用したシステムログを格納した全アンロードログファイルを-lオプションに指定しても，この警告メッセージが出力されます。
aa....aa：-lオプションの先頭に指定したアンロードログファイル※１のログ情報（システムログファイルのログサーバランID）
bb....bb：-lオプションの先頭に指定したアンロードログファイル※１のログ情報（システムログファイルの世代番号）
cc....cc：RDエリアに格納されているログ情報（システムログファイルのログサーバランID）ID※２
dd....dd：RDエリアに格納されているログ情報（システムログファイルの世代番号）※２
ee....ee：RDエリア名称
注※１
各サーバの先頭のアンロードログファイルが対象になります。
（例）
-l bes1_unlog01，bes1_unlog02，bes2_unlog01，bes2_unlog02
前記のように-lオプションを指定した場合，ログ情報の表示対象となるアンロードログファイルは，bes1_unlog01（バックエンドサーバ1のアンロードログファイル），bes2_unlog01（バックエンドサーバ2のアンロードログファイル）になります。
注※２
次に示すときにログ情報をRDエリアに格納します。
・RDエリアのバックアップ閉塞時
・RDエリアのクローズ時
・HiRDBの正常終了時
[対策]pdrstrコマンドの-lオプションに，データベースの回復に必要なアンロードログファイルをすべて指定してください。cc....cc及びdd....ddを参照して，必要なアンロードログファイルを調べます。
KFPR26271-I
NetBackup information, policy=aa....aa, date=bb....bb, time=cc....cc　　（Ｌ＋Ｓ）
日付bb....bb，時刻cc....ccで取得されたポリシー名aa....aaのバックアップで回復します。
aa....aa：ポリシー名
bb....bb：日付（YYYY/MM/DD）
cc....cc：時刻（HH:MM:SS）
(Ｓ)処理を続行します。
KFPR26272-W
No unload log file in specified directory, directory name = aa....aa　　（Ｓ＋Ｌ）
指定ディレクトリ下には，アンロードログファイルがありません。
aa....aa：ディレクトリ名（100文字を超える場合，後ろから100文字を出力します）
(Ｓ)処理を続行します。
[対策]ディレクトリ名aa....aaを確認してください。ディレクトリ名が誤っている場合は，ディレクトリ名の誤りを訂正し，再度実行してください。
KFPR26273-E
Error occurred directory analysis, directory name = aa....aa　　（Ｓ＋Ｌ）
ディレクトリ名aa....aaの解析時にエラーが発生しました。
aa....aa：ディレクトリ名（100文字を超える場合，後ろから100文字を出力します）
(Ｓ)処理を終了します。
[対策]前後に出力されているKFPR26203-Eメッセージに従ってエラー原因を取り除いた後，再度実行してください。
KFPR26274-E
Too many parameter exists at -a option in command line.
コマンドライン中のオプションでパラメタ引数の指定数が多過ぎます。
a：オプション名
[対策]オプション名と対策を以下に示します。
オプション名
対策
ｄ
指定したディレクトリ名の総数が，指定できる最大数128個を超えています。指定するディレクトリ数が128個以内になるように，指定ディレクトリ内のアンロードログファイルを移動し，再度実行してください。
KFPR26275-I
Pdbkupls started.　　（Ｓ＋Ｌ）
pdbkuplsコマンドを開始します。
(Ｓ)処理を続行します。
KFPR26276-I
Pdbkupls terminated, return code=aa　　（Ｓ＋Ｌ）
pdbkuplsコマンドがリターンコードaaで終了しました。
aa....aa：コマンドのリタンコード
0：正常終了
12：エラー終了
(Ｓ)処理を続行します。
[対策]コマンドのリタンコードがエラー終了(12)の場合は，syslogfile（Windowsの場合はイベントログ）中の該当メッセージが出力されている前後に，エラーメッセージが出力されています。そのエラーメッセージの対策を参照してエラー原因を取り除いて，再度実行してください。
KFPR26277-E
Required backup files not specified.　　（Ｓ＋Ｌ）
情報を表示するために必要なバックアップファイルが不足しています。
(Ｓ)処理を終了します。
[対策]必要なバックアップファイルをすべて指定して，再度実行してください。
KFPR26278-I
aa....aaGbyte processing.　　（Ｓ）
バックアップファイルをaa....aaギガバイト読み込み中です。
aa....aa：現在までに読み込んだデータサイズ
(Ｓ)処理を続行します。
KFPR26279-I
aa....aaGbyte reading completed.　　（Ｓ）
バックアップファイルの読み込みが，約aa....aaギガバイト完了しました。
aa....aa：バックアップファイルのサイズ（単位：ギガバイト）
0.01ギガバイト単位で切り上げます（0.01ギガバイト未満のバックアップファイルの場合は，0.01Gbyteと表示されます）。
(Ｓ)処理を続行します。
KFPR26280-E
Specified backup file invalid. filename=aa....aa, code=bb....bb　　（Ｓ＋Ｌ）
指定したバックアップファイルは不正です。
aa....aa：エラーとなったバックアップファイルの名称（100文字を超える場合，バックアップファイル名の後ろから100文字だけ出力します）。
bb....bb：エラー要因
diff：差分バックアップ機能で取得したバックアップファイル
other：pdcopy以外で取得したバックアップファイル
error：pdcopyで取得したバックアップですが，エラー（リターンコード12）で終了しているバックアップファイル
(Ｓ)処理を終了します。
[対策]正しいバックアップファイル名を指定して，再度実行してください。


KFPSメッセージ

KFPS00010-I
HiRDB setup start, func = aa....aa, HIRDB directory = bb....bb　　（Ｒ＋Ｓ）
HiRDBセットアップ処理を開始します。
aa....aa：機能名
add：HiRDBをOSに登録します。
delete：HiRDBをOSから削除します。
bb....bb：HiRDB運用ディレクトリ名
(Ｓ)処理を続行します。
KFPS00011-I
HiRDB setup ended, return code=aa　　（Ｒ＋Ｓ）
HiRDBセットアップ処理を終了します。
aa：終了コード
0：正常終了しました。
8：処理中に異常が発生しました。
(Ｓ)処理を終了します。
[対策]終了コードが0以外の場合は，このメッセージの前に出力されたメッセージを参照して，対策してください。また，直前にテキストビジーが発生している場合は，HiRDBのゾンビプロセスが居残っているおそれがあります。この場合は，UNIXのkillコマンドでゾンビプロセスを消してから，再度実行してください。
KFPS00012-I
Library setup for character code set aa....aa　　（Ｓ）
文字コードaa....aaを使用するためのライブラリをセットアップしました。
aa....aa：HiRDBの文字コード種別
CHINESE：EUC中国語漢字コード
LANG-C：単一バイト文字コード
SJIS：シフトJIS漢字コード
UJIS：EUC日本語漢字コード
UTF-8：Unicode（UTF-8）
(Ｓ)処理を続行します。
KFPS00013-I
Library setup completed for program aa...aa　　（Ｓ）
プログラムaa....aaを使用するためのライブラリをセットアップしました。
aa....aa：プログラム名
・OmniBack：JP1/OmniBack II
(Ｓ)処理を続行します。
KFPS00014-I
Load module setup completed for aa....aa　　（Ｓ）
aa....aaのロードモジュールをセットアップしました。
aa....aa：ロード種別
POSIX：POSIXライブラリ版のHiRDB
(Ｓ)処理を続行します。
KFPS00015-E
Unable to setup aa....aa, reason code=bb....bb　　（Ｓ）
aa....aaのロードモジュールのセットアップができません。
aa....aa：ロード種別
POSIX：POSIXライブラリ版のHiRDB
NO-POSIX：POSIXライブラリ版でないHiRDB
bb....bb：理由コード
REMOVED：このロードモジュールは削除されています。
(Ｓ)処理を終了します。
(Ｏ)HiRDBを再インストールしてください。
KFPS00020-E
Pdsetup already used by another user　　（Ｓ）
ほかのユーザが使用しているため，pdsetupコマンドを入力できません。
(Ｓ)処理を終了します。
[対策]ほかのユーザが実行しているpdsetupコマンドの終了を待って再度実行してください。
KFPS00021-E
Invalid user name, user=aa....aa　　（Ｓ）
HiRDB管理者のユーザ名が不正です。
aa....aa：ユーザ名
ただし，メモリ不足が発生し，ユーザ名のチェックができなかった場合，"********"を出力します。
(Ｓ)処理を終了します。
[対策]
〈ユーザ名に"********"が出力されている場合〉
必要のないプログラムを停止した後，再度実行してください。
〈上記以外の場合〉
次のどちらかの対策をしてください。
・/etc/passwdに記述されているHiRDB管理者のユーザIDに対応する名称を変更してください。
・HiRDB管理者及びHiRDB運用ディレクトリの所有者を変更してください。
KFPS00022-E
Language "aa....aa" not installed　　（Ｓ）
言語 "aa....aa"は，インストールされていません。
aa....aa：言語名
(Ｓ)処理を終了します。
[対策]言語 "aa....aa"をインストールしてください。
KFPS00030-E
Permission denied　　（Ｓ）
許可されていません。
(Ｓ)処理を終了します。
[対策]pdsetupコマンド，又はpdopsetupコマンドは，スーパユーザが実行してください。
KFPS00031-E
Specified HiRDB system already catalogued　　（Ｓ）
指定したHiRDBシステムは既に登録されています。
(Ｓ)処理を終了します。
[対策]指定したHiRDB運用ディレクトリを調査し，必要であればpdsetup -dを入力してから，再度実行してください。
KFPS00032-E
Specified HiRDB system not catalogued　　（Ｓ）
指定したHiRDBシステムは登録されていません。
(Ｓ)処理を終了します。
[対策]指定したHiRDB運用ディレクトリを調査し，必要であればpdsetupを入力してから再度実行してください。
KFPS00033-E
Specified HiRDB home directory not exist　　（Ｓ）
指定したHiRDB運用ディレクトリはありません。
(Ｓ)処理を終了します。
[対策]指定したHiRDB運用ディレクトリを見直し，再度実行してください。
KFPS00034-E
Insufficient disk capacity　　（Ｓ）
ディスク容量がありません。
(Ｓ)処理を終了します。
[対策]指定したHiRDB運用ディレクトリに十分な容量を割り当ててから再度実行してください。また，直前にテキストビジーが発生している場合は，HiRDBのゾンビプロセスが居残っているおそれがあります。
この場合は，OSのkillコマンド（Windows NTの場合はpdkillコマンド）でゾンビプロセスを消してから，再度実行してください。
KFPS00035-I
Create files necessary for execution　　（Ｓ）
実行に必要なファイルを作成します。
(Ｓ)処理を続行します。
KFPS00036-Q
Specify whether to delete files necessary for execution from specified HiRDB home directory ?
[y:YES , n:NO]　　（Ｓ）
指定したHiRDB運用ディレクトリ下の実行に必要なファイルを削除するかどうか指定してください。
[y：削除する n：削除しない]
(Ｓ)処理を続行します。
(Ｏ)y，nのどちらかを応答してください。
KFPS00037-E
Not install aa....aa　　（Ｓ）
プログラムaa....aaが組み込まれていません。又は，プログラムaa....aaが，HiRDBが前提としているバージョンではありません。
aa....aa：SORT，又はSORT型名
(Ｓ)処理を終了します。
(Ｏ)プログラムaa....aaを組み込んでから，再度実行してください。
HP-UX（32ビットモード），又はSolarisのPOSIXライブラリ版HiRDBを使用する場合，バージョン06-03以降のSORT Version 6をインストールしてください。
KFPS00038-E
Specified HiRDB home directory not full path name　　（Ｓ）
HiRDB運用ディレクトリは絶対パス名で指定してください。
(Ｓ)処理を終了します。
[対策]HiRDB運用ディレクトリを絶対パス名で指定し，再度実行してください。
KFPS00040-I
Delete files necessary for execution　　（Ｒ＋Ｓ）
実行に必要なファイルを削除します。
(Ｓ)処理を続行します。
KFPS00050-E
Root directory specified　　（Ｓ）
HiRDB運用ディレクトリにルートディレクトリが指定されています。
(Ｓ)処理を終了します。
[対策]ルートディレクトリをHiRDB運用ディレクトリに変更できません。HiRDB運用ディレクトリを別に作成して再度実行してください。
KFPS00054-E
Unable to specify HiRDB home directory path name more than 128 bytes　　（Ｓ）
指定したHiRDB運用ディレクトリのパスの長さが128バイトを超えています。
(Ｓ)処理を終了します。
[対策]HiRDB運用ディレクトリのパスの長さは，128バイト以内で指定してください。シンボリックリンクを使用している場合は，リンク先の実体パスの長さが128バイト以内になるようにしてください。
KFPS00060-E
Usage： aa....aa 　　（Ｓ）
コマンドの形式aa....aaが誤っています。
aa....aa：
・HP-UX（32ビットモード）の場合
pdsetup { -d [-f] | [-c {sjis|chinese|lang-c|ujis|utf-8}] [-p program ] [-l load ] }
HiRDB_home_directory
・HP-UX（64ビットモード）の場合
pdsetup { -d [-f] | [-c {sjis|chinese|lang-c|ujis|utf-8}] }
HiRDB_home_directory
・Solaris（32ビットモード）及びAIX 5L（32ビットモード）の場合
pdsetup { -d [-f] | [-c {sjis|chinese|lang-c|ujis|utf-8}] [-l load ] }
HiRDB_home_directory
・Solaris（64ビットモード）及びAIX 5L（64ビットモード）の場合
pdsetup { -d [-f] | [-c {sjis|chinese|lang-c|ujis|utf-8}] }
HiRDB_home_directory
・Linuxの場合
pdsetup { -d [-f] | [-c {sjis|chinese|lang-c|ujis|utf-8}] }
HiRDB_home_directory
(Ｓ)処理を終了します。
[対策]オペランドを見直し，再度実行してください。
KFPS00320-I
RPC Info. RC=aa....aa, Func:bb....bb, Msg:cc....cc, Local(Pid=dd....dd, Port=ee....ee)　　（Ｒ）
RPC情報です。
aa....aa：リターンコード
bb....bb：保守情報１（関数名・モジュール名など）
cc....cc：保守情報２
dd....dd：自プロセスID
ee....ee：自ポート番号
(Ｓ)処理を続行します。
KFPS00323-E
RPC is unavailable. Remote node address=aa....aa,Remote port number=bb....bb, Remote tid=cc....cc, Local pid=dd....dd, Local port number=ee....ee　　（Ｒ）
RPCが実行できません。
aa....aa：目的ホストのIPアドレス
bb....bb：目的プロセスのポート番号
cc....cc：目的プロセスのスレッドID
dd....dd：自プロセスID
ee....ee：自プロセスのポート番号
(Ｓ)処理を続行します。
[対策]メッセージログに出力されているメッセージに従って対策してください。
KFPS00326-E
Insufficient memory for RPC. Local pid=aa....aa, Local port number=bb....bb　　（Ｅ＋Ｒ）
RPCを実行するために発行したsocket（）やsend（）などのシステムコールが，メモリ不足によって異常終了しました。
aa....aa：自プロセスID
bb....bb：自ポート番号
(Ｓ)表示されたサーバが異常終了します。
[対策]「RPC関連エラーの詳細コード」に従って対策してください。
KFPS00327-E
Too few sockets. RPC is unavailable. Local pid=aa....aa,Local port number=bb....bb, error number=cc....cc　　（Ｒ）
ソケットが不足したためRPCが実行できません。
aa....aa：自プロセスID
bb....bb：自プロセスのポート番号
cc....cc：エラー番号
(Ｓ)エラー番号が20490の場合，異常終了します。そのほかの番号の場合，処理を続行します。
[対策]エラー番号が20490の場合，保守員に連絡してください。
そのほかのエラー番号の場合，「RPC関連エラーの詳細コード」に従って対策してください。
KFPS00328-E
No data in RPC trace file aa....aa　　（Ｅ）
指定したファイルaa....aaにデータがありません。
aa....aa：指定したファイル名
(Ｓ)該当するコマンドの処理を中止します。
[対策]ファイル名を確認して，コマンドを再度入力してください。
KFPS00330-E
RPC trace file aa....aa not found　　（Ｅ）
指定したファイルaa....aaがありません。
aa....aa：指定したファイル名
(Ｓ)該当するコマンドの処理を中止します。
[対策]ファイル名を確認して，コマンドを再度入力してください。
KFPS00332-E
RPC trace file access error. Return information=aa....aa, Function name=bb....bb　　（Ｅ）
考えられるエラーを次に示します。
・メモリが不足しています。
・RPCトレースファイルの入出力エラーです。
aa....aa：リターン情報
bb....bb：関数名
(Ｓ)該当するコマンドの処理を中止します。
[対策]保守員に連絡してください。
KFPS00335-E
Time out occurred in chained RPC. Service group=aa....aa, local pid=bb....bb　　（Ｒ）
連鎖RPC（同一トランザクション内で，2回以上同一サービス機能グループのサーバを応答型RPCでコールしました）で，コール先が既にアボートしました。又は，連鎖RPCの前回のコールから一定時間たってもトランザクションが終了しません。
aa....aa：サービスグループ名
bb....bb：自プロセス番号
(Ｓ)表示されたサーバが異常終了します。
(Ｐ)HiRDB管理者に連絡してください。
[対策]メッセージログに出力されているメッセージに従って対策してください。
KFPS00336-E
RPC of message received from client or server with different HiRDB version.Local pid=aa....aa, Remote node address=bb....bb, Remote port number=cc....cc　　（Ｒ）
電文を送信した側と受信した側のHiRDBのバージョンが異なります。
aa....aa：受信したプロセスID
bb....bb：送信側のノードアドレス
cc....cc：送信側のポート番号（5けた以内の数字）
(Ｓ)処理を続行します。このメッセージを出力する原因となった電文を破棄します。このとき，送信元には，通知されません。
[対策]メッセージを出力したサーバと，電文を送信したHiRDBクライアント又はHiRDBサーバのバージョンが一致しているか確認してください。一致していない場合，HiRDBクライアントとHiRDBサーバのバージョンを一致させてください。
KFPS00337-E
Unable to open RPC trace file aa....aa　　（Ｅ＋Ｒ）
RPCトレースファイルのオープンに失敗したか，又はRPCトレースファイル関連の定義解析エラーが発生しました。
aa....aa：RPCトレースファイル名
RPCトレースファイルのパス名が188以上の場合は，RPCトレースファイルのパス名の後ろから187文字を出力します。
(Ｓ)処理を続行します。このとき，RPCトレースは取得されません。
[対策]次に示すオペランドに誤りがないか確認してください。
・pd_rpc_trace_name
・pd_rpc_trace_size
これらのオペランドを修正しても再度このメッセージが出力される場合は，保守員に連絡してください。なお，システム資源の不足（ディスク容量不足，ファイル数不足など）の場合は，OSのカーネルパラメタを変更してください。
KFPS00341-I
pdcmknod started　　（Ｌ＋Ｓ）
pdcmknodコマンドを開始します。
(Ｓ)処理を続行します。
KFPS00342-I
pdcmknod ended　　（Ｌ＋Ｓ）
pdcmknodコマンドが終了しました。
(Ｓ)処理を終了します。
KFPS00343-E
Unable to execute pdcmknod command,HiRDB system is running　　（Ｓ）
pdcmknodコマンドを実行したホスト上で，HiRDBが稼働しています。
(Ｓ)処理を終了します。
[対策]pdcmknodコマンドを実行するホスト上で，すべてのHiRDBシステムをpdstopコマンドで終了してください。その後，すべてのHiRDBシステムをpdsetup -dコマンドでOSから削除した後，再度コマンドを実行してください。
KFPS00345-W
Insufficient HiRDB registered ports, reason code=aaa. Use OS assigned ports　　（Ｌ）
HiRDBが通信処理で使用しているポート番号の数が，pd_registered_portオペランドで指定したポート番号の数を超えました。又は，pd_registered_portオペランドで指定したポート番号は，ほかのプログラムで使用中です。このためOSの自動割り当てポート番号を使用します。
aaa：理由コード
-10：pd_registered_portオペランドで指定したポート番号の数を超えました。
-20：pd_registered_portオペランドで指定したポート番号は，ほかのプログラムで使用中です。
(Ｓ)処理を続行します。
[対策]次の処置をしてください。
理由コード
対策
-10
pd_registered_portオペランドの指定値を確認してください。ポート番号の数が不足している可能性があります。
-20
pd_registered_portオペランドの指定値を確認してください。指定範囲のポート番号が，ほかのプログラムで使用されている可能性があります。
ほかのプログラムが使用している場合は，ポート番号の指定範囲を見直してください。ほかのプログラムが使用していない場合は，pd_registered_portオペランドで指定しているポート番号の数が不足している可能性があります。
このメッセージが出力された場合は，統計解析ユティリティ（システムの稼働に関する統計情報）を実行することをお勧めします。そこで，次に示す項目を確認してください。
・HiRDB予約ポートの使用数（#OF REGISTERED PORTS）
・HiRDB予約ポートオーバ時のOS自動割り当てポートの使用数（#OF ASSIGNED PORTS）
KFPS00346-E
Port number in registered ports definition invalid　　（Ｌ）
pd_registered_portオペランドの指定に誤りがあります。
(Ｓ)HiRDBの開始処理を終了します。
[対策]pd_registered_portオペランドの指定値を修正して，HiRDBを再度開始してください。
KFPS00347-E
Insufficient shared memory.Required memory size=aa....aa bytes　　（Ｌ）
共用メモリが不足しました。
aa....aa：確保しようとした共用メモリ領域のサイズ
(Ｓ)HiRDBの開始処理を終了します。
[対策]共用メモリの見積もりを再度確認してください。また，このメッセージの前に障害のメッセージが出力されている場合，そのメッセージに従って対策してください。対策後もこのメッセージが出力される場合は，メッセージの内容を保存し，保守員に連絡してください。
KFPS00348-E
Duplicate registered ports, type=aa...aa, port number=bb...bb　　（Ｌ）
pd_registered_portオペランドで指定したポート番号の範囲内に，重複してはいけないポート番号あります。
aa....aa：重複したポート番号の種別
NAME：
pd_name_portオペランド，又はpdunitオペランドの-pオプションで指定したポート番号と重複しています。
SERVICE：
pd_service_portオペランドで指定したポート番号と重複しています。
SERVICES：
/etc/servicesに登録されているポート番号と重複しています。
bb....bb：重複したポート番号
(Ｓ)HiRDBの開始処理を終了します。
[対策]pd_registered_portオペランドの指定値を修正して，HiRDBを再度開始してください。なお，このメッセージには重複した最初のポート番号だけを表示します。したがって，見直すときにはほかのポート番号も重複していないか確認してください。
KFPS00349-E
Insufficient network port　　（Ｌ）
通信ポート番号の割り当てに失敗しました。
このメッセージが出力された場合は，通信ポート番号の再取得処理をします。再取得処理が成功すればHiRDBプロセスは問題なく稼働します。このメッセージが大量に出力している場合，又はこのメッセージの出力後に通信障害によるHiRDBプロセスの障害が発生した場合は，次に示す要因が考えられます。
・OSの自動割り当てポート番号が不足している
・このメッセージの直後に出力されるKFPS00352-IメッセージのIPアドレスのネットワークが異常終了している
・hostsファイルに指定するHiRDBが使用するホスト名のIPアドレスに誤りがある
(Ｓ)処理を続行します。通信ポート番号の再取得処理を行います。
[対策]次に示す対策を行ってください。
1. ポート番号が不足している場合は，HiRDB以外のプログラムが通信ポートを大量に使用していないか調べてください。大量に使用している場合は，使用している通信ポートを減らしてください。
又は，pd_registered_portオペランドを指定して，HiRDBが使用する通信ポート番号を確保（範囲指定）してください。ポート番号を範囲指定する方法については，マニュアル「HiRDB Version 7 システム運用ガイド」を参照してください。
また，HiRDB/パラレルサーバのシステムマネジャを定義したサーバマシンでこのメッセージが出力される場合，又はHiRDB/シングルサーバの場合，クライアント環境定義のPDTCPCONOPTオペランドに1を指定すると有効なときがあります。PDTCPCONOPTオペランドについては，マニュアル「HiRDB Version 7 UAP開発ガイド」を参照してください。
2. ネットワークが異常終了している場合は，ネットワークを起動してください。
3. hostsファイルの内容を見直してHiRDBで定義しているホスト名のエントリに，誤ったIPアドレスを指定していないか確認してください。誤っている場合は訂正してHiRDBを開始してください。
4. 上記以外の場合は，KFPS00352-Iメッセージの出力内容を取得して，保守員に連絡してください。
KFPS00350-W
Process memory over pd_svr_castoff_size value. server=aa....aa, memory size=bb....bb, value= size=cc....cc　　(Ｌ)
メモリ使用量がpd_svr_acstoff_sizeオペランドで指定された値を超えたため，サーバプロセスを終了します。
aa....aa：サーバ名（システム共通定義のpdstartオペランドで指定したサーバ名）
bb....bb：使用したメモリサイズ（単位：メガバイト）
cc....cc：pd_svr_castoff_sizeオペランドに指定したサイズ（単位：メガバイト）
(Ｓ)該当プロセスを終了します。
[対策]このメッセージが大量に出力される場合は，常駐プロセスの効果が低下します。さらに，プロセス終了及びプロセス開始の頻発や，システムログ及びメッセージログへの多量出力によって，性能劣化を招きます。次の式を満たすように，サーバごとにpd_svr_castoff_sizeオペランド値を指定することをお勧めします。
a－b＜c
a：SQL処理終了後のサーバプロセス仮想メモリサイズ
b：HiRDB開始直後のサーバプロセス仮想メモリサイズ
c：pd_svr_castoff_sizeオペランド値
仮想メモリサイズは，オペレーティングシステムのコマンド（例えば，HP-UXではtopコマンド）で調査してください。
KFPS00351-E
Hostname (aa......aa) not found　　(Ｌ)
ホスト名称（aa....aa）が取得できませんでした。
aa....aa：ホスト名称
(Ｓ)処理を終了します。
[対策]次の要因が考えられます。これらの要因を取り除いて処理を再実行してください。
・hostsファイルにホスト名称又はIPアドレスがありません。
・hostsファイルの参照権限がありません。
・hostsファイルをHiRDB稼働中に変更しました。hostsファイルを変更した場合は，HiRDBを一度正常終了して，その後正常開始してください。
・DNS又はNISを使用している場合は，検索するデータベースにホスト名称又はIPアドレスがありません。
・DNS又はNISを使用している場合は，検索するデータベース又はDNSの環境設定ファイルに参照権限がありません。又は，それらの設定に誤りがあります。
・DNS又はNISを共用している場合は，/etc/nsswitch.confファイルの設定に誤りがあります。
KFPS00352-I
Port number maintenance information,(aa....aa)　　(Ｌ)
ポート番号の保守情報です。KFPS00349-Eメッセージの保守情報です。
aa....aa：保守情報
(Ｓ)処理を続行します。
[対策]直前に出力されているKFPS00349-Eメッセージの保守情報です。KFPS00349-Eメッセージの対策に従って処置してください。
KFPS00353-E
System call error occurred while communication, func=aa....aa, errno=bb....bb, info=cc....cc　　(Ｌ)
通信中のシステムコールで予期しないエラーが発生しました。
aa....aa：システムコール名
bb....bb：システムコールのリターンコード
cc....cc：内部情報
(Ｓ)アボートコード（Psrc780）を出力して，このプロセスを終了します。
[対策]エラーコード（errno：エラーの状態を表す外部整数変数）を調査して，errno.h又はOSのマニュアルを参照してエラーの原因を取り除き，障害を回復後，システムを再度開始してください。なお，代表的なerrnoについては，「システムコールのリターンコード」を参照してください。
エラーの要因を示します。
・通信ソケットの環境を管理，変更するようなプログラムが起動している場合（セキュリティ管理プログラムなど）
・ポートスキャンなどによってHiRDBのプロセスに対し，大量にコネクション要求をした場合
改善されない場合は保守員に連絡してください。
KFPS00403-E
Unable to start lock service. reason code=aa....aa　　（Ｅ＋Ｌ）
排他サービス機能の開始・再開始の処理中に障害が発生しました。
aa....aa：障害の内容を示す理由コード
(Ｓ)HiRDBシステムを異常終了します。
[対策]理由コード一覧を見て対策し，再度開始してください。
理由コードと対策を次に示します。
理由コード
意味
対策
10
定義解析の開始処理でエラー発生
このメッセージの前に障害メッセージが出力されている場合，そのメッセージに従って対策してください。
20
通信障害発生
30
領域不足発生
メモリを必要以上に確保していないか確認してください。メモリを必要以上に確保している場合は，不要な資源を解放してください。
40
共用メモリ不足発生
各サーバ定義のpd_lck_pool_sizeオペランドの指定値を見直してください。
60
デッドロック情報を出力するディレクトリがありません
$PDDIR/spool/pdlckinfディレクトリを作成してください。
KFPS00412-E
Error occurred while terminating lock service； continues processing.reason code=aa....aa　　（Ｌ）
排他サービス機能の終了中にエラーが発生しました。
aa....aa：障害の内容を示す理由コード
(Ｓ)処理を続行します。
[対策]理由コード一覧を見て対策してください。理由コードと対策を次に示します。
理由コード
意味
対策
10
通信障害発生
このメッセージの前に障害メッセージが出力されていれば，そのメッセージに従って対策してください。
KFPS00430-E
Unable to execute aa....aa command. reason code=bb....bb　　（Ｌ）
パラメタの指定誤り又は実行時のエラーが原因で，コマンドを実行できません。
aa....aa：コマンド名
bb....bb：障害の内容を示す理由コード
(Ｓ)コマンドの実行を中断し，終了します。
[対策]理由コード一覧を見て対策し，再度コマンドを入力してください。理由コードと対策を次に示ます。
理由コード
意味
対策
10
通信障害発生
このメッセージの前に障害メッセージが出力されている場合，そのメッセージに従って対策してください。
30
領域不足発生
メモリを必要以上に確保していないか確認してください。メモリを必要以上に確保している場合は，不要な資源を解放してください。
40
バージョン不一致
HiRDBの各ライブラリのバージョンを見直してください。
50
ネームサービス機能停止中
ネームサービスが起動されているか確認してください。
KFPS00431-I
Usage： pdls -d lck [-a] [-s server_ID]　　（Ｅ＋Ｓ）
pdlsコマンド（排他待ち情報の表示）の使用方法を表示します。このメッセージは，次に示す場合に出力します。
・コマンドのオプションに-hを指定した場合
・コマンドのオプション，又は引数の使用方法が誤っている場合
(Ｓ)コマンドの使用方法に誤りがある場合は，コマンド処理を中止します。
(Ｏ)コマンドの使用方法に誤りがある場合は，正しい使用方法で再度コマンドを入力してください。
KFPS00432-I
Usage：pdls -d lck -p　　（Ｅ＋Ｓ）
pdlsコマンド（排他制御用テーブルのプール情報の表示）の使用方法を示します。このメッセージは，次に示す場合に出力します。
・コマンドのオプション，又は引数の使用方法が誤っている場合
(Ｓ)コマンド処理を中止します。
(Ｏ)正しい使用方法で，再度コマンドを入力してください。
KFPS00433-E
Unable to execute aa....aa command command execution mode not set up for lock service　　（Ｅ）
排他サービス機能が起動されていません。又は，終了中のためコマンドを実行できません。
aa....aa：コマンド名
(Ｓ)コマンド処理を中止します。
(Ｏ)システムの開始を確認した後，再度コマンドを入力してください。
KFPS00434-E
Unable to execute the command versions of the aa....aa command and lock service library different　　（Ｅ）
コマンドと排他サービスライブラリのバージョンが不一致のため，aa....aaコマンドが実行できません。
aa....aa：コマンド名
(Ｓ)コマンド処理を中止します。
[対策]現在使用中のHiRDBが使用できるコマンドかどうか確認し，対策した後再度コマンドを入力してください。
KFPS00440-W
Deadlock occurred. server=aa....aa　　（Ｌ）
排他サービス機能の排他処理で，デッドロックが発生しました。
aa....aa：デッドロックの発生したサーバ名
(Ｓ)処理を続行します。
KFPS00441-I
Deadlock information output to aa....aa file　　（Ｌ）
デッドロック情報を出力しました。
aa....aa：デッドロック情報のファイル名
(Ｓ)処理を続行します。
[対策]出力されたデッドロック情報を調べ，必要があれば，デッドロックの原因を取り除いてください。また，調査の終了したデッドロック情報や，調査の必要がないデッドロック情報などは削除してください。
なお，デッドロック情報の出力内容については，マニュアル「HiRDB Version 7 システム運用ガイド」を，デッドロックへの対処方法については，マニュアル「HiRDB Version 7 UAP開発ガイド」を参照してください。
KFPS00442-E
Unable to output deadlock information. reason code=aa....aa　　（Ｅ＋Ｌ）
デッドロック情報が出力できません。
aa....aa：障害の内容を示す理由コード
(Ｓ)処理を続行します。
[対策]理由コード一覧を見て対策してください。理由コードと対策を表に示します。
理由コード
意味
対策
10
環境変数PDDIRの値の取得失敗
PDDIRの値が設定されているかどうか見直してください。
20
ファイルのオープン失敗
$PDDIR/spool/pdlckinfディレクトリがあるか確認してください。
ファイルの数が多過ぎないか確認してください。ファイルの数が多過ぎた場合は，不要なファイルを削除してください。
30
ファイルへの書き込み時，エラー発生
ファイルの数が多過ぎないか確認してください。ファイルの数が多過ぎた場合は，不要なファイルを削除してください。
40
時刻取得失敗
－
50
領域不足発生
メモリを必要以上に確保していないか確認してください。メモリを必要以上に確保している場合は，不要な資源を解放してください。
（凡例）－：該当しません。
KFPS00443-I
Insufficient memory in lock table. server=aa....aa, code=bb, using=cc....cc, total=dd....dd, PROGRAM=ee....ee　　（Ｌ）
サーバaa....aaが排他処理中に確保する排他資源管理テーブルが不足しました。
aa....aa：サーバ名
bb：エラーコード
cc....cc：エラーの発生したユーザが現在使用しているテーブル数
dd....dd：ユーザ全体で使用できるテーブルの総数
ee....ee：UAPの識別情報
クライアント環境定義のPDCLTAPNAMEに指定したUAPの識別情報が表示されます。ユティリティの場合はユティリティのコマンド名が表示されます。ただし，一部のユティリティは表示できません。表示できない場合は"********"が表示されます。
(Ｓ)処理を続行します。
(Ｐ)エラーコードによって下記に示す対策をしてください。
エラーコード
意味
対策
10，30
排他資源又は排他共有待ちを処理するためのテーブルが不足しました。
このメッセージの後に出力されているKFPS00447-Iメッセージ（複数出力されている場合はメッセージの付加情報のプロセスIDが一致するもの）で示す排他資源管理テーブル情報を参照し，原因を調査してください。
排他資源管理テーブル情報については，マニュアル「HiRDB Version 7 システム運用ガイド」を参照してください。
不当に多くの排他要求をしているUAPがある場合は，排他要求が少なくなるようにUAPを修正してください。UAPの排他要求数はSQLによって異なります。
排他資源数の見積もりについては，マニュアル「HiRDB Version 7 システム定義」を参照してください。
なお，UAP当たりの排他要求数の上限はクライアント環境定義のPDLOCKLIMITで設定できます。
排他資源管理テーブル数の見積もりが小さ過ぎる場合は，UAPを実行する時間帯をずらすことで同時に排他資源管理テーブルを使用しないようにするか，又は以下の定義を変更してください。定義を変更した場合は，HiRDB全体又は現象が発生したユニットを停止させてから再開始してください。
＜サーバの種別がフロントエンドサーバの場合＞
エラーが発生したサーバの定義のpd_fes_lck_pool_sizeオペランドの指定値を増やしてください。
＜そのほかの場合＞
エラーが発生したサーバの定義のpd_lck_pool_sizeオペランドの指定値を増やしてください。
20，40，50
トランザクション又は排他解除待ちを処理するためのテーブルが不足しました。
同時実行するUAP又はユティリティの数を減らしてください。
60
トランザクションを超えて保持する表，RDエリアを処理するためのテーブルが不足しました。
エラーが発生したサーバの定義のpd_lck_until_disconnect_cntオペランドの指定値を増やしてください。
KFPS00444-I
Number of lock requests exceeds the limit, server=aa....aa， number=bb....bb　　（Ｌ）
サーバaa....aaで排他要求が上限値に達しました。
aa....aa：サーバ名
bb....bb：排他要求数
(Ｓ)処理を続行します。
[対策]クライアント環境定義のPDLOCKLIMITオペランドの指定値を増やしてください。
KFPS00446-W
Lock queue length reached aaa,server=bb....bb ,resource type=cccc,resource id=dd....dd　　（Ｌ）
リソースID dd....ddの資源の排他処理で，排他待ちユーザ数がaaaになりました。
aaa：排他待ちユーザ数
bb....bb：サーバ名
cccc：資源種別名
dd....dd：資源情報
(Ｓ)処理を続行します。
(Ｐ)使用しているリソースに対する排他処理が妥当かどうかを見直してください。
(Ｏ)pd_lck_queue_limitオペランドに指定した値を確認してください。指定した値が正しい場合，使用しているリソースに対する排他処理が妥当かどうかを見直してください。リソースについては，「排他制御時のエラー内容」を参照してください。
KFPS00447-I
Insufficient exclusive control table information output to aa....aa file　　（Ｌ）
排他資源管理テーブル情報を出力しました。
aa....aa：排他資源管理テーブル情報を出力したファイル名
(Ｓ)処理を続行します。
(Ｐ)出力された排他資源管理テーブル情報を調べ，それぞれのユーザで使用している排他資源数が妥当かどうか見直してください。必要があれば直前に出力されているKFPS00443-Iメッセージ（複数出力されている場合はメッセージの付加情報のプロセスIDが一致するもの）に従って対策してください。
なお，排他資源管理テーブル情報については，マニュアル「HiRDB Version 7 システム運用ガイド」を参照してください。
[対策]出力された排他資源管理テーブル情報を調べ，必要があれば直前に出力されているKFPS00443-Iメッセージ（複数出力されている場合はメッセージの付加情報のプロセスIDが一致するもの）に従って対策してください。
排他資源管理テーブル情報については，マニュアル「HiRDB Version 7 システム運用ガイド」を参照してください。
なお，排他資源管理テーブル情報ファイルは増加するため，調査が終了したり，調査する必要がないファイルは，pdcspoolコマンドかOSのrmコマンドで適時削除してください。
KFPS00448-E
Unable to output insufficient exclusive control table information. Reason code=aa....aa　　（Ｅ＋Ｌ）
排他資源管理テーブル情報が出力できません。
aa....aa：障害の内容を示す理由コード
(Ｓ)処理を続行します。
[対策]理由コードによって次に示す対策をしてください。
理由コード
意味
対策
10
環境変数PDDIRの取得失敗
PDDIRの値が設定されているかどうか見直してください。
20
ファイルのオープン失敗
$PDDIR/spool/pdlckinfディレクトリがあるか確認し，ファイルの数が多過ぎないか確認してください。多過ぎる場合は，不要なファイルをpdcspoolコマンドかOSのrmコマンドで削除してください。
30
ファイルへの書き込み時，エラー発生
40
時刻取得失敗
－
50
スワップ領域不足発生
不要なプロセス又はメモリを必要以上に確保するプロセスがないか確認してください。ある場合は，プロセスを停止させてください。
（凡例）－：該当しません。
KFPS00450-W
Waiting time for exclusive control release out. server=aa....aa, wait_time=bb....bb　　（Ｌ）
排他待ち時間のタイムアウトが発生しました。
aa....aa：タイムアウトの発生したサーバ名
bb....bb：排他待ち時間（秒）
(Ｓ)処理を続行します。
KFPS00451-I
Timeout information output to aa....aa file　　（Ｌ）
タイムアウトの情報を出力しました。
aa....aa：タイムアウトの情報を出力したファイル名
(Ｓ)処理を続行します。
[対策]出力されたタイムアウトの情報を調べ，必要があれば，タイムアウトの原因を取り除いてください。また，調査の終了したタイムアウトの情報や，調査の必要がないタイムアウトの情報などは削除してください。
なお，タイムアウト情報の出力内容については，マニュアル「HiRDB Version 7 システム運用ガイド」を参照してください。
また，デッドロックが原因でタイムアウトが発生したときは，デッドロックへの対処方法に従って対策してください。
デッドロックの対処方法については，マニュアル「HiRDB Version 7 UAP開発ガイド」を参照してください。
KFPS00452-E
Unable to output timeout information. reason code=aa....aa　　（Ｅ＋Ｌ）
タイムアウトの情報が出力できません。
aa....aa：障害の内容を示す理由コード
(Ｓ)処理を続行します。
[対策]理由コード一覧を見て対策してください。理由コードと対策を表に示します。
理由コード
意味
対策
10
環境変数PDDIRの値の取得失敗
PDDIRの値が設定されているかどうか見直してください。
20
ファイルのオープン失敗
$PDDIR/spool/pdlckinfディレクトリがあるかどうか確認してください。
ファイルの数が多過ぎないか確認してください。ファイルの数が多過ぎた場合は，不要なファイルを削除してください。
30
ファイルへの書き込み時，エラー発生
ファイルの数が多過ぎないか確認してください。ファイルの数が多過ぎた場合は，不要なファイルを削除してください。
40
時刻取得失敗
－
50
領域不足発生
メモリを必要以上に確保していないか確認してください。メモリを必要以上に確保している場合は，不要な資源を解放してください。
（凡例）－：該当しません。
KFPS00460-E
Insufficient memory. size=aa....aa bytes, area type=bb....bb　　（Ｅ＋Ｌ）
メモリ不足が発生しました。
aa....aa：確保しようとしたサイズ
bb....bb：メモリ不足が発生した領域の種別
DYNAMIC_SHMPOOL：動的共用メモリ領域
PROCESS：プロセス領域
STATIC_SHMPOOL：静的共用メモリ領域
(Ｓ)処理を続行します。
[対策]プロセス領域の場合は，プロセス数などを見直し対策してください。繰り返し発生する場合は，保守員に連絡してください。
KFPS00601-I
Shared memory aa....aa found insufficient while executing name service；another bb....bb bytes required　　（Ｅ）
ネームサービス機能の実行中に共用メモリが不足しました。
aa....aa：HiRDBの内部情報
bb....bb：不足したサイズのバイト数
(Ｓ)ネームサービス機能に要求された処理を打ち切ります。HiRDBの開始処理中のときは，開始処理を中断します。
[対策]共用メモリの見積もりを再度確認してください。また，このメッセージの前に障害のメッセージが出力されている場合，そのメッセージに従って対策してください。対策後もこのメッセージが出力される場合は，メッセージの内容を保存し，保守員に連絡してください。
KFPS00602-W
Error occurred during name service for HiRDB/client.reason code=aa....aa, maintenance information=bb....bb　　（Ｅ）
HiRDBクライアント機能に対するネームサービス機能が利用できなくなりました。
aa....aa：要因コード
bb....bb：保守情報
(Ｓ)通常のネームサービス機能は続行します。しかし，クライアント機能に対するネームサービス機能は利用できなくなります。
[対策]
要因コードが"nclt001"又は"nclt007"の場合，プロセス固有メモリが不足しています。この場合，プロセス数を減らすなどの対策をしてください。
要因コードが上記以外の場合は，このメッセージの内容を保存して保守員に連絡してください。
なお，HiRDBクライアントの 環境変数にPDHOSTを指定しているUAPの場合，ネームサービス機能への影響はありません。
KFPS00606-E
Definition variable aa....aa specifies undefined host name bb....bb. definition file=cc....cc　　（Ｅ）
定義変数aa....aaに指定されたノード名bb....bbは定義されていません。
aa....aa：HiRDB内部情報
bb....bb：ノード名
cc....cc：誤りのある定義ファイル{ SERVER }
SERVER：$PDCONFPATH/pdsys
(Ｓ)構成定義の解析を続行しますが，ネームサービスは実行しません。
[対策]定義ファイル，又はhostsファイルを修正して，HiRDBを再度実行してください。
KFPS00608-W
Interprocess communication error occurred in name service.maintenance information=aa....aa　　（Ｅ＋Ｒ）
ネームサービス実行中に，プロセス間通信でエラーが発生しました。
aa....aa：保守情報
(Ｓ)処理を続行します。
(Ｏ)次に示す項目について，調査及び対策を実施してください。
(1) HiRDBシステムを構成するすべてのホストが起動されていない場合，すべてのホストを起動してください。同様に，LANが起動されていない場合は起動してください。このメッセージは，ほかのホスト及びLANが起動している場合でも，出力されることがあります。その場合は，このメッセージを無視してください。
(2) 通信障害が頻繁に発生する要因について，HiRDB管理者に連絡し，調査してください。
(3) HiRDBの定義情報に誤りがないか，HiRDB管理者に連絡し，調査してください。
[対策]次に示す項目について，調査及び対策を実施してください。
(1)通信障害が頻繁に発生する原因が分かった場合，HiRDBを停止後に対策し，再度HiRDBを開始してください。
(2)次に示す定義情報が誤っていないか確認してください。誤っていた場合はHiRDBシステムを停止し，定義情報を修正して再開始してください。
・システム共通定義のpdunitオペランドで，-x及び-cオプションに指定したホスト名称
(3)上記に該当しない場合は，保守員に連絡してください。
KFPS00609-E
Unable to analyze definition file, due to insufficient memory　　（Ｅ＋Ｌ）
プロセスのメモリ不足を検知したため，システム共通定義ファイルの解析処理が実行できません。
(Ｓ)処理を終了します。
[対策]次に示す方法で使用できるメモリに余裕を持たせてから再度HiRDBを開始してください。
・同一マシン内で稼働しているほかのプロセスの数を減らしてください。
・スワップ領域を増やしてください。
・実メモリを増設してください。
KFPS00610-I
Transaction queuing started, queuing unit=aa....aa, down cc....cc=bb....bb　　（Ｌ）
高速系切り替え，1：1スタンバイレス型系切り替えの場合：
bb....bbユニットが異常終了中のため，aa....aaユニットでトランザクションのキューイングを開始します。
影響分散スタンバイレス型系切り替えの場合：
bb....bbサーバが異常終了中のため，aa....aaユニットでトランザクションのキューイングを開始します。
トランザクションをキューイングするユニットがトランザクションのキューイング連絡を受け付けたときにこのメッセージを出力します。
aa....aa：トランザクションをキューイングするユニット名
bb....bb：
・高速系切り替え，1：1スタンバイレス型系切り替えの場合：異常終了中のユニット名
・影響分散スタンバイレス型系切り替えの場合：異常終了中のサーバ名
cc....cc：
・高速系切り替え，1：1スタンバイレス型系切り替えの場合：unit
・影響分散スタンバイレス型系切り換えの場合：server
(Ｓ)トランザクションのキューイングを開始します。なお，このメッセージを出力する前からトランザクション開始エラー時のリトライ処理によって，トランザクションをキューイングしている場合もあります。
KFPS00611-I
Transaction queuing ended, queuing unit=aa....aa, down cc....cc=bb....bb　　（Ｌ）
高速系切り替え，1：1スタンバイレス型系切り替えの場合：
bb....bbユニットがトランザクションを受け付け可能になったため，aa....aaユニットでトランザクションのキューイングを終了します。
影響分散スタンバイレス型系切り替えの場合：
bb....bbサーバがトランザクション受け付け可能になったため，aa....aaユニットでトランザクションのキューイングを終了します。
トランザクションをキューイング中のユニットがトランザクションの受付可能の連絡を受け付けたときにこのメッセージを出力します。
aa....aa：トランザクションをキューイング中のユニット名
bb....bb：
・高速系切り替え，1：1スタンバイレス型系切り替えの場合：トランザクション受け付け可能になったユニット名
・影響分散スタンバイレス型系切り替えの場合：トランザクション受け付け可能になったサーバ名
cc....cc：
・高速系切り替え，1：1スタンバイレス型系切り替えの場合：unit
・影響分散スタンバイレス型系切り替えの場合：server
(Ｓ)トランザクションのキューイングを終了します。
KFPS00612-E
Timeout for transaction queuing occurred, reason=aa....aa, queuing unit=bb....bb, down dd....dd=cc....cc　　（Ｌ）
bb....bbユニットに対するトランザクションのキューイング処理でタイムアウトが発生しました。次に示すどちらかのタイムアウトが発生しています。
・pd_ha_trn_queuing_wait_timeオペランドの値を超えても，異常終了中のユニット又はサーバからトランザクション受け付け可能の連絡がなかった
・pd_ha_trn_restart_retry_timeオペランドの値を超えても，異常終了中のユニット又はサーバが開始しなかった
aa....aa：タイムアウトの理由
・pd_ha_trn_queuing_wait_time：pd_ha_trn_queuing_wait_timeオペランドの値を超えた
・pd_ha_trn_restart_retry_time：pd_ha_trn_restart_retry_timeオペランドの値を超えた
bb....bb：トランザクションをキューイングするユニット名
cc....cc：
・高速系切り替え，1：1スタンバイレス型系切り替えの場合：異常終了中のユニット名
・影響分散スタンバイレス型系切り替えの場合：異常終了中のサーバ名
dd....dd：
・1：1スタンバイレス型系切り替えの場合：unit
・影響分散スタンバイレス型系切り替えの場合：server
(Ｓ)トランザクションのキューイグを終了します。これ以降発生するトランザクションはキューイングされないでエラーになります。この場合，次に示す要因が考えられます。
・pd_ha_trn_queuing_wait_timeオペランドの値又はpd_ha_trn_restart_retry_timeオペランドの値が小さい
・高速系切り替え機能の処理が失敗した
・系切り替え処理が失敗した。
なお，異常終了中のユニット又はサーバがトランザクション受け付け可能になった時点で，トランザクションはエラーにならないで正常に処理されます。
[対策]次に示す処置をしてください。
・aa....aaがpd_ha_trn_queuing_wait_timeの場合
次に示す二つの要因が考えられます。
1. pd_ha_trn_queuing_wait_timeオペランドの値（時間）内に，HiRDBの開始処理が完了しませんでした。この場合，pd_ha_trn_queuing_wait_timeオペランドの値を大きくしてください。
2. 異常終了中のユニット又はサーバの再開始処理中にエラーが発生して再開始に失敗しました。このメッセージの前に出力されたメッセージを参照して原因を特定してください。
・aa....aaがpd_ha_trn_restart_retry_timeの場合
次に示す二つの要因が考えられます。
1. pd_ha_trn_restart_retry_timeオペランドの値（時間）内に異常終了したユニット又はサーバが再開始できませんでした。系の切り替え時にディスクの切り離し処理に時間が掛かっているなどの要因が考えられます。この場合，pd_ha_trn_restart_retry_timeオペランドの値を大きくしてください。
2. 系の切り替え処理に失敗しました。この場合，このメッセージの前に出力されたメッセージを参照して原因を特定してください。また，OSのメッセージ，及びクラスタソフトウェアのメッセージも参照してください。
KFPS00700-E
Error occurred in system call aa....aa. errno=bbb, function name=cc....cc　　（Ｅ＋Ｌ）
aa....aaシステムコールでエラーが発生しました。
aa....aa：システムコール名
bbb：システムコールのリターンコード
cc....cc：エラーの発生した関数名
(Ｓ)処理を続行します。又は，HiRDBシステムを異常終了します。
[対策]エラーコード（errno : エラーの状態を表す外部整数変数）を調査して，errno.h又はユーザが使用するOSのマニュアルを参照してエラーの原因を取り除いてから，再度実行してください。
なお，代表的なerrnoについては，「システムコールのリターンコード」を参照してください。
KFPS00701-E
Unable to continue processing due to file system error　　（Ｌ）
ファイルを操作するシステムコールが異常終了しました。
(Ｓ)システムを停止します。
[対策]このメッセージの直前に別のメッセージが出力されている場合，そのメッセージを参照してください。操作対象のファイルのアクセス権に問題がない場合，保守員に連絡してください。
KFPS00703-E
Insufficient memory. required memory size=aa....aa bytes, area type=bb....bb　　（Ｌ）
メモリ不足が発生しました。
aa....aa：確保しようとした領域のサイズ
bb....bb：メモリ不足が発生した領域の種別
PROCESS：プロセス固有領域
STATIC_SHMPOOL：静的共用メモリ
(Ｓ)システムを停止します。
[対策]メモリ不足が発生した領域の種別がプロセス固有領域の場合は，プロセス数を見直し，再度実行してください。繰り返し発生する場合は保守員に連絡し，原因を調査してください。
KFPS00705-E
Error found while analyzing definition file　　（Ｌ）
HiRDBシステム定義ファイルの解析中にエラーを検出しました。
(Ｓ)開始コマンド待ちです。
(Ｏ)HiRDBシステム定義ファイルを訂正し，pdstartコマンドを入力してください。
[対策]このメッセージの直前に別のメッセージが出力されている場合，そのメッセージを参照してください。HiRDBシステム定義ファイルに誤りがない場合は，保守員に連絡してください。
KFPS00707-E
Max number of processes in process service definition invalid　　（Ｌ）
システム共通定義又はユニット制御情報定義の最大プロセス数の指定に誤りがあります。
(Ｓ)開始コマンド待ちです。
(Ｏ)定義ファイルを修正し，pdstartコマンドで再度実行してください。定義ファイルが正しい場合は，保守員に連絡してください。
KFPS00709-E
Process monitoring time in process service definition invalid　　（Ｌ）
システム共通定義又はユニット制御情報定義のプロセス監視時間の指定に誤りがあります。
(Ｓ)開始コマンド待ちです。
(Ｏ)定義ファイルを修正し，pdstartコマンドで再度実行してください。定義ファイルが正しい場合は，保守員に連絡してください。
KFPS00710-E
Shared memory unavailable； unable to continue processing　　（Ｅ＋Ｌ）
プロセスサーバデーモンで，共用メモリが利用できません。又は，コマンドで共用メモリの利用ができません。
(Ｓ)システムを異常終了します。コマンドの場合，処理を終了します。
(Ｏ)
・プロセスサーバデーモンの場合
保守員に連絡してください。
・コマンドの場合
コマンドを再度実行してください。HiRDBを開始していない場合，又は開始途中の場合，HiRDBの開始処理が終わってからコマンドを実行してください。繰り返し実行しても同じメッセージが出力される場合，保守員に連絡してください。
KFPS00712-E
Unable to continue processing due to program error or hardware failure　　（Ｅ＋Ｌ）
プログラム不良又はハードウェア不良のため，処理が続行できません。
(Ｓ)システムを停止します。
[対策]保守員に連絡し，原因を調査してください。
KFPS00713-E
Load module bb....bb for server aa....aa not found　　（Ｌ）
サーバ名aa....aaに対するロードモジュールbb....bbがありません。
aa....aa：サーバ名
bb....bb：ロードモジュール名
(Ｓ)システムを異常終了します。
[対策]保守員に連絡し，原因を調査してください。
KFPS00714-E
Load module bb....bb for server aa....aa not executable file　　（Ｌ）
サーバ名aa....aaに対するロードモジュールbb....bbが実行できるファイルではありません。
aa....aa：サーバ名
bb....bb：ロードモジュール名
(Ｓ)システムを異常終了します。
[対策]保守員に連絡し，原因を調査してください。
KFPS00715-E
Unable to continue processing serious error occurred (reason code=aaa). enter pdrpause　　（Ｅ＋Ｌ）
HiRDBの処理を続行できないエラーが発生しました。
aaa：要因コード
1：次のどれかの誤りがあります。
・/etc/inittabの内容が不正です。
・インストール先ディレクトリ名に空白が含まれています。
・環境変数PDDIRの設定に誤りがあります。
・Windows NTの場合，HiRDBのインストール先が正しくありません。
・Windows NTの場合，HiRDBのインストールが正常終了していません。
2：メモリ不足です。
3，4，13，44，101：ステータスファイルのオープンに失敗しました。
5，104：ステータスファイルの読み込みに失敗しました。
6：時刻の取得に失敗しました。
7：HiRDBの再開始処理でHiRDBが3回連続異常終了しました。ただし，pd_term_watch_countオペランドを指定している場合は，その指定値の回数だけ連続異常終了しました。
8：ステータスファイルの内容不正です。
9，105：ステータスファイル内のファイルポインタの移動に失敗しました。
10，14，42，102：ステータスファイルの書き込みに失敗しました。
11，15，103：ステータスファイルのクローズに失敗しました。
16：共用メモリが破壊されています。
20：定義エラーです。
21：ディレクトリの移動に失敗しました。
22：共用ライブラリのコピーに失敗しました（ファイルシステムが満杯又はテキストビジー）。
25：HS_Linkドライバcombuf通信機能の使用に関するエラーです。
30：関連プログラムプロダクトがインストールされていません。
43：ステータスファイルの権限変更に失敗しました。
(Ｓ)処理を終了します。
[対策]次の手順で対策してください。
1. システム定義のpd_start_levelオペランドに1を指定していて，このメッセージの付加情報にあるユニットを除いて開始処理を続行してよい場合は，このメッセージは無視してください。
2. このメッセージの出力後に，pdstartコマンドが終了していない場合，pdstop -fコマンドを実行してください。
3. このメッセージの出力時刻前後に，システムマネジャのユニットのsyslogfile（Windows NT版の場合はイベントログ）にエラーメッセージ又は警告メッセージが出力されている場合，そのメッセージの対策に従ってください。
4. このメッセージの出力時刻前後に，このメッセージの付加情報にあるユニットのsyslogfileにエラーメッセージ又は警告メッセージが出力されている場合，そのメッセージの対策に従ってください。
5. このメッセージの付加情報にあるユニットで，要因コードに対応した障害要因を取り除いてください。
6. このメッセージの付加情報にあるユニットで，pdrpauseコマンドを実行してください。
7. Windows NT版の場合，サービスを再開始してください。サービスが停止していない場合は，サービスをいったん停止した後，再度サービスを開始してください。
8. pdstartコマンドを実行してください。
9. HiRDB管理者が対処できないエラーが発生している場合は，保守員に連絡してください。
KFPS00717-E
System went down aaa consecutive times　　（Ｌ）
システムが一定時間内にaaa回連続して停止しました。
aaa：異常終了回数
(Ｓ)HiRDBの再開始処理を中止します。
[対策]このメッセージの前に出力されているメッセージを調査し，障害を取り除いた後，再度開始してください。HiRDB管理者が対処できないエラーが発生している場合，保守員に連絡してください。
KFPS00719-E
Message output error. message ID= aaa　　（Ｅ＋Ｌ）
メッセージを出力するときに障害が発生しました。
aaa：出力しようとしたメッセージのメッセージID
(Ｓ)処理を続行します。
(Ｏ)出力しようとしたメッセージの，メッセージIDの項に記述されているオペレータの処置に従ってください。
[対策]出力しようとしたメッセージの，メッセージIDの項に記述されているHiRDB管理者の処置に従ってください。
KFPS00720-E
Load module name not defined in definition file of server aa....aa　　（Ｌ）
サーバの定義ファイルにロードモジュール名の定義（set module = ）がありません。
aa....aa：サーバ名（定義ファイル名と同じ）
(Ｓ)処理を続行します。
(Ｏ)定義ファイルにロードモジュール名を記述して，再度サーバを開始してください。
[対策]保守員に連絡してください。
KFPS00721-E
Versions of process service library and process service daemon different　　（Ｅ）
プロセスサービス機能のデーモンとプロセスサービス機能にサービス要求したライブラリのバージョンが一致しません。そのため，プロセスサービス機能のデーモンは，サービスを実行できません。
(Ｓ)処理を中止します。
[対策]現在使用中のHiRDBシステムが使用できるライブラリを使って，ユーザサーバ，又はコマンドを再度作成して開始してください。繰り返し発生する場合は，保守員に連絡してください。
KFPS00722-E
Unable to excute recover process, code=aa....aa　　（Ｅ＋Ｌ）
異常終了したプロセスを回復するとき，プロセスの起動に失敗しました。
aa....aa：エラーコード
-729：pd_max_server_processオペランドの指定値を超えるプロセスを起動しようとしました。
上記以外：内部エラーが発生しました。
(Ｓ)異常終了します。
[対策]エラーコードに従って，次の処置をしてください。
-729：システム共通定義，及びユニット制御情報定義のpd_max_server_processオペランドの指定値を増やしてください。
上記以外：このメッセージの前に出力されたメッセージを調査し，対策してください。
KFPS00727-E
HA monitor has been stopped　　（Ｌ）
現在HAモニタ又はHitachi HA Toolkit Extensionは停止中です。
(Ｓ)異常終了します。
(Ｏ)HAモニタ又はHitachi HA Toolkit Extensionを起動して，HiRDBを再度開始してください。
KFPS00728-E
System error detected during communication with HA monitor. error code=aaaa, detail code=bbbb　　（Ｌ）
HAモニタ又はHitachi HA Toolkit Extensionへの連絡処理でシステムエラーを検知しました。
aaaa：HAモニタ又はHitachi HA Toolkit Extensionのリターンコード
bbbb：HAモニタ又はHitachi HA Toolkit Extensionの詳細リターンコード
(Ｓ)異常終了します。
[対策]HAモニタ又はHitachi HA Toolkit Extensionが稼働しているか確認してください。稼働している場合は，保守員に連絡してください。
KFPS00729-E
Unable to continue HiRDB unit processingbecause server process went down aaaaa times; stops HiRDB unit bbbb　　（Ｌ）
プロセスの異常終了回数監視機能（pd_down_watch_procオペランド）の監視時間内に，HiRDBのサーバプロセスがaa....aa回異常終了したため，ユニットbbbbを異常終了します。
aa....aa：サーバプロセスの異常終了回数
bbbb：ユニット識別子
(Ｓ)異常終了します。
[対策]このメッセージの後に出力されたメッセージに従って，必要がある場合は再度HiRDBを開始してください。サーバプロセスの異常終了によってHiRDBを異常終了させたくない場合は，pd_down_watch_procオペランドを省略するか，又は0を指定してください。プロセスの異常終了回数監視機能については，マニュアル「HiRDB Version 7 システム運用ガイド」を参照してください。
KFPS00730-I
pdpfresh ended, return code = aa....aa　　（Ｓ）
pdpfreshコマンドがリターンコードaa....aaで終了しました。
aa....aa：リターンコード（[対策]を参照してください）
(Ｓ)pdpfreshコマンド実行時に-cオプションを指定していない場合で，かつリターンコードが0及び4の場合は，処理を続行します。それ以外の場合は，処理を終了します。
[対策]次のリターンコードに従って対処してください。
リターンコード
pdpfreshコマンドの処理結果
対策
0
-cなし
サーバプロセスのリフレッシュを開始しました。
なし。
-cあり
リフレッシュ中のプロセスはありません。
1
-cなし
設定されることはありません。
次の手順で対処してください。
1. pdls -d prc -cコマンドを実行してください。STATUSがCとなっているプロセスが，副系RDエリアを含むHiRDBファイルシステム領域にアクセスしている可能性があるプロセスです。
2. このプロセスを強制的にリフレッシュしてよい場合は，pdpfresh -fコマンドを再度実行してください。リフレッシュしない場合は，この実行中のプロセスが終了してから，pdpfreshコマンドを再度実行してください（必要であれば，そのプロセスが終了するような処置をしてください）。
-cあり
リフレッシュ中のプロセスがあります。
4
警告終了しました（一つ以上のサーバでエラーが発生）。
エラーが発生したサーバの状態を確認してください。稼働中の場合は，そのサーバのプロセスがRDエリアをアクセス中のまま残っている（ペアボリュームの再同期を妨げている）可能性があります。pdpfreshコマンドでそのサーバを指定して再度実行してください。
6
ユティリティ実行中のため，終了しました。
ユティリティが終了してからpdpfreshコマンドを再度実行してください。又は，実行中のユティリティがエラーになってもかまわない場合は，pdpfresh -pコマンドを再度実行してください。
8
異常終了しました。
保守員に連絡してください。
KFPS00750-E
Unable to execute command due to insufficient memory. required memory size= aa....aa bytes, area type= bb....bb　　（Ｅ）
メモリ不足のため，コマンドが実行できません。
aa....aa：確保しようとした領域のサイズ
bb....bb：メモリ不足が発生した領域の種別
PROCESS：プロセス固有領域
STATIC_SHMPOOL：静的共用メモリ
(Ｓ)コマンドを異常終了します。
[対策]メモリ不足の発生した領域の種別がプロセス固有領域の場合は，プロセス数を見直して再度実行してください。繰り返し発生する場合は，保守員に連絡して原因を調査してください。
KFPS00751-E
Command syntax incorrect　　（Ｅ）
コマンドの文法が誤っています。
(Ｏ)コマンドの文法を確認してください。
KFPS00752-E
Load module name invalid　　（Ｅ）
pdlsコマンドの引数（ロードモジュール名）の長さが不正です。
(Ｏ)正しい引数を設定してください。
KFPS00753-E
Server name invalid　　（Ｅ）
pdlsコマンドの引数（サーバ名）の長さが不正です。
(Ｏ)正しい引数を設定してください。
KFPS00754-E
Process ID invalid　　（Ｅ）
pdlsコマンドの引数（プロセスID）の値が不正です。
(Ｏ)正しい引数を設定してください。
KFPS00755-E
Inter-process communication unavailable　　（Ｅ）
プロセス間の通信ができないため，コマンドが実行できません。次に示す原因が考えられます。
・HiRDBが動作していません
・プロセス間で通信する環境が整っていません
(Ｏ)HiRDBシステムが動作しているときにコマンドを入力してください。
KFPS00756-E
Command argument invalid　　（Ｅ）
コマンドの引数が誤っています。
(Ｏ)正しい引数を設定してください。
KFPS00759-E
Service group name invalid　　（Ｅ）
pdlsコマンドの引数（サービスグループ名）の長さが不正です。
(Ｏ)正しい引数を設定してください。
KFPS00760-E
Unable to execute pdrpause command, HiRDB unit is not PAUSE　　　（Ｅ）
HiRDBの開始処理又は再開始処理の中断状態が解除されているため，pdrpauseコマンドは実行できません。
(Ｓ)処理を終了します。
(Ｏ)pdrpauseコマンドを実行する必要はありません。
KFPS00791-I
Usage：pdls -d prc {[-a|-s server ID|-g service group name|-l load module name|-p process ID]}　　（Ｓ）
pdlsコマンドの使用方法を示します。コマンドの形式が誤っている場合に出力します。
(Ｓ)コマンドを異常終了します。
(Ｏ)正しいコマンドを入力してください。
KFPS00793-I
Usage：pdrpause　　（Ｓ）
pdrpauseコマンドの指定形式が誤っています。
(Ｓ)処理を終了します。
(Ｏ)コマンドの使用方法に従って，再度実行してください。
KFPS00803-E
Unable to start scheduler. reason code=aa....aa　　（Ｅ＋Ｌ）
スケジューラの正常開始・再開始中に障害が発生しました。
aa....aa：障害の内容を示す理由コード
(Ｓ)HiRDBの正常開始・再開始処理を中止します。
[対策]理由コード一覧を見て対策し，再度HiRDBを開始してください。理由コードと対策を表に示します。
理由コード
意味
対策
1
共用メモリ確保不可
このメッセージの前に障害メッセージが出力されていれば，そのメッセージに従って対策した後，再度HiRDBを開始してください。
2
定義解析エラー
5
通信障害発生
6
キュー情報ファイルへのアクセスエラー
HiRDB運用ディレクトリ下のspoolディレクトリへのアクセス権限があるかどうかを確認してください。アクセス権限がある場合は保守員に連絡してください。
KFPS00830-E
Unable to start server aa....aa. reason code=b　　（Ｅ＋Ｌ）
サーバの開始処理中に障害が発生しました。
aa....aa：開始できないサーバ名
b：障害の内容を示す理由コード
(Ｓ)サーバの開始処理を中止します。
(Ｏ)該当するサーバを開始する必要がある場合は，HiRDB管理者の処置後，pdstart -sコマンドでサーバを開始してください。
[対策]理由コード一覧を見て対策してください。理由コードと対策を表に示します。
理由
コード
意味
対策
1
該当サーバ開始済み
指定されたサーバ又はサービスグループは，既に開始されています。指定誤りの場合は正しいサーバ名を指定して，pdstart -sコマンドを実行してください。
2
タイミングエラー
スケジューラが開始されていません。又は，終了中です。システム再開始後，pdstart -sコマンドを実行してください。
3
サーバ数不正
スケジューラ下で動作できるサーバ数を超えました。スケジュールサービス定義を見直して対策した後，pdstart -sコマンドを実行してください。
4
通信障害発生
このメッセージの前に障害メッセージが出力されている場合，そのメッセージに従って対策した後に，pdstart -sコマンドを実行してください。
5
プログラムバージョン不一致
HiRDBシステムの各ライブラリのバージョンを見直して対策した後に，pdstart -sコマンドを実行してください。
6
常駐プロセスの起動
該当するサーバマシンで起動できるプロセス数を見直して対策してください。HiRDB開始時にこのメッセージが出力された場合は，pdstartコマンドを実行してHiRDBを再開始してください。pdstart -sコマンド実行時に発生した場合は，再度pdstart -sコマンドを実行してください。
7
メモリ不足
定義で指定したメモリサイズを見直して対策した後に，pdstart -sコマンドを実行してください。
8
定義解析エラー
このメッセージの前に障害メッセージが出力されている場合，そのメッセージに従って対策した後に，pdstart -sコマンドを実行してください。
KFPS00835-E
Unable to terminate server aa....aa. reason code=bb....bb　　（Ｅ＋Ｌ）
サーバの終了処理中に障害が発生しました。
aa....aa：終了できないサーバ名
bb....bb：障害の内容を示す理由コード
(Ｓ)サーバの終了処理を中止します。
(Ｏ)該当するサーバを終了する必要がある場合は，HiRDB管理者の処置後，サーバの停止コマンド（pdstop -s）でサーバを終了してください。
[対策]理由コード一覧を見て対策してください。理由コードと対策を表に示します。
理由コード
意味
対策
1
該当サーバ未起動
指定されたサーバ又はサービスグループが起動されていません。指定誤りの場合は正しいサーバ名を指定して，pdstop -sコマンドを入力してください。
2
タイミングエラー
スケジューラが開始されていません。又は，終了中です。システム再開始後，pdstart -sコマンドを入力してください。
3
通信障害発生
このメッセージの前に障害メッセージが出力されている場合，そのメッセージに従って対策した後，pdstart -sコマンドを入力してください。
4
プログラムバージョン不一致
HiRDBの各ライブラリのバージョンを見直し，対策した後，pdstop -sコマンドを入力してください。
5
メモリ不足
定義で指定したメモリサイズを見直し，対策した後，pdstop -sコマンドを入力してください。
6
定義解析エラー
このメッセージの前に障害メッセージが出力されている場合，そのメッセージに従って対策した後，pdstart -sコマンドを入力してください。
KFPS00836-E
Unable to create a server process. server=aa....aa, reason code=bb....bb(cc....cc)　　（Ｅ＋Ｌ）
サーバのスケジュール時，サーバプロセスの生成に失敗しました。
aa....aa：プロセスを生成できなかったサーバ名
bb....bb：プロセス生成失敗の理由コード
cc....cc：内部コード
(Ｓ)処理を続行します。
[対策]次に示す理由コード一覧に従って対策してください。
理由コード
意味
対策
1
最大プロセス数オーバ
実行中のプロセス数を減らしてください。
2
メモリ不足（fork失敗）
メモリ不足を解消してください。
99
HiRDB内部エラー
これ以前に出力されたメッセージ又は内部コードとエラーの詳細コードを照らし合わせて，障害の原因を取り除いてください。
影響分散スタンバイレス型系切り替え機能を使用している場合，系の切り替え時に内部コード-725が出力されることがありますが，切り替え中のサーバ開始を抑止しているためであり問題ありません。
KFPS00840-E
Error occurred while analyzing definitions. server attribute=aa....aa　　（Ｅ＋Ｌ）
システムの定義情報を解析中に障害が発生しました。
aa....aa：システムの定義情報を解析する処理対象のサーバの属性
"SYSTEM"：システムサーバ
"USER"：フロントエンドサーバ，バックエンドサーバ，又はディクショナリサーバ
サーバの属性によってシステムの処理と対策が異なります。
(1)システムサーバの場合
(Ｓ)HiRDBを異常終了します。
[対策]このメッセージの前に障害のメッセージが出力されている場合，そのメッセージに従って対策し，再度HiRDBを開始してください。繰り返し発生する場合は保守員に連絡してください。
(2)HiRDB/パラレルサーバの場合
(Ｓ)該当するサーバに対する処理を中止し，プロセスを終了させます。
[対策]該当するサーバの定義を見直し対策後，pdstart　-sコマンドで再度開始します。繰り返し発生する場合は保守員に連絡してください。
KFPS00841-E
Service group name not defined in server definition file. server=aa....aa　　（Ｅ＋Ｌ）
サーバの定義ファイルにサービスグループ名の定義がありません。
aa....aa：定義エラーが発生したサーバのサーバ名
(Ｓ)サーバの開始処理を中止します。
(Ｏ)該当するサーバを開始する必要がある場合は，HiRDB管理者の処置後，サーバの開始コマンド（pdstart　-s）でサーバを開始してください。
[対策]該当するサーバの定義ファイルにサービスグループ名の定義を追加してください。
KFPS00843-I
Changed process count. server:aa....aa　　（Ｓ）
サーバプロセスの常駐プロセス数，最大起動本数を変更しました。
aa....aa：プロセス数を変更したサーバのサーバ名
(Ｓ)処理を続行します。
KFPS00844-E
Error occurred in pdchprc command. server:aa....aa, reason code=bb　　（Ｅ）
pdchprcコマンド実行時にエラーが発生しました。
aa....aa：エラーが発生したサーバのサーバ名
エラー発生タイミングによって，サーバ名称に”********”が出力される場合があります。
bb：エラーの内容を示す理由コード
(Ｓ)処理を終了します。
[対策]次に示す理由コードに従って対策してください。
理由
コード
意味
対策
11
サーバ未起動
サーバ名の指定誤りの場合は，正しいサーバ名を指定して，pdchprcコマンドを実行してください。
12
サーバ名不正
正しいサーバ名を指定して，pdchprcコマンドを実行してください。
13
サーバ終了中
サーバ名の指定誤りの場合は，正しいサーバ名を指定して，pdchprcコマンドを実行してください。
14
ユニット未起動
サーバaa....aaのユニットの起動完了後，pdchprcコマンドを実行してください。
21
定義解析エラー
このメッセージの前に障害メッセージが出力されている場合，そのメッセージに従って対策してください。
22
通信タイムアウト
23
メモリ不足
メモリ不足を解消してください。
24
プログラムバージョン不一致
HiRDBの各ライブラリのバージョンを見直して，対策してください。
25
最大プロセス数超過
実行中のプロセス数を減らしてください。
26
通信障害発生
このメッセージの前に障害メッセージが出力されている場合，そのメッセージに従って対策してください。
上記以外
該当しません。
このメッセージの前に障害メッセージが出力されている場合，そのメッセージに従って対策してください。メッセージが出力されていない場合は保守員に連絡してください。
KFPS00847-W
Unable to delete message queue automatically in next system startup; queue information failed to be cataloged.server=aa....aa　　（Ｅ＋Ｌ）
キュー情報ファイルへの書き込みに失敗したので，次回システム開始時にメッセージキューを自動的に削除できません。
aa....aa：キュー情報の書き込みに失敗したサーバのサーバ名
影響分散スタンバイレス型系切り替え機能の対象となるユニットの場合，サーバ名が出力されないで"******"が出力される場合があります。
(Ｓ)処理を続行します。
[対策]このメッセージの前に出力されている障害メッセージに従って対策してください。HiRDBが停止している時にipcrmコマンドを使って該当するメッセージキューを削除してください。
KFPS00849-W
Specified aa....aa is too large for max users, assumed limit bbb, server:cc....cc　　（Ｅ）
pdchprcコマンドで指定したプロセス数に，HiRDBの定義で指定したサーバプロセスの最大起動プロセス数よりも大きな値を指定しています。
HiRDBの定義で指定したサーバプロセスの最大起動プロセス数を仮定して，処理を続行します。
aa....aa：変更しようとした項目
max_process_count：最大起動プロセス数
resident_process_count：常駐プロセス数
bbb：HiRDBの定義で指定したサーバプロセスの最大起動プロセス数
cc....cc：サーバ名
(Ｓ)処理を続行します。
(Ｏ)プロセス数の数値が大き過ぎる場合は，数値を小さくしてpdchprcコマンドを入力してください。
KFPS00850-E
Unable to perform scheduling for server bb....bb due to an error occurred in system call aa....aa. errno=cc....cc　　（Ｅ＋Ｌ）
aa....aaシステムコールでエラーが発生したため，該当するサーバに対するスケジューリングができません。
aa....aa：エラーが発生したシステムコール名
bb....bb：エラーが発生したサーバのサーバ名
影響分散スタンバイレス型系切り替え構成ユニットの場合には，サーバ名が出力されないで”******”が出力されるときがあります。
cc....cc：システムコールのリターンコード
(Ｓ)該当するサーバに対するスケジューリング処理を終了しますが，ほかのスケジューリングは続行します。ただし，サーバ名が”******”の場合はユニットの開始を停止します。
[対策]リターン情報から障害の原因を特定して対策してください。原因が分からない場合は保守員に連絡してください。
・MSGGETシステムコールがエラーの場合は，OSのオペレーティングシステムパラメタ（カーネルパラメタ）のmsgmni（メッセージキュー識別子数）の値が小さいことが考えられます。 msgmniに対して該当するサーバマシン内で稼働する全プログラムの所要量を見積もってください。そして，指定値を変更した後にサーバマシンをリブートしてください。
・MSGSND，MSGRCVシステムコールがエラーの場合は，OSのオペレーティングシステムパラメタ（カーネルパラメタ）のmsgmni又はmsgtql（メッセージヘッダ数）の値が小さいことが考えられます。 該当するサーバマシン内で稼働する全プログラムの所要量を見積もってください。そして，指定値を変更した後に該当するサーバマシンをリブートしてください。また，HiRDBが使用するメッセージキューがipcrmコマンドなどで不当に削除された可能性があります。削除されている場合は， HiRDBが異常終了していなければ，強制終了してください。その後，該当するサーバマシンをリブートしてください。
HiRDBサーバがWindows NT版の場合，HiRDBが必要とするメッセージキュー識別子数を見積もって，それより大きい値をシステム環境変数PDUXPLMSGMNI及びPDUXPLMSGTQLに設定してください。設定後，HiRDBを終了してサービスを再開始してください。メッセージキュー識別子数の見積もり方法については，マニュアル「HiRDB Version 7 システム導入・設計ガイド」を参照してください。
KFPS00851-E
Unable to delete message queue due to an error occurred in MSGCTL system call. errno=aa....aa, queue ID=bb....bb　　（Ｅ）
MSGCTLシステムコールでエラーが発生したため，メッセージキューを削除できません。
aa....aa：システムコールのリターンコード
bb....bb：エラーが発生したメッセージキューのキューID
(Ｓ)処理を続行します。
(Ｏ)メッセージキューを削除する場合，ipcrmコマンドで該当するメッセージキューを削除してください。
Windows NTの場合，HiRDBのサービスを再開始してください。再開始後も発生する場合，又は原因が分からない場合は，保守員に連絡してください。
[対策]システムコールのリターンコードを基に，OSのマニュアルを参照して原因を調査し，対策してください。原因が分からない場合，又はこのメッセージが繰り返し発生する場合は，保守員に連絡してください。
KFPS00852-E
Unable to delete message queue due to queue information acquisition failed. reason code=aa....aa　　（Ｅ）
キュー情報の取得に失敗したため，メッセージキューを削除できません。
aa....aa：理由コード
(Ｓ)メッセージキューの削除処理を中止します。
[対策]このメッセージの前に障害メッセージが出力されていれば，そのメッセージに従って対策してください。理由コードと対策を次に示します。
理由コード
意味
対策
1
メモリ不足
不要なプロセスを終了させて，再度起動してください。
2
キュー情報ファイルアクセスエラー
このメッセージの前に障害メッセージが出力されている場合，そのメッセージに従って対策した後，再度起動してください。
また，$PDDIR/spool下にあるファイルを不当にアクセスしていないか確認してください。
3
プログラムバージョン不一致
HiRDBのコマンド，ライブラリなどのバージョンを見直し，対策した後，再度起動してください。
4
環境変数不正
環境変数を正しく設定し，再度起動してください。
KFPS00854-W
Insufficient memory in message buffer pool. server=aa....aa　　（Ｅ＋Ｌ）
該当するサーバのメッセージ格納バッファプールのメモリ不足が発生したため，クライアントからのメッセージを格納できません。
aa....aa：メモリ不足が発生したサーバのサーバ名
(Ｓ)処理を続行します。
[対策]このメッセージの前に障害のメッセージが出力されている場合，そのメッセージに従って対策してください。該当するサーバに障害が発生している場合は，対策後，再度実行してください。繰り返し発生する場合は，保守員に連絡してください。
KFPS00855-W
Insufficient memory. required area size=aa....aa bytes, area type=bb....bb　　（Ｅ＋Ｌ）
メモリ不足が発生しました。
aa....aa：確保しようとした領域のサイズ
bb....bb：メモリ不足が発生した領域の種別
DYNAMIC SHMPOOL：動的共用メモリ
PROCESS：プロセス固有領域
STATIC SHMPOOL：静的共用メモリ
(Ｓ)処理を続行します。
[対策]
このメッセージの前に障害メッセージが出力されている場合，そのメッセージに従って対策してください。メモリ不足が発生した領域の種別がプロセス固有領域の場合は，次の対策を実施した後に再度実行してください。
1. HiRDBサーバプロセスの常駐数を縮小する。
2. 不要なプロセスを停止させる。
3. 仮想メモリを拡張する。
繰り返し発生する場合は保守員に連絡してください。
KFPS00856-E
Scheduler library and scheduler daemon have different version　　（Ｅ＋Ｌ）
スケジューラライブラリとスケジューラデーモンのプログラムバージョンが一致しません。
(Ｓ)処理を終了します。
[対策]保守員に連絡してください。
KFPS00857-E
Mismatched version found during scheduler processing, version type=aa....aa　　（Ｅ＋Ｌ）
スケジューラの処理中にバージョンの不一致が発生しました。
aa....aa：不一致が発生したバージョン種別
COMMAND：コマンドバージョン
HOLD：閉塞ファイルバージョン
NAMDATA：ネームサーバ登録バージョン
QUEUE：キュー情報ファイルバージョン
REQUEST：サービス要求ヘッダバージョン
STATUS：ステータスファイルバージョン
TABLE：テーブルバージョン
(Ｓ)処理を終了します。
[対策]現在使用中のHiRDBの環境を調査し，対策した後，HiRDBを再度開始してください。
KFPS00860-W
Pd_service_port ignored, reason code=aaaa(bbbbb), cannot use PDSERVICEPORT for HiRDB/client.　　（Ｌ）
aaaa(bbbbb)に示す理由によって，HiRDBはpd_service_portオペランドの指定を無視して続行します。HiRDBクライアントからの高速接続機能は利用できません。このメッセージが出力されたHiRDBに対して，クライアントから高速接続をすると，クライアントはHiRDBサーバが稼働していないとして接続を中止します。
aaaa：理由コード
bbbbb：理由コードごとの保守情報
〈理由コードが1の場合〉
0
〈理由コードが2又は3の場合〉
-208：HiRDBの提供ロードモジュール不正
(Ｓ)処理を続行します。
(Ｏ)理由コードに従って対策してください。
理由コード
意味
対策
1
pd_service_portオペランドの値とpd_name_portオペランドの値が重複しています。
システム共通定義又はユニット制御情報定義でpd_service_portオペランドに指定したポート番号が，pd_name_portオペランドで設定されたポート番号と重複しています。重複しないように定義を変更し，HiRDBを再度実行してください。
2又は3
定義解析が不正です。
〈保守情報が-208の場合〉
HiRDBのインストールが正しく実行されていないか，又はHiRDBの提供ロードモジュールが不正になっているおそれがあります。再度HiRDBをインストールした後に，HiRDBをセットアップして再度実行してください。
〈保守情報が-208以外の場合〉
管理者に連絡してください。
[対策](Ｏ)に記述した要因に該当しないときは，保守員に連絡してください。
KFPS00880-I
Usage: pdls -d scd [-s server name]　　（Ｓ）
pdls -d scdコマンドのオプション指定形式が不正です。
(Ｓ)処理を終了します。
[対策]使用法に従ってコマンドを実行してください。
KFPS00888-W
Server aa....aa exceeded pd_queue_watch_time value. value=bb....bb　　（Ｌ）
メッセージキュー監視機能のメッセージ監視時間（pd_queue_watch_timeオペランドの値）を超えても，メッセージキューからメッセージが取り出されません。現象が発生したサーバはaa....aaです。メッセージキュー監視機能については，マニュアル「HiRDB Version 7 システム運用ガイド」を参照してください。
メッセージ監視時間を超えたのは次に示す要因が考えられます。
・CPU負荷によって処理性能が低下している
・入出力障害によって入出力が遅延している
・UAPやユティリティの多重実行時，HiRDBサーバプロセス数が適正値に比べて小さいため，メッセージキューからメッセージを取り出すときに必要なプロセス数が不足している
HiRDBサーバプロセス数は次に示すオペランドで制限されています。
・pd_max_server_process
ユニット内で稼働するサーバ数が多い場合は，このオペランドの指定値を詳細に見積もってください。また，スタンバイレス型系切り替え機能を使用する場合は，系切り替えが発生したときを想定した見積もりが必要になります。
・pd_max_bes_process
マルチフロントエンドサーバ，又は1：1スタンバイレス型系切り替え機能を使用する場合は，このオペランドの指定値を詳細に見積もってください。
・pd_max_dic_process
マルチフロントエンドサーバを使用する場合は，このオペランドの指定値を詳細に見積もってください。
・pd_ha_max_server_process
影響分散スタンバイレス型系切り替え機能を使用する場合は，このオペランドの指定値を詳細に見積もってください。
aaaa：サーバ名
bbbbb：pd_queue_watch_timeオペランドの値
(Ｓ)処理を続行します。
[対策]CPU利用率，入出力障害の発生有無，HiRDBサーバプロセス数の制限などを見直してください。
pd_queue_watch_timeover_actionオペランドにcontinueを指定している場合は，該当するサーバにアクセスしているトランザクションをpdcancelコマンドなどで終了させて，沈み込み要因を特定し対策してください。
HiRDBサーバプロセス数の制限の場合は，同時に実行するUAP及びユティリティの数を少なくするか，又は同時実行可能なプロセス数を増やしてください。
問題がない場合は保守員に連絡してください。
KFPS00889-E
Server aa....aa exceeded pd_queue_watch_time value, Unit terminated.　　（Ｌ）
メッセージキュー監視機能のメッセージ監視時間（pd_queue_watch_timeオペランドの値）を超えても，メッセージキューからメッセージが取り出されません。現象が発生したサーバはaa....aaです。
pd_queue_watch_timeover_actionオペランドにstopを指定しているため，ユニットを終了します。メッセージキュー監視機能については，マニュアル「HiRDB Version 7 システム運用ガイド」を参照してください。
メッセージ監視時間を超えたのは次に示す要因が考えられます。
・CPU負荷によって処理性能が低下している
・入出力障害によって入出力が遅延している
・UAPやユティリティの多重実行時，HiRDBサーバプロセス数が適正値に比べて小さいため，メッセージキューからメッセージを取り出すときに必要なプロセス数が不足している
HiRDBサーバプロセス数は次に示すオペランドで制限されています。
・pd_max_server_process
ユニット内で稼働するサーバ数が多い場合は，このオペランドの指定値を詳細に見積もってください。また，スタンバイレス型系切り替え機能を使用する場合は，系切り替えが発生したときを想定した見積もりが必要になります。
・pd_max_bes_process
マルチフロントエンドサーバ，又は1：1スタンバイレス型系切り替え機能を使用する場合は，このオペランドの指定値を詳細に見積もってください。
・pd_max_dic_process
マルチフロントエンドサーバを使用する場合は，このオペランドの指定値を詳細に見積もってください。
・pd_ha_max_server_process
影響分散スタンバイレス型系切り替え機能を使用する場合は，このオペランドの指定値を詳細に見積もってください。
aaaa：サーバ名
(Ｓ)HiRDBを異常終了します。
[対策]CPU利用率，入出力障害の発生有無，HiRDBサーバプロセス数の制限などを見直してください。問題がない場合は保守員に連絡してください。
KFPS00890-E
Error occurred during scheduler command processing. reason code=aa....aa, command=bb....bb　　（Ｅ）
スケジューラのコマンド処理でエラーが発生しました。
aa....aa：障害の内容を示す理由コード
bb....bb：コマンド名
(Ｓ)コマンド処理を中止します。
(Ｏ)理由コード一覧を見て対策し，再度コマンドを入力してください。理由コードと対策を次に示します。
理由
コード
意味
対策
31
メモリ不足
起動プロセス数を見直して，使用メモリを削減してください。また，このメッセージの前に障害メッセージが出力されている場合，そのメッセージに従って対策してください。対策後，再度コマンドを実行してください。
33
定義解析エラー
このメッセージの前に障害メッセージが出力されている場合，そのメッセージに従って対策した後，再度コマンドを入力してください。
KFPS00891-E
Invalid use of command aa....aa　　（Ｅ）
aa....aaコマンドの使用方法が不正です。
aa....aa：コマンド名
(Ｓ)処理を終了します。
[対策]正しい使用方法で，再度コマンドを入力してください。
KFPS00892-E
Scheduler inoperable; unable to execute aa....aa command.　　（Ｅ）
スケジューラが起動されていません。又は，終了処理中なのでコマンドを実行できません。
aa....aa：コマンド名
(Ｓ)コマンド処理を中止します。
(Ｏ)システム起動完了後，再度コマンドを入力してください。
KFPS00894-E
Scheduler aa....aa command and scheduler daemon have different version　　（Ｅ）
スケジューラのaa....aaコマンドとデーモンのプログラムバージョンが一致しません。
aa....aa：コマンド名
(Ｓ)処理を中止します。
[対策]現在使用中のHiRDBが使用できるコマンドを確認し，対策後，再度コマンドを入力してください。繰り返し発生する場合は，保守員に連絡してください。
KFPS00900-I
Communication protocol error occurred. status code=aaaaaa, request code=bbbbbb, branch number=cccccc, server=dddddd　　（Ｌ）
トランザクション処理の通信に，プロトコルエラーが発生しました。
aaaaaa：HiRDB内部コード（状態コード）
bbbbbb：HiRDB内部コード（リクエストコード）
cccccc：HiRDB内部コード（ブランチ番号）
dddddd：サーバ名
[対策]次のどれかの対策を実施してください。
・ユーザが使用しているOSのマニュアル，TCP/IPネットワークガイド，及びマニュアル「HiRDB Version 7 システム定義」を参照して，RPC，ソケット関係の通信のパラメタをチューニングしてください。
・該当するサーバの並行度をあげてください。
・該当するサーバがあるサーバマシンのネットワーク負荷を見直してください。
KFPS00955-E
Unable to start transaction service. reason code=aaaa　　（Ｅ＋Ｌ）
トランザクションサービス機能の開始・再開始中に理由コードに示すエラーが発生しました。このため，トランザクションサービス機能を開始できません。
aaaa：理由コード
(Ｓ)HiRDBを異常終了します。
[対策]理由コードによって対策し，再度HiRDBを開始してください。理由コードと対策を次に示します。
理由
コード
意味
対策
0001
プロセスのメモリ不足発生
プロセス数を少なくしてから，再度HiRDBを開始してください。再度このメッセージが出力される場合，保守員に連絡してください。
0002
トランザクションマネジャ管理ファイル読み込み失敗
保守員に連絡してください。
0100
共用メモリ不足発生
保守員に連絡してください。
0200
定義解析の開始処理でエラー発生
このメッセージの前に障害メッセージが出力されている場合，そのメッセージに従って対策してください。
0201
システム共通定義又はユニット制御情報解析失敗
システム共通定義又はユニット制御情報を見直し，HiRDBを再度開始してください。定義が正しい場合は，保守員に連絡してください。
0300
通信障害発生
このメッセージの前に障害メッセージが出力されている場合，そのメッセージに従って対策してください。
0600
ネームサービス機能にサービス情報登録失敗
1100
統計ログサービス機能使用開始時にエラー
1800
回復プロセス起動に失敗
1801
システムマネジャにサーバ完了報告時エラー発生
KFPS00956-E
Error occurred while terminating transaction service;
continues processing. reason code=aaaa　　（Ｅ＋Ｌ）
トランザクションサービス機能を終了中に障害が発生しました。
aaaa：理由コード
(Ｓ)処理を続行します。
[対策]トランザクションサービス機能が正常に終了できない原因を理由コードによって調査し，対策してください。理由コードと対策を次に示します。
理由
コード
意味
対策
0001
プロセスメモリ不足発生
プロセス数を少なくしてから，再度HiRDBを開始してください。再度このメッセージが出力される場合は，保守員に連絡してください。
0300
通信障害発生
このメッセージの前に障害メッセージが出力されている場合，そのメッセージに従って対策してください。
0601
ネームサービス機能でサービス情報削除失敗
1101
統計ログサービス機能の使用終了時にエラー
1802
回復プロセス終了に失敗
KFPS00957-E
Unable to change definition at transaction service restart　　（Ｅ＋Ｌ）
再開始であるにもかかわらず，前回の正常開始時のpd_max_users，pd_max_bes_process，pd_max_dic_processのどれかの指定値を変更しています。
(Ｓ)処理を続行します。
[対策]再開始で変更できないシステム定義を，変更前の状態に戻してHiRDBを開始してください。その後，HiRDBをいったん正常終了させてから，システム定義を変更してください。
KFPS00958-I
Unit terminating; stops receiving new transactions　　（Ｅ＋Ｌ）
ユニットの終了を指示されたため，新たなトランザクションの受け付けを中止します。トランザクションサービス機能は終了処理に備えます。
KFPS00961-E
Unable to start transaction recovery service. reason code= aaaa　　（Ｅ＋Ｌ）
トランザクション回復サービス機能の開始処理中に，理由コードに示すエラーが発生しました。そのため，トランザクション回復サービス機能を開始できません。
aaaa：理由コード
(Ｓ)HiRDBを異常終了します。
[対策]理由コードによって対策し，再度HiRDBを開始してください。理由コードと対策を次に示します。
理由
コード
意味
対策
0200
定義解析の開始処理でエラー発生
このメッセージの前に障害メッセージが出力されている場合，そのメッセージに従って対策してください。
0300
通信障害発生
0800
回復プロセスのスケジュールサービス機能登録失敗
1801
システムマネジャにサービス機能完了報告時エラー
KFPS00962-E
Error occurred while terminating transaction recovery service; continues processing. reason code=aaaa　　（Ｅ＋Ｌ）
トランザクション回復サービス機能の終了処理中に障害が発生しました。
aaaa：理由コード
(Ｓ)処理を続行します。
[対策]トランザクションサービス機能が正常に終了できない原因を理由コードによって調査し，対策してください。理由コードと対策を次に示します。
理由
コード
意味
対策
0300
通信障害発生
このメッセージの前に障害メッセージが出力されている場合，そのメッセージに従って対策してください。
KFPS00965-E
Insufficient memory. required memory size= aa....aa bytes, area type= bb....bb　　（Ｅ＋Ｌ）
メモリ不足が発生しました。
aa....aa：確保しようとした領域のサイズ
bb....bb：メモリ不足が発生した領域の種別
DYNAMIC SHMPOOL：動的共用メモリ
PROCESS：プロセス固有領域
STATIC SHMPOOL：静的共用メモリ
(Ｓ)処理を中止します。
[対策]メモリ不足が発生した領域の種別がプロセス固有領域の場合は，プロセス数を見直し，対策後，再度実行してください。繰り返し発生する場合は，保守員に連絡してください。
KFPS00969-E
Error occurred during aa....aa processing, reason code=bbbb, TRNGID=ccccccccdddddddd, TRNBID=cccccccceeeeeeee, server=ff....ff, PID=gg....gg　　（L）
トランザクションの決着処理中にエラーが発生しました。
TRNGID：トランザクションのグローバル識別子
TRNBID：トランザクションのブランチ識別子
aa....aa：トランザクション決着処理
prepare：コミット一相目処理
commit：コミット二相目処理
rollback：ロールバック処理
bbbb：理由コード
cccccccc：HiRDBシステムの識別子,及びユニット識別子
dddddddd：グローバルトランザクション番号
eeeeeeee：トランザクションブランチ番号
ff....ff：サーバ名
gg....gg：HiRDBサーバのプロセスID
(Ｓ)該当プロセスを終了します。
[対策]理由コードに従って対策してください。
トランザクション決着処理
理由
コード
意味
対策
commit
0001
トランザクションのコミット処理中に，ほかのサーバとのトランザクション同期合わせに失敗しました。
メッセージを出力したサーバ以外のサーバ（回復不要FESを除く）が，何かの原因でトランザクション処理を続行できない状態になっています。ネットワーク，システム，及びサーバの状態を確認してください。
KFPS00970-E
Unable to execute aa....aa command of transaction, reason code=bbbb　　（Ｅ）
トランザクションのaa....aaコマンドを実行できません。
aa....aa：コマンド名
bbbb：理由コード
(Ｓ)処理を中止します。
[対策]理由コード一覧を見て対策してください。
理由
コード
意味
対策
0001
プロセスのメモリ不足が発生しました。
プロセス数を少なくして，再度HiRDBを開始してください。再度このエラーが発生する場合は，保守員に連絡してください。
0003
フラグ引数の文字数が範囲を超えています。
フラグ引数の内容を見直してください。その後，誤りを修正して，再度コマンドを入力してください。
0004
フラグ引数の文字列に指定外の文字があります。
0005
フラグ引数の10進文字列の値が範囲を超えています。
0008
表示する情報がありません。
トランザクションを決着できません。
理由を次に示します。
・該当するトランザクションがありません。
・トランザクションサービスを使用できません。
・トランザクションが決着できる状態ではありません。
0009
オプションフラグ，又はフラグ引数に誤りがあります。
オプションフラグ，又はフラグ引数を見直してください。その後，誤りを修正して，再度コマンドを入力してください。
0010
一時的にメモリが不足したため，システムコールでエラーが発生しました
しばらくしてから，再度コマンドを入力してください。
0200
定義解析の開始処理で，エラーが発生しました。
このメッセージの前に障害メッセージが出力されている場合，そのメッセージに従って対策してください。
0300
通信障害が発生しました。
理由を次に示します。
・このメッセージの前に出力されている障害メッセージが原因で通信障害が発生しました。障害メッセージに従って対策してください。
・一時的なメモリ不足が原因で通信障害が発生しました。プロセス数を少なくして，再度コマンドを入力してください。
0301
タイムアウトが発生しました。
0602
バージョンが一致しません。
HiRDBシステムの各ライブラリのバージョンを見直し，対策後，コマンドを入力してください。
0700
ファイルアクセス時にエラーが発生しました。
このメッセージの前に障害メッセージが出力されている場合,そのメッセージに従って対策してください。
0701
トランザクションのコミット処理でエラーが発生しました。
0702
トランザクションのロールバック処理でエラーが発生しました。
0703
トランザクションの強制終了処理でエラーが発生しました。
0704
トランザクションの状態情報取得でエラーが発生しました。
0705
システムマネジャがあるユニットが稼働していません。
システムマネジャがあるユニットを開始した後にコマンドを実行してください。
0706
システムマネジャがないサーバマシンからコマンドが入力されました。
システムマネジャがあるサーバマシンからコマンドを実行してください。
0707
環境情報取得エラーが発生しました。
障害メッセージが出力されている場合はそのメッセージに従って対策してください。障害を取り除いた後に再度HiRDBを開始してください。
0708
HiRDB運用ディレクトリのパスの長さが最大パス長を超えています。
HiRDB運用ディレクトリのパスの長さは次の長さ以内にしてください。
HP-UX，AIX 5L，及びSolarisの場合：128文字
Linuxの場合：27文字
Windows NTの場合：200文字
KFPS00971-I
Command accepted; (aa....aa)　　（Ｌ＋Ｓ）
aa....aaコマンドを受け付けました。
aa....aa：入力したコマンドの文字列
(Ｓ)処理を続行します。
KFPS00972-I
Error occurred during commit processing; reason code=aaaa,TRNGID=bb....bb PROGRAM=cc....cc　　（Ｌ）
コミット処理中にエラーが発生しました。
aaaa：理由コード
bb....bb：グローバルトランザクション識別子
cc....cc：UAPの識別情報
(Ｓ)処理を続行します。
[対策]次の理由コード一覧に従って対策してください。
理由
コード
意味
対策
0001
コミット要求に対して，子ブランチからの通信の受信待ち状態でタイムアウトが発生したため，ロールバックで決着しました。
ネットワーク，システム，及びサーバの状態を確認してください。又は，最大応答待ち時間の設定を見直してください。
KFPS00973-I
Transaction branch completed. TRNGID=aaaaaaaabbbbbbbb, TRNBID=aaaaaaaacccccccc, server=dd....dd, service=ee....ee, completion type=ff　　（Ｌ）
トランザクションブランチに障害が発生したため，ロールバックを決着しました。
TRNGID：トランザクションのグローバル識別子
TRNBID：トランザクションのブランチ識別子
aaaaaaaa：HiRDBシステムの識別子，及びユニット識別子
bbbbbbbb：グローバルトランザクション番号
cccccccc：トランザクションブランチ番号
dd....dd：サーバ名
ee....ee：HiRDBシステムの内部コード
ff：トランザクション決着種別
r：ロールバック
hr：ヒューリスティックロールバック
(Ｓ)処理を続行します。
KFPS00974-I
Usage: pdfgt{-A[-x host_name|-u unit_id][-s server_name]|-t TRNGID[-x host_name|-u unit_id][-s server_name]}　　（Ｅ＋Ｓ）
pdfgtコマンド（トランザクションの強制停止）の使用方法を示します。このメッセージは次の場合に出力します。
・コマンドのオプション，又は引数の使用方法が異なっている場合
・コマンドのオプションに-hを指定した場合
(Ｓ)処理を終了します。
(Ｏ)コマンドの使用方法に誤りがあった場合，正しい使用方法で再度コマンドを入力してください。
KFPS00975-I
Usage:pdls -d trn {[-t TRNGID] [-{a | c}] | -bc | -B system_node_ID [-{a | c}] | -rc | -R RM_name [-{a | c}] [-s server_name]}　　（Ｅ＋Ｓ）
pdlsコマンド（トランザクションの状態表示）の使用方法を示します。
このメッセージは，次の場合に出力します。
・コマンドのオプションに-hを指定した場合
・コマンドのオプション，又は引数の使用方法が誤っている場合
(Ｓ)コマンドの使用方法に誤りがあった場合は，コマンドの処理を中止します。
(Ｏ)コマンドの使用方法に誤りがあった場合は，正しい使用方法で，再度コマンドを入力してください。
KFPS00976-I
Usage: pdcmt {-A [-x host_name | -u unit_id] [-s server_name]| -t TRNGID [-x host_name | -u unit_id] [-s server_name]}　　（Ｅ＋Ｓ）
pdcmtコマンド（トランザクションのコミット）の使用方法を示します。このメッセージは，次に示す場合に出力します。
・コマンドのオプション，又は引数の使用方法が異なっている場合
・コマンドのオプションに-hを指定した場合
(Ｓ)コマンドの使用方法に誤りがあった場合，コマンドの処理を中止します。
(Ｏ)コマンドの使用方法に誤りがあった場合，正しい使用方法で，再度コマンドを入力してください。
KFPS00977-I
Usage: pdrbk {-A [-x host_name | -u unit_id] [-s server_name] | -t TRNGID [-x host_name | -u unit_id] [-s server_name]}　　（Ｅ＋Ｓ）
pdrbkコマンド（トランザクションのロールバック）の使用方法を示します。このメッセージは次に示す場合に出力します。
・コマンドのオプション，又は引数の使用方法が異なっている場合
・コマンドのオプションに-hを指定した場合
(Ｓ)コマンドの使用方法に誤りがあった場合，コマンドの処理を中止します。
(Ｏ)コマンドの使用方法に誤りがあった場合，正しい使用方法で，再度コマンドを入力してください。
KFPS00978-E
Command aa....aa used invalidly　　（Ｅ）
aa....aaコマンドの使用方法が不正です。
aa....aa：コマンド名
(Ｓ)コマンド処理を中止します。
(Ｏ)正しい使用方法で，再度コマンドを入力してください。
KFPS00979-E
Transaction service inoperable; unable to execute aa....aa command　　（Ｅ）
トランザクションサービス機能が起動されていません。又は，終了処理中です。このため，aa....aaコマンドを実行できません。
aa....aa：コマンド名
(Ｓ)コマンド処理を中止します。
(Ｏ)システムの起動が完了後，再度コマンドを入力してください。
KFPS00980-W
Unable to monitor elapsed time for transaction branch. TRNGID=aaaaaaaabbbbbbbb, TRNBID=aaaaaaaacccccccc, server=dd....dd, service=ee....ee　　（Ｅ＋Ｌ）
トランザクションブランチの経過時間を監視できません。
TRNGID：トランザクションのグローバル識別子
TRNBID：トランザクションのブランチ識別子
aaaaaaaa：HiRDBシステムの識別子，及びユニット識別子
bbbbbbbb：グローバルトランザクション番号
cccccccc：トランザクションブランチ番号
dd....dd：サーバ名
ee....ee：HiRDBの内部コード
(Ｓ)処理を続行します。
[対策]経過監視時間が不要な場合は無視してください。必要な場合はHiRDBを停止し，このメッセージ以前に表示されたタイマサービス機能のメッセージから障害要因を取り除いて，HiRDBを再度開始してください。
KFPS00981-I
Usage: pdtrndec -i input_file_name[,input_file_name...] [-r rollback_script_file_name] [-o output_directory_name]　　（Ｅ＋Ｓ）
pdtrndecコマンド（未決着状態のトランザクションを強制決着するコマンド）の使用方法を示します。このメッセージは次の場合に出力されます。
・pdtrndecコマンドのオプション又は引数の指定方法が間違っている場合
・pdtrndecコマンドに-hオプションを指定した場合
(Ｓ)コマンドの指定方法に間違いがあった場合，コマンドの処理を中止します。
[対策]コマンドの指定方法に間違いがあった場合は，正しい指定方法で再度コマンドを実行してください。
KFPS00982-E
System call error, func=aa....aa, errno=bb....bb, path name=cc....cc　　（Ｅ）
cc....ccのファイル又はディレクトリで，aa....aaのエラーが発生しました。
aa....aa：エラーが発生したシステムコール名
open：ファイル又はディレクトリへのオープン
close：ファイル又はディレクトリへのクローズ
read：ファイル又はディレクトリへの読み込み
write：ファイル又はディレクトリへの書き込み
fseek：ファイルポインタ又はディレクトリへの設定
bb....bb：エラーが発生したシステムコールのerrno
cc....cc：エラーが発生したファイル又はディレクトリの絶対パス名
パス名が164バイト以上ある場合は，表示するパス名の先頭に“...”を付けて最後尾から161バイト分を表示します。
(Ｓ)処理を終了します。
[対策]error.h及びOSのマニュアルを参照してエラー原因を取り除いてください。
KFPS00983-I
Current transaction cancel occurred, server = aa....aa, transaction count = bb....bb　　（Ｌ）
完了していないトランザクションを強制終了しました。
aa....aa：サーバ名
bb....bb：強制終了したトランザクション数
(Ｓ)処理を続行します。
[対策]このメッセージの前に障害メッセージが出力されている場合は，そのメッセージに従って障害を取り除いてください。
KFPS00985-I
Undetermined transaction information stored in aa....aa　　（Ｅ＋Ｌ）
未決着のトランザクションに関する情報をaa....aaに取得しました。
aa....aa：ファイルの絶対パス名
(Ｓ)処理を続行します。
KFPS00986-W
Unable to store undetermined transaction information in aa....aa. reason code= bbbb　　（Ｅ＋Ｌ）
未決着のトランザクションに関する情報をaa....aaに取得できません。
aa....aa：ファイルの絶対パス名
bbbb：理由コード
(Ｓ)処理を続行します。
[対策]理由コードに従って対策してください。理由コードと対策を次に示します。
理由
コード
意味
対策
0001
プロセスのメモリ不足発生
プロセス数を少なくし，再度HiRDBを開始してください。再度このメッセージが出力される場合は，保守員に連絡してください。
0052
ファイル操作失敗
このメッセージの前に出力されたメッセージの理由コードによって，失敗した原因を調査し，対策してください。
0056
環境変数不正
環境変数に正しい値を設定して，再度実行してください。
KFPS00988-I
Transaction information. TRNGID=aaaaaaaabbbbbbbb, TRNBID=aaaaaaaacccccccc, PID=dd....dd, C-PID=ee....ee(ff....ff), TIME=gghhii, PROGRAM=jj....jj, TMID=kkkk, XID=llllllllllllllll,mmmmmmmmmmmmmmmm,ENVGRP=nnnn　　（Ｌ）
トランザクションの障害に関する補足情報を示しています。このメッセージは，次の場合に出力します。
・トランザクション関連の障害が発生した場合
・計画停止時に完了していないトランザクションがある場合
TRNGID：トランザクションのグローバル識別子
TRNBID：トランザクションのブランチ識別子
aaaaaaaa：HiRDB識別子，及びユニット識別子
bbbbbbbb：グローバルトランザクション番号
cccccccc：トランザクションブランチ番号
dd....dd：UAP又はユティリティ処理の延長で，トランザクション処理をしていたサーバのプロセスID
ee....ee：サーバのプロセスと接続していたクライアント（UAP又はユティリティ）のプロセスID。ただし，クライアントと接続していたサーバプロセスだけ有効です。また，UAPとリンケージしているクライアントライブラリのHiRDB Version4.0 04-00以降の場合に有効です。
ff....ff：サーバのプロセスと接続していたクライアント（UAP又はユティリティ）のIPアドレス。ただし，クライアントと接続していたサーバプロセスだけ有効です。また，UAPとリンケージしているクライアントライブラリのHiRDB Version4.0 04-00以降の場合に有効です。
gghhii：サービス要求受付時刻（時分秒）。ただし，クライアントと接続していないサーバプロセスのときは，"999999"を表示します。
jj....jj：UAPの識別情報
クライアント環境定義のPDCLTAPNAMEに指定したUAPの識別名称を表示します。
・PDCLTAPNAMEが設定されていない場合："Unknown"を表示します。
・ユティリティの場合：ユティリティのコマンド名を表示します。
kkkk：接続しているOLTPのOLTP識別子（HiRDB_PDTMID,PDTMID）
HiRDBサーバのプロセスと接続したクライアント（UAP）が，X/Openに従ったアプリケーションの場合に，この内容を出力します。OLTP識別子指定なしのときは****を出力します。
llllllllllllllll,mmmmmmmmmmmmmmmm：
OLTPから与えられたトランザクション識別子。サーバのプロセスと接続していたクライアント（UAP）が，X/Openに従ったアプリケーションの場合だけ，この内容を出力します。ただし，OLTPがOpenTP1又はTPBrokerのときだけ有効です。
nnnn：OLTPから与えられた環境変数グループ識別子
HiRDBサーバのプロセスと接続したクライアント（UAP）が，X/Openに従ったアプリケーションで複数接続機能を使用している場合に，この内容を出力します。複数接続機能を使用していない場合は，****を出力します。
(Ｓ)処理を続行します。
(Ｏ)HiRDB管理者の指示に従ってください。
[対策]
〈トランザクション関連の障害が発生した場合〉
このメッセージより前に表示された次に示す障害メッセージの原因調査のために，必要に応じてこのメッセージを利用してください。
・KFPS00972-I
・KFPS00973-I
・KFPS00990-I
・KFPS00991-I
・KFPS00992-E
・KFPS00993-I
〈計画停止時に完了していないトランザクションがある場合〉
完了していないトランザクションを確認するために，必要に応じてこのメッセージを利用してください。
KFPS00990-I
Transaction branch recovery complete. TRNGID=aaaaaaaabbbbbbbb, TRNBID=aaaaaaaacccccccc, server=dd....dd, service=ee....ee, completion type=f,gg　　（Ｅ＋Ｌ）
トランザクションブランチの回復が完了しました。
TRNGID：トランザクションのグローバル識別子
TRNBID：トランザクションのブランチ識別子
aaaaaaaa：HiRDBシステムの識別子，及びユニット識別子
bbbbbbbb：グローバルトランザクション番号
cccccccc：トランザクションブランチ番号
dd....dd：サーバ名
ee....ee：HiRDBの内部コード
f：該当するトランザクションブランチの完了種別
c：コミット
r：ロールバック
gg：グローバルトランザクションの完了種別
c：コミット
hc：ヒューリスティックコミット
hh：ヒューリスティックハザード
hm：ヒューリスティックミックス
hr：ヒューリスティックロールバック
r：ロールバック
(Ｓ)処理を続行します。
KFPS00991-I
Unable to recover from transaction branch. TRNGID=aaaaaaaabbbbbbbb, TRNBID=aaaaaaaacccccccc, server=dd....dd, service=ee....ee, determination type=ff　　（Ｅ＋Ｌ）
トランザクションブランチの回復が完了できなかったため，再度実行します。
TRNGID：トランザクションのグローバル識別子
TRNBID：トランザクションのブランチ識別子
aaaaaaaa：HiRDBシステムの識別子，及びユニット識別子
bbbbbbbb：グローバルトランザクション番号
cccccccc：トランザクションブランチ番号
dd....dd：サーバ名
ee....ee：HiRDBの内部コード
ff：決着種別
c：コミット
hc：ヒューリスティックコミット
hh：ヒューリスティックハザード
hm：ヒューリスティックミックス
hr：ヒューリスティックロールバック
r：ロールバック
(Ｓ)処理を続行します。
[対策]このメッセージの前に障害メッセージが出力されている場合，発生した障害を取り除いてください。
KFPS00992-E
Unable to determine commit or rollback for transaction branch. TRNGID=aaaaaaaabbbbbbbb, TRNBID=aaaaaaaacccccccc, server=dd....dd, service=ee....ee　　（Ｅ＋Ｌ）
トランザクションブランチが通信障害などの障害発生のため，システムでコミット，又はロールバックができません。
TRNGID：トランザクションのグローバル識別子
TRNBID：トランザクションのブランチ識別子
aaaaaaaa：HiRDBシステムの識別子，及びユニット識別子
bbbbbbbb：グローバルトランザクション番号
cccccccc：トランザクションブランチ番号
dd....dd：サーバ名
ee....ee：HiRDBの内部コード
(Ｓ)トランザクションブランチの状態を保持し，処理を続行します。
[対策]障害回復の見込みがない場合に備えて，pdcmt又はpdrbkコマンドでのトランザクション決着の準備をしてください。又は，OpenTP1，TPBrokerが起動していない場合があります。確認して，OpenTP1，TPBrokerを起動してください。
また，pdcmt/pdrbkコマンドで決着する場合，同一TRNGIDを持つほかのトランザクションブランチの決着種別に合わせてください。
ほかのトランザクションブランチの決着種別は，回復完了後に出力するKFPS00990-Iメッセージ中で同一TRNGIDを持つトランザクションブランチの完了種別に合わせてください。
同一TRNGIDを持つKFPS00990-Iメッセージがなく，pdls -d trnでもほかにトランザクションブランチがないときは，pdrbkコマンドで決着してください。
KFPS00993-I
Accepted process abnormal end request. PID=aa....aa, TRNGID=bb....bb, TRNBID=cc....cc, REQUEST=dd....dd　　（Ｌ）
次に示すどれかの理由のため，サーバプロセス処理の強制終了要求を受け付けました。
・関連サーバプロセスが停止しました。
・関連ユニットが異常終了しました。
・トランザクションを中断する必要がある要因が発生しました。
aa....aa：強制終了対象のプロセスID
bb....bb：トランザクション識別子（トランザクションのグローバル識別子）
cc....cc：トランザクション識別子（トランザクションのブランチ識別子）
dd....dd：要求種別
abnormal_unit_branch：異常ユニット関連ブランチ強制終了要求
clt_attention：クライアントでの割り込みに伴う強制終了要求（クライアントのUAP実行中に，キーボードのCtrl＋Cを押した場合も該当します）
force_end：OLTPからの回復指示による強制停止要求（OLTPがOpenTP1の場合だけ有効で，例えば，OpenTP1が異常終了して再開始するときなどが該当します）
pdcancel_end：pdcancelによる強制終了要求
PDCWAITTIME_over：クライアントのPDCWAITTIMEオーバに伴う強制終了要求
subordinate_branch：トランザクション子ブランチ強制終了要求（例えば，ほかのエラー要因によって，トランザクションの関連する子ブランチが強制終了させられる場合など，該当します）
superior_branch：トランザクション親ブランチ強制終了要求（例えば，トランザクションの子ブランチの異常によって，トランザクションの親ブランチが強制終了させられる場合など，該当します）
abnormal_tran_end：シンクポイントダンプ有効化のスキップ回数監視機能による強制終了要求
log_remain_check：システムログファイルの空き容量監視機能による強制終了要求
abnormal_svr_branch：異常サーバ関連ブランチ強制終了要求
(Ｓ)異常終了します。該当するサーバプロセスを強制終了させます。
(Ｐ)HiRDB管理者に連絡してください。対策後に処理を再実行してください。
[対策]原因となった関連サーバプロセス，関連ユニット，又はトランザクションで出力されたメッセージに従って対策してください。
・要求種別がabnormal_tran_endの場合
このメッセージの後に出力しているKFPS00988-IメッセージのUAPの識別情報がhdssqle[aa…aa]bb （aa…aa:：反映グループ名，bb：抽出元HiRDB Datareplicator識別子）の場合は，マニュアル「HiRDB Version 7 システム運用ガイド」の「シンクポイントダンプ有効化のスキップ回数監視機能」を参照して対策してください。
KFPS01001-I
aa....aa assigned as current logical status file. server kind:bb server:cc....cc　　（Ｌ＋Ｓ）
ステータスファイルaa....aaを現用ファイルとして割り当てました。
aa....aa：現用のステータスファイル名
bb：サーバ種別
00：ユニット
01：サーバ
cc....cc：割り当てを実行したサーバ名
サーバ種別が00の場合，ユニット名を表示します。また，サーバ種別が01の場合，サーバ名を表示します。
(Ｓ)処理を続行します。
[対策]障害が発生したステータスファイルがある状態でHiRDBを開始する場合，このメッセージが示す情報は，次に示すオペランドの指定に必要となるため，記録しておくことを推奨します。
・ユニット制御情報定義のpd_syssts_last_active_fileオペランド
・サーバ定義のpd_sts_last_active_fileオペランド
KFPS01005-E
Unable to status service due to aa....aa.　　（Ｅ＋Ｌ）
ステータスサービス機能を開始できません。
aa....aa：エラーの内容を示す理由コード
(Ｓ)HiRDBを異常終了します。
[対策]理由コード一覧を見て対策し，再度HiRDBを開始してください。
理由
コード
意味
対策
0000000001
ステータスサービス機能の定義環境エラー
直前に出力されたメッセージの対策に従ってください。障害を取り除いた後にHiRDBを開始してください。
0000000003
ステータスサービス機能の定義誤り
ユニット制御情報定義又はサーバ定義を見直した後にHiRDBを開始してください。
0000000004
ユニット制御情報定義又はサーバ定義に指定した全ステータスファイルが閉塞状態です。
直前に出力されたメッセージの対策に従ってください。障害を取り除いた後にHiRDBを開始してください。
0000000005
0000000006
メモリ不足
直前に障害メッセージが出力されている場合は，そのメッセージの対策に従ってください。
メモリ不足の原因を特定して対策してください。
OSのオペレーティングシステムパラメタ（最大プロセス数，1プロセス当たりのメモリ割り当てサイズの上限値など）を見直して対策した後に，HiRDBを開始してください。
0000000007
0000000008
ステータスファイル障害
直前に出力されたメッセージの対策に従ってください。障害を取り除いた後にHiRDBを開始してください。
0000000009
スワップ処理エラー
0000000010
障害が発生したステータスファイルがあります。pd_syssts_initial_errorオペランド又はpd_sts_initial_errorオペランドにstopが指定されているため，HiRDBの開始処理を中止しました。
直前に出力されたメッセージの対策に従ってください。障害を取り除いた後にHiRDBを開始してください。
再開始後もこの理由コードでHiRDBが終了する場合は，障害が発生したステータスファイルがある状態でHiRDBを開始するかを検討してください。障害が発生したステータスファイルがある状態でHiRDBを開始するときの手順については，マニュアル「HiRDB Version 7 システム運用ガイド」を参照してください。
0000000011
0000000012
0000000013
0000000014
内部処理エラー
直前に障害メッセージが出力されている場合は，そのメッセージの対策に従ってください。直前に障害メッセージが出力されていない場合は保守員に連絡してください。
0000000015
HiRDBが特定した現用ファイル名と，pd_syssts_last_active_fileオペランド又はpd_sts_last_active_fileオペランドに指定したファイル名が一致しません。
マニュアル「HiRDB Version 7 システム運用ガイド」の「障害が発生したステータスファイルがある状態でHiRDBを開始するときの手順」を参照してください。
pd_syssts_last_active_fileオペランド又はpd_sts_last_active_fileオペランドに，前回稼働時の現用ファイル名を指定しているかを確認してください。前回稼働時の現用ファイル名を指定していない場合は，pd_syssts_last_active_fileオペランド又はpd_sts_last_active_fileオペランドに前回稼働時の現用ファイル名を指定して，HiRDBを開始してください。前回稼働時の現用ファイル名を指定しているのにこの理由コードが出力される場合は，前回稼働時の現用ファイルに障害が発生しています。マニュアル「HiRDB Version 7 システム運用ガイド」の「現用ファイルの両系に障害が発生したためHiRDB（ユニット）を再開始できないときの対処方法」に示す手順に従い，HiRDBを開始してください。
0000000016
pd_syssts_last_active_fileオペランド又はpd_sts_last_active_fileオペランドが指定されていない場合は，前回稼働時の現用ファイルが特定できないため，HiRDBの開始処理を中止しました。pd_syssts_last_active_fileオペランド又はpd_sts_last_active_fileオペランドが指定されている場合は，予備ファイルがないため，HiRDBの開始処理を中止しました。
・pd_syssts_last_active_fileオペランド又はpd_sts_last_active_fileオペランドが指定していない場合
マニュアル「HiRDB Version 7 システム運用ガイド」の「障害が発生したステータスファイルがある状態でHiRDBを開始するときの手順」に示す手順に従い，pd_syssts_last_active_fileオペランド又はpd_sts_last_active_fileオペランドに前回稼働時の現用ファイル名を指定して，HiRDBを開始してください。
・pd_syssts_last_active_fileオペランド又はpd_sts_last_active_fileオペランドを指定している場合
予備ファイルを用意してから，HiRDBを開始してください。
0000000017
HiRDBが特定した現用ファイルの正常な系と，pd_syssts_last_active_sideオペランド又はpd_sts_last_active_sideオペランドに指定された系が一致しません。
マニュアル「HiRDB Version 7 システム運用ガイド」の「障害が発生したステータスファイルがある状態でHiRDBを開始するときの手順」を参照してください。
pd_syssts_last_active_sideオペランド又はpd_sts_last_active_sideオペランドに，前回稼働時の現用ファイルの正常な系を指定しているかを確認してください。正常な系を指定していない場合は，pd_syssts_last_active_sideオペランド又はpd_sts_last_active_sideオペランドに正常な系を指定して，HiRDBを開始してください。正常な系を指定しているのにこの理由コードが出力される場合は，前回稼働時の現用ファイルに障害が発生しています。マニュアル「HiRDB Version 7 システム運用ガイド」の「現用ファイルの両系に障害が発生したためHiRDB（ユニット）を再開始できないときの対処方法」に示す手順に従い，HiRDBを開始してください。
0000000018
前回稼働時の現用ファイルの正常な系が特定できないため，HiRDBの開始処理を中止しました。
マニュアル「HiRDB Version 7 システム運用ガイド」の「障害が発生したステータスファイルがある状態でHiRDBを開始するときの手順」に示す手順に従い，pd_syssts_last_active_sideオペランド又はpd_sts_last_active_sideオペランドに，現用ファイルの正常な系を指定して，HiRDBを開始してください。
KFPS01006-E
aa....aa statement in status service definition is invalid. reason code=bb....bb　　（Ｅ＋Ｌ）
ユニット制御情報定義又はサーバ定義のaa....aa文に指定誤りがあります。ユニット制御情報定義又はサーバ定義の解析中にエラーが発生しました。
aa....aa：ユニット制御情報定義又はサーバ定義
bb....bb：エラーの内容を示す理由コード
理由コードと対策を表に示します。
(Ｓ)ステータスサービスの開始処理を中止します。
(Ｏ)ユニット制御情報定義又はサーバ定義を修正した後で，再度HiRDBを開始してください。
[対策]次に示す理由コードから原因を特定し，ユニット制御情報定義又はサーバ定義を見直してください。
理由コード
原因
対策
0000000001
定義に指定した内容が重複しています。
ユニット制御情報定義又はサーバ定義を見直してから，HiRDBを開始してください。
0000000002
定義文の指定がありません。又は定義文に誤りがあります。
0000000003
定義指定値エラーです。
0000000004
定義に指定した文字数が不正です。
0000000005
定義に指定したファイル名がありません。
0000000006
組み合わせて指定できない定義文があります。
KFPS01008-I
aa....aa file unable to be used as standby status file due to bb....bb.　　（Ｅ＋Ｌ）
予備ステータスファイルとして使用できないファイルがあります。
aa....aa：ステータスファイルのパス名，又はステータスファイル名
ステータスファイルのパス名が153文字以上の場合は，ステータスファイルのパス名の後ろから152文字を出力します。
bb....bb：エラーの内容を示す理由コード
(Ｓ)処理を終了します。
[対策]次に示す理由コード一覧を参照して，対策してください。
理由コード
意味
対策
0000000001
現用ファイルとレコード長の不一致
現用ファイルのレコード長に合わせてください。
0000000002
A系とB系ファイルのレコード数の不一致
A系とB系ファイルのレコード数を同じにしてください。
0000000003
A系とB系ファイルのレコード長の不一致
A系とB系ファイルのレコード長を同じにしてください。
KFPS01009-E
File consistency error occurred in physical status file aa....aa.　　（Ｅ＋Ｌ）
ステータスファイルでファイル整合性エラーが発生しました。
aa....aa：ステータスファイルのパス名
ステータスファイルのパス名が162文字以上の場合は，ステータスファイルのパス名の後ろから161文字を出力します。
(Ｓ)
〈予備ステータスファイルがある場合〉
スワップ処理をします。
〈予備ステータスファイルがない場合〉
開始処理を中止します。
なお，障害が発生したファイルを閉塞状態にします。
(Ｏ)以前にオンラインダウンやファイルシステム障害の発生，及びステータスファイルの割り当てに誤りがないか，確認してください。ステータスファイルの障害を取り除き，ステータスファイルを準備するか，又はHiRDBを再度開始してください。
KFPS01010-E
Error occurred in last updated status file aa....aa. reason code=bb....bb　　（Ｅ＋Ｌ）
最新の情報を持つステータスファイルでエラーが発生しました。
aa....aa：ステータスファイル
ステータスファイルのパス名が145文字以上の場合は，ステータスファイルのパス名の後ろから144文字を出力します。
bb....bb：エラーの内容を示す理由コード
理由コードと対策を表に示します。
(Ｓ)
〈理由コード（0000000006）が発生した場合〉
ファイルの障害を回復して，処理を続行します。
〈理由コード（0000000006）以外が発生した場合〉
予備ステータスファイルがある場合は，スワップ処理をします。予備ステータスファイルがない場合は，開始処理を中止します。障害が発生したファイルを閉塞状態にします。
〈A系とB系共に障害が発生した場合〉
開始処理を中止します。
[対策]理由コード一覧を見て対策してください。
理由コード
意味
対策
0000000001
A系とB系ファイルのレコード数，又はレコード長の不一致
レコード数，レコード長を正常な系と一致させ，pdstsinitコマンドで初期設定してください。
0000000002
A系とB系ファイル共に，レコード数，又はレコード長が不一致，かつデータの異常検知
A系とB系ファイルのレコード数，レコード長を一致させ，pdstsinitコマンドで初期設定してください。
0000000003
A系とB系ファイルのレコード更新番号の不一致
B系ファイルをpdstsinitコマンドで初期設定してください。
0000000004
A系とB系ファイル共に，レコード更新不正の検知
A系とB系ファイルをpdstsinitコマンドで初期設定してください。
0000000005
レコード入力エラーの検知
以前に出力されたKFPS01040-Eメッセージに従ってください。
0000000006
ファイル更新未完了の検知
対策の必要はありません。ただし，A系B系共に障害になった場合は，エラー発生ファイルをpdstsinitコマンドで初期設定してください。
KFPS01011-I
HiRDB system selected aa....aa as last update status file.　　（Ｌ＋Ｓ）
オープンしているファイルの中で，最新の情報を持つステータスファイルはaa....aaです。pd_syssts_initial_errorオペランド又はpd_sts_initial_errorオペランドに，continue又はexcontinueが指定された状態で，前回稼働時の現用ファイルが特定できなかった場合に，オープンしているステータスファイルの中から最新の情報を持つファイル名をaa....aaに表示します。
なお，aa....aaに出力されたファイル名が，前回稼働時の現用ファイルであるとは限りません。前回稼働時の現用ファイルが特定できない条件については，マニュアル「HiRDB Version 7 システム定義」のpd_syssts_initial_errorオペランド又はpd_sts_initial_errorオペランドの説明を参照してください。
aa....aa：ステータスファイル名
(Ｓ)処理を続行します。
KFPS01012-I
Error occurred in last updated status file b on aa....aa system　　（Ｌ＋Ｓ）
最新の情報を持つステータスファイルaa....aaの片方の系に障害が発生しています。
aa....aa：現用のステータスファイル名
b：障害が発生している系｛A｜B｝
(Ｓ)処理を続行します。
KFPS01040-E
aa....aa error occurred in physical status file bb....bb. reason code=cc....cc　　（Ｅ＋Ｌ）
ステータスファイルbb....bbで，エラーaa....aaが発生しました。このメッセージ出力後のHiRDBの処理は，HiRDBの開始時とコマンド実行時で異なります。
・HiRDBの開始時
現用ファイルを割り当てる前（KFPS01001-Iメッセージの出力前）の場合は，障害が発生したファイルを障害閉塞します。
現用ファイルを割り当てた後（KFPS01001-Iメッセージの出力後）の場合は，障害が発生したファイルを障害閉塞した後に，障害が発生したステータスファイルが現用ファイルのときはスワップ処理をします。
・コマンド実行時
処理を続行します。
aa....aa：エラー内容を次に示します。
close：ファイルのClose
create：ファイルの作成
delete：ファイルの削除
filecheck：ファイル妥当性チェック
fstat：ファイルの状態報告
logical：レコード整合性不正
open：ファイルのOpen
read：レコードの入力
write：レコードの出力
bb....bb：ステータスファイルのパス名
ステータスファイルのパス名が145文字以上の場合は，パス名の後ろから144文字を表示します。
cc....cc：障害の発生した理由コード
(Ｓ)予備のステータスファイルがある場合，スワップ処理をします。予備のステータスファイルがない場合は，障害が発生したファイルを閉塞状態にし，処理を続行します。
[対策]次に示す理由コードから原因を特定し，対策してください。
理由コード
原因
対策
0000000001
ステータスファイルのレコード不正が発生しました。
該当するステータスファイルをpdstsinitコマンドで初期設定してください。
0000000002
保守員に連絡してください。
0000000003
ステータスファイルの更新が未完了です。
該当するステータスファイルをpdstsinitコマンドで初期設定してください。
0000000004
HiRDBファイルシステムエラーが発生しました。
保守員に連絡してください。
0000000005
ステータスファイルの管理領域不正が発生しました。
該当するステータスファイルをpdstsinitコマンドで初期設定してください。
0000000006
該当するファイルがステータスファイルとして定義されていません。
ステータスファイルbb....bbのパス名が正しいか確認してください。
ユニット制御情報定義又はサーバ定義を見直してください。
0000000007
障害ファイルを初期化していません。
該当するステータスファイルをpdstsrmコマンドで削除し，pdstsinitコマンドで初期設定してください。
0000000008
ステータスファイルの初期化不正が発生しました。
該当するステータスファイルをpdstsinitコマンドで初期設定してください。
0000000009
ステータスファイルの管理領域不正が発生しました。
0000000010
0000000011
0000000020
指定したパスのHiRDBファイルシステム領域に対し，アクセス権限がありません。
ステータスファイルが格納されているHiRDBファイルシステム領域のアクセス権限を見直してください。
0000000021
ファイルのアクセス権限がありません。
ステータスファイルのアクセス権限を見直してください。
0000000022
排他エラー（ほかのプロセスが使用中）が発生しました。
オープンしているステータスファイルに対して，pdstsrm，pdstsinit，又はpdcat -d sts -eコマンドを実行した可能性があります。pdls -d stsコマンドを実行し，指定したファイルがオープン状態か確認してください。オープン状態の場合は，次に示す対処をしてください。
・pdstsrm又はpdstsinitコマンドの場合は，pdstsclsコマンドでステータスファイルをクローズした後に，再度コマンドを実行してください。
・pdcat -d sts -eコマンドの場合は，pdstsclsコマンドでステータスファイルをクローズしてください。又は，-eオプションを省略して再度コマンドを実行してください。
0000000023
システム資源（ファイルロック）の不足が発生しました。
直前に障害メッセージが出力されている場合は，そのメッセージの対策に従ってください。OSのオペレーティングシステムパラメタ（同時ファイルオープン許容数など）を見直してください。
0000000024
ファイルに対して書き込み権限がありません。
ステータスファイルのアクセス権限を見直してください。
0000000025
システム資源（ファイルディスクリプタ）の不足が発生しました。
直前に障害メッセージが出力されている場合は，そのメッセージの対策に従ってください。OSのオペレーティングシステムパラメタ（同時ファイルオープン許容数など）を見直してください。
0000000026
HiRDBシステムファイル領域として初期設定していません。
ステータスファイルbb....bbのパス名が正しいか確認してください。
pdfmkfsコマンドで，HiRDBシステムファイル領域として初期設定してください。
0000000027
入出力エラーが発生しました。
ディスク障害や，OS障害が発生していないかを調査し，対策してください。ステータスファイルを配置したディスクを有効化しているか確認してください。ディスクが有効化されていない場合は有効化してください。
0000000028
メモリ不足が発生しました。
OSのオペレーティングシステムパラメタ（最大プロセス数，1プロセス当たりのメモリ確保サイズの上限値など）を見直してください。
0000000029
ファイルがありません。
ステータスファイルbb....bbのパス名が正しいか確認してください。又は，ユニット制御情報定義，サーバ定義を見直してください。
0000000030
キャラクタ型スペシャルファイルのオープン数オーバが発生しました。
直前に障害メッセージが出力されている場合は，そのメッセージの対策に従ってください。OSのオペレーティングシステムパラメタ（同時ファイルオープン許容数など）を見直してください。
0000000031
ファイル名が不正です。
次に示す原因が考えられます。
・パス名に使用できない文字を指定しています。
・パス名の長さが制限（167文字）を超えました。
・HiRDBファイル名の長さが制限（30文字）を超えました。
コマンドの引数に指定したステータスファイル名，ユニット制御情報定義，又はサーバ定義を見直してください。
0000000032
内部処理エラーが発生しました。
保守員に連絡してください。
0000000033
0000000034
0000000035
0000000036
0000000037
指定したパスはHiRDBファイルシステム領域ではありえません。
直前に障害メッセージが出力されている場合は，そのメッセージの対策に従ってください。
ステータスファイルbb....bbのパス名が正しいか確認してください。
該当するステータスファイルをpdfmkfsコマンドで初期設定してください。
0000000038
HiRDBファイルシステム領域の容量が不足しています。
HiRDBファイルシステム領域の容量を大きくして，pdfmkfsコマンドで再度初期設定してください。
別のHiRDBファイルシステム領域にステータスファイルを配置してください。
0000000039
HiRDBファイルのシステムバージョン不一致が発生しました。
直前に障害メッセージが出力されている場合は，そのメッセージの対策に従ってください。
bb....bbがあるHiRDBファイルシステム領域は使用できません。別のHiRDBファイルシステム領域を指定するか，又はpdfmkfsコマンドでHiRDBファイルシステム領域を再度初期設定してください。
0000000040
内部処理エラーが発生しました。
保守員に連絡してください。
0000000041
0000000042
0000000043
システムファイル用ではないHiRDBファイルシステム領域に，ステータスファイルを作成しようとしました。
HiRDBファイルシステム領域名及びpdfstatfsコマンドでHiRDBファイルシステム領域の使用目的を確認し，システムファイル用HiRDBファイルシステム領域にステータスファイルを作成してください。
KFPS01041-I
Physical status file with error is closed and status service is placed in shutdown state. remove the closed file with pdstsrm command and switch over to standby status file with pdstsinit command and pdstsopen command.　　（Ｅ＋Ｌ）
ステータスサービス機能は，エラーが発生したステータスファイルをclose後，閉塞状態にします。エラーが発生したファイルをpdstsrmコマンドで削除した後，pdstsinitコマンドとpdstsopenコマンドを使用して，予備ステータスファイルにしてください。
(Ｓ)処理を続行します。
(Ｏ)エラー発生ファイルをpdstsrmコマンドで削除してください。pdstsinitコマンドでファイルを初期設定後，pdstsopenコマンドで予備ステータスファイルにしてください。
KFPS01042-E
Logical status file aa....aa is short of capacity.　　（Ｅ＋Ｌ）
ステータスファイルで容量不足エラーが発生しました。
aa....aa：ステータスファイル名
(Ｓ)予備ステータスファイルがある場合，スワップ処理をします。予備ステータスファイルがない場合，スワップ処理を中止します。
[対策]ステータスファイル容量を見直してください。
KFPS01043-I
Fragmentation occurred in logical status file aa....aa　　（Ｅ＋Ｌ）
ステータスファイルでフラグメンテーションが発生しました。
aa....aa：ステータスファイル名
(Ｓ)予備ステータスファイルがある場合，スワップ処理をします。予備ステータスファイルがない場合，スワップ処理を中止します。
KFPS01044-I
Current logical status file aa....aa is placed in the one-system operation state. The normal system is b. Take appropriate action immediately.　　（Ｌ＋Ｓ）
現用のステータスファイルaa....aaが片系運転状態になりました。正常系を表示します。至急，対策してください。
aa....aa：現用のステータスファイル名
b：正常に動作している系｛A｜B｝
(Ｓ)処理を続行します。
[対策]次に示すどれかの対策をしてください。
・予備ファイルを用意し，pdstsswapコマンドでステータスファイルをスワップします。
・障害になった原因を特定して対策した後に，現用ファイルの障害が発生した系をpdstsinitコマンドで初期設定し，pdstsopenコマンドでオープンします。
ステータスファイルの片系運転時にHiRDBを開始する場合，このメッセージに表示される情報は，次に示すオペランドを指定するときに必要になるため，記録しておくことをお勧めします。
・pd_syssts_last_active_file
・pd_syssts_last_active_side
・pd_sts_last_active_file
・pd_sts_last_active_side
KFPS01050-E
Inter-process communication error occurred.　　（Ｅ）
プロセス間通信エラーが発生しました。
ステータスサービス機能へのサービス要求処理中にプロセス間通信エラーが発生しました。又は，ステータスサービス機能が動作中の場合，RPCでエラーが発生しました。
(Ｓ)処理を中止します。
(Ｏ)HiRDB動作環境を調査して障害要因を取り除いた後，再度ステータスサービス機能にサービス要求をしてください。
KFPS01051-I
Physical status file with error is closed and status service is placed in shutdown state.　　（Ｅ＋Ｌ）
ステータスサービス機能は，エラーが発生したステータスファイルをクローズ後，閉塞状態にします。
(Ｓ)エラー発生ファイルをpdstsinitコマンドで初期設定後，pdstsopenコマンドで予備ステータスファイルにしてください。
KFPS01060-I
Status file aa....aa open.　　（Ｌ＋Ｓ）
ステータスファイルのaa....aaをオープンしました。
ステータスファイルのオープンを完了しました。
aa....aa：ステータスファイルのパス名，又はステータスファイル名
(Ｓ)処理を続行します。
KFPS01061-I
Status file aa....aa closed.　　（Ｌ＋Ｓ）
ステータスファイルのaa....aaをクローズしました。
ステータスファイルのクローズを完了しました。
aa....aa：ステータスファイルのパス名，又はステータスファイル名
(Ｓ)処理を続行します。
KFPS01062-I
Status file swapping started.reason=aaaaaaaa　　（Ｌ＋Ｓ）
ステータスファイルのスワップ処理を開始しました。
aaaaaaaa：スワップを開始した契機の内容
COMMAND：スワップコマンド（pdstsswap）入力
ONLINE：オンライン中の現用ファイルへのアクセスエラー
START：ステータスサービス機能の開始時，及び再開始時の現用ファイル異常（アクセスエラー，A系/B系間の論理的エラー）
(Ｓ)処理を続行します。
KFPS01063-I
Status file swapping completed. current logical status file:aa....aa　　（Ｌ＋Ｓ）
ステータスファイルのスワップ処理を完了しました。
aa....aa：現用のステータスファイル名
(Ｓ)処理を続行します。
[対策]障害が発生したステータスファイルがある状態でHiRDBを開始する場合，このメッセージに表示される情報が次に示すオペランドを指定するときに必要になるため，記録しておくことをお勧めします。
・pd_syssts_last_active_file
・pd_sts_last_active_file
KFPS01064-E
Error occurred during status file swapping. reason code=aa....aa　　（Ｅ＋Ｌ）
ステータスファイルのスワップ処理でエラーが発生しました。
aa....aa：理由コード
理由コードと対策を表に示します。
(Ｓ)スワップ処理を中止します。
(Ｏ)理由コード一覧を見て対策してください。
理由コード
意味
対策
0000000001
予備のステータスファイルがありません。
予備のステータスファイルを準備してください。
0000000002
0000000003
プロセス固有領域の確保に失敗しました。
直前に出力された障害メッセージの対策に従ってください。
0000000004
スワップ先にできる予備のステータスファイルがありません。現用ファイル以外のステータスファイルが閉塞状態，若しくは予約状態です。又は，容量が不足しています。
予備のステータスファイルを準備してください。予備のステータスファイルがあるのにこの理由コードが出力される場合は，予備のステータスファイルの容量が不足しています。ステータスファイルの容量を見積もり直し，容量を大きくした予備のステータスファイルを準備してください。容量を大きくしたステータスファイルを現用ファイルにした後，残りのステータスファイルも容量を大きくしてください。
0000000005
現用のステータスファイルに障害が発生しました。
直前に障害メッセージが出力されている場合は，そのメッセージの対策に従ってください。出力されていない場合は，保守員に連絡してください。
0000000006
内部処理エラーが発生しました。
保守員に連絡してください。
0000000007
直前に障害メッセージが出力されている場合は，そのメッセージの対策に従ってください。出力されていない場合は，保守員に連絡してください。
0000000008
0000000009
保守員に連絡してください。
KFPS01070-E
Error occurred during aa....aa command processing. reason code=bb....bb　　（Ｅ＋Ｌ）
aa....aaコマンド処理でエラーが発生しました。
ステータスサービス機能のコマンド処理でエラーが発生しました。
aa....aa：コマンド名
bb....bb：理由コード
理由コードと対策を表に示します。
(Ｓ)コマンド処理を終了します。
(Ｏ)以前に出力されたエラーメッセージを調査してください。障害を取り除いた後，再度コマンドを入力してください。
理由コード
意味
対策
0000000001
ステータスファイル管理レコード（STR）情報不正
以前に障害メッセージが出力されていれば，そのメッセージに従って対策してください。
0000000002
ステータスファイル管理レコード（SHR）情報不正
又は，コマンドに指定した引数を見直してください。原因が不明なときは，ファイルを保存し，HiRDB管理者に連絡してください。
0000000003
現用ファイルとレコード長が異なります。又は，A系とB系のファイル容量が異なります。
pdlsコマンドで，-d stsオプションを指定し，ステータスファイルのレコード長，レコード数を調査してください。又は，pdstsinitコマンドで初期設定してください。
0000000004
ファイルの状態がコマンドを入力できる状態ではありません。
pdlsコマンドで，-d stsオプションを指定し，ファイル状態を調査してください。ファイル状態を正しく設定してから，再度コマンドを実行してください。
0000000005
基本ファイルシステムエラー
以前に出力されたメッセージ，又はステータスサービス機能が出力したメッセージがあれば，そのメッセージに従って対策してください。
0000000006
ユニット制御情報定義，又はサーバ定義に定義されていないファイル名を指定しました。
コマンドで指定した引数を見直してください。
0000000007
プロセス間通信エラー
以前に障害メッセージが出力されていれば，そのメッセージに従って対策してください。障害を取り除き，再度コマンドを実行してください。
0000000008
予備のステータスファイルがありません。
予備のステータスファイルを準備してください。
0000000009
スワップ処理エラー
ステータスファイルを準備して，再度HiRDBを開始してください。
0000000010
システムコールエラー
障害を取り除き，再度コマンドを実行してください。
0000000011
ほかのステータスサービス機能がステータスファイルを（OPEN）使用中，又はほかのステータスサービス機能のコマンドが実行中
システム定義に指定したステータスファイル名に重複がないか見直してください。又は，ほかのステータスサービス機能で使用中のステータスファイルをクローズするか，若しくはステータスサービス機能の終了，及びコマンドの終了を待ってください。
0000000012
システム定義解析エラー
システム定義を見直してください。
0000000013
プロセス間通信初期化エラー
障害を取り除き，再度コマンドを実行してください。
0000000014
コマンドが受付状態ではありません。
HiRDB起動中に再度コマンドを実行してください。
0000000015
RPC電文内データ長不正
保守員に連絡してください。
0000000016
現用ファイルを指定しました。
pdlsコマンドで-d stsオプションを指定して，ファイル状態を調査し，コマンドに指定した引数を見直してください。又は，ステータスファイルをスワップし，再度コマンドを実行してください。
0000000017
指定ファイルの状態は，変更済みです。
pdlsコマンドで-d stsオプションを指定して，ファイル状態を確認してください。
0000000018
ファイルチェックで異常を検出しました。
エラーが発生したファイルをpdstsinitコマンドで初期設定してください。
KFPS01081-I
Usage: pdstsinit [-x host_name | -u unit_id] -f full_path_name [-l record_length] [-c record_number]
pdstsinit -s server_name -f full_path_name [-l record_length] [-c record_number]　　（Ｅ＋Ｓ）
HiRDB/シングルサーバでのpdstsinitコマンドの使用方法を示します。コマンドの形式が誤っている場合に出力します。
使用方法：pdstsinit -f　ファイル名　［-l　レコード長］　［-c　レコード数］
(Ｓ)処理を終了します。
(Ｏ)使用方法に従ってコマンドを実行してください。
KFPS01081-I
Usage: pdstsinit {-x host_name | -u unit_id} -f full_path_name [-l record_length] [-c record_number] [-D]
pdstsinit -s server_name [-x host_name|-u unit_id] -f full_path_name [-l record_length] [-c record_number] [-D]　　（Ｅ＋Ｓ）
HiRDB/パラレルサーバでのpdstsinitコマンドの使用方法を示します。コマンドの形式が誤っている場合に出力します。
使用方法：pdstsinit -f　ファイル名　［-l　レコード長］　［-c　レコード数］　［-D］
(Ｓ)処理を終了します。
(Ｏ)使用方法に従ってコマンドを実行してください。
KFPS01082-I
Usage: pdstsrm [-x host_name | -u unit_id] -f full_path_name
pdstsrm -s server_name -f full_path_name　　（Ｅ＋Ｓ）
HiRDB/シングルサーバでのpdstsrmコマンドの使用方法を示します。コマンドの形式が誤っている場合に出力します。
使用方法：pdstsrm　-f　ファイル名
(Ｓ)処理を終了します。
(Ｏ)使用方法に従ってコマンドを実行してください。
KFPS01082-I
Usage: pdstsrm {-x host_name | -u unit_id} -f full_path_name [-D]
pdstsrm -s server_name [-x host_name|-u unit_id] -f full_path_name [-D]　　（Ｅ＋Ｓ）
HiRDB/パラレルサーバでのpdstsrmコマンドの使用方法を示します。コマンドの形式が誤っている場合に出力します。
使用方法：pdstsrm　-f　ファイル名　［D］
(Ｓ)処理を終了します。
(Ｏ)使用方法に従ってコマンドを実行してください。
KFPS01083-I
Usage: pdstsopen [-x host_name | -u unit_id] {-f full_path_name | -n logical_file_name}
pdstsopen -s server_name {-f full_path_name | -n logical_file_name}　　（Ｅ＋Ｓ）
HiRDB/シングルサーバでのpdstsopenコマンドの使用方法を示します。コマンドの形式が誤っている場合に出力します。
使用方法：pdstsopen　{-f　ファイル名　|　-n　論理ファイル名}
(Ｓ)処理を終了します。
(Ｏ)使用方法に従ってコマンドを実行してください。
KFPS01083-I
Usage: pdstsopen {-x host_name | -u unit_id} {-f full_path_name | -n logical_file_name}
pdstsopen -s server_name {-f full_path_name | -n logical_file_name}　　（Ｅ＋Ｓ）
HiRDB/パラレルサーバでのpdstsopenコマンドの使用方法を示します。コマンドの形式が誤っている場合に出力します。
使用方法：pdstsopen　{-f　ファイル名　|　-n　論理ファイル名}
(Ｓ)処理を終了します。
(Ｏ)使用方法に従ってコマンドを実行してください。
KFPS01084-I
Usage: pdstscls [-x host_name | -u unit_id] {-f full_path_name | -n logical_file_name}
pdstscls -s server_name {-f full_path_name | -n logical_file_name}　　（Ｅ＋Ｓ）
HiRDB/シングルサーバでのpdstsclsコマンドの使用方法を示します。コマンドの形式が誤っている場合に出力します。
使用方法：pdstscls　{-f　ファイル名　|　-n　論理ファイル名}
(Ｓ)処理を終了します。
(Ｏ)使用方法に従ってコマンドを実行してください。
KFPS01084-I
Usage: pdstscls {-x host_name | -u unit_id} {-f full_path_name | -n logical_file_name}
pdstscls -s server_name {-f full_path_name | -n logical_file_name}　　（Ｅ＋Ｓ）
HiRDB/パラレルサーバでのpdstsclsコマンドの使用方法を示します。コマンドの形式が誤っている場合に出力します。
使用方法：pdstscls　{-f　ファイル名　|　-n　論理ファイル名}
(Ｓ)処理を終了します。
(Ｏ)使用方法に従ってコマンドを実行してください。
KFPS01086-I
Usage: pdstsswap [-x host_name | -u unit_id]
pdstsswap -s server_name　　（Ｅ）
HiRDB/シングルサーバでのpdstsswapコマンドの使用方法を示します。コマンドの形式が誤っている場合に出力します。
使用方法：pdstsswap
(Ｓ)処理を終了します。
(Ｏ)使用方法に従ってコマンドを実行してください。
KFPS01086-I
Usage: pdstsswap {-x host_name | -u unit_id}
pdstsswap -s server_name　　（Ｅ）
HiRDB/パラレルサーバでのpdstsswapコマンドの使用方法を示します。コマンドの形式が誤っている場合に出力します。
使用方法：pdstsswap
(Ｓ)処理を終了します。
(Ｏ)使用方法に従ってコマンドを実行してください。
KFPS01090-E
Error occurred in system call aa....aa. [error code=bb....bb] function with error: cc....cc　　（Ｅ＋Ｌ）
aa....aaシステムコールでエラーが発生しました。
aa....aa：エラーが発生したシステムコール名
bb....bb：システムコールのリターン値
cc....cc：システムコールを発行した関数名
(Ｓ)エラー内容によって，処理を続行するか，又はHiRDBを異常終了します。
[対策]保守員に連絡してください。
KFPS01091-E
Insufficient memory. required memory size=aa....aa bytes, area type: bb....bb　　（Ｅ＋Ｌ）
ステータスサービス機能でメモリ不足が発生しました。
aa....aa：確保しようとした領域のサイズ（単位：バイト）
bb....bb：メモリ不足が発生した領域の種別
PROCESS：プロセス固有領域
STATIC SHMPOOL：静的共用メモリ
(Ｓ)内容によって，処理を続行します。又は，HiRDBを異常終了します。
[対策]メモリ不足が発生した領域の種別に従って，対処してください。
〈静的共用メモリの場合〉
保守員に連絡してください。
〈プロセス固有領域の場合〉
プロセス固有領域の使用状況を見直し，対策後，再度実行してください。なお，繰り返し発生する場合，保守員に連絡してください。
KFPS01099-E
Error occurred with aa....aa function. error code=bb....bb function: cc....cc　　（Ｅ＋Ｌ）
aa....aa関数でエラーが発生しました。
HiRDB関数でエラーが発生しました。
aa....aa：エラーが発生したHiRDB関数名
bb....bb：HiRDB関数の内部リターン値
cc....cc：HiRDB関数を発行した関数名
(Ｓ)エラーの内容によって，処理を続行するか，又はHiRDBを異常終了します。
[対策]このメッセージの前後に出力されたメッセージから原因を調査し，障害を取り除いた後，再度実行してください。このメッセージの前後にメッセージが出力されていない場合，「RPC関連エラーの詳細コード」及び「システム関連エラーの詳細コード」を参照し，HiRDB関数の内部リターン値と同じコードがあるならば，該当するコードの対策に従ってください。HiRDBの異常終了時は，コアファイルを取得してください。
KFPS01103-E
Unable to start log service. reason code=aaaa　　（Ｅ＋Ｌ）
ログサービス機能を開始できません。
ログサービス機能の開始・再開始処理中に障害が発生しました。
aaaa：障害の内容を示す理由コード
理由コードと対策を表に示します。
(Ｓ)HiRDBを異常終了します。
[対策]ログサービス機能が開始・再開始できない理由を理由コード一覧を見て対策してください。その後，再度HiRDBを開始してください。
理由コード
意味
対策
備考
101
メモリ不足発生
メモリ使用量を見直してください。
－
103
ネットワーク障害発生
障害を回復した後，システムを再度起動してください。
405
定義解析処理中にエラー検出
定義ファイルを見直して，正しく設定した後，システムを再度起動してください。
エラーの詳細は， KFPS002××で示されます。
501
HiRDBサーバ数の上限値を超えました
定義内容を修正した後，システムを再度起動してください。
－
502
ステータスファイル中のシステムの回復に必要な情報がありません。
各サーバ定義のサーバ用ステータスファイルに関するオペランドを見直してください。次に示す項目が主な要因として考えられます。
・pd_sts_file_name_1～7オペランドに指定しているステータスファイル名を変更した
・pd_sts_file_name_1～7オペランドに指定しているステータスファイルを初期化した
・pd_sts_last_active_file， pd_sts_last_active_sideオペランドに指定している論理ファイル名又は系が前回稼働時に現用だったステータスファイルと異なっている
503
ステータスファイルの入出力処理でエラー発生
エラー原因を調査し，障害を回復後，システムを再度起動してください。
504
ログサービス機能のプロセス起動中にエラー発生
508
シンクポイントダンプサービス機能のプロセス起動中にエラー発生
512
シンクポイントダンプサービス機能関係の定義解析エラー発生
514
トランザクションリカバリログサービス機能のプロセス起動中にエラーが発生しました。
エラー原因を調査し，障害を回復後，HiRDBを再度開始してください。
詳細なエラー原因は，このメッセージ以前に表示されています。
515
トランザクションログリカバリサービス機能の定義解析処理中にエラーが発生しました。
このメッセージ以前に出力されているメッセージに従って，定義を修正してください。その後，HiRDBを再度開始してください。
－
516
ログサービス機能のプロセスの内部スレッドの起動に失敗しました。
エラー原因を調査し，障害を回復後，HiRDBを再度開始してください。
詳細なエラー原因は，このメッセージ以前に表示されています。
541
ステータスサービス機能の起動中にエラーが発生しました。
このメッセージの前に出力されているメッセージに従って障害を回復し，システムを再度起動してください。
－
（凡例）－：該当しません。
KFPS01104-W
Unable to recover previous log service conditions referring to status file; continues restart processing without status file. reason code=aaaa　　（Ｌ）
前回のログサービス機能の状態をステータスファイルから回復できません。ステータスファイルなしで再開始を続行します。
aaaa：障害の内容を示す理由コード
理由コードと対策を表に示します。
(Ｓ)処理を続行します。
[対策]理由コード一覧を見て対策してください。
理由コード
意味
対策
備考
502
前回のオンライン状態がステータスファイル中にありません。
－
考えられる原因を次に示します。
前回起動時のステータス書き込み中に障害発生
503
ステータスレコードの入出力処理でエラー発生
このメッセージの前にステータスサービスのメッセージ（KFPS010××）が出力されるので，再開始不成功の場合，その指示に従ってください。
－
（凡例）－：該当しません。
KFPS01108-W
Error occurred while terminating log service; continues processing. reason code=aaaa　　（Ｌ）
ログサービス機能の終了中に障害が発生しましたが，このまま続行します。
aaaa：障害の内容を示す理由コード
理由コードと対策を表に示します。
(Ｓ)処理を続行します。
[対策]理由コード一覧を見て調査し，必要があれば対策してください。
理由
コード
意味
対策
101
メモリ不足発生
次回起動に備えて，メモリ容量を見直してください。
103
ネットワーク障害発生
次回起動に備えて，ネットワーク障害を回復してください。
503
ステータスファイルの入出力処理でエラー発生
次回起動に備えて，エラーの原因を調査し対策してください。
KFPS01109-W
Minor error occurred while analyzing definitions for log service. file being analyzed aa....aa, record number=bb....bb, reason code=cccc　　（Ｅ＋Ｌ）
ログサービス機能に関係する定義解析中に，軽度エラーが発生しました。
aa....aa：解析中の定義ファイル名
bb....bb：エラーのあったレコード番号
cccc：障害の内容を示す理由コード
理由コードと対策を表に示します。
(Ｓ)エラーのあったpdlogadfg，又はpdlogadpfオペランドの定義文を無視して，ログサービス機能の開始・再開始処理を続行します（定義文がないものとして動作します）。
[対策]ログサービス機能に関係する定義を見直してください。
理由コード
意味
対策
備考
408
pdlogadfgオペランドに誤りがあります。
・-gオプションが未指定
・ファイルグループ名が他と重複
必要があればシステムを停止し定義を修正した後，再度起動してください。
－
409
pdlogadpfオペランドの-gオプション指定に誤りがあります。
・-gオプションが未指定
・そのファイルグループはpdlogadfgで未定義
411
pdlogadpfオペランドの-aオプション指定に誤りがあります。
・-aオプションが未指定
・-aオプションに指定したパス長が制限文字数を超えています。
・-aオプションに指定したHiRDBファイル名の長さが制限（30文字）を超えています。
412
pdlogadpfオペランドの-bオプション指定に誤りがあります。
・-bオプションが未指定（二重化ログ使用時）
・-bオプションに指定したパス長が制限文字数を超えています。
・-bオプションに指定したHiRDBファイル名の長さが制限（30文字）を超えています。
・ほかと重複
二重化ログ使用
413
pdlogadfgオペランドの数が最大値を超えました。
定義エラーとなったpdlogadfgオペランドは定義数に含まれません。
415
同一ファイルグループ名のpdlogadpfオペランドが二つ以上あります。
－
422
pdlogadfgオペランドの-dオプション指定に誤りがあります。又は，指定されていません。
423
pdlogadpfオペランドの-dオプション指定に誤りがあります。又は，指定されていません。
（凡例）－：該当しません。
KFPS01113-E
Unable to start aaaa(xx....xx) log file service. reason code=bbbb　　（Ｅ＋Ｌ）
aaaa(xx....xx)ログサービス機能を開始できません。
ログサービス機能の開始・再開始処理中に障害が発生しました。
aaaa：ログファイル種別
sys：システムログファイル
xx....xx：HiRDBのサーバ名
bbbb：障害の内容を示す理由コード
理由コードと対策を表に示します。
(Ｓ)ユニットの開始処理を中断します。
[対策]理由コード一覧を見て対策してください。その後，再度HiRDBを開始してください。
理由コード
意味
対策
備考
101
メモリ不足発生
メモリ使用量を見直してください。
－
103
ネットワーク障害発生
障害を回復した後，システムを再度起動してください。
114
システム内のメッセージ待ち行列識別子テーブルに定義がありません。
カーネルを再度コンフィグレーションしてください。その際メッセージ関連パラメタのmsgmniの値を変更してください。
405
定義解析処理中にエラー検出
定義ファイルを見直して，正しく設定した後，システムを再度起動してください。
エラーの詳細は，KFPS002××で示されます。
414
有効なログファイルグループ定義の数が，システム開始に必要な最小世代数に達していません。
対応するHiRDBサーバ定義のpdlogadfgオペランドを修正し，システムを再度起動してください。
有効な定義とは，pdlogadfgオペランドの内，エラーがなく，かつ，ONL指定されたものです。
416
pdlogadpfオペランドが定義されていないファイルグループがあります。
対応するHiRDBサーバ定義のpdlogadpfオペランドを修正し，システムを再度起動してください。
－
503
ステータスファイルの入出力処理でエラー発生
エラー原因を調査し，障害を回復後，システムを再度起動してください。
504
ログ入出力プロセスの起動中にエラー発生
510
ログファイルのチェック処理でエラー検出
詳細なエラー原因は，このメッセージ以前に表示されています。
（凡例）－：該当しません。
KFPS01114-W
Error occurred while terminating aaaa(xx....xx) log file service;continues processing. reason code=bbbb　　（Ｅ＋Ｌ）
aaaa(xx....xx)ログサービス機能の終了中に障害が発生しましたが，このまま続行します。
aaaa：ログファイル種別
sys：システムログファイル
xx....xx：HiRDBのサーバ名
bbbb：障害の内容を示す理由コード
理由コードと対策を表に示します。
注　このメッセージが出力されても，次回のログサービス機能は正常に開始します。
(Ｓ)終了処理を続行します。
[対策]理由コード一覧を見て，必要があれば対策してください。
理由コード
意味
対策
備考
101
メモリ不足発生
次回起動に備えて，メモリ容量を見直してください。
－
103
ネットワーク障害発生
次回起動に備えて，ネットワーク環境を回復してください。
503
ステータスファイルの入出力処理でエラー発生
次回起動に備えて，エラー原因を調査し，対策してください。
511
ログファイルの終了処理でエラー発生
次回起動に備えて，エラー原因を調査し，対策してください。
詳細なエラー内容は，このメッセージ以前に出力されます。
（凡例）－：該当しません。
KFPS01115-E
Unable to start I/O service of aaaa(xx....xx) log file. reason code=bbbb　　（Ｅ＋Ｌ）
aaaa(xx....xx)ログファイルの入出力プロセスを開始できません。
aaaa：ログファイル種別
sys：システムログファイル
xx....xx：HiRDBのサーバ名
bbbb：障害の内容を示す理由コード
理由コードと対策を表に示します。
(Ｓ)HiRDBを終了します。
[対策]理由コード一覧を見て対策してください。その後，再度HiRDBを開始してください。
理由コード
意味
対策
備考
101
メモリ不足発生
メモリ使用量を見直してください。
－
103
ネットワーク障害発生
障害を回復した後，システムを再度起動してください。
405
定義解析処理中にエラー検出
定義ファイルを見直して正しく設定した後，システムを再度起動してください。
エラーの詳細は，KFPS002××に示しています。
503
ステータスファイルの入出力処理でエラー発生
エラー原因を調査して障害を回復後，システムを再度起動してください。
－
（凡例）－：該当しません。
KFPS01116-W
Error occurred while terminating I/O service of aaaa(xx....xx) log file;continues processing. reason code=bbbb　　（Ｌ）
aaaa(xx....xx)ログファイルの入出力プロセスの終了中に障害が発生しましたが，このまま続行します。
aaaa：ログファイル種別
sys：システムログファイル
xx....xx：HiRDBのサーバ名
bbbb：障害の内容を示す理由コード
理由コードと対策を表に示します。
注　このメッセージが出力されても，次回のログサービス機能は正常に開始します。
(Ｓ)終了処理を続行します。
[対策]理由コード一覧を見て，必要があれば対策してください。
理由
コード
意味
対策
101
メモリ不足発生
次回起動に備えて，メモリ容量を見直してください。
103
ネットワーク障害発生
次回起動に備えて，ネットワーク障害を回復してください。
503
ステータスファイルの入出力処理でエラー発生
次回起動に備えて，エラー原因を調査して，対策してください。
KFPS01121-E
Insufficient memory. required memory size=aa....aa, type:bb....bb　　（Ｌ）
メモリ不足が発生しました。
aa....aa：確保しようとしたサイズ
bb....bb：メモリ不足が発生した領域の種別
STATIC_SHMPOOL：静的共用メモリ
(Ｓ)処理を中止します。
[対策]システム定義を見直して，再度実行してください。
KFPS01125-E
Unable to use log service server aaaa(xx....xx). reason code=cccc-dd　　（Ｌ）
サーバ：aaaa(xx....xx)はログサービス機能を使用できません。
aaaa：サーバ名
xx....xx：HiRDB内部コード
cccc：理由コード
理由コードと対策を表に示します。
dd：HiRDB内部コード
(Ｓ)このメッセージの後に出力されるaaaaaaaaのサーバのメッセージに従います。
(Ｏ)理由コード一覧を見て対策してください。
理由コード
意味
オペレータの処置
HiRDB管理者の処置
101
メモリ不足発生
－
このメッセージの後に出力されるメッセージに従ってください。
104
ログサービス機能がオンライン中ではありません。
システムを一度停止し，再度起動してください。
HiRDBが正常に開始していない理由を調査してください。
903
同じ名称のサーバが，ログサービス機能を使用しようとしました。
－
サーバ名，又は開始モードを見直してください。
904
ログサービス機能が正常開始したため，該当するサーバは再開始できません。
このメッセージの後に，出力されるメッセージに従ってください。
905
ステータスファイルのアクセスエラーのため，該当するサーバにログサービスを提供できません。
ステータスファイルのアクセスエラーの原因を調査してください。
906
ログファイルの入出力エラー，又はそのほかの障害のため，該当するサーバの再開始に必要なログがありません。
必要に応じて，ログファイルのエラー原因を調査してください。
907
シンクポイントサービス機能を開始しようとしましたが，該当するサーバには，シンクポイントサービス機能は提供できません。
このメッセージの後に出力されるメッセージに従ってください。
HiRDBサーバ定義に誤りがないか調べてください。
908
シンクポイントサービス機能を使用しないサーバに対する，シンクポイントサービス定義があります。
－
（凡例）－：該当しません。
KFPS01128-W
Unable to specify bb....bb in aa....aa operand, replace bb....bb with cc....cc, server=dd....dd　　（Ｌ）
aa....aaオペランドにはbb....bbを指定できません。bb....bbをcc....ccに置き換えます。
aa....aa：オペランド名
bb....bb：aa....aaオペランドの指定値
cc....cc：aa....aaオペランドの置き換えた値
dd....dd：サーバ名
(Ｓ)処理を続行します。
[対策]マニュアル「HiRDB Version 7 システム定義」を参照して，aa....aaオペランドの指定値を見直してください。特に次に示すことに注意してください。
・組み合わせできない値を指定していないか
・再開始時に変更できないオペランドの値を変更していないか
KFPS01129-E
Definition analysis error . definition name=aa....aa. server name=bb....bb. reason code=cc....cc　　（Ｅ＋Ｌ）
bb....bbサーバの定義解析処理で，aa....aaオペランドの解析エラーが発生しました。
aa....aa：オペランド名
bb....bb：HiRDBのサーバ名
cc....cc：障害の内容を表す理由コード
1：指定値がオペランドの指定範囲を超えています。
2：指定したオペランドの数に誤りがあります。
606：上記以外のエラーです。
(Ｓ)処理を終了します。
[対策]マニュアル「HiRDB Version 7 システム定義」を参照して，aa....aaオペランドの指定値を見直してください。
KFPS01130-W
Error occurred while starting aaaa(bb....bb) log service; continues processing. reason code=cccc　　（Ｌ）
aaaa(bb....bb)では，ログサービス機能の開始中に障害が発生しましたが，このまま続行します。
aaaa：ログファイル種別
sys：システムログファイル
bb....bb：HiRDBのサーバ名
cccc：障害の内容を表す理由コード
1654：データ連動用連絡ファイル不正
(Ｓ)理由コードが1654の場合，システムログファイル中のHiRDB Datareplicator抽出未完了/抽出完了状態は，前回のHiRDB停止時のままの状態でシステム起動を続行します。該当するサーバでHiRDB停止中に抽出が完了しているログファイルがあっても，抽出未完了状態を解除しません。
(Ｏ)理由コードが1654の場合，pdls -d rpl -jコマンドを実行してHiRDB Datareplicatorとの連絡ファイルを参照して，連動運用が続行できる状態であるかを確認してください。HiRDB Datareplicatorとの連動が続行できない状態であれば，管理者に連絡してください。
[対策]理由コードが1654の場合，HiRDB Datareplicator連携ができない状態であれば，マニュアル「HiRDBデータ連動機能　HiRDB Datareplicator Version 7」を参照してデータ連動をし直してください。
KFPS01150-E
Auto log unload service terminated. server=aa....aa:create dir=bb....bb:reason=cccc　　（Ｌ）
aa....aaサーバで自動ログアンロード機能を停止しました。
aa....aa：HiRDBのサーバ名
bb....bb：アンロードログファイル作成ディレクトリ名
cccc：障害の内容を表す理由コード
1660：全アンロードログファイル作成ディレクトリでシステムログファイルのアンロード処理に失敗しました。
1661：自動ログアンロード処理のプロセス生成に失敗しました。
1664：作成しようとしたアンロードログファイルがほかのプロセスで使用中です。
(Ｓ)処理を続行します。
[対策]次に示すどれかの処置をしてください。
・理由コードが1660の場合
アンロードログファイル作成ディレクトリの空きディスク容量が不足しているか，又はディスク障害が発生しています。空きディスク容量を確保するか，又はディスク障害を回復してください。その後，pdlogatul -bコマンドを実行するか，又はHiRDBを再度正常開始して自動ログアンロード機能を再開してください。
・理由コードが1661の場合
サーバマシンで実行できるプロセスの最大実行数を確認して不要なプロセスを終了してください。また，メモリなどのシステムリソースに空きがあるかを確認してください。
・理由コードが1664の場合
アンロードログファイル作成先ディレクトリ内のファイルを操作しているプロセスがあるかどうかを確認してください。その後，pdlogatul -bコマンドを実行するか，又はHiRDBを再度正常開始して自動ログアンロード機能を再開してください。
・上記以外の場合
次に示す資料を取得して保守員に連絡してください。
・$PDDIR/spool下の全ファイル
・HiRDBシステム定義ファイル
・syslogfile（Windows NTの場合はイベントログ）
・pdlogls -d sysコマンドの実行結果
KFPS01151-I
aa....aa changed auto log unload directory from bb....bb to cc....cc.reason=dddd　　（Ｌ）
aa....aaサーバが使用するアンロードログファイル作成ディレクトリをbb....bbからcc....ccへ切り替えました。
aa....aa：HiRDBのサーバ名
bb....bb：切り替え元のアンロードログファイル作成ディレクトリ名
切り替え元のアンロードログファイル作成ディレクトリ名が77文字以上の場合は，切り替え元のアンロードログファイル作成ディレクトリ名の後ろから76文字を出力します。
cc....cc：切り替え先のアンロードログファイル作成ディレクトリ名
切り替え先のアンロードログファイル作成ディレクトリ名が77文字以上の場合は，切り替え先のアンロードログファイル作成ディレクトリ名の後ろから76文字を出力します。
dddd：理由コード
1665：アンロードログファイル作成ディレクトリがあるディスク容量が満杯になりました。
(Ｓ)処理を続行します。
[対策]アンロードログファイル作成ディレクトリ内のアンロードログファイルを別領域に移動するか，又は不要なアンロードログファイルを削除してください。
KFPS01152-W
No use aa....aa as auto log unload directory. server=bb....bb:reason=cccc　　（Ｌ）
bb....bbサーバが使用するアンロードログファイル作成ディレクトリ（ディレクトリ名aa....aa）にディレクトリを切り替えることができません。ほかのディレクトリを切り替え先にします。
aa....aa：アンロードログファイル作成ディレクトリ名
bb....bb：HiRDBのサーバ名
cccc：詳細コード（[対策]に示す一覧表を参照してください）
(Ｓ)処理を続行します。
[対策]次に示す詳細コード一覧を参照して，対策してください。
詳細コード
意味
対策
1661
資源不足（メモリ，ファイル記述子，ロックセグメント）が発生しました。
メモリ所要量を見積もり直してください。
また，必要であれば次に示すOSのオペレーティングシステムパラメタの値を変更してください。
・maxfiles
・nfile
・nflocks
1666
パーミション不正が発生しました。
アンロードログファイル作成ディレクトリに書き込み権限を与えてください。
1667
入出力障害が発生しました。
アンロードログファイル作成ディレクトリがあるディスクの障害を回復してください。データベースの回復に必要なアンロードログファイルが消失した場合はバックアップを取得してください。
1668
アンロードログファイル作成ディレクトリ又はアンロードログファイル作成用のHiRDBファイルシステム領域がありません。
アンロードログファイル作成ディレクトリ又はアンロードログファイル作成用のHiRDBファイルシステム領域を作成してください。
1669
前回使用時に作成したアンロードログファイルが，アンロードログファイル作成ディレクトリ内にあります。
アンロードログファイルを別領域に移動するか，又は不要なアンロードログファイルを削除してください。
1670
アンロードログファイル作成ディレクトリ又はアンロードログファイル作成用のHiRDBファイルシステム領域の種別が不正です。
・アンロードログファイル作成ディレクトリのパス名が正しいか確認してください。
・アンロードログファイル作成用のHiRDBファイルシステム領域が，ユティリティ用として作成されているか確認してください。
KFPS01153-I
Auto log unload service restart. server=aa....aa:create dir=bb....bb:reason=cccc　　（Ｌ）
aa....aaサーバの自動ログアンロード機能を再開します。
aa....aa：HiRDBのサーバ名
bb....bb：アンロードログファイル作成ディレクトリ名
cccc：理由コード
1662：pdlogatul -bコマンドを実行して自動ログアンロード機能を再開しました。
(Ｓ)処理を続行します。
KFPS01154-I
Auto log unload service stopped. server=aa....aa:create dir=bb....bb:reason=cccc　　（Ｌ）
aa....aaサーバの自動ログアンロード機能を停止しました。
aa....aa：HiRDBのサーバ名
bb....bb：アンロードログファイル作成ディレクトリ名
cccc：理由コード
1662：pdlogatul -tコマンドを実行して自動ログアンロード機能を停止しました。
(Ｓ)処理を続行します。
KFPS01155-W
aa....aa changed auto log unload directory from bb....bb to cc....cc.reason=dddd　　（Ｌ）
aa....aaサーバが使用するアンロードログファイル作成ディレクトリ（ディレクトリ名bb....bb）に障害が発生したため，ディレクトリをbb....bbからcc....ccへ切り替えました。
aa....aa：HiRDBのサーバ名
bb....bb：切り替え元のアンロードログファイル作成ディレクトリ名
切り替え元のアンロードログファイル作成ディレクトリ名が77文字以上の場合は，切り替え元のアンロードログファイル作成ディレクトリ名の後ろから76文字を出力します。
cc....cc：切り替え先のアンロードログファイル作成ディレクトリ名
切り替え先のアンロードログファイル作成ディレクトリ名が77文字以上の場合は，切り替え先のアンロードログファイル作成ディレクトリ名の後ろから76文字を出力します。
dddd：詳細コード（[対策]に示す一覧表を参照してください）
(Ｓ)処理を続行します。
[対策]次に示す詳細コード一覧を参照して，対策してください。
詳細コード
意味
対策
1661
資源不足（メモリ，ファイル記述子，ロックセグメント）が発生しました。
メモリ所要量を見積もり直してください。
また，必要であれば次に示すOSのオペレーティングシステムパラメタの値を変更してください。
・maxfiles
・nfile
・nflocks
1666
パーミション不正が発生しました。
アンロードログファイル作成ディレクトリに書き込み権限を与えてください。
1667
入出力障害が発生しました。
アンロードログファイル作成ディレクトリがあるディスクの障害を回復してください。データベースの回復に必要なアンロードログファイルが消失した場合はバックアップを取得してください。
1668
アンロードログファイル作成ディレクトリ又はアンロードログファイル作成用のHiRDBファイルシステム領域がありません。
アンロードログファイル作成ディレクトリ又はアンロードログファイル作成用のHiRDBファイルシステム領域を作成してください。
1669
前回使用時に作成したアンロードログファイルが，アンロードログファイル作成ディレクトリ内にあります。
アンロードログファイルを別領域に移動するか，又は不要なアンロードログファイルを削除してください。
1670
アンロードログファイル作成ディレクトリ又はアンロードログファイル作成用のHiRDBファイルシステム領域の種別が不正です。
・アンロードログファイル作成ディレクトリのパス名が正しいか確認してください。
・アンロードログファイル作成用のHiRDBファイルシステム領域が，ユティリティ用として作成されているか確認してください。
KFPS01156-I
aa....aa wait for auto log unloading.file group=bb....bb:create dir=cc....cc　　（Ｌ）
aa....aaサーバで自動ログアンロードの完了を待っています。現在，ファイルグループbb....bbのシステムログファイルをアンロードしています。
aa....aa：HiRDBのサーバ名
bb....bb：アンロード中のシステムログファイルのファイルグループ名
cc....cc：アンロードログファイル作成ディレクトリ名
(Ｓ)処理を続行します。
KFPS01157-W
Unable to use auto log unload service. server=aa....aa:reason=bbbb　　（Ｌ）
aa....aaサーバでは自動ログアンロード機能を使用できません。
aa....aa：HiRDBのサーバ名
bbbb：理由コード
1662：HiRDBシステム定義に誤りがあります。
1663：ステータスファイルの情報が不正です。
(Ｓ)処理を続行します。
[対策]次に示すどれかの処置をしてください。
・理由コードが1662の場合
pd_log_auto_unload_pathオペランドの指定値に誤りがないか確認してください。誤りがなければHiRDBを再度正常開始して自動ログアンロード機能を開始してください。
・理由コードが1663の場合
直前にステータスファイルに関する障害メッセージが出力されている場合は，そのメッセージに従って対策してください。ステータスファイルに障害がない場合は，HiRDBを再度正常開始して自動ログアンロード機能を開始してください。
・上記以外の場合
次に示す資料を保存して保守員まで連絡してください。
・$PDDIR/spool下の全ファイル
・HiRDBシステム定義ファイル
・syslogfile（Windows NTの場合はイベントログ）
・pdlogls -d sysコマンドの表示結果
KFPS01160-E
Insufficient system log space. Transaction service stopped. Transactions terminate by force, server = aa....aa, output file name = bb....bb　　（Ｌ）
システムログファイルの空き率が警告値未満になりました。対象サーバはaa....aaです。システムログファイルの空き容量監視機能によってaa....aaサーバへの新規トランザクションのスケジューリングを抑止し，サーバ内の全トランザクションを強制終了します。また，システムログファイルの状態情報ファイルを$PDDIR/spool/pdjnlinf/bb....bbに出力します。
システムログファイルの空き容量監視機能については，マニュアル「HiRDB Version 7 システム運用ガイド」を参照してください。
aa....aa：HiRDBのサーバ名
bb....bb：システムログファイルの状態情報ファイル名
(Ｓ)処理を続行します。
[対策]次に示す処置をしてください。
・pdloglsコマンドでシステムログファイルの状態を調べて，スワップ先にできる状態のシステムログファイルを増やしてください。
・KFPS01161-Iメッセージが出力されるまでaa....aaサーバへの新規トランザクションの発生を抑止してください。
これらの処置をした後に，サーバaa....aaのシステムログファイルの空き容量が不足した原因を解消してください。
システムログファイルの空き率が警告値未満になったときのHiRDB管理者の処置については，マニュアル「HiRDB Version 7 システム運用ガイド」の「システムログファイルの空き容量監視機能」を参照してください。
なお，リアルタイムSANレプリケーションを適用している場合に，このメッセージの前にKFPS02178-Eメッセージが出力されているときは，KFPS02178-Eメッセージの対策に従ってください。
KFPS01161-I
System log available space gained. Transaction service restart, server = aa....aa, rest = bb....bb%　　（Ｌ）
システムログ出力可能領域を新たに取得したため，システムログファイルの空き率が警告値以上になりました。対象サーバはaa....aaです。システムログファイルの空き容量監視機能による新規トランザクションのスケジューリング抑止を解除します。システムログファイルの空き容量監視機能については，マニュアル「HiRDB Version 7 システム運用ガイド」を参照してください。
aa....aa：HiRDBのサーバ名
bb....bb：システムログが出力できるシステムログファイルの残容量の割合（単位：％）
システムログファイルの全容量を100%とした場合の割合です。
(Ｓ)処理を続行します。
[対策]次に示す処置をしてください。
・新規トランザクションの発生抑止を解除してください。
・KFPS01160-Eメッセージの対策を実施していない場合はすぐに実施してください。
・bb....bbが少ない場合，システムログファイルの空き容量不足の原因が解消されていません。このまま運用を続けると，システムログファイルの空き容量不足が再度発生する可能性があります。空き容量不足を解消する方法については，マニュアル「HiRDB Version 7 システム運用ガイド」の「システムログファイルの空き容量監視機能」を参照してください。
KFPS01162-W
Insufficient system log space, server = aa....aa, output file name = bb....bb　　（Ｌ）
システムログファイルの空き率が警告値未満になりました。対象サーバはaa....aaです。システムログファイルの状態情報ファイルを$PDDIR/spool/pdjnlinf/bb....bbに出力します。
aa....aa：HiRDBのサーバ名
bb....bb：システムログファイルの状態情報ファイル名
(Ｓ)処理を続行します。
[対策]pdloglsコマンドでシステムログファイルの状態を調べて，スワップ先にできる状態のシステムログファイルを増やしてください。システムログファイルの空き率が警告値未満になったときのHiRDB管理者の処置については，マニュアル「HiRDB Version 7 システム運用ガイド」の「システムログファイルの空き容量監視機能」を参照してください。
この処置をした後に，サーバaa....aaのシステムログファイルの空き容量が不足した原因を解消してください。
なお，リアルタイムSANレプリケーションを適用している場合に，このメッセージの前にKFPS02178-Eメッセージが出力されているときは，KFPS02178-Eメッセージの対策に従ってください。
KFPS01163-W
Waiting for transaction completion, server = aa....aa, current transaction count = bb....bb　　（Ｌ）
トランザクションの終了を待ち合わせています。対象サーバはaa....aaです。終了を待ち合わせているトランザクションを強制終了するとRDエリアが障害閉塞になる可能性があるため，強制終了しないでください。
aa....aa：HiRDBのサーバ名
bb....bb：終了を待ち合わせているトランザクションの数
[対策]KFPS01161-Iメッセージが出力されるまでaa....aaサーバへの新規トランザクションの発生を抑止してください。終了を待ち合わせているトランザクションを調べる方法については，マニュアル「HiRDB Version 7 システム運用ガイド」の「システムログファイルの空き容量監視機能」を参照してください。
KFPS01170-E
Unable to read system log file, server=aa....aa, reason=bbbb(cc....cc)　　（Ｌ）
オンライン再編成の追い付き反映で，システムログファイルの更新ログが読み込みできません。
aa....aa：HiRDBのサーバ名
bbbb：理由コード（[対策]を参照してください）
cc....cc：詳細情報（[対策]を参照してください）
(Ｓ)処理を終了します。
[対策]次の理由コードと詳細情報の一覧を参照し，対処してください。なお，更新可能なオンライン再編成の再実行については，マニュアル「インナレプリカ機能 HiRDB Staticizer Option Version 7」を参照してください。
理由コード
(bbbb)
詳細情報
(cc....cc)
意味
対策
101
割り当てようとしたメモリサイズ
必要なメモリ領域の確保に失敗しました。
システムの仮想メモリの容量を見直してください。容量が不足している場合は，仮想メモリの容量を拡張してください。メモリ容量を拡張できない場合は，不要なほかの常駐プログラムやプロセスを停止するなど，仮想メモリの空きを確保してください。
106
内部情報
HiRDBが使用する共用メモリにアクセスできません。
HiRDBが停止しているときにこのメッセージが出力された場合，HiRDBを再度開始してからpdorendコマンドを再実行してください。
HiRDB稼働中にこのメッセージが出力された場合，共用メモリ領域が消失しているか，又はアクセス権限が不正になっていることが考えられます。直前にシステムコールエラーのメッセージが出力されている場合は，そのメッセージに従って対策してください。システムコールエラーのメッセージが出力されていない場合は，次の項目について問題がないか確認してください。
・更新可能なオンライン再編成の実行者がHiRDB管理者かどうか
・HiRDB運用ディレクトリにあるspoolディレクトリ下のファイルを不当に改竄していないか
問題の特定ができない場合は，保守員に連絡してください。
112
内部情報
更新可能なオンライン再編成を実行する，サーバがあるユニットが開始されていません。
該当するユニットを開始してください。
711
世代番号
詳細コードの世代番号の，システムログファイルのファイルグループの世代抜けを検知しました。
pdlogls -d sysコマンドで，該当する世代番号のシステムログファイルのファイルグループがあるかどうか確認してください。
システムログファイルのファイルグループがない場合は，システムログファイルが上書きされていて，必要な更新ログレコードが入力できないため，更新可能なオンライン再編成が継続できない状態となっています。更新可能なオンライン再編成を再実行したい場合は，pdorbeginコマンドから再度実行してください。
システムログファイルのファイルグループがある場合は，保守員に連絡してください。連絡する場合には，次に示す資料を用意してください。
・pdls -d org -aコマンドの実行結果
・pdlogls -d sysコマンドの実行結果
・該当するシステムログファイル，又は該当するシステムログファイルのバックアップファイル（アンロードログファイルを除く）
1001
701
システムログ反映開始ポイントが示す，システムログファイルのファイルグループが見付かりません。
pdls -d org -aコマンドを実行し，システムログ反映開始ポイントのシステムログファイルのファイルグループ名を確認してください。さらに，pdlogls -d sysコマンドでそのシステムログファイルのファイルグループがあるかどうかを確認してください。
システムログファイルのファイルグループがない場合は，システムログファイルが上書きされていて，必要な更新ログレコードが入力できないため，更新可能なオンライン再編成が継続できない状態となっています。更新可能なオンライン再編成を再実行したい場合は，pdorbeginコマンドから再度実行してください。
702
システムログ反映開始ポイントが示すシステムログファイルのオープンができません。
直前に出力されているKFPS01171-Eメッセージを参照し，エラー原因の特定と対策をしてください。対策後，pdorendコマンドを実行し，更新可能なオンライン再編成を再実行してください。
1605
システムログ反映開始ポイントが示すシステムログファイルの世代情報が不正です。
pdls -d org -aコマンドを実行し，システムログ反映開始ポイントが示すシステムログファイルのファイルグループの世代番号及びランIDを確認してください。さらに，その世代番号及びランIDが，pdlogls -d sysコマンドでのシステムログファイルのファイルグループの世代番号及びランIDと同じかどうか確認してください。
世代番号又はランIDが異なる場合は，システムログファイルが上書きされていて，必要な更新ログレコードが入力できないため，更新可能なオンライン再編成が継続できない状態となっています。更新可能なオンライン再編成を再実行したい場合は，pdorbeginコマンドから再度実行してください。
世代番号及びランIDが同じ場合は，保守員に連絡してください。連絡する場合には，次に示す資料を用意してください。
・pdls -d org -aコマンドの実行結果
・pdlogls -d sysコマンドの実行結果
・該当するシステムログファイル，又は該当するシステムログファイルのバックアップファイル（アンロードログファイルを除く）
1653
701
システムログ反映済みポイントが示す，システムログファイルのファイルグループが見付かりません。
pdls -d org -aコマンドを実行し，システムログ反映済みポイントが示すシステムログファイルのファイルグループ名を確認してください。さらに，pdlogls -d sysコマンドでそのシステムログファイルのファイルグループがあるかどうか確認してください。
システムログファイルのファイルグループがない場合は，システムログファイルが上書きされていて，必要な更新ログレコードが入力できないため，更新可能なオンライン再編成が継続できない状態となっています。更新可能なオンライン再編成を再実行したい場合は，pdorbeginコマンドから再度実行してください。
702
システムログ反映済みポイントが示すシステムログファイルのオープンができません。
直前に出力されているKFPS01171-Eメッセージを参照し，エラー原因の特定と対策をしてください。対策後，pdorendコマンドを実行し，更新可能なオンライン再編成を再実行してください。
1602
システムログ反映済みポイントからのシステムログファイル入力中に，システムログブロック抜けを検知しました。
pdlogls -d sysコマンドを実行し，直前に出力されているKFPS01171-Eメッセージの入力対象のシステムログブロック番号を含むシステムログファイルのファイルグループがあるかどうか確認してください。
システムログファイルのファイルグループがない場合は，システムログファイルが上書きされていて，必要な更新ログレコードが入力できないため，更新可能なオンライン再編成が継続できない状態となっています。更新可能なオンライン再編成を再実行したい場合は，pdorbeginコマンドから再度実行してください。
1605
システムログ反映済みポイントが示すシステムログファイルの世代情報が不正です。
pdls -d org -aコマンドを実行し，システムログ反映済みポイントが示すシステムログファイルのファイルグループの世代番号及びランIDを確認してください。さらに，その世代番号及びランIDが，pdlogls -d sysコマンドでの該当するシステムログファイルのファイルグループの世代番号及びランIDと同じかどうか確認してください。
世代番号又はランIDが異なる場合は，システムログファイルが上書きされていて，必要な更新ログレコードが入力できないため，更新可能なオンライン再編成が継続できない状態となっています。更新可能なオンライン再編成を再実行したい場合は，pdorbeginコマンドから再度実行してください。
世代番号及びランIDが同じ場合は，保守員に連絡してください。連絡する場合には，次に示す資料を用意してください。
・pdls -d org -aコマンドの実行結果
・pdlogls -d sysコマンドの実行結果
・該当するシステムログファイル，又は該当するシステムログファイルのバックアップファイル（アンロードログファイルを除く）
KFPS01171-E
Error occurred while reading system log file, server=aa....aa, file_group=bb....bb, system A/B=c, reason=dddd(ee....ee)　　（Ｌ）
更新可能なオンライン再編成でのシステムログファイル入力中に，障害が発生しました。
aa....aa：HiRDBのサーバ名
bb....bb：システムログファイルのファイルグループ名
c：エラーが発生した系（A又はB）
dddd：理由コード（[対策]を参照してください）
ee....ee：詳細情報（[対策]を参照してください）
(Ｓ)処理を続行します。
[対策]次の理由コードと詳細情報の一覧を参照し，対処してください。
理由コード
(dddd)
詳細情報
(ee....ee)
意味
対策
213
HiRDBファイルシステムのエラーコード
システムログファイルのオープンエラーが発生しました。
「HiRDBファイルシステムに対するアクセス要求から返されるエラーコード」を基に，エラー原因を調査して対策してください。
詳細情報がHiRDBファイルシステムのエラーコード以外の場合は，保守員に連絡してください。
215
HiRDBファイルシステムのエラーコード
システムログファイルの読み込みエラーが発生しました。
219及び1652
内部コード
システムログファイル入力中に，ログブロックデータの不正を検知しました。
システムログファイルを二重化している場合，障害が発生していない系を使用して処理を継続します。
システムログファイルを二重化していない場合，又は二重化している両系で障害が発生した場合，更新可能なオンライン再編成が継続できない状態となっています。更新可能なオンライン再編成を再実行したい場合は，いったんpdorend -uコマンドで更新可能なオンライン再編成を中止した後，pdorbeginコマンドから再度実行してください。更新可能なオンライン再編成を再度実行しても，このエラーメッセージが繰り返し出力される場合，次の資料を取得してから保守員に連絡してください。
・$PDDIR/spool下のすべてのディレクトリ及びファイル
・HiRDBのシステム定義ファイル
・障害が発生したサーバに対して実行したpdlogls -d sys -eコマンドの実行結果
・障害が発生したサーバにある，オンライン再編成上書き禁止状態のシステムログファイルに対して，pdfbkupコマンドを実行して作成したバックアップファイル
・syslogfile（Windows NT版の場合はイベントログ）
602
内部コード
システムログファイル入力中に，ログレコードデータの不正を検知しました。
システムログファイルを二重化している場合，障害が発生していない系を使用して処理を継続します。
システムログファイルを二重化していない場合，又は二重化している両系で障害が発生した場合，更新可能なオンライン再編成が継続できないため，異常終了した状態となっています。更新可能なオンライン再編成を再実行したい場合は，いったんpdorend -uコマンドで更新可能なオンライン再編成を中止した後，pdorbeginコマンドから再度実行してください。更新可能なオンライン再編成を再度実行しても，このエラーメッセージが繰り返し出力される場合，次の資料を取得してから保守員に連絡してください。
・$PDDIR/spool下のすべてのディレクトリ及びファイル
・HiRDBのシステム定義ファイル
・障害が発生したサーバに対して実行したpdlogls -d sys -eコマンドの実行結果
・障害が発生したサーバにある，オンライン再編成上書き禁止状態のシステムログファイルに対して，pdfbkupコマンドを実行して作成したバックアップファイル
・syslogfile（Windows NT版の場合はイベントログ）
1602
入力対象のシステムログブロック番号
システムログファイル入力中に，システムログブロック抜けを検知しました。
pdlogls -d sysコマンドを実行し，入力対象のシステムログブロック番号を含むシステムログファイルのファイルグループがあるかどうか確認してください。
入力対象のシステムログブロック番号を含むシステムログファイルのファイルグループがない場合は，該当するシステムログファイルのファイルグループが上書きされている可能性があります。これによって，更新可能なオンライン再編成が継続できない状態になっている場合は，直後にKFPS01170-Eメッセージが表示されます。KFPS01170-Eメッセージの対策を参照してください。
入力対象のシステムログブロック番号を含むシステムログファイルのファイルグループがある場合は，システムログファイルを二重化していれば，障害が発生していない系を使用して処理を継続できます。しかし，システムログファイルを二重化していない場合，又は二重化している両系で障害が発生している場合は，更新可能なオンライン再編成が継続できなくなることがあります。この場合，直後にKFPS01170-Eメッセージが表示されます。KFPS01170-Eメッセージの対策を参照してください。
1605
システムログファイルの世代情報※
システムログファイルの世代情報が管理情報と一致しないため，更新ログレコードの入力処理ができません。
システムログファイルを二重化している場合，障害が発生していない系を使用して処理を継続できます。
システムログファイルを二重化していない場合，又は二重化している両系で障害が発生している場合は，更新可能なオンライン再編成が継続できなくなることがあります。この場合，直後にKFPS01170-Eメッセージが表示されます。KFPS01170-Eメッセージの対策を参照してください。
1653
システムログファイルの世代情報※
システムログファイルの世代情報が，システムログ反映開始ポイントと一致していないため，更新ログレコード入力処理で使用できません。
システムログファイルを二重化している場合，障害が発生していない系を使用して処理を継続します。
システムログファイルを二重化していない場合，又は二重化している両系で障害が発生した場合，更新可能なオンライン再編成が継続できない状態となっています。この場合，直後にKFPS01170-Eメッセージが出力されます。KFPS01170-Eメッセージの対策を参照してください。
注※
形式を次に示します。
AA....AA,BB....BB,CC....CC
AA....AA：ランID
BB....BB：ユーザランID
CC....CC：世代番号
KFPS01175-W
Online DB Reorganization overwrite status in all log file group changed and retrying swap, server=aa....aa, type=bbb　　（Ｌ）
オンライン再編成上書き禁止状態のシステムログファイルがありましたが，システム定義のpd_log_org_no_standby_file_opr=continueの指定があるため，サーバ内の全システムログファイルのオンライン再編成上書き状態を，オンライン再編成上書き可能状態に変更して，システムログファイルのスワップをします。
aa....aa：HiRDBのサーバ名
bbb：システムログファイル（sys）
(Ｓ)処理を続行します。
[対策]このメッセージ出力以降，システムログファイルはすべてオンライン再編成上書き可能状態になります。その結果，オンライン再編成の追い付き反映で必要な更新情報が上書きされ，更新可能なオンライン再編成が継続できなくなることがあります。継続できなくなった場合，KFPS01170-Eメッセージが出力されるので，その対策に従ってください。
KFPS01180-E
Skipped blocks detected while reading log. type:aaaa(xx....xx), previous read point: bb....bb,cc....cc, current read point:dd....dd,ee....ee,read direction: g　　（Ｌ）
ログ読み込み時，ブロック抜けを検出しました。
aaaa：ログファイル種別
sys：システムログファイル
xx....xx：HiRDBのサーバ名
bb....bb：ブロック抜けの直前に読み込んだログファイルグループ名
cc....cc：ブロック抜けの直前に読み込んだログブロック番号
dd....dd：現在読み込んだログファイルグループ名
ee....ee：現在読み込んだログブロック番号
g：ログブロックを読み込む方向
f：順方向への読み込み
b：逆方向への読み込み
注　bb....bb，cc....ccは，読み込んだログブロックがない場合********，********を表示します。
(Ｓ)処理を続行します。
[対策]次に示すメッセージを基に原因を調査してください。ファイル障害の場合は障害を復旧してください。データを復旧できる場合は，復旧させてから再度HiRDBを開始してください。データを復旧できない場合は，バックアップから回復して再度HiRDBを開始してください。原因が不明の場合は，保守員に連絡してください。
・KFPS01181-E
・KFPS01183-E
・KFPS01184-E
KFPS01181-E
Log read error. type:aaaa(xx....xx), read point: bb....bb,cc....cc, read direction: d, element file: ee....ee system A/B: f, reason code=gggg-hh　　（Ｌ）
ログ読み込み時，リード障害が発生しました。
aaaa：ログファイル種別
sys：システムログファイル
xx....xx：HiRDBのサーバ名
bb....bb：ファイルグループ名
cc....cc：ブロック番号
d：ログブロックを読み込む方向
f：順方向への読み込み
b：逆方向への読み込み
ee....ee：システムログファイル名
f：障害が発生した系
a：A系
b：B系
gggg：理由コード
213：入力中のファイルグループに，未オープン状態のファイルがあります。
214：入力中のファイルグループに，閉塞中のファイルがあります。
215：入力中のファイルグループに，読み込み不可状態のファイルがあります。
209：入力中のファイルグループで，入出力エラーが発生しました。
hh：HiRDB内部コード
(Ｓ)処理を続行します。
[対策]このメッセージの理由コード，又はこのメッセージの前にKFPS01203-Eメッセージが出力されている場合は，その理由コードによって原因を調査してください。
KFPS01182-I
Generation file groups changed for further reading of log blocks. type:aaaa(xx....xx), from:bb....bb,cc....cc, to:dd....dd,ee....ee, read direction: g　　（Ｌ）
ログを読み込む世代を切り替えます。
aaaa：ログファイル種別
sys：システムログファイル
xx....xx：HiRDBのサーバ名
bb....bb：切り替え元のファイルグループ名
cc....cc：切り替え元の世代番号
dd....dd：切り替え先のファイルグループ名
ee....ee：切り替え先の世代番号
g：ログブロックを読み込む方向
f：順方向への読み込み
b：逆方向への読み込み
KFPS01183-E
Skipped generations detected while reading log blocks. type:aaaa(xx....xx), range: bb....bb,cc....cc to dd....dd,ee....ee, skipped generations: ff....ff to gg....gg, read direction: h　　（Ｌ）
ログ読み込み時，世代抜けを検出しました。
aaaa：ログファイル種別
sys：システムログファイル
xx....xx：HiRDBのサーバ名
bb....bb：ログブロックを読み込む，先頭のログファイルグループ名
cc....cc：ログブロックを読み込む，先頭のログ世代番号
dd....dd：ログブロックを読み込む，最終のログファイルグループ名
ee....ee：ログブロックを読み込む，最終のログ世代番号
ff....ff：世代の抜けた先頭世代番号
gg....gg：世代の抜けた最終世代番号
h：ログブロックを読み込む方向
f：順方向への読み込み
b：逆方向への読み込み
注　ログサービス機能の回復時，dd....dd，ee....eeは，********，********を表示します。世代抜けの範囲が1世代の場合，ff....ff，gg....ggは同じ内容を表示します。
(Ｓ)処理を続行します。
KFPS01184-E
Invalid log data detected while reading log. type:aaaa(xx....xx), read point: bb....bb,cc....cc, element file: dd....dd read direction: e, system A/B: f　　（Ｌ）
ログ読み込み時，不正なログデータを検出しました。
aaaa：ログファイル種別
sys：システムログファイル
xx....xx：HiRDBのサーバ名
bb....bb：不正なログデータを検出したログファイルグループ名
cc....cc：読み込もうとしたログのブロック番号
dd....dd：システムログファイル名
e：ログブロックを読み込む方向
f：順方向への読み込み
b：逆方向への読み込み
f：障害が発生した系
a：A系
b：B系
(Ｓ)処理を続行します。
[対策]このメッセージが表示された場合，ログファイルが破壊された可能性があります。このログファイルの運用を中止し，障害の原因を調査してください。
KFPS01185-E
Unable to read log file group. type:aaaa(xx....xx), read point: bb....bb,cc....cc, read direction: d, reason code=eeee-ff　　（Ｌ）
ログファイル読み込み時，読み込みを実行できないファイルグループがあります。
aaaa：ログファイル種別
sys：システムログファイル
xx....xx：HiRDBのサーバ名
bb....bb：ファイルグループ名
cc....cc：ブロック番号
d：ログブロックを読み込む方向
f：順方向への読み込み
b：逆方向への読み込み
eeee：理由コード
1001：該当するファイルグループのログ最終位置が消失したため，該当するファイルグループを読み込めません。
ff：HiRDB内部コード
(Ｓ)処理を続行します。
KFPS01200-E
Failure to open aaaa(xx....xx)log file. element file: bb....bb, system A/B: c,reason code=dddd-ee　　（Ｌ）
aaaa(xx....xx)ログファイルのオープンに失敗しました。ファイルのオープンができません。
aaaa：ログファイル種別
sys：システムログファイル
xx....xx：HiRDBのサーバ名
bb....bb：ファイルグループ名
c：系種別
a：A系
b：B系
dddd：理由コード
ee：HiRDB内部コード
理由コードと対策を表に示します。
(Ｓ)障害が発生したファイルを閉塞し，処理を続行します。
(Ｏ)理由コード一覧を見て対策してください。
理由コード
意味
オペレータの処置
HiRDB管理者の処置
101
メモリ不足が発生しました。
－
メモリの再見積もりをしてください。
201
ファイル名が不正です。
次に示す原因が考えられます。
・パス名に使用できない文字を指定しています。
・HiRDBファイル名の長さが制限（30文字）を超えました。
ファイル名を正しく指定し直し，再度コマンドを実行してください。
－
202
指定したファイル名がキャラクタ型スペシャルファイルではありません。又はこのファイルに対応する装置がありません。
－
pdlogadpfオペランドの指定を見直してください。
203
pathで指定した装置がHiRDBファイルシステム用に初期化されていません。
207
指定したパスのHiRDBファイルシステム領域のオープンで，上限値オーバが発生しました。
現在ログサービス機能で使用されていないファイルをクローズし，再度オープンしてください。
１プロセス内でオープンできるファイルの上限値を見直し，必要であればカーネルを再作成してください。
208
指定したパスのHiRDBファイルシステム領域に対し，アクセス権限がありません。
pdflsコマンドを用いHiRDBファイルのアクセス権限について確認してください。
－
209
入出力エラーが発生しました。
入出力エラーが発生した原因を調査し，対策をしてください。
210
HiRDBファイルシステムのバージョンが一致しません。
pdfmkfsコマンドでHiRDBファイルシステムを再作成し直した後pdloginitコマンドでログファイルを再作成してください。
211
指定したファイルに対するアクセス権限がありません。
pdflsコマンドを用いログファイルのアクセス権限について確認してください。
212
指定したファイルがありません。
－
pdlogadpfオペランドの指定を見直してください。
218
219
指定されたファイルはログファイルとして使用できないファイルです。
エラーとなったファイルについて，pdlogrmコマンドを用い一度ファイルを削除した後，pdloginitコマンドで再度ファイルを作成し直してください。
－
220
指定されたファイルはログファイルではありません。
－
pdlogadpfオペランドの指定を見直してください。
221
ロックセグメント不足が発生しました。
OSのシステム構築時に，指定したレコードロックセグメント数を見直してください。
222
ログファイルをオープンしようとしましたが，ほかのプロセスで使用中です。
該当するログファイルがほかのプロセスで使用されているか確認してください。必要であれば再度オープンしてください。
－
（凡例）－：該当しません。
KFPS01201-E
Failure to close aaaa(xx....xx) log file. element file: bb....bb, system A/B: c, reason code=dddd-ee　　（Ｌ）
aaaa(xx....xx)ログファイルのクローズに失敗しました。ファイルのクローズができません。
aaaa：ログファイル種別
sys：システムログファイル
xx....xx：HiRDBのサーバ名
bb....bb：システムログファイル名
c：系種別
a：A系
b：B系
dddd：理由コード
101：メモリ不足が発生しました。
209：入出力エラーが発生しました。
221：ロックセグメント不足が発生しました。
ee：HiRDB内部コード
(Ｓ)エラーを無視し，処理を続行します。
(Ｏ)入出力エラーが発生したファイルの原因を調査し，障害要因を取り除いてください。ロックセグメント不足の場合，OSのシステム構築時に指定したレコードロックセグメント数の値を見直してください。
[対策]メモリ不足が発生した場合，再度メモリを見積もる必要があります。
KFPS01202-E
Failure to write to aaaa(xx....xx) log file. element file: bb....bb, system A/B: c,reason code=dddd-ee　　（Ｌ）
aaaa(xx....xx)ログファイルの書き込みに失敗しました。ファイルへの書き込みができません。
aaaa：ログファイル種別
sys：システムログファイル
xx....xx：HiRDBのサーバ名
bb....bb：システムログファイル名
c：系種別
a：A系
b：B系
dddd：理由コード
209：入出力エラーが発生しました。
226：ディスク容量が不足しています。
ee：HiRDB内部コード
(Ｓ)障害となったファイルを閉塞し，処理を続行します。
[対策]次に示す処置をしてください。
・理由コードが209の場合
入出力エラーが発生したファイルの原因を調査し，障害要因を取り除いて，再度HiRDBに割り当ててください。
・理由コードが226の場合
次に示す対策のどれかを実行してください。
1. 容量不足のディスク中にあるHiRDBが使用しないファイルを別のディスクに移動するか，又は削除してください。
2. キャラクタ型スペシャルファイルを使用してください。
3. pdfmkfsコマンドに-iオプションを指定してHiRDBファイルシステム領域を作成してください。
4. 容量が大きいディスクに入れ替えて，HiRDBファイルシステム領域をバックアップから回復してください。
KFPS01203-E
Failure to read from aaaa(xx....xx) log file. element file: bb....bb, system A/B: c,reason code=dddd-ee　　（Ｌ）
aaaa(xx....xx)ログファイルの読み込みに失敗しました。ファイルからの読み込みができません。
aaaa：ログファイル種別
sys：システムログファイル
xx....xx：HiRDBのサーバ名
bb....bb：システムログファイル名
c：系種別
a：A系
b：B系
dddd：理由コード
209：入出力エラーが発生しました。
ee：HiRDB内部コード
(Ｓ)エラーを無視し，処理を続行します。
(Ｏ)入出力エラーが発生したファイルの原因を調査し，障害要因を取り除いて，再度HiRDBに割り当ててください。
KFPS01204-E
Error occurred while handling log element file of aaaa(xx....xx) log file. reason code=bbbb-cc　　（Ｌ）
aaaa(xx....xx)ログファイルの操作中{ open | close | read | write }に障害が発生しました。
aaaa：ログファイル種別
sys：システムログファイル
xx....xx：HiRDBのサーバ名
bbbb：理由コード
101：メモリ不足が発生しました。
103：ネットワーク障害が発生しました。
105：通信又はファイルの入出力処理中にタイムアウトが発生しました。
ee：HiRDB内部コード
(Ｓ)異常終了します。
[対策]次に示す処置をしてください。
・理由コードが101の場合
メモリ所要量を再度見積ってください。
・理由コードが103の場合
ネットワーク障害が発生した原因を調査して対策してください。その後，HiRDBを開始してください。
・理由コードが105の場合
ネットワーク，及びシステムの状態を確認してください。システムに掛かる負荷を軽くしてください。システムログファイルを作成したディスクに対するハードウェア障害のメッセージが出力されている場合は，ディスクの状態を確認してください。
又は，HiRDBを再度開始してください。
KFPS01205-E
Failure to concurrent access aaaa(xx....xx) log file. element file: bb....bb, system A/B: c, reason code=dddd-ee　　（Ｌ）
aaaa(xx....xx)ログファイルのコンカレントアクセス中（オープン）に障害が発生しました。
aaaa：ログファイルの種別
sys：システムログファイル
xx....xx：HiRDBのサーバ名
bb....bb：ファイルグループ名
c：系種別
a：A系
b：B系
dddd：理由コード
ee：HiRDBの内部コード
(Ｓ)HiRDBを停止します。
[対策]次に示す処置をしてください。
理由
コード
意味
対策
101
メモリが不足しました。
メモリ所要量を再度見積もってください。必要であればメモリを追加してください。
207
ファイルのオープン数が上限値を超えました。
HP-UXの場合はsamコマンドでOSのオペレーティングシステムパラメタnfileの値を変更してください。
Solarisの場合はlimit又はulimitで最大ファイル記述子数を変更してシステムを構築し直し，再度実行してください。
Linuxの場合はほかのプロセスの終了を待って再度実行してください。
208
アクセス権限がありません。
ファイルのアクセス権を見直してください。
Windows NT版の場合，raw I/O機能を使用している領域で発生したときはフォーマットされたディスクを指定していないか見直してください。
209
システムログファイルへのアクセス時に入出力エラーが発生しました。
直前に出力されたKFPO00107-Eメッセージのerrnoに対応した処置をしてください。
210
システムログファイルの初期化バージョンが不正です。
システムログファイルの絶対パス名を見直してください。バージョンダウンを行った場合はHiRDBを正常終了した後に，システムログファイルを作成し直してから，HiRDBを開始してください。
214
ファイルのロックセグメント不足が発生しました。
HP-UXの場合はsamコマンドでOSのオペレーティングシステムパラメタnflocksの値を変更してください。
そのほかのOSの場合はロックを使用しているほかのプロセスの終了を待ってから，再度実行してください。
KFPS01206-W
Unable to open aaaa(bb....bb) log file because file record size is unavailable. element file:cc....cc, system A/B:d, record size=eeee, pd_log_rec_leng=ffff　　（Ｅ＋Ｌ）
システムログファイルのレコード長がpd_log_rec_lengオペランドの値と異なるため，システムログファイルをオープンできません。
aaaa：sys（システムログファイル）
bb....bb：サーバ名
cc....cc：システムログファイルのファイルグループ名
d：障害が発生した系
eeee：システムログファイルのレコード長（バイト）
ffff：pd_log_rec_lengオペランドの値
(Ｓ)処理を続行します。
(Ｏ)システムログファイルのレコード長とpd_log_rec_lengオペランドの値を合わせてください。
システムログファイルのレコード長の変更方法については，マニュアル「HiRDB Version 7 システム運用ガイド」を参照してください。
KFPS01207-E
HiRDB file system area sector size, record size or record count is invalid. reason code=aaaa, HiRDB file system area sector size=bb....bb, valid record size range=cc....cc　　（Ｅ）
HiRDBファイルシステム領域のセクタ長，指定したレコード長，又は指定したレコード数が不正です。
aaaa：理由コード
理由コードの内容を次に示します。
1604：pdloginitコマンドの-nオプションの指定値がcc....ccの範囲外です。
1611：HiRDBファイルシステム領域のセクタ長が4096バイトより大きいです。該当するHiRDBファイルシステム領域にはHiRDBファイルを作成できません。
1612：pdloginitコマンドの-lオプションの指定値がHiRDBファイルシステム領域のセクタ長よりも小さいです。
bb....bb：HiRDBファイルシステム領域のセクタ長
cc....cc：指定できるレコード数の範囲を「下限－上限」の形式で表示
ただし，理由コードが1611又は1612の場合は***が表示されます。
(Ｓ)処理を終了します。
(Ｏ)理由コードによって処置が変わります。
1604：pdloginitコマンドの-nオプションの指定値をcc....ccの範囲内の数値にして，再度pdloginitコマンドを実行してください。
1611：セクタ長が4096バイト以下のハードディスク（パーティション）にHiRDBファイルシステム領域を初期設定し，再度pdloginitコマンドを実行してください。
1612：pdloginitコマンドの-lオプションの指定値をHiRDBファイルシステム領域のセクタ長以上にして，再度pdloginitコマンドを実行してください。
KFPS01211-I
aa....aa log file group unload start. server=bb....bb:gen no=cc....cc　　（Ｌ）
bb....bbサーバのシステムログファイルaa....aaに対して，自動ログアンロード機能によるアンロード処理を開始します。
aa....aa：システムログファイルのファイルグループ名
bb....bb：HiRDBのサーバ名
cc....cc：システムログファイルの世代番号
(Ｓ)処理を続行します。
KFPS01212-I
aa....aa log file group unload completed. server=bb....bb:unload log file name=cc....cc　　（Ｌ）
bb....bbサーバのシステムログファイルaa....aaに対して，自動ログアンロード機能によるアンロード処理が完了しました。作成されたアンロードログファイル名はcc....ccです。
aa....aa：システムログファイルのファイルグループ名
bb....bb：HiRDBのサーバ名
cc....cc：アンロードログファイル名
アンロードログファイル名が139文字以上の場合は，アンロードログファイル名の後ろから138文字を出力します。
(Ｓ)処理を続行します。
KFPS01213-W
aa....aa log file group already unloaded. Change log file group status to be unloaded. server=bb....bb:gen no=cc....cc　　（Ｌ）
システムログファイルaa....aaを自動ログアンロードしようとしましたが，既にアンロードが完了しています。システムログファイルaa....aaの状態をアンロード済み状態に変更します。
aa....aa：システムログファイルのファイルグループ名
bb....bb：HiRDBのサーバ名
cc....cc：システムログファイルの世代番号
(Ｓ)処理を続行します。
KFPS01215-I
File group bb....bb of aaaa(xx....xx) log opened.　　（Ｌ）
aaaa(xx....xx)ログのbb....bbをオープンしました。
ログファイルグループをオープンしました。
aaaa：ログファイル種別
sys：システムログファイル
xx....xx：HiRDBのサーバ名
bb....bb：オープンしたファイルグループ名
KFPS01216-I
File group bb....bb of aaaa(xx....xx) log closed.　　（Ｌ）
aaaa(xx....xx)ログのbb....bbをクローズしました。
ログファイルグループをクローズしました。
aaaa：ログファイル種別
sys：システムログファイル
xx....xx：HiRDBのサーバ名
bb....bb：クローズしたファイルグループ名
KFPS01217-I
File group bb....bb of aaaa(xx....xx) log became available.　　（Ｌ）
aaaa(xx....xx)の(bb....bb)ログファイルは，HiRDBで使用できるようになりました。
aaaa：ログファイル種別
sys：システムログファイル
xx....xx：HiRDBのサーバ名
bb....bb：使用できるようになったログファイルグループ名
KFPS01218-I
File group bb....bb of aaaa(xx....xx) log became unavailable.　　（Ｌ）
aaaa(xx....xx)のログファイルグループbb....bbは，HiRDBで使用できなくなりました。
aaaa：ログファイル種別
sys：システムログファイル
xx....xx：HiRDBのサーバ名
bb....bb：使用できなくなったログファイルグループ名
KFPS01220-E
Request to swap aaaa(xx....xx) log file unable to be executed because there is no standby log file group available.　　（Ｌ）
aaaa(xx....xx)ログのスワップ要因が発生しましたが，スワップ先にできるシステムログファイルがありません。スワップ先にできるシステムログファイルがない原因を次に示します。
(1)待機中のログファイルがない場合
(2)待機中のファイルグループが次の場合
・アンロード待ち状態
・上書きできない状態（該当するログファイルに対応するシンクポイントダンプを取得中です）
・HiRDBの回復処理でリード中
・コマンド処理で使用中
aaaa：ログファイル種別
sys：システムログファイル
xx....xx：HiRDBのサーバ名
(Ｓ)システムを停止します。
[対策]次に示すどれかの対策を実施してください。
・ログファイルを使用できる状態，又はログファイルを追加してください。
・ログファイルをアンロードしてください。
・予約ファイルがある場合，オンラインで使用できるようにスワップしてください。
・ログファイルを増やしてください。
KFPS01221-I
aaaaaaaa assigned as current file group of bbbb(xx....xx) log file. generation number=cc....cc, first block number=dd....dd　　（Ｌ）
ログファイルグループaaaaaaaaをHiRDBのサーバ名bbbb(xx....xx)の現用ログファイルとして割り当てました。
aaaaaaaa：割り当てたログファイルグループのログファイルグループ名
bbbb：ログファイル種別
sys：システムログファイル
xx....xx：HiRDBのサーバ名
cc....cc：ログ世代番号
dd....dd：ファイル内の先頭ログブロック番号
KFPS01222-I
aa....aa released from bbbb(xx....xx) log file. generation number=cc....cc, first block number=dd....dd, last block number=ee....ee　　（Ｌ）
bbbb(xx....xx)のシステムログファイルが現用でなくなりました。
aa....aa：現用でなくなったファイルのファイルグループ名
bbbb：ログファイル種別
sys：システムログファイル
xx....xx：HiRDBのサーバ名
cc....cc：ログ世代番号
dd....dd：ファイル内の先頭ログブロック番号
ee....ee：ファイル内の最終ログブロック番号
0の場合は，ログが1件も出力されていないファイルを示します。
KFPS01223-E
Error occurred during aaaa(xx....xx) log swap processing. reason code=bbbb　　（Ｌ）
aaaa(xx....xx)のログファイルのスワップ処理中に障害が発生しました。
aaaa：ログファイル種別
sys：システムログファイル
xx....xx：HiRDBのサーバ名
bbbb：理由コード
101：メモリ不足が発生しました。
103：ネットワーク障害が発生しました。要因を次に示します。
・イーサネットボードやケーブルなどのハードウェア障害
・ネットワーク定義の設定誤り
・目的ノードが実行中ではありません。又はそのノードでHiRDBが実行中ではありません。
・目的プロセスが実行中ではありません。
105：タイムアウト障害が発生しました。
(Ｓ)システムを停止します。
[対策]理由コードが103の場合は，次の処置をしてください。
5. OSのコマンドでサーバマシンの接続状態を調べてください。
6. HiRDBのコマンドで各サーバの実行状態を調べてください。
メモリの見積もりが正しいか確認してください。
KFPS01224-I
aaaa(xx....xx) log does not have standby file group available for next swapping.　　（Ｌ）
aaaa(xx....xx)には，次のスワップ要因の発生時に，交代先として使用できるファイルグループがありません。
交代先として使用できるログファイルグループを用意してください。
aaaa：ログファイル種別
sys：システムログファイル
xx....xx：HiRDBのサーバ名
(Ｏ)アンロードしていないログファイルグループがある場合は，アンロードしてください。アンロードしていないログファイルグループがない場合，予約ファイルグループがあれば，予約ファイルをオープンしてください。
KFPS01225-I
Request to swap aaaa(xx....xx) log occurred, but no standby file group available. system opened file groups having been closed to get available standby.　　（Ｌ）
aaaa(xx....xx)のシステムログファイルのスワップ要因が発生しましたが，現用に割り当てることができるファイルグループがないので，クローズ状態のファイルグループをオープンし，スワップ先を探します。
aaaaのシステムログファイルのスワップ要因が発生しましたが，前回のオンラインで仕掛かっていたトランザクションがまだ決着していないため，予約ファイルをオープンしました。
aaaa：ログファイル種別
sys：システムログファイル
xx....xx：HiRDBのサーバ名
KFPS01226-E
bb....bb file group of aaaa(xx....xx) log opened but unable to be assigned as current file group; now closing　　（Ｌ）
aaaa(xx....xx)のbb....bbログファイルをオープンしましたが，現用に割り当てることができないので，クローズします。
クローズファイルをオープンしましたが，ログファイルグループステータスがアンロード済みでないため，現用として割り当てることができないのでクローズします。
aaaa：ログファイル種別
sys：システムログファイル
xx....xx：HiRDBのサーバ名
bb....bb：オープンされたログファイルグループ名
(Ｓ)bb....bbで示すログファイルをクローズして処理を続行します。
KFPS01227-W
aaaa(bb....bb) log does not have standby file group available for next swapping;stop datareplication and continues swapping　　（Ｅ＋Ｌ）
aaaa(bb....bb)では，HiRDB Datareplicatorの抽出未完了状態のファイルがあるためにスワップできませんでした。しかし，pd_log_rpl_no_standby_file_opr=continueの指定があるため，HiRDB Datareplicator連携を中止して，ログファイルのスワップを続行します。
aaaa：ログファイル種別
sys：システムログファイル
bb....bb：HiRDBのサーバ名
(Ｓ)処理を続行します。
(Ｏ)HiRDB Datareplicator連携が，強制的に終了してしまいます。HiRDB Datareplicator連携を再開始するためには，反映側データベースの再作成が必要です。マニュアル「HiRDBデータ連動機能 HiRDB Datareplicator Version 7」を参照して，対処してください。
[対策]マニュアル「HiRDBデータ連動機能 HiRDB Datareplicator Version 7」を参照して，データ連動を再開始するように対処してください。データ連動を再開するためには，反映側データベースの再作成が必要です。
KFPS01228-W
Error occurred aaaa(bb....bb) log for waiting syncpoint acquisition opportunities. reason code=cccc　　（Ｌ）
-wオプションを指定したpdlogswap又はpdlogsyncコマンド実行時のシンクポイントダンプの有効化待ち監視で，シンクポイントダンプの有効化が完了しませんでした。
aaaa：ログファイルの種別
sys：システムログファイル
bb....bb：サーバ名
cccc：理由コード
105：-wオプションを指定したpdlogswap又はpdlogsyncコマンド実行時のシンクポイント有効化待ち監視時間オーバ
(Ｓ)処理を続行します。
(Ｏ)次に示す[対策]に従った後，pdlogswap又はpdlogsyncコマンドを再度実行してください。対策後にpdlogswap又はpdlogsyncコマンドを再度実行しても同じ事象が発生したり，[対策]に記述した事項に該当しない場合には，保守員に連絡してください。
[対策]長時間実行中のトランザクションがあるかどうかを調べます。
〈長時間実行中のトランザクションがある場合〉
（1）該当するトランザクションをキャンセルできないとき
・該当するトランザクションの終了を待って，シンクポイントの有効化ができることを確認後，pdlogswap又はpdlogsyncコマンドを再度実行します。
・現在実行中のトランザクションの終了までシンクポイントの有効化を待ち合わせられるように，-tオプションに十分な値を設定して再度pdlogswap又はpdlogsyncコマンドを実行してください。
（2）該当するトランザクションをキャンセルできるとき
・キャンセルした後にpdlogswap又はpdlogsyncコマンドを再度実行してください。
〈長時間実行中のトランザクションがない場合〉
・pdlogswap又はpdlogsyncコマンドを再度実行してください。
KFPS01229-I
Next aa....aa log file restart point, generation number=bb....bb, block number=cc....cc. restart end point, generation number=dd....dd, block number=ee....ee. last acquired syncpoint dump ffff/gg/hh ii:jj:kk　　（Ｌ）
サーバ名aa....aaの次回再開始時のシステムログ入力開始位置，システムログ入力終了位置及びシンクポイントダンプを最後に有効化した日時を表示します。
ただし，再開始前にシンクポイントダンプファイルやステータスファイルに障害が発生した場合は，このメッセージで表示したシステムログ入力開始位置と実際にシステムログを入力する位置が異なる場合があります。
aa....aa：サーバ名
bb....bb：入力開始位置となるシステムログの世代番号※１
cc....cc：入力開始位置となるシステムログのブロック番号※１
dd....dd：入力終了位置となるシステムログの世代番号※１
ee....ee：入力終了位置となるシステムログのブロック番号※１
ffff/gg/hh：最新のシンクポイントを有効化した日付※２
ii：jj：kk：最新のシンクポイントを有効化した時刻※２
注※１
世代番号，ブロック番号とも，表示する値が求まらない場合は，「********」を表示します。
注※２
有効化日付が求まらない場合は，「****/**/**」を，有効化時刻が求まらない場合は，「**:**:**」を表示します。
(Ｓ)処理を続行します。ただし，このメッセージはHiRDBユニット強制停止／異常終了時だけ出力します。
(Ｏ)システムログファイルを追加しないと再開始できない場合に，追加するシステムログファイル数を決定したり，次回再開始時に要する時間の目安を求める場合に，このメッセージの出力情報とpdloglsコマンドの実行結果を合わせて参照してください。このメッセージの世代番号，ブロック番号が「********」の場合，前回のHiRDBユニット終了時に出力されたメッセージを参照してください。
[対策]HiRDB/シングルサーバでは，該当するユニットのpdlogファイル及びsyslogfile（Windows NTの場合はイベントログ）にこのメッセージを出力します。
HiRDB/パラレルサーバでのこのメッセージの出力先を次に示します。
・該当するHiRDBユニットが異常終了する場合には，システムマネジャのあるユニットのpdlogファイル及びsyslogfile（又はイベントログ）に出力します。ただし，該当するユニットとシステムマネジャのあるユニットとの間で通信障害が発生したり，システムマネジャのあるユニットが停止している場合には，自ユニットのsyslogfile（又はイベントログ）に出力します。
・該当するHiRDBユニットを強制停止する場合には，自ユニットのsyslogfile（又はイベントログ）に出力します。
KFPS01230-E
Unable to read log file reason=(aaaa,bbbbbbbb)　　（Ｅ＋Ｌ）
HiRDB Datareplicatorのログ入力処理が実行できません。
aaaa：理由コード
bbbbbbbb：詳細コード
理由コードaaaaに対する詳細コードと対策を表に示します。
(Ｓ)処理を終了します。
(Ｏ)理由コードと詳細コードの一覧を見て，対処してください。
理由
コード
詳細コード
意味
オペレータの処置
101
割り当てようとしたサイズ
メモリ不足が発生しました。
プロセス数などを見直し，対策後再度実行してください。
203
HiRDBファイルシステムのエラーコード
ログファイルのオープンエラー，又は読み込みエラーが発生しました。
「HiRDBファイルシステムに対するアクセス要求から返されるエラーコード」を基に，エラーの原因を調査してください。詳細コードがエラー要因コード一覧の内容以外の時は，保守員に連絡してください。
212
0
入力開始ポイント以外のすべてのファイルにアクセスできませんでした。
pdloglsコマンドを実行し，その結果から原因を調査してください。
405
101
定義解析中にメモリ不足が発生しました。
現在実行中のプロセスの終了を待って，再度実行してください。直前にシステムコールのエラーメッセージが出力されている場合は，そのメッセージに従って対策してください。
403
定義ファイルのオープンエラーが発生しました。
直前に出力された定義ファイルのオープンエラーメッセージを基に原因を調査してください。
404
解析ファイルのオープンエラーが発生しました。
直前に出力された解析ファイルのオープンエラーメッセージを基に原因を調査してください。
405
解析処理中にエラーを検出しました。
直前に出力された解析エラーのメッセージを基に原因を調査してください。
414
有効なログファイルグループ数が0です。
対応するサーバ定義のpdlogadfgオペランド，及びpdlogadpfオペランドを修正して，再度実行してください。
410
0
システムログファイルのファイルグループ名が重複しています。
対応するサーバ定義のpdlogadfgオペランド，及びpdlogadpfオペランドを修正して，再度実行してください。
413
0
システムログファイルのファイルグループ数の上限値を超えています。
対応するサーバ定義のpdlogadfgオペランド，及びpdlogadpfオペランドを修正して，再度実行してください。
1602
ログブロック番号
ログファイルのブロック抜けを検知しました。
ログファイルが上書きされている可能性があります。原因を調査してください。
1653
0
ログ入力位置が不正です。
定義ファイルの内容を確認してください。
定義ファイルに誤りがなければ，pdls -d rpl -jコマンドで出力される入力開始ポイントのファイルがあるか，又はアクセスができるかを確認してください。
ファイルがあり，アクセスができる場合は，pdls -d rpl -j，及びpdlogls -d sysコマンドを入力します。pdlsコマンドで表示される現在抽出中のシステムログの位置が，pdloglsコマンドで表示された全システムログファイルのログブロック出力状態中になければ，HiRDB Datareplicator連携ができません。システム管理者の処理に従って，再度HiRDB Datareplicator連携が開始できるようにしてください。
pdlsコマンドで表示される現在抽出中のシステムログの位置が，pdloglsコマンドで表示された全システムログファイルのログブロック出力状態中にある場合は，保守員に連絡してください。
[対策]HiRDB Datareplicator連携中であれば，中止してください。
HiRDB Datareplicator連携を再開始するためには，反映側データベースの再作成が必要です。マニュアル「HiRDBデータ連動機能 HiRDB Datareplicator Version 7」を参照して，対処してください。
ただし，理由コード203を出力した場合は，一時的にシステムログファイルを参照できなかった可能性があります。直前に出力されているKFPS01231-Wメッセージ及びKFPO00107-Eメッセージを参照し，一時的なデバイスビジーなど，システムログファイルを格納しているディスクが問題なく参照できる場合は，HiRDB Datareplicatorを再開始してください。
KFPS01231-W
Error occurred while reading log element file,file group=aa....aa,
system A/B:b,reason=(cccc,dd....dd)　　（Ｅ＋Ｌ＋Ｒ）
ログファイルグループaa....aaのb系ファイルの読み込み中にエラーが発生しました。
aa....aa：ログファイルグループ名称
b：エラーが発生した系
a：A系
b：B系
cccc：理由コード
dd....dd：詳細コード
理由コードccccに対する詳細コードと対策を表に示します。
(Ｓ)処理を続行します。
(Ｏ)理由と詳細コードの一覧を見て，対処してください。
理由
コード
詳細コード
意　　味
オペレータの処置
213
HiRDBファイルシステムのエラーコード
ログファイルのオープンエラーが発生しました。
「HiRDBファイルシステムに対するアクセス要求から返されるエラーコード」から，エラーの原因を調査してください。詳細コードがエラー要因コード一覧の内容以外の時は，保守員に連絡してください。
215
HiRDBファイルシステムのエラーコード
ログファイルの読み込みエラーが発生しました。
1602
ログブロック番号
ログファイルのブロック抜けを検知しました。
ログファイルが上書きされている可能性があります。原因を調査してください。
KFPS01232-E
Datareplication stopped for aaaa(bb....bb);reason code=cccc, continues processing.　　（Ｅ＋Ｌ）
aaaa(bb....bb)ログサービスでは，ccccに示す理由によってデータ連動用情報の出力ができなくなりましたが，このままHiRDBの稼働を続行します。
aaaa：ログファイル種別
sys：システムログファイル
bb....bb：HiRDBのサーバ名
cccc：障害の内容を示す理由コード
115：HiRDB Datareplicatorの抽出処理中断を検知しました
212：データ連動用連絡ファイルがありません
(Ｓ)処理を続行します。
(Ｏ)HiRDB Datareplicator連携は，強制的に終了してしまいます。マニュアル「HiRDB Version 7 システム運用ガイド」，及びマニュアル「HiRDBデータ連動機能 HiRDB Datareplicator Version 7」を参照して，適切な対処をしてください。
[対策]HiRDB Datareplicator連携を再度実行するためには，反映側データベースの再作成が必要です。
マニュアル「HiRDBデータ連動機能 HiRDB Datareplicator Version 7」を参照して，HiRDB Datareplicator連携を再度実行できる状態にしてください。その後，pdrplstartコマンドを入力するか，又はシステム共通定義(環境変数PDCONFPATHの下のpdsys)でpd_rpl_init_start=Yになっていることを確認してからHiRDBを正常開始して，HiRDB Datareplicator連携を再開してください。
KFPS01233-E
HiRDB Datareplicator access communication file for aaaa(bb....bb) is invalid; continues processing.reason code=cccc　　（Ｅ＋Ｌ）
HiRDB Datareplicatorとのデータ連動用連絡ファイルの障害を検知しましたが，HiRDBの稼働を続行します。以降，HiRDB Datareplicatorを使用したデータ連動はできません。
aaaa：ログファイル種別
sys：システムログファイル
bb....bb：HiRDBのサーバ名
cccc：保守情報
(Ｓ)システムログファイルの，HiRDB Datareplicator抽出未完了／完了状態はそのままで，処理を続行します。
(Ｏ)pdls -d rplコマンドを入力して，HiRDBがデータ連動情報を出力中かどうかを確認してください。HiRDBがデータ連動情報を出力中であれば，以降，HiRDB Datareplicatorを使用したデータ連動はできません。pdrplstopコマンドを入力して，HiRDB Datareplicator連携を終了してください。同時に，抽出側と反映側のHiRDB Datareplicatorを停止してください。
[対策]HiRDB Datareplicator連携を再度実行するためには，反映側データベースの再作成が必要です。
マニュアル「HiRDBデータ連動機能 HiRDB Datareplicator Version 7」を参照して，HiRDB Datareplicator連携を再度実行できる状態にしてください。その後，pdrplstartコマンドを入力するか，又はシステム共通定義でpd_rpl_init_start=Yになっていることを確認してからHiRDBを正常開始して，HiRDB Datareplicator連携を再開してください。
KFPS01234-I
No extract database in aa....aa.　　（Ｌ）
aa....aaサーバには，HiRDB Datareplicatorが抽出の対象としているデータベースがありません。以降，該当するHiRDBサーバでは，システムログファイルの抽出未完了／完了に関する管理をしません。
aa....aa：HiRDBのサーバ名
(Ｓ)該当するHiRDBサーバでは，システムログファイル中のHiRDB Datareplicatorの抽出未完了又は抽出完了の状態を除いて，システムの稼働を続行します。
(Ｏ)該当するHiRDBサーバに，連動の対象となるデータベースがない場合には，問題ありません。HiRDB Datareplicatorの抽出システム定義及び抽出定義が誤っている場合には，データ連動の続行はできません。pdrplstopコマンドを実行して，HiRDB Datareplicator連携を中止してください。同時に，抽出側及び反映側のHiRDB Datareplicatorを停止してください。
[対策]HiRDB Datareplicator連携を再度実行するためには，反映側データベースの再作成が必要です。
HiRDB Datareplicatorの抽出システム定義及び抽出定義が誤っている場合には，マニュアル「HiRDBデータ連動機能 HiRDB Datareplicator Version 7」を参照して，誤っている定義を修正し，HiRDB Datareplicator連携を再度実行できる状態にしてください。その後，pdrplstartコマンドを入力するか，又はシステム共通定義でpd_rpl_init_start=Yになっていることを確認してからHiRDBを正常開始して，HiRDB Datareplicator連携を再開してください。
KFPS01235-E
Log file generation may be skipping between log file group aa....aa (cc....cc, dd....dd) and bb....bb (ee....ee, ff....ff)　　（Ｅ＋Ｒ＋Ｌ）
データ抽出で読み込みシステムログファイルのファイルグループをaa....aaからbb....bbに切り替えましたが，その間にシステムログファイルの世代抜けエラーが発生している可能性があります。
aa....aa：前回の読み込み対象の，システムログファイルのファイルグループ名
bb....bb：読み込み対象のシステムログファイルのファイルグループ名
cc....cc：aa....aaのランID（16進数表示）
dd....dd：aa....aaの世代番号（16進数表示）
ee....ee：bb....bbのランID（16進数表示）
ff....ff：bb....bbの世代番号（16進数表示）
(Ｓ)処理を続行します。
(Ｏ)抽出側データベースと反映側データベースとの間で不整合が発生している可能性があります。抽出側データベースをpdholdコマンドで参照可能バックアップ閉塞状態にして，最新データまで反映処理をした後，抽出側データベースと反映側データベースとの間で不整合がないか確認してください。
・不整合がない場合
抽出側データベースへの更新を再開してください。HiRDB Datareplicator連携を継続できます。
・不整合がある場合
抽出側データベースと反映側データベースとの，両方のデータ連動環境の同期をとって初期化する必要があります。データベース間に不整合がある場合の対処方法については，マニュアル「HiRDBデータ連動機能 HiRDB Datareplicator Version 7」を参照してください。
なお，正常開始途中にユニットが停止して，かつシステムログファイルにディスク障害が発生していない場合にこのメッセージが出力されたときは，データベース間の不整合は発生していません。
KFPS01240-E
Element file aa....aa unable to be used as bbbb(xx....xx) log file. file group： cc....cc，system A/B： d， reason code=eeee　　（Ｌ）
ログファイルとして使用できないファイルがあります。
aa....aa：障害が発生したシステムログファイル名
bbbb：ログファイル種別
sys：システムログファイル
xx....xx：HiRDBのサーバ名
cc....cc：障害が発生したログファイルグループ名
d：障害が発生した系
a：A系
b：B系
eeee：理由コード
理由コードと対策を表に示します。
(Ｓ)このファイルを切り離し，処理を続行します。
(Ｏ)理由コード一覧を見て対策してください。
理由
コード
意味
オペレータの処置
HiRDB管理者の処置
223
定義した最大レコードデータを取得できるだけの容量がありません。
HiRDB管理者に連絡してファイル容量の見積もり値を聞き，このファイルの容量が正しいか調べてください。ファイルの容量が誤っている場合は，正しいファイル容量でこのファイルを再作成してください。
定義を調べ，最大レコードデータ長が正しいか確認してください。最大レコードデータ長が誤っている場合はファイル容量を見積もり直した後，定義を変更してください。最大レコードデータ長が正しい場合は，見積もったファイル容量でこのファイルを再作成するようにオペレータに連絡してください。
601
ファイルのオープンに失敗しました。
該当するメッセージの直前に出力されたKFPS01200-E，KFPS01203-Eメッセージに従ってください。
－
602
ファイルの管理情報の読み込み失敗
603
ファイル上の管理情報が破壊されています。
このファイルを初期化してください。
604
ファイル上の使用システム情報がこのシステムと異なります。ほかのシステムのファイルを破壊する可能性があります。
HiRDB管理者にこのシステムで使用してもいいファイルか確認してください。このシステムで使用してもいい場合は，このファイルを初期化してください。
このファイルがほかのシステムで使用するファイルか確認してください。ほかのシステムで使用している場合は，このファイルを使用しないように定義を変更してください。
605
ファイル構成が現ファイル構成と異なります。ファイル構成を変更した可能性があります。
HiRDB管理者に連絡し，ファイル構成を変更していないか確認してください。ファイル構成を変更していない場合は，このファイルを初期化してください。
定義を調べ，該当するファイルを使用するファイルグループ，及びシステムログファイルを変更していないかどうか，確認してください。ファイル構成を変更している場合，定義上のファイル構成を元に戻してください。
606
ファイルの状態は現用です。
このファイルは，前回の使用で障害が発生した可能性があります。ログ情報を引き上げた後，ファイル状態の変更，又はファイルの初期化をしてください。
－
（凡例）－：該当しません。
注　ファイルの初期化は次に示す手順でしてください。
（1）pdlogrmコマンドでファイルを削除する。
（2）pdloginitコマンドでファイルを再作成する。
ファイル状態の変更は，pdlogchgコマンドでしてください。ログ情報の引き上げは，pdlogunldコマンドでしてください。
KFPS01250-I
aaaa（xx....xx） log file group bb....bb is not unloaded; unload.　　（Ｌ）
aaaa（xx....xx）のbb....bbログファイルグループは，アンロードされていません。又は，このログファイルグループは，ログ情報が引き上げられていません。このログファイルグループはスワップ時の交代先とされないため，ログ情報を引き上げてください。
aaaa：ログファイル種別
sys：システムログファイル
xx....xx：HiRDBのサーバ名
bb....bb：ログ情報が引き上げられていないログファイルグループ名
(Ｓ)ログサービス機能の開始処理を続行します。
(Ｏ)pdlogunldコマンドを入力して，ログ情報を引き上げてください。
KFPS01251-E
aaaa（xx....xx） log file group bb....bb　is　in　invalid　state； change　file　group state.　　（Ｌ）
aaaa（xx....xx）のログファイルグループbb....bbは，状態が不正です。ファイルグループの状態を変更してください。
このログファイルグループは前回オンラインで障害が発生したため，ログファイルグループの状態が不正です。この状態のままでは，ログ情報の取得ができません。ログ情報の引き上げ，又はファイルグループ状態を変更してください。
aaaa：ログファイル種別
sys：システムログファイル
xx....xx：HiRDBのサーバ名
bb....bb：ログファイルグループの状態が不正なログファイルグループ名
(Ｓ)ログサービス機能の開始処理を続行します。
(Ｏ)pdlogunldコマンドを入力してログ情報を引き上げるか，pdlogchgコマンドを入力してファイルグループ状態を変更してください。
KFPS01252-I
aaaa(bb....bb) log file group cc....cc is not extracted; extract.　　（Ｌ）
aaaa(bb....bb)のcc....ccログファイルグループは，HiRDB Datareplicatorによる抽出が完了していません。HiRDB Datareplicatorでシステムログを抽出してください。このログファイルグループは，システムログの抽出が完了するまで，スワップ時の交代先とされません。
aaaa：ログファイル種別
sys：システムログファイル
bb....bb：HiRDBのサーバ名
cc....cc：HiRDB Datareplicatorによる抽出が完了していないログファイルグループ名
(Ｓ)処理を続行します。
(Ｏ)HiRDB Datareplicatorが稼働中でなければHiRDB Datareplicatorを稼働して，システムログを抽出してください。
KFPS01253-I
aaa(bb....bb) log file group cc....cc not reflected by Online DB Reorganization; retry Online DB Reorganization or cancel Online DB Reorganization　　（Ｌ）
aaa(bb....bb)のシステムログファイルのファイルグループは，更新ログを使用したオンライン再編成の追い付き反映が終了していません。
aaa：システムログファイル（sys）
bb....bb：HiRDBのサーバ名
cc....cc：システムログファイルのファイルグループ名
(Ｓ)処理を続行します。
[対策]pdorendコマンドを実行してオンライン再編成の追い付き反映を継続するか，又はpdorbegin -uコマンド若しくはpdorend -uコマンドを実行して更新可能なオンライン再編成を中止するかしてください。
KFPS01255-W
Number of available file groups of aaaa(xx....xx) log is insufficient； open log file groups.　　（Ｌ）
aaaa（xx....xx）は使用できるログファイルグループが最低必要な数を満たしていません。ログファイルグループをオープンしてください。
使用できるログファイルグループが必要な数を満たしていないため，このまま運用を続けるとログ情報の取得先を変更できません。早急にログファイルグループをオープンしてください。
aaaa：ログファイル種別
sys：システムログファイル
xx....xx：HiRDBのサーバ名
(Ｓ)処理を続行します。
(Ｏ)pdlogopenコマンドを入力して，クローズ中のファイルグループをオープンしてください。
KFPS01256-E
No standby file groups of aaaa(xx....xx) log are available.　　（Ｌ）
aaaa（xx....xx）は使用できるログファイルグループがありません。
ログ情報の取得先として使用できるログファイルグループがないため，現用ログファイルグループが決定できません。
aaaa：ログファイル種別
sys：システムログファイル
xx....xx：HiRDBのサーバ名
(Ｓ)KFPS01113-Eメッセージを出力し，ログサービス機能の開始処理を中止します。
(Ｏ)現用ファイルグループが決定できなかった原因を排除してください。
KFPS01257-E
Unable to restore current aaaa(xx....xx) log file group.　　（Ｌ）
前回オンラインで使用したファイルがすべて初期化されているため，現用ログファイルグループを回復できません。
aaaa：ログファイル種別
sys：システムログファイル
xx....xx：HiRDBのサーバ名
(Ｓ)KFPS01113-Eメッセージを出力し，ログサービス機能の再開始処理を中止します。
(Ｏ)HiRDBを強制正常開始した後，データベースを回復してください。
KFPS01258-W
Unable to swap current aaaa(xx....xx) log file group for a standby file group because no standby is available; ignores "rerun swap" and continues processing.　　（Ｌ）
aaaa（xx....xx）の交代先ファイルグループが見付からなかったため，リランスワップしないで，このまま続行します。
aaaa：ログファイル種別
sys：システムログファイル
xx....xx：HiRDBのサーバ名
(Ｓ)アンロードしていないログファイルグループがあれば，アンロードしてください。
KFPS01260-E
Log generation file for system recovery not found; stops recovery processing. type:aaaa(xx....xx)　　（Ｌ）
システム回復対象のログ世代ファイルがないため，回復処理を中止します。
aaaa：ログファイル種別
sys：システムログファイル
xx....xx：HiRDBのサーバ名
(Ｓ)システムを停止します。
[対策]KFPS01240-Eメッセージを基に原因を調査してください。
KFPS01261-E
Error occurred while reading log blocks; stos recovery processing. type:aaaa(xx....xx)　　（Ｌ）
ログ読み込み時に障害が発生したため，回復処理を中止します。
aaaa：ログファイル種別
sys：システムログファイル
xx....xx：HiRDBのサーバ名
(Ｓ)システムを停止します。
[対策]このメッセージの直後に出力された，次に示すメッセージを基に障害原因を調査してください。
・KFPS01180-E
・KFPS01181-E
・KFPS01183-E
・KFPS01184-E
KFPS01262-I
Log block reading started. type:aaaa(xx....xx), read start point:bb....bb,cc....cc,dd....dd　　（Ｌ）
ログの読み込みを開始しました。
aaaa：ログファイル種別
sys：システムログファイル
xx....xx：HiRDBのサーバ名
bb....bb：読み込み開始のファイルグループ名
cc....cc：読み込み開始の世代番号
dd....dd：読み込み開始のブロック番号
KFPS01263-I
Log block reading completed. type:aaaa(xx....xx), read end point:bb....bb,cc....cc,dd....dd　　（Ｌ）
ログの読み込みを終了しました。
システム回復時，ログの読み込みを終了しました。
aaaa：ログファイル種別
sys：システムログファイル
xx....xx：HiRDBのサーバ名
bb....bb：読み込み最終のファイルグループ名
cc....cc：読み込み最終の世代番号
dd....dd：読み込み最終のブロック番号
注　bb....bb，cc....cc，dd....ddは，入力したログブロックがない場合，********，********，********を表示します。
KFPS01264-E
Error occurred during inter-system adjustment for duplicated log files. type:aaaa(xx....xx)　　（Ｌ）
HiRDB回復時，二重化されたログファイルの系間整合で，障害が発生しました。
系間整合とは，ログファイルを二重化で運用するとき，HiRDB停止のタイミングによって，ログ最終位置にA系とB系の間で誤差が生じます。HiRDB再開始時，この誤差を整えることをいいます。
aaaa：ログファイル種別
sys：システムログファイル
xx....xx：HiRDBのサーバ名
(Ｓ)処理を続行します。
(Ｏ)次に示すメッセージを基に原因を調査してください。
・KFPS01202-E
・KFPS01203-E
KFPS01265-I
Log block reading started for database recovery. type:aaaa(bb....bb), read start point:cc....cc,dd....dd,ee....ee　　（Ｌ）
データベースを回復するためのログの読み込みを開始しました。
aaaa：ログファイル種別
sys：システムログファイル
bb....bb：HiRDBのサーバ名
cc....cc：読み込み開始のファイルグループ名
dd....dd：読み込み開始の世代番号
ee....ee：読み込み開始のブロック番号
(Ｓ)処理を続行します。
KFPS01266-I
Log block reading completed for database recovery. type:aaaa(bb....bb), read end point:cc....cc,dd....dd,ee....ee　　（Ｌ）
データベースを回復するためのログの読み込みを終了しました。
aaaa：ログファイル種別
sys：システムログファイル
bb....bb：HiRDBのサーバ名
cc....cc：読み込み終了のファイルグループ名
dd....dd：読み込み終了の世代番号
ee....ee：読み込み終了のブロック番号
注　bb....bb,cc....cc,ee....eeは，入力したログブロックがない場合，**..**を表示します。
(Ｓ)処理を続行します。
KFPS01267-E
Error occurred while database recovery for aaaa(bb....bb). reason code=(cccc,dddd)　　（Ｅ＋Ｌ）
データベースの回復に失敗しました。
aaaa：ログファイル種別
sys：システムログファイル
bb....bb：HiRDBのサーバ名
cccc：理由コード
dddd：保守情報
(Ｓ)異常終了します。
(Ｏ)理由コード一覧を見て対策してください。
[対策]理由コード一覧を見て対策してください。
理由コード
意味
オペレータの処置
HiRDB管理者の処置
107
メッセージキューの操作で，障害が発生しました。
HiRDB管理者に連絡してください。
保守員に連絡してください。
114
メッセージキューの操作で，不正を検知しました。
再度リランを開始してください。
エラーが再度発生する場合は，保守員に連絡してください。
209
入力中のログファイルで入出力エラーが発生しました。
この理由コード，又はこのメッセージの前にKFPS01203-Eメッセージが出力されている場合は，その理由コードで，原因を調査してください。
保守員に連絡してください。
213
入力中のログファイルに，オープンしていない状態のファイルがあります。
214
入力中のログファイルに，閉塞中のファイルがあります。
215
入力中のログファイルに入力できない状態のファイルがあります。
711
ログファイルの世代飛びが発生しました。
ログファイルの定義を参照して，誤って変更していないかを確認してください。
1001
入力開始位置のログファイルが存在しません。
ログファイルの定義を参照して，誤って変更していないかを確認してください。
誤ってシステムログファイルを初期化していないかを確認してください。システムログファイルを初期化していて，かつHiRDBを再開始できない場合は，現用ファイルの両系障害です。
現用ファイルの両系障害時の対処方法については，マニュアル「HiRDB Version 7 システム運用ガイド」を参照してください。
1602
ログブロックの不正を検知しました。
ログファイルが破壊されている可能性があります。HiRDB管理者に連絡してください。
1610
ログブロックの抜けを検知しました。
KFPS01268-E
Invalid log data detected while reading log. type:aa....aa(bb....bb), read point: cc....cc,dd....dd.　　（Ｌ）
システムログの読み込み時に，不正なログデータを検出しました。
aa....aa：ファイル種別
sys：システムログファイル
bb....bb：HiRDBのサーバ名
cc....cc：不正なログデータを検出したシステムログファイルのファイルグループ名
dd....dd：読み込もうとしたシステムログのブロック番号
(Ｓ)処理を終了します。
[対策]このメッセージの前後に出力されたアボートコードによって処置が異なります。
・Psjnr38が出力された場合
Psjnr38が出力された場合の対策に従ってください。
・Psjnr38以外が出力された場合
$PDDIR/spool下にあるファイルとシステムログファイルを退避して，保守員に連絡してください。
KFPS01269-I
Reading log block. type:aaaa(bb....bb), reading point:cc....cc,dd....dd,ee....ee　　（Ｌ）
HiRDBの再開始処理でシステムログの読み込み中です。
aaaa：ファイル種別
sys：システムログファイル
bb....bb：HiRDBのサーバ名
cc....cc：読み込み中のシステムログのファイルグループ名
dd....dd：読み込み中のシステムログの世代番号
ee....ee：読み込み中のシステムログのブロック番号
(Ｓ)処理を続行します。
KFPS01270-E
Unable to use log file due to I/O error.element file: aa....aa, system A/B: b　　（Ｅ＋Ｌ）
ログファイルが入出力エラーのために使用できません。
aa....aa：障害の発生したシステムログファイル名
b：障害の発生した系
a：A系
b：B系
(Ｓ)処理を続行します。
(Ｏ)エラーの要因を取り除いてから，再度コマンドを入力してください。
[対策]直前に出力されたメッセージを参照し，入出力エラーの原因を調査してから，その要因を取り除いてください。
KFPS01271-I
Unloading comleted. generation number=aa....aa, start block number=bb....bb, end block number=cc....cc　　（Ｅ＋Ｌ）
アンロードが終了しました。アンロードしたブロック番号の範囲を示します。
aa....aa：アンロード元ログファイルグループの世代番号
bb....bb：アンロード済み先頭ブロック番号
cc....cc：アンロード済み最終ブロック番号
注　cc....ccは，アンロードしたログブロックがない場合********を表示します。なお，このメッセージは自動ログアンロード機能使用時にだけ表示されます。
KFPS01272-E
Unable to unload log file. element file： aa....aa, system A/B： b, reason code=cccc-dd　　（Ｅ＋Ｌ）
アンロードを実行しようとしたファイルグループに，アンロードできないシステムログファイルがあります。
aa....aa：障害が発生したシステムログファイル名
b：障害の発生した系
a：A系
b：B系
cccc：理由コード
dd：HiRDB内部コード
(Ｓ)処理を続行します。
(Ｏ)理由コード一覧を見て対策してください。
[対策]理由コード一覧を見て対策してください。
理由コード
意味
オペレータの処置
HiRDB管理者の処置
220
このファイルはシステムログファイルではありません。
－
ファイルグループのシステムログファイル名を見直してください。
603
ファイル上の管理情報が破壊されています。
該当するファイルグループのアンロードを中止し，HiRDBから切り離してください。
－
605
ファイル上の構成と定義ファイルの構成が異なっています。
－
システムログファイルに関する定義を変更していないか見直してください。
1603
システムログファイルはアンロード済み状態です。
コマンドに指定したファイルグループを見直してください。
1607
システムログファイルはHiRDBで未使用です。
－
（凡例）－：該当しません。
KFPS01273-E
Unable to change log file status. element file： aa....aa, system A/B： b,reason code=cccc-dd　　（Ｅ＋Ｌ）
ファイルの状態を変更しようとしたファイルグループに，状態の変更ができないシステムログファイルがあります。
aa....aa：障害が発生したシステムログファイル名
b：障害の発生した系
a：A系
b：B系
cccc：理由コード
理由コードと対策を表に示します。
dd：HiRDB内部コード
(Ｓ)処理を続行します。
(Ｏ)理由コード一覧を見て対策してください。
[対策]理由コード一覧を見て対策してください。
理由コード
意味
オペレータの処置
HiRDB管理者の処置
220
このファイルはシステムログファイルではありません。
－
ファイルグループのシステムログファイル名を見直してください。
603
ファイル上の管理情報が破壊されています。
該当するファイルグループのアンロードを中止し，HiRDBから切り離してください。
－
605
ファイル上の構成と定義ファイルの構成が異なっています。
－
システムログファイルに関する定義を変更していないか見直してください。
1603
システムログファイルはアンロード済み状態です。
コマンドに指定したファイルグループ名を見直してください。
－
1607
システムログファイルはHiRDBで未使用です。
（凡例）－：該当しません。
KFPS01274-E
Failure to open log element file. element file ：aa....aa, system A/B： b, reason code=cccc-dd　　（Ｅ＋Ｌ）
システムログファイルのオープンに失敗しました。
aa....aa：システムログファイル名
b：障害の発生した系
a：A系
b：B系
cccc：理由コード
dd：HiRDB内部コード
(Ｓ)処理を続行します。
(Ｏ)理由コードに従って対策してください。
[対策]理由コードに従って対策してください。
理由コード
意味
オペレータの処置
HiRDB管理者の処置
101
メモリ不足が発生しました。
現在実行中のプロセスの終了を待って，再度コマンドを実行してください。
メモリの見積もりをし直してください。
201
ファイル名が不正です。
次に示す原因が考えられます。
・パス名に使用できない文字を指定しています。
・HiRDBファイル名の長さが制限（30文字）を超えました。
ファイル名を正しく指定し直し，再度コマンドを実行してください。
－
202
指定したパスのHiRDBファイルシステム領域名が， HiRDBファイルシステム領域ではありません。
指定したパスの HiRDBファイルシステム領域名を見直して，再度コマンドを実行してください。
pdlogadpfオペランドのファイルの指定を見直してください。
203
指定したパスの装置がHiRDBファイルシステム用に初期化されていませ
ん。
－
207
指定したパスの HiRDBファイルシステム領域のオープンで，上限値オーバが発生しました。
－
208
指定したパスの HiRDBファイルシステム領域に対し，アクセス権限がありません。
pdflsコマンドを用いてHiRDBファイルのアクセス権限について確認してください。
pdlogadpfオペランドのファイルの指定を見直してください。
209
入出力エラーが発生しました。
入出力エラーが発生した原因を調査し，対策してください。
－
210
HiRDBファイルシステムのバージョンが一致していません。
－
pdlogadpfオペランドのファイルの指定を見直してください。
211
指定したファイルに対するアクセス権限がありません。
pdflsコマンドを用いてログのアクセス権限について確認してください。
－
212
指定したファイルがありません。
－
pdlogadpfオペランドのファイルの指定を見直してください。
221
ロックセグメント不足が発生しました。
OSのシステム起動時に，指定したレコードロックセグメント数を見直してください。
222
該当するシステムログファイルは，ほかのプロセスで使用中です。
該当するシステムログファイル，又はそのファイルグループの運用状態を確認し，再度コマンドを実行してください。
－
（凡例）－：該当しません。
KFPS01275-E
Minor error occurred while analyzing definitions for log service. file being analyzed： aaaaaaaa, record number=bbbbbbbbbb,reason code=cccc　　（Ｅ＋Ｌ）
ログファイルに関する定義を解析中に軽度エラーが発生しました。
aaaaaaaa：解析中の定義ファイル名
bbbbbbbbbb：エラーがあったレコード番号
cccc：障害の内容を示す理由コード
理由コードと対策を表に示します。
(Ｓ)ログサービス機能のコマンドを続行します。
[対策]ログサービス機能関係の定義を見直してください。
理由コード
意味
対策
409
pdlogadpfオペランドの-gオプションの指定に次のどちらかの誤りがあります。
・-gオプションを指定していない
・システムログファイルグループ名称長に誤りがある
pdlogadpfオペランドの指定を修正した後に再度コマンドを実行してください。
410
同一ファイルグループ名称を指定したpdlogadpfオペランドを二つ以上指定しています。
411
pdlogadpf定義オペランドの-aオプション指定に誤りがあります。
-aオプションが未指定
ファイル名が未指定
412
pdlogadpf定義オペランドの-bオプション指定に誤りがあります。
二重化する場合で，-bオプションが未指定
ファイル名が未指定
422
pdlogadfgオペランドの-dオプション指定に誤りがあります。又は，指定されていません。
必要があればシステムを停止し，定義内容を修正した後，再度起動してください。
423
pdlogadpfオペランドの-dオプション指定に誤りがあります。又は，指定されていません。
KFPS01277-E
Log point information is invalid. info=aaaa　　（Ｌ）
ログポイント情報の不正を検知しました。
aaaa：システムの保守情報
(Ｓ)処理を続行します。
(Ｏ)次に示す項目について，調査及び対策を実施してください。
1. pdrstrコマンドに指定したバックアップファイルが誤っていないかを確認してください。誤っている場合には，正しいファイル名称を指定して，再度実行してください。
2. pdrstrコマンドで，バックアップファイルから再作成したログポイント情報ファイル，pdloglsコマンドの実行結果を参照し，ログポイント情報ファイルに記されたログファイルがあるかを確認し，その結果を管理者に報告してください。
[対策]次に示す項目について，調査及び対策を実施してください。
1. ログポイント情報ファイルに記されたログファイルがない場合には，サーバ定義中のログファイルの指定を操作していないかを確認してください。
バックアップ取得後に使用したログファイルを定義中から除いている場合には，追加して再度実行してください。
また，上記ログファイルを削除，又はログポイント情報ファイルに記されているログファイルが上書きされている場合には，-L指定のpdrstrでデータベースを回復できません。
2. 上記に該当しない場合は，保守員に連絡してください。
KFPS01278-W
Failure to processing log file group. type：aaa(bb....bb),file group：cc....cc,reason code=dddd-ee　　（Ｌ）
bb....bbサーバが使用するcc....ccログファイルグループは，ddddに示す理由でファイルの状態を参照できないため，処理対象から除外します。
aaa：ログ種別（sys，又はlar）
bb....bb：HiRDBのサーバ名称
cc....cc：ファイルグループ名称
dddd：理由コード
209：ログファイルの入出力エラー
213：ログファイルのオープンエラー
215：ログファイルの入力不可
222：ほかのプロセスでこのファイルグループを使用中
1601：対象ログファイルなし
ee：システム保守情報
(Ｓ)処理を続行します。該当するログファイルグループは，処理の対象から除外します。
(Ｏ)該当するログファイルを使用していない場合，特に問題ありません。
・pdrstr（データベース回復ユティリティ）実行時
バックアップ取得から現在までの間に該当するログファイルを使用している場合，データベースが正しく回復できないことがあります。KFPS01279-Wメッセージが出力されている場合，その内容も考慮し，管理者に連絡して対策した後に再度実行してください。
・pdlogchg（ログファイルのステータス変更コマンド）実行時
・理由コードが222の場合
該当するログファイルグループに対して，メモリ上の状態とシステムログファイル自身の状態が不整合となっています。該当するログファイルグループをpdlogclsコマンドでクローズした後，pdlogopenコマンドで再度オープンしてください。
・そのほかの理由コードの場合
理由コードに従って対策をした後に再度コマンドを実行してください。また，KFPS01279-Wメッセージが出力されている場合は，メッセージで出力された障害を対策した後に再度コマンドを実行してください。
[対策]該当するログファイルがpdrstr，及びpdlogchgの実行に不要な場合，特に問題ありません。該当するログファイルが上記コマンドの実行に必要な場合，次に示す項目について，調査及び対策を実施してください。
1. 該当するログファイルグループに障害が発生した，又は該当するログファイルグループをオンラインで使用後，初期化している場合，ログファイルが回復できる場合，回復後に再度実行してください。
2. サーバ定義中のログファイルに関する記述が誤っていないかを確認し，誤っている場合には，正しく訂正した後に再度実行してください。
3. HiRDB稼働中にpdlogchg -zコマンドを実行して理由コード222が出力された場合は，該当するログファイルは再使用できません。いったんログファイルをクローズしてから再度オープンしてください。
4. 上記に該当しない場合は，保守員に連絡してください。
KFPS01279-W
Unable to use log file. element file：aa....aa, system A/B：b,reason code=cccc-dd　　（Ｌ）
aa....aaログファイルは，ccccに示す理由でファイルの状態を参照できません。処理対象から除外します。
aa....aa：ログファイル名称
b：障害が発生した系（a，又はb）
cccc：理由コード
dd：システム保守情報
(Ｓ)処理を続行します。該当するログファイルは，処理の対象から除外します。
(Ｏ)該当するログファイルを使用していない場合，特に問題ありません。このメッセージの直後に，該当するログファイルが属するファイルグループについてKFPS01278-Wメッセージが出力されていない場合，問題ありません。上記に該当しない場合，理由コードの内容から原因を調査し，管理者に連絡してください。
[対策]該当するログファイルがpdrstr，及びpdlogchgの実行に不要な場合，特に問題ありません。該当するログファイルが上記コマンドの実行に必要な場合，理由コードの内容から原因を調査し，KFPS01278-Wに記述した内容に従って回復して，再度実行してください。理由コードを次に示します。
理由コード
意味
オペレータの処置
HiRDB管理者の処置
101
メモリ不足が発生しました。
現在実行中のプロセスの終了を待って，再度コマンドを実行してください。
メモリの見積もりをし直してください。
201
ファイル名が不正です。
次に示す原因が考えられます。
・パス名に使用できない文字を指定しています。
・HiRDBファイル名の長さが制限（30文字）を超えました。
ファイル名を正しく指定し直し，再度コマンドを実行してください。
－
202
指定したパスの HiRDBファイルシステム領域名が， HiRDBファイルシステム領域ではありません。
指定したパスの HiRDBファイルシステム領域名を見直して，再度コマンドを実行してください。
pdlogadpfオペランドのファイルの指定を見直してください。
203
指定したパスの装置がHiRDBファイルシステム用に初期化されていません。
－
207
指定したパスの HiRDBファイルシステム領域のオープンで，上限値オーバが発生しました。
－
208
指定したパスの HiRDBファイルシステム領域に対し，アクセス権限がありません。
pdflsコマンドを用いてHiRDBファイルのアクセス権限について確認してください。
pdlogadpfオペランドのファイルの指定を見直してください。
209
入出力エラーが発生しました。
入出力エラーが発生した原因を調査し，対策してください。
－
210
HiRDBファイルシステムのバージョンが一致していません。
－
pdlogadpfオペランドのファイルの指定を見直してください。
211
指定したファイルに対するアクセス権限がありません。
pdflsコマンドを用いてログのアクセス権限について確認してください。
－
212
指定したファイルがありません。
－
pdlogadpfオペランドのファイルの指定を見直してください。
221
ロックセグメント不足が発生しました。
OSのシステム起動時に，指定したレコードロックセグメント数を見直してください。
222
該当するシステムログファイルはほかのプロセスで使用中です。
該当するシステムログファイル又はそのファイルグループの運用状態を確認し，再度コマンドを実行してください。
－
603
ファイル上の管理情報が破壊されています。
このファイルを初期化してください。
605
ファイル上のファイル構成が現ファイル構成と異なります。ファイル構成を変更した可能性があります。
HiRDB管理者に連絡し，ファイル構成を変更していないか確認してください。ファイル構成を変更していない場合は，このファイルを初期化してください。
定義を調べ，該当するファイルを使用するファイルグループ，及びシステムログファイルを変更していないかどうか，確認してください。ファイル構成を変更している場合，定義上のファイル構成を元に戻してください。
1607
ファイルはHiRDBで未使用です。
該当するファイルグループを見直してください。
－
（凡例）－：該当しません。
KFPS01280-E
Unable to execute aa....aa command due to bbbb-cc　　（Ｅ）
aa....aaコマンドが実行できません。
aa....aa：実行できなかったコマンド名
bbbb：理由コード
cc：HiRDB内部コード
(Ｓ)コマンドの実行を終了します。
(Ｏ)理由コードによって対策し，必要があれば再度コマンドを実行してください。
[対策]次に示す理由コード一覧を参照して，対策してください。
理由
コード
意味
オペレータの処置
HiRDB管理者の処置
101
メモリ不足が発生しました。
現在実行中のプロセスの終了を待って再度コマンドを実行してください。直前にシステムコールのメッセージが出力されている場合は，そのメッセージに従って対策してください。
HiRDB稼働中に次に示すコマンドを実行した場合は，更にそれぞれの対策を実施してください。
再度メモリの見積もりをしてください。
・pdlogchgコマンド
メモリ中の状態とシステムログファイルの状態が不整合となっている可能性があります。該当するファイルグループをpdlogclsコマンドでクローズし，pdlogopenコマンドで再度オープンしてください。この時点でファイルグループがアンロード待ち状態になっていたら，再度pdlogchgコマンドを実行してください。
・pdlogunldコマンド
直後にKFPS01271-Iメッセージが出力された場合は，アンロードログファイルは正常に作成されています。しかしメモリ中の状態とシステムログファイルの状態が不整合となっています。該当するファイルグループをpdlogclsコマンドでクローズし，pdlogopenコマンドで再度オープンしてください。KFPS01271-Iメッセージが出力されなかった場合は，再度pdlogunldコマンドを実行してください。
102
読み出しプロセスにアタッチされている共用メモリのセグメント数が，システムで規定されている許容最大共用メモリアタッチ数の限度を超えるため，共用メモリライブラリのサービス機能を提供できません。
直前にシステムコールのメッセージが出力されている場合は，そのメッセージに従って対策してください。
再度共用メモリの見積もりをしてください。
103
ネットワーク障害が発生しました。考えられる発生要因を次に示します。
・イーサネット・ボードやケーブルなどのハードウェア障害
・ネットワーク定義の設定誤り
・目的プロセスが実行中でない。
次の手順で原因を調査し，対策してください。
(1)OSのコマンドでサーバマシンの接続状態を調べてください。
(2)HiRDBのコマンドで各サーバの実行状態を調べてください。
HiRDB稼働中に次に示すコマンドを実行した場合は，更にそれぞれの対策を実施してください。
・pdlogchgコマンド
メモリ中の状態とシステムログファイルの状態が不整合となっている可能性があります。該当するファイルグループをpdlogclsコマンドでクローズし，pdlogopenコマンドで再度オープンしてください。この時点でファイルグループがアンロード待ち状態になっていたら，再度pdlogchgコマンドを実行してください。
・pdlogunldコマンド
直後にKFPS01271-Iメッセージが出力された場合は，アンロードログファイルは正常に作成されています。しかしメモリ中の状態とシステムログファイルの状態が不整合となっています。該当するファイルグループをpdlogclsコマンドでクローズし，pdlogopenコマンドで再度オープンしてください。KFPS01271-Iメッセージが出力されなかった場合は，再度pdlogunldコマンドを実行してください。
104
ログサービス機能がオンライン中でないか，又は共用メモリ上の必要な情報が参照できません。
pdlsコマンドで該当HiRDBユニットの実行状態を調べてください。
－
105
コマンドの実行時にタイムアウトを検出しました。
・該当HiRDBユニットがオンライン状態でない場合，オンライン状態になってから，再度コマンドを実行してください。
・該当HiRDBユニットが既にオンライン状態であり，-wオプションを指定したpdlogswapコマンドで該当理由コードが出力された場合には，長時間実行中のトランザクションがあるかどうかを調査してください。
(1)長時間実行中のトランザクションがある場合
(a)該当トランザクションをキャンセルできないとき
・該当トランザクションの終了を待って，シンクポイントダンプの有効化ができることを確認した後に，再度pdlogswapコマンドを実行してください。
・現在実行中のトランザクションの終了までシンクポイントダンプの有効化を待ち合わせられるように，-tオプションに十分な値を設定して，再度pdlogswapコマンドを実行してください。
(b)該当トランザクションをキャンセルできるとき
・キャンセルした後に，再度pdlogswapコマンドを実行してください。
(2)長時間実行中のトランザクションがない場合
・再度pdlogswapコマンドを実行してください。
106
共用メモリが使用できません。
直前に出力されている，システムコールのエラーメッセージに従って対策してください。
107
システムコールでエラーが発生しました。
直前に出力されたシステムコールのエラーメッセージを基に原因を調査してください。
108
二重化されていないのに，不正なオプションが指定されています。
非二重化時に指定できるオプションだけを指定し，再度コマンドを実行してください。
110
コマンドの指定は，該当するシステムの実行環境では動作できません。
-dで指定したオプションを見直してください。また，該当するシステムの実行環境を見直してください。
116
以前に実行した，-wオプションを指定したpdlogswapコマンドによるシンクポイントダンプの有効化待ち中であるため，再度-wオプションを指定したpdlogswapコマンドは実行できません。
長時間実行中のトランザクションがあるかどうかを調査してください。
(1)長時間実行中のトランザクションがある場合
(a)該当トランザクションをキャンセルできないとき
・該当トランザクションの終了を待って，シンクポイントダンプの有効化ができることを確認した後に，再度pdlogswapコマンドを実行してください。
・現在実行中のトランザクションの終了までシンクポイントダンプの有効化を待ち合わせられるように，-tオプションに十分な値を設定して，再度pdlogswapコマンドを実行してください。
(b)該当トランザクションをキャンセルできるとき
・キャンセルした後に，再度pdlogswapコマンドを実行してください。
(2)長時間実行中のトランザクションがない場合
・再度pdlogswapコマンドを実行してください。
201
ファイル名が不正です。
次に示す原因が考えられます。
・パス名に使用できない文字を指定しています。
・HiRDBファイル名の長さが制限（30文字）を超えました。
ファイル名を正しく指定し直し，再度コマンドを実行してください。
202
指定したファイル名がキャラクタ型スペシャルファイルではありません。又はこのキャラクタ型スペシャルファイルに対する装置がありません。
指定したファイル名を見直し，再度コマンドを実行してください。
203
指定した装置がHiRDBファイルシステム用に初期化されていません。
ファイル名を見直してください。ファイル名が正しい場合は，装置をHiRDBファイルシステム用に初期化してください。
204
ファイルが既にあります。
ファイル名を見直してください。ファイル名が正しい場合は，pdlogrmコマンドでファイルを削除した後，再度pdloginitコマンドを実行してください。
205
ファイルを作成するための領域が確保できません。
ファイルを作成する装置を変更してください。又は，いらないファイルを削除するか，ファイルのバックアップをしてpdfmkfsコマンドでHiRDBファイルを再作成した後，ファイルのリストアをしてファイルを作成してください。
再度ファイルの見積もりをしてください。
206
ファイルシステム初期化時に指定したファイル数の上限を超えました。
207
キャラクタ型スペシャルファイルのオープンで上限値オーバが発生しました。
－
208
指定したキャラクタ型スペシャルファイルに対するアクセス権限がありません。
pdflsコマンドでアクセス権限の確認をしてください。
209
HiRDBファイルシステム上に作成したログファイルへのアクセス時に，入出力エラーが発生しました。
入出力エラーが発生した原因を調査し，対策してください。pdloginitコマンドの場合，入出力エラーが発生していないほかのディスク装置，又はパーティションにHiRDBファイルシステム領域を作成し直した後で，コマンドを再度実行してください。
－
210
HiRDBファイルシステムのバージョンが一致しません。
HiRDBファイルシステムを作成し直してください。
211
指定したファイルに対するアクセス権限がありません。
pdflsコマンドアクセス権限の確認をしてください。
212
ファイルがありません。
正しいファイル名を指定し，再度コマンドを実行してください。
216
指定されたファイル名は，ログ，又はシンクポイントダンプではありません。
217
指定されたファイル名は，アンロードログではありません。
221
ロックセグメント不足が発生しました。
－
OSシステム構築時に指定したレコードロックセグメント数を見直してください。
222
ログファイルを使用しようとしましたが，ほかのプロセスで使用中です。
コマンドで指定したファイルがほかのプロセスで使用中でないか確認してください。必要であれば，再度コマンドを実行してください。HiRDBの稼働中に次に示すコマンドを実行した場合は，更にそれぞれの対策を実施してください。
－
・pdlogopen，pdlogcls，pdlogswapコマンドの場合
再度コマンドを実行してください。
・pdlogchgコマンドの場合
メモリ中の状態とシステムログファイルの状態が不整合となっている可能性があります。該当するファイルグループをpdlogclsコマンドでクローズし，pdlogopenコマンドで再度オープンしてください。この時点でファイルグループがアンロード待ち状態になっていたら，再度pdlogchgコマンドを実行してください。
・pdlogunldコマンドの場合
直後にKFPS01271-Iメッセージが出力された場合は，アンロードログファイルは正常に作成されています。しかしメモリ中の状態とシステムログファイルの状態が不整合となっています。該当するファイルグループをpdlogclsコマンドでクローズし，pdlogopenコマンドで再度オープンしてください。KFPS01271-Iメッセージが出力されなかった場合は，再度pdlogunldコマンドを実行してください。
224
指定されたファイルはアンロード待ち状態です。
ファイル名を見直してください。ファイル名が正しい場合は，pdlogunld，若しくは，pdlogchgコマンドでファイルをアンロード済み状態にするか，又は-uオプションを指定して，再度pdlogrmを実行してください。
225
システムファイル用ではないHiRDBファイルシステム領域に，ファイルを作成しようとしました。
HiRDBファイルシステム領域名及びpdfstatfsコマンドでHiRDBファイルシステム領域の使用目的を確認し，システムファイル用HiRDBファイルシステム領域にファイルを作成するようにしてください。
227
指定されたファイルは抽出未完了状態です。
ファイル名を見直してください。ファイル名が正しい場合は，pdlogchgコマンドでファイルを抽出完了状態にするか，又は-uオプションを指定して，再度pdlogrmコマンドを実行してください。
228
指定したファイルはオンライン再編成上書き禁止状態です。
ファイル名を見直してください。ファイル名が正しい場合は，pdlogchgコマンドでオンライン再編成上書き可能状態にするか，又はpdlogrm -uコマンドを実行してください。
301
ファイルが既にあります。
OSのコマンドを用いてファイルを正しいファイル名で再度コマンドを実行してください。
302
指定されたファイル名はディレクトリです。
303
アンロードログファイルのオープン時に，エラーが発生しました。
直前に出力されたopenシステムコールのエラーメッセージを基に原因を調査してください。
304
アンロードログファイルのクローズ時に，エラーが発生しました。
直前に出力されたcloseシステムコールのエラーメッセージを基に原因を調査してください。
305
アンロードログファイルへのアクセス時に，エラーが発生しました。
直前に出力されたwriteシステムコールのエラーメッセージを基に原因を調査してください。
306
HiRDBファイルシステム領域に作成したアンロードログファイルでエラーが発生しました。
直前に出力されたKFPS01300-Eメッセージを基に原因を調査してください。
307
アンロードログファイルのリード時にエラーが発生しました。
直前に出力されたreadシステムコールのエラーメッセージを基に原因を調査してください。
403
定義ファイルのオープンエラーが発生しました。
直前に出力された定義ファイルのオープンエラーメッセージを基に原因を調査してください。
404
解析ファイルのオープンエラーが発生しました。
直前に出力された解析ファイルのオープンエラーメッセージを基に原因を調査してください。
405
定義解析処理中にエラーを検出しました。
直前に出力された解析エラーのメッセージを基に原因を調査してください。
410
定義解析処理中にシステムログファイルのファイルグループ名の重複エラーを検出しました。
pdlogadpfオペランドの-gオプションに指定したファイルグループ名が重複していないか確認してください。
413
定義解析処理中にシステムログファイルのファイルグループ数の上限エラーを検出しました。
pdlogadpfオペランドの数がシステムログファイルのファイルグループ数の上限値を超えていないか確認してください。
414
有効なログファイルグループ定義の数が，システム開始に必要な最小世代数に達していません。有効なログファイルグループの定義とは，pdlogadfgオペランドのうち，エラーがなく，かつONL指定されたものです。
対応するHiRDBサーバ定義のpdlogadfgオペランドを修正し，システムを再度起動してください。
417
定義解析処理中にエラーを検出しました。
直前に出力された解析エラーのメッセージを基に原因を調査してください。
701
ファイルグループがありません。
pdloglsコマンドでファイルグループの状態を確認し，必要なら再度コマンドを実行してください。また，直前に定義ファイルの解析エラーが発生している場合は，定義解析エラーのメッセージを基に原因を調査してください。
702
ファイルグループのオープンに失敗しました。
ログファイルに出力されているKFPS01200-E，又はKFPS01201-Eメッセージの理由コードによって，失敗した原因を調査し，対策してください。
703
ファイルグループのクローズに失敗しました。
704
該当するファイルグループは既にオープンされています。
pdloglsコマンドでファイルグループの状態を確認し，正しいファイルグループ名を指定して再度コマンドを実行してください。
705
該当するファイルグループは既にクローズされています。
706
該当するファイルグループはクローズできる状態ではありません。
707
該当するファイルグループはシステムの回復 処理，又はpdlogunld，pdlogchgコマンドで使用中です。
pdloglsコマンドでファイルグループの状態を確認し，正しいファイルグループ名を指定して再度コマンドを実行してください。
708
上書きできるファイルグループがなくなるため，該当するファイルグループはクローズできません。
－
709
同一世代のファイルグループがほかにあるため，ファイルのオープンをやめました。
該当するファイルをpdlogrmコマンドで削除した後，pdloginitで作成してください。
710
指定されたファイルグループは現用です。
pdloglsコマンドでファイルグループの状態を確認し，必要なら再度コマンドを実行してください。
712
システムログファイルの空き率が警告値未満になるため，システムログファイルをクローズできません。
システムログファイルの空き率を増やした後にpdlogclsコマンドを再実行してください。システムログファイルの空き率については，マニュアル「HiRDB Version 7 システム運用ガイド」を参照してください。
1101
オープン対象ファイルのオープンに失敗しました。
出力されたKFPS01240-Eメッセージに従ってください。
1301
指定されたリソースグループ名がありません。
pdloglsコマンドでリソースグループ名を確認してください。
1601
アンロード，又はステータス変更ができるログファイルがありません。
指定したファイルグループ名を見直してください。
1602
ログファイルのブロック抜けを検知しました。
ログファイルが破壊された可能性があります。該当するファイルグループのアンロードを中止して，HiRDB管理者に連絡してください。
該当するシステムログファイルをアンロードできません。該当するシステムログファイルのアンロードログを使用しなくてもDBを回復できるように，バックアップを取得してください。また，原因調査のため，アンロードに失敗したシステムログファイルを障害資料として取得し，保守員に連絡してください。
1603
該当するファイルグループはアンロード済み状態です。
指定したファイルグループ名を見直してください。指定したファイルグループが正しくて，pdloglsコマンドでこのファイルグループがアンロード待ち状態と表示される場合は，以前に入力したpdlogunldコマンド又はpdlogchgコマンドで，メモリ中の状態を更新できない障害が発生した可能性があります（アンロード処理自体は成功しています）。この場合，該当するファイルグループをpdlogclsコマンドでクローズし，その後pdlogopenコマンドで再オープンすると，不整合状態を解消できます。
－
1604
pdloginitコマンドの-nオプションの指定値が12～2097152の範囲外です。
-nオプション指定値を12～2097152の範囲内の数値として，再度pdloginitコマンドを実行してください。
1606
コマンド実行中にHiRDBが次に示すどれかの状態になりました。
・HiRDB開始処理中
・HiRDB終了処理中
・HiRDB稼働中
システムログファイルを保護するため，コマンドを終了します。
－
pdls -d svrコマンドで，HiRDBの稼働状態を確認してください。
HiRDBが停止しているときに，pdlogchg又はpdlogunldコマンドを再実行してください。
なお，pdlogunldコマンドの実行中にこのメッセージが出力された場合，作成したアンロードログファイルはデータベースの回復に使用できません。
1607
pd_log_unload_check=Nを指定していて，かつHiRDBが稼働中のため，ファイルグループの状態を変更できません。
－
pdlogchgコマンドには-Rオプションを指定してください。
pdlogunldコマンドには-fオプションを指定してください。
1609
該当するファイルグループは抽出完了状態です。
指定したファイルグループ名を見直してください。指定したファイルグループが正しくて，pdloglsコマンドでこのファイルグループが抽出未完了状態と表示される場合は，以前に入力したpdlogchgコマンドで，メモリ中の状態を更新できない障害が発生した可能性があります。この場合，該当するファイルグループをpdlogclsコマンドでクローズして，その後pdlogopenコマンドで再オープンすると，不整合状態を解消できます。
－
1612
pdloginitコマンドの-lオプションの指定値が1024～4096の範囲外です。
-lオプション指定値を1024～4096の範囲内の数値として，再度pdloginitコマンドを実行してください。
1613
HiRDBファイルシステム領域のセクタ長，指定したレコード長，又は指定したレコード数が不正です。
直前に出力されたKFPS01207-Eメッセージを基に原因を調査してください。
1614
pdloginitコマンドで指定したHiRDBファイル名が不正です。
システムログファイル名を絶対パス名で指定して，再度pdloginitコマンドを実行してください。
1615
該当するファイルグループはオンライン再編成上書き可能状態です。
指定したファイルグループ名を見直してください。指定したファイルグループ名が正しい場合，かつpdloglsコマンドでこのファイルグループがオンライン再編成上書き禁止状態と表示される場合は，以前に実行したpdlogchgコマンドでメモリ中の状態を更新できない障害が発生した可能性があります。この場合，該当するファイルグループをpdlogclsコマンドでクローズして，その後pdlogopenコマンドでオープンしてください（ファイルとメモリの不整合が解消されます）。
1660
自動ログアンロード機能のアンロードログファイル出力先ディレクトリが使用できません。
自動ログアンロード機能のアンロードログファイル出力先ディレクトリに指定したディレクトリがあるか確認してください。また，出力先ディレクトリに書き込み権限があるか確認してください。
1670
すべてのアンロードログファイル作成ディレクトリが使用できません。
出力されたKFPS01152-Wメッセージの理由コードを参照して対策してください。
1676
1677
自動ログアンロード機能は使用できません。
●HiRDBを正常開始している場合
HiRDBの開始時に次に示すオペランドが，該当するサーバのサーバ定義に指定されていたかを確認してください。
・pd_log_auto_unload_path
・pd_log_unload_check=Y
●HiRDBを計画停止又は再開始している場合
前回のHiRDB稼働時に自動ログアンロード機能が使用できていたかを確認してください。また，HiRDB開始時に次に示すオペランドが，該当するサーバのサーバ定義に指定されていたかを確認してください。
・pd_log_unload_check=Y
1678
自動ログアンロード機能は既に動作しています。
pdlogatulコマンドで，自動ログアンロード機能が動作していることを確認してください。
1679
自動ログアンロード機能は既に停止しています。
pdlogatulコマンドで，自動ログアンロード機能が停止していることを確認してください。
1680
自動ログアンロード停止待ち監視中に，次の要因で自動ログアンロード機能が停止しました。
・すべてのアンロードログ作成先ディレクトリが使用できません。
・アンロードログファイルの名称が重複しています。
・資源不足です。
ほかに出力されているメッセージから，自動ログアンロード機能が停止した原因を調査し，対策した後に自動ログアンロード機能を再開始（pdlogatul -bコマンドを実行）してください。その後，再度pdlogatul -t -wコマンドを実行してください。
1681
自動ログアンロード停止待ち監視中にタイムアウトが発生したため，監視を中断して自動ログアンロード機能を停止しました。
アンロードログ作成先ディレクトリがあるディスクで入出力遅延が発生していないか確認してください。その後，自動ログアンロード機能を再開始（pdlogatul -bコマンドを実行）してから，再度pdlogatul -t -wコマンドを実行してください。
（凡例）－：該当しません。
KFPS01281-E
Invalid command format.　　（Ｅ）
コマンドの形式が誤っています。
(Ｓ)コマンドの実行を中止します。
(Ｏ)コマンドの形式を確認し，再度コマンドを実行してください。
KFPS01282-E
bb....bb specified with aa option not found.　　（Ｅ）
aaオプションで指定されたbb....bbが見付かりません。
aa：オプションコード
-g：ファイルグループ名指定時のオプション
bb....bb：ファイルグループ名
(Ｓ)コマンドの実行を中止します。
(Ｏ)オプションの引数を正しく指定し直し，再度コマンドを実行してください。
KFPS01283-W
Minor error occurred during aa....aa command execution. reason code=bbbb-cc　　（Ｅ）
aa....aaコマンド実行中に軽度エラーが発生しました。
コマンド処理は正常に終了しましたが，実行中に理由コードに示す軽度エラーが発生しました。
aa....aa：実行中に軽度エラーが発生したコマンド名
bbbb：理由コード
cc：HiRDB内部コード
(Ｓ)コマンド処理を続行します。
(Ｏ)理由コード一覧を見て対策し，必要な場合は，再度コマンドを実行してください。
[対策]理由コード一覧を見て対策してください。
理由コード
意味
オペレータの処置
1102
オープン対象ファイルの一部のオープンに失敗しました（この場合，オープンに成功したファイルについては，オープンを有効とします）。
必要であれば，ログファイルに出力されているKFPS01240-Eメッセージに従って対策してください。
1103
オープン対象となるファイルすべてが，既にオープンされています。
必要であれば，pdloglsコマンド（-e指定）でファイルグループを構成するファイルの状態を確認し，正しいファイルグループ名，A系かB系かを指定して，再度コマンドを入力してください。
1104
クローズ対象となるファイルすべてが，既にクローズされています。
KFPS01284-I
Usage: pdlogsync -d sys [-s servername] [-w [-t wait time]] 　　（Ｅ）
pdlogsyncコマンドの入力形式に誤りがあります（HiRDB／シングルサーバの場合）。
(Ｓ)処理を終了します。
(Ｏ)コマンドを正しく入力してください。
KFPS01284-I
Usage: pdlogsync -d sys -s servername [-w [-t wait time]] 　　（Ｅ）
pdlogsyncコマンドの入力形式に誤りがあります（HiRDB／パラレルサーバの場合）。
(Ｓ)処理を終了します。
(Ｏ)コマンドを正しく入力してください。
KFPS01285-E
Command unable to be executed due to swap processing.　　（Ｅ）
システムログファイルが処理中のためコマンドが実行できません。
(Ｓ)コマンドの実行を中止します。
(Ｏ)スワップ処理の終了を待って，再度コマンドを実行してください。
KFPS01286-E
Unable to perform swapping because no standby log file group is available.　　（Ｅ）
交代用ログファイルグループがないため，スワップできません。
(Ｓ)スワップコマンドを中止します。
(Ｏ)pdlogunldコマンド，又はpdlogchgコマンドで，アンロード済み状態にし，交代先を用意してください。又は，pdlogopenコマンドで予備状態のログファイルをオンラインに割り当て，交代先を用意してください。その後，必要があれば再度コマンドを実行してください。
KFPS01290-I
Usage： pdlogswap -d sys [-s server_name] [-w [-t wait_time]]　　（Ｅ）
HiRDB/シングルサーバでのpdlogswapコマンドの使用方法を示します。コマンドの形式が誤っている場合に出力します。
(Ｓ)処理を続行します。
KFPS01290-I
Usage： pdlogswap -d sys -s server_name [-w [-t wait_time]]　　（Ｅ）
HiRDB/パラレルサーバでのpdlogswapコマンドの使用方法を示します。コマンドの形式が誤っている場合に出力します。
(Ｓ)処理を続行します。
KFPS01291-I
Usage： pdlogls -d sys|spd [-s server_name] [-g file_group_name] [-e] [-l]　　（Ｅ）
HiRDB/シングルサーバでのpdloglsコマンドの使用方法を示します。コマンドの形式が誤っている場合に出力します。
KFPS01291-I
Usage: pdlogls {-d sys -s server_name [-u unit_id] [-g file_group_name] [-e]|-d spd -s server_name [-g file_group_name] [-e] [-l]}　　（Ｅ）
HiRDB/パラレルサーバでのpdloglsコマンドの使用方法を示します。コマンドの形式が誤っている場合に出力します。
KFPS01292-I
Usage: pdloginit {-d sys [-s server_name] -f file_name -n record_count [-l record_size] | -d spd [-s server_name] -f file_name -n record_count}　　（Ｅ）
HiRDB/シングルサーバでのpdloginitコマンドの使用方法を示します。コマンドの形式が誤っている場合に出力します。
KFPS01292-I
Usage: pdloginit {-d sys -s server_name [-u unit_id] -f file_name -n record_count [-l record_size] | -d spd -s server_name [-u unit_id] -f file_name -n record_count} [-D]　　（Ｅ）
HiRDB/パラレルサーバでのpdloginitコマンドの使用方法を示します。コマンドの形式が誤っている場合に出力します。
KFPS01293-I
Usage: pdlogrm -d sys|spd [-s server_name] -f file_name [-u]　　（Ｅ）
HiRDB/シングルサーバでのpdlogrmコマンドの使用方法を示します。コマンドの形式が誤っている場合に出力します。
KFPS01293-I
Usage: pdlogrm -d sys|spd -s server_name [-X unit_id] -f file_name [-u] [-D]　　（Ｅ）
HiRDB/パラレルサーバでのpdlogrmコマンドの使用方法を示します。コマンドの形式が誤っている場合に出力します。
KFPS01294-I
Usage: pdlogopen -d sys|spd [-s server_name] -g file_group_name [-a] [-b]　　（Ｅ）
HiRDB/シングルサーバでのpdlogopenコマンドの使用方法を示します。コマンドの形式が誤っている場合に出力します。
KFPS01294-I
Usage: pdlogopen -d sys|spd -s server_name -g file_group_name [-a] [-b]　　（Ｅ）
HiRDB/パラレルサーバでのpdlogopenコマンドの使用方法を示します。コマンドの形式が誤っている場合に出力します。
KFPS01295-I
Usage: pdlogcls -d sys|spd [-s server_name] -g file_group_name [-a] [-b]　　（Ｅ）
HiRDB/シングルサーバでのpdlogclsコマンドの使用方法を示します。コマンドの形式が誤っている場合に出力します。
KFPS01295-I
Usage: pdlogcls -d sys|spd -s server_name -g file_group_name [-a] [-b]　　（Ｅ）
HiRDB/パラレルサーバでのpdlogclsコマンドの使用方法を示します。コマンドの形式が誤っている場合に出力します。
KFPS01296-I
Usage: pdlogunld -d sys [-s server_name] -g file_group_name [-o output_file_name] [-n] [-f] [-k file_kind] [-i init_size [,expand_size]]　　（Ｅ）
HiRDB/シングルサーバでのpdlogunldコマンドの使用方法を示します。コマンドの形式が誤っている場合に出力します。
KFPS01296-I
Usage: pdlogunld -d sys -s server_name [-u unit_id] -g file_group_name [-o output_file_name][-n] [-f] [-k file_kind] [-i init_size [,expand_size]]　　（Ｅ）
HiRDB/パラレルサーバでのpdlogunldコマンドの使用方法を示します。コマンドの形式が誤っている場合に出力します。
KFPS01297-I
Usage: pdlogchg{-d sys [-s server_name] -g file_group_name [-R|-G] | -z log_point_information [-x host_name]}　　（Ｅ）
HiRDB/シングルサーバでのpdlogchgコマンドの使用方法を示します。コマンドの形式が誤っている場合に出力します。
(Ｓ)処理を終了します。
KFPS01297-I
Usage: pdlogchg {-d sys -s server_name [-u unit_id] -g file_group_name [-R|-G] | -z log_point_information [-x host_name]}　　（Ｅ）
HiRDB/パラレルサーバでのpdlogchgコマンドの使用方法を示します。コマンドの形式が誤っている場合に出力します。
(Ｓ)処理を終了します。
KFPS01299-I
Usage: pdlogatul -d sys [-s server_name] [-b|-t|-i]　　（Ｅ）
HiRDB/シングルサーバでのpdlogatulコマンドの使用方法を示します。コマンドの形式が誤っている場合に出力します。
(Ｓ)処理を続行します。
KFPS01299-I
Usage: pdlogatul -d sys -s server_name [-b|-t|-i]　　（Ｅ）
HiRDB/パラレルサーバでのpdlogatulコマンドの使用方法を示します。コマンドの形式が誤っている場合に出力します。
(Ｓ)処理を続行します。
KFPS01300-E
aa....aa error occurred, file=bb....bb　　（Ｅ＋Ｌ）
HiRDBファイルシステム領域に作成したアンロードログファイルに対する入出力エラーが発生しました。
aa....aa：エラーの内容
Close：ファイルのクローズ処理
Open：ファイルのオープン処理
Read：ファイルの読み込み処理
Write：ファイルの書き込み処理
bb....bb：エラーが発生したアンロードログファイル名
アンロードログファイルのパス名が151文字以上の場合は，アンロードログファイルのパス名の後ろから150文字を出力します。
(Ｓ)処理を終了します。
(Ｏ)このメッセージに続いて出力されるメッセージの対策に従ってください。エラーの原因を取り除いた後に，再度コマンドを実行してください。
KFPS01301-E
System call error, func=aa....aa, errno=bb...bb　　（Ｅ＋Ｌ）
HiRDBファイルシステム領域に作成したアンロードログファイルに対して，システムコールでエラーが発生しました。
aa....aa：エラーが発生したシステムコール名称
bb....bb：エラーが発生したシステムコールのerrno
(Ｓ)処理を終了します。
(Ｏ)エラー番号（errno：エラー状態を表す外部整数変数）をerrno.h及びOSのマニュアルを参照してエラーの原因を取り除いた後に，再度pdlogunldコマンドを実行してください。
KFPS01302-E
File I/O error occurred, reason=aa....aa, func=bb....bb, errno=cc....cc, (dd....dd)　　（Ｅ＋Ｌ）
HiRDBファイルシステム領域に作成したアンロードログファイルに対する入出力中にエラーが発生しました。
aa....aa：エラーの理由
File-format：指定したファイルの形式と実際のファイルの形式が異なります。
File-lock：指定したファイルはほかのユティリティで排他制御されているため，ファイルの読み書きができません。
Invalid-device：指定したファイルのエントリタイプが不正です。エントリタイプがシステムで識別できる場合は，英字１文字を括弧で囲んで表示します。この英字は，OSのls -lコマンドで出力されたモードのエントリと同じです。
Invalid-environment：unameシステムコールで得られる設定値に誤りがあるため，ストリーミングテープ装置が使用できません。OSが正しくインストールされているか，又はOSのバージョンがHiRDB及び関連製品の前提条件に合っているかどうかを確認してください。
Invalid-parameter：指定したパラメタの指定の組み合わせが不正です。
Invalid-path：アンロードログファイル名のパス名に誤りがあります。
Invalid-permission：指定したファイルのパーミッションが不正です。
No-file：読み込み用にオープンしようとしたファイルがありません。又は，書き込み中のファイルが消去されました。
No-space：書き込むファイルに十分な容量がありません。ファイル容量を見直してください。又は，増分時に増分回数が増分できる最大値を超えています。
Unmatch-entry：ヘッダがあるファイルに対して，ヘッダ中のエントリが制御情報ファイルの指定と一致しません。一致しないエントリ名称を括弧の中に表示します。
bb....bb：エラーが発生したシステム関数名
HiRDBファイルシステム領域でエラーが発生した場合はHiRDBファイルシステム領域の関数名を，それ以外の場合は***が表示されます。
cc....cc：システム関数が返却したエラー番号（errno）
HiRDBファイルシステム領域でエラーが発生した場合は，HiRDBファイルシステム領域のエラーコードが出力されます。エラーコードについては，「HiRDBファイルシステムに対するアクセス要求から返されるエラーコード」を参照してください。
それ以外の場合は０が出力されます。
dd....dd：障害を検知したソースファイル名と行番号
(Ｓ)処理を終了します。
(Ｏ)エラーの理由及びエラー番号を参照してエラーの原因を取り除いた後に，再度pdlogunldコマンドを実行してください。
KFPS01303-E
HiRDB file aa....aa error, errno=bb....bb, HiRDB file name=cc....cc　　（Ｅ＋Ｌ）
HiRDBファイルシステム領域に作成したアンロードログファイルに対するアクセスエラーが発生しました。
aa....aa：エラーの内容
close：ファイルのクローズ処理
create：ファイルの生成処理
expand：ファイルの拡張処理
fstat：ファイル情報の取得処理
opne：ファイルのオープン処理
read：ファイルの読み込み処理
write：ファイルの書き込み処理
bb....bb：エラーコード
エラーコードについては，「HiRDBファイルシステムに対するアクセス要求から返されるエラーコード」を参照してください。
cc....cc：エラーが発生したアンロードログファイル名
アンロードログファイルのパス名が151文字以上の場合は，アンロードログファイルのパス名の後ろから150文字を出力します。
(Ｓ)処理を終了します。
(Ｏ)エラーコードを参照してエラーの原因を取り除いた後に，再度コマンドを実行してください。
KFPS01380-I
Usage: pdlogucat [-k std|csv] unload_log_file_name　　（Ｅ）
pdlogucatコマンドの使用方法を表示します。コマンドの形式が誤っている場合に出力します。
(Ｓ)処理を終了します。
KFPS01800-I
Now starting HiRDB unit aaaa　　（Ｌ）
HiRDBのユニットを開始中です。
aaaa：ユニット識別子
(Ｓ)HiRDBシステムの開始処理を続行します。
KFPS01801-E
Unable to start HiRDB unit due to improper operational environment. reason code=aa....aa　　（Ｅ）
動作環境が整っていないため開始できません。
aa....aa：理由コード
(Ｓ)HiRDB開始処理を中断します。
[対策]次に示す対策をした後にHiRDBを開始してください。なお，ここで説明している以外の理由コードを出力した場合は保守員に連絡してください。
理由コード
原因
対策
ENV_PDDIR
環境変数PDDIRが設定されていません。又は，そのディレクトリを参照できません。
環境変数PDDIRを設定してください。
MEMORY
プロセス固有メモリ又は共用メモリが不足しています。
SHM_EINVAL，SHM_ENOMEM，SHM_ENOSPCの説明を参照してください。
PAUSE
HiRDBの処理を続行できないエラーが発生し，プロセスサービスを中断しています。
コマンド入力画面，及びsyslogfile（又はイベントログ）で，直前に出力されているメッセージを参照してください。
PROGRAM
前提製品がありません。
前提製品をインストールしてください。
RPL_FILE
HiRDB Datareplicatorとのデータ連動用連絡ファイルがないか，アクセス権限がないか，又は内容が不正です。
直前に出力されたKFPS01889-Eメッセージを参照して，HiRDB Datareplicatorのデータ連動用連絡ファイルの障害を回復してください。代表的なエラー要因と対策を次に示します。
・function value = SYSTEM CALL(stat) ERROR, error = 2の場合
データ連動用連絡ファイルがありません。データ連動用連絡ファイルのディスクマウントが外れている場合は，マウントを掛け直してからHiRDB DatareplicatorとHiRDBを再開始してください。データ連動用連結ファイルがない場合は，反映側のデータベースと同期をとった後にデータ連動用連絡ファイルを再作成し，HiRDB DatareplicatorとHiRDBを再度開始してください。
・function value = SYSTEM CALL(open) ERROR, error = 13の場合
データ連動用連絡ファイルへのアクセス権限がありません。データ連動用連絡ファイルへのアクセス権を確認し，アクセス権限がない場合はアクセス権限を設定してからHiRDB DatareplicatorとHiRDBを再開始してください。
・function value = FILE ERRORの場合
データ連動用連絡ファイルが不正です。反映側DBと同期をとった後にデータ連動用連絡ファイルを再作成し，HiRDB DatareplicatorとHiRDBを再度開始してください。
RPL_INSTALL
次に示す要因が考えられます。
・HiRDB Datareplicatorをインストールしているディスクに障害が発生しているなど，HiRDB Datareplicatorのインストールディレクトリが参照できない障害が発生しています。
・HiRDBのアドレッシングモードとHiRDB Datareplicatorのアドレスモードが異なっています。
・HiRDB Datareplicatorがインストールされていません。
次に示す項目について確認し対策してください。
・メッセージを出力したユニットがあるサーバマシンで，HiRDB Datareplicatorをインストールしているディスクに障害が発生しているなど，HiRDB Datareplicatorのインストールディレクトリが参照できない障害が発生していないか確認してください。障害がある場合は，原因を取り除いて再度実行してください。
・メッセージを出力したユニットのアドレッシングモードとHiRDB Datareplicator のアドレスモードが同じか確認してください。HiRDBのアドレッシングモードとHiRDB Datareplicator のアドレスモードが異なる場合，HiRDBのアドレッシングモードと同じアドレスモードのHiRDB Datareplicatorに入れ替えて再実行してください。
・メッセージを出力したユニットがあるサーバマシンにHiRDB Datareplicatorがインストールされているか確認してください。インストールされていない場合は，HiRDB Datareplicator をインストールして再実行してください。
RPL_STOP
HiRDB DatareplicatorがHiRDBとのデータ連動を中止しています。
データ連動が中止した原因を調査して問題を取り除いてください。その後，HiRDB Datareplicatorを開始してください。調査方法については，マニュアル「HiRDBデータ連動機能 HiRDB Datareplicator Version 7」を参照してください。
SETUP
システムがセットアップされていません。Windows NT版の場合はHiRDBサービスが停止しています。
HiRDBサーバがUNIX版の場合は，pdsetupコマンドでHiRDBをセットアップしてください。
HiRDBサーバがWindows NT版の場合は，HiRDBサービスが開始されていない可能性があります。サービスを開始してから再度HiRDBを開始してください。
SHM_EINTR
共用メモリの確保処理を実行中にシグナルを受けました。
シグナル発生要因を調査し対策した後に，再度HiRDBを開始してください。
SHM_EINVAL
共用メモリサイズがシステムの上限値を超えました。HiRDBサーバがWindows NT版の場合，インストールドライブの容量不足によって，共用メモリ用の作業ファイルが確保できません。
システムの共用メモリのセグメント最大サイズを大きくして，カーネルを再度作成してください。HiRDBサーバがWindows NT版の場合，HiRDBのインストールドライブに，共用メモリサイズ以上の空き容量を確保してください。
SHM_EMFILE
オープンしているファイル数がシステムでオープンできるファイルテーブル数を超えました。
オープンしているファイル数を減らしてください。又は，オープンできるファイルテーブル数を増して，カーネルを再度作成してください。
SHM_ENOMEM
共用メモリサイズに相当するメモリがシステム上にありません。
システムの実メモリを増やしてください。
SHM_ENOSPC
UNIX版の場合
共用メモリ識別子の数がシステムで定義されている最大値を超えました。
Windows NT版の場合
インストールドライブに,共用メモリを確保するだけのディスク容量がありません。
UNIX版の場合
共用メモリ面数を減らしてください。又は，共用メモリ識別子の最大数を大きくして，カーネルを再度作成してください。
Windows NT版の場合
このメッセージ出力以前にKFPO00113-Eメッセージが出力されます。KFPO00113-Eメッセージの説明文を参照して対策してください。
SHM_EOVER
共用メモリサイズが２ギガバイトを超えました。詳細コードを次に示します。
・lck：ロックサーバ
・trn：トランザクション制御
・表示なし：ユニットコントローラ
詳細コードごとに次の処置をして，ユニットコントローラ用共用メモリサイズが2ギガバイト以内になるようにしてください。
・lckの場合
pd_max_access_tables，pd_max_users，pd_max_bes_process，pd_max_dic_process，pd_lck_hash_entry，pd_lck_pool_size，pd_fes_lck_pool_size，又はpd_max_open_holdable_cursorsオペランドの値を小さくしてください。
・trnの場合
pd_max_users，pd_max_bes_process，又はpd_max_dic_processオペランドの値を小さくしてください。又は，フロントエンドサーバ数，バックエンドサーバ数の数を減らしてください。
SHM_CALC ＊＊＊
共用メモリサイズの算出中に内部矛盾が発生しました。＊＊＊はHiRDBの内部情報です。
$PDDIR/spool下のファイル，及びsyslogfileを取得して保守員に連絡してください。
VERSION
OSのバージョンが異なっています。
正しいバージョンのOSと入れ替えてください。
AHA_INSTALL
HiRDB Advanced High Availabilityがセットアップされていません。
スタンバイレス型系切り替え機能を使用する場合はHiRDB Advanced High Availabilityが必要になります。HiRDB Advanced High Availabilityを導入するか，又はpd_ha_agentオペランドを削除してください。
AHA_VR
システム定義に影響分散スタンバイレス型系切り替え機能の使用を指定していますが，メッセージを出力したユニットを配置したサーバマシンに現在セットアップされているHiRDB Advanced High Availabilityのバージョンが不正です。
次に示すどちらかの処置をしてください。
・KFPS05620-Iメッセージを参照して，セットアップ済みのHiRDB Advanced High Availabilityのバージョンを確認してください。バージョンが不正な場合は，正しいバージョンのHiRDB Advanced High Availabilityをセットアップし，再実行してください。
・影響分散スタンバイレス型系切り替え機能の使用を見直してください。
NONALTSVUNIT
代替BESユニット以外では実行できません。
代替BESユニットで実行してください。
NRF_INSTALL
回復不要FESの設定がされています（pdstartオペランドに-k stlsオプションを指定しているフロントエンドサーバがあります）が，メッセージを出力したユニットのサーバマシンにHiRDB Non Recover FESがセットアップされていません。
回復不要FESを設定する場合はHiRDB Non Recover FESが必要になります。HiRDB Non Recover FESを導入するか，又はpdstartオペランドの-k stlsオプションを削除してください。
注
理由コードがRPL_STOP及びRPL_FILEの場合，このメッセージの前にサーバ名を表示するKFPS04624-Iメッセージを，障害が起きたサーバ数分表示します。
KFPS01802-E
Unable to start HiRDB unit because another HiRDB with the same ID operating　　（Ｅ）
同じHiRDB識別子のHiRDBが動作中のため，開始できません。
(Ｓ)HiRDBの開始処理を中断します。
(Ｐ)動作中のHiRDBの終了を待って，再度開始してください。又は，HiRDB識別子を変更して，再度開始してください。
KFPS01803-I
HiRDB unit aaaa start mode determined. start mode:bb....bb　　（Ｌ）
ユニットの開始モードを決定しました。
aaaa：ユニット識別子
bb....bb：開始モード
R：再開始
R(P)：計画停止後の再開始
S：正常開始
(Ｓ)処理を続行します。
KFPS01812-E
Error occurred while starting server aa....aa. reason code=bb....bb　　（Ｅ＋Ｌ）
サーバaa....aa開始中にエラーが発生しました。
aa....aa：エラーの発生したサーバ名
bb....bb：エラーの要因を示します。
COMMUNICATION：プロセス間の通信エラーが発生しました。
CONFIGURATION：定義解析中にエラーが発生しました。
EXIST：同一サーバ名，又は同一サービスグループ名のサーバが既に動作しています。
FORK FAILED：サーバの起動失敗
LOCK：排他処理に失敗しました。
MAX PROCESSES：最大プロセス数の指定値を超えました。
MEMORY：メモリが不足しました。
NO RPC ENVIRONMENT：RPC環境が開始されていません。
NO SCHEDULER：スケジューラが終了処理中，又は停止しています。
NO SERVER：サーバが正常終了，又は異常終了しました。
NO SERVICE PRODUCER：プロセスサービス機能が開始されていません。
PRC ERROR：プロセスサービス機能でエラーが発生しました。
SCD NOT UP：スケジューラサービス機能が開始されていません。
SERVER DOWN：サーバが異常終了しました。
SHARED MEMORY：共用メモリが確保できません。
STOPPING NOW：サーバが終了処理中です。
VERSION INVALID：バージョンが不正です。
(Ｓ)HiRDBの処理を続行します。ただし，HiRDBの開始中など，これ以上HiRDBが稼働できない場合にはHiRDBを終了します。
[対策]エラー要因を取り除いた後，再度サーバを開始してください。
CONFIGURATION：定義を調べてください。
COMMUNICATION：ネットワーク障害要因を調べてください。
FORK FAILED：メモリ量，プロセス数を調べてください。
MAX PROCESSES：システム共通定義の最大同時起動サーバプロセス数を調べてください。
MEMORY：実メモリサイズ，又はスワップエリアサイズを調べてください。Windows NTの場合，Windows NTの実メモリサイズ，又は仮想メモリサイズを調べてください。
NO RPC ENVIRONMENT：pd_rpc_open（）が発行されているか調べてください。
NO SERVER：サーバが異常終了した場合，要因を調べてください。
PRC ERROR：COMMUNICATION，VERSION INVALIDの処置と同じ対処をしてください。
SERVER DOWN：サーバが異常終了する要因を調べてください。
SHERED MEMORY：この現象の発生前後に，OSのsyslog（WindowsNTの場合はイベントログ）に出力されているメッセージの内容に従って対処してください。繰り返し発生する場合は保守員に連絡してください。
VERSION INVALID：ライブラリとデーモンのバージョンを調べてください。
KFPS01813-I
Server aa....aa started[ on unit bbbb]　　（Ｌ）
サーバaa....aaがユニットbbbbでオンライン状態になりました。なお，on unit bbbbは，影響分散スタンバイレス型系切り替えを適用しているユニットでサーバを起動した場合に出力します。
aa....aa：起動が完了したサーバ名
bbbb：サーバ起動先ユニットのユニット識別子
(Ｓ)HiRDBの処理を続行します。
KFPS01814-I
HiRDB unit aaaa previous operation not terminate normally； perform normal start　　（Ｌ）
HiRDBを正常開始しようとしましたが，前回のHiRDBの終了状態が正常終了ではありません。
aaaa：ユニット識別子
(Ｓ)強制的に正常開始します。
KFPS01815-E
Error occurred in OS while executing aa....aa. function value=bb....bb, errno=cc....cc　　（Ｅ）
OSのシステム関数でエラーが発生しました。
aa....aa：異常終了したシステムコール，又はサブルーチン名
bb....bb：異常終了したシステムコール，又はサブルーチンの関数値
cc....cc：異常終了したときのerrnoの値
(Ｓ)処理を中止します。
[対策]errnoの値を調査し，errno.h又はユーザが使用するOSのマニュアルを参照し，エラーの原因を取り除いてください。
なお，代表的なerrorについては，「システムコールのリターンコード」を参照してください。
KFPS01818-E
Stops activating server aa....aa because the server not in halt state　　（Ｅ）
停止していないサーバを指定しているため，サーバの起動を中止します。
aa....aa：停止していないサーバ名
(Ｓ)サーバ起動処理を中止します。
(Ｏ)起動するサーバ名を見直してください。
KFPS01819-I
Server aa....aa failed information. process ID=bb....bb, C-PID=cc....cc(dd....dd), TIME=eeffgg, PROGRAM=hh....hh　　（Ｌ）
サーバプロセス停止に関する補足情報を示します。
クライアントと接続されていない場合，又はHiRDBが使用する内部的なサーバの場合は，このメッセージは出力しません。
aa....aa：停止したサーバ名
bb....bb：停止したサーバのプロセスID
cc....cc：接続していたクライアント（UAP又はユティリティ）のプロセスID。ただし，クライアントと接続していたサーバプロセスだけ有効です。
dd....dd：接続していたクライアント（UAP又はユティリティ）のIPアドレス。ただし，クライアントと接続していたサーバプロセスだけ有効です。
eeffgg：サービス要求受付時刻（時分秒）。ただし，クライアントと接続していないサーバプロセスの場合は，999999を表示します。
hh....hh：UAPの識別情報。クライアント環境定義のPDCLTAPNAMEに指定したUAPの識別名称を表示します。PDCLTAPNAMEが設定されていない場合は，"Unknown"を表示します。ユティリティの場合は，ユティリティのコマンド名を表示します。ただし，ユティリティサーバプロセス上で動作していた場合や，障害発生によってUAP識別情報が取得できなかった場合などは，空白を表示することがあります。
(Ｓ)処理を続行します。
(Ｏ)HiRDB管理者の指示に従ってください。
[対策]このメッセージ以前に表示された障害メッセージの原因調査のために，必要に応じて使用してください。
KFPS01820-E
Server aa....aa failed. process ID=bb....bb, service group name=cc....cc, run mode=dd....dd, critical state=e,critical mask=ff....ff, end state=gg....gg, server type=hhh　　（Ｅ＋Ｌ）
サーバaa....aaが停止しました。次の状態を検出しています。
gg....ggの値
説明
007f
0009
サーバプロセスの強制終了要求を受け付けました。pdcancelコマンドを実行した場合には，このメッセージが出力されます。このメッセージの前後に出力されているメッセージなどから，プロセスが強制停止要求を受けた原因（pdcancelコマンドの実行を含む）を調査し，必要に応じて対処してください。ただし，UAPやユティリティ実行中に関連プロセスや関連プロセスの存在するユニットが異常終了すると，ほかのメッセージを出力しないで，このメッセージを出力することがあります。
0003
0083
サーバプロセスの強制終了要求を受け付けました。実行したトランザクションの状態，このメッセージの前後に出力されているメッセージなどから，プロセスが強制停止要求を受けた原因を調査し，必要に応じて対処してください。
0006
0086
0100
0800
処理中に異常を検知したため，異常終了しました。このメッセージの前後に出力されているメッセージなどから，異常終了した原因を調査し，必要に応じて対処してください。
8000
メモリ不足によって，プロセスの起動失敗，又はプロセスが異常終了しました。次のどれかの方法で対策してください。
・同一サーバマシン内で稼働しているほかのプロセスの数を減らしてください。
・スワップ領域を増やしてください。
・実メモリを増設してください。
・Windows NT版の場合，デスクトップヒープ指定値を見直してください。デスクトップヒープ指定値については，マニュアル「HiRDB Version 7 システム導入・設計ガイド」を参照してください。
c000
connectシステムコールを発行しましたが，接続先がダウンしているか，又はネットワーク障害によって接続できませんでした。
c100
2回目以降のSQLの応答送信時に送信先がダウンしているか，又はネットワーク障害によって送信できませんでした。
c200
HiRDBクライアント側に制御があって，トランザクション中にHiRDBクライアント環境定義PDSWAITTIMEのタイムアウトを検知しました。
c300
通信処理中に通信相手に異常が発生し相手通信ソケットがクローズされました。
c400
クライアント側に制御があって，トランザクション中でない場合に，クライアント環境定義PDSWATCHTIMEのタイムアウトを検出しました。又は，Windows版HiRDBクライアントの接続中にHiRDBシステムで設定しているpd_watch_pc_client_timeのタイムアウトを検出しました。
c500
サーバ起動時に，スペシャルファイル（FIFO）が取得できませんでした。
c600
HiRDBで同時に処理できるトランザクション数の上限を超えました。ロールバックが多発していることが考えられるため，ロールバックの完了を待ってUAPを再度実行してください。
c700
HiRDBサーバでSQL実行中にSQL要求元のクライアントの異常終了を検知しました。
c800
該当するサーバとシステムマネジャとの間でネットワーク障害が発生していたため，SQLの要求送信に失敗しました。
c900
2回目以降のSQLの要求受信時に，送信元とシステムマネジャとの間でネットワーク障害が発生していたため，SQLの要求受信に失敗しました。
d000
トランザクション処理中に親プロセスが強制終了したため，子プロセスを強制終了させました。
d100
UAPの処理が，クライアント環境定義PDSWAITTIME及びPDSWATCHTIMEで設定した監視時間内に終了しないため，サーバの処理を中断しました。又は，pdcancelコマンドが実行されたため，関連するサーバの処理を中断しました。
d200
OLTP環境下のUAPで，同時に処理できるトランザクション数の上限を超えました。ロールバックが多発していることが考えられるため，ロールバックの完了を待ってUAPを再度実行してください。
d300
異常を検知したが，pd_dump_suppress_watch_timeオペランドの指定が有効なため，トラブルシュート情報を出力しないで終了しました。
d500
トランザクションの決着処理中にエラーが発生しました。
000f
ff00
HiRDBのサーバプロセスをOSのkillコマンド（Windows NTの場合，pdkillコマンド）で強制停止しました。
008b
HiRDBの稼働中にOSのスタックオーバーフローが発生した可能性があります。スタックオーバフローが発生する原因と対策を次に示します。
原因1
次に示す原因が考えられます。
・呼び出しを多数行ったり，無限に繰り返したりするユーザ定義ルーチンを実行した
・ユーザ定義データ型のネストや，継承が多いユーザ定義データ型で定義した列をSQL文中に指定した
・IF文，WHILE文，又はスカラ関数のネストが多い
原因1の対策
・前記のSQLの原因を見直して，可能であれば対策してください。
・カーネルパラメタmaxssizの値を見直して，スタックサイズを増やしてください。
原因2
OSのメモリ不足が発生したため，スタック拡張に失敗しました。
原因2の対策
不要なプログラムを終了してメモリの空き容量を増やしてください。
aa....aa：停止したサーバ名
bb....bb：停止したサーバのプロセスID
cc....cc：停止したサーバのサービスグループ名
dd....dd：停止直前のサーバの走行モード
PDBSV：HiRDBサーバ
PDBSYS：HiRDB処理中
e：
N：クリティカル状態ではありません
Y：クリティカル状態です
ff....ff：クリティカル情報
gg....gg：wait(2)で返されるプロセス終了状態（HiRDBのコマンドの場合は，****を表示します）。
hhh：サーバ種別（HiRDBサーバ以外のときは，***を表示します）
(Ｓ)エラーの起きたサーバの処理を終了してから，必要であれば，サーバを再度起動します。
[対策]
gg....ggがc800の場合：
該当するサーバのユニットのステータス情報がSTOP(A)になっているか，pdlsコマンドで確認してください。ステータス情報がSTOP(A)になっている場合，ユニットとシステムマネジャの間のネットワークに障害が発生している場合があります。ユニットをpdstop -zコマンドで停止した後，ネットワーク障害の原因を調査して対策してください。対策後にユニットを再度開始してください。
gg....ggがc900の場合：
送信元に，gg....ggが"c800"となっているKFPS01820-Eメッセージが表示されているか，確認してください。表示されている場合，送信元の停止要因を調査し，対策してください。
上記以外の場合：
このメッセージの前に出力されたメッセージ，又はトラブルシュート情報（ダンプ，トレースなど）に従って，サーバの停止要因を調査し，対策してください。その後，必要であれば，サーバを再度起動してください。なお，gg....ggがc000，c100，c200，c300，c400，c500，c600，c700，c800，c900，d000，d100，d200，d300，及びd500の場合は，トラブルシュート情報は出力されません。
KFPS01821-E
Unable to continue HiRDB unit processing because serious error occurred；stops HiRDB unit aaaa　　（Ｅ＋Ｌ）
HiRDBの処理を続行できないエラーが発生したため，HiRDBを停止します。
aaaa：ユニット識別子
(Ｓ)HiRDBを停止した後，必要な場合は再度HiRDBシステムを開始します。
(Ｏ)このメッセージの前に出力されているメッセージに従って，エラー要因を取り除いてください。必要がある場合は再度HiRDBを開始してください。
KFPS01823-E
System version invalid； stops unit startup　　（Ｅ＋Ｌ）
システムのバージョンが不正です。このため，ユニットを停止します。
(Ｓ)ユニット開始処理を中断します。
[対策]ライブラリとサーバのバージョンを調査して，再開始してください。
KFPS01824-E
HiRDB ID invalid； stops unit startup　　（Ｅ＋Ｌ）
不正なHiRDB識別子が，定義に指定されています。又は，HiRDB識別子が指定されていません。
(Ｓ)ユニットの再開始処理を中断します。
(Ｏ)正しいHiRDB識別子を指定して，再度HiRDBを開始してください。
KFPS01826-I
HiRDB dir = aa....aaHiRDB vrs = bb....bbunit run ID = cc....ccHiRDB ID = ddddunit ID = eeee　　（Ｌ）
ユニットを正常開始するときの環境を表示します。ただし，ユニットの再開始の場合，前回の環境を表示します。
aa....aa：HiRDB運用ディレクトリ名
bb....bb：HiRDBのバージョン
・HiRDBが64ビットモードの場合，バージョンに続いて（64）を表示します。
・POSIXライブラリ版を使用している場合，バージョンに続いて（POSIX）を表示します。
（例）バージョン07-00，POSIXライブラリ版，64ビットモードのHiRDBの場合
'07-00(64)(POSIX)'
cc....cc：ユニットのランID
pdstart　-rコマンドで開始した場合，00....00となります。
dddd：HiRDB識別子
eeee：ユニット識別子
(Ｓ)処理を続行します。
(Ｏ)実行環境を確認してください。
KFPS01827-E
Unit ID invalid； stops unit startup　　（Ｅ）
不正なユニット識別子が定義に指定されています。又は，ユニット識別子が指定されていません。
(Ｓ)ユニットの開始処理を中断します。
(Ｏ)ユニット制御情報定義に正しいユニット識別子を指定して，再度HiRDBを開始してください。
KFPS01828-E
System definition parameter aa....aa missing； stops unit startup　　（Ｅ）
HiRDBシステム定義に必要なオペランドがありません。
aa....aa：HiRDBシステム定義に必要なオペランド名称
(Ｓ)異常終了します。
[対策]必要なオペランドを追加して，再度HiRDBを実行してください。
KFPS01829-E
aa....aa invalid； stops unit startup　　（Ｅ）
ユニットの再開始処理で，aa....aaの内容が正常開始時と一致していません。
aa....aa：エラーの要因
HiRDB dir：HiRDB運用ディレクトリ
HiRDB ID：HiRDB識別子
Master file name：マスタディレクトリ用RDエリアの先頭のHiRDBファイル名
System Version：システムのバージョン
Unit ID：ユニット識別子
Server Number：サーバ数
Utility exec mode：ユティリティ実行モード
(Ｓ)異常終了します。
[対策]要因で示す事項を修正して，再度HiRDBを再開始してください。
System Version：HiRDBのバージョン
HiRDB ID：システム共通定義のpd_system_idオペランド
HiRDB dir：システム共通定義のpdunitオペランドの-dオプション
Unit ID：ユニット制御情報定義のpd_unit_idオペランド
Master file name：システム共通定義のpd_master_file_nameオペランド
Server Number：システム共通定義のpdstartオペランドの指定個数，又はシステム共通定義のpd_mlg_msg_log_unitのオペランド
Utility exec mode：システム共通定義のpd_utl_exec_modeオペランド
KFPS01830-I
Server aa....aa recovery process start　　（Ｌ）
HiRDBサーバの再開始で，回復処理を開始します。
aa....aa：サーバ名
(Ｓ)処理を続行します。
KFPS01831-I
Server aa....aa recovery process end　　（Ｌ）
HiRDBサーバの再開始で，回復処理が終了しました。
aa....aa：サーバ名
(Ｓ)処理を続行します。
KFPS01832-I
Data replication restart. unit ID=aa....aa, reason code=bb....bb 　　（Ｅ＋Ｌ）
HiRDB Datareplicator連携を再開始しました。
aa....aa：ユニット識別子
bb....bb：HiRDB Datareplicator連携を再開始した理由
FORCE：前回稼働時にHiRDB Datareplicatorと連携していたのに，HiRDBをpdstart -iコマンドで開始しました。
STATUS：HiRDB Datareplicatorのデータ連動用連絡ファイルの初期化，障害，又はHiRDBのシステムステータスファイルの初期化，又は障害が発生しました。
(Ｓ)HiRDB Datareplicator連携をいったん停止した後，再開始します。
[対策]必要であれば，HiRDB Datareplicatorのデータ連動用連絡ファイルの初期化及び反映側のデータベースを再作成してください。
KFPS01833-I
Unable to continue data replication. unit ID=aaaa, reason code=bb....bb 　　（Ｅ＋Ｌ）
HiRDB Datareplicator連携を続けることができません。
aaaa：ユニット識別子
bb....bb：データ連動を続けられない理由
DEFINITION：
前回HiRDB Datareplicator連携をしていたが，システム共通定義のpd_rpl_init_startオペランドに'N'を指定
RPL_FILE：HiRDB Datareplicatorのデータ連動用連絡ファイルの障害
RPL_STATUS：
HiRDB Datareplicatorのデータ連動用連絡ファイルの初期化
(Ｓ)データ連動をいったん停止した後，HiRDBの開始処理を続行します。
[対策]HiRDB Datareplicator連携を再度実行する場合は，障害の要因を取り除いたうえで，反映側のHiRDBと同期をとった後で，pdrplstartコマンドでHiRDB Datareplicator連携を再開始してください。
また，HiRDBを停止する運用があって，かつ常にHiRDB Datareplicator連携をしたい場合は，システム共通定義のpd_rpl_init_startオペランドに'Y'を指定してください。
理由コードがRPL_STATUS及びRPL_FILEの場合，このメッセージの前にサーバ名を表示するKFPS04624-Iメッセージを，障害が起きたサーバ数分表示します。
KFPS01834-E
Error occurred in status file while data replication.unit ID=aaaa, reason code=bb....bb　　（Ｅ＋Ｌ）
HiRDB Datareplicator連携機能を使用しているときに，ステータスファイルで障害を検知しました。
aaaa：ユニット識別子
bb....bb：理由コード
COMMUNICATION：プロセス間通信エラーです
SERVER NOT UP：ステータスサービスが起動していません
I/O ERROR：入出力エラーです
OTHER：そのほかのエラーです
(Ｓ)HiRDBを停止します。
[対策]このメッセージの前に出力されているメッセージに従って，エラー原因を取り除いてください。
KFPS01835-E
Error found in system configuration for fall-back operation. reason code=aa....aa　　（Ｅ＋Ｌ）
縮退起動に関するシステム定義の記述に誤りがあります。
aa....aa：理由コード
UNIT ID ERRORユニット識別子：
pd_start_skip_unitオペランドに記述したユニット識別子がシステム構成の中に含まれていません。
DUPLICATE UNITID
pd_start_skip_unitオペランドで同一ユニット識別子を複数記述できません。
MGR UNIT NOT SKIPPED：
pd_start_skip_unitオペランドでシステムマネジャのあるユニットは指定できません。
DIC UNIT NOT SKIPPED：
pd_start_skip_unitオペランドでディクショナリサーバのあるユニットは指定できません。
NECESSARY ONE FES FOR FALL-BACK：
縮退起動時はフロントエンドサーバが一つ以上稼働している必要があります。
NECESSARY ONE BES FOR FALL-BACK：
縮退起動時はバックエンドサーバが一つ以上稼働している必要があります。
(Ｓ)処理を終了します。
[対策]pd_start_level及びpd_start_skip_unitオペランドの指定を見直した後，HiRDBを再開始してください。
KFPS01836-W
Fall-back operation ignored, because of restarting with "pdstart -i"　　（Ｅ＋Ｌ）
HiRDBサーバを縮退起動するとき，pdstartコマンドに-iオプションは指定できません。縮退起動をしません。
(Ｓ)処理を続行します。
[対策]HiRDBシステムを縮退起動する場合，pdstartコマンドのオプションには何も指定しないか，-rオプション又はdbdestroyオプションを指定してください。
KFPS01837-I
Unit startup skipping for fall-back operation. unit ID=aa....aa　　（Ｅ＋Ｌ）
ユニット識別子が示すHiRDBユニットを起動対象外として，HiRDBシステムを縮退起動します。
aa....aa：ユニット識別子
(Ｓ)処理を続行します。
KFPS01838-W
Fall-back operation ignored, because no startup skip HiRDB unit　　（Ｅ＋Ｌ）
このシステム構成では，起動対象外にできるユニットがありません。縮退起動モードを無視します。
(Ｓ)処理を続行します。
[対策]システム共通定義のpd_start_levelオペランドを０(縮退起動を適用しない)に変更してください。HiRDBシステムを縮退起動したい場合は，フロントエンドサーバ，バックエンドサーバを複数のユニットに配置するなどHiRDBが縮退起動できるシステム構成に変更してください。
KFPS01840-I
Now terminating HiRDB unit aaaa　　（Ｌ）
HiRDBの終了中です。
aaaa：ユニット識別子
(Ｓ)HiRDBの処理を続行します。
KFPS01841-I
HiRDB unit aaaa terminated. mode=bb....bb　　（Ｓ）
HiRDBのユニットaaaaが終了しました。終了モードはbb....bbです。
aaaa：ユニット識別子
bb....bb：終了モード
NORMAL：正常終了
PLAN：計画停止
FORCE：強制終了
(Ｓ)HiRDBの処理を続行します。
KFPS01842-I
Now terminating server aa....aa　　（Ｌ）
サーバの終了処理中です。
aa....aa：終了処理中のサーバ名
(Ｓ)HiRDBの処理を続行します。
KFPS01843-I
Server aa....aa terminated　　（Ｓ）
サーバが停止しました。
aa....aa：停止したサーバ名
(Ｓ)HiRDBの処理を続行します。
KFPS01844-E
Error occurred while terminating server aa....aa. reason code=bb....bb　　（Ｅ＋Ｌ）
サーバの終了処理に失敗しました。サーバを終了できなかったか，又は終了処理中にサーバが異常終了しました。
aa....aa：エラーの発生したサーバ名
bb....bb：エラーの要因を示します。
ABNORMAL：pdstopコマンドでHiRDBを終了させようとしましたが，正常終了していないサーバがあります。
ABORT：サーバが異常終了（pdstop）しました。
ABORTING：サーバの異常終了処理中（pdstop　-s）です。
COMMUNICATION：プロセス間の通信エラーが発生しました。
CRITICAL：クリティカル状態のため強制停止を保留します。
EXIT：停止中（サーバがありません），又は終了処理中です。
MEMORY：メモリが不足しました。
PROTOCOL：pd_rpc_mainloopを発行できません。
STARTING：サーバが起動処理中です。
(Ｓ)HiRDBの処理を続行します。
(Ｏ)終了していないサーバの有無を確認してください。終了していないサーバがある場合は，エラーの要因を取り除いた後，再度サーバを終了してください。前回終了の状態によって，強制終了（pdstop　-s　-f，又はpdstop　-f）しか受け付けない場合があります。
KFPS01845-E
Commands unable to enter because HiRDB inactive　　（Ｅ＋Ｌ）
HiRDBの停止中のため，コマンドの入力はできません。
(Ｓ)コマンドを終了します。
KFPS01846-E
Unable to terminate the unit normally； some servers forced to terminate　　（Ｅ＋Ｌ）
強制終了で停止したサーバがあります。このため，システムを正常終了できません。
(Ｓ)コマンドを終了します。
(Ｏ)KFPS01844-Eの"ABNORMAL"で出力されたサーバを再度起動し，正常終了させてください。又は，システムを強制終了してください。
KFPS01847-E
Unable to terminate the unit； some servers being started or terminated　　（Ｅ＋Ｌ）
開始処理中又は終了処理中のサーバがあります。このため，システムの終了ができません。
(Ｓ)コマンドを終了します。
(Ｏ)サーバの開始処理又は終了処理が終わるまで待ってください。又は，"pdstop　-f"コマンドを入力してください。
KFPS01849-W
Now waiting for termination of server aa....aa　　（Ｌ＋Ｓ）
サーバの終了を待ち合わせます。
aa....aa：終了を待ち合わせるサーバ名
(Ｓ)表示したサーバが終了するまで，システムの終了を待ちます。
(Ｏ)表示したサーバを終了させてください。
KFPS01850-I
HiRDB system terminated. mode=aa....aa　　（Ｓ）
HiRDBが終了しました。終了モードはaa....aaです。
aa....aa：終了モード
NORMAL：正常終了
PLAN：計画停止
FORCE：強制終了
(Ｓ)処理を続行します。
KFPS01851-E
Server aa....aa initialization error occurred； return code=bb....bb　　（Ｅ＋Ｌ）
サーバの初期化でエラーが発生しました。
aa....aa：HiRDB/シングルサーバ，又はHiRDB/パラレルサーバ（フロントエンドサーバ）のサーバ名
bb....bb：エラーコード
(Ｓ)HiRDB/シングルサーバの場合は，異常終了します。また，フロントエンドサーバの場合には，pdlsコマンドで表示される状態をSUSPENDにします。
[対策]HiRDB/シングルサーバの場合は，再度pdstartコマンドを実行してください。HiRDB/パラレルサーバの場合は，pdstart -aを実行してください。
KFPS01853-W
Hostname=aa....aa,unable to execute cc....cc command,unit state not bb....bb　　（Ｅ）
ホスト名称aa....aaのユニットの状態がbb....bbではありません。このため，コマンドが実行できません。
aa....aa：コマンドが実行できなかったホスト名
bb....bb：コマンド入力できるステータスを示します。
OFFLINE：オフライン中
ONLINE ：オンライン中
cc....cc：入力したコマンド名を示します。
(Ｓ)コマンドを終了します。
(Ｏ)システム又はユニットのステータスが表示された状態になるのを待って，再度コマンドを入力してください。ただし，開始（開始処理中を含む）状態でのpdstartコマンド，及び停止（終了処理中を含む）状態でのpdstopコマンドは，実行できません。この場合，停止又は開始したことを確認してから，コマンドを入力してください。
KFPS01854-E
Unable to start standby,online unit notup.　　（Ｅ＋Ｌ）
高速系切り替え機能で待機系を起動したときに実行系ユニットが起動していませんでした。
(Ｓ)HiRDBを異常終了します。
[対策]実行系ユニットが正常に起動しているか確認してください。実行系ユニットが正常に起動すると，pdlsコマンドの実行結果でSTATUSがACTIVEと表示されるか，又はKFPS05210-I及びKFPS05110-Iメッセージが出力されます。
Hitachi HA Toolkit Extensionを使用している場合は，Hitachi HA Toolkit Extensionのサービスプロセスが起動しているか確認してください。サービスプロセスを起動しないで実行系ユニットを起動した場合，両系とも待機系として起動します。サービスプロセスの起動方法については，マニュアル「Hitachi HA Toolkit」を参照してください。
KFPS01855-E
Unable to stop alternate server or original server aa....aa　　（Ｅ＋Ｌ）
スタンバイレス型系切り替え機能では，代替BES及び正規BESを単独終了できません。
aa....aa：代替BES又は正規BES名
(Ｓ)処理を終了します。
[対策]代替BES又は正規BESを停止する場合は，代替BESユニット又は正規BESユニットを終了してください。
KFPS01856-E
Unable to stop server aa....aa by force ,server not bb....bb　　（Ｅ＋Ｌ）
サーバ名aa....aaがbb....bbでないため，強制停止できません。
aa....aa：サーバ名
bb....bb：エラーの要因
IN HAGROUP：影響分散スタンバイレス型系切り替え機能の対象
ONLINE：オンライン中
(Ｓ)処理を終了します。
[対策]エラーの要因に従って対策してください。
・エラーの要因がIN HAGROUPの場合
影響分散スタンバイレス型系切り替え機能を適用していないサーバは，強制停止できません。コマンドのオプション指定を見直してください。サーバを停止したい場合は，正常終了（pdstop -s コマンドを実行）してください。
・エラーの要因がONLINEの場合
サーバが既に停止している可能性があります。pdlsコマンドを実行してサーバの稼働状態を確認してください。
KFPS01860-E
Command format aa....aa invalid　　（Ｅ）
コマンドが誤っています。
aa....aa：該当するコマンドの形式
pdstop　〔-f〕：システムの終了コマンド
pdstop　〔-f〕　-s　server_name：サーバの終了コマンド
pdstart：システムの開始コマンド
pdstart　-s　server_name：サーバの開始コマンド
(Ｓ)コマンドを終了します。
(Ｏ)コマンドを再度入力してください。
KFPS01861-E
Error occurred during command execution. reason code=aa....aa　　（Ｅ＋Ｌ）
コマンドでエラーが発生しました。
aa....aa：コマンドで発生したエラーを示します。
COMMUNICATION：プロセス間の通信エラーが発生しました。
DEFINE FILE：定義ファイルにエラーが発生しました。
INITIALIZING：pdstartによる開始処理中のため，コマンドを受け付けられません。HiRDBの開始が完了するのを待って，再度コマンドを入力してください。
MEMORY：メモリが不足しました。
PARAM：引数が正しくありません。
RPL STATUS：HiRDB Datareplicator連携の開始又は終了処理に失敗しました。
SERVER NAME LEN：サーバ名の長さが正しくありません。
SHARED MEMORY：共用メモリのアクセスに失敗しました。
STATUS：サーバの追加，及び削除に失敗しました。
TIMEOUT：時間内にシステムの初期化処理が終了しませんでした。
UTILITY：ユティリティ実行中のため，コマンドを受け付けられません。ユティリティが終了するのを待って，再度コマンドを実行してください。
(Ｓ)コマンドを終了します。
(Ｏ)エラーの要因を取り除いた後，再度コマンドを入力してください。
〈pdstop -sコマンドの場合〉
終了していないサーバがあるか確認してください。前回の終了状態によって，pdstop -s -f，又はpdstop -fコマンドしか受け付けない場合があります。
〈SHARED MEMORYの場合〉
システムの起動処理中に運用コマンドを入力すると，このメッセージが出力されることがあります。必要があれば，再度コマンドを実行してください。
〈TIMEOUTの場合〉
次に示す操作をしてください。
1. システム定義のpd_start_levelオペランドに1を指定していて，このメッセージの付加情報に表示されているユニットを除いて，HiRDBの開始処理を続行する場合は，このメッセージを無視してください。
2. このメッセージの出力後にpdstartコマンドが終了していない場合はpdstop -fコマンドを実行してください。
3. このメッセージの出力時刻の前後に，システムマネジャがあるユニットのsyslogfileにエラーメッセージ又は警告メッセージが出力されている場合は，そのメッセージの対処に従ってください。
4. このメッセージの出力時刻の前後に，このメッセージの付加情報に表示されているユニットのsyslogfileにエラーメッセージ又は警告メッセージが出力されている場合は，そのメッセージの対処に従ってください。
5. pd_start_time_outオペランドの指定値を大きくしてください。
6. pdstartコマンドを再度実行してください。
7. 6で実行したpdstartコマンドが再びこのメッセージを出力した場合は，1～6の操作を繰り返してください。
〈RPL STATUSの場合〉
直前に出力されるメッセージに従って対処して下さい。
KFPS01862-E
Enter server name　　（Ｅ＋Ｌ）
サーバ名を入力してください。
(Ｓ)コマンドを終了します。
(Ｏ)コマンドの引数として，サーバ名を入力してください。
KFPS01863-E
Hostname=aa....aa, unable to execute cc....cc command, unit state not bb....bb　　（Ｅ）
ホスト名aa....aaのユニットの状態がbb....bbではありません。このため，コマンドが実行できません。
aa....aa：コマンドが実行できなかったホスト名
bb....bb：コマンド入力できるステータスを示します。
OFFLINE：オフライン中
ONLINE：オンライン中
cc....cc：入力したコマンド名を示します。
(Ｓ)コマンドを終了します。
(Ｏ)システム又はユニットのステータスが表示された状態になるのを待って，再度コマンドを入力してください。ただし，開始（開始処理中を含む）状態でのpdstartコマンド，及び停止（終了処理中を含む）状態でのpdstopコマンドは，実行できません。この場合，停止又は開始したことを確認してから，コマンドを入力してください。
KFPS01864-E
Timeout occurred during execution of command aa....aa　　（Ｅ＋Ｌ）
コマンドでタイムオーバが発生しました。
aa....aa：コマンド名
pdstop：終了コマンド
(Ｓ)コマンドを終了します。
[対策]コアファイルにダンプが出力されている場合はそのダンプを保存してください。異常終了した原因を調査して，HiRDBを再度開始してください。
KFPS01865-E
Server failed: cancels execution of aa....aa command　　（Ｌ）
サーバが異常終了しました。このため，コマンドの処理を中止します。
aa....aa：入力したコマンド名
pdstop：システム終了コマンド
(Ｓ)コマンドを終了します。
[対策]コアファイルにダンプが出力されている場合はそのダンプを保存してください。異常終了した原因を調査して，HiRDBを再度開始してください。
KFPS01866-E
Server aa....aa specified twice　　（Ｅ＋Ｌ）
入力コマンドの並びに同じ名称を指定しました。
aa....aa：重複したサーバ名
(Ｓ)コマンドを終了します。
(Ｏ)入力コマンドの並びから同じ名称を削除して，再度コマンドを入力してください。
KFPS01867-E
Unable to continue processing because shared memory unused　　（Ｅ）
共用メモリを使用できません。このため，処理が続行できません。
(Ｓ)コマンドを終了します。
(Ｏ)システムが動作中か確認し，再度コマンドを入力してください。
KFPS01868-E
Server name aa....aa invalid　　（Ｅ＋Ｌ）
不正なサーバ名があります。
aa....aa：不正なサーバ名
(Ｓ)コマンドを終了します。
(Ｏ)コマンド引数を修正し，再度コマンドを入力してください。
KFPS01869-E
Unable to accept the command because the unit failed or not installed　　（Ｅ）
システムがインストールされていません。又は，システムが停止しています。このため，コマンドが受け付けられません。
(Ｓ)コマンドを終了します。
(Ｏ)システムが動作中か確認し，再度コマンドを入力してください。
KFPS01870-E
Unable to analyze the definition file due to insufficient memory　　（Ｅ＋Ｌ）
定義ファイルの解析処理中にプロセスのメモリが不足しました。
(Ｓ)定義ファイルの解析処理を中止します。
[対策]プロセスの数を少なくするか，ほかのプロセスの使用メモリ量を少なくして，再度HiRDBを開始してください。
KFPS01871-E
Communication error occurred. server name=aa....aa, return code=bb....bb　　（Ｅ＋Ｌ）
通信エラーが発生しました。
aa....aa：エラーが発生したサーバ名
bb....bb：エラーリターンしたときのリターン値
(Ｓ)該当するサーバの処理を中断します。
(Ｏ)このメッセージの前に出力されているメッセージに従って，エラーの要因を取り除いてください。その後，必要があれば再度HiRDBを開始してください。
KFPS01872-I
HiRDB is placed in the standby state　　（Ｌ）
HiRDBが待機状態になりました。
(Ｓ)処理を続行します。
KFPS01873-E
HA monitor has been stopped　　（Ｌ）
現在HAモニタ又はHitachi HA Toolkit Extensionは停止中です。
(Ｓ)異常終了します。
(Ｏ)HAモニタ又はHitachi HA Toolkit Extensionを起動して，HiRDBを再度開始してください。
KFPS01874-E
Cannot connect to HA monitor. reason=aa....aa　　（Ｌ）
HAモニタ又はHitachi HA Toolkit Extensionと接続できません。
aa....aa：HAモニタ又はHitachi HA Toolkit Extensionと接続できなかった要因
HA NOEXIST：HAモニタ又はHitachi HA Toolkit Extensionがありません。又は未起動です。
PDDIR LEN：環境変数PDDIRの文字列長が最大文字列長を超えています。
DUPLICATE：同一名のサーバを起動しようとしています。
(Ｓ)異常終了します。
(Ｏ)エラー要因を取り除いた後，HiRDBを開始してください。
KFPS01875-E
System error detected during communication with HA monitor. error code=aaaa,detail code=bbbb　　（Ｌ）
HAモニタ又はHitachi HA Toolkit Extensionへの連絡処理中にシステムエラーを検知しました。
aaaa：HAモニタ又はHitachi HA Toolkit Extensionのリターンコード
bbbb：HAモニタ又はHitachi HA Toolkit Extensionの詳細リターンコード
(Ｓ)影響分散スタンバイレス型系切り替え機能を適用したユニットの場合はサーバを停止します。それ以外の場合は異常終了します。
[対策]このメッセージの前後に出力されているHAモニタ又はHitachi HA Toolkit Extensionのメッセージを参照し，そのメッセージに従って対処してください。HAモニタ又はHitachi HA Toolkit Extensionのメッセージが出力されていない場合は保守員に連絡してください。
KFPS01877-I
HiRDB stop request issued from HA monitor; stops HiRDB. reason=aa....aa　　（Ｌ）
HAモニタ又はHitachi HA Toolkit ExtensionからHiRDBの停止要求が発生したため，HiRDBを停止します。
aa....aa：HiRDB内部の停止要因コード（保守情報）
(Ｓ)異常終了します。
(Ｏ)HAモニタ又はHitachi HA Toolkit Extensionのメッセージを参照してください。
KFPS01878-I
HiRDB restart request issued from HA monitor; stops HiRDB temporarily. reason=aa....aa　　（Ｌ）
HAモニタ又はHitachi HA Toolkit ExtensionからHiRDBの再開始要求が発生したため，HiRDBをいったん停止します。
aa....aa：HiRDB内部の停止要因コード（保守情報）
(Ｓ)停止後の開始方法によって次の処理をします。
自動起動の場合：HiRDBを停止して自動起動します。
手動起動の場合：HiRDBを停止します。
(Ｏ)停止後の開始方法が手動の場合は，pdstartコマンドでHiRDBを再開始してください。
KFPS01879-I
HiRDB standby state released, status=aa　　（Ｌ）
HiRDBの待機状態が解除されました。
aa：HiRDBの状態コード（保守情報）
(Ｓ)処理を続行します。
KFPS01880-W
Statistics already output stopped　　（Ｅ）
統計情報の出力は，既に停止しています。
(Ｓ)入力されたコマンドを無視します。
(Ｏ)統計情報が出力中かどうかを確認し，必要に応じて再度pdstendコマンドを実行してください。統計情報が出力中かどうかについては，pdls -d stjコマンドを実行して確認してください。
統計ログファイルに出力する統計情報の指定を追加，又は変更する場合は，pdstbegin，又はpdstendコマンドで追加，又は変更する統計情報の内容を指定してコマンドを実行してください。
KFPS01881-I
Usage: pdstbegin{[-k statistics_type [,statistics_type]…] [-m time_interval] [-x host_name [,host_name]…] [-a|-s server_name[,server_name]…]}　　（Ｅ＋Ｓ）
pdstbeginコマンド及びpdstendコマンドの使用方法を示します。
KFPS01882-E
Command argument invalid　　（Ｅ）
コマンドの引数に誤りがあります。又は，コマンドに不要な引数が指定されています。
(Ｓ)コマンドの処理を中止します。
(Ｏ)コマンドの引数を訂正し，再度入力してください。
KFPS01883-E
Cancels processing because the same command running　　（Ｅ）
既に同じコマンドのプロセスがあります。コマンドが異常終了した直後に，再度コマンドを入力した場合も，このメッセージを出力することがあります。
(Ｓ)コマンドの処理を中止します。
(Ｏ)実行中のコマンドプロセスの終了を待って，コマンドを再度入力してください。コマンドが異常終了した場合は，しばらく待ってからコマンドを再度入力してください。
KFPS01884-E
Statistics already output　　（Ｅ）
統計情報は既に統計ログファイルへ出力しています。
(Ｓ)入力されたコマンドを無視します。
(Ｏ)統計情報が出力中かどうかについては，pdls -d stjコマンドを実行して確認してください。統計ログファイルに出力する統計情報の指定を追加，又は変更する場合は，pdstbegin，又はpdstendコマンドで追加，又は変更する統計情報の内容を指定してコマンドを実行してください。
KFPS01885-E
Cancels the command because shared memory for statistics in server aa....aa unable to be allocated　　（Ｅ）
サーバaa....aaの統計情報を実行するための共用メモリを確保できません。このため，コマンドの処理を中止します。
aa....aa：共用メモリを確保しようとしたサーバ名
(Ｓ)コマンドの処理を中止します。
(Ｏ)該当するサーバに関する統計ログファイルを取得する指定をやめて，pdststartコマンドを再度入力してください。
KFPS01886-W
Cancels system active statistics log output. reason code=aa....aa　　（Ｒ＋Ｓ）
システム稼働統計情報のログ出力ができません。
aa....aa：理由コード
MAX PROCESSES：HiRDB内で同時に起動するサーバのプロセス数の最大値を超えました。
(Ｓ)処理を続行します。
なお，ログ出力しようとしたシステム稼働統計情報の内容は，次回出力するシステム稼働統計情報のないように含めて出力されます。このエラーは，現時点でのHiRDBのオンライン稼働に影響を与えません。
[対策]reason codeにMAX PROCESSESが表示された場合，最大同時起動サーバプロセス数（pd_max_server_processオペランド）の指定値が小さいと考えられます。このため，pd_max_server_processオペランドの指定値を見直した後，正しい値を設定してください。
KFPS01888-W
Too small aa....aa. pd_max_users assumed. server=bb....bb 　　（Ｅ＋Ｌ）
pd_max_bes_process又はpd_max_dic_processにシステム共通定義のpd_max_usersの指定値よりも小さな値を指定しています。pd_max_usersの指定値を仮定します。
aa....aa：pd_max_usersの指定値を仮定する定義名称
pd_max_bes_process：バックエンドサーバの最大起動プロセス数
pd_max_dic_process：ディクショナリサーバの最大起動プロセス数
bb....bb：サーバ名
(Ｓ)処理を続行します。
[対策]該当するpd_max_bes_process又はpd_max_dic_processの指定値を見直してください。
KFPS01889-E
Error occurred in HiRDB Datareplicator while executing aa....aa. server ID=bb....bb, function value=cc....cc, errno=dddd　　（Ｅ＋Ｌ）
HiRDB Datareplicator連携で，エラーが発生しました。
aa....aa：異常終了したサブルーチン名
bb....bb：サーバ名
cc....cc：異常終了したサブルーチンの理由コード
INTERNAL ERROR：内部処理でエラーが発生しました。
SEQUENCE ERROR：関数の発行順序にエラーがありました。
PARAMETER ERROR：引数が不正です。
FILE ERROR：HiRDB Datareplicator運用ディレクトリ名：データ連動用連絡ファイルが不正です（運用ディレクトリ名は，最大64文字表示します）。
SYSTEM CALL(システムコール名) ERROR：システムコールエラーです。
FILE LOCK ERROR：データ連動用連絡ファイルへの参照権限，更新権限が取得できませんでした。
dddd：異常終了したサブルーチンのerrnoの値
(Ｓ)HiRDB開始時であれば，HiRDB Datareplicator連携を中止します。pdls -d rplコマンド実行時，及びHiRDBが稼働中の場合は，HiRDB Datareplicator連携を続行します。
[対策]理由コードがFILE ERROR，又はSYSTEM CALL ERRORの場合は，HiRDBとHiRDB Datareplicatorの実行環境を確認してください。なお，ユニットの系切り替え中にpdls -d rplコマンドを実行した場合，このメッセージを出力することがありますが，系切り替え完了後に再度コマンドを実行してください。
また，HiRDB稼働中にこのメッセージが出力された場合，syslogfile（Windows NTの場合はイベントログ）を参照するか，又はpdls -d rplコマンドを実行し，データ連動状態を確認してください。KFPS05141-Iメッセージが出力されていなければ，データ連動は中断していないので，回復の必要はありません。
そのほかの理由コードの場合は，保守員に連絡してください。
KFPS01890-I
Statistics：ID=aa....aa, number of events=bb....bb, average=cc....cc, max=dd....dd, min=ee....ee　　（Ｌ＋Ｓ）
イベントに関する統計情報を示します。
aa....aa：イベントID
bb....bb：上記イベントの起きた回数
cc....cc：イベントの平均値
dd....dd：イベントの最大値
ee....ee：イベントの最小値
(Ｓ)コマンドを終了します。
KFPS01891-E
Invalid value for variable aa....aa in definition file.　　（Ｅ＋Ｌ）
HiRDBシステム定義のオペランドの指定値に誤りがあります。
aa....aa：HiRDBシステム定義のオペランド名
(Ｓ)HiRDBの開始処理を終了します。
[対策]aa....aaオペランドの指定値を見直してください。その後，HiRDBを開始してください。
KFPS01892-E
aa....aa invalid; stops unit startup. server ID=bb....bb, old value=cc....cc, new value=dd....dd　　（Ｅ）
aa....aaオペランドの指定値を変更したため，ユニットを再開始できません。aa....aaオペランドの値は，異常終了又は強制終了後に変更できません。
aa....aa：HiRDBシステム定義のオペランド名
bb....bb：サーバ名（aa....aaのオペランドがシステム共通定義，又はユニット制御情報定義の場合は"********"を表示します）
cc....cc：aa....aaオペランドの変更前の値
dd....dd：aa....aaオペランドの変更後の値
(Ｓ)ユニットの開始処理を終了します。
[対策]aa....aaに表示される情報によって対策が異なります。
●pd_max_usersと表示された場合
pd_max_usersオペランドの値を変更前の値（cc....ccの値）に戻してください。その後，ユニットを再開始してください。
●pd_max_bes_process or pd_max_usersと表示された場合
条件
対策
pd_max_bes_processオペランドを省略している場合
pd_max_usersオペランドの値を変更前の値（cc....ccの値）に戻してください。その後，ユニットを再開始してください。
pd_max_bes_processオペランドを指定している場合
cc....ccの値＞pd_max_usersの値
pd_max_bes_processオペランドの値を変更前の値（cc....ccの値）に戻してください。その後，ユニットを再開始してください。
cc....ccの値≦pd_max_usersの値
pd_max_users及びpd_max_bes_processオペランドの値を変更前の値（cc....ccの値）に戻してください。その後，ユニットを再開始してください。
注
pd_max_bes_processオペランドの値を変更する場合，どのバックエンドサーバ定義を変更するかは，bb....bbで表示されるサーバ名から特定してください。
●pd_max_dic_process or pd_max_usersと表示された場合
条件
対策
pd_max_dic_processオペランドを省略している場合
pd_max_usersオペランドの値を変更前の値（cc....ccの値）に戻してください。その後，ユニットを再開始してください。
pd_max_dic_processオペランドを指定している場合
cc....ccの値＞pd_max_usersの値
pd_max_dic_processオペランドの値を変更前の値（cc....ccの値）に戻してください。その後，ユニットを再開始してください。
cc....ccの値≦pd_max_usersの値
pd_max_users及びpd_max_dic_processオペランドの値を変更前の値（cc....ccの値）に戻してください。その後，ユニットを再開始してください。
●pd_max_list_usersと表示された場合
pd_max_list_usersオペランドの値を変更前の値（cc....ccの値）に戻してください。その後，ユニットを再開始してください。
●pd_max_list_countと表示された場合
pd_max_list_countオペランドの値を変更前の値（cc....ccの値）に戻してください。その後，ユニットを再開始してください。
●pd_max_reflect_process_countと表示された場合
pd_max_reflect_process_countオペランドの値を変更前の値（cc....ccの値）に戻してください。その後，ユニットを再開始してください。
●pd_ha_max_act_guest_serversと表示された場合
pd_ha_max_act_guest_serversオペランドの値を変更前の値（cc....ccの値）に戻してください。その後，ユニットを再開始してください。
KFPS01893-E
Error occurred during pd_ha_restart_failure command execution　　（Ｅ）
ユニット制御情報定義のpd_ha_restart_failureオペランドで指定されたコマンドを起動できません。又は，異常終了しました。
(Ｓ)ユニットの開始処理を終了します。
[対策]コマンド及び定義内容を見直してください。
pdstartコマンドを入力して再開始をするか，又は系切り替えをしてください。
KFPS01894-I
Master_file_name = aa....aa　　（Ｌ）
正常開始したユニットの環境を表示します。また，再開始したユニットは前回の環境を表示します。
aa....aa：マスタディレクトリ用RDエリアの先頭のHiRDBファイル名
(Ｓ)処理を続行します。
(Ｏ)実行環境を確認してください。
KFPS01895-E
Error found in system definition, file=aa....aa, line=bb....bb, option=c　　（Ｅ）
定義内容に誤りがあります。
aa....aa：定義ファイル名称
bb....bb：行番号
c：オプション名称
(Ｓ)異常終了します。
(Ｏ)HiRDBシステム管理者に連絡してください。
[対策]定義ファイルの内容を修正し，再度HiRDBを実行してください。
KFPS01896-E
Error found in system configuration. reason code=aa....aa　　（Ｅ）
HiRDBシステム定義に指定したシステム構成関連のオペランドの指定に誤りがあります。
aa....aa：理由コード
(Ｓ)異常終了します。
[対策]理由コードに対応する対策をした後にHiRDBを開始してください。
理由コード
対策
CURRENT PDDIR ERR ディレクトリ名
環境変数PDDIRに指定したHiRDB運用ディレクトリ名とpdunitオペランドの-dオプションに指定したHiRDB運用ディレクトリが一致しません。HiRDB運用ディレクトリ名を一致させてください。
なお，表示されているディレクトリ名は-dオプションに指定したHiRDB運用ディレクトリで，63文字までしか表示されません。
CURRENT PORT NUMBER ERR ユニット識別子
pdunitオペランドの-pオプションに指定したポート番号とpd_name_portオペランドに指定したポート番号が一致しません。ポート番号を一致させてください。
CURRENT UNIT ID ERR ユニット識別子
・pdstartオペランドの-uオプションに指定したユニット識別子とpdunitオペランドの-uオプションに指定したユニット識別子が一致しません。ユニット識別子を一致させてください。
・pdstartオペランドの-uオプションに指定したユニット識別子が重複しています。ユニット識別子はシステム内で重複しないようにしてください。
DUPLICATE DIC
pdstartオペランドの-tオプションにDICが複数個指定されています。DICの指定はシステム内で一つだけにしてください。
DUPLICATE HOSTNAME ホスト名
pdunitオペランドの-xオプションに指定したホスト名が重複しています。ホスト名はシステム内で重複しないようにしてください。
DUPLICATE HOSTNAME ユニット識別子
pdunitオペランドの-xオプションに指定したホスト名と-cオプションに指定したホスト名が重複しています。-xオプションには現用系のホスト名を，-cオプションには予備系のホスト名を指定してください。現用系と予備系には異なるホスト名を指定します。系切り替え機能を使用しない場合は-cオプションを指定しないでください。
DUPLICATE MGR
pdstartオペランドの-tオプションにMGRが複数個指定されています。MGRの指定はシステム内で一つだけにしてください。
DUPLICATE PDDIR ディレクトリ ユニット識別子
pdunitオペランドの-dオプションに指定したHiRDB運用ディレクトリが重複しています。相互系切り替え構成の場合，ユニットごとに異なるHiRDB運用ディレクトリを指定してください。Windows NT版の場合，英字の大文字と小文字を同一文字として扱うため，大文字と小文字だけが異なるHiRDB運用ディレクトリ名を指定するとエラーになります。
DUPLICATE PORT NUMBER ユニット識別子
pdunitオペランドの-pオプションに指定したポート番号が重複しています。相互系切り替え構成の場合，ユニットごとに異なるポート番号を指定してください。
DUPLICATE SERVER ID サーバ名
pdstartオペランドの-sオプションに指定したサーバ名が重複しています。システム内でサーバ名が重複しないようにしてください。Windows NT版の場合，英字の大文字と小文字を同一文字として扱うため，大文字と小文字だけが異なるサーバ名を指定するとエラーになります。
DUPLICATE UNIT ID ユニット識別子
pdunitオペランドの-uオプションに指定したユニット識別子が重複しています。システム内でユニット識別子が重複しないようにしてください。
FES SAME UNIT
1ユニット内に複数のフロントエンドサーバを定義しています。1ユニット内に定義できるフロントエンドサーバは一つだけです。
INVALID Datareplicator environment
HiRDB Datareplicatorの実行環境が不正です。HiRDB Datareplicatorの実行環境を確認してください。
MISSING pdunit ホスト名
pdstartオペランドの-xオプションに指定したホスト名とpdunitオペランドの-xオプションに指定したホスト名が一致しません。ホスト名を一致させてください。
NEED TO SPECIFY pd_rpl_hdepath
pd_rpl_hdepathオペランドが指定されていません。HiRDB Datareplicatorを使用する場合は，pd_rpl_hdepathオペランドに抽出側HiRDB Datareplicatorの運用ディレクトリ名を指定してください。
NEED TO SPECIFY pdunit -c ホスト名
pdunitオペランドの-cオプションの指定がありません。IPアドレスを引き継がない系切り替えをする場合はこのオプションを指定してください。
NEED TO SPECIFY pdunit -p ポート番号
pdunitオペランドの-pオプションの指定がありません。ユティリティ専用ユニットを使用する場合はこのオプションを指定してください。HiRDB/パラレルサーバで相互系切り替え構成の場合はこのオプションを指定してください。
NO BES
バックエンドサーバの指定がありません。バックエンドサーバはシステム内で一つ以上必要になります。pdstartオペランドの-tオプションの指定を見直してください。
NO DIC
ディレクトリサーバの指定がありません。ディクショナリサーバはシステム内で一つ必要になります。pdstartオペランドの-tオプションの指定を見直してください。
NO FES
フロントエンドサーバの指定がありません。フロントエンドサーバはシステム内で一つ以上必要になります。pdstartオペランドの-tオプションの指定を見直してください。
NO MGR
システムマネジャの指定がありません。システムマネジャはシステム内で一つ必要になります。pdstartオペランドの-tオプションの指定を見直してください。
OUT OF SYSTEM
pdunitオペランドの-xオプションにHiRDBを実行するホストのホスト名が指定されていません。pdunitオペランドの-xオプションの指定を見直してください。
SDS SAME UNIT
1ユニット内に複数のシングルサーバが定義されています。pdstartオペランドの指定を見直してください。
UNABLE TO SPECIFY pdunit -c ユニット識別子
pdunitオペランドの-cオプションを指定できるのは，IPアドレスを引き継がない系切り替え機能を使用するときだけです。該当しない場合は-cオプションを削除してください。
UNKNOWN HOSTNAME ホスト名（/etc/hosts）ユニット識別子
pdunitオペランドに指定したホスト名がhostsファイルに登録されていません。pdunitオペランドに指定したホスト名を変更するか，又はhostsファイルにpdunitオペランドに指定したホスト名を追加してください。DNSを使用している場合，DNSの設定が正しくてもこの理由コードのメッセージが出力されます。この場合はこのメッセージを無視してください。
INVALID pdcltgrpクライアントグループ名
pdcltgrpオペランドの-gオプションに指定したクライアントグループ名が不正です。-gオプションの指定を見直してください。クライアントグループについては，マニュアル「HiRDB Version 7 システム運用ガイド」を参照してください。
NUMBER OF pdcltgrp EXCEEDS THE LIMIT
ユーザ指定のpdcltgrpオペランドの指定個数が10を超えています。10グループ以内にしてください。
EXCEEDED pd_max_users
pdcltgrpオペランドで指定したクライアントグループごとの接続最低保証数の合計がpd_max_usersオペランドの値以上になっています。接続最低保証数の合計を小さくするか，又はpd_max_usersオペランドの値を大きくしてください。
DUPLICATE pdcltgrpクライアントグループ名
pdcltgrpオペランドで指定したクライアントグループ名が重複しています。重複しないようにしてください。
NUMBER OF SERVER EXCEEDS THE LIMIT
ユニット内のサーバ数の上限（サーバ数の上限は34）を超えています。pdunitオペランドの指定を見直して，ユニット内で定義するサーバ数を減らしください。
UNABLE TO SPECIFY pd_ha_agent
高速系切り替え機能を使用するための前提条件に誤りがあります。高速系切り替え機能を使用する場合は次に示すオペランドを指定してください。
・pd_ha = use
・pd_ha_unitを指定しない
・pd_ha_ipaddr_inherit = N
・pd_ha_acttype = server
スタンバイレス型系切り替え，又は影響分散スタンバイレス型系切り替えを使用する場合には，次に示すオペランドを指定する必要があります。それぞれのオペランドの内容を確認してください。
・pd_ha = use
・pd_ha_unitを指定しない。
・pd_ha_acttype = server
INVALID pd_max_users_wrn_pnt operand
pd_max_users_wrn_pntオペランドの指定に誤りがあります。指定できる範囲内の値を指定してください。
INVALID pd_aud_file_wrn_pnt operand
pd_aud_file_wrn_pntオペランドの指定に誤りがあります。指定できる範囲内の値を指定してください。
NUMBER OF CONNECT USERS EXCEEDS THE LIMIT
pd_max_usersオペランドに指定した値とpd_max_reflect_process_countオペランドに指定した値（指定していない場合は0とみなします）の合計が，pd_max_usersオペランドに指定できる上限値を超えています。pd_max_usersオペランドに指定できる上限値以下になるようにしてください。
NUMBER OF PROCESSES EXCEEDS THE LIMIT, server = サーバ名
・該当するサーバがバックエンドサーバの場合
pd_max_bes_processオペランドに指定した値とpd_max_reflect_process_countオペランドに指定した値（指定していない場合は0とみなします）の合計が，pd_max_bes_processオペランドに指定できる上限値を超えています。pd_max_bes_processオペランドに指定できる上限値以下になるようにしてください。
・該当するサーバがディクショナリサーバの場合
pd_max_dic_processオペランドに指定した値とpd_max_reflect_process_countオペランドに指定した値（指定していない場合は0とみなします）の合計が，pd_max_dic_processオペランドに指定できる上限値を超えています。pd_max_dic_processオペランドに指定できる上限値以下になるように指定してください。
NEED TO SPECIFY pd_rise_pairvolume_combination
pd_rise_pairvolume_combinationオペランドの指定がありません。pd_rise_useオペランドにYを指定する場合は，pd_rise_pairvolume_combinationオペランドを指定してください。
NEED TO SPECIFY pd_hostname
pd_hostnameオペランドの指定がありません。pd_rise_useオペランドにYを指定する場合は，pd_hostnameオペランドを指定してください。
INVALID pd_mode_conf
pd_mode_confオペランドの指定が不正です。pd_rise_useオペランドにYを指定する場合は，pd_mode_confオペランドにはMANUAL1，又はMANUAL2を指定してください。
INVALID pd_dbsync_point
pd_dbsync_pointオペランドの指定が不正です。pd_rise_pairvolume_combinationオペランドにhybridを指定する場合は，pd_dbsync_pointオペランドにcommitを指定できません。
NEED TO SPECIFY pd_rise_fence_level
pd_rise_fence_levelオペランドの指定がありません。pd_rise_useオペランドにYを指定し，かつpd_rise_pairvolume_combinationオペランドにsync又はhybridを指定する場合は，pd_rise_fence_levelオペランドを指定してください。
INVALID KIND
pdstartオペランドの-kオプションの指定に誤りがあります。又は，-kオプションに複数の機能名を指定しています。-kオプションの指定を見直してください。
INVALID pdstart -k stls
pdstartオペランドの-kオプションの指定に誤りがあります。次の原因が考えられます。
・フロントエンドサーバ以外のサーバに-k stlsを指定しています。-k stlsオプションはフロントエンドサーバにだけ指定できます。
・フロントエンドサーバ以外のサーバがあるユニットのサーバに-k stls指定しています。-k stlsオプションは，フロントエンドサーバ以外のサーバがあるユニットには指定できません。
INVALID pdstart -c
システム共通定義のpdstart -cオペランドに指定した代替BES名が不正です。システム共通定義のpdstart -cオペランドに指定した代替BES名を見直してください。なお，この理由コードの後ろに保守情報を伴うことがあります。
INVALID pdstart -t
システム共通定義のpdstart -cオペランドに指定したユニットにバックエンドサーバ以外のサーバが定義されています。pdstart -cオペランドに指定したサーバがあるユニットには，バックエンドサーバ以外のサーバを定義できません。pdstart -cオペランドの指定と，代替BESユニット内のサーバ種別を見直してください。なお，この理由コードの後ろに保守情報を伴うことがあります。
INVALID pdunit -d：error about ホスト名：ホスト名
1：1スタンバイレス型系切り替え機能を適用するユニットの正規BESユニットと代替BESユニットでHiRDB運用ディレクトリ名が異なります。1：1スタンバイレス型系切り替え機能を適用するユニットについては，正規BESユニットと代替BESユニットでHiRDB運用ディレクトリ名を同じにしてください。
INVALID pdunit -p：error about ホスト名：ホスト名
1：1スタンバイレス型系切り替え機能を適用するユニットの正規BESユニットと代替BESユニットでポート番号が異なります。1：1スタンバイレス型系切り替え機能を適用するユニットについては，正規BESユニットと代替BESユニットで同じポート番号を指定してください。
NUMBER OF pdhagroup EXCEEDS THE LIMIT
HAグループが二つ以上定義されています。HAグループは一つだけ定義してください。
NO SERVER IN HAGROUP UNIT ユニット識別子
HAグループ内のユニットに，現用系サーバがありません。現用系のサーバを定義してください。
INVALID SERVER IN UNIT ユニット識別子
HAグループ内のユニット，又はpd_ha_agentオペランドにserverを指定した正規BESユニットに，バックエンドサーバ以外のサーバがあります。HAグループ内のユニットやpd_ha_agentオペランドにserverを指定した正規BESユニットには，バックエンドサーバだけを定義してください。
INVALID pd_ha_agent ユニット識別子
HAグループ内のユニットに対して，pd_ha_agentオペランドでactiveunitsが指定されていません。pdhagroup -uオペランドで指定したユニットのユニット制御情報定義のpd_ha_agentオペランドにactiveunitsを指定してください。
NEED TO SPECIFY pdstart -g : サーバ名
HAグループ内のユニットのサーバに，HAグループの指定がありません。pdhagroup -uオペランドで指定したユニット内のサーバはpdstart -gオペランドにユニットが属するHAグループ識別子を指定してください。
INVALID pdstart -g : サーバ名
HAグループ内のユニットのサーバが，ユニットと同じHAグループに含まれません。pdhagourp -uオペランドで指定したユニット内のサーバはpdstart -gオペランドにユニットが属するHAグループ識別子を指定してください。
INVALID pdhagroup -u ユニット識別子
pdhagroup -uオペランドに指定したユニットが，pdunit -uオペランドで定義されていません。pdhagroup -uオペランドとpdunit -uオペランドの指定を見直してください。
INVALID pdunit -p : error about HAグループ識別子
HAグループ内のユニットのポート番号が異なっています。HAグループ内のユニットに対応するpdunit -pオペランドはすべて同じポート番号を指定してください。
INVALID pdunit -d : error about HAグループ識別子
HAグループ内のユニットのHiRDB運用ディレクトリが異なっています。HAグループ内のユニットに対応するpdunit -dオペランドはすべて同じHiRDB運用ディレクトリを指定してください。
UNABLE TO SPECIFY pdstart -g サーバ名
HAグループに含まれないユニット内のサーバにpdstart -gオペランドが指定されています。pdstart -gオペランドが指定できるのは，pdhagroup -uオペランドに指定したユニット内のサーバだけです。pdhagroup -uオペランドとpdstartオペランドを見直してください。
NEED TO ADD ユニット識別子 TO pdhagroup -u
pd_ha_agentオペランドにactiveunitsが指定されているユニットがpdhagroup -uオペランドで指定されていません。HAグループに含まれないユニットのユニット制御情報定義のpd_ha_agentオペランドにactiveunitsが指定されています。pdhagroup -uオペランドとpd_ha_agentオペランドを見直してください。
UNABLE TO SPECIFY pd_ha_max_act_guest_servers
HAグループに含まれないユニットにpd_ha_max_act_guest_serversオペランドが指定されています。pd_ha_max_act_guest_serversオペランドが指定できるのは，pdhagroup -uオペランドに指定したユニットだけです。pdhagroup -uオペランドとpd_ha_max_act_guest_serversオペランドを見直してください。
UNABLE TO SPECIFY SAME SYSTEM pdstart -c, pdstart -g
同一のシステム内に，pdstart -cオペランドの指定があるサーバとpdstart -gオペランドの指定があるサーバが混在しています。1：1スタンバイレス型系切り替えと影響分散スタンバイレス型系切り替えを同じシステム内に混在できません。pdstartオペランドを見直してください。
KFPS01897-E
Error found in system definition. file=aa....aa, line=bb....bb　　（Ｅ）
定義内容に誤りがあります。
aa....aa：定義ファイル名
bb....bb：行番号
(Ｓ)異常終了します。
[対策]定義ファイルの内容を修正し，再度HiRDBを実行してください。
KFPS01898-E
Error occurred while starting server, server ID=aa....aa, server type=bbb, reason code=cc....cc　　（Ｅ＋Ｌ）
HiRDBサーバの開始処理中にエラーが発生しました。
aa....aa：サーバ名
bbb：サーバ種別
cc....cc：要因
CONFIGURATION：定義解析中にエラーが発生しました。
SERVER INIT ERROR：HiRDBサーバの初期化でエラーが発生しました。
SERVER START ERROR：HiRDBサーバのプロセス起動でエラーが発生しました。
(Ｓ)
〈要因がCONFIGURATIONの場合〉
処理を続行します。
〈要因がSERVER　INIT　ERROR，又はSERVER　START　ERRORの場合〉
ユニットが異常終了します。
[対策]定義解析中のエラーの場合は定義ファイルの内容を修正し，サーバを開始するコマンドでエラーとなったサーバを開始してください。HiRDBサーバの初期化，又はプロセス起動でエラーが発生した場合は，この前後に出力されているメッセージで示す対策に従ってください。
KFPS01899-E
Error occurred while initializing server, server ID=aa....aa, server type=bbb, reason code=cc....cc　　（Ｅ）
HiRDBサーバの初期化中にエラーが発生しました。
aa....aa：サーバ名
bbb：サーバ種別
cc....cc：要因
CONFIGURATION：定義解析中にエラーが発生しました。
(Ｓ)異常終了します。
[対策]定義ファイルの内容を修正し，再度HiRDBを実行してください。
KFPS01900-I
Server information. System event = 0xaaaaaaaa bbbbbbbb cccccccc. user event = 0xdddddddd.　　（Ｅ＋Ｌ）
サーバ情報です。システムイベントは，0xaaaaaaaa bbbbbbbb ccccccccです。ユーザイベントは，0xddddddddです。
aaaaaaaa：システムイベント情報１（内部コード）
bbbbbbbb：システムイベント情報２（内部コード）
cccccccc：システムイベント情報３（内部コード）
dddddddd：ユーザイベント情報（内部コード）
(Ｓ)処理を続行します。
[対策]このメッセージの前に出力されたKFPS01820-Eメッセージの付加情報です。KFPS01820-Eメッセージを基に対策してください。
KFPS01902-E
Unable to start message log service due to insufficient memory　　（Ｅ）
プロセス固有領域が不足したため，メッセージログサービス機能を開始できません。
(Ｓ)処理を打ち切ります。
[対策]不要なプロセスを減らして，HiRDBを再度開始してください。
KFPS01903-E
Unable to start message log service due to communication failure　　（Ｅ）
通信障害が発生したため，メッセージログサービス機能を開始できません。
(Ｓ)処理を打ち切ります。
[対策]hostsファイルのアクセス権限，hostsファイル内の設定に誤りがある場合は，hostsファイルを修正してください。通信障害の要因を調査し，障害を取り除いた後，HiRDBを再度開始してください。
KFPS01910-I
Message log file changed over from aa....aa to bb....bb　　（Ｅ＋Ｌ）
このメッセージ以降のメッセージログは，切り替え後のメッセージログファイルに出力されます。
aa....aa：切り替え前のメッセージログファイル名※
bb....bb：切り替え後のメッセージログファイル名※
注　複数世代のメッセージログファイルを保存したい場合は，このメッセージ出力後，直ちに切り替え前のメッセージログファイルを退避してください。
注※
メッセージログファイル名は絶対パスで表示し，81文字以上の場合はファイルパス名の後ろから80文字を表示します。
(Ｓ)処理を続行します。
KFPS01911-E
Error occurred while preprocessing message log file aa....aa　　（Ｅ＋Ｌ）
メッセージログファイルに対し，このメッセージの前に出力されたKFPO00107-Eメッセージ（stat，又はopenシステムコールエラーの場合に該当します）で示される要因のエラーが発生しました。
aa....aa：エラーの発生したメッセージログファイル名
メッセージログファイル名は絶対パスで表示し，149文字以上の場合はファイルパス名の後ろから148文字を表示します。
(Ｓ)処理を打ち切ります。
[対策]メッセージログファイルのエラー要因を取り除いた後，HiRDBを再度開始してください。
KFPS01912-E
Error occurred while opening message log file aa....aa　　（Ｅ＋Ｌ）
メッセージログファイルのオープン処理で，このメッセージの前に出力されたKFPO00107-Eメッセージ（openシステムコールエラーの場合に該当します）で示される要因のエラーが発生しました。
aa....aa：エラーの発生したメッセージログファイル名
メッセージログファイル名は絶対パスで表示し，155文字以上場合はファイルパス名の後ろから154文字を表示します。
(Ｓ)処理を続行します。
[対策]メッセージログファイルのエラー要因を取り除いた後，HiRDBを再度開始してください。
KFPS01913-E
Error occurred during message log file changeover； message log output destination changed to standard error output　　（Ｅ）
メッセージログファイルのスワップ処理でエラーが発生しました。このため，メッセージログの出力先を標準エラー出力へ変更します。
(Ｓ)メッセージログの出力先を標準エラー出力に変更した後，処理を続行します。
[対策]このメッセージの前に出力されたKFPS01912-Eメッセージの要因を調査し，メッセージログファイルをオープンできる状態にしてください。
KFPS01914-E
I/O error occurred in message log file aa....aa； message log output destination changed to standard error output　　（Ｅ）
ログファイルaa....aaに入出力エラーが発生しました。このため，メッセージログの出力先を標準エラー出力へ変更しました。
aa....aa：エラーが発生したメッセージログファイル名
(Ｓ)メッセージログの出力先を標準エラー出力に変更した後，処理を続行します。
[対策]入出力エラーの原因（ディスク容量が一杯など）を調査し，取り除いてください。
KFPS01915-I
(Message log output destination changed from standard error output to message log file )aa....aa　　（Ｅ＋Ｌ）
メッセージログファイルのオープン（再試行）が成功したので，メッセージログの出力先を標準エラー出力からメッセージログファイルへ切り替えました。
aa....aa：切り替え後のメッセージログファイル名
メッセージログファイル名は絶対パスで表示し，115文字以上の場合はファイルパス名の後ろから114文字を表示します。
(Ｓ)メッセージログの出力先をメッセージログファイルに変更した後，処理を続行します。
KFPS01920-E
Unable to handle program version aa....aa that requested message log output in this system. request source process ID=bb....bb　　（Ｅ）
メッセージログの出力要求元プログラムが使用しているメッセージログサービス機能の関数と，ログサーバとのバージョンが一致しません。このため，メッセージログ出力要求を受け付けられません。
aa....aa：メッセージログ出力要求元プログラムが使用しているメッセージログサービス機能の関数のバージョン
bb....bb：メッセージログ出力要求元のプロセスID
(Ｓ)処理を続行します。
[対策]メッセージログ出力要求元プログラムがシステムプログラムの場合は，保守員に連絡してください。
KFPS01933-E
Unable to output message aa....aa due to invalid parameter　　（Ｅ）
メッセージログサービス機能へのパラメタが不正です。このため，メッセージログを出力できません。
aa....aa：出力できなかったメッセージログのメッセージIDの通番
(Ｓ)処理を続行します。
[対策]このメッセージログと出力できなかったメッセージログのメッセージIDの通番を記録し，保守員に連絡してください。
KFPS01943-E
Unable to output message aa....aa due to invalid parameter　　（Ｅ）
メッセージログサービス機能へのパラメタが不正です。このため，メッセージログが出力できません。
aa....aa：出力できなかったメッセージログのメッセージID
(Ｓ)処理を続行します。
[対策]このメッセージログと出力できなかったメッセージログのメッセージIDを記録し，保守員に連絡してください。
KFPS01944-E
Unable to output message aa....aa； invalid parameter for message log service　　（Ｅ）
メッセージログサービス機能に対するパラメタに誤りがあります。このため，メッセージログaa....aaが出力できません。
aa....aa：出力できなかったメッセージログのメッセージID
(Ｓ)処理を続行します。
[対策]このメッセージログと出力できなかったメッセージログのメッセージIDを記録し，保守員に連絡してください。
KFPS01945-E
Failed in output of log message to JP1； output to JP1 is restrained. maintenance info： aa....aa　　（Ｅ＋Ｌ）
JP1のイベントサーバへのログメッセージ出力に失敗したため，JP1のイベントサーバへの出力を抑止します。
aa....aa：保守情報
(Ｓ)JP1のイベントサーバへの出力を抑止します。
(Ｐ)HiRDB管理者に連絡してください。
[対策]JP1（JP1/System Event Service又はJP1/Base）のイベントサーバへメッセージを出力する必要がある場合は，接続に失敗した原因を調査し，取り除いてください。
KFPS01946-I
restarts log message output to JP1　　（Ｓ＋Ｌ）
JP1のイベントサーバへのログメッセージ出力に成功したため，JP1のイベントサーバへの出力を再開します。
(Ｓ)処理を続行します。
KFPS01947-E
I/O error occurred during output of log message to JP1. maintenance info： aa....aa　　（Ｅ＋Ｌ）
JP1のイベントサーバへのログメッセージ出力で入出力エラーが発生しました。
aa....aa：保守情報
(Ｓ)処理を続行します。
(Ｐ)HiRDB管理者に連絡してください。
[対策]JP1のイベントサーバ（JP1/System Event Service又はJP1/Base）へメッセージを出力する必要がある場合は，接続に失敗した原因を調査し，取り除いてください。
KFPS01948-E
Unable to connect to event server of JP1　　（Ｅ＋Ｌ）
JP1のイベントサーバに接続できません。
JP1にHiRDBのイベントを通知するように指定（pd_jp1_useオペランドにYを指定）されましたが，JP1のイベントサーバに接続できません。
(Ｓ)処理を続行します。
[対策]JP1のイベントサーバ（JP1/System Event Service又はJP1/Base）へメッセージを出力する必要がある場合は，接続に失敗した原因を調査し，取り除いてください。必要ない場合は，JP1にHiRDBのイベントを通知しないように指定（pd_jp1_useオペランドにNを指定）して，HiRDBを再度開始してください。
KFPS01950-I
Usage： pdcat [-ab] [-c E|W|I|Q] [-x host name] [-d start date] [-t start time] [-T stop time] [-n record number] [message log file name]　　（Ｅ＋Ｓ）
pdcatコマンドの使用方法を示します。コマンドのオプション，又は引数が誤っている場合に出力します。
(Ｏ)コマンドのオプション，又は引数に誤りがある場合は正しく再入力してください。
KFPS01951-E
Insufficient memory　　（Ｅ）
メッセージログサービス機能のコマンド実行中にプロセス固有領域が不足しました。
(Ｓ)処理を打ち切ります。
[対策]不要なプロセスがあれば，減らしてください。
KFPS01952-E
Error occurred during message log service. maintenance information= aa....aa　　（Ｅ）
メッセージログサービス機能で異常が発生しました。
aa....aa：保守情報
(Ｓ)処理を打ち切ります。
[対策]このメッセージの内容を記録し，保守員に連絡してください。
KFPS01953-E
Failed in obtaining message log file storage directory　　（Ｅ）
メッセージログファイル格納ディレクトリの取得に失敗しました。
(Ｓ)処理を打ち切ります。
(Ｏ)環境変数PDDIRを設定してから，再度実行してください。
KFPS01954-E
Unable to open message log file aa....aa　　（Ｅ）
メッセージログファイルがないか，メッセージログファイルに対する読み込み権限がないため，オープンできません。
aa....aa：メッセージログファイル名
(Ｓ)該当するメッセージログファイルのオープン処理を放棄します。
(Ｏ)適切な処置をしてから，再度実行してください。
[対策]該当するメッセージログファイルに対する読み込み権限がない場合は，読み込み権限を与えてください。
KFPS01955-E
I/O error occurred in message log file aa....aa　　（Ｅ）
メッセージログファイルで，このメッセージログの前に出力されたKFPO00107-Eで示される要因のエラーが発生しました。
aa....aa：メッセージログファイル名
(Ｓ)処理を打ち切ります。
[対策]メッセージログファイルのエラー要因を取り除いて，再度実行してください。
KFPS01956-E
I/O error occurred in message log file aa....aa　　（Ｅ）
ディスクで入出力エラーが発生したため，該当するファイルの処理を中止しました。
aa....aa：メッセージログファイル名
(Ｓ)該当するファイルに対する一切の処理を放棄します。
KFPS01957-E
File aa....aa is not a message log file　　（Ｅ）
ファイルaa....aaはメッセージログファイルではありません。
aa....aa：処理しようとしたファイル名
(Ｓ)該当するファイルに対する処理を放棄します。
KFPS01958-E
Unable to handle the version (aa....aa) of the message log file (bb....bb) in this command　　（Ｅ）
該当するメッセージログファイルがないなどの理由によって，最終更新時刻の取得に失敗しました。
aa....aa：メッセージログファイル名
bb....bb：メッセージログファイルのバージョン番号
(Ｓ)該当するファイルに対する一切の処理を放棄します。
[対策]保守員に連絡してください。
KFPS01959-E
No message log to output　　（Ｅ）
出力するメッセージログはありません。
KFPS01968-E
Unable to find message log file (aa....aa)　　（Ｅ）
指定されたファイルがありません。
aa....aa：指定したファイル名
(Ｓ)指定されたファイルを無視して，処理を続行します。
[対策]このメッセージの内容を記録し，保守員に連絡してください。
KFPS01971-E
Communication failure occurred　　（Ｅ）
通信障害が発生したため，コマンドが実行できません。
(Ｓ)処理を打ち切ります。
[対策]直前に出力されたメッセージから通信障害の原因を調査し，取り除いてください。
KFPS01972-E
Message log server inactive or terminated　　（Ｅ）
メッセージログサーバが起動していません。又は，停止処理中です。このため，コマンドを実行できません。
[対策]pdstartコマンドで，HiRDBを開始してください。
KFPS01973-E
Versions of message log server and command are different　　（Ｅ）
メッセージログサーバとのバージョンが異なるため，コマンドを実行できません。
(Ｓ)処理を打ち切ります。
[対策]HiRDBのインストール方法が正しいか確認してください。
KFPS01974-E
Real-time output function active　　（Ｅ）
リアルタイム出力機能は起動している状態です。
KFPS01975-E
Real-time output function inactive　　（Ｅ）
リアルタイム出力機能は起動していない状態です。
KFPS01976-E
Unable to set environmental variable aa....aa　　（Ｅ）
環境変数aa....aaが設定されていません。
aa....aa：設定されていない環境変数名
(Ｓ)処理を打ち切ります。
(Ｏ)環境変数を設定して，再度実行してください。
KFPS01977-E
Name server inactive； unable to execute command　　（Ｅ）
ネームサーバが起動されていません。このため，コマンドが実行できません。
[対策]pdstartコマンドで，HiRDBを開始してください。
KFPS01978-E
Invalid command argument　　（Ｅ）
コマンド引数の指定がないか，又は指定できるコマンド引数の個数より多くのコマンド引数が指定されています。
(Ｓ)コマンドの処理を中止します。
(Ｏ)このメッセージログの直後に出力される使用方法のメッセージに従い，再度入力してください。
KFPS01979-E
Mandatory option flag not specified or option flags specified in incorrect combination　　（Ｅ）
指定する必要があるオプションフラグが指定されていません。又は，オプションフラグの組み合わせが不正です。
(Ｓ)コマンドの処理を中止します。
(Ｏ)このメッセージログの直後に出力される使用方法のメッセージに従い，再度入力してください。
KFPS01980-E
**・Unable to output message (aa....aa) due to memory shortage； component (bbb)****　　（Ｅ＋Ｓ）
メモリ不足のためメッセージログが出力できません。
aa....aa：出力できなかったメッセージログのメッセージID
bbb：メッセージログ出力要求元コンポーネント名称
(Ｓ)処理を続行します。
[対策]不要なプロセスがあれば，減らしてください。
メッセージID対応表とメッセージID通番を基に該当するメッセージを参照してください。
コンポーネント名称
メッセージID上位4けた
bac，cpy，jar，rec
KFPR
bpp，cit，cpp
KFPZ
dbh
KFPH
dfc
KFPB
dic
KFPD
dsa，sta
KFPK
exp，int，mod
KFPX
goi，ric
KFPN
ios
KFPI
osl
KFPO
lod，rld
KFPL
sqa
KFPA
utl
KFPU
上記以外
KFPS
KFPS01981-E
**・Unable to output message (aa....aa) due to memory shortage； component (bbb) ****　　（Ｅ＋Ｓ）
メモリが不足したため，メッセージログが出力できません。
aa....aa：出力できなかったメッセージログのメッセージIDの通番
bbb：メッセージログ出力要求元コンポーネント名称
(Ｓ)処理を続行します。
[対策]不要なプロセスがあれば，減らしてください。
メッセージID対応表とメッセージID通番を基に該当するメッセージを参照してください。
コンポーネント名称
メッセージID上位4けた
bac，cpy，jar，rec
KFPR
bpp，cit，cpp
KFPZ
dbh
KFPH
dfc
KFPB
dic
KFPD
dsa，sta
KFPK
exp，int，mod
KFPX
goi，ric
KFPN
ios
KFPI
osl
KFPO
lod，rld
KFPL
sqa
KFPA
utl
KFPU
上記以外
KFPS
KFPS01983-E
**・Unable to output message (aa....aa) due to message log file version different； component (bbb) ****　　（Ｅ＋Ｓ）
メッセージログファイルのバージョンが要求元プログラムのバージョンと異なるため，メッセージログが出力できません。
aa....aa：出力できなかったメッセージログのメッセージIDの通番
bbb：メッセージログ出力要求元コンポーネント名称
(Ｓ)処理を続行します。
[対策]実行したプログラムを再度リンケージしてください。
メッセージID対応表とメッセージID通番を基に該当するメッセージを参照してください。
コンポーネント名称
メッセージID上位4けた
bac，cpy，jar，rec
KFPR
bpp，cit，cpp
KFPZ
dbh
KFPH
dfc
KFPB
dic
KFPD
dsa，sta
KFPK
exp，int，mod
KFPX
goi，ric
KFPN
ios
KFPI
osl
KFPO
lod，rld
KFPL
sqa
KFPA
utl
KFPU
上記以外
KFPS
KFPS01984-E
**・Unable to output message (aa....aa) due to message log file not found； component (bbb) ****　　（Ｅ＋Ｓ）
メッセージログファイルがありません。このため，メッセージログが出力できません。
aa....aa：出力できなかったメッセージログのメッセージIDの通番
bbb：メッセージログ出力要求元コンポーネント名称
(Ｓ)処理を続行します。
[対策]環境変数PDDIRが正しく設定されているか確認してください。
メッセージID対応表とメッセージID通番を基に該当するメッセージを参照してください。
コンポーネント名称
メッセージID上位4けた
bac，cpy，jar，rec
KFPR
bpp，cit，cpp
KFPZ
dbh
KFPH
dfc
KFPB
dic
KFPD
dsa，sta
KFPK
exp，int，mod
KFPX
goi，ric
KFPN
ios
KFPI
osl
KFPO
lod，rld
KFPL
sqa
KFPA
utl
KFPU
上記以外
KFPS
KFPS01985-E
**・Unable to output message (aa....aa) due to message log file I/O error； component (bbb) ****　　（Ｅ＋Ｓ）
メッセージログファイルに入出力エラーが発生しました。このため，メッセージログが出力できません。
aa....aa：出力できなかったメッセージログのメッセージIDの通番
bbb：メッセージログ出力要求元コンポーネント名称
(Ｓ)処理を続行します。
[対策]メッセージID対応表とメッセージID通番を基に該当するメッセージを参照してください。
コンポーネント名称
メッセージID上位4けた
bac，cpy，jar，rec
KFPR
bpp，cit，cpp
KFPZ
dbh
KFPH
dfc
KFPB
dic
KFPD
dsa，sta
KFPK
exp，int，mod
KFPX
goi，ric
KFPN
ios
KFPI
osl
KFPO
lod，rld
KFPL
sqa
KFPA
utl
KFPU
上記以外
KFPS
なお，ユーザが対処できない場合，このメッセージと出力できなかったメッセージのメッセージID通番を記録して，保守員に連絡してください。
KFPS01986-E
**・Unable to output message (aa....aa) due to message log file access denied； component (bbb) ****　　（Ｅ＋Ｓ）
メッセージログファイルに対するアクセス権がありません。このため，メッセージログが出力できません。
aa....aa：出力できなかったメッセージログのメッセージIDの通番
bbb：メッセージログ出力要求元コンポーネント名称
(Ｓ)処理を続行します。
[対策]メッセージログファイルに読み込み許可がなければ，読み込み許可を与えてください。また，メッセージログファイルのパスを構成するディレクトリに検索許可がなければ，検索許可を与えてください。
メッセージID対応表とメッセージID通番を基に該当するメッセージを参照してください。
コンポーネント名称
メッセージID上位4けた
bac，cpy，jar，rec
KFPR
bpp，cit，cpp
KFPZ
dbh
KFPH
dfc
KFPB
dic
KFPD
dsa，sta
KFPK
exp，int，mod
KFPX
goi，ric
KFPN
ios
KFPI
osl
KFPO
lod，rld
KFPL
sqa
KFPA
utl
KFPU
上記以外
KFPS
KFPS01989-E
Unable to make message log file： file (aa....aa) version error. file=bb....bb,command=cc....cc　　（Ｅ）
該当するコマンドでは，扱えない（コマンドより新しい）バージョンのメッセージログファイルが指定されました。このため，メッセージログファイルが作成できません。
aa....aa：エラーが発生したファイル名
bb....bb：ファイルのバージョン
cc....cc：コマンドのバージョン
(Ｓ)コマンドの実行を中止します。
[対策]このメッセージの内容を記録し，保守員に連絡してください。
KFPS01990-E
**・Unable to output message (aa....aa) due to parameter too many； component (bbb) ****　　（Ｅ＋Ｓ）
パラメタが不正です。このため，メッセージログが出力できません。
aa....aa：出力できなかったメッセージログのメッセージIDの通番
bbb：メッセージログ出力要求元コンポーネント名称
(Ｓ)処理を続行します。
[対策]メッセージID対応表とメッセージID通番を基に該当するメッセージを参照してください。
コンポーネント名称
メッセージID上位4けた
bac，cpy，jar，rec
KFPR
bpp，cit，cpp
KFPZ
dbh
KFPH
dfc
KFPB
dic
KFPD
dsa，sta
KFPK
exp，int，mod
KFPX
goi，ric
KFPN
ios
KFPI
osl
KFPO
lod，rld
KFPL
sqa
KFPA
utl
KFPU
上記以外
KFPS
なお，ユーザが対処できない場合，このメッセージと出力できなかったメッセージのメッセージID通番を記録して，保守員に連絡してください。
KFPS01991-E
**・Unable to output message (aa....aa) due to parameter not enough； component (bbb) ***　　（Ｅ＋Ｓ）
パラメタが不正です。このため，メッセージログが出力できません。
aa....aa：出力できなかったメッセージログのメッセージIDの通番
bbb：メッセージログ出力要求元コンポーネント名称
(Ｓ)処理を続行します。
[対策]メッセージID対応表とメッセージID通番を基に該当するメッセージを参照してください。
コンポーネント名称
メッセージID上位4けた
bac，cpy，jar，rec
KFPR
bpp，cit，cpp
KFPZ
dbh
KFPH
dfc
KFPB
dic
KFPD
dsa，sta
KFPK
exp，int，mod
KFPX
goi，ric
KFPN
ios
KFPI
osl
KFPO
lod，rld
KFPL
sqa
KFPA
utl
KFPU
上記以外
KFPS
なお，ユーザが対処できない場合，このメッセージと出力できなかったメッセージのメッセージID通番を記録して，保守員に連絡してください。
KFPS01992-I
**・Unable to output message (aa....aa) due to message too long； component (bbb) ***　　（Ｅ＋Ｓ）
編集したメッセージ長が上限値を超えました。このため，メッセージを切り捨てて処理しました。
aa....aa：切り捨て処理をしたメッセージログのメッセージIDの通番
bbb：メッセージログ出力要求元コンポーネント名称
(Ｓ)処理を続行します。
[対策]このメッセージと切り捨て処理をしたメッセージログのメッセージIDの通番を記録して，保守員に連絡してください。
KFPS01993-E
**・Unable to output message (aa....aa) due to invalid argument； component (bbb) ***　　（Ｅ＋Ｓ）
パラメタが不正です。このため，メッセージログが出力できません。
aa....aa：出力できなかったメッセージログのメッセージIDの通番
bbb：メッセージログ出力要求元コンポーネント名称
(Ｓ)処理を続行します。
[対策]メッセージID対応表とメッセージID通番を基に該当するメッセージを参照してください。
コンポーネント名称
メッセージID上位4けた
bac，cpy，jar，rec
KFPR
bpp，cit，cpp
KFPZ
dbh
KFPH
dfc
KFPB
dic
KFPD
dsa，sta
KFPK
exp，int，mod
KFPX
goi，ric
KFPN
ios
KFPI
osl
KFPO
lod，rld
KFPL
sqa
KFPA
utl
KFPU
上記以外
KFPS
UAPの処理でFETCH文を実行し，エラーが発生した後続けてFETCH文を実行した場合，このメッセージがKFPAのメッセージIDで出力されることがあります。この場合，UAPを修正してください。
なお，ユーザが対処できない場合，このメッセージと出力できなかったメッセージのメッセージID通番を記録して，保守員に連絡してください。
KFPS01996-E
(**・Unable to output message (aa....aa) due to message not found; component (bbb) ***)　　（Ｅ＋Ｓ）
メッセージログファイル中にメッセージログがありません。このため，メッセージログが出力できません。
aa....aa：出力できなかったメッセージログのメッセージIDの通番
bbb：メッセージログ出力要求元コンポーネント名称
(Ｓ)処理を続行します。
[対策]メッセージID対応表とメッセージID通番を基に該当するメッセージを参照してください。
コンポーネント名称
メッセージID上位4けた
bac，cpy，jar，rec
KFPR
bpp，cit，cpp
KFPZ
dbh
KFPH
dfc
KFPB
dic
KFPD
dsa，sta
KFPK
exp，int，mod
KFPX
goi，ric
KFPN
ios
KFPI
osl
KFPO
lod，rld
KFPL
sqa
KFPA
utl
KFPU
上記以外
KFPS
なお，ユーザが対処できない場合，このメッセージと出力できなかったメッセージのメッセージID通番を記録して，保守員に連絡してください。
KFPS02101-I
pd_spd_syncpoint_skip_limit is too small,assumed limit 2,server=aa....aa　　（Ｌ）
aa....aaサーバのpd_spd_syncpoint_skip_limitオペランドに1を指定したか，又は自動計算の結果が2未満となりました。pd_spd_syncpoint_skip_limitオペランドに2を仮定して処理を続行します。
aa....aa：サーバ名
(Ｓ)処理を続行します。
[対策]pd_spd_syncpoint_skip_limitオペランドに1を指定した場合は指定値を修正してください。自動計算でこのメッセージが出力された場合は，マニュアル「HiRDB Version 7 システム運用ガイド」の「シンクポイントダンプ有効化のスキップ回数監視機能」を参照して自動計算をやめるかどうかを検討してください。
KFPS02102-E
Unable to start syncpoint dump service aa....aa.reason code=bb....bb　　（Ｅ＋Ｌ）
aa...aaサーバのシンクポイントダンプのサービスを開始できません。
aa....aa：サーバ名
bb....bb：理由コード
理由コードと対策を表に示します。
(Ｓ)HiRDBを停止します。
[対策]理由コード一覧を見て，対策後，再度HiRDBを開始してください。
理由
コード
意味
対策
備考
6
共用メモリプールの容量が要求を満たすのに不十分
保守員に連絡してください。
－
8
77
88
メモリ不足
プロセス固有，及び共用メモリの使用状況を見直してください。
9
解析情報ファイルのオープンエラー
シンクポイントダンプファイルに関する定義を見直してください。
10
105
解析処理中に続行できないエラー発生
15
36
ネットワーク障害が発生
エラーの原因を調査し，対策後システムを再起動してください。
24
定義の読み込みに失敗
既に出力されているメッセージによって対策してください。
28
メモリ不足
プロセス固有，及び共用メモリ使用状況を見直してください。
33
34
ネームサービス機能で内部矛盾を検知しました。
保守員に連絡してください。
35
タイムアウト
エラーの原因を調査し，対策後システムを再起動してください。
37
ネームサービス機能の利用不可
HiRDBのコマンドでサーバの実行状態を調べてください。
38
50
79
プロセス間通信エラー
エラーの原因を調査し，対策後システムを再起動してください。
41
ステータスファイル入出力エラー
43
作業領域の確保不可
プロセス固有，及び共用メモリ使用状況を見直してください。
44
バッファ面数不足
サーバ定義の内容を見直してください。
45
要求サイズ分のレコードの確保不可（ステータスファイル容量不足）
47
ステータスサーバの未動作
HiRDBのコマンドでステータスサーバの実行状態を調べてください。
52
スワップ処理エラー
エラーの原因を調査し，対策後システムを再起動してください。
72
ステータス書き込みエラー
73
ステータス読み込みエラー
74
定義解析エラー
直前に出力されているKFPUメッセージを参照して対策してください。メッセージが出力されていない場合，保守員に連絡してください。
76
内部ファイル書き込みエラー
エラー原因を調査し，対策後システムを再起動してください。
89
定義ファイル名二重定義
サーバ定義の内容を見直し，正しく設定した後，システムを再起動してください。
92
ファイルオープン失敗
エラーの原因を調査し，対策後システムを再起動してください。
エラーの詳細は，KFPS02122-Wに表示されます。
94
解析でエラー発見
定義ファイルを見直し，正しく設定した後，システムを再起動してください。
－
104
メッセージキュー不足（Windows NT版の場合，インストールドライブの容量不足）
カーネルを再度コンフィグレーションしてください。その際メッセージ関連パラメタのmsgmniの値を変更してください。
Windows NT版の場合，HiRDBのインストールドライブに，共用メモリサイズ以上の空き容量を確保してください。
KFPS02104-W
Unable to recover the previous syncpoint dump service status from status file;continues recovery processing without status file,reason code=aa....aa　　（Ｌ）
前回のシンクポイントダンプをステータスファイルから回復できません。ステータスファイルなしで回復を続行します。
aa....aa：理由コード
理由コードと対策を表に示します。
(Ｓ)シンクポイントダンプを取得しないサーバはシステムログからの再開始ができないので，正常開始します。
[対策]理由コード一覧を見て対策してください。
理由コード
意味
対策
46
回復に使用するステータスのレコードがありません。
サーバ定義の内容を見直してください。
90
ステータスファイルの内容が不正です。
93
リソースのランIDが不正です。
前回のHiRDBで使用していた定義と同一か見直してください。
KFPS02105-W
Error occurred while terminating syncpoint dump service;continutes processing.reason code=aa....aa　　（Ｌ）
シンクポイントダンプのサービス終了処理中に障害が発生しましたが，このまま続行します。
aa....aa：理由コード
(Ｓ)処理を続行します。
[対策]理由コード一覧を見て対策してください。
理由コード
意味
対策
28
プロセス固有領域が確保できません。
共用メモリが不足しています。
プロセス固有，及び共用メモリ使用状況を見直してください。
35
タイムアウトが発生しました。
エラーの原因を調査し，対策後システムを起動してください。
36
ネットワーク障害が発生しました。
37
ネームサービス機能を利用できません。
HiRDBのコマンドでサーバの実行状態を調べてください。
38
プロセス間通信エラー
次回の起動時に備えエラーの原因を調査し，対策後システムを再起動してください。
KFPS02110-E
Process-specific area found insufficient while performing syncpoint dump service for aa....aa service.　　（Ｌ）
aa....aaサーバのシンクポイントダンプのサービス実行中に，プロセス固有領域の不足が発生しました。
aa....aa：サーバ名
(Ｓ)HiRDBを停止します。
[対策]プロセス固有領域の使用状況を調査した後，HiRDBを再度開始してください。
KFPS02111-E
Error occurred while performing syncpoint dump service for aa....aa service.reason code=bb....bb function：cc....cc　　（Ｌ）
aa....aaサーバのシンクポイントダンプ取得中に障害が発生しました。
aa....aa：サーバ名
bb....bb：理由コード
cc....cc：エラーが発生した関数名
(Ｓ)異常終了します。
[対策]理由コード一覧を見て対策後，HiRDBを再度開始してください。また，保守員への連絡が必要であれば，障害情報の資料を取得して，保守員へ連絡してください。
理由コード
意味
対策
4
共用メモリのアクセスができません。
保守員に連絡してください。
11
引数が誤っています。
12
関数の発行順序エラーが発生しました。
13
致命的又は予期しないエラーが発生しました。
「RPC関連エラーの詳細コード」の-303を参照してください。
14
メモリが不足しています。
メモリの使用量を見直してください。
15
ネットワーク障害が発生しました。
以下の手順でエラーの原因を調査し，対策してください。
1. OSのコマンドでサーバマシンの接続状態を調べてください。
2. HiRDBのコマンドで各サーバの実行状態を調べてください。
16
送受信タイムアウトが発生しました。
17
入力パラメタ長が限界値を超えています。
18
返ってきた応答がコール元のエリアに入りきりません。
19
該当するサービス機能は未登録です。
20
サーバは終了中です。
21
該当するサービス機能を提供するプロセスがありません。
22
25
予期しないエラーが発生しました。
23
RPC環境が開始されていません。
26
ネーム情報の検索エラーが発生しました。
保守員に連絡してください。
27
引数の指定に誤りがあります。
28
プロセス固有領域が確保できません。
共用メモリが不足しました。
プロセス固有，及び共用メモリ使用状況を見直してください。
29
関数と共用メモリ間，又は関数とサーバ間のバージョンが不一致です。
以下の手順でエラーの原因を調査し，対策してください。
1. OSのコマンドでサーバマシンの接続状態を調べてください。
2. HiRDBのコマンドで各サーバの実行状態を調べてください。
30
33
34
ネームサービス機能で内部矛盾を検知しました。
保守員に連絡してください。
31
関数のパラメタエラーが発生しました。
以下の手順でエラーの原因を調査し，対策してください。
1. OSのコマンドでサーバマシンの接続状態を調べてください。
2. HiRDBのコマンドで各サーバの実行状態を調べてください。
32
関数の発行手順エラーが発生しました。
35
タイムアウトが発生しました。
エラーの原因を調査し，対策後システムを再起動してください。
36
ネットワーク障害が発生しました。
37
ネームサービス機能を利用できません。
HiRDBのコマンドでサーバの実行状態を調べてください。
38
79
プロセス間通信エラーが発生しました。
次回の起動時に備えエラーの原因を調査し，対策後システムを再起動してください。
39
ステータスが不正です（サーバ未起動，異常終了中，強制停止中）。
80
84
86
87
配列の大きさとして指定された（した）値が定義の最大値を超えています。
保守員に連絡してください。
81
82
領域を確保できません。
メモリの使用量を見直してください。
83
データ変換中にエラーが発生しました。
保守員に連絡してください。
85
関数から受信した電文が短いため，引数に分解できません。
109
110
データベースバッファの掃き出し処理でタイムアウトを検出しました。
$PDDIR/spool下の保守資料を保存して，保守員に連絡してください。その後システムを再起動してください。
111
112
データベースバッファの同期合わせ処理でタイムアウトが発生しました。
KFPS02112-W
Minor error occurred while analyzing definitions for syncpoint dump service. file being analyzed:aa....aa, record number=bb....bb, reason code=cc....cc　　（Ｌ）
シンクポイントダンプサービス機能に関係する定義解析中に，軽度エラーが発生しました。
aa....aa：解析中の定義ファイル名
bb....bb：エラーのあったレコード番号
cc....cc：障害の内容を示す理由コード
(Ｓ)エラーのあったpdlogadfg，又はpdlogadpfオペランドの定義文を無視して，シンクポイントダンプサービス機能の開始，又は再開始処理を続行します（定義文がないものとして動作します）。
[対策]理由コード一覧を参照して，シンクポイントダンプサービス機能に関係する定義を見直してください。
理由コード
意味
対策
411
pdlogadpfオペランドの-aオプション指定に誤りがあります。
・-aオプションに指定したパス長が制限文字数を超えています。
・-aオプションに指定したHiRDBファイル名の長さが制限（30文字）を超えています。
必要に応じてシステムを停止し定義を修正した後，再開始してください。
412
pdlogadpfオペランドの-bオプション指定に誤りがあります（二重化シンクポイントダンプ使用時）。
・-bオプションに指定したパス長が制限文字数を超えています。
・-bオプションに指定したHiRDBファイル名の長さが制限（30文字）を超えています。
KFPS02114-E
File error occurred while getting information necessary for aa....aa service recovery.　　（Ｌ）
aa....aaサーバの回復に必要な情報取得時にファイル障害が発生しました。
aa....aa：障害が発生したサーバ名
(Ｓ)HiRDBを停止します。
[対策]このメッセージまでに出力されたエラーメッセージの内容と，ファイルの状態を確認した上で，HiRDBを再度開始してください。
KFPS02115-E
File error occurred while getting syncpoint dump for aa....aa service.　　（Ｌ）
aa....aaサーバのシンクポイントダンプの取得中にファイル障害が発生しました。
aa....aa：障害が発生したサーバ名
(Ｓ)HiRDBを停止します。
[対策]このメッセージまでに出力されたエラーメッセージの内容を確認し，ファイルの状態を確認した上で，HiRDBを再度開始してください。
KFPS02118-I
Syncpoint dump file group aa....aa for bb....bb service has been opened　　（Ｌ）
bb....bbサーバのシンクポイントダンプファイルをオープンしました。
aa....aa：シンクポイントダンプファイルのファイルグループ名
bb....bb：サーバ名
(Ｓ)処理を続行します。
KFPS02119-I
Syncpoint dump file group aa....aa for bb....bb service has been closed　　（Ｌ）
bb....bbサーバのシンクポイントダンプファイルをクローズしました。
aa....aa：シンクポイントダンプファイルのファイルグループ名
bb....bb：サーバ名
(Ｓ)処理を続行します。
KFPS02122-W
Error occurred while opening syncpoint dump file group for aa....aa service.file group name:bb....bb,reason code=cccc　　（Ｌ）
aa....aaサーバのシンクポイントダンプファイルのオープン処理で障害が発生しました。
aa....aa：障害が発生したサーバ名
bb....bb：障害が発生したシンクポイントダンプファイルのファイルグループ名
cccc：理由コード
理由コードと対策を表に示します。
(Ｓ)処理を続行します。
[対策]理由コードに対応する対策をしてください。
理由
コード
意味
対策
59
ファイルステータスフラグが不正です。
保守員に連絡してください。
61
ファイル名が不正です。
エラーが発生したサーバのサーバ定義を見直してください。
62
システムファイル用のHiRDBファイルシステム領域にシンクポイントダンプファイルが作成されていません。
システムファイル用のHiRDBファイルシステム領域にシンクポイントダンプファイルを作成してください。
63
シンクポイントダンプファイルがありません。
64
ファイルシステムのバージョンが不一致です。
HiRDBの実行環境を見直してください。
65
ファイルシステムの排他エラーが発生しました。
66
ファイルシステムロックセグメントが不足しました。
メモリ使用量を見直してください。
67
107
ファイルシステムオープン処理で上限値を超えました。
不要なファイルをクローズするか，又はオープンできるファイルの上限値を見直し，必要であればカーネルを再度作成してください。
68
該当するスペシャルファイルに対するアクセス権限がありません。
HiRDB実行環境を見直してください。
69
該当するファイルに対するアクセス権限がありません。
70
ファイルシステム入出力エラー
入出力エラーが発生した原因を調査し対策してください。
71
ファイルシステムのメモリが不足しました。
メモリ使用量を見直してください。
88
メモリ不足
プロセス固有領域の使用状況を見直してください。
92
ファイル検定エラーが発生しました（シンクポイントダンプ用に初期設定されていないか，ほかのサーバ又はHiRDBで使用中のシンクポイントダンプファイルです）。
以下の手順でエラーの原因を調査し，対策してください。
1. シンクポイントダンプファイルのpdlogadpfオペランド，又はシステム共通定義を見直してください。
2. シンクポイントダンプファイル用にHiRDBファイルシステム領域を初期設定して再実行してください。
97
サイズ不正
シンクポイントダンプファイルの容量を見直してください。
98
入出力エラー
入出力エラーが発生した原因を調査し，対策をしてください。
106
ファイル名不正
次に示す原因が考えられます。
・ファイル名に使用できない文字を指定しています。
・HiRDBファイル名の長さが制限（30文字）を超えました。
サーバ定義又はコマンドのオペランドで指定したファイル名を見直してください。
108
ファイル名未登録
pdlogadpfコマンドで該当するファイルグループに対応するファイル名を登録してください。
KFPS02123-W
Error occurred while closing syncpoint dump file group for aa....aa service.file group name:bb....bb,reason code=cccc　　（Ｌ）
aa....aaサーバのシンクポイントダンプファイルのクローズ処理で障害が発生しました。
aa....aa：障害が発生したサーバ名
bb....bb：障害が発生したシンクポイントダンプファイルのファイルグループ名
cccc：理由コード
(Ｓ)処理を続行します。
[対策]理由コードに対応する対策をしてください。
理由
コード
意味
対策
66
ファイルシステムロックセグメント不足
メモリ使用量を見直してください。
70
ファイルシステム入出力エラー
入出力エラーが発生した原因を調査し対策してください。
71
ファイルシステムメモリ不足
メモリ使用量を見直してください。
91
A系及びB系の両方で障害が発生しています。
直前に出力されているKFPS4321-Wメッセージを参照して対策してください。
205
プログラム内部矛盾検知
保守員に連絡してください。
KFPS02124-W
Error occurred while reading from syncpoint dump file for aa....aa service.file group name:bb....bb,generation number=cc....cc,reason code=dddd　　（Ｌ）
aa....aaサーバのシンクポイントダンプファイルの読み込み時に障害が発生しました。
aa....aa：障害が発生したサーバ名
bb....bb：障害が発生したシンクポイントダンプファイルのファイルグループ名
cc....cc：障害が発生した世代番号
dddd：理由コード
(Ｓ)処理を続行します。
[対策]直前にKFPS04323-Wメッセージが出力されている場合は，KFPS04323-Wメッセージを参照して対策してください。直前にKFPS04323-Wメッセージが出力されていない場合は，理由コードに対応する対策をしてください。
理由
コード
意味
対策
1
ファイルの領域を超えるレコード入力要求が発生しました。
保守員に連絡してください。
70
入出力エラーが発生しました。
エラーが発生した原因を調査し対策してください。
201
203
206
208
シンクポイントダンプファイルの入力でエラーを検出しました。
保守員に連絡してください。
KFPS02125-W
Error occurred while writing to syncpoint dump file for aa....aa service.file group name:bb....bb,generation number=cc....cc,reason code=dddd　　（Ｌ）
aa....aaサーバのシンクポイントダンプファイルの書き込み時に障害が発生しました。
aa....aa：障害が発生したサーバ名
bb....bb：障害が発生したシンクポイントダンプファイルのファイルグループ名
cc....cc：障害が発生した世代番号
dddd：理由コード
(Ｓ)処理を続行します。
[対策]直前にKFPS04322-Wメッセージが出力されている場合は，KFPS04322-Wメッセージを参照して対策してください。直前にKFPS04322-Wメッセージが出力されていない場合は，理由コードに対応する対策をしてください。
理由
コード
意味
対策
1
ファイルの領域を超えるレコード出力要求が発生しました。
保守員に連絡してください。
70
入出力エラーが発生しました。
エラーが発生した原因を調査し対策してください。
95
要求したレコード数分のシンクポイントダンプがファイルに書き込めません。
保守員に連絡してください。
202
204
207
209
シンクポイントダンプファイルの出力でエラーを検出しました。
KFPS02126-E
Number of file groups is insufficient for aa....aa service.number of available file groups=bb....bb，number of guaranteed generations=cc....cc　　（Ｌ）
aa....aaサーバのシンクポイントダンプファイルの数が不足しています。aa....aaサーバのシンクポイントダンプファイル数が（保証世代数＋1）を満たしていません。
aa....aa：サーバ名
bb....bb：使用可能なシンクポイントダンプファイルのファイルグループ数
cc....cc：保証世代数
(Ｓ)サーバaa....aaに対するシンクポイントダンプの取得を中断します。
[対策]このメッセージの前に出力される，次に示すメッセージを基に原因を調査してください。
・KFPS02122-W
・KFPS02124-W
・KFPS02127-W
KFPS02127-W
Unable to use syncpoint dump file for aa....aa service due to insufficient file capacity,file group name=bb....bb,system A/B=c,file capacity=dd....dd,size needed for syncpoint dump=ee....ee　　（Ｌ）
aa....aaサーバのシンクポイントダンプファイルの容量が不足しているため使用できません。
aa....aa：サーバ名
bb....bb：ファイルグループ名
c：系種別（a：A系，b：B系）
dd....dd：シンクポイントダンプファイルの容量（レコード数）
ee....ee：シンクポイントダンプファイルの要求レコード数
(Ｓ)処理を続行します。
[対策]cで表示された系のシンクポイントダンプファイルの容量を変更してください。ee....ee に示す要求レコード数を参考にしてください。
KFPS02128-E
Server name aa....aa specified with this command is invalid.　　（Ｅ）
コマンドで指定されたサーバ名が不正です。
サーバ名：aa....aa
aa....aa：サーバ名
(Ｓ)コマンドの実行を中止します。
(Ｏ)サーバ名を正しく入力して，コマンドを再度実行してください。
KFPS02129-E
Syncpoint dump file group name aa....aa specified with this command is invalid.　　（Ｅ）
コマンドで指定されたシンクポイントダンプファイル名が不正です。
aa....aa：ファイルグループ名
(Ｓ)コマンドの実行を中止します。
(Ｏ)シンクポイントダンプファイルのファイルグループ名を正しく入力して，コマンドを再度実行してください。
KFPS02131-E
-g option specified with this command is invalid.　　（Ｅ）
コマンドで指定された-gオプションの指定内容に誤りがあります。
(Ｓ)コマンドの実行を中止します。
(Ｏ)-gオプションを正しく指定して，コマンドを再度実行してください。
KFPS02132-E
Stops command processing due to error.reason code=aa....aa　　（Ｅ）
障害が発生したためコマンド処理を中止します。
aa....aa：障害の内容を示す理由コード
(Ｓ)コマンドの実行を中断します。
[対策]メッセージログファイルに出力されているエラーメッセージを調査し，対策してください。
理由コード
意味
対策
2
共用メモリ関数でパラメタエラーが発生しました。
保守員に連絡してください。
3
要求されたセグメントサイズが共用メモリ全体のプールサイズを超えています。
4
ほかのプロセスの確保したセグメントを共用しようとしましたが，まだほかのプロセスに確保されていません。
HiRDBのコマンドでログ/シンクポイントダンプサービス機能の実行状態を調べ，オンライン状態になってから再度コマンドを実行してください。
5
関数の実行順序エラーが発生しました。
6
共用メモリプールの容量が十分ではありません。
保守員に連絡してください。
7
共用メモリプールの排他処理に失敗しました。
11
引数に誤りがあります。
12
関数の入力順序エラーが発生しました。
13
致命的，又は予期しないエラーが発生しました。
「RPC関連エラーの詳細コード」の-303を参照してください。
14
メモリが不足しました。
メモリの使用量を見直してください。
以下の手順でエラーの原因を調査し，対策してください。
1. OSのコマンドでサーバマシンの接続状態を調べてください。
2. HiRDBのコマンドで各サーバの実行状態を調べてください。
15
ネットワーク障害が発生しました。
16
送受信タイムアウトが発生しました。
18
入力パラメタ長が限界値を超えています。
18
返ってきた応答がコール元のエリアに入りきりません。
19
該当するサービス機能は未登録です。
20
サーバは終了中です。
21
該当するサービス機能を提供するプロセスがありません。
以下の手順でエラーの原因を調査し，対策してください。
1. OSのコマンドでサーバマシンの接続状態を調べてください。
2. HiRDBのコマンドで各サーバの実行状態を調べてください。
22
25
予期しないエラーが発生しました。
23
RPC環境が開始されていません。
26
ネーム情報の検索エラーが発生しました。
保守員に連絡してください。
27
引数の指定に誤りがあります。
28
プロセス固有領域が確保できません。
メモリの使用量を見直してください。
29
関数と共用メモリ間，又は関数とサーバ間のバージョンが不一致です。
以下の手順でエラーの原因を調査し，対策してください。
1. OSのコマンドでサーバマシンの接続状態を調べてください。
2. HiRDBのコマンドで各サーバの実行状態を調べてください。
31
関数のパラメタエラーが発生しました。
32
関数の入力順序エラーが発生しました。
35
タイムアウトが発生しました。
36
ネットワーク障害が発生しました。
37
ネームサービス機能を利用できません。
40
キー値が既にあります。
サーバ定義，又は初期化を見直してください。
41
入出力エラーが発生しました。
入出力エラーの発生した原因を調査し，対策してください。
42
オフセット＋レングスが確保領域の範囲外です。
保守員に連絡してください。
43
作業領域が確保できません。
メモリの使用量を見直してください。
44
バッファ面数が不足しています。
サーバ定義を見直してください。
45
要求サイズ分のレコードを確保できません（ステータスファイル容量不足）。
46
キー値に該当するレコードがありません。
保守員に連絡してください。
47
ステータスサービス機能を実行するサーバが動作中ではありません。
HiRDBのコマンドでサーバの実行状態を調べてください。
48
オフセットが確保領域の範囲外です。
保守員に連絡してください。
49
パラメタ形式が不正です。
50
プロセス間通信エラーが発生しました。
HiRDBのコマンドでサーバの実行状態を調べてください。
51
要求サイズが誤っています。
保守員に連絡してください。
52
スワップ処理エラーが発生しました。
「システム関連エラーの詳細コード」の-1039を参照して対策してください。対策後，HiRDBを開始してください。
53
プロトコルバージョンエラーが発生しました。
保守員に連絡してください。
54
確保済みのキー値でサイズが異なります。
80
84
86
87
配列の大きさとして指定された（した）値が定義の最大値を超えています。
81
82
領域を確保できません。
メモリの使用量を見直してください。
83
データ変換中にエラーが発生しました。
保守員に連絡してください。
85
関数から受信した電文が短いため，引数に分解できません。
96
プログラム内部矛盾を検知しました。
97
ファイル不正
シンクポイントダンプファイルのサイズを見直してください。
入出力エラーが発生した原因を調査し，対策してください。
98
入出力エラー
KFPS02135-E
File group name aa....aa specified in definition file bb....bb is already defined in definition file cc....cc.　　（Ｌ）
定義ファイルaa....aaに指定したファイルグループ名bb....bbはcc....cc定義ファイルで既に定義されています。
aa....aa：エラーが発生した定義ファイル名
bb....bb：ファイルグループ名
cc....cc：既にファイルグループ名が定義されている定義ファイル名
(Ｓ)解析処理を続行し，解析処理終了時ユニットの開始処理を中断します。
[対策]二重となっているファイルグループ名を訂正してください。
KFPS02137-E
Physical file name aa....aa specified in definition file bb....bb is already defined in definition file cc....cc.　　（Ｌ）
定義ファイルaa....aaに指定したファイル名bb....bbは，定義ファイルcc....ccで既に定義されています。
aa....aa：エラーが発生した定義ファイル名
bb....bb：ファイル名
cc....cc：既に定義している定義ファイル名
(Ｓ)解析処理を続行し，解析処理終了時ユニットの開始処理を中断します。
[対策]二重定義となっているファイル名を訂正してください。
KFPS02139-E
Definition file aa....aa contains commands with deleted file group name bb....bb.　　（Ｌ）
シンクポイントダンプ再開始時，定義ファイルaa....aaの内容に，正常開始時の定義から削除したファイルグループ名bb....bbがあります。
aa....aa：エラーが発生した定義ファイル名
bb....bb：ファイルグループ名
(Ｓ)解析処理を続行し，解析処理終了時ユニットの開始処理を中断します。
[対策]削除した世代の定義を回復し，正常開始時と同じにしてください。
KFPS02141-E
File group name aa....aa specified with pdlogadfg is already defined in definition file bb....bb.record number=cc....cc　　（Ｌ）
定義ファイルaa....aaのpdlogadfgに指定したファイルグループ名bb....bbは同定義で既に定義されています。
aa....aa：エラーが発生した定義ファイル名
bb....bb：ファイルグループ名
cc....cc：エラーが発生した定義ファイル中のレコード番号
(Ｓ)解析処理を続行し，解析処理終了時ユニットの開始処理を中断します。
[対策]二重定義となっているファイルグループ名を訂正してください。
KFPS02143-E
Physical file name aa....aa specified with pdlogadpf is already defined in definition file bb....bb.record number=cc....cc　　（Ｌ）
pdlogadpfオペランドに指定したファイル名が重複指定されています。
aa....aa：重複指定しているファイル名
bb....bb：エラーが発生したサーバ定義のファイル名
cc....cc：エラーが発生した定義ファイル中のレコード番号
(Ｓ)処理を終了します。
[対策]重複指定しているファイル名を修正してください。
KFPS02144-E
pdlogadfg does not specify file group name in definition file aa....aa.record number=bb....bb　　（Ｌ）
定義ファイルaa....aaに指定したpdlogadfgにファイルグループ名の指定がありません。
aa....aa：エラーが発生したサーバ定義のファイル名
bb....bb：エラーが発生した定義ファイル中のレコード番号
(Ｓ)解析処理を続行し，解析処理終了時ユニットの開始処理を中断します。
[対策]定義ファイルの記述内容を確認し，訂正してください。
KFPS02145-E
pdlogadpf does not specify file group name in definition file aa....aa.record number=bb....bb　　（Ｌ）
定義ファイルaa....aaに指定したpdlogadpfにファイルグループ名の指定がありません。
aa....aa：エラーが発生したサーバ定義のファイル名
bb....bb：エラーが発生した定義ファイル中のレコード番号
(Ｓ)解析処理を続行し，解析処理終了時ユニットの開始処理を中断します。
[対策]定義ファイルの記述内容を確認し，訂正してください。
KFPS02147-E
pdlogadpf does not specify physical file name in definition file aa....aa.record number=bb....bb　　（Ｌ）
pdlogadpfオペランドにシンクポイントダンプファイル名の指定がありません。
aa....aa：エラーが発生したサーバ定義のファイル名
bb....bb：エラーが発生した定義ファイル中のレコード番号
(Ｓ)処理を終了します。
[対策]次に示すどちらかの対策をしてください。
・シンクポイントダンプファイルを二重化していない場合は，pdlogadpf -d spdオペランドに-aオプションの指定があることを確認してください。
・シンクポイントダンプファイルを二重化している場合は，pdlogadpf -d spdオペランドに-a及び-bオプションの指定があることを確認してください。
KFPS02148-E
File group name specified with pdlogadpf is not defined in definition file aa....aa.record number=bb....bb　　（Ｌ）
シンクポイントダンプ再開始時，定義ファイルaa....aaのpdlogadpfコマンド中で指定されたファイルグループ名bb....bbがpdlogadpfコマンドで定義されていません。
aa....aa：エラーが発生したサーバ定義のファイル名
bb....bb：エラーが発生した定義ファイル中のレコード番号
(Ｓ)解析処理を続行し，解析処理終了時ユニットの開始処理を中断します。
[対策]定義ファイルの記述内容を確認し，訂正してください。
KFPS02149-E
Number of pdlogadfg commands with ONL is insufficient in definition file aa....aa.　　（Ｌ）
シンクポイントダンプ開始時，定義ファイル中にONL指定のpdlogadfgの数が（有効保障世代数＋1）を満たしていません。
aa....aa：エラーが発生したサーバ定義のファイル名
(Ｓ)解析処理を続行し，解析処理終了時ユニットの開始処理を中断します。
[対策]定義ファイルの記述内容を確認し，訂正してください。
KFPS02153-E
Number of pdlogadfg commands exceeds the limit in definition file aa....aa.　　（Ｌ）
定義ファイルaa....aaのpdlogadfgの指定値が上限を超えています。
aa....aa：エラーが発生したサーバ定義のファイル名
(Ｓ)ユニットの開始処理を中断します。
[対策]世代数を30以下に訂正してください。
KFPS02154-E
More than one pdlogadpf command is specified for pdlogadfg -g bb....bb in definition file aa....aa.　　（Ｌ）
定義ファイルaa....aaのpdlogadfg　-g　bb....bbに対応するpdlogadfgが複数指定されています。
aa....aa：エラーが発生したサーバ定義のファイル名
bb....bb：pdlogadfgが複数指定されたファイルグループ名
(Ｓ)ユニットの開始処理を中断します。
[対策]要素数を1世代1要素に訂正してください。
KFPS02155-E
Number of pdlogadpf commands exceeds the limit in definition file aa....aa.　　（Ｌ）
定義ファイルaa...aaのpdlogadpfの指定数が上限値を超えています。
aa....aa：エラーが発生したサーバ定義のファイル名
(Ｓ)ユニットの開始処理を中断します。
[対策]定義ファイルの記述内容を確認し，訂正してください。
KFPS02156-E
pdlogadpf is not specified for pdlogadfg -g bb....bb in definition file aa....aa.　　（Ｌ）
定義ファイルaa....aaのpdlogadfg　-g　bb....bbに対するpdlogadfgがありません。
aa....aa：エラーが発生したサーバ定義のファイル名
bb....bb：pdlogadfgで指定したファイルグループ名
(Ｓ)ユニットの開始処理を中断します。
[対策]定義ファイルの記述内容を確認し，訂正してください。
KFPS02157-E
Shared memory error occured while starting or terminating syncpoint dump service.reason code=aa....aa，function=bb....bb　　（Ｌ）
シンクポイントダンプサービス機能の開始又は終了処理中，共用メモリ障害が発生しました。
aa....aa：理由コード
bb....bb：エラーが発生した関数名
(Ｓ)ユニットの開始処理を中断します。
[対策]理由コード一覧を見て対策してください。
理由コード
意味
対策
4
共用メモリのアクセスができません。
保守員に連絡してください。
6
共用メモリプールの容量が要求を満たすのに不十分です。
KFPS02158-E
Error occurred in status file while starting or terminating syncpoint dump service.reason code=aa....aa,function=bb....bb　　（Ｌ）
シンクポイントダンプサービス機能の開始又は終了処理中に，ステータスファイルに障害が発生しました。
aa....aa：理由コード
bb....bb：エラーが発生した関数名
(Ｓ)ユニットの開始処理を中断します。
[対策]理由コード一覧を見て対策してください。
理由コード
意味
対策
41
入出力エラーが発生しました。
入出力エラーの発生した原因を調査し対策してください。
43
作業領域が確保できません。
メモリの使用量を見直してください。
44
バッファ面数が不足しています。
サーバ定義の内容を見直してください。
45
要求サイズ分のレコードを確保できません（ステータスファイル容量不足）。
47
ステータスサーバが動作中ではありません。
HiRDBのコマンドでサーバの実行状態を調べてください。
50
プロセス間通信エラーが発生しました。
エラーの原因を調査し，対策後システムを再起動してください。
52
スワップ処理エラーが発生しました。
KFPS02159-E
Memory found insufficient while starting or terminating syncpoint dump service.　　（Ｌ）
シンクポイントダンプサービス機能の開始又は終了処理中，メモリ不足が発生しました。
(Ｓ)ユニットの開始処理を中断します。
[対策]メモリ資源を取り過ぎていないか確認してください。不要な資源は解放してください。又は，定義で指定した共用メモリサイズを見直し，対策後，再度起動してください。
KFPS02160-E
Error occurred in system service call while starting or terminating syncpoint dump service.reason code=aa....aa，function=bb....bb　　（Ｌ）
シンクポイントダンプサービス機能の開始又は終了処理中，障害が発生しました。
aa....aa：理由コード
bb....bb：エラーが発生した関数名
(Ｓ)ユニットの開始処理を中断します。
[対策]理由コード一覧を見て対策してください。
理由コード
意味
対策
72
ステータスファイルの書き込みエラーが発生しました。
エラーの原因を調査し，対策してください。
73
ステータスファイルの読み込みエラーが発生しました。
74
該当するサーバの定義解析エラーが発生しました。
サーバ定義の内容を見直し，正しく設定した後システムを再度起動してください。
75
正常終了，計画停止時にサーバが異常終了しました。又は，サーバ異常終了中です。
エラーの原因を調査し，対策してください。
77
メモリが不足しました。
メモリ使用量を見直してください。
78
強制停止しようとしましたが，サーバはクリティカル状態です。
エラーの原因を調査し，対策してください。
79
プロセス間通信エラーが発生しました。
KFPS02167-W
File group specified with the command is already open.　　（Ｅ）
コマンドで指定されたファイルグループは既にオープンされています。
(Ｓ)コマンドの実行を中断します。
(Ｏ)pdloglsコマンドを入力し，ファイル状態を確認してください。
KFPS02168-W
File group specified with the command is already closed.　　（Ｅ）
コマンドで指定されたファイルグループは既にクローズされています。
(Ｓ)コマンドの実行を中断します。
(Ｏ)pdloglsコマンドを入力し，ファイル状態を確認してください。
KFPS02169-E
Failure to open syncpoint dump file.　　（Ｅ）
シンクポイントダンプファイルのオープンに失敗しました。
(Ｓ)コマンドの実行を中断します。
(Ｏ)pdloglsコマンドを入力し，ファイル状態を確認してください。合わせて，メッセージログファイルに出力されるKFPS02122-Wメッセージを基に原因を調査してください。
KFPS02170-E
Failure to close syncpoint dump file.reason code=aa....aa　　（Ｅ）
シンクポイントダンプファイルのクローズに失敗しました。
aa....aa：理由コード
(Ｓ)コマンドの実行を中断します。
(Ｏ)理由コードを参照して，対策してください。
理由コード
意味
対策
91
ファイルシステムでエラーが発生しました。
ログファイルに出力されるKFPS02123-Wメッセージを基に，エラー原因を調査し，対策してください。
99
有効ファイルに対してクローズ要求を出しています。
pdloglsコマンドを入力して，該当するファイルの状態を確認してください。
100
入出力中のファイルに対して，クローズ要求を出しています。
pdloglsコマンドを入力して，最新のシンクポイントダンプファイルが，現用ログをポイントしたことを確認してから，コマンドを再度実行してください。
KFPS02171-E
Unable to perform command processing because there is not enough memory to allocate work area.　　（Ｅ）
作業領域が確保できないため，コマンドが実行できません。
(Ｓ)コマンドの実行を中断します。
[対策]メモリ資源を取り過ぎていないか確認してください。不要な資源は解放してください。又は，定義で指定した共用メモリサイズを見直し，対策後，再度コマンドを入力してください。
KFPS02172-I
There is no information to be displayed about syncpoint dump file.　　（Ｅ）
シンクポイントダンプファイルの表示情報がありません。
pdloglsコマンドで表示するシンクポイントダンプファイルの表示情報がありません。
(Ｓ)コマンド処理を終了します。
(Ｏ)システムがオンライン作動中かを確認してください。又は，サーバの実行状態を確認し，再度コマンドを入力してください。
KFPS02173-E
Status file error occurred during syncpoint dump processing.reason code=aa....aa　　（Ｌ）
シンクポイントダンプ処理でステータスファイル障害が発生しました。
aa....aa：理由コード
(Ｓ)ユニットの開始処理を中断します。
[対策]理由コード一覧を見て対策後，HiRDBを再度開始してください。また，保守員への連絡が必要であれば，障害情報の資料も取得して，保守員に連絡してください。
理由コード
意味
対策
40
キー値が既にあります。
サーバ定義又は初期化を見直してください。
41
入出力エラーが発生しました。
入出力エラーの発生した原因を調査し，対策してください。
42
オフセット＋レングスが確保領域の範囲外です。
保守員に連絡してください。
43
作業領域が確保できません。
メモリの使用量を見直してください。
44
バッファ面数が不足しました。
サーバ定義を見直してください。
45
要求サイズ分のレコードを確保できません（ステータスファイル容量不足）。
46
キー値に該当するレコードがありません。
保守員に連絡してください。
47
ステータスサーバが動作中ではありません。
HiRDBのコマンドでサーバの実行状態を調べてください。
48
オフセットが確保領域の範囲外です。
保守員に連絡してください。
49
パラメタ形式が不正です。
50
プロセス間通信エラーが発生しました。
HiRDBのコマンドでサーバの実行状態を調べてください。
51
要求サイズが誤っています。
保守員に連絡してください。
52
スワップ処理エラーが発生しました。
「システム関連エラーの詳細コード」のコード-1039を参照し，対策をしてください。対策後，HiRDBを開始してください。
53
プロトコルバージョンエラーが発生しました。
保守員に連絡してください。
54
確保済みのキー値でサイズが異なります。
KFPS02174-E
Contents of syncpoint dump file for aa....aa service are invalid,file group name=bb....bb　　（Ｌ）
シンクポイントダンプファイルの内容が不正です。
aa....aa：サーバ名
bb....bb：誤りがあるシンクポイントダンプファイルのファイルグループ名
(Ｓ)処理を続行します。
[対策]bb....bbのシンクポイントダンプファイルを再作成してください。
KFPS02176-I
No syncpoint dump file available for next acquisition.　　（Ｌ）
次回の取得先となるシンクポイントダンプファイルがありません。
[対策]予備のファイルをオープンし，次回のシンクポイントダンプ取得に備えてください。
KFPS02177-I
Number of syncpoint dump files is not enough for aa....aa service recovery；opens all files.　　（Ｌ）
aa....aaサーバの回復に必要なシンクポイントダンプファイルが不足しています。このため，すべてのファイルをオープンします。
aa....aa：サーバ名
KFPS02178-E
Unable to acquire syncpoint dump for assuring syncpoint failure in remote site, server name=aa....aa, group=bb....bb, reason code=cc....cc　　（Ｅ＋Ｌ）
リモートサイトにあるRDエリアのシンクポイントが保証できないため，シンクポイントダンプを取得できません。シンクポイントダンプの取得処理を中断します。
このメッセージが表示されたaa....aaサーバでは，リアルタイムSANレプリケーションが正しく動作していないため，リモートサイトへ送信したデータに矛盾が発生している可能性があります。このままリモートサイトでHiRDBを開始すると，HiRDBが開始できない，データの不整合，データ欠損が発生します。
aa....aa：シンクポイントダンプを取得できないサーバ名
bb....bb：障害を検知したペア論理ボリュームグループ名
cc....cc：理由コード
(Ｓ)処理を続行します。
[対策]理由コードの一覧を参照し，対策してください。HiRDBが稼働している場合，メインサイトとリモートサイトの間に発生したデータ矛盾を取り除くため，障害を対策した後にaa....aaサーバに対してpdlogsyncコマンドを実行してシンクポイントを取得してください。
理由コード
意味
対策
115
116
117
118
119
サーバaa....aaのシンクポイントダンプ取得処理で，グループbb....bbの更新データのコピー待ち合わせを行いましたが，待ち合わせに失敗しました。
直前に表示したKFPS04680-E，KFPS01815-Eメッセージを参照して障害の原因を調査し，対策してください。
KFPS02179-I
Syncpoint dump acquisition opportunities for aa....aa service were skipped.number of skip=bb....bb，log generation number=cc....cc factor code=ddd-ee　　（Ｌ）
シンクポイントダンプを取得する契機になりましたが，前回のログファイルスワップによってシンクポイントダンプを取得中なので，サーバaa....aaのシンクポイントダンプ取得契機を無視しました。
aa....aa：サーバ名
bb....bb：シンクポイントダンプ取得契機を無視した回数の累計
cc....cc：シンクポイントダンプ取得契機を無視したログ世代番号
ddd：シンクポイントダンプ取得契機を無視した要因コード（HiRDBの内部状態を示すコードであり，ユーザは意識する必要はありません）
ee：シンクポイントダンプ取得契機を無視した詳細コード
(Ｓ)処理を続行します。
[対策]このメッセージは，ログファイルのスワップ間隔が短い，又はUAPのトランザクションに対するコミットが遅い場合に出力します。このメッセージが頻繁に出力される場合は，システム定義のpd_log_sdintervalオペランドの値を増やしてください。又は，ログファイルの容量を大きくするなどの対策を実施してください。それでも頻繁に出力される場合は，UAPを見直してください。
このメッセージを出力しても，交代用のログファイルが十分に用意してあれば，オンラインの続行，及び再開始に支障はありません。ただし，再開始時間が多少遅くなることがあります。
KFPS02181-I
Unable to find syncpoint dump file aa....aa service recovery.　　（Ｌ）
サーバaa....aaの回復に使用するシンクポイントダンプファイルがありません。
aa....aa：サーバ名
(Ｓ)メッセージKFPS02102-Eを出力し，HiRDBを停止します。
[対策]このメッセージが出力される前に出力されたエラーメッセージの内容を確認するとともに，前回オンラインで使用していたシンクポイントダンプファイルを使用しているか確認したうえで，HiRDBを再開始してください。
KFPS02182-E
Insufficient memory.size=aa....aa,area type：bb....bb　　（Ｌ）
メモリ不足が発生しました。
aa....aa：確保しようとしたサイズ
bb....bb：メモリ不足が発生した領域の種別
(Ｓ)HiRDBを停止します。
[対策]システム定義を見直し，対策後，HiRDBを再度開始してください。
KFPS02183-I
Syncpoint dump for aa....aa has been acquired to file group bb....bb. log file information：cc....cc, dd....dd, ee....ee. start time=ff....ff, end time=gg....gg.　　（Ｌ＋Ｒ＋Ｓ）
サーバ名aa....aaに対するシンクポイントダンプをbb....bbに取得しました。
aa....aa：サーバ名
bb....bb：取得先となったシンクポイントダンプファイルのファイルグループ
cc....cc：ログファイルのファイルグループ名
dd....dd：ログファイルの世代番号
ee....ee：ログファイルのブロック番号
ff....ff：シンクポイントダンプ取得開始時刻（hh:mm:ss）
gg....gg：シンクポイントダンプ有効化完了時刻（hh:mm:ss）
(Ｓ)処理を続行します。
KFPS02184-E
Unable to close the file group because number of file groups is insufficient.　　（Ｅ）
ファイルグループの数が不足しているためクローズできません。
該当するファイルグループをクローズすると，シンクポイントダンプファイルグループの数が有効保証世代数＋1を満たさなくなり，クローズできません。
(Ｓ)コマンドの実行を中断します。
(Ｏ)pdloglsコマンドを入力し，ファイル状態を確認してください。
KFPS02185-I
aa....aa service is recovered with syncpoint dump of file group bb....bb.　　（Ｌ）
サーバaa....aaをファイルグループ名bb....bbのシンクポイントダンプで回復しました。
aa....aa：サーバ名
bb....bb：ファイルグループ名
KFPS02186-W
aa....aa service could not recovered with effective syncpoint dump.　　（Ｌ）
サーバaa....aaを有効なシンクポイントダンプで回復できません。
aa....aa：サーバ名
(Ｓ)有効世代より前に逆戻りして，読み込みできるシンクポイントダンプからの回復を試みます。
[対策]有効保証世代の読み込みができなくなった原因を調査し，対策してください。
KFPS02187-I
Number of syncpoint dump files is not enough for aa....aa service;continues syncpoint dump processing with file reduced mode　　（Ｌ）
サーバaa....aaのシンクポイントダンプファイル数が不足したため，縮退運転に切り替えます。
aa....aa：サーバ名
[対策]このメッセージの前に出力されるメッセージを基に原因を調査してください。
KFPS02188-I
Number of syncpoint dump files is enough for aa....aa service;continues syncpoint dump processing with normal mode　　（Ｌ）
サーバaa....aaのシンクポイントダンプファイル数が確保できたため，通常運転に切り替えます。
aa....aa：サーバ名
(Ｓ)処理を続行します。
KFPS02189-W
Take measure;syncpoint dump service for aa....aa service is file reduced mode　　（Ｌ）
aa....aaサーバに対するシンクポイントダンプサービス機能は縮退運転中です。至急，対策してください。
aa....aa：サーバ名
(Ｓ)処理を続行します。
[対策]このメッセージの前に出力されるメッセージを基に原因を調査してください。
KFPS02190-E
Number of pdlogadfg commands with ONL exceeds the limit in definition file aa....aa.　　（Ｌ）
定義ファイルaa....aaのpdlogadfgのONL指定数が上限を超えています。
aa....aa：エラーが発生したサーバ定義のファイル名
(Ｓ)HiRDBシステムを停止します。
[対策]サーバ定義で定義ファイル中のONL指定のオペランド（pdlogadfg）を30個以内にして，再度HiRDBを開始してください。
KFPS02191-E
-b option specified with this command is invalid.　　（Ｅ）
-bオプション（B系）の指定に誤りがあります。シンクポイントダンプファイルを二重化したのに-bオプションを指定していません。又は，シンクポイントダンプファイルを二重化していないのに-bオプションを指定しています。
(Ｓ)処理を終了します。
[対策]pd_spd_dualオペランドの指定（シンクポイントダンプファイルを二重化するかどうかの指定）を確認して，コマンドを再度実行してください。
KFPS02192-W
File group specified with the command is already allocate　　（Ｅ）
コマンドで指定されたファイルグループには，既にファイルが割り当てられています。
(Ｓ)コマンドの実行を中止します。
[対策]割り当てるファイルグループを確認し，再度コマンドを実行してください。
KFPS02193-E
Physical file name aa....aa specified with this command is invalid,system A/B=b　　（Ｅ）
コマンドで指定したシンクポイントダンプファイル名に誤りがあります。
aa....aa：ファイル名
ファイル名が149文字以上の場合は，ファイル名の後ろから148文字を出力します。
b：系種別（a：A系，b：B系）
(Ｓ)処理を終了します。
[対策]以下の原因が考えられます。オプションに指定したファイル名を確認してコマンドを再実行してください。
・ファイルパス名が制限文字数を超えています。
・HiRDBファイル名の長さが制限（30文字）を超えています。
・指定したファイル名は，ほかのシンクポイントダンプファイルのファイルグループで使用されています。
KFPS02194-I
Syncpoint dump file group cc....cc for aa....aa service has been allocated physical file bb....bb　　（Ｌ）
サーバaa....aaにシンクポイントダンプファイルを割り当てました。
aa....aa：サーバ名
bb....bb：ファイルグループ名
cc....cc：ファイル名
ファイル名が123文字以上の場合，ファイル名の後ろから122文字を出力します。
(Ｓ)処理を終了します。
KFPS02195-W
Minor error occured while analying definitions for syncpoint dump service, file being　analyzed： aa....aa, record number=bb....bb, reason code=cc....cc　　（Ｅ＋Ｌ）
シンクポイントダンプサービス機能の定義解析中にエラーが発生しました。
aa....aa：解析中の定義ファイル名
bb....bb：エラーのあったレコード番号
cc....cc：障害の内容を示す理由コード
408：pdlogadfgオペランドに誤りがあります（-dオプションが指定されていないと考えられます）。
409：pdlogadpfオペランドに誤りがあります（-dオプションが指定されていないと考えられます）。
(Ｓ)処理を続行します。
[対策]必要があればエラーとなった定義を修正後，再度HiRDBを開始してください。
KFPS02196-W
Server name conflict with status-file.server=aa....aa　　（Ｌ）
システム共通定義のpdstartオペランドでサーバ名を次のようにしましたが，ステータスファイルを初期化していないため，サーバ名称とステータスファイルを対応付けられません。
・サーバ名の変更
・サーバ名の追加
・サーバ名の削除
・サーバ名の記述順序の変更
aa....aa：サーバ名
(Ｓ)新たにステータスファイルの領域を割り当てて，処理を続行します。なお，この場合，ステータスファイルに十分な空き領域がないと，ユニット停止の要因となります。
(Ｏ)次回，ユニットを正常停止した後，次の表に従ってステータスファイルを初期化してください。
変更内容
初期化対策のステータスファイル
pdstartのサーバ名の変更
該当するサーバのステータスファイルを初期化してください。
pdstartのサーバ名の追加，削除，及び記述順序の変更
該当するユニット内のすべてのステータスファイルを初期化してください。
KFPS02200-E
Unable to provide transaction log service for aa....aa service. reason code=bbbb　　（Ｅ＋Ｌ）
サーバaa....aaに対して，トランザクションログサービス機能を提供できません。
aa....aa：サーバ名
bbbb：理由コード
(Ｓ)HiRDBを異常終了します。
[対策]理由コード一覧を見て対策後，再度HiRDBを開始してください。理由コードと対策を次に示します。
理由コード
意味
対策
0001
プロセス固有領域不足発生
プロセス数を少なくしてから，HiRDBを開始してください。引き続き多発する場合は，保守員に連絡してください。
0100
共用メモリ不足発生
保守員に連絡してください。
1001
ステータスファイルの書き込み失敗
このメッセージが出力される前に障害メッセージが出力されている場合，そのメッセージに従って対策してください。障害メッセージが出力されていない場合，保守員に連絡してください。
KFPS02210-E
Insufficient memory. size=aaaaaaaaaa bytes, area type= bb....bb　　（Ｅ＋Ｌ）
メモリ不足が発生しました。
aaaaaaaaaa：確保しようとした領域のサイズ
bb....bb：メモリ不足が発生した領域の種別
DYNAMIC_SHMPOOL：動的共用メモリ
PROCESS：プロセス固有領域
STATIC_SHMPOOL：静的共用メモリ
(Ｓ)処理を中止します。
[対策]
〈メモリ不足が発生した領域の種別が動的共用メモリの場合〉
定義ファイルの指定値を見直し，対策後，再度実行してください。
〈メモリ不足が発生した領域の種別がプロセス固有領域の場合〉
プロセス数を見直し，対策後，再度実行してください。
〈メモリ不足が発生した領域の種別が静的共用メモリの場合〉
時間をおいて再度実行してください。
繰り返し発生する場合，保守員に連絡してください。
KFPS02220-E
Unable to recover transaction due to log error　　（Ｅ＋Ｌ）
HiRDBの全面回復時に，不正なログを検知しました。このため，トランザクションを回復できません。
考えられる原因を次に示します。
・システムログファイルが破壊されました。
・不正なシステムログファイルでHiRDBの全面回復をしようとしました。
(Ｓ)HiRDBを停止します。
(Ｏ)ログファイルを調査して，エラーの要因を取り除いてください。トランザクションを回復するときは，HiRDBを再度開始してください。
KFPS02240-W
aa....aa recovery to last commit point bbbb/cc/dd ee:ff:gg, TRNGID=hh....hh, TRNBID=ii....ii, PROGRAM=jj....jj, INFO_FILE=kk....kk　　（Ｌ）
サーバaa....aaは，bbbb/cc/dd ee:ff:ggにコミットした時点まで，データベースを回復しました。
aa....aa：データベースの回復を行ったサーバ名
bbbb：最新のコミットをした日付(年)
cc：最新のコミットをした日付(月)
dd：最新のコミットをした日付(日)
ee：最新のコミットをした時刻(時)
ff：最新のコミットをした時刻(分)
gg：最新のコミットをした時刻(秒)
hh....hh：最新のコミットをしたトランザクションのグローバル識別子
ii....ii：最新のコミットをしたトランザクションのブランチ識別子
jj....jj：最新のコミットをしたトランザクションのPDCLTAPNAMEの値（ユティリティの場合は"****"が表示されます）
kk....kk：トランザクション情報ファイル名
(Ｓ)処理を続行します。
[対策]コミットをした時刻，及びトランザクション情報ファイルから最新のデータベースに回復できているかを確認してください。トランザクション情報ファイルでの確認方法については，マニュアル「HiRDB Version 7 システム運用ガイド」を参照してください。確認した結果，最新のデータベースに回復できていない場合は，回復できていないデータの更新を再度実行してください。
KFPS02254-E
Unable to start transaction log service. reason code=aaaa　　（Ｅ＋Ｌ）
トランザクションログサービス機能の開始中に理由コードに示すエラーが発生しました。そのため，トランザクションログサービス機能を開始できません。
aaaa：理由コード
(Ｓ)HiRDBを異常終了します。
[対策]理由コード一覧に従って対策し，再度HiRDBを開始してください。
理由コードと対策を次に示します。
理由コード
意味
対策
0001
プロセス固有領域不足発生
プロセス数を少なくしてから，再度HiRDBを開始してください。再度このメッセージが出力される場合は，保守員に連絡してください。
0100
共用メモリ不足発生
保守員に連絡してください。
0200
定義解析開始処理でエラー発生
このメッセージの前に障害メッセージが出力されている場合，そのメッセージに従って対策してください。
障害メッセージが出力されていない場合，保守員に連絡してください。
0201
システム共通定義又はユニット制御情報定義解析処理でエラー発生
0300
通信障害発生
「RPC関連エラーの詳細コード」を参照して対策してください。
0301
タイムアウト発生
0600
ネームサービス機能にサービス情報登録失敗
このメッセージの前に障害メッセージが出力されている場合，そのメッセージに従って対策してください。
障害メッセージが出力されていない場合，保守員に連絡してください。
1000
ステータスファイルの読み込み失敗
1001
ステータスファイルの書き込み失敗
1002
ステータスファイルの確保に失敗
KFPS02255-E
Error occurred while terminating transaction log service； continues processing. reason code=aaaa　　（Ｅ＋Ｌ）
トランザクションログサービス機能の終了中に，理由コードに示すエラーが発生したが，終了処理を続行します。
aaaa：理由コード
(Ｓ)HiRDBを異常終了します。
[対策]理由コード一覧に従って対策し，次のHiRDB開始時に備えてください。
理由コードと対策を次に示します。
理由コード
意味
対策
0001
プロセス固有領域不足発生
プロセス数を少なくしてから，再度HiRDBを開始してください。再度このメッセージが出力される場合は，保守員に連絡してください。
0100
共用メモリ不足発生
保守員に連絡してください。
0601
ネームサービス機能にサービス情報削除失敗
このメッセージの前に障害メッセージが出力されている場合，そのメッセージに従って対策してください。障害メッセージが出力されていない場合，保守員に連絡してください。
1001
ステータスファイルの書き込み失敗
1003
ステータスファイルの解放に失敗
KFPS02256-E
Unable to continue transaction log service.reason code=aaaa　　（Ｅ＋Ｌ）
トランザクション対応のシステムログ入出力に関するサービスを続行できません。
aaaa：理由コード
2000：シンクポイントダンプ入出力サービスが使用できません。
2001：シンクポイントダンプ入出力サービスの開始時に誤りがあります。
2003：シンクポイントダンプファイルの入出力ができません。
(Ｓ)HiRDBを異常終了します。
(Ｏ)このメッセージの前後にシンクポイントダンプ入出力サービスに関する次のメッセージが出力されていれば，そのメッセージの処置に従って，対策した後，再度実行してください。
・KFPS021xx-y
（ただし，xxは00～99，yはE，W，又はIのどれかを表します）
シンクポイントダンプ入出力サービスに関するメッセージが出力されていない場合は，HiRDB管理者に連絡してください。
[対策]メッセージログを参照して，シンクポイントダンプ入出力サービスに関するエラー以外に，何らかのエラーメッセージが出力されていないか調査してください。エラーの原因が判明した場合は，対策後再度実行してください。
上記に該当しない場合は，保守員に連絡してください。
KFPS03302-E
Unable to start interval service. reason code=aaaa　　（Ｅ＋Ｌ）
インタバルサービス機能を開始できません。
aaaa：理由コード
200：通信不正
300：メモリ不足
400：共用メモリ不足
500：システム不正
600：ステータス（ファイル）不正
700：adm不正
(Ｓ)処理を終了します。
(Ｏ)システム管理者に連絡し，理由コードに示す内容に対して処置した後，HiRDBシステムを再度開始してください。
[対策]理由コードに示す内容に対して，処置してください。
KFPS03700-E
Error occurred in XA interface, func=aa....aa,reason=bb....bb, code=cc....cc　　（Ｒ）
XAインタフェースで異常が発生しました。
aa....aa：エラーが発生した機能名
bb....bb：障害の種別を示す文字列
SVR PROC：トランザクションの決着処理時にHiRDBサーバで異常が発生しました。
SQL ERR：SQL処理で異常が発生しました。
CLT ENV：XAインタフェースを使用するための環境設定時に異常が発生しました。
RPC INIT：通信環境の初期化時に異常が発生しました。
RPC CALL：通信実行時に異常が発生しました。
TRN OPEN：トランザクションの回復処理中の通信路確保時に異常が発生しました。
TRN CMIT：トランザクションの回復処理（コミット）時にHiRDBサーバで異常が発生しました。
TRN ROLB：トランザクションの回復処理（ロールバック）時にHiRDBサーバで異常が発生しました。
TRN WAIT：トランザクションの回復処理終了監視時にHiRDBサーバで異常が発生しました。
TRN RCV：未決着トランザクション情報取得時にHiRDBサーバで異常が発生しました。
AX FUNC：トランザクション開始，再開始時に異常が発生しました。
AX TRID：トランザクション開始，再開始時のトランザクションIDが不正です。
TXA OPEN：リソースマネジャのオープン時に異常が発生しました。
TXA STAT：トランザクション開始，再開始時に異常が発生しました（マルチスレッド対応のXAインタフェースを使用している場合）。
TXA CLOS：リソースマネージャのクローズ時に異常が発生しました。
TXA ENV：トランザクションマネジャとの連携で異常が発生しました。
cc....cc：障害の原因を示すコード
(Ｓ)処理を続行します。
(Ｐ)又は(Ｏ)障害の原因を示すコードに従って，対策してください。
エラーの種別
障害の原因を示すコード
意味
対策
SVR　PROC
-902
不当にロールバックが発生しました。
保守員に連絡してください。
SQL　CODE
SQLコード
該当するSQLコードの説明を参照してください。
該当するSQLコードの説明を参照して，対策してください。
CLT　ENV
-1
クライアント環境定義のPDXAMODEに0又は１以外の値が指定されています。
クライアント環境定義PDXAMODEには０又は１を指定してください。PDXAMODEについては，マニュアル「HiRDB Version 7 UAP開発ガイド」を参照してください。
-10
クライアント環境定義の指定値が正しくありません。
マニュアル「HiRDB Version 7 UAP開発ガイド」を参照し，クライアント環境定義の指定値が正しいかどうかを確認してください。
TXA　CLOS
-6
トランザクションマネジャとHiRDBクライアントで，トランザクション移行の設定がそれぞれ異なっています。
トランザクションマネジャとHiRDBクライアントの設定を合わせてください。HiRDBクライアントのトランザクション移行はクライアント環境定義のPDXAMODEで設定します。トランザクションの移行については，マニュアル「HiRDB Version 7 システム導入・設計ガイド」を参照してください。
RPC　INIT
-2403
初期化に失敗しました。
サーバが起動されていないなどの原因が考えられます。サーバ状態を確認してください。
-2415
HiRDBサーバが開始されていません。
RPC　CALL
-2404
メモリが不足しました。
ネットワーク障害，又はサーバが起動されていないなどの原因が考えられます。ネットワーク状態，又はサーバ状態を確認してください。
-2406
-2418
ネットワーク障害が発生しました。
-2407
送受信タイムアウトが発生しました。
-2410
-2411
-2414
-2415
HiRDBサーバが開始されていません。
-2412
-2413
-2432
HiRDBサーバが停止処理中です。
-2416
HiRDBサーバでシステムエラーが発生しました。
-2417
HiRDBサーバでメモリが不足しました。
-2420
HiRDBサーバを開始中です。
-2431
HiRDBサーバへの接続数が最大同時接続数を超えました。
TRN　OPEN
-99
HiRDBサーバの開始中です。
ネットワーク障害，又はHiRDBサーバが開始していないなどの原因が考えられます。ネットワークの状態，又はHiRDBサーバの状態を確認してください。
100
待機系HiRDBに接続しています。
OLTP製品のクライアント環境変数HiRDB_PDHOSTに実行系のホスト名を指定しているか確認してください。
実行系のホスト名を指定している場合は，HiRDBクライアントのバージョンが06-02-/A以前でないか確認してください。06-02-/A以前の場合，現用系のユニットが待機系になっているときにこのコードが出力されることがあります。この場合，HiRDBクライアントを06-02-/B以降にバージョンアップしてください。すぐにバージョンアップできない場合は，現用系のユニットを待機系から実行系に切り替えてください。
TRN　CMIT
TRN　ROLB
TRN　WAIT
TRN　RCV
-4
ホスト間通信の不正です。
サーバが起動されていないなどの原因が考えられます。サーバ状態を確認してください。
-6
不当にロールバックが発生しました。
保守員に連絡してください。
-7
該当するトランザクションがHiRDBにありません。
該当するトランザクションはHiRDBで独自に決着しました。OLTP側のトランザクションの状態を確認してください。
100
待機系HiRDBに接続しています。
OLTP製品のクライアント環境変数HiRDB_PDHOSTに実行系のホスト名を指定しているか確認してください。
実行系のホスト名を指定している場合は，HiRDBクライアントのバージョンが06-02-/A以前でないか確認してください。06-02-/A以前の場合，現用系のユニットが待機系になっているときにこのコードが出力されることがあります。この場合，HiRDBクライアントを06-02-/B以降にバージョンアップしてください。すぐにバージョンアップできない場合は，現用系のユニットを待機系から実行系に切り替えてください。
AX　FUNC
-1
OLTP側で異常が発生しました。
OLTP側の状態を確認してください。
-3
発行順序が不正です。
アプリケーションプログラムがトランザクションのサービスを受けていないことが考えられます。アプリケーションプログラムを確認してください。
AX　TRID
-1
トランザクションID内のデータが不正です。
OLTP側の状態を確認してください。
-2
トランザクションIDが指定されていません。
TXA　OPEN
-2
プロセス当たりで同時に接続できるコネクションの数がトランザクション最大同時実行数を超えました。
トランザクション最大同時実行数を確認してください。トランザクションの最大同時実行数はクライアント環境定義PDTXACANUMで設定します。
-3
マルチスレッド対応のXAインタフェースを使用して，HiRDBサーバに接続できません。
マルチスレッド対応のXAインタフェースを使用してHiRDBサーバに接続できるように，HiRDBサーバをバージョンアップしてください。
TXA　STAT
-2
1プロセスが同時に実行できる最大トランザクション数を超えました。
トランザクション最大同時実行数を確認してください。トランザクション最大同時実行数はクライアント環境定義PDTXACANUMで指定します。
-3
マルチスレッド対応のXAインタフェースを使用して，HiRDBサーバに接続できません。
マルチスレッド対応のXAインタフェースを使用してHiRDBサーバに接続できるように，HiRDBサーバをバージョンアップしてください。
TXA　ENV
-1
Cosminexusからスタンダード・アドバンスドモードでデータソースを使用してHiRDBに接続する場合，CosminexusのデータソースのXA Open Stringが未設定，又は形式が不正なため，設定が無視されています。また，クライアント環境定義PDUSERが未設定です。
CosminexusのデータソースのXA Open Stringの設定，及びクライアント環境定義PDUSERを確認してください。
-2
OpenTP1/Server Base Enterprise OptionからHiRDBに接続する場合，xa_open関数用の文字列が未設定，又は形式が不正なため，設定が無視されています。また，クライアント環境定義PDUSERが未設定です。
OpenTP1/Server Base Enterprise Optionのxa_open関数用文字列の設定，及びクライアント環境定義PDUSERを確認してください。
KFPS04128-I
Usage： pdlogadpf -d spd [-s server_name] -g file_group_name -a physical_file_name　　（Ｅ）
HiRDB/シングルサーバでのpdlogadpfコマンドの使用方法を示します。コマンドの形式が誤っている場合に出力します。
KFPS04128-I
Usage： pdlogadpf -d spd -s server_name -g file_group_name -a physical_file_name　　（Ｅ）
HiRDB/パラレルサーバでのpdlogadpfコマンドの使用方法を示します。コマンドの形式が誤っている場合に出力します。
KFPS04160-E
Specification of aa option required.　　（Ｅ）
必要なオプションの指定が不足しています。
aa：オプション名
(Ｓ)処理を終了します。
[対策]必要オプションを追加して再実行してください。
KFPS04161-E
Argument of aa option is invalid.　　（Ｅ）
オプション引数の不足，又は指定が誤っています。
aa：オプション名
(Ｓ)処理を終了します。
[対策]正しいオプションを指定して再実行してください。
KFPS04162-W
Unable to specify aa option. ignored.　　（Ｅ）
指定できないオプションを指定しています。無視します。
aa：オプション名
(Ｓ)処理を続行します。
[対策]不要なオプションは削除してください。
KFPS04163-E
Specified hostname conflicts with the server name.　　（Ｅ）
指定したホスト名と，指定したHiRDBサーバと対応するホスト名が異なります。
(Ｓ)処理を終了します。
[対策]ホスト名の指定を省略するか，又は，HiRDBサーバに対応したホスト名を指定してください。
KFPS04164-E
Server name must be equal to SDS’s name for single server.　　（Ｅ）
HiRDB/シングルサーバでは，サーバ名にシングルサーバのサーバ名を指定します。
(Ｓ)処理を終了します。
[対策]HiRDB/シングルサーバではサーバ名の指定は省略できるため，指定しないか，正しいHiRDBのサーバ名を指定してください。
KFPS04165-E
Hostname must be equal to SDS hostname for single server.　　（Ｅ）
HiRDB/シングルサーバでは，ホスト名はシングルサーバと対応するホスト名を指定します。
(Ｓ)処理を終了します。
[対策]HiRDB/シングルサーバではホスト名の指定は省略できるため，指定しないか，正しいホスト名を指定してください。
KFPS04170-E
Failed to open (unload) log file(aa....aa). reason code=bbbbbb.　　（Ｅ）
ログファイル，又はアンロードログファイルのオープンに失敗しました。
aa....aa：ファイル名
ファイル名が164文字以上の場合は，ファイル名の後ろから163文字を出力します。
bbbbbb：pdi_ofl_open()，又はp_f_ios_open()の戻り値
(Ｓ)処理を続行します。
KFPS04171-E
Unable to get server name because specfication of ‘pdstart’ operand is invalid in system definition file.　　（Ｅ）
システム共通定義のpdstartオペランドに誤りがあります。このため，サーバ名を取得できません。
(Ｓ)処理を終了します。
[対策]pdstartオペランドの指定を修正して，再度実行してください。
KFPS04172-E
Unable to execute command due to failure of aa....aa system call(command), code=bb....bb　　（Ｅ）
aa....aaシステムコール（コマンド）のエラーが要因で，コマンドの実行ができません。
ログコマンドで呼び出す内部コマンドの起動に失敗した場合に出力されます。
aa....aa：エラーとなったシステムコール，又はコマンド
{ exec | fork | rsh rcp}
bb....bb：システムコール，又はrshの戻り値に対する内部コード
(Ｓ)処理を終了します。
[対策]環境変数，又はHiRDBシステム定義を見直して，再度実行してください。
KFPS04173-E
Specified hostname invalid in 'pdstart' operand.　　（Ｅ）
システム共通定義のpdstartオペランドに指定したホスト名が誤っています。
(Ｓ)処理を終了します。
(Ｏ)システム共通定義を修正後，再度実行してください。
[対策]システム共通定義のpdstartオペランドに指定しているホスト名を修正してください。
KFPS04178-E
Unable to specify aa option　　（Ｅ）
aaオプションは指定できません。
aa：オプション名
(Ｓ)処理を終了します。
(Ｏ)aaオプションを指定しないでコマンドを再度実行してください。
KFPS04179-E
Unit ID aaaa is invalid　　（Ｅ）
コマンドのオプションに指定したユニット識別子が不正です。
aaaa：ユニット識別子
(Ｓ)処理を終了します。
(Ｏ)ユニットaaaaが影響分散スタンバイレス型系切り替えのHAグループに属しているかどうか確認してください。HAグループに属していない場合，HAグループに属しているユニットのユニット識別子を指定して，コマンドを再度実行してください。
KFPS04200-E
(Specification of aa option required.)　　（Ｅ）
必要なオプションの指定が不足しています。
aa：オプション名
(Ｓ)処理を終了します。
[対策]必要オプションを追加して再度実行してください。
KFPS04201-E
Argument of aa option is invalid.　　（Ｅ）
オプション引数の不足，又は指定が誤っています。
aa：オプション名
(Ｓ)処理を終了します。
[対策]正しいオプションを指定して再度実行してください。
KFPS04202-E
One of aa....aa options must specified　　（Ｅ）
複数あるオプションのうちどれか一つの指定が必要です。
aa....aa：コンマで区切られたオプションのリスト
(Ｓ)処理を終了します。
[対策]どれか一つのオプションを指定して再度実行してください。
KFPS04203-E
Only of aa....aa options can specified.　　（Ｅ）
複数のオプションのうちどれか一つだけが指定できます。
排他オプション同士を同時に指定した場合に出力します。
aa....aa：コンマで区切られたオプションのリスト
(Ｓ)処理を終了します。
[対策]どれか一つだけオプションを指定して再度実行してください。
KFPS04204-E
Specified hostname conflicts with the server name.　　（Ｅ）
指定したホスト名と，指定したHiRDBサーバと対応するホスト名が矛盾します。
(Ｓ)処理を終了します。
[対策]ホスト名の指定は省略できるため，指定を削除するか，HiRDBサーバに対応したホスト名を指定してください。
KFPS04205-E
Server name must be equal to SDS's name for single server.　　（Ｅ）
HiRDB/シングルサーバでは，サーバ名はシングルサーバのサーバ名を指定します。
HiRDB/シングルサーバでは，HiRDBサーバは一つなので省略できますが，指定をして，かつ，定義されたシングルサーバ名と矛盾があった場合はこのメッセージを出力します。
(Ｓ)処理を終了します。
[対策]HiRDB/シングルサーバではサーバ名指定は省略できるため，指定しないか，正しいHiRDBのサーバ名を指定してください。
KFPS04206-E
Hostname must be equal to SDS hostname for single server.　　（Ｅ）
HiRDB/シングルサーバでは，ホスト名はシングルサーバのホスト名を指定します。
HiRDB/シングルサーバでは，一つのホスト内で閉じているのでホスト名指定は省略できますが，指定をして，かつ，自ホスト名と矛盾があった場合はこのメッセージを出力します。
(Ｓ)処理を終了します。
[対策]HiRDB/シングルサーバではホスト名指定は省略できるため，指定しないか，正しいホスト名を指定してください。
KFPS04207-E
Unable to get server name because specfication of `pdstart' operand is invalid in system definition file.　　（Ｅ）
システム共通定義のpdstartオペランドに誤りがあります。このため，サーバ名を取得できません。
(Ｓ)処理を終了します。
[対策]システム共通定義のpdstartオペランドの指定を修正して，再度実行してください。
KFPS04208-E
Unable to execute command due to failure of aa....aa system call(command), code=bb....bb　　（Ｅ）
aa....aaシステムコール（コマンド）のエラーが要因で，コマンドの実行ができません。
ステータスログコマンドで呼び出す内部コマンドの起動に失敗した場合に出力されます。
aa....aa：エラーとなったシステムコール，又はコマンド
{ exec | fork | rsh }
bb....bb：システムコール，又はrshの戻り値に対する内部コード
(Ｓ)処理を終了します。
[対策]環境変数，又はシステム定義ファイルを見直して，再度実行してください。
KFPS04209-E
Specified hostname invalid in 'pdstart' operand.　　（Ｅ）
システム共通定義のpdstartオペランドに指定したホスト名が誤っています。
(Ｓ)処理を終了します。
(Ｏ)システム共通定義を修正後，再度実行してください。
[対策]pdstartオペランドに指定しているホスト名を修正してください。
KFPS04320-W
Failure to open syncpoint dump file for aa....aa service,file group name=bb....bb,system A/B=c,reason code=dddd　　（Ｌ）
シンクポイントダンプファイルのオープンに失敗しました。ファイルのオープンができません。
aa....aa：サーバ名
bb....bb：シンクポイントダンプファイルのファイルグループ名
c：系種別（a：A系，b：B系）
dddd：理由コード
(Ｓ)処理を続行します。
[対策]理由コードに対応する対策をしてください。
理由
コード
意味
対策
59
ファイルステータスフラグが不正です。
保守員に連絡してください。
61
ファイル名が不正です。
エラーが発生したサーバのサーバ定義を見直してください。
62
システムファイル用のHiRDBファイルシステム領域にシンクポイントダンプファイルが作成されていません。
システムファイル用のHiRDBファイルシステム領域にシンクポイントダンプファイルを作成してください。
63
シンクポイントダンプファイルがありません。
64
ファイルシステムのバージョンが不一致です。
HiRDBの実行環境を見直してください。
65
ファイルシステムの排他エラーが発生しました。
66
ファイルシステムロックセグメントが不足しました。
メモリ使用量を見直してください。
67
107
ファイルシステムオープン処理で上限値を超えました。
不要なファイルをクローズするか，又はオープンできるファイルの上限値を見直し，必要であればカーネルを再度作成してください。
68
該当するスペシャルファイルに対するアクセス権限がありません。
HiRDB実行環境を見直してください。
69
該当するファイルに対するアクセス権限がありません。
70
ファイルシステム入出力エラー
入出力エラーが発生した原因を調査し対策してください。
71
ファイルシステムのメモリが不足しました。
メモリ使用量を見直してください。
88
メモリ不足
プロセス固有領域の使用状況を見直してください。
92
ファイル検定エラーが発生しました（シンクポイントダンプ用に初期設定されていないか，ほかのサーバ又はHiRDBで使用中のシンクポイントダンプファイルです）。
以下の手順でエラーの原因を調査し，対策してください。
1. シンクポイントダンプファイルのpdlogadpfオペランド，又はシステム共通定義を見直してください。
2. シンクポイントダンプファイル用にHiRDBファイルシステム領域を初期設定して再実行してください。
97
サイズ不正
シンクポイントダンプファイルの容量を見直してください。
98
入出力エラー
入出力エラーが発生した原因を調査し，対策をしてください。
106
ファイル名不正
次に示す原因が考えられます。
・ファイル名に使用できない文字を指定しています。
・HiRDBファイル名の長さが制限（30文字）を超えました。
サーバ定義又はコマンドのオペランドで指定したファイル名を見直してください。
108
ファイル名未登録
pdlogadpfコマンドで該当するファイルグループに対応するファイル名を登録してください。
KFPS04321-W
Failure to close syncpoint dump file for aa....aa service,file group name=bb....bb,system A/B=c,reason code=dddd　　（Ｌ）
シンクポイントダンプファイルのクローズに失敗しました。ファイルのクローズができません。
aa....aa：サーバ名
bb....bb：シンクポイントダンプファイルのファイルグループ名
c：系種別（a：A系，b：B系）
dddd：理由コード
(Ｓ)処理を続行します。
[対策]理由コードに対応する対策をしてください。
理由
コード
意味
対策
66
ファイルシステムロックセグメント不足
メモリ使用量を見直してください。
70
ファイルシステム入出力エラー
入出力エラーが発生した原因を調査し対策してください。
71
ファイルシステムメモリ不足
メモリ使用量を見直してください。
106
ファイルシステムパスエラー
次に示す原因が考えられます。
・パス名に使用できない文字を指定しています。
・HiRDBファイル名の長さが制限（30文字）を超えました。
ファイル名を正しく指定しているか見直してください。
205
プログラム内部矛盾検知
保守員に連絡してください。
KFPS04322-W
Failure to write to syncpoint dump file for aa....aa service,file group name=bb....bb,system A/B=c,reason code=dddd　　（Ｌ）
シンクポイントダンプファイルの書き込みに失敗しました。ファイルへの書き込みができません。
aa....aa：サーバ名
bb....bb：シンクポイントダンプファイルのファイルグループ名
c：系種別（a：A系，b：B系）
dddd：理由コード
(Ｓ)処理を続行します。
[対策]理由コードに対応する対策をしてください。
理由
コード
意味
対策
1
ファイルの領域を超えるレコード出力要求が発生しました。
保守員に連絡してください。
70
入出力エラーが発生しました。
エラーが発生した原因を調査し対策してください。
95
要求したレコード数分のシンクポイントダンプがファイルに書き込めません。
保守員に連絡してください。
202
204
207
209
シンクポイントダンプファイルの出力でエラーを検出しました。
KFPS04323-W
Failure to read from syncpoint dump filefor aa....aa service,file group name=bb....bb,system A/B=c,reason code=dddd　　（Ｌ）
シンクポイントダンプファイルの読み込みに失敗しました。ファイルの読み込みができません。
aa....aa：サーバ名
bb....bb：シンクポイントダンプファイルのファイルグループ名
c：系種別（a：A系，b：B系）
dddd：理由コード
(Ｓ)処理を続行します。
[対策]理由コードに対応する対策をしてください。
理由
コード
意味
対策
1
ファイルの領域を超えるレコード入力要求が発生しました。
保守員に連絡してください。
70
入出力エラーが発生しました。
エラーが発生した原因を調査し対策してください。
201
203
206
208
シンクポイントダンプファイルの入力でエラーを検出しました。
保守員に連絡してください。
KFPS04370-W
Syncpoint dump file is already closed,system A/B=a　　（Ｌ）
シンクポイントダンプファイルは既にクローズしています。
a：系種別（a：A系，b：B系）
(Ｓ)処理を終了します。
[対策]pdlogls -d spd -eコマンドを実行してシンクポイントダンプファイルの状態を確認してください。
KFPS04371-W
Syncpoint dump file is already opened,system A/B=a　　（Ｌ）
シンクポイントダンプファイルは既にオープンしています。
a：系種別（a：A系，b：B系）
(Ｓ)処理を終了します。
[対策]pdlogls -d spd -eコマンドを実行してシンクポイントダンプファイルの状態を確認してください。
KFPS04372-I
Syncpoint dump file for aa....aa service has been opened,file group name=bb....bb,system A/B=c　　（Ｌ）
aa....aaサーバのシンクポイントダンプファイルをオープンしました。
aa....aa：サーバ名
bb....bb：シンクポイントダンプファイルのファイルグループ名
c：系種別（a：A系，b：B系）
(Ｓ)処理を続行します。
KFPS04373-I
Syncpoint dump file for aa....aa service has been closed,file group name=bb....bb,system A/B=c　　（Ｌ）
aa....aaサーバのシンクポイントダンプファイルをクローズしました。
aa....aa：サーバ名
bb....bb：シンクポイントダンプファイルのファイルグループ名
c：系種別（a：A系，b：B系）
(Ｓ)処理を続行します。
KFPS04605-W
Unable to specify aa....aa operand, ignored　　（Ｌ）
該当するプラットフォームでは指定できない定義を指定しています。
aa....aa：無視される定義
(Ｓ)指定された定義を無視して，処理を続行します。
[対策]定義ファイルから該当する定義を削除して，HiRDBを開始してください。
KFPS04606-W
Unable to connect to event server of JP1　　（Ｌ）
システム共通定義で，JP1と連携するように（pd_jp1_use=Y，かつpd_jp_event_level=2）指定されましたが，JP1のイベントサーバに接続できません。
(Ｓ)処理を続行します。
[対策]JP1/Integrated Managerへイベントを出力する必要がある場合は，接続に失敗した原因を調査し，取り除いてください。JP1/Integrated Manager又はJP1/Baseがインストールされていない可能性があります。
JP1/Integrated Managerへイベントを出力する必要がない場合は，pd_jp1_useオペランドにNを指定して，HiRDBを再開始してください。
KFPS04607-I
Data replication restart, server ID=aa....aa, reason code=bb....bb　　（Ｌ）
HiRDB Datareplicatorとの連携を再開始しました。
aa....aa：サーバ名
bb....bb：HiRDB Datareplicatorとの連携を再開始した理由
FORCE：前回稼働時はHiRDB Datareplicatorとの連携をしていたが，HiRDBをpdstart -iコマンドで開始した
STATUS：次に示すどちらかの理由
・HiRDB Datarepicatorのデータ連動用連絡ファイルの初期化，又は障害が発生した
・サーバ用ステータスファイルの初期化，又は障害が発生した
(Ｓ)HiRDB Datareplicatorとの連携を一度停止した後，再開始します。
[対策]必要に応じて，HiRDB Datareplicatorのデータ連動用連絡ファイルの初期化及び反映側のデータベースを再作成してください。
KFPS04608-W
Unable to continue data replication, server ID=aa....aa, reason code=bb....bb　　（Ｌ）
HiRDB Datareplicatorとの連携を続行できません。
aa....aa：サーバ名
bb....bb：HiRDB Datareplicatorとの連携を続行できない理由
DEFINITION：前回稼働時はHiRDB Datareplicatorとの連携をしていたが，pd_rpl_init_startオペランドにNを指定した
RPL_FILE：HiRDB Datareplicatorのデータ連動用連絡ファイルに障害が発生した
RPL_STATUS：HiRDB Datareplicatorのデータ連動用連絡ファイルが初期化された
(Ｓ)HiRDB Datareplicatorとの連携を停止した後，サーバの起動処理を続行します。
[対策]HiRDB Datareplicatorとの連携を再度実行する場合は，障害の要因を取り除いて，反映側のHiRDBと同期を取った後に，pdrplstartコマンドでHiRDB Datareplicatorとの連携を再開始してください。 また，HiRDBを停止する運用があり，かつ常にHiRDB Datareplicatorとの連携をする場合は，pd_rpl_init_startオペランドにYを指定してください。
KFPS04609-E
Error occurred in status file while data replication, server ID=aa....aa, reason code=bb....bb　　（Ｌ）
HiRDB Datareplicatorとの連携中にステータスファイルの障害を検知しました。
aa....aa：サーバ名
bb....bb：理由コード
COMMUNICATION：プロセス間通信エラー
SERVER NOT UP：ステータスサービスが起動していない
I/O ERROR：入出力エラー
OTHER：そのほかのエラー
(Ｓ)異常終了します。
[対策]このメッセージの前に出力されているメッセージに従って，エラー原因を取り除いてください。
KFPS04611-I
Usage: pdmemsv [{-d | -s}]　　（Ｅ＋Ｓ）
pdmemsvコマンドのオプションの指定形式が不正です。
(Ｓ)処理を終了します。
(Ｏ)使用方法に従ってコマンドを実行してください。
KFPS04612-E
Error occured in execution, reason code= aa....aa　　（Ｅ）
要因コードaa....aaによって，pdmemsvコマンドが実行できません。
aa....aa：
ALREADY：実行しようとした操作は，既に実行されています。
INSTALL_DIR：インストールディレクトリ下の環境では，このコマンドは実行できません。
NO_DIR：必要なディレクトリ名がありません。
NO_LIBS：環境が破壊されています。
NOT_SINGLE：HiRDB/シングルサーバでは，ありません。
NOT_PARALLEL：HiRDB/パラレルサーバでは，ありません。
PDDIR：環境変数PDDIRがありません。
PERMISSION：実行者がスーパユーザではありません。
SETUP：HiRDBが動作中です。
VERSION：インストール済みのHiRDBと$PDDIR下のHiRDBは，バージョンが異なります。又は，必要なロードモジュールがpdlodsvコマンドで削除されています。
(Ｓ)処理を終了します。
(Ｏ)要因ごとに次の処置をしてください。
〈PDDIRの場合〉
環境変数PDDIRの設定をこのコマンドで操作したいHiRDBの環境にしてください。
〈PERMISSIONの場合〉
スーパユーザで実行してください。
〈SETUPの場合〉
実行に必要なファイルを残すようにして，pdsetup -dを実行してください。
〈VERSIONの場合〉
インストールしたHiRDBと，$PDDIRのHiRDBのバージョンが同じかどうかを確認してください。pdlodsvコマンドで必要なロードモジュールを削除した場合は，運用ディレクトリと同じバージョンのHiRDBを再度インストールしてください。
〈そのほかの場合〉
環境変数PDDIRの内容が正しいか見直してください。正しい場合，HiRDB管理者に連絡してください。
[対策]インストールしたHiRDBと$PDDIRのHiRDBのバージョンが同じかどうかを確認してください。$PDDIRのHiRDBは，システム用のファイルが必要です。pdsetup -dで実行に必要なファイルまで削除されていないかを確認してください。
KFPS04614-I
Usage : aa....aa　　（Ｓ）
aa....aaコマンドのオプション指定形式が誤っています。
aa....aa：オプション指定形式が誤っているコマンド
pdopsetup [-d] [-k option] HiRDB_home_directory
pdlodsv [-r kind]
(Ｓ)処理を終了します。
[対策]コマンドの使用方法に従って再度実行してください。
KFPS04615-E
Specified HiRDB option already setup, option=aaa, version=bb....bb　　（Ｅ）
pdopsetupコマンドで指定したHiRDB運用ディレクトリには，バージョンbb....bbの付加プログラムプロダクトが既に組み込まれています。
aaa：付加プログラムプロダクト
obj：HiRDB Object Option
exd：HiRDB External Data Access
sti：HiRDB Staticizer Option
aha：HiRDB Advanced High Availability
ldp：HiRDB LDAP Option
apt：HiRDB Advanced Partitioning Option
nrf：HiRDB Non Recover FES
bb....bb：付加プログラムプロダクトのバージョン
(Ｓ)処理を終了します。
[対策]指定したHiRDB運用ディレクトリに組み込まれている付加プログラムプロダクトのバージョンと，インストールされている付加プログラムプロダクトのバージョンを確認してください。インストールされている付加プログラムプロダクトのバージョンを組み込む場合は，pdopsetup -dコマンドを実行してからpdopsetupコマンドを実行してください。
KFPS04616-E
Specified HiRDB option not setup, option=aaa　　（Ｅ）
pdopsetup -dコマンドで指定したHiRDB運用ディレクトリには付加プログラムプロダクトが組み込まれていないため，削除できません。
aaa：付加プログラムプロダクト
obj：HiRDB Object Option
exd：HiRDB External Data Access
sti：HiRDB Staticizer Option
aha：HiRDB Advanced High Availability
ldp：HiRDB LDAP Option
apt：HiRDB Advanced Partitioning Option
nrf：HiRDB Non Recover FES
(Ｓ)処理を終了します。
[対策]pdopsetupコマンドで指定したHiRDB運用ディレクトリが正しいか確認してください。
KFPS04617-E
HiRDB option not installed, PP=aa....aa　　（Ｅ）
HiRDBの付加プログラムプロダクトがインストールされていません。
aa....aa：付加プログラムプロダクト名称
HiRDB/Single Server - Object Option
HiRDB/Parallel Server - Object Option
HiRDB External Data Access
HiRDB Staticizer Option
HiRDB Advanced High Availability
HiRDB LDAP Option
HiRDB Advanced Partitioning Option
HiRDB Non Recover FES
(Ｓ)処理を終了します。
[対策]HiRDBの付加プログラムプロダクトをインストールした後，再度実行してください。
KFPS04618-I
HiRDB option setup complete, func=aa....aa, option=bbb, version=cc....cc　　（Ｓ）
HiRDBの付加プログラムプロダクトの組み込み，又は取り外しをしました。
aa....aa：機能種別
add：組み込み
delete：取り外し
bbb：付加プログラムプロダクト
obj：HiRDB Object Option
exd：HiRDB External Data Access
sti：HiRDB Staticizer Option
aha：HiRDB Advanced High Availability
ldp：HiRDB LDAP Option
apt：HiRDB Advanced Partitioning Option
nrf：HiRDB Non Recover FES
cc....cc：付加プログラムプロダクトのバージョン
(Ｓ)処理を終了します。
KFPS04619-E
Unable to execute aa....aa command due to HiRDB unit not offline or not terminate normally　　（Ｓ＋Ｒ）
HiRDBのユニットが停止状態でないため，aa....aaコマンドを実行できません。
aa....aa：コマンド名
(Ｓ)処理を終了します。
[対策]コマンド実行時，HiRDBが稼働中(開始・終了処理中も含みます)であることが考えられます。このような状態でこのコマンドを実行できません。
また，pdplgset，pdopsetup，又はpddbadsetコマンドの場合，HiRDBが停止していても，異常終了したかpdstop -fコマンドで強制停止した場合は入力できません。
HiRDBが稼働中の場合は，pdstopコマンドでHiRDBを正常停止してから再度実行してください。そうでない場合は，一度HiRDBを開始した後，pdstopコマンドでHiRDBを正常停止してから再度実行してください。
KFPS04620-I
Server aa....aa information. Process ID=bb....bb. System event=0xcccccccc dddddddd eeeeeeee. User event=0xffffffff. SYS_CALL=0xgggggggg.　　（Ｌ）
サーバの情報です。
aa....aa：サーバ名
bb....bb：プロセスID
cccccccc：システムイベント情報1（内部コード）
dddddddd：システムイベント情報2（内部コード）
eeeeeeee：システムイベント情報3（内部コード）
ffffffff：ユーザイベント情報（内部コード）
gggggggg：システムコールコード情報（内部コード）
(Ｓ)処理を続行します。
[対策]このメッセージの前に出力されたKFPS01820-Eメッセージの付加情報です。サーバ名，及びプロセスIDに対応するKFPS01820-Eメッセージを基に対策してください。
KFPS04621-E
Caution: Server aa....aa (process ID=bb....bb) killed by user request　　（Ｌ）
HiRDB以外からのユーザの要求によって，HiRDBのサーバプロセスが停止しました。
HiRDB以外からのユーザの要求には，次のものがあります。
・OSのkillコマンドを実行しました（Windows NTの場合はpdkillコマンド）。ただし，このメッセージの対象とするシグナルはSIGTERM，SIGKILL，SIGQUIT，SIGABRTだけです。
・Javaストアドプロシジャ，Javaストアドファンクションを使用している場合に，Java仮想マシンがシグナルを送信しました。このメッセージの対象となるシグナルは，SIGTERM，SIGKILL，及びSIGABRTです。
・AIX 5LのAsynchronous I/O Subsystemをインストール，又は有効化しない状態で，システムログの並列出力機能を適用しました。
aa....aa：abortプロセスのサーバ名
bb....bb：上記サーバのプロセスID
(Ｓ)処理を続行します。
(Ｏ)coreを出力した場合は，HiRDB管理者へ連絡してください。
[対策]OS提供のkillコマンド（Windows NTの場合はpdkillコマンド）が実行されたかどうか調査してください。
又は，AIX 5LのAsynchronous I/O Subsystemをインストール若しくは有効化しない状態で，システムログの並列出力機能を適用していないか（pd_log_dual_write_methodオペランドにparallelを指定していないか）確認してください。システムログの並列出力機能については，マニュアル「HiRDB Version 7 システム導入・設計ガイド」を参照してください。
KFPS04622-E
Invalid user name, user=aa....aa; bb....bb processing.　　（Ｅ＋Ｌ）
aa....aaは不正なユーザ名です。
aa....aa：ユーザ名
bb....bb：システムの処置
stops：処理を中断します。
continues：実行ユーザのログインアカウントを使用して，処理を続行します（pdinit実行時だけ）。
(Ｓ)bb....bbの内容に従います。
(Ｏ)ユティリティの使用方法に従って再度実行してください。
[対策]pdinit実行時にこのメッセージが出力された場合は，ユーザ名を見直して再度実行してください。なお，次の名称はユーザ名として使用できません。
・8バイトを超える名称
・先頭文字が半角英字（大文字又は小文字）で始まらない名称
・半角英字（大文字又は小文字）及び半角数字以外の文字列を含む名称
・HiRDB，MASTER，ALL，PUBLIC（認可識別子として使用できない予約語）
KFPS04623-E
Invalid password, user=aa....aa; bb....bb processing.　　（Ｅ＋Ｌ）
ユーザ名aa....aaに対するパスワードが不正です。
aa....aa：ユーザ名
bb....bb：システムの処置
stops：処理を中断します。
(Ｓ)bb....bbの内容に従います。
(Ｏ)ユティリティの使用方法に従って再度実行してください。
[対策]pdinit実行時にこのメッセージが出力された場合は，パスワードを見直して再度実行してください。なお，次の名称はパスワードとして使用できないので，変更してください。
・30バイトを超える名称
・先頭文字が半角英字（大文字又は小文字）で始まらない名称
・半角英字（大文字又は小文字）及び半角数字以外の文字列を含む名称
KFPS04624-I
Data replication already stopped, unit ID=aaaa, server ID=bb....bb　　（Ｅ＋Ｌ）
HiRDB Datareplicatorのデータ連動用連絡ファイルの障害，又はデータ連動中断が起きたサーバ名を表示します。このメッセージは障害が起きたサーバの数だけ表示されます。
aaaa：ユニット識別子
bb....bb：サーバ名
(Ｓ)データ連動を停止し，HiRDBの開始処理を続行します。
[対策]後続のKFPS01833-I及びKFPS01801-Eメッセージの対処方法に従ってください。
KFPS04625-E
Error found in system configuration. reason code=aa....aa　　（Ｌ）
システム共通定義又はユニット制御情報定義に指定したオペランドの指定方法に誤りがあります。
aa....aa：理由コード
SPECIFIED pd_spool_cleanup_level：
pd_spool_cleanup_levelオペランドの指定方法に誤りがあります。
SPECIFIED pd_spool_cleanup_interval_level：
pd_spool_cleanup_interval_levelオペランドの指定方法に誤りがあります。
(Ｓ)処理を終了します。
[対策]指定方法に誤りがあるオペランドを修正してください。オペランドの修正後にHiRDBを開始してください。
KFPS04626-E
Unable to remove aa....aa, reason code=bb....bb　　（Ｓ）
aa....aaのロードモジュールが削除できません。
aa....aa：ロード種別
POSIX：POSIXライブラリ版のHiRDB
bb....bb：理由コード
USING：このロードモジュールは使用されているため，削除できません。
REMOVED：このロードモジュールは既に削除されています。
RUNNING：pdsetupコマンドが実行中です。
(Ｓ)処理を終了します。
[対策]理由コードがRUNNINGの場合は，pdsetupコマンドが終了するのを待ってください。終了したら，再度実行してください。
KFPS04627-E
HiRDB Datareplicator extraction process not in progress, because error occurred in HiRDB Datareplicator access communication file. unit ID=aaaa, server ID=bb....bb.　　（Ｌ）
データ連動用連絡ファイルへのアクセスが失敗したため，HiRDB Datareplicatorによるデータ連動の抽出処理が動作できません。
aaaa：ユニット識別子
bb....bb：サーバ名
(Ｓ)処理を続行します。
[対策]データ連動用連絡ファイルへのアクセス失敗理由を調査して対策してください。直前に出力されたKFPS01889-Eメッセージからアクセス失敗理由を調査できます。
●KFPS01889-Eメッセージのfunction valueが"SYSTEM CALL(stat) ERROR"でかつerrnoが2の場合
データ連動用連絡ファイルが見付かりません。再作成する場合は，HiRDB Datareplicatorによる連動連絡ファイルの初期化が必要です。次に示す手順で実施してください。
7. pdrplstopコマンドでデータ連動処理を終了します。
8. 未反映のシステムログがある場合は，HiRDB DataextractorやHiRDB Datareplicatorのデータ連動回復機能などを使用して，データ連動の抽出－反映間の整合性を回復します。
9. HiRDB Datareplicatorが提供する hdestart -iコマンドを実行して，データ連動用連絡ファイルを再作成して初期化します。
10. pdrplstartコマンドでデータ連動処理を開始します。
●KFPS01889-Eメッセージのerrnoが13の場合
データ連動用連絡ファイルのアクセス権限がありません。HiRDB管理者がデータ連動用連絡ファイルにアクセスできるようにアクセス権限を変更してください。
●KFPS01889-Eメッセージのfunction valueが"FILE LOCK ERROR"の場合
HiRDB Datareplicatorがデータ連動用連絡ファイルを占有している可能性があります。HiRDB Datareplicatorの実行状態を確認してください。
KFPS04628-W
Data replication stopped, please check.　　（Ｅ＋Ｌ）
HiRDB Datareplicatorとのデータ連動が停止しました。データ連動の停止要因を確認してください。
(Ｓ)処理を続行します。
[対策]HiRDB Datareplicatorとのデータ連動が停止した要因を確認してください。問題がある場合は，HiRDB DataextractorやHiRDB Datareplicatorのデータ連動回復機能などを使用して，データ連動の抽出－反映間の整合性を回復してください。
KFPS04629-I
Command failed on online unit, command=aa....aa, hostname=bb...bb; Retrying on standby unit　　（Ｌ＋Ｓ）
実行系ユニットでaa....aaコマンドの実行が失敗したため，待機系ユニットでコマンドを再実行します。
aa....aa：コマンド名
bb....bb：ホスト名
(Ｓ)処理を続行します。
[対策]待機系ユニットで再実行したコマンドが正常終了した場合は，実行系ユニットで発生したエラーを無視してください。なお，ここでいう実行系及び待機系とはHiRDBが判断する状態であり，実際の系の状態とは異なることがあります。実行系及び待機系ともエラーが発生した場合は，実際の系の状態を調査して実行系ユニットで発生したエラーのメッセージに従って対策してください。
KFPS04630-I
External Data Access Adapter setup start, func="aa....aa", External Data Access Adapter name=bb....bb　　（Ｌ＋Ｓ）
HiRDB External Data Access Adapterのセットアップ処理を開始します。
aa....aa：処理の内容
setup：HiRDB External Data Access Adapterのセットアップ
delete：HiRDB External Data Access Adapterの削除
bb....bb：HiRDB External Data Access Adapterの名称
(Ｓ)処理を続行します。
KFPS04631-I
External Data Access Adapter setup ended, return code=aa....aa　　（Ｌ＋Ｓ）
HiRDB External Data Access Adapterのセットアップ処理を終了します。
aa....aa：終了コード
０：正常終了
８：異常終了
(Ｓ)処理を終了します。
[対策]終了コードが０以外の場合は，このメッセージの前に出力されたメッセージKFPS046XX-E，及びOSのメッセージを参照し，対策してください。
KFPS04632-I
Usage: pddbadset External_Data_Access_Adapter_name installed_directory pddbadset -d External_Data_Access_Adapter_name　　（Ｓ）
pddbadsetコマンドの使用方法を示します。コマンドの形式が誤っている場合にこのメッセージを出力します。コマンドの形式を見直してコマンドを再度実行してください。
(Ｓ)処理を終了します。
KFPS04633-E
Invalid "PDDIR", path name="aa....aa"　　（Ｅ＋Ｌ）
環境変数PDDIRの内容が不正です。
aa....aa：環境変数PDDIRの指定値
表示されない場合はPDDIRが指定されていません。
(Ｓ)処理を終了します。
[対策]次に示す処置をしてください。
●aa....aaが表示されている場合
・PDDIRに正しいHiRDB運用ディレクトリ名が指定されているかを確認してください。誤ったパス名を指定している場合は，正しいパス名を指定してコマンドを再度実行してください。
・PDDIRにHiRDB運用ディレクトリ名が絶対パスで指定されているかを確認してください。相対パスで指定している場合，絶対パスに直してください。その後，コマンドを再度実行してください。
●aa....aaが表示されていない場合
PDDIRにHiRDB運用ディレクトリ名を絶対パスで指定してコマンドを再度実行してください。
KFPS04634-E
External Data Access Adapter aa....aa already setup　　（Ｅ＋Ｌ）
指定したHiRDB External Data Access Adapterは既にセットアップされています。
aa....aa：HiRDB External Data Access Adapterの名称
(Ｓ)処理を終了します。
[対策]aa....aaに対するpddbadsetコマンドが正常終了している場合は，再度実行する必要はありません。正常終了していない場合は，pddbadset -dコマンドを実行してから，再度pddbadsetコマンドを実行してください。
KFPS04635-E
Permission error occurred, path name=aa....aa　　（Ｅ＋Ｌ）
aa....aaのアクセス権限がありません。
aa....aa：読み込み，書き込みができなかったファイル又はディレクトリ名
(Ｓ)処理を終了します。
[対策]次に示すどれかの処置をしてください。
・コマンドの引数に誤りがある場合は，コマンドの引数を正しく指定して再度実行してください。
・インストールディレクトリにアクセス権限がない場合は，インストールディレクトリを削除し，インストールし直してください。又は，HiRDB管理者がアクセスできるようにインストールディレクトリにアクセス権限を与えてください。
・内部処理のOSのコマンドでエラーが発生した場合は，OSのコマンドのエラーメッセージに従ってエラーの原因を調査し，対策してください。
・上記以外の場合は，$PDDIR/adapter下のファイル，及び引数に指定したインストールディレクトリ下のファイルを保存し，保守員に連絡してください。
KFPS04636-E
File or directory not exists, path name=aa....aa　　（Ｅ＋Ｌ）
ファイル又はディレクトリaa....aaがありません。
aa....aa：参照しようとしたファイル名又はディレクトリ名
(Ｓ)処理を終了します。
[対策]次に示すどれかの処置をしてください。
・コマンドの引数に誤りがある場合は，コマンドの引数を正しく指定して再度実行してください。
・インストールディレクトリが壊れている場合は，HiRDB External Data Access Adapterを再インストールしてください。
・内部処理のOSのコマンドでエラーが発生した場合は，OSのコマンドのエラーメッセージに従ってエラーの原因を調査し，対策してください。
・上記以外の場合は，$PDDIR/adapter下のファイル，及び引数に指定したインストールディレクトリ下のファイルを保存し，保守員に連絡してください。
KFPS04637-E
Not a directory, path name=aa....aa　　（Ｅ＋Ｌ）
aa....aaはディレクトリではありません。
aa....aa：参照しようとしたファイル名
(Ｓ)処理を終了します。
[対策]引数に指定したパス名に誤りがないかを確認してください。誤っている場合は正しいインストールディレクトリ名を指定し，再度コマンドを実行してください。HiRDB運用ディレクトリにadapterというファイルを独自に作成している場合は，ファイル名称を変更してください。
KFPS04638-E
External Data Access Adapter aa....aa not setup　　（Ｅ＋Ｌ）
HiRDB External Data Access Adapterはセットアップされていません。
aa....aa：HiRDB External Data Access Adapterの名称
(Ｓ)処理を終了します。
[対策]次に示すどれかの処置をしてください。
・引数に指定したHiRDB External Data Access Adapterの名称に誤りがある場合は，引数に正しいHiRDB External Data Access Adapterの名称を指定してコマンドを再度実行してください。
・環境変数PDDIRに指定しているパス名に誤りがある場合は，環境変数PDDIRに正しいパス名を指定してコマンドを再度実行してください。
・引数に指定したHiRDB External Data Access Adapterはセットアップされていないため，コマンドを実行する必要はありません。
KFPS04639-E
Pddbadset already used by another user　　（Ｅ＋Ｌ）
既にpddbadsetコマンドを実行中です。
(Ｓ)処理を終了します。
[対策]現在実行しているpddbadsetコマンドが終了した後に，再度pddbadsetコマンドを実行してください。
KFPS04640-E
Pddbadset settype is not support　　（Ｅ＋Ｌ）
コマンドの引数に指定したHiRDB External Data Access Adapterの種別はサポートされていません。
(Ｓ)処理を終了します。
[対策]コマンドの引数にHiRDB External Data Access Adapterの種別を正しく指定してください。現在サポートしているHiRDB External Data Access Adapter，及び対応するコマンドの引数を次に示します。
・外部サーバがHiRDB又はXDM/RD E2の場合：hiv6
・外部サーバがORACLEの場合：orav8
・外部サーバがDB2の場合：db2udbv6
KFPS04641-E
External Data Access required　　（Ｅ＋Ｌ）
このコマンドを実行するにはHiRDB External Data Accessが必要です。
(Ｓ)処理を終了します。
[対策]HiRDB External Data Accessをインストールして環境設定をした後に，このコマンドを実行してください。
KFPS04643-I
Assumed aa....aa default value=bb....bb on unit cccc　　（Ｌ）
ユニットccccで定義オペランドaa....aaの省略値bb....bbを仮定しました。
aa....aa：定義オペランド名
pd_max_server_process（最大同時起動サーバプロセス数）
bb....bb：定義オペランドの省略値
cccc：ユニット識別子
(Ｓ)処理を続行します。
[対策]運用中に最大同時起動サーバプロセス数の不足を検知した場合は，オペランドの指定値を見積もって，省略値より大きな値を指定してHiRDBを再開始してください。
KFPS04644-I
Assumed aa....aa default value=bb....bb on server cc....cc　　（Ｌ）
サーバcc....ccのaa....aaオペランドの省略値としてbb....bbを仮定しました。
aa....aa：オペランド名
pd_bes_shmpool_size（バックエンドサーバ用共用メモリサイズ）
pd_dic_shmpool_size（ディクショナリサーバ用共用メモリサイズ）
pd_sds_shmpool_size（シングルサーバ用共用メモリサイズ）
bb....bb：オペランドの省略値（単位：バイト）
cc....cc：サーバ名
(Ｓ)処理を続行します。
[対策]運用中に共用メモリサイズ不足を検知した場合は，オペランドの指定値を見積もり直してください。省略値（bb....bbの値）より大きな値を指定してHiRDBを再開始してください。
KFPS04645-I
pdprgcopy ended, return code=aa　　（Ｌ＋Ｓ）
pdprgcopyコマンドが終了しました。
aa：リターンコード
0：pdprgcopyコマンドが正常終了しました。
8：pdprgcopyコマンドがエラー終了しました。
(Ｓ)処理を終了します。
[対策]リターンコードが8の場合は，標準エラー出力やsyslogfile（Windows NT版の場合はイベントログ）に出力されたエラーメッセージを参照してエラーの原因を取り除いてください。その後，コマンドを再実行してください。
KFPS04646-I
pdprgrenew ended, return code=aa　　（Ｌ＋Ｓ）
pdprgrenewコマンドが終了しました。
aa：リターンコード
0：pdprgrenewコマンドが正常終了しました。
8：pdprgrenewコマンドがエラー終了しました。入れ替え前のHiRDBのままです。
12：pdprgrenewコマンドがエラー終了しました。入れ替え前のHiRDBに戻す処理の途中でエラーが発生しました。HiRDBは停止しています。
(Ｓ)処理を終了します。
[対策]リターンコードによって次の処置をしてください。
リターンコードが8の場合
標準エラー出力やsyslogfile（Windows NT版の場合はイベントログ）に出力されたエラーメッセージを参照してエラーの原因を取り除いてください。その後，コマンドを再実行してください。
なお，コマンド実行時にHiRDBが稼働中の場合はコマンド終了後もHiRDBは稼働しています。コマンド実行時にHiRDBが停止状態の場合はコマンド終了後もHiRDBは停止状態のままとなります。
リターンコードが12の場合
このメッセージの直前に出力されたKFPS04647-Iメッセージを参照して，どの処理中にエラーが発生したか確認し，対処してからpdprgrenewコマンドを再度実行してください。対処方法を次に示します。
・KFPS04647-IメッセージでSYS_SUSPEND，又はSYS_RESUMEと表示されているとき
HiRDBのプロセスがあれば，pdstop -fコマンドでHiRDBを強制終了してからpdprgrenew -bコマンドを実行してください。HiRDBのプロセスがなければ，pdprgrenew -bコマンドを実行してください。
・KFPS04647-IメッセージでRECOVER_REPLACE，RECOVER_BACKUP，又はRECOVER_SYS_SUSPENDと表示されているとき
標準エラー出力やsyslogfile（Windows NT版の場合はイベントログ）に出力されたエラーメッセージを参照して，エラーの原因を取り除いてからpdprgrenew -bコマンドを実行してください。
KFPS04647-I
pdprgrenew aa....aa started　　（Ｌ＋Ｓ）
pdprgrenewコマンドはaa....aa処理を開始しました。
aa....aa：処理内容
処理内容（aa....aa）
説明
SYS_SUSPEND
HiRDBを内部的に中断します。
BACKUP
稼働中のHiRDBのバックアップを取得します。
REPLACE
修正版HiRDBへの入れ替えをします。
SYS_RESUME
修正版HiRDBで再開始します。
RECOVER_REPLACE
エラー発生時の回復処理です。修正版HiRDBを入れ替え用ディレクトリに戻します。
RECOVER_BACKUP
エラー発生時の回復処理です。入れ替え前のHiRDBに戻します。
RECOVER_SYS_SUSPEND
エラー発生時の回復処理です。入れ替え前のHiRDBで再開始します。
(Ｓ)処理を続行します。
KFPS04648-E
Error occurred in pdprgrenew command, unit ID=aaaa, reason code=bb....bb　　（Ｅ＋Ｌ）
pdprgrenewコマンド実行中にエラーが発生しました。
aaaa：ユニット識別子
bb....bb：理由コード
理由コード（bb....bb）
説明
permission error
実行者がHiRDB管理者ではありません。
renew directory not exist
HiRDB運用ディレクトリ下にrenewディレクトリがありません。
renew_bak directory exist
HiRDB運用ディレクトリ下にrenew_bakディレクトリが存在しています。
rename error
プログラム入れ替え処理のrename()システムコールでエラーが発生しました。
transactions exist
pdprgrenewコマンドはトランザクションの終了を待ちましたが，15分経過しても実行中のトランザクションがあるためコマンドの実行を中断しました。
offline units exist
システム内に停止しているユニットがあります。
offline servers exist
停止しているサーバがあります。
communication error occurred
通信エラーが発生しました。ネットワーク，各ユニット又はサーバに障害が発生している可能性があります。
utility be executing
HiRDBのユティリティが実行中です。ユティリティ実行中はpdprgrenewコマンドは実行できません。
replication mode unmatch
HiRDB Datareplicator連携機能使用時，pd_rpl_init_startオペランドの指定と動作状態が異なります。
pdprgrenew -b be unnecessary
pdprgrenew -bコマンドが実行されましたが，pdprgrenew -bコマンドを実行する必要はないため，何もしませんでした。
(Ｓ)処理を続行します。
[対策]理由コードに対応した処置をしてください。
permission errorの場合
pdprgrenewコマンドはHiRDB管理者が実行してください。
renew directory not existの場合
pdprgcopyコマンドを実行してからpdprgrenewコマンドを再度実行してください。
renew_bak directory existの場合
HiRDB運用ディレクトリ下のrenew_bakディレクトリを削除するか，別のディレクトリ名に変更してからpdprgrenewコマンドを再度実行してください。
rename errorの場合
pdprgcopyコマンドでコピーした修正版HiRDBがあるHiRDB運用ディレクトリ下のrenewディレクトリと，HiRDB運用ディレクトリ下の稼働中HiRDBディレクトリ（bin，libなど）とが同一のファイルシステム上にない場合はエラーとなります。必要なディレクトリが同一のファイルシステム上に存在するように修正してからpdprgrenewコマンドを再度実行してください。
ディレクトリが同一のファイルシステム上にある場合は，OSのrename()システムコールが失敗しています。OSのメッセージがsyslogfile（Windows NT版の場合はイベントログ）に出力されている可能性があります。エラーの原因を取り除き，pdprgrenew -bコマンドでHiRDBを入れ替え前の状態に戻した後でpdprgrenewコマンドを再度実行してください。
transactions existの場合
長時間動作するトランザクションがないことを確認し，現在実行中のトランザクションの終了を待って，pdprgrenewコマンドを再度実行してください。
offline units exist，及びoffline servers existの場合
HiRDBのすべてのユニット，及びサーバを開始してからpdprgrenewコマンドを再度実行してください。
communication error occurredの場合
通信エラーの原因を調べて対策してから，コマンドを再度実行してください。
utility be executingの場合
HiRDBのユティリティが終了してからpdprgrenewコマンドを再度実行してください。
replicator mode unmatch
pd_rpl_init_startオペランドの指定と動作状態を合わせてからpdprgrenewコマンドを再度実行してください。
pdprgrenew -b be unnecessaryの場合
pdprgrenew -bコマンドは，KFPS04646-Iメッセージでリターンコード12を出力してpdprgrenewコマンドが終了した場合にだけ実行してください。
KFPS04649-E
Error occurred in pdprgcopy command, unit ID=aaaa, reason code=bb....bb　　（Ｅ＋Ｌ）
pdprgcopyコマンド実行中にエラーが発生しました。
aaaa：ユニット識別子
bb....bb：理由コード
permission error：
実行者がHiRDB管理者ではありません。
invalid version：
バージョン番号及びリビジョン番号が同じでないため，HiRDBは入れ替えできません。
invalid addressing mode：
稼働中のHiRDBと入れ替える修正版HiRDBとで，アドレッシングモードが異なります。
no space disk：
必要な空きディスク容量がありません。
unmatch versions：
ユニット間でHiRDBのバージョンが異なります。
renew directory exist：
HiRDB運用ディレクトリ下にrenewディレクトリが既に存在しています。
invalid HiRDB server type：
稼働中のHiRDBと入れ替える修正版HiRDBとで，HiRDBサーバの種別（HiRDBシングルサーバか，HiRDBパラレルサーバか）が異なります。
install directory：
pdprgcopyコマンドの引数として指定したディレクトリがHiRDBインストールディレクトリです。
communication error occurred：
通信エラーが発生しました。ネットワーク，各ユニット又はサーバに障害が発生している可能性があります。
copy error：
ファイルをコピー中にエラーが発生しました。
delete error：
pdprgcopyコマンド実行中にエラーが発生したため，HiRDB運用ディレクトリ下のrenewディレクトリを削除しようとしましたが，renewディレクトリの削除に失敗しました。
(Ｓ)処理を続行します。
[対策]理由コードに対応した処置をしてください。
permission errorの場合
pdprgcopyコマンドはHiRDB管理者が実行してください。
invalid versionの場合
稼働中のHiRDBと入れ替える修正版HiRDBとでは，バージョン番号及びリビジョン番号が同じでないと入れ替えはできません。バージョン番号及びリビジョン番号が同じ修正版HiRDBをインストールしてからpdprgcopyコマンドを再度実行してください。
invalid addressing modeの場合
稼働中のHiRDBと入れ替える修正版HiRDBとでは，アドレッシングモードが同じでないと入れ替えはできません。稼働中のHiRDBと同じアドレッシングモードの修正版HiRDBをインストールしてからpdprgcopyコマンドを再度実行してください。
unmatch versionsの場合
入れ替える修正版HiRDBはすべてのユニットで同一のバージョンをインストールしてください。
no space diskの場合
HiRDB運用ディレクトリ下に修正版HiRDBが必要とする空き容量を確保してから，pdprgcopyコマンドを再度実行してください。
install directoryの場合
HiRDB運用ディレクトリとインストールディレクトリとが同じディレクトリの場合，修正版HiRDBへの入れ替えはできません。
インストールディレクトリとHiRDB運用ディレクトリとが異なるディレクトリの場合は，pdprgcopyコマンドの引数にHiRDB運用ディレクトリを指定して再度実行してください。
renew directory existの場合
HiRDB運用ディレクトリ下のrenewディレクトリを別のディレクトリ名に変更するか，削除してからpdprgcopyコマンドを再度実行してください。
invalid HiRDB server typeの場合
稼働中のHiRDBと入れ替える修正版HiRDBとでは，HiRDBサーバの種別（HiRDBシングルサーバか，HiRDBパラレルサーバか）が同じでないと入れ替えはできません。稼働中のHiRDBと同じサーバ種別の修正版HiRDBをインストールしてからpdprgcopyコマンドを再度実行してください。
communication error occurredの場合
通信エラーの原因を調べて対策してから，コマンドを再度実行してください。
copy errorの場合
OSのメッセージがsyslogfile（Windows NT版の場合はイベントログ）に出力されている可能性があります。コピー処理が失敗した原因を調査し，原因を取り除いてからpdprgcopyコマンドを再度実行してください。
delete errorの場合
このメッセージより前のエラーメッセージを参照してエラー原因を取り除き，HiRDB運用ディレクトリ下のrenewディレクトリを削除してからpdprgcopyコマンドを再度実行してください。
KFPS04650-I
Trouble shoot file and temporally file delete aa....aa. system ID=bbbb, unit ID=cccc　　（Ｌ）
$PDDIR/spool下のトラブルシュート情報ファイル，及び$PDDIR/tmp下の作業用一時ファイルの削除を開始又は終了します。
aa....aa：処理内容
started：削除処理の開始
completed：削除処理の終了
bbbb：HiRDB識別子
cccc：ユニット識別子
(Ｓ)処理を続行します。
KFPS04651-W
Message log server restarted　　（Ｅ＋Ｌ）
メッセージログサーバを再起動しました。メッセージログサーバの異常終了から再起動完了までの間にHiRDBが出力したメッセージはメッセージログファイル（$PDDIR/spool/pdlog1又はpdlog2）に出力されません。メッセージ出力元のサーバマシンのsyslogfile又はイベントログに出力されます。ただし，メッセージがsyslogfile又はイベントログに出力されないこともあります。なお，実行中のUAP，コマンド，及びユティリティについては問題ありません。
(Ｓ)処理を続行します。
KFPS04652-E
Pdstop command failed,reason=aa....aa　　（Ｅ＋Ｌ）
ほかの運用コマンドが実行中のため，pdstopコマンドが実行できませんでした。
aa....aa：コマンドを実行できない理由
・RPL_STARTING：HiRDB Datareplicatorとの連携の開始処理中です。
・RPL_STOPPING：HiRDB Datareplicatorとの連携の終了処理中です。
(Ｓ)処理を終了します。
[対策]ほかの運用コマンドが終了した後にpdstopコマンドを再実行してください。
KFPS04653-E
Unable to stop unit aaaa with alternate servers, reason=bb....bb　　（Ｅ＋Ｌ）
スタンバイレス型系切り替え機能の代替機能の状態によって，代替BESユニット又は代替機能を停止できません。
aaaa：pdstopコマンドの-u又は-xオプションに指定したユニット識別子
bb....bb：理由コード
(Ｓ)処理を終了します。
[対策]理由コードを参照して対処してください。
理由コード
説明
対策
STARTING
代替機能の準備中です。
再度停止コマンドを実行してください。
SBY_STARTING
代替機能を待機サーバとして準備中です。
KFPS01872-Iメッセージの出力後に再度停止コマンドを実行してください。
SBY_TERM
代替機能の待機停止中です。
再度停止コマンドを実行してください。
SBY_RELEASE
代替機能を系切り替えによって実行準備中です。
KFPS05110-Iメッセージの出力後に再度停止コマンドを実行してください。
ACT_STARTING
代替機能を実行サーバとして準備中です。
STOPPING
代替機能の停止中です。
KFPS01841-Iメッセージの出力後に再度停止コマンドを実行してください。
ONLINE
代替中です。
代替中の場合は高速停止できません。システム構成変更コマンド又は修正版HiRDBへの入れ替えを実行する場合は，代替中から正常状態に系を切り戻してから実行してください。
OFFLINE
既に修正済みです。
代替BESユニットは既に停止しています。
NONALTSVUNIT
代替BESユニットではありません。
代替BESユニットでコマンドを実行してください。
KFPS04654-W
Unable to continue alternate service for unit aaaa because of dying alternate server unit bbbb　　（Ｌ）
代替BESユニットが終了するため，実行中の代替機能を停止します。
aaaa：正規BESユニットのユニット識別子
bbbb：代替BESユニットのユニット識別子
(Ｓ)処理を終了します。
[対策]代替BESユニットが正規BESユニットのサーバ機能を代替中で，正規BESユニットが待機完了している場合は系切り替えが発生します。系切り替えが発生しない場合は，正規BESユニットに対してpdstart -qコマンドを実行してください。
KFPS04655-E
Unable to continue HiRDB server aa....aaprocessing because serious error occurred　　（Ｌ）
aa....aaサーバで，処理が続行できないエラーが発生しました。
aa....aa：サーバ名
(Ｓ)処理を終了します。
[対策]このメッセージの前に出力されたメッセージに従ってエラーの原因を取り除いてください。必要があれば，サーバを再開始してください。
KFPS04660-I
Pdchgconf started　　（Ｌ）
システム構成変更コマンド（pdchgconfコマンド）を開始しました。
(Ｓ)処理を続行します。
KFPS04661-I
Pdchgconf terminated. return code=aa　　（Ｌ）
システム構成変更コマンド（pdchgconfコマンド）が終了しました。
aa：リターンコード
0：システム構成変更処理が正常終了しました。
8：システム構成変更処理がエラー終了しました。
(Ｓ)処理を終了します。
[対策]リターンコードが8の場合は，標準エラー出力やメッセージログファイルに出力されたエラーメッセージを参照してエラーの原因を取り除いてください。その後，コマンドを再実行してください。
KFPS04662-E
Unable to execute pdchgconf, because aa....aa　　（Ｌ）
システム構成変更コマンド（pdchgconfコマンド）を実行できません。
aa....aa：理由コード
(Ｓ)処理を終了します。
[対策]理由コードに対応する対策をしてください。
理由コード
対策
transactions exist
トランザクション又はユティリティが15分間実行中のままです。長時間動作するトランザクション又はユティリティがないことを確認してからコマンドを再実行してください。
offline units exist
停止中のユニットがあります。全ユニットを開始してからコマンドを再実行してください。
offline servers exist
停止中のサーバがあります。全サーバを開始してからコマンドを再実行してください。
change of configuration invalid （pd_system_id）
pd_system_idオペランドは変更できません。このオペランドの指定値を元に戻してからコマンドを再実行してください。
change of configuration invalid （pd_master_file_name）
pd_master_file_nameオペランドは変更できません。このオペランドの指定値を元に戻してからコマンドを再実行してください。
communication error occurred
通信エラーが発生しました。通信エラーの原因を調べて対策した後にコマンドを再実行してください。
pdrplstop executing
pdrplstopコマンドが実行中です。pdrplstopコマンドの終了後にコマンドを再実行してください。
only for pdrstr and pdcopy mode
pdstart -rコマンドでHiRDBを開始しています。正常開始又は再開始した後にコマンドを再実行してください。
Online DB Reorganization executing
更新可能なオンライン再編成が実行中です。更新可能なオンライン再編成の終了後にコマンドを再実行してください。
replication mode unmatch
HiRDB Datareplicatorとの連携の動作状態が定義と異なります。HiRDB Datareplicatorとの連携の動作状態を定義と合わせてからコマンドを再実行してください。
change of configuration invalid （unit status file:bbbb,cc....cc）
変更できないユニット用ステータスファイルの定義を変更しています。bbbbはユニット識別子，cc....ccは誤りのあるステータスファイル名です。このオペランドの指定値を元に戻してからコマンドを再実行してください。
change of configuration invalid （server status file:dd....dd,ee....ee）
変更できないサーバ用ステータスファイルの定義を変更しています。dd....ddはサーバ名，ee....eeは誤りのあるステータスファイル名です。このオペランドの指定値を元に戻してからコマンドを再実行してください。
change of configuration invalid （log file:ff....ff,gg....gg）
変更できないシステムログファイルの定義を変更しています。ff....ffはサーバ名，gg....ggは誤りのあるシステムログファイルのファイルグループ名です。このオペランドの指定値を元に戻してからコマンドを再実行してください。
change of configuration invalid （sync point dump file:hh....hh,ii....ii）
変更できないシンクポイントダンプファイルの定義を変更しています。hh....hhはサーバ名，ii....iiは誤りのあるシンクポイントダンプファイルのファイルグループ名です。このオペランドの指定値を元に戻してからコマンドを再実行してください。
configuration change failed
HiRDBシステム定義の変更に失敗しました。次に示す手順で対策してください。
1. エラー要因を対策してください。HiRDB運用ディレクトリ下のディスク容量が満杯の場合はディスク容量を確保してください。システム共通定義ファイルに書き込み権限がない場合は，HiRDB管理者に対してこのファイルの書き込み権限を与えてください。通信障害が発生した場合は原因を取り除いてください。
2. 全ユニットのHiRDBシステム定義の状態を確認してください。変更前の状態でない場合は$PDDIR/conf/backconfから回復してください。
3. HiRDBは停止しているため，HiRDBを開始してコマンドを再実行してください。
disk change failed
ディスクの切り離し，又は接続に失敗しました。次に示す手順で対策してください。
1. ディスク切り離し，接続シェルの内容を確認してください。シェルの実行権限がない場合は実行権限を与えてください。
2. 全ユニットのHiRDBシステム定義の状態を確認してください。変更前の状態でない場合は$PDDIR/conf/backconfから回復してください。
3. ディスクの接続状態を確認してください。
4. HiRDBは停止中のため，HiRDBを開始してコマンドを再実行してください。
change of configuration directory invalid
ディレクトリが不正です。HiRDBの各ユニットの$PDDIR/conf/chgconfディレクトリを確認して，コマンドを再実行してください。
change of configuration directory not exist
ディレクトリが存在しません。HiRDBの各ユニットの$PDDIR/conf/chgconfディレクトリを確認して，コマンドを再実行してください。
HiRDB Advanced High Availability not setup
HiRDB Advanced High Availabilityがセットアップされていません。システム構成変更コマンドを使用する場合はHiRDB Advanced High Availabilityをセットアップしてください。
unable to skip offline unit
pd_mode_confオペランドの指定値がAUTOのため，停止中の回復不要FESユニットを無視してコマンドを実行できません。停止中のユニットを開始してから，再度コマンドを実行してください。
change of configuration invalid(pdstart -k stls)
停止中の回復不要FESユニットに対して，pdstartオペランドの-k stlsオプションの指定を変更できません。停止中のユニットを開始してから，再度コマンドを実行してください。
KFPS04663-W
Now waiting for termination of transaction or utility　　（Ｌ）
トランザクション又はユティリティの終了を待ち合わせています。
(Ｓ)処理を続行します。
[対策]pdchgconfコマンドの実行を優先する場合は，実行中のトランザクション，ユティリティをpdls -d trn又はpdls -d prcで確認した後に，pdcancelコマンドでキャンセルしてください。トランザクション又はユティリティの実行を優先する場合は何もしないでください。
KFPS04664-I
Configuration change processing aa....aa. unit:bbbb　　（Ｌ）
システム構成変更コマンド（pdchgconfコマンド）でシステム定義を変更しています。
aa....aa：処理内容
start：システム定義の変更開始
end：システム定義の変更終了
recover：システム定義の変更の取り消し開始
bbbb：ユニット識別子
(Ｓ)処理を続行します。
KFPS04665-W
Changing definition file skipped in pdchgconf, unit ID=aaaa, reason code=bb....bb　　（Ｅ）
pdchgconfコマンドは，ユニットaaaaのシステム定義ファイルの入れ替えを行いませんでした。
aaaa：システム定義ファイルの入れ替えを行わなかったユニットの識別子
bb....bb：システム定義ファイルの入れ替えを行わなかった理由
communication error occurred：通信エラーが発生しました。ネットワーク，各マシン，ユニット，又はサーバに障害が発生している可能性があります。
(Ｓ)処理を続行します。
[対策]ユニットaaaaを再開始する前に，$PDDIR/conf下と$PDCONFPATH下のシステム定義ファイルを変更後のシステム定義ファイルに置き換えてください。
bb....bbにcommunication error occurredが表示された場合：システムマネジャのユニットからユニットaaaaへの通信エラーが発生する要因があります。ネットワークに障害が発生していないか，又はリモートシェルの実行権限があるかなど，通信エラーの原因を調べて対策してください。
KFPS04666-I
System configuration changed　　（Ｊ）
システム定義が変更された可能性があります。このメッセージは，JP1/Integrated Managerにイベントを通知する場合に出力されます。
(Ｓ)処理を続行します。
KFPS04680-E
Error occurred in Real_Time_SAN_Replication, reason code=aa....aa, command=bb....bb, group=cc....cc　　（Ｅ＋Ｌ）
RAID Managerのコマンドがエラーになりました。
aa....aa：コード
bb....bb：エラーになったRAID Managerのコマンド名
cc....cc：ペア論理ボリュームグループ名
(Ｓ)処理を続行します。
[対策]次に示すコード一覧に対応した処置をしてください。
コード(aa....aa)
意味
HiRDB管理者の処置
SYSTEMCALL
RAID Managerのコマンドbb....bbの呼び出しに失敗しました。
「SYSTEMCALLの場合の対策」表を参照して，このメッセージの直前に出力されているKFPS01815-Eメッセージのerrno，value値に対応する対策をしてください。
ERRORRETURN[dd....dd]
RAID Managerのコマンドbb....bbがエラーになりました。RAID Managerのコマンドのエラーコードはdd....ddです。コマンドの実行対象となるペア論理ボリュームグループはcc....ccです。
RAID Managerのマニュアルを参照し，エラーコードに対応する処置をしてください。dd....ddに表示されたコードで，代表的なものは「ERRORRETURNの場合の対策」表を参照してください。
GETRESULTFAILED
RAID Managerのコマンドbb....bbの結果取得に失敗しました。
HiRDB運用ディレクトリがあるディスクの空き容量が不足しているか，又はメモリ不足の可能性があります。ディスクの空き容量及びメモリの空き容量を見直して，空き容量を増やしてください。
TIMEOUT
ペア論理ボリュームグループの更新待ち合わせ処理で，待ち合せの上限を超えました。
RAID Manager及びHORCの稼働状態を確認し，cc....ccに表示されたペア論理ボリュームグループについて副ボリュームへの反映が遅延している原因を調査し，対策してください。原因の調査，対策方法については，RAID Manager及びHORCのマニュアルを参照してください。
BROKEN
ペア論理ボリュームグループの更新待ち合わせ処理で，対象のボリュームグループのペア状態が解除されました。
ペア論理ボリュームグループのペア状態が解除された原因を調査し，対策してください。原因の調査，対策方法については，RAID Managerのマニュアルを参照してください。
CHANGED
ペア論理ボリュームグループの更新待ち合わせ処理で，対象のボリュームグループの同期状態が一度解除された後に再同期化されました。
ペア論理ボリュームグループのペア状態が解除された原因を調査し，対策してください。原因の調査，対策方法については，RAID Managerのマニュアルを参照してください。
●SYSTEMCALLの場合の対策
errno
value
意味
対策
2
0
コマンド実行中にプロセスがキャンセルされました。
キャンセルされた原因（意図したキャンセルを除く）を特定し，対策してください。
126
コマンドの実行権限がありません。
HiRDB管理者にRAID Managerの運用管理者権限を与えてください。
127
コマンドがデフォルトパスにインストールされていません。
コマンドをデフォルトパスにインストールしてください。
11
任意
1ユーザが実行中のプロセスの合計が，システムの上限を超えています。
次に示すオペレーティングシステムパラメタ（カーネルパラメタ）の値を大きくしてください。
・HP-UX：maxuprc又はnproc
・Solaris：maxuprc又はmax_nprocs
・AIX 5L：maxuproc又は固定ライセンス数
・Linux：MAX_TASKS_PER_USER又はNR_TASKS
Windows NTの場合，又はこれらの対策をしても改善されない場合は，保守員に連絡してください。
12
任意
次に示すどちらかの要因が考えられます。
・スワップ領域不足のため，プロセスを新しく生成できない
・プロセス数が多過ぎるか，又は一部のプロセスが大量のメモリを消費している
スワップ領域が不足している場合は拡張してください。拡張できない場合は，不要なプロセスを停止してください。一部のプロセスが大量のメモリを消費している場合は，該当するプロセスを一度停止できないか検討してください。
13
任意
コマンドのアクセス権限に誤りがあります。
コマンドのアクセス権限を確認してください。
●ERRORRETURNの場合の対策
dd....ddの値
意味
対策
EX_COMERR
RAID Managerとの通信に失敗しました。
RAID Managerインスタンスが動作しているか，又はHORCMINSTオペランドの指定値が正しいか確認してください。
EX_ATTHOR
RAID Managerインスタンスにコネクトできません。
次に示す対策をしてください。
・RAID Managerインスタンスが動作しているか確認してください。
・HORCMINSTオペランドの指定値が正しいか確認してください。
・ペアボリュームの構成定義が正しいか確認してください。
EX_ENOENTEX_ENOGRP
cc....ccで指定したグループがありません。
次に示す対策をしてください。
・HORCMINSTオペランドの指定値が正しいか確認してください。
・ペアボリュームの構成定義が正しいか確認してください。
EX_INVVOL
cc....ccで指定したグループのステータスが不正です。
cc....ccに含まれる，個々のペアボリュームの属性とステータスを確認し，すべてのペアボリュームの属性が主ボリューム，かつステータスがPAIRになっているか確認してください。
KFPS04681-E
aa....aa invalid; stops unit startup. server ID=bb....bb, old value=cccccc, new value=dddddd　　（Ｅ）
aa....aaオペランドの指定値を変更したため，ユニットを再開始できません。aa....aaオペランドの値は，異常終了，強制終了，又は計画停止後には変更できません。
aa....aa：指定値が一致していないオペランド
・pd_rise_use
・pd_rise_pairvolume_combination
bb....bb：サーバ名
aa....aaオペランドがシステム共通定義，又はユニット制御情報定義の場合は"********"を表示します。
cccccc：aa....aaオペランドの変更前の値
dddddd：aa....aaオペランドの変更後の値
(Ｓ)処理を終了します。
[対策]aa....aaオペランドの値を変更前の値（cccccc）に戻して，ユニットを再開始してください。
KFPS05001-I
Usage: pdls [-d {prc [-a] [-c]|svr [-a [-b]]|scd|trn [-t TRNGID] [-{a|c}]|lck [-a]|mem|sts [-s server_name] [-n logical_file_name|-f physical_file_name|-a|-l|-p]|ha|act|rpl [-j] [-u unit_id] [-s server_name]|rpc [-a]|stj|org [-s server_name] [-a]|aud [-U user_id]|ust}|-a [-b]]　　（Ｓ）
pdlsコマンドのオプション指定形式が誤っています。
(Ｓ)処理を終了します。
(Ｏ)HiRDB/シングルサーバのコマンドの使用方法に従って再度実行してください。
KFPS05001-I
Usage: pdls [-x host_name[,host_name]...|-u unit_id[,unit_id]...] [-d {prc [-{a|s server_name}] [-c]|svr [-a [-b]]|scd [-s server_name]|trn [-t TRNGID] [-{a|c}] [-s server_name]|lck [-a] [-s server_name]|mem|sts [-s server_name] [-n logical_file_name|-f physical_file_name|-a|-l|-p]|ha [-u unit_id|-s server_name][-a]|act [-s server_name]|rpl [-j] [-s server_name]|rpc [-a]|stj [-s server_name]|org [-s server_name] [-a]|aud [-U user_id]|ust}|-a [-b]]　　（Ｓ）
pdlsコマンドのオプション指定形式が誤っています。
(Ｓ)処理を終了します。
(Ｏ)HiRDB/パラレルサーバのコマンドの使用方法に従って再度実行してください。
KFPS05002-I
Usage: pdinit -d statement_control_file_name [-u authorization_identifier [-p password]]　　（Ｓ）
pdinitのオプション指定形式が誤っています。
(Ｓ)処理を終了します。
[対策]ユティリティの使用方法に従って再度実行してください。
KFPS05003-I
Usage: pdmod -a statement_control_file_name　　（Ｓ）
pdmodのオプション指定形式が誤っています。
(Ｓ)処理を終了します。
[対策]ユティリティの使用方法に従って再度実行してください。
KFPS05005-I
Usage: pdstart [{-i|-r|dbdestroy}] [-w]　　（Ｓ）
pdstartコマンドのオプション指定形式が誤っています。
(Ｓ)処理を終了します。
[対策]HiRDB/シングルサーバのコマンドの使用方法に従って再度実行してください。
KFPS05005-I
Usage: pdstart [{-i|-r|dbdestroy}] [-w] | [-x host_name|-u unit_id] [-r|dbdestroy] | [[-x host_name|-u unit_id] -s server_name] | [-a [-s FES_name]] | [-q [-r]] | [-q -c]　　（Ｓ）
pdstartコマンドのオプション指定形式が誤っています。
(Ｓ)処理を終了します。
[対策]HiRDB/パラレルサーバのコマンドの使用方法に従って再度実行してください。
KFPS05006-I
Usage:pdstop [ -P [ -d ] | -f [ -d | -q ] | [ -d ] ]　　（Ｓ）
pdstopコマンドのオプション指定形式が誤っています。
(Ｓ)処理を終了します。
[対策]HiRDB/シングルサーバのコマンドの使用方法に従って再度実行してください。
KFPS05006-I
Usage: pdstop [{[-x host_name|-u unit_id][-s server_name] [-d]|-P [-d]|-f [-x host_name|-u unit_id][-s server_name] [-d]|-z [-d|-q|-c|-s server_name]}]　　（Ｓ）
pdstopコマンドのオプション指定形式が誤っています。
(Ｓ)処理を終了します。
[対策]HiRDB/パラレルサーバのコマンドの使用方法に従って再度実行してください。
KFPS05007-I
System definition check ended. return code = a　　（Ｓ）
pdconfchkコマンドが，リターンコードaで終了しました。
a：リターンコード
0：正常終了
8：エラー終了。引数が不正か，又はpdconfchkコマンドの実行結果でエラーが出力されています。
(Ｓ)処理を終了します。
[対策]リターンコードが0以外の場合，pdconfchkコマンドの実行結果を参照し，エラーの原因を取り除いてください。
KFPS05008-I
Usage: pdcancel {-U|-u uap_name[-i process_id]|-i process_id -d}　　（Ｓ）
pdcancelコマンドのオプション指定形式が誤っています。
(Ｓ)処理を終了します。
[対策]HiRDB/シングルサーバのコマンドの使用方法に従って再度実行してください。
KFPS05008-I
Usage: pdcancel {-x host_name|-X unit_id}{-U|-u uap_name[-i process_id]|-i process_id -d}　　（Ｓ）
pdcancelコマンドのオプション指定形式が誤っています。
(Ｓ)処理を終了します。
[対策]HiRDB/パラレルサーバのコマンドの使用方法に従って再度実行してください。
KFPS05009-I
Usage: pdcat {[-a | -b | -ab] [-c importance_code[,importance_code]...] [-y yyyymmdd] [-t hhmmss] [-T hhmmss] [-n record_number] [file_name] | -d sts {[-x host_name|-u unit_id]|-s server_name} -f full_path_name [-v] [-e] }　　（Ｓ）
pdcatコマンドのオプション指定形式が誤っています。
(Ｓ)処理を終了します。
(Ｏ)HiRDB/シングルサーバのコマンドの使用方法に従って再度実行してください。
KFPS05009-I
Usage: pdcat {[-x host_name|-u unit_id] [-a | -b | -ab ] [-c importance_code[,importance_code]...] [-y yyyymmdd] [-t hhmmss] [-T hhmmss] [-n record_number] [file_name] | -d sts {-x host_name|-u unit_id|-s server_name} -f full_path_name [-v] [-e] }　　（Ｓ）
pdcatコマンドのオプション指定形式が誤っています。
(Ｓ)処理を終了します。
(Ｏ)HiRDB/パラレルサーバのコマンドの使用方法に従って再度実行してください。
KFPS05011-I
Usage: pddump [-f rpc_trace_file_name]　　（Ｓ）
pddumpコマンドのオプション指定形式が誤っています。
(Ｓ)処理を終了します。
(Ｏ)HiRDB/シングルサーバのコマンドの使用方法に従って再度実行してください。
KFPS05011-I
Usage: pddump {-x host_name|-u unit_id}[-f rpc_trace_file_name]　　（Ｓ）
pddumpコマンドのオプション指定形式が誤っています。
(Ｓ)処理を終了します。
(Ｏ)HiRDB/パラレルサーバのコマンドの使用方法に従って再度実行してください。
KFPS05012-I
Usage: pdconfchk [-d directory_name] [-n]　　（Ｓ）
pdconfchkコマンドのオプション指定形式が誤っています。
(Ｓ)処理を終了します。
[対策]コマンドの使用方法に従って再度実行してください。
KFPS05015-I
Usage: pdstjswap [-x host_name|-u unit_id]　　（Ｅ）
pdstjswapコマンドのオプション指定形式が誤っています。
(Ｓ)処理を終了します。
(Ｐ)HiRDB/シングルサーバのコマンドの使用方法に従って，再度実行してください。
KFPS05015-I
Usage: pdstjswap {-x host_name|-u unit_id}　　（Ｅ）
pdstjswapコマンドのオプション指定形式が誤っています。
(Ｓ)処理を終了します。
(Ｐ)HiRDB/パラレルサーバのコマンドの使用方法に従って，再度実行してください。
KFPS05016-I
Usage: pdstbegin {[-k statistics_type[,statistics_type]...] [-m time_interval] [-a|-s server_name[,server_name]…]}　　（Ｓ）
pdstbeginコマンドのオプション指定形式が誤っています。
(Ｓ)処理を終了します。
[対策]HiRDB/シングルサーバのコマンドの使用方法に従って，再度実行してください。
KFPS05016-I
Usage: pdstbegin { [-k statistics_type[,statistics_type]...] [-m time_interval] [-x host_name|-u unit_id] [-a|-s server_name[,server_name]…]}　　（Ｓ）
pdstbeginコマンドのオプション指定形式が誤っています。
(Ｓ)処理を終了します。
[対策]HiRDB/パラレルサーバのコマンドの使用方法に従って，再度実行してください。
KFPS05017-I
Usage: pdstend [-k statistics_type[, statistics_type]...][-a|-s server_name[, server_name]...]　　（Ｓ）
pdstendコマンドのオプション指定形式が誤っています。
(Ｓ)処理を終了します。
[対策]HiRDB/シングルサーバのコマンドの使用方法に従って，再度実行してください。
KFPS05017-I
Usage: pdstend [-k statistics_type[, statistics_type]...][-x host_name|-u unit_id][-a|-s server_name[, server_name]...]　　（S）
pdstendコマンドのオプション指定形式が誤っています。
(Ｓ)処理を終了します。
[対策]HiRDB/パラレルサーバのコマンドの使用方法に従って，再度実行してください。
KFPS05018-I
Usage: pdchgconf　　（Ｓ）
pdchgconfコマンドのオプション指定形式が誤っています。
(Ｓ)処理を終了します。
[対策]コマンドの使用方法に従って，再度実行してください。
KFPS05019-I
Usage: pdopen {-r RDAREA[,RDAREA...]|-r ALL} [-q generation_number]　　（Ｓ）
pdopenコマンドのオプション指定形式が誤っています。
(Ｓ)処理を終了します。
[対策]コマンドの使用方法に従って，再度実行してください。
KFPS05020-I
Usage: pdclose {-r RDAREA[,RDAREA...]|-r ALL} [-q generation_number]　　（Ｓ）
pdcloseコマンドのオプション指定形式が誤っています。
(Ｓ)処理を終了します。
[対策]コマンドの使用方法に従って，再度実行してください。
KFPS05021-I
Usage: pdhold {-r RDAREA[,RDAREA...]|-r ALL} [-q generation_number] {[-c]|[-i]|[-b [-w][-u] | [-s]]}　　（Ｓ）
pdholdコマンドのオプション指定形式が誤っています。
(Ｓ)処理を終了します。
[対策]コマンドの使用方法に従って，再度実行してください。
KFPS05022-I
Usage: pdrels {-r RDAREA[,RDAREA...]|-r ALL} [-q generation_number] [-o]　　（Ｓ）
pdrelsコマンドのオプション指定形式が誤っています。
(Ｓ)処理を終了します。
[対策]コマンドの使用方法に従って，再度実行してください。
KFPS05023-I
Usage: pddbls { { { -r RDAREA[,RDAREA...] | -r ALL | -s server_name[,server_name...] } [ -{ l | a } ] [-{ b | o } ] [ -m ] } | { { -q generation_number | -C } [ - { l | a } ] [ -m ] } }　　（Ｓ）
pddblsコマンドのオプション指定形式が誤っています。
(Ｓ)処理を終了します。
[対策]コマンドの使用方法に従って，再度実行してください。
KFPS05024-I
Usage: pdrplstart　　（Ｌ＋Ｓ）
pdrplstartコマンドのオプション形式が誤っています。
(Ｓ)処理を終了します。
[対策]コマンドの使用方法に従って，再度実行してください。
KFPS05025-I
Usage: pdrplstop [-f]　　（Ｌ＋Ｓ）
pdrplstopコマンドのオプション形式が誤っています。
(Ｓ)処理を終了します。
[対策]コマンドの使用方法に従って，再度実行してください。
KFPS05026-I
Usage: pdndls [-w HiRDB_ID] [-x host_name]　　（Ｅ）
pdndlsコマンドのオプション指定形式が誤っています。
(Ｓ)処理を終了します。
(Ｏ)コマンドの使用方法に従って，再度実行してください。
KFPS05028-I
Usage: pdchprc [-p resident_process_count[,max_process_count]]　　（Ｓ）
pdchprcコマンドのオプション指定形式が誤っています。
(Ｓ)処理を終了します。
(Ｐ)HiRDB／シングルサーバの使用方法に従って再度実行してください。
KFPS05028-I
Usage: pdchprc {-a|-s server_name} [-p resident_process_count[,max_process_count]]　　（Ｓ）
pdchprcコマンドのオプション指定形式が誤っています。
(Ｓ)処理を終了します。
(Ｐ)HiRDB／パラレルサーバの使用方法に従って再度実行してください。
KFPS05029-I
Usage: pdcspool [-i] [-d day_count] [-k { all|dump } ]　　（Ｓ）
pdcspoolコマンドのオプション指定形式が誤っています。
(Ｓ)処理を終了します。
(Ｏ)コマンドの使用方法に従って再度実行してください。
KFPS05030-I
Remove following files　　（Ｓ）
次のファイルを削除します。
(Ｓ)処理を続行します。なお，このメッセージの後に，$PDDIR/spoolを除いた形で，削除するファイルのパス名を一覧出力します。
KFPS05031-E
An error occurred due to bb....bb　　（Ｅ）
コマンドの内部関数にエラーが発生しました。
bb....bb：エラーが発生した要因
(Ｓ)処理を終了します。
[対策]保守員に連絡してください。
KFPS05032-E
RPC　error, return code=aa....aa　　（Ｅ）
RPC通信でエラーが発生しました。
aa....aa：rpcのエラーコード
(Ｓ)処理を終了します。
[対策]「RPC関連エラーの詳細コード」を参照してエラーの原因を取り除き，再度コマンドを実行してください。このエラーが再度発生する場合は，保守員に連絡してください。
KFPS05033-E
Internal function error, func=aa....aa, return code=bb....bb　　（Ｅ）
コマンド内部の処理でエラーが発生しました。
aa....aa：エラーが発生した関数名称
bb....bb：システム関連エラーの詳細コード
(Ｓ)処理を終了します。
[対策]「システム関連エラーの詳細コード」を参照して，エラーの原因を取り除いてください。ユーザが対応できないエラーが発生している場合，保守員に連絡してください。
KFPS05034-E
System call error, func=aa....aa, return code=bb....bb, errno=cc....cc　　（Ｅ）
システム関数でエラーが発生しました。エラーになった関数名，関数のリターンコード及びerrnoを出力します。
aa....aa：関数名称
bb....bb：リターンコード
cc....cc：errnoの値
(Ｓ)処理を終了します。
(Ｏ)エラーインジケータの値を調査し，errno.h及びユーザが使用するOSのマニュアルを参照してエラーの原因を取り除き，再度実行してください。
[対策]エラーの要因を取り除き，コマンドを実行してください。
KFPS05035-E
Unable to start command; insufficient memory on PROCESS　　（Ｅ）
プロセス固有領域が不足しました。
(Ｓ)処理を終了します。
[対策]「4.3　システムコールのリターンコード」の「システムコール=malloc，ニモニック＝ENOMEN」を参照して，エラーとなった原因を調査し，対策してください。
KFPS05036-E
aa....aa receive data incorrect　　（Ｅ）
コマンドaa....aaに関するRPCの受信結果が不正です。
aa....aa：コマンド名称
(Ｓ)処理を終了します。
[対策]通信障害又はメモリ不足が発生している可能性があります。このメッセージの前に障害メッセージが出力されている場合は，そのメッセージに従って対策してください。対策後もこのメッセージが出力される場合は保守員に連絡してください。
KFPS05037-E
Enter command in manager node　　（Ｅ）
システムマネジャではないホストへコマンドが入力されました。
(Ｓ)処理を終了します。
(Ｏ)システムマネジャがあるサーバマシンでコマンドを入力してください。
KFPS05038-E
Remote procedure call error occurred　　（Ｅ）
通信エラーが発生しました。
(Ｓ)処理を終了します。
[対策]このメッセージの前に障害メッセージが出力されている場合は，そのメッセージに従って対策してください。メッセージが出力されていない場合は保守員に連絡してください。
KFPS05039-E
Unable to access shared memory　　（Ｅ）
共用メモリにアクセスできません。
(Ｓ)処理を終了します。
[対策]
HiRDBの共用メモリを削除した可能性があります。HiRDBの共用メモリを削除した場合は，保守員に連絡してください。
前記以外の場合は，既に出力されている詳細メッセージに従って，エラーの原因を取り除いてください。詳細メッセージが出力されていない場合，保守員に連絡してください。
なお，Windows版のHiRDB/パラレルサーバを使用している場合，pdstartコマンドの入力直後にこのメッセージが出力されることがあります。この場合，システム定義が誤っている可能性があるため，イベントログに出力されているメッセージを基にシステム定義を見直してください。
KFPS05040-E
Unable to start command due to HiRDB status off line　　（Ｅ）
HiRDBが開始されていない状態でコマンドが入力されました。
(Ｓ)処理を終了します。
[対策]HiRDBを開始してからコマンドを実行してください。
KFPS05041-E
Incorrect server name specified　　（Ｅ）
コマンドのオプションに指定したサーバ名に誤りがあります。HiRDBのサーバとして定義されていないサーバ名を指定したか，又はコマンド実行対象外のサーバ名を指定しています。
(Ｓ)処理を終了します。
[対策]サーバ名を確認し，コマンドを再実行してください。
KFPS05042-E
Incorrect hostname or unit id specified　　（Ｅ）
コマンドのパラメタに，HiRDBのホスト又はユニットとして定義されていないホスト名称又はユニット識別子が指定されました。
(Ｓ)処理を終了します。
[対策]HiRDBのホスト又はユニットとして定義されているホスト名称又はユニット識別子を指定して，コマンドを実行してください。
KFPS05043-E
Unable to execute aa....aa command from bb....bb to cc....cc　　（Ｅ）
リモートホストに対して，コマンドが実行できません。
aa....aa：コマンド名称
bb....bb：ローカルホスト名称
cc....cc：リモートホスト名称
(Ｓ)処理を終了します。
[対策]ローカルホストからリモートホストに対して同じユーザIDでログインする権限があるか調査してください。又は，ログインシェルがc-shellの場合，＄HOME/.cshrcに誤ったPDDIRを設定していないか調査してください。
pdconfchkコマンドを実行した場合にこのメッセージが表示されて，メッセージ中のcc....ccに予備系のホスト名が表示されたときは，pd_hostnameオペランドに指定したホスト名，又はpdstartオペランドの-xオプションに指定したホスト名が間違っている可能性があります。pd_hostnameオペランドに現用系の標準ホスト名を指定しているか確認してください。また，pdstartオペランドの-xオプションに正しいホスト名を指定しているか確認してください。
KFPS05044-E
Communication error occurred,function=aa....aa, errno=bb....bb　　（Ｅ）
ユティリティの異常終了を知らせる通信に，エラーが発生しました。
aa....aa：エラーが発生した関数名
bb....bb：errno
(Ｓ)処理を終了します。
[対策]エラーインジケータの値を調査して，エラーの原因を取り除き，必要があれば再度ユティリティを実行してください。繰り返しこのエラーメッセージが出力される場合，保守員に連絡してください。
KFPS05045-E
No server in this unit　　（Ｅ）
コマンドを入力したユニットには，サーバの定義がありません。
(Ｓ)処理を終了します。
[対策]コマンドを入力したユニットを間違えている場合，正しいユニットでコマンドを実行してください。そのほかの場合，一度ユニットを停止し，サーバ定義を追加した後，再度コマンドを実行してください。
KFPS05045-E
No dictionary server　　（Ｅ）
ディクショナリサーバの定義がありません。
(Ｓ)処理を続行します。
[対策]システム共通定義にディクショナリサーバの定義があるか調査してください。
〈ディクショナリサーバの定義がある場合〉
再度実行してください。再度このメッセージが出力されるときは，保守員に連絡してください。
〈ディクショナリサーバの定義がない場合〉
ディクショナリサーバを定義してください。
KFPS05046-E
Dictionary already initialized　　（Ｅ）
既にディクショナリの初期化は完了しています。
(Ｓ)処理を終了します。
[対策]初期化するときは，マスタディレクトリ用RDエリアのHiRDBファイル領域をpdfmkfsコマンドで再作成するか，又はpdstart　-iでシステム起動後に，初期化してください。
KFPS05047-E
Command aa....aa failed, process ID=bb....bb　　（Ｌ）
運用コマンド，又はユティリティのコマンドプロセスが異常終了しました。
aa....aa：コマンド名称
bb....bb：プロセスID
(Ｓ)処理を続行します。
[対策]このメッセージの前に出力されたメッセージトラブルシュート情報（ダンプ，トレースなど），及び対応するサーバに関するメッセージを基に，コマンドの異常終了要因を調査して，対策してください。対処できない場合は，保守員に連絡してください。
KFPS05048-Q
Fall-back operation will be started, do you really want to proceed ? (y/n)　　（Ｅ＋Ｌ）
pd_start_skip_unitオペランドを指定して，HiRDBシステムを縮退起動しようとするとき，縮退起動してよいかどうかの応答を待ちます。
(Ｓ)処理を続行します。
(Ｏ)このメッセージの直前にKFPS01837-Iメッセージで起動処理をスキップするユニット識別子を表示します。その内容を確認したうえで縮退起動する場合は'y'を，しない場合は'n'を応答してください。'n'を応答した場合は，HiRDBの開始処理を中止します。
KFPS05049-Q
DB recovery from backup required when restarting with "pdstart -dbdestroy", (n/3), do you really want to proceed ?(y/n)　　（Ｓ）
"pdstart dbdestroy"でHiRDBを再開始すると，データベース回復ユティリティでのデータベースの回復が必要になります。そのため，本当に強制開始をするかどうかを問い合わせます。このメッセージが最大3回出力され，3回のメッセージにすべて"y"を応答すると，強制開始をします。"y"以外を応答すると強制開始をキャンセルして終了します。"pdstart dbdestroy"は，"pdstart"でHiRDBが開始できない場合だけ入力します。必ず，最初に"pdstart"でHiRDBを再開始してください。再開始できない場合には，次の処置をしてください。
1. "pdstart -r"でHiRDBを再開始します。
2. マスタディレクトリ用RDエリアを回復し，バックアップを取得後，HiRDBシステムを終了します。
3. "pdstart dbdestroy"でHiRDBを強制開始します。
4. 前回のHiRDBの開始後，又はpdcloseコマンド入力以降に更新したRDエリアの回復，及びバックアップを取得後，閉塞状態を解除します。
(Ｓ)応答を待ちます。
[対策]
〈強制開始する場合〉
出力されるすべてのメッセージに"y"を応答してください。
〈強制開始をキャンセルする場合〉
"y"以外を応答してください。
KFPS05050-Q
DB will be initialized when restarting with "pdstart -i", do you really want to proceed ? (y/n)　　（Ｓ）
pdstart -iコマンドでHiRDBを開始すると，すべてのデータベースを再度作り直す必要があるため，本当に初期設定モードで開始するかどうかを問い合わせます。
"y"を応答すると，初期設定モードでの開始を続行します。
"y"以外を応答すると，開始をキャンセルして終了します。
データベースの初期設定をしないでHiRDBを開始する場合は，pdstartコマンドを入力してください。
(Ｓ)応答を待ちます。
[対策]データベースを再初期化する場合は，"y"を応答してください。データベースを再初期化しない場合は，"y"以外を応答してください。
KFPS05051-E
Unable to cancel process due to status critical　　（Ｅ）
ステータスがクリティカル状態であるため，プロセスを取り消せません。
(Ｓ)コマンドを終了します。
(Ｏ)必要であれば，再度コマンドを実行してください。
KFPS05052-E
Unable to cancel process due to HiRDB status busy　　（Ｅ）
HiRDBが高負荷状態であるため，プロセスの取り消しに失敗しました。
(Ｓ)コマンドを終了します。
(Ｏ)必要であれば，再度コマンドを実行してください。
KFPS05053-E
Unable to specify manager node　　（Ｓ）
コマンドのパラメタにシステムマネジャがあるサーバマシン（ホスト）を指定してはいけません。
(Ｓ)処理を終了します。
[対策]システムマネジャがあるサーバマシンにコマンドを入力してください。
KFPS05054-E
Same UAP name process exists, Specify server process id　　（Ｅ）
pdcancelコマンドで指定されたUAP名称と同じ名称のUAP処理プロセスが複数あります。
(Ｓ)処理を終了します。
[対策]プロセスIDを指定して再度コマンドを実行してください。
KFPS05055-E
No such process　　（Ｅ）
次のどれかに該当します。
・pdcancelコマンドで指定されたプロセスがありません。
・pdcancelコマンドを実行する直前に該当するプロセスが終了しています。
・-dオプションを指定したpdcancelコマンドで，HiRDBシステム制御プロセスをキャンセルしようとしました。
(Ｓ)処理を終了します。
(Ｏ)
・該当するプロセスが残っている場合，プロセスidを指定するか，又はUAP名称を訂正して再度実行してください。
・-dオプションを指定したpdcancelコマンドを実行するときは，フロントエンドサーバ，バックエンドサーバ，ディクショナリサーバ，シングルサーバ，ユティリティプロセスのどれかのプロセスIDを指定してください。
KFPS05056-E
Unable to stop MGR unit with "-z" option　　（Ｅ）
システムマネジャ（MGR）で-zオプションのpdstopコマンドは実行できません。
(Ｓ)処理を終了します。
(Ｏ)システムマネジャを終了する場合は，pdstopコマンドでオプションを指定しないか，又は-fオプションを指定して，HiRDBシステムを終了してください。
KFPS05057-W
Unable to find server process　　（Ｅ）
pdcancelコマンドでキャンセルしようとしたHiRDB/シングルサーバのプロセスがありません。
(Ｓ)処理を終了します。
[対策]オプションに指定したキャンセル対象のプロセスがあるかどうか確認して，必要があれば，オプションを正しく指定して再度実行してください。
KFPS05057-W
Unable to find front end server process　　（Ｅ）
pdcancelコマンドでキャンセルしようとしたHiRDB/パラレルサーバのフロントエンドサーバのプロセスがありません。
(Ｓ)処理を終了します。
[対策]オプションに指定したキャンセル対象のプロセスがあるかどうか確認して，必要があれば，オプションを正しく指定して再度実行してください。
KFPS05058-E
Dictionary being initialized　　（Ｓ）
pdinitは，既に実行中です。
(Ｓ)処理を終了します。
KFPS05059-E
Usage: aa...aa　　（Ｓ）
コマンドのオプション指定形式が誤っています。
aa....aa：コマンドの形式
(Ｓ)処理を終了します。
[対策]マニュアル「HiRDB Version 7 コマンドリファレンス」でコマンドの使用方法を確認して，再度実行してください。
KFPS05060-E
Unable to execute aa...aa because bb...bb　　（Ｓ）
aa...aaコマンドが実行できません。
aa....aa：コマンド名
bb....bb：理由コード
file not found：設定ファイルがありません。
setup file is invalid：設定ファイルに誤りがあります。
(Ｓ)処理を終了します。
[対策]
・file not fount
aa...aaコマンドに指定した設定ファイル名のパス名が正しいか確認してください。
・set file is invalid
aa...aaコマンドに指定した設定ファイルの内容に間違いがあります。設定ファイルの内容を修正して，再度コマンドを実行してください。
KFPS05061-E
Too long path name with aa....aa and directory_name　　（Ｅ）
pdconfchkコマンドの-dオプションに指定したディレクトリ下のHiRDBシステム定義ファイルのパス名が長過ぎます。
aa....aa：
・PDDIR：ユニット制御情報定義ファイルの格納場所
・PDCONFPATH：ユニット制御情報定義ファイル以外のHiRDBシステム定義ファイルの格納場所
(Ｓ)処理を終了します。
[対策]次に示す対策をしてください。
・aa....aaがPDDIRの場合
$PDDIR/conf/サブディレクトリのパス名が220バイト以内になるように見直してください。
・aa....aaがPDCONFPATHの場合
ユニット制御情報定義にPDCONFPATHオペランドを指定した場合は，共用ディレクトリ＋サブディレクトリのパス名が220バイト以内になるように見直してください。ユニット制御情報定義にPDCONFPATHオペランドを指定していない場合は，$PDDIR/conf/サブディレクトリのパス名が220バイト以内になるように見直してください。
KFPS05062-W
Unmatched PDCONFPATH between system definition file and environment variable　　（Ｅ）
ユニット制御情報定義ファイルのPDCONFPATHオペランドの値（指定がない場合は$PDDIR/confを仮定）とpdconfchk実行時の環境変数PDCONFPATHの値が異なります。pdconfchkコマンドはユニット制御情報定義ファイルのPDCONFPATHオペランドの値を利用しています。
(Ｓ)処理を続行します。
[対策]環境変数PDCONFPATHの値を見直してください。
KFPS05063-E
Unable to stop normally because unit terminated abnormally　　（Ｓ）
異常終了又はpdstop -fコマンドで停止したユニットがあるため，HiRDBを正常終了できません。
(Ｓ)処理を続行します。
[対策]異常終了，又はpdstop -fで停止したユニットをpdlsコマンドで確認して，該当するユニットを開始した後，pdstopコマンドで正常終了してください。又は，pdstop -fコマンドで強制終了してください。
KFPS05064-E
Unable to stop HiRDB normally because unit being started　　（Ｓ）
開始処理中のユニットがあります。このため，HiRDBを正常終了できません。
(Ｓ)処理を続行します。
[対策]HiRDBシステムの開始が完了してから再度pdstopコマンドを実行してください。又は，pdstop -fコマンドで強制終了してください。
KFPS05065-E
Unable to stop HiRDB normally because unit being terminated　　（Ｓ）
終了処理中のユニットがあります。このため，HiRDBを正常終了できません。
(Ｓ)処理を続行します。
[対策]ユニット停止が完了してから再度pdstopコマンドを実行してください。又は，pdstop -fコマンドで強制終了してください。
KFPS05066-E
Error found while analyzing system common definition file　　（Ｅ）
システム共通定義のオペランドを解析するときにエラーを検出しました。
(Ｓ)処理を終了します。
[対策]システム共通定義の定義内容を訂正し，再度実行してください。
KFPS05067-E
Unable to start server due to dictionary server is inactive　　（Ｅ）
ディクショナリサーバが起動中ではないため，フロントエンドサーバ又はバックエンドサーバを開始できません。
(Ｓ)処理を終了します。
[対策]ディクショナリサーバを運用上停止している場合でなければ，ディクショナリサーバを起動してから再度実行してください。
KFPS05068-E
Unable to stop aaaa normally due to existence of half status unit　　（Ｓ）
閉塞中のユニットがあります。このため，aaaaを正常終了できません。
aaaa：終了種別
HiRDB：システム
unit：ユニット
server：サーバ
(Ｓ)処理を続行します。
[対策]終了するためには，pdstop -fコマンドを入力してください。
KFPS05069-W
Unable to stop unit due to error occurred while terminating　　（Ｓ）
終了処理中にエラーが発生したため，終了できないユニットがあります。
又は既にユニットが終了しています。
(Ｓ)処理を続行します。
[対策]
直前にKFPS05222-Eメッセージが出力されている場合は，そのメッセージに従って対処してください。pdstop -fコマンドの場合は，既にユニットが停止している可能性があるため，直前に出力されたメッセージを確認してください。
上記以外の場合は，終了できないユニットを直前のメッセージから確認し，pdstop -f又はpdstop -zコマンドでユニットを停止してください。
強制終了できない場合は保守員に連絡してください。
KFPS05070-E
Unable to stop unit normally due to error occurred while terminating　　（Ｓ）
終了処理中にエラーが発生したため，ユニットを正常終了できません。
(Ｓ)処理を続行します。
[対策]pdstop -fコマンドでユニットを停止してください。停止できない場合は，保守員に連絡してください。
KFPS05071-E
Unable to stop server due to error occurred while terminating　　（Ｓ）
終了処理中にエラーが発生したため，サーバを正常終了できません。又は既にサーバが停止しています。
(Ｓ)処理を続行します。
[対策]
pdstop -fコマンドでサーバを停止してください。停止できない場合は，保守員に連絡してください。
停止コマンドの実行時，既にサーバが停止している場合，このメッセージが出力されることがあります。この場合，このメッセージを無視してください。
停止しようとしたサーバが稼働していたユニットのsyslogfileに，停止できない理由を示すメッセージが出力されている場合は，そのメッセージを参照してください。
KFPS05072-W
HiRDB system termination process(mode = aa....aa) execution exceeds bb minutes　　（Ｅ＋Ｌ）
HiRDBの停止処理がbb分を過ぎても終了しません。
(Ｓ)pdstop -Pコマンドは終了しますが，計画停止処理は続行します。
[対策]次に示すどれかの処置をしてください。
・実行中のユティリティ又はトランザクションが終了するまで計画停止処理を待たせる場合は何もする必要はありません。
・実行中のユティリティ又はトランザクションの処理を打ち切って計画停止をする場合は，pdcancelコマンドで実行中のユティリティ又はトランザクションをキャンセルします。ユティリティ又はトランザクションがキャンセルされると，HiRDBは計画停止します。
・pdcancelコマンドでトランザクションをキャンセルできない場合は，該当するプロセスをOSの-6オプション指定のkillコマンド（Windows NTの場合はpdkillコマンド）で削除して，ユニットを強制終了した後，$PDDIR/spool下の資料を保存して保守員へ連絡してください。
KFPS05073-E
Environmental variable aa....aa nothing.　　（Ｅ）
環境変数aa....aaが設定されていません。
aa....aa：環境変数
(Ｓ)HiRDBの環境変数の設定状態によって，処理を続行又は終了します。
[対策]HiRDBに必要な環境変数がすべて設定されているかどうか見直してください。対策後，再度コマンドを実行してください。
KFPS05074-E
Unable to stop normally, use pdstop command with "-f" option　　（Ｓ）
終了処理中にエラーが発生したため，正常終了できません。
(Ｓ)処理を終了します。
(Ｏ)UAP，又はユティリティ実行中の処理がある場合，処理が終了してから，再度pdstopコマンドを実行してください。そのほかの場合，pdstop -fコマンドで強制終了してください。
[対策]終了できない場合，保守員に連絡してください。
KFPS05075-E
Unable to execute command, command=aa....aa, return code=bb....bb, errno=cc....cc　　（Ｅ）
コマンド中で実行するシェルコマンドが失敗しました。
aa....aa：実行しようとしたコマンド
bb....bb：コマンドのリターンコード
cc....cc：エラー番号
(Ｓ)処理を終了します。
[対策]実行しようとしたコマンドが，失敗した原因を取り除き，必要があれば再度コマンドを実行してください。繰り返しこのエラーメッセージが出力される場合，保守員に連絡してください。
KFPS05076-E
Unable to start this unit with "-i" option　　（Ｌ）
ユティリティ専用ユニットはpdstart -iコマンドで開始できません。
HiRDB/パラレルサーバの場合は，ユニット単位の開始時に-iオプションを指定できません。
(Ｓ)処理を終了します。
[対策]HiRDB/シングルサーバの場合はpdstartコマンドで開始してください。又は，pdstartコマンドで"-r"又は"dbdestroy"オプションを指定して開始してください。
HiRDB/パラレルサーバで再度初期設定する場合は，システムの停止後にpdstart -iコマンドでシステムを開始してください。ユニットを開始する場合は，pdstartコマンドに"-x"オプションを指定するか，又はこれに"-r"又は"dbdestroy"オプションを指定してください。
KFPS05077-E
Unable to execute remote shell command, hostname=aa....aa　　（Ｅ）
リモートホストに対してリモートシェルコマンドが実行できません。
aa....aa：ホスト名称
(Ｓ)処理を終了します。
[対策]コマンドが実行できなかったホストに対してリモートシェル実行権限があるか確認し，必要があれば再度実行してください。Windows版でHiRDB/パラレルサーバを使用する場合，又はHiRDB/シングルサーバで系切り替え機能を使用する場合，リモートシェルとの接続が必要です。設定が漏れていないか確認してください。詳細は，マニュアル「HiRDB Version 7 システム導入・設計ガイド」の「OS環境ファイルの設定」を参照してください。
KFPS05078-I
Unable to recognize HiRDB system initialization completion　　（Ｌ）
pdstartコマンドでシステム初期化処理の完了を確認できません。
(Ｓ)処理を続行します。
[対策]
・データベース初期設定ユティリティを実行していない場合
この場合，KFPS05201-Qメッセージが出力されていないか確認してください。出力されているときは，pdinitコマンド入力待ちになっています。pdinitコマンドを実行してください。ユティリティの処理が終了後，システムの初期化処理を再開します。しばらくしてからpdlsコマンドを入力して，システムの状態を確認してください。なお，pdinitコマンドの入力待ちになっているかどうかは，pdlsコマンドでも確認できます。
・HiRDBバージョンアップコマンドを実行していない場合
この場合，KFPS05203-Qメッセージが出力されていないか確認してください。出力されているときは，pdvrupコマンド入力待ちになっています。pdvrupコマンドを実行してください。pdvrupコマンドの処理が終了後，システムの初期化処理を再開します。しばらくしてからpdlsコマンドを入力して，システムの状態を確認してください。
・データベース初期設定ユティリティ，HiRDBバージョンアップコマンド入力要求がない場合
サーバの起動に時間が掛かっているため，しばらくしてからpdlsコマンドを入力し，システムの状態を確認してください。システムの初期化処理が完了しない場合，ほかに原因がないかメッセージを確認してください。なお，原因が判明しない時は，保守員に連絡してください。
・pdstartコマンドが正常終了しない場合
pd_system_complete_wait_timeオペランドに，pdstartコマンドの完了待ち時間を指定してください。完了待ち時間を長くすれば，pdstartコマンドを正常終了させられます。
・系切り替え機能を使用していて，待機系を起動した場合
実行系ユニットが起動していないため，待機系ユニットが実行系ユニットの起動を待ち合わせている可能性があります。pdlsコマンド，及びHAモニタ又はHitachi HA Toolkit Extensionのコマンドで実行系ユニットの状態を確認してください。実行系ユニットが起動していない場合は起動エラーの原因を取り除いた後に実行系ユニットを再度起動してください。
・系切り替え機能を使用していて，実行系を起動した場合
系が実行系ユニットの起動を待ち合わせているか，待機系ユニットとして起動している可能性があります。pdlsコマンド，及びHAモニタ又はHitachi HA Toolkit Extensionのコマンドで系の状態を確認してください。実行系ユニットとして起動していない場合，HAモニタ（Hitachi HA Toolkit Extension）のコマンド又はクラスタソフトウェアで実行系ユニットとして起動してください。
KFPS05079-E
Dictionary not initialized, unable to start server　　（Ｅ）
ディクショナリがpdinitコマンドで初期化されていないにもかかわらず，pdstartコマンドでサーバを開始しようとしました。
(Ｓ)処理を終了します。
[対策]ディクショナリを初期化し，必要があれば再度実行してください。
KFPS05080-Q
Uap name=aa....aa, uap start time=bb....bb, server process id=cc....cc,cancel process ? (y/n)　　（Ｓ）
pdcancelコマンドにUAP名称を指定して実行する場合は，UAP名称，UAP開始時間，サーバのプロセスIDを出力して，キャンセルを実行するかどうかの応答を待ちます。
pdcancelコマンドに-dオプションを指定して実行する場合は，サーバのプロセスIDを出力して，キャンセルを実行するかどうかの応答を待ちます。
aa....aa：UAP名称
pdcancelコマンドを-dオプション指定で実行した場合は，"********"を表示します。
bb....bb：UAP開始時間
pdcancelコマンドを-dオプション指定で実行した場合は，"999999"を表示します。
cc....cc：キャンセル対象プロセスのプロセスID
(Ｓ)処理を続行します。
(Ｏ)キャンセルを続行する場合は"y"，中止する場合は"n"を入力してください。
KFPS05081-Q
Cancel all server process ? (y/n)　　（Ｓ）
HiRDB/シングルサーバ中のすべてのUAP処理プロセスをキャンセルするかどうかの応答を待ちます。
(Ｓ)処理を続行します。
[対策]キャンセルを続行する場合は"y"，中止する場合は"n"を入力してください。
KFPS05081-Q
Hostname=aa....aa, cancel all front end server processes ? (y/n)　　（Ｓ）
指定されたホストで実行中のすべてのUAP処理プロセスをキャンセルする場合に，キャンセルするかどうかの応答を待ちます。
aa....aa：ホスト名称
(Ｓ)処理を続行します。
[対策]キャンセルを続行する場合は"y"，中止する場合は"n"を入力してください。
KFPS05082-Q
Utility server name=aa....aa, process id=bb....bb, cancel process ? (y/n)　　（Ｓ）
pdcancelコマンドでユティリティをキャンセルする場合に，ユティリティのサーバ名称とプロセスIDを出力し，キャンセルするかどうかの応答を待ちます。
aa....aa：ユティリティサーバ名称
bb....bb：ユティリティサーバのプロセスID
(Ｓ)処理を続行します。
[対策]キャンセルを続行する場合は"y"，中止する場合は"n"を入力してください。
KFPS05083-E
aa....aa terminated, due to server process abnormal end　　（Ｅ）
ユティリティ，又は運用コマンドで，通信相手のサーバプロセスが異常終了しました。
aa....aa：コマンド名称
(Ｓ)処理を終了します。
[対策]pdstop，又はpdcancelでサーバプロセスを終了させた場合以外は，保守員に連絡してください。
KFPS05084-E
Invalid option argument specified, option argument=aa....aa　　（Ｅ）
コマンドで，不正なオプション引数が指定されました。
aa....aa：オプション引数
(Ｓ)処理を終了します。
[対策]オプション引数を訂正し，必要ならば再度実行してください。
KFPS05085-W
Insufficient memory in message buffer pool, due to concurrent execution of aa....aa command　　（Ｅ）
aa....aaコマンドを同時実行するときに，HiRDBサーバ用のメッセージ格納バッファプールのメモリが，一時的に不足しました。なお，該当するエラーの発生に伴って，KFPS00854-Wが出力されることがあります。しかし，この場合は，サーバ障害ではありません。
aa....aa：運用コマンドの名称
pddbls：RDエリアの状態表示
pdclose：RDエリアのクローズ
pdhold：RDエリアの閉塞
pdmod：データベース構成変更ユティリティ
pdopen：RDエリアのオープン
pdrels：RDエリアの閉塞解除
(Ｓ)処理を終了します。
(Ｏ)現在実行中のコマンドの実行完了後，再度実行してください。
KFPS05087-E
Unable to execute aa....aa command because bb....bb　　（Ｅ）
系切り替え構成でないため，aa....aaコマンドを実行できません。
aa....aa：コマンド名
・pdls -d ha
・pdstop -f -q（HiRDB/シングルサーバの場合）
・pdstop -z -q（HiRDB/パラレルサーバの場合）
bb....bb：コマンドを実行できない理由
・pd_ha is not 'use'：系切り替え構成でないシステムです。
・pd_ha is not 'use' or pd_ha_unit is 'nouse'：系切り替え構成でないシステム，又はユニットです。
(Ｓ)処理を終了します。
[対策]pd_haオペランドにuseを指定しているか確認してください。また，pd_ha_unitオペランドにnouseを指定しているか確認してください。
KFPS05090-E
Unable to execute pdndls command　　（Ｌ）
pdndlsコマンドを実行できません。
(Ｓ)処理を終了します。
(Ｏ)マルチノード構成定義ファイルを作成後，再度実行してください。
KFPS05091-E
Incorrect HiRDB ID specified　　（Ｌ）
コマンドのパラメタに定義されていないHiRDB識別子が指定されました。
(Ｓ)処理を終了します。
(Ｏ)マルチノード構成定義ファイルに記述しているHiRDB識別子の内容又はオプションに定義したHiRDB識別子の内容を確認してください。
KFPS05092-E
Error occurred　　（Ｅ）
pdndlsコマンドの実行中にエラーを検知しました。
(Ｓ)処理を続行します。
(Ｏ)このメッセージの次に表示されるエラーの詳細内容を確認して，対処してください。
KFPS05093-E
Error found while analyzing pdmnd definition file　　（Ｅ）
pdndlsコマンドを実行できません。
(Ｓ)処理を終了します。
(Ｏ)マルチノード構成定義ファイルの内容を確認してください。
KFPS05094-E
System error, func=aa....aa, code=bb....bb, detail=cc....cc, call func=dd....dd, line=ee....ee　　（Ｅ）
HiRDB組み込み支援機能の内部処理で異常を検知しました。
aa....aa：異常が発生した関数名
bb....bb：エラーコード
cc....cc：エラー詳細コード
dd....dd：呼び出し元ファイル名（内部情報）
ee....ee：呼び出し元行番号（内部情報）
(Ｓ)処理を終了します。
(Ｏ)次のどちらかの処置をしてください。
・HiRDB組み込み支援機能を使用していない場合
このコマンドはHiRDB組み込み支援機能を使用している場合に実行できるコマンドです。
・HiRDB組み込み支援機能を使用している場合
運用モデル設定ファイルの参照に失敗しました。運用モデル設定ファイルの状態を検証してください。又は，環境変数PDEMBDIRの設定が正しいか確認してください。
[対策]「エラー詳細コード一覧」を参照して対策してください。原因が不明の場合はこのメッセージの内容，$PDDIR/spool下のファイル，及びsyslogfile（Windows NTの場合はイベントログ）のバックアップを取得して保守員に連絡してください。
KFPS05095-E
Unable to execute command, user=aa...aa　　（Ｅ）
ユーザaa....aaが入力したコマンドが実行できません。
aa...aa：コマンドを入力したログインユーザ名
(Ｓ)処理を終了します。
(Ｏ)コマンドを入力したログインユーザ環境を見直してください。コマンドの詳細，及びエラー原因については直前に出力されているKFPS05043-E又はKFPS05077-Eメッセージを確認してください。
KFPS05096-I
Usage: pdpfresh [-s server_name] [-{f | c} ]　　（Ｓ）
pdpfreshコマンドのオプション指定形式が誤っています。
(Ｓ)処理を終了します。
[対策]オプションの指定を修正して再度実行してください。
KFPS05097-E
Unable to stop normally during Online DB Reorganization　　（Ｓ）
更新可能なオンライン再編成が完了していないため，正常終了できません。
(Ｓ)処理を終了します。
[対策]オプションの指定を修正して再度実行してください。
(Ｏ)pdls -d orgコマンドを実行し，オンライン再編成の追い付き反映が完了したことを確認してください。完了していたら，再度pdstopコマンドで正常終了してください。オンライン再編成の追い付き反映が完了する前にHiRDBを終了させたい場合は，計画停止（pdstop -P）又は強制終了（pdstop -f）を実行してください。
KFPS05098-I
Usage: pdprgrenew [-b] HiRDB_home_directory　　（Ｓ）
pdprgrenewコマンドのオプション指定形式が誤っています。
(Ｓ)処理を終了します。
[対策]オプションの指定を修正して再度実行してください。
KFPS05099-I
Usage: pdprgcopy HiRDB_home_directory　　（Ｓ）
pdprgcopyコマンドのオプション指定形式が誤っています。
(Ｓ)処理を終了します。
[対策]オプションの指定を修正して再度実行してください。
KFPS05100-E
Error occurred in HiRDB unit starting process,reason code = aa　　（Ｌ）
ユニットの開始処理中に障害が発生し，ユニットの起動ができません。
aa：理由コード
10：定義解析エラー
20：通信障害発生
30：領域不足発生
40：共用メモリ不足発生
(Ｓ)異常終了します。
[対策]理由コードに従って対策してください。対策できない場合は，保守員に連絡してください。
理由コード
意味
対策
10
定義解析エラー
直前に出力されたメッセージを参照してHiRDBシステム定義に誤りがないかどうかを確認し，誤りを訂正してください。
20
通信障害発生
直前に出力されたメッセージを参照して通信障害の原因を調査し，取り除いてください。
30
領域（メモリ）不足発生
ほかのプロセスが終了してから実行するか，スワップ領域のサイズを見直して再度実行してください。
40
共用メモリ不足発生
共用メモリサイズの見積もりが正しいか見直してください。見積もりが正しい場合は保守員に連絡してください。
KFPS05101-E
HiRDB unit definition parameter analysis error　　（Ｌ）
HiRDBユニットの定義パラメタを解析中に，エラーが発生しました。
(Ｓ)異常終了します。
[対策]保守員に連絡してください。
KFPS05102-E
Insufficient memory on STATIC_SHMPOOL, size=aa....aa　　（Ｌ）
共用メモリの確保エラーが発生しました。
aa....aa：確保しようとした領域サイズ（単位：バイト）
(Ｓ)処理を終了します。
[対策]このユニットの$PDDIR/spool下のファイル，及びsyslogfile（Windows NTの場合はイベントログ）を資料として保存した後，保守員に連絡してください。
KFPS05110-I
HiRDB unit aaaa initialization process complete　　（Ｌ）
HiRDBユニットaaaaの初期化が完了しました。
aaaa：ユニット識別子
(Ｓ)処理を続行します。
KFPS05111-E
Error occurred in HiRDB unit aaaa termination process. mode = bb....bb, reason code = cc....cc　　（Ｌ）
HiRDBユニットaaaaの終了処理中にエラーが発生しました。
終了モードがPLANの場合は，すべてのユニットを強制終了します。
aaaa：ユニット識別子
bb....bb：終了モード
NORMAL：正常終了
PLAN：計画停止
FORCE：強制終了
cc....cc：理由コード
COMMUNICATION：システムマネジャへの通信エラー
INTERNAL ERROR：内部処理エラー
(Ｓ)異常終了します。
[対策]このメッセージの前に出力されたメッセージなどを調査し，障害を取り除いた後，システムを再起動してください。
〈計画停止中の場合〉
すべてのユニットが停止していることを確認してから，システムを再起動してください。
停止していないユニットがあるときは，システムマネジャユニットからpdstop -fコマンドを入力するか，又は停止していないユニットに直接loginしてpdstop -zコマンドを入力し，停止した後にシステムを再起動してください。
なお，ユニットの停止状況の確認方法は，各ユニットのsyslogfile（Windows NTの場合はイベントログ）を参照し，次のメッセージが出力されていればそのユニットは停止しています。
・KFPS01821-Eメッセージ
・システムマネジャユニットの場合：KFPS01850-Iメッセージ（終了モード＝FORCE）
・システムマネジャではないユニットの場合：KFPS01841-Iメッセージ（終了モード＝FORCE）
原因不明の場合には，このユニットの$PDDIR/spool下のファイル，及びsyslogfile（又はイベントログ）を資料として保存した後，保守員に連絡してください。
KFPS05112-I
Some servers did not startup,please check　　（Ｌ）
幾つかのHiRDBサーバが起動していない場合があります（HiRDBユニットとしては，起動完了となっています）。
(Ｓ)処理を続行します。
[対策]pdlsコマンドでサーバの状態を確認してください。サーバの状態がHELPの場合は，データベースの回復が必要です。また，STOPの場合は起動できなかった原因を取り除き，再度起動してください。
KFPS05113-E
Error occurred in HiRDB unit aaaa starting process, reason code=b　　（Ｌ）
ユニットaaaaの開始時にエラーが発生しました。エラーコードが「7」の場合には，計画停止処理中のユニットがあるため，ユニットの再開始が実行できません。すべてのユニットを強制終了します。
aaaa：ユニット識別子
b：エラーコード
(Ｓ)エラーコードが1～6，8の場合はユニットが異常終了します。エラーコードが7の場合はすべてのユニットを強制終了します。
[対策]エラーコードとその対策を次に示します。
エラー
コード
エラーの内容
対策
1
内部処理エラー
このユニットの$PDDIR/spool下のファイル，及びsyslogfile（又はイベントログ）を資料として保存した後，保守員に連絡してください。
2
通信エラー
システムマネジャユニットが停止していないか確認してください。システムマネジャユニットが停止している場合，システムマネジャユニットの停止原因を調査して，障害を取り除いてください。その後，HiRDBを再開始してください。システムマネジャユニットが稼働しているのにエラーになった場合は，ネットワーク障害の可能性があります。「RPC関連エラーの詳細コード」を参照して調査してください。原因不明の場合は，システムマネジャユニットと，このアボートコードを出力したユニットの$PDDIR/spool下のファイル及びsyslogfile（Windows NTの場合はイベントログ）を退避して，保守員に連絡してください。
3
定義パラメタエラー
該当するユニットの定義パラメタの内容がシステムマネジャがあるユニットの定義やほかのユニットの定義と矛盾していることが考えられます。特に，サーバ構成及びユニット識別子が正しいか確認し，誤りを修正してから再度実行してください。詳細はKFPS05215-Wメッセージを参照してください。
4
メモリ不足
ほかのプロセスが終了してから実行するか，スワップ領域のサイズを見直して再度実行してください。
5
バージョン不一致
このユニットの$PDDIR/spool下のファイル，及びsyslogfile（又はイベントログ）を資料として保存した後，保守員に連絡してください。
6
内部処理エラー
7
他ユニットとの状態不一致エラー
すべてのユニットが停止していることを確認してからシステムを再起動してください。停止していないユニットがある場合は，システムマネジャユニットからpdstop -fコマンドを入力するか，又は停止していないユニットに直接loginしてpdstop -zコマンドを入力して，停止した後にシステムを再起動してください。
なお，ユニットの停止状況の確認方法は，各ユニットのsyslogfile（Windows NTの場合はイベントログ）を参照し，次のメッセージが出力されていればそのユニットは停止しています。
・KFPS01821-Eメッセージ
・システムマネジャユニットの場合：KFPS01850-Iメッセージ（終了モード＝FORCE）
・システムマネジャではないユニットの場合：KFPS01841-Iメッセージ（終了モード＝FORCE）
8
影響分散スタンバイレス型系切り替え対象サーバの起動待ちタイムアウト発生
直前に表示されているKFPS05251-Wメッセージで表示されているサーバの起動状態をHAモニタ又はHitachi HA Toolkit Extensionで確認した後，異常終了したユニットを再起動してください。
9
ユニット間でシステム定義の内容が不一致
直前に表示されているKFPS05247-Eメッセージを参照して各ユニットのpd_rpl_hdepathオペランドの値を同じにした後，異常終了したユニットを再開始してください。
KFPS05114-E
SDS server did not startup　　（Ｌ）
シングルサーバの起動が確認できません。
(Ｓ)異常終了します。
[対策]保守員に連絡してください。
KFPS05120-W
Waiting for UAP and/or utility disconnect in HiRDB unit aaaa, current connect user count = bbb　　（Ｌ）
UAP又はユティリティの終了を待ち合わせています。
aaaa：終了を待ち合わせているユニット識別子
bbb：終了を待ち合わせている接続ユーザ数
(Ｓ)処理を続行します。この後，新たなユーザはHiRDBに接続できません。UAP又はユティリティの処理が終了するまでHiRDBの終了処理を保留します（15分間）。UAP又はユティリティの処理が終了すると，HiRDBの終了処理を開始します。
HiRDBに接続しているユーザの詳細情報を接続ユーザ情報ファイル（$PDDIR/spool/cnctusrinf）に出力します。また，次に示すコマンドの実行結果を接続ユーザ詳細ファイル（$PDDIR/spool下にあるcnctusrdtl）に出力します。
・pdls -d act
・pdls -d prc
・pdls -d trn
なお，HiRDB／パラレルサーバの場合，これらのファイルはシステムマネジャがあるサーバマシンに出力されます。
また，このメッセージの出力時刻前後に，実行中のUAP又はユティリティが停止した場合，これらの情報はHiRDBに接続しているユーザの詳細情報に含まれないことがあります。
(Ｏ)接続ユーザ情報ファイル（$PDDIR/spool/cnctusrinf）に出力された情報を参照して，接続しているユーザを調べて対処してください。それでも，接続しているユーザが分からない場合は，接続ユーザ詳細ファイル（$PDDIR/spool/cnctusrdtl）に出力された情報を参照して，接続しているユーザを調べて対処してください。対処方法については，マニュアル「HiRDB Version 7 システム運用ガイド」を参照してください。
接続ユーザ情報ファイルの出力例を次に示します。
出力例
UNIT ID : M350(173420)
UID PID GID SVID TIME PROGRAM
C-GRP C-PID C-IP
334 22118 300 fes1 173330 uap00
WS 22205 172.17.32.37
〔説明〕
UNIT ID：
ユニット識別子及びcnctusrinfファイル作成時刻（時分秒）を表示します。
UID：
HiRDBに接続中のユーザのユーザIDを表示します。
PID：
HiRDBに接続中のユーザのプロセスIDを表示します。
GID：
HiRDBに接続中のユーザのグループIDを表示します。
SVID：
ユーザが接続しているサーバのサーバ名を表示します。
HiRDBのサーバプロセス起動直後には，空白が表示される場合があります。
TIME：
HiRDBがサービスの要求を受け付けた時刻（時分秒）を表示します。ユーザが接続していないサーバについては999999を表示します。
PROGRAM：
クライアント環境定義のPDCLTAPNAMEオペランドの指定値が表示されます。PDCLTAPNAMEオペランドを省略した場合は，「Unknown」を表示します。
PDCLTAPNAMEオペランドについては，マニュアル「HiRDB Version 7 UAP開発ガイド」を参照してください。
・ユティリティの場合は「******」を表示します。
・分散データベース機能を使用してHiRDBにアクセスするUAPの場合は，「RDAUSER－認可識別子」と表示します。
・HiRDBのサーバプロセス起動直後には，「******」が表示される場合があります。
C-GRP：
HiRDBに接続中のユーザの種別（クライアントグループの種別）を表示します。
なお，クライアントグループの接続枠保証機能を使用していて，ユーザ任意のクライアントグループを定義している場合は，ユーザが定義したクライアントグループ名称を表示します。
表示される
文字列
ユーザの種別
XA
X/Open XAインタフェースでHiRDBに接続したユーザです。
DF
分散クライアントからHiRDBに接続したユーザです。
PC
PCクライアントからHiRDBに接続したユーザです。
WS
WSクライアントからHiRDBに接続したユーザです。
MF
メインフレーム系クライアント（VOS3クライアントなど）からHiRDBに接続したユーザです。
C-PID：
クライアントのプロセスIDを表示します。
C-IP：
クライアントのIPアドレスを表示します。
注
C-GRP，C-PID，及びC-IPは，次に示す場合は表示されません。
・UAP又はユティリティをクライアント側で実行していない場合（UAP又はユティリティをHiRDBシステムで実行した場合）
・UAPをリンケージしたクライアントのバージョンがHiRDB Version 4.0 04-00より前の場合
KFPS05121-E
Unable to stop normally, UAP and/or utility remaining in HiRDB unit aaaa, current connect user count = bbb　　（Ｌ）
UAP又はユティリティが実行中のため，HiRDBシステムを停止できません。
aaaa：UAP又はユティリティ実行中のユニット識別子
bbb：UAP又はユティリティ実行中のコネクトユーザ数
(Ｓ)終了処理を終了します。
(Ｏ)UAP又はユティリティの処理が終了してから，再度pdstopコマンドを実行してください。実行中のユーザを確認したい場合は，pdls -d trn，pdls -d prcで確認してください。
KFPS05123-W
Using resource for "aa....aa" operand reached bb....bb%[, cc....cc]　　（Ｌ）
システム定義のオペランドaa....aaのリソースが，警告値bb....bbに達しました。
aa....aa：システム定義のオペランド名
bb....bb：警告値（単位：％）
cc....cc：付加情報
(Ｓ)処理を続行します。
[対策]オペランドによって，出力される付加情報及び対策方法が異なります。次の表を参照して対策してください。また，オペランドによっては付加情報が出力されないことがあります。
システム定義のオペランド名（aa....aa）
付加情報（cc....cc）
対策
pd_max_users：最大同時接続数
dd....dd/ee....ee, server=ff....ff
・dd....dd：接続しているユーザ数
・ee....ee：定義値
・ff....ff：フロントエンドサーバ名又はシングルサーバ名。なお，ユティリティの実行時で警告値に達した場合は，"**....**"を出力します。該当するユティリティを次に示します。
・pdload
・pdrorg
・pddbst
・pdgetcst
・pdmod
pd_max_usersの値が妥当かどうかを見直してください。妥当でない場合はオペランドの値を変更してください。
pd_max_access_tables：最大同時アクセス可能実表数
dd....dd/ee....ee, server=ff....ff
・dd....dd：使用数
・ee....ee：定義数
・ff....ff：サーバ名
pd_max_access_tablesの値が妥当かどうかを見直してください。妥当でない場合はオペランドの値を変更してください。
pd_max_rdarea_no：RDエリアの最大数
pd_max_file_no：RDエリアを構成するHiRDBファイルの最大数
dd....dd/ee....ee, server=ff....ff
・dd....dd：使用数
・ee....ee：定義数
・ff....ff：サーバ名
pd_max_rdarda_no又はpd_max_file_noの値が妥当かどうかを見直してください。妥当でない場合はオペランドの値を変更してください。
pdwork：作業表用HiRDBファイルシステム領域
dd....dd=ee....ee/ff....ff,file system=gg....gg(hh....hh)
・dd....dd：詳細区分※
capacity　容量
file count　ファイル数
expand count　増分回数
・ee....ee：使用量
・ff....ff：割り当て量
・gg....gg：HiRDBファイルシステム領域名
・hh....hh：サーバ名
該当する作業表用HiRDBファイルシステム領域について，pdfmkfsコマンドで指定したオプションが妥当かどうか見直してください。妥当でない場合は，オペランドの値を再度見積もってpdfmkfsコマンドで該当する作業表用HiRDBファイルシステム領域の初期設定をしてください。なお，pdfmkfsコマンドは，HiRDBシステムを正常終了させてから実行してください。
client-group connect users：クライアントグループ指定時の自由利用枠のユーザ数
dd....dd/ee....ee, server=ff....ff
・dd....dd：自由利用枠で接続しているユーザ数
・ee....ee：定義値
・ff....ff：フロントエンドサーバ名又はシングルサーバ名。なお，ユティリティの実行時で警告値に達した場合は，"**....**"を出力します。該当するユティリティを次に示します。
・pdload
・pdrorg
・pddbst
・pdgetcst
・pdmod
次の観点でpdcltgrpオペランドによるクライアントグループごとの接続最低保証数の値が妥当かどうかを見直してください。
・ユティリティやクライアントグループに属さないUAPを多数実行する場合は，pdcltgrpオペランドで指定した各クライアントグループの接続最低保証数の値を下げて，自由利用枠を増やしてください。
・クライアントグループに割り当てた接続最低保証数に余裕がある場合は，そのクライアントグループに対するpdcltgrpオペランドの接続最低保証数の値を下げて，自由利用枠を増やしてください。
pd_max_list_users：最大リスト作成ユーザ数
dd...dd/ee....ee, server=ff....ff
・dd....dd: 使用数
・ee....ee: 定義数
・ff....ff: サーバ名
pd_max_list_usersの指定値が妥当かどうかを見直してください。妥当でない場合は，再度指定値を見積もって，値を変更してください。なお，システム定義を変更する場合は，先にHiRDBシステムを正常終了させてください。
pd_max_list_count：1ユーザ当たりの最大作成可能リスト数
dd...dd/ee....ee, server=ff....ff
・dd....dd: 使用数
・ee....ee: 定義数
・ff....ff: サーバ名
pd_max_list_countの値が妥当かどうかを見直してください。妥当でない場合はオペランドの値を変更してください。
pd_aud_max_generation_num：監査証跡ファイルの最大数
dd....dd/ee....ee/unit=ffff
dd....dd：スワップ先にできない監査証跡ファイル数
ee....ee：オペランドの値
ffff：ユニット識別子
・データロード待ちの監査証跡ファイルをデータロードするように監査人に連絡してください。
・pd_aud_max_generation_numオペランドの値が妥当かどうかを見直してください。妥当でない場合はオペランドの値を変更してください。
注※
詳細区分が容量の場合，使用量及び割り当て量の単位はメガバイトになります。
KFPS05124-E
Number of connect users exceeded max users, server=aa....aa　　（Ｌ）
HiRDBへの接続数が最大同時接続数（pd_max_usersオペランドの値）を超えました。
aa....aa：最大同時接続数を検知したサーバ名
(Ｓ)処理を続行します。
(Ｏ)ほかのユーザの終了を待ってから再度実行してください。
(Ｐ)ほかのユーザの終了を待ってから再度実行してください。
[対策]必要であれば，pd_max_usersの値が妥当かどうかを見直してください。妥当でない場合は指定値を再度見積もって変更してください。
KFPS05130-E
Unable to execute command. except pdvrup　　（Ｌ）
pdvrupコマンド以外は実行できません。
(Ｓ)処理を終了します。
[対策]システムが起動完了になってから，再度実行してください。
KFPS05131-E
Unable to execute aa....aa command. reason code=bbbb　　（Ｌ）
aa....aaコマンドの実行が失敗しました。
aa....aa：実行しようとしたコマンド名
bbbb：詳細コード(「システム関連エラーの詳細コード」を参照してください)
(Ｓ)処理を終了します。
(Ｏ)失敗した原因を取り除いて，必要があれば再度コマンドを実行してください。繰り返しこのエラーメッセージが出力される場合，保守員に連絡してください。
KFPS05140-I
Data replication started. unit=aaaa　　（Ｅ＋Ｌ）
HiRDB Datareplicator連携を開始しました。
aaaa：ユニット識別子
(Ｓ)処理を続行します。
KFPS05141-I
Data replication stopped. unit=aaaa　　（Ｅ＋Ｌ）
HiRDB Datareplicator連携を停止しました。
aaaa：ユニット識別子
(Ｓ)処理を続行します。
KFPS05142-W
Unable to stop data replication, server=aa....aa, reason=bb....bb　　（Ｅ＋Ｌ）
HiRDB Datareplicatorとのデータ連携を停止できません。
aa....aa：サーバ名
bb....bb：理由コード
(Ｓ)処理を続行します。
[対策]理由コードに対応する対策をしてください。
理由コード
原因
対策
FILE LOCK ERROR
HiRDB Datareplicatorのデータ連動用連絡ファイルへの参照権限又は更新権限が取得できません。
HiRDB Datareplicatorがデータ連動用連絡ファイルを占有しています。原因を調査して対策してください。
FILE OPEN ERROR
HiRDB Datareplicatorのデータ連動用連絡ファイルをオープンできません。
データ連動用連絡ファイルが削除された，又はディスク障害によってデータ連動用連絡ファイルをオープンできません。反映側のデータベースと同期をとった後にデータ連動用連絡ファイルを再作成し，HiRDB DatareplicatorとHiRDBを再度開始してください。
KFPS05170-E
Server aa....aa recovery failed,abnormally terminated unit=bbbb　　（Ｌ）
ユニット異常終了に伴うサーバの回復処理に失敗しました。
aa....aa：回復処理に失敗したサーバ名
bbbb：異常終了したユニットの識別子
(Ｓ)処理を続行します。
[対策]このユニットの$PDDIR/spool下のファイル，及びsyslogfile（Windows NTの場合はイベントログ）を資料として保存した後，保守員に連絡してください。
KFPS05171-E
Process recovery failed,abnormally terminated process=aa....aa　　（Ｌ）
プロセス異常終了に伴う回復処理に失敗しました。
aa....aa：異常終了したプロセスID
(Ｓ)異常終了します。
[対策]pdls -d prcコマンドで，該当するプロセスIDが残っていないか確認してください。残っていない場合は問題ありません。残っている場合は，このユニットの$PDDIR/spool下のファイル，及びsyslogfile（Windows NTの場合はイベントログ）を資料として保存した後，保守員に連絡してください。
KFPS05172-E
Unable to inform unit aaaa that process is abnormal,abnormal process=bb....bb　　（Ｌ）
プロセス異常終了に伴うユニットの回復処理ができません。
aaaa：回復処理を実行できなかったユニット識別子
bb....bb：異常終了したプロセスID
(Ｓ)処理を続行します。
[対策]メッセージに出力されているユニットが起動していない場合はエラーではないので，ユニットの状態を確認してください。ユニットが起動している場合は，保守員に連絡してください。
KFPS05173-E
Recovery failure because server(aa....aa) abnormally terminated, utility=bb....bb cc....cc　　（Ｌ）
サーバ異常終了に伴うユニットの回復処理に失敗しました。
aa....aa：異常終了したサーバ名称（最大8文字）
bb....bb：異常終了したサーバと関係があり，回復に失敗したユティリティのプロセスID（最大10文字）
cc....cc：HiRDBが使用する内部的なサービス名称（最大16文字）
(Ｓ)処理を続行します。
[対策]pdls -d prc -aコマンドで，メッセージで表示されたプロセスIDが残っていないか確認してください。残っていない場合，問題ありません。残っている場合，pdls -d trn -aコマンドで実行されていたユティリティ名称を調べ，実行時間が長いユティリティかどうか調べてください。実行時間が長い場合の対処はマニュアル「HiRDB Version 7 システム運用ガイド」を参照してください。
KFPS05180-E
System call/function error,call=aa....aa, code=bbb　　（Ｌ）
システムコール，又は関数にエラーが発生しました。
aa....aa：エラーが発生したシステムコールの名称，又は関数名
bbb：エラーコード
(Ｓ)システム開始時，又はpdstop -x実行時に，このメッセージが出力される場合には異常終了します。また，pdstopコマンドの延長でこのメッセージが出力される場合には，そのコマンドの処理を終了します。
[対策]次に示す表を基に対策してください。
エラーが発生した名称
エラーコード
原因
対策
system
-1
実行中のプロセスの合計がシステムで決められた制限を超えています。
OSのnprocパラメタの値を増やしてください。
一人のユーザが使用できるプロセスの合計が限界を超えています。
OSのmaxuprcパラメタの値を増やしてください。
物理メモリが不足しています。
メモリを必要以上に確保していないか確認してください。確保している場合は，不要な資源を解放してください。
Windows NTの場合，物理メモリが不足しています。
メモリを必要以上に確保していないか確認してください。確保している場合は，不要な資源を解放してください。
上記以外
上記以外
－
保守員に連絡してください。
（凡例）－：該当しません。
KFPS05190-E
Communication error occurred, from host aa....aa to host bb....bb, processing code=ccc　　（Ｌ）
ホストaa....aaからホストbb....bbへの通信エラーが発生しました。
aa....aa：ホスト名
bb....bb：ホスト名
ccc：処理中コード（HiRDBの内部コード）
(Ｓ)システムの状態によって処理を続行又は異常終了します。
[対策]
1. システムマネジャ（MGR）として定義しているホストが起動されていない場合は，該当するホストを起動した後，HiRDBユニットを再度開始してください。
2. ユティリティ専用ユニットを定義している場合，bb....bbホストが起動されていないことが考えられます。起動していないときは，エラーではありません。bb....bbホストを起動していたかどうか確認してください。
3. そのほかの場合，保守員に連絡してください。
KFPS05191-E
Communication error occurred, from host aa....aa to host bb....bb, processing code=ccc, reason code=dddd　　（Ｌ）
ホストaa....aaからホストbb....bbへの通信エラーが発生しました。
aa....aa：ホスト名
bb....bb：ホスト名
ccc：処理中コード（HiRDBの内部コード）
dddd：理由コード（HiRDBの内部コード）
(Ｓ)システムの状態によって処理を続行又は異常終了します。
[対策]
1. システムマネジャ（MGR）として定義しているホストが起動されていない場合は，該当するホストを起動した後，HiRDBユニットを再度開始してください。
2. ネットワーク障害が考えられるの場合には，障害要因を取り除き，HiRDBユニットを再度開始してください。
3. そのほかの場合，保守員に連絡してください。
KFPS05192-E
Communication error occurred, from utility to MGR/SDS unit, processing code=aaa　　（Ｌ）
ユティリティを実行したユニットから，システムマネジャ（MGR）又はシングルサーバ（SDS）として定義されたユニットへの，通信エラーが発生しました。
aaa：処理中コード（HiRDBの内部コード）
(Ｓ)システムの状態によって処理を続行又は異常終了します。
[対策]ユティリティを実行したユニット及びシステムマネジャのあるユニットの$PDDIR/spool下のファイル，及びsyslogfile（Windows NTの場合はイベントログ）を資料として保存した後，保守員に連絡してください。
KFPS05193-E
Communication error occurred, to host aa....aa, processing code=bbb, reason code=cccc　　（Ｌ）
ホストaa....aaへの通信エラーが発生しました。
ホスト名称が’********’の場合は，システムマネジャ又はシングルサーバとして定義されたホストへの通信エラーが発生しました。
aa....aa：ホスト名
bbb：処理中コード（HiRDBの内部コード）
cccc：理由コード（HiRDBの内部コード）
(Ｓ)システムの状態によって処理を続行又は異常終了します。
[対策]処理中コードと理由コードの内容に従って，対策してください。
理由
コード
対策
640
ホストaa....aaのユニットが起動されていないことが考えられます。この場合，該当ユニットを起動してください。該当ユニットが縮退などで起動していない場合はこのメッセージを無視してかまいません。該当ユニットが起動しているのに，このメッセージが出力される場合は通信障害が発生しています。「RPC関連エラーの詳細コード」を参照し，通信障害が発生していないか調査してください。
740
840
1140
1340
1440
1540
1640
1740
1840
2240
2300
2350
2500
2630
2700
2710
2720
2730
上記以外
保守員に連絡してください。
KFPS05194-E
Communication error occurred, to node MGR, processing code=aaa　　（Ｌ）
HiRDBユニット内のシステムマネジャ（MGR）があるサーバマシンへの通信エラーが発生しました（処理中コードはHiRDB内部コード）。
aaa：処理中コード
(Ｓ)システムの状態によって処理を続行又は異常終了します。
[対策]このユニット及びシステムマネジャのあるユニットの$PDDIR/spool下のファイル，及びsyslogfile（Windows NTの場合はイベントログ）を資料として保存した後，保守員に連絡してください。
KFPS05195-E
Communication error occurred, to node MGR,processing code=aaa, reason code=bbbb　　（Ｌ）
HiRDBユニット内のサーバマシン（MGR）への通信エラーが発生しました（処理中コード，理由コードは，HiRDBの内部コードです）。
aaa：処理中コード
bbbb：理由コード
(Ｓ)システムの状態によって処理を続行又は異常終了します。
[対策]このユニット及びシステムマネジャのあるユニットの$PDDIR/spool下のファイル，及びsyslogfile（Windows NTの場合はイベントログ）を資料として保存した後，保守員に連絡してください。
KFPS05200-E
Error occurred in HiRDB system starting process, reason code=aa　　（Ｌ）
HiRDBの開始処理中に障害が発生し，HiRDBが開始できません。
aa：理由コード
10：定義解析エラー
20：通信障害発生
30：メモリ不足
40：共用メモリ不足
(Ｓ)異常終了します。
[対策]理由コードに従って，対策してください。対策できない場合はシステムマネジャのあるユニットの$PDDIR/spool下のファイル，及びsyslogfile（Windows NTの場合はイベントログ）を資料として保存した後，保守員に連絡してください。
理由コード
意味
対策
10
定義解析エラー
直前に出力されたメッセージを参照してHiRDBシステム定義に誤りがないかどうかを確認し，誤りを訂正してください。
20
通信障害発生
直前に出力されたメッセージを参照して通信障害の原因を調査し，取り除いてください。
30
領域（メモリ）不足発生
ほかのプロセスが終了してから実行するか，スワップ領域のサイズを見直して再度実行してください。
40
共用メモリ不足発生
共用メモリサイズの見積もりが正しいか見直してください。見積もりが正しい場合は保守員に連絡してください。
KFPS05201-Q
Dictionary not initialized； enter pdinit command　　（Ｌ＋Ｓ）
HiRDBシステムのディクショナリの初期化が完了していません。pdinitコマンドを入力してディクショナリを初期化してください。
(Ｓ)pdinit -dコマンドでディクショナリの初期化が完了するのを待ちます。
[対策]pdinitコマンドを入力してください。
Windows NTの場合，pdinitコマンドはAdministrator権限で実行する必要があります。ただし，実行者は「"root"」となります。
KFPS05202-E
Insufficient memory on STATIC_SHMPOOL, size=aa....aa　　（Ｌ）
共用メモリの確保エラーが発生しました。
aa....aa：確保しようとした領域サイズ（単位：バイト）
(Ｓ)処理を終了します。
[対策]システムマネジャのあるユニットの$PDDIR/spool下のファイル，及びsyslogfile（Windows NTの場合はイベントログ）を資料として保存した後，保守員に連絡してください。
KFPS05203-Q
HiRDB version upped: enter pdvrup command　　（Ｌ＋Ｓ）
pdvrupコマンドの入力待ちです。pdvrupコマンドを入力してください。
(Ｓ)pdvrupコマンドの入力待ちです。
[対策]pdvrupコマンドを入力してください。
KFPS05205-E
Error occurred while starting HiRDB control process, reason code=aa　　（Ｌ）
HiRDBシステム制御プロセスの開始時に，エラーが発生しました。このため，システムが開始できません。
aa：理由コード
10：定義解析エラー
20：通信障害発生
30：メモリ不足
40：共用メモリ不足
(Ｓ)異常終了します。
[対策]理由コードに従って，対策してください。対策できない場合はシステムマネジャのあるユニットの$PDDIR/spool下のファイル，及びsyslogfile（Windows NTの場合はイベントログ）を資料として保存した後，保守員に連絡してください。
理由コード
意味
対策
10
定義解析エラー
直前に出力されたメッセージを参照してHiRDBシステム定義に誤りがないかどうかを確認し，誤りを訂正してください。
20
通信障害発生
直前に出力されたメッセージを参照して通信障害の原因を調査し，取り除いてください。
30
領域（メモリ）不足発生
ほかのプロセスが終了してから実行するか，スワップ領域のサイズを見直して再度実行してください。
40
共用メモリ不足発生
共用メモリサイズの見積もりが正しいか見直してください。見積もりが正しい場合は保守員に連絡してください。
KFPS05206-E
Incompatible character code set for HiRDB unit aaaa,character code set = bb....bb, MGR unit character code set = cc....cc　　（Ｌ）
ユニットaaaaの文字コード種別bb....bbは，MGRユニットの文字コード種別cc....ccと異なります。このため，HiRDBシステムを開始できません。
aaaa：ユニット識別子
bb....bb：ユニットaaaaの文字コード種別
CHINESE：EUC中国語漢字コード
LANG-C：単一バイト文字コード
SJIS：シフトJISコード
UJIS：EUC日本語漢字コード
UTF-8：Unicode（UTF-8）
cc....cc：MGRユニットの文字コード種別
(Ｓ)異常終了します。
[対策]文字コード種別を統一してください。なお，文字コード種別を統一する場合，pdsetup -dコマンドを実行し，応答メッセージに「y」で応答した後，再度pdsetup -cコマンドで正しい文字コード種別を指定してください。
KFPS05207-E
Unable to start HiRDB system, some units exist whose version are not equal to that of MGR unit　　（Ｌ）
システムマネジャ（MGR）があるユニットとそのほかのユニットで，次に示すことが異なります。このため，HiRDBを開始できません。
・バージョン
・アドレッシングモード（32ビットモード又は64ビットモード）
・ロード種別（POSIXライブラリ版を使用しているかどうか）
(Ｓ)異常終了します。
(Ｐ)KFPS05209-I，又はKFPS05212-Eメッセージを参照して，バージョン，アドレッシングモード，及びロード種別をユニット間で統一してください。その後，HiRDBを開始してください。
KFPS05208-E
Unable to start HiRDB system, abnormally terminated units exist　　（Ｌ）
前回，異常終了，計画停止，又は強制終了したユニットがありました。このため，HiRDBを開始できません。
(Ｓ)異常終了します。
[対策]KFPS05209-I，又はKFPS05212-Eメッセージを参照して，全ユニットのバージョン，アドレッシングモード，及びロード種別（POSIXライブラリ版を使用しているかどうか）を旧バージョンに戻してください。旧バージョンで正常終了後，HiRDBをバージョンアップしてください。旧バージョンに戻す手順，及びバージョンアップの手順については，マニュアル「HiRDB Version 7 システム導入・設計ガイド」を参照してください。
KFPS05209-I
HiRDB version information, unit_id = aaaa, bb....bb, cc....cc　　（Ｌ）
HiRDBのユニットaaaaの情報を表示します。
aaaa：ユニット識別子
bb....bb：現在のHiRDBのバージョン情報
version：HiRDBのバージョンを表示します。HiRDB Object Optionを組み込んでいる場合，バージョンに続けて"(Object Option)"を表示します。
addressing mode：HiRDBのアドレッシングモードを表示します。
32：32ビットモード
64：64ビットモード
load：HiRDBのロード種別を表示します。この情報はHP-UX版（32ビットモード），Solaris版，及びAIX 5L版の場合に表示されます。
POSIX：POSIXライブラリ版
NO-POSIX：非POSIXライブラリ版
cc....cc：前回終了時のHiRDBのバージョン情報
stop status：前回のHiRDBの終了モードを表示します。
A：計画停止，強制終了，又はユニットの異常終了
N：正常終了
previous operation stop version：前回終了時のHiRDBのバージョンを表示します。HiRDB Object Optionを組み込んでいる場合，バージョンに続けて"(Object Option)"を表示します。
ステータスファイルが初期化状態の場合は，********が表示されます。
addressing mode：前回終了時のHiRDBのアドレッシングモードを表示します。
32：32ビットモード
64：64ビットモード
load：前回終了時のHiRDBのロード種別を表示します。この情報はHP-UX版（32ビットモード），Solaris版，及びAIX 5L版の場合に表示されます。
POSIX：POSIXライブラリ版
NO-POSIX：非POSIXライブラリ版
(Ｓ)異常終了します。
[対策]このメッセージの前に出力されているKFPS05207-E，又はKFPS05208-Eメッセージを参照して対策してください。
・KFPS05207-Eが出力されていた場合
このメッセージ及びKFPS05212-Eメッセージを参照して，全ユニットのバージョン，アドレッシングモード，及びロード種別を統一してください。その後，HiRDBを開始してください。
・KFPS05208-Eが出力されていた場合
このメッセージ及びKFPS05212-Eメッセージを参照して，全ユニットのバージョン，アドレッシングモード，及びロード種別を旧バージョンに戻してください。旧バージョンで正常終了後，HiRDBをバージョンアップしてください。旧バージョンに戻す手順，及びバージョンアップの手順については，マニュアル「HiRDB Version 7 システム導入・設計ガイド」を参照してください。
KFPS05210-I
HiRDB system initialization process complete　　（Ｌ）
HiRDBシステムの初期化が完了しました。
(Ｓ)処理を続行します。
KFPS05211-I
Server aa....aa is ready to connect　　（Ｌ）
HiRDB/パラレルサーバのフロントエンドサーバ（FES）として定義されたサーバが，一度終了した後，再度起動して，connectが実行できる状態になりました。
aa....aa：サーバ名
(Ｓ)処理を続行します。
KFPS05212-E
HiRDB aa....aa option information, unit_id = bbbb, version = cc....cc, previous operation stop version = dd....dd　　（Ｌ）
HiRDBのユニットbbbbの付加プログラムプロダクトaa....aaのバージョン情報を表示します。
aa....aa：付加プログラムプロダクト
・Object Option：HiRDB/Single Server - Object Option又はHiRDB/Parallel Server - Object Option
・Staticizer Option：HiRDB Staticizer Option
・External Data Access：HiRDB External Data Access
・Advanced High Availability：HiRDB Advanced High Availability
・Advanced Partitioning Option：HiRDB Advanced Partitioning Option
・Non Recover FES：HiRDB Non Recover FES
bbbb：ユニット識別子
cc....cc：付加プログラムプロダクトのバージョン
dd....dd：前回ユニット終了時の付加プログラムプロダクトのバージョン
バージョンが00-00と表示されている場合，付加プログラムプロダクトが組み込まれていないことを意味します。
(Ｓ)異常終了します。
[対策]このメッセージの前に出力されているKFPS05207-E，又はKFPS05208-Eメッセージを参照して対策してください。
・KFPS05207-Eが出力されていた場合
このメッセージ及びKFPS05209-Iメッセージを参照して，全ユニットのバージョン，アドレッシングモード，及びロード種別を統一してください。その後，HiRDBを開始してください。
・KFPS05208-Eが出力されていた場合
このメッセージ及びKFPS05209-Iメッセージを参照して，全ユニットのバージョン，アドレッシングモード，及びロード種別を旧バージョンに戻してください。旧バージョンで正常終了後，HiRDBをバージョンアップしてください。旧バージョンに戻す手順，及びバージョンアップの手順については，マニュアル「HiRDB Version 7 システム導入・設計ガイド」を参照してください。
KFPS05213-E
Unit aa....aa did not startup　　（Ｅ＋Ｌ）
ユニットが開始しなかったため，HiRDBを起動完了できませんでした。
aa....aa：ユニット識別子
(Ｓ)異常終了します。
[対策]該当するユニットのsyslogfile（Windows NTの場合はイベントログ），又はメッセージログファイルを参照して，HiRDBユニットが開始しない原因を調査し，対策してください。対策後，HiRDBシステム又はユニットを開始してください。
KFPS05214-W
Fall-back operation ignored, because of aa....aa　　（Ｅ＋Ｌ）
HiRDBシステムを縮退起動できません。縮退起動モードを無視します。
aa....aa：理由コード
HiRDB version upped：HiRDBがバージョンアップされています。
dictionary not initialized：ディクショナリ未初期化
(Ｓ)処理を続行します。
[対策]HiRDBバージョンアップ及びディクショナリ初期化時は，システムを構成するすべてのユニットを開始してください。
KFPS05215-W
HiRDB unit aaaa definition errer, reason code=b　　（Ｌ）
ユニットの定義にエラーがあります。
aaaa：ユニット識別子
b：エラーコード
1：システムIDが誤っています
2：ホスト名称が誤っています
3：ユニット識別子が誤っています
4：必要なサーバが定義中にありません
5：不要なサーバが定義中にあります
9：そのほかのエラーです
(Ｓ)処理を続行します。
[対策]エラーコードが1～5の場合には，そのコードに従ってユニットの定義を見直し，該当するユニットを再度実行してください。エラーコードが9の場合には，保守員に連絡してください。
KFPS05216-I
Valid option for HiRDB system fall-back operation　　（Ｅ＋Ｌ）
HiRDBシステムを縮退起動するオプションが指定されています。
(Ｓ)処理を続行します。
KFPS05217-I
Unit aa....aa did not startup; switches to fall-back operation　　（Ｅ＋Ｌ）
HiRDBシステム開始中にユニットが開始しなかったため，HiRDBを縮退起動します。
aa....aa：ユニット識別子
(Ｓ)処理を続行します。
[対策]HiRDBユニットが開始しない原因を調査して対策後，HiRDBユニットを開始して縮退状態を解消してください。
KFPS05218-I
All unit initialization completed; switches to normal operation　　（Ｅ＋Ｌ）
HiRDBのすべてのユニットが起動完了したので縮退状態を解消して，通常運転に戻ります。
(Ｓ)処理を続行します。
KFPS05219-I
HiRDB initialization process complete； only for pdrstr and pdcopy　　（Ｌ）
pdstart -rによるHiRDBの起動が完了しました。このモードでは，pdrstrコマンドとpdcopyコマンドを実行できます。
(Ｓ)処理を続行します。
KFPS05220-I
HiRDB system termination process started. mode = aa....aa　　（Ｌ）
HiRDBシステムの終了処理を開始しました。
aa....aa：終了モード
FORCE：強制終了
NORMAL：正常終了
PLAN：計画停止
(Ｓ)処理を続行します。
KFPS05221-E
Error occurred in HiRDB system termination process. mode = aa....aa　　（Ｌ）
HiRDBシステムの終了処理中にエラーが発生しました。
終了モードがPLANの場合は，すべてのシステムマネジャではないユニットを強制終了します。
aa....aa：終了モード
NORMAL：正常終了
PLAN：計画停止
FORCE：強制終了
(Ｓ)異常終了します。
[対策]システムマネジャではないユニットが何らかの原因で終了処理に失敗しているか，通信障害が発生していることが考えられます。このメッセージの前に出力されたメッセージなどを調査し，障害を取り除いた後，システムを再起動してください。
〈計画停止中の場合〉
すべてのユニットが停止していることを確認してからシステムを再起動してください。
停止していないユニットがあるときは，システムマネジャユニットからpdstop -fコマンドを入力するか，又は停止していないユニットに直接loginしてpdstop -zコマンドを入力して，停止した後にシステムを再起動してください。
なお，ユニットの停止状況の確認方法は，各ユニットのsyslogfile（Windows NTの場合はイベントログ）を参照し，次のメッセージが出力されていればそのユニットは停止しています。
・KFPS01821-Eメッセージ
・システムマネジャではないユニットの場合：KFPS01841-Iメッセージ（終了モード=FORCE）
原因不明の場合には，システムマネジャのあるユニットの$PDDIR/spool下のファイル，及びsyslogfile（又はイベントログ）を資料として保存した後，保守員に連絡してください。
KFPS05222-E
Unable to terminate HiRDB unit aaaa due to communication error　　（Ｌ）
通信エラーによってユニットaaaaを停止できません。
aaaa：ユニット識別子
(Ｓ)処理を続行します。
[対策]ユニットを次のどれかの方法で終了させてください。
・システムマネジャのあるユニットから，pdstop -xコマンドで該当するホスト名を指定する
・システムマネジャのあるユニットから，pdstop -uコマンドで該当するユニット識別子を指定する
・該当するユニットに直接ログインしてpdstop -zコマンドを実行する
終了できない場合は，保守員に連絡してください。
KFPS05223-I
HiRDB unit aaaa inactive,status = bb　　（Ｌ）
HiRDBユニットaaaaは，ステータスbbです。
aaaa：ユニット識別子
bb：ステータスコード
10：開始処理中です
15：開始処理中です
16：pdinitコマンドでデータベースを初期化してください
20：ユニット起動が完了しました
21：フロントエンドサーバ起動が完了しました
25：終了処理中です
30：正常終了しました
31：強制終了しました
32：異常終了しました
40：データベースの閉塞中です
(Ｓ)処理を続行します。
[対策]pdstopコマンドで正常終了できない場合，その原因となるユニットの状態が表示されます。正常終了できない場合は，pdstop -fコマンドを入力してください。
KFPS05224-E
Error occurred while terminating MGR unit　　（Ｌ）
システムマネジャ（MGR）があるユニットの終了処理中にエラーが発生しました。
(Ｓ)異常終了します。
[対策]システムマネジャのあるユニットの$PDDIR/spool下のファイル，及びsyslogfile（Windows NTの場合はイベントログ）を資料として保存した後，保守員に連絡してください。
KFPS05225-E
Error occurred while terminate HiRDB control process　　（Ｌ）
HiRDBシステム制御プロセスの終了処理中にエラーが発生しました。
(Ｓ)異常終了します。
[対策]システムマネジャのあるユニットの$PDDIR/spool下のファイル，及びsyslogfile（Windows NTの場合はイベントログ）を資料として保存した後，保守員に連絡してください。
KFPS05226-E
Unable to terminate HiRDB server aa....aa　　（Ｌ）
サーバ名aa....aaのサーバを停止できません。
aa....aa：サーバ名
(Ｓ)処理を終了します。
[対策]pdlsコマンドで該当するサーバの状態を確認してください。起動中の場合，再度pdstopコマンドで停止してください。
KFPS05227-W
Now waiting for termination of HiRDB unit aaaa　　（Ｌ）
HiRDBユニットaaaaの停止完了を待ち合わせています。
aaaa：ユニット識別子
(Ｓ)処理を続行します。
[対策]同じユニット識別子で数回メッセージが出力されている場合，そのユニットが何らかの原因で停止処理に時間が掛かっているか，又はユニットが異常終了しているおそれがあります。
このメッセージまでに出力されたメッセージの内容をチェックし，HiRDBシステムの状態を確認してください。
〈異常終了しているとき〉
HiRDBシステムをpdstop -fコマンドで強制停止してください。
〈停止処理に時間が掛かっているとき〉
次の要因が考えられます。
1. トランザクションの回復
2. 通信障害
KFPS05230-E
Unable to stop aaaa normally because bbbb being cccc　　（Ｓ）
bbbbのcccc処理中のため，aaaaを正常停止，計画停止，及び強制停止できません。
aaaa：停止種別 { HiRDB | unit | server }
bbbb：停止種別 { HiRDB | unit | server }
cccc：処理内容
started：開始
terminated：終了
(Ｓ)処理を続行します。
(Ｏ)bbbbの開始又は停止処理が完了してから，再度pdstopコマンドを実行してください。又は，pdstop -fコマンドで強制終了してください。ただし，パラレルサーバの場合は，pdstop -f -x ホスト名，又はpdstop -f -u ユニット識別子を指定した強制終了はできません。
KFPS05231-E
Unable to stop server due to server is inactive　　（Ｓ）
サーバが起動されていません。このため，サーバを停止できません。
(Ｓ)処理を続行します。
KFPS05232-E
Unable to stop unit due to unit is inactive　　（Ｓ）
ユニットが開始されていません。又は，ユニットが停止しています。このため，ユニットの停止処理ができません。
(Ｓ)処理を続行します。
KFPS05233-E
Unable to stop HiRDB system normally due to user identifier remained　　（Ｓ）
UAP，ユティリティが実行中か又は終了していないトランザクションが残っているため，HiRDBシステムの正常停止はできません。
(Ｓ)処理を終了します。
(Ｏ)実行中のUAP，ユティリティの終了及びトランザクションの終了を待って，再度pdstopコマンドを実行してください。
停止できない原因となったユーザを確認したい場合は，まずpdls -d actコマンドを使ってユーザの情報を表示します。次に，表示されたユーザ識別通番及びプロセスIDを基に，pdls -d prcコマンド，及びpdls -d trnコマンドの表示結果と突き合わせてユーザ又はトランザクションを特定します。原因となるユーザ又はトランザクションがない場合は，時間を置いて再度確認してください。
KFPS05234-E
Unable to stop unit due to user identifier remained　　（Ｓ）
UAP，ユティリティが実行中か又は終了していないトランザクションが残っているため，HiRDBユニットの正常停止はできません。
(Ｓ)処理を終了します。
(Ｏ)実行中のUAP，ユティリティの終了及びトランザクションの終了を待って，再度pdstopコマンドを実行してください。
停止できない原因となったユーザを確認したい場合は，まずpdls -d actコマンドを使ってユーザの情報を表示します。次に，表示されたユーザ識別通番及びプロセスIDを基にpdls -d prcコマンド，pdls -d trnコマンドの表示結果と突き合わせてユーザ又はトランザクションを特定します。原因となるユーザ又はトランザクションがない場合は，時間を置いて再度確認してください。
KFPS05235-E
Unable to stop server due to user identifier remained　　（Ｓ）
UAP，ユティリティが実行中か又は終了していないトランザクションが残っているため，HiRDBサーバの停止はできません。
(Ｓ)処理を終了します。
(Ｏ)実行中のUAP，ユティリティの終了及びトランザクションの終了を待って，再度pdstopコマンドを実行してください。
停止できない原因となったユーザを確認したい場合は，まずpdls -d actコマンドを使ってユーザの情報を表示します。次に，表示されたユーザ識別通番及びプロセスIDを基にpdls -d prcコマンド，pdls -d trnコマンドの表示結果と突き合わせてユーザ又はトランザクションを特定します。該当するユーザ又はトランザクションがない場合は，時間を置いて再度確認してください。
KFPS05236-E
Unable to stop HiRDB system normally, because unit aaaa stop failed　　（Ｅ＋Ｌ）
ユニットaaaaの終了処理に失敗したため，HiRDBの正常終了，又は計画停止はできません。
aaaa：終了処理に失敗したユニットの識別子
(Ｓ)処理を続行します。
[対策]aaaaユニットがユニット終了処理に失敗した原因を調査してください。aaaaユニットが稼働中の可能性があります。psコマンドなどを実行してHiRDBプロセスが稼働中かどうか確認した後，必要に応じてpdstop -zコマンドでaaaaユニットを強制終了してください。
KFPS05240-E
Pdrplstart command failed. reason=aa....aa　　（Ｅ＋Ｌ）
pdrplstartコマンド実行中にエラーが発生しました。
aa....aa：障害の種別を示す文字列
SYSTEM INCOMPLETE：
システムが起動完了していません。
ANY UNIT INACTIVE：
全ユニットのステータスがACTIVEではありません。
ANY BES INACTIVE：
全バックエンドサーバのステータスがACTIVEではありません。
UTL UNIT：UTLユニットでは実行できません。
STARTED：既にHiRDB Datareplicator連携を実行中です。
PD_RPL_HDEPATH：HiRDB Datareplicator連携を実行できる環境ではありません。
TIMEOUT：実行時間をオーバーしました。
STATUS WRITE ERROR：ステータスファイルの書き込みに失敗しました。
STOPPING NOW：HiRDB Datareplicator連携の停止処理中です。
EXTRACT STOPPED：HiRDB Datareplicatorの抽出処理が中断しています。
(Ｓ)処理を終了します。
[対策]障害の種別を示す文字列の内容に従って対策してください。障害の種別を示す文字列に該当しない場合は，保守員に連絡してください。
障害の種別を示す文字列
意味
対策
SYSTEM INCOMPLETE
システムが起動完了していません。
システムが起動完了してから再度コマンドを実行してください。
ANY UNIT INACTIVE
全ユニットのステータスがACTIVEではありません。
停止しているユニットを再開始した後，再度コマンドを実行してください。
ANY BES INACTIVE
全バックエンドサーバのステータスがACTIVEではありません。
停止しているバックエンドサーバを再起動した後，再度コマンドを実行してください。
UTL UNIT
UTLユニットでは実行できません。
－
STARTED
既にHiRDB Datareplicator連携を実行中です。
－
PD_RPL_HDEPATH
データ連動をできる環境ではありません。
ユニット制御情報定義にpd_rpl_hdepathオペランドを指定し，HiRDBを再開始した後，再度コマンドを実行してください。
TIMEOUT
実行時間をオーバーしました。
再度コマンドを実行してください。
STATUS WRITE ERROR
ステータスファイルの書き込みに失敗しました。
システム共通定義のpd_rpl_hdepathオペランドの指定内容に誤りがないか確認してください。又は，データ連動連絡用ファイルがあるか確認してください。
STOPPING NOW
HiRDB Datareplicator連携を停止しています。
すべてのHiRDB Datareplicator連携ユニットの停止を確認した後に，再度コマンドを実行してください。
EXTRACT STOPPED
HiRDB Datareplicatorの抽出処理が中断しています。
データ連動用連絡ファイルの初期化をしてから，再度コマンドを実行してください。
（凡例）－：該当しません。
KFPS05241-E
Pdrplstop command failed, reason=aa....aa　　（Ｅ＋Ｌ）
pdrplstopコマンド実行中にエラーが発生しました。
aa....aa：障害種別
(Ｓ)処理を終了します。
[対策]対策後にpdrplstopコマンドを再実行してください。マニュアルに記載されていない障害種別が出力された場合は保守員に連絡してください。
障害種別
障害の内容
対策
UTL UNIT
ユティリティ専用ユニットでは実行できません。
ユティリティ専用ユニットに対してはpdrplstopコマンドを実行できません。
STOPPED
既にHiRDB Datareplicatorとの連携を停止しています。
既にHiRDB Datareplicatorとの連携を停止しているため，pdrplstopコマンドを実行できません。
PD_RPL_HDEPATH
pd_rpl_hdepath オペランドを指定していません。
pd_rpl_hdepathオペランドを指定してください。HiRDBを開始した後に再度pdrplstopコマンドを実行してください。
TIMEOUT
実行時間をオーバーしました。
再度pdrplstopコマンドを実行してください。
STATUS WRITE
ERROR
ステータスファイルの書き込みに失敗しました。
pd_rpl_hdepathオペランドの指定内容が正しいことを確認した後に再度pdrplstopコマンドを実行してください。又は，データ連動用連絡ファイルがあるか確認した後に再度pdrplstopコマンドを実行してください。
ANY UNIT
INACTIVE
稼働していないユニットがあります。
停止中のユニットを開始した後に再度pdrplstopコマンドを実行してください。
ANY BES
INACTIVE
稼働していないバックエンドサーバがあります。
停止中のバックエンドサーバを開始した後に再度pdrplstopコマンドを実行してください。
EXTRACTING
STATUS
HiRDB Datareplicatorの抽出処理が完了していません。
このメッセージの前に出力されているKFPS05243-Wメッセージを参照して対策してください。
FILE LOCK
ERROR
HiRDB Datareplicatorのデータ連動用連絡ファイルの参照権限，又は更新権限が取得できません。
FILE OPEN ERROR
HiRDB Datareplicatorのデータ連動用連絡ファイルをオープンできません。
COMMUNICATION
プロセス間の通信エラーが発生しました。
通信エラーが発生したユニットのネットワーク障害の要因を調査して対策してください。
BUSY
サービス要求先サーバが処理中のため，コマンドを実行できません。
このメッセージの直前に出力されているKFPS05244-Wメッセージを参照して対策してください。
KFPS05242-I
Accepted data replication stop request　　（Ｅ＋Ｌ）
HiRDB Datareplicator連携の終了要求を受け付けました。
(Ｓ)処理を続行します。
KFPS05243-W
Unable to stop data replication,server=aa....aa,reason=bb....bb　　（Ｅ＋Ｌ）
HiRDB Datareplicator とのデータ連動を停止できません。
aa....aa：サーバ名
bb....bb：理由コード
(Ｓ)処理を続行します。
[対策]対策後にpdrplstopコマンドを再実行してください。
理由コード
障害の内容
対策
EXTRACTING
STATUS
HiRDB Datareplicator による抽出処理が完了していません。
次に示す項目をすべて確認した後に再度pdrplstopコマンドを実行してください。
1. HiRDB Datareplicatorのhdestateコマンドで抽出プロセスが稼働しているか確認してください。抽出プロセスが稼働していない場合は，抽出プロセスを起動した後に2を確認してください。
2. HiRDB Datareplicatorによる抽出処理が完了していることを確認してください。次に示す条件をすべて満たす場合は抽出処理が完了しています。
・稼働中のトランザクションがない
pdls -d trnコマンドで稼働中のトランザクションがないことを確認してください。
・抽出中のシステムログブロック番号＞現用ファイルの最終ブロック番号である
抽出中のシステムログブロック番号はpdls -d rpl -jコマンドで確認してください。また，現用ファイルの最終ブロック番号はpdlogls -d sysコマンドで確認してください。
BES INACTIVE
稼働していないバックエンドサーバがあります。
停止中のバックエンドサーバを開始した後に再度pdrplstopコマンドを実行してください。
FILE LOCK
ERROR
HiRDB Datareplicatorのデータ連動用連絡ファイルの参照権限，又は更新権限が取得できません。
HiRDB Datareplicatorがデータ連動用連絡ファイルを占有しています。原因を調査して対策してください。その後，pdrplstopコマンドを再実行してください。
FILE OPEN ERROR
HiRDB Datareplicatorのデータ連動用連絡ファイルをオープンできません。
データ連動用連絡ファイルが削除された，又はディスク障害によってデータ連動用連絡ファイルをオープンできません。反映側のデータベースと同期をとった後にデータ連動用連絡ファイルを再作成し，HiRDB DatareplicatorとHiRDBを再度開始してください。
KFPS05244-W
Unable to stop data replication,unit=aaaa,reason=bb....bb　　（Ｅ＋Ｌ）
HiRDB Datareplicatorとの連動を停止できません。
aaaa：ユニット識別子
bb....bb：理由コード
(Ｓ)処理を終了します。
[対策]対策後にpdrplstopコマンドを再実行してください。
理由コード
障害の内容
対策
UNIT INACTIVE
稼働していないユニットがあります。
稼働していないユニットを開始した後にpdrplstopコマンドを再実行してください。
COMMUNICATION
プロセス間の通信エラーが発生しました。
通信エラーが発生したユニットのネットワーク障害の要因を調査して対策してください。
PD_RPL_HDEPATH
pd_rpl_hdepathオペランドを指定していません。
pd_rpl_hdepathオペランドを指定してください。
BUSY
サービス要求先サーバが処理中のため，コマンドを実行できません。
pdrplstopコマンドを再実行してください。
KFPS05245-W
Unit stopped for fall-back operation exists. Do not create target database from stopped unit,unit=aaaa　　（Ｅ＋Ｌ）
縮退起動によって開始していないユニットがあります。縮退起動によって開始していないユニットのデータベースを基にして，反映側データベースを再作成しないでください。
aaaa：ユニット識別子
(Ｓ)処理を続行します。
KFPS05246-E
Unable to start HiRDB system, because pd_rpl_hdepath not matched between units　　（Ｌ）
HiRDB Datareplicatorの運用ディレクトリがユニット間で一致していないため，HiRDBを開始できません。
(Ｓ)処理を終了します。
[対策]影響分散スタンバイレス型系切り替え機能の対象ユニットは，pd_rpl_hdepathオペランドの値を同じにしてください。その後，HiRDBを開始してください。
なお，KFPS05247-Eメッセージにpd_rpl_hdepathオペランドの値が表示されます。
KFPS05247-E
HiRDB unit information, unit_id = aaaa, bb....bb　　（Ｌ）
ユニットaaaaの情報を表示します。
aaaa：ユニット識別子
bb....bb：ユニットの情報
pd_rpl_hdepath：pd_rpl_hdepathオペランドの値（抽出側HiRDB Datareplicator運用ディレクトリ名）
このオペランドを省略している場合は（null）が表示されます。
(Ｓ)異常終了します。
[対策]影響分散スタンバイレス型系切り替え機能の対象ユニットのpd_rpl_hdepathオペランドの値を同じにしてください。その後，HiRDBを開始してください。
KFPS05248-E
Unable to start unit aaaa due to pd_ha_agent operand invalid　　（Ｌ）
ユニットaaaaのpd_ha_agentオペランドが不正なため，HiRDBを開始できません。ユニットaaaaのpd_ha_agentオペランドの値が，影響分散スタンバイレス型系切り替え機能から別の系切り替え機能に変更されている可能性があります。
aaaa：ユニット識別子
(Ｓ)処理を終了します。
[対策]ユニットaaaaのpd_ha_agentオペランドの値を確認してください。影響分散スタンバイレス型系切り替え機能の対象ユニットでサーバが異常終了した場合は，pd_ha_agentオペランドの値を変更できません。pd_ha_agentオペランドにactiveunitsを指定し，HiRDBを開始してください。
KFPS05249-E
aa...aa invalid; stops unit startup, unit_id = bbbb　　（Ｌ）
ユニットbbbbの再開始処理で，aa....aaの内容が正常開始時と一致していません。
aa....aa：エラー要因
"pdhagroup"：pdhagroupオペランド
bbbb：ユニット識別子
(Ｓ)異常終了します。
[対策]pdhagroupオペランドの値を確認してください。システムマネジャユニットを正常終了していない場合は，pdhagroupオペランドを変更できません。正常開始時の状態に戻した後にHiRDBを開始してください。
KFPS05250-I
Pdvrup command will be executed automatically　　（Ｌ）
pdvrupコマンドを自動起動します。
(Ｓ)処理を続行します。
KFPS05251-W
Waiting for server start, server = aa....aa　　（Ｌ）
サーバの起動を待ち合わせています。
aa....aa：起動を待ち合わせているサーバ名
(Ｓ)処理を続行します。
[対策]
影響分散型スタンバイレス系切り替え対象のユニットで系切り替え製品のコマンド※1によってメッセージに示されたサーバの状態を確認してください。
（どのユニットにもサーバが表示されない場合）
実行系サーバを起動するユニットを選んで，サーバを実行系サーバとして起動※２してください。
（サーバが実行サーバの起動待ち状態となっていた場合）
サーバを実行系サーバとして起動※２してください。
（実行系サーバの起動中状態のユニットがある場合）
サーバの起動とともに待ち合わせを解消します。特に操作をする必要はありません。
どれにも当てはまらない場合は，保守員へ連絡してください。
注※１
系切り替え製品がHAモニタの場合はmonshowコマンド，Hitachi HA Toolkit Extensionの場合はhateshowコマンド
注※２
系切り替え製品がHAモニタの場合はmonactコマンド，Hitachi HA Toolkit Extensionの場合は上位にいるクラスタソフトウェア（MC/ServiceGuardなど）のパッケージを起動するコマンドを入力します。
KFPS05288-I
HiRDB unit aaaa status change to ACTIVE　　（Ｌ）
STOP(A)ユニットaaaaの稼働状態を確認したため，ユニットのステータスをACTIVEに変更します。
aaaa：ユニット名
(Ｓ)処理を続行します。
KFPS05289-E
HiRDB unit aaaa status change to STOP(A)　　（Ｌ）
ユニットaaaaへの通信，又はユニットaaaaからの受信ができませんでした。又は，ユニットaaaaへのクライアント接続ができない状態を検知しました。ユニットaaaaのステータスをSTOP(A)に変更します。
aaaa：ユニット名称
(Ｓ)処理を続行します。
[対策]
aaaaユニットでpsコマンドを実行して，HiRDBプロセスが起動中かどうか，状態を確認してください。
起動中である場合は，通信障害，又はユニットaaaaでサービスのスローダウンが発生している可能性があります。このメッセージが出力される前に出力されたメッセージなどで原因を調査し，pdstop -zでユニットを停止した後，再度起動してください。
停止している場合は系切り替えが発生したか，又は異常終了している可能性があります。異常終了している場合は，そのときに出力されたメッセージに従って対策してください。再度起動するときは，pdstart -x，又はpdstart -uを実行してください。
KFPS05290-E
Communication error occurred, from host aa....aa to host bb....bb, processing code=ccc　　（Ｌ）
ホストaa....aaからホストbb....bbへの通信エラーが発生しました。
aa....aa：ホスト名
bb....bb：ホスト名
ccc：処理中コード（HiRDBの内部コード）
(Ｓ)システムの状態によって処理を続行又は異常終了します。
[対策]
（1）HiRDB起動中に出力された場合，システムマネジャ（MGR）以外のHiRDBユニットが起動していないことが考えられます。その場合には該当するHiRDBユニットを起動してください。
（2）そのほかの場合は，保守員に連絡してください。
KFPS05291-E
Communication error occurred,to host=aa....aa processing code=bbb reason code=ccc　　（Ｌ）
ホストaa....aaへの通信エラーが発生しました。
aa....aa：ホスト名
bbb：処理中コード（HiRDBの内部コード）
cccc：理由コード（HiRDBの内部コード）
(Ｓ)システムの状態によって処理を続行又は異常終了します。
[対策]処理中コードと理由コードの内容に従って，対策してください。
理由
コード
対策
840
ホストaa....aaのユニットが起動されていないことが考えられます。この場合，このユニットを起動してください。このユニットが縮退などで起動していない場合はこのメッセージを無視してください。このユニットが起動しているのに，このメッセージが出力される場合は通信障害が発生しています。「RPC関連エラーの詳細コード」を参照し，通信障害が発生していないか調査してください。
940
1040
1140
1440
1640
1840
2140
2240
2340
2440
2450
2500
2840
2940
3040
3200
3740
上記以外
保守員に連絡してください。
KFPS05292-I
Unit aaaa inactive　　（Ｌ）
ユニットaaaaは，正常な稼働状態になっていません。
aaaa：ユニット識別子
(Ｓ)処理を終了します。
[対策]ユニットの状態によって対処してください。
KFPS05293-E
Unable to access shared memory　　（Ｌ）
pdlsコマンド実行時，共用メモリにアクセスできません。
(Ｓ)処理を終了します。
[対策]該当するホストを起動して，pdlsコマンドを入力してください。
KFPS05300-I
Now preparing for statistics log service. run ID=aaaaaaaa　　（Ｅ＋Ｌ）
統計ログサービス機能を準備中です。
aaaaaaaa：ランID
(Ｓ)処理を続行します。
KFPS05303-E
Unable to start statistics log service. reason code=aaaa　　（Ｅ＋Ｌ）
統計ログサービス機能を開始できません。理由コードは次のとおりです（aaaa）。
aaaa：理由コード
101：メモリ不足
103：通信不正
401：未定義エラー
405：定義エラー
514：til開始失敗
(Ｓ)処理を終了します。
(Ｏ)HiRDB管理者に連絡し，理由コードに示す内容に対して処置した後，HiRDBシステムを再度開始してください。
[対策]理由コードに示す内容に対して，対策してください。
KFPS05304-I
Specified pd_stj_file_size is too small; sets pd_stj_file_size at 1024 and continues processing　　（Ｌ）
pd_stj_file_sizeオペランドの値が小さいため，1024キロバイトに切り上げて処理をします。pd_stj_file_sizeオペランドの値は，次に示す条件を満たす必要があります。
pd_stj_file_size≧pd_stj_buff_size×2
(Ｓ)処理を続行します。
[対策]HiRDBを終了したときに，pd_stj_file_sizeオペランドの値を変更してください。
KFPS05308-W
Error occurred while terminating statistics log service； continues processing. reason code=aaaa　　（Ｅ＋Ｌ）
統計ログサービス機能の終了処理中に障害が発生しましたが，このまま続行します。
aaaa：理由コード
103：通信不正
(Ｓ)処理を続行します。
KFPS05321-E
Insufficient memory. required memory size=aa....aa, area type=bb....bb　　（Ｅ＋Ｌ）
メモリ不足が発生しました。確保しようとしたサイズ及び確保しようとしたメモリの種類を示します。
aa....aa：メモリの確保サイズ
bb....bb：メモリの種類
STATIC_SHMPOOL：静的共用メモリ
(Ｓ)処理を終了します。
(Ｏ)HiRDB管理者に連絡し，対策した後再度HiRDBシステムを開始してください。
[対策]システムが使用できる共用メモリサイズを拡張してください。
KFPS05350-W
Failure to open statistics log file. file name=aa....aa, reason code=bbbb-cc　　（Ｅ＋Ｌ）
統計ログファイルのオープンに失敗しました。
aa....aa：統計ログファイル名
bbbb：理由コード
303：openシステムコールエラー
cc：HiRDB内部コード
(Ｓ)処理を終了します。
(Ｏ)HiRDB管理者に連絡し，原因を取り除いた後再度実行してください。
[対策]直前に出力されているKFPO00107-Eメッセージを基にエラー原因を調査し，対策してください。
KFPS05351-W
Failure to close statistics log file. file name=aa....aa, reason code=bbbb-cc　　（Ｅ＋Ｌ）
統計ログファイルのクローズに失敗しました。
aa....aa：統計ログファイル名
bbbb：理由コード
304：closeシステムコールエラー
cc：HiRDB内部コード
(Ｓ)処理を続行します。
(Ｏ)HiRDB管理者に連絡し，原因を取り除いてください。
[対策]理由コードで示す原因を取り除いてください。
KFPS05352-W
Failure to write statistics log file. fime name=aa....aa,reason code=bbbb-cc　　（Ｅ＋Ｌ）
統計ログファイルへの出力で失敗しました。
aa....aa：統計ログファイル名
bbbb：理由コード
305：writeシステムコールでエラー
cc：HiRDB内部コード
(Ｓ)処理を続行します。
(Ｏ)HiRDB管理者に連絡し，原因を取り除いてください。
[対策]直前に出力されているKFPO00107-Eメッセージを基にエラー原因を調査し，対策してください。
KFPS05353-E
Error occurred while handling statistics log file. file name=aa....aa,reason code=bbbb-cc　　（Ｅ＋Ｌ）
統計ログファイルの操作中に障害が発生しました。
aa....aa：統計ログファイル名
bbbb：理由コード
103：通信不正
cc：HiRDB内部コード
(Ｓ)処理を終了します。
[対策]理由コードを参照し，原因を取り除いてください。
KFPS05354-E
Error occurred while handling statistics log file. reason code=aaaa-bb　　（Ｅ＋Ｌ）
統計ログファイルの操作中に障害が発生しました。
aaaa：理由コード
101：メモリ不足
103：通信不正
105：タイムアウト（通信）
bb：HiRDB内部コード
(Ｓ)処理を終了します。
(Ｏ)HiRDB管理者に連絡し，原因を取り除いた後，再度実行してください。
[対策]理由コードを参照して原因を取り除いてください。
KFPS05355-I
Statistics log file swapped. from=aa....aa, to=bb....bb, unit ID=cccc　　（Ｅ＋Ｌ）
統計ログファイルが切り換わりました。
aa....aa：切り換え前のファイル名（切り換え前）
bb....bb：切り換え後のファイル名（切り換え後）
cccc：ユニット識別子
(Ｓ)処理を続行します。
KFPS05360-W
Cancels statistics output. unit ID=aaaa　　（Ｌ）
ユニットaa....aaの統計情報の取得を停止します。
直前に統計ログファイルに関する異常を示すメッセージが出力されています。このため，直接の原因は，このメッセージを参照してください。
aaaa：ユニット識別子
(Ｓ)処理を終了します。
このメッセージを出力したとき，統計ログファイルに書き込もうとしたバッファに格納されていた統計情報は，捨てられているので注意してください。
[対策]メッセージ中に表示されたユニットで，統計情報を必要としない場合，運用を続行できます。
統計情報を必要とする場合，該当するユニットを一度終了し，直前に出力されたメッセージに示す直接の原因を取り除いてください。その後，該当するユニットに対してpdstjswapコマンドを実行するか，又はユニットを再度起動して，統計情報の取得を再開してください。
KFPS05361-W
Already canceled statistics output. unit ID=aaaa　　（Ｌ）
aaaaで示すユニットの統計情報出力は，以前に発生した障害で既に停止しています。
aaaa：ユニット識別子
(Ｓ)処理を続行します。
このメッセージを出力したとき，統計ログファイルに書き込もうとしたバッファに格納されていた統計情報は，捨てられているので注意してください。
[対策]メッセージ中に表示されたユニットで，特に統計情報を必要としない場合，運用を続行できます。
統計情報を必要とする場合，該当するユニットを一度終了し，直前に出力されたメッセージに示す直接の原因を取り除いてください。その後，該当するユニットを再度起動し，統計情報の取得を再開してください。
KFPS05362-W
Unable to cancel statistics output. unit ID=aaaa　　（Ｌ）
aaaaで示すユニットは，統計情報の取得が停止できません。直前に統計ログファイルに関する異常を示すメッセージが出力されています。このため,直接の原因は,このメッセージを参照してください。
aaaa：ユニット識別子
(Ｓ)処理を続行します。
このメッセージを出力したとき，統計ログファイルに書き込もうとしたバッファに格納されていた統計情報は，捨てられているので注意してください。
[対策]pdstendコマンドを入力し，統計情報の取得を停止させてください。また，メッセージ中に表示されたユニットで，特に統計情報を必要としない場合，運用を続行してください。統計情報を必要とする場合，該当するユニットを一度終了し，直前に出力されたメッセージに示す直接の原因を取り除いてください。その後，該当するユニットを再度起動し，統計情報の取得を再開してください。
KFPS05370-I
Usage:pdstjswap [-x host_name|-u unit_id]　　（Ｅ）
pdstjswapコマンドの使用方法を示します。
(Ｓ)処理を続行します。
KFPS05372-E
One of aa....aa option must be specified.　　（Ｅ）
複数のオプションのうち，どれかを一つ指定する必要があります。
aa....aa：オプション
(Ｓ)処理を終了します。
(Ｏ)オプションを一つ指定して，再度コマンドを実行してください。
KFPS05373-E
Unable to execute command due to failure of aa....aa system call (command), code=bb....bb.　　（Ｅ）
aa....aaシステムコール（コマンド）のエラーが原因で，コマンドが実行できません。
aa....aa：エラーとなったシステムコール名又はコマンド名
｛exec｜fork｜rsh｝
bb....bb：システムコール又はrshの戻り値に対する内部コード
(Ｓ)処理を終了します。
[対策]直前に出力されているKFPO00107-Eメッセージを基にエラー原因を調査し，対策してください。
KFPS05374-E
Specified hostname invalid in 'pdstart' operand.　　（Ｅ）
システム定義のpdstartオペランドに指定したホスト名が誤っています。
(Ｓ)処理を終了します。
(Ｏ)システム定義のpdstartオペランドに指定しているホスト名を修正してください。
KFPS05375-E
Hostname must be equal to SDS hostname for single server.　　（Ｅ）
HiRDB/シングルサーバの場合，ホスト名はシングルサーバのホスト名を指定してください。HiRDB/シングルサーバの場合，シングルサーバのホスト名は一つだけなので省略できますが，ホスト名を指定し，そのホスト名が正しくないときにはこのメッセージが出力されます。
(Ｓ)処理を終了します。
(Ｏ)ホスト名を省略するか，又は正しいホスト名を指定して，再度コマンドを実行してください。
KFPS05381-E
Insufficient memory　　（Ｅ）
メモリ不足が発生しました。
(Ｓ)処理を終了します。
(Ｏ)プロセス数などを見直して，対策後に再度実行してください。
KFPS05393-E
Communication error occurred. info=aa....aa　　（Ｅ）
コマンドの実行時に通信障害が発生しました。
aa....aa：保守情報
(Ｓ)処理を終了します。
(Ｏ)通信障害の原因を取り除いた後に再度コマンドを実行してください。
[対策]このメッセージの直前に，通信障害の原因を示すメッセージが出力されている場合は，そのメッセージの処置に従って通信障害の原因を取り除いてください。通信障害の原因を示すメッセージが出力されていない場合は，保守情報の内容を記録して保守員に連絡してください。
KFPS05394-E
Unit state not online. info=aa....aa　　（Ｅ）
ユニットの状態がオンラインではありません。
aa....aa：保守情報
(Ｓ)処理を終了します。
(Ｏ)ユニットが稼働していない場合は，ユニットを開始して再度コマンドを実行してください。
[対策]ユニットが稼働しているのにこのメッセージが出力された場合は，保守情報の内容を記録して保守員に連絡してください。
KFPS05395-E
Statistics log service is inactive. info=aa....aa　　（Ｅ）
このユニットでは統計ログを取得していません。
aa....aa：保守情報
(Ｓ)処理を終了します。
(Ｏ)統計ログの取得を開始した後に再度コマンドを実行してください。
[対策]このユニットで統計ログが取得されているのにこのメッセージが出力された場合は，保守情報の内容を記録して保守員に連絡してください。
KFPS05396-W
Statistics log file not deleted.　　（Ｅ）
統計ログファイルのスワップ処理が終了しましたが，統計ログファイルの削除処理ができませんでした。次に示す原因が考えられます。
・現在出力中の統計ログファイルを削除しようとした
・削除しようとした統計ログファイルがほかのプログラム又はコマンドで使用されている
(Ｓ)処理を続行します。
(Ｏ)統計ログファイルが削除された場合，次回の統計ログファイルのスワップ処理が正常にできないことがあります。統計情報を取得している場合は，統計ログファイルのスワップが発生する前に統計情報の取得を終了してください。統計情報を取得していない場合は，統計情報の取得を控えてください。統計情報を取得するには，HiRDBを一度終了して再度開始してください。
ほかのプログラム又はコマンドによって統計ログファイルが使用中の場合は，引き続き統計情報を取得できます。ただし，削除対象の統計ログファイルは削除されないため，アンロード又は編集をするときに注意してください。
[対策]メッセージの説明に記した理由に該当しない場合に，このメッセージが出力されたときは保守員に連絡してください。
KFPS05397-E
Unexpected error occurred. info:(aa....aa:bbbb)cc....cc　　（Ｅ）
予期せぬエラーが発生しました。
aa....aa：保守情報
bbbb：保守情報
cc....cc：保守情報
(Ｓ)異常終了します。
[対策]保守情報の内容を記録して保守員に連絡してください。
KFPS05398-E
Statistics log file can not open　　（Ｅ）
コマンドの実行中に統計ログファイルのオープン処理に失敗しました。次に示す原因が考えられます。
・ファイルシステム領域が不足している
・スワップ先の統計ログファイルの上書きができない（統計ログファイル又は統計ログファイルの格納ディレクトリの書き込み権限がない）
(Ｓ)処理を終了します。
(Ｏ)このメッセージが出力された場合，統計情報を取得できません。統計情報を取得している場合は，すぐに統計情報の取得を終了してください。統計情報を取得していない場合は，統計情報の取得を控えてください。
ファイルシステムの容量不足が原因の場合は，このファイルシステムの不要なファイルを削除してください。スワップ先の統計ログファイルを上書きできない場合は，この統計ログファイルの属性を上書き可能にしてください。
これらの対策をした後に，pdstjswapコマンドを実行して統計情報の取得を再開してください。
[対策]メッセージの説明に記した理由に該当しない場合に，このメッセージが出力されたときは保守員に連絡してください。
KFPS05600-I
HiRDB unit aaaa prepare for starting. status=bb....bb　　（Ｌ）
ユニットaaaaを開始するための準備中です。
aaaa：ユニット識別子
bb....bb：ユニットの状態
ACCEPT pdstart：
pdstartコマンドを受け付けました。
FIX SHARED MEMORY：
共用メモリのページ固定処理を開始しました。
CREATE PIPE FILE：
パイプファイルの作成処理を開始しました。
(Ｓ)処理を続行します。
KFPS05601-I
This program is HiRDB/Workgroup Server　　（Ｌ）
このプログラムは，HiRDB/Workgroup Serverです。
(Ｓ)処理を続行します。
KFPS05602-I
HiRDB Option = aa....aa, unit_id = bbbb, version = cc....cc　　（Ｌ）
組み込まれている付加PP名を表示します。このメッセージはユニットの正常開始又は再開始時に出力されます。再開始時は前回の環境を表示します。
aa....aa：付加PPの名称
・Object Option：HiRDB/Single Server - Object Option又はHiRDB/Parallel Server - Object Option
・Staticizer Option：HiRDB Staticizer Option
・External Data Access：HiRDB External Data Access
・Advanced High Availability：HiRDB Advanced High Availability
・Advanced Partitioning Option：HiRDB Advanced Partitioning Option
・Non Recover FES：HiRDB Non Recover FES
bbbb：ユニット識別子
cc....cc：付加PPのバージョン
(Ｓ)処理を続行します。
KFPS05603-I
Server aa....aa starting on unit bbbb　　（Ｌ）
ユニットbbbbでサーバaa....aaが実行系として起動開始しました。
aa....aa：実行系として起動開始したサーバのサーバ名
bbbb：サーバ起動先ユニットのユニット識別子
(Ｓ)処理を続行します。
KFPS05605-W
No more guest servers activatable on unit aaaa, number of active guest servers reached pd_ha_max_act_guest_servers　　（Ｌ）
ゲスト用領域の空きがなくなったため，ユニットaaaaはこれ以上ゲストBESを受け入れることができません。
aaaa：ゲスト用領域の空きがなくなったユニットのユニット識別子
(Ｓ)処理を続行します。
KFPS05606-W
Unable to activate server aa....aa on unit bbbb,number of act guest servers over pd_ha_max_act_guest_servers　　（Ｌ）
ユニットbbbbのゲスト用領域の空きがないため，サーバaa....aaをユニットbbbbで実行系にできませんでした。
aa....aa：実行系にできないサーバのサーバ名
bbbb：ゲスト用領域の空きがないユニットの識別子
(Ｓ)処理を続行します。
[対策]次に示すどれかの方法で，該当するサーバがHAグループ内の他ユニット上で実行系として稼働しているかどうかを確認してください。
・このメッセージの後にHAグループ内の他ユニットでKFPS01813-Iメッセージが出力されていることを確認する
・pdls -d haコマンドを実行する
・pdls -d svrコマンドを実行する
該当するサーバが実行系として稼働していない場合は，システムマネジャユニット又は各ユニットに出力されているメッセージを参照してください。必要に応じてメッセージに従って対策した後，サーバを開始してください。
KFPS05607-I
HiRDB server aa....aa stop request issued from HA monitor;stops HiRDB server aa....aa, reason=bb....bb　　（Ｌ）
HAモニタ又はHitachi HA Toolkit Extensionからサーバaa....aaの停止要求が発生したため，サーバaa....aaを停止します。
aa....aa：停止するサーバのサーバ名
bb....bb：HiRDB内部の停止要因コード
(Ｓ)異常終了します。
(Ｏ)HAモニタ又はHitachi HA Toolkit Extensionのメッセージを参照してください。
KFPS05608-I
HiRDB server aa....aa restart request issued from HA monitor;stops HiRDB server aa....aa temporarily, reason=bb....bb　　（Ｌ）
HAモニタ又はHitachi HA Toolkit Extensionからサーバaa....aaの再開始要求が発生したため，サーバaa....aaを停止します。
aa....aa：停止するサーバのサーバ名
bb....bb：HiRDB内部の停止要因コード
(Ｓ)サーバを一度停止した後に再開始します。
(Ｏ)このメッセージが出力された後，システムマネジャユニットからpdls -d ha（又はpdls -d ha -a）コマンドでサーバの稼働状態を確認してください。サーバが再開始していない場合は，エラー要因によってサーバが開始できないことがあります。このメッセージの後に出力されているメッセージを参照して，メッセージの対処方法に従ってください。
KFPS05609-I
HiRDB server aa....aa start mode determined, start mode:bb....bb　　（Ｌ）
サーバの開始モードを決定しました。
aa....aa：サーバ名
bb....bb：開始モード
R：再開始
R(P)：計画停止後の再開始
S：正常開始
(Ｓ)処理を続行します。
KFPS05610-I
Server aa....aa is placed in the starting wait state　　（Ｅ＋Ｌ）
サーバaa....aaは実行系サーバの起動待ち状態です。
aa....aa：サーバ名
(Ｓ)処理を続行します。
(Ｏ)実行系サーバが起動していません。実行系サーバを起動するか，HAモニタ又はHitachi HA Toolkit Extensionのコマンドで実行系として起動してください。
KFPS05611-I
Server aa....aa is placed in the standby state　　（Ｅ＋Ｌ）
サーバaa....aaが待機状態になりました。
aa....aa：サーバ名
(Ｓ)処理を続行します。
KFPS05612-I
Unable to recognize HiRDB server aa....aa initialization completion　　（Ｅ＋Ｌ）
pdstartコマンドでサーバaa....aaの初期化処理の完了を確認できません。
又は，何かの原因によってサーバが起動できませんでした。
(Ｓ)処理を続行します。
(Ｏ)サーバの起動に時間が掛かっているか，又はサーバの起動に失敗しました。pdlsコマンドを入力し，サーバの稼働状態を確認してください。
・サーバが起動中の場合
しばらくしてから再度pdlsコマンドを入力してシステムの状態を確認してください。サーバの初期化処理が完了しない場合，ほかに原因がないかメッセージを確認してください。
・サーバが停止中の場合
サーバの起動中にエラーが発生して，サーバが起動できないことがあります。メッセージログファイル及びsyslogfileのメッセージを確認してサーバ起動に失敗した原因を確認してください。メッセージがない場合は，ユニット内未使用ゲスト用領域がないために起動できないことが原因の可能性があります。pdls -d ha コマンドでユニット内の稼働中ゲストバックエンドサーバ数と，pd_ha_max_act_guest_serversオペランドの値から，ユニット内未使用ゲスト用領域の数を確認してください。ユニット内の稼働中ゲストバックエンドサーバ数が，pd_ha_max_act_guest_serversオペランドの値に達している場合は，ほかのユニットでバックエンドサーバを起動してください。
なお，原因が判明しないときは，保守員に連絡してください。
サーバの起動処理に常に時間が掛かる場合は，pd_system_complete_wait_timeオペランドにシステム起動に必要な時間を指定してpdstartコマンドを正常に終了させてください。
KFPS05613-W
Too big "pd_ha_max_act_guest_servers". Max value assumed, reason code = aa....aa, unit = bbbb, original value = cc....cc, assumed value = dd....dd　　（Ｅ＋Ｌ）
pd_ha_max_act_guest_serversオペランドに上限値よりも大きな値を設定しています。上限値を設定します。
aa....aa：理由コード
SERVER LIMIT：ユニット制御情報定義のpd_ha_max_act_guest_serversオペランドの指定値とホストBES数の合計がユニット内のサーバ数の上限を超えています。pd_ha_max_act_guest_serversオペランドにユニット内のサーバ数の上限を超えない値を設定します。
GUEST BES COUNT：ユニット制御情報定義のpd_ha_max_act_guest_serversオペランドにゲストBES数より大きな値が設定されています。pd_ha_max_act_guest_serversオペランドにゲストBES数を設定します。
bbbb：ユニット識別子
cc....cc：ユニット制御情報定義のpd_ha_max_act_guest_serversオペランドに指定した値
dd....dd：内部計算によってpd_ha_max_act_guest_serversオペランドに設定した値
(Ｓ)処理を続行します。
[対策]
理由コードに対する次の説明を参考にして，ユニット制御情報定義のpd_ha_max_act_guest_serversオペランド指定が正しいかどうかを見直してください。
SERVER LIMIT：pd_ha_max_act_guest_serversオペランドに指定した値と，ユニット内のホストBES数の合計がユニット内のサーバ数の上限を超えています。pd_ha_max_act_guest_serversオペランドにユニット内のサーバ数の上限を超えない値を設定します。pd_ha_max_act_guest_serversオペランドに指定した値よりも，同時に稼働できるゲストサーバ数が少なくなります。
GUEST BES COUNT：pd_ha_max_act_guest_serversオペランドにユニットで稼働するゲストBES数より大きな値が指定されています。適切なリソースを確保するため，ユニットで稼働するゲストBES数をpd_ha_max_act_guest_serversオペランドに設定します。
KFPS05614-W
Too small "pd_ha_max_server_process". Total of host BES "pd_max_bes_process" assumed, unit = aaaa, original value = bb....bb, assumed value = cc....cc　　（Ｅ＋Ｌ）
ユニット制御情報定義のpd_ha_max_server_processオペランドに該当ユニット内ホストBESのpd_max_bes_procesオペランドの合計よりも小さな値を指定しています。該当ユニット内ホストBESのpd_max_bes_processオペランドの合計を設定します。
aaaa：ユニット識別子
bb....bb：ユニット制御情報定義のpd_ha_max_server_processオペランドに指定した値
cc....cc：内部計算によってpd_ha_max_server_processオペランドに設定した値
(Ｓ)処理を続行します。
[対策]ユニット制御情報定義のpd_ha_max_server_processオペランドの指定値を見直してください。
KFPS05615-W
Too small "pd_ha_process_count". Total of host BES "pd_process_count" assumed, unit = aaaa, orginal value = bb....bb, assumed value = cc....cc　　（Ｅ＋Ｌ）
ユニット制御情報定義のpd_ha_process_countオペランドに該当ユニット内ホストBESのpd_process_countオペランドの合計よりも小さな値を指定しています。該当ユニット内ホストBESのpd_process_countオペランドの合計を設定します。
aaaa：ユニット識別子
bb....bb：ユニット制御情報定義のpd_ha_process_countオペランドに指定した値
cc....cc：内部計算によってpd_ha_process_countオペランドに設定した値
(Ｓ)処理を続行します。
[対策]ユニット制御情報定義のpd_ha_process_countオペランドの指定値を見直してください。
KFPS05616-I
Guest servers became activatable on unit aaaa　　（Ｌ）
ゲスト用領域に空きがあるため，ユニットaaaaはゲストBESを受け入れることができます。
aaaa：ユニット識別子
(Ｓ)処理を続行します。
KFPS05617-I
Server aa....aa stop request accept from HA monitor; stops server reason=bb....bb　　（Ｌ）
HAモニタ又はHitachi HA Toolkit Extensionからサーバの停止要求が発生したため，サーバaa....aaを停止します。
aa....aa：サーバ名
bb....bb：HiRDB内部の停止要因コード（保守情報）
(Ｓ)処理を終了します。
(Ｏ)直前に出力されているHAモニタのメッセージを参照してください。
KFPS05618-E
Unable to specify definition in HAgroup unit, unit ID=aaaa, definition file=bb....bb, record number=cc....cc　　（Ｅ＋Ｌ）
影響分散スタンバイレス型系切り替え適用ユニットのユニット制御情報定義に，影響分散スタンバイレス型系切り替え適用ユニットで指定できないオペランドが指定されています。
aaaa：ユニット識別子
bb....bb：解析中の定義ファイル名
cc....cc：エラーがあったレコード番号
(Ｓ)異常終了します。
[対策]ユニット制御情報定義を見直してください。影響分散スタンバイレス型系切り替えで指定できないオペランドを削除してHiRDBを再度開始してください。影響分散スタンバイレス型系切り替え機能使用時にユニット制御情報定義で指定できるオペランドについては，マニュアル「HiRDB Version 7 システム定義」を参照してください。
KFPS05619-E
Unable to execute aa....aa command,server bb....bb state not cc....cc　　（Ｅ＋Ｌ）
サーバ名bb....bbの状態がcc....ccではありません。このため，コマンドが実行できません。
aa....aa：入力したコマンド名｛pdstart｜pdstop｝
bb....bb：コマンドを実行できなかったサーバ名
cc....cc：コマンドを入力できるステータス
OFFLINE：オフライン中
ONLINE：オンライン中
(Ｓ)処理を終了します。
[対策]サーバbb....bbのステータスがcc....ccになるのを待って，コマンドを再度実行してください。ただし，開始状態（開始処理中を含む）でのpdstartコマンド，及び停止状態（停止処理中を含む）でのpdstopコマンドは実行できません。この場合は，停止又は開始したことを確認してからコマンドを実行してください。
KFPS05620-I
Invalid version of HiRDB option, option=aaa, invalid version=bb....bb, required version=cc....cc　　（Ｌ）
セットアップ済みの付加PP aaaのバージョンが不正です。セットアップ済みの付加PPのバージョンはbb....bbで，正しいバージョンはcc....cc以降です。
aaa：付加PP
aha：Advanced High Availability
bb....bb：セットアップ済みの付加PPのバージョン
cc....cc：付加PPの正しいバージョン
(Ｓ)HiRDBの開始処理を中断します。
(Ｏ)このメッセージは，このメッセージの前に出力されたKFPS01801-Eメッセージの付加情報です。付加PP名及び付加PPの正しいバージョンを確認し，KFPS01801-Eメッセージの指示に従ってください。
KFPS05621-I
Server aa....aa standby state released, status=bb....bb　　（Ｅ＋Ｌ）
サーバaa....aaの待機状態が解除されました。
aa....aa：サーバ名
bb....bb：サーバの状態コード（保守情報）
(Ｓ)処理を続行します。
KFPS05700-I
HiRDB unit aaaa Security Audit bb....bb　　（Ｌ）
HiRDB（HiRDB/パラレルサーバの場合はユニット）開始時のセキュリティ監査機能の状態を示します。
aaaa：ユニット識別子
bb....bb：セキュリティ監査機能の状態
・inactive：HiRDBの開始時から監査証跡の取得を開始しません。
(Ｓ)処理を続行します。
[対策]HiRDBを強制正常開始したため，セキュリティ監査機能が停止しています。セキュリティ監査機能を有効にする場合は，pdaudbeginコマンドを実行してください。停止したままでよい場合は，対処は不要です。
KFPS05701-E
Unable to start Security Audit, unit=aaaa, reason code=bb....bb　　（Ｌ）
ユニットaaaaでエラーが発生したため，監査証跡の取得を開始できません。
aaaa：ユニット識別子
bb....bb：理由コード
(Ｓ)HiRDBを異常終了します。
[対策]理由コードに対応する対策をした後に，再度HiRDBを開始してください。
理由コード
対策
PROCESS_MEMORY
プロセス固有メモリが不足しています。プロセス固有メモリを見積もり直してください。
COMMUNICATION
ネットワーク障害が発生しました。ネットワーク障害を回復してください。
CONFIGURATION
HiRDBシステム定義の解析処理中にエラーが発生しました。このメッセージの前後に出力されている定義解析エラーのメッセージを参照して，システム定義のオペランドを見直してください。
NO_FILE_NAME
pd_aud_file_nameオペランドが指定されていません。pd_aud_file_nameオペランドを指定してください。
FILE_ACCESS
監査証跡ファイルのアクセス時にエラーが発生しました。このメッセージの前後に出力されているKFPS05704-Eメッセージを参照し，対策してください。
KFPS05702-I
aa....aa assigned as current audit trail generation file, unit=bbbb　　（Ｌ＋Ｓ）
ユニットbbbbの監査証跡ファイルaa....aaを現用にしました。
aa....aa：監査証跡ファイル名
bbbb：ユニット識別子
(Ｓ)処理を続行します。
KFPS05703-I
Audit trail generation file aa....aa released, unit=bbbb　　（Ｌ＋Ｓ）
ユニットbbbbの監査証跡ファイルaa....aaが現用でなくなりました。
aa....aa：監査証跡ファイル名
bbbb：ユニット識別子
(Ｓ)処理を続行します。
KFPS05704-E
aa....aa error occurred in audit trail generation file bb....bb, unit=cccc, reason code=dd....dd　　（Ｅ＋Ｌ）
ユニットccccの監査証跡ファイルbb....bbへのアクセス時にエラーが発生しました。
aa....aa：エラー時の処理
・Open：ファイルのオープン
・Close：ファイルのクローズ
・Read：ファイルの読み込み
・Write：ファイルの書き込み
・Create：ファイルの作成
・Delete：ファイルの削除
bb....bb：監査証跡ファイル名
監査証跡ファイル用のHiRDBファイルシステム領域のアクセスエラーの場合は****************を表示します。
cccc：ユニット識別子
dd....dd：理由コード
(Ｓ)処理を終了します。
[対策]理由コードに対応する対策をした後に，再度HiRDBを開始してください。
理由コード
対策
PROCESS_MEMORY
プロセス固有メモリが不足しています。プロセス固有メモリを見積もり直してください。
OPEN_MAX
監査証跡ファイルのオープン処理で，オープンできるファイル数が上限値を超えました。1プロセス内でオープンできるファイル数の上限値を見直してください。必要ならばカーネルを再作成してください。
FILE_PERMISSION
監査証跡ファイル用のHiRDBファイルシステム領域に対するアクセス権がありません。OSのlsコマンドなどでアクセス権を確認してください。アクセス権がない場合はアクセス権を与えてもらってください。
IO_ERROR
入出力エラーが発生しました。次に示す手順で対策してください。
1. 入出力エラーが発生した原因を調査して対策します。
2. pdaudrmコマンドで，入出力エラーが発生した監査証跡ファイルを削除します。ファイルの削除ができない場合は残りのファイルで運用を続けてください。
上記の方法で対処できない場合は，ディスクを交換して監査証跡ファイル用のHiRDBファイルシステム領域を再作成してください。
VERSION
監査証跡ファイル用のHiRDBファイルシステム領域のバージョンが一致しません。pdfmkfsコマンドで監査証跡ファイル用のHiRDBファイルシステム領域を再作成してください。
GEN_FILE_PERMISSION
監査証跡ファイルのアクセス権がありません。pdflsコマンドで監査証跡ファイルのアクセス権を確認してください。アクセス権がない場合はアクセス権を与えてもらってください。
FILE_NOT_FOUND
監査証跡ファイルがありません。
●エラー時の処理がDelete以外の場合
・監査証跡ファイル用のHiRDBファイルシステム領域が作成されているか確認してください。作成されていない場合はpdfmkfsコマンドで監査証跡ファイル用のHiRDBファイルシステム領域を作成してください。
・作成した監査証跡ファイル用のHiRDBファイルシステム領域と，pd_aud_file_nameオペランドに指定したHiRDBファイルシステム領域名が一致しているか確認してください。
・pdloadコマンド実行時の制御文ファイルに指定した監査証跡ファイル名が正しいか確認してください。
●エラー時の処理がDeleteの場合
・監査証跡ファイル用のHiRDBファイルシステム領域が作成されているか確認してください。
・作成した監査証跡ファイル用のHiRDBファイルシステム領域と，pd_aud_file_nameオペランドに指定したHiRDBファイルシステム領域名が一致しているか確認してください。
GEN_FILE_NOT_FOUND
・監査証跡ファイルがありません。pdls -d audコマンドで監査証跡ファイルがあるか確認してください。
・pdloadコマンド実行時の制御文ファイルに指定した監査証跡ファイル名が正しいか確認してください。
LOCKSEGMENT
ロックセグメントが不足しました。OSのシステム構築時に指定したレコードロックセグメント数を見直してください。
NO_SPACE
監査証跡ファイルを作成するために必要な空き領域を確保できませんでした。監査証跡ファイル用のHiRDBファイルシステム領域の大きさを見積もり直してください。
FILE_TYPE
監査証跡ファイル用のHiRDBファイルシステム領域がキャラクタ型スペシャルファイル上に作成されていません。pdfmkfsコマンドでHiRDBファイルシステム領域をキャラクタ型スペシャルファイル上に作成してください。
FILE_OBJECT
監査証跡ファイル用のHiRDBファイルシステム領域の使用目的（pdfmkfsコマンドの-kオプション）がSYS又はSVRではありません。pdfmkfsコマンドの-kオプションにSYS又はSVRを指定して，HiRDBファイルシステム領域を作成してください。
FILE_AREA
監査証跡ファイル用の領域がHiRDBファイルシステム領域として作成されていません。pdfmkfsコマンドで監査証跡ファイル用のHiRDBファイルシステム領域を作成してください。
LARGE_FILE
監査証跡ファイル用のHiRDBファイルシステム領域がラージファイル（HiRDBサーバがWindows版の場合は2048メガバイト以上のHiRDBファイルシステム領域）で作成されていますが，pd_large_file_useオペランドにYが指定されていません。pd_large_file_useオペランドにYを指定するか，又は2ギガバイト未満の監査証跡ファイル用のHiRDBファイルシステム領域を作成してください。
FILE_NUM
作成できる監査証跡ファイル数の上限を超えました。次に示すどちらかの処置をしてください。
・pd_aud_max_generation_numオペランドの値を見直してください。
・監査証跡ファイル用のHiRDBファイルシステム領域をpdfmkfsコマンドで再作成してください。そのとき，HiRDBファイルシステム領域内の最大ファイル数，及び領域長を見積もり直してください。最大ファイル数，及び領域長を変更する場合は，pd_aud_max_generation_num及びpd_aud_max_generation_sizeオペランドの値も見直してください。
INTERNAL_ERROR
内部処理エラーが発生しました。$PDDIR/spool下の全ファイル及びsyslogfileの内容を保存して保守員に連絡してください。
KFPS05705-E
Available audit trail generation file number=a. HiRDB unit bbbb force terminate　　（Ｌ）
スワップ先にできる監査証跡ファイルが残り0又は1個になりました。pd_aud_no_standby_file_oprオペランドにdownを指定しているため，ユニットbbbbを強制終了します。
a：スワップ先にできる監査証跡ファイルの数
bbbb：ユニット識別子
(Ｓ)HiRDBを異常終了します。
[対策]監査証跡ファイルの運用方法については，マニュアル「HiRDB Version 7 システム運用ガイド」を参照してください。
KFPS05706-W
No standby audit trail generation file available, unit=aaaa. Force overwrite audit trail generation file　　（Ｌ）
ユニットaaaaで，スワップ先にできる監査証跡ファイルがなくなりました。pd_aud_no_standby_file_oprオペランドにforcewrite（省略値）を指定しているため，データロード待ちのファイル（閉塞状態のファイルを除く）の中で最終更新日時が一番古いファイルをスワップ先にします。
aaaa：ユニット識別子
(Ｓ)処理を続行します。
[対策]データロード待ちの監査証跡ファイルをデータロードするように監査人に連絡してください。監査証跡ファイルの運用方法については，マニュアル「HiRDB Version 7 システム運用ガイド」を参照してください。
KFPS05707-E
Error occurred in all audit trail generation files, unit=aaaa. Security Audit stopped　　（Ｌ）
pd_aud_no_standby_file_oprオペランドにforcewrite（省略値）を指定していますが，HiRDBファイルシステム領域内の全監査証跡ファイルが閉塞中のため，監査証跡の出力を中止します。
aaaa：ユニット識別子
(Ｓ)処理を続行します。
[対策]監査証跡ファイルに障害が発生したときの対処方法については，マニュアル「HiRDB Version 7 システム運用ガイド」を参照してください。
KFPS05708-W
Unable to use Security Audit, unit=aaaa, reason code=bb....bb　　（Ｅ＋Ｌ）
システム構成がセキュリティ監査機能の前提条件を満たしていないため，セキュリティ監査機能を使用できません。前提条件を次に示します。
・ユティリティ専用ユニットにはセキュリティ監査機能を使用できません。
・HiRDB/パラレルサーバでサーバがないユニット（システムマネジャだけのユニットを含む）がある場合，セキュリティ監査機能を使用できません。
aaaa：ユニット識別子
bb....bb：理由コード
・UTILITY：ユティリティ専用ユニットのため，セキュリティ監査機能を使用できません。
・ONLY_SYSTEM_MANAGER：ユニット内にシステムマネジャだけしか定義されていないため，セキュリティ監査機能を使用できません。
・NO_SERVER：ユニット内にサーバが定義されていないため，セキュリティ監査機能を使用できません。
(Ｓ)処理を続行します。
[対策]セキュリティ監査機能を使用する場合はシステム構成を変更してください。
KFPS05709-E
Internal function error occurred, unit=aaaa, function=bb....bb, return code=cc....cc　　（Ｅ＋Ｌ）
ユニットaaaaで内部処理エラーが発生しました。
aaaa：ユニット識別子
bb....bb：エラーが発生した関数名
cc....cc：システム関連エラーの詳細コード
(Ｓ)処理を終了します。
[対策]出力されたシステム関連エラーの詳細コードに対応する対策をしてください。システム関連エラーの詳細コードについては，「システム関連エラーの詳細コード」を参照してください。対応できないエラーが発生した場合は保守員に連絡してください。
KFPS05750-I
Security Audit aaaaaaa, unit=bbbb　　（Ｓ）
ユニットbbbbの監査証跡の取得を開始又は終了しました。
aaaaaaa：監査証跡の取得状態
・started：監査証跡の取得開始
・stopped：監査証跡の取得終了
bbbb：ユニット識別子
(Ｓ)処理を続行します。
KFPS05751-I
Usage: aa....aa　　（Ｅ＋Ｓ）
HiRDB/シングルサーバでのaa....aaコマンドの使用方法を示します。このメッセージはコマンドの形式に誤りがある場合に出力されます。
aa....aa：コマンドの使用方法
・pdaudbegin
・pdaudend
・pdaudrm -g audit_generation_file_name [-f]
・pdaudswap
(Ｓ)処理を終了します。
[対策]コマンドを再度実行してください。
KFPS05751-I
Usage: aa....aa　　（Ｅ＋Ｓ）
HiRDB/パラレルサーバでのaa....aaコマンドの使用方法を示します。このメッセージはコマンドの形式に誤りがある場合に出力されます。
aa....aa：コマンドの使用方法
・pdaudbegin [-u unit_id]
・pdaudend [-u unit_id]
・pdaudrm -u unit_id -g audit_generation_file_name [-f]
・pdaudswap -u unit_id
(Ｓ)処理を終了します。
[対策]コマンドを再度実行してください。
KFPS05752-E
Error occurred during aa....aa command execution, unit=bbbb, reason code=cc....cc　　（Ｅ＋Ｌ）
aa....aaコマンドの実行中にエラーが発生しました。
aa....aa：コマンド名
・pdaudbegin
・pdaudend
・pdaudrm
・pdaudswap
・pdls -d aud
bbbb：エラーが発生したユニット識別子
cc....cc：理由コード
(Ｓ)処理を終了します。
[対策]理由コードに対応する対策をしてください。
理由コード
対策
ALREADY_STARTED
監査証跡は既に取得されています。
COMMUNICATION
ネットワーク障害が発生しました。ネットワーク障害を回復してください。
CONFIGURATION
HiRDBシステム定義の解析処理中にエラーが発生しました。このメッセージの前後に出力されている定義解析エラーのメッセージを参照して，システム定義のオペランドを見直してください。
PROCESS_MEMORY
プロセス固有メモリが不足しています。プロセス固有メモリを見積もり直してください。
ALREADY_STOPPED
監査証跡の取得は既に中止されています。
DELETE_ERROR
監査証跡ファイルが次に示すどれかの状態であるため，削除できません。
・閉塞していない監査証跡ファイルである
・データロード待ちの監査証跡ファイルである
・まだ生成されていない監査証跡ファイルである
pdls -d audコマンドを実行して，監査証跡ファイルの状態を確認してください。閉塞していないファイル，生成されていないファイルは削除できません。データロード待ちのファイルを削除する場合は，pdaudrmコマンドに-fオプションを指定して実行してください。
NOT_AUDITOR
監査人ではないためこのコマンドを実行できません。環境変数PDUSERに監査人のユーザIDとパスワードが正しく指定されているか確認してください。
UNABLE_SWAP
pd_aud_no_standby_file_opr=downが指定されているため，残りの1ファイルはスワップ先にできません。次に示す対策をしてください。
・データロード待ちの監査証跡ファイルをデータロードするように監査人に連絡してください。
・監査証跡ファイルに障害が発生したときの処置については，マニュアル「HiRDB Version 7 システム運用ガイド」を参照してください。
NO_STANDBY_FILE
スワップ先にできる監査証跡ファイルがないため，スワップできません。次に示す対策をしてください。
・データロード待ちの監査証跡ファイルをデータロードするように監査人に連絡してください。
・監査証跡ファイルに障害が発生したときの処置については，マニュアル「HiRDB Version 7 システム運用ガイド」を参照してください。
NO_GEN_FILE
監査証跡ファイルが一つも作成されていないため，監査証跡ファイルのスワップ処理を行いません。
OTHER_COMMAND
ほかのコマンド（pdaudbegin，pdaudend，pdaudrm，pdaudswap）が実行中のため，コマンドを実行できません。ほかのコマンドが終了した後に再度コマンドを実行してください。
SECURITY_AUDIT_NOT_UP
監査証跡は取得されていません。監査証跡を取得しているときにコマンドを実行してください。
FILE_ACCESS
監査証跡ファイルのアクセス時にエラーが発生しました。このメッセージの前後に出力されているKFPS05704-Eメッセージを参照し，対策してください。
UNIT_NOT_ONLINE
コマンドの対象ユニットは停止中です。ユニットの開始後にコマンドを実行してください。
NO_FILE_NAME
pd_aud_file_nameオペランドが指定されていません。pd_aud_file_nameオペランドを指定してください。
UTILITY
ユティリティ専用ユニットのため，セキュリティ監査機能を使用できません。
ONLY_SYSTEM_MANAGER
ユニット内にシステムマネジャだけしか定義されていないため，セキュリティ監査機能を使用できません。セキュリティ監査機能を使用する場合はシステム構成を変更してください。
NO_SERVER
ユニット内にサーバが定義されていないため，セキュリティ監査機能を使用できません。セキュリティ監査機能を使用する場合はシステム構成を変更してください。
LOCK
コマンド実行時に排他エラーが発生しました。時間を空けてコマンドを再実行してください。
NO_AVAILABLE_GEN_FILE
スワップ先にできる監査証跡ファイルがありません。次に示す処置をして，スワップ先にできる監査証跡ファイルを確保してください。その後，HiRDBを再度開始してください。
・監査人にデータロード待ちのファイルを監査証跡表へデータロードするように連絡してください。
・監査証跡ファイルに障害が発生した場合の処置については，マニュアル「HiRDB Version 7 システム運用ガイド」を参照してください。
RESTORE_MODE
pdstart -rコマンドでHiRDBを開始したため，pdaudswapコマンドを実行できません。
KFPS05801-I
Usage: pdvrchk -x host_name -d directory_name　　（Ｓ）
pdvrchkコマンドのオプションの指定形式に誤りがあります。
(Ｓ)処理を終了します。
[対策]オプションの指定を修正してコマンドを再度実行してください。
KFPS05802-E
Error occurred in execute pdvrchk command, reason_code = aa(bb....bb,cc....cc,dd....dd)　　（Ｓ）
pdvrchkコマンドの実行中にエラーが発生しました。
aa：エラーコード
bb....bb：HiRDBの内部情報
cc....cc：HiRDBの内部情報
dd....dd：HiRDBの内部情報
(Ｓ)処理を終了します。
[対策]エラー要因に対応する対策をしてください。
エラー
コード
エラー要因
対策
01
環境変数PDDIRがありません。
このコマンド実行者の環境に環境変数PDDIRを設定してコマンドを再実行してください。
02
-xオプションに指定したホスト名に対するリモートシェルでエラーが発生しました。次に示す要因が考えられます。
・-dオプションに指定したHiRDB運用ディレクトリがありません。
・-xオプションに指定したホストのネットワークが起動していません。
・-xオプションに指定したホスト名に誤りがあります。
pingの実行結果などによって指定ホストのネットワークが起動していることを確認してください。又は，-dオプションに指定するHiRDB運用ディレクトリ，-xオプションに指定するホスト名が正しいか確認してコマンドを再実行してください。
03
内部処理エラー
このメッセージより前に出力されているメッセージに従って対策した後にコマンドを再実行してください。
KFPS05803-I
pdvrchk ended, return code = aa....aa　　（Ｓ）
pdvrchkコマンドはリターンコードaa....aaで終了しました。
aa....aa：コマンドのリターンコード
(Ｓ)処理を終了します。
[対策]リターンコードに対応する対策をしてください。
リターン
コード
説明
対策
0
コマンド実行元サーバマシンと対象サーバマシン間でのバージョン情報，付加オプション一致
必要ありません。
8
コマンド実行元サーバマシンと対象サーバマシン間でのバージョン情報，付加オプション不一致
HiRDB及びインストールされている付加プログラムプロダクトのバージョンを一致させてください。
・HiRDB Advanced High Availabilityについてはバージョン情報，付加オプション比較元とその対象ユニットの構成によっては不一致と表示されることがあります（システムマネジャのユニットとバックエンドサーバのユニットの比較など）
・HiRDB LDAP Optionについてはバージョンのチェックをしません。
12
コマンド実行時エラー(コマンドの引数誤りを含む)
このメッセージの前に出力されているKFPS05801-I，KFPS05802-Eメッセージなどに従って対策してください。
KFPS05810-I
Usage: pdrisechk [-d {all|db|sys}] [{-u unit_id|-s server_name}]　　（Ｓ）
pdrisechkコマンドのオプションの指定形式に誤りがあります。
(Ｓ)処理を終了します。
[対策]正しいオプションを指定してコマンドを再実行してください。
KFPS05813-E
Unable to execute aa....aa command, reason bb....bb　　（Ｅ）
aa....aaコマンドの実行に失敗しました。
aa....aa：実行できなかったコマンド名
pdrisechk
bb....bb：実行できなかった理由
pd_rise_use is not 'Y'：pd_rise_useオペランドにYが指定されていません。
NEED TO SPECIFY pd_rise_pairvolume_combination：pd_rise_pairvolume_combinationオペランドが指定されていない，又は指定値に誤りがあります。
NEED TO SPECIFY pd_rise_fence_level：pd_rise_fence_levelオペランドが指定されていない，又は指定値に誤りがあります。
(Ｓ)処理を終了します。
[対策]オペランドの指定値を確認して修正した後に，コマンドを再実行してください。
KFPS05815-I
"pdrisechk" ended, end code=aa....aa　　（Ｓ）
pdrisechkコマンドが終了コードaa....aaで終了しました。
aa....aa：コマンドの終了コード
(Ｓ)処理を終了します。
(Ｏ)終了コードの対処方法に従ってください。
[対策]終了コードの対処方法に従ってください。
コマンド終了コード
意味
オペレータの処置
HiRDB管理者の処置
OK
pdrisechkコマンドは正常に終了しました。ペアボリュームの設定に誤りはありません。
－
－
INVALID_PAIR_SETUP
HiRDBが使用するペアボリュームの設定に誤りがありました。
HiRDB管理者に連絡してください。
出力されるKFPS05816-Eメッセージを参照して，誤りがあるペアボリュームの設定を正しく設定してください。
ERROR_SOME_UNIT
pdrisechkコマンドの実行中に，あるユニットの構成確認でエラーが発生しました。
このメッセージ以前に出力されたメッセージを参照して対策を行い，再度コマンドを実行してください。必要に応じて，HiRDB管理者に連絡してください。
このメッセージ以前に出力されたメッセージを参照して対策を行い，再度コマンドを実行してください。
（凡例）－：該当しません。
KFPS05816-E
Invalid volume setup. aa....aa, file type=bb....bb, group=cc....cc, code=dd....dd　　（Ｅ）
ペア論理ボリュームグループcc....ccのペア設定が正しくありません。
aa....aa：ペア設定に問題があるペア論理ボリュームグループに配置されているHiRDBファイル種別によって，次の形式で出力されます。
bb....bbがDB，LOG，SPD，SSTSの場合
server=ee....ee
ee....ee：HiRDBサーバ名称
bb....bbがUSTSの場合
unit=ffff
ffff：ユニットID
bb....bbがALLの場合
system=gggg
gggg：HiRDBシステムID
bb....bb：ペア論理ボリュームグループcc....ccに作成したファイル種別
DB：データベースファイル（RDエリアを構成するファイル）
LOG：システムログファイル
SPD：シンクポイントダンプファイル
SSTS：サーバステータスファイル
USTS：ユニットステータスファイル
ALL：データベースファイル及びシステムファイル
cc....cc：ペア論理ボリュームグループ名称
dd....dd：理由コード
(Ｓ)処理を終了します。
(Ｏ)理由コードの対策に従ってください。
[対策]理由コードの対策に従ってください。
理由コード
意味
HiRDB管理者の処置
INVALID_VOLUME_ATTRIBUTE
該当するペア論理ボリュームグループのペア属性がP-VOLではありません。
コマンドを実行しているホストが，メインサイト側か確認してください。また，ペア論理ボリュームグループを作成していない場合，ペア論理ボリュームグループを作成してください。
INVALID_FENCE_LEVEL
該当するペア論理ボリュームグループのフェンスレベルの設定に誤りがあります。
pd_rise_pairvolume_combinationオペランドの値がsyncの場合は，pd_rise_fence_levelオペランドの値に合わせて，ペア論理ボリュームグループのフェンスレベルにdata又はneverを設定してください。
pd_rise_pairvolume_combinationオペランドの値がhybridで，bb....bbにDBが表示されている場合は，ペア論理ボリュームグループのフェンスレベルにasyncを設定してください。
bb....bbにDB以外が表示されている場合は，pd_rise_fence_levelオペランドの値に合わせて，ペア論理ボリュームグループのフェンスレベルにdata又はneverを設定してください。
pd_rise_pairvolume_combinationオペランドの値がasyncの場合は，ペア論理ボリュームグループのフェンスレベルにasyncを設定してください。
INVALID_STATUS
該当するペア論理ボリュームグループにPAIR，PFULではないペアステータスのペアが存在します。
該当するペア論理ボリュームグループのペアステータスを確認し，そのペアステータスになった原因を調査し，対策してください。原因の調査，対策方法については，RAID Managerのマニュアルを参照してください。
KFPS05821-E
Unable to specify hostname or server name outside HAGROUP　　（Ｅ）
指定したホスト名（ユニット識別子）又はサーバ名は，影響分散スタンバイレス型系切り替え機能を適用したホスト（ユニット）又はサーバではありません。指定したオプションは，影響分散スタンバイレス型系切り替え機能を適用したユニット又はサーバ以外では指定できません。
(Ｓ)処理を終了します。
[対策]指定したホスト名（ユニット識別子）又はサーバ名がHAグループに属しているかを確認してください。
KFPS05822-E
aa....aa invalid; stops server restart.server ID=bb....bb, old value=cc....cc,new value=dd....dd　　（Ｅ）
aa....aaオペランドの指定値を変更したため，サーバを再開始できません。aa....aaオペランドの値は，異常終了，強制終了，又は計画停止後変更できません。
aa....aa：一致していない定義項目
"pd_utl_exec_mode"：ユティリティ実行モード
"pd_max_list_users"：同時リスト所有可能ユーザ数
"pd_max_list_count"：1ユーザ当たりのリスト作成数
"pd_max_reflect_process_count"：更新可能なオンライン再編成追い付き反映処理同時実行可能保証プロセス数
"pd_max_users"：同時実行可能ユーザ数（SDS，FES）
"pd_max_bes_process" or "pd_max_users"：最大起動プロセス数（BES）
"pd_max_dic_process" or "pd_max_users"：最大起動プロセス数（DS）
bb....bb：サーバ名（aa....aaオペランドがシステム共通定義，又はユニット制御情報定義の場合は"********"を表示します）
cc....cc：aa....aaオペランドの変更前の値
dd....dd：aa....aaオペランドの変更後の値
(Ｓ)処理を終了します。
[対策]aa....aaオペランドの値を変更前の値（cc....cc）に戻し，サーバを再開始してください。ただし，次のオペランドのどちらかがaa....aaオペランドに出力されている場合，以下のようにしてください。
・"pd_max_bes_process"，"pd_max_dic_process"，又は"pd_max_users"の場合，pd_max_bes_process又はpd_max_dic_processオペランドを指定していないときは，pd_max_usersの値を変更してください。
・"pd_max_bes_process"，"pd_max_dic_process"，又は"pd_max_users"の場合，pd_max_bes_process又はpd_max_dic_processオペランドを指定しているときは，次のようにしてください。
cc....cc＞pd_max_users指定値の場合
pd_max_bes_process又はpd_max_dic_processオペランドの値を変更してください。
cc....cc≦pd_max_users指定値の場合
・cc....cc＞pd_max_bes_process又はpd_max_dic_processの値のときは，pd_max_usersの値を変更してください。
・cc....cc≦pd_max_bes_process又はpd_max_dic_processの値のときは，pd_max_users，pd_max_bes_process，又はpd_max_dic_processオペランドの値を変更してください。
KFPS05827-E
Unable to stop server outside HAGROUP with "aa....aa" option　　（Ｅ）
影響分散スタンバイレス型系切り替え機能の対象外のサーバに対するpdstop -s server_nameコマンドに，aa....aaオプションは指定できません。
aa....aa：指定したオプション｛-x host_name｜-u unit_id｝-z
(Ｓ)処理を終了します。
[対策]
指定したオプションが-x host_name，又は-u unit_idの場合
コマンドのオプション指定を見直してください。影響分散スタンバイレス型系切り替え機能の対象外のサーバを停止するときは-x host_name，又は-u unit_idオプションを指定しないでコマンドを実行してください。
指定したオプションが-zの場合
コマンドのオプション指定を見直してください。影響分散スタンバイレス型系切り替え機能の対象外のサーバは強制停止できません。停止したい場合は正常停止（システムマネジャがあるユニットでpdstop -s server_nameコマンドを実行）してください。
KFPS05828-E
Unable to stop normally because server terminated abnormally　　（Ｓ）
異常終了，又はpdstop -f，pdstop -zコマンドで強制終了したサーバがあるため，HiRDBを正常終了できません。
(Ｓ)処理を終了します。
[対策]次に示すどちらかの方法でHiRDBを終了してください。
・異常終了，又はpdstop -f，pdstop -zコマンドで強制終了したサーバをpdlsコマンドで確認し，該当するサーバを起動した後にpdstopコマンドで正常終了してください。
・pdstop -fコマンドでHiRDBを強制終了してください。
KFPS05839-I
Usage: pdstjsync　　（Ｅ）
pdstjsyncコマンドのオプション指定形式が誤っています。
(Ｓ)処理を終了します。
(Ｏ)コマンドの使用方法に従って再度実行してください。
KFPS05840-I
Statistics log written, from statistics log buffer to statistics log file　　（Ｓ）
統計ログバッファの情報をログファイルに出力しました。
(Ｓ)処理を続行します。
KFPS05841-E
pdstjsync command failed, readson=a....a　　（Ｅ）
統計ログバッファの情報をログファイルに出力できませんでした。
aa....aa：障害の内容を示す理由コード
ALREADY_STOPPED：統計情報は既に停止しています。
(Ｓ)処理を終了します。
[対策]
ALREADY_STOPPEDの場合：
統計情報取得中にこのコマンドを実行してください。
KFPS05842-I
Usage: pdsvhostname -s server_name [-b]　　（Ｅ）
pdsvhostnameコマンドのオプションの指定形式が誤っています。
(Ｓ)pdsvhostnameコマンドを終了します。
[対策]コマンドの使用方法に誤りがある場合は，正しい使用方法で再度実行してください。
KFPS06001-E
Error occurred in system call aa....aa.errno=bbb　　（Ｌ）
プロセス起動時の初期化処理中に発行したシステムコールでエラーが発生しました。
このメッセージの出力後，KFPS04621-Eメッセージが出力されることがありますが無視してください。
aa....aa：発行したシステムコール名称
bbb：システムコールのリターンコード（errno）
(Ｓ)アボートコードPopt001を出力してこのプロセスを終了します。
(Ｏ)システムコール名称とシステムコールのリターンコードを基にOSのマニュアルで原因を調査してください。
[対策]システムコール名称とリターンコードを基に原因を調査してください。メモリ不足に起因する場合は，必要のないプロセスを停止したり，システムのスワップ領域を増やしたりして空きメモリを増やしてください。メモリ不足以外の要因の場合は保守員に連絡してください。


KFPTメッセージ

KFPT00001-E
aa....aa:system call error, func=bb....bb,errno=cc....cc　　（Ｅ＋Ｌ）
システムコール（関数）でエラーが発生しました。
aa....aa：コマンド名
Pdorcheck：オンライン再編成の適用条件チェック
Pdorcreate：オンライン再編成の追い付き反映環境の作成
Pdrdrefls：関連するRDエリアの情報の表示
Pdorend：オンライン再編成の追い付き反映
bb....bb：エラーが発生したシステムコール名
cc....cc：errnoに設定されたエラー番号
(Ｓ)処理を終了します。
(Ｏ)エラー番号（errno：エラー状態を示す外部変数）を基に，errno.h及び該当する関数の記載されたリファレンスマニュアルを参照して，エラー原因を取り除き，再度コマンドを実行してください。代表的なerrnoについては，「システムコールのリターンコード」を参照してください。
KFPT00002-E
aa....aa:insufficient memory, size=bb....bb　　（Ｅ＋Ｌ）
メモリ不足が発生しました。
aa....aa：コマンド名（KFPT00001-Eの埋め込み文字中のコマンド名を参照してください）
bb....bb：確保しようとしたメモリサイズ（単位：バイト）
(Ｓ)処理を終了します。
(Ｏ)大量にメモリを使用するプロセスがないか確認し，ある場合はプロセスの終了を待ってから再度コマンドを実行してください。ない場合は，HiRDB管理者に連絡してください。
[対策]システムの仮想メモリの容量を見直して，容量が不足している場合はメモリを追加して容量を拡張してください。メモリを追加できない場合は，ほかの常駐プログラムやプロセスを停止するなど，仮想メモリの空きを確保してください。
KFPT00003-E
aa....aa:interface error, func=bb....bb,code=cc....cc　　（Ｅ＋Ｌ）
プログラム内の関数間で，インタフェースエラーが発生しました。
aa....aa：コマンド名（KFPT00001-Eの埋め込み文字中のコマンド名を参照してください）
bb....bb：エラーが発生した関数名
cc....cc：詳細コード
(Ｓ)処理を終了します。
(Ｏ)保守員に連絡してください。
KFPT00004-E
aa....aa:system management function error, func=bb....bb,code=cc....cc　　（Ｅ＋Ｌ）
システム関連エラーが発生しました。
aa....aa：コマンド名（KFPT00001-Eの埋め込み文字中のコマンド名を参照してください）
bb....bb：エラーとなった関数名
cc....cc：エラー詳細コード
(Ｓ)処理を終了します。
(Ｏ)「システム関連エラーの詳細コード」又は「RPC関連エラーの詳細コード」を参照して，エラー原因を取り除き，再度コマンドを実行してください。対処できない場合には，保守員に連絡してください。
KFPT00005-E
aa....aa:SQL error occurred　　（Ｅ＋Ｌ）
SQLエラーが発生しました。
aa....aa：コマンド名（KFPT00001-Eの埋め込み文字中のコマンド名を参照してください）
(Ｓ)処理を終了します。
(Ｏ)直前に出力されたSQL文に関するメッセージを参照して，エラー原因を取り除いてください。SQL文に関するメッセージが出力されていない場合は，保守員に連絡してください。
KFPT00006-E
aa....aa:bb....bb not setup　　（Ｅ＋Ｌ）
bb....bbが組み込まれていないため，コマンドを実行できません。
aa....aa：コマンド名（KFPT00001-Eの埋め込み文字中のコマンド名を参照してください）
bb....bb：オプション名
Staticizer Option：HiRDB Staticizer Option
(Ｓ)処理を終了します。
[対策]bb....bbを組み込んでから，再度コマンドを実行してください。
KFPT00007-E
aa....aa:unable to access to dictionary table, kind=bb....bb,table=cc....cc　　（Ｅ＋Ｌ）
ディクショナリ表に対するアクセスでエラーが発生しました。
aa....aa：コマンド名（KFPT00001-Eの埋め込み文字中のコマンド名を参照してください）
bb....bb：SQLの種別
OPEN：OPENエラー
CLOSE：CLOSEエラー
SELECT：SELECTエラー
PREPARE：PREPAREエラー
FETCH：FETCHエラー
cc....cc：ディクショナリ表の名称
(Ｓ)処理を終了します。
(Ｏ)このメッセージの直前に出力されているKFPAxxxxxメッセージを参照し，メッセージが示すエラー原因を取り除き，再度コマンドを実行してください。KFPAxxxxxメッセージが出力されていない場合は，保守員に連絡してください。
KFPT00008-E
aa....aa:unable to access to reflection management table　　（Ｅ＋Ｌ）
追い付き状態管理表に対するアクセスでエラーが発生しました。
aa....aa：コマンド名（KFPT00001-Eの埋め込み文字中のコマンド名を参照してください）
(Ｓ)処理を終了します。
(Ｏ)このメッセージの直前に出力されているKFPAxxxxxメッセージを参照し，メッセージが示すエラー原因を取り除き，再度コマンドを実行してください。KFPAxxxxxメッセージが出力されていない場合は，保守員に連絡してください。
KFPT00009-E
aa....aa:SQL error occurred during reflection execution, TBLID=bb....bb, kind=cccc,code=dd....dd　　（Ｅ＋Ｌ）
表ID（bb....bb）の追い付き反映処理実行中にSQLエラーが発生しました。
aa....aa：コマンド名（KFPT00001-Eの埋め込み文字中のコマンド名を参照してください）
bb....bb：表ID
cccc：SQLの種別
PREP：PREPAREエラー
EXEC：EXECUTEエラー
dd....dd：内部コード
(Ｓ)処理を終了します。
(Ｏ)このメッセージの直前に出力されているKFPAxxxxxメッセージを参照し，メッセージが示すエラー原因を取り除き，再度コマンドを実行してください。KFPAxxxxxメッセージが出力されていない場合は，保守員に連絡してください。
KFPT00010-E
aa....aa:failed to load library, library name=bb....bb, reason=cc....cc　　（Ｌ）
ライブラリのロードに失敗しました。
aa....aa：コマンド名（KFPT00001-Eの埋め込み文字中のコマンド名を参照してください）
bb....bb：ロードに失敗したライブラリ名
cc....cc：失敗した理由
(Ｓ)処理を終了します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]ライブラリ名がlib_phsgml_rpl，lib_phsgml_rpl64，又はlib_phsgml_rpl_rの場合は，HiRDB Text Search Plug-inが正しくセットアップされているかどうか確認してください。
KFPT00011-E
aa....aa:failed to get procedure address, procedure name=bb....bb, library name=cc....cc, reason=dd....dd　　（Ｌ）
関数アドレスの取得に失敗しました。
aa....aa：コマンド名（KFPT00001-Eの埋め込み文字中のコマンド名を参照してください）
bb....bb：関数名
cc....cc：ライブラリ名
dd....dd：失敗した理由
(Ｓ)処理を終了します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]関数名がget_sgml_indata_exの場合は，HiRDB Text Search Plug-inが正しくセットアップされているかどうか確認してください。
KFPT00012-E
aa....aa:file access error, func=bb....bb,file=cc....cc,errno=dd....dd　　（Ｌ）
ファイルアクセスエラーが発生しました。
aa....aa：コマンド名（KFPT00001-Eの埋め込み文字中のコマンド名を参照してください）
bb....bb：要因（エラーが発生したシステムコール名）
cc....cc：ファイル名
ファイル名が150バイトを超える場合は，末尾から150バイト分を表示します。
dd....dd：errnoに設定されたエラー番号
(Ｓ)処理を終了します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]エラー番号（errno：エラー状態を示す外部変数）を基に，errno.h及び該当する関数の記載されたリファレンスマニュアルを参照して，エラー原因を取り除き，再度コマンドを実行してください。代表的なerrnoについては，「システムコールのリターンコード」を参照してください。
KFPT00013-E
aa....aa:LOCK TABLE failed, table name=bb....bb, lock kind=cc....cc　　（Ｌ）
表bb....bbに対する排他制御に失敗しました。
aa....aa：コマンド名（KFPT00001-Eの埋め込み文字中のコマンド名を参照してください）
bb....bb："認可識別子"."表識別子"
cc....cc：排他制御モード
EXCLUSIVE：排他モード
(Ｓ)処理を終了します。
(Ｏ)このメッセージの直前に出力されているKFPAXXXXXメッセージを参照し，そのメッセージのエラー要因を取り除いて，再度コマンドを実行してください。
KFPT01000-E
aa....aa:insufficient memory in message buffer pool　　（Ｅ＋Ｌ）
メッセージ格納バッファプールの一時的なメモリ不足が発生しました。なお，このエラーの発生に伴い，KFPS00854-Wメッセージが出力されている場合がありますが，サーバ障害ではありません。
aa....aa：コマンド名（KFPT00001-Eの埋め込み文字中のコマンド名を参照してください）
(Ｓ)処理を終了します。
(Ｏ)pdlsコマンド（-d prc）を実行して，ほかのユティリティが動作しているかどうかを確認してください。ほかのユティリティが動作している場合，ほかのユティリティの終了を待ってから再度実行してください。
KFPT01001-E
aa....aa:unable to send message from bb....bb to cc....cc　　（Ｅ＋Ｌ）
送信エラーが発生したため，ホストbb....bbからホストcc....ccへデータを送信できませんでした。
aa....aa：コマンド名（KFPT00001-Eの埋め込み文字中のコマンド名を参照してください）
bb....bb：送信元ホスト名
cc....cc：送信先ホスト名
(Ｓ)処理を終了します。
(Ｏ)このメッセージの前に出力されたKFPT00004-Eメッセージの処置に従ってください。ただし，物理的な通信エラーが発生していない場合は，システム定義でホスト間の関係に矛盾があることが考えられるため，エラーが発生したホスト間の定義を見直し再度実行してください。
KFPT01002-E
aa....aa:invalid log record format exists in system log file, server=bb....bb, file_group=cc....cc, block_number=0xdd....dd, record_number=0xee....ee　　（Ｅ＋Ｌ）
不正なフォーマットのシステムログレコードを検出しました。
aa....aa：コマンド名（KFPT00001-Eの埋め込み文字中のコマンド名を参照してください）
bb....bb：サーバ名
cc....cc：システムログファイルのファイルグループ名
dd....dd：ブロック番号（16進数）
ee....ee：レコード番号（16進数）
(Ｓ)異常終了します。
(Ｏ)保守員に連絡してください。
KFPT01003-E
aa....aa:unable to reflect,because reflect management table initialized　　（Ｅ＋Ｌ）
追い付き状態管理表が初期化されたため，追い付き反映処理が再実行できません。
aa....aa：コマンド名（KFPT00001-Eの埋め込み文字中のコマンド名を参照してください）
(Ｓ)異常終了します。
(Ｏ)バックアップから，正系RDエリアを追い付き反映処理開始直前の状態に回復して，追い付き反映処理を再実行してください。
KFPT01004-I
Pdorend:interrupt request accepted　　（Ｌ）
中断要求を受け付けました。
(Ｓ)処理を続行します。
KFPT01005-E
Pdorend:request for reflect service failed,request=aa....aa,code=bb....bb　　（Ｌ）
反映サービスへの要求が失敗しました。
aa....aa：要求内容（保守情報）
CONNECT：起動要求
CNTLINF：制御情報送信要求
TABLEFRST：表定義情報送信開始要求
TABLENEXT：表定義情報送信継続要求
TABLELAST：表定義情報送信終了要求
DBUPDINF：DB更新要求
COMMIT：COMMIT要求
DISCONNECT：停止要求
bb....bb：応答コード（保守情報）
(Ｓ)処理を終了します。
(Ｏ)このメッセージの直前に出力されているKFPTxxxxx-Eメッセージに従って対処してください。
KFPT01006-E
aa....aa:procedure for obtain ADT input data returned error status, procedure name=bb....bb, information=cc....cc　　（Ｌ）
抽象データ型の入力データ取得関数から，エラーレベルのステータスが返されました。
aa....aa：コマンド名（KFPT00001-Eの埋め込み文字中のコマンド名を参照してください）
bb....bb：エラーが発生した関数名
cc....cc：付加情報
(Ｓ)処理を終了します。
(Ｏ)保守員に連絡してください。
KFPT01007-E
aa....aa:server down detected　　（Ｌ）
サーバの異常終了を検知しました。又は，系切り替えが発生したため，処理を続行できません。
aa....aa：コマンド名（KFPT00001-Eの埋め込み文字中のコマンド名を参照してください）
(Ｓ)処理を終了します。
(Ｐ)既に出力されているエラーメッセージを基に，サーバが異常終了したエラー原因を取り除き，再度コマンドを実行してください。なお，処理中に系切り替えが発生している場合，コマンドを実行するホストからコマンド処理に必要なファイルを参照及び更新できる状態にして，再度実行してください。
KFPT01008-E
Pdorend:error occurred during reflection execution, server=aa....aa,pdorend command process id=bb....bb　　（Ｌ）
サーバaa....aaの追い付き反映処理中にエラーが発生しました。
aa....aa：追い付き反映処理中にエラーが発生したサーバ名
bb....bb：サーバaa....aaの追い付き反映処理を実行したpdorendコマンドのプロセスID
(Ｓ)処理を終了します。
(Ｏ)メッセージログファイル，又はsyslogfile（Windows NTの場合はイベントログ）を参照してください。このメッセージの後に出力されているエラーメッセージ（bb....bbのプロセスIDと同一のプロセスのエラーメッセージ）を基に対処してください。
KFPT01009-I
Pdorend:reflection execution finished, server=aa....aa,pdorend command process id=bb....bb,ins=cc....cc,upd=dd....dd,del=ee....ee,cmt=ff....ff　　（Ｌ）
サーバaa....aaの追い付き処理が終了しました。
aa....aa：追い付き処理対象サーバ名
bb....bb：サーバaa....aaの追い付き処理を実行した更新可能なオンライン再編成データベース追い付き反映コマンド（pdorend）のプロセスID
cc....cc：INSERT行数※
dd....dd：UPDATE行数※
ee....ee：DELETE行数※
ff....ff：反映対象トランザクションcommit回数
注※　更新可能なオンライン再編成運用中に，副系RDエリアに対するアクセスでロールバックが発生した場合，そのトランザクション回復用のDB更新件数も含まれます。
(Ｓ)処理を続行します。
KFPT01010-W
aa....aa:SQL error skip occurred during reflection execution, server=bb....bb, pid=cc....cc　　（Ｌ）
サーバbb....bbの追い付き反映処理中に，スキップ対象のSQLエラーが発生しました。
aa....aa：コマンド名（KFPT00001-Eの埋め込み文字中のコマンド名を参照してください）
bb....bb：追い付き反映処理エラーが発生したサーバ名
cc....cc：プロセスID
(Ｓ)処理を続行します。
[対策]
追い付き反映制御ファイルのreport文のskip_infoオペランドに指定したスキップ情報出力ファイル_bb....bb_cc....ccの内容を参照し，スキップされた更新情報の内容（キー値）を取得してください。取得したキー値から，オリジナルRDエリア及びレプリカRDエリアを検索し，必要に応じてオリジナルRDエリアのデータをレプリカRDエリアの内容に更新してください。
KFPT01011-E
aa....aa:only one "bb....bb" can be specified in reflection control file　　（Ｅ＋Ｌ）
追い付き反映制御ファイルには，bb....bb文を一つだけ指定できます。
aa....aa：コマンド名（KFPT00001-Eの埋め込み文字中のコマンド名を参照してください）
bb....bb：文の名称
(Ｓ)処理を終了します。
[対策]
追い付き反映制御ファイルのbb....bb文の指定を一つにして，再度コマンドを実行してください。
KFPT01012-E
aa....aa:invalid absolute pathname, operand="bb....bb", max length=cc....cc, line=dd....dd　　（Ｅ＋Ｌ）
追い付き反映制御ファイルdd....dd行目に指定したbb....bbオペランドの絶対パス名が，絶対パス名の長さの最大値cc....ccを超えています。
aa....aa：コマンド名（KFPT00001-Eの埋め込み文字中のコマンド名を参照してください）
bb....bb：オペランド名
skip_info：report文のskip_infoオペランド
cc....cc：絶対パス名の最大値
dd....dd：行番号
(Ｓ)処理を終了します。
[対策]
skip_infoオペランドで指定した絶対パス名に，"_サーバ名称"（最大9文字）と"_プロセスID"（最大11文字）を付加した名称でファイルを作成します。メッセージに出力されている絶対パス名の最大値から，上記の"_サーバ名称_プロセスID"の長さの最大長（20文字）を引いた長さ以内に絶対パス名を変更して，再度コマンドを実行してください。
KFPT01013-E
aa....aa:invalid format exists in reflection control file, line=bb....bb, info="cc....cc"　　（Ｅ＋Ｌ）
追い付き反映制御ファイル中のbb....bb行目に指定したcc....ccの形式に誤りがあります。
aa....aa：コマンド名（KFPT00001-Eの埋め込み文字中のコマンド名を参照してください）
bb....bb：行番号
cc....cc：誤りがある文字列（30文字を超える場合は最初の30文字だけ出力）
(Ｓ)処理を終了します。
[対策]cc....ccの内容を修正して，再度コマンドを実行してください。
KFPT01014-E
aa....aa:invalid attribute exists in reflection control file, line=bb....bb, operand="cc....cc"　　（Ｅ＋Ｌ）
追い付き反映制御ファイル中のbb....bb行目に指定したcc....ccオペランドの値に誤りがあります。
aa....aa：コマンド名（KFPT00001-Eの埋め込み文字中のコマンド名を参照してください）
bb....bb：行番号
cc....cc：オペランド名
(Ｓ)処理を終了します。
[対策]cc....ccオペランドの値を修正して，再度コマンドを実行してください。
KFPT01015-E
aa....aa:"bb....bb" statement not specified in reflection control file　　（Ｅ＋Ｌ）
追い付き反映制御ファイルに必要なbb....bb文がありません。
aa....aa：コマンド名（KFPT00001-Eの埋め込み文字中のコマンド名を参照してください）
bb....bb：文の名称
(Ｓ)処理を終了します。
[対策]追い付き反映制御ファイルにbb....bb文を指定して，再度コマンドを実行してください。
KFPT01016-E
aa....aa:SQLWARN occurred. Unable to reflection execution, server=bb....bb, pid=cc....cc, SQLCODE=dd....dd, SQLWARN=ee....ee　　（Ｌ）
サーバbb....bbで追い付き反映処理を続行できないSQLWARNが発生しました。
aa....aa：コマンド名（KFPT00001-Eの埋め込み文字中のコマンド名を参照してください）
bb....bb：追い付き反映処理エラーが発生したサーバ名
cc....cc：プロセスID
dd....dd：SQLCODE
ee....ee：SQLWARN
発生したSQLWARNnのnが出力されます。複数のSQLWARNnが発生した場合は，コンマで区切って出力されます。
(Ｓ)処理を終了します。
[対策]直後に出力されたSQL文のメッセージを参照して，エラー要因を取り除いてください。SQL文に関するメッセージが出力されていない場合は，保守員に連絡してください。
KFPT01017-E
aa....aa:invalid attribute exists in reflection control file, operand="bb....bb", value="cc....cc", reason=dd....dd　　（Ｌ）
追い付き反映制御ファイル中のbb....bbオペランドに指定している値cc....ccに誤りがあります。
aa....aa：コマンド名称（種別は，KFPT00001-Eの埋込み文字中のコマンド名称参照）
bb....bb：オペランド名称
cc....cc：オペランド指定値※
・skip_infoオペランドの場合
オペランドで指定した，スキップ情報出力ファイル名のうちのディレクトリ部の名称
注※　オペランド指定値が100バイトを超える場合は，末尾から100バイト分出力する。
dd....dd：理由コード
Invalid-device：ファイル形式が不正です。
Invalid-permission：ファイルパーミッションが不正です。
No-directory：ディレクトリがありません。
(Ｓ)処理を終了します。
KFPT02000-E
aa....aa:invalid option specified with this command, option=bb　　（Ｅ）
不正なオプションを指定しています。
aa....aa：コマンド名（KFPT00001-Eの埋め込み文字中のコマンド名を参照してください）
bb：不正なオプション
(Ｓ)処理を終了します。
(Ｏ)コマンドラインの指定を修正し，再度実行してください。
KFPT02001-E
aa....aa:invalid combination of option flags (bb and cc) exists in command line　　（Ｅ）
コマンドライン中に，不正な組み合わせのオプションフラグがあります。
aa....aa：コマンド名（KFPT00001-Eの埋め込み文字中のコマンド名を参照してください）
bb：不正な組み合わせのオプションフラグ
cc：不正な組み合わせのオプションフラグ
(Ｓ)処理を終了します。
(Ｏ)コマンドラインの指定を修正し，再度実行してください。
KFPT02002-E
aa....aa:invalid bb option　　（Ｅ）
bbオプションの指定に誤りがあります。
このメッセージは，次のどれかに該当する場合に出力されます。
・指定値がない。
・指定値が制限値を超えている。
・指定値の種類が不当である。
aa....aa：コマンド名（KFPT00001-Eの埋め込み文字中のコマンド名を参照してください）
bb：不正なオプションフラグ
(Ｓ)処理を終了します。
(Ｏ)オプションの指定内容を修正し，再度実行してください。
KFPT02003-E
aa....aa:option flag bb....bb not specified in command line　　（Ｅ）
コマンドライン中に，必要なオプションフラグの指定がありません。
aa....aa：コマンド名（KFPT00001-Eの埋め込み文字中のコマンド名を参照してください）
bb....bb：必要なオプションフラグ
(Ｓ)処理を終了します。
(Ｏ)コマンドラインを修正し，再度実行してください。
KFPT02004-W
aa....aa:no data, RDAREA="bb....bb",server=cc....cc　　（Ｅ）
指定したRDエリア中に，表，インデクス，及びLOBデータがありません。
aa....aa：コマンド名（KFPT00001-Eの埋め込み文字中のコマンド名を参照してください）
bb....bb：RDエリア名
cc....cc：サーバ名
(Ｓ)処理を続行します。
(Ｏ)指定したRDエリア名を確認してください。
KFPT02005-E
aa....aa:not original RDAREA, RDAREA="bb....bb",server=cc....cc　　（Ｅ＋Ｌ）
指定したRDエリアは，オリジナルRDエリアではありません。
aa....aa：コマンド名（KFPT00001-Eの埋め込み文字中のコマンド名を参照してください）
bb....bb：RDエリア名
cc....cc：サーバ名
(Ｓ)処理を終了します。ただし，オンライン再編成の適用条件チェック（pdorcheckコマンド）でこのメッセージが出力された場合，オプションに指定したすべてのRDエリアのチェックが終了するまで処理を続行します。
(Ｏ)オリジナルRDエリアを指定して，再度実行してください。
KFPT02006-E
aa....aa:number of bb....bb exceeds cc....cc　　（Ｅ）
指定したbb....bbの数が，最大値cc....ccを超えました。
aa....aa：コマンド名（KFPT00001-Eの埋め込み文字中のコマンド名を参照してください）
bb....bb：指定値の種別
server names：サーバ名
RDAREA names：RDエリア名
table names：表名
cc....cc：指定できる最大値
(Ｓ)処理を終了します。
(Ｏ)指定したbb....bbの個数を確認して，修正後にコマンドを再実行してください。
KFPT02007-E
aa....aa:error exists in command line　　（Ｅ）
指定したコマンドライン中に，オプションフラグがない不正な指定値があります。
aa....aa：コマンド名（KFPT00001-Eの埋め込み文字中のコマンド名を参照してください）
(Ｓ)処理を終了します。
(Ｏ)このメッセージの後に出力されるコマンドの使用方法を参照して，誤りを修正した後，コマンドを再実行してください。
KFPT02008-E
Pdrdrefls:invalid AUTHID in PDUSER　　（Ｅ＋Ｌ）
環境変数PDUSERに設定している認可識別子が不正です。
このメッセージは，次のどれかに該当する場合に出力されます。
・指定値が制限長を超えている。
・指定値の内容が不正である。
・指定値の文字コードが不正である。
(Ｓ)処理を終了します。
(Ｏ)環境変数PDUSERを修正し，再度コマンドを実行してください。PDUSERについては，マニュアル「HiRDB Version 7 UAP開発ガイド」を参照してください。
KFPT02009-I
Usage: pdrdrefls [-k dsp] -e org {-r RDAREA_name[,RDAREA_name,...]|-t [auth_id.]table_name} [-s server_name[,server_name,...]] [-l [-d separator]] [-a]　　（Ｅ）
pdrdreflsコマンド（-k dsp）の指定形式を示します。このメッセージは，コマンドの指定形式が誤っている場合に出力されます。
(Ｓ)処理を終了します。
(Ｏ)pdrdreflsコマンドの指定形式を修正して，再度実行してください。
KFPT02010-I
Usage: pdrdrefls -k chk -e org -r RDAREA_name[,RDAREA_name,...] [-s server_name[,server_name,...]]　　（Ｅ）
pdrdreflsコマンド（-k chk）の指定形式を示します。このメッセージは，コマンドの指定形式が誤っている場合に出力されます。
(Ｓ)処理を終了します。
(Ｏ)pdrdreflsコマンドの指定形式を修正して，再度実行してください。
KFPT02012-I
Usage: pdorcheck -r RDAREA_name[,RDAREA_name,...]　　（Ｅ）
pdorcheckコマンドの指定形式を示します。このメッセージは，コマンドの指定形式が誤っている場合に出力されます。
(Ｓ)処理を終了します。
(Ｏ)pdorcheckコマンドの指定形式を修正して，再度実行してください。
KFPT02014-I
Pdorcreate terminated, return code=a　　（Ｅ＋Ｌ）
オンライン再編成の追い付き反映環境の作成が終了しました。
a：リターンコード
0：正常終了
8：異常終了
(Ｓ)処理を終了します。
(Ｏ)リターンコード8の場合は，処理中に出力されているEレベルのメッセージを基にエラー原因を取り除き，再度実行してください。
KFPT02015-I
Usage: pdorcreate {[-r RDAREA_name[,RDAREA_name,...]] -o RDAREA_name | -d}　　（Ｅ）
pdorcreateコマンドの指定形式を示します。このメッセージは，コマンドの指定形式が誤っている場合に出力されます。
(Ｓ)処理を終了します。
(Ｏ)pdorcreateコマンドの指定形式を修正して，再度実行してください。
KFPT02016-E
aa....aa:unable to execute Online DB Reorganization, reason=bb....bb,resource kind=cc....cc,name=dd....dd　　（Ｅ＋Ｌ）
更新可能なオンライン再編成を実行できません。
aa....aa：コマンド名（KFPT00001-Eの埋め込み文字中のコマンド名を参照してください）
bb....bb：理由
"invalid datatype"：処理対象外のデータ型が定義されています。
"unique index"：更新可能なオンライン再編成の実行に必要なUNIQUE指定のインデクスが定義されていません。
"invalid RECOVERY type"：LOB列格納用RDエリアの更新ログ取得方式がログ取得モード（ALL）以外で定義されています。
cc....cc：資源種別
table：表
dd....dd：適用条件を満足していない資源名称
資源種別がtableの場合："認可識別子"."表識別子"
(Ｓ)処理を続行します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]HiRDB管理者に連絡してください。
bb....bbが"invalid datatype"の場合：
資源名称で出力されている表の構成列のデータ型を確認し，次のどちらかの対処をしてください。
・資源名称で出力された表を，更新可能なオンライン再編成の対象でない別のRDエリアに定義してください。
・資源名称で出力された表を，すべての構成列が更新可能なオンライン再編成ができるデータ型に変更してください。更新可能なオンライン再編成ができるデータ型については，マニュアル「HiRDB Version 7 コマンドリファレンス」のpdorcheckコマンドを参照してください。
bb....bbが"unique index"の場合：
資源名称で出力されている表に対して，次のどちらかの対処をしてください。
・次のどれかのインデクスを定義してください。
・定義長が256バイト以上のVARCHAR，及びMVARCHAR，並びに定義長が128文字以上のNVARCHARの列を構成列に含まない主キーインデクス
・定義長が256バイト以上のVARCHAR，及びMVARCHAR，並びに定義長が128文字以上のNVARCHARの列を構成列に含まないPRIMARY指定のクラスタキーインデクス
・定義長が256バイト以上のVARCHAR，及びMVARCHAR，並びに定義長が128文字以上のNVARCHARの列を構成列に含まないUNIQUE指定のクラスタキーインデクス
・構成列がすべてNOT NULL属性で，定義長が256バイト以上のVARCHAR，及びMVARCHAR，並びに定義長が128文字以上のNVARCHARの列を構成列に含まないUNIQUE指定のインデクス
・資源名称で出力された表を，更新可能なオンライン再編成の対象でない別のRDエリアに定義してください。
bb....bbが"invalid RECOVERY type"の場合：
資源名称で出力されている表の構成列のデータ型を確認し，次のどちらかの対処をしてください。
・資源名称で出力された表を，更新可能なオンライン再編成の対象でない別のRDエリアに定義してください。
・資源名称で出力された表に対してDROP TABLEを実行して，ユーザLOB用RDエリアに定義したすべての列の列回復制約をALLにして，表を再定義してください。
KFPT02017-E
aa....aa:invalid execution node　　（Ｅ＋Ｌ）
コマンドaa....aaを実行しようとしたサーバマシンが不正です。
aa....aa：コマンド名（KFPT00001-Eの埋め込み文字中のコマンド名を参照してください）
(Ｓ)処理を終了します。
(Ｏ)HiRDB/シングルサーバの場合はシングルサーバがあるサーバマシン，HiRDB/パラレルサーバの場合はシステムマネジャがあるサーバマシンからコマンドを実行してください。
KFPT02018-W
Pdorcreate:reflection management table already aaaaaaa　　（Ｅ＋Ｌ）
・aaaaaaaがcreatedの場合
追い付き状態管理表は既に作成されています。
・aaaaaaaがdroppedの場合
追い付き状態管理表は既に削除されています。又は，作成されていません。
aaaaaaa：状態種別
created：作成済み
dropped：削除済み，又は未作成
(Ｓ)処理を終了します。
KFPT02019-E
aa....aa:specified value not found in system, bb....bb=cc....cc　　（Ｅ＋Ｌ）
指定した名称bb....bbは，HiRDBにはありません。bb....bbがtableの場合は，別名で定義された表の可能性があります。
aa....aa：コマンド名（KFPT00001-Eの埋め込み文字中のコマンド名を参照してください）
bb....bb：cc....ccの種別
server：サーバ
RDAREA：RDエリア
table：表
cc....cc：指定した名称（サーバ名以外は，引用符（"）で囲んで表示）
(Ｓ)処理を終了します。オンライン再編成の適用条件チェック（pdorcheckコマンド）でこのメッセージが出力された場合，オプションに指定したすべてのRDエリアのチェックが終了するまで処理を続行します。
(Ｏ)指定した名称がHiRDBにあるかどうかを確認し，正しい名称を指定して再度コマンドを実行してください。
KFPT02020-I
Pdorcreate:reflection management table aaaaaaa　　（Ｅ＋Ｌ）
追い付き状態管理表の作成処理，又は削除処理が完了しました。
aaaaaaa：状態種別
created：作成済み
dropped：削除済み
(Ｓ)処理を続行します。
KFPT02021-E
aa....aa:invalid RDAREA type, name="bb....bb"　　（Ｅ＋Ｌ）
RDエリアbb....bbは，ユーザ用RDエリア又はユーザLOB用RDエリアではありません。
aa....aa：コマンド名（KFPT00001-Eの埋め込み文字中のコマンド名を参照してください）
bb....bb：RDエリア名
(Ｓ)処理を終了します。オンライン再編成の適用条件チェック（pdorcheckコマンド）でこのメッセージが出力された場合，オプションに指定したすべてのRDエリアのチェックが終了するまで処理を続行します。
(Ｏ)指定したRDエリア名を確認し，正しい名称を指定して再度コマンドを実行してください。
KFPT02022-I
Pdorcheck:all resources conformed to Online DB Reorganization　　（Ｅ＋Ｌ）
指定したRDエリア内のすべての資源が，更新可能なオンライン再編成の適応対象となりました。
(Ｓ)処理を続行します。
KFPT02023-W
Pdorcreate:unable to delete environment of Online DB Reorganization, reason=aa....aa,server=bb....bb　　（Ｅ＋Ｌ）
オンライン再編成の追い付き反映環境の削除ができません。
aa....aa：理由
EXECUTING ORG：更新可能なオンライン再編成を実行中のサーバがあります。
bb....bb：サーバ名
(Ｓ)処理を続行します。
(Ｏ)pddblsコマンドを実行し，bb....bbで出力されたサーバに定義されているすべてのRDエリアのステータスを確認してください。その後，直後に出力される対話入力メッセージ（KFPT02024-Q）に対して次のどちらかを応答してください。
・オンライン再編成閉塞のRDエリアがある場合
対話入力に'n'を応答し，更新可能なオンライン再編成が終了してから，再度コマンドを実行してください。
・オンライン再編成閉塞のRDエリアがない場合
対話入力に'y'を応答し，削除処理を続行してください。
KFPT02024-Q
Pdorcreate:command will delete environment of Online DB Reorganization by force.If RDAREA in Online DB Reorganization hold status exists,delete operation may destroy DB.Do you really want to proceed?(y/n)　　（Ｅ＋Ｌ）
更新可能なオンライン再編成の実行環境を，強制的に削除するかどうかの応答メッセージです。
なお，オンライン再編成閉塞のRDエリアがある場合に'y'を指定すると，DBを破壊する可能性があるため注意してください。
(Ｓ)'y'を応答した場合，処理を続行します。'n'を応答した場合，又は'y'，'n'以外を応答した場合は，処理を終了します。
(Ｏ)このメッセージの直前に出力されている，KFPT02023-Wメッセージのサーバに属するすべてのRDエリアのステータスが，オンライン再編成閉塞であるかどうかを確認してください。
すべてのRDエリアがオンライン再編成閉塞でない場合は，'y'を応答してください。オンライン再編成閉塞のRDエリアがある場合は，'n'を応答してください。
RDエリアのステータスは，pddblsコマンドで確認できます。
KFPT02025-E
Pdorcreate:plural RDAREAs defined for same server specified, server=aa....aa, RDAREA="bb....bb" and "cc....cc"　　（Ｅ＋Ｌ）
同一サーバにあるRDエリアを複数指定しました。
aa....aa：サーバ名
bb....bb：サーバaa....aaにあるRDエリア名
cc....cc：サーバaa....aaにあるRDエリア名
(Ｓ)処理を終了します。
(Ｏ)指定したRDエリアaa....aa，又はbb....bbのどちらかを，-rオプションの指定から外して，再度コマンドを実行してください。
KFPT02026-I
Pdorcreate:dropping reflection management table canceled　　（Ｅ＋Ｌ）
追い付き状態管理表の削除をキャンセルしました。
(Ｓ)処理を続行します。
KFPT02027-E
aa....aa:replicated RDAREA not defined, name="bb....bb"　　（Ｅ＋Ｌ）
RDエリアbb....bbに，レプリカRDエリアが定義されていません。
aa....aa：コマンド名（KFPT00001-Eの埋め込み文字中のコマンド名を参照してください）
bb....bb：RDエリア名
(Ｓ)処理を終了します。オンライン再編成の適用条件チェック（pdorcheckコマンド）でこのメッセージが出力された場合，オプションに指定したすべてのRDエリアのチェックが終了するまで処理を続行します。
(Ｏ)RDエリアbb....bbにレプリカRDエリアを定義して，再度コマンドを実行してください。
KFPT02028-W
Pdrdrefls:insufficient specification of RDAREA about relation, relation kind=aaa, required RDAREA name="bb....bb"　　（Ｅ）
aaaで示す関連性について，RDエリアの指定が不足しています。
aaa：関連種別
org：更新可能なオンライン再編成での関連
bb....bb：指定したRDエリア名
(Ｓ)処理を終了します。
(Ｏ)このメッセージで出力されたRDエリア名を追加して，再度コマンドを実行してください。又は，pdrdrefls -k dspコマンドを実行し，関連資源を確認してください。
KFPT02029-W
Pdrdrefls:all specified RDAREAs unsatisfied condition of aa option　　（Ｅ）
指定したすべてのRDエリアが，aaオプションの条件を満たしていません。
aa：条件のオプション名
-s：サーバ名
(Ｓ)処理を続行します。
(Ｏ)aaオプションの指定内容，及びオプションで指定したRDエリアの内容を確認し，修正した後に再度コマンドを実行してください。
KFPT02030-W
Pdrdrefls:all table RDAREAs of specified table unsatisfied condition of aa option　　（Ｅ）
指定した表のすべての表格納用RDエリアが，aaオプションの条件を満たしていません。
aa：条件のオプション名
-s：サーバ名
(Ｓ)処理を続行します。
(Ｏ)aaオプションの指定内容，及びオプションで指定した表が格納されているRDエリアの内容を確認し，修正した後に再度コマンドを実行してください。
KFPT02031-E
Pdrdrefls:RDAREA unsatisfied condition of option aa specified, RDAREA=bb....bb　　（Ｅ＋Ｌ）
オプションaaで指定したRDエリアは，条件を満たしていません。
aa：条件のオプション名
-s：サーバ名
bb....bb：条件を満たしていないRDエリア名
(Ｓ)オプションで指定したすべてのRDエリアについて，aaオプションでのコマンド実行可否の確認をした後，処理を終了します。
(Ｏ)aaオプションの指定内容，及びオプションで指定したRDエリアの内容を確認し，修正した後に再度コマンドを実行してください。
KFPT02032-E
aa....aa:not available without specification of bb....bb operand　　（Ｅ）
システム定義にbb....bbオペランドが定義されていないため，コマンドaa....aaが実行できません。
aa....aa：コマンド名
Pdorcreate：オンライン再編成の追い付き反映環境の作成
Pdorcheck：オンライン再編成の適用条件チェック
bb....bb：システム定義のオペランド
pd_inner_replica_control：インナレプリカ最大グループ数
pd_max_reflect_process_count：追い付き反映処理時に確保するプロセス数
(Ｓ)処理を終了します。
(Ｏ)HiRDBを終了して，システム定義のオペランドを追加してから，HiRDBを開始してください。その後，コマンドを再度実行してください。


KFPUメッセージ

KFPU00200-E
Invalid option is specified with this command　　（Ｅ）
該当するコマンドでは指定できないオプションを指定しています。又は，オプションの引数が指定されていません。
(Ｓ)コマンド処理を中止します。
(Ｏ)正しいオプションを指定するか，又はオプションの引数を指定して，再度コマンドを実行してください。
KFPU00201-E
Number of command arguments or options exceeds the limit　　（Ｅ）
オプションの数を32個以下にするか，又はコマンド引数の数を64個以下にしてください。
(Ｓ)コマンド処理を中止します。
(Ｏ)コマンド引数，又はオプションの数を許容範囲以内にして，再度実行してください。
KFPU00202-E
Length of command arguments or option arguments exceeds the limit　　（Ｅ）
コマンド引数の合計長を4,096文字以下にするか，又はオプション引数の合計長を4,096文字以下にしてください。
(Ｓ)コマンド処理を中止します。
(Ｏ)正しい文字長を指定して，再度実行してください。
KFPU00210-W
Argument bb....bb of aa....aa function incorrect　　（Ｅ＋Ｌ）
aa....aa関数の引数bb....bbの指定値が正しくありません。
aa....aa：
pdi_umt_malloc：モジュールトレースバッファ割り当て要求
pdi_urt_open：RPCトレース用バッファオープン要求
pdi_uat_malloc：UAPトレースバッファ割り当て要求
bb....bb：
trnum：モジュールトレース，又はUAPトレースの格納可能最大数
file：RPCトレース用ファイル名
size：RPCトレース用ファイルの切り替えサイズ
flags：RPCトレース用ファイルのオープン時の属性
(Ｓ)トレースを取得しないで処理を続行します。
(Ｐ)HiRDBが正しく組み込まれているか確認してください。
KFPU00211-W
Function aa....aa already issued　　（Ｅ＋Ｌ）
aa....aa関数は既に発行されています。
aa....aa：
pdi_umt_malloc：モジュールトレースバッファ割り当て要求
pdi_urt_open：RPCトレース用ファイルオープン要求
(Ｓ)処理を続行します。
KFPU00212-W
Unable to perform tracing due to buffer allocation for aa....aa failed. process ID=bb....bb, buffer size=cc....cc　　（Ｅ＋Ｌ）
aa....aa用のバッファがプロセス固有領域に確保できなかったので，トレースは取得されません。
aa....aa：処理内容
MODULE TRACE：モジュールのトレース
UAP TRACE：UAPのトレース
bb....bb：バッファが確保できなかったプロセスID
cc....cc：確保しようとしたバッファのサイズ
(Ｓ)トレースを取得しないで処理を続行します。
(Ｐ)トレースを取得する必要がなければ，そのまま処理を続行してください。トレースを取得する必要がある場合は，該当するプロセスを終了させ，トレース用バッファのサイズを見直してください。
KFPU00215-E
Unable to open analysis file. analysis file=aa....aa, errno=bbb　　（Ｅ＋Ｌ）
定義情報を解析するために使用する解析ファイルがオープンできません。
aa....aa：解析ファイル名
bbb：エラー番号（errno）
なお，エラー番号が0の場合は，パス名の記述に誤りがあります。
(Ｓ)定義ファイル解析処理を中止します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]障害を取り除いた後，再度HiRDBを開始してください。
KFPU00216-E
Incorrect variable. file=aa....aa, line=bb....bb, variable=cc....cc　　（Ｅ＋Ｌ）
定義ファイルに記述されている変数の指定値に誤りがあります。
aa....aa：定義ファイル名
bb....bb：エラーが発生した行
cc....cc：変数名
(Ｓ)エラーが発生した定義情報の解析処理を中止します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]該当する変数名の記述形式を確認した後，指定値を訂正してください。
KFPU00217-E
Command name invalid. file=aa....aa, line=bb....bb, command=cc....cc　　（Ｅ＋Ｌ）
定義ファイルに記述されているコマンドが解析できません。
aa....aa：定義ファイル名
bb....bb：エラーが発生した行
cc....cc：コマンド名
(Ｓ)エラーが発生した定義情報の解析処理を中止します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]該当するコマンド名の記述形式を確認した後，コマンド名を訂正してください。
KFPU00218-E
Option name in definition file invalid. file=aa....aa, line=bb....bb, option=cc....cc　　（Ｅ＋Ｌ）
定義ファイルに記述されているオプション名に誤りがあります。
aa....aa：定義ファイル名
bb....bb：エラーが発生した行
cc....cc：オプション名
(Ｓ)エラーが発生した定義情報の解析処理を中止します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]該当するオプション名の記述形式を確認した後，オプション名を訂正してください。
KFPU00219-E
Command argument invalid. file=aa....aa, line=bb....bb, command=cc....cc　　（Ｅ＋Ｌ）
コマンドの引数に誤りがあります。
aa....aa：定義ファイル名
bb....bb：エラーが発生した行
cc....cc：コマンド名
(Ｓ)エラーが発生した定義情報の解析処理を中止します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]該当するコマンドの記述形式を確認した後，引数を訂正してください。
KFPU00220-E
Option argument invalid. file=aa....aa, line=bb....bb, option=cc....cc　　（Ｅ＋Ｌ）
オプションの引数に誤りがあります。
aa....aa：定義ファイル名
bb....bb：エラーが発生した行
cc....cc：オプション名
(Ｓ)エラーが発生した定義情報の解析処理を中止します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]該当するオプションの記述形式を確認した後，引数を訂正してください。
KFPU00221-E
Unable to analyze definition file due to insufficient memory. memory requirement=aa....aa　　（Ｅ＋Ｌ）
定義ファイルの解析処理で，メモリが不足しました。
aa....aa：エラーが発生した際の要求メモリ量
(Ｓ)定義ファイルの解析処理を中止します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]システムの許容する最大プロセスサイズを超えない範囲で，プロセスサイズを変更し，再度HiRDBを開始してください。
KFPU00222-E
Number of nests in definition file exceeds the limit. file=aa....aa, line=bb....bb　　（Ｅ＋Ｌ）
定義ファイルのネスト回数が最大ネスト回数を超えました。
aa....aa：定義ファイル名
bb....bb：エラーが発生した行
(Ｓ)エラーが発生した定義情報の解析処理を中止します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]includeコマンドの使用状況を確認した後，ネスト回数が5を超えないように，定義ファイルを訂正してください。
KFPU00223-E
Option aa....aa specified twice. file=bb....bb, line=cc....cc　　（Ｅ＋Ｌ）
オプションの指定が重複しています。
aa....aa：定義ファイル名
bb....bb：エラーが発生した行
cc....cc：オプション名
(Ｓ)エラーが発生した定義情報の解析処理を中止します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]該当するオプションの記述形式を確認した後，同一オプションを二つ以上指定している場合は，どちらか一方を削除してください。
KFPU00224-E
Error occurred in system call (function) aa....aa. errno=bb....bb, function (command) name= cc....cc　　（Ｅ）
プログラム内で発行したシステムコール，又はHiRDBで使用できる関数がエラーとなりました。
aa....aa：発行したシステムコール名，又はHiRDBで使用できる関数名
bb....bb：システムコール，又は関数のリターンコード
cc....cc：エラーの発生したHiRDB関数名，又はコマンド名
(Ｓ)処理を中断してコール元に制御を戻します。
(Ｏ)リターンコードを参照して原因を調査してください。モジュールトレース，又はコアファイルを出力してください。
[対策]リターン情報を参照して原因を調査し，プログラムの修正，又はシステム定義を変更してください。
KFPU00240-E
Unable to set environmental variable. file=aa....aa, line=bb....bb　　（Ｅ＋Ｌ）
環境変数の設定に記述されている変数の指定値に誤りがあります。
aa....aa：ファイル名
bb....bb：エラーが発生した行
(Ｓ)エラーが発生した定義情報の解析処理を中止します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]システム共通定義のputenv形式のオペランドを確認した後，環境変数値を訂正してください。
KFPU00241-E
I/O error occurred. file=aa....aa　　（Ｅ＋Ｌ）
定義情報を解析するために使用する定義ファイル及び解析ファイルの読み出しでエラーが発生しました。
aa....aa：ファイル名
(Ｓ)定義ファイル解析処理を中止します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]障害を取り除き，再度HiRDBを開始してください。
KFPU00242-E
Unable to open definition file. definition file=aa....aa, errno=bbb　　（Ｅ＋Ｌ）
定義ファイルをオープンできません。
aa....aa：定義情報ファイル名
bbb：エラー番号（errno）
なお，エラー番号が0の場合は，絶対パス名の記述に誤りがあります。
(Ｓ)エラーが発生した定義ファイルの解析処理を中止します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]該当するファイル名の記述形式を確認した後，ファイル名及び絶対パス名を訂正してください。
KFPU00243-E
Record length exceeds the limit. file=aa....aa, line=bb....bb　　（Ｅ＋Ｌ）
定義情報のレコード長が，最大レコード長（80バイト）を超えています。
aa....aa：ファイル名
bb....bb：エラーが発生した行
(Ｓ)エラーが発生した定義情報の解析処理を中止します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]該当する定義情報の記述形式を確認した後，80バイト以内に収まるように訂正してください。又は，継続する行に分けて記述してください。
KFPU00244-E
Variable name specified wrong. file=aa....aa, line=bb....bb　　（Ｅ＋Ｌ）
指定された変数に次の誤りがあり，解析できません。
・変数名の記述がありません
・指定された変数名に誤りがあります
aa....aa：ファイル名
bb....bb：エラーが発生した行
(Ｓ)エラーが発生した定義情報の解析処理を中止します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]変数名を正しく指定してください。又は，定義ファイルと定義内容の関係が正しいか見直してください。
KFPU00245-E
Unable to open definition file specified with include. file=aa....aa, line=bb....bb, definition file=cc....cc, errno=ddd　　（Ｅ＋Ｌ）
includeで指定された定義ファイルをオープンできません。
aa....aa：ファイル名
bb....bb：エラーが発生した行
cc....cc：定義ファイル名
ddd：エラー番号（errno）
なお，エラー番号が0の場合は，絶対パス名の記述に誤りがあります。
(Ｓ)エラーが発生した定義情報の解析処理を中止します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]該当するファイル名の記述形式を確認した後，ファイル名，及び絶対パス名を訂正してください。
KFPU00246-E
Definition aa....aa described wrong. file=bb....bb, line=cc....cc　　（Ｅ＋Ｌ）
aa....aaの記述形式に誤りがあります。
aa....aa：エラーが発生した定義名（set，putenvなど）
bb....bb：ファイル名
cc....cc：エラーが発生した行
(Ｓ)エラーが発生した定義情報の解析処理を中止します。
(Ｏ)HiRDB管理者に連絡してください。
[対策]該当する定義情報の記述形式を確認した後，訂正してください。
KFPU00247-E
Command name aa....aa invalid　　（Ｅ＋Ｌ）
コマンド名に誤りがあります。
aa....aa：コマンド名
(Ｓ)エラーが発生したコマンド処理を中止します。
(Ｏ)エラーが発生したコマンドのコマンド名を確認した後，コマンド名を訂正し，再度実行してください。
KFPU00248-E
Option name in aa....aa command invalid　　（Ｅ＋Ｌ）
オプション名に誤りがあります。
aa....aa：コマンド名
(Ｓ)エラーが発生したコマンド処理を中止します。
(Ｏ)エラーが発生したコマンドのオプション名を確認した後，オプション名を訂正し，再度実行してください。
KFPU00249-E
Command argument invalid. command=aa....aa　　（Ｅ＋Ｌ）
コマンドの引数に誤りがあります。
aa....aa：コマンド名
(Ｓ)エラーが発生したコマンド処理を中止します。
(Ｏ)エラーが発生したコマンドの引数を確認した後，引数を訂正し再度実行してください。
KFPU00250-E
Option argument invalid. option=aa....aa　　（Ｅ＋Ｌ）
オプションの引数に誤りがあります。
aa....aa：オプション名
(Ｓ)エラーが発生したコマンド処理を中止します。
(Ｏ)エラーが発生したコマンドのオプションの引数を確認した後，引数を訂正し再度実行してください。
KFPU00251-E
Option specified twice. command=aa....aa　　（Ｅ＋Ｌ）
オプションの指定が重複しています。
aa....aa：コマンド名
(Ｓ)エラーが発生したコマンド処理を中止します。
(Ｏ)エラーが発生したコマンドのオプションを確認した後，同一オプションが二つ以上指定されている場合は，どちらか一方を削除し，再度実行してください。
KFPU00252-E
Unable to analyze definition file due to PDDIR not specified, user=aa...aa　　（Ｅ）
環境変数PDDIRが設定されていないため，定義ファイルの解析処理ができません。
aa....aa：処理を実行したログインユーザ名
(Ｓ)処理を終了します。
(Ｏ)処理を実行したユーザのログインシェル環境に環境変数PDDIRが設定されているかどうかを見直してください。コマンドの実行に失敗した場合は，環境変数PDDIRを設定して再度実行してください。


KFPWメッセージ

KFPW00001-W
Not found External Data Access Adapter　　（Ｅ＋Ｌ）
HiRDB External Data Access Adapterがセットアップされていないため，HiRDB External Data Access機能は使用できません。
(Ｓ)処理を続行します。
[対策]HiRDB External Data Access機能を使用する場合は，HiRDB External Data Access Adapterをセットアップしてください。
KFPW00002-E
External Data Access Adapter version invalid, External Data Access Adapter=aa....aa version=bbbb
HiRDB External Data Access Adapterのバージョンが，HiRDB External Data Access機能が前提としているバージョンではありません。
aa....aa：HiRDB External Data Access Adapter名
bbbb：HiRDB External Data Access Adapterのバージョン
(Ｓ)処理を終了します。
[対策]エラーとなったHiRDB External Data Access Adapterをアンセットアップし，HiRDB External Data Access機能が前提としているバージョンのHiRDB External Data Access Adapterをセットアップしてください。HiRDB External Data Access機能が前提としているバージョンについては，マニュアル「HiRDB External Data Access Version 7」を参照してください。
KFPW00003-W
No user mapping is specified for aa....aa foreign server　　（Ｌ）
ユーザマッピングが定義されていないため，外部サーバにアクセスできません。
aa....aa：外部サーバ名
(Ｓ)処理を続行します。
[対策]CREATE USER MAPPINGでユーザマッピングを定義した後，HiRDBを再開始してください。
KFPW00004-E
Specified foreign server conflicts with External Data Access Adapter, name=aa....aa type=bb....bb version=cc....cc　　（Ｌ）
指定した外部サーバに対応するHiRDB External Data Access Adapterがありません。
aa....aa：外部サーバ名
bb....bb：外部サーバ種別
cc....cc：外部サーバのサーババージョン及びリビジョン
(Ｓ)異常終了します。
[対策]bb....bb，cc....ccに対応するHiRDB External Data Access Adapterをインストールしセットアップした後に，HiRDBを再開始してください。
KFPW02501-E
System error, func="aa....aa" code=bb....bb information=(cc....cc,dd....dd)　　（Ｌ）
HiRDBの関数でエラーが発生しました。
aa....aa：関数名
bb....bb：エラーコード
cc....cc：保守情報1
dd....dd：保守情報2
(Ｓ)異常終了します。
[対策]「システム関連エラーの詳細コード」を参照し，エラーの要因を取り除いて，再度実行してください。なお，エラーの要因が特定できない場合は，保守員に連絡してください。
KFPW02502-E
System call error occurred, func="aa....aa" errno=bb....bb information=(cc....cc,dd....dd)　　（Ｌ）
システムコール中にエラーが発生しました。
aa....aa：システムコール名
bb....bb：エラーコード（エラーの状態を表す外部整数変数）
cc....cc：保守情報1
dd....dd：保守情報2
(Ｓ)異常終了します。
[対策]次に示すどちらかの対策をしてください。
・システムコール名がshl_loadでエラーコードが2の場合
pd_foreign_server_libpathオペランドを正しく指定していない可能性があります。HiRDB External Data Access Adapterに対応する外部サーバのクライアントライブラリのパス名をpd_foreign_server_libpathオペランドに指定してください。その後，HiRDBを再開始してください。
・上記以外の場合
エラーコードをerrno.h又は該当する関数の記載されたマニュアルを参照してエラーの要因を取り除いてください。その後，HiRDBを再開始してください。
KFPW02503-I
aa....aa　　（Ｌ）
システムコールで発生したエラー情報を出力します。
OSのシステムログ機能が日本語文字コードに対応していない場合，メッセージがシステムログに正しく出力されないことがあります。この場合，HiRDBのメッセージログを参照してください。
aa....aa：エラー情報
(Ｓ)処理を続行します。
KFPW02504-E
System call error occurred, func="aa....aa" information=(bb....bb,cc....cc)　　（Ｌ）
システムコール中にエラーが発生しました。
aa....aa：システムコール名
bb....bb：保守情報1
cc....cc：保守情報2
(Ｓ)処理を続行します。
[対策]このメッセージの前に出力されたKFPW02503-Iを参照しエラーの要因を取り除いて，HiRDBを再開始してください。
KFPW05001-E
Incorrect definition variable, definition file=aa....aa definition variable=bb....bb　　（Ｌ）
外部サーバ情報定義のオペランドの指定値に誤りがあります。
aa....aa：外部サーバ情報定義ファイル名（外部サーバ名）
bb....bb：誤りがあるオペランド名
(Ｓ)異常終了します。
[対策]誤りがあるオペランドを修正した後に，HiRDBを再開始してください。
KFPW05002-E
The aa....aa definition variable must be specified, definition file=bb....bb type=cc....cc　　（Ｌ）
外部サーバ情報定義が作成されていません。
aa....aa：外部サーバ情報定義名
bb....bb：外部サーバ情報定義ファイル名（外部サーバ名）
cc....cc：外部サーバの種別
(Ｓ)処理を終了します。
[対策]外部サーバ情報定義を作成した後にHiRDBを再度開始してください。
KFPW05003-E
Insufficient shared memory for foreign server definition, file=aa....aa　　（Ｌ）
putenv形式の外部サーバ情報定義を格納する領域が不足しました。
aa....aa：外部サーバ情報定義ファイル名（外部サーバ名）
(Ｓ)異常終了します。
[対策]外部サーバ情報定義ファイルに，マニュアルに記載されていないputenv形式のオペランドがあります。マニュアルに記載されていないputenv形式のオペランドを削除した後に，HiRDBを再開始してください。
KFPW05004-W
The specified environment variable is invalid, variable=aa....aa definition file=bb....bb type=cc....cc　　（Ｌ）
指定したクライアント環境定義のオペランドは外部サーバ情報定義ファイルに指定しても無効になります。指定したオペランドは外部サーバに対して固定の値か，又は自HiRDBの指定値を適用します。
aa....aa：クライアント環境定義のオペランド名
bb....bb：外部サーバ情報定義ファイル名（外部サーバ名）
cc....cc：外部サーバの種別
(Ｓ)処理を続行します。
[対策]外部サーバ情報定義からaa....aaオペランドを削除してください。
KFPW05010-E
Server aa....aa termination failed　　（Ｌ）
サーバの停止処理時，エラーが発生しました。
aa....aa：サーバ名
(Ｓ)異常終了します。
[対策]このメッセージの前に出力されているKFPW02501-Eメッセージを基にエラー要因を取り除いて，HiRDBを再開始してください。
KFPW05030-E
Insufficient memory on PROCESS, size=aa....aa　　（Ｌ）
HiRDBサーバの開始時に，プロセス固有領域のメモリが不足しました。
aa....aa：確保しようとした領域サイズ（単位：バイト）
(Ｓ)異常終了します。
[対策]プロセス数などを見直して，HiRDBを再開始してください。又は，スワップ領域を大きくしてください。
KFPW05031-E
HiRDB System "aa....aa" failed, return code=bb....bb　　（Ｌ）
システムマネジャの機能aa....aaを実行するときに，リターンコードbb....bbで終了しました。
aa....aa：HiRDBの機能
bb....bb：リターンコード
(Ｓ)異常終了します。
[対策]「システム関連エラーの詳細コード」を参照し，エラーの要因を取り除いて，再度実行してください。なお，エラーの要因が特定できない場合は，保守員に連絡してください。
KFPW05032-E
Work file "aa....aa" failed, return code=bb....bb file=cc....cc　　（Ｌ）
作業用ファイルcc....ccに対するaa....aaがリターンコードbb....bbで終了しました。
aa....aa：HiRDBファイルシステムの機能
｛open | close | lseek | read | write｝
bb....bb：リターンコード
cc....cc：作業用ファイル名
(Ｓ)異常終了します。
[対策]「システム関連エラーの詳細コード」を参照し，エラーの要因を取り除いて，再度実行してください。なお，エラーの要因が特定できない場合は，保守員に連絡してください。
KFPW05033-E
System error, func "aa....aa", code=bb....bb　　（Ｌ）
HiRDB関数でエラーが発生しました。
aa....aa：HiRDB関数名
bb....bb：エラーコード
(Ｓ)異常終了します。
[対策]「システム関連エラーの詳細コード」を参照し，エラーの要因を取り除いて，再度実行してください。なお，エラーの要因が特定できない場合は，保守員に連絡してください。
KFPW05034-E
Server aa....aa initialization failed, function=bb....bb, return code=cc....cc　　（Ｌ）
サーバ開始時に，bb....bbでリターンコードcc....ccのエラーが発生しました。
aa....aa：サーバ名
bb....bb：エラーの発生した関数
cc....cc：リターンコード
(Ｓ)異常終了します。
[対策]このメッセージの前に出力されているメッセージの内容からエラー要因を取り除いて，HiRDBを再開始してください。
KFPW05035-E
System call error occurred, func="aa....aa", errno=bb....bb　　（Ｌ）
システムコール中にエラーが発生しました。
aa....aa：システムコール名
システムコールを特定できない場合は****を出力します。
bb....bb：エラーコード（エラーの状態を表す外部整数変数）
(Ｓ)異常終了します。
[対策]errno.h又はユーザが使用するOSのマニュアルを参照してエラー要因を取り除いて，再度実行してください。
KFPW05036-E
System call error occurred, func="system", cmd="aa....aa", code=bb....bb, inf="cc....cc"　　（Ｌ）
System関数によって実行したコマンドで，エラーが発生しました。
aa....aa：コマンド名
bb....bb：シェルの終了コード
cc....cc：コマンドのエラー出力情報
(Ｓ)異常終了します。
[対策]エラー出力情報とシェルの終了コードを基に，ユーザが使用しているOSのマニュアルを参照してください。エラー要因を取り除いて，再度実行してください。
KFPW05037-I
Information type=aa....aa detail="bb....bb"　　（Ｌ）
種別aa....aa，詳細bb....bbの事象が発生しました。
aa....aa：情報の種別
bb....bb：内部情報
(Ｓ)処理を続行します。
KFPW05038-I
Server aa....aa waiting until dictionary server start　　（Ｌ）
バックエンドサーバの開始処理をする場合，ディクショナリサーバが開始されている必要があります。このため，ディクショナリサーバが開始されるのを待ちます。
aa....aa：サーバ名
(Ｓ)処理を続行します。
ディクショナリサーバが開始された場合，処理を続行します。一定時間内にディクショナリサーバの開始が確認できない場合，ディクショナリサーバの開始を確認しないで，処理を続行します。
[対策]ディクショナリサーバ又はディクショナリサーバがあるサーバマシンを開始してください。ネットワーク障害が考えられる場合は，障害の要因を取り除いてください。
KFPW05039-W
Reduced External Data Access due to DATADICTIONARY search failed SQLCODE=aaaa　　（Ｌ）
ディクショナリ表の検索に失敗したため，HiRDB External Data Access機能を使用できません。
aaaa：SQLCODE
(Ｓ)HiRDB External Data Access機能を使用できない状態で処理を続行します。
[対策]HiRDB External Data Access機能を使用したい場合は，直前に出力されたメッセージに従って処置をして，HiRDBを再開始してください。
KFPW05040-E
Unmatched foreign server definition(standby=aa....aa,current=bb....bb)　　（Ｌ）
外部サーバに関連する定義情報（外部サーバ定義及びユーザマッピング定義）が待機系と実行系で不一致です。このメッセージは次に示す条件をすべて満たす場合に出力されます。
・高速系切り替え機能を使用している
・待機系が待機状態のときに実行系の停止，再起動をした
・待機系の停止，再起動をしていない状態で系切り替えが発生した
aa....aa：保守情報
bb....bb：保守情報
(Ｓ)異常終了します。
[対策]HiRDBを再度開始してください。
KFPW06000-W
Cannot connect to foreign server, back end server name=aa....aa foreign server name=bb....bb id=cc....cc　　（Ｅ）
バックエンドサーバプロセスの起動時，外部サーバに接続できませんでした。
aa....aa：バックエンドサーバの名称
bb....bb：外部サーバ名
cc....cc：プロセスID
(Ｓ)処理を続行します。
[対策]エラー要因を取り除いてください。
KFPW06001-E
Cannot connect to foreign server, back end server name=aa....aa foreign server name=bb....bb id=cc....cc　　（Ｅ）
外部サーバにユーザID"PUBLIC"が定義されていないため，プロセス起動時に外部サーバに接続できませんでした。
aa....aa：バックエンドサーバの名称
bb....bb：外部サーバ名
cc....cc：プロセスID
(Ｓ)処理を続行します。
[対策]CREATE USER MAPPINGでユーザID"PUBLIC"を定義した後，HiRDBを再開始してください。又は，外部サーバの接続タイミング（外部サーバ情報定義のpd_hb_db_conオペランド）をアクセス時に変更した後，HiRDBを再開始してください。
KFPW06011-W
Cannot disconnect to foreign server, back end server name=aa....aa foreign server name=bb....bb id=cc....cc　　（Ｅ）
バックエンドサーバプロセスの終了時，外部サーバとの切り離し処理に失敗しました。
aa....aa：バックエンドサーバの名称
bb....bb：外部サーバ名
cc....cc：プロセスID
(Ｓ)処理を続行します。
[対策]エラー要因を取り除いてください。


KFPXメッセージ

KFPX14004-E
Line aaaa:bb....bb operand value cc....cc invalid　　（Ｌ）
オペランドbb....bbの指定に誤りがあります。
aaaa：行番号
bb....bb：オペランド名
cc....cc：誤ったオペランドの指定値
(Ｓ)すべての制御文を解析した後，処理を終了します。
[対策]制御文のオペランドの指定値を修正し，再度実行してください。
KFPX14017-E
No control statements　　（Ｌ）
指定された制御文ファイルに制御文がありません。
(Ｓ)処理を終了します。
[対策]制御文ファイルに制御文を作成し，再度実行してください。
KFPX14018-E
Specified control statement incomplete　　（Ｌ）
制御文が完結していないのにセミコロン（；）を指定しました。
(Ｓ)すべての制御文を解析した後，処理を終了します。
[対策]制御文を修正し，再度実行してください。
KFPX14019-E
Unable to omit aa....aa RDAREA　　（Ｌ）
データベース初期設定ユティリティで指定する必要があるRDエリアを指定していません。
aa....aa：RDエリアの種類
datadictionary：データディクショナリ用RDエリア
datadictionary（LOB）：データディクショナリLOB用RDエリア
datadirectory：データディレクトリ用RDエリア
masterdirectory：マスタディレクトリ用RDエリア
(Ｓ)すべての制御文を解析した後，処理を終了します。
[対策]出力されたRDエリアaa....aaをcreate rdarea文で指定して，再度実行してください。なお，データディクショナリLOB用RDエリアは2個指定してください。
KFPX14020-E
Line aaaa:bb....bb operand value cc....cc duplicate　　（Ｌ）
bb....bbオペランドに指定した値cc....ccは，既に指定されています。
aaaa：行番号
bb....bb：オペランドのキーワード
cc....cc：重複しているオペランドの指定値
(Ｓ)すべての制御文を解析した後，処理を終了します。
[対策]不要なオペランドの指定値cc....ccを取り除いた後，再度実行してください。
KFPX14023-E
Line aaaa:number of bb....bb rdarea exceeds cccc　　（Ｌ）
bb....bbに示すRDエリアの数が最大値ccccを超えました。
aaaa：行番号
bb....bb：RDエリアの種類
datadictionary：データディクショナリ用RDエリア
datadictionary（LOB）：データディクショナリLOB用RDエリア
datadictionary of routines：routines指定のデータディクショナリ用RDエリア
datadirectory：データディレクトリ用RDエリア
masterdirectory：マスタディレクトリ用RDエリア
cccc：各RDエリアの最大値
(Ｓ)すべての制御文を解析した後，処理を終了します。
[対策]RDエリアの数を最大値以下に修正した後，再度実行してください。
KFPX14024-E
Line aaaa:required bb....bb operand not specified　　（Ｌ）
必要なオペランドbb....bbの指定がありません。
aaaa：行番号
bb....bb：必要なオペランド
(Ｓ)すべての制御文を解析した後，処理を終了します。
[対策]必要なオペランドを指定し，再度実行してください。
KFPX14025-E
Line aaaa:number of parameters in bb....bb operand exceeds cccc　　（Ｌ）
オペランドbb....bbのパラメタの個数が，最大値ccccを超えました。
aaaa：行番号
bb....bb：オペランド名
cccc：パラメタ個数の最大値
(Ｓ)すべての制御文を解析した後，処理を終了します。
[対策]パラメタの個数を最大値以下に修正し，再度実行してください。
KFPX14026-E
Line aaaa:invalid string "bb....bb" in statement cc....cc　　（Ｌ）
制御文cc....ccに不正な文字列bb....bbがありました。
aaaa：行番号
bb....bb：不正な文字列
cc....cc：不正な文字列を含んでいる制御文の名称
(Ｓ)すべての制御文を解析した後，処理を終了します。
[対策]不正な文字列bb....bbを取り除いた後，再度実行してください。
KFPX14027-E
Line aaaa:duplicate bb....bb operand　　（Ｌ）
オペランドbb....bbが重複しています。
aaaa：行番号
bb....bb：オペランド名
(Ｓ)すべての制御文を解析した後，処理を終了します。
[対策]重複しているオペランドを取り除いた後，再度実行してください。
KFPX14029-E
Line aaaa:number of bb....bb operands exceeds cccc　　（Ｌ）
オペランドbb....bbの個数が，最大値ccccを超えました。
aaaa：行番号
bb....bb：オペランド名
cccc：オペランドの最大値
(Ｓ)すべての制御文を解析した後，処理を終了します。
[対策]オペランドの数を最大値以下に修正し，再度実行してください。
KFPX14030-E
Line aaaa:invalid bb....bb statement　　（Ｌ）
誤った制御文を検出しました。
aaaa：行番号
bb....bb：検出した制御文
(Ｓ)すべての制御文を解析した後，処理を終了します。
[対策]誤った制御文を訂正し，再度実行してください。
KFPX14031-E
Line aaaa:control statements out of sequence　　（Ｅ）
制御文の入力順序に誤りがあります。
aaaa：行番号
(Ｓ)すべての制御文を解析した後，処理を終了します。
[対策]制御文を正しい順序に並べ替え，再度実行してください。
RDエリアは，次に示す順序で指定してください。
1. masterdirectory
2. datadirectory
3. datadictionary
4. datadictionary(LOB)
5. user
6. LOB
7. LIST
注　5，6，7は，順不同です。
KFPX14035-E
Line aaaa:mismatched double quotations in bb....bb　　（Ｌ）
制御文のオペランドの指定値bb....bbの引用符号（"）が正しく対になっていません。
aaaa：行番号
bb....bb：オペランドの指定値
(Ｓ)すべての制御文を解析した後，処理を終了します。
[対策]引用符号を修正し，再度実行してください。
KFPX14045-W
Line aaaa:page size raised to bb....bb　　（Ｌ）
ページ長が2048の倍数ではありません。このため，bb....bbに切り上げました。
aaaa：行番号
bb....bb：切り上げた値
(Ｓ)切り上げたページ長を仮定し，処理を続行します。
[対策]create rdarea文の，page bb....bb charactersオペランドのページ長の値に2048の倍数を指定してください。
KFPX14046-W
Line aaaa:bb pages assumed for segment size　　（Ｌ）
マスタディレクトリ用RDエリア，又はデータディレクトリ用RDエリアのセグメント長をシステム固定値の50に仮定しました。また，LOB用RDエリアの場合は，セグメント長をシステム固定値の1に仮定しました。
aaaa：行番号
bb：セグメント長の仮定値{ 1 | 50 }
(Ｓ)
〈マスタディレクトリ用RDエリア，又はデータディレクトリ用RDエリアの場合〉
セグメント長を50として，処理を続行します。
〈LOB用RDエリアの場合〉
セグメント長を1として，処理を続行します。
[対策]create rdarea文のstorage control segmentオペランドのセグメント長をbbに修正してください。
〈マスタディレクトリ用RDエリア，又はデータディレクトリ用RDエリアの場合〉
セグメント長の値を50にしてください。
〈LOB用RDエリアの場合〉
セグメント長の値を1にしてください。
KFPX14047-W
Line aaaa:missing semicolon assumed　　（Ｌ）
制御文の最後にセミコロン（；）が指定されていません。このため，セミコロンを仮定しました。
aaaa：行番号
(Ｓ)処理を続行します。
[対策]セミコロン（；）を指定してください。
KFPX14051-E
Too small RDAREA size, RDAREA name aa....aa, size=bbbb　　（Ｌ）
RDエリアaa....aaのセグメント数に必要なユニット数が不足しています。
aa....aa：RDエリア名称
bbbb：必要なセグメント数
(Ｓ)処理を終了します。
[対策]制御文のinitialオペランドの指定値をbbbb以上に設定して，再度実行してください。
KFPX14078-W
Line aaaa:extension nouse assumed　　（Ｌ）
自動増分機能を指定できるのは，次のRDエリアだけです。これ以外のRDエリアが指定されたため，extensionオペランドの指定値にnouseを仮定しました。
・データディクショナリ用RDエリア
・データディクショナリLOB用RDエリア
・ユーザ用RDエリア
・ユーザLOB用RDエリア
・レジストリ用RDエリア
・レジストリLOB用RDエリア
aaaa：行番号
(Ｓ)処理を続行します。
[対策]create rdarea文のextensionオペランドの指定値をnouseに修正してください。
KFPX14204-E
Line aaaa:bb....bb operand value cc....cc invalid　　（Ｌ）
オペランドbb....bbの指定に誤りがあります。
aaaa：行番号
bb....bb：オペランド名
cc....cc：誤ったオペランドの指定値
(Ｓ)すべての制御文を解析した後，処理を終了します。
[対策]制御文のオペランドの指定値を修正し，再度実行してください。
KFPX14217-E
No control statements　　（Ｌ）
指定された制御文ファイルに制御文がありません。
(Ｓ)処理を終了します。
[対策]制御文ファイルに制御文を作成し，再度実行してください。
KFPX14218-E
Specified control statement incomplete　　（Ｌ）
制御文が完結していないのにセミコロン（；）を指定しました。
(Ｓ)すべての制御文を解析した後，処理を終了します。
[対策]制御文を修正し，再度実行してください。
KFPX14220-E
Line aaaa:bb....bb operand value cc....cc duplicate　　（Ｌ）
bb....bbオペランドに指定した値cc....ccは，既に指定されています。又は，既にシステムにあります。
aaaa：行番号
bb....bb：オペランドのキーワード
cc....cc：重複しているオペランドの指定値
(Ｓ)すべての制御文を解析した後，処理を終了します。
[対策]不要なオペランドの指定値cc....ccを取り除いた後，再度実行してください。
KFPX14223-E
Line aaaa:number of bb....bb rdarea exceeds cccc　　（Ｌ）
bb....bbに示すRDエリアの数が最大値ccccを超えました。
aaaa：行番号
bb....bb：RDエリアの種類
datadictionary（LOB）：データディクショナリLOB用RDエリア
datadictionary of routines：routines指定のデータディクショナリ用RDエリア
registry：レジストリ用RDエリア
registry（LOB）：レジストリLOB用RDエリア
datadictionary of dbmanagement：dbmanagement指定のデータディクショナリ用RDエリア
cccc：各RDエリアの最大値
(Ｓ)処理を終了します。
[対策]RDエリアの数を最大値以下に修正して，再度実行してください。
KFPX14224-E
Line aaaa:required bb....bb operand not specified　　（Ｌ）
必要なオペランドbb....bbが指定されていません。
aaaa：行番号
bb....bb：必要なオペランド
(Ｓ)すべての制御文を解析した後，処理を終了します。
[対策]必要なオペランドを指定し，再度実行してください。
KFPX14225-E
Line aaaa:number of parameters in bb....bb operand exceeds cccc　　（Ｌ）
オペランドbb....bbのパラメタの個数が，最大値ccccを超えました。
aaaa：行番号
bb....bb：オペランド名
cccc：パラメタ個数の最大値
(Ｓ)すべての制御文を解析した後，処理を終了します。
[対策]パラメタの個数を最大値以下に修正し，再度実行してください。
KFPX14226-E
Line aaaa:invalid string "bb....bb" in statement cc....cc　　（Ｌ）
制御文cc....ccに不正な文字列bb....bbがあります。
aaaa：行番号
bb....bb：不正な文字列
cc....cc：不正な文字列を含んでいる制御文の名称
(Ｓ)すべての制御文を解析した後，処理を終了します。
[対策]不正な文字列bb....bbを取り除いた後，再度実行してください。
KFPX14227-E
Line aaaa:duplicate bb....bb operand　　（Ｌ）
オペランドbb....bbが重複しています。
aaaa：行番号
bb....bb：オペランド名
(Ｓ)すべての制御文を解析した後，処理を終了します。
[対策]重複しているオペランドを取り除いた後，再度実行してください。
KFPX14229-E
Line aaaa:number of bb....bb operands exceeds cccc　　（Ｌ）
オペランドbb....bbの個数が，最大値ccccを超えました。
aaaa：行番号
bb....bb：オペランド名
cccc：オペランドの最大値
(Ｓ)すべての制御文を解析した後，処理を終了します。
[対策]オペランドの数を最大値以下に修正し，再度実行してください。
KFPX14230-E
Line aaaa:invalid bb....bb statement　　（Ｌ）
誤った制御文を検出しました。
aaaa：行番号
bb....bb：検出した制御文
(Ｓ)すべての制御文を解析した後，処理を終了します。
[対策]誤った制御文を訂正し，再度実行してください。
KFPX14235-E
Line aaaa:mismatched double quotations in bb....bb　　（Ｌ）
制御文のオペランドの指定値bb....bbの引用符号（"）が正しく対になっていません。
aaaa：行番号
bb....bb：オペランドの指定値
(Ｓ)すべての制御文を解析した後，処理を終了します。
[対策]引用符号を修正し，再度実行してください。
KFPX14236-E
Unable to aa....aa rdarea due to invalid RDAREA status[, server name= bb....bb]　　（Ｌ）
RDエリアの状態が正しくないので，aa....aaに示す構成変更処理ができません。
aa....aa：構成変更処理
alter：変更
expand：拡張
initialize：再初期化
remove：削除
define copy：構成情報複写
recast：統合
bb....bb：サーバ名（共用RDエリアの場合だけ出力されます）
(Ｓ)該当するRDエリアの構成変更処理を中止し，次の制御文の処理を続行します。
[対策]RDエリアを次に示す状態にして，再度実行してください。
alter：クローズ状態，かつコマンド閉塞状態
expand：オープン状態，又はコマンド閉塞状態（非閉塞又はhold）
initialize：クローズ状態，かつコマンド閉塞状態又は障害閉塞状態
remove：クローズ状態，かつコマンド閉塞状態又は障害閉塞状態
define copy：クローズ状態，かつコマンド閉塞状態
recast：クローズ状態，かつコマンド閉塞状態
KFPX14238-E
Unable to aa....aa "bb....bb" due to invalid RDAREA type　　（Ｌ）
bb....bbのRDエリアに対して，RDエリア種別が不正です。このため，aa....aaに示す構成変更処理ができません。
aa....aa：構成変更の機能
initialize：RDエリアの再初期化
remove：RDエリアの削除
replicate：RDエリアのレプリカ定義
define copy：RDエリアの構成情報複写
move：RDエリアの移動
create audit table：RDエリアの監査証跡表作成
bb....bb：RDエリア名
(Ｓ)該当するRDエリアの構成変更処理を中止して，次の処理を続行します。
[対策]次に示すRDエリアを指定して，再度実行してください。
initialize：ユーザ用RDエリア，データディクショナリLOB用RDエリア，ユーザLOB用RDエリア，リスト用RDエリア，レジストリ用RDエリア，及びレジストリLOB用RDエリア
remove：ユーザ用RDエリア，ユーザLOB用RDエリア，リスト用RDエリア，解析情報表及び運用履歴表を格納するデータディクショナリ用RDエリア
replicate：ユーザ用RDエリア，ユーザLOB用RDエリア
define copy：ユーザ用RDエリア，ユーザLOB用RDエリア
move：ユーザ用RDエリア，ユーザLOB用RDエリア
create audit table：ユーザ用RDエリア（共用RDエリアは指定できません）
KFPX14245-W
Line aaaa:page size raised to bb....bb　　（Ｌ）
ページ長が2048の倍数ではありません。このため，bb....bbに切り上げました。
aaaa：行番号
bb....bb：切り上げた値
(Ｓ)切り上げたページ長を仮定し，処理を続行します。
[対策]create rdarea文のpage bb....bb charactersオペランドのページ長には，2048の倍数を指定してください。
KFPX14246-W
Line aaaa:bb pages assumed for segment size　　（Ｌ）
LOB用RDエリアのセグメント長をシステム固定値の1に仮定しました。
aaaa：行番号
bb：セグメント長の仮定値
(Ｓ)セグメント長を1として，処理を続行します。
(Ｐ)create rdarea文のstorage control segmentオペランドのセグメント長の値を1に修正してください。
KFPX14247-W
Line aaaa:missing semicolon assumed　　（Ｌ）
制御文の最後にセミコロン（；）が指定されていなかったので，セミコロンを仮定しました。
aaaa：行番号
(Ｓ)処理を続行します。
[対策]セミコロン（；）を指定してください。
KFPX14250-I
Processing of [aa....aa] statement ended return code=bb [, RDAREA name ="cc....cc" [to dd....dd]]　　（Ｌ）
構成変更ユティリティaa....aaの処理がbbのリターンコードで終了しました。
aa....aa：データベース構成変更ユティリティの機能
なお，制御文解析エラー時は，出力されないことがあります。
・alter rdarea：RDエリアの変更
・alter HiRDB mode：シングルからパラレルへの移行機能
・alter system：システム定義の変更
・create rdarea：RDエリアの追加
・expand rdarea：RDエリアの拡張
・initialize rdarea：RDエリアの再初期化
・remove rdarea：RDエリアの削除
・create generation：HiRDBファイルシステム領域の世代登録
・remove generation：HiRDBファイルシステム領域の世代削除
・replicate rdarea：RDエリアのレプリカ定義
・define copy rdarea：RDエリアの構成情報複写
・recast rdarea：RDエリアの統合
・move rdarea：RDエリアの移動
・create auditor：監査人の登録
・create audit table：監査証跡表の作成
bb：リターンコード
0：正常終了
4：警告レベルのエラーがありましたが処理は終了しました。
8：異常終了しました。出力されているエラーメッセージを参照し，エラーの原因を取り除いた後，再度実行してください。
cc....cc：RDエリア名
なお，制御文解析エラー時は出力されないことがあります。alter HiRDB mode及びcreate auditorのときは出力されません。
dd....dd：移動先のサーバ名（RDエリアの移動のときだけ出力されます）
(Ｓ)処理を続行します。
KFPX14251-E
Too small RDAREA size, RDAREA name aa....aa, size=bbbb　　（Ｌ）
RDエリアaa....aaのセグメント数が，必要なユニット数よりも不足しています。
aa....aa：RDエリア名
bbbb：必要なセグメント数
(Ｓ)処理を終了します。
(Ｐ)制御文のinitialオペランドの指定値をbbbb以上に設定して，再度実行してください。
KFPX14253-E
aa....aa bb....bb not defined　　（Ｌ）
bb....bbの名称で示すaa....aaが，システムにありません。
aa....aa：名称の種類
RDAREA：RDエリア
File：HiRDBファイル
Rfile：レプリカHiRDBファイルシステム領域名
bb....bb：次のどれかを表示
・RDエリア名
・HiRDBファイル名
・レプリカHiRDBファイルシステム領域名（世代番号）
(Ｓ)該当するRDエリアの構成変更処理を中止して，次の制御文の処理を続行します。
[対策]RDエリア名，HiRDBファイル名を修正して，再度実行してください。
レプリカHiRDBファイルシステム領域名の場合は，HiRDBファイルシステム領域を世代登録してから再度実行してください。
KFPX14255-W
Unable to initialize index aa....aa.bb....bb due to cc....cc, RDAREA name="dd....dd"　　（Ｌ）
cc....ccの理由で，インデクスaa....aa.bb....bbの初期化処理ができません。
aa....aa：認可識別子
bb....bb：インデクス識別子
cc....cc：エラーの原因
RDAREA status is invalid：RDエリアの状態が不正です。
HiRDB system error occurred：SQLエラーです。
dd....dd：RDエリア名
(Ｓ)該当するRDエリアのインデクスの初期化処理を中断し，次の処理を続行します。
[対策]
〈RDエリアの状態が不正の場合〉
RDエリアの状態をRELEASE，OPENにして再度実行してください。又は，データベース再編成ユティリティで再初期化したRDエリア内のインデクスにデータを挿入するとき，インデクスを再作成してください。
〈SQLエラーの場合〉
SQLメッセージを参照して，エラーの原因を取り除き，再度実行してください。又は，データベース再編成ユティリティで再初期化したRDエリア内のインデクスにデータを挿入するとき，インデクスを再作成してください。
なお，この処置をしないで，インデクスaa....aa.，bb....bbに検索，又は挿入をした場合，インデクスのデータが削除されていないため，その結果は保証されません。
KFPX14259-E
Unable to remove due to exist table or index　　（Ｌ）
削除するRDエリアに，表，インデクス，LOB列，又はレプリカRDエリアがあります。このため，RDエリアの削除ができません。
(Ｓ)処理を終了します。
[対策]削除対象のRDエリアにあるすべての表，インデクス，LOB列，及びレプリカRDエリアを削除した後，再度実行してください。
KFPX14262-E
Unable to aa....aa due to insufficient master directory rdarea　　（Ｌ）
マスタディレクトリ用RDエリアの容量が不足しました。このため，aa....aaは処理できません。
aa....aa：エラーの発生した処理
create rdarea：RDエリアの追加
replicate rdarea：RDエリアのレプリカ定義
(Ｓ)処理を終了します。
[対策]マスタディレクトリ用RDエリアを拡張（expand rdarea）した後，再度実行してください。
KFPX14268-W
Too small RDAREA size, RDAREA=aa....aa, area size=bbbb-cccc　　（Ｌ）
RDエリアのエリアサイズ（セグメント数）が，エリア内の表及びインデクスの定義数よりも少な過ぎます。そのため，表及びインデクスの中に使用できないものがあります。
aa....aa：RDエリア名
bbbb：該当するRDエリアの表及びインデクスを使用するのに最低限必要なセグメント数（該当するRDエリアに格納されている表数及びインデクス数の総和）
cccc：割り当てられているRDエリアのセグメント数
(Ｓ)処理を続行します。
[対策]セグメント数を多く指定した後，再度初期化してください。又は，不要な表又はインデクスの定義があれば，定義を削除してください。
KFPX14280-E
Failed to allocate RDAREA "aa....aa" to global buffer bb....bb, return code=cc[, server name= dd....dd]　　（Ｌ）
RDエリア名aa....aaをグローバルバッファbb....bbに割り当て時に，エラーが発生しました。
aa....aa：RDエリア名称
bb....bb：グローバルバッファ名称
cc：理由コード
4：RDエリアのページ長よりも小さいバッファ長を指定しました。
8：指定したバッファプールがありません（オリジナルRDエリア，又はレプリカRDエリアにグローバルバッファが割り当てられていない場合は，bb....bbが表示されないことがあります）。
12：指定したバッファプールはインデクス用，又はLOB用です。
16：ステータスログファイルへの出力に失敗しました。
dd....dd：サーバ名（共用RDエリアの場合だけ出力されます）
(Ｓ)該当するRDエリアの構成変更処理を中止して，次の処理を続行します。
[対策]エラーの要因を取り除いて，再度実行してください。
KFPX14302-W
Line aaaa:extension nouse assumed　　（Ｌ）
自動増分機能を指定できるのは，次のRDエリアだけです。これ以外のRDエリアが指定されたため，extensionオペランドの指定値にnouseを仮定しました。
・データディクショナリ用RDエリア
・データディクショナリLOB用RDエリア
・ユーザ用RDエリア
・ユーザLOB用RDエリア
・レジストリ用RDエリア
・レジストリLOB用RDエリア
aaaa：行番号
(Ｓ)処理を続行します。
[対策]create rdarea文，expand rdarea文，initialize rearea文，又はalter rdarea文のextensionオペランドの指定値をnouseに修正してください。
KFPX18400-I
Pdexp terminated, return code=aa....aa　　（Ｓ）
ディクショナリ搬出入ユティリティ（pdexp）の処理が，次に示すリターンコードの内容で終了しました。
aa....aa：リターンコード
0：正常終了
4：警告レベルのエラーがありましたが，処理は終了しました。
8：正常に処理したものと，一部処理を中止したものがあります。
12：1件も正常に処理を完了しないで，終了しました。又は，ユティリティのサーバプロセスがキャンセル，若しくは異常終了しました。
(Ｓ)処理を終了します。
(Ｏ)リターンコードが0以外の場合，このユティリティが出力したメッセージを調査し，そのメッセージに従って処置してください。
ただし，次に示す場合は，正常に完了した処理があっても，リターンコードが12となります。
・pdcancelコマンドでキャンセルした場合
・ユティリティのサーバプロセスで異常が発生したなどの場合
このため，搬入時にリターンコード12で終了したときは，ディクショナリ表（SQL_TABLES表のTABLE_SCHEMA列，TABLE_NAME列）を検索し，正常に完了した処理を確認してください。
KFPX18410-E
Insufficient memory on aa....aa, size=bb....bb　　（Ｌ＋Ｓ）
メモリが不足したため，作業領域を確保できません。
aa....aa：領域の種別を示す文字列
DYNAMIC_SHMPOOL：動的共用メモリ
PROCESS：プロセス固有領域
STATIC_SHMPOOL：静的共用メモリ
bb....bb：確保しようとした領域サイズ（単位：バイト）
(Ｓ)処理を終了します。
(Ｏ)使用できるメモリを増やして実行してください。
KFPX18430-E
Error occurred:aa....aa　　（Ｅ＋Ｌ＋Ｓ）
搬出入処理でエラーを検知しました。又は，HiRDBでエラーを検知しました。
aa....aa：ユティリティが検知したエラー，又はHiRDB本体が検知したエラーメッセージ
(Ｓ)処理を終了します。
(Ｏ)次に示すどちらかの処置をしてください。
・このメッセージの前に出力したメッセージに従って，対処してください。
・HiRDB本体から出力されたメッセージに従って，対処してください。
KFPX18431-E
cc....cc import error occurred, error_sql_no=aa....aa,error_sql=bb....bb　　（Ｅ＋Ｌ＋Ｓ）
搬入時に発行した create cc....ccでエラーを検知しました。
aa....aa：create cc....cc文中の手続き文の番号
bb....bb：create cc....cc文中の手続き中でエラーとなったSQL文又はSQL手続文
cc....cc：｛Procedure｜Trigger｝
(Ｓ)処理を終了します。
(Ｏ)error_sql_no，error_sql，及びこの後に出力されているSQLエラーメッセージに示されているエラーの原因を取り除いて，再度実行してください。
KFPX18467-E
Line aa....aa:incorrect control statement　　（Ｅ）
-t，-p，又は-g指定に次のような誤りがあります。
・引用符（"）の指定方法が不正です。
・指定値の長さが不正です。
・スキーマ名.識別子の形式ではありません。
・-t，-p，又は-gの指定値がありません。
aa....aa：行番号
(Ｓ)制御文の解析後，処理を終了します。
(Ｏ)制御文を修正してください。
KFPX18468-E
Line aa....aa:invalid operation　　（Ｅ）
制御文の指定に誤りがあります。又は，-t，-p，若しくは-g以外の指定があります。
aa....aa：行番号
(Ｓ)制御文の解析後，処理を終了します。
(Ｏ)制御文を修正してください。
KFPX18476-E
Line aa....aa:invalid value in bb....bb name　　（Ｅ）
bb....bbの指定に不正があります。
aa....aa：行番号
bb....bb：誤りがある指定｛procedure｜schema｜table｜trigger｝
(Ｓ)制御文の解析後，処理を終了します。
(Ｏ)制御文を修正してください。
KFPX18477-E
Line aa....aa:unable to specify -t and -p and -g at the same time　　（Ｅ）
表の搬出入の指定（-tオプション），ストアドプロシジャの搬出入の指定（-pオプション），及びトリガの搬出入の指定（-gオプション）は，同時にできません。
aa....aa：行番号
(Ｓ)該当するエラーを検知した時点で，処理を終了します。
(Ｏ)表，ストアドプロシジャ，及びトリガの搬出入は，別々に実行してください。
KFPX18480-E
Number of -t/-p/-g statement exceeds 64　　（Ｅ）
ディクショナリ搬出入ユティリティで搬出入する表（-tオプション），ストアドプロシジャ（-pオプション），又はトリガ（-gオプション）の数が，制限（64）を超えました。
(Ｓ)処理を終了します。
(Ｏ)-t，-p，又は-gオプションの指定を64以下に修正してください。
65以上の表，ストアドプロシジャ，又はトリガを処理する場合，1回で処理する数を64以下に分けて起動してください。
KFPX18481-E
No -t/-p/-g statement　　（Ｅ）
搬出入の対象となる表（-tオプション），ストアドプロシジャ（-pオプション），又はトリガ（-gオプション）の指定が，一つもありません。
(Ｓ)制御文の解析後，処理を終了します。
(Ｏ)一つ以上の-t，-p，又は-gオプションを指定してください。
KFPX18490-E
Line aa....aa:duplicate name　　（Ｅ）
搬出入の対象となる表（-tオプション），ストアドプロシジャ（-pオプション），又はトリガ（-gオプション）の名称に，同じ名称の指定があります。
aa....aa：行番号
(Ｓ)制御文の解析後，処理を終了します。
(Ｏ)制御文を修正してください。
KFPX18502-E
No privileges to export/import　　（Ｌ＋Ｓ）
ユーザに搬出入を実行する権限がありません。搬出入を実行するには，DBA権限が必要です。
(Ｓ)処理を終了します。
(Ｏ)DBA権限を与えてもらってから，再度実行してください。
KFPX18504-E
Unable to export aa....aa, name="bb....bb"."cc....cc"　　（Ｌ＋Ｓ）
このメッセージの前に出力したメッセージの内容が原因で，aa....aaの搬出ができません。
aa....aa：搬出する対象｛procedure｜table｜trigger｝
bb....bb：スキーマ名（パブリックビューの搬出の場合はPUBLICとなります）
cc....cc：表識別子，ルーチン識別子，又はトリガ識別子
(Ｓ)処理を終了します。
(Ｏ)このメッセージの前に出力したメッセージに従って，対処してください。
KFPX18506-E
Specified aa....aa not found in dictionary, name="bb....bb"."cc....cc"　　（Ｌ＋Ｓ）
搬出指定したaa....aaは，ディクショナリ中にありません。
aa....aa：搬出する対象｛procedure｜table｜trigger｝
bb....bb：スキーマ名（パブリックビューの搬出の場合はPUBLICとなります）
cc....cc：表識別子，ルーチン識別子，又はトリガ識別子
(Ｓ)この表に対する処理を中止し，次の処理を続行します。
(Ｏ)正しい表名，プロシジャ名，又はトリガ名を指定してください。
KFPX18507-W
cc....cc invalid, name="aa....aa."bb....bb"　　（Ｌ＋Ｓ）
cc....ccが無効となっています。
正常に搬出しましたが，無効なcc....ccは，搬入時に使用している表があるかどうかのチェックをしません。そのため，使用している表が搬入先にない場合，その時点で搬入処理が打ち切られます。使用している表がすべて搬入先にあれば，正常に搬入できます。
aa....aa：スキーマ名
bb....bb：プロシジャ識別子，又はトリガ識別子
cc....cc：｛Procedure｜Trigger｝
(Ｓ)cc....ccの処理は正常に終了します。ただし，ユティリティのリターンコードは4となります。
(Ｏ)このcc....ccを搬入するとき，使用している表がすべて搬入先にあることを確認してください。
KFPX18508-E
Not support facility in definition of aa....aa"bb....bb"."cc....cc"　　（Ｌ＋Ｓ）
搬出対象のaa....aaとして指定された定義にディクショナリ搬出入ユティリティ（pdexp）がサポートしていない機能があるため，搬出できません。
ディクショナリ搬出入ユティリティでサポートしていないものは次のとおりです。
〈aa....aaがtableの場合〉
・抽象データ型を含む表
・外部表
〈aa....aaがprocedureの場合〉
・抽象データ型，及び手続きを使用している手続き
・抽象データ型内で宣言されている手続き
aa....aa：｛table（表）｜procedure（手続き）｝
bb....bb：スキーマ名
cc....cc：表識別子，又はルーチン識別子
(Ｓ)この表，又は手続きの搬出処理をスキップして処理を続行します。ただし，抽象データ型及び手続きを使用している手続きを搬出した場合は，処理を終了します。
(Ｏ)抽象データ型及び手続きを使用している手続きでエラーが発生した場合は，その手続きの指定を制御文ファイルから取り除き，ユティリティを再実行してください。
そのほかのサポートしていない表，手続きでエラーが発生した場合は，搬入先システムで該当する定義SQL文をpddefなどで実行してください。
KFPX18550-E
Unable to import aa....aa, name="bb....bb"."cc....cc"　　（Ｌ＋Ｓ）
このメッセージの前に出力したメッセージの内容が原因で，
aa....aaの搬入ができません。
aa....aa：搬出する対象｛index｜procedure｜table｜trigger｝
bb....bb：スキーマ名（パブリックビューの搬入の場合はPUBLICとなります）
cc....cc：インデクス識別子，ルーチン識別子，表識別子，又はトリガ識別子
(Ｓ)処理を終了します。
(Ｏ)このメッセージの前に出力したメッセージに従って，対処してください。
KFPX18551-E
Table not defined, name="aa....aa"."bb....bb"　　（Ｌ＋Ｓ）
表aa....aa.bb....bbが，搬入先システムで定義されていません。このため，KFPX18550-Eで示すストアドプロシジャ，又はトリガの搬入ができません。
aa....aa：スキーマ名（パブリックビューの場合はPUBLICとなります）
bb....bb：表識別子
(Ｓ)このメッセージの後に出力されているKFPX18550-Eメッセージで示すストアドプロシジャ，又はトリガの搬入処理を中止して，次の搬入処理を続行します。
(Ｏ)表aa....aa.bb....bbを定義した後，再度搬入してください。
KFPX18555-E
Same cc....cc already exist, name="aa....aa"."bb....bb"　　（Ｌ＋Ｓ）
搬入するcc....ccは，既に搬入先システムにあります。
aa....aa：スキーマ名
bb....bb：ルーチン識別子，又はトリガ識別子
cc....cc：｛procedure｜trigger｝
(Ｓ)このcc....ccの搬入処理を中止して，次の搬入処理を続行します。
(Ｏ)再度搬入するときは，DROP cc....cc文でcc....ccを削除した後，実行してください。
KFPX18560-E
Invalid export file　　（Ｌ＋Ｓ）
指定したファイルは，搬出ファイルではありません。又は，次に示すように搬出ファイルの内容と表，ストアドプロシジャ，又はトリガの指定が一致しません。
・表の搬出ファイルに，表の搬入（-t）以外を指定しています。
・ストアドプロシジャの搬出ファイルに，ストアドプロシジャの搬入（-p）以外を指定しています。
・トリガの搬出ファイルに，トリガの搬入（-g）以外を指定しています。
(Ｓ)処理を終了します。
(Ｏ)-iオプションに正しい搬出ファイルを指定してください。
KFPX18562-E
Export file incompleted　　（Ｌ＋Ｓ）
搬出ファイルの不正，又は不当なEOFを検知しました。
(Ｓ)処理を終了します。
(Ｏ)正常に搬出できた搬出ファイルかどうかを確認してください。不正な場合，正常に搬出が完了した搬出ファイルで搬入してください。
KFPX18563-E
Same table already exist, name="aa....aa"."bb....bb"　　（Ｌ＋Ｓ）
搬入する表は，既に搬入先システムにあります。
aa....aa：スキーマ名（パブリックビューの場合はPUBLICとなります）
bb....bb：表識別子
(Ｓ)該当する表に対する処理を中止して，処理を続行します。
(Ｏ)再度搬入する場合，DROP TABLE文で表を削除した後，再度実行してください。
KFPX18566-E
Specified aa....aa not found in export file, name="bb....bb"."cc....cc"　　（Ｌ＋Ｓ）
搬入対象のaa....aaは，搬出ファイル中にありません。
aa....aa：搬入する対象｛procedure｜table｜trigger｝
bb....bb：スキーマ名（パブリックビューの搬入の場合はPUBLICとなります）
cc....cc：表識別子，ルーチン識別子，又はトリガ識別子
(Ｓ)該当する表に対する処理を中止して，処理を続行します。
(Ｏ)正しい表名，ストアドプロシジャ名，又はトリガ名を指定してください。
KFPX18579-E
aaaaa error occurred on bb....bb　　（Ｌ＋Ｓ）
bb....bbで示すディクショナリ表のアクセス時に，エラーが発生しました。
aaaaa：処理内容｛Input｝
bb....bb：ディクショナリ表識別子
(Ｓ)処理を終了します。
(Ｏ)このメッセージの前に出力したメッセージに従って，対処してください。
KFPX21000-I
Usage: pdobjconv　　（Ｓ）
SQLオブジェクト移行ユティリティのオプションの形式に誤りがあります。
(Ｓ)処理を終了します。
(Ｏ)SQLオブジェクト移行ユティリティのコマンド形式を確認して，再度実行してください。
KFPX21001-I
SQL OBJECT converter start at aa....aa on bb....bb　　（Ｅ＋Ｌ）
SQLオブジェクト移行ユティリティ（pdobjconvコマンド）を開始しました。
aa....aa：開始時間　hh:mm:ss（hh：時　mm：分　ss：秒）
bb....bb：開始年月日　yyyy:mm:dd（yyyy：年　mm：月　dd：日）
(Ｓ)処理を続行します。
KFPX21002-I
SQL OBJECT converter ended, return code= aa　　（Ｅ＋Ｌ）
SQLオブジェクト移行ユティリティ（pdobjconvコマンド）が，リターンコードaaで終了しました。
aa：リターンコード
０：正常終了しました。
４：警告エラーがありましたが，処理は終了しました。
８：処理は終了しましたが，移行に失敗したSQLオブジェクトがあります。
12：異常終了しました。
(Ｓ)処理を終了します。
[対策]リターンコードに従って処置してください。
０又は４：対策は必要ありません。
８：SQLオブジェクトの移行に失敗したビュー表，手続き，及び関数があります。
HiRDBがSQLオブジェクト移行ユティリティを自動起動した場合は，$PDDIR/spool/pdobjconv.logファイルを参照して，エラーとなった原因を取り除いて，再度SQLオブジェクト移行ユティリティを実行してください。オペレータがSQLオブジェクト移行ユティリティを実行した場合は，カレントディレクトリにあるpdobjcon.logファイルを参照して，エラーとなった原因を取り除いて，再度SQLオブジェクト移行ユティリティを実行してください。
12：途中で処理が中断されています。メッセージを参照して障害を取り除いてから，再度SQLオブジェクト移行ユティリティを実行してください。
KFPX21003-E
Invalid option for pdobjconv　　（Ｓ）
pdobjconvコマンドのオプションの形式に誤りがあります。
(Ｓ)処理を終了します。
(Ｏ)pdobjconvコマンドのオプション形式を確認して，再度実行してください。
KFPX21004-E
Insufficient memory on PROCESS for SQL OBJECT conversion, size=aa....aa　　（Ｅ）
SQLオブジェクト移行ユティリティ実行時にプロセス固有領域を確保しようとしましたが，メモリが不足したため確保できませんでした。
aa....aa：確保しようとした領域サイズ（単位：バイト）
(Ｓ)処理を終了します。
[対策]次に示すどれかの方法で，使用できるメモリに余裕をもたせてください。
・同時実行しているプロセス数を減らしてください。
・スワップ領域を増やしてください。
・実メモリを増設してください。
KFPX21005-E
System call error in SQL OBJECT conversion, func=aa....aa, errno=bb....bb　　（Ｅ＋Ｌ）
SQLオブジェクト移行ユティリティ実行時にシステム関数でエラーが発生しました。
aa....aa：システム関数名
bb....bb：エラーコード
(Ｓ)処理を終了します。
[対策]システム関数のerrnoを調査して原因を取り除き，再度実行してください。
KFPX21006-E
Open error in report file “aa....aa" for SQL OBJECT conversion, errno=bb....bb　　（Ｅ＋Ｌ）
bb....bbの理由で，SQLオブジェクト移行ユティリティの実行結果ファイルのオープンに失敗しました。
aa....aa：ファイル名称
bb....bb：エラーコード
(Ｓ)処理を終了します。
[対策]システム関数のerrnoを調査して原因を取り除き，再度実行してください。
KFPX21007-E
RPC(aa....aa) error occurred in SQL OBJECT conversion, code=bb....bb　　（Ｅ＋Ｌ）
SQLオブジェクト移行ユティリティ実行時にRPCでエラーが発生しました。
aa....aa：RPCの処理種別
bb....bb：エラー詳細コード
(Ｓ)処理を終了します。
[対策]「システム関連エラーの詳細コード」及び直前に出力されたKFPS05032-Eメッセージを参照してエラーの原因を取り除き，再度コマンドを実行してください。ただし，エラー詳細コードが「-999」の場合は，このメッセージの前にエラーの原因を示すエラー情報が出力されています。また，エラー詳細コードが「-310」の場合は，通信先のサーバが起動されていないと考えられます。
KFPX21008-E
Pdobjconv must be executed at HiRDB unit including system manager　　（Ｅ）
SQLオブジェクト移行ユティリティは，システムマネジャが定義されているユニットで実行してください。
(Ｓ)処理を終了します。
[対策]システムマネジャが定義されているユニットで，再度コマンドを実行してください。
KFPX21100-E
aa....aa “bb....bb".“cc....cc“ not found in system　　（Ｅ＋Ｌ）
指定したビュー表，手続き，又は関数　bb....bb.cc....ccは，HiRDBシステムにありません。
aa....aa：次のどれかです。
View：ビュー表
Procedure：手続き
Function：関数
bb....bb：認可識別子
cc....cc：表名，手続き名，又は関数名
(Ｓ)処理を終了します。
[対策]正しいビュー表，手続き，又は関数名を指定して，再度実行してください。
KFPX21101-W
aa....aa “bb....bb".“cc....cc“ dropped from system during SQL OBJECT conversion　　（Ｅ＋Ｌ）
SQLオブジェクト移行ユティリティ実行中にビュー表，手続き，又は関数bb....bb.cc....ccがHiRDBシステムから削除されています。
aa....aa：次のどれかです。
View：ビュー表
Procedure：手続き
Function：関数
bb....bb：認可識別子
cc....cc：表名，手続き名，又は関数名
(Ｓ)処理を続行します。
KFPX21102-I
SQL OBJECT of aa....aa “bb....bb“."cc....cc“ already converted　　（Ｅ＋Ｌ）
ビュー表，手続き，又は関数　bb....bb.cc....ccのSQLオブジェクトは既に移行が完了しているため，SQLオブジェクトの移行処理をしませんでした。
aa....aa：次のどれかです。
View：ビュー表
Procedure：手続き
Function：関数
bb....bb：認可識別子
cc....cc：表名，手続き名，又は関数名
(Ｓ)処理を続行します。
KFPX21103-I
SQL OBJECT of aa....aa “bb....bb“."cc....cc“ converted successfully　　（Ｅ＋Ｌ）
ビュー表，手続き，又は関数　bb....bb.cc....ccのSQLオブジェクトの移行に成功しました。
aa....aa：次のどれかです。
View：ビュー表
Procedure：手続き
Function：関数
bb....bb：認可識別子
cc....cc：表名，手続き名，又は関数名
(Ｓ)処理を続行します。
KFPX21104-E
SQL OBJECT conversion for aa....aa “bb....bb“."cc....cc“ failed　　（Ｅ＋Ｌ）
ビュー表，手続き，又は関数　bb....bb.cc....ccのSQLオブジェクトの移行に失敗しました。
aa....aa：次のどれかです。
View：ビュー表
Procedure：手続き
Function：関数
bb....bb：認可識別子
cc....cc：表名，手続き名，又は関数名
(Ｓ)処理を続行します。
[対策]このメッセージの後に続くメッセージから原因を調査してください。原因を取り除いてから，再度実行してください。
KFPX21105-W
Register again REGISTRY MANIPULATION PROCEDURE; enter pdreginit command　　（Ｓ＋Ｅ＋Ｌ）
レジストリ操作用プロシジャの再登録が必要です。
(Ｓ)処理を続行します。
[対策]pdreginitコマンドで，レジストリ操作用プロシジャを再登録してください。
KFPX21200-I
Usage : pdjarsync [-S | -I | -R | -D | -L] [-x host_name [, host_name]] [-u owner_name [, owner_name]] [-f jar_file_name]　　（Ｓ）
pdjarsyncコマンドのオプション形式に誤りがあります。
(Ｓ)処理を終了します。
(Ｏ)コマンドを正しく入力して，再度実行してください。
KFPX21201-E
Specification host aa....aa not found in system definition file　　（Ｓ）
指定したaa....aaは，システム共通定義にありません。
aa....aa：ホスト名
(Ｓ)処理を終了します。
(Ｏ)正しいホスト名を指定して，再度実行してください。
KFPX21202-E
JAR file "aa....aa" already exist　　（Ｓ）
指定したJARファイルaa....aaは，既に登録されています。
aa....aa：JARファイル名
(Ｓ)処理を終了します。
(Ｏ)JARファイルを上書きしてもよい場合は，pdjarsync -Rコマンドを実行してください。
KFPX21203-E
Internal function error, func=aa....aa, return code=bb....bb　　（Ｓ）
コマンドの内部処理でエラーが発生しました。
aa....aa：エラーが発生した関数名
bb....bb：システム関連エラーの詳細コード
「システム関連エラーの詳細コード」を参照してください。
(Ｓ)処理を終了します。
(Ｏ)エラー要因を取り除いてから，再度実行してください。
KFPX21204-E
Insufficient memory on PROCESS for JAR file synchronizer, size=aa....aa　　（Ｓ）
pdjarsyncコマンド実行時にプロセス固有領域を確保しようとしましたが，メモリ不足で確保できませんでした。
aa....aa：確保しようとしたサイズ（単位：バイト）
(Ｓ)処理を終了します。
(Ｏ)次のどれかの対処をしてください。
・同時実行しているプロセス数を減らしてください。
・スワップ領域を増やしてください。
・実メモリを増設してください。
KFPX21205-E
Pdstart command parameter missing in system common definition　　（Ｓ）
システム共通定義のpdstartに誤りがあります。
(Ｓ)処理を終了します。
(Ｏ)システム共通定義のpdstartの内容を修正して，再度実行してください。
KFPX21206-E
Incorrect hostname or unitid specified in system definition　　（Ｓ）
指定したホスト名又はユニット識別子は，システム定義でHiRDBのホスト又はユニットとして定義されていません。
(Ｓ)処理を終了します。
(Ｏ)システム共通定義のpdunit，pdstartで指定しているホスト名，ユニット識別子，又はユニット制御情報定義のpd_unit_idオペランドで指定しているユニット識別子を修正し，再度実行してください。
KFPX21207-E
System call error in JAR file synchronizer, func=aa....aa, errno=bb....bb　　（Ｓ）
システム関数aa....aaでエラーが発生しました。
aa....aa：システム関数名
bb....bb：エラーコード（errno）
(Ｓ)処理を終了します。
(Ｏ)エラーコード（errno）から，エラーの原因を調査してください。エラー要因を取り除いた後，再度実行してください。なお，エラーコードの値は，ユーザが使用するOSのマニュアルを参照してください。
KFPX21208-E
Invalid option　　（Ｓ）
コマンドラインの指定に誤りがあります。
(Ｓ)処理を終了します。
(Ｏ)正しいオプションを指定して，再度実行してください。
KFPX21209-E
JAR file "aa....aa" not found in system　　（Ｓ）
JARファイルaa....aaはHiRDBシステムにありません。
aa....aa：JARファイル名
(Ｓ)処理を終了します。
(Ｏ)指定したJARファイル名又は所有者名に誤りがないか確認してください。誤りがある場合，JARファイル名又は所有者名を修正して，再度実行してください。
KFPX24000-I
DB initialize ended, return code=aa　　（Ｓ）
データベース初期設定ユティリティの処理が，次に示すリターンコードの内容で終了しました。
aa：リターンコード
0：正常終了
4：警告レベルのエラーがありましたが，処理は終了しました。
8：データベース初期設定ユティリティ実行時にエラーが発生しましたが，初期化は終了しています。HiRDBを一度終了した後，再度HiRDBを開始してください。
12：データベース初期設定ユティリティ実行時にエラーが発生しました。メッセージを参照してエラーの原因を取り除き，再度実行してください。
(Ｓ)処理を終了します。
KFPX24001-E
Insufficient memory on PROCESS, size=aa....aa　　（Ｌ）
データベース初期設定ユティリティ実行時にプロセス固有領域を確保しようとましたが，メモリが不足したため確保できません。
aa....aa：確保しようとした領域サイズ（単位：バイト）
(Ｓ)処理を終了します。
[対策]プロセス数を見直し，再度実行してください。繰り返し発生する場合は，保守員に連絡してください。
KFPX24002-E
System call error, func=aa....aa, errno=bbbb　　（Ｌ）
システム関数aa....aaを実行しましたが，エラーが発生しました。
aa....aa：実行した関数
bbbb：エラーコード（errno）
(Ｓ)処理を終了します。
[対策]エラーコードに従って，エラーの原因を取り除き，再度実行してください。
KFPX24003-E
Message output failed, return code=aa....aa, msgno=bbbbb　　（Ｓ）
メッセージをログファイルに出力しようとしましたが，リターンコードaa....aaで終了しました。
aa....aa：システム関連エラーの詳細コード
bbbbb：出力しようとしたメッセージ番号
(Ｓ)処理を終了します。
[対策]「システム関連エラーの詳細コード」を参照し，エラーの原因を取り除いて再度実行してください。
KFPX24004-E
Control statement file open failed : aa....aa　　（Ｌ）
aa....aaの理由で，制御情報ファイルのオープンに失敗しました。
aa....aa：オープンに失敗した原因
errno = bbbb：エラーコードbbbbで終了しました。
no such file：ファイルがありません。
permission denied：ファイルはありますが権限がありません。
(Ｓ)処理を終了します。
[対策]エラーの原因を取り除き，再度実行してください。制御情報のファイルは，ディクショナリサーバ（DS）にあるファイルの絶対パス名を指定してください。
KFPX24005-E
Line aaaa:HiRDB file name unable to start with "pl"　　（Ｌ）
HiRDBファイル名称にplで始まる名称を指定できません。
aaaa：行番号
(Ｓ)処理を終了します。
[対策]HiRDBファイル名称をpl以外で始まる名称に修正して，再度実行してください。
KFPX24006-E
Line aaaa:double quotations missing　　（Ｌ）
ファイル名称に引用符号（"）が指定されていません。
aaaa：行番号
(Ｓ)すべての制御文を解析した後，処理を終了します。
[対策]ファイル名称に引用符号（"）を指定した後，再度実行してください。
KFPX24007-E
Line aaaa:number of bb....bb operands exceed the server limit cccc　　（Ｌ）
bb....bbオペランドの個数が，一つのサーバに指定できる最大値ccccを超えました。
aaaa：行番号
bb....bb：オペランド名
cccc：オペランドの最大値
(Ｓ)すべての制御文を解析した後，処理を終了します。
(Ｏ)bb....bbオペランドの数を最大値以下に修正し，再度実行してください。
KFPX24008-E
Interprocess communication failed, return code=aaaa　　（Ｌ）
データベース初期設定ユティリティ終了の報告時に通信エラーが発生しました。
aaaa：システム関連エラーの詳細コード
(Ｓ)処理を終了します。
[対策]「システム関連エラーの詳細コード」を参照し，エラーの原因を取り除き，再度実行してください。又は，初期設定は終了しているので，一度HiRDBを終了させて再度HiRDBを開始してください。
KFPX24009-W
Line aaaa:bb....bb assumed for page size　　（Ｌ）
ページ長bb....bb以外は指定できないRDエリアに，bb....bb以外の値を指定しました。このため，bb....bbを仮定しました。
aaaa：行番号
bb....bb：仮定したページ長
(Ｓ)処理を続行します。
[対策]create rdarea文のpageオペランドのページ長をbb....bbに修正してください。
〈マスタディレクトリ用RDエリア，又はデータディレクトリ用RDエリアの場合〉
ページ長を4096にしてください。
〈LOB用RDエリアの場合〉
ページ長を8192にしてください。
KFPX24010-E
RPC "aa....aa" failed, return code=bb....bb,svname=cc....cc　　（Ｌ）
RPCのaa....aaがエラーコードbb....bbで終了しました。
aa....aa：RPCの機能
callv：通信の発進
reply：通信の受信
bb....bb：エラーコード
cc....cc：サーバ識別子
(Ｓ)処理を終了します。
[対策]「RPC関連エラーの詳細コード」を参照し，エラーの原因を取り除いて再度実行してください。
KFPX24011-W
Line aaaa:dictionary server name assumed　　（Ｌ）
指定されたディクショナリサーバ名はありません。定義されているディクショナリサーバ名を仮定します。
aaaa：行番号
(Ｓ)処理を続行します。
KFPX24012-I
DB initialize start at aa....aa on bb....bb　　（Ｌ）
データベース初期設定ユティリティを開始しました。
aa....aa：開始時間 hh：mm：ss(hh：時 mm：分 ss：秒)
bb....bb：開始年月日 yyyy/mm/dd（yyyy：年 mm：月 dd：日）
(Ｓ)処理を続行します。
KFPX24013-I
DB initialize ended return code=aa at bb....bb on cc....cc　　（Ｌ）
データベース初期設定ユティリティがaaのリターンコードで終了しました。
aa：リターンコード
0：正常終了
4：警告レベルのエラーがありましたが処理は終了しました。
8：初期化は正常に終了しましたが，初期化の終了時にの通信が発生しました。一度HiRDBを終了した後，再度開始してください。
12：異常終了しました。出力されているエラーメッセージを参照し，原因を取り除いた後再度実行してください。
bb....bb：終了時間 hh：mm：ss（hh：時 mm：分 ss：秒）
cc....cc：終了年月日 yyyy/mm/dd（hhhh：年 mm：月 dd：日）
(Ｓ)処理を終了します。
KFPX24014-E
HiRDB system "aa....aa" failed, return code=bb....bb　　（Ｌ）
aa....aa機能がbb....bbのリターンコードで終了しました。
aa....aa：機能名称
besinf：バックエンドサーバ情報取得
branchdel：トランザクションブランチの登録の削除
branchreg：トランザクションブランチの登録
dicinf：ディクショナリサーバ情報取得
getpath：DBPATH取得
mainloop：RPCサービス実行
open：RPCサーバ初期化
bb....bb：システム関連エラーの詳細コード
(Ｓ)処理を終了します。
[対策]「システム関連エラーの詳細コード」を参照し，エラーの原因を取り除き，再度実行してください。
KFPX24015-E
Putenv failed, due to insufficient memory on PROCESS　　（Ｌ）
環境変数の設定をしましたが，領域不足のためエラーで終了しました。
(Ｓ)処理を終了します。
(Ｐ)プロセス数を見直し，再度実行してください。繰り返し発生する場合は，保守員に連絡してください。
KFPX24016-E
RPC service failed, no such communication id, return code=aa....aa　　（Ｌ）
RPCの通信がエラーコードaa....aaで終了しました。ただし，どのサーバに対する通信がエラーになったのかは，分かりません。
aaaa：エラーコード
(Ｓ)処理を終了します。
[対策]「RPC関連エラーの詳細コード」を参照し，エラーの原因を取り除き，再度実行してください。
又は，このメッセージの前にほかのメッセージが出力されているときは，そのメッセージを参考にしてエラーの原因を取り除き，再度実行してください。
KFPX24017-E
HiRDB file "aa....aa" failed, return code=bb....bb, HiRDB file name=cc....cc　　（Ｌ）
HiRDBファイルcc....ccに対するaa....aaがリターンコードbb....bbで終了しました。
aa....aa：HiRDBファイルシステムの機能
close：HiRDBファイルのクローズ
create：HiRDBファイルの作成
write：HiRDBファイルへの書き込み
statfs：HiRDBファイルシステム領域の情報取得
bb....bb：エラーコード
cc....cc：HiRDBファイル名称
(Ｓ)処理を終了します。
[対策]「HiRDBファイルシステムに対するアクセス要求から返されるエラーコード」を参照して，エラーの原因を取り除き，再度実行してください。
KFPX24018-E
Masterdirectory 1st file name invalid, name = "aa....aa"　　（Ｌ）
マスタディレクトリ用RDエリアの第一ファイル名称aa....aaは，システム共通定義で指定している第一ファイル名称と異なります。
aa....aa：指定されたマスタディレクトリ用RDエリアの第一ファイル名称
(Ｓ)処理を終了します。
[対策]制御文の中で指定したマスタディレクトリ用RDエリアの第一ファイル名称と，システム共通定義のpd_master_file_nameで指定した名称を同じ名称にして，再度実行してください。
KFPX24019-E
View definition file open failed : aa....aa　　（Ｌ）
aa....aaに示す理由で，pdview.pddefのオープンに失敗しました。
aa....aa：オープンに失敗した原因
errno=bbbb：エラーコードbbbbで終了しました。
no such file：$PDDIR/lib/sysdef下にファイルがありません。
permission denied：ファイルはありますが，使用できる権限がありません。
(Ｓ)処理を終了します。
[対策]保守員に連絡してください。
KFPX24020-E
Number of aa....aa exceeds bb....bb　　（Ｌ）
RDエリア数又はHiRDBファイル数が，システム共通定義aa....aaの値bb....bbを超えました。
aa....aa：システム共通定義
pd_max_rdarea_no：RDエリアの最大数
pd_max_file_no：RDエリアを構成するHiRDBファイルの最大数
bb....bb：定義された値
(Ｓ)処理を終了します。
[対策]制御文の定義数をaa....aaの値よりも少なくして，再度実行してください。又は，HiRDBを一度終了させ，aa....aaの値を設定し直してから，再度実行してください。
KFPX24021-E
Control statement file invalid device(a)　　（Ｌ）
指定された制御文ファイルが不正です。
a：ファイルのエントリタイプ
OSのls -lコマンドで出力したモードのエントリと同様
(Ｓ)処理を終了します。
[対策]通常ファイルを指定して，再度実行してください。
KFPX24022-E
Line aaaa:unable to specify "bb....bb" and "cc....cc" statement at the same time in"define system" statement　　（Ｌ）
define system文には，bb....bbとcc....ccを同時に指定できません。
aaaa：行番号
bb....bb：オペランド指定値
cc....cc：オペランド指定値
(Ｓ)処理を終了します。
[対策]define system文の指定値を修正し，再度実行してください。
KFPX24024-E
Unable to send message from aa....aa to bb....bb　　（Ｌ）
ホストaa....aaとホストbb....bb間で，通信エラーが発生しました。
aa....aa：送信元ホスト名　※
bb....bb：送信先ホスト名　※
注※　系切り替え機能を使用している場合は，現用系のホスト名となります。
(Ｓ)処理を終了します。
[対策]このメッセージの前に出力されたKFPX24010-Eメッセージの処置に従ってください。ただし，物理的な通信エラーが発生していない場合は，システム定義でホスト間の関係に矛盾があると考えられます。このため，エラーが発生したホスト間の定義を見直して再度実行してください。
KFPX24025-W
Line aaaa:"bb....bb" operand ignored because cannot specified 　　（Ｌ）
オぺランドbb....bbは，指定できないので無視しました。
aaaa：行番号
bb....bb：オぺランド名
open attribute：マスタディレクトリ，データディレクトリ，データディクショナリ，データディクショナリLOB用のRDエリアには指定できません。
(Ｓ)処理を続行します。
[対策]bb....bbオペランドを削除してください。
KFPX24026-E
Line aaaa:dd....dd operand value bb....bb invalid, because HiRDB file size exceeds ccc byte　　（Ｌ）
initialオぺランドの指定値bb....bbでは，データベースとしてのHiRDBファイルの上限値cccバイトを超えて作成してしまうため，指定できません。
extensionオぺランドの指定値bb....bbでは，自動増分後，データベースとしてのHiRDBファイルの上限値cccバイトを超えて作成してしまうため，指定できません。
aaaa：行番号
bb....bb：指定値
ccc：上限値
64G：64ギガバイト（Windows NTの場合は2ギガバイト）
dd....dd：指定オペランド
initial：initialオペランド
extension：extensionオペランド
(Ｓ)すべての制御文を解析した後，処理を終了します。
[対策]制御文のオペランドの指定値を小さく変更して，再度実行してください。
KFPX24028-W
line aaaa:max entries raised to bb....bb　　（Ｌ）
create rdarea文のmax entriesオペランドの指定値が500の倍数でないため，bb....bbに切り上げました。max entriesオペランドは，リスト用RDエリアに作成できる最大リスト数を指定するオペランドです。
aaaa：行番号
bb....bb：切り上げた値
(Ｓ)処理を続行します。
KFPX24029-W
Extension use specification for RDAREA aa....aa ignored, due to no expand option for HiRDB file system area of last HiRDB file　　（Ｌ）
RDエリアaa....aaを構成する最後のHiRDBファイルを作成したHiRDBファイルシステム領域に，増分指定（pdfmkfsコマンドの-eオプション）がされていないため，extension useは無効になります。
aa....aa：RDエリア名
(Ｓ)処理を続行します。
[対策]自動増分機能を使用する場合は，該当するHiRDBファイルシステム領域に増分指定をする必要があります。pdfmkfsコマンドの-eオプションで最大増分回数を指定してください。
KFPX24030-E
Unable to create shared RDARED aa....aa due to not apecified pd_shared_rdarea_use=Y　　（Ｌ）
pd_shared_rdarea_useオペランドにYが指定されていないため，共用RDエリアaa....aaを作成できません。
aa....aa：RDエリア名
(Ｓ)処理を終了します。
[対策]HiRDBを一度停止し，pd_shared_rdarea_useオペランドにYを設定してから再度実行してください。
KFPX24200-I
DB modification ended, return code=aa　　（Ｓ）
データベース構成変更ユティリティの処理が，aaのリターンコードで終了しました。
aa：リターンコード
0：正常終了
4：警告レベルのエラーがありましたが，処理は終了しました。
8：一部の処理が正常に終了しました。エラーとなった部分の原因を取り除き，再度エラーとなった部分だけを実行してください。
12：異常終了しました。出力されているエラーメッセージを参照し，原因を取り除いた後，再度実行してください。
16：データベースを破壊しました。データベースを回復する必要があります。
(Ｓ)処理を終了します。
KFPX24201-E
Insufficient memory on PROCESS, size=aa....aa　　（Ｌ）
データベース構成変更ユティリティ実行時にプロセス固有領域を確保しようとしましたが，メモリが不足したため確保できません。
aa....aa：確保しようとした領域サイズ（単位：バイト）
(Ｓ)処理を終了します。
[対策]プロセス数を見直し，再度実行してください。繰り返し発生する場合は，保守員に連絡してください。
KFPX24202-E
System call error, func=aa....aa, errno=bbbb　　（Ｌ）
システム関数aa....aaを実行しましたが，エラーが発生しました。
aa....aa：実行した関数
bbbb：エラーコード（errno）
(Ｓ)処理を終了します。
[対策]エラーコードに従って，エラーの原因を取り除き，再度実行してください。
KFPX24203-E
Message output failed, return code=aa....aa, msgno=bbbbb　　（Ｓ）
メッセージをログファイルに出力しようとしたが，リターンコードaa....aaで終了しました。
aa....aa：システム関連エラーの詳細コード
bbbbb：出力しようとしたメッセージ番号
(Ｓ)処理を終了します。
[対策]「システム関連エラーの詳細コード」を参照し，エラーの原因を取り除いて再度実行してください。
KFPX24204-E
Control statement file open failed : aa....aa　　（Ｌ）
aa....aaの理由で，制御情報ファイルのオープンに失敗しました。
aa....aa：オープンに失敗した原因
errno = bbbb：エラーコードbbbbで終了しました。
no such file：ファイルがありません。
permission denied：ファイルはありますが権限がありません。
(Ｓ)処理を終了します。
[対策]エラーの原因を取り除き，再度実行してください。
KFPX24205-E
Line aaaa:HiRDB file name unable to start with "pl"　　（Ｌ）
HiRDBファイル名称に，plで始まる名称は指定できません。
aaaa：行番号
(Ｓ)該当するRDエリアの構成変更処理を中止して，次の制御文の処理を続行します。
[対策]HiRDBファイル名称をpl以外で始まる名称に修正して，再度実行してください。
KFPX24206-E
Line aaaa:double quotations missing　　（Ｌ）
ファイル名称に引用符号（"）が指定されていません。
aaaa：行番号
(Ｓ)すべての制御情報ファイルを解析した後，処理を終了します。
[対策]引用符号（"）を指定した後，再度実行してください。
KFPX24207-E
Line aaaa:number of bb....bb operands exceed the server limit cccc　　（Ｌ）
bb....bbオペランドの個数が，一つのサーバに指定できる最大値ccccを超えました。
aaaa：行番号
bb....bb：オペランド名
cccc：オペランドの最大値
(Ｓ)すべての制御情報ファイルを解析した後，処理を終了します。
[対策]bb....bbオペランドの数を最大値以下に修正し，再度実行してください。
KFPX24208-E
Work file open failed, aa....aa　　（Ｌ）
作業用ファイルのオープン処理でエラーが発生しました。
aa....aa：エラーの原因
errno=bbbb：エラーコードbbbbで終了しました。
no such file：ファイルがありません。
permission denied：ファイルはありますが権限がありません。
(Ｓ)処理を終了します。
[対策]$PDDIR/tmp下に作成されるファイルを参照して，エラーの原因を取り除き，再度コマンドを実行してください。
KFPX24209-W
Line aaaa:bb....bb assumed for page size　　（Ａ）
ページ長bb....bb以外は指定できないRDエリアに，bb....bb以外の値を指定しました。このため，bb....bbを仮定しました。
aaaa：行番号
bb....bb：仮定したページ長
(Ｓ)処理を続行します。
(Ｐ)create rdarea文のpageオペランドのページ長をbb....bbに修正してください。LOB用RDエリアのページ長は8192です。
KFPX24210-E
RPC "aaaaa" failed, return code=bb....bb,svname=cc....cc　　（Ｌ）
サーバcc....ccに対するRPCのaaaaaがエラーコードbb....bbで終了しました。
aaaaa：RPCの機能
callv：通信の発信
reply：通信の受信
bb....bb：RPC関数詳細のエラーコード
cc....cc：サーバ識別子
(Ｓ)処理を終了します。
[対策]「RPC関連エラーの詳細コード」を参照し，エラーの原因を取り除いて再度実行してください。
KFPX24211-W
Line aaaa:dictionary server name assumed　　（Ｌ）
指定されたディクショナリサーバのサーバ名はありません。定義されているディクショナリサーバのサーバ名を仮定します。
aaaa：行番号
(Ｓ)処理を続行します。
KFPX24212-I
DB modification start at aa....aa on bb....bb　　（Ｌ）
データベース構成変更ユティリティを開始しました。
aa....aa：開始時間 hh：mm：ss（hh：時 mm：分 ss：秒）
bb....bb：開始年月日 yyyy/mm/dd（yyyy：年 mm：月 dd：日）
(Ｓ)処理を続行します。
KFPX24213-I
DB modification for ended return code=aa at bb....bb on cc....cc　　（Ｌ）
データベース構成変更ユティリティがaaのリターンコードで終了しました。
aa：リターンコード
0：正常終了
4：警告レベルのエラーがありましたが処理は終了しました。
8：一部の処理が正常に終了しました。エラーの原因を取り除き，再度エラーとなった部分だけを実行してください。
12：異常終了しました。出力されているエラーメッセージを参照し，原因を取り除いた後再度実行してください。
16：データベースが不整合となりました。データベースを回復する必要があります。
bb....bb：終了時間 hh：mm：ss（hh：時 mm：分 ss：秒）
cc....cc：終了年月日 yyyy/mm/dd（yyyy：年 mm：月 dd：日）
(Ｓ)処理を終了します。
KFPX24214-E
HiRDB system "aa....aa" failed, return code=bb....bb　　（Ｌ）
aa....aa機能がbb....bbのリターンコードで終了しました。
aa....aa：機能名称
begin：トランザクションの開始
besinf：バックエンド・サーバ情報取得
branchdel：トランザクションブランチの登録の削除
branchreg：トランザクションブランチの登録
commit：トランザクションの終了
dicinf：ディクショナリ・サーバ情報取得
rollback：トランザクションのロールバック
getpath：DBPATH取得
bb....bb：システム関連エラーの詳細コード
(Ｓ)処理を終了します。
[対策]「システム関連エラーの詳細コード」を参照し，エラーの原因を取り除いて再度実行してください。
KFPX24215-E
Putenv failed, due to insufficient memory on PROCESS　　（Ｌ）
環境変数を設定しようとしましたが，領域不足のためエラーで終了しました。
(Ｓ)処理を終了します。
[対策]プロセス数を見直し，再度実行してください。繰り返し発生する場合は，保守員に連絡してください。
KFPX24216-E
RPC service failed, no such communication id, return code=aa....aa　　（Ｌ）
RPCの通信が，aa....aaのリターンコードで終了しました。ただし，通信IDが分からないので，どのサーバに対する通信がエラーになったのかは不明です。
aa....aa：RPC関連エラーの詳細コード
(Ｓ)処理を終了します。
[対策]「RPC関連エラーの詳細コード」を参照してください。また，先にほかのメッセージが出力されている場合，そのメッセージを参考にしてエラーの原因を取り除き，再度実行してください。
KFPX24217-E
HiRDB file "aa....aa" failed, return code=bb....bb, HiRDB file name=cc....cc　　（Ｌ）
HiRDBファイルcc....ccに対するaa....aaが，リターンコードbb....bbで終了しました。
aa....aa：HiRDBファイルシステムの機能
close：HiRDBファイルのクローズ
create：HiRDBファイルの作成
delete：HiRDBファイルの削除
write：HiRDBファイルへの書き込み
fstat：HiRDBファイルの情報取得
statfs：HiRDBファイルシステム領域の情報取得
bb....bb：HiRDBファイルシステムのエラーコード
cc....cc：HiRDBファイル名称
(Ｓ)
〈delete以外の場合〉
処理を終了します。
〈deleteの場合〉
処理を続行します。
[対策]
〈delete以外の場合〉
「HiRDBファイルシステムに対するアクセス要求から返されるエラーコード」を参照して，エラーの原因を取り除き，再度実行してください。
〈deleteの場合〉
「HiRDBファイルシステムに対するアクセス要求から返されるエラーコード」を参照して，エラーの原因を取り除いてください。
なお，必要がないHiRDBファイルの場合は，pdfrmコマンドで削除してください。
KFPX24218-E
Line aaaa:unknown file name "bb....bb" in used cc....cc　　（Ｌ）
追加しようとしたRDエリアのファイル"bb....bb"は，既にサーバcc....ccで使用しています。又は，システム共通定義にサーバcc....ccがないため，ファイル"bb....bb"の重複チェックができません。
aaaa：行番号
bb....bb：ファイル名称
cc....cc：サーバ名
(Ｓ)処理を終了します。
[対策]システム共通定義のサーバ定義で，初期設定した状態が変更されています。このため，定義内容を元に戻すか，追加しようとしたRDエリアのファイル名を変更してください。
KFPX24219-E
Unable to execute "pdmod" at the same time　　（Ｌ）
データベース構成変更ユティリティと同時に実行できないユティリティが実行中です。次に示す場合では，データベース構成変更ユティリティを実行できません。
・既にデータベース構成変更ユティリティが実行中の場合
・ディクショナリを再編成している場合
(Ｓ)処理を終了します。
[対策]データベース構成変更ユティリティと同時に実行できないユティリティが終了した後，再度実行してください。
KFPX24220-E
Number of aa....aa exceeds bb....bb[, server name=cc....cc]　　（Ｌ）
RDエリア数，HiRDBファイル数，又はインナレプリカ最大グループ数がシステム共通定義のaa....aaオペランドの値bb....bbを超えました。
aa....aa：システム共通定義のオペランド
pd_max_file_no：RDエリアを構成するHiRDBファイルの最大数
pd_max_rdarea_no：RDエリアの最大数
pd_inner_replica_control：インナレプリカ最大グループ数
bb....bb：定義されている値
cc....cc：サーバ名（共用RDエリアの場合だけ出力されます）
(Ｓ)該当するRDエリアの構成変更処理を中止して，次の制御情報ファイルの処理を続行します。
[対策]HiRDBを一度終了させて，システム共通定義のaa....aaの値を修正してから，再度実行してください。
KFPX24221-E
Control statement file invalid device(a)　　（Ｌ）
指定された制御文ファイルが不正です。
a：ファイルのエントリタイプ
OSのls -lコマンドで出力したモードのエントリと同様
(Ｓ)処理を終了します。
[対策]通常ファイルを指定して，再度実行してください。
KFPX24222-E
Too small page size aa....aa for bb....bb cc....cc, ddddd name=ee....ee.ff....ff　　（Ｌ）
変更したページ長aa....aaでは，FIX表又はインデクスee....ee.ff....ffを格納できません。
aa....aa：変更したページサイズ
bb....bb：長さの種別
row length：行長
key length：キー長
cc....cc：行の長さ（単位：バイト）
dd....dd：名称種別
TABLE：FIX表
INDEX：インデクス
ee....ee：認可識別子
ff....ff：表識別子又はインデクス識別子
(Ｓ)処理を終了します。
[対策]次に示す条件を満たすページ長を指定して再度実行してください。
行長≦↓RDエリアのページ長÷1000↓×1000
キー長≦MIN（（RDエリアのページ長÷２）－1240，4036）
KFPX24223-E
RDAREA aa....aa not specified　　（Ｌ）
制御文中に，RDエリアaa....aaの指定がありません。
aa....aa：RDエリア名
(Ｓ)処理を終了します。
[対策]serverオペランドに，RDエリアaa....aaを指定するか，又はothersを指定して，再度実行してください。
KFPX24224-E
Unable to send message from aa....aa to bb....bb　　（Ｌ）
ホストaa....aaとホストbb....bb間で，通信エラーが発生しました。
aa....aa：送信元ホスト名　※
bb....bb：送信先ホスト名　※
注※　系切り替え機能を使用している場合は，現用系のホスト名となります。
(Ｓ)処理を終了します。
[対策]このメッセージの前に出力されたKFPX24210-Eメッセージの処置に従ってください。ただし，物理的な通信エラーが発生していない場合は，システム定義でホスト間の関係に矛盾があると考えられます。このため，エラーが発生したホスト間の定義を見直して再度実行してください。
KFPX24225-I
Processing of aa....aa statement ended, RDAREA name="bb....bb"　　（Ｌ）
RDエリアbb....bbに対するデータベース構成変更ユティリティの処理aa....aaが終了しました。
ただし，KFPX24226-Iが出力されるまで，トランザクションは完結しません。このため，KFPX24226-Iのリターンコードが8の場合，処理がロールバックされます。
aa....aa：データベース構成変更ユティリティの機能
create rdarea：RDエリアの追加
bb....bb：RDエリア名称
(Ｓ)処理を続行します。
KFPX24226-I
Processing of create rdarea statements ended return code=a　　（Ｌ）
データディクショナリ用RDエリア，又はレジストリ用RDエリアの追加処理が，aのリターンコードで終了しました。
a：リターンコード
0：正常終了
4：警告レベルのエラーはありましたが処理は終了しました。
8：異常終了しました。このメッセージの前に出力されているエラーメッセージを参照し，原因を取り除いた後，再度実行してください。
(Ｓ)処理を終了します。
KFPX24227-E
Line aaaa:unable to specify bb....bb and cc....cc statement at the same time　　（Ｌ）
データベース構成変更ユティリティの機能bb....bbとcc....ccは同一の制御文ファイル中に指定できません。
aaaa：行番号
bb....bb：データベース構成変更ユティリティの機能
alter HiRDB mode：HiRDB/シングルサーバ構成からHiRDB/パラレルサーバ構成へのRDエリアの変更
alter rdarea：RDエリアの変更
alter system：システム定義の変更
create rdarea：RDエリアの追加
expand rdarea：RDエリアの拡張
initialize rdarea：RDエリアの再初期化
remove rdarea：RDエリアの削除
cc....cc：データベース構成変更ユティリティの機能
create rdarea for system：データディクショナリ用RDエリア，データディクショナリLOB用RDエリアの追加
(Ｓ)処理を終了します。
[対策]同一の制御文ファイルに指定できない機能を別々の制御文ファイルにして，再度別々に実行してください。
KFPX24228-E
Unable to omit DATADICTIONARY LOB RDAREA　　（Ｌ）
データディクショナリLOB用RDエリアを追加する制御文が指定されていません。
次に示す場合は，LOB used by HiRDB（SQL_ROUTINES）指定のデータディクショナリLOB用RDエリアを同一の制御文ファイルで2個追加してください。
・datadictionary of routines指定のRDエリアを追加する場合
・LOB used by HiRDB（SQL_ROUTINES）指定のデータディクショナリLOB用RDエリアを追加する場合
(Ｓ)処理を終了します。
[対策]LOB used by HiRDB（SQL_ROUTINES）指定のRDエリアを同一の制御文中に2個定義して，再度実行してください。
KFPX24229-E
Control statement for create rdarea in system must first statment of control statement file　　（Ｌ）
データディクショナリ用RDエリア，又はデータディクショナリLOB用RDエリアを追加する制御文は，制御文ファイルの先頭から記述する必要があります。
(Ｓ)処理を終了します。
[対策]データディクショナリ用RDエリア又はデータディクショナリLOB用RDエリアを追加する制御文を制御文ファイルの先頭に記述して，再度実行してください。
KFPX24230-E
Line aaaa:unable to create rdarea due to already exist RDAREA type　　（Ｌ）
追加しようとしたRDエリアのRDエリア種別は，既にシステム内にあります。
aaaa：行番号
(Ｓ)処理を終了します。
[対策]不要な制御文を削除して，再度実行してください。
KFPX24231-W
Unable to initialize LOB column aa....aa.bb....bb due to cc....cc, RDAREA name="dd....dd"　　（Ｌ）
cc....ccの理由で，LOB列構成基表aa....aa.bb....bbのLOB列を格納しているRDエリアdd....ddに対する初期化処理ができません。
aa....aa：認可識別子
bb....bb：表識別子
cc....cc：エラーの理由
RDAREA status is invalid：RDエリアの状態が不正です。
HiRDB system error occurred：SQLエラーです。
dd....dd：ユーザLOB用RDエリア名
(Ｓ)該当するユーザLOB用RDエリアの初期化処理を中断して，次の処理を続行します。
[対策]次に示すどれかを実施してください。
・ユーザLOB用RDエリアdd....ddをHOLD，CLOSE状態にした後，dd....ddを再初期化
・cc....ccの原因を取り除いた後，この制御文を再度実行
・LOB列構成基表のpurge tableを実行
なお，この処置をしないで，表aa....aa.bb....bbに検索，又は挿入をした場合，LOB列データが削除されていないため，その結果は保証されません。
KFPX24232-E
Unable to initialize rdarea "aa....aa" allocated for SQL_ROUTINES.DEF_SOURCE　　（Ｌ）
RDエリアaa....aaは，データディクショナリ表SQL_ROUTINESのDEF_SOURCE列に割り当てられているデータディクショナリLOB用RDエリアのため，再初期化はできません。
aa....aa：データディクショナリLOB用RDエリア名
(Ｓ)処理を終了します。
[対策]データディクショナリLOB用RDエリアの再初期化はオブジェクトを格納しているRDエリアだけで実行してください。
KFPX24233-E
Definition file aa....aa open failed : bb....bb　　（Ｌ）
bb....bbの理由で$PDDIR/lib/sysdef下にある定義ファイルaa....aaのオープンに失敗しました。
aa....aa：ファイル名称
bb....bb：オープンに失敗した原因
no such file：$PDDIR/lib/sysdef下にファイルがありません。
permission denied：ファイルはありますが，権限がありません。
errno=cccc：エラーコードccccで終了しました。
(Ｓ)処理を終了します。
[対策]保守員に連絡してください。
KFPX24234-E
Unable to execute "cc....cc" in "alter system" statement due to exist view table derived from DATADICTIONARY, view table name "aa....aa".bb....bb　　（Ｌ）
ディクショナリ表を参照しているビュー表があります。このため，alter　system文のcc....ccオペランドは実行できません。ディクショナリ表を参照しているビュー表は，すべて削除する必要があります。
aa....aa：認可識別子
bb....bb：ビュー表名
cc....cc：オペランド名
(Ｓ)処理を終了します。
[対策]ディクショナリ表を参照しているビュー表を削除してから再度実行してください。なお，ディクショナリ表を参照しているビュー表名を調査する場合，次に示すSQL文を実行してください。
SELECT VIEW_SCHEMA,VIEW_NAME
FROM MASTER.SQL_VIEW_TABLE_USAGE
WHERE BASE_OWNER='MASTER'
KFPX24235-E
Line aaaa:unable to specify "dicinf limited" due to "HiRDB security "is "no"　　（Ｌ）
HiRDBの機密保護機能を使用していないため，alter system文
にdicinf limitedは指定できません。
aaaa：行番号
(Ｓ)処理を終了します。
[対策]dicinf limitedを指定する場合，HiRDB security yesを指定してデータベース初期設定ユティリティから実行し直してください。
KFPX24236-E
Unable to execute "aa....aa" in "alter system" due to UAP and/or utility is executing　　（Ｌ）
実行中のUAP又はユティリティがあるため，alter system文のaa....aaオペランドは実行できません。
aa....aa：オペランド名
(Ｓ)処理を終了します。
[対策]ディクショナリ表にアクセスしているUAP又はユティリティがすべて終了してから，再度実行してください。
KFPX24237-I
Dicinf mode change to aa....aa　　（Ｌ）
dicinfをaa....aaに変更しました。
aa....aa：変更した種別
limited：ディクショナリ表の参照に制限があります。
unlimited：ディクショナリ表の参照に制限がありません。
(Ｓ)処理を終了します。
[対策]ディクショナリ表にアクセスしているUAP又はユティリティがすべて終了してから，再度実行してください。
KFPX24238-W
SQL OBJECT of procedure "aa....aa".bb....bb invalidated　　（Ｌ）
手続き"aa....aa".bb....bbのSQLオブジェクトを無効にしました。
aa....aa：認可識別子
bb....bb：ルーチン識別子
(Ｓ)処理を続行します。
[対策]手続き"aa....aa".bb....bbのSQLオブジェクトをALTER PROCEDUREで再作成してください。認可識別子"MASTER"でルーチン識別子が"SQL_REGISTRY"で始まるプロシジャの場合は，レジストリ機能初期設定ユティリティ（pdreginit）で-k renewを指定して再作成してください。
KFPX24239-I
Dictionary datatype mchar changed to "use"　　（Ｌ）
dictionary datatype mchar オプションをuseに変更しました。
(Ｓ)処理を続行します。
KFPX24240-W
Line aaaa:"bb....bb" operand ignored because cannot specified　　（Ｌ）
オぺランドbb....bbは指定できないため無視しました。
aaaa：行番号
bb....bb：オぺランド名
open attribute：マスタディレクトリ，データディレクトリ，データディクショナリ，データディクショナリLOB用のRDエリアには指定できません。
(Ｓ)処理を続行します。
[対策]bb....bbオペランドを削除してください。
KFPX24241-E
Line aaaa:dd....dd operand value bb....bb invalid, because HiRDB file size exceeds ccc byte　　（Ｌ）
initialオぺランドの指定値bb....bbでは，データベースとしてのHiRDBファイルの上限値cccバイトを超えて作成してしまうため，指定できません。
extensionオぺランドの指定値bb....bbでは，自動増分後，データベースとしてのHiRDBファイルの上限値cccバイトを超えて作成してしまうため，指定できません。
aaaa：行番号
bb....bb：指定値
ccc：上限値
64G：64ギガバイト（Windows NTの場合は2ギガバイト）
dd....dd：指定オペランド
initial：initialオペランド
extension：extensionオペランド
(Ｓ)すべての制御文を解析した後，処理を終了します。
[対策]制御文のオペランドの指定値を小さく変更して，再度実行してください。
KFPX24242-W
Unable to aa....aa bb....bb.cc....cc due to dd....dd, RDAREA name="ee....ee"　　（Ｌ）
bb....bb.cc....ccの格納RDエリアee....eeに対するaa....aaの処理が，dd....ddの理由でできません。
aa....aa：処理種別
purge BLOB attribute：BLOB属性のデータ削除
purge PLUGIN INDEX：プラグインインデクスのデータ削除
bb....bb：認可識別子
cc....cc：表識別子又はインデクス識別子
dd....dd：エラーの理由
RDAREA status is invalid：RDエリア状態不正
HiRDB system error occurred：SQLエラー
ee....ee：RDエリア名称
(Ｓ)該当RDエリアのaa....aaの処理をスキップし，次の処理を続行します。
[対策]RDエリア状態不正の場合は，ee....eeのRDエリアをRELEASE，OPENにして再度実行してください。SQLエラーの場合は，このメッセージの前に出力されているSQLメッセージを参照し，原因を取り除いて再度実行してください。
KFPX24243-E
Object Option required　　（Ｌ）
抽象データ型，レジストリ用RDエリア，及びレジストリLOB用RDエリアをアクセスする場合，HiRDB Object Optionが必要です。
(Ｓ)処理を終了します。
[対策]HiRDB Object Optionを組み込んでから，再度実行してください。
KFPX24244-I
Unable to delete LIST data, rdarea id = aa....aa （Ｌ）
再初期化対象RDエリアに格納されている表を基に作成した，リストデータの削除に失敗しました。
aa....aa：エラーになったリスト用RDエリアのRDエリアIDリスト
（形式）RDエリアIDを10けたで表示(9が埋め字)。区切りはコンマ（，）。
(Ｓ)処理を続行します。
(Ｐ)このメッセージに出力されているリスト用RDエリアに障害が発生している可能性があります。したがって，再初期化終了後にリストの再作成，又は削除をする場合，エラーとなる可能性があります。このメッセージの前に出力されているメッセージからエラー内容を，また，このメッセージに出力されているRDエリアIDからRDエリア名称を特定し，原因を調査してください。
KFPX24245-W
line aaaa:max entries raised to bb....bb　　（Ｌ）
create rdarea文又はinitialize rdarea文のmax entriesオペランドの指定値が500の倍数でないため，bb....bbに切り上げました。max entriesオペランドは，リスト用RDエリアに作成できる最大リスト数を指定するオペランドです。
aaaa：行番号
bb....bb：切り上げた値
(Ｓ)処理を続行します。
KFPX24246-W
Extension use specification for RDAREA aa....aa ignored, due to no expand option for HiRDB file system area of last HiRDB file　　（Ｌ）
RDエリアaa....aaを構成する最後のHiRDBファイルを作成したHiRDBファイルシステム領域に，増分指定（pdfmkfsコマンドの-eオプション）がされていないためextension useは無効になります。
aa....aa：RDエリア名
(Ｓ)処理を続行します。
[対策]自動増分機能を使用する場合は，該当するHiRDBファイルシステム領域に増分指定をする必要があります。pdfmkfsコマンドの-eオプションで最大増分回数を指定してください。
KFPX24247-E
Unable to remove generation "aa....aa" due to bb....bb　　（Ｌ）
HiRDBファイルシステム領域aa....aaは，bb....bbの理由で世代を削除できません。
aa....aa：世代削除するHiRDBファイルシステム領域名
bb....bb：理由
original HiRDB file system area：オリジナルHiRDBファイルシステム領域を指定しました。
exist replica rdarea：レプリカRDエリアが対象HiRDBファイルシステム領域を使用中です。
not defined：指定したHiRDBファイルシステム領域は世代登録されていません。
(Ｓ)処理を終了します。
[対策]HiRDBファイルシステム領域の世代情報をすべて削除すると，オリジナルHiRDBファイルシステム領域を削除できます。レプリカRDエリアがHiRDBファイルシステム領域を使用している場合は，次に示すSQL文を使用してレプリカRDエリアを確認してください。その結果，不要なレプリカRDエリアならば，レプリカRDエリアを削除した後に再度実行してください。
SELECT RDAREA_NAME
FROM MASTER.SQL_RDAREAS X,MASTER.SQL_PHYSICAL_FILES Y
WHERE X.ORIGINAL_RDAREA_ID IS NOT NULL
AND X.RDAREA_NAME = Y.RDAREA_NAME AND X.SERVER_NAME='サーバ名称'
AND Y.PHYSICAL_FILE_NAME LIKE 'HiRDBファイルシステム領域名%'
KFPX24248-E
Unable to initialize rdarea "aa....aa" due to not found replica RDAREA(generation number bb) for original RDAREA "cc....cc"　　（Ｌ）
オリジナルRDエリアcc....ccに世代番号bbのレプリカRDエリアがありません。このため，RDエリアaa....aaの再初期化でほかのRDエリアの処理が実行できません。
aa....aa：再初期化対象のRDエリア名
bb：世代番号
cc....cc：ほかのRDエリアを処理対象とするオリジナルRDエリア名
(Ｓ)処理を終了します。
[対策]対応するレプリカRDエリアを作成した後に再度実行してください。
KFPX24249-E
Unable to "aa....aa" due to generation already registerd in HiRDB file system area　　（Ｌ）
HiRDBファイルシステム領域の世代登録があるため，処理aa....aaができません。
aa....aa：処理内容
alter HiRDB mode：HiRDB/パラレルサーバへの構成変更
(Ｓ)処理を終了します。
[対策]HiRDBファイルシステム領域の世代情報をすべて削除した後に再度実行してください。
KFPX24250-E
Unable to aa....aa rdarea due to invalid replica status　　（Ｌ）
レプリカRDエリアのレプリカステータスが不正なため，処理aa....aaができません。
aa....aa：処理内容
remove：RDエリアの削除
(Ｓ)処理を終了します。
[対策]レプリカRDエリアのレプリカステータスをカレントからサブに変更した後に再度実行してください。
KFPX24251-W
Not found HiRDB file system area "aa....aa"　　（Ｌ）
レプリカHiRDBファイルシステム領域又はオリジナルHiRDBファイルシステム領域がありません。
aa....aa：HiRDBファイルシステム領域名
(Ｓ)処理を続行します。
[対策]HiRDBファイルシステム領域の世代情報は登録されているため，レプリカRDエリアを使用する前に該当するHiRDBファイルシステム領域を作成する必要があります。
KFPX24252-E
Unable to recast rdarea due to aa....aa rdarea "bb....bb" in progress　　（Ｌ）
RDエリアbb....bbがaa....aa処理中のため，RDエリアの統合ができません。
aa....aa：処理内容
initialize：RDエリアの再初期化
remove：RDエリアの削除
bb....bb：RDエリア名
(Ｓ)処理を終了します。
[対策]aa....aaの処理が終了した後に再度実行してください。
KFPX24253-E
Staticizer Option required　　（Ｌ）
HiRDBファイルシステム領域の世代登録，又はレプリカRDエリアの定義をするにはHiRDB Staticizer Optionが必要です。
(Ｓ)処理を終了します。
[対策]HiRDB Staticizer Optionをインストールした後に再度実行してください。
KFPX24254-E
Unable to replicate rdarea due to not exist table or index　　（Ｌ）
オリジナルRDエリアに表，インデクス，又はLOB列が定義されていないため，レプリカRDエリアを定義できません。
(Ｓ)処理を終了します。
[対策]対象となるオリジナルRDエリアが正しいか確認した後に再度実行してください。
KFPX24255-E
Unable to aa....aa due to not specified original RDAREA　　（Ｌ）
オリジナルRDエリアを指定していないため，aa....aaの処理ができません。
aa....aa：構成変更処理
・replicate rdarea：RDエリアの複製定義
・recast rdarea：RDエリアの統合
(Ｓ)処理を終了します。
[対策]オリジナルRDエリアを指定して再度実行してください。
KFPX24256-E
Number of replica count exceed 10,replica count limit over RDAREA aa....aa　　（Ｌ）
レプリカカウンタが最大値である10を超えました。レプリカカウンタが上限値を超えたRDエリアはaa....aaです。
aa....aa：レプリカカウンタが上限値を超えたRDエリアの名称（オリジナルRDエリア）
(Ｓ)処理を終了します。
[対策]オリジナルRDエリアのレプリカ定義数を確認した後に再度実行してください。
KFPX24257-E
Unable to define copy rdarea due to specified RDAREA aa....aa invalid original RDAREA/replica RDAREA　　（Ｌ）
指定したRDエリアaa....aaはオリジナルRDエリア及びレプリカRDエリアのどちらでもないため，RDエリアの構成情報複写ができません。
aa....aa：RDエリア名
(Ｓ)処理を終了します。
[対策]指定したRDエリアが正しいか確認してください。オリジナルRDエリア又はレプリカRDエリアのどちらかを指定して再度実行してください。
KFPX24258-E
Unable to define copy rdarea due to invalid sameness original RDAREA　　（Ｌ）
複写先と複写元に指定したRDエリアのオリジナルRDエリアが同じでないため，RDエリアの構成情報が複写できません。
(Ｓ)処理を終了します。
[対策]複写先と複写元に指定したRDエリアのオリジナルRDエリア名を確認して再度実行してください。
KFPX24259-E
Unable to aa....aa due to create generation invalid HiRDB file system area　　（Ｌ）
HiRDBファイルシステム領域の世代登録をしていないため，この処理aa....aaはできません。
aa....aa：構成変更処理
replicate rdarea：RDエリアのレプリカ定義
define copy rdarea：RDエリアの構成情報複写
(Ｓ)処理を終了します。
[対策]HiRDBファイルシステム領域の世代登録をした後に再度実行してください。
KFPX24260-E
Unable to recast rdarea due to invalid original RDAREA replica count 1　　（Ｌ）
オリジナルRDエリアのレプリカカウンタが1でないため，RDエリアを統合できません。
(Ｓ)処理を終了します。
[対策]オリジナルRDエリアのレプリカカウンタ数を確認て再度実行してください。
KFPX24261-I
HiRDB system must restarted　　（Ｌ）
RDエリアの移動をした後は，必ずHiRDBシステムを再開始してください。
(Ｓ)処理を続行します。
[対策]HiRDBシステムを再開始してください。
KFPX24262-E
Line:aaaa:unable to move rdarea "bb....bb" due to lack of specification for related RDAREA "cc....cc"　　（Ｌ）
関連するRDエリアcc....ccが指定されていないため，RDエリアbb....bbの移動ができません。
aa....aa：行番号
bb....bb：移動対象のRDエリア
cc....cc：関連するRDエリア
(Ｓ)該当する制御文の解析を終了した後に処理を終了し，次の制御文の処理を開始します。
[対策]関連するRDエリアをすべて指定して，再度実行してください。
KFPX24263-E
Line aaaa:unable to move rdarea "bb....bb" due to rdarea in different server　　（Ｌ）
異なるバックエンドサーバのRDエリアbb....bbが指定されたため，RDエリアの移動ができません。
aa....aa：行番号
bb....bb：RDエリア名
(Ｓ)該当する制御文の解析を終了した後に処理を終了し，次の制御文の処理を開始します。
[対策]同一サーバ内のRDエリアだけを指定して，再度実行してください。
KFPX24264-E
Line aaaa:unable to move rdarea. Source BES and destination BES identical　　（Ｌ）
移動対象RDエリアの現在のサーバ名を指定したため，RDエリアの移動ができません。
aa....aa：行番号
(Ｓ)該当する制御文の解析を終了した後に処理を終了し，次の制御文の処理を開始します。
[対策]移動先のサーバ名を指定し直して，再度実行してください。
KFPX24265-E
Line aaaa:unable to move rdarea "bb....bb" due to NONDIV_IDX defined, index_name=cc....cc. "dd....dd"　　（Ｌ）
指定したRDエリアbb....bbに非分割キーインデクスが定義されているため，RDエリアの移動ができません。
aa....aa：行番号
bb....bb：RDエリア名
cc....cc：認可識別子
dd....dd：インデクス識別子
(Ｓ)該当する制御文の解析を終了した後に処理を終了し，次の制御文の処理を開始します。
[対策]非分割キーインデクスを削除して，再度実行してください。
KFPX24266-E
Line aaaa:unable to move rdarea "bb....bb" due to create generation invalid HiRDB file system area　　（Ｌ）
移動先サーバに対して，指定したRDエリアbb....bbを構成するHiRDBファイルのHiRDBファイルシステム領域の世代登録をしていないため，RDエリアの移動ができません。
aa....aa：行番号
bb....bb：RDエリア名
(Ｓ)該当する制御文の解析を終了した後に処理を終了し，次の制御文の処理を開始します。
[対策]移動先サーバに対するHiRDBファイルシステム領域の世代登録をしてから，再度実行してください。
KFPX24268-E
Unable to aa....aa rdarea "bb....bb" due to exist INSERT ONLY table cc....cc.dd....dd　　（Ｌ）
RDエリアbb....bbに改竄防止表cc....cc.dd....ddが存在するため，aa....aaができません。
aa....aa：データベース構成変更ユティリティ（pdmod）の機能
initialize：RDエリアの再初期化
replicate：RDエリアのレプリカ定義
bb....bb：RDエリア名
cc....cc：認可識別子
dd....dd：表識別子
(Ｓ)該当する制御文の処理を終了し，次の制御文の処理を開始します。
[対策]RDエリアの再初期化の場合，次の処置をしてください。
・回復が必要な場合，バックアップファイルから回復してください。
・RDエリアの容量を大きくしたい場合，RDエリアの拡張（expand rdarea）又はRDエリアの自動増分で容量を大きくしてください。
KFPX24269-E
Unable to aa....aa because bb....bb already exists in HiRDB system　　（Ｌ）
bb....bbは既に登録又は作成されているためaa....aaができません。
aa....aa：データベース構成変更ユティリティの機能
・create auditor：監査人の登録
・create audit table：監査証跡表の作成
bb....bb：監査人又は監査証跡表
・auditor：監査人
・audit table：監査証跡表
(Ｓ)該当する制御文の解析を終了した後に処理を終了し，次の制御文の処理を開始します。
[対策]監査証跡表を再作成する場合は，監査人がDROP TABLEで監査証跡表を削除した後に実行してください。
KFPX24270-E
Unable to create audit table unless privilege for RDAREA "aa....aa" granted only auditor　　（Ｌ）
RDエリアaa....aaの利用権限が監査人以外のユーザにもあるため，監査証跡表を作成できません。
aa....aa：RDエリア名
(Ｓ)該当する制御文の解析を終了した後に処理を終了し，次の制御文の処理を開始します。
[対策]RDエリアの利用権限が監査人だけに与えられているユーザ用RDエリアを指定して再実行してください。
KFPX24271-E
Unable to create auditor because user "aa....aa" bb....bb　　（Ｌ）
ユーザaa....aaはbb....bbのため，監査人として登録できません。
aa....aa：ユーザ名
bb....bb：理由
has DBA privilege：ユーザaa....aaはDBA権限を既に持っています。
password account locked：ユーザaa....aaはパスワード無効アカウントロック状態です。
(Ｓ)該当する制御文の解析を終了した後に処理を終了し，次の制御文の処理を開始します。
[対策]次に示すどちらかの処置をしてください。
・理由がhas DBA privilegeの場合
次に示すどちらかの処置をしてください。
・REVOKE文でユーザのDBA権限を削除した後に再実行してください。
・DBA権限がないユーザ又は新規ユーザを指定して再実行してください。
・理由がpassword account lockedの場合
パスワード無効アカウントロック状態を解除するか，又はパスワード無効アカウントロック状態でないユーザ（新規ユーザを含む）を指定して，再実行してください。
KFPX24272-E
Unable to create audit table due to no auditor　　（Ｌ）
監査人がいないため，監査証跡表を作成できません。
(Ｓ)該当する制御文の解析を終了した後に処理を終了し，次の制御文の処理を開始します。
[対策]データベース構成変更ユティリティのcreate auditor文で監査人を登録した後に再実行してください。
KFPX24273-E
Unable to create audit table due to duplicate table name aa....aa.bb....bb　　（Ｌ）
表aa....aa.bb....bbは既にあるため，監査証跡表にこの名称を使用できません。
aa....aa：認可識別子
bb....bb：表識別子
(Ｓ)該当する制御文の解析を終了した後に次の制御文の処理を開始します。
[対策]監査証跡表をほかの名称にして再実行してください。
KFPX24274-E
Unable to create shared RDAREA aa....aa due to not specified pd_shared_rdarea_use=Y　　（Ｌ）
pd_shared_rdarea_useオペランドにYが指定されていないため，共用RDエリアaa....aaを追加できません。
aa....aa：RDエリア名
(Ｓ)該当するRDエリアの構成変更処理を中止し，次の制御文の処理を続行します。
[対策]HiRDBを一度停止し，pd_shared_rdarea_useオペランドにYを設定してから再度実行してください。
KFPX24275-E
No schema for aa....aa　　（Ｌ）
スキーマがないため，監査証跡表を作成できません。
aa....aa：スキーマがない監査人の認可識別子（8けた以内）
(Ｓ)該当するRDエリアの構成変更処理を中止し，次の制御文の処理を続行します。
[対策]create schemaでスキーマを作成してから，再度実行してください。
KFPX24400-E
HiRDB system "aa....aa" failed, return code=bb....bb　　（Ｌ）
aa....aaの機能が，bb....bbのリターンコードで終了しました。
aa....aa：機能名称
pd_com_call：通信の発信
pdi_adm_get_my_orghostname：ホスト名取得
pdi_adm_pdmgrinf：マネジャ・サーバ情報取得
pdi_adm_pddicinf：ディクショナリ・サーバ情報取得
pdi_ndm_branchreg：ブランチの登録
pdi_ndm_branchdel：ブランチの登録の削除
pdi_utl_sh_prolog：RPC環境開始
pdi_utl_sh_epilog：シェルプロセス終了
bb....bb：システム関連エラーの詳細コード
(Ｓ)処理を終了します。
[対策]「システム関連エラーの詳細コード」を参照し，エラーの原因を取り除き，再度実行してください。
KFPX24401-I
Usage:pdvrup　　（Ｅ）
pdvrupコマンドの指定方法を示します。pdvrupコマンドには，オプションはありません。
(Ｓ)処理を終了します。
[対策]コマンドの形式を修正して，再度実行してください。
KFPX24402-E
System call error, func=aa....aa, errno=bbbb　　（Ｌ）
システム関数aa....aaを実行しましたが，エラーが発生しました。
aa....aa：実行した関数
bbbb：エラーコード
(Ｓ)処理を終了します。
[対策]エラーコードを基に，エラーの原因を取り除き，再度実行してください。
KFPX24403-E
Pdvrup must be executed at unit where manager is defined　　（Ｌ）
pdvrupコマンドは，システムマネジャを定義したサーバマシンで実行してください。
(Ｓ)処理を終了します。
[対策]システムマネジャを定義したサーバマシンにリモートログインして，pdvrupコマンド実行してください。
KFPX24404-I
Pdvrup ended, return code=aa　　（Ｌ）
pdvrupコマンドが，aaのリターンコードで終了しました。
aa：リターンコード
0：正常終了しました。
4：pdvrupコマンド実行中にエラーが発生しましたが，バージョンアップは正常終了しました。HiRDBを一度終了させて，再度開始してください。
12：異常終了しました。
(Ｓ)処理を終了します。
[対策]リターンコードが12の場合は，出力されているエラーメッセージを参照し，原因を取り除いた後，再度実行してください。
KFPX24405-E
Insufficient memory on PROCESS, size=aa....aa　　（Ｌ）
pdvrupコマンドの実行時にプロセス固有領域を確保しようとしましたが，メモリ不足のため，確保できませんでした。
aa....aa：確保しようとした領域サイズ（単位：バイト）
(Ｓ)処理を終了します。
[対策]HiRDB以外のプロセスを含め，すべてのプロセス数を見直してください。不要なプロセスを削除してから再度実行してください。なお，繰り返し発生するときは，保守員に連絡してください。
KFPX24406-E
Message output failed, return code=aa....aa, msgno=bbbbb　　（Ｌ）
メッセージをログファイルに出力しようとしましたが，リターンコードaa....aaで終了しました。
aa....aa：システム関連エラーの詳細コード
bbbbb：出力しようとしたメッセージ番号
(Ｓ)処理を終了します。
[対策]「システム関連エラーの詳細コード」を参照し，エラーの原因を取り除いてください。
KFPX24407-E
Unable to execute "pdvrup" at the same time　　（Ｌ）
pdvrupコマンドが実行中のため，後から実行したpdvrupコマンドを実行できません。
(Ｓ)処理を終了します。
[対策]実行中のpdvrupコマンドの終了を待ってください。
KFPX24408-E
Pdvrup command failed, due to DATABASE Version already coincide with HiRDB version, version=aaaaa　　（Ｌ）
HiRDBのバージョンとディクショナリのバージョンが一致しているため，バージョンアップをしません。
aaaaa：バージョン番号
(Ｓ)処理を終了します。
KFPX24409-E
Pdvrup command terminated, due to server process abnormal end　　（Ｌ）
pdvrupコマンド実行中に，通信相手のサーバプロセスが異常終了しました。
(Ｓ)処理を終了します。
[対策]pdstop又はpdcancelコマンドでサーバプロセスを終了させたとき以外は，保守員に連絡してください。
KFPX24410-E
Definition file aa....aa open failed : bb....bb　　（Ｌ）
bb....bbの理由で$PDDIR/lib/sysdef下にある定義ファイルaa....aaのオープンに失敗しました。
aa....aa：ファイル名称
bb....bb：オープンに失敗した原因
no such file：$PDDIR/lib/sysdef下にファイルがありません。
permission denied：ファイルはありますが，権限がありません。
errno=cccc：エラーコードccccで終了しました。
(Ｓ)処理を終了します。
[対策]保守員に連絡してください。
KFPX24600-I
Pdreginit command start at aa....aa on bb....bb　　（Ｓ）
レジストリ機能初期設定ユティリティを開始しました。
aa....aa：開始時間（hh：mm：ss）
hh：時
mm：分
ss：秒
bb....bb：開始年月日（yyyy／mm／dd）
yyyy：年
mm：月
dd：日
(Ｓ)処理を続行します。
KFPX24601-I
Pdreginit command for ended return code=a at bb....bb on cc....cc　　（Ｓ）
レジストリ機能初期設定ユティリティがaのリターンコードで終了しました。
a：リターンコード
0：正常終了しました。
4：警告レベルのエラーがありましたが，処理は終了しました。
8：異常終了しました。このメッセージの前に出力されているエラーメッセージを参照し，原因を取り除いた後，再度実行してください。
bb....bb：開始時間（hh：mm：ss）
hh：時
mm：分
ss：秒
cc....cc：開始年月日（yyyy／mm／dd）
yyyy：年
mm：月
dd：日
(Ｓ)処理を終了します。
KFPX24602-E
Invalid option is specified with pdreginit command　　（Ｓ）
pdreginitコマンドでは指定できないオプションを指定しています。又は，オプションの引数が指定されていません。
(Ｓ)処理を終了します。
[対策]正しいオプションを指定するか，又はオプションの引数を指定して，再度実行してください。
KFPX24603-I
Usage: pdreginit [-k {all|proc|renew} ] [-a statement_control_file_name]　　（Ｓ）
レジストリ機能初期設定ユティリティ（pdreginit）のオプションの指定形式に誤りがあります。
(Ｓ)処理を終了します。
[対策]pdreginitの正しい指定方法に従って，再度実行してください。
KFPX24604-E
No RDAREA for routine definition　　（Ｓ）
データディクショナリLOB用RDエリアが定義されていません。そのため，レジストリ用RDエリア，及びレジストリLOB用RDエリアが追加できません。
(Ｓ)処理を終了します。
[対策]データベース構成変更ユティリティ（pdmod）で，データディクショナリLOB用RDエリアを定義した後，再度実行してください。
KFPX24605-E
EXEC SQL aa....aa Error　　（Ｓ）
aa....aaで示すSQL文がエラーとなりました。
aa....aa：実行したSQL文
(Ｓ)処理を終了します。
[対策]このメッセージの後に出力されているエラーメッセージを基にエラーの原因を取り除いた後，再度実行してください。
KFPX24606-E
Unable to omit registry RDAREA or registry LOB RDAREA　　（Ｌ）
レジストリ用RDエリア又はレジストリLOB用RDエリアを追加する制御文が指定されていません。
for registry指定のRDエリア，又はfor LOB used by HiRDB（SQL_REGISTRY）指定のRDエリアを追加する場合は，両方指定する必要があります。
(Ｓ)処理を終了します。
[対策]for registry指定のRDエリアとfor LOB used by HiRDB（SQL_REGISTRY）指定のRDエリアを同一制御文ファイル中に定義して，再度実行してください。
KFPX24607-E
Object Option required　　（Ｓ）
HiRDB Object Optionが必要です。
(Ｓ)処理を終了します。
[対策]HiRDB Object Optionを組み込んでから，再度実行してください。
KFPX28400-I
aa....aa process started　　（Ｌ＋Ｓ）
aa....aaの処理を開始しました。
aa....aa：処理内容{ Export | Import | Create DDL}
(Ｓ)処理を続行します。
KFPX28401-I
aa....aa process terminated　　（Ｌ＋Ｓ）
aa....aaの処理を終了しました。
aa....aa：処理内容{ Export | Import | Create DDL}
(Ｓ)処理を続行します。
KFPX28402-I
aa....aa, name="bb....bb"."cc....cc"　　（Ｌ＋Ｓ）
表bb....bb.cc....cc，ストアドプロシジャbb....bb.cc....cc，又はトリガbb....bb.cc....ccを，搬出又は搬入しました。又は，定義系SQL文を生成しました。
aa....aa：実行した処理
｛Procedure exported｜Procedure imported｜Table exported｜Table imported｜Trigger exported｜Trigger imported｜DDL Created｝
bb....bb：スキーマ名（パブリックビューの搬出入の場合はPUBLICとなります）
cc....cc：表識別子，ルーチン識別子又はトリガ識別子
(Ｓ)処理を続行します。
KFPX28403-E
HiRDB call error, func=aa....aa, errno=bb....bb　　（Ｅ＋Ｓ＋Ｌ）
ユティリティとHiRDB本体との制御処理で，エラーが発生しました。
aa....aa：エラーが発生した処理
｛connect｜disconnect｜commit｜rollback｝そのほかの場合，HiRDBの処理種別です。
bb....bb：エラー詳細コード
(Ｓ)処理を終了します。
(Ｏ)次のどちらかの処置を取ってください。なお，オペレータが対処できないエラーが発生している場合は，HiRDB管理者に連絡してください。
〈このメッセージの前にメッセージが出力されている場合〉
そのメッセージに従って対処してください。
〈このメッセージの前にメッセージが出力されていない場合〉
「エラー詳細コード一覧」を参照し，エラーの原因を取り除いた後，再度コマンドを実行してください。
KFPX28404-E
System call error, func=aa....aa, errno=bb....bb　　（Ｅ＋Ｌ＋Ｓ）
システム関数でエラーが発生しました。
aa....aa：システム関数
bb....bb：エラーコード
(Ｓ)処理を終了する場合と続行する場合があります。
(Ｏ)
〈このメッセージの前にメッセージが出力されている場合〉
そのメッセージに従って対処してください。
〈funcで示したシステム関数のエラーの場合〉
システム関数のerrnoを調査し，その内容に従って対処してください。
〈パスワードの入力時にtcgetattr関数のエラーが発生した場合〉
次に示す原因が考えられます。
・rch（リモートシェル）でユティリティを起動しました。
・そのほか，端末の環境が不正です。
これらのメッセージは，パスワードの入力前後に出力されています。
KFPX28405-E
Dictionary error(aa....aa, bb....bb)　　（Ｌ＋Ｓ）
ディクショナリに不整合があります。
aa....aa：ディクショナリ表名
bb....bb：不整合の理由
(Ｓ)処理を終了します。
(Ｏ)ディクショナリが正しく回復されているか確認し，正しい手順で回復してください。
KFPX28406-E
RPC error occurred　　（Ｅ）
ユティリティのシェルプロセスとサーバプロセスとの通信処理で，エラーが発生しました。
(Ｓ)処理を終了します。
(Ｏ)ユティリティの起動ホスト，及び搬出ファイルがあるホストで，HiRDBが正常に開始したかを確認してください。
KFPX28407-E
File error occurred, func=aa....aa, file=bb　　（Ｅ＋Ｌ＋Ｓ）
bbファイルで，aa....aaエラーが発生しました。
aa....aa：エラーの内容
{ OPEN | CLOSE | READ | WRITE | CREATE }
bb：ファイル名称
-e：搬出ファイルを示します。
-f：制御文ファイルを示します。
-i：搬入ファイルを示します。
-p：処理結果出力ファイルを示します。
-o：定義系SQL出力ファイルを示します。
(Ｓ)処理を終了します。
(Ｏ)
〈OPENエラーの場合〉
指定したファイル名が正しいかを確認してください。
〈そのほかの場合〉
指定したファイルの権限の有無などを確認してください。
〈-oファイルの場合〉
・-iにホスト名を指定していないとき
-oで指定したファイルの権限の有無などを確認してください。
・-iにホスト名を指定しているとき
-oで指定したファイル名，又はそのホストの$PDDIR/tmp下に作成する一時的ワークファイル(pdexp_sqlで始まるファイル名称)の権限の有無などを確認してください。
〈-pファイルの場合〉
処理結果は，メッセージログファイルに出力されています。このため，メッセージログファイルの内容を確認してください。
KFPX28408-E
Invalid execution node　　（Ｅ）
ディクショナリ搬出入ユティリティ(pdexp)を起動したノードが不正です。
(Ｓ)処理を終了します。
(Ｏ)
〈シングルサーバの場合〉
HiRDB本体のサーバマシンでディクショナリ搬出入ユティリティ(pdexp)を起動してください。
〈パラレルサーバの場合〉
システムマネジャ（MGR）のサーバマシンで起動してください。
KFPX28409-E
Invalid device, file=-f　　（Ｅ）
-fで指定した制御文ファイルが，不正です。又は，指定したファイルへのアクセスができません。
(Ｓ)処理を終了します。
(Ｏ)正しいファイルを指定してください。又は，パス指定のディレクトリの状態が正しいかどうか確認してください。
KFPX28410-E
Insufficient memory in message buffer pool due to concurrent execution of "pdexp"　　（Ｅ）
pdexpを同時実行したため，ユティリティサーバ用のメッセージ格納バッファプールのメモリが，一時的に不足しました。pdexpは，同時実行できません。
なお，該当するエラーの発生に伴って，KFPS00854-Wが出力されることがあります。しかし，この場合は，サーバ障害ではありません。
(Ｓ)処理を終了します。
(Ｏ)現在実行中のpdexpの実行完了後，再度実行してください。
KFPX28411-E
Unable to send message from aa....aa to bb....bb　　（Ｅ）
ホストaa....aaとホストbb....bb間で，通信エラーが発生しました。
aa....aa：送信元ホスト名　※
bb....bb：送信先ホスト名　※
注※　系切り替え機能を使用している場合は，現用系のホスト名となります。
(Ｓ)処理を終了します。
[対策]このメッセージの前に出力されたKFPX28403-Eメッセージの処置に従ってください。ただし，物理的な通信エラーが発生していない場合は，システム定義でホスト間の関係に矛盾があると考えられます。このため，エラーが発生したホスト間の定義を見直して再度実行してください。
KFPX28412-E
Invalid environment, reason=aaaaaa　　（Ｅ）
ディクショナリ搬出入ユティリティの実行環境に誤りがあります。
次の要因が考えられます。
・リモートシェルの環境で実行しています。
・シェルで＆を付けて，バックグラウンドで実行しています。
・パスワードの応答ができない環境で実行しています。
aaaaaa：理由コード
no_tty：実行環境に端末がありません。
(Ｓ)処理を終了します。
(Ｏ)
〈理由コードがno_ttyの場合〉
パスワードの応答ができない環境で実行するには，環境変数PDUSERに認可識別子とパスワードを指定し，コマンドラインで-uオプションを指定しないで再度実行してください。
KFPX28413-E
File I/O error occurred, reason=aa....aa, func=bb....bb, errno=cc....cc, (dd....dd)　　（Ｅ＋Ｓ＋Ｌ）
ファイル入出力中にエラーが発生しました。
aa....aa：エラー理由
Invalid-deviceで指定されたファイルのエントリタイプが識別できる場合は1文字を（）に入れて表示します。これは，OSのls -lコマンドでプリントしたモードのエントリと同じです。
Invalid-parameter：指定したパラメタの組み合わせが不正です。
Invalid-device：指定したファイルのエントリタイプが不正です。
File-format：指定したフォーマットと実際のファイルのフォーマットが異なります。
File-lock：ユティリティが読み書きしているファイルへの書き込みです。
No-file：読み込み用にオープンしようとしたファイルがありません。又は，書き込み中のファイルが消去されました。
Invalid-permission：指定したファイルのパーミッションが不正です。
No-space：書き込むファイルに十分な容量がありません。
Invalid-file：正しく作成されていないファイルが指定されました。
bb....bb：エラーが発生したシステム関数名
システム関数でエラーが起きていない場合は***が出力されます。
cc....cc：エラー番号
システム関数でエラーが起きていない場合は0が出力されます。
dd....dd：障害を検知したソースファイル名と行番号
(Ｓ)処理を終了します。
[対策]エラー理由及びエラー番号を参照してエラーの原因を取り除き，再度実行してください。
KFPX28440-E
Invalid option　　（Ｅ）
コマンドラインの指定に誤りがあります。不当なオプションを指定しました。
(Ｓ)処理を終了します。
(Ｏ)正しいオプションに修正してください。
KFPX28441-I
Usage: pdexp {-e [host_name:]export_file_name|-i [host_name:]export_file_name [-o output_file_name [-a]]} [-f statement_control_file_name] [-u user_name]　　（Ｅ）
ディクショナリ搬出入ユティリティのオプション指定形式に誤りがあります。
(Ｓ)処理を終了します。
(Ｏ)ユティリティの使用方法に従って，再度実行してください。
KFPX28442-E
Unable to specify -e and -i at the same time　　（Ｅ）
コマンドラインの指定に誤りがあります。-eと-iの指定を同時にしました。
(Ｓ)処理を終了します。
(Ｏ)-e，-iのどちらか一方を指定してください。
KFPX28443-E
Missing aa....aa option　　（Ｅ）
コマンドラインの指定に誤りがあります。-e，又は-iのどちらも指定されていません。又は，-eが指定されていますが，-fが指定されていません。
aa....aa：オプション名{ -e/-i | -f }
(Ｓ)処理を終了します。
(Ｏ)オプションを正しく指定してください。
KFPX28445-E
Invalid value in aa option　　（Ｅ）
コマンドラインの指定に次のような誤りがあります。
・aaオプションの指定値が不正です。
・aaオプションの指定値が制限を超えています（-uオプションの場合，8文字を超えています。-u以外のオプション場合，100文字を超えています）。
・aaオプションの指定値がありません。
・aaオプションの指定値が絶対パス名ではありません。
aa：不正なオプション名
(Ｓ)処理を終了します。
(Ｏ)オプションを正しく指定してください。
KFPX28446-E
Invalid value in host name　　（Ｅ）
コマンドラインの指定に次のような誤りがあります。
・ホスト名の指定が不正です。
・指定したホスト名は，搬出入できるホストではありません。
・指定したホスト名は，系切り替え機能の予備系のホストです。
(Ｓ)処理を終了します。
(Ｏ)正しいホスト名を指定してください。
・HiRDB/シングルサーバシングルサーバの自ホストで実行する場合は，ホスト名を省略してください。
・系切り替え機能を使用している場合は，現用系のホスト名を指定してください。
KFPX28447-E
Invalid aa....aa　　（Ｅ）
ディクショナリ搬出入ユティリティの実行時に，環境変数で指定される認可識別子又はパスワードが不正です。
aa....aa：エラーが発生した種別
auth_id：認可識別子
password：パスワード
(Ｓ)処理を終了します。
(Ｏ)
〈auth_idが出力されたとき〉
環境変数PDUSERの内容を修正して，再度コマンドを実行してください。
〈passwordが出力されたとき〉
環境変数PDUSERの内容を修正して，再度コマンドを実行してください。又は，入力応答メッセージに対してパスワードを入力したときは，再度コマンドを実行して，入力誤りがないようにしてください。
Windows版の場合，-uオプションを省略する場合は，コマンドプロンプト上で，認可識別子やパスワードを指定する文字列を「'」で囲んでいないか，確認してください（ただし，クライアント環境定義(hirdb.ini)の中では，「'」で囲むのが正しい指定方法です）。
正しい指定例：PDUSER="root"/"root"
KFPX28501-E
Invalid environment for aa....aa　　（Ｅ）
aa....aa用のディクショナリ表がないため，このHiRDBシステムは，aa....aaを搬出入できるシステムではありません。
aa....aa:｛procedure｜trigger｝
(Ｓ)処理を終了します。
(Ｏ)
〈搬出の場合〉
該当するシステムには，aa....aaがないため，aa....aaの搬出ができません。
〈搬入の場合〉
データベース構成変更ユティリティで，ストアドプロシジャ用のRDエリアを追加した後，搬入してください。
KFPX28502-E
Incompatible aa....aa between export and import system　　（Ｌ＋Ｓ）
搬出したシステムと，搬入するシステムのaa....aaが異なるため，搬入できません。
aa....aa：エラーの内容
byte order：バイトオーダ
(Ｓ)処理を終了します。
(Ｏ)同じバイトオーダのシステム間で搬出入をしてください。
KFPX28503-E
Incompatible character code set, HiRDB=aa....aa, export file=bb....bb　　（Ｌ＋Ｓ）
搬出ファイルの文字コード種別と搬入先のHiRDBの文字コード種別が不一致です。
aa....aa：HiRDBの文字コード種別
CHINESE：EUC中国語漢字コード
LANG-C：単一バイト文字コード
SJIS：シフトJIS漢字コード
UJIS：EUC日本語漢字コード
UTF-8：Unicode（UTF-8）
bb....bb：搬出ファイルの文字コード種別
CHINESE：EUC中国語漢字コード
LANG-C：単一バイト文字コード
SJIS：シフトJIS漢字コード
UJIS：EUC日本語漢字コード
UTF-8：Unicode（UTF-8）
(Ｓ)処理を終了します。
(Ｏ)同じ文字コード種別のシステム間で搬出入をしてください。
KFPX28504-W
Unable to specify aa....aa name, reason~bb....bb, name="cc....cc"."dd....dd"　　（Ｌ＋Ｓ）
参照表の表定義時に内部的にHiRDBが作成したトリガは搬出できません。このようなトリガは，参照表を搬出入すると作成されるので搬出入する必要はありません。
aa....aa：名称
trigger
table
bb....bb：理由
system trigger
AUDIT TRAIL TABLE
cc....cc：スキーマ名
dd....dd：トリガ名又は表識別子
(Ｓ)指定された名称の処理は無視し，処理を続行します。
(Ｏ)次に示すどちらかの処置をしてください。
・bb...bbがsystem triggerの場合：制御文の名称に，参照表の定義時に内部的にHiRDBが作成したトリガ名を指定しないでください。
・bb...bbがAUDIT TRAIL TABLEの場合：制御文の名称に，監査証跡表の表名を指定しないでください。
KFPX28505-E
Audit trail file write error, reason=aaaaa　　（Ｅ＋Ｌ）
監査証跡ファイルの出力時にエラーが発生したため，ユティリティの監査証跡は監査証跡ファイルに出力されません。
aaaaa：エラー詳細コード
(Ｓ)処理を続行します。
(Ｏ)エラー詳細コードを参照してエラーの原因を取り除いてください。エラー詳細コードについては，「システム関連エラーの詳細コード」を参照のこと。
KFPX29001-E
Specified value aa....aa invalid　　（Ｓ）
指定された値が，指定できる範囲ではありません。
aa....aa：指定された不正値
(Ｓ)指定値を無視して，設定値は変更しません。
[対策]再度メニューを選択して，指定できる値に修正してください。
KFPX29002-I
Specified directory aa....aa are install directory　　（Ｓ）
指定されたディレクトリは，HiRDB運用ディレクトリではなく，インストールディレクトリです。このままシステム生成を続行すると，インストールディレクトリをそのまま使用して，システムを作成します。この場合，新しいバージョンのHiRDBをインストールすると，このシステムが必ずバージョンアップされて，旧バージョンのまま使用できなくなります。
aa....aa：指定されたディレクトリ
[対策]指定したディレクトリにHiRDBシステムを構築する場合は，そのまま続行してください。別のディレクトリにHiRDBシステムを構築したい場合は，pdgenコマンドをいったん終了して，HiRDB運用ディレクトリを作成した後，pdgenコマンドを再度実行してください。
KFPX29003-E
Enter file or directory name with complete path name=aa....aa　　（Ｓ）
ディレクトリ及びファイルの名称は，"/"で始まる絶対パスで指定する必要があります。
aa....aa：指定されたファイル名及びディレクトリ名
(Ｓ)指定値を無視して，設定値は変更しません。
[対策]指定を，完全パス名に変更してください。
KFPX29004-E
Specified directory aa....aa is not HiRDB directory　　（Ｓ）
指定されたディレクトリは，HiRDB運用ディレクトリではありません。又は，pdsetupが完了していません。
aa....aa：指定されたHiRDB運用ディレクトリ名（他ホストの場合，先頭に"ホスト名："が表示されます）
(Ｓ)指定値を無視して，設定値は変更しません。
[対策]ディレクトリ名称を見直して，誤っていた場合は，HiRDB運用ディレクトリの名称を正しく指定して，再設定してください。pdsetupが完了していなかった場合は，いったんpdgenを終了した後，pdsetupを実行して，それから再度pdgenを実行してください。
KFPX29005-E
Invalid file or directory specified aa....aa bb....bb　　（Ｓ）
指定されたディレクトリ又はファイルの名称が誤っています。
aa....aa：指定されたディレクトリ名又はファイル名
bb....bb：エラー種別
not character special file：Rawファイルを選択している場合に，キャラクタ型スペシャルファイル名を指定するところに，異なるファイルを指定しています。又は，指定されたファイルはありません。
invalid directory name：通常ファイルを選択した場合に，ファイルの上位ディレクトリがない名称が指定されました。
not UNIX file：通常ファイルを選択した場合に，通常ファイルではないファイルの名称が指定されました。
(Ｓ)指定値を無視して，設定値は変更しません。
[対策]再度項目を選択して，正しいディレクトリ又はファイルの名称を入力してください。
KFPX29006-E
Rdarea-add-menu can select after system generation　　（Ｓ）
RDエリア追加メニューは，システム作成が完了していないと選択できません。
(Ｓ)処理を続行します。
[対策]システム構築が完了した後，RDエリアを追加してください。
KFPX29007-E
Invalid host name are specified aa....aa　　（Ｓ）
次に示すどれかの原因が考えられます。
・指定されたホスト名が誤っています。
・hostsファイルに登録されていません
・ホストが立ち上がっていません。
aa....aa：指定されたホスト名
(Ｓ)指定値を無視して，設定値は変更しません。
[対策]ホスト名を確認してください。ホスト名が誤っていた場合は，正しい名称を指定して，再度設定してください。hostsファイルにない名称を指定した場合は，hostsファイルにそのホスト名を追加してください。ホストが立ち上がっていない場合は，ホストを起動した後，pdgenコマンドを実行してください。なお，pdgenコマンドは，pingコマンドでチェックをしています。このエラーが発生した場合は，指定したホストに対してpingコマンドでエラーが起きないかどうかを確認してください。
KFPX29008-E
Remote shell configuration are not setupped with aa....aa　　（Ｓ）
指定されたホストとの間にリモートシェルの環境設定がされていません。
aa....aa：ホスト名
(Ｓ)指定値を無視して，設定値は変更しません。
[対策]指定されたホストとの間で，pdgenコマンドを実行している使用者がリモートシェルを実行できるように環境設定してください。
KFPX29009-E
System-generation can select after unit initialized　　（Ｓ）
HiRDB/パラレルサーバの環境構築をするとき，システム作成の指定は，ユニットの初期化が完了していないと選択できません。現在は，ユニットを初期化していないか，システムマネジャ又はディクショナリサーバがあるユニットの初期化が完了していません。
(Ｓ)指定値を無視して，処理を続行します。
[対策]ユニット初期化メニューを選択して，ユニットの初期化を実行し，完了した後，システムを作成してください。
KFPX29010-E
Invalid status　　（Ｓ）
メニューでの選択順序が正しくありません。又は，現在，HiRDB環境を構築しようとしているHiRDB運用ディレクトリ上で，HiRDBが既に起動しています。
(Ｓ)指定値を無視します。
[対策]正しい順序でメニューを選択してください。
このHiRDB運用ディレクトリ上に，再度HiRDB環境を構築したい場合は，起動中のHiRDBを停止して，pdsetupコマンドを実行後，再度実行してください。
KFPX29011-E
HiRDB directory or /tmp is full in aa....aa　　（Ｓ）
aa....aaで示すホストにあるHiRDB運用ディレクトリ又は/tmpの容量が不足しているため，指定されたメニューの処理を実行できません。
aa....aa：容量が不足したホスト名称
(Ｓ)指定されたメニューの処理を中断します。
[対策]aa....aaで示すホストにあるHiRDB運用ディレクトリ及び/tmpに1Mバイト以上の空きを作成してから，再度メニューを実行してください。
KFPX29012-E
Plugin-setup-menu can select after system generation　　（Ｓ）
プラグイン組み込み画面は，システム作成が完了していないと選択できません。
(Ｓ)指定値を無視して，処理を続行します。
[対策]システム構築が完了した後，再度メインメニューからプラグイン組み込み画面を選択してください。
KFPX29013-E
Invalid file or directory specified aa....aa　　（Ｓ）
指定したディレクトリ名称又はファイル名称に誤りがあります。次に示す原因が考えられます。
・プラグインPPをインストールしていません。
・各項目で指定した名称に誤りがあります。
aa....aa：指定したディレクトリ名称又はファイル名称（他ホストの場合，先頭に"ホスト名："が表示されます）
(Ｓ)処理を続行します。
[対策]プラグインのPPをインストールしているか確認してください。インストールしている場合，プラグインPPインストールディレクトリ名称，プラグイン名称，プラグイン定義ファイル名称，及びプラグインPICファイル名称の指定値を確認してください。
エラーの原因を解決した後，プラグイン組み込みメニュー中のプラグインの組み込み（s）を再度実行してください。
KFPX29014-E
Unable to update this menu for "Assume by pdgen"　　（Ｓ）
この項目はpdgenコマンドによって値が仮定されているため変更できません。
この項目を変更できるのは，プラグイン名称入力でのプラグイン選択で"Other Plugin"を選択しプラグイン名称を入力した場合だけです。
(Ｓ)処理を続行します。
[対策]プラグイン組み込み画面のプラグイン名称入力でのプラグイン選択で，"Other Plugin"を選択してプラグイン名称を入力すると，この項目は更新可能となります。
KFPX29015-E
Unable to setup PLUGIN for necessary parameter omitted　　（Ｓ）
プラグインの組み込み画面で指定が必要なパラメタが省略されているため，プラグインの組み込みができませんでした。
プラグイン組み込み画面では，プラグインPPインストールディレクトリ名称，プラグイン名称，プラグイン定義ファイル名称，及びプラグインPICファイル名称は省略できません。
(Ｓ)処理を続行します。
[対策]プラグイン組み込み画面でプラグインPPインストールディレクトリ名称，プラグイン名称，プラグイン定義ファイル名称，及びプラグインPICファイル名称を指定して，再度組み込み(s)を実行してください。
KFPX29016-E
Unable to select this menu for HiRDB not running　　（Ｓ）
プラグインの組み込み中に問題が発生したため，HiRDBが停止した状態になっています。したがって，選択された項目は実行できません。
(Ｓ)処理を続行します。
[対策]pdgenを終了し，プラグイン組み込み中に問題が発生したときに出力されたメッセージから原因を調査してください。問題を解決後，pdsetupコマンドで再度実行してください。
KFPX29017-E
PLUGIN already exist　　（Ｓ）
指定したプラグインは登録済みです。
(Ｓ)処理を続行します。
[対策]プラグイン組み込み画面の指定値を確認し，修正後，再度実行してください。
KFPX29018-E
Object Option unmatched　　（Ｓ）
HiRDB/パラレルサーバの場合で，ユニット同士のHiRDB Object Optionの組み込みの有無が一致していません。
(Ｓ)処理を続行します。
[対策]すべてのユニットでHiRDB Object Optionの組み込みの有無を統一して再度実行してください。
KFPX29019-E
Object Option required　　（Ｓ）
HiRDB運用ディレクトリにHiRDB Object Optionが組み込まれていない場合，この項目は選択できません。
(Ｓ)処理を続行します。
[対策]このメニュー項目を実行したい場合には，システムジェネレータ(pdgen)を終了し，HiRDB運用ディレクトリにpdopsetupコマンドでHiRDB Object Optionを組み込んでから再度実行してください。
KFPX29500-I
HiRDB system generation start at aa....aa on bb....bb　　（Ｌ）
HiRDBシステムの環境構築を開始します。
aa....aa：開始時間（hh:mm:ss）
bb....bb：開始年月日（yyyy/mm/dd）
(Ｓ)処理を続行します。
KFPX29501-I
HiRDB system generation ended return code=aa at bb....bb on cc....cc　　（Ｌ）
HiRDBシステムの環境構築を終了しました。
aa....aa：リターンコード
0：正常終了
8：異常終了
bb....bb：終了時間（hh:mm:ss）
cc....cc：終了年月日（yyyy/mm/dd）
(Ｓ)処理を終了します。
[対策]リターンコードが8の場合は，HiRDBシステムの環境構築は失敗し，途中で処理が中断されています。$PDDIR/spool/redult_generate.logファイルを参照して，エラー要因を取り除き，再度セットアップからの環境構築を再実行してください。
KFPX29502-I
HiRDB definition files creation start, PDCONFPATH=aa....aa　　（Ｌ）
HiRDBシステム定義ファイル群の作成処理を開始します。
aa....aa：HiRDBシステム定義ファイル群を作成するディレクトリの名称
(Ｓ)処理を続行します。
KFPX29503-I
HiRDB definition files creation ended　　（Ｌ）
HiRDBシステム定義ファイル群の作成処理を終了しました。
(Ｓ)処理を続行します。
KFPX29504-I
HiRDB file system area initialization for aa....aa start, file=bb....bb:cc....cc, size=dd....dd　　（Ｌ）
HiRDBファイルシステム領域の初期設定処理を開始します。
aa....aa：HiRDBファイルシステム領域の使用目的
DB：RDエリア用
SYS：システムファイル用
WORK：作業表ファイル用
UTL：ユティリティ用
SVR：ユティリティ用を除くその他すべて
bb....bb：ホスト名
cc....cc：HiRDBファイルシステム領域の名称
dd....dd：HiRDBファイルシステム領域のサイズ（単位：メガバイト）
(Ｓ)処理を続行します。
KFPX29505-I
HiRDB file system area initialization ended, file=aa....aa:bb....bb　　（Ｌ）
HiRDBファイルシステム領域の初期設定処理を終了しました。
aa....aa：ホスト名
bb....bb：HiRDBファイルシステム領域の名称
(Ｓ)処理を続行します。
KFPX29506-I
HiRDB system file initialization for aa....aa start　　（Ｌ）
システムファイルの初期設定処理を開始します。
aa....aa：システムファイルの種別
system_log：システムログファイル
synchronization_point_dump：シンクポイントダンプファイル
server_status：サーバ用ステータスファイル
unit_status：ユニット用ステータスファイル
(Ｓ)処理を続行します。
KFPX29507-I
HiRDB system file initialization ended　　（Ｌ）
システムファイルの初期設定処理を終了しました。
(Ｓ)処理を続行します。
KFPX29508-I
HiRDB system starting at aa....aa on bb....bb　　（Ｌ）
HiRDBシステムの起動処理を開始します。
aa....aa：起動開始時間（hh:mm:ss）
bb....bb：起動開始年月日（yyyy/mm/dd）
(Ｓ)処理を続行します。
KFPX29509-I
HiRDB system started at aa....aa on bb....bb　　（Ｌ）
HiRDBシステムの起動処理を完了しました。
aa....aa：起動完了時間（hh:mm:ss）
bb....bb：起動完了年月日（yyyy/mm/dd）
(Ｓ)処理を続行します。
KFPX29510-I
HiRDB management file creation start, HiRDB file system area=aa....aa　　（Ｌ）
HiRDB管理情報ファイルの作成処理を開始します。
aa....aa：HiRDBファイルシステム領域の名称
(Ｓ)処理を続行します。
KFPX29511-I
HiRDB management file creation ended　　（Ｌ）
HiRDB管理情報ファイルの作成処理を終了しました。
(Ｓ)処理を続行します。
KFPX29512-E
Specified directory aa....aa is not HiRDB directory　　（Ｌ）
環境変数PDDIRに設定されているディレクトリは，HiRDB運用ディレクトリではありません。又は，セットアップが完了していません。
aa....aa：環境変数PDDIRに設定されているディレクトリ名
(Ｓ)処理を終了します。
[対策]HiRDB運用ディレクトリの名称が誤っている場合は，名称を修正してください。セットアップが完了していなかった場合は，セットアップ実行後に再度環境構築をしてください。
KFPX29513-E
Invalid HiRDB status, PDDIR=aa....aa　　（Ｌ）
HiRDBの環境構築をしようとしているHiRDB運用ディレクトリ上では，既にHiRDBが起動しています。
aa....aa：環境変数PDDIRに設定されているディレクトリ名
(Ｓ)処理を終了します。
[対策]環境変数PDDIRの設定値が正しいか確認してください。設定値が正しい場合は，起動中のHiRDBを停止して，再度セットアップをした後に環境構築をしてください。
KFPX29514-E
System call error, func=aa....aa, errno=bb....bb　　（Ｌ）
システム関数でエラーが発生しました。
aa....aa：システム関数名
bb....bb：エラーコード
(Ｓ)処理を終了します。
[対策]システム関数のerrnoを調査して，そのエラー要因を取り除き再度実行してください。
KFPX29515-E
aa....aa file "bb....bb" open failed, reason code=cc....cc　　（Ｌ）
aa....aaファイルのオープン処理に失敗しました。
aa....aa：ファイルの種別
Management：管理情報
bb....bb：ファイル名
cc....cc：エラー詳細コード
(Ｓ)処理を終了します。
[対策]管理情報アクセスライブラリ関連のエラー詳細コードを調査して，その原因を取り除いて再度実行してください。
KFPX29516-E
HiRDB definition file creation failed, file="aa....aa"　　（Ｌ）
HiRDBシステム定義ファイルの作成に失敗しました。
aa....aa：ファイル名
(Ｓ)処理を終了します。
[対策]このメッセージの出力以前の環境構築の実行結果ログファイルに出力された障害メッセージから原因を調査して，その原因を取り除いて再度実行してください。
KFPX29517-E
HiRDB file system area initialization failed, path name="aa....aa"　　（Ｌ）
HiRDBファイルシステム領域の初期設定に失敗しました。
aa....aa：HiRDBファイルシステム領域の名称
(Ｓ)処理を終了します。
[対策]このメッセージの出力以前の環境構築の実行結果ログファイルに出力された障害メッセージから原因を調査して，その原因を取り除いて再度実行してください。
KFPX29518-E
HiRDB system file initialization failed, file="aa....aa"　　（Ｌ）
システムファイルの初期設定に失敗しました。
aa....aa：ファイル名
(Ｓ)処理を終了します。
[対策]このメッセージの出力以前の環境構築の実行結果ログファイルに出力された障害メッセージから原因を調査して，その原因を取り除いて再度実行してください。
KFPX29519-E
HiRDB start failed　　（Ｌ）
HiRDBシステムの開始に失敗しました。
(Ｓ)処理を終了します。
[対策]このメッセージの出力以前の環境構築の実行結果ログファイルに出力された障害メッセージから原因を調査して，その原因を取り除いて再度実行してください。
KFPX29520-E
HiRDB management file creation failed, reason code=aa....aa　　（Ｌ）
HiRDBファイルシステム領域へのHiRDB管理情報ファイルの作成に失敗しました。
aa....aa：エラー詳細コード
(Ｓ)処理を終了します。
[対策]管理情報アクセスライブラリ関連のエラー詳細コードを調査して，その原因を取り除いて再度実行してください。
KFPX29521-I
PLUGIN setup start　　（Ｌ）
プラグインのセットアップを開始します。
(Ｓ)処理を続行します。
KFPX29522-I
PLUGIN setup ended　　（Ｌ）
プラグインのセットアップを終了しました。
(Ｓ)処理を続行します。
KFPX29523-I
Registry initialization start　　（Ｌ）
レジストリの初期設定処理を開始します。
(Ｓ)処理を続行します。
KFPX29524-I
Registry initialization ended　　（Ｌ）
レジストリの初期設定処理を終了しました。
(Ｓ)処理を続行します。
KFPX29525-I
Processing of PLUGIN registration start　　（Ｌ）
プラグインの登録処理を開始します。
(Ｓ)処理を続行します。
KFPX29526-I
Processing of PLUGIN registration ended　　（Ｌ）
プラグインの登録処理を終了しました。
(Ｓ)処理を続行します。
KFPX29527-E
PLUGIN setup failed, PLUGIN name=aa....aa, install directory=bb....bb　　（Ｌ）
プラグインaa....aaのセットアップに失敗しました。
aa....aa：プラグイン名
bb....bb：セットアップしようとしたプラグインのインストールディレクトリ名
(Ｓ)処理を終了します。
[対策]このメッセージの出力以前に環境構築の実行結果ログファイルに出力された障害メッセージから原因を調査し，その原因を取り除いた後に再度実行してください。
KFPX29528-E
Registry initialization failed　　（Ｌ）
レジストリの初期設定に失敗しました。
(Ｓ)処理を終了します。
[対策]このメッセージの出力以前に環境構築の実行結果ログファイルに出力された障害メッセージから原因を調査し，その原因を取り除いた後に再度実行してください。
KFPX29529-E
Processing of PLUGIN registration failed, PLUGIN name=aa....aa　　（Ｌ）
プラグインaa....aaの登録に失敗しました。
aa....aa：プラグイン名
(Ｓ)処理を終了します。
[対策]このメッセージの出力以前に環境構築の実行結果ログファイルに出力された障害メッセージから原因を調査し，その原因を取り除いた後に再度実行してください。
KFPX29631-E
[aa....aa]の値が数値ではありません。　　（Ｄ）
詳細定義画面の定義で数値指定の入力項目に数値以外が指定されました。
aa....aa：指定値が不正な入力項目の名称
(Ｓ)エラーメッセージを表示し，正しい値が入力されるのを待ちます。
[対策]数値を指定して再度実行してください。
KFPX29632-E
[aa....aa]の値が範囲制限でエラーがあります。　　（Ｄ）
詳細定義画面の定義で入力項目に指定範囲外の値が指定されました。
aa....aa：指定値が不正な入力項目の名称
(Ｓ)エラーメッセージを表示し，正しい値が入力されるのを待ちます。
[対策]指定範囲内の値を指定して再度実行してください。
KFPX29633-E
オペランド情報ファイルの読み込みでエラーが発生しました。
詳細：<aa....aa>
エラー行：<bb....bb>　　（Ｄ）
オペランド情報ファイルの読み込み処理でエラーが発生しました。
aa....aa：エラーの詳細情報（以下の文字列が埋め込まれます）
・バージョンより前にオペランド情報が記述されています。
・オペランド情報タイプが不正です。
・オペランド形式が不正です。
・オペランドの省略可否が不正です。
・オペランドの公開可否が不正です。
・対象サーバ種別が不正です。
・指定可能定義種別が不正です。
・値の型が不正です。
・値の最小値が不正です。
・値の最大値が不正です。
・OS種別が不正です。
・オペランドの複数指定可否が不正です。
・オプションフラグの省略可否が不正です。
・オプションフラグの公開可否が不正です。
・フラグ引数の有無が不正です。
・COM0形式のオペランド情報が存在しません。
bb....bb：エラー発生行
(Ｓ)処理は続行しますが，エラーとなったオペランドについては詳細定義画面での編集ができなくなります。
[対策]エラーの詳細情報からエラー原因を調査し，対策後に再度実行してください。
KFPX29634-E
オペランド情報ファイル（aa....aa）が存在しません。　　（Ｄ）
オペランド情報ファイルaa....aaがありません。
aa....aa：オペランド情報ファイルの名称
(Ｓ)処理は続行しますが，詳細定義画面でのオペランド編集はできなくなります。
[対策]aa....aaで示されるオペランド情報ファイルを設定して再度実行してください。
KFPX29635-E
オペランド情報ファイル（aa....aa）が空です。　　（Ｄ）
オペランド情報ファイルaa....aaの内容が空です。
aa....aa：オペランド情報ファイルの名称
(Ｓ)処理は続行しますが，詳細定義画面でのオペランド編集はできなくなります。
[対策]オペランド情報ファイルaa....aaを見直して再度実行してください。
KFPX29636-E
オペランド情報ファイル（aa....aa）を開けません。　　（Ｄ）
オペランド情報ファイルaa....aaをオープンできません。
aa....aa：オペランド情報ファイルの名称
(Ｓ)処理は続行しますが，詳細定義画面でのオペランド編集はできなくなります。
[対策]オペランド情報ファイルaa....aaの状態を確認し，オープンできる状態にして再度実行してください。
KFPX29637-E
[aa....aa]の値の文字数制限でエラーがあります。　　（Ｄ）
詳細定義画面の定義で入力項目に指定した文字数が制限値を超えました。
aa....aa：指定値が不正な入力項目の名称
(Ｓ)エラーメッセージを表示し，正しい値が入力されるのを待ちます。
[対策]文字数を制限値以内にして再度実行してください。
KFPX29638-E
システム定義のチェック結果の読み込みに失敗しました。
詳細：<aa....aa>　　（Ｄ）
システム定義のチェック結果を格納したファイルの読み込みに失敗しました。
aa....aa：エラーの詳細及び対象ファイル名
(Ｓ)処理は続行しますが，システム定義のチェック結果は表示されません。
[対策]aa....aaに表示されたエラーの詳細情報に従ってエラーを取り除き，再度実行してください。
KFPX29639-E
値が入力されていません。　　（Ｄ）
詳細定義画面の定義で値の指定が必要な入力項目に値が指定されていません。
(Ｓ)エラーメッセージを表示し，正しい値が入力されるのを待ちます。
[対策]値を指定して再度実行してください。
KFPX29640-E
値が最小文字数未満です。　　（Ｄ）
詳細定義画面の定義で指定した値が最小文字数未満です。
(Ｓ)エラーメッセージを表示し，正しい値が入力されるのを待ちます。
[対策]値を最小文字数以上にして再度実行してください。
KFPX29641-E
値が最大文字数を超えています。　　（Ｄ）
詳細定義画面の定義で指定した値が最大文字数を超えています。
(Ｓ)エラーメッセージを表示し，正しい値が入力されるのを待ちます。
[対策]値を最大文字数以下にして再度実行してください。
KFPX29642-E
値が数値でありません。　　（Ｄ）
詳細定義画面の定義で数値指定の入力項目に数値以外が指定されました。
(Ｓ)エラーメッセージを表示し，正しい値が入力されるのを待ちます。
[対策]数値を指定して再度実行してください。
KFPX29643-E
値が最小値未満です。　　（Ｄ）
詳細定義画面の定義で指定した値が最小値未満です。
(Ｓ)エラーメッセージを表示し，正しい値が入力されるのを待ちます。
[対策]最小値以上の値を指定して再度実行してください。
KFPX29644-E
値が最大値を超えています。　　（Ｄ）
詳細定義画面の定義で指定した値が最大値を超えています。
(Ｓ)エラーメッセージを表示し，正しい値が入力されるのを待ちます。
[対策]最大値以下の値を指定して再度実行してください。
KFPX29645-E
オペランド[aa....aa]は省略できないため削除できません。　　（Ｄ）
省略できないオペランドを削除しようとしました。
aa....aa：オペランド名称
(Ｓ)処理を続行します。
KFPX29646-E
追加するオペランドが選択されていません。　　（Ｄ）
「追加オペランド選択」ダイアログで追加するオペランドが選択されていません。
(Ｓ)エラーを表示し，正しいオペランドが選択されるのを待ちます。
[対策]追加するオペランドを選択してください。
KFPX29647-E
追加するオプションフラグが選択されていません。　　（Ｄ）
「追加オプションフラグ選択」ダイアログで追加するオプションフラグが選択されていません。
(Ｓ)エラーを表示し，正しいオプションフラグが選択されるのを待ちます。
[対策]追加するオプションフラグを選択してください。
KFPX29648-E
指定した[aa....aa]は既に存在します。　　（Ｄ）
既に存在するaa....aaを追加しようとしました。
aa....aa：追加しようとしたパラメタ又は名称
(Ｓ)エラーメッセージを表示し，正しい値が入力されるのを待ちます。
KFPX29649-E
RDエリアを割り当てるHiRDBファイルが存在しません。　　（Ｄ）
「RDエリアを割り当てるHiRDBファイル」ダイアログで，HiRDBファイル名が指定されていません。
(Ｓ)エラーメッセージを表示し，正しい値が入力されるのを待ちます。
[対策]HiRDBファイルを指定して再度実行してください。
KFPX29650-E
A系ステータスファイル名とB系ステータスファイル名が同一です。　　（Ｄ）
A系ステータスファイルとB系ステータスファイルに同一名称が指定されました。
(Ｓ)エラーメッセージを表示し，正しい値が入力されるのを待ちます。
[対策]A系ステータスファイルとB系ステータスファイルの名称を重複しないようにして再度実行してください。
KFPX29651-E
A系システムログファイル名とB系システムログファイル名が同一です。　　（Ｄ）
A系システムログファイルとB系システムログファイルに同一名称が指定されました。
(Ｓ)エラーメッセージを表示し，正しい値が入力されるのを待ちます。
[対策]A系システムログファイルとB系システムログファイルの名称を重複しないようにして再度実行してください。
KFPX29652-E
-oオプションを指定できるのは一つだけです。　　（Ｄ）
「グローバルバッファ編集」ダイアログで-oオプションを複数のグローバルバッファに割り当てようとしました。
(Ｓ)エラーメッセージを表示し，割り当て操作をキャンセルします。
[対策]グローバルバッファに対して指定する-oオプションを見直して再度実行してください。
KFPX29653-E
[aa....aa]の値が指定されていません。　　（Ｄ）
詳細定義画面の定義でaa....aaの入力項目に値が指定されていません。
aa....aa：指定値が不正な入力域の名称
(Ｓ)エラーメッセージを表示し，正しい値が入力されるのを待ちます。
[対策]値を指定して再度実行してください。
KFPX29654-E
hostsファイルの読み込みでエラーが発生しました。
詳細：<aa....aa>　　（Ｄ）
hostsファイルの読み込みでaa....aaで示されるエラーが発生しました。
aa....aa：hostsファイルの読み込みエラーの詳細情報
(Ｓ)処理を続行します。
[対策]aa....aaに表示されたエラーの詳細情報に従ってエラーを取り除き，再度実行してください。
KFPX29655-E
ホスト名を選択してください。　　（Ｄ）
「hostsファイルからホスト名を選択」ダイアログでホスト名が選択されていません。
(Ｓ)エラーメッセージを表示し，正しいホスト名が選択されるのを待ちます。
[対策]ホスト名を選択して再度実行してください。
KFPX29656-E
[aa....aa]の指定が不完全です。　　（Ｄ）
詳細定義画面の定義でaa....aaの指定が不完全です。
aa....aa：指定値が不完全な入力項目の名称
(Ｓ)エラーメッセージを表示し，正しい値が入力されるのを待ちます。
[対策]正しい値を指定して再度実行してください。
KFPX29657-E
グローバルバッファ[aa....aa]にはRDエリアが割り当てられていません。　　（Ｄ）
「グローバルバッファ編集」ダイアログで，グローバルバッファにRDエリアが割り当てられていません。
aa....aa：エラーとなったグローバルバッファ名称
(Ｓ)エラーメッセージを表示し，正しい指定で実行されるのを待ちます。
[対策]グローバルバッファにRDエリアを割り当てて再度実行してください。
KFPX29658-E
RDエリア[aa....aa]にはHiRDBファイルが割り当てられていません。　　（Ｄ）
「RDエリア編集」ダイアログで，RDエリアaa....aaにHiRDBファイルが割り当てられていません。
aa....aa：RDエリア名称
(Ｓ)エラーメッセージを表示し，正しい値が入力されるのを待ちます。
[対策]aa....aaで示されるRDエリアにHiRDBファイルを割り当てて再度実行してください。
KFPX29659-E
HiRDBセットアップツールは複数起動できません。　　（Ｄ）
HiRDBセットアップツールを複数起動しようとしました。
(Ｓ)処理を続行します。
[対策]既に起動済みのHiRDBセットアップツールを終了してください。又は起動済みのHiRDBセットアップツールを使用してください。
KFPX29660-E
現在のHiRDBのバージョンのpdconfchkコマンドは，本セットアップツールには対応していないため定義チェックを実行できません。セットアップ又は定義更新後にコマンドプロンプトからpdconfchkコマンドを実行し，定義内容をチェックしてください。　　（Ｄ）
使用中のHiRDBのバージョンが古いため，pdconfchkコマンドがHiRDBセットアップツールに対応していません。このため，オペランドのチェックが実行できません。セットアップ又は定義更新が完了した後に，pdconfchkコマンドでオペランドのチェックをしてください。
(Ｓ)処理を続行します。
[対策]セットアップ又は定義更新完了後にpdconfchkコマンドでオペランドのチェックを行ってください。HiRDBセットアップツールに対応しているpdconfchkコマンドが提供されているのはHiRDB 06-02-/B以降です。
KFPX29661-E
定義更新の場合は，pd_system_idオペランドを変更できません。　　（Ｄ）
定義更新のため，pd_system_idオペランドの変更はできません。
(Ｓ)処理を続行します。
KFPX29662-E
[aa....aa]の[bb....bb]の値が指定されていません。　　（Ｄ）
系切り替えの指定で，ユニットaa....aaに対してbb....bbが指定されていません。
aa....aa：ユニット名
bb....bb：指定されていない項目
(Ｓ)エラーメッセージを表示し，正しい値が入力されるのを待ちます。
[対策]エラーとなった入力項目を指定して再度実行してください。
KFPX29663-E
[aa....aa]の[bb....bb]の値が数値ではありません。　　（Ｄ）
系切り替えの指定で，ユニットaa....aaに必要な値bb....bbが数値で指定されていません。
aa....aa：ユニット名
bb....bb：エラーとなった入力項目
(Ｓ)エラーメッセージを表示し，正しい値が入力されるのを待ちます。
[対策]数値を指定して再度実行してください。
KFPX29664-E
[aa....aa]の[bb....bb]の値の範囲制限でエラーがあります。　　（Ｄ）
系切り替えの指定で，ユニットaa....aaのbb....bbに指定範囲外の値が指定されています。
aa....aa：ユニット名
bb....bb：エラーとなった入力項目
(Ｓ)エラーメッセージを表示し，正しい値が入力されるのを待ちます。
[対策]指定範囲内の値を指定して再度実行してください。
KFPX29665-E
[aa....aa]の[bb....bb]の値の文字数制限でエラーがあります。　　（Ｄ）
系切り替えの指定でユニットaa....aaのbb....bbの値が文字数制限範囲外です。
aa....aa：ユニット名
bb....bb：エラーとなった入力項目
(Ｓ)エラーメッセージを表示し，正しい値が入力されるのを待ちます。
[対策]指定範囲内の値を指定して再度実行してください。
KFPX29666-E
-iオプション（領域を初期化する）が指定されていません。系切り替え機能使用時は，必ず-iオプション（領域を初期化する）を指定してください。　　（Ｄ）
系切り替え機能の指定があるのに，「ファイルシステム領域編集」ダイアログで-iオプション（領域を初期化する）が指定されていません。
(Ｓ)エラーメッセージを表示し，正しい値が入力されるのを待ちます。
[対策]系切り替え機能を使用する場合は-iオプション（領域を初期化する）を指定して再度実行してください。
KFPX29667-E
[aa....aa]の-iオプション（領域を初期化する）が指定されていません。系切り替え機能使用時は，必ず-iオプション（領域を初期化する）を指定してください。　　（Ｄ）
系切り替え機能の指定があるのに，「ファイルシステム領域編集」ダイアログでHiRDBファイルシステム領域aa....aaの-iオプション（領域を初期化する）が指定されていません。
aa....aa：HiRDBファイルシステム領域名
(Ｓ)エラーメッセージを表示し，正しい値が入力されるのを待ちます。
[対策]系切り替え機能を使用する場合は-iオプション（領域を初期化する）を指定して再度実行してください。
KFPX29668-E
[aa....aa]の-kオプション（使用目的）に"SVR"が指定されています。系切り替え機能使用時は，-kオプション（使用目的）に"SVR"は指定できません。　　（Ｄ）
系切り替え機能の指定があるのに，HiRDBファイルシステム領域aa....aaの使用目的に"SVR"が指定されています。
aa....aa：HiRDBファイルシステム領域名
(Ｓ)エラーメッセージを表示し，正しい値が入力されるのを待ちます。
[対策]系切り替え機能を使用する場合は"SVR"以外の目的に合った使用目的を指定して再度実行してください。
KFPX29669-E
予備系ホスト名が指定されていないユニットがあります。系切り替え機能を使用する場合は，系切り替え機能の設定ダイアログで予備系ホスト名を指定してください。　　（Ｄ）
系切り替え機能の指定があるのに，予備系のホスト名が指定されていないユニットがあります。
(Ｓ)エラーメッセージを表示し，予備系のホスト名を入力して再実行されるのを待ちます。
[対策]予備系のホスト名が指定されていないユニットに対して，系切り替え機能の設定ダイアログで予備系のホスト名を指定して再度実行してください。
KFPX29670-E
フォルダ名称の取得に失敗しました。処理を終了します。　　（Ｄ）
「フォルダの参照」ダイアログで指定したフォルダ名称の取得に失敗しました。
(Ｓ)エラーメッセージを表示し，正しいフォルダを指定して再実行されるのを待ちます。
[対策]指定したフォルダの状態を調査し参照できる状態にするか，又は別のフォルダを指定して再度実行してください。
KFPX29671-E
実行ディレクトリが不正です。処理を終了します。
■説明：セットアップツールは「HiRDBインストールディレクトリ\pdzistup\bin」ディレクトリで実行する必要があります。　　（Ｄ）
セットアップツール実行ディレクトリが不正です。
(Ｓ)処理を終了します。
[対策]実行ディレクトリを見直して適切なディレクトリから実行してください。なお，セットアップツール実行ディレクトリを基点にHiRDBインストールディレクトリ\bin\pdntcmd.batを探し，見付からなかった場合にこのエラーが出力されます。
KFPX29672-E
HiRDBのインストール環境ファイル（Setup.ini）が不正です。処理を終了します。
■説明：HiRDBのインストールが正しく行われていない可能性があります。HiRDBインストール環境を見直してください。　　（Ｄ）
HiRDBのインストール環境ファイル（Setup.ini）の内容が不正です。
(Ｓ)処理を終了します。
[対策]HiRDBインストール環境を見直してください。環境が不正な場合はHiRDBをインストールし直して再度実行してください。
KFPX29673-E
ポート番号に誤りがあります。ポート番号は5001～65535の範囲で指定してください。　　（Ｄ）
ポート番号に5001～65535以外の値が指定されました。
(Ｓ)エラーメッセージを出力し，ポート番号に正しい値を指定して再実行されるのを待ちます。
[対策]ポート番号の指定を5001～65535の範囲の値に変更して再度実行してください。
KFPX29674-E
指定したドライブでは容量が足りないため，セットアップを続行できません。
[<aa....aa>]　　（Ｄ）
セットアップ先のドライブの空き容量が不足しているため，セットアップ処理を続行できません。
aa....aa：セットアップ先フォルダ名称（システムファイルとRDエリアの格納先が異なる場合に出力されます）
(Ｓ)エラーメッセージを表示し，セットアップ可能なフォルダ名称を指定して実行されるのを待ちます。
[対策]セットアップ先として十分な空領域を持つドライブのフォルダを指定して再度実行してください。
KFPX29675-E
aa....aaのバックアップファイルが多過ぎます。幾つか消去してOKを選択してください。キャンセルの場合上書きします。　　（Ｄ）
バックアップファイルが多過ぎるため，バックアップファイルを作成できません。
aa....aa：バックアップの対象になるファイル名
(Ｓ)メッセージで表示した対応を待ちます。
[対策]バックアップファイルを削除する場合は，ファイルを削除してOKを選択してください。バックアップファイルを上書きする場合はキャンセルを選択してください。
KFPX29676-E
ポート番号は既にほかのプログラムで使用されています。＜省略値：20000＞
次のファイルを確認し，使用されていない番号を指定してください。
■"Windowsシステムディレクトリ\drivers\etc\services"　　（Ｄ）
ほかのプログラムで使用されているポート番号を指定しました。ほかのプログラムで使用されているポート番号とは，メッセージに表示されるserviceファイル中に記述されたポート番号のことです。
(Ｓ)エラーメッセージを表示し，使用されていないポート番号を指定して実行されるのを待ちます。
[対策]ほかのプログラムと重複しないポート番号を指定して再度実行してください。なお，serviceファイル中に記述されているポート番号との重複チェックは行いますが，serviceファイルに記述されていないほかのHiRDBで使用されているポート番号との重複チェックは行いません。
KFPX29677-E
システムエラーが発生しました。
エラーコード：aa....aa
エラー内容：bb....bb　　（Ｄ）
システムエラーが発生しました。このエラーメッセージはセットアップ中にWindowsシステムのプロセス処理でエラーが発生した場合に出力されます。
aa....aa：システムのエラーコード
bb....bb：システムのエラー内容
(Ｓ)処理を終了します。
[対策]メモリ不足の可能性があるため，メモリを増やすか，又は不要なアプリケーションを終了して再度実行してください。メモリが十分な状態でもエラーが発生する場合は保守員に連絡してください。なお，このメッセージでいうプロセス処理とはWin32 API Create Process関数の処理のことです。
KFPX29678-E
ファイルの作成に失敗しました。
ファイル名：aa....aa
処理を終了します。　　（Ｄ）
aa....aaで示すファイルの作成に失敗しました。
aa....aa：ファイル名
(Ｓ)処理を終了します。
[対策]aa....aaのファイルが作成できる状況にあるかを確認し，原因を取り除いて再度実行してください。
KFPX29679-E
セットアップツール用iniファイルのオープンに失敗しました。
ファイル名：aa....aa
処理を終了します。　　（Ｄ）
aa....aaで示されるiniファイルのオープンに失敗しました。
aa....aa：オープンに失敗したiniファイル名称
(Ｓ)処理を終了します。
[対策]aa....aaで示されるiniファイルがあるか，又はオープンできる状態にあるかを確認し，原因を取り除いて再度実行してください。
KFPX29680-E
aa....aa処理でエラーが発生しました。エラーの内容はログファイル（pdi_log.txt）に出力されています。　　（Ｄ）
処理aa....aaでエラーが発生しました。
aa....aa：エラーの発生した処理
(Ｓ)処理を終了します。
[対策]ログファイル（pdi_log.txt）に出力されたエラー内容を調査し，原因を取り除いて再度実行してください。
KFPX29681-E
ソケットの初期化でエラーが発生しました。処理を終了します。　　（Ｄ）
Windowsソケットの初期化でエラーが発生しました。ネットワークへの接続準備ができていない，又はWinSockが同時に使用できる最大プロセスに達した可能性があります。
(Ｓ)処理を終了します。
[対策]ネットワークへの接続準備ができていない，又はWinSockが同時に使用できる最大プロセスに達した可能性があるため，少し時間をおいてから再度実行してください。
KFPX29682-E
一時ファイル用ディレクトリの作成に失敗しました。
ディレクトリ名：aa....aa
処理を終了します。　　（Ｄ）
一時ファイル用のディレクトリaa....aaの作成に失敗しました。
aa....aa：ディレクトリ名称
(Ｓ)処理を終了します。
[対策]ディレクトリaa....aaが作成できる状態にあるかを調査し，原因を取り除いて再度実行してください。
KFPX29683-E
aa....aaの指定に誤りがあります。aa....aaは4文字の英数字で指定してください。　　（Ｄ）
入力項目aa....aaの指定に誤りがあります。
aa....aa：入力項目
(Ｓ)エラーメッセージを表示し，正しい値が入力されるのを待ちます。
[対策]4文字の英数字で指定して再度実行してください。
KFPX29684-E
システム定義ファイルの読み込みに失敗しました。
対象ファイル：aa....aa
エラー内容：bb....bb　　（Ｄ）
処理を終了します。
システム定義ファイルaa....aaの読み込み処理で，bb....bbに示される原因によって失敗しました。
aa....aa：システム定義ファイル
bb....bb：エラー内容
(Ｓ)処理を続行します。
[対策]bb....bbに示されるエラー内容から原因を取り除き，再度実行してください。
KFPX29685-E
データベース情報の作成処理でエラーが発生しました。
■エラー内容：aa....aa
エラーの詳細はログファイル（pdi_log.txt）に出力されています。　　（Ｄ）
データベース情報の作成処理でエラーが発生しました。
aa....aa：エラーの内容
・ファイルのオープンに失敗
・ファイルの読み込みに失敗
・メモリ不足
・定義内容の書式不正
(Ｓ)処理を終了します。
[対策]aa....aaで示されるエラー内容，及びログファイル（pdi_log.txt）が出力されている場合はログファイルの内容を参照し，原因を取り除いて再度実行してください。
KFPX29686-E
リモートホストへのアクセスでエラーが発生しました。処理を終了します。
エラーの詳細はログファイル（pdi_log.txt）に出力されています。　　（Ｄ）
リモートホストへのアクセスでエラーが発生しました。次に示す原因が考えられます。
・対象ファイルがオープンできません。
・対象ファイルがアクセスできない状態になっています。
・リモートホストが起動されていないか，存在しません。
・リモートホストのserviceファイル中に記述してある"Rsh Port Name"（pdntenvコマンドで設定する名称です）のポート番号がローカルホストと一致しません。
・リモートホストのHiRDBサービス起動ユーザがローカルホストと一致しません。
・リモートホストのHiRDBサービスが起動されていません。
・リモートホストのログインユーザ/パスワード（HiRDB管理者）がローカルホストと一致しません。
(Ｓ)処理を終了します。
[対策]ログファイル（pdi_log.txt）に出力された内容と，考えられる原因からエラー要因を取り除き，再度実行してください。
KFPX29687-E
内部オブジェクトの生成処理でエラーが発生しました。処理を終了します。
■メモリ不足の可能性があります。　　（Ｄ）
セットアップツールの内部オブジェクト生成処理でエラーが発生しました。原因としてメモリ不足が推定されます。
(Ｓ)処理を終了します。
[対策]メモリを増やすか，又は不要なアプリケーションを終了させて，再度実行してください。
KFPX29688-E
ファイル（ディレクトリ）の作成処理でエラーが発生しました。
■原因：aa....aa
■ファイル作成先ホスト名：bb....bb
■ファイル名：cc....cc　　（Ｄ）
ファイル（ディレクトリ）作成処理でエラーが発生しました。次に示す原因が考えられます。
・cc....ccの対象ファイルが上書きモードでオープンできません。
・cc....ccの対象ファイルがアクセスできない状態になっています。
・bb....bbのリモートホストが起動されていないか，存在しません。
・bb....bbのリモートホストのserviceファイル中に記述してある"Rsh Port Name"（pdntenvコマンドで設定する名称です）のポート番号がローカルホストと一致しません。
・bb....bbのリモートホストのHiRDBサービス起動ユーザがローカルホストと一致しません。
・bb....bbのリモートホストのHiRDBサービスが起動されていません。
・bb....bbのリモートホストのログインユーザ/パスワード（HiRDB管理者）がローカルホストと一致しません。
aa....aa：エラーの原因
・コピー処理失敗
・バックアップ処理失敗
・ファイルのオープンに失敗
・リモートホストファイルへのアクセス失敗
・ディレクトリの作成に失敗
bb....bb：ファイル（ディレクトリ）作成先ホスト名
cc....cc：ファイル（ディレクトリ）名
(Ｓ)処理を終了します。
[対策]aa....aaで示されるエラーの原因を調査し，エラー要因を取り除いて，再度実行してください。
KFPX29689-E
ファイルのオープンに失敗しました。
ファイル名：aa....aa　　（Ｄ）
ファイルaa....aaのオープンに失敗しました。
aa....aa：ファイル名
(Ｓ)処理を終了します。
[対策]ファイルaa....aaがオープンできる状況にあるかを調査し，原因を取り除いて再度実行してください。
KFPX29690-E
メモリ不足が発生しました。処理を終了します。　　（Ｄ）
メモリ不足が発生しました。
(Ｓ)処理を終了します。
[対策]メモリを増やすか，又は不要なアプリケーションを終了させて，再度実行してください。
KFPX29691-E
HiRDBの開始処理でエラーが発生しました。イベントビューアに出力されているメッセージを参照し，メッセージに対する対処を行ってください。　　（Ｄ）
HiRDBの開始処理でエラーが発生しました。イベントビューアに出力されているメッセージを参照して対処する必要があります。
(Ｓ)処理を終了します。
[対策]イベントビューアに出力されているメッセージを参照し，原因を取り除いて再度実行してください。
KFPX29692-Q
オペランド[aa....aa]を削除します。よろしいですか？　　（Ｄ）
オペランドaa....aaの削除確認メッセージです。
aa....aa：オペランド名
(Ｓ)メッセージの応答に対する処理を行います。
KFPX29693-Q
オペランド[aa....aa]のオプションフラグ[bb....bb]を削除します。よろしいですか？　　（Ｄ）
aa....aaオペランドのオプションフラグbb....bbの削除確認メッセージです。
aa....aa：オペランド名
bb....bb：オプションフラグ
(Ｓ)メッセージの応答に対する処理を行います。
KFPX29694-Q
オペランド[aa....aa]にはオプションフラグ[bb....bb]しか存在しません。削除する場合は，オペランド自体を削除することになります。よろしいですか？　　（Ｄ）
aa....aaオペランドのオプションフラグbb....bbの削除確認メッセージです。aa....aaオペランドにはオプションフラグbb....bbしかないため，オプションフラグを削除すると，同時にオペランドも削除されます。
aa....aa：オペランド名
bb....bb：オプションフラグ
(Ｓ)メッセージの応答に対する処理を行います。
KFPX29695-Q
オペランド[aa....aa]のオプションフラグ[bb....bb]は省略できません。削除する場合は，オペランド自体を削除することになります。よろしいですか？　　（Ｄ）
aa....aaオペランドのオプションフラグbb....bbの削除確認メッセージです。オプションフラグbb....bbは省略できないため，オプションフラグを削除すると，同時にオペランドも削除されます。
aa....aa：オペランド名
bb....bb：オプションフラグ
(Ｓ)メッセージの応答に対する処理を行います。
KFPX29696-Q
aa....aaを削除します。よろしいですか？　　（Ｄ）
aa....aaの削除確認メッセージです。
aa....aa：削除対象
(Ｓ)メッセージの応答に対する処理を行います。
KFPX29697-Q
システム定義のチェックが完了していないため，セットアップは開始できません。詳細定義を終了しますか？　　（Ｄ）
システム定義のチェックが完了していないのに，詳細定義画面を終了してよいかの確認メッセージです。システム定義のチェックが完了しないとセットアップは実行できません。
(Ｓ)メッセージの応答に対する処理を行います。
KFPX29698-Q
システム定義の内容が変更されていますが，定義更新処理をまだ行っていません。詳細定義を終了しますか？　　（Ｄ）
定義更新処理を実行しないのに，詳細定義画面を終了してよいかの確認メッセージです。
(Ｓ)メッセージの応答に対する処理を行います。
KFPX29699-Q
HiRDBが起動中です。HiRDBを停止してセットアップを続けますか？
注意：既にHiRDB環境が構築されているシステムの場合，セットアップを実行すると現在の環境に上書きされます。　　（Ｄ）
HiRDBの稼働中にセットアップツールを起動したため，HiRDBを終了してセットアップツールの処理を続行するかの確認メッセージです。
(Ｓ)メッセージの応答に対する処理を行います。
KFPX29700-Q
指定されたセットアップディレクトリは存在しません。[<aa....aa>]
ディレクトリを作成しますか？　　（Ｄ）
セットアップ先に作成されたディレクトリがない場合に，ディレクトリを作成するかどうかの確認メッセージです。
aa....aa：セットアップ先ディレクトリ名（カスタム画面の場合に表示されます）
(Ｓ)メッセージの応答に対する処理を行います。
KFPX29701-Q
開始画面に戻ると現在設定済みの情報はすべてリセットされます。処理を続行してよろしいですか？　　（Ｄ）
カスタム画面から開始画面に戻る場合は，カスタム画面で定義した情報がすべてデフォルトの状態に戻ってしまいますが，このまま続行してよいかの確認メッセージです。
(Ｓ)メッセージの応答に対する処理を行います。
KFPX29702-Q
セットアップ先のHiRDB環境にはシステム定義ファイルが存在します。既存ファイルのバックアップを作成しますか？　　（Ｄ）
セットアップ時に既存のシステム定義ファイルのバックアップを作成するかどうかの確認メッセージです。
(Ｓ)メッセージの応答に対する処理を行います。
KFPX29703-Q
既にHiRDB環境が存在します。セットアップを続けますか？
■注意：既にHiRDB環境が構築されているシステムの場合，セットアップを続行すると現在の環境に上書きされます。　　（Ｄ）
既存のHiRDBの環境に対してセットアップを続行するかどうかの確認メッセージです。
(Ｓ)メッセージの応答に対する処理を行います。
KFPX29704-I
HiRDBのセットアップ処理を開始します。　　（Ｄ）
セットアップ開始メッセージです。
(Ｓ)処理を続行します。
KFPX29705-I
セットアップ処理を中断しました。　　（Ｄ）
セットアップ中断メッセージです。
(Ｓ)処理を続行します。
KFPX29706-I
本バージョンのHiRDBではシステム定義ファイルの予備系への配布ができません。手動で配布してください。　　（Ｄ）
HiRDBのバージョンが古いため，システム定義ファイルを予備系に配布できません。バージョン06-02-/E以降を使用してください。バージョンアップできない場合は手動で配布してください。
(Ｓ)処理を続行します。
[対策]システム定義ファイルを手動で予備系ホストに配布してください。
KFPX29707-E
セットアップディレクトリを指定してください。　　（Ｄ）
セットアップディレクトリを指定しないでセットアップを実行しようとしました。
(Ｓ)エラーメッセージを表示し，セットアップディレクトリを指定して実行されるのを待ちます。
[対策]セットアップディレクトリを指定して実行してください。


KFPYメッセージ

KFPY01001-E
Defined PLUGIN name aa....aa not matched between units, unit=bb....bb　　（Ｌ）
bb....bbユニットのシステム共通定義のpdpluginオペランドに指定したプラグイン名称aa....aaが，ディクショナリサーバがあるユニットのシステム共通定義のpdpluginオペランドに指定した名称と異なります。
aa....aa：プラグイン名
bb....bb：ディクショナリサーバがあるユニットとpdpluginオペランドの不一致を起こしたユニットの識別子
(Ｓ)異常終了します。
[対策]ディクショナリサーバがあるユニットと，ユニットIDがbb....bbのユニット間で，システム共通定義に記述されたpdpluginオペランドが一致するように修正してください。
なお，KFPY01002-Wメッセージが出力されている場合，そのメッセージの対策をしてください。
KFPY01002-W
PLUGIN aa....aa not registered　　（Ｌ）
プラグインaa....aaは登録されていません。
aa....aa：プラグイン名
(Ｓ)処理を続行します。
[対策]次に示すどちらかの対策をしてください。
・システム共通定義のpdpluginオペランドに指定したプラグイン名に誤りがある場合，pdpluginオペランドに正しいプラグイン名を記述してください。また，プラグインaa....aaを利用できる状態にするには，HiRDBを再開始してください。
・プラグインaa....aaをpdplgrgstコマンドで登録していない場合，システム共通定義にaa....aaのpdpluginオペランドを指定していない状態でHiRDBを開始し，pdplgrgstコマンドでaa....aaを登録します。aa....aaを使用する場合は，HiRDBを停止し，システム共通定義にaa....aa pdpluginオペランドを記述して，HiRDBを開始してください。
KFPY01003-E
System command error occurred, cmd=aa....aa, code=bb....bb, inf="cc....cc"　　（Ｌ）
システムの内部コマンドでエラーが発生しました。
aa....aa：コマンド名
bb....bb：シェルの終了コード
cc....cc：コマンドのエラー出力情報
(Ｓ)異常終了します。
[対策]次に示すどちらかの対策をしてください。
・aa....aaが"rcp"の場合，リモートシェル実行環境の設定に誤りがあるか，又は設定がされていません。
マニュアル「HiRDB Version 7 システム導入・設計ガイド」の「リモートシェル実行環境の設定」を参照して設定をした後，HiRDBを開始してください。
・aa....aaが"rcp"以外の場合，cc....ccのエラー出力情報とbb....bbシェルの終了コードを基に，ユーザが使用しているOSのマニュアルを参照してエラーの原因を取り除いた後，HiRDBを開始してください。
KFPY01004-E
Copy error, code=aa....aa, unit=bb....bb　　（Ｌ）
プラグイン内部情報をディクショナリサーバからユニット識別子bb....bbのユニットへのコピーに失敗しました。
aa....aa：エラーを検出した関数のリターンコード
bb....bb：コピー先のユニットID
(Ｓ)異常終了します。
[対策]このメッセージの前にOSのメッセージ，又はOSコマンドのメッセージが出力されている場合は，OSのマニュアルを参照して対策してください。
確認した内容に問題がない場合は，保守員に連絡してください。
KFPY01005-E
System error, func=aa....aa, code=bb....bb, call func=cc....cc, line=dd....dd　　（Ｌ）
内部処理で異常を検知しました。
aa....aa：異常が発生した関数名
bb....bb：エラー番号
cc....cc：異常が発生した関数を呼び出した関数名
dd....dd：行番号
(Ｓ)異常終了します。
[対策]次のファイルを保存し，保守員に連絡してください。HiRDBがダウンしている場合は再開始してください。
・$PDDIR/spool及び$PDDIR/tmp下にあるファイル
・syslogfile（Windows NTの場合はイベントログ）
KFPY01006-I
PLUGIN available, unit=aa....aa, PLUGIN name=bb....bb　　（Ｌ）
プラグインbb....bbはユニットaa....aaで利用できます。
aa....aa：ユニットID
bb....bb：プラグイン名
(Ｓ)処理を続行します。
KFPY01007-E
Insufficient memory, memory kind="aa....aa", size=bb....bb　　（Ｌ）
メモリ不足が発生しました。
aa....aa：メモリ種別
SHARE：共用メモリ
PROCESS：プロセスメモリ
bb....bb：取得しようとしたメモリサイズ
(Ｓ)異常終了します。
[対策]aa....aa種別に応じて対策してください。
〈aa....aa種別がSHAREの場合〉
次のファイルを保存し，保守員に連絡した後，HiRDBを開始してください。
・$PDDIR/spool及び$PDDIR/tmp下にあるファイル
・syslogfile（Windows NTの場合はイベントログ）
〈aa....aa種別がPROCESSの場合〉
同時に実行しているプロセスの終了を待って，再度コマンドを実行してください。繰り返し発生する場合は，次のファイルを保存し，保守員に連絡してください。
・$PDDIR/spool及び$PDDIR/tmp下にあるファイル
・syslogfile（又はイベントログ）
KFPY01008-E
PLUGIN error, PLUGIN name=aa....aa, inf1=bb....bb, inf2=cc....cc　　（Ｌ）
プラグインaa....aaが異常を検知しました。
aa....aa：プラグイン名
bb....bb：保守情報１
cc....cc：保守情報２
(Ｓ)処理が続行できる場合は，処理を中断してロールバックします。処理が続行できない場合は，異常終了します。
[対策]このメッセージの前に出力されたメッセージを調査し，問題がある場合は，該当するメッセージに対する処理を実行してください。メッセージが出力されていない場合は，次のファイルを保存し，保守員に連絡してください。
・$PDDIR/spool，$PDDIR/tmp，及び$PDDIR/plugin下にあるファイル
・$PDDIR/conf下にあるpdsys
・syslogfile（Windows NTの場合はイベントログ）
KFPY01010-E
Failed to load PLUGIN, PLUGIN name=aa....aa, reason="bb....bb", unit=cc....cc　　（Ｌ）
プラグインのロードに失敗しました。
aa....aa：プラグイン名
bb....bb：原因コード
"NO LIBRARY"
"NO PERMISSION"
"NO SPACE"
"BROKEN"
cc....cc：ユニット識別子
(Ｓ)異常終了します。
[対策]次に従って対策してください。
〈原因コードがNO LIBRARYの場合〉
プラグインaa....aaがありません。$PDDIR/plugin/lib下にプラグインaa....aaのライブラリファイルがあるか確認してください。ない場合は，pdplgsetコマンドでプラグインをセットアップし，HiRDBを再開始してください。
〈原因コードがNO PERMISSIONの場合〉
プラグインaa....aaのライブラリに対するアクセス権限がありません。
HiRDBが停止している状態でpdplgset -dコマンドでプラグインaa....aaをアンセットアップ後，再度セットアップしてください。Windows NTの場合，HiRDBが停止している状態でプラグインをアンインストールしてから，再度インストールしてください。
この対策で問題が解消しない場合は，次のファイルを保存して，保守員に連絡してください。
・$PDDIR/spool，$PDDIR/tmp，及び$PDDIR/plugin下にあるファイル
・syslogfile（Windows NTの場合はイベントログ）
〈原因コードがNO SPACEの場合〉
プラグインaa....aaをプロセスのアドレス空間にロードするための領域が足りません。同時に実行するプラグインを減らしてください。
〈原因コードがBROKENの場合〉
プラグインaa....aaは破壊されています。
HiRDBが停止している状態でpdplgset -dコマンドを実行して，プラグインaa....aaをアンセットアップ後，再度セットアップしてください。Windows NTの場合，HiRDBが停止している状態でプラグインをアンインストールしてから，再度インストールしてください。
この対策で問題が解消しない場合は，プラグインaa....aaを再インストールした後，再度この対策を実行してください。
KFPY01011-E
Not found function in PLUGIN, PLUGIN name=aa....aa, function=bb....bb, unit=cc....cc　　（Ｌ）
ユニットcc....ccのプラグインaa....aaに関数bb....bbがありませんでした。
aa....aa：プラグイン名
bb....bb：プラグイン関数
cc....cc：ユニット識別子
(Ｓ)異常終了します。
[対策]次のファイルを保存して，保守員に連絡してください。
・$PDDIR/spool，$PDDIR/tmp，及び$PDDIR/plugin下にあるファイル
・$PDDIR/conf下にあるpdsys
・syslogfile（Windows NTの場合はイベントログ）
KFPY01012-E
PLUGIN not available, unit=aa....aa, PLUGIN name=bb....bb　　（Ｌ）
プラグインbb....bbは，ユニットaa....aaでは利用できません。
aa....aa：ユニットID
bb....bb：プラグイン名
(Ｓ)プラグイン利用宣言がないものとして処理を続行するか，又は異常終了します。
[対策]
ワーニングメッセージKFPY01002-Wが出力されている場合
・誤ったプラグイン名bb....bbを指定しています。正しいプラグイン名をシステム共通定義のpdpluginオペランドに指定して，HiRDBを再度開始してください。
・プラグインbb....bbは，pdplgrgstコマンドによって登録されていません。システム共通定義のbb....bbに対するpdpluginオペランドを削除して，HiRDBを開始してください。bb....bbをpdplgrgstコマンドで登録してください。HiRDBを停止後，再度開始してください。
ワーニングメッセージKFPY01002-Wが出力されていない場合
・ユニット間でシステム共通定義のpdpluginオペランドが異なっています。ユニット間でHiRDBシステム共通定義のpdpluginオペランドの内容が一致するように修正してください。
・HiRDB Object Optionが組み込まれていません。HiRDB Object Optionを組み込んでください。
KFPY01013-E
Failed to execute rollback for PLUGIN, PLUGIN name=aa....aa, PLUGIN ID=bb....bb, unit=cc....cc, inf=dd....dd　　（Ｌ）
プラグインaa....aaが更新したRDエリアのロールバックに失敗しました。
aa....aa：プラグイン名
利用宣言がされていないプラグインのロールバック処理をしようとした場合，"****"が表示されます。
bb....bb：プラグインID
cc....cc：ユニットID
dd....dd：保守情報（RDエリアID）
(Ｓ)プラグインがロールバックしようとしたRDエリアを閉塞し，処理を続行します。
(Ｐ)プラグインがロールバックしようとしたRDエリアを閉塞し，処理を続行します。
[対策]このメッセージの後に出力されているKFPH00306-Eメッセージを参照し，閉塞したRDエリアを回復してください。このメッセージ以外にKFPYxxxxx-Eのメッセージが出力されている場合は，そのメッセージ参照して対策してください（xxxxx：５けたのメッセージ番号）。
KFPY01015-W
PLUGIN not available due to held dictionary RDAREA　　（Ｌ）
ディクショナリRDエリアが閉塞しているため，プラグインが利用できません。
(Ｓ)プラグインが利用できない状態でHiRDB開始処理を続行します。
[対策]マニュアル「HiRDB Version 7 システム運用ガイド」の障害発生時の運用方法の記述内容を参照して，ディクショナリRDエリアを回復してください。
KFPY01016-E
Unable to call PLUGIN, PLUGIN ID=aa....aa, unit=bb....bb, reason code="cc....cc"　　（Ｌ）
プラグインIDがaa....aaのプラグインは，cc....ccの理由で呼び出せませんでした。
aa....aa：プラグインID
bb....bb：ユニットID
cc....cc：理由コード
UNAVAILABLE：プラグインIDがaa....aaのプラグインは利用できません。
UNDEFINED：プラグインIDがaa....aaのプラグインに対するpdpluginオペランドが定義されていません。又は，プラグインの初期化処理でエラーが発生しました。
(Ｓ)データベース回復ユティリティの実行時は実行を中止します。リランの場合は，回復しようとしたRDエリアを閉塞し，処理を続行します。
[対策]
〈理由コードが"UNAVAILABLE"の場合〉
このメッセージの前に出力されているKFPYnnnnn（nnnnn：5けたのメッセージ番号）のメッセージに従って対策してください。
〈理由コードが"UNDEFINED"の場合〉
HiRDBを停止し，プラグインIDがaa....aaのプラグインの利用宣言（pdpluginオペランド）をシステム共通定義に記述して，HiRDBを開始してください。
プラグインIDがaa....aaのプラグインをセットアップしていないときは，pdplgsetでプラグインをセットアップしてください。Windows NTの場合，プラグインIDがaa....aaのプラグインをインストールしていないときは，プラグインをインストールしてください。
それ以外のときは，このメッセージの前に出力されているKFPYnnnnn（nnnnn：5けたのメッセージ番号）のメッセージに従って対策してください。
KFPY01017-E
PLUGIN aa....aa not setup, unit=bb....bb　　（Ｌ）
プラグインaa....aaは，セットアップされていません。又は，誤ったプラグイン名aa....aaをシステム共通定義のpdpluginオペランドに指定しています。
aa....aa：プラグイン名
bb....bb：ユニットID
(Ｓ)プラグインaa....aaが利用できない状態で処理を続行します。
[対策]
次に従って対策してください。
・プラグインaa....aaがセットアップされていない場合，HiRDBを停止後，pdplgsetでプラグインaa....aaをセットアップし，再度HiRDBを開始してください。Windows NTの場合，プラグインaa....aaがインストールされていない場合，HiRDBを停止後，プラグインをインストールしてから，再度HiRDBを開始してください。
・誤ったプラグイン名aa....aaをシステム共通定義のpdpluginオペランドに指定している場合，HiRDBを停止後，システム共通定義のpdpluginオペランドに正しいプラグイン名を指定して，再度HiRDBを開始してください。
KFPY01018-E
PIC file broken, PLUGIN name=aa....aa, unit=bb....bb, inf=cc....cc　　（Ｌ）
プラグイン名aa....aaのPICファイルが破壊されています。
aa....aa：プラグイン名
bb....bb：ユニットID
cc....cc：保守情報（理由コード）
1：アイキャッチャーが不一致です。
2：不正なデータです。
3：データがありません。
(Ｓ)プラグインaa....aaが利用できない状態で処理を続行します。
[対策]HiRDBを停止後，プラグインaa....aaをpdplgset -dによってアンセットアップし，再度セットアップ後にHiRDBを開始してください。
アンセットアップすると$PDDIR/plugin/aa....aa下にあるすべてのファイルが削除されます。そのため，必要なファイルがある場合は，事前に退避する必要があります。
Windows NTの場合，HiRDBを停止後，プラグインをインストールしてから，再度HiRDBを開始してください。
KFPY01019-E
Failed to read PIC file, PLUGIN name=aa....aa, unit=bb....bb, func=cc....cc, code=dd....dd　　（Ｌ）
プラグインaa....aaのPICファイルの読み込みに失敗しました。
aa....aa：プラグイン名
bb....bb：ユニットID
cc....cc：エラーが発生した関数名
dd....dd：関数のエラーコード
(Ｓ)プラグインaa....aaが利用できない状態で処理を続行します。
[対策]エラーコードdd....ddを基にerrno.h及びユーザが使用するOSのマニュアルを参照し，対策してください。
対策後，プラグインを利用する場合は，HiRDBを停止し，再度HiRDBを開始してください。
KFPY01020-E
No PLUGIN available, unit=aa....aa　　（Ｌ）
ユニットaa....aaのすべてのプラグインは利用できません。
aa....aa：ユニットID
(Ｓ)ユニットaa....aaですべてのプラグインが利用できない状態で処理を続行します。
[対策]このメッセージの前に出力されているKFPYnnnnn（nnnnn：5けたのメッセージ番号）のメッセージに従って対策してください。
KFPY01021-E
Too long path name, unit=aa....aa, file name=bb....bb　　（Ｌ）
ファイル名bb....bbのパスが長過ぎます。
aa....aa：ユニットID
bb....bb：ファイル名
(Ｓ)処理を続行します。
[対策]ファイルbb....bbの絶対パスの長さがシステムの上限値を超えないように，HiRDB運用ディレクトリを作成してください。
KFPY01022-E
aa....aa　　（Ｌ）
システムコールで発生したエラーの情報を出力します。OSのシステムログ機能が日本語文字コードに対応していない場合，メッセージがシステムログに正しく出力されないことがあります。この場合，HiRDBのメッセージログを参照してください。
aa....aa：エラー情報
(Ｓ)処理を続行します。
KFPY01023-E
System call error, func=aa....aa, PLUGIN=bb....bb　　（Ｌ）
システムコールでエラーが発生しました。
aa....aa：エラーが発生した関数名
bb....bb：プラグイン名
(Ｓ)処理を続行します。
[対策]このメッセージの前に出力されたKFPY01022-Iメッセージの内容に従って，エラーの原因を取り除き，HiRDBを停止した後にHiRDBを再開始してください。
KFPY01024-E
PLUGIN aa....aa not defined in system definition file, operand=bb....bb, server=cc....cc　　（Ｌ）
サーバcc....ccのサーバ定義のオペランドbb....bbで指定されたプラグインaa....aaは，システム共通定義に定義されていません。
aa....aa：プラグイン名
bb....bb：オペランド名
cc....cc：サーバ名
(Ｓ)異常終了します。
[対策]サーバcc....ccのサーバ定義のオペランドbb....bbで指定されたプラグインaa....aaが，システム共通定義のpdpluginオペランドで指定されていることを確認してください。
KFPY01025-E
Duplicate aa....aa operand for PLUGIN bb....bb in cc....cc server definition file　　（Ｌ）
サーバcc....ccのサーバ定義で，プラグインbb....bbを指定したオペランドaa....aaが重複しています。
aa....aa：オペランド名
bb....bb：プラグイン名
cc....cc：サーバ名
(Ｓ)異常終了します。
[対策]サーバcc....ccのサーバ定義を見直して，オペランドaa....aaのプラグインbb....bbの指定を修正してください。
KFPY01026-E
Error found in system definition, file=aa....aa, line=bb....bb　　（Ｌ）
システム定義の内容に誤りがあります。
aa....aa：システム定義のファイル名
bb....bb：行番号
(Ｓ)異常終了します。
[対策]システム定義のファイルaa....aaの内容を修正して，再度実行してください。
KFPY01027-E
PLUGIN library aa....aa incompatible load model type with HiRDB　　（Ｌ）
プラグインライブラリaa....aaのロード種別（POSIXライブラリ版，又は非POSIXライブラリ版）と，HiRDBのロード種別が一致していません。
aa....aa：プラグイン名
(Ｓ)プラグイン利用宣言がないものとして処理を続行します。
[対策]HiRDBのロード種別に合わせたプラグインを，再度登録してください。
KFPY01028-E
Incompatible PLUGIN library format with HiRDB, PLUGIN data model=aa, HiRDB data model=bb　　（Ｌ）
プラグインライブラリの形式がHiRDBと一致していません。
aa：プラグインのデータモデル
bb：HiRDBのデータモデル
(Ｓ)プラグイン利用宣言がないものとして処理を続行します。
[対策]aaが32でbbが64の場合，プラグインを64ビットモードにしてください。aaが64でbbが32の場合，HiRDBを64ビットモードにするか，又はプラグインを32ビットモードにしてください。なお，64ビットモードのHiRDBに移行した場合，32ビットモードのHiRDBには戻せません。
KFPY01200-I
PLUGIN setup start, func="aa....aa", PLUGIN name=bb....bb　　（Ｌ＋Ｓ）
プラグインセットアップ処理を開始します。
aa....aa：機能名
add：プラグインのセットアップ
delete：プラグインの削除
bb....bb：プラグイン名
(Ｓ)処理を続行します。
KFPY01201-I
PLUGIN setup ended, return code=aa....aa　　（Ｌ＋Ｓ）
プラグインセットアップ処理を終了します。
aa....aa：終了コード
０：正常終了しました。
８：処理中に異常が発生しました。
(Ｓ)処理を終了します。
[対策]終了コードが0以外のときは，このメッセージの前に出力されたKFPY012nn-E（nn：２けたの数字）メッセージ，及びOSコマンドのメッセージを参照して対策してください。
KFPY01202-I
Usage: pdplgset plugin_name installed_plugin_directory
pdplgset -d plugin_name　　（Ｓ）
pdplgsetコマンドの使用方法を示します。コマンドの形式が誤っている場合に出力されます。
(Ｓ)処理を終了します。
[対策]コマンドの形式を見直して，再度実行してください。
KFPY01203-E
Invalid "PDDIR", path name="aa....aa"　　（Ｅ＋Ｌ）
環境変数PDDIRの内容が不正です。
aa....aa：環境変数PDDIRに設定されている内容
なお，表示されない場合は，PDDIRに値が設定されていません。
(Ｓ)処理を終了します。
[対策]次の対策をしてください。
〈aa....aaが表示されている場合〉
・PDDIRに正しいHiRDB運用ディレクトリが設定されているか確認してください。誤ったパスを指定している場合は，正しいパスを設定して，再度コマンドを実行してください。
・PDDIRにHiRDB運用ディレクトリの絶対パスが設定されているか確認してください。相対パスの場合，絶対パスをPDDIRに設定して，再度コマンドを実行してください。
〈aa....aaが表示されていない場合〉
・PDDIRにHiRDB運用ディレクトリの絶対パス名を指定して，再度コマンドを実行してください。
KFPY01204-E
PLUGIN aa....aa already setup　　（Ｅ＋Ｌ）
指定されたプラグインaa....aaは，既にセットアップされています。
aa....aa：プラグイン名
(Ｓ)処理を終了します。
[対策]前回実行したプラグインaa....aaのセットアップコマンドが正常終了している場合は，再度実行する必要はありません。
前回aa....aaのセットアップが正常終了していない場合は，pdplgset -dを実行した後，再度pdplgsetコマンドを実行してください。
KFPY01206-E
Permission error occurred, path name=aa....aa　　（Ｅ＋Ｌ）
aa....aaにアクセス権限がありません。次に示す原因が考えられます。
・コマンドの引数が正しく指定されていません。
・インストールディレクトリにアクセス権限がありません。
・内部処理のOSコマンドでエラーが発生しました。
・その他（前記の原因以外の原因）
aa....aa：読み込み又は書き込みができなかったファイル，又はディレクトリ
(Ｓ)処理を終了します。
[対策]
〈コマンドの引数が正しく指定されていない場合〉
コマンドの引数を正しく指定して再度実行してください。
〈インストールディレクトリにアクセス権限がない場合〉
インストールディレクトリを削除してインストールし直してください。又は，HiRDB管理者がアクセスできるように権限を与えてください。
〈内部処理のOSコマンドでエラーが発生した場合〉
OSコマンドのエラーメッセージに従って，エラーの原因を調査して対策してください。
〈そのほかの場合〉
$PDDIR/plugin下にあるファイル，及び引数に指定したインストールディレクトリ下のファイルを保存し，保守員に連絡してください。
KFPY01207-E
Failed to create file or directory, path name="aa....aa"　　（Ｅ＋Ｌ）
ファイル又はディレクトリaa....aaの作成に失敗しました。次に示す原因が考えられます。
・HiRDB管理者の権限でコマンドを実行していません。
・HiRDB管理者の権限でHiRDB運用ディレクトリに書き込み権限がありません。
・内部処理で実行したOSコマンドでエラーが発生しました。
・その他（前記の原因以外の原因）
aa....aa：作成に失敗したファイル又はディレクトリ
(Ｓ)処理を終了します。
[対策]
〈HiRDB管理者の権限でコマンドを実行していない場合〉
HiRDB管理者の権限でコマンドを実行してください。
〈HiRDB管理者の権限でHiRDB運用ディレクトリに書き込み権限がない場合〉
HiRDB運用ディレクトリに書き込み権限を与えてください。
〈内部処理で実行したOSコマンドでエラーが発生した場合〉
OSコマンドのエラーメッセージが出力されているときは，そのメッセージに従ってエラーの原因を調査して対策してください。
〈そのほかの場合〉
$PDDIR/plugin下にあるファイルを保存し，保守員に連絡してください。
KFPY01208-E
File or directory not exists, path name=aa....aa　　（Ｅ＋Ｌ）
ファイル又はディレクトリaa....aaがありません。次に示す原因が考えられます。
・コマンドの引数が正しく指定されていません。
・インストールディレクトリが破壊されています。
・内部処理のOSコマンドでエラーが発生しました。
・その他（前記の原因以外の原因）
aa....aa：参照しようとしたファイル名又はディレクトリ名
(Ｓ)処理を終了します。
[対策]
〈コマンドの引数が正しく指定されていない場合〉
コマンドの引数を正しく指定して再度実行してください。
〈インストールディレクトリが破壊されている場合〉
セットアップしようとしたプラグインを再インストールしてください。
〈内部処理のOSコマンドでエラーが発生した場合〉
OSコマンドのエラーメッセージが出力されているときは，そのメッセージに従ってエラーの原因を調査して対策してください。
〈そのほかの場合〉
$PDDIR/plugin下にあるファイル，及びコマンドの引数に指定したインストールディレクトリ下のファイルを退避し，保守員に連絡してください。
KFPY01209-E
Not a directory, path name=aa....aa　　（Ｅ＋Ｌ）
aa....aaはディレクトリではありません。
aa....aa：参照しようとしたディレクトリ名
(Ｓ)処理を終了します。
[対策]引数に指定したパスが誤っていないか確認し，誤っている場合は正しいインストールディレクトリを指定して再度コマンドを実行してください。
HiRDB運用ディレクトリにpluginというファイルを独自に作成している場合は，名称を変更してください。
KFPY01210-E
PLUGIN aa....aa not installed　　（Ｅ＋Ｌ）
プラグインaa....aaはインストールされていません。
aa....aa：プラグイン名
(Ｓ)処理を終了します。
[対策]引数に指定したパスが正しいか確認し，誤っている場合は正しいパスを指定して再度コマンドを実行してください。
プラグインaa....aaがインストールされていない場合は，インストールしてください。
KFPY01211-E
Internal error occurred, func=aa....aa, location=bb....bb, info="cc....cc"　　（Ｅ＋Ｌ）
内部エラーが発生しました。
aa....aa：内部矛盾が発生した関数名
bb....bb：aa....aa内の位置
cc....cc：エラー情報
(Ｓ)異常終了します。
[対策]$PDDIR/plugin下にあるファイル，syslogfile（Windows NTの場合はイベントログ），及びコマンドの実行画面に表示されたOSコマンドのメッセージが出力されている場合は，そのメッセージを保存し，保守員に連絡してください。
HiRDBを開始するときは，全ユニットのシステム共通定義からセットアップしようとしたプラグインのpdpluginオペランドを削除して開始してください。
KFPY01213-E
Specified directory not full path name　　（Ｅ＋Ｌ）
指定したディレクトリは絶対パス名ではありません。
(Ｓ)処理を終了します。
[対策]コマンドの引数に絶対パスでインストールディレクトリを指定して実行してください。
KFPY01214-E
PLUGIN aa....aa not setup　　（Ｅ＋Ｌ）
プラグインaa....aaはセットアップされていません。次に示す原因が考えられます。
・引数に指定したプラグイン名が誤っています。
・環境変数PDDIRに設定しているパスが誤っています。
・引数に指定したプラグイン名のプラグインは，セットアップされていません。
aa....aa：プラグイン名
(Ｓ)処理を終了します。
[対策]
〈引数に指定したプラグイン名が誤っている場合〉
引数に正しいプラグイン名を指定して，再度コマンドを実行してください。
〈環境変数PDDIRに設定しているパスが誤っている場合〉
環境変数PDDIRに正しいパスを指定して，再度コマンドを実行してください。
〈引数に指定したプラグイン名のプラグインがセットアップされていない場合〉
コマンドを実行する必要はありません。
KFPY01215-E
Unable to execute aa....aa command while HiRDB running　　（Ｅ＋Ｌ）
HiRDBが起動しているためコマンドを実行できません。
aa....aa：実行したコマンド名
(Ｓ)処理を終了します。
[対策]HiRDBが停止しているときにコマンドを実行してください。
KFPY01216-E
Pdplgset already used by another user　　（Ｅ＋Ｌ）
既にpdplgsetコマンドを実行中です。
(Ｓ)処理を終了します。
[対策]現在実行しているpdplgsetコマンドが終了するのを待って，再度pdplgsetコマンドを実行してください。
KFPY01227-E
PLUGIN library aa....aa incompatible load model type with HiRDB　　（Ｌ）
プラグインライブラリaa....aaのロード種別（POSIXライブラリ版，又は非POSIXライブラリ版）と，HiRDBのロード種別が一致していません。
aa....aa：プラグイン名
(Ｓ)処理を終了します。
[対策]HiRDBのバージョンに合わせたプラグインをインストールして，HiRDBのロード種別に合ったプラグインを指定して再度実行してください。
KFPY02001-E
Fatal error, inf=aa....aa　　（Ｅ）
コマンドの実行中に致命的なエラーが発生しました。
aa....aa：保守情報
(Ｓ)処理を終了します。
[対策]保守員に連絡してください。
KFPY02006-E
Invalid arguments
usage: pdplgrgst [{-a|-d}] [-u] definition_file PIC file　　（Ｅ）
プラグイン定義ファイル，又はPICファイルの指定が不正です。コマンドの使用方法を出力します。
(Ｓ)処理を終了します。
[対策]コマンドラインの引数として，プラグイン定義ファイル名とPICファイル名を指定してください。ファイル名が正しく指定されているか確認した後，再度コマンドを実行してください。
KFPY02007-E
Read error occurred, file="aa....aa", errno=bbb　　（Ｅ）
ファイルaa....aaの読み込みでエラーが発生しました。
aa....aa：読み込みに失敗したファイル名
bbb：errnoに設定された値
(Ｓ)処理を終了します。
[対策]errno（エラー状態を表す外部整数変数）の値を基にerrno.h，及びユーザが使用しているOSのマニュアルを参照してエラーの原因を取り除いた後，再度コマンドを実行してください。
KFPY02010-E
Insufficient process local memory, size=aa....aa　　（Ｅ）
コマンドの実行時にプロセス固有領域を確保しようとしましたが，メモリ不足のために確保できません。
aa....aa：確保しようとした領域サイズ（単位：バイト）
(Ｓ)処理を終了します。
[対策]大量にメモリを実行するプロセスがほかにあるか確認し，次に示す処置をしてください。
〈大量にメモリを使用するプロセスがある場合〉
プロセスの終了を待って，再度コマンドを実行してください。
〈大量にメモリを使用するプロセスがない場合〉
不要なプロセスを終了させて，再度コマンドを実行してください。再度，このメッセージが出力された場合には，保守員に連絡してください。
KFPY02011-E
Invalid PLUGIN definition file, file=aa....aa　　（Ｅ）
プラグイン定義ファイルの内容が不正です。
aa....aa：コマンドラインに指定されたファイル名
(Ｓ)処理を終了します。
[対策]コマンドラインの引数で指定したファイルが，プラグイン定義ファイルであることを確認してください。
KFPY02012-E
Invalid PIC file, file=aa....aa　　（Ｅ）
PICファイルの内容が不正です。
aa....aa：コマンドラインに指定されたファイル名
(Ｓ)処理を終了します。
[対策]コマンドラインの引数で指定したファイルが，PICファイルであることを確認してください。
KFPY02013-E
aaaaa type "bb....bb" already defined　　（Ｅ）
抽象データ型又はインデクス型bb....bbは既に定義されています。
aaaaa：型種別
Data：抽象データ型
Index：インデクス型
bb....bb：既に定義されている型の名称
(Ｓ)処理を終了します。
[対策]型bb....bbがユーザが定義した抽象データ型の場合，プラグインを使用するためには抽象データ型bb....bbを削除してください。型bb....bbがユーザが定義した抽象データ型でない場合，プラグインは正常に登録されていません。pdplgrgstコマンドを-dオプションを指定して実行してプラグインをHiRDBから削除し，再度プラグインを登録してください。
KFPY02014-E
PLUGIN definition file aa....aa not correspond to PIC file bb....bb　　（Ｅ）
指定されたプラグイン定義ファイルは，指定されたPICファイルに対応しません。
aa....aa：コマンドラインに指定されたプラグイン定義ファイル名称
bb....bb：コマンドラインに指定されたPICファイル名称
(Ｓ)処理を終了します。
[対策]コマンドラインの引数に指定したプラグイン定義ファイルとPICファイルが，共に登録しようとしているプラグインのものであることを確認し，再度コマンドを実行してください。
KFPY02015-E
PLUGIN aa....aa already registered in schema "bb....bb"　　（Ｅ）
プラグインaa....aaは既にHiRDBに登録されています。
aa....aa：登録しようとしたプラグインの名称
bb....bb：プラグインが登録されているスキーマ
(Ｓ)処理を終了します。
[対策]プラグインaa....aaは既にHiRDBに登録されています。プラグインを利用するためには，システム共通定義ファイルにpdpluginオペランドを記述し，HiRDBを再開始してください。プラグインを削除するためには，pdplgrgstコマンドを-dオプションを指定して実行してください。プラグインのバージョンアップをするには，-aオプションを指定して実行してください。
KFPY02016-I
Processing of PLUGIN aa....aa ended, PLUGIN=bb....bb, return code=c　　（Ｅ）
プラグインの登録又は削除が終了しました。
aa....aa：処理の内容
registration：登録
unregistration：削除
updating：バージョンアップ
bb....bb：プラグイン名称
c：終了コード（0又は8）
(Ｓ)処理を終了します。
[対策]終了コードが0以外の場合は，このメッセージより前に出力されたメッセージに従い対処してください。なお，次の場合はプラグイン名称として********が出力されます。
・コマンドラインの引数の指定に誤りがあるとき
・コマンドラインに指定されたプラグイン定義ファイルとPICファイルの対応が不正なとき
・HiRDBとの接続に失敗したとき
・環境変数PDUSERの設定がDBA権限のあるユーザの設定でないとき
・メモリ確保に失敗したとき
KFPY02017-E
PLUGIN aa....aa not registered　　（Ｅ）
プラグインaa....aaは登録されていません。
aa....aa：削除しようとしたプラグインの名称
(Ｓ)処理を終了します。
[対策]プラグインaa....aaはHiRDBに登録されていないか，既に削除されています。プラグインを登録する場合は，-a又は-dオプションのどちらも指定しないでください。プラグイン登録時に-uオプションを指定してpdplgrgstコマンド実行者のスキーマに登録した場合は，削除又はバージョンアップするときにも-uオプションを指定してください。
KFPY02018-E
PLUGIN aa....aa registered in schema "bb....bb", not in schema "cc....cc"　　（Ｅ）
プラグインaa....aaはスキーマbb....bbに登録されていますが，スキーマcc....ccには登録されていません。
aa....aa：プラグイン名称
bb....bb：プラグインが登録されているスキーマ
cc....cc：プラグインを削除する対象のスキーマ
(Ｓ)処理を終了します。
[対策]プラグインの削除対象のスキーマには，指定したプラグインは登録されていませんでした。pdplgrgstコマンドに指定するオプションと環境変数PDUSERの値を，次の表に従って設定し，再度コマンドを実行してください。
bb....bbの内容
指定するオプション
PDUSERの設定
MASTER
-d
DBA権限があるユーザ
MASTER以外
-d -u
ユーザbb....bbの認可識別子とパスワード
KFPY02019-E
Error occurred while unregistering PLUGIN, inf=aa....aa　　（Ｅ）
プラグイン削除のために実行したSQLでエラーが発生しました。
aa....aa：SQL実行エラー内容
(Ｓ)処理を終了します。
[対策]メッセージテキスト出力内容を基にエラーの原因を取り除き，再度コマンドを実行してください。
KFPY02021-E
Error occurred while updating PLUGIN, inf=aa....aa　　（Ｅ）
プラグインのバージョンアップ中にエラーが発生しました。
aa....aa：SQL実行エラー内容
(Ｓ)処理を終了します。
[対策]メッセージテキスト出力内容を基にエラーの原因を取り除き，再度コマンドを実行してください。
KFPY02022-E
Newer version of PLUGIN aa....aa registered, registered PLUGIN version=bb....bb, specified PLUGIN version=cc....cc　　（Ｅ）
新しいバージョンのプラグインが登録されています。
aa....aa：プラグイン名称
bb....bb：登録されているプラグインのバージョン
cc....cc：登録しようとしたプラグインのバージョン
(Ｓ)処理を終了します。
[対策]登録されているプラグインより古いバージョンのプラグインに更新できません。バージョンがbb....bbのプラグインをインストール，セットアップしてください。
KFPY02023-E
PLUGIN definition file incompatible with PIC file　　（Ｅ）
プラグイン定義ファイルとPICファイルが対応しません。
(Ｓ)処理を終了します。
[対策]プラグインが不適切にセットアップされています。セットアップし直してください。
KFPY02024-E
Newer version of HiRDB required to aa....aa version bb....bb of PLUGIN cc....cc　　（Ｅ）
バージョンがbb....bbのプラグインcc....ccを登録又はバージョンアップするには，新しいバージョンのHiRDBが必要です。
aa....aa：処理の内容
register：登録
update：バージョンアップ
bb....bb：プラグインのバージョン
cc....cc：登録又はバージョンアップしようとしたプラグイン
(Ｓ)処理を終了します。
[対策]HiRDBのバージョンアップをしてください。
KFPY02025-E
Incompatible PLUGIN library format with HiRDB, PLUGIN data model=aa, HiRDB data model=bb　　（Ｅ）
プラグインライブラリの形式がHiRDBと一致していません。
aa：プラグインのデータモデル
bb：HiRDBのデータモデル
(Ｓ)処理を終了します。
[対策]aaが32でbbが64の場合，プラグインを64ビットモードにしてください。aaが64でbbが32の場合，HiRDBを64ビットモードにするか，又はプラグインを32ビットモードにしてください。なお，64ビットモードのHiRDBに移行した場合，32ビットモードのHiRDBには戻せません。
KFPY02026-E
Object Option required　　（Ｅ）
HiRDB Object Optionが必要です。
(Ｓ)処理を終了します。
[対策]このコマンドの実行には，HiRDB Object Optionが必要です。HiRDB Object Optionを組み込んでください。
KFPY02027-E
PLUGIN library aa....aa incompatible load model type with HiRDB　　（Ｅ）
プラグインライブラリのロード種別（POSIXライブラリ版，又は非POSIXライブラリ版）と，HiRDBのロード種別が一致していません。
aa....aa：プラグイン名
(Ｓ)処理を終了します。
[対策]HiRDBのロード種別（POSIXライブラリ版，又は非POSIXライブラリ版）に合わせたプラグインを登録してから，再度実行してください。
KFPY02039-E
Open error occurred, file="aa....aa", errno=bbb　　（Ｅ）
プラグインを登録するときに使用するファイルaa....aaをオープンできません。
aa....aa：オープンに失敗したファイルの名前
bbb：エラー番号（errno）
(Ｓ)処理を終了します。
[対策]errno（エラー状態を表す外部整数変数）の値を基にerrno.h，及びユーザが使用しているOSのマニュアルを参照してエラーの原因を取り除いた後，再度コマンドを実行してください。
KFPY02101-E
Failed to get time　　（Ｅ）
現在時刻を取得できませんでした。
(Ｓ)処理を終了します。
[対策]保守員に連絡してください。
KFPY02110-E
Data type "aa....aa" not defined　　（Ｅ）
プラグインに必要なaa....aaという抽象データ型が定義されていません。
aa....aa：定義されていない抽象データ型名
(Ｓ)処理を終了します。
(Ｐ)aa....aaという抽象データ型を定義し，再度コマンドを実行してください。再度，このメッセージが出力される場合には，保守員に連絡してください。
[対策]保守員に連絡してください。
KFPY02111-E
Index type "aa....aa" not defined　　（Ｅ）
プラグインに必要なaa....aaというインデクス型が定義されていません。
aa....aa：定義されていないインデクス型名
(Ｓ)処理を終了します。
(Ｐ)aa....aaというインデクス型を定義し，再度コマンドを実行してください。再度，このメッセージが出力される場合には，保守員に連絡してください。
[対策]保守員に連絡してください。
KFPY02112-E
Duplicate data type PLUGIN for "aa....aa"　　（Ｅ）
aa....aaに対するデータ型プラグインは既に登録されています。
aa....aa：抽象データ型名
(Ｓ)処理を終了します。
[対策]既にこのプラグインが登録されている場合は，このコマンドを使用する必要はありません。このプラグインが登録されていない状態で，このメッセージが出力された場合には，保守員に連絡してください。
KFPY02113-E
Duplicate index type PLUGIN for "aa....aa"　　（Ｅ）
aa....aaに対するインデクス型プラグインは既に登録されています。
aa....aa：インデクス型名
(Ｓ)処理を終了します。
[対策]既に該当するプラグインが登録されている場合，このコマンドを使用する必要はありません。
KFPY02114-E
Duplicate PLUGIN name "aa....aa"　　（Ｅ）
aa....aaというプラグインは既に登録されています。
aa....aa：登録済みのプラグイン名
(Ｓ)処理を終了します。
[対策]既に該当するプラグインが登録されている場合，このコマンドを使用する必要はありません。
KFPY02120-E
PIC file error, inf=aa....aa　　（Ｅ）
PICファイルが不正です。
aa....aa：保守情報
(Ｓ)処理を終了します。
[対策]PICファイルの内容が破壊されているおそれがあります。プラグインのインストールとセットアップをし直してください。再度，このメッセージが出力される場合には，保守員に連絡してください。
KFPY02121-E
PIC file version error　　（Ｅ）
HiRDBのバージョンが，登録しようとしたプラグインの稼働できるバージョンではありません。
(Ｓ)処理を終了します。
[対策]HiRDBのバージョンが登録しようとしたプラグインの稼働条件を満たしていることを確認してください。
KFPY02122-E
PIC file header error　　（Ｅ）
PICファイルのヘッダが不正です。
(Ｓ)処理を終了します。
[対策]コマンド引数にPICファイル名が指定されていることを確認し，再度コマンドを実行してください。PICファイル名を指定しているのにこのメッセージが出力されている場合には，保守員に連絡してください。
KFPY02140-E
PLUGIN ID(aa....aa) already used　　（Ｅ）
aa....aaはプラグインIDとして既に使用されています。
aa....aa：プラグインID
(Ｓ)処理を終了します。
[対策]保守員に連絡してください。
KFPY02200-E
Error occurred on server, inf=aaa　　（Ｅ）
プラグインを登録するためにサーバへアクセスするときにサーバ内でエラーが発生しました。
aaa：保守情報
(Ｓ)処理を終了します。
[対策]
〈このメッセージの前に他メッセージが出力されている場合〉
このメッセージの前に出力されたメッセージに従って，エラーの原因を取り除き，再度コマンドを実行してください。
〈このメッセージの前に他メッセージがない場合〉
保守員に連絡してください。
KFPY02201-E
Error occurred while defining PLUGIN, inf=aa....aa　　（Ｅ）
プラグインの定義のためにSQLを実行したときにエラーが発生しました。
aa....aa：SQL実行エラー内容
(Ｓ)処理を終了します。
[対策]メッセージテキスト出力内容を基にエラーの原因を取り除いた後，再度コマンドを実行してください。
KFPY02202-E
Error occurred while processing PIC file, inf=aaaa　　（Ｅ）
PICファイルを処理中にエラーが発生しました。
aaaa：保守情報
(Ｓ)処理を終了します。
[対策]保守員に連絡してください。
KFPY02210-E
Connect error occurred　　（Ｅ）
サーバへの接続のときにエラーが発生しました。
(Ｓ)処理を終了します。
[対策]
〈このメッセージの前にSQL文に関するメッセージが出力されている場合〉
メッセージが示すエラーの原因を取り除いた後，再度コマンドを実行してください。
〈このメッセージの前にSQL文に関するメッセージが出力されていない場合〉
HiRDBシステムに対して，DBA権限があるかどうかを確認した後，再度コマンドを実行してください。
KFPY02213-E
User aa....aa has no DBA privilege　　（Ｅ）
pdplgrgstコマンドを実行するために必要なDBA権限がありません。
aa....aa：ユーザ名
(Ｓ)処理を終了します。
[対策]pdplgrgstコマンドの実行には，DBA権限が必要です。環境変数PDUSERにDBA権限を持つユーザを指定して，再度コマンドを実行してください。
KFPY02220-E
Failed in definition　　（Ｅ）
プラグイン定義に失敗しました。
(Ｓ)処理を終了します。
[対策]このメッセージの前に出力されたメッセージを参照し，エラーの原因を取り除いた後，再度コマンドを実行してください。
（例）プラグイン定義ファイル名を確認してください。
KFPY02230-E
Invalid setting of environment variable PDUSER　　（Ｅ）
環境変数PDUSERの設定が不正です。
(Ｓ)処理を終了します。
[対策]環境変数PDUSERの設定を確認し，再度コマンドを実行してください。このコマンドを実行するには，環境変数PDUSERの設定が必要です。
KFPY02300-E
Error occurred, inf1=aa....aa, inf2=bbbb　　（Ｅ）
コマンドの実行中にエラーが発生しました。
aa....aa：保守用情報１
bbbb：保守用情報２
(Ｓ)処理を終了します。
[対策]保守員に連絡してください。
KFPY03001-E
PLUGIN module requested abortion. PLUGIN ID=aa....aa, Abort code=bb....bb, Information=cc....cc　　（Ｌ）
プラグインが異常終了を要求しました。
aa....aa：プラグインID
bb....bb：アボートコード
cc....cc：アボート情報
(Ｓ)異常終了します。
[対策]$PDDIR/spool，$PDDIR/tmp，$PDDIR/plugin下にあるファイル，及びsyslogfile（Windows NTの場合はイベントログ）を退避してください。
また，メッセージに出力されたプラグインIDに対応するプラグインのマニュアルを参照し，アボートコードに対する対策をしてください。なお，退避した情報は，対策に必要な場合に参照してください。
KFPY99999-I
(dddddddd)xxxxx-y :zz....zz　　（Ｌ）
プラグイン名ddddddddのメッセージを出力します。
dddddddd：プラグイン名
xxxxx：メッセージID
y：エラーメッセージの重要度
zz....zz：メッセージテキスト
(Ｓ)プラグインddddddddが出力したメッセージxxxxx-yの処置に依存します。
[対策]プラグイン名ddddddddのメッセージxxxxx-yの処置に従って対策してください。


KFPZメッセージ

KFPZ02401-E
Environment definition error, valiable=aa....aa, reason=bb....bb　　（Ｒ）
環境変数の指定に誤りがあります。
aa....aa：誤りのあった環境変数名
bb....bb：エラーの原因
NET ENVIRONMENT：指定内容がネットワーク環境と一致しません
(Ｓ)処理を終了します。
(Ｐ)メッセージ中に表示された環境変数の指定内容を確認し，誤りを修正して再度実行してください。reason=NET ENVIRONMENTの場合は，PDHOSTで指定したホスト名がhostsファイルにあることを確認してください。
KFPZ02402-E
Memory shortage, size=aa....aa, inf=bb....bb　　（Ｒ）
sizeに示すバイト数aa....aaのメモリが確保できません。
aa....aa：確保しようとしたバイト数
bb....bb：保守情報
(Ｓ)処理を終了します。
(Ｐ)システム管理者へ連絡してください。
[対策]メモリ所要量を見積もり直してください。
KFPZ02404-E
Parameter error, func=aa....aa, item=bb....bb　　（Ｒ）
内部矛盾が発生しました。
aa....aa：エラーの発生した関数名
bb....bb：誤りのあった関数名
(Ｓ)処理を終了します。
(Ｐ)システム管理者へ連絡してください。
[対策]保守員へ連絡してください。
KFPZ02405-E
System call error, func=aa....aa, errno=bb....bb　　（Ｒ）
funcに示すシステムコールがエラーリターンしました。
aa....aa：エラーリターンしたシステムコール名
bb....bb：エラーインジケータ
(Ｓ)処理を終了します。
(Ｐ)エラーインジケータの値を調査し，errno.h（Windows NTの場合はWinsockのエラーコードを含む）及びユーザが使用するOSのマニュアルを参照してエラーの原因を取り除き，再度実行してください。
KFPZ02406-E
Error occurred in HiRDB/client, reason=aa....aa, inf=bb....bb　　（Ｒ）
HiRDB/clientの内部処理でエラーが発生しました。
aa....aa：エラーの発生した原因として次のどれかを表示します
MEMORY：メモリが不足しました。
NETWORK：ネットワーク障害が発生しました。
RESIDENT MEM：常駐メモリがありません。
RESOURCE：資源が不足しています。
TIME OUT：タイムアウトが発生しました。
TSR MODULE：常駐モジュールが起動されていません。
UNEXPECT：そのほかのエラーが発生しました。
bb....bb：保守情報
(Ｓ)エラーの理由が「常駐メモリなし」の時は，エラーを無視して処理を続行します。エラーの理由が「常駐メモリなし」以外の時は，実行中の処理を中止します。
(Ｐ)このメッセージが出力されたエラーログを記録して，HiRDB管理者に連絡してください。
[対策]出力されたエラーログから原因を追求して，エラーの原因を取り除いてください。
KFPZ02410-E
HiRDB replied error, code=aa....aa, IPaddr=bb....bb, port=cc....cc, inf=dd....dd　　（Ｒ）
HiRDBからエラーの応答を受信しました。
aa....aa：HiRDBが返したエラーコード
bb....bb：送信元IPアドレス（クライアントUAPとHiRDBサーバが同一サーバマシンで動作する場合は，0が挿入されます）
cc....cc：送信元ポート番号
dd....dd：エラーを検出したファイル名称
(Ｓ)処理を続行します。
(Ｐ)このメッセージに続いてエラーログ先頭識別子が「>>」のメッセージが出力されていない場合は，リトライ処理で処理が成功しています。エラーログ先頭識別子が「>>」のメッセージが出力されている場合は，そのメッセージの対処方法を参照してください。このとき，HiRDBが返したエラーコードが「RPC関連エラーの詳細コード」，又は「システム関連エラーの詳細コード」にある場合は，併せてそのコードの要因及び対処方法も参照してください。
KFPZ02411-E
Invalid message received, IPaddr=aaaaaaaa, port=bb....bb,inf=cc....cc　　（Ｒ）
解析できないメッセージを受信しました。
aaaaaaaa：送信元IPアドレス（クライアントUAPとHiRDBサーバが同一サーバマシンで動作する場合は，0が挿入されます）
bb....bb：送信元ポート番号
cc....cc：エラーの発生したファイルの名称
(Ｓ)処理を続行します。受信したメッセージを無視して次のメッセージを待ちます。
(Ｐ)HiRDB管理者へ連絡してください。
[対策]送信元のIPアドレス及びポート番号から送信元プロセスを求め，ネットワーク環境を見直してください。
KFPZ02420-E
Protocol error, IPaddr=aaaaaaaa, port =bb....bb, reason=cc....cc　　（Ｒ）
HiRDBプロセス間通信プロトコルのヘッダに不正な情報を検出しました。
aaaaaaaa：送信元IPアドレス（クライアントUAPとHiRDBサーバが同一サーバマシンで動作する場合は，0が挿入されます）
bb....bb：送信元ポート番号
cc....cc：理由として，次のどれかが出力されます
INF2 ERROR：付加情報2の内容が不正です。
SIZE OVER：HiRDB IPCヘッダ部として，12バイトを超えるメッセージを受信しました。
SIZE SHORT：HiRDB IPCヘッダ部として，12バイト未満のメッセージを受信しました。
SIZE ZERO：HiRDB IPCヘッダ部として，0バイトのメッセージを受信しました。
(Ｓ)処理を終了します。
(Ｐ)HiRDB管理者へ連絡してください。
[対策]
〈SIZE ZEROの場合〉
サーバ（HiRDB/シングルサーバ（SDS），又はHiRDB/パラレルサーバ（FES））の停止の原因を調べて，原因を取り除いた後，再度UAPを実行してください。
〈そのほかの場合〉
保守員に連絡してください。
KFPZ02421-E
Invalid size, received size=aa....aa, size in head=bb....bb, IPaddr=cccccccc,port=dd....dd　　（Ｒ）
受信完了通知のデータ長が，HiRDBのプロセス間で使用する通信プロトコルのヘッダのデータ長に満たないため，処理を中止します。
aa....aa：受信データ長
bb....bb：ヘッダ中のデータ長
cccccccc：送信元IPアドレス（クライアントUAPとHiRDBサーバが同一サーバマシンで動作する場合は，0が挿入されます）
dd....dd：送信元ポート番号
(Ｓ)処理を終了します。
(Ｐ)サーバが異常終了していないか確認してください。
KFPZ02444-E
Communication error, func=aa....aa, [(bb....bb)], errno=cc....cc　　（Ｒ）
通信障害が発生しました。
aa....aa：障害が発生したソケットインタフェースの関数名（21文字以内）
bb....bb：次のどちらかの文字列が表示されます。
IPアドレス:ポート番号：
INET通信で関数名がconnectの場合に表示されます。
ポート番号：
INET通信以外で関数名がconnectの場合に表示されます。
cc....cc：エラーインディケータ
(Ｓ)処理を終了します。
(Ｐ)エラーインディケータの値を調査し，errno.h（Windows NTの場合はWinsockのエラーコードを含む）及びユーザが使用するOSのマニュアルを参照して，エラーの原因を取り除き，再度実行してください。
func=write，read，errnoの示す値がEPIPE又は(WSA)※ECONNRESETの場合，HiRDBサーバが異常終了している可能性があります。
func=connect，errnoの示す値がENOENT又は(WSA)※ECONNREFUSEDの場合，クライアント環境定義のPDHOST又はPDNAMEPORTオペランドの指定が誤っている可能性があります。
クライアント環境定義のPDHOST及びPDNAMEPORTオペランドの値が正しくて，func=connect，errnoの示す値が(WSA)※ETIMEDOUT又は(WSA)※ECONNREFUSEDの場合，HiRDBサーバに対する接続要求が多過ぎる可能性があります。この場合，時間をおいて再度実行するか，又はListenキューの指定値を大きくしてください。Listenキューについては，マニュアル「HiRDB Version 6 システム導入・設計ガイド」を参照してください。
注※　(WSA)はWinsockのエラーコード名です。
KFPZ02445-I
Client information, Type=aa....aa, Inf=bb....bb　　（Ｒ）
クライアント情報を出力します。
aa....aa：クライアント情報の種別（[対策]を参照してください）
bb....bb：クライアント情報（[対策]を参照してください）
(Ｓ)処理を続行します。
[対策]クライアント情報に対応する対策をしてください。
クライアント情報の種別（aa....aa）
クライアント情報（bb....bb）
内容
対策
Reconnect
MAX_USERS_OVER, time=cc....cc
接続ユーザ数オーバーでの再接続処理の実行開始です。cc....cc秒間再接続を試します。
再接続できなかった場合は，システム定義のpd_max_usersオペランドの指定値を見直してください。
MAINTENANCE, time=cc....cc
修正版HiRDBのプログラムの入れ替え，又はシステム構成変更コマンド（pdchgconfコマンド）での再接続処理の実行開始です。cc....cc秒間再接続を試します。
修正版HiRDBのプログラムの入れ替え，又はシステム構成変更コマンド（pdchgconfコマンド）が終了してから，再度実行してください。
AUTO_RECONNECT, number=cc....cc, interval=dd....dd
自動再接続機能での再接続処理の開始です。dd....dd秒間隔で，cc....cc回再接続を試します。
再接続できなかった場合は，通信障害の原因を取り除いて再度実行してください。
KFPZ02470-E
Invalid parameter, parameter number=aa....aa　　（Ｒ）
COMMAND EXECUTE文の引数が不正です。
aa....aa：引数の番号
#1：コマンドライン変数
#3：実行結果受け取り領域長変数
#4：実行結果長受け取り変数
#5：実行結果受け取り変数
#6：実行コマンドリターンコード受け取り変数
#7：環境変数グループ名変数
#8：実行ユニット変数
(Ｓ)処理を終了します。
(Ｐ)引数の設定内容を確認し，誤りがあれば修正して再度実行してください。
KFPZ02471-E
Communication error occurred, reason=aa....aa　　（Ｒ）
HiRDB Assist - Serverとの通信でエラーが発生しました。
aa....aa：エラー詳細
INIT ERROR,CODE=bbb：
HiRDB Assist - Server初期化エラー
NETWORK：
ネットワーク障害
Assist-Server NOT UP：
HiRDB Assist - Server未起動
Assist-Server BUSY：
通信でタイムアウト発生
bbb：HiRDB Assist - Serverのエラー詳細コード
(Ｓ)処理を終了します。
(Ｐ)HiRDB管理者に障害の内容を連絡し，障害要因を取り除いた後に再度実行してください。
[対策]実行結果受け取り領域及びコマンドトレースに出力されている詳細情報を基に障害要因を取り除いて，再度実行してください。エラー詳細がAssist-Server NOT UPの場合は，クライアント環境定義のPDASTHOST及びPDASTPORTの指定値を見直してください。
HiRDB Assist - Serverのエラー詳細コード及び対策を次に示します。
エラー詳細コード
原因
対策
-7001
HiRDB Assist - Serverの内部引数不正です。
保守員に連絡してください。
-7002
HiRDB Assist - Server内部で実行したシステムコールがエラーとなりました。又は，クライアントから要求されたデータ内容が不正です。
再度実行してください。このエラーが再発する場合は，HiRDB Assist - Serverディレクトリ下のすべての情報を取得してから，保守員に連絡してください。
-7003
プロセス固有メモリ不足です。
システム全体のメモリに，十分な空きがあるときに再度実行してください。
-7007
HiRDBのシステム定義の内容に誤りがあります。
HiRDBのシステム定義を修正してから，再度実行してください。
-7008
HiRDBのシステム定義がありません。
HiRDB Assist - Serverを正しくセットアップしてください。
-7009
HiRDB Assist - Server接続時の初期化処理に失敗しました。
クライアントに返されるiniterr情報を確認して，そのエラーコードの対策をしてください。
-7014
指定したユーザ名／パスワードが誤っています。
ユーザ名／パスワードを正しく指定してから，再度実行してください。
-7015
HiRDBのPDDIR環境変数に誤りがあります。
PDDIR環境変数を正しく設定してから，再度実行してください。
-7016
HiRDBのシステムマネジャのユニット以外に接続しようとしています。
システムマネジャのユニット上のHiRDB Assist - Serverに接続してください。
-7017
指定したユーザが，HiRDBの管理者IDと異なるグループです。
HiRDB管理者IDと同じグループ内のユーザを使用して接続してください。
-7019
一時格納ファイル名称取得に失敗しました。
再度実行してください。このエラーが再発する場合は，HiRDB Assist - Serverディレクトリ下のすべての情報を取得してから，保守員に連絡してください。
-7023
一時格納ファイルのオープンに失敗しました。
-7039
HiRDB Assist - Serverの定義に誤りがあります。
HiRDB Assist - Serverの定義を修正してから，再度実行してください。
-7041
HiRDBのライブラリ又はDLLが，ダイナミックにリンクできません。
HiRDB Assist - Serverを正しくセットアップし直してから，再度実行してください。
上記以外
HiRDB Assist - ServerのREADME.TXTを参照してください。
KFPZ02472-E
Error occurred in Assist - Server, code=aaaaa　　（Ｒ）
HiRDB Assist - Serverでエラーが発生しました。
aaaaa：HiRDB Assist - Serverのエラー詳細コード
(Ｓ)処理を終了します。
(Ｐ)HiRDB管理者に障害の内容を連絡して，障害を取り除いた後に再度実行してください。
[対策]HiRDB Assist - Serverのエラー詳細コードから障害の内容を取り除き，再度実行してください。HiRDB Assist - Serverのエラー詳細コード及び対策を次に示します。
エラー詳細コード
原因
対策
-7001
HiRDB Assist - Serverの内部引数不正です。
保守員に連絡してください。
-7002
HiRDB Assist - Server内部で実行したシステムコールがエラーとなりました。又は，クライアントから要求されたデータ内容が不正です。
再度実行してください。このエラーが再発する場合は，HiRDB Assist - Serverディレクトリ下のすべての情報を取得してから，保守員に連絡してください。
-7003
プロセス固有メモリ不足です。
システム全体のメモリに，十分な空きがあるときに再度実行してください。
-7019
一時格納ファイル名称取得に失敗しました。
再度実行してください。このエラーが再発する場合は，HiRDB Assist - Serverディレクトリ下のすべての情報を取得してから，保守員に連絡してください。
-7023
一時格納ファイルのオープンに失敗しました。
上記以外
HiRDB Assist - ServerのREADME.TXTを参照してください。
KFPZ02473-E
Reset environment definition error, envname=aa....aa, variable=bb....bb, reason=cc....cc　　（Ｒ）
p_rdb_mth_ChgEnv関数で，動的に変更されるクライアント環境定義の指定に誤りがあります。
aa....aa：クライアント環境定義の環境変数名
bb....bb：aa....aaの指定値（30バイトを超える場合は最初の30バイトを表示）
cc....cc：理由として次のどれかの文字列が出力されます。
OUT OF RANGE：値が範囲外です。
INVALID CHAR：指定できない文字があります。
INVALID IDENTIFIER：識別子が不正です。
(Ｓ)処理を終了します。
(Ｐ)誤りを修正してから，再度実行してください。
KFPZ03000-I
Error information, type=aa....aa, inf=bb....bb　　（Ｒ）
HiRDB/CLT処理中にエラーを検出しました。このメッセージは，エラー発生時に，原因調査用の詳細情報をCLTのエラーログに出力するものです。
aa....aa：エラー情報の種別
bb....bb：エラー情報
(Ｓ)処理を続行します。
(Ｐ)前後に出力されているメッセージの対処に従ってください。
(Ｏ)前後に出力されているメッセージの対処に従ってください。
[対策]このメッセージは，エラー発生時の保守情報です。保守員に連絡する場合には，ほかのメッセージとともに，このメッセージの内容も保守資料として伝えてください。
KFPZ04001-E
SQLVAR information, type:aa....aa,reason:bb....bb　　（Ｒ）
クライアントライブラリが検出したKFPA11311-Eメッセージに対する詳細情報です。サーバが検出した場合は出力されません。
aa....aa：エラーの原因となった事象の種別。次のどれかの値です。
real length：可変長データの実長不正
data length：データ長不正
decimal：10進データの精度・位取り不正
data type：データ型不正
bb....bb：aa....aaに対する変数情報。次の情報から構成されます。
number：1から始まるパラメタの序数
sqlcod：sqlcodの値
sqllen：sqllenの値
real length：パラメタの実長
sqlprcsn：sqlprcsnの値
sqlscale：sqlscaleの値
(Ｓ)処理を続行します。
(Ｐ)KFPA11311-Eメッセージとこのメッセージからパラメタを修正後，UAPを実行してください。
KFPZ04002-E
SQLDA information, type:aa....aa, reason:bb....bb　　（Ｒ）
クライアントライブラリが検出したKFPA11310-Eメッセージに対する詳細情報です。サーバが検出した場合は出力されません。
aa....aa：エラーの原因となった事象の種別。
sqln：sqlvarの個数不正
sqld：?パラメタ数，又は検索項目数不正
bb....bb：aa....aaに対する変数情報。次の情報から構成されます。
sqln：sqlnの値
sqld：sqldの値
(Ｓ)処理を続行します。
(Ｐ)KFPA11310-EメッセージとこのメッセージからSQLDAの領域の値を修正後，UAPを再度実行してください。
KFPZ13000-E
Required uap program file name missing　　（Ｓ）
プリプロセスするファイル名が指定されていません。
(Ｓ)処理を終了します。
(Ｐ)ファイル名を指定して，再度プリプロセスを実行してください。
KFPZ13001-E
Too many uap program file　　（Ｓ）
プリプロセスするファイルが多過ぎます。
(Ｓ)処理を終了します。
(Ｐ)ファイル数を減らして，再度プリプロセスを実行してください。
KFPZ13002-E
Too long path name　　（Ｓ）
登録原文を検索するために指定したパス名が長過ぎます。
(Ｓ)処理を終了します。
(Ｐ)環境変数PDCBLLIBに指定するパス名を短くして，再度プリプロセスを実行してください。
KFPZ13010-E
Invalid message file　　（Ｓ）
メッセージファイルの内容に不正な情報があります。
(Ｓ)処理を終了します。
(Ｐ)プリプロセサと同じバージョンのメッセージファイルを再度インストールしてください。
KFPZ13020-E
Unable to edit message, id=aa....aa　　（Ｓ）
エラーメッセージの編集時にエラーが発生したため，aa....aaに示すメッセージが編集できません。
aa....aa：編集できなかったエラーメッセージのID
(Ｓ)処理を終了します。
(Ｐ)このメッセージの前に出力されたエラーメッセージに従って，エラーの原因を取り除いてください。
KFPZ13050-E
Insufficient process local memory, size=aa....aa　　（Ｓ）
作業領域を確保しようとしましたが，サイズaa....aaを確保できません。
aa....aa：確保できなかった領域の領域長（単位：バイト）
(Ｓ)処理を終了します。
(Ｐ)メモリを増設してください。又は，ほかのプログラムを終了して，再度プリプロセスを実行してください。
KFPZ13051-E
Memory free error occurred　　（Ｓ）
作業領域を解放できません。
(Ｓ)処理を終了します。
(Ｐ)保守員に連絡してください。
KFPZ13060-E
Too many errors, preprocessing terminated　　（Ｓ）
SQL文のエラーが多く検出されたため，プリプロセス処理を中止します。
(Ｓ)処理を終了します。
(Ｐ)既に出力されたメッセージを参照してエラーの原因を取り除き，再度プリプロセスを実行してください。
KFPZ13100-E
Invalid string "aa....aa" in SQL　　（Ｓ）
SQL文中の文字列aa....aaに誤りがあります。
aa....aa：誤りのある文字列
(Ｓ)このSQL文を無視します。以降，この原始プログラムのプリプロセスを中止し，文法チェックだけを実行します。
(Ｐ)次に示す誤りが考えられます。このため，誤りを修正して再度プリプロセスを実行してください。
・予約語のつづりに誤りがあります。
・SQL文の後に余分な文字列があります。
KFPZ13102-E
Invalid string "aa....aa" in data description　　（Ｓ）
変数の定義部内の文字列aa....aaに誤りがあります。
aa....aa：誤りのある文字列
(Ｓ)この誤りを無視し，プリプロセスを続行します。
(Ｐ)変数の定義部の誤りを修正し，再度プリプロセスを実行してください。
KFPZ13104-E
Invalid data attribute of variable "aa....aa"　　（Ｓ）
このデータ属性は変数として使用できないため，指定できません。
(Ｓ)この変数を無視し，プリプロセスを続行します。
(Ｐ)このデータ属性を修正し，再度プリプロセスを実行してください。
KFPZ13105-E
Invalid data length of variable "aa....aa"　　（Ｓ）
埋込み変数aa....aaのデータ長に次の誤りがあります。
・BINARY型のデータ長が4の倍数ではありません。
(Ｓ)ポストソースの生成を中止し，文法チェックだけを実行します。
(Ｐ)埋込み変数のデータ長の誤りを修正して，再度プリプロセスを実行してください。
KFPZ13106-E
Invalid use of structure or pointer variable "aa....aa"　　（Ｓ）
構造体又はポインタの使用方法が不正です。
ポインタは，接続ハンドルを操作するSQLの埋込み言語では使用できません。
構造体は，次の指定箇所にだけ埋込み変数として使用できます。
・FETCH文又は1行SELECT文のINTO句
・INSERT文のVALUES句
・EXECUTE文のUSING句及びINTO句
aa....aa：誤りのある埋込み変数名，又は標識変数名
(Ｓ)ポストソースの生成を中止し，文法チェックだけを実行します。
(Ｐ)埋込み変数又は標識変数を見直して，再度プリプロセスを実行してください。
KFPZ13107-E
Number of members in indicator structure unmatch with embedded structure "aa....aa"　　（Ｓ）
埋込み変数の構造体と，標識変数の構造体のメンバ数が一致しません。
aa....aa：誤りのある標識変数名
(Ｓ)ポストソースの生成を中止し，文法チェックだけを実行します。
(Ｐ)埋込み変数の構造体のメンバ数と，標識変数の構造体のメンバ数を一致させて，再度プリプロセスを実行してください。
KFPZ13108-E
Invalid identifier "aa....aa" in SQL　　（Ｓ）
SQL文中に誤った名前aa....aaがあります。
aa....aa：誤った名前
{カーソル名 | SQL文識別子 | 標識変数 | 埋込み変数 | ホスト識別子 | SQL記述領域名 | 認可識別子 | 表識別子 | 列名 | 列名記述領域}
(Ｓ)このSQL文を無視します。以降，この原始プログラムのプリプロセスを中止し，文法チェックだけを実行します。
(Ｐ)SQL文を修正し，再度プリプロセスを実行してください。
KFPZ13110-E
Invalid string "aa....aa" in bb....bb program　　（Ｓ）
bb....bbのプログラムでは，文字列aa....aaは使用できません。
aa....aa：使用できない文字列
bb....bb：言語種別{ C | COBOL | C++ | OOCOBOL }
(Ｓ)このSQL文を無視します。以降，この原始プログラムのプリプロセスを中止し，文法チェックだけを実行します。
(Ｐ)SQL文を修正し，再度プリプロセスを実行してください。
KFPZ13112-E
Invalid "aa....aa" following "bb....bb"　　（Ｓ）
SQL文中の文字列aa....aaは，文字列bb....bbの後に指定できません。
aa....aa：SQLの文法上指定できない位置に指定した文字列
bb....bb：SQLの文字列
(Ｓ)このSQL文を無視します。以降，この原始プログラムのプリプロセスを中止し，文法チェックだけを実行します。
(Ｐ)次の誤りが考えられます。このため，誤りを修正して再度プリプロセスを実行してください。
・予約語のつづりに誤りがあります。
・SQL文の構文上で指定できない位置にaa....aaを指定しています。
KFPZ13114-E
Incomplete SQL　　（Ｓ）
SQL文が完成していません。
(Ｓ)このSQL文を無視します。以降，この原始プログラムのプリプロセスを中止し，文法チェックだけを実行します。
(Ｐ)SQL文を修正し，再度プリプロセスを実行してください。
KFPZ13116-E
Semicolon missing　　（Ｓ）
セミコロン（；）の前で，SQL文の終了を検出しました。
(Ｓ)このSQL文を無視します。以降，この原始プログラムのプリプロセスを中止し，文法チェックだけを実行します。
(Ｐ)正しい位置にセミコロンを付け，再度プリプロセスを実行してください。
KFPZ13118-E
Closing quotation mark missing　　（Ｓ）
文字定数を閉じる引用符（"），又はアポストロフィ（'）がありません。
(Ｓ)このSQL文を無視します。以降，この原始プログラムのプリプロセスを中止し，文法チェックだけを実行します。
(Ｐ)文字定数を引用符又はアポストロフィで閉じて，再度プリプロセスを実行してください。
KFPZ13122-E
Invalid use of "aa....aa" parameter　　（Ｓ）
不正な埋込み変数名aa....aaが使用されました。
aa....aa：不正に使用された埋込み変数
(Ｓ)このSQL文を無視します。以降，この原始プログラムのプリプロセスを中止し，文法チェックだけを実行します。
(Ｐ)誤りがないように埋込み変数を修正し，再度プリプロセスを実行してください。
KFPZ13131-E
Data description entry with TYPEDEF clause not level 1　　（Ｓ）
TYPEDEF句を指定したデータ記述項のレベル番号が1ではありません。
(Ｓ)処理を続行します。
(Ｐ)TYPEDEF句を指定したデータ記述項のレベル番号を1にしてください。
KFPZ13132-E
Unable to specify subordinate element or level 88 entry after data description entry with TYPE clause　　（Ｓ）
TYPE句の指定があるデータ記述項の後に，従属するデータ記述項又はレベル88記述項が続いています。
(Ｓ)処理を続行します。
(Ｐ)TYPE句の指定があるデータ記述項の後の，従属するデータ記述項又はレベル88記述項を削除してください。
KFPZ13133-E
Unable to specify "aa....aa" in bb....bb clause, due to data description entry subordinated to group item　　（Ｓ）
bb....bb句の"aa....aa"にこの記述項が従属している集団項目を指定しています。
aa....aa：型名，又はSAME AS句中のデータ名
bb....bb：TYPE，又はSAME AS
(Ｓ)処理を続行します。
(Ｐ)型名，又はSAME AS句中のデータ名は，この記述項が従属している集団項目を指定しないようデータ記述項の宣言を見直してください。
KFPZ13134-E
Level 77 item "aa....aa" not elementary　　（Ｓ）
レベル番号77に指定した型名，又はデータ名aa....aaが基本項目ではありません。
aa....aa：型名，又はSAME AS句中のデータ名
(Ｓ)処理を続行します。
(Ｐ)記述項の左辺がレベル77項目の場合，型名，又はSAME AS句中のデータ名は基本項目にしてください。
KFPZ13135-E
Invalid type-name "aa....aa"　　（Ｓ）
型名aa....aaが宣言されていないか，又は重複して宣言されています。
aa....aa：型名
(Ｓ)処理を続行します。
(Ｐ)TYPE句より前に，一度だけ型名を宣言してください。
KFPZ13136-E
Unable to specify subordinate element or level 88 entry after data description entry with SAME AS clause　　（Ｓ）
SAME AS句の指定のあるデータ記述項の後に，従属するデータ記述項又はレベル88記述項が続いています。
(Ｓ)処理を続行します。
(Ｐ)SAME AS句を指定したデータ記述項の後の，従属するデータ記述項又はレベル88記述項を削除してください。
KFPZ13138-E
Data-name "aa....aa" in SAME AS clause contain OCCURS clause　　（Ｓ）
SAME AS句中で指定したデータ名aa....aaの記述にOCCURS句があります。
aa....aa：データ名
(Ｓ)処理を続行します。
(Ｐ)SAME AS句中で指定したデータ名の記述に，OCCURS句を指定しないようデータ記述項の宣言を見直してください。
KFPZ13139-E
Data-name "aa....aa" in SAME AS clause neither elementary nor level 1 group item　　（Ｓ）
SAME AS句中のデータ名aa....aaが，基本項目又はレベル1集団項目ではありません。
aa....aa：データ名
(Ｓ)処理を続行します。
(Ｐ)SAME AS句中のデータ名は，基本項目又はレベル1集団項目にしてください。
KFPZ13141-E
Invalid data-name "aa....aa" in SAME AS clause　　（Ｓ）
SAME AS句中のデータ名aa....aaが宣言されていないか，又は一意ではありません。
aa....aa：データ名
(Ｓ)処理を続行します。
(Ｐ)SAME AS句中のデータ名が参照するデータ項目を，この指定の前に記述してください。又は，一意になるようにSAME AS句中のデータ名を修飾してください。
KFPZ13142-E
Length of identifier "aa....aa" exceeds bb character　　（Ｓ）
名前の文字数が，指定できる文字数の最大値を超えています。
aa....aa：誤った名前
{カーソル名 | SQL文識別子 | 標識変数 | 埋込み変数 | ホスト識別子 | SQL記述領域名 | 認可識別子 | 表識別子 | 列名 | 列名記述領域名}
bb：指定できる文字数の最大値
(Ｓ)このSQL文を無視します。以降，この原始プログラムのプリプロセスを中止し，文法チェックだけを実行します。
(Ｐ)名前の文字数を最大値以下に修正し，再度プリプロセスを実行してください。
KFPZ13144-E
Length of character string exceeds aa....aa　　（Ｓ）
最大値aa....aaを超えた長さの文字列定数がSQL文中にあります。
aa....aa：指定できる長さの最大長
(Ｓ)このSQL文を無視します。以降，この原始プログラムのプリプロセスを中止し，文法チェックだけを実行します。
(Ｐ)文字列定数の長さを最大値以下に修正し，再度プリプロセスを実行してください。
KFPZ13146-E
Length of SQL exceeds 2M bytes　　（Ｓ）
SQL文の1文の長さが2Mバイトを超えています。
(Ｓ)このSQL文を無視します。以降，この原始プログラムのポストソースの生成を中止し，文法チェックだけを実行します。
(Ｐ)SQL文の1文の長さを2Mバイト以下に修正し，再度プリプロセスを実行してください。
KFPZ13150-E
Number of cursor exceeds 1023 in a program　　（Ｓ）
一つのプログラム中のカーソルの数が1023を超えています。
(Ｓ)このSQL文を無視します。以降，この原始プログラムのポストソースの生成を中止し，文法チェックだけを実行します。
(Ｐ)カーソルの数を1023以下に修正し，再度プリプロセスを実行してください。
KFPZ13152-E
Number of aa....aa exceeds bb....bb in SQL　　（Ｓ）
SQL文の1文中の埋込み変数と標識変数の総数，表識別子又は列名の数が，指定できる最大数を超えています。
aa....aa：変数，表識別子又は列名の種別
bb....bb：指定できる最大数
(Ｓ)このSQL文を無視します。以降，この原始プログラムのポストソースの生成を中止し，文法チェックだけを実行します。
(Ｐ)aa....aaの数を最大数以下に修正し，再度プリプロセスを実行してください。
KFPZ13156-E
Cursor "aa....aa" already used in "bb....bb" statement　　（Ｓ）
カーソルaa....aaは，既に別のOPEN文，FETCH文，又はCLOSE文で使用されています。
aa....aa：カーソル名
bb....bb：重複したSQL文
CLOSE：CLOSE文
FETCH：FETCH文
OPEN：OPEN文
(Ｓ)このSQL文を無視します。以降，この原始プログラムのポストソースの生成を中止し，文法チェックだけを実行します。
(Ｐ)カーソル名を変えて，再度プリプロセスを実行してください。
KFPZ13160-E
Variable "aa....aa" already defined　　（Ｓ）
指定した埋込み変数，又は標識変数は，既に定義されています。
aa....aa：埋込み変数，又は標識変数
(Ｓ)このエラーを無視してポストソースの生成を続行します。
(Ｐ)別の埋込み変数，又は標識変数名を指定し，再度プリプロセスを実行してください。
KFPZ13162-E
Cursor "aa....aa" already defined　　（Ｓ）
指定したカーソルは既に定義されています。
aa....aa：カーソル名
(Ｓ)このエラーを無視します。以降，この原始プログラムのポストソースの生成を中止し，文法チェックだけを実行します。
(Ｐ)別のカーソル名を指定し，再度プリプロセスを実行してください。
KFPZ13166-E
SQL statement identifier "aa....aa" already defined　　（Ｓ）
指定したSQL文識別子aa....aaは既に定義されています。
aa....aa：SQL文識別子
(Ｓ)このSQL文を無視します。以降，この原始プログラムのポストソースの生成を中止し，文法チェックだけを実行します。
(Ｐ)別のSQL文識別子を指定し，再度プリプロセスを実行してください。
KFPZ13168-E
SQL statement identifier "aa....aa" already used for another cursor　　（Ｓ）
指定したSQL文識別子aa....aaは，既に別のカーソルで定義されています。同一のSQL文識別子は，複数のカーソルでは指定できません。
aa....aa：SQL文識別子
(Ｓ)このSQL文を無視します。以降，この原始プログラムのポストソースの生成を中止し，文法チェックだけを実行します。
(Ｐ)別のSQL文識別子を指定し，再度プリプロセスを実行してください。
KFPZ13170-E
Colon missing before variable "aa....aa" in user program　　（Ｓ）
UAPの埋込み変数，又は標識変数aa....aaに，コロン（：）が付いていません。
aa....aa：埋込み変数，又は標識変数
(Ｓ)このエラーを無視して処理を続行します。以降，この原始プログラムのポストソースの生成を中止し，文法チェックだけを実行します。
(Ｐ)埋込み変数又は標識変数にコロンを付け，再度プリプロセスを実行してください。
KFPZ13174-E
Read only cursor specified UPDATE or DELETE statement　　（Ｓ）
読み込み専用のカーソルがUPDATE文，又はDELETE文で指定されました。
(Ｓ)このSQL文を無視します。この原始プログラムのポストソースの生成を中止し，文法チェックだけを実行します。
(Ｐ)UPDATE文，又はDELETE文で指定するカーソルを読み込み専用でないものに変えて再度プリプロセスを実行してください。
KFPZ13200-E
PREPARE statement missing for SQL statement identifier "aa....aa"　　（Ｓ）
SQL文識別子aa....aaで示すSQL文に対応するPREPARE文が定義されていません。
aa....aa：SQL文識別子
(Ｓ)このSQL文を無視します。この原始プログラムのポストソースの生成を中止し，文法チェックだけを実行します。
(Ｐ)SQL文識別子で示すSQL文に対応するPREPARE文を定義してください。
KFPZ13201-E
DECLARE CURSOR statement missing for cursor name "aa....aa"　　（Ｓ）
指定したカーソル名aa....aaは，カーソル宣言がされていません。
aa....aa：カーソル名
(Ｓ)このSQL文を無視します。この原始プログラムのポストソースの生成を中止し，文法チェックだけを実行します。
(Ｐ)カーソル名aa....aaをカーソル宣言してください。
KFPZ13202-E
Variable "aa....aa" undefined　　（Ｓ）
指定した埋込み変数aa....aaは定義されていません。
aa....aa：埋込み変数
(Ｓ)このSQL文を無視します。この原始プログラムのポストソースの生成を中止し，文法チェックだけを実行します。
(Ｐ)埋込み変数aa....aaを定義してください。
KFPZ13203-E
Invalid attribute of variable "aa....aa"　　（Ｓ）
指定した埋込み変数aa....aaの定義属性に誤りがあります。
aa....aa：埋込み変数
(Ｓ)このSQL文を無視します。この原始プログラムのポストソースの生成を中止し，文法チェックだけを実行します。
(Ｐ)埋込み変数の定義属性を修正してください。
KFPZ13204-E
Indicator variable or parameter "aa....aa" not defined　　（Ｓ）
指定した標識変数aa....aaが定義されていません。
aa....aa：標識変数
(Ｓ)このSQL文を無視します。この原始プログラムのポストソースの生成を中止し，文法チェックだけを実行します。
(Ｐ)標識変数aa....aaを定義してください。
KFPZ13205-E
Invalid attribute of indicator variable "aa....aa"　　（Ｓ）
指定した標識変数aa....aaの定義属性に誤りがあります。
aa....aa：標識変数
(Ｓ)このSQL文を無視します。この原始プログラムのポストソースの生成を中止し，文法チェックだけを実行します。
(Ｐ)標識変数の定義属性を修正してください。
KFPZ13206-E
Unable to identify variable "aa....aa"　　（Ｓ）
埋込み変数又は標識変数の記述が誤っています。このため，変数を特定できません。
aa....aa：埋込み変数又は標識変数
(Ｓ)ポストソースの生成を中止して，文法チェックだけをします。
(Ｐ)埋込み変数又は標識変数を一意に特定できるようにソースプログラムを修正し，再度プリプロセスを実行してください。
KFPZ13207-E
Length of variable "aa....aa" exceeds bb....bb bytes　　（Ｓ）
CHAR，VARCHAR，NCHAR，NVARCHAR，MCHAR，MVARCHAR，BLOB，CLOB，又はBINARYの埋込み変数aa....aaの定義長がbb....bbバイトを超えました。
aa....aa：埋込み変数名
bb....bb：定義長
(Ｓ)処理を続行します。ポストソースの生成を中止し，文法チェックだけを実行します。
(Ｐ)埋込み変数の定義長をbb....bbバイト以下にしてください。
KFPZ13208-E
Number of variables in "INTO" clause must be equal to output columns　　（Ｓ）
検索しようとする列の個数と，列の内容を設定するINTO句の埋込み変数の個数が一致していません。
(Ｓ)このSQL文はポストソースにそのまま変換して，処理を続行します。
(Ｐ)個数を一致させてください。
KFPZ13210-E
Invalid DECLARE CURSOR statement　　（Ｓ）
操作系SQL文では，カーソルを使用するときのDECLARE CURSORの形式を，次に示す形式にしてください。
・DECLARE カーソル名 CURSOR [WITH HOLD] FOR SELECT文
形式２のカーソル宣言の場合，同じSQL文識別子を使用するカーソルの形式は，一致している必要があります。
(Ｓ)このSQL文を無視します。この原始プログラムのポストソースの生成を中止し，文法チェックだけを実行します。
(Ｐ)DECLARE　CURSORを修正してください。
KFPZ13212-E
Number of SQL exceeds 4095 in a program　　（Ｓ）
一つのプログラム中で使用しているSQL文の数が4095を超えています。
(Ｓ)処理を終了します。
(Ｐ)SQL文を4095以下に減らして，再度プリプロセスを実行してください。
KFPZ13214-E
Number of variables in "USING" clause must be equal to number of input variables in DECLARE CURSOR statement　　（Ｓ）
DECLARE CURSORで入力した埋込み変数の個数と，USING句の埋込み変数の個数が一致していません。
(Ｓ)このSQL文を無視します。この原始プログラムのポストソースの生成を中止し，文法チェックだけを実行します。
(Ｐ)個数を一致させてください。
KFPZ13222-E
Invalid structure of indicator variable "aa....aa" for its corresponding variable　　（Ｓ）
埋込み変数と標識変数との間に，次に示すどれかの不整合があります。
・埋込み変数が配列構造であるのに，標識変数が配列構造ではありません。
・埋込み変数が単純構造であるのに，標識変数が配列構造又は繰返し構造です。
・埋込み変数が繰返し構造であるのに，標識変数の属性が繰返し構造ではありません。
aa....aa：標識変数名
(Ｓ)このSQL文を無視します。この原始プログラムのプリプロセスを中止し，文法チェックだけを実行します。
(Ｐ)標識変数の構造を，埋込み変数の構造に合わせてください。
KFPZ13223-E
Number of elements of indicator variable "aa....aa" not equal to number of elements of array or multi-value variable　　（Ｓ）
配列型の埋込み変数に対応する標識変数の要素数が一致していません。又は，繰返し列の埋込み変数に対応する標識変数の要素数が一致しません。
aa....aa：標識変数名
(Ｓ)処理を続行します。
(Ｐ)標識変数と埋込み変数の配列の要素数を一致させてください。
KFPZ13224-E
Update columns not specified in "FOR UPDATE" clause of DECLARE CURSOR statement　　（Ｓ）
カーソル宣言のFOR UPDATE句で指定していない列名を，同一カーソル指定のUPDATE文中のSET句，ADD句，又はDELETE句のどれかで指定しています。
(Ｓ)このSQL文を無視します。この原始プログラムのポストソースの生成を中止し，文法チェックだけを実行します。
(Ｐ)UPDATAE文で指定し，カーソル宣言のFOR UPDATE句では指定していない列名を，FOR UPDATE句に指定してください。
KFPZ13225-I
Length of variable "aa....aa" exceeds 30000 bytes　　（Ｓ）
FIX表に対する行単位インタフェースで使用する埋込み変数aa....aaのデータ長が，30000バイトを超えました。
aa....aa：埋込み変数名
(Ｓ)処理を続行します。ポストソースの生成を中止し，文法チェックだけを実行します。
(Ｐ)埋込み変数のデータ長を30000バイト以下に修正し，再度プリプロセスを実行してください。
KFPZ13226-I
Invalid attribute "aa....aa" corresponding to row　　（Ｓ）
行に対応する埋込み変数aa....aaのデータ属性に誤りがあります。
aa....aa：埋込み変数名
(Ｓ)処理を続行します。ポストソースの生成を中止し，文法チェックだけを実行します。
(Ｐ)埋込み変数のデータ属性を正しく定義し直し，再度プリプロセスを実行してください。
KFPZ13227-E
Length of variable "aa....aa" exceeds 2M bytes　　（Ｓ）
埋込み変数の定義長が2Mバイトを超えました。
aa....aa：埋込み変数名
(Ｓ)このSQL文を無視します。この原始プログラムのポストソースの生成を中止し，文法チェックだけを実行します。
(Ｐ)埋込み変数の長さを2Mバイト以下に修正し，再度プリプロセスを実行してください。
KFPZ13228-E
Number of elements of array variable "aa....aa" exceeds 4096　　（Ｓ）
埋込み変数又は標識変数の配列の要素数が，4096を超えました。
aa....aa：埋込み変数名又は標識変数名
(Ｓ)このSQL文を無視します。この原始プログラムのプリプロセスを中止し，文法チェックだけを実行します。
(Ｐ)埋込み変数又は標識変数の配列の要素数を4096以下に修正してください。
KFPZ13229-E
Invalid usage of array variable "aa....aa"　　（Ｓ）
配列構造の埋込み変数と単純構造の埋込み変数を同時に使用しています。又は，配列構造の埋込み変数と繰返し構造の埋込み変数を同時に指定しています。
aa....aa：埋込み変数名
(Ｓ)このSQL文を無視します。この原始プログラムのプリプロセスを中止し，文法チェックだけを実行します。
(Ｐ)このSQL文で使用する埋込み変数を，配列構造か単純構造のどちらかにしてください。又は，このSQL文で使用する埋込み変数を，単純構造と繰返し構造にしてください。
KFPZ13233-E
Specified table different from that in DECLARE CURSOR statement　　（Ｓ）
このSQL文で指定した表は，DECLARE　CURSORで指定した表と異なります。
(Ｓ)このSQL文を無視します。この原始プログラムのポストソースの生成を中止し，文法チェックだけを実行します。
(Ｐ)SQL文を修正し，再度プリプロセスを実行してください。
KFPZ13234-E
Specified SQL statement before DECLARE CONNECTION HANDLE SET　　（Ｓ）
COBOL言語の場合に複数接続機能を使用するとき，DECLARE CONNECTION HANDLE SETの記述前（有効範囲外）に接続ハンドルの割り当て，及び取得以外のSQL文は記述できません。
(Ｓ)処理を終了します。
(Ｐ)SQL文を修正し，再度プリプロセスを実行してください。
KFPZ13236-W
"Block transfer facility" not applied for cursor "aa....aa", because of FETCH using array variable　　（Ｓ）
カーソルaa....aaが，配列を使用したFETCH文と，配列を使用しないFETCH文の両方で使用されています。そのため，実行時にブロック転送機能を使用しても，配列を使用しないFETCH文でブロック転送ができません。
aa....aa：カーソル名
(Ｓ)処理を続行します。
(Ｐ)ブロック転送機能を使用する場合は，UAPを修正して，再度プリプロセスを実行してください。
KFPZ13511-E
Error occurred in preprocessor,inf1=aa....aa,inf2=bbbb　　（Ｓ）
SQLプリプロセサで内部矛盾が発生しました。
aa....aa：エラーを検出したソースファイルの名称
bbbb：エラーを検出した位置（行番号）
(Ｓ)処理を終了します。
(Ｐ)HiRDB管理者に連絡してください。
[対策]保守員に連絡してください。
KFPZ13570-E
"aa....aa" option missing　　（Ｓ）
プリプロセスオプションのaa....aaを指定していません。
aa....aa：プリプロセスオプション
(Ｓ)処理を終了します。
(Ｐ)プリプロセスオプションを指定し，再度プリプロセスを実行してください。
KFPZ13572-E
Invalid option "aa....aa"　　（Ｓ）
プリプロセスオプションのオペランドaa....aaの指定値に誤りがあります。
aa....aa：誤りのあるオペランド
(Ｓ)処理を終了します。
(Ｐ)プリプロセスオプションのオペランド値を修正し，再度プリプロセスを実行してください。
KFPZ13574-E
Invalid keyword "aa....aa"　　（Ｓ）
プリプロセスオプションの，オペランドのキーワードaa....aaに誤りがあります。
aa....aa：誤りのあるキーワード
(Ｓ)処理を終了します。
(Ｐ)プリプロセスオプションのオペランドのキーワードを修正し，再度プリプロセスを実行してください。
KFPZ13575-E
Preprocess option "aa....aa" conflict with "bb....bb"　　（Ｓ）
プリプロセスオプションaa....aaは，bb....bbと同時には指定できません。
aa....aa：エラーとなったプリプロセスオプション
bb....bb：指定済みのプリプロセスオプション
(Ｓ)処理を終了します。
(Ｐ)プリプロセスオプションを修正し，再度プリプロセスを実行してください。
KFPZ13576-E
Error occurred during internal compiler processing "aa....aa"　　（Ｓ）
内部コンパイラ処理aa....aaでエラーが発生しました。
aa....aa：エラーとなった内部コンパイラ処理（150バイトを超える場合，先頭から150バイトを表示）
(Ｓ)処理を終了します。
(Ｐ)このメッセージより前に出力されたメッセージを参照し，プリプロセスオプションのエラー要因を取り除いて，再度プリプロセスを実行してください。
KFPZ13577-E
Duplicate option "aa....aa"　　（Ｓ）
プリプロセスオプションaa....aaを重複して指定しています。
aa....aa：エラーとなったプリプロセスオプション
(Ｓ)処理を終了します。
(Ｐ)プリプロセスオプションを修正して，再度プリプロセスを実行してください。
KFPZ13580-E
File "aa....aa" not found　　（Ｓ）
指定したUAPソースファイルaa....aaが，ありません。
aa....aa：ファイル名
(Ｓ)処理を終了します。
(Ｐ)ファイル名の誤りを修正した後，再度プリプロセスを実行してください。
KFPZ13584-E
Read error occurred on file "aa....aa",errno=bb　　（Ｓ）
指定したUAPソースファイルaa....aaの読み込み時にエラーが発生しました。
aa....aa：ファイル名
bb：エラー番号
(Ｓ)処理を終了します。
(Ｐ)エラーインジケータの値を調査し，errno.h及びユーザが使用するOSのマニュアルを参照して，エラーの原因を取り除き，再度実行してください。
KFPZ13586-E
Invalid file name file "aa....aa"　　（Ｓ）
指定したファイル名aa....aaが誤っています。
aa....aa：ファイル名
(Ｓ)処理を終了します。
(Ｐ)システムメッセージを参照し，エラーの原因を取り除いた後，再度プリプロセスを実行してください。
KFPZ13600-E
END DECLARE SECTION missing　　（Ｓ）
END DECLARE SECTIONの前で，プログラムの終わりを検出しました。
(Ｓ)処理を終了します。
(Ｐ)END DECLARE SECTIONを追加して，再度プリプロセスを実行してください。
KFPZ13601-E
BEGIN DECLARE SECTION missing　　（Ｓ）
BEGIN DECLARE SECTIONがありません。
(Ｓ)処理を終了します。
(Ｐ)BEGIN DECLARE SECTIONを追加して，再度プリプロセスを実行してください。
KFPZ13602-E
SQL statement not found after EXEC SQL　　（Ｓ）
EXEC SQLの後にSQL文がありません。
(Ｓ)このEXEC SQLを無視して，処理を続行します。
(Ｐ)SQL文を追加して，再度プリプロセスを実行してください。
KFPZ13603-E
WORKING-STORAGE SECTION missing　　（Ｓ）
WORKING-STORAGE SECTIONがありません。又は，実行時に使用する作業領域を生成できません。
(Ｓ)処理を終了します。
(Ｐ)WORKING-STORAGE SECTIONを追加して，再度プリプロセスを実行してください。
KFPZ13610-E
Incomplete data description　　（Ｓ）
変数の定義部が完成していません。
(Ｓ)この変数定義文を無視して，処理を続行します。
(Ｐ)変数の定義部を修正して，再度プリプロセスを実行してください。
KFPZ13611-E
Incorrect margin used for EXEC SQL　　（Ｓ）
EXEC SQLの前後に不正な空白文字列があります。
(Ｓ)このSQL文を無視します。
(Ｐ)SQL文を修正し，再度プリプロセスを実行してください。
KFPZ13612-E
Invalid string "aa....aa" before EXEC SQL　　（Ｓ）
EXEC SQLの前に文字列"aa....aa"があります。
aa....aa：EXEC SQLの前にある文字列
(Ｓ)文字列を無視して，処理を続行します。
(Ｐ)EXEC SQLの前にある文字列を取り除くか，2行に分け，再度プリプロセスを実行してください。
KFPZ13635-E
SQL object not generated　　（Ｓ）
ポストソースを生成できません。
(Ｓ)処理を終了します。
(Ｐ)システムメッセージを参照し，エラーの原因を取り除いた後，再度プリプロセスを実行してください。
KFPZ13706-E
Open error occurred on file "aa....aa",errno=bb　　（Ｓ）
ファイルのオープン時にエラーが発生しました。
aa....aa：エラーが発生したファイル名
bb：エラー番号
(Ｓ)処理を続行します。ただし，該当するファイルへの出力処理はしません。
(Ｐ)エラーインジケータの値を調査し，errno.h及びユーザが使用するOSのマニュアルを参照して，エラーの原因を取り除き，再度実行してください。
KFPZ13707-E
Write error occurred on file "aa....aa",errno=bb　　（Ｓ）
ファイルへの書き込みエラーが発生しました。
aa....aa：エラーが発生したファイル名
bb：エラー番号
(Ｓ)処理を終了します。
(Ｐ)エラーインジケータの値を調査し，errno.h及びユーザが使用するOSのマニュアルを参照して，エラーの原因を取り除き，再度実行してください。
KFPZ13708-E
Too long line in user program　　（Ｓ）
UAPの1行の長さが32000バイトを超えています。
(Ｓ)処理を終了します。
(Ｐ)エラーが発生した行を複数行に分割して，1行の長さを制限内にしてから，再度プリプロセスを実行してください。
KFPZ13709-E
Open error occurred on file aa....aa　　（Ｓ）
指定したUAPソースファイルを開けません。
aa....aa：ファイル名
(Ｓ)処理を終了します。
(Ｐ)エラーの原因を取り除いて，再度トランスレートをしてください。
KFPZ13710-E
Write error occurred on file aa....aa　　（Ｓ）
ファイルへの書き込み時に，エラーが発生しました。
aa....aa：ファイル名
(Ｓ)処理を終了します。
(Ｐ)エラーの原因を取り除いて，再度トランスレートをしてください。
KFPZ13711-E
Read error occurred on file "aa....aa"　　（Ｓ）
指定したUAPソースファイルからの読み込み時に，エラーが発生しました。
aa....aa：ファイル名
(Ｓ)処理を終了します。
(Ｐ)エラーの原因を取り除いて，再度トランスレートをしてください。
KFPZ13712-E
Security error occurred on file "aa....aa", reason=bb....bb　　（Ｓ）
指定したUAPソースファイルからの読み込み時に，セキュリティエラーが発生しました。
aa....aa：ファイル名
bb....bb：エラー理由
(Ｓ)処理を終了します。
(Ｐ)エラーの原因を取り除いて，再度トランスレートをしてください。
KFPZ13713-E
Invalid directory "aa....aa"　　（Ｓ）
指定したディレクトリが不正です。
aa....aa：ディレクトリ名
(Ｓ)処理を終了します。
(Ｐ)エラーの原因を取り除いて，再度トランスレートをしてください。
KFPZ13800-E
Invalid token or identifier aa....aa　　（Ｓ）
不正なトークン又は識別子を指定しています。
aa....aa：不正なトークン又は識別子
(Ｓ)ポストソースを生成しないで処理を続行します。
(Ｐ)プログラムを修正して，再度プリプロセスを実行してください。
KFPZ13801-E
Too complicated expression: stack overflow　　（Ｓ）
式が複雑なため，解釈で使用するスタックがオーバフローしました。次の原因が考えられます。
・演算子の優先順位が記述順と逆転している箇所が多過ぎます。
・括弧のネストが深過ぎます。
(Ｓ)ポストソースを生成しないで処理を続行します。
(Ｐ)プログラムを修正して，再度プリプロセスを実行してください。
KFPZ13802-E
Too complicated struct or union: stack overflow　　（Ｓ）
構造体又は共用体のネストが深過ぎて，解釈で使用するスタックがオーバフローしました。
(Ｓ)ポストソースを生成しないで処理を続行します。
(Ｐ)プログラムを修正して，再度プリプロセスを実行してください。
KFPZ13803-E
Illegal declaration aa....aa　　（Ｓ）
変数aa....aaの宣言に誤りがあります。
aa....aa：変数名
(Ｓ)ポストソースを生成しないで処理を続行します。
(Ｐ)プログラムを修正して，再度プリプロセスを実行してください。
KFPZ13804-E
Illegal combination of type names "aa....aa"　　（Ｓ）
不正な型指定子の組み合わせが使用されています。
aa....aa：型指定子として指定した文字列
(Ｓ)ポストソースを生成しないで処理を続行します。
(Ｐ)プログラムを修正して，再度プリプロセスを実行してください。
KFPZ13805-E
Illegal storage-class specification "aa....aa"　　（Ｓ）
記憶クラスの指定に誤りがあります。
aa....aa：記憶クラスとして指定した文字列
(Ｓ)ポストソースを生成しないで処理を続行します。
(Ｐ)プログラムを修正して，再度プリプロセスを実行してください。
KFPZ13806-E
Illegal type qualifier specification "aa....aa"　　（Ｓ）
型修飾子の指定に誤りがあります。
aa....aa：型修飾子として指定した文字列
(Ｓ)ポストソースを生成しないで処理を続行します。
(Ｐ)プログラムを修正して，再度プリプロセスを実行してください。
KFPZ13807-E
Unable to specify SQL statement or SQL TYPE IS declare statement in included file　　（Ｓ）
インクルードファイルの中には，SQL文，又はSQL TYPE IS型の埋込み変数の宣言は指定できません。
(Ｓ)ポストソースを生成しないで，処理を続行します。
(Ｐ)プログラムを修正して，再度プリプロセスを実行してください。
KFPZ20002-E
Memory shortage, inf1=aa....aa, inf2=bbbb　　（Ａ）
メモリが不足しました。
aa....aa：保守情報1
bbbb：保守情報2
(Ｓ)処理を終了します。
(Ｐ)不要なプロセスを終了した後，再度実行してください。
KFPZ20003-E
Function sequence error for HiRDB ODBC Driver　　（Ａ）
要求コードのシーケンスに誤りがあります。
(Ｓ)処理を終了します。
(Ｐ)処理中のステートメントハンドルをSQLFreeStmt関数で解放するか，又はサーバとの接続を切断してください。
KFPZ20004-E
Environment definition Error in ODBC.INI,variable=aa....aa　　（Ａ）
ODBCの環境設定に誤りがあります。
aa....aa：誤りのあるクライアント環境変数名
(Ｓ)処理を終了します。
(Ｐ)ODBCのデータソース設定をして，環境変数設定値を見直してください。
KFPZ20005-W
Warning flag (aa....aa) detected　　（Ａ）
HiRDBへアクセスするときに，SQL連絡領域の警告フラグ（SQLWARN）が設定されました。
aa....aa：警告フラグの種別（SQLWARN1～SQLWARNF）
(Ｓ)処理を終了します。
(Ｐ)マニュアル「HiRDB Version 7 SQLリファレンス」又は「HiRDB Version 7 UAP開発ガイド」を参照して，対策してください。
KFPZ20006-E
System call error, func=aa....aa, errno=bbbb　　（Ａ）
マルチスレッドライブラリでエラーが発生しました。
aa....aa：エラーが発生した関数名
bbbb：GetLastError（Windowsエラーコード取得関数）で得たエラーコード
(Ｓ)処理を打ち切り，UAPにエラーコードを返します。
(Ｐ)errno.h及びユーザが使用するOSのマニュアルを参照してエラーの要因を取り除き，再度実行してください。
KFPZ20007-E
HiRDB API error, func=aa....aa, error code=bbbb　　（Ａ）
HiRDBのAPIでエラーが発生しました。
aa....aa：エラーが発生した関数名
bbbb：HiRDB APIからのリターンコード
p_rdb_RC_MEMERR（-70）：メモリ不足
p_rdb_RC_SIMERR（-80）：同一接続下での同時要求
(Ｓ)処理を打ち切り，UAPにエラーコードを返します。
(Ｐ)リターンコードに示すエラーの要因を取り除き，再度実行してください。bbbbで上記以外のリターンコードが出力されている場合には，保守員に連絡してください。
KFPZ20999-E
Internal Error occurred, inf1=aa....aa, inf2=bbbb　　（Ａ）
ODBCドライバの内部矛盾が発生しました。
aa....aa：保守情報1
bbbb：保守情報2
(Ｓ)処理を終了します。
[対策]エラーメッセージを記録し，保守員に連絡してください。
エラーログファイルが出力されているときは，エラーログファイルのバックアップを取得してください。
KFPZ22001-E
Profile aa....aa not found, Java error class name bb....bb　　（Ａ）
プロファイルaa....aaが見付かりません。
aa....aa：プロファイル名
bb....bb：エラークラス名
(Ｓ)処理を終了します。
(Ｐ)指定したプロファイルがあるかどうかを確認して，再度実行してください。
プロファイルがある場合にこのメッセージが出力されるときは，プロファイルが壊れている可能性があります。この場合，再度UAPをトランスレートして，プロファイルを作成し直してください。
KFPZ22002-E
Unable to load profile aa....aa　　（Ａ）
プロファイルaa....aaが読み込めません。
aa....aa：プロファイル名
(Ｓ)処理を終了します。
(Ｐ)プロファイルが壊れている可能性があるため，プロファイルを作成し直して再度実行してください。又は，HiRDBのSQLJトランスレータで作成したプロファイルではない可能性があるため，プロファイルをHiRDBのSQLJトランスレータで作成し直して再度実行してください。
KFPZ22003-E
Unable to convert data type aa....aa to bb....bb　　（Ａ）
型変換ができない組み合わせを指定しています。
aa....aa：データベースの型名
bb....bb：UAPの変数の型名
(Ｓ)処理を終了します。
(Ｐ)SQL文及びUAPを見直して，再度トランスレートをしてプロファイルを作成し直してください。
KFPZ22004-E
Invalid method aa....aa　　（Ａ）
無効なメソッドを呼び出しています。
aa....aa：メソッド名
(Ｓ)処理を終了します。
(Ｐ)aa....aaはHiRDBでは使用できないため，UAPを見直して再度実行してください。
KFPZ22005-E
Unable to fetch null value into primitive data type　　（Ａ）
ナル値をプリミティブな型に読み込めません（ナル値のデータを，get～NoNullメソッドで取得しようとしています）。
(Ｓ)処理を終了します。
(Ｐ)SQL文及びUAPを見直して，再度トランスレートをしてプロファイルを作成し直してください。
KFPZ22006-E
No rows found in single row select　　（Ａ）
1行SELECT文の検索結果が0件でした。
(Ｓ)処理を終了します。
(Ｐ)SQL文を見直して，再度実行してください。
KFPZ22007-E
Cardinality violation in single row select　　（Ａ）
1行SELECT文の検索結果が2行以上になりました。
(Ｓ)処理を終了します。
(Ｐ)SQL文を見直して，再度実行してください。
KFPZ22008-E
Number (aa....aa) of items in iterator or INTO clause unmatch (bb....bb) number of select items　　（Ａ）
イテレータのフィールドの数，又はINTO句の埋込み変数の数が，選択項目の数と一致していません。
aa....aa：UAP側が指定する（予想する）ResultSetの列数
bb....bb：ResultSetの列数
(Ｓ)処理を終了します。
(Ｐ)SQL文，及びIteratorの宣言を見直して，再度実行してください。
KFPZ22009-E
Null connection context　　（Ａ）
接続コンテキストがナル値です。
(Ｓ)処理を終了します。
(Ｐ)接続コンテキストが正しく生成されているかUAPを見直して，再度実行してください。
KFPZ22010-E
Null execution context　　（Ａ）
実行コンテキストがナル値です。
(Ｓ)処理を終了します。
(Ｐ)実行コンテキストが正しく生成されているかUAPを見直して，再度実行してください。
KFPZ22011-E
Null JDBC connection　　（Ａ）
JDBC connectionオブジェクトがナル値です。
(Ｓ)処理を終了します。
(Ｐ)JDBC connectionオブジェクトが正しく生成されているかUAPを見直して，再度実行してください。
KFPZ22012-E
Memory shortage,size=aa....aa　　（Ａ）
SQLJの実行中にメモリ不足が発生しました。
aa....aa：確保できなかった領域の領域長（単位：バイト）
(Ｓ)SQLExceptionをthrowします。
(Ｐ)HiRDBデータ型（HiRDBCHAR，HiRDBVARCHAR，HiRDBNCHAR，HiRDBNVARCHAR，HiRDBMCHAR，HiRDBMVARCHAR，HiRDBBLOB，HiRDBBINARY，HiRDBDECIMAL），及びbyte[]を使用している場合は，指定した領域の長さを見直してください。不要なプロセスを終了した後，再度実行してください。
KFPZ22013-E
Failed character convert.　　（Ａ）
HiRDBの文字コードが，SQLJで使用できない文字コードとなっています。
(Ｓ)SQLExceptionをthrowします。
(Ｐ)SQLJで使用できる文字コードは，SJIS（シフトJIS漢字コード），UJIS（EUC日本語漢字コード），LANG-C（8ビットコード），及びUTF-８です。HiRDBの文字コードを変更し，再度実行してください。
KFPZ22014-E
Not found java or HiRDB data classes aa....aa.　　（Ａ）
Javaデータ型（Short，Integer，Float，Double，String，BigDecimal），又はHiRDBデータ型（HiRDBCHAR，HiRDBVARCHAR，HiRDBMCHAR，HiRDBMVARCHAR，HiRDBNCHAR，HiRDBNVARCHAR，HiRDBDECIMAL，HiRDBBLOB，HiRDBBINARY）のクラスが見付かりません。又は，メモリ不足のため，クラスがロードできませんでした。
aa....aa：クラス名
(Ｓ)SQLExceptionをthrowします。
(Ｐ)不要なプロセスを終了してください。又は，SQLJが正しくインストールされているか，正しくクラスパスが設定されているかを見直してください。その後，再度実行してください。
KFPZ22015-E
Unable to allocate connection handle due to lack of memory.　　（Ａ）
メモリ不足のため，コネクションハンドルの割り当てに失敗しました。
(Ｓ)SQLExceptionをthrowします。
(Ｐ)不要なプロセスを終了し，再度実行してください。又は，実行環境のメモリ環境を確認し，再度実行してください。
KFPZ22016-E
Iterator aa....aa already defined.　　（Ａ）
SQLJネイティブインターフェース使用時は，同一の反復子オブジェクトを使用して異なるSELECT文を実行できません。
aa....aa：反復子オブジェクト名
(Ｓ)処理を終了します。
(Ｐ)反復子オブジェクトは各SELECT文でユニークになるようにUAPを修正し，再度トランスレートを実行してください。
KFPZ22017-E
Internal error occurred in method aa....aa during execution of SQLJ native interface, code=bb....bb.　　（Ａ）
SQLJネイティブインタフェースで内部矛盾が発生しました。
aa....aa：エラーを検出したSQLJネイティブインタフェースのメソッド名
bb....bb：内部情報
(Ｓ)SQLExceptionをthrowします。
(Ｐ)再度UAPをトランスレートしてから実行してください。再度実行してもエラーが発生する場合は，保守員に連絡してください。
KFPZ22019-E
Invalid port number aa....aa for connection to HiRDB server.　　（Ａ）
接続するHiRDBサーバのポート番号が不正です。指定できるポート番号は5001～65535です。
aa....aa：不正なポート番号
(Ｓ)SQLExceptionをthrowします。
(Ｐ)ポート番号を修正し，UAPをトランスレートしてから実行してください。
KFPZ23000-E
Parentheses missing　　（Ｓ）
必要な箇所に括弧（( )，[ ]，又は{ }）を記述していません。
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23001-E
Equal symbol missing　　（Ｓ）
必要な箇所に等号（＝）を記述していません。
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23002-E
Invalid expression in user program　　（Ｓ）
#SQL句外の，プログラム中の式が不正です。
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23003-E
Invalid word "aa....aa" in user program　　（Ｓ）
#SQL句外の，プログラム中の語句が不正です。
aa....aa：不正な語句
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23004-E
Invalid named iterator aa....aa　　（Ｓ）
名前付き反復子の定義が誤っています。
aa....aa：反復子の名称
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23005-E
Duplicate withkey aa....aa　　（Ｓ）
WITH句を二重指定しています。
aa....aa：WITH句のキーワード
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23006-E
Invalid data type aa....aa　　（Ｓ）
使用できないデータ型を指定しています。
aa....aa：型名
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23007-E
Unclosed Parentheses　　（Ｓ）
括弧（( )，[ ]，又は{ }）が閉じていません。
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23008-E
Dot missing　　（Ｓ）
必要な箇所にドット（.）を記述していません。
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23009-E
Duplicate field definition aa....aa　　（Ｓ）
フィールドの二重定義をしています。
aa....aa：フィールド名
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23010-E
No field in positioned iterator　　（Ｓ）
名前なし反復子に，フィールドを定義していません。
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23011-E
Identifier missing　　（Ｓ）
必要な箇所に識別子を記述していません。
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23012-E
INTO clause missing　　（Ｓ）
INTO句を記述していません。
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23013-E
Invalid SQLJ statement　　（Ｓ）
SQLJ文に誤りがあります。
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23014-E
Too many execution contexts for one SQL statement　　（Ｓ）
一つのSQL文に，実行コンテキストを複数指定しています。
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23015-E
Too many connection contexts for one SQL statement　　（Ｓ）
一つのSQL文に，接続コンテキストを複数指定しています。
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23016-E
Duplicate class definition aa....aa　　（Ｓ）
クラスが二重定義されています。
aa....aa：クラス名
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23017-E
Unclosed quotation　　（Ｓ）
文字列定数の引用符号（'又は"）が閉じていません。
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23100-E
Invalid SQLJ statement declared　　（Ｓ）
SQLJ文の記述が不正です。
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23101-E
Unable to identify class aa....aa　　（Ｓ）
クラスaa....aaが識別できません。
aa....aa：クラス名
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23102-E
Not Array type aa....aa　　（Ｓ）
aa....aaは配列型ではありません。
aa....aa：型名
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23103-E
Unable to identify constructor aa....aa　　（Ｓ）
コンストラクタを特定できません。
aa....aa：コンストラクタ名
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23104-E
Unable to identify field aa....aa　　（Ｓ）
フィールドaa....aaを特定できません。
aa....aa：フィールド名
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23105-E
Unable to identify method aa....aa　　（Ｓ）
メソッドを特定できません。
aa....aa：メソッド名
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23106-E
Numeric operands required　　（Ｓ）
オペランドの型が数値型ではありません。
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23107-E
Array index requires numeric type　　（Ｓ）
配列の添字に，数値型以外のデータ型を指定しています。
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23108-E
Invalid data type of operand for cast operator　　（Ｓ）
キャストできないデータ型を，キャスト演算子のオペランドに指定しています。
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23109-E
Invalid data type of operand for equality operator　　（Ｓ）
等号演算子のオペランドのデータ型が不正です。
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23110-E
Invalid data type of operand for boolean or numeric operator　　（Ｓ）
数値演算子又は論理演算子で使用できないデータ型をオペランドに指定しています。
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23111-E
Invalid data type of operand for boolean operator　　（Ｓ）
論理演算子で使用できないデータ型をオペランドに指定しています。
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23112-E
Invalid data type of operand for comparison operator　　（Ｓ）
比較演算子で使用できないデータ型をオペランドに指定しています。
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23113-E
Invalid data type of operand for complement operator　　（Ｓ）
補数演算子で使用できないデータ型をオペランドに指定しています。
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23114-E
Invalid data type of operand for conditional operator　　（Ｓ）
条件演算子で使用できないデータ型をオペランドに指定しています。
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23116-E
Constructor undefined　　（Ｓ）
コンストラクタが定義されていません。
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23117-E
Field aa....aa not accessible 　　（Ｓ）
フィールドがアクセスできません。
aa....aa：フィールド名
(Ｓ)処理を終了します。
(Ｐ)変数の修飾子に注意してプログラムを見直し，再度プリプロセスしてください。
KFPZ23118-E
Invalid data type of operand for increment/decrement operator　　（Ｓ）
インクリメント演算子又はデクリメント演算子のオペランドに，使用できないデータ型を指定しています。
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23119-E
Invalid data type of operand for instanceof operator　　（Ｓ）
instanceof演算子のオペランドに，使用できないデータ型を指定しています。
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23121-E
Method not accessible　　（Ｓ）
呼び出せないメソッドを指定しました。
(Ｓ)処理を終了します。
(Ｐ)メソッドの修飾子に注意してプログラムを見直し，再度プリプロセスしてください。
KFPZ23122-E
Method aa....aa undefined　　（Ｓ）
メソッドが定義されていません。
aa....aa：メソッド名
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23123-E
Invalid identifier aa....aa　　（Ｓ）
不正な識別子があります。
aa....aa：識別子
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23124-E
Invalid data type of operand for negation operator　　（Ｓ）
否定演算子のオペランドのデータ型が不正です。
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23125-E
Invalid data type of operand for shift operator　　（Ｓ）
シフト演算子のオペランドのデータ型が不正です。
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23126-E
Invalid data type of operand for sign operator　　（Ｓ）
符号演算子のオペランドのデータ型が不正です。
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23127-E
Token aa....aa unexpected　　（Ｓ）
予期していないトークンを記述しています。
aa....aa：トークン
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23128-E
Undefined identifier aa....aa　　（Ｓ）
システムで定義されていない識別子を指定しています。
aa....aa：識別子
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23130-E
Undefined target type in cast expression aa....aa　　（Ｓ）
キャスト式のターゲットのデータ型が定義されていません。
aa....aa：キャストするデータ型の型名，クラス名
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23132-E
Initiarization lists unexpected　　（Ｓ）
記述できない箇所に初期値を記述しています。
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23136-E
Invalid SQLJ declaration　　（Ｓ）
SQLJの宣言文が不正です。
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23137-E
Invalid SQLJ Iterator declaration　　（Ｓ）
反復子の宣言が不正です。
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23138-E
Incomplete file　　（Ｓ）
UAPのファイルがプログラムの途中で終わっています。
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23139-E
Invalid expression　　（Ｓ）
#SQL句の式が不正です。
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23140-E
Invalid IN/OUT mode for INTO variables　　（Ｓ）
INTO句に指定した，埋込み変数のIN/OUTモードの指定が誤っています。
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23141-E
Incomplete SQLJ statement　　（Ｓ）
SQLJ文が不完全です。
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23142-E
Invalid token aa....aa　　（Ｓ）
不正なトークンを記述しています。
aa....aa：語句
(Ｓ)処理を終了します。
(Ｐ)プログラムを修正して，再度プリプロセスしてください。
KFPZ23143-E
Invalid data length aa....aa　　（Ａ）
指定した領域の長さが不正です。
aa....aa：指定した領域の長さ
(Ｓ)SQLExceptionをthrowします。
(Ｐ)HiRDBデータ型（HiRDBCHAR，HiRDBVARCHAR，HiRDBNCHAR，HiRDBNVARCHAR，HiRDBMCHAR，HiRDBMVARCHAR，HiRDBBLOB，HiRDBBINARY，HiRDBDECIMAL）で指定した領域の長さ，精度，及びスケールを見直してください。
KFPZ24000-E
Invalid CommandTimeout property, please specify zero or more.　　（A）
HiRDBCommandクラスのCommandTimeoutプロパティに負の値を設定しています。
(Ｓ)処理を終了します。
(Ｐ)０以上の値を設定してください。
KFPZ24001-E
Invalid Connection property.　　（A）
HiRDBCommandクラスのConnectionプロパティにHiRDBConnectionクラスのオブジェクトを設定していない状態で，ExecuteNonQueryメソッド，ExecuteReaderメソッド，ExecuteScalarメソッド，又はPrepareメソッドのどれかを実行しています。
(Ｓ)処理を終了します。
(Ｐ)Connectionプロパティを設定して，実行してください。
KFPZ24002-E
Prepare method performed before connection opened.　　（A）
HiRDBConnectionクラスのOpenメソッドが実行されていない状態で，HiRDBCommandクラスのPrepareメソッドを実行しています。
(Ｓ)処理を終了します。
(Ｐ)接続を開いて，使用できる状態にしてください。
KFPZ24003-E
Invalid value of ArraySize property.　　（A）
HiRDBCommandクラスのExecuteNonQueryメソッドの引数ArraySizeが0以下です。又はHiRDBParameterクラスのValueプロパティに代入した配列データ数と一致しません。
(Ｓ)処理を終了します。
(Ｐ)Arraysizeを配列要素数と一致させてください。
KFPZ24004-E
Method for execution performed before connection opened.　　（A）
HiRDBConnectionクラスのOpenメソッドが実行されていない状態で，HiRDBCommandクラスのExecuteNonQueryメソッド，ExecuteReaderメソッド，又はExecuteScalarメソッドのどれかを実行しています。
(Ｓ)処理を終了します。
(Ｐ)接続を開いて，使用できる状態にしてください。
KFPZ24005-E
Invalid CommandText property.　　（A）
HiRDBCommandクラスのCommandTextプロパティが空の状態で，同クラスのPrepareメソッド，ExecuteNonQueryメソッド，ExecuteReaderメソッド，又はExecuteScalarメソッドのどれかを実行しています。
(Ｓ)処理を終了します。
(Ｐ)CommandTextプロパティに実行するSQLを設定してください。
KFPZ24006-E
Invalid Transaction property.　　（A）
トランザクション実行中で，かつHiRDBCommandクラスのTransactionプロパティがnullの状態の場合に，同クラスのExecuteNonQueryメソッド，ExecuteReaderメソッド，又はExecuteScalarメソッドのどれかを実行しています。
(Ｓ)処理を終了します。
(Ｐ)Transactionプロパティを設定してください。
KFPZ24007-E
Unsupported value specified for property of HiRDBCommand class.　　（A）
HiRDBParameterクラスのDirectionプロパティにReturnValueが指定された状態で，HiRDBCommandクラスのExecuteNonQueryメソッド，ExecuteReaderメソッド，ExecuteScalarメソッド，又はPrepareメソッドのどれかを実行しています。又はUpdateRowSourceプロパティにBoth/FirstReturnedRecordが指定されています。
(Ｓ)処理を終了します。
(Ｐ)未サポートのため，使用できません。ほかの値を指定してください。
KFPZ24008-E
Unable to change ConnectionString property during connection opened.　　（A）
接続中にHiRDBConnectionクラスのConnectionStringプロパティを変更しています。
(Ｓ)処理を終了します。
(Ｐ)接続が閉じている状態で設定してください。
KFPZ24009-E
Unable to change Pooling property during connection opened.　　（A）
接続中にHiRDBConnectionクラスのPoolingプロパティを変更しています。
(Ｓ)処理を終了します。
(Ｐ)接続が閉じている状態で設定してください。
KFPZ24010-E
Unable to change LifeTime property during connection opened.　　（A）
接続中にHiRDBConnectionクラスのLifeTimeプロパティを変更しています。
(Ｓ)処理を終了します。
(Ｐ)接続が閉じている状態で設定してください。
KFPZ24011-E
BeginTransaction method performed before connection opened.　　（A）
HiRDBConnectionクラスのOpenメソッドが実行されていない（接続が閉じている）状態で，HiRDBConnectionクラスのBeginTransactionメソッドを実行しています。
(Ｓ)処理を終了します。
(Ｐ)接続を開いて，使用できる状態にしてください。
KFPZ24012-E
Transaction already executed.　　（A）
既にトランザクションが実行中の状態で，HiRDBConnectionクラスのBeginTransactionメソッドを実行しています。
(Ｓ)処理を終了します。
(Ｐ)既にトランザクションは実行中のため，実行しないようにしてください（パラレルトランザクションは使用できません）。
KFPZ24013-E
ChangeDatabase method performed before connection opened.　　（A）
HiRDBConnectionクラスのOpenメソッドが実行されていない（接続が閉じている）状態で，HiRDBConnectionクラスのChangeDatabaseメソッドを実行しています。
(Ｓ)処理を終了します。
(Ｐ)接続を開いて，使用できる状態にしてください（ChangeDatabaseメソッドは使用できません）。
KFPZ24014-E
Connection already opened.　　（A）
既に接続が開かれている状態で，HiRDBConnectionクラスのOpenメソッドを実行しています。
(Ｓ)処理を終了します。
(Ｐ)既に接続は開かれているため，実行しないでください。
KFPZ24015-E
SchemaTable method performed before record opened.　　（A）
HiRDBDataReaderクラスのIsClosedプロパティがtrueの状態で，GetSchemaTableメソッドを実行しています。
(Ｓ)処理を終了します。
(Ｐ)HiRDBCommandクラスのExecuteReaderメソッドを実行して，レコードを開いてから実行してください。
KFPZ24016-E
NextResult method performed before record opened.　　（A）
HiRDBDataReaderクラスのIsClosedプロパティがtrueの状態で，NextResultメソッドを実行しています。
(Ｓ)処理を終了します。
(Ｐ)HiRDBCommandクラスのExecuteReaderメソッドを実行して，レコードを開いてから実行してください。
KFPZ24017-E
Record method performed before record opened.　　（A）
HiRDBDataReaderクラスのIsClosedプロパティがtrueの状態で，Readメソッドを実行しています。
(Ｓ)処理を終了します。
(Ｐ)HiRDBCommandクラスのExecuteReaderメソッドを実行して，レコードを開いてから実行してください。
KFPZ24018-E
Unable to specify method for cast due to null value.　　（A）
nullデータをHiRDBDataReaderクラスのGetBooleanメソッド，GetByteメソッド，GetBytesメソッド，GetCharメソッド，GetCharsメソッド，GetDateTimeメソッド，GetDecimalメソッド，GetDoubleメソッド，GetFloatメソッド，GetInt16メソッド，GetInt32メソッド，GetInt64メソッド，又はGetStringメソッドのどれかで取得しようとしています。
(Ｓ)処理を終了します。
(Ｐ)HiRDBDataReaderクラスのGetValueメソッドでnullデータを取得してください。
KFPZ24019-E
Invalid value for column number of methods in HiRDBDataReader class.　　（A）
無効なカラム番号を指定して，HiRDBDataReaderクラスのGetBooleanメソッド，GetByteメソッド，GetBytesメソッド，GetCharメソッド，GetCharsメソッド，GetDataTypeNameメソッド，GetDateTimeメソッド，GetDecimalメソッド，GetDoubleメソッド，GetFieldTypeメソッド，GetFloatメソッド，GetInt16メソッド，GetInt32メソッド，GetInt64メソッド，GetNameメソッド，GetStringメソッド，GetValueメソッド，IsDBNullメソッド，又はGetFieldArrayCountメソッドのどれかを実行しています。
(Ｓ)処理を終了します。
(Ｐ)カラム番号を確認して実行してください。
KFPZ24020-E
Invalid column name spacified in GetOrdinal method.　　（A）
無効なカラム名を指定して，HiRDBDataReaderクラスのGetOrdinalメソッドを実行しています。
(Ｓ)処理を終了します。
(Ｐ)カラム名を確認して実行してください。
KFPZ24021-E
Invalid parameter name specified in method of HiRDBParameterCollection class.　　（A）
無効なパラメタ名を指定して，HiRDBParameterCollectionクラスのIndexOfメソッド又はRemoveAtメソッドを実行しています。
(Ｓ)処理を終了します。
(Ｐ)パラメタ名を確認して実行してください。
KFPZ24022-E
Unable to perform Commit method or Rollback method, , because transaction already terminated.　　（A）
既にトランザクションは完了の状態で，HiRDBTransactionクラスのCommitメソッド又はRollbackメソッドを実行しています。
(Ｓ)処理を終了します。
(Ｐ)既にトランザクションは完了の状態のため，実行しないようにしてください。
KFPZ24023-E
Invalid DataAdapter property.　　（A）
HiRDBCommandBuilderクラスのDataAdapterプロパティを設定していない状態で，GetDeleteCommandメソッド，GetInsertCommandメソッド，GetUpdateCommandメソッド，又はRefreshSchemaメソッドのどれかを実行しています。
(Ｓ)処理を終了します。
(Ｐ)DataAdapterプロパティを設定して，実行してください。
KFPZ24024-E
Invalid SelectCommand property of HiRDBDataAdapter class object.　　（A）
HiRDBCommandBuilderクラスのDataAdapterオブジェクトのSelectCommandプロパティを設定していない状態で，HiRDBCommandBuilderクラスのGetDeleteCommandメソッド，GetInsertCommandメソッド，GetUpdateCommandメソッド，又はRefreshSchemaメソッドのどれかを実行しています。
(Ｓ)処理を終了します。
(Ｐ)DataAdapterオブジェクトのSelectCommandプロパティを設定して，実行してください。
KFPZ24025-E
Unable to specify Null for specified property or argument.　　（A）
nullを指定できないプロパティ，コンストラクタ引数，又はメソッド引数に，nullを指定しています。
(Ｓ)処理を終了します。
(Ｐ)null以外を指定してください。
KFPZ24026-E
Specified value not convertible into HiRDB Type aa....aa　　（A）
aa....aa番目のHiRDBParameterクラスのHiRDBTypeプロパティに指定した型に変換できない値を，Valueプロパティに指定しています。
aa....aa：パラメタ番号
(Ｓ)処理を終了します。
(Ｐ)変換できる型の値，又はHiRDBTypeプロパティに指定した型の値を，Valueプロパティに指定してください。
KFPZ24100-E
Invalid connection string.　　（A）
無効な接続文字列の引数を指定しました。又は必要な接続文字列の引数が指定されていません。
(Ｓ)処理を終了します。
(Ｐ)接続文字列を確認して実行してください。
KFPZ24101-E
Unable to allocate connection handle due to lack of memory.　　（A）
メモリ不足によって，コネクションハンドルの割り当てに失敗しました。
(Ｓ)処理を終了します。
(Ｐ)実行環境のメモリ容量を確認してください。
KFPZ24102-E
Unable to release connection handle due to lack of memory.　　（A）
メモリ不足によって，コネクションハンドルの解放に失敗しました。
(Ｓ)処理を終了します。
(Ｐ)実行環境のメモリ容量を確認してください。
KFPZ24103-E
Connection handle not allocated.　　（A）
コネクションハンドルが割り当てられていません。
(Ｓ)処理を終了します。
(Ｐ)コネクションハンドルを割り当ててください。
KFPZ24104-E
Error occurred in environment variable for connection.　　（A）
環境変数設定時にエラーが発生しました。
(Ｓ)処理を終了します。
(Ｐ)環境変数を確認して実行してください。
KFPZ24105-E
Too many SQL prepared and excuted concurrently.　　（A）
並行して準備，又は実行しているSQL文が多過ぎます。
(Ｓ)処理を終了します。
(Ｐ)セクション番号の最大値を増やしてください（デフォルト：SECTION_MAX = 4095）。
KFPZ24106-E
Invalid value for input ? parameter of DATETIME or INTERVAL data type.　　（A）
日付型，時刻型，日間隔型，又は時間間隔型の入力？パラメタに対して指定した値の形式が不正です。
(Ｓ)処理を終了します。
(Ｐ)指定した日付型，時刻型，日間隔型，又は時間間隔型に対して，有効な文字列表現の値を指定してください。
KFPZ24107-E
Overflow error occurred for input ? parameter of DECIMAL or DATETIME or INTERVAL data type.　　（A）
Decimal型，日付型，時刻型，日間隔型，又は時間間隔型の入力？パラメタ値の型変換時にオーバーフローが発生しました。
(Ｓ)処理を終了します。
(Ｐ)日付型，時刻型，日間隔型，又は時間間隔型の値を，適切な文字列表現で設定してください。
KFPZ24108-E
Unknown type specified in DbType property.　　（A）
HiRDBParameterクラスのDbTypeプロパティに使用できないデータ型が指定されました。
(Ｓ)処理を終了します。
(Ｐ)型を確認して設定してください。
KFPZ24109-E
Unsupported type specified in DbType property.　　（A）
HiRDBParameterクラスのDbTypeプロパティにBoolean，Currency，Guid，又はVarNumericのどれかを設定しています。
(Ｓ)処理を終了します。
(Ｐ)未サポートのため，使用できません。ほかの値を指定してください。
KFPZ30001-I
Usage: pdtrcmgr -d pathname [-b|-e] [-k { [s] [u] [p] [r]|[a] }] [-n uapname] [-s size] [-o]　　（Ｓ）
トレース取得コマンドpdtrcmgrの指定形式を表示します。
(Ｓ)処理を続行します。
(Ｐ)pdtrcmgrの指定形式に従って，再度実行してください。
KFPZ30002-E
Command option error, option=-a, reason=bb....bb　　（Ｓ）
オプションの指定に誤りがあります。
a：誤りがあるオプション
bb....bb：理由として次のどれかが出力されます。
NOT TARGET：引数がありません。
OUT OF RANGE：指定できる範囲を超えています。
NO OPTION：必要なオプションがありません。
INVALID CHAR：指定できない文字があります。
ALREADY USED：既に使用されています。
(Ｓ)処理を終了します。
(Ｐ)誤りを修正してから再度実行してください。
KFPZ30003-E
End Request failed, pathname=aa....aa, bb....bb　　（Ｓ）
システムで使用するファイルを削除できなかったため，SQLトレースの出力要求を停止できません。
aa....aa：誤りがあるパス名（30バイトを超える場合は後ろから30バイトを表示）
bb....bb：エラーの理由又はエラー番号｛reason=cc....cc｜errno=dd....dd｝
cc....cc：エラーの理由
INVALID PATH：パス名が不正
PERMISSION DENIED：パーミッションエラー
dd....dd：エラー番号
(Ｓ)処理を終了します。
(Ｐ)誤りを修正し，再度実行してください。
・INVALID PATHの場合，指定したパス名が誤っているか，又はトレース取得要求をしていない可能性があります。
・PERMISSION DENIEDの場合，指定したパスの権限が有効でない可能性があります。
・エラー番号の場合，errno.hを参照してください。
KFPZ30004-E
Begin request failed, pathname=aa....aa, func=bb....bb, cc....cc　　（Ｓ）
システムで使用するファイルを作成（更新）できなかったため，SQLトレースの出力要求を開始できません。
aa....aa：誤りがあるパス名（30バイトを超える場合は後ろから30バイトを表示）
bb....bb：エラーが発生した関数の名称｛fopen｜fclose｝
cc....cc：エラーの理由又はエラー番号｛reason=dd....dd｜errno=ee....ee｝
dd....dd：エラーの理由
INVALID PATH：パス名が不正
PERMISSION DENIED：パーミッションエラー
FILE TABLE OVERFLOW：オーバフロー
TOO MANY OPEN FILES：オープン制御オーバー
ee....ee：エラー番号
(Ｓ)処理を終了します。
(Ｐ)誤りを修正し，再度実行してください。
・INVALID PATHの場合，指定したパス名が誤っているか，又はトレース取得要求をしていない可能性があります。
・PERMISSION DENIEDの場合，指定したパスの権限が有効でない可能性があります。
・エラー番号の場合，errno.hを参照してください。
KFPZ30005-E
Trace information file error, pathname=aa....aa, func=bb....bb, errno=cc....cc　　（Ｒ）
トレース情報ファイル（.#pdtrc）がオープン又はクローズできないため，SQLトレースを出力できません。
aa....aa：誤りがあるパス名（30バイトを超える場合は後ろから30バイトを表示）
bb....bb：エラーが発生した関数の名称｛fopen｜fclose｝
cc....cc：エラー番号
(Ｓ)処理を終了します。
(Ｐ)パス名，関数名，及びエラー番号から誤りを修正し，再度実行してください。エラー番号については，errno.hを参照してください。
KFPZ40001-I
Usage:pdclttrc [-s server_name] [-p process_id] [-e] [-l PDUAPREPLVL_values] [-m ?parameter_max_data_size] [-n number_of_output_operation_codes] [-o sqltrace_file_size]　　（Ｅ）
pdclttrcコマンドのオプションの指定形式が誤っています。
(Ｓ)処理を終了します。
(Ｏ)オプションの指定形式を修正して，再度実行してください。
KFPZ40002-W
-l option ignored, because server_process performing memory communication, server_name=aa....aa, process_id=bb....bb　　（Ｓ）
サーバプロセスはメモリ通信を実行しているため，-lオプションの指定は無視されます。
aa....aa：サーバ名
bb....bb：サーバプロセスID
(Ｓ)処理を続行します。
KFPZ40003-E
Server_process already executed for pdclttrc command, server_name=aa....aa, process_id=bb....bb　　（Ｓ）
サーバプロセスは既にSQLトレースの動的取得を行っています。
aa....aa：サーバ名
bb....bb：サーバプロセスID
(Ｓ)処理を終了します。
(Ｏ)再度実行する場合は，いったんSQLトレースの取得を終了してください。
KFPZ40004-E
Server_process not connected with client, server_name=aa....aa, process_id=bb....bb　　（Ｓ）
サーバプロセスはクライアントと接続していません。
aa....aa：サーバ名
bb....bb：サーバプロセスID
(Ｓ)処理を終了します。
(Ｏ)クライアントと接続しているサーバプロセスを指定してください。
KFPZ40005-E
Specified server_process not exist, server_name=aa....aa, process_id=bb....bb　　（Ｅ）
指定されたサーバプロセスは存在しません。
aa....aa：サーバ名
bb....bb：サーバプロセスID
(Ｓ)処理を終了します。
(Ｏ)存在するサーバプロセスを指定してください。


？パラメタを使用したデータの入力

？パラメタ入力

「＊」入力規則

？パラメタ入力ダイアログ


？パラメタ入力

●「？パラメタ入力ダイアログ」からの入力の場合

＜値の入力要求＞

  SQL入力ウインドウから「？」を指定したSQL入力すると、「？パラメタ入力ダイアログ」を表示して値の入力を要求します。

・「要求パラメタリスト」の各項目の内容は、次のとおりです。

項目 | 内容
NO | ＳＱＬの何番目の？パラメタに対する入力要求かを表します。
DATA TYPE | ？パラメタのデータ型を表します。 詳細は、TABLEINFコマンドの「データコード値と表示する文字列」表を参照してください。 また、抽象データ型のパラメタ入出力はできません。 非ナル値制約列の場合、NOT NULLの修飾表現を表示します。 繰り返し列の場合、ARRAY[n]（nは繰り返し数）の修飾表現を表示します。 データ型が未設定のときは、**で表現します。
VALUE | ？パラメタの入力値になります。 ？パラメタ入力ダイアログ表示直後は、「*」を入力した場合の値が入ります。

＜入力規則＞

・長大データ型(BLOB)、BINARY型またはCLOB型に対しては、文字列定数、「１６進入力」形式または「ファイル入力」形式で入力が可能です。

・繰り返し列に対する入力は、下に示すようにARRAY[]を使用します。

    CREATE TABLE T(C INTEGER ARRAY[3]);

    INSERT INTO T VALUES(?);

    （「？パラメタ入力ダイアログ」が表示される）

    ARRAY[100,200,300]　　…値編集領域に入力する

  括弧内に指定できる形式は、「値入力」および「１６進入力」です。

●GUI版で「ファイルから実行」の入力の場合

＜値の入力要求＞

  ？を指定したＳＱＬを入力すると、次のメッセージが検索結果ウインドウに表示されます。

DATA ( 1) ? : DECIMAL(29,10) ARRAY[4] : VALUE(NULL)

↑ ↑ ↑

① ② ③

① ＳＱＬの何番目の？パラメタに対する入力要求かを表します。

② ？パラメタのデータ型

  データ型を表します。

  長さ又は、精度・位取りを持つ型の場合は、その値を括弧で囲んで表現します。

  非ナル値制約列の場合、NOT NULLの修飾表現を表示します。

  繰り返し列の場合、ARRAY[n]（nは繰り返し数）の修飾表現を表示します。

『値式 IS NULL』の値式に対する？パラメタのときは、”SQLCODE = 0x01”と表現します。

  データ型が未設定のときは、**で表現します。

③ 「*」が入力されたときの設定値を表します。

  データ型が文字列型([M | N][VAR]CHAR) 、長大データ型(BLOB) 、BINARY型もしくはCLOB型のときは、最大１６バイトまでを表示し、以降は表示を省略します。

  長大データ型(BLOB)もしくはBINARY型のときは、１６進で表示します。（但し、長大データ型(BLOB)およびBINARY型でデータの長さが０バイトのときは、「''」で表現します。）

  繰り返し列のときは、１要素目のデータのみを表示します。

＜入力規則＞

・？パラメタに対する入力要求を行いません。そのためファイル内に、？パラメタを指定したＳＱＬに続き入力値を指定しておく必要があります。

・パラメタ値入力の終了は、行の最後にセミコロンを入力し改行してください。

・長大データ型(BLOB)、BINARY型またはCLOB型に対しては、文字列定数、「１６進入力」形式または「ファイル入力」形式で入力が可能です。

・空送信時は、エラーとなります。

・繰り返し列に対する入力は、下に示すようにARRAY[]を使用します。

    CREATE TABLE T(C INTEGER ARRAY[3]);

    INSERT INTO T VALUES(?);

    ARRAY[100,200,300];

  括弧内に指定できる形式は、「値入力」「１６進入力」および「*」です。

・入力要求に対するパラメタ値入力をやめて、？パラメタを指定したＳＱＬを取り消したい場合はQUITを入力してください。

●値の入力形式

  ？パラメタに対する値の入力形式は、次の通りです。

・「値入力」形式

・「１６進入力」形式

・「FILE ファイル名」形式

・「*」形式

＜「値入力」形式＞

  次のいずれかの値を指定できます。

・整数定数

・１０進数定数

・浮動小数点定数

・文字列定数

・各国文字列定数

・混在文字列定数

・NULL

  詳細は、ＨｉＲＤＢマニュアル「ＳＱＬリファレンス」を参照してください。

[留意事項]

・整数定数、１０進数定数および浮動小数点定数において、実数部（整数部と小数部）、および指数を表現する数値の制限は、最大２９桁までです。

・整数数値型（INTEGER,SMALLINT）および固定小数点型(DECIMAL,INTERVAL YEAR TO DAY,INTERVAL HOUR TO SECOND)に対する入力において、整数型に対する小数点以下の入力など、格納できる範囲を越えるデータが入力された場合、エラーとなります。

＜「１６進入力」形式＞

  「0x」(xは大文字でも可)で始まり、それに続き１６進文字が数個並ぶ文字列を指します。

[留意事項]

・本形式は、浮動小数点型(FLOAT,REAL)に対して使用することができません。

[指定例]

・入力桁数が奇数の場合、先頭に０を付加し処理されます。

例） | 入力 ： | 0x100
 | 処理値 ： | 0x0100

・入力が各々の型の定義長を超えるときは、エラーとなります。

例） | 対象データ型： | CHAR(4) |
 | 入力 ： | 0x413132333435 | …６バイトを表現しているので定義長を越えている。

・整数数値型（INTEGER,SMALLINT）に対する入力では、入力データ（16進表現）を10進表現に変換し設定します。

例） | 対象データ型： | INTEGER
 | 入力 ： | 0x00001000
 | 設定 ： | 4096

・固定小数点型（DECIMAL,INTERVAL YEAR TO DAY,INTERVAL HOUR TO SECOND）に対する入力では、入力データを連続したバイト値として、設定します。

  形式はパック１０進形式で定義長に合せて記述してください。

例） | 対象データ型： | DECIMAL(10,4) | ...定義長は６バイト
 | 入力 ： | 0x01234567891C |
 | 設定 ： | 123456.7891 |

・整数数値型および固定小数点型以外に対する入力では、入力データを連続したバイト値として、設定します。

例） | 対象データ型： | VARCHAR(16)
 | 入力 ： | 0x41313233
 | 設定 ： | 'A123'

＜「FILE ファイル名」形式＞

  指定した「ファイル名」から値を入力します。

[留意事項]

・指定したファイルの内容の先頭からの連続バイトデータ全て（制御文字を含むバイナリ）を入力データとして扱います。

・「ファイル名」は絶対パスで指定してください。

・「ファイル名」に「\」記号以外の文字または空白文字を含む場合は、「ファイル名」を二重引用符で囲んでください。

  （例）

    FILE "C:\TEMP\DA DC.TXT"

・指定したファイルが存在しない場合、エラーとなります。

・「FILE ファイル名」形式は、文字列型([M | N][VAR]CHAR)、TIME型、DATE型、TIMESTAMP型、長大データ型(BLOB)、BINARY型またはCLOB型に対してのみ有効です。

＜「*」形式＞

  「*」入力の詳細については「｢*｣入力規則」を参照してください。


？パラメタ入力ダイアログ

  「SQL入力ウインドウ」から？パラメタを含むSQLを実行すると、？パラメタ入力ダイアログを表示します。

  入力値を設定し、[実行]ボタンを押すとSQLが実行されます。

●？パラメタ入力ダイアログ

（＊３）

（＊２）

（＊１）

・「要求パラメタリスト」（図中の（＊１））

  要求された？パラメタをリスト形式で表示します（注１）。

  値を入力（編集）したい行を選択すると、現在の値（VALUEの値）が「値編集領域」に表示されます。

  値を変更した行は黄色、入力値エラーがある行は赤色で表示されます。

  ？パラメタ入力ダイアログが表示された直後は、VALUEには前回の値がセットされます。

  前回の値がない場合は規定値がセットされます。

  前回の値に対しての詳細は「？パラメタ入力」を参照してください。

・「値編集領域」（図中の（＊２））

  入力できるデータは2,000,000文字です。

  要求パラメタリストで選択されている行の値を変更する領域です。

  改行(0x0d0a)及びタブ文字も入力値に含まれます（注２）。

  値の最後にセミコロンは付けないでください。

  その他の入力規則については、「？パラメタ入力」に従ってください。

・「エラー表示領域」（図中の（＊３））

  入力値エラーがあった場合に、エラーが発生したパラメタの番号（図中の（＊１）のNO列の値）とエラーメッセージが表示されます。

ボタンの表示 | ボタンの機能概要
[更新] | 「値編集領域」の値を「要求パラメタリスト」に反映し、その行を黄色で表示します。
[ﾌｧｲﾙ指定] | ファイル参照ダイアログから入力値に指定したいファイルを選択することができます。 選択されたファイルは”FILE ファイル名”の形式で値編集領域に表示されます。
[実行] | 「要求パラメタリスト」に表示されている値を？パラメタの入力データとして確定します。 入力値にエラーがありSQLが実行できない時は、入力値の再編集をする必要があります。 入力値にエラーがある行が赤色で表示され、そのエラー内容が「エラー表示領域」に表示されます。
[ｷｬﾝｾﾙ] | SQLをキャンセルします。
[入力履歴] | 「SQL履歴」ウインドウを表示します。

注１：？パラメタの値に、改行文字(0x0d0a)及びタブ文字が含まれていても表示はされません。

注２：タブ文字を値として入力する場合「Ctrl + Tab」を押すことによって入力できます。

その他：

・「Tab」キーを押すごとにコントロールのフォーカスが、左上から右下に向かって移動します。

・入力値にエラーがあって入力値の再編集を行うときに、エラーがある行（赤色表示部分）以外の入力値を再編集すると、入力値エラーとなりSQLが実行できなくなる場合があります。この場合、「ｷｬﾝｾﾙ」ボタンを押して、ＳＱＬをキャンセルしてから、再度ＳＱＬを実行してください。

●ファイル参照ダイアログ

  [ﾌｧｲﾙ指定]ボタンを押下することにより、下図のダイアログが表示されます。


「*」入力規則

●？パラメタを使用したＳＱＬ入力の場合

＜GUI版の「ファイルから実行」での値の入力の場合＞

  入力要求メッセージで表示される値は、下記に示す条件を全て満たす場合に限り、前回に入力された値を使用します。

・前回ＳＱＬと同一のＳＱＬを実行する。

・前回ＳＱＬとの間に受け渡し領域の大きさを変更するコマンド（SET ARRAY LIMIT,SET BINARY LIMIT,SET BLOB LIMIT,SET CHAR LIMIT,SET NCHAR LIMIT）を実行しない。但し、前回ＳＱＬと同一のＳＱＬを実行する場合であっても、下記に示す条件のときは前回に入力された値を有効としません（値は、不定値になります）。

  ‐ 数値文字間の暗黙型変換を利用した場合。

  ‐ SQL Executer内でのエラー(KFPXで始まるエラー)が発生した場合（当該データのみ）。

  ‐ データ型不正のエラーが発生した場合。

  ‐ 検索条件値として入力したデータが、定義長より長い場合（当該データのみ）。

  その他の場合、データ型の定義により「1.3　既定値」に示す値になります。

＜？パラメタ入力ダイアログからの値の入力＞

  入力値として「*」を指定した場合、実行するSQLと同じものがSQL履歴にあれば（複数ある場合最新のもの）、その時の入力値になります。実行するSQLと同じものがない場合は、「1.3　既定値」に示す値になります。

＜既定値＞

データ型の定義 |  | 既定値 |
非ナル値制約がない場合 |  | NULL |
非ナル値制約付き |  |  |
 | INTEGER | 0 |
 | SMALLINT | 0 |
 | DECIMAL | 0 |
 | FLOAT | 0 |
 | SMALLFLT | 0 |
 | CHARACTER(n) | nバイトの空白 |
 | VARCHAR(n) | 1バイトの空白 |
 | NCHAR(n) | n文字の空白 |
 | NVARCHAR(n) | 1文字の空白 |
 | MCHAR(n) | nバイトの空白 |
 | MVARCHAR(n) | 1バイトの空白 |
 | DATE | 0001-01-01 |
 | TIME | 00:00:00 |
 | INTERVAL YEAR TO DAY | 0ヶ年0ヶ月0ヶ日間 |
 | INTERVAL HOUR TO SECOND | 0時間0分0秒間 |
 | BLOB(n) | 長さ0バイトのデータ |
 | TIMESTAMP | 0001-01-01△00:00:00 | *注1
 | BINARY(n) | 長さ0バイトのデータ |
 | CLOB(n) | 長さ0バイトのデータ |

注１）△は半角スペースを表します。

●ＧＥＴＦＩＬＥコマンドで値を入力する場合

  どのような条件においても下記に示す値を使用します。

データ型の定義 |  | 既定値 |
非ナル値制約がない場合 |  | NULL |
非ナル値制約付き |  |  |
 | INTEGER | 0 |
 | SMALLINT | 0 |
 | DECIMAL | 0 |
 | FLOAT | 0 |
 | SMALLFLT | 0 |
 | CHARACTER(n) | nバイトの空白 |
 | VARCHAR(n) | 1バイトの空白 |
 | NCHAR(n) | n文字の空白 |
 | NVARCHAR(n) | 1文字の空白 |
 | MCHAR(n) | nバイトの空白 |
 | MVARCHAR(n) | 1バイトの空白 |
 | DATE | 0001-01-01 |
 | TIME | 00:00:00 |
 | INTERVAL YEAR TO DAY | 0ヶ年0ヶ月0ヶ日間 |
 | INTERVAL HOUR TO SECOND | 0時間0分0秒間 |
 | BLOB(n) | 長さ0バイトのデータ |
 | TIMESTAMP | 0001-01-01△00:00:00 | *注1
 | BINARY(n) | 長さ0バイトのデータ |
 | CLOB(n) | 長さ0バイトのデータ |

注１）△は半角スペースを表します。


ＸＤＭ／ＲＤ接続

  XDM/RD E2に接続する場合に使用できる、XDM/RD E2のデータ型とSQLの記述形式については、マニュアル「ＨｉＲＤＢ XDM/RD E2接続機能」の「6.1 基本項目」を参照してください。

●データ型に対する注意事項

＜INTERVAL YEAR TO SECOND型またはBOOLEAN型＞

・このデータ型の列を検索することはできません。

・？パラメタを使用することができません。

＜CHAR型またはMCHAR型＞

・？パラメタに２バイト文字を含むデータを入れると、XDM/RD E2 が文字コード変換してデータ長が延びた結果、SQLがエラーになることがあります。

  その場合SET PADDING CHARコマンドにNONEを指定してください。

＜TIME型またはINTERVAL HOUR TO SECOND型＞

  少数秒精度を表現できる型のときは、下記に示す制限があります。

・ このデータ型の列を検索することはできません。

・ ？パラメタを使用することができません。

●pdsqlコマンドに対する注意事項

  pdsqlコマンドの一覧は「pdsqlコマンド一覧」を参照してください。

＜使用できないコマンド＞

・「：（サーバコマンド実行）」コマンドは使用できません。

＜ディクショナリ検索系コマンド＞

・ディクショナリ検索系のコマンドを使用するには「HiRDB互換ディクショナリビュー」の定義が必要になります。

  「HiRDB互換ディクショナリビュー」については、マニュアル「XDM E2系　XDM/RD E2　使用の手引－運用編－」を参照してください。

  ディクショナリ検索系コマンドとは以下のコマンドです。

    ・COLUMNS

・CONSTRAINTS(*1)

    ・DESCRIPTORS

    ・FILES

    ・INDEXCLM

    ・INDEXES

    ・LOBS

    ・PRPARAMS

    ・RDAREAINF(*1)

    ・RDAREAS

    ・ROUTINES

・SERVERS

・SOURCE

    ・TABLEINF

    ・TABLES(*1)

・TRIGGERS(*1)

    ・TYPES(*1)

    ・USERS

*1：９文字以上のスキーマ名を使用する場合、コマンドを実行した結果において、

スキーマ名を含む文字列が列の幅を超える部分は、表示されません。

●実行できるSQL及びSQL文の終了指定

＜実行できるSQL＞

  XDM/RD E2接続で実行できるSQLを下記に示します。

  SQLの文法についてはマニュアル「XDM E2系　XDM/RD E2　SQLリファレンス」を参照してください。

[定義系SQL]

実行できるSQL |  | 内容
スキーマの定義 | CREATE SCHEMA | スキーマを定義します。
 | DROP SCHEMA | スキーマを削除します。
表の定義 | CREATE TABLE | 表を定義します。
 | DROP TABLE | 表を削除します。
表定義の変更 | ALTER TABLE | 表定義を変更します。
ビューの定義 | CREATE VIEW | ビュー表を定義します。
 | DROP VIEW | ビュー表を削除します。
インデクスの定義 | CREATE INDEX | インデクスを定義します。
 | DROP INDEX | インデクスを削除します。
手続きの定義 | CREATE PROCEDURE(*1)(*8) | 手続きを定義します。
 | DROP PROCEDURE | 手続きを削除します。
手続きの変更 | ALTER PROCEDURE | 手続きを変更します。
別名の定義 | CREATE ALIAS | 別名を定義します。
 | DROP ALIAS | 別名を削除します。
関数の変更 | ALTER FUNCTION | 関数を変更します。
関数の定義 | CREATE FUNCTION(*2)(*8) | 関数を定義します。
 | DROP FUNCTION | 関数を削除します。
型の定義 | CREATE TYPE(*3)(*8) | 型を定義します。
ユーザ定義型の削除 | DROP TYPE | 抽象データ型、個別型、名前付き行型を削除します。
トリガの再作成 | ALTER TRIGGER | トリガのSQLオブジェクトを再作成します。
トリガの定義 | CREATE TRIGGER(*4)(*8) | トリガを定義します。
トリガの削除 | DROP TRRIGER | トリガを削除します。
シーケンス生成子定義の変更 | ALTER SEQUENCE | シーケンス生成子の定義を変更します。
シーケンス生成子定義 | CREATE SEQUENCE | シーケンス生成子を定義します。
 | DROP SEQUENCE | シーケンス生成子を削除します。
RDノード対応定義の定義 | CREATE NONLOCAL TABLE | RDノードと表の対応を定義します。
 | DROP NONLOCAL TABLE | RDノードと表の対応定義を削除します。
ロール定義 | CREATE ROLE | ロールを定義します。
 | DROP ROLE | ロールを削除します。
ユーザ属性の変更 | ALTER USER | ユーザ属性を変更します。
権限の定義 サブシステム権限 | GRANT DBA | DBA権限を与えます。
 | REVOKE DBA | DBA権限を取り消します。
 | GRANT CONNECT | CONNECT権限を与えます。
 | REVOKE CONNECT | CONNECT権限を取り消します。
権限の定義 スキーマ定義権限 | GRANT SCHEMA | スキーマ定義権限を与えます。
 | REVOKE SCHEMA | スキーマ定義権限を取り消します。
権限の定義 アクセス権限 | GRANT アクセス権限 | アクセス権限を与えます。
 | REVOKE アクセス権限 | アクセス権限を取り消します。
権限の定義 RDエリア利用権限 | GRANT RDAREA | RDエリア利用権限を与えます。
 | REVOKE RDAREA | RDエリア利用権限を取り消します。
権限の定義 ユーザ定義型権限 | GRANT ユーザ定義型権限 | ユーザ定義型権限を与えます。
 | REVOKE ユーザ定義型権限 | ユーザ定義型権限を取り消します。
権限の定義 シーケンス生成子権限 | GRANT シーケンス生成子権限 | シーケンス生成子権限を与えます。
 | REVOKE シーケンス生成子権限 | シーケンス生成子権限を取り消します。
権限の定義 ロール利用権限 | GRANT ロール利用権限 | ロール利用権限を与えます。
 | REVOKE ロール利用権限 | ロール利用権限を取り消します。
注釈の付加 | COMMENT | 表及び列に注釈を付けます。

[操作系SQL]

実行できるSQL |  | 内容
行の削除 | DELETE | 行を削除します。
行の挿入 | INSERT | 行を挿入します。
全行の削除 | PURGE TABLE | 全行を削除します。
検索 | SELECT(*6) | 表のデータを検索します。
行の更新 | UPDATE | 表のデータを更新します。

[制御系]

実行できるSQL |  | 内容
トランザクションの終了 | COMMIT | トランザクションを終了させます。
表の排他制御 | LOCK | 表に排他制御をします。
トランザクションの取り消し | ROLLBACK | トランザクションを取り消します。

[SQL制御文]

実行できるSQL |  | 内容
手続きの呼び出し | CALL(*5) | 手続きを呼び出します。

*1： CREATE PROCEDUREを指定する場合は１行の最後に END_PROC を付加します。

(例)

CREATE PROCEDURE P1()

BEGIN

INSERT INTO T1 (C1) VALUES(10) ;

UPDATE T1 SET C1 = 0 WHERE C1 < 10 ;

END

END_PROC;

*2：CREATE FUNCTIONを指定する場合は１行の最後に END_FUNC を付加します。

(例)

CREATE FUNCTION FUNC1( NUM1 INTEGER,NUM2 INTEGER )

RETURNS INTEGER

BEGIN

DECLARE SUM1 INTEGER;

SET SUM1 = NUM1 + NUM2;

RETURN SUM1;

END

END_FUNC;

*3：CREATE TYPEを指定する場合は１行の最後に END_TYPE を付加します。

(例)

CREATE TYPE TEL( NAME VARCHAR(15),TEL_NO INTEGER )

END_TYPE;

*4：CREATE TRIGGERを指定する場合は１行の最後にEND_TRIGを付加します。

(例)

CREATE TRIGGER TRIG1

AFTER INSERT ON T0

FOR EACH ROW

INSERT INTO T1 VALUSE(10, “ABC”)

END_TRIG;

*5：CALL文で呼び出す手続きの引数が入力パラメタの場合、値式または“？”を指定できます。

  手続きの引数が出力パラメタまたは入出力パラメタの場合、手続きの引数に“？”を指定してください。

  CALL文を入力後、入力パラメタまたは入出力パラメタに対し「？パラメタ入力ダイアログ」が表示されるので対応した値を指定してください。

  「？パラメタ入力ダイアログ」での入力を行った後、CALL文が実行され正常終了した際に、出力パラメタまたは入出力パラメタの結果を表示します。

(例)

  手続き：

    CREATE PROCEDURE BOUNUS_CNTS(IN VAL INTEGER,OUT POINT INTEGER)

      BEGIN

        SET POINT = VAL + 100;

      END

    END_PROC;

  CALL文の実行例：

    call BOUNUS_CNTS(?,?);

     DATA ( 1) ? : INTEGER : VALUE(NULL)

    ----+----1----+----2----+----3----+----4----+----5----+----6----+----7----+

    5000;

     POINT

    ------------

     5100

*6：指定できるのは動的SELECTのみです。 また、カーソル指定はできません。

＜SQL文の終了指定＞

  １行の最後に セミコロン ( ; ) があれば、そこまでをSQL文とみなして処理します。セミコロンがない場合は、その行は次の行に継続しているものとして扱われます。

(例)

CREATE TABLE T1(C1 INT, (継続)

C2 CHAR(10), (継続)

C3 CHAR(10))； (SQL文の終了)

・１行の長さは、６５５３０文字以内である必要があります。


SJIS版とUnicode版の違い

●前提条件

  SJIS版のHiRDB SQL Executerプログラムは、HiRDBクライアントと受け渡しする文字データの文字セットがシフトＪＩＳコードの場合にだけ使用できます。

  Unicode版のHiRDB SQL Executerプログラムは、HiRDBクライアントと受け渡しする文字データの文字セットがUnicode(UCS2)の場合にだけ使用できます。

  HiRDBクライアントと受け渡しする文字データの文字コードはHiRDBサーバの文字コードと環境変数PDCLTCNVMODE の値で決まります。

  詳細はHiRDBのマニュアル「ＵＡＰ開発ガイド」またはHiRDBの取扱説明書「ＨｉＲＤＢクライアントでのＵＣＳ２サポート」を参照してください。

●使用できる文字セット

  シフトJISまたはUCS2の各符号化方法でＯＳがサポートしている文字セットが使用できます。

  SJIS版は符号化方法としてシフトJISを使用するので、Windows Codepage 932の文字セット(※)が使用できます。ＯＳに外字を登録すれば外字も使用できます。

  Unicode版では符号化方法としてUCS2を使用するので、SJIS版より広範囲の文字を扱えます。ただし、Windowsのコマンドプロンプトが日本語を表示する方法としてWindows Codepage 932しかサポートしていないので、ラインモード版では、Windows Codepage 932の文字セットに含まれない文字は表示できません。GUI版ではＯＳがサポートしているUnicode文字を全て表示できます。

※：Windows Codepage 932の文字セットは「JIS X 0201:1997 (ラテン文字・片仮名)

+ JIS X 0208:1997 + NEC特殊文字(13区) + NEC選定IBM拡張文字(89～92区) +

IBM拡張文字(115～119区)」です。

●入力テキストファイルについて

  ここでは、次のファイルを入力テキストファイルと呼びます。

  ・GUI版の[ファイルから実行]メニューで指定するファイル

  ・ラインモード版のpdsqlコマンド「＜」に指定するファイル

  ・ラインモード版で標準入力をリダイレクトするファイル

  ・ラインモード版のGETFILEコマンドで指定するファイル

  ・ラインモード版で、？パラメタで文字列型に対して「FILE ファイル名」で指定するファイル

  SJIS版では入力テキストファイルはシフトJIS形式にする必要があります。

  Unicode版では入力テキストファイルはUCS2形式にする必要があります。バイトオーダはリトルエンディアンにする必要があります。ファイルの先頭に付加できるBOM(Byte Order Mark)は 0xFFFE です。BOMは付いていてもいなくてもかまいません。ビッグエンディアンのBOM(0xFEFF)が付いているとエラーになります。

●出力テキストファイルについて

  ここでは、次のファイルを出力テキストファイルと呼びます。

  ・ラインモード版のpdsqlコマンド「＞」に指定するファイル

    (GUI版には「＞」コマンドがありません)

  ・GUI版とラインモード版のPUTFILEコマンドのFIX形式、DAT形式の出力ファイル

  SJIS版では出力テキストファイルはシフトJIS形式になります。

  Unicode版では出力テキストファイルはUCS2形式になります。バイトオーダはリトルエンディアンです。ファイルの先頭にBOM(Byte Order Mark＝0xFFFE)が付きます。

●注意事項

  ・Unicode版プログラムはWindows Meでは使用できません。

  ・Unicode版のラインモード版プログラムで、コマンドプロンプトへの表示内容をファイルにリダイレクトした場合、ファイルの形式はシフトJISになります。UCS2にはなりません。

  ・SQL文中以外（pdsqlコマンド等）に指定する文字列定数（シングルコーテーションで囲んだ文字列）は、SJIS版プログラムの場合文字コードがSJISで32,000バイト、Unicode版プログラムの場合文字コードがUnicode(UTF-8)で32,000バイトとなります。そのためUnicode版プログラムの場合、文字コードがUnicode(UCS2)で32,000バイト以内であってもエラーとなる場合があります。


SQL予約語削除機能による影響

  pdsqlコマンドおよびSQL Executerが提供する機能の中には、HiRDBサーバのＳＱＬ予約語削除機能にて削除可能な予約語を使用したＳＱＬ文を発行しているものが存在します。

  予約語を削除すると文法エラー等が発生し、使用できなくなるコマンド/機能を以下に示します。

  予約語削除により使用できなくなるコマンド/機能

予約語 | 使用できなくなるコマンド／機能
CASE | TABLEINF , TRIGGERS
ELSE | TABLEINF , TRIGGERS
END | TABLEINF , TRIGGERS
FREE | (SET SPLIT SIZEによる長大データの分割取得)
NOWAIT | COLUMNS , CONSTRAINTS , DESCRIPTORS , FILES , INDEXCLM , INDEXES , LOBS , PRPARAMS , RDAREAINF , RDAREAS , ROUTINES , SERVERS , SOURCE , TABLEINF , TABLES , TRIGGERS , TYPES , USERS
SUBSTR | COLUMNS , CONSTRAINTS , DESCRIPTORS , INDEXCLM , LOBS , PRPARAMS , ROUTINES , SERVERS , TABLEINF , TABLES , TRIGGERS , TYPES
THEN | TABLEINF , TRIGGERS
VALUE | COLUMNS , INDEXCLM , INDEXES , TABLEINF , USERS
WHEN | TABLEINF , TRIGGERS


BLOCK/ITERATE

[機能]

  BLOCK / ITERATEの間に指定したＳＱＬ又はpdsqlコマンドを繰り返し実行します。

[形式１]：単純な繰り返し

  BLOCK

  ＳＱＬ又はpdsqlコマンド

  ITERATE [繰り返し回数]

オペランド

● 繰り返し回数 ～＜符号なし整数＞（1～2147483647）<<1>>

  指定したＳＱＬ又はpdsqlコマンドを実行する回数を指定します。

[形式２]：変数を使用した繰り返し

  BLOCK 変数名 = 初期値 TO 終値 [ BY 増分値 ] [ LENGTH 長さ ] [ HEX ]

  ＳＱＬ又はpdsqlコマンド

  ITERATE

オペランド

● 変数名 ～＜識別子＞（1～8文字）

  ＳＱＬ又はpdsqlコマンド中で変数として使用する名称を指定します。変数は初期値から終値まで値が変化します。

名称規則：

・１バイトコード英文字で始まっていること

・１バイトコード英数字で構成されていること

・長さは８バイトまでであること

・大文字と小文字を区別していること

・予約語と異なること

● 初期値 ～＜符号なし整数＞（-2147483648～2147483647）

  変数の初期値を指定します。

● 終値 ～＜符号なし整数＞（-2147483648～2147483647）

  変数の終値を指定します。

● 増分値 ～＜符号なし整数＞

  初期値＜終値の場合（1～2147483647） <<1>>

  初期値＞終値の場合（-2147483648～-1）<<-1>>

  変数の増分値を指定します。

● 長さ ～＜符号なし整数＞（1～255）<<けた数>>

  変数の置き換え時に変数の桁数を変換する場合に指定します。

  （例）LENGTH 3 と指定すると、1->001、2->002として置き換えます。

● HEX <<１０進数表記>>

  変数の置き換え時に変数を１６進で表記する場合に指定します。

  （例）11->A、20->14として置き換えます。

[規則]

(1) ＳＱＬ又はpdsqlコマンドは最大５０文まで指定できます。

(2) 変数名と同じ文字列がＳＱＬ又はpdsqlコマンド中に存在する場合、その文字列は変数の値に置き換えられます。

(3) BLOCK文のﾈｽﾄ指定(BLOCK/ITERATE中に再度BLOCK文を指定すること)は、できません。

(4) BLOCK文を取り消したい場合はSQLおよびpdsqlコマンドの替わりにQUITを入力してください。

[留意事項]

(1) 指定したＳＱＬ又はpdsqlコマンドを実行する回数は、終値 - 初期値 + 1回になります。

(2) 空白や記号などで区切られた語句の中に変数名名称が含まれている場合も、置き換えられますので、変数名名称は十分に注意してください（使用例(2)を参照）。

[使用例]

(1)INSERT文で１～５０までのデータを入れます。

    BLOCK X=1 TO 50;

    INSERT INTO T1 (C1) VALUES(X);

    ITERATE;

  下記の実行結果と同等になります。

    INSERT INTO T1 (C1) VALUES(1)

    INSERT INTO T1 (C1) VALUES(2)

        ..

    INSERT INTO T1 (C1) VALUES(50)

(2)テーブルT001DATAからT005DATAを削除します。

   BLOCK AX=1 TO 5 LENGTH 3;

   DROP TABLE TAXDATA;

   ITERATE;

下記の実行結果と同等になります。

   DROP TABLE T001DATA;

   DROP TABLE T002DATA;

   ..

   DROP TABLE T005DATA;


CHANGE

[機能]

  直前に実行したＳＱＬ中の文字列を変更し、実行します。

[形式]

  CHANGE 文字列１ 文字列２ [ { HOLD | NOHOLD } ][ { DISPLAY | NODISPLAY } ]

オペランド

● 文字列１ ～＜文字列＞（1～255文字）

  変更前の文字列を指定します。

● 文字列２ ～＜文字列＞（1～255文字）

  変更後の文字列を指定します。

● HOLD | NOHOLD

  HOLD 文字列の変更後、ＳＱＬを実行しません。

  NOHOLD 文字列の変更後、ＳＱＬを実行します。

● DISPLAY | NODISPLAY

  DISPLAY 変更前後のＳＱＬを表示します。

  NODISPLAY 変更前後のＳＱＬを表示しません。

[留意事項]

(1) 変更後のＳＱＬの長さが２Ｍバイトを超えることはできません。

(2) 文字列１・文字列２は、アポストロフィ（’）で囲んでください。また、アポストロフィを文字として指定する場合は、アポストロフィを２つ続けて指定します。

    (例） 文字列が A'BC の場合は 'A''BC' と指定します。

(3) 大文字と小文字は区別されます。

[使用例]

表(T1)検索後、表(T2)を検索します。

  SELECT * FROM USER1.T1;

実行結果が表示される

  CHANGE 'T1' 'T2';

以下のＳＱＬが実行されます。

  SELECT * FROM USER1.T2;


COLUMNS

[機能]

  指定表の列一覧を表示します。

[形式]

  COLUMNS [[ ＲＤノード名[.] ] 認可識別子[.] ] 表識別子

オペランド

● ＲＤノード名 ～＜ＲＤノード名＞（1～30文字）

  リモートデータベースアクセスをする場合、ＲＤノード名を指定します。

  ＲＤノード名はリモートデータベースがＨｉＲＤＢの場合のみ指定できます。

  ＲＤノード名を省略した場合、ローカルアクセスになります。

● 認可識別子 ～＜認可識別子＞（1～8文字）

  表を所有しているユーザの認可識別子を指定します。

  認可識別子を省略した場合、ＣＯＮＮＥＣＴ時の認可識別子が仮定されます。

● 表識別子 ～＜表識別子＞（1～30文字）

  列の情報を表示する表識別子を指定します。

[使用例]

  表(ZAIKO)の列一覧を表示します。

    COLUMNS ZAIKO;

[留意事項]

(1) 繰返し列数は、HiRDB Version 5.0 05-03以降でのみ表示されます。

[出力形式]

COLUMN_ID COLUMN_NAME DATA_TYPE

--------- ------------------------------ ------------------------

aaaaa bb....bb cc....cc

～ DATA_LENGTH MAX_ELM

～ ----------- -------

dd....dd ee...ee

aaaaa : 列ＩＤ

bb....bb : 列名

cc....cc : データ型

データ型が抽象データ型の場合は、データ型識別子を表示します。

dd....dd : データ長

データ型が抽象データ型の場合は、表示されません。

ee...ee : 繰返し列数


注釈

[機能]

  行を注釈行にします。

[形式]

  /* 注釈 [ */ ]

[留意事項]

・

本コマンドは、１行すべてに対して注釈にする場合を対象としています。


CONNECT

[機能]

  HiRDBに接続します。

[形式]

  CONNECT [ 認可識別子[/パスワード] [ホスト名/ポート番号] ]

オペランド

● 認可識別子 ～＜認可識別子＞（1～8文字）

  HiRDBに接続する認可識別子を指定します。

● パスワード ～＜パスワード＞（1～30文字）

  認可識別子に対するパスワードを指定します。

● ホスト名 ～＜ホスト名＞（1～255文字）

  接続するHiRDBシステムのホスト名を指定します。

● ポート番号 ～＜符号なし整数＞（1～2147483647）

  接続するHiRDBシステムのポート番号を指定します。

[留意事項]

(1) オペランドを省略した場合、CONNECTコマンド投入後、認可識別子およびパスワードを入力する必要があります。

  入力する認可識別子およびパスワードは大文字に変換されます。

  小文字を使用する場合は、引用符（”）で囲んでください。

(2) CONNECT後に別の認可識別子でHiRDBに接続するには、一旦DISCONNECTコマンドでHiRDBから切り離した後、CONNECTコマンドを指定してください。

(3) パスワードを省略した場合、パスワード無しとしてHiRDBに接続します。

[参照]

DISCONNECT


CONSTRAINTS

[機能]

  指定した認可識別子が定義している制約名の一覧を表示します。

[形式]

  CONSTRAINTS [ { 認可識別子 | ALL } ]

オペランド

● 認可識別子 ～＜認可識別子＞（1～8文字）

制約名を定義しているユーザの認可識別子を指定します。

認可識別子を省略した場合、ＣＯＮＮＥＣＴ時の認可識別子が仮定されます。

● ALL

定義してある全てを表示します。

[出力形式]

CONSTRAINT_NAME TABLE_NAME TYPE

---------------------------------------- ------------------------------ ----

aa....aa bb....bb c

aa....aa : 制約名

bb....bb : 制約を定義している表の表名

c : 制約の種類


DESCRIPTORS

[機能]

  抽象データ型の属性を表示します。

[形式]

  DESCRIPTORS [[ ＲＤノード名[.] ] 認可識別子[.] ] 抽象データ型識別子

  または、DESCS

オペランド

● ＲＤノード名 ～＜ＲＤノード名＞（1～30文字）

  リモートデータベースアクセスをする場合、ＲＤノード名を指定します。

  ＲＤノード名はリモートデータベースがＨｉＲＤＢの場合のみ指定できます。

  ＲＤノード名を省略した場合、ローカルアクセスになります。

● 認可識別子 ～＜認可識別子＞（1～8文字）

  抽象データ型を所有しているユーザの認可識別子を指定します。

  認可識別子を省略した場合、ＣＯＮＮＥＣＴ時の認可識別子が仮定されます。

● 抽象データ型識別子 ～＜抽象データ型識別子＞（1～30文字）

属性の情報を表示する抽象データ型識別子を指定します。

[留意事項]

(1) 本コマンドは、HiRDB Version 5.0以降で使用できます。

[出力形式]

POSITION OBJECT_NAME DATA_TYPE

-------- ------------------------------ ------------------------

aaaaa bb....bb cc....cc

～ DATA_LENGTH

～ -----------

dd....dd

aaaaa : 属性ＩＤ

bb....bb : 属性名

cc....cc : データ型

データ型が抽象データ型の場合は、データ型識別子を表示します。

dd....dd : データ長

データ型が抽象データ型の場合は、表示されません。


DISCONNECT

[機能]

  COMMIT発行後、HiRDBから切り離します。

[形式]

  DISCONNECT

[留意事項]

(1) DISCONNECTコマンドは、HiRDBから切り離しますが、本プログラムは終了しません。

  再度、HiRDBと接続するためにはCONNECTコマンドを、本プログラムを終了するには[ファイル]メニューから[終了]を選択してください。

(2) DISCONNECTコマンドは、HiRDBから切り離す前にCOMMITを発行します。

  そのため、トランザクションを無効にする場合、事前にROLLBACKを発行しておく必要があります。

[参照]

CONNECT


EXIT

[機能]

  COMMIT & DISCONNECTを発行後、本プログラムを終了します。

[形式]

  EXIT

[留意事項]

(1) 本プログラムの終了前に、COMMIT & DISCONNECTを発行します。そのため、トランザクションを無効にする場合、事前にROLLBACKを発行しておく必要があります。

(2) HiRDBに接続していない状態でEXITを投入した場合、本プログラムの終了だけを行います。

[参照]

  DISCONNECT


< ( ファイルからのＳＱＬ、pdsqlコマンド入力 )

[機能]

  ファイルからＳＱＬ、pdsqlコマンドを読み込んで実行します。

[形式]

  < ファイル名

  <<

オペランド

● ファイル名 ～＜ファイル名＞

  実行するＳＱＬ、pdsqlコマンドを格納しているファイルのファイル名を指定します。

[規則]

(1) 指定したファイル中にEXITコマンドがあると、そこで入力を中断します。

  中断した続きから読み込んで実行する場合は、<< を入力してください。

(2) 読み込むファイル中に"<"コマンドを指定することはできません。

[参照]

  >


> ( 入力ＳＱＬ、pdsqlコマンドのファイル出力 )

[機能]

  入力したＳＱＬ、pdsqlコマンドをファイルに出力します。

[形式]

  > ファイル名

オペランド

● ファイル名 ～＜ファイル名＞

  入力したＳＱＬ、pdsqlコマンドを出力するファイル名を指定します。

[規則]

(1) ＳＱＬ、pdsqlコマンドの出力を終了するには再び > を入力してください。

[留意事項]

(1) コマンドの格納の終了のために最後に入力した > もファイルに格納されているので、コマンドを保存したファイルを入力に使用する場合は、> を削除してから使用してください。

(2) 読み込むファイル中に"<"コマンドを指定することはできません。

[参照]

  <


FILES

[機能]

  ＲＤエリアの構成ファイル一覧を表示します。

[形式]

  FILES [[ ＲＤノード名[.] ] { ＲＤエリア名 | ALL } ]

オペランド

● ＲＤノード名 ～＜ＲＤノード名＞（1～30文字）

  リモートデータベースアクセスをする場合、ＲＤノード名を指定します。

  ＲＤノード名はリモートデータベースがＨｉＲＤＢの場合のみ指定できます。

  ＲＤノード名を省略した場合、ローカルアクセスになります。

● ＲＤエリア名 ～＜識別子＞（1～30文字）

  構成ファイルを表示するＲＤエリア名を指定します。

● ALL

  定義してある全てを表示します。

[使用例]

  ＲＤエリア(PDBUSER01)の構成ファイル一覧を表示します。

      FILES PDBUSER01;

[出力形式]

RDAREA_ID RDAREA_NAME SERVER PHYSICAL_FILE_ID

--------- ------------------------------ -------- ----------------

aaaaa bb....bb cccccccc ddddd

～ PHYSICAL_FILE_NAME INITIAL_SIZE

～ ------------------ ------------

ee....ee fffff

aaaaa : ＲＤエリアＩＤ

bb....bb : ＲＤエリア名

cccccccc : サーバ名

ddddd : ファイルＩＤ

ee....ee : ファイル名

fffff : 初期割当てセグメント数


GETFILE

[機能]

  SQL文に指定した？パラメタのデータをファイルから入力します。

[形式]

GETFILE [COMMIT コミット間隔]

  FROM ファイル名 SQL文

オペランド

●COMMIT コミット間隔 ～＜符号なし整数＞（0～2147483647）

COMMITを発行する間隔を数値で指定します。

0以外を指定した場合、ファイルの終端に達したときは

AUTO COMMITモードに関わらずに、COMMITを発行します。

0を指定した場合、ファイルの終端になるまでCOMMITは発行しません。

また、ファイルの終端に達したときCOMMITを発行するかは

AUTO COMMITモードに依存します。

省略した場合は、0を仮定します。

●ファイル名 ～＜ファイル名＞

  ？パラメタのデータを格納したファイル名を指定します。

●ＳＱＬ文

・次のＳＱＬ文が指定できます。

・INSERT文

・DELETE文

・UPDATE文

・ファイルからデータを入力する列については、？パラメタを指定してください。

・？パラメタの詳細内容については「？パラメタ入力」を参照してください。

・ＳＱＬ文の文法についてはマニュアル「ＨｉＲＤＢ ＳＱＬリファレンス」を参照してください。

[留意事項]

・？パラメタの数とファイル上の列数が一致しない場合はエラーとなり、次の行の処理に移ります。

・SQL Executer 08-00以降では2GB超のラージファイルをサポートしています。これにより入力ファイルが2GBを超える場合でもファイルからの入力が可能です。

・GETFILEコマンドは、環境変数 PDSQLBLOBLIMIT、PDSQLBINARYLIMIT、PDSQLCLOBLIMITおよび、pdsqlコマンド SET ARRAY LIMIT 、SET BINARY LIMIT、SET BLOB LIMIT、SET CLOB LIMIT、SET CHAR LIMIT、SET FETCH LIMIT、SET NCHAR LIMITで指定した長さが入力可能な最大長となります。(入力可能な最大長を超えるデータを入力した場合、メッセージ：KFPX27059-Eを出力します)

[制限事項]

・ ？パラメタに対する値の入力形式の｢FILE ファイル名｣は使用できません。｢FILE ファイル名｣の詳細内容については「？パラメタを使用したデータの入力」を参照してください。

・データ中に表示不可文字(ナル文字など ASCIIコード 0x00～0x1F)を入れないでください。

[入力形式]

・ファイル１行には、？パラメタに対応するデータを列記します(行の終わりには改行文字を付加します)。

・ 列データと列データの間は、セパレータ文字のカンマ(,)で区切ります。

・１行は最大2,097,152バイトです。

各データ型に対するデータの入力形式

データ型 列データ入力形式 ナル値

━━━━━━━　━━━━━━━━━━━━━━━━━━━━━━━　━━━━

INTEGER 及び ・数値を文字で指定します。 (*1)

SMALLINT 及び ・マイナスは、"－"符号を付けます。

DECIMAL 及び ・小数点は、整数．小数で指定します。

FLOAT 及び ・浮動小数点は、仮数部ｅ指数部で指定します。

SMALLFLT

CHARACTER 及び ・前後を二重引用符(“)で囲んである文字で指定 (*1)

VARCHAR 及び します。

NCHAR 及び ・データ中の二重引用符は二重引用符を連続して

NVARCHAR 及び 記述してください。

MCHAR 及び

MVARCHAR 及び

BINARY

DATE ・文字列"yyyy-mm-dd"の形式で指定します。 (*1)

TIME ・文字列"hh:mm:ss"の形式で指定します。 (*1)

TIMESTAMP ・文字列"yyyy-mm-dd△hh:mm:ss[.nnnnnn]"の (*1)

形式で指定します。

INTERVAL YEAR ・数値[-]yyyymmdd.の形式で指定します。 (*1)

TO DAY ・マイナスは、"－"符号を付けます。

INTERVAL HOUR ・数値[-]hhmmss.の形式で指定します。 (*1)

TO SECOND ・マイナスは、"－"符号を付けます。

BLOB 対応していません。 (*1)

*1： 文字列NULL、またはアスタリスクまたはブランクを指定することができます。

アスタリスクまたはブランクを指定した場合、｢＊｣入力規則に

従った値が格納されます。

[使用例]

CREATE TABLE T1(C1 INT, C2 CHAR(10);

GETFILE FROM \tmp\data INSERT INTO T1 VALUES(?, ?);

・「\tmp\data」の内容

1000,"AAAAAAAAAA"

2000,"BBBBBBBBBB"

3000,NULL


HELP

[機能]

  ヘルプを表示します。

[形式]

  HELP [ { pdsqlコマンド名 | pdsql } ]

  または ?

オペランド

● pdsqlコマンド名 ～＜識別子＞（1～30文字）

  pdsqlコマンドの説明を表示します。

● pdsql

  pdsqlの説明を表示します。

[留意事項]

(1) オペランドを省略した場合、コマンド一覧を表示します。


INDEXCLM

[機能]

  指定したインデクスの列一覧を表示します。

[形式]

  INDEXCLM [[ ＲＤノード名[.] ] 認可識別子[.] ] インデクス識別子

オペランド

● ＲＤノード名 ～＜ＲＤノード名＞（1～30文字）

  リモートデータベースアクセスをする場合、ＲＤノード名を指定します。

  ＲＤノード名はリモートデータベースがＨｉＲＤＢの場合のみ指定できます。

  ＲＤノード名を省略した場合、ローカルアクセスになります。

● 認可識別子 ～＜認可識別子＞（1～8文字）

  インデクスを所有しているユーザの認可識別子を指定します。

  認可識別子を省略した場合、ＣＯＮＮＥＣＴ時の認可識別子が仮定されます。

● インデクス識別子 ～＜インデクス識別子＞（1～30文字）

・列の情報を表示するインデクス識別子を指定します。

・インデクスがクラスターキーの場合、" で囲んで指定します。

      例 INDEXCLM "(CLUSTER0000131196)";

[使用例]

  インデクス(I1)の列一覧を表示します。

      INDEXCLM I1;

[留意事項]

(1) 繰返し列数は、HiRDB Version 5.0 05-03以降でのみ表示されます。

[出力形式]

INDEX_ORDER COLUMN_ID COLUMN_NAME

------------ --------- ------------------------------

aaaaa bbbbb cc....cc

～ DATA_TYPE DATA_LENGTH MAX_ELM ASC_DESC

～ ------------------------ ----------- ------- --------

dd....dd ee....ee ff...ff g

aaaaa : インデクス定義順

bbbbb : 列ＩＤ

cc....cc : 列名

dd....dd : データ型

ee....ee : データ長

ff...ff : 繰返し列数

g : ASC/DESC


INDEXES

[機能]

  指定した認可識別子が所有しているインデクス一覧を表示します。

[形式]

  INDEXES [[ ＲＤノード名[.] ] { 認可識別子 | ALL } ]

オペランド

● ＲＤノード名 ～＜ＲＤノード名＞（1～30文字）

  リモートデータベースアクセスをする場合、ＲＤノード名を指定します。

  ＲＤノード名はリモートデータベースがＨｉＲＤＢの場合のみ指定できます。

  ＲＤノード名を省略した場合、ローカルアクセスになります。

● 認可識別子 ～＜認可識別子＞（1～8文字）

  インデクスを所有しているユーザの認可識別子を指定します。

  認可識別子を省略した場合、ＣＯＮＮＥＣＴ時の認可識別子が仮定されます。

● ALL

  定義してある全てを表示します。

[使用例]

  ユーザ(認可識別子:USER1)の所有するインデクス一覧を表示します。

      INDEXES USER1;

[留意事項]

(1) 繰返し列数は、HiRDB Version 5.0 05-03以降でのみ表示されます。

[出力形式]

INDEX_ID INDEX_NAME TABLE_NAME

------------ ------------------------------ ------------------------------

aa....aa bb....bb cc....cc

～ UNIQUE_TYPE ARRAY COLUMN

～ ----------- ----- ------

d e fffff

aa....aa : インデクスＩＤ

bb....bb : インデクス名

cc....cc : 表名

d : ユニークタイプ

e : 繰返し列 (M)

fffff : インデクス構成列数


ITERATE

[機能]

  BLOCK / ITERATEの間のＳＱＬ又はpdsqlコマンドの指定を終了します。

[参照]

  詳細は BLOCKを参照してください。


LOBS

[機能]

  ＬＯＢ用に割り当てられているＲＤエリアを表示します。

[形式]

  LOBS [ ＲＤノード名 ]

オペランド

● ＲＤノード名 ～＜ＲＤノード名＞（1～30文字）

  リモートデータベースアクセスをする場合、ＲＤノード名を指定します。

  ＲＤノード名はリモートデータベースがＨｉＲＤＢの場合のみ指定できます。

  ＲＤノード名を省略した場合、ローカルアクセスになります。

[出力形式]

RDAREA_NAME COLUMN/INDEX DIV_NO DATA_LENGTH

------------------------------ ------------------------------ ------ -----------

aa....aa bb....bb ccc dd....dd

aa....aa : ＲＤエリア名

bb....bb : 列名

ccc : 分割条件指定順序

dd....dd : データ長


PRPARAMS

[機能]

  指定した手続きのパラメタ一覧を表示します。

[形式]

  PRPARAMS [[ ＲＤノード名[.] ] 認可識別子[.] ] 手続き名

オペランド

● ＲＤノード名 ～＜ＲＤノード名＞（1～30文字）

  リモートデータベースアクセスをする場合、ＲＤノード名を指定します。

  ＲＤノード名はリモートデータベースがＨｉＲＤＢの場合のみ指定できます。

  ＲＤノード名を省略した場合、ローカルアクセスになります。

● 認可識別子 ～＜認可識別子＞（1～8文字）

  手続きを所有しているユーザの認可識別子を指定します。

  認可識別子を省略した場合、ＣＯＮＮＥＣＴ時の認可識別子が仮定されます。

● 手続き名 ～＜識別子＞（1～30文字）

  パラメタの情報を表示する手続き名を指定します。

[使用例]

  手続き(P1)のパラメタ一覧を表示します。

      PRPARAMS P1;

[出力形式]

NO MODE PARAMETER_NAME DATA_TYPE DATA_LENGTH

------ ---- -------------------------- -------------------- -----------

aaaaa bbb cc....cc dd....dd ee....ee

aaaaa : パラメタ指定順序

bbb : パラメタ入出力モード

cc....cc : パラメタ名

dd....dd : データ型

ee....ee : データ長


PUTFILE

[機能]

検索した結果をファイルに出力します。
・ | ＤＡＴ形式
・ | 拡張ＤＡＴ形式
・ | バイナリ形式
・ | 固定長データ形式

[形式]

PUTFILE | [ADD][COL_NAME]
 | [{DAT | EXTDAT | BINARY | FIX | SEPARATOR_TAB | BIN_PDRORG}]
 | [QOUT_OFF] [{LF | CRLF}] [SUP]
 | [DATE_TO_CHAR] [TIME_TO_CHAR] [TIMESTAMP_TO_CHAR]
 | TO ファイル名 SELECT文

オペランド

● | ADD
 | 指定したファイルが既に存在していたとき、追加書き込みを行ないます。
 | 既存ファイルの形式チェックは行いません。
 | ファイルが既に存在し、且つ、このオペランドを指定しないとき、上書き（既存の情報を消去し、書き込み）を行います。
● | COL_NAME
 | 検索した結果をＤＡＴ形式、又は拡張ＤＡＴ形式で出力するとき、先頭行に抽出列名を出力します。
 | 出力形式にBINARY、FIX、BIN_PDRORGを指定したときにこのオペランドを指定するとエラーとなります。
● | {DAT | EXTDAT | BINARY | FIX | SEPARATOR_TAB | BIN_PDRORG} <<DAT>>
 | ・ | DAT
 |  | 検索した結果をＤＡＴ形式で出力する場合に指定します（列区切り文字はカンマです）。
 |  | この形式の出力ファイルはデータベース作成ユティリティ（pdload）でＤＡＴ形式の入力データファイルとして使用できます。
 | ・ | EXTDAT
 |  | 検索した結果を拡張ＤＡＴ形式で出力する場合に指定します（列区切り文字はカンマです）。
 |  | この形式の出力ファイルはデータベース作成ユティリティ（pdload）で拡張ＤＡＴ形式の入力データファイルとして使用できます。
 | ・ | BINARY
 |  | 検索した結果をバイナリ（FIX表対応）形式で出力する場合に指定します。
 |  | この形式の出力ファイルはデータベース作成ユティリティ（pdload）でFIX表に対するバイナリ形式の入力データファイルとして使用できます。
 | ・ | FIX
 |  | 検索した結果を固定長データ形式で出力する場合に指定します。
 |  | この形式の出力ファイルはデータベース作成ユティリティ（pdload）で固定長データ形式の入力データファイルとして使用できます。
 | ・ | SEPARATOR_TAB
 |  | 検索した結果をＤＡＴ形式（列区切り文字：タブ）で出力する場合に指定します。
 |  | この形式の出力ファイルはデータベース作成ユティリティ（pdload）でＤＡＴ形式の入力データファイルとして使用できます。
 | ・ | BIN_PDRORG
 |  | 検索した結果をバイナリ（非FIX表対応）形式で出力する場合に指定します。
 |  | この形式の出力ファイルはデータベース作成ユティリティ（pdload）で非FIX表に対するバイナリ形式の入力データファイルとして使用できますが、FIX表に対するバイナリ形式の入力データファイルとしては使用できません。
● | QUOT_OFF
 | 検索した結果をＤＡＴ形式または拡張ＤＡＴ形式で出力するとき、出力データの前後を二重引用符で囲まずに出力する場合に指定します。
 | 出力形式にBINARYおよびFIX、BIN_PDRORGを指定したときにこのオペランドを指定するとエラーとなります。
 | 対象となるのは次のデータ型です。
 | ・ | CHAR
 | ・ | VARCHAR
 | ・ | MCHAR
 | ・ | MVARCHAR
 | ・ | NCHAR
 | ・ | NVARCHAR
 | ・ | BINARY
 | 省略した場合、上記のデータ型のデータは前後を二重引用符で囲んで出力します。
● | {LF | CRLF}
 | 検索した結果をＤＡＴ形式、拡張ＤＡＴ形式、又は固定長データ形式で出力するとき、検索した行１行の終わりを表す改行コードの出力方法を指定します。
 | 指定を行わなかった場合、プラットフォームにより出力が異なります。
 | Windows、Windows IPF：<<CRLF>>
 | 上記以外：<<LF>>
 | 出力形式にBINARY、BIN_PDRORGを指定したときにこのオペランドを指定するとエラーとなります。
 | LF |  | ：0x0Aで改行コードを出力します。
 | CRLF |  | ：0x0D、0x0Aで改行コードを出力します。
● | SUP
 | 検索した結果をＤＡＴ形式、又は拡張ＤＡＴ形式でCHAR、NCHAR、MCHAR型の列データを出力するとき、列データの後方に連続する空白を出力しないときに指定します。
 | 出力形式にBINARY、FIX、BIN_PDRORGを指定したときにこのオペランドを指定するとエラーとなります。
 | 本オペランドを使用することにより、出力するデータ量の削減ができます。
 | ここでいう空白とは、データ型によって異なります。
 | CHAR型,MCHAR型 |  |  |  | ：半角空白
 | NCHAR型 |  |  |  | ：全角空白
 | 出力例：
 | データ型 |  |  | ：MCHAR(32) |  | 定義長32文字
 | 挿入データ |  |  | ：" Naka-Ku Yokohama " |  | 20文字のデータ(後方の空白3文字)
 | SUPオペランドなし |  |  | ：" Naka-Ku Yokohama " |  | 後方の空白15文字
 | SUPオペランドあり |  |  | ：" Naka-Ku Yokohama" |  | 後方の空白無し
● | [DATE_TO_CHAR] [TIME_TO_CHAR] [TIMESTAMP_TO_CHAR]
 | 検索した結果をＤＡＴ形式または拡張ＤＡＴ形式で出力するとき、出力データの前後を二重引用符で囲んで出力する場合に指定します。
 | 出力形式にBINARYおよびFIX、BIN_PDRORGを指定したときに、このオペランドを指定するとエラーとなります。
 | DATE_TO_CHAR を指定したとき対象となるのは DATE のデータ型です。
 | TIME_TO_CHAR を指定したとき対象となるのは TIME のデータ型です。
 | TIMESTAMP_TO_CHAR を指定したとき対象となるのは TIMESTAMP のデータ型です。
 | 省略した場合、上記のデータ型のデータは前後を二重引用符で囲まずに出力します。
● | ファイル名 ～＜ファイル名＞
 | 検索した結果を格納するファイル名を指定します。
 | パス名を指定した場合は指定したディレクトリ下にファイルが格納されます。
 | 指定しなかった場合はカレントディレクトリにファイルが格納されます。
● | SELECT文
 | SELECT文の文法については、マニュアル「HiRDB ＳＱＬリファレンス」を参照してください。

[留意事項]

(1) PUTFILEコマンドは、次の環境変数またはpdsqlコマンドで指定した制限を受けた結果が検索結果として出力されます。

    環境変数：

        ・PDSQLBLOBLIMIT

        ・PDSQLBINARYLIMIT

        ・PDSQLCLOBLIMIT

    pdsqlコマンド：

        ・SET ARRAY LIMIT

        ・SET BINARY LIMIT

        ・SET BLOB LIMIT

        ・SET CLOB LIMIT

        ・SET CHAR LIMIT

        ・SET FETCH LIMIT

        ・SET NCHAR LIMIT

[出力形式]

● | ＜ＤＡＴ形式＞＜拡張ＤＡＴ形式＞の場合
 | ・ | 検索した行１行に対して、１行のデータを出力します(行の終わりには改行コードを付加します)。
 | ・ | 列データと列データの間は、列区切り文字で区切ります。
 | ・ | １行は最大２，０９７，１５２バイトです。
 | ・ | ファイルに出力したデータは、pdloadの入力データとして使用できます。
 | ・ | 検索した文字データ及びBINARY型データ中に表示不可文字(ナル文字など ASCIIコード 0x00～0x1F)がある場合、出力形式によって出力が異なります。
 |  | ＤＡＴ形式 | ：表示不可文字を空白に変換して出力します。
 |  | 拡張ＤＡＴ形式 | ：表示不可文字を変換せずに出力します。
 | ・ | 検索した文字データ及びBINARY型データ中に囲み文字(二重引用符)と同じ文字がある場合、出力形式によって出力が異なります。
 |  | ＤＡＴ形式 | ：文字を変換せずに出力します。
 |  | 拡張ＤＡＴ形式 | ：文字を二重出力します。
 | ・ | QUOT_OFFオペランドを指定したときは、囲み文字が存在しないためＤＡＴ形式、拡張ＤＡＴ形式ともに文字を変換せずに出力します。
 |  | QUOT_OFFオペランドなしでの出力例：
 |  | 格納データ | ：famous "Suzuki"
 |  | ＤＡＴ形式 | ："famous "Suzuki""
 |  | 拡張ＤＡＴ形式 | ："famous ""Suzuki"""
 | ・ | 各データ型に対するデータの出力形式は次のとおりです。
 |  | 以下にあげられていないデータ型を検索結果に含む場合はエラーとなります。

データ型 | 列データ出力形式 | ナル値
INTEGER SMALLINT DECIMAL FLOAT SMALLFLT | ・数値を文字で出力します。 ・マイナスは、"－"符号を付けます。 ・小数点は、整数．小数で出力します。 ・浮動小数点は、仮数部ｅ指数部で出力します。 | *注1
CHARACTER VARCHAR NCHAR NVARCHAR MCHAR MVARCHAR BINARY | ・前後を二重引用符(“)で囲んで出力します。 ・０バイト長の場合、出力しません。 ・QUOT_OFFオペランドが指定されている場合は、前後を二重引用符で囲まずに出力します。 | 出力しない
DATE | ・文字列yyyy-mm-ddの形式で出力します。 DATE_TO_CHARオペランドが指定されている場合は 前後を二重引用符で囲んで出力します。 | *注1
INTERVAL YEAR TO DAY | ・数値[-]yyyymmdd.の形式で出力します。 ・マイナスは、"－"符号を付けます。 | *注1
TIME | ・文字列hh:mm:ssの形式で出力します。 TIME_TO_CHARオペランドが指定されている場合は 前後を二重引用符で囲んで出力します。 | *注1
INTERVAL HOUR TO SECOND | ・数値[-]hhmmss.の形式で出力します。 ・マイナスは、"－"符号を付けます。 | *注1
BLOB | ・対応していません。 ・０バイト長の場合、出力しません。 ・長さが０バイト以上の場合、ナル値で出力します。 | *注1
TIMESTAMP | ・文字列yyyy-mm-dd△hh:mm:ss[.nnnnnn]の形式で出力します。 TIMESTAMP_TO_CHARオペランドが指定されている場合は 前後を二重引用符で囲んで出力します。 ・小数点以下はデータの定義長に依存します。 | *注1注2

● | ＜バイナリ（FIX表対応）形式＞の場合
 | ・ | pdrorgコマンドでFIX表をアンロードした場合の形式です。ファイル中のデータの形式の詳細はマニュアル「コマンドリファレンス」を参照してください。
 | ・ | 本データ形式で出力したファイルをデータベース作成ユティリティpdloadでロードする場合はナル値・関数情報ファイルでナル値を下記（ナル値の出力形式）の出力値に指定してください。
 |  | その時、ナル値の出力値と同じ値の実データがあるとそのデータもナル値としてロードされるので注意してください。
 | ・ | データがナル値の場合の各データ型に対するナル値の出力形式は次のとおりです。
 |  | 以下にあげられていないデータ型を検索結果に含む場合はエラーとなります。

データ型 | ナル値の場合の出力値
INTEGER | 0
SMALLINT | 0
DECIMAL | 0
FLOAT | 0
SMALLFLT | 0
CHARACTER | 空白
VARCHAR | １バイトの空白
NCHAR | 空白
NVARCHAR | １文字の空白
MCHAR | 空白
MVARCHAR | １バイトの空白
DATE | 0001-01-01
INTERVAL YEAR TO DAY | 00000000.
TIME | 00:00:00
INTERVAL HOUR TO SECOND | 000000.
BLOB | 長さ０バイトのデータ
TIMESTAMP | 0001-01-01△00:00:00 注2
BINARY | 長さ０バイトのデータ

● | ＜バイナリ（非FIX表対応）形式＞の場合
 | ・ | pdrorgコマンドで非FIX表をアンロードした場合の形式です。
 |  | ファイル中のデータの形式の詳細はHiRDBマニュアル「コマンドリファレンス」を参照してください。
 | ・ | 本データ形式で出力したファイルをデータベース作成ユティリティpdload にて、FIX表へのデータロードは行えません。
● | ＜固定長データ形式＞の場合
 | ・ | 検索した行１行に対して、１行のデータを出力します(行の終わりには改行文字を付加します)。
 | ・ | 列データと列データの間はありません。
 | ・ | １行は最大２，０９７，１５２バイトです。
 | ・ | ファイルに出力したデータは、pdloadの入力データとして使用できます。
 | ・ | 検索した文字データ中に表示不可文字(ナル文字など ASCIIコード 0x00～0x1F)がある場合、表示不可文字をコロン（:）に変換して出力します。
 | ・ | データがナル値の場合、データ型の出力長分の空白文字(0x20)を出力します。
 | ・ | 各データ型に対するデータの出力形式は次のとおりです。
 |  | 以下にあげられていないデータ型を検索結果に含む場合はエラーとなります。

データ型 | 列データ出力形式
INTEGER SMALLINT DECIMAL FLOAT SMALLFLT | ・数値を文字で出力します。 ・マイナスは、"－"符号を付けます。 ・小数点は、整数．小数で出力します。 ・浮動小数点は、仮数部ｅ指数部で出力します。
CHARACTER VARCHAR NCHAR NVARCHAR MCHAR MVARCHAR | ・HiRDBに格納されている形式で出力します。 ・定義長より短い可変長文字列の場合は、定義長まで空白文字(0x20)を埋めます。
DATE | ・yyyy-mm-ddの形式で出力します。
INTERVAL YEAR TO DAY | ・[-]yyyymmdd.の形式で出力します。 ・マイナスは、"－"符号を付けます。
TIME | ・hh:mm:ssの形式で出力します。
INTERVAL HOUR TO SECOND | ・[-]hhmmss.の形式で出力します。 ・マイナスは、"－"符号を付けます。
BLOB | ・文字データとして、出力します。 ・定義長より短い可変長文字列の場合は、定義長まで空白文字(0x20)を埋めます。
TIMESTAMP | ・yyyy-mm-dd△hh:mm:ss[.nnnnnn]の形式で出力します。 注2
BINARY | ・文字データとして、出力します。 ・定義長より短い可変長文字列の場合は、定義長まで空白文字(0x20)を埋めます。

・

各データ型に対する出力長は、次のとおりです。

データ型 | 出力長（バイト）
INTEGER | 11
SMALLINT | 6
DECIMAL | 定義長に依存
FLOAT | 23
SMALLFLT | 23
CHARACTER | 定義長
VARCHAR | 定義長
NCHAR | 定義長*2
NVARCHAR | 定義長*2
MCHAR | 定義長
MVARCHAR | 定義長
DATE | 10
INTERVAL YEAR TO DAY | 10
TIME | 8
INTERVAL HOUR TO SECOND | 8
BLOB | 定義長に依存
TIMESTAMP | 定義長に依存
BINARY | 定義長に依存

＊注１ 環境変数 PDUAPPTFNULLにＯＮを設定した場合は、何も出力しません。

環境変数 PDUAPPTFNULLにＯＦＦを設定した場合は、*を出力します。

環境変数 PDUAPPTFNULLを設定していない場合は、*を出力します。

＊注２ △は半角スペースを表します。


RDAREAINF

[機能]

  指定したＲＤエリアの情報を表示します。

[形式]

  RDAREAINF ＲＤエリア名

オペランド

● ＲＤエリア名 ～＜識別子＞（1～30文字）

  情報を表示したいRDエリアを指定します。

[出力形式]

TYPE USER NAME USED_TABLE

-------- ---------- ------------ ----------

aaaa bbbb cccc dddd

aaaa : 格納されているデータの種類(TABLE,INDEX,BLOB)

bbbb : 作成者(認可識別子)

cccc : 名前

aaaaがTABLEのときテーブル名、

aaaaがINDEXのときインデクス名、

aaaaがBLOBのときカラム名

dddd : aaaaがINDEX、BLOBのとき、元となるテーブル名


RDAREAS

[機能]

  ＲＤエリアの一覧を表示します。

[形式]

  RDAREAS [ ＲＤノード名 ]

オペランド

● ＲＤノード名 ～＜ＲＤノード名＞（1～30文字）

  リモートデータベースアクセスをする場合、ＲＤノード名を指定します。

  ＲＤノード名はリモートデータベースがＨｉＲＤＢの場合のみ指定できます。

  ＲＤノード名を省略した場合、ローカルアクセスになります。

[出力形式]

RDAREA_ID RDAREA_NAME SERVER TYPE PAGE_SIZE

--------- ------------------------------ -------- ---- ---------

aaaa bb....bb cccccccc d eeeee

～ SEGMENT_SIZE INITIAL_SIZE FILE_COUNT N_TABLE N_INDEX

～ ------------ ------------ ---------- ------- -------

fffff ggggg hhhhh iiiii jjjjj

aaaa : ＲＤエリアＩＤ

bb....bb : ＲＤエリア名

cccccccc : サーバ名

d : ＲＤエリアタイプ

eeeee : ページ長

fffff : セグメントサイズ

ggggg : 初期割当てセグメント数

hhhhh : ファイル数

iiiii : 格納表数

jjjjj : 格納インデクス数


REPEAT

[機能]

  直前に実行したＳＱＬを再度実行します。

[形式]

  REPEAT [ 繰り返し回数 ] [ { DISPLAY | NODISPLAY } ]

オペランド

● 繰り返し回数 ～＜符号なし整数＞（1～2147483647）《1》

  直前に実行したＳＱＬを実行する回数を指定します。

● DISPLAY | NODISPLAY

  DISPLAY 再度実行するＳＱＬを表示します。

  NODISPLAY 再度実行するＳＱＬを表示しません。

[留意事項]

(1) COMMIT･ROLLBACK等の制御系ＳＱＬは、繰り返しの対象にはなりません。

(2) 直前にTABLES･COLUMNS等の一覧情報表示コマンドを実行している場合は、HiRDB SQL Executerが内部的に生成して発行したＳＱＬが繰り返しの対象になります。

[使用例]

  表(T1)に同じデータをINSERT文で１００行挿入します。

      INSERT INTO T1 (C1,C2) VALUES(1000,2000);

      REPEAT 99;


ROUTINES

[機能]

  指定した認可識別子が所有している手続きの一覧を表示します。

[形式]

  ROUTINES [[ ＲＤノード名[.] ] { 認可識別子 | ALL } ]

オペランド

● ＲＤノード名 ～＜ＲＤノード名＞（1～30文字）

  リモートデータベースアクセスをする場合、ＲＤノード名を指定します。

  ＲＤノード名はリモートデータベースがＨｉＲＤＢの場合のみ指定できます。

  ＲＤノード名を省略した場合、ローカルアクセスになります。

● 認可識別子 ～＜認可識別子＞（1～8文字）

  手続きを所有しているユーザの認可識別子を指定します。

  認可識別子を省略した場合、ＣＯＮＮＥＣＴ時の認可識別子が仮定されます。

● ALL

  定義してある全てを表示します。

[使用例]

  ユーザ(認可識別子:USER1)の所有する手続き一覧を表示します。

      ROUTINES P1;

[出力形式]

ROUTINE_NAME SPECIFIC_NAME

--------------------------------------- ------------------------------

aa...aa bb...bb

～ TYPE N_PARAM OBJECT_SIZE CREATE_TIME

～ ---- ------- ------------ --------------

c ddddd eeeee ff...ff

aa...aa : ルーチン名

bb...bb : 特定名称

c : ルーチン種別

P : 手続き

F : 関数

ddddd : パラメタの数

eeeee : 定義ソースサイズ(単位:バイト)。

外部ルーチン及びレジストリ操作用プロシジャの場合は0。

ff...ff : ルーチン作成時の時刻。

SQL手続き文の場合はSQL解析時刻，外部ルーチンの場合はルーチン

定義作成時刻。


: ( サーバコマンドの実行 )

[機能]

  ：(コロン)の後に指定したコマンドをサーバ側で実行します。

[形式]

  : コマンド

オペランド

● コマンド

  サーバ側で実行するコマンドを指定します。

[注意事項]

・ | コマンドを実行するHiRDBサーバにHiRDB Assist-Serverが必要です。
 | 詳細は、次のマニュアルを参照してください。
 |  | マニュアル「HiRDB SQLリファレンス」の「COMMAND EXECUTE文」
 |  | マニュアル「HiRDB UAP開発ガイド」
・ | 本機能は、以下のバージョンで使用できます。
 |  | HiRDB Version 6 06-00以降

[参照]

  SET CMDBUF


SERVERS

[機能]

  指定した認可識別子が所有している外部サーバの一覧を表示します。

[形式]

  SERVERS [ { 認可識別子 | ALL } ]

オペランド

● 認可識別子 ～＜認可識別子＞（1～8文字）

  外部サーバを所有しているユーザの認可識別子を指定します。

  認可識別子を省略した場合、ＣＯＮＮＥＣＴ時の認可識別子が仮定されます。

● ALL

  定義してある全てを表示します。

[出力形式]

SERVER_ID SERVER_NAME ～

------------ ------------------------------------------------------------- ～

aa....aa bb....bb ～

～ BES TYPE VERSION ～

～ -------- ------------------------------ ------------------------------ ～

～ cc....cc dd....dd ee....ee ～

～ N_TABLE MAPPING_USER_ID

～ ------------ ------------------------------

～ f gg....gg

aa....aa : 外部サーバID

bb....bb : 外部サーバ名

cc....cc : 外部サーバにアクセスするBES名称

dd....dd : サーバ種別

ee....ee : サーババージョン

f : 外部サーバに定義された表の数

gg....gg : 外部サーバ上のユーザの名称


SET ARRAY DISPLAY MODE

[機能]

  繰返し列情報の出力内容を切り替えます。

[形式]

  SET ARRAY DISPLAY MODE { DATA | NUM }

オペランド

● DATA| NUM

  DATA ： 検索結果として格納されているデータを表示します。

  NUM ： 検索結果として格納されているデータ数を表示します。

[留意事項]

(1)格納されているデータ数は、NULL値データも数として含まれます。

(2)本コマンドは、検索結果の表示形式が表形式の状態でＳＱＬ文を実行したときにのみ有効です。

  PUTFILEコマンドを実行した場合は、常に「格納されているデータ」を出力します。

(3)実際に格納されているデータ数が、SET ARRAY LIMITコマンドで指定した要素数より多い場合、SET ARRAY LIMITコマンドで指定した数が返ります。

[使用例]

    CREATE TABLE T ( ID CHAR(11), V SMALLINT ARRAY[5], C DECIMAL(10,5));

    INSERT INTO T VALUES('A19Y3946122',ARRAY[4,7,1,6,5],+100.35);

    INSERT INTO T VALUES('D25Y7788792',ARRAY[9,NULL,NULL,3,2],+120.02);

    INSERT INTO T VALUES('J03Y9750756',ARRAY[1,6,3],+99.56);

    SET ARRAY DISPLAY MODE NUM;

    SELECT ID,V,C FROM T ORDER BY ID; ...格納されているデータ数を表示。

    SET ARRAY DISPLAY MODE DATA;

    SELECT ID,V,C FROM T ORDER BY ID; ... 格納されているデータを表示。

[出力例]

  検索ＳＱＬ実行時の出力例を、使用例のテーブルで示します。

・SET ARRAY DISPLAY MODE DATA のとき

ID V[0] V[1] V[2] V[3] V[4] C

----------- -------- -------- -------- -------- -------- ------------

A19Y3946122 4 7 1 6 5 00100.35000

D25Y7788792 9 ****** ****** 3 2 00120.02000

J03Y9750756 1 6 3 ****** ****** 00099.56000

･･･

・SET ARRAY DISPLAY MODE NUM のとき

ID NUMELM(V) C

----------- --------- ------------

A33Y3946122 5 00100.35000

D25Y7788792 5 00120.02000

J03Y9750756 3 00099.56000


SET ARRAY LIMIT

[機能]

  繰返し列の最大要素数を制限します。

[形式]

  SET ARRAY LIMIT 最大要素数

オペランド

● 要素数 ～＜符号なし整数＞（{0 | 2～30000}）

  繰返し列の最大要素数を指定します。

  繰返し列の最大要素数を制限しない(列の定義時の最大要素数に従う)場合は、0を指定します。

[使用例]

  繰り返し数が５０で定義されている列を先頭から１０要素分だけ検索します。

CREATE TABLE T1(C1 INTEGER ARRAY[50]);

・・・

SET ARRAY LIMIT 10;

SELECT C1 FROM T1;


SET ARRAY NOVALUE

[機能]

  繰返し列で値の入っていない要素を表示する文字を設定します。

[形式]

  SET ARRAY NOVALUE '文字'

オペランド

● '文字 ' ～(1文字)《'＊'》

  繰返し列の要素に値が入っていない場合に表示する文字を設定します。

[留意事項]

(1) 検索結果が表形式表示になっている時、設定が有効になります。

(2) PUTFILEコマンドに対して設定は適用されません。

(3) 使用できる文字は半角の英数字及び記号です。


SET AUTO COMMIT

[機能]

  ＳＱＬの実行が正常に終了した場合、自動的にCOMMITを発行します。

[形式]

  SET AUTO COMMIT { ON | OFF }

オペランド

● ON | OFF

  ON : ＳＱＬの実行が正常に終了した場合、自動的にCOMMITを発行します。

  OFF : ＳＱＬの実行が正常に終了した場合、自動的にCOMMITを発行しません。

[留意事項]

(1) ＳＱＬの実行が正常に終了した場合に自動的にCOMMITを発行するＳＱＬの場合は、OFF を指定してもCOMMITを発行します。

[使用例]

  自動的にCOMMITを発行します。

      SET AUTO COMMIT ON;

      INSERT INTO T1 (C1,C2) VALUES(1000,2000);

  自動的にCOMMITを発行しません。

      SET AUTO COMMIT OFF;

      INSERT INTO T1 (C1,C2) VALUES(1000,2000);

      COMMIT;


SET BINARY LIMIT

[機能]

  BINARY型の受け渡し領域の長さを制限します。

[形式]

  SET BINARY LIMIT 長さ

オペランド

● 長さ ～＜符号なし整数＞（0～2147483647）

  BINARY型の長さを指定します。

  BINARY型の長さを制限しない(列の定義長に従う)場合は、0を指定します。

[留意事項]

(1)環境変数 PDSQLBINARYLIMITにて本プログラム起動時にあらかじめ制限することができます。

  STATUSコマンドにて確認できます。

[使用例]

  BINARY型の長さが2147483647バイトの列を100バイト分だけ検索します。

      CREATE TABLE T1(C1 BINARY(2147483647));

      ・・・

      SET BINARY LIMIT 100;

      SELECT C1 FROM T1;


SET BLOB LIMIT

[機能]

  BLOB型の受け渡し領域の長さを制限します。

[形式]

  SET BLOB LIMIT 長さ

オペランド

● 長さ ～＜符号なし整数＞（0～2147483647）

  BLOB型の長さを指定します。

  BLOB型の長さを制限しない(列の定義長に従う)場合は、0を指定します。

[留意事項]

(1)環境変数 PDSQLBLOBLIMITにて本プログラム起動時にあらかじめ制限することができます。STATUSコマンドにて確認できます。

[使用例]

  BLOB型の長さが2Gバイトの列を100バイト分だけ検索します。

      CREATE TABLE T1(C1 BLOB(2G);

      ・・・

      SET BLOB LIMIT 100;

      SELECT C1 FROM T1;


SET CHAR LIMIT

[機能]

  次のデータ型の受け渡し領域の長さを制限します。

・CHAR

・VARCHAR

・MCHAR

・MVARCHAR

[形式]

  SET CHAR LIMIT 長さ

オペランド

● 長さ ～＜符号なし整数＞（0～32000）

  CHAR/VARCHAR/MCHAR/MVARCHAR型の長さを指定します。

  CHAR/VARCHAR/MCHAR/MVARCHAR型の長さを制限しない(列の定義長に従う)場合は、0を指定します。

[使用例]

  CHAR型の長さが30000バイトの列を100バイト分だけ検索します。

      CREATE TABLE T1(C1 CHAR(30000));

      ・・・

      SET CHAR LIMIT 100;

      SELECT C1 FROM T1;

[留意事項]

(1) 本コマンドは、pdsqlコマンドのディクショナリ情報表示コマンドに対しても有効です。


SET CLOB LIMIT

[機能]

  CLOB型の受け渡し領域の長さを制限します。

[形式]

  SET CLOB LIMIT 長さ

オペランド

● 長さ ～＜符号なし整数＞（0～2147483647）

  CLOB型の長さを指定します。

  CLOB型の長さを制限しない(列の定義長に従う)場合は、0を指定します。

[留意事項]

(1)環境変数 PDSQLCLOBLIMITにて本プログラム起動時にあらかじめ制限することができます。

  STATUSコマンドにて確認できます。

[使用例]

  CLOB型の長さが2Gバイトの列を100バイト分だけ検索します。

      CREATE TABLE T1(C1 CLOB(2G) IN ULOB1);

      ・・・

      SET CLOB LIMIT 100;

      SELECT C1 FROM T1;


SET CMDBUF

[機能]

  サーバで実行したコマンドの結果を受け取る領域の長さを変更します。

[形式]

  SET CMDBUF 長さ

オペランド

● 長さ ～＜符号なし整数＞（1～2147483647）

  サーバで実行したコマンドの結果を受け取る領域の長さを指定します。

  初期値は、30,000バイトです。


SET CONVSPACE

[機能]

  SQL文、pdsqlコマンドの文字列中に、改行を除く制御文字コード(0x01～0x1F)が存在するときに、該当する文字コードを半角空白に変換します。

[形式]

  SET CONVSPACE { ON | OFF }

オペランド

● ON | OFF <<OFF>>

ON : | 制御文字コードを半角空白に変換します。
OFF : | 制御文字コードを変換しません。

[環境変数]

● PDSQL_CONVSPACE = ON | OFF

ON : | 制御文字コードを半角空白に変換します。
OFF : | 制御文字コードを変換しません。

  設定がない場合はOFFが仮定されます。

[留意事項]

(1)

状態はSTATUSコマンドにて確認できます。


SET DISPLAY

[機能]

  出力形式を変更します。

[形式]

  SET DISPLAY [{ ALL｜OFF }] [{ PROMPT｜NOPROMPT }]

オペランド

● { ALL｜OFF } <<ALL>>

ALL : 検索結果、メッセージを出力します。

OFF : メッセージだけを出力します。

● { PROMPT｜NOPROMPT } <<PROMPT>>

PROMPT : コマンド入力のプロンプトを表示します。

NOPROMPT : コマンド入力のプロンプトを表示しません。

[環境変数]

● PDSQL_DISPLAY = ALL | OFF

ALL : 検索結果、メッセージを出力します。

OFF : メッセージだけを出力します。

設定がない場合はALLが仮定されます。

● PDSQL_DISPLAYNOLINE = YES | NO

YES : コマンド入力のプロンプトを表示しません。

NO : コマンド入力のプロンプトを表示します。

設定がない場合はNOが仮定されます。

[留意事項]

(1) 状態はSTATUSコマンドにて確認できます。


SET DUMPMODE

[機能]

  検索結果を１６進形式と文字形式で表示します。

[形式]

  [ SET ] DUMPMODE { ON | OFF }

オペランド

● ON | OFF

ON : | 検索結果を表形式で表示(TBLMODEがON)のときは、検索結果を１６進形式で表示します。 検索結果をリスト形式で表示(TBLMODEがOFF)のときは、検索結果を１６進形式と文字形式で表示します。
OFF : | 検索結果を文字形式で表示します。

[環境変数]

● PDUAPDUMP = { ON | OFF } | { YES | NO }

ON または YES : | 検索結果を表形式で表示(TBLMODEがON)のときは、検索結果を１６進形式で表示します。 検索結果をリスト形式で表示(TBLMODEがOFF)のときは、検索結果を１６進形式と文字形式で表示します。
OFF または NO : | 検索結果を文字形式で表示します。

  設定がない場合はOFFが仮定されます。


SET ECHOBACK

[機能]

  入力されたコマンド文字列をエコー表示します。

[形式]

  SET ECHOBACK { ON | OFF }

オペランド

● ON | OFF

  ON： 入力されたコマンドをエコー表示します。

  OFF：入力されたコマンドを表示しません。


SET FETCH LIMIT

[機能]

  検索する行数を制限します。

[形式]

  SET FETCH LIMIT 検索行数

オペランド

● 検索行数 ～＜符号なし整数＞（0～2147483647）

・検索する行数を指定します。

・検索する行数を制限しない場合は、０を指定します。

[使用例]

  検索件数を１０行に制限します。

      SET FETCH LIMIT 10;

      SELECT * FROM T1 ORDER BY C1 ASC;

[留意事項]

(1) 本コマンドは、pdsqlコマンドのディクショナリ情報表示コマンドに対しても有効です。


SET NCHAR LIMIT

[機能]

  NCHAR/NVARCHAR型の受け渡し領域の長さを制限します。

[形式]

  SET NCHAR LIMIT 長さ

オペランド

● 長さ ～＜符号なし整数＞（0～16000）

  NCHAR/NVARCHAR型の長さを指定します。

  NCHAR/NVARCHAR型の長さを制限しない(列の定義長に従う)場合は、0を指定します。

[使用例]

  NCHAR型の長さが15000文字の列を100文字分だけ検索します。

      CREATE TABLE T1(C1 NCHAR(15000));

      ・・・

      SET NCHAR LIMIT 100;

      SELECT C1 FROM T1;

[留意事項]

(1) 本コマンドは、pdsqlコマンドのディクショナリ情報表示コマンドに対しても有効です。


SET NULL CHARACTER

[機能]

  検索結果の表形式表示機能でナル値を表示する文字を設定します

[形式]

  SET NULL CHAR〔ACTER〕 '文字'

オペランド

● '文字 ' ～(1文字)《'＊'》

  ナル値の場合に表示する文字を設定します。

[留意事項]

(1)検索結果が表形式表示になっている時、設定が有効になります。

(2)PUTFILEコマンドに対して設定は適用されません。

(3)使用できる文字は半角の英数字及び記号です。


SET PADDING CHAR

[機能]

  CHAR型とMCHAR型の値を入力する？パラメタに対して、HiRDB SQL Executer側で入力データの後ろに埋め文字を追加するかどうかを指定します。

[形式]

  SET PADDING CHAR { SPACE | NONE }

オペランド

● SPACE | NONE

  SPACE : 入力したデータの後ろに空白文字を埋めて、定義長と同じ長さにしたデータを？パラメタの値として使用します。

  NONE : 入力したデータと同じ長さのデータを？パラメタの値として使用します。

[留意事項]

(1) 本プログラム起動時にはSPACEオペランドを選択した状態になります。

(2) SPACEオペランドを選択した状態でXDM/RD E2 に接続している場合、固定長(CHAR型またはMCHAR型)の入力？パラメタに２バイト文字を含むデータを入れると、XDM/RD E2 が文字コード変換してデータ長が延びた結果、SQLがエラーになることがあります。

  NONEオペランドを指定した場合は、この問題を回避できます。

  なお、NCHAR型の場合は、文字コード変換してもデータ長が変わらないので、この問題は発生しません。

(3) 入力？パラメタのあるSQL文を入力すると、本プログラムがサーバ(HiRDBまたはXDM/RD E2)から入力？パラメタ情報(データ型、定義長など)を取得します。

  サーバから取得した？パラメタ情報が、？パラメタの値の入力要求メッセージの中に表示されます。

  本プログラムが作成する入力？パラメタ値のデータ型は次の通りになります。

サーバから取得した？パラメタ情報のデータ型 |  | CHAR | MCHAR
本プログラムが作成する入力？パラメタ値のデータ型 | SPACEオペランドを指定した場合 | CHAR | MCHAR
 | NONEオペランドを指定した場合 | VARCHAR | MVARCHAR


SET RESULT FILEOUT

[機能]

  実行結果を画面表示と同時にファイルにも出力します。

[形式]

  SET RESULT FILEOUT { ON [ファイル名] | OFF }

オペランド

● ON [ファイル名]

  実行結果を指定したファイルに出力します。

  ファイル名を省略した場合、前回指定したファイルが使用されます。

  プログラム起動後最初にこのコマンドを実行する時は、ファイル名が必須になります。

● OFF

  実行結果のファイル出力を停止します。

[留意事項]

(1) ラインモード版のHELPコマンドの実行結果はファイルに出力されません。

(2) 実行したSQL文・pdsqlコマンドは出力されません。出力したい場合は、SET ECHOBACKコマンドも合わせて使用してください。

(3) すでに存在するファイルを指定した場合、追加書き込みとなります。


SET SPLIT SIZE

[機能]

  BINARY/BLOB/CLOB型の分割取得するサイズを指定します。

  本コマンドを使用することにより、BINARY/BLOB/CLOB型に格納されているデータを検索する際に、メモリ不足となることを回避して検索出力することができます。

[形式]

  SET SPLIT SIZE 分割取得サイズ

オペランド

● 分割取得サイズ ～＜符号なし整数＞（0,4～2097152）<<0>>

  BINARY/BLOB/CLOB型の分割取得するサイズをキロバイト単位で指定します。

  分割取得を行わない場合は、0を指定します。

[留意事項]

(1) | 本コマンドは、接続サーバ及びクライアントがHiRDB V7 07-01以降において有効となります。
(2) | 指定値の目安としては、実データ長の分布を考慮して、分割取得回数が少なくなり、かつメモリ不足が発生しない値を指定してください。
 | 実データ長の分布が不明なとき、目安を求める例：
 |  | SELECT AVG(LENGTH(blob1)) FROM table1 WHERE int1<100;
 |  |  | ･･･ | (検索SQLと同一条件において)取得する行データに含まれる長大データ(blob1)の実データ長の平均値を取得する。
(3) | 環境変数 PDSQL_SPLITSIZEにて本プログラム起動時にあらかじめ指定することができます。
 | STATUSコマンドにて確認できます。
(4) | 本コマンドにて分割取得の指定を行った場合、HiRDBサーバとの通信および出力処理も分割されるため、分割取得回数に伴い性能が劣化します。
 | あらかじめ実データ長の最大がメモリ不足にならない程の値と判別できる場合は、SET BINARY LIMIT、SET BLOB LIMIT、SET CLOB LIMITの各コマンドにて最大データ長を設定して検索を実行してみてください。
(5) | SELECT文による検索に対応します。CALL文は対応しません。
(6) | 検索結果をリスト形式で表示に設定しているときにBINARY/BLOB/CLOB型の検索を行っても表示されません。

[使用例]

・ | 次の設定でファイル出力コマンドを実行したときにメモリ不足が発生したと想定して、メモリ不足を回避する流れの一例を示す。
 | 表定義：
 |  |  | CREATE TABLE T1(“int1” INTEGER, “blob1” BLOB(2G) IN RDLOB1) IN RDDATA1;
 | “blob1”列の実データ：
 |  |  | 最大実データ長＝700メガバイト
 |  |  | 平均実データ長＝100メガバイト
 | 実行するファイル出力コマンド：
 |  |  | PUTFILE BIN_PDRORG TO C:\TEMP\T1.DAT SELECT “int1”,”blob1” FROM T1;
 | メモリ不足回避の流れ：
 |  | 1) | 何も設定せずにコマンドを実行した場合、定義長(2G+4)のメモリが必要になる。
 |  |  | メモリ不足が発生する場合、BLOB型データの最大長に実データの最大を指定する。
 |  |  | SET BLOB LIMIT 734003200;
 |  | 2) | この結果、BLOB LIMITの長さ(700M+4)のメモリが必要になる。
 |  |  | それでもメモリ不足が発生する場合、分割取得サイズに実データの平均を指定する。
 |  |  | SET SPLIT SIZE 104857600;
 |  | 3) | この結果、SPLIT SIZEのサイズ(100M+4)のメモリが必要になる。
 |  |  | それでもメモリ不足が発生する場合は、分割取得サイズの値を半分にする。
 |  |  | SET SPLIT SIZE 52428800;
 |  | 4) | 以降、メモリ不足が再発する場合は、分割取得サイズの値を小さくしていくことで回避する。


SET TBLMODE

[機能]

  検索結果を表形式で表示するかどうかの設定をします。

[形式]

  SET TBLMODE { ON | OFF }

オペランド

● ON | OFF

  ON： 検索結果を表形式で(列を横に)表示します。

  OFF：検索結果をリスト形式で(列を縦に)表示します。

[留意事項]

・ナル値は、******** で表します。


SOURCE

[機能]

  定義ソースを表示します。

[形式]

  SOURCE { VIEW | PROCEDURE | FUNCTION | TRIGGER | ROUTINE }

          [認可識別子.] 定義ソース名称

オペランド

● { VIEW | PROCEDURE | FUNCTION | TRIGGER | ROUTINE }

  定義ソースの種別を指定します。

VIEW :ビュー表

PROCEDURE :手続き

FUNCTION :関数

TRIGGER :トリガ

ROUTINE :関数、手続き、トリガ

● 認可識別子 ～＜認可識別子＞（1～8文字）

  定義ソースを所有しているユーザの認可識別子を指定します。

  認可識別子を省略した場合、ＣＯＮＮＥＣＴ時の認可識別子が仮定されます。

● 定義ソース名称

  情報を表示する定義ソース名称を指定します。

[留意事項]

(1) XDM/RDにおいて、ディクショナリＬＯＢを使用している場合は、定義ソースが表示されません。

(2) HiRDBでは関数、手続き、トリガの定義ソースがBLOB型で格納されているため、以下の動作となります。

  SJIS版SQL Executerでは、HiRDBサーバが使用する文字コード種別がシフトJISコード以外のとき、ASCIIコード以外の文字が含まれていると文字化け表示します。

  Unicode版SQL Executerでは、HiRDBサーバが使用する文字コード種別がUnicode(UTF-8)以外のとき、ASCIIコード以外の文字が含まれていると文字化け表示します。


STATUS

[機能]

  本プログラムの動作状態を表示します。

[形式]

  { STATUS | ST } [ ALL ]

オペランド

● ALL

  SET コマンドでの設定の有無にかかわらず、全ての状態を表示します。

[出力形式]

VERSION | : | HiRDB SQL Executerのバージョン
SERVER VERSION | : | 接続しているHiRDBサーバのバージョン
CONNECT USER-ID | : | HiRDBサーバに接続している認可識別子
FETCH LIMIT | : | SET FETCH LIMIT の設定値
DUMP FORMAT OUTPUT MODE | : | SET DUMPMODE の設定値
TABLE FORMAT DISPLAY MODE | : | SET TBLMODE の設定値
ARRAY DISPLAY MODE | : | SET ARRAY DISPLAY MODE の設定値
ECHOBACK | : | SET ECHOBACK の設定値
AUTO COMMIT MODE | : | SET AUTO COMMIT の設定値
BLOB LIMIT LENGTH | : | SET BLOB LIMIT の設定値
BINARY LIMIT LENGTH | : | SET BINARY LIMIT の設定値
CLOB LIMIT LENGTH | : | SET CLOB LIMIT の設定値
CHARACTER LIMIT LENGTH | : | SET CHAR LIMIT の設定値
NCHAR LIMIT LENGTH | : | SET NCHAR LIMIT の設定値
ARRAY LIMIT | : | SET ARRAY LIMIT の設定値
SPLIT SIZE | : | SET SPLIT SIZEの設定値
SERVER COMMAND BUFFER | : | SET CMDBUF の設定値
NULL CHARACTER | : | SET NULL CHARACTER の設定値
ARRAY NOVALUE | : | SET ARRAY NOVALUE の設定値
PADDING CHAR | : | SET PADDING CHAR の設定値
RESULT FILEOUT | : | SET RESULT FILEOUT の設定値
SPLIT SIZE | : | SET SPLIT SIZE の設定値
DISPLAY MODE | : | SET DISPLAY の設定値
CONVSPACE | : | SET CONVSPACE の設定値

[留意事項]

・ALLオペランドを指定しない場合、設定値が省略値と同じ情報は表示しません。

  ただし、次の情報は無条件で表示されます。

VERSION :

SERVER VERSION :

CONNECT USER-ID :

FETCH LIMIT :

DUMP FORMAT OUTPUT MODE :

AUTO COMMIT MODE :


TABLEINF

[機能]

  指定した表の情報を表示します。

[形式]

  TABLEINF [ ＲＤノード名[.] ] [ 認可識別子 [.]] 表識別子

オペランド

● ＲＤノード名 ～＜ＲＤノード名＞（1～30文字）

  リモートデータベースアクセスをする場合、ＲＤノード名を指定します。

  ＲＤノード名はリモートデータベースがＨｉＲＤＢの場合のみ指定できます。

  ＲＤノード名を省略した場合、ローカルアクセスになります。

● 認可識別子 ～＜認可識別子＞（1～8文字）

  表を所有しているユーザの認可識別子を指定します。

  認可識別子を省略した場合、ＣＯＮＮＥＣＴ時の認可識別子が仮定されます。

● 表識別子

  情報を表示する表識別子を指定します。

[留意事項]

(1) XDM/RD 10-01にて、参照制約またはトリガが定義されている表に対し本コマンドを実行すると、HiRDBディクショナリビュー表が存在しないため、ＳＱＬ文のエラーとなり処理を中断します。

[出力形式]

Table Type : aa....aa

Table Schema : bb....bb

Table Name : cc....cc

Table ID : dddddddddd(dd....dd)

Column :

eeeee ff....ff gg....gg [hh....hh]

Divide Info : ii....ii(*9)(*11)

RDAREA Name : kk....kk(*9)

Server Name : MM....MM(*10)

Option : ll....ll(*9)(*10)

Check : LL....LL(*9)(*11)(*13)

Foreign Key : NN....NN(*9)(*11)

----------------------------------------------------------------------(*2)

Index Information

Index Type : mm....mm

Index Name : nn....nn

Index ID : oooooooooo(oo....oo)

Column :

ppppp qq....qq rrrr

RDAREA Name : ss....ss

Option : tt....tt

----------------------------------------------------------------------(*8)(*11)

Trigger Information

EEEEE

Trigger Name : FF....FF.GG....GG(HH....HH)

Action Time : II....II

Event : JJ....JJ

Action Type : KK....KK

----------------------------------------------------------------------(*3)

View Information

uuuuu vv....vv.ww....ww

----------------------------------------------------------------------(*4)(*12)

Routine Information

xxxxx yy....yy.zz....zz(AA....AA)

yy....yy.OO....OO(PP....PP)(*11)

yy....yy.QQ....QQ(RR....RR)(*11)

----------------------------------------------------------------------(*5)

Base Table Information

BBBBB CC....CC.DD....DD

aa....aa : 表識別子の種別。以下のいずれかです。

TABLE

[SHARE](*11) FIX TABLE

FOREIGN TABLE

[PUBLIC](*11) VIEW

[PUBLIC](*11) READ ONLY VIEW

bb....bb : スキーマ名(*1)

cc....cc : 表識別子の名称(*1)

dddddddddd(dd....dd) : 表ID。値を16進数（10進数）で表示します。

eeeee ～ hh....hh : 構成列情報。列の数だけ繰返し表示されます。

eeeee : 列ID

ff....ff : 列名(*1)

gg....gg : データ型。(*6)

hh....hh : 列属性情報。以下の内容を出力します。

[CHARACTER SET [文字集合所有者.]文字集合名] : 文字集合属性。(*1)(*14)

[ARRAY[繰返し列数]] : 繰返し列属性。(*11)

[NO SPLIT]：ノースプリットオプション属性。(*11)

[SUPPRESS]：列データ抑制指定属性。(*14)

[RECOVERY {ALL | PARTIAL | NO }] : 列回復制約属性。

[IN ((ＲＤエリア名)[,(ＲＤエリア名)]...)]

: LOB列格納用ＲＤエリア名。

[ALLOCATE (属性名 IN (ＲＤエリア名)

[,属性名 IN (ＲＤエリア名)]...)]

: 抽象データ型定義内LOB格納用ＲＤエリア指定属性。

{NULL | NOT NULL} : NULL/NOT NULL属性。

[WITH DEFAULT] : WITH DEFAULT 属性。

[SYSTEM GENERATED] : SYSTEM GENERATED属性。(*11)

[PLUGIN (プラグインオプション)]：プラグイン指定属性。(*11)

[DEFAULT [既定値]]：DEFAULT属性。(*11)

[UPDATE ONLY FROM NULL]：更新可能列属性。(*11)

[INNER CONSTRUCTOR OF TYPE1]：暗号化指定属性。(*14)

ii....ii : 分割情報。以下のいずれかです。(*11)

NON DIVISION

KEY RANGE

PARTITIONED BY (列名)

PARTITIONED BY MULTIDIM (マトリクス分割表情報)

[FIX] HASH (ハッシュ関数名) BY (列名)[,(列名)]...

kk....kk : 表格納先ＲＤエリア情報。

MM....MM : 外部サーバ名称。(*1)

ll....ll : 表オプション情報。

表識別子の種別が TABLE または FIX TABLE のとき、

以下の内容を出力します。

PCTFREE＝((未使用領域の比率),(セグメント内の空きページ比率)) :

使用比率情報。

{LOCK ROW｜LOCK PAGE} : 排他資源単位。

[SUPPRESS DECIMAL] : データの省略格納指定情報。

[WITHOUT ROLLBACK] : 行の排他情報。(*11)

{SEGMENT REUSE ｛〔セグメント数〔｛K｜M｜G｝〕〕｜NO}} :

空き領域の再利用情報。(*11)

[INSERT ONLY [WHILE

｛日間隔データ｜ラベル付き間隔｝ BY 列名]] :

改竄防止表属性。(*11)

表識別子の種別が FOREIGN TABLE のとき、以下の構文で出力します。

OPTIONS(SCHEMA '外部サーバ上のスキーマ名',

TABLE '外部サーバ上の表名')

LL....LL : 制約判定情報。制約判定の数だけ繰返し表示されます。

以下の構文で出力します。(*11)(*13)

CONSTRAINT 制約名 CHECK(検査制約の探索条件)

NN....NN : 参照制約情報。参照制約の数だけ繰返し表示されます。

以下の構文で出力します。(*11)

CONSTRAINT 制約名 FOREIGN KEY(外部キーを持つ表の列名)

REFERENCES 参照する表の表名称

ON DELETE ON_DELETEトリガ名称

ON UPDATE ON_UPDATEトリガ名称

mm....mm ～ tt....tt : インデクス情報。

インデクスの数だけ繰返し表示されます。

mm....mm : インデクス種別。以下のいずれかです。

[UNIQUE] INDEX

[UNIQUE] CLUSTER KEY

UNIQUE PRIMARY [CLUSTER] KEY

nn....nn : インデクス名(*1)

oooooooooo(oo....oo) : インデクスID。

値を16進数（10進数）で表示します。

ppppp ～ rrrr : 構成列情報。列の数だけ繰返し表示されます。

ppppp : 列ID

qq....qq : 列名(*1)

rrrr : 昇順/降順情報。{ASC | DESC}

ss....ss : インデクス格納先ＲＤエリア名。

tt....tt : インデクスオプション情報。以下の内容を出力します。

PCTFREE＝((未使用領域の比率)) : 使用比率情報。

EEEEE ～ KK....KK : トリガ情報(*11)

トリガの数だけ繰返し表示されます。

EEEEE : 表示通番

FF....FF : トリガが所属するスキーマ名(*1)

GG....GG : トリガ名(*1)

HH....HH : 特定名称(*7)

II....II : トリガ動作契機。｛BEFORE｜AFTER｝

JJ....JJ : トリガ契機。

｛INSERT｜DELETE｜UPDATE〔OF 列名〔，列名〕…〕｝

KK....KK : トリガ動作。

〔｛FOR EACH ROW｜FOR EACH STATEMENT｝〕

uuuuu ～ ww....ww : ビュー情報。ビューの数だけ繰返し表示されます。

uuuuu : 表示通番

vv....vv : スキーマ名(*1)

ww....ww : ビュー名(*1)

xxxxx ～ AA....AA : ルーチン情報。(*12)

ルーチンの数だけ繰返し表示されます。

xxxxx : 表示通番

yy....yy : スキーマ名(*1)

zz....zz : ルーチン名(*1)

AA....AA : 特定名称(*7)

OO....OO : トリガ名。(*1)(*11)

PP....PP : 特定名称。(*7)(*11)

QQ....QQ : 制約名(*1)(*11)

RR....RR : 特定名称(*7)(*11)

BBBBB ～ DD....DD : 参照先の表情報。

参照先の表の数だけ繰返し表示されます。

BBBBB : 表示通番

CC....CC : 表が所属するスキーマ名(*1)

DD....DD : 表名(*1)

*1：名称に英小文字が含まれる場合は、二重引用符で囲みます。

*2：コマンドで指定した表識別子を参照するインデクス情報を表示します。

*3：コマンドで指定した表識別子を参照するビュー情報を表示します。

*4：コマンドで指定した表識別子を参照するルーチン情報を表示します。

*5：コマンドで指定した表識別子が参照する表情報を表示します。

*6：定義されているデータコード値と表示する表情報を、下の表に示します。

データコード値と表示する文字列：

┌────┬────────────┬────────────────┐

│データ │表示するデータ型名称 │長さに関する注記 │

│コード値│ │ │

├────┼────────────┼────────────────┤

│96 又は│INTERVAL YEAR TO SECOND │「(精度,位取り)」で表現します。 │

│97 │ │ │

│100 又は│INTERVAL YEAR TO DAY │「(精度,位取り)」で表現します。 │

│101 │ │ │

│110 又は│INTERVAL HOUR TO SECOND │「(精度,位取り)」で表現します。 │

│111 │ │ │

│112 又は│DATE │表示しません。 │

│113 │ │ │

│120 又は│TIME │「(位取り)」で表現します。 │

│121 │ │位取りが０のときは表示しません。│

│124 又は│TIMESTAMP │「(位取り)」で表現します。 │

│125 │ │位取りが０のときは表示しません。│

│131 │抽象データ型名称 │表示しません。 │

│144 又は│BINARY │最大格納バイト数 │

│145 │ │ │

│146 又は│BLOB │最大格納バイト数 │

│147 │ │ │

│152 又は│CLOB │最大格納バイト数 │

│153 │ │ │

│160 又は│MVARCHAR │最大格納バイト数 │

│161 │ │ │

│164 又は│MCHAR │格納バイト数 │

│165 │ │ │

│176 又は│NVARCHAR │最大格納文字数 │

│177 │ │ │

│180 又は│NCHAR │格納文字数 │

│181 │ │ │

│192 又は│VARCHAR │最大格納バイト数 │

│193 │ │ │

│196 又は│CHAR │格納バイト数 │

│197 │ │ │

│224 又は│FLOAT │表示しません。 │

│225 │ │ │

│226 又は│SMALLFLT │表示しません。 │

│227 │ │ │

│228 又は│DECIMAL │「(精度,位取り)」で表現します。 │

│229 │ │ │

│240 又は│INTEGER │表示しません。 │

│241 │ │ │

│244 又は│SMALLINT │表示しません。 │

│245 │ │ │

└────┴────────────┴────────────────┘

但し、SQL Executer 02-06以前では以下に示す表示内容の制限があります。

・TIMESTAMP型は位取りが表示されません。

・抽象データ型はドット(.)表示となります。

*7：特定名称については、マニュアル「HiRDB UAP開発ガイド」を参照してください。

*8：コマンドで指定した表識別子を参照するトリガ情報を表示します。

*9：表識別子の種別が TABLE または FIX TABLE のときに表示されます。

*10：表識別子の種別が FOREIGN TABLE のときに表示されます。

*11：SQL Executer 02-06以前では出力されません。

*12：ルーチン名がトリガの特定名称であった場合、トリガ名を表示します。

  トリガ名が参照制約の特定名称であった場合、制約名を表示します。

  XDM/RD 10-01にて上記の情報が存在するとき、HiRDBディクショナリビュー表が存在しないため、出力されません。

*13：HiRDBでは定義ソースがBLOB型で格納されているため、以下の動作となります。

  SJIS版SQL Executerでは、HiRDBサーバが使用する文字コード種別がシフトJISコード以外のとき、ASCIIコード以外の文字が含まれていると文字化け表示します。

  Unicode版SQL Executerでは、HiRDBサーバが使用する文字コード種別がUnicode(UTF-8)以外のとき、ASCIIコード以外の文字が含まれていると文字化け表示します。

*14)SQL Executer 08-00以前では出力されません。


TABLES

[機能]

  指定した認可識別子が所有している表の一覧を表示します。

[形式]

  TABLES [[ ＲＤノード名[.] ] { 認可識別子 | ALL } ]

オペランド

● ＲＤノード名 ～＜ＲＤノード名＞（1～30文字）

  リモートデータベースアクセスをする場合、ＲＤノード名を指定します。

  ＲＤノード名はリモートデータベースがＨｉＲＤＢの場合のみ指定できます。

  ＲＤノード名を省略した場合、ローカルアクセスになります。

● 認可識別子 ～＜認可識別子＞（1～8文字）

  表を所有しているユーザの認可識別子を指定します。

  認可識別子を省略した場合、ＣＯＮＮＥＣＴ時の認可識別子が仮定されます。

● ALL

  定義してある全てを表示します。

[出力形式]

TABLE_SCHEMA TABLE_NAME N_COLS N_INDEX CREATE_TIME

------------ ------------------------------ ------ ------- --------------

aa....aa bb....bb ccccc ddddd ee....ee

aa....aa : 認可識別子

bb....bb : 表名

ccccc : 構成列数

ddddd : インデクス定義数

ee....ee : 表作成時間


TRIGGERS

[機能]

  指定した認可識別子が所有しているトリガの一覧を表示します。

[形式]

  TRIGGERS [ { 認可識別子 | ALL } ]

オペランド

● 認可識別子 ～＜認可識別子＞（1～8文字）

  トリガを所有しているユーザの認可識別子を指定します。

  認可識別子を省略した場合、ＣＯＮＮＥＣＴ時の認可識別子が仮定されます。

● ALL

  定義してある全てを表示します。

[出力形式]

TRIGGER_NAME SPECIFIC_NAME ～

---------------------------------------- ------------------------------ ～

aa....aa bb....bb ～

～ TABLE_NAME ACT EVT TYP VAL CREATE_TIME

～ ------------------------------ --- --- --- --- ----------------

～ cc....cc d e f g hh....hh

aa....aa : トリガ名称(認可識別子.トリガ名)

bb....bb : トリガ動作手続きの特定名

cc....cc : トリガを定義した表の名称

d : トリガ動作時期

e : トリガ契機種別

f : トリガ動作単位

g : トリガ/インデクス有効フラグ

hh....hh : トリガ作成時間


TYPES

[機能]

  指定した認可識別子が所有している抽象データ型を表示します。

[形式]

  TYPES [[ ＲＤノード名[.] ] { 認可識別子 | ALL } ]

オペランド

● ＲＤノード名 ～＜ＲＤノード名＞（1～30文字）

  リモートデータベースアクセスをする場合、ＲＤノード名を指定します。

  ＲＤノード名はリモートデータベースがＨｉＲＤＢの場合のみ指定できます。

  ＲＤノード名を省略した場合、ローカルアクセスになります。

● 認可識別子 ～＜認可識別子＞（1～8文字）

  抽象データ型を所有しているユーザの認可識別子を指定します。

  認可識別子を省略した場合、ＣＯＮＮＥＣＴ時の認可識別子が仮定されます。

● ALL

  定義してある全てのユーザの抽象データ型を表示します。

[留意事項]

(1) 本コマンドは、HiRDB Version 5.0以降で使用できます。

[出力形式]

TYPE_ID TYPE_NAME N_ATTR

------------ ------------------------------ ------

aa....aa bb....bb ccccc

aa....aa : 抽象データ型ＩＤ

bb....bb : 抽象データ型名

ccccc : 構成属性数


USERS

[機能]

  ユーザ一覧を表示します。

[形式]

  USERS [[ ＲＤノード名[.] ] { 認可識別子 | ALL } ]

オペランド

● ＲＤノード名 ～＜ＲＤノード名＞（1～30文字）

  リモートデータベースアクセスをする場合、ＲＤノード名を指定します。

  ＲＤノード名はリモートデータベースがＨｉＲＤＢの場合のみ指定できます。

  ＲＤノード名を省略した場合、ローカルアクセスになります。

● 認可識別子 ～＜認可識別子＞（1～8文字）

  表示するユーザの認可識別子を指定します。

  認可識別子を省略した場合、ＡＬＬが仮定されます。

● ALL

  ユーザ全てを表示します。

[出力形式]

USER_ID DBA SCHEMA CREATE_TIME TEST

------------------------------ --- ------ -------------- ----

aa....aa b c dd....dd e

aa....aa : ユーザＩＤ

b : ＤＢＡ権限

c : スキーマ定義権限

dd....dd : スキーマ作成時間

e : パスワード制限違反者種別コード(未チェック時は空白)[*1]

*1:HiRDB V7 07-02以降に接続しているときに出力されます。