HiRDB CMヘルプの目次

HiRDB Control Manager ヘルプ

目 次

§ はじめに

HiRDB Control Managerで使用する略語と商標

HiRDB Control Managerの概要

§ 構築編

HiRDB Control Managerの構成

インストール/アンインストール方法

ログイン

§ 解説編

HiRDB CMで管理する情報

バックアップ/リカバリ

カタログ/スケジュール

データベース状態解析

自動データメンテナンス

HiRDBメッセージ監視

系切り替え構成HiRDBの管理

デバイス情報

§ 操作編

メニューバー

[オプション]メニュー

[ウィンドウ]メニュー

[ヘルプ]メニュー

ボタンバー

タブメニュー

[システムステータス]タブ

[マップ]タブ

[バックアップ]タブ

[リカバリ]タブ

[データメンテナンス]タブ

[スケジュール]タブ

[システムログ管理]タブ

[ステータスファイル管理]タブ

[表操作]タブ

[ツール]タブ

[管理HiRDB]タブ

[監視]タブ

§ 連携編

カタログ実行コマンド連携

JP1/AJS2連携

JP1/AJS2-SO連携

§ メッセージ編

§ 付録

Agent定義パラメータ一覧

管理情報のバックアップ/リカバリ

HiRDB CMで使用するIPアドレスを変更する方法

§ 用語集


はじめに

目次

はじめに

このヘルプは、プログラムプロダクト　HiRDB Control Managerの機能について説明したものです。

<対象読者>

HiRDB Control Managerを使ってHiRDBシステムを運用する方々を対象にしています。

このヘルプの記述は、次に示す知識があることを前提にしています。

プログラムプロダクト　スケーラブルデータベースサーバ　HiRDBのシステム管理の基礎的な知識

<ヘルプの構成>

HiRDB Control Managerで使用する略語と商標

HiRDB Control Managerの概要

構築編

HiRDB Control Managerの構成

インストール/アンインストール方法

ログイン

解説編

HiRDB CMで管理する情報

バックアップ/リカバリ

カタログ/スケジュール

データベース状態解析

自動データメンテナンス

HiRDBメッセージ監視

系切り替え構成HiRDBの管理

デバイス情報

操作編

メニューバー

ボタンバー

タブメニュー

連携編

カタログ実行コマンド

JP1/AJS2連携

JP1/AJS2-SO連携

メッセージ編

付録

Agent定義パラメータ一覧

管理情報のバックアップ/リカバリ

HiRDB CMで使用するIPアドレスを変更する方法

用語集


HiRDB Control Managerで使用する略語と商標

HiRDB Control Managerで使用する英語略と商標類

HiRDB Control Managerで使用する英語略と商標類について、以下に示します。

1. 英語略

HiRDB Control Manager で使用する英語略の一覧を次に示します。

英語略 | 正式名称
CUI (CLI) | Character-based User Interface
DB | Database
DBMS | Database Management System
DNS | Domain Name System
FQDN | FQDN
GUI | Graphical User Interface
J2EE | Java 2 Enterprise Edition
LAN | Local Area Network
LVM | Logical Volume Manager
NFS | Network File System
RDB | Relational Database
TCP/IP | Transmission Control Protocol/Internet Protocol

2. 製品名称の表記

HiRDB Control Managerでは製品名称及び名称について、次のように表記しています。

表記 | 製品名称又は名称
HiRDB CM | HiRDB Control Manager
HiRDB CM - Console CM Console Console CMC コンソール | HiRDB Control Manager - Console
HiRDB CM - Server Server CM Server CMS サーバ | HiRDB Control Manager - Server
HiRDB CM - Agent Agent CM Agent 通常Agent CMA エージェント | HiRDB Control Manager - Agent
HiRDB CM - Web Console Web Console | HiRDB Control Manager - Web Console
HiRDB CM - Agent NetBackup NetBackup用Agent | HiRDB Control Manager - Agent NetBackup
HiRDB CM - Agent XDM/RD XDM/RD用Agent | HiRDB Control Manager - Agent XDM/RD
HiRDB/シングルサーバ シングルサーバ | HiRDB/Single Server Version 6 HiRDB/Single Server Version 7 HiRDB/Single Server Version 8
HiRDB/パラレルサーバ パラレルサーバ | HiRDB/Parallel Server Version 6 HiRDB/Parallel Server Version 7 HiRDB/Parallel Server Version 8
HiRDB | HiRDB/Single Server Version 6 HiRDB/Parallel Server Version 6 HiRDB/Single Server Version 7 HiRDB/Parallel Server Version 7 HiRDB/Single Server Version 8 HiRDB/Parallel Server Version 8
Windows 2000 Professional | Microsoft(R) Windows(R) 2000 Professional
Windows 2000 Server | Microsoft(R) Windows(R) 2000 Server
Windows 2000 Advanced Server | Microsoft(R) Windows(R) 2000 Advanced Server
Windows 2000 Datacenter Server | Microsoft(R) Windows(R) 2000 Datacenter Server
Windows XP | Microsoft(R) Windows(R) XP Professional Operating System
Windows Server 2003, Standard Edition | Microsoft(R) Windows Server(R) 2003, Standard Edition 日本語版
Windows Server 2003, Enterprise Edition | Microsoft(R) Windows Server(R) 2003, Enterprise Edition 日本語版
Windows Server 2003, Standard Edition x64 | Microsoft(R) Windows Server(R) 2003, Standard x64 Edition 日本語版
Windows Server 2003, Enterprise Edition x64 | Microsoft(R) Windows Server(R) 2003, Enterprise x64 Edition 日本語版
Windows Server 2003, Standard Edition R2 | Microsoft(R) Windows Server(R) 2003 R2, Standard Edition 日本語版
Windows Server 2003, Enterprise Edition R2 | Microsoft(R) Windows Server(R) 2003 R2, Enterprise Edition 日本語版
Windows Server 2003, Standard Edition R2 x64 | Microsoft(R) Windows Server(R) 2003 R2, Standard x64 Edition 日本語版
Windows Server 2003, Enterprise Edition R2 x64 | Microsoft(R) Windows Server(R) 2003 R2, Enterprise x64 Edition 日本語版
Windows Vista Business | Microsoft(R) Windows Vista Business
Windows Vista Enterprise | Microsoft(R) Windows Vista Enterprise
Windows Vista Ultimate | Microsoft(R) Windows Vista Ultimate
Windows Vista Business(x64) | Microsoft(R) Windows Vista Business(x64)
Windows Vista Enterprise(x64) | Microsoft(R) Windows Vista Enterprise(x64)
Windows Vista Ultimate(x64) | Microsoft(R) Windows Vista Ultimate(x64)
Windows Server 2008, Standard | Microsoft(R) Windows Server(R) 2008 Standard 日本語版
Windows Server 2008, Enterprise | Microsoft(R) Windows Server(R) 2008 Enterprise 日本語版
Windows Server 2008, Standard 32-bit | Microsoft(R) Windows Server(R) 2008 Standard 32-bit 日本語版
Windows Server 2008, Enterprise 32-bit | Microsoft(R) Windows Server(R) 2008 Enterprise 32-bit 日本語版
Microsoft SQL Server | Microsoft(R) SQL Server
64ビットバージョン Windows Server 2003 Windows 2003(IPF) | 64ビットバージョン Microsoft(R) Windows Server(R) 2003,Enterprise Edition (IPF)
Microsoft Internet Information Server | Microsoft(R) Internet Information Server
Windows 2000 | Windows 2000 Professional Windows 2000 Server Windows 2000 Advanced Server Windows 2000 Datacenter Server
Windows Server 2003 | Windows Server 2003, Standard Edition Windows Server 2003, Enterprise Edition Windows Server 2003, Standard Edition x64 Windows Server 2003, Enterprise Edition x64 Windows Server 2003, Standard Edition R2 Windows Server 2003, Enterprise Edition R2 Windows Server 2003, Standard Edition R2 x64 Windows Server 2003, Enterprise Edition R2 x64
Windows Vista | Windows Vista Business Windows Vista Enterprise Windows Vista Ultimate Windows Vista Business(x64) Windows Vista Enterprise(x64) Windows Vista Ultimate(x64)
Windows Server 2008 | Windows Server 2008, Standard Windows Server 2008, Enterprise Windows Server 2008, Standard 32-bit Windows Server 2008, Enterprise 32-bit
Windows | Windows 2000 Windows XP Windows Server 2003 Windows Vista Windows Server 2008
WOW64 | Windows on Windows 64
IPF | Itanium(R) Processor Family
Windows(IPF) | Windows 2003(IPF)
NetBackup | JP1/VERITAS NetBackup BS v4.5 JP1/VERITAS NetBackup v4.5 JP1/VERITAS NetBackup 5
XDM/BASE E2 | Extensible Data Manager/Base Extended Version 2 XDM基本プログラム XDM/BASE E2
XDM/RD E2 | XDM/Relational Database Extended Version 2 リレーショナルデータベースシステム XDM/RD E2
XNF/TCP | Extended HNA Based Communication Networking Facility/Transmission Control Protocol XNF TCP/IP接続機能
DBコネクションサーバ | VOS3 Database Connection Server
JP1/AJS2 | JP1/Automatic Job Management System 2 JP1/Automatic Job Management System 2 - Light Edition JP1/Automatic Job Management System 2 - Manager JP1/Automatic Job Management System 2 - View
JP1/AJS2-View | JP1/Automatic Job Management System 2 - View
JP1/AJS2-SOM | JP1/Automatic Job Management System 2 - Scenario Operation Manager
JP1/AJS2-SOV | JP1/Automatic Job Management System 2 - Scenario Operation View
JP1/IM | JP1/Integrated Manager JP1/Integrated Manager - Central Console JP1/Integrated Manager - View JP1/Integrated Manager - Central Information Master
JP1/IM-CC | JP1/Integrated Manager - Central Console
JP1/IM-View | JP1/Integrated Manager - View
JP1/IM-CM | JP1/Integrated Manager - Central Information Master
HA Toolkit Ex | Hitachi HA Toolkit Extension
MSCS | Microsoft Cluster Service

3. 属性表示記号

ユーザ指定値の範囲などを表す記号を次に示します。

属性表示記号 | 意味
(( )) | ユーザ指定範囲を示します。
<< >> | ユーザが指定しなかった場合に仮定される値を示します。
［ ］ | ボタンやテキストボックスなど，画面に表示されている要素を示します。
［ ］－［ ］ | 画面に表示されるメニューやアイコンなどを選択する操作を示します。

4.KB（キロバイト）などの単位表記

1KB（キロバイト），1MB（メガバイト），1GB（ギガバイト），1TB（テラバイト）はそれぞれ1,024バイト，1,0242バイト，1,0243バイト，1,0244バイトです。

5. 商標類

· Windowsは，米国およびその他の国における米国Microsoft Corp.の登録商標です。

· Windows Serverは，米国Microsoft Corporationの米国及びその他の国における登録商標です。

· Windows Vistaは，米国Microsoft Corporationの米国及びその他の国における登録商標です。

· Microsoftは，米国およびその他の国における米国Microsoft Corp.の登録商標です。

· MS-DOSは，米国およびその他の国における米国Microsoft Corp.の登録商標です。

· Visual C++は，米国およびその他の国における米国Microsoft Corp.の登録商標です。

· Itaniumは，アメリカ合衆国および他の国におけるインテルコーポレーション および子会社の商標です。

· UNIX は，X/Open Company Limitedが独占的にライセンスしている米国ならびに他の国における登録商標です。

· AIX は，米国における米国International Business Machines Corp.の登録商標です。

· HPは，米国Hewlett-Packard Companyの会社名です。

· HP9000は，米国Hewlett-Packard Companyの商品名称です。

· HP-UXは，米国Hewlett-Packard Companyのオペレーティングシステムの名称です。

· Linuxは，Linux Torvalds の米国及びその他の国における登録商標あるいは商標です。

· Red Hatは，米国Red Hat software,Inc.の登録商標です。

· Solarisは，米国及びその他の国におけるSun Microsystems,Inc.の商標又は登録商標です。

· VERITASは，米国VERITAS Software Corporationの登録商標です。

· VERITAS NetBackupは，米国及びその他の国での米国VERITAS Software Corporation の商品名称です。

· VERITAS NetBackup BusinesServerは，米国及びその他の国での米国VERITAS Software Corporation の商品名称です。

· Java 及びすべてのJava関連の商標及びロゴは，米国及びその他の国における米国Sun Microsystems, Inc.の商標または登録商標です。

· JDKは，米国 Sun Microsystems,Inc.の米国およびその他の国における商標または登録商標です。

· Tomcatは，Apache Software Foundationの登録商標です。


HiRDB Control Managerの概要

1. HiRDB Control Managerとは

HiRDB Control Manager (HiRDB CM: HiRDB Control Manager) はUNIXオペレーションシステム、あるいはWindowsオペレーションシステム上で動作するHiRDBの運用を、PCからのGUI操作で行えるようにすることで、HiRDBの運用操作性を向上させ、かつ複数のHiRDBを統合的に運用することを狙ったソフトウェアです。

2. アプリケーション構成

HiRDB Control Managerは次に示す3種類の部品から構成されます。

l コンソール

コンソール (CMC: HiRDB Control Manager - Console) はHiRDB CMを操作するGUIインターフェースを提供します。

JP1/AJS2-Viewのカスタムジョブ機能を使用してJP1/AJS2と連携する機能を提供します。

動作環境はWindows 2000、Windows XP、Windows Server 2003、Windows(IPF)、Windows Vista、Windows Server 2008です。ただし、JP1/AJS2連携機能はWindows Vista、Windows Server 2008ではサポートされていません。

l サーバ

サーバ (CMS: HiRDB Control Manager - Server) はCMCからの指示を受け、適切な処理を行います。また、HiRDB CMの管理情報を保持し、HiRDB CMの制御を行います。CMSは1つのHiRDB CMシステム内に1つ存在します。

JP1/AJS2、JP1/IM、JP1/AJS2-SO(シナリオテンプレート）とそれぞれ連携する機能を提供します。

CMSは、HiRDB Control ManagerをWEBブラウザで操作することのできるJ2EEアプリケーションを提供します。

動作環境はWindows 2000、Windows XP、Windows Server 2003、Windows(IPF)、Windows Vista、Windows Server 2008です。ただし、JP1シリーズとの連携機能、および、J2EEアプリケーションはWindows(IPF)ではサポートされていません。J2EEアプリケーションはWindows(IPF)ではサポートされていません。

l エージェント

エージェント (CMA: HiRDB Control Manager - Agent) はCMSからの指示を受けHiRDBへのアクセスを行う処理実行部を担当します。機能ごとに違うエージェントが存在し、HiRDBユニット1つに対し1つ存在します。

また、CMAは、単独でHiRDBクライアントから直接コマンドを実行する「UAPからのコマンド実行」機能を提供します。

動作環境はWindows 2000、Windows XP、Windows Server 2003、Windows(IPF)、Windows Vista、Windows Server 2008、Linux、Linux(IPF)、HP-UX、HP-UX(IPF)、AIX、Solarisです。

各アプリケーションは別々のサーバマシンへインストール、あるいはOSがWindowsである場合は同サーバマシンにインストールすることが可能です。

次にHiRDB Control Managerの構成例を示します。

HiRDB Control Managerの構成

3. HiRDB Control Managerの機能

HiRDB Control Managerでは以下に示すHiRDBの運用を、PCから行うことができます。( )内は、それぞれの機能で使用するHiRDBの運用コマンドおよびユティリティ名です。

( 1 ) 複数HiRDBシステムの一元管理

( 2 ) HiRDBの各種状態表示

· HiRDBシステムの状態表示(pdls)

· HiRDBシステムログファイルの状態表示(pdlogls)

· HiRDBシンクポイントダンプファイルの状態表示(pdlogls)

· HiRDBシステムステータスファイルの状態表示(pdls -d sts)

· RDエリアの状態表示(pddbls)

· グローバルバッファの状態表示(pdbufls)

· データベース状態解析ユティリティ(pddbst)

· HiRDB errlogファイル内容表示

· HiRDB cmdlogファイル内容表示

· syslog/Windowsイベントログ内容表示

· CPU利用率、メモリ使用量、共用メモリ使用量、メッセージキュー使用数、セマフォ使用数

( 3 ) HiRDBシステムの開始 (pdstart) ・停止 (pdstop)

· HiRDBシステム正常開始/正常停止

· HiRDBユニット正常開始/正常停止

· HiRDBサービス正常開始/正常停止

· HiRDBシステム強制開始/強制終了

· HiRDBユニット強制停止

· HiRDB複写回復専用開始

· プロセスサービスの再起動(pdrpause)

· トランザクションキューイング機能の開始、停止(pdtrnqing)

( 4 ) データベース複写ユティリティ (pdcopy) とデータベース回復ユティリティ (pdrstr)

· ウィザード : ガイダンスに従い、簡単な情報入力で的確な操作を行うことができます。

· カスタマイズ : 詳細な設定が可能です。

( 5 ) RDエリアの操作

· オープン (pdopen) ・クローズ (pdclose) ・閉塞 (pdhold) ・閉塞解除 (pdrels)

· データベース構成変更ユティリティ(追加・拡張・再初期化・削除) (pdmod)

· カレントRDエリアの変更 (pddbchg)

( 6 ) 表の操作

· データベース作成ユティリティ (pdload)

· データベース再編成ユティリティ (pdrorg)

· 表定義生成ユティリティ (pddef)

· 空きページ解放ユティリティ (pdreclaim)

· 定義系ＳＱＬの生成 (pddefrev)

( 7 ) システムログファイルの操作

· アンロード (pdlogunld)

· 状態変更 (pdlogchg)

· スワップ (pdlogswap)

· オープン (pdlogopen)

· クローズ (pdlogclose)

· 削除 (pdlogrm)

· 作成 (pdloginit)

· 自動アンロードログ制御 (pdlogatul)

( 8 ) ステータスファイルの操作

· スワップ (pdstswap)

· オープン (pdstsopen)

· クローズ (pdstscls)

· 削除 (pdstsrm)

· 作成 (pdstsinit)

( 9 ) グローバルバッファの操作

· グローバルバッファの追加，削除，及び変更 (pdbufmod)

( 10 ) HiRDB運用ディレクトリの容量表示および整理

· HiRDB運用ディレクトリがあるディスクの使用率表示

· $PDDIR/spoolディレクトリ下及び$PDDIR/tmpディレクトリ下に作成したファイルを削除(pdcspool)

( 11 ) HiRDBリソース構成表示

· 表/インデックスとRDエリアの関係表示

· RDエリアとHiRDBファイルシステムの関係表示

· HiRDBシステムログとHiRDBファイルシステムの関係表示

· ユーザと表/インデックスの関係表示

· HiRDBシステム構成表示

· ディスクとHiRDBリソースの関係表示（表、ツリー図）

( 12 ) RDエリア自動メンテナンス

· RDエリアの使用容量を定期的に蓄積して容量オーバする日を予測することができます(pddbst)

· 期限内に容量オーバが発生すると予測された場合、当該RDエリアの再編成(pdrorg)または、空きページ解放（pdreclaim）を実行します。

· 期限内に容量オーバが発生すると予測されたRDエリア情報を強調表示します。

( 13 ) HiRDBリソース警告表示

次のリソースに対してしきい値を設定して、「注意」「警告」のレベルに分けた強調表示を行うことができます。

§ RDエリアセグメント使用率

§ グローバルバッファプールヒット率

§ HiRDBファイルシステム領域使用率

§ 利用可能なシステムログファイル数

§ 排他資源管理テーブル使用率

§ PDDIRが含まれるディスク使用率

§ CPU利用率

§ メモリ使用量

§ 共用メモリ使用量

§ メッセージキュー使用数

§ セマフォ使用数

§ HiRDBメッセージレベル

( 14 ) HiRDB周辺プログラムの起動および環境設定

· HiRDB SQL Executerの起動および環境設定

· HiRDB SQL Tuning Advisorの起動および環境設定

( 15 ) カタログ登録とスケジュール実行

何度もおこなうHiRDB操作はカタログとして登録し、その登録したカタログを指定するだけで簡単に再実行することができます。また、カタログの実行日時を設定することもでき、最高一年間の範囲でスケジュール実行を行うことができます。

( 16 ) XDM/RD稼動状態表示およびRDエリア、表構成情報表示

VOS3上に配置されたXDM/RDの稼動状態およびRDエリア、表に関する構成情報をDBコネクションサーバを介して取得し、表示を行うことが出来ます。XDM/RDをCMで管理する場合は、03-00以前のCM Agentか、または、08-00以降に同梱されるXDM/RD用CM Agentが必要です。

( 17 ) JP1/AJS2-SO連携

HiRDB Control Managerで管理するHiRDBシステムの一部運用操作をJP1/AJS2-SO「シナリオテンプレート」として提供します。

( 18 ) JP1/IM-View連携

HiRDB Control Managerで管理するHiRDBシステムの運用操作をJP1/IM-Viewの「統合機能メニュー」および「イベントコンソール」から行える機能を提供します。

( 19 ) JP1/IM-CM連携

HiRDB Control Managerで管理するHiRDBシステムの構成情報をJP1/IM-CM-Viewの「構成情報メニュー」に表示できる機能を提供します。

( 20 ) HiRDBリソース情報ファイル出力

次の一覧情報をCSV形式でファイルへ出力できます。

§ 表/インデックス詳細情報一覧

§ RDエリア詳細情報一覧

§ HiRDBファイルシステム情報一覧

§ HiRDBリソースとディスク関係情報一覧

( 21 ) JP1/AJS2連携

HiRDB CMで作成したカタログをJP1/AJS2から実行できる機能を提供します。JP1/AJS2連携により、さまざまな契機で運用操作のスケジュールを行うことができます。連携の方法には次の２つの方法があります。

§ カタログ実行コマンド連携

§ JP1/AJS2カスタムジョブ連携

( 22 ) HiRDBクライアントからのコマンド実行

HiRDBクライアントを使用したUAP中にコマンドを指定して実行できる機能を提供します。

( 23 ) HiRDBメッセージ監視機能

HiRDBが出力した重要なメッセージを監視し、その内容を表示する機能を提供します。

( 24 ) シンクポイントダンプ取得(pdlogsync)

( 25 ) 既存バックアップファイルの登録(pdbkupls)

( 26 ) 既存アンロードログファイルの登録(pdlogucat)

( 27 ) 改ざん防止表への移行ウィザード

ユーザ表を改ざん防止表へ対話式に移行する機能を提供します。

( 28 ) レプリカ定義

HiRDBファイルシステム領域、RDエリアの世代登録・削除を行う機能を提供します。

<注意事項>

· HiRDB CMは上記の操作を行うにあたり、コマンド実行に必要な情報を収集するため、HiRDBのディクショナリ表の検索や記載されている以外のHiRDBコマンドやOSコマンドの発行をすることがあります。これらの操作によってHiRDBのログやOSのシステムログに履歴が残ることがあります。


構築編

目次

構築編

この章では、HiRDB　CMのシステム構築手順、及びバージョンアップ手順について説明します。

＜この章の構成＞

· HiRDB Control Managerの構成

· インストール/アンインストール方法

· ログイン


HiRDB Control Managerの構成

HiRDB Control ManagerはHiRDB Control Manager - Serverを中心とし、システムを構成します。

以下に6つの構成例を示します。

§ HiRDB Control Manager - Server専用のサーバマシンを使用する場合

管理対象HiRDBシステムが稼動するマシン上へHiRDB Control Manager - Serverを配置すると、HiRDBシステムが動作するマシンへ負荷がかかります。HiRDBシステムが稼動するマシンへの負荷を抑えるためには、HiRDB Control Manager - Server専用のサーバマシンを設置することを推奨します。また、複数のHiRDBシステムを管理する場合にも本構成を推奨します。

§ HiRDB Control Manager - ServerをHiRDBシステム稼動マシン上で使用する場合

管理するHiRDBが少数であり、HiRDBシステムが稼動しているサーバマシンに余裕がある場合の構成です。

§ HiRDB Control Manager - ConsoleとServerを同じサーバマシンで使用する場合

管理するHiRDBが少数であり、HiRDB CM - Server専用のマシンを使用しない場合の構成です。

§ HiRDB Control ManagerでNetBackup情報を管理する場合

管理するHiRDBがNetBackupを使用したバックアップ運用を行う場合の構成です。

§ HiRDB Control Managerでスタンバイ型系切り替え構成HiRDBを管理する場合

管理するHiRDBがスタンバイ型系切り替えを使用している場合の構成です。

§ HiRDB Control ManagerでXDM/RD情報を管理する場合

VOS３上に配置されたXDM/RDを管理(構成表示のみ）する場合の構成です。

l HiRDB Control Manager - Server専用のサーバマシンを使用する場合

管理対象HiRDBシステムが稼動するマシン上へHiRDB Control Manager - Serverを配置すると、HiRDBシステムが動作するマシンへ負荷がかかります。HiRDBシステムが稼動するマシンへの負荷を抑えるためには、HiRDB Control Manager - Server専用のサーバマシンを設置することを推奨します。また、複数のHiRDBシステムを管理する場合にも本構成を推奨します。

構成例を以下の図で示します。

HiRDB CM - Server専用のサーバマシンを使用する場合

図-1 Server専用のサーバマシンを使用する場合の構成

HiRDB Control Manager - Server専用のサーバマシンを用意し、Server、Console、Agentを別々のサーバマシンで動作させる構成です。

l HiRDB Control Manager - ServerをHiRDBシステム稼動マシン上で使用する場合

この構成は管理するHiRDBが少数であり、HiRDBシステムが稼動しているサーバマシンに余裕がある場合の構成です。

構成例を以下の図で示します。

HiRDB CM - ServerをHiRDBシステム稼動マシン上で使用する場合

図-2 ServerをHiRDBシステム稼動マシン上で使用する場合の構成

HiRDB Control Manager - ServerをHiRDBシステムが稼動しているサーバマシンで動作させる構成です。

l HiRDB Control Manager - ConsoleとServerを同じサーバマシンで使用する場合

この構成は管理するHiRDBが少数であり、HiRDB Control Manager - Server専用マシンを使用しないで、Console用マシンと同じマシンを用いる場合の構成です。

構成例を以下の図で示します。

図-2 ServerをHiRDBシステム稼動マシン上で使用する場合の構成

HiRDB Control Manager - ServerとHiRDB Control Manager - Console 同じマシン上で動作する構成です。

l HiRDB Control ManagerでNetBackup情報を管理する場合

この構成は管理するHiRDBがNetBackupを使用したバックアップ運用を行う場合に使用します。

構成例を以下の図で示します。

図-3 NetBackup情報を管理する場合の構成

NetBackupサーバマシン上にHiRDB Control Manager - Agent（NetBackup専用）をインストールし、動作させる構成です。

l スタンバイ型系切り替え構成のHiRDBを管理する場合

この構成は管理するHiRDBがスタンバイ型系切り替えを使用している場合に使用します。

スタンバイ型系切り替えを使用した、HiRDB/シングルサーバまたは、１ノードのパラレルサーバの構成例を以下の図で示します。

図-4 スタンバイ型系切り替え構成のHiRDBを管理する構成

スタンバイ型系切り替え構成のHiRDBを管理する構成です。

  スタンバイ型系切り替えを使用するユニットを管理する場合、現用系・予備系双方のマシンにAgentをインストールする必要があります。

  HiRDBシングルサーバあるいは、HiRDBパラレルサーバのMGRユニットを管理するAgentは、Serverとの通信用に各マシンのステーショナルIPアドレスの他にサービスIPアドレスを使用します。このサービスIPアドレスは、対象のHiRDBユニットが稼動中のマシンでアクティブとなるようにクラスタシステムに登録しておく必要があります。

  Consoleから対象のHiRDBへの操作を行った場合は、以下の規則でAgentへの接続を行います。

①.　HiRDBが稼動中の場合、サービスIPアドレスを使用して接続を行います。

②. HiRDBが停止していて、現用系のマシンに接続可能である場合、現用系マシンのステーショナルIP使用して接続を行います。

③. HiRDBが停止していて、現用系のマシンに接続可能でない場合、予備系マシンのステーショナルIPアドレスを使用して接続を行います。

  接続先は、Serverが各HiRDBシステムごとに記憶します。以下に示す5つの契機で接続先のAgentマシンを決定します。

· Serverを起動するとき

· 管理情報の自動更新が行われたとき

· HiRDBが起動、停止を行ったとき

· 管理情報の更新を実行したとき

l HiRDB Control ManagerでXDM/RD情報を管理する場合

この構成はXDM/RDを管理（構成表示のみ）する場合に使用します。

構成例を以下の図で示します。

図-5 XDM/RDと接続する場合の構成

XDM/RD管理用のPCを用意し、Server、Console、Agent(XDM/RD専用）を同一マシンで動作させる構成です。

このServer、Consoleは、他のHiRDBシステムをXDM/RDと同時に管理することも可能です。


インストール/アンインストール方法

ここでは、HiRDB CMのインストール及びアンインストール方法を説明します。

HiRDB CMを使用するには、以下のアプリケーションをインストールする必要があります。

· HiRDB Control Manager - Server

· HiRDB Control Manager - Console

· HiRDB Control Manager - Agent

各アプリケーションの役割については、HiRDB Control Managerの概要を参照してください。

バックアップ及びリカバリでNetBackup連携機能を使用する場合は、NetBackupマスタサーバマシン上にNetBackup用のHiRDB Control Manager - Agentをインストールする必要があります。

HiRDB Clientを使ったSQLコマンド実行機能だけを使用する場合は、HiRDB Control Manager - Agentのみインストールすることも可能です。

これらのアプリケーションを、Server、Console、Agentの順でインストールします。

NetBackup連携機能を使用する場合はServer、Console、NetBackup用Agent、Agentの順でインストールします。

各アプリケーションのインストール/アンインストール方法は、次で説明します。

· HiRDB Control Manager - Server

· HiRDB Control Manager - Console

· HiRDB Control Manager - Agent


ログイン

Consoleを起動するにはパスワードが必要です。

[スタート] - [プログラム] - [HiRDB CM - Console] から「HiRDB CM - Console」を起動すると、[ログイン]画面が表示されます。

<前提条件>

· 接続するCM Serverを起動してください。

1. 接続を行うCM Serverの情報を指定する。

[CM サーバの変更]タブを開き、ここでConsoleが接続するServerの情報を指定します。

以下の3つの中からいずれかを選択し、対応した情報を指定します。

初期値には、Consoleインストール時に指定したCMサーバ接続情報が設定されます。

· 「IPアドレス」

接続するServerのIPアドレスを入力します。設定範囲は各((0～255))の間で入力できます。

· 「ホスト名」

ホスト名は((最大64文字))まで指定可能です。

· 「ドメイン名」

Serverが存在するコンピュータのFQDN (xxx@xx.xx) を入力してください。

ドメイン名は((最大255文字))まで指定可能です。

2. Serverの「ポート番号」を入力する。

接続するServerのポート番号を入力します。

設定範囲は((5001～65535))の間で入力できます。

3. パスワードを指定する。

Serverに接続するにはパスワードが必要です。[CMシステムログイン]タブを開き次の入力を行います。

· 「コンソールID」

Consoleを実行したマシンのコンピュータ名が表示されます。入力することはできません。この名称は、Serverで接続情報として記録されます。

· 「パスワード」

Serverインストール時に設定したパスワードあるいは、Console メニューバーの[オプション]-[パスワードの変更]コマンドで設定したパスワードを入力してください。

管理者パスワードを入力した場合は、HiRDB CMの全ての機能を使用できる管理者としてログインします。一般ユーザ用パスワードを入力した場合は、HiRDBの状態確認のみ可能な一般ユーザとしてログインします。

一般ユーザとして操作可能なHiRDB CM の機能は、[操作編]「一般ユーザに対する機能制限について」を参照してください。

4. [OK]ボタンをクリック。

Serverと接続完了後にConsoleメイン画面を表示します。

一般ユーザとしてログインした際は、その旨を通知するメッセージを表示します。


解説編

目次

解説編

この章では、HiRDB　CM独自の機能について説明します。その他の機能については、操作編の各画面を参照してください。

＜この章の構成＞

· HiRDB CMで管理する情報

· バックアップ/リカバリ

· カタログ/スケジュール

· データベース状態解析

· 自動データメンテナンス

· HiRDBメッセージ監視

· 系切り替え構成HiRDBの管理

· デバイス情報


管理情報蓄積機能

HiRDB CMが管理する情報

この章では、HiRDB CMで管理するHiRDB管理情報の扱いについて説明します。

l HiRDB CMが管理する情報

  HiRDB CMでは、HiRDBの情報（一部マシン情報）を管理情報としてServerに蓄積します。ConsoleからHiRDBの情報を表示する場合、一部蓄積が行えない情報以外の全ての情報はServerに蓄積された情報を表示します。これにより、管理対象のHiRDBが停止していても情報の表示が行えます。

  蓄積情報は、５つのカテゴリに分類されています。各カテゴリは任意のタイミングで手動で最新の状態に更新が行えます。その一方でデバイス情報以外の４つのカテゴリは定期的に自動更新を行うことができます。また、HiRDB CMからHiRDBの更新情報が変更されるような操作（例えば、RDエリアの追加など）が行われた場合、操作後に自動で管理情報の更新が実行されます。

  次にServerに蓄積される管理情報の各カテゴリとその内容について説明します。

§ 定義情報

このカテゴリには、構成情報とHiRDBシステムのシステム・ユニット・サーバの定義情報が含まれます。HiRDB定義ファイルの変更を行った場合に更新を行う必要があります。また、CM Agentのバージョン情報もこのカテゴリに分類されます。CM Agentのバージョンアップを行う場合は、このカテゴリを更新する必要があります。

この情報を更新する場合は、対象のHiRDBが正常な状態で起動されている必要があります。CM Agentは次のHiRDBコマンドやOSコマンドを順次実行します（CM Agentのバージョンによっては実行されないコマンドもあります）。

pdls -d svr

pdadmvr -s

df -k

pdprcsls

pddbls -r all -a

pdlogls -d sys -s

pdls -d sts

pdfstatfs -b

pdbufls

§ 構成情報

このカテゴリには、次に示すHiRDBのオブジェクトの情報、各オブジェクトの関連情報が含まれます。

RDエリア

表

インデクス

システムログファイル

ステータスファイル

ユーザ（認可識別子）

グローバルバッファ情報

  関連情報とは、例えば、「表１がRDエリア１上に定義されている」「HiRDBファイルシステムA上にシステムログファイルAが定義されている」などの情報です。上で示したHiRDBオブジェクトの構成を変更した場合、このカテゴリ情報を更新する必要があります。

この情報を更新する場合は、対象のHiRDBが正常な状態で起動されている必要があります。CM Agentは次のHiRDBコマンドやOSコマンドを順次実行します（CM Agentのバージョンによっては実行されないコマンドもあります）。

pdls -d svr

pddbls -r all -a

pdlogls -d sys -s

pdls -d sts

pdfstatfs -b

pdbufls

§ リソース情報

このカテゴリには、次に示すHiRDBオブジェクトの容量、使用率などの情報とHiRDBマシンの一部情報が含まれます。HiRDBマシンの情報については、「マシン情報の管理」を参照してください。

RDエリア

HiRDBファイルシステム領域

システムログファイル

ステータスファイル

この情報を更新する場合は、対象のHiRDBの全ユニットまたは一部のユニットが起動されている必要があります。CM Agentは次のHiRDBコマンドやOSコマンドを順次実行します（CM Agentのバージョンによっては実行されないコマンドもあります）。

pdls -d svr

pddbls -r all -a

pdadmvr -s

df -k

pdls -d sts

pdcat -d sts

pdfstatfs -b

§ 状態情報

このカテゴリには、次に示すHiRDBオブジェクトの状態情報が含まれます。

RDエリア状態

HiRDBシステム・ユニット・サーバの稼動状態

システムログファイルの状態

グローバルバッファの状態

この情報を更新する場合は、対象のHiRDBの全ユニットまたは一部のユニットが起動されている必要があります。CM Agentは次のHiRDBコマンドやOSコマンドを順次実行します（CM Agentのバージョンによっては実行されないコマンドもあります）。

pdls -d svr

pdprcsls

pdls -d sts

pdcat -d sts

pdlogls -d sys -s

pddbls -r all -a

§ デバイス情報

このカテゴリには、HiRDBが稼動するマシンのディスク構成情報が含まれます。デバイス情報の詳細については、[解説編] > [デバイス情報]で説明します。

  上記、５つのカテゴリに含まれない、システムステータスの詳細画面などで表示される情報は、HiRDB CM Consoleからの表示要求があった時点でHiRDBシステムから取得されます。

<注意事項>

· インナレプリカ機能を使用しているHiRDBシステムの状態情報以外の情報を更新する場合は、すべての世代のHiRDBファイルシステム領域にアクセスできる状態にしておく必要があります。HiRDBファイルシステム領域やHiRDBファイルシステム領域上のRDエリアなどの情報の取得に失敗した場合、各種情報が不明として更新される場合があります。デバイス装置、OS上のシステムログファイルにI/Oエラー情報が表示される場合もありますので、注意してください。

· HiRDB CMが表示/管理するHiRDBファイルシステム領域は以下のとおりです。

    ・１つ以上のRDエリアが格納されているHiRDBファイルシステム領域（※１）

    ・１つ以上のHiRDBシステムログファイルが格納されているHiRDBファイルシステム領域（※１）

    ・１つ以上のHiRDBステータスファイルが格納されているHiRDBファイルシステム領域（※１）

    ・HiRDB CM Console操作で作成したHiRDBファイルシステム領域

    ・HiRDB CM Console操作で登録したバックアップファイル格納用HiRDBファイルシステム領域

    ・HiRDB CM Console操作で登録したログアンロードファイル格納用HiRDBファイルシステム領域

    ・HiRDB CM Console操作で情報追加した既存HiRDBファイルシステム領域（※２）

    ・HiRDB CM Console操作で情報追加した既存HiRDBバックアップファイルが格納されたHiRDBファイルシステム領域（※２、※３）

    ・HiRDB CM Console操作で情報追加した既存HiRDBログアンロードファイルが格納されたHiRDBファイルシステム領域（※２、※３）

  ※１：HiRDB CMが自動的に管理対象とします。

  ※２：既存HiRDBファイルシステム領域とは、HiRDB CM Console操作以外（HiRDBコマンド等を直接実行した）で作成されたHiRDBファイルシステム領域のことを指します。

  ※３：HiRDB CM 08-00以降の機能です。

l 管理情報更新間隔の設定

  各カテゴリの特質を理解した上で、[管理情報更新間隔]の設定を行う必要があります。次に、HiRDB CMで推奨する管理情報更新間隔の設定基準を示します。

§ 定義情報更新間隔の設定基準

頻繁にシステム構成の変更が発生する運用を行っている場合に、自動更新を設定します。このカテゴリの情報を大半の運用では自動で更新する必要はありません。通常は、更新間隔に0を設定し、自動更新を行わないでください。

§ 構成情報更新間隔の設定基準

HiRDB CMを使用しないで、構成情報のカテゴリに含まれるHiRDBオブジェクトの変更が行われる場合にその頻度に応じて更新間隔を設定してください。このカテゴリの情報を自動更新する必要のある運用には、次に示すようなケースが考えられます。

HiRDBの状態を監視し、その結果に応じてHiRDBオブジェクトの構成が変更されるような対処が行われるシステム

表、インデクスが日々追加されるような運用を行っているシステム。

ユーザが日々追加されるような運用を行っているシステム。

HiRDB CMを使用して対処を行う場合や、管理者が手動で対処を行いその後このカテゴリの情報を手動で更新する場合は、この情報を自動更新する必要はありません。

§ リソース情報更新間隔の設定基準

  このカテゴリは、主にHiRDBに対してデータの挿入、削除操作が頻繁に行われるシステムに対して、その頻度に応じて自動更新間隔を設定します。通常、データの増分量が、システム全体の１％程度になる時間間隔を指定してください。また、この値は[警告表示機能]を使用する場合には、その精度になります。監視したい時間間隔に自動更新間隔を設定することをお勧めします。

§ 状態情報更新間隔の設定基準

  このカテゴリは、HiRDB CMを使用してHiRDBの状態を監視したい間隔で指定します。この間隔が、[ボタンバー]や、[タブメニュー] > [システムステータス] で表示される各HiRDBシステムの状態の精度になります。

<注意事項>

· インナレプリカ機能を使用しているHiRDBシステムの「状態情報」以外の情報を更新する場合は、すべての世代のHiRDBファイルシステム領域にアクセスできる状態にしておく必要があります。通常の運用の状態が、すべての世代のHiRDBファイルシステム領域にアクセスできる状態でない場合は、必ず[状態情報]以外の更新間隔を0に設定してください。

l マシン情報の管理

  HiRDB CMでは、HiRDBの情報以外にHiRDBの各ユニットが稼動しているマシンのリソース情報も表示します。HiRDB　CMで表示するマシンのリソース情報の一覧を次に示します。これらの情報は、[タブメニュー] > [システムステータス] > [詳細] > [ユニット詳細情報]で表示されます。

これらの情報は、対象HiRDBが使用している値ではなく、対象HiRDBが稼動するマシン上でHiRDB以外のプログラムも使用している値も含まれています。使用するOSコマンドの詳細は、各OSのマニュアルを参照してください。

§ PDDIRが含まれるディスクの使用率

対象のユニットのHiRDBがインストールされているディレクトリが含まれているディスクの使用率です。各OSで次に示す情報を表示しています。

Windowsの場合 ： WindowsAPIを使用して値を取得します。

UNIXの場合 ： dfコマンドにより値を取得します。

§ CPU使用率

対象のユニットのCPU使用率を表示します。各OSで次に示す情報から値を決定しています。

Windowsの場合 ： WindowsAPIのパフォーマンスモニタ取得用関数を使用して1秒間隔で５回結果を取得し、その平均を使用します。

UNIXの場合 ： vmstatコマンドで取得したCPUユーザ時間とCPUシステム時間の合計を使用します。

§ メモリ使用量

対象のユニットのメモリ使用率を量をMB単位で表示します。各OSで次に示す情報から値を決定しています。

Windowsの場合 ： WindowsAPIを使用して物理メモリ使用量と仮想メモリ使用量を取得し、その合計を使用します。

Linuxの場合：free -mコマンドを実行して、実行結果の物理メモリ使用量とスワップメモリ使用量を取得し、その合計を使用します。

AIX, HP-UXの場合：vmstatコマンドを実行して、実行結果の仮想メモリの使用ページ数の値を使用します。

Solarisの場合：swap -sコマンドを使用して、実行結果のスワップメモリ使用量の値を使用します。

§ 共用メモリ使用量

対象のユニットの共用メモリ使用量をMB単位で表示します。各OSで次に示す情報から値を決定しています。ここで取得される共有メモリ量は、マシン全体の使用量であり、HiRDBのみの共用メモリ使用量は、[タブメニュー] > [システムステータス] > [詳細] > [共用メモリ使用量情報]ボタンで表示します。

Windowsの場合 ： 常に 「-」を表示します。

Linuxの場合：ipcs -mコマンド実行結果の共用メモリ使用量の総和を使用します。

Linux以外のUNIXの場合：ipcs -m -bコマンド実行結果の共用メモリ使用量の総和を使用します。

§ メッセージキュー使用数

対象のユニットのメッセージキュー使用数です。各OSで次に示す情報から値を決定しています。

Windowsの場合 ： 常に 「-」を表示します。

UNIXの場合 ： ipcs -qコマンドの実行結果で表示されるデータ行数を使用します。

§ セマフォ使用数

対象のユニットのCPU使用率を表示します。各OSで次に示す情報から値を決定しています。

Windowsの場合 ： 常に 「-」を表示します。

UNIXの場合 ： ipcs -sコマンドの実行結果で表示されるデータ行数を使用します。

<注意事項>

· マシン情報は、対象HiRDBが系切り替え構成の場合、通常実行系ユニットの情報を取得します。HiRDBユニットが停止している場合は、現用系ユニットの情報を取得します。現用系ユニットが停止してる場合は、予備系ユニットのマシン情報を取得します。

l HiRDB CMでの操作後の自動更新

  HiRDB CMでHiRDBに対して以下の操作を行った場合、自動的に管理情報の更新を行います。

- RDエリアに関する操作

- HiRDBファイルシステム領域に関する操作

- データロード

- 再編成

- 空きページ開放

- システムログファイルに関する操作

- ステータスファイルに関する操作

- バックアップ

- リカバリ

- 改ざん防止表への移行

また、上記の操作をカタログ化し、スケジュール実行を行った場合、スケジュール実行結果がHiRDB CM Serverに登録された段階で自動的に管理情報の更新を行います。

自動的に管理情報の更新を行いたくない場合は、[コマンド実行後の管理情報更新抑止]設定を行ってください。


バックアップ/リカバリ機能

バックアップ/リカバリ

HiRDB　CMを使用して管理対象HiRDBのバックアップ/リカバリの機能について説明します。また、後半では、使用例を紹介します。

· バックアップ/リカバリの説明

§ バックアップ機能

§ リカバリ機能

§ バックアップファイル管理方式

§ HiRDBファイルシステム領域単位のバックアップ/リカバリ機能

· バックアップ-ウィザード機能の使用例

· バックアップ-カスタマイズ機能の使用例

· 差分バックアップ機能の使用例

· NetBackup機能の使用例

· リカバリ-ウィザード機能の使用例

· リカバリ-カスタマイズ機能の使用例

· HiRDBファイルシステム領域単位のバックアップ/リカバリの使用例


バックアップ/リカバリの説明

ここでは、HiRDB CMを使用して管理対象のHiRDBのバックアップ/リカバリを行う機能について説明します。

l バックアップ機能

  HiRDB CMでは、[カスタマイズ]と[ウィザード]の２種類のバックアップ方法を提供しています。

· [カスタマイズ]機能：

  [カスタマイズ]機能では、HiRDBが提供しているCLIとほぼ同じオプションの指定がGUIで行うことができます。また、ユーザが指定する必要がないオプション（HiRDBの構成上一意に求まるオプション）の入力を省くことができます。

  HiRDB CMでは、 各[マップ]や[データベース状態解析ユティリティ]画面に表示されたRDエリアに対して、バックアップ-カスタマイズ操作を行うこができます。これにより、HiRDBの構成、状態を確認しながらバックアップを取得することができます。

· [ウィザード]機能：

  [ウィザード]機能では、[カスタマイズ]機能に加えてHiRDBの構成を自動的に導き出すことができます。たとえば、ある表のバックアップを取得したい場合、対象の表からHiRDBが提供しているバックアップの取得単位であるRDエリアを求める必要があります。[ウィザード]機能を使用した場合、表などのより運用に直結したリソースを指定するだけで、HiRDB　CMが対象となるRDエリアを自動的に検索します。また、分割表やBLOB列の関係により、同時にバックアップを取得することが推奨されるRDエリアも検索します。また、頻繁に指定するオプションは[ウィザード環境設定]画面によって一括で指定することができます。

  HiRDB CMでHiRDBのNetBackup連携によるバックアップを行うことができます。HiRDB CMでは、一度ポリシーに対してバックアップを行った場合、次以降のバックアップはポリシー名を指定するだけで同じバックアップがオプションの指定を行わなくても繰り返し実行できます。HiRDB CMでNetBackup連携を行う場合、HiRDB CM　Consoleから新規にNetBackupポリシを作成してください。既存のポリシを登録することはできません。

HiRDB CMでは、以下の流れでバックアップを行います。

項番 | HiRDB操作 | 実行コマンド | 詳細
1 | RDエリアの閉塞、または、複写/回復専用開始 | pdhold または pdstop, pdstart -r | 参照・更新不可能モードでバックアップを実行する場合、RDエリアの閉塞を行います。マスタ用RDエリアをバックアップ対象に含む場合は、HiRDBを複写/回復専用モードで開始します。 バックアップカスタマイズ実行前にRDエリアの閉塞、または、複写/回復専用モードでの起動がされていた場合は何も行いません。
2 | システムログファイルのスワップ | pdlogswap | データベース回復時に必要なシステムログを物理的に分けるために、システムログファイルをスワップします。複写/回復専用モードで開始している場合には行いません。
3 | バックアップ実行 | pdcopy | バックアップを実行します。
4 | システムログファイルの解放 | pdlogchg | アンロードレスシステムログ運用をしている場合、ログポイント以前のシステムログの状態を変更します。
5 | RDエリアの閉塞解除、または、HiRDBの正常開始 | pdrels または pdstop, pdstart | 項番1で閉塞したRDエリアの閉塞解除を行います。複写/回復専用モードでHiRDBが開始している場合は、HiRDBを正常開始します。 バックアップカスタマイズ実行前にRDエリアの閉塞、または、複写/回復専用モードでの起動がされていた場合は何も行いません。

l リカバリ機能

HiRDB CMでは、[カスタマイズ]と[ウィザード]の２種類のリカバリ方法を提供しています。

· [カスタマイズ]機能：

  [カスタマイズ]機能では、HiRDBが提供しているCLIとほぼ同じオプションの指定がGUIで行うことができます。また、ユーザが指定する必要がないオプション（HiRDBの構成上一意に求まるオプション）の入力を省くことができます。

· [ウィザード]機能：

  [ウィザード]機能では、回復対象に対してHiRDB CMで取得したバックアップファイルの中から検索を行い、指定対象を最新の同期点または、任意の時間の状態に回復する方法を提示します。提示した条件を選択するだけで、簡単にリカバリが実行できます。

HiRDB CMでは、次の条件でリカバリ方法を提示します。

§ 最新の同期点に回復を行う場合：

  指定した対象を全て含む最新のバックアップファイルを使用してバックアップ取得時点への回復を行う回復方法を提示します。また、対象のサーバが自動ログアンロードを使用している場合、自動ログアンロードで取得したアンロードログファイルを使用した最新の同期点への回復を提示します。

§ 任意の同期点に回復を行う場合：

  指定した対象を全て含むバックアップファイルの中で、指定した時刻以前で最新のバックアップファイルを使用してバックアップ取得時点への回復方法を提示します。また、対象のサーバが自動ログアンロードを使用している場合、自動ログアンロードで取得したアンロードログファイルを使用した任意の同期点への回復を提示します。ただし、差分バックアップ機能をして取得したバックアップファイルが検索された場合は、回復方法を提示できません。

  各[マップ]や[データベース状態解析ユティリティ]画面に表示されたRDエリアに対して、リカバリ-ウィザード操作を行うこができます。これにより、HiRDBの構成、状態を確認しながらバックアップを取得することができます。

  [ウィザード]機能では、もっとも一般的なオプションでのリカバリ方法を提示します。より複雑なオプションを指定したリカバリを行いたい場合は、[カスタマイズ]画面を使用してください。

  リカバリウィザード機能は、単一のバックアップ取得方法で運用を行っている場合に有効な機能です。複数の条件で取得したバックアップファイルが存在する運用を行っている場合は、[バックアップ詳細情報]でバックアップ情報を確認して、[カスタマイズ]機能によるリカバリを行ってください。

  HiRDB　CMでは、自動ログアンロード機能で取得したアンロードログファイルを使用したリカバリを使用する場合、アンロードログファイルを一つずつ指定する必要がありません。HiRDB　CMでは、HiRDBの定義ファイルで定義された自動ログアンロード格納先ディレクトリを自動的に検索してリカバリを行います。ただし、この機能を使用する場合、次の条件が満たされている必要があります。

§ バックアップを取得してからの全てシステムログファイルが自動ログアンロード機能でアンロードされていること

§ バックアップ取得後からアンロードログファイル出力先ディレクトリが変更されていないこと

§ 自動ログアンロードファイルが各サーバに２５６個以下であること

§ 回復対象がすべて同一ホスト上に存在していること

§ アンロードログ格納先にディレクトリとHiRDBファイルシステム領域を混在していないこと

§ 回復対象のサーバに対して定義されている自動ログアンロード格納先ディレクトリの総計が129以上にならないこと

リカバリウィザードでは、以下の流れでリカバリを行います。

項番 | HiRDB操作 | 実行コマンド | 詳細
1 | 使用するアンロードログファイルの決定 | pdfstatfs, pdfls | 自動ログアンロード機能で取得したログファイルを使用する場合に、リカバリコマンドで指定するアンロードログファイルを決定します。 ・ HiRDBが07-02以上 - アンロードログファイルが通常ファイルの場合、アンロードログファイル格納先ディレクトリをpdrstrの-dオプションに指定します。 - アンロードログファイルがHiRDBファイルの場合、アンロードログファイル格納先HiRDBファイルシステム領域に存在するアンロードログファイルを古いものから順にpdrstrの-lオプションに指定します。 ・ HiRDBが07-02未満 アンロードログファイル格納先に存在するアンロードログファイルを古いものから順にpdrstrの-lオプションに指定します。
2 | RDエリアの閉塞、または、HiRDBの複写/回復専用開始 | pdhold または pdstop, pdstart -r | RDエリアの閉塞を行います。マスタ用RDエリアを回復対象に含む場合は、複写/回復専用モードでHiRDBを開始します。 リカバリウィザード実行前にRDエリアの閉塞、または、複写/回復専用モードでの起動がされていた場合は何も行いません。
3 | リカバリ実行 | pdrstr | リカバリを実行します。
4 | RDエリアの閉塞解除、または、HiRDBの正常開始 | pdrels または pdstop, pdstart | 項番2で閉塞したRDエリアの閉塞解除を行います。複写/回復専用モードでHiRDBが開始している場合は、HiRDBを正常開始します。 リカバリウィザード実行前にRDエリアの閉塞、または、複写/回復専用モードでの起動がされていた場合は何も行いません。

l バックアップファイル管理方式

  HiRDB　CMでは、バックアップを取得する前にバックアップ格納先ディレクトリ、または、HiRDBファイルシステム領域をあらかじめ定義する必要があります。バックアップ格納先に登録されたディレクトリ、HiRDBファイルシステム領域は他の目的で使用することはできません。

  各バックアップファイルに対しての取得要素、方法、時間などの情報は、HiRDB CM Serverで管理情報として蓄積されます。同名のバックアップを取得した場合は、最新のバックアップ情報のみを保存します。これらの情報は、[バックアップ詳細情報]画面で参照可能です。

バックアップファイル名の命名規則には次の２種類があります。主に、バックアップ操作を[カタログ]として登録する場合に設定できます。

· [上書き]

指定したバックアップファイル名でバックアップ名を取得します。 バックアップカスタマイズ、バックアップウィザード画面から即時実行を行った場合はこの指定になります。

  バックアップ操作をカタログとして登録する場合、バックアップファイルの保存世代数の管理が必要のない時に、こちらのカタログを使用することをお勧めします。なお、NetBackupの場合は、必ずこちらを指定してください。

· [別名保存]

  指定したバックアップファイル名の後方にYYYYMMDDmmhhss形式で取得日時を追加してバックアップを取得します。そのため、バックアップファイル名は１５文字以内に指定する必要があります。「差分バックアップ」画面から即時実行を行った場合はこの指定になります。

  バックアップ操作をカタログとして登録する場合、バックアップファイルの世代を管理したい時に、こちらのカタログを使用するしてください。差分バックアップ操作をカタログとして登録する場合も、必ずこちらの指定になります。

l HiRDBファイルシステム領域単位のバックアップ/リカバリ機能

  上記までは、HiRDBのデータベース複写/回復ユティリティ（pdcopy/pdrstr)機能を使用して一般的なバックアップ/リカバリ機能について説明しました。HiRDB CMでは、HiRDBのpdfbkup/pdfrstrコマンドを使用し、HiRDBファイルシステム領域またはHiRDBファイル単位でバックアップ/リカバリを行う機能も提供しています。HiRDBファイルシステム領域/HiRDBファイル単位のバックアップ/リカバリを行う場合は、必ずHiRDBマニュアルに記述されたHiRDBファイルシステムのバックアップ/リカバリ運用を参照して、正しいを行ってください。また、HiRDB CMでは、運用を簡単にするため、複数の目的（RDエリア用、システムログ用、ステータスファイル用等）で使用しているHiRDBファイルシステム領域のバックアップを行うはできません。この場合は、HiRDBファイル単位でバックアップを取得してください。


バックアップ-カスタマイズの使用例

バックアップカスタマイズを使用してバックアップを取得する使用例を次に示します。

<手順>

1. バックアップ格納先ディレクトリを作成します。

2. バックアップカスタマイズ画面でバックアップを実行します。

3. バックアップファイルを確認します。

<条件>

· バックアップの対象はRDエリアとします。

· バックアップファイルは通常のファイルに取得します。

1. バックアップ格納先ディレクトリを作成します。

バックアップファイルを格納するディレクトリを定義します。

§ [タブメニュー] > [バックアップ] > [バックアップ格納先の登録/削除]をクリックし、バックアップ格納先登録画面を起動します。

§ バックアップ格納先登録画面でバックアップ格納先ディレクトリを作成します。

2. バックアップカスタマイズ画面でバックアップを実行します。

バックアップカスタマイズ画面を起動し、バックアップを実行します。

§ [タブメニュー] > [バックアップ] > [カスタマイズ]をクリックし、バックアップ-カスタマイズ画面を起動します。

§ バックアップカスタマイズ-取得単位タブ画面でRDエリアを選択します。

§ バックアップカスタマイズ-取得単位タブ画面で、ホスト名を指定しバックアップ取得先ボタンを押します。

§ バックアップ格納先の指定画面で、バックアップファイル名を指定し、OKボタンを押します。

§ バックアップカスタマイズ-取得モードタブ画面で、取得モードを設定します。

§ バックアップカスタマイズ-詳細設定タブ画面で、詳細設定をします。

§ バックアップカスタマイズ-確認タブ画面で指定された内容を確認してから、実行ボタンを押します。

§ バックアップ処理中画面が表示されます。

§ バックアップが終了すると結果が表示されます。

3. バックアップファイルを確認します。

バックアップファイルが正しく取得できていることを確認します。

§ [タブメニュー] > [バックアップ] > [バックアップファイルの表示/削除]をクリックし、バックアップファイルの表示/削除画面を起動します。

§ 対象のHiRDBシステムを選択し、取得したバックアップファイルを確認してください。


バックアップ-ウィザードの使用例

バックアップウィザードを使用してバックアップを取得する使用例を次に示します。

<手順>

1. バックアップ格納先ディレクトリを作成します。

2. ウィザード環境設定でオプションを指定します。

3. バックアップウィザード画面でバックアップを実行します。

4. バックアップファイルを確認します。

<条件>

· バックアップの対象を表T_SAMPLE１の全てのデータとします。

表T_SAMPLE1は、RD1、RD2からなる横分割表です。

インデクスI_SAMPLE1が定義されています。

インデクスT_SAMPLE1は、RD3、RD4に定義されています。

· バックアップファイルは通常のファイルに取得します。

1. バックアップ格納先ディレクトリを作成します。

バックアップファイルを格納するディレクトリを定義します。

§ [タブメニュー] > [バックアップ] > [バックアップ格納先の登録/削除]をクリックし、バックアップ格納先登録画面を起動します。

§ バックアップ格納先登録画面でバックアップ格納先ディレクトリを作成します。

2. ウィザード環境設定でオプションを指定します。

バックアップ-ウィザードの実行オプションの設定を行います。

§ [タブメニュー] > [バックアップ] > [ウィザード環境設定]をクリックし、ウィザード環境設定画面を起動します。

§ ウィザード環境設定画面で次に示す設定をデフォルトとして登録しておきます。

バックアップ取得モード　：　参照可能/更新不可能モード

処理結果出力ファイル　：　任意のファイル名を指定しておきます。

§ ウィザード環境設定画面を閉じます。

3. バックアップウィザード画面でバックアップを実行します。

バックアップウィザード画面を起動し、バックアップを実行します。

§ [タブメニュー] > [バックアップ] > [ウィザード]をクリックし、バックアップウィザード画面を起動します。

§ バックアップウィザード-処理対象の検索画面で表/インデクスを選択し、次へボタンを押します。

§ バックアップウィザード-表/インデクスの表示画面で表T_SAMPLE1を選択し、次へボタンを押します。

§ バックアップウィザード-関連するRDエリアの追加画面でインデクスの関係でRD３、RD４が表示されます。RD3、RD４もバックアップ対象RDエリアとして含めてから、次へボタンを押します。

§ バックアップウィザード-バックアップ取得先の指定画面で、ホスト名を指定しバックアップ取得先ボタンを押します。

§ バックアップ格納先の指定画面で、バックアップファイル名を指定し、OKボタンを押します。

§ バックアップウィザード-バックアップ取得先の指定画面で、次へボタンを押します。

§ バックアップウィザード-確認画面で指定された内容を確認してから、実行ボタンを押します。

§ バックアップ処理中画面が表示されます。

§ バックアップが終了すると結果が表示されます。

4. バックアップファイルを確認します。

バックアップファイルが正しく取得できていることを確認します。

§ [タブメニュー] > [バックアップ] > [バックアップファイルの表示/削除]をクリックし、バックアップファイルの表示/削除画面を起動します。

§ 対象のHiRDBシステムを選択し、取得したバックアップファイルを確認してください。


差分バックアップの使用例

差分バックアップ機能を使用してバックアップを取得する使用例を次に示します。

<手順>

1. バックアップ格納先ディレクトリを作成します。

2. 差分バックアップ管理ファイルを格納するHiRDBファイルシステム領域を作成します。

3. バックアップカスタマイズ画面で初めのフルバックアップを取得します。

4. 差分バックアップ画面で累積差分バックアップを実行します。

5. バックアップファイルを確認します。

<条件>

· ユーザ用RDエリア（RD1、RD2、RD3)に対して差分バックアップ機能を適用します。

· 差分バックアップグループ名は、backupg1とします。

1. バックアップ格納先ディレクトリを作成します。

バックアップファイルを格納するディレクトリを定義します。

§ [タブメニュー] > [バックアップ] > [バックアップ格納先の登録/削除]をクリックし、バックアップ格納先登録画面を起動します。

§ バックアップ格納先登録画面でバックアップ格納先ディレクトリを作成します。

2. 差分バックアップ管理ファイルを格納するHiRDBファイルシステム領域を作成します。

差分バックアップ管理ファイル用のHiRDBファイルシステム領域を作成します。

§ [タブメニュー] > [マップ] > [HiRDBファイルシステム領域]をクリックし、HiRDBファイルシステム領域マップ画面を起動します。

§ HiRDBファイルシステム領域マップ画面で対象のシステムとマネージャノードのホストを選択します。

§ 「HiRDBファイルシステム領域の追加」ボタンを選択し、「HiRDBファイルシステム領域の初期設定/登録」画面を起動します。

§ 「HiRDBファイルシステム領域の初期設定/登録」画面で、HiRDBファイルシステム領域を作成します。

    ※「使用目的」はユティリティ用に設定してください。

    ※サイズは、HiRDBのマニュアルを参考にして見積りを行ってください。

3. バックアップカスタマイズ画面で初めのフルバックアップを取得します。

バックアップカスタマイズ画面を起動し、最初のフルバックアップを取得し、差分バックアップグループを作成します。

§ [タブメニュー] > [バックアップ] > [カスタマイズ]をクリックし、バックアップ-カスタマイズ画面を起動します。

§ バックアップカスタマイズ-取得単位タブ画面でRDエリアを選択します。

§ バックアップカスタマイズ-取得単位タブ画面で、ホスト名を指定しバックアップ取得先ボタンを押します。

§ バックアップ格納先の指定画面で、バックアップファイル名を指定し、OKボタンを押します。

§ バックアップカスタマイズ-取得モードタブ画面で、取得モードを設定します。

§ バックアップカスタマイズ-差分バックアップタブ画面で、差分バックアップ情報を設定します。

    「差分バックアップグループ」にbackupg1と指定します。

    「管理ファイルを格納するHiRDBファイルシステム領域名」に手順２で作成したHiRDBファイルシステム領域名を選択します。

    その他のオプションは必要に応じて設定してください。

§ バックアップカスタマイズ-詳細設定タブ画面で、詳細設定をします。

§ バックアップカスタマイズ-確認タブ画画面で指定された内容を確認してから、実行ボタンを押します。

§ バックアップ処理中画面が表示されます。

§ バックアップが終了すると結果が表示されます。

この操作は、バックアップウィザードでも行うことができます。

4. 差分バックアップ画面で累積差分バックアップを実行します。

差分バックアップ画面を起動し、累積差分バックアップを取得します。

§ [タブメニュー] > [バックアップ] > [差分バックアップ]をクリックし、差分バックアップ画面を起動します。

§ 差分バックアップ画面で次に示す項目を選択します。

    HiRDBシステムリストで対象のHiRDBシステムを選択します。

    差分バックアップグループリストでbackupg1を選択します。

    取得モードに前回からの累積差分バックアップを指定します。

§ 差分バックアップ画面でバックアップ取得先ボタンを押します。

§ バックアップ格納先の指定画面で、バックアップファイル名を指定し、OKボタンを押します。

§ 差分バックアップ画面で実行ボタンを押します。

§ バックアップ処理中画面が表示されます。

§ バックアップが終了すると結果が表示されます。

5. バックアップファイルを確認します。

バックアップファイルが正しく取得できていることを確認します。

§ [タブメニュー] > [バックアップ] > [バックアップ詳細情報]をクリックし、バックアップ詳細情報画面を起動します。

§ 「表示対象」に差分バックアップを選択し、差分バックアップグループ（backupg1）を選択して次へボタンを押します。

§ バックアップ詳細情報画面でバックアップファイルの情報を確認してください。


NetBackupの使用例

NetBackupを使用してバックアップを取得する使用例を次に示します。

<手順>

1. NetBackup用Agentをインストールします。

2. HiRDB CM Agentの設定ファイルを変更します。

3. NetBackupポリシを作成します。

4. バックアップカスタマイズ画面で初めのバックアップを実行します。

5. NetBakcup画面で二回目以降のバックアップを実行します。

6. バックアップ結果を確認します。

※手順２は、HiRDB CM Agentインストール時にNetBackup連携登録を行っている場合は不要です。

<条件>

· HiRDBのNetBackup連携機能のための設定が全て終わってることを前提にしています。

· NetBackupでストレージデバイス、ボリュームの設定が終わっていることを前提にしてます。

HiRDBのNetBakcup連携の設定方法は、マニュアル「JP１/VERITAS NetBackup v4.5 Agent for HiRDB License」を参照してください。

1. NetBackup用Agentをインストールします。

NetBackup用AgentをNetBackupマスタサーバとして稼動するマシンにインストールします。

§ NetBackup用Agentをインストールします。

  インストール方法は、下記のリンクを参照してください。

NetBackupAgentのインストール/アンインストール方法

一度インストールを行えば、この操作を行う必要はありません。

2. HiRDB CM Agentの設定ファイルを変更します。

HiRDB用CM AgentとNetBackup用CM Agentとの連携をHiRDB用CM Agentインストール時に設定を行っていない場合に設定します。通常は、HiRDB用CM Agentインストール時に設定を行ってください。

§ Windowsの場合は、[スタートメニュー]からHiRDBコマンドプロンプトを起動します。UNIXの場合は、HiRDB用の環境変数を設定したプロンプトを用意します。

§ 次に示すコマンドを実行しNetBackupクライアントのハードディスク名を設定します。

    {HiRDBインストールディレクトリ}\CMAgent\bin\cmrconf -c NetBackupClientHardeare ハードウェア名

§ 次に示すコマンドを実行しNetBackupクライアントのOS名を設定します。

    {HiRDBインストールディレクトリ}\CMAgent\bin\cmrconf -c NetBackupClientOS OS名

§ 次に示すコマンドを実行しNetBackup用CM AgentのIPとポート番号を登録します。

    {HiRDBインストールディレクトリ}\CMAgent\bin\cmrconf -c NetBackupAgentIP NetBackuo用AgentのIPアドレス

    {HiRDBインストールディレクトリ}\CMAgent\bin\cmrconf -c NetBackupAgentPort NetBackuo用Agentのポート番号

§ 次に示すコマンドを実行しNetBackup用CM Agentの連携設定を有効にします。

    {HiRDBインストールディレクトリ}\CMAgent\bin\cmrconf -c NetBackup 1

※HiRDBがパラレルサーバの場合、NetBackupクライアントがインストールされているユニット上で設定を行ってください。

※NetBackupクライアントのハードウェアとOSは、ポリシの作成時に使用される情報です。指定する項目は、NetBackupマスタサーバを参照してください。

3. NetBackupポリシを作成します。

HiRDB CM ConsoleのNetBackup画面を起動してポリシを作成します。

§ [タブメニュー] > [バックアップ] > [NetBackup]をクリックし、NetBackup画面を起動します。

§ NetBackup画面で対象のHiRDBシステムを選択して、ポリシーの作成ボタンを押し、NetBackupポリシ作成画面を起動します。

§ NetBackupポリシ作成画面で、次に示す設定を行い、実行ボタンを押してポリシを作成します。

ポリシ名　：　任意の名前を指定します。

ストレージユニット名　：　NetBackupマスタサーバで設定したストレージユニット名を指定します。

NetBackupクライアントホスト名　：　NetBackupクライアントがインストールされているホスト名を指定します。

4. バックアップカスタマイズ画面で初めのバックアップを実行します。

バックアップカスタマイズ画面を起動して初めのバックアップを行います。

§ [タブメニュー] > [バックアップ] > [カスタマイズ]をクリックし、バックアップカスタマイズ画面を起動します。

§ バックアップカスタマイズ-取得単位タブ画面でRDエリアを選択します。

§ バックアップカスタマイズ-取得単位タブ画面でファイル種別にNetBackupを指定します。

§ バックアップカスタマイズ-取得単位タブ画面でファイル種別にNetBackupを指定します。

§ バックアップカスタマイズ-取得モードタブ画面で、ポリシー名に手順３で作成したポリシーを選択します。

§ バックアップカスタマイズ-詳細設定タブ画面で、詳細設定をします。

§ バックアップカスタマイズ-確認タブ画面で指定された内容を確認してから、実行ボタンを押します。

§ バックアップ処理中画面が表示されます。

§ バックアップが終了すると結果が表示されます。

この操作は、バックアップウィザードでも行うことができます。

5. NetBakcup画面で二回目以降のバックアップを実行します。

HiRDB　CM　ConsoleのNetBackup画面を起動して二回目以降のバックアップを行います。

§ [タブメニュー] > [バックアップ] > [NetBackup]をクリックし、NetBackup画面を起動します。

§ NetBackup画面で対象のHiRDBシステム、ポリシを選択して実行ボタンを押します。

§ バックアップ処理中画面が表示されます。

§ バックアップが終了すると結果が表示されます。

6. バックアップ結果を確認します。

バックアップが正しく取得できていることを確認します。

§ [タブメニュー] > [バックアップ] > [バックアップファイルの表示/削除]をクリックし、バックアップファイルの表示/削除画面を起動します。

§ 対象のHiRDBシステムを選択し、取得したバックアップファイルを確認してください。


リカバリ-カスタマイズの使用例

リカバリカスタマイズを使用してデータベースを回復する運用について、次の３種類のリカバリについて使用例を紹介します。

1. バックアップ取得時点に回復する方法

2. HiRDB CMで取得したアンロードログファイルを使用して任意の同期点に回復する方法

3. 自動ログアンロード機能を使用しているHiRDBに対して、最新の同期点に回復する方法

1. バックアップ取得時点に回復する方法

リカバリカスタマイズを使用して、バックアップ取得時点にデータベースの状態を回復する使用例を次に示します。

<手順>

1. バックアップファイルを確認します。

2. リカバリ-カスタマイズ画面でリカバリを実行します。

1. バックアップファイルを確認します。

バックアップ詳細情報画面を起動し使用するバックアップファイルを決定します。

§ [タブメニュー] > [バックアップ] > [バックアップ詳細情報]をクリックし、バックアップ詳細情報画面を起動します。

§ バックアップ詳細情報画面で、回復したい対象を選択し、次へボタンを押します。

§ バックアップ詳細情報画面に表示されるバックアップファイルから、使用するバックアップファイルを決定します。

2. リカバリ-カスタマイズ画面でリカバリを実行します。

リカバリカスタマイズ画面を起動してリカバリを実行します。

§ [タブメニュー] > [リカバリ] > [カスタマイズ]をクリックし、リカバリカスタマイズ画面を起動します。

§ リカバリカスタマイズ－回復単位タブ画面で、回復対象を選択します。

§ リカバリカスタマイズ－バックアップファイルタブ画面で、ホスト名を選択し、バックアップファイルの指定ボタンを押します。

§ バックアップファイルの指定画面で、手順１で決定したバックアップファイルを選択し、OKボタンを押します。

§ リカバリカスタマイズ－詳細設定タブ画面で、処理結果出力ファイル名を設定します。

§ リカバリカスタマイズ－確認タブ画面で、設定した内容を確認して、実行ボタンを押します。

§ リカバリ処理中画面が表示されます。

§ リカバリが終了すると結果が表示されます。

2. HiRDB CMで取得したアンロードログファイルを使用して任意の同期点に回復する方法

リカバリカスタマイズを使用して、HiRDB　CMで取得したアンロードログファイルを使用してデータベースを任意の同期点に回復する使用例を次に示します。

<手順>

1. バックアップファイルを確認します。

2. リカバリ-カスタマイズ画面でリカバリを実行します。

<条件>

· バックアップ取得後から現在までの全てのアンロードログファイルをHiRDB CMで取得している必要があります。

· リカバリを行う全ての回復対象が１つのホスト上にある必要があります。

1. バックアップファイルを確認します。

バックアップ詳細情報画面を起動し使用するバックアップファイルを決定します。

§ [タブメニュー] > [バックアップ] > [バックアップ詳細情報]をクリックし、バックアップ詳細情報画面を起動します。

§ バックアップ詳細情報画面で、回復したい対象を選択し、次へボタンを押します。

§ バックアップ詳細情報画面に表示されるバックアップファイルから、使用するバックアップファイルを決定します。

2. リカバリ-カスタマイズ画面でリカバリを実行します。

リカバリカスタマイズ画面を起動してリカバリを実行します。

§ [タブメニュー] > [リカバリ] > [カスタマイズ]をクリックし、リカバリカスタマイズ画面を起動します。

§ リカバリカスタマイズ－回復単位タブ画面で、回復対象を選択します。

§ リカバリカスタマイズ－回復単位タブ画面で、使用ファイルにバックアップファイル＋ログファイルを選択します。

§ リカバリカスタマイズ－バックアップファイルタブ画面で、ホスト名を選択し、バックアップファイルの指定ボタンを押します。

§ バックアップファイルの指定画面で、手順１で決定したバックアップファイルを選択し、OKボタンを押します。

§ リカバリカスタマイズ－ログファイルタブ画面で、使用するログファイルに手動でアンロードしたアンロードログファイルを指定します。

§ リカバリカスタマイズ－ログファイルタブ画面で、回復指定時間を設定します。

§ リカバリカスタマイズ－ログファイルタブ画面で、ホスト名を選択し、アンロードログファイルの指定ボタンを押します。

§ アンロードログファイル指定画面で、必要なアンロードログファイルを順番に指定します。

手順１で表示したバックアップ情報画面のシステムログ情報リストで表示されたシステムログファイル以降のアンロードログファイルを全て指定してください。

指定するアンロードログファイルの順番は、世代とランIDを参考に世代の古いものから順に指定してください。順番が違う場合エラーとなります。

§ リカバリカスタマイズ－詳細設定タブ画面で、処理結果出力ファイル名を設定します。

§ リカバリカスタマイズ－確認タブ画面で、設定した内容を確認して、実行ボタンを押します。

§ リカバリ処理中画面が表示されます。

§ リカバリが終了すると結果が表示されます。

  HiRDBのバージョンがv0702以降の場合は、アンロードログファイル格納先ディレクトリを指定することできます。ディレクトリを指定する場合は、アンロードログファイルを順番に指定する必要がありません。

3. 自動ログアンロード機能を使用しているHiRDBに対して、最新の同期点に回復する方法

リカバリカスタマイズを使用して、HiRDBの自動ログアンロ－ド機能で取得したアンロードログファイルを使用してデータベースを最新の同期点に回復する使用例を次に示します。

<手順>

1. バックアップファイルを確認します。

2. システムログファイルをスワップします。

3. リカバリ-カスタマイズ画面でリカバリを実行します。

<条件>

· リカバリを行う全ての回復対象が１つのホスト上にある必要があります。

1. バックアップファイルを確認します。

バックアップ詳細情報画面を起動し使用するバックアップファイルを決定します。

§ [タブメニュー] > [バックアップ] > [バックアップ詳細情報]をクリックし、バックアップ詳細情報画面を起動します。

§ バックアップ詳細情報画面で、回復したい対象を選択し、次へボタンを押します。

§ バックアップ詳細情報画面に表示されるバックアップファイルから、使用するバックアップファイルを決定します。

2. システムログファイルをスワップします。

現在のシステムログファイルに記載された内容をリカバリの結果に反映するために、システムログファイルをスワップし、自動ログアンロード機能によって、アンロードログファイルを取得します。

§ [タブメニュー] > [システムログ管理] > [システムログのスワップ]をクリックし、システムログのスワップ画面を起動します。

§ システムログのスワップ画面で、回復対象のサーバのシステムログファイルを選択し、実行ボタンを押します。

§ システムログのスワップ処理中画面が表示されます。

§ システムログのスワップが終了すると結果が表示されます。

この操作は、手順１で表示したバックアップ詳細情報画面のシステムログ情報リストに表示された全てのサーバに対して行ってください。

3. リカバリ-カスタマイズ画面でリカバリを実行します。

リカバリカスタマイズ画面を起動してリカバリを実行します。

§ [タブメニュー] > [リカバリ] > [カスタマイズ]をクリックし、リカバリカスタマイズ画面を起動します。

§ リカバリカスタマイズ－回復単位タブ画面で、回復対象を選択します。

§ リカバリカスタマイズ－回復単位タブ画面で、使用ファイルにバックアップファイル＋ログファイルを選択します。

§ リカバリカスタマイズ－バックアップファイルタブ画面で、ホスト名を選択し、バックアップファイルの指定ボタンを押します。

§ バックアップファイルの指定画面で、手順１で決定したバックアップファイルを選択し、OKボタンを押します。

§ リカバリカスタマイズ－ログファイルタブ画面で、使用するログファイルに自動ログアンロード機能で取得したアンロードログファイルを指定します。

§ リカバリカスタマイズ－詳細設定タブ画面で、処理結果出力ファイル名を設定します。

§ リカバリカスタマイズ－確認タブ画面で、設定した内容を確認して、実行ボタンを押します。

§ リカバリ処理中画面が表示されます。

§ リカバリが終了すると結果が表示されます。


リカバリ-ウィザードの使用例

リカバリウィザードを使用して任意の同期点にデータベースを回復する使用例を次に示します。

<手順>

1. リカバリ-ウィザード画面でリカバリを実行します。

1. リカバリ-ウィザード画面でリカバリを実行します。

リカバリカスウィザード画面を起動してリカバリを実行します。

§ [タブメニュー] > [リカバリ] > [ウィザード]をクリックし、リカバリウィザード画面を起動します。

§ リカバリウィザード－回復単位指定画面で、回復対象を選択します。

§ リカバリウィザード－回復単位指定画面で回復指定時間を設定し、次へボタンを押します。

§ リカバリウィザード－確認画面で表示される内容を確認して、実行ボタンを押します。

§ リカバリ処理中画面が表示されます。

§ リカバリが終了すると結果が表示されます。


IOSのバックアップ/リカバリ使用例

HiRDBファイルシステム領域単位のバックアップ/リカバリの使用例

  HiRDBファイルシステム領域単位のバックアップ/リカバリ機能を使用して、rawファイルとして使用しているHiRDBファイルシステム領域の拡張を行う方法を紹介します。

<手順>

1. HiRDBを正常停止します。

2. バックアップファイル格納先のディレクトリを作成します。

3. HiRDBファイルシステム領域のバックアップを取得する

4. rawファイルとして使用していたデバイスの構成を変更します。

5. HiRDBファイルシステム領域の初期化を行います。

6. HiRDBファイルシステム領域のリカバリを行います。

7. HiRDBを正常開始します。

<条件>

· 対象とするHiRDBファイルシステム領域に含まれるHiRDBファイルは全て同じ使用方法であることとします。

1. HiRDBを正常停止します。

対象のHiRDBシステムを正常停止します。前回に強制停止を行っていて現在、HiRDBが停止中の場合は、一度HiRDBを正常開始したあと、再度正常停止を行ってください。

§ [タブメニュー] > [システムステータス] で対象のHiRDBシステムをクリックし、システムステータス画面を起動します。

§ システムステータス画面で、正常停止ボタンをクリックし、対象のHiRDBシステムを正常停止します。

2. バックアップファイル格納先のディレクトリを作成します。

バックアップファイルを格納するディレクトリを定義します。

§ [タブメニュー] > [バックアップ] > [バックアップ格納先の登録/削除]をクリックし、バックアップ格納先登録画面を起動します。

§ バックアップ格納先登録画面でバックアップ格納先ディレクトリを作成します。

  HiRDBファイルシステム領域単位のバックアップでは、HiRDBファイルシステム領域のあるマシン上にあるディレクトリを格納先としてしようする必要があります。

3. HiRDBファイルシステム領域のバックアップを取得する。

HiRDBファイルシステム領域のバックアップを取得します。

§ [タブメニュー] > [バックアップ] > [HiRDBファイルシステム領域単位のバックアップ]をクリックし、HiRDBファイルシステム領域単位のバックアップ画面を起動します。

§ HiRDBファイルシステム領域単位のバックアップ画面で、対象のHiRDBシステム、ホスト、HiRDBファイルシステム領域名を選択します。

§ HiRDBファイルシステム領域単位のバックアップ画面で、バックアップファイル格納先ディレクトリを選択してバックアップファイル名を入力します。

§ HiRDBファイルシステム領域単位のバックアップ画面で、指定された内容を確認してから、実行ボタンを押します。

§ バックアップ処理中画面が表示されます。

§ バックアップが終了すると結果が表示されます。

4. rawファイルとして使用していたデバイスの構成を変更します。

  rawファイルとして使用していたデバイスの構成を変更します。この操作はHiRDB CMから行うことはできません。各OSのマニュアルまたは、HiRDBのマニュアルを参考に設定を行ってください。変更後のディスクの容量は変更前のディスクの容量より大きいものを設定してください。シンボリックリンクを使用した運用を行っている場合は、シンボリックリンクを変更してください。また、権限を正しく設定してください。

5. HiRDBファイルシステム領域の初期化を行います。

HiRDB CMで記憶している変更前のHiRDBファイルシステム領域の情報を削除したあと、HiRDBファイルシステム領域の再初期化を行います。

§ [タブメニュー] > [マップ] > [HiRDBファイルシステム領域]をクリックし、HiRDBファイルシステム領域マップ画面を起動します。

§ HiRDBファイルシステム領域マップ画面で、対象のHiRDBシステム、HiRDBファイルシステム領域を選択し、HiRDBファイルシステム領域の削除ボタンを押します。

§ HiRDBファイルシステム領域マップ画面で、HiRDBファイルシステム領域の追加ボタンを押し、HiRDBファイルシステム領域の初期設定/登録画面を起動します。

§ HiRDBファイルシステム領域の初期設定/登録画面必要な情報を入力し、登録ボタンを押し、HiRDBファイルシステム領域を作成します。

6. HiRDBファイルシステム領域のリカバリを行います。

再作成したHiRDBファイルシステム領域に対してリカバリを行い、HiRDBファイルシステム領域の情報を回復します。

§ [タブメニュー] > [リカバリ] > [HiRDBファイルシステム領域単位のリカバリ]をクリックし、HiRDBファイルシステム領域単位のリカバリ画面を起動します。

§ HiRDBファイルシステム領域単位のリカバリ-回復単位タブ画面で、対象のHiRDBシステム、ホスト、HiRDBファイルシステム領域名を選択します。

§ HiRDBファイルシステム領域単位のリカバリ-回復単位タブ画面で、バックアップファイルの指定ボタンをクリックし、バックアップファイルを選択します。

§ HiRDBファイルシステム領域単位のリカバリ-詳細設定タブ画面で、処理方針を選択します。

§ HiRDBファイルシステム領域単位のリカバリ-確認タブ画面で、指定された内容を確認してから、実行ボタンを押します。

§ リカバリ処理中画面が表示されます。

§ リカバリが終了すると結果が表示されます。

7. HiRDBを正常開始します。

HiRDBを正常開始します。

§ [タブメニュー] > [システムステータス] で対象のHiRDBシステムをクリックし、システムステータス画面を起動します。

§ システムステータス画面で、正常開始ボタンをクリックし、対象のHiRDBシステムを正常開始します。


カタログ/スケジュール機能

カタログ/スケジュール

この章では、HiRDB CMのカタログ/スケジュールについて説明します。後半で、スケジュール機能の使用例の紹介します。

l カタログ

  カタログとは、一連の操作を記憶し、それをカタログとして登録することで何度も繰り返し実行できる、HiRDB CM独自の機能です。カタログ登録は次のような操作の場合にお勧めします。

· 同じコマンドを繰り返し実行する場合

· スケジュール機能を使用して、自動でコマンドの実行を時間指定したい場合

· 自動データメンテナンス機能の自動対処として動作を行う場合

· JP1/AJS2カスタムジョブ連携でJP1/AJS2のジョブとして使用する場合

· JP1/AJS2カタログ実行連携でHiRDB CM Serverに対してCLIで実行を行いたい場合

  HiRDB　CMでは、次の操作をカタログとして登録することができます。

· バックアップ機能

· リカバリ機能

· 再編成機能

· データロード機能

· システムログファイル操作機能

· ステータスファイル操作機能

· 空きページ解放機能

  カタログの作成は、各ユティリティ実行画面から登録が行えます。また、カタログ名には、64文字までの英数字が使用でき、各カタログ名は、HiRDB CMシステム内でユニークな名前にする必要があります。

l スケジュール

  スケジュールとは、カタログを指定した時間に自動で実行する機能です。スケジュールの実行契機として次に示す間隔を指定することができます。

· 日時時間指定（１回の実行）

  指定した日時に対象のカタログを一度だけ実行します。実行後に、登録したスケジュールは自動的に削除されます。

· 時間指定による、毎日の実行

  指定した実行時刻に毎日、対象のカタログを実行します。

· 曜日指定による、毎週の実行

  実行時刻と複数の曜日を指定し、毎週指定した曜日に対象のカタログを実行します。

· 日時指定による、毎月の実行

  実行時刻と複数の日を指定し、毎月指定した日に対象のカタログを実行します。30、31日など月によっては存在しない日時を指定した場合、その日がない月は実行が見送られます。

  毎日の実行、毎週の実行、毎月の実行でスケジュールを登録する場合、有効範囲日時の指定を行うことができます。

  スケジュール登録は、カタログが実行される時間に対象のHiRDBが正常起動されている時間を指定する必要があります。カタログ実行時に対象のHiRDBが停止していた場合、カタログの処理が失敗します。また、カタログが実行される時間に対象のマシンが停止してた場合、カタログの実行が見送られます。マシンが再起動されても見送られたスケジュールは実行されません。

  スケジュールの情報は、HiRDB CM Agent上で管理されます。そのため、HiRDB CM Serverが停止したり、アンインストールしていてもスケジュールは動作したままになります。不要になったスケジュールは、必ずスケジュールの削除を行う必要があります。

  UNIX版HiRDBを対象にしてスケジュール機能では、crontabコマンドを使用します。そのため、HiRDB Control Manager - Agentセットアップ時に指定したHiRDB管理者ID (ログインユーザ) に対してcrontabコマンドを実行できるように登録する必要があります。

HiRDB　CMのスケジュール機能では、時間指定以外の実行契機を指定することはできません。例えば、バックアップを行ったあと、その結果に応じて再編成を行うなどの運用をスケジュールする場合は、JP1/AJS2連携を使用してください。

l スケジュール使用例

  次にて定期的なバックアップをHiRDB CMのスケジュールを用いて行う運用をスケジュール機能を使用して行う例を紹介します。

<手順>

1. バックアップ用のカタログを作成します。

2. スケジュール追加画面でスケジュールを登録します。

3. スケジュールの実行結果を確認します。

<運用条件>

· 日曜日はメンテナンス日とした運用を想定します。

· 月曜から土曜日のオンライン業務が終了した後（20:00）に業務データが格納されているRDエリアのバックアップを行います。

· 毎週日曜日にオンライン業務が終了した後（20:00）にHiRDBシステム全体のバックアップを行います。

· 毎日取得したバックアップは世代管理をしません。

· 毎週日曜日に取得したバックアップはすべての世代を保存します。

1. バックアップ用のカタログを作成します。

  システム全体のバックアップカタログと業務データのバックアップカタログを作成します。

§ [タブメニュー] > [バックアップ] > [バックアップ格納先の登録/削除]をクリックし、バックアップ格納先登録画面を起動します。

§ バックアップ格納先登録画面でバックアップ格納先ディレクトリを作成します。

§ [タブメニュー] > [バックアップ] > [ウィザード]をクリックし、バックアップウィザード画面を起動します。

§ バックアップウィザード画面で業務表を指定したバックアップカタログを作成します。カタログ作成時に「上書き」を選択します。

§ バックアップウィザード画面でシステムを指定したバックアップカタログを作成します。カタログ作成時に「別名保存」を選択します。

2. スケジュールの追加画面でスケジュールの登録をします。

  スケジュールの追加画面でスケジュールの登録をします。

§ [タブメニュー] > [スケジュール] > [スケジュールの追加]をクリックして、スケジュールウィザード画面を起動します。

§ スケジュール追加画面でシステム全体のバックアップカタログを毎週日曜日、20:00を指定して登録します。

§ スケジュール追加画面で業務データのバックアップカタログを毎週月～土曜日、20:00を指定して登録します。

§ [タブメニュー] > [スケジュール] > [スケジュールの状況確認]をクリックして、スケジュールの状況確認画面を起動します。

§ スケジュールの状況確認画面で、スケジュールが正しく登録されたことを確認します。

3. スケジュールの実行結果を確認します。

  スケジュールが実行された後、スケジュールの実行結果を確認します。

§ [タブメニュー] > [スケジュール] > [スケジュールの状況確認]をクリックして、スケジュールの状況確認画面を起動します。

§ スケジュールの状況確認画面で、スケジュールの結果を確認したい日に対して右クリックを行い、表示されたメニューからスケジュール実行結果をクリックし、カタログ実行結果情報画面を起動します。

§ カタログ実行結果画面で、カタログの実行結果を確認します。


データベース状態解析機能

データベース状態解析

この章では、データベース状態解析について説明します。また、後半では、使用例を紹介します。

l データベース状態解析

  データベース状態解析とは、データベースの実データの分布を視覚的に表示する機能です。表/インデクスの解析を行う場合は、その表データまたは、インデクス情報が格納されているRDエリアごとに実データ部分の分布を表示します。これは、RDエリア全てのデータの分布ではありません。たとえば、あるRDエリアに表１と表２が格納されている構成で、表１に対して状態解析機能を使用した場合は、対象のRDエリアの表１が使用している部分についての実データの分布を表示します。表２が使用している部分の分布の表示は行いません。RDエリアの解析を行う場合は、RDエリア上に定義されている表、インデクスごとにデータの分布を表示します。RDエリアの全体の容量を確認する場合は、RDエリアマップのセグメント使用率を確認してください。

  次にRDエリアのセグメントとページについて簡単に説明します。詳細は、HiRDBのマニュアルを参照してください。

§ セグメント

  表及びインデクスのデータを格納する最小単位です。1セグメントには、一つの表又は一つのインデクスのデータだけが格納されます。連続した複数ページから構成されています。RDエリアに表のデータを定義する場合、１セグメントずつ領域を確保します。データの削除が一度も行われていない状態では、１つのセグメントに格納できるデータが満杯になった時点で、次のセグメントを確保します。

§ ページ

  データベースの入出力処理の最小単位です。ページ長を大きくすると、連続した行を同一ページ内に格納できるため、データを連続して処理する場合に入出力回数を削減できます。１セグメント内に含まれるページ数をセグメントサイズと呼びます。

  最も簡単な例をあげてページとセグメントの確保の流れを説明します。

  「ある表に初めてデータを挿入する場合、まず１つのセグメントをを確保します。確保したセグメントの中から１つのページを取得します。そのページにデータを書き込みます。もし、そのページにデータが格納しきれない場合、次のページを取得します。これを繰り返し確保したセグメントの中の全てのページを使い切った場合、次のセグメントを確保します。」

  途中でデータの削除が発生した、表のデータ型による特殊な格納方法など、さまざまな要因からここで説明した順番で確保されないケースがたくさんあります。ここでは、簡単にセグメントとページの役割を知ってもらうために簡単な説明を行いました。詳細については、HiRDBのマニュアルを参照してください。

  データベース状態解析機能では、実データの分布をグラフ（ページ使用状態グラフ）で表現します。ページ使用状態グラフは次に示す情報の集合です。

  横軸：使用セグメント内のページ　セグメントごとに連続した情報です。

  縦軸：ページ使用率

  赤：ページ内の実データ部分

  緑：使用空きページ（ページ内の未使用部分）

  黄：未使用ページ（未確保ページ）

  横軸のスケールは、使用セグメント数により表示単位を自動的に調整されます。あるページが50％使用されている場合、そのページの情報は、下半分が赤色で表示され、上半分が緑色で表示されます。ページに実データが何もない場合は、緑色、100%データが格納されている場合は赤色で表示されます。未使用ページとはセグメントとして確保されているが、ページとしてはまだ確保されていないページです。つまり、黄色で表示されたページは一度もデータが挿入されたことのないページであり、緑色のみで表示された部分は、一度データが挿入されてから、そのデータが削除されたページ（他の要因でも発生する場合があります）を示します。

  ページ使用状況情報が、10,000ページ以上ある場合、サンプリングによって取得したデータを表示します。これは、全てのページについて表示してもここの値に意味はなく、統計情報として捉えることで視覚的にわかりやすくするためです。また、平滑化処理を行った場合、ページの使用状況が平均化されるためユーザが直感的に乱れ情報として認識しにくくなる可能性があるため、単純なサンプリングのみを行った結果が表示されます。サンプリングによって読み飛ばされた値は表示されるデータには含まれません。

  ページ使用状態グラフの傾向と実データの関連について説明します。

＜使用空きページによる影響をグラフで表示した例＞

使用空きページによる影響は次の図のような状態で表示されます。

  セグメント４は、実際にページにデータを格納していない(未使用)状態ですが、選択されたオブジェクトが過去にセグメントを確保したためセグメントを所持し続けていることを示し、これにより他のオブジェクトがそのセグメントを使用できないことを示しまします。この状況は、インデクスを解析対象にした場合によく見られる現象であり、表情報が削除されたなど実際に使用していないリーフがある場合に顕著に見られる状態です。

  この状態に対して空きページ解放を実行すると次のような状態表示となり、セグメント４が解放されたことが確認できます。

＜低使用率ページによる乱れをグラフで表示した例＞

１ページ当たりのデータ格納率が低く、データ格納効率が低下していることが視覚的に表現されています。

この状態に対して再編成を実行すると次のような表示となります。また、上図のセグメント４は、再編成によりセグメントを開放したので表示されません。

＜PCTFREEによる乱れをグラフで表示した例＞

解析対象の表にPCTFREEが設定されている場合、次のようにPCTFREE値により、ページ使用率が詰まっていないグラフが表示されます。

これは、HiRDBがアクセス効率、使用効率を向上するために設定された値が表現されているだけでありデータ格納上、データ格納効率は正常な状態と判断できます。

＜使用セグメント数が多い場合の乱れをグラフで表示した例＞

使用セグメント多い場合、セグメントごとに着目してページ使用効率を判断できない場合があります。この場合、次のようなグラフを表示します。

このように多くのセグメントで、ページ格納率に大きな乱れが表現されている場合は、解析した表に対する再編成を行う必要があると判断できます。

l データベース状態解析の使用例

  データベース状態解析を使用してデータベースの状態を解析する使用例を次に示します。

<手順>

1. データベース状態解析環境設定を行います。

2. データベース状態解析画面で表の状態を解析します。

3. 解析結果から対処を行います。

4. 対処後の状態を確認します。

<条件>

· HiRDBが正常に起動していることを確認してあります。

· 表単位で解析を行います。

· RDエリアの容量は十分にあることが確認されています。

· 業務時間外であり、即時対策を実行できる環境であることとします。

1. データベース状態解析環境設定を行います。

データベース状態解析で一時的に使用するデータファイルの格納先ディレクトリを設定します。この一時データは、おおよそ解析対象の全ページの合計数×1Byteの大きさになります。解析対象のデータが大きい場合、十分なサイズのディレクトリを指定してください。

§ [タブメニュー] > [データメンテナンス] > [データベース状態解析環境設定]をクリックし、データベース状態解析ユティリティ環境設定画面を起動します。

§ データベース状態解析ユティリティ環境設定画面で、対象のHiRDBシステムを選択し全てのサーバごとにディレクトリを指定します。

§ 「登録」ボタンを押して、変更内容を登録します。

  この設定を行わない場合、HiRDBインストールディレクトリの下に一時データファイルが作成されます。

  指定するディレクトリは対象のサーバが存在するマシン上のディレクトリを指定してください。系切り替え構成の場合は、対象のサーバが起動しているマシンに存在するディレクトリを指定してください。影響負荷分散型系切り替えの場合は、実行前に対象サーバの状態によって出力されるマシンが変更されるので注意してください。

2. データベース状態解析画面で表の状態を解析します。

  データベース状態解析画面で表の状態を解析します。

§ [タブメニュー] > [データメンテナンス] > [データベース状態解析]をクリックし、データベース状態解析画面を起動します。

§ データベース状態解析画面で、対象のHiRDBシステムと表を選択します。

§ データベース状態解析画面のICONボタンの中から「状態解析」ボタンをクリックし、データベース状態解析を実行します。

§ データベース状態解析実行中ダイアログが表示され、データベース状態解析が開始されます。

§ データベース状態解析終了すると、データベース状態解析画面に結果が表示されます。

3. 解析結果から対処を行います。

  データベース状態解析画面の解析解析結果を参照し、対策を行います。

§ 解析結果を参照し、対策方法の決定を行います。

解析結果と対策方法の決定は、上記で説明したページ使用状態グラフの傾向と実データの関連について説明を参考にして決定してください。

§ 対策に対応する画面を呼び出します。

アイコンボタンの中から対策を行うための画面を呼び出してください。再編成を行う場合は、事前にバックアップを取得するなど、HiRDBのマニュアルで推奨されている運用方法に従うようにしてください。対処画面での操作方法は、各画面の説明を参考にしてください。

4. 対処後の状態を確認します。

  対策が終わったあとで、データベース状態解析画面で再度、表の状態を解析します。

§ データベース状態解析画面のICONボタンの中から「状態解析」ボタンを再度クリックし、データベース状態解析を実行します。

§ データベース状態解析実行中ダイアログが表示され、データベース状態解析が開始されます。

§ データベース状態解析終了すると、データベース状態解析画面に結果が更新されます。


自動データメンテナンス機能

自動データメンテナンス

この章では、自動データメンテナンスについて説明します。また、後半では、使用例を紹介します。

l 自動データメンテナンス

  自動データメンテナンスとは、HiRDBシステムが提供するデータベース再編成時期予測機能(pddbst)コマンドを用いて、運用統計情報から各RDエリアで容量不足が発生する時期を予測た解析結果情報を元に警告表示または、一部処理において自動的に対処を行う機能です。

  HiRDBシステムのデータベース再編成時期予測機能は、次の２つのフェーズで実行されます。

    § 再編成時期の予測データ取得(pddbst -k logi：状態解析結果蓄積機能)

定期的にHiRDBのpddbstユティリティを実行し、解析情報表にデータベースの解析結果を蓄積していきます。また、一部SQL、運用コマンドが実行されるたびに運用履歴表にデータベースの運用履歴情報が出力されます。

    § 再編成時期の予測データ解析(pddbst -k pred：再編成時期予測機能)

解析情報表及び運用履歴表を入力情報にして、pddbstユティリティで再編成時期の予測を行います。この予測には、再編成時期の予測データ取得(状態解析結果蓄積機能)を３回以上行っている必要があります。

HiRDB　CMではHiRDBのデータベース再編成時期予測機能の予測レベル１（主にRDエリアの容量不足を監視する機能）を使用しています。HiRDBの再編成予測機能の詳細は、HiRDBのマニュアル「システム運用ガイド 13.4 表の再編成時期を予測する方法」を参照してください。

HiRDB CMの自動データメンテナンス機能では、この２つのフェーズを一日一回指定した時間に実行し、解析結果をConsoleに表示します。一部対処方法については、カタログ機能を用いて指定したカタログを自動的に実行します。また、[リソース警告値の設定]でRDエリアセグメント使用率警告値に設定した値を解析の基準値として使用します。

  自動データメンテナンス機能で、メンテナンス実行時間に指定する時刻は、対象のHiRDBで業務を行っていないまたは、HiRDBに対する負荷が上がっても問題のない時間で、対象のHiRDBが必ず起動している時間を指定してください。指定した時刻に対象のHiRDBが停止している場合、再編成時期予測のデータ取得、解析は行われません。

  HiRDBのデータベースの再編成時期予測機能は、予測データ取得を3回行ったあとでなければ解析が行われません。HiRDB CMでは、一日一回、予測データ取得を行うので、初めてデータベース再編成予測機能または、自動データメンテナンス機能を使用した場合、実際に解析結果が表示されるのは自動データメンテナンスを設定してから４日後になります。(ただし、自動データメンテナンス機能登録以前に予測に必要なデータが3個以上蓄積されている場合は、４日以前にデータベース再編成予測機能の解析結果を表示します。)

  HiRDB CMでは、自動データメンテナンス機能として次の操作を行うことができます。

§ 自動データメンテナンス機能の開始

自動データメンテナンス必要な情報を設定し、自動データメンテナンス機能を開始します。自動データメンテナンス機能を開始する前には、HiRDBで解析情報表と運用履歴表を格納するディクショナリ用RDエリアを作成しておく必要があります。

§ 自動データメンテナンス機能の解除

HiRDB CMで再編成時期の予測データの取得と解析を停止します。自動データメンテナンス機能を解除しても、HiRDBの再編成時期予測機能を停止されていないため、HiRDBが運用履歴情報の蓄積はそのまま続けます。HiRDBの再編成時期予測機能の停止も行う場合は、pd_rorg_predictオペランドの指定値をNに変更してください。

§ 自動データメンテナンス機能の一時停止

自動データメンテナンス機能を一時的に停止ます。たとえば、非営業日などのHiRDBがオフラインの日などは、一時停止をしてください。自動データメンテナンス機能を解除しても、HiRDBの再編成時期予測機能を停止されていないため、HiRDBが運用履歴情報の蓄積はそのまま続けます。HiRDBの再編成時期予測機能の停止も行う場合は、pd_rorg_predictオペランドの指定値をNに変更してください。

§ 自動データメンテナンス機能の再開始

自動データメンテナンス機能を再開始します。再開しを行うと一時停止前の状態で開始が行われます。

§ 自動データメンテナンス機能の結果表示

自動データメンテナンスの解析結果を表示します。

  HiRDBのデータベース再編成時期予測機能の解析結果で提案される対処方法を次に示します。

§ pdrorgコマンドによる表又はインデクスの再編成

§ pdreclaimコマンドによる使用中空きページの解放，及び使用中空きセグメントの解放

§ pdmodコマンドによるRDエリアの拡張

§ RDエリアの自動増分

§ pdmodコマンドによるRDエリアの再初期化

  HiRDB CMで自動対処として、表/インデクスの再編成と空きページ解放を行うことができます。データベース再編成時期予測機能がそれ以外の対処方法を提案した場合は、対処を行わず解析結果を表示します。

l 自動データメンテナンス使用例

次に自動データメンテナンスの使用例を紹介します。

<手順>

1. HiRDBで解析情報表と運用履歴表を格納するディクショナリ用RDエリアを作成します。

2. HiRDBの定義を変更し、データベースの再編成予測機能を有効にします。

3. 自動対処を行う場合、対処用のカタログを作成します。

4. 解析基準値の設定のため、リソース監視値の設定画面で、RDエリアセグメント使用率警告値を設定します。

5. 自動データメンテナンス画面で自動データメンテナンスの開始をします。

6. データベースの解析結果を収集します。

7. 自動データメンテナンス画面で解析結果を確認します。

※手順１、２の操作はHiRDB CMで行うことはできません。対象のHiRDBマシン上で行ってください。

<条件>

· データベースの再編成予測機能をはじめて使用する場合について記載しています。

· 自動データメンテナンスの入力情報は次のようにします。

メンテナンス対象期間 ３日

メンテナンス実行時間 00:00:00

解析対象　　　　　　　　表T_SAMPLE1、インデクスI_SAMPLE1、表T_SAMPLE2

解析の基準値 70%

自動対象を行う対象 表T_SAMPLE1、インデクスI_SAMPE1

· 00:00:00から１時間の間は、毎日必ずHiRDBが起動しています。

· 00:00:00から1時間の間は、クリティカルな業務は行われません。

1. HiRDBで解析情報表と運用履歴表を格納するディクショナリ用RDエリアを作成します。

データべース再編成時期予測機能を有効にするため、解析情報表と運用履歴表を格納するディクショナリ用RDエリアを作成します。

§ 解析情報表と運用履歴表を格納するディクショナリ用RDエリアをpdmodコマンドにより作成します。

pdmodコマンドの使用方法は、HiRDBのマニュアル「コマンドリファレンス」を参考にしてください。また、システムログの容量の見積もりも合わせて確認してください。

2. HiRDBの定義を変更し、データベースの再編成時期予測機能を有効にします。

データベース再編成時期予測機能を有効にするため、HiRDBのシステム定義ファイルを変更します。

§ HiRDBを正常停止します。

§ 対象のHiRDBのシステム定義ファイルにpd_rorg_predictオペランドを追加し、Yを設定します。

§ HiDBの正常開始します。

3. 自動対処を行う場合、対処用のカタログを作成します。

自動対処を行うためのカタログを作成します。ここでは、表T_SAMPLE1とその表上に定義されているインデクスI_SAMPLE1の自動対処用のカタログを作成する例を示します。この例を参考に自動対処を行う全ての表または、インデクスの対処用のカタログを作成してください。

§ [タブメニュー] > [マップ] > [表]をクリックして、表マップ画面を起動します。

§ 表マップ画面で、対象のHiRDBシステムと表T_SAMPLE1を選択します。

§ 表マップ画面で、アイコンボタンメニューから「再編成」アイコンボタンをクリックして、データベース再編成ユティリティ画面を起動します。

§ データベース再編成ユティリティ画面で、必要な情報を入力し、「カタログ」ボタンをクリック、表の再編成カタログを作成します。

§ 表マップ画面で、アイコンボタンメニューから「空きページ解放」アイコンボタンをクリックして、空きページ解放ユティリティ画面を起動します。

§ 空きページ解放画面で、必要な情報を入力し、「カタログ」ボタンをクリックし、表の空きページ解放カタログを作成します。

§ 表マップ画面で、インデクス情報リストからインデクスI_SAMPLE1を選択します。

§ 表マップ画面で、アイコンボタンメニューから「インデクスの再編成」アイコンボタンをクリックして、データベース再編成ユティリティ画面を起動します。

§ データベース再編成ユティリティ画面で、必要な情報を入力し、「カタログ」ボタンをクリック、インデクスの再編成カタログを作成します。

§ 表マップ画面で、アイコンボタンメニューから「空きページ解放」アイコンボタンをクリックして、空きページ解放ユティリティ画面を起動します。

§ 空きページ解放画面で、処理対象種別にインデクスを選択し、インデクス名リストで、I_SAMPLE1を選択します。

§ 空きページ解放画面で、その他必要な情報を入力し、「カタログ」ボタンをクリックし、インデクスの空きページ解放カタログを作成します。

§ [タブメニュー] > [バックアップ] > [ウィザード]をクリックして、バックアップウィザード画面を起動します。

§ バックアップウィザード画面で表T_SAMPLE1に対するバックアップカタログを作成します。（関係RDエリアの追加画面で、インデクスI_SAMPLE1のRDエリアもバックアップ対象に追加してください。）

4. 解析基準値の設定のため、リソース監視値の設定画面で、RDエリアセグメント使用率警告値を設定します。

解析基準値の設定のため、リソース監視値の設定画面で、RDエリアセグメント使用率警告値を設定します。

§ [タブメニュー] > [監視] > [リソース警告値の設定]をクリックして、リソース警告値の設定画面を起動します。

§ リソース警告値の設定画面で、対象のHiRDBシステムを選択し、RDエリアセグメント使用率の警告値を70%に設定します。

§ リソース警告値の設定画面で、「OK」ボタンをクリックして設定を行います。

5. 自動データメンテナンス画面で自動データメンテナンスの開始をします。

自動データメンテナンス画面で、自動データメンテナンスの設定を行います。

§ [タブメニュー] > [データメンテナンス] > [自動データメンテナンス]をクリックして、自動データメンテナンス画面を起動します。

§ 自動データメンテナンス画面で対象のHiRDBを選択します。

§ 自動データメンテナンス-チェックポイントタブ画面で、次の入力情報を設定します。

メンテナンス対象期間、メンテナンス実行時間、解析対象（メンテナンス対象から選択）、RDエリアセグメント使用率の警告値を使用する

§ 自動データメンテナンス-メンテナンスタブ画面で、メンテナンス方針リストから、表T_SAMPLE1、インデクスI_SAMPLE1、表SAMPLE2を選択し、「解析対象の変更」ボタンを押します。

選択されたHiRDBオブジェクトの解析対象がONになります。

§ 自動データメンテナンス-メンテナンスタブ画面で、メンテナンス方針リストから、表T_SAMPLE1を選択し、「修正↓」ボタンを押します。

§ 自動データメンテナンス-メンテナンスタブ画面で、「メンテナンス前のバックアップ実行」、「空きページ解放」、「再編成」に３の処理で作成したカタログを指定します。

§ 自動データメンテナンス-メンテナンスタブ画面で、「設定↑」ボタンをクリックし、設定を確定します。

§ 自動データメンテナンス-メンテナンスタブ画面で、メンテナンス方針リストから、インデクスI_SAMPLE1を選択し、「修正↓」ボタンを押します。

§ 自動データメンテナンス-メンテナンスタブ画面で、「メンテナンス前のバックアップ実行」、「空きページ解放」、「再編成」に３の処理で作成したカタログを指定します。

§ 自動データメンテナンス-メンテナンスタブ画面で、「設定↑」ボタンをクリックし、設定を確定します。

§ 自動データメンテナンス-メンテナンスタブ画面のメンテナンスリストで設定の確認を行います。

§ 自動データメンテナンス画面で、「登録」ボタンをクリックし自動データメンテナンスを開始します。

6. データベースの解析結果を収集します。

自動データメンテナンスの設定を行ってから、実際に解析が行われるのは、４日後になります。ここでは、解析結果の表示の説明を次の手順で説明するため、HiRDBに対して再編成時期予測データの取得を手動で行います。この手順は、本来行う必要はりません。

§ 対象のHiRDBマシン上で、HiRDB用のコマンドプロンプトを開きます。

§ 次のコマンドを３回実行します。

pddbst -k logi -r T_SAMPLE1表が存在するRDエリア名 -e1 -d

pddbst -k logi -r I_SAMPLE1インデクスが存在するRDエリア名 -e1 -d

pddbst -k logi -r T_SAMPLE2 表が存在するRDエリア名-e1 -d

7. 自動データメンテナンス画面で解析結果を確認します。

メンテナンス実行時間が過ぎてしばらくしてから、自動データメンテナンスの結果を確認します。

§ [タブメニュー] > [データメンテナンス] > [自動データメンテナンス]をクリックして、自動データメンテナンス画面を起動します。

§ 自動データメンテナンス画面で対象のHiRDBを選択します。

§ 自動データメンテナンス-メンテナンスタブ画面で、解析結果を確認します。

§ 自動データメンテナンス-メンテナンスタブ画面で、「メンテナンス状況」ボタンを押すと、直前のデータベース再編成時期予測の予測データ収集コマンド実行結果と、データベース再編成時期予測機能の予測データ解析コマンドの実行結果が確認できます。

§ 自動データメンテナンス-メンテナンスタブ画面の解析結果リストに表示されたHiRDBオブジェクトを選択すると、解析結果の詳細情報が表示されます。

§ 自動データメンテナンス-メンテナンスタブ画面の解析結果リストに表示されたHiRDBオブジェクトを選択するし、「即時解析」ボタンをクリックすると、データベース状態解析ユティリティ画面が起動され、対象オブジェクトの現在の状態が確認できます。

§ 自動対処が行われた場合は、解析結果リストの自動対処に結果が通知されます。詳細の結果は、[タブメニュー] > [スケジュール] > [カタログ実行結果]をクリックしてカタログ実行結果画面を起動し、自動対処に設定したカタログの実行結果を確認してください。


HiRDBメッセージ監視機能

HiRDBメッセージ監視

この章では、HiRDBメッセージ監視について説明します。

l HiRDBのメッセージ

HiRDBシステムは、稼動中の情報をHiRDBシステムメッセージログ(pdlogxファイル)へ出力します。HiRDBシステム管理者は、必要に応じて、このメッセージログファイルを定期的に確認し、HiRDBシステムが出力する警告、障害メッセージを検出して対処する必要があります。このような監視操作は、多くの場合、HiRDBシステム管理者が手作業により実施するか、JP1/AJS2のメッセージ監視機能を使用します。HiRDB CMでは、HiRDBメッセージについて、自動的に監視を行い、検出したHiRDBメッセージをHiDRB CM Consoleから確認することができます。

  HiRDB CMで自動監視するHiRDBメッセージ一覧およびメッセージの概要を次に示します。これらのHiRDBメッセージ詳細、対処方法については、HiRDBのマニュアルを参照してください。

HiRDBのメッセージID | メッセージの概要
KFPH00211-I | RDエリアのセグメントの使用率があるシキイ値を越えた場合に出力されるメッセージです。
KFPH00212-I | 表が使用するRDエリア内に未使用のセグメントがなくなったため、使用中のセグメントから空き領域を探している場合に出力されるメッセージです。
KFPH00306-E | 参照処理実行中にRDエリアが障害閉塞した場合に出力されるメッセージです。
KFPH00307-E | 更新処理実行中にRDエリアが障害閉塞した場合に出力されるメッセージです。
KFPH00372-I | HiRDB開始処理時などに、回復していない障害閉塞RDエリアがある場合に出力されるメッセージです。
KFPH22017-I | LOB用RDエリアのLOBの管理領域が不足しているため再利用をい行っている場合に出力されるメッセージです。
KFPH22023-W | サーバ内のリスト作成可能数に対する警告メッセージです。
KFPS02101-I | シンクポイントダンプ有効化のスキップ回数に関するメッセージです。
KFPS00441-I | デッドロック情報を出力した場合に出力されるメッセージです。HiRDBのメッセージ監視画面から該当するデットロック情報ファイルを参照できます。
KFPS00443-I | 排他資源管理テーブル不足が発生した場合に出力されるメッセージです。
KFPS00444-I | 排他要求が上限値に達した場合に出力されるメッセージです。
KFPS00447-I | 排他資源管理テーブル不足情報を出力した場合に出力されるメッセージです。HiRDBのメッセージ監視画面から該当する排他資源管理テーブル情報ファイルを参照でできます。
KFPS00451-I | タイムアウトの情報を出力した場合に出力されるメッセージです。HiRDBのメッセージ監視画面から該当するタイムアウト情報ファイルを参照でできます。
KFPS00888-W KFPS00889-E | メッセージキュー監視機能のメッセージ監視時間（pd_queue_watch_timeオペランドの値）を超えても、メッセージキューからメッセージが取り出せない場合に出力するメッセージです。
KFPS05123-W | HiRDBの定義ファイルで指定できるHiRDBリソースに関する監視値を超えた場合に出力されるメッセージです。

  HiRDBメッセージ情報に、出力ファイルがある場合に、その出力ファイルの情報を取得し表示することができます。表示できる情報ファイルは次の３つです。

§ デッドロック情報ファイル

サーバ内の複数のトランザクション間に発生したデッドロックの情報です。

HiRDB/パラレルサーバの場合、サーバ間でデッドロックが発生したときは、タイムアウト情報として出力されます。

デッドロックについては、マニュアル「HiRDB Version 7 UAP開発ガイド」を参照してください。

§ 排他資源管理テーブル情報ファイル

HiRDBの排他制御でデッドロック、排他待ちタイムアウト、排他資源管理テーブル不足エラーが発生したときのユーザ情報です。出力された場合はバックアップを取得してください。

§ タイムアウト情報ファイル

排他待ち限界経過時間を超えたことを示す情報です。

  また、KFPH00211-I、KFPH00212-Iメッセージで表示されたRDエリア、表に対してデータベース状態解析を行うことができます。


系切り替え

系切り替え構成HiRDBの管理

この章では、HiRDB CMで系切り替え構成のHiRDBを管理する方法について説明します。

l HiRDB CMでサポートする系切り替え構成

HiRDB　CMでは、一部クラスタソフトウェア使用した系切り替え構成を使用しているHiRDBを管理することができます。

HiRDB CMで系切り替え構成を管理することができるHiRDBのバージョンを次に示します。

HiRDB CMで系切り替え構成を扱うことのできるHiRDBのバージョン

HiRDB種別 | バージョン
HiRDB/SingleServer | Version7 07-02以降 Version8 08-00以降
HiRDB/ParallelServer | Version7 07-02以降 Version8 08-00以降

HiRDB CMでは、1対１スタンバイレス型系切り替えは、管理対象として登録することができません。

HiRDB CMで管理可能な系切り替え構成

系切り替え種別 |  |  | OS
 |  |  | Windwos | Linux | HP-UX | AIX | Solaris
スタンバイ型系切り替え※2 | サーバモード | ユーザホットスタンバイ | ○※1 | ○ | ○ | ○ | ○
 |  | 高速系切り替え | ○※1 | ○ | ○ | ○ | ○
 |  | 通常系切り替え | ○※1 | ○ | ○ | ○ | ○
 | モニタモード | 通常系切り替え | ○ | ○ | ○ | ○ | ○
スタンバイレス型系切り替え | サーバモード | 1：1スタンバイレス型系切り替え | × | × | × | × | ×
 |  | 影響分散スタンバイレス型系切り替え | ○ | ○ | ○ | ○ | ○
 | モニタモード | － | － | － | － | － | －

※1：Hitachi HA Toolkitのserver定義文のactcommandオペランドを指定する必要があります。

※2：1つの現用系ユニットと複数の予備系ユニットで構成されるスタンバイ型系切り替え構成（マルチスタンバイ構成）を管理することはできません。

HiRDB CMでは、HiRDBが使用するクラスタソフトウェアによって、サポートのレベルが異なります。HAモニタ、MSCSでは、完全なサポートを行います。その他のクラスタソフトウェアについては、管理者が、クラスタの操作とHiRDBの操作を含めて、ユニット単独の停止/強制停止用スクリプトファイルを事前に用意することで、開始/停止制御のみをサポートします。スクリプトファイルを用意しない場合は、開始/停止制御をHiRDB CMから扱うことができません。（ただし、HiRDBの登録/状態情報の表示は行うことができます。）

HiRDB CMの対応するクラスタソフトウェア

クラスタソフトウェア名 | 対応OS
MSCS | Windwos
HAモニタ | HP-UX、AIX5L、Linux
その他※ | HP-UX、AIX5L、Linux、Solaris

HiRDB CMで可能な系切り替え操作

系切り替え種別 |  | 操作 | クラスタソフト
 |  |  | HAモニタ | MSCS | その他
スタンバイ型系切り替え | サーバモード | システム全体開始 | ○ | ○ | ○
 |  | ユニット開始 | ○ | ○ | ○
 |  | サーバ開始 | ○ | ○ | ○
 |  | システム全体停止 | ○ | ○ | ○
 |  | ユニット停止 | ○ | ○ | ○
 |  | サーバ停止 | ○ | ○ | ○
 |  | 待機状態変更 | ○ | ○ | ×
 |  | 系切り替え | ○ | ○ | ×
 |  | 待機系停止 | ○ | ○ | ×
 | モニタモード | システム全体開始 | ○ | ○ | ○
 |  | ユニット開始 | ○ | ○ | ○
 |  | サーバ開始 | ○ | ○ | ○
 |  | システム全体停止 | ○ | ○ | ○
 |  | ユニット停止 | ○ | ○ | ○
 |  | サーバ停止 | ○ | ○ | ○
 |  | 待機状態変更 | ○ | － | ×
 |  | 系切り替え | ○ | ○ | ×
 |  | 待機系停止 | ○ | － | ×
影響負荷分散スタンバイレス型系切り替え |  | システム全体開始 | ○ | ○ | ○
 |  | ユニット開始 | ○ | ○ | ○
 |  | サーバ開始 | ○ | ○ | ○
 |  | システム全体停止 | ○ | ○ | ○
 |  | ユニット停止 | ○ | ○ | ○
 |  | サーバ停止 | ○ | ○ | ○
 |  | 待機状態変更 | ○ | ○ | ○
 |  | 系切り替え | ○ | ○ | －
 |  | 待機系停止 | ○ | ○ | ○

スタンバイ型系切り替えとスタンバイレス型系切り替え（影響分散スタンバイレス型系切り替え）の概要について、次に説明します。詳細は、HiRDBの各種マニュアルを参照してください。

§ スタンバイ型系切り替え

  スタンバイ型系切り替えでの系を切り替える対象は、ユニットです。１つのユニットは、実行系、待機系と呼ばれる２つのマシンで構成されます。実行系マシンでは、HiRDBが稼動し、待機系マシンでは、HiRDBが待機状態になります。実行系マシンに障害が発生した場合、待機系マシンのHiRDBが稼動し処理を続行することで、ノンストップ運用を実現できます。

§ スタンバイレス型系切り替え（影響分散スタンバイレス型系切り替え）

  スタンバイレス型系切り替えでの系を切り替える対象は、サーバになります。ユニットマシンに障害が発生した場合、障害ユニット内のサーバが他のユニットに移動することで、ノンストップ運用の実現できます。

l 系切り替え構成のHiRDBを管理する場合の留意事項

次に系切り替え構成のHiRDBを管理する場合の留意事項について説明を行います。

§ HiRDB/シングルサーバまたは、HiRDB/パラレルサーバのシステムマネジャがスタンバイ型系切り替え構成を採用している場合、Agentが使用するサービスIPアドレスを設定する必要があります。このIPアドレスは、対象ユニットの起動時にアクティブになるように設定してください。

§ HiRDB CMで扱うHiRDBファイルシステム領域、ディレクトリ、ファイルは全て共用ディスク上に作成し、現用系、予備系双方で同じパスで参照できる必要があります。共用ディスクを用意できない場合は、次のことに注意してください。

バックアップ/リカバリ

  バックアップ格納先のディレクトリ、HiRDBファイルシステム領域を共用ディスク上に作成していない場合、現用系で取得したバックアップファイルを予備系で使用することはできません。また、予備系で取得したバックアップファイルを現用系で使用することはできません。

  自動ログアンロード機能で取得したアンロードログファイルを使用したリカバリを行う場合は、共用ディスク上に自動ログアンロードの格納先を指定してください。共用ディスクに上に作成していない場合は、この機能を使用しないでください。

アンロードログファイル

  アンロードログ格納先のディレクトリ、HiRDBファイルシステム領域を共用ディスク上に作成していない場合は、アンロードログファイルの削除、リカバリを行うこはできません。

制御文ファイル・SQLファイル

  次に示すファイルは原則共用ディスク上に作成してください。共用ディスクを用意できない場合は、実行時に実行系となっているマシン上に作成してください。

再編成、データロードなどで使用する制御文ファイル

定義系SQLの実行で使用するSQL文ファイル

§ 使用するクラスタソフトウェアにHAモニタを使用する場合、HAモニタのサーバ識別名（サーバ対応環境設定定義のalias名）を次の規則で設定する必要があります。

スタンバイ型系切り替えを使用する場合

- CM Agentのバージョンが08-00以前の場合、aliasを対応するユニット名とする必要があります。

- CM Agentのバージョンが08-01以降の場合、インストール時にalias名を指定することができます。

影響分散スタンバイレス型系切り替えを使用する場合

- aliasを対応するHiRDBサーバ名と同一にする必要があります。

§ 使用するクラスタソフトウェアにMSCSを使用する場合、MSCSのリソースグループ名を次の規則で設定する必要があります。

スタンバイ型系切り替えを使用する場合

- CM Agentのバージョンが08-00以前の場合、リソースグループ名を対応するユニット名とする必要があります。

- CM Agentのバージョンが08-01以降の場合、インストール時にリソースグループ名を指定することができます。

§ 使用するクラスタソフトウェアにHAモニタ以外のクラスを使用し、サーバモードを使用する場合、Hitachi HA Toolkit Extensionのサーバ識別名（サーバ対応環境設定定義のalias名）を以下の規則に設定する必要があります。

スタンバイ型系切り替えを使用する場合

- CM Agentのバージョンが08-00以前の場合、aliasを対応するユニット名とする必要があります。

- CM Agentのバージョンが08-01以降の場合、インストール時にalias名を指定することができます。

影響分散スタンバイレス型系切り替えを使用する場合

-aliasを対応するHiRDBサーバ名と同一にする必要があります。

§ 使用するクラスタソフトウェアにMSCSを使用し、サーバモードを使用する場合、Hitachi HA Toolkit ExtensionのServer定義文に必ずactcommandを指定する必要があります。省略した場合は、動作不定となります。

§ マネージャノードが系切り替え構成を行っている構成で、予備系を実行系として動作している場合次の動作が行えません。

スケジュール操作

自動データメンテナンス操作

JP1/ＡＪＳ２カスタムジョブ連携(登録、解除)

ＨｉＲＤＢ新規登録機能

管理ＨｉＲＤＢ解除機能

管理情報のリカバリ

  また、スケジュールで指定した時刻に対象のHiRDBのマネージャノードが予備系を実行系として稼動している場合、スケジュールによるカタログ実行は見送られます。自動メンテナンスの場合も同様に実行が見送られます。

§ クラスタソフトウェアがHiRDBの状態に応じてディスクの切り替えを行う系切り替えを使用している運用で、対象のユニットが停止している場合には次のことに注意してください。

管理情報の自動更新機能を使用してないでください。(管理情報更新間隔を0に設定してください。)

HiRDB CMから操作を行うときには、現用系ユニットまたはホストBESが存在するユニットからHiRDBが使用する全てのリソースがアクセス可能である必要があります。必要に応じて、ディスクの設定を手動で行ってください。

§ スタンバイ型系切り替え構成の場合、実行系であるユニットが現用系であるか予備系であるかで、HiRDBが動作するホスト名が異なります。しかし、構成情報表示画面やHiRDB独自の処理を行う画面については、ユーザは特に実行系がどのホストであるかを意識する必要はありません。HiRDB CMでは、状態情報の表示を行うシステムステータスの初期画面以外では、全てのホスト名をHiRDBシステム定義で指定した現用系ホスト名で表示します。ただし、これは表示のみであり、処理の実行はすべて実行系ホストで行われます。

§ スタンバイ型系切り替えを使用している場合、デバイス情報は現用系でのみ情報を取得します。よって、予備系で実行系の場合でも、デバイスマップ、リソース関連表などで表示される情報は全て現用系ホストマシンのデバイス情報になります。

§ 計画系切り替え、待機系の状態変更はクラスタコマンドを実行した段階でHiRDB CMからの処理が成功となります。実際に正しく操作されたかはしばらく待ってからシステムステータス画面で確認してください。

§ HiRDBメッセージ監視を行っている場合、次のことに注意してください。

系切り替えが発生した場合、系切り替え発生前に出力されていたHiRDBのメッセージが読み飛ばされる場合があります。

情報ファイル表示を行う時に実行系上に情報ファイルがない（予備系上に情報ファイルが出力されている）場合は情報ファイルの表示を行えません。

§ CM Agentのバージョンが08-00以前であり、クラスタソフトウェアにHAモニタを使用する場合、HAモニタの連動系切り替え設定(group句)を使用した系切り替えを行えません。08-01以降のバージョンでは、CM Agentのインストール時にHAモニタのgroup句を指定することで、連動系切り替えを行うことができます。

l HAモニタ、MSCS以外のクラスタソフトを使用する方法

HAモニタ、MSCS以外のクラスタソフトを使用し、HiRDB CMから開始/停止制御を行う場合、管理者は、次のスクリプトファイルを事前に作成しておく必要があります。スクリプトファイルは、対象のクラスタを使用しているすべてのユニットに対して個々に作成し、配置してください。

§ ユニット単独開始ファイル

機能 ： 対象ユニットの単独開始をサポートするスクリプトファイルです。主に２つの機能を持ちます。

-クラスタの常置を稼動状態に変更する。

-HiRDBユニットを単独開始する。（pdstart -q)

このファイルは次の用途で使用します。

-システム全体開始時

-ユニット単独開始時

ファイル名 ： {HiRDBインストールディレクトリ}/CMAgent/conf/ClusterStartCmd

引数 ： 第一引数=ユニット名 (ただし、内部で読み飛ばしてもかまいません。）

戻り値 ： 成功の場合、コマンドの結果を0で設定してください。失敗した場合は、0以外の整数を設定してください。

§ ユニット単独強制停止ファイル

機能 ：ユニット単独強制停止ファイルは、主に２つの役割を持ちます。

- HiRDBユニットの強制停止 (pdstop -z -q)

- クラスタの状態を停止状態に変更する。

このファイルは次の用途で使用します。

-システム全体停止時

-ユニット停止時

-システム全体開始エラー時に先行投入されたユニット単独開始コマンドを決着用コマンド

ファイル名 ： {HiRDBインストールディレクトリ}/CMAgent/conf/ClusterStopCmd

引数 ： 第一引数=ユニット名 (ただし、内部で読み飛ばしてもかまいません。）

戻り値 ： 成功の場合、コマンドの結果を0で設定してください。失敗した場合は、0以外の整数を設定してください。

<注意事項>

· スクリプトファイルは、root権限で実行されます。スクリプト作成時には、十分注意して作成してください。

· Agent内部では、環境変数をHiRDB制御用に操作しています。必要な環境変数、または、不必要な環境変数はスクリプト内部で設定/解除を行ってください。

· スクリプトファイルには、実行権限を追加してください。

· HiRDB CMから正常停止/計画停止が操作された場合、はじめにHiRDBの正常停止/計画停止コマンドを単独で実行し、その後、クラスタの状態を停止状態に変更するためにユニット単独強制停止ファイルを実行します。そのため、スクリプト内のHiRDBの強制停止コマンドは、既にHiRDBユニットが停止しているため、エラーになる場合があります。スクリプトを作成する際には、HiRDBの強制停止コマンドが失敗した場合でも、クラスタの状態を停止にする処理が実行されるように実装してください。

· システム全体開始エラー時に先行投入されたユニット単独開始コマンドの決着用コマンドとして扱う場合、ユニット単独強制停止ファイルをそのまま実行します。そのため、クラスタ状態が不安定な状態でもクラスタ状態を停止状態に変更できるように処理を実装してください。

· スクリプトファイルの標準出力ならびに、標準エラー出力は、スクリプトファイルがエラーの場合（戻り値が0以外の場合）、Consoleの結果画面で参照することができます。成功時には、表示を行いません。


デバイス情報

この章では、HiRDB CMで扱うデバイス情報について説明します。また、後半では、デバイス情報ファイルを使用したデバイス情報の取得例を紹介します。

l デバイス情報

HiRDB CM Consoleで表示を行うデバイス情報は、次の図のような情報です。

· 論理ドライブ/ファイルシステム

「HiRDBシステム」で選択した対象がWindows OSの場合は、ドライブ名を表示します。

UNIX OSの場合は、ファイルシステム名を表示します。

· 論理ボリューム[LV]

「HiRDBシステム」で選択した対象がHP-UX OSの場合は、LVMの論理ボリュームまたは、VxVMボリューム名を表示します。

· ボリュームグループ[VG]

「HiRDBシステム」で選択した対象がHP-UX OSあるいはAIX OSの場合は、LVMのボリュームグループ名または、VxVMのディスクグループ名を表示します。

Solaris OSの場合は、VxVMのディスクグループ名を表示します。

· 物理ボリューム[PV]

「HiRDBシステム」で選択した対象がHP-UX OSの場合は、LVMの物理ボリューム名または、VxVMのディスク名を表示します。

AIX OSの場合は、LVMの物理ボリューム名を表示します。

Solaris OSの場合は、VxVMのディスク名を表示します。

· 物理ドライブ

「HiRDBシステム」で選択した対象がWindows OSの場合は、ディスク番号を表示します。

UNIX OSの場合は、デバイススペシャルファイル名を表示します。

· 論理デバイス[LDEV]

論理デバイス番号を表示します。

· RAIDグループ

RAIDグループ番号を表示します。

これらのデバイス情報は次の４つの機能で使用しています。

§ デバイスマップ

§ リソース関係

§ バックアップウィザード － デバイス指定のバックアップ対象検索

§ ファイル/ディレクトリ一覧表示 ― ファイルシステム指定

HiRDB CMでは、次の２種類の方法でデバイス情報を取得することができます。

§ デバイス情報の自動取得

§ ユーザ定義のデバイス情報ファイルから取得

  HiRDB CMでは、一度取得したデバイス情報は自動削除されることはありません。そのため、デバイスの構成を変更したり、デバイス情報ファイルを変更した場合は、古いデバイス情報が残る場合があります。この場合は、[マップ]-[デバイス]で古いデバイス情報が×印で表示されます。デバイスマップ画面のデバイス情報削除アイコンボタンを実行し、不必要になったデバイス情報を削除してください。

l デバイス情報の自動取得

管理対象のHiRDBがインストールされているマシンのデバイス情報を自動的に取得します。自動取得は次に示すOSでのみ実行することができます。

OS

HP-UX11i

AIX 5L 5.1

AIX 5L 5.2

AIX 5L 5.3

Linux AS2

Linux AS/ES3

Linux AS/ES4

Solaris 8

Solaris 9

Solaris 10

Windows 2000

Windows 2003

  デバイス情報自動取得では、管理対象HiRDBが使用しないデバイス情報も同時に取得するため、対象マシンに接続されたディスクの情報が多い場合は、取得処理に時間がかかります。また、デバイス情報が多い場合、デバイスマップ、リソース関連での情報表示を行うときにも時間がかかります。そのため、ディスクが多い場合は、デバイス情報ファイルを作成する方針を推奨します。

  デバイス情報の自動取得では、OSの標準のデバイス情報を取得します。そのため、標準以外のデバイス情報を使用している場合、情報取得に失敗する場合があります。この場合も、デバイス情報ファイルを使用した方法でデバイス情報の取得を行ってください。

l ユーザ定義のデバイス情報ファイルからの取得

  デバイス情報ファイルとは、管理対象のHiRDBが動作するマシンのデバイス情報をHiRDB CMで定められた形式で記述した定義ファイルです。ユーザが作成したデバイス情報ファイルから情報を取得する方法は、自動取得と比べて次の点で優れています。

§ 全てのOSでデバイス情報の取得が可能です。

§ 管理対象のマシンでHiRDB以外のアプリケーションが使用するディスクの数が多い場合、必要なデバイス情報のみを定義することが出来きます。（リソース関連、デバイスマップなどの表示性能が向上する。）

§ 管理対象HiRDBが使用しないデバイス情報を隠蔽することができるます。

§ LVM、パスマネージャなどがHiRDB CMでサポートしていない環境のものでもデバイス情報を定義できます。

デバイス情報ファイルは、次に示す名称でユニットごとに作成してください。

{管理対象HiRDBのインストールディレクトリ}/CMAgent/util/cmadevinfo

次にデバイス情報ファイルの記述規則について説明します。

  デバイス情報ファイルは、タグとCSV情報の結合形式表現されます。各タグは、[] [/]で表現されます。タグで囲まれた部分は;(セミコロン)区切りのCSV形式レコードとなります。各タグとそのタグに囲まれるCSVの形式を表にまとめます。

タグ名 |  | 説明 | CSVの内容 |  | 最大文字数
 |  |  | 番号 | 内容
CMRDevInfo |  | メインタグ | ― | ― | ―
 | DISK | 物理ディスク情報 | 1 | 物理ドライブ名 | 256
 |  |  | 2 | LU名 | 11
 |  |  | 3 | RAIDグループ名 | 5
 |  |  | 4 | LDEV名 | 5
 | VMINFO | LVM情報 | 1 | 物理ボリューム名(PV) | 256
 |  |  | 2 | ボリュームグループ名(VG) | 256
 |  |  | 3 | 論理ボリューム名(LV) | 256
 | PATH | ダイナミックリンクマネージャユなどのパス管理ソフト情報 | 1 | デバイスファイル名 | 256
 |  |  | 2 | パスソフト変換後のデバイスファイル名 | 256
 | FS | ファイルシステム情報 | 1 | デバイスファイル名 | 256
 |  |  | 2 | ファイルシステム名 | 256
 | PART | パーテション情報を表示 | 1 | デバイスファイル名 | 256
 |  |  | 2 | パーテション名 | 256

HiRDB CM Agentでは、メインタグである[CMRDevInfo]タグがない場合は、エラーになるります。他の各タグが省略された場合は、その情報は読み飛ばして処理を続けます。また、タグ間のCSVファイルに過不足があった場合、有効なデータのみを取得します。各情報の長さが長い場合は、前方の有効な部分のみを読み取ります。

各デバイス情報名は、UNIXの場合、/devからのフルパスで記入する必要があります。関連のあるデバイス情報名称が一致すれば、同じものとして認識します。そのため、関連のある情報は、同じ名称で記載してください。（大文字と小文字は別のものと認識するので統一してください。）

<注意事項>

· ユーザ定義のデバイス情報ファイルを作成して、所定の場所へ格納後には、必ず CM Consoleから[オプション]-[管理情報の更新]画面で当該HiRDBシステムに対して「デバイス情報」を選択し、情報更新を行ってください。「デバイス情報」の更新を行わないとCM Consoleでは、ユーザ定義のデバイス情報を表示することができません。

· 複数のRAIDグループを指定する場合は、すべてのRAIDグループIDが一意になる設定を行ってください。

次に各タグとタグ間の関連について、デバイス構成の特徴ごとに説明します。

  1. パーテションを持たないUNIX－OSのデバイス情報ファイル

  2. パーテションを持つUNIX－OSのデバイス情報ファイル

  3. Windows-OSのデバイス情報ファイル

  4. パス管理ソフトを使用したOSのデバイス情報ファイル

1.パーテションを持たないUNIX-OSのデバイス情報ファイル

ここでは、HP-UX、AIXなどのパーテションの概念を持たないUNIXでのデバイス情報ファイルの作成規則について説明します。

HP-UX、AIXなどのパーテションを持たないOSでは、[DISK]、[VMINFO]、[FS]タグについてデバイス情報ファイルを記載する必要があります。

  図の①のように、物理ドライブと物理ボリュームが結びついている場合（LVMを使用する構成）、[DISK]タグの物理ドライブ名と[VMINFO]タグの物理ボリューム名を同じ名称で記入します。一般的にHP-UXでは、/dev/c0t0d0、AIXでは、/dev/hdisk0のような名称になります。

  図の②のように、物理ドライブとファイルシステムが結びついてる場合（LVMを使用しない構成）では、[DISK]タグの物理ドライブ名と[FS]タグのデバイスファイル名を同じ名称で記入します。一般的にHP-UXでは、/dev/c0t0d0、AIXでは、/dev/hdisk0のような名称になります。

  図の③のように、論理ボリュームとファイルシステムが結びついている場合は、[LVMINFO]タグの論理ボリューム名と[FS]タグのデバイスファイル名を同じ名称で記入します。一般的にHP-UXでは、/dev/vg01/lv01、AIXでは、/dev/lv01のような名称になります。

本章の後半では、HP-UXのデバイス情報ファイル作成例を紹介します。

2.パーテションを持つUNIX-OSのデバイス情報ファイル

ここでは、LINUX、SOLARISなどのパーテションの概念を持つUNIXでのデバイス情報ファイルの作成規則について説明します。

LINUX、SOLARISなどのパーテションを持つOSでは、[DISK]、[PART]、[VMINFO]、[FS]タグについてデバイス情報を記載する必要があります。

  図の①のように、物理ドライブとパーテションの関係を、[DISK]タグの物理ドライブ名と[PART]タグのデバイスファイル名を同じ名称で記入することで表現します。一般的にLINUXでは、/dev/sda /deb/hda、SORALISでは、/dev/c0t1d1のような名称になります。

  図の②のように、パーテションと物理ボリュームが結びついている場合（LVMを使用する構成）、[PART]タグのパーテション名と[VMINFO]タグの物理ボリューム名を同じ名称で記入します。一般的にLINUXでは、/dev/sda1 /deb/hda1、SORALISでは、/dev/c0t1d1s1のような名称になります。

  図の③のように、パーテションとファイルシステムが結びついてる場合（LVMを使用しない構成）では、[PART]タグのパーテション名と[FS]タグのデバイスファイル名を同じ名称で記入します。一般的にLINUXでは、/dev/sda1 /deb/hda1、SORALISでは、/dev/c0t1d1s1のような名称になります。

  図の④のように、論理ボリュームとファイルシステムが結びついている場合は、[LVMINFO]タグの論理ボリューム名と[FS]タグのデバイスファイル名を同じ名称で記入します。一般的にLINUXでは、/dev/vg01/lv01、SOLARISでは、/dev/dg01のような名称になります。

本章の後半では、Linuxのデバイス情報ファイル作成例を紹介します。

3.Windwos-OSのデバイス情報ファイル

ここでは、Windowsのデバイス情報ファイルの作成規則について説明します。

Windowsでは、[DISK]、[FS]タグについてデバイス情報を記載する必要があります。

  図の①のように、物理ドライブとファイルシステム（ドライブ）の関係を、[DISK]タグの物理ドライブ名と[FS]タグのデバイスファイル名を同じ名称で記入することで表現します。Windowsの物理ドライブ名称については、特に制限はありません。任意の名称をつけてください。自動取得では、Disk0、Disk1と表現しています。

本章の後半では、Windowsのデバイス情報ファイル作成例を紹介します。

4. パス管理ソフトを使用したOSのデバイス情報ファイル

ここでは、パス管理ソフトを用いたのデバイス情報ファイルの作成規則について説明します。

ダイナミックリンクマネージャなどのパス管理ソフトを使用したOSでは、[DISK]、[PATH]、[PART]、[VMINFO]、[FS]の全てのタグについて、デバイス情報を記載する必要があります。

次の図は、パーテションの概念を持たないOSでのパス管理ソフトを使用した場合のデバイス構成図です。

  図の①のように、物理ドライブをパス管理ソフトで一つのデバイスパス名として使用している関係を表すためには、[DISK]タグの物理ドライブと[PATH]タグのデバイスファイル名同じ名称で記入します。

  図の②のように、デバイスパス名と物理ボリュームが結びついている場合（LVMを使用する構成）、[PATH]タグのパスソフト変換後のデバイスファイル名と[VMINFO]タグの物理ボリューム名を同じ名称で記入します。

  図の③のように、、デバイスパス名とファイルシステムが結びついてる場合（LVMを使用しない構成）では、[PATH]タグのパスソフト変換後のデバイスファイル名と[FS]タグのデバイスファイル名を同じ名称で記入します。

次の図は、パーテションの概念を持つOSでのパス管理ソフトを使用した場合のデバイス構成図です。

  図の①のように、物理ドライブをパス管理ソフトで一つのデバイスパス名として使用している関係を表すためには、[DISK]タグの物理ドライブと[PATH]タグのデバイスファイル名を同じ名称で記入します。

  図の②のように、デバイスパス名とパーテションとの関係を表すために、[PATH]タグのパスソフト変換後のデバイスファイル名と[PART]タグのデバイスファイル名を同じ名称で記入します。

次にデバイス情報ファイルの作成例を紹介します。

§ Windowsでのデバイス情報ファイル作成例

§ HP-UXでのデバイス情報ファイル作成例

§ AIXでのデバイス情報ファイル作成例

§ LINUXでのデバイス情報ファイル作成例

§ Solarisでのデバイス情報ファイル作成例


操作編

目次

操作編

HiRDB CM - Consoleが表示する画面の名称について説明します。

§ メニューバー

  主にHiRDB CMを制御する機能の実行、設定を行います。

§ ボタンバー

  HiRDB CMからHiRDBを管理するための各種機能を呼び出すボタンの一覧が表示されます。

  タブメニューに表示されている各種アイコンをドラッグ＆ドロップすることで、ボタンバーへ各操作項目のショートカットアイコンを作成することができます。

§ タブメニュー

  HiRDB CMでは、HiRDBを管理するための操作を機能別のカテゴリに分けて表示します。タブメニューは機能毎のタブをまとめたメニュー画面です。タブメニュー内のタブには、サブメニューと呼ばれる操作項目が表示されます。サブメニュー内の操作項目アイコンをクリックすると、メインウィンドウに操作画面（チャイルドウィンドウ）が表示されます。

§ コンテキストヘルプ

  HiRDB CMの画面上にマウスポインタを位置付けたHiRDB CMでは、HiRDBを管理するための操作を機能別のカテゴリに分けて表示します。タブメニューは機能毎のタブをまとめたメニュー画面です。タブメニュー内のタブには、サブメニューと呼ばれる操作項目が表示されます。サブメニュー内の操作項目アイコンをクリックすると、メインウィンドウに操作画面（チャイルドウィンドウ）が表示されます。

§ チャイルド・ウィンドウ

各種操作を行うチャイルド・ウィンドウは以下のウィンドウ操作ボタンを持ちます。

・最小化ボタン

チャイルド・ウィンドウを最小化します。最小化時には、このボタンは最小化前のサイズに戻すボタンになります。

・拡張ボタン

チャイルド・ウィンドウをメイン・ウィンドウのサイズにリサイズします。このボタンは常にメイン・ウィンドウのサイズにチャイルド・ウィンドウをリサイズし、リサイズ前のサイズに戻すボタンにはなりません。チャイルド・ウィンドウを小さくする場合は、ウィンドウの端にカーソルを合わせ、手動でサイズを変更してください。

・クローズボタン

チャイルド・ウィンドウを閉じます。

この章では、上記で説明したConsoleの各画面の操作方法を説明します。

＜この章の構成＞

· メニューバー

§ [オプション]メニュー

§ [ウィンドウ]メニュー

§ [ヘルプ]メニュー

· ボタンバー

· タブメニュー

§ [システムステータス]タブ

§ [マップ]タブ

§ [バックアップ]タブ

§ [リカバリ]タブ

§ [データメンテナンス]タブ

§ [スケジュール]タブ

§ [システムログ管理]タブ

§ [ステータスファイル管理]タブ

§ [表操作]タブ

§ [ツール]タブ

§ [管理HiRDB]タブ

§ [監視]タブ

一般ユーザに対する機能制限について

HiRDB CM 08-03では、管理対象HiRDBの状態確認のみが可能な一般ユーザという概念を追加しました。

一般ユーザとしてログインした場合、HiRDB CMの一部のメニューが表示されません。

この一般ユーザに対し、08-02までのログインユーザと同様にHiRDB CMの全機能を使用できるログインユーザのことを、管理者といいます。

管理者と一般ユーザの使用可能な機能の違いを下表に示します。

接続ユーザ別使用可能機能一覧

○：操作可能

×：操作不可

機能 |  |  |  | 管理者 | 一般ユーザ
メニューバー | [オプション] メニュー | [コンソール接続数の設定] |  | ○ | ×
 |  | [パスワードの変更] |  | ○ | ×
 |  | [管理情報更新間隔の変更] |  | ○ | ×
 |  | [管理情報の更新] |  | ○ | ○
 |  | [管理情報のバックアップ/リカバリ] |  | ○ | ×
 |  | [コンソール応答待ち時間の変更] |  | ○ | ○
 |  | [JP1/AJS2との連携] |  | ○ | ×
 |  | [ロギング情報表示設定] |  | ○ | ○
 |  | [HiRDB開始制御] |  | ○ | ×
 |  | [コンソールの終了] |  | ○ | ○
 | [ウィンドウ] メニュー | [ボタンメニューの表示] |  | ○ | ×
 |  | [ボタンメニューの単一列表示] |  | ○ | ×
 |  | [全ボタンメニューの削除] |  | ○ | ×
 |  | [アイコンの整列] |  | ○ | ○
 |  | [ウィンドウの整列] |  | ○ | ○
 | [ヘルプ] メニュー | [コンテキストヘルプの表示] |  | ○ | ×
 |  | [目次] |  | ○ | ×
 |  | [検索] |  | ○ | ×
 |  | [キーワード] |  | ○ | ×
 |  | [HiRDB CMバージョン情報] |  | ○ | ×
ボタンバー |  |  |  | ○ | ×
タブメニュー | [システムステータス] タブ | 各システムステータスの表示 |  | ○ | ○
 |  | HiRDB開始/停止/系切り替えボタン |  | ○ | ×
 |  | トランザクション状態情報 | 強制終了 | ○ | ×
 |  | ユニット詳細情報 | クリーンアップ | ○ | ×
 |  | ユニット用ステータスファイル情報 | スワップ | ○ | ×
 |  |  | オープン | ○ | ×
 |  |  | クローズ | ○ | ×
 |  | サーバ詳細情報 | キューイング | ○ | ×
 |  |  | アンロード制御 | ○ | ×
 |  | RDエリア詳細情報 | 閉塞 | ○ | ×
 |  |  | 閉塞解除 | ○ | ×
 |  |  | オープンクローズ | ○ | ×
 |  |  | カレント変更 | ○ | ×
 |  | システムログファイル情報 | スワップ | ○ | ×
 |  |  | オープン | ○ | ×
 |  |  | クローズ | ○ | ×
 |  |  | 状態変更 | ○ | ×
 |  |  | アンロード | ○ | ×
 |  | プロセス状態情報 | リフレッシュ | ○ | ×
 |  |  | プロセス数変更 | ○ | ×
 |  | サーバ用ステータスファイル情報 | スワップ | ○ | ×
 |  |  | オープン | ○ | ×
 |  |  | クローズ | ○ | ×
 |  | シンクポイントダンプファイル情報 | 取得 | ○ | ×
 |  | 上記以外 |  | ○ | ○
 | [マップ]タブ | [表]マップ | 定義系SQL | ○ | ×
 |  |  | DICの再編成 | ○ | ×
 |  |  | DICの空きページ解放 | ○ | ×
 |  |  | バックアップ | ○ | ×
 |  |  | リカバリ | ○ | ×
 |  |  | データロード | ○ | ×
 |  |  | 再編成 | ○ | ×
 |  |  | インデクスの再編成 | ○ | ×
 |  |  | 空きページ解放 | ○ | ×
 |  |  | 表情報をファイルに保存 | ○ | ○
 |  |  | インデクス情報をファイルに保存 | ○ | ○
 |  |  | 改ざん防止ウィザード | ○ | ×
 |  |  | 表詳細情報 | ○ | ○
 |  | [RDエリア]マップ | RDエリアの追加 | ○ | ×
 |  |  | RDエリアの削除 | ○ | ×
 |  |  | RDエリアの拡張 | ○ | ×
 |  |  | RDエリアの再初期化 | ○ | ×
 |  |  | バックアップ | ○ | ×
 |  |  | リカバリ | ○ | ×
 |  |  | データロード | ○ | ×
 |  |  | 再編成 | ○ | ×
 |  |  | 空きページ解放 | ○ | ×
 |  |  | RDエリア情報をファイルに保存 | ○ | ○
 |  |  | レプリカ定義 | ○ | ×
 |  |  | 構成情報複写 | ○ | ×
 |  |  | レプリカグループ統合 | ○ | ×
 |  |  | RDエリア詳細情報 | ○ | ○
 |  | [ユーザ]マップ | ユーザ追加 | ○ | ×
 |  |  | ユーザ削除 | ○ | ×
 |  |  | アクセス権限 | ○ | ×
 |  |  | ユーザ権限 | ○ | ×
 |  | [デバイス]マップ | バックアップ | ○ | ×
 |  |  | リカバリ | ○ | ×
 |  |  | データロード | ○ | ×
 |  |  | 再編成 | ○ | ×
 |  |  | 空きページ解放 | ○ | ×
 |  |  | デバイス情報削除 | ○ | ○
 |  | [HiRDBファイルシステム領域]マップ | HiRDBファイルシステム領域の追加 | ○ | ×
 |  |  | HiRDBファイルシステム領域の削除 | ○ | ×
 |  |  | HiRDBファイルの削除 | ○ | ×
 |  |  | HiRDBファイルシステム領域のバックアップ | ○ | ×
 |  |  | HiRDBファイルシステム領域のリカバリ | ○ | ×
 |  |  | HiRDBファイルのバックアップ | ○ | ×
 |  |  | HiRDBファイルのリカバリ | ○ | ×
 |  |  | HiRDBファイルシステム領域情報をファイルに保存 | ○ | ○
 |  |  | 世代登録 | ○ | ×
 |  |  | 世代削除 | ○ | ×
 |  |  | HiRDBファイルシステム領域詳細情報 | ○ | ○
 |  | [リソース関係表]コマンド |  | ○ | ○
 |  | [インナレプリカ]マップ | カレントRDエリアの変更 | ○ | ×
 |  |  | バックアップ | ○ | ×
 |  |  | リカバリ | ○ | ×
 |  |  | データロード | ○ | ×
 |  |  | 再編成 | ○ | ×
 |  |  | 空きページ解放 | ○ | ×
 |  | [グローバルバッファ]マップ | 追加 | ○ | ×
 |  |  | 割り当て | ○ | ×
 |  |  | 変更 | ○ | ×
 |  |  | 削除 | ○ | ×
 | [バックアップ]タブ |  |  | ○ | ×
 | [リカバリ]タブ |  |  | ○ | ×
 | [システムログ管理]タブ |  |  | ○ | ×
 | [ステータスファイル管理]タブ |  |  | ○ | ×
 | [データメンテナンス]タブ |  |  | ○ | ×
 | [スケジュール]タブ |  |  | ○ | ×
 | [表操作]タブ |  |  | ○ | ×
 | [ツール]タブ |  |  | ○ | ○
 | [管理HiRDB]タブ |  |  | ○ | ×
 | [監視]タブ |  |  | ○ | ×


メニューバー

メニューバーには、以下のようなメニューがあります。

[オプション]メニュー

[ウィンドウ]メニュー

[ヘルプ]メニュー


[オプション]メニュー

[オプション]メニューには、以下のようなコマンドがあります。

[コンソール接続数の設定]

[パスワードの変更]

[管理情報の更新間隔変更]

[管理情報の更新]

[管理情報のバックアップ/リカバリ]

[コンソール応答待ち時間の変更]

[JP1/AJS2との連携]

[ロギング情報表示設定 ]

[HiRDB開始制御]

[コンソールの終了]


[コンソール接続数の設定]

ConsoleがServerへ同時に接続可能な最大接続数の設定をします。

このコマンドを選択すると、[コンソール接続数の設定]画面が表示されます。

1. Consoleの「最大接続数」を指定する。

設定範囲は((1～10))の間で指定することができます。デフォルト値は<<2>>です。

2. [OK]ボタンをクリック。

Consoleの最大接続数を変更します。

<注意事項>

· 設定された最大接続数を超えるConsoleの同時接続はできません。

· JP1/AJS2,JP1/IM-SO,JP1/IM,JP1/IM-CM,カタログ実行コマンドとの連携を行う場合は、「最大接続数」を5以上に設定することを推奨します。「最大接続数」が少ないと連携動作中に連携操作が失敗することがありますので注意してください。


[パスワードの変更]

Consoleに接続するためのパスワードを変更します。

このコマンドを選択すると、[パスワードの変更]画面が表示されます。

1. 「対象パスワード」を選択する。

変更するパスワードを選択してください。

2. 「旧パスワード」を指定する。

HiRDB CMで、現在使用しているパスワードを入力してください。

3. 「新パスワード」と「新パスワードの確認」を指定する。

任意のパスワードを「新パスワード」と「新パスワードの確認」に入力してください。(新しいパスワードを2回入力することで、入力の誤りを防ぐことができます。)

パスワードは((最大64文字))までの半角英数字のみ指定可能です。なお、英字の場合は大文字小文字の区別を行います。

4. [OK]ボタンをクリック。

HiRDB CMのパスワードを変更します。

ここで変更したパスワードは、次回Console起動時から使用できます。

<注意事項>

· パスワードはセキュリティ保護のために、定期的に変更することをお勧めします。

· 管理者パスワードと一般ユーザパスワードを同一のものにすることはできません。


[管理情報の更新間隔変更]

[管理情報更新間隔の変更]

HiRDB CMが管理している情報を、自動で更新する間隔の変更を行います。

このコマンドを選択すると、[管理情報更新間隔の変更]画面が表示されます。

1. 更新間隔を指定する。

設定範囲は、[日]は((0～365))、[時]は((0～23))、[分]は((0～59))の間で指定することができます。各管理情報の詳細な説明は、[HiRDB CMが管理する情報]を参照してください。

· 「状態情報」

HiRDBシステムの状態に関する情報を更新する間隔を設定します。

HiRDBシステム・ユニットの稼動状態、ユーザ接続状態、HiRDBプロセス状態などの情報を更新します。

· 「リソース情報」

RDエリアの使用状況に関する情報を更新する間隔を設定します。

RDエリアの使用率、システムログファイル使用量、シンクポイントダンプファイル使用量を更新します。

· 「構成情報」

HiRDBシステムの構成に関する情報を更新する間隔を設定します。

RDエリア・表・インデクス・ユーザ情報を更新します。

· 「定義情報」

HiRDBシステムの定義に関する情報を更新する間隔を設定します。

HiRDBシステム・ユニット・サーバの定義情報を更新します。

2. コマンド実行後の管理情報更新抑止機能の設定。

バックアップを複数サーバに対して取得する、RDエリアを連続で複数作成する等、連続で同じ操作を行う場合、１操作ごとに管理情報更新を行わずに、まとめて管理情報を更新することができます。

チェックボックスがチェックされている場合は、コマンド実行後の管理情報更新は行いません。すべてのコマンド実行後に[管理情報の更新]から手動で管理情報の更新を行ってください。

3. [OK]ボタンをクリック。

HiRDB CM管理情報の更新間隔を変更します。

ここで変更した更新間隔は、即時に反映され、変更された更新間隔で管理情報を更新します。

<注意事項>

· 設定項目をすべて"0"に設定すると管理情報は自動的に更新を行わなくなります。

· 各設定項目の更新間隔に小さい値（数分単位）を設定すると、管理しているHiRDBシステムに大きな負荷がかかることがあります。更新間隔を変更される場合は十分注意してください。

· 系切り替え構成を使用している場合：

  管理情報を更新する場合は、HiRDBが使用するすべてのDISKにアクセス可能である必要があります。特にHiRDBが停止している時は、注意してください。[管理情報更新]中にHiRDBが使用するDISKへのアクセスへ失敗した場合は、取得できなかった情報がすべてデフォルトの値に設定されます。系切り替え構成を使用しているシステムが停止している場合は、管理情報の更新間隔を0に設定することをお勧めします。

· 管理情報更新間隔の初期値：

  管理情報更新間隔の初期値は、Serverのバージョンによって次のように異なります。バージョンアップを行った場合は、バージョンアップを行う前の管理情報更新間隔の値を引き継ぎます。[解説編] > [管理情報蓄積機能]を参照して適切な値に変更してください。

CM Serverバージョン01-00～03-00までの初期値　定義情報：１日　構成情報：１２時間　リソース情報：３０分　状態情報：５分

CM Serverバージョン04-00以降での初期値 定義情報：３０日　構成情報：７日　リソース情報：２４時間　状態情報：３０分

  ただし、CM Serverバージョン08-01以降はインストール時に管理情報自動更新の設定画面で「自動で更新しない」を選択すると、管理情報更新間隔の値は全て０になります。

· HiRDB停止中に自動更新が実行された場合、pdlsのエラーが管理HiRDBが稼動するマシンのsyslog（イベントログ）に表示される場合があります。

· コマンド実行後の管理情報抑止機能の使用した場合、手動で情報更新を行うまで、表示される情報はコマンド実行前の情報になります。

· インナレプリカ機能を使用しているHiRDBシステムの「状態情報」以外の情報を更新する場合は、すべての世代のHiRDBファイルシステム領域にアクセスできる状態にしておく必要があります。通常の運用の状態が、すべての世代のHiRDBファイルシステム領域にアクセスできる状態でない場合は、必ず[状態情報]以外の更新間隔を0に設定してください。

HiRDB CM以外でHiRDBシステムの状態や構成を変更した場合、[オプション]-[管理情報の更新]を実行して即時に管理情報の更新を行うことができます。


[管理情報の更新]

HiRDB CMが管理しているHiRDBシステム情報の即時更新を行います。

このコマンドを選択すると、[管理情報の更新]画面が表示されます。

1. 即時更新を行うHiRDBシステムを選択する。

HiRDB CMが管理するHiRDBシステム一覧項目から即時更新を行うHiRDBシステムを1つ又は複数個選択してください。HiRDBシステムを選択すると各管理情報の最終更新開始時間と終了時間が表示されます。複数のHiRDBシステムを選択した場合は、最後に選択したHiRDBシステムの最終更新開始時間と終了時間が表示されます。各管理情報の詳細な説明は、[HiRDB CMが管理する情報]を参照してください。

2. 即時更新を行う情報種別を選択する。

即時実行する情報の種別を次のいずれかの項目から選択します。

· 「状態情報」

HiRDBシステムの状態に関するHiRDBシステム・ユニットの稼動状態、ユーザ接続状態、HiRDBプロセス状態などの情報を更新します。

· 「リソース情報」

RDエリアの使用状況に関するRDエリアの使用率、ステータスファイル情報、HiRDBファイルシステム領域情報を更新します。

· 「構成情報」

HiRDBシステムのRDエリア・表・インデクス・ユーザ情報を更新します。

· 「定義情報」

HiRDBシステムのHiRDBシステム・ユニット・サーバの定義情報を更新します。

· 「デバイス情報」

HiRDBがインストールされているマシンのデバイス情報を更新します。

3. [実行]ボタンをクリック。

選択されたHiRDBシステムに対して指定された情報種別の情報について即時更新を実行します。

更新処理中は、「管理情報の更新の実行」ダイアログが表示されます。

情報の更新が正常に終了すると「管理情報の更新に成功しました。」メッセージが表示されます。

<注意事項>

· 選択されたHiRDBシステムの情報量により、情報の更新が成功するまでに数分から十数分間かかる場合があります。

· CM Serverバージョン01-01より前のバージョンの場合、いずれかの情報種別を選択しても管理されている全てのシステムに対して全ての情報更新が行われます。また、結果はすぐに戻ってきますが、HiRDB CM Server上の情報更新が終わるまでに、数分間の時間がかかる場合があります。

· [実行]ボタンを続けて何回もクリックすると、管理情報更新の対象となるHiRDBシステムに大きな負荷がかかる恐れがありますので十分注意してください。

· 系切り替え構成を使用している場合：

  管理情報を更新する場合は、HiRDBが使用するすべてのDISKにアクセス可能である必要があります。特にHiRDBが停止している時は、注意してください。[管理情報更新]中にHiRDBが使用するDISKへのアクセスへ失敗した場合は、取得できなかった情報がすべてデフォルトの値に設定されます。

· デバイス情報を一度も取得していない場合、更新日時に、[不明]と表示します。

· CM Server上書きインストール後に「管理情報更新」操作を行わない状態で本画面を表示した場合に前回の更新時刻を表示することが出来ません。[不明]と表示されます。[不明]が表示されている場合は、「管理情報更新」操作実施後に再度本画面を表示してください。


[管理情報のバックアップ/リカバリ｣

[管理情報のバックアップ/リカバリ]

HiRDB CMが管理している情報のバックアップ/リカバリを行います。管理情報のバックアップ/リカバリ機能については、[付録] > [管理情報のバックアップ/リカバリ]機能を参照してください。このコマンドを選択すると、[管理情報のバックアップ/リカバリ]画面が表示されます。

[管理情報のバックアップ/リカバリ]画面では、次のことが実行可能です。

· 管理情報のバックアップ環境設定

· 管理情報のバックアップ実行

· 管理情報のリカバリ実行

· 管理情報のバックアップ環境設定

1. 「バックアップ環境設定」チェックボックスをONにする。

バックアップ環境設定グループが活性化されます。「バックアップ/リカバリ」チェックボックスがOFFになります。

2. バックアップ格納先ディレクトリを指定する。

バックアップ情報を格納するディレクトリを指定します。インストール時には次のディレクトリに指定されています。

<CMSインストールディレクトリ>\cms_backup_dir

3. バックアップ時にデータの再編成を行う」チェックボックスの設定。

バックアップ時に管理情報の再編成も合わせて行う場合は、このチェックボックスをONにします。再編成を行わない場合は、OFFにします。

4. 「自動バックアップ運用を併用する」チェックボックスを設定する。

自動バックアップ運用を併用する場合は、このチェックボックスをONにし、自動バックアップを行う情報更新間隔を設定します。自動バックアップ運用を行わない場合は、このチェックボックスをOFFにします。

5. バックアップ環境設定の更新する。

OKボタンを押すと、設定した内容でバックアップ環境設定が更新されます。

<注意事項>

· バックアップ格納先ディレクトリは、HiRDB CM - Sevrerのインストールディレクトリと別のディスク上のディレクトリを設定してください。

· 管理情報のバックアップ実行

1. 「バックアップ/リカバリ」チェックボックスをONにする。

バックアップ/リカバリグループが活性化されます。「バックアップ環境設定」チェックボックスがOFFになります。

2. 「管理情報のバックアップ」ラジオボタンを選択する。

「管理情報のバックアップ」ラジオボタンを選択します。

3. バックアップ実行する。

OKボタンを押すと、バックアップを実行します。

<注意事項>

· バックアップを実行したときに、HiRDB CMで他の操作が行われていると、バックアップは実行されません。

· バックアップ実行中は、HiRDB CMに対する他の操作を行うことができません。

· バックアップを実行時にHiRDB CM - Server内で管理情報の更新が行われていると、バックアップ処理に時間がかかることがあります。

· 管理情報のリカバリ実行

1. 「バックアップ/リカバリ」チェックボックスをONにする。

バックアップ/リカバリグループが活性化されます。「バックアップ環境設定」チェックボックスがOFFになります。

2. 「管理情報のリカバリ」ラジオボタンを選択する。

「管理情報のリカバリ」ラジオボタンを選択します。

3. バックアップ情報格納先ディレクトリの指定する。

バックアップ情報格納先ディレクトリを指定します。

4. 「リカバリ実行後にバックアップを取得する」チェックボックスの設定する。

リカバリが成功した後にバックアップ情報を取得する場合はこのチェックボックスをONにします。

5. リカバリ実行する。

OKボタンを押すと、指定したバックアップ情報の詳細が表示されます。表示された内容を確認して問題がなければ、実行ボタンを押し、リカバリを実行します。

<注意事項>

· 管理情報のリカバリを行う場合は、バックアップ情報が次に示す条件を満たしている必要があります。

・ リカバリを実行するServerと同一バージョン、同一リビジョンのServerで取得したバックアップ情報である

・ リカバリを実行するServerと同じインストールパスを持つServerで取得したバックアップ情報である

・ リカバリを実行するServerと同じ標準IPアドレス、ポート番号を使用するServerで取得したバックアップ情報である

・ リカバリを実行するServerと同じ規模でインストールされたServerで取得したバックアップ情報である

· 管理情報のリカバリを行う前には、次のことを行う必要があります。

・ 管理情報の自動更新を停止する（管理情報更新間隔を0に設定する）

・ 登録されている自動メンテナンス機能を停止する

・ 複数のマシンから Serverに接続してる場合、管理情報のリカバリを実行するConsole以外 Consoleを終了する

・ Web Consoleを使用している場合、Webアプリケーションサーバを停止しておく

・ 管理HiRDBのマネージャノードが系切り替え構成を使用している場合、実行系が現用系であることを確認しておく

· リカバリを実行したときに、HiRDB CMで他の操作が行われていると、リカバリは実行されません。

· リカバリ実行中は、HiRDB CMに対する他の操作を行うことができません。


[コンソール応答待ち時間]

[コンソール応答待ち時間の変更]

ConsoleがServerへ要求した処理の応答を待つ最大待ち時間を設定します。

このコマンドを選択すると、[コンソール応答待ち時間の変更]画面が表示されます。

1. Consoleの「最大応答待ち時間」を指定する。

設定範囲は((60～3600)秒)の間で指定することができます。デフォルト値は<<300>>秒です。

2. [OK]ボタンをクリック。

Consoleの応答待ち時間を変更します。

<注意事項>

· 変更したコンソール応答待ち時間は、次回起動するHiRDB CM Consoleから有効となります。変更したコンソール応答待ち時間を使用する場合は、コンソール応答待ち時間変更後にHiRDB CM Consoleを一旦終了させ、再起動してください。

· 指定した応答待ち時間を越えてもServerからの応答が無い場合は、KFPE11117-Eメッセージを表示してServerとの接続を切断します。

· 管理するHiRDBシステムによっては、指定した時間内に応答が返せない場合があります。このため、900秒未満の時間を指定すると誤って、操作が中断されることがあります。

· KFPE11117-Eメッセージが頻繁に表示される場合は、この指定値が小さいことが考えられます。現在の指定値より長い時間に変更してください。

· 指定した応答待ち時間は,次の操作に対しては無効です。

バックアップ実行

リカバリ実行

· 次の操作実行途中にConsoleの応答待ち時間切れが発生した場合は,操作中の画面を中断しますが,対象HiRDBに対しての実行は継続します。

この応答待ち時間切れが発生した場合は,実行中だった処理に対する実行結果を各種状態表示を使って確認してください。

表作成実行

表再編成実行

RDエリア追加実行

RDエリア削除実行

RDエリア拡張実行

RDエリア再初期化実行

RDエリア状態変更実行

アンロード実行

システムログファイルスワップ実行

システムログファイル状態変更実行


[JP1/AJS2との連携]

HiRDB CMで作成したカタログを、JP1/AJS2-Viewのカスタマイズジョブとして登録・スケジュール・実行するための準備（JP1/AJS2-Viewへの登録）を行います。また、連携を解除することもできます。

この機能は、JP1/AJS2カスタムジョブ連携を行う機能です。カタログ実行コマンドを使用してJP1/AJS2と連携を行う場合は、この操作は必要ありません。JP1/AJS2との連携方法については、[連携編] > [JP1/AJS2連携]で説明をしています。

このコマンドを選択すると、[JP1/AJS2との連携]画面が表示されます。

JP1/AJS2との連携機能は、JP1/AJS2の提供する他製品との連携機能（カスタムPCジョブまたはカスタムUNIXジョブ）を利用して、HiRDB CMで作成したカタログ情報をJP1/AJS2のジョブとして扱うことができる機能です。

JP1/AJS2との連携を行うためには、JP1/AJS2カスタムジョブ連携操作手順に従って設定を行う必要があります。

1. JP1/AJS2との連携状態を確認します。

「JP1/AJS2との連携状態」項目に「非連携中」または「連携中」の状態が表示されます。

  表示された状態が「非連携中」の時に「登録」を行うことができます。

  表示された状態が「連携中」の時に「登録解除」を行うことができます。

2. 連携するJP1/AJS2-Viewの情報を確認します。

「マシン名」「IPアドレス」「JP1/AJS2-View インストールディレクトリ」が表示されます。

各項目に表示された情報が正しいかを確認してください。「JP1/AJS2-View インストールディレクトリ」に表示されたディレクトリが「JP1/AJS2-View インストールディレクトリ」と違っている場合は、正しいJP1/AJS2-View インストールディレクトリに変更してください。

3. [登録]または[登録解除]ボタンをクリック。

    [登録]ボタン

JP1/AJS2-Viewのカスタマイズジョブとして登録・スケジュールを実行できる環境を設定するための情報を登録します。

[登録]完了後に、JP1/AJS2-ViewでHiRDB Control Managerのカタログをスケジュール・実行することができます。

    [登録解除]ボタン

JP1/AJS2-Viewのカスタマイズジョブとして登録・スケジュールを実行できる環境を破棄（解除）します。

[登録解除]完了後は、JP1/AJS2-ViewでHiRDB Control Managerのカタログをスケジュール・実行することができません。

JP1/AJS2の提供する他製品との連携機能（カスタムPCジョブまたはカスタムUNIXジョブ）の詳細は、JP1/Automatic Job Management System 2 連携ガイドを参照してください。

JP1/AJS2に登録したカタログの実行結果は、[カタログ実行結果情報]の種別に「JP1/AJS2」として表示されたカタログを選択することで確認できます。

<注意事項>

· CM Consoleと同じマシン上にJP1/AJS2-Viewがインストールされていなければ、このコマンドは操作できません。

· 1台のマシン上に複数HiRDBシステムが存在する場合、そのうちの１つのHiRDBシステムに対してのみJP1/AJS2連携機能を使用することができます。

· 登録解除を行った場合でも、既に設定されたジョブ又はジョブネットは破棄されません。JP1/AJS2-Viewにより、当該ジョブを削除してください。

· JP1/AJS2で設定したジョブ（HiRDB CMカタログ）が不要になった場合は、以下の操作を行ったください。

  (1)JP1/AJS2-Viewにより、当該ジョブを削除

  (2)[スケジュール]タブの[カタログ情報]画面から該当するカタログを選択し、[JP1/AJS2カタログ解除]を実行


[ロギング情報表示設定]

HiRDB CMが管理しているHiRDBシステムの各ユニットが動作するマシン上のsyslog(またはイベントログ)、HiRDBシステムerrlog、cmdlogファイルをConsoleに表示する時に必要となる各種表示項目の設定を行います。この設定値は、[システムステータス]>[詳細]>[シスログ情報]ボタンを操作した場合に使用されます。このコマンドを選択すると、[ロギング情報表示設定]画面が表示されます。

1. 表示範囲を指定する。「表示範囲の指定詳細」

Consoleに表示する各種ロギング情報量を変更することができます。

· 「表示行数」

一度に表示するロギング情報の最大表示行数を指定します。

· 「表示開始位置の選択」

表示するロギング情報の表示開始位置を次の項目から選択することができます。

「最新のログ表示」：最新のロギング情報から遡って情報を表示する場合に選択します。

「開始行の指定」：表示を行う開始行を1～9999の範囲で指定する場合に選択します。

[すべて表示」：ロギング情報をすべてConsoleへ表示する場合に選択します。ただし、表示できるロギング情報は最大10000行です。

2. syslogファイルを指定する。「syslogファイル指定詳細」

HiRDBシステムの各ユニット単位に表示するsyslogファイルのパス名を設定することができます。

[システムステータス]>[詳細]>[シスログ情報]表示操作を行う場合は、該当するHiRDBユニットが動作するOS上のシステムログファイルを設定してください。また、対象となるHiRDBユニットがWindows上で動作している場合、本設定は無効となります。

· 「HiRDBシステム」

対象とするHiRDBシステムを選択します。

· 「ユニット」

対象となるHiRDBシステムのユニットを選択します。

· 「システムロギング情報ファイル名」

「HiRDBシステム」と「ユニット」で選択したHiRDBユニットの動作するOSで取得しているシステムロギング情報ファイルを完全パス名で指定します。この項目は、「参照」ボタンを押して、当該OS上の「ファイル/ディレクトリ一覧」画面から選択することもできます。

3. [OK]ボタンをクリック。

「表示範囲の指定詳細」情報を当該Consoleのみに設定します。この指定値は、他のConsoleへは記録されません。

「syslogファイル指定詳細」情報は、HiRDB CM Serverに記録されます。また、この設定値は他のConsoleへも反映されます。

<注意事項>

· Consoleへ表示する行数が500以上を指定（もしくは「すべてを表示」を選択）した場合、一時的にAgent-Server-Console間のネットワークに負荷がかかったり、当該HiRDBシステムが動作するマシンに負荷がかかることがありますので十分注意してください。

· 表示行数は、表示対象となったロギング情報ファイル内の「改行」文字を1行分として表示します。「改行文字」を含まないロギング情報ファイルを表示する場合は、表示指定に関係なくすべての情報を表示します。

· [システムステータス]>[詳細]>[シスログ情報]表示操作を行う場合は、該当するHiRDBユニットが動作するOS上のシステムログファイルを設定してください。この項目を設定しない、または誤ったファイル名を設定した場合、[シスログ詳細]表示に失敗することが有ります。

Windows上で動作するHiRDBユニットのsyslogをConsoleへ表示する場合は、Windowsの「イベントビューア」で表示される「アプリケーションログ」情報が表示されます。


[HiRDB開始制御]

HiRDBのユニット/サーバ起動時の特殊な起動を行う場合に設定します。

このコマンドを実行すると、[HiRDB開始制御]画面が表示されます。

· [pdrpauseコマンド実行]

  HiRDBシステムまたは、ユニット単独開始時にプロセスサービスの再起動(pdrpause)コマンドの実行を行う場合に設定します。プロセスサービスの再起動(pdrpause)コマンドは、KFPS00715-Eメッセージが出力されて、システムの開始処理又は再開始処理が中断されていた場合に、中断されていたプロセスサービスを再起動を行うコマンドです。通常の運用では、[pdrpauseコマンド実行]を指定しないでください。KFPS00715-Eメッセージが出力され開始処理、または、計画系切り替え処理に失敗した場合に、要因コードに対する障害を取り除いた後に[pdrpauseコマンド実行]を選択し、再度、[開始]または、[計画系切り替え]の実行を行ってください。

<注意事項>

· この機能は、OSがWindowsの場合は設定することができません。

· KFPS00715-Eメッセージが出力されていない状態で、このオプションを指定して[開始]コマンドを実行した場合、システムログファイルにKFPS00760-Eメッセージが出力されます。

· HiRDBシステム定義でpd_mode_confオペランドにAUTOを設定している環境で、このオプションを指定して[開始]コマンドを実行した場合、プロセスサービスの再起動(pdrpause)コマンドのみを実行して、HiRDB 開始(pdstart)コマンドを実行せずに、プロセスサービスの再起動に成功した段階で終了します。これは、プロセスサービスの再起動後にHiRDBが自動的に開始されためです。そのため、数秒待ってから、正常に開始したことを[システムステータス]画面で確認してください。

· [トランザクションキューイング]

影響分散スタンバイレス型系切り替えを使用しているサーバのサーバ単独停止時または計画系切り替え時にトランザクションキューイング（pdtrnqing）コマンドの実行を行う場合に指定します。トランザクションキューイング機能とは、影響分散スタンバイレス型系切り替えを使用しているサーバの、停止時または計画系切り替え時にトランザクションをエラー終了にならないように、系切り替えが完了するまでフロントエンドサーバでトランザクションを一時的に蓄積する機能です。詳細は、HiRDBの「システム運用ガイド」を参照してください。

<注意事項>

· [トランザクションキューイング]機能を使用するには、対象のHiRDBがバージョン07-03以降である必要があります。


[コンソールの終了]

作業を中断し、HiRDB CM Consoleを終了します。


[ウィンドウ]メニュー

[ウィンドウ]メニューには、以下のようなコマンドがあります。

[ボタンメニューの表示]

[ボタンメニューの単一列表示]

[全ボタンメニューの削除]

[アイコンの整列]

[ウィンドウの整列]


[ボタンメニューの表示]

ボタンメニューは、、タブメニューおよびタブメニュー内の各種メニューをアイコン形式で表示します。ボタンメニューのアイコンをクリックすると対応するタブメニューまたは、メニューのチャイルドウィンドウが開きます。

ボタンメニューの表示/非表示を設定します。

[ボタンメニューの表示]コマンドの左にチェック チェック をつけると表示、チェックをつけないと非表示となります。


[ボタンメニューの単一列表示]

ボタンメニューは、、タブメニューおよびタブメニュー内の各種メニューをアイコン形式で表示します。ボタンメニューに表示されたアイコンを縦一列に表示するか否かを設定できます。

[ボタンメニューの単位列表示]コマンドの左にチェック チェック をつけるとアイコンを縦一列に表示します。、チェックをつけないと、表示画面サイズにあわせてアイコンを縦に表示して、それ以上のアイコンは横の列に表示します。


[全ボタンメニューの削除]

ボタンメニューに表示されているすべてのアイコンをボタンメニュー上から削除します。


[アイコンの整列]

[アイコンの整列]コマンド

ウィンドウのアイコンを整列します。

チャイルドウィンドウの[最小化]を行ってアイコン化した場合に、不規則に配置されたアイコンをメイン画面の下部に整列して表示します。


[ウィンドウの整列]

表示されているチャイルドウィンドウを横一列に整列します。

不規則に配置されたチャイルドウィンドウをメイン画面上で横一列に整列して表示します。

<注意事項>

· 複数のチャイルドウィンドウを開いた状態で、[ウィンドウの整列]を行うと右端のチャイルドウィンドウが、他のチャイルドウィンドウと重なって表示される場合があります。


[ヘルプ]メニュー

[ヘルプ]メニューには、以下のようなコマンドがあります。

[コンテキストヘルプの表示]

[目次]

[検索]

[キーワード]

[HiRDB CMバージョン情報]


[コンテキストヘルプの表示]

[コンテキストヘルプの表示]コマンド

コンテキストヘルプは、タブメニュー下にあるHiRDB CMの簡単な説明を表示する機能です。

コンテキストヘルプの表示/非表示を設定します。

[コンテキストヘルプの表示]コマンドの左にチェック チェック をつけると表示、チェックをつけないと非表示となります。


[目次]

[目次]コマンド

ヘルプの[目次]タブを表示します。

この他にも、ヘルプには以下のような検索方法があります。

[検索]コマンド

[キーワード]コマンド


[検索]

[検索]コマンド

ヘルプの[検索]タブを表示します。

キーワード入力欄に語句を入力し、[検索開始]ボタンをクリックするとヘルプ全体の全文検索を行います。入力した語句に関連するトピックのタイトルが一覧表示されます。

<検索オプション>

以下の方法で、さらに的確な結果を得るための検索を行うことができます。

(1). 論理演算子による検索

キーワード入力欄の右にある 右向き三角形 ボタンをクリックするとポップアップメニューが表示され、以下のような検索が行えます。

メニュー | 例 | 結果
AND | a AND b | "a"及び"b"両方を含んだトピック。
OR | a OR b | "a"又は"b"を含むトピック。
NOT | a NOT b | "a"を含むが、"b"を含まないトピック。
NEAR | a NEAR b | "a"の前後8単語以内に"b"が存在するトピック。(英単語のみ有効)

(2). [以前の結果から検索]

以前に実行した検索の結果に対する絞り込み検索を行えます。

(3). [類似する文字に合致]

入力した語句の変化形も含めて検索を行えます。このオプションは英単語のみ有効です。

(4). [タイトルのみ検索]

入力した語句がタイトルのみに含まれるトピックを検索します。

(5). ワイルドカード

英単語の場合のみワイルドカード (*、?) が使用できます。アスタリスク (*) とクォーテーションマーク (?) は単語の1文字にはなりません。ワイルドカードの使用例を以下に示します。

例 | 結果
HiRDB* | "HiRDB"、"HiRDB Control Manager"、"HiRDB CM"など
30?1 | "3001"、"3011"、"3021"など

この他にも、ヘルプには以下のような検索方法があります。

[目次]コマンド

[キーワード]コマンド


[キーワード]

[キーワード]コマンド

ヘルプの[キーワード]タブを表示します。

[キーワード]タブでは、索引が表示されているリストをスクロールさせて目的のトピックを見つける方法と、キーワードを入力して調べる方法があります。

この他にも、ヘルプには以下のような検索方法があります。

[目次]コマンド

[検索]コマンド


[HiRDB CMバージョン情報]

[HiRDB CMバージョン情報]コマンド

HiRDB CMの製品情報を表示します。

· 製品名

· 現在のバージョン情報

・使用しているHiRDB Control Manager - Console バージョン情報を表示します。

・HiRDB Control Manager - Consoleが接続しているHiRDB Control Manager - Server バージョン情報を表示します。

・HiRDB Control Manager - Serverが管理しているHiRDBシステムのHiRDB Control Manager - Agent バージョン詳細情報を表示します。

  HiRDB Control Manager - Agent バージョンは、管理されているHiRDBシステムごとに表示します。

· 著作権情報


ボタンバー

  ボタンバーは、HiRDB CMからHiRDBを管理するための各種機能を呼び出すボタンの一覧が表示されます。このフィールドには、タブメニューのメニューアイコンと各種タブメニューに含まれるサブメニューをドラッグ＆ドロップしておくことができます。

  メニューアイコンをドラッグ＆ドラップして置いたボタンを押すと対応するタブメニューが開かれます。サブメニューをドラッグ＆ドロップたボタンを押すと対応するチャイルドウィンドウが開かれます。ボタンバーにはデフォルトで、タブメニューのメニューアイコンが表示されます。必要のないボタンは、右クリックで表示されるメニューから削除することが可能です。また、[オプション] > [ウィンドウ] > [全ボタンの削除]を実行すると全てのボタンが削除されます。

次に初期状態で表示されるアイコンの説明を行います。

システムステータス システムステータス

このアイコンをクリックすると、[システムステータス]タブを開きます。

マップ マップ

このアイコンをクリックすると、[マップ]タブを開きサブメニューを表示します。

バックアップ

このアイコンをクリックすると、[バックアップ]タブを開きサブメニューを表示します。

リカバリ

このアイコンをクリックすると、[リカバリ]タブを開きサブメニューを表示します。

システムログ管理

このアイコンをクリックすると、[システムログ管理]タブを開きサブメニューを表示します。

[ステータスファイル] ステータスファイル管理

このアイコンをクリックすると、[ステータスファイル管理]タブを開きサブメニューを表示します。

データメンテナンス

このアイコンをクリックすると、[データメンテナンス]タブを開きサブメニューを表示します。

スケジュール

このアイコンをクリックすると、[スケジュール]タブを開きサブメニューを表示します。

表操作

このアイコンをクリックすると、[表操作]タブを開きサブメニューを表示します。

ツール

このアイコンをクリックすると、[ツール]タブを開きサブメニューを表示します。

管理HiRDB

このアイコンをクリックすると、[管理HiRDB]タブを開きサブメニューを表示します。

監視

このアイコンをクリックすると、[監視]タブを開きサブメニューを表示します。


タブメニュー

タブメニューには、以下のようなメニューがあります。

[システムステータス]タブ

[マップ]タブ

[バックアップ]タブ

[リカバリ]タブ

[システムログ管理]タブ

[ステータスファイル管理]タブ

[データメンテナンス]タブ

[スケジュール]タブ

[表操作]タブ

[ツール]タブ

[管理HiRDB]タブ

[監視]タブ


[システムステータス]タブ

管理HiRDBシステムの状態を表示します。

また、HiRDBシステム名をクリックあるいは右クリックで[詳細]コマンドを実行すると、そのHiRDBシステムの構成情報を表示できます。

HiRDBシステムの状態は、アイコンのカラーで表しています。

なお、HiRDBシステムの状態は[管理情報の更新]コマンドの「状態情報」で設定した更新間隔に従って、自動的に更新されます。

以下にHiRDBシステムの状態を説明します。

アイコン | カラー | 状態
 | 緑 | 稼動中
 | 赤 | 停止
 | 青 | 開始準備中、初期化開始中
 | ピンク | 停止準備中
 | 紫 | 一部停止
 | 灰色 | 複写/回復専用開始モード
 | 黒 | 不明※

※不明 : Agentのサービスが停止している、あるいはServerとAgent間で通信障害が発生している可能性があります。

Agentのサービスが停止している場合はサービスを起動してください。通信ができない場合は、障害の対策を行ってください。

HiRDBシステム名をクリックあるいは右クリックでポップアップメニューを表示し選択すると、以下のコマンドが実行できます。このコマンドは、選択したHiRDBシステムの構成及び状態を参照できます。また、状態変更コマンドの実行も可能です。

[詳細]コマンド

[システムステータス]タブ内 (システムステータス名が表示されていない部分） で右クリックするとポップアップメニューが表示され、次のコマンドが実行できます。

[管理HiRDBの新規登録]コマンド

[更新]

<注意事項>

· XDM/RDの状態は「稼動中」、「停止」または「不明」状態のみ表示します。


[詳細]

[システムステータス 詳細]コマンド

[システムステータス]タブで指定されたHiRDBシステムの構成情報を表示します。

また、選択したシステムの各種状態表示及び状態変更が可能です。

実行可能な操作については以降の説明を参照してください。

l [更新]ボタン

「HiRDBシステムの構成」リストに表示されているアイテムを、手動で最新の状態に更新します。また、[F5]キーを押下することでも更新ができます。

ここで表示される情報は、実行時点においてCM Serverで管理されている情報です。HiRDBの最新の情報に更新する場合は、[管理情報の更新]を行った後に実行してください。

l [詳細]ボタン

各種状態表示を実行するためのツールバーとリストを、画面の右側へ表示します。

§ HiRDBシステムの構成

§ HiRDBシステム・ユニットの状態変更

- 正常開始 (pdstart)

- 複写/回復専用開始モード (pdstart -r)

- 強制開始 (pdstart dbdestroy)

- 待機状態変更

- 正常終了 (pdstop)

- 計画停止 (pdstop -P)

- 強制停止 (pdstop -f)

- 計画系切り替え

§ 各種状態表示と状態変更

- HiRDBシステム詳細情報

- ユーザ状態表示 (pdls -d act)

- トランザクション状態表示 (pdls -d trn -a)

- 排他制御情報表示 (pdls -d lck -a)

- 排他資源使用率表示 (pdls -d lck -p)

- グローバルバッファ情報の表示 (pdbufls -k all)

- 共有メモリの使用量表示 (pdls -d mem)

- 通信制御情報表示 (pdls -d rpc)

- 通信制御詳細情報表示 (pdls -d rpc -a)

- ユニット詳細情報

- ユニット用ステータスファイル状態表示 (pdls -d sts -u ユニット名)

- コマンドログ情報

- エラーログ情報

- シスログ情報

- サーバ詳細情報

- RDエリア詳細情報 (pddbls -s サーバ名)

- システムログファイル詳細情報 (pdlogls -d sys -s サーバ名)

- プロセスの状態表示 (pdls -d prc -s サーバ名)

- サーバ用ステータスファイル状態表示 (pdls -d sts -s サーバ名)

- シンクポイントダンプファイル詳細情報表示 (pdlogls -d spd -s サーバ名 -e)

- HiRDBデータレプリケ-タ連携状態表示 (pdls -d rpｌ -j -s サーバ名)

各項目の( )は該当の操作を実行した際に発行されるHiRDBコマンドです。

HiRDBのバージョンや構成により、若干異なることがあります。

また、操作によっては実行した際にHiRDBコマンドを発行せず、HiRDB CMが管理している情報を表示する場合があります。

l 「HiRDBシステムの構成」リスト

このリストは、画面が表示された直後はツリーが閉じた状態となっています。ツリーを展開していくと、上から順に「HiRDBシステム」・「ユニット」・「サーバ」のアイコンが表示されます。

<注意事項>

· XDM/RDの状態は「稼動中」、「停止」または「不明」状態のみ表示します。

(1). 「HiRDBシステム」

ツリーの一番上に表示されているアイコンです。

アイコンの横に<<"HiRDB CMニックネーム"("稼動状態")>>を表示します。

XDM/RDの場合は、アイコンの横に<<"XDM/RDサブシステム識別子">>を表示します。

アイコン | 状態
稼動中 | 稼動中
停止 | 停止
開始準備中 | 開始準備中、初期化開始中
停止準備中 | 停止準備中
 | 一部停止
 | 複写/回復専用開始モード
不明 | 不明

(2). 「ユニット」

「HiRDBシステム」アイコンの下に表示されているアイコンです。

スタンバイ型系切り替え構成を使用していない場合、ユニットのアイコンの横に<<"ユニット名"("稼動状態")@"ホスト名">>を表示します。

スタンバイ型系切り替え構成を使用している場合、ユニットのアイコンの横に<<"ユニット名"("稼動状態")@"ホスト名"(系種別：物理状態)>>を表示します。物理状態として表示される情報を以下に示します。

表示形式 | 状態
ONL | 実行処理中
SBY | 待機処理中
(ONL) | 実行系として起動処理中
(SBY) | 待機系として起動処理中
*ONL* | 実行系の再起動待ち中
*SBY* | 実行系の起動待ち中
ONL?? | 系切り替え待ち中
SBY?? | 連動系切り替え待ち中
ONL>> | 実行系の停止処理中
SBY>> | 待機系の停止処理中
STP | 停止中
*** | 不明

<注意事項>

· 待機系の物理状態は、サーバモードまたは、クラスタシステムにHAモニタを使用するモニタモードの場合に有効な値です。

· 対象のユニットがHAモニタまたはMSCS以外のクラスタを使用したIPアドレス引継ぐ構成の場合、待機系の物理状態は[***]として表示されます。

XDM/RDの場合は、アイコンの横に<<"XDM/RDサブシステム識別子"("稼動状態")@"DBコネクションサーバのIPアドレス_DBコネクションサーバのサーバスケジュール番号_RDノード名称">>を表示します。

アイコン | 備考
MGR | · HiRDB/シングルサーバの場合は、このアイコンが表示されます。 · HiRDB/パラレルサーバの場合に、システムマネジャ (MGR) サーバがあるユニットを表します。 · スタンバイ型系切り替え構成を使用している場合に、実行系ユニットを表します。(ユニットが停止してる場合は、現用系ユニットを表します。)
非MGR | · HiRDB/パラレルサーバの場合に、システムマネジャ (MGR) サーバが存在しないユニットを表します。 · スタンバイ型系切り替え構成を使用している場合に、実行系ユニットを表します。(ユニットが停止してる場合は、現用系ユニットを表します。)
 | · スタンバイ型系切り替え構成を使用している場合に、待機系ユニットを表します。(ユニットが停止してる場合は、予備系ユニットを表します。)

ユニット情報として表示する文字の色はそのユニットの状態によって変化します。また、系切り替えを使用しているユニットの場合は、「物理状態」に対応します。以下にユニット情報とし表示される文字の色とユニットの状態の関係を示します。

アイコンカラー | カラー名 | 状態(系切り替えを使用していないユニットの場合) | 物理状態(系切り替えを使用しているユニットの場合)
 | 緑 | 稼動中 | ONL
 | 赤 | 停止 | STP
 | 青 | 開始準備中、初期化開始中、ウェイト状態 | (ONL) 、*ONL*、ONL??、
 | ピンク | 停止準備中 | ONL>>
 | 紫 | サーバ一部停止 | －
 | 黒 | 不明 | ***
 | 茶 | - | SBY、(SBY) 、*SBY*、SBY?? 、SBY>>
 | オレンジ | トランザクション抑止中 | －

(3). 「サーバ」

「ユニット」アイコンの下に表示されているアイコンです。

影響分散スタンバイレス型系切り替えを使用していない場合は、アイコンの横に<<"サーバ名(状態)">>を使用していない場合は、アイコンの横に<<"サーバ名(状態)">>を表示します。

影響分散スタンバイレス型系切り替えを使用している場合は、アイコンの横に<<"サーバ名(状態)(種別)">>を表示します。系切り替えを使用していないサーバは、「状態」として、pdls -d svrの結果に対応する情報を表示します。一方、影響分散スタンバイレス型系切り替えを使用しているサーバは、「状態」としてpdls -d ha -aの結果に対応する情報を表示します。

XDM/RDの場合は、アイコンの横に<<"XDM/RDサブシステム識別子">>を表示します。

アイコン | 備考
SDS | シングルサーバ (SDS) を表しています。
BES | バックエンドサーバ (BES) を表しています。 影響分散スタンバイレス型系切り替え構成を使用している場合は、稼動中であるサーバを表しています。(サーバが停止している場合は、ホストBESを表します。)
DS | ディクショナリサーバ (DS) を表しています。
FES | フロントエンドサーバ (FES) を表しています。
 | 影響分散スタンバイレス型系切り替え構成を使用している場合は、待機中であるサーバを表しています。(サーバが停止している場合は、ゲストBESを表します。)

サーバ情報として表示する文字の色はそのサーバの状態によって変化します。また、以下にサーバ情報とし表示される文字の色とサーバの状態の関係を示します。

アイコンカラー | カラー名 | 状態
 | 緑 | 稼動中
 | 赤 | 停止
 | 青 | 開始準備中、系切り替え中、ウェイト状態、初期化開始中
 | ピンク | 停止準備中
 | 黒 | 不明
 | 茶 | 待機状態
 | オレンジ | トランザクション抑止中

l ツールバー [HiRDBシステム・ユニット・サーバの状態変更]

[システムステータス 詳細]画面の上部に配置されている8つのボタンの説明をします。

「HiRDBシステムの構成」リストで対象を選択し、ボタンをクリックするとHiRDBシステムあるいはユニット、サーバの状態変更を実行します。

また、これらのボタンをクリックすると、実行中にそれぞれの操作を行った「HiRDB名」「操作開始時間」を示すメッセージボックスが表示されます。

<注意事項>

· XDM/RDに対するこれらの操作は失敗します。

[正常開始] [正常開始]ボタン (pdstart)

このボタンをクリックすると「HiRDBシステム」あるいは「ユニット」「サーバ」の正常開始を行います。なお、前回の終了モードが正常停止の場合は[正常開始]、前回の終了モードが強制停止又は、異常終了の場合は[再開始]となります。

<注意事項>

· [正常開始]コマンドは、システムマネジャ (MGR) が存在するユニットの単独開始を実行することはできません。

· ディクショナリサーバ・シングルサーバの単独開始を実行することはできません。

· 系切り替え構成を使用しているシステム、ユニットに対して実行した場合、5分以内にHiRDBが起動しない時は、タイムアウトエラーにより処理を終了します。HiRDBの起動時間が5分以上かかるシステムの場合は、HiRDB CM - Agent定義パラメータ（「WaitTimeUnitStart」「WaitTimeSystemStart」）を変更してください。CM Agent定義の変更方法は、CM Agentのソフトフェア添付資料、Readme.txt、あるいはリリースノートを参照してください。

· 系切り替え構成を使用している場合、CM Agentは構成に応じて以下のHiRDBコマンド、または、クラスタコマンド/APIを発行します。

pdstart -q

monbegin(HAモニタ)

monact(HAモニタ)

OnlineClusterGroup(MSCS)

複写/回復専用開始モード [複写/回復専用開始モード]ボタン (pdstart -r)

このボタンをクリックすると「HiRDBシステム」の複写/回復専用開始モードを行います。

<注意事項>

· 複写/回復専用開始モードは、データベース複写ユティリティ (pdcopy) 又はデータベース回復ユティリティ (pdrstr) を実行するための状態です。下記以外のコマンドを実行した場合はHiRDBの動作が保証されません。

§ データベース複写ユティリティ (pdcopy)

§ データベース回復ユティリティ (pdrstr)

§ HiRDBシステムの状態表示 (pdls)

§ HiRDBシステム・ユニット・サーバの終了 (pdstop)

· 系切り替え構成を使用している場合、複写/回復専用開始は実行できません。

[強制開始] [強制開始モード]ボタン (pdstart dbdestroy)

このボタンをクリックすると「HiRDBシステム」の強制開始モードを行います。

<注意事項>

· 強制開始を行うとデータベースが破壊され、開始後にデータベースの回復が必要になります。強制開始モードで開始する場合は、十分注意してください。

· HiRDBシステムが系切り替え構成を使用している場合：

  HiRDBの起動に必要なIPアドレス、DISK等のシステムリソースを利用可能な状態に準備しておく必要があります。

[待機状態変更] [待機状態変更]ボタン

このボタンをクリックすると待機系の「ユニット」あるいは「サーバ」を待機状態に変更します。[待機状態]を解除(停止)する場合は、正常停止ボタンを実行してください。

<注意事項>

· 系切り替えを使用していないユニットあるいはサーバに対してはこの機能は使用できません。

· HAモニタまたは、MSCSとHA Tool Kit以外のクラスタシステムによる系切り替え構成を使用している場合、この機能は実行できません。

· CM Agentは構成に応じて以下のHiRDBコマンド、または、クラスタコマンドを発行します。

pdstart -q

monbegin(HAモニタ)

[正常停止] [正常終了]ボタン (pdstop)

このボタンをクリックすると「HiRDBシステム」あるいは「ユニット」「サーバ」の正常終了を行います。

<注意事項>

· [正常終了]コマンドは、シングルサーバ (SDS) 又はシステムマネジャ (MGR) が存在するユニットの単独終了を実行することはできません。

· ディクショナリサーバ・シングルサーバの単独終了を実行することはできません。

· 系切り替え構成を使用している場合、CM Agentは構成に応じて以下のクラスタコマンド/APIを発行します。

monend(HAモニタ)

monsbystp(HAモニタ)

hatesbystp(MSCS+HA Toolkit Ex)

OfflineClusterGroup(MSCS)

[計画停止] [計画停止]ボタン (pdstop -P)

このボタンをクリックすると「HiRDBシステム」の計画停止を行います。

<注意事項>

· 系切り替え構成を使用している場合、CM Agentは構成に応じて以下のクラスタコマンド/APIを発行します。

monend(HAモニタ)

monsbystp(HAモニタ)

hatesbystp(MSCS+HA Toolkit Ex)

OfflineClusterGroup(MSCS)

[強制停止] [強制停止]ボタン (pdstop -f)

このボタンをクリックすると「HiRDBシステム」あるいは「ユニット」の強制停止を行います。

<注意事項>

· [強制停止]コマンドのシステムマネジャ (MGR) が存在するユニット単独強制停止はサポートしていません。

· 系切り替え構成を使用している場合、CM Agentは構成に応じて以下のクラスタコマンド/APIを発行します。

monend(HAモニタ)

monsbystp(HAモニタ)

hatesbystp(MSCS+HA Toolkit Ex)

OfflineClusterGroup(MSCS)

[計画系切り替え] [計画系切り替え]ボタン

このボタンをクリックすると「ユニット」あるいは「サーバ」の計画系切り替えを行います。

<注意事項>

· 系切り替えを使用していない「ユニット」あるいは、「サーバ」に対してはこの機能は使用できません。

· HAモニタまたは、MSCSとHA Tool Kit以外のクラスタシステムによる系切り替え構成を使用している場合、この機能は実行できません。

· このコマンドを実行した場合、計画系切り替え用のコマンドの実行に成功した時点で成功になります。実際に計画系切り替えが成功したかどうかは、しばらくしてから状態をみて判断してください。

· CM Agentは構成に応じて以下のHiRDBコマンド、または、クラスタコマンド/APIを発行します。

monswap(HAモニタ)

MoveClusterGroup(MSCS)

l ツールバー [状態表示]

この機能を実行するためには、[詳細]ボタンをクリックして画面の右側にツールバー[状態表示]と表示用のリストボックスを表示します。

次に「HiRDBシステムの構成」リストで対象を選択し、参照したい情報に対応するボタンをクリックすると状態表示用のリストに、実行した結果を表示します。ボタンは、マウスの左クリックで実行するか、または、各ボタンにカーソルを位置付けて、「スペース」キーを押すことにより実行することもできます。

<注意事項>

· XDM/RDに対するこれらの操作は失敗する場合があります。

· 「HiRDBシステム」の状態表示

HiRDBシステム詳細情報 [HiRDBシステム詳細情報]ボタン

このボタンをクリックすると、選択したHiRDBシステムの詳細を表示します。

XDM/RDの場合は、[HiRDBシステムID]に"XDM/RDサブシステム識別子"を表示します。

ユーザ状態表示 [ユーザ状態表示]ボタン (pdls -d act)

このボタンをクリックすると、ユーザの状態を表示します。

トランザクション状態表示 [トランザクション状態表示]ボタン (pdls -d trn -a)

このボタンをクリックすると、トランザクションの状態を表示します。

また、リストで表示されたファイルグループを選択し、リスト下のボタンあるいは右ポップアップメニューを表示するとトランザクションの状態変更が実行できます。

§ 強制終了

排他制御情報表示 [排他制御情報表示]ボタン (pdls -d lck -a)

このボタンをクリックすると、排他制御の占有情報及び待ち情報を表示します。

排他資源使用率表示 [排他資源使用率表示]ボタン (pdls -d lck -p)

このボタンをクリックすると、排他制御資源管理テーブルの使用率を表示します。

グローバルバッファ情報の表示 [グローバルバッファ情報の表示]ボタン (pdbufls -k all)

このボタンをクリックすると、グローバルバッファの状態を表示します。

08-01以降のConsoleでは、グローバルバッファの動的変更は、[マップ]タブ-[グローバルバッファ]画面から行うことができます。

<注意事項>

· XDM/RDに対する情報は、表示,実行できません。

· 複数サーバ上のRDエリアへ1つのグローバルバッファを割当てる場合は、同一グローバルバッファ名称が、該当サーバ数分、表示されます。

· ディクショナリ用RDエリアが閉塞状態にある場合、グローバルバッファ情報を正しく求めることができません。また、このときの表示情報は、正しくありません。グローバルバッファ情報の表示を行う場合は、ディクショナリ用RDエリアが閉塞状態に無いことを確認してください。

· グローバルバッファの各ヒット率は、以前にグローバルバッファ情報表示を実行してから現在までのヒット率を表示します。また、手動でpdbuflsコマンドのグローバルバッファ統計情報表示を行った場合は、そのコマンド実行時から現在までのヒット率を表示します。

共有メモリの使用量表示 [共有メモリの使用量表示]ボタン (pdls -d mem)

このボタンをクリックすると、サーバの共有メモリの情報を表示します。

通信制御情報 [サーバ通信制御情報表示]ボタン (pdls -d rpc)

このボタンをクリックすると、サーバ通信制御情報を表示します。

通信制御詳細情報 [サーバ通信制御詳細情報表示]ボタン (pdls -d rpc -a)

このボタンをクリックすると、サーバ通信制御詳細情報を表示します。

· 「ユニット」の状態表示

ユニット詳細情報 [ユニット詳細情報]ボタン

このボタンをクリックすると、選択したユニットの詳細を表示します。

XDM/RDの場合は、

    ・[ホスト名]に"DBコネクションサーバのIPアドレス_DBコネクションサーバのサーバスケジュール番号_RDノード名称"

    ・[処理対象]に"XDM/RDサブシステム識別子"

    ・[システム定義更新日付]、[ユニット定義更新日付]、[ユニット開始日付]、[ユニット開始時刻]には

      XDM/RDの稼動状態を最後に取得した日時

を表示します。

§ クリーンアップ

  pdcspoolコマンドを使用して、HiRDB運用ディレクトリ下のトラブルシュート情報および作業用一時ファイルを削除します。

ユニットステータスファイル情報 [ユニット用ステータスファイル状態表示]ボタン (pdls -d sts -u ユニット名)

このボタンをクリックすると、選択したユニットのシステムステータスファイル状態を表示します。

また、リストで表示されたファイルグループを選択し、リスト下のボタンあるいは右ポップアップメニューを表示するとステータスファイルの状態変更が実行できます。なお、リストは[Ctrl]あるいは[Shift]キーを使用することで、複数選択が可能です。複数を選択した状態で、右ポップアップメニューの「詳細」を実行すると「詳細情報」画面には選択されたうちのいづれか１つのユニット用ステータスファイルが表示されます。

§ スワップ

§ オープン

§ クローズ

コマンドログ情報 [コマンドログ情報]ボタン

このボタンをクリックすると、選択したユニットのHiRDB運用ディレクトリ/spool/cmdlogディレクトリ下のcmdlog1または、cmdlog2の内容を表示します。表示範囲および表示情報量は、[ロギング情報表示設定]で変更できます。表示された情報内のHiRDBメッセージに対してメッセージの詳細を参照する場合は、[メッセージ詳細説明表示]操作を実行してください。

右クリックから[検索]コマンドを実行することで、表示されている内容から任意の文字列を検索することができます。

エラーログ情報 [エラーログ情報]ボタン

このボタンをクリックすると、選択したユニットのHiRDB運用ディレクトリ/spool/errlogディレクトリ下のerrlog1または、errlog2の内容を表示します。表示範囲および表示情報量は、[ロギング情報表示設定]で変更できます。表示された情報内のHiRDBメッセージに対してメッセージの詳細を参照する場合は、[メッセージ詳細説明表示]操作を実行してください。

右クリックから[検索]コマンドを実行することで、表示されている内容から任意の文字列を検索することができます。

システムログ情報表示 [シスログ情報]ボタン

このボタンをクリックすると、選択したユニットのsyslog情報を表示します。選択したユニットがWindowsの場合は、「イベントログ」－「アプリケーションログ」情報を表示します。表示範囲および表示情報量、または表示対象syslogファイル設定は、[ロギング情報表示設定]で設定できます。また、表示された情報内のHiRDBメッセージに対してメッセージの詳細を参照する場合は、[メッセージ詳細説明表示]操作を実行してください。

右クリックから[検索]コマンドを実行することで、表示されている内容から任意の文字列を検索することができます。

<注意事項>

· [シスログ情報]を操作するには、[メニューバー]>[オプション]>[ロギング情報表示設定]でsyslogファイルの情報を必ず設定する必要があります。

· 「サーバ」の状態表示

サーバ詳細情報 [サーバ詳細情報]ボタン

このボタンをクリックすると、選択したサーバの詳細を表示します。

XDM/RDの場合、[種別]は、"SDS"を表示します。また、[サーバ名称]には、"XDM/RDサブシステム識別子"を表示します。

§ アンロード制御

  HiRDBシステムのすべてのサーバの自動ログアンロード制御情報を表示します。表示されているサーバが自動ログアンロード機能が有効である場合に実行することができます。

§ キューイング

  選択されているサーバに対してトランザクションキューイング (pdtrnqing) コマンドを実行します。トランザクションキューイング機能とは、影響分散スタンバイレス型系切り替えを使用しているサーバの、停止時または計画系切り替え時にトランザクションをエラー終了にならないように、系切り替えが完了するまでフロントエンドサーバでトランザクションを一時的に蓄積する機能です。詳細は、HiRDBマニュアル「システム運用ガイド」を参照してください。

<注意事項>

· [キューイング]機能は、対象HiRDBが07-03以降のバージョンでのみ実行可能です。

· [キューイング]機能は、対象のサーバが影響分散スタンバイレス型系切り替えを使用している場合にのみ実行可能です。

RDエリア詳細情報 [RDエリア詳細情報]ボタン (pddbls -s サーバ名)

このボタンをクリックすると、RDエリアの状態を表示します。また、リストで表示されたRDエリア名を選択し、リスト下のボタンあるいは右ポップアップメニューを表示するとRDエリアの状態変更が実行できます。

なお、リストは[Ctrl]あるいは[Shift]キーを使用することで、複数選択が可能です。複数を選択した状態で、右ポップアップメニューの「詳細」を実行すると「詳細情報」画面には選択されたうちのいづれか１つのRDエリアが表示されます。

XDM/RDの場合は、セグメントに関する情報を"0"で表示します。

<注意事項>

· XDM/RDに対する状態、HiRDBファイルオープン契機は表示されません。

·当該RDエリアがインナレプリカを使用していない場合、「オリジナルRDエリア名」「世代番号」「レプリカステータス」「レプリカカウンタ」項目情報は表示されません。

§ 閉塞

§ 閉塞解除

§ オープン/クローズ

§ カレント変更

システムログファイル情報表示 [システムログファイル詳細情報]ボタン (pdlogls -d sys -s サーバ名)

このボタンをクリックすると、システムログファイルの情報を表示します。

また、リストで表示されたファイルグループを選択し、リスト下のボタンあるいは右ポップアップメニューを表示するとシステムログファイルの状態変更が実行できます。なお、リストは[Ctrl]あるいは[Shift]キーを使用することで、複数選択が可能です。複数を選択した状態で、右ポップアップメニューの「詳細」を実行すると「詳細情報」画面には選択されたうちのいづれか１つのシステムログファイルが表示されます。

<注意事項>

· XDM/RDに対するシステムログファイル情報は表示されません。

§ スワップ

§ 状態変更

§ アンロード

§ オープン

§ クローズ

プロセス状態情報表示 [プロセスの状態表示]ボタン (pdls -d prc -s サーバ名)

このボタンをクリックすると、サーバのプロセスの状態を表示します。

また、リスト下のボタンを押下することで、「サーバプロセス数の変更」または、「サーバプロセスのリフレッシュ」が行えます。

§ プロセス数変更

§ リフレッシュ

サーバステータスファイル情報 [サーバ用ステータスファイル状態表示]ボタン (pdls -d sts -s サーバ名)

このボタンをクリックすると、選択したサーバのシステムステータスファイル状態を表示します。

また、リストで表示されたステータスファイルを選択し、リスト下のボタンあるいは右ポップアップメニューを表示するとステータスファイルの状態変更が実行できます。なお、リストは[Ctrl]あるいは[Shift]キーを使用することで、複数選択が可能です。複数を選択した状態で、右ポップアップメニューの「詳細」を実行すると「詳細情報」画面には選択されたうちのいづれか１つのサーバ用ステータスファイルが表示されます。

§ スワップ

§ オープン

§ クローズ

シンクポイントダンプファイル [シンクポイントダンプファイル詳細]ボタン (pdlogls -d spd -s サーバ名 -e)

このボタンをクリックすると、シンクポイントダンプファイルの詳細情報を表示します。

§ シンクポイントダンプの取得

  画面下の[取得]ボタンを押すことで、pdlogsyncコマンドにより対象サーバのシンクポイントダンプを取得することができます。また、コマンド実行時には、pdlogsyncコマンドのタイムアウト時間を指定することもできます。

HiRDBデータレプリケ-タ詳細情報 [HiRDBデータレプリケ－タ連携状態表示]ボタン (pdls -d rpl -j -s サーバ名)

このボタンをクリックすると、HiRDBデータレプリケ－タ連携情報を表示します。

<注意事項>

· 連携状態は、抽出の対象となるデータベースが存在しHiRDB Datareplicator連携が開始されている場合に、「使用」と表示されます。抽出の対象となるデータベースが存在しても、HiRDB Datareplicator連携が開始されていない場合は、「未使用」と表示されます。


[マップ]タブ

[マップ]タブには、以下のようなコマンドがあります。

[表]

[RDエリア]

[ユーザ]

[デバイス]

[HiRDBファイルシステム領域]

[リソース関係表]

[インナレプリカ]

[グローバルバッファ]


[表]

[表]コマンド

選択したHiRDBまたはXDM/RDシステム下の表情報を表示します。対象となる表は、ユーザ用の実表のみであり、ディクショナリ表、ビュー表等は表示されません。

また、選択したシステムや表に対し、各種操作を行うことができます。詳細は以降の説明を参照してください。

このコマンドを選択すると、[表 マップ]画面を表示します。

「システム」コンボボックスから参照したいHiRDBシステムまたは、XDM/RDシステムを選択しますると、選択したシステムに定義されている全ての表が「表一覧」リストに表示されます。「表一覧」の表示形式は、「アイコン形式」「リスト形式」を選択することができます。

「表一覧」リストに表示されている表アイコンを選択すると拡張画面が表示され、表の格納されているRDエリア情報、および、表に定義されているインデクス情報を確認することができます。

<注意事項>

· インナレプリカ機能を使用している場合、「RDエリア情報」・「インデクス情報」で表示されるRDエリアはオリジナルRDエリアとなります。また、表を選択してデータロード・再編成などの操作を世代番号を指定しないで行う場合、カレントRDエリアが対象となります。

· クラスタキーを定義した表を選択した場合、「インデクス情報」一覧項目にHiRDBが自動的に作成した「クラスタインデクス」名を持つインデクス情報が表示されます。

[表 マップ]画面では、次の操作を行うことができます。

§ [定義系SQL] 定義系SQL

選択されているシステムに対してデータベース定義ユティリティ(pddef)の実行を行います。新たな表を作成する場合に使用します。

§ [DICの再編成] DICの再編成

選択されているシステムのディクショナリ表（DIC)に対するデータベース再編成ユティリティ(pdrorg)の実行を行います。

§ [DICの空きページ解放] DICの空きページ解放

選択されているシステムのディクショナリ表（DIC)に対する空きページ解放ユティリティ(pdreclaim)の実行を行います。

§ [バックアップ] バックアップ

拡張画面のRDエリア情報で選択されているRDエリアに対するバックアップを行います。

§ [リカバリ] リカバリ

拡張画面のRDエリア情報で選択されているRDエリアに対するリカバリを行います。

§ [データロード] データロード

選択されている表に対するデータロードを行います。

§ 再編成 再編成

選択されている表に対する再編成を行います。

§ [インデクスの再編成] インデクスの再編成

拡張画面のインデクス情報で選択されているインデクスに対する再編成を行います。

§ 空きページ解放 空きページ解放

選択されている表に対する空きページ解放を行います。

§ [image] 表情報保存

選択されているシステムの全ユーザ表情報を指定したファイルに以下に示すCSV形式で保存します。

番号 | 項目名 | 説明
１ | 表名 | HiRDBシステムに登録されている表名を表示します。 ユーザ表が表示されます。ディクショナリ表、ビュー表等は表示されません。
２ | 所有者名 | 対象の表の認可識別子（所有者名）を表示します。
３ | 改ざん防止 | 対象の表が改ざん防止表であるかを表示します。
４ | 表定義日 | 対象の表を作成（定義）した日を表示します。
５ | 表定義変更日 | 対象の表定義を変更した日を表示します。
６ | RDエリア名 | 対象の表のデータが格納される全てのRDエリア名を表示します。 分割表の場合は、複数のRDエリアが 「,」 (カンマ)区切りで表示されます。
７ | 構成列数 | 対象の表を構成する列の総数を表示します。
８ | インデクス定義数 | 対象の表に対して定義されているインデクスの総数を表示します。
９ | 最大行長[B] | 対象の表の最大行長を表示します。
１０ | 平均行長[B] | 対象の表の平均長を表示します。
１１ | BLOB列数 | 対象の表を構成するBLOB列の総数を表示します。
１２ | 格納RDエリア数 | 対象の表のデータが格納されるユーザ用RDエリアの総数を表示します。 LOB用RDエリアの総数は含まれません。
１３ | ユーザLOB用RDエリア数 | 対象の表のデータが格納されるRDエリアの中のLOB用RDエリアの総数を表示します。
１４ | ページ内空き使用比率[%] | PCTFREE:ページ内に設定する未使用領域の比率
１５ | セグメント内空きページ比率[%] | PCTFREE:セグメント内に設定する未使用領域の比率
１６ | 排他資源単位 | 対象の表の排他資源単位を表示します。 排他資源単位が行の場合、「ROW」と表示します。ページ単位の場合、「PAGE」と表示します。
１７ | 表定義キャッシュサイズ[B] | 表個別の定義キャッシュサイズを表示します。 サーバ定義のpd_table_def_cache_size指定値と異なる場合があります。
１８ | FIX指定 | 対象の表定義時にFIX指定を行った場合、「○」と表示します。FIX指定をしていない場合、「×」と表示します。
１９ | ハッシュ関数 | 対象の表がハッシュ関数を使用した分割表の場合、ハッシュ関数名を表示します。ハッシュ関数を使用していない場合は、「------」と表示します。
２０ | 分割種別 | 対象の表が以下に示す特殊な分割表である場合、分割方法を表示します。 境界値分割、マトリックス分割、フレキシブルハッシュ分割、FIXハッシュ分割 上記以外の分割表、または、非分割表の場合は、「------」と表示します。
２１ | WITHOUT ROLLBACK指定 | 対象の表定義時にWITHOUT ROLLBACK指定を行った場合、「○」と表示します。指定していない場合、「×」と表示します。
２２ | リバランス機能使用 | 対象の表がリバランス機能を使用している場合、「○」と表示します。使用しない場合は、「×」と表示します。
２３ | SEGMENT REUSE指定 | 対象の表定義時にSEGMENT REUSE指定を行った場合、「○」と表示します。指定していない場合、「×」と表示します。

<注意事項>

· 最大行長と平均行長は、次に示す規則で計算を行います。

§ 対象表に列データ抑止が指定されている場合であっても、データ抑止されていない場合の値を表示します。

§ SUPPRESS DECIMALを指定した列は、通常のDECIMAL型として計算し、表示します。

§ 実際のデータ長は定義長と同じと見なして計算し、表示します。

§ 対象表に繰返し列、抽象データ型の列が含まれる表の計算は行いません.。「------」と表示します。

§ ノースプリットオプション指定ありの列が存在する場合、ノースプリットオプションが指定されている全列を分岐ありとして計算しても分岐条件が成立する場合は、ノースプリットオプションが指定されている全列が分岐ありとして計算した値を表示します。

· HiRDBのバージョンが06-02以前、および、CM Agentのバージョンが08-00以前の場合、「改ざん防止オプション」は「-」となります。

· 表情報保存機能では、「改ざん防止機能開始日時」「行削除禁止期間」情報がCSVファイルに保存されませんが、[表詳細]画面では表示されます。

§ [image] インデクス情報保存

選択されているシステムの全インデクス情報を指定したファイルに以下に示すCSV形式で保存します。

番号 | 項目名 | 説明
１ | インデクス名 | HiRDBシステムに登録されているインデクス名を表示します。 ユーザ表用インデクスが表示されます。ディクショナリ表用インデクス等は表示されません。
２ | インデクス所有者名 | 対象のインデクスの認可識別子（所有者名）を表示します。
３ | 表名 | 対象のインデクスが定義されている表名を表示します。
４ | 表所有者名 | 対象のインデクスが定義されている表名の認可識別子（所有者名）を表示します。
５ | 改ざん防止 | 対象のインデクスが定義されている表が改ざん防止表であるかを表示します。
６ | ユニークタイプ | 対象のインデクスがユニーク制約として使用される場合は、「○」を表示します。ユニーク制約として使用されない場合は、「×」を表示します。
７ | 主キー | 対象のインデクスが主キー制約として使用される場合は、「○」を表示します。主キー制約として使用されない場合は、「×」を表示します。
８ | クラスタキー | 対象のインデクスがクラスタインデクスである場合は、「○」を表示します。非クラスタインデクスである場合は、「×」を表示します。
９ | DB格納キー長 | 対象のインデクスのDB格納キー長を表示します。
１０ | ページ内未使用領域比率[%] | PCTFREE:ページ内に設定する未使用領域の比率
１１ | 分割キー | 対象のインデクスが分割インデクスである場合は、「○」を表示します。非分割インデクスである場合は、「×」を表示します。 また、対象のインデクスがプラグインインデクスである場合も「○」を表示します。
１２ | RDエリア名 | 対象のインデクスが格納される全てのRDエリア名を表示します。 分割インデクスの場合は、複数のRDエリアが「,」 (カンマ)区切りで表示されます。

<注意事項>

· BINARY型、BLOB型、抽象データ型、BOOLEAN型などのデータ型をインデクス構成列に含む場合、DB格納キー長は計算されません。

§ [image] 改ざん防止表への移行

選択されている表に対する改ざん防止表への移行ウィザードを実行します。

§ [表詳細] 表詳細

選択されている表の詳細情報を参照することができます。

「表詳細」として表示される情報は、「表情報保存」でCSVとして保存される情報と同じ情報です。

<注意事項>

· XDM/RDに対して実行できる操作は以下の操作です。それ以外の操作は失敗します。

- 表情報保存

- インデクス情報保存

- 表詳細表示


[RDエリア]

[RDエリア]コマンド

選択したHiRDBまたはXDM/RDシステム下のRDエリア情報を表示します。

また、選択したシステムやRDエリアに対して、各種操作を行うことができます。詳細は以降の説明を参照してください。

このコマンドを選択すると、[RDエリア マップ]画面を表示します。

「システム」コンボボックスから参照したいHiRDBシステムまたは、XDM/RDシステムを選択すると、選択したシステムが持つRDエリアが「RDエリア一覧」リストに表示されます。「RDエリア一覧」の表示形式は、「アイコン形式」「リスト形式」を選択することができます。

「RDエリア一覧」リストに表示されているRDエリアアイコンを選択すると拡張画面が表示され、RDエリアを構成するHiRDBファイル情報、および、RDエリアに格納されている表/インデクス情報を確認することができます。

<注意事項>

· インナレプリカ機能を使用している場合、オリジナルRDエリアを選択した場合のみ、表/インデクスの一覧が表示されます。レプリカRDエリアを指定した場合は、表/インデクスの一覧は表示されません。また、表/インデクス一覧を選択してデータロード・再編成などの操作を世代番号を指定しないで行う場合、カレントRDエリアが対象となります。

[RDエリア マップ]画面では、次の操作を行うことができます。

§ [RDエリア追加] RDエリア追加

選択されているシステムに新たなRDエリアを追加します。

§ [RDエリア削除] RDエリア削除

選択されているRDエリアを削除します。

§ [RDエリア拡張] RDエリア拡張

選択されているRDエリアの拡張を行います。

データ追加によって、RDエリアの容量が足りなくなった場合にRDエリアを構成するHiRDBファイルを追加し、RDエリアの容量を拡張します。

§ [RDエリア再初期化] 再初期化

選択されているRDエリアの再初期化を行います。

§ [バックアップ] バックアップ

選択されているRDエリアに対するバックアップを行います。

§ [リカバリ] リカバリ

選択されているRDエリアに対するリカバリを行います。

§ [再編成] 再編成

拡張画面の表/インデクス情報で選択されている表に対する再編成を行います。

§ [データロード] データロード

拡張画面の表/インデクス情報で選択されている表に対するデータロードを行います。

§ [空きページ解放] 空きページ解放

拡張画面の表/インデクス情報で選択されている表に対する空きページ解放を行います。

§ [image] RDエリア情報保存

  選択されているシステムの全RDエリア情報を指定したファイルに以下に示すCSV形式で保存します。

番号 | 項目名 | 説明
１ | RDエリア名 | RDエリア名を表示します。
２ | RDエリア種別 | 対象のRDエリアの種別を表示します。
３ | 使用率[%] | 対象のRDエリアの使用率を表示します。
４ | サーバ名 | 対象のRDエリアが存在するサーバ名を表示します。
５ | HiRDBファイル名 | 対象のRDエリアが構成されるHiRDBファイル名を表示します。 複数のHiRDBファイルが表示される場合、,（カンマ）区切りで表示します。
６ | 状態 | 対象のRDエリアの状態を以下の形式でが表示します。 CLOSE クローズ CLOSE HOLD クローズ、障害閉塞 CLOSE HOLD（RIS E） クローズ、障害閉塞中（障害によるログ適用不可能状態） CLOSE HOLD（RIS L） クローズ、障害閉塞中（ログレスモードのUAP，ユティリティの実行によるログ適用不可能状態） CLOSE HOLD（RIS M） クローズ、障害閉塞中（pdmodによるログ適用不可能状態） CLOSE HOLD（INQ） クローズ、参照可能コマンド閉塞 CLOSE HOLD（CMD） クローズ、コマンド閉塞 CLOSE HOLD（BU） クローズ、更新可能バックアップ閉塞 CLOSE HOLD（BU I） クローズ、参照可能バックアップ閉塞 CLOSE HOLD（BU W） クローズ、更新可能バックアップ閉塞（WAITモード） CLOSE HOLD（BU IW） クローズ、参照可能バックアップ閉塞（更新WAITモード） CLOSE HOLD(SYNC) クローズ、同期化閉塞 CLOSE ACCEPT-HOLD クローズ、pdholdコマンド受付状態 HOLD 障害閉塞 HOLD（INQ） 参照可能コマンド閉塞 HOLD（CMD） コマンド閉塞 HOLD（BU） 更新可能バックアップ閉塞 HOLD（BU I） 参照可能バックアップ閉塞 HOLD（BU W） 更新可能バックアップ閉塞（WAITモード） HOLD（BU IW） 参照可能バックアップ閉塞（更新WAITモード） HOLD（SYNC） 同期化閉塞 HOLD（RIS E） 障害閉塞中（障害によるログ適用不可能状態） HOLD（RIS L） 障害閉塞中（ログレスモードのUAP、ユティリティの実行によるログ適用不可能状態） HOLD（RIS M）障害閉塞中（pdmodによるログ適用不可能状態） ACCEPT-HOLD pdholdコマンド受付状態 OPEN オープン状態 HOLD(ORG) オンライン再編成閉塞 CLOSE HOLD（ORG） クローズ、オンライン再編成閉塞
７ | ページ長[B] | 対象のRDエリアのページ長を表示します。
８ | セグメントサイズ | 対象のRDエリアの１セグメントあたりのページ数を表示します。
９ | 全セグメント数 | 対象のRDエリアの全セグメント数を表示します。
１０ | 自動増分セグメント数 | 対象のRDエリアの自動増分セグメント数を表示します。
１１ | HiRDBファイルオープン契機 | 対象のRDエリアのHiRDBファイルのオープン契機を表示します。
１２ | オリジナルRDエリア名 | 対象のRDエリアがインナレプリカ機能を使用している場合、オリジナルRDエリア名を表示します。インナレプリカ機能を使用していない場合は空白になります。
１３ | 世代番号 | 対象のRDエリアがインナレプリカ機能を使用している場合、世代番号を表示します。インナレプリカ機能を使用していない場合は空白になります。
１４ | レプリカステータス | 対象のRDエリアがインナレプリカ機能を使用している場合、レプリカ状態を表示します。インナレプリカ機能を使用していない場合は空白になります。
１５ | レプリカ数 | 対象のRDエリアがインナレプリカ機能を使用していて、オリジナルRDエリアの場合、定義されているレプリカRDエリアの総数を表示します。インナレプリカ機能を使用していない場合、またはレプリカRDエリアの場合は空白になります。

§ [image] レプリカRDエリアの定義

選択されているRDエリアに対するレプリカRDエリアの定義を行います。

§ [image] RDエリアの構成情報複写

選択されているオリジナルRDエリアの構成情報をレプリカRDエリアに複写します。

§ [image] インナレプリカグループの統合

選択されているオリジナルRDエリアをレプリカRDエリアと統合し、一つのRDエリアにします。

§ [RDエリア詳細] RDエリア詳細

選択されているRDエリアの詳細な情報を参照することができます。

「RDエリア詳細」として表示される情報は、「RDエリア情報保存」でCSVとして保存される情報と同じ情報です。

<注意事項>

· XDM/RDに対して実行できる操作は以下の操作です。それ以外の操作は失敗します。

- RDエリア情報保存

- RDエリア詳細表示

l RDエリアの追加

データベース構成変更ユティリティのRDエリアの追加機能を実行します。

[RDエリア追加]ボタンをクリックすると、RDエリアの追加機能を実行するための画面を表示します。

<前提条件>

· ここで追加できるRDエリアは、ユーザ用RDエリア、ユーザLOB用RDエリア、リスト用RDエリアです。その他のRDエリアは追加することができません。

1. 追加する「RDエリア名」を指定する。

新たに追加するRDエリア名を入力してください。

RDエリア名は((最大30文字))まで指定可能です。

2. RDエリアを追加する「サーバ」を選択。

RDエリアの追加を行うサーバを選択してください。

3. RDエリアの「種類」を選択。

追加するRDエリアの種類を選択してください。

· ユーザ用RDエリア

· ユーザLOB用RDエリア

· リスト用RDエリア

4. 「ページ長」を指定する。

RDエリアを構成するHiRDBファイルのページ長を、2,048の倍数のバイト単位で入力してください。

なお、追加するRDエリアの「種類」がユーザLOB用RDエリアの場合は、<<8,192>>で固定されます。この値は、8,192以外の値を指定した場合でも、8,192で実行されます。

ユーザLOB用RDエリア以外の種類については、マニュアル「HiRDB システム導入・設計ガイド」を参照してください。

5. 「セグメントサイズ」を指定する。

1セグメントの大きさを、ページ数で入力してください。

なお、追加するRDエリアの「種類」がユーザLOB用RDエリアの場合は、<<1>>で固定されます。この値は、1以外の値を指定した場合でも、1で実行されます。

ユーザLOB用RDエリア以外の種類については、マニュアル「HiRDB システム導入・設計ガイド」を参照してください。

6. 「一時割り当てするグローバルバッファ名」を指定する。

追加するRDエリアに一時的にグローバルバッファを割り当てたい場合に選択します。

省略した場合は、システム定義で指定したグローバルバッファに割り当てられます。

<注意事項>

· 対象のRDエリアのページ長より大きいグローバルバッファのみを表示します。

· RDエリアを追加するサーバに既存のRDエリアがひとつも存在しない場合、種別が「その他」のグローバルバッファを選択してもRDエリアの追加に失敗します。対象サーバにグローバルバッファが何も割り当てられていない場合は、[グローバルバッファの動的変更]を使用してRDエリア作成後に一時割り当てを行ってください。

· 対象のRDエリアが存在するサーバ上のグローバルバッファのみを表示します。HiRDBシステム定義に記載されたグローバルバッファであっても、対象サーバ上でどのRDエリアも使用していない場合は、表示されません。

7. 「自動増分セグメント数」を指定する。

RDエリアの自動増分機能を使用する場合に自動増分セグメント数を指定します。

0を指定した場合は、自動増分機能機能を適用しません。

<注意事項>

· 自動増分機能を適用する場合、RDエリアに対して割り当てるHiRDBファイルシステム領域に「増分回数指定」が指定されている必要があります。

8. RDエリアに対して割り当てる「HiRDBファイル領域名」及び「HiRDBファイル名」と「セグメント数」を指定する。

コンボボックス「HiRDBファイルシステム領域名」を選択し、「HiRDBファイル名」を入力してください。そして、入力した「HiRDBファイル名」のセグメント数を指定します。

これらを指定したら[追加]ボタンをクリックし、下のリストへ追加します。

リストへ追加されたHiRDBファイルシステム領域とHiRDBファイルが実行する対象となります。

リストにHiRDBファイルシステム領域とHiRDBファイルを誤って追加した場合は、[削除]ボタンをクリックします。すると、リストで選択したHiRDBファイルシステム領域とHiRDBファイルを実行する対象から削除します。

HiRDB CMにHiRDBファイルシステム領域が登録されていない場合は、[システム領域の初期設定]ボタンをクリックすると、[HiRDBファイルシステム領域の初期設定]コマンドが実行できます。

· HiRDBファイル一覧のセグメント数はHiRDB CM Agentがv0801以降の場合に表示します。HiRDB CM Agentのバージョンがv0800以前の場合は「-」が表示されます。また、HiRDB CM Server バージョンアップ後に構成情報更新を行わずに画面を開いた場合、HiRDBファイル一覧のセグメント数には「-」が表示される場合があります。

9. [実行]ボタンのクリック。

RDエリアの追加を実行します。

l RDエリアの削除

データベース構成変更ユティリティのRDエリアの削除機能を実行します。

リスト「RDエリア一覧」からRDエリアアイコンを選択し[RDエリア削除]ボタンをクリックすると、RDエリアの削除を実行します。

<前提条件>

· ここで削除できるRDエリアは、ユーザ用RDエリア、ユーザLOB用RDエリア、リスト用RDエリアです。その他のRDエリアは削除することができません。また、削除するRDエリア内に表/インデクスが存在する場合もRDエリアを削除することはできません。

<注意事項>

· RDエリアの削除に失敗した場合、対象RDエリアの状態が閉塞&クローズになる可能性があります。

· オリジナルRDエリアの削除はできません。レプリカグループの統合を行った後、削除してください。

· レプリカRDエリアの削除は、同じインナレプリカグループ内にレプリカRDエリアが二つ以上ある場合にだけ実行できます。一つだけレプリカRDエリアがある場合は、レプリカグループの統合を行ってください。

l RDエリアの拡張

データベース構成変更ユティリティのRDエリアの拡張機能を実行します。

リスト「RDエリア一覧」からRDエリアアイコンを選択し[RDエリア拡張]ボタンをクリックすると、RDエリアの拡張機能を実行するための画面を表示します。

<前提条件>

· 次のRDエリアはRDエリアの拡張を実行できません。

- レジストリ用RDエリア

- レジストリLOB用RDエリア

1. 「自動増分セグメント数」を指定する。

RDエリアの自動増分機能を使用する場合に自動増分セグメント数を指定します。

0を指定した場合は、拡張前の自動増分セグメント数を引き継ぎます。

<注意事項>

· 自動増分機能を適用する場合、RDエリアに対して割り当てるHiRDBファイルシステム領域に「増分回数指定」が指定されている必要があります。

2. RDエリアに対して追加する「HiRDBファイル領域名」及び「HiRDBファイル名」と「セグメント数」を指定する。

コンボボックス「HiRDBファイルシステム領域名」を選択し、「HiRDBファイル名」を入力してください。そして、入力した「HiRDBファイル名」のセグメント数を指定します。

これらを指定したら[追加]ボタンをクリックし、下のリストへ追加します。

リストへ追加されたHiRDBファイルシステム領域とHiRDBファイルが実行する対象となります。

リストにHiRDBファイルシステム領域とHiRDBファイルを誤って追加した場合は、[削除]ボタンをクリックします。すると、リストで選択したHiRDBファイルシステム領域とHiRDBファイルを実行する対象から削除します。

HiRDB CMにHiRDBファイルシステム領域が登録されていない場合は、[システム領域の初期設定]ボタンをクリックすると、[HiRDBファイルシステム領域の初期設定]コマンドが実行できます。

処理対象のRDエリアがオリジナルRDエリアであれば、[HiRDBファイルシステム領域の世代登録]画面が表示されます。

<注意事項>

· ここでHiRDBファイルシステム領域の世代登録を行わないと、オリジナルRDエリアの拡張用のHiRDBファイルシステム領域として使用することができなくなります。必ず、HiRDBファイルシステム領域の世代登録を行ってください。

· HiRDBファイル一覧のセグメント数はHiRDB CM Agentがv0801以降の場合に表示します。HiRDB CM Agentのバージョンがv0800以前の場合は「-」が表示されます。また、HiRDB CM Server バージョンアップ後に構成情報更新を行わずに画面を開いた場合、HiRDBファイル一覧のセグメント数には「-」が表示される場合があります。

3. [実行]ボタンのクリック。

RDエリアの拡張を実行します。

<注意事項>

· 自動増分機能を適用する場合、RDエリアに対して割り当てるHiRDBファイルシステム領域に「増分回数指定」が指定されている必要があります。

· HiRDB CMでは、レプリカRDエリアの拡張を行うことはできません。

l RDエリアの再初期化

データベース構成変更ユティリティのRDエリアの再初期化機能を実行します。

リスト「RDエリア一覧」からRDエリアアイコンを選択し[RDエリア再初期化]ボタンをクリックすると、RDエリアの再初期化機能を実行するための画面を表示します。

<前提条件>

· ここで再初期化を実行できるRDエリアは、ユーザ用RDエリア、ユーザLOB用RDエリア、リスト用RDエリアです。その他のRDエリアは再初期化を実行することができません。

· 改ざん防止表を含むRDエリアに対して、再初期化を実行することはできません。

1. 「ページ長」を指定する。

RDエリアを構成するHiRDBファイルのページ長を変更する場合に、2,048の倍数のバイト単位で入力してください。

なお、再初期化するRDエリアの「種類」がユーザLOB用RDエリアの場合は、<<8,192>>で固定されます。この値は、8,192以外の値を指定した場合でも、8,192で実行されます。

ユーザLOB用RDエリア以外の種類については、マニュアル「HiRDB システム導入・設計ガイド」を参照してください。

2. 「セグメントサイズ」を指定する。

セグメントサイズを変更する場合に入力してください。

なお、再初期化するRDエリアの「種類」がユーザLOB用RDエリアの場合は、<<1>>で固定されます。この値は、1以外の値を指定した場合でも、1で実行されます。

ユーザLOB用RDエリア以外の種類については、マニュアル「HiRDB システム導入・設計ガイド」を参照してください。

3. 「自動増分セグメント数」を指定する。

RDエリアの自動増分機能を使用する場合に自動増分セグメント数を指定します。

0を指定した場合は、再初期化前の自動増分セグメント数を引き継ぎます。

<注意事項>

· 自動増分機能を適用する場合、RDエリアに対して割り当てるHiRDBファイルシステム領域に「増分回数指定」が指定されている必要があります。

4. [実行]ボタンのクリック。

RDエリアの再初期化を実行します。

<注意事項>

· RDエリアの再初期化に失敗した場合、対象RDエリアの状態が閉塞&クローズになる可能性があります。

· HiRDB CMでは、レプリカRDエリアの再初期化を行うことはできません。

· HiRDBファイル一覧のセグメント数はHiRDB CM Agentがv0801以降の場合に表示します。HiRDB CM Agentのバージョンがv0800以前の場合は「-」が表示されます。また、HiRDB CM Server バージョンアップ後に構成情報更新を行わずに画面を開いた場合、HiRDBファイル一覧のセグメント数には「-」が表示される場合があります。

l レプリカRDエリアの定義

データベース構成変更ユティリティのRDエリアのレプリカ定義機能を実行します。

<前提条件>

· HiRDBシステム定義pd_inner_replica_controlオプションの値が1以上の場合に実行できます。

· 対象のRDエリアがオリジナルRDエリアまたは、レプリカRDエリアが未定義のRDエリアに対して実行します。レプリカRDエリアに対してレプリカ定義を実行することはできません。

· 改ざん防止表を含むRDエリアに対して、レプリカ定義を実行することはできません。

· レプリカ定義を実行できるRDエリアは、ユーザ用RDエリア、ユーザLOB用RDエリアです。その他のRDエリアはレプリカ定義を実行することができません。

· 対象のRDエリアに対するレプリカRDエリアが10以上定義されている場合は、レプリカ定義を実行することはできません。

1. 「レプリカRDエリア名称]を指定する。

「レプリカRDエリア名」テキストボックスにレプリカRDエリア名称を指定します。

2. 「世代番号]を指定する。

「世代番号」コンボボックスに未定義の世代番号が表示されます。作成する世代番号を選択します。

3. 「グローバルバッファ]を指定する。

「割り当てグローバルバッファ」コンボボックスに指定可能なグローバルバッファ名が表示されます。割り当てを行うグローバルバッファ名称を選択します。[オリジナルRDエリアと同じグローバルバッファ]を選択すると、オリジナルRDエリアが使用しているグローバルバッファと同じグローバルバッファが割り当てられます。

<注意事項>

· 対象のRDエリアのページ長より大きいグローバルバッファのみを表示します。

· 対象のRDエリアが存在するサーバ上のグローバルバッファのみを表示します。HiRDBシステム定義に記載されたグローバルバッファであっても、対象サーバ上でどのRDエリアも使用していない場合は、表示されません。

· 選択されたRDエリアがユーザ用RDエリアの場合は、RDエリア用またはother用のグローバルバッファを表示し、選択されたRDエリアがユーザLOB用RDエリアの場合は、LOB用またはother用のグローバルバッファを表示します。

4. HiRDBファイルシステム領域の世代登録情報を指定する。

レプリカRDエリアを定義する場合、オリジナルRDエリアが使用しているすべてのHiRDBファイルシステム領域に指定した世代番号と同一の世代登録を行っておく必要があります。HiRDBファイルシステム領域の世代登録も同時に行う場合に指定します。既に世代登録を行っている場合は、操作する必要はありません。

· 「レプリカHiRDBファイルシステム領域一覧」リストから対象のHiRDBファイルシステム領域を選択します。

· 「下」ボタンを押します。

· 「レプリカHiRDBファイルシステム領域名」テキストボックスにレプリカHiRDBファイルシステム領域名を指定します。

· 「上」ボタンを押し、更新を「レプリカHiRDBファイルシステム領域一覧」リストに反映します。

· 上記の操作を、「レプリカHiRDBファイルシステム領域一覧」リストの定義済みカラムが×になっているHiRDBファイルシステム領域すべてに対して行います。

<注意事項>

· オリジナルRDエリアがレプリカHiRDBファイルシステム領域上に存在する場合、レプリカRDエリアを定義出来ません。

5. 「実行」ボタンをクリックします。

レプリカRDエリアの定義を実行します。

l 構成情報の複写

データベース構成変更ユティリティのRDエリアの構成情報の複写機能を実行します。HiRDB CMでは、レプリカRDエリアを指定して構成情報を複写することはできません。オリジナルRDエリアの構成情報をすべてのレプリカRDエリアに対して一括で行います。

1. HiRDBファイルシステム領域の世代登録。

オリジナルRDエリアが使用しているHiRDBファイルシステム領域に対して、世代登録が行われていないHiRDBファイルシステム領域が存在する場合に、「HiRDBファイルシステム領域の世代登録」ボタンを押し、HiRDBファイルシステム領域の世代登録を行います。

2. 「実行」ボタンをクリックします。

構成情報の複写を実行します。

<注意事項>

· HiRDBファイルシステム領域の世代番号登録に欠落がある場合、エラーになります。

l インナレプリカグループ統合

データベース構成変更ユティリティのRDエリアの統合機能を実行します。

リスト「RDエリア一覧」からRDエリアアイコンを選択し[インナレプリカグループ統合]ボタンをクリックすると、インナレプリカグループ統合を実行します。

<前提条件>

· レプリカRDエリアが一つだけ存在する場合に、インナレプリカグループ統合を実行することができます。複数世代のレプリカRDエリアが存在する場合は、不要なレプリカRDエリアを削除した後に実行してください。

· オリジナルRDエリアとレプリカが一つしかない場合のレプリカRDエリアに対して、RDエリア削除を実行することは出来ません。レプリカ統合に失敗した場合は、手動でRDエリアを削除するか、リカバリを実行してください。


[ユーザ]

[ユーザ]コマンド

選択したHiRDBシステム下のユーザ情報を表示します。また、[表示種別]選択することで、ユーザ情報からの関連表情報表示や、表情報からの関連ユーザ情報表示ができます。

このコマンドを選択すると、[ユーザマップ]画面を表示します。

1．「HiRDBシステム」

ユーザ情報を参照するHiRDBシステムを選択します。選択したHiRDBシステムに登録されているユーザが「ユーザ一覧」リストに表示されます。

2．「表示種別」

選択したHiRDBシステム下のユーザ情報について「ユーザ」または「表」を選択します。選択した表示種別により「ユーザ」であれば「ユーザ一覧」を表示し,「表」であれば「表一覧」を表示します。

  § 「ユーザ一覧」

    この画面では、[表示種別]で「ユーザ」を選択すると[ユーザ追加]および[ユーザ削除]を行うことができます。

§ [ユーザ追加] ユーザ追加

新たなユーザを追加します。[ユーザ追加]ボタンをクリックすると[ユーザの追加]画面を表示します。

§ [ユーザ削除] ユーザ削除

   ユーザ一覧リストで選択されたユーザを削除します。

§ [ユーザ権限] ユーザ権限

選択されたユーザの権限を変更します。[ユーザ権限]ボタンをクリックすると[ユーザ権限]画面を表示します。

「ユーザマップ－表一覧」リストに表示されている表を選択して[アクセス権限]ボタンをクリックすると選択した表に対するアクセス権を変更することができます。

§ [アクセス権限] アクセス権限

選択した表に対するアクセス権限を変更します。[アクセス権限]ボタンをクリックすると[アクセス権限]画面を表示します

  § 「表一覧」

この画面では、[表示種別]で「表」を選択すると[表一覧を]を表示します。

「ユーザマップ－ユーザ一覧」リストに表示されている表を選択すると[アクセス権限]または[ユーザ権限]を変更することができます。

§ [アクセス権限] アクセス権限

選択した表に対するアクセス権限を変更します。[アクセス権限]ボタンをクリックすると[アクセス権限]画面を表示します。

§ [ユーザ権限] ユーザ権限

選択された表に対するユーザ権限を変更します。[ユーザ権限]ボタンをクリックすると[ユーザ権限]画面を表示します。

<注意事項>

·PUBLICユーザについて

  ユーザマップでは、PUBLICユーザが表示されます。これは、表のPUBLIC属性をあらわすための擬似的なユーザであり、PUBLICユーザ自身の権限は変更できません。各表に対して、PUBLIC指定を付加したい場合、このPUBLICユーザに権限を付加してください。

·XDM/RDに対する上記の操作は失敗します。

· HiRDB CM ServerまたはHiRDB CM Agentが01-00の場合は、ユーザ情報を表示できません。この環境でユーザ情報を表示するとKFPE23017-Eエラーが発生します。

l ユーザの追加

[ユーザ追加]ボタンをクリックすると、ユーザの追加機能を実行するための画面を表示します。

<前提条件>

· ここで追加できるユーザは、CONNECT権限、スキーマ定義権限、DBA権限を持ったユーザです。その他の権限をもつユーザは追加することができません。

1. 追加する「ユーザ名」を指定する。

新たに追加するユーザ名を入力してください。

ユーザ名は((最大8文字))まで指定可能です。

2. 追加するユーザの「パスワード」を指定する。

追加を行うユーザのパスワードを入力してください。

パスワードは((最大30文字))まで指定可能です。

3. [実行]ボタンのクリック。

ユーザの追加を実行します。

<注意事項>

· ユーザの追加に成功した後に追加したユーザの情報を表示する場合は、F5キーを押してください。

· 既存のユーザと同じ名前のユーザを追加した場合、既存のユーザ情報を指定した値で更新します。

l ユーザ権限

[ユーザ権限]ボタンをクリックすると、ユーザの権限変更機能を実行するための画面を表示します。

1. 変更する「ユーザ権限」を選択する。

現状の権限が「CONNECT権限」「スキーマ定義権限」「DBA権限」のチェックボックスに設定されています。各チェックボックスのチェックを外すことにより権限の削除を行うことができます。また、各チェックボックスをチェックすることにより権限を追加することもできます。

2. [実行]ボタンのクリック。

ユーザ権限の変更を実行します。

<注意事項>

· ユーザ権限の変更に成功した後に変更したユーザの情報を表示する場合は、F5キーを押してください。

l アクセス権限

[アクセス権限]ボタンをクリックすると、表のアクセス権限変更機能を実行するための画面を表示します。

1. 「所有者のパスワード」を指定する。

選択した表の所有者ユーザのパスワードを指定して下さい。

パスワードは((最大30文字))まで指定可能です。

2. 変更する「権限」を選択する。

現状の権限が「SELECT」「INSART」「UPDATE」「DELETE」のチェックボックスに設定されています。各チェックボックスのチェックを外すことにより権限の削除を行うことができます。また、各チェックボックスをチェックすることにより権限を追加することもできます。

3. [実行]ボタンのクリック。

表に対するユーザのアクセス権限変更を実行します。

<注意事項>

· アクセス権限の変更に成功した後に変更したアクセス権限情報を表示する場合は、F5キーを押してください。


[デバイス]

[デバイス]コマンド

指定した管理HiRDBシステム下のデバイス情報を表示します。また、選択したデバイスに格納されているRDエリア及びテーブル一覧を参照できます。

このコマンドを選択すると、[デバイス マップ]画面を表示します。

「HiRDBシステム」コンボボックスから参照したいHiRDBシステムを選択し、次に「ホスト名」コンボボックスからホスト名を選択します。

「デバイス種別」コンボボックスで参照したいデバイス種別を選択すると、「デバイス一覧」リストが表示されます。

「デバイス一覧」リストに表示されているデバイスアイコンを選択すると、「詳細表示」グループで選択した、そのデバイスが持つ情報を参照することができます。

「詳細表示」グループでは以下の情報を選択することができます。

· 「HiRDBリソース」

選択したデバイスが持つ以下のHiRDBリソースを全て表示します。

RDエリア

表/インデクス

システムログファイル

· 「RDエリア」

選択したデバイスが持つ全てのRDエリアを表示します。

· 「表」

選択したデバイスが持つ全ての表を表示します。

· 「システムログファイル」

選択したデバイスが持つ全てのシステムログファイルを表示します。

· 「HiRDBファイルシステム領域」

選択したデバイスが持つ全てのHiRDBファイルシステムを表示します。

· 「ステータスファイルグループ」

選択したデバイスが持つ全てのステータスファイルグループを表示します。

· 「バックアップファイル」

選択したデバイスが持つバックアップファイルを表示します。NetBackupなどの特殊なバックアップ格納領域に取得したバックアップ情報は表示されません。

· 「アンロードログファイル」

選択したデバイスが持つアンロードログファイルを表示します。自動ログアンロード機能または、手動で取得したアンロードログファイルは表示されません。

画面の下部に表示されるリストから選択したRDエリアに対して、バックアップおよびリカバリを実行することができます。

§ [バックアップ] バックアップ

選択されたRDエリアに対するバックアップを行います。

§ [リカバリ] リカバリ

選択されたRDエリアに対するリカバリを行います。

画面の下部に表示されるリストから選択した表に対して、表の作成および再編成を実行することができます。

§ [データロード] データロード

選択された表に対するデータロードを行います。

§ [空きページ解放] 空きページ解放

選択された表に対する空きページ解放を行います。

§ [再編成] 再編成

選択された表に対する再編成を行います。

また、デバイス構成の変更やデバイスの障害等により、前回情報取得時のデバイス情報の更新に失敗した場合は、「デバイス一覧」リストに×印つきでデバイスアイコンが表示されます。デバイスアイコンが×印で表示された場合は、選択したホストのデバイス状態を確認してください。

デバイス構成を変更した等、デバイス状態に問題がなければ、以下のコマンド実行することで、過去のデバイス情報を削除することができます。

完全に古いデバイス情報を削除する場合は、全てのデバイス種別について×印で表示されるデバイスがないことを確認してください。

§ [デバイス情報削除] デバイス情報削除

デバイス情報を取得した段階で、前回に取得してデバイス情報で最新の情報と一致しないデバイス情報は×印で表示されます。×印で表示されたデバイス情報は、次のいずれかの状態であると判断することができます。

    - デバイスの状態が不正のため、デバイス情報の取得に失敗した。

    - デバイスの取り外し、属性変更を行った。

    - デバイス情報ファイルの変更を行った。

前者の場合は、原因を取り除いたあと、再度デバイス情報の更新を行ってください。後者の場合、不要になったデバイス情報を選択し、「デバイス情報削除」ボタンを実行し削除してください。

<注意事項>

· 「HiRDBシステム」で選択した対象がLinuxOS以外のUNIX OSの場合:

§ HiRDB CM Agentのバージョンが01-01以前で、論理ボリュームまたは論理ドライブを表示する場合には、ルートディレクトリ ( / ) にマウントされているデバイス情報を表示できません。

§ HiRDB CM Serverまたは、HiRDB CM Agentのバージョンが01-01以前では「 / 」を含めて16文字を超えるファイルシステム名は正しく表示されません。また、16文字を超えるファイルシステム以下に存在するRDエリアは表示されません。

· 「HiRDBシステム」で選択した対象がLinux OSであり、HiRDB CM Agentのバージョンが01-01以前の場合はデバイス情報を表示することはできません。

· HiRDB CM Agentのバージョンが02-00以前の場合は、「詳細表示」にシステムログファイル、HiRDBファイルシステム領域を指定できません。

· HiRDBファイルシステム領域名にシンボリックリンクを使用している場合、シンボリックリンクファイルが存在するデバイスとHiRDBファイルシステム領域の実体が存在するデバイスの両方のデバイスから関係を表示します。

· スタンバイ型系切り替え構成を使用している場合：

  スタンバイ型系切り替え構成を使用しているユニットに対しては、常に現用系のデバイス情報を表示します。


[HiRDBファイルシステム領域]

[HiRDBファイルシステム領域]コマンド

選択したHiRDBシステム下のHiRDBファイルシステム領域情報をホスト単位に表示します。

HiRDB CMが表示/管理するHiRDBファイルシステム領域は以下のとおりです。

    ・１つ以上のRDエリアが格納されているHiRDBファイルシステム領域（※１）

    ・１つ以上のHiRDBシステムログファイルが格納されているHiRDBファイルシステム領域（※１）

    ・１つ以上のHiRDBステータスファイルが格納されているHiRDBファイルシステム領域（※１）

    ・HiRDB CM Console操作で作成したHiRDBファイルシステム領域

    ・HiRDB CM Console操作で登録したバックアップファイル格納用HiRDBファイルシステム領域

    ・HiRDB CM Console操作で登録したログアンロードファイル格納用HiRDBファイルシステム領域

    ・HiRDB CM Console操作で情報追加した既存HiRDBファイルシステム領域（※２）

    ・HiRDB CM Console操作で情報追加した既存HiRDBバックアップファイルが格納されたHiRDBファイルシステム領域（※２、※３）

    ・HiRDB CM Console操作で情報追加した既存HiRDBログアンロードファイルが格納されたHiRDBファイルシステム領域（※２、※３）

  ※１：HiRDB CMが自動的に管理対象とします。

  ※２：既存HiRDBファイルシステム領域とは、HiRDB CM Console操作以外（HiRDBコマンド等を直接実行した）で作成されたHiRDBファイルシステム領域のことを指します。

  ※３：HiRDB CM 08-00以降の機能です。

また、選択したHiRDBやHiRDBファイルシステム領域に対し、各種操作を行うことができます。詳細は以降の説明を参照してください。

このコマンドを選択すると、[HiRDBファイルシステム領域マップ]画面を表示します。

「HiRDBシステム」コンボボックスから参照したいHiRDBシステムを選択し、次に「ホスト名」コンボボックスから対象となるホスト名を選択します。選択したホスト下のHiRDBファイルシステム領域が「HiRDBファイルシステム領域一覧」リストに表示されます。「HiRDBファイルシステム領域一覧」の表示形式は、「アイコン形式」「リスト形式」を選択することができます。

「HiRDBファイルシステム領域一覧」リストに表示されているHiRDBファイルシステム領域アイコンを選択すると拡張画面が表示され、HiRDBファイルシステム領域内に存在するHiRDBファイルの情報、および、HiRDBファイルシステム領域に関連するレプリカHiRDBファイルシステム領域情報を確認することができます。

「レプリカHiRDBファイルシステム領域情報」リストでは、HiRDBファイルシステム領域一覧で選択されたHiRDBファイルシステム領域に関連するオリジナルHiRDBファイルシステム領域名もしくはレプリカHiRDBファイルシステム領域名の一覧と各HiRDBファイルシステム領域上に作成されているRDエリアの一覧を表示します。

HiRDBファイルシステム領域の世代番号登録は行われているものの、RDエリアの世代登録が行われていない場合や、定義されているレプリカRDエリアがオリジナルHiRDBファイルシステム領域上に作成されているオリジナルRDエリアと不一致の場合は、対象のHiRDBファイルシステム領域情報を赤色で表示します。

レプリカとして世代登録されているHiRDBファイルシステム領域上にレプリカRDエリアではないRDエリアが存在する場合は、対象のHiRDBファイルシステム領域情報を黄色で表示します。

<注意事項>

· XDM/RDシステムでは本コマンドをサポートしていません。XDM/RDシステムを選択しても情報は表示されません。また、各種操作も実行できません。

· 03-00以前のCM Agentを使用している場合、システムステータスファイルが格納されているHiRDBファイルシステム領域は表示されません。

· 選択されているHiRDBファイルシステム領域が世代登録されていない場合、「レプリカHiRDBファイルシステム領域情報」リストに情報は表示されません。

· CM Agentのバージョンが08-00以前の場合、「レプリカHiRDBファイルシステム領域情報」リストに情報は表示されません。

· 同じオリジナルHiRDBファイルシステム領域名、同じレプリカHiRDBファイルシステム領域名で、複数のサーバに違う世代番号で世代登録されている場合、そのレプリカHiRDBファイルシステム領域の情報はレプリカHiRDBファイルシステム領域情報リストに表示されません。

· 影響分散スタンバイレス型系切り替え構成を使用している場合：

  「サーバ用ステータスファイル」、「RDエリア」、「アンロードログファイル格納用」などサーバとの関係のある用途で使用するHiRDBファイルシステム領域は、ホストBESとなるマシンのホスト名を指定した場合に表示されます。ゲストBESとなるホスト名を指定した場合は、表示されません。

· HiRDB CMでは使用目的を「ユティリティ用(Windowsキャッシュを使用しない)」として作成したHiRDBファイルシステム領域を「ユティリティ用」として扱います。作成後の画面表示では「ユティリティ用(Windowsキャッシュを使用しない)」と「ユティリティ用」を区別せず、全て「ユティリティ用」に統一されます。

[HiRDBファイルシステム領域マップ]画面では、次の操作を行うことができます。

§ [HiRDBファイルシステム領域の追加] 追加

選択されているHiRDBシステムに新たなHiRDBファイルシステム領域を追加します。[追加]ボタンをクリックすると、[HiRDBファイルシステム領域の初期設定/登録]コマンドが実行できます。

§ [HiRDBファイルシステム領域の削除] 削除

選択されているHiRDBファイルシステム領域の削除を行います。

<注意事項>

· HiRDBファイルシステム領域内にHiRDBファイルがある場合は、HiRDBファイルシステム領域の削除を実行できません。削除を行う場合は、HiRDBファイルを全て削除した後に当該HiRDBファイルシステム領域を削除してください。

· 世代登録されているHiRDBファイルシステム領域を削除する場合は、世代削除を先に実行してください。世代削除を行わないままHiRDBファイルシステム領域の削除を実行すると、実体はなくなりますが世代は登録されたままになります。

· HiRDB CMで登録したHiRDBファイルシステム領域をHiRDB CM以外から削除しないでください。HiRDB CMの管理情報を削除することができず、画面に情報が表示され続けます。管理情報が不正に残ってる場合は、HiRDBファイルシステム領域の削除を行ってください。

§ [HiRDBファイルの削除] HiRDBファイルの削除

拡張画面のHiRDBファイル情報で選択されているHiRDBファイルの削除を行います。

<注意事項>

· RDエリア、システムログファイル等で使用中のHiRDBファイルを削除した場合は、使用中の状態およびデータが失われますので使用状態を十分に確認して削除してください。

§ [image] HiRDBファイルシステム領域のバックアップ

選択されているHiRDBファイルシステム領域に対してHiRDBファイルシステム領域単位のバックアップを行います。

§ [image] HiRDBファイルシステム領域のリカバリ

選択されているHiRDBファイルシステム領域に対してHiRDBファイルシステム領域単位のリカバリを行います。

§ [image] HiRDBファイルのバックアップ

拡張画面のHiRDBファイル情報で選択されているHiRDBファイルに対してHiRDBファイル単位のバックアップを行います。

§ [image] HiRDBファイルのリカバリ

拡張画面のHiRDBファイル情報で選択されているHiRDBファイルに対してHiRDBファイル単位のリカバリを行います。

§ [image] HiRDBファイルシステム領域情報保存

選択されているHiRDBシステムの全HiRDBファイルシステム領域情報を指定したファイルに以下に示すCSV形式で保存します。

番号 | 項目名 | 説明
１ | HiRDBファイルシステム領域 | HiRDBファイルシステム領域名称。
２ | ホスト名 | 対象のHiRDBファイルシステム領域のホスト名称。
３ | 総容量[KB] | 対象のHiRDBファイルシステム領域の総容量。KB単位で表します。
４ | 作成可能ファイル数 | 対象のHiRDBファイルシステム領域上に現時点で作成することができるHiRDBファイルの総数。
５ | 使用率[%] | 対象のHiRDBファイルシステム領域の使用率。
６ | 増分可能回数 | 対象のHiRDBファイルシステム領域上に現時点で増分することができる回数。
７ | 作成可能ファイルサイズ[KB] | 対象のHiRDBファイルシステム領域で作成可能なHiRDBファイルのサイズ。KB単位で表します。
８ | 使用目的 | 対象のHiRDBファイルシステム領域の使用目的。次のいずれかで表されます。 ・すべて(ユティリティを除く） ・RDエリア（リスト用RDエリアを除く） ・システムログ・シンクポイントダンプ・ステータスファイル ・リスト用RDエリア、作業表用ファイル ・ユティリティ用
９ | 未使用領域[KB] | 対象のHiRDBファイルシステム領域の未使用領域サイズ。KB単位で表します。
１０ | 最大作成可能ファイル数 | 対象のHiRDBファイルシステム領域上に作成することができるHiRDBファイルの総数。
１１ | 作成済みファイル数 | 対象のHiRDBファイルシステム領域上に現時点で作成されたHiRDBファイルの総数。
１２ | 空き領域総数 | 対象のHiRDBファイルシステム領域上の空き領域区画数。
１３ | 増分回数上限値 | 対象のHiRDBファイルシステム領域作成時に指定した増分回数。
１４ | 増分回数合計 | 対象のHiRDBファイルシステム領域で現時点までに増分した回数。
１５ | セクタ長[B] | 対象のHiRDBファイルシステム領域のセクタ長。
１６ | 初期化ユーザ | 対象のHiRDBファイルシステム領域を初期化したユーザ名称。HiRDB CMで作成したユーザは、CM Agentをセットアップしたユーザ名になります。Windowsの場合は、CM Agentサービスのユーザ名になります。
１７ | 初期化日時 | 対象のHiRDBファイルシステム領域を初期化した日時。

<注意事項>

· HiRDBファイルシステム領域情報保存機能では、「世代番号」「オリジナルHiRDBファイルシステム領域名」情報はCSVファイルに保存しませんが、[HiRDBファイルシステム領域情報詳細]画面では表示されます。

· 同じオリジナルHiRDBファイルシステム領域名、同じレプリカHiRDBファイルシステム領域名で、複数のサーバに違う世代番号で世代登録されている場合、HiRDBファイルシステム領域詳細情報画面の世代番号、オリジナルHiRDBファイルシステム領域は表示されません。

· HiRDBファイルシステム領域の使用目的が[RDエリア用]または、[すべて]の場合にだけ、世代番号、オリジナルHiRDBファイルシステム領域を表示します。

§ [image] HiRDBファイルシステム領域の世代登録

選択されているHiRDBファイルシステム領域に対して世代登録を行います。

§ [image] HiRDBファイルシステム領域の世代削除

選択されているHiRDBファイルシステム領域に対して世代削除を行います。

<注意事項>

· HiRDBファイルシステム領域の世代削除は、世代番号が1～10のHiRDBファイルシステム領域に対してのみ実行できます。世代番号が0のHiRDBファイルシステム領域に対しては世代削除を実行できません。

· HiRDBファイルシステム領域の世代削除は、処理対象のHiRDBファイルシステム領域上にレプリカRDエリアが存在しない場合だけ実行できます。

· 選択されたレプリカHiRDBファイルシステム領域の世代が登録されている全てのサーバに対して、世代削除を実行します。

§ [image] HiRDBファイルシステム領域詳細

選択されているHiRDBファイルシステム領域の詳細な情報を参照することができます。

「HiRDBファイルシステム領域詳細」として表示される情報は、「HiRDBファイルシステム領域情報保存」でCSVとして保存される情報と同じ情報です。

l HiRDBファイルシステム領域の世代登録

データベース構成変更ユティリティのHiRDBファイルシステム領域の世代登録機能を実行します。

<前提条件>

· CM Agentのバージョンが、08-00以前の場合、HiRDBファイルシステム領域の世代登録を行うことはできません。

· HiRDBファイルシステム領域は、ひとつのサーバに対して世代登録を行います。サーバの特定は、HiRDBファイルシステム領域上に存在するRDエリアから求めます。そのため、対象のHiRDBファイルシステム領域上にRDエリアが定義されていない場合、世代登録を行うことはできません。また、HiRDBファイルシステム領域上に複数のRDエリアが存在し、かつ、別々のサーバに存在する場合は、世代登録を行うことができません

1. 「世代番号」を指定する。

「世代番号」コンボボックスから、世代登録を行う世代番号を指定します。

2. 「レプリカHiRDBファイルシステム領域名」を指定する。

「レプリカHiRDBファイルシステム領域名」テキストボックスにレプリカHiRDBファイルシステム領域名を指定します。

3. 世代登録するレプリカHiRDBファイルシステム領域名を確定します。

「追加」ボタンを押し、「レプリカHiRDBファイルシステム領域一覧」リストに世代登録を行う対象を登録します。

リストを選択し、「削除」ボタンを押すことで、登録を取り消すことができます。

複数世代を一度に登録する場合は、ここまでの操作を世代登録したいすべての世代に対して行います。

4. 世代登録を実行する。

「実行」ボタンを押し、世代登録を実行します。

<注意事項>

· HiRDBファイルシステム領域上に存在するHiRDBファイルがユーザ用RDエリアまたはユーザLOB用RDエリア以外の場合は、世代登録を行うことができません。


[リソース関係表]

[リソース関係表]コマンド

HiRDB CMで管理するリソースからデバイスまでの関係情報を表示します。また、本画面に表示された情報を、csv形式のファイルへ保存することもできます。この関係は、表とデバイス、RDエリアとデバイス、HiRDBシステムログファイルグループとデバイス、ステータスファイルグループとデバイス、バックアップファイルとデバイス、アンロードログファイルとデバイスの６種類の関係を表示、保存することができます。

１．「HiRDBシステム」の選択

リソース関係情報を表示したいHiRDBシステムを選択します。

２．「表示種別」の選択

次の何れかの関係情報種別を選択します。

§ 「表/インデクス」

表/インデックス単位に

表/インデクス　－　RDエリア　－　HiRDBファイル　－　HiRDBファイルシステム領域　－　ファイルシステム　－　ボリューム　－　デバイス

の関係情報を表示します。

§ 「システムログファイルグループ」

HiRDBシステムログファイルグループ単位に

HiRDBシステムログファイルグループ　－　HiRDBファイル　－　HiRDBファイルシステム領域　－　ファイルシステム　－　ボリューム　－　デバイス

の関係情報を表示します。

§ 「RDエリア」

RDエリア単位に

RDエリア　－　HiRDBファイル　－　HiRDBファイルシステム領域　－　ファイルシステム　－　ボリューム　－　デバイス

の関係情報を表示します。

§ 「ステータスファイルグループ」

ステータスファイルグループ単位に

論理ファイル　－　HiRDBファイル　－　HiRDBファイルシステム領域　－　ファイルシステム　－　ボリューム　－　デバイス

の関係情報を表示します。

サーバ用ステータスファイルの情報には、サーバ名が表示されユニット名は表示されません。また、ユニット用ステータスファイルの情報には、ユニット名が表示され、サーバ名は表示されません。

§ 「バックアップファイル」

バックアップファイル単位に

バックアップファイル　－　HiRDBファイル　－　HiRDBファイルシステム領域　－　ファイルシステム　－　ボリューム　－　デバイス

の関係情報を表示します。

NetBackupなどの特殊なバックアップ格納領域に取得したバックアップ情報は表示されません。

§ 「アンロードログファイル」

アンロードログファイル単位に

アンロードログファイル名　－　HiRDBファイル　－　HiRDBファイルシステム領域　－　ファイルシステム　－　ボリューム　－　デバイス

の関係情報を表示します。

HiRDB　CMから取得したアンロードログファイルのみを表示します。自動ログアンロード機能または、HiRDB CMを介さないで取得したアンロードログファイルは表示されません。

また、「表示形式」でツリーを選択することで、ホストごとに関連情報を階層形式で表示することができます。

ツリー表示を行うには、以下の手順に従ってください。

１．表示項目の選定

リストで表示された項目の中からツリー表示を行う情報を選択してください。何も選択されていない場合は、全ての項目が表示対象となります。

表示項目数が多い場合、ツリー表示に時間がかかる場合があります。

２．表示方法の選択

「表示形式」からツリーを選択してください。

３．ホスト名の選択

対象のHiRDBがパラレルサーバの場合、表示を行うホスト名を選択してください。

４．アイコンの移動

項目数が多い、または分割表などの複雑な関連をもっている場合、各アイコンの関連線が重なる場合があります。

アイコンは水平方向に移動可能です。場所を入れ替えて関係線が見やすい位置に移動してください。

画面上部のICONボタンを押すことで、以下の操作を行うことができます。

§ [image] ファイルに保存

リスト表示を行っている場合に、関係情報が表示された画面では、[保存]ボタンをクリックするとConsoleを起動しているマシン上に現在表示している関係情報をcsv形式のファイルとして保存することができます。

§ [image] 拡大表示

ツリー表示を行っている場合に、階層図を拡大します。

§ [image] 縮小表示

      ツリー表示を行っている場合に、階層図を縮小します。

§ [image] 標準サイズ表示

ツリー表示を行っている場合に、階層図を標準の大きさにします。

<注意事項>

· 管理するHiRDBがWindows XP上で動作する環境では、CM Agentのバージョンが08-00未満の場合、リソース関係情報を表示できません。また、CM Agentのバージョンが08-00以降の場合、「ユーザ定義デバイス情報ファイル」が設定されているCM Agentのみ、リソース関係情報を表示できます。

· 管理するHiRDBがWindows Vista上、または、Windows Server 2008上で動作する環境では、「ユーザ定義デバイス情報ファイル」が設定されているCM Agentのみ、リソース関係情報を表示できます。

· HiRDBシステムが動作するマシン上に複数のデバイスがある場合、表示までに数分以上の時間がかかる場合があります。

· Windowsで動作するHiRDBシステムがドライブ以外（ドライブ以下のディレクトリ）にディスクをMountしているファイルシステムを使用している場合は、リソース関係情報を表示、保存できません。

· HiRDB CM Agentバージョンが02-00以前の場合は、「表示種別」にシステムログファイルグループ、ステータスファイルグループを指定しても、情報は表示されません。

· HiRDBファイルシステム領域名にシンボリックリンクを使用している場合、シンボリックリンクファイルが存在するデバイスとHiRDBファイルシステム領域の実体が存在するデバイスの両方の関係を表示します。

· スタンバイ型系切り替え構成を使用している場合：

  スタンバイ型系切り替え構成を使用しているユニットに対しては、常に現用系のデバイス情報を表示します。

· インナレプリカ機能を使用している場合、表-RDエリア・インデクス－RDエリアの関係はオリジナルRDエリアに対してのみ表示されます。


[インナレプリカ]

[インナレプリカ]コマンド

選択したHiRDBシステム下のインナレプリカ機能を使用したRDエリアを運用グループごとに表示します。運用グループとは、表の横分割、表-インデクスの関係等により、複数のRDエリアを一まとまりとして扱い、データの整合性を保持した状態で運用または、レプリカ定義する必要があるRDエリアのグループです。

「HiRDBシステム」コンボボックスから参照したいHiRDBシステムを選択すると、選択したHiRDBシステムが持つ運用グループが「運用グループ一覧」リストに表示されます。[運用グループ一覧]の表示形式は、[アイコン形式][リスト形式]を選択することができます。運用グループ中で、世代番号が一致していないRDエリアが存在する場合、運用グループアイコンまたは、リストの背景が赤で表示されます。また、レプリカステータスが一致していないRDエリアが存在する場合は、背景が黄で表示されます。運用グループを選択することで、選択した運用グループに含まれるRDエリア、表、インデックスの情報を表示します。

この画面では、次の操作を実行することができます。

§ [image] カレントRDエリア変更

選択した運用グループに含まれる全てのRDエリアのカレントRDエリアを変更します。

§ [image] バックアップ

[RDエリア情報]リストで選択された世代のRDエリアのバックアップを取得します。

§ [image] リカバリ

[RDエリア情報]リストで選択された世代のRDエリアのリカバリを行います。

§ [image] データロード

[表/インデクス情報]リストで選択された表に対するデータロードを行います。

§ [image] 再編成

[表/インデクス情報]リストで選択された表に対する再編成を行います。

§ [image] 空きページ解放

[表/インデクス情報]リストで選択された表/インデクスに対する空きページ解放を行います。

<注意事項>

· 「HiRDBシステム」コンボボックスを選択した後、運用グループが表示されるまで若干時間がかかる場合があります。


[グローバルバッファ]

[グローバルバッファ]コマンド

選択したHiRDBシステムのグローバルバッファ情報を表示します。

また、選択したHiRDBや表に対し、各種操作を行うことができます。詳細は以降の説明を参照してください。

このコマンドを選択すると、[グローバルバッファ マップ]画面を表示します。

「HiRDBシステム」コンボボックスから参照したいHiRDBシステムを選択すると、選択したHiRDBシステムが持つグローバルバッファが「グローバルバッファ一覧」リストに表示されます。[グローバルバッファ一覧]の表示形式は、[アイコン形式][リスト形式]を選択することができます。

「グローバルバッファ一覧」リストに表示されているグローバルバッファアイコンを選択すると拡張画面が表示され、グローバルバッファの詳細情報、および、グローバルバッファが割り当てられているRDエリア、インデクスの情報を確認することができます。

<注意事項>

· XDM/RDシステムでは本コマンドをサポートしていません。XDM/RDシステムを選択しても情報は表示されません。また、各種操作も実行できません。

· 04-00未満のCM Agentを使用している場合、グローバルバッファマップは表示されません。

· グローバルバッファマップで表示される累計ヒット率は、HiRDB起動時からの累計で表示されます。

(この累計ヒット率は、統計的数値ではないためバッファチューニング等の数値として使用することはできません。）

· 管理対象ＨｉＲＤＢがパラレルサーバであり、次のすべての条件が重なる場合、各サーバでバッファサイズが異なる場合があります。

- HiRDBシステム定義(pdsys）のpdbuffeｒ句で-lオプションを省略している。

- 対象グローバルバッファを割り当てているRDエリアのページ長が異なる。

このような場合、HiRDB CMでは、サーバ毎に割り当てられているグローバルバッファのバッファサイズで最大のものを表示します。

· 管理対象ＨｉＲＤＢがパラレルサーバの場合、累積ヒット率の値は、各サーバ上でのヒット率の平均値を表示します。ただし、サーバに割り当てられているグローバルバッファが一度も使用されていない場合は、平均値の計算から除外されます。

· HiRDB起動直後には、グローバルバッファ上に情報がありません。そのため、はじめの一回目のアクセスは、必ず実READ/WRITEになります。そのため、累積ヒット率が100%を超えることはありません。

[グローバルバッファ マップ]画面では、次の操作を実行することができます。

§ [image] グローバルバッファの追加

選択されているHiRDBシステムへ新しいグローバルバッファを動的に追加します。

§ [image] グローバルバッファの割当

選択されているグローバルバッファへ新たなRDエリアを動的に割当てます

§ [image] グローバルバッファの変更

選択されているグローバルバッファの詳細設定情報を変更します。

§ [image] グローバルバッファの削除

選択されているグローバルバッファを削除します。または、選択されているグローバルバッファの割当てているRDエリア割当て解除を行います。

<注意事項>

· グローバルバッファの追加/割当/変更/削除を実行する場合は、HiRDB Advanced High Availability Version 7プログラムを、対象とするHiRDBシステムにインストールしておく必要があります。


[バックアップ]タブ

[バックアップ]タブには、以下のようなコマンドがあります。

[ウィザード]

[カスタマイズ]

[差分バックアップ]

[NetBackup]

[HiRDBファイルシステム領域単位のバックアップ]

[カタログ実行]

[バックアップファイル格納先の登録/削除]

[バックアップ詳細情報]

[バックアップファイル表示/削除]

[ウィザード環境設定]

[既存バックアップファイルの登録]


[ウィザード]

[ウィザード]コマンド

データベース複写ユティリティ (pdcopy) をウィザードで実行します。

このコマンドを選択すると、バックアップを実行するための[ウィザード]画面が表示されます。

バックアップ ウィザードの各項目の設定内容を、以下で説明します。

· バックアップ ウィザード

<前提条件>

· このコマンドでバックアップを実行する前に、各ファイル種別ごとに下記の事を行ってください。

1. 「通常ファイル」あるいは「HiRDBファイルシステム領域」を使用する場合:

HiRDB CMにバックアップファイルの格納先を登録する必要があります。登録していない場合、バックアップを実行できません。

以下のコマンドでバックアップファイルの格納先を登録してください。

[バックアップファイル格納先の登録/削除]コマンド

2. 「EasyMT」あるいは「EasyMT, MTguide」を使用する場合:

ボリューム名、EasyMT用属性ファイル名を指定する場合、[ウィザード環境設定]コマンドで「ボリューム名」、「EasyMT用属性ファイル名」を、あらかじめ登録しておく必要があります。(ボリューム名、EasyMT用属性ファイル名を指定しない場合は、登録の必要はありません)

3. 「JP1/OmniBack Ⅱ」を使用する場合:

ディスクエージェントがある「ホスト名」と「バーリストファイル名」を、[ウィザード環境設定]コマンドであらかじめ登録しておく必要があります。登録していない場合は、JP1/OmniBack Ⅱを使用したバックアップは実行できません。

· NetBackupを使用する場合:

NetBackup クライアントのサーバマシンにNetBackup用のAgentをインストールしておいてください。インストールしていない場合は、HiRDB CMでNetBackupを使用したバックアップ及びリカバリは実行できません。

<注意事項>

· 差分バックアップ機能を使用する場合:

ServerまたはAgentが01-00の場合に差分バックアップ機能を実行しないでください。差分バックアップを使用する場合は、Console, Server, Agent全てのバージョンが01-01以降のものを使用してください。

· [ウィザード環境設定]コマンドの「スキップ対象エラーを検知した場合は処理を続行する」はサポートしていません。

· 自動ログアンロード機能を使用している場合に、動作状態が中断時のバックアップは実行できません。自動ログアンロードの動作状態はpdlogatul運用コマンドで確認することができます。

· システムログファイルのスワップ先が無い場合は、バックアップを実行できません。アンロードログファイルの状態はpdlogls運用コマンド、あるいは[システムログのアンロード]コマンドで確認することができます。

· 複写回復専用開始の状態でバックアップを取得すると、KFPE25023-Wで警告終了しますが、バックアップは正常に終了しています。

· NetBackupを使用する場合:

この機能を[カタログ]にする場合、[カタログ登録]画面で「同名のバックアップファイルが存在した場合」グループで「上書き」・「別名保存」どちらのオプションを選択しても「別名保存」で実行されます。同一ポリシーによるNetBackupが実行され、別名のバックアップファイルが作成されます。

· [ウィザード環境設定]画面が開かれている場合、[バックアップ－バックアップウィザード]を実行できません。[ウィザード環境設定]画面を閉じた後[バックアップ－ウィザード]を実行してください。

· ＲＤエリアの状態について:

ＲＤエリアの状態は、ユティリティを実行後も実行前のＲＤエリア状態となります。

· 世代番号の指定について:

バックアップウィザードでは、世代番号の指定を行うことはできません。

· 系切り替え構成を使用する場合：

マスタ用RDエリアを含む回復を行う場合、あらかじめ複写回復専用モードでHiRDBシステムを開始しておく必要があります。

毎回バックアップを実行するがオプションの指定値に変化がない場合には、[ウィザード環境設定]コマンドで、バックアップ ウィザードの初期値をあらかじめ設定しておくと、ウィザードで入力する情報が少なくなり入力の負担が軽減されます。

[ウィザード環境設定]コマンド


[カスタマイズ]

[カスタマイズ]コマンド

データベース複写ユティリティ (pdcopy) をカスタマイズで実行します。

このコマンドを選択すると、バックアップを実行するための[カスタマイズ]画面が表示されます。

バックアップ カスタマイズの各タブページの設定内容を、以下で説明します。

· [取得単位]ページ

· [取得モード]ページ

· [差分バックアップ]ページ

· [詳細設定]ページ

· [確認]ページ

<前提条件>

· NetBackupを使用する場合:

NetBackup クライアントのサーバマシンにNetBackup用のAgentをインストールしておいてください。インストールしていない場合は、HiRDB CMでNetBackupを使用したバックアップ及びリカバリは実行できません。

<注意事項>

· 差分バックアップ機能を使用する場合:

ServerまたはAgentが01-00の場合に差分バックアップ機能を実行しないでください。差分バックアップを使用する場合は、Console, Server, Agent全てのバージョンが01-01以降のものを使用してください。

· [詳細]ページのオプション「スキップ対象エラーを検知した場合は処理を続行する」はサポートしていません。

· 自動ログアンロード機能を使用している場合に、動作状態が中断時のバックアップは実行できません。自動ログアンロードの動作状態はpdlogatul運用コマンドで確認することができます。

· システムログファイルのスワップ先が無い場合は、バックアップを実行できません。アンロードログファイルの状態はpdlogls運用コマンド、あるいは[システムログのアンロード]コマンドで確認することができます。

· 複写回復専用開始の状態でバックアップを取得すると、KFPE25023-Wで警告終了しますが、バックアップは正常に終了しています。

· NetBackupを使用する場合:

この機能を[カタログ]にする場合、[カタログ登録]画面で「同名のバックアップファイルが存在した場合」グループで「上書き」・「別名保存」どちらのオプションを選択しても「別名保存」で実行されます。同一ポリシーによるNetBackupが実行され、別名のバックアップファイルが作成されます。

· ＲＤエリアの状態について:

ＲＤエリアの状態は、ユティリティを実行後も実行前のＲＤエリア状態となります。

· 系切り替え構成を使用する場合：

マスタ用RDエリアを含む回復を行う場合、あらかじめ複写回復専用モードでHiRDBシステムを開始しておく必要があります。


[差分バックアップ]

[差分バックアップ]コマンド

差分バックアップ機能を使用したバックアップを実行します。

このコマンドを選択すると、差分バックアップを実行するための画面を表示します。ここで、差分バックアップを実行するのに必要な情報を選択してください。

<前提条件>

· 本画面から差分バックアップを実行する場合は、事前にバックアップの[ウィザード]コマンド、または[カスタマイズ]コマンドから差分バックアップを実行してください。本画面では2回目以降のバックアップを実行できます。

1. リストボックス「HiRDBシステム」でHiRDBシステム名を選択。

HiRDB CMが管理しているHiRDBシステムの一覧が表示されていますので、差分バックアップを実行したいHiRDBシステム名を選択してください。なお、リストボックス「HiRDBシステム」は複数選択ができません。

2. リストボックス「差分バックアップグループ」で差分バックアップグループ名を選択。

リストボックス「HiRDBシステム」で選択したHiRDBシステムが持つ差分バックアップグループ名一覧が表示されます。ここの差分バックアップグループ名を選択すると、その差分バックアップグループの詳細な情報がリストボックス「取得対象」で表示されます。なお、リストボックス「差分バックアップグループ」は複数選択ができません。

3. 「取得モード」を選択。

任意の差分バックアップ取得モードを選択します。

· フルバックアップ

バックアップ対象となるRDエリア内の使用中ページすべてをバックアップします。

· 最新のフルバックアップからの累積差分バックアップ

最も新しく取得されたフルバックアップから現在までに更新されたページに対してのみバックアップを取得した累積差分バックアップファイルを作成します。

· 前回のフルバックアップまたは累積差分バックアップからの累積差分バックアップ

前回取得された累積差分バックアップ（累積差分バックアップを取得していない場合は、前回のフルバックアップ）から現在までに更新されたページに対してのみバックアップを取得した累積差分バックアップファイルを作成します。

· 前回からの差分バックアップ

前回取得された差分バックアップ（差分バックアップを取得していない場合は、前回のフルバックアップまたは、累積差分バックアップ）から現在までに更新されたページに対してのみバックアップを取得した差分バックアップファイルを作成します。

4. 「ファイル種別」を選択。

バックアップファイルの種別を選択します。

5. バックアップファイル名を入力する。

6. 実行

· [実行]ボタンをクリック:

差分バックアップの実行を行います。

· [カタログ]ボタンをクリック:

指定した情報でカタログを作成します。[カタログの登録]画面が表示されますので、エディットボックス[カタログ名]に任意の名前を入力してください。カタログ名は英数字のみ指定可能です。

カタログ名を入力して[OK]ボタンをクリックすると、カタログの登録を行います。

<注意事項>

· 差分バックアップ操作をカタログとして登録した場合、[別名保存]用のカタログとして登録されます。

· HiRDBファイルのバックアップ操作を[別名保存]のカタログとして使用する場合は、HRDBファイル名を15文字以内に指定してください。


[NetBackup]

[NetBackup]コマンド

NetBackup連携機能を使用したバックアップを実行します。

このコマンドを選択すると、NetBackupを使用したバックアップを実行するための画面を表示します。

[NetBackup]画面では、以下の機能を実行することができます。

§ NetBackupを使用したバックアップ実行

この機能は実行したいNetBackup ポリシーを指定するだけでバックアップを取得できます。

§ NetBackupポリシーの新規作成

この機能はNetBackup ポリシーを新規に作成することができます。

§ NetBackup ポリシーの削除

この機能は、不要になったNetBackup ポリシーの削除を行うことができます。

<前提条件>

· HiRDB CMでNetBackupを使用したバックアップあるいはリカバリを実行する場合は、NetBackup クライアントのサーバマシンにNetBackup用のAgentをインストールしておいてください。インストールしていない場合は、HiRDB CMでNetBackupを使用したバックアップ及びリカバリは実行できません。

· 本画面からNetBackupを使用したバックアップを実行する場合は、事前にバックアップの[ウィザード]コマンド、または[カスタマイズ]コマンドからNetBackupを実行してください。本画面では2回目以降のバックアップを実行できます。

<注意事項>

· NetBackupを使用したバックアップを実行する場合:

この機能を[カタログ]にする場合、[カタログ登録]画面で「同名のバックアップファイルが存在した場合」グループで「上書き」・「別名保存」どちらのオプションを選択しても「別名保存」で実行されます。

· NetBackup ポリシーの削除を実行する場合:

対象NetBackupポリシーに格納されているバックアップ情報も全て削除されます。ここで削除したNetBackup ポリシーは復元することはできません。削除を行う場合には、対象をよく確認してから行ってください。同一ポリシーによるNetBackupが実行され、別名のバックアップファイルが作成されます。

· 削除するNetBackupポリシーを使用したカタログを作成し、且つスケジュール登録を行っている場合、これらの情報は自動的に削除されません。不要な場合、カタログは[カタログ情報]コマンド、スケジュールは[スケジュールリスト]コマンドの削除機能を使用して削除してください。

l NetBackupを使用したバックアップを実行する場合:

1. リストボックス「HiRDBシステム」でHiRDBシステム名を選択。

リストボックス「HiRDBシステム」一覧から、バックアップを実行したいHiRDBシステム名を選択してください。なお、リストボックス「HiRDBシステム」は複数選択ができません。

2. リストボックス「NetBackup ポリシー」で実行したいポリシー名を選択。

リストボックス「HiRDBシステム」で選択したHiRDBシステムが持つNetBackupポリシー一覧が表示されます。ここのポリシー名を選択すると、そのポリシーの詳細な情報がリストボックス「ポリシー設定内容」で表示されます。なお、リストボックス「NetBackup ポリシー」は複数選択ができません。

3. 「取得モード」を選択。

選択されたポリシーが、差分バックアップ用のポリシーである場合、バックアップの取得モードを選択することができます。

4. 実行

· [実行]ボタンをクリック:

バックアップを実行します。

· [カタログ]ボタンをクリック:

指定した情報でカタログを作成します。[カタログの登録]画面が表示されますので、エディットボックス[カタログ名]に任意の名前を入力してください。カタログ名は英数字のみ指定可能です。

カタログ名を入力して[OK]ボタンをクリックすると、カタログの登録を行います。

l NetBackup ポリシーを新規作成する場合:

1. リストボックス「HiRDBシステム」でHiRDBシステム名を選択。

リストボックス「HiRDBシステム」一覧から、ポリシーを作成するHiRDBシステム名を選択してください。なお、リストボックス「HiRDBシステム」は複数選択ができません。

2. [ポリシー作成]ボタンをクリック。

3. [NetBackup ポリシー作成]画面表示。

ここで、NetBackup ポリシーを作成するために必要な情報を設定します。

4. 情報を指定する。

· 「ポリシー名」

新規で作成するNetBackup ポリシー名を指定します。((最大128文字))まで指定可能です。

· 「ストレージユニット名」

NetBackupで使用するストレージユニット名を指定します。((最大128文字))まで指定可能です。

· 「NetBackupクライアントホスト名」

NetBackup クライアントをインストールしたサーバのホスト名を指定します。

5. [実行]ボタンをクリック。

指定された情報でNetBackup ポリシーを作成します。

l NetBackup ポリシーの削除を実行する場合:

1. リストボックス「HiRDBシステム」でHiRDBシステム名を選択。

リストボックス「HiRDBシステム」一覧から、削除を行いたいNetBackup ポリシーが属するシステムを選択してください。なお、リストボックス「HiRDBシステム」は複数選択ができません。

2. リストボックス「NetBackup ポリシー」で削除したいポリシー名を選択。

リストボックス「HiRDBシステム」で選択したHiRDBシステムが持つNetBackupポリシー一覧が表示されます。ここのポリシー名を選択すると、そのポリシーの詳細な情報がリストボックス「ポリシー設定内容」で表示されます。なお、リストボックス「NetBackup ポリシー」は複数選択ができません。

3. [ポリシーの削除]ボタンをクリック。

指定されたNetBackup ポリシーの削除を実行します。


[HiRDBファイルシステム領域単位のバックアップ]

[HiRDBファイルシステム領域単位のバックアップ]コマンド

HiRDBファイルシステム領域を通常ファイルに退避 (pdfbkup) します。また、HiRDBファイル単位にも退避できます。

1. 取得対象を指定する。

グループ「取得単位」にあるラジオボタンの中から任意の単位を選択してください。

· HiRDBファイルシステム領域のバックアップを実行する場合:

グループ「取得単位」から「HiRDBファイルシステム領域」ラジオボタンを選択してください。

· HiRDBファイルのバックアップを実行する場合:

グループ「取得単位」から「HiRDBファイル」ラジオボタンを選択してください。

2. 対象のHiRDBシステムを選択する。

コンボボックス「HiRDBシステム」から取得する対象が属するシステム名を選択してください。

3. 対象のホスト名を選択する。

コンボボックス「ホスト名」から取得する対象が属するホスト名を選択してください。

4. バックアップ取得対象を選択する。

リストボックス「HiRDBファイルシステム領域」から取得する対象が属するHiRDBファイルシステム領域を選択してください。取得対象がHiRDBファイルの場合、リストボックス「HiRDBファイル」からHiRDBファイルを選択してください。

5. 実行

· [実行]ボタンをクリック:

内容を確認し問題がなければ[実行]ボタンをクリックしてください。バックアップの実行を行います。

· [カタログ]ボタンをクリック:指定した情報でカタログを作成します。

このボタンをクリックすると、カタログの情報を入力するための[カタログの登録]画面が表示されます。

§ 「カタログ名」

エディットボックス「カタログ名」に任意の名前を入力してください。カタログ名の入力は((最大64文字))で、英数字のみ指定可能です。

§ 「同名のバックアップファイルが存在した場合」

ここで作成したカタログを使用してバックアップを実行したときに、既に同名のバックアップファイルが存在していた場合の対処方法を選択してください。

- 「上書き」

同名のバックアップファイルが存在した場合は上書きを行います。

- 「別名保存」

同名のバックアップファイルが存在するか否かに関わらず、以下のフォーマットで名称を作成しバックアップファイルを取得します。

"指定されたバックアップファイル名" + "カタログ実行日時"

カタログ名を入力して[OK]ボタンをクリックすると、カタログの作成及び登録を行います。

<注意事項>

· 対象のHiRDBファイルシステム領域内に種別の異なるHiRDBファイルが存在する場合、HiRDBファイルシステム領域単位にバックアップは実行できません。

· pdfbkupコマンドが異常終了した場合、バックアップファイルが作成されることがあります。OSのコマンドで直接削除してください。

· 対象となるHiRDBファイルシステム領域にアクセスしている場合は、退避処理をしません。 [サーバプロセスのリフレッシュ]を行って、HiRDBファイルシステム領域にアクセスしているプロセスをキャンセルしてから再度実行してください。

· 退避するHiRDBファイルシステム領域又はHiRDBファイルが2ギガバイトを超える場合、退避先のファイルを、ラージファイルが使用できるファイルシステムにする必要があります。


[カタログ実行]

[カタログ実行]コマンド

バックアップのカタログを操作するためのカタログリストを表示します。

このコマンドを選択すると、既存のカタログの状態を表示したカタログリストを表示します。ここで、カタログの操作を行います。

このコマンドは自動で最新の状態に更新されません。

最新の情報を表示するには、この[カタログ実行]コマンドを再実行するか、あるいは[F5]キーを押下することで最新の状態へ更新することができます。

1. 任意のカタログを選択。

カタログリストの上段にあるリストボックスに、既存の各カタログの状態が表示されます。ここで任意のカタログ名を選択し、右クリックを行うとポップアップメニューが表示されます。以下で各機能の説明をします。

§ [実行]

選択したカタログを即実行します。

§ [スケジュール]

カタログを実行する日時を指定します。[スケジュール ウィザード]画面が表示されます。指定した対象をダブルクリックすることでも実行できます。

§ [変更]

選択したカタログに登録されている内容を変更します。カタログに登録されている値をデフォルトとした[カスタマイズ]画面が表示されますので、任意の値を指定してください。

<注意事項>

· カタログの変更は既存のスケジュールには反映されません。変更前のカタログを使用したスケジュールが存在する場合は、当該スケジュールを一度削除した後に、再度新しいカタログを使用してスケジュールを登録してください。

§ [削除]

選択したカタログのファイルを削除します。また、[Delete]キーを押下することでも削除ができます。

ここで削除したカタログは再生することができません。


[バックアップファイル表示/削除]

[バックアップファイル表示/削除]コマンド

HiRDB CMで管理しているバックアップファイルを表示し、また削除を行います。

このコマンドを選択すると、バックアップファイルを一覧表示するための画面を表示します。

1. HiRDBシステム名を選択。

コンボボックス「HiRDBシステム」一覧から、削除を実行したいバックアップファイルが属しているHiRDBシステム名を選択してください。

2. バックアップファイル取得単位ごとに表示を行うことができます。

次のバックアップ取得単位ごとに取得されたバックアップファイル情報をリストボックスに表示します。

・ＡＬＬ

バックアップ取得単位に関係なく全てのバックアップファイルを表示します。

ただし、HiRDBファイルシステム領域単位とHiRDBファイル単位に取得したバックアップファイルは表示されません。

・ＨｉＲＤＢシステム

ＨｉＲＤＢシステム単位に取得したバックアップファイルを表示します。

・ユニット

ユニット単位に取得したバックアップファイルを表示します。

・サーバ

サーバ単位に取得したバックアップファイルを表示します。

・ＲＤエリア

ＲＤエリア単位に取得したバックアップファイルを表示します。

・差分バックアップ

差分バックアップファイルを表示します。

・HiRDBファイルシステム領域

HiRDBファイルシステム領域単位に取得したバックアップファイルを表示します。

・HiRDBファイル

HiRDBファイル単位に取得したバックアップファイルを表示します。

3. 削除するバックアップファイル名を選択。

HiRDBシステム名を選択すると、リストボックス「バックアップファイル情報」に、選択されたHiRDBシステムが持つバックアップファイル名が一覧表示されます。削除するバックアップファイル名を選択してください。なお、バックアップファイル名は複数選択が可能です。

4. [削除]ボタンをクリック。

選択されているバックアップファイルの削除を実行します。

また、[Delete]キーを押下することでも削除ができます。

<注意事項>

· ファイル種別が「EasyMT」・「EasyMT, MTguide」・「JP1/OmniBack Ⅱ」のファイルを削除する場合:

ここでの処理はHiRDB CMの管理から解除されるのみで、バックアップファイルそのものは削除されません。実体の削除を行う場合は、各製品にて個別に削除してください。

· ファイル種別が「NetBackup」のファイルを削除する場合:

対象NetBackupポリシーを使用したカタログを作成し、且つスケジュール登録を行っている場合、これらの情報は自動的に削除されません。不要な場合、カタログは[カタログ情報]コマンド、スケジュールは[スケジュールリスト]コマンドの削除機能を使用して削除してください。


[バックアップ詳細情報]

[バックアップ詳細情報]コマンド

HiRDB CMで管理しているバックアップファイルをバックアップデータごとに表示します。

1. HiRDBシステム名を選択。

コンボボックス「HiRDBシステム」一覧から、表示したいバックアップファイルが属しているHiRDBシステム名を選択してください。

2. 表示対象バックアップファイルの検索条件を指定。

グループ「取得単位」にあるラジオボタンの中から任意の単位を選択し、コンボボックスと各リストボックスから表示を行うバックアップファイルの取得対象を指定します。

· HiRDBシステム全体で取得したバックアップファイルを表示する場合:

グループ「取得単位」から「HiRDBシステム」ラジオボタンを選択ます。

· ユニット単位で取得したバックアップファイルを表示する場合:

グループ「取得単位」から「ユニット単位」ラジオボタンを選択します。リストボックス「ユニット」に情報が表示されますので、任意のユニット名を指定します。

· サーバ単位で取得したバックアップファイルを表示する場合:

グループ[取得単位]から「サーバ単位」ラジオボタンを選択します。リストボックス「ユニット」から取得する対象が属するユニットを選択してください。リストボックス「ユニット」で情報を選択すると、リストボックス「サーバ」に情報が表示されますので、任意のサーバ名を指定します。

· RDエリア単位で取得したバックアップファイルを表示する場合:

グループ「取得単位」から「RDエリア単位」ラジオボタンを選択します。リストボックス「ユニット」・「サーバ」から取得する対象が属するユニット・サーバを選択してください。リストボックス「サーバ」で情報を選択すると、リストボックス「RDエリア」に情報が表示されますので、任意のRDエリア名を指定します。

· 差分バックアップで取得したバックアップファイルを表示する場合:

リスト「差分バックアップグループ」から表示対象の差分バックアップグループを選択します。

3. 「次へ」ボタンの選択。

「次へ」ボタンを押すことで、検索が開始されます。検索が正常に終了すると、取得単位ごとのバックアップ情報が表示されます。

4. 対象バックアップファイルの選択。

画面上部に検索されたバックアップがアイコンで時系列に表示されます。アイコンにカーソルを合わせるとバックアップファイル名と取得時間が表示されます。詳細情報表示を行いたいバックアップに該当するアイコンをクリックしてください。

· バックアップ情報表示内容

次にバックアップ情報として表示される情報の詳細について説明します。

検索されるバックアップファイル：

  「取得対象」がシステム全体で取得したバックアップファイルを表示する場合、バックアップ実行時にシステム全体を指定したバックアップファイルが対象になります。ユニット単位で表示する場合、バックアップ実行時にシステム全体または、ユニット単位を指定したバックアップファイルが対象となります。サーバ単位で表示する場合、バックアップ実行時にシステム全体、ユニット単位または、サーバ単位を指定したバックアップファイルが対象となります。

バックアップファイルアイコンの色：

  「取得対象」で差分バックアップを選択した場合、フルバックアップで取得したバックアップファイルは黄色のアイコンで表示されます。累積差分バックアップで取得したバックアップファイルは、赤いアイコンで表示されます。また、「取得対象」で差分バックアップ以外を選択した場合、指定した全ての対象を含むバックアップファイルは黄色アイコンで表示されます。一部の対象を含むバックアップファイルは赤色のアイコンで表示されます。バックアップ取得後にRDエリアを追加した場合、同じサーバ、ユニット、システムを選択した場合でも赤色のアイコンで表示します。

サーバランIDについて：

  サーバランIDとそれに対応する世代番号は、バックアップファイル取得時に対象のサーバが自動ログアンロード機能を使用していた場合にのみ表示されます。

<注意事項>

· NetBackupを使用したバックアップファイルを表示、検索することはできません。


[バックアップファイル格納先の登録/削除]

[バックアップファイル格納先の登録/削除]コマンド

バックアップで取得するバックアップファイルの格納先を作成し登録します。

HiRDB CMでバックアップを実行するためには、このコマンドでバックアップファイルの格納先を登録する必要があります。

このコマンドを選択すると、バックアップファイル格納先を登録あるいは削除するための画面を表示します。

§ 通常ファイル格納先の作成と登録

通常ファイル格納用のディレクトリを作成し、HiRDB CMへ登録します。

§ ファイル格納用HiRDBファイルシステム領域の作成と登録

バックアップファイル格納用のHiRDBファイルシステム領域を作成し、HiRDB CMへ登録します。

§ 管理ファイル格納先の削除

HiRDB CMで管理しているバックアップファイル格納先を削除します。

<注意事項>

1. 「通常ファイル格納先の作成と登録」及び「ファイル格納用ファイルシステム領域の作成と登録」について:

· 指定された「格納先ディレクトリ名」あるいは「HiRDBファイルシステム領域名」の語尾に空白が入力されていた場合は、空白が取り除かれて実行されます。

· ここで登録したバックアップファイル格納先は、[アンロードログファイル格納先の登録/削除]コマンドで登録し使用することはできません。

2. 「管理ファイル格納先の削除」について:

· 削除を実行するファイル格納先にバックアップファイルが1つでも存在する場合は削除を実行できません。バックアップファイル格納先の削除を実行するには、[バックアップファイル情報]コマンドの削除機能を使用し、格納されているバックアップファイルを全て削除してから実行してください。

HiRDB CM以外で作成したファイルが存在する場合は、それらのファイルを削除又は別のディレクトリに移動させてからファイル格納先の削除を実行してください。

· 削除を実行するファイル格納先がキャラクタ型スペシャルファイル上に作成したHiRDBファイルシステム領域である場合は、HiRDB CMの管理からは解除されますがキャラクタ型スペシャルファイルそのものは削除されません。

· マルチHiRDBシステムを構成している場合:

異なるHiRDBシステムに対して同一サーバマシンの同一ディレクトリをファイル格納先として登録しないでください。バックアップファイルの正しい管理が出来なくなります。

誤って登録した場合は、双方のHiRDBから格納先の削除を行ってください。

· 系切り替え構成を使用している場合：

スタンバイ型系切り替え構成を使用している場合、現用系-予備系の双方の系から接続可能な共有DISK上にバックアップ格納先を作成してください。共有DISK上にバックアップ格納先を作成しない場合、[データべ-スの複写]・[データベースの回復]・[バックアップファイルの削除]・[バックアップファイル格納先の削除]などの操作ができなくなります。

l 通常ファイル格納先の作成と登録

1. 「実行する操作」グループで「通常ファイル格納先の作成と登録」を選択。

通常ファイル格納用のディレクトリを作成し、HiRDB CMへ登録します。

2. 「HiRDBシステム」からHiRDBシステム名を選択。

3. 「ホスト」からホスト名を選択。

バックアップファイル格納先を作成するホストを指定します。

4. 「格納先ディレクトリ名」を入力する。

バックアップファイル格納先ディレクトリ名を指定します。

なお、登録するディレクトリの1段階上の階層までは、既に存在するパスを指定します。

格納先ディレクトリ名は絶対パスで指定してください。

[参照]ボタンをクリックして対象となる格納先ディレクトリ名称を指定することもできます。

5. 「登録」ボタンをクリック。

指定されたバックアップファイル格納先ディレクトリの作成と登録を行います。

l ファイル格納用HiRDBファイルシステム領域の作成と登録

1. 「実行する操作」グループで「ファイル格納用HiRDBファイルシステム領域の作成と登録」を選択。

バックアップファイル格納用のHiRDBファイルシステム領域を作成し、HiRDB CMへ登録します。

2. 「HiRDBシステム」からHiRDBシステム名を選択。

3. 「ホスト」からホスト名を選択。

バックアップファイル格納先を作成するホストを指定します。

4. 「HiRDBファイルシステム領域名」を入力する。

バックアップファイル格納先用のHiRDBファイルシステム領域名を指定します。

なお、登録するHiRDBファイルシステム領域を格納するディレクトリまでは、既に存在するパスを指定します。

HiRDBファイルシステム領域名は絶対パスで指定してください。

[参照]ボタンをクリックして対象となる格納先HiRDBファイルシステム領域名を指定することもできます。

5. 各オプションを指定する。

· 「ファイル格納用HiRDBファイルシステム領域の設定」グループ

§ 「HiRDBファイルシステム領域サイズ」

HiRDBファイルシステム領域として割り当てる容量をメガバイト単位で指定します。設定範囲は((1～1048575))の間で指定することができます。

§ 「作成するHiRDBファイル数」

HiRDBファイルシステム領域内に作成するHiRDBファイル数の上限を指定します。設定範囲は((1～4096))の間で指定することができます。

§ 「HiRDBファイルの増分回数」

HiRDBファイルシステム領域内のHiRDBファイルの増分回数の上限値を指定します。設定範囲は((0～60000))の間で指定することができます。

§ 「HiRDBファイルシステム領域を初期化する」

「HiRDBファイルシステム領域サイズ」で指定したサイズ分の領域を最初から初期化する場合に指定します。このオプションを選択しない場合、HiRDBファイルシステム領域の管理情報だけを作成します。

· 「ファイル種別」グループ

HiRDBファイルシステム領域のファイル種別を以下の2つから選択します。

§ 「通常ファイル」

§ 「キャラクタ型スペシャルファイル」

6. 「登録」ボタンをクリック。

指定されたHiRDBファイルシステム領域の作成と登録を行います。

l 管理ファイル格納先の削除

1. 「実行する操作」グループで「管理ファイル格納先の削除」を選択。

HiRDB CMで管理しているバックアップファイル格納先を削除します。

2. 「HiRDBシステム」からHiRDBシステム名を選択。

3. 「ホスト」からホスト名を選択。

削除するバックアップファイル格納先が存在するホスト名を指定します。

4. 削除するバックアップファイル格納先を選択。

削除を行うバックアップファイル格納先を「管理ファイル格納先」リストボックスから選択します。

なお、「管理ファイル格納先」リストボックスは、複数指定が可能です。

5. 「削除」ボタンをクリック。

指定されたバックアップファイル格納先を削除します。


[ウィザード環境設定]

[ウィザード環境設定]コマンド

[バックアップ ウィザード]コマンド画面のデフォルト値の設定、及びオプション情報の登録を行います。

このコマンドを選択するとウィザードの環境設定を保存するための画面を表示します。なお、ここでの設定は[バックアップ カスタマイズ]コマンド画面には反映されません。

[バックアップウィザード - 環境設定]画面

1. 各オプションの入力及び登録をする。

· リストボックス「HiRDBシステム」

ウィザード画面でHiRDBシステムを選択する項目が表示された場合、ここで選択された情報がデフォルト値として設定されます。複数の選択はできません。

· グループ「ファイル種別」

バックアップファイルの種別を選択します。ここで選択された情報がデフォルト値として設定されます。

「JP1/OmniBack」ラジオボタンは、グループ「JP1/OmniBack Ⅱ」のリストボックス「バーリストファイル名」へバーリストファイル名が登録されている場合に、選択ができます。リストボックス「バーリストファイル名」に何も登録されていない場合は、選択できません。

· グループ「バックアップ取得モード」

バックアップ取得中の、RDエリアの閉塞状態を設定します。このグループは[バックアップ ウィザード]コマンドに設定用の項目がありません。任意のバックアップ取得モードでバックアップを実行したい場合は、この[ウィザード環境設定]で設定してください。

· グループ「処理結果出力ファイル」

出力ファイルの設定をします。このグループは[バックアップ ウィザード]に設定用の項目がありません。処理結果出力ファイルの格納先を変更したい場合やRDエリアの使用状況を出力したい場合は、この[ウィザード環境設定]で設定してください。

· グループ「JP1/OmniBack Ⅱ」

JP1/OmniBack Ⅱを使用する場合に設定します。

リストボックス「バーリストファイル名」にバーリストファイル名が登録されていない場合は、[バックアップ ウィザード]コマンドでJP1/OmniBack Ⅱのバックアップが実行できません。JP1/OmniBack Ⅱを[バックアップ ウィザード]で実行する場合は、必ずバーリストファイルを登録してください。

· グループ「EasyMT」

EasyMT又はEasyMT, MTguideを使用する場合に設定します。

リストボックス「属性定義ファイル名」とリストボックス「MTのボリューム名」に情報が登録されていない場合、[バックアップ ウィザード]で属性定義ファイル名とMTのボリューム名の指定ができません。[バックアップ ウィザード]で属性定義ファイル名とMTのボリューム名を指定して実行する場合は、必ず登録してください。 (EasyMT又とEasyMT, MTguideは、属性定義ファイル名とMTのボリューム名を登録していなくても実行できます。)

スピンボックス「入出力バッファ面数」は、[バックアップ ウィザード]に設定用の項目がありません。任意の値でバックアップを実行したい場合は、この[ウィザード環境設定]で設定してください。

· チェックボックス「排他待ち限界経過時間」

排他待ち時間を監視する最大待ち時間を秒単位で指定します。チェックボックスを選択すると、時間指定用のスピンボックスの入力が可能となりますので、任意の値を入力してください。このチェックボックスは[バックアップ ウィザード]に設定用の項目がありません。任意の値を指定したい場合は、この[ウィザード環境設定]で設定してください。

2. [保存]ボタンをクリック。

設定された情報を保存します。この画面で指定された値は[バックアップ ウィザード]画面のデフォルト値、あるいは内部で持つ情報に反映されます。

<注意事項>

· [バックアップ－ウィザード]画面が表示されている場合は、[ウィザード環境設定]を行うことはできません。全ての[ウィザード－バックアップ]画面を閉じてから[ウィザード環境設定]を実行してください。


[既存バックアップファイルの登録]

[既存バックアップファイルの登録]コマンド

HiRDB CMを使用せずにpdcopyコマンドで取得したバックアップファイルをHiRDB CMに登録し、GUIで管理する場合に実行します。

CM Agentはpdbkuplsコマンドを実行し、その結果を元にCM Serverで情報を管理します。

このコマンドを選択すると、[既存バックアップファイルの登録]画面が表示されます。

<前提条件>

· 対象システムがXDM/RDの場合、本コマンドを実行することはできません。

· 対象システムのCM Agentが08-01未満の場合、本コマンドを実行することはできません。

· 対象HiRDBシステムのバージョンが07-02未満の場合、本コマンドを実行することはできません。

· 登録するバックアップは、対象HiRDBシステムのユニットが存在するマシンから参照できる必要があります。

· 登録できるバックアップ情報は、通常ファイルまたは、HiRDBファイルシステム領域に出力したバックアップです。テープ装置、NetBackupなどに取得したバックアップ情報を登録することはできません。

· 差分バックアップ機能を使用して取得したバックアップファイルは登録できません。

1. HiRDBシステム名を選択。

コンボボックス「HiRDBシステム」から、処理対象となるHiRDBシステムを選択します。

2. バックアップファイルが存在するホスト名を選択。

コンボボックス「バックアップの存在するホスト名」に対象HiRDBシステムのホスト名が表示されます。パラレルサーバの場合は、バックアップファイルが存在するホストを選択してください。対象のHiRDBシステムがシングルサーバの場合は、選択する必要はありません。

3. 「バックアップファイル種別」を選択。

バックアップファイルの種別を選択します。

· 通常ファイル

Unixまたは、Windwosファイルシステム上に通常ファイルとして取得したバックアップファイルを登録する場合に選択します。

· HiRDBファイル

HiRDBファイルシステム領域上にHiRDBファイルとして取得したバックアップファイルを登録する場合に選択します。

4. 「バックアップファイル名」を指定。

· 登録するバックアップ情報が一つのファイルで構成される場合

テキストボックス「バックアップファイル名」にバックアップファイルの名称を絶対パスで指定します。

· 登録するバックアップ情報が複数一つのファイルで構成される場合

a. チェックボックス「複数ファイルで構成するバックアップファイル」をチェックします。

b. テキストボックス「バックアップファイル名」に一つのバックアップファイルの名称を絶対パスで指定します。

c. 「追加」ボタンをクリックし、バックアップファイルを構成するファイル一覧にバックアップファイル名を追加します。

d. すべてのファイルに対して、b、ｃの操作を実行します。

追加したバックアップファイルを一覧から削除する場合は、該当するファイルを選択し「削除」ボタンをクリックしてください。

5. 実行。

「登録」ボタンをクリックし、既存バックアップファイルの登録を行います。

<注意事項>

· 一度のpdcopyで複数のバックアップファイルにバックアップ情報を出力した場合、すべてのバックアップファイルを同時に指定してください。

· 本コマンドで登録したバックアップを使用したリカバリでは、自動ログアンロード機能により取得したアンロードログファイルを指定したリカバリを実行することができません。アンロードログファイルを使用して回復を行う場合は、手動でアンロードログファイルを指定してください。

· 本コマンドで登録したバックアップは、HiRDB CM内で次のように扱われます。

-登録したバックアップの取得単位に関係なく、取得単位がRDエリア単位として登録されます。

-世代番号指定オプション(-q)に0を指定して取得したバックアップファイルは、世代番号指定オプションを指定しないで取得したバックアップファイルとして登録されます。

-「バックアップファイル詳細情報」画面で参照する場合、「システムログ情報」には何も表示されません。

· 同名のバックアップファイルが既にHiRDB CMに登録されている場合、登録処理はエラーになります。バックアップファイルの名称を変更して登録してください。

· 登録したバックアップファイルが存在するディレクトリまたは、HiRDBファイルシステム領域が、HiRDB CM上でバックアップ格納先として登録されていない場合、自動的にバックアップ格納先として登録されます。


[リカバリ]タブ

[リカバリ]タブには、以下のようなコマンドがあります。

[ウィザード]

[カスタマイズ]

[HiRDBファイルシステム領域単位のリカバリ]

[カタログ実行]


[ウィザード]

[ウィザード]コマンド

データベース回復ユティリティ (pdrstr) をウィザードで実行します。

このコマンドを選択すると、リカバリを実行するための[ウィザード]画面が表示されます。

  この[ウィザード]コマンドは、リカバリを行いたい対象を指定すると、HiRDB CMで取得したバックアップファイルの中から検索を行い、指定対象を最新の同期点または、任意の時間の状態に回復する方法を提示する機能です。また、同じ画面から提示された回復方法でリカバリを実行することもできます。

  リカバリウィザード機能は、単一のバックアップ方法で運用している場合に有効な機能です。複数の条件で取得したバックアップファイルが存在する運用を行っている場合は、[バックアップ詳細情報]でバックアップ情報を確認して、[リカバリカスタマイズ]によるリカバリをお勧めします。

HiRDB CMでは、次の条件でリカバリ方法を提示します。

· 最新の同期点に回復を行う場合：:

  指定した対象を全て含む最新のバックアップファイルを使用してバックアップ取得時点への回復を行う回復方法を提示します。また、対象のサーバが自動ログアンロードを使用している場合、自動ログアンロードで取得したアンロードログファイルを使用して最新の同期点への回復を提示します。

· 任意の同期点に回復を行う場合：:

  指定した対象を全て含むバックアップファイルの中で、指定した時刻以前で最新のバックアップファイルを使用してバックアップ取得時点への回復方法を提示します。また、対象のサーバが自動ログアンロードを使用している場合、自動ログアンロードで取得したアンロードログファイルを使用して指定した同期点への回復を提示します。ただし、差分バックアップ機能をして取得したバックアップファイルが検索された場合は、回復方法を提示できません。

<前提条件>

· この[ウィザード]コマンドは、HiRDB CMで1回以上バックアップを取得していなければ実行することができません。

· この[ウィザード]コマンドでリカバリを実行するには、HiRDBの状態が稼動中あるいは複写/回復専用開始モードである必要があります。それ以外のHiRDBの状態では実行することができません。

1. リカバリ対象を指定します。

グループ「回復単位」にあるラジオボタンの中から任意の単位を選択し、コンボボックスと各リストボックスからリカバリ対象を指定します。

· HiRDBシステム全体のリカバリを実行する場合:

グループ「回復単位」から「HiRDBシステム」ラジオボタンを選択し、コンボボックス「HiRDBシステム」から任意の対象を指定します。

· ユニット単位のリカバリを実行する場合:

グループ「回復単位」から「ユニット単位」ラジオボタンを選択します。

コンボボックス「HiRDBシステム」から回復する対象が属するHiRDBシステムを選択してください。HiRDBシステムを選択すると、リストボックス「ユニット」に情報が表示されますので、任意のユニット名を指定します。

· サーバ単位のリカバリを実行する場合:

グループ「回復単位」から「サーバ単位」ラジオボタンを選択します。

コンボボックス「HiRDBシステム」・「ユニット」から回復する対象が属するシステム名を選択してください。リストボックス「ユニット」で情報を選択すると、リストボックス「サーバ」に情報が表示されますので、任意のサーバ名を指定します。

· RDエリア単位のリカバリを実行する場合:

グループ「回復単位」から「RDエリア単位」ラジオボタンを選択します。

コンボボックス「HiRDBシステム」・「ユニット」・「サーバ」から回復する対象が属するシステム名を選択してください。リストボックス「サーバ」で情報を選択すると、リストボックス「RDエリア」に情報が表示されますので、任意のRDエリア名を指定します。

2. [回復指定時間]を設定します。

任意の時間に回復を行う場合は、[回復指定時間]を設定します。最新の同期点への回復を行う場合は、[回復時間]を指定する必要はありせん。

3. [確認画面へ]ボタンをクリック。

指定された条件で回復を行う条件を検索します。

4. [確認]画面

検索したバックアップファイル情報を元に、実行するリカバリの内容を表示します。

· [実行]ボタンをクリック:

内容を確認し問題がなければ[実行]ボタンをクリックしてください。リカバリの実行を行います。

· [カタログ]ボタンをクリック:

指定した情報でカタログを作成します。[カタログの登録]画面が表示されますので、エディットボックス[カタログ名]に任意の名前を入力してください。カタログ名は英数字のみ指定可能です。

<注意事項>

· 指定対象にフロントエンドサーバが含まれる場合:

サーバ単位でのリカバリは実行できません。

· 指定対象にリスト用RDエリアが含まれる場合:

RDエリア単位でのリカバリは実行できません。

· 管理対象HiRDBがWindows版パラレルサーバであり、すべてのユニットのHiRDBのインストールディレクトリが同じではない場合に、「ログファイルを使用した回復」を本画面から[実行]しないでください。以下の順序で実行してください。

  1． [カタログ]登録を行ってください。

  2． 作成したカタログに対して[リカバリ]タブメニュー-[カタログ実行]画面から[変更]コマンドを実行してください。

  3． 2で実行された[リカバリカスタマイズ]画面の[ログファイル]タブページで、ソート用ワークバッファディレクトリを指定してください。

  4． [リカバリカスタマイズ]画面の[確認]タブページから[実行]を行ってください。

· 自動ログアンロード機能で取得したログを使用したリカバリが提示された場合:

- 自動ログアンロードのアンロードログファイル出力先ディレクトリに、ファイルが257以上格納されている場合は実行することができません。ファイルが257以上存在する場合は不要なファイルの削除を行い、アンロードログファイル出力先ディレクトリ内のファイルを256以内にしてください。

- 回復対象がすべて同一ホスト上に存在していない場合は実行することができません。ホストごとに数回に分けてリカバリを行ってください。

- 回復対象のサーバに対して定義されている自動ログアンロード格納先ディレクトリの総計が129以上の場合は実行することができません。サーバごとに数回に分けてリカバリを行ってください。

- 以下のいずれかに該当する場合、「自動アンロードログファイル」を選択してリカバリを実行することができません。

(1). バックアップ取得時点からリカバリを実行するまでの間にアンロードログファイルの出力先ディレクトリを変更した場合。

(2). バックアップ取得時点からリカバリを実行するまでの間に自動ログアンロード運用に切り替えた場合。

(3). アンロードログ格納先にディレクトリとHiRDBファイルシステム領域を混在している場合。

· インナレプリカ構成について:

[リカバリウィザード]では、インナレプリカ機能をサポートしておりません。別の世代のRDエリアで最新のバックアップが取得されている場合でも、指定したRDエリアのバックアップが選択される場合があります。また、自動ログアンロードを使用したリカバリが選択された場合は、対象RDエリアのログを使用して回復が行われます。対象バックアップ取得後に他の世代で運用を行ったシステムを回復する場合は、[リカバリカスタマイズ]を使用して回復を行ってください。

· HiRDBファイルシステム領域単位のリカバリについて：

[リカバリウィザード]では、HiRDBファイルシステム領域単位リカバリをサポートしておりません。HiRDBファイルシステム単位のリカバリを行う場合は、[HiRDBファイルシステム単位のリカバリ]を使用して回復を行ってください。

· 系切り替え構成を使用する場合：

マスタ用RDエリアを含む回復を行う場合、あらかじめ複写回復専用モードでHiRDBシステムを開始しておく必要があります。

· 複写回復専用開始の状態でリカバリを取得すると、KFPE25023-Wで警告終了しますが、リカバリは正常に終了しています。


[カスタマイズ]

[カスタマイズ]コマンド

データベース回復ユティリティ (pdrstr) をカスタマイズで実行します。

このコマンドを選択すると、リカバリを実行するための[カスタマイズ]画面が表示されます。

リカバリ カスタマイズの各タブページの設定内容を、以下で説明します。

· [回復単位]ページ

· [バックアップファイル]ページ

· [ログファイル]ページ

· [詳細設定]ページ

· [確認]ページ

<前提条件>

· この[カスタマイズ]コマンドは、HiRDB CMで1回以上バックアップを取得していなければ実行することができません。

· この[カスタマイズ]コマンドは、指定されたリカバリ内容とHiRDBの稼動状態によって、実行可能な時と実行不可能な時があります。

以下にリカバリの実行条件を示します。

 | マスタディレクトリ用RDエリアを含む |  | マスタディレクトリ用RDエリアを含まない
HiRDB稼動状態 | アンロードログファイル指定有 | アンロードログファイル指定無 | アンロードログファイル指定有 | アンロードログファイル指定無
稼動中 | 不可 | 可能 | 可能 | 可能
停止 | 不可 | 可能 | 不可 | 不可
複写/回復専用開始モード | 不可 | 可能 | 不可 | 可能
一部停止中 | 不可 | 可能 | 不可 | 不可

<注意事項>

· 指定対象にマスタディレクトリ用RDエリアが含まれる場合:

他のRDエリアと同時にリカバリを実行する時は、アンロードログファイルを指定してのリカバリは実行できません。

なお、マスタディレクトリ用RDエリアのみ指定してリカバリを実行する時は、アンロードログファイルあるいはアンロードレスシステムログ運用を指定してのリカバリは可能です。

· 指定対象にデータディクショナリLOB用RDエリアが含まれる場合:

このRDエリアはアンロードログファイルを取得できないため、アンロードログファイルを指定してのリカバリは実行できません。なお、アンロードレスシステムログ運用を指定したリカバリは可能です。

· 自動ログアンロードを選択してリカバリを実行する場合:

- 自動ログアンロードのアンロードログファイル出力先ディレクトリに、ファイルが257以上格納されている場合は実行することができません。ファイルが257以上存在する場合は不要なファイルの削除を行い、アンロードログファイル出力先ディレクトリ内のファイルを256以内にしてください。

- 回復対象がすべて同一ホスト上に存在していない場合は実行することができません。ホストごとに数回に分けてリカバリを行ってください。

- 回復対象のサーバに対して定義されている自動ログアンロード格納先ディレクトリの総計が129以上の場合は実行することができません。サーバごとに数回に分けてリカバリを行ってください。

- 以下のいずれかに該当する場合、「自動アンロードログファイル」を選択してリカバリを実行することができません。

(1). バックアップ取得時点からリカバリを実行するまでの間にアンロードログファイルの出力先ディレクトリを変更した場合。

(2). バックアップ取得時点からリカバリを実行するまでの間に自動ログアンロード運用に切り替えた場合。

(3). アンロードログ格納先にディレクトリとHiRDBファイルシステム領域を混在している場合。

· ログファイルを使用してリカバリを実行する場合:

複数のホスト上に存在するRDエリアを同時に回復することはできません。単一ホスト上のRDエリアごとに分けて回復を行ってください。

· 系切り替え構成を使用する場合：

マスタ用RDエリアを含む回復を行う場合、あらかじめ複写回復専用モードでHiRDBシステムを開始しておく必要があります。

· 複写回復専用開始の状態でリカバリを取得すると、KFPE25023-Wで警告終了しますが、リカバリは正常に終了しています。


[HiRDBファイルシステム領域単位のリカバリ]

[HiRDBファイルシステム領域単位のリカバリ]コマンド

HiRDBファイルシステム領域単位でバックアップしたHiRDBファイルシステムを格納（リストア）します。また、HiRDBファイル単位にも格納できます。

このコマンドを選択すると、リカバリを実行するための画面が表示されます。各タブページで任意の情報を指定してください。

HiRDBファイルシステム領域単位のリカバリの各タブページの設定内容を、以下で説明します。

· [回復単位]ページ

· [詳細設定]ページ

· [確認]ページ


[カタログ実行]

[カタログ実行]コマンド

リカバリのカタログを操作するためのカタログリストを表示します。

このコマンドを選択すると、既存のカタログの状態を表示したカタログリストを表示します。ここで、カタログの操作を行います。

このコマンドは自動で最新の状態に更新されません。

最新の情報を表示するには、この[カタログ実行]コマンドを再実行するか、あるいは[F5]キーを押下することで最新の状態へ更新することができます。

1. 任意のカタログを選択。

カタログリストの上段にあるリストボックスに、既存の各カタログの状態が表示されています。ここで任意のカタログ名を選択し、右クリックを行うとポップアップメニューが表示されます。以下で各機能の説明をします。

§ [実行]

選択したカタログを即実行します。

§ [スケジュール]

カタログを実行する日時を指定します。[スケジュール ウィザード]画面が表示されます。指定した対象をダブルクリックすることでも実行できます。

§ [変更]

選択したカタログに登録されている内容を変更します。カタログに登録されている値をデフォルトとした[カスタマイズ]画面が表示されますので、任意の値を指定してください。

<注意事項>

· カタログの変更は既存のスケジュールには反映されません。変更前のカタログを使用したスケジュールが存在する場合は、当該スケジュールを一度削除した後に、再度新しいカタログを使用してスケジュールを登録してください。

§ [削除]

選択したカタログのファイルを削除します。また、[Delete]キーを押下することでも削除ができます。

ここで削除したカタログは再生することができません。


[システムログ管理]タブ

[システムログ管理]タブには、以下のようなコマンドがあります。

[システムログのアンロード]

[システムログの状態変更]

[システムログのスワップ]

[システムログファイルのオープン]

[システムログファイルのクローズ]

[システムログファイルの拡張]

[システムログファイルの削除]

[カタログ実行]

[アンロードログファイル情報]

[アンロードログファイル格納先の登録/削除]

[自動ログアンロード機能制御]

[既存アンロードログファイルの登録]


[システムログのアンロード]

[システムログのアンロード]コマンド

システムログファイルのアンロード (pdlogunld) を実行します。

このコマンドを選択すると、[システムログのアンロード]画面が表示されます。

· アンロードログファイルの名称について

アンロードログファイルの名称は、HiRDB CMで作成し実行します。ユーザがアンロードログファイル名を指定する必要はありません。

なお、HiRDB CMで作成したアンロードログファイルの名称は以下のようになります。

アンロード時のファイル名 = サーバ名 + システムランID + 世代番号 + ファイルグループ名

<前提条件>

· このコマンドは、HiRDB CMにアンロードログファイルの格納先を登録している必要があります。登録していない場合、システムログのアンロードを行えません。

以下のコマンドでアンロードログファイルの格納先を登録してください。

[アンロードログファイル格納先の登録/削除]コマンド

1. 「HiRDBシステム」と「サーバ」を指定する。

アンロードを実行するシステムをコンボボックス「HiRDBシステム」、サーバをコンボボックス[サーバ]から選択すると、選択したサーバ下のシステムログファイルの情報がリスト「システムログファイル」に表示されます。

2. アンロードを実行する「ファイルグループ名」を選択。

リスト「システムログファイル」から、アンロードを実行するファイルグループ名を選択します。

なお、リスト「システムログファイル」は複数選択が可能です。

3. 「アンロードログファイルの最大保持数」を指定する。

スピンボックス「アンロードログファイルの最大保持数」から、設定範囲は((1～256))の間で指定してください。

4. アンロードログファイルの「ファイル種別」を選択。

「アンロードログファイルの種別」グループから、ファイル種別を選択します。

通常ファイルで取得する場合は「ファイル」を選択し、HiRDBファイルシステム領域に取得する場合は「HiRDBファイル」を選択します。

ファイル種別を選択すると、HiRDB CMに登録されているファイル格納先をリスト「アンロードログファイル格納先」に表示します。

5. 「アンロードログファイルの格納先」を指定する。

リスト「アンロードログファイルの格納先」から、ファイル格納先を選択してください。

ファイル格納先を選択すると、その格納先が存在する「ホスト」が表示されます。

6. 「ファイルグループの状態」を指定する。

「ファイルグループの状態」グループから、アンロード対象のファイルグループの状態を指定できます。このオプションは任意で選択が可能です。

· 「ファイルグループの状態をチェックしない」

ファイルグループの状態をチェックしないで、アンロードを実行する場合に選択してください。

· 「アンロード待ち状態の継続」

ファイルグループの状態を変更しないで、アンロード待ちの状態を継続する場合に指定します。

7. 「ファイル種別」ごとの詳細を指定する。

「ファイル種別」グループで「HiRDBファイル」を選択した場合に、HiRDBファイルの「初期容量と増分値」を指定できます。

· 「初期容量と増分値」

HiRDBファイルの初期容量と増分値を指定します。設定範囲は((1～1048574))の間で指定することができます。指定しない場合は、デフォルトで<<100>>が仮定されます。

§ 初期容量

HiRDBファイルの初期容量を指定します。

初期容量は、[アンロードログファイル格納先の登録/削除]コマンドでHiRDBファイルシステム領域作成時に指定した「初期容量」より小さくなければなりません。これは、システムが管理用に使用する領域が必要となるためです。

§ 増分値

増分値 (アンロードデータが初期容量を超えた場合に確保する容量） を指定します。

アンロードログファイル容量の増分は、最大23回できます。ただし、[アンロードファイル格納先の登録/削除]コマンドでHiRDBファイルシステム領域作成時に指定した「HiRDBファイルの増分回数」を超えて増分はできません。

8. 実行

· [実行]ボタンをクリック:

内容を確認し問題がなければ[実行]ボタンをクリックしてください。システムログのアンロードを実行します。

· [カタログ]ボタンをクリック:

指定した情報でカタログを作成します。

[カタログの登録]画面が表示されますので、エディットボックス「カタログ名」に任意の名前を入力してください。カタログ名は英数字のみ指定可能です。

カタログ名を入力して[OK]ボタンをクリックすると、カタログの作成及び登録を行います。

<注意事項>

· 「ファイルグループの状態」グループの「ファイルグループの状態をチェックしない」を選択して実行した場合、以降のアンロードログファイルの名称が、前回と同じアンロードログファイルの名称と同じになる可能性があります。

· 指定したアンロードログファイル格納先に同名のアンロードログファイルが存在した場合、システムログのアンロードは行われません。

· カタログを作成し、それを使用したシステムログのアンロードを実行する場合:

カタログを使用したシステムログのアンロードを実行する時の、アンロードログファイル名には実行時のシステムランIDと世代番号が付けられます。従って、リスト「システムログファイル」に表示されているアンロードログファイル名とは異なる可能性があります。

· リスト「システムログファイル」から処理対象を複数指定し実行時にエラーが発生した場合は、成功したアンロードログファイルは削除されます。この場合は、正常に実行されるシステムログファイルのみを選択し、「状態をチェックしない」オプションを選択してください。

複数のシステムログファイルを対象としたアンロードをカタログする時は注意してください。

· システムログのアンロードをカタログしスケジュールする場合は、各システムログファイルに対してスケジュールを複数登録することをお勧めします。

· 系切り替え構成を使用している場合：

  対象の「ユニット」または、「サーバ」が停止している場合、アンロードを行う物理ファイルが存在するDISKへアクセスが可能であることを確認してから実行してください。

  影響分散スタンバイレス型系切り替え構成を使用している「サーバ」に対して、HiRDBシステムが停止している場合は、本コマンドを実行することはできません。

· 既にHiRDB CMで同じ情報のアンロードログファイルが登録されている場合は、アンロードログファイル情報を上書きして登録します。ここで、同じ情報のアンロードログファイルとは、取得元のシステムログファイルのサーバ名、サーバランID、世代番号、ファイルグループ名が一致するアンロードログファイルです。このとき、元のアンロードログファイルの実ファイルは削除されません。手動で削除を行ってください。


[システムログの状態変更]

[システムログの状態変更]コマンド

システムログファイルの状態変更 (pdlogchg) を実行します。

このコマンドを選択すると、[システムログの状態変更]画面が表示されます。

1. 「HiRDBシステム」と「サーバ」を指定する。

状態変更を実行するシステムをコンボボックス「HiRDBシステム」、サーバをコンボボックス[サーバ]から選択すると、選択したサーバ下のシステムログファイルの情報がリスト「システムログファイル」に表示されます。

2. 状態変更を実行する「ファイルグループ名」を選択。

リスト「システムログファイル」から、状態変更を実行するファイルグループ名を選択します。

なお、リスト「システムログファイル」は複数選択が可能です。

3. 実行

· [実行]ボタンをクリック:

内容を確認し問題がなければ[実行]ボタンをクリックしてください。システムログの状態変更を実行します。

· [カタログ]ボタンをクリック:

指定した情報でカタログを作成します。[カタログの登録]画面が表示されますので、エディットボックス[カタログ名]に任意の名前(英数字のみ入力可能)を入力してください。

カタログ名を入力して[OK]ボタンをクリックすると、選択した情報を確認するための[確認]画面が表示されます。ここで問題がなければ[確認]画面の[実行]ボタンをクリックしてください。カタログの登録を行います。

<注意事項>

· システムログの状態変更をカタログしスケジュールする場合は、各システムログファイルに対してスケジュールを複数登録することをお勧めします。

· 系切り替え構成を使用している場合：

  対象の「ユニット」または、「サーバ」が停止している場合、状態変更を行う物理ファイルが存在するDISKへアクセスが可能であることを確認してから実行してください。

  影響分散スタンバイレス型系切り替え構成を使用している「サーバ」に対して、HiRDBシステムが停止している場合は、本コマンドを実行することはできません。


[システムログのスワップ]

[システムログのスワップ]コマンド

システムログファイルのスワップ (pdlogswap) を実行します。

このコマンドを選択すると、[システムログのスワップ]画面が表示されます。

1. 「HiRDBシステム」と「サーバ」を指定する。

スワップを実行するシステムをコンボボックス「HiRDBシステム」、サーバをコンボボックス[サーバ]から選択すると、選択したサーバ下のシステムログファイルの情報がリスト「システムログファイル」に表示されます。

2. [実行]ボタンをクリック。

内容を確認し問題がなければ[実行]ボタンをクリックしてください。システムログのスワップを実行します。


[システムログファイルのオープン]

[システムログファイルのオープン]コマンド

システムログファイルのオープン (pdlogopen) を実行します。

このコマンドを選択すると、[システムログファイルのオープン]画面が表示されます。

1. 「HiRDBシステム」と「サーバ」を指定する。

オープンを実行するシステムをコンボボックス「HiRDBシステム」、サーバをコンボボックス[サーバ]から選択すると、選択したサーバ下のシステムログファイルの情報がリスト「システムログファイル」に表示されます。

2. オープンを実行する「ファイルグループ名」を選択。

リスト「システムログファイル」から、オープンを実行するファイルグループ名を選択します。

なお、リスト「システムログファイル」は複数選択が可能です。

3. 実行

· [実行]ボタンをクリック:

内容を確認し問題がなければ[実行]ボタンをクリックしてください。システムログファイルのオープンを実行します。

· [カタログ]ボタンをクリック:

指定した情報でカタログを作成します。

[カタログの登録]画面が表示されますので、エディットボックス「カタログ名」に任意の名前を入力してください。カタログ名は英数字のみ指定可能です。

カタログ名を入力して[OK]ボタンをクリックすると、カタログの作成及び登録を行います。

<注意事項>

· システムログのオープンをカタログしスケジュールする場合は、各システムログファイルに対してスケジュールを複数登録することをお勧めします。


[システムログファイルのクローズ]

[システムログファイルのクローズ]コマンド

システムログファイルのクローズ (pdlogcls) を実行します。

このコマンドを選択すると、[システムログファイルのクローズ]画面が表示されます。

1. 「HiRDBシステム」と「サーバ」を指定する。

クローズを実行するシステムをコンボボックス「HiRDBシステム」、サーバをコンボボックス[サーバ]から選択すると、選択したサーバ下のシステムログファイルの情報がリスト「システムログファイル」に表示されます。

2. クローズを実行する「ファイルグループ名」を選択。

リスト「システムログファイル」から、クローズを実行するファイルグループ名を選択します。

なお、リスト「システムログファイル」は複数選択が可能です。

3. 実行

· [実行]ボタンをクリック:

内容を確認し問題がなければ[実行]ボタンをクリックしてください。システムログファイルのクローズを実行します。

· [カタログ]ボタンをクリック:

指定した情報でカタログを作成します。

[カタログの登録]画面が表示されますので、エディットボックス「カタログ名」に任意の名前を入力してください。カタログ名は英数字のみ指定可能です。

カタログ名を入力して[OK]ボタンをクリックすると、カタログの作成及び登録を行います。

<注意事項>

· システムログのクローズをカタログしスケジュールする場合は、各システムログファイルに対してスケジュールを複数登録することをお勧めします。


[システムログファイルの拡張]

[システムログファイルの拡張]コマンド

システムログファイルの拡張を実行します。

[システムログファイルの拡張]コマンドでは、以下のことを行います。

  1． システムログファイルの物理ファイルがない場合は、物理ファイルを作成 (pdloginit) します。

  2． システムログファイルをオープンします。

このコマンドを選択すると、[システムログファイルの拡張]画面が表示されます。

<前提条件>

· システムログファイルの拡張を行う場合は、拡張を行うサーバに対してあらかじめ、クローズ状態のシステムログファイルを用意しておく必要があります。

1. 「HiRDBシステム」と「サーバ」を指定する。

拡張を実行するシステムをコンボボックス「HiRDBシステム」、サーバをコンボボックス[サーバ]から選択すると、選択したサーバ下のシステムログファイルの情報がリスト「システムログファイル」に表示されます。

2. 拡張を実行する「ファイルグループ名」を選択。

リスト「システムログファイル」から、拡張を実行するファイルグループ名を選択します。

なお、リスト「システムログファイル」は複数選択が可能です。

3. 「レコード数」を指定します。

システムログファイルを作成するHiRDBファイルのレコード数を指定します。

4. HiRDBファイルシステム領域の初期設定を行います。

[HiRDBファイルシステム領域の初期設定]ボタンにより、[HiRDBファイルシステム領域の初期設定/登録]画面を表示できます。

選択したシステムログファイルの物理ファイルを作成するHiRDBファイルシステムが存在しない場合は、[HiRDBファイルシステム領域の初期設定]画面から対応するHiRDBファイルシステム領域を作成してください。

<注意事項>

· [HiRDBファイルシステム領域の初期設定]ボタンから表示した[HiRDBファイルシステム領域の初期設定]画面では、拡張を実行するファイルグループの物理ファイルを作成するHiRDBファイルシステム領域の選択のみを行います。システムログファイルの物理ファイル以外の用途のHiRDBファイルシステム領域は作成できません。

5. 実行

· [実行]ボタンをクリック:

内容を確認し問題がなければ[実行]ボタンをクリックしてください。システムログファイルの拡張を実行します。

· [カタログ]ボタンをクリック:

指定した情報でカタログを作成します。

[カタログの登録]画面が表示されますので、エディットボックス「カタログ名」に任意の名前を入力してください。カタログ名は英数字のみ指定可能です。

カタログ名を入力して[OK]ボタンをクリックすると、カタログの作成及び登録を行います。

<注意事項>

· システムログの拡張をカタログしスケジュールする場合は、各システムログファイルに対してスケジュールを複数登録することをお勧めします。

· HiRDBが停止している場合は、システムログファイルをオープンすることができません。物理ファイルの作成のみを行います。

· 既に物理ファイルがある場合は、物理ファイルの作成を行わないため、レコード数の指定は無効になります。レコード数を変更したい場合は、[システムログファイルの削除]を行った後、[システムログファイルの拡張]を行って下さい。

·システムログが二重化されていて、かつ、どちらかの物理ファイルのみが存在する場合は、指定されたレコード数と既に存在する物理ファイルのレコード数が一致する場合のみ物理ファイルを作成します。

· リスト「システムログファイル」には、クローズ状態のシステムログファイルのみ表示されます。

· 系切り替え構成を使用している場合：

  対象の「ユニット」または、「サーバ」が停止している場合、拡張する物理ファイルが存在するDISKへアクセスが可能であることを確認してから実行してください。

  影響分散スタンバイレス型系切り替え構成を使用している「サーバ」に対して、HiRDBシステムが停止している場合は、本コマンドを実行することはできません。


[システムログファイルの削除]

[システムログファイルの削除]コマンド

システムログファイルの削除 (pdlogrm) を実行します。

このコマンドを選択すると、[システムログファイルの削除]画面が表示されます。

1. 「HiRDBシステム」と「サーバ」を指定する。

削除を実行するシステムをコンボボックス「HiRDBシステム」、サーバをコンボボックス[サーバ]から選択すると、選択したサーバ下のシステムログファイルの情報がリスト「システムログファイル」に表示されます。

2. 削除を実行する「ファイルグループ名」を選択。

リスト「システムログファイル」から、削除を実行するファイルグループ名を選択します。

なお、リスト「システムログファイル」は複数選択が可能です。

3. 削除方法を指定します。

システムログファイルの状態に応じて、強制削除を行うかを指定します。このオプションは任意で選択が可能です。

· 「強制削除」

システムログファイルが次の状態であっても強制的にファイルを削除するときに指定します。

  アンロード待ち状態

  HiRDB Datareplicator連携時の抽出未完了状態

  オンライン再編成上書き禁止状態

4. 実行

· [実行]ボタンをクリック:

内容を確認し問題がなければ[実行]ボタンをクリックしてください。システムログファイルの削除を実行します。

· [カタログ]ボタンをクリック:

指定した情報でカタログを作成します。

[カタログの登録]画面が表示されますので、エディットボックス「カタログ名」に任意の名前を入力してください。カタログ名は英数字のみ指定可能です。

カタログ名を入力して[OK]ボタンをクリックすると、カタログの作成及び登録を行います。

<注意事項>

· システムログの削除をカタログしスケジュールする場合は、各システムログファイルに対してスケジュールを複数登録することをお勧めします。

· システムログが二重化されている場合は、両方の物理ファイルを削除します。一方の物理ファイルが削除、他方の物理ファイルの削除に失敗した場合は、システムログファイルのが不正な状態になります。そのシステムログはオープンせずに、再度システムログファイルの削除を行ってください。

· 系切り替え構成を使用している場合：

  対象の「ユニット」または、「サーバ」が停止している場合、削除する物理ファイルが存在するDISKへアクセスが可能であることを確認してから実行してください。

  影響分散スタンバイレス型系切り替え構成を使用している「サーバ」に対して、HiRDBシステムが停止している場合は、本コマンドを実行することはできません。


[カタログ実行]

[カタログ実行]コマンド

アンロードログ管理のカタログを操作するためのカタログリストを表示します。

このコマンドを選択すると、既存のカタログの状態を表示したカタログリストを表示します。ここで、カタログの操作を行います。

このコマンドは自動で最新の状態に更新されません。

最新の情報を表示するには、この[カタログ実行]コマンドを再実行するか、あるいは[F5]キーを押下することで最新の状態へ更新することができます。

1. 任意のカタログを選択。

カタログリストの上段にあるリストボックスに、既存の各カタログの状態が表示されています。ここで任意のカタログ名を選択し、右クリックを行うとポップアップメニューが表示されます。以下で各機能の説明をします。

§ [実行]

選択したカタログを即実行します。

§ [スケジュール]

カタログを実行する日時を指定します。[スケジュール ウィザード]画面が表示されます。指定した対象をダブルクリックすることでも実行できます。

§ [変更]

選択したカタログに登録されている内容を変更します。カタログに登録されている値をデフォルトとした[カスタマイズ]画面が表示されますので、任意の値を指定してください。

<注意事項>

· カタログの変更は既存のスケジュールには反映されません。変更前のカタログを使用したスケジュールが存在する場合は、当該スケジュールを一度削除した後に、再度新しいカタログを使用してスケジュールを登録してください。

§ [削除]

選択したカタログのファイルを削除します。また、[Delete]キーを押下することでも削除ができます。

ここで削除したカタログは再生することができません。


[アンロードログファイル情報]

[アンロードログファイル情報]コマンド

HiRDB CMで管理しているアンロードログファイルを表示し、また削除を行います。

このコマンドを選択すると、アンロードログファイルを一覧表示するための画面を表示します。

1. HiRDBシステム名を選択。

コンボボックス「HiRDBシステム」一覧から、削除を実行したいアンロードログファイルが属しているHiRDBシステム名を選択してください。

2. サーバ名を選択。

コンボボックス「サーバ名」一覧から、削除を実行したいアンロードログファイルが属しているサーバ名を選択してください。

3. アンロードログファイル種別を選択。

4. アンロードログファイル格納先の選択。

リスト「管理ファイル格納先」からアンロードログファイル格納先を選択してください。

アンロードログファイル格納先を選択すると、リスト「アンロードログファイル」に格納されているファイルが表示されます。

5. 削除するアンロードログファイル名を選択。

削除するアンロードログファイル名を選択してください。なお、アンロードログファイル名は複数選択が可能です。

6. [削除]ボタンをクリック。

選択されているアンロードログファイルの削除を実行します。

<注意事項>

· [既存アンロードログファイルの登録]コマンドで登録したアンロードログファイルは、HiRDB CMで管理する名称と実際の名称が異なる場合があります。リストボックス「アンロードログファイル」に表示される実ファイル名を参照し、確認を行った削除を実行してください。


[アンロードログファイル格納先の登録/削除]

[アンロードログファイル格納先の登録/削除]コマンド

システムログのアンロードで取得するアンロードログファイルの格納先を作成し登録します。

HiRDB CMでシステムログのアンロードを実行するためには、このコマンドでアンロードログファイルの格納先を登録する必要があります。

このコマンドを選択すると、アンロードログファイル格納先を登録あるいは削除するための画面を表示します。

§ 通常ファイル格納先の作成と登録

通常ファイル格納用のディレクトリを作成し、HiRDB CMへ登録します。

§ ファイル格納用HiRDBファイルシステム領域の作成と登録

アンロードログファイル格納用のHiRDBファイルシステム領域を作成し、HiRDB CMへ登録します。

§ 管理ファイル格納先の削除

HiRDB CMで管理しているアンロードログファイル格納先を削除します。

<注意事項>

1. 「通常ファイル格納先の作成と登録」及び「ファイル格納用ファイルシステム領域の作成と登録」について:

· 指定された「格納先ディレクトリ名」あるいは「HiRDBファイルシステム領域名」の語尾に空白が入力されていた場合は、空白が取り除かれて実行されます。

· ここで登録したアンロードログファイル格納先は、[バックアップファイル格納先の登録/削除]コマンドで登録し使用することはできません。

2. 「管理ファイル格納先の削除」について:

· 削除を実行するファイル格納先にアンロードログファイルが1つでも存在する場合は削除を実行できません。アンロードログファイル格納先の削除を実行するには、[アンロードログファイル情報]コマンドの削除機能を使用し、格納されているアンロードログファイルを全て削除してから実行してください。

HiRDB CM以外で作成したファイルが存在する場合は、それらのファイルを削除又は別のディレクトリに移動させてからファイル格納先の削除を実行してください。

· 削除を実行するファイル格納先が、キャラクタ型スペシャルファイル上に作成したHiRDBファイルシステム領域である場合は、HiRDB CMの管理からは解除されますがキャラクタ型スペシャルファイルそのものは削除されません。

· マルチHiRDBシステムを構成している場合:

異なるHiRDBシステムに対して同一サーバマシンの同一ディレクトリをファイル格納先として登録しないでください。アンロードログファイルの正しい管理が出来なくなります。

誤って登録した場合は、双方のHiRDBから格納先の削除を行ってください。

· 系切り替え構成を使用している場合：

現用系-予備系の双方の系または、ゲストBESとなるすべてのマシンから接続可能な共有DISK上にアンロードログファイル格納先を作成してください。共有DISK上にアンロードログファイル格納先を作成しない場合、[システムログのアンロード]・[データベースの回復]・[アンロードログファイルの削除]・[アンロードログファイルル格納先の削除]などの操作ができなくなります

l 通常ファイル格納先の作成と登録

1. 「実行する操作」グループで「通常ファイル格納先の作成と登録」を選択。

通常ファイル格納用のディレクトリを作成し、HiRDB CMへ登録します。

2. 「HiRDBシステム」からHiRDBシステム名を選択。

3. 「サーバ」からサーバ名を選択。

アンロードログファイル格納先を作成するサーバを指定します。

4. 「格納先ディレクトリ名」を入力する。

アンロードログファイル格納先ディレクトリ名を指定します。

なお、登録するディレクトリの1段階上の階層までは、既に存在するパスを指定します。

格納先ディレクトリ名は絶対パスで指定してください。

5. 「登録」ボタンをクリック。

指定されたアンロードログファイル格納先ディレクトリの作成と登録を行います。

l ファイル格納用HiRDBファイルシステム領域の作成と登録

1. 「実行する操作」グループで「ファイル格納用HiRDBファイルシステム領域の作成と登録」を選択。

アンロードログファイル格納用のHiRDBファイルシステム領域を作成し、HiRDB CMへ登録します。

2. 「HiRDBシステム」からHiRDBシステム名を選択。

3. 「サーバ」からサーバ名を選択。

アンロードログファイル格納先を作成するサーバを指定します。

4. 「HiRDBファイルシステム領域名」を入力する。

アンロードログファイル格納先用のHiRDBファイルシステム領域名を指定します。

なお、登録するHiRDBファイルシステム領域を格納するディレクトリまでは、既に存在するパスを指定します。

格納先ディレクトリ名は絶対パスで指定してください。

5. 各オプションを指定する。

· 「ファイル格納用HiRDBファイルシステム領域の設定」グループ

§ 「HiRDBファイルシステム領域サイズ」

HiRDBファイルシステム領域として割り当てる容量をメガバイト単位で指定します。設定範囲は((1～1048575))の間で指定することができます。

§ 「作成するHiRDBファイル数」

HiRDBファイルシステム領域内に作成するHiRDBファイル数の上限を指定します。設定範囲は((1～4096))の間で指定することができます。

§ 「HiRDBファイルの増分回数」

HiRDBファイルシステム領域内のHiRDBファイルの増分回数の上限値を指定します。設定範囲は((0～60000))の間で指定することができます。

§ 「HiRDBファイルシステム領域を初期化する」

「HiRDBファイルシステム領域サイズ」で指定したサイズ分の領域を最初から初期化する場合に指定します。このオプションを選択しない場合、HiRDBファイルシステム領域の管理情報だけを作成します。

· 「ファイル種別」グループ

HiRDBファイルシステム領域のファイル種別を以下の2つから選択します。

§ 「通常ファイル」

§ 「キャラクタ型スペシャルファイル」

6. 「登録」ボタンをクリック。

指定されたHiRDBファイルシステム領域の作成と登録を行います。

l 管理ファイル格納先の削除

1. 「実行する操作」グループで「管理ファイル格納先の削除」を選択。

HiRDB CMで管理しているアンロードログファイル格納先を削除します。

2. 「HiRDBシステム」からHiRDBシステム名を選択。

3. 「サーバ」からサーバ名を選択。

削除するアンロードログファイル格納先が存在するサーバ名を指定します。

4. 削除するアンロードログファイル格納先を選択。

削除を行うアンロードログファイル格納先を「管理ファイル格納先」リストボックスから選択します。

なお、「管理ファイル格納先」リストボックスは、複数指定が可能です。

5. 「削除」ボタンをクリック。

指定されたアンロードログファイル格納先を削除します。


[自動ログアンロード機能制御]

[自動ログアンロード機能制御]コマンド

自動ログアンロード機能を制御します。

このコマンドを選択すると、[自動ログアンロード機能制御]画面が表示されます。[自動ログアンロード機能制御]画面では、すべてのサーバに対する自動ログアンロード機能の動作状態を表示します。

<注意事項>

· 対象のHiRDBが停止している場合、もしくは停止しているユニットかサーバがある場合は、すべて、又は一部の情報が取得できません。

リスト下のボタンを押すことで、以下のコマンドが実行できます。

§ 一時停止 (pdlogatul -d sys -t)

§ 再開始 (pdlogatul -d sys -b)

l 一時停止 (pdlogatul -d sys -t)

自動ログアンロード機能を中断する場合に実行します。

1. 「サーバ」を指定

「自動ログアンロード機能情報」リストから対象のサーバを選択してください。

2. 「アンロード処理終了までコマンドの終了を遅延させる」オプションを指定

現在自動アンロード実行中のログ世代に対するアンロード処理が完了するまで、コマンドの終了を遅延させるときに指定します。このオプションを省略した場合は、自動ログアンロード機能を中断し、実行中のアンロード処理を強制的に終了します。

3. 「実行」

「一時停止」ボタンを押すと自動ログアンロード機能を中断を行います。

<注意事項>

· [コマンドの終了を遅延させる]オプションを指定した場合、アンロード処理がHiRDB CM Consoleで設定した待ち時間内に終わらないと、CM Consoleはタイムアウトでエラー終了しますが、CM Agentの処理は続きます。また、タイムアウトが発生した後、アンロード処理が終わるまでの間に同じHiRDBに対して操作を行うと、KFPE34070-Eエラーが発生します。

l 再開始 (pdlogatul -d sys -b)

自動ログアンロード機能を再開始する場合に実行します。

1. 「サーバ」を指定

「自動ログアンロード機能情報」リストから対象のサーバを選択してください。

2. 「実行」

「再開始」ボタンを押すと自動ログアンロード機能を再開始を行います。

<注意事項>

· 自動ログアンロード機能を再開始した場合、アンロード待ち状態であるシステムログファイルが自動的にアンロードされますが、HiRDB CMでは、アンロード終了を待ち合わせません。[再開始]直後にシステムログファイルの最新の情報を参照したい場合は、[オプション]-[管理情報の更新]から[状態情報]の更新を行ってください。


[既存アンロードログファイルの登録]

[既存アンロードログファイルの登録]コマンド

HiRDB CMを使用せずにpdlogunldコマンドで取得したアンロードログファイルをHiRDB CMに登録し、GUIで管理する場合に実行します。

CM Agentはpdlogucatコマンドを実行し、その結果を元にCM Serverで情報を管理します。

このコマンドを選択すると、[既存アンロードログファイルの登録]画面が表示されます。

<前提条件>

· 対象システムがXDM/RDの場合、本コマンドを実行することはできません。

· 対象システムのCM Agentが08-01未満の場合、本コマンドを実行することはできません。

· 対象HiRDBシステムのバージョンが07-02未満の場合、本コマンドを実行することはできません。

· 登録するアンロードログファイルは、アンロードログファイルとして取得したシステムログファイルを持つサーバと同じマシン上にある必要があります。

· HiRDB CMでは、アンロードログファイル名を実際のファイル名ではなく、次の命名規則に従った名称で管理します。

アンロード時のファイル名 = サーバ名 + システムランID + 世代番号 + ファイルグループ

実ファイル名は、[アンロードログファイル情報]コマンドで確認することができます。

1. HiRDBシステム名を選択。

コンボボックス「HiRDBシステム」から、処理対象となるHiRDBシステムを選択します。

2. アンロードログファイルが存在するホスト名を選択。

コンボボックス「アンロードログファイルの存在するホスト名」に対象HiRDBシステムのホスト名が表示されます。パラレルサーバの場合は、アンロードログファイルが存在するホストを選択してください。対象のHiRDBシステムがシングルサーバの場合は、選択する必要はありません。

3.アンロードログファイルに対応するサーバ名を選択。

コンボボックス「アンロードログファイルに対応するサーバ名」で、対象のアンロードログファイルの取得元であるサーバ名を選択します。

4. 「アンロードログファイル種別」を選択。

アンロードログファイルの種別を選択します。

· 通常ファイル

Unixまたは、Windwosファイルシステム上に通常ファイルとして取得したアンロードログファイルを登録する場合に選択します。

· HiRDBファイル

HiRDBファイルシステム領域上にHiRDBファイルとして取得したアンロードログファイルを登録する場合に選択します。

5. アンロードログファイルを指定。

· アンロードログファイル単位に指定する場合

テキストボックス「アンロードログファイル名」にアンロードログファイルの名称を絶対パスで指定します。

· ディレクトリまたはHiRDBファイルシステム領域名を指定する場合

a. チェックボックス「ディレクトリまたはHiRDBファイルシステム領域名を指定する」をチェックします。

b. テキストボックス「ディレクトリ名/HiRDBファイルシステム領域名」にディレクトリまたは、HiRDBファイルシステム領域名を絶対パスで指定します。

6. 実行。

「登録」ボタンをクリックし、既存アンロードログファイルの登録を行います。

<注意事項>

· アンロードログファイル種別でHiRDBファイルを選択した場合、登録することができるアンロードログファイルの絶対パスの長さは167文字以内です。それ以上のパスを指定した場合はエラーとなります。

· 登録することができるアンロードログファイル名の長さは255文字以内です。それ以上のファイルを指定した場合はエラーとなります。

· HiRDB CMで保持できるアンロードログファイル数は、システムログのアンロード時に設定した最大保持数、またはデフォルト値256個です。上限を超えるファイルを登録した場合、HiRDB CMは既存の管理情報と登録した管理情報のうち、新しいものから最大保持数分を保持し、管理対象とします。

· 登録したアンロードログファイルが存在するディレクトリまたは、HiRDBファイルシステム領域が、HiRDB CM上でアンロードログファイル格納先として登録されていない場合、自動的にアンロードログファイル格納先として登録されます。

· 既にHiRDB CMで同じ情報のアンロードログファイルが登録されている場合、アンロードログファイルを登録することはできません。ここで言う同じ情報のアンロードログファイルとは、取得元のシステムログファイルのサーバ名、システムランID、世代番号、ファイルグループ名が一致するアンロードログファイルとなります。


[ステータスファイル管理]タブ

[ステータスファイル管理]タブには、以下のようなコマンドがあります。

[ステータスファイルのスワップ]

[ステータスファイルのオープン]

[ステータスファイルのクローズ]

[ステータスファイルの作成]

[ステータスファイルの削除]

[カタログ実行]


[ステータスファイルのスワップ]

[ステータスファイルのスワップ]コマンド

ステータスファイルのスワップ (pdstsswap) を実行します。

このコマンドを選択すると、[ステータスファイルのスワップ]画面が表示されます。

1. 「HiRDBシステム」を指定する。

スワップを実行するシステムをコンボボックス「HiRDBシステム」から選択します。

2. ステータスファイルの種別と対象オブジェクトを選択します。

「種別」グループから[ユニット用ステータスファイル]か[サーバ用ステータスファイル]を選択します。次にコンボボックス[ユニット]あるいは[サーバ]から対象を選択すると、ステータスファイルの情報がリスト「ステータスファイル管理」に表示されます。

3. [実行]ボタンをクリック。

内容を確認し問題がなければ[実行]ボタンをクリックしてください。ステータスファイルのスワップを実行します。


[ステータスファイルのオープン]

[ステータスファイルのオープン]コマンド

ステータスファイルのオープン (pdstsopen) を実行します。

このコマンドを選択すると、[ステータスファイルのオープン]画面が表示されます。

1. 「HiRDBシステム」を指定する。

オープンを実行するシステムをコンボボックス「HiRDBシステム」から選択します。

2. ステータスファイルの種別と対象オブジェクトを選択します。

「種別」グループから[ユニット用ステータスファイル]か[サーバ用ステータスファイル]を選択します。次にコンボボックス[ユニット]あるいは[サーバ]から対象を選択すると、ステータスファイルの情報がリスト「ステータスファイル管理」に表示されます。

2. オープンを実行する「ステータスファイル名」を選択。

リスト「ステータスファイル管理」から、オープンを実行するステータスファイル名を選択します。

なお、リスト「ステータスファイル管理」は複数選択が可能です。

3. 実行

· [実行]ボタンをクリック:

内容を確認し問題がなければ[実行]ボタンをクリックしてください。ステータスファイルのオープンを実行します。

· [カタログ]ボタンをクリック:

指定した情報でカタログを作成します。

[カタログの登録]画面が表示されますので、エディットボックス「カタログ名」に任意の名前を入力してください。カタログ名は英数字のみ指定可能です。

カタログ名を入力して[OK]ボタンをクリックすると、カタログの作成及び登録を行います。


[ステータスファイルのクローズ]

[ステータスファイルのクローズ]コマンド

ステータスファイルのクローズ (pdstscls) を実行します。

このコマンドを選択すると、[ステータスファイルのクローズ]画面が表示されます。

1. 「HiRDBシステム」を指定する。

クローズを実行するシステムをコンボボックス「HiRDBシステム」から選択します。

2. ステータスファイルの種別と対象オブジェクトを選択します。

「種別」グループから[ユニット用ステータスファイル]か[サーバ用ステータスファイル]を選択します。次にコンボボックス[ユニット]あるいは[サーバ]から対象を選択すると、ステータスファイルの情報がリスト「ステータスファイル管理」に表示されます。

2. クローズを実行する「ステータスファイル名」を選択。

リスト「ステータスファイル管理」から、クローズを実行するステータスファイル名を選択します。

なお、リスト「ステータスファイル管理」は複数選択が可能です。

3. 実行

· [実行]ボタンをクリック:

内容を確認し問題がなければ[実行]ボタンをクリックしてください。ステータスファイルのクローズを実行します。

· [カタログ]ボタンをクリック:

指定した情報でカタログを作成します。

[カタログの登録]画面が表示されますので、エディットボックス「カタログ名」に任意の名前を入力してください。カタログ名は英数字のみ指定可能です。

カタログ名を入力して[OK]ボタンをクリックすると、カタログの作成及び登録を行います。


[ステータスファイルの作成]

[ステータスファイルの作成]コマンド

ステータスファイルの作成を実行します。

[ステータスファイルの作成]コマンドでは、以下のことを行います。

  1． ステータスファイルの物理ファイルがない場合は、物理ファイルを作成 (pdstsinit) します。

  2． ステータスファイルをオープンします。

このコマンドを選択すると、[ステータスファイルの作成]画面が表示されます。

<前提条件>

· ステータスファイルの作成を行う場合は、作成を行うサーバ・ユニットに対してあらかじめ、クローズ状態のステータスファイルを定義しておく必要があります。

· ステータスファイルを共有ディスクに作成する場合は、実行前に指定する「ユニット」または「サーバ」のすべてのステータスファイルが存在するすべてのディスクにアクセスが可能であることを確認して実行してください。

すべてのディスクにアクセスが可能でない状態で実行すると、作成に失敗します。

1. 「HiRDBシステム」を指定する。

作成を実行するシステムをコンボボックス「HiRDBシステム」から選択します。

2. ステータスファイルの種別と対象オブジェクトを選択します。

「種別」グループから[ユニット用ステータスファイル]か[サーバ用ステータスファイル]を選択します。次にコンボボックス[ユニット]あるいは[サーバ]から対象を選択すると、ステータスファイルの情報がリスト「ステータスファイル管理」に表示されます。

3. 作成を実行する「ステータスファイル名」を選択。

リスト「ステータスファイル管理」から、作成を実行するステータスファイル名を選択します。

なお、リスト「ステータスファイル管理」は複数選択が可能です。

4. 「レコード数」を指定します。

ステータスファイルを作成するHiRDBファイルのレコード数を指定します。

5. HiRDBファイルシステム領域の初期設定を行います。

[HiRDBファイルシステム領域の初期設定]ボタンにより、[HiRDBファイルシステム領域の初期設定/登録]画面を表示できます。

選択したステータスファイルの物理ファイルを作成するHiRDBファイルシステムが存在しない場合は、[HiRDBファイルシステム領域の初期設定]画面から対応するHiRDBファイルシステム領域を作成してください。

<注意事項>

· [HiRDBファイルシステム領域の初期設定]ボタンから表示した[HiRDBファイルシステム領域の初期設定]画面では、作成を実行するステータスファイルの物理ファイルを作成するHiRDBファイルシステム領域の選択のみを行います。ステータスファイルの物理ファイル以外の用途のHiRDBファイルシステム領域は作成できません。

6. 実行

· [実行]ボタンをクリック:

内容を確認し問題がなければ[実行]ボタンをクリックしてください。ステータスファイル作成を実行します。

· [カタログ]ボタンをクリック:

指定した情報でカタログを作成します。

[カタログの登録]画面が表示されますので、エディットボックス「カタログ名」に任意の名前を入力してください。カタログ名は英数字のみ指定可能です。

カタログ名を入力して[OK]ボタンをクリックすると、カタログの作成及び登録を行います。

<注意事項>

·対象の「ユニット」または「サーバ」が停止している状態で、ステータスファイルの作成操作を行うと、作成したステータスファイルはオープンされません。

·対象の「ユニット」または「サーバ」が停止している状態で、ステータスファイルの作成操作を行うためには、対象の「ユニット」または「サーバ」が使用していたステータスファイルすべての物理ファイルがアクセス可能な状態（ファイル内のデータを読み取れない状態）でなければなりません。対象の「ユニット」または「サーバ」のステータスファイルが使用する物理ファイルのうち、1つ以上の物理ファイルがアクセスできない場合は、ステータスファイル作成操作はできません。

· 系切り替え構成を使用している場合：

  影響分散スタンバイレス型系切り替え構成を使用している「サーバ」に対して、HiRDBシステムが停止している場合は、本コマンドを実行することはできません。


[ステータスファイルの削除]

[ステータスファイルの削除]コマンド

ステータスファイルの削除 (pdstsrm) を実行します。

このコマンドを選択すると、[ステータスファイルの削除]画面が表示されます。

<前提条件>

· ステータスファイルが共有ディスクに作成されている場合は、実行前に指定する「ユニット」または「サーバ」のすべてのステータスファイルが存在するすべてのディスクにアクセスが可能であることを確認して実行してください。

すべてのディスクにアクセスが可能でない状態で実行すると、削除に失敗します。

1. 「HiRDBシステム」を指定する。

削除を実行するシステムをコンボボックス「HiRDBシステム」から選択します。

2. ステータスファイルの種別と対象オブジェクトを選択します。

「種別」グループから[ユニット用ステータスファイル]か[サーバ用ステータスファイル]を選択します。次にコンボボックス[ユニット]あるいは[サーバ]から対象を選択すると、ステータスファイルの情報がリスト「ステータスファイル管理」に表示されます。

3. 削除を実行する「ステータスファイル名」を選択。

リスト「ステータスファイル管理」から、削除を実行するステータスファイル名を選択します。

なお、リスト「ステータスファイル管理」は複数選択が可能です。

4. 実行

· [実行]ボタンをクリック:

内容を確認し問題がなければ[実行]ボタンをクリックしてください。ステータスファイルの削除を実行します。

· [カタログ]ボタンをクリック:

指定した情報でカタログを作成します。

[カタログの登録]画面が表示されますので、エディットボックス「カタログ名」に任意の名前を入力してください。カタログ名は英数字のみ指定可能です。

カタログ名を入力して[OK]ボタンをクリックすると、カタログの作成及び登録を行います。

<注意事項>

· A系B系の両方の物理ファイルを削除します。一方の物理ファイルが削除、他方の物理ファイルの削除に失敗した場合は、ステータスファイルが不正な状態になります。そのステータスファイルはオープンせずに、再度ステータスファイルの削除を行ってください。

·対象の「ユニット」または「サーバ」が停止している状態で、ステータスファイルの作成操作を行うと、作成したステータスファイルはオープンされません。

·対象の「ユニット」または「サーバ」が停止している状態で、ステータスファイルの作成操作を行うためには、対象の「ユニット」または「サーバ」が使用していたステータスファイルすべての物理ファイルがアクセス可能な状態（ファイル内のデータを読み取れない状態）でなければなりません。対象の「ユニット」または「サーバ」のステータスファイルが使用する物理ファイルのうち、1つ以上の物理ファイルがアクセスできない場合は、ステータスファイル作成操作はできません。

· 系切り替え構成を使用している場合：

  対象の「ユニット」または、「サーバ」が停止している場合に、ステータスファイルの削除を行うと、削除に失敗しても「削除に成功しました。」メッセージが表示されることがあります。これは、対象となるステータスファイルの物理ファイルにアクセスができない時に発生します。

  影響分散スタンバイレス型系切り替え構成を使用している「サーバ」に対して、HiRDBシステムが停止している場合は、本コマンドを実行することはできません。


[カタログ実行]

[カタログ実行]コマンド

ステータスファイルのカタログを操作するためのカタログリストを表示します。

このコマンドを選択すると、既存のカタログの状態を表示したカタログリストを表示します。ここで、カタログの操作を行います。

このコマンドは自動で最新の状態に更新されません。

最新の情報を表示するには、この[カタログ実行]コマンドを再実行するか、あるいは[F5]キーを押下することで最新の状態へ更新することができます。

1. 任意のカタログを選択。

カタログリストの上段にあるリストボックスに、既存の各カタログの状態が表示されています。ここで任意のカタログ名を選択し、右クリックを行うとポップアップメニューが表示されます。以下で各機能の説明をします。

§ [実行]

選択したカタログを即実行します。

§ [スケジュール]

カタログを実行する日時を指定します。[スケジュール ウィザード]画面が表示されます。指定した対象をダブルクリックすることでも実行できます。

§ [変更]

選択したカタログに登録されている内容を変更します。カタログに登録されている値をデフォルトとした[カスタマイズ]画面が表示されますので、任意の値を指定してください。

<注意事項>

· カタログの変更は既存のスケジュールには反映されません。変更前のカタログを使用したスケジュールが存在する場合は、当該スケジュールを一度削除した後に、再度新しいカタログを使用してスケジュールを登録してください。

§ [削除]

選択したカタログのファイルを削除します。また、[Delete]キーを押下することでも削除ができます。

ここで削除したカタログは再生することができません。


[データメンテナンス]タブ

[データメンテナンス]タブには、以下のようなコマンドがあります。

[データロード]

[再編成]

[ディクショナリ表の再編成]

[カタログ実行]

[空きページ解放]

[データベース状態解析]

[データベース状態解析環境設定]

[自動データメンテナンス]


[データロード]

[データロード]コマンド

データベース作成ユティリティ (pdload) を実行します。

このコマンドを選択すると、データベース作成ユティリティを実行するための画面を表示します。

<注意事項>

· XDM/RDに対する上記の操作は失敗します。

l データベース作成ユティリティ

データベース作成ユティリティ（pdload）は、ユーザが用意したデータを入力し、表へデータを格納を行うユティリティです。データベース作成ユティリティについての詳細は、「HiRDB Version　7 コマンドリファレンス　データベース作成ユティリティ」を参照してください。

1. 対象HiRDBシステムを選択する。

再編成を行うHiRDBシステムを選択します。表マップ、RDエリアマップ等から本画面を呼び出した場合は、表名を選択する必要はありません。

2. 「表識別子」を指定する。

データロードを行う表を指定します。指定方法について、以下で説明します。

（１） データロードを行う表を選択する。

  リストボックス「表名」から対象の表を選択します。表マップ、RDエリアマップ等から本画面を呼び出した場合は、表名を選択する必要はありません。

（２） 「パスワード」を指定する。

  「所有者」で指定されたユーザのパスワードを指定します。

3. データ処理方式を指定する。

表の既存のデータに対する扱いを選択してください。

· 「追加モード」

表の既存のデータを残して、入力データを追加します。

· 「作成モード」

表の既存のデータをすべて削除してから、入力データを格納します。

<注意事項>

· 追加モードでデータロードした場合、追加データは既存のデータの最終格納ページ以降のページに格納されます。このため、クラスタキーを定義した表に対して追加モードでデータロードすると、追加データはクラスタキー順に格納されません。

· 追加モードでデータロードをするときは、必ず未使用ページにデータを格納します。未使用ページを確保できなかった場合にはエラーとなります。既存のデータが格納されている使用中ページに空きがあっても利用しません。ただし、詳細設定で「使用済みページへレコードを格納」指定時には、既存データが格納されている使用中ページを利用します。

· RDエリア単位のデータロードを作成モードで実行した場合、削除される既存の表データは、指定したRDエリア部分だけです。

· データ削除中は、option文にnowait=yesを指定していてもNOWAIT検索はできません。

· 同期点指定のデータロードで異常終了した後の再実行の場合、作成モードを指定しても無視されます。

· 更新凍結状態のRDエリアに格納されているLOB列、又はLOB属性の抽象データ型列がある表に対してデータロードする場合、作成モードを指定するとデータを削除できないためエラーとなります。なお、LOB列構成基表にだけデータロードする場合でも、作成モードを指定するとエラーとなります。

· 改ざん防止表の場合、作成モードのデータロードはできません。

· ＲＤエリアの状態について:

ＲＤエリアの状態は、ユティリティを実行後も実行前のＲＤエリア状態となります。

4. 入力データファイル情報を指定する。

入力データファイルの形式を選択してください。

· 「DAT形式」

入力データファイルがDAT形式の場合に選択します。

なお、このオプションを選択すると「セパレータ文字」が必要です。

また、「列構成情報ファイル名」の指定を場合によって入力します。

§ 「セパレータ文字」

各データ間のセパレータ文字を入力してください。

デフォルトでは<< , (カンマ) >>を使用します。

セパレータ文字としてスペースやパイプ記号 ( | ) を使用する場合は二重引用符 ( " ) で囲んでください。

なお、HiRDB CMではタブを指定できません。

§ 「拡張機能を使用する」

入力データファイルに拡張機能を使用している場合に指定します。

・「囲み文字」

各入力データの列値を囲んでいる囲み文字を指定します。デフォルトは<<"(二重引用符)>>です。

なお、空白、タブ、アスタリスク(*)、および、セパレータと同じ文字は指定できません。

・「小数点データを格納する」

入力データファイル中のINTEGER、および、SMALLINTに対応する列に、小数点を含むデータが記載されていても入力データエラーとせず、整数部のみを表に格納する場合に指定します。

<注意事項>

· 08-01以前のCM Agentでは拡張機能を使用することができません。

· 06-02のHiRDBシステムでは「小数点データを格納する」を指定することができません。

· 「固定長データ形式」

入力データファイルが固定長データ形式の場合に指定します。

なお、このオプションを指定すると「列構成情報ファイル名」の指定が必要です。

§ 「列構成情報ファイル名」

入力データファイルの形式で「DAT形式」あるいは「固定長データ形式」が選択された場合に指定します。

[参照]ボタンをクリックして対象となる列構成情報ファイルのパス名称を指定することもできます。

「固定長データ形式」の場合は、必ず指定してください。

「DAT形式」の場合は、次のような場合に指定します。

- 入力データファイルのデータの列の並び順と、表の列の並び順が異なっているデータを格納する

- 入力データファイルのデータの列数と、表の列数が異なっているデータを格納する

- 入力データファイルのデータを表の列のデータ型に変換して格納する

- 抽象データ型に格納する値を生成するコンストラクタ関数を指定する

- 入力データファイルの繰り返し列の要素数が、表定義時の最大要素数より少ないときに格納する

· 「バイナリ形式」

入力データファイルがバイナリ形式の場合に選択します。

なお、このオプションを選択すると、「ナル値情報ファイル名」を指定することができます。

§ 「ナル値情報ファイル名」

ナル値・関数情報ファイル名を入力します。

[参照]ボタンをクリックして対象となるナル値情報ファイルのパス名称を指定することもできます。

ナル値・関数情報ファイル名は次にような場合に指定します。

- 入力データをナル値とみなす値に変更する

- 抽象データ型列に格納する値を生成するコンストラクタ関数の情報を記述する

§ 「アンロードで取得した入力データファイル」

データベース再編成ユティリティで、データベース作成ユティリティの入力データファイルとして作成したバイナリ形式のファイルを入力データファイルとする場合に指定します。

<注意事項>

· アンロードした表とデータロードする表の間で、列データ型などの表定義が異なる場合はデータロードできません。ただし、非FIX表に限り、列構成情報ファイルを指定することで、列定義順序と列数を変更したデータロードができます。なお、UAPやUOCで入力データファイルの内容を変更する場合、行長、列データオフセット、及び行データの間は、間隔を空けないで詰めた形式で編集する必要があります。

5. 「制御情報ファイル」の指定する。

  データロードの制御文を記述した制御情報ファイルの指定方式を指定します。

· HiRDB CMで自動生成する場合:

  HiRDB　CMで制御情報ファイルを自動作成するための基本情報を入力します。詳細情報は、「データベース作成ユティリティ詳細設定」画面で指定します。

「入力データファイル名」を指定する。

ホスト名を選択し、入力データファイル名を絶対パスで入力してください。

[参照]ボタンをクリックして対象となる入力データファイル名を絶対パスで選択することもできます。

<注意事項>

· 以下のいずれかに該当する場合、「制御情報ファイルの自動生成」は行えません。この場合は、制御文を直接指定してデータロードを行ってください。

   (1) LOB列を含む表に対するデータロード

   (2) UOCを使用するデータロード

   (3) EasyMTを使用したデータロード

   (4) 横分割表に対するRDエリア単位のデータロード

· 制御情報ファイルを直接指定する場合:

管理対象HiRDBの任意のサーバ上にある制御情報ファイルを直接指定します。

なお、制御文についての詳細はマニュアル「HiRDB コマンドリファレンス」を参照してください。

  [参照]ボタンをクリックして対象となる制御文情報ファイルのパス名称を指定することもできます。

6. [詳細]ボタンをクリック。

データベース作成ユティリティの詳細設定画面を開きます。

7．[実行]ボタンをクリック。

データベース作成ユティリティを実行します。

8．[カタログ]ボタンをクリック:指定した情報でカタログを作成します。

このボタンをクリックすると、カタログの情報を入力するための[カタログの登録]画面が表示されます。

§ 「カタログ名」

エディットボックス「カタログ名」に任意の名前を入力してください。カタログ名の入力は((最大64文字))で、英数字のみ指定可能です。

カタログ名を入力して[OK]ボタンをクリックすると、カタログの作成及び登録を行います。

<注意事項>

· 処理実行中に「KFPE11117-E(タイムアウト)」エラーが発生した場合、pdloadの処理は継続して実行されます。

しばらくしてから、処理が正常に終了しているかを確認してください。

l データベース作成ユティリティ　詳細設定

データベース作成ユティリティに対する詳細設定を行います。各タブページで任意の情報を指定してください。

データベース作成ユティリティ - 詳細設定画面の各タブページの設定内容を、以下で説明します。

· [詳細設定１]ページ

· [詳細設定２]ページ

· [インデクス情報ファイル用ディレクトリ]ページ

· [ソート用ワークディレクトリ]ページ

· [データ処理]ページ

「OK」ボタンをクリックすると、各タブページで設定された詳細情報を確定し、「データロード」画面へ戻ります。

「標準に戻す」をクリックすると、全てのタブページの情報がデフォルトの状態に戻ります。

l データベース作成ユティリティ　詳細設定　[詳細設定１]ページ

「詳細設定１」タブページでは以下の情報を設定します。

1. 入力開始行

入力データファイルの１行目からデータを入力しないで、指定した行からデータを入力する場合に指定します。

指定できる値は((1～4294967295))です。初期値は、<<1>>です。

2. 入力データ長

入力データファイルがDAT形式、拡張DAT形式、バイナリ形式、及びデータべデース再編成ユティリティで生成したバイナリ形式の場合に指定できます。

指定できる値は((0,32～524288))です。初期値は、<<32>>です。

3. 入力不正時に処理を中断

入力データの不正を検出した場合に、処理を中断するときにチェックします。チェックしない場合は、入力データの不正を検出しても処理を続行します。

4. クラスタキーの昇順/降順チェック

表にクラスタキーが定義してある場合、入力データがクラスタキーの昇順又は降順になっているかどうかをチェックしないで、入力順にデータロードする場合にチェックボックスをチェックします。チェックボックスをチェックしない場合は、クラスタキー順のチェックをして、クラスタキー順でない入力データはエラーとなります。

5. 長さ０のデータを格納する

可変長文字列、可変長各国文字列、及び可変長混在文字列に対して、長さ0のデータを格納する場合にチェックボックスをチェックします。

6. 使用済みページへレコード格納

データロード時、未使用ページを使い切った場合に、使用中ページの未使用領域へデータを格納したいときにチェックします。チェックしない場合は、未使用領域にデータを格納する前にKFPH26010-Iメッセージを出力します。

7. 経過メッセージ出力間隔

処理の実行状況を出力するメッセージの出力間隔を、1万行単位で指定します。

指定できる値は((1～1000))万行です。初期値は<<10>>万行です。

8. インデクス作成方法を指定する。

インデクスの作成方法を指定します。インデクスの作成方法には次の四つがあります。

· 「一括作成モード」

表の作成処理に引き続き、インデクスを一括作成します。行データの格納中はインデクスを作成しないで、インデクス作成情報をインデクス情報ファイルに出力します。行データの格納処理が完了した後、引き続きインデクスを作成します。

· 「インデクス情報ファイルの自動削除」

インデクス一括作成が正常終了した後、index文に指定したインデクス情報ファイルを自動的に削除する場合に指定します。

インデクス情報ファイルを削除しないでおくと、ディスク容量を圧迫することになります。このインデクス情報ファイルの削除し忘れに備え、インデクス一括作成終了後に自動的にインデクス情報ファイルを削除する場合に指定します。

· 「更新モード」

行を格納するたびにインデクスを更新します。

· 「インデクス情報出力モード」

インデクス情報だけをインデクス情報ファイルに出力します。行データの格納中はインデクスを作成しないで、インデクス作成情報をインデクス情報ファイルに出力します。

· 「インデクス情報出力抑止モード」

インデクスは更新しません。また、インデクス情報をインデクス情報ファイルに出力しません。

9. ログの取得モードを指定する。

データベースの更新ログの取得方法を指定します。

· 「更新前ログ取得モード」

ロールバックに必要なデータベースの更新ログは取得しますが、ロールフォワードに必要なデータベースの更新ログは取得しません。

· 「ログ取得モード」

ロールバック及びロールフォワードに必要なデータベースの更新ログを取得します。

· 「ログレスモード」

データベースの更新ログを取得しません。

10. 「表の一括出力」を指定する。

ローカルバッファを使用するときに指定します。このオプションを指定すると、ローカルバッファを使用してDBアクセスができるようになり、一括出力によって入出力回数が削減できます。

このオプションを省略した場合は、グローバルバッファを使用して1ページ単位に出力をします。

· 「一括出力用ローカルバッファ面数」

一括出力用ローカルバッファは、データページに対して使用します。

一括出力用ローカルバッファ面数には、16～32面を指定することをお勧めします。64キロバイト÷ページ長が目安です。

· 「divの指定」

次の条件をすべて満たす場合にdivを指定してください。次の条件をすべて満たす場合にdivを指定しないと、入出力回数が増加し、性能が劣化することがあります。

横分割表に対して、表単位にデータロードをする

ハッシュ関数（HASH1～HASH6）を使用した横分割表に対してデータロードをする、又はキーレンジ分割の表に格納する入力データのキー値の順序がランダムになっている

表を格納するRDエリアが1サーバ内に複数ある

なお、divを指定すると、サーバ内表分割数分のバッファを確保するため、メモリ消費量が増えます。

· 「ランダムアクセス用ローカルバッファ面数」

ランダムアクセス用ローカルバッファは、インデクスページに対して使用します。

l データベース作成ユティリティ　詳細設定　[詳細設定２]ページ

「詳細設定２」タブページでは以下の情報を設定します。

1. 表にLOB列がある。

データロード行う表にLOB列がある場合に指定してください。

· 「LOB入力ファイル」

LOBデータごとにファイルを用意する場合に指定してください。

· 「列単位LOB入力ファイル」

一つのLOB列にある複数のLOBデータを、一つのファイルに用意する場合に指定してください。

· 「LOBパラメータのみ入力ファイルに直接記述」

LOB列への格納データは格納するLOBデータごとにLOB入力ファイルを用意し、抽象データ型列に格納する値を生成するコンストラクタ関数の入力パラメタとなるデータ（LOBパラメタ）は入力データファイルに格納する場合に指定してください。

この指定は、入力データファイルがバイナリ形式の場合だけに指定してください。

· 「入力データファイルに直接記述」

LOBデータ、及び抽象データ型列のLOBパラメタデータを、入力データファイルに直接記述する場合に指定して下さい。

この指定は、入力データファイルがバイナリ形式の場合だけに指定してください。

2. EasyMTの使用

入力データがEasyMTにある場合にチェックボックスをチェックします。

3. 世代番号の指定

インナレプリカ機能を使用している場合、データロード対象となるRDエリアの世代番号を指定します。

4. チューニング情報出力の指定

データベース作成ユティリティ実行時の、チューニング情報を出力するファイルを絶対パス名で入力します。

  [参照]ボタンをクリックして対象となるファイル名を絶対パスで指定することもできます。

<注意事項>

· 制御情報ファイルを自動生成する場合のみ指定できます。

l データベース作成ユティリティ　詳細設定　[インデクス情報ファイル用ディレクトリ]ページ

「インデクス情報ファイル用ディレクトリ」タブページでは、インデクス情報に関連する指定を行います。

<注意事項>

· 制御情報ファイルを自動生成する場合のみ指定できます。

1. インデクス情報ファイル用ディレクトリを指定

サーバ名を選択し、インデクス情報ファイル用ディレクトリを絶対パスで入力します。

  [参照]ボタンをクリックして対象となるインデクス情報ファイル用ディレクトリを絶対パスで指定することもできます。

↓ボタンを押すことで選択を決定します。

  決定したインデクス情報ファイル用ディレクトリは「インデクス情報ファイル用ディレクトリ一覧」に表示されます。「インデクス情報ファイル用ディレクトリ一覧」からサーバ名を選択し↑ボタンを押すことで、インデクス情報ファイル用ディレクトリ名の修正が行えます。

l データベース作成ユティリティ　詳細設定　[ソート用ワークディレクトリ]ページ

「ソート用ワークディレクトリ」タブページでは、インデクスを作成するときに使用するソート用ワークファイルの情報に関連する指定を行います。

<注意事項>

· 制御情報ファイルを自動生成する場合のみ指定できます。

1. ソート用ワークファイル作成ディレクトリ名を指定

サーバ名を選択し、ソート用バッファサイズ、ソート用ワークファイル作成ディレクトリを絶対パスで入力します。

  [参照]ボタンをクリックして対象となるソート用ワークファイル作成ディレクトリを絶対パスで指定することもできます。

  「ソート用バッファサイズ」に指定できる値は、<<128～2097152>>KBです。初期値は<<10240>>KBです。

↓ボタンを押すことで選択を決定します。

  決定したソート用ワークファイル作成ディレクトリはソート用ワークファイル作成ディレクトリ一覧」に表示されます。「ソート用ワークファイル作成ディレクトリ一覧」からサーバ名を選択し↑ボタンを押すことで、ソート用ワークファイル作成ディレクトリの修正が行えます。

l データベース作成ユティリティ　詳細設定　[データ処理]ページ

「データ処理」タブページでは、データロードのオプション機能に関連する指定を行います。

<注意事項>

· 制御情報ファイルを自動生成する場合のみ指定できます。

1. 表の空き領域比率の変更

  データロードのときに、CREATE TABLEで指定した空き領域比率（PCTFREEの指定値）を変更してデータを格納したい場合に指定します。

次のような場合に指定します。

  定義時に空き領域比率に0以外を指定した表の場合、データロード中に定義時の空き領域比率が適用されたことによって、データ格納時にRDエリアの容量不足が発生することがあります。このような場合に指定すると、暫定的にRDエリアを拡張しないで、データロードを完了できます。

· 「未使用領域比率」

指定できる値は((0～99))％です。初期値は<<30>>％です。

· 「セグメント内空きページ比率」

指定できる値は((0～50))％です。初期値は<<10>>％です。

2. インデクス未使用領域比率の変更

インデクスを作成する場合に、CREATE INDEXで指定した空き領域比率（PCTFREEの指定値）を変更してインデクスを作成したいときに指定します。

指定できる値は、((0～99))％です。初期値は<<30>>％です。

3. 実行監視時間の指定

データロードの実行時間を監視する場合に、その監視時間を分単位で指定します。省略した場合は、実行時間の監視はしません。

指定できる値は((0～357913940)分です。

4. 入力データ空白変換の指定

データロードをするときに、データの空白変換処理方針を指定します。

· 「変換する」

データの空白変換をします。

表データ中の空白文字を統一したい場合に指定します。

表データ中の空白文字を統一する方法については、マニュアル「HiRDB Version 7 システム運用ガイド」を参照してください。

· 「変換しない」

データの空白変換をしません。

5. データ切り捨て警告メッセージ出力の有無

DAT形式の入力データファイルのデータロード時に、次のデータ型の列に対して文字データを格納する場合、入力データのデータ長が表の列定義長より長いときは、表の列定義長以上のデータ部分は切り捨てられます。

文字データ型（CHAR、VARCHAR）

各国文字データ型（NCHAR、NVARCHAR）

混在文字データ型（MCHAR、MVARCHAR）

BINARY型

この切り捨てが発生したときに、エラー情報ファイルに警告メッセージ（KFPL31090-W）を出力するかどうかを指定します。

· 「出力する」

警告メッセージを出力します。

· 「出力しない」

警告メッセージを出力しません。

6. 同期点の指定

同期点指定のデータロードをする場合に指定します。

· 「ジョブ名」

同期点指定の再編成、又は同期点指定のリロードを実行する場合のジョブ名を指定します。

· 「同期点行数」

何万件格納するごとにトランザクションを決着するか、データ件数を指定します。

指定できる値は((1～1000)万件です。初期値は<<100>>万件です。

· 「同期点情報をクリアする」

データロードの再実行が必要ない場合、又は現在データベース中にある同期点情報をクリアして再度、データロードを実行する場合に指定します。

7. 入力データエラー時にロールバックをする

入力データエラー（論理エラー）を検知した場合、データ格納処理を無効（ロールバック）にするときに指定します。

8. 列定義長より長いデータを入力データエラーとする

DAT形式（拡張DAT形式を含む）の入力データファイルの、次のデータ型の列に格納する入力データ長が列定義長より長い場合、入力データエラーとして扱うときに指定します。

CHAR

VARCHAR

NCHAR

NVARCHAR

MCHAR

MVARCHAR

BINARY

9. NOWAIT検索の実行

データロード中の表に対して、NOWAIT検索をするかどうかを指定します。NOWAIT検索とは、排他オプションにNOWAITを指定して検索するSQLのことをいいます。

· 「実行する」

NOWAIT検索を実行する場合に指定します。

· 「実行しない」

NOWAIT検索を実行しない場合に指定します。

10. ナル値のDEFAULT句定義値変換

DEFAULT句を指定している表に対してデータロードする場合、入力データがナル値（"*"又は記述しない場合）のときに、DEFAULT句の既定値を格納するか、又はナル値を格納するかを指定します。

· 「変換する」

DEFAULT句の既定値を格納します。

· 「変換しない」

ナル値を格納します。


[再編成]

[再編成]コマンド

表に対するデータベース再編成ユティリティ (pdrorg) を実行します。

このコマンドを選択すると、データベース再編成ユティリティを実行するための画面を表示します。

<注意事項>

· XDM/RDに対する上記の操作は失敗します。

l データベース再編成ユティリティ

データベース再編成ユティリティ（pdrorg）は、表、及びインデクスのメンテナンスをするユティリティです。データベース再編成ユティリティについての詳細は、「HiRDB Version　7 コマンドリファレンス　データベース再編成ユティリティ」を参照してください。

1. 対象HiRDBシステムを選択する。

再編成を行うHiRDBシステムを選択します。表マップ、RDエリアマップ等から本画面を呼び出した場合は、表名を選択する必要はありません。

2. 「表識別子」を指定する。

再編成を行う表/インデクスを指定します。指定方法について、以下で説明します。

表種別指定

再編成対象種別 | 指定方法
ユーザ表 | (1) 再編成を行う表を選択する。 リストボックス「表名」から対象の表を選択します。表マップ、RDエリアマップ等から本画面を呼び出した場合は、表名を選択する必要はありません。 (2) 「パスワード」を指定する。 「所有者」で指定されたユーザのパスワードを指定します。
ユーザインデクス | (1) 再編成を行うインデクスが存在する表を選択する。 リストボックス「表名」から対象の表を選択します。表マップ、RDエリアマップ等から本画面を呼び出した場合は、表名を選択する必要はありません。 (2) 「パスワード」を指定する。 「所有者」で指定されたユーザのパスワードを指定します。
ディクショナリ表 | (1) 再編成を行う表を指定します。 全てのディクショナリ表に対して再編成を行う場合、「全てのディクショナリ表」を選択してください。表名を指定する場合は、対象となる表を選択してください。

3. 「処理方針」を選択する。

表/インデクスに対して行う処理を選択してください。

· 「表のアンロード&リロード」

表の再編成をする場合に指定します。

· 「表のアンロード」

表のアンロードをする場合に指定します。

· 「表のリロード」

表へリロードする場合に指定します。

· 「インデクスの再編成」

インデクスの再編成をする場合に指定します。

· 「インデクスの一括作成」

インデクスの一括作成をする場合に指定します。

· 「インデクスの再作成」

インデクスの再作成をする場合に指定します。

4. 「制御情報ファイル」を指定する。

  データベース再編成ユティリティの制御文を記述した制御情報ファイルの指定方式を指定します。

· HiRDB CMで自動生成する場合:

  HiRDB　CMで制御情報ファイルを自動作成するための基本情報を入力します。詳細情報は、「データベース再編成ユティリティ詳細設定」画面で指定します。処理対象ごとの指定方法を以下に示します。

制御情報ファイルの基本情報指定方法

処理対象 | 指定方法
表のアンロード&リロード | アンロードデータファイルを指定する。 サーバ名を選択し、アンロードデータファイル名を絶対パスで入力します。 [参照]ボタンをクリックして対象となるアンロードデータファイル名を絶対パスで指定することもできます。 ↓ボタンを押すことで選択を決定します。 決定したアンロードデータファイルは「アンロードデータファイル一覧」に表示されます。「アンロードデータファイル一覧」からサーバ名を選択し↑ボタンを押すことで、アンロードデータファイル名の修正が行えます。
表のアンロード
表のリロード
インデクスの再編成 | インデクス名を選択する。 再編成の対象となるインデクス名をリストから選択します。インデクス名は複数選択することができます。また、「全てのインデクス」を選択することで表に関連する全てのインデクスの再編成、再作成が行えます。
インデクスの再作成
インデクスの一括作成 | 「インデクスの一括作成」に対する制御情報ファイルの自動生成は行えません。

<注意事項>

· 以下のいずれかに該当する場合、「制御情報ファイルの自動生成」は行えません。この場合は、制御文を直接指定して再編成を行ってください。

   (1) 「処理方針」に「インデクスの一括作成」を選択した場合

· 制御情報ファイルを直接指定する場合:

管理対象HiRDBのマネジャノード上にある制御情報ファイルを直接指定します。指定方法を以下に示します。

(1)｢制御文ファイルを指定する｣を選択してください。

(2)制御情報ファイル名を指定します。

[参照]ボタンをクリックして対象となる制御情報ファイル名を絶対パスで指定することもできます。

なお、制御情報ファイルについての詳細はマニュアル「HiRDB コマンドリファレンス」を参照してください。

5. [詳細]ボタンをクリック。

データベース再編成ユティリティの詳細設定画面を開きます。

6．[実行]ボタンをクリック。

データベース再編成ユティリティを実行します。

7．[カタログ]ボタンをクリック:指定した情報でカタログを作成します。

このボタンをクリックすると、カタログの情報を入力するための[カタログの登録]画面が表示されます。

§ 「カタログ名」

エディットボックス「カタログ名」に任意の名前を入力してください。カタログ名の入力は((最大64文字))で、英数字のみ指定可能です。

カタログ名を入力して[OK]ボタンをクリックすると、カタログの作成及び登録を行います。

<注意事項>

· 処理実行中に「KFPE11117-E(タイムアウト)」エラーが発生した場合、pdrorgの処理は継続して実行されます。

しばらくしてから、処理が正常に終了しているかを確認してください。

· ＲＤエリアの状態について:

ＲＤエリアの状態は、ユティリティを実行後も実行前のＲＤエリア状態となります。

l データベース再編成ユティリティ　詳細設定

データベース再編成ユティリティに対する詳細設定を行います。各タブページで任意の情報を指定してください。

データベース再編成ユティリティ - 詳細設定画面の各タブページの設定内容を、以下で説明します。

· [詳細設定１]ページ

· [詳細設定２]ページ

· [インデクス情報ファイル用ディレクトリ]ページ

· [ソート用ワークディレクトリ]ページ

· [データ処理]ページ

「OK」ボタンをクリックすると、各タブページで設定された詳細情報を確定し、「データベース再編成ユティリティ」画面へ戻ります。

「標準に戻す」をクリックすると、全てのタブページの情報がデフォルトの状態に戻ります。

l データベース再編成ユティリティ　詳細設定　[詳細設定１]ページ

「詳細設定１」タブページでは以下の情報を設定します。

1. ログの取得モードを指定する。

データベースの更新ログの取得方法を指定します。

· 「更新前ログ取得モード」

ロールバックに必要なデータベースの更新ログは取得しますが、ロールフォワードに必要なデータベースの更新ログは取得しません。

· 「ログ取得モード」

ロールバック及びロールフォワードに必要なデータベースの更新ログを取得します。

· 「ログレスモード」

データベースの更新ログを取得しません。

2. インデクス作成方法を指定する。

インデクスの作成方法を指定します。インデクスの作成方法には次の三つがあります。

· 「一括作成モード」

表へのリロード処理に引き続き、インデクスを一括作成します。

· 「更新モード」

行を格納するたびにインデクスを更新します。

· 「インデクス情報出力モード」

インデクス情報だけをインデクス情報ファイルに出力します。

3. 出力データ形式。

表のデータを、DAT形式、拡張DAT形式、またはバイナリ形式でアンロードデータファイルに出力します。

· 「DAT形式」

DAT形式でデータを出力する場合に指定します。

· 「拡張DAT形式」

拡張DAT形式でデータを出力する場合に指定します。

§ 「セパレータ文字」

各データ間のセパレータ文字を入力してください。

デフォルトでは<< , (カンマ) >>を使用します。

セパレータ文字としてスペースやパイプ記号 ( | ) を使用する場合は、二重引用符 ( " ) で囲まないでください。詳しくはマニュアル「HiRDB コマンドリファレンス」を参照してください。

なお、HiRDB CMではタブを指定できません。

§ 「改行コード」

データ改行コードとして「CR」「CRLF」のいずれかを指定してください。

cr：0x0aで改行コードを出力します。

crlf：0x0d、0x0aで改行コードを出力します。

§ 「空白の出力なし」

CHAR、NCHAR、MCHAR型の列データをDAT形式でアンロードする場合に、列データの後方に連続する空白を出力しないときに指定してください。

CHAR、MCHAR型の場合、表定義の列長に満たない部分の半角空白を圧縮します。列データがすべて空白の場合は、半角空白を1バイト出力します。NCHARの場合、表定義の列長に満たない部分の2バイトの空白を圧縮します。

列データがすべて空白の場合は、2バイトの空白を1文字出力します。2バイトの空白は使用する文字コードによって異なります。文字コードについては、マニュアル「HiRDB SQLリファレンス」を参照してください。

· 「バイナリ形式」

バイナリ形式のデータを出力する場合に指定します。

<注意事項>

· アンロードデータファイルを、データベース作成ユティリティの入力データファイルとして使用する場合、又はUAPなどで使用する場合に指定します。

· 「空白の出力なし」を指定した場合の出力形式については、「HIRDB コマンドリファレンス　データベース作成ユティリティの入力用ファイルの形式」を参照してください。

· 表の1行の定義長は512MB以下でなければDAT形式に出力できません。行の定義長が512MBを超える表の場合はバイナリ形式を採用してください。

· 対象の表が改ざん防止表の場合、 「出力データ形式」の指定をしない「表のアンロード」は実行できません。

· 08-01以前のCM Agentでは「拡張DAT形式」を指定できません。

· 07-01以前のHiRDBシステムでは「拡張DAT形式」を指定できません。

4. アンロード指定

アンロードするデータの順番を指定します。指定してください。

· 「クラスタ順」

クラスタキー順にアンロードする場合に指定します。

· 「データ格納順」

表のデータの格納順にアンロードする場合に指定します。

· 「インデクス順」

インデクス順にアンロードする場合に指定します。

descを指定すると、インデクスの降順にアンロードできます。なお、descは、単一列インデクスの場合にだけ指定できます。

· 「主キー順」

主キー順にアンロードする場合に指定します。

§ 「アンロード順序」

アンロード順序として「昇順」「降順」のいずれかを選択してください。

5. RDエリアの指定

複数のRDエリアに分割格納した横分割表の場合、特定のRDエリアの部分だけ再編成するときに、対象となるRDエリアの名称を選択してください。

l データベース再編成ユティリティ　詳細設定　[詳細設定２]ページ

「詳細設定２」タブページでは以下の情報を設定します。

1. 「ローカルバッファの使用」を指定する。

アンロード処理でのDBからの読み込み、及びリロード処理でのDBへの書き込みをする場合に、ローカルバッファを使用するときに指定します。このオプションを指定すると、ローカルバッファを使用してDBアクセスができるようになり、一括入出力によって入出力回数を削減できます。

· 「一括出力用ローカルバッファ面数」

一括出力用ローカルバッファは、データページに対して使用します。

バッファ面数を((2～4096))の範囲で指定してください。初期値は<<16>>面です。

· 「divの指定」

次の条件をすべて満たす場合にdivを指定してください。次の条件をすべて満たす場合にdivを指定しないと、入出力回数が増加し、性能が劣化することがあります。

・アンロード時の分割条件と、リロード時の分割条件が異なる

・表格納用RDエリアが1サーバ内に複数ある

なお、divを指定すると、サーバ内表分割数分のバッファを確保するため、メモリ消費量が増えます。

· 「ランダムアクセス用ローカルバッファ面数」

ランダムアクセス用ローカルバッファは、インデクスページに対して使用します。

2. データファイル種別

アンロードデータファイル、又はLOBデータのアンロードファイルの種別を指定します。

· 「HiRDBファイル」

アンロードデータファイル、又はLOBデータのアンロードファイルとしてHiRDBファイルを使用する場合に指定します。

· 「EasyMT」

アンロードデータファイル、またはLOBデータのアンロードファイルとしてEasyMTを使用する場合に指定します。

3. データファイルを1サーバ上に保存

複数のサーバに格納されている表データを、1サーバの1アンロードデータファイルにアンロードする場合に指定ください。

LOB列がある表の場合も、一つのLOBデータのアンロードファイルへアンロードできます。

4. 後方の空白を抑止

CHAR、NCHAR、又はMCHAR型の列にサプレスオプションを指定している表を再編成する場合に、列データの後方に連続する空白があるとき、その空白を取り除いてアンロードするときに指定します。

5. インデクス情報ファイル削除

インデクス作成処理が正常終了した後に、インデクス情報ファイルを自動的に削除する場合に指定します。

6. LOB列あり

LOB属性を持つ抽象データ型が定義された表をアンロードする場合、又はLOB格納RDエリアの詰め換えをする場合に指定します。

7. 経過メッセージ出力間隔

処理の実行状況を出力するメッセージの出力間隔を、1万行単位で指定します。

指定できる値は((1～1000))万行です。初期値は<<10>>万行です。

8. 世代番号の指定

インナレプリカ機能を使用している場合、再編成対象となるRDエリアの世代番号を指定します。

9. チューニング情報出力の指定

再編成ユティリティ実行時の、チューニング情報を出力するファイルを絶対パス名で入力します。

  [参照]ボタンをクリックして対象となるファイル名を絶対パスで指定することもできます。

<注意事項>

· 制御情報ファイルを自動生成する場合のみ指定できます。

l データベース再編成ユティリティ　詳細設定　[インデクス情報ファイル用ディレクトリ]ページ

「インデクス情報ファイル用ディレクトリ」タブページでは、インデクス情報に関連する指定を行います。

<注意事項>

· 制御情報ファイルを自動生成する場合のみ指定できます。

1. インデクス情報ファイル用ディレクトリを指定

サーバ名を選択し、インデクス情報ファイル用ディレクトリを絶対パスで入力します。

  [参照]ボタンをクリックして対象となるインデクス情報ファイル用ディレクトリを絶対パスで指定することもできます。

↓ボタンを押すことで選択を決定します。

  決定したインデクス情報ファイル用ディレクトリは「インデクス情報ファイル用ディレクトリ一覧」に表示されます。「インデクス情報ファイル用ディレクトリ一覧」からサーバ名を選択し↑ボタンを押すことで、インデクス情報ファイル用ディレクトリ名の修正が行えます。

l データベース再編成ユティリティ　詳細設定　[ソート用ワークディレクトリ]ページ

「ソート用ワークディレクトリ」タブページでは、インデクスを作成するときに使用するソート用ワークファイルの情報に関連する指定を行います。

<注意事項>

· 制御情報ファイルを自動生成する場合のみ指定できます。

1. ソート用ワークファイル作成ディレクトリ名を指定

サーバ名を選択し、ソート用バッファサイズ、ソート用ワークファイル作成ディレクトリを絶対パスで入力します。

  [参照]ボタンをクリックして対象となるソート用ワークファイル作成ディレクトリを絶対パスで指定することもできます。

  「ソート用バッファサイズ」に指定できる値は、<<128～2097152>>KBです。初期値は<<10240>>KBです。

↓ボタンを押すことで選択を決定します。

  決定したソート用ワークファイル作成ディレクトリはソート用ワークファイル作成ディレクトリ一覧」に表示されます。「ソート用ワークファイル作成ディレクトリ一覧」からサーバ名を選択し↑ボタンを押すことで、ソート用ワークファイル作成ディレクトリの修正が行えます。

l データベース再編成ユティリティ　詳細設定　[データ処理]ページ

「データ処理」タブページでは、再編成のオプション機能に関連する指定を行います。

<注意事項>

· 制御情報ファイルを自動生成する場合のみ指定できます。

1. アンロードデータの空白変換の指定

再編成するときに、データの空白変換処理方針を指定します。

· 「変換しない」

データの空白変換をしません。

· 「リロード時に空白変換する」

リロード時にアンロードデータの空白変換をします。

次のような場合に指定します。

  既存データの空白文字を統一したい場合

  別システムに表データを移行する場合に、移行先システムで空白文字を統一したいとき

· 「アンロード時に空白変換する」

リロード時にアンロードデータの空白変換をして、更に「出力データ形式」指定のアンロード時にアンロードデータの空白変換をします。

次のような場合に指定します。

「出力データ形式」指定で出力したアンロードデータをUAPなどで使用する場合に、そのアンロードデータの空白文字を統一したいとき

2. 表の空き領域比率の変更

リロードのときに、CREATE TABLEで指定した空き領域比率（PCTFREEの指定値）を変更してデータを格納したい場合に指定します。

次のような場合に指定します。

  表定義時に空き領域比率に0以外を指定した表の場合、この表の運用中に空き領域がなくなったとします。

この場合、満杯状態になったRDエリアの表に対してpdrorgを実行したときは、定義時の空き領域比率が適用されて、データベース再編成ユティリティ実行時にRDエリアの容量不足が発生することがあります。その場合に、暫定的にRDエリアを拡張しないで、データベース再編成ユティリティの処理を完了できます。

· 「未使用領域比率」

指定できる値は((0～99))％です。初期値は<<30>>％です。

· 「セグメント内空きページ比率」

指定できる値は((0～50))％です。初期値は<<10>>％です。

3. インデクス未使用領域比率の変更

インデクスを作成する場合に、CREATE INDEXで指定した空き領域比率（PCTFREEの指定値）を変更してインデクスを作成したいときに指定します。

指定できる値は((0～99))％です。初期値は<<30>>％です。

4. 再編成の再実行時に表のステータスを通常に戻す

表の再編成の再実行時に、強制的に表のステータスモードを通常状態にする場合に指定します。この場合、表の再編成処理は再開始しません。

次のような場合に指定します。

  データ未完状態となったRDエリア（表）をSQLで参照したい場合など、強制的に表のステータスモードを通常状態に戻すときに指定します。

5. 同期点の指定

同期点指定の再編成、又は同期点指定のリロードをする場合に指定します。

· 「ジョブ名」

同期点指定の再編成、又は同期点指定のリロードを実行する場合のジョブ名を指定します。

· 「同期点行数」

何万件格納するごとにトランザクションを決着するか、データ件数を指定します。

指定できる値は((1～1000))万件です。初期値は<<100>>万件です。

· 「同期点情報をクリアする」

データベース再編成ユティリティの再実行が必要ない場合、又は現在データベース中にある同期点情報をクリアして再度、データベース再編成ユティリティを実行する場合に指定します。

<注意事項>

· 対象の表が改ざん防止表の場合、「同期点指定」を指定した「表のアンロード＆リロード」は実行できません。

6. 実行監視時間の指定

データベース再編成ユティリティの実行時間を監視する場合に、その監視時間を分単位で指定します。省略した場合は、実行時間の監視はしません。

指定できる値は((0～35791394))分です。


[ディクショナリ表の再編成]

[ディクショナリ表の再編成]コマンド

ディクショナリ表に対するデータベース再編成ユティリティ (pdrorg) を実行します。

このコマンドを選択すると、「全てのディクショナリ表」または指定したディクショナリ表に対してデータベース再編成ユティリティを実行するための画面を表示します。

<注意事項>

· XDM/RDに対する上記の操作は失敗します。

l データベース再編成ユティリティ

[データベース再編成ユティリティの実行]画面の操作方法は、[再編成]を参照してください。


[カタログ実行]

[カタログ実行]コマンド

データメンテナンスのカタログを操作するためのカタログリストを表示します。

このコマンドを選択すると、既存のカタログの状態を表示したカタログリストを表示します。ここで、カタログの操作を行います。

このコマンドは自動で最新の状態に更新されません。

最新の情報を表示するには、この[カタログ実行]コマンドを再実行するか、あるいは[F5]キーを押下することで最新の状態へ更新することができます。

1. 任意のカタログを選択。

カタログリストの上段にあるリストボックスに、既存の各カタログの状態が表示されます。ここで任意のカタログ名を選択し、右クリックを行うとポップアップメニューが表示されます。以下で各機能の説明をします。

§ [実行]

選択したカタログを即実行します。

§ [スケジュール]

カタログを実行する日時を指定します。[スケジュール ウィザード]画面が表示されます。指定した対象をダブルクリックすることでも実行できます。

§ [変更]

選択したカタログに登録されている内容を変更します。カタログに登録されている値をデフォルトとした[カスタマイズ]画面が表示されますので、任意の値を指定してください。

<注意事項>

· カタログの変更は既存のスケジュールには反映されません。変更前のカタログを使用したスケジュールが存在する場合は、当該スケジュールを一度削除した後に、再度新しいカタログを使用してスケジュールを登録してください。

§ [削除]

選択したカタログのファイルを削除します。また、[Delete]キーを押下することでも削除ができます。

ここで削除したカタログは再生することができません。


[空きページ解放]

[空きページ解放]コマンド

空きページ解放ユティリティ (pdreclaim) を実行します。

このコマンドを選択すると、空きページ解放ユティリティを実行するための画面を表示します。

<注意事項>

· XDM/RDに対する上記の操作は失敗します。

· 06-02のHiRDBシステムに対して空きページ解放コマンドを実行することはできません。

l 空きページ解放ユティリティ

空きページ解放ユティリティ（pdreclaim）は，オンラインサービス中に，pdrorgでの再編成処理の一部である使用中空きページの解放ができます。空きページ解放ユティリティについての詳細は、「HiRDB Version　7 コマンドリファレンス　空きページ解放ユティリティ」を参照してください。

1. 「HiRDBシステム」を選択。

空きページ解放を実行するHiRDBシステムを選択してください。

2. 「処理対象種別」を選択。

空きページ解放を行う処理種別を次の中から選択してください。

· 「表」

表単位の空きページ解放をする場合に選択します。

· 「インデクス」

インデクス単位の空きページ解放をする場合に選択します。

· 「ディクショナリインデクス」

ディクショナリ表のインデクスの空きページ解放をする場合に選択します。

· 「ディクショナリ表」

ディクショナリ表の空きページ解放をする場合に選択します。

3. 「処理対象」を選択。

空きページ解放を行う対象を選択してください。

· 「認可識別子」を選択

対象とする表作成ユーザ（認可識別子）を選択してください。

· 「表名」を選択

選択された「認可識別子」で作成した表一覧が表示されます。対象とする表名を選択してください。

· 「インデクス名」を選択

選択された「表」に関連するインデクス一覧が表示されます。対象とするインデクス名を選択してください。

4. [処理範囲指定]を選択してください。

空きページ解放を行う対象物に対して、一部のサーバまたは一部のRDエリアのみを対象とする場合に指定します。

· 「サーバ」を選択

対象とする表またはインデクスが複数のサーバで構成され、一部のサーバについてのみ空きページ解放を行う場合に、実行するサーバを選択してください。

· 「RDエリア」を選択

対象とする表またはインデクスが複数のRDエリアで構成され、一部のRDエリアについてのみ空きページ解放を行う場合に、実行するRDエリアを選択してください。

5. [詳細設定]項目を指定。

空きページ解放ユティリティ実行時に次の詳細設定項目が指定できます。

· 「コミット間隔の指定」

使用中空きページ解放処理のトランザクション決着間隔を，解放したページ数で指定します。

· 「同時実行トランザクション決着待ち時間」

インデクスの使用中空きページ解放中に，同時にアクセスしているUAPのトランザクションがある場合，UAPのトランザクションが決着するまでpdreclaimは待ち状態になります。このpdreclaimの待ち時間を秒単位で指定します。

· 「使用中空きセグメントを解放する」

使用中セグメント内のページがすべて未使用ページとなる使用中空きセグメントがある場合，それを解放する（未使用セグメントにする）ときに指定します。

· 「ページコンパクションをしない場合」

表の使用中空きページ解放だけをして，ページコンパクションをしない場合に指定します。

· 「処理監視時間の指定」

pdreclaimの実行時間を監視する場合に，その監視時間を分単位で指定します。

· 「世代番号の指定」

インナレプリカ機能を使用している場合，データロード対象となるRDエリアの世代番号を指定します。

6. [カタログ]ボタンをクリック:指定した情報でカタログを作成します。

このボタンをクリックすると、カタログの情報を入力するための[カタログの登録]画面が表示されます。

§ 「カタログ名」

エディットボックス「カタログ名」に任意の名前を入力してください。カタログ名の入力は((最大64文字))で、英数字のみ指定可能です。

カタログ名を入力して[OK]ボタンをクリックすると、カタログの作成及び登録を行います。

7. [実行]ボタンをクリック。

空きページ解放ユティリティを実行します。


[データベース状態解析]

[データベース状態解析]コマンド

データベース状態解析ユティリティ (pddbst) を実行して、表/インデクスが使用中のセグメントについて、セグメント内全ページの使用率を表示します。[解説編] > [データベース状態解析]でより詳しい説明をしています。

このコマンドを選択すると、データベース状態解析ユティリティを実行するための画面を表示します。

<注意事項>

· データベース状態解析コマンドを実行して、データベースの状態解析が行えるのは次の管理HiRDBシステムです。

HiRDB/Single Server Version 7 07-01以降または、 HiRDB/Parallel Server Version 7 07-01以降

· データベース状態解析を実行する場合は、事前に[データベース状態解析環境設定]を行う必要があります。

· インナレプリカ機能を使用している表・インデクスの状態解析を行った場合は、カレントRDエリアが対象となります。

l データベース状態解析

データベース状態解析は、オンラインサービス中に，データベース状態解析ユティリティを使用して、対象とする表またはインデクスの使用ページに関する使用率をグラフとして表示します。

1. 「HiRDBシステム」を選択。

データベース状態解析を実行するHiRDBシステムを選択してください。

2. 「情報種別」を選択。

データベース状態解析を行う処理種別を次の中から選択してください。

· 「ユーザ表」

ユーザ表に対して使用ページ状態の解析を行います。

· 「ディクショナリ表」

ディクショナリ表に対して使用ページ状態の解析を行います。

· 「ユーザインデクス」

ユーザ表のインデクス対して使用ページ状態の解析を行います。

· 「RDエリア」

ＲＤエリアに対して使用ページ状態の解析を行います。

3. 「一覧」から解析対象の表または、インデクス、ＲＤエリアを選択。

データベース状態解析を行う対象を選択してください。選択後は「状態解析」ICONボタンをクリックすることで、選択した対象物に対する使用ページ状態の解析を実行します。状態解析は、全ページの使用率を参照するため、対象物のページ数に比例して解析時間がかかります。また、全ページ使用状態を求めるため、データベース状態解析ユティリティ(pddbst)をHiRDBシステム上で実行します。

<注意事項>

· 「状態解析」ボタンを連続して押すと、解析対象のHiRDBシステムに大きな負荷をかける恐れがあります。十分注意してください。

· HiRDB Version 8以降の場合にのみ、「情報種別」でRDエリアを選択できます。

· 状態解析が可能なRDエリアは以下の種別に限ります。

－ユーザ用RDエリア

－データディクショナリ用RDエリア

－レジストリ用RDエリア

4. 状態解析結果の表示。

状態解析が終了すると、次の状態解析実行結果情報を表示します。また、状態解析を行った表または、インデクスに対して「空きページ解放」、「再編成」操作ができます。RDエリアに対しては、「RDエリアの拡張」、「バックアップ」、「リカバリ」操作ができます。

· 「表情報」

解析対象表に関する情報を表示します。

· 「RDエリア情報」

解析対象表のRDエリアに関する情報を表示します。

複数RDエリアで構成された表を解析した場合、RDエリア単位に情報を表示します。「RDエリア名」から選択することにより、各RDエリア情報を表示することができます。

· 「ページ使用状態」

表、インデクスの論理的なデータ格納状態を解析して、RDエリア単位にページ使用状態をグラフで表示します。

複数RDエリアで構成された表を解析した場合は、「RDエリア情報」の「RDエリア名」で選択されたRDエリアに対するページ使用状態を表示します。

ページ使用率状態グラフについては、[解説編] > [データベース状態解析機能]を参照してください。

<注意事項>

· 解析対象が10000ページを越える場合、「ページ使用状態グラフ」に表示されるページ内使用率は、サンプリングしたページ使用率データを元に解析した結果を表示しています。サンプリング方法については、[解説編] > [データベース状態解析機能]を参照してください。


[データベース状態解析環境設定]

[データベース状態解析環境設定]コマンド

データベース状態解析ユティリティ実行時に使用する作業用ディレクトリの設定を行います。

このコマンドを選択すると、データベース状態解析ユティリティ実行環境設定画面を表示します。

1. 「HiRDBシステム」を選択。

データベース状態解析ユティリティ実行時の作業用ディレクトリを設定するHiRDBシステムを選択してください。

2. 「作業用ディレクトリ名」へ作業用ディレクトリを入力。

データベース状態解析ユティリティ実行時には、各サーバごとに作業用ディレクトリが必要になります。この作業用ディレクトリを絶対パスで入力してください。[参照]ボタンをクリックして対象となるディレクトリ名を絶対パスで指定することもできます。また、「サーバリスト一覧」から、既に登録されているディレクトリ名称を転記することもできます。

3. 「サーバリスト一覧」から作業用ディレクトリを変更するサーバを選択。

「作業用ディレクトリ名」に指定されたディレクトリ名称を登録するサーバを「サーバリスト一覧」から選択してください。

4. 「登録」ボタンをクリックし、作業用ディレクトリ情報を登録してください。

「サーバリスト一覧」に表示された各サーバの作業用ディレクトリ情報を登録します。

§ 各サーバに対して、2,3の操作を繰り返し行った後で「登録」ボタンを実行することにより、複数のサーバ情報を一括で登録することができます。

<注意事項>

· HiRDB CMは設定された作業用ディレクトリが存在するかどうかのチェックを行いません。各サーバに存在するディレクトリを絶対パスで設定してください。存在しないディレクトリを指定した場合やディレクトリが絶対パスで指定されていない場合は、データベース状態解析が失敗します。


[自動データメンテナンス]

[自動データメンテナンス]コマンド

このコマンドを実行すると「自動データメンテナンス」画面を表示します。

[自動データメンテナンス]は、容量不足となるであろうRDエリアを事前に察知して、「再編成ユティリティ」、「空きページ解放」、「Consoleへの警告表示動作」を自動的に行うことができます。

<注意事項>

· 自動データメンテナンスは、１HiRDBシステムに１登録しかできません。自動データメンテナンスが登録できるのは、次の管理HiRDBシステムです。

HiRDB/Single Server Version 7 07-02以降または、 HiRDB/Parallel Server Version 7 07-02以降

· データベース状態解析を実行する場合は、事前にHiRDBシステム本体で再編成時期予測機能を実行するために必要な設定を行っておく必要があります。

· RDエリアの容量不足とは、RDエリア容量の80%以上を使用している場合の状態を示します。

· RDエリアの容量不足の予測機能は、４回以上蓄積を行った後でのみ動作します。　HiRDB CMで新規に自動データメンテナンスを実行する場合は、登録日から４日後に予測が有効になります。ただし、自動データメンテナンス対象表・インデックス（RDエリア）に関するDB状態解析蓄積情報が既にHiRDBシステムへ蓄積されている場合は、４日以前に予測結果を表示する場合があります。

· 複数の自動データメンテナンス画面を同時に開き、それぞれの画面を交互に操作しないでください。表示・操作結果が正しく動作しないことがあります。

表示・操作が正しく行えなくなった場合は、一旦自動データメンテナンス画面を全て閉じて再度1つの自動データメンテナンス画面を開いて操作してください。

また、複数のHiRDBシステムに対して自動データメンテナンスを操作する場合、1つの自動データメンテナンス画面で複数HiRDBシステムに対する操作を行わ内でください。必ず１つのHiRDBシステムに対する操作が完了した後に一旦自動データメンテナンス画面を閉じ、他のHiRDBシステムに対して自動データメンテナンスを行うために再度自動データメンテナンス画面を開いてください。

· 「メンテナンス結果」タブに表示される情報は、タブを開いたときの情報です。この画面を開いたままでそれ以降の情報を確認することはできません。

新たな結果情報を確認する場合は、自動データメンテナンス画面を一旦閉じ、再度開きなおしてください。（同一画面を開いたままでは、その後の結果情報を自動的に再表示することはありません。）

· 系切り替え機能を使用している場合:

  HiRDBシングルサーバまたは、HiRDBパラレルサーバのMGRユニットが系切り替え構成を使用している場合は、スケジュールは現用系マシン上でのみ有効になります。

  自動データメンテナンスの登録/登録解除/再開始/一時停止を行う場合、対象HiRDBが停止している状態、もしくは、HiRDBシングルサーバまたは、HiRDBパラレルサーバのMGRユニットが現用系で実行中である必要があります。

  データの蓄積または、解析時刻に、HiRDBシングルサーバまたは、HiRDBパラレルサーバのMGRユニットが予備系で稼動中である場合、スケジュール処理を行いません。

l データベース再編成時期予測

データベース再編成時期予測(pddbst)は、RDエリア内の表/インデクスが使用するセグメントについて、セグメント単位の使用量を定期的に蓄積する機能、蓄積した情報を分析してRDエリアが容量不足になるであろう日を予測する機能、RDエリア容量不足を事前に回避するための対処方法を提示する機能があります。

データベース再編成時期予測機能の詳細は、「スケーラブルデータベースサーバ HiRDB Version 7 コマンドリファレンス」または、「スケーラブルデータベースサーバ HiRDB Version 7 システム運用ガイド」を参照してください。

l自動データメンテナンス

自動データメンテナンスは、データベース再編成時期予測機能を使用して対象となるRDエリアの容量不足を監視し、容量不足が発生するであろう日までに、提示された対処方法に従い容量不足を事前に回避する動作を自動的に行います。

この自動データメンテナンスを稼働させた場合は、対象としたRDエリアについて、毎日指定された時間にRDエリア使用量情報を蓄積して、同時刻に蓄積された情報を基に対象となるRDエリアが容量不足になるであろう日を予測します。この動作は自動データメンテナンスの登録が取り消されるかまたは、一時停止を指示されるまで継続されます。自動データメンテナンスは、[解説編] > [自動データメンテナンス]でより詳しく解説をしています。

1．自動データメンテナンス機能を稼動する。

自動データメンテナンスを稼動させるために次の手順で操作を行ってください。

a．対象HiRDBシステムを選択。

自動メンテナンスを稼働させるHiRDBシステムを選択してください。

b．チェックポイントタブ項目の指定。

再編成時期予測機能を実行するための以下の条件を指定してください。

· 「メンテナンス対象期間」

RDエリアの容量不足を最大、何日前までに察知して対処するかを日単位で指定してください。

· 「メンテナンス実行時間」

RDエリア使用量情報の蓄積および分析を行う時刻を時分秒で指定してください。

· 「解析対象」

自動メンテナンス対象とする単位を次の中から選択してください。

・ 「システム全体」

HiRDBシステムが持っている全てのRDエリアを対象とします。ディクショナリ用RDエリアも対象となります。

・ 「メンテナンスタブから選択」

メンテナンスタブ項目に表示されている表/インデクスから自動メンテナンス対象とするRDエリアを使用している表/インデクスを選択することができます。

<注意事項>

· 「システム全体」を選択すると自動データメンテナンス稼動中のRDエリア情報蓄積および解析処理でHiRDBシステムに大きな負荷を与える可能性があります。HiRDBシステムの規模に応じて、「メンテナンスタブ」か、「システム全体」かを検討してください。

· 解析対象に指定されていないオブジェクトは、情報の蓄積がおこわなれませんが、解析は行われます。

· 「RDエリアセグメント使用率の警告値を使用する。」

「リソース警告値の設定」でRDエリアの使用率にチェックしている場合、その値を基準値として使用する場合に指定します。

<注意事項>

· RDエリアセグメント使用率の警告値に10%以下の値を指定している場合は、自動データメンテナンスの基準値に10%の値を使用します。

ｃ. メンテナンスタブ項目の設定。

HiRDBシステムが持つ全ての表/インデクスが表示されます。表示された表/インデクスを選択して、自動データメンテナンスの対象とするか/しないかを設定することができます。また、自動データメンテナンスの対象とした表/インデクスに対して容量不足となるであろうRDエリアを事前に察知した場合に実施する「再編成」ユティリティ、「空きページ解放」ユティリティのカタログを登録することもできます。

· 「メンテナンス方針」

HiRDBシステムが持つ全ての表/インデクスについて以下の情報が表示されます。

「解析対象」カラム

自動データメンテナンスの対象「ON」か非対象「OFF」を表示します。

「チェックポイント」タブの「解析対象」項目で「システム全体」を選択した場合、表示される全ての表/インデクスが「YES」となります。

個々の「解析対象」を変更する場合は、変更する表/インデクスを1つ選択して「解析対象の変更」ボタンを押してください。また、「変更」ボタンを押した後、「処理設定項目」を設定後に「設定」ボタンを押すことでも「解析対象」を変更することができます。

「対象名」カラム

表/インデクス名称を表示します。

ディクショナリ/ディクショナリインデクスに対しては「－」を表示します。

「対象種別」カラム

「ディクショナリインデクス」「ディクショナリ表」「ユーザインデクス」「ユーザ表」の何れかを表示します。

「所有者」カラム

表/インデクスの所有者名を表示します。

「再編成」カラム

「処理設定」項目で設定した「再編成」のカタログ名を表示します。

「空きページ解放」カラム

「処理設定」項目で設定した「空きページ解放」のカタログ名を表示します。

「バックアップ」カラム

「処理設定」項目で設定した「バックアップ」のカタログ名を表示します。

· 「修正」ボタン

「メンテナンス方針」に表示された対象について、容量不足となるであろうRDエリアを事前に察知した場合に実施する処理の設定操作を開始することができます。

· 「設定」ボタン

「メンテナンス方針」に表示された対象について、容量不足となるであろうRDエリアを事前に察知した場合に実施する処理設定情報を登録することができます。

· 「解析対象の変更」ボタン

「メンテナンス方針」に表示された対象について、自動データメンテナンス対象なっている場合にこのボタンをクリックすると対象外に変更します。また、自動メンテナンス対象外になっているものに対してこのボタンをクリックすると自動メンテナンス対象とすることができます。

· 「処理設定」

容量不足となるであろうRDエリアを事前に察知した場合に実施する処理を設定します。再編成時期予測機能で提示される対処方法は、「再編成」「空きセグメント解放」「RDエリア拡張」「RDエリアの再構築」です。このうち「再編成」と「空きセグメント解放」は、カタログを登録しておくことにより自動的に処理することができます。これらの対処指示に対して処理カタログを登録していない場合は、CM Console上の警告表示のみを行います。

· 「メンテナンス前のバックアップ実行」

対処方法として実施する「再編成」処理の前にバックアップを取得したい場合は、この項目にバックアップのカタログを指定します。

· 「メンテナンス手法」

RDエリアの容量不足を事前に検知し、容量不足を回避するために提示された対処方法に対して実行する次の処理カタログを指定します。

・ 「空きページ解放」

RDエリアの容量不足を事前に検知し、容量不足を回避するために提示された操作が「空きページ解放」の時に対処として実行するカタログ名を指定します。「カタログ作成」ボタンを押すと空きページ解放実行用カタログを作成することができます。

・「再編成」

RDエリアの容量不足を事前に検知し、容量不足を回避するために提示された操作が「再編成」の時に対処として実行するカタログ名を指定します。「カタログ作成」ボタンを押すと再編成実行用カタログを作成することができます。

ｄ. 自動データメンテナンス機能の登録

「チェックボックス」タブ、「メンテナンス」タブに設定した内容を確認してください。

「登録」ボタンを押下することで自動データメンテナンス機能を稼動することができます。

<注意事項>

·自動データメンテナンス機能登録後にカタログの内容を変更した場合、登録時のカタログの内容で動作します。カタログの内容を変更したい場合は、「登録解除」を行ってから再度「登録」を行ってください。

2．自動データメンテナンス機能を停止する。

「登録削除」ボタンを押下することで自動データメンテナンス機能を停止することができます。

<注意事項>

· 「登録削除」を行なっても、HiRDBが蓄積した情報は削除されません。蓄積情報を削除する方法は、「スケーラブルデータベースサーバ HiRDB Version 7 コマンドリファレンス」または、「スケーラブルデータベースサーバ HiRDB Version 7 システム運用ガイド」を参照してください。

3．自動データメンテナンス機能を「一時停止」「再開始」する。

「一時停止」ボタンを押下することで自動データメンテナンス機能を一時停止することができます。一時停止を行った場合、「チェックボックス」タブ、「メンテナンス」タブに設定した内容は削除されません。「再開始」ボタンを押下することで以前と同じ設定で自動データメンテナンス機能を開始することができます。

<注意事項>

· 「一時停止中」に、「チェックボックス」タブ、「メンテナンス」タブで設定されている内容を変更しても、「再開始」時にその変更は反映されません。　設定内容を変更した場合は、 「登録削除」を行った後に設定内容を変更し、再度「登録」を行ってください。

4. 自動データメンテナンス実行結果を確認する。

自動データメンテナンス機能の実行結果は、「メンテナンス結果」タブで確認することができます。以下に、「メンテナンス結果」タブについて説明します。

· 「解析結果」

RDエリア使用量情報を解析した結果、「メンテナンス対象期間」中にRDエリアの容量不足が発生するであろうと予測されたRDエリアまたは当該RDエリア上に格納された表/インデクスの情報を表示します。

「対象種別」カラム

  ユーザ表、ユーザインデクス、RDエリア、LOB用RDエリア、ディクショナリ表、ディクショナリインデクスのいずれかを表示します。

「所有者」カラム

  「対象種別」が表/インデクスの場合、所有者名を表示します。RDエリアの場合は、「------」と表示されます。

「対象名」カラム

  容量不足となる、または再編成等が必要となると予測したRDエリア、表/インデクス名称を表示します。

「予測日」カラム

  容量不足となる予測日時を表示します。

「メンテナンス方法」カラム

  RDエリアの容量不足を事前に検知し、容量不足を回避するために提示された対処方法を表示します。

  ・空きセグメント解放

空きセグメントを解放することで、容量不足を回避できる場合に表示されます。自動対処が行われなかった場合は、手動で「空きページ解放ユティリティ」を実行してください。

  ・再編成

データベース再編成ユティリティを実行するすることで、容量不足を回避できる場合に表示されます。自動対処が行われなかった場合は、手動で「データベース再編成ユティリティ」を実行してください。

  ・RDエリアの拡張

容量不足を回避するためにRDエリアの拡張を行う必要がある場合に表示されます。RDエリアの拡張が提示された場合は、手動で「RDエリアの拡張」を実行してください。

  ・RDエリアの再構築

容量不足を回避するためにRDエリアの拡張を行う必要があり、かつRDエリアを拡張できない場合に表示されます。　データ量の見積もりを再度計算し、データベースを再構築してください。

「自動対処」カラム

対処方法が登録されている場合は、その対処処理が実行されたか否かを表示します。

自動対処として実行されたカタログの実行結果は、[カタログ実行結果情報]画面で確認できます。

「通知のみ」又は、カタログの実行に失敗となった対象については、RDエリアマップ、表マップ等で通知を行います。

・RDエリアに対して、拡張が要求されている場合は、黄土色で警告表示を行います。

・表/インデクスに対して、メンテナンスが要求されている場合は、桃色で警告表示を行います。

<注意事項>

· 対象方法に[空きセグメント解放]が提示された場合、登録された空きページ解放ユティリティのカタログ情報を元に、空きページ解放と空きセグメント解放を連続して実行します。そのため、[カタログ実行結果情報]画面では、空きページ解放ユティリティカタログが実行された結果が２つ表示されます。

·LOB用RDエリアに対してメンテナンス方法で再編成が指示されている場合に、対処前に[RDエリアマップ]や、[システムステータス]-[RDエリア詳細]のインジケータにセグメント使用率が0％で表示されることがあります。この場合は、RDエリア容量不足による対処ではなく、アクセス性能改善のための指示になります。詳細は、「スケーラブルデータベースサーバ HiRDB Version 7 コマンドリファレンス」を参照してください。

· 処理対象が分割表の時は、[解析結果]リストに複数のレコードが表示される場合があります。これは、表が存在するそれぞれのRDエリアごとに解析を行うためです。

処理対象が分割表であり、複数の処理が提示された場合は、以下の規則で対処方法を決定します。

  ・自動対処方法に空きページ解放と再編成の両方のカタログが登録されており、かつ、両方のメンテナンス方法が指定されている場合は、再編成を行います。

  ・一つのRDエリア上の解析結果によって、再編成が指示されている場合でも、他のRDエリアで、再編成の実行によりRDエリアの容量が増加する可能性がある場合には、再編成を行いません。通知のみとなります。

· 「メンテナンス状況」ボタン

  自動データメンテナンス稼動中に「メンテナンス状況」ボタンを押すと、最新の解析実施状況を確認することができます。

· 「解析結果の詳細」

「解析結果」で表示されたリストに対する詳細情報を表示します。ここに表示される内容は、HiRDBのデータベース解析ユティリティの表示結果に準じています。「スケーラブルデータベースサーバ HiRDB Version 7 コマンドリファレンス」を参照してください。

· 「即時解析」ボタン

「即時解析」ボタンを押すと、「解析結果」フィールドで選択された表/インデクスについて「データベース状態解析」を実行し、RDエリア内の論理的なデータ配置を確認することができます。

<注意事項>

· ディクショナリ表/ディクショナリインデクスに対しては、予測結果に対するカタログ処理を実行できません。

· メンテナンス対象が分割表の場合、解析結果で再編成が要求されても自動対処しない場合があります。

（ 再編成時期予測機能で分割されている表を含むRDエリアの解析において、一方で分割表の再編成が要求されていても、他の分割表を含むRDエリアに対して拡張の要求がある場合、RDエリアの拡張を行わないで再編成を実行すると、RDエリアの容量の限界を超える可能性があるので、自動対処として再編成は実行されません。）


[スケジュール]タブ

[スケジュール]タブには、以下のようなコマンドがあります。

[スケジュールの追加]

[スケジュールの状況確認]

[スケジュールリスト]

[カタログ情報]

[カタログ実行結果情報]

<注意事項>

· 系切り替え機能を使用している場合:

  HiRDBシングルサーバまたは、HiRDBパラレルサーバのMGRユニットが系切り替え構成を使用している場合、スケジュールは現用系でのみ有効になります。

  スケジュール追加/変更/削除する場合、対象HiRDBが停止している状態、もしくは、HiRDBシングルサーバまたは、HiRDBパラレルサーバのMGRユニットが現用系で稼動中である必要があります。

  スケジュール実行時刻に、HiRDBシングルサーバまたは、HiRDBパラレルサーバのMGRユニットが予備系で稼動中である場合、スケジュール処理を行いません。


[スケジュールの追加]

[スケジュールの追加]コマンド

カタログのスケジュールをウィザードで実行します。

このコマンドを選択すると、スケジュールを実行するための[ウィザード]画面が表示されます。

スケジュール ウィザードの各項目の設定内容を、以下で説明します。

· スケジュール ウィザード

<2036年の対応>

· このコマンドの時間指定において、2036年を超えた時間の指定をすることはできません。

<前提条件>

· このコマンドを使用するには、HiRDB CM上で1ファイル以上のカタログを作成していることが必要です。

<注意事項>

· 実行期間を指定してスケジュールを追加した場合:

スケジュール情報が実行期間を過ぎても自動的に削除されません。そのため、[スケジュールリスト]コマンド等でスケジュール情報が表示されたままになります。

このスケジュール情報が不要な場合は、手動で削除してください。削除の方法については、[スケジュールリスト]コマンドを参照してください。


[スケジュールの状況確認]

[スケジュールの状況確認]コマンド

スケジュールの状況を表示します。

スケジュールが設定されている日付に、実行されるカタログに対応したアイコンが表示します。

このコマンドは自動で最新の状態に更新されません。最新の情報を表示するには、この[スケジュールの状況確認]コマンドを再実行するか、あるいは[F5]キーを押下することで最新の状態へ更新することができます。

[スケジュールの状況確認]画面内のアイコンまたは日付で右クリックを行うとポップアップメニューが表示され、次のコマンドが実行できます。

§ [スケジュールリスト]コマンド

対応した日付に実行されるスケジュールの一覧を[スケジュールリスト]画面に表示します。

§ [カタログ実行結果情報]コマンド

対応した日付に実行されたカタログ実行結果の一覧を[カタログ実行結果情報]画面に表示します。


[スケジュールリスト]

[スケジュールリスト]コマンド

スケジュールの実行時間と詳細を表示します。

上段のリストボックスに表示されているスケジュールを選択すると、そのスケジュールの詳細が下段のリストボックス「スケジュール 詳細」に表示されます。

このコマンドは自動で最新の状態に更新されません。

最新の情報を表示するには、この[スケジュールリスト]コマンドを再実行するか、あるいは[F5]キーを押下することで最新の状態へ更新することができます。

[スケジュールリスト]の上段リストボックスでスケジュールを選択して右クリックを行うとポップアップメニューが表示され、次のコマンドが実行できます。

§ [変更]コマンド

選択しているスケジュールの情報をデフォルト値として表示した[スケジュール ウィザード]画面を表示し、スケジュールの実行する時間を変更します。

§ [削除]コマンド

選択したスケジュールを削除します。

また、[Delete]キーを押下することでも削除ができます。

<注意事項>

· [変更]コマンドを実行する場合:

スケジュール名を変更すると、HiRDB CMは新規スケジュールの登録とみなします。従って、選択したスケジュール情報は変更されません。このスケジュールが不要な場合は、[削除]コマンドを使用して削除してください。

· スケジュール時間に表示される秒単位の項目は、全て「:00」が表示されます。実行時間は、分単位での実行契機を設定します。（秒指定は無効となります。）


[カタログ情報]

[カタログ情報]コマンド

カタログの詳細を表示します。

上段のリストボックスに表示されているカタログを選択すると、そのカタログの詳細が下段のリストボックス「カタログ 詳細」に表示されます。

このコマンドは自動で最新の状態に更新されません。

最新の情報を表示するには、この[カタログ情報]コマンドを再実行するか、あるいは[F5]キーを押下することで最新の状態へ更新することができます。

[カタログ情報]の上段リストボックスでカタログを選択して右クリックを行うとポップアップメニューが表示され、次のコマンドが実行できます。また、選択したカタログが「JP1/AJS2」で使用されている場合、「JP1/AJS2カタログ解除」を行うことができます。

カタログをJP1/AJS2のカスタムジョブ（JP1/AJS2カタログ）として使用するためには[メニューバー]>[オプション]>[JP1/AJS2との連携]を実行してください。また、JP1/AJS2に対して[JP1/AJS2連携操作手順]に従い設定を行う必要があります。

§ [スケジュール]コマンド

選択しているカタログをスケジュールします。[スケジュール ウィザード]画面が表示されるので、ここで必要な情報を指定してください。指定した対象をダブルクリックすることでも実行できます。

§ [削除]コマンド

選択したカタログを削除します。また、[Delete]キーを押下することでも削除ができます。ここで削除したカタログは再生することができません。

§ [JP1/AJS2カタログ解除]コマンド

JP1/AJS2へ登録したカスタムジョブの削除は、HiRDB CMカタログ情報と連携していません。JP1/AJS2で使用しなくなったカタログ情報は、このコマンドを使用して実行環境を解除してください。

<注意事項>

· [削除]コマンドを実行する場合、スケジュール中のカタログは、削除することができません。スケジュールを解除してから、カタログを削除してください。また、JP1/AJS2で使用中のカタログに対しても[削除]コマンドを実行することはできません。JP1/AJS2で使用中のカタログを削除する場合は、まず[JP1/AJS2カタログ解除]操作を行った後で[削除]を実行してください。


[カタログ実行結果情報]

[カタログ実行結果情報]コマンド

カタログの実行結果を表示します。

上段のリストボックスに表示されているカタログを選択すると、そのカタログの実行結果の詳細が下段のリストボックス「実行結果 ログ」に表示されます。また、「実行結果ログ」に表示された情報内のHiRDBメッセージに対してメッセージの詳細を参照する場合は、[メッセージ詳細説明表示]操作を実行してください。

＜実行結果コードの見方＞

1. スケジュール成功時

HiRDB CMはKFPE31001-Iメッセージを返します。(HiRDB CM Agent が01-00以前は、0を返します。）

2. スケジュール失敗時

HiRDBでエラーが発生した場合、HiRDB CMはHiRDBのメッセージを返します。

HiRDB CMでエラーが発生した場合、HiRDB CMは実行結果コードにKFPE34000～KFPE34999を返します。HiRDB CM Agentが01-00以前の場合は、HiRDB CMは実行結果コードに-4000～-4999を返します。この番号はHiRDB CMの出力するAgentのメッセージの下4桁に対応しています。詳細は「HiRDB CM - Agentのメッセージ」を参照してください。

このコマンドは自動で最新の状態に更新されません。

最新の情報を表示するには、この[カタログ実行結果情報]コマンドを再実行するか、あるいは[F5]キーを押下することで最新の状態へ更新することができます。

カタログ実行結果情報では、HiRDBのカタログの実行した結果が表示されます。表示されるカタログ実行結果は、次の３つの実行を行った場合です。

§ スケジュール機能によるカタログ実行を行った結果

§ 自動データメンテナンスのメンテナンスとして実行した結果

§ JP1/AJS2カスタムジョブ連携を行った結果

[カタログ実行結果情報]の上段リストボックスでカタログを選択して右クリックを行うとポップアップメニューが表示され、次のコマンドが実行できます。

§ [詳細]コマンド

[カタログ情報]画面を表示し、カタログの詳細を表示します。

§ [削除]コマンド

選択したカタログを削除します。

また、[Delete]キーを押下することでも実行できます。

<注意事項>

· カタログ実行結果情報は、次の２つの規則によって管理されます。

    1. 一年分のデータだけが保存されます。一年以上経過したカタログ実行結果情報は、自動的に削除されます。

    2. HiRDB CM Serverインストール時に指定した管理情報規模に応じて、規定の件数分のデータだけが保存されます。保存されるデータ数は、小規模（標準）の場合は、5000件、大規模の場合は、50000件です。規定件数以上のカタログ実行結果を保存する場合は、最も古いカタログ実行結果が自動的に削除されます。


[表操作]タブ

[表操作]タブには、以下のようなコマンドがあります。

[定義系SQL]

[定義系SQL生成]

[改ざん防止表移行ウィザード]


[定義系SQL]

[定義系SQL]コマンド

指定した管理HiRDBシステムに対してスキーマの定義や内容の変更などをするデータベース定義ユティリティ （pddef） を実行します。

このコマンドを選択すると、[定義系SQLの実行]画面を表示します。

1. HiRDBシステムの情報を入力する。

定義系SQLを実行するHiRDBシステムを選択します。

2. 認可識別子を入力する。

選択したHiRDBシステムのユーザの認可識別子を指定してください。

認可識別子は((最大8文字))です。大文字/小文字は区別されるのでダブルコーテーションで囲む必要はありません。

3. パスワードを入力する。

選択したHiRDBシステムのユーザのパスワードを指定してください。

パスワードは((最大30文字))です。大文字/小文字は区別されるのでダブルコーテーションで囲む必要はありません。

4. 定義系SQLの指定方法を選択する。

次の定義系SQLの指定方法を選択します。

· 「定義系SQLを保存してあるファイルを指定」

あらかじめHiRDBシステムマネジャノード上に作成された定義系SQLを格納した入力ファイルを使用して実行します。

ファイル名称は、ディレクトリを含めた完全パス名称を指定して下さい。

[参照]ボタンにより対象ファイルのパス名称を指定することもできます。

<注意事項>

· 入力ファイルのあるホスト上のユニットがスタンバイ型系切り替え機能を使用している場合、実行系ホスト上のファイルが対象になります。また、対象ユニットが停止している場合は、現用系のホスト上のファイルが対象になります。

· 「定義系SQLを直接入力」

実行する定義系SQLを[定義系SQL文]フィールドへ直接入力してください。

記述する定義系SQLの詳細については、マニュアル「HiRDB SQLリファレンス」を参照してください。

定義系SQL実行時に[ファイルに保存して実行]または、保存しないで[実行]を選択することができます。

<注意事項>

· [定義系SQL文]フィールドへ直接入力できる最大文字数は、32768バイトです。

· 「ファイルに保存してある定義系SQLを編集」

[ファイルからSQLを取得]ボタンを押すと[ファイル/ディレクトリ一覧]画面が表示されます。[ファイル/ディレクトリ一覧]画面の[ホスト名]および[ドライブ]を選択して、ホスト上に作成された定義系SQL格納ファイルを決定します。

指定されたファイルから定義系SQLを読み出して、[定義系SQL文]フィールドへ表示します。[定義系SQL文]フィールドへ表示された定義系SQLは直接編集することができます。

また、定義系SQL実行時に[ファイルに保存して実行]または、保存しないで[実行]を選択することができます。

<注意事項>

· 入力ファイルのあるホスト上のユニットがスタンバイ型系切り替え機能を使用している場合、実行系ホスト上のファイルが対象になります。また、対象ユニットが停止している場合は、現用系のホスト上のファイルが対象になります。

· [定義系SQL文]フィールドで編集できる最大文字数は、32768バイトです。

· 「既に定義されている表からSQLを取得し編集」

「表からSQLを取得」ボタンを実行することで、指定したHiRDBシステムで既に定義されている表から定義系SQLを生成して、[定義系SQL文]フィールドへ表示します。[定義系SQL文]フィールドへ表示された定義系SQLは直接編集することができます。

また、定義系SQL実行時に[ファイルに保存して実行]または、保存しないで[実行]を選択することができます。

<注意事項>

· [定義系SQL文]フィールド編集できる最大文字数は、32768バイトです。

5. [実行してファイルに保存]ボタンをクリック。

[定義系SQL文]フィールドに書かれた定義系SQLを実行後[定義系SQL文]フィールドへ表示された定義系SQLを指定されたファイルに保存します。保存するファイル名称は、ディレクトリを含めた完全パス名称を指定して下さい。

<注意事項>

· ファイルを保存するホスト上のユニットがスタンバイ型系切り替え機能を使用している場合、実行系ホスト上に保存されます。また、対象ユニットが停止している場合は、現用系のホスト上に保存されます。

6. [実行]ボタンをクリック。

選択したHiRDBシステムに対して、定義系SQLの指定方法で選択された定義系SQLを実行します。

<注意事項>

· 実行するSQLによって必要な権限が異なります。SQL実行時の権限については，マニュアル「HiRDB SQLリファレンス」を参照してください。


[定義系SQL生成]

[定義系SQL生成]コマンド

指定した管理HiRDBシステムで既に定義されている表から定義系SQLを生成するコマンド (pddefrev) を実行します。

このコマンドを選択すると、[定義系SQL生成]画面を表示します。

1. HiRDBシステムの情報を入力する。

定義系SQLを生成する対象の表が定義されているHiRDBシステムを選択します。

2. 表を選択する。

[表一覧]項目に表示された表の中から、定義系SQLを生成する表を選択します。

3. 生成した定義系SQLを保存する保存先ファイル名を指定します。

選択した表から生成される定義系SQLの保存先を完全パス名で指定します。

ファイル名称は、ディレクトリを含めた完全パス名称を指定して下さい。[参照]ボタンにより対象ファイルのパス名称を指定することもできます。

4. [実行]ボタンをクリック。

選択した表に対して定義系SQL生成を実行して保存します。

<注意事項>

· ファイルを保存するホスト上のユニットがスタンバイ型系切り替え機能を使用している場合、実行系ホスト上に保存されます。また、対象ユニットが停止している場合は、現用系のホスト上に保存されます。


[改ざん防止表移行ウィザード]

[改ざん防止表移行ウィザード]コマンド

HiRDBでは、ユーザの表アクセス権限に関係なく、表の更新/削除を禁止できる改ざん防止オプションを表に定義することができます。この改ざん防止オプションは表作成時、または、定義変更時に指定することができます。HiRDB CMでは、非改ざん防止表を改ざん防止表に変更する一連の処理をウィザードとして提供します。

このコマンドを選択すると、改ざん防止表への移行を実行するための[ウィザード]画面が表示されます。

改ざん防止表へのウィザードの各設定内容を以下で説明します。

· 改ざん防止表への移行ウィザード

<前提条件>

· 対象システムがXDM/RDの場合、本コマンドを実行することはできません。

· 対象システムのCM Agentが08-01未満の場合、本コマンドを実行することはできません。

· 対象HiRDBシステムのバージョンが07-02未満の場合、本コマンドを実行することはできません。

· 改ざん防止表に対する追加設定（改ざん防止表から条件を変更した改ざん防止表への移行）は行えません。

· 外部キーを定義した表に対して本コマンドを実行することはできません。

· 検査制約を定義した表に対して本コマンドを実行することはできません。

· インナレプリカ機能を定義したRDエリアに定義されている表に対して本コマンドを実行することはできません。

· 監査証跡表に対して本コマンドを実行することはできません。

· BLOB列を持つ表に対して本コマンドを実行することはできません。

· 抽象データ型の列を持つ表に対して本コマンドを実行することはできません。

改ざん防止表ウィザードでは、次の操作を行い、改ざん防止表への移行を行います。

項番 | HiRDB操作 | 実行コマンド | 詳細
1 | 事前バックアップ | pdcopy | 実行前のバックアップを行います。バックアップの対象はデータディクショナリ用RDエリアと表および関連インデクス格納先RDエリアです。バックアップ取得時には、RDエリアの閉塞は行いません。
2 | RDエリアの閉塞 | pdhold | 表のアンロードを行うためにRDエリアを閉塞します。
3 | 表データのアンロード | pdrorg -k unld | 既存表に格納されているデータをアンロードします。
4 | RDエリアの閉塞解除 | pdrels | RDエリアの閉塞を解除します。
5 | 表データ削除 | PURGE TABLE文 | 既存表のデータを全て削除します。
6 | 表定義変更 | ALTER TABLE文 | 1. 更新可能列の指定を行います。 2. 表に改ざん防止オプションを指定します。
7 | RDエリアの閉塞 | pdhold | データロードのためにRDエリアを閉塞します。
8 | 表データの再ロード | pdload | アンロードしたデータを再ロードします。ログレスモードで実行します。
9 | RDエリアの閉塞解除 | pdrels | RDエリアの閉塞解除します。

<注意事項>

· 改ざん防止表への移行ウィザードを実行する際には、対象表を格納したRDエリアの状態をオープンかつ閉塞解除の状態にしてください。

一連の処理中にRDエリアがオープンしていないと実行できない処理や、閉塞して他ユーザのアクセスを抑止するのが望ましい処理が混在しているため、オープンかつ閉塞解除以外の状態の場合、HiRDB CMは改ざん防止表への移行を行いません。

· 移行実施後にはデータディクショナリ用RDエリアと表格納先ユーザ用RDエリアのバックアップを取得してください。

本ウィザードでは表の定義が変更されるため、成功時にはRDエリアのバックアップを取得してください。RDエリアのバックアップを取得しないままHiRDBの運用を続行すると、障害発生時に正しくDBが回復できなくなります。また、表データの再ロードはログレスモードで行います。そのため、本操作を行ったシステムログを使用したリカバリが実行できなくなります。

· 改ざん防止表への移行処理中には、データベースへのアクセスを行わないでください。

· 改ざん防止表への移行に失敗した場合、事前取得したバックアップを使用して、ディクショナリ表、対象表とその表に定義されているインデクスが存在するすべてのRDエリアのリカバリを行います。改ざん防止表への移行に失敗した後もシステムログ連続性の観点からバックアップを取得することをお勧めします。


[ツール]タブ

[ツール]タブには、以下のようなコマンドがあります。

[登録/削除]

[HiRDBクライアント環境変数設定]

[SQL Executer]

[SQL TA]

<注意事項>

· HiRDB CM - Console 08-02以降では、Consoleがインストールされているマシン上にHiRDB SQL Executer、および、HiRDB SQL Tuning Advisorがインストールされていない場合、[SQL Executer]コマンド、および、[SQL TA]コマンドが表示されません。

また、[登録/削除]コマンドから外部ツールを登録した場合、登録したツールが一緒に表示されます。

登録したツールの起動については次の項目を参照してください。

[外部ツールの起動]

なお、以下のコマンドは、HiRDB CM - Console 08-02でサポートされなくなりました。

HiRDB簡易セットアップツールをConsoleから起動する場合は、[登録/削除]コマンドを使用し、外部ツールとして登録してください。

[HiRDB簡易セットアップ]


[登録/削除]

[登録/削除]コマンド

CM Consoleと同一マシン上に存在する外部ツール(アプリケーション)を登録し、CM Consoleを介して起動できるようにします。

このコマンドを選択すると、[ツールの登録/削除]画面が表示されます。

[ツールの登録/削除]画面には、CM Consoleに登録されているツールの一覧が表示されます。

<注意事項>

· CM Consoleをインストールしたマシン上に、HiRDB SQL Executer、および、HiRDB SQL Tuning Advisorがインストールされていた場合、「SQL Executer」、「SQL TA」がそれぞれ自動的に登録されます。初めから存在するこれらのツールを削除した場合に、その後これらのツールが自動的に登録されることはありません。[登録]機能を使用し、各ツールを登録してください。

· 登録した外部ツールは、ツールを登録したマシンのCM Consoleでのみ起動できます。別のマシンにインストールされたCM Consoleと登録内容を共有することはできません。また、同一マシンであっても異なるログインユーザでCM Consoleを起動した場合には、登録内容を共有することができません。

[ツールの登録/削除]画面では、次の操作を行うことができます。

- 登録

- 詳細/変更

- 削除

l ツールの登録

[ツールの登録]画面を起動します。

各項目を指定し、ツールをCM Consoleに登録します。

1. 「表示名」を入力する。

CM Consoleのタブメニューに表示するツール名称を入力します。

既に登録されているツールと同じ名称を指定することはできません。

表示名の入力可能文字は ((最大20バイト))、((文字コードJIS X 0208)) の文字です。

ただし、先頭の空白、および '\' を指定することはできません。また、末尾の空白は無視されます。

2. アイコンイメージファイルを指定する。

CM Consoleのタブメニューやボタンメニューに表示するアイコンイメージファイルを指定します。

指定できるファイル種別は拡張子が、「gif」「jpg」「jpeg」「bmp」のものです。それ以外のファイルを指定した場合、正しくアイコンが表示されません。

アイコンイメージファイルを指定しない場合やアイコンイメージファイルが存在しない場合は、デフォルトのツールアイコンを使用します。

ファイルのパスにはマルチバイト文字を使用することはできません。

3. 「コマンドライン」を指定する。

「指定」ボタンをクリックすると、[コマンドライン指定]画面を起動します。

・「実行ファイル」を指定する。

CM Consoleが実行するファイル名を指定します。

ファイルのパスにはマルチバイト文字を使用することはできません。

・「引数」を指定する。

コマンドラインに渡す引数を指定します。

指定する順序とパラメータをリストから選択、または入力し、「追加↓」ボタンで一覧に追加してください。

引数は((最大64個))まで指定可能です。

各引数は((最大124バイト))まで指定可能で、マルチバイト文字を使用することはできません。

(例) コマンドプロンプトを起動し、起動ディレクトリのディレクトリ/ファイル一覧を表示する場合、次のように指定します。

実行ファイル | C:\WINNT\system32\CMD.EXE
第1引数 | /K
第2引数 | DIR

4. 「ツール起動方法」を指定する。

登録したツールを起動する際に、HiRDB CMで管理しているHiRDBシステムの情報を使用するかどうかを選択します。

HiRDBシステム情報を使用する場合、起動時に次の画面が表示され、HiRDBシステム情報を選択/指定することができます。

上記の画面を介してツールを起動する場合、コマンドライン、および、環境変数に以下のパラメータを指定することができます。

パラメータ | 内容
%HIRDB_USER% | 起動画面で指定した「認可識別子」「パスワード」
%HIRDB_IP% | 起動画面で選択したHiRDBシステムのIPアドレス
%HIRDB_PORT% | 起動画面で選択したHiRDBシステムのポート番号
%HIRDB_PATH% | 起動画面で選択したHiRDBシステムの運用ディレクトリ

起動方法の違いについては、[外部ツールの起動]を参照してください。

5. 「HiRDBクライアント環境変数」を指定する。

「ツール起動方法」で「ツール起動時にHiRDBシステム情報を使用する」を選択した場合に指定することができます。

登録したツールを起動する際に、HiRDB CMに登録されているHiRDBクライアント環境変数を設定するかどうかを選択します。

HiRDBクライアント環境変数を設定する場合、ツール起動前に[HiRDBクライアント環境変数設定]コマンドで対象とするHiRDBシステムのクライアント環境変数を登録しておいてください。CM Consoleはツール起動時に、登録されているHiRDBクライアント環境変数を環境変数に設定してからツールを起動します。

6. 「環境変数」を指定する。

ツール起動時に設定する環境変数を指定します。

CM Consoleはツール起動時に、一覧に指定されている環境変数を設定してからツールを起動します。

環境変数は((最大128個))まで指定可能です。

各環境変数は、変数名に((最大255バイト))まで、値に((最大1024バイト))まで指定可能で、マルチバイト文字を使用することはできません。

7. ツールを登録する。

登録に成功したツールはタブメニューにアイコンが表示されます。

l ツールの詳細/変更

[ツールの詳細/変更]画面を起動します。

登録済みのツールの設定を変更することができます。変更できる内容については、[ツールの登録]を参照してください。

l ツールの削除

選択したツールの登録情報を削除します。


[環境変数設定]

[HiRDBクライアント環境変数設定]コマンド

外部ツール実行時に有効にするHiRDBクライアント環境変数をCM Serverに登録します。

このコマンドを選択すると、[HiRDBクライアント環境変数設定]画面が表示されます。

1. HiRDBクライアント環境定義の対象となるHiRDBシステムを選択。

· 「HiRDBシステム」

HiRDBクライアント環境定義を登録するHiRDBシステムを選択します。選択できるHiRDBシステムは、HiRDB Control Managerに登録されているシステムのみです。

2. 外部ツール実行時のHiRDBクライアント環境変数を指定する。

次のタブ項目に分類されたHiRDBクライアント環境変数を指定します。HiRDBクライアント環境変数の詳細は、「HiRDB Version 7 UAP開発ガイド　クライアント環境定義の設定内容」を参照してください。

· 「通信」タブ

HiRDBクライアントと接続するHiRDBシステム間の通信に関する環境定義を指定します。

· 「トレース」タブ

HiRDBクライアントのトレース情報に関する環境定義を指定します。

· 「SQL」タブ

HiRDBクライアントが扱うSQLに関する環境定義を指定します。

· 「統計」タブ

HiRDBクライアントが扱う統計情報に関する環境定義を指定します。

· 「排他」タブ

HiRDBクライアントの排他制御に関する環境定義を指定します。

3. [登録]ボタンをクリック。

指定したシステムへ設定したHiRDBクライアント環境定義情報を登録します。

<注意事項>

· 外部ツール起動時にHiRDBクライアント環境変数が有効になるのは、ツールの登録時に「ツール起動時にHiRDBシステム情報を使用する」を選択していた場合のみです。「ツール起動時にHiRDBシステム情報を使用しない」としたツールに対しては、本画面で設定した環境変数は有効になりません。

· 本画面でチェックボックスをONにしない項目、および、本画面にない項目については、システム環境変数、または、HiRDB.iniファイルの設定が有効になります。


[HiRDB簡易セットアップ]

[HiRDB簡易セットアップ]コマンド

本コマンドはHiRDB CM - Console 08-01以前で使用できます。08-02以降は、外部ツールとしてHiRDBセットアップコマンドを登録してください。

HiRDB簡易セットアップコマンド(pdisetup.exe)を実行します。

<前提条件>

· HiRDB CM - ConsoleからHiRDB簡易セットアップコマンドを実行する場合、Consoleのインストールディレクトリの直下にHiRDBセットアップディレクトリに作成されるPDISETUPフォルダ/ディレクトリをコピーしておく必要があります。Consoleのインストールディレクトリの直下に本ディレクトリとその内容がコピーされていない場合は、サブメニューに[HiRDB簡易セットアップ]コマンドは表示されません.。


[SQL Executer]

[SQLExecuter]コマンド

HiRDB SQL Executerを実行します。

このコマンドを選択すると、[SQL Executerの起動]画面が表示されます。

<前提条件>

· HiRDB Control Manager - Consoleがインストールされているマシン上にHiRDB SQL Executerがインストールされていなければなりません。このHiRDB SQL Executerは、実行可能な環境となっている必要があります。HiRDB SQL Executer実行環境につきましては、HiRDB SQL Executer readme.txt等を参照してください。

1. HiRDB SQL Executerを接続するための情報を入力する。

以下の3つの項目に対して情報を指定します。

· 「HiRDBシステム」

接続するHiRDBシステム、またはXDM/RDシステムを選択します。選択できるHiRDBシステムまたは、XMD/RDシステムは、HiRDB　Control Managerに登録されているシステムのみです。

· 「認可識別子」

管理するHiRDBシステムでDBの操作権限をもつユーザの認可識別子を指定してください。

認可識別子は((最大8文字))です。大文字/小文字は区別されるのでダブルコーテーションで囲む必要はありません。

· 「パスワード」

管理するHiRDBシステムでDBの操作権限をもつユーザのパスワードを指定してください。

パスワードは((最大30文字))です。大文字/小文字は区別されるのでダブルコーテーションで囲む必要はありません。

2. SQL Executer起動時のHiRDBクライアント環境設定を行う場合は、[環境設定]ボタンをクリックする。

このボタンを押すと、[実行環境設定]画面が開き、HiRDB SQL Executerの動作時に使用するHiRDBクライアント環境変数を設定することができます。

3. [実行]ボタンをクリック。

指定したシステムへ接続するHiRDB SQL Executerを起動します。

<注意事項>

· HiRDB CMで管理しているHiRDBシステムまたは、XDM/RDに対してのみ接続できます。

· HiRDB SQL Executerを起動する場合には、HiRDB SQL Executerの他にHiRDBクライアントが必要です。前提となるHiRDBクライアントのバージョンは、ご使用になるHiRDB SQL Executerのreadme.txtまたは、ソフトウエア添付資料を参照してください。また、PATHシステム環境変数に、HiRDBクライアントのライブラリが格納されているディレクトリを設定しておく必要があります。


[SQL TA]

[SQL TA]コマンド

HiRDB SQL Tuning Advisorを実行します。

このコマンドを選択すると、[SQL TAの起動]画面が表示されます。

<前提条件>

· HiRDB Control Manager - Consoleがインストールされているマシン上にHiRDB SQL Tuning Advisorがインストールされていなければなりません。このHiRDB SQL Tuning Advisorは、実行可能な環境となっている必要があります。HiRDB SQL Tuning Advisor実行環境につきましては、HiRDB SQL Tuning Advisor readme.txt等を参照してください。

1. HiRDB SQL Tuning Advisorを接続するための情報を入力する。

以下の3つの項目に対して情報を指定します。

· 「HiRDBシステム」

接続するHiRDBシステムを選択します。選択できるHiRDBシステムは、Control Managerに登録されているシステムのみです。

· 「認可識別子」

管理するHiRDBシステムでDBの操作権限をもつユーザの認可識別子を指定してください。

認可識別子は((最大8文字))です。大文字/小文字は区別されるのでダブルコーテーションで囲む必要はありません。

· 「パスワード」

管理するHiRDBシステムでDBの操作権限をもつユーザのパスワードを指定してください。

パスワードは((最大30文字))です。大文字/小文字は区別されるのでダブルコーテーションで囲む必要はありません。

2. SQL Tuning Advisor起動時のHiRDBクライアント環境設定を行う場合は、[環境設定]ボタンをクリックする。

このボタンを押すと、[実行環境設定]画面が開き、HiRDB SQL Tuning Advisorの動作時に使用するHiRDBクライアント環境変数を設定することができます。

3. [実行]ボタンをクリック。

指定したシステムへ接続するHiRDB SQL Tuning Advisorを起動します。

<注意事項>

· HiRDB CMで管理しているHiRDBシステムに対してのみ接続できます。

· HiRDB SQL Tuning Advisorを起動する場合には、HiRDB SQL Tuning Advisorの他にHiRDBクライアントが必要です。前提となるHiRDBクライアントのバージョンは、ご使用になるHiRDB SQL Tuning Advisorのreadme.txtまたは、ソフトウエア添付資料を参照してください。また、PATHシステム環境変数に、HiRDBクライアントのライブラリが格納されているディレクトリを設定しておく必要があります。


[管理HiRDB]タブ

[管理HiRDB]タブには、以下のようなコマンドがあります。

[管理HiRDBの新規登録]

[管理HiRDB一覧/変更]

[管理HiRDBの解除]

<注意事項>

· XDM/RDの登録を行う場合は、本文中および操作画面の"HiRDB"を"XDM/RD"に置き換えて参照してください。


[管理HiRDB新規登録]

[管理HiRDBの新規登録]コマンド

HiRDB CMで管理するHiRDBシステムの登録を行います。

このコマンドを選択すると、[管理HiRDBの新規登録]画面が表示されます。

<前提条件>

· 新規で追加するHiRDBシステムには、HiRDBシステムが存在するサーバマシンにAgentをインストールしている必要があります。入力した情報の先にAgentが存在しない場合はエラーとなり、指定したHiRDBシステムの追加ができません。

· 新規に追加するHiRDBシステムは正常起動の状態にしておいてください。それ以外の状態の場合、HiRDB CMはエラーを返し登録が失敗します。

1. 新たに管理するHiRDBシステムの情報を入力する。

以下の3つの中からいずれかを選択し、対応した情報を指定します。

· 「IPアドレス」

  追加するHiRDBシステムに対して設定したAgentのIPアドレスを入力します。設定範囲は各((0～255))の間で入力できます。

  HiRDBシングルサーバまたは、HiRDBパラレルサーバのMGRユニットが系切り替え構成を使用している場合、CM Agentが使用するサービスIPを指定してください。

· 「ホスト名」

ホスト名は((最大64文字))まで指定可能です。

(1). HiRDB/シングルサーバの場合:

追加するHiRDBシステムのHiRDBシングルサーバホスト名を入力します。

(2). HiRDB/パラレルサーバの場合:

追加するHiRDBシステムのマネジャユニットがあるホスト名を入力します。

  HiRDBシングルサーバまたは、HiRDBパラレルサーバのMGRユニットが系切り替え構成を使用している場合、CM Agentが使用するサービスIPに対応するホスト名を指定してください。

· 「ドメイン名」

追加するHiRDBシステムが存在するコンピュータのフルドメイン名 (xxx@xx.xx) を入力してください。

ドメイン名は((最大255文字))まで指定可能です。

  HiRDBシングルサーバまたは、HiRDBパラレルサーバのMGRユニットが系切り替え構成を使用している場合、CM Agentが使用するサービスIPに対応するドメイン名を指定してください。

2. Agentの「ポート番号」を入力する。

新たに登録するHiRDBシステムが存在するマシンにインストールしたAgentのポート番号を入力します。

設定範囲は((5001～65535))の間で入力できます。

3. 「デバイス情報の取得する」チェックボックスを選択する。

HiRDBシステムを登録すると同時にデバイス情報も取得する場合にチェックをします。デバイス情報については、[解説編] > [HiRDB CMが管理する情報]を参照してください。

4. [OK]ボタンをクリック。

指定したHiRDBシステムを管理登録します。

<注意事項>

· HiRDB CMで既に管理しているHiRDBシステムの登録はできません。

· NetBackup用Agentをインストールしている場合:

NetBackup用Agentは各管理HiRDBにインストールされたAgentからの要求のみを受け付け処理を行います。従って、NetBackup用AgentはHiRDB CMに登録する必要はありません。

· XDM/RDを登録する場合は、XDM/RDを管理するために設定したXDM/RD用Agentをインストールしたマシンに対する情報を指定して下さい。

· 「デバイス情報を取得する」チェックボックスを選択しない場合は、登録後のHiRDBシステムに対して次の操作ができません。

・[マップ]-[デバイス]画面にデバイス情報は表示できません。

・[バックアップ]-[ウイザード]画面で「取得対象」に「デバイス」を選択した場合、対象とするデバイス情報は表示されません。

・[参照?]ボタンで表示される[ファイル/ディレクトリ一覧]画面で「ドライブ」項目を選択することができません。

・[マップ]-[リソース関係表]画面に情報が表示できません。また,情報を保存できません。

HiRDB登録後に、これらの操作を使用する場合は、[オプション]-[管理情報の更新]画面で、「情報種別」の「デバイス情報」を選択し、実行してください。管理情報更新完了後に上記操作が可能となります。

この機能で登録したHiRDBシステムは、次のコマンドで管理を解除することができます。

[管理HiRDBの解除]コマンド


[管理HiRDB一覧/変更]

[管理HiRDB一覧/変更]コマンド

管理されたHiRDBの管理情報の表示/変更を行います。

このコマンドを選択すると、[管理HiRDB一覧/変更]のリストが表示されます。

この機能は、管理しているHiRDBシステムに別称を付けることができます。ここで付けたニックネームは、HiRDB CM内でHiRDBシステム名の代わりに表示されます。

新規に管理登録した直後はデフォルトで、<<HiRDBシステムID(IPアドレス_Agent ポート番号)>>となっています。

このコマンドは自動で最新の状態に更新されません。

最新の情報を表示するには、この[管理HiRDB一覧/変更]コマンドを再実行するか、あるいは[F5]キーを押下することで最新の状態へ更新することができます。

1. 変更したいHiRDBシステムをリストから選択する。

ここで、ニックネームの変更を行いたいHiRDBシステムを選択し、ダブルクリックあるいは[実行]ボタンをクリックします。

2. [HiRDBニックネームの変更]画面の表示。

3. 「新ニックネーム」を入力する。

任意のニックネームを入力してください。ただし、既にHiRDB CMで使用されているニックネーム名は指定できません。

ニックネームは((最大100文字))まで指定でき、全角文字の使用が可能です。

3. [OK]ボタンをクリック。

ニックネームを変更します。

<注意事項>

· ニックネームにシングルコーテーション(')は使用しないでください。


[管理HiRDBの解除]

[管理HiRDBの解除]コマンド

管理しているHiRDBシステムを、HiRDB CMの管理から解除します。

このコマンドを選択すると、[管理HiRDBの解除]画面が表示されます。

このコマンドは自動で最新の状態に更新されません。

最新の情報を表示するには、この[管理HiRDBの解除]コマンドを再実行するか、あるいは[F5]キーを押下することで最新の状態へ更新することができます。

1. 解除したいHiRDBシステムをリストから選択する。

2. [解除]ボタンをクリック。

選択したHiRDBシステムをHiRDB CMの管理から解除します。

また、[Delete]キーを押下することでも解除ができます。

このコマンドで解除したHiRDBシステムは、同HiRDB CMシステムに再登録することができます。また、異なるHiRDB CMシステムに登録することもできます。

<注意事項>

· この[管理HiRDBの解除]コマンドを実行すると、解除を行ったHiRDBで作成した全てのカタログ及びスケジュール情報が削除されます。それらの情報は、再生及び再利用することはできません。

· HiRDBシングルサーバまたは、HiRDBパラレルサーバのMGRユニットが系切り替え構成を使用している場合、HiRDB停止中または、当該ユニットが現用系で稼動中の時のみ実行可能です。


[監視]タブ

[監視]タブには、以下のようなコマンドがあります。

[リソース警告値の設定]

[HiRDBメッセージ監視]


[リソース警告値の設定]

[リソース警告値の設定]コマンド

各リソースの警告表示を行うしきい値を設定します。

このコマンドを選択すると、リソース警告値の設定画面を表示します。

しきい値の種類には、「注意」、「警告」の2種類が設定できます。それぞれのしきい値を越えたリソースを表示する場合、「注意」値を越えていれば「黄色」で表示され、「警告」値を越えていれば「オレンジ色」で表示されます。

次のリソースに対してしきい値の設定を行うことができます。

· 「RDエリアセグメント使用率」

RDエリアのセグメント使用率に対して「注意」「警告」値を指定できます。

しきい値を越えたRDエリアに対しては、[システムステータス]>[詳細]>[RDエリア詳細情報]表示、[マップ]>[RDエリア]表示または、[マップ]>[表]>拡張情報表示時に該当するしきい値色で強調表示されます。

ここで指定した値は、[自動データメンテナンス]機能の基準値として使用される場合があります。

· 「グローバルバッファヒット率」

グローバルバッファのヒット率に対して「注意」「警告」値を指定できます。

しきい値を越えたグローバルバッファに対しては、[システムステータス]>[詳細]>[グローバルバッファ情報]表示時に該当するしきい値色で強調表示されます。

グローバルバッファヒット率では、ヒット率が0%の時は、警告表示を行いません。1%以上の場合についてのみ警告表示を行います。

· 「HiRDBファイルシステム領域使用率」

HiRDBファイルシステム領域の使用率に対して「注意」「警告」値を指定できます。

しきい値を越えたHiRDBファイルシステム領域に対しては、[マップ]>[HiRDBファイルシステム領域]表示時に該当するしきい値色で強調表示されます。

· 「利用可能システムログファイル数」

利用可能なシステムログファイル残数に対して「注意」「警告」値を指定できます。

しきい値を越えたシステムログファイルに対応するサーバ情報に対しては、[システムステータス]>[詳細]>[システムログファイル詳細情報]表示、または、[アンロードログ管理]>[システムログの状態変更]表示、[アンロードログ管理]>[システムログのアンロード]表示、[アンロードログ管理]>[システムログのスワップ]表示時に該当するしきい値色で強調表示されます。

· 「HiRDB運用ディレクトリ(PDDIR)が含まれるディスクの使用率」

HiRDB運用ディレクトリが含まれるディスクの使用率に対して「注意」「警告」値を指定できます。

しきい値を越えたHiRDB運用ディレクトリに対しては、[システムステータス]>[詳細]>[ユニット詳細情報]表示時に該当するしきい値色で強調表示されます。

· 「排他資源管理テーブル使用率」

排他資源管理テーブル使用率に対して「注意」「警告」値を指定できます。

しきい値を越えた場合、[システムステータス]>[詳細]>[排他資源情報]表示時に該当するしきい値色で強調表示されます。

· 「CPU使用率」

HiRDBの各ユニットマシンのCPU使用率に対して「注意」「警告」値を指定できます。

しきい値を超えたCPU使用率に対しては、[システムステータス]>[詳細]>[ユニット詳細情報]表示時に該当するしきい値色で強調表示されます。

· 「メモリ使用量」

HiRDBの各ユニットマシンのメモリ使用量に対して「注意」「警告」値を指定できます。

しきい値を超えたに対しては、[システムステータス]>[詳細]>[ユニット詳細情報]表示時に該当するしきい値色で強調表示されます。

· 「共用メモリ使用量」

HiRDBの各ユニットマシンの共用メモリ使用量に対して「注意」「警告」値を指定できます。

しきい値を超えた共用メモリ使用量に対しては、[システムステータス]>[詳細]>[ユニット詳細情報]表示時に該当するしきい値色で強調表示されます。

· 「メッセージキュー使用数」

HiRDBの各ユニットマシンのメッセージキュー使用数に対して「注意」「警告」値を指定できます。

しきい値を超えたメッセージキュー使用数に対しては、[システムステータス]>[詳細]>[ユニット詳細情報]表示時に該当するしきい値色で強調表示されます。

· 「HiRDBメッセージ」

[システムステータス]>[詳細]>[システムログ情報]表示で表示されるメッセージの中で、HiRDBが出力するメッセージを強調表示を行う場合のしきい値を指定できます。HiRDBのメッセージのエラーレベルに対応する「-、I、,W、E」のいずれかの値を「注意」「警告」値として選択できます。「-」を選択した場合は、強調表示を行いません。


[HiRDBメッセージ監視]

[HiRDBメッセージ監視]コマンド

このコマンドを選択するとHiRDBメッセージ監視画面を表示します。

HiRDBメッセージ監視画面では、次の４つのことが実行できます。

§ HiRDBメッセージ監視の設定

§ HiRDBメッセージ監視の開始/停止

§ HiRDBメッセージ監視結果の一覧表示

§ HiRDBメッセージ監視結果の削除

l HiRDBメッセージ監視の設定

  [HiRDBメッセージ監視]画面で[監視設定]ボタンを押すと、監視設定画面を表示します。この画面では、HiRDBメッセージ監視で使用する監視項目の設定を行います。この操作は、監視を行っていない場合にのみ実行できます。

1. 前回履歴情報の削除の選択。

HiRDBメッセージ監視開始時に前回までに検出したHiRDBメッセージを一覧から全ての削除する場合に選択します。

2. 監視間隔の設定。

HiRDBメッセージの監視を行う間隔を設定します。

3. 監視対象メッセージIDの選択。

監視を行うHiRDBメッセージを選択します。監視を行うHiRDBメッセージのチェックボックスをチェックにしてください。監視対象に設定できるHiRDBメッセージの一覧については、[解説編] > [HiRDBメッセージ監視]を参照してください。

4. HiRDBメッセージ監視設定を更新。

[設定]ボタンを押すと、HiRDBメッセージ監視の設定が更新されます。

<注意事項>

· HiRDBメッセージ監視機能は、HiRDB CM Agentバージョンが08-00以降の場合に、使用できます。HiRDB CM Agentバージョンが08-00未満の場合は、メッセージ一覧が表示されません。

l HiRDBメッセージ監視の開始/停止

[HiRDBメッセージ監視]画面で[開始]ボタンを押すと、HiRDBメッセージ監視が開始されます。[停止]ボタンを押すと、HiRDBメッセージ監視が停止されます。

l HiRDBメッセージ監視結果の一覧表示

[HiRDBメッセージ監視]画面では、HiRDBメッセージ監視で検出したHiRDBメッセージの一覧が表示されます。表示されたメッセージを選択し、アイコンボタンを押すことで、メッセージのより詳細な情報を確認できます。アイコンボタンとその動作について、次に記載します。

§ [image] データベース状態解析

メッセージに含まれるRDエリアまたは、表に対してデータベース状態解析を行います。

§ [image] 情報ファイル表示

メッセージに含まれる情報ファイルを表示します。表示する情報ファイルについては、[解説編] > [HiRDBメッセージ監視]を参照してください。

§ [image] HiRDBメッセージ詳細表示

対象のHiRDBメッセージの詳細の説明を表示します。

<注意事項>

· HiRDBメッセージはHiRDB CM Serverインストール時に指定した管理情報規模に応じて、規定の件数分のデータだけが保存されます。保存されるデータ数は、小規模（標準）の場合は、1HiRDBシステムで500件、大規模の場合は、１HiRDBシステム5000件です。規定件数以上のHiRDBメッセージを検知した場合は、最も古いHiRDBメッセージが自動的に削除されます。

· 管理対象HiRDBが系切り替え構成を使用している場合、現用系マシンで出力されたメッセージが対象になります。予備系で出力されたメッセージは収集できません。

· 情報ファイルは、次の契機で削除されます。削除された場合、情報ファイルの表示はできません。

  ・ [システムステータス] > [詳細] > [ユニット詳細情報] > [クリーンアップ]を実行すると、情報ファイルが削除されます。

  ・ HiRDBのpdcspoolコマンドを実行した場合、情報ファイルが削除される場合があります。

pdcspoolの詳細は、HiRDBのマニュアル「コマンドリファレンス」を参照してください。

  ・ HiRDBのシステム定義ファイル(pdsys)にpd_spool_cleanup、pd_spool_cleanup_intervalを指定し、pd_spool_cleanup_interval_level、pd_spool_cleanup_levelの情報種別にallを指定している場合、指定された契機で情報ファイルが削除されます。各オペランドの詳細は、HiRDBのマニュアル「システム定義」を参照してください。

l HiRDBメッセージ監視結果の削除

  [HiRDBメッセージ監視]画面で[履歴の削除]ボタンを押すと履歴の削除画面を表示します。この画面では、HiRDBメッセージ監視で検出したHiRDBメッセージの中から不要なメッセージを削除することができます。

1. HiRDBメッセージの削除条件を指定。

§ すべてのHiRDBメッセージを削除する場合

削除範囲ラジオボタングループの中から、「すべて」ラジオボタンを選択します。

§ 特定のHiRDBメッセージを削除する場合

削除範囲ラジオボタングループの中から、「HiRDBメッセージ指定」ラジオボタンを選択し、コンボボックスから対象のHiRDBメッセージを選択します。

§ 時間を指定してHiRDBメッセージを削除する場合

削除範囲ラジオボタングループの中から、「時間指定」ラジオボタンを選択し、時間を指定します。指定した時間以前のすべてのHiRDBメッセージが削除対象になります。

2. 検出したHiRDBメッセージの削除。

[削除]ボタンを押すと、指定された条件に該当するHiRDBメッセージが削除されます。


連携編

目次

連携編

この章では、HiRDB　CMとJP1/AJS2などの他製品との連携機能について説明します。

＜この章の構成＞

· カタログ実行コマンド連携

· JP1/AJS2連携

· JP1/AJS2-SO連携


カタログ実行コマンド連携

  カタログ実行コマンドを実行することによりHiRDB CMで作成したカタログをコマンドラインで実行することができます。また、HiRDBシステム全体の正常開始・正常停止を実行することができます。

JP1/AJS2、JP1/AJS2-SOと連携することで、HiRDBの運用を自動化することができます。

l カタログ実行コマンド

  カタログ実行コマンドの詳細を説明します。

[インストールディレクトリ]

｛CMServerインストールディレクトリ｝\bin

[コマンド名]

CmsCtlgCmd.exe

[戻り値]

0：成功

4：警告終了

8：エラー終了

[処理結果]

処理結果を標準エラー出力に出力されます。

[引数]

CmsCtlgCmd.exe -m ?host? -i ?hirdbid? -t ?ctlgtype? [-c ?ctlgname?]

?host?: HiRDBシステムホスト名称を指定します。(MGRノードのホスト名)

?hirdbid?: HiRDB識別子を指定します。

?ctlgtype?: カタログ種別 以下のいずれかを指定します。

backup : 通常バックアップ用カタログを実行する場合に指定します。

diffbkup : 差分バックアップ用カタログを実行する場合に指定します。

netbkup : ネットバックアップ用カタログを実行する場合に指定します。

rstr : リカバリ用カタログを実行する場合に指定します。

fsbkup : HiRDBファイルシステム領域単位のバックアップ用カタログを実行する場合に指定します。

fsrstr : HiRDBファイルシステム領域単位のリカバリ用カタログを実行する場合に指定します。

unload : システムログのアンロード用カタログを実行する場合に指定します。

logchg : システムログの状態変更用カタログを実行する場合に指定します。

pdrorg : データベースの再編成用カタログを実行する場合に指定します。

pdload : データベースの作成用カタログを実行する場合に指定します。

reclaim : 空きページ解放ユティリティ用カタログを実行する場合に指定します。

logopen : システムログのオープン用カタログを実行する場合に指定します。

logcls : システムログのクローズ用カタログを実行する場合に指定します。

logex : システムログの拡張用カタログを実行する場合に指定します。

logrm : システムログの削除用カタログを実行する場合に指定します。

stsopen : ステータスファイルのオープン用カタログを実行する場合に指定します。

stscls : ステータスファイルのクローズ用カタログを実行する場合に指定します。

stsex : ステータスファイルの作成用カタログを実行する場合に指定します。

stsrm : ステータスファイルの削除用カタログを実行する場合に指定します。

start : HiRDBシステムの開始用カタログを実行する場合に指定します。

stop : HiRDBシステムの停止用カタログを実行する場合に指定します。

?ctlgname?: カタログ名を指定します。ctlgtypeが?start?または?stop?の場合は指定する必要はありません。

[実行権限]

アドミニストレータ権限

<注意事項>

·?host?パラメータは、HiRDBシステム共通定義(pdsys)に書かれているMGRユニットのホスト名を指定下さい。また、MGRユニットがスタンバイ型系切り替え構成の場合は、MGRユニットの現用系ホスト名を指定してください。

·実行されるカタログは、実行時にCM Serverに登録されているカタログになります。JP1/AJS2などでスケジュールする場合、スケジュール登録後に当該カタログを変更すると変更されたカタログが実行されます。

·CM　Serverがインストールされているマシン上でのみ実行することができます。

l JP1/AJS2との連携例

  JP1/AJS2と連携してスケジュール・実行・実結果確認するまでの操作手順について説明します。

1.構成

  カタログ実行コマンドを使用したJP1/AJS2との連携構成の一例を以下の図に示します。

２.操作手順

カタログ実行コマンドを用いて、HiRDB Control Managerで作成したすべてのカタログをJP1/AJS2のジョブとしてスケジュール・実行・実行結果確認するまでの操作手順について説明します。

１.HiRDB　CMでのカタログ作成

２.JP1/AJS2によるジョブネット作成

  ３.JP1/AJS2によるジョブ実行・結果確認

１.HiRDB　CMでのカタログ作成

HiRDB CMで任意のカタログを作成してください。

２.JP1/AJS2-Viewによるジョブネットの作成

  JP1/AJS2-Viewを使用してジョブネットを作成します。ジョブネットの作成方法については、JP1/AJS2のマニュアルを参照してください。

  ジョブネットの作成例を以下の図に示します。

①：HiRDB　CM　Serverのホスト名を指定します。

  ②：カタログ実行コマンドをフルパスで指定します。

  ③：カタログ実行コマンドの引数を指定します。

  ④：しきい値の設定を行います。カタログ実行コマンドは、警告終了時に４、異常終了時に８でコマンドを終了します。

３.JP1/AJS2によるジョブ実行・結果確認

  JP1/AJS2　-Viewを使用して、実行/実行結果の確認を行ってください。各ジョブの実行詳細には、KFPE形式のメッセージが表示されます。メッセージの詳細は、本ヘルプの「メッセージの説明」を参照してください。


JP1/AJS2連携

  HiRDB CMでは、JP1/AJS2を使用してHiRDBの操作をスケジュールすることができます。JP1/AJS2との連携方法として次の２つの方法があります。

§ HiRDB　CMのカタログ実行コマンドをJP1/AJS2のジョブとして登録する方法

§ JP2/AJS2のカスタムジョブ機能を使用する方法

  それぞれの連携方法を以下に説明します。

l HiRDB CMのカタログ実行コマンドをJP1/AJS2のジョブとして登録する方法

カタログ実行コマンドは、HiRDB　CMで作成したカタログ（一部操作）をコマンドで実行する機能です。カタログ実行コマンドは、HiRDB CM - Serverインストール時、自動的にマシンへインストールされます。JP1/AJS2のPCジョブ、UNIXジョブとしてこのコマンドを登録することでスケジュールが可能になります。カタログ実行コマンドの詳細、JP1/AJS2のジョブとしての登録方法は、[連携編] > [カタログ実行コマンド] を参照してください。

  この連携方法は、次のようなメリットがあります。

§ 管理対象のHiRDBがUNIXの場合にも使用できます。

§ HiRDB CMでサポートしている全てのカタログをJP1/AJS2のジョブとして登録することができます。

§ HiRDBが稼動しているマシン上にJP1/AJS2-Agentをインストールする必要がありません。複数のHiRDBを管理している場合でも、HiRDB CM - Serverがインストールされているマシンに１台JP1/AJS2をインストールするだけですべてのHiRDBマシンに対するジョブネットの作成が行えます。

§ カタログ実行以外にも、HiRDBシステムの正常開始、正常停止操作をジョブとして登録できます。

§ HiRDB CM - Consoleからカタログ作成を行う以外の特別な操作（JP1/ASJ2連携登録）が必要ありません。

§ JP1/AJS2-Viewを任意のマシンにインストールすることができます。

l HiRDB CMのカタログ実行コマンドをJP1/AJS2のカスタムジョブとして登録する方法

  JP1/ASJ2カスタムジョブ連携は、JP1/AJS2のカスタムジョブ機能を使用した連携です。カスタムジョブについては、JP1/AJS2のマニュアルを参照してください。この連携では、HiRDB CM - Agentインストール時に同じマシンにカスタムジョブ連携用のHiRDB　CM - Agentがインストールされます。JP1/AJS2カスタムジョブ連携の詳細、登録方法については、次のリンク先で説明を行います。[連携編] > [JP1/AJS2連携] > [JP1/AJS2カスタムジョブ連携]

  この連携方法は、次のようなメリットがあります。

§ HiRDBのマシン上にのみ、JP1/AJS2-Agentまたは、Managerをインストールできる場合に使用できます。

§ 管理対象のHiRDBのOSがWindowsの場合にのみ使用できます。（JP1/AJS2のカスタムジョブがWindowsだけのサポートであるため）

§ JP1/AJS2-Viewでジョブの設定するときにコマンドラインを入力する必要がなくなります。


JP1/AJS2-SO連携

  HiRDB CMは、JP1/Automatic Job Management System 2 - Scenario Operation Mangerとシナリオテンプレートによる連携を行っています。シナリオテンプレートの使用方法については、JP1/AJS2マニュアル「JP1/Automatic Job Management System 2 - Scenario Operation」を参照してください。

  ここでは、JP1/AJS2-SOと連携を行う場合の構成とHiRDB CMが提供するシナリオテンプレートの種類について説明します。

l JP1/AJS２-SO連携構成

  JP1/AJS2 - SOと連携を行う場合の構成の一例を以下の図に示します。

  HiRDB CM - ServerとJP1/AJS2 - Managerまたは、Agentは同じマシン上に必ずインストールしてください。HiRDB CM - ServerとJP1/AJS2 - SOを別マシン上にインストールする場合は、シナリオテンプレートをJP1/AJS2-SOマシン上にコピーして使用してください。シナリオテンプレートからシナリオを登録する場合は、シナリオの実行マシンは、HiRDB CM - Serverのインストールされたマシンを指定する必要があります。

l シナリオテンプレート

  HiRDB CMが提供するシナリオテンプレート定義ファイルは次に示すファイルです。このファイルはHiRDB　CMServerをインストールしたときに作成されます。

(インストールフォルダ)\link\JP1AJS2\ScenarioTemplate\HiRDB.sjis.xml

  このシナリオテンプレート定義を読み込むと、JP1/AJS2-SOで次に示すシナリオライブラリフォルダ名にシナリオテンプレートが作成されます。

/ScenarioLibrary/HiRDB

  HiRDB CMで提供するシナリオテンプレートの種類を次に示します。

項番 | 名称 | 機能概要
１ | MOVE_SERVER | 影響負荷分散型系切り替え機能を使用をしようしているHiRDBシステムに対して、バックエンドサーバの移動を行います。
２ | NORMAL_START_SYSTEM | 系切り替え機能を使用していないHiRDBシステムに対して正常開始を行います。
３ | NORMAL_STOP_SYSTEM | 系切り替え機能を使用していないHiRDBシステムに対して正常停止を行います。
４ | FOURCE_STOP_SERVER | サーバの単独強制停止を行います。
５ | ENABLE_TRAN_QUEUEING | 影響負荷分散型系切り替え機能を使用をしようしているHiRDBシステムに対して、対象のサーバのトランザクションキューイング機能を開始します。
６ | DISABLE_TRAN_QUEUEING | 影響負荷分散型系切り替え機能を使用をしようしているHiRDBシステムに対して、対象のサーバのトランザクションキューイング機能を正常停止します。
７ | FORCE_DISABLE_TRAN_QUEUEING | 影響負荷分散型系切り替え機能を使用をしようしているHiRDBシステムに対して、対象のサーバのトランザクションキューイング機能を強制停止します。

§ MOVE_SERVER

（１）名称

MOVE_SERVER

（２）概要

影響分散型スタンバイレス系切り替え環境下のバックエンドサーバをHAグループ内の他ユニットへ移動します。

（３）機能

バックエンドサーバの他ユニットへの移動をオンラインで実現します。本シナリオテンプレートでは、指定したHiRDBシステムに対して以下の操作を行います。

a. HiRDBシステムが正常稼動していることを確認します。

b. 移動対象サーバが稼動していることを確認します。

c. 移動対象サーバが移動先ユニットに対するホスト上で待機状態であることを確認します。

d. 移動対象サーバのトランザクションキューイングを開始します。

e. 移動対象サーバを強制停止します。

f. 対象サーバを移動先ユニットに対するホスト上で正常開始します。

g. 対象サーバのトランザクションキューイングを解除します。

（４）入力シナリオ変数

項番 | 入力シナリオ変数 | 説明
１ | hirdbcmhost | HiRDB Control Manager - Serverのホスト名を指定します。
２ | hirdbcmdir | HiRDB Control Manager - Serverのインストールディレクトリを指定します。
３ | host | 対象HiRDBのマネージャユニットに対するホスト名を指定します。
４ | hirdbid | 対象HiRDBのシステムIDを指定します。
５ | server | 移動するバックエンドサーバ名を指定します。影響分散型スタンバイレス系切り替え環境で構築されたユニット上のバックエンドサーバを指定してください。
６ | svrhost | 移動先ユニット名を指定します。

（５）出力シナリオ変数

項番 | 入力シナリオ変数 | 説明
１ | acthost | シナリオ実行時に対象バックエンドサーバが稼動していたユニットに対するホスト名が設定されます。

（６）前提ＯＳ

HiRDB Control Manager - Server がサポートするＯＳ

（７）前提プログラム

(ａ)CM Agentを管理、操作する以下のCM Consoleが必要です。

R-15434-11 HiRDB Control Manager - Console 03-00以降

(ｂ)CM Agentを管理する以下のCM Serverが必要です。

R-15434-21 HiRDB Control Manager - Server 03-00以降

(ｃ)HiRDBサーバを管理する以下のいずれかのCM Agentが必要です。

R-15434-31 HiRDB Control Manager - Agent 03-00以降

R-1S434-31 HiRDB Control Manager - Agent 03-00以降

R-18434-31 HiRDB Control Manager - Agent 03-00以降

R-1M434-31 HiRDB Control Manager - Agent 03-00以降

R-19434-31 HiRDB Control Manager - Agent 03-00以降

R-15434-318 HiRDB Control Manager - Agent 03-00以降

R-18434-31J HiRDB Control Manager - Agent 03-00以降

R-1S434-31V HiRDB Control Manager - Agent 03-00以降

(ｄ)監視対象となる以下のいずれかのHiRDBが必要です。

P-1M62-1371 HiRDB/Parallel Server Version 7 07-02以降

P-1M62-1771 HiRDB/Parallel Server Version 7 (64) 07-02以降

P-1B62-1371 HiRDB/Parallel Server Version 7 07-02以降

P-1J62-1571 HiRDB/Parallel Server Version 7 (64) 07-02以降

P-9S62-1371 HiRDB/Parallel Server Version 7 07-02以降

P-9V62-1371 HiRDB/Parallel Server Version 7 (64) 07-02以降

P-2462-7374 HiRDB/Parallel Server Version 7 07-02以降

P-2862-7374 HiRDB/Parallel Server Version 7 (64) 07-02以降

(ｅ)HiRDBの影響負荷分散型スタンバイレス系切り替えを構成する

HAモニタ

MS/CS

（８）実行権限

特になし

（９）注意事項

(ａ)本シナリオテンプレートを使用して、HiRDB影響分散型スタンバイレス系切り替え構成以外のバックエンドサーバに対する移動はできません。

(ｂ)本シナリオテンプレートを実行する際は、対象HiRDBが正常稼動している必要があります。

(ｃ)移動対象サーバはあるユニットで正常に稼動している必要があり、移動先ホスト上で待機状態である必要があります。

(ｄ)本シナリオテンプレートで指定する対象HiRDBは、HiRDB Control Managerで管理されている必要があります。

(ｅ)HAモニタ Server定義ファイルのaliasには、HiRDBシステム共通定義で指定されているバックエンドサーバ名称と同一の名称を設定しておく必要が有ります。

(ｆ)hirdbcmhost、host、svrhost入力シナリオ変数は、「シナリオ登録」時に必ず入力してください。これらのシナリオ変数を入力しなかった場合は、JP1/AJS2-SOMの稼働するホスト名称が仮定されます。

(ｇ)トランザクションキューイングジョブでエラーが発生した場合、詳細情報に以下のメッセージが表示されることがあります。以下の何れかのメッセージが表示されている場合は、それぞれの対処方法を実施してください。

KFPS05622-E pdtrnqing command failed、 reason=aa...a、 inf=内部コード

aa...a対応コードと対処方法を次の表に示します。

コード | 内容 | 説明
SINGLE_SERVER | シングルサーバでは実行できません | 本シナリオが実行できるシステム環境ではありません。この環境では実行しないでください。
NOT_AHA_SYSTEM | HiRDBシステムが影響分散スタンバイレス型系切り替え構成でありません。 | 本シナリオが実行できるシステム環境ではありません。この環境では実行しないでください。
NOT_HAGROUP | 影響分散スタンバイレス型系切り替え対象以外のサーバを指定しています。 | 指定するサーバには影響分散型スタンバイレス型系切り替え対象バックエンドサーバを指定して下さい。
NOT_ACTIVE | サーバがコマンド実行ユニットで稼動していません。 | 指定したバックエンドサーバが稼動しているユニットで実行して下さい。または、トランザクションキューイング解除指定をしている場合は、強制解除を指定して下さい。
TIMEOUT_S | トランザクションキューイング開始時に、サーバで実行中のトランザクションが終了するまで待ち合わせましたが、システム共通定義pd_ha_trn_queuing_wait_time時間経過しても、トランザクションが終了しません。 | 指定したバックエンドサーバで稼動しているトランザクションを終了させるか、pdcancelコマンドを対象HiRDBシステム上で直接実行して、実行中のトランザクションをキャンセルして下さい。または、対象HiRDBシステムのシステム共通定義pd_ha_trn_queuing_wait_time指定値を見直して下さい。
TIMEOUT_E | トランザクションキューイング解除時に、サーバの起動完了を待ち合わせましたが、システム共通定義pd_ha_trn_queuing_wait_time時間経過しても、サーバの起動が完了しません。 | サーバの起動を行っている場合は、サーバの起動に失敗していないか確認して下さい。失敗している場合は、エラー要因を取り除いて、サーバを起動して下さい。または、対象HiRDBシステムのシステム共通定義pd_ha_trn_queuing_wait_time指定値を見直して下さい。
PROCESS_MEMORY | プロセス固有メモリが不足しています。 | 不要なプロセスを停止するなどサーバマシン内の使用メモリを減らして、再度シナリオを実行して下さい。

（10）異常時の対処

異常が発生した場合、JP1/AJS2-Viewのジョブネットモニタの結果から異常終了したPCジョブの実行結果詳細に表示されているメッセージを確認してください。メッセージの詳細は、HiRDB Control Manager - ServerのHELPを参照してください。

（11）運用例

サーバ単位の移動を用いた負荷分散の運用例

HIRDBシステムに勤休管理DBをBES1、BES2に構成し、旅費精算DBをBES3、BES4に構成し、月末処理で、旅費精算DBへのアクセスが増加し、勤休管理DBへのアクセスが減少すると想定した場合、本シナリオテンプレートを使用し、BES2を勤休管理DBが稼動するホストへ移動を行うことで、旅費精算DBが稼動するホストの負荷を軽減でき、かつ、勤休管理DBが稼動するホストの資源を一部利用することで旅費精算DBの処理能力を向上することができる。

§ NORMAL_START_SYSTEM

（１）名称

NORMAL_START_SYSTEM

（２）概要

HiRDBシステム全体を正常開始します。

（３）機能

本シナリオテンプレートでは、指定したHiRDBシステムに対して以下の操作を行います。

a. HiRDBシステムの正常開始を行います。

（４）入力シナリオ変数

項番 | 入力シナリオ変数 | 説明
１ | hirdbcmhost | HiRDB Control Manager - Serverのホスト名を指定します。
２ | hirdbcmdir | HiRDB Control Manager - Serverのインストールディレクトリを指定します。
３ | host | 対象HiRDBのマネージャユニットに対するホスト名を指定します。
４ | hirdbid | 対象HiRDBのシステムIDを指定します。

（５）出力シナリオ変数

なし。

（６）前提ＯＳ

HiRDB Control Manager - Server がサポートするＯＳ

（７）前提プログラム

(ａ)CM Agentを管理、操作する以下のCM Consoleが必要です。

R-15434-11 HiRDB Control Manager - Console 03-00以降

(ｂ)CM Agentを管理する以下のCM Serverが必要です。

R-15434-21 HiRDB Control Manager - Server 03-00以降

(ｃ)HiRDBサーバを管理する以下のいずれかのCM Agentが必要です。

R-15434-31 HiRDB Control Manager - Agent 03-00以降

R-1S434-31 HiRDB Control Manager - Agent 03-00以降

R-18434-31 HiRDB Control Manager - Agent 03-00以降

R-1M434-31 HiRDB Control Manager - Agent 03-00以降

R-19434-31 HiRDB Control Manager - Agent 03-00以降

R-15434-318 HiRDB Control Manager - Agent 03-00以降

R-18434-31J HiRDB Control Manager - Agent 03-00以降

R-1S434-31V HiRDB Control Manager - Agent 03-00以降

（８）実行権限

特になし

（９）注意事項

(ａ)本シナリオテンプレートで指定する対象HiRDBは、HiRDB Control Managerで管理されている必要があります。

(ｂ)本シナリオテンプレートでは、pdstartコマンドのみを発行します。HiRDBシステムが系切り替え構成などを使用している場合、別途クラスタの操作が必要になる場合があります。

(ｃ)HAモニタ Server定義ファイルのaliasには、HiRDBシステム共通定義で指定されているバックエンドサーバ名称と同一の名称を設定しておく必要が有ります。

(ｄ)hirdbcmhost、host入力シナリオ変数は、「シナリオ登録」時に必ず入力してください。これらのシナリオ変数を入力しなかった場合は、JP1/AJS2-SOMの稼働するホスト名称が仮定されます。

（10）異常時の対処

異常が発生した場合、JP1/AJS2-Viewのジョブネットモニタの結果から異常終了したPCジョブの実行結果詳細に表示されているメッセージを確認してください。

（11）運用例

DBシステムの定期開始・停止運用

本シナリオテンプレートとNORMAL_STOP_SYSTEMシナリオテンプレートとを組み合わせて使用することで非営業日などのDBシステムの自動停止・開始運用を行えます。

§ NORMAL_STOP_SYSTEM

（１）名称

NORMAL_START_SYSTEM

（２）概要

HiRDBシステム全体を正常停止します。

（３）機能

本シナリオテンプレートでは、指定したHiRDBシステムに対して以下の操作を行います。

a. HiRDBシステムの正常停止を行います。

（４）入力シナリオ変数

項番 | 入力シナリオ変数 | 説明
１ | hirdbcmhost | HiRDB Control Manager - Serverのホスト名を指定します。
２ | hirdbcmdir | HiRDB Control Manager - Serverのインストールディレクトリを指定します。
３ | host | 対象HiRDBのマネージャユニットに対するホスト名を指定します。
４ | hirdbid | 対象HiRDBのシステムIDを指定します。

（５）出力シナリオ変数

なし。

（６）前提ＯＳ

HiRDB Control Manager - Server がサポートするＯＳ

（７）前提プログラム

(ａ)CM Agentを管理、操作する以下のCM Consoleが必要です。

R-15434-11 HiRDB Control Manager - Console 03-00以降

(ｂ)CM Agentを管理する以下のCM Serverが必要です。

R-15434-21 HiRDB Control Manager - Server 03-00以降

(ｃ)HiRDBサーバを管理する以下のいずれかのCM Agentが必要です。

R-15434-31 HiRDB Control Manager - Agent 03-00以降

R-1S434-31 HiRDB Control Manager - Agent 03-00以降

R-18434-31 HiRDB Control Manager - Agent 03-00以降

R-1M434-31 HiRDB Control Manager - Agent 03-00以降

R-19434-31 HiRDB Control Manager - Agent 03-00以降

R-15434-318 HiRDB Control Manager - Agent 03-00以降

R-18434-31J HiRDB Control Manager - Agent 03-00以降

R-1S434-31V HiRDB Control Manager - Agent 03-00以降

（８）実行権限

特になし

（９）注意事項

(ａ)本シナリオテンプレートで指定する対象HiRDBは,HiRDB Control Managerで管理されている必要があります。

(ｂ)本シナリオテンプレートでは,pdstopコマンドのみを発行します。HiRDBシステムが系切り替え構成などを使用している場合,別途クラスタの操作が必要になる場合があります。

(ｃ)HAモニタ Server定義ファイルのaliasには,HiRDBシステム共通定義で指定されているバックエンドサーバ名称と同一の名称を設定しておく必要が有ります。

(ｄ)hirdbcmhost,host入力シナリオ変数は,「シナリオ登録」時に必ず入力してください。これらのシナリオ変数を入力しなかった場合は,JP1/AJS2 - SOMの稼働するホスト名称が仮定されます。

（10）異常時の対処

異常が発生した場合、JP1/AJS2-Viewのジョブネットモニタの結果から異常終了したPCジョブの実行結果詳細に表示されているメッセージを確認してください。

（11）運用例

DBシステムの定期開始・停止運用

本シナリオテンプレートとNORMAL_STOP_SYSTEMシナリオテンプレートとを組み合わせて使用することで非営業日などのDBシステムの自動停止・開始運用を行えます。

§ FOURCE_STOP_SERVER

（１）名称

FOURCE_STOP_SERVER

（２）概要

影響分散型スタンバイレス系切り替え環境下のバックエンドサーバを強制停止します。

（３）機能

本シナリオテンプレートでは、指定したHiRDBシステムに対して以下の操作を行います。

a. 指定サーバの強制停止を行います。

（４）入力シナリオ変数

項番 | 入力シナリオ変数 | 説明
１ | hirdbcmhost | HiRDB Control Manager - Serverのホスト名を指定します。
２ | hirdbcmdir | HiRDB Control Manager - Serverのインストールディレクトリを指定します。
３ | host | 対象HiRDBのマネージャユニットに対するホスト名を指定します。
４ | hirdbid | 対象HiRDBのシステムIDを指定します。
５ | server | 停止するバックエンドサーバ名を指定します。影響分散型スタンバイレス系切り替え環境で構築されたユニット上のバックエンドサーバを指定してください。

（５）出力シナリオ変数

なし。

（６）前提ＯＳ

HiRDB Control Manager - Server がサポートするＯＳ

（７）前提プログラム

(ａ)CM Agentを管理、操作する以下のCM Consoleが必要です。

R-15434-11 HiRDB Control Manager - Console 03-00以降

(ｂ)CM Agentを管理する以下のCM Serverが必要です。

R-15434-21 HiRDB Control Manager - Server 03-00以降

(ｃ)HiRDBサーバを管理する以下のいずれかのCM Agentが必要です。

R-15434-31 HiRDB Control Manager - Agent 03-00以降

R-1S434-31 HiRDB Control Manager - Agent 03-00以降

R-18434-31 HiRDB Control Manager - Agent 03-00以降

R-1M434-31 HiRDB Control Manager - Agent 03-00以降

R-19434-31 HiRDB Control Manager - Agent 03-00以降

R-15434-318 HiRDB Control Manager - Agent 03-00以降

R-18434-31J HiRDB Control Manager - Agent 03-00以降

R-1S434-31V HiRDB Control Manager - Agent 03-00以降

(ｄ)監視対象となる以下のいずれかのHiRDBが必要です。

P-1M62-1371 HiRDB/Parallel Server Version 7 07-02以降

P-1M62-1771 HiRDB/Parallel Server Version 7 (64) 07-02以降

P-1B62-1371 HiRDB/Parallel Server Version 7 07-02以降

P-1J62-1571 HiRDB/Parallel Server Version 7 (64) 07-02以降

P-9S62-1371 HiRDB/Parallel Server Version 7 07-02以降

P-9V62-1371 HiRDB/Parallel Server Version 7 (64) 07-02以降

P-2462-7374 HiRDB/Parallel Server Version 7 07-02以降

P-2862-7374 HiRDB/Parallel Server Version 7 (64) 07-02以降

(ｅ)HiRDBの影響負荷分散型スタンバイレス系切り替えを構成する

HAモニタ

（８）実行権限

特になし

（９）注意事項

(ａ)本シナリオテンプレートを使用して、HiRDB影響分散型スタンバイレス系切り替え構成以外のバックエンドサーバに対する移動はできません。

(ｂ)本シナリオテンプレートを実行する際は、対象HiRDBが正常稼動している必要があります。

(ｃ)本シナリオテンプレートで指定する対象HiRDBは、HiRDB Control Managerで管理されている必要があります。

(ｄ)HAモニタ Server定義ファイルのaliasには、HiRDBシステム共通定義で指定されているバックエンドサーバ名称と同一の名称を設定しておく必要が有ります。

(ｅ)hirdbcmhost、host、svrhost入力シナリオ変数は、「シナリオ登録」時に必ず入力してください。これらのシナリオ変数を入力しなかった場合は、JP1/AJS2-SOMの稼働するホスト名称が仮定されます。

（10）異常時の対処

異常が発生した場合、JP1/AJS2-Viewのジョブネットモニタの結果から異常終了したPCジョブの実行結果詳細に表示されているメッセージを確認してください。

（11）運用例

DBシステムの定期開始・停止運用

影響分散型スタンバイレス系切り替えバックエンドサーバの強制停止操作を自動化します。

§ ENABLE_TRAN_QUEUEING

（１）名称

ENABLE_TRAN_QUEUEING

（２）概要

バックエンドサーバに対して発生するトランザクションの抑止を開始します。

（３）機能

影響分散型スタンバイレス系切り替え環境下のバックエンドサーバに対して発生するトランザクションの抑止（キューイング）を開始（有効）状態にします。このトランザクションキューイングが有効になることで、当該サーバを一旦停止した場合でも、トランザクションがエラーとなることを防ぐことが出来ます。

（４）入力シナリオ変数

項番 | 入力シナリオ変数 | 説明
１ | hirdbcmhost | HiRDB Control Manager - Serverのホスト名を指定します。
２ | hirdbcmdir | HiRDB Control Manager - Serverのインストールディレクトリを指定します。
３ | host | 対象HiRDBのマネージャユニットに対するホスト名を指定します。
４ | hirdbid | 対象HiRDBのシステムIDを指定します。
５ | server | 停止するバックエンドサーバ名を指定します。影響分散型スタンバイレス系切り替え環境で構築されたユニット上のバックエンドサーバを指定してください。

（５）出力シナリオ変数

なし。

（６）前提ＯＳ

HiRDB Control Manager - Server がサポートするＯＳ

（７）前提プログラム

(ａ)CM Agentを管理、操作する以下のCM Consoleが必要です。

R-15434-11 HiRDB Control Manager - Console 03-00以降

(ｂ)CM Agentを管理する以下のCM Serverが必要です。

R-15434-21 HiRDB Control Manager - Server 03-00以降

(ｃ)HiRDBサーバを管理する以下のいずれかのCM Agentが必要です。

R-15434-31 HiRDB Control Manager - Agent 03-00以降

R-1S434-31 HiRDB Control Manager - Agent 03-00以降

R-18434-31 HiRDB Control Manager - Agent 03-00以降

R-1M434-31 HiRDB Control Manager - Agent 03-00以降

R-19434-31 HiRDB Control Manager - Agent 03-00以降

R-15434-318 HiRDB Control Manager - Agent 03-00以降

R-18434-31J HiRDB Control Manager - Agent 03-00以降

R-1S434-31V HiRDB Control Manager - Agent 03-00以降

(ｄ)監視対象となる以下のいずれかのHiRDBが必要です。

P-1M62-1371 HiRDB/Parallel Server Version 7 07-02以降

P-1M62-1771 HiRDB/Parallel Server Version 7 (64) 07-02以降

P-1B62-1371 HiRDB/Parallel Server Version 7 07-02以降

P-1J62-1571 HiRDB/Parallel Server Version 7 (64) 07-02以降

P-9S62-1371 HiRDB/Parallel Server Version 7 07-02以降

P-9V62-1371 HiRDB/Parallel Server Version 7 (64) 07-02以降

P-2462-7374 HiRDB/Parallel Server Version 7 07-02以降

P-2862-7374 HiRDB/Parallel Server Version 7 (64) 07-02以降

(ｅ)HiRDBの影響負荷分散型スタンバイレス系切り替えを構成する

HAモニタ

（８）実行権限

特になし

（９）注意事項

(ａ)本シナリオテンプレートを使用して、HiRDB影響分散型スタンバイレス系切り替え構成以外のバックエンドサーバに対する移動はできません。

(ｂ)本シナリオテンプレートを実行する際は、対象HiRDBが正常稼動している必要があります。

(ｃ)本シナリオテンプレートで指定する対象HiRDBは、HiRDB Control Managerで管理されている必要があります。

(ｄ)HAモニタ Server定義ファイルのaliasには、HiRDBシステム共通定義で指定されているバックエンドサーバ名称と同一の名称を設定しておく必要が有ります。

(ｅ)hirdbcmhost、host、svrhost入力シナリオ変数は、「シナリオ登録」時に必ず入力してください。これらのシナリオ変数を入力しなかった場合は、JP1/AJS2-SOMの稼働するホスト名称が仮定されます。

(ｆ)トランザクションキューイングジョブでエラーが発生した場合、詳細情報に以下のメッセージが表示されることがあります。以下の何れかのメッセージが表示されている場合は、それぞれの対処方法を実施してください。

KFPS05622-E pdtrnqing command failed、 reason=aa...a、 inf=内部コード

aa...a対応コードと対処方法を次の表に示します。

コード | 内容 | 説明
SINGLE_SERVER | シングルサーバでは実行できません | 本シナリオが実行できるシステム環境ではありません。この環境では実行しないでください。
NOT_AHA_SYSTEM | HiRDBシステムが影響分散スタンバイレス型系切り替え構成でありません。 | 本シナリオが実行できるシステム環境ではありません。この環境では実行しないでください。
NOT_HAGROUP | 影響分散スタンバイレス型系切り替え対象以外のサーバを指定しています。 | 指定するサーバには影響分散型スタンバイレス型系切り替え対象バックエンドサーバを指定して下さい。
NOT_ACTIVE | サーバがコマンド実行ユニットで稼動していません。 | 指定したバックエンドサーバが稼動しているユニットで実行して下さい。または、トランザクションキューイング解除指定をしている場合は、強制解除を指定して下さい。
TIMEOUT_S | トランザクションキューイング開始時に、サーバで実行中のトランザクションが終了するまで待ち合わせましたが、システム共通定義pd_ha_trn_queuing_wait_time時間経過しても、トランザクションが終了しません。 | 指定したバックエンドサーバで稼動しているトランザクションを終了させるか、pdcancelコマンドを対象HiRDBシステム上で直接実行して、実行中のトランザクションをキャンセルして下さい。または、対象HiRDBシステムのシステム共通定義pd_ha_trn_queuing_wait_time指定値を見直して下さい。
TIMEOUT_E | トランザクションキューイング解除時に、サーバの起動完了を待ち合わせましたが、システム共通定義pd_ha_trn_queuing_wait_time時間経過しても、サーバの起動が完了しません。 | サーバの起動を行っている場合は、サーバの起動に失敗していないか確認して下さい。失敗している場合は、エラー要因を取り除いて、サーバを起動して下さい。または、対象HiRDBシステムのシステム共通定義pd_ha_trn_queuing_wait_time指定値を見直して下さい。
PROCESS_MEMORY | プロセス固有メモリが不足しています。 | 不要なプロセスを停止するなどサーバマシン内の使用メモリを減らして、再度シナリオを実行して下さい。

（10）異常時の対処

異常が発生した場合、JP1/AJS2-Viewのジョブネットモニタの結果から異常終了したPCジョブの実行結果詳細に表示されているメッセージを確認してください。

（11）運用例

オンライン中のサーバ資源のメンテナンス

本シナリオテンプレートとDISABLE_TRAN_QUEUEINGシナリオテンプレートを使用することで、トランザクションを中断させずに対象サーバのメンテナンスが行えます。

§ DISABLE_TRAN_QUEUEING

（１）名称

DISABLE_TRAN_QUEUEING

（２）概要

バックエンドサーバに対して発生するトランザクションの抑止を停止します。

（３）機能

影響分散型スタンバイレス系切り替え環境下のバックエンドサーバに対して発生するトランザクションの抑止（キューイング）を停止（無効）状態にします。

（４）入力シナリオ変数

項番 | 入力シナリオ変数 | 説明
１ | hirdbcmhost | HiRDB Control Manager - Serverのホスト名を指定します。
２ | hirdbcmdir | HiRDB Control Manager - Serverのインストールディレクトリを指定します。
３ | host | 対象HiRDBのマネージャユニットに対するホスト名を指定します。
４ | hirdbid | 対象HiRDBのシステムIDを指定します。
５ | server | 停止するバックエンドサーバ名を指定します。影響分散型スタンバイレス系切り替え環境で構築されたユニット上のバックエンドサーバを指定してください。

（５）出力シナリオ変数

なし。

（６）前提ＯＳ

HiRDB Control Manager - Server がサポートするＯＳ

（７）前提プログラム

(ａ)CM Agentを管理、操作する以下のCM Consoleが必要です。

R-15434-11 HiRDB Control Manager - Console 03-00以降

(ｂ)CM Agentを管理する以下のCM Serverが必要です。

R-15434-21 HiRDB Control Manager - Server 03-00以降

(ｃ)HiRDBサーバを管理する以下のいずれかのCM Agentが必要です。

R-15434-31 HiRDB Control Manager - Agent 03-00以降

R-1S434-31 HiRDB Control Manager - Agent 03-00以降

R-18434-31 HiRDB Control Manager - Agent 03-00以降

R-1M434-31 HiRDB Control Manager - Agent 03-00以降

R-19434-31 HiRDB Control Manager - Agent 03-00以降

R-15434-318 HiRDB Control Manager - Agent 03-00以降

R-18434-31J HiRDB Control Manager - Agent 03-00以降

R-1S434-31V HiRDB Control Manager - Agent 03-00以降

(ｄ)監視対象となる以下のいずれかのHiRDBが必要です。

P-1M62-1371 HiRDB/Parallel Server Version 7 07-02以降

P-1M62-1771 HiRDB/Parallel Server Version 7 (64) 07-02以降

P-1B62-1371 HiRDB/Parallel Server Version 7 07-02以降

P-1J62-1571 HiRDB/Parallel Server Version 7 (64) 07-02以降

P-9S62-1371 HiRDB/Parallel Server Version 7 07-02以降

P-9V62-1371 HiRDB/Parallel Server Version 7 (64) 07-02以降

P-2462-7374 HiRDB/Parallel Server Version 7 07-02以降

P-2862-7374 HiRDB/Parallel Server Version 7 (64) 07-02以降

(ｅ)HiRDBの影響負荷分散型スタンバイレス系切り替えを構成する

HAモニタ

（８）実行権限

特になし

（９）注意事項

(ａ)本シナリオテンプレートを使用して、HiRDB影響分散型スタンバイレス系切り替え構成以外のバックエンドサーバに対する移動はできません。

(ｂ)本シナリオテンプレートを実行する際は、対象HiRDBが正常稼動している必要があります。

(ｃ)本シナリオテンプレートで指定する対象HiRDBは、HiRDB Control Managerで管理されている必要があります。

(ｄ)HAモニタ Server定義ファイルのaliasには、HiRDBシステム共通定義で指定されているバックエンドサーバ名称と同一の名称を設定しておく必要が有ります。

(ｅ)hirdbcmhost、host、svrhost入力シナリオ変数は、「シナリオ登録」時に必ず入力してください。これらのシナリオ変数を入力しなかった場合は、JP1/AJS2-SOMの稼働するホスト名称が仮定されます。

(ｆ)トランザクションキューイングジョブでエラーが発生した場合、詳細情報に以下のメッセージが表示されることがあります。以下の何れかのメッセージが表示されている場合は、それぞれの対処方法を実施してください。

KFPS05622-E pdtrnqing command failed、 reason=aa...a、 inf=内部コード

aa...a対応コードと対処方法を次の表に示します。

コード | 内容 | 説明
SINGLE_SERVER | シングルサーバでは実行できません | 本シナリオが実行できるシステム環境ではありません。この環境では実行しないでください。
NOT_AHA_SYSTEM | HiRDBシステムが影響分散スタンバイレス型系切り替え構成でありません。 | 本シナリオが実行できるシステム環境ではありません。この環境では実行しないでください。
NOT_HAGROUP | 影響分散スタンバイレス型系切り替え対象以外のサーバを指定しています。 | 指定するサーバには影響分散型スタンバイレス型系切り替え対象バックエンドサーバを指定して下さい。
NOT_ACTIVE | サーバがコマンド実行ユニットで稼動していません。 | 指定したバックエンドサーバが稼動しているユニットで実行して下さい。または、トランザクションキューイング解除指定をしている場合は、強制解除を指定して下さい。
TIMEOUT_S | トランザクションキューイング開始時に、サーバで実行中のトランザクションが終了するまで待ち合わせましたが、システム共通定義pd_ha_trn_queuing_wait_time時間経過しても、トランザクションが終了しません。 | 指定したバックエンドサーバで稼動しているトランザクションを終了させるか、pdcancelコマンドを対象HiRDBシステム上で直接実行して、実行中のトランザクションをキャンセルして下さい。または、対象HiRDBシステムのシステム共通定義pd_ha_trn_queuing_wait_time指定値を見直して下さい。
TIMEOUT_E | トランザクションキューイング解除時に、サーバの起動完了を待ち合わせましたが、システム共通定義pd_ha_trn_queuing_wait_time時間経過しても、サーバの起動が完了しません。 | サーバの起動を行っている場合は、サーバの起動に失敗していないか確認して下さい。失敗している場合は、エラー要因を取り除いて、サーバを起動して下さい。または、対象HiRDBシステムのシステム共通定義pd_ha_trn_queuing_wait_time指定値を見直して下さい。
PROCESS_MEMORY | プロセス固有メモリが不足しています。 | 不要なプロセスを停止するなどサーバマシン内の使用メモリを減らして、再度シナリオを実行して下さい。

（10）異常時の対処

異常が発生した場合、JP1/AJS2-Viewのジョブネットモニタの結果から異常終了したPCジョブの実行結果詳細に表示されているメッセージを確認してください。

（11）運用例

オンライン中のサーバ資源のメンテナンス

本シナリオテンプレートとENABLE_TRAN_QUEUEINGシナリオテンプレートを使用することで、トランザクションを中断させずに対象サーバのメンテナンスが行えます。

§ FORCE_TRAN_QUEUEING

（１）名称

FORCE_TRAN_QUEUEING

（２）概要

バックエンドサーバに対して発生するトランザクションのを抑止強制停止します。

（３）機能

影響分散型スタンバイレス系切り替え環境下のバックエンドサーバに対して発生するトランザクションの抑止（キューイング）を強制停止（無効）状態にします。

（４）入力シナリオ変数

項番 | 入力シナリオ変数 | 説明
１ | hirdbcmhost | HiRDB Control Manager - Serverのホスト名を指定します。
２ | hirdbcmdir | HiRDB Control Manager - Serverのインストールディレクトリを指定します。
３ | host | 対象HiRDBのマネージャユニットに対するホスト名を指定します。
４ | hirdbid | 対象HiRDBのシステムIDを指定します。
５ | server | 停止するバックエンドサーバ名を指定します。影響分散型スタンバイレス系切り替え環境で構築されたユニット上のバックエンドサーバを指定してください。

（５）出力シナリオ変数

なし。

（６）前提ＯＳ

HiRDB Control Manager - Server がサポートするＯＳ

（７）前提プログラム

(ａ)CM Agentを管理、操作する以下のCM Consoleが必要です。

R-15434-11 HiRDB Control Manager - Console 03-00以降

(ｂ)CM Agentを管理する以下のCM Serverが必要です。

R-15434-21 HiRDB Control Manager - Server 03-00以降

(ｃ)HiRDBサーバを管理する以下のいずれかのCM Agentが必要です。

R-15434-31 HiRDB Control Manager - Agent 03-00以降

R-1S434-31 HiRDB Control Manager - Agent 03-00以降

R-18434-31 HiRDB Control Manager - Agent 03-00以降

R-1M434-31 HiRDB Control Manager - Agent 03-00以降

R-19434-31 HiRDB Control Manager - Agent 03-00以降

R-15434-318 HiRDB Control Manager - Agent 03-00以降

R-18434-31J HiRDB Control Manager - Agent 03-00以降

R-1S434-31V HiRDB Control Manager - Agent 03-00以降

(ｄ)監視対象となる以下のいずれかのHiRDBが必要です。

P-1M62-1371 HiRDB/Parallel Server Version 7 07-02以降

P-1M62-1771 HiRDB/Parallel Server Version 7 (64) 07-02以降

P-1B62-1371 HiRDB/Parallel Server Version 7 07-02以降

P-1J62-1571 HiRDB/Parallel Server Version 7 (64) 07-02以降

P-9S62-1371 HiRDB/Parallel Server Version 7 07-02以降

P-9V62-1371 HiRDB/Parallel Server Version 7 (64) 07-02以降

P-2462-7374 HiRDB/Parallel Server Version 7 07-02以降

P-2862-7374 HiRDB/Parallel Server Version 7 (64) 07-02以降

(ｅ)HiRDBの影響負荷分散型スタンバイレス系切り替えを構成する

HAモニタ

（８）実行権限

特になし

（９）注意事項

(ａ)本シナリオテンプレートを使用して、HiRDB影響分散型スタンバイレス系切り替え構成以外のバックエンドサーバに対する移動はできません。

(ｂ)本シナリオテンプレートで指定する対象HiRDBは、HiRDB Control Managerで管理されている必要があります。

(ｃ)HAモニタ Server定義ファイルのaliasには、HiRDBシステム共通定義で指定されているバックエンドサーバ名称と同一の名称を設定しておく必要が有ります。

(ｄ)hirdbcmhost、host、svrhost入力シナリオ変数は、「シナリオ登録」時に必ず入力してください。これらのシナリオ変数を入力しなかった場合は、JP1/AJS2-SOMの稼働するホスト名称が仮定されます。

(ｅ)トランザクションキューイングジョブでエラーが発生した場合、詳細情報に以下のメッセージが表示されることがあります。以下の何れかのメッセージが表示されている場合は、それぞれの対処方法を実施してください。

KFPS05622-E pdtrnqing command failed、 reason=aa...a、 inf=内部コード

aa...a対応コードと対処方法を次の表に示します。

コード | 内容 | 説明
SINGLE_SERVER | シングルサーバでは実行できません | 本シナリオが実行できるシステム環境ではありません。この環境では実行しないでください。
NOT_AHA_SYSTEM | HiRDBシステムが影響分散スタンバイレス型系切り替え構成でありません。 | 本シナリオが実行できるシステム環境ではありません。この環境では実行しないでください。
NOT_HAGROUP | 影響分散スタンバイレス型系切り替え対象以外のサーバを指定しています。 | 指定するサーバには影響分散型スタンバイレス型系切り替え対象バックエンドサーバを指定して下さい。
NOT_ACTIVE | サーバがコマンド実行ユニットで稼動していません。 | 指定したバックエンドサーバが稼動しているユニットで実行して下さい。または、トランザクションキューイング解除指定をしている場合は、強制解除を指定して下さい。
TIMEOUT_S | トランザクションキューイング開始時に、サーバで実行中のトランザクションが終了するまで待ち合わせましたが、システム共通定義pd_ha_trn_queuing_wait_time時間経過しても、トランザクションが終了しません。 | 指定したバックエンドサーバで稼動しているトランザクションを終了させるか、pdcancelコマンドを対象HiRDBシステム上で直接実行して、実行中のトランザクションをキャンセルして下さい。または、対象HiRDBシステムのシステム共通定義pd_ha_trn_queuing_wait_time指定値を見直して下さい。
TIMEOUT_E | トランザクションキューイング解除時に、サーバの起動完了を待ち合わせましたが、システム共通定義pd_ha_trn_queuing_wait_time時間経過しても、サーバの起動が完了しません。 | サーバの起動を行っている場合は、サーバの起動に失敗していないか確認して下さい。失敗している場合は、エラー要因を取り除いて、サーバを起動して下さい。または、対象HiRDBシステムのシステム共通定義pd_ha_trn_queuing_wait_time指定値を見直して下さい。
PROCESS_MEMORY | プロセス固有メモリが不足しています。 | 不要なプロセスを停止するなどサーバマシン内の使用メモリを減らして、再度シナリオを実行して下さい。

（10）異常時の対処

異常が発生した場合、JP1/AJS2-Viewのジョブネットモニタの結果から異常終了したPCジョブの実行結果詳細に表示されているメッセージを確認してください。

（11）運用例

本シナリオテンプレートを使用することで、対象サーバ停止時のトランザクションキューイング解除が行えます。


メッセージ編

目次

メッセージ編

この章では、HiRDB CMが出力するメッセージ及びアプリケーションエラーについて説明します。

＜この章の構成＞

· メッセージ記述形式

· KFPEメッセージ一覧

§ KFPE1XXXX HiRDB CM Consoleメッセージ

§ KFPE2XXXX HiRDB CM Serverメッセージ

§ KFPE3XXXX HiRDB CM Agentメッセージ

§ KFPE4XXXX HiRDB CM JP1/AJS2カスタムジョブ連携メッセージ

§ KFPE5XXXX HiRDB CM WEB Consoleメッセージ

· Consoleアプリケーションエラー

· HiRDBメッセージの詳細説明表示

· Serverリターンコード


メッセージの記述形式

ここでは、メッセージの説明の記述形式を示します。

KFPEXnnnn-i
メッセージ | 出力メッセージフォーマット
対処方法 | このエラーの原因や対処方法などを説明しています。

· KFPE

HiRDB CM及びHiRDB Assistが出力するメッセージであることを示すコードです。

· X

エラーが発生したアプリケーションを数字で示します。

1 : HiRDB CM - Consoleからのメッセージを示します。

2 : HiRDB CM - Serverからのメッセージを示します。

3 : HiRDB CM - Agentからのメッセージを示します。

4 : HiRDB CM - JP1/AJS2連携からのメッセージを示します。

5 : HiRDB CM - Web Consoleからのメッセージを示します。

· nnnn

メッセージ番号を示します。

· i

メッセージの重要度を示します。

§ E : エラーメッセージ

機能が働かない障害が発生したことを示しています。

§ W : 警告メッセージ

リソースの使用状況や指定した値の誤りなどについての警告を示します。

§ I : インフォメーションメッセージ

上記E、及びWに該当しない単純な動作状況を示します。

§ Q : 応答待ちメッセージ

出力したメッセージに対するユーザの応答を待っていることを示します。


KFPEメッセージ

目次 > メッセージ編

KFPEメッセージ

KFPE11001-E

メッセージ

Consoleは既に開いています。

Consoleは同じPC上に複数の起動ができません。

対処方法

-

KFPE11002-W

メッセージ

ファイルエラーが発生しました。

Consoleは履歴をログファイルに書き込むことができませんでした。

対処方法

-

KFPE11003-E

メッセージ

hostsファイルが見つかりません。

対処方法

-

KFPE11004-W

メッセージ

レジストリから情報を読み込むことができませんでした。
初期値はデフォルト値が表示されます。
インストールユーザ以外で実行した可能性があります。

対処方法

HiRDB Control Manager Consoleをインストールしたユーザで、 HiRDB Control Manager - Consoleを実行してください。

KFPE11005-W

メッセージ

レジストリに情報を書き込むことができませんでした｡インストールユーザ以外で実行した可能性があります｡

対処方法

HiRDB Control Manager Consoleをインストールしたユーザで、 HiRDB Control Manager - Consoleを実行してください。

KFPE11006-E

メッセージ

Hostsファイルの書式に誤りがあるため、

ホスト名を読み込めませんでした。

Hostsファイルの書式を確認してください。

対処方法

Hostsファイルの書式に誤りが含まれています。以下の事を確認してください。

・2バイト空白が含まれていないこと。

・IPアドレスは定義しているがホスト名は定義していないものが存在しないこと。

KFPE11007-E

メッセージ

ConsoleのバージョンとServerのバージョンが一致しません。Consoleの起動を中止します。

対処方法

CM Consoleは同一バージョンのCM Serverとしか接続できません。CM ServerのバージョンをCM Consoleと同じにしてください。

KFPE11008-E

メッセージ

[<コントロール>]を指定してください。

対処方法

処理を実行するために必要なオプションが指定されていません。

メッセージで表示されている<コントロール名>を指定してください。

KFPE11009-E

メッセージ

無効なオプション[<コントロール>]が指定されました。

対処方法

不正なオプションが指定されました。

KFPE11010-E

メッセージ

[<コントロール名>]が2回以上指定されています。

対処方法

<コントロール>を１回指定してください。

KFPE11011-E

メッセージ

IPアドレスまたはホスト名を指定してください。

対処方法

-

KFPE11012-I

メッセージ

情報参照のみ可能な一般ユーザでログインします。

対処方法

-

KFPE11101-E

メッセージ

Serverが存在するホストが停止しています。

対処方法

Serverが存在するホストが停止状態であるため、接続することができません。ホストの状態を確認してください。

KFPE11102-E

メッセージ

Serverが存在するホストはネットワーク上にありません。

Serverとの接続ができません。

対処方法

ホストの状態又は情報を確認してください。

KFPE11103-E

メッセージ

ネットワーク障害が発生したため、Serverとの接続が失われました。

対処方法

ネットワークの状態を確認してください。なお、実行中の処理があった場合は中断された可能性があります。

KFPE11104-E

メッセージ

メモリが不足しているため、処理を実行できません。

しばらく時間を置いてから再実行してください。

対処方法

実行中の処理が存在する場合は、その処理が終了するのを待ってから再実行してください。また、不要なプログラムを終了させてください。

KFPE11105-E

メッセージ

Serverとの通信データに不正な情報が存在したため、処理を中断しました。

処理を再実行してください。

対処方法

操作中の画面を一旦閉じてから再実行してください。

また、頻繁に発生する場合は、以下の情報を取得して保守員に連絡してください。

・Consoleインストールディレクトリ下のCMCSysLog.txt

・このメッセージが表示されている状態の画面イメージ(画面のイメージは [Ctrl+Print Screen]キーで取得してください)

・使用中のConsoleのバージョン

KFPE11106-E

メッセージ

Serverとの通信データに不正な情報が存在したため、処理を中断しました。

処理を再実行してください。

対処方法

操作中の画面を一旦閉じてから再実行してください。

また、頻繁に発生する場合は、以下の情報を取得して保守員に連絡してください。

・Consoleインストールディレクトリ下のCMCSysLog.txt

・このメッセージが表示されている状態の画面イメージ(画面のイメージは [Ctrl+Print Screen]キーで取得してください)

・使用中のConsoleのバージョン

KFPE11107-E

メッセージ

処理がキャンセルされました。

対処方法

Serverへデータを送る前に処理をキャンセルしました。

処理を続行する場合は、再実行してください。

KFPE11108-E

メッセージ

キャンセルすることはできません。

既に処理はServerへ送られています。

対処方法

処理が既にServerへ送られている場合は、処理をキャンセルすることができません。

この処理は既に実行されています。

現在、Serverで実行されている処理が終了するのを待ってから、次の操作を行ってください。

KFPE11109-E

メッセージ

Serverは同時処理実行数の最大値に達しています。

Consoleはこれ以上の処理を行うことはできません。

対処方法

Serverが同時処理実行数の最大値((65535))に達しています。

現在、Serverで実行している処理が終了するのを待ってから再実行してください。

KFPE11110-E

メッセージ

ネットワーク サブシステムで障害が発生したため、指定されたホストのIPアドレスを見つけられませんでした。

対処方法

ネットワークの状態を確認してください。

KFPE11111-E

メッセージ

指定されたホストのIPアドレスが見つかりません。

対処方法

IPアドレスを確認してください。

KFPE11112-E

メッセージ

修復できないエラーが発生したため、指定されたホストのIPアドレスを見つけられませんでした。

対処方法

-

KFPE11113-E

メッセージ

指定されたホストは無効です。

対処方法

-

KFPE11114-E

メッセージ

指定されたポート番号でServerへの接続ができません。

ポート番号の確認をしてください。

対処方法

ポート番号の確認とServerの状態を確認してください。

KFPE11115-E

メッセージ

タイムアウトが発生しました。

Serverが見つかりません。

対処方法

Serverの状態を確認してください。

KFPE11116-E

メッセージ

Serverとの接続が既に閉じられています。

対処方法

Serverあるいはホストが停止しているため、接続が閉じられた可能性があります。

KFPE11117-E

メッセージ

タイムアウトが発生しました。

対処方法

このエラーは、次の要因が考えられます。

・Serverへのリクエストが大量に発生しているため、情報検索に時間がかかっています。

[バックアップ ウィザード]コマンドで取得対象を検索した時に発生した場合、[検索する取得対象名]に対象を絞り込むためのキーワードを指定し、再実行してください。

・Serverの情報更新中、あるいはServerが稼動するマシンの負荷が高い場合があります。

[更新]、[管理HiRDBの新規登録]、[管理HiRDBの解除]コマンドを実行した場合は、他の操作を行うとServerの情報更新に時間がかかり、Consoleからの要求に対する応答が遅くなることがあります。

このような場合は、しばらくしてから再実行してください。

・通信障害が発生している可能性があります。

ネットワークの状態を確認し、HiRDB CMを起動し直して再実行してください。

また、[システムステータス 詳細]画面で発生した場合、当該HiRDBシステムに対してバックアップあるいはリカバリ等、他の操作が実行されている可能性があります。

その場合は、他の操作が終了してから、表示操作を再実行してください。

KFPE11118-E

メッセージ

指定されたホストは無効です。

対処方法

-

KFPE11119-E

メッセージ

Serverとの接続が中断しました。

対処方法

-

KFPE11120-E

メッセージ

Serverが停止しているため、Consoleを終了します。

対処方法

-

KFPE11121-E

メッセージ

システムメモリ量が不足しているか、Serverから受信したデータ長が不正です。アプリケーションを終了します。

対処方法

システムのメモリ使用量を確認してください。十分なメモリを確保できる環境で再度実行してください。

KFPE11201-E

メッセージ

ネットワーク サブシステムで障害が発生したため、指定されたドメインのIPアドレスを見つけられませんでした。

対処方法

ネットワークの状態を確認してください。

KFPE11202-E

メッセージ

指定されたドメインのIPアドレスが見つかりません。

対処方法

ネットワークの状態を確認してください。

KFPE11203-E

メッセージ

指定されたドメインのIPアドレスが見つかりません。

対処方法

指定したドメイン名を確認してください。

KFPE11204-E

メッセージ

修復できないエラーが発生したため、指定されたドメインのIPアドレスを見つけられませんでした。

対処方法

-

KFPE11205-E

メッセージ

指定されたドメインのIPアドレスが見つかりません。

対処方法

指定したドメイン名を確認してください。

KFPE11206-E

メッセージ

指定されたドメイン名は無効です。

対処方法

-

KFPE11207-I

メッセージ

Console最大接続数の変更に成功しました。

対処方法

-

KFPE11208-I

メッセージ

Console最大接続数を変更しませんでした。

対処方法

再度実行してください。

KFPE11209-I

メッセージ

ニックネームを変更しませんでした。

対処方法

再度実行してください。

KFPE11301-I

メッセージ

<パスワード あるいは 管理情報の更新>の変更に成功しました。

対処方法

-

KFPE11302-E

メッセージ

[新パスワード]と[新パスワードの確認]で指定された値が一致していません。

再入力してください。

対処方法

指定したパスワードを確認してください。

KFPE11303-E

メッセージ

パスワードに不正文字が含まれています。パスワードには英数字のみ指定してください。

対処方法

パスワードには英数字のみ指定してください。

KFPE11351-I

メッセージ

Console応答待ち時間の変更に成功しました。

対処方法

-

KFPE11352-I

メッセージ

Console応答待ち時間を変更しませんでした。

対処方法

再度実行してください。

KFPE11401-I

メッセージ

管理情報の更新間隔の変更に成功しました。

対処方法

-

KFPE11402-I

メッセージ

管理情報の更新間隔を変更しませんでした。

対処方法

再度実行してください。

KFPE11403-I

メッセージ

Serverが処理中のため、状態情報が取得できませんでした。

対処方法

-

KFPE11551-I

メッセージ

JP1/AJS2の登録解除に成功しました。

対処方法

-

KFPE11552-E

メッセージ

JP1/AJS2で使用されているため、削除できません。

対処方法

JP1/AJS2の解除を行ってから、再度削除を実行してください。

KFPE11553-E

メッセージ

使用中のPC上にJP1/AJS2 - Viewがインストールされていません。

対処方法

HiRDB CM Console起動マシン上にJP1/AJS2 - Viewがインストールされていない場合は、インストールした後再度実行してください。JP1/AJS2 - Viewがインストールされているがメッセージが表示された場合、連携操作でエラーが発生しました。 この場合、JP1/AJS2連携画面でJP1/AJS2 - Viewのインストールディレクトリを直接入力することで、処理を続けることができます。

KFPE11554-E

メッセージ

JP1/AJS2で使用されていないカタログは解除できません。

対処方法

解除するカタログのJP1/AJS2使用状況を確認してください。

KFPE11555-E

メッセージ

使用中のPC上にConsoleがインストールされていません。

対処方法

Consoleをインストールしてください。

KFPE11556-E

メッセージ

JP1/AJS2のインストールディレクトリが不正です。

対処方法

指定したパスが正しいか確認してください。間違っていた場合は、正しいパスを指定してから再度実行してください。

KFPE11557-E

メッセージ

JP1/AJS2-Viewのインストールディレクトリを自動取得できませんでした。手動で入力してください。

対処方法

JP1/AJS2 - Viewのインストールディレクトリを入力してください。

KFPE11558-E

メッセージ

JP1/AJS2との連携環境の設定に失敗しました。

対処方法

再度実行してください。

KFPE11559-I

メッセージ

JP1/AJS2との連携環境の設定に成功しました。

対処方法

-

KFPE11560-I

メッセージ

JP1/AJS2用カタログの解除に成功しました。

対処方法

-

KFPE11601-I

メッセージ

ロギング情報表示の設定に成功しました。

対処方法

-

KFPE11602-I

メッセージ

レジストリの値が不正です。デフォルト値を表示します。

対処方法

-

KFPE11603-I

メッセージ

記憶されている値の範囲が無効です。デフォルト値を表示します。

対処方法

-

KFPE11604-I

メッセージ

バージョン情報の取得に失敗しました。

対処方法

再度実行してください。

KFPE11605-I

メッセージ

グローバルバッファの追加に成功しました。

対処方法

-

KFPE11606-I

メッセージ

グローバルバッファのRDエリアへの割り当てに成功しました。

対処方法

-

KFPE11607-I

メッセージ

グローバルバッファの定義の変更に成功しました。

対処方法

-

KFPE11608-I

メッセージ

グローバルバッファの削除に成功しました。

対処方法

-

KFPE11609-I

メッセージ

グローバルバッファのRDエリアの削除に成功しました。

対処方法

-

KFPE11610-E

メッセージ

128個を超えるRDエリアは指定できません。

対処方法

処理対象とするRDエリア数を128個以下にしてから、再度実行してください。

KFPE11611-E

メッセージ

3200個を超えるRDエリアは指定できません。

対処方法

処理対象とするRDエリア数を3200個以下にしてから、再度実行してください。

KFPE11612-E

メッセージ

サーバ起動中の常駐プロセス数は、サーバ起動中の最大起動プロセス数以下の値を指定してください。

対処方法

サーバ起動中の常駐プロセス数は、サーバ起動中の最大起動プロセス数以下の値を指定してから、再度実行してください。

KFPE11613-E

メッセージ

サーバ起動中の最大起動プロセス数は、HiRDBシステム定義の最大起動プロセス数以下の値を指定してください。

対処方法

サーバ起動中の最大起動プロセス数は、HiRDBシステム定義の最大起動プロセス数以下の値にしてから、再度実行してください。

KFPE11614-I

メッセージ

サーバプロセスの起動本数の変更に成功しました。

対処方法

-

KFPE11615-Q

メッセージ

強制開始を行うとデータベースが破壊され、開始後にデータベースの回復が必要になります。よろしいですか？

対処方法

HiRDBを強制開始すると，データベース回復ユティリティでのデータベースの回復が必要になります。本当に強制開始をするか確認して、強制開始を行う場合は「はい」を選択してください。強制開始を行わない場合は「いいえ」を選択してください。

KFPE11616-I

メッセージ

検索文字列が見つかりません。

対処方法

-

KFPE11617-I

メッセージ

サーバプロセス数を変更しませんでした。

対処方法

-

KFPE11618-I

メッセージ

カレントRDエリアの変更に成功しました｡

対処方法

-

KFPE11619-E

メッセージ

シングルサーバ、または、フロントエンドサーバ以外のサーバのプロセスは強制終了できません。

対処方法

-

KFPE11620-Q

メッセージ

指定されたUAPプロセスを強制終了してよろしいですか？

対処方法

-

KFPE11621-I

メッセージ

トランザクションキューイング操作の実行に成功しました。

対処方法

-

KFPE11622-Q

メッセージ

指定された[<コントロール>]を正常終了します。よろしいですか？

対処方法

-

KFPE11623-Q

メッセージ

指定された[<コントロール>]を計画停止します。よろしいですか？

対処方法

-

KFPE11624-Q

メッセージ

指定された[<コントロール>]を強制停止します。よろしいですか？

対処方法

-

KFPE11701-I

メッセージ

HiRDBファイルシステム領域の削除に成功しました。

対処方法

-

KFPE11702-E

メッセージ

この機能はv01-01以前のServerではサポートされていません。

対処方法

この機能を使用する場合、Serverのバージョンアップを行ってください。

KFPE11703-I

メッセージ

HiRBファイルの削除に成功しました。

対処方法

-

KFPE11704-E

メッセージ

所有者の異なる表が選択されているため、アクセス権限を変更することができません。

対処方法

所有者が同じ表に対してのみ、一括でアクセス権限の変更を行うことができます。所有者毎に分けて実行してください。

KFPE11706-E

メッセージ

指定されたオリジナルHiRDBファイルシステム領域に対して同じ世代番号のレプリカHiRDBファイルシステムシステム領域が既に指定されています。

対処方法

世代番号を重複しないように変更してください。

KFPE11707-E

メッセージ

同じレプリカHiRDBファイルシステム領域名が既に指定されています

対処方法

HiRDB CMに登録された同名のHiRDBファイルシステム領域情報を確認してください。対象のHiRDBファイルシステム領域情報が不要な場合は、世代登録の解除を行った後、再度実行してください。

KFPE11708-I

メッセージ

HiRDBファイルシステム領域の世代登録に成功しました。

対処方法

-

KFPE11709-I

メッセージ

HiRDBファイルシステム領域の世代削除に成功しました。

対処方法

-

KFPE11710-Q

メッセージ

選択されたHiRDBファイルシステム領域の世代削除を実行します。よろしいですか？

対処方法

-

KFPE11711-I

メッセージ

全ての世代のHiRDBファイルシステム領域が既に登録されています。

対処方法

-

KFPE11712-Q

メッセージ

{para1}と{para2}を統合します。よろしいですか？

対処方法

-

KFPE11713-I

メッセージ

インナレプリカグループの統合に成功しました。

対処方法

-

KFPE11714-I

メッセージ

全ての世代のRDエリアが既に定義されています。

対処方法

-

KFPE11715-E

メッセージ

HiRDBファイルシステム領域名に使用できない文字を指定しています。HiRDBファイルシステム領域名に '*?|,' は指定できません。

対処方法

HiRDBファイルシステム領域名を正しい値に変更してください。

KFPE11716-I

メッセージ

レプリカRDエリアの定義に成功しました。

対処方法

‐

KFPE11717-I

メッセージ

RDエリアの構成情報複写に成功しました｡オリジナルRDエリアとレプリカRDエリアの実体を一致させてください｡

対処方法

‐

KFPE11718-E

メッセージ

改ざん防止表を含むRDエリアの再初期化を実行することはできません｡

対処方法

HiRDBでは、改ざん防止表を含むRDエリアの再初期化を行うことはできません。詳細は、HiRDBのマニュアルを参照してください。

KFPE11719-E

メッセージ

レプリカRDエリアの再初期化を実行することはできません｡

対処方法

-

KFPE11720-E

メッセージ

指定された表に対して､改ざん防止表への移行ウィザードを実行することはできません｡

対処方法

指定された表は、改ざん防止表への移行ウィザードを実行できません。[操作編]>[タブメニュー]>[表操作]>[改ざん防止表移行ウィザード]の前提条件を参照してください。

KFPE11721-E

メッセージ

レプリカRDエリアの拡張を実行することはできません。

対処方法

HiRDB CMでは、オリジナルRDエリアとレプリカRDエリアが不一致になることを避けるため、レプリカRDエリアの拡張を実行することはできません。オリジナルRDエリアを拡張した後、RDエリアの構成情報複写を行うことでレプリカグループ内のすべてのRDエリアを拡張してください。

KFPE11722-Q

メッセージ

世代登録されたHiRDBファイルシステム領域に直接アクセスしてHiRDBファイル情報を取得します。よろしいですか？

対処方法

-

KFPE11723-E

メッセージ

既に同名のHiRDBファイルが一覧に設定されています。

対処方法

同名のHiRDBファイルを指定することはできません。HiRDBファイル名を変更してください。

KFPE11801-I

メッセージ

バックアップ ウィザード環境設定の値を保存しました。

対処方法

-

KFPE11802-E

メッセージ

[HiRDBシステム]の複数選択はできません。

対処方法

[HiRDBシステム]は単一選択のみ可能です。

KFPE11803-E

メッセージ

指定された[xxxxxxxx]は既に登録されています。

対処方法

既に登録されている名称と同じ名称を登録することはできません。

指定した名称が誤っている場合は、確認し再入力してください。

KFPE11804-E

メッセージ

バックアップファイル名に次の文字は指定できません。',' '/' '\'

対処方法

バックアップファイル名に',' '/' '\'は指定できません。

KFPE11805-E

メッセージ

指定したHiRDBファイルシステム領域内に種別の異なるHiRDBファイルが存在します。

対処方法

-

KFPE11806-E

メッセージ

指定した情報に対するバックアップファイルが存在していません。

対処方法

-

KFPE11807-Q

メッセージ

以下のバックアップファイルを使用して管理情報のリカバリを行います。よろしいですか?

対処方法

-

KFPE11808-I

メッセージ

変更された値がないので管理情報のバックアップ設定値を変更しませんでした。

対処方法

-

KFPE11809-I

メッセージ

指定されたバックアップファイルを削除しました。

対処方法

-

KFPE11810-Q

メッセージ

バックアップファイルの格納先が登録されていません。登録しますか？

対処方法

-

KFPE11811-I

メッセージ

既存バックアップの登録に成功しました。

対処方法

-

KFPE11812-E

メッセージ

格納先の登録に失敗したため、既存バックアップファイルの登録を中止しました。

対処方法

登録を行うバックアップファイルが存在するディレクトリまたは、HiRDBファイルシステム領域の状態を確認してください。

KFPE12001-I

メッセージ

スケジュールの追加/変更に成功しました。

対処方法

-

KFPE12002-W

メッセージ

指定された日付のうち、29・30・31日は存在しない月があります。その場合はスケジュールが実行されません。

よろしいですか?

対処方法

スケジュール機能の毎月指定で月最後の処理を行う場合は、28日を超えた日付の指定は行わないでください。

KFPE12003-E

メッセージ

[スケジュール指定有]状態のカタログは削除できません。

対処方法

カタログは[スケジュール指定無]あるいは[スケジュール実行済]状態の場合に削除できます。

KFPE12101-I

メッセージ

指定したHiRDBシステムの登録に成功しました。

対処方法

-

KFPE12102-Q

メッセージ

選択したHiRDBシステムをHiRDB CMの管理から解除します。

よろしいですか?

対処方法

-

KFPE12103-I

メッセージ

<管理HiRDBの解除 あるいは ニックネームの変更>に成功しました。

対処方法

-

KFPE12104-I

メッセージ

管理HiRDBの解除に成功しました。

対処方法

-

KFPE12105-E

メッセージ

選択されたHiRDBは別の画面で操作されているため、解除はできません。

対処方法

指定したHiRDBに対する操作を行っているWindowsを全て閉じてから、再度実行してください。

KFPE12106-I

メッセージ

HiRDファイルシステム領域の登録に成功しました。

対処方法

-

KFPE12107-Q

メッセージ

指定されたシステムを初期化開始します。\nよろしいですか？

対処方法

-

KFPE12108-I

メッセージ

HiRDB開始制御の設定に成功しました。

対処方法

-

KFPE12109-E

メッセージ

HiRDB簡易セットアップツールが見つかりません。

対処方法

HiRDB簡易セットアップツールが次のディレクトリに存在するか確認してください。

{Consoleのインストールディレクトリ}\PDISETUP\bin

KFPE12201-I

メッセージ

RDエリアの状態変更に成功しました。

対処方法

-

KFPE12202-I

メッセージ

指定されたアンロードログファイルを削除しました。

対処方法

-

KFPE12203-E

メッセージ

アンロードログファイル名が1024文字を超えています。

対処方法

HiRDB CMで管理できるアンロードログファイルの絶対パスは、1024文字です。アンロードログファイル名または、格納ディレクトリを1024文字以内に収まるように変更してください。

KFPE12204-E

メッセージ

アンロードログファイル名が167文字を超えています。

対処方法

HiRDB CMで管理できるアンロードログファイル名は、167文字です。アンロードログファイル名を変更したあと、再度実行してください。

KFPE12205-I

メッセージ

既存アンロードログファイルの登録に成功しました。

対処方法

-

KFPE12401-I

メッセージ

NetBackup ポリシーの作成に成功しました。

対処方法

-

KFPE12402-Q

メッセージ

指定されたポリシーに格納しているバックアップファイルも削除されます。

よろしいですか?

対処方法

-

KFPE12403-E

メッセージ

指定された差分バックアップグループはNetBackupを使用していません。

対処方法

バックアップウィザード、またはバックアップカスタマイズにより、1回目のフルバックアップを取得した時の設定内容を確認してください。

KFPE12501-I

メッセージ

指定されたRDエリアを削除しました。

対処方法

-

KFPE12502-I

メッセージ

RDエリアの追加に成功しました。

対処方法

-

KFPE12503-I

メッセージ

RDエリアの拡張に成功しました。

対処方法

-

KFPE12504-I

メッセージ

RDエリアの再初期化に成功しました。

対処方法

-

KFPE12505-I

メッセージ

HiRDBファイルシステム領域の初期化に成功しました。

対処方法

-

KFPE12506-E

メッセージ

指定されたHiRDBファイル名に' *?""<>| 'カンマが含まれています。

HiRDBファイル名に' *?""<>| 'は指定できません。

対処方法

-

KFPE12507-E

メッセージ

指定されたファイル格納先に' *?""<>| 'カンマが含まれています。

ファイル格納先に' *?""<>| 'は指定できません。

対処方法

-

KFPE12508-I

メッセージ

指定されたユーザを削除しました。

対処方法

-

KFPE12509-E

メッセージ

64個を超える表は指定できません。

対処方法

処理対象とする表数を64個以下にしてから、再度実行してください。

KFPE12510-E

メッセージ

この機能はv01-01以前のServerではサポートされていません。

対処方法

必要に応じてServerのバージョンアップを行ってください。

KFPE12511-E

メッセージ

環境設定が不正です。SQL TAは実行できません。

対処方法

実行環境の設定を行ってから、再度実行してください。

KFPE12512-E

メッセージ

使用中のPC上にSQL TAがインストールされていません。

対処方法

SQL Tuning Advisorをインストールしてください。

KFPE12513-E

メッセージ

この機能は現在接続しているServerではサポートされていません。

対処方法

必要に応じてServerのバージョンアップを行ってください。

KFPE12514-E

メッセージ

SQL TAは実行できません。

対処方法

SQL Tuning Advisorの起動時にプロセスが生成できませんでした。

KFPE12515-I

メッセージ

システムに対するクライアント環境変数を正常に登録しました。

対処方法

-

KFPE12516-I

メッセージ

定義系SQL生成に成功しました。

対処方法

-

KFPE12517-E

メッセージ

使用中のPC上にSQL Executerがインストールされていません。

対処方法

SQL Executerをインストールしてください。

KFPE12518-Q

メッセージ

Serverの管理情報を更新しますか？

対処方法

-

KFPE12519-I

メッセージ

いくつかの項目に対して無効な値が設定されています。これらの項目にはデフォルト値が表示されます。

対処方法

-

KFPE12520-E

メッセージ

名称の先頭に「pd」、「hds」、「0」の文字は使用できません。

対処方法

名称の先頭に「pd」、「hds」、「0」の文字以外を使用してください。

KFPE12521-E

メッセージ

大文字A～Zのみ入力可能です。

対処方法

-

KFPE12522-E

メッセージ

引数に抜けている順番があります。

対処方法

引数の順番に欠番がないように指定順番を見直してください。

KFPE12523-E

メッセージ

選択されたツール起動方法では使用できない環境変数、または、コマンドライン引数が指定されています。

対処方法

ツール起動方法で「ツール起動時にHiRDBシステム情報を使用する」を選択していない場合は、環境変数、または、コマンドライン引数に以下の変数を指定できません。
・%HIRDB_IP%
・%HIRDB_PATH%
・%HIRDB_PORT%
・%HIRDB_USER%

KFPE12524-E

メッセージ

指定された表示名は既に登録されています。

対処方法

同名のツールを登録することはできません。名称を変更してください。

KFPE12525-I

メッセージ

外部ツールの登録に成功しました。

対処方法

-

KFPE12526-E

メッセージ

ツールの実行に失敗しました。

対処方法

登録されているツールの引数や環境変数を見直してください。

KFPE12527-I

メッセージ

ツールの実行に成功しました。

対処方法

ツールが起動しない場合は、引数や環境変数の設定値が不適切である可能性があります。登録されているツールの引数や環境変数を見直してください。

KFPE12528-Q

メッセージ

ツールタブメニューから登録を削除します。よろしいですか？

対処方法

-

KFPE12529-E

メッセージ

指定された実行ファイルは存在しません。

対処方法

CM Consoleの稼動するマシンに存在しないファイルを指定することはできません。
実行ファイルのパスを確認してください。

KFPE12530-E

メッセージ

表示名に「\」を入力することはできません。

対処方法

「\」を使用しない名称に変更してください。

KFPE12531-I

メッセージ

外部ツールの登録内容を変更しました。

対処方法

-

KFPE12601-I

メッセージ

作業用ディレクトリの登録に成功しました。

対処方法

-

KFPE12602-E

メッセージ

選択された表はHiRDBシステム内に存在しません。

対処方法

-

KFPE12603-I

メッセージ

条件に合う対象がありません。

対処方法

-

KFPE12604-I

メッセージ

選択されたRDエリアが存在するサーバのアンロードデータファイルを使用します。

対処方法

-

KFPE12605-I

メッセージ

選択されたRDエリアが存在するサーバのソート用ワークディレクトリを使用します。

対処方法

-

KFPE12606-I

メッセージ

選択されたRDエリアが存在するサーバのインデクス情報ファイル用ディレクトリを使用します。

対処方法

-

KFPE12607-I

メッセージ

自動データメンテナンス機能が設定されていません。

対処方法

-

KFPE12608-I

メッセージ

自動データメンテナンス機能が一度も実行されていません。

対処方法

-

KFPE12609-E

メッセージ

自動データメンテナンスの解析に失敗しました。

対処方法

メンテナンス状態ボタンを実行し、表示されるメッセージを参照してください。

KFPE12610-I

メッセージ

メンテナンス方法が設定されていないため、解析だけを行います。

対処方法

-

KFPE12611-I

メッセージ

自動データメンテナンスの登録に成功しました｡

対処方法

-

KFPE12612-I

メッセージ

自動データメンテナンスの解除に成功しました｡

対処方法

-

KFPE12613-I

メッセージ

自動データメンテナンス状態の変更に成功しました｡

対処方法

-

KFPE12614-E

メッセージ

アンロードデータファイルは一つだけ指定してください。

対処方法

アンロードデータファイルを複数指定しないでください。

KFPE12615-I

メッセージ

メンテナンス処理に成功しました｡

対処方法

-

KFPE12616-I

メッセージ

メンテナンス処理に失敗しました｡

対処方法

-

KFPE12617-E

メッセージ

対象のオブジェクトが存在しないため、画面を開けませんでした。

対処方法

対象のオブジェクトが既に削除されている可能性があります。

KFPE12618-E

メッセージ

拡張DAT形式でのアンロードでは、アンロードログファイルを複数指定できません。

対処方法

拡張DAT形式でアンロードログファイルを作成する場合は、一つのファイルを指定してください。

KFPE12711-I

メッセージ

格納先の削除に成功しました。

対処方法

-

KFPE12712-I

メッセージ

格納先の作成に成功しました。

対処方法

-

KFPE12732-E

メッセージ

指定されたCPU使用率の注意値は無効な値です。

対処方法

-

KFPE12733-E

メッセージ

指定されたCPU使用率の警告値は無効な値です。

対処方法

-

KFPE12734-E

メッセージ

CPU使用率の警告値は注意値より大きい値を指定してください。

対処方法

-

KFPE12735-E

メッセージ

指定されたメモリ使用量の注意値は無効な値です。

対処方法

-

KFPE12736-E

メッセージ

指定されたメモリ使用量の警告値は無効な値です。

対処方法

-

KFPE12737-E

メッセージ

メモリ使用量の警告値は注意値より大きい値を指定してください。

対処方法

-

KFPE12738-E

メッセージ

指定された共用ﾒﾓﾘ使用量の注意値は無効な値です。

対処方法

-

KFPE12739-E

メッセージ

指定された共用ﾒﾓﾘ使用量の警告値は無効な値です。

対処方法

-

KFPE12740-E

メッセージ

共用ﾒﾓﾘ使用量の警告値は注意値より大きい値を指定してください。

対処方法

-

KFPE12741-E

メッセージ

指定されたメッセージキュー使用数の注意値は無効な値です。

対処方法

-

KFPE12742-E

メッセージ

指定されたメッセージキュー使用数の警告値は無効な値です。

対処方法

-

KFPE12743-E

メッセージ

メッセージキュー使用数の警告値は注意値より大きい値を指定してください。

対処方法

-

KFPE12744-E

メッセージ

指定されたセマフォ使用数の注意値は無効な値です。

対処方法

-

KFPE12745-E

メッセージ

指定されたセマフォ使用数の警告値は無効な値です。

対処方法

-

KFPE12746-E

メッセージ

セマフォ使用数の警告値は注意値より大きい値を指定してください。

対処方法

-

KFPE12747-E

メッセージ

以下の規則にしたがって、警告値は注意値より大きい値を指定してください。 E > W > I > -

対処方法

-

KFPE12748-E

メッセージ

指定された排他資源管理テーブル使用率の注意値は無効な値です。

対処方法

-

KFPE12749-E

メッセージ

指定された排他資源管理テーブル使用率の警告値は無効な値です。

対処方法

-

KFPE12750-E

メッセージ

排他資源管理テーブル使用率の警告値は注意値より大きい値を指定してください。

対処方法

-

KFPE12751-E

メッセージ

指定されたRDエリアセグメント使用率の注意値は無効な値です。

対処方法

-

KFPE12752-E

メッセージ

指定されたRDエリアセグメント使用率の警告値は無効な値です。

対処方法

-

KFPE12753-E

メッセージ

RDエリアセグメント使用率の警告値は注意値より大きい値を指定してください。

対処方法

-

KFPE12754-E

メッセージ

指定されたグローバルバッファプールヒット率の注意値は無効な値です。

対処方法

-

KFPE12755-E

メッセージ

指定されたグローバルバッファプールヒット率の警告値は無効な値です。

対処方法

-

KFPE12756-E

メッセージ

グローバルバッファプールヒット率の警告値は注意値より小さい値を指定してください。

対処方法

-

KFPE12757-E

メッセージ

指定されたHiRDBファイルシステム領域使用率の注意値は無効な値です。

対処方法

-

KFPE12758-E

メッセージ

指定されたHiRDBファイルシステム領域使用率の警告値は無効な値です。

対処方法

-

KFPE12759-E

メッセージ

HiRDBファイルシステム領域使用率の警告値は注意値より大きい値を指定してください。

対処方法

-

KFPE12760-E

メッセージ

指定された利用可能システムログファイル数の注意値は無効な値です。

対処方法

-

KFPE12761-E

メッセージ

指定された利用可能システムログファイル数の警告値は無効な値です。

対処方法

-

KFPE12762-E

メッセージ

利用可能システムログファイル数の警告値は注意値より小さい値を指定してください。

対処方法

-

KFPE12763-E

メッセージ

指定されたPDDIRが含まれるディスク使用率の注意値は無効な値です。

対処方法

-

KFPE12764-E

メッセージ

指定されたPDDIRが含まれるディスク使用率の警告値は無効な値です。

対処方法

-

KFPE12765-E

メッセージ

PDDIRが含まれるディスク使用率の警告値は注意値より大きい値を指定してください。

対処方法

-

KFPE12766-I

メッセージ

リソース警告値の設定に成功しました。

対処方法

-

KFPE12767-I

メッセージ

リソース警告値の設定に失敗しました。

対処方法

再度実行してください。

KFPE12768-I

メッセージ

HiRDBメッセージ監視を開始しました｡

対処方法

-

KFPE12769-I

メッセージ

HiRDBメッセージ監視を停止しました｡

対処方法

-

KFPE12770-I

メッセージ

HiRDBメッセージ監視機能の設定変更に成功しました｡

対処方法

-

KFPE12771-I

メッセージ

履歴情報の削除に成功しました｡

対処方法

-

KFPE12772-E

メッセージ

HiRDBメッセージの監視間隔は5分～720分の間の時間を指定してください｡

対処方法

-

KFPE12773-I

メッセージ

対象のオブジェクトが存在しないため、画面を開けませんでした。

対処方法

-

KFPE12774-I

メッセージ

対象のRDｴﾘｱはデータベース状態解析を行うことはできません｡

対処方法

-

KFPE12801-E

メッセージ

選択された列は、更新可能列として使用できません｡

対処方法

更新可能列に指定できない列が選択されました。更新可能列の指定については、HiRDBのマニュアルを参照してください。

KFPE12802-E

メッセージ

全ての列を更新可能列に指定することはできません｡

対処方法

HiRDBでは、すべての列を更新可能列にすることはできません。詳細は、HiRDBのマニュアルを参照してください。

KFPE12803-E

メッセージ

非ナル値からナル値への一回限りの更新ができない列に対し､一回限りのオプションが指定されています｡

対処方法

列の属性に対する一回限りの更新の可否については、HiRDBのマニュアルを参照してください。

KFPE19001-E

メッセージ

複数選択はできません。

対処方法

1つのみ選択してください。

KFPE19002-E

メッセージ

[<コントロール名>]を指定してください。

対処方法

処理を実行するために必要なオプションが指定されていません。

メッセージで表示されている<コントロール名>を指定してください。

KFPE19003-E

メッセージ

[<コントロール名>]を選択してください。

対処方法

処理を実行するために必要なオプションが選択されていません。

メッセージで表示されている<コントロール名>を選択してください。

KFPE19004-E

メッセージ

[<コントロール名>]は無効なフォーマットで指定されています。

正しいフォーマットで入力してください。

対処方法

画面の説明あるいはヘルプを参照し、正しいフォーマットで入力してください。

KFPE19005-E

メッセージ

[<コントロール名>]の指定値にスペースが含まれています。

スペースの入力はできません。

対処方法

メッセージで表示されている<コントロール名>ではスペースの入力はできません。

入力したスペースを取り除いてください。

KFPE19006-E

メッセージ

[<コントロール名>]が最大指定数<値>個を超えて入力されています。

対処方法

最大指定数内で入力してください。

KFPE19007-E

メッセージ

[<コントロール名>]で指定された値は範囲外です。

指定範囲内の値を入力してください。

対処方法

指定範囲内の値を入力してください。

KFPE19008-E

メッセージ

[<コントロール名>]は最大文字数を超えています。

<値>文字以内で指定してください。

対処方法

メッセージで表示されている<値>以内で文字を入力してください。

KFPE19009-E

メッセージ

指定された開始日時は終了日時を超えています。

開始日時は終了日時を超える入力ができません。

対処方法

指定した開始日時と終了日時を確認し、開始日時が終了日時を超えないように指定してください。

KFPE19010-E

メッセージ

メモリ不足が発生しました。

処理を実行することができません。

対処方法

-

KFPE19011-E

メッセージ

Consoleは同時処理実行数の最大値に達しています。

Consoleはこれ以上の処理を行うことはできません。

対処方法

実行中の処理が終了するのを待ってから再実行してください。

KFPE19012-E

メッセージ

ウィンドウの起動数が最大値に達しています。

Consoleはこれ以上の画面を開くことはできません。

対処方法

Console上で起動しているチャイルドウィンドウの数が最大値((65535))に達しています。

不要なチャイルドウィンドウを終了してから、新しいチャイルドウィンドウを起動してください。

KFPE19013-E

メッセージ

Consoleの内部処理に失敗しました。

最新の情報を取得することができませんでした。

対処方法

しばらく時間を置いてから再実行してください。

KFPE19014-E

メッセージ

Consoleの内部処理に失敗しました。

最新の情報を取得することができませんでした。

対処方法

しばらく時間を置いてから再実行してください。

KFPE19015-I

メッセージ

カタログを作成しました。

対処方法

-

KFPE19016-I

メッセージ

カタログの登録内容を変更しました。

対処方法

-

KFPE19017-E

メッセージ

情報が見つからなかったため、[<コントロール名>]は選択されていません。

対処方法

-

KFPE19018-Q

メッセージ

指定した <コントロール名> を削除します。

よろしいですか?

対処方法

-

KFPE19019-E

メッセージ

ポート番号で指定された値は範囲外です。

5001～65535の範囲で指定してください。

対処方法

指定範囲内の値を入力してください。

KFPE19999-E

メッセージ

予期しないエラーが発生しました。

対処方法

-

KFPE23001-E

メッセージ

通信中にエラーが発生しました。

対処方法

ServerとAgentがインストールされているサーバマシンの状態を確認してください。

KFPE23002-E

メッセージ

使用しているConsole,Server,Agent間でバージョン互換ができません。

対処方法

以下の要因が考えられます。Console、Server、Agentのバージョンを確認してください。
・ConsoleとServerのバージョンが異なります。ConsoleとServerのバージョンは同一である必要があります。
・現在使用するAgentでは使用できない機能、またはオプションが選択されています。各機能の注意事項を参照してください。

KFPE23003-E

メッセージ

レジストリの不正を検知しました。

対処方法

Serverのアンインストールを実行後、再度インストールを行ってください。

その際に、上書きインストールは実行しないでください。

KFPE23004-E

メッセージ

Agentとの通信に失敗しました。

対処方法

ServerとAgentがインストールされているサーバマシンの状態を確認してください。

KFPE23005-E

メッセージ

Agentに送信できませんでした。

対処方法

Agentがインストールされているマシンの状態を確認してください。

KFPE23006-E

メッセージ

この機能は、Serverでサポートされていません。

対処方法

ConsoleとServerのバージョンを確認してください。

KFPE23007-E

メッセージ

同時に接続できるConsoleの数が上限を超えました。

対処方法

接続しているConsoleの数を確認してください。

また、必要であれば[コンソールの接続数の設定]コマンドでConsoleの最大接続数を変更してください。

KFPE23008-E

メッセージ

Server内で予期しないエラーが発生しました。

対処方法

Serverの再起動を行ってから、処理を再度実行してください。

頻繁に発生する場合は、保守員に連絡してください。

KFPE23009-E

メッセージ

通信中にソケットが閉じられました。

対処方法

Agentがインストールされているマシンの状態を確認してください。

KFPE23010-E

メッセージ

通信開始処理に失敗しました。

対処方法

保守員に連絡してください。

KFPE23011-E

メッセージ

タイムアウトが発生しました。

対処方法

しばらくしてから、再度実行してください。

頻繁に発生する場合は、保守員に連絡してください。

KFPE23012-E

メッセージ

指定されたHiRDBシステムがServerに登録されていません。

対処方法

Serverの状態の更新を行ってください。

KFPE23013-E

メッセージ

ユーザ認証に失敗しました。

対処方法

パスワードを確認してください。

KFPE23014-E

メッセージ

通信中にソケットが初期化されました。

対処方法

しばらくしてから、再度実行してください。

頻繁に発生する場合は、保守員に連絡してください。

KFPE23015-E

メッセージ

指定されたカタログが存在しません。

対処方法

古いデータがConsoleに表示されている可能性があります。Consoleの状態を更新してください。

KFPE23016-E

メッセージ

ファイルアクセスの権限がありません。

対処方法

Serverのインストールディレクトリ下のすべてのアクセス権限を確認してください。

KFPE23017-E

メッセージ

情報検索に失敗しました。

対処方法

処理の実行のために指定した内容を再度確認してください。

指定したリソースに対して別画面から操作を行っていた場合、画面を開き直すか最新の状態に更新してから再度条件を指定し、実行してください。

頻発する場合は保守員に連絡してください。

KFPE23018-E

メッセージ

同名のカタログが既に存在しています。

対処方法

カタログ名を変更し再度実行してください。

KFPE23019-E

メッセージ

指定されたスケジュール実行結果が存在しません。

対処方法

古いデータがConsoleに表示されている可能性があります。Consoleの状態を更新してください。

KFPE23020-E

メッセージ

指定されたカタログ種別が不正です。

対処方法

ConsoleのバージョンあるいはServerのバージョンが古い可能性があります。

ConsoleとServerのバージョンを確認してください。

KFPE23021-E

メッセージ

同名のスケジュールが既に存在しています。

対処方法

スケジュール名を変更するか、同名スケジュールの削除を行ってから再度実行してください。

KFPE23022-E

メッセージ

指定されたスケジュール種別が不正です。

対処方法

ConsoleのバージョンあるいはServerのバージョンが古い可能性があります。

ConsoleとServerのバージョンを確認してください。

KFPE23023-E

メッセージ

指定されたスケジュールが存在しません。

対処方法

古いデータがConsoleに表示されている可能性があります。Consoleの状態を更新してください。

KFPE23024-E

メッセージ

CMで管理できる情報が上限に達しました。

対処方法

使われていない情報の削除を行ってください。

KFPE23025-E

メッセージ

スケジュール処理に失敗しました。

対処方法

しばらくしてから、再度実行してください。

頻繁に発生する場合は、保守員に連絡してください。

KFPE23026-E

メッセージ

カタログ処理に失敗しました。

対処方法

しばらくしてから、再度実行してください。

頻繁に発生する場合は、保守員に連絡してください。

KFPE23027-E

メッセージ

選択されたオプションが不正です。

対処方法

正しいオプションを選択して再度実行してください。

KFPE23028-E

メッセージ

バックアップに必要な情報がServerにありません。

Serverの管理情報を最新の状態に更新してから、再度実行してください。

対処方法

Serverが保持する情報が古い可能性があります。Serverの管理情報を最新の状態に更新してから、再度実行してください。

再実行してもバックアップに失敗する場合は、保守員に連絡してください。

KFPE23029-E

メッセージ

リカバリに必要な情報がServerにありません。

指定したリカバリ条件を見直してから、再度実行してください。

対処方法

バックアップ時の情報がServerに保持されていない可能性があります。指定したリカバリ条件を見直してから、再度実行してください。

再実行してもリカバリに失敗する場合は、保守員に連絡してください。

KFPE23030-E

メッセージ

条件に合う対象がありません。

対処方法

-

KFPE23031-E

メッセージ

パスワードの変更に失敗しました。

対処方法

-

KFPE23032-E

メッセージ

旧パスワードが間違っています。

対処方法

旧パスワードを確認してください。

KFPE23033-E

メッセージ

管理情報の更新に失敗しました。

対処方法

Agentがインストールされているマシンの状態と、管理対象HiRDBの状態を確認してください。詳細情報がある場合は、詳細情報に表示されているメッセージを確認してください。

KFPE23034-E

メッセージ

バージョン情報の取得に失敗しました。

対処方法

しばらくしてから、再度実行してください。

KFPE23035-E

メッセージ

コンソールの最大接続数の取得に失敗しました。

対処方法

-

KFPE23036-E

メッセージ

システムログのアンロードに失敗しました。

対処方法

指定したアンロードログファイルの格納先が削除されている可能性があります。

古いデータがConsoleに表示されている可能性がありますので、一旦、[システムログのアンロード]の画面を閉じた後で再度メニューを選択してください。

システムログのアンロードをカタログで実行した場合は、カタログが無効になっている可能性があります。カタログを変更あるいは削除してください。

頻繁に発生する場合は、保守員に連絡してください。

KFPE23037-E

メッセージ

指定されたディレクトリは存在しません。

対処方法

存在するディレクトリを指定してください。

KFPE23038-E

メッセージ

システムログの状態変更に失敗しました。

対処方法

指定内容の見直しを行った後で、再度実行してください。

既にアンロード済み状態になっているシステムログを指定すると失敗します。

HiRDBの運用上システムログファイルのアンロードが不要になっている場合は、状態変更に失敗します。

上記以外の理由で頻繁に発生する場合は、保守員に連絡してください。

KFPE23039-E

メッセージ

HiRDBシステムの新規登録に失敗しました。

対処方法

-

KFPE23040-E

メッセージ

HiRDBニックネームの変更に失敗しました。

対処方法

-

KFPE23041-E

メッセージ

メモリー領域が不足しているため処理を中断しました。

対処方法

しばらくしてから、再度実行してください。

頻繁に発生する場合は、Serverがインストールされているマシンのメモリを見直してください。

KFPE23042-E

メッセージ

追加するRDエリアの検索に失敗しました。

対処方法

保守員に連絡してください。

KFPE23043-E

メッセージ

サービスの開始処理に失敗しました。

対処方法

しばらくしてから、再度実行してください。

頻繁に発生する場合は、保守員に連絡してください。

KFPE23044-E

メッセージ

バックアップオプションの確認に失敗しました。

対処方法

バックアップに必要な情報がServerにありません。指定したオプションを見直してから再度実行してください。

KFPE23045-E

メッセージ

選択されたアイテム数が多すぎるため、情報検索処理が続行できませんでした。

対処方法

操作の対象となるアイテムの数を減らして再度実行してください。

一度に操作の対象とできるアイテム数は、255個です。

KFPE23046-E

メッセージ

Server内で予期しないエラーが発生しました。

頻発する場合は、保守員に連絡してください。

対処方法

-

KFPE23047-E

メッセージ

CMの管理に失敗しました。削除に失敗したバックアップファイルがあります。

対処方法

再度実行して下さい。

頻発する場合は、保守員に連絡してください。

KFPE23048-E

メッセージ

指定されたNetBackupクライアントホスト名の検索に失敗しました。

対処方法

-

KFPE23049-E

メッセージ

更新間隔の取得に失敗しました。

対処方法

-

KFPE23050-E

メッセージ

更新間隔の変更に失敗しました。

対処方法

-

KFPE23051-E

メッセージ

Consoleの最大接続数の変更に失敗しました。

対処方法

-

KFPE23052-E

メッセージ

管理HiRDBの解除に失敗しました。

対処方法

-

KFPE23053-E

メッセージ

指定されたポリシーは存在しません。

対処方法

古いデータがConsoleに表示されている可能性があります。Consoleの状態を更新してください。

KFPE23054-E

メッセージ

ポリシーの削除に失敗しました。

対処方法

-

KFPE23055-E

メッセージ

削除に失敗した格納先があります。

対処方法

エラー詳細で削除に失敗した格納先が出力されます。それを参照し、以下のことを確認して原因を取り除いてください。

格納先の中にファイルが存在する可能性があります。全てのファイルを削除または移動した後で再度実行してください。

頻繁に発生する場合は、保守員に連絡してください。

KFPE23056-E

メッセージ

Server起動処理中のため、接続できません。

しばらくしてから、再度接続してください。

対処方法

再度実行してください。

頻繁に発生する場合は、保守員に連絡してください。

KFPE23057-E

メッセージ

Server停止処理中のため、処理を中断しました。

対処方法

Server終了後、数分待ってからServerサービスを開始してください。

Consoleの接続を行い、処理を再度実行してください。

KFPE23058-E

メッセージ

HiRDB管理情報のメンテナンス中であるため、処理を行えませんでした。

しばらくしてから、再度実行してください。

対処方法

頻繁に発生する場合は、保守員に連絡してください。

KFPE23059-E

メッセージ

HiRDB管理情報の更新中であるため、処理を行えませんでした。

対処方法

頻繁に発生する場合は、管理情報の更新間隔を見直してください。

KFPE23060-E

メッセージ

HiRDBが停止中のため、処理を続行できませんでした。

対処方法

管理対象HiRDBの状態を確認してください。

停止中の場合は、管理対象HiRDBを開始してください。

KFPE23061-E

メッセージ

指定されたHiRDBは既にHiRDB CMで管理されています。

対処方法

指定されたHiRDBは既に別のHiRDB CMで管理されています。

HiRDBを管理しているHiRDB CMで[管理HiRDBの解除]を実行してから、再実行してください。

KFPE23062-E

メッセージ

リカバリオプションの確認に失敗しました。

対処方法

リカバリ操作に必要なバックアップ情報がありません。指定したオプションを見直してから再度実行してください。

または、リカバリ対象に対してバックアップが取得されていないことが考えられます。バックアップを取得していない場合は、リカバリ操作を行うことができません。

KFPE23063-E

メッセージ

他のHiRDBシステムで既に同じニックネームが使用されています。

対処方法

指定されたニックネームは、Serverが管理する他のHiRDBシステムで使用されています。別のニックネームを指定してください。

KFPE23064-E

メッセージ

権限変更に失敗しました。管理情報を更新してからユーザマップを参照してください。

対処方法

管理情報を更新してからユーザマップを参照してください。

KFPE23065-E

メッセージ

HiRDBファイルシステム領域情報の取得に失敗しました。

対処方法

管理情報を更新して、指定されたHiRDBファイルシステム領域が存在するか確認してください。

KFPE23066-E

メッセージ

差分バックアップに必要な情報がServerにありません。

Serverの管理情報を最新の状態に更新してから、再度実行してください。

対処方法

Serverが保持する情報が古い可能性があります。Serverの管理情報を最新の状態に更新してから、再度実行してください。再実行してもバックアップに失敗する場合は、バックアップウィザードまたはカスタマイズから、フルバックアップを取得し直してください。

KFPE23067-E

メッセージ

Serverのバージョンアップに失敗しました。

対処方法

再度Serverのサービスを開始してください。再実行してもバージョンアップに失敗する場合は、保守員に連絡してください。

KFPE23068-E

メッセージ

Serverのバージョンダウンは行えません。

対処方法

以前使用していたバージョン以上のServerを上書きインストールしてください。

KFPE23069-E

メッセージ

JP1/AJS2との連携登録が未登録です。

対処方法

Consoleの、[オプション]－[JP1/AJS2との連携]操作を行って下さい。

KFPE23070-E

メッセージ

カタログ情報の更新に失敗しました。

対処方法

保守員に連絡してください。

KFPE23071-E

メッセージ

AJS2/Consoleに表示されているカタログ情報が最新の情報と一致しません。

対処方法

画面を一旦閉じて、再度入力をしてください。

KFPE23072-E

メッセージ

カタログの登録に失敗しました。

対処方法

カタログの登録処理中に別のConsoleから当該カタログが削除された可能性があります。画面の更新を行い、最新の情報を取得してから再度実行してください。

KFPE23073-E

メッセージ

指定したパスが不正です。

対処方法

指定したパスを見直し、正しいパスを指定後に再度実行してください。

KFPE23074-E

メッセージ

ファイルIO操作に失敗しました。

対処方法

CM Serverをインストールしたディスクに対するファイルIO操作が正常にできるか確認してください。

KFPE23075-E

メッセージ

Server内でエラーが発生しました。

対処方法

CM Server内部処理でエラーが発生しました。保守員に連絡してください。

KFPE23076-E

メッセージ

Serverに不正に接続しました。

対処方法

「HiRDBの登録」操作時にCM Serverが使用するポート番号を指定しないでください。

KFPE23077-E

メッセージ

リソース警告値の設定に失敗しました。

対処方法

CM Serverが停止しているかまたは、CM Serverへの情報更新処理に負荷がかかっているため、リソース警告値をCM Serverへ設定することができません。CM Serverが停止していないかを確認後、再度設定してください。

KFPE23078-E

メッセージ

指定したパスが長すぎます。

対処方法

パス名を短くして再度実行してください。

KFPE23079-E

メッセージ

作業ディレクトリが指定されていません。有効なパス名を設定してください。

対処方法

データベース状態解析ユティリティで使用する作業ディレクトリが設定されていません。[データメンテナンス]-[データベース状態解析環境設定]で作業ディレクトリを設定してから再度実行してください。

KFPE23080-E

メッセージ

Agentのバージョンが古いので、制御文ファイルを指定してください。

対処方法

Agentのバージョンが古いため、制御文の自動生成が実行できません。制御文ファイルを指定していただくか、Agentのバージョンをv0300以上のものにバージョンアップをご検討ください。

KFPE23081-E

メッセージ

HiRDBファイルシステム領域の登録に失敗しました。

対処方法

保守員に連絡してください。

KFPE23082-E

メッセージ

指定したHiRDBが登録されていません。

対処方法

Consoleから該当するHiRDBをCMに登録してください。

KFPE23083-E

メッセージ

CMに登録されているシステムはありません。

対処方法

CMにHiRDBシステムを登録してください。

KFPE23084-E

メッセージ

全システムの情報取得に失敗しました。

対処方法

それぞれのHiRDBシステムに対するエラーコードを確認し対策してから、再度実行してください。

KFPE23085-E

メッセージ

カタログ登録する処理を実行する際にエラーとなる不適切なオプションが選択されています。カタログの設定を再度見直してください。

対処方法

カタログ登録する処理を実行する際にエラーとなる不適切なオプションが選択されています。例えばバージョン互換性のないオプションが選択されている可能性があります。カタログの設定を見直した上で再度実行してください。

KFPE23086-E

メッセージ

JP1/AJS2-SC連携コマンドで指定されたオプションに不正があります。

対処方法

オプションの値を確認し、再度実行してください。

KFPE23087-E

メッセージ

再編成時期予測機能の実行環境が整っていないため処理を中断しました。

対処方法

定義ファイル、または運用管理RDエリアを確認してください。

KFPE23088-E

メッセージ

すでにメンテナンス機能が登録されています。

対処方法

自動データメンテナンス機能の解除を行った後に、登録してください。

KFPE23089-E

メッセージ

一時停止のためのメンテナンススケジュールの解除は成功しましたが、管理情報の更新に失敗しました。

対処方法

一度自動データメンテナンス機能の解除を実行してください。

KFPE23090-E

メッセージ

メンテナンススケジュールの登録に成功しましたが、管理情報の更新に失敗し,その後のメンテナンススケジュールの解除にも失敗しました。

対処方法

crontabsファイル内の該当する情報を削除して、crontabを実行してください。

KFPE23091-E

メッセージ

メンテナンスの解除は成功しましたが、管理情報の更新に失敗しました。

対処方法

再度自動データメンテナンス機能の解除を実行してください。もしくは、管理HiRDBの解除を実行してください。

KFPE23092-E

メッセージ

管理情報の更新に失敗しました。一部のメンテナンスデータが削除されています。

対処方法

Agentのインストールディレクトリ以下のsave/maintenanceディレクトリの状態を確認し、削除されていないファイルを削除してください。

KFPE23093-E

メッセージ

メンテナンス処理データの削除に失敗しました。

対処方法

Agentのインストールディレクトリ以下のsave/maintenanceディレクトリの状態を確認し、削除されていないファイルを削除してください。

KFPE23094-E

メッセージ

指定されたHiRDBファイルシステム領域またはディレクトリは使用中です。

対処方法

同じパスのHiRDBファイルシステム領域またはディレクトリは、別の用途で使用されています。また、指定されたパスで既に登録済みのHiRDBファイルシステム領域は、使用目的がユティリティ用でなければ、バックアップファイル格納先およびアンロードログファイル格納先として初期設定できません。確認してください。既に不要なHiRDBファイルシステム領域またはディレクトリの場合は、格納されているHiRDBファイルまたはファイルの削除を行った後に、再度登録を行ってください。

KFPE23095-E

メッセージ

指定されたHiRDBファイルシステム領域は登録済みです。

対処方法

指定されたHiRDBファイルシステム領域は、既に登録されています。確認してください。

KFPE23096-E

メッセージ

指定されたHiRDBシステムのマシンへの接続に失敗しました。

対処方法

対象システムが系切り替え構成を使用している場合は、状態情報の更新を行ってください。対象HiRDBシステムのマシンの状態を確認してください。

KFPE23097-E

メッセージ

対象のバックアップファイルについて、より新しい情報が既にHiRDB CMで管理されています。

対処方法

対象のバックアップファイルを再度確認してください。

KFPE23098-E

メッセージ

インナレプリカ機能は未サポートです。

対処方法

指定されたHiRDBのOSではインナレプリカ機能をサポートしていません。したがって、インナレプリカに関する操作は実行できません。また、ユティリティ操作で世代番号を指定することはできません。世代番号の指定を解除して、再度処理を行ってください。

KFPE23099-E

メッセージ

Agentの起動に失敗しました。

対処方法

-

KFPE23100-E

メッセージ

指定されたHiRDBの環境では開始制御を行うことができません。

対処方法

HiRDBのバージョン、OSを確認してください。トランザクションキューイング機能はHiRDBのバージョンがv07-03以上の場合に使用できます。pdrpause機能はHiRDBのOSがUNIXの場合に使用できます。

KFPE23101-E

メッセージ

指定されたHiRDBのバージョンではトランザクションキューイング機能を使用することができません。

対処方法

HiRDBのバージョンを確認してください。トランザクションキューイング機能はHiRDBのバージョンがv07-03以上の場合に使用できます。

KFPE23102-E

メッセージ

指定されたHiRDBのOSではPDRPAUSE機能を使用することができません。

対処方法

HiRDBのOSを確認してください。pdrpause機能はHiRDBのOSがUNIXの場合に使用できます。

KFPE23103-E

メッセージ

指定されたバックアップ情報では、使用中のServerを回復することはできません。

対処方法

指定されたバックアップ情報が現在のServerのバックアップ情報ではない可能性があります。以下の条件に該当する場合、リカバリ処理は実行できません。
・バックアップ実行後にServerのバージョンアップを行った

KFPE23104-E

メッセージ

管理情報のリカバリを行うための前処理に失敗しました。再度実行してください。

対処方法

リカバリの前処理でエラーが発生したため、以下の状態になっている可能性があります。CMの運用を続行せず、管理情報のリカバリを再度実行してください。
・1個または複数のHiRDBシステムに対し、設定済みの自動メンテナンスが解除された。
・1個または複数のHiRDBシステムに対し、Agentとの接続が停止された。

KFPE23105-E

メッセージ

Server内で重大なエラーが発生しています。Serverを停止し、リカバリコマンドによる回復を実行してください。

対処方法

管理情報のリカバリ中にエラーが発生したため、以降の処理をServerでは受け付けることができません。 Serverを停止し、Serverをインストールしたマシン上でリカバリコマンドを実行してください。

KFPE23106-E

メッセージ

管理情報の更新処理を行っているため、管理情報のバックアップ/リカバリを実行できません。

対処方法

管理情報の更新機能を停止した後、再度実行してください。

KFPE23107-E

メッセージ

Serverで実行中の処理があるため、管理情報のバックアップ/リカバリを実行できません。

対処方法

現在行っているConsoleからの操作が終了した後で、再度実行してください。

KFPE23108-E

メッセージ

管理情報のバックアップを行っているため、Serverへの要求を受け付けることができません。

対処方法

しばらくしてから再度実行してください。

KFPE23109-E

メッセージ

管理情報のリカバリを行っているため、Serverへの要求を受け付けることができません。

対処方法

しばらくしてから再度実行してください。

KFPE23110-E

メッセージ

管理情報のバックアップ用管理ファイルが不正です。

対処方法

バックアップ用管理ファイルが不当に変更された可能性があります。指定されたバックアップ情報をリカバリに使用することはできません。別のバックアップ情報を使用してください。

KFPE23111-E

メッセージ

管理情報のバックアップを行うための前処理に失敗しました。再度実行してください。

対処方法

管理情報のバックアップを再度実行してください。頻発する場合は保守員に連絡してください。

KFPE23112-E

メッセージ

管理情報のバックアップに失敗しました。再度実行してください。

対処方法

管理情報のバックアップを再度実行してください。頻発する場合は保守員に連絡してください。

KFPE23113-E

メッセージ

バックアップ時に実行する管理情報の再編成に失敗しました。再度実行してください。

対処方法

管理情報のバックアップを再度実行してください。頻発する場合は保守員に連絡してください。

KFPE23114-E

メッセージ

管理情報のバックアップ/リカバリでエラーが発生し、Server側で処理前の状態への回復を試みましたが、回復できませんでした。

対処方法

＜バックアップの場合＞
指定されたディレクトリに格納されていた以前のバックアップ情報を使用した回復が行えません。
再度バックアップを実行し、Serverの障害に備えてください。
＜リカバリの場合＞
Server内のデータに不整合が発生しています。
Serverを停止し、Serverをインストールしたマシン上でリカバリコマンドを実行してください。

KFPE23115-E

メッセージ

Server内で重大なエラーが発生しています。Serverを停止し、リカバリコマンドによる回復を実行してください。

対処方法

Server運用中の自動バックアップ処理またはリカバリ処理において、HiRDB CMの運用続行が不可能なエラーが発生しました。Serverではこれ以降の処理を受け付けることができません。Serverを停止し、Serverをインストールしたマシン上でリカバリコマンドを実行してください。

KFPE23116-E

メッセージ

管理情報のバックアップ格納先ディレクトリが存在しない、またはディレクトリではない可能性があります。

対処方法

管理情報のバックアップ格納先として使用するパスが、実在するディレクトリであることを確認してください。
ディレクトリではない場合、管理情報のバックアップの設定で正しいディレクトリを指定しなおしてください。
ディレクトリが存在しない場合、作成してください。

KFPE23117-E

メッセージ

指定されたバックアップ格納先にはバックアップがありません。

対処方法

過去にバックアップを取得した管理情報のバックアップ格納先を指定してください。

KFPE23118-E

メッセージ

Serverの稼動状態が不正です。Serverを停止し、再度開始してください。

対処方法

Serverを一旦停止し、その後再開始してください。

KFPE23119-E

メッセージ

指定されたバックアップと最新のバックアップの取得時刻が異なります。再度、使用するバックアップを確認してください。

対処方法

管理情報のリカバリの確認画面を表示している間に、Serverの自動バックアップが実行されたか、 別のConsoleからバックアップが実行された可能性があります。再度、リカバリに使用するバックアップの情報を確認してください。

KFPE23120-E

メッセージ

警告値が設定されていないため、自動データメンテナンスの登録を行いませんでした。

対処方法

警告値設定画面で、RDエリア警告値の設定をおこなってください。

KFPE23121-E

メッセージ

UNIX版Serverには、04-00未満のAgentを登録することはできません。

対処方法

UNIX版Serverには、v0400未満のAgentを登録するこはできません。Agentをバージョンアップしてください。

KFPE23122-E

メッセージ

Agent上に不当なスケジュールが残っています。

対処方法

-

KFPE23123-E

メッセージ

HiRDBメッセージ監視機能情報を設定してください。

対処方法

HiRDBメッセージ監視機能の監視状態情報を設定してください。

KFPE23124-E

メッセージ

HiRDBメッセージ監視機能が監視中です。監視状態を確認してください。

対処方法

HiRDBメッセージ監視機能を停止してください。機能を停止しても解決しない場合は、Serverを一旦停止し、その後再開始してください。

KFPE23125-E

メッセージ

HiRDBメッセージ監視機能が非監視中です。監視状態を確認してください。

対処方法

HiRDBメッセージ監視機能を開始してください。機能を停止しても解決しない場合は、Serverを一旦停止し、その後再開始してください。

KFPE23126-E

メッセージ

監視処理情報が登録されていません。

対処方法

Serverを一旦停止し、その後再開始してください。

KFPE23127-E

メッセージ

全ての表または認可識別子に対して、アクセス権限変更に失敗しました。

対処方法

エラーコードと一緒に詳細が記載されている場合は、それらの対策を行ってから再度実行してください。

KFPE23128-E

メッセージ

07-02未満のHiRDBでは、既存バックアップファイルを登録することはできません。

対処方法

本機能はHiRDBのバージョンが07-02以降の場合に使用できます。
07-02未満のHiRDBでは、既存バックアップファイルをHiRDB CMで管理することはできません。

KFPE23129-E

メッセージ

既存バックアップファイルの登録に失敗しました。

対処方法

再度実行してください。
詳細が表示されている場合は、Agentでバックアップファイルの情報取得に失敗しています。以下の原因が考えられます。
・指定したファイルが存在しない
・指定したファイルへのアクセス権限がない
・指定したファイルがpdcopyで取得したバックアップではない
・指定したファイル数が不足している
詳しくはメッセージ中のエラーコードを参照してください。

KFPE23130-E

メッセージ

指定されたバックアップファイルは既にHiRDB CMで管理されています。

対処方法

バックアップファイル表示/削除画面からHiRDB CMで管理されているバックアップファイルを確認してください。

KFPE23131-E

メッセージ

07-02未満のHiRDBでは、既存アンロードログを登録することはできません。

対処方法

本機能はHiRDBのバージョンが07-02以降の場合に使用できます。
07-02未満のHiRDBでは、既存アンロードログファイルをHiRDB CMで管理することはできません。

KFPE23132-E

メッセージ

既存アンロードログファイルの登録に失敗しました。

対処方法

再度実行してください。
詳細が表示されている場合は、Agentでアンロードログファイルの情報取得に失敗しています。以下の原因が考えられます。
・指定したファイルが存在しない
・指定したファイルへのアクセス権限がない
・指定したファイルがアンロードログファイルではない
・HiRDBファイルの場合、絶対パスが167バイトを超えている
・アンロードログファイル名が255バイトを超えている
・指定したHiRDBやサーバのアンロードログファイルではない
詳しくはメッセージ中のエラーコードを参照してください。

KFPE23134-E

メッセージ

バックアップに含まれるRDエリア情報が現在のHiRDBシステム情報と一致しません。

対処方法

バックアップに含まれるバックアップ対象RDエリアの情報が、現在のHiRDBシステムのRDエリア情報と一致しません。リカバリで使用できないため、登録しませんでした。バックアップ取得後にHiRDBシステム構成が変更された可能性があります。新しいバックアップを取得してください。

KFPE23135-E

メッセージ

指定されたアンロードログファイルの名称が長すぎます。

対処方法

HiRDB CMではファイル名称が256バイト以上のアンロードログファイルを登録できません。ファイル名称を変更するか、または、本ファイルを既存アンロードログファイルの登録で指定しないでください。

KFPE23136-E

メッセージ

アンロードログファイル格納先の登録処理に失敗したため、アンロードログファイルの登録処理を中断しました。

対処方法

以下のことを確認してください。
指定したファイルを格納するディレクトリ、または、HiRDBファイルシステム領域が別の用途でHiRDB CMに管理されている場合、そのファイルを登録できません。登録するファイルのパスを変更してから、再度実行してください。
＜アンロードログファイルが通常ファイルの場合＞
・指定したファイルを格納するディレクトリがバックアップファイルの格納先として登録されていないか
＜アンロードログファイルがHiRDBファイルの場合＞
・指定したHiRDBファイルの存在するHiRDBファイルシステム領域がバックアップファイルの格納先として登録されていないか
・指定したHiRDBファイルの存在するHiRDBファイルシステム領域が差分バックアップの管理ファイルを格納するHiRDBファイルシステム領域として使用されていないか

KFPE23137-E

メッセージ

改ざん防止表への移行に必要な情報の取得に失敗しました。

対処方法

再度実行してください。

KFPE23138-E

メッセージ

指定されたHiRDBファイルシステム領域は複数のサーバにまたがっているため、世代登録が実行できません。

対処方法

複数のサーバにまたがっているHiRDBファイルシステム領域の世代登録を実行することはできません。また、そのようなHiRDBファイルシステム領域上に存在するRDエリアに対するレプリカRDエリアは作成することができません。

KFPE23139-E

メッセージ

バックアップファイル格納先の登録処理に失敗したため、バックアップファイルの登録処理を中断しました

対処方法

以下のことを確認してください。
指定したファイルを格納するディレクトリ、または、HiRDBファイルシステム領域が別の用途でHiRDB CMに管理されている場合、そのファイルを登録できません。登録するファイルのパスを変更してから、再度実行してください。
＜バックアップファイルが通常ファイルの場合＞
・指定したファイルを格納するディレクトリがアンロードログファイルの格納先として登録されていないか
＜バックアップファイルがHiRDBファイルの場合＞
・指定したHiRDBファイルの存在するHiRDBファイルシステム領域がアンロードログファイルの格納先として登録されていないか
・指定したHiRDBファイルの存在するHiRDBファイルシステム領域が差分バックアップの管理ファイルを格納するHiRDBファイルシステム領域として使用されていないか

KFPE23140-E

メッセージ

指定されたカタログはスケジュールされているため、削除または変更することができません。

対処方法

指定されたカタログはスケジュールされています。画面を更新し、スケジュールの状態を再度確認してください。カタログを削除または変更する場合は、このカタログに対するスケジュールの削除を先に行ってください。

KFPE23141-E

メッセージ

オリジナルHiRDBファイルシステム領域として指定されたものに、既にレプリカHiRDBファイルシステム領域として登録されているものが含まれています。

対処方法

オリジナルHiRDBファイルシステム領域として指定されたものに、既にレプリカHiRDBファイルシステム領域として登録されているものが含まれています。先に世代削除を行ってから、再度実行してください。

KFPE23142-E

メッセージ

NetBackupに必要な情報がServerにありません。再度ポリシーを作成し、バックアップを実行してください。

対処方法

NetBackupを実行するために必要なデータがServerから削除された可能性があります。
再度NetBackupポリシーを作成し、バックアップウィザード、または、カスタマイズからバックアップを実行してください。

KFPE23143-E

メッセージ

指定された新パスワードは他のユーザのパスワードとして使用されているため、パスワードを変更することができません。

対処方法

新パスワードを他のパスワードに変更してください。

KFPE23601-E

メッセージ

コマンド引数の個数が不正です。

対処方法

実行コマンドの引数指定形式を確認して、再度実行してください。

KFPE23602-E

メッセージ

コマンド引数が不正です。

対処方法

保守員に連絡してください。

KFPE23603-E

メッセージ

コマンド引数が不正です。

対処方法

保守員に連絡してください。

KFPE23604-E

メッセージ

コマンド引数に指定された値は、絶対パスではありません。

対処方法

絶対パス形式でパスを指定してください。

KFPE23605-E

メッセージ

コマンド引数に指定されたパスが長すぎます。

対処方法

実行コマンドの形式を確認して、再度実行してください。

KFPE23606-E

メッセージ

コマンド引数が不正です。

対処方法

実行コマンドの形式を確認して、再度実行してください。

KFPE23701-E

メッセージ

Unexpected error occurred during internal process of command.

対処方法

コマンド内部処理中に予期せぬエラーが起こりました。再実行してください。

KFPE23702-E

メッセージ

Memory error occurred during internal process of command.

対処方法

コマンド内部処理中にメモリエラーが起こりました。実行中の処理が存在する場合、その処理が終了するのを待って、再実行してください。また、不要なプログラムを終了させてください。

KFPE23703-E

メッセージ

Connect error occurred during communication with the CM-Server.

対処方法

CM-Serverとの通信処理中に接続エラーが起こりました。CM-Serverの状態を確認してください。

KFPE23704-E

メッセージ

Socket error occurred during communication with the CM-Server.

対処方法

CM-Serverとの通信処理中にソケットエラーが起こりました。CM-Serverの状態を確認してください。

KFPE23705-E

メッセージ

Time-over error occurred during communication with the CM-Server.

対処方法

CM-Serverとの通信処理中にタイムオーバエラーが起こりました。CM-Serverの状態を確認してください。

KFPE23706-E

メッセージ

The initialization of the socket failed in the communication with the CM-Server.

対処方法

CM-Serverとの通信処理中にソケット初期化に失敗しました。しばらくしてから、再度実行してください。

KFPE23707-E

メッセージ

An error occurred in registry access.

対処方法

レジストリアクセスに失敗しました。CM-Serverのアンインストールを実行後、再度インストールを行ってください。

KFPE23708-E

メッセージ

Illegal data was detected.

対処方法

不正なデータを検出しました。入力データを修正し、再実行してください。

KFPE23709-E

メッセージ

The error of the version of input data was detected.

対処方法

入力データのデータバージョンエラーを検出しました。入力データを修正し、再実行してください。

KFPE23710-E

メッセージ

FunctionID error of input data was detected.

対処方法

入力データの実行機能IDエラーを検出しました。入力データを修正し、再実行してください。

KFPE23711-E

メッセージ

The range error of input data was detected.

対処方法

入力データの範囲指定エラーを検出しました。入力データを修正し、再実行してください。

KFPE23712-E

メッセージ

DOM-APIからの例外を検知しました。

対処方法

DOM-APIからの例外を検知しました。入力データを修正し、再実行してください。

KFPE23713-E

メッセージ

XMLパーサからの例外を検知しました。

対処方法

XMLパーサからの例外を検知しました。入力データを修正し、再実行してください。

KFPE23714-E

メッセージ

The XML purser error was detected during the input data analysis processing.

対処方法

XMLパーサーエラーを入力データ分析処理で検出しました。入力データを修正し、再実行してください。

KFPE23715-E

メッセージ

The input data error was detected.

対処方法

入力データエラーを検出しました。入力データを修正し、再実行してください。

KFPE23716-E

メッセージ

The error of request information on input data was detected.

対処方法

入力データのリクエスト情報エラーを検出しました。入力データを修正し、再実行してください。

KFPE23717-E

メッセージ

It failed in the analysis of request information in input data.

対処方法

入力データ内のリクエスト情報の解析でエラーを検出しました。入力データ内のリクエスト情報の構成を修正し、再実行してください。

KFPE23718-E

メッセージ

The setup is not yet complete.

対処方法

セットアップが完了していません。CM-Serverのアンインストールを実行後、再度インストールを行ってください。

KFPE23719-E

メッセージ

The mistake was found in the tag of input data.

対処方法

入力データのタグに誤りがあります。入力データのリクエスト情報を修正し、再実行してください。

KFPE23720-E

メッセージ

The catalog was not found

対処方法

指定されたカタログが見つかりません。

KFPE23740-I

メッセージ

HiRDB or Server was started.

対処方法

シナリオコンダクタコマンドからのHiRDBシステム開始に成功しました。

KFPE23741-I

メッセージ

HiRDB or Server was stopped.

対処方法

シナリオコンダクタコマンドからのHiRDBシステムの停止に成功しました。

KFPE23742-I

メッセージ

HiRDB or Server stauts was displayed.

対処方法

シナリオコンダクタコマンドからのステータス表示に成功しました。

KFPE23743-I

メッセージ

Transaction queuing status was changed.

対処方法

シナリオコンダクタコマンドからのステータス変更に成功しました。

KFPE23752-E

メッセージ

CM-Server error number = KFPE2XXXX-E

対処方法

表示されたエラーコードの対策を行ってください。エラーコードの詳細は、「HiRDB Control Manager ヘルプ」の「メッセージの説明」を参照してください。

KFPE23753-E

メッセージ

CM-Agent error number = KFPE3XXXX-E

対処方法

表示されたエラーコードの対策を行ってください。エラーコードの詳細は、「HiRDB Control Manager ヘルプ」の「メッセージの説明」を参照してください。

KFPE23754-E

メッセージ

error detail is as follws:

対処方法

表示された詳細内容を確認し、対策してください。

KFPE23755-E

メッセージ

Argument is invalid.

Usage :メッセージ"

対処方法

メッセージにしたがって、対策を行ってください。

KFPE23756-E

メッセージ

CM-Server warning number = KFPE2XXXX-E

ErrCode=KFPEXXXXX-X HiRDB_ID=XXXX HostName=XXXXXXXX

対処方法

表示されたエラーコードの対策を行ってください。エラーコードの詳細は、「HiRDB Control Manager ヘルプ」の「メッセージの説明」を参照してください。

KFPE23757-E

メッセージ

HiRDB position info acquisition failed in part.

対処方法

一部のシステムの構成情報取得に失敗しました。

KFPE23781-E

メッセージ

CmsBkupRstr command started. in part.

対処方法

Serverのバックアップ、または、リカバリを開始しました。

KFPE23782-E

メッセージ

CmsBkupRstr command finished. in part.

対処方法

Serverのバックアップ、または、リカバリを終了しました。

KFPE23783-E

メッセージ

Backup/Recovery of CM - Server succeeded. in part.

対処方法

Serverのバックアップ操作、または、リカバリ操作に成功しました。

KFPE23784-E

メッセージ

Checking of CM - Server service failed. in part.

対処方法

Serverのサービスの状態確認に失敗しました。Serverが正しくインストールされているか、Serverをインストールしたユーザでコマンドを実行しているかを確認し、再度実行してください。

KFPE23785-E

メッセージ

CM - Server is running. in part.

対処方法

Serverが稼働しています。Serverのサービスを停止してからコマンドを実行してください。

KFPE23786-E

メッセージ

Registry access failed. in part.

対処方法

レジストリ操作に失敗しました。Serverをインストールしたユーザでコマンドを実行しているかを確認し、再度実行してください。

KFPE23787-E

メッセージ

Memory error occurred. in part.

対処方法

メモリエラーが発生しました。しばらくしてから、再度実行してください。頻繁に発生する場合は、Serverがインストールされているマシンのメモリを見直してください。

KFPE23788-E

メッセージ

Internal error occurred. in part.

対処方法

内部エラーが発生しました。再度実行してください。頻繁に発生する場合は、保守員に連絡してください。

KFPE23789-E

メッセージ

Backup/Recovery of CM - Server failed. (return code = xxx) in part.

対処方法

Serverのバックアップ操作、または、リカバリ操作に失敗しました。CM Serverのリタンコードを参照して、原因を取り除いた後、再度実行してください。

KFPE25001-W

メッセージ

ServerとConsoleのバージョンが一致していません。

実行できない機能がある可能性があります。

対処方法

ConsoleとServerのバージョンを確認してください。

KFPE25002-W

メッセージ

同じカタログを使用したスケジュールが登録されています。

スケジュールリスト画面から、正しくスケジュールされているか確認してください。

対処方法

スケジュールの確認画面から、正しくスケジュールされているか確認してください。

KFPE25003-W

メッセージ

バックアップ処理に時間がかかっています。しばらくしてから他の操作をしてください。

対処方法

バックアップ処理に時間がかかっているため、しばらく時間を置いてください。

バックアップ処理が終了すると、[バックアップファイル情報]コマンドの一覧に取得したバックアップファイルが表示されるので、正しく実行されていることを確認してください。

KFPE25004-W

メッセージ

リカバリ処理に時間がかかっています。しばらくしてから他の操作をしてください。

対処方法

リカバリ処理に時間がかかっているため、しばらく時間を置いてください。

KFPE25005-W

メッセージ

関連するRDエリア情報を取得できませんでした。選択した対象のみ、バックアップを取得します。

対処方法

-

KFPE25010-W

メッセージ

アンロード処理に時間がかかっています。しばらくしてから他の操作をしてください。

対処方法

アンロード処理に時間がかかっているため、しばらく時間を置いてください。

アンロード処理が終了すると、[アンロードログファイル情報]コマンドの一覧に取得したアンロードログファイルが表示されるので、正しく実行されていることを確認してください。

KFPE25011-W

メッセージ

システムログの状態変更処理に時間がかかっています。しばらくしてから他の操作をしてください。

対処方法

システムログの状態変更処理に時間がかかっているため、しばらく時間を置いてください。

KFPE25012-W

メッセージ

コマンドの実行に成功しましたが、HiRDB CMの管理に失敗しました。

対処方法

実行した操作の情報は、HiRDB CMで管理することができませんでした。

バックアップ・リカバリの場合、再度実行することをお勧めします。

KFPE25013-W

メッセージ

カタログの実行に時間がかかっています。しばらくしてから確認して下さい。

対処方法

カタログの実行に時間がかかっているため、しばらく時間を置いてください。

カタログの実行が終了すると、[カタログ実行結果情報]コマンドで実行した結果を参照することができます。

KFPE25014-W

メッセージ

HiRDB開始処理に時間がかかっています。しばらくしてから確認してください。

対処方法

HiRDB開始処理に時間がかかっています。しばらくしてから確認してください。

KFPE25015-W

メッセージ

HiRDB終了処理に時間がかかっています。しばらくしてから確認してください。

対処方法

HiRDB終了処理に時間がかかっています。しばらくしてから確認してください。

KFPE25016-W

メッセージ

HiRDBの解除は成功しましたが、Agentの保持している情報が削除できませんでした。Agentをアンインストールしてください。

対処方法

指定されたHiRDBをServerの管理対象から解除できました。

しかし、以下ような現象が発生しているため、Agentの保持するスケジュール情報等の削除に失敗しました。

・Agentが停止している

・Agent - Server間のネットワークが不通

・Agentの上書きインストール時にIPアドレスあるいはポート番号が変更された

・既にAgentがアンインストールされている

当該Agentの再開始は行わないでください。また、当該Agentは必ずアンインストールしてください。

KFPE25017-W

メッセージ

HiRDBファイル情報が取得できませんでした。

対処方法

HiRDBファイルシステム領域の情報は取得できましたが、HiRDBファイル情報が取得できませんでした。以下のような状況が考えられるため、状態を確認してください。

・Agentが停止している

KFPE25020-W

メッセージ

指定されたLOB用RDエリアのRDエリア用のグローバルバッファまたは種別がOTHERのグローバルバッファが存在しません。

対処方法

HiRDBファイルシステム領域の情報は取得できましたが、HiRDBファイル情報が取得できませんでした。以下のような状況が考えられるため、状態を確認してください。

・Agentが停止している

KFPE25021-W

メッセージ

一部のサーバで解析情報を取得できませんでした。

対処方法

ConsoleとServerのバージョンを確認してください。

KFPE25022-W

メッセージ

空きページ解放の実行に時間がかかっています。しばらくしてから確認してください。

対処方法

空きページ解放の実行に時間がかかっています。しばらくしてから確認してください。

KFPE25023-W

メッセージ

コマンドの実行に成功しましたが、HiRDB CMの管理情報の更新に失敗しました。定義情報の更新を行ってください。

対処方法

HiRDBコマンドの実行には成功しましたが、HiRDB CMで管理している情報の更新処理に失敗しました。 [オプション]-[管理情報の更新]において該当するHiRDBシステムの定義情報を更新した上で、以降の運用を行うことをお勧めします。 定義情報の更新を行わない場合、Console上の表示とHiRDBの状態が異なることがあります。

KFPE25029-W

メッセージ

データロード処理に時間がかかっています。しばらくしてから他の操作をしてください。

対処方法

データロード処理に時間がかかっているため、処理を行っているリソースに対する操作をする場合は、しばらく時間を置いてください。

KFPE25030-W

メッセージ

再編成処理に時間がかかっています。しばらくしてから他の操作をしてください。

対処方法

再編成処理に時間がかかっているため、処理を行っているリソースに対する操作をする場合は、しばらく時間を置いてください。

KFPE25031-W

メッセージ

ポリシー作成処理に時間がかかっています。しばらくしてから他の操作をしてください。

対処方法

ポリシー作成処理に時間がかかっているため、しばらくしてからNetBackupを実行してください。

KFPE25032-W

メッセージ

ポリシー削除処理に時間がかかっています。しばらくしてから他の操作をしてください。

対処方法

ポリシー削除処理に時間がかかっているため、しばらくしてから他の操作を行ってください。

KFPE25033-W

メッセージ

一部のHiRDBファイルの削除に失敗しました。再度、削除処理を実行してください。

対処方法

一部のHiRDBファイルの削除に失敗しました。最新のHiRDBファイルの情報を確認し、再度、削除処理を行ってください。

KFPE25034-W

メッセージ

一部のシステムの構成情報取得に失敗しました。

対処方法

失敗したHiRDBシステムに対するエラーコードを確認し対策してから、再度実行してください。

KFPE25035-W

メッセージ

トランザクションキューイングﾞを使用しない指定になっているため、トランザクションキューイングﾞを行いません。

対処方法

HiRDBの定義ファイルを確認してください。

KFPE25036-W

メッセージ

定義系SQLの実行は成功しましたが、SQL文のファイルへの保存に失敗しました。

対処方法

定義系SQL文をファイルに保存する場合は、手動で行ってください。

KFPE25037-W

メッセージ

開始処理に成功しましたが、待機状態変更処理に失敗しました。

対処方法

原因を取り除いた後、予備系を待機状態にしてください。

KFPE25038-W

メッセージ

開始処理に成功しましたが、後処理に失敗しました。

対処方法

頻繁にエラーが発生する場合、保守員に連絡してください。

KFPE25039-W

メッセージ

一部のサーバで自動ログアンロード機能の情報を取得できませんでした。

対処方法

情報を取得できなかったサーバが停止している場合は、サーバを開始した後、再度実行してください。

KFPE25040-W

メッセージ

管理情報のリカバリは成功しましたが、Serverの再開始処理に失敗しました。Serverを再起動してください。

対処方法

管理情報はバックアップ取得時の情報に回復できましたが、Serverの再開始処理に失敗しました。
以降の処理をServerでは受け付けることができません。Serverを再起動してください。

KFPE25041-W

メッセージ

管理情報のリカバリは成功しましたが、リカバリ後のバックアップに失敗しました。バックアップのみ、再度実行してください。

対処方法

管理情報はバックアップ取得時の情報に回復できましたが、回復後の管理情報をバックアップすることができませんでした。
再度バックアップのみを実行してください。

KFPE25042-W

メッセージ

管理情報のリカバリは成功しましたが、Agentとの再接続に失敗しました。Serverを再起動してください。

対処方法

管理情報はバックアップ取得時の情報に回復できましたが、Agentとの通信経路の確保に失敗しました。
以降の処理をServerでは受け付けることができません。Serverを再起動してください。

KFPE25043-W

メッセージ

管理情報のリカバリは成功しましたが、再接続に失敗したAgentがあります。該当するAgentを登録解除してください。

対処方法

管理情報はバックアップ取得時の情報に回復できましたが、回復後のServerで管理しているAgentにServerからの接続ができなかったものがあります。詳細メッセージに表示されたAgentを登録解除してください。

KFPE25044-W

メッセージ

管理情報のリカバリは成功しましたが、不要なスケジュールの削除に失敗しました。該当するAgentを登録解除してください。

対処方法

管理情報はバックアップ取得時の情報に回復できましたが、回復後のServerで管理しないスケジュールの削除処理に失敗しました。
詳細メッセージに表示されたAgentで不当なスケジュールが実行される可能性があります。該当するAgentを登録解除してください。

KFPE25045-W

メッセージ

管理情報のリカバリは成功しましたが、Agentの自動メンテナンス機能の再開始処理に失敗しました。該当するAgentの自動メンテナンス機能を再設定してください。

対処方法

管理情報はバックアップ取得時の情報に回復できましたが、Agentの自動メンテナンス機能の再開始に失敗しました。
該当するAgentの自動メンテナンス機能を再設定してください。

KFPE25046-W

メッセージ

管理情報のリカバリは成功しましたが、管理情報の自動更新機能の起動に失敗しました。Serverを再起動してください。

対処方法

管理情報はバックアップ取得時の情報に回復できましたが、管理情報の自動更新機能の起動に失敗しました。
以降の処理をServerでは受け付けることができません。Serverを再起動してください。

KFPE31001-I

メッセージ

スケジュール処理に成功しました。

対処方法

-

KFPE31002-I

メッセージ

システムログファイルのアンロードに成功しました。

対処方法

-

KFPE31003-I

メッセージ

システムログファイルの状態変更に成功しました。

対処方法

-

KFPE34001-E

メッセージ

通信中にエラーが発生しました。

対処方法

管理対象HiRDBがパラレルサーバの場合は、非システムマネジャ (MGR) ノードのマシンサーバの状態を確認してください。

KFPE34002-E

メッセージ

Server,Agent間でバージョン互換ができません。

対処方法

ServerとAgentのバージョンを確認してください。

管理対象HiRDBがパラレルサーバの場合は、非システムマネジャ (MGR) ノードのマシンサーバの状態を確認してください。

KFPE34003-E

メッセージ

Agent内で通信エラーが発生しました。

対処方法

管理対象HiRDBがパラレルサーバの場合は、非システムマネジャ (MGR) ノードのマシンサーバの状態を確認してください。

KFPE34004-E

メッセージ

Agent内で予期しないエラーが発生しました。

対処方法

頻繁に発生する場合は、保守員に連絡してください。

KFPE34005-E

メッセージ

HiRDBの操作に失敗しました。

対処方法

指定したパラメータを確認してください。

詳細メッセージがある場合は、記述されている内容に従って対策して下さい。

詳細メッセージがない場合は、再度実行して下さい。

詳細メッセージがない場合が頻発する場合は、保守員に連絡して下さい。

KFPE34006-E

メッセージ

選択されたオプションが不正です。

対処方法

指定したオプションを見直してください。

KFPE34007-E

メッセージ

スケジュール処理に失敗しました。

対処方法

スケジュールの確認を行ってください。

KFPE34008-E

メッセージ

デバイス解析に失敗しました。

対処方法

条件を見直してください。

KFPE34008-E

メッセージ

非MGRのAgentに接続したため、処理を行いませんでした。

対処方法

KFPE34010-E

メッセージ

タイムアウトが発生しました。

対処方法

管理対象HiRDBがパラレルサーバの場合は、非システムマネジャ (MGR) ノードのマシンサーバの状態を確認してください。

KFPE34011-E

メッセージ

Agent間の通信に失敗しました。

対処方法

管理対象HiRDBがパラレルサーバの場合は、非システムマネジャ (MGR) ノードのマシンサーバの状態を確認してください。

KFPE34012-E

メッセージ

通信中にソケットが閉じられました。

対処方法

管理対象HiRDBがパラレルサーバの場合は、非システムマネジャ (MGR) ノードのマシンサーバの状態を確認してください。

KFPE34013-E

メッセージ

通信中にソケットが初期化されました。

対処方法

管理対象HiRDBがパラレルサーバの場合は、非システムマネジャ (MGR) ノードのマシンサーバの状態を確認してください。

KFPE34014-E

メッセージ

Agent間の通信に失敗しました。

対処方法

管理対象HiRDBがパラレルサーバの場合は、非システムマネジャ (MGR) ノードのマシンサーバの状態を確認してください。

KFPE34015-E

メッセージ

この機能はAgentでサポートされていません。

対処方法

Agentのバージョンを確認してください。

KFPE34016-E

メッセージ

メモリ領域が不足しているため処理を中断しました。

対処方法

しばらくしてから、再度実行してください。

頻繁に発生する場合は、Agentがインストールされているサーバマシンのメモリを見直してください。

KFPE34017-E

メッセージ

パラメータが不正です。

対処方法

指定した条件を見直してください。

頻繁に発生する場合は、保守員に連絡してください。

Console,ServerのバージョンがAgentバージョンよりも新しく、Agentでサポートされていない機能を指定した場合に、本エラーが発生することがあります。

KFPE34018-E

メッセージ

ファイル操作に失敗しました。

対処方法

CM Agentをインストールしたディスクに対するファイルIO操作が正常にできるか確認してください。

システムステータスのユニット詳細画面でシステムログ情報を表示した時にこのメッセージが表示される場合、ロギング情報表示設定が不適当である可能性があります。

[オプション]-[ロギング情報表示設定]で設定を見直してください。

KFPE34019-E

メッセージ

Agentの定義ファイルが不正です。

対処方法

Agentの定義ファイルを見直してください。

Agent定義パラメータのServerExistやServerIPAddress、ServerPortNumberが正しくない場合は、Agentだけがアンインストール/インストール（アンセットアップ/セットアップ）された可能性があります。管理HiRDBの解除を行った後で、再度管理HiRDBの新規登録を行ってください。

KFPE34020-E

メッセージ

管理対象のHiRDBではありません。

対処方法

指定されたAgentは、別のServerに管理されている可能性があります。その場合は、管理しているServerから実行してください。

Agentのインストール時にServer自動探索機能を使用した場合は、指定したServerのIPアドレスに誤りがあった可能性があります。その場合は、Agentの再インストールを行ってください。

KFPE34021-E

メッセージ

IOエラーが発生しました。

対処方法

・フォーマットされていないボリューム（ドライブ）が指定された可能性があります。
フォーマット済みのボリューム（ドライブ）を指定してください。
・アクセス権限の無いファイル/ボリューム（ドライブ）が指定された可能性があります。
アクセス権限を正しく設定後、再度実行してください。
本メッセージが頻繁に発生する場合は、指定したファイル/ボリューム（ドライブ）が割り当てられているディスクを正しくアクセスできるよう対策後、再度実行してください。

KFPE34022-E

メッセージ

情報検索に失敗しました。

対処方法

以下を確認してください。
●管理対象HiRDBの稼働状態を確認してください。HiRDBが稼動していない場合は、HiRDBが正常稼動後に再度実行してください。
●管理対象HiRDBがパラレルサーバで構成され、かつWindows上で稼動している場合は、AgentサービスのアカウントがHiRDBと同じであることを確認してください。誤っている場合は、アカウントを正しく設定後に再度実行してください。
アカウント設定方法につきましては、CM Agent readme.txt「９．使用上の注意事項（３）」を参照してください。
●Agentインストール時に指定したHiRDBのDBA権限を持つ認可識別子及びパスワードが正しく設定されているか確認してください。
Agentインストール時に指定したDBA権限を持つ認可識別子の設定は以下のコマンドで確認できます。
cmrconf -l HiRDBUseｒ
HiRDBのDBA権限を持つ認可識別子及びパスワードが誤っている場合は、cmrconfコマンドを使用して正しい値に変更後、再度実行してください。
cmrconfコマンドの詳細は、CM Agentのreadme.txtもしくはソフトウェア添付資料を参照してください。
●AgentとHiRDBのLANGならびにPDLANGの値が正しく設定されているか確認してください。
Agentインストール時に指定したLANG、PDLANGの設定は以下のコマンドで確認できます。
cmrconf -l LANG
cmrconf -l PDLANG
PDLANGが省略されている場合は、表示されません。PDLANG、LANGの設定は、「HiRDB UAP開発ガイド」を参照してください。
LANGまたはPDLANGが誤っている場合は、cmrconfコマンドを使用して正しい値に変更後、再度実行してください。
cmrconfコマンドの詳細は、CM Agentのreadme.txtもしくはソフトウェア添付資料を参照してください。
●上記に該当しない場合は、管理HiRDBのWORK用HiRDBファイルシステム領域に作成できるHiRDBファイル数が不足している可能性があります。当該HiRDBファイルシステム領域の最大HiRDBファイル数を増やし、再度実行してください

KFPE34023-E

メッセージ

条件に合う対象がありません。

対処方法

-

KFPE34024-E

メッセージ

管理対象のHiRDBが停止しています。

対処方法

管理対象HiRDBの状態を確認してください。

HiRDBが停止している場合は、開始してください。

KFPE34025-E

メッセージ

管理対象のHiRDBの定義解析に失敗しました。

対処方法

管理対象HiRDBの定義を確認してください。

KFPE34026-E

メッセージ

バックアップの実行に失敗しました。

対処方法

バックアップ取得対象のHiRDBが停止している場合は、開始してください。

あるいは、指定されたバックアップ取得先が存在していない可能性があります。

KFPE34027-E

メッセージ

管理対象のHiRDBの情報取得に失敗しました。

対処方法

-

KFPE34028-E

メッセージ

win32サービス内でエラーが発生しました。

対処方法

サービスの再起動を行ってください。

KFPE34029-E

メッセージ

RDエリアの状態変更に失敗しました。

RDエリアを複数指定した場合、一部のRDエリアのみ状態変更が行われている可能性があります。

メニューバーから[更新]を行い、RDエリアの状態を確認してください。

対処方法

RDエリアを複数指定した場合、一部のRDエリアのみ状態変更が行われている可能性があります。メニューバーから[更新]を行い、RDエリアの状態を確認してください。詳細が表示されている場合は、メッセージに従って原因を取り除いてから再度実行してください。

KFPE34030-E

メッセージ

RDエリアの状態変更に成功したが、状態の確認ができませんでした。

メニューバーから[更新]を行ってください。

対処方法

メニューバーから[更新]を実行し、状態更新を行ってください。

KFPE34031-E

メッセージ

環境変数処理中にエラーが発生しました。

対処方法

Agentがインストールされているサーバマシンの状態を確認してください。

KFPE34032-E

メッセージ

認証に失敗しました。

入力したユーザ名及びパスワードを確認してください。

対処方法

インストール時に指定したユーザ名及びパスワードを確認してください。

KFPE34033-E

メッセージ

接続中のユーザがいるため、終了処理ができません。

接続中のユーザを終了してから、再度実行してください。

対処方法

接続中のユーザを終了してから、再度実行してください。

KFPE34034-E

メッセージ

HiRDBの稼働状態が不正なため処理を実行できませんでした。。

管理情報更新後、HiRDBの状態を確認してください。

対処方法

HiRDBを開始した後に再度実行してください。

KFPE34035-E

メッセージ

ファイルの削除に失敗しました。

対処方法

残存するファイルを個別に削除して下さい。

KFPE34036-E

メッセージ

ポリシー作成に失敗しました。

対処方法

Agent NetBackupのインストールディレクトリが正しいか、またNetBackupマスタサーバのサービスが起動されているか確認してから、再度実行して下さい。頻繁に発生する場合は、保守員に連絡してください。

KFPE34037-E

メッセージ

同名のポリシーが既に存在しています。

対処方法

ポリシー名を変更し再度実行してください。

KFPE34038-E

メッセージ

指定したファイル格納先は存在しません。

対処方法

パス名を見直してください。

KFPE34039-E

メッセージ

ポリシー削除に失敗しました。

対処方法

Agent NetBackupのインストールディレクトリが正しいか、またNetBackupマスタサーバのサービスが起動されているか確認してから、再度実行して下さい。頻繁に発生する場合は、保守員に連絡してください。

指定したポリシーがバックアップで使用されていない場合は、NetBackupマスタサーバを使用して削除してください。

指定したポリシーがバックアップで使用されている場合は、ポリシー及びポリシーに関連するバックアップファイルが削除されていない可能性があります。ポリシーが削除されていない場合は、NetBackupマスタサーバを使用して削除してください。バックアップファイルが削除されていない場合は、手動でバックアップファイルを削除してください。

KFPE34040-E

メッセージ

/usr/bin/crontabを使用できません。

対処方法

Agentの環境を確認して、再度実行してください。

KFPE34041-E

メッセージ

cron機能を使用できません。

対処方法

Agentの環境を確認して、crontabが使用できる状態に変更後に再度実行してください。

KFPE34042-E

メッセージ

スワップ先のシステムログファイルがありません。

対処方法

アンロード待ちのシステムログファイルをアンロードまたは状態の変更を行ってください。

KFPE34043-E

メッセージ

取り扱うファイル数が多すぎます。

対処方法

自動ログアンロードファイル格納ディレクトリ内に含まれるアンロードログファイル数が多すぎます。

不要なアンロードログファイルを削除してから、再度実行してください。

KFPE34044-E

メッセージ

前処理に失敗しました。

対処方法

指定した条件を見直してください。

詳細が表示されている場合は、メッセージに従って原因を取り除いた後に再度実行してください。

再初期化の場合は、管理HiRDBの情報が古い可能性があります。メニューバー[オプション]-[更新]で管理情報を最新にしてください。

KFPE34045-E

メッセージ

ファイルのアクセスが拒否されました。ファイルがオープン中の可能性があります。

対処方法

残存するファイルを個別に削除してください。

KFPE34046-E

メッセージ

指定内容でファイル格納先は作成できません。

対処方法

パス名またはオプションの指定が不正です。あるいは、パス名に対応するデバイスがシステムに接続されていない場合や、指定されたパスへのアクセス権限がない場合があります。

指定内容を見直してください。

KFPE34047-E

メッセージ

指定されたHiRDBファイルシステム領域またはディレクトリは使用中です。

対処方法

別の用途で登録済みの格納先を指定した可能性があります。指定したパス名を見直してください。

HiRDBファイルシステム領域の初期設定の場合は、HiRDBファイルが格納されていると実行できません。

KFPE34048-E

メッセージ

非システムマネジャが登録されていません。

対処方法

非システムマネジャノードにAgentをインストールし、サービスを開始してください。

既にサービスが開始されている場合は、管理HiRDBの指定情報が正しいことを確認してから、サービスの再起動を行ってください。

KFPE34049-E

メッセージ

アンロードログファイルの格納先ディレクトリが見つかりません。

対処方法

対象のHiRDB定義を確認し、自動ログアンロード格納先ディレクトリが正しいことを確認してください。

KFPE34050-E

メッセージ

アンロードログファイルが見つかりません。

対処方法

バックアップ取得後のアンロードログファイルが削除された、または、バックアップ取得後のシステムログファイルの切り替えが行われていない可能性があります。

アンロードログファイルを削除された場合は、アンロードログを使用しない回復を行ってください。システムログの切り替えが行われていない場合は、システムログのスワップを行ってください。

KFPE34051-E

メッセージ

パラメータが長すぎるため、実行できません。

対処方法

アンロードログファイルを指定している場合は、アンロードログファイルの絶対パスを短くしてください。

自動ログアンロード運用の場合は、アンロードログファイルの絶対パスを短くして、指定してください。

KFPE34052-E

メッセージ

自動ログアンロード機能が動作中ではありません。

対処方法

自動ログアンロード機能が停止中または使用できない状態です。

自動ログアンロードログディレクトリがあるディスクに障害が発生している、あるいは満杯になっているか、サーバ定義で指定されていない可能性があります。

原因を取り除いて、自動ログアンロード機能を開始してください。

KFPE34053-E

メッセージ

システムログファイルのA系とB系のレコード数が一致しません。

対処方法

A系またはB系のどちらかの物理ファイルが既に存在していて、指定されたレコード数と一致しない為、初期設定を行っても使用できません。

既に存在する物理ファイルのレコード数を確認して、同じレコード数を指定して存在しない物理ファイルの初期設定を行ってください。

KFPE34054-E

メッセージ

AgentのIPアドレスが一致しません。

対処方法

指定されたAgentのIPアドレスはインストール時に指定されたIPアドレスと一致しません。正しいAgentのIPアドレスを指定してください。

KFPE34055-E

メッセージ

Agentのポート番号が一致しません。

対処方法

指定されたAgentのポート番号はインストール時に指定されたポート番号と一致しません。正しいAgentのポート番号を指定してください。

KFPE34056-E

メッセージ

スケジュールのパラメータが長すぎるため、実行できませんでした。

対処方法

HiRDBが適正なディレクトリにインストールされているか確認してください。

KFPE34057-E

メッセージ

NetBackup用Agentとしてインストールされているため、処理を実行できませんでした。

対処方法

IP、ポート番号を確認し再度実行してください。また、Agentが正しくインストールされているか確認してください。

KFPE34058-E

メッセージ

Agentで使用しているユーザのため、変更できません。

対処方法

インストール時に指定したユーザ名及びパスワードを確認してください。

KFPE34059-E

メッセージ

ディレクトリ情報の取得に失敗しました。

対処方法

指定したディレクトリ内の情報を取得できません。HELPを参照し、ディレクトリ内の情報を確認して下さい。

KFPE34060-E

メッセージ

Agent間のバージョンが一致していないため処理を中断しました。

対処方法

Agent間のバージョンを一致させて、再度実行してください。

KFPE34061-E

メッセージ

指定されたディレクトリに対するアクセス権限がないため、情報を取得できませんでした。

対処方法

権限の確認を行ってください。インストール時に指定したユーザにアクセス権限がない場合、アクセス権限を設定してください。

KFPE34062-E

メッセージ

Agentで使用しているユーザのDBA、CONNECT権限とパスワードの変更はできません。

対処方法

Agentで使用しているユーザのため、権限の変更を行うとAgentが使用不可能になります。権限を変更したい場合は、Agentをアンインストール後、再度インストールを行い、DBA権限ユーザを変更してください。

KFPE34063-E

メッセージ

ユーザ追加/権限変更に失敗しました。

対処方法

HiRDBの起動状態をチェックしてください。又は、HiRDBのエラー情報を参照して、ユーザ権限とパスワードを修正後、再度実行してください。

KFPE34064-E

メッセージ

ユーザ表権限変更に失敗しました。

対処方法

ユーザ表権限が不正に変更されている可能性があるので、ユーザマップを参照して、確認して下さい。

KFPE34065-E

メッセージ

RDエリアの状態が不正なため、処理を中断しました。

対処方法

システムステータスのRDエリア詳細情報を参照し、RDエリアの状態を確認してください。正しい状態に変更して再度実行してください。

KFPE34066-E

メッセージ

AJS2ジョブの設定が不正です。

対処方法

該当するジョブを削除し、再度登録してから実行してください。

KFPE34067-E

メッセージ

不正なファイルまたは、ディレクトリを指定したため、処理を中断しました。

対処方法

正しいディレクトリまたは、ファイル名称を指定して再度実行してください。

KFPE34068-E

メッセージ

指定されたファイルは存在しません。

対処方法

指定されたファイルは存在しません。既存のファイルを指定してください。

KFPE34069-E

メッセージ

指定されたファイルは空です。

対処方法

指定されたファイルは空です。空ではないファイルを指定してください。

KFPE34070-E

メッセージ

スケジューラと競合したため、処理を中断しました。

対処方法

スケジュールまたはJP1/AJS2の稼働状態を確認して、これらの処理が同時に実行されていた場合は、しばらく時間をおいて、再度処理を実行してください。または、本現象発生前に、Consoleからの操作途中に通信エラーや、応答待ちでタイムアウトが発生していた場合は、前回の処理を行っているAgentプロセスが、まだ処理を続行していることが考えられます。

KFPE34071-E

メッセージ

指定されたグローバルバッファは削除できない種別です。

対処方法

この種別のグローバルバッファは削除できません。

KFPE34072-E

メッセージ

グローバルバッファに指定するRDエリア数が上限値を超えています。

対処方法

グローバルバッファの動的変更の場合は、1回に指摘できるRDエリア数の上限を超えています。定義変更の場合は、1個のグローバルバッファを割り当てられるRDエリア数の上限を超えています。

KFPE34073-E

メッセージ

指定可能なグローバルバッファの最大数を超えるため、グローバルバッファを作成できません。

対処方法

1個のサーバに作成できるグローバルバッファ数の上限を超えています。または、HiRDBパラレルサーバの場合にシステム全体に作成できるグローバルバッファ数の上限を超えています。

KFPE34074-E

メッセージ

指定された種別のグローバルバッファはシステムに1つしか作成できません。

対処方法

この種別のグローバルバッファは既に存在します。システムで1個しか作成できません。

KFPE34075-E

メッセージ

指定されたグローバルバッファがRDエリアに割り当てられていないグローバルバッファになるため、この処理は実行できません。

対処方法

指定されたRDエリアをグローバルバッファから削除すると、RDエリアに割り当てられていないグローバルバッファになります。指定されたグローバルバッファが不要な場合は、RDエリアを指定しないでグローバルバッファの削除を行ってください。

KFPE34076-E

メッセージ

指定されたグローバルバッファは、システム定義に存在しません。

対処方法

指定されたグローバルバッファは、システム定義に定義されていません。

KFPE34077-E

メッセージ

HiRDBのバージョンは、指定された処理をサポートしていません。

対処方法

HiRDBのバージョン確認を行って、サポート対象か確認下さい。

KFPE34078-E

メッセージ

指定されたLOB用RDエリアのRDエリア用のグローバルバッファまたは種別がOTHERのグローバルバッファが存在しません。

対処方法

指定のグローバルバッファの存在確認を行って下さい。

KFPE34079-E

メッセージ

データベース状態解析ユティリティの実行に失敗しました。

対処方法

ユーザ用RDエリア、データディクショナリ用RDエリア、レジストリ用RDエリア以外のRDエリアにのみ格納されている表、インデクスについてはデータベース状態解析ユティリティを実行できません。

KFPE34080-E

メッセージ

このOSではサポートされていません。

対処方法

該当機能がサポートされているOSを選択してください。

KFPE34081-E

メッセージ

解析処理中にディレクトリ、ファイルが追加されたため、処理を中断しました。

対処方法

再度実行してください。

KFPE34082-E

メッセージ

06-02より前のバージョンのHiRDBを管理することはできません。

対処方法

管理対象のHiRDBをv06-02以降にバージョンアップしてください。

KFPE34083-E

メッセージ

複数のホストに格納されているアンロードログファイルを使用したリカバリを行うことはできません。

対処方法

2自動ログアンロードで取得したアンロードログを使用しないリカバリを実行するか、または、同一ホストに存在するリソースに対してリカバリを実行してください。

KFPE34084-E

メッセージ

クラスタコマンドの実行に失敗しました。

対処方法

クラスタが出力するログを参照し、エラーの原因を取り除いてから再度実行してください。

KFPE34085-E

メッセージ

コマンドで指定したサーバ名又は、サーバの状態が不正なため、処理を中断しました。

対処方法

指定したサーバの状態を確認してください。

KFPE34086-E

メッセージ

コマンドで指定したホスト名又は、ホスト上で稼動するサーバの状態が不正なため、処理を中断しました。

対処方法

指定したホスト上で稼動するHiRDBの状態を確認してください。

KFPE34087-E

メッセージ

トランザクションキューイングを行わない指定を行っているため処理を中断しました。

対処方法

HiRDBの定義を確認してください。

KFPE34088-E

メッセージ

システムログファイルのオープンに失敗しました。

対処方法

エラー詳細情報のファイルグループ単位のエラーコードおよびHiRDBのメッセージを参照してください。

KFPE34089-E

メッセージ

システムログファイルのクローズに失敗しました。

対処方法

エラー詳細情報のファイルグループ単位のエラーコードおよびHiRDBのメッセージを参照してください。

KFPE34090-E

メッセージ

システムログファイルの拡張に失敗しました。

対処方法

エラー詳細情報のファイルグループ単位のエラーコードおよびHiRDBのメッセージを参照してください。

KFPE34091-E

メッセージ

システムログファイルの削除に失敗しました。

対処方法

エラー詳細情報のファイルグループ単位のエラーコードおよびHiRDBのメッセージを参照してください。

KFPE34092-E

メッセージ

システムログファイルは既にオープンされています。

対処方法

既に物理ファイルが初期設定されていて、オープンされています。物理ファイルのHiRDBレコード数を確認してください。

KFPE34093-E

メッセージ

再編成時期予測機能の実行環境が整っていないため処理を中断しました。

対処方法

定義ファイル、または運用管理RDエリアを確認してください。

KFPE34094-E

メッセージ

メンテナンス処理データの保存に失敗しました。

対処方法

Agentのインストールディレクトリ以下のsave/maintenanceディレクトリの状態を確認してください。

KFPE34095-E

メッセージ

定義系SQLの実行は成功しましたが、SQL文のファイルへの保存に失敗しました。

対処方法

定義系SQL文をファイルに保存する場合は、手動で行ってください。

KFPE34096-E

メッセージ

HiRDBファイルシステム領域以外のファイルが既に存在します。

対処方法

指定されたパスに同名のHiRDBファイルシステム領域以外のファイルが存在します。確認してください。

KFPE34097-E

メッセージ

Agentインストール、または、インストール後の自動通信が終了していません。

対処方法

数分待ってから再度実行指定ください。 繰り返しこのエラーが発生する場合は、以下の確認を行ってください。

1.Agentのネットワーク環境

2.Agentインストール、セットアップ順序

3.Agentインストール、セットアップ時のパラメータ

KFPE34098-E

メッセージ

Agentインストール、セットアップ時に指定したパタメータが不正です。

対処方法

アンインストール後、指定パラメータを見直し再度インストールしてください。

KFPE34099-E

メッセージ

現在の系切り替え状態では使用できないパタメータが指定されています。

対処方法

HiRDBの構成とAgentをインストール時に指定した構成が一致しているか確認してください。一致していない場合は、Agent定義ファイルの変更を行ってください。

KFPE34100-E

メッセージ

現用系で実行することはできません。

対処方法

指定された機能は、現用系では実行することができません。

KFPE34101-E

メッセージ

予備系で実行することはできません。

対処方法

指定された機能は、予備系では実行することができません。HiRDBが現用系で稼動中である場合のみ実行可能です。

KFPE34102-E

メッセージ

Agentの定義ファイルに定義されたクラスタ種別が不正です。

対処方法

Agentの定義ファイルを確認してください。

KFPE34103-E

メッセージ

クラスタコマンドの実行に失敗しました。

対処方法

クラスタの状態を確認してください。

KFPE34104-E

メッセージ

非MGRユニットのHiRDBシステムマシンの接続に失敗しました。

対処方法

対象HiRDBシステムのマシンの状態を確認してください。

KFPE34105-E

メッセージ

本操作は、系切り替え構成時には実行できません。

対処方法

系切り替え構成時には実行できない操作が選択されました。手動で行ってください。

KFPE34106-E

メッセージ

後処理に失敗しました。

対処方法

しばらくしてから、[管理情報の更新]画面から状態情報の更新を行って、状態を確認してください。

KFPE34107-E

メッセージ

一部の待機系ユニットの状態を待機状態にできませんでした。

対処方法

原因を取り除いた後[システムステータス]画面から、対象のユニットの[待機状態変更]を行っください。

KFPE34108-E

メッセージ

HiRDBの開始処理後の後処理に失敗しました。

対処方法

しばらくしてから、[管理情報の更新]画面から状態情報の更新を行って、状態を確認してください。

KFPE34109-E

メッセージ

HiRDB開始処理中にタイムアウトが発生したため、処理を中断しました。

対処方法

開始処理がAgent定義に指定された時間内に終了しませんでした。原因を取り除いた後、再度実行してください。指定された時間内に開始処理が終了しない場合は、Agent定義句の開始処理タイムアウト時間を変更する必要があります。ソフトウェア添付ファイルまたは、readme.txtを参照してAgent定義句の開始処理タイムアウト時間の変更を行ってください。デフォルト値は15分で指定されています。

KFPE34110-E

メッセージ

HAモニタまたはMS/CS以外のクラスタではサポートされていない機能であるため、処理を中断しました。

対処方法

対象のクラスタソフトウェアではサポートしていない機能です。手動で行ってください。

KFPE34111-E

メッセージ

ヘッダの受信時にエラーが発生しました。

対処方法

通信処理中にエラーが発生してます。全てのユニットマシンの状態を確認してください。

KFPE34112-E

メッセージ

ステータスファイルのオープンに失敗しました。

対処方法

エラー詳細情報のステータスファイル単位のエラーコードおよびHiRDBのメッセージを参照してください。

KFPE34113-E

メッセージ

ステータスファイルのクローズに失敗しました。

対処方法

エラー詳細情報のステータスファイル単位のエラーコードおよびHiRDBのメッセージを参照してください。

KFPE34114-E

メッセージ

ステータスファイルの作成に失敗しました。

対処方法

エラー詳細情報のステータスファイル単位のエラーコードおよびHiRDBのメッセージを参照してください。

KFPE34115-E

メッセージ

ステータスファイルの削除に失敗しました。

対処方法

エラー詳細情報のステータスファイル単位のエラーコードおよびHiRDBのメッセージを参照してください。

KFPE34116-E

メッセージ

ステータスファイルは既にオープンされています。

対処方法

既に物理ファイルが初期設定されていて、オープンされています。物理ファイルのHiRDBレコード数を確認してください。

KFPE34117-E

メッセージ

ステータスファイルを初期設定するためのHiRDBファイルシステム領域が存在しません。

対処方法

ステータスファイルの物理ファイルのためのHiRDBファイルシステム領域の初期設定をしてください。

KFPE34118-E

メッセージ

HiRDBの稼動中に使用していた現用のステータスファイルの初期設定および削除は実行できません。

対処方法

指定されたステータスファイルは、HiRDBの稼動中に現用として使用されたステータスファイルです。

KFPE34119-E

メッセージ

現用系が待機状態のため、実行できません。

対処方法

KFPE34120-E

メッセージ

全てのサーバで自動ログアンロード機能の情報取得に失敗しました。

対処方法

詳細が表示されている場合は、メッセージに従って原因を取り除いてから再度実行してください。

KFPE34121-E

メッセージ

指定された世代のレプリカRDエリアが存在しないRDエリアを指定しました。

対処方法

世代番号を正しく指定してください。

KFPE34122-E

メッセージ

サーバプロセスのリフレッシュが完了していません。

対処方法

サーバプロセスのリフレッシュが完了していません。また、サーバプロセス数の取得および変更の場合は、サーバプロセスのリフレッシュが完了するまでは実行できません。

KFPE34123-E

メッセージ

ﾄﾗﾝｻﾞｸｼｮﾝｷｭｰｲﾝｸﾞ開始に失敗しました。

対処方法

トランザクションキューイングを開始しようとして失敗しました。HiRDBのシステム定義や実行環境を確認してください。

KFPE34124-E

メッセージ

処理に失敗しましたが、ﾄﾗﾝｻﾞｸｼｮﾝｷｭｰｲﾝｸﾞ機能は開始されています。

対処方法

影響不可分散スタンバイレス型系切り替えを使用しているサーバに対する停止処理または計画系切り替え処理に失敗しました。しかし、トランザクションキューイング機能は開始されています。トランザクションキューイング機能を停止したい場合はシステムのサーバ詳細画面から実行してください。

KFPE34125-E

メッセージ

pdrpauseの実行に失敗しました。

対処方法

pdrpauseの実行に失敗しました。HiRDBの状態や実行環境を確認してください。

KFPE34126-E

メッセージ

環境変数PDDIRが設定されていません。

対処方法

PDDIRが設定されていないため、処理を中断しました。環境変数PDDIRに対象のHiRDBの運用ディレクトリを指定してください。

KFPE34127-E

メッセージ

指定されたバックアップファイルは別のHiRDBのバックアップファイルです。

対処方法

選択したHiRDB以外のHiRDBで取得したバックアップファイルを指定しないでください。

KFPE34128-E

メッセージ

指定されたアンロードログファイルは別のHiRDBのアンロードログファイルです。

対処方法

選択したHiRDB以外のHiRDBで取得したアンロードログファイルを指定しないでください。

KFPE34129-E

メッセージ

指定されたアンロードログファイルは別のサーバのアンロードログファイルです。

対処方法

選択したサーバ以外のサーバで取得したアンロードログファイルを指定しないでください。
HiRDB CMでは一つの格納先に複数サーバのアンロードログを格納する運用はできません。アンロードログファイルが通常ファイルの場合は、格納先を分けて登録してください。

KFPE34130-E

メッセージ

指定されたアンロードログファイルは07-02未満のHiRDBのアンロードログファイルです。

対処方法

HiRDB CMでは07-02未満のHiRDBで取得したアンロードログファイルを登録できません。本ファイルを既存アンロードログファイルの登録で指定しないでください。

KFPE34131-E

メッセージ

指定されたアンロードログファイルの名称が長すぎます。

対処方法

HiRDB CMではファイル名称が256バイト以上のアンロードログファイルを登録できません。ファイル名称を変更するか、または、本ファイルを既存アンロードログファイルの登録で指定しないでください。

KFPE34132-E

メッセージ

指定されたアンロードログファイルの絶対パスが長すぎます。

対処方法

アンロードログファイルの絶対パスは通常ファイルで1024バイト以下、HiRDBファイルで167バイト以下です。格納先を変更するなどして、パスの長さを調節してください。

KFPE34133-E

メッセージ

指定されたアンロードログファイルはアンロードの完了状態が正常でないため、登録できません。

対処方法

正常にアンロードが完了していないファイルを指定しないでください。

KFPE34134-E

メッセージ

指定されたパスにはファイルが存在しません。

対処方法

ファイルの存在するパスを指定してください。

KFPE34135-E

メッセージ

改ざん防止表への移行に失敗しました。

対処方法

詳細が表示されている場合は、メッセージに従って原因を取り除いてから再度実行してください。
詳細情報は、次に示す形式で記載されます。

処理名称 --- 結果コード
処理名称 --- 結果コード
処理名称 --- 結果コード
[detail]
詳細情報

処理名称には、次のいずれかを記載します。また、処理名称に対応して詳細情報にヘッダ付きの各HiRDBコマンド実行結果または、SQL実行結果を出力します。

処理名称

処理内容

詳細情報

備考

ヘッダ

メッセージ

Pre Backup

事前バックアップ

-

pdcopyコマンドの実行結果

-

Data Unload - pdhold

RDエリアの閉塞

Hold of RDAREA failed.

pdholdコマンドの実行結果

-

Data Unload - pdrorg

表データのアンロード

Unload of data in specified table failed.

pdrorgコマンドの実行結果

-

Data Unload - pdrels

RDエリアの閉塞解除

Release of RDAREA(s) failed.

pdrelsコマンドの実行結果

-

Data Deletion

表データの全削除

Purging of data in specified table failed.

SQLの実行結果

-

Table Definition Change

表定義変更

Changing of specified table definition failed.

SQLの実行結果

-

Data Reload - pdhold

RDエリアの閉塞

Hold of RDAREA failed.

pdholdコマンドの実行結果

-

Data Reload - pdload

表データの再ロード

Reloading of data failed.

pdloadコマンドの実行結果

-

DB Recovery - pdhold

RDエリアの閉塞クローズ

Hold of RDAREA failed.

pdholdコマンドの実行結果,事前バックアップファイル名,アンロードファイル名

エラーが発生時の回復処理に関するメッセージ

DB Recovery - pdrstr

リストア

Recovery of database failed.

pdrstrコマンドの実行結果,事前バックアップファイル名,アンロードファイル名

エラーが発生時の回復処理に関するメッセージ

DB Recovery - pdrels

RDエリアの閉塞解除 オープン

Release of RDAREA(s) failed.

pdrelsコマンドの実行結果

エラーが発生時の回復処理に関するメッセージ

結果コードには次のいずれかを記述します。

success

対象の処理に成功しました。

failed

対象の処理に失敗しました。

KFPE34136-E

メッセージ

改ざん防止表への移行は成功しましたが、RDエリアの閉塞解除処理に失敗しました。

対処方法

RDエリアの状態を確認し、必要に応じて閉塞解除を行ってください。

KFPE34137-E

メッセージ

改ざん防止表への移行中にAgent内部でエラーが発生しました。

対処方法

Agent内部で予期しないエラーが発生したため、処理を中断しました。データベースの状態が変更されている可能性があります。 以下の場所にバックアップファイルがある場合は、そのファイルを使用してHiRDBの回復を行ってください。 バックアップファイルがない場合は、保守員に連絡してください。
[バックアップファイル名]
「MGRノードの一時ファイル格納先ディレクトリ」\fptwiz_backup

KFPE34138-E

メッセージ

改ざん防止表への移行のための前処理に失敗しました。

対処方法

再度実行してください。

KFPE34139-E

メッセージ

pdmodコマンドの実行で警告レベルのエラーが発生しましたが、処理は終了しました。

対処方法

pdmodコマンドの実行で警告レベルのエラーが発生しましたが、処理は終了しました。 警告は、詳細メッセージを参照してください。

KFPE34250-E

メッセージ

内部コマンドで予期しないエラーが発生しました

対処方法

頻繁に発生する場合は、保守員に連絡してください

KFPE34251-E

メッセージ

内部コマンドが警告終了しました。

対処方法

頻繁に発生する場合は、保守員に連絡してください

KFPE34701-I

メッセージ

Composition information acquisition was successful.

対処方法

構成情報取得に成功しました。

KFPE34751-E

メッセージ

Command argument error

対処方法

コマンド引数エラーが発生しました。

KFPE34801-I

メッセージ

It succeeded in registering.

対処方法

Agent定義追加に成功しました。

KFPE34802-I

メッセージ

It succeeded in canceling communication.

対処方法

通信設定情報の解除に成功しました。

KFPE34851-E

メッセージ

The specified argument is invalid.

対処方法

コマンド引数に指定したパラメータが不正です。

Usageに従い、正しい指定を行ってください。

KFPE34852-E

メッセージ

PDDIR has not been set.

対処方法

PDDIRが設定されていないため、処理を中断しました。

環境変数PDDIRに対象のHiRDBの運用ディレクトリを指定してください。

KFPE34853-E

メッセージ

A file operation failed.

対処方法

ファイル操作に失敗しました。

KFPE34854-E

メッセージ

A memory shortage occurred.

対処方法

メモリ不足のため処理を中断しました。

システムリソースの確認後、再度実行してください。

KFPE34855-E

メッセージ

The specified parameter cannot be registered or changed.

対処方法

コマンドライン引数に指定した定義句を変更することはできません。

KFPE34856-E

メッセージ

The specified value is invalid.

対処方法

コマンドライン引数に指定した値が不正です。

KFPE34857-E

メッセージ

The specified password is invalid.

対処方法

指定したユーザパスワードが不正です。

KFPE34858-E

メッセージ

This function is not supported in the OS.

対処方法

指定した定義句は、本OSで未サポートな定義です。

KFPE34859-E

メッセージ

The number of arguments is incorrect

対処方法

コマンドライン引数の数が不正です。

Usageに従い、正しい指定を行ってください。

KFPE34860-E

メッセージ

The existing definition is invalid.

対処方法

Agent定義ファイル不正です。

KFPE34861-E

メッセージ

The specified parameter has not been defined.

対処方法

コマンドライン引数で指定した定義句が定義されていません。

KFPE34862-E

メッセージ

The specified parameter cannot be changed.

対処方法

コマンドライン引数で指定した定義句を変更することができません。

KFPE34863-E

メッセージ

The value of PDDIR is invalid.

対処方法

環境変数で指定したPDDIRの値が不正です。

KFPE34880-E

メッセージ

CMAgent error number = KFPE3XXXX-E Please refer to HELP.

対処方法

Agentでエラーが発生しました。表示されているKFPEメッセージをConsoleのHelpで確認してください。

KFPE34890-E

メッセージ

An unexpected error occurred.

対処方法

予期しないエラーが発生しました。保守員に連絡してください。

KFPE34910-I

メッセージ

HiRDB_CMA setup start, func = aa....aa, HiRDB directory = bb....bb

対処方法

Agentセットアップ処理を開始します。

aa....aa:機能名

add:HiRDB CMAgentをOSに登録します。

delete:HiRDB CMAgentをOSから削除します。

bb....bb:HiRDB運用ディレクトリ名

KFPE34911-I

メッセージ

HiRDB_CMA setup ended, return code=aa

対処方法

Agentセットアップ処理を終了します。

aa:終了コード

0:正常に終了しました。

4:一部の処理が正常に終了しませんでした。

8:処理中に異常が発生しました。

KFPE34912-I

メッセージ

HiRDB_CMA setup canceled

対処方法

Agentセットアップ処理はキャンセルされました。

KFPE34913-I

メッセージ

Definitions of Agent displayed

対処方法

Agentの定義情報を表示します。

KFPE34920-E

メッセージ

cmasetup already used by another user

対処方法

他のユーザが使用している為、cmasetupコマンドを入力できません。

KFPE34930-E

メッセージ

Permission denied

対処方法

コマンドの実行が許可されていません。

cmasetupコマンドは、スーパーユーザーで実行してください

KFPE34931-E

メッセージ

Specified HiRDB_CMA system already catalogued

対処方法

指定したAgentシステムは、既に登録されています。

指定したHiRDB運用ディレクトリ下のAgent運用ディレクトリを調査し、必要であればcmasetup -dを入力した後に再度実行してください。

KFPE34932-E

メッセージ

Specified HiRDB_CMA system not catalogued

対処方法

指定したAgentシステムは登録されていません。

指定したHiRDB運用ディレクトリを調査し、Agent運用ディレクトリが残っているようであれば手動で削除してください。

KFPE34933-E

メッセージ

Specified HiRDB directory not exist

対処方法

指定したHiRDB運用ディレクトリはありません。

指定したHiRDB運用ディレクトリを見直し、再度実行してください。

KFPE34934-E

メッセージ

aa....aa error occurred

対処方法

Agentの提供ロードモジュールの複写および削除に失敗しました。

aa....aa:機能名

Copy:提供ロードモジュールの複写

Remove:提供ロードモジュールの削除

指定したHiRDB運用ディレクトリを見直し、再度実行してください。

( 1 ) aa....aaがCopyの場合

このメッセージの前に出力されたメッセージを参照して対策してください。直前にテキストビジーが発生している場合には、Agentのゾンビプロセスが居残っている場合があります。この場合は、UNIXのkillコマンドでゾンビプロセスを消してから再度実行してください。ディスク容量が不足した場合は、HiRDB運用ディレクトリに十分な容量を割り当ててから再度実行してください。

( 2 ) aa....aaがRemoveの場合

このメッセージの前に出力されたメッセージを参照して対策してください。直前にテキストビジーが発生してる場合にはAgentのゾンビプロセスが居残っている場合があります。この場合は、UNIXのkillコマンドでゾンビプロセスを消してください。その後、該当メッセージの前に出力されているメッセージを参照して、削除に失敗したディレクトリおよびファイルをUNIXのrm -rfコマンドで削除してください。

KFPE34935-E

メッセージ

Create files necessary for execution

対処方法

実行に必要なファイルを作成します。

KFPE34936-E

メッセージ

Unable to set up a lower version

対処方法

下位バージョンへのセットアップはできません。

KFPE34938-E

メッセージ

Specified HiRDB directory not full path name

対処方法

HiRDB運用ディレクトリを絶対パス名で指定し、再度実行してください。

KFPE34939-E

メッセージ

Unable to accept the command due to HiRDB_CMA running

対処方法

Agentが稼動中の為、該当コマンドは実行できません。

HiRDB CMAgentを終了させた後に、再度実行してください。

KFPE34940-I

メッセージ

Delete files necessary for execution

対処方法

実行に必要なファイルを削除します。

KFPE34941-E

メッセージ

Existing environment broken. Set up again after un-setup

対処方法

既存のAgentの環境が不正です。アンセットアップ実行後、再度セットアップを行ってください。

KFPE34942-E

メッセージ

Specified HiRDB directory too long

対処方法

指定したHiRDB運用ディレクトリのパスが長すぎます。指定できるHiRDB運用ディレクトリのパス長は73バイト以下です。

KFPE34950-E

メッセージ

Root directory specified

対処方法

HiRDB運用ディレクトリにルートディレクトリが指定されています。

ルートディレクトリをHiRDB運用ディレクトリに変更できません。HiRDB運用ディレクトリを別に作成して、再度実行してください。

KFPE34960-E

メッセージ

Usage: cmasetup [-d] [HiRDB directory]

対処方法

cmasetupコマンドの指定が誤っています。

オペランドを見直し、再度実行してください。

KFPE34970-Q

メッセージ

Specified HiRDB_CMA system already catalogued. Continue? (Y/N)

対処方法

指定したAgentシステムは、既に登録されています。上書きセットアップを行う場合にはYを選択してください。Nを選択した場合は、セットアップを終了します。

KFPE34971-Q

メッセージ

Setup determined above values. OK? (Y/N)

対処方法

上記の値でセットアップを確定します。

KFPE36003-W

メッセージ

システムログファイルの初期設定に成功しましたが、HiRDBが停止中のためオープンできませんでした。

対処方法

HiRDBの状態を確認してください。

KFPE36004-W

メッセージ

システムログファイルのA系の物理ファイルは既に初期設定されています。

対処方法

システムログファイルのA系の物理ファイルは既に初期設定されているため、指定されたHiRDBレコード数での初期設定は実行しませんでした。

KFPE36005-W

メッセージ

システムログファイルのB系の物理ファイルは既に初期設定されています。

対処方法

システムログファイルのB系の物理ファイルは既に初期設定されているため、指定されたHiRDBレコード数での初期設定は実行しませんでした。

KFPE36006-W

メッセージ

ステータスファイルの初期設定に成功しましたが、HiRDBまたは対象のユニットまたはサーバが停止中のためオープンできませんでした。

対処方法

HiRDBの状態を確認してください。

KFPE42001-E

メッセージ

JP1/AJS2連携用Console内で予期しないｴﾗｰが発生しました。

対処方法

頻繁に発生する場合は、保守員に連絡してください。

KFPE42002-E

メッセージ

メモリ領域が不足しているため処理を中断しました。

対処方法

しばらくしてから、再度実行してください。頻繁に発生する場合は、Agentがインストールされているサーバマシンのメモリを見直してください。

KFPE42003-E

メッセージ

Serverに接続できませんでした。

対処方法

CM Consoleで前回接続した情報でCM Serverへ接続可能か確認し、再度CM Ajs2Consoleを起動してください。

KFPE42004-E

メッセージ

通信処理でエラーが発生しました。

対処方法

CosnoleとServerがインストールされているマシンの状態を確認してください。

KFPE42005-E

メッセージ

Serverとの通信でタイムアウトが発生しました。

対処方法

しばらくしてから再度実行してください。頻繁に発生する場合は、Console-Server間のネットワークを確認して下さい。

KFPE42006-E

メッセージ

通信処理の初期化に失敗しました。

対処方法

ws2_32.dllのバージョンを確認し、最新のバージョンにしてください。

KFPE42007-E

メッセージ

ファイルアクセスに失敗しました。

対処方法

JP1/AJS2のカスタムジョブの定義プログラム以外の用途で使用することはできません。

KFPE42008-E

メッセージ

JP1/AJS2-View以外から起動されました。

対処方法

JP1/AJS2のカスタムジョブの定義プログラム以外の用途で使用することはできません。

KFPE42009-E

メッセージ

JP1/AJS2用DLLでｴﾗｰが発生しました

対処方法

JP1/AJS2のインストール状態とバージョンを確認してください。

KFPE42010-E

メッセージ

JP1/AJS2のDLLを読み込めませんでした。JP1/AJS2が正常にインストールされていない可能性があります。

対処方法

JP1/AJS2のインストール状態とバージョンを確認してください。

KFPE42011-E

メッセージ

環境変数の読込みに失敗しました。

対処方法

環境変数の設定を見直してください。

KFPE42012-E

メッセージ

処理対象AgentのOSが未サポートであるために処理を中断しました。

対処方法

Windows環境以外のAgentにこの機能を使用することはできません。

KFPE42013-E

メッセージ

前回JP1/AJS2で設定したカスタムジョブ情報に誤りがあるため処理を中断しました。

対処方法

対象のジョブを一度削除してから再度ジョブ定義を行ってください。

KFPE42014-E

メッセージ

レジストリアクセスに失敗しました。

対処方法

CM Console,AJS2-Viewのインストール状態を確認してください。

KFPE42015-E

メッセージ

CM Consoleがインストールされていない、または、インストール状態が不正です。

対処方法

CM Consoleが正しくインストールされているかを確認してください。

KFPE42016-E

メッセージ

Serverから取得したカタログ情報に不正なデータが含まれていたため処理を中断しました。

対処方法

対象のカタログをCM consoleで削除し、再度カタログを作成してください。

KFPE42017-E

メッセージ

カタログ作成後にカタログの要素が削除された可能性があります。

対処方法

対象のカタログをCM consoleで削除し、再度カタログを作成してください。

KFPE42101-E

メッセージ

AJS2/Console実行中にKFPEnnnn-mが発生しました。

対処方法

CM Consoleヘルプを参照して、出力されているKFPEメッセージの内容を確認してください。

KFPE42102-E

メッセージ

AJS2/Console実行中に予期せぬエラーが発生しました。

対処方法

保守員に連絡してください。

KFPE47001-W

メッセージ

AJS2のコマンドラインを取得できませんでした。前回情報を表示できません。

対処方法

前回情報を表示できません。再度AJS2カスタムジョブの設定を行ってください。

KFPE47002-W

メッセージ

UNIXAgentのため、情報は自分で設定してください。

対処方法

-

KFPE47003-W

メッセージ

カタログを構成する情報が既に削除されているので表示できません。

対処方法

対象のカタログをConsoleで削除し、再度カタログを作成してください。

KFPE57501-E

メッセージ

ユーザ認証に失敗しました。

対処方法

ユーザ名、パスワードを確認してください。

KFPE57502-E

メッセージ

選択したRDエリア種別は拡張できません。

対処方法

拡張可能なRDエリアを指定してください。

KFPE57503-E

メッセージ

xxxxxxxxがありません。

対処方法

条件に合うxxxxxxxxがありません。選択条件を確認してください。

KFPE57504-E

メッセージ

xxxxxxxxを指定してください。

対処方法

表示された入力項目は省略することはできません。

値を入力してください。

KFPE57505-E

メッセージ

xxxxxxxxに数字のみを入力してください。

対処方法

数字のみを入力してください。

KFPE57506-E

メッセージ

xxxxxxxxに指定範囲内の値を入力してください。

対処方法

指定範囲内の値を入力してください。

KFPE57507-E

メッセージ

xxxxxxxxに英数字を入力してください。

対処方法

入力した値が英数字かを確認してください。

KFPE57508-E

メッセージ

処理対象のHiRDBシステムはHiRDB CMで管理しているHiRDBシステムではありません。

対処方法

HiRDB CMで管理されているHiRDBシステムを指定してください。

KFPE57509-E

メッセージ

通信処理に失敗しました。

対処方法

ネットワークの状態を確認してください。

頻繁に発生する場合は、保守員に連絡してください。

KFPE57510-E

メッセージ

通信処理に失敗しました。

対処方法

ネットワークの状態を確認してください。

頻繁に発生する場合は、保守員に連絡してください。

KFPE57511-E

メッセージ

指定されたxxxxxxxxがnnnnnnnn字を超えました。

対処方法

表示された文字数以内の文字を指定してください。

KFPE57512-E

メッセージ

HiRDB CM Console-WEB版のシステムログファイル情報の初期化に失敗しました。

対処方法

インストールに失敗した可能性があります。　マシンの状態を確認してください。

頻繁に発生する場合は、保守員に連絡してください。

KFPE57513-E

メッセージ

システム内部エラーが発生しました。

対処方法

インストールに失敗した可能性があります。　マシンの状態を確認してください。

頻繁に発生する場合は、保守員に連絡してください。

KFPE57514-E

メッセージ

通信処理に失敗しました。

対処方法

ネットワークの状態を確認してください。

頻繁に発生する場合は、保守員に連絡してください。

KFPE57515-E

メッセージ

xxxxxxxxに整数を入力してください。

対処方法

表示されたコントロールの入力値を確認してください。

KFPE57516-E

メッセージ

システム内部エラーが発生しました。

対処方法

インストールに失敗した可能性があります。　マシンの状態を確認してください。

頻繁に発生する場合は、保守員に連絡してください。

KFPE57517-E

メッセージ

通信最大待ち時間が不正な値に設定されています。必ず0より大きい数字を入力してください。

対処方法

以下の設定ファイルの値が不正に変更された可能性があります。

ファイル名 {CM Serverインストールディレクトリ}\CMC-WEB\WEB-INF\web.xml

設定値 WaitMaxTime=300 [秒]

KFPE57518-E

メッセージ

通信処理でタイムアウトが発生しました。

対処方法

{CM Serverインストールディレクトリ}\CMC-WEB\WEB-INF\web.xmlドキュメントのWaitMaxTime設定値が妥当か確認してください。

WaitMaxTime設定値に問題がなければ、保守員に連絡してください。

KFPE57519-E

メッセージ

選択したシステムログファイルグループにクローズ以外の状態が存在します。

対処方法

システムログファイルのオープン状態を確認し、クローズ状態のシステムログファイルを選択してください。

KFPE57520-E

メッセージ

HiRDB CM で管理していないシステムが指定されているため、処理を中断しました。

対処方法

管理HiRDBをCM Consoleから追加してください。

KFPE57521-E

メッセージ

セッションに値がありません。

対処方法

ブラウザ/WEB-Server間の通信処理でタイムアウトが発生しました。
再度ログインしてください。
タイムアウト時間のデフォルトは、30分に設定されています。頻繁に発生する場合は、以下の値を変更することで、ブラウザ/WEB-Server間のタイムアウト時間を変更できます。
Tomcatを使用している場合：
{CMSインストールディレクトリ}\CMC-WEB\WEB-INF\web.xmlファイルに記述された
<session-config>
<session-timeout>30</session-timeout>
</session-config>
の値を変更してください。
変更後は、Tomcatの再起動を行ってください。
Cosminexusを使用している場合：
{CMC-WEB.warファイルが解凍されたディレクトリ}\CMC-WEB\WEB-INF\web.xmlファイルに記述された
<session-config>
<session-timeout>30</session-timeout>
</session-config>
の値を変更してください。
変更後は、J2EEサーバの再起動を行ってください。

KFPE57522-E

メッセージ

CM Server又はCM Agentでxxxxxxxxエラーが発生しました。

対処方法

CM Server又はCM Agentと同じバージョンのHelpを参照し、原因を取り除いてから再度実行してください。

KFPE57523-E

メッセージ

レジストリとCMC-WEBのバージョンが異なっています。

対処方法

レジストリCMC-WEBのキーCurrentVersionの値とCMC－WEBのバージョンが一致しているか確認してください。

KFPE57524-Q

メッセージ

指定したxxxxxxxxを削除します。よろしいですか？

対処方法

-

KFPE57525-E

メッセージ

xxxxxxxxに指定範囲nnnnnnnn内の値を入力してください。

対処方法

指定範囲内の値を入力してください。

KFPE57526-W

メッセージ

xxxxxxxxの削除に失敗しました。

対処方法

【削除対象がバックアップファイル、またはアンロードログファイルの場合】
実ファイルの削除に失敗しても、HiRDB CMの管理情報は削除されています。HiRDBの稼動するマシンで実ファイルを削除してください。
【削除対象がその他のリソースの場合】
削除可能な{para1}を指定してください。

KFPE57527-E

メッセージ

xxxxxxxxを行う場合、一つだけのレコードを選択してください。

対処方法

一つだけのレコードを選択してください。

KFPE57528-E

メッセージ

レジストリの操作に失敗しました。

対処方法

保守員に連絡してください。

KFPE57529-E

メッセージ

正しい旧パスワードを入力してください。

対処方法

-

KFPE57530-E

メッセージ

入力されたパスワードは一致しません。新しいパスワードを両方のボックスに入力してください。

対処方法

新しいパスワードを両方のボックスに入力してください。

KFPE57531-E

メッセージ

xxxxxxxxには成功しましたが、その後の情報取得に失敗しました。再度、更新処理を行うか、xxxxxxxxの状態を確認してください。

対処方法

CM Serverと対象HiRDBの稼動状態を確認してください。

KFPE57532-E

メッセージ

選択したRDエリア種別は削除できません。

対処方法

ユーザ用RDエリア、ユーザLOB用RDエリア、リスト用RDエリア以外のRDエリア種別は削除できません。

KFPE57533-E

メッセージ

xxxxxxxxの指定値にスペースが含まれています。スペースの入力はできません。

対処方法

xxxxxxxxの指定値にスペースを含めないでください。

KFPE57534-E

メッセージ

xxxxxxxxを指定フォーマットで入力してください。

対処方法

-

KFPE57535-E

メッセージ

異なるホスト名は実行できません。同じホスト名を選択してください。

対処方法

同じホスト名を選択してください。

KFPE57536-E

メッセージ

インデクス用のグローバルバッファは割当できません。

対処方法

-

KFPE57537-E

メッセージ

その他用のグローバルバッファは削除できません。

対処方法

その他用のグローバルバッファを選択しないでください。

KFPE57538-E

メッセージ

xxxxxxxxの先頭文字に英字を入力してください。

対処方法

英字から始まる名称を指定してください。

KFPE57539-E

メッセージ

xxxxxxxxに偶数を入力してください。

対処方法

偶数を入力してください。

KFPE57540-E

メッセージ

変更する項目を選択してください。

対処方法

-

KFPE57541-E

メッセージ

一度も使用されていないポリシーを実行することはできません。

対処方法

-

KFPE57542-E

メッセージ

グローバルバッファ名に英数字を入力してください。

対処方法

英数字からなるグローバルバッファ名を指定してください。

KFPE57543-E

メッセージ

選択している格納先のファイル名の文字数が不正です。

入力したHiRDBファイル名、又はHiRDBファイルシステム領域名の文字数が不正です。

対処方法

HiRDBファイルシステム領域＋HiRDBファイル、または、バックアップファイル格納先＋ファイル名のパス長が指定可能な上限を越えています。ファイル名を変更してください。

KFPE57544-E

メッセージ

選択したサーバはxxxxxxxxできません。

対処方法

xxxxxxxxを実行するには、サーバタイプがFES以外のサーバを選択してください。

KFPE57545-E

メッセージ

HiRDBファイル名に英数字とアンダーバーを入力してください。

選択している格納先のファイル名に英数字とアンダーバーを入力してください。

対処方法

英数字とアンダーバーからなる名称を指定してください。

KFPE57546-E

メッセージ

サーバ起動中の常駐プロセス数は、サーバ起動中の最大起動プロセス数以下の値を指定してください。

対処方法

常駐プロセス数が最大起動プロセス数を超えないようにしてください。

KFPE57547-E

メッセージ

サーバプロセスの起動本数の変更は行えません。

対処方法

サーバプロセス数の検索をもう一回行ってください。

KFPE57548-E

メッセージ

選択したサーバ稼動状態はxxxxxxxxできません。

対処方法

再開始を行うには、稼動状態が停止中のサーバを選択してください。一時停止を行うには、稼動状態が停止中のサーバを選択してください。

KFPE57549-E

メッセージ

選択されたRDエリアのカレント変更はできません。

対処方法

世代番号の値が0のレコードを選択してください。

KFPE57550-E

メッセージ

選択した状態はステータスファイルの作成ができません。

対処方法

ステータスファイルの作成を行うには、状態が「障害閉塞ファイル」、「予約ファイル」、「物理ファイルがない」、「不明ファイル」のいずれかのレコードを選択してください。

KFPE57551-E

メッセージ

[スケジュール指定有]状態のカタログは削除できません。

対処方法

カタログを削除する場合は、当該カタログを使用するスケジュールを全て削除してから実行してください。

KFPE57552-E

メッセージ

指定したHiRDBファイルシステム領域内に種別の異なるHiRDBファイルが存在します。

対処方法

使用用途の異なるHiRDBファイルが含まれる場合、HiRDBファイルシステム領域単位のバックアップは実行できません。HiRDBファイル単位のバックアップを実行してください。

KFPE57553-E

メッセージ

入力したバックアップファイル格納先、又はバックアップファイル名の文字数が不正です。

対処方法

バックアップファイル格納先＋ファイル名のパス長が指定可能な上限を越えています。ファイル名を変更してください。

KFPE57554-E

メッセージ

指定された開始日時は終了日時を超えています。開始日時は終了日時を超える入力ができません。

対処方法

開始日時が終了日時を越えないようにしてください。

KFPE57555-Q

メッセージ

指定された日付のうち、29・30・31日は存在しない月があります。その場合はスケジュールが実行されません。よろしいですか？

対処方法

-

KFPE57556-E

メッセージ

指定したRDエリアの種別では、拡張はサポートされていません。

対処方法

指定されたRDエリアの拡張はHiRDB CMでは実行できません。HiRDBコマンドを実行してください。

KFPE57557-E

メッセージ

自動データメンテナンスの解析に失敗しました。

対処方法

自動データメンテナンス処理状況を確認してください。

KFPE57558-E

メッセージ

メンテナンス処理に失敗しました｡

対処方法

自動データメンテナンス処理状況を確認し、原因を取り除いてください。

KFPE57559-E

メッセージ

選択した解析対象にユーザ表、ユーザインデクス、ディクショナリ表以外の種別が存在します。

対処方法

選択した解析対象はユーザ表、ユーザインデクス、ディクショナリ表以外の種別の場合、解析操作が実行されません。

KFPE57560-E

メッセージ

指定されたxxxxxxxxは無効な値です。

対処方法

リソース警告値の有効設定値を確認し、指定してください。

KFPE57561-E

メッセージ

xxxxxxxxはyyyyyyyyよりzzzzzzzzを指定してください。

対処方法

正しいxxxxxxxx、yyyyyyyyyを入力してください。

KFPE57562-E

メッセージ

xxxxxxxxはyyyyyyyy以上のzzzzzzzzを指定してください。

対処方法

正しいxxxxxxxx、yyyyyyyyyを入力してください

KFPE57563-E

メッセージ

xxxxxxxxのレプリカRDエリアが定義されていない世代があります。

対処方法

対象世代のレプリカRDエリア環境を確認してください。

KFPE57564-E

メッセージ

監視状態が監視中なので、監視状態の変更は行えません。

対処方法

監視状態を非監視中に変更してから再度実行してください。

KFPE57565-E

メッセージ

対象データに対して、状態解析は実行できません。

対処方法

正しい対象データを指定してください。

KFPE57566-E

メッセージ

選択したデータには情報ファイルが存在しません。

対処方法

正しいデータを指定してください。

KFPE57567-E

メッセージ

指定した時間以前の情報はありません。

対処方法

正しい時間を指定してください。

KFPE57568-E

メッセージ

カタログのバージョンが古いため、詳細情報を表示することができません。

対処方法

CMC-WEBでは指定したカタログの詳細情報を表示することができません。当該カタログの情報を確認する場合は、CM Consoleを使用してください。

KFPE57569-E

メッセージ

異なる所有者の表に対して、アクセス権限を変更することはできません。

対処方法

同じ所有者の表に対して、アクセス権限を変更してください。

KFPE57570-E

メッセージ

キーワードに使用できない文字が含まれています。使用できる文字は、半角英数字と空白、および、「.(ピリオド)」「_(下線)」「-(ハイフン)」「@」「\」「/」「#」「:」です。

対処方法

使用できる文字は、半角英数字と空白、および、「.(ピリオド)」「_(下線)」「-(ハイフン)」「@」「\」「/」「#」「:」です。

KFPE57571-E

メッセージ

1個以上のカタログ種別を選択してください。

対処方法

－

KFPE57572-E

メッセージ

一回の操作では複数の表に対する権限を同じにする必要があります。権限を設定してください。

対処方法

指定された表に対する権限が一致していません。権限を与えるか与えないかどちらかに設定してください。

KFPE57573-E

メッセージ

指定したRDエリアの種別では、再初期化はサポートされていません。

対処方法

指定されたRDエリアの再初期化はHiRDB CMでは実行できません。HiRDBコマンドを実行してください。

KFPE57574-E

メッセージ

bes_typeには「host」、または「guest」以外を指定できません。

対処方法

bes_typeの指定は「host」または、「guest」を指定してください。

KFPE57575-E

メッセージ

指定されたユニットは、指定されたサーバの属するユニットではありません。

対処方法

指定したユニットまたはサーバ名とHiRDBの構成を確認し、正しい構成を指定してください。

KFPE57576-E

メッセージ

指定されたユニットは、指定されたサーバのゲスト領域ではありません。

対処方法

指定したユニットまたはサーバ名とHiRDBの構成を確認し、正しい構成を指定してください。

KFPE57577-E

メッセージ

指定されたユニットは、指定されたサーバの正規ユニットではありません。

対処方法

指定したユニットまたはサーバ名とHiRDBの構成を確認し、正しい構成を指定してください。

KFPE57578-E

メッセージ

unit_typeには「primary」、または「secondary」以外を指定できません。

対処方法

unit_typeの指定は「primary」または「secondary」を指定してください。

KFPE57579-E

メッセージ

VV-RR以下のAgentでは本機能をサポートしていません。

対処方法

本機能を使用する場合は、Agentをバージョンアップしてください。

KFPE57580-E

メッセージ

VV-RR未満のHiRDBでは本機能をサポートしていません。

対処方法

本機能を使用する場合は、HiRDBをバージョンアップしてください。

KFPE57581-E

メッセージ

選択された表は既に改ざん防止表です。

対処方法

改ざん防止表以外の表を選択してください。

KFPE57582-E

メッセージ

xxxxxxxxは改ざん防止表に変更できません。

対処方法

改ざん防止表へ移行できない表が指定されました。改ざん防止表へ移行できる表を選択してください。対象となる表についてはHELPの[表]-[改ざん防止表に移行]の項目を参照してください。

KFPE57583-E

メッセージ

全ての列を更新可能列にすることはできません。

対処方法

全ての列を更新可能列にすることは改ざん防止になりません。更新可能列の設定を見直してください。

KFPE57584-E

メッセージ

改ざん防止表を含むRDエリアの再初期化を実行することはできません。

対処方法

-

KFPE57585-E

メッセージ

HiRDBファイルシステム領域の世代削除を実行する場合はレプリカHiRDBファイルシステム領域を選択してください。

対処方法

レプリカHiRDBファイルシステム領域を選択してください。

KFPE57586-E

メッセージ

レプリカRDエリアが存在するHiRDBファイルシステム領域の世代削除は実行できません。

対処方法

指定されたHiRDBファイルシステム領域の世代削除を行う場合は、レプリカRDエリアを削除してから実行してください。

KFPE57587-Q

メッセージ

選択されたHiRDBファイルシステム領域の世代削除を実行します。よろしいですか？

対処方法

-

KFPE57588-E

メッセージ

xxxxxxxxは無効なフォーマットで指定されています。正しいフォーマットで入力してください。

対処方法

指定されたパスがWindows、またはUNIXでの有効なパス名ではありません。

以下の点を確認してください。

・絶対パスで記述されている

・ディレクトリ名とファイル名に分離できる

・パスに使用できない文字が含まれていない

KFPE57589-E

メッセージ

xxxxxxxxHiRDBファイルシステム領域の世代登録は実行できません。

対処方法

世代登録ができるHiRDBファイルシステム領域を選択してください。

KFPE57590-E

メッセージ

HiRDBファイルシステム領域の世代登録を実行する場合はオリジナルとなるHiRDBファイルシステム領域を選択してください。

対処方法

既に世代登録されているレプリカHiRDBファイルシステム領域が指定されました。世代登録をしていないHiRDBファイルシステム領域、またはオリジナルHiRDBファイルシステム領域を選択してください。

KFPE57591-E

メッセージ

削除する項目をレプリカHiRDBファイルシステム領域一覧から選択してください。

対処方法

削除対象を選択し、再度実行してください。

KFPE57592-E

メッセージ

指定されたオリジナルHiRDBファイルシステム領域に対して同じ世代番号のレプリカHiRDBファイルシステム領域が既に指定されています。

対処方法

世代番号を重複しないように変更してください。

KFPE57593-E

メッセージ

同じレプリカHiRDBファイルシステム領域名が既に指定されています。

対処方法

レプリカHiRDBファイルシステム領域名を重複しないように変更してください。

KFPE57601-E

メッセージ

定義ファイル「%CMC-WEB%\c\conf\CommConf」の内容不正なため、処理を中断しました。

対処方法

WEB Serverを再起動してください。

KFPE57602-E

メッセージ

通信処理に失敗しました。

対処方法

WEB Serverを再起動してください。
頻繁に発生する場合は、保守員に連絡してください。

KFPE57610-E

メッセージ

通信処理に失敗しました。

対処方法

共有メモリ作成時にMutexエラーが発生しました。WEB Serverを再起動してください。
頻繁に発生する場合は、保守員に連絡してください。

KFPE57611-E

メッセージ

通信処理に失敗しました。

対処方法

共有メモリ作成時、イベント処理エラーが発生しました。WEB Serverを再起動してください。
頻繁に発生する場合は、保守員に連絡してください。

KFPE57612-E

メッセージ

通信処理に失敗しました。

対処方法

WEB Serverを再起動してください。
頻繁に発生する場合は、保守員に連絡してください。

KFPE57613-E

メッセージ

通信処理中にレジストリ操作に失敗しました。

対処方法

共有メモリ作成時、レジストリ処理エラーが発生しました。WEB Serverを再起動してください。
頻繁に発生する場合は、保守員に連絡してください。

KFPE57615-E

メッセージ

共有メモリ処理エラーが発生しました。

対処方法

WEB Serverを再起動してください。
頻繁に発生する場合は、保守員に連絡してください。

KFPE57623-E

メッセージ

解析情報が指定値を超えたため、処理を中断しました。

対処方法

WEB Serverを再起動してください。

頻繁に発生する場合は、保守員に連絡してください。

KFPE57625-E

メッセージ

通信処理中にタイムアウトが発生しました。

対処方法

以下の要因が考えられます。

・CM Serverにアクセスが集中している。

・管理対象HiRDBへのアクセスが集中している。

上記原因を取り除いたあと再度実行してください。

頻繁に発生する場合は、以下の設定ファイルの値を変更した後、WEB Serverを再起動してください。

ファイル名 {CM Serverインストールディレクトリ}\CMC-WEB\c\conf\CommConf

設定値 TimeOut=30 [秒]

KFPE57626-E

メッセージ

通信処理中に予期しないエラーが発生しました。

対処方法

WEB Serverを再起動してください。

頻繁に発生する場合は、保守員に連絡してください。

KFPE57627-E

メッセージ

CM Serverが停止しているため、処理を中断しました。

対処方法

CM Serverの起動状態を確認してください。

KFPE57628-E

メッセージ

通信処理に失敗しました。

対処方法

ネットワークの状態を確認してください。

頻繁に発生する場合は、保守員に連絡してください。

KFPE57630-E

メッセージ

通信処理に失敗しました。

対処方法

ネットワークの状態を確認してください。

頻繁に発生する場合は、保守員に連絡してください。

KFPE57631-E

メッセージ

通信処理に失敗しました。

対処方法

ネットワークの状態を確認してください。

頻繁に発生する場合は、CM Consoleから操作を行ってください。

KFPE57634-E

メッセージ

通信処理中に、WEB Serverのサービス強制終了されました。

対処方法

WEB Serverを起動してください。

KFPE57643-E

メッセージ

実行結果の情報量が多いため、Web Consoleでは結果を表示することができません。

対処方法

CM Consoleから操作を行ってください。

KFPE57645-E

メッセージ

通信処理中にタイムアウトが発生しました。

対処方法

以下の要因が考えられます。

・CM Serverにアクセスが集中している。

・管理対象HiRDBへのアクセスが集中している。

上記原因を取り除いたあと再度実行してください。

頻繁に発生する場合は、以下の設定ファイルの値を変更した後、WEB Serverを再起動してください。

ファイル名 {CM Serverインストールディレクトリ}\CMC-WEB\c\conf\CommConf

設定値 TimeOut=30 [秒]

KFPE57646-E

メッセージ

通信処理中に予期しないエラーが発生しました。

対処方法

WEB Serverを再起動してください。

頻繁に発生する場合は、保守員に連絡してください。

KFPE57647-E

メッセージ

CM Serverが停止しているため、処理を中断しました。

対処方法

CM Serverの起動状態を確認してください。

KFPE57648-E

メッセージ

通信処理に失敗しました。

対処方法

ネットワークの状態を確認してください。

頻繁に発生する場合は、保守員に連絡してください。

KFPE57650-E

メッセージ

通信処理に失敗しました。

対処方法

ネットワークの状態を確認してください。

頻繁に発生する場合は、保守員に連絡してください。

KFPE57654-E

メッセージ

通信処理中に、WEB Serverのサービス強制終了されました。

対処方法

WEB Serverを起動してください。

KFPE57663-E

メッセージ

解析情報が指定値を超えたため、処理を中断しました。

対処方法

WEB Serverを再起動してください。

頻繁に発生する場合は、保守員に連絡してください。

KFPE57665-E

メッセージ

通信処理中にタイムアウトが発生しました。

対処方法

以下の要因が考えられます。

・CM Serverにアクセスが集中している。

・管理対象HiRDBへのアクセスが集中している。

上記原因を取り除いたあと再度実行してください。

頻繁に発生する場合は、以下の設定ファイルの値を変更した後、WEB Serverを再起動してください。

ファイル名 {CM Serverインストールディレクトリ}\CMC-WEB\c\conf\CommConf

設定値 TimeOut=30 [秒]

KFPE57666-E

メッセージ

通信処理中に予期しないエラーが発生しました。

対処方法

WEB Serverを再起動してください。

頻繁に発生する場合は、保守員に連絡してください。

KFPE57667-E

メッセージ

CM Serverが停止しているため、処理を中断しました。

対処方法

CM Serverの起動状態を確認してください。

KFPE57668-E

メッセージ

通信処理に失敗しました。

対処方法

ネットワークの状態を確認してください。

頻繁に発生する場合は、保守員に連絡してください。

KFPE57670-E

メッセージ

通信処理に失敗しました。

対処方法

ネットワークの状態を確認してください。

頻繁に発生する場合は、保守員に連絡してください。

KFPE57674-E

メッセージ

通信処理中に、WEB Serverのサービスが強制終了されました。

対処方法

WEB Serverを起動してください。

KFPE57683-E

メッセージ

解析情報が指定値を超えたため、処理を中断しました。

対処方法

WEB Serverを再起動してください。

頻繁に発生する場合は、保守員に連絡してください。

KFPE57685-E

メッセージ

通信処理中にタイムアウトが発生しました。

対処方法

以下の要因が考えられます。

・CM Serverにアクセスが集中している。

・管理対象HiRDBへのアクセスが集中している。

上記原因を取り除いたあと再度実行してください。

頻繁に発生する場合は、以下の設定ファイルの値を変更した後、WEB Serverを再起動してください。

ファイル名 {CM Serverインストールディレクトリ}\CMC-WEB\c\conf\CommConf

設定値 TimeOut=30 [秒]

KFPE57686-E

メッセージ

通信処理中に予期しないエラーが発生しました。

対処方法

WEB Serverを再起動してください。

頻繁に発生する場合は、保守員に連絡してください。

KFPE57687-E

メッセージ

CM Serverが停止しているため、処理を中断しました。

対処方法

CM Serverの起動状態を確認してください。

KFPE57688-E

メッセージ

通信処理に失敗しました。

対処方法

ネットワークの状態を確認してください。

頻繁に発生する場合は、保守員に連絡してください。

KFPE57690-E

メッセージ

通信処理に失敗しました。

対処方法

ネットワークの状態を確認してください。

頻繁に発生する場合は、保守員に連絡してください。

KFPE57691-E

メッセージ

返信電文体を接収する時、イベント処理エラーが発生しました。

対処方法

WEB Serverを再起動してください。

頻繁に発生する場合は、保守員に連絡してください。

KFPE57694-E

メッセージ

通信処理中に、WEB Serverのサービス強制終了されました。

対処方法

WEB Serverを起動してください。

KFPE57701-I

メッセージ

xxxxxxxxに成功しました。

対処方法

-

KFPE57702-I

メッセージ

管理情報の更新間隔を変更しませんでした。

対処方法

-

KFPE57703-I

メッセージ

xxxxxxxxを作成しました。

対処方法

-

KFPE57704-I

メッセージ

自動データメンテナンス機能が設定されていません。

対処方法

-

KFPE57705-I

メッセージ

自動データメンテナンス機能が一度も実行されていません。

対処方法

-

KFPE57706-I

メッセージ

カタログの登録内容を変更しました。

対処方法

-

KFPE57801-E

メッセージ

選択されたHiRDBファイルシステム領域はレプリカを使用していません。

対処方法

インナレプリカ機能を使用しているHiRDBファイルシステム領域を選択してください。

KFPE57802-E

メッセージ

レプリカRDエリアの拡張は実行できません。

対処方法

指定されたRDエリアの拡張はHiRDB CMでは実行できません。HiRDBコマンドを実行してください。

KFPE57803-E

メッセージ

レプリカグループ内にレプリカRDエリアが一つしかない場合は、レプリカRDエリアの削除を実行できません。

対処方法

レプリカRDエリアがレプリカグループ内に一つしかない場合は、レプリカ統合を行ってください。

KFPE57804-E

メッセージ

オリジナルRDエリアの削除は実行できません。

対処方法

オリジナルRDエリアを削除する場合は、レプリカ統合を行い、その後、統合後のRDエリアを削除してください。

KFPE57805-E

メッセージ

レプリカRDエリアの再初期化は実行できません。

対処方法

指定されたRDエリアの再初期化はHiRDB CMでは実行できません。HiRDBコマンドを実行してください。

KFPE57806-E

メッセージ

このシステムにレプリカRDエリアを定義することはできません。

対処方法

指定されたHiRDBシステムはインナレプリカを使用する設定になっていません。インナレプリカ関連機能を実行しないでください。

KFPE57807-E

メッセージ

レプリカRDエリアには、レプリカRDエリアを定義することはできません。

対処方法

レプリカRDエリアを定義する場合は、レプリカRDエリアが定義されていないRDエリア、またはオリジナルRDエリアを選択してください。

KFPE57808-E

メッセージ

選択されたRDエリアにレプリカRDエリアをこれ以上定義することはできません。

対処方法

指定されたRDエリアには既に10世代のレプリカRDエリアが定義されています。

KFPE57809-E

メッセージ

選択されたRDエリアはレプリカRDエリアを定義することができない種別です。

対処方法

レプリカRDエリアを定義できるのはユーザ用RDエリア、またはユーザLOB用RDエリアです。RDエリアの種別を確認してください。

KFPE57810-E

メッセージ

選択されたRDエリアは改ざん防止表が定義されているため、レプリカRDエリアを定義できません

対処方法

改ざん防止表が定義されているRDエリアのレプリカRDエリアを定義することはできません。RDエリアに格納されている表を確認してください。

KFPE57811-E

メッセージ

RDエリアのレプリカ定義を行う場合、一つだけのRDエリアを選択してください。

対処方法

-

KFPE57812-E

メッセージ

RDエリアの構成情報複写を行う場合、一つだけのRDエリアを選択してください。

対処方法

-

KFPE57813-E

メッセージ

レプリカ統合を行う場合、一つだけのRDエリアを選択してください。

対処方法

-

KFPE57814-E

メッセージ

RDエリアの構成情報複写を行う場合、オリジナルRDエリアを選択してください。

対処方法

-

KFPE57815-E

メッセージ

レプリカ統合を実行する場合はオリジナルRDエリアを選択してください。

対処方法

-

KFPE57816-E

メッセージ

レプリカRDエリアが複数ある場合はレプリカ統合を実行できません。

対処方法

レプリカ統合を行う場合は、統合後に残すRDエリア以外のレプリカRDエリアを削除し、その後、レプリカ統合を実行してください。

KFPE57817-E

メッセージ

xxxxxxxxとyyyyyyyyを統合します。よろしいですか？

対処方法

-

KFPE57818-E

メッセージ

既に定義されているレプリカHiRDBファイルシステム領域を変更することはできません。

対処方法

-

KFPE57819-E

メッセージ

レプリカRDエリアが存在しないためレプリカ統合を実行できません。

対処方法

-

KFPE57820-E

メッセージ

拡張DAT形式でのアンロードでは、アンロードログファイルを複数指定できません。

対処方法

拡張DAT形式でアンロードログファイルを作成する場合は、一つのファイルを指定してください。

KFPE57821-W

メッセージ

オリジナルRDエリアをxxxxxxxxする場合は、HiRDBファイルシステム領域の世代登録を先に行う必要があります。手動で世代登録を行ってください。

対処方法

HiRDBファイルシステム領域の世代登録を行ってください。

KFPE57822-E

メッセージ

RDエリア名に使用できない文字が含まれています。使用できる文字は、半角英数字と空白、および、「_(下線)」「-(ハイフン)」「@」「\」「#」です。

対処方法

RDエリア名を見直し、指定可能な文字を使用してください。

KFPE57823-E

メッセージ

世代番号xxのHiRDBファイルシステム領域の世代削除を行ってください。

対処方法

世代登録されているHiRDBファイルシステム領域上にオリジナルRDエリアが定義されています。HiRDBファイルシステム領域の世代を削除してください。

KFPE57824-E

メッセージ

既に同名のHiRDBファイルが一覧に設定されています。

対処方法

HiRDBファイル名を重複しないように変更してください。

KFPE57825-E

メッセージ

1RDエリアに割り当てられるHiRDBファイルは最大16個です。

対処方法

17個以上のHiRDBファイルを指定しないでください。

KFPE57826-E

メッセージ

xxxxxxxxに指定できない文字が含まれています。

対処方法

xxxxxxxxを見直し、指定可能な文字のみを使用してください。

KFPE57827-E

メッセージ

空白、タブ、アスタリスク（*）、セパレータ文字と同じ文字は、囲み文字として指定できません。

対処方法

囲み文字を見直し、指定可能な文字を使用してください。

KFPE57828-E

メッセージ

空白、アスタリスク（*）、引用符（"）、下線（_）は、セパレータ文字として指定できません。

対処方法

セパレータ文字を見直し、指定可能な文字を使用してください。

KFPE57829-E

メッセージ

xxxxxxxxに使用できない文字が含まれています。使用できる文字は、半角英数字とピリオド（.）、および、「-(ハイフン)」「_(下線)」です。

対処方法

xxxxxxxxを見直し、指定可能な文字を使用してください。

KFPE57830-E

メッセージ

xxxxxxxxに使用できない文字が含まれています。使用できる文字は、半角英数字と「_(下線)」、および、「-(ハイフン)」です。

対処方法

xxxxxxxxを見直し、指定可能な文字を使用してください。

KFPE57831-E

メッセージ

ディレクトリ名に使用できない文字が含まれています。使用できる文字は、半角英数字と空白、および、「.(ピリオド)」「\」「/」「（」「）」「：(コロン)」「_(下線)」です。

対処方法

ディレクトリ名を見直し、指定可能な文字を使用してください。

KFPE57832-E

メッセージ

xxxxxxxxに使用できない文字が含まれています。使用できる文字は、半角英数字と「_(下線)」です。

対処方法

xxxxxxxxを見直し、指定可能な文字を使用してください。


Consoleアプリケーションエラー

ここではConsole上で障害が発生した場合の対処方法について説明します。

Console上でアプリケーション エラーが発生した場合は、次の情報を取得して保守員に連絡してください。

・ Consoleインストールディレクトリ下のCMCSysLog.txt

・ Windowsイベントログ

・ ワトソン博士で得られた情報(ログファイル DRWTSN32.log)

・ このメッセージが表示されている状態の画面イメージ(画面のイメージは [Alt+Print Screen]キーで取得してください)


メッセージ詳細説明表示

Console上の「メッセージボックス」、[システムステータス]>[詳細]>[シスログ情報]、[スケジュール]>[カタログ実行結果情報]>[実行結果ログ]画面で表示されている文字列に対して、メッセージ詳細情報を参照することができます。操作例を以下に示します。

＜操作例＞

(1)Console上の画面に次の文字列が表示されている

      10:09:51 hirdb001 KFPS01800-I xxxxxx xxxxxxxxxxxxxx xxxxxxxxxxxxxxxxxxxxxxx xxxxxxxxxxxxxxxx

(2)HiRDBメッセージIDを含む文字列を　左クリックで選択します。（メッセージIDを含んでいれば、選択する文字列開始、終了位置は特に限定しません。）

      10:09:51 hirdb001 KFPS01800-I xxxxxx xxxxxxxxxxxxxx xxxxxxxxxxxxxxxxxxxxxxx xxxxxxxxxxxxxxxx

(3)選択した文字列にマウスカーソルを位置付け、右クリックすると「ヘルプ」ボタンが表示されます。選択したメッセージの詳細説明を参照する場合は、この「ヘルプ」ボタンを実行してください。

(4)選択された文字列の中にHiRDBメッセージが含まれている場合は、当該メッセージIDに対応するメッセージ詳細説明をHELP画面に表示します。

<注意事項>

·表示されるHiRDBメッセージ詳細説明は、「スケーラブルデータベースサーバHiRDB Version 7 メッセージ (UNIX(R)/Windows(R)用)操作書3000-6-278-10」の記述内容を引用していますので、現在ご使用になっているHiRDBシステムのメッセージ内容と違う内容を表示する場合があります。

·選択された文字列にHiRDBメッセージIDが含まれていないか、または、該当するメッセージ詳細説明が無い場合、HELP画面は、「はじめに」を表示する場合があります。


Serverリターンコード

CM Serverリターンコード

HiRDB Control Manager - Serverが提供するコマンドを実行したときのリターンコード（戻り値）を下表に示します。

表 ＨiRDB Control Manager - Serverが提供するコマンドの戻り値一覧

戻り値 | 対応エラーメッセージ | 使用コマンド | 備考
0 | - |  | 正常終了
1 | KFPE23601-E | CMS | 詳細はメッセージコード参照
2 | KFPE23602-E | CMS | 詳細はメッセージコード参照
3 | KFPE23603-E | CMS | 詳細はメッセージコード参照
4 | KFPE23604-E | CMS | 詳細はメッセージコード参照
5 | KFPE23605-E | CMS | 詳細はメッセージコード参照
6 | KFPE23606-E | CMS | 詳細はメッセージコード参照
7 | KFPE23103-E | CMS | 詳細はメッセージコード参照
8 | KFPE23104-E | CMS | 詳細はメッセージコード参照
9 | KFPE23105-E | CMS | 詳細はメッセージコード参照
10 | KFPE23110-E | CMS | 詳細はメッセージコード参照
11 | KFPE23111-E | CMS | 詳細はメッセージコード参照
12 | KFPE23112-E | CMS | 詳細はメッセージコード参照
13 | KFPE23113-E | CMS | 詳細はメッセージコード参照
14 | KFPE23114-E | CMS | 詳細はメッセージコード参照
15 | KFPE23115-E | CMS | 詳細はメッセージコード参照
16 | KFPE23116-E | CMS | 詳細はメッセージコード参照
17 | KFPE23117-E | CMS | 詳細はメッセージコード参照
18 | KFPE23074-E | CMS | 詳細はメッセージコード参照
19 | KFPE25040-W | CMS | 詳細はメッセージコード参照
20 | KFPE25041-W | CMS | 詳細はメッセージコード参照
21 | KFPE23046-E | CMS | 詳細はメッセージコード参照
101 | KFPE23801-E | CMSMenu | 予約コード
102 | KFPE23804-E | CMSMenu | 予約コード
103 | KFPE23809-E | CMSMenu | 予約コード
104 | KFPE23810-E | CMSMenu | 予約コード
105 | KFPE23813-E | CMSMenu | 予約コード
106 | KFPE23817-E | CMSMenu | 予約コード
107 | KFPE23821-E | CMSMenu | 予約コード
201 | KFPE23784-E | CmsBkupRstr | 詳細はメッセージコード参照
202 | KFPE23785-E | CmsBkupRstr | 詳細はメッセージコード参照
203 | KFPE23786-E | CmsBkupRstr | 詳細はメッセージコード参照
204 | KFPE23787-E | CmsBkupRstr | 詳細はメッセージコード参照
205 | KFPE23788-E | CmsBkupRstr | 詳細はメッセージコード参照
255 | - | - | 上記以外のエラー
（凡例）－：該当しません。


その他

目次

付録

この章では、HiRDB CMでサポートするその他の情報について説明します。

＜この章の構成＞

· Agent定義パラメータ一覧

· 管理情報のバックアップ/リカバリ機能

· HiRDB CMで使用するIPアドレスを変更する方法


Agent定義情報

Agent定義情報パラメータ一覧

HiRDB CM Agentは、インストール時に指定された情報で動作を行います。パラメータの確認は、Agentのセットアップ時とAgent定義パラメータ編集コマンドで行うことができます。Agent定義パラメータ編集コマンドについては、各Agentのソフトフェア添付資料、Readme.txtまたは、リリースノートを参照してください。

l Agent定義パラメータ一覧

以下にAgent定義パラメータの一覧を示します。

パラメータ名 | 値 | 内容
AutoRocketPunch | Y/N | 対象のユニットがシステムマネジャの場合、Rocket Punch機能を示します。 対象のユニットが非システムマネジャの場合は、Agentシステムが内部で使用するパラメータです。
RocketPunchInterval | 1-30[分] | 対象のユニットがシステムマネジャの場合、Rocket Punch機能を発行する間隔を示します。 対象のユニットが非システムマネジャの場合は、Agentシステムが内部で使用するパラメータです。
ConnectIPAddress | 10進ドット記法IPアドレス | 対象のAgentが使用するIPアドレスです。 管理対象のユニットがスタンバイ型系切り替えを使用しており、システムマネジャの場合は、Agentが使用するサービスIPアドレスが表示されます。
ConnectPortNumber | ポート番号 | 対象のAgentが使用するポート番号です。 対象のAgentがスタンバイ系切り替え構成を使用している場合は、現用系と予備系で同じポート番号が指定されている必要があります。
ServerIPAddress | 10進ドット記法IPアドレス | 対象のユニットがシステムマネジャの場合、対象のAgentを管理するServerのIPアドレスを示します。 対象のユニットが非システムマネジャの場合は、Agentシステムが内部で使用するパラメータです。
ServerPortNumber | ポート番号 | 対象のユニットがシステムマネジャの場合、対象のAgentを管理するServerのポート番号を示します。 対象のユニットが非システムマネジャの場合は、Agentシステムが内部で使用するパラメータです。
SetupID | 4文字英数字 | Agentシステムが内部で使用するパラメータです。
EasyMT | Y/N | バックアップ装置としてEasyMTを使用する場合は、Yを示します。使用しない場合は、Nを表示します。
MTGuide | Y/N | バックアップ装置としてMT Guideを使用する場合は、Yを示します。使用しない場合は、Nを表示します。
Omniback | Y/N | バックアップ装置としてJP1/OminiBackを使用する場合は、Yを示します。使用しない場合は、Nを表示します。
NetBackup | Y/N | バックアップ装置としてNetBackupを使用する場合は、Yを示します。使用しない場合は、Nを表示します。
EXCurrentVersion | VV-RR-/X | CM Agentのバージョンを示します。
ServerExist | Y/N | Agentシステムが内部で使用するパラメータです。
HiRDBUser | 30文字以内 | 対象のAgentが使用するDBA権限ユーザ名です。
HiRDBPassword | **** | 対象のAgentが使用するDBA権限パスワードです。****で表示されます。
CMAgentManager | Y/N | Agentが管理するHiRDBユニットの種別を示します。対象ユニットがシステムマネジャの場合「Y」、それ以外の場合は「N」を表示します。
UnitAgentIp_xxxx | 10進ドット記法IPアドレス | Agentシステムが内部で使用するパラメータです。
UnitAgentPort_xxxx | 10進ドット記法IPアドレス | Agentシステムが内部で使用するパラメータです。
CommandWaitTime | 3 | Agentシステムが内部で使用するパラメータです。
AutoUnloadMaxFiles | 256 | Agentシステムが内部で使用するパラメータです。
NetBackupAgentIP | 10進ドット記法IPアドレス | バックアップ装置としてNetBackupを使用する場合に、連携を行うNetBackupAgentが使用するIPアドレスを示します。
NetBackupAgentPort | ポート番号 | バックアップ装置としてNetBackupを使用する場合に、連携を行うNetBackupAgentが使用するポート番号を示します。
NetBackupAgent | Y/N | Agentシステムが内部で使用するパラメータです。
LoginUser | 英数字30文字以内 | CM Agentが起動時に使用するユーザ名です。セットアップコマンドを実行した時のユーザ名が表示されます。(このパラメータはWindows版Agentでは使用しません。)
NetBackupClientHardware | 英数字32文字以内 | バックアップ装置としてNetBackupを使用する場合に、連携するNetBakcupのハードウェア名を示します。
NetBackupClientOS | 英数字32文字以内 | バックアップ装置としてNetBackupを使用する場合に、連携するNetBakcupのOSを示します。
LANG | 英数字32文字以内 | 管理対象のHiRDBが使用する文字コードを示します。
PDLANG | 英数字32文字以内 | 管理対象のHiRDBが使用する文字コードに対応するHiRDBのクライアント環境変数PDLANGに対応した値です。
RequestWaitTime | 60 | Agentシステムが内部で使用するパラメータです。
RequestWaitCnt | 10 | Agentシステムが内部で使用するパラメータです。
DeviceWaitTime | 60 | Agentシステムが内部で使用するパラメータです。
DeviceWaitCnt | 10 | Agentシステムが内部で使用するパラメータです。
SetupAgent | Y/N | Agentシステムが内部で使用するパラメータです。
MyHaUnitType | 0/1/2 | 管理対象のHiRDBユニットの系切り替え種別を示します。 非系切り替え構成の場合は「０」、スタンバイ型系切り替え構成の場合は「１」、スタンバイレス型 (影響分散型)の場合は「２」を表示します。
HaPairUnitEntry | Y/N | Agentシステムが内部で使用するパラメータです。
HaPrimaryUnit | Y/N | 管理対象のHiRBユニットがスタンバイ型系切り替え構成を使用している場合に現用系か予備系かを示します。 現用系の場合は「Y」、予備系の場合は「N」を表示します。
HaMyPairUnitIp | 10進ドット記法IPアドレス | 管理対象のHiRDBユニットがスタンバイ型系切り替え構成を使用している場合、自ユニットが現用系であれば、予備系のAgentのIPアドレス、自ユニットが予備系であれば、現用系のAgentのIPアドレスを示します。
HaMyMachineIp | 10進ドット記法IPアドレス | 対象のAgentが使用するIPアドレスを示します。
ScndServerIPAddress | 10進ドット記法IPアドレス | Agentシステムが内部で使用するパラメータです。
HaScndUnitIp_xxxx | 10進ドット記法IPアドレス | Agentシステムが内部で使用するパラメータです。
HaUnitType_xxxx | 0/1/2 | Agentシステムが内部で使用するパラメータです。
MyClusterType | 0/1/2/3/9 | 管理対象のユニットが系切り替え構成を使用している場合、クラスタシステムの種別を示します。 系切り替えを使用していない場合は、「０」、HAモニタを使用している場合は「１」、MSCSを使用したモニタモードの場合は「２」、MSCSとHA Tool Kitを使用したサーバモードの場合は「３」、それ以外のクラスタシステムの場合は「９」を示します。
MSCSで自マシンの使用するノード名 | 英数字32文字以内 | MSCSのクラスタノード名を示します。
UnitClusterType_xxxx | 0/1/2 | Agentシステムが内部で使用するパラメータです。
WaitTimeUnitStart | 300秒 | 管理対象のHiRDBが系切り替え構成を使用している場合、ユニットが開始するまでの最大待ち時間です。この時間を超えた場合、開始処理がタイムアウトします。
WaitTimeSystemStart | 300秒 | 管理対象のHiRDBが系切り替え構成を使用している場合、システム全体が開始するまでの最大待ち時間です。この時間を超えた場合、開始処理がタイムアウトします。 この値を変更した場合は、全てのユニットで同じ値にしておく必要があります。
HAmonitorAlias | 英数字8文字以内 | HAモニタまたは、Hitachi HA Toolkit Extensionのserver定義ファイルで当該HiRDBユニットに対応したalias名称を指定するパラメータです。
HAmonitorGroup | 英数字8文字以内 | HAモニタ server定義ファイルで該当HiRDBユニットに対応した連動系切り替えgroup名称を指定するパラメータです。対象ユニットが連動系切り替えを使用している場合にのみ設定されます。
MSCSGroup | 英数字32文字以内 | MSCSクラスタアドミニストレータ設定で当該HiRDBユニットに対応したリソースグループ名称を指定するパラメータです。


管理情報のバックアップ_リカバリ機能

管理情報のバックアップ/リカバリ

この章では、HiRDB CMで管理する情報のバックアップ/リカバリを行う方法について説明します。

l 管理情報のバックアップ/リカバリの概要

  HiRDB CMでは、登録されたHiRDBシステム構成、バックアップファイル情報等の管理情報をHiRDB CM - Serverをインストール（または、セットアップ）したディレクトリの下に格納します。そのため、ディスク障害等でHiRDB CM - Serverのインストールディレクトリにアクセスができなくなった場合、それまでの管理情報を全て失うことになります。

  管理情報のバックアップ/リカバリ機能は、このような事態から管理情報を守る目的で実行する機能です。

バックアップを取得していない場合、復元が行えない管理情報を次に示します。

· バックアップファイル情報

HiRDB CMで取得したHiRDBのバックアップファイルの情報です。バックアップ取得時間や、対象となったRDエリア名称等、HiRDBのリカバリに必要なさまざまな情報を保持しています。この情報が失われると、HiRDB CMからバックアップファイルを対象とした全ての操作（リカバリやバックアップファイルの削除など）ができなくなります。

· アンロードログファイル情報

HiRDB CMで取得したアンロードログファイルの情報です。アンロード実行時刻や、対象となったサーバ名称等、HiRDBのリカバリに必要なさまざまな情報を保持しています。この情報が失われると、HiRDB CMからアンロードログファイルを対象とした全ての操作（リカバリやアンロードログファイルの削除など）ができなくなります。

· スケジュール情報

HiRDB CMのスケジュール情報です。この情報は、この情報が失われると、現在Agentに登録されているスケジュールの解除、変更が行えなくなります。Agentに残っているスケジュールは1回実行された後、削除されます。スケジュール登録情報は、HiRDB CM - Agentにも登録されているため、HiRDB CM - Server上のスケジュール情報が失われた場合、HiRDB CM - Agentを一度アンインストールする必要があります。

  この機能は以下の２つの条件に当てはまる運用を行う場合に使用してください。下記の条件に該当しないHiRDB CMシステムでは、管理情報が失われた場合、HiRDB CM - ServerとHiRDB CM - Agentを一度アンインストールし、再度インストールすることで正常な運用に戻すことができます。

· HiRDB CMを利用して管理対象HiRDBのバックアップ/リカバリを行う運用

· HiRDB CMのスケジュール機能を使用する運用

l 管理情報のバックアップ機能

管理情報のバックアップには次の２つの運用方法があります。

· ユーザがHiRDB CMから任意のタイミングでバックアップを取得する方法

· 管理情報更新頻度に応じて自動的にバックアップを取得する方法

  また、それぞれの方法を組み合わせて運用することもできます。

ユーザが任意のタイミングでバックアップを取得する場合は、次の取得契機を考慮してください。該当の操作を行ったにもかかわらず、管理情報のバックアップを取得しなかった場合は、リカバリを行った際にHiRDB CMの運用に必要な情報が失われてしまう可能性があります。

· 管理情報のバックアップを必ず行う必要がある運用

- 管理対象のHiRDBの新規登録

- 登録済みのHiRDB CM Agentのバージョンアップ後の定義情報更新後

- 登録済みのHiRDBの構成変更後の定義情報更新後

· 管理情報の取得を推奨する運用

- カタログ　スケジュールの登録、削除、変更

- 自動データメンテナンスの登録、削除

- 登録済みHiRDBのバックアップ、システムログのアンロード実行

HiRDB CMが管理情報更新頻度に応じて自動的にバックアップを取得する場合は、あらかじめユーザが自動バックアップを使用するように設定する必要があります。自動バックアップではHiRDB CMの管理情報更新の更新回数がユーザの指定した更新回数に達した時点でバックアップを取得します。指定できる回数は１万回～100万回です。更新回数に、１万回を指定した場合、HiRDBリソースの追加、変更、削除操作（バックアップ、RDエリアの追加、表の追加など）を約20回行った間隔で管理情報のバックアップが実行されます。ただし、自動バックアップでは更新回数が指定回数に達しても、前回のバックアップから12時間以上経過していないとバックアップを取得しません。

また、自動バックアップではユーザの実行した操作を意識していません。運用によっては、リカバリを行った際に一部の管理情報が失われる可能性もあります。管理対象のHiRDBの新規登録など、管理情報のバックアップを必要とする操作を行った場合には、手動でのバックアップを実行することをお勧めします。

管理情報のバックアップ操作、または、バックアップ取得先などの設定は、[管理情報のバックアップ/リカバリ]画面から行うことができます。HiRDB CMをインストールした直後は次のような設定になっています。必要に応じて変更してください。

バックアップ情報格納先ディレクトリ ： ＜CMSインストールディレクトリ＞\cms_backup_dir

自動バックアップ設定 ： 自動バックアップを行う

自動バックアップのための更新回数 ： 更新1万回

l 管理情報のリカバリ機能

管理情報のリカバリを行う場合は、バックアップ情報が次に示す条件をみたしている必要があります。

· バックアップ情報が同一バージョン、同一リビジョンで取得したバックアップ情報である

· バックアップ情報を取得したHiRDB CM - Serverと同一のインストールパスである

· バックアップ情報を取得したHiRDB CM - Serverと同一の標準IPアドレス、ポート番号を使用している

· バックアップ情報を取得したHiRDB CM - Serverと同じ規模でインストールされている

管理情報のリカバリを行う前には、次のことを行う必要があります。

· 管理情報の自動更新を停止する（管理情報更新間隔を0に設定する）

· 登録されている自動メンテナンス機能を停止する

· 複数のマシンからHiRDB CM - Serverに接続してる場合、管理情報のリカバリを実行するHiRDB CM - Console以外のHiRDB CM - Consoleを終了する

· HiRDB CM - WebConsoleを使用している場合、Webアプリケーションサーバを停止しておく

リカバリを実行したときに、HiRDB CMで他の操作が行われていると、リカバリは実行されません。

リカバリ実行中は、HiRDB CMに対する他の操作を行うことができません。

l 管理情報のバックアップ/リカバリの使用例

管理情報のバックアップ/リカバリ機能を使用した運用を行っている場合のHiRDB CM - Server障害時の復旧手順について、使用例を紹介します。

<手順>

1. ディスク障害を取り除き、HiRDB CM - Serverをアンインストールします。

2. HiRDB CM - Serverをインストールします。

3. 管理情報のリカバリを行います。

<条件>

· ディスク障害前のバックアップ情報が存在します。

· バックアップ情報に、バックアップファイル情報、アンロードログファイル情報、スケジュール情報の欠損はありません。

· 管理対象のHiRDBは全て正常で起動しています。

バックアップ情報が残っていない場合は、全てのHiRDB CM - AgentとHiRDB CM - Severをアンインストールしてから再度インストール、セットアップを行う必要があります。

1. ディスク障害を取り除き、HiRDB CM - Serverをアンインストールします。

  ディスクの障害を取り除き、HiRDB CM - Serverをアンインストールします。マシンの復旧のためOSを再インストールを行ったり、別マシンを用意したりした場合はこの操作を行う必要はありません。ただし、別マシンを用意する場合、使用する標準IPアドレスは同じものにしておく必要があります。

§ ディスクの障害を取り除きます。

§ HiRDB CM Serverのアンインストールを行います。

    HiRDB　CM　- Serverのアンインストールが行えない場合は、readmeを参考にして不正に残った情報を全て削除してください。

2. HiRBB CM - Serverをインストールします。

  同一バージョン、同一リビジョンのHiRDB CM - Serverを再度インストールします。

§ HiRDB CM - Serverを新規インストールします。

    インストール時に指定する情報は、復旧前のHiRDB CM - Serverと同じものを指定してください。

3. 管理情報のリカバリを行います。

  管理情報のリカバリを行います。

§ マシンの再起動後にHiRDB CM - Consoleを接続します。

§ [オプション] > [管理情報更新間隔の変更]をクリックし、管理情報更新間隔の変更画面を起動します。

§ 管理情報更新間隔の変更画面で、全てのカテゴリに0を設定し、OKボタンをクリックします。（管理情報の自動更新機能を停止ます。）

§ [オプション] > [管理情報のバックアップ/リカバリ]をクリックし、管理情報のバックアップ/リカバリ画面を起動します。

§ バックアップ格納先ディレクトリにバックアップ情報を取得したディレクトリを指定して、OKボタンをクリックします。

§ 管理情報のリカバリ確認画面が表示されます。

§ 管理情報のリカバリ確認画面で、バックアップ情報取得時刻を確認して、OKボタンをおします。

§ 管理情報のリカバリ処理中画面が表示されます。

§ 管理情報のリカバリが成功すると、結果が表示されます。

§ [オプション] > [管理情報の更新]ボタンをクリック、管理情報の更新画面を起動します。

§ 管理情報の更新画面で、全てのHiRDBシステムを選択し、定義情報の更新を行います。


IPアドレス変更方法

HiRDB CMで使用するIPアドレスを変更する方法

HiRDB CMで使用するIPアドレスを構築後に変更する方法について説明します。ここで示す方法は、管理対象HiRDBが登録された後に変更する手順になります。未登録(管理HiRDBの登録に成功していない)の場合は、Serverをアンインストール、または、Agentをアンセットアップしてから再度セットアップしてください。

以下に各IPアドレスを変更する方法を記載します。

· HiRDB CM ConsoleのIPアドレスを変更する。

· HiRDB CM ServerのIPアドレスを変更する。

- Console-Server間の通信で使用するIPアドレス

- Server-Agent間の通信で使用するIPアドレス

· HiRDB CM AgentのIPアドレスを変更する。

- Server-Agent間の通信で使用するIPアドレス

- マネージャAgent-非マネージャyAgent間の通信で使用するIPアドレス

l HiRDB CM ConsoleのIPアドレスを変更する

Consoleが使用するIPアドレスは、Consoleマシン上の標準ホスト（コンピュータ名)に対応するIPアドレスになります。Consoleが使用するIPアドレスを変更しても設定を変更する必要はありません。

l HiRDB CM ServerのIPアドレスを変更する

<Console - Server間の通信で使用するIPアドレス>

Console-Server間で使用するIPアドレスは、Console起動時に[ログイン]画面で指定したServerマシンのIPアドレスになります。HiRDB CMで設定を行う必要はありません。

<Server - Agent間の通信で使用するIPアドレス>

Serverのバージョンが08-01以降の場合：

Serverが使用するIPアドレスは、インストール時に指定した情報をServer上で管理して使用します。上書きインストールを行うことで、この値を変更することができます。また、Agent上では、管理元のServerのIPアドレスを保持しています。その設定も変更する必要があります。

次の手順に従ってIPアドレスの変更を行います。

1. ServerのWindowsサービスを停止します。

2. Serverの上書きインストールを行います。

ここで新しいIPアドレスを指定します。

3. 管理対象のHiRDBマシンにログインします。

(パラレルサーバの場合は、マネージャノードのマシンにログインします。）

4. 環境変数PDDIRに対象HiRDBのセットアップディレクトリを設定します。

5. 以下のコマンドを実行し、現在の設定を確認します。

$PDDIR/CMAgent/bin/cmrconf -l ServerIPAddress

6. 以下のコマンドを実行し、設定値の変更を行います。

$PDDIR/CMAgent/bin/cmrconf -c ServerIPAddress ServerのIPアドレス

7. 以下のコマンドを実行し、変更結果を確認します。

$PDDIR/CMAgent/bin/cmrconf -l ServerIPAddress

マネージャノードが系切り替えを使用している場合は、3-７の操作を現用/予備系の双方に対して行ってください。

8. 複数のHiRDBを管理している場合、4.5.6の操作をすべてのHiRDBに対して行います。

Serverのバージョンが08-00以前の場合：

Serverが使用するIPアドレスは、Serverがインストールされているマシンの標準ホスト（コンピュータ名）に対応するIPアドレスを使用します。

また、Agent上では、管理元のServerのIPアドレスを保持しています。その設定も変更する必要があります。

次の手順に従ってIPアドレスの変更を行います。

1. ServerのWindowsサービスを停止します。

2. Serverがインストールされているマシンの標準ホストに対応するIPアドレスを変更します。

3. 管理対象のHiRDBマシンにログインします。

(パラレルサーバの場合は、マネージャノードのマシンにログインします。）

4. 環境変数PDDIRに対象HiRDBのセットアップディレクトリを設定します。

5. 以下のコマンドを実行し、現在の設定を確認します。

$PDDIR/CMAgent/bin/cmrconf -l ServerIPAddress

6. 以下のコマンドを実行し、設定値の変更を行います。

$PDDIR/CMAgent/bin/cmrconf -c ServerIPAddress ServerのIPアドレス

7. 以下のコマンドを実行し、変更結果を確認します。

$PDDIR/CMAgent/bin/cmrconf -l ServerIPAddress

マネージャノードが系切り替えを使用している場合は、3-７の操作を現用/予備系の双方に対して行ってください。

8. 複数のHiRDBを管理している場合、4.5.6の操作をすべてのHiRDBに対して行います。

l HiRDB CM AgentのIPアドレスを変更する

<Server-Agent間で使用するIPアドレス>

Agentが使用するIPアドレスは、ServerとAgent上で管理しています。 AgentのIPアドレスを変更するとServerは、対象のHiRDBシステムを別のHiRDBとして管理するため、既に登録されたAgent(管理HiRDB情報）を一旦解除してから再登録する必要があります。また、対象のHiRDBがパラレルサーバの場合、同じIPアドレスをマネージャユニット-非マネージャユニット間で一部使用しています。そのため、非マネージャユニットにインストールされたAgentでも操作が必要になります。

系切り替えを使用していない場合：

次の手順に従ってIPアドレスの変更を行います。

1. 管理情報の解除を行います。

Console画面の[管理HiRDB] > [管理HiRDBの解除]画面から対象のHiRDBを解除します。

2. 管理対象のHiRDBマシンにログインします。

(パラレルサーバの場合は、マネージャノードのマシンにログインします。）

3. 環境変数PDDIRに対象HiRDBのセットアップディレクトリを設定します。

4. 以下のコマンドを実行し、現在の設定を確認します。

$PDDIR/CMAgent/bin/cmrconf -l ConnectIPAddress

$PDDIR/CMAgent/bin/cmrconf -l HaMyMachineIp

5. 以下のコマンドを実行し、設定値の変更を行います。

$PDDIR/CMAgent/bin/cmrconf -c ConnectIPAddress 変更後のIPアドレス

$PDDIR/CMAgent/bin/cmrconf -c HaMyMachineIp 変更後のIPアドレス

6. 以下のコマンドを実行し、変更結果を確認します。

$PDDIR/CMAgent/bin/cmrconf -l ConnectIPAddress

$PDDIR/CMAgent/bin/cmrconf -l HaMyMachineIp

7. 管理対象HiRDBがパラレルサーバの場合、非マネージャノードにログインします。

8. 環境変数PDDIRに対象HiRDBのセットアップディレクトリを設定します。

9. 以下のコマンドを実行し、現在の設定を確認します。

$PDDIR/CMAgent/bin/cmrconf -l ServerIPAddress

10.以下のコマンドを実行し、設定値の変更を行います。

$PDDIR/CMAgent/bin/cmrconf -c ServerIPAddress 変更後のIPアドレス

11.以下のコマンドを実行し、変更結果を確認します。

$PDDIR/CMAgent/bin/cmrconf -l ServerIPAddress

12.すべての非マネージャノードに対して7,8,9,10,11の操作を行います。

13.対象のHiRDBの情報を再登録します。

Console画面の[管理HiRDB] > [管理HiRDBの新規登録]画面から対象のHiRDBを登録します。

系切り替えを使用している場合：

管理対象HiRDB(パラレルサーバの場合、マネージャノード) が系切り替えを使用している場合、Server-Agent間で使用するIPアドレスは、次の3つのいずれかになります。

· 対象ユニットが稼動している間、稼動している系で有効となるHiRDB CM用のサービスIPアドレス

· 現用系マシン上で固定となる静的IPアドレス

· 予備系マシン上で固定となる静的IPアドレス

各IPアドレスについて手順が異なります。注意してください。

[HiRDB CM用のサービスIPアドレスの変更]

1. 管理情報の解除を行います。

Console画面の[管理HiRDB] > [管理HiRDBの解除]画面から対象のHiRDBを解除します。

2. 管理対象のHiRDBマシンにログインします。

(パラレルサーバの場合は、マネージャノードのマシンにログインします。）

3. 環境変数PDDIRに対象HiRDBのセットアップディレクトリを設定します。

4. 以下のコマンドを実行し、現在の設定を確認します。

$PDDIR/CMAgent/bin/cmrconf -l ConnectIPAddress

5. 以下のコマンドを実行し、設定値の変更を行います。

$PDDIR/CMAgent/bin/cmrconf -c ConnectIPAddress 変更後のIPアドレス

6. 以下のコマンドを実行し、変更結果を確認します。

$PDDIR/CMAgent/bin/cmrconf -l ConnectIPAddress

7. 対象のHiRDBの情報を再登録します。

Console画面の[管理HiRDB] > [管理HiRDBの新規登録]画面から対象のHiRDBを登録します。

[現用系マシン上で固定となる静的IPアドレスの変更]

1. 管理情報の解除を行います。

Console画面の[管理HiRDB] > [管理HiRDBの解除]画面から対象のHiRDBを解除します。

2. 管理対象のHiRDBマシンの現用系ユニットにログインします。

(パラレルサーバの場合は、マネージャノードのマシンにログインします。）

3. 環境変数PDDIRに対象HiRDBのセットアップディレクトリを設定します。

4. 以下のコマンドを実行し、現在の設定を確認します。

$PDDIR/CMAgent/bin/cmrconf -l HaMyMachineIp

5. 以下のコマンドを実行し、設定値の変更を行います。

$PDDIR/CMAgent/bin/cmrconf -c HaMyMachineIp 変更後のIPアドレス

6. 以下のコマンドを実行し、変更結果を確認します。

$PDDIR/CMAgent/bin/cmrconf -l HaMyMachineIp

7. 管理対象のHiRDBマシンの予備系ユニットにログインします。

(パラレルサーバの場合は、マネージャノードのマシンにログインします。）

8. 環境変数PDDIRに対象HiRDBのセットアップディレクトリを設定します。

9. 以下のコマンドを実行し、現在の設定を確認します。

$PDDIR/CMAgent/bin/cmrconf -l HaMyPairUnitIp

10. 以下のコマンドを実行し、設定値の変更を行います。

$PDDIR/CMAgent/bin/cmrconf -c HaMyPairUnitIp 変更後のIPアドレス

11. 以下のコマンドを実行し、変更結果を確認します。

$PDDIR/CMAgent/bin/cmrconf -l HaMyPairUnitIp

12. 管理対象HiRDBがパラレルサーバの場合、非マネージャノードにログインします。

13. 環境変数PDDIRに対象HiRDBのセットアップディレクトリを設定します。

14. 以下のコマンドを実行し、現在の設定を確認します。

$PDDIR/CMAgent/bin/cmrconf -l ServerIPAddress

15.以下のコマンドを実行し、設定値の変更を行います。

$PDDIR/CMAgent/bin/cmrconf -c ServerIPAddress 変更後のIPアドレス

16.以下のコマンドを実行し、変更結果を確認します。

$PDDIR/CMAgent/bin/cmrconf -l ServerIPAddress

17.すべての非マネージャノードに対して12-16の操作を行います。

非マネージャがスタンバイ型系切り替えを使用している場合は、現用系/予備系の双方のマシンで設定値の変更を行ってください。

18. 対象のHiRDBの情報を再登録します。

Console画面の[管理HiRDB] > [管理HiRDBの新規登録]画面から対象のHiRDBを登録します。

[予備系マシン上で固定となる静的IPアドレスの変更]

1. 管理情報の解除を行います。

Console画面の[管理HiRDB] > [管理HiRDBの解除]画面から対象のHiRDBを解除します。

2. 管理対象のHiRDBマシンの予備系ユニットにログインします。

(パラレルサーバの場合は、マネージャノードのマシンにログインします。）

3. 環境変数PDDIRに対象HiRDBのセットアップディレクトリを設定します。

4. 以下のコマンドを実行し、現在の設定を確認します。

$PDDIR/CMAgent/bin/cmrconf -l HaMyMachineIp

5. 以下のコマンドを実行し、設定値の変更を行います。

$PDDIR/CMAgent/bin/cmrconf -c HaMyMachineIp 変更後のIPアドレス

6. 以下のコマンドを実行し、変更結果を確認します。

$PDDIR/CMAgent/bin/cmrconf -l HaMyMachineIp

7. 管理対象のHiRDBマシンの現用系ユニットにログインします。

(パラレルサーバの場合は、マネージャノードのマシンにログインします。）

8. 環境変数PDDIRに対象HiRDBのセットアップディレクトリを設定します。

9. 以下のコマンドを実行し、現在の設定を確認します。

$PDDIR/CMAgent/bin/cmrconf -l HaMyPairUnitIp

10. 以下のコマンドを実行し、設定値の変更を行います。

$PDDIR/CMAgent/bin/cmrconf -c HaMyPairUnitIp 変更後のIPアドレス

11. 以下のコマンドを実行し、変更結果を確認します。

$PDDIR/CMAgent/bin/cmrconf -l HaMyPairUnitIp

12. 管理対象HiRDBがパラレルサーバの場合、非マネージャノードにログインします。

13. 環境変数PDDIRに対象HiRDBのセットアップディレクトリを設定します。

14. 以下のコマンドを実行し、現在の設定を確認します。

$PDDIR/CMAgent/bin/cmrconf -l ScndServerIPAddress

15.以下のコマンドを実行し、設定値の変更を行います。

$PDDIR/CMAgent/bin/cmrconf -c ScndServerIPAddress変更後のIPアドレス

16.以下のコマンドを実行し、変更結果を確認します。

$PDDIR/CMAgent/bin/cmrconf -l ScndServerIPAddress

17.すべての非マネージャノードに対して12-16の操作を行います。

非マネージャがスタンバイ型系切り替えを使用している場合は、現用系/予備系の双方のマシンで設定値の変更を行ってください。

18. 対象のHiRDBの情報を再登録します。

Console画面の[管理HiRDB] > [管理HiRDBの新規登録]画面から対象のHiRDBを登録します。

<マネージャノード-非マネージャノード間で使用するIPアドレス>

HiRDBパラレルサーバの場合、マネージャノードと非マネージャノード上にインストールされたAgentの間で通信を行います。

この通信用のIPアドレスは、それぞれのAgent上で管理されています。

対象ユニットがスタンバイ型系切り替えを使用していない場合：

1. 管理対象のHiRDBマシンの非マネージャノードマシンにログインします。

2. 環境変数PDDIRに対象HiRDBのセットアップディレクトリを設定します。

3. 以下のコマンドを実行し、現在の設定を確認します。

$PDDIR/CMAgent/bin/cmrconf -l ConnectIPAddress

$PDDIR/CMAgent/bin/cmrconf -l HaMyMachineIp

4. 以下のコマンドを実行し、設定値の変更を行います。

$PDDIR/CMAgent/bin/cmrconf -c ConnectIPAddress 変更後のIPアドレス

$PDDIR/CMAgent/bin/cmrconf -c HaMyMachineIp 変更後のIPアドレス

5. 以下のコマンドを実行し、変更結果を確認します。

$PDDIR/CMAgent/bin/cmrconf -l ConnectIPAddress

$PDDIR/CMAgent/bin/cmrconf -l HaMyMachineIp

6. 管理対象のHiRDBマシンのマネージャノードマシンにログインします。

7. 環境変数PDDIRに対象HiRDBのセットアップディレクトリを設定します。

8. 以下のコマンドを実行し、現在の設定を確認します。

$PDDIR/CMAgent/bin/cmrconf -l UnitAgentIp_{対象のユニット名}

9. 以下のコマンドを実行し、設定値の変更を行います。

$PDDIR/CMAgent/bin/cmrconf -c UnitAgentIp 対象のユニット名 変更後のIPアドレス

10. 以下のコマンドを実行し、変更結果を確認します。

$PDDIR/CMAgent/bin/cmrconf -l UnitAgentIp_{対象のユニット名}

マネージャノードが系切り替えを使用している場合は、6-10の操作を現用/予備系の双方に対して行ってください。

11. 管理情報の更新を行います。

Console画面の[オプション] > [管理情報の更新]画面から対象のHiRDBシステムの定義情報を更新します。

対象ユニットがスタンバイ型系切り替えを使用している場合：

スタンバイ型系切り替えを使用ている場合は、マネージャノードと対象ユニットの現用系ノード間で使用するIPアドレスとマネージャノードと対象ユニットの予備系ノード間で使用するIPアドレスを別々に変更する必要があります。

次の手順で変更を行います。

[マネージャノードと対象ユニットの現用系ノード間で使用するIPアドレスの変更]

1. 管理対象のHiRDBマシンの非マネージャノードマシンの現用系ノードにログインします。

2. 環境変数PDDIRに対象HiRDBのセットアップディレクトリを設定します。

3. 以下のコマンドを実行し、現在の設定を確認します。

$PDDIR/CMAgent/bin/cmrconf -l ConnectIPAddress

$PDDIR/CMAgent/bin/cmrconf -l HaMyMachineIp

4. 以下のコマンドを実行し、設定値の変更を行います。

$PDDIR/CMAgent/bin/cmrconf -c ConnectIPAddress 変更後のIPアドレス

$PDDIR/CMAgent/bin/cmrconf -c HaMyMachineIp 変更後のIPアドレス

5. 以下のコマンドを実行し、変更結果を確認します。

$PDDIR/CMAgent/bin/cmrconf -l ConnectIPAddress

$PDDIR/CMAgent/bin/cmrconf -l HaMyMachineIp

6. 管理対象のHiRDBマシンの非マネージャノードマシンの予備系ノードにログインします。

7. 環境変数PDDIRに対象HiRDBのセットアップディレクトリを設定します。

8. 以下のコマンドを実行し、現在の設定を確認します。

$PDDIR/CMAgent/bin/cmrconf -l HaMyPairUnitIp

9. 以下のコマンドを実行し、設定値の変更を行います。

$PDDIR/CMAgent/bin/cmrconf -c HaMyPairUnitIp 変更後のIPアドレス

10. 以下のコマンドを実行し、変更結果を確認します。

$PDDIR/CMAgent/bin/cmrconf -l HaMyPairUnitIp

11. 管理対象のHiRDBマシンのマネージャノードマシンにログインします。

12. 環境変数PDDIRに対象HiRDBのセットアップディレクトリを設定します。

13. 以下のコマンドを実行し、現在の設定を確認します。

$PDDIR/CMAgent/bin/cmrconf -l UnitAgentIp_{対象のユニット名}

14. 以下のコマンドを実行し、設定値の変更を行います。

$PDDIR/CMAgent/bin/cmrconf -c UnitAgentIp 対象のユニット名 変更後のIPアドレス

15. 以下のコマンドを実行し、変更結果を確認します。

$PDDIR/CMAgent/bin/cmrconf -l UnitAgentIp_{対象のユニット名}

マネージャノードが系切り替えを使用している場合は、11-15の操作を現用/予備系の双方に対して行ってください。

16. 管理情報の更新を行います。

Console画面の[オプション] > [管理情報の更新]画面から対象のHiRDBシステムの定義情報を更新します。

[マネージャノードと対象ユニットの予備系ノード間で使用するIPアドレスの変更]

1. 管理対象のHiRDBマシンの非マネージャノードマシンの予備系ノードにログインします。

2. 環境変数PDDIRに対象HiRDBのセットアップディレクトリを設定します。

3. 以下のコマンドを実行し、現在の設定を確認します。

$PDDIR/CMAgent/bin/cmrconf -l ConnectIPAddress

$PDDIR/CMAgent/bin/cmrconf -l HaMyMachineIp

4. 以下のコマンドを実行し、設定値の変更を行います。

$PDDIR/CMAgent/bin/cmrconf -c ConnectIPAddress 変更後のIPアドレス

$PDDIR/CMAgent/bin/cmrconf -c HaMyMachineIp 変更後のIPアドレス

5. 以下のコマンドを実行し、変更結果を確認します。

$PDDIR/CMAgent/bin/cmrconf -l ConnectIPAddress

$PDDIR/CMAgent/bin/cmrconf -l HaMyMachineIp

6. 管理対象のHiRDBマシンの非マネージャノードマシンの現用系ノードにログインします。

7. 環境変数PDDIRに対象HiRDBのセットアップディレクトリを設定します。

8. 以下のコマンドを実行し、現在の設定を確認します。

$PDDIR/CMAgent/bin/cmrconf -l HaMyPairUnitIp

9. 以下のコマンドを実行し、設定値の変更を行います。

$PDDIR/CMAgent/bin/cmrconf -c HaMyPairUnitIp 変更後のIPアドレス

10. 以下のコマンドを実行し、変更結果を確認します。

$PDDIR/CMAgent/bin/cmrconf -l HaMyPairUnitIp

11. 管理対象のHiRDBマシンのマネージャノードマシンにログインします。

12. 環境変数PDDIRに対象HiRDBのセットアップディレクトリを設定します。

13. 以下のコマンドを実行し、現在の設定を確認します。

$PDDIR/CMAgent/bin/cmrconf -l HaScndUnitIp_{対象のユニット名}

14. 以下のコマンドを実行し、設定値の変更を行います。

$PDDIR/CMAgent/bin/cmrconf -c HaScndUnitIp対象のユニット名 変更後のIPアドレス

15. 以下のコマンドを実行し、変更結果を確認します。

$PDDIR/CMAgent/bin/cmrconf -l HaScndUnitIp_{対象のユニット名}

マネージャノードが系切り替えを使用している場合は、11-15の操作を現用/予備系の双方に対して行ってください。

16. 管理情報の更新を行います。

Console画面の[オプション] > [管理情報の更新]画面から対象のHiRDBシステムの定義情報を更新します。


用語集

目次

用語集

[ A ] [ H ] [I] [ N ] [ R ]

[ア行] [カ行] [サ行] [タ行] [ハ行] [マ行] [ヤ行] [ラ行] [ワ行]

[ A ]

Agent自動探索機能

[ H ]

HiRDB管理者

HiRDBファイル

HiRDBファイルシステム領域

[ I ]

IPアドレスを引き継ぐ構成

[ N ]

NetBackup

NetBackup連携機能

[ R ]

RDエリア

Rocket Punch機能

[ア行]

アンロードログファイル

インナレプリカ

インナレプリカグループ

ウィザード

オリジナルRDエリア

影響分散スタンバイレス系切り替え

[カ行]

カスタマイズ

カタログ

カレントRDエリア

高速系切り替え機能

[サ行]

サーバモード

サービスIPアドレス

サブRDエリア

差分バックアップ機能

システムマネジャ

システムログファイル

シンクポイントダンプファイル

シングルサーバ

自動ログアンロード機能

スタンバイレス型系切り替え

スタンバイ型系切り替え

セグメント(ネットワーク)

[タ行]

ディクショナリサーバ

データディクショナリLOB用RDエリア

データディクショナリ用RDエリア

データディレクトリ用RDエリア

[ハ行]

バックエンドサーバ

ファイル最大保持数

フロントエンドサーバ

[マ行]

マスタディレクトリ用RDエリア

モニタモード

[ヤ行]

ユーザLOB用RDエリア

ユーザ用RDエリア

[ラ行]

リスト用RDエリア

レジストリLOB用RDエリア

レジストリ用RDエリア

レプリカRDエリア

[ワ行]

ワイルドカード


HiRDB Control Manager - Server

インストール/アンインストール方法

HiRDB Control Manager - Server

ここではHiRDB Control Manager - Serverのインストール/アンインストール方法をWindowsとUNIXに分けて説明します。

HiRDB Control Manager - ServerのOSに応じて、以下のリンクを参照してください。

§ Windows

Windows/Windows(IPF)

§ UNIX

現在、UNIX上で動作するHiRDB CM - Serverは、ありません。


HiRDB Control Manager - Server_Unix

インストール/アンインストール方法

UNIX HiRDB Control Manager - Server

ここでは、UNIX版　HiRDB Control Manager - Serverのインストール/アンインストール方法を説明します。

現在、UNIX上で動作する HiRDB Control Manager - Serverはありません。

§ インストール

§ アンインストール

l インストール

<前提条件>

· Serverでは2つの連続したポート番号を使用します。

他アプリケーションと競合しないように、インストールする前にはポート番号を確認してください。なお、デフォルトでは<<20291～20292>>の番号を使用します。

· インストールを行う前に次に示すOSのカーネルパラメータの値が設定されていることを確認してください。

カーネルパラメータ |  |  | 値
HP-UX | Linux | Solaris
maxdsiz | - | - | 52MB
maxssiz | - | - | 80MB
maxfiles_lim | NR_OPEN | rlim_fd_max | 1344
nfile | NR_FILE | - | 1600
- | threads-max | - | 576
nflocks | - | - | 645
maxuprc | - | maxuprc | 1024
nproc | nproc | max_nprocs | 1000
- | - | maxusers | 128
msgmni | MSGMNI | msgsys:msginfo_msgmni | 64
msgtql | - | msgsys:msginfo_msgtql | 128
semmni | SEMMNI | semsys:seminfo_semmni | 1024
semmns | SEMMNS | semsys:seminfo_semmns | 7200
semmnu | - | semsys:seminfo_semmnu | 1024
semume | - | semsys:seminfo_semume | 512
- | - | semsys:seminfo_semmsl | 128
- | - | semsys:seminfo_semopm | 128
- | - | semsys:seminfo_semmap | 1024
shmmax | SHMMAX | shmsys:shminfo_shmmax | 200MB
shmmni | SHMMNI | shmsys:shminfo_shmmni | 2000
shmseg | SHMSEG | shmsys:shminfo_shmseg | 240

l アンインストール

<前提条件>

· アンインストールを行うServerで管理しているHiRDBシステムが存在する場合は、「管理HiRDBの解除」コマンドで、Serverからの管理を解除してください。

· Serverのサービスが停止していなければなりません。[サービス]から「HiRDB Control Manager - Server」の状態を確認し、開始している場合は停止を行ってください。

· CM - Web Consoleを使用している場合、TomcatまたはCosminexusからCM - Web Consoleの登録を解除して下さい。

<注意事項>

· Serverアンインストール後はインストールディレクトリにディレクトリやファイルが残る場合があります。

このような場合は手動で該当するディレクトリやファイルを削除してください。同じディレクトリへ再度Serverをインストールする場合、ディレクトリやファイルが残っているとインストールが実行できません。

· Serverのアンインストールを行うと、管理している全てのカタログ及びスケジュール情報が削除されます。それらの情報は、再利用することはできません。


HiRDB Control Manager - Agent

インストール/アンインストール方法

HiRDB Control Manager - Agent

ここでは、HiRDB Control Manager - Agentのインストール/アンインストール方法を説明します。

HiRDB Control Manager - AgentにはHiRDBの基本的な機能をサポートしている通常Agentの他に、HiRDBの機能ごとにサポートしているアプリケーションが存在します。したがって、使用する機能に対応するAgentをインストールする必要があります。

- 通常Agent

「通常Agent」は管理するHiRDBシステムを搭載しているサーバマシンにインストールし、HiRDBの操作を可能にするアプリケーションです。

- NetBackup用Agent

「NetBackup用Agent」はNetBackup連携機能を使用する場合に、NetBackupマスタサーバとして稼動するマシンにインストールし、NetBackupの操作を可能にするアプリケーションです。

「通常Agent」をインストールする前にインストールを行います。

NetBackup連携機能を使用しない場合は、インストールは不要です。

- XDM/RD用Agent

「XDM/RD用Agent」はXDM/RD情報を管理する場合に、Windowsマシンへインストールし、XDM/RD情報の参照を可能にするアプリケーションです。

本AgentはHiRDB Control Manager - Agentバージョン03-00以前のHiRDB Control Manager - Agentに同梱されています。

HiRDB Control Manager - Agentバージョン04-00には、同梱されていません。

また、HiRDB Control Manager - Agentバージョン08-00以降のHiRDB Control Manager - Agentには、HiRDB Control Manager - Agentバージョン03-00-/Bの「XDM/RD用Agent」が同梱されています。

XDM/RD情報を管理しない場合は、インストールは不要です。


HiRDB Control Manager - 通常Agent

インストール/アンインストール方法

HiRDB Control Manager - 通常Agent

ここではHiRDB Control Manager - 通常Agentのインストール/アンインストール方法をWindowsとUNIXに分けて説明します。

「通常Agent」は管理するHiRDBシステムの各ユニットが稼働するマシンにインストールして、HiRDBシステムの情報収集や、操作を行うアプリケーションです。

「通常Agent」を、HiRDBクライアントからのコマンド実行機能のみで使用する場合、CM ServerおよびCM Consoleをインストールする必要はありません。

HiRDB Control Manager - AgentのOSに応じて、以下のリンクを参照してください。

§ Windows

Windows/Windows(IPF)

§ UNIX

HP-UX/HP-UX(IPF)/Linux/Linux(IPF)/AIX/Solaris


HiRDB Control Manager - 通常Agent(UNIX)

インストール/アンインストール方法

UNIX HiRDB Control Manager - 通常Agent

UNIX HiRDB Control Manager - 通常Agentのインストール/アンインストール方法を説明します。

UNIX版のHiRDB Control Manager - 通常Agentでは、インストール後にセットアップコマンドを実行することにより、Agentの設定が完了します。インストールとあわせて、セットアップコマンドについても以下で説明します。

Agentのインストールおよびセットアップ方法を、管理するHiRDBサーバ種別ごとに次で説明します。

§ インストール/セットアップ

§ アンセットアップ/アンインストール

l インストール/セットアップ

HiRDB Control Manager - Agentは、管理するHiRDBシステムを搭載している全てのサーバマシンにインストールする必要があります。

2ユニット以上で構成されるHiRDB/パラレルサーバの場合は、マネジャシステム (MGR) 及び 非マネジャシステムにHiRDB Control Manager - Agentをインストールしてください。

Agentのインストール方法を、管理するHiRDBサーバ種別ごとに次で説明します。

§ HiRDB/シングルサーバ及び1ユニット構成のHiRDB/パラレルサーバへのインストール/セットアップ

§ 2ユニット以上で構成されるHiRDB/パラレルサーバへのインストール/セットアップ

§ 系切り替え構成を含むHiRDBへのインストール/セットアップ

セットアップが終了すると、インターネットサービスデーモンにAgentを起動するためのサービスが登録されます。

これにより、Agentはサーバマシンが起動している間は常時稼動します。

<注意事項>

· HiRDBの構成を変更する場合は、すべてのユニット上のAgentをアンインストールした後に、再度インストールを実行してください。上書きインストールによる構成の変更はできません。

構成変更例：
   - HiRDBシステムを構成するユニットやサーバを追加/削除した場合

- 系切り替えを使用しない構成でセットアップしているAgentを、系切り替えを使用する構成に変更する場合

- 系切り替えを使用する構成でセットアップしているAgentを、系切り替えを使用しない構成に変更する場合

- 系切り替えを使用する構成でセットアップしているAgentの系切り替え種別(サーバ/モニタモード等)を変更する場合

HiRDB/シングルサーバ及び1ユニット構成のHiRDB/パラレルサーバへのインストール/セットアップ

<前提条件>

· Agentでは1つのポート番号を使用します。なお、NetBackup用Agentを同じサーバマシンにインストールする場合は、2つのポート番号を用意してください。

他アプリケーションと競合しないように、インストールする前にはポート番号を確認してください。デフォルトでは<<20293>>を使用します。

· Agentのインストールおよびセットアップはスーパーユーザ （id：root） のみ行うことができます。実行時にはスーパーユーザになる必要があります。

· NetBackup連携機能を使用する場合は、通常Agentの前にNetBackup用Agentをインストールしてください。

1. Agentのインストール。

各OSのソフトウェア添付資料に従い、該当マシンへAgentを組み込んでください。

既に最新のAgentがインストールされている場合には、この作業は必要ありません。2のセットアップコマンドを実行してください。

2. セットアップコマンドの実行。

スーパーユーザで次のコマンドを実行します。

/opt/hirdbCMA/bin/cmasetup HiRDB運用ディレクトリ

· HiRDB運用ディレクトリ

管理対象とするHiRDBユニットのHiRDB運用ディレクトリを絶対パスで指定してください。

本パラメータは必須です。

コマンドを実行すると、対話形式により以下のパラメータの入力を求められます。

· Agentの種別

ここでは、「Y」を選択します。

HP-UX(IPF)、Linux(IPF)、および、Solaris10ではAgentの種別選択はありません。

· Agentが使用するIPアドレス

このAgentが、Serverからの要求を受け付けるために使用するIPアドレスを10進ドット記法で指定してください。

Serverが稼動するマシン上から通信できるIPアドレスを指定する必要があります。

本パラメータは必須です。

· Agentが使用するポート番号

このAgentが、Serverからの要求を受け付けるために使用するポート番号を指定してください。

設定範囲は((5001～65535))です。当該マシン内で使用されていないポート番号を指定する必要があります。

本パラメータは必須です。ポート番号を入力しないで[Enter]キーを押した場合は、<<20293>>が仮定されます。

· inetdデーモンのサービス名

Agentは、Serverからの要求を受け付けるためにinetdデーモンを使用します。inetdがこのAgentを識別するためのサービス名称を指定してください。

このサービス名称は、/etc/servicesファイルに既に記述されているサービス名称と重複しない半角英数字のみを使用した文字列を((12文字以内))で指定する必要があります。

本パラメータは必須です。

指定されたサービス名称は、/etc/servicesおよび/etc/inetd.confに次の2個のサービス名称として登録されます。

・ サービス名称_tcp

・ サービス名称_udp

Linux、および、Linux(IPF)ではinetdデーモンの代わりにxinetdデーモンを使用します。

Solaris10ではinetdデーモンの代わりにSMFサービスを使用します。

設定の詳細については、各OSのソフトウェア添付資料を参照してください。

· HiRDBユニットのノード

このAgent が対象とするHiRDBユニットの種別を指定します。

ここでは、「Y」を指定してください。

パラメータを入力しないで[Enter]キーを押した場合は、<<Y>>が仮定されます。

· 系切り替え構成の選択

系切り替え構成種別を選択します。ここでは、「１」の系切り替え構成未使用を設定してください。

パラメータを入力しないで[Enter]キーを押した場合は、<<1>>が仮定されます。

· Rocket Punch機能使用要否

管理対象となるHiRDBシステムをServerに対して、自動的に登録する機能を使用するか否かを指定してください。

パラメータを入力しないで[Enter]キーを押した場合は、<<N>>が仮定されます。

「N」を指定した場合は、Console上の「管理HiRDBの新規登録」コマンドを使用して手動で登録を行う必要があります。

· Rocket Punch機能の時間間隔

RocketPunch機能を使用する場合にのみ入力要求があります。

Serverに情報を通知する時間の間隔を入力してください。

なお、設定範囲は((1～30/分))の間で、パラメータを入力しないで[Enter]キーを押した場合は、1分間隔で自動登録の要求が行われます。

· Rocket Punch機能の発信先ServerのIPアドレス

RocketPunch機能を使用する場合にのみ入力要求があります。

自動登録を要求する先のServerのIPアドレスを10進ドット記法で指定してください。

· Rocket Punch機能の発信先Serverのポート番号

RocketPunch機能を使用する場合にのみ入力要求があります。

自動登録を要求する先のServerのポート番号を指定してください。

設定範囲は((5001～65535))です。ポート番号を入力しないで[Enter]キーを押した場合は、<<20291>>が仮定されます。

· 認可識別子

管理するHiRDBシステムでDBの操作権限をもつ認可識別子を指定してください。

認可識別子は((最大8文字))となっています。

本パラメータは必須です。

認可識別子をダブルコーテーションで囲む必要はありません。入力した文字列の大文字と小文字は区別されます。

· 認可識別子のパスワード

管理するHiRDBシステムでDBの操作権限をもつパスワードを指定してください。

パスワードは((最大30文字))となっています。

本パラメータは必須です。

パスワードをダブルコーテーションで囲む必要はありません。入力した文字列の大文字と小文字は区別されます。

· PDLANG

当該HiRDB Control Manager - Agent が対象とするHiRDBをセットアップした際に、指定した文字コードを選択してください。

セットアップ時に文字コードを指定しなかった場合は、defaultを指定してください。

· LANG

当該HiRDB Control Manager - Agent が動作するサーバマシンの文字コード (環境変数LANG) を選択してください。

選択肢以外の文字コードを使用している場合は、othersを指定してください。

パラメータを入力しないで[Enter]キーを押した場合は、<<1>>が仮定されます。

· EasyMT使用可否

バックアップおよびリカバリ機能でEasyMTを使用するか否かを指定してください。

パラメータを入力しないで[Enter]キーを押した場合は、<<N>>が仮定されます。

Linux、および、Linux(IPF)ではサポートされていないため、設問は表示されません。

· MTGuide使用可否

バックアップおよびリカバリ機能でMTGuideを使用するか否かを指定してください。

パラメータを入力しないで[Enter]キーを押した場合は、<<N>>が仮定されます。

Linux、および、Linux(IPF)ではサポートされていないため、設問は表示されません。

· JP1/OmniBack Ⅱ使用可否

>バックアップおよびリカバリ機能でJP1/OmniBack Ⅱを使用するか否かを指定してください。

パラメータを入力しないで[Enter]キーを押した場合は、<<N>>が仮定されます。

Linux、および、Linux(IPF)ではサポートされていないため、設問は表示されません。

· NetBackup使用可否

バックアップおよびリカバリ機能でNetBackupを使用するか否かを指定してください。

パラメータを入力しないで[Enter]キーを押した場合は、<<N>>が仮定されます。

· NetBackup用AgentをインストールしたIPアドレス

NetBackup連携機能を使用する場合にのみ入力要求があります。

NetBackup用AgentをインストールしたマシンのIPアドレスを10進ドット記法で指定してください。

· NetBackup用Agentをインストールしたポート番号

NetBackup連携機能を使用する場合にのみ入力要求があります。

NetBackup用Agentのポート番号を指定してください。設定範囲は((5001～65535))です。

ポート番号を入力しないで[Enter]キーを押した場合は、<<20293>>が仮定されます。

· NetBackup ClientのハードウェアとOS情報

管理対象のHiRDBが使用するNetBackupクライアントのハードウェア及びオペレーティングシステムを選択してください。選択肢にない組み合わせの場合、othersを指定してください。

すべてのパラメータの入力が終了すると、セットアップを行うAgentの定義パラメータが表示されます。

内容を確認してください。パラメータの内容は、Agent定義パラメータ一覧を参照してください。

「Y」を入力するとセットアップを実行して処理を終了します。「N」を入力すると処理を中断します。

<注意事項>

· パラメータの入力は[Enter]キーにより終了してください。

· セットアップコマンドでは入力されたパラメータの文字列や値のチェックは行いません。入力値には十分注意してください。

入力を誤った場合は、アンセットアップコマンド実行後、再度セットアップコマンドを実行してください。

2ユニット以上で構成されるHiRDB/パラレルサーバへのインストール/セットアップ

2ユニット以上で構成されるHiRDB/パラレルサーバにAgentをインストールおよびセットアップする際には、最初にシステムマネジャ (MGR) にAgentを組み込んでください。

システムマネジャ (MGR) へのインストールおよびセットアップが完了したら、全ての非システムマネジャへAgentをインストールします。

<前提条件>

· Agentでは1つのポート番号を使用します。なお、NetBackup用Agentを同じサーバマシンにインストールする場合は、2つのポート番号を用意してください。

他アプリケーションと競合しないように、インストールする前にはポート番号を確認してください。デフォルトでは<<20293>>を使用します。

· Agentのインストールおよびセットアップはスーパーユーザ （id：root） のみ行うことができます。実行時にはスーパーユーザになる必要があります。

· NetBackup連携機能を使用する場合は、通常Agentの前にNetBackup用Agentをインストールしてください。

1. Agentのインストール。

各OSのソフトウェア添付資料に従い、すべての該当マシンへAgentを組み込んでください。

既に最新のAgentがインストールされている場合には、この作業は必要ありません。2のセットアップコマンドを実行してください。

2. セットアップコマンドの実行。

スーパーユーザで次のコマンドを実行します。

/opt/hirdbCMA/bin/cmasetup HiRDB運用ディレクトリ

· HiRDB運用ディレクトリ

管理対象とするHiRDBユニットのHiRDB運用ディレクトリを絶対パスで指定してください。

本パラメータは必須です。

コマンドを実行すると、対話形式により以下のパラメータの入力を求められます。

· Agentの種別

ここでは、「Y」を選択します。

HP-UX(IPF)、Linux(IPF)、および、Solaris10ではAgentの種別選択はありません。

· AgentをインストールするIPアドレス

このAgentが、Serverからの要求を受け付けるために使用するIPアドレスを10進ドット記法で指定してください。

Serverが稼動するマシン上から通信できるIPアドレスを指定する必要があります。

本パラメータは必須です。

· Agentの使用するポート番号

このAgentが、Serverからの要求を受け付けるために使用するポート番号を指定してください。

設定範囲は((5001～65535))です。当該マシン内で使用されていないポート番号を指定する必要があります。

本パラメータは必須です。ポート番号を入力しないで[Enter]キーを押した場合は、<<20293>>が仮定されます。

· inetdデーモンのサービス名

Agentは、Serverからの要求を受け付けるためにinetdデーモンを使用します。inetdがこのAgentを識別するためのサービス名称を指定してください。

このサービス名称は、/etc/servicesファイルに既に記述されているサービス名称と重複しない半角英数字のみを使用した文字列を((12文字以内))で指定する必要があります。

本パラメータは必須です。

指定されたサービス名称は、/etc/servicesおよび/etc/inetd.confに次の2個のサービス名称として登録されます。

・ サービス名称_tcp

・ サービス名称_udp

Linux、および、Linux(IPF)ではinetdデーモンの代わりにxinetdデーモンを使用します。

Solaris10ではinetdデーモンの代わりにSMFサービスを使用します。

設定の詳細については、各OSのソフトウェア添付資料を参照してください。

· HiRDBユニットのノード

このAgentが対象とするHiRDBユニットの種別を指定します。

管理対象とするHiRDBユニットがシステムマネジャの場合は「Y」を、非システムマネジャの場合は「N」を指定します。

パラメータを入力しないで[Enter]キーを押した場合は、<<Y>>が仮定されます。

· 系切り替え構成の選択

系切り替え構成種別を選択します。ここでは、「１」の系切り替え構成未使用を設定してください。

パラメータを入力しないで[Enter]キーを押した場合は、<<1>>が仮定されます。

· Rocket Punch機能使用要否

管理対象とするHiRDBユニットがシステムマネジャの場合にのみ入力要求があります。

管理対象となるHiRDBシステムをServerに対して、自動的に登録する機能を使用するか否かを指定してください。

パラメータを入力しないで[Enter]キーを押した場合は、<<N>>が仮定されます。

「N」を指定した場合は、Console上の「管理HiRDBの新規登録」コマンドを使用して手動で登録を行う必要があります。

· Rocket Punch機能の時間間隔

管理対象とするHiRDBユニットがシステムマネジャであり、かつ、RocketPunch機能を使用する場合にのみ入力要求があります。

Serverに情報を通知する時間の間隔を入力してください。

なお、設定範囲は((1～30/分))の間で、パラメータを入力しないで[Enter]キーを押した場合は、1分間隔で自動登録の要求が行われます。

· Rocket Punch機能の発信先ServerのIPアドレス

管理対象とするHiRDBユニットがシステムマネジャであり、かつ、RocketPunch機能を使用する場合にのみ入力要求があります。

自動登録を要求する先のServerのIPアドレスを10進ドット記法で指定してください。

· Rocket Punch機能の発信先Serverのポート番号

管理対象とするHiRDBユニットがシステムマネジャであり、かつ、RocketPunch機能を使用する場合にのみ入力要求があります。

自動登録を要求する先のServerのポート番号を指定してください。

設定範囲は((5001～65535))です。ポート番号を入力しないで[Enter]キーを押した場合は、<<20291>>が仮定されます。

· システムマネジャに組み込んだAgentのIPアドレス

管理対象とするHiRDBユニットが非システムマネジャの場合にのみ入力要求があります。

システムマネジャのHiRDBユニットに組み込んだAgentの使用するIPアドレスを10進ドット記法で指定してください。

· システムマネジャに組み込んだAgentのポート番号

管理対象とするHiRDBユニットが非システムマネジャの場合にのみ入力要求があります。

システムマネジャのHiRDBユニットに組み込んだAgentの使用するポート番号を指定してください。

設定範囲は((5001～65535))です。ポート番号を入力しないで[Enter]キーを押した場合は、<<20293>>が仮定されます。

· 認可識別子

管理するHiRDBシステムでDBの操作権限をもつ認可識別子を指定してください。

認可識別子は((最大8文字))となっています。

本パラメータは必須です。

認可識別子をダブルコーテーションで囲む必要はありません。入力した文字列の大文字と小文字は区別されます。

· 認可識別子のパスワード

管理するHiRDBシステムでDBの操作権限をもつパスワードを指定してください。

パスワードは((最大30文字))となっています。

本パラメータは必須です。

パスワードをダブルコーテーションで囲む必要はありません。入力した文字列の大文字と小文字は区別されます。

· PDLANG

当該HiRDB Control Manager - Agent が対象とするHiRDBをセットアップした際に、指定した文字コードを選択してください。

セットアップ時に文字コードを指定しなかった場合は、defaultを指定してください。

· LANG

当該HiRDB Control Manager - Agent が動作するサーバマシンの文字コード (環境変数LANG) を選択してください。

選択肢以外の文字コードを使用している場合は、othersを指定してください。

パラメータを入力しないで[Enter]キーを押した場合は、<<1>>が仮定されます。

· EasyMT使用可否

バックアップおよびリカバリ機能でEasyMTを使用するか否かを指定してください。

パラメータを入力しないで[Enter]キーを押した場合は、<<N>>が仮定されます。

Linux、および、Linux(IPF)ではサポートされていないため、設問は表示されません。

· MTGuide使用可否

バックアップおよびリカバリ機能でMTGuideを使用するか否かを指定してください。

パラメータを入力しないで[Enter]キーを押した場合は、<<N>>が仮定されます。

Linux、および、Linux(IPF)ではサポートされていないため、設問は表示されません。

· JP1/OmniBack Ⅱ使用可否

バックアップおよびリカバリ機能でJP1/OmniBack Ⅱを使用するか否かを指定してください。

パラメータを入力しないで[Enter]キーを押した場合は、<<N>>が仮定されます。

Linux、および、Linux(IPF)ではサポートされていないため、設問は表示されません。

· NetBackup使用可否

バックアップおよびリカバリ機能でNetBackupを使用するか否かを指定してください。

パラメータを入力しないで[Enter]キーを押した場合は、<<N>>が仮定されます。

· NetBackup用AgentをインストールしたIPアドレス

NetBackup連携機能を使用する場合にのみ入力要求があります。

NetBackup用AgentをインストールしたマシンのIPアドレスを10進ドット記法で指定してください。

· NetBackup用Agentをインストールしたポート番号

NetBackup連携機能を使用する場合にのみ入力要求があります。

NetBackup用Agentのポート番号を指定してください。設定範囲は((5001～65535))です。

ポート番号を入力しないで[Enter]キーを押した場合は、<<20293>>が仮定されます。

· NetBackup ClientのハードウェアとOS情報

管理対象のHiRDBが使用するNetBackupクライアントのハードウェア及びオペレーティングシステムを選択してください。選択肢にない組み合わせの場合、othersを指定してください。

すべてのパラメータの入力が終了すると、セットアップを行うAgentの定義パラメータが表示されます。

内容を確認してください。パラメータの内容は、Agent定義パラメータ一覧を参照してください。

「Y」を入力するとセットアップを実行して処理を終了します。「N」を入力すると処理を中断します。

<注意事項>

· パラメータの入力は[Enter]キーにより終了してください。

· セットアップコマンドでは入力されたパラメータの文字列や値のチェックは行いません。入力値には十分注意してください。

入力を誤った場合は、アンセットアップコマンド実行後、再度セットアップコマンドを実行してください。

系切り替え構成を含むHiRDBへのインストール/セットアップ

以下の順序で各ユニットにAgentをインストールしてください。下記以外の順序でインストールを行うと、各ユニット間の連携処理に時間がかかることや、失敗することがありますので注意してください。

①．HiRDB/シングルサーバあるいは、HiRDB/パラレルサーバのシステムマネジャの現用系ユニット

(MGRノードがスタンバイ型系切り替えを使用していない場合は、そのユニットが対象となります。)

②．HiRDB/シングルサーバあるいは、HiRDB/パラレルサーバのシステムマネジャの予備系ユニット

(MGRノードがスタンバイ型系切り替えを使用していない場合は、この操作を行う必要はありません。)

③．２ノード以上のHiRDB/パラレルサーバにおける、ある非システムマネジャの現用系ユニット

(スタンバイ型系切り替えを使用していない場合は、そのユニットが対象となります。)

④．２ノード以上のHiRDB/パラレルサーバにおける、ある非システムマネジャの予備系ユニット

(スタンバイ型系切り替えを使用していない場合は、この操作を行う必要はありません。)

⑤．③～④をすべての非システムマネジャに対して行います。

ひとつのユニットに対し、以下の1、2の手順が全て完了してから、他のユニットへのセットアップを行ってください。

<前提条件>

· Agentでは1つのポート番号を使用します。なお、NetBackup用Agentを同じサーバマシンにセットアップする場合は、2つのポート番号を用意してください。

他アプリケーションと競合しないように、インストールする前にはポート番号を確認してください。なお、デフォルトでは<<20293>>を使用します。

· NetBackup連携機能を使用する場合は、通常Agentの前にNetBackup用Agentをインストールしてください。

· HiRDB/シングルサーバまたは、HiRDB/パラレルサーバのシステムマネジャがスタンバイ型系切り替えの場合、Agentが使用するサービスIPアドレスを設定する必要があります。 このIPアドレスは、対象ユニットの起動時にアクティブになるように設定してください。

· 対象のHiRDBシステムがクラスタソフトウェアとしてHAモニタを使用し、かつ、影響分散スタンバイレス型系切り替え構成を使用する場合、HAモニタのserver定義文で指定するaliasオペランドを対象のサーバ名と同一の名称に設定する必要があります。

1. Agentのインストール。

各OSのソフトウェア添付資料に従い、すべての該当マシンへAgentを組み込んでください。

既に最新のAgentがインストールされている場合には、この作業は必要ありません。2のセットアップコマンドを実行してください。

2. セットアップコマンドの実行。

スーパーユーザで次のコマンドを実行します。

/opt/hirdbCMA/bin/cmasetup HiRDB運用ディレクトリ

· HiRDB運用ディレクトリ

管理対象とするHiRDBユニットのHiRDB運用ディレクトリを絶対パスで指定してください。

本パラメータは必須です。

コマンドを実行すると、対話形式により以下のパラメータの入力を求められます。

· Agentの種別

ここでは、「Y」を選択します。

HP-UX(IPF)、Linux(IPF)、および、Solaris10ではAgentの種別選択はありません。

· AgentをインストールするIPアドレス

このAgentが、Serverからの要求を受け付けるために使用するIPアドレスを10進ドット記法で指定してください。

Serverが稼動するマシン上から通信できるIPアドレスを指定する必要があります。

本パラメータは必須です。

スタンバイ型系切り替えを使用するユニットにセットアップする場合は、ユニットの稼動状態に関係なく接続できるIPアドレスを指定してください。

· Agentの使用するポート番号

このAgentが、Serverからの要求を受け付けるために使用するポート番号を指定してください。

設定範囲は((5001～65535))です。当該マシン内で使用されていないポート番号を指定する必要があります。

本パラメータは必須です。ポート番号を入力しないで[Enter]キーを押した場合は、<<20293>>が仮定されます。

スタンバイ型系切り替えを使用するユニットにセットアップ場合、現用系を管理するAgentと予備系を管理するAgentで必ず同じポート番号を指定してください。

HiRDBシステムを構成する各ユニットでポート番号が一致する必要はありません。相互系切り替え構成など同一サーバマシンに複数のユニットが存在する場合は、必ずユニットごとに別のポート番号を指定してください。

· inetdデーモンのサービス名

Agentは、Serverからの要求を受け付けるためにinetdデーモンを使用します。inetdがこのAgentを識別するためのサービス名称を指定してください。

このサービス名称は、/etc/servicesファイルに既に記述されているサービス名称と重複しない半角英数字のみを使用した文字列を((12文字以内))で指定する必要があります。

本パラメータは必須です。

指定されたサービス名称は、/etc/servicesおよび/etc/inetd.confに次の2個のサービス名称として登録されます。

・ サービス名称_tcp

・ サービス名称_udp

Linux、および、Linux(IPF)ではinetdデーモンの代わりにxinetdデーモンを使用します。

Solaris10ではinetdデーモンの代わりにSMFサービスを使用します。

設定の詳細については、各OSのソフトウェア添付資料を参照してください。

· HiRDBユニットのノード

このAgentが対象とするHiRDBユニットの種別を指定します。

管理対象とするHiRDBユニットがシステムマネジャの場合は「Y」を、非システムマネジャの場合は「N」を指定します。

パラメータを入力しないで[Enter]キーを押した場合は、<<Y>>が仮定されます。

· 系切り替え構成情報

このAgentが対象とするユニットの系切り替え構成を指定します。

管理対象とするHiRDBユニットが系切り替え構成を使用していない場合は「1」を、スタンバイ型系切り替えを使用している場合は「2」を、影響分散スタンバイレス型系切り替えを使用している場合は「3」を指定します。

パラメータを入力しないで「Enter」キーを押した場合は、<<1>>が仮定されます。

· クラスタ種別

このAgentが対象とするユニットの系切り替え構成を使用する場合にHiRDBユニットが使用しているクラスタソフトウェアを指定します。

管理対象とするHiRDBユニットがHAモニタを使用している場合は「1」を、その他のクラスタを使用している場合は「9」を指定します。

パラメータを入力しないで「Enter」キーを押した場合は、<<1>>が仮定されます。

Solarisの場合、この設問はありません。

· HAモニタalias名称

このAgentが対象とするユニットがスタンバイ型系切り替え構成であり、クラスタソフトウェアとしてHAモニタを使用する場合に、HAモニタサーバ対応の環境を設定する定義ファイル(servers)内のaliasパラメータに指定したalias名称（サーバの識別名（サーバの別名））を指定します。

クラスタ種別がHAモニタ以外の場合、または、スタンバイ型系切り替え構成以外の場合、この設問はありません。

· HAモニタgroup名称

このAgentが対象とするユニットがスタンバイ型系切り替え構成であり、クラスタソフトウェアとしてHAモニタを使用する場合に、HAモニタサーバ対応の環境を設定する定義ファイル(servers)内groupパラメータに指定したgroup名称（連動系切り替えグループ名称）を指定する。

パラメータを入力しないで「Enter」キーを押した場合は、group名称の指定が省略されます。

連動系切り替えを使用していない場合は、パラメータを入力しないで「Enter」キーを押してください。

クラスタ種別がHAモニタ以外の場合、または、スタンバイ型系切り替え構成以外の場合、この設問はありません。

· 現用系/予備系情報

このAgentが対象とするユニットのスタンバイ型系切り替え構成を使用する場合に対象ユニットが現用系であるか予備系であるかを指定します。

現用系として使用される場合は、「P」を、予備系として使用される場合は「S」を指定します。

パラメータを入力しないで「Enter」キーを押した場合は、<<P>>が仮定されます。

· 他系のIPアドレス情報

このAgentが対象とするユニットがスタンバイ型系切り替え構成を使用する場合に、対象ユニットが現用系であれば予備系、予備系であれば現用系のIPアドレスを入力します。

· サービスIPアドレス情報

このAgentが対象とするHiRDBユニットがHiRDB/シングルサーバ、または、HiRDB/パラレルサーバのシステムマネジャであり、スタンバイ型系切り替え構成を使用する場合に、HiRDB CMで使用するサービスIPアドレスを入力します。

· Rocket Punch機能使用要否

管理対象とするHiRDBユニットがHiRDB/シングルサーバ、または、HiRDB/パラレルサーバのシステムマネジャの場合にのみ入力要求があります。

管理対象となるHiRDBシステムをServerに対して、自動的に登録する機能を使用するか否かを指定してください。

パラメータを入力しないで[Enter]キーを押した場合は、<<N>>が仮定されます。

「N」を指定した場合は、Console上の「管理HiRDBの新規登録」コマンドを使用して手動で登録を行う必要があります。

スタンバイ型系切り替え構成の予備系ユニットの場合、この設問はありません。

· Rocket Punch機能の時間間隔

管理対象とするHiRDBユニットがHiRDB/シングルサーバ、または、HiRDB/パラレルサーバのシステムマネジャであり、かつ、RocketPunch機能を使用する場合にのみ入力要求があります。

Serverに情報を通知する時間の間隔を入力してください。

なお、設定範囲は((1～30/分))の間で、パラメータを入力しないで[Enter]キーを押した場合は、1分間隔で自動登録の要求が行われます。

· Rocket Punch機能の発信先ServerのIPアドレス

管理対象とするHiRDBユニットがHiRDB/シングルサーバ、または、HiRDB/パラレルサーバのシステムマネジャであり、かつ、RocketPunch機能を使用する場合にのみ入力要求があります。

自動登録を要求する先のServerのIPアドレスを10進ドット記法で指定してください。

· Rocket Punch機能の発信先Serverのポート番号

管理対象とするHiRDBユニットがHiRDB/シングルサーバ、または、HiRDB/パラレルサーバのシステムマネジャであり、かつ、RocketPunch機能を使用する場合にのみ入力要求があります。

自動登録を要求する先のServerのポート番号を指定してください。

設定範囲は((5001～65535))です。ポート番号を入力しないで[Enter]キーを押した場合は、<<20291>>が仮定されます。

· システムマネジャに組み込んだAgentのIPアドレス

管理対象とするHiRDBユニットが非システムマネジャの場合にのみ入力要求があります。

システムマネジャのHiRDBユニットに組み込んだAgentの使用するIPアドレスを10進ドット記法で指定してください。

· システムマネジャに組み込んだAgentのポート番号

管理対象とするHiRDBユニットが非システムマネジャの場合にのみ入力要求があります。

システムマネジャのHiRDBユニットに組み込んだAgentの使用するポート番号を指定してください。

設定範囲は((5001～65535))です。ポート番号を入力しないで[Enter]キーを押した場合は、<<20293>>が仮定されます。

· 認可識別子

管理するHiRDBシステムでDBの操作権限をもつ認可識別子を指定してください。

認可識別子は((最大8文字))となっています。

本パラメータは必須です。

認可識別子をダブルコーテーションで囲む必要はありません。入力した文字列の大文字と小文字は区別されます。

· 認可識別子のパスワード

管理するHiRDBシステムでDBの操作権限をもつパスワードを指定してください。

パスワードは((最大30文字))となっています。

本パラメータは必須です。

パスワードをダブルコーテーションで囲む必要はありません。入力した文字列の大文字と小文字は区別されます。

· PDLANG

当該HiRDB Control Manager - Agent が対象とするHiRDBをセットアップした際に、指定した文字コードを選択してください。

セットアップ時に文字コードを指定しなかった場合は、defaultを指定してください。

· LANG

当該HiRDB Control Manager - Agent が動作するサーバマシンの文字コード（環境変数LANG）を選択してください。

選択肢以外の文字コードを使用している場合は、othersを指定してください。

パラメータを入力しないで[Enter]キーを押した場合は、<<1>>が仮定されます。

· EasyMT使用可否

バックアップおよびリカバリ機能でEasyMTを使用するか否かを指定してください。

パラメータを入力しないで[Enter]キーを押した場合は、<<N>>が仮定されます。

Linux、および、Linux(IPF)ではサポートされていないため、設問は表示されません。

· MTGuide使用可否

バックアップおよびリカバリ機能でMTGuideを使用するか否かを指定してください。

パラメータを入力しないで[Enter]キーを押した場合は、<<N>>が仮定されます。

Linux、および、Linux(IPF)ではサポートされていないため、設問は表示されません。

· JP1/OmniBack Ⅱ使用可否

バックアップおよびリカバリ機能でJP1/OmniBack Ⅱを使用するか否かを指定してください。

パラメータを入力しないで[Enter]キーを押した場合は、<<N>>が仮定されます。

Linux、および、Linux(IPF)ではサポートされていないため、設問は表示されません。

· NetBackup使用可否

バックアップおよびリカバリ機能でNetBackupを使用するか否かを指定してください。

パラメータを入力しないで[Enter]キーを押した場合は、<<N>>が仮定されます。

· NetBackup用AgentをインストールしたIPアドレス

NetBackup連携機能を使用する場合にのみ入力要求があります。

NetBackup用AgentをインストールしたマシンのIPアドレスを10進ドット記法で指定してください。

· NetBackup用Agentをインストールしたポート番号

NetBackup連携機能を使用する場合にのみ入力要求があります。

NetBackup用Agentのポート番号を指定してください。設定範囲は((5001～65535))です。

ポート番号を入力しないで[Enter]キーを押した場合は、<<20293>>が仮定されます。

· NetBackup ClientのハードウェアとOS情報

管理対象のHiRDBが使用するNetBackupクライアントのハードウェア及びオペレーティングシステムを選択してください。選択肢にない組み合わせの場合、othersを指定してください。

すべてのパラメータの入力が終了すると、セットアップを行うAgentの定義パラメータが表示されます。

内容を確認してください。パラメータの内容は、Agent定義パラメータ一覧を参照してください。

「Y」を入力するとセットアップを実行して処理を終了します。「N」を入力すると処理を中断します。

<注意事項>

· パラメータの入力は[Enter]キーにより終了してください。

· セットアップコマンドでは入力されたパラメータの文字列や値のチェックは行いません。入力値には十分注意してください。

入力を誤った場合は、アンセットアップコマンド実行後、再度セットアップコマンドを実行してください。

l アンセットアップ/アンインストール

<前提条件>

· アンセットアップを行うAgentで管理しているHiRDBシステムが、Serverに登録されている場合は「管理HiRDBの解除」コマンドで、Serverの管理を解除してください。

· アンセットアップおよびアンインストールはスーパーユーザ （id：root） のみ行うことができます。実行時にはスーパーユーザになる必要があります。

1. アンセットアップコマンドの実行。

スーパーユーザで次のコマンドを実行します。

/opt/hirdbCMA/bin/cmasetup -d HiRDB運用ディレクトリ

· HiRDB運用ディレクトリ

管理対象とするHiRDBユニットのHiRDB運用ディレクトリを絶対パスで指定してください。

本パラメータは必須です。

コマンド実行後は、必要に応じて各OSのソフトウェア添付資料に記載されている操作を行ってください。

2. Agentのアンインストール。

各OSのソフトウェア添付資料にしたがい、該当マシンからAgentを削除してください。

<注意事項>

· アンセットアップをしていない、稼動中のAgentが存在するサーバマシンでアンインストールを実行すると、稼動している他のAgentが正常に動作しなくなります。アンインストール時には、該当マシン上で他のあらゆるAgentがアンセットアップされていることを確認してから実行してください。


HiRDB Control Manager - 通常Agent(Windows)

インストール/アンインストール方法

Windows HiRDB Control Manager - 通常Agent

Windows HiRDB Control Manager - 通常Agentのインストール/アンインストール方法を説明します。

§ インストール

§ アンインストール

l インストール

HiRDB Control Manager - Agentは、管理するHiRDBシステムを搭載している全てのサーバマシンにインストールする必要があります。

2ユニット以上で構成されるHiRDB/パラレルサーバの場合は、マネジャシステム (MGR) 及び 非マネジャシステムにHiRDB Control Manager - Agentをインストールしてください。

Agentのインストール方法を、管理するHiRDBサーバ種別ごとに次で説明します。

§ HiRDB/シングルサーバ及び1ユニット構成のHiRDB/パラレルサーバへのインストール

§ 2ユニット以上で構成されるHiRDB/パラレルサーバへのインストール

§ 系切り替え構成を含むHiRDBへのインストール

インストールが終了すると、[サービス]に「HiRDB Control Manager - Agent」が登録されます。

Agentを使用するには、「HiRDB Control Manager - Agent」を開始してください。

<注意事項>

· HiRDBの構成を変更する場合は、すべてのユニット上のAgentをアンインストールした後に、再度インストールを実行してください。上書きインストールによる構成の変更はできません。

構成変更例：
- HiRDBシステムを構成するユニットやサーバを追加/削除した場合

- 系切り替えを使用しない構成でセットアップしているAgentを、系切り替えを使用する構成に変更する場合

- 系切り替えを使用する構成でセットアップしているAgentを、系切り替えを使用しない構成に変更する場合

- 系切り替えを使用する構成でセットアップしているAgentの系切り替え種別(サーバ/モニタモード等)を変更する場合

HiRDB/シングルサーバ及び1ユニット構成のHiRDB/パラレルサーバへのインストール

<前提条件>

· Agentでは1つのポート番号を使用します。なお、他のAgent、NetBackup用Agent、XDM/RD用Agentを同じサーバマシンにインストールする場合は、インストール数分のポート番号を用意してください。

他アプリケーションと競合しないように、インストールする前にはポート番号を確認してください。デフォルトでは<<20293>>を使用します。

· Server及びAgentのインストール終了後は、サーバマシンの再起動が必要となります。Server及びAgentのインストールを行う前に、全てのアプリケーションを終了させてください。

· NetBackup連携機能を使用する場合は、通常Agentの前にNetBackup用Agentをインストールしてください。

1. セットアッププログラムの起動。

CDをドライブに装着し、エクスプローラを使ってCDドライブへ移動します。その中にある「SETUP.EXE」を実行するとセットアッププログラムが起動しますので、画面の指示に従ってインストールをしてください。

2. Agent種別の選択。

HiRDB Control Manager - Agentの種別を選択します。

ここでは「通常Agent」を選択してください。

IPF版のAgentの場合、本画面は表示されません。

3. セットアップ方法の選択。

このAgentを組み込むHiRDBシステムのセットアップ種別に応じ、セットアップ方法を選択してください。

4. セットアップ識別子の設定。

3で｢識別子付きのHiRDBにセットアップ」を選択した場合には、HiRDBシステムの識別子を入力してください。

なお、識別子は((最大4文字))まで入力できます。

標準セットアップのHiRDBシステムにAgentを組み込む場合は、この設定画面は表示されません。

5. ユーザ情報の設定。

名前と会社名を入力してください。

6. AgentをインストールするサーバマシンのIPアドレスとポート番号を設定。

AgentをインストールするサーバマシンのIPアドレス及びポート番号を入力してください。

ポート番号の設定範囲は((5001～65535))です。Agentの値をデフォルトにした場合は、<<20293>>を使用します。

ポート番号は他アプリケーションと競合しないように注意してください。

「通常Agent」と「NetBackup用Agent」は両アプリケーションともデフォルトでは<<20293>>を使用します。

両アプリケーションを同一サーバマシンにインストールする際に、どちらもデフォルトポート番号を使用すると競合し、アプリケーションが正常に動作しません。

したがって、両アプリケーションを同一サーバマシンにインストールする場合は、競合しないポート番号を設定してください。

7. HiRDBノード選択。

このAgentを組み込むHiRDBシステムのノードを選択します。

ここでは、「システムマネジャ」を選択してください。

8. 系切り替え構成選択。

    このAgentを組み込むHiRDBシステムの系切り替え構成を選択します。

    ここでは、「系切り替え未使用ユニット」を選択してください。

9. Rocket Punch機能使用の選択。

このAgentのIPアドレスとポート番号をServerへ通知し、自動的に管理させることができます。

Serverに自動的に管理させる場合は、「自動的に登録を依頼する」を選択してください。

「自動的に登録を依頼しない」を選択した場合は、Console上の「管理HiRDBの新規登録」コマンドを使用して手動で登録を行う必要があります。

· 「自動的に登録を依頼する」 | : | 手順10.へ進みます。
· 「自動的に登録を依頼しない」 | : | 手順12.へ進みます。

10. Rocket Punch機能の時間間隔設定。

Serverに情報を通知する時間の間隔を入力してください。

設定範囲は((1～30/分))で、デフォルトの値は<<1>>となっています。

11. Rocket Punch機能の発信先を設定。

Rocket Punch機能を使用して自動管理させるServerの情報を入力してください。

ServerをインストールしたサーバマシンのIPアドレスとポート番号を入力します。

ポート番号の設定範囲は((5001～65534))です。Serverのポート番号をデフォルトの値にした場合は<<20291>>を使用します。

12. 認可識別子の設定。

管理するHiRDBシステムでDBの操作権限をもつ認可識別子及びパスワードを指定してください。

認可識別子は((最大8文字))、パスワードは((最大30文字))となっています。

認可識別子およびパスワードをダブルコーテーションで囲む必要はありません。入力した文字列の大文字と小文字は区別されます。

ここで指定した認可識別子とパスワードはよく確認して次の手順へ進んでください。

設定した値に誤りが含まれていた場合は、HiRDBの操作が正常に動作しません。

13. Windowsファイアウォール例外リストの登録。

Ａｇｅｎｔをインストールするマシンが、Windwos XP SP2以降、Windows Server 2003 SP1以降、Windows Vista、Windows Server 2008の場合にWindwosファイアウォールを「有効」に設定していると、ネットワークの制限によりHiRDB CMが正しく機能しません。本画面で例外登録を行うと、ファイアーウォールを使用していても、HiRDB CMを正しく起動することができます。

本画面では、Windowｓファイアウォールを「有効」にしている場合は、「Windowsファイアウォール例外リストへ登録する。」を選択してください。Windowsファイアーウォールを無効に設定している場合は、「Windowsファイアウォール例外リストへ登録しない。」を選択してください。

14. バックアップ装置の選択。

管理するHiRDBシステムが使用しているバックアップ装置を選択します。

NetBackup連携機能を使用しているHiRDBシステムにおいて、このAgentをインストールしているサーバマシンがNetBackupクライアントホストとして使用されている場合は、「NetBackup」を選択してください。NetBackupクライアントホストではない場合は、「NetBackup」を選択する必要はありません。

NetBackup連携機能を使用しない場合は、何も選択する必要はありません。

なお、次の手順に進むためには、NetBackupマスタサーバにNetBackup用Agentをインストールしている必要があります。NetBackup用Agentのインストールを行っていない場合は、先にNetBackup用Agentのインストールをしてください。

· 「NetBackup」を使用する | : | 手順15.へ進みます。
· 「NetBackup」を使用しない | : | 手順17.へ進みます。

15. NetBackup用Agentのマスタサーバの情報を設定。

NetBackupマスタサーバに組み込んだNetBackup用AgentのIPアドレスとポート番号を入力してください。

ポート番号の設定範囲は((5001～65535))です。NetBackup用Agentのポート番号をデフォルトの値にした場合は<<20293>>を使用します。

16. NetBackupクライアント情報を入力。

NetBackupクライアントのハードウェアとOS情報を選択してください。「その他」を選択した場合は、入力を促す画面が表示されます。

17. インストール内容を確認して「次へ」をクリック。

HiRDB Control Manager - Agentのインストールを開始します。

18. 「完了」ボタンをクリック。

ファイルのコピーが終了すると、サーバマシンの再起動が必要となります。

ドライブからCDを取り出し、「完了」ボタンをクリックして再起動をしてください。

2ユニット以上で構成されるHiRDB/パラレルサーバへのインストール

2ユニット以上で構成されるHiRDB/パラレルサーバにAgentをインストールする際には、最初にシステムマネジャ (MGR) にAgentを組み込んでください。

システムマネジャ (MGR) へのインストールが完了したら、全ての非システムマネジャへAgentをインストールします。

<前提条件>

· Agentでは1つのポート番号を使用します。なお、他のAgent、NetBackup用Agent、XDM/RD用Agentを同じサーバマシンにインストールする場合は、インストール数分のポート番号を用意してください。

他アプリケーションと競合しないように、インストールする前にはポート番号を確認してください。デフォルトでは<<20293>>を使用します。

· Server及びAgentのインストール終了後は、サーバマシンの再起動が必要となります。Server及びAgentのインストールを行う前に、全てのアプリケーションを終了させてください。

· NetBackup連携機能を使用する場合は、通常Agentの前にNetBackup用Agentをインストールしてください。

1. セットアッププログラムの起動。

CDをドライブに装着し、エクスプローラを使ってCDドライブへ移動します。その中にある「SETUP.EXE」を実行するとセットアッププログラムが起動しますので、画面の指示に従ってインストールをしてください。

2. Agent種別の選択。

HiRDB Control Manager - Agentの種別を選択します。

ここでは「通常Agent」を選択してください。

IPF版のAgentの場合、本画面は表示されません。

3. セットアップ方法の選択。

このAgentを組み込むHiRDBシステムのセットアップ種別に応じ、セットアップ方法を選択してください。

4. セットアップ識別子の設定。

3で｢識別子付きのHiRDBにセットアップ」を選択した場合には、HiRDBシステムの識別子を入力してください。

なお、識別子は((最大4文字))まで入力できます。

標準セットアップのHiRDBシステムにAgentを組み込む場合は、この設定画面は表示されません。

5. ユーザ情報の設定。

名前と会社名を入力してください。

6. AgentをインストールするサーバマシンのIPアドレスとポート番号を設定。

AgentをインストールするサーバマシンのIPアドレス及びポート番号を入力してください。

ポート番号の設定範囲は((5001～65535))です。Agentの値をデフォルトにした場合は、<<20293>>を使用します。

ポート番号は他アプリケーションと競合しないように注意してください。

「通常Agent」と「NetBackup用Agent」は両アプリケーションともデフォルトでは<<20293>>を使用します。

両アプリケーションを同一サーバマシンにインストールする際に、どちらもデフォルトポート番号を使用すると競合し、アプリケーションが正常に動作しません。

したがって、両アプリケーションを同一サーバマシンにインストールする場合は、競合しないポート番号を設定してください。

7. ノード選択。

このAgentを組み込むHiRDBシステムのノードを選択します。

システムマネジャ (MGR) にインストールする場合は「システムマネジャ」を選択してください。

非システムマネジャにインストールする場合は「非システムマネジャ」を選択してください。

8. 系切り替え構成選択。

    このAgentを組み込むHiRDBシステムの系切り替え構成を選択します。

    ここでは、「系切り替え未使用ユニット」を選択してください。

· 「システムマネジャ」 | : | 手順9.へ進みます。
· 「非システムマネジャ」 | : | 手順12.へ進みます。

9. Rocket Punch機能使用の選択。

このAgentのIPアドレスとポート番号をServerへ通知し、自動的に管理させることができます。

Serverに自動的に管理させる場合は、「自動的に登録を依頼する」を選択してください。

「自動的に登録を依頼しない」を選択した場合は、Console上の「管理HiRDBの新規登録」コマンドを使用して手動で登録を行う必要があります。

· 「自動的に登録を依頼する」 | : | 手順10.へ進みます。
· 「自動的に登録を依頼しない」 | : | 手順13.へ進みます。

10. Rocket Punch機能の時間間隔設定。

Serverに情報を通知する時間の間隔を入力してください。

設定範囲は((1～30/分))で、デフォルトの値は<<1>>となっています。

11. Rocket Punch機能の発信先を設定。

Rocket Punch機能を使用して自動管理させるServerの情報を入力してください。

ServerをインストールしたサーバマシンのIPアドレスとポート番号を入力します。

ポート番号の設定範囲は((5001～65534))です。Serverのポート番号をデフォルトの値にした場合は<<20291>>を使用します。

12. システムマネジャ (MGR) のIPアドレスとポート番号を設定。

システムマネジャ (MGR) にインストールしたAgentのIPアドレス及びポート番号を入力してください。

13. 認可識別子の設定。

管理するHiRDBシステムでDBの操作権限をもつ認可識別子及びパスワードを指定してください。

認可識別子は((最大8文字))、パスワードは((最大30文字))となっています。

認可識別子およびパスワードをダブルコーテーションで囲む必要はありません。入力した文字列の大文字と小文字は区別されます。

ここで指定した認可識別子とパスワードはよく確認して次の手順へ進んでください。

設定した値に誤りが含まれていた場合は、HiRDBの操作が正常に動作しません。

14. Windowsファイアウォール例外リストの登録。

Ａｇｅｎｔをインストールするマシンが、Windwos XP SP2以降、Windows Server 2003 SP1以降、Windows Vistaの場合にWindwosファイアウォールを「有効」に設定していると、ネットワークの制限によりHiRDB CMが正しく機能しません。本画面で例外登録を行うと、ファイアーウォールを使用していても、HiRDB CMを正しく起動することができます。

本画面では、Windowｓファイアウォールを「有効」にしている場合は、「Windowsファイアウォール例外リストへ登録する。」を選択してください。Windowsファイアーウォールを無効に設定している場合は、「Windowsファイアウォール例外リストへ登録しない。」を選択してください。

15. バックアップ装置の選択。

管理するHiRDBシステムが使用しているバックアップ装置を選択します。

NetBackup連携機能を使用しているHiRDBシステムにおいて、このAgentをインストールしているサーバマシンがNetBackupクライアントホストとして使用されている場合は、「NetBackup」を選択してください。NetBackupクライアントホストではない場合は、「NetBackup」を選択する必要はありません。

NetBackup連携機能を使用しない場合は、何も選択する必要はありません。

なお、次の手順に進むためには、NetBackupマスタサーバにNetBackup用Agentをインストールしている必要があります。NetBackup用Agentのインストールを行っていない場合は、先にNetBackup用Agentのインストールをしてください。

· 「NetBackup」を使用する | : | 手順16.へ進みます。
· 「NetBackup」を使用しない | : | 手順18.へ進みます。

16. NetBackup用Agentのマスタサーバの情報を設定。

NetBackupマスタサーバに組み込んだNetBackup用AgentのIPアドレスとポート番号を入力してください。

ポート番号の設定範囲は((5001～65535))です。NetBackup用Agentのポート番号をデフォルトの値にした場合は<<20293>>を使用します。

17. NetBackupクライアント情報を入力。

NetBackupクライアントのハードウェアとOS情報を選択してください。「その他」を選択した場合は、入力を促す画面が表示されます。

18. インストール内容を確認して「次へ」をクリック。

HiRDB Control Manager - Agentのインストールを開始します。

19. 「完了」ボタンをクリック。

ファイルのコピーが終了すると、サーバマシンの再起動が必要となります。

ドライブからCDを取り出し、「完了」ボタンをクリックして再起動をしてください。

サーバマシンの再起動を行った後は、サービスのアカウントを設定します。

20. サービスのアカウントを設定。

[コントロールパネル]の「管理ツール」にある「サービス」を起動し、「HiRDB Control Manager - Agent <識別子>」の状態を確認します。サービスの状態が開始の場合は、停止してください。

「HiRDB Control Manager - Agent <識別子>」の[プロパティ]を起動し、ここで管理するHiRDBと同様のアカウントを設定します。

[ログオン]ページを開き、ラジオボタン「アカウント」を選択します。選択すると、「ユーザ名」と「パスワード」及び「パスワードの確認入力」の入力が可能となりますので、各項目に管理するHiRDBと同じ値を設定してください。

入力が終了したら「適用」ボタンでサービスのプロパティの更新を行い、[プロパティ]を閉じます。

サービス「HiRDB Control Manager - Agent <識別子>」を開始します。

系切り替え構成を含むHiRDBへのインストール

以下の順序で各ユニットにAgentをインストールしてください。下記以外の順序でインストールを行うと、各ユニット間の連携処理に時間がかかることや、失敗することがありますので注意してください。

①．HiRDB/シングルサーバあるいは、HiRDB/パラレルサーバのシステムマネジャの現用系ユニット

(MGRノードがスタンバイ型系切り替えを使用していない場合は、そのユニットが対象となります。)

②．HiRDB/シングルサーバあるいは、HiRDB/パラレルサーバのシステムマネジャの予備系ユニット

(MGRノードがスタンバイ型系切り替えを使用していない場合は、この操作を行う必要はありません。)

③．２ノード以上のHiRDB/パラレルサーバにおける、ある非システムマネジャの現用系ユニット

(スタンバイ型系切り替えを使用していない場合は、そのユニットが対象となります。)

④．２ノード以上のHiRDB/パラレルサーバにおける、ある非システムマネジャの予備系ユニット

(スタンバイ型系切り替えを使用していない場合は、この操作を行う必要はありません。)

⑤．③～④をすべての非システムマネジャに対して行います。

ひとつのユニットに対し、以下の1～23の手順が全て完了してから、他のユニットのインストールを行ってください。

<前提条件>

· Agentでは1つのポート番号を使用します。なお、他のAgent、NetBackup用Agent、XDM/RD用Agentを同じサーバマシンにインストールする場合は、インストール数分のポート番号を用意してください。

他アプリケーションと競合しないように、インストールする前にはポート番号を確認してください。デフォルトでは<<20293>>を使用します。

· Server及びAgentのインストール終了後は、サーバマシンの再起動が必要となります。Server及びAgentのインストールを行う前に、全てのアプリケーションを終了させてください。

· NetBackup連携機能を使用する場合は、通常Agentの前にNetBackup用Agentをインストールしてください。

· HiRDB/シングルサーバまたは、HiRDB/パラレルサーバのシステムマネジャがスタンバイ型系切り替えの場合、Agentが使用するサービスIPアドレスを設定する必要があります。 MSCSのリソースとしてIPアドレスの登録およびネットワーク名登録を行ったあと、対象のユニットのグループに登録してください。

· 影響分散スタンバイレス型計切り替えを使用する各サーバに対応するMSCSのグループ名およびリソース名は、それぞれHiRDBのサーバ名と一致させておく必要があります。一致していない場合は、HiRDBに対する開始、停止、状態変更、計画系切り替えの操作が失敗することがあります。

· 対象のHiRDBシステムがクラスタソフトウェアとしてMSCSとHA Toolkit Exを使用し、影響分散スタンバイレス型系切り替え構成を使用する場合、HA Toolkit Exのservers定義ファイルで指定するaliasオペランドを対象のサーバ名と同一の名称に設定する必要があります。

1. セットアッププログラムの起動。

CDをドライブに装着し、エクスプローラを使ってCDドライブへ移動します。その中にある「SETUP.EXE」を実行するとセットアッププログラムが起動しますので、画面の指示に従ってインストールをしてください。

2. Agent種別の選択。

HiRDB Control Manager - Agentの種別を選択します。

ここでは「通常Agent」を選択してください。

IPF版のAgentの場合、本画面は表示されません。

3. セットアップ方法の選択。

このAgentを組み込むHiRDBシステムのセットアップ種別に応じ、セットアップ方法を選択してください。

4. セットアップ識別子の設定。

3で｢識別子付きのHiRDBにセットアップ」を選択した場合には、HiRDBシステムの識別子を入力してください。

なお、識別子は((最大4文字))まで入力できます。

標準セットアップのHiRDBシステムにAgentを組み込む場合は、この設定画面は表示されません。

5. ユーザ情報の設定。

名前と会社名を入力してください。

6. AgentをインストールするサーバマシンのIPアドレスとポート番号を設定。

AgentをインストールするサーバマシンのIPアドレス及びポート番号を入力してください。

ポート番号の設定範囲は((5001～65535))です。Agentの値をデフォルトにした場合は、<<20293>>を使用します。

ポート番号は他アプリケーションと競合しないように注意してください。

スタンバイ型系切り替えを使用するユニットにAgentを組み込む場合、現用系を管理するAgentと予備系を管理するAgentで必ず同じポート番号を指定してください。

HiRDBシステムを構成する各ユニットでポート番号が一致する必要はありません。相互系切り替え構成など同一サーバマシンに複数のユニットが存在する場合は、必ずユニットごとに別のポート番号を指定してください。

同一サーバマシン上で同じポート番号を指定した場合、ポート番号が競合し、アプリケーションが正常に動作しません。

ここで指定するサーバマシンのIPアドレスは、対象マシンで静的なIPアドレスを指定してください。HiRDB CMで使用するサービスIPアドレスではありませんので、注意してください。

「通常Agent」と「NetBackup用Agent」は両アプリケーションともデフォルトでは<<20293>>を使用します。

両アプリケーションを同一サーバマシンにインストールする際に、どちらもデフォルトポート番号を使用すると競合し、アプリケーションが正常に動作しません。

したがって、両アプリケーションを同一サーバマシンにインストールする場合は、競合しないポート番号を設定してください。

7. HiRDBノード選択。

このAgentを組み込むHiRDBシステムのノードを選択します。

HiRDB/シングルサーバ、または、システムマネジャ (MGR) にインストールする場合は「システムマネジャ」を選択してください。

非システムマネジャにインストールする場合は「非システムマネジャ」を選択してください。

8. 系切り替え構成選択。

このAgentを組み込むHiRDBユニットの系切り替え構成を選択します。

· 「系切り替え構成未使用ユニット」 |  |
· HiRDB/シングルサーバ、または、システムマネジャ | : | 手順13.へ進みます。
· 非システムマネジャ | : | 手順16.へ進みます。
· 「スタンバイ型系切り替え(モニタモード)」 | : | 手順9.へ進みます。
· 「スタンバイ型系切り替え(サーバモード)」 | : | 手順9.へ進みます。
· 「影響分散スタンバイレス型系切り替え」 | : | 手順12.へ進みます。

9. リソースグループ名称の指定。

インストール対象のユニットに対応するMSCSのリソースグループ名称を指定します。

· 「スタンバイ型系切り替え(モニタモード)」 | : | 手順11.へ進みます。
· 「スタンバイ型系切り替え(サーバモード)」 | : | 手順10.へ進みます。

10. HA Toolkit Exのalias名称の指定。

インストール対象のユニットに対応するHA toolkit Ex のalias名称を名称を指定します。

11. スタンバイ型系切り替え構成情報の指定。

このAgentを組み込むHiRDBユニットの系種別、および、スタンバイ型系切り替えを構成するもう一方のAgentが使用する静的なIPアドレスを指定します。

また、HiRDB/シングルサーバまたは、HiRDB/パラレルサーバのシステムマネジャの場合は、HiRDB CMが使用するサービスIPアドレスの指定も行います。

12. クラスタノード名の指定。

このAgentを組み込むHiRDBユニットが使用するMSCSのクラスタノード名を指定してします。通常は、そのマシンの標準ホスト名となります。

· 「現用系システムマネジャ」 | : | 手順13.へ進みます。
· 「予備系システムマネジャ」 | : | 手順17.へ進みます。
· 「非システムマネジャ」 | : | 手順16.へ進みます。

13. Rocket Punch機能使用の選択。

このAgentのIPアドレスとポート番号をServerへ通知し、自動的に管理させることができます。

Serverに自動的を管理させる場合は、「自動的に登録を依頼する」を選択してください。

「自動的に登録を依頼しない」を選択した場合は、Console上の「管理HiRDBの新規登録」コマンドを使用して手動で登録を行う必要があります。

· 「自動的に登録を依頼する」 | : | 手順14.へ進みます。
· 「自動的に登録を依頼しない」 | : | 手順17.へ進みます。

14. Rocket Punch機能の時間間隔設定。

Serverに情報を通知する時間の間隔を入力してください。

設定範囲は((1～30/分))で、デフォルトの値は<<1>>となっています。

15. Rocket Punch機能の発信先を設定。

Rocket Punch機能を使用して自動管理させるServerの情報を入力してください。

ServerをインストールしたサーバマシンのIPアドレスとポート番号を入力します。

ポート番号の設定範囲は((5001～65534))です。Serverのポート番号をデフォルトの値にした場合は<<20291>>を使用します。

手順17.へ進みます。

16. システムマネジャ (MGR) のIPアドレスとポート番号を設定。

システムマネジャ (MGR) にインストールしたAgentのIPアドレス及びポート番号を入力してください。

システムマネジャ (MGR) がスタンバイ型系切り替え構成を使用している場合は、現用系ユニットの静的なIPアドレスを指定してください。

17. 認可識別子の設定。

管理するHiRDBシステムでDBの操作権限をもつ認可識別子及びパスワードを指定してください。

認可識別子は((最大8文字))、パスワードは((最大30文字))となっています。

認可識別子およびパスワードをダブルコーテーションで囲む必要はありません。入力した文字列の大文字と小文字は区別されます。

ここで指定した認可識別子とパスワードはよく確認して次の手順へ進んでください。

設定した値に誤りが含まれていた場合は、HiRDBの操作が正常に動作しません。

18. Windowsファイアウォール例外リストの登録。

Agentをインストールするマシンが、Windwos XP SP2以降、Windows Server 2003 SP1以降、Windows Vistaの場合にWindwosファイアウォールを「有効」に設定していると、ネットワークの制限によりHiRDB CMが正しく機能しません。本画面で例外登録を行うと、ファイアーウォールを使用していても、HiRDB CMを正しく起動することができます。

本画面では、Windowｓファイアウォールを「有効」にしている場合は、「Windowsファイアウォール例外リストへ登録する。」を選択してください。Windowsファイアーウォールを無効に設定している場合は、「Windowsファイアウォール例外リストへ登録しない。」を選択してください。

19. バックアップ装置の選択。

管理するHiRDBシステムが使用しているバックアップ装置を選択します。

NetBackup連携機能を使用しているHiRDBシステムにおいて、このAgentをインストールしているサーバマシンがNetBackupクライアントホストとして使用されている場合は、「NetBackup」を選択してください。NetBackupクライアントホストではない場合は、「NetBackup」を選択する必要はありません。

NetBackup連携機能を使用しない場合は、何も選択する必要はありません。

なお、次の手順に進むためには、NetBackupマスタサーバにNetBackup用Agentをインストールしている必要があります。NetBackup用Agentのインストールを行っていない場合は、先にNetBackup用Agentのインストールをしてください。

· 「NetBackup」を使用する | : | 手順20.へ進みます。
· 「NetBackup」を使用しない | : | 手順22.へ進みます。

20. NetBackup用Agentのマスタサーバの情報を設定。

NetBackupマスタサーバに組み込んだNetBackup用AgentのIPアドレスとポート番号を入力してください。

ポート番号の設定範囲は((5001～65535))です。NetBackup用Agentのポート番号をデフォルトの値にした場合は<<20293>>を使用します。

21. NetBackupクライアント情報を入力。

NetBackupクライアントのハードウェアとOS情報を選択してください。「その他」を選択した場合は、入力を促す画面が表示されます。

22. インストール内容を確認して「次へ」をクリック。

HiRDB Control Manager - Agentのインストールを開始します。

23. 「完了」ボタンをクリック。

ファイルのコピーが終了すると、サーバマシンの再起動が必要となります。

ドライブからCDを取り出し、「完了」ボタンをクリックして再起動をしてください。

サーバマシンの再起動を行った後は、サービスのアカウントを設定します。

24. サービスのアカウントを設定。

[コントロールパネル]の「管理ツール」にある「サービス」を起動し、「HiRDB Control Manager - Agent <識別子>」の状態を確認します。サービスの状態が開始の場合は、停止してください。

「HiRDB Control Manager - Agent <識別子>」の[プロパティ]を起動し、ここで管理するHiRDBと同様のアカウントを設定します。

[ログオン]ページを開き、ラジオボタン「アカウント」を選択します。選択すると、「ユーザ名」と「パスワード」及び「パスワードの確認入力」の入力が可能となりますので、各項目を管理するHiRDBと同様のアカウントを設定してください。

入力が終了したら「適用」ボタンでサービスのプロパティの更新を行い、[プロパティ]を閉じます。

サービス「HiRDB Control Manager - Agent <識別子>」を開始します。

l アンインストール

<前提条件>

· アンインストールを行うAgentで管理しているHiRDBシステムが、Serverに登録されている場合は「管理HiRDBの解除」コマンドで、Serverからの管理を解除してください。

· Agentのサービスが停止していなければなりません。[サービス]から「HiRDB Control Manager - Agent <識別子>」の状態を確認し、開始している場合は停止を行ってください。

1. アンインストールの実行。

[コントロールパネル]の[アプリケーションの追加と削除]を使用して、「HiRDB Control Manager - Agent <識別子>」の削除を行ってください。

アンインストール後に再度インストールする場合には、アンインストール後に一旦サーバマシンを再起動してからインストールをしてください。

<注意事項>

· Agentアンインストール後はインストールディレクトリにディレクトリやファイルが残る場合があります。

このような場合は手動で該当するディレクトリやファイルを削除してください。同じディレクトリへ再度Agentをインストールする場合、アンインストール後のディレクトリやファイルが残っているとインストールが実行できません。


HiRDB Control Manager - Agent NetBackup

インストール/アンインストール方法

HiRDB Control Manager - Agent NetBackup

ここではHiRDB Control Manager - Agent NetBackupのインストール/アンインストール方法をWindowsとUNIXに分けて説明します。

「NetBackup用Agent」はNetBackup連携機能を使用する場合に、NetBackupマスタサーバをインストールしたサーバマシンにインストールしてください。

NetBackup連携機能を使用しない場合は、インストールは不要です。

また、NetBackup用Agentは通常Agentのインストールを行う前に、インストールを行う必要があります。

HiRDB Control Manager - Agent NetBackupのOSに応じて、以下のリンクを参照してください。

なお、Windows(IPF)、Windows Vista、Windows Server 2008、HP-UX(IPF)、Linux(IPF)、および、Solaris10では、NetBackup用Agentはサポートされていません。

§ Windows

Windows

§ HP-UX

HP-UX/Linux/AIX/Solaris


HiRDB Control Manager - Agent NetBackup(HP-UX)

インストール/アンインストール方法

UNIX HiRDB Control Manager - Agent NetBackup

UNIX HiRDB Control Manager - Agent NetBackupのインストール/アンインストール方法を説明します。

UNIX版のHiRDB Control Manager - Agent NetBackupでは、インストール後にセットアップコマンドを実行することにより、Agentの設定が完了します。インストールとあわせて、セットアップコマンドについても以下で説明します。

NetBackup連携機能を使用しない場合は、インストールは不要です。

§ インストール/セットアップ

§ アンセットアップ/アンインストール

l インストール/セットアップ

HiRDB Control Manager - Agent NetBackupは、VERITAS NetBackupマスタサーバの稼動するサーバマシンにインストールします。

<前提条件>

· Agentでは1つのポート番号を使用します。なお、通常Agentを同じサーバマシンにインストールする場合は、2つのポート番号を用意してください。

他アプリケーションと競合しないように、インストールする前にはポート番号を確認してください。デフォルトでは<<20293>>を使用します。

· Agentのインストールおよびセットアップはスーパーユーザ （id：root） のみ行うことができます。実行時にはスーパーユーザになる必要があります。

1. Agentのインストール。

各OS毎のCM Agentリリースノートに従い、該当マシンへAgentを組み込んでください。

既に最新のAgentがインストールされている場合には、この作業は必要ありません。2のセットアップコマンドを実行してください。

2. セットアップコマンドの実行。

スーパーユーザで次のコマンドを実行します。

/opt/hirdbCMA/bin/cmasetup NetBackupインストールディレクトリ

· NetBackupインストールディレクトリ

サーバマシンで稼動しているVERITAS NetBackupインストールディレクトリを絶対パスで指定してください。

本パラメータは必須です。

コマンドを実行すると、対話形式により以下のパラメータの入力を求められます。

· Agentの種別

セットアップするAgentの種別を選択します。

ここでは、「N：NetBackup Agent」を指定してください。

Solaris版NetBackup用Agentを使用する場合、OSがSolaris8、またはSolaris9である必要があります。Solaris10ではNetBackup用Agentをサポートしていません。

· AgentをインストールするIPアドレス

このNetBackup用Agentが、各通常Agentからの要求を受け付けるために使用するIPアドレスを10進ドット記法で指定してください。

通常Agentが稼動するマシン上から通信できるIPアドレスを指定する必要があります。

本パラメータは必須です。

· Agentの使用するポート番号

このNetBackup用Agentが、各通常Agentからの要求を受け付けるために使用するポート番号を指定してください。

設定範囲は((5001～65535))です。当該マシン内で使用されていないポート番号を指定する必要があります。

本パラメータは必須です。ポート番号を入力しないで[Enter]キーを押した場合は、<<20293>>が仮定されます。

· inetdデーモンのサービス名

NetBackup用Agentは、各通常Agentからの要求を受け付けるためにinetdデーモンを使用します。inetdがこのNetBackup用Agentを識別するためのサービス名称を指定してください。

このサービス名称は、/etc/servicesファイルに既に記述されているサービス名称と重複しない半角英数字のみを使用した文字列を((12文字以内))で指定する必要があります。

本パラメータは必須です。

指定されたサービス名称は、/etc/servicesおよび/etc/inetd.confに次のサービス名称として登録されます。

・ サービス名称_tcp

Linuxではinetdデーモンの代わりにxinetdデーモンを使用します。

設定の詳細については、各OS毎のCM Agentリリースノートを参照してください。

<注意事項>

· パラメータの入力は[Enter]キーにより終了してください。

· セットアップコマンドでは入力されたパラメータの文字列や値のチェックは行いません。入力値には十分注意してください。

入力を誤った場合は、アンセットアップコマンド実行後、再度セットアップコマンドを実行してください。

l アンインストール

<前提条件>

· アンインストールはスーパーユーザ （id：root） のみ行うことができます。実行時にはスーパーユーザになる必要があります。

1. アンセットアップコマンドの実行。

スーパーユーザで次のコマンドを実行します。

/opt/hirdbCMA/bin/cmasetup -d NetBackupインストールディレクトリ

· NetBackupインストールディレクトリ

サーバマシンで稼動しているVERITAS NetBackupインストールディレクトリを絶対パスで指定してください。

本パラメータは必須です。

コマンド実行後は、必要に応じて各OSのソフトウェア添付資料に記載されている操作を行ってください。

2. Agentのアンインストール。

各OSのソフトウェア添付資料に従い、該当マシンからAgentを削除してください。

<注意事項>

· アンセットアップをしていない、稼動中のAgentが存在するサーバマシンでアンインストールを実行すると、稼動している他のAgentが正常に動作しなくなります。アンインストール時には、該当マシン上で他のあらゆるAgentがアンセットアップされていることを確認してから実行してください。


HiRDB Control Manager - Agent NetBackup(Windows)

インストール/アンインストール方法

Windows HiRDB Control Manager - Agent NetBackup

Windows HiRDB Control Manager - Agent NetBackupのインストール/アンインストール方法を説明します。

NetBackup連携機能を使用しない場合は、インストールは不要です。

§ インストール

§ アンインストール

l インストール

<前提条件>

· NetBackup用Agentでは1つのポート番号を使用します。通常Agent、XDM/RD用Agentを同じサーバマシンにインストールする場合は、インストール数のポート番号を用意してください。

他アプリケーションと競合しないように、インストールする前にはポート番号を確認してください。デフォルトでは<<20293>>を使用します。

· Server及びAgentのインストール終了後は、サーバマシンの再起動が必要となります。Server及びAgentのインストールを行う前に、全てのアプリケーションを終了させてください。

· NetBackup連携機能を使用する場合は、通常Agentの前にNetBackup用Agentをインストールしてください。

1. セットアッププログラムの起動。

CDをドライブに装着し、エクスプローラを使ってCDドライブへ移動します。その中にある「SETUP.EXE」を実行するとセットアッププログラムが起動しますので、画面の指示に従ってインストールをしてください。

2. Agent種別の選択。

HiRDB Control Manager - Agentの種別を選択します。

ここでは「NetBackup用Agent」を選択してください。

3. ユーザ情報の設定。

名前と会社名を入力してください。

4. AgentをインストールするサーバマシンのIPアドレスとポート番号を設定。

AgentをインストールするサーバマシンのIPアドレス及びポート番号を入力してください。ポート番号の設定範囲は((5001～65535))の間で入力できます。

ポート番号は他アプリケーションと競合しないように注意してください。

「通常Agent」と「NetBackup用Agent」は両アプリケーションともデフォルトでは<<20293>>を使用します。

両アプリケーションを同一サーバマシンにインストールする際に、どちらもデフォルトポート番号を使用すると競合し、アプリケーションが正常に動作しません。

したがって、両アプリケーションを同一サーバマシンにインストールする場合は、競合しないポート番号を設定してください。

5. NetBackup用Agentのインストール先を選択。

NetBackup用AgentはNetBackupマスタサーバのインストールディレクトリ下にインストールします。

ここで、NetBackupマスタサーバのインストールディレクトリを指定してください。

例 : c:\Program Files\VERITAS\NetBackup

6. インストール内容を確認して「次へ」をクリック。

HiRDB CM - Agent NetBackupのインストールを開始します。

7. 「完了」ボタンをクリック。

ファイルのコピーが終了すると、サーバマシンの再起動が必要となります。

ドライブからCDを取り出し、「完了」ボタンをクリックして再起動をしてください。

l アンインストール

<前提条件>

· Agentのサービスが停止していなければなりません。[サービス]から「HiRDB CM - Agent NetBackup」の状態を確認し、開始している場合は停止を行ってください。

1. アンインストールの実行。

[コントロールパネル]の[アプリケーションの追加と削除]を使用して、「HiRDB CM - Agent NetBackup」の削除を行ってください。

アンインストール後に再度インストールする場合には、アンインストール後に一旦サーバマシンを再起動してからインストールをしてください。

<注意事項>

· Agentアンインストール後はインストールディレクトリにディレクトリやファイルが残る場合があります。

このような場合は手動で該当するディレクトリやファイルを削除してください。同じディレクトリへ再度Agentをインストールする場合、アンインストール後のディレクトリやファイルが残っているとインストールが実行できません。


HiRDB Control Manager - Agent XDM/RD

インストール/アンインストール方法

HiRDB Control Manager - Agent XDM/RD

ここでは、HiRDB Control Manager - Agent XDM/RDのインストール/アンインストール方法を説明します。

「XDM/RD用Agent」はXDM/RD情報を管理する場合に、Windowsマシンへインストールしてください。

本AgentはHiRDB Control Manager - Agentバージョン03-00以前のHiRDB Control Manager - Agentに同梱されています。

HiRDB Control Manager - Agentバージョン04-00には、同梱されていません。

また、HiRDB Control Manager - Agentバージョン08-00以降のHiRDB Control Manager - Agentには、HiRDB Control Manager - Agentバージョン03-00-/Bの「XDM/RD用Agent」が同梱されています。

XDM/RD情報を管理しない場合は、インストールは不要です。

なお、Windows(IPF)、Windows Vista、Windows Server 2008、および、UNIX系OSでは、XDM/RD用Agentはサポートされていません。

§ Windows

<注意事項>

· XDM/RD用Agentは、一部の表示コマンドのみをサポートします。｢バックアップ｣｢リカバリ｣｢スケジュール｣｢システムログ管理｣等の操作はサポートしていません。

· XDM/RD用Agentをインストールすると、HiRDB CM - Agent 03-00-/BのCM Agent　XDM/RD用がインストールされます。


HiRDB Control Manager - Agent XDM/RD(Windows)

インストール/アンインストール方法

Windows HiRDB Control Manager - Agent XDM/RD

Windows HiRDB Control Manager - Agent XDM/RDのインストール/アンインストール方法を説明します。

§ インストール

§ アンインストール

l インストール

<前提条件>

· XDM/RD用Agentでは1つのポート番号を使用します。他アプリケーションと競合しないように、インストールする前にはポート番号を確認してください。デフォルトでは<<20293>>を使用します。

· Server及びAgentのインストール終了後は、サーバマシンの再起動が必要となります。Server及びAgentのインストールを行う前に、全てのアプリケーションを終了させてください。

· XDM/RD用Agentをインストールするマシン上には、HiRDBクライアントをインストールしてください。

1. セットアッププログラムの起動。

CDをドライブに装着し、エクスプローラを使ってCDドライブへ移動します。その中にある「SETUP.EXE」を実行するとセットアッププログラムが起動しますので、画面の指示に従ってインストールをしてください。

2. Agent種別の選択。

HiRDB Control Manager - Agentの種別を選択します。

ここでは「XDM/RD用Agent」を選択してください。

3. XDM/RD識別子の設定。

XDM/RD用Agentをインストールするサーバマシンで認識するための識別子を入力してください。この識別子はサーバマシン内で一意である必要があります。

識別子には4文字以内の半角英数字を使用できます。

4. ユーザ情報の設定。

名前と会社名を入力してください。

5. AgentをインストールするマシンのIPアドレスとポート番号を設定。

AgentをインストールするサーバマシンのIPアドレス及びポート番号を入力してください。

ポート番号の設定範囲は((5001～65535))です。Agentの値をデフォルトにした場合は、<<20293>>を使用します。

ポート番号は他アプリケーションと競合しないように注意してください。

6. Rocket Punch機能使用の選択。

このAgentのIPアドレスとポート番号をServerへ通知し、自動的に管理させることができます。

Serverに自動的に管理させる場合は、「通知する」を選択してください。

「通知しない」を選択した場合は、Console上の「管理HiRDBの新規登録」コマンドを使用して手動で登録を行う必要があります。

· 「通知する」 | : | 手順7.へ進みます。
· 「通知しない」 | : | 手順9.へ進みます。

7. Rocket Punch機能の時間間隔設定。

Serverに情報を通知する時間の間隔を入力してください。

なお、設定範囲は((1～30/分))の間で、デフォルトは<<1>>となっています。

8. Rocket Punch機能の発信先を設定。

Rocket Punch機能を使用して自動管理させるServerの情報を入力してください。

ServerをインストールしたサーバマシンのIPアドレスとポート番号を入力します。

ポート番号の設定範囲は((5001～65534))です。Serverのポート番号をデフォルトの値にした場合は<<20291>>を使用します。

9. DBコネクションサーバIPアドレスとサーバスケジュール番号を設定。

DBコネクションサーバへ接続するため、DBコネクションサーバ側のIPアドレスを指定して下さい。

また、DBコネクションサーバのコントロール空間起動制御文およびサーバ空間起動制御文のSCHEDULENOオペランドに指定されているサーバスケジュール番号を指定してください。（SCHEDULENOオペランドを省略した場合はサーバスケジュール番号（ポート番号）に40179が仮定されています。）

10. XDMサブシステム識別子の設定。

XDM/BASEシステム定義のXDM/RDのサブシステム定義のIDオペランドに指定されているサブシステム識別子を指定してください。

11. XDM/RDノード名称の設定。

XDM/BASEシステム定義のXDM/RDのサブシステム定義のNODE NAMEオペランドに指定されているXDM/RD E2のRDノード名称を指定してください。

12. 認可識別子の設定。

管理するXDM/RDシステムでDBの操作権限をもつ認可識別子及びパスワードを指定してください。

何も指定されなかった場合には、認可識別子/パスワードともに<<CM>>が仮定されます。

ここで指定した認可識別子とパスワードはよく確認して次の手順へ進んでください。

設定した値に誤りが含まれていた場合は、XDM/RDの操作が正常に動作しません。

13. XDM/RD用Agentのインストール先を選択。

XDM/RD用Agentは任意のインストールディレクトリ下にインストールします。

ここで、任意のインストールディレクトリを指定してください。

デフォルトのインストールディレクトリは、「c:\Program Files\HITACHI\hirdbCMA\CMAgent」です。

14. インストール内容を確認して「次へ」をクリック。

HiRDB CM - Agent XDM/RDのインストールを開始します。

15. 「完了」ボタンをクリック。

ファイルのコピーが終了すると、サーバマシンの再起動が必要となります。

ドライブからCDを取り出し、「完了」ボタンをクリックして再起動をしてください。

l アンインストール

<前提条件>

· XDM/RD用Agentのサービスが停止していなければなりません。[サービス]から「HiRDB Control Manager - Agent XDMRD <識別子>」の状態を確認し、開始している場合は停止を行ってください。

1. アンインストールの実行。

[コントロールパネル]の[アプリケーションの追加と削除]を使用して、「HiRDB Control Manager - Agent XDMRD <識別子>」の削除を行ってください。

アンインストール後に再度インストールする場合には、アンインストール後に一旦サーバマシンを再起動してからインストールをしてください。

<注意事項>

· Agentアンインストール後はインストールディレクトリにディレクトリやファイルが残る場合があります。

このような場合は手動で該当するディレクトリやファイルを削除してください。同じディレクトリへ再度Agentをインストールする場合、アンインストール後のディレクトリやファイルが残っているとインストールが実行できません。


HiRDB Control Manager - Console

インストール/アンインストール方法

HiRDB Control Manager - Console

ここでは、HiRDB Control Manager - Consoleのインストール/アンインストール方法を説明します。

§ インストール

§ アンインストール

l インストール

<前提条件>

· Consoleをインストールする前に、ServerをインストールしたサーバマシンのIPアドレス又はホスト名とServerが使用するポート番号を確認してください。Consoleのインストール時に必要です。

1. セットアッププログラムの起動。

CDをドライブに装着し、エクスプローラを使ってCDドライブへ移動します。その中にある「SETUP.EXE」を実行するとセットアッププログラムが起動しますので、画面の指示に従ってインストールをしてください。

2. 接続するServerのIPアドレス又はホスト名の設定。

このConsoleが接続するServerのIPアドレス又はホスト名を入力してください。

この設定値は、インストール後にConsoleログイン画面で変更することができます。

3. 接続先ポート番号の設定。

このConsoleが接続するServerのポート番号を入力してください。ポート番号は((5001～65535))の間で入力できます。

なお、Serverのデフォルトポート番号は<<20291>>です。

この設定値は、インストール後にConsoleログイン画面で変更することができます。

4. タイムアウトの設定。

Consoleから行う1操作に対する待ち時間を設定してください。

この値は、管理するHiRDBシステムの規模を考慮して設定してください。

なお、設定範囲は((60～3600/秒))の間で、デフォルトは<<300>>となっています。

この設定値は、インストール後にConsoleメイン画面の[オプション]で変更することができます。

5. インストール内容を確認して「次へ」をクリック。

HiRDB Control Manager - Consoleのインストールを開始します。

6. 「完了」ボタンをクリック。

ファイルのコピーが終了したら、ドライブからCDを取り出し、「完了」ボタンをクリックしてください。

<注意事項>

· Console をインストールする場合、Serverは、Consoleと同一バージョンにする必要があります。Consoleバージョンと異なるバージョンのServerには接続できません。

l アンインストール

1. アンインストールの実行。

[コントロールパネル]の[アプリケーションの追加と削除]を使用して、「HiRDB Control Manager - Console」の削除を行ってください。


HiRDB Control Manager - Server_Windows

インストール/アンインストール方法

Windows HiRDB Control Manager - Server

ここでは、Windwos版　HiRDB Control Manager - Serverのインストール/アンインストール方法を説明します。

§ インストール

§ アンインストール

l インストール

<前提条件>

· Serverでは2つの連続したポート番号を使用します。

他アプリケーションと競合しないように、インストールする前にはポート番号を確認してください。なお、デフォルトでは<<20291～20292>>の番号を使用します。

· Server及びAgentのインストール終了後は、サーバマシンの再起動が必要となります。よって、Server及びAgentのインストールを行う前は、全てのアプリケーションを終了させてください。

· 上書きインストールを行う場合は、既存Serverのサービスを停止させてから行ってください。なお、上書きインストールを実行すると既存Serverが持つ情報が全て引き継がれます。

· Serverは、Console、Agentと通信を行うために、Serverインストール時に指定したIPアドレスを使用します。インストール後にこのIPアドレスが変更されると、Console、Agentとの通信ができなくなります。Serverインストール前に当該マシンのIPアドレスを正しく設定してください。

インストール後にIPアドレスが変更された場合は、[付録] > [HiRDB CMで使用するIPアドレスを変更する方法]を参照し、再度IPアドレスの設定を行ってください。

1. セットアッププログラムの起動。

CDをドライブに装着し、エクスプローラを使ってCDドライブへ移動します。その中にある「SETUP.EXE」を実行するとセットアッププログラムが起動しますので、画面の指示に従ってインストールをしてください。

2. IPアドレスの設定。

ServerがAgentとの送受信で使用するIPアドレスを指定します。

3. 管理者パスワードの設定。

HiRDB CMに接続するための管理者用パスワードを入力してください。

パスワードは((最大64文字))までの半角英数字のみ指定できます。なお、英字の場合は大文字小文字の区別を行います。

4. 一般ユーザパスワードの設定。

HiRDB CMに接続するための一般ユーザ用パスワードを入力してください。

パスワードは((最大64文字))までの半角英数字のみ指定できます。なお、英字の場合は大文字小文字の区別を行います。

なお、一般ユーザのパスワードと管理者のパスワードを同一のものにすることはできません。

5. 接続ポート番号の設定。

ConsoleがServerに接続する時に使用するポート番号を入力してください。設定範囲は((5001～65535))の間で入力できます。

このポート番号は他アプリケーションと競合しないように注意してください。

なお、デフォルトでは<<20291>>です。

6. 最大接続数の設定。

ConsoleがServerに接続できる最大数を入力してください。

ここで指定した数値より多いConsoleの接続は出来ません。HiRDB CMを使用するユーザの人数を考慮して設定してください。

なお、設定範囲は((1～10))の間で、デフォルトは<<2>>です。

7. Agent自動探索機能使用の選択。

同一セグメント内に存在するデフォルトポート番号※を使用しているAgentを自動的に登録します。

Agentの自動探索を行う場合は、「自動探索を行う」を選択してください。

デフォルトは、「自動探索を行わない。」です。

※(Agentのデフォルトポート番号は<<20293>>です。詳細はAgentのインストール/アンインストール方法を参照してください。)

8. 管理情報規模の選択。

HiRDB CMで管理するHiRDBシステム群の規模を選択してください。

小規模(標準)：以下の情報量についての条件を全て満たす場合に選択してください。

· 管理するHiRDBシステムが9システム以下

· 管理対象HiRDBシステムの持つRDエリア総数が5000個以下

· 管理対象HiRDBシステムの持つ表/インデクス総数が5000以下（分割数分を含む）

大規模：小規模（標準）で管理できる値を越える場合に選択してください。また、HiRDB CMで管理対象として登録後にHiRDBシステムが小規模（標準）で管理できる値を越える可能性がある場合に選択してください。大規模設定では、小規模設定の約2倍の情報まで管理することができます。

9. 管理情報自動更新の設定。

管理情報の自動更新（管理対象HiRDBシステム情報の自動収集）を行うかを設定します。自動更新を行う場合、管理HiRDBに定期的に負荷がかかる場合があります。

「設定しない。」を選択した場合、自動収集を行いません。

「設定する。」を選択した場合、デフォルトの値で自動収集を行います.。

この値は、インストールが終了した後、[メニューバー] > [オプション] > [管理情報更新間隔の変更]画面から設定値を変更することができます。[解説編] > [HiRDB CMが管理する情報] の「管理情報更新間隔の設定」に記載した設定基準を参考に、デフォルト値から変更を行ってください。

10. Windowsファイアウォール例外リストの登録。

Serverをインストールするマシンが、Windwos XP SP2以降、Windows Server 2003 SP1以降、Windows Vista、Windows Server 2008の場合にWindwosファイアウォールを「有効」に設定していると、ネットワークの制限によりHiRDB CMが正しく機能しません。本画面で例外登録を行うと、ファイアーウォールを使用していてもHiRDB CMを正しく起動することができます。

本画面では、Windowｓファイアウォールを「有効」にしている場合は、「Windowsファイアウォール例外リストへ登録する。」を選択してください。Windowsファイアーウォールを無効に設定している場合は、「Windowsファイアウォール例外リストへ登録しない。」を選択してください。

11. CM - Web Console使用の選択。

WebブラウザからCM - Web Consoleを使用してServerへ接続を行う場合に選択します。

  JP1/IMの拡張機能設定で「統合機能メニュー」「イベントモニタ」からの「モニタ操作画面」機能を使用する場合も、この設定が必要になります。

「CM - Web Consoleを使用する」を選択した場合は、次の項目を入力してください。

ユーザ名：CM - Web ConsoleからHiRDBシステムの運用操作を行うための画面を開く際に使用するユーザ名を指定してください。

パスワード：CM - Web ConsoleからHiRDBシステムの運用操作を行うための画面を開く際に使用するパスワードを指定してください。

パスワード確認入力：「パスワード」に入力した値と同じものを再度入力してください。

12. インストール内容を確認して「次へ」をクリック。

HiRDB Control Manager - Serverのインストールを開始します。

13. 「完了」ボタンをクリック。

ファイルのコピーが終了すると、サーバマシンの再起動が必要となります。

ドライブからCDを取り出し、「完了」ボタンをクリックして再起動をしてください。

l アンインストール

<前提条件>

· アンインストールを行うServerで管理しているHiRDBシステムが存在する場合は、「管理HiRDBの解除」コマンドで、Serverからの管理を解除してください。

· Serverのサービスが停止していなければなりません。[サービス]から「HiRDB Control Manager - Server」の状態を確認し、開始している場合は停止を行ってください。

· CM - Web Consoleを使用している場合、TomcatまたはCosminexusからCM - Web Consoleの登録を解除して下さい。

· JP1/AJS2、JP1/IM、JP1/IM-CM連携を行っている場合は、Serverアンインストール前に必ず、すべての連携設定を解除してください。

· Serverインストールフォルダ下にユーザ独自のファイルおよびフォルダを作成している場合は、アンインストール前にそれらのファイルを退避してください。ServerをアンインストールするとServerをインストールしたフォルダ下のすべての情報が削除されます。

1. アンインストールの実行。

[コントロールパネル]の[アプリケーションの追加と削除]を使用して、「HiRDB Control Manager - Server」の削除を行ってください。

アンインストール後に再度インストールする場合には、アンインストール後に一旦サーバマシンを再起動してからインストールをしてください。

<注意事項>

· Serverアンインストール後はインストールディレクトリにディレクトリやファイルが残る場合があります。

このような場合は手動で該当するディレクトリやファイルを削除してください。同じディレクトリへ再度Serverをインストールする場合、ディレクトリやファイルが残っているとインストールが実行できません。

· Serverのアンインストールを行うと、管理している全てのカタログ及びスケジュール情報が削除されます。それらの情報は、再利用することはできません。


Agent自動探索機能

Server開始時に同一セグメント内でデフォルトポート番号を使用するAgentに対し、自動的に登録処理を行う機能です。Agentで管理するHiRDBが、まだ、どのServerにも登録されていない場合に限り、このHiRDBをServerに登録することができます。

この機能はServer開始後5分間行います。

登録処理が終了するとConsoleから、Agent自動探索機能によって登録されたHiRDBを運用できるようになります。

<前提条件>

· 自動探索機能の対象となるAgentは同一セグメント内にあるデフォルトポート番号<<20293>>を使用するAgentのみです。

別セグメント内のサーバマシンにインストールしたAgentで管理するHiRDBやデフォルト以外のポート番号を使用しているAgentで管理するHiRDBは、AgentのRocket Punch機能を使用してServerへ登録するか、あるいはConsoleから[管理HiRDBの新規登録]コマンドを実行して登録してください。

<注意事項>

· ServerへのHiRDB登録処理には数分ほど時間がかかります。Server開始後、直ちにConsoleを起動してもHiRDBシステムは表示されません。時間をおいてから再度Consoleを起動してください。


一般ユーザパスワード

HiRDB Control Managerの全機能のうち、管理HiRDBの状態変更を伴わない機能のみを使用できるログインユーザ用のパスワードです。


インナレプリカ

複製したデータ（レプリカ）を元のデータベースとは異なる別のデータベースとして扱うための機能です。


影響分散スタンバイレス型系切り替え

  障害発生時に障害ユニット内のバックエンドサーバへの処理要求を、複数の稼働中ユニットに分散して実行させる機能を影響分散スタンバイレス型系切り替え機能といいます。影響分散スタンバイレス型系切り替え機能では、待機用サーバマシン，又は待機ユニットを準備する必要はなく、システムリソースを効率的に利用できます。障害発生後、障害ノードのサーバ処理を代行するユニットでは処理負荷が増えるため，トランザクション処理性能に影響を及ぼすことがあります。ただし，複数のユニットが障害ユニット内サーバへの処理要求を分担して実行することで、ユニット当たりの負荷上昇を抑え、システムの性能劣化を軽減します。


オリジナルRDエリア

インナレプリカ機能で、複製したデータ（レプリカ）を作成するときにレプリカの基となるRDエリアのことです。


インナレプリカグループ

同名の表・インデクスが存在するオリジナルとレプリカのRDエリアのまとまりのことです。


アンロードログファイル

システムログファイルの内容 (システムログ) を、pdlogunldコマンドでアンロードして作成したファイルのことです。


ウィザード

ガイダンスに従って情報を入力していくことで、的確な操作を実行できる機能のことです。コマンドの知識があまり無くても、難解なコマンドを簡単に実行できるように設計されています。そのかわり、詳細なオプションは指定できません。


HiRDB管理者

システム管理者用のユーザIDでOSにログインしたユーザのうち、HiRDBを操作する権利があるユーザのことです。HiRDBのコマンドを実行する権限があり、HiRDBのディレクトリ及びファイルの所有者です。


HiRDBファイル

HiRDBの情報を格納するための、HiRDB専用のファイルのことです。HiRDBファイルは、HiRDBファイルシステム領域上の連続した複数のセグメントから構成されます。HiRDBファイルには、表、インデクス、障害発生時にシステムの状態を回復させるのに必要な情報などが格納されます。


HiRDBファイルシステム領域

システムログファイル、シンクポイントダンプファイル、ステータスファイル及びRDエリアを作成する領域のことです。また、HiRDBファイルシステム領域内に作成されるファイルをHiRDBファイルといいます。HiRDBファイルシステム領域は、システムファイル用、作業表用ファイル用及びRDエリア用のように、用途ごとに作成します。


バックエンドサーバ

バックエンドサーバ (BES: Back　End　Server) は、フロントエンドサーバからの実行指示に従い、データベースへのアクセス、排他制御、及び演算処理などをします。また、検索結果に対してソート、マージ、及び結合処理をします。

バックエンドサーバは、HiRDB/パラレルサーバに1つ又は複数設定できます。


フロントエンドサーバ

フロントエンドサーバ (FES: Front　End　Server) は、ユーザが実行するSQLからデータベースへのアクセス方法を決定し、バックエンドサーバに実行内容を指示します。

フロントエンドサーバは、HiRDB/パラレルサーバに1つ又は複数設定できます。


ファイル最大保持数

HiRDB CMで管理するファイルの最大数のことです。この最大保持数を超えて管理しようとした場合、HiRDB CMは更新日時が古いファイルから管理を解除していきます。


IPアドレスを引き継ぐ構成

スタンバイ型系切り替え構成の中でも、現用系と予備系のユニットが同じIPアドレスを使用する構成のことです。主に、エイリアスIPアドレスを使用してIPアドレスを切り替えます（一方を停止して，もう一方を起動します）。


管理者パスワード

HiRDB Control Managerの全機能を使用できるログインユーザ用のパスワードです。


カタログ

一連の操作を記憶し、それをカタログとして登録することで何度も繰り返し実行できる、HiRDB CM独自の機能です。

カタログ登録は次のような操作の場合にお勧めします。

· 同じコマンドを繰り返し実行する、又は一連の操作が複雑である。

· コマンドの実行を時間指定したい。


カレントRDエリア

インナレプリカ機能を使用しているRDエリアで、HiRDBクライアント環境変数や運用コマンドで指定のないときには、決まったRDエリア（デフォルトのRDエリア）へアクセスします。このRDエリアを「カレントRDエリア」と呼びます。


カスタマイズ

コマンドのオプションを詳細に設定できる機能のことです。ある程度、コマンドに知識がある方に向いています。


高速系切り替え機能

高速系切り替え

待機系HiRDBのサーバプロセス及びシステムサーバをあらかじめ起動しておいて、系の切り替え時にサーバプロセス及びシステムサーバの起動処理をしない系切り替え構成のことです。　系の切り替え時にサーバプロセス及びシステムサーバの起動処理がない分、系の切り替え時間を短縮できます。


モニタモード

  系障害(ハードウェアの障害、OSの障害、電源断、クラスタソフトウェアの障害、系のスローダウン )だけを監視対象とする系切り替え機能の運用方法。

  モニタモードに対し、サーバモードの場合は、系障害のほかにサーバ障害なども監視対象とします。


マスタディレクトリ用RDエリア

ディクショナリ表、ユーザが作成した表やインデクスなどを格納するRDエリアの情報、RDエリアの登録場所(サーバ)の情報などを管理するRDエリアのことです。


NetBackup

VERITAS社のバックアップ管理製品です。データのバックアップ及びリストアを実行できます。


NetBackup連携機能

HiRDBのバックアップをNetBackup上に取得する機能です。


RDエリア

データの格納単位の1つで、1～16個のHiRDBファイルから構成されます。RDエリアには、次に示すものがあります。

· マスタディレクトリ用RDエリア

· データディクショナリ用RDエリア

· データディレクトリ用RDエリア

· データディクショナリLOB用RDエリア

· ユーザ用RDエリア

· ユーザLOB用RDエリア

· レジストリ用RDエリア

· レジストリLOB用RDエリア

· リスト用RDエリア

·ワーク用RDエリア（XDM/RDのみ）

·ワーク用RDエリア(拡張記憶装置使用)（XDM/RDのみ）

·ルーチンオブジェクト用RDエリア（XDM/RDのみ）

·SQLオブジェクト用RDエリア（XDM/RDのみ）

·一時表用RDエリア（XDM/RDのみ）

·カタログ情報用RDエリア（XDM/RDのみ）


Rocket Punch機能

Agentで管理しているHiRDBが、まだ、どのServerにも登録されていない場合に限り、Agentのサービス開始時に任意のServerへ管理登録要求を行う機能です。

Agentのサービス開始からユーザの指定した任意の時間間隔で10回までServerへ通知を行います。

Serverは要求を受け取ると、このAgentに対しHiRDBの登録処理を行います。登録処理が終了するとConsoleからこのHiRDBを運用できるようになります。

<前提条件>

· この機能を使用する際には、Agentのサービスを開始する前に管理HiRDBを起動し、管理登録要求を行うServerのサービスを開始してください。

<注意事項>

· ServerへのHiRDB登録処理には数分ほど時間がかかります。Agent開始後、直ちにConsoleを起動してもHiRDBシステムは表示されません。時間をおいてから再度Consoleを起動してください。

· Windows版のHiRDB CMにおいて、ServerとAgentを同一サーバマシンにインストールし、且つ、サービスのスタートアップの種類が「自動」である場合、サーバマシン起動後のサービス開始順序が保証されていません。そのため、Serverが開始されていない状態で先に開始したAgentから1回目の管理登録要求が通知されることがあります。Serverはこの1回目の要求を受け取ることができないため、Agentから2回目の要求が通知されるまでHiRDBの登録処理は行われません。


リスト用RDエリア

リスト用RDエリアには、ASSIGN LIST文で作成するリストを格納します。絞込み検索をする場合に、リスト用RDエリアを作成します。


レジストリ用RDエリア

レジストリ情報を管理する表 (レジストリ管理表) を格納するためのRDエリアです。レジストリ機能を使用する場合に必要です。ただし、プラグインの種類によっては、レジストリ機能を使用しないものがあります。


レジストリLOB用RDエリア

レジストリ情報を管理する表(レジストリ管理表)を格納するためのRDエリアです。レジストリ機能を使用する場合に必要です。ただし、プラグインの種類によっては、レジストリ機能を使用しないものがあります。登録されるデータの長さによって、レジストリLOB用RDエリアに格納するかどうかをシステムが自動的に決定します。また、レジストリ管理表に情報を登録したりする、操作用のストアドプロシジャもこのRDエリアに格納します。


レプリカRDエリア

インナレプリカ機能で、複製したデータ（レプリカ）となるRDエリアのことです。


自動ログアンロード機能

システムログをアンロードする運用では、HiRDB管理者がpdlogunldコマンドでアンロード待ち状態のシステムログファイルをアンロードする必要があります。このシステムログファイルのアンロード作業を自動化する機能を自動ログアンロード機能といいます。


差分バックアップ機能

差分バックアップ機能とは、前回のバックアップ取得時点からの差分情報だけをバックアップとして取得する機能です。このため、バックアップの取得処理時間を短縮できます。データベースの容量が多くてデータ更新量が少ない場合に、差分バックアップ機能の使用を検討してください。


システムマネジャ

システムマネジャ (MGR: System　Manager) は、HiRDBの開始及び終了処理を制御します。また、システム構成情報の管理やサーバの障害検出などをします。

システムマネジャは、HiRDB/パラレルサーバに1つあります。


シングルサーバ

シングルサーバ (SDS: Single　Database　Server) は、単体で動作するデータベースシステムです。データベース(表、インデクス)、データベースの情報を持つデータディクショナリ (各種のディクショナリ表)、及びシステムが使用するシステムファイル(システムログファイルなど)を管理します。


セグメント(ネットワーク)

LANなどのグループ化されたネットワークの単位のことです。


サーバモード

  系障害(ハードウェアの障害、OSの障害、電源断、クラスタソフトウェアの障害、系のスローダウン )及び、サーバ障害(HiRDB（HiRDB/パラレルサーバの場合はユニット）の異常終了、HiRDB（HiRDB/パラレルサーバの場合はユニット）のスローダウン、データベースのパス障害)を監視対象とする系切り替え機能の運用方法。

  サーバモードではモニタモードに比べて系の切り替え時間を短縮できます。


サービスIPアドレス

HiRDB/シングルサーバまたは、HiRDB/パラレルサーバのシステムマネージャが系切り替え構成を使用している場合に、HiRDB CMが使用するエイリアスIPアドレスのことです。

対象のHiRDBユニットが稼動中のマシンで有効になるようにクラスタシステムに登録しておく必要があります。


スタンバイ型系切り替え

業務処理中のHiRDBのほかに待機用のHiRDBを準備して、業務処理中のサーバマシン又はHiRDBに障害が発生した場合、待機用のHiRDBに業務処理を自動的に切り替えます。これをスタンバイ型系切り替え機能といいます。

  業務処理が中断するのは障害発生時から待機用のHiRDBに処理が切り替わるまでです。障害発生時のシステム停止時間をなるべく短くしたい場合に系切り替え機能を使用します。

  系切り替え機能は複数のサーバマシンを使用したクラスタシステムの構成で実現します。HiRDB/シングルサーバの場合はシステム単位で系を切り替えます。

  なお、業務処理中の系を実行系，待機中の系を待機系といい、系の切り替えが発生するたびに実行系と待機系が入れ替わります。また、システム構築時や環境設定時に二つの系を区別するため、最初に実行系として起動する系を現用系、待機系として起動する系を予備系といいます。系が切り替わると実行系と待機系は変わりますが、現用系と予備系は変わりません。


スタンバイレス型系切り替え

  スタンバイ型系切り替え機能とは異なり、障害が発生した場合は待機系ユニットに系を切り替えるのではなく、ほかのユニットに系を切り替えて稼働中のバックエンドサーバに処理を代行させる系切り替え構成のことです。


サブRDエリア

カレントRDエリアではない，インナレプリカグループ内のほかのRDエリアのことは「サブRDエリア」と呼びます。


シンクポイントダンプファイル

HiRDBが異常終了した場合、システムログだけで回復処理をすると、HiRDB開始からのすべてのシステムログが必要になって、回復に多大な時間が掛かります。そこで、HiRDB稼動中に一定の間隔でポイントを設けて、そのポイントで回復に必要なHiRDB管理情報を保存することで、ポイント以前のシステムログを不要にして回復時間を短縮できます。このポイントで取得するHiRDB管理情報を格納するファイルをシンクポイントダンプファイルといいます。


システムログファイル

データベースの更新履歴情報を格納するためのファイルです。一般的にはジャーナルファイルともいいます。データベースの更新履歴情報をシステムログといいます。システムログは、HiRDB又はUAPが異常終了した場合、HiRDBがデータベースを回復するときに使用します。また、データベースを回復するときの入力情報にも使用します。


論理的な関係

論理的な関係とは、以下のような状態のことをいいます。

· 表⇔インデクスの関係

· 表の横分割

· LOB用RDエリア

· 抽象データ型


物理状態

スタンバイ型系切り替えを使用しているユニットの各系のクラスタが管理している状態です。対象のユニットが使用しているクラスタシステムによって、取得する方法がことなります。

· HAモニタを使用している場合：　各系でHAモニタのmonshowコマンドによって表示される情報です。

· MS/CS+Ha Tool Kit を使用してる場合：　各系でHa Tool Kit のhateshowコマンドによって表示される情報です。

· その他のクラスタシステムを使用している場合：　HiRDBのpdls -d ha コマンドで表示される情報です。


ディクショナリサーバ

ディクショナリサーバ (DS: Dictionary　Server) は、データベースの定義情報であるデータディクショナリ (各種のディクショナリ表) を一括管理します。

ディクショナリサーバは、HiRDB/パラレルサーバに1つあります。


データディクショナリ用RDエリア

定義系SQLの解析結果を管理するディクショナリ表及びディクショナリ表のインデクスを格納するためのRDエリアのことです。


データディレクトリ用RDエリア

インデクスについての情報 (列名、データ型など) をHiRDBのデータ形式で格納するためのRDエリアです。


データディクショナリLOB用RDエリア

ストアドプロシジャ又はストアドファンクションを格納するRDエリアのことです。ストアドプロシジャ又はストアドファンクションの定義ソース格納用と、オブジェクト格納用の2つがあります。


ワイルドカード

ウィザードのエディットボックス[検索する取得対象名]などの検索機能を有する入力コントロールでは、ワイルドカード (パーセント記号 "%" とアンダースコア "_") を使用できます。使用方法を次に示します。

· パーセント記号 "%" : 0文字以上の任意の文字列の検索を行う。

· アンダースコア "_" : 任意の１文字の検索を行う。

例 | 結果
HRD% | "HRDB"、"HRD10"、"HRD1(0.0.0.0)"など
HRD_0 | "HRDB0"、"HRD10"、"HRD20"など


ユーザLOB用RDエリア

文書、画像、音声などの長大な可変長データを格納するためのRDエリアのことです。次に示すデータをユーザLOB用RDエリアに格納する必要があります。

· BLOB型を指定した列 (BLOB列)

· 抽象データ型内の、BLOB型を指定した属性

· プラグインインデクス


ユーザ用RDエリア

ユーザが作成する表とインデクスを格納するためのRDエリアのことです。


JP1/AJS2カスタムジョブ連携

JP1/AJS2連携カスタムジョブ連携

HiRDB Control Managerで作成したカタログをJP1/AJS2のカスタムジョブを使用してスケジュール・実行・実結果確認することができます。

  JP1/AJS2カスタムジョブ機能を使用したJP1/AJS2との連携構成の一例を以下の図に示します。

<注意事項>

· 1台のマシン上に複数HiRDBシステムが存在する場合、そのうちの１つのHiRDBシステムに対してのみJP1/AJS2連携機能を使用することができます。

· HiRDBシングルサーバまたは、HiRDBパラレルサーバのMGRユニットが系切り替え構成を使用している場合、スケジュールは現用系でのみ有効になります。

  [HiRDB CM AJS2/Console]画面で登録ボタンを実行するまたは、[カタログ情報]画面で[JP1/AJS2連携解除]を実行する場合は、対象HiRDBが停止している状態、もしくは、HiRDBシングルサーバまたは、HiRDBパラレルサーバのMGRユニットが現用系で実行中である必要があります。

  JP1/AJS2からのカタログ実行時刻に、HiRDBシングルサーバまたは、HiRDBパラレルサーバのMGRユニットが予備系で稼動中である場合、実行処理を行わずにエラー終了します。

スケジュール・実行・実結果確認を行う手順を以下で説明します。

１.JP1/AJS2-Viewと連携するためのHiRDB CMでの準備

HiRDB CM Consoleを起動し、メニューバーの[オプション]-[JP1/AJS2との連携]コマンドで開かれた画面から[登録]ボタンを押して登録します。

  この登録操作は、JP1/AJS2との連携状態が[非連携中]のときに1度だけ実行してください。一度連携を始めると、[登録解除]を行うまでは、常に[連携中]状態が継続されます。

２.JP1/AJS2-Agentと連携するためのHiRDB CM Agentでの準備

JP1/AJS２との連携機能を使用してジョブの実行を行う場合、HiRDBシステム上へ配置されたJP1/AJS2-AgentとHiRDB CM - Agentの連携を登録が必要です。次のJP1/Baseのコマンドを実行してJP1/AJS2-AgentとHiRDB CM - Agentの連携の登録を行って下さい。

  JP1/Baseインストールディレクトリ\bin\jbssetcnf "HiRDB CM Agentインストールディレクトリ\save\AJS2\CmAjs.env"

<注意事項>

· JP1/Baseコマンド実行後は、一旦JP1/Baseを停止して再起動を行ってください。

３.JP1/AJS2-ViewへHiRDB CMのカタログをカスタマイズジョブとして登録

JP1/AJS2-ViewでHiRDB CMのカタログ情報を扱うためには、HiRDB CMのカタログをJP1/AJS2-Viewのカスタムジョブとして登録する必要があります。

  カスタムジョブとして登録するHiRDB CMカタログは、以下の7種類です。

(1)バックアップ/差分バックアップ/ネットバックアップ カタログ

(2)リストアカタログ

(3)データロードカタログ

(4)再編成カタログ

(5)システムログファイル状態変更カタログ

(6)システムログファイルアンロードカタログ

(7)ページ解放ユティリティカタログ

  カスタムジョブを登録するには、JP1/AJS2-Viewの「カスタムジョブの登録」に次の情報を入力して「OK」ボタンを操作して登録してさい。

  JP1/AJS2-View「カスタムジョブの登録」画面の「名前」「コメント」項目には、任意の値を設定してください。操作方法の詳細は、JP1/Automatic Job Management System 2 操作ガイド　「13.9　［カスタムジョブの登録］ダイアログボックス」を参照してください。

(1)バックアップ/差分バックアップ/ネットバックアップ カタログの登録

(2)リストアカタログの登録

(3)データロードカタログの登録

(4)再編成カタログの登録

(5)システムログファイル状態変更カタログの登録

(6)システムログファイルアンロードカタログの登録

(7)空きページ解放ユティリティカタログの登録

４.HiRDB CM操作によるカタログの作成

HiRDB CM - Console上でJP1/AJS2のカスタマイズジョブとして実行する操作のカタログを作成してください。

JP1/AJS2で使用できるカタログは、次の操作で作成したカタログです。

   (1)バックアップ/差分バックアップ/ネットバックアップ 操作

(2)リカバリ操作

(3)データロード操作

(4)再編成操作

(5)システム)ログファイル状態変更操作

(6)システムログファイルアンロード操作

(7)空きページ解放ユティリティ操作

５.JP1/AJS2-Viewを使用したジョブネットの作成。

JP1/AJS２-View[ジョブシステム運用]を起動して、[ジョブネットエディタウィンドウ]で[カスタムジョブ]項目に表示されたHiRDB CMカタログアイコンを使用してジョブネットを作成することができます。[ジョブネットエディタウィンドウ]の操作方法は、JP1/Automatic Job Management System 2 操作ガイドを参照してください。

(1)[ジョブネットエディタウィンドウ]の[カスタムジョブ]から、アイコンを選択した場合に次の[詳細定義]画面が表示されます。

  HiRDB CMで作成したカタログを使用する場合は、[詳細...]ボタンを選択して[HiRDB CM AJS2/Console]画面を表示してください。

(2)[HiRDB CM AJS2/Console]画面で[システム名]を選択するとそのシステムで作成されたHiRDB CM カタログ情報の一覧が[カタログ一覧]項目に表示されます。このカタログ一覧からJP1/AJS2ジョブとして登録するカタログを1個選択してください。カタログを選択後、[カタログ詳細]表示内容を確認して[登録]ボタンを押してください。[登録]ボタンを押すと、[HiRDB CM AJS2/Console]登録内容確認画面が表示されます。

(3)[HiRDB CM AJS2/Console]登録内容確認画面の[マシン名]項目に表示されたマシン名称上で今回登録したカタログが実行されます。実行されるマシン名が正しいかを確認して[OK]ボタンを押してください。なお、[マシン名]項目に表示されたマシン名称は、(1)の[詳細定義]画面[実行ホスト]項目へ必ず指定する必要があります。

<注意事項>

· JP1/AJS2 ジョブネット登録後の各カタログ実行結果で表示される「終了コード」に「-nnnn」が表示される場合があります。このコードの詳細は、HiRDB CM メッセージ「KFPE3nnnn」を参照してください。


HiRDB Assistからの移行

<<　v04-00で廃止されました。 >>

HiRDB Assist移行ツールを実行することによりHiRDB Assistで作成した以下のファイルが、HiRDB CMに登録されます。

· バックアップファイル

· アンロードログファイル

· カタログファイル（HiRDB開始操作、終了操作、バックアップ操作、システムログのアンロード操作および状態変更、データベース作成ユティリティ、データベース再編成ユティリティ操作）

以下にHiRDB Assist移行ツールの実行方法を説明します。該当するOSを参照してください。

§ Windows版 HiRDB Assistからの移行

§ UNIX版 HiRDB Assistからの移行

<注意事項>

· HiRDB Assistで履歴用ファイルシステム領域を使用していた場合の移行はサポートされていません。

· バックアップファイルとアンロードログファイルを同じディレクトリに格納する運用をしていた場合には、データを移行できません。

· HiRDB Assistから移行したアンロードログファイルの「取得日時」は、そのシステムログファイルの現用割り当て時間になります。

· HiRDB Assistからのアンロードを行わず、自動ログアンロード機能のみを使用していたサーバについては、データを移行する必要はありません。

· HiRDB Assistからのアンロードと自動ログアンロード機能を併用していた場合には、データを移行できません。

· HiRDB Assistから移行したバックアップファイルとアンロードログファイルを使用してリカバリを行う場合は、[リカバリカスタマイズ]を使用してください。

· HiRDB AssistでカタログしたHiRDBの開始操作および終了操作はServerに登録することができますが、HiRDB CMによるカタログ操作は、サポートされていません。

· カタログ移行時は、HiRDB Assistにはないいくつかの項目に対してHiRDB CMの推奨するデフォルト値が設定されます。この値を変更する場合は、カタログ表示画面から[変更]を実行してください。

l Windows版 HiRDB Assistからの移行

<前提条件>

· 移行元のHiRDB Assistが管理しているHiRDB システムにAgentをインストールし、Serverへ登録しておいてください。

· ServerおよびAgentが起動していることを確認してください。

· バックアップファイル、アンロードログファイルの格納先をそれぞれServerへ登録しておいてください。

1. 実行ファイルを移行元のサーバマシンにコピーする。

Serverの"<インストールディレクトリ>\bin"フォルダ内の"cmconvert.exe"を見つけてください。

このファイルを、移行元のHiRDB Assistが管理しているHiRDBシステムのサーバマシンにコピーしてください。

2. コマンドプロンプトの起動。

[プログラム] - [HiRDBSingleServer <識別子>] または[HiRDBParallelServer <識別子>]からHiRDBコマンドプロンプトを起動してください。

以下のコマンドを実行し、環境変数PDDIRが正しく設定されていることを確認してください。

set

3. convertコマンドの入力。

移行するファイル種別ごとにコマンドを入力します。

<"cmconvert.exe"コピー先ディレクトリ>\cmconvert ファイル種別( { -a | -b | -c } )

· ファイル種別

-a : バックアップファイル

-b : アンロードログファイル

-c : カタログファイル

例 : "cmconvert.exe"をc:\win32app\hitachi\hirdb_s\CMAgent\binにコピーし、バックアップファイルを移行する場合

c:\win32app\hitachi\hirdb_s\CMAgent\bin\cmconvert -a

4. 実行。

ツールの指示に従って、実行してください。

移行が正常に終了されると、コマンドラインに「移行ツール終了」と表示されます。

実行後は"cmconvert.exe"と同ディレクトリにconvert.logファイルが作成されます。エラーが発生した場合は、このファイルを参照し原因を取り除いた上で再実行してください。

l UNIX版 HiRDB Assistからの移行

<前提条件>

· 移行元のHiRDB Assistが管理しているHiRDB システムにAgentをインストールし、Serverへ登録しておいてください。

· カタログファイルの保存されているWindowsマシンにConsoleをインストールしてください。

· ServerおよびAgentが起動していることを確認してください。

· バックアップファイル、アンロードログファイルの格納先をそれぞれServerへ登録しておいてください。

［バックアップファイルおよびアンロードログファイルの登録］

移行元のHiRDB Assistが管理しているHiRDBの稼動するUNIXマシン上から実行します。

1. HiRDB/シングルサーバ、もしくはHiRDB/パラレルサーバのシステムマネジャの稼動するマシンにログインする。

管理対象のHiRDBシステムの稼動するマシンにログインしてください。

以下のコマンドを実行し、

  環境変数PDDIRが正しく設定されていること。

  環境変数LAMGがSJISで設定されていること（ただしLinuxの場合は、EUC）。

を確認してください。

env

2. cmconvertコマンドの入力。

移行するファイル種別ごとにコマンドを入力します。

$PDDIR/CMAgent/util/bin/cmconvert ファイル種別( { -a | -b } )

· ファイル種別

-a : バックアップファイル

-b : アンロードログファイル

3. 実行。

ツールの指示に従って、実行してください。

移行が正常に終了されると、コマンドラインに「 { バックアップファイル | アンロードログファイル } の移行が完了しました」と表示されます。

実行後は$PDDIR/CMAgent/util/binディレクトリにconvert.logファイルが作成されます。エラーが発生した場合は、このファイルを参照し原因を取り除いた上で再実行してください。

［カタログファイルの登録］

登録するカタログファイルのあるWindowsマシン上から実行します。

1. コマンドプロンプトの起動。

[スタート] - [プログラム] - [アクセサリ]からコマンドプロンプトを起動します。

2. convertコマンドの入力。

Consoleをインストールしたドライブに移動し、以下のコマンドを入力します。

<Consoleのインストールディレクトリ>\util\cmconvert -c

3. 実行。

ツールの指示に従って、実行してください。

移行が正常に終了されると、コマンドラインに「カタログファイルの移行が完了しました」と表示されます。

実行後は<Consoleのインストールディレクトリ>\utilディレクトリにconvert.logファイルが作成されます。エラーが発生した場合は、このファイルを参照し原因を取り除いた上で再実行してください。


[ファイル/ディレクトリ一覧]

各種画面上にある[参照]ボタンをクリックすることにより、対象ホスト上のディレクトリおよびファイル情報を参照することができます。この画面を使用して、対象とするファイルを選択することができます。[参照]ボタンをクリックすると[ファイル/ディレクトリ一覧]画面が表示されます。

[ドライブ名]リストを選択することで、任意のドライブ/マウントポイントに移動することができます。また、対象システムがWindows版HiRDBの場合、ドライブ名を直接入力することができます。

<注意事項>

· XDM/RDに対する上記の操作は失敗します。

· 参照するディレクトリにリンクが設定されている場合、当該ディレクトリ下を参照できません。

· Windowsプラットフォーム上の「シュートカットキー」は、ファイルとして表示されます。

· リンクされたディレクトリまたはファイルのリンク先に実体が無い場合は表示されません。

· HiRDB CM Agentインストール時に対象となるHiRDBシステムの管理者ID(loginユーザID)がアクセス権限の無いディレクトリ下の参照はできません。

· 名称が256文字以上のディレクトリまたはファイルを参照することはできません。

· マルチバイトコードを含むディレクトリまたはファイル名称は正しく表示されないことが有ります。また、当ディレクトリ、ファイルを参照、選択しないでください。

· 表示するファイルまたは、ディレクトリのユーザID,グループIDが当該マシン上に登録されていない場合は、所有者、所有者グループが空白で表示されます。

· 表示するファイルまたは、ディレクトリの更新時間が不当な場合は、空白で表示されます。

· [デバイス情報]が取得できないシステムを対象として操作を行う場合、[ドライブ名]リストには何も表示されません。

· 系切り替え構成を使用してる場合：

表示されているホスト名は、常に現用系のホスト名となりますが、表示する内容は該当するユニットの実行系の情報が表示されます。対象ユニットが稼動していない場合は、現用系の情報が表示されます。

  [ドライブ名]リストには、常に現用系のドライブ名/マウントポイントが表示されます。


[目的別]

[目的別]コマンド

<< このコマンドは、HiRDB CM V01-00では未サポートです。

もし将来的にサポートすることになった場合、このページを使用してください。 >>

目的ごとに合ったバックアップを実行します。

このコマンドを選択すると、目的別バックアップを実行するための画面を表示します。

1. 「目的別バックアップ」を選択。

バックアップを行う目的を選びます。

2. HiRDBシステム名を選択。

リストボックス「HiRDBシステム」にHiRDB CMが管理しているHiRDBシステムの一覧が表示されていますので、処理対象が属するHiRDBシステム名を選択してください。なお、リストボックス「HiRDBシステム」は複数選択ができません。

3. 処理を行いたい対象を選択。

リストボックス「処理対象」にグループ「目的別バックアップ」で選択したラジオボタンごとのアイテムが表示されます。任意の対象を選択してください。

リストボックス「処理対象」を選択すると、リストボックス「取得対象」にバックアップを行う取得対象名が表示されます。

4. バックアップファイル名を入力する。

エディットボックス「バックアップファイル名」に任意のバックアップファイル名を入力してください。

5. 実行

· [実行]ボタンをクリック:

選択した情報を確認するための[確認]画面が表示されます。ここで、内容を確認し問題がなければ[確認]画面の[実行]ボタンをクリックしてください。バックアップの実行を行います。

· [カタログ]ボタンをクリック:

指定した情報でカタログを作成します。[カタログの登録]画面が表示されますので、エディットボックス「カタログ名」に任意の名前(英数字のみ入力可能)を入力してください。

カタログ名を入力して[OK]ボタンをクリックすると、選択した情報を確認するための[確認]画面が表示されます。ここで問題がなければ[確認]画面の[実行]ボタンをクリックしてください。カタログの登録を行います。


バックアップ カスタマイズ(取得単位)

[カスタマイズ]コマンド

バックアップ カスタマイズ (取得単位)

ここでは、バックアップ取得対象とバックアップファイル名を指定します。

[バックアップ - カスタマイズ] 取得単位タブ

1. 取得対象を指定する。

グループ「取得単位」にあるラジオボタンの中から任意の単位を選択し、コンボボックスと各リストボックスから取得対象を指定します。

· HiRDBシステム全体のバックアップを実行する場合:

グループ「取得単位」から「HiRDBシステム」ラジオボタンを選択し、コンボボックス「HiRDBシステム」から任意の対象を指定します。

· ユニット単位のバックアップを実行する場合:

グループ「取得単位」から「ユニット単位」ラジオボタンを選択します。コンボボックス「HiRDBシステム」から取得する対象が属するHiRDBシステムを選択してください。HiRDBシステムを選択すると、リストボックス「ユニット」に情報が表示されますので、任意のユニット名を指定します。

· サーバ単位のバックアップを実行する場合:

グループ[取得単位]から「サーバ単位」ラジオボタンを選択します。コンボボックス「HiRDBシステム」・「ユニット」から取得する対象が属するシステム名を選択してください。リストボックス「ユニット」で情報を選択すると、リストボックス「サーバ」に情報が表示されますので、任意のサーバ名を指定します。

· RDエリア単位のバックアップを実行する場合:

グループ「取得単位」から「RDエリア単位」ラジオボタンを選択します。コンボボックス「HiRDBシステム」・「ユニット」・「サーバ」から取得する対象が属するシステム名を選択してください。リストボックス「サーバ」で情報を選択すると、リストボックス「RDエリア」に情報が表示されますので、任意のRDエリア名を指定します。

2. バックアップファイル名を指定する。

グループ「ファイル種別」にあるラジオボタンの中から任意の種別を選択し、バックアップファイル名を指定します。

バックアップファイル名とその指定方法について、以下で説明します。

バックアップファイル名

選択したラジオボタン | 最大文字 指定数 | バックアップファイル名
通常ファイル | 1024 | (1) バックアップファイルを格納する「ホスト名」を選択する。 (2) 「バックアップ取得先」ボタンをクリック。 [バックアップファイル格納先の指定]画面が表示されますので、ここでバックアップ格納先とバックアップファイル名を指定します。 この画面については以下で説明します。 [バックアップファイル格納先の指定]画面
HiRDBファイルシステム領域 | 1024 | (1) バックアップファイルを格納する「ホスト名」を選択する。 (2) 「バックアップ取得先」ボタンをクリック。 [バックアップファイル格納先の指定]画面が表示されますので、ここでバックアップ格納先とバックアップファイル名を指定します。 この画面については以下で説明します。 [バックアップファイル格納先の指定]画面
EasyMT | 1024 | EasyMTのMTのスペシャルファイル名をコンボボックス「ホスト名」とエディットボックス「MTのスペシャルファイル名」に指定します。
EasyMT, MTguide | 1024 | MTguideが管理する装置記号名又は装置グループ名をコンボボックス「装置ホスト名」とエディットボックス「装置記号名又は装置グループ名」に指定します。
JP1/OmniBack Ⅱ | 512 | JP1/OmniBack Ⅱのディスクエージェントがあるホストをコンボボックス「ホスト名」に指定し、オブジェクト名をエディットボックス「オブジェクト名」に指定します。
NetBackup | 128 | NetBackup クライアントがあるホストをコンボボックス「ホスト名」に指定し、ポリシーをコンボボックス「ポリシー名」から指定します。

3. 他タブページ、あるいは確認画面を表示する。

他タブページで設定しなければならない情報がある場合は、任意のタブページを表示します。オプションの設定内容を確認又はバックアップを実行する場合は[確認画面へ]ボタンをクリックします。

· [取得モード]ページ

· [差分バックアップ]ページ

· [詳細設定]ページ

· [確認]ページ


バックアップ カスタマイズ(取得モード)

[カスタマイズ]コマンド

バックアップ カスタマイズ (取得モード)

ここでは、バックアップ取得モードとバックアップファイル種別に関するオプションを指定します。

[バックアップ - カスタマイズ]取得モードタブ

1. バックアップ取得モードを指定する。

グループ「取得モード」にあるラジオボタンの中から任意の取得モードを選択します。バックアップ取得モードについて、以下で説明します。

バックアップ取得モード | 説明 | リカバリ方法
参照・更新不可能モード | バックアップ取得中、バックアップ対象RDエリアの参照及び更新ができません。 | バックアップだけでデータベースをバックアップ取得時点にリカバリできます。
参照可能/更新不可能モード | バックアップ取得中、バックアップ取得対象のRDエリアの参照はできますが、更新はできません。
更新可能モード | バックアップ取得中、バックアップ取得対象RDエリアの参照及び更新ができます。 | データベースをリカバリするときに、バックアップ及びバックアップ取得直前のシンクポイントからのシステムログが必要になります。

2. ログポイント情報ファイルの出力有無を指定する。

· 「ログポイント情報の出力有無」

ログポイントに関する情報を出力するファイル名を指定します。このオプションはアンロードレスシステムログ運用をおこなう場合は必ず指定してください。

3. バックアップファイル種別ごとのオプションを指定する。

「取得単位」ページの「ファイル種別」で「EasyMT」・「EasyMT, MTguide」・「JP1/OmniBack Ⅱ」を選択している場合、次のオプションを指定します。

· バックアップファイル種別が「EasyMT」及び「EasyMT, MTguide」の場合:

グループ「EasyMT」のオプションを指定できます。

§ 「属性定義ファイル名」

EasyMT用のMT属性定義ファイルのファイル名を指定します。

§ 「入出力バッファ面数」

EasyMT用の入出力バッファ面数を指定します。指定値を大きくすれば性能が向上しますが、その分メモリ所要量も大きくなります。設定範囲は((1～255))の間で指定することができます。

§ 「MTのボリューム名」

バックアップを取得するMTのボリューム名を指定します。((最大6文字))まで指定可能で、カンマ","で区切ることにより、((最大10個))まで指定可能です。

§ 「EasyMTファイル名」

バックアップファイル作成時に付けるファイル名を指定します。((最大17文字))まで指定可能です。

· バックアップファイル種別が「JP1/OmniBack Ⅱ」の場合:

バーリストファイル名を指定します。このオプションは必須項目です。

§ 「JP1/OmniBack Ⅱバーリストファイル名」

JP1/OmniBack Ⅱのバーリストファイル名を指定します。((最大64文字))まで指定可能です。

4. 他タブページ、あるいは確認画面を表示する。

他タブページで設定しなければならない情報がある場合は、任意のタブページを表示します。オプションの設定内容を確認又はバックアップを実行する場合は[確認画面へ]ボタンをクリックします。

· [取得単位]ページ

· [差分バックアップ]ページ

· [詳細設定]ページ

· [確認]ページ

<注意事項>

· アンロードレスシステムログ運用を選択（ログポイント情報の出力有無の指定）をし、マスタディレクトリ用RDエリアを含むバックアップを行う場合は、「バックアップ取得モード」に参照可能・更新不可モードを必ず指定してください。

· アンロードレスシステムログ運用を選択（ログポイント情報の出力有無の指定）をしバックアップを取得する場合は、バックアップ対象サーバのサーバ定義にpd_logunld_checkオプションをYで指定すつ必要があります。


バックアップ カスタマイズ(差分バックアップ)

[カスタマイズ]コマンド

バックアップ カスタマイズ (差分バックアップ)

ここでは、差分バックアップ機能の使用の有無と差分バックアップを使用する場合の情報を指定します。なお、差分バックアップ機能を使用しない場合は、このページに情報を設定する必要はありません。

[バックアップ - カスタマイズ]差分バックアップタブ

<前提条件>

· 差分バックアップを実行する場合は、予めＨｉＲＤＢ Control Managerで管理ファイルを格納するＨｉＲＤＢファイルシステム領域を作成してください。

1. 差分バックアップ使用の有無を指定する。

差分バックアップ機能を使用する場合はチェックボックス「差分バックアップを使用する」を選択します。

2. 差分バックアップ機能を使用するための情報を指定する。

「差分バックアップグループ名」と「管理ファイルを格納するHiRDBファイルシステム領域名」は必須項目です。

· 「差分バックアップグループ名」

差分バックアップを実行するにあたり、その単位となるグループ名を指定します。((最大30文字))まで指定可能です。

· 「履歴情報ファイル名」

差分バックアップの履歴情報を出力する場合に、そのファイル名を指定します。ディレクトリを含む完全パス名称を指定して下さい。

[参照]ボタンをクリックして対象となる履歴情報ファイルのパス名称を指定することもできます。

バックアップ実行後には、pdfbkupコマンドで差分バックアップ管理ファイルのバックアップを取得する必要があります。差分バックアップ管理ファイルに障害が発生した場合、このバックアップを使用してpdfrstrコマンドで回復します。

· 「管理ファイルを格納するHiRDBファイルシステム領域名」

既に登録されたHiRDBファイルシステム領域から差分バックアップ管理ファイルを格納するHiRDBファイルシステム領域名を選択します。

HiRDBファイルシステム領域の一覧には使用目的が「ユティリティ用」で、かつ、HiRDB CMで別の用途として使用されていないHiRDBファイルシステム領域が表示されます。

なお、Windows版06-02のHiRDBに対して差分バックアップを実行する場合、差分バックアップの管理ファイルを格納するHiRDBファイルシステム領域に使用目的が「ユティリティ用(Windowsキャッシュを使用しない)」のHiRDBファイルシステム領域を指定することはできません。HiRDB CMでは「ユティリティ用」と「ユティリティ用(Windowsキャッシュを使用しない)」のHiRDBファイルシステム領域を区別しないため、当該HiRDBファイルシステム領域を指定する際にはあらかじめHiRDBコマンド「pdfstatfs」を使用して、使用目的を確認しておいてください。

· 「管理ファイルの容量(MB)」

差分バックアップの容量を指定します。指定しない場合は、デフォルト値で<<1>>が仮定されます。設定範囲は((1～2046))の間で指定することができます。

指定する容量は、HiRDBファイルシステム領域作成時の容量 (pdfmkfsコマンドの-nオプション指定値－5)より小さくしてください。なお、管理ファイルの容量の増分は、最大２３回できます。

4. 他タブページ、あるいは確認画面を表示する。

他タブページで設定しなければならない情報がある場合は、任意のタブページを表示します。オプションの設定内容を確認又はバックアップを実行する場合は[確認画面へ]ボタンをクリックします。

· [取得単位]ページ

· [取得モード]ページ

· [詳細設定]ページ

· [確認]ページ


バックアップ カスタマイズ(詳細設定)

[カスタマイズ]コマンド

バックアップ カスタマイズ (詳細設定)

ここでは、詳細なオプションを指定します。

[バックアップ - カスタマイズ]詳細設定タブ

1. 各オプションを指定する。

· 「処理結果出力ファイル」グループ

§ 「バックアップの処理結果ファイルを出力する」

バックアップの処理結果を出力するファイル名を指定します。

§ 「RDエリア使用状況の処理結果ファイルを出力する」

RDエリアの使用状況を処理結果出力ファイルに出力する場合に指定します。

· 「バックアップファイル初期容量と増分値(MB)」

バックアップファイルの初期容量と増分値を指定します。設定範囲は((1～1048574))の間で指定することができます。

バックアップファイルの初期容量と増分値は、括弧"( )"とカンマ","で区切ることにより、((最大10個))まで指定可能です。

例 :(100,200),(212,112)

§ 初期容量

バックアップファイルの初期容量を指定します。指定しない場合は、デフォルト値で<<100>>が仮定されます。

初期容量は、[バックアップファイル格納先の登録/削除]コマンドでHiRDBファイルシステム領域作成時に指定した「初期容量」より小さくなければなりません。これは、システムが管理用に使用する領域が必要となるためです。

§ 増分値

増分値 (バックアップデータが初期容量を超えた場合に確保する容量） を指定します。指定しない場合は、デフォルト値で<<10>>が仮定されます。

バックアップファイル容量の増分は、最大23回できます。ただし、[バックアップファイル格納先の登録/削除]コマンドでHiRDBファイルシステム領域作成時に指定した「HiRDBファイルの増分回数」を超えて増分はできません。

· 「排他待ち限界経過時間」

排他待ち時間を監視する最大待ち時間を秒単位で指定します。設定範囲は((0～200000))の間で指定することができます。

· 「世代番号の指定」

インナレプリカ機能を使用している場合，バックアップ対象のRDエリアの世代番号を指定します。0を指定した場合はオリジナルRDエリアが対象となり，1～10を指定した場合は指定した世代のレプリカRDエリアが対象となります。

<注意事項>

· 取得対象にオリジナルRDエリア以外のRDエリアが含まれる場合は、このオプションを指定しないでください。

2. 他タブページ、あるいは確認画面を表示する。

他タブページで設定しなければならない情報がある場合は、任意のタブページを表示します。オプションの設定内容を確認又はバックアップを実行する場合は[確認画面へ]ボタンをクリックします。

· [取得単位]ページ

· [取得モード]ページ

· [差分バックアップ]ページ

· [確認]ページ


バックアップ カスタマイズ(確認)

[カスタマイズ]コマンド

バックアップ カスタマイズ (確認)

ここでは選択した項目の確認を行い、バックアップの実行又はカタログの登録を実行します。

[バックアップ - カスタマイズ]確認タブ

1. 情報の確認を行う。

表示されている項目を確認してください。

指定項目が不足している場合は、赤字で表示されます。該当するタブページで情報を入力してください。

2. 実行

· [実行]ボタンをクリック:

内容を確認し問題がなければ[実行]ボタンをクリックしてください。バックアップの実行を行います。

· [カタログ]ボタンをクリック:指定した情報でカタログを作成します。

このボタンをクリックすると、カタログの情報を入力するための[カタログの登録]画面が表示されます。

§ 「カタログ名」

エディットボックス「カタログ名」に任意の名前を入力してください。カタログ名の入力は((最大64文字))で、英数字のみ指定可能です。

§ 「同名のバックアップファイルが存在した場合」

ここで作成したカタログを使用してバックアップを実行したときに、既に同名のバックアップファイルが存在していた場合の対処方法を選択してください。

- 「上書き」

同名のバックアップファイルが存在した場合は上書きを行います。

- 「別名保存」

同名のバックアップファイルが存在するか否かに関わらず、以下のフォーマットで名称を作成しバックアップファイルを取得します。

"指定されたバックアップファイル名" + "カタログ実行日時"

<注意事項>

· [別名保存]は、通常ファイルとHiRDBファイルへのバックアップの場合のみ有効な指定です。

· HiRDBファイルのバックアップ操作を[別名保存]のカタログとして使用する場合は、HRDBファイル名を15文字以内に指定してください。

カタログ名を入力して[OK]ボタンをクリックすると、カタログの作成及び登録を行います。


バックアップ カスタマイズ(バックアップファイル格納先の指定)

[カスタマイズ]コマンド

バックアップ カスタマイズ(バックアップファイル格納先の指定)

ここでは、バックアップファイル名を指定します。

1. 「格納先ディレクトリ名」を指定する。

HiRDB CMに登録されているバックアップファイルの格納先を指定します。

2. 「バックアップファイル名」を指定する。

任意のバックアップファイルを入力します。

3. 「バックアップ取得先」リストへ入力したバックアップファイル名を指定する。

[追加]ボタンと[削除]ボタンを使用してバックアップ取得先を指定します。

· [追加]ボタン

このボタンをクリックすると、「格納先ディレクトリ名」と「バックアップファイル名」で指定した値を連結し、「バックアップ取得先」リストに移動します。「バックアップ取得先」リストに移動したバックアップファイル名はバックアップ実行のための指定値として使用されます。

· [削除]ボタン

このボタンをクリックすると、「バックアップ取得先」リストで選択した値をリストから削除します。

2. [OK]ボタンをクリック。

[取得単位]ページへ戻ります。


バックアップ ウィザード(取得対象の検索)

[ウィザード]コマンド

バックアップ ウィザード (取得対象の検索)

ここでは、バックアップを取得する対象を検索します。

1. 「取得対象」を選択。

7つあるラジオボタンの中から任意の対象を選択します。

「デバイス」を選択した場合は、次画面へ進んでください。

それ以外の取得対象を選択した場合は、対象の名称をエディットボックス「検索する取得対象名」に入力してください。なお、名称の指定にはワイルドカードが使用できます。

2. [次へ>]ボタンをクリック。

「取得対象」と「検索する取得対象名」をキーワードにして、バックアップを実行する対象を検索します。

次画面は[取得対象]ラジオボタンで選択した情報により、遷移する画面が分かれています。

次画面について、以下で説明します。

[次へ>]...

選択したラジオボタン | 次の画面
HiRDBシステム | HiRDBシステムの表示
ユニット | ユニットの表示
サーバ | サーバの表示
RDエリア | RDエリアの表示
表/インデクス | 表/インデクスの表示
HiRDBファイル | HiRDBファイルの表示
デバイス | デバイスの指定


バックアップ ウィザード(HiRDBシステムの表示)

[ウィザード]コマンド

バックアップ ウィザード (HiRDBシステムの表示)

ここでは、HiRDBシステム一覧を表示します。

1. 「取得対象」を選択。

HiRDBシステムの「バックアップ実行」又はHiRDBシステム下の表示する対象を指定します。

· HiRDBシステム単位のバックアップを実行する場合:

「バックアップ実行」ラジオボタンを選択します。リストボックス「HiRDBシステム」から任意のHiRDBシステム名を指定してください。

· 指定したHiRDBシステム下の情報を表示する場合:

「HiRDBシステムの要素」ラジオボタンを選択すると、その配下にある5つのラジオボタンが選択可能となりますので任意の対象を選びます。リストボックス「HiRDBシステム」から検索を行いたいHiRDBシステム名を指定し、検索対象名をエディットボックス「検索する取得対象名」に入力してください。なお、名称の指定にはワイルドカードが使用できます。

リストボックス「HiRDBシステム」は複数選択ができません。

2. [次へ>]ボタンをクリック。

次画面は「取得対象」ラジオボタンで選択した情報により、遷移する画面が分かれています。

次画面について、以下で説明します。

[次へ>]...

選択したラジオボタン |  | 次の画面
バックアップ実行 |  | · リストボックスで選択したHiRDBシステムがシングルサーバの場合: システムログ運用方法の指定 · リストボックスで選択したHiRDBシステムがパラレルサーバの場合: バックアップ取得先の指定
HiRDBシステムの要素 | ユニットを表示 | ユニットの表示
 | サーバを表示 | サーバの表示
 | RDエリアを表示 | RDエリアの表示
 | 表/インデクスを表示 | 表/インデクスの表示
 | HiRDBファイルを表示 | HiRDBファイルの表示


バックアップ ウィザード(ユニットの表示)

[ウィザード]コマンド

バックアップ ウィザード (ユニットの表示)

ここでは、ユニット一覧を表示します。

1. 「取得対象」を選択。

ユニットの「バックアップ実行」又はユニット下の表示する対象を指定します。

· ユニット単位のバックアップを実行する場合:

「バックアップ実行」ラジオボタンを選択します。リストボックス「ユニット」から任意のユニット名を指定してください。

· 指定したユニットを含むHiRDBシステムの情報を表示する場合:

「HiRDBシステムを表示」ラジオボタンを選択します。リストボックス「ユニット」から検索を行いたいユニット名を指定してください。

· 指定したユニット下の情報を表示する場合:

「ユニットの要素」ラジオボタンを選択すると、その配下にある4つのラジオボタンが選択可能となりますので任意の対象を選びます。リストボックス「ユニット」から検索を行いたいユニット名を指定し、検索対象名をエディットボックス「検索する取得対象名」に入力してください。なお、名称の指定にはワイルドカードが使用できます。

リストボックス「ユニット」は、同じHiRDBシステムに属している場合に複数の選択ができますが、異なるHiRDBシステムに属するユニット名の複数選択はできません。

2. [次へ>]ボタンをクリック。

次画面は[取得対象]ラジオボタンで選択した情報により、遷移する画面が分かれています。

次画面について、以下で説明します。

[次へ>]...

選択したラジオボタン |  | 次の画面
バックアップ実行 |  | · リストボックスで選択したユニット下のRDエリアが持つ表/インデクスと、論理的な関係を持つ表/インデクスがあり、同時にバックアップを取得しなければならない場合: 関連するRDエリアの追加 · 関連するRDエリアがない場合: バックアップ取得先の指定
HiRDBシステムを表示 |  | HiRDBシステムの表示
ユニットの要素 | サーバを表示 | サーバの表示
 | RDエリアを表示 | RDエリアの表示
 | 表/インデクスを表示 | 表/インデクスの表示
 | HiRDBファイルを表示 | HiRDBファイルの表示


バックアップ ウィザード(サーバの表示)

[ウィザード]コマンド

バックアップ ウィザード (サーバの表示)

ここでは、サーバ一覧を表示します。

1. 「取得対象」を選択。

サーバの「バックアップ実行」又はサーバ下の表示する対象を指定します。

· サーバ単位のバックアップを実行する場合:

「バックアップ実行」ラジオボタンを選択します。リストボックス「サーバ」から任意のサーバ名を指定してください。

· 指定したサーバを含むHiRDBシステムの情報を表示する場合:

「HiRDBシステムを表示」ラジオボタンを選択します。リストボックス「サーバ」から検索を行いたいサーバ名を指定してください。

· 指定したサーバを含むユニットの情報を表示する場合:

「ユニットを表示」ラジオボタンを選択します。リストボックス「サーバ」から検索を行いたいサーバ名を指定してください。

· 指定したユニット下の情報を表示する場合:

「サーバの要素」ラジオボタンを選択すると、その配下にある3つのラジオボタンが選択可能となりますので任意の対象を選びます。リストボックス「サーバ」から検索を行いたいサーバ名を指定し、検索対象名をエディットボックス「検索する取得対象名」に入力してください。なお、名称の指定にはワイルドカードが使用できます。

リストボックス「サーバ」は、同じHiRDBシステムに属している場合に複数の選択ができますが、異なるHiRDBシステムに属するサーバ名の複数選択はできません。

2. [次へ>]ボタンをクリック。

次画面は「取得対象」ラジオボタンで選択した情報により、遷移する画面が分かれています。

次画面について、以下で説明します。

[次へ>]...

選択したラジオボタン |  | 次の画面
バックアップ実行 |  | · リストボックスで選択したサーバ下のRDエリアが持つ表/インデクスと、論理的な関係を持つ表/インデクスがあり、同時にバックアップを取得しなければならない場合: 関連するRDエリアの追加 · リストボックスで選択したサーバが1つであり、なおかつ関連するRDエリアがない場合: システムログ運用方法の指定 · 関連するRDエリアがない場合: バックアップ取得先の指定
HiRDBシステムを表示 |  | HiRDBシステムの表示
サーバの要素 | RDエリアを表示 | RDエリアの表示
 | 表/インデクスを表示 | 表/インデクスの表示
 | HiRDBファイルを表示 | HiRDBファイルの表示


バックアップ ウィザード(RDエリアの表示)

[ウィザード]コマンド

バックアップ ウィザード (RDエリアの表示)

ここでは、RDエリア一覧を表示します。

1. 「取得対象」を選択。

RDエリアの「バックアップ実行」又は表示をおこなうRDエリアの上位システムを指定します。

· RDエリア単位のバックアップを実行する場合:

「バックアップ実行」ラジオボタンを選択します。リストボックス「RDエリア」から任意のRDエリア名を指定してください。

· 指定したRDエリアを含むHiRDBシステムの情報を表示する場合:

「HiRDBシステムを表示」ラジオボタンを選択します。リストボックス「RDエリア」から検索を行いたいRDエリア名名を指定してください。

· 指定したRDエリアを含むユニットの情報を表示する場合:

「ユニットを表示」ラジオボタンを選択します。リストボックス「RDエリア」から検索を行いたいRDエリア名を指定してください。

· 指定したRDエリアを含むサーバの情報を表示する場合:

「サーバを表示」ラジオボタンを選択します。リストボックス「RDエリア」から検索を行いたいRDエリア名を指定してください。

リストボックス「RDエリア」は、同じHiRDBシステムに属している場合に複数の選択ができますが、異なるHiRDBシステムに属するRDエリア名の複数選択はできません。

2. [次へ>]ボタンをクリック。

次画面は「取得対象」ラジオボタンで選択した情報により、遷移する画面が分かれています。

次画面について、以下で説明します。

[次へ>]...

選択したラジオボタン | 次の画面
バックアップ実行 | · リストボックスで選択したRDエリアが持つ表/インデクスと、論理的な関係を持つ表/インデクスがあり、同時にバックアップを取得しなければならない場合: 関連するRDエリアの追加 · 関連するRDエリアがない場合: バックアップ取得先の指定
HiRDBシステムを表示 | HiRDBシステムの表示
ユニットを表示 | ユニットの表示
サーバを表示 | サーバの表示


バックアップ ウィザード(表/インデクスの表示)

[ウィザード]コマンド

バックアップ ウィザード (表/インデクスの表示)

ここでは、表/インデクス一覧を表示します。

1. 「取得対象」を選択。

指定した表/インデクスを含むRDエリアの「バックアップ実行」又は表示をおこなう表/インデクス (RDエリア) の上位システムを指定します。

· 指定した表/インデクスを含むRDエリア単位のバックアップを実行する場合:

「バックアップ実行」ラジオボタンを選択します。リストボックス「表/インデクス」から任意の表/インデクス名を指定してください。

· 指定した表/インデクスを含むHiRDBシステムの情報を表示する場合:

「HiRDBシステムを表示」ラジオボタンを選択します。リストボックス「表/インデクス」から任意の表/インデクス名を指定してください。

· 指定した表/インデクスを含むユニットの情報を表示する場合:

「ユニットを表示」ラジオボタンを選択します。リストボックス「表/インデクス」から任意の表/インデクス名を指定してください。

· 指定した表/インデクスを含むサーバの情報を表示する場合:

「サーバを表示」ラジオボタンを選択します。リストボックス「表/インデクス」から任意の表/インデクス名を指定してください。

<注意事項>

· インナレプリカ機能を使用している場合、選択した表・インデクスが属するオリジナルRDエリアがバックアップの対象となりますとなります。

· リストボックス「表/インデクス」は、同じHiRDBシステムに属している場合に複数の選択ができますが、異なるHiRDBシステムに属する表/インデクス名の複数選択はできません。

2. [次へ>]ボタンをクリック。

次画面は「取得対象」ラジオボタンで選択した情報により、遷移する画面が分かれています。

次画面について、以下で説明します。

[次へ>]...

選択したラジオボタン | 次の画面
バックアップ実行 | · リストボックスで選択した表/インデクスが属するRDエリアと、論理的な関係を持つ表/インデクスがあり、同時にバックアップを取得しなければならない場合: 関連するRDエリアの追加 · 関連するRDエリアがない場合: バックアップ取得先の指定
HiRDBシステムを表示 | HiRDBシステムの表示
ユニットを表示 | ユニットの表示
サーバを表示 | サーバの表示


バックアップ ウィザード(HiRDBファイルの表示)

[ウィザード]コマンド

バックアップ ウィザード (HiRDBファイルの表示)

ここでは、HiRDBファイルの階層一覧を表示します。

1. 「取得対象」を選択。

指定したHiRDBファイルを含むRDエリアの「バックアップ実行」又は表示をおこなうHiRDBファイル (RDエリア) の上位システムを指定します。

· 指定したHiRDBファイルを含むRDエリア単位のバックアップを実行する場合:

「バックアップ実行」ラジオボタンを選択します。ツリービュー「HiRDBファイル」から任意のHiRDBファイル名を指定してください。

· 指定したHiRDBファイルを含むHiRDBシステムの情報を表示する場合:

「HiRDBシステムを表示」ラジオボタンを選択します。ツリービュー「HiRDBファイル」から任意のHiRDBファイル名を指定してください。

· 指定したHiRDBファイルを含むユニットの情報を表示する場合:

「ユニットを表示」ラジオボタンを選択します。ツリービュー「HiRDBファイル」から任意のHiRDBファイル名を指定してください。

· 指定したHiRDBファイルを含むサーバの情報を表示する場合:

「サーバを表示」ラジオボタンを選択します。ツリービュー「HiRDBファイル」から任意のHiRDBファイル名を指定してください。

ツリービュー「HiRDBファイル」は、同じHiRDBシステムに属している場合に複数の選択ができますが、異なるHiRDBシステムに属するHiRDBファイル名の複数選択はできません。

2. [次へ>]ボタンをクリック。

次画面は「取得対象」ラジオボタンで選択した情報により、遷移する画面が分かれています。

次画面について、以下で説明します。

[次へ>]...

選択したラジオボタン | 次の画面
バックアップ実行 | · リストボックスで選択したHiRDBファイルが属するRDエリアが持つ表/インデクスと、論理的な関係を持つ表/インデクスがあり、同時にバックアップを取得しなければならない場合: 関連するRDエリアの追加 · 関連するRDエリアがない場合: バックアップ取得先の指定
HiRDBシステムを表示 | HiRDBシステムの表示
ユニットを表示 | ユニットの表示
サーバを表示 | サーバの表示


バックアップ ウィザード(デバイスの指定)

[ウィザード]コマンド

バックアップ ウィザード (デバイスの指定)

ここでは、検索するデバイスを指定します。

1. バックアップを実行するHiRDBシステムを指定する。

リストボックス「HiRDBシステム」から任意のHiRDBシステム名を指定してください。

なお、リストボックス「HiRDBシステム」は複数選択ができません。

2. 「デバイス種別」を選択します。

9つあるラジオボタンの中から任意の種別を選択し、その名称をエディットボックス「デバイス名」に入力してください。

2. [次へ>]ボタンをクリック。

次画面について、以下で説明します。

RDエリアの表示

<注意事項>

· 「HiRDBシステム」で選択した対象がLinux OSであり、かつ、AgentのバージョンがV01-01以前の場合、この機能は使用できません。[<戻る]ボタンで前画面に戻ってください。

· 2ユニット以上で構成されたHiRDBシステムを選択して、"/"ファイルシステム（rootファイルシステム）が割当てられているデバイス名を指定した場合は、正しいバックアップ操作を行えません。


バックアップ ウィザード(関連するRDエリアの追加)

[ウィザード]コマンド

バックアップ ウィザード (関連するRDエリアの追加)

ここでは、関連するRDエリアの表示とバックアップを取得するRDエリアの追加を行います。

この画面は、前画面で指定した[取得対象]のRDエリアと論理的な関係を持つ表/インデクスが他のRDエリアにある場合に表示されます。

1. バックアップを取得するRDエリアの追加を行う。

リストボックス「バックアップ対象RDエリア」に、前画面で指定したバックアップを取得するRDエリアが一覧表示され、指定した情報に関連のあるRDエリアがリストボックス「関連するRDエリア」に表示されます。

· [すべて選択]ボタン

リストボックス「関連するRDエリア」内のRDエリアを、全て選択された状態にします。

· [追加」ボタン

リストボックス「関連するRDエリア」で選択したRDエリアを、「バックアップ対象RDエリア」に指定します。

· [削除]ボタン

「追加」ボタンで「バックアップ対象RDエリア」に指定したRDエリアを、「バックアップ対象RDエリア」から削除します。

バックアップを行うRDエリアをリストボックス「バックアップ対象RDエリア」内へ移動させます。

2. [次へ>]ボタンをクリック。

前画面で選択した情報により、遷移する画面が分かれています。

次画面について、以下で説明します。

(1) 前画面で設定した情報が、取得単位はサーバで取得対象は1つである。

(2) この画面でリストボックス「関連するRDエリア」内のRDエリアを1つも「バックアップ対象RDエリア」に指定していない。

· (1)～(2)の条件を全て満たしている場合:

システムログ運用方法の指定

· それ以外:

バックアップ取得先の指定


バックアップ ウィザード(システムログ運用方法の指定)

[ウィザード]コマンド

バックアップ ウィザード (システムログ運用方法の指定)

ここでは、システムログの運用方法を指定します。

1. システムログの運用を選択。

· 「アンロードレスシステムログ運用」

システムログをアンロードしない運用を行っている場合は、必ずここを選択します。

· 「システムログをアンロードする運用」

システムログをアンロードする運用を行っている場合は、ここを選択します。

2. [次へ>]ボタンをクリック。

次画面について、以下で説明します。

バックアップ取得先の指定

<注意事項>

· 「HiRDBシステム」で選択した対象がLinux OSであり、かつ、AgentのバージョンがV01-01以前の場合、この機能は使用できません。[<戻る]ボタンで前画面に戻ってください。

· 2ユニット以上で構成されたHiRDBシステムを選択して、"/"ファイルシステム（rootファイルシステム）が割当てられているデバイス名を指定した場合は、正しいバックアップ操作を行えません。

· アンロードレスシステムログ運用を選択し、マスタディレクトリ用RDエリアを含むバックアップを行う場合は、「バックアップ取得モード」に参照可能・更新不可モードを必ず指定してください。

· アンロードレスシステムログ運用を選択しバックアップを取得する場合は、バックアップ対象サーバのサーバ定義にpd_logunld_checkオプションをYで指定すつ必要があります。


バックアップ ウィザード(バックアップ取得先の指定)

[ウィザード]コマンド

バックアップ ウィザード (バックアップ取得先の指定)

ここでは、バックアップファイルの格納先とそれに関する情報を指定します。

1. 「ファイル種別」を選択。

ラジオボタンの中から任意のファイル種別を選択します。次にバックアップファイル名を入力しますが、ラジオボタンごとに入力するファイルの名前と指定方法が分かれます。

バックアップファイル名とその指定方法について、以下で説明します。

バックアップファイル名

選択したラジオボタン | 最大文字 指定数 | バックアップファイル名
通常ファイル | 1024 | (1) バックアップファイルを格納する「ホスト名」を選択する。 (2) 「バックアップ取得先」ボタンをクリック。 [バックアップファイル格納先の指定]画面が表示されますので、ここでバックアップ格納先とバックアップファイル名を指定します。 この画面については以下で説明します。 [バックアップファイル格納先の指定]画面
HiRDBファイルシステム領域 | 1024 | (1) バックアップファイルを格納する「ホスト名」を選択する。 (2) 「バックアップ取得先」ボタンをクリック。 [バックアップファイル格納先の指定]画面が表示されますので、ここでバックアップ格納先とバックアップファイル名を指定します。 この画面については以下で説明します。 [バックアップファイル格納先の指定]画面
EasyMT | 1024 | EasyMTのMTのスペシャルファイル名をコンボボックス「ホスト名」とエディットボックス「MTのスペシャルファイル名」に指定します。
EasyMT, MTguide | 1024 | MTguideが管理する装置記号名又は装置グループ名をコンボボックス「装置ホスト名」とエディットボックス「装置記号名又は装置グループ名」に指定します。
JP1/OmniBack Ⅱ | 512 | JP1/OmniBack Ⅱのディスクエージェントがあるホストをコンボボックス「ホスト名」に指定し、オブジェクト名をエディットボックス「オブジェクト名」に指定します。
NetBackup | 128 | NetBackup クライアントがあるホストをコンボボックス「ホスト名」に指定し、ポリシーをコンボボックス「ポリシー名」から指定します。

2. 各オプションを指定する。

「ファイル種別」で選択されたラジオボタンごとにオプションの指定をします。

· 「HiRDBファイルシステム領域」

グループ「バックアップファイルの容量」でバックアップファイルの初期容量と増分値を指定できます。必須項目ではありません。

§ 「初期容量」

バックアップファイルの初期容量を指定します。指定しない場合は、デフォルト値で<<100>>が仮定されます。設定範囲は((1～1048574))の間で指定することができます。

初期容量は、[バックアップファイル格納先の登録/削除]コマンドでHiRDBファイルシステム領域作成時に指定した「初期容量」より小さくなければなりません。これは、システムが管理用に使用する領域が必要となるためです。

§ 「増分値」

増分値 (バックアップデータが初期容量を超えた場合に確保する容量） を指定します。指定しない場合は、デフォルト値で<<10>>が仮定されます。設定範囲は((1～1048574))の間で指定することができます。

バックアップファイル容量の増分は、最大23回できます。ただし、[バックアップファイル格納先の登録/削除]コマンドでHiRDBファイルシステム領域作成時に指定した「HiRDBファイルの増分回数」を超えて増分はできません。

· 「EasyMT」又は「EasyMT, MTguide」

グループ「EasyMT」で各オプションを指定できます。必須項目ではありません。

「ボリューム名」、「属性定義ファイル」は、[ウィザード環境設定]コマンドで情報を登録しておく必要があります。

§ 「ボリューム名」

バックアップを取得するMTのボリューム名を指定します。

§ 「属性定義ファイル名」

EasyMT用のMT属性定義ファイルのファイル名を指定します。

§ 「EasyMTファイル名」

バックアップファイル作成時に付けるファイル名を指定します。((最大17文字))まで指定可能です。

· 「JP1/OmniBack Ⅱ」

リストボックス「バーリストファイル名」でバーリストファイルを選択します。なお、複数の選択はできません。必須項目です。

「JP1/OmniBack Ⅱ」を使用してバックアップを実行するには、[ウィザード環境設定]コマンドで[バーリストファイル名]を登録しておく必要があります。

§ 「バーリストファイル名」

JP1/OmniBack IIのバーリストファイル名を指定します。

· 「NetBackup」

[格納先の指定]項目で「ポリシー名」を選択します。なお、複数の選択はできません。必須項目です。

「NetBackup」を使用してバックアップを実行するには、[NetBackup]コマンドで[ポリシー名]を登録しておく必要があります。

§ 「ポリシー名」

NetBackupポリシー名を指定します。

· 「差分バックアップグループを新規作成する」

チェックボタン「差分バックアップグループを新規作成する」で差分バックアップを使用するかどうかの選択をします。取得対象にLOB用RDエリアが存在する場合は、使用できません。ファイル種別で「通常ファイル」又は「HiRDBファイルシステム領域」、「NetBackup」を選択した場合にのみ差分バックアップグループの新規作成が指定できます。このチェックボックスをチェックした場合[次へ]ボタンをクリックすると[バックアップウィザード－差分バックアップの指定]画面を表示します。

3. [次へ>]ボタンをクリック。

次画面について、以下で説明します。

確認

[バックアップウィザード－差分バックアップの指定]


バックアップ ウィザード(差分バックアップ)

[ウィザード]コマンド

バックアップ ウィザード (差分バックアップ)

ここでは、差分バックアップの情報を指定します。

[バックアップ - ウィザード]差分バックアップ

<前提条件>

· 差分バックアップを実行する場合は、予めＨｉＲＤＢ Control Managerで管理ファイルを格納するＨｉＲＤＢファイルシステム領域を作成してください。

1. 差分バックアップ機能を使用するための情報を指定する。

「差分バックアップグループ名」と「管理ファイルを格納するHiRDBファイルシステム領域名」は必須項目です。

· 「差分バックアップグループ名」

差分バックアップを実行するにあたり、その単位となるグループ名を指定します。((最大30文字))まで指定可能です。

· 「履歴情報ファイル名」

差分バックアップの履歴情報を出力する場合に、そのファイル名を指定します。ディレクトリを含む完全パス名称を指定して下さい。

[参照]ボタンをクリックすると、対象となるファイルパス名称を選択することができます。

バックアップ実行後には、pdfbkupコマンドで差分バックアップ管理ファイルのバックアップを取得する必要があります。差分バックアップ管理ファイルに障害が発生した場合、このバックアップを使用してpdfrstrコマンドで回復します。

· 「管理ファイルを格納するHiRDBファイルシステム領域名」

既に登録されたHiRDBファイルシステム領域から差分バックアップ管理ファイルを格納するHiRDBファイルシステム領域名を選択します。

· 「管理ファイルの容量(MB)」

差分バックアップ管理ファイルの容量を指定します。指定しない場合は、デフォルト値で<<1>>が仮定されます。設定範囲は((1～2046))の間で指定することができます。

指定する容量は、HiRDBファイルシステム領域作成時の容量 (pdfmkfsコマンドの-nオプション指定値－5)より小さくしてください。なお、管理ファイルの容量の増分は、最大23回できます。

2. [次へ>]ボタンをクリック。

次画面について、以下で説明します。

確認


バックアップ ウィザード(確認)

[ウィザード]コマンド

バックアップ ウィザード (確認)

ここでは選択した項目の確認を行い、バックアップの実行又はカタログの登録を実行します。

1. 情報の確認を行う。

表示されている項目を確認してください。

2. 実行

· [実行]ボタンをクリック:

内容を確認し問題がなければ[実行]ボタンをクリックしてください。バックアップの実行を行います。

· [カタログ]ボタンをクリック:

指定した情報でカタログを作成します。

このボタンをクリックすると、カタログの情報を入力するための[カタログの登録]画面が表示されます。

§ 「カタログ名」

エディットボックス「カタログ名」に任意の名前を入力してください。カタログ名の入力は((最大64文字))で、英数字のみ指定可能です。

§ 「同名のバックアップファイルが存在した場合」

ここで作成したカタログを使用してバックアップを実行したときに、既に同名のバックアップファイルが存在していた場合の対処方法を選択してください。

- 「上書き」

同名のバックアップファイルが存在した場合は上書きを行います。

- 「別名保存」

同名のバックアップファイルが存在するか否かに関わらず、以下のフォーマットで名称を作成しバックアップファイルを取得します。

"指定されたバックアップファイル名" + "カタログ実行日時"

カタログ名を入力して[OK]ボタンをクリックすると、カタログの作成及び登録を行います。


バックアップ ウィザード(バックアップファイル格納先の指定)

[ウィザード]コマンド

バックアップ ウィザード (バックアップファイル格納先の指定)

ここでは、バックアップファイル名を指定します。

1. 「格納先ディレクトリ名」を指定する。

HiRDB CMに登録されているバックアップファイルの格納先を指定します。

2. 「バックアップファイル名」を指定する。

任意のバックアップファイルを入力します。

3. 「バックアップ取得先」リストへ入力したバックアップファイル名を指定する。

[追加]ボタンと[削除]ボタンを使用してバックアップ取得先を指定します。

· [追加]ボタン

このボタンをクリックすると、「格納先ディレクトリ名」と「バックアップファイル名」で指定した値を連結し、「バックアップ取得先」リストに移動します。「バックアップ取得先」リストに移動したバックアップファイル名はバックアップ実行のための指定値として使用されます。

· [削除]ボタン

このボタンをクリックすると、「バックアップ取得先」リストで選択した値をリストから削除します。

2. [OK]ボタンをクリック。

[バックアップ取得先の指定]画面へ戻ります。


[グローバルバッファの動的変更]コマンド

[グローバルバッファ動的変更]コマンド

グローバルバッファ名を選択し、リスト下のボタンから次のコマンド(pdbufmod)が実行できます。

§ 追加

§ 割当

§ 変更

§ 削除

これらのコマンドを実行すると、グローバルバッファ動的変更を実行するための画面が表示されます。

<注意事項>

· XDM/RDのRDエリアに対するグローバルバッファ動的変更はサポートしていません。

· グローバルバッファ動的変更を行った状態は、次回HiRDBシステム再起動時に無効となります。変更後のグローバルバッファに関する状態をHiRDBシステム再起動時に引き継ぐためには、HiRDBシステム正常停止後に、HiRDBシステム定義(pdsys)のグローバルバッファ情報を変更する必要があります。

· 高速系切り替え機能、又はスタンバイレス型系切り替え機能を使用している場合、グローバルバッファの動的変更を行うことはできません。

l 追加

当該HiRDBシステムへ新しいグローバルバッファを動的に追加します。

グローバルバッファの追加操作について説明します。

1. グローバルバッファに割り当てるRDエリア又はインデクスを選択。

新規追加するグローバルバッファへ割り当てるリソースを「RDエリア」、「LOB用RDエリア」、「インデクス」の中から選択してください。また、グローバルバッファへ明示的に割り当てられていないRDエリアの使用するグローバルバッファを新規追加する場合は、「指定しない全てのRDエリア割当」を選択してください。

· 「RDエリア」

システム内に存在するRDエリアが表示されます。表示されたRDエリア名称を1つ以上選択してください。

· 「LOB用RDエリア」

システム内に存在するLOB用RDエリアが表示されます。表示されたLOB用RDエリア名称を1つ以上選択してください。

· 「インデクス」

システム内に存在するインデクスが表示されます。表示されたインデクス名称を１つだけ選択してください。

· 「指定しない全てのRDエリア割当」

グローバルバッファへ明示的に割り当てられていないRDエリアが使用するグローバルバッファを新規追加する場合に選択してください。

2. 新規追加するグローバルバッファ名称を指定。

新規に追加するグローバルバッファ名称を入力してください。ここで指定するグローバルバッファ名称は、HiRDBシステムで一意となる名称を入力してください。

3. 新規追加するグローバルバッファの詳細情報を指定。

新規追加するグローバルバッファに対して「バッファ面数」、「バッファサイズ」、「同時実行最大プリフェッチ数」、「一括入力最大ページ数」、「デファードライトトリガ時の更新ページ出力比率」を指定できます。

· 「バッファ面数」

新規追加するグローバルバッファの面数を指定してください。

· 「バッファサイズ」

新規追加するグローバルバッファ1面のサイズを指定してください。

· 「同時実行最大プリフェッチ数」

同時にプリフェッチ機能を使用する最大数を指定してください。

· 「一括入力最大ページ数」

プリフェッチ機能の一括入力最大ページ数を指定してください。

· 「デファードライトトリガ時の更新ページ出力比率」

デファードライトトリガでの更新ページ出力比率をパーセントで指定してください。

4. [実行]ボタンをクリック。

グローバルバッファの新規追加を実行します。

l 割当

選択されたグローバルバッファへ新たなRDエリアを動的に割当てます。

グローバルバッファのRDエリアへの割当操作について説明します。

1. グローバルバッファに割当てるRDエリアを選択。

グローバルバッファへ割当てるRDエリアを「RDエリア」項目に表示されたRDエリアの中から選択してください。

· 「RDエリア」

現在、明示的にグローバルバッファを割当てていないRDエリア名称が表示されます。表示されたRDエリア名称を1つ以上選択してください。

2. [実行]ボタンをクリック。

選択されたグローバルバッファへ指定されたRDエリアの割当を実行します。

l 変更

選択されたグローバルバッファの詳細設定情報を変更します。

グローバルバッファの変更操作について説明します。

1. 新規追加するグローバルバッファの詳細を指定。

選択されたグローバルバッファに対して「バッファ面数」、「バッファサイズ」、「同時実行最大プリフェッチ数」、「一括入力最大ページ数」、「デファードライトトリガ時の更新ページ出力比率」を変更できます。

· 「バッファ面数」

変更するグローバルバッファの面数を指定してください。

· 「バッファサイズ」

変更するグローバルバッファ1面のサイズを指定してください。

· 「同時実行最大プリフェッチ数」

変更するグローバルバッファの同時にプリフェッチ機能を使用する最大数を指定してください。

· 「一括入力最大ページ数」

変更するグローバルバッファのプリフェッチ機能の一括入力最大ページ数を指定してください。

· 「デファードライトトリガ時の更新ページ出力比率」

変更するグローバルバッファのデファードライトトリガでの更新ページ出力比率をパーセントで指定してください。

2. [実行]ボタンをクリック。

選択されたグローバルバッファの詳細設定情報変更を実行します。

l 削除

選択されたグローバルバッファを削除します。または、選択されたグローバルバッファの割当てているRDエリア割当て解除を行います。

グローバルバッファの削除操作について説明します。

1. グローバルバッファを削除するか、RDエリアの割当て解除を行うか選択。

グローバルバッファの削除操作画面では、選択されたグローバルバッファに対して次の操作を行うことができます。

・グローバルバッファの削除

・グローバルバッファを割当てられているRDエリア割当て解除

これらの選択は、「RDエリア割当て解除」チェックボックスをチェックすることで「グローバルバッファを割当てられているRDエリア割当て解除」操作を選択することができます。

· 「RDエリア割当て解除」

選択されたグローバルバッファが割当てられているRDエリア一覧が表示されます。表示されたRDエリア名称の中で、割当てを解除するRDエリアを1つ以上選択してください。この項目を選択した場合は、「グローバルバッファの削除」を行いません。

2. [実行]ボタンをクリック。

選択されたグローバルバッファの削除または、RDエリアの割当て解除を実行します。

<注意事項>

· グローバルバッファを削除した場合、割当てられていたRDエリアの状態は、閉塞＆クローズ状態になります。

· 複数のサーバに割当てられているグローバルバッファを削除した場合、サーバ単位に表示されていた当該グローバルバッファ情報は全て削除されます。


[HiRDBファイルシステム領域の初期設定/登録]

[HiRDBファイルシステム領域の初期設定/登録]コマンド

HiRDBファイルシステム領域の初期設定及び登録を行います。

このコマンドを選択すると、HiRDBファイルシステム領域の初期設定/登録を実行するための画面を表示します。

<注意事項>

· 指定された「HiRDBファイルシステム領域名」の語尾に空白が入力されていた場合は、空白が取り除かれて実行されます。

· スタンバイ型系切り替え構成を使用している場合：

  現用系-予備系の双方の系から接続可能な共有DISK上にHiRDBファイルシステム領域を作成してください。

· 影響分散スタンバイレス型系切り替え構成を使用している場合：

  「サーバ用ステータスファイル」、「RDエリア」、「アンロードログファイル格納用」などサーバとの関係のある用途で使用するHiRDBファイルシステム領域を作成する場合、必ずホストBESなるマシンのホスト名を指定すつ必要があります。テキストボックス「ホスト名」に表示されるホスト名を必ず確認してください。ゲストBESとなるホストを指定してHiRDBファイルシステム領域の作成を行った場合、他の画面から作成したHiRDBファイルシステム領域を選択できなくなる可能性があります。

  HiRDBファイルシステム領域の用途に応じて、共有DISK上に作成するかローカルDISKに作成するか判断してください。

· 実体がなく世代登録だけされているHiRDBファイルシステム領域を登録する場合は、HiRDBが起動している必要があります。

· HiRDB CMでは使用目的を「ユティリティ用(Windowsキャッシュを使用しない)」として作成したHiRDBファイルシステム領域を「ユティリティ用」として扱います。作成後の画面表示では「ユティリティ用(Windowsキャッシュを使用しない)」と「ユティリティ用」を区別せず、全て「ユティリティ用」に統一されます。

1. 「HiRDBファイルシステム領域名」を入力する。

HiRDBファイルシステム領域名を指定します。

なお、登録するHiRDBファイルシステム領域を格納するディレクトリまでは、既に存在するパスを指定します。

格納先ディレクトリ名は絶対パスで指定してください。

[参照]ボタンをクリックして対象となるHiRDBファイルシステム領域名を絶対パスで指定することもできます。

2. 新規に作成するかまたは、既存HiRDBファイルシステム領域を登録するか選択してください。

新規に作成するを選択した場合は、「３．各オプションを指定する。」に従って指定してください。

既存のHiRDBファイルシステム領域を選択した場合は、「登録」ボタンをクリックして登録を行います。

3. 各オプションを指定する。

· 「ファイル格納用HiRDBファイルシステム領域の設定」グループ

§ 「HiRDBファイルシステム領域サイズ」

HiRDBファイルシステム領域として割り当てる容量をメガバイト単位で指定します。設定範囲は((1～1048575))の間で指定することができます。

§ 「作成するHiRDBファイル数」

HiRDBファイルシステム領域内に作成するHiRDBファイル数の上限を指定します。設定範囲は((1～4096))の間で指定することができます。

§ 「HiRDBファイルの増分回数」

HiRDBファイルシステム領域内のHiRDBファイルの増分回数の上限値を指定します。設定範囲は((0～60000))の間で指定することができます。

§ 「HiRDBファイルシステム領域を初期化する」

「HiRDBファイルシステム領域サイズ」で指定したサイズ分の領域を最初から初期化する場合に指定します。このオプションを選択しない場合、HiRDBファイルシステム領域の管理情報だけを作成します。

· 「ファイル種別」グループ

HiRDBファイルシステム領域のファイル種別を以下の2つから選択します。

§ 「通常ファイル」

§ 「キャラクタ型スペシャルファイル」

4. 「使用目的」を選択。

作成するHiRDBファイルシステム領域の使用目的を選択してください。

5. 「登録」ボタンをクリック。

新規にHiRDBファイルシステム領域を作成する場合は、指定されたHiRDBファイルシステム領域の初期設定及び登録を実行します。

既存のHiRDBファイルシステム領域を登録する場合は、HiRDBファイルシステム領域詳細情報画面が表示されます。

表示された内容を確認し、登録を実行してください。


[ウィザード環境設定]

[ウィザード環境設定]コマンド

<< このコマンドは、HiRDB CM V01-00では未サポートです。

もし将来的にサポートすることになった場合、このページを使用してください。 >>

[リカバリ ウィザード]画面のデフォルト値の設定、及びオプション情報の登録を行います。

このコマンドを選択するとウィザードの環境設定を保存するための画面を表示します。ここで、ウィザードの環境設定を行ってください。なお、ここでの設定は[リカバリ カスタマイズ]画面には反映されません。

1. 各オプションの入力及び登録をする。

· リストボックス「HiRDBシステム」

リカバリ画面でHiRDBシステムを選択する項目が表示された場合、ここで選択された情報がデフォルト値として設定されます。複数の選択はできません。

· エディットボックス「ソート用ワークディレクトリ名」

アンロードログファイルを使用して回復又はアンロードログレス運用の場合に、SORTが使用する一時ファイルを作成するディレクトリの名称を指定します。デフォルトでは"/tmp"で指定されています。

エディットボックス「ソート用ワークディレクトリ名」は、[リカバリ ウィザード]に設定用の項目がありません。任意の値でリカバリを実行したい場合は、この[ウィザード環境設定]で設定してください。

· スピンボックス「ソート用バッファサイズ」

アンロードログファイルを使用して回復又はアンロードレスシステムログ運用の場合に、SORTが使用するワークバッファサイズを指定します。

スピンボックス「ソート用バッファサイズ」は、[リカバリ ウィザード]に設定用の項目がありません。任意の値でリカバリを実行したい場合は、この[ウィザード環境設定]で設定してください。

2. [保存]ボタンをクリック。

設定された情報を保存します。この画面で指定された値は[リカバリ ウィザード]画面のデフォルト値、あるいは内部で持つ情報に反映されます。


リカバリ カスタマイズ（ログファイル）

[カスタマイズ]コマンド

リカバリ カスタマイズ (ログファイル)

ここでは、ログファイルを指定します。

1. 使用するログファイルを指定する。

グループ「使用するログファイル」にあるラジオボタンの中から任意のログファイルを選択します。選択したログファイルに対して、ログファイルの指定方法が異なります。ログファイルの指定方法について、以下で説明します。

ログ種別 | 説明 | ログファイルの指定方法
自動ログアンロード機能で取得したアンロードログファイル | 自動ログアンロード運用時にアンロードログファイルを使用したリカバリを実行します。 | 自動ログアンロード運用で取得したアンロードログファイルを使用します。ログファイルを指定する必要はありません。
手動でアンロードしたアンロードログファイル | システムログをアンロードする運用を行っている場合は、ここを選択します。 | ディレクトリを指定する場合 | （１）アンロードログファイルが存在するホスト名を指定します。 （２）[ディレクトリ名を指定する]を選択します。 （３）[アンロードログファイルの指定]ボタンをクリック。 [アンロードログファイル格納先の指定]画面が表示されますので、ここでアンロードログファイルが格納されているディレクトリを指定します。 この画面については以下で説明します。 [アンロードログファイル格納先の選択]画面
 |  | ファイルを指定する場合 | （１）アンロードログファイルが存在するホスト名を指定します。 （２）[アンロードログファイルの指定]ボタンをクリック。 [アンロードログファイルの指定]画面が表示されますので、ここでアンロードログファイルを指定します。 この画面については以下で説明します。 [アンロードログファイルの指定]画面
システムログファイル（アンロードレスシステムログ運用） | アンロードレスシステムログ運用を行っている場合は、ここを選択します。 | システムログファイルを使用します。ログファイルを指定する必要はありません。

<注意事項>

·ディレクトリ指定を行う場合：

  ・対象HiRDBシステムが07-02より前のバージョンである場合は、本オプションを指定しないでください。

2. 回復指定時間を指定する。

データベース回復時の回復対象となる先頭のログの出力時刻と最終のログの出力時刻を指定します。

最新の同期点へ回復を行う場合は、終了時間を指定しないで下さい。

3. 「ソート用ワークバッファサイズ」を指定する。

SORTが使用するワークバッファサイズを指定します。指定しない場合は、デフォルト値で<<1024>>が仮定されます。設定範囲は((256～2097152))の間で指定することができます。

4. 「ソート用ワークディレクトリ名」を指定する。

SORTが使用する一時ファイルを作成するディレクトリ名を指定します。指定しない場合は、デフォルト値でUNIXでは/tmpが、Windowsでは%PDDIR%\tmpが仮定されます。

<注意事項>

· 管理対象HiRDBがWindows版パラレルサーバであり、非マネージャノードとマネージャノードのHiRDBのインストールディレクトリが異なる場合は、ソート用ワークバッファディレクトリにすべてのユニット上に存在するディレクトリを必ず指定してください。

5. 他タブページ、あるいは確認画面を表示する。

他タブページで設定しなければならない情報がある場合は、任意のタブページを表示します。オプションの設定内容を確認又はリカバリを実行する場合は[確認画面へ]ボタンをクリックします。

· [回復単位]ページ

· [バックアップファイル]ページ

· [詳細設定]ページ

· [確認]ページ


リカバリ カスタマイズ（アンロード格納先の指定）

[カスタマイズ]コマンド

リカバリ カスタマイズ (アンロードログファイル格納先の選択)

ここでは、アンロードログファイル格納先を指定します。

1.「アンロードログファイル格納先」を選択する。

  HiRDB CMで管理しているアンロードログファイル格納先一覧から、リカバリに使用するアンロードログファイルが格納されているディレクトリを指定します。

<注意事項>

· アンロードログファイルをHiRDBファイルシステム領域上に取得している場合は、格納先指定を行うことはできません。

2. [OK]ボタンをクリック。

[ログファイル]ページへ戻ります。


リカバリ カスタマイズ（アンロードログファイルの指定）

[カスタマイズ]コマンド

リカバリ カスタマイズ (アンロードログファイルの指定)

ここでは、アンロードログファイル名を指定します。

1.「アンロードログファイル」を選択する。

  アンロードログファイルをリストから選択し、追加ボタンを押下することで選択します。

  アンロードログファイルを複数指定する場合は、世代の古いものから順にから順に[追加]を行ってください。

<注意事項>

· 必要なアンロードログファイルをすべて指定する必要があります。必要なアンロードログファイルが足りない場合、リカバリがエラー終了します。

2. [OK]ボタンをクリック。

[ログファイル]ページへ戻ります。


リカバリ カスタマイズ(回復単位)

[カスタマイズ]コマンド

リカバリ カスタマイズ (回復単位)

ここでは、リカバリ対象名とリカバリに使用するファイル種別を指定します。

1. リカバリ対象を指定する。

グループ「回復単位」にあるラジオボタンの中から任意の単位を選択し、コンボボックスと各リストボックスからリカバリ対象を指定します。

· HiRDBシステム全体のリカバリを実行する場合:

グループ「回復単位」から「HiRDBシステム」ラジオボタンを選択し、コンボボックス「HiRDBシステム」から任意の対象を指定します。

· ユニット単位のリカバリを実行する場合:

グループ「回復単位」から「ユニット単位」ラジオボタンを選択します。コンボボックス「HiRDBシステム」から回復する対象が属するHiRDBシステムを選択してください。HiRDBシステムを選択すると、リストボックス「ユニット」に情報が表示されますので、任意のユニット名を指定します。

· サーバ単位のリカバリを実行する場合:

グループ「回復単位」から「サーバ単位」ラジオボタンを選択します。コンボボックス「HiRDBシステム」・「ユニット」から回復する対象が属するシステム名を選択してください。リストボックス「ユニット」で情報を選択すると、リストボックス「サーバ」に情報が表示されますので、任意のサーバ名を指定します。

· RDエリア単位のリカバリを実行する場合:

グループ「回復単位」から「RDエリア単位」ラジオボタンを選択します。コンボボックス「HiRDBシステム」・「ユニット」・「サーバ」から回復する対象が属するシステム名を選択してください。リストボックス「サーバ」で情報を選択すると、リストボックス「RDエリア」に情報が表示されますので、任意のRDエリア名を指定します。

· バックアップファイル中の全RDエリアのリカバリを実行する場合:

グループ「回復単位」から「バックアップファイル」ラジオボタンを選択します。

2. リカバリに使用するファイルを指定する。

グループ「使用ファイル」からリカバリに使用するファイルを選択します。

·バックアップファイルのみ

バックアップファイルのみを使用してバックアップ取得時へのリカバリを行います。

·ログファイルのみ

アンロードログファイル、又は、システムログのみを使用して現状の状態から任意の同期点へのリカバリを行います。

·バックアップファイル+ログファイル

バックアップファイルとアンロードログファイル、又は、システムログを使用してバックアップ取得時の状態から任意の同期点へのリカバリを行います。

3. 他タブページ、あるいは確認画面を表示する。

他タブページで設定しなければならない情報がある場合は、任意のタブページを表示します。オプションの設定内容を確認又はリカバリを実行する場合は[確認画面へ]ボタンをクリックします。

· [バックアップファイル]ページ

· [ログファイル]ページ

· [詳細設定]ページ

· [確認]ページ


リカバリ カスタマイズ(バックアップファイル)

[カスタマイズ]コマンド

リカバリ カスタマイズ (バックアップファイル)

ここでは、バックアップファイルを指定します。

1. バックアップファイル名を指定する。

ラジオボタンの中から任意のファイル種別を選択します。次にバックアップファイル名を入力しますが、ラジオボタンごとに入力するファイルの名前と指定方法が分かれます。

バックアップファイル名とその指定方法について、以下で説明します。

バックアップファイル名

選択したラジオボタン | 最大文字 指定数 | バックアップファイル名
通常ファイル | 1024 | (1) バックアップファイルを格納する「ホスト名」を選択する。 (2) 「バックアップ取得先」ボタンをクリック。 [バックアップファイルの指定]画面が表示されますので、ここでバックアップファイル名を指定します。 この画面については以下で説明します。 [バックアップファイルの指定]画面
HiRDBファイルシステム領域 | 1024 | (1) バックアップファイルを格納する「ホスト名」を選択する。 (2) 「バックアップ取得先」ボタンをクリック。 [バックアップファイルの指定]画面が表示されますので、ここでバックアップファイル名を指定します。 この画面については以下で説明します。 [バックアップファイルの指定]画面
EasyMT | 1024 | EasyMTのMTのスペシャルファイル名をコンボボックス「ホスト名」とエディットボックス「MTのスペシャルファイル名」に指定します。
EasyMT, MTguide | 1024 | MTguideが管理する装置記号名又は装置グループ名をコンボボックス「装置ホスト名」とエディットボックス「装置記号名又は装置グループ名」に指定します。
JP1/OmniBack Ⅱ | 512 | JP1/OmniBack Ⅱのディスクエージェントがあるホストをコンボボックス「ホスト名」に指定し、オブジェクト名をエディットボックス「オブジェクト名」に指定します。
NetBackup | 128 | ポリシーをコンボボックス「ポリシー名」から指定します。

2. [１]で指定したバックアップファイル種別に対するオプションに関する情報を指定する。

· バックアップファイル種別が「NetBackup」の場合:

グループ「NetBackup バックアップ条件選択」が指定できます。

§ 「NetBackup バックアップ条件選択」

同一ポリシー名を指定して実行したバックアップの中から、検索条件を指定することで、任意の時点で取得したバックアップを使用してリカバリを実行できます。

3. 他タブページ、あるいは確認画面を表示する。

他タブページで設定しなければならない情報がある場合は、任意のタブページを表示します。オプションの設定内容を確認又はリカバリを実行する場合は[確認画面へ]ボタンをクリックします。

· [回復単位]ページ

· [ログファイル]ページ

· [詳細設定]ページ

· [確認]ページ


リカバリ カスタマイズ(詳細設定)

[カスタマイズ]コマンド

リカバリ カスタマイズ (詳細設定)

ここでは、詳細なオプションを指定します。

1. バックアップファイル種別ごとのオプションを指定する。

[バックアップファイル]ページの「ファイル種別」グループで「EasyMT」・「EasyMT, MTguide」・「JP1/OmniBack Ⅱ」を選択している場合、次のオプションを指定します。

· バックアップファイル種別が「EasyMT」及び「EasyMT, MTguide」の場合:

グループ「EasyMT」のオプションを指定できます。

§ 「MT属性定義ファイル名」

EasyMT用のMT属性定義ファイルのファイル名を指定します。

§ 「入出力バッファ面数」

EasyMT用の入出力バッファ面数を指定します。指定値を大きくすれば性能が向上しますが、その分メモリ所要量も大きくなります。設定範囲は((1～255))の間で指定することができます。

§ 「MTのボリューム名」

バックアップを取得したMTのボリューム名を指定します。((最大6文字))まで指定可能で、カンマ","で区切ることにより、((最大10個))まで指定可能です。

例 :vol_001,vol_002

§ 「EasyMTファイル名」

バックアップファイル作成時に付けたファイル名を指定します。((最大17文字))まで指定可能です。

· バックアップファイル種別が「JP1/OmniBack Ⅱ」の場合:

バーリストファイル名を指定します。このオプションは必須項目です。

§ 「JP1/OmniBack Ⅱバーリストファイル名」

JP1/OmniBack Ⅱのバーリストファイル名を指定します。((最大64文字))まで指定可能です。

2. 差分バックアップ機能の使用有無を指定する。

· 「差分バックアップを使用する」

差分バックアップ機能を使用してリカバリを実行する場合に選択します。

§ 「差分バックアップグループ名」

任意の差分バックアップグループ名を指定します。((最大30文字))まで指定可能です。

3. リカバリの処理結果ファイルの出力有無を指定する。

· 「回復処理結果出力ファイルの出力有無」

§ 「回復処理結果ファイル名」

リカバリの処理結果を出力するファイル名を指定します。

4. 世代番号を指定する。

· 「世代番号の指定」

インナレプリカ機能を使用している場合、回復対象のRDエリアの世代番号を指定します。0を指定した場合はオリジナルRDエリアが対象となり、1～10を指定した場合は指定した世代のレプリカRDエリアが対象となります。

· 「ログに対応するRDエリアの世代番号の指定」

インナレプリカ機能を使用している場合、回復対象のRDエリアが複数世代にわたって更新されているときに、そのログに対応するRDエリアの世代番号を指定します。

§ 「世代番号」

0を指定した場合はオリジナルRDエリアが対象となり、1～10を指定した場合は指定した世代のレプリカRDエリアが対象となります。

§ 「カレントRDエリア」

システムログファイル中の各時点でカレントになっているRDエリアを対象とします。この場合，世代番号は意識しないで，システムログファイル中の各時点でカレントになっているRDエリアのログを使用して回復します。

<注意事項>

· 「カレントRDエリア」を指定した場合、3世代以上にわたって更新される場合や、複数世代が同時に更新される場合でも、各時点でカレントになっているRDエリアのログを使用して回復できます。なお、カレントの切り替え時は、切り替え直前のRDエリアと切り替え直後のRDエリアとで、内容が一致している必要があります（データだけでなく、ファイル内の配置も一致している必要があります）。

· 「カレントRDエリア」を指定する場合、バージョン07-00以降のHiRDBで出力されたログでなければなりません。

5. 他タブページ、あるいは確認画面を表示する。

他タブページで設定しなければならない情報がある場合は、任意のタブページを表示します。オプションの設定内容を確認又はリカバリを実行する場合は[確認画面へ]ボタンをクリックします。

· [回復単位]ページ

· [バックアップファイル]ページ

· [ログファイル]ページ

· [確認]ページ


リカバリ カスタマイズ(確認)

[カスタマイズ]コマンド

リカバリ カスタマイズ (確認)

ここでは選択した項目の確認を行い、リカバリの実行又はカタログの登録を実行します。

1. 情報の確認を行う。

表示されている項目を確認してください。

指定項目が不足している場合は、赤字で表示されます。該当するタブページで情報を入力してください。

2. 実行

· [実行]ボタンをクリック:

内容を確認し問題がなければ[実行]ボタンをクリックしてください。リカバリの実行を行います。

· [カタログ]ボタンをクリック:

[カタログの登録]画面が表示されますので、エディットボックス「カタログ名」に任意の名前を入力してください。カタログ名は英数字のみ指定可能です。

カタログ名を入力して[OK]ボタンをクリックすると、カタログの作成及び登録を行います。


リカバリ カスタマイズ(バックアップファイル格納先の選択)

[カスタマイズ]コマンド

リカバリ カスタマイズ (バックアップファイルの選択)

ここでは、バックアップファイル名を指定します。

1. 「バックアップファイル名」を指定する。

任意のバックアップファイルを入力します。

2. [OK]ボタンをクリック。

[バックアップファイル]ページへ戻ります。


HiRDBファイルシステム領域単位のリカバリ (回復単位)

[HiRDBファイルシステム領域単位のリカバリ]コマンド

回復単位ページ

ここでは、リカバリ対象名とリカバリに使用するファイル種別を指定します。

1. 回復対象を指定する。

グループ「回復単位」にあるラジオボタンの中から任意の単位を選択してください。

· HiRDBファイルシステム領域のリカバリを実行する場合:

グループ「回復単位」から「HiRDBファイルシステム領域」ラジオボタンを選択してください。

· HiRDBファイルのリカバリを実行する場合:

グループ「回復単位」から「HiRDBファイル」ラジオボタンを選択してください。

2. 対象のHiRDBシステムを選択する。

コンボボックス「HiRDBシステム」から回復する対象が属するシステム名を選択してください。

3. 対象のホスト名を選択する。

コンボボックス「ホスト名」から回復する対象が属するホスト名を選択してください。

4. リカバリ取得対象を選択する。

リストボックス「HiRDBファイルシステム領域」から回復する対象が属するHiRDBファイルシステム領域を選択してください。回復対象がHiRDBファイルの場合、リストボックス「HiRDBファイル」からHiRDBファイルを選択してください。

5. 使用するバックアップファイル名を選択する。

[バックアップファイルの指定]ボタンを押すと[バックアップファイルの指定]画面が表示されますので、バックアップファイル名を指定してください。

6. 他タブページ、あるいは確認画面を表示する。

他タブページで設定しなければならない情報がある場合は、任意のタブページを表示します。オプションの設定内容を確認又はリカバリを実行する場合は[確認画面へ]ボタンをクリックします。

· [詳細設定]ページ

· [確認]ページ


HiRDBファイルシステム領域単位のリカバリ (詳細設定)

[HiRDBファイルシステム領域単位のリカバリ]コマンド

詳細設定ページ

ここでは、詳細なオプションを指定します。

1.各オプションを指定する。

· 格納先に同名のHiRDBファイルがある場合の処理方針:

格納先のHiRDBファイルシステム領域に，リストアするバックアップファイル中にあるHiRDBファイルと同じ名称のHiRDBファイルがある場合の処理を指定します。

§ 格納先のHiRDBﾌｧｲﾙが更新されている場合は格納しない

    タイムスタンプを比較し，格納先のHiRDBのHiRDBファイルが更新されている場合は、格納しません。

§ バックアップファイル中のHiRDBファイルを格納しない

    バックアップファイル中のHiRDBファイルを格納しません。

§ 常にバックアップファイル中のHiRDBファイルを格納する

    タイムスタンプに関係なく、バックアップファイル中のHiRDBファイルを格納します。

2. 他タブページ、あるいは確認画面を表示する。

他タブページで設定しなければならない情報がある場合は、任意のタブページを表示します。オプションの設定内容を確認又はリカバリを実行する場合は[確認画面へ]ボタンをクリックします。

· [回復単位]ページ

· [確認]ページ


HiRDBファイルシステム領域単位のリカバリ (確認)

[HiRDBファイルシステム領域単位のリカバリ]コマンド

確認ページ

ここでは選択した項目の確認を行い、HiRDBファイルシステム領域単位のリカバリの実行又はカタログの登録を実行します。

1. 情報の確認を行う。

表示されている項目を確認してください。

指定項目が不足している場合は、赤字で表示されます。該当するタブページで情報を入力してください。

2. 実行

· [実行]ボタンをクリック:

内容を確認し問題がなければ[実行]ボタンをクリックしてください。リカバリの実行を行います。

· [カタログ]ボタンをクリック:

[カタログの登録]画面が表示されますので、エディットボックス「カタログ名」に任意の名前を入力してください。カタログ名は英数字のみ指定可能です。

カタログ名を入力して[OK]ボタンをクリックすると、カタログの作成及び登録を行います。


スケジュール ウィザード(カタログの指定)

[スケジュールの追加]コマンド

スケジュール ウィザード(カタログの指定)

ここでは、スケジュールを実行するカタログを指定します。

1. スケジュールを実行するカタログを選択する。

リストボックスにHiRDB CMが管理しているカタログが一覧表示されます。その中から任意のカタログ名を選択してください。なお、カタログ名は複数の選択はできません。

2. [次へ>]ボタンをクリック。

次の画面について、以下で説明します。

スケジュール名の指定と実行間隔の選択


スケジュール ウィザード(スケジュール名の指定と実行間隔の選択)

[スケジュールの追加]コマンド

スケジュール ウィザード(スケジュール名の指定と実行間隔の選択)

ここでは、スケジュール名と実行をする間隔を選択します。

1. スケジュール名を指定する。

エディットボックス「スケジュール名」に任意のスケジュール名を入力してください。

2. 実行間隔を選択。

3. [次へ>]ボタンをクリック。

次の画面について、以下で説明します。

開始時間の指定


スケジュール ウィザード(開始時間の指定)

[スケジュールの追加]コマンド

スケジュール ウィザード(開始時間の指定)

ここでは、スケジュールを実行をする開始時間を指定します。

1. スケジュールを実行する開始時間を指定する。

· 実行間隔が「一回」の場合:

スケジュールを開始する「時刻」と「日付」を指定します。

· 実行間隔が「毎日」・「毎週」・「毎月」の場合:

スケジュールを開始する「時刻」を指定します。

<注意事項>

· 「時刻」指定で指定した秒の単位は、カタログ開始時刻では無効となり、すべて「00」秒で実行を開始します。

2. [次へ>]ボタンをクリック。

[スケジュール名の指定と実行間隔の選択]の「実行間隔」ラジオボタンで選択した情報により、遷移する画面が分かれています。

次の画面について、以下で説明します。

[次へ>]...

選択したラジオボタン | 次の画面
一回 | 確認
毎日 | 実行期間の指定
毎週 | 週の指定
毎月 | 日付の指定


スケジュール ウィザード(週の指定)

[スケジュールの追加]コマンド

スケジュール ウィザード(週の指定)

ここでは、スケジュールを実行をする週を指定します。

1. スケジュールを実行する週を指定する。

2. [次へ>]ボタンをクリック。

次の画面について、以下で説明します。

実行期間の指定


スケジュール ウィザード(日付の指定)

[スケジュールの追加]コマンド

スケジュール ウィザード(日付の指定)

ここでは、スケジュールを実行をする日付を指定します

1. スケジュールを実行する日付を指定します。

2. [次へ>]ボタンをクリック。

次の画面について、以下で説明します。

実行期間の指定


スケジュール ウィザード(確認)

[スケジュールの追加]コマンド

スケジュール ウィザード(確認)

ここでは、選択した項目の確認を行います。

1. 情報の確認を行う。

2. [実行]ボタンをクリック。

内容を確認し問題がなければ[実行]ボタンをクリックしてください。スケジュールの実行を行います。

<注意事項>

· 「開始時刻」で表示される秒の単位は、カタログ開始時刻では無効となり、すべて「00」秒で実行を開始します。


スケジュール ウィザード(実行期間の指定)

[スケジュールの追加]コマンド

スケジュール ウィザード(実行期間の指定)

ここでは、スケジュールを実行期間を指定します。

開始日と終了日を指定し、その期間内のみスケジュールを行います。

1. 「スケジュールの実行期間を指定する」

実行期間を指定する場合は、このチェックボックス「スケジュールの実行期間を指定する」を選択してください。

実行期間を指定しない場合は、チェックボックスを選択せずに[次へ]ボタンをクリックして次画面へ進んでください。

· 「開始日」

スケジュール実行期間の開始日を指定します。

なお、ここで指定する日付は「終了日」で指定された日付を超えないようにしてください。

· 「終了日」

スケジュール実行期間の終了日を指定します。

なお、ここで指定する日付は「開始日」で指定された日付より以前には指定することができません。

2. [次へ>]ボタンをクリック。

次の画面について、以下で説明します。

確認


[外部ツールの起動]

[外部ツールの起動]コマンド

登録済みの外部ツールを起動します。

外部ツールの起動方法は登録時の指定により次の二通りに区別されます。

- HiRDBシステム情報を使用する起動

- HiRDBシステム情報を使用しない起動

l HiRDBシステム情報を使用する起動

HiRDBシステム情報を使用して外部ツールを起動する場合、登録したツールのタブメニューをクリックすると次の画面が表示されます。

1. HiRDBシステムを選択。

外部ツールが使用するHiRDBシステムを選択します。

2. 認可識別子とパスワードを入力。

HiRDBへ接続するための認可識別子とパスワードを入力します。

大文字/小文字は区別されるのでダブルコーテーションで囲む必要はありません。

3. 実行をクリック。

HiRDB CMはツール登録時の設定に応じて環境設定を行い、ユーザが指定したコマンドラインを実行します。

ツールの起動場所はConsoleのインストールディレクトリになります。

§ 環境変数が登録されている場合

設定された環境変数を有効にします。

§ コマンドライン引数、または、環境変数に以下のパラメータが含まれる場合

・ %HIRDB_IP%

・ %HIRDB_PATH%

・ %HIRDB_PORT%

・ %HIRDB_USER%

HiRDB CMは選択されたHiRDBシステムに接続して次の値を取得し、コマンドライン引数を置換、または環境変数を設定します。

パラメータ | 値
%HIRDB_USER% | 起動画面で入力した「認可識別子」と「パスワード」を「"認可識別子"/"パスワード"」の形式で設定する
%HIRDB_IP% | 起動画面で選択したHiRDBシステムの稼動するマシンのIPアドレス
%HIRDB_PORT% | 起動画面で選択したHiRDBシステムの使用するポート番号(システム共通定義のpd_name_port)
%HIRDB_PATH% | 起動画面で選択したHiRDBシステムの運用ディレクトリ(PDDIR)

§ HiRDBクライアント環境変数を設定する場合

[HiRDBクライアント環境変数設定]コマンドにより定義されているHiRDBクライアント環境変数を有効にします。

§ HiRDBクライアント環境変数を設定しない場合

[HiRDBクライアント環境変数設定]コマンドにより定義されているHiRDBクライアント環境変数は有効になりません。

<注意事項>

· ここでの「HiRDBクライアント環境変数が有効にならない」とはHiRDB CMに定義されている各変数の値を設定しないことを意味します。Consoleの稼動するマシンのシステム環境変数やユーザ環境変数、および、HiRDB.iniファイルに設定されているHiRDBクライアント環境変数を無効にしてツールを起動するのではありません。システム環境変数やユーザ環境変数、および、HiRDB.iniファイルの設定は起動するツールに引き継がれますので注意してください。

· 「実行」ボタンクリック後、KFPE12527-Iメッセージが表示されたにもかかわらずツールが起動しない場合は、登録されているコマンドライン引数や環境変数が間違っている可能性があります。設定を見直してから再度実行してください。

l HiRDBシステム情報を使用しない起動

HiRDB CMはツール登録時に設定された環境変数を有効にし、ユーザが指定したコマンドラインを実行します。

ツールの起動場所はConsoleのインストールディレクトリになります。

<注意事項>

· 「実行」ボタンクリック後、KFPE12527-Iメッセージが表示されたにもかかわらずツールが起動しない場合は、登録されているコマンドライン引数や環境変数が間違っている可能性があります。設定を見直してから再度実行してください。


改ざん防止表ウィザード_2_5

改ざん防止表移行ウィザード 2/5 - 削除禁止期間設定画面

改ざん防止表で保持されるデータを一定期間後に削除する運用を行う場合に、削除禁止期間を設定します。

<前提条件>

· 削除禁止期間を設定する場合、あらかじめSYSTEM GENERATEDオプション指定されたDATE型の列を対象表に定義しておいてください。該当する列がある場合だけ、その列を挿入履歴保持列として指定することで、削除禁止期間の設定を行うことができます。

1. 削除禁止期間の適用を選択。

§ 「表のデータの削除を行わない。」を選択

削除禁止期間を設定しない場合に選択します。

§ 「一定期間後に表のデータの削除を許可する。」を選択

削除禁止期間を設定する場合に選択します。次の２つの値を設定します。

-「挿入履歴保持列名」の選択

「挿入履歴保持列」コンボボックスから挿入履歴を保持する列を選択します。

-「行削除禁止期間」の選択

データ挿入日からデータを削除できる範囲を、年、月、日のいずれかの単位で指定します。

2. 「次へ」を選択。

「次へ」ボタンを選択し、次の画面に進みます。

改ざん防止ウィザード 3/5 - 更新可能列設定画面


改ざん防止表ウィザード_1_5

改ざん防止表移行ウィザード 1/5 - 対象表選択画面

処理対象となるシステムと表を決定します。

1. 「HiRDBシステム」を選択。

「HiRDBシステム」コンボボックスから対象となるHiRDBシステムを選択します。

2. 改ざん防止表への移行を行う表を選択。

「改ざん防止表へ移行可能な表一覧」リストから改ざん防止表への移行を行う表を選択します。

3. 「パスワード」の指定。

選択した改ざん防止表への移行を行う表の所有者のパスワードを「パスワード」テキストボックスに指定します。

4. 「次へ」を選択。

「次へ」ボタンを選択し、次の画面に進みます。

改ざん防止ウィザード 2/5 - 削除禁止期間設定画面

<注意事項>

· 本画面で表示されるHiRDBシステムと表は、「改ざん防止表ウィザード」で改ざん防止表への移行が行えるHiRDBシステムと表だけを表示します。改ざん防止表への移行が行えないものは表示されません。


改ざん防止表ウィザード_3_5

改ざん防止表移行ウィザード 3/5 - 更新可能列設定画面

改ざん防止表に移行後、一部の列データの更新を許す運用をする場合に、更新可能列を設定します。また、更新可能列に常に更新を許すか、もしくはナル値から一回だけ非ナル値への更新を許すかを選択することができます。

1. 更新可能列の適用を選択。

§ 「列単位でのデータ更新を許可しない」を選択

列単位でデータ更新を許可しない場合に選択します。

§ 「一部の列の更新を許可する。」を選択

一部の列の更新を許可する場合に選択します。

-更新可能列の選択

「列一覧」リストに列名が表示されます。対象の列を選択し、「>>」ボタンをクリックすることで、「更新可能列一覧」リストに登録することができます。更新可能列として指定できる列は、「列一覧」リストの「選択可否」列に○と表示されます。指定できない列は、×で表示されます。

-更新種別の選択

「更新可能列一覧」リスト上で、常に更新を許すか、もしくはナル値から一回だけ非ナル値への更新を許すかを選択します。対象の更新可能列のチェックボックスをチェックすると、ナル値から非ナル値への更新を一回だけ許す設定になります。チェックボックスにチェックしない場合は、常に更新を許す列になります。

2. 「次へ」を選択。

「次へ」ボタンを選択し、次の画面に進みます。

改ざん防止ウィザード 4/5 - 一時ファイル格納先設定画面

<注意事項>

· すべての列を更新可能列に設定することはできません。すべての列を「更新可能列一覧」リストに登録した場合、「次へ」ボタンを選択した段階で、エラーになります。


改ざん防止表ウィザード_4_5

改ざん防止表移行ウィザード 4/5 - 一時ファイル格納先設定画面

改ざん防止表への移行中に作成されるバックアップファイル、アンロードファイルなどの一時ファイルを格納するディレクトリを設定します。

1. 一時ファイル格納先ディレクトリを指定します。

各ホストに、一時ファイルを格納するディレクトリを指定します。「一時ファイル格納先一覧」リストを選択し、「上」ボタンを押すことで、一時ファイル格納先ディレクトリを変更できます。一時ファイル格納先ディレクトリを変更したあとは、「下」ボタンを押し一時ファイル格納先ディレクトリを更新することができます。

2. 「次へ」を選択。

「次へ」ボタンを選択し、次の画面に進みます。

改ざん防止ウィザード 5/5 - 確認画面

<注意事項>

· 一時ファイル格納先ディレクトリには、すべてのホスト上で以下のファイルが作成できる領域を用意しておいてください。各データファイルの見積もりは、HiRDBのマニュアルを参照してください。

- バックアップファイル

対象の表とその表に定義されているすべてのインデクスが存在するRDエリアのバックアップと、ディクショナリ用RDエリアのバックアップを一時的に格納します。パラレルサーバの場合は、マネージャノード上に作成されます。

- アンロードファイル

改ざん防止表への移行を行う表のすべてのデータをバイナリ形式アンロードファイルで一時的に格納します。パラレルサーバの場合、表が存在するサーバ上に作成されます。対象の表が分割表の場合は、表が存在するすべてのサーバ上ですべての表データが格納できる領域を準備する必要があります。

- インデクス情報ファイル

データベース作成ユティリティを実行したときに一時的に作成されるインデクス情報ファイルを一時的に格納します。

· 一時ファイル格納先ディレクトリは、デフォルトの設定では、HiRDBディレクトリ(PDDIR)/tmpディレクトリが指定されています。そのため、容量不足が発生するとHiRDBの動作に影響を与える場合があります。他のディスクを用意できる場合は、別ディスク上のディレクトリを指定してください。


改ざん防止表ウィザード_5_5

改ざん防止表移行ウィザード 5/5 - 確認画面

設定項目を確認した後、改ざん防止表への移行を実行します。

１. 「実行」を選択。

「実行」ボタンを選択し、改ざん防止表への移行を実行します。

<注意事項>

· 改ざん防止表への移行を行う表の規模によって、処理時間が長くなる場合があります。[コンソール 応答待ち時間]の設定値を確認してから実行してください。


[プロセスの変更]コマンド

プロセス情報表示 プロセスの状態表示 (pdls -d prc -s) を実行すると、リストにサーバのプロセス状態一覧が表示されます。リスト下のボタンから表示されたサーバに対して次のコマンドが実行できます。

§ プロセス数変更 (pdchprc -p)

§ プロセスのリフレッシュ(pdpfresh)

l プロセス数の変更 (pdchprc -p)

1. 常駐プロセス数を変更します。

常駐プロセス数の[定義値]に表示される数値以下の値に常駐プロセス数を変更することができます。

2. 最大起動プロセス数を変更します。

最大起動プロセス数の[定義値]に表示される数値以下の場合に最大起動プロセス数を変更することができます。

3. [実行]ボタンをクリック。

サーバプロセス数の変更を実行します。

<注意事項>

· 現在のサーバ稼動プロセス数取得(pdchprc)に失敗した場合は、[サーバプロセス数の変更]画面は表示されません。

· サーバプロセスのリフレッシュ中に本コマンドを実行しないでください。実行した場合は、エラー終了します。

l サーバプロセスのリフレッシュ (pdpfresh)

1. オプションを指定。

以下のオプションを有効にする場合は、チェックボックスを選択します。

§ 強制的にプロセスをリフレッシュする。

  強制的にリフレッシュする場合に指定します。

§ リフレッシュ完了までコマンドの終了を待ち合わせる。

    pdpfresh実行後にすべてのサーバプロセスの起動が完了するまで待ち合わせる場合に指定します。

3. [実行]ボタンをクリック。

サーバプロセスのリフレッシュを実行します。

<注意事項>

· 「リフレッシュ完了までコマンドの終了を待ち合わせる」オプションを指定しないで実行した場合、実行後にサーバプロセスが何も表示されない場合があります。リフレッシュが終了してから再度、[プロセス情報表示]ボタンをクリックしてください。


[RDエリアの状態変更]コマンド

RDエリア詳細情報 RDエリア詳細情報 (pddbls -s) を実行すると、リストにRDエリア一覧が表示されます。

そのリストからRDエリア名を選択し、リスト下のボタンあるいは右ポップアップメニューから次のコマンドが実行できます。

§ 閉塞 (pdhold)

§ 閉塞解除 (pdrels)

§ オープン/クローズ (pdopen, pdclose)

§ カレント状態変更 (pddbchg)

これらのコマンドを実行すると、RDエリア状態変更を実行するための画面が表示されます。

<注意事項>

· XDM/RDのRDエリアに対するRDエリア状態変更はサポートしていません。

l 閉塞 (pdhold)

指定したRDエリアを閉塞します。

各コマンドについて以下で説明します。

1. 実行する閉塞を選択。

指定したRDエリアに対し、実行する閉塞を選択してください。

· 「閉塞 (参照可) 」 (pdhold -i)

閉塞したRDエリアに対して、ユーザからの参照を許可する場合に実行します。

· 「閉塞 (参照不可) 」 (pdhold)

RDエリアを閉塞します。閉塞したRDエリアに対して、ユーザからの参照はできません。

· 「閉塞&クローズ」 (pdhols -c)

閉塞を行った後、RDエリアをクローズします。

· 「参照可能バックアップ閉塞」 (pdhold -b)

HiRDB Staticizer Optionが組み込まれている場合にのみ実行できます。

閉塞解除をするまで更新トランザクションをエラーにしても良い場合に実行します。

· 「参照可能バックアップ閉塞 (更新WAITモード) 」 (pdhold -b -w)

HiRDB Staticizer Optionが組み込まれている場合にのみ実行できます。

閉塞解除をするまで更新トランザクションを待たせても良い場合に実行します。

· 「更新可能バックアップ閉塞」 (pdhold -b -u)

HiRDB Staticizer Optionが組み込まれている場合にのみ実行できます。

すぐにバックアップ閉塞を行いたい場合で、且つ、バックアップ閉塞中もそのRDエリアに対してアクセスしたい時に実行します。

· 「更新可能バックアップ閉塞 (WAITモード) 」 (pdhold -b -w -u)

HiRDB Staticizer Optionが組み込まれている場合にのみ実行できます。

更新トランザクションの完了を待ってバックアップ閉塞にしてもよい場合で、且つ、バックアップ閉塞中にそのRDエリアにアクセスしたい時に実行します。

· 「同期化閉塞」 (pdhold -s)

HiRDB Staticizer Optionが組み込まれており、且つ、インナレプリカ機能を使用している場合に実行できます。

RDエリアのバッファを破棄し、参照及び更新トランザクションを待ち状態にする場合に実行します。

2. [実行]ボタンをクリック。

RDエリアの閉塞を実行します。

l 閉塞解除 (pdrels)

指定したRDエリアの閉塞状態を解除します。

各コマンドについて以下で説明します。

1. 実行する閉塞解除を選択。

指定したRDエリアに対し、実行する閉塞解除を選択してください。

· 「閉塞解除」 (pdrels)

RDエリアの閉塞状態を解除します。

· 「閉塞解除&オープン」 (pdrels -o)

閉塞状態を解除した後、RDエリアをオープンします。

2. [実行]ボタンをクリック。

RDエリアの閉塞解除を実行します。

l オープン/クローズ (pdopen,pdclose)

指定したRDエリアをオープンあるいはクローズします。

各コマンドについて以下で説明します。

1. 実行するコマンドを選択。

指定したRDエリアに対し、実行するコマンドを選択してください。

· 「オープン」 (pdopen)

指定したRDエリアをオープンします。

· 「クローズ」 (pdclose)

指定したRDエリアをクローズします。

2. [実行]ボタンをクリック。

RDエリアのオープンあるいはクローズを実行します。

l レプリカRDエリアのカレント状態変更 (pddbchg)

レプリカRDエリアのレプリカステータスを切り替えます（サブRDエリアをカレントRDエリアに変更します）。実行手順を以下に示します。

1. 世代番号を指定。

  カレントRDエリアに変更するRDエリアの世代番号を指定します。

2. WAITを指定。

  指定したRDエリアに対して排他が掛かっている場合、システム定義のpd_lck_wait_timeoutオペランドの指定値の範囲内で、排他が解除されるまで待つときに指定します。このオプションを省略した場合、指定したRDエリアに対してほかのトランザクションが排他を掛けていると、エラー終了します。

3. [OK]ボタンをクリック。

レプリカRDエリアのレプリカステータスを切り替えます。

<注意事項>

· レプリカRDエリアのレプリカステータス変更は、オリジナルRDエリアを選択した場合のみ実行可能です。インナレプリカを使用していないRDエリアまたは、オリジナルRDエリア以外のRDエリアを選択して実行した場合は、処理に失敗します。


[トランザクションの変更]コマンド

トランザクション制御情報表示 トランザクションの状態表示 (pdls -d trn -a) を実行すると、リストにトランザクション状態一覧が表示されます。リスト下のボタンから表示されたサーバに対して次のコマンドが実行できます。

§ 強制終了 (pdcancel)

l UAP処理の強制終了 (pdcancel)

UAPを処理するHiRDB側の処理プロセスを，UAPから強制的に切り離し，終了します。

<注意事項>

· シングルサーバまたは、フロントエンドサーバ、以外のサーバのプロセスは強制終了できません。


AIXでのデバイス情報ファイルの作成例

AIXでのデバイス情報ファイル作成例

  ここでは、AIXでのデバイス情報ファイルの作成方法について説明します。ここで紹介する方法は、標準的なコマンドを使用した方法であり、デバイスの構成によっては、ここで紹介する以外のコマンドを使用する必要がある場合があります。

次の手順でデバイス情報ファイルを作成します。

①. デバイス情報ファイルを作成します。

HiRDB CM Agentをインストールした段階で、次に示すデバイス情報ファイルの雛形が作成されます。

{HiRDBインストールディレクトリ}/CMAgent/util/cmadevinfo_format

このファイルをコピーして、次の名前に名前を変更します。

{HiRDBインストールディレクトリ}/CMAgent/util/cmadevinfo

②. DISK一覧を取得します。

  DISKの一覧は、OSのlsdevコマンドで取得することができます。

次のコマンドを実行し、物理デバイスの一覧を取得します。

# lsdev -C -c disk -S a

hdisk7  使用可能 3A-09-00-8,0  16 ビット LVD SCSI ディスク・ドライブ

hdisk9  使用可能 3A-09-00-10,0 16 ビット LVD SCSI ディスク・ドライブ

hdisk10 使用可能 3A-09-00-11,0 16 ビット LVD SCSI ディスク・ドライブ

hdisk3  使用可能 11-09-00-3,0  他の SCSI ディスク・ドライブ

hdisk8  使用可能 3A-09-00-9,0  16 ビット LVD SCSI ディスク・ドライブ

hdisk11 使用可能 11-09-00-4,0  他の SCSI ディスク・ドライブ

hdisk0  使用可能 11-09-00-2,0  他の SCSI ディスク・ドライブ

hdisk4  使用可能 11-09-00-6,0  他の SCSI ディスク・ドライブ

hdisk5  使用可能 11-09-00-5,0  他の SCSI ディスク・ドライブ

hdisk1  使用可能 11-09-00-1,0  他の SCSI ディスク・ドライブ

この情報から、[DISK]タグを次のように定義することが出来ます。

[DISK]

/dev/hdisk0;;;

/dev/hdisk1;;;

/dev/hdisk3;;;

/dev/hdisk4;;;

/dev/hdisk5;;;

/dev/hdisk7;;;

/dev/hdisk9;;;

/dev/hdisk10;;;

/dev/hdisk11;;;

[/DISK]

HiRDB CMでは、デバイス情報はすべてフルパスで管理します。そのため、先頭/dev/をつけた形で定義を行います。

対象のシステムがRAIDを使用している構成の場合は、LU、LDEV、RAIDなどの情報をDISKタグの情報に追加してください。

③. LVMの情報を取得します。

次のコマンドを実行し、ボリュームグループ名（VG）の一覧を取得します。（手順１）

# lspv

hdisk7          00014c0f8ef385a5                    rootvg

hdisk9          00014c0fd26dbdf5                    vg02

hdisk10         00014c0fd26ebe23                    vg02

hdisk3          00014c0f1958c2dc                    vg05

hdisk8          00014c0fe2c02193                    vg00

hdisk11         00014c0fc725bda6                    vg06

hdisk0          00014c0fd17937b6                    vg04

hdisk4          00014c0fccbd9eae                    vg08

hdisk5          00014c0fe2c0a934                    vg07

hdisk1          00014c0f4dcff58d                    vg03

VG名が表示されていない行の情報は、VGが割りあたっていないため対象外とします。

各ボリュームグループ名（VG）に対して、次のコマンドを実行し、論理ボリューム名を取得します。（手順２）

ここでは、vg02を例にして記述します。

# lsvg -l vg02

vg02:

LV NAME             TYPE       LPs   PPs   PVs  LV STATE      MOUNT POINT

hd3-18G-dv6         jfs        156   156   1    open/syncd    /hirdb4

hd3-18G-dv7         jfs        156   156   1    open/syncd    /hirdb5

hd3-18G-dv8         jfs        156   156   1    open/syncd    /hirdb6

loglv03             jfslog     1     1     1    open/syncd    N/A

hd3-18G-dv7-log     jfslog     1     1     1    open/syncd    N/A

hd3-18G-dv8-log     jfslog     1     1     1    open/syncd    N/A

raw01               jfs        4     4     1    closed/syncd  N/A

raw02               jfs        4     4     1    closed/syncd  N/A

raw03               jfs        4     4     1    closed/syncd  N/A

TSG                 jfs        31    31    1    open/syncd    /TSG

TYPEによって必要なものだけを抜き出します。上記例では、jfslogはユーザが使用できない領域であるため、デバイス情報から除外します。

手順1,2から[VMINFO]タグの情報を次のように定義できます。

[VMINFO]

/dev/hdisk10;/dev/vg02;/dev/hd3-18G-dv6

/dev/hdisk10;/dev/vg02;/dev/hd3-18G-dv7

/dev/hdisk10;/dev/vg02;/dev/hd3-18G-dv8

/dev/hdisk10;/dev/vg02;/dev/raw01

/dev/hdisk10;/dev/vg02;/dev/raw02

/dev/hdisk10;/dev/vg02;/dev/raw03

/dev/hdisk10;/dev/vg02;/dev/TSG

/dev/hdisk9;/dev/vg02;/dev/hd3-18G-dv6

/dev/hdisk9;/dev/vg02;/dev/hd3-18G-dv7

/dev/hdisk9;/dev/vg02;/dev/hd3-18G-dv8

/dev/hdisk9;/dev/vg02;/dev/raw01

/dev/hdisk9;/dev/vg02;/dev/raw02

/dev/hdisk9;/dev/vg02;/dev/raw03

/dev/hdisk9;/dev/vg02;/dev/TSG

[/VMINFO]

手順2,3を各VGごとに行い、[VMINFO]タグ情報を追加してください。HiRDB CMでは、全てのDiskパス名を/devからのフルパスで明記する必要があります。先頭に/devを追加して記載してください。

④. FSの情報を取得します。

  FSの情報はdfコマンドにより取得することが出来ます。

次のコマンドを実行し、FS名の一覧を取得します。

# df

Filesystem    512-blocks      Free %Used    Iused %Iused Mounted on

/dev/hd4          327680    256216   22%     4179     6% /

/dev/hd2        12058624    219936   99%   107288     8% /usr

/dev/hd9var      2031616    386776   81%     2715     2% /var

/dev/hd3         2031616   1092000   47%      793     1% /tmp

/dev/hd1         8060928   1302456   84%     7666     1% /home

/proc                  -         -    -         -     -  /proc

/dev/hd10opt     2293760    654592   72%     4496     2% /opt

/dev/hd2-18G-dv3   10223616    455200   96%   132607    11% /hirdb1

/dev/hd2-18G-dv4   10223616    864912   92%    75307     6% /hirdb2

/dev/hd2-18G-dv5   10223616    340664   97%    56759     5% /hirdb3

･･･

この結果から、[FS]タグの情報次のように定義できます。

[FS]

/dev/hd4;/

/dev/hd2;/usr

/dev/hd9var;/var

/dev/hd3;/tmp

/dev/hd1;/home

/dev/hd10opt;/opt

/dev/hd2-18G-dv3;/hirdb1

/dev/hd2-18G-dv4;/hirdb2

/dev/hd2-18G-dv5;/hirdb3

････

[/FS]


HP-UXでのデバイス情報ファイル作成例

  ここでは、HP-UXでのデバイス情報ファイルの作成方法について説明します。ここで紹介する方法は、標準的なコマンドを使用した方法であり、デバイスの構成によっては、ここで紹介する以外のコマンドを使用する必要がある場合があります。

次の手順でデバイス情報ファイルを作成します。

①. デバイス情報ファイルを作成します。

HiRDB CM Agentをインストールした段階で、次に示すデバイス情報ファイルの雛形が作成されます。

{HiRDBインストールディレクトリ}/CMAgent/util/cmadevinfo_format

このファイルをコピーして、次の名前に名前を変更します。

{HiRDBインストールディレクトリ}/CMAgent/util/cmadevinfo

②. DISK一覧を取得します。

  DISKの一覧は、ioscanコマンドで取得することができます。次にsdiskデバイスドライバ（HP-UXが標準で提供するSCSIディスク制御用のデバイスドライバ）を使用したシステムでディスクの一覧を取得する方法を次に示します。

次のコマンドにより、Diskの一覧を表示することができます。

/usr/sbin/ioscan -kfnd sdisk | grep -e "/dev/"

   このコマンドは、スーパユーザ権限で実行する必要があります。

#/usr/sbin/ioscan -kfnd sdisk 2>/dev/null | grep -e "/dev/"

                           /dev/dsk/c0t0d0     /dev/rdsk/c0t0d0

                           /dev/dsk/c2t0d0     /dev/rdsk/c2t0d0

                           /dev/dsk/c2t1d0     /dev/rdsk/c2t1d0

                           /dev/dsk/c2t2d0     /dev/rdsk/c2t2d0

                           /dev/dsk/c2t2d1     /dev/rdsk/c2t2d1

                           /dev/dsk/c2t2d2     /dev/rdsk/c2t2d2

実行結果で、前方に表示されたレコードは、物理ドライブ名であり、後方はrawデバイススペシャルファイル名になります。HiRDB CMでは、物理ドライブ名を使用します。

（/dev/dsk/cntndn ('n'は任意の数値)が、物理Disk名になります。）

この情報から、[DISK]タグを次のように定義することが出来ます。

[DISK]

/dev/dsk/c0t0d0;;;

/dev/dsk/c2t0d0;;;

/dev/dsk/c2t1d0;;;

[/DISK]

対象のシステムがRAIDを使用している構成の場合は、LU、LDEV、RAIDなどの情報をDISKタグの情報に追加してください。

③. LVMの情報を取得します。

  LVM情報は、使用しているLVMの管理ソフトに応じたコマンドを発行して取得します。ここでは、HP-UXの標準のLVM機構を使用している場合の例を記載します。

次のコマンドを実行し、ボリュームグループ名（VG）の一覧を取得します。（手順１）

#/usr/sbin/vgdisplay 2>/dev/null | egrep 'VG Name'

VG Name                     /dev/vg00

VG Name                     /dev/vg01

VG Name                     /dev/vg02

各ボリュームグループ名（VG）に対して、次のコマンドを実行し、論理ボリューム名を取得します。（手順２）

ここでは、/dev/vg00を例にして記述します。

$ /usr/sbin/vgdisplay -v /dev/vg00 2>/dev/null | egrep -e "LV Name"

   LV Name                     /dev/vg00/lvol1

   LV Name                     /dev/vg00/lvol2

   LV Name                     /dev/vg00/lvol3

各VG名に対して次のコマンドを実行し、PV情報を取得します。（手順3）

$ /usr/sbin/vgdisplay -v /dev/vg00 2>/dev/null | egrep -e "PV Name"

   PV Name                     /dev/dsk/c0t0d0

   PV Name                     /dev/dsk/c2t0d0

手順1,2,3から[VMINFO]タグの情報を次のように定義できます。

[VMINFO]

/dev/dsk/c0t0d0;/dev/vg00;/dev/vg00/lvol1

/dev/dsk/c2t0d0;/dev/vg00;/dev/vg00/lvol1

/dev/dsk/c0t0d0;/dev/vg00;/dev/vg00/lvol2

/dev/dsk/c2t0d0;/dev/vg00;/dev/vg00/lvol2

/dev/dsk/c0t0d0;/dev/vg00;/dev/vg00/lvol3

/dev/dsk/c2t0d0;/dev/vg00;/dev/vg00/lvol3

[/VMINFO]

手順2,3を各VGごとに行い、[VMINFO]タグ情報を追加してください。

④. FSの情報を取得します。

  FSの情報はdfコマンドにより取得することが出来ます。

次のコマンドを実行し、FS名の一覧を取得します。

#df -l

/cm                  (/dev/vg01/lvol1     ):   491770 blocks     65414 i-nodes

/home                (/dev/vg00/lvol1     ):    32064 blocks       474 i-nodes

/home1               (/dev/vg00/lvol2     ):  1376516 blocks    183219 i-nodes

/home2               (/dev/vg00/lvol3     ):  1989078 blocks    264773 i-nodes

/opt                 (/dev/vg02/lvol2     ):  1276864 blocks     20043 i-nodes

/                    (/dev/vg02/lvol1     ):  1276864 blocks     20043 i-nodes

この結果から、[FS]タグの情報次のように定義できます。

[FS]

/dev/vg01/lvol1;/cm

/dev/vg00/lvol1:/home

/dev/vg00/lvol2;/home1

/dev/vg00/lvol3;/home2

/dev/vg02/lvol2;/opt

/dev/vg02/lvol1;/

[/FS]


LINUXでのデバイス情報ファイル作成例

  ここでは、Liuxでのデバイス情報ファイルの作成方法について説明します。ここで紹介する方法は、標準的なコマンドを使用した方法であり、デバイスの構成によっては、ここで紹介する以外のコマンドを使用する必要がある場合があります。

次の手順でデバイス情報ファイルを作成します。

①. デバイス情報ファイルを作成します。

HiRDB CM Agentをインストールした段階で、次に示すデバイス情報ファイルの雛形が作成されます。

{HiRDBインストールディレクトリ}/CMAgent/util/cmadevinfo_format

このファイルをコピーして、次の名前に名前を変更します。

{HiRDBインストールディレクトリ}/CMAgent/util/cmadevinfo

②. DISK一覧を取得します。

  DISKの一覧は、OSの/proc/partitionsファイルに記載されている情報から、sdまたは、hdで始まるデバイス名を取り出します。

/proc/ partitionsファイルのコピーをローカルに作成します。

cp /proc/ partitions /home/users/cmuser/paritions_file

コピーしたファイルに対し次のコマンドを実行してDiskの一覧を取得します。

#cd /home/users/cmuser

#cat paritions_file | sed -n '3,$p' | awk '{print $4}' | egrep 'sd[a-z]|hd[a-z]'

sda

sda1

sda2

sda3

sdb

sdb1

sdb2

sdb3

sdb4

hda

hda1

hda2

hda3

sdx、hdx(xは任意の英数字)はDisk名になります。sdxn、hdxn(xは任意の英数字、nは任意の数字)は各Diskのパーテション名になります。

この情報から、[DISK]タグ、[PART]タグを次のように定義することが出来ます。

[DISK]

/dev/sda;;;

/dev/sdb;;;

/dev/hda;;;

[/DISK]

[PART]

/dev/sda;/dev/sda1

/dev/sda;/dev/sda2

/dev/sda;/dev/sda3

/dev/sdb;/dev/sdb1

/dev/sdb;/dev/sdb2

/dev/sdb;/dev/sdb3

/dev/sdb;/dev/sdb4

/dev/hda;/dev/hda1

/dev/hda;/dev/hda2

/dev/hda;/dev/hda3

[/PART]

対象のシステムがRAIDを使用している構成の場合は、LU、LDEV、RAIDなどの情報をDISKタグの情報に追加してください。

③. LVMの情報を取得します。

  LVM情報は、使用しているLVMの管理ソフトに応じたコマンドを発行して取得します。ここでは、Linux Logical Volume Manager機構を使用している場合の例を記載します。

次のコマンドを実行し、ボリュームグループ名（VG）の一覧を取得します。（手順１）

#/sbin/vgdisplay | egrep 'VG Name'

VG Name               vg001

VG Name               vg002

VG Name               vg003

各ボリュームグループ名（VG）に対して、次のコマンドを実行し、論理ボリューム名を取得します。（手順２）

ここでは、/dev/vg001を例にして記述します。

#/sbin/vgdisplay -v vg001 | egrep 'LV Name'

LV Name                /dev/vg001/lv001

LV Name                /dev/vg001/lv002

LV Name                /dev/vg001/lv003

各VG名に対して次のコマンドを実行し、PV情報を取得します。（手順3）

#/sbin/vgdisplay -v vg001 | egrep 'PV Name'

PV Name (#)           /dev/sda1 (1)

PV Name (#)           /dev/sdb1 (2)

手順1,2,3から[VMINFO]タグの情報を次のように定義できます。

[VMINFO]

/dev/sda1;/dev/vg001;/dev/vg001/lv001

/dev/sdb1;/dev/vg001;/dev/vg001/lv001

/dev/sda1;/dev/vg001;/dev/vg001/lv002

/dev/sdb1;/dev/vg001;/dev/vg001/lv002

/dev/sda1;/dev/vg001;/dev/vg001/lv003

/dev/sdb1;/dev/vg001;/dev/vg001/lv004

[/VMINFO]

手順2,3を各VGごとに行い、[VMINFO]タグ情報を追加してください。HiRDB CMでは、全てのDiskパス名を/devからのフルパスで明記する必要があります。先頭に/devを追加して記載してください。

④. FSの情報を取得します。

  FSの情報はdfコマンドにより取得することが出来ます。

次のコマンドを実行し、FS名の一覧を取得します。

#df

Filesystem           1K-ブロック    使用   使用可 使用% マウント位置

/dev/hda1             10317860   7122124   2671616  73% /

/dev/hda2               101089      9356     86514  10% /boot

/dev/hda3              1101089      4356     86514  10% /opt

/dev/vg001/lv001       2064208     30480   1928872   2% /db_ios

/dev/vg001/lv002       1032088      1764    977896   1% /home1

/dev/vg002/lv001       4120384    134712   3776368   4% /home2

/dev/vg002/lv002       4120384    134712   3776368   4% /home3

この結果から、[FS]タグの情報次のように定義できます。

[FS]

/dev/hda1;/

/dev/hda2;/boot

/dev/hda3;/opt

/dev/vg001/lv001;/db_ios

/dev/vg001/lv002;/home1

/dev/vg002/lv001;/home2

/dev/vg002/lv002;/home3

[/FS]


Solarisでのデバイス情報ファイル作成例

  ここでは、Solarisでのデバイス情報ファイルの作成方法について説明します。ここで紹介する方法は、標準的なコマンドを使用した方法であり、デバイスの構成によっては、ここで紹介する以外のコマンドを使用する必要がある場合があります。

次の手順でデバイス情報ファイルを作成します。

①. デバイス情報ファイルを作成します。

HiRDB CM Agentをインストールした段階で、次に示すデバイス情報ファイルの雛形が作成されます。

{HiRDBインストールディレクトリ}/CMAgent/util/cmadevinfo_format

このファイルをコピーして、次の名前に名前を変更します。

{HiRDBインストールディレクトリ}/CMAgent/util/cmadevinfo

②. DISK一覧を取得します。

formatコマンドの初期画面に表示される物理ディスクの一覧から情報を取得します。

AVAILABLE DISK SELECTIONS:

       0. c1t0d0 <SUN18G cyl 7506 alt 2 hd 19 sec 248>

          /pci@1f,0/pci@1/scsi@8/sd@0,0

       1. c2t8d0 <SUN18G cyl 7506 alt 2 hd 19 sec 248>

          /pci@1f,0/pci@1/scsi@8,1/sd@8,0

       2. c2t9d0 <SUN18G cyl 7506 alt 2 hd 19 sec 248>

          /pci@1f,0/pci@1/scsi@8,1/sd@9,0

       3. c3t2d0 <SUN18G cyl 7506 alt 2 hd 19 sec 248>

          /pci@1f,0/pci@1/pci@5/SUNW,isptwo@4/sd@2,0

       4. c3t3d0 <SUN18G cyl 7506 alt 2 hd 19 sec 248>

          /pci@1f,0/pci@1/pci@5/SUNW,isptwo@4/sd@3,0

Specify disk (enter its number): 0

selecting c1t0d0

[disk formatted]

Warning: Current Disk has mounted partitions.

FORMAT MENU:

        disk       - select a disk

        type       - select (define) a disk type

        partition  - select (define) a partition table

        current    - describe the current disk

        format     - format and analyze the disk

        repair     - repair a defective sector

        label      - write label to the disk

        analyze    - surface analysis

        defect     - defect list management

        backup     - search for backup labels

        verify     - read and display labels

        save       - save new disk/partition definitions

        inquiry    - show vendor, product and revision

        volname    - set 8-character volume name

        !<cmd>     - execute <cmd>, then return

        quit

format> quit

#

この情報から、[DISK]タグを次のように定義することが出来ます。

[DISK]

/dev/dsk/c1t0d0;;;

/dev/dsk/c2t8d0;;;

/dev/dsk/c2t9d0;;;

/dev/dsk/c3t2d0;;;

/dev/dsk/c3t3d0;;;

[/DISK]

HiRDB CMでは、ディスク情報をフルパスで管理するため、先頭に/dev/dsk/を追加した形式で記載します。

対象のシステムがRAIDを使用している構成の場合は、LU、LDEV、RAIDなどの情報をDISKタグの情報に追加してください。

③. パーテション情報を取得します。

パーテション情報は、vxdiskコマンドを使用して情報を取得します。

次のコマンドを実行します。

# vxdisk list

DEVICE       TYPE      DISK         GROUP        STATUS

c1t0d0s2     sliced    -            -            error

c1t0d0s6     simple    c1t0d0s6     rootdg       online

c2t8d0s2     sliced    -            -            online

c2t9d0s2     sliced    c3t9d0s2     vcs-dg04     online

c3t2d0s2     sliced    c2t2d0s2     cmdg01       online

c3t3d0s2     sliced    c3t3d0s2     cmdg01       online

DEVICE列に表示された名称が、パーテション情報になります。また、命名規則から後方のsx(xは整数)を削除した名称がパーテション元の物理ディスク名称になります。これらの情報から[PATH]タグを次のように定義することが出来ます。

[PART]

/dev/dsk/c1t0d0;/dev/dsk/c1t0d0s2

/dev/dsk/c1t0d0;/dev/dsk/c1t0d0s6

/dev/dsk/c2t8d0;/dev/dsk/c2t8d0s2

/dev/dsk/c2t9d0;/dev/dsk/c2t9d0s2

/dev/dsk/c3t2d0;/dev/dsk/c3t2d0s2

/dev/dsk/c3t3d0;/dev/dsk/c3t3d0s2

[/PART]

HiRDB CMでは、ディスク情報をフルパスで管理するため、先頭に/dev/dsk/を追加した形式で記載します。

④ LVMの情報を取得します。

  LVM情報は、使用しているLVMの管理ソフトに応じたコマンドを発行して取得します。

次のコマンドを実行し、ボリュームグループ名（VG）の一覧を取得します。（手順１）

# vxdisk list

DEVICE       TYPE      DISK         GROUP        STATUS

c1t0d0s2     sliced    -            -            error

c1t0d0s6     simple    c1t0d0s6     rootdg       online

c2t8d0s2     sliced    -            -            online

c2t9d0s2     sliced    c3t9d0s2     vcs-dg04     online

c3t2d0s2     sliced    c2t2d0s2     cmdg01       online

c3t3d0s2     sliced    c3t3d0s2     cmdg01       online

次のコマンドを実行し、論理ボリューム名を取得します。（手順２）

# vxprint -AsF '%vname'

Disk group: cmdg01

vhoge01

vhoge03

Disk group: vcs-dg04

vol01

vol_makiko

vol02

sysdeg01

sysdeg02

sysdeg03

setup01

sysdeg07

手順1,2から[VMINFO]タグの情報を次のように定義できます。下記の例では、cmdg01に対する情報を抜粋して示しています。

[VMINFO]

/dev/dsk/c2t9d0s2;/dev/vx/dsk/cmdg01;/dev/vx/dsk/vhoge01

/dev/dsk/c2t9d0s2;/dev/vx/dsk/cmdg01;/dev/vx/dsk/vhoge03

/dev/dsk/c3t3d0s2;/dev/vx/dsk/cmdg01;/dev/vx/dsk/vhoge01

/dev/dsk/c3t3d0s2;/dev/vx/dsk/cmdg01;/dev/vx/dsk/vhoge03

・・・

[/VMINFO]

HiRDB CMでは、全てのDiskパス名をフルパスで明記する必要があります。ディスク情報には、/dev/dsk/をボリュームグループ名、論理ボリューム名には、/dev/vx/dskを先頭に追加して記載してください。

⑤. FSの情報を取得します。

  FSの情報はdfコマンドにより取得することが出来ます。

次のコマンドを実行し、FS名の一覧を取得します。

# df

/                  (/dev/dsk/c1t0d0s0 ): 1224444 ブロック   311042 ファイル

/proc              (/proc             ):       0 ブロック     7897 ファイル

/etc/mnttab        (mnttab            ):       0 ブロック        0 ファイル

/dev/fd            (fd                ):       0 ブロック        0 ファイル

/var/run           (swap              ): 1295440 ブロック    47226 ファイル

/tmp               (swap              ): 1295440 ブロック    47226 ファイル

/export/home       (/dev/dsk/c1t0d0s7 ): 4611156 ブロック  1675018 ファイル

/sync/cmu1(/dev/vx/dsk/cmdg01/vhoge01): 1323466 ブロック   507891 ファイル

/sync/cmu2(/dev/vx/dsk/cmdg01/vhoge03): 1323466 ブロック   507891 ファイル

この結果から、[FS]タグの情報次のように定義できます。

[FS]

/dev/dsk/c1t0d0s0;/

/dev/dsk/c1t0d0s7;/export/home

/dev/vx/dsk/cmdg01/vhoge01;/sync/cmu1

/dev/vx/dsk/cmdg01/vhoge03;/sync/cmu2

[/FS]


Windowsでのデバイス情報ファイル作成例

  ここでは、Windwosでのデバイス情報ファイルの作成方法について説明します。ここで紹介する方法は、標準的なコマンドを使用した方法であり、デバイスの構成によっては、ここで紹介する以外のコマンドを使用する必要がある場合があります。

  Windowsでは、[DISK]タグと[FS]タグの情報を定義する必要があります。次の手順でデバイス情報ファイルを作成します。

①. デバイス情報ファイルを作成します。

HiRDB CM Agentをインストールした段階で、次に示すデバイス情報ファイルの雛形が作成されます。

{HiRDBインストールディレクトリ}\CMAgent\util\cmadevinfo_format

このファイルをコピーして、次の名前に名前を変更します。

{HiRDBインストールディレクトリ}\CMAgent\util\cmadevinfo

②. DISK情報を設定します。

Windwosの[コントロールパネル]→[管理ツール]→[コンピュータの管理]をクリックし、コンピュータの管理画面を表示します。コンピュータの管理画面で、[ディスクの管理]画面をクリックし、デバイス情報を表示します。

コンピュータの管理画面で、一つのDiskが表示されている場合、[DISK]タグを次のように記入します。

[DISK]

disk0;;;

[/DISK]

  もし、ディスクが複数表示された場合は、次のように記載ます。

[DISK]

disk0;;;

disk1;;;

[/DISK]

コンピュータの管理画面でdisk0上にc:e:f:g:ドライブが表示されている場合、[FS]タグを次のように記入します。

[FS]

disk0;c:

disk0;e:

disk0;f:

disk0;g:

[/FS]